EnOcean Link: EnOcean Link Manual

EnOcean Link 1.7.0.0
Middleware to Connect USB300 easily to other Projects
  • Main Page
  • Related Pages
  • Modules
  • Classes
  • Files
  • Examples
EnOcean Link Manual

Table of Contents

  • Introduction
  • Used Libraries
  • Defines
    • Follow Up

Introduction

EnOcean Link is a powerful library to handle packets, telegrams and messages received in an ESP3 Format.

Using EnOcean Link you can write your own Application in a few easy steps, and uses it function to handle for you the most common EnOcean Tasks.

The following features are included:

  • EnOcean Equipment Profile 2.6.3 and Generic Profiles data handling
  • Set and Get Values as float or integer (depending on the datatype). See eoProfile::SetValue and eoProfile::GetValue
  • Handling the Teach-IN process for you. See eoTeachInModule and eoGateway.
  • Security Teach-IN and decryption (eoSecurity and eoGateway)
  • Sending and receiving of telegrams
  • Storing and loading of configurations in an human readable version
  • Message chaining
  • Remote management
  • Serial commands interface with eoSerialCommand
  • Different software filter, to filter telegrams
  • You can implement your own Filter, using the eoIFilter class
Note:
In the following document about EnOcean Link, it is assumed that you've a basic concept about EEP2.6.3, ESP3, GP and EnOcean world itself.

The current release contains a eoPacketStream reader for Linux (eoLinuxPacketStream) and Windows (eoWin32PacketStream).

All examples & tutorials have been tested on a Linux x86 PC.

To start use the Step by Step Guide

Used Libraries

EnOcean Link uses the following libraries for the Linux based Implementation

  • std::map
  • std::vector
  • std::list
  • std::string
  • std::set
  • std::iostream
  • <time.h>
  • ctime
  • <termios.h>
  • <fcntl.h>
  • <stdint.h>
  • <math.h>

If you want to integrate EnOcean Link to other platforms/os system you've to create your own PacketStream class to handle receive/sendByte and your own Timer Class.

Defines

  • Gateway : eoGateway
  • Packet: eoPacket
  • Message : eoMessage
  • Telegram : eoTelegram

Follow Up

  • Step by Step
  • Tutorials
  • Compile
  • References
  • Testing EnOcean Link
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Compile

  • Related Pages
  • Modules
  • Classes
  • Files
  • Examples
Compile

Compile for ARM

To compile for ARM platform we created a build Target in eclipse. Using GNU ARM Eclipse plugin and an arm Toolchain. To integrate the plugin to eclipse follow the How To.

We prepared an example target for the ARMCortex(M3)(linux Library using Linaro Toolchain) and the Rasperry Pi(Linaro Toolchain)

Note:
Important to crosscompile to linux you need the arm-linux-gnueabihf- toolchain! and not arm-none-eabi.

For the make files, the example script ./pi.sh exist. If you use a different target platform please edit the ARM_ Variables.

#!/bin/bash
ARM_TOOLCHAIN_PATH=/opt/pitools/arm-bcm2708/arm-bcm2708hardfp-linux-gnueabi/bin/
ARM_TOOLCHAIN=arm-bcm2708hardfp-linux-gnueabi
ARM_CPPFLAGS=-Ofast -mfpu=vfp -mfloat-abi=hard -march=armv6zk -mtune=arm1176jzf-s
PATH=$PATH:$ARM_TOOLCHAIN_PATH
mkdir RaspBerryPi
cd RaspBerryPi/
../configure --host=$ARM_TOOLCHAIN --enable-platform=POSIX CPPFLAGS="$ARM_CPPFLAGS"
if [[ "$?" -eq "0" ]]; then
echo "Starting Make process"
else
echo "Configure failed!"
exit $?
fi
make clean
make
if [[ "$?" -eq "0" ]]; then
echo "Copying static Library for examples/Tutorials"
else
exit $?
fi
cp .libs/libEOLink.a ./libEOLink.a

M3 Settings

GnuChain Settings 1
GnuChain Settings 2

PI Settings

GnuChain Settings 1
GnuChain Settings 2

Compile for Raspberry Pi

If you have an Raspberry Pi and an EnOcean extension board or an EDK 350. then you can also use EnOcean Link with Raspberry Pi. You can either easily connect to the Raspberry Pi extension pins the EnOcean extension board or insert the USB 300(C/U)/ USB 400J EnOcean stick which is included in EDK 350. The letters (C/U/J) express different frequencies but the functions are same. Either way you will connect an EnOcean Module with identical Firmware (Gateway Controller) which provides an transparent UART interface for the radio.

Raspberry Pi with extension board
Raspberry Pi with EnOcean USB Stick

To run EnOcean Link on Raspberry Pi you can download the EnOcean Link source code and compile it directly on Raspberry Pi or compile it on an PC an deploy it. Of course you have to cross compile then. You can refer to the section Compile for ARM or use one of the many manuals available on the web e.g. http://hertaville.com/2012/09/28/development-environment-raspberry-pi-cross-compiler/. Then simply copy the resource or use remote deployment, also described in the previous link. For the start you can either play with Hello World or one of the tutorials.

For your convenience, here a summary of the steps:

  1. Set up your Raspberry Pi - http://www.raspberrypi.org/quick-start-guide

  2. Download EnOcean Link and set up Step by Step.

    Here you have to consider to specify the right serial port of your gateway connected to your Raspberry Pi. If you use USB300 as gateway then you can refer to steps in the step by step guide. If you use the EnOcean extension board or other gateways please adjust the defines - e.g change the writing permissions of the device. For example:

    sudo chmod 777 /dev/ttyAMA0

    Then you use this define:

    #define SER_PORT "/dev/ttyAMA0"
  3. Cross compile EnOcean Link for Raspberry Pi. Compile for ARM or http://hertaville.com/2012/09/28/development-environment-raspberry-pi-cross-compiler/
  4. Deploy the binaries. http://hertaville.com/2012/09/28/development-environment-raspberry-pi-cross-compiler/ or copy.
  5. When needed set the access rights of your gateway connected to your Raspberry Pi - e.g.
    sudo chmod 777 /dev/ttyAMA0
  6. Run it. Please rember to follow the licensing of EnOcean Link . Enjoy.

Makefile

Note:
The makefile system has been changed after the 1.3.0.0 Release

To compile the library the GNU autoconf,GNU automake and GNU libtoolhave been selected. For your convince a ./configure script with the necessary files has been already created. If you want to modify the script the necessary GNU files are available.

The configure script allows an easy usage to cross compile or change settings.

example:

mkdir myCortexLibrary
cd myCortexLibrary
../configure --host=arm-none-linux-gnueab --enable-platform=POSIX CPPFLAGS="-mcpu=cortex-a8 -O3"
make
ls .libs/
  • First you create the build folder and change into it.
  • Afterwards you call the configure script and pass the name of the Toolchain and the CPPFLAGS.
  • Then you call make and the in folder .libs/ shared&static libraries are generated.

2 Example (pi.sh and ReleaseLib.sh) are available to show the possibilities for generating the library.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Changelog

  • Files
  • Examples
Changelog

EnOcean Link v1.7.0.0 MAINTENANCE (19. November 2015)

Notes:

  • Seventh MAINTENANCE release

Supported Profiles:

  • EEP 2.6.4 - Status 01. November 2015
  • Generic Profiles - (only full Version, not in Trial)

Changes:

  • Added additional tests are for the testframework.
  • Added new EnOcean Equipment Profiles A5-06-04,A5-10-22,A5-10-23,A5-11-05,D2-06-xx,D2-01-0C,D2-50-xx.
    • Added the serialization for the teachin module.
    • Fixed an crash when loading a save file, which contained an invalid profile. The invalid profile number is ignored.
    • Fixed an error for 4BS profiles messages, for some profiles the rorg was set wrong in the message.
    • Fixed an error inside the eoStorageManager. Not more then 16 entries for devices/watches/gpChannels could be stored.
    • Fixed an error for Storing Generic Profile Channels, the gpProfiles are now loaded and stored correctly.
    • Fixed an error in A5-30-xx profile, the F_OPEN_CLOSED channel was used as floating value and not as integer.
    • Fixed an error in the A5-04-02 profile, it was not available anymore
    • Fixed an error for the A5-06-xx profiles with Luminance over the max value, the error bit is now set correctly for the message.
    • Fixed an error for the SetRawValue, size 0 for raw value is not anymore a valid size.
    • Fixed an error for the SetRawValue, if the range did not start from 0, there was an offset error.
    • Fixed an error for the D2-03-xx profiles, the type was not handled arcodingly to the EEP
    • Fixed an error for the A5-20-xx profile, the eoEEP_A520xx::SetDirection(HVCA_DIRECTION direction) mappped the HVAC_DIRECTION the wrong way.
    • Fixed an error for the parsing of chained messages out of order. If CDM arrive out of order, they are parsed correctly now.
    • Fixed the header guard for 2 profiles had a type.
    • Optimization: EnoceanLink Library Source Code is now c++99 conform, removed last commas in the enumeration list.
    • Optimization: A few checks inside the source code and a few calls did not have any impact, these were removed.

EnOcean Link v1.6.0.0 MAINTENANCE (02. June 2015)

Notes:

  • Sixth MAINTENANCE release

Supported Profiles:

  • EEP 2.6.3 - Status 02. June 2015
  • Generic Profiles - (only full Version, not in Trial)

Changes:

  • Test Framework has been added to the full Version. Customer can perform automated tests.
  • New EnOcean Equipment Profiles A5-09-0A,A5-09-0B,A5-12-10,a5-30-05,D2-40-xx,D2-32-xx,D2-01-xx have been added.
  • Introduced eoISimpleBidirectionalProfile for BiDirectional Profiles which do not identify the direction or the command via special field. In parsing process the structure for the actual telegram is selected automatically (Inbound or Outbound).
  • eoGateway does not overwrite the last received packet after sending an own Packet/Telegram.
  • IsPacketPending() function in eoPacketStream
  • Various minor performance and bug fixes

EnOcean Link v1.5.0.0 MAINTENANCE (27. October 2014)

Notes:

  • Fifth MAINTENANCE release

Supported Profiles:

  • EEP 2.6.2 - Status 25. October 2014
  • Generic Profiles - (only full Version, not in Trial)

Changes:

  • Added Remote Commissioning Support Class.
  • Added profile (A5-20-04, A5-09-09, D2-10-xx, D2-05-00)
  • Added support for selective repeating
  • General optimization & various minor performance and bug fixes
  • Added extended example for VLD telegrams
  • Various minor performance and bug fixes

EnOcean Link v1.4.0.0 MAINTENANCE (09. May 2014)

Notes:

  • Fourth MAINTENANCE release

Supported Profiles:

  • EEP 2.6 - Status 17. December 2013
  • Generic Profiles - (only full Version, not in Trial)

Changes:

  • Added various profiles (A5-04-03, A5-12-04, A5-12-05, A5-05-01,D2-05-xx)
  • Eclipse Project: Changed Build target for ARM to use the gnuarmeclipse plugin and allow different toolchains.
  • Make Files: removed general make files and changed to the GNU autoconf/automake toolchain
  • Make Files: added the configure script and 2 simple example bash scripts to "auto compile"
  • Windows Support has been added, eoWin32PacketStream and eoTimer have modifications for Windows
  • #ifdef WIN32 or #ifdef POSIX is used for Windows32 or POSIX compatible operating systems
  • Added eoWatcher and eoIWatcher class to check for robust and secure Enocean Networks
  • Various minor performance and bug fixes

EnOcean Link v1.3.0.0 MAINTENANCE (13. December 2013)

Notes:

  • Third MAINTENANCE release

Supported Profiles:

  • EEP 2.5 - Status 30. November 2013
  • Generic Profiles - (only full Version, not in Trial)

Changes:

  • Added various profiles (D2-04-XX,D2-01-0a ,F6-02-04 ,F6-04-02 ,F6-10-01,D2-A0-01,A5-30-04,A5-30-03,A5-09-08,F6-05-01)
  • Added PSK Security Feature
  • Improved stability of eoMessage Classes
  • Optimized and fixed various bugs in the GPChainer, TeachInChainer and RemoteChainer class
  • Profile errors fixed in A5-09-XX, and A5-13-XX
  • Added support functions for Subtypes support
  • Updated manufacturer list
  • Added Advanced Protocol sending

Planned features for further releases:

  • Adding Profiles

EnOcean Link v1.2.0.0 MAINTENANCE (20. August 2013)

Notes:

  • Second MAINTENANCE release

Supported Profiles:

  • EEP 2.5 - Status 30. April 2013
  • Generic Profiles - (only full Version, not in Trial)

Changes:

  • Added Generic Profiles bidirectional support

Planned features for further releases:

  • Adding Profiles

EnOcean Link v1.1.0.0 MAINTENANCE (30. April 2013)

Notes:

  • First MAINTENANCE release
  • Quality assurance finished

Supported Profiles:

  • EEP 2.5 - Status 30. April 2013
  • Generic Profiles

Changes:

  • Added MSC telegram support
  • Added support for Advanced Protocol
  • eoLogger.h moved to Includes folder
  • OK and ERROR renamed to EO_OK and EO_ERROR respectively
  • Resolved casting warnings
  • Corrected EEP profiles:
    • F6-02-xx
    • F6-03-xx
    • A5-38-xx
    • A5-06-xx
    • D2-01-xx
  • Added EEP profiles:
    • D2-20-xx
  • Updated to AES128 algorithm which is using the BSD license
  • Using localtime_r() instead of localtime() in eoLogger

Planned features for further releases:

  • Adding Generic Profiles bidirectional support (after approving by Alliance)
  • Adding Profiles

EnOcean Link v1.0.0.0 FINAL (25. January 2013)

Notes:

  • First FINAL release
  • Quality assurance finished
  • All classes has been tested
    • Smart Acknowledge
    • Remote Management
    • Security

Serial communication Supported Teach Processes:

  • EEP
    • RPS Learn
    • 1BS Learn
    • 4BS Learn - 1. 2. and 3. variant
  • UTE Learn
  • Smart Acknowledge Learn
  • Generic Profiles Learn
  • Security Learn

Supported Chaining:

  • Remote Mamagement Chaining
  • Generic Profiles Chaning
  • Security Teach In Chaining
  • General Chaining

Supported Profiles:

  • EEP 2.5 - Status 25.January 2013 (implementation without D2-20-xx)
  • Generic Profiles

Planned features for further releases:

  • One device having more possible profiles set
  • VLD Family profiles e.g. D2-01-xx listening the right channels during teach in
  • Adding Generic Profiles bidirectional support (after approving by Alliance)
  • Adding Profiles

EnOcean Link v1.0.0.0 FINAL-BASIC (25. January 2013)

Test release restrictions - All features like final besides:

  • Only selected profiles
    • F6-02-XX, F6-03-XX, F6-04-XX, F6-10-XX
    • D5-00-XX
    • A5-02-XX, A5-04-XX, A5-06-XX, A5-07-XX, A5-10-XX, A5-12-XX
  • No remote management support
  • No security support

EnOcean Link v0.9.0.0 BETA (7. December 2012)

Notes:

  • BETA release
  • Quality assurance not finished
  • Not all classes has been tested

Changes and features:

  • Added EnOcean security implementation - eoSecurity
  • Added security rolling code storage - eoRollingCodeStorage
  • Added ESP3 commands support - eoSerialCommand
  • Added RemoteManagement support - eoRemoteManager
  • Added message chaining support for Generic Profiles
  • Added message chaining support for Remote Management
  • Added message chaining support for Secure Teach-In
  • Queing serial telegram receiving and getting response telegrams
  • Updated Teach-In implementation
  • Added support for multiple profiles channels of the same type e.g. multiple temperatures
  • Added Generic Profiles support - eoGenericProfile
  • Update Profiles class structure
  • Added manufacturer list
  • Fixed several memory leaks
  • Code cleaned up
  • Using the standard <stdint.h> definitions instead of custom ones e.g. using uint8_t instead of uint8
  • Updated documentation
  • Added new EnOcean Equipment Profiles EEP2.1 and EEP2.5
    • 32-02-xx
    • A5-06-xx
    • A5-07-03
    • A5-09-xx
    • A5-10-1F
    • A5-11-xx
    • A5-13-xx
    • A5-14-xx
    • A5-20-xx
    • A5-30-xx
    • A5-37-xx
    • A5-38-xx
    • D2-00-xx
    • D2-01-xx
    • D2-02-xx
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: References

References

Referenced EnOcean Specification Documents:

  • ESP3 - EnOcean Serial Protocol 3
  • EEP2.6.3 - EnOcean Equipment Protocol
  • GP1.0 - Generic Profiles

Usefull Links for developers:

  • Knowledge Base find here all developer documentation and specifications e.g. Radio Protocol
  • GatewayController Firmware User manual - TCM 310
  • GatewayController Firmware User manual - USB 300
  • Software Product page
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Step by Step

Step by Step

Introduction

We recommend that you use an Ubuntu-Linux PC,Eclipse and an USB300 Stick for your first Testing Applications or a Windows PC with Eclipse or Visual Studio.

This Step by Step Guide will help you to get your first project to compile with eclipse:

  • Install Eclipse for Ubuntu or download for Windows
  • Modify UDEV to detect USB sticks as USB300 (can be skipped)
  • Starting up Eclipse and set up your Project
  • Compile and Start the Hello World
Note:
This should also work with every other Linux Distribution, but the steps for installing Eclipse & Co will be different.
This guide does not expect that you've a deep knowledge about using Ubuntu.

If you want to know more about Ubunut Linux and the Usage please refer to https://help.ubuntu.com/

Installing Eclipse

Open a console with the key combination ALT+SHIFT+T and enter the following line:

sudo apt-get install gcc g++ eclipse-cdt

This will download&install Eclipse,gcc and g++ for the developing of eoLink on Linux Systems.

If you want to develop under Windows with eclipse, please download eclipse cdt https://eclipse.org/cdt/ and mingw-gcc http://www.mingw.org/

Note:
You can also Visual Studio 2013 https://www.visualstudio.com/ or newer, and use the included solution file.

Adding UDEV Rules for the USB300 Stick (Skip for Windows)

The following steps will generate always a device /dev/USB300 when you plug a USB300 into the PC.

Open a console with the keys ALT+SHIFT+T and enter the following lines:

sudo sh -c 'echo SUBSYSTEMS==\"usb\", KERNEL==\"ttyUSB?\", ATTRS{interface}==\"EnOcean USB300 ??\",MODE=\"0666\", SYMLINK+=\"USB300\" > /etc/udev/rules.d/70-enocean-stick.rules'

You will asked for your password, enter it afterwards.

Now Restart udev with the following command:

sudo /etc/init.d/udev restart

You can plug now your USB300 into the PC and a new device /dev/USB300 should have been created.

Note:
Alternativelly you can access the USB directly, for this change the writing permisions of the USB Device. For example:
sudo chmod 777 /dev/ttyUSB0
Then you use this define:
#define SER_PORT "/dev/ttyUSB0"
.

Start up Eclipse and setting up the Project

Start Up Eclipse, using the Eclipse button of the dashboard.

Select the folder where you want to have your workspace

After starting up Eclipse use the File->Import Option of the Menu, to import the zip File.

Follow the assistant, and choose as archive File the eoLink.zip File.

Press Finish and you've the eoLink eclipse Project in You workspace.

If you want to learn more about Eclipse-CDT please refer to http://www.eclipse.org/cdt/documentation.php

Hello World

Getting to the Project

After Importing the Projects, we can now start by Building the HelloWorld.cpp Example.

If you've still the Welcome Screen open, press "switch to Workspace".

If the open view is not the C/C++ view switch to the view by pressing the Button and Say open C/C++ Perspective.

First, you have to build EOLink to the ReleaseLib target.

Note:
For Windows the target is named ReleaseWindows.

After building EOLink, you've to select the Tutorial Project, and then select the HelloWorld Target.

Now you can open the HelloWorld.cpp, which implements a eoLink Receiver using the USB300, or you can test the application by pressing the run button(green arrow).

Hello World - the Code.

The first few lines set the serial Port to the rigth device.

The eoLink Header is included from the EOLink project, which contains the SourceCode of eoLink.

#define SER_PORT "/dev/USB300"
#include "./eoLink.h"
#include <stdio.h>
Note:
for Windows the SER_PORT has a name like "\\\.\\COM35". Using Dolphin View you can look up the COM PORT you need to use.

In the main function we first define an eoGateway and try to open a connection to our device

//First a Gateway will be defined
eoGateway myGateway;
//This tries to open an connection to the USB300 or fails otherwise
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=OK)
{
printf("Failed to open USB300\n");
return 0;
}
printf("Hello to the world of eoLink\n");

Now we can use an eoCommonCommand command to read the version and the application of the connected enoceanGateway Device

if(myGateway.commands.ReadVersion(version)==OK)
printf("%s %i.%i.%i.%i, ID:0x%08lX on %s\n",
version.appDescription,
version.appVersion[0], version.appVersion[1], version.appVersion[2], version.appVersion[3],
version.chipID,
SER_PORT);

We use a variable recv to parse the RECEIVE_FLAGS from eoGateway::Receive(). We put the receive functionallity in an endless loop and if we've received a telegram, we print it out.

uint16_t recv;
while(1)
{
recv = myGateway.Receive();
if (recv & RECV_TELEGRAM)
eoDebug::Print(myGateway.telegram);
}

Pressing the Hammer you can compile the target, pressing the green arrow you can run the Target.

Follow Up

Now you can continue with the Tutorials or you can read up about eoGateway and how to use it.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Testing EnOcean Link

Testing EnOcean Link

Testing

For testing the different modules of EnOcean Link, the gTest - xUnit test framework is used. For your convince the whole test framework is added and can be rerun and extended if you add or modify any parts of EnOcean Link.

Compile the test suite

For your convenience an Eclipse Project exist for the test framework and pre compiled libraries for x86 Linux and Windows Systems.

The targets Debug and Release are for the Linux System. You need to compile the Library before compiling the test.

Executing the test suite

The binary of the testsuite can be executed as standalone executable without any arguments. The –help argument listens the supported features from the Google Testframework.

For example you can use:

test –gtest_list_tests

to list all tests and then

test –gtest_filter=GenericProfile*

to run all GenericProfile Tests.

Introduction to the test code

Each functionality and profile family has in the test framework an own test file. The google test framework is used for the integration and more details of the usage of the framework can be found in the Google Test documentation.

The following example shows how the Constructor of the eoDevice could be tested.

//We declare a test in the groud of eoDevice and this test is the DeviceCreation tests.
TEST(eoDevice, DeviceCreation)
{
eoDevice myDev = eoDevice(0x11324242);
//If EXPECT_XX is not true, the test continues
//If ASSERT_XX is false, the test stops
EXPECT_EQ(myDev.ID,0x11324242);
}

For a more complicated test an own helper test fixture/class can be created with helper functions and can be used:

class ProfileFixture: public testing::Test
{
protected:
void Init(uint8_t rorg,uint8_t func,uint8_t type);
}

A test based on this fixture can be used with the following macro

//Use the ProfileFixture and declare the test eepA50201
TEST_F(ProfileFixture,eepA50201)
{
//Init the Profile via a simulated Teach IN message
Init(0xA5,02,01);
//check if the Channel exists basic value test
CheckChannel(S_TEMP);
float getValue;
uint8_t data0[4] = {0x00,0x00,0x00,0x08};
memcpy(msg->data, data0, 4 );
myProf->Parse(*msg);
myProf->GetValue(S_TEMP,getValue);
//To check a floating value.
EXPECT_NEAR(0.0000,getValue,0.5);
}

How to write a test code for your own profile.

If you implement your own profile or extend/modify an existing profile, the following tests are recommended.

  • Write tests for each profile-type
  • Write a test for receiving functionality
  • Write a test for sending functionality
  • Test for each channel existence.
  • For channels using a floating point unit channel type, write a test for the min,max and medium value.
  • For channels using enums or integer type, check if possible each value or at least the min and maximum value.
  • If channel definitions or values are dependent from each others (e.g. the profile contains a flag which indicates the type of a different channel), check if these flags are parsed right and modify the logic of the profile.
  • Use a coverage tool, e.g. gcov to see if your profile is completely tested.

References

Referenced Documents:

  • gTest - Google Test
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Trial License Agreement

Trial License Agreement

Please consider that this is the Trail License of EnOcean Link. The usage and features are limited. You accepted the License Agreement by downloading this package. Please see License agreement here:

[INSTALATION PATH]\EOLink\LICENSE

Test release restrictions - All features like final besides:

  • Only selected profiles
    • F6-02-XX, F6-03-XX, F6-04-XX, F6-10-XX
    • D5-00-XX
    • A5-02-XX, A5-04-XX, A5-06-XX, A5-07-XX, A5-10-XX, A5-12-XX
  • No remote management support
  • No security support
  • No Generic Profiles support

Main purpouse of Trail Package is to show the dependencies and constrains of EnOcean Link. You can also build any kind of demonstrator which will provide you deep understanding how EnOcean Link works. The interfaces are same as on the full version.

The current Licensee Agreement for the Trial License is as following:

License Terms EnOcean Link Trial Version

THIS SOFTWARE PRODUCT OFFERED FOR DOWNLOAD INCLUDING SOURCE CODE AND PERTAINING DOCUMENTATION EMBODIED THEREIN ("LICENSED SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING, GERMANY ("ENOCEAN") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE, DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN ENOCEAN. ANY USE OF THE LICENSED SOFTWARE BY THE PERSON OR ORGANIZATION WHICH DOWNLOADED THE LICENSED SOFTWARE ("YOU" OR "USER" OR LICENSEE" AS THE CASE MAY BE) SHALL BE SUBJECT TO THE FOLLOWING LICENSE TERMS AND BY DOWNLOADING AND/OR USING THE LICENSED SOFTWARE YOU ACKNOWLEDGE TO BE BOUND BY THESE TERMS:

  1. License Grant 1.1 EnOcean hereby grants to Licensee a non-exclusive, non-transferable license to use the Licensed Software for Licensee’s internal demonstration, testing and evaluation purposes in connection with Licensee's system which shall be used for testing and evaluating the Licensed Software ("Reference Environment"). 1.2 The use of the Licensed Software shall be exclusively limited for demonstrating, testing and evaluating the Licensed Software and shall within such scope include the right to modify the Licensed Software and/or the source code, provided, however, that Licensee shall not be entitled (i) to use or integrate the Licensed Software and/or resulting modifications in its products or (ii) to sub-license, reproduce or distribute the Licensed Software. Licensee shall not decompile or reverse-engineer the Licensed Software or any parts thereof. 1.3 The Licensed Software may contain freeware, shareware or open source software. No license fee is charged to Licensee for the use of such freeware, shareware or open source software. Regarding such portions of Licensed Software, the Licensee hereby accepts the specific license conditions ("Open Source Conditions"). To the extent there is a conflict between these Terms and the Open Source Conditions, the terms of the Open Source Conditions shall prevail over the terms and conditions of these Terms with regard to the open source software.
  1. Copyright, Trademarks, Title 2.1 All rights, title and interest in and to the Licensed Software (and any part thereof) other than the rights to use expressly granted in Clause 2, shall remain wholly vested in EnOcean or its third party licensors. Licensee acknowledges that it has no rights whatsoever in respect of the Licensed Software save for the rights to use expressly granted in Clause 1. 2.2 Any and all rights, title and interest in any derivative works created by or any other intellectual property right arising in connection with Licensee modifying the Licensed Software, including trade secrets and know-how shall be exclusively owned by EnOcean and EnOcean shall be entitled to seek or apply for statutory protection in its sole discretion.
  1. Exclusion of Warranty Licensee acknowledges and agrees that EnOcean provides no warranties and shall have no liability towards Licensee whatsoever in respect of Licensee's possession and/or use of the Licensed Software, including freeware, shareware or open source software. In particular, Licensee acknowledges and accepts that the Licensed Software, including source code and documentation may not be error free.
  1. Limitation of Liability 4.1 EnOcean shall be liable for damages only to the extent proximately caused by EnOcean's negligence or willful acts or omissions, except where such liability is mandatory under applicable law. 4.2 EnOcean shall in no event be liable to nor indemnify Licensee for loss of contracts, loss of business, loss of data (including but not limited to any and all costs for retrieving and restoring lost data), loss of interest, for lost profits or business interruption or any indirect or consequential damages, irrespective of the cause of action or the legal theory upon which such claim is based. 4.3 The limitation of liability set forth in this Clause 4 shall not apply in case of personal injury and death, fraud and intentional acts or omissions.
  1. Intellectual Property Infringement If any claim, suit, action or proceeding is brought against Licensee by a third party to the extent it is based on any infringement of intellectual property rights, such as but not limited to patents utility models, design patents, copyrights or mask work rights owned by third parties, by the use of the Licensed Software explicitly authorized under these Terms ("Claims"), and if, as a result of such a Claim, Licensee becomes enjoined or it is likely, in EnOcean' opinion, that Licensee will become enjoined from using the Licensed Software, Licensee shall immediately stop using the Licensed Software.
  1. Term and Termination 6.1 These Terms and the license granted in Clause 1 shall take effect upon the first download and shall terminate 24 months thereafter. 6.2 The license granted in Clause 1 may be terminated by EnOcean at any time upon written notice with a notice period of two weeks.
  1. Export Regulations 7.1 Licensee shall comply with all export laws applicable to the Licensed Software and/or the Software Documentation in effect from time to time. Without limiting the generality of the foregoing, Licensee expressly warrants that it will not directly or indirectly export, re-export, or transship the Licensed Software in violation of any applicable export laws, rules or regulations.
  1. Miscellaneous 8.1 Venue (Gerichtsstand) for any and all disputes arising out of or in connection with these Terms and its consummation shall be the high court Munich I (Landgericht München I) and each Party submits to the exclusive jurisdiction of said court and agrees that venue shall lie exclusively with such court to the extent legally permissible. 8.2 These Terms shall be construed in accordance with and governed by the laws of the Federal Republic of Germany without regard to its conflict of laws principles. 8.3 Unless otherwise explicitly set forth in these Terms, no delay or omission of the Parties in exercising any right, power, or privilege under these Terms shall impair or shall be construed as a waiver of any such right, power or privilege, nor shall any partial exercise of such right, power or privilege preclude any further exercise of such right, power or privilege or the exercise of any other right, power or privilege. 8.4 The partial or entire invalidity, illegality or unenforceability of any provision of these Terms shall not affect the validity, legality or enforceability of the remaining part or any other provision. The invalid or unenforceable provision shall be replaced by a provision which, in so far as it is legally permissible, reflects the actual intentions of the Parties as closely as possible or, considering the meaning and purpose of the Agreement or of the invalid or unenforceable provision, the presumptive intentions of the Parties had they considered the point at the time of concluding these Terms. The foregoing shall also apply to the extent that these Terms do not completely regulate any question that may arise with respect to its subject matter or otherwise contains any gap (Regelungslücke).
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Tutorials

Tutorials
  • Tutorial 1 - eoDebugGateway Software for LinuxConsoles
  • Tutorial 2 - eoGateway Software, which checks Temperature and sends a warning Messages!
  • Tutorial 3 - eoGatewaySoftware, which receives the Temperature from one Device/Profile and converts it to another.
  • Tutorial 4 - eoGatewaySoftware, minimalistic example for manual Teach IN and Teach Out.
  • Tutorial 5 - example for Serial Commands.
  • Tutorial 6 - example casting eep temperatures to generic profile temperatures
  • Security Watcher Example - example Security Watcher
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Tutorial 1

  • Tutorials
Tutorial 1

The Source Code of this Tutorial can be found here: tutorial1.cpp

This Tutorial will help you to understand the base concept of an eoGateway,eoStorageManager and the concept of Filter eoIDFilter,eodBmFilter.

After starting up the example, it will a be definied Time in learnMode for near field Devices. These learned in Devices and their configuration will be stored using the eoStorageManager. To start developing an eoLink application you've either to include the SourceCode or a preCompiled library to your linker, and include the "eoLink.h" file.

#include "./eoLink.h"

In our example we use some defines, to change the LearnTime,the config FileName and the device to use.

#define SER_PORT "/dev/ttyUSB1"// the Serial Port Device
#define SAVE_CONFIG "./learned.txt" // where to store the gateway Configuration
#define LEARN_TIME_S 10 // allows you to set the time the gateway should stay in learnmode
Note:
The following code parts can be either all in the main function, or an own function which returns an integer.

To receive Telegrams we need an eoGateway and connect it via eoGateway::Open to an EnOcean Gateway Device like the USB300.

eoGateway = myGateway;
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=OK)
{
printf("Failed to open USB300\n");
return 0;
}

If the connection is stable, we could now start to receive Telegrams, but we want only to receive Telegrams which are in the near Field range. To archieve this we add to our Gateway Class an eodBmFilter.

eodBmFilter * learnFilter = new eodBmFilter();
myGateway.learnFilter = learnFilter;
learnFilter->maxdBm=-0;
learnFilter->mindBm=-60;

As we want to see in the Normal Mode only Telegrams from learned IN devices, we've to add an eoIDFilter.

eoIDFilter * myFilter = new eoIDFilter();
myGateway.filter=myFilter;

Now we're nearly ready to receive and handle the Packets but to do so we need an uint16_t variable to handle the ReturnFlags of the eoGateway::Receive Function.

uint16_t recv;

And as we want to stay only a short time, after the startup, in learnMode we've to add some variables which check the passed Time.We're gonna use Time::getTickCount(), which increases every 10ms the Tick amount.

uint32_t learnTime=Timer::getTickCount()+LEARN_TIME_S*100;
uint32_t time=Timer::getTickCount();

In this case we say we want to TeachIN devices which either send a 4BS TeachIN telegram, or if we get a RPS telegram, that we TeachIN a 4Button Rocker.

As the RPS Profiles don't have a TeachIN message we've to set the profile manually.

myGateway.TeachInModule->SetRPS(0x02,0x01);

Now we only have to change from the normal gateway mode to the learnMode.

Note:
to activate learnMode just change the eoGateway::LearnMode to true, to deactivate it again change it to false
//Activate LearnMode
myGateway.LearnMode=true;
Now we've prepared everything we need to get to Receive Messages and handle TeachIN Telegrams.
while(learnTime>time)
{
//updates the time, using the HAL getTickCount function
time=eoTimer::getTickCount();
//the Gateway::Receive() Functions returns different flags, depending on the Packet we got
recv = myGateway.Receive();
//as we're in LearnMode currently we only want to process Teach_IN Telegrams(as specified in EEP)
if (recv & RECV_TEACHIN)
{
//add the Source ID to the Normale Mode Filter
myFilter->Add(myGateway.telegram.sourceID);
//Print out the Message to stdout
eoDebug::Print(myGateway.telegram);
//If the TeachIN process was successfull and we got a Profile print out the Message!
eoProfile *profile = myGateway.device->GetProfile();
if(profile!=NULL)
{
printf("Device %08lX Learned-In EEP: %02X-%02X-%02X\n", myGateway.device->ID, profile->rorg, profile->func, profile->type );
for (int i = 0; i<profile->GetChannelCount(); i++)
{
printf("%s %.2f ... %.2f %s\n", profile->GetChannel(i)->ToString(NAME), profile->GetChannel(i)->min, profile->GetChannel(i)->max, profile->GetChannel(i)->ToString(UNIT));
}
}
}
}
When we leave this function, we want to switch to normal mode and store the current configuration of the Gateway and all learned in devices!

To store an Object, which has the ISerialize interface implemented, you use the eoStorageManager and add Objects to handle to the Manager.

myGateway.LearnMode=false;
eoStorageManager myStore;
myStore.addObject("Gateway",&myGateway);//the name has to be unique!
myStore.Save(SAVE_CONFIG);

Now you've a text file, containing all the learned-in devices, which you can use for other applications.

This example application now just shows the incoming data of TeachIN devices, and if the profile is Supported, the Values are printed in clear Text.

while (1)
{
recv = myGateway.Receive();
if (recv & RECV_MESSAGE)
{
//Resend received telegrams
myGateway.Send(myGateway.message);
eoDebug::Print(myGateway.telegram);
}
//If we got a valid Profile Telegram which is not a Learn IN we print the received Values
if (recv & RECV_PROFILE)
{
printf("Device %08lX\n", myGateway.device->ID);
eoProfile *profile = myGateway.device->GetProfile();
float f;
uint8_t t;
for (int i = 0; i<profile->GetChannelCount(); i++)
{
//get the channel value if it is a float
if (profile->GetValue( profile->GetChannel(i)->type, f) ==OK)
printf("%s %.2f %s\n", profile->GetChannel(i)->ToString(NAME),f,profile->GetChannel(i)->ToString(UNIT));
//get the channel value if it is an uint
if (profile->GetValue( profile->GetChannel(i)->type, t) ==OK)
printf("%s %u \n", profile->GetChannel(i)->ToString(NAME),t);
}
}
}
return 0;
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Tutorial 2

  • Tutorials
Tutorial 2

The Source Code of the Tutorial can be found here: tutorial2.cpp

This Tutorial will help you to understand how to load configurations, use the eoProfile::GetValue Function and how to send Telegrams.

In this example Application we've a configuration which contains the Information about a Temperature Sensor sending an EEP2.1-A5-02-05 4BS Telegram.

This Application will send a 1BS "Warning" Telegram, if we reach a temperature over 30 Degree Celsius.

Here is the example Configuration File:

_EOLINK_SAVE
HEADER
{
name:_HUMAN_ARCHIVE
major:0x0
minor:0x2
}
Gateway
{
myDeviceManager
{
Counter:0x1
Device_0000
{
profile
{
rorg:0xa5
func:0x2
type:0x5
manufacturer:0x1a
}
dBm:0x0
ID:0x100867a
secIn
{
}
secIn
{
}
}
}
myFilter
{
type:0x1
Counter:0x1
ID_0000:0x100867a
}
myLearnFilter
{
}
LearnMode:FALSE
}

As you can see all number values are stored in Hex, and must of the Configuration is self explaining.

If you've a Temperature Sensor at your dispose, and want to test this application you've to change both fields containg the ID:0x100867a, to your device ID.

After including the eoLink Header File and opening the connection the eoGateway the eoStorageManager has to load the eoGateway Configuration.

eoGateway myGateway;
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=OK)
{
printf("Failed to open USB300\n");
return 0;
}
//Loading the prepared Configuartion
eoStorageManager myStore;
myStore.addObject("Gateway",&myGateway);
myStore.Load(LOAD_CONFIG);
uint16_t recv;

Loading and Storing use the same Object Information.

The next Step is to prepare the warning Telegram with a certain RORG and some data. We choose 1BS and 0xFF as data.

Telegram myTel = Telegram(1);
myTel.RORG=RORG_1BS;
myTel.data[0]=0xFF;

As in the previous example we use the return flags to check if we got Information about a Profile.

When we receive a temperature over 30 degree, we use eoGateway::Send() to send our definied 1BS Telegram.

while (1)
{
recv = myGateway.Receive();
if (recv & RECV_PROFILE)
{
printf("Device %08lX\n", myGateway.device->ID);
eoProfile *profile = myGateway.device->GetProfile();
float f;
if (profile->GetValue( S_TEMP, f) ==OK)
{
printf(" %.2f \n", f);
//our value is higher then 30Â° send the warning message!
if(f>30.0)
myGateway.Send(myMessage);
}
}
}
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Tutorial 3

  • Tutorials
Tutorial 3

In this Tutorial tutorial3.cpp we receive Information from an EEP A5-02-05 and translate it to A5-02-20 Profile. The same configuration as in Tutorial 2 is used and loaded.

eoGateway myGateway;
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=OK)
{
printf("Failed to open USB300\n");
return 0;
}
//Loading the prepared Configuartion
eoStorageManager myStore;
myStore.addObject("Gateway",&myGateway);
myStore.Load(LOAD_CONFIG);
printf("Loaded Config \n");
uint16_t recv;

Now as we want to send data, we've to create an eoTelegram and eoProfile. To create an eoProfile we use the static function eoProfileFactory::CreateProfile, which takes as paramaters either an eoTelegram containing a Teach IN telegram, or the RORG,FUNC,TYPE. If eoLink Supports you profile it returns a new instance of the selected profile otherwise it returns a null pointer.

eoTelegram myTel = eoTelegram(4);
eoProfile *sendProfile = eoProfileFactory::CreateProfile(0xA5,0x02,0x20);

Using the eoProfile we can call the eoProfile::CreateTeachIN function to prepare a teachIN Telegram and send it via the eoGateway.

if(sendProfile!=NULL)
sendProfile->CreateTeachIN(myTel);
myGateway.Send(myTel);

As in the previous examples, the eoGateway::Receive functions runs in a while loop. As soon as we get temperature, we use the eoProfile::SetValue function and the eoProfile::Create to generate a 4BS datatelegram. Now we use the eoGateway::Send to send the 4bs telegram.

while (1)
{
recv = myGateway.Receive();
//Got a Profile
if (recv & RECV_PROFILE)
{
printf("Device %08lX\n", myGateway.device->ID);
eoProfile *profile = myGateway.device->GetProfile();
float f;
//with a Temperature
if (profile->GetValue( S_TEMP, f) ==OK)
{
printf(" %.2f \n", f);
if(sendProfile==NULL)
continue;
//Use the eoProfile to set the temperature value
if(sendProfile->SetValue(S_TEMP,f)==OK)
{
//and send a Temperature Telegram
if(sendProfile->Create(myMessage)==OK)
myGateway.Send(myMessage);
}
}
}
}
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Tutorial 4

  • Tutorials
Tutorial 4

In this Tutorial tutorial4.cpp we Teach IN manual after a Teach IN telegram, and Teach Out if we receive a second one.

#define SER_PORT "/dev/USB300"
#define SAVE_CONFIG "./learned.txt"
#define LEARN_TIME_S 1
#include "./eoLink.h"
#include <stdio.h>
int main(int argc, const char* argv[]) {
eoGateway myGateway;
uint16_t recv=0;
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=OK)
{
printf("Failed to open USB300\n");
return 0;
}
myGateway.TeachInModule->SetRPS(0x02,0x01);
myGateway.TeachInModule->Set1BS(0x00,0x01);
while (1)
{
recv = myGateway.Receive();
//Got a Profile
if (recv & RECV_SECTEACHIN)
{
myGateway.TeachInModule->TeachOut(myGateway.message.sourceID);
}
else if (recv & RECV_TEACHIN)
{
myGateway.TeachInModule->TeachIN(myGateway.message);
}
}
return 0;
}
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Tutorial 5

  • Tutorials
Tutorial 5

In this Tutorial tutorial5.cpp we show how to use Serial Commands.

#define SER_PORT "/dev/USB300"
#define SAVE_CONFIG "./learned.txt"
#define LEARN_TIME_S 1
#include "./eoLink.h"
#include <stdio.h>
int main(int argc, const char* argv[]) {
eoGateway myGateway;
uint16_t recv=0;
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=OK)
{
printf("Failed to open USB300\n");
return 0;
}
eoSerialCommand cmd(&myGateway);
//Read Sw and HW version of the device
CO_RD_VERSION_RESPONSE version;
if (cmd.ReadVersion(version) == OK)
{
printf("%s %i.%i.%i.%i, ID:0x%08lX on %s\n",
version.appDescription,
version.appVersion[0], version.appVersion[1], version.appVersion[2], version.appVersion[3],
version.chipID,
SER_PORT);
}
//Failed to read the version of the device
else
{
printf("Failed to retrieve USB300 version\n");
return -1;
}
//Perform a built in self test
if (cmd.BIST() == OK)
printf ("Successful BIST performed!\n");
//Failed BIST
else
{
printf("Failed to perform BIST\n");
return -1;
}
//Read device ID base
CO_RD_IDBASE_RESPONSE baseID;
if (cmd.ReadIDBase(baseID) == OK)
printf("Base ID: %08lX, %i writes left\n", baseID.baseID, baseID.remainingWrites);
else
{
printf("Failed to retrieve USB300 base ID\n");
return -1;
}
//Write repeater
uint8_t repLevel = 1;
if (cmd.WriteRepeater(true, repLevel) == OK)
printf("Repeater added!\n");
else
{
printf("Failed to add repeater\n");
return -1;
}
//Read repeater
CO_RD_REPEATER_RESPONSE repeater;
if (cmd.ReadRepeater(repeater) == OK)
printf("Enabled: %s, Level: %i\n", repeater.repEnable ? "true":"false", repeater.repLevel);
else
{
printf("Failed to read repetear\n");
return -1;
}
//Add filter
if (cmd.AddFilter(CHOICE,0x11223344, BLOCK) == OK)
printf("Filter added!\n");
else
{
printf("Failed to add filter\n");
return -1;
}
//Read filter
CO_RD_FILTER_RESPONSE filter[1];
uint8_t filterCount;
if (cmd.ReadFilter(filter, &filterCount, 1) == OK)
printf("Filter type: %i, Filter value: 0x%08lX\n", filter[0].filterType, filter[0].filterValue);
else
{
printf("Failed to read filter\n");
return -1;
}
//Delete filter
if (cmd.DeleteFilter(CHOICE, 0x11223344) == OK)
printf("Filter deleted\n");
else
{
printf("Failed to delete filter\n");
return -1;
}
//Enable filter
if (cmd.EnableFilter(true, OR) == OK)
printf("Filter enabled\n");
else
{
printf("Failed to enable filter\n");
return -1;
}
//Delete all filter
if (cmd.DeleteAllFilter() == OK)
printf("All filter has been deleted!\n");
else
{
printf("Failed to delete all filter\n");
return -1;
}
//Wait maturity time
if (cmd.WaitMaturity(true) == OK)
printf("Maturity turned on\n");
else
{
printf("Failed to turn on maturity\n");
return -1;
}
return 0;
}
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Tutorial 6

  • Tutorials
Tutorial 6

This tutorials will learn in different EEP temperature profiles and creates one Generic Profile containing all temperature channels. Afterwards the received temperatures will be converted to generic profile temperatures and sent.

The Source Code of this Tutorial can be found here: tutorial6.cpp

Tutorial 6 consist of 3 functions: Tries to open the gateway

bool openGateway(eoGateway &myGateway)

Lets the eoGateway run in learn mode. Only A5-02-xx temperature profiles will be learned in, and an generic profile channel will be created.

learnInMode(eoGateway &myGateway,eoGenericProfile &genericTemperatureProfiles,std::map<uint32_t,uint8_t> &devToID)

When we receive a telegram from a learned in device, the temperature will be parsed and the generic profile temperature profile channel will be set.

void operatingMode(eoGateway &myGateway,eoGenericProfile &genericTemperatureProfiles,std::map<uint32_t,uint8_t> &devToID)

and the main functions

int main(int argc, const char* argv[]) {
//First a Gateway and a storageManager will be definied
eoGateway myGateway;
//Empty Generic Profile
eoGenericProfile genericTemperatureProfiles;
std::map<uint32_t,uint8_t> devToID;
if(openGateway(myGateway))
{
eodBmFilter * learnFilter = new eodBmFilter();
myGateway.learnFilter = learnFilter;
learnFilter->maxdBm=-0;
learnFilter->mindBm=-60;
//the eoIDFilter will allow our Gateway application to filter all the unwanted Telegrams
eoIDFilter * myFilter = new eoIDFilter();
myGateway.filter=myFilter;
printf("EnOcean-Link Gateway LearnMode\n");
learnInMode(myGateway,genericTemperatureProfiles,devToID);
printf("Learn Mode off\n");
operatingMode(myGateway,genericTemperatureProfiles,devToID);
delete learnFilter;
delete myFilter;
}
return 0;
}

In the openGateway function, no generic Profile functions are used.

The learnInMode uses the eoGenericProfile::AddChannelOut(CHANNEL_TYPE type, GP_RESOLUTION resolution, int8_t engMaximum, int8_t engMinimum, GP_SCALING scaleMaximum, GP_SCALING scaleMinimum, VALUE_TYPE valueType) for adding a generic profile channel, using the eep channel information

genericTemperatureProfiles.AddChannelOut(S_TEMP,GP_RES_10BIT,(int8_t)tempChannel->max,(int8_t)tempChannel->min,GP_SCAL_1,GP_SCAL_1,VAL_CURR);

As in generic profiles the "subtype" of the same channel types are just counted, (the first temperature channel is subtype 1, the second temperature is subtype 2 and so on) we save which device has which subtype number

devToID[myGateway.device->ID]=devToID.size()-1;

Then the teach in time is over a Teach In telegram is created and sent

eoMessage teachMessage(128);
genericTemperatureProfiles.CreateTeachIN(teachMessage);
myGateway.Send(teachMessage);

In the operatingMode() function the temperatures values are updated after receing a teached in tempetature and a generic profile message is created.

eoProfile* tempProfile = myGateway.device->GetProfile();
float temperature;
if (tempProfile->GetValue( S_TEMP, temperature) ==EO_OK)
{
eoMessage gpMessage(128);
genericTemperatureProfiles.SetValue(S_TEMP,temperature,devToID[myGateway.device->ID]);
genericTemperatureProfiles.Create(gpMessage);
myGateway.Send(gpMessage);
}
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Security Watcher Example

  • Tutorials
Security Watcher Example

This is an example Integration for the AN513: Robust EnOcean networks

The Source Code of this Tutorial can be found here: WatcherMain.cpp

The eoWatcher class contains the function to detect possible security issues. It contains functions for a general security Detection (e.g. DOS) and device specific (e.g. REPLAY)

Using the

function one can add a specific device to check. If you set maxPerdiodTime and minPerdiodTime you assume that your device sends atleast every minPeriodTime and max maxPeriodTime.

Using the CheckSecurity you can check for securitiy issues using the information of the currently received telegram.

In the WatcherMain.cpp we use one instance of the eoWatcher Class to handle the possible Security Issue of our Gateway.

//10 telegrams allowed with less then 100ms between them(maturity time)
eoWatcher myWatcher(10,100);
myGateway.secWatcher=myWatcher;
//We add our example device, which we expect to send every 10sec and at least every 100ms.
//The device Specific RLC Window is 10, and if we receive 5 Telegrams with a wrong CMAC we get an Error.
//After each received Telegram the expted tel Period is reseted (Meaning maxPeriodTime and minPeriodTime count from
//the moment we got this Telegram
myWatcher.AddDevice(0xFEFFFEBC,1000,100,10,5,true);

The exampe Function HandleSecResult(EO_SEC_WATCH_RESULT watchRes) would handle the different threats.

//Easy Handler for the different Security Issues
void HandleSecResult(EO_SEC_WATCH_RESULT watchRes)
{
switch(watchRes)
{
case(WATCH_OK):
break;
case(WATCH_DEVICE_NA):
break;
case(WATCH_DEVICE_ALREADY_EXIST):
break;
case(WATCH_NOT_SECURE_DEVICE):
break;
case(WATCH_NOT_WATCHED_DEVICE):
break;
case(WATCH_DOS_ASSUMED):
printf("Possible DOS detected \n");
break;
case(WATCH_TEL_TO_EARLY):
break;
case(WATCH_TEL_TO_LATE):
break;
case(WATCH_CMAC_OVERFLOW):
break;
case(WATCH_RLC_OVERFLOW):
break;
case(WATCH_DELAY_ASSUMED):
printf("A possible delay Attack detected \n");
break;
default:
printf("The Security watcher returned a not valid value!\n");
break;
}
}

We add the handle function in the mainLoop of the application.

if (recv & RECV_TELEGRAM)
{
eoDebug::Print(myGateway.telegram);
HandleSecResult((EO_SEC_WATCH_RESULT)myGateway.GetSecWatchResult());
}
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Modules

Modules
Here is a list of all modules:
[detail level 123]
\ API | This section describes most improtant part of EnOcean Link API interface to the application
o EEP2.6 Profiles API | This section describes most improtant part of EnOcean Equipment profiles. In all classes are tables available that show the translation into CHANNEL_TYPE. All profiles have mapped all channels. If profile has two same CHANNEL_TYPE they are differed by index aka subtype. The subtype is specific for every profile or profile family
o Generic Profile Interface | This section describes most improtant part of Generic profiles. This part is still not full released since the TWG has not completely released the Generic Profile Specification
o Gateway API | This section describes the Gateway functionality and cooperation with GatewayController firmware
| o Filters | This section describes the filter functionality of the Gateway
| o Remote Management API | This section shows the functions and structures used for remote management
| o Remote Commissioning API | This section shows the functions and structures used for remote commissioning
| o ESP 3 Command Support | This part holds the structures for the support of COMMON COMMANDs from EnOcen Serial Protocol
| \ Smart Acknowledge Support | This section holds the functions and structures used for smart acknowledge. Smart Acknowledge Lrn is part of the normal teach in process too
o Security API |
| o SLF Fields |
| \ Teach Info Fields |
\ Storage API |
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: API

Modules | Classes
API

This section describes most improtant part of EnOcean Link API interface to the application. More...

Collaboration diagram for API:

Modules

EEP2.6 Profiles API
This section describes most improtant part of EnOcean Equipment profiles. In all classes are tables available that show the translation into CHANNEL_TYPE. All profiles have mapped all channels. If profile has two same CHANNEL_TYPE they are differed by index aka subtype. The subtype is specific for every profile or profile family.
Generic Profile Interface
This section describes most improtant part of Generic profiles. This part is still not full released since the TWG has not completely released the Generic Profile Specification.
Gateway API
This section describes the Gateway functionality and cooperation with GatewayController firmware.
Security API
Storage API

Classes

class | eoConverter
contains static Helper Functions More...
class | eoDebug
helper class for Debug Messages More...
class | eoTimer
tickCount helper More...

Detailed Description

This section describes most improtant part of EnOcean Link API interface to the application.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: EEP2.6 Profiles API

Classes | Enumerations
EEP2.6 Profiles API
API

This section describes most improtant part of EnOcean Equipment profiles. In all classes are tables available that show the translation into CHANNEL_TYPE. All profiles have mapped all channels. If profile has two same CHANNEL_TYPE they are differed by index aka subtype. The subtype is specific for every profile or profile family. More...

Collaboration diagram for EEP2.6 Profiles API:

Classes

class | eoF6EEProfile
EnOcean Equipment Profiles class for RORG F6. More...
class | eoEEPChannelInfo
Specific class for EEP channel information. Class used to decribe the EEP channels. It has the EEP_ITEM to describe the EEP channel values and the subtype - index. More...
class | eoManufacturer
Manufacturer List. More...
class | eoEEProfile
base class for EEProfile parsing More...
class | eoA5EEProfile
EnOcean Equipment Profiles. More...
class | eoD2EEProfile
EnOcean Equipment Profiles. More...
class | eoEEP_A502xx
The class to handle EEP a502 profiles. More...
class | eoEEP_A504xx
The class to handle EEP a504 profiles. More...
class | eoEEP_A505xx
The class to handle EEP a505 profiles. More...
class | eoEEP_A506xx
The class to handle EEP a506 profiles. More...
class | eoEEP_A507xx
The class to handle EEP a507 profiles. More...
class | eoEEP_A508xx
The class to handle EEP a508 profiles. More...
class | eoEEP_A509xx
The class to handle EEP a509 profiles. More...
class | eoEEP_A510xx
The class to handle EEP a510 profiles. More...
class | eoEEP_A511xx
The class to handle EEP a511 profiles. More...
class | eoEEP_A512xx
The class to handle EEP a512 Automated meter reading (AMR) profiles. More...
class | eoEEP_A513xx
The class to handle EEP a513 profiles. More...
class | eoEEP_A514xx
The class to handle EEP a514 profiles. More...
class | eoEEP_A520xx
The class to handle EEP a520 profiles. More...
class | eoEEP_A530xx
The class to handle EEP a530 profiles. More...
class | eoEEP_A537xx
The class to handle EEP a537 profiles. More...
class | eoEEP_A538xx
The class to handle EEP a538 profiles. More...
class | eoEEP_D200xx
The class to handle EEP D200 profiles. More...
class | eoEEP_D201xx
The class to handle EEP D201 profiles. More...
class | eoEEP_D202xx
The class to handle EEP D202 profiles. More...
class | eoEEP_D203xx
The class to handle EEP D203 Secure Light and Blind Control. More...
class | eoEEP_D204xx
The class to handle EEP D204 Secure Light and Blind Control. More...
class | eoEEP_D205xx
The class to handle EEP D205 profiles. More...
class | eoEEP_D206xx
The class to handle EEP D206 profiles. More...
class | eoEEP_D210xx
The class to handle EEP D210 profiles. More...
class | eoEEP_D220xx
The class to handle EEP D220 profiles. More...
class | eoEEP_D230xx
The class to handle EEP D230 profiles. More...
class | eoEEP_D231xx
The class to handle EEP D231 profiles. More...
class | eoEEP_D232xx
The class to handle EEP D232 Automated meter reading (AMR) profiles. More...
class | eoEEP_D240xx
The class to handle EEP D240 profiles. More...
class | eoEEP_D2A0xx
The class to handle EEP D2A0 profiles. More...
class | eoEEP_D500xx
The class to handle EEP d500 profiles. More...
class | eoEEP_F602xx
The class to handle EEP f602 Rocker Switch, 2 Rocker profiles. More...
class | eoEEP_F603xx
The class to handle EEP f603 profiles. More...
class | eoEEP_F604xx
The class to handle EEP f604 profiles. More...
class | eoEEP_F605xx
The class to handle EEP f605 profiles. More...
class | eoEEP_F610xx
The class to handle EEP f610 profiles. More...

Enumerations

enum CHANNEL_TYPE {
S_RES = 0x00, S_ACCEL = 0x01, S_ACCEL_ABS = S_ACCEL + SP_ABS, S_ACCEL_REL = S_ACCEL + SP_REL,
S_ANGLE = 0x02, S_ANGLE_ABS = S_ANGLE + SP_ABS, S_ANGLE_REL = S_ANGLE + SP_REL, S_ANGVD = 0x03,
S_ANGVD_ABS = S_ANGVD + SP_ABS, S_ANGVD_REL = S_ANGVD + SP_REL, S_AREA = 0x04, S_AREA_ABS = S_AREA + SP_ABS,
S_AREA_REL = S_AREA + SP_REL, S_CONC = 0x05, S_CONC_ABS = S_CONC + SP_ABS, S_CONC_REL = S_CONC + SP_REL,
S_CURRENT = 0x06, S_CURRENT_ABS = S_CURRENT + SP_ABS, S_CURRENT_REL = S_CURRENT + SP_REL, S_DISTANCE = 0x07,
S_DISTANCE_ABS = S_DISTANCE + SP_ABS, S_DISTANCE_REL = S_DISTANCE + SP_REL, S_ELECFSTR = 0x08, S_ELECFSTR_ABS = S_ELECFSTR + SP_ABS,
S_ELECFSTR_REL = S_ELECFSTR + SP_REL, S_ENERGY = 0x09, S_ENERGY_ABS = S_ENERGY + SP_ABS, S_ENERGY_REL = S_ENERGY + SP_REL,
S_COUNTER = 0x0A, S_COUNTER_ABS = S_COUNTER + SP_ABS, S_COUNTER_REL = S_COUNTER + SP_REL, S_FORCE = 0x0B,
S_FORCE_ABS = S_FORCE + SP_ABS, S_FORCE_REL = S_FORCE + SP_REL, S_FREQ = 0x0C, S_FREQ_ABS = S_FREQ + SP_ABS,
S_FREQ_REL = S_FREQ + SP_REL, S_HEATFLUX = 0x0D, S_HEATFLUX_ABS = S_HEATFLUX + SP_ABS, S_HEATFLUX_REL = S_HEATFLUX + SP_REL,
S_IMPULSE = 0x0E, S_IMPULSE_ABS = S_IMPULSE + SP_ABS, S_IMPULSE_REL = S_IMPULSE + SP_REL, S_LUMINANCE = 0x0F,
S_LUMINANCE_ABS = S_LUMINANCE + SP_ABS, S_LUMINANCE_REL = S_LUMINANCE + SP_REL, S_MAGNETICF = 0x10, S_MAGNETICF_ABS = S_MAGNETICF + SP_ABS,
S_MAGNETICF_REL = S_MAGNETICF + SP_REL, S_MASS = 0x11, S_MASS_ABS = S_MASS + SP_ABS, S_MASS_REL = S_MASS + SP_REL,
S_MASSDENS = 0x12, S_MASSDENS_ABS = S_MASSDENS + SP_ABS, S_MASSDENS_REL = S_MASSDENS + SP_REL, S_MASSFLOW = 0x13,
S_MASSFLOW_ABS = S_MASSFLOW + SP_ABS, S_MASSFLOW_REL = S_MASSFLOW + SP_REL, S_POWER = 0x14, S_POWER_ABS = S_POWER + SP_ABS,
S_POWER_REL = S_POWER + SP_REL, S_PRESSURE = 0x15, S_PRESSURE_ABS = S_PRESSURE + SP_ABS, S_PRESSURE_REL = S_PRESSURE + SP_REL,
S_RELHUM = 0x16, S_RELHUM_ABS = S_RELHUM + SP_ABS, S_RELHUM_REL = S_RELHUM + SP_REL, S_RESIST = 0x17,
S_RESIST_ABS = S_RESIST + SP_ABS, S_RESIST_REL = S_RESIST + SP_REL, S_TEMP = 0x18, S_TEMP_ABS = S_TEMP + SP_ABS,
S_TEMP_REL = S_TEMP + SP_REL, S_TIME = 0x19, S_TIME_ABS = S_TIME + SP_ABS, S_TIME_REL = S_TIME + SP_REL,
S_TORQUE = 0x1A, S_TORQUE_ABS = S_TORQUE + SP_ABS, S_TORQUE_REL = S_TORQUE + SP_REL, S_VELOCITY = 0x1B,
S_VELOCITY_ABS = S_VELOCITY + SP_ABS, S_VELOCITY_REL = S_VELOCITY + SP_REL, S_VOLTAGE = 0x1C, S_VOLTAGE_ABS = S_VOLTAGE + SP_ABS,
S_VOLTAGE_REL = S_VOLTAGE + SP_REL, S_VOLUME = 0x1D, S_VOLUME_ABS = S_VOLUME + SP_ABS, S_VOLUME_REL = S_VOLUME + SP_REL,
S_VOLFLOW = 0x1E, S_VOLFLOW_ABS = S_VOLFLOW + SP_ABS, S_VOLFLOW_REL = S_VOLFLOW + SP_REL, S_SETPOINT = 0x1F,
S_SETPOINT_ABS = S_SETPOINT + SP_ABS, S_SETPOINT_REL = S_SETPOINT + SP_REL, S_PARTICLES = 0x20, S_PARTICLES_ABS = S_PARTICLES + SP_ABS,
S_PARTICLES_REL = S_PARTICLES + SP_REL, S_DIMMING = 0x21, S_DIMMING_ABS = S_DIMMING + SP_ABS, S_DIMMING_REL = S_DIMMING + SP_REL,
S_SOLAR_RAD = 0x22, S_SOLAR_RAD_ABS = S_SOLAR_RAD + SP_ABS, S_SOLAR_RAD_REL = S_SOLAR_RAD + SP_REL, S_PERCENTAGE = 0x23,
S_PERCENTAGE_ABS = S_PERCENTAGE + SP_ABS, S_PERCENTAGE_REL = S_PERCENTAGE + SP_REL, S_VALUE = 0x24, S_VALUE_ABS = S_VALUE + SP_ABS,
S_VALUE_REL = S_VALUE + SP_REL, S_RGB = 0x25, S_RGB_ABS = S_RGB + SP_ABS, S_RGB_REL = S_RGB + SP_REL,
S_ERROR_CODE = 0x26, S_ERROR_CODE_ABS = S_ERROR_CODE + SP_ABS, S_ERROR_CODE_REL = S_ERROR_CODE + SP_REL, S_RADON_ACTIVITY = 0x27,
S_RADON_ACTIVITY_ABS = S_RADON_ACTIVITY + SP_ABS, S_RADON_ACTIVITY_REL = S_RADON_ACTIVITY + SP_REL, S_AMPER_PER_HOUR = 0x28, S_AMPER_PER_HOUR_ABS = S_AMPER_PER_HOUR + SP_ABS,
S_AMPER_PER_HOUR_REL = S_AMPER_PER_HOUR + SP_REL, S_ROTATION_PER_MIN = 0x29, S_ROTATION_PER_MIN_ABS = S_ROTATION_PER_MIN + SP_ABS, S_ROTATION_PER_MIN_REL = S_ROTATION_PER_MIN + SP_REL,
E_ROCKER_A = T_ENUM + 0x01, E_ROCKER_B = T_ENUM + 0x02, E_ROCKER_C = T_ENUM + 0x03, E_ROCKER_D = T_ENUM + 0x04,
E_ENERGYBOW = T_ENUM + 0x05, E_MULTIPRESS = T_ENUM + 0x06, E_WINDOWHANDLE = T_ENUM + 0x07, E_FANSPEED = T_ENUM + 0x08,
E_TARIFF = T_ENUM + 0x09, E_VOC = T_ENUM + 0x0A, E_CONTROLLER_MODE = T_ENUM + 0x0B, E_ERROR_STATE = T_ENUM + 0x0C,
E_STATE = T_ENUM + 0x0D, E_END_POS = T_ENUM + 0x0E, E_OCCUPANCY = T_ENUM + 0x0F, E_USER_ACTION = T_ENUM + 0x10,
E_PRESENCE = T_ENUM + 0x11, E_DIM_VALUE = T_ENUM + 0x12, E_IO_CHANNEL = T_ENUM + 0x13, E_UNITS = T_ENUM + 0x14,
E_DAYS = T_ENUM + 0x15, E_COMMAND = T_ENUM + 0x16, E_DIRECTION = T_ENUM + 0x17, E_ROOM_SIZE = T_ENUM + 0x18,
E_KEY_DATA = T_ENUM + 0x19, E_GP_MULTIPURPOSE = GP_ENUM + 0x01, E_GP_BUILDING_MODE = GP_ENUM + 0x02, E_GP_OCCUPANCY = GP_ENUM + 0x03,
E_GP_HVAC_MODE = GP_ENUM + 0x04, E_GP_CHANGEOVER_MODE = GP_ENUM + 0x05, F_AUTO_MAN = T_FLAG + 0x01, F_BTN_PRESS = T_FLAG + 0x02,
F_BTN_TRIGGER = T_FLAG + 0x03, F_DAY_NIGHT = T_FLAG + 0x04, F_DOWN = T_FLAG + 0x05, F_GENALARM = T_FLAG + 0x06,
F_HEAT_COOL = T_FLAG + 0x07, F_HIGH_LOW = T_FLAG + 0x08, F_OCCUPIED = T_FLAG + 0x09, F_ON_OFF = T_FLAG + 0x0A,
F_OPEN_CLOSED = T_FLAG + 0x0B, F_POWERALARM = T_FLAG + 0x0C, F_START_STOP = T_FLAG + 0x0D, F_UP = T_FLAG + 0x0E,
F_VIBRATION = T_FLAG + 0x0F, F_RES = T_FLAG + 0xFF
}

Detailed Description

This section describes most improtant part of EnOcean Equipment profiles. In all classes are tables available that show the translation into CHANNEL_TYPE. All profiles have mapped all channels. If profile has two same CHANNEL_TYPE they are differed by index aka subtype. The subtype is specific for every profile or profile family.

Enumeration Type Documentation

enum CHANNEL_TYPE

The Channel Type contains all defined Signal Types, Flag Types and Enumeration Types. Every Type Group is a 8bit value + a type group specific offset.

Note:
Signal Types are floating point and Enums/Flags are uint8_t
Enumerator:
S_RES

S_RES.

S_ACCEL

1 - Acceleration m/s^2

S_ACCEL_ABS

Acceleration m/s^2 - absolute setpoint.

S_ACCEL_REL

Acceleration m/s^2 - relative setpoint.

S_ANGLE

2 - Angle in degrees

S_ANGLE_ABS

Angle in degrees - absolute setpoint.

S_ANGLE_REL

Angle in degrees - relative setpoint.

S_ANGVD

3 - Angular velocity degrees/s

S_ANGVD_ABS

Angular velocity degrees/s - absolute setpoint.

S_ANGVD_REL

3 - Angular velocity degrees/s

S_AREA

4 - Area m^2

S_AREA_ABS

Area m^2 - absolute setpoint.

S_AREA_REL

Area m^2 - relative setpoint.

S_CONC

5 - Concentration ppm

S_CONC_ABS

Concentration ppm - absolute setpoint.

S_CONC_REL

Concentration ppm - relative setpoint.

S_CURRENT

6 - Current Amps

S_CURRENT_ABS

Concentration ppm - absolute setpoint.

S_CURRENT_REL

Concentration ppm - relative setpoint.

S_DISTANCE

7 - Distance meters

S_DISTANCE_ABS

Distance meters - absolute setpoint.

S_DISTANCE_REL

Distance meters - relative setpoint.

S_ELECFSTR

8 - Electric field strength V/m

S_ELECFSTR_ABS

Electric field strength V/m - absolute setpoint.

S_ELECFSTR_REL

Electric field strength V/m - relative setpoint.

S_ENERGY

9 -Energy W*h

S_ENERGY_ABS

Energy W*h - absolute setpoint.

S_ENERGY_REL

Energy W*h - relative setpoint.

S_COUNTER

10 - Counter

S_COUNTER_ABS

Counter - absolute setpoint.

S_COUNTER_REL

Counter - relative setpoint.

S_FORCE

11 - Force Newtons

S_FORCE_ABS

Force Newtons - absolute setpoint.

S_FORCE_REL

Force Newtons - relative setpoint.

S_FREQ

12 - Frequency Hz

S_FREQ_ABS

Frequency Hz - absolute setpoint.

S_FREQ_REL

Frequency Hz - relative setpoint.

S_HEATFLUX

13 - Heat flux density W/m^2/s

S_HEATFLUX_ABS

Heat flux density W/m^2/s - absolute setpoint.

S_HEATFLUX_REL

Heat flux density W/m^2/s - relative setpoint.

S_IMPULSE

14 - Impulse N*s/kg

S_IMPULSE_ABS

Impulse N*s/kg - absolute setpoint.

S_IMPULSE_REL

Impulse N*s/kg - relative setpoint.

S_LUMINANCE

15 -Luminance intensity Lux

S_LUMINANCE_ABS

Luminance intensity Lux - absolute setpoint.

S_LUMINANCE_REL

Luminance intensity Lux - relative setpoint.

S_MAGNETICF

16 - Magnetic field strength A/m

S_MAGNETICF_ABS

Magnetic field strength A/m - absolute setpoint.

S_MAGNETICF_REL

Magnetic field strength A/m - relative setpoint.

S_MASS

17 - Mass kg

S_MASS_ABS

Mass kg - absolute setpoint.

S_MASS_REL

Mass kg - relative setpoint.

S_MASSDENS

18 - Mass density kg/m^3

S_MASSDENS_ABS

Mass density kg/m^3 - absolute setpoint.

S_MASSDENS_REL

Mass density kg/m^3 - relative setpoint.

S_MASSFLOW

19 - Mass flow kg/s

S_MASSFLOW_ABS

Mass flow kg/s - absolute setpoint.

S_MASSFLOW_REL

Mass flow kg/s - relative setpoint.

S_POWER

20 - Power Watts in W

S_POWER_ABS

<Power Watts in W - absolute setpoint

S_POWER_REL

Power Watts in W - relative setpoint.

S_PRESSURE

21 - Pressure Pascals

S_PRESSURE_ABS

Pressure Pascals - absolute setpoint.

S_PRESSURE_REL

Pressure Pascals - relative setpoint.

S_RELHUM

22 - Relative humidity Percent

S_RELHUM_ABS

Relative humidity Percent - absolute setpoint.

S_RELHUM_REL

Relative humidity Percent - relative setpoint.

S_RESIST

23 - Resistance Ohms

S_RESIST_ABS

Resistance Ohms - absolute setpoint.

S_RESIST_REL

Resistance Ohms - relative setpoint.

S_TEMP

24 - Temperature Deg C

S_TEMP_ABS

Temperature Deg C - absolute setpoint.

S_TEMP_REL

Temperature Deg C - relative setpoint.

S_TIME

25 - Time Seconds

S_TIME_ABS

Time Seconds - absolute setpoint.

S_TIME_REL

Time Seconds - relative setpoint.

S_TORQUE

26 - Torque N*m

S_TORQUE_ABS

Torque N*m - absolute setpoint.

S_TORQUE_REL

Torque N*m - relative setpoint.

S_VELOCITY

27 - Velocity m/s

S_VELOCITY_ABS

Velocity m/s - absolute setpoint.

S_VELOCITY_REL

Velocity m/s - relative setpoint.

S_VOLTAGE

28 - Voltage Volts

S_VOLTAGE_ABS

Voltage Volts - absolute setpoint.

S_VOLTAGE_REL

Voltage Volts - relative setpoint.

S_VOLUME

29 - Volume m^3

S_VOLUME_ABS

Volume m^3 - relative setpoint.

S_VOLUME_REL

Volume m^3 - absolute setpoint.

S_VOLFLOW

30 -Volumetric Flow m^3/s

S_VOLFLOW_ABS

Volumetric Flow m^3/s - absolute setpoint.

S_VOLFLOW_REL

Volumetric Flow m^3/s - relative setpoint.

S_SETPOINT

31 - Setpoint

S_SETPOINT_ABS

Setpoint - absolute setpoint.

S_SETPOINT_REL

Setpoint - relative setpoint.

S_PARTICLES

32 - Particles

S_PARTICLES_ABS

Particles - absolute setpoint.

S_PARTICLES_REL

Particles - relative setpoint.

S_DIMMING

33 - Dimming

S_DIMMING_ABS

Dimming - absolute setpoint.

S_DIMMING_REL

Dimming - relative setpoint.

S_SOLAR_RAD

34 - Solar radiation

S_SOLAR_RAD_ABS

Solar radiation - absolute setpoint.

S_SOLAR_RAD_REL

Solar radiation - relative setpoint.

S_PERCENTAGE

35 - Percentage %

S_PERCENTAGE_ABS

Percentage % - absolute setpoint.

S_PERCENTAGE_REL

Percentage % - relative setpoint.

S_VALUE

36 - Value

S_VALUE_ABS

Value - absolute setpoint.

S_VALUE_REL

Value - relative setpoint.

S_RGB

37 - RGB

S_RGB_ABS

RGB - absolute setpoint.

S_RGB_REL

RGB - relative setpoint.

S_ERROR_CODE

38 - Error code

S_ERROR_CODE_ABS

Error code - absolute setpoint.

S_ERROR_CODE_REL

Error code - relative setpoint.

S_RADON_ACTIVITY

39 - Radon Activity in Bq/m3

S_RADON_ACTIVITY_ABS

Radon Activity - absolute setpoint.

S_RADON_ACTIVITY_REL

Radon Activity - relative setpoint.

S_AMPER_PER_HOUR

40 - Amper per hour A/h

S_AMPER_PER_HOUR_ABS

Amper per hour - absolute setpoint.

S_AMPER_PER_HOUR_REL

Amper per hour - relative setpoint.

S_ROTATION_PER_MIN

41 - Rotation per minute 1/min

S_ROTATION_PER_MIN_ABS

Amper per hour - absolute setpoint.

S_ROTATION_PER_MIN_REL

Amper per hour - relative setpoint.

E_ROCKER_A

T_ENUM + 1 - Rocker Button A ENUM_ROCKER_STATE

E_ROCKER_B

T_ENUM + 2 - Rocker Button B ENUM_ROCKER_STATE

E_ROCKER_C

T_ENUM + 3 - Rocker Button C ENUM_ROCKER_STATE

E_ROCKER_D

T_ENUM + 4 - Rocker Button D ENUM_ROCKER_STATE

E_ENERGYBOW

T_ENUM + 5 - ENUM_ENERGY_STATE

E_MULTIPRESS

T_ENUM + 6 - ENUM_MULTIPRESS_STATE;

E_WINDOWHANDLE

T_ENUM + 7 - ENUM_WINDOW_STATE

E_FANSPEED

T_ENUM + 8 - ENUM_FAN_SPEED_5STAGE, ENUM_FAN_SPEED_7STAGE , CS_FAN_STAGE, HVCA_FANSPEED !! See EEP for selected profile!!

E_TARIFF

T_ENUM + 9 - Tariff information

E_VOC

T_ENUM + 10 - ENUM_VOC VOC (Volatile organic compound) information

E_CONTROLLER_MODE

T_ENUM + 11 - CS_ENUM_CONTROLLER_MODE, HVAC_MODE, HVCA_CONTROLLER_MODE

E_ERROR_STATE

T_ENUM + 12 - CS_ENUM_03_ERROR_STATE, CS_ENUM_04_ERROR_STATE, VLD_ERROR_LEVEL

E_STATE

T_ENUM + 13 - CS_ENUM_BLIND_STATE, CC_LOCKING_OPERATIONS, VLD_DEFAULT_STATE, VLD_SMOKE_DETECTION, VLD_QUERY_STATUS, VALVE_STATUS, VALVE_REQUEST, CS_WORKING_MODE

E_END_POS

T_ENUM + 14 - CS_ENUM_END_POS, HVCA_VANE_POSITION, CS_RELAY_STATUS

E_OCCUPANCY

T_ENUM + 15 - CS_ENUM_ROOM_OCCUPANCY, HVCA_ROOM_OCCUPANCY, HVCA_ROOM_OCCUPANCY_TYPE_20, CC_ROOM_OCCUPANCY

E_USER_ACTION

T_ENUM + 16 - CC_FUNCTIONS, RCP_USER_ACTION

E_PRESENCE

T_ENUM + 17 - RCP_PRESENCE

E_DIM_VALUE

T_ENUM + 18 - VLD_DIM_VALUE

E_IO_CHANNEL

T_ENUM + 19 - VLD_IO_CHANNEL

E_UNITS

T_ENUM + 20 - CC_ENERGY_UNITS, MSR_METER_UNITS

E_DAYS

T_ENUM + 21 - EA_ENUM_DAYS

E_COMMAND

T_ENUM + 22 - Commands for the VLD Families and EEP Profiles with more then one telegram type.

E_DIRECTION

T_ENUM + 23 - Directions for A5-20-xx profile

E_ROOM_SIZE

T_ENUM + 24 - Room size for D2-20-xx profile

E_KEY_DATA

T_ENUM + 25 - Key enum for A5-30-06 profile

E_GP_MULTIPURPOSE

GP_ENUM + 1 - Multipurpose

E_GP_BUILDING_MODE

GP_ENUM + 2 - Building mode

E_GP_OCCUPANCY

GP_ENUM + 3 - Occupancy mode

E_GP_HVAC_MODE

GP_ENUM + 4 - HVAC mode

E_GP_CHANGEOVER_MODE

GP_ENUM + 5 - Changeover mode

F_AUTO_MAN

T_FLAG + 0x01 Automatic (1) / manual (0)

F_BTN_PRESS

T_FLAG + 0x02 Button pressed (1 when pressed, 0 when not changed)

F_BTN_TRIGGER

T_FLAG + 0x03 Button triggered *

F_DAY_NIGHT

T_FLAG + 0x04 Day(1) / night(0)

F_DOWN

T_FLAG + 0x05 Down "-" (1 when pressed)

F_GENALARM

T_FLAG + 0x06 General alarm (1)

F_HEAT_COOL

T_FLAG + 0x07 Heat (1) / cool (0)

F_HIGH_LOW

T_FLAG + 0x08 High (1) / low (0)

F_OCCUPIED

T_FLAG + 0x09 Occupied (1) / unoccupied (0)

F_ON_OFF

T_FLAG + 0x10 On (1) / off (0)

F_OPEN_CLOSED

T_FLAG + 0x11 Open (1) / closed (0)

F_POWERALARM

T_FLAG + 0x12 Power alarm (1)

F_START_STOP

T_FLAG + 0x13 Start (1) / stop (0)

F_UP

T_FLAG + 0x14 Up "+" (1 when pressed)

F_VIBRATION

T_FLAG + 0x15 Vibration (1) / No vibration (0)

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoF6EEProfile Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions
eoF6EEProfile Class Reference
EEP2.6 Profiles API

EnOcean Equipment Profiles class for RORG F6. More...

#include <eoF6EEProfile.h>

Inheritance diagram for eoF6EEProfile:
[legend]
Collaboration diagram for eoF6EEProfile:
[legend]

List of all members.

Public Member Functions

virtual eoReturn | Create (eoMessage &msg)
Generates an EEP Message.
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t subFlag)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t subFlag)
Gets the Value as a float.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetType (uint8_t type)
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Additional Inherited Members

- Protected Attributes inherited from eoEEProfile
eoEEPChannelInfo * channel
ChannelInfo list for direct Access to channels.
uint8_t channelCount
Number of channels.
- Protected Attributes inherited from eoProfile
eoMessage msg
helper function to convert bits

Detailed Description

EnOcean Equipment Profiles class for RORG F6.

<>

Base class for EnOcean Equipment Profiles - RORG - 0xF6, contains functions which are always the same for all derivated F6 Profiles.

Member Function Documentation

virtual eoReturn eoF6EEProfile::Create ( eoMessage & m )
virtual

Generates an EEP Message.

This functions generates a Message for the specified EEP, with the current ChannelInfo values

Parameters:
m Reference to the Message (will be cleared and generated new)
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoF6EEProfile::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEPChannelInfo Class Reference

  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
eoEEPChannelInfo Class Reference
EEP2.6 Profiles API

Specific class for EEP channel information. Class used to decribe the EEP channels. It has the EEP_ITEM to describe the EEP channel values and the subtype - index. More...

#include <eoChannelInfo.h>

Inheritance diagram for eoEEPChannelInfo:
[legend]
Collaboration diagram for eoEEPChannelInfo:
[legend]

List of all members.

Public Attributes

const EEP_ITEM * | eepItem
points to static description of EEP
- Public Attributes inherited from eoChannelInfo
CHANNEL_TYPE type
CHANNEL_TYPE
VALUE_TYPE signalType
Current, Setpoint Absolute, Setpoint relative.
float | min
Min as clear value.
float | max
Max as clear value.

Additional Inherited Members

- Public Member Functions inherited from eoChannelInfo
const char * ToString (uint8_t strType)

Detailed Description

Specific class for EEP channel information. Class used to decribe the EEP channels. It has the EEP_ITEM to describe the EEP channel values and the subtype - index.

Examples:
Gateway_SubtypeExample.cpp.
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoManufacturer Class Reference

Static Public Member Functions
eoManufacturer Class Reference
EEP2.6 Profiles API | Generic Profile Interface

Manufacturer List. More...

#include <eoManufacturer.h>

List of all members.

Static Public Member Functions

static const char * GetName (const uint16_t manufacturerID)

Detailed Description

Manufacturer List.

The eoManufacturer class provides functionality to convert manufacturer ID to name.

Member Function Documentation

static const char* eoManufacturer::GetName ( const uint16_t manufacturerID )
static

Returns the name of manufacturer as zero terminated string

Returns:
Manufacturer name
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEProfile Class Reference

Public Member Functions | Protected Attributes
eoEEProfile Class Reference
EEP2.6 Profiles API

base class for EEProfile parsing More...

#include <eoEEProfile.h>

Inheritance diagram for eoEEProfile:
[legend]
Collaboration diagram for eoEEProfile:
[legend]

List of all members.

Public Member Functions

eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t subFlag)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t subFlag)
Gets the Value as a float.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetType (uint8_t type)
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Protected Attributes

eoEEPChannelInfo * channel
ChannelInfo list for direct Access to channels.
uint8_t channelCount
Number of channels.
- Protected Attributes inherited from eoProfile
eoMessage msg
helper function to convert bits

Additional Inherited Members

- Public Attributes inherited from eoProfile
uint8_t | rorg
R-ORG.
uint8_t | func
Func.
uint8_t | type
Type.
uint16_t | manufacturer
Manufacturer.
- Protected Member Functions inherited from eoProfile
float | ScaleFromRAW (uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax)
Creates floating Point from Raw Value.
uint32_t | ScaleToRAW (float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax)
Creates Raw Value from a floating Point.
- Static Protected Member Functions inherited from eoProfile
static eoReturn | GetRawValue (const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size)
Gives raw data Value from a Message.
static eoReturn | SetRawValue (eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size)
Inserts raw data Value in a message.
- Static Protected Attributes inherited from eoProfile
static const uint8_t | maskArray [8]
Mask array.

Detailed Description

base class for EEProfile parsing

This class is the base class for all eoEEProfiles.

Constructor & Destructor Documentation

eoEEProfile::eoEEProfile ( uint16_t size = 4 )

Constructor

Parameters:
size Default size of the expected message.

Member Function Documentation

virtual eoChannelInfo* eoEEProfile::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoProfile.

Reimplemented in eoEEP_A520xx, eoEEP_D210xx, eoEEP_D230xx, eoEEP_A538xx, eoEEP_A511xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D220xx, eoEEP_A513xx, eoEEP_D206xx, eoEEP_A512xx, eoEEP_D205xx, eoEEP_A509xx, eoEEP_A530xx, eoEEP_D202xx, eoEEP_D240xx, eoEEP_D231xx, eoEEP_D232xx, and eoEEP_A537xx.

virtual eoChannelInfo* eoEEProfile::GetChannel ( CHANNEL_TYPE type )
virtual

Returns the channel for the selected type

Parameters:
type CHANNEL_TYPE
Returns:
Pointer to ChannelInfo or Null

Reimplemented from eoProfile.

Reimplemented in eoEEP_A512xx, eoEEP_F602xx, eoEEP_A506xx, eoEEP_F603xx, eoEEP_F605xx, eoEEP_F610xx, and eoEEP_F604xx.

virtual eoChannelInfo* eoEEProfile::GetChannel ( uint8_t channelNumber )
virtual

returns the pointer to eoChannelInfo for the selected channelNumber or NULL

Parameters:
channelNumber
Returns:
Pointer to Channel

Reimplemented from eoProfile.

virtual uint8_t eoEEProfile::GetChannelCount ( ) const
virtual

Returns Number of channels for this profile

Returns:
number of channels

Reimplemented from eoProfile.

virtual eoReturn eoEEProfile::GetSubTypeChannel | ( | CHANNEL_TYPE | type,
 |  | std::vector< eoEEPChannelInfo * > & | vector
 | ) |  |
virtual

returns vector containing subtype values

Parameters:
type CHANNEL_TYPE
vector
Returns:
EO_OK

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoA5EEProfile Class Reference

Public Member Functions
eoA5EEProfile Class Reference
EEP2.6 Profiles API

EnOcean Equipment Profiles. More...

#include <eoA5EEProfile.h>

Inheritance diagram for eoA5EEProfile:
[legend]
Collaboration diagram for eoA5EEProfile:
[legend]

List of all members.

Public Member Functions

eoA5EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetType (uint8_t type)
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Additional Inherited Members

- Protected Attributes inherited from eoEEProfile
eoEEPChannelInfo * channel
ChannelInfo list for direct Access to channels.
uint8_t channelCount
Number of channels.
- Protected Attributes inherited from eoProfile
eoMessage msg
helper function to convert bits

Detailed Description

EnOcean Equipment Profiles.

base class for EnOcean Equipment Profiles, contains functions which are always the same

Constructor & Destructor Documentation

eoA5EEProfile::eoA5EEProfile ( uint16_t size = 4 )

Constructor.

Parameters:
size Default size of the expected message.

Member Function Documentation

virtual eoReturn eoA5EEProfile::Create ( eoMessage & m )
virtual

Generates an EEP Message.

This functions generates a Message for the specified EEP, with the current ChannelInfo values

Parameters:
m Reference to the Message (will be cleared and generated new)
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Reimplemented in eoEEP_A520xx.

virtual eoReturn eoA5EEProfile::CreateTeachIN ( eoMessage & m )
virtual

Generates an EEP Telegram(only not chained supported!!1)

This functions generates a Message for the specified EEP, with the current ChannelInfo values

Parameters:
m Reference to the Message (will be cleared and generated new)
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoA5EEProfile::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Reimplemented in eoEEP_A520xx, eoEEP_A510xx, eoEEP_A538xx, eoEEP_A511xx, eoEEP_A513xx, eoEEP_A512xx, eoEEP_A509xx, eoEEP_A530xx, eoEEP_A537xx, eoEEP_A506xx, eoEEP_A507xx, and eoEEP_A504xx.

virtual eoReturn eoA5EEProfile::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Reimplemented in eoEEP_A520xx, eoEEP_A538xx, eoEEP_A511xx, eoEEP_A513xx, and eoEEP_A509xx.

virtual eoReturn eoA5EEProfile::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Reimplemented in eoEEP_A520xx, eoEEP_A538xx, eoEEP_A510xx, eoEEP_A511xx, eoEEP_A513xx, eoEEP_A512xx, eoEEP_A530xx, and eoEEP_A537xx.

bool eoA5EEProfile::Is4BSData ( const eoMessage & m )

Checks if the message is a 4BS data Telegram as in [EEP]

Parameters:
m Message to check
Returns:
true=yes; false=no
bool eoA5EEProfile::IsSecDData ( const eoMessage & message )
virtual

Checks if the data is RORG_SECD

Parameters:
message to check
Returns:
true or false;

Reimplemented from eoProfile.

virtual eoReturn eoA5EEProfile::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Reimplemented in eoEEP_A538xx, eoEEP_A513xx, and eoEEP_D500xx.

virtual eoReturn eoA5EEProfile::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Reimplemented in eoEEP_A520xx, eoEEP_A510xx, eoEEP_A538xx, eoEEP_A511xx, eoEEP_A513xx, eoEEP_A512xx, eoEEP_A509xx, eoEEP_A530xx, eoEEP_A537xx, eoEEP_A507xx, eoEEP_A504xx, and eoEEP_A506xx.

virtual eoReturn eoA5EEProfile::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Reimplemented in eoEEP_A520xx, eoEEP_A538xx, eoEEP_A510xx, eoEEP_A511xx, eoEEP_A513xx, eoEEP_A512xx, eoEEP_A530xx, and eoEEP_A537xx.

virtual eoReturn eoA5EEProfile::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Reimplemented in eoEEP_A520xx, eoEEP_A538xx, eoEEP_A511xx, eoEEP_A513xx, and eoEEP_A509xx.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoD2EEProfile Class Reference

Public Member Functions
eoD2EEProfile Class Reference
EEP2.6 Profiles API

EnOcean Equipment Profiles. More...

#include <eoD2EEProfile.h>

Inheritance diagram for eoD2EEProfile:
[legend]
Collaboration diagram for eoD2EEProfile:
[legend]

List of all members.

Public Member Functions

eoD2EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | SetCommand (uint8_t cmd)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetType (uint8_t type)
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Additional Inherited Members

- Protected Attributes inherited from eoEEProfile
eoEEPChannelInfo * channel
ChannelInfo list for direct Access to channels.
uint8_t channelCount
Number of channels.
- Protected Attributes inherited from eoProfile
eoMessage msg
helper function to convert bits

Detailed Description

EnOcean Equipment Profiles.

base class for EnOcean Equipment Profiles, contains functions which are always the same

Constructor & Destructor Documentation

eoD2EEProfile::eoD2EEProfile ( uint16_t size = 4 )

Constructor.

Parameters:
size Default size of the expected message.

Member Function Documentation

virtual eoReturn eoD2EEProfile::CreateTeachIN ( eoMessage & m )
virtual

Generates an EEP Telegram(only not chained supported!!1)

This functions generates a Message for the specified EEP, with the current ChannelInfo values

Parameters:
m Reference to the Message (will be cleared and generated new)
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoD2EEProfile::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Reimplemented in eoEEP_D210xx, eoEEP_D230xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D220xx, eoEEP_D204xx, eoEEP_D206xx, eoEEP_D205xx, eoEEP_D202xx, eoEEP_D240xx, eoEEP_D231xx, and eoEEP_D232xx.

virtual eoReturn eoD2EEProfile::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Reimplemented in eoEEP_D210xx, eoEEP_D230xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D206xx, eoEEP_D205xx, eoEEP_D202xx, eoEEP_D240xx, eoEEP_D231xx, and eoEEP_D232xx.

virtual eoReturn eoD2EEProfile::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Reimplemented in eoEEP_D210xx, eoEEP_D230xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D220xx, eoEEP_D206xx, eoEEP_D202xx, eoEEP_D240xx, and eoEEP_D231xx.

virtual eoReturn eoD2EEProfile::SetCommand ( uint8_t cmd )
virtual

Sets and checks if the specified command is supported

Parameters:
cmd
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented in eoEEP_D210xx, eoEEP_D230xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D206xx, eoEEP_D205xx, eoEEP_D240xx, eoEEP_D202xx, and eoEEP_D231xx.

virtual eoReturn eoD2EEProfile::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Reimplemented in eoEEP_D210xx, eoEEP_D230xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D220xx, eoEEP_D204xx, eoEEP_D206xx, eoEEP_D205xx, eoEEP_D202xx, eoEEP_D240xx, eoEEP_D231xx, and eoEEP_D232xx.

virtual eoReturn eoD2EEProfile::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Reimplemented in eoEEP_D210xx, eoEEP_D230xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D220xx, eoEEP_D206xx, eoEEP_D202xx, eoEEP_D240xx, and eoEEP_D231xx.

virtual eoReturn eoD2EEProfile::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Reimplemented in eoEEP_D210xx, eoEEP_D230xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D206xx, eoEEP_D205xx, eoEEP_D202xx, eoEEP_D240xx, eoEEP_D231xx, and eoEEP_D232xx.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A502xx Class Reference

Public Member Functions
eoEEP_A502xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a502 profiles. More...

#include <eoEEP_A502xx.h>

Inheritance diagram for eoEEP_A502xx:
[legend]
Collaboration diagram for eoEEP_A502xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a502 profiles.

Allows the user to handle EEP a502 profiles, the following profiles are available:

  • A5-02-01
  • A5-02-02
  • A5-02-03
  • A5-02-04
  • A5-02-05
  • A5-02-06
  • A5-02-07
  • A5-02-08
  • A5-02-09
  • A5-02-0A
  • A5-02-0B
  • A5-02-10
  • A5-02-11
  • A5-02-12
  • A5-02-13
  • A5-02-14
  • A5-02-15
  • A5-02-16
  • A5-02-17
  • A5-02-18
  • A5-02-19
  • A5-02-1A
  • A5-02-1B
  • A5-02-20
  • A5-02-30
    The following channels are available:
    Channel Index | CHANNEL_TYPE | Type
    0 | S_TEMP | float

Member Function Documentation

eoReturn eoEEP_A502xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A504xx Class Reference

Public Member Functions
eoEEP_A504xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a504 profiles. More...

#include <eoEEP_A504xx.h>

Inheritance diagram for eoEEP_A504xx:
[legend]
Collaboration diagram for eoEEP_A504xx:
[legend]

List of all members.

Public Member Functions

virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
eoReturn | SetType (uint8_t type)
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a504 profiles.

Allows the user to handle EEP a504 profiles, the following profile is available:

  • A5-04-01
  • A5-04-02
  • A5-04-03

The following channels are available for type 01 and type 02:

Channel Index | Channel Type | Type
0 | S_RELHUM | float
1 | S_TEMP | float

The following channels are available for type 03:

Channel Index | Channel Type | Type
0 | S_RELHUM | float
1 | S_TEMP | float
2 | F_ON_OFF | uint8_t

Member Function Documentation

virtual eoReturn eoEEP_A504xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A504xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_A504xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A504xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A504xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A505xx Class Reference

Public Member Functions
eoEEP_A505xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a505 profiles. More...

#include <eoEEP_A505xx.h>

Inheritance diagram for eoEEP_A505xx:
[legend]
Collaboration diagram for eoEEP_A505xx:
[legend]

List of all members.

Public Member Functions

virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
eoReturn | SetType (uint8_t type)
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a505 profiles.

Allows the user to handle EEP a505 profiles, the following profile is available:

  • A5-05-01
    The following channels are available:
    Channel Index | Channel Type | Type
    0 | S_PRESSURE (kPa) | float
    1 | F_ON_OFF | uint8_t

Member Function Documentation

virtual eoReturn eoEEP_A505xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_A505xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A505xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A506xx Class Reference

Public Member Functions
eoEEP_A506xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a506 profiles. More...

#include <eoEEP_A506xx.h>

Inheritance diagram for eoEEP_A506xx:
[legend]
Collaboration diagram for eoEEP_A506xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a506 profiles.

Allows the user to handle EEP a506 profiles, the following profiles are available:

  • A5-06-01
  • A5-06-02
  • A5-06-03
  • A5-06-04

The following channels are available for 01, 02, 03 profiles:

Channel Index | Channel Type | Type | Comment
0 | S_VOLTAGE | float |
1 | S_LUMINANCE | float | Application automatically choosing the right channel

The following channels are available for 04 profile:

Channel Index | Channel Type | Type
0 | S_TEMP | float
1 | S_LUMINANCE | float
2 | S_PERCENTAGE | float

Member Function Documentation

virtual eoChannelInfo* eoEEP_A506xx::GetChannel ( CHANNEL_TYPE type )
virtual

Returns the channel for the selected type

Parameters:
type CHANNEL_TYPE
Returns:
Pointer to ChannelInfo or Null

Reimplemented from eoEEProfile.

eoReturn eoEEP_A506xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A506xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

eoReturn eoEEP_A506xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A507xx Class Reference

Public Member Functions
eoEEP_A507xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a507 profiles. More...

#include <eoEEP_A507xx.h>

Inheritance diagram for eoEEP_A507xx:
[legend]
Collaboration diagram for eoEEP_A507xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a507 profiles.

Allows the user to handle EEP a507 profiles, the following profile is available:

  • A5-07-01
  • A5-07-02
  • A5-07-03
    The following channels are available for type 01:
    Channel Index | Channel Type | Type
    0 | S_VOLTAGE | float
    1 | F_OCCUPIED | uint8_t

    The following channels are available for type 02 and for type 03:
    Channel Index | Channel Type | Type
    0 | S_VOLTAGE | float
    1 | S_LUMINANCE | float
    2 | F_OCCUPIED | uint8_t

Member Function Documentation

eoReturn eoEEP_A507xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A507xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_A507xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

eoReturn eoEEP_A507xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A507xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A508xx Class Reference

Public Member Functions
eoEEP_A508xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a508 profiles. More...

#include <eoEEP_A508xx.h>

Inheritance diagram for eoEEP_A508xx:
[legend]
Collaboration diagram for eoEEP_A508xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a508 profiles.

Allows the user to handle EEP a508 profiles, the following profiles are available:

  • A5-08-01
  • A5-08-02
  • A5-08-03
    The following channels are available:
    Channel Index | Channel Type | Type
    0 | S_VOLTAGE | float
    1 | S_LUMINANCE | float
    2 | S_TEMP | float
    3 | F_OCCUPIED | uint8_t
    4 | F_BTN_PRESS | uint8_t

Member Function Documentation

virtual eoReturn eoEEP_A508xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_A508xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A508xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A509xx Class Reference

Public Member Functions
eoEEP_A509xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a509 profiles. More...

#include <eoEEP_A509xx.h>

Inheritance diagram for eoEEP_A509xx:
[legend]
Collaboration diagram for eoEEP_A509xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a509 profiles.

Allows the user to handle EEP a509 profiles, the following profiles are available:

  • A5-09-01
  • A5-09-02
  • A5-09-04
  • A5-09-05
  • A5-09-06
  • A5-09-07
  • A5-09-08
  • A5-09-09
  • A5-09-0A
  • A5-09-0B

The following channels are available for 01 Profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | S_TEMP | float

The following channels are available for 02 Profile:

Channel Index | Channel Type | Type
0 | S_VOLTAGE | float
1 | S_CONC | float
2 | S_TEMP | float

The following channels are available for 04 Profile:

Channel Index | Channel Type | Type
0 | S_RELHUM | float
1 | S_CONC | float
2 | S_TEMP | float

The following channels are available for 05 Profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | E_VOC | ENUM_VOC

The following channels are available for 06 Profile:

Channel Index | Channel Type | Type
0 | S_RADON_ACTIVITY | float

The following channels are available for 07 Profile:

Channel Index | Channel Type | Type | Comment
0 | S_PARTICLES | float | PM10
1 | S_PARTICLES | float | PM2_5
2 | S_PARTICLES | float | PM1

The following channels are available for 08 Profile:

Channel Index | Channel Type | Type
0 | S_CONC | float

The following channels are available for 09 Profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | F_POWERALARM | uint8_t

The following channels are available for 0A Profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | S_TEMP | float
2 | S_VOLTAGE | float

The following channels are available for 0B Profile:

Channel Index | Channel Type | Type
0 | S_VOLTAGE | float
1 | S_COUNTER | float
2 | E_UNITS | ENUM_RADIATION_UNIT

Member Function Documentation

eoChannelInfo* eoEEP_A509xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

eoReturn eoEEP_A509xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A509xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_A509xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A509xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

eoReturn eoEEP_A509xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A509xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_A509xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A510xx Class Reference

Public Member Functions
eoEEP_A510xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a510 profiles. More...

#include <eoEEP_A510xx.h>

Inheritance diagram for eoEEP_A510xx:
[legend]
Collaboration diagram for eoEEP_A510xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t subFlag)
Gets the Value as unsigned integer.
eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a510 profiles.

Allows the user to handle EEP a510 profiles, the following profiles are available:

  • A5-10-01
  • A5-10-02
  • A5-10-03
  • A5-10-04
  • A5-10-05
  • A5-10-06
  • A5-10-07
  • A5-10-08
  • A5-10-09
  • A5-10-0A
  • A5-10-0B
  • A5-10-0C
  • A5-10-0D
  • A5-10-10
  • A5-10-11
  • A5-10-12
  • A5-10-13
  • A5-10-14
  • A5-10-15
  • A5-10-16
  • A5-10-17
  • A5-10-18
  • A5-10-19
  • A5-10-1A
  • A5-10-1B
  • A5-10-1C
  • A5-10-1D
  • A5-10-1E
  • A5-10-1F
  • A5-10-20
  • A5-10-21
  • A5-10-22
  • A5-10-23

The following channels are available for 01 profile:

Channel Index | Channel Type | Type
0 | E_FANSPEED | ENUM_FAN_SPEED_5STAGE
1 | S_SETPOINT | float
2 | S_TEMP | float
3 | F_BTN_PRESS | uint8_t

The following channels are available for 02 profile:

Channel Index | Channel Type | Type
0 | E_FANSPEED | ENUM_FAN_SPEED_5STAGE
1 | S_SETPOINT | float
2 | S_TEMP | float
3 | F_DAY_NIGHT | uint8_t

The following channels are available for 03 profile:

Channel Index | Channel Type | Type
0 | S_SETPOINT | float
1 | S_TEMP | float

The following channels are available for 04 profile:

Channel Index | Channel Type | Type
0 | E_FANSPEED | ENUM_FAN_SPEED_5STAGE
1 | S_SETPOINT | float
2 | S_TEMP | float

The following channels are available for 05 profile:

Channel Index | Channel Type | Type
0 | S_SETPOINT | float
1 | S_TEMP | float
2 | F_BTN_PRESS | uint8_t

The following channels are available for 06 profile:

Channel Index | Channel Type | Type
0 | S_SETPOINT | float
1 | S_TEMP | float
2 | F_DAY_NIGHT | uint8_t

The following channels are available for 07 profile:

Channel Index | Channel Type | Type
0 | E_FANSPEED | ENUM_FAN_SPEED_5STAGE
1 | S_TEMP | float

The following channels are available for 08 profile:

Channel Index | Channel Type | Type
0 | E_FANSPEED | ENUM_FAN_SPEED_5STAGE
1 | S_TEMP | float
2 | F_BTN_PRESS | uint8_t

The following channels are available for 09 profile:

Channel Index | Channel Type | Type
0 | E_FANSPEED | ENUM_FAN_SPEED_5STAGE
1 | S_TEMP | float
2 | F_DAY_NIGHT | uint8_t

The following channels are available for 0A profile:

Channel Index | Channel Type | Type
0 | S_SETPOINT | float
1 | S_TEMP | float
2 | F_OPEN_CLOSED | uint8_t

The following channels are available for 0B profile:

Channel Index | Channel Type | Type
0 | S_TEMP | float
1 | F_OPEN_CLOSED | uint8_t

The following channels are available for 0C profile:

Channel Index | Channel Type | Type
0 | S_TEMP | float
1 | F_BTN_PRESS | uint8_t

The following channels are available for 0D profile:

Channel Index | Channel Type | Type
0 | S_TEMP | float
1 | F_DAY_NIGHT | uint8_t

The following channels are available for 10 profile:

Channel Index | Channel Type | Type
0 | S_SETPOINT | float
1 | S_TEMP | float
2 | F_BTN_PRESS | uint8_t
3 | S_RELHUM | float

The following channels are available for 11 profile:

Channel Index | Channel Type | Type
0 | S_SETPOINT | float
1 | S_TEMP | float
2 | F_DAY_NIGHT | uint8_t
3 | S_RELHUM | float

The following channels are available for 12 profile:

Channel Index | Channel Type | Type
0 | S_SETPOINT | uint8_t
1 | S_TEMP | float
2 | S_RELHUM | float

The following channels are available for 13 profile:

Channel Index | Channel Type | Type
0 | S_TEMP | float
1 | F_BTN_PRESS | uint8_t
2 | S_RELHUM | float

The following channels are available for 14 profile:

Channel Index | Channel Type | Type
0 | S_TEMP | float
1 | F_DAY_NIGHT | uint8_t
2 | S_RELHUM | float

The following channels are available for 15 profile:

Channel Index | Channel Type | Type
0 | S_SETPOINT | float
1 | S_TEMP | float

The following channels are available for 16 profile:

Channel Index | Channel Type | Type
0 | S_SETPOINT | float
1 | S_TEMP | float
2 | F_BTN_PRESS | uint8_t

The following channels are available for 17 profile:

Channel Index | Channel Type | Type
0 | S_TEMP | float
1 | F_BTN_PRESS | uint8_t

The following channels are available for 18 profile:

Channel Index | Channel Type | Type
0 | E_FANSPEED | ENUM_FAN_SPEED_7STAGE
1 | S_LUMINANCE | float
2 | S_TEMP_ABS | float
3 | S_TEMP | float
4 | F_BTN_PRESS | uint8_t

The following channels are available for 19 profile:

Channel Index | Channel Type | Type
0 | E_FANSPEED | ENUM_FAN_SPEED_7STAGE
1 | S_RELHUM | float
2 | S_TEMP_ABS | float
3 | S_TEMP | float
4 | F_BTN_PRESS | uint8_t

The following channels are available for 1A profile:

Channel Index | Channel Type | Type
0 | E_FANSPEED | ENUM_FAN_SPEED_7STAGE
1 | S_VOLTAGE | float
2 | S_TEMP_ABS | float
3 | S_TEMP | float
4 | F_BTN_PRESS | uint8_t

The following channels are available for 1B profile:

Channel Index | Channel Type | Type
0 | E_FANSPEED | ENUM_FAN_SPEED_7STAGE
1 | S_LUMINANCE | float
2 | S_VOLTAGE | float
3 | S_TEMP | float
4 | F_BTN_PRESS | uint8_t

The following channels are available for 1C profile:

Channel Index | Channel Type | Type
0 | E_FANSPEED | ENUM_FAN_SPEED_7STAGE
1 | S_LUMINANCE | float
2 | S_LUMINANCE_ABS | float
3 | S_TEMP | float
4 | F_BTN_PRESS | uint8_t

The following channels are available for 1D profile:

Channel Index | Channel Type | Type
0 | E_FANSPEED | ENUM_FAN_SPEED_7STAGE
1 | S_RELHUM | float
2 | S_RELHUM_ABS | float
3 | S_TEMP | float
4 | F_BTN_PRESS | uint8_t

The following channels are available for 1E profile:

Channel Index | Channel Type | Type
0 | E_FANSPEED | ENUM_FAN_SPEED_7STAGE
1 | S_LUMINANCE | float
2 | S_VOLTAGE | float
3 | S_TEMP | float
4 | F_BTN_PRESS | uint8_t

The following channels are available for 1F profile:

Channel Index | Channel Type | Type | Comment
0 | E_FANSPEED | ENUM_FAN_SPEED_5STAGE |
1 | S_SETPOINT | float |
2 | S_TEMP | float |
3 | F_BTN_PRESS | uint8_t | Occupancy, OCCUPANCY
4 | F_BTN_PRESS | uint8_t | Unoccupancy, UNOCCUPANCY

The following channels are available for 20 profile:

Channel Index | Channel Type | Type
0 | S_SETPOINT | float
1 | S_TEMP | float
2 | E_STATE | ROP_SET_POINT_MODE
3 | F_POWERALARM | uint8_t
4 | F_HIGH_LOW | ROP_USER_ACTIVITY

The following channels are available for 21 profile:

Channel Index | Channel Type | Type
0 | S_SETPOINT | float
1 | S_RELHUM | float
2 | S_TEMP | float
3 | E_STATE | ROP_SET_POINT_MODE
4 | F_POWERALARM | uint8_t
5 | F_HIGH_LOW | ROP_USER_ACTIVITY

The following channels are available for 22 profile:

Channel Index | Channel Type | Type
0 | S_SETPOINT | float
1 | S_RELHUM | float
2 | S_TEMP | float
3 | E_FANSPEED | ENUM_FAN_SPEED_7STAGE

The following channels are available for 23 profile:

Channel Index | Channel Type | Type
0 | S_SETPOINT | float
1 | S_RELHUM | float
2 | S_TEMP | float
3 | E_FANSPEED | ENUM_FAN_SPEED_7STAGE
3 | F_OCCUPIED | uint8_t

Member Function Documentation

virtual eoReturn eoEEP_A510xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A510xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A510xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_A510xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A510xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A510xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A510xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A511xx Class Reference

Public Member Functions
eoEEP_A511xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a511 profiles. More...

#include <eoEEP_A511xx.h>

Inheritance diagram for eoEEP_A511xx:
[legend]
Collaboration diagram for eoEEP_A511xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a511 profiles.

Allows the user to handle EEP a511 profiles, the following profiles are available:

  • A5-11-01
  • A5-11-02
  • A5-11-03
  • A5-11-04
  • A5-11-05

The following channels are available for 01 profile:

Channel Index | Channel Type | Type | Comment
0 | S_LUMINANCE | float |
1 | S_LUMINANCE_ABS | float |
2 | S_DIMMING | float |
3 | F_ON_OFF | uint8_t | Repeater, CS_REPEATER
4 | F_ON_OFF | uint8_t | Power relay timer, CS_POWER_RELAY_TIMER
5 | F_ON_OFF | uint8_t | Daylight harvesting, CS_DAYLIGHT_HARVEST
6 | F_ON_OFF | uint8_t | Dimming, CS_DIMMING
7 | F_OPEN_CLOSED | uint8_t |
8 | F_BTN_PRESS | uint8_t |
9 | F_ON_OFF | uint8_t | Power relay, CS_POWER_RELAY

The following channels are available for 02 profile:

Channel Index | Channel Type | Type | Comment
0 | S_SETPOINT | float |
1 | E_FANSPEED | CS_FAN_STAGE |
2 | S_TEMP_ABS | float |
3 | F_ON_OFF | uint8_t | Alarm, CS_ALARM
4 | E_CONTROLLER_MODE | CS_ENUM_CONTROLLER_MODE |
5 | F_ON_OFF | uint8_t | Controller state, CS_CONTROLLER_STATE
6 | F_ON_OFF | uint8_t | Energy hold-off, CS_ENERGY_HOLDOFF
7 | E_OCCUPANCY | CS_ENUM_ROOM_OCCUPANCY |

The following channels are available for 03 profile:

Channel Index | Channel Type | Type | Comment
0 | S_SETPOINT | float |
1 | F_ON_OFF | uint8_t | Angle sign, CS_ANGLE_SIGN
2 | S_ANGLE | float |
3 | F_ON_OFF | uint8_t | Position value flag, CS_POSITION_VALUE
4 | F_ON_OFF | uint8_t | Angle value flag, CS_ANGLE_VALUE
5 | E_ERROR_STATE | CS_ENUM_03_ERROR_STATE |
6 | E_END_POS | CS_ENUM_END_POS |
7 | E_STATE | CS_ENUM_BLIND_STATE |
8 | F_ON_OFF | uint8_t | Service mode, CS_SETVICE_MODE
9 | F_ON_OFF | uint8_t | Mode of the position, CS_MODE_OF_POSITION

The following channels are available for 04 profile:

Channel Index | Channel Type | Type | Comment
0 | S_RGB | float | RGB Red, CS_RGB_RED
1 | S_RGB | float | RGB Green, CS_RGB_GREEN
2 | S_RGB | float | RGB Blue, CS_RGB_BLUE
3 | S_DIMMING | float |
4 | S_TIME | float |
5 | S_VALUE | float |
6 | E_UNITS | CS_ENERGY_UNITS |
7 | F_ON_OFF | uint8_t | Service mode, CS_SETVICE_MODE
8 | F_ON_OFF | uint8_t | Operating hours, CS_OPERATING_HOURS
9 | E_ERROR_STATE | CS_ENUM_04_ERROR_STATE |
10 | F_ON_OFF | uint8_t | Status, CS_STATUS

The following channels are available for 05 profile:

Channel Index | Channel Type | Type
0 | E_CONTROLLER_MODE | CS_WORKING_MODE
1 | E_STATE | CS_RELAY_STATUS

Member Function Documentation

eoChannelInfo* eoEEP_A511xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_A511xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A511xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A511xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A511xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A511xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A511xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A511xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A511xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A511xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A512xx Class Reference

Public Member Functions
eoEEP_A512xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a512 Automated meter reading (AMR) profiles. More...

#include <eoEEP_A512xx.h>

Inheritance diagram for eoEEP_A512xx:
[legend]
Collaboration diagram for eoEEP_A512xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a512 Automated meter reading (AMR) profiles.

Allows the user to handle EEP a512 Automated meter reading (AMR) profiles, the following profiles are available:

  • A5-12-00
  • A5-12-01 Electricity
  • A5-12-02 Gas
  • A5-12-03 Water
  • A5-12-04
  • A5-12-10

The following channels are available for Profile 0:

Channel Index | Channel Type | Type
0 | S_COUNTER | float
1 | S_VOLUME | float
2 | E_TARIFF | uint8_t

The following channels are available for Profile 01:

Channel Index | Channel Type | Type | Comment
0 | S_ENERGY | float |
1 | S_POWER | float | Unit is kWh
2 | E_TARIFF | uint8_t |

The following channels are available for Profile 02 and 03:

Channel Index | Channel Type | Type
0 | S_VOLFLOW | float
1 | S_VOLUME | float
2 | E_TARIFF | uint8_t

The following channels are available for Profile 04:

Channel Index | Channel Type | Type
0 | S_MASS | float
1 | S_TEMP | float
2 | E_STATE | BATTERY_LEVEL

The following channels are available for Profile 05:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | uint8_t | POSITION_LOCATION_0
1 | F_ON_OFF | uint8_t | POSITION_LOCATION_1
2 | F_ON_OFF | uint8_t | POSITION_LOCATION_2
3 | F_ON_OFF | uint8_t | POSITION_LOCATION_3
4 | F_ON_OFF | uint8_t | POSITION_LOCATION_4
5 | F_ON_OFF | uint8_t | POSITION_LOCATION_5
6 | F_ON_OFF | uint8_t | POSITION_LOCATION_6
7 | F_ON_OFF | uint8_t | POSITION_LOCATION_7
8 | F_ON_OFF | uint8_t | POSITION_LOCATION_8
9 | F_ON_OFF | uint8_t | POSITION_LOCATION_9
10 | S_TEMP | float |
11 | E_STATE | uint8_t |

The following channels are available for Profile 10:

Channel Index | Channel Type | Type
0 | S_AMPER_PER_HOUR | float
1 | S_CURRENT | float
2 | E_TARIFF | uint8_t

Member Function Documentation

virtual eoChannelInfo* eoEEP_A512xx::GetChannel ( CHANNEL_TYPE type )
virtual

Returns the channel for the selected type

Parameters:
type CHANNEL_TYPE
Returns:
Pointer to ChannelInfo or Null

Reimplemented from eoEEProfile.

eoChannelInfo* eoEEP_A512xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_A512xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A512xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A512xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A512xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A512xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A512xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A512xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A513xx Class Reference

Public Member Functions
eoEEP_A513xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a513 profiles. More...

#include <eoEEP_A513xx.h>

Inheritance diagram for eoEEP_A513xx:
[legend]
Collaboration diagram for eoEEP_A513xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
eoReturn | SetCommand (uint8_t cmd)
eoReturn | Parse (const eoMessage &m)
Parses a msg using learned in Profile from Device.
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a513 profiles.

Allows the user to handle EEP a513 profiles, the following profiles are available:

  • A5-13-01
  • A5-13-02
  • A5-13-03
  • A5-13-04
  • A5-13-05
  • A5-13-06
  • A5-13-07

The following channels are available for 01 profile:

Channel Index | Channel Type | Type | Comment
0 | S_LUMINANCE | float |
1 | S_TEMP | float |
3 | S_VELOCITY | float |
4 | F_DAY_NIGHT | uint8_t |
5 | F_ON_OFF | uint8_t | Rain/ no rain, RAIN_NORAIN

The following channels are available for 02 profile:

Channel Index | Channel Type | Type | Comment
0 | S_LUMINANCE | float | Sun West, SUN_WEST
1 | S_LUMINANCE | float | Sun South, SUN_SOUTH
2 | S_LUMINANCE | float | Sun East, SUN_EAST
5 | F_ON_OFF | EA_HEMISPHERE |

The following channels are available for 03 profile:

Channel Index | Channel Type | Type | Comment
0 | S_TIME | float | Time day, TIME_DAY
1 | S_TIME | float | Time month, TIME_MONTH
2 | S_TIME | float | Time year, TIME_YEAR
3 | F_ON_OFF | uint8_t | Time source

The following channels are available for 04 profile:

Channel Index | Channel Type | Type | Comment
0 | E_DAYS | EA_ENUM_DAYS |
1 | S_TIME | float | Time hour, TIME_HOUR
2 | S_TIME | float | Time minute, TIME_MINUTE
3 | S_TIME | float | Time second, TIME_SECOND
4 | F_ON_OFF | EA_TIME_SOURCE | Time source, TIME_SOURCE
5 | F_ON_OFF | EA_AM_PM | AM/PM, AM_PM
4 | F_ON_OFF | EA_TIME_FORMAT | Time format, TIME_FORMAT

The following channels are available for 05 profile:

Channel Index | Channel Type | Type | Comment
0 | S_ANGLE | float | Elevation, ELEVATION
1 | S_ANGLE | float | Azimuth, AZIMUTH

The following channels are available for 06 profile:

Channel Index | Channel Type | Type | Comment
0 | S_ANGLE | float | Latitude, LATITUDE
1 | S_ANGLE | float | Longitude, LONGITUDE

The following channels are available for 07 profile:

Channel Index | Channel Type | Type | Comment
0 | S_ANGLE | float | Elevation, ELEVATION
1 | F_DAY_NIGHT | uint8_t |
2 | S_ANGLE | float | Azimuth, AZIMUTH
3 | S_SOLAR_RAD | float |

Member Function Documentation

eoChannelInfo* eoEEP_A513xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

eoReturn eoEEP_A513xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_A513xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A513xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A513xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A513xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A513xx::SetCommand ( uint8_t cmd )

Sets and checks if the specified command is supported

Parameters:
cmd
Returns:
eoReturn EO_OK or NOT_SUPPORTED
eoReturn eoEEP_A513xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

eoReturn eoEEP_A513xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_A513xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A513xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A513xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A514xx Class Reference

Public Member Functions
eoEEP_A514xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a514 profiles. More...

#include <eoEEP_A514xx.h>

Inheritance diagram for eoEEP_A514xx:
[legend]
Collaboration diagram for eoEEP_A514xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a514 profiles.

Allows the user to handle EEP a514 profiles, the following profiles are available:

  • A5-14-01
  • A5-14-02
  • A5-14-03
  • A5-14-04
  • A5-14-05
  • A5-14-06

The following channels are available for 01 profile:

Channel Index | Channel Type | Type
0 | S_VOLTAGE | float
1 | F_OPEN_CLOSED | uint8_t

The following channels are available for 02 profile:

Channel Index | Channel Type | Type
0 | S_VOLTAGE | float
1 | S_LUMINANCE | float
2 | F_OPEN_CLOSED | uint8_t

The following channels are available for 03 profile:

Channel Index | Channel Type | Type
0 | S_VOLTAGE | float
1 | F_VIBRATION | uint8_t
2 | F_OPEN_CLOSED | uint8_t

The following channels are available for 04 profile:

Channel Index | Channel Type | Type
0 | S_VOLTAGE | float
1 | S_LUMINANCE | float
2 | F_VIBRATION | uint8_t
3 | F_OPEN_CLOSED | uint8_t

The following channels are available for 05 profile:

Channel Index | Channel Type | Type
0 | S_VOLTAGE | float
1 | F_VIBRATION | uint8_t

The following channels are available for 06 profile:

Channel Index | Channel Type | Type
0 | S_VOLTAGE | float
1 | S_LUMINANCE | float
2 | F_VIBRATION | uint8_t

Member Function Documentation

eoReturn eoEEP_A514xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_A514xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

eoReturn eoEEP_A514xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A520xx Class Reference

Public Member Functions
eoEEP_A520xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a520 profiles. More...

#include <eoEEP_A520xx.h>

Inheritance diagram for eoEEP_A520xx:
[legend]
Collaboration diagram for eoEEP_A520xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subFlag)
virtual eoChannelInfo * | GetOutChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetOutChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetOutChannel (uint8_t channelNumber)
eoReturn | SetDirection (HVCA_DIRECTION direction)
virtual eoReturn | SetDirection (SIMPLE_DIRECTION directionToSet)
virtual void | ClearValues ()
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Additional Inherited Members

- Protected Attributes inherited from eoISimpleBidirectionalProfile
SIMPLE_DIRECTION direction

Detailed Description

The class to handle EEP a520 profiles.

Allows the user to handle EEP a520 profiles, the following profiles are available:

  • A5-20-01 (two directions)
  • A5-20-02 (two directions)
  • A5-20-03 (two directions)
  • A5-20-04 (two directions)
  • A5-20-10 (two directions)
  • A5-20-11 (two directions)
  • A5-20-12

    DIRECTION-1 = Transmit mode: Message from the actuator to the controller DIRECTION-2 = Receive mode: Commands from the controller to the actuator
    Note:
    In Old EnOcean Link Version the direction could be set with E_DIRECTION, it is recommended with the new version to use after initializing the profile the SetDirection Function to set once the direction of the profile. The Profile interprets then the received data always as direction y and transmit data always with the direction x.
    The following channels are available for 01 profile, direction 1:
    Channel Index | Channel Type | Type | Comment
    0 | S_SETPOINT | float
    1 | F_ON_OFF | uint8_t | Service on, SERVICE_ON
    2 | F_ON_OFF | uint8_t | Energy input, ENERGY_INPUT
    3 | F_ON_OFF | uint8_t | Energy storage, ENERGY_STORAGE
    4 | F_ON_OFF | uint8_t | Battery capacity, BATTERY_CAPACITY
    5 | F_ON_OFF | uint8_t | Contact cover, CONTACT_COVER
    6 | F_ON_OFF | uint8_t | Temperature sensor failure, TEMPERATURE_FAIL
    7 | F_ON_OFF | uint8_t | Detection, window open, WINDOW_DETECTION
    8 | F_ON_OFF | uint8_t | Actuator obstructed, ACTUATOR_OBSTRUCTED
    9 | S_TEMP | float

    The following channels are available for 01 profile, direction 2:
    Channel Index | Channel Type | Type | Comment
    0 | S_SETPOINT | float
    1 | S_TEMP_ABS | float
    2 | S_TEMP | float
    3 | F_ON_OFF | uint8_t | Run init sequence, RUN_INTI_SEQ
    4 | F_ON_OFF | uint8_t | Lift set, LIFT_SET
    5 | F_ON_OFF | uint8_t | Valve open, VALVE_OPEN
    6 | F_ON_OFF | uint8_t | Valve closed, VALVE_CLOSED
    7 | F_ON_OFF | uint8_t | Summer bit, SUMMER_BIT
    8 | F_ON_OFF | uint8_t | Set point selection, SET_POINT_SELECTION
    9 | F_ON_OFF | uint8_t | Set point inverse, SET_POINT_INVERSE
    10 | F_ON_OFF | uint8_t | Select function, SELECT_FUNCTION

    The following channels are available for 02 profile, direction 1:
    Channel Index | Channel Type | Type | Comment
    0 | S_PERCENTAGE | float
    1 | F_ON_OFF | uint8_t | Set point inverse, SET_POINT_INVERSE

    The following channels are available for 02 profile, direction 2:
    Channel Index | Channel Type | Type | Comment
    0 | S_SETPOINT | float
    1 | F_ON_OFF | uint8_t | Set point inverse, SET_POINT_INVERSE

    The following channels are available for 03 profile, direction 1:
    Channel Index | Channel Type | Type
    0 | S_SETPOINT | float
    1 | S_TEMP | float

    The following channels are available for 03 profile, direction 2:
    Channel Index | Channel Type | Type | Comment
    0 | S_SETPOINT | float
    1 | S_TEMP_ABS | float
    2 | S_TEMP | float
    3 | F_ON_OFF | uint8_t | Set point selection, SET_POINT_SELECTION
    4 | F_ON_OFF | uint8_t | Set point inverse, SET_POINT_INVERSE

    The following channels are available for 04 profile, direction 1:
    Channel Index | Channel Type | Type | Comment
    0 | S_PERCENTAGE | float
    1 | S_TEMP | float | FEED_TEMP
    2 | S_TEMP_ABS | float
    3 | S_TEMP | float | CURRENT_TEMP
    4 | E_ERROR_STATE | uint8_t
    5 | F_ON_OFF | HVCA_MEASUREMENT_STATUS | MEASUREMENT_STATUS
    6 | F_ON_OFF | HVCA_STATUS_REQUEST | STATUS_REQUEST
    7 | F_ON_OFF | HVCA_BUTTON_LOCK | BUTTON_LOCK
    8 | F_ON_OFF | HVCA_TEMP_SELECTION | TEMP_SELECTION
    9 | F_ON_OFF | HVCA_FAILURE | FAILURE

    The following channels are available for 04 profile, direction 2:
    Channel Index | Channel Type | Type | Comment
    0 | S_PERCENTAGE | float
    1 | S_TEMP_ABS | float
    2 | F_ON_OFF | HVCA_MEASUREMENT_CONTROL | MEASUREMENT_CONTROL
    3 | E_STATE | HVCA_WAKEUP_CYCLE | WAKEUP_CYCLE
    4 | E_STATE | HVCA_DISPLAY_ORIENTATION | DISPLAY_ORIENTATION
    0 | F_ON_OFF | HVCA_MEASUREMENT_STATUS | BUTTON_LOCK
    1 | E_COMMAND | HVCA_SERVICE_COMMAND

    The following channels are available for 10 profile, direction 1, 2:
    Channel Index | Channel Type | Type | Comment
    0 | E_CONTROLLER_MODE | HVAC_MODE
    1 | E_END_POS | HVCA_VANE_POSITION
    2 | E_FANSPEED | HVCA_FANSPEED
    3 | S_SETPOINT | float
    4 | E_OCCUPANCY | HVCA_ROOM_OCCUPANCY
    5 | F_ON_OFF | uint8_t | On/Off, ON_OFF

    The following channels are available for 11 profile, direction 1:
    Channel Index | Channel Type | Type | Comment
    0 | F_ON_OFF | uint8_t | External disablement, EXTERNAL_DISABLEMENT
    1 | F_ON_OFF | uint8_t | Remote controller disablement, DISABLE_REMOTE_CONTROL
    2 | F_OPEN_CLOSED | uint8_t

    The following channels are available for 11 profile, direction 2:
    Channel Index | Channel Type | Type | Comment
    0 | S_ERROR_CODE | float
    1 | F_ON_OFF | uint8_t | Other disablement, OTHER_DISABLEMENT
    2 | F_ON_OFF | uint8_t | Window contact disablement, WINDOW_DISABLEMENT
    3 | F_ON_OFF | uint8_t | Key card disablement, KEYCARD_DISABLEMENT
    4 | F_ON_OFF | uint8_t | External disablement, EXTERNAL_DISABLEMENT
    5 | F_ON_OFF | uint8_t | Remote controller disablement, DISABLE_REMOTE_CONTROL
    6 | F_OPEN_CLOSED | uint8_t
    7 | F_ON_OFF | uint8_t | Alarm state, ALARM_STATE

    The following channels are available for 12 profile:
    Channel Index | Channel Type | Type | Comment
    0 | S_PERCENTAGE | float
    1 | E_FANSPEED | HVCA_FANSPEED
    2 | S_SETPOINT | float
    3 | F_ON_OFF | uint8_t | Fan override, FAN_OVERRIDE
    4 | E_CONTROLLER_MODE | HVCA_CONTROLLER_MODE
    5 | F_ON_OFF | uint8_t | Controller state, CONTROLLER_STATE
    7 | F_ON_OFF | uint8_t | Energy hold-off, ENERGY_HOLDOFF
    7 | E_OCCUPANCY | HVCA_ROOM_OCCUPANCY_TYPE_20

Member Function Documentation

virtual void eoEEP_A520xx::ClearValues ( )
virtual

All raw values of the internal Message will be set to zero.

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A520xx::Create ( eoMessage & m )
virtual

Generates an EEP Message.

This functions generates a Message for the specified EEP, with the current ChannelInfo values

Parameters:
m Reference to the Message (will be cleared and generated new)
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoChannelInfo* eoEEP_A520xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoChannelInfo* eoEEP_A520xx::GetOutChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

Returns the outChannel for the selected type and subtype

Parameters:
type | CHANNEL_TYPE
subType | is either the numeric "subChannelNUmber" (temperature CHannel 0,1,2,3) or a specified keyword for it(see profile)
Returns:
Pointer to Channel

Reimplemented from eoISimpleBidirectionalProfile.

virtual eoChannelInfo* eoEEP_A520xx::GetOutChannel ( CHANNEL_TYPE type )
virtual

Returns the outChannel for the selected type

Parameters:
type CHANNEL_TYPE
Returns:
Pointer to ChannelInfo or Null

Implements eoISimpleBidirectionalProfile.

virtual eoChannelInfo* eoEEP_A520xx::GetOutChannel ( uint8_t channelNumber )
virtual

returns the pointer to eoChannelInfo for the selected outChannelNumber or NULL

Parameters:
channelNumber
Returns:
Pointer to Channel

Implements eoISimpleBidirectionalProfile.

eoReturn eoEEP_A520xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_A520xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A520xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A520xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A520xx::SetDirection ( HVCA_DIRECTION direction )

Sets the direction for this profile

Note:
Deprecated funtion, the function from the Interface using the ::SIMPLE_DIRECTION should be used.
Parameters:
direction
Returns:
virtual eoReturn eoEEP_A520xx::SetDirection ( SIMPLE_DIRECTION direction )
virtual

Set the direction of the profile, if the specific profile does not support Bidirectional mode, nothing happens.

Parameters:
direction

Implements eoISimpleBidirectionalProfile.

eoReturn eoEEP_A520xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

eoReturn eoEEP_A520xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_A520xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A520xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A520xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A530xx Class Reference

Public Member Functions
eoEEP_A530xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a530 profiles. More...

#include <eoEEP_A530xx.h>

Inheritance diagram for eoEEP_A530xx:
[legend]
Collaboration diagram for eoEEP_A530xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a530 profiles.

Allows the user to handle EEP a530 profiles, the following profiles are available:

  • A5-30-01
  • A5-30-02
  • A5-30-03
  • A5-30-04
  • A5-30-05
  • A5-30-06
    The following channels are available for 01 Profile:
    Channel Index | Channel Type | Type
    0 | F_ON_OFF | uint8_t
    1 | S_VOLTAGE | A530_BATTERY_VALUE

The following channels are available for 02 Profile:

Channel Index | Channel Type | Type
0 | F_ON_OFF | uint8_t

The following channels are available for 03 Profile:

Channel Index | Channel Type | Type | Comment
0 | S_TEMP | float |
1 | F_HIGH_LOW | A530_BATTERY_VALUE | STATUS_WAKE
2 | F_HIGH_LOW | A530_BATTERY_VALUE | DIGITAL_IN_3
3 | F_HIGH_LOW | A530_BATTERY_VALUE | DIGITAL_IN_2
4 | F_HIGH_LOW | A530_BATTERY_VALUE | DIGITAL_IN_1
5 | F_HIGH_LOW | A530_BATTERY_VALUE | DIGITAL_IN_0

The following channels are available for 04 Profile:

Channel Index | Channel Type | Type | Comment
0 | S_VALUE | float |
1 | F_HIGH_LOW | A530_BATTERY_VALUE | DIGITAL_IN_2
2 | F_HIGH_LOW | A530_BATTERY_VALUE | DIGITAL_IN_1
3 | F_HIGH_LOW | A530_BATTERY_VALUE | DIGITAL_IN_0

The following channels are available for 05 Profile:

Channel Index | Channel Type | Type
0 | S_VOLTAGE | float
1 | F_ON_OFF | A530_SIGNAL_TYPE
2 | S_COUNTER | float

The following channels are available for 06 Profile:

Channel Index | Channel Type | Type | Comment
0 | E_KEY_DATA | uint8_t | KEY_DATA_1
1 | E_KEY_DATA | uint8_t | KEY_DATA_2
2 | E_KEY_DATA | uint8_t | KEY_DATA_3
3 | E_KEY_DATA | uint8_t | KEY_DATA_4
4 | E_KEY_DATA | uint8_t | KEY_DATA_5
5 | E_KEY_DATA | uint8_t | KEY_DATA_6
6 | S_VOLTAGE | float |

Member Function Documentation

eoChannelInfo* eoEEP_A530xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_A530xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A530xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A530xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A530xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A530xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A530xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A530xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A537xx Class Reference

Public Member Functions
eoEEP_A537xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a537 profiles. More...

#include <eoEEP_A537xx.h>

Inheritance diagram for eoEEP_A537xx:
[legend]
Collaboration diagram for eoEEP_A537xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a537 profiles.

Allows the user to handle EEP a537 profiles, the following profiles are available:

  • A5-37-01
    The following channels are available:
    Channel Index | Channel Type | Type | Comment
    0 | S_SETPOINT | float
    1 | F_ON_OFF | uint8_t | Absolute/relative power usage, ABS_REL_POWER
    2 | S_PERCENTAGE | float
    3 | S_TIME | float
    4 | S_VALUE | float
    5 | F_ON_OFF | uint8_t | Random start delay, RAND_START_DELAY
    6 | F_ON_OFF | uint8_t | Randomized end delay, RAND_END_DELAY
    7 | F_ON_OFF | uint8_t | Max/min power usage, MAX_MIN_POWER

Member Function Documentation

eoChannelInfo* eoEEP_A537xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_A537xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A537xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A537xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A537xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A537xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A537xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A537xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_A538xx Class Reference

Public Member Functions
eoEEP_A538xx Class Reference
EEP2.6 Profiles API

The class to handle EEP a538 profiles. More...

#include <eoEEP_A538xx.h>

Inheritance diagram for eoEEP_A538xx:
[legend]
Collaboration diagram for eoEEP_A538xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
eoReturn | SetCommand (uint8_t cmd)
eoReturn | Parse (const eoMessage &m)
Parses a msg using learned in Profile from Device.
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP a538 profiles.

Allows the user to handle EEP a538 profiles, the following profiles are available:

  • A5-38-08
  • A5-38-09

NOTE: set the command ID.

The following channels are available in Switching:

Channel Index | Channel Type | Type | Comment
0 | S_TIME | float |
1 | F_ON_OFF | uint8_t | Lock/Unlock, CC_LOCK_UNLOCK
2 | F_ON_OFF | uint8_t | Delay or duration, CC_DELAY_DURATION
3 | F_ON_OFF | uint8_t | Switching command, CC_SWITCHING_COMMAND

The following channels are available in Dimming:

Channel Index | Channel Type | Type | Comment
0 | S_DIMMING | float |
1 | S_TIME | float |
2 | F_ON_OFF | uint8_t | Dimming range, CC_DIMMING_RANGE
3 | F_ON_OFF | uint8_t | Store final value, CC_STORE_FINAL_VAL
4 | F_ON_OFF | uint8_t | Switching command, CC_SWITCHING_COMMAND

The following channels are available in Setpoint shift:

Channel Index | Channel Type | Type
0 | S_SETPOINT | float

The following channels are available in Basic Setpoint:

Channel Index | Channel Type | Type
0 | S_TEMP_ABS | float

The following channels are available in Control variable:

Channel Index | Channel Type | Type | Comment
0 | S_SETPOINT | float |
1 | E_CONTROLLER_MODE | CC_CONTROLLER_MODE |
2 | F_ON_OFF | uint8_t | Controller state, CC_CONTROLLER_STATE
3 | F_ON_OFF | uint8_t | Energy hold-off, CC_ENERGY_HOLDOFF
4 | E_OCCUPANCY | CC_ROOM_OCCUPANCY |

The following channels are available in Fan stage:

Channel Index | Channel Type | Type
0 | E_FANSPEED |

The following channels are available in Central Command:

Channel Index | Channel Type | Type | Comment
0 | S_PERCENTAGE | float | Blind position, CC_BLIND_POSITION
1 | S_ANGLE | float | Blind angle, CC_ANGLE_BLIND_POSITION
2 | S_TIME | float | Blind open position, CC_BLIND_OPEN_POSITION
3 | S_TIME | float | Blind open angle, CC_BLIND_OPEN_ANGLE
4 | S_TIME | float | Blind close position, CC_BLIND_CLOSE_POSITION
5 | S_TIME | float | Blind close angle, CC_BLIND_CLOSE_ANGLE
6 | S_TIME | float | Runtime value to close, CC_RUNTIME_CLOSE
7 | S_TIME | float | Runtime value to open, CC_RUNTIME_OPEN
8 | S_TIME | float | Sunblind reversion time, CC_SUNBLIND_REVERSION
9 | S_PERCENTAGE | float | Set minimum position, CC_SET_MIN_POSITION
10 | S_PERCENTAGE | float | Set maximum position, CC_SET_MAX_POSITION
11 | S_ANGLE | float | Fully shut angle, CC_FULLY_SHUT_ANGLE
12 | S_ANGLE | float | Fully open angle, CC_FULLY_OPEN_ANGLE
13 | F_ON_OFF | uint8_t | Position logic, CC_POSITION_LOGIC
14 | E_USER_ACTION | CC_FUNCTIONS |
15 | F_ON_OFF | uint8_t | Send status flag
16 | F_ON_OFF | uint8_t | Position and angle flag
17 | F_ON_OFF | uint8_t | Service mode flag

The following channels are available in Extended Lightning control:

Channel Index | Channel Type | Type | Comment
1 | S_TIME | float | Up ramping time, CC_UP_RAMPING_TIME
2 | S_TIME | float | Down ramping time, CC_DOWN_RAMPING_TIME
3 | S_DIMMING | float | Dimming value, CC_DIMMING_VALUE
4 | S_TIME | float | Set ramping time, CC_SET_RAMPING_TIME
5 | S_RGB | float | RGB red, CC_RGB_RED
6 | S_RGB | float | RGB green, CC_RGB_GREEN
7 | S_RGB | float | RGB blue, CC_RGB_BLUE
8 | F_ON_OFF | uint8_t | Scene function, CC_SCENE
9 | S_VALUE | float | Scene number, CC_SCENE_NUMBER
10 | S_DIMMING | float | Minimum dimming value, CC_MIN_DIM_VALUE
11 | S_DIMMING | float | Maximum dimming value, CC_MAX_DIM_VALUE
12 | S_TIME | float | Lamp operating hours, CC_LAMP_OPERATING_HOUR
13 | E_STATE | CC_LOCKING_OPERATIONS |
14 | S_VALUE | float | Energy metering value, CC_ENERGY_METERING_VALUE
15 | E_UNITS | CC_ENERGY_UNITS |
16 | E_USER_ACTION | CC_FUNCTIONS |
17 | F_ON_OFF | uint8_t | Send status flag, CC_SEND_STATUS
18 | F_ON_OFF | uint8_t | Store final value, CC_STORE_FINAL_VAL
19 | F_ON_OFF | uint8_t | Service mode flag, CC_SERVICE_MODE

Member Function Documentation

eoChannelInfo* eoEEP_A538xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_A538xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A538xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A538xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A538xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A538xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_A538xx::SetCommand ( uint8_t cmd )

Sets and checks if the specified command is supported

Parameters:
cmd
Returns:
eoReturn EO_OK or NOT_SUPPORTED
eoReturn eoEEP_A538xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A538xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A538xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_A538xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

virtual eoReturn eoEEP_A538xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D200xx Class Reference

Public Member Functions
eoEEP_D200xx Class Reference
EEP2.6 Profiles API

The class to handle EEP D200 profiles. More...

#include <eoEEP_D200xx.h>

Inheritance diagram for eoEEP_D200xx:
[legend]
Collaboration diagram for eoEEP_D200xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
eoEEP_D200xx (uint16_t size=10)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
virtual eoReturn | SetCommand (uint8_t cmd)
- Public Member Functions inherited from eoD2EEProfile
eoD2EEProfile (uint16_t size=4)
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP D200 profiles.

Allows the user to handle EEP D200 profiles, the following profiles are available:

  • D2-00-01

NOTE: set command before using the profile.

The following channels are available in First User Action on RCP:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | uint8_t | Valid configuration, RCP_CONFIG_VALID
1 | E_USER_ACTION | RCP_USER_ACTION |

The following channels are available in Display Content:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | uint8_t | User notification, RCP_USER_NOTIFICATION
1 | F_OPEN_CLOSED | uint8_t |
2 | F_ON_OFF | uint8_t | Dew point, RCP_DEW_POINT
3 | F_ON_OFF | uint8_t | Cooling, RCP_COOLING
4 | F_ON_OFF | uint8_t | Heating, RCP_HEATING
5 | S_TEMP | float | Room temperature °C, RCP_ROOM_TEMPERATURE_C
6 | S_TEMP | float | Room temperature °F, RCP_ROOM_TEMPERATURE_F
7 | S_TEMP | float | Nominal temperature °C, RCP_NOMINAL_TEMPERATURE_C
8 | S_TEMP | float | Nominal temperature °F, RCP_NOMINAL_TEMPERATURE_F
9 | S_TEMP_ABS | float | Delta Temperature Set Point °C, RCP_DELTA_TEMP_SETPOINT_C
10 | S_TEMP_ABS | float | Delta Temperature Set Point °F, RCP_DELTA_TEMP_SETPOINT_F
11 | S_TEMP_ABS | float | Delta Temperature Set Point (graphical), RCP_DELTA_TEMP_GRAPHIC
12 | S_TIME | float | Hours in 24h format, RCP_TIME_24_HOURS
13 | S_TIME | float | AM hours in 12h format, RCP_TIME_AM_HOURS
14 | S_TIME | float | PM hours in 12h format, RCP_TIME_PM_HOURS
15 | S_TIME | float | Date [DD.MM], RCP_TIME_DAY_MONTH
16 | S_TIME | float | Date [MM.DD], RCP_TIME_MONTH_DAY
17 | S_LUMINANCE | float |
18 | S_PERCENTAGE | float |
19 | S_CONC | float |
20 | S_RELHUM | float |
21 | F_ON_OFF | uint8_t | Fan manual, RCP_FAN_MANUAL
22 | E_FANSPEED | RCP_5_LEVEL_FANSPEED |
23 | F_ON_OFF | uint8_t | More data will follow, RCP_MORE_DATA

The following channels are available in Repeated User Action on RCP:

Channel Index | Channel Type | Type
0 | S_TEMP_ABS | float
1 | E_PRESENCE | RCP_PRESENCE
2 | E_FANSPEED | RCP_6_LEVEL_FANSPEED

The following channels are available in Measurement result:

Channel Index | Channel Type | Type
0 | S_TEMP | float

The following channels are available in Sensor configuration:

Channel Index | Channel Type | Type | Comment
0 | S_TEMP_ABS | float | Temperature difference between two subsequent measurements to trigger a Message Type D
1 | S_TIME | float | Keep alive timing, RCP_KEEP_ALIVE_TIME
2 | E_PRESENCE | uint8_t | User defined
3 | E_FANSPEED | uint8_t | User defined
4 | S_TIME | float | Temperature measurement timing, RCP_TEMP_MEASUREMENT_TIMING
5 | S_SETPOINT | float | Set pointSteps, RCP_SETPOINT_STEPS
6 | S_SETPOINT | float | Set point range limit, RCP_SETPOINT_RANGE_LIMIT
7 | F_ON_OFF | uint8_t | More data will follow, RCP_MORE_DATA

Constructor & Destructor Documentation

eoEEP_D200xx::eoEEP_D200xx ( uint16_t size = 10 )

Constructor with message size

Parameters:
size

Member Function Documentation

eoChannelInfo* eoEEP_D200xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_D200xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D200xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D200xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D200xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D200xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D200xx::SetCommand ( uint8_t cmd )
virtual

Sets and checks if the specified command is supported

Parameters:
cmd
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D200xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D200xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D200xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D200xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D200xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D201xx Class Reference

Public Member Functions
eoEEP_D201xx Class Reference
EEP2.6 Profiles API

The class to handle EEP D201 profiles. More...

#include <eoEEP_D201xx.h>

Inheritance diagram for eoEEP_D201xx:
[legend]
Collaboration diagram for eoEEP_D201xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
eoEEP_D201xx (uint16_t size=10)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
virtual eoReturn | SetLength (uint8_t type)
virtual eoReturn | SetCommand (uint8_t cmd)
- Public Member Functions inherited from eoD2EEProfile
eoD2EEProfile (uint16_t size=4)
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP D201 profiles.

Allows the user to handle EEP D201 profiles, the following profiles are available:

  • D2-01-00
  • D2-01-01
  • D2-01-02
  • D2-01-03
  • D2-01-04
  • D2-01-05
  • D2-01-06
  • D2-01-07
  • D2-01-08
  • D2-01-09
  • D2-01-0A
  • D2-01-0B
  • D2-01-10
  • D2-01-11
  • D2-01-12

NOTE: set command before using the profile.

The following channels are available in Actuator Set Output:

Channel Index | Channel Type | Type
0 | E_DIM_VALUE | VLD_DIM_VALUE
1 | E_IO_CHANNEL | VLD_IO_CHANNEL
2 | S_PERCENTAGE | float

The following channels are available in Actuator Set Local:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | uint8_t | Taught in devices, TAUGHT_IN_DEVICES
1 | F_ON_OFF | uint8_t | Over current shut down, OVER_CURRENT_SHUT
2 | F_ON_OFF | uint8_t | Reset over current shut down, RESET_OVER_CURRENT
3 | F_ON_OFF | uint8_t | Local control, LOCAL_CONTROL
4 | E_IO_CHANNEL | VLD_IO_CHANNEL |
5 | S_TIME | float | Dimming timer medium, DIMMING_MEDIUM
6 | S_TIME | float | Dimming timer slow, DIMMING_SLOW
7 | F_ON_OFF | uint8_t | User interface indication, USER_INDICATION
8 | E_STATE | VLD_DEFAULT_STATE |
9 | S_TIME | float | Dimming timer fast, DIMMING_FAST

The following channels are available in Actuator Status Query:

Channel Index | Channel Type | Type
0 | E_IO_CHANNEL | VLD_IO_CHANNEL

The following channels are available in Actuator Status Response:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | uint8_t | Over current switch off, OVER_CURRENT_SHUT
1 | E_ERROR_STATE | VLD_ERROR_LEVEL |
2 | E_IO_CHANNEL | VLD_IO_CHANNEL |
3 | F_ON_OFF | uint8_t | Local control, LOCAL_CONTROL
4 | S_PERCENTAGE | float |

The following channels are available in Actuator Set Measurement:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | uint8_t | Report measurement, REPORT_MEASUREMENT
1 | F_ON_OFF | uint8_t | Reset measurement, RESET_MEASUREMENT
2 | F_ON_OFF | uint8_t | Measurement mode, MEASUREMENT_MODE
3 | E_IO_CHANNEL | VLD_IO_CHANNEL |
4 | S_POWER | float | Power in W, POWER_W
5 | S_POWER | float | Power in kW, POWER_KW
6 | S_ENERGY | float | Energy in Ws, ENERGY_WS
7 | S_ENERGY | float | Energy in Wh, ENERGY_WH
8 | S_ENERGY | float | Energy in kWh, ENERGY_KWH
9 | S_TIME | float | Maximum time between two subsequent Actuator, MAX_SUB_TIME
10 | S_TIME | float | Minimum time between two subsequent Actuator, MIN_SUB_TIME

The following channels are available in Actuator Measurement Query:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | uint8_t | Query, QUERY
1 | E_IO_CHANNEL | VLD_IO_CHANNEL |

The following channels are available in Actuator Measurement Response:

Channel Index | Channel Type | Type | Comment
0 | E_IO_CHANNEL | VLD_IO_CHANNEL |
1 | S_POWER | float | Power in W, POWER_W
2 | S_POWER | float | Power in kW, POWER_KW
3 | S_ENERGY | float | Energy in Ws, ENERGY_WS
4 | S_ENERGY | float | Energy in Wh, ENERGY_WH
5 | S_ENERGY | float | Energy in kWh, ENERGY_KWH

The following channels are available in Actuator Set Pilot Wire Mode:

Channel Index | Channel Type | Type
0 | E_CONTROLLER_MODE | VLD_PILOTWIRE_MODE

The following channels are available in Actuator Pilot Wire Mode Query: | Channel Index | Channel Type | Type | |:-------------:|:------------:|:----:|

The following channels are available in Actuator Set Pilot Wire Response:

Channel Index | Channel Type | Type
0 | E_CONTROLLER_MODE | VLD_PILOTWIRE_MODE

Allows the user to handle EEP D201 profiles, the following profiles are available:

  • D2-50-00
  • D2-50-01
  • D2-50-10
  • D2-50-11

NOTE: set command before using the profile.

The following channels are available in Ventilation Remote Transmission Request:

Channel Index | Channel Type | Type | Note
0 | E_CONTROLLER_MODE | D250_REQUESTED_MSG_TYPE | REQUESTED_MSG_TYPE

The following channels are available in Ventilation Control:

Channel Index | Channel Type | Type | Note
0 | E_CONTROLLER_MODE | D250_REQUESTED_MSG_TYPE | REQUESTED_MSG_TYPE
1 | E_CONTROLLER_MODE | D250_OP_MODE | OP_MODE
2 | E_CONTROLLER_MODE | D250_AIRFLAP_BYPASS | HEAT_EXCHANGE_CTRL
3 | F_ON_OFF | uint8_t | TIMER_OP_CTRL
4 | S_PERCENTAGE | float | CO2_TRHESHOLD
5 | S_RELHUM | float |
6 | S_PERCENTAGE | float | AIR_QUALITY_TRHESHOLD
7 | S_TEMP | float | ROOM_TEMP

The following channels are available in Ventilation Basic Status:

Channel Index | Channel Type | Type | Note
0 | E_CONTROLLER_MODE | D250_OP_MODE | OP_MODE_CTRL
1 | F_ON_OFF | uint8_t | SAFTEY_MODE
2 | F_ON_OFF | uint8_t | HEAT_EXCHANGE_CTRL
3 | F_ON_OFF | uint8_t | SUPPLY_AIR_POS
4 | F_ON_OFF | uint8_t | EXHAUST_AIR_POS
5 | F_ON_OFF | uint8_t | DEFROST_MODE
6 | F_ON_OFF | uint8_t | COOLING_PROTECTION
7 | F_ON_OFF | uint8_t | OUTDOOR_HEATER_STATUS
8 | F_ON_OFF | uint8_t | SUPPLY_HEATER_STATUS
9 | F_ON_OFF | uint8_t | DRAIN_HEATER_STATUS
10 | F_ON_OFF | uint8_t | TIMER_OP_CTRL_STATUS
11 | F_ON_OFF | uint8_t | FILTER_MAINTENANCE
12 | F_ON_OFF | uint8_t | WEEKLY_PROGRAM
13 | F_ON_OFF | uint8_t | ROOM_TEMP_CTRL
14 | S_PERCENTAGE | float | AIR_QUALITY_1
15 | F_ON_OFF | uint8_t | MASTER_SLAVE_CONFIG
16 | S_PERCENTAGE | float | AIR_QUALITY_2
17 | S_TEMP | float | OUTDOOR_TEMP
18 | S_TEMP | float | SUPPLY_TEMP
19 | S_TEMP | float | INDOOR_TEMP
20 | S_TEMP | float | EXHAUST_TEMP
21 | S_VOLFLOW | float | SUPPLY_FAN_RATE
22 | S_VOLFLOW | float | EXHAUST_FAN_RATE
23 | S_ROTATION_PER_MIN | float | SUPPLY_FAN_SPEED
24 | S_ROTATION_PER_MIN | float | EXHAUST_FAN_SPEED

The following channels are available in Ventilation Extended Status:

Channel Index | Channel Type | Type | Note
0 | S_VALUE | float | SW_VERSION
1 | S_TIME | float |
2 | S_VALUE | float | DIGITAL_INPUT_STATUS
3 | S_VALUE | float | DIGITAL_OUTPUT_STATUS
4 | S_VALUE | float | INFO_MSG_STATUS
5 | S_VALUE | float | FAULT_STATUS

Constructor & Destructor Documentation

eoEEP_D201xx::eoEEP_D201xx ( uint16_t size = 10 )

Constructor with message size

Parameters:
size

Member Function Documentation

eoChannelInfo* eoEEP_D201xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_D201xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D201xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D201xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D201xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D201xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D201xx::SetCommand ( uint8_t cmd )
virtual

Sets and checks if the specified command is supported

Parameters:
cmd
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D201xx::SetLength ( uint8_t type )
virtual

Sets the channels and length

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED
eoReturn eoEEP_D201xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D201xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D201xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D201xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D201xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D202xx Class Reference

Public Member Functions
eoEEP_D202xx Class Reference
EEP2.6 Profiles API

The class to handle EEP D202 profiles. More...

#include <eoEEP_D202xx.h>

Inheritance diagram for eoEEP_D202xx:
[legend]
Collaboration diagram for eoEEP_D202xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
eoEEP_D202xx (uint16_t size=10)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | SetCommand (uint8_t cmd)
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
- Public Member Functions inherited from eoD2EEProfile
eoD2EEProfile (uint16_t size=4)
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP D202 profiles.

Allows the user to handle EEP D202 profiles, the following profiles are available:

  • D2-02-00
  • D2-02-01
  • D2-02-02

NOTE: set the command ID before using the profile.

The following channels are available in Sensor measurement:

Channel Index | Channel Type | Type
0 | S_TEMP | float
1 | S_LUMINANCE | float
2 | F_OCCUPIED | uint8_t
3 | E_STATE | VLD_SMOKE_DETECTION

The following channels are available in Sensor test/trigger:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | uint8_t | Self-test, VLD_SELF_TEST
1 | F_ON_OFF | uint8_t | Trigger alarm, VLD_TRIGGER_ALARM

The following channels are available in Actuator set measurement:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | uint8_t | Report measurement, VLD_REPORT_MEASUREMENT
1 | S_TEMP_ABS | float |
2 | S_LUMINANCE_ABS | float |
3 | S_TIME | float | Maximum time between two subsequent Actuator, VLD_MAX_TIME
4 | S_TIME | float | Minimum time between two subsequent Actuator, VLD_MIN_TIME

The following channels are available in Sensor measurement query:

Channel Index | Channel Type | Type
0 | E_STATE | VLD_QUERY_STATUS

Constructor & Destructor Documentation

eoEEP_D202xx::eoEEP_D202xx ( uint16_t size = 10 )

Constructor with message size

Parameters:
size

Member Function Documentation

eoChannelInfo* eoEEP_D202xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_D202xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D202xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D202xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D202xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D202xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D202xx::SetCommand ( uint8_t cmd )
virtual

Sets and checks if the specified command is supported

Parameters:
cmd
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D202xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D202xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D202xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D202xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D202xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D203xx Class Reference

Public Member Functions
eoEEP_D203xx Class Reference
EEP2.6 Profiles API

The class to handle EEP D203 Secure Light and Blind Control. More...

#include <eoEEP_D203xx.h>

Inheritance diagram for eoEEP_D203xx:
[legend]
Collaboration diagram for eoEEP_D203xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
void | ClearValues ()
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
- Public Member Functions inherited from eoD2EEProfile
eoD2EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | SetCommand (uint8_t cmd)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP D203 Secure Light and Blind Control.

Allows the user to handle EEP D203 Secure Light and Blind Control, 2 Rocker profiles, the following profile is available:

  • D2-03-01
  • D2-03-02

The following channels are available:

Channel Index | Channel Type | Type
0 | E_ROCKER_A | uint8_t
1 | E_ROCKER_B | uint8_t
2 | E_ENERGYBOW | uint8_t
3 | E_MULTIPRESS | uint8_t

The following channels are available:

Channel Index | Channel Type | Type
0 | E_WINDOWHANDLE | ENUM_WINDOW_STATE

The E_ROCKER_A and E_ROCKER_B return a ENUM_ROCKER_STATE

E_ENERGYBOW ENUM_ENERGY_STATE

E_MULTIPRESS ENUM_MULTIPRESS_STATE

Member Function Documentation

void eoEEP_D203xx::ClearValues ( )
virtual

All raw values of the internal Message will be set to zero.

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D203xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D203xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_D203xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D203xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D204xx Class Reference

Public Member Functions
eoEEP_D204xx Class Reference
EEP2.6 Profiles API

The class to handle EEP D204 Secure Light and Blind Control. More...

#include <eoEEP_D204xx.h>

Inheritance diagram for eoEEP_D204xx:
[legend]
Collaboration diagram for eoEEP_D204xx:
[legend]

List of all members.

Public Member Functions

eoEEP_D204xx (uint16_t size=4)
eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
- Public Member Functions inherited from eoD2EEProfile
eoD2EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | SetCommand (uint8_t cmd)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP D204 Secure Light and Blind Control.

Allows the user to handle EEP D204 Secure Light and Blind Control, 2 Rocker profiles, the following profile is available:

  • D2-04-00
  • D2-04-01
  • D2-04-02
  • D2-04-03
  • D2-04-04
  • D2-04-05
  • D2-04-06
  • D2-04-07
  • D2-04-08
  • D2-04-09
  • D2-04-10
  • D2-04-1A
  • D2-04-1B
  • D2-04-1C
  • D2-04-1D
  • D2-04-1E

The following channels are available for 00 profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | S_RELHUM | float
2 | S_TEMP | float
3 | F_DAY_NIGHT | uint8_t
4 | E_STATE | NS_BATTERY_AUTONOMY

The following channels are available for 01 profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | S_RELHUM | float
2 | F_DAY_NIGHT | uint8_t
3 | E_STATE | NS_BATTERY_AUTONOMY

The following channels are available for 02 profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | S_TEMP | float
2 | F_DAY_NIGHT | uint8_t
3 | E_STATE | NS_BATTERY_AUTONOMY

The following channels are available for 03 profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | S_TEMP | float
2 | E_STATE | NS_BATTERY_AUTONOMY

The following channels are available for 04 profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | S_TEMP | float

The following channels are available for 05 profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | S_TEMP | float
2 | F_DAY_NIGHT | uint8_t

The following channels are available for 06 profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | F_DAY_NIGHT | uint8_t

The following channels are available for 07 profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | F_DAY_NIGHT | uint8_t
2 | E_STATE | NS_BATTERY_AUTONOMY

NOTE: The S_CONC in the following devices has a range 0-5000 ppm.

The following channels are available for 08 profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | S_RELHUM | float
2 | S_TEMP | float
3 | F_DAY_NIGHT | uint8_t
4 | E_STATE | NS_BATTERY_AUTONOMY

The following channels are available for 09 profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | S_RELHUM | float
2 | F_DAY_NIGHT | uint8_t
3 | E_STATE | NS_BATTERY_AUTONOMY

The following channels are available for 10 profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | S_TEMP | float
2 | F_DAY_NIGHT | uint8_t
3 | E_STATE | NS_BATTERY_AUTONOMY

The following channels are available for 1A profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | S_TEMP | float
2 | E_STATE | NS_BATTERY_AUTONOMY

The following channels are available for 1B profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | S_TEMP | float

The following channels are available for 1C profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | S_TEMP | float
2 | F_DAY_NIGHT | uint8_t

The following channels are available for 1D profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | F_DAY_NIGHT | uint8_t

The following channels are available for 1E profile:

Channel Index | Channel Type | Type
0 | S_CONC | float
1 | F_DAY_NIGHT | uint8_t
2 | E_STATE | NS_BATTERY_AUTONOMY

Constructor & Destructor Documentation

eoEEP_D204xx::eoEEP_D204xx ( uint16_t size = 4 )

Constructor with message size

Parameters:
size

Member Function Documentation

virtual eoReturn eoEEP_D204xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D204xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D204xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D204xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D204xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D205xx Class Reference

Public Member Functions
eoEEP_D205xx Class Reference
EEP2.6 Profiles API

The class to handle EEP D205 profiles. More...

#include <eoEEP_D205xx.h>

Inheritance diagram for eoEEP_D205xx:
[legend]
Collaboration diagram for eoEEP_D205xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
eoEEP_D205xx (uint16_t size=10)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
virtual eoReturn | SetLength (uint8_t type)
virtual eoReturn | SetCommand (uint8_t cmd)
- Public Member Functions inherited from eoD2EEProfile
eoD2EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP D205 profiles.

Allows the user to handle EEP D205 profiles, the following profiles are available:

  • D2-05-00

NOTE: set the command ID before using the profile.

The following channels are available in Go to Position and Angle message:

Channel Index | Channel Type | Type | Comment
0 | S_PERCENTAGE | float | CUR_VER_POSITION
1 | S_PERCENTAGE | float | CUR_ROT_ANGLE
2 | E_END_POS | D205_REPOSITIONING_ENUM |
3 | E_STATE | D205_LOCK_MODE_ENUM |
4 | E_IO_CHANNEL | uint8_t |

The following channels are available in Stop message:

Channel Index | Channel Type | Type
0 | E_IO_CHANNEL | uint8_t

The following channels are available in Query Position and Angle message:

Channel Index | Channel Type | Type
0 | E_IO_CHANNEL | uint8_t

The following channels are available in Reply Position and Angle message:

Channel Index | Channel Type | Type | Comment
0 | S_PERCENTAGE | float | CUR_VER_POSITION
1 | S_PERCENTAGE | float | CUR_ROT_ANGLE
2 | E_STATE | D205_LOCK_MODE_ENUM |
3 | E_IO_CHANNEL | uint8_t |

The following channels are available in Go to Position and Angle message:

Channel Index | Channel Type | Type | Comment
0 | S_TIME | float | SET_VER_DURATION
1 | S_TIME | float | SET_VER_DURATION
2 | E_STATE | D205_AET_ALARM_ENUM |
3 | E_IO_CHANNEL | uint8_t |

Constructor & Destructor Documentation

eoEEP_D205xx::eoEEP_D205xx ( uint16_t size = 10 )

Constructor with message size

Parameters:
size

Member Function Documentation

eoChannelInfo* eoEEP_D205xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_D205xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D205xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D205xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D205xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D205xx::SetCommand ( uint8_t cmd )
virtual

Sets and checks if the specified command is supported

Parameters:
cmd
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D205xx::SetLength ( uint8_t type )
virtual

Sets the channels and length

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED
eoReturn eoEEP_D205xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D205xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D205xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D205xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D206xx Class Reference

Public Member Functions
eoEEP_D206xx Class Reference
EEP2.6 Profiles API

The class to handle EEP D206 profiles. More...

#include <eoEEP_D206xx.h>

Inheritance diagram for eoEEP_D206xx:
[legend]
Collaboration diagram for eoEEP_D206xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
eoEEP_D206xx (uint16_t size=10)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
virtual eoReturn | SetLength (uint8_t type)
virtual eoReturn | SetCommand (uint8_t cmd)
- Public Member Functions inherited from eoD2EEProfile
eoD2EEProfile (uint16_t size=4)
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP D206 profiles.

Allows the user to handle EEP D206 profiles, the following profiles are available:

  • D2-06-01

NOTE: set the command ID before using the profile.

The following channels are available in Sensor Values message:

Channel Index | Channel Type | Type | Comment
0 | E_STATE | uint8_t | BURGLARY_ALARM
1 | E_STATE | uint8_t | PROTECTION_PLUS_ALARM
2 | E_STATE | uint8_t | HANDLE_POSITION
3 | E_STATE | uint8_t | WINDOW_STATE
4 | E_STATE | uint8_t | BUTTON_1
5 | E_STATE | uint8_t | BUTTON_2
6 | E_STATE | uint8_t | MOTION
7 | E_STATE | uint8_t | VACATION_MODE
8 | S_TEMP | float |
9 | S_RELHUM | float |
10 | S_LUMINANCE | float |
11 | S_PERCENTAGE | float |

The following channels are available in Configuration Report message:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | uint8_t | VACATION_MODE
1 | F_ON_OFF | uint8_t | HANDLE_CLICK
2 | F_ON_OFF | uint8_t | BATTERY_CLICK
3 | S_TIME | float | SENSOR_INTERVAL
4 | S_TIME | float | VACATION_INTERVAL

The following channels are available in Log Data 01 message:

Channel Index | Channel Type | Type | Comment
0 | S_COUNTER | float | POWER_ONS
1 | S_COUNTER | float | ALARMS

The following channels are available in Log Data 02 message:

Channel Index | Channel Type | Type | Comment
0 | S_COUNTER | float | HANDLE_CLOSED
1 | S_COUNTER | float | HANDLE_OPENED
2 | S_COUNTER | float | HANDLE_TILTED

The following channels are available in Log Data 03 message:

Channel Index | Channel Type | Type | Comment
0 | S_COUNTER | float | WINDOW_TILTS

The following channels are available in Log Data 04 message:

Channel Index | Channel Type | Type | Comment
0 | S_COUNTER | float | BUTTON_1
1 | S_COUNTER | float | BUTTON_2

The following channels are available in Control and Settings message:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | uint8_t | START_TRANSMISSION_CONFIG_SETTINGS
1 | F_ON_OFF | uint8_t | START_TRANSMISSION_LOG_DATA
2 | F_ON_OFF | uint8_t | VACATION_MODE
3 | E_STATE | uint8_t | HANDLE_CLICK
4 | E_STATE | uint8_t | BATTERY_CLICK
5 | S_TIME | float | VACATION_INTERVAL
6 | S_TIME | float | SENSOR_INTERVAL

Constructor & Destructor Documentation

eoEEP_D206xx::eoEEP_D206xx ( uint16_t size = 10 )

Constructor with message size

Parameters:
size

Member Function Documentation

eoChannelInfo* eoEEP_D206xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_D206xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D206xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D206xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D206xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D206xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D206xx::SetCommand ( uint8_t cmd )
virtual

Sets and checks if the specified command is supported

Parameters:
cmd
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D206xx::SetLength ( uint8_t type )
virtual

Sets the channels and length

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED
eoReturn eoEEP_D206xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D206xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D206xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D206xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D206xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D210xx Class Reference

Public Member Functions
eoEEP_D210xx Class Reference
EEP2.6 Profiles API

The class to handle EEP D210 profiles. More...

#include <eoEEP_D210xx.h>

Inheritance diagram for eoEEP_D210xx:
[legend]
Collaboration diagram for eoEEP_D210xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
eoEEP_D210xx (uint16_t size=10)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
virtual eoReturn | SetLength (uint8_t type)
virtual eoReturn | SetCommand (uint8_t cmd)
- Public Member Functions inherited from eoD2EEProfile
eoD2EEProfile (uint16_t size=4)
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP D210 profiles.

Allows the user to handle EEP D210 profiles, the following profiles are available:

  • D2-10-00
  • D2-10-01
  • D2-10-02

NOTE: set the command ID before using the profile.

The following channels are available in General Message:

Channel Index | Channel Type | Type | Comment
0 | E_STATE | D210_MSG_CONTINUATION_ENUM | MSG_CONTINUATION
1 | E_STATE | D210_INFO_REQUEST_ENUM | INFO_REQUEST_CLASS
2 | E_STATE | D210_FEEDBACK_CLASS_ENUM | FEEDBACK_CLASS
3 | F_ON_OFF | D210_GENERAL_MSG_TYPE_ENUM | GENERAL_MSG_TYPE

The following channels are available in Data Message:

Channel Index | Channel Type | Type | Comment
0 | E_STATE | D210_MSG_CONTINUATION_ENUM | MSG_CONTINUATION
1 | S_RELHUM | float |
2 | F_ON_OFF | D210_VALIDITY_FLAG_ENUM | RELHUM_VALIDITY
3 | S_VALUE | float |
4 | F_ON_OFF | D210_VALIDITY_FLAG_ENUM | FANSPEED_VALIDITY
5 | F_ON_OFF | D210_FAN_SPEED_MODE_ENUM | FANSPEED_MODE
6 | F_ON_OFF | uint8_t | CUSTOM_WARNING_2
7 | F_ON_OFF | uint8_t | CUSTOM_WARNING_1
8 | F_ON_OFF | uint8_t | MOLD_WARNING
9 | E_STATE | D210_WINDOW_OPEN_ENUM | WINDOW_OPEN_DETECTION
10 | E_STATE | D210_BATTERY_STATUS_ENUM | BATTERY_STATUS
11 | F_ON_OFF | D210_SOLAR_POWERED_ENUM | SOLAR_POWERED_STATUS
12 | E_STATE | D210_PIR_STATUS_ENUM | PIR_STATUS
13 | E_OCCUPANCY | D210_OCCUPANCY_STATUS_ENUM |
14 | E_STATE | D210_COOLING_HEATING_STATUS_ENUM | COOLING_STATUS
15 | E_STATE | D210_COOLING_HEATING_STATUS_ENUM | HEATING_STATUS
16 | E_CONTROLLER_MODE | D210_ROOM_CONTROL_ENUM |
17 | F_ON_OFF | D210_VALIDITY_FLAG_ENUM | TEMP_SETPOINT_VALIDITY
18 | F_ON_OFF | D210_VALIDITY_FLAG_ENUM | TEMP_VALIDITY
19 | S_TEMP_ABS | float | RECENT_TEMP_SETPOINT
20 | S_TEMP | float |

The following channels are available in Configuration Message:

Channel Index | Channel Type | Type | Comment
0 | E_STATE | D210_MSG_CONTINUATION_ENUM | MSG_CONTINUATION
1 | F_ON_OFF | D210_LOCK_ENUM | PIR_LOCK
2 | F_ON_OFF | D210_LOCK_ENUM | TEMP_LOCK
3 | F_ON_OFF | D210_LOCK_ENUM | DISPLAY_LOCK
4 | F_ON_OFF | D210_LOCK_ENUM | DATE_TIME_LOCK
5 | F_ON_OFF | D210_LOCK_ENUM | TIME_PROG_LOCK
6 | F_ON_OFF | D210_LOCK_ENUM | OCCUPANCY_LOCK
7 | F_ON_OFF | D210_LOCK_ENUM | TEMP_SETPOINT_LOCK
8 | F_ON_OFF | D210_LOCK_ENUM | FAN_SPEED_LOCK
9 | S_TIME | float,D210_RADIO_COM_INTERVAL_ENUM | RADIO_COM_INTERVAL
10 | F_ON_OFF | D210_LOCK_ENUM | KEY_LOCK
11 | E_STATE | D210_DISPLAY_CONTENT_ENUM | DISPLAY_CONTENT
12 | E_STATE | D210_TEMP_SCALE_ENUM | TEMP_SCALE
13 | F_ON_OFF | D210_DAYLIGHT_SAVE_ENUM | DAYLIGHT_SAVE
14 | E_STATE | D210_TIME_NOTATION_ENUM | TIME_NOTATION
15 | S_TIME | float | TIME_CURRENT_DAY
16 | S_TIME | float | TIME_CURRENT_MONTH
17 | S_TIME | float | TIME_CURRENT_YEAR
18 | S_TIME | float | TIME_CURRENT_MINUTE
19 | S_TIME | float | TIME_CURRENT_HOUR
20 | F_ON_OFF | D210_DATE_TIME_UPDATE_ENUM | DATE_TIME_UPDATE_FLAG

The following channels are available in Room Control Setup Message:

Channel Index | Channel Type | Type | Comment
0 | E_STATE | D210_MSG_CONTINUATION_ENUM | MSG_CONTINUATION
1 | S_TEMP_ABS | float | BUILDING_PROTECT_TEMP_SETPOINT
2 | S_TEMP_ABS | float | PRECOMFORT_TEMP_SETPOINT
3 | S_TEMP_ABS | float | ECONOMY_TEMP_SETPOINT
4 | S_TEMP_ABS | float | COMFORT_TEMP_SETPOINT
5 | F_ON_OFF | D210_VALIDITY_FLAG_ENUM | BUILDING_PROTECT_TEMP_SETPOINT_VALIDITY
6 | F_ON_OFF | D210_VALIDITY_FLAG_ENUM | PRECOMFORT_TEMP_SETPOINT_VALIDITY
7 | F_ON_OFF | D210_VALIDITY_FLAG_ENUM | ECONOMY_TEMP_TEMP_SETPOINT_VALIDITY
8 | F_ON_OFF | D210_VALIDITY_FLAG_ENUM | COMFORT_TEMP_SETPOINT_VALIDITY

The following channels are available in Time Program Setup Message:

Channel Index | Channel Type | Type | Comment
0 | E_STATE | D210_MSG_CONTINUATION_ENUM | MSG_CONTINUATION
1 | S_TIME | float | END_TIME_MINUTE
2 | S_TIME | float | END_TIME_HOUR
3 | S_TIME | float | START_TIME_MINUTE
4 | S_TIME | float | START_TIME_HOUR
5 | E_DAYS | D210_PERIOD_ENUM |
6 | E_CONTROLLER_MODE | D210_ROOM_CONTROL_ENUM |
7 | F_ON_OFF | D210_TIME_PROG_DELETION_ENUM | TIME_PROG_DELETION

Constructor & Destructor Documentation

eoEEP_D210xx::eoEEP_D210xx ( uint16_t size = 10 )

Constructor with message size

Parameters:
size

Member Function Documentation

eoChannelInfo* eoEEP_D210xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_D210xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D210xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D210xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D210xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D210xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D210xx::SetCommand ( uint8_t cmd )
virtual

Sets and checks if the specified command is supported

Parameters:
cmd
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D210xx::SetLength ( uint8_t type )
virtual

Sets the channels and length

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED
eoReturn eoEEP_D210xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D210xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D210xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D210xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D210xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D220xx Class Reference

Public Member Functions
eoEEP_D220xx Class Reference
EEP2.6 Profiles API

The class to handle EEP D220 profiles. More...

#include <eoEEP_D220xx.h>

Inheritance diagram for eoEEP_D220xx:
[legend]
Collaboration diagram for eoEEP_D220xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
eoEEP_D220xx (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
- Public Member Functions inherited from eoD2EEProfile
eoD2EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | SetCommand (uint8_t cmd)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP D220 profiles.

Allows the user to handle EEP D220 profiles, the following profiles are available:

  • D2-20-00 (two directions)
  • D2-20-01 (two directions)
  • D2-20-02 (two directions)
Note:
Direction 1 is set with E_DIRECTION,0 and Direction 2 is set with E_DIRECTION,1

The following channels are available for 00 profile, Fan Control Message (direction 1):

Channel Index | Channel Type | Type | Comment
0 | E_CONTROLLER_MODE | VLD_FC_OP_MODE | OP_MODE
1 | E_STATE | VLD_FC_TEMP_LEVEL | TEMP_LEVEL
2 | E_CONTROLLER_MODE | VLD_FC_RELHUM_CONTROL | RELHUM_CONTROL
3 | E_STATE | VLD_FC_ROOM_SIZE_REF | ROOM_SIZE_REFERENCE
4 | E_ROOM_SIZE | VLD_FC_ROOM_SIZE |
5 | E_STATE | VLD_FC_STAGE | RELHUM_THRESHOLD, between 0-100% float number
6 | S_RELHUM | float |
7 | E_FANSPEED | VLD_FC_STAGE | Enum of fan speed, VLD_FC_STAGE
8 | S_PERCENTAGE | float | Percentage of fan speed between 0-100%

The following channels are available for 00 profile, Fan Control Message (direction 2):

Channel Index | Channel Type | Type | Comment
0 | E_CONTROLLER_MODE | VLD_FC_OP_MODE | OP_MODE
1 | E_STATE | VLD_FC_SERVICE_INFORMATION | SERVICE_INFO
2 | E_STATE | VLD_FC_RELHUM_CONTROL | RELHUM_THRESHOLD
3 | S_RELHUM | float |
4 | E_STATE | VLD_FC_ROOM_SIZE_REF | ROOM_SIZE_REFERENCE
5 | E_ROOM_SIZE | VLD_FC_ROOM_SIZE |
6 | E_FANSPEED | VLD_FC_STAGE | Enum of fan speed, VLD_FC_STAGE
7 | S_PERCENTAGE | float | Percentage of fan speed between 0-100%

The following channels are available for 01 profile, Fan Control Message (direction 1):

Channel Index | Channel Type | Type | Comment
0 | E_STATE | VLD_FC_ROOM_SIZE_REF | ROOM_SIZE_REFERENCE
1 | E_ROOM_SIZE | VLD_FC_ROOM_SIZE |
2 | E_FANSPEED | VLD_FC_STAGE |
3 | S_PERCENTAGE | float |

The following channels are available for 01 profile, Fan Control Message (direction 2):

Channel Index | Channel Type | Type | Comment
0 | E_CONTROLLER_MODE | VLD_FC_OP_MODE | OP_MODE
1 | E_STATE | VLD_FC_ROOM_SIZE_REF | ROOM_SIZE_REFERENCE
2 | E_ROOM_SIZE | VLD_FC_ROOM_SIZE |
3 | E_FANSPEED | VLD_FC_STAGE |
4 | S_PERCENTAGE | float |

The following channels are available for 02 profile, Fan Control Message (direction 1):

Channel Index | Channel Type | Type | Comment
0 | E_STATE | VLD_FC_ROOM_SIZE_REF | ROOM_SIZE_REFERENCE
1 | E_ROOM_SIZE | VLD_FC_ROOM_SIZE |
2 | E_FANSPEED | VLD_FC_STAGE |
3 | S_PERCENTAGE | float |

The following channels are available for 02 profile, Fan Control Message (direction 2):

Channel Index | Channel Type | Type | Comment
0 | E_CONTROLLER_MODE | VLD_FC_OP_MODE | OP_MODE
1 | E_STATE | VLD_FC_ROOM_SIZE_REF | ROOM_SIZE_REFERENCE
2 | E_ROOM_SIZE | VLD_FC_ROOM_SIZE |
3 | E_FANSPEED | VLD_FC_STAGE |
4 | S_PERCENTAGE | float |

Constructor & Destructor Documentation

eoEEP_D220xx::eoEEP_D220xx ( uint16_t size = 4 )

Constructor with message size

Parameters:
size

Member Function Documentation

eoChannelInfo* eoEEP_D220xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_D220xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D220xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D220xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D220xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_D220xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D220xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D220xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D220xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D230xx Class Reference

Public Member Functions
eoEEP_D230xx Class Reference
EEP2.6 Profiles API

The class to handle EEP D230 profiles. More...

#include <eoEEP_D230xx.h>

Inheritance diagram for eoEEP_D230xx:
[legend]
Collaboration diagram for eoEEP_D230xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
eoEEP_D230xx (uint16_t size=10)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subFlag)
virtual eoReturn | SetCommand (uint8_t cmd)
- Public Member Functions inherited from eoD2EEProfile
eoD2EEProfile (uint16_t size=4)
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP D230 profiles.

Allows the user to handle EEP D230 profiles, the following profiles are available:

  • D2-30-11
Note:
set the command before use.

The following channels are available for Set heating controls output command:

Channel Index | Channel Type | Type
0 | E_STATE | MSR_TIME_VALUES
1 | F_OPEN_CLOSED | MSR_CONNECTED_VALVE
2 | S_VALUE | float
3 | F_ON_OFF | MSR_INIT_SEQU
4 | S_SETPOINT | float

The following channels are available for Heating controls status query command:

Channel Index | Channel Type | Type
0 | S_VALUE | float

The following channels are available for Heating controls status response command:

Channel Index | Channel Type | Type | Comment
0 | E_ERROR_STATE | MSR_ERROR_CODE | MSR_CHANNEL_ERROR
1 | S_VALUE | float |
2 | S_PERCENTAGE | float |
3 | S_TEMP | float | MSR_CHANNEL_RETURN_TEMP

If Heating channel (HCH) returns 31, the following channels are available:

Channel Index | Channel Type | Type | Comment
0 | E_ERROR_STATE | MSR_ERROR_CODE_CH31 | MSR_CHANNEL_ERROR_HCH31
1 | S_TEMP | float | MSR_CHANNEL_SUPPLY_TEMP
2 | S_TEMP | float | MSR_CHANNEL_RETURN_TEMP

The following channels are available for Set meter configuration command:

Channel Index | Channel Type | Type | Comment
0 | E_STATE | MSR_REPORT_TIME_VALUES | MSR_CHANNEL_REPORT_TIME
1 | E_STATE | MSR_METER_BUS_TYPE | MSR_CHANNEL_METER_TYPE
2 | S_VALUE | float | MSR_CHANNEL_METER_CHANNEL
3 | E_UNITS | MSR_METER_UNITS | MSR_CHANNEL_METER_1
4 | E_UNITS | MSR_METER_UNITS | MSR_CHANNEL_METER_2

The rest of the channels are depending on the BUS type (MBUS, S0, D0).

The following channels are available if MBUS is available:

Channel Index | Channel Type | Type | Comment
0 | S_VALUE | float | MSR_CHANNEL_PRIMARY_ADDR

The following channels are available if S0 is available:

Channel Index | Channel Type | Type | Comment
0 | E_UNITS | MSR_FACTOR_PULSES | MSR_CHANNEL_PULSES_FACTOR
1 | S_VALUE | float | MSR_CHANNEL_NUM_OF_PULSES
2 | S_VALUE | float | MSR_CHANNEL_PRESET_VALUE

The following channels are available if D0 is available:

Channel Index | Channel Type | Type | Comment
0 | E_STATE | MSR_PROTOCOL | MSR_CHANNEL_PROTOCOL

The following channels are available for Meter status query command:

Channel Index | Channel Type | Type
0 | E_STATE | MSR_METER_BUS_TYPE
1 | S_VALUE | float

The following channels are available for Meter reading report/status response command:

Channel Index | Channel Type | Type | Comment
0 | E_STATE | MSR_METER_ERROR_CODE | MSR_CHANNEL_METER_ERROR
1 | E_STATE | MSR_METER_BUS_TYPE | MSR_CHANNEL_METER_TYPE
2 | S_VALUE | float | MSR_CHANNEL_METER_CHANNEL
3 | E_STATE | MSR_VALUE_SELECTION | MSR_CHANNEL_VALUE_SELECTION
4 | E_UNITS | MSR_VALUE_UNITS |
5 | S_VALUE | float | MSR_CHANNEL_METER_1

Constructor & Destructor Documentation

eoEEP_D230xx::eoEEP_D230xx ( uint16_t size = 10 )

Constructor with message size

Parameters:
size

Member Function Documentation

virtual eoChannelInfo* eoEEP_D230xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_D230xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D230xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D230xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D230xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D230xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D230xx::SetCommand ( uint8_t cmd )
virtual

Sets and checks if the specified command is supported

Parameters:
cmd
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D230xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D230xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D230xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D230xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D230xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D231xx Class Reference

Public Member Functions
eoEEP_D231xx Class Reference
EEP2.6 Profiles API

The class to handle EEP D231 profiles. More...

#include <eoEEP_D231xx.h>

Inheritance diagram for eoEEP_D231xx:
[legend]
Collaboration diagram for eoEEP_D231xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
eoEEP_D231xx (uint16_t size=10)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subFlag)
virtual eoReturn | SetCommand (uint8_t cmd)
- Public Member Functions inherited from eoD2EEProfile
eoD2EEProfile (uint16_t size=4)
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP D231 profiles.

Allows the user to handle EEP D231 profiles, the following profiles are available:

  • D2-31-00
  • D2-31-01

NOTE: set the command before use.

The following channels are available for Set meter configuration command:

Channel Index | Channel Type | Type | Comment
0 | E_STATE | MSR_TIME_VALUES | MSR_CHANNEL_REPORT_TIME
1 | E_STATE | MSR_METER_BUS_TYPE | MSR_CHANNEL_METER_TYPE
2 | S_VALUE | float | MSR_CHANNEL_METER_CHANNEL
3 | E_UNITS | MSR_METER_UNITS | MSR_CHANNEL_METER_1
4 | E_UNITS | MSR_METER_UNITS | MSR_CHANNEL_METER_2

The rest of the channels are depending on the BUS type (MBUS, S0, D0).

The following channels are available if MBUS is available:

Channel Index | Channel Type | Type | Comment
0 | S_VALUE | float | MSR_CHANNEL_PRIMARY_ADDR

The following channels are available if S0 is available:

Channel Index | Channel Type | Type | Comment
0 | E_UNITS | MSR_FACTOR_PULSES | MSR_CHANNEL_PULSES_FACTOR
1 | S_VALUE | float | MSR_CHANNEL_NUM_OF_PULSES
2 | S_VALUE | float | MSR_CHANNEL_PRESET_VALUE

The following channels are available if D0 is available:

Channel Index | Channel Type | Type | Comment
0 | E_STATE | MSR_PROTOCOL | MSR_CHANNEL_PROTOCOL

The following channels are available for Meter status query command:

Channel Index | Channel Type | Type
0 | E_STATE | MSR_METER_BUS_TYPE
1 | S_VALUE | float

The following channels are available for Meter reading report/status response command:

Channel Index | Channel Type | Type | Comment
0 | E_STATE | MSR_METER_ERROR_CODE | MSR_CHANNEL_METER_ERROR
1 | E_STATE | MSR_METER_BUS_TYPE | MSR_CHANNEL_METER_TYPE
2 | S_VALUE | float | MSR_CHANNEL_METER_CHANNEL
3 | E_STATE | MSR_VALUE_SELECTION | MSR_CHANNEL_VALUE_SELECTION
4 | E_UNITS | MSR_VALUE_UNITS |
5 | S_VALUE | float | MSR_CHANNEL_METER_1

Constructor & Destructor Documentation

eoEEP_D231xx::eoEEP_D231xx ( uint16_t size = 10 )

Constructor with message size

Parameters:
size

Member Function Documentation

virtual eoChannelInfo* eoEEP_D231xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_D231xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D231xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D231xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D231xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D231xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D231xx::SetCommand ( uint8_t cmd )
virtual

Sets and checks if the specified command is supported

Parameters:
cmd
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D231xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D231xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D231xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D231xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D231xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D232xx Class Reference

Public Member Functions
eoEEP_D232xx Class Reference
EEP2.6 Profiles API

The class to handle EEP D232 Automated meter reading (AMR) profiles. More...

#include <eoEEP_D232xx.h>

Inheritance diagram for eoEEP_D232xx:
[legend]
Collaboration diagram for eoEEP_D232xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
- Public Member Functions inherited from eoD2EEProfile
eoD2EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | SetCommand (uint8_t cmd)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP D232 Automated meter reading (AMR) profiles.

Allows the user to handle EEP D232 Automated meter reading (AMR) profiles, the following profiles are available:

  • D2-32-00
  • D2-32-01
  • D2-32-02

The following channels are available for Profile 0:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | uint8_t |
1 | S_CURRENT | float | Channel 1, CURR_CHANNEL_1

The following channels are available for Profile 1:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | uint8_t |
1 | S_CURRENT | float | Channel 1, CURR_CHANNEL_1
2 | S_CURRENT | float | Channel 2, CURR_CHANNEL_2

The following channels are available for Profile 2:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | uint8_t |
1 | S_CURRENT | float | Channel 1, CURR_CHANNEL_1
2 | S_CURRENT | float | Channel 2, CURR_CHANNEL_2
3 | S_CURRENT | float | Channel 3, CURR_CHANNEL_3

Member Function Documentation

eoChannelInfo* eoEEP_D232xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_D232xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D232xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D232xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D232xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D232xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D232xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D232xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D240xx Class Reference

Public Member Functions
eoEEP_D240xx Class Reference
EEP2.6 Profiles API

The class to handle EEP D240 profiles. More...

#include <eoEEP_D240xx.h>

Inheritance diagram for eoEEP_D240xx:
[legend]
Collaboration diagram for eoEEP_D240xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
eoEEP_D240xx (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t index)
virtual eoReturn | SetLength (uint8_t type)
virtual eoReturn | SetCommand (uint8_t cmd)
- Public Member Functions inherited from eoD2EEProfile
eoD2EEProfile (uint16_t size=4)
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP D240 profiles.

Allows the user to handle EEP D240 profiles, the following profiles are available:

  • D2-40-00
  • D2-40-01

NOTE: set the command ID before using the profile.

The following channels are available in Message ID 0x00:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | D240_DRIVING_LED_ENUM | DRIVING_LED
1 | F_ON_OFF | D240_TRUE_FALSE_ENUM | RESPONSE_MODE
2 | F_ON_OFF | D240_TRUE_FALSE_ENUM | DAYLIGH_HARVEST
3 | E_OCCUPANCY | D240_OCCUPANCY_ENUM |
4 | F_ON_OFF | D240_STATUS_REASON_ENUM | STATUS_REASON
5 | S_PERCENTAGE | float | DIM_LEVEL_MONO

The following channels are available in Message ID 0x01:

Channel Index | Channel Type | Type | Comment
0 | F_ON_OFF | D240_DRIVING_LED_ENUM | DRIVING_LED
1 | F_ON_OFF | D240_TRUE_FALSE_ENUM | RESPONSE_MODE
2 | F_ON_OFF | D240_TRUE_FALSE_ENUM | DAYLIGH_HARVEST
3 | E_OCCUPANCY | D240_OCCUPANCY_ENUM |
4 | F_ON_OFF | D240_STATUS_REASON_ENUM | STATUS_REASON
5 | S_PERCENTAGE | float | DIM_LEVEL_RED
5 | S_PERCENTAGE | float | DIM_LEVEL_GREEN
5 | S_PERCENTAGE | float | DIM_LEVEL_BLUE

Constructor & Destructor Documentation

eoEEP_D240xx::eoEEP_D240xx ( uint16_t size = 4 )

Constructor with message size

Parameters:
size

Member Function Documentation

eoChannelInfo* eoEEP_D240xx::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

virtual eoReturn Create(eoMessage &m); virtual eoReturn CreateTeachIN(eoMessage &m);

virtual eoReturn Parse(const eoMessage &msg);

virtual eoReturn GetValue(CHANNEL_TYPE type, float &value); virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value); virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type,float value, uint8_t subFlag); virtual eoReturn SetValue(CHANNEL_TYPE type,uint8_t value, uint8_t subFlag);

virtual eoReturn SetValue(CHANNEL_TYPE type, float value); virtual eoReturn SetValue(CHANNEL_TYPE type, const uint8_t value);

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_D240xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D240xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D240xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D240xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

eoReturn eoEEP_D240xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D240xx::SetCommand ( uint8_t cmd )
virtual

Sets and checks if the specified command is supported

Parameters:
cmd
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D240xx::SetLength ( uint8_t type )
virtual

Sets the channels and length

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED
eoReturn eoEEP_D240xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D240xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D240xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D240xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

virtual eoReturn eoEEP_D240xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoD2EEProfile.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D2A0xx Class Reference

Public Member Functions
eoEEP_D2A0xx Class Reference
EEP2.6 Profiles API

The class to handle EEP D2A0 profiles. More...

#include <eoEEP_D2A0xx.h>

Inheritance diagram for eoEEP_D2A0xx:
[legend]
Collaboration diagram for eoEEP_D2A0xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
eoEEP_D2A0xx (uint16_t size=1)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
eoReturn | SetDirection (VALVE_DIRECTION direction)
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoChannelInfo * | GetOutChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetOutChannel (uint8_t channelNumber)
virtual eoReturn | SetDirection (SIMPLE_DIRECTION directionToSet)
virtual void | ClearValues ()
- Public Member Functions inherited from eoD2EEProfile
eoD2EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | SetCommand (uint8_t cmd)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)
- Public Member Functions inherited from eoISimpleBidirectionalProfile
virtual eoChannelInfo * | GetOutChannel (CHANNEL_TYPE type, uint8_t subType)

Additional Inherited Members

- Protected Attributes inherited from eoISimpleBidirectionalProfile
SIMPLE_DIRECTION direction

Detailed Description

The class to handle EEP D2A0 profiles.

Allows the user to handle EEP DA20 profiles, the following profiles are available:

  • D2-A0-01
    DIRECTION-1 = Transmit mode: Message from the actuator to the controller DIRECTION-2 = Receive mode: Commands from the controller to the actuator
Note:
In Old EnOcean Link Version the direction could be set with E_DIRECTION, it is recommended with the new version to use after initializing the profile the SetDirection Function to set once the direction of the profile. The Profile interprets then the received data always as direction y and transmit data always with the direction x.

The following channels are available for direction to controller:

Channel Index | Channel Type | Type
0 | E_STATE | VALVE_STATUS

The following channels are available for direction to valve:

Channel Index | Channel Type | Type
0 | E_STATE | VALVE_REQUEST

Constructor & Destructor Documentation

eoEEP_D2A0xx::eoEEP_D2A0xx ( uint16_t size = 1 )

Constructor with message size

Parameters:
size

Member Function Documentation

virtual void eoEEP_D2A0xx::ClearValues ( )
virtual

All raw values of the internal Message will be set to zero.

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D2A0xx::Create ( eoMessage & m )
virtual

Generates an EEP Message.

This functions generates a Message for the specified EEP, with the current ChannelInfo values

Parameters:
m Reference to the Message (will be cleared and generated new)
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

virtual eoChannelInfo* eoEEP_D2A0xx::GetOutChannel ( CHANNEL_TYPE type )
virtual

Returns the outChannel for the selected type

Parameters:
type CHANNEL_TYPE
Returns:
Pointer to ChannelInfo or Null

Implements eoISimpleBidirectionalProfile.

virtual eoChannelInfo* eoEEP_D2A0xx::GetOutChannel ( uint8_t channelNumber )
virtual

returns the pointer to eoChannelInfo for the selected outChannelNumber or NULL

Parameters:
channelNumber
Returns:
Pointer to Channel

Implements eoISimpleBidirectionalProfile.

virtual eoReturn eoEEP_D2A0xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_D2A0xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_D2A0xx::SetDirection ( VALVE_DIRECTION direction )

Sets and checks if the specified direction is supported

Parameters:
direction
Returns:
eoReturn EO_OK or NOT_SUPPORTED
virtual eoReturn eoEEP_D2A0xx::SetDirection ( SIMPLE_DIRECTION direction )
virtual

Set the direction of the profile, if the specific profile does not support Bidirectional mode, nothing happens.

Parameters:
direction

Implements eoISimpleBidirectionalProfile.

eoReturn eoEEP_D2A0xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D2A0xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_D500xx Class Reference

Public Member Functions
eoEEP_D500xx Class Reference
EEP2.6 Profiles API

The class to handle EEP d500 profiles. More...

#include <eoEEP_D500xx.h>

Inheritance diagram for eoEEP_D500xx:
[legend]
Collaboration diagram for eoEEP_D500xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
- Public Member Functions inherited from eoA5EEProfile
eoA5EEProfile (uint16_t size=4)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t index)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t index)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t index)
Gets the Value as a float.
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
bool | Is4BSData (const eoMessage &m)
bool | IsSecDData (const eoMessage &m)
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual void | ClearValues ()
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP d500 profiles.

Allows the user to handle EEP d500 profiles, the following profile is available:

  • D5-00-01
    The following channels are available:
    Channel Index | Channel Type | Type
    0 | F_OPEN_CLOSED | uint8_t

Member Function Documentation

virtual eoReturn eoEEP_D500xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_D500xx::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoA5EEProfile.

eoReturn eoEEP_D500xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_D500xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_F602xx Class Reference

Public Member Functions
eoEEP_F602xx Class Reference
EEP2.6 Profiles API

The class to handle EEP f602 Rocker Switch, 2 Rocker profiles. More...

#include <eoEEP_F602xx.h>

Inheritance diagram for eoEEP_F602xx:
[legend]
Collaboration diagram for eoEEP_F602xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
void | ClearValues ()
- Public Member Functions inherited from eoF6EEProfile
virtual eoReturn | Create (eoMessage &msg)
Generates an EEP Message.
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t subFlag)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t subFlag)
Gets the Value as a float.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP f602 Rocker Switch, 2 Rocker profiles.

Allows the user to handle EEP f602 Rocker Switch, 2 Rocker profiles, the following profiles are available:

  • F6-02-01
  • F6-02-02
  • F6-02-03
  • F6-02-04
    The following channels are available:
    Channel Index | Channel Type | Type
    0 | E_ROCKER_A | uint8_t
    1 | E_ROCKER_B | uint8_t
    2 | E_ENERGYBOW | uint8_t
    3 | E_MULTIPRESS | uint8_t

The E_ROCKER_A and E_ROCKER_B return a ENUM_ROCKER_STATE

E_ENERGYBOW ENUM_ENERGY_STATE

E_MULTIPRESS ENUM_MULTIPRESS_STATE

Member Function Documentation

void eoEEP_F602xx::ClearValues ( )
virtual

All raw values of the internal Message will be set to zero.

Reimplemented from eoProfile.

virtual eoChannelInfo* eoEEP_F602xx::GetChannel ( CHANNEL_TYPE type )
virtual

Returns the channel for the selected type

Parameters:
type CHANNEL_TYPE
Returns:
Pointer to ChannelInfo or Null

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_F602xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_F602xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_F602xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_F603xx Class Reference

Public Member Functions
eoEEP_F603xx Class Reference
EEP2.6 Profiles API

The class to handle EEP f603 profiles. More...

#include <eoEEP_F603xx.h>

Inheritance diagram for eoEEP_F603xx:
[legend]
Collaboration diagram for eoEEP_F603xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
void | ClearValues ()
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
- Public Member Functions inherited from eoF6EEProfile
virtual eoReturn | Create (eoMessage &msg)
Generates an EEP Message.
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t subFlag)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t subFlag)
Gets the Value as a float.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP f603 profiles.

Allows the user to handle EEP f603 profiles, the following profiles are available:

  • F6-03-01
  • F6-03-02
    The following channels are available:
    Channel Index | Channel Type | Type
    0 | E_ROCKER_A | uint8_t
    1 | E_ROCKER_B | uint8_t
    2 | E_ROCKER_C | uint8_t
    3 | E_ROCKER_D | uint8_t
    4 | E_ENERGYBOW | uint8_t
    5 | E_MULTIPRESS | uint8_t

Member Function Documentation

void eoEEP_F603xx::ClearValues ( )
virtual

All raw values of the internal Message will be set to zero.

Reimplemented from eoProfile.

virtual eoChannelInfo* eoEEP_F603xx::GetChannel ( CHANNEL_TYPE type )
virtual

Returns the channel for the selected type

Parameters:
type CHANNEL_TYPE
Returns:
Pointer to ChannelInfo or Null

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_F603xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_F603xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_F603xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_F604xx Class Reference

Public Member Functions
eoEEP_F604xx Class Reference
EEP2.6 Profiles API

The class to handle EEP f604 profiles. More...

#include <eoEEP_F604xx.h>

Inheritance diagram for eoEEP_F604xx:
[legend]
Collaboration diagram for eoEEP_F604xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
- Public Member Functions inherited from eoF6EEProfile
virtual eoReturn | Create (eoMessage &msg)
Generates an EEP Message.
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t subFlag)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t subFlag)
Gets the Value as a float.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP f604 profiles.

<>

Allows the user to handle EEP f604 profiles, the following profiles are available:

  • F6-04-01
  • F6-04-02
    The following channels are available:
    Channel Index | Channel Type | Type
    0 | F_ON_OFF | uint8_t

Member Function Documentation

virtual eoChannelInfo* eoEEP_F604xx::GetChannel ( CHANNEL_TYPE type )
virtual

Returns the channel for the selected type

Parameters:
type CHANNEL_TYPE
Returns:
Pointer to ChannelInfo or Null

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_F604xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_F604xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_F604xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_F605xx Class Reference

Public Member Functions
eoEEP_F605xx Class Reference
EEP2.6 Profiles API

The class to handle EEP f605 profiles. More...

#include <eoEEP_F605xx.h>

Inheritance diagram for eoEEP_F605xx:
[legend]
Collaboration diagram for eoEEP_F605xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
- Public Member Functions inherited from eoF6EEProfile
virtual eoReturn | Create (eoMessage &msg)
Generates an EEP Message.
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t subFlag)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t subFlag)
Gets the Value as a float.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP f605 profiles.

<>

Allows the user to handle EEP f605 profiles, the following profiles are available:

  • F6-05-01

The following channels are available 00:

Channel Index | Channel Type | Type
0 | E_STATE | WAS_VALUES

Member Function Documentation

virtual eoChannelInfo* eoEEP_F605xx::GetChannel ( CHANNEL_TYPE type )
virtual

Returns the channel for the selected type

Parameters:
type CHANNEL_TYPE
Returns:
Pointer to ChannelInfo or Null

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_F605xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_F605xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_F605xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoEEP_F610xx Class Reference

Public Member Functions
eoEEP_F610xx Class Reference
EEP2.6 Profiles API

The class to handle EEP f610 profiles. More...

#include <eoEEP_F610xx.h>

Inheritance diagram for eoEEP_F610xx:
[legend]
Collaboration diagram for eoEEP_F610xx:
[legend]

List of all members.

Public Member Functions

eoReturn | SetType (uint8_t type)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
- Public Member Functions inherited from eoF6EEProfile
virtual eoReturn | Create (eoMessage &msg)
Generates an EEP Message.
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
- Public Member Functions inherited from eoEEProfile
eoEEProfile (uint16_t size=4)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual uint8_t | GetChannelCount () const
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t subFlag)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t subFlag)
Gets the Value as a float.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
eoReturn | SetManufacturer (uint16_t manufacturerID)

Detailed Description

The class to handle EEP f610 profiles.

<>

Allows the user to handle EEP f610 profiles, the following profiles are available:

  • F6-10-00
  • F6-10-01
    The following channels are available:
    Channel Index | Channel Type | Type
    0 | E_WINDOWHANDLE | uint8_t
    The E_WINDOWHANDLE uses ENUM_WINDOW_STATE

Member Function Documentation

virtual eoChannelInfo* eoEEP_F610xx::GetChannel ( CHANNEL_TYPE type )
virtual

Returns the channel for the selected type

Parameters:
type CHANNEL_TYPE
Returns:
Pointer to ChannelInfo or Null

Reimplemented from eoEEProfile.

virtual eoReturn eoEEP_F610xx::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoEEP_F610xx::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

virtual eoReturn eoEEP_F610xx::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Generic Profile Interface

Classes
Generic Profile Interface
API

This section describes most improtant part of Generic profiles. This part is still not full released since the TWG has not completely released the Generic Profile Specification. More...

Collaboration diagram for Generic Profile Interface:

Classes

class | eoGenericProfile
The class to handle Generic Profiles. More...
class | eoGPChannelInfo
Generic Profile Channel. More...
class | eoManufacturer
Manufacturer List. More...

Detailed Description

This section describes most improtant part of Generic profiles. This part is still not full released since the TWG has not completely released the Generic Profile Specification.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoGenericProfile Class Reference

Public Member Functions | Public Attributes
eoGenericProfile Class Reference
Generic Profile Interface

The class to handle Generic Profiles. More...

#include <eoGenericProfile.h>

Inheritance diagram for eoGenericProfile:
[legend]
Collaboration diagram for eoGenericProfile:
[legend]

List of all members.

Public Member Functions

eoGenericProfile (uint16_t msgLength)
void | AllowTeachIN ()
bool | operator== (const eoGenericProfile &othProfile) const
bool | operator!= (const eoGenericProfile &othProfile) const
eoReturn CreateTeachIN (eoMessage &msg)
creates Teach In Messsage
eoReturn | Create (eoMessage &m, std::vector< int > channelNumbers)
creates Selective Data Message
eoReturn | ParseSelData (const eoMessage &msg)
eoReturn | ParseTeachIN (const eoMessage &msg)
eoReturn | Parse (const eoMessage &msg)
eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t subFlag)
Gets the Value as Floating point.
eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t subFlag)
Gets the Value as a float.
eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
eoReturn | SetType (uint8_t type)
eoReturn | AddChannel (CHANNEL_TYPE type, GP_RESOLUTION resolution, int8_t engMaximum, int8_t engMinimum, GP_SCALING scaleMaximum, GP_SCALING scaleMinimum, VALUE_TYPE valueType)
eoReturn | AddChannelOut (CHANNEL_TYPE type, GP_RESOLUTION resolution, int8_t engMaximum, int8_t engMinimum, GP_SCALING scaleMaximum, GP_SCALING scaleMinimum, VALUE_TYPE valueType)
eoReturn | AddChannel (CHANNEL_TYPE type, VALUE_TYPE valueType)
eoReturn | AddChannelOut (CHANNEL_TYPE type, VALUE_TYPE valueType)
eoReturn | AddChannel (CHANNEL_TYPE type, GP_RESOLUTION resolution, VALUE_TYPE valueType)
eoReturn | AddChannelOut (CHANNEL_TYPE type, GP_RESOLUTION resolution, VALUE_TYPE valueType)
eoChannelInfo * GetChannel (CHANNEL_TYPE type)
eoChannelInfo * | GetChannel (uint8_t channelNumber)
eoChannelInfo * GetChannelOut (CHANNEL_TYPE type)
eoChannelInfo * | GetChannelOut (uint8_t channelNumber)
eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
eoChannelInfo * | GetChannelOut (CHANNEL_TYPE type, uint8_t subType)
uint8_t | GetChannelCount () const
uint8_t | GetChannelCountOut () const
void | ClearChannels ()
void | ClearChannelsOut ()
void | ClearValues ()
uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
uint32_t | GetProductId ()
void | SetProductId (const uint32_t prodId)
virtual eoReturn | Create (eoMessage &msg)
Generates an EEP Message.
- Public Member Functions inherited from eoProfile
eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
eoReturn | SetManufacturer (uint16_t manufacturerID)

Public Attributes

GP_HEADER_PURPOSE purpose
Teach-In Purpose.
GP_DATA_DIRECTION dataDirection
Data direction.
- Public Attributes inherited from eoProfile
uint8_t | rorg
R-ORG.
uint8_t | func
Func.
uint8_t | type
Type.
uint16_t | manufacturer
Manufacturer.

Additional Inherited Members

- Protected Member Functions inherited from eoProfile
float | ScaleFromRAW (uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax)
Creates floating Point from Raw Value.
uint32_t | ScaleToRAW (float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax)
Creates Raw Value from a floating Point.
- Static Protected Member Functions inherited from eoProfile
static eoReturn | GetRawValue (const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size)
Gives raw data Value from a Message.
static eoReturn | SetRawValue (eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size)
Inserts raw data Value in a message.
- Protected Attributes inherited from eoProfile
eoMessage msg
helper function to convert bits
- Static Protected Attributes inherited from eoProfile
static const uint8_t | maskArray [8]
Mask array.

Detailed Description

The class to handle Generic Profiles.

The eoGenericProfile class allows the user to handle and teachIN genericProfils. Must Functions are the same as in the eoProfile class. For the user application the difference between a generic and an Enocean equipment profile is in most cases transparent.

The eoGenericProfile class adds some functions, to allow the user easy to create an own generic Profile and to manually parse external Teach IN Message.

Examples:
genericProfile_examples.cpp, and tutorial6.cpp.

Constructor & Destructor Documentation

eoGenericProfile::eoGenericProfile ( uint16_t msgLength )

*Constructor

Parameters:
msgLength Length of the generic profile message.

Member Function Documentation

eoReturn eoGenericProfile::AddChannel | ( | CHANNEL_TYPE | type,
 |  | GP_RESOLUTION | resolution,
 |  | int8_t | engMaximum,
 |  | int8_t | engMinimum,
 |  | GP_SCALING | scaleMaximum,
 |  | GP_SCALING | scaleMinimum,
 |  | VALUE_TYPE | valueType
 | ) |  |

Adds an inbound Generic Profile Channel to this Generic Profile with the specified Values.

Parameters:
type
resolution
engMaximum
engMinimum
scaleMaximum
scaleMinimum
valueType
Returns:
Examples:
genericProfile_examples.cpp.
eoReturn eoGenericProfile::AddChannel | ( | CHANNEL_TYPE | type,
 |  | VALUE_TYPE | valueType
 | ) |  |

Allows you to add an inbound Flag Type Generic Channel

Parameters:
type
valueType
Returns:
EO_OK or NOT_SUPPORTED
eoReturn eoGenericProfile::AddChannel | ( | CHANNEL_TYPE | type,
 |  | GP_RESOLUTION | resolution,
 |  | VALUE_TYPE | valueType
 | ) |  |

Allows you to add an inbound ENUM Type Generic Channel

Parameters:
type | Type of the channel - signal,flag etc.
resolution | of the ENum
valueType
Returns:
EO_OK or NOT_SUPPORTED
eoReturn eoGenericProfile::AddChannelOut | ( | CHANNEL_TYPE | type,
 |  | GP_RESOLUTION | resolution,
 |  | int8_t | engMaximum,
 |  | int8_t | engMinimum,
 |  | GP_SCALING | scaleMaximum,
 |  | GP_SCALING | scaleMinimum,
 |  | VALUE_TYPE | valueType
 | ) |  |

Adds an outband Generic Profile Channel to this Generic Profile with the specified Values.

Parameters:
type
resolution
engMaximum
engMinimum
scaleMaximum
scaleMinimum
valueType
Returns:
Examples:
genericProfile_examples.cpp, and tutorial6.cpp.
eoReturn eoGenericProfile::AddChannelOut | ( | CHANNEL_TYPE | type,
 |  | VALUE_TYPE | valueType
 | ) |  |

Allows you to add an outbound Flag Type Generic Channel

Parameters:
type
valueType
Returns:
EO_OK or NOT_SUPPORTED
eoReturn eoGenericProfile::AddChannelOut | ( | CHANNEL_TYPE | type,
 |  | GP_RESOLUTION | resolution,
 |  | VALUE_TYPE | valueType
 | ) |  |

Allows you to add an outband ENUM Type Generic Channel

Parameters:
type | Type of the channel - signal,flag etc.
resolution | of the ENum
valueType
Returns:
EO_OK or NOT_SUPPORTED
void eoGenericProfile::AllowTeachIN ( )

This function will activate the parsing for one Teach IN Telegram! After a parsing of a teachIN message the teachIN function will be deactivated again.

void eoGenericProfile::ClearChannels ( )

Delete all channels and resets the genericProfile

void eoGenericProfile::ClearChannelsOut ( )

Delete all channels and resets the genericProfile

void eoGenericProfile::ClearValues ( )
virtual

All raw values of the internal Message will be set to zero.

Reimplemented from eoProfile.

Examples:
genericProfile_examples.cpp.
eoReturn eoGenericProfile::Create | ( | eoMessage & | m,
 |  | std::vector< int > | channelNumbers
 | ) |  |

creates Selective Data Message

This function will create a Selective Data message as defined in the GenericProfile spec.

Parameters:
msg
channelNumbers
Returns:
Examples:
genericProfile_examples.cpp, and tutorial6.cpp.
virtual eoReturn eoGenericProfile::Create ( eoMessage & m )
virtual

Generates an EEP Message.

This functions generates a Message for the specified EEP, with the current ChannelInfo values

Parameters:
m Reference to the Message (will be cleared and generated new)
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoGenericProfile::CreateTeachIN ( eoMessage & msg )
virtual

creates Teach In Messsage

This function will create a teach in message as defined in the GenericProfile spec. The outbound channels will be used as outbound channel. If inbound channels are set, the dataDirection will be set to bidirectional and the inbound channels will be added inside the "teach-in information"

Parameters:
msg
Returns:

Reimplemented from eoProfile.

Examples:
genericProfile_examples.cpp, and tutorial6.cpp.
eoChannelInfo* eoGenericProfile::GetChannel ( CHANNEL_TYPE type )
virtual

Returns the inbound channel for the selected type

Parameters:
type CHANNEL_TYPE
Returns:
Pointer to ChannelInfo or Null

Reimplemented from eoProfile.

Examples:
genericProfile_examples.cpp.
eoChannelInfo* eoGenericProfile::GetChannel ( uint8_t channelNumber )
virtual

Returns the inbound channel for the selected channelnumber

Parameters:
channelNumber channelnumber
Returns:
Pointer to ChannelInfo or Null

Reimplemented from eoProfile.

eoChannelInfo* eoGenericProfile::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

This function allows you to access different inbound Channels with he same Channel_type. It will return the corresponding Channel or NULL.

For example if you've a GP with 8 S_TEMP and you call GetChannel(S_TEMP,0) it will return the first corresponding Temperature channel. 3 will return the 4 channel and 8 will return NULL;

Parameters:
type | CHANNEL_TYPE
subType | subType specifies which Channel with the same type you want to Select
Returns:

Reimplemented from eoProfile.

uint8_t eoGenericProfile::GetChannelCount ( ) const
virtual

Returns Number of inbound channels for this profile

Returns:
number of channels

Reimplemented from eoProfile.

Examples:
genericProfile_examples.cpp.
uint8_t eoGenericProfile::GetChannelCountOut ( ) const

Returns Number of outbound channels for this profile

Returns:
number of channels
Examples:
genericProfile_examples.cpp.
eoChannelInfo* eoGenericProfile::GetChannelOut ( CHANNEL_TYPE type )

Returns the outbound channel for the selected type

Parameters:
type CHANNEL_TYPE
Returns:
Pointer to ChannelInfo or Null
eoChannelInfo* eoGenericProfile::GetChannelOut ( uint8_t channelNumber )

Returns the pointer to eoChannelInfo for the selected outbound channelNumber or NULL

Parameters:
channelNumber
Returns:
Pointer to Channel
eoChannelInfo* eoGenericProfile::GetChannelOut | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |

This function allows you to access different outband Channels with he same Channel_type. It will return the corresponding Channel or NULL.

Parameters:
type | CHANNEL_TYPE
subType | subType specifies which Channel with the same type you want to Select
Returns:
uint32_t eoGenericProfile::GetProductId ( )

Returns the product ID for this profile

Returns:
product Id
eoReturn eoGenericProfile::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoGenericProfile::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoGenericProfile::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

bool eoGenericProfile::operator!= ( const eoGenericProfile & othProfile ) const

Overloading not equal operator.

Parameters:
othProfile Profile to be compared with.
bool eoGenericProfile::operator== ( const eoGenericProfile & othProfile ) const

Overloading equal operator.

Parameters:
othProfile Profile to be compared with.
eoReturn eoGenericProfile::Parse ( const eoMessage & msg )
virtual

Parses the Messages and will react if it is a Generic Profile Message. When you receive selective of a Full data Message, the internal data will be changed accordingly.

If AllowTeachIN() is activated, a TeachIN Message will be parsed accordingly to the GP SPEC(meaning teachIN or teachOUT are allowed) , and a response will be prepared for you. You can access it via Create(eoMessage &m).

Note:
Then you parse another Message after the TeachIN Message, the Teach IN response will be overwritten!
Parameters:
msg
Returns:

Reimplemented from eoProfile.

eoReturn eoGenericProfile::ParseSelData ( const eoMessage & msg )

Helper function to GP Selected DataChannel

Parameters:
msg GP to parse
Returns:
eoReturn eoGenericProfile::ParseTeachIN ( const eoMessage & msg )

Helper Function to parse TI Message, only works after calling AllowTeachIN()!

Parameters:
msg
Returns:
eoReturn EO_OK, NOT_SUPPORTED
uint8_t eoGenericProfile::Serialize ( eoArchive & arch )
virtual

Serialization Function which will be called by the eoStorageManager.

This function will be called by the eoArchive(inside of the eoStorageManager) and allows the class to be Serialized.

Parameters:
arch archive where to Load or to Store.

Reimplemented from eoProfile.

void eoGenericProfile::SetProductId ( const uint32_t prodId )

Sets the product ID for this profile

Parameters:
prodId product Id
eoReturn eoGenericProfile::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented from eoProfile.

eoReturn eoGenericProfile::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Examples:
genericProfile_examples.cpp, and tutorial6.cpp.
eoReturn eoGenericProfile::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

eoReturn eoGenericProfile::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented from eoProfile.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoGPChannelInfo Class Reference

Public Member Functions | Static Public Member Functions | Public Attributes
eoGPChannelInfo Class Reference
Generic Profile Interface

Generic Profile Channel. More...

#include <eoGPChannelInfo.h>

Inheritance diagram for eoGPChannelInfo:
[legend]
Collaboration diagram for eoGPChannelInfo:
[legend]

List of all members.

Public Member Functions

eoGPChannelInfo ()
eoGPChannelInfo (CHANNEL_TYPE type, GP_RESOLUTION resolution, int8_t engMaximum, int8_t engMinimum, GP_SCALING scaleMaximum, GP_SCALING scaleMinimum)
GP_CHANNELTYPE | GetGPChannelType () const
Get the channel type - signal, flag etc.
GP_RESOLUTION | GetResolution () const
Get the resolution of the channel type.
int8_t | GetEngMax () const
Get the enginnering maximum - without scale.
eoReturn | Scale (int8_t engMaximum)
int8_t | GetEngMin () const
Get the the enginnering minimum - without scale.
GP_SCALING | GetScaleMax () const
Get the GP_SCALING of engineering maximum.
GP_SCALING | GetScaleMin () const
Get the GP_SCALING of engineering minimum.
void | SetRejected (uint8_t rejected)
Set the rejected flag of the channel.
uint8_t | GetRejected ()
Get the rejected flag of the channel.
uint8_t | Serialize (eoArchive &a)
- Public Member Functions inherited from eoChannelInfo
const char * | ToString (uint8_t strType)

Static Public Member Functions

static float ScaleToFloat (GP_SCALING scale)

Public Attributes

uint16_t | bitoffs
Offset of the channel value in data legram in bits.
- Public Attributes inherited from eoChannelInfo
CHANNEL_TYPE type
CHANNEL_TYPE
VALUE_TYPE signalType
Current, Setpoint Absolute, Setpoint relative.
float | min
Min as clear value.
float | max
Max as clear value.

Detailed Description

Generic Profile Channel.

Implements the Generic Profile Channel as described in the GP specification, with the following differences:

CHANNEL_TYPE type contains all Signal,ENUM types. If you want to check the Generic Profile Channel Type use getGPChannelType();

After setting the resolution or the scaling or the engineering values, the real max and min value will be recalculated.

Examples:
genericProfile_examples.cpp.

Constructor & Destructor Documentation

eoGPChannelInfo::eoGPChannelInfo ( )

bitoffs is Calculated automatically and should not be changed!!

eoGPChannelInfo::eoGPChannelInfo | ( | CHANNEL_TYPE | type,
 |  | GP_RESOLUTION | resolution,
 |  | int8_t | engMaximum,
 |  | int8_t | engMinimum,
 |  | GP_SCALING | scaleMaximum,
 |  | GP_SCALING | scaleMinimum
 | ) |  |

Creates an new Generic profil channel info with specific variables.

Parameters:
type | Type of the channel - signal, flag etc.
resolution | Resolution of the new channel.
engMaximum | Engineering maximum of the expected value.
engMinimum | Engineering minimum of the expected value.
scaleMaximum | Scaling factor for engineering maximum of the expected value.
scaleMinimum | Scaling factor for engineering minimum of the expected value.

Member Function Documentation

eoReturn eoGPChannelInfo::Scale ( int8_t engMaximum )

Scale the value according a engineering maximum.

Parameters:
engMaximum
static float eoGPChannelInfo::ScaleToFloat ( GP_SCALING scale )
static

*Convert the GP_SCALING to a float multiplier.

Parameters:
scale the intended scale.
uint8_t eoGPChannelInfo::Serialize ( eoArchive & a )
virtual

*Serialize to an acrchive.

Parameters:
a Intended eoArchive.

Reimplemented from eoISerialize.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Gateway API

Modules | Classes
Gateway API
API

This section describes the Gateway functionality and cooperation with GatewayController firmware. More...

Collaboration diagram for Gateway API:

Modules

Filters
This section describes the filter functionality of the Gateway.
Remote Management API
This section shows the functions and structures used for remote management.
Remote Commissioning API
This section shows the functions and structures used for remote commissioning.
ESP 3 Command Support
This part holds the structures for the support of COMMON COMMANDs from EnOcen Serial Protocol.
Smart Acknowledge Support
This section holds the functions and structures used for smart acknowledge. Smart Acknowledge Lrn is part of the normal teach in process too.

Classes

class | eoGateway
EnOcean Gateway class, for handling a gateway Module. More...
class | eoDevice
a class to describe an EnOcean Device More...
class | eoDeviceManager
Manages the devices. More...
class | eoMessage
Message Class for communication. More...
class | eoPacket
Class which contains a Packet. More...
class | eoChannelInfo
Abstract class for channel information. Abstract class for channel information. From this class specific channel informations classes for Generic Profiles or EEP are derived. More...
class | TEACH_STRUCT
Teach message structure. More...
class | eoProfile
base class for Profile parsing More...
class | eoTeachInModule
handles TeachIn Messages More...
enum RECEIVE_FLAGS {
RECV_PACKET = (1 << 0), RECV_TELEGRAM = (1 << 1), RECV_MESSAGE = (1 << 2), RECV_TEACHIN = (1 << 3),
RECV_PROFILE = (1 << 4), RECV_TELEGRAM_SEC = (1 << 5), RECV_ERROR = (1 << 6), RECV_DEVICE_ADDED = (1 << 7),
RECV_SECTEACHIN = (1 << 8), RECV_REMAN = (1 << 9)
}

Detailed Description

This section describes the Gateway functionality and cooperation with GatewayController firmware.

Enumeration Type Documentation

enum RECEIVE_FLAGS

Receive Flags from the gateway, to handle the receive events.

Enumerator:
RECV_PACKET

Received Package.

RECV_PACKET

RECV_TELEGRAM

Received Telegram.

RECV_TELEGRAM

RECV_MESSAGE

Received Message.

RECV_MESSAGE

RECV_TEACHIN

Received Teach in Telegram.

RECV_TEACHIN

RECV_PROFILE

Received Telegram containing learn_in Profile Information.

RECV_PROFILE

RECV_TELEGRAM_SEC

Received Secured Telegram.

RECV_TELEGRAM_SEC

RECV_ERROR

Received Error Telegram.

RECV_ERROR

RECV_DEVICE_ADDED

Receiver Device Added.

RECV_DEVICE_ADDED

RECV_SECTEACHIN

Receiver got second teachIN.

RECV_SECTEACHIN

RECV_REMAN

Receiver Remote Management MEssage.

RECV_REMAN

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Filters

Classes
Filters
Gateway API

This section describes the filter functionality of the Gateway. More...

Collaboration diagram for Filters:

Classes

class | eodBmFilter
uses Telegram dBm values as filter base More...
class | eoIDFilter
uses EnOcean IDs as filter base More...
class | eoIFilter
Filter Interface. More...

Detailed Description

This section describes the filter functionality of the Gateway.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eodBmFilter Class Reference

Public Member Functions | Public Attributes
eodBmFilter Class Reference
Filters

uses Telegram dBm values as filter base More...

#include <eodBmFilter.h>

Inheritance diagram for eodBmFilter:
[legend]
Collaboration diagram for eodBmFilter:
[legend]

List of all members.

Public Member Functions

eodBmFilter ()
eodBmFilter (int8_t maxDBm, int8_t minDBm)
bool | Filter (eoMessage &msg)
bool | Filter (eoTelegram &tel)
virtual uint8_t | Serialize (eoArchive &arch)
- Public Member Functions inherited from eoIFilter
virtual void | RemoveAll ()

Public Attributes

int8_t | maxdBm
int8_t | mindBm
- Public Attributes inherited from eoIFilter
uint8_t | type
Type.

Detailed Description

uses Telegram dBm values as filter base

eodBmFilter is an easy filter, which allows you to filter a Telegram via the dBm Value

Note:
the dBm value is a signed! value and normally between (far away)-90...-40dBm(near)
Examples:
GatewayFiltered_example.cpp, tutorial1.cpp, and tutorial6.cpp.

Constructor & Destructor Documentation

eodBmFilter::eodBmFilter ( )

Using this constructor, no Telegrams get filtered

eodBmFilter::eodBmFilter | ( | int8_t | maxDBm,
 |  | int8_t | minDBm
 | ) |  |

Constructor which sets max and min DBM

Parameters:
maxDBm | maximal dBM Value allowed
minDBm | minimal dBM Value needed

Member Function Documentation

bool eodBmFilter::Filter ( eoMessage & msg )
virtual

You can't filter normal messages, as they don't contain a dBm Information!

Parameters:
msg Message to Filter
Returns:
false

Reimplemented from eoIFilter.

bool eodBmFilter::Filter ( eoTelegram & tel )
virtual

Filters the Telegram comparing its dBm against the set dBm

Parameters:
tel Telegram to Filter
Returns:
true when the dBm value is between max and min is in the Filter list.

Reimplemented from eoIFilter.

virtual uint8_t eodBmFilter::Serialize ( eoArchive & arch )
virtual

Serialization Function which will be called by the eoStorageManager This function will be called by the eoArchive(inside of the eoStorageManager) and allows the class to be Serialized.

Parameters:
&arch Archive where to Load or to Store.

Reimplemented from eoIFilter.

Member Data Documentation

int8_t eodBmFilter::maxdBm

maximal dBm value which is allowed

Examples:
GatewayFiltered_example.cpp, tutorial1.cpp, and tutorial6.cpp.
int8_t eodBmFilter::mindBm

minimal dBm value which is allowed

Examples:
GatewayFiltered_example.cpp, tutorial1.cpp, and tutorial6.cpp.
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoIDFilter Class Reference

Public Member Functions
eoIDFilter Class Reference
Filters

uses EnOcean IDs as filter base More...

#include <eoIDFilter.h>

Inheritance diagram for eoIDFilter:
[legend]
Collaboration diagram for eoIDFilter:
[legend]

List of all members.

Public Member Functions

bool | Filter (eoMessage &msg)
bool | Filter (eoTelegram &tel)
virtual uint8_t | Serialize (eoArchive &arch)
void | Add (uint32_t id)
void | Remove (uint32_t id)
void | RemoveAll ()

Additional Inherited Members

- Public Attributes inherited from eoIFilter
uint8_t type
Type.

Detailed Description

uses EnOcean IDs as filter base

eoIDFilter is an easy filter, which allows you to filter a Telegram / Message via the ID GatewayFiltered_example.cpp

Examples:
GatewayFiltered_example.cpp, sendTelegram_example.cpp, tutorial1.cpp, tutorial6.cpp, and vld_example.cpp.

Member Function Documentation

void eoIDFilter::Add ( uint32_t id )

Adds an EnOcean ID to the filter

Parameters:
id uint32_t ID
Examples:
GatewayFiltered_example.cpp, and tutorial1.cpp.
bool eoIDFilter::Filter ( eoMessage & msg )
virtual

Filters the Message using the internal ID List

Parameters:
msg Message to Filter
Returns:
true when the Message::sourceID is in the Filter list.

Reimplemented from eoIFilter.

bool eoIDFilter::Filter ( eoTelegram & tel )
virtual

Filters the Message using the internal ID List

Parameters:
tel Telegram to Filter
Returns:
true when the Message::sourceID is in the Filter list.

Reimplemented from eoIFilter.

void eoIDFilter::Remove ( uint32_t id )

Removes an EnOcean ID to the filter

Parameters:
id uint32_t ID
void eoIDFilter::RemoveAll ( )
virtual

Remove all IDS.

Reimplemented from eoIFilter.

virtual uint8_t eoIDFilter::Serialize ( eoArchive & arch )
virtual

Serialization Function which will be called by the eoStorageManager This function will be called by the eoArchive(inside of the eoStorageManager) and allows the class to be Serialized.

Parameters:
&arch Archive where to Load or to Store.

Reimplemented from eoIFilter.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoIFilter Class Reference

Public Member Functions | Public Attributes
eoIFilter Class Reference
Filters

Filter Interface. More...

#include <eoIFilter.h>

Inheritance diagram for eoIFilter:
[legend]
Collaboration diagram for eoIFilter:
[legend]

List of all members.

Public Member Functions

virtual bool | Filter (eoMessage &msg)
virtual bool | Filter (eoTelegram &tel)
virtual uint8_t | Serialize (eoArchive &arch)
virtual void | RemoveAll ()

Public Attributes

uint8_t type
Type.

Detailed Description

Filter Interface.

\ref GatewayFiltered_example.cpp

The Filter Interface allows you to easily Implement your own Filter strategies.Filters are used in the Gateway.

Member Function Documentation

virtual bool eoIFilter::Filter ( eoMessage & msg )
virtual

Applies the specified filter on the Message.

Parameters:
msg
Returns:
false when the message is filtered, else false.

Reimplemented in eodBmFilter, and eoIDFilter.

virtual bool eoIFilter::Filter ( eoTelegram & tel )
virtual

Applies the specified filter on the Telegram.

Parameters:
tel
Returns:
false when the message is filtered, else false.

Reimplemented in eodBmFilter, and eoIDFilter.

virtual void eoIFilter::RemoveAll ( )
virtual

Remove all IDS.

Reimplemented in eoIDFilter.

virtual uint8_t eoIFilter::Serialize ( eoArchive & arch )
virtual

Serialization Function which will be called by the eoStorageManager This function will be called by the eoArchive(inside of the eoStorageManager) and allows the class to be Serialized.

Parameters:
&arch Archive where to Load or to Store.

Reimplemented from eoISerialize.

Reimplemented in eodBmFilter, and eoIDFilter.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Remote Management API

Classes
Remote Management API
Gateway API

This section shows the functions and structures used for remote management. More...

Collaboration diagram for Remote Management API:

Classes

class | eoRemoteManager
Remote Manager interface class. More...
struct | FLASH_READ_RESPONSE
Flash read response structure. More...
struct | LEARNED_SENSOR_RESPONSE
Learned sensors response structure. More...
struct | MAILBOX_SETTINGS_RESPONSE
Mailbox settings response structure. More...
struct | PING_RESPONSE
Ping response structure. More...
struct | QUERY_FUNCTION_RESPONSE
Query function response structure. More...
struct | QUERY_ID
Query ID structure. More...
struct | QUERY_STATUS_RESPONSE
Query status response structure. More...

Detailed Description

This section shows the functions and structures used for remote management.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoRemoteManager Class Reference

Public Member Functions
eoRemoteManager Class Reference
Remote Management API

Remote Manager interface class. More...

#include <eoRemoteManager.h>

List of all members.

Public Member Functions

eoRemoteManager (eoGateway *gateway)
eoReturn | UnLock (const uint32_t securityCode, const uint32_t destinationID)
eoReturn | Lock (const uint32_t securityCode, const uint32_t destinationID)
eoReturn | SetCode (const uint32_t securityCode, const uint32_t destinationID)
eoReturn | Action (const uint32_t destinationID)
eoReturn | Ping (const uint32_t destinationID)
eoReturn | ParsePingAnswer (PING_RESPONSE &response)
eoReturn | QueryID (const QUERY_ID &msg)
eoReturn | ParseQueryIDAnswer (QUERY_ID &response)
eoReturn | QueryFunction (const uint32_t destinationID)
eoReturn | ParseQueryFunctionAnswer (QUERY_FUNCTION_RESPONSE *response, uint8_t maxIDCount, uint8_t &IDCount)
eoReturn | QueryStatus (const uint32_t destinationID)
eoReturn | ParseQueryStatusAnswer (QUERY_STATUS_RESPONSE &response)
eoReturn | RemoteLearnIn (const uint32_t destinationID, REMOTE_TYPE learnFlag)
eoReturn | RemoteFlashWrite (const uint32_t destinationID, const uint16_t &memoryAddress, const uint16_t numOfBytes, const uint8_t data[])
eoReturn | RemoteFlashRead (const uint32_t destinationID, const uint16_t &memoryAddress, const uint16_t numOfBytes)
eoReturn | ParseRemoteFlashReadAnswer (FLASH_READ_RESPONSE *response, uint16_t *dataCount, uint8_t maxDataCount)
eoReturn | RemoteSmartReadMailboxSettings (const uint32_t destinationID)
eoReturn | ParseRemoteSmartReadMailboxSettingsAnswer (MAILBOX_SETTINGS_RESPONSE &response)
eoReturn | RemoteSmartReadLearnedSensors (const uint32_t destinationID)
eoReturn | ParseRemoteSmartReadLearnedSensors (LEARNED_SENSOR_RESPONSE *response, uint8_t *learnedCount, uint8_t maxLearnedCount)
eoReturn | RemoteSmartAddMailbox (const uint32_t destinationID, const uint8_t mailboxIndex, const uint32_t sensorID, const uint32_t postmasterID)
eoReturn | RemoteSmartDeleteMailbox (const uint32_t destinationID, const uint8_t mailboxIndex)
eoReturn | RemoteSmartLearnIn (const uint32_t destinationID, const uint8_t learnCount, const uint32_t sensorID, const uint32_t controllerID)
eoReturn | RemoteSmartLearnOut (const uint32_t destinationID, const uint8_t learnCount, const uint32_t sensorID, const uint32_t controllerID)

Detailed Description

Remote Manager interface class.

Constructor & Destructor Documentation

eoRemoteManager::eoRemoteManager ( eoGateway * gateway )

*Constructor.

Parameters:
gateway eoGateway to be used for remote management.

Member Function Documentation

eoReturn eoRemoteManager::Action ( const uint32_t destinationID )

When this command is received then the addressed device performs an action (audio, visual, etc), depending on the functionality of the device.

Parameters:
destinationID The device ID of the end device
eoReturn eoRemoteManager::Lock | ( | const uint32_t | securityCode,
 |  | const uint32_t | destinationID
 | ) |  |

This command locks the device. Unicast: yes Broadcast: yes Device responses to command: no

Parameters:
destinationID | The device ID of the end device
securityCode | Security code
eoReturn eoRemoteManager::ParsePingAnswer ( PING_RESPONSE & response )

With this command the actor parse the remote management message into the PING_RESPONSE structure. Unicast: yes Broadcast: no Device responses to command: yes

Parameters:
[out] response Pointer to the PING_RESPONSE structure
eoReturn eoRemoteManager::ParseQueryFunctionAnswer | ( | QUERY_FUNCTION_RESPONSE * | response,
 |  | uint8_t | maxIDCount,
 |  | uint8_t & | IDCount
 | ) |  |

With this command the actor parse the remote management message into the QUERY_FUNCTION_RESPONSE structure.

Parameters:
[in] | maxIDCount | Size of the QUERY_FUNCTION_RESPONSE array
[out] | IDCount | The number of entry count on the RPC list
[out] | response | Pointer to the QUERY_FUNCTION_RESPONSE array
eoReturn eoRemoteManager::ParseQueryIDAnswer ( QUERY_ID & response )

With this command the actor parse the remote management message into the QUERY_ID structure.

Parameters:
[out] response Pointer to the QUERY_ID structure
eoReturn eoRemoteManager::ParseQueryStatusAnswer ( QUERY_STATUS_RESPONSE & response )

With this command the actor parse the remote management message into the QUERY_STATUS_RESPONSE structure.

Parameters:
[out] response Pointer to the QUERY_STATUS_RESPONSE array
eoReturn eoRemoteManager::ParseRemoteFlashReadAnswer | ( | FLASH_READ_RESPONSE * | response,
 |  | uint16_t * | dataCount,
 |  | uint8_t | maxDataCount
 | ) |  |

Using this command the actor parse the remote management message into FLASH_READ_RESPONSE structure.

Parameters:
[out] | response | Pointer to the FLASH_READ_RESPONSE array
[out] | dataCount | The number of bytes the device read from the memory
[in] | maxDataCount | Size of the FLASH_READ_RESPONSE array
eoReturn eoRemoteManager::ParseRemoteSmartReadLearnedSensors | ( | LEARNED_SENSOR_RESPONSE * | response,
 |  | uint8_t * | learnedCount,
 |  | uint8_t | maxLearnedCount
 | ) |  |

Using this command the actor parse the remote management message into LEARNED_SENSOR_RESPONSE structure

Parameters:
[out] | response | Pointer to the LEARNED_SENSOR_RESPONSE array
[out] | learnedCount | Number of learned in devices
[in] | maxLearnedCount | Size of the LEARNED_SENSOR_RESPONSE array
eoReturn eoRemoteManager::ParseRemoteSmartReadMailboxSettingsAnswer ( MAILBOX_SETTINGS_RESPONSE & response )

Using this command the actor parse the remote management message into MAILBOX_SETTINGS_RESPONSE structure.

Parameters:
[out] response Pointer to the MAILBOX_SETTINGS_RESPONSE structure
eoReturn eoRemoteManager::Ping ( const uint32_t destinationID )

The ping command functionality is similar to ping in TCP / IP communication. The actor sends a ping request to see if the Remote Device is alive and communicating. Ping requests are processed also when device is in lock status. Remote device sends the radio signal strength of the received request within the ping response. Unicast: yes Broadcast: yes Device responses to command: no

Parameters:
destinationID The device ID of the end device
eoReturn eoRemoteManager::QueryFunction ( const uint32_t destinationID )

With this command the actor requests the supported extended functions list. Unicast: yes Boradcast: no Device responses to command: yes

Parameters:
destinationID The device ID of the end device
eoReturn eoRemoteManager::QueryID ( const QUERY_ID & msg )

With this command the actor requests an answer from a specific EEP. Unicast: no Broadcast: yes Device responses to command: yes

Parameters:
msg Pointer to the QUERY_ID structure
eoReturn eoRemoteManager::QueryStatus ( const uint32_t destinationID )

With this command the actor directly asks for the status info of the Remote Device. Unicast: yes Broadcast: yes Device responses to command: yes The Remote Device answers with remote management debug data.

Parameters:
destinationID The device ID of the end device
eoReturn eoRemoteManager::RemoteFlashRead | ( | const uint32_t | destinationID,
 |  | const uint16_t & | memoryAddress,
 |  | const uint16_t | numOfBytes
 | ) |  |

Using this command the flash can be read from the application. The data requested data area transmitted in RPC telegrams. Unicast: yes Broadcast: no Device responses to command: no

Parameters:
destinationID | The device ID of the end device
memoryAddress | Destination where the data should be read from
numOfBytes | Number of bytes to be read from the flash
eoReturn eoRemoteManager::RemoteFlashWrite | ( | const uint32_t | destinationID,
 |  | const uint16_t & | memoryAddress,
 |  | const uint16_t | numOfBytes,
 |  | const uint8_t | data[]
 | ) |  |

Using this command the flash of a device can be written. Unicast: yes Broadcast: yes Device responses to command: no

Parameters:
destinationID | The device ID of the end device
memoryAddress | Destination where the data should be stored
numOfBytes | Number of bytes to be transfered and written to the flash
data[] | Array to be transfered and written to the flash
eoReturn eoRemoteManager::RemoteLearnIn | ( | const uint32_t | destinationID,
 |  | REMOTE_TYPE | learnFlag
 | ) |  |

Determines the device type to learn in, all other devices learn telegrams are ignored. Unicast: yes Broadcast: yes Device responses to command: no

Parameters:
destinationID | The device ID of the end device
learnFlag | Determines different behaviour of the learn procedure
eoReturn eoRemoteManager::RemoteSmartAddMailbox | ( | const uint32_t | destinationID,
 |  | const uint8_t | mailboxIndex,
 |  | const uint32_t | sensorID,
 |  | const uint32_t | postmasterID
 | ) |  |

Using this command the device adds a mailbox. Only for controller! Unicast: yes Broadcast: no

Parameters:
destinationID | The device ID of the end device
mailboxIndex | Index of the mailbox
sensorID | The device ID of the sensor
postmasterID | The device ID of the postmaster
eoReturn eoRemoteManager::RemoteSmartDeleteMailbox | ( | const uint32_t | destinationID,
 |  | const uint8_t | mailboxIndex
 | ) |  |

Using this command the device deletes the mailbox.

Parameters:
destinationID | The device ID of the postmaster
mailboxIndex | Index of the mailbox
eoReturn eoRemoteManager::RemoteSmartLearnIn | ( | const uint32_t | destinationID,
 |  | const uint8_t | learnCount,
 |  | const uint32_t | sensorID,
 |  | const uint32_t | controllerID
 | ) |  |

Using this command the device learns out the sensor. Only for controller!

Parameters:
destinationID | The device ID of the controller
learnCount | Learn count
sensorID | Device ID of the sensor
controllerID | Device ID of the controller or postmaster
eoReturn eoRemoteManager::RemoteSmartLearnOut | ( | const uint32_t | destinationID,
 |  | const uint8_t | learnCount,
 |  | const uint32_t | sensorID,
 |  | const uint32_t | controllerID
 | ) |  |

Using this command the device learns out the sensor. Only for controller!

Parameters:
destinationID | The device ID of the controller
learnCount | Learn count
sensorID | Device ID of the sensor
controllerID | Device ID of the controller or postmaster
eoReturn eoRemoteManager::RemoteSmartReadLearnedSensors ( const uint32_t destinationID )

Using this command the learned in sensors can be read. Unicast: yes Broadcast: no Device responses to command: yes

Parameters:
destinationID The device ID of the end device
eoReturn eoRemoteManager::RemoteSmartReadMailboxSettings ( const uint32_t destinationID )

Using this command the mailbox setting can be read. Unicast: yes Broadcast: no Device responses to command: yes

Parameters:
destinationID The device ID of the end device
eoReturn eoRemoteManager::SetCode | ( | const uint32_t | securityCode,
 |  | const uint32_t | destinationID
 | ) |  |

This command sets the security code of the device. Unicast: yes Broadcast: yes Device responses to command: no

Parameters:
destinationID | The device ID of the end device
securityCode | Security code
eoReturn eoRemoteManager::UnLock | ( | const uint32_t | securityCode,
 |  | const uint32_t | destinationID
 | ) |  |

This command unlocks the device. Unicast: yes Broadcast: yes Device responses to command: no

Parameters:
destinationID | The device ID of the end device
securityCode | Security code
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: FLASH_READ_RESPONSE Struct Reference

Public Attributes
FLASH_READ_RESPONSE Struct Reference
Remote Management API

Flash read response structure. More...

#include <eoRemoteManager.h>

List of all members.

Public Attributes

uint8_t data
Read data.

Detailed Description

Flash read response structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: LEARNED_SENSOR_RESPONSE Struct Reference

Public Attributes
LEARNED_SENSOR_RESPONSE Struct Reference
Remote Management API

Learned sensors response structure. More...

#include <eoRemoteManager.h>

List of all members.

Public Attributes

uint32_t | sensorID
Device ID of the sensor.
uint32_t | controllerID
Device ID of the controller.
uint8_t | learnedCount
Number of learned in devices.

Detailed Description

Learned sensors response structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: MAILBOX_SETTINGS_RESPONSE Struct Reference

Public Attributes
MAILBOX_SETTINGS_RESPONSE Struct Reference
Remote Management API

Mailbox settings response structure. More...

#include <eoRemoteManager.h>

List of all members.

Public Attributes

uint16_t | flashAddress
SmartAck flash address where the settings are stored.
uint16_t | mailboxCount
Number of mailboxes.

Detailed Description

Mailbox settings response structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: PING_RESPONSE Struct Reference

Public Attributes
PING_RESPONSE Struct Reference
Remote Management API

Ping response structure. More...

#include <eoRemoteManager.h>

List of all members.

Public Attributes

uint8_t | rorg
EEP RORG.
uint8_t | func
EEP Function.
uint8_t | type
EEP Type.
int8_t | rssi
RSSI of the pinged device.

Detailed Description

Ping response structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: QUERY_FUNCTION_RESPONSE Struct Reference

Public Attributes
QUERY_FUNCTION_RESPONSE Struct Reference
Remote Management API

Query function response structure. More...

#include <eoRemoteManager.h>

List of all members.

Public Attributes

uint16_t | functionNum
Function number.
uint16_t | manufaturerID
Manufacturer ID.

Detailed Description

Query function response structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: QUERY_ID Struct Reference

Public Attributes
QUERY_ID Struct Reference
Remote Management API

Query ID structure. More...

#include <eoRemoteManager.h>

List of all members.

Public Attributes

uint8_t | rorg
EEP RORG - 8 bit.
uint8_t | func
EEP Function - 6 bit.
uint8_t | type
EEP Type - 7 bit.

Detailed Description

Query ID structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: QUERY_STATUS_RESPONSE Struct Reference

Public Attributes
QUERY_STATUS_RESPONSE Struct Reference
Remote Management API

Query status response structure. More...

#include <eoRemoteManager.h>

List of all members.

Public Attributes

bool | codeSetFlag
Code set flag.
uint8_t | lastSEQ
Last SEQ.
uint16_t | lastFunc
Last function code.
uint8_t | lastFuncRet
Last function return code.

Detailed Description

Query status response structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Remote Commissioning API

Classes
Remote Commissioning API
Gateway API

This section shows the functions and structures used for remote commissioning. More...

Collaboration diagram for Remote Commissioning API:

Classes

class | eoReCom
Remote Commissioning interface class. More...
enum eoReComReturn {
RECOM_OK = 0x00, RECOM_WRONG_ID = 0x01, RECOM_WRONG_UNLOCK_CODE = 0x02, RECOM_WRONG_EEP = 0x03,
RECOM_WRONG_MANUFACTURER_ID = 0x04, RECOM_WRONG_DATA_SIZE = 0x05, RECOM_NO_CODE_SET = 0x06, RECOM_NOT_SEND = 0x07,
RECOM_RPC_FAIL = 0x08, RECOM_MSG_TIMEOUT = 0x09, RECOM_MSG_TOO_LONG = 0x0A, RECOM_MSG_PART_RECEIVED = 0x0B,
RECOM_MSG_PART_NOT_RECEIVED = 0x0C, RECOM_ADDR_OUT_OF_RANGE = 0x0D, RECOM_CODE_DATA_SIZE_EXCEED = 0x0E, RECOM_WRONG_DATA = 0x0F
}
Contains all the return values from ReCom functions. More...
enum FN_RECOM_CODE {
FN_RECOM_ACK = 0x240, FN_RECOM_GET_METADATA = 0x210, FN_RECOM_GET_METADATA_RESPONSE = 0x810, FN_RECOM_GET_TABLE = 0x211,
FN_RECOM_GET_TABLE_RESPONSE = 0x811, FN_RECOM_SET_TABLE = 0x212, FN_RECOM_GET_GP_TABLE = 0x213, FN_RECOM_GET_GP_TABLE_RESPONSE = 0x813,
FN_RECOM_SET_GP_TABLE = 0x214, FN_RECOM_SET_LEARN_MODE = 0x220, FN_RECOM_TRIG_OUTBOUND_TEACH_REQ = 0x221, FN_RECOM_GET_DEVICE_CONFIG = 0x230,
FN_RECOM_GET_DEVICE_CONFIG_RESPONSE = 0x830, FN_RECOM_SET_DEVICE_CONFIG = 0x231, FN_RECOM_GET_LINK_BASED_CONFIG = 0x232, FN_RECOM_GET_LINK_BASED_CONFIG_RESPONSE = 0x832,
FN_RECOM_SET_LINK_BASED_CONFIG = 0x233, FN_RECOM_APPLY_CHANGES = 0x226, FN_RECOM_RESET_TO_DEFAULTS = 0x224, FN_RECOM_RADIO_LINK_TEST_CONTROL = 0x225,
FN_RECOM_GET_PRODUCT_ID = 0x227, FN_RECOM_GET_PRODUCT_RESPONSE = 0x827, FN_RECOM_GET_REPEATER_FUNCTIONS = 0x250, FN_RECOM_GET_REPEATER_FUNCTIONS_RESPONSE = 0x850,
FN_RECOM_SET_REPEATER_FUNCTIONS = 0x251, FN_RECOM_SET_REPEATER_FILTER = 0x252
}
Function codes for Remote Commissioning. More...
enum | RECOM_SUPPORT { RECOM_NOT_SUPPORTED = 0x00, RECOM_SUPPORTED = 0x01 }
Enums for supported flags. More...
enum | RECOM_TABLE_DIR { RECOM_INBOUND_TABLE = 0x00, RECOM_OUTBOUND_TABLE = 0x01 }
Enums for table direction. More...
enum | RECOM_CHANGES { RECOM_CHANGES_NOT_APPLY = 0x00, RECOM_CHANGES_APPLY = 0x01 }
Enums for changes. More...
enum | RECOM_LEARN_MODE { RECOM_LEARN_IN = 0x00, RECOM_LEARN_OUT = 0x01, RECOM_EXIT_LEARN = 0x02 }
Enums for learn modes. More...
enum | RECOM_RESET { RECOM_NO_DEFAULT_RESET = 0x00, RECOM_DEFAULT_RESET = 0x01 }
Enums for configuration. More...
enum | RECOM_REPEATER_FUNC { RECOM_REPEATER_OFF = 0x00, RECOM_REPEATER_ON = 0x01, RECOM_FILTERED_REPEATER_ON = 0x02 }
Enums for repeater function. More...
enum | RECOM_REPEATER_LEVEL { RECOM_REPEATER_LEVEL_1 = 0x01, RECOM_REPEATER_LEVEL_2 = 0x02 }
Enums for repeater level. More...
enum | RECOM_REPEATER_FILTER { RECOM_REPEATER_AND = 0x00, RECOM_REPEATER_OR = 0x01 }
Enums for repeater filter. More...
enum | RECOM_REPEATER_FILTER_CONTROL { RECOM_REPEATER_BLOCK = 0x00, RECOM_REPEATER_APPLY = 0x01, RECOM_REPEATER_DELETE_FILTER = 0x02, RECOM_REPEATER_DELETE_ALL = 0x03 }
Enums for repeater filter control. More...
enum | RECOM_REPEATER_FILTER_TYPE { RECOM_FILTER_SOURCE_ID = 0x00, RECOM_FILTER_RORG = 0x01, RECOM_FILTER_DBM = 0x02, RECOM_FILTER_DESTINATION_ID = 0x03 }
Enums for repeater filter type. More...
typedef struct gplinkTable | GP_LINK_TABLE

Detailed Description

This section shows the functions and structures used for remote commissioning.

Enumeration Type Documentation

enum eoReComReturn

Contains all the return values from ReCom functions.

Enumerator:
RECOM_OK

OK.

RECOM_WRONG_ID

Wrong target ID.

RECOM_WRONG_UNLOCK_CODE

Wrong unlock code.

RECOM_WRONG_EEP

Wrong EEP.

RECOM_WRONG_MANUFACTURER_ID

Wrong manufacturer ID.

RECOM_WRONG_DATA_SIZE

Wrong data size.

RECOM_NO_CODE_SET

No code set.

RECOM_NOT_SEND

Not send.

RECOM_RPC_FAIL

RPC failed.

RECOM_MSG_TIMEOUT

Message time out.

RECOM_MSG_TOO_LONG

Too long message.

RECOM_MSG_PART_RECEIVED

Message part already received.

RECOM_MSG_PART_NOT_RECEIVED

Message part not received.

RECOM_ADDR_OUT_OF_RANGE

Address out of range.

RECOM_CODE_DATA_SIZE_EXCEED

Code data size exceeded.

RECOM_WRONG_DATA

Wrong data.

enum FN_RECOM_CODE

Function codes for Remote Commissioning.

Enumerator:
FN_RECOM_ACK

Remote Commissioning Acknowledge.

FN_RECOM_GET_METADATA

Get Link Table Metadata Query.

FN_RECOM_GET_METADATA_RESPONSE

Get Link Table Metadata Response.

FN_RECOM_GET_TABLE

Get Link Table Query.

FN_RECOM_GET_TABLE_RESPONSE

Get Link Table Response.

FN_RECOM_SET_TABLE

Set Link Table Query.

FN_RECOM_GET_GP_TABLE

Get Link Table GP Entry Query.

FN_RECOM_GET_GP_TABLE_RESPONSE

Get Link Table GP Entry Response.

FN_RECOM_SET_GP_TABLE

Set Link Table GP Entry Query.

FN_RECOM_SET_LEARN_MODE

Remote Set Learn Mode.

FN_RECOM_TRIG_OUTBOUND_TEACH_REQ

Trigger Outbound Remote Teach Request.

FN_RECOM_GET_DEVICE_CONFIG

Get Device Configuration Query.

FN_RECOM_GET_DEVICE_CONFIG_RESPONSE

Get Device Configuration Response.

FN_RECOM_SET_DEVICE_CONFIG

Set Device Configuration Query.

FN_RECOM_GET_LINK_BASED_CONFIG

Get Link Based Configuration Query.

FN_RECOM_GET_LINK_BASED_CONFIG_RESPONSE

Get Link Based Configuration Response.

FN_RECOM_SET_LINK_BASED_CONFIG

Set Link Based Configuration Query.

FN_RECOM_APPLY_CHANGES

Apply Changes Command.

FN_RECOM_RESET_TO_DEFAULTS

Reset to Defaults.

FN_RECOM_RADIO_LINK_TEST_CONTROL

Radio Link Test Control.

FN_RECOM_GET_PRODUCT_ID

Get Product ID Query.

FN_RECOM_GET_PRODUCT_RESPONSE

Get Product ID Response.

FN_RECOM_GET_REPEATER_FUNCTIONS

Get Repeater Functions Query.

FN_RECOM_GET_REPEATER_FUNCTIONS_RESPONSE

Get Repeater Functions Response.

FN_RECOM_SET_REPEATER_FUNCTIONS

Set Repeater Functions Query.

FN_RECOM_SET_REPEATER_FILTER

Set Repeater Filter Query.

enum RECOM_CHANGES

Enums for changes.

Enumerator:
RECOM_CHANGES_NOT_APPLY

Do not apply changes.

RECOM_CHANGES_APPLY

Apply changes.

enum RECOM_LEARN_MODE

Enums for learn modes.

Enumerator:
RECOM_LEARN_IN

Learn in mode.

RECOM_LEARN_OUT

Learn out mode.

RECOM_EXIT_LEARN

Exit any learn mode.

enum RECOM_REPEATER_FILTER

Enums for repeater filter.

Enumerator:
RECOM_REPEATER_AND

Repeater filter AND.

RECOM_REPEATER_OR

Repeater filter OR.

enum RECOM_REPEATER_FILTER_CONTROL

Enums for repeater filter control.

Enumerator:
RECOM_REPEATER_BLOCK

Repeater filter Block.

RECOM_REPEATER_APPLY

Repeater filter Apply.

RECOM_REPEATER_DELETE_FILTER

Repeater filter delete specified.

RECOM_REPEATER_DELETE_ALL

Repeater filter delete all filter.

enum RECOM_REPEATER_FILTER_TYPE

Enums for repeater filter type.

Enumerator:
RECOM_FILTER_SOURCE_ID

Repeater filter source ID.

RECOM_FILTER_RORG

Repeater filter RORG.

RECOM_FILTER_DBM

Repeater filter dBm.

RECOM_FILTER_DESTINATION_ID

Repeater filter destination ID.

enum RECOM_REPEATER_FUNC

Enums for repeater function.

Enumerator:
RECOM_REPEATER_OFF

Repeater off.

RECOM_REPEATER_ON

Repeater on.

RECOM_FILTERED_REPEATER_ON

Filtered repeating on.

enum RECOM_REPEATER_LEVEL

Enums for repeater level.

Enumerator:
RECOM_REPEATER_LEVEL_1

Repeater level 1.

RECOM_REPEATER_LEVEL_2

Repeater level 2.

enum RECOM_RESET

Enums for configuration.

Enumerator:
RECOM_NO_DEFAULT_RESET

Do not reset default.

RECOM_DEFAULT_RESET

Reset default.

enum RECOM_SUPPORT

Enums for supported flags.

Enumerator:
RECOM_NOT_SUPPORTED

Not supported.

RECOM_SUPPORTED

Supported.

enum RECOM_TABLE_DIR

Enums for table direction.

Enumerator:
RECOM_INBOUND_TABLE

Inbound.

RECOM_OUTBOUND_TABLE

Outbound.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoReCom Class Reference

Public Member Functions
eoReCom Class Reference
Remote Commissioning API

Remote Commissioning interface class. More...

#include <eoReCom.h>

List of all members.

Public Member Functions

eoReCom (eoGateway *gateway)
eoReturn | GetMetadata (uint32_t destinationID)
eoReturn | ParseGetMetadataResponse (QUERY_METADATA_RESPONSE &response) const
eoReturn | GetLinkTable (QUERY_LINK_TABLE const &query, uint32_t const destinationID)
eoReturn | ParseGetLinkTableResponse (std::vector< LINK_TABLE > &response, RECOM_TABLE_DIR &tableDir) const
eoReturn | SetLinkTable (std::vector< LINK_TABLE > const &query, RECOM_TABLE_DIR tableDir, uint32_t destinationID)
eoReturn | GetGPLinkTable (GP_LINK_TABLE const &query, uint32_t destinationID)
eoReturn | ParseGetGPLinkTableResponse (GP_LINK_TABLE &query) const
eoReturn | SetGPLinkTable (GP_LINK_TABLE const &query, uint32_t destinationID)
eoReturn | RemoteSetLearnMode (QUERY_SET_LEARN_MODE const &learnMode, uint32_t destinationID)
eoReturn | TriggerOutboundTeachRequest (uint8_t channel, uint32_t destinationID)
eoReturn | GetDeviceConfig (QUERY_DEVICE_CONFIG const &deviceConf, uint32_t destinationID)
eoReturn | ParseDeviceConfigResponse (std::vector< DEVICE_CONFIG > &deviceConf) const
eoReturn | SetDeviceConfig (std::vector< DEVICE_CONFIG > const &deviceConf, uint32_t destinationID)
eoReturn | GetLinkBasedConfig (QUERY_LINK_BASED_CONFIG const &linkConfig, uint32_t destinationID)
eoReturn | SetLinkBasedConfig (std::vector< LINK_BASED_CONFIG > const &linkConfig, uint32_t destinationID)
eoReturn | ParseLinkBasedConfigResponse (std::vector< LINK_BASED_CONFIG > &linkConfig) const
eoReturn | ApplyChanges (QUERY_APPLY_CHANGES const &changes, uint32_t destinationID)
eoReturn | ResetDefaults (QUERY_RESET_DEFAULTS const &defaults, uint32_t destinationID)
eoReturn | RadioLinkTest (QUERY_RADIO_LINK_TEST const &radioLink, uint32_t destinationID)
eoReturn | GetProductID (uint32_t destinationID=BROADCAST_ID)
eoReturn | ParseGetProductIDResponse (QUERY_PRODUCT_ID_RESPONSE &response) const
eoReturn | GetRepeater (uint32_t destinationID)
eoReturn | ParseGetRepeaterResponse (REPEATER_FUNCTIONS &response) const
eoReturn | SetRepeater (REPEATER_FUNCTIONS const &repeaterFunc, uint32_t destinationID)
eoReturn | SetRepeaterFilter (QUERY_SET_REPEATER_FILTER const &repeaterFunc, uint32_t destinationID)

Detailed Description

Remote Commissioning interface class.

This helper class, allows sending and parsing of different Remote Commissioning commands. The command parameter are wrapped in different parameter helper structs. For a detailed explanation of remote commissioning please consult the ReCom Spec.

Constructor & Destructor Documentation

eoReCom::eoReCom ( eoGateway * gateway )

*Constructor.

Parameters:
gateway eoGateway to be used for remote commissioning.

Member Function Documentation

eoReturn eoReCom::ApplyChanges | ( | QUERY_APPLY_CHANGES const & | changes,
 |  | uint32_t | destinationID
 | ) |  |

Apply changes command. Unicast: yes Broadcast: no Command has paired response: no

Parameters:
changes | QUERY_APPLY_CHANGES structure
destinationID | The device ID of the end device
eoReturn eoReCom::GetDeviceConfig | ( | QUERY_DEVICE_CONFIG const & | deviceConf,
 |  | uint32_t | destinationID
 | ) |  |

Get device configuration query. Unicast: yes Broadcast: no Command has paired response: yes

Parameters:
deviceConf | device configuration query arguments
destinationID | The device ID of the end device
eoReturn eoReCom::GetGPLinkTable | ( | GP_LINK_TABLE const & | query,
 |  | uint32_t | destinationID
 | ) |  |

Get GP Link table command. Unicast: yes Broadcast: no Device response to command: yes

Parameters:
query | GP_LINK_TABLE
destinationID | ID of the recom device to modify
eoReturn eoReCom::GetLinkBasedConfig | ( | QUERY_LINK_BASED_CONFIG const & | linkConfig,
 |  | uint32_t | destinationID
 | ) |  |

Get link based configuration query. Unicast: yes Broadcast: no Command has paired response: yes

Parameters:
linkConfig | QUERY_LINK_BASED_CONFIG structure
destinationID | The device ID of the end device
eoReturn eoReCom::GetLinkTable | ( | QUERY_LINK_TABLE const & | query,
 |  | uint32_t const | destinationID
 | ) |  |

Get link table command. Unicast: yes Broadcast: no Command has paired response: yes

Parameters:
query | QUERY_LINK_TABLE structure
destinationID | The device ID of the end device
eoReturn eoReCom::GetMetadata ( uint32_t destinationID )

Get link table metadata command. Unicast: yes Broadcast: no Command has paired response: yes

Parameters:
destinationID The device ID of the end device
eoReturn eoReCom::GetProductID ( uint32_t destinationID = BROADCAST_ID )

Get prodcut ID. Unicast: yes Broadcast: yes Command has paired response: yes

Parameters:
destinationID The device ID of the end device
eoReturn eoReCom::GetRepeater ( uint32_t destinationID )

Get repeater functions query. Unicast: yes Broadcast: no Command has paired response: yes

Note:
To stop the beaconing of the Get Product ID Response, an addressed reman message needs to be send.
Parameters:
destinationID The device ID of the end device
eoReturn eoReCom::ParseDeviceConfigResponse ( std::vector< DEVICE_CONFIG > & deviceConf ) const

Parses the device config response

Parameters:
deviceConf vector to store the response, new elements will be pushed to the back of the vector
Returns:
eoReturn eoReCom::ParseGetGPLinkTableResponse ( GP_LINK_TABLE & query ) const

Parses the GP Link table response

Parameters:
query response parsed
Note:
the data array inside of the query, will be deleted and a new block of memory will be allocated!
Returns:
eoReturn eoReCom::ParseGetLinkTableResponse | ( | std::vector< LINK_TABLE > & | response,
 |  | RECOM_TABLE_DIR & | tableDir
 | ) |  | const

With this command the actor parse the remote commission message into a LINK_TABLE structure. Unicast: yes Broadcast: no Command has paired response: yes

Parameters:
[out] | response | Link Table response will be added to this pointer
[out] | tableDir | The table direction of the returned entries
eoReturn eoReCom::ParseGetMetadataResponse ( QUERY_METADATA_RESPONSE & response ) const

With this command the actor parse the remote commission message into a QUERY_METADATA_RESPONSE structure. Unicast: yes Broadcast: no Command has paired response: yes

Parameters:
[out] response Metadata response
eoReturn eoReCom::ParseGetProductIDResponse ( QUERY_PRODUCT_ID_RESPONSE & response ) const

With this command the actor parse the remote commission message into a QUERY_PRODUCT_ID_RESPONSE structure. Unicast: yes Broadcast: yes Command has paired response: yes

Note:
After sending a productID Request, each ReCom device sends ProductID Response in beaconing mode, until an addressed reman answer has been sent.
Parameters:
[out] response QUERY_PRODUCT_ID_RESPONSE structure
eoReturn eoReCom::ParseGetRepeaterResponse ( REPEATER_FUNCTIONS & response ) const

With this command the actor parse the remote commission message into a REPEATER_FUNCTIONS structure. Unicast: yes Broadcast: no Command has paired response: yes

Parameters:
[out] response REPEATER_FUNCTIONS structure
eoReturn eoReCom::ParseLinkBasedConfigResponse ( std::vector< LINK_BASED_CONFIG > & linkConfig ) const

Parses the device config response

Parameters:
linkConfig vector to store the response, new elements will be pushed to the back of the vector
Returns:
eoReturn eoReCom::RadioLinkTest | ( | QUERY_RADIO_LINK_TEST const & | radioLink,
 |  | uint32_t | destinationID
 | ) |  |

Radio link test control. Unicast: yes Broadcast: no Command has paired response: yes

Parameters:
radioLink | QUERY_RADIO_LINK_TEST structure
destinationID | The device ID of the end device
eoReturn eoReCom::RemoteSetLearnMode | ( | QUERY_SET_LEARN_MODE const & | learnMode,
 |  | uint32_t | destinationID
 | ) |  |

Remote set learn mode. Unicast: yes Broadcast: yes Command has paired response: no

Parameters:
learnMode | Device learn mode
destinationID | The device ID of the end device
eoReturn eoReCom::ResetDefaults | ( | QUERY_RESET_DEFAULTS const & | defaults,
 |  | uint32_t | destinationID
 | ) |  |

Reset to defaults. Unicast: yes Broadcast: yes Command has paired response: no

Parameters:
defaults | QUERY_RESET_DEFAULTS structure
destinationID | The device ID of the end device
eoReturn eoReCom::SetDeviceConfig | ( | std::vector< DEVICE_CONFIG > const & | deviceConf,
 |  | uint32_t | destinationID
 | ) |  |

Set device configuration. Unicast: yes Broadcast: no Command has paired response: no

Parameters:
deviceConf | list of config parameters
destinationID | device ID
Returns:
eoReturn eoReCom::SetGPLinkTable | ( | GP_LINK_TABLE const & | query,
 |  | uint32_t | destinationID
 | ) |  |

Set link table content command. Unicast: yes Broadcast: yes Command has paired response: no

Parameters:
query
destinationID
Returns:
eoReturn eoReCom::SetLinkBasedConfig | ( | std::vector< LINK_BASED_CONFIG > const & | linkConfig,
 |  | uint32_t | destinationID
 | ) |  |

Set Link based configuration query Unicast: yes Broadcast: no

Parameters:
linkConfig vector containing the parameters
Note:
Warning the direction and table index will be taken from the first entry, entries which have a different direction or table index will be skipped!
Parameters:
destinationID
Returns:
eoReturn eoReCom::SetLinkTable | ( | std::vector< LINK_TABLE > const & | query,
 |  | RECOM_TABLE_DIR | tableDir,
 |  | uint32_t | destinationID
 | ) |  |

Set link table content command. Unicast: yes Broadcast: yes Command has paired response: yes

Parameters:
query | LINK_TABLE structures in a vector.
tableDir | The table direction of the entries
destinationID | The device ID of the end device
eoReturn eoReCom::SetRepeater | ( | REPEATER_FUNCTIONS const & | repeaterFunc,
 |  | uint32_t | destinationID
 | ) |  |

Set repeater function. Unicast: yes Broadcast: no Command has paired response: no

Parameters:
repeaterFunc | paramters to set
destinationID | The device ID of the end device
eoReturn eoReCom::SetRepeaterFilter | ( | QUERY_SET_REPEATER_FILTER const & | repeaterFunc,
 |  | uint32_t | destinationID
 | ) |  |

Set repeater function. Unicast: yes Broadcast: no Command has paired response: no

Parameters:
repeaterFunc | filter to set
destinationID | The device ID of the end device
eoReturn eoReCom::TriggerOutboundTeachRequest | ( | uint8_t | channel,
 |  | uint32_t | destinationID
 | ) |  |

Trigger outbound remote teach request. Unicast: yes Broadcast: no Command has paired response: yes

Parameters:
channel | Channel selection
destinationID | The device ID of the end device
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoReCom.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoReCom.h File Reference

eoRemoteCommissioning More...

#include "eoGateway.h"
#include "eoGenericProfile.h"
Include dependency graph for eoReCom.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | QUERY_METADATA_RESPONSE
Query metadata response structure. More...
struct | QUERY_LINK_TABLE
Query link table structure. More...
struct | LINK_TABLE
Entry for get/set link table. More...
struct | QUERY_SET_LEARN_MODE
Set learn mode structure. More...
struct | QUERY_DEVICE_CONFIG
Query device configuration. More...
struct | DEVICE_CONFIG
Dvice configuration response. More...
struct | QUERY_LINK_BASED_CONFIG
Query link based configuration. More...
struct | QUERY_APPLY_CHANGES
Apply changes struct. More...
struct | QUERY_RESET_DEFAULTS
Query reset structure. More...
struct | QUERY_RADIO_LINK_TEST
Radio link test control. More...
struct | QUERY_PRODUCT_ID_RESPONSE
Get product ID response. More...
struct | QUERY_SET_REPEATER_FILTER
Set repeater filter. More...
class | eoReCom
Remote Commissioning interface class. More...
enum eoReComReturn {
RECOM_OK = 0x00, RECOM_WRONG_ID = 0x01, RECOM_WRONG_UNLOCK_CODE = 0x02, RECOM_WRONG_EEP = 0x03,
RECOM_WRONG_MANUFACTURER_ID = 0x04, RECOM_WRONG_DATA_SIZE = 0x05, RECOM_NO_CODE_SET = 0x06, RECOM_NOT_SEND = 0x07,
RECOM_RPC_FAIL = 0x08, RECOM_MSG_TIMEOUT = 0x09, RECOM_MSG_TOO_LONG = 0x0A, RECOM_MSG_PART_RECEIVED = 0x0B,
RECOM_MSG_PART_NOT_RECEIVED = 0x0C, RECOM_ADDR_OUT_OF_RANGE = 0x0D, RECOM_CODE_DATA_SIZE_EXCEED = 0x0E, RECOM_WRONG_DATA = 0x0F
}
Contains all the return values from ReCom functions. More...
enum FN_RECOM_CODE {
FN_RECOM_ACK = 0x240, FN_RECOM_GET_METADATA = 0x210, FN_RECOM_GET_METADATA_RESPONSE = 0x810, FN_RECOM_GET_TABLE = 0x211,
FN_RECOM_GET_TABLE_RESPONSE = 0x811, FN_RECOM_SET_TABLE = 0x212, FN_RECOM_GET_GP_TABLE = 0x213, FN_RECOM_GET_GP_TABLE_RESPONSE = 0x813,
FN_RECOM_SET_GP_TABLE = 0x214, FN_RECOM_SET_LEARN_MODE = 0x220, FN_RECOM_TRIG_OUTBOUND_TEACH_REQ = 0x221, FN_RECOM_GET_DEVICE_CONFIG = 0x230,
FN_RECOM_GET_DEVICE_CONFIG_RESPONSE = 0x830, FN_RECOM_SET_DEVICE_CONFIG = 0x231, FN_RECOM_GET_LINK_BASED_CONFIG = 0x232, FN_RECOM_GET_LINK_BASED_CONFIG_RESPONSE = 0x832,
FN_RECOM_SET_LINK_BASED_CONFIG = 0x233, FN_RECOM_APPLY_CHANGES = 0x226, FN_RECOM_RESET_TO_DEFAULTS = 0x224, FN_RECOM_RADIO_LINK_TEST_CONTROL = 0x225,
FN_RECOM_GET_PRODUCT_ID = 0x227, FN_RECOM_GET_PRODUCT_RESPONSE = 0x827, FN_RECOM_GET_REPEATER_FUNCTIONS = 0x250, FN_RECOM_GET_REPEATER_FUNCTIONS_RESPONSE = 0x850,
FN_RECOM_SET_REPEATER_FUNCTIONS = 0x251, FN_RECOM_SET_REPEATER_FILTER = 0x252
}
Function codes for Remote Commissioning. More...
enum | RECOM_SUPPORT { RECOM_NOT_SUPPORTED = 0x00, RECOM_SUPPORTED = 0x01 }
Enums for supported flags. More...
enum | RECOM_TABLE_DIR { RECOM_INBOUND_TABLE = 0x00, RECOM_OUTBOUND_TABLE = 0x01 }
Enums for table direction. More...
enum | RECOM_CHANGES { RECOM_CHANGES_NOT_APPLY = 0x00, RECOM_CHANGES_APPLY = 0x01 }
Enums for changes. More...
enum | RECOM_LEARN_MODE { RECOM_LEARN_IN = 0x00, RECOM_LEARN_OUT = 0x01, RECOM_EXIT_LEARN = 0x02 }
Enums for learn modes. More...
enum | RECOM_RESET { RECOM_NO_DEFAULT_RESET = 0x00, RECOM_DEFAULT_RESET = 0x01 }
Enums for configuration. More...
enum | RECOM_REPEATER_FUNC { RECOM_REPEATER_OFF = 0x00, RECOM_REPEATER_ON = 0x01, RECOM_FILTERED_REPEATER_ON = 0x02 }
Enums for repeater function. More...
enum | RECOM_REPEATER_LEVEL { RECOM_REPEATER_LEVEL_1 = 0x01, RECOM_REPEATER_LEVEL_2 = 0x02 }
Enums for repeater level. More...
enum | RECOM_REPEATER_FILTER { RECOM_REPEATER_AND = 0x00, RECOM_REPEATER_OR = 0x01 }
Enums for repeater filter. More...
enum | RECOM_REPEATER_FILTER_CONTROL { RECOM_REPEATER_BLOCK = 0x00, RECOM_REPEATER_APPLY = 0x01, RECOM_REPEATER_DELETE_FILTER = 0x02, RECOM_REPEATER_DELETE_ALL = 0x03 }
Enums for repeater filter control. More...
enum | RECOM_REPEATER_FILTER_TYPE { RECOM_FILTER_SOURCE_ID = 0x00, RECOM_FILTER_RORG = 0x01, RECOM_FILTER_DBM = 0x02, RECOM_FILTER_DESTINATION_ID = 0x03 }
Enums for repeater filter type. More...
typedef struct gplinkTable | GP_LINK_TABLE

Detailed Description

eoRemoteCommissioning

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: ESP 3 Command Support

Classes
ESP 3 Command Support
Gateway API

This part holds the structures for the support of COMMON COMMANDs from EnOcen Serial Protocol. More...

Collaboration diagram for ESP 3 Command Support:

Classes

class | eoGateway
EnOcean Gateway class, for handling a gateway Module. More...
class | eoSerialCommand
EnOcean Common Commands class, enables an easy interface for the most common commands. More...
class | CO_RD_FILTER_RESPONSE
Read filter response. More...
class | CO_RD_IDBASE_RESPONSE
Read base ID response. More...
class | CO_RD_REPEATER_RESPONSE
Read repeater response. More...
class | CO_RD_VERSION_RESPONSE
Read version response. More...
class | CO_READY_RESPONSE
Ready response. More...

Detailed Description

This part holds the structures for the support of COMMON COMMANDs from EnOcen Serial Protocol.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoGateway Class Reference

Public Member Functions | Public Attributes
eoGateway Class Reference
Gateway API | ESP 3 Command Support

EnOcean Gateway class, for handling a gateway Module. More...

#include <eoGateway.h>

Inheritance diagram for eoGateway:
[legend]
Collaboration diagram for eoGateway:
[legend]

List of all members.

Public Member Functions

void | LearnModeOn ()
Activates Learn Mode.
void | LearnModeOff ()
Deactivates Learn Mode.
uint32_t | GetSecWatchResult () const
Returns the security Result of the eoIWatcher Interface.
eoGateway ()
eoGateway (eoDeviceManager *devManager)
eoGateway (eoPacketStream *str)
eoGateway (eoPacketStream *str, eoDeviceManager *devManager)
eoGateway (eoPacketStream *str, eoDeviceManager *devManager, eoIFilter *normFilter, eoIFilter *lrnFilter)
uint16_t | Receive ()
Handles received Telegrams.
eoReturn | Send (const eoPacket &p)
eoReturn | Send (const eoMessage &msg)
virtual eoReturn | Send (const eoReManMessage &reMsg)
eoReturn | Open (const char *port)
void | Close ()
uint8_t | Serialize (eoArchive &arch)
Serialization Function which will be called by the eoStorageManager.

Public Attributes

eoPacketStream * stream
Pointer to the eoPacketStream Handler.
eoTeachInModule * TeachInModule
Pointer to eoTeachInModule.
eoDeviceManager * deviceManager
Pointer to the device manager, handling your Devices.
eoIFilter * filter
eoIFilter * learnFilter
eoIWatcher * secWatcher
security Watcher to Use
bool | LearnMode
When true, activates LearnMode until set to False.
uint8_t | errorCode
contains the last Error Code from the receive function
eoDevice * device
Pointer to the device, to which the last received Telegram belongs.
eoPacket packet
received Packet data
eoPacket responsePacket
Response Packet after sending any sort of Packet/Message/Telegram with the Gateway.
eoTelegram telegram
received Telegram
eoMessage message
received Message
eoReManMessage reManMessage
received Remote Management Message
eoSerialCommand commands
Common Commands.
bool | advancedMode
Advanced mode turned on.
eoSecurity security
Security handler for the gateway.

Detailed Description

EnOcean Gateway class, for handling a gateway Module.

The eoGateway class, allows you to easily handle Packages received from an EnOcean Gateway module(USB300,TCM310...). with simple calls you can learn in Devices, add filters, check if you received a Message and send packets.
The eoGateway has two different modes the learnMode and the normalMode. After creating the eoGateway the Gateway is in the normalMode, the following steps explain the functionality of the receive function.

  1. Receive packet
  2. Is Telegram?
  3. Encrypted Telegram-> if Yes decrypt
  4. Is the Telegram a part of a chained Message?
  5. Telegram gets handled and can be accessed unless it gets filtered.

    1. Learn MODE!
      Uses the learnFilter (if it is set) to Filter telegrams. Always add the Device to device Manager(flag|=RECV_DEVICE_ADDED), when it is a Security Teach IN, store secure Information. The eoGateway::device is set accordingly.

      When an EEP Teach IN telegram is received, it is handled by the eoTeachInModule. If the telegram contains the func,type the right eoProfile will be created. As for rps no Teach IN telegram is specified you've to use eoTeachInModule::SetRPS function.

      If you receive a second Teach IN from a learned IN EEP device the RECV_SECTEACHIN will be set.

    2. Normal Mode Uses the filter (if it is set) to Filter telegrams. If the device is in the deviceManager it is set to the Device, otherwise it returns a dummy device with the ID 0, which is not in the deviceManger.
  6. If we get a EEP TeachIN telegram(4bs or 1bs) set the RECV_TEACHIN flag, so you're application can handle always teachINS
  7. If the gateway has a profile saved for the received telegram, parse the data and set RECV_PROFILE
Note:
deviceManger,stream and TeachInModule will be destroyed in the Destructor, if you need to keep them, set the Pointer to NULL before calling the Destructor!
*To be sure that no telegram gets missed, ensure that eoGateway::Receive() is called at least once every 100ms.
Examples:
commands_example.cpp, Gateway_example.cpp, Gateway_SubtypeExample.cpp, GatewayFiltered_example.cpp, genericProfile_examples.cpp, HelloWorld.cpp, Security_example.cpp, sendTelegram_example.cpp, storage_example.cpp, tutorial1.cpp, tutorial2.cpp, tutorial3.cpp, tutorial4.cpp, tutorial5.cpp, tutorial6.cpp, vld_example.cpp, and WatcherMain.cpp.

Constructor & Destructor Documentation

eoGateway::eoGateway ( )

Creates your EnOcean gateway class, with the hardware specific PacketStream Handler and a new DeviceManager

eoGateway::eoGateway ( eoDeviceManager * devManager )

Creates your EnOcean gateway class, with the hardware specific PacketStream Handler.

Parameters:
devManager - createas a Gateway with a specified eoDeviceManager.
eoGateway::eoGateway ( eoPacketStream * str )

Creates your EnOcean gateway class.

Parameters:
str - createas a Gateway with a specified eoPacketStream.
eoGateway::eoGateway | ( | eoPacketStream * | str,
 |  | eoDeviceManager * | devManager
 | ) |  |

Creates your EnOcean gateway class.

Parameters:
str | - createas a Gateway with a specified eoPacketStream.
devManager | - createas a Gateway with a specified eoDeviceManager.
eoGateway::eoGateway | ( | eoPacketStream * | str,
 |  | eoDeviceManager * | devManager,
 |  | eoIFilter * | normFilter,
 |  | eoIFilter * | lrnFilter
 | ) |  |

Creates your EnOcean gateway class.

Parameters:
str | - createas a Gateway with a specified eoPacketStream.
devManager | - createas a Gateway with a specified eoDeviceManager.
normFilter | - createas a Gateway with a specified filter for data communication.
lrnFilter | - createas a Gateway with a specified filter for learn process.

Member Function Documentation

void eoGateway::Close ( )

Closes the connection.

Examples:
genericProfile_examples.cpp.
eoReturn eoGateway::Open ( const char * port )

Tries to open a connection to the specified Port

Parameters:
port to open; for example "/dev/ttyUSB0"
Returns:
eoReturn EO_OK if everything was ok else PORT_ERROR
Examples:
commands_example.cpp, Gateway_example.cpp, Gateway_SubtypeExample.cpp, GatewayFiltered_example.cpp, genericProfile_examples.cpp, HelloWorld.cpp, Security_example.cpp, sendTelegram_example.cpp, tutorial1.cpp, tutorial2.cpp, tutorial3.cpp, tutorial4.cpp, tutorial5.cpp, tutorial6.cpp, vld_example.cpp, and WatcherMain.cpp.
uint16_t eoGateway::Receive ( )

Handles received Telegrams.

The receive function handles all incoming Packets.
Depending if we're in LearnMode or not the handling differs. In normal mode:

When a packet has been received (RECV_PACKET), it automatically tries to decode as much as possible from the Packet.
If the Packet contains a Telegram the Telegram variable will be filled if it is not filtered from the filter, (RECV_TELEGRAM)
If the Telegram is a chained Message, the message will be filled(RECV_MESSAGE)
If the Telegram is secured and the device is learn_in the telegram will be decrypted (RECV_TELEGRAM_SEC)
If the Telegram is from a learned in EEP or GP Device the profile Information will be set (RECV_PROFILE)

In LearnMode data will handled as in normal mode but the learnFilter will be used to Filter telegram & Devices will be learned in as specified in the [EEP] or [GP] document.

When a second 4BS or 1BS Teach IN telegram from the same devices gets received, the RECV_SECTEACHIN flag will be set.

If you're in normal mode, a RECV_TEACHIN flag will be set for 4BS and 1BS Teach IN telegrams, but the device&&profile will not be learned in!

Note:
the RECV_TEACHIN flag is set, so that the user can implement his own learn IN System

*

Note:
*To be sure that no telegram gets missed, ensure that eoGateway::Receive() is called at least once every 100ms.
Returns:
RECEIVE_FLAGS
Examples:
Gateway_example.cpp, Gateway_SubtypeExample.cpp, GatewayFiltered_example.cpp, genericProfile_examples.cpp, HelloWorld.cpp, tutorial1.cpp, tutorial2.cpp, tutorial3.cpp, tutorial4.cpp, tutorial6.cpp, vld_example.cpp, and WatcherMain.cpp.
eoReturn eoGateway::Send ( const eoPacket & p )

sends Packet to the connected device

Note:
the Gateway waits for a Response, as defined in the ESP3 for maximal 500ms! In the worst case you need to wait for such a long time
Parameters:
p Packet to send
Returns:
eoReturn
Examples:
genericProfile_examples.cpp, Security_example.cpp, sendTelegram_example.cpp, tutorial1.cpp, tutorial2.cpp, tutorial3.cpp, tutorial6.cpp, and vld_example.cpp.
eoReturn eoGateway::Send ( const eoMessage & msg )

sends a Message via the connected device

Parameters:
msg Message to send
Returns:
eoReturn
virtual eoReturn eoGateway::Send ( const eoReManMessage & reMsg )
virtual

sends a Message via the connected device

Parameters:
reMsg Remote Management Message to send
Returns:
eoReturn
uint8_t eoGateway::Serialize ( eoArchive & arch )
virtual

Serialization Function which will be called by the eoStorageManager.

This function will be called by the eoArchive(inside of the eoStorageManager) and allows the class to be Serialized.

Parameters:
arch archive where to Load or to Store.

Reimplemented from eoISerialize.

Member Data Documentation

eoDevice* eoGateway::device

Pointer to the device, to which the last received Telegram belongs.

Note:
could be a NULL Pointer!!!
Examples:
Gateway_example.cpp, Gateway_SubtypeExample.cpp, GatewayFiltered_example.cpp, genericProfile_examples.cpp, tutorial1.cpp, tutorial2.cpp, tutorial3.cpp, tutorial6.cpp, vld_example.cpp, and WatcherMain.cpp.
eoIFilter* eoGateway::filter

when this Filter points to a Filter implementation, the received telegram will be filtered while not in learn Mode.

Note:
To use no filter, filter=NULL
Examples:
GatewayFiltered_example.cpp, sendTelegram_example.cpp, tutorial1.cpp, tutorial6.cpp, and vld_example.cpp.
eoIFilter* eoGateway::learnFilter

This filter will bes used in learnMod

Note:
To use no filter, filter=NULL
Examples:
GatewayFiltered_example.cpp, tutorial1.cpp, and tutorial6.cpp.
eoMessage eoGateway::message

received Message

Note:
contains the last received data!
Examples:
genericProfile_examples.cpp, tutorial1.cpp, tutorial4.cpp, and tutorial6.cpp.
eoPacket eoGateway::packet

received Packet data

Note:
contains the last received data!
Examples:
Gateway_example.cpp, Gateway_SubtypeExample.cpp, and vld_example.cpp.
eoReManMessage eoGateway::reManMessage

received Remote Management Message

Note:
contains the last received data!#
eoTelegram eoGateway::telegram

received Telegram

Note:
contains the last received data!
Examples:
Gateway_example.cpp, Gateway_SubtypeExample.cpp, GatewayFiltered_example.cpp, genericProfile_examples.cpp, HelloWorld.cpp, tutorial1.cpp, tutorial6.cpp, vld_example.cpp, and WatcherMain.cpp.
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoSerialCommand Class Reference

Public Member Functions
eoSerialCommand Class Reference
ESP 3 Command Support | Smart Acknowledge Support

EnOcean Common Commands class, enables an easy interface for the most common commands. More...

#include <eoSerialCommand.h>

List of all members.

Public Member Functions

eoSerialCommand (eoGateway *gateway)
eoReturn | Sleep (const uint32_t sleepPeriod)
eoReturn Reset ()
eoReturn | ReadVersion (CO_RD_VERSION_RESPONSE &version)
eoReturn BIST ()
eoReturn | WriteIDBase (const uint32_t baseID)
eoReturn | ReadIDBase (CO_RD_IDBASE_RESPONSE &response)
eoReturn | WriteRepeater (bool repEnable, const uint8_t repLevel)
eoReturn | ReadRepeater (CO_RD_REPEATER_RESPONSE &response)
eoReturn | AddFilter (const FILTER_TYPE filterType, const uint32_t filterValue, const FILTER_KIND filterKind)
eoReturn | DeleteFilter (const FILTER_TYPE filterType, const uint32_t filterValue)
eoReturn DeleteAllFilter ()
eoReturn | EnableFilter (const bool filterEnabled, const FILTER_OPERATOR filterOperator)
eoReturn | ReadFilter (CO_RD_FILTER_RESPONSE *filter, uint8_t *filterCount, uint8_t maxFilterCount)
eoReturn | WaitMaturity (const bool waitMaturity)
eoReturn | SmartAckConfirmLearn (uint16_t responseTime, SA_CONFIRM_CODE confirmCode)
eoReturn | SmartAckLearnAck (SA_LEARN_ACK_RESPONSE &response)
eoReturn | Ready (CO_READY_RESPONSE &response)
eoReturn | SmartAckWriteLearnMode (bool enable, SA_EXTENDED_LEARNMODE extended, uint32_t timeout)
eoReturn | SmartAckReadLearnMode (SA_RD_LEARNMODE_RESPONSE &response)
eoReturn | SmartAckLearnConfirm (uint16_t responseTime, SMARTACK_CONFIRM_CODE confirmCode, uint32_t postmasterID, uint32_t clientID)
eoReturn | SmartAckSendLearnRequest (uint16_t manufacturerID, uint32_t EEP)
eoReturn | SmartAckReset (uint32_t clientID)
eoReturn | SmartAckLearnedClients (SA_RD_LEARNEDCLIENTS_RESPONSE *clients, uint8_t *learnedCount, uint8_t maxLearnedCount)
eoReturn | SmartAckSetReclaimTries (uint8_t reclaimCount)
eoReturn | SmartAckSetPostmaster (uint8_t mailboxCount)
eoReturn | EventSmartAckConfirmLearn (SA_CONFIRM_LEARN_REQUEST &request)
eoReturn | WriteMode (WR_MODE_CODE mode)
eoReturn | DutyCycleReadLimit (CO_RD_DUTYCYCLE_RESPONSE &response)
eoReturn | EventDutyCycleLimit (CO_DUTYCYCLE_LIMIT &request)
eoReturn | DutyCycleLimit (CO_DUTYCYCLE_LIMIT limit)
eoPacket GetSerialPacket ()

Detailed Description

EnOcean Common Commands class, enables an easy interface for the most common commands.

The eoCommonCommand class, allows you to easily integrate the most common ESP commands into your program.

Examples:
commands_example.cpp, Security_example.cpp, tutorial5.cpp, and tutorial6.cpp.

Constructor & Destructor Documentation

eoSerialCommand::eoSerialCommand ( eoGateway * gateway )

*Contructor

Parameters:
gateway Gateway to be used for serial command.

Member Function Documentation

eoReturn eoSerialCommand::AddFilter | ( | const FILTER_TYPE | filterType,
 |  | const uint32_t | filterValue,
 |  | const FILTER_KIND | filterKind
 | ) |  |

*Add filter to filter list.

Parameters:
filterType | Type of filter
filterValue | Value of filter function compare
filterKind | Blocking/Applying filter
Returns:
EO_OK or NOT_SUPPORTED or WRONG_PARAM or memory error
Examples:
commands_example.cpp, and tutorial5.cpp.
eoReturn eoSerialCommand::BIST ( )

*Read System Log from device databank.

Returns:
EO_OK or NOT_SUPPORTED
Examples:
commands_example.cpp, and tutorial5.cpp.
eoReturn eoSerialCommand::DeleteAllFilter ( )

*Delete all filters from filter list.

Returns:
EO_OK or NOT_SUPPORTED
Examples:
commands_example.cpp, and tutorial5.cpp.
eoReturn eoSerialCommand::DeleteFilter | ( | const FILTER_TYPE | filterType,
 |  | const uint32_t | filterValue
 | ) |  |

*Delete filter from filter list.

Parameters:
filterType | Type of filter
filterValue | Value of filter function compare
Returns:
EO_OK or NOT_SUPPORTED or WRONG_PARAM or memory error
Examples:
commands_example.cpp, and tutorial5.cpp.
eoReturn eoSerialCommand::DutyCycleLimit ( CO_DUTYCYCLE_LIMIT limit )

Send Duty Cycle Limit telegram.

Parameters:
limit CO_DUTYCYCLE_LIMIT
eoReturn eoSerialCommand::DutyCycleReadLimit ( CO_RD_DUTYCYCLE_RESPONSE & response )

*Reads the actual duty cycle limit values.

Parameters:
[out] response Pointer to the duty cycle read limit response structure
Returns:
EO_OK or NOT_SUPPORTED
eoReturn eoSerialCommand::EnableFilter | ( | const bool | filterEnabled,
 |  | const FILTER_OPERATOR | filterOperator
 | ) |  |

*Enable/Disable all supplied filters.

Parameters:
filterEnabled | Filter enable
filterOperator | Filter operator (AND or OR)
Returns:
EO_OK or NOT_SUPPORTED or WRONG_PARAM
Examples:
commands_example.cpp, and tutorial5.cpp.
eoReturn eoSerialCommand::EventDutyCycleLimit ( CO_DUTYCYCLE_LIMIT & request )

Parse the Duty Cycle Limit event into enum

Parameters:
request CO_DUTYCYCLE_LIMIT
eoReturn eoSerialCommand::EventSmartAckConfirmLearn ( SA_CONFIRM_LEARN_REQUEST & request )

Parse the SmartACK confirm learn event packet into structure

Parameters:
request SA_CONFIRM_LEARN_REQUEST structure
eoPacket eoSerialCommand::GetSerialPacket ( )

Get a copy of the last generated SerialPacket, mainly for debugging issues

Returns:
eoReturn eoSerialCommand::ReadFilter | ( | CO_RD_FILTER_RESPONSE * | filter,
 |  | uint8_t * | filterCount,
 |  | uint8_t | maxFilterCount
 | ) |  |

*Read supplied filters.

Parameters:
[out] | filter | Pointer to the CO_RD_FILTER_RESPONSE structure
[out] | filterCount | Pointer to the variable where the number of filters stored in the devices is stored
[in] | maxFilterCount | The size of the CO_RD_FILTER_RESPONSE array
Returns:
EO_OK or NOT_SUPPORTED
Examples:
commands_example.cpp, and tutorial5.cpp.
eoReturn eoSerialCommand::ReadIDBase ( CO_RD_IDBASE_RESPONSE & response )

*READ ID range base number.

Parameters:
[out] response Pointer to CO_RD_IDBASE_RESPONSE structure
Returns:
EO_OK or NOT_SUPPORTED
Examples:
commands_example.cpp, and tutorial5.cpp.
eoReturn eoSerialCommand::ReadRepeater ( CO_RD_REPEATER_RESPONSE & response )

*Read Repeater Level OFF, 1, 2.

Parameters:
[out] response Pointer to the CO_RD_REPEATER_RESPONSE structure
Returns:
EO_OK or NOT_SUPPORTED
Examples:
commands_example.cpp, and tutorial5.cpp.
eoReturn eoSerialCommand::ReadVersion ( CO_RD_VERSION_RESPONSE & version )

*Read the device SW version / HW version, chip-ID, etc.

Parameters:
[out] version Pointer to the CO_RD_VERSION_RESPONSE structure
Returns:
EO_OK or NOT_SUPPORTED
Examples:
commands_example.cpp, HelloWorld.cpp, tutorial5.cpp, tutorial6.cpp, and WatcherMain.cpp.
eoReturn eoSerialCommand::Ready ( CO_READY_RESPONSE & response )

*Parse the last received gateway.packet into ready response structure.

Parameters:
[out] response Pointer to the CO_READY_RESPONSE structure
Returns:
EO_OK or NOT_SUPPORTED
eoReturn eoSerialCommand::Reset ( )

*Order to reset the Device

Returns:
EO_OK or NOT_SUPPORTED
eoReturn eoSerialCommand::Sleep ( const uint32_t sleepPeriod )

*Order to enter the energy saving mode.

Parameters:
sleepPeriod The value of deep sleep period in 10 ms units
Returns:
EO_OK or NOT_SUPPORTED
eoReturn eoSerialCommand::SmartAckConfirmLearn | ( | uint16_t | responseTime,
 |  | SA_CONFIRM_CODE | confirmCode
 | ) |  |

*Response from backbone controller how to handle the received learn request.

Parameters:
[in] | responseTime | Response time for client in ms
[in] | confirmCode | Confirmation code
Returns:
EO_OK or NOT_SUPPORTED
eoReturn eoSerialCommand::SmartAckLearnAck ( SA_LEARN_ACK_RESPONSE & response )

*Parse the last received gateway.packet into LearnAck response structure

Parameters:
[out] response Pointer to the SA_LEARN_ACK_RESPONSE structure
Returns:
EO_OK or NOT_SUPPORTED
eoReturn eoSerialCommand::SmartAckLearnConfirm | ( | uint16_t | responseTime,
 |  | SMARTACK_CONFIRM_CODE | confirmCode,
 |  | uint32_t | postmasterID,
 |  | uint32_t | clientID
 | ) |  |

*Send smart ack learn answer to modify mailbox at postmaster.

Parameters:
responseTime | Response time for sensor in ms
confirmCode | Learn IN/OUT
postmasterID | Device ID of the used Post master
clientID | Device ID of the learned IN/OUT client
Returns:
EO_OK or NOT_SUPPORTED or WRONG_PARAM
eoReturn eoSerialCommand::SmartAckLearnedClients | ( | SA_RD_LEARNEDCLIENTS_RESPONSE * | clients,
 |  | uint8_t * | learnedCount,
 |  | uint8_t | maxLearnedCount
 | ) |  |

*Read mailbox information at the Post Master device, about all learned Smart Ack clients.

Parameters:
[out] | *clients | Pointer to the Learned clients response structure
[out] | *learnedCount | Number of Learned clients
[in] | maxLearnedCount | The size of the Learned clients response array
Returns:
EO_OK or NOT_SUPPORTED or WRONG_PARAM
eoReturn eoSerialCommand::SmartAckReadLearnMode ( SA_RD_LEARNMODE_RESPONSE & response )

*Reads the learnmode state of Smart Ack Controller.

Parameters:
[out] response Pointer to the learnmode response structure
Returns:
EO_OK or NOT_SUPPORTED
eoReturn eoSerialCommand::SmartAckReset ( uint32_t clientID )

*Send reset command to a Smart Ack Client.

Parameters:
clientID Device ID of the client
Returns:
EO_OK or NOT_SUPPORTED or WRONG_PARAM
eoReturn eoSerialCommand::SmartAckSendLearnRequest | ( | uint16_t | manufacturerID,
 |  | uint32_t | EEP
 | ) |  |

*Sends Smart Ack Learn Request telegram to Smart Ack Controller. This function will only be used in a Smart Ack Client.

Parameters:
manufacturerID
EEP
Returns:
EO_OK or NOT_SUPPORTED or WRONG_PARAM
eoReturn eoSerialCommand::SmartAckSetPostmaster ( uint8_t mailboxCount )

*Set the amount of reclaim tries in Smart Ack Client.

Parameters:
mailboxCount Amount of mailboxes available
Returns:
EO_OK or NOT_SUPPORTED or WRONG_PARAM
eoReturn eoSerialCommand::SmartAckSetReclaimTries ( uint8_t reclaimCount )

*Set the amount of reclaim tries in Smart Ack Client.

Parameters:
reclaimCount Preseting for the number of required reclaim tries
Returns:
EO_OK or NOT_SUPPORTED or WRONG_PARAM
eoReturn eoSerialCommand::SmartAckWriteLearnMode | ( | bool | enable,
 |  | SA_EXTENDED_LEARNMODE | extended,
 |  | uint32_t | timeout
 | ) |  |

*Enables or disables learn mode of Smart Ack Controller.

Parameters:
enable | Start/End Learnmode
extended | Simple/Advanced Learnmode
timeout | Time-out of learnmode in ms
Returns:
EO_OK or NOT_SUPPORTED or WRONG_PARAM
eoReturn eoSerialCommand::WaitMaturity ( const bool waitMaturity )

*Waiting till end of maturity time before received radio telegrams will transmit.

Parameters:
waitMaturity Bool value
Returns:
EO_OK or NOT_SUPPORTED or WRONG_PARAM
Examples:
commands_example.cpp, and tutorial5.cpp.
eoReturn eoSerialCommand::WriteIDBase ( const uint32_t baseID )

*Write ID range base number.

Parameters:
baseID Base ID
Returns:
EO_OK or NOT_SUPPORTED
eoReturn eoSerialCommand::WriteMode ( WR_MODE_CODE mode )

Change the mode between Advanced and Compatible mode (default)

Parameters:
mode WR_MODE_CODE enum
eoReturn eoSerialCommand::WriteRepeater | ( | bool | repEnable,
 |  | const uint8_t | repLevel
 | ) |  |

*Write Repeater Level OFF, 1, 2.

Parameters:
repEnable | Repeater Enable
repLevel | Repeater Level
Returns:
EO_OK or NOT_SUPPORTED or WRONG_PARAM
Examples:
commands_example.cpp, and tutorial5.cpp.
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: CO_RD_FILTER_RESPONSE Class Reference

Public Attributes
CO_RD_FILTER_RESPONSE Class Reference
ESP 3 Command Support

Read filter response. More...

#include <eoSerialCommand.h>

List of all members.

Public Attributes

FILTER_TYPE filterType
Filter type.
uint32_t filterValue
Filter value.

Detailed Description

Read filter response.

Examples:
commands_example.cpp, and tutorial5.cpp.
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: CO_RD_IDBASE_RESPONSE Class Reference

Public Attributes
CO_RD_IDBASE_RESPONSE Class Reference
ESP 3 Command Support

Read base ID response. More...

#include <eoSerialCommand.h>

List of all members.

Public Attributes

uint32_t | baseID
Base ID.
uint8_t | remainingWrites
Remaining write cycles for base ID.

Detailed Description

Read base ID response.

Examples:
commands_example.cpp, and tutorial5.cpp.
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: CO_RD_REPEATER_RESPONSE Class Reference

Public Attributes
CO_RD_REPEATER_RESPONSE Class Reference
ESP 3 Command Support

Read repeater response. More...

#include <eoSerialCommand.h>

List of all members.

Public Attributes

bool | repEnable
Repeater enabled.
uint8_t | repLevel
Repeater level.

Detailed Description

Read repeater response.

Examples:
commands_example.cpp, and tutorial5.cpp.
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: CO_RD_VERSION_RESPONSE Class Reference

Public Attributes
CO_RD_VERSION_RESPONSE Class Reference
ESP 3 Command Support

Read version response. More...

#include <eoSerialCommand.h>

List of all members.

Public Attributes

uint8_t | appVersion [4]
Application version.
char | appDescription [16]
Application description.
uint8_t | apiVersion [4]
API version.
uint32_t | chipID
Chip ID.
uint32_t | chipVersion
Chip version (reserved for internal use)

Detailed Description

Read version response.

Examples:
commands_example.cpp, HelloWorld.cpp, Security_example.cpp, tutorial5.cpp, tutorial6.cpp, and WatcherMain.cpp.
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: CO_READY_RESPONSE Class Reference

Public Attributes
CO_READY_RESPONSE Class Reference
ESP 3 Command Support

Ready response. More...

#include <eoSerialCommand.h>

List of all members.

Public Attributes

EC_RESET_CAUSE resetCause
Cause of reset.

Detailed Description

Ready response.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Smart Acknowledge Support

Classes
Smart Acknowledge Support
Gateway API

This section holds the functions and structures used for smart acknowledge. Smart Acknowledge Lrn is part of the normal teach in process too. More...

Collaboration diagram for Smart Acknowledge Support:

Classes

class | eoSerialCommand
EnOcean Common Commands class, enables an easy interface for the most common commands. More...
class | SA_LEARN_ACK_RESPONSE
Learn SmartAck response. More...
class | SA_RD_LEARNEDCLIENTS_RESPONSE
SmartAck learned clients response structure. More...
class | SA_RD_LEARNMODE_RESPONSE
SmartAck read learnmode response structure. More...

Detailed Description

This section holds the functions and structures used for smart acknowledge. Smart Acknowledge Lrn is part of the normal teach in process too.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: SA_LEARN_ACK_RESPONSE Class Reference

Public Attributes
SA_LEARN_ACK_RESPONSE Class Reference
Smart Acknowledge Support

Learn SmartAck response. More...

#include <eoSerialCommand.h>

List of all members.

Public Attributes

uint16_t responseTime
Response time for Smart Ack Client in ms in which the controller can prepare the data and send it to the postmaster. Only actual if learn return code is Learn IN.
SA_CONFIRM_CODE confirmCode
Confirmation Code.

Detailed Description

Learn SmartAck response.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: SA_RD_LEARNEDCLIENTS_RESPONSE Class Reference

Public Attributes
SA_RD_LEARNEDCLIENTS_RESPONSE Class Reference
Smart Acknowledge Support

SmartAck learned clients response structure. More...

#include <eoSerialCommand.h>

List of all members.

Public Attributes

uint32_t | clientID
Device ID of the Smart Ack Client.
uint32_t | postmasterID
Postmaster ID dedicated Smart Ack Client.
uint8_t | mailboxIndex
Internal counter of Post master (0x00 ... 0x0E)

Detailed Description

SmartAck learned clients response structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: SA_RD_LEARNMODE_RESPONSE Class Reference

Public Attributes
SA_RD_LEARNMODE_RESPONSE Class Reference
Smart Acknowledge Support

SmartAck read learnmode response structure. More...

#include <eoSerialCommand.h>

List of all members.

Public Attributes

bool enabled
Learnmode not active = 0/Learnmode active = 1.
SA_EXTENDED_LEARNMODE extended
Simple Learnmode = 0/Advance Learnmode = 1/Advance Learnmode select Rep. = 2.

Detailed Description

SmartAck read learnmode response structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoDevice Class Reference

Public Member Functions | Public Attributes
eoDevice Class Reference
Gateway API

a class to describe an EnOcean Device More...

#include <eoDevice.h>

Inheritance diagram for eoDevice:
[legend]
Collaboration diagram for eoDevice:
[legend]

List of all members.

Public Member Functions

eoDevice (uint32_t id)
eoReturn | SetProfile (eoProfile *myProfile)
eoReturn | SetProfile (const uint8_t rorg, const uint8_t func, const uint8_t type)
eoProfile * | GetProfile () const
uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.

Public Attributes

int8_t | dBm
uint32_t | ID
eoSecureInfo secIn
eoSecureInfo secOut

Detailed Description

a class to describe an EnOcean Device

this class contains all Information to handle a Device.

Examples:
deviceManager_example.cpp, and Security_example.cpp.

Constructor & Destructor Documentation

eoDevice::eoDevice ( uint32_t id )

*Constructor.

Parameters:
id EnOcean ID of the device.

Member Function Documentation

eoProfile* eoDevice::GetProfile ( ) const

Gets the Pointer to the eoProfile from this instance

Returns:
the device eoProfile
Examples:
Gateway_example.cpp, Gateway_SubtypeExample.cpp, GatewayFiltered_example.cpp, genericProfile_examples.cpp, tutorial1.cpp, tutorial2.cpp, tutorial3.cpp, tutorial6.cpp, vld_example.cpp, and WatcherMain.cpp.
uint8_t eoDevice::Serialize ( eoArchive & arch )
virtual

Serialization Function which will be called by the eoStorageManager.

This function will be called by the eoArchive(inside of the eoStorageManager) and allows the class to be Serialized.

Parameters:
arch archive where to Load or to Store.

Reimplemented from eoISerialize.

eoReturn eoDevice::SetProfile ( eoProfile * myProfile )

The used Profile will be destroyed and myProfile will be used for the Device

Parameters:
myProfile
Returns:
eoReturn::EO_OK or eoReturn::WRONG_PARAM if the profile overmitted has the same EEP
eoReturn eoDevice::SetProfile | ( | const uint8_t | rorg,
 |  | const uint8_t | func,
 |  | const uint8_t | type
 | ) |  |

The old Profile will be destroyed and a new one according rorg - func and type will be used. If the choosen profile can not be created an empty eoProfile will be used

Parameters:
rorg | EEP RORG
func | EEP Func
type | EEP Type
Returns:
eoReturn::EO_OK or eoReturn::NOT_SUPPORTED

Member Data Documentation

int8_t eoDevice::dBm

last dBm

Examples:
deviceManager_example.cpp.
uint32_t eoDevice::ID

ID of the Device

Examples:
deviceManager_example.cpp, Gateway_example.cpp, Gateway_SubtypeExample.cpp, GatewayFiltered_example.cpp, genericProfile_examples.cpp, tutorial1.cpp, tutorial2.cpp, tutorial3.cpp, tutorial6.cpp, vld_example.cpp, and WatcherMain.cpp.
eoSecureInfo eoDevice::secIn

Security Information for decryption

eoSecureInfo eoDevice::secOut

Security Information for encryption

Examples:
Security_example.cpp.
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoDeviceManager Class Reference

Public Member Functions
eoDeviceManager Class Reference
Gateway API

Manages the devices. More...

#include <eoDeviceManager.h>

Inheritance diagram for eoDeviceManager:
[legend]
Collaboration diagram for eoDeviceManager:
[legend]

List of all members.

Public Member Functions

eoDeviceManager ()
eoDevice * | Add (uint32_t id)
eoDevice * | Get (uint32_t id)
void | Remove (uint32_t id)
const id_device_map & | GetDeviceList () const
uint32_t | Size () const
uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.

Detailed Description

Manages the devices.

The DeviceManagaer helps you to manage different devices. Using it functions you can get a eoDevice Pointer to the Devices.

Examples:
deviceManager_example.cpp.

Constructor & Destructor Documentation

eoDeviceManager::eoDeviceManager ( )

Constructor

Member Function Documentation

eoDevice* eoDeviceManager::Add ( uint32_t id )

It a device with same id already exist, returns a pointer to this Device otherwise adds a device with the id to the device manager

Parameters:
id The SourceID of the Device
Returns:
Pointer to the Device
Examples:
deviceManager_example.cpp, and Security_example.cpp.
eoDevice* eoDeviceManager::Get ( uint32_t id )

Searches for the id in the DeviceManager and returns a Device pointer if there was a device found otherwise NULL

Parameters:
id The SourceID of the Device
Returns:
Pointer to the Device
Examples:
deviceManager_example.cpp, and Security_example.cpp.
const id_device_map& eoDeviceManager::GetDeviceList ( ) const

Returns the map containing all the Devices.

Returns:
Reference to the id_device_map of the DeviceManager
void eoDeviceManager::Remove ( uint32_t id )

Removes the Device from the DeviceManager if the Device exists

Parameters:
id of the Device to Delete
Examples:
deviceManager_example.cpp.
uint8_t eoDeviceManager::Serialize ( eoArchive & arch )
virtual

Serialization Function which will be called by the eoStorageManager.

This function will be called by the eoArchive(inside of the eoStorageManager) and allows the class to be Serialized.

Parameters:
arch archive where to Load or to Store.

Reimplemented from eoISerialize.

uint32_t eoDeviceManager::Size ( ) const

Gets the number of Devices in the DeviceManager

Returns:
number of Devices
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoMessage Class Reference

Public Member Functions | Public Attributes
eoMessage Class Reference
Gateway API

Message Class for communication. More...

#include <eoMessage.h>

Inheritance diagram for eoMessage:
[legend]
Collaboration diagram for eoMessage:
[legend]

List of all members.

Public Member Functions

eoReturn | copyTo (eoMessage &msg) const
virtual void | Clear ()
eoMessage (uint16_t size=1)
eoMessage (const eoTelegram &tel)
- Public Member Functions inherited from eoAbstractMessage
eoReturn | SetDataLength (uint16_t dataLen, bool reallocate=false)
uint16_t | GetDataLength () const
uint16_t | GetMaxLength () const

Public Attributes

uint8_t | RORG
RORG as specified by EnOcean.
uint8_t | status
status Information from device
uint32_t | sourceID
SourceID.
uint32_t | destinationID
the destination ID
uint8_t | securityLevel
Security level of the message.
- Public Attributes inherited from eoAbstractMessage
uint8_t * | data
Data Pointer.
uint16_t | dataLength
Payload data length.
uint16_t | maxLength

Additional Inherited Members

- Protected Member Functions inherited from eoAbstractMessage
eoAbstractMessage (uint16_t size=1)

Detailed Description

Message Class for communication.

this class describes a Message, a message is the virtual piece of information, which is exchanged between eoLink and the Gateway.

It contains the payload data, the Source ID and the RORG information.

Examples:
genericProfile_examples.cpp, profile_examples.cpp, Security_example.cpp, sendTelegram_example.cpp, tutorial2.cpp, tutorial3.cpp, tutorial6.cpp, and vld_example.cpp.

Constructor & Destructor Documentation

eoMessage::eoMessage ( uint16_t size = 1 )

Creates a new Message and reserves size bytes for the data in the ram

Parameters:
size bytes ti reserve in the ram
eoMessage::eoMessage ( const eoTelegram & tel )

Creates a new Message from a telegram

Parameters:
tel eoTelegram used by the eoMessage.

Member Function Documentation

virtual void eoMessage::Clear ( )
virtual

Clears the message

Returns:

Reimplemented in eoTelegram.

eoReturn eoMessage::copyTo ( eoMessage & msg ) const

Copies the content of this eoMessage to another eoMessage.

Returns:
EO_OK
OUT_OF_RANGE if the eoMessage.maxLength is smaller than this eoMessage.maxLength

Member Data Documentation

uint32_t eoMessage::sourceID

SourceID.

When sending data= ID to use

Note:
can only be a valid id based from the BASE_ID or use 0x0 for the connected device ID

When it is a received Message, id from the transmitter.

Examples:
GatewayFiltered_example.cpp, genericProfile_examples.cpp, tutorial1.cpp, tutorial4.cpp, and tutorial6.cpp.
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoPacket Class Reference

Public Member Functions | Public Attributes
eoPacket Class Reference
Gateway API

Class which contains a Packet. More...

#include <eoPacket.h>

List of all members.

Public Member Functions

eoPacket ()
eoPacket (uint8_t *dataBuffer, uint16_t size)
eoPacket (uint16_t size)
eoPacket (eoPacket &packet)
uint16_t | getBufferSize ()
uint8_t | copyTo (eoPacket &packet)

Public Attributes

uint8_t * | data
uint16_t | dataLength
uint8_t | optionalLength
uint8_t | type

Detailed Description

Class which contains a Packet.

Packets are used for the communication with the connected EnOcean Device via ESP3. linuxPacketStream_example.cpp

Examples:
linuxPacketStream_example.cpp, and packetStream_example.cpp.

Constructor & Destructor Documentation

eoPacket::eoPacket ( )

The base constructor for Packet will allocate 550bytes for the internal dataBuffer. 550bytes is enough for ESP 3 (1.17), if you need more or less you can always use Packet(uint16_t size);

eoPacket::eoPacket | ( | uint8_t * | dataBuffer,
 |  | uint16_t | size
 | ) |  |

This constructor allows the User to set the dataBuffer Pointer as he wants The dataBuffer, will not be deleted in this case, in the destructor.

Parameters:
dataBuffer | Pointer to dataBuffer
size | size of the buffer
eoPacket::eoPacket ( uint16_t size )

This constructor automatically allocates size bytes as dataBuffer

Parameters:
size bytes to allocate
eoPacket::eoPacket ( eoPacket & packet )

This is copy constructor automatically allocates size bytes as dataBuffer

Parameters:
packet bytes to allocate

Member Function Documentation

uint8_t eoPacket::copyTo ( eoPacket & packet )

Copies the content of this eoPacket to packet.

Returns:
EO_OK
OUT_OF_RANGE if the packet.bufferSize is smaller than this eoPacket.dataLength+optionalLength
uint16_t eoPacket::getBufferSize ( )

Returns the size of the buffer

Returns:
Buffersize

Member Data Documentation

uint8_t* eoPacket::data

Direct access to DataBuffer, can be unsafe only use it if you know what you do!

Examples:
linuxPacketStream_example.cpp, packetStream_example.cpp, and vld_example.cpp.
uint16_t eoPacket::dataLength

Sets or get the DataLength of the Packet

Examples:
linuxPacketStream_example.cpp, and packetStream_example.cpp.
uint8_t eoPacket::optionalLength

Sets or get the Optional DataLength of the Packet

Examples:
linuxPacketStream_example.cpp, and packetStream_example.cpp.
uint8_t eoPacket::type

The PACKET_TYPE

Examples:
linuxPacketStream_example.cpp, and packetStream_example.cpp.
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoChannelInfo Class Reference

Public Member Functions | Public Attributes
eoChannelInfo Class Reference
Gateway API

Abstract class for channel information. Abstract class for channel information. From this class specific channel informations classes for Generic Profiles or EEP are derived. More...

#include <eoChannelInfo.h>

Inheritance diagram for eoChannelInfo:
[legend]

List of all members.

Public Member Functions

const char * ToString (uint8_t strType)

Public Attributes

CHANNEL_TYPE type
CHANNEL_TYPE
VALUE_TYPE signalType
Current, Setpoint Absolute, Setpoint relative.
float | min
Min as clear value.
float | max
Max as clear value.

Detailed Description

Abstract class for channel information. Abstract class for channel information. From this class specific channel informations classes for Generic Profiles or EEP are derived.

Examples:
tutorial6.cpp.

Member Function Documentation

const char* eoChannelInfo::ToString ( uint8_t strType )

Returns for signalTypes either the NAME or the UNIT, for flags a small desc

Parameters:
strType NAME(0x00) or UNIT(0x01)
Returns:
Pointer to const String
Examples:
Gateway_example.cpp, Gateway_SubtypeExample.cpp, GatewayFiltered_example.cpp, genericProfile_examples.cpp, sendTelegram_example.cpp, tutorial1.cpp, vld_example.cpp, and WatcherMain.cpp.
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: TEACH_STRUCT Class Reference

Public Attributes
TEACH_STRUCT Class Reference
Gateway API

Teach message structure. More...

#include <eoTeachInModule.h>

List of all members.

Public Attributes

bool teachedIN
Teached in.

Detailed Description

Teach message structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoProfile Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Static Protected Member Functions | Protected Attributes | Static Protected Attributes
eoProfile Class Reference
Gateway API

base class for Profile parsing More...

#include <eoProfile.h>

Inheritance diagram for eoProfile:
[legend]
Collaboration diagram for eoProfile:
[legend]

List of all members.

Public Member Functions

eoProfile (uint16_t size=0)
virtual bool | operator== (const eoProfile &othProfile) const
virtual bool | operator!= (const eoProfile &othProfile) const
virtual bool | IsSecDData (const eoMessage &message)
virtual void | ClearValues ()
virtual eoReturn | Create (eoMessage &m)
Generates an EEP Message.
virtual eoReturn | CreateTeachIN (eoMessage &m)
Generates an EEP Telegram(only not chained supported!!1)
virtual eoReturn | Parse (const eoMessage &msg)
Parses a msg using learned in Profile from Device.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value)
Gets the Value as Floating Point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, float &value, uint8_t subFlag)
Gets the Value as Floating point.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value, uint8_t subFlag)
Gets the Value as a float.
virtual eoReturn | GetValue (CHANNEL_TYPE type, uint8_t &value)
Sets the Value using a unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value, uint8_t subFlag)
Gets the Value as unsigned integer.
virtual eoReturn | SetValue (CHANNEL_TYPE type, float value)
Sets the Value using a Floating Point.
virtual eoReturn | SetValue (CHANNEL_TYPE type, uint8_t value)
Sets the Value using a uint8_t.
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetChannel (CHANNEL_TYPE type)
virtual eoChannelInfo * | GetChannel (uint8_t channelNumber)
virtual eoReturn | GetSubTypeChannel (CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector)
virtual eoReturn | SetType (uint8_t type)
virtual uint8_t | Serialize (eoArchive &a)
Serialization Function which will be called by the eoStorageManager.
virtual uint8_t | GetChannelCount () const
eoReturn | SetManufacturer (uint16_t manufacturerID)

Public Attributes

uint8_t | rorg
R-ORG.
uint8_t | func
Func.
uint8_t | type
Type.
uint16_t | manufacturer
Manufacturer.

Protected Member Functions

float | ScaleFromRAW (uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax)
Creates floating Point from Raw Value.
uint32_t | ScaleToRAW (float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax)
Creates Raw Value from a floating Point.

Static Protected Member Functions

static eoReturn | GetRawValue (const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size)
Gives raw data Value from a Message.
static eoReturn | SetRawValue (eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size)
Inserts raw data Value in a message.

Protected Attributes

eoMessage msg
helper function to convert bits

Static Protected Attributes

static const uint8_t maskArray [8]
Mask array.

Detailed Description

base class for Profile parsing

The eoProfile class, enables an abstract Layer for handling the two different Profile Worlds of the EnOcean world. It adds an easy to use Interface for your application, and in the most cases your application does not need to care which sort of profile you're using. The GetValue and SetValue enables an easy way to read and write Sensor and other Data to a Message.

The Real Implementation for EEP is done in the eoEEProfile and for the Generic Profiles in the eoGenericProfile class. profile_examples.cpp

Examples:
Gateway_example.cpp, Gateway_SubtypeExample.cpp, GatewayFiltered_example.cpp, genericProfile_examples.cpp, profile_examples.cpp, Security_example.cpp, sendTelegram_example.cpp, tutorial1.cpp, tutorial2.cpp, tutorial3.cpp, tutorial6.cpp, vld_example.cpp, and WatcherMain.cpp.

Constructor & Destructor Documentation

eoProfile::eoProfile ( uint16_t size = 0 )

eoProfile constructor.

Parameters:
size Default size of messages.

Member Function Documentation

virtual void eoProfile::ClearValues ( )
virtual

All raw values of the internal Message will be set to zero.

Reimplemented in eoEEP_A520xx, eoGenericProfile, eoEEP_D2A0xx, eoEEP_D203xx, eoEEP_F602xx, and eoEEP_F603xx.

Examples:
profile_examples.cpp, and sendTelegram_example.cpp.
virtual eoReturn eoProfile::Create ( eoMessage & m )
virtual

Generates an EEP Message.

This functions generates a Message for the specified EEP, with the current ChannelInfo values

Parameters:
m Reference to the Message (will be cleared and generated new)
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented in eoEEP_A520xx, eoGenericProfile, eoA5EEProfile, eoEEP_D2A0xx, and eoF6EEProfile.

Examples:
genericProfile_examples.cpp, profile_examples.cpp, Security_example.cpp, sendTelegram_example.cpp, tutorial3.cpp, and vld_example.cpp.
virtual eoReturn eoProfile::CreateTeachIN ( eoMessage & m )
virtual

Generates an EEP Telegram(only not chained supported!!1)

This functions generates a Message for the specified EEP, with the current ChannelInfo values

Parameters:
m Reference to the Message (will be cleared and generated new)
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented in eoA5EEProfile, eoGenericProfile, and eoD2EEProfile.

Examples:
Security_example.cpp, and tutorial3.cpp.
virtual eoChannelInfo* eoProfile::GetChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
virtual

Returns the channel for the selected type and subtype

Parameters:
type | CHANNEL_TYPE
subType | is either the numeric "subChannelNUmber" (temperature CHannel 0,1,2,3) or a specified keyword for it(see profile)
Returns:
Pointer to Channel

Reimplemented in eoEEP_A520xx, eoEEP_D210xx, eoEEP_D230xx, eoEEP_A538xx, eoEEP_A511xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D220xx, eoGenericProfile, eoEEP_A513xx, eoEEP_D206xx, eoEEP_A512xx, eoEEP_D205xx, eoEEP_A509xx, eoEEP_A530xx, eoEEP_D202xx, eoEEP_D240xx, eoEEP_D231xx, eoEEP_D232xx, eoEEP_A537xx, and eoEEProfile.

Examples:
Gateway_example.cpp, Gateway_SubtypeExample.cpp, GatewayFiltered_example.cpp, genericProfile_examples.cpp, sendTelegram_example.cpp, tutorial1.cpp, tutorial6.cpp, vld_example.cpp, and WatcherMain.cpp.
virtual eoChannelInfo* eoProfile::GetChannel ( CHANNEL_TYPE type )
virtual

Returns the channel for the selected type

Parameters:
type CHANNEL_TYPE
Returns:
Pointer to ChannelInfo or Null

Reimplemented in eoGenericProfile, eoEEP_A512xx, eoEEProfile, eoEEP_F602xx, eoEEP_A506xx, eoEEP_F603xx, eoEEP_F605xx, eoEEP_F610xx, and eoEEP_F604xx.

virtual eoChannelInfo* eoProfile::GetChannel ( uint8_t channelNumber )
virtual

returns the pointer to eoChannelInfo for the selected channelNumber or NULL

Parameters:
channelNumber
Returns:
Pointer to Channel

Reimplemented in eoGenericProfile, and eoEEProfile.

virtual uint8_t eoProfile::GetChannelCount ( ) const
virtual

Returns Number of channels for this profile

Returns:
number of channels

Reimplemented in eoGenericProfile, and eoEEProfile.

Examples:
Gateway_example.cpp, Gateway_SubtypeExample.cpp, GatewayFiltered_example.cpp, genericProfile_examples.cpp, sendTelegram_example.cpp, tutorial1.cpp, vld_example.cpp, and WatcherMain.cpp.
static eoReturn eoProfile::GetRawValue | ( | const eoMessage & | msg,
 |  | uint32_t & | value,
 |  | uint16_t | offset,
 |  | uint8_t | size
 | ) |  |
staticprotected

Gives raw data Value from a Message.

Given the right position(offset) and the bitsize(size), this function gives the rawData Value from a message

Parameters:
msg | Message to use to get the rawValue
value | the rawValue
offset | position of the Data in the telegram
size | size of the data
Returns:
eoReturn
virtual eoReturn eoProfile::GetSubTypeChannel | ( | CHANNEL_TYPE | type,
 |  | std::vector< eoEEPChannelInfo * > & | vector
 | ) |  |
virtual

returns vector containing subtype values

Parameters:
type CHANNEL_TYPE
vector
Returns:
EO_OK

Reimplemented in eoEEProfile.

Examples:
Gateway_SubtypeExample.cpp.
virtual eoReturn eoProfile::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value
 | ) |  |
virtual

Gets the Value as Floating Point.

Using the CHANNEL_TYPE type information, this information gets the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented in eoEEP_A520xx, eoEEP_D210xx, eoEEP_D230xx, eoEEP_A510xx, eoEEP_A538xx, eoEEP_A511xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D220xx, eoEEP_A513xx, eoEEP_D204xx, eoEEP_D206xx, eoEEP_A512xx, eoEEP_D205xx, eoEEP_A509xx, eoEEP_A530xx, eoEEP_D202xx, eoGenericProfile, eoEEP_D240xx, eoA5EEProfile, eoEEP_D231xx, eoEEP_D232xx, eoEEP_A537xx, eoEEP_A506xx, eoEEP_A507xx, eoEEP_A504xx, and eoD2EEProfile.

Examples:
Gateway_example.cpp, Gateway_SubtypeExample.cpp, GatewayFiltered_example.cpp, genericProfile_examples.cpp, profile_examples.cpp, sendTelegram_example.cpp, tutorial1.cpp, tutorial2.cpp, tutorial3.cpp, tutorial6.cpp, vld_example.cpp, and WatcherMain.cpp.
virtual eoReturn eoProfile::GetValue | ( | CHANNEL_TYPE | type,
 |  | float & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as Floating point.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented in eoEEP_A520xx, eoEEP_D210xx, eoEEP_D230xx, eoEEP_A538xx, eoEEP_A511xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_A513xx, eoEEP_D206xx, eoEEP_D205xx, eoEEP_A509xx, eoEEP_D202xx, eoGenericProfile, eoEEP_D240xx, eoA5EEProfile, eoEEP_D231xx, eoEEP_D232xx, and eoD2EEProfile.

virtual eoReturn eoProfile::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented in eoEEP_A520xx, eoEEP_D210xx, eoEEP_D230xx, eoEEP_A538xx, eoEEP_A510xx, eoEEP_A511xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D220xx, eoEEP_A513xx, eoEEP_D206xx, eoEEP_A512xx, eoEEP_A530xx, eoEEP_D202xx, eoEEP_D240xx, eoA5EEProfile, eoEEP_D231xx, eoEEP_A537xx, and eoD2EEProfile.

virtual eoReturn eoProfile::GetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t & | value
 | ) |  |
virtual

Sets the Value using a unsigned integer.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
value | Reference to uint8_t
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented in eoEEP_A520xx, eoEEP_D210xx, eoEEP_D230xx, eoEEP_A510xx, eoEEP_A538xx, eoEEP_A511xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D220xx, eoEEP_A513xx, eoEEP_D204xx, eoEEP_D206xx, eoEEP_A512xx, eoEEP_D205xx, eoEEP_A509xx, eoEEP_A530xx, eoGenericProfile, eoEEP_D202xx, eoEEP_D240xx, eoEEP_D231xx, eoEEP_D2A0xx, eoEEP_A514xx, eoEEP_D232xx, eoEEP_A537xx, eoEEP_D203xx, eoEEP_A507xx, eoEEP_F602xx, eoEEP_A504xx, eoEEP_F603xx, eoEEP_A508xx, eoEEP_D500xx, eoEEP_A505xx, eoEEP_F605xx, eoEEP_F610xx, and eoEEP_F604xx.

virtual bool eoProfile::IsSecDData ( const eoMessage & message )
virtual

Checks if the data is RORG_SECD

Parameters:
message to check
Returns:
true or false;

Reimplemented in eoA5EEProfile.

virtual bool eoProfile::operator!= ( const eoProfile & othProfile ) const
virtual

Returns true if rorg,func and type are different.

Parameters:
othProfile
Returns:
true or false
virtual bool eoProfile::operator== ( const eoProfile & othProfile ) const
virtual

Returns true if rorg,func and type are the same.

Parameters:
othProfile
Returns:
true or false
virtual eoReturn eoProfile::Parse ( const eoMessage & msg )
virtual

Parses a msg using learned in Profile from Device.

This function will parse the Message msg using the Profile Specific data

Parameters:
msg Message to parse
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented in eoEEP_D210xx, eoEEP_D230xx, eoEEP_A538xx, eoEEP_D201xx, eoEEP_A513xx, eoEEP_D200xx, eoEEP_D220xx, eoEEP_D206xx, eoEEP_D205xx, eoGenericProfile, eoEEP_D202xx, eoEEP_D240xx, eoA5EEProfile, eoEEP_D231xx, eoEEP_D2A0xx, eoF6EEProfile, eoEEP_D203xx, and eoEEP_D500xx.

Examples:
profile_examples.cpp.
float eoProfile::ScaleFromRAW | ( | uint32_t | rawValue,
 |  | uint32_t | rangeMin,
 |  | uint32_t | rangeMax,
 |  | float | scaleMin,
 |  | float | scaleMax
 | ) |  |
protected

Creates floating Point from Raw Value.

Converts the rawValue into a floating Point value, using the parameters and the formula specified in the [GP]
To get values use GetValue() !
!Warning this function does not check if the rawValue is in range!

Parameters:
rawValue | rawValue to convert
rangeMin | maximal rawValue
rangeMax | minimal rawValue
scaleMin | minimal Value
scaleMax | minimal Value
Returns:
the Value as floating Point
uint32_t eoProfile::ScaleToRAW | ( | float | value,
 |  | uint32_t | rangeMin,
 |  | uint32_t | rangeMax,
 |  | float | scaleMin,
 |  | float | scaleMax
 | ) |  |
protected

Creates Raw Value from a floating Point.

Converts the floating Point into a raw value, using the parameters and the formula specified in the [GP]
To set values use SetValue() !
!Warning this function does not check if the rawValue is in range!

Parameters:
value | Floating Point to convert
rangeMin | maximal rawValue
rangeMax | minimal rawValue
scaleMin | minimal Value
scaleMax | minimal Value
Returns:
virtual uint8_t eoProfile::Serialize ( eoArchive & arch )
virtual

Serialization Function which will be called by the eoStorageManager.

This function will be called by the eoArchive(inside of the eoStorageManager) and allows the class to be Serialized.

Parameters:
arch archive where to Load or to Store.

Reimplemented from eoISerialize.

Reimplemented in eoGenericProfile.

eoReturn eoProfile::SetManufacturer ( uint16_t manufacturerID )

Sets the manufacturer ID.

Returns:
eoReturn EO_OK or NOT_SUPPORTED
static eoReturn eoProfile::SetRawValue | ( | eoMessage & | msg,
 |  | uint32_t & | value,
 |  | uint16_t | offset,
 |  | uint8_t | size
 | ) |  |
staticprotected

Inserts raw data Value in a message.

Given the right position(offset) and the bitsize(size), this function modifies the rawValue of a message (other information will not bet set!)

Parameters:
msg | Message to use to get the rawValue
value | the rawValue
offset | position of the Data in the telegram
size | size of the data
Returns:
eoReturn
virtual eoReturn eoProfile::SetType ( uint8_t type )
virtual

Sets and checks if the specified [EEP] type is supported

Parameters:
type
Returns:
eoReturn EO_OK or NOT_SUPPORTED

Reimplemented in eoEEP_A520xx, eoEEP_D210xx, eoEEP_D230xx, eoEEP_A538xx, eoEEP_A510xx, eoEEP_A511xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D220xx, eoEEP_A513xx, eoEEP_D204xx, eoEEP_D206xx, eoEEP_A512xx, eoGenericProfile, eoEEP_D205xx, eoEEP_A509xx, eoEEP_A530xx, eoEEP_D202xx, eoEEP_D240xx, eoEEP_D231xx, eoEEP_D2A0xx, eoEEP_A514xx, eoEEP_D232xx, eoEEP_A502xx, eoEEP_D203xx, eoEEP_A537xx, eoEEP_A504xx, eoEEP_F602xx, eoEEP_A506xx, eoEEP_A507xx, eoEEP_F603xx, eoEEP_A508xx, eoEEP_A505xx, eoEEP_F605xx, eoEEP_F610xx, eoEEP_D500xx, and eoEEP_F604xx.

virtual eoReturn eoProfile::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as a float.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented in eoEEP_A520xx, eoEEP_D210xx, eoEEP_D230xx, eoEEP_A538xx, eoEEP_A511xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_A513xx, eoEEP_D206xx, eoEEP_D205xx, eoEEP_A509xx, eoEEP_D202xx, eoGenericProfile, eoEEP_D240xx, eoA5EEProfile, eoEEP_D231xx, eoEEP_D232xx, and eoD2EEProfile.

Examples:
genericProfile_examples.cpp, profile_examples.cpp, Security_example.cpp, sendTelegram_example.cpp, tutorial3.cpp, and vld_example.cpp.
virtual eoReturn eoProfile::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value,
 |  | uint8_t | subFlag
 | ) |  |
virtual

Gets the Value as unsigned integer.

Using the CHANNEL_TYPE type information, this information gets the unsigned integer value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to uint8_t
subFlag | Sub flag
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented in eoEEP_A520xx, eoEEP_D210xx, eoEEP_D230xx, eoEEP_A538xx, eoEEP_A510xx, eoEEP_A511xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D220xx, eoEEP_A513xx, eoEEP_D206xx, eoEEP_A512xx, eoEEP_A530xx, eoEEP_D202xx, eoEEP_D240xx, eoA5EEProfile, eoEEP_D231xx, eoEEP_A537xx, and eoD2EEProfile.

virtual eoReturn eoProfile::SetValue | ( | CHANNEL_TYPE | type,
 |  | float | value
 | ) |  |
virtual

Sets the Value using a Floating Point.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the floating point value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented in eoEEP_A520xx, eoEEP_D210xx, eoEEP_D230xx, eoEEP_A510xx, eoEEP_A538xx, eoEEP_D201xx, eoEEP_A511xx, eoEEP_D200xx, eoEEP_D220xx, eoEEP_A513xx, eoEEP_D204xx, eoEEP_D206xx, eoEEP_A512xx, eoEEP_D205xx, eoEEP_A509xx, eoEEP_A530xx, eoGenericProfile, eoEEP_D202xx, eoEEP_D240xx, eoA5EEProfile, eoEEP_D231xx, eoEEP_D232xx, eoEEP_A537xx, eoEEP_A507xx, eoEEP_A504xx, eoEEP_A506xx, and eoD2EEProfile.

virtual eoReturn eoProfile::SetValue | ( | CHANNEL_TYPE | type,
 |  | uint8_t | value
 | ) |  |
virtual

Sets the Value using a uint8_t.

Using the CHANNEL_TYPE type information, this information sets the channel raw value, using the uint8_t value accordingly, if the Profile does not support the requested CHANNEL_TYPE NOT_SUPPORTED is returned, if the functions is not implemented for the chosen profile, NOT_IMPLEMENTED is returned

Parameters:
type | CHANNEL_TYPE
value | Reference to floating point
Returns:
eoReturn EO_OK,NOT_SUPPORTED,NOT_IMPLEMENTED

Reimplemented in eoEEP_A520xx, eoEEP_D210xx, eoEEP_D230xx, eoEEP_A510xx, eoEEP_A538xx, eoEEP_A511xx, eoEEP_D201xx, eoEEP_D200xx, eoEEP_D220xx, eoEEP_A513xx, eoEEP_D204xx, eoEEP_D206xx, eoEEP_A512xx, eoEEP_D205xx, eoEEP_A509xx, eoGenericProfile, eoEEP_A530xx, eoEEP_D202xx, eoEEP_D240xx, eoEEP_D231xx, eoEEP_D2A0xx, eoEEP_A514xx, eoEEP_D232xx, eoEEP_A537xx, eoEEP_D203xx, eoEEP_A507xx, eoEEP_F602xx, eoEEP_A504xx, eoEEP_F603xx, eoEEP_A508xx, eoEEP_D500xx, eoEEP_A505xx, eoEEP_F605xx, eoEEP_F610xx, and eoEEP_F604xx.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoTeachInModule Class Reference

Public Member Functions | Static Public Member Functions
eoTeachInModule Class Reference
Gateway API

handles TeachIn Messages More...

#include <eoTeachInModule.h>

Inheritance diagram for eoTeachInModule:
[legend]
Collaboration diagram for eoTeachInModule:
[legend]

List of all members.

Public Member Functions

eoTeachInModule (eoDeviceManager *eoDevManager, eoSecurity *sec)
void | SetRPS (uint8_t func, uint8_t type)
void | Set1BS (uint8_t func, uint8_t type)
void | Set4BS (uint8_t func, uint8_t type)
TEACH_RETURN | TeachIN (eoMessage &m)
handles Teach IN Message
TEACH_RETURN | TeachIN (uint8_t rorg, uint8_t func, uint8_t type, uint32_t device_id)
handles Teach IN Message
void | TeachOut (uint32_t id)
bool | isTeachedIN (eoMessage &telegram)
bool | isTeachedIN (eoDevice &dev)
eoReturn | ParseUTE (eoMessage &msg)
eoReturn | CreateUTEResponse (eoMessage &teachInUTE, eoMessage &responseUTE, UTE_RESPONSE type, UTE_DIRECTION direction)
eoReturn | CreateGPResponse (eoMessage &msg, uint16_t manId, uint32_t destinationId, GP_RESPONSE_RESULT response, eoProfile *profile)
virtual uint8_t | Serialize (eoArchive &arch)
Serialization Function which will be called by the eoStorageManager.

Static Public Member Functions

static bool isTeachIN (eoMessage &telegram)

Detailed Description

handles TeachIn Messages

a helper class to handle EEP Teach-IN as specified.

Constructor & Destructor Documentation

eoTeachInModule::eoTeachInModule | ( | eoDeviceManager * | eoDevManager,
 |  | eoSecurity * | sec
 | ) |  |

Standard constructor for the TeachInModule

Parameters:
eoDevManager | eoDeviceManager
sec | security Module to use to handle security Messages

Member Function Documentation

eoReturn eoTeachInModule::CreateGPResponse | ( | eoMessage & | msg,
 |  | uint16_t | manId,
 |  | uint32_t | destinationId,
 |  | GP_RESPONSE_RESULT | response,
 |  | eoProfile * | profile
 | ) |  |

Creates GP teach in response for GP teach in

Parameters:
msg
manId | manufacturer ID
destinationId
response | GP_RESPONSE_RESULT
profile
Returns:
EO_OK
Examples:
genericProfile_examples.cpp.
eoReturn eoTeachInModule::CreateUTEResponse | ( | eoMessage & | teachInUTE,
 |  | eoMessage & | responseUTE,
 |  | UTE_RESPONSE | type,
 |  | UTE_DIRECTION | direction
 | ) |  |

Creates UTE teach in response from UTE teach in request

Parameters:
teachInUTE
[out] | responseUTE
type | UTE_RESPONSE
direction | UTE_DIRECTION
Returns:
EO_OK
Examples:
vld_example.cpp.
bool eoTeachInModule::isTeachedIN ( eoMessage & telegram )

Checks if the device belonging to the Message is teached IN

Parameters:
telegram
Returns:
true or false
bool eoTeachInModule::isTeachedIN ( eoDevice & dev )

Checkes if the device is Teached IN

Parameters:
dev device to check
Returns:
true or false
static bool eoTeachInModule::isTeachIN ( eoMessage & telegram )
static

Returns True if it is a teach IN telegram for 4BS or 1BS

Parameters:
telegram to check
Returns:
true or false
eoReturn eoTeachInModule::ParseUTE ( eoMessage & msg )

Parse the message into UTE

Parameters:
msg
Returns:
EO_OK
virtual uint8_t eoTeachInModule::Serialize ( eoArchive & arch )
virtual

Serialization Function which will be called by the eoStorageManager.

This function will be called by the eoArchive(inside of the eoStorageManager) and allows the class to be Serialized.

Parameters:
arch archive where to Load or to Store.

Reimplemented from eoISerialize.

void eoTeachInModule::Set1BS | ( | uint8_t | func,
 |  | uint8_t | type
 | ) |  |

Allows you to set the manual 1BS EEP to use

Parameters:
func
type
Examples:
tutorial4.cpp.
void eoTeachInModule::Set4BS | ( | uint8_t | func,
 |  | uint8_t | type
 | ) |  |

Allows you to set the manual 4BS EEP to use

Parameters:
func
type
void eoTeachInModule::SetRPS | ( | uint8_t | func,
 |  | uint8_t | type
 | ) |  |

Allows you to set the manual RPS EEP to use

Parameters:
func
type
Examples:
Gateway_example.cpp, Gateway_SubtypeExample.cpp, GatewayFiltered_example.cpp, tutorial1.cpp, tutorial4.cpp, and WatcherMain.cpp.
TEACH_RETURN eoTeachInModule::TeachIN ( eoMessage & m )

handles Teach IN Message

This function uses the information passed in the message to teach in a new device. If the device is already teached in SECOND_TEACH_IN will be returned and the device will not be teached in. If the message is a security teach in, the security parameters will be set and saved in the device manager, if the security teach Information is from a ptm device, a ptm profile will be generated.

EEP teach in messages and generic teach in messages will be parsed accordingly to spec, and a profile will be created if it is supported.

For profiles which do not support teach in information (e.g. rps), the information has to be set before using the SetRPS,Set1Bs,.. function

If a profile has been set the return value will be either EEP_TEACH_IN,NEW_DEVICE_AND_EPP or GENERIC_TEACH_IN.

Parameters:
m
Returns:
TEACH_RETURN NO_TEACH_IN,NEW_DEVICE , SECOND_TEACH_IN, NEW_DEVICE_AND_EPP, EEP_TEACH_IN
Examples:
tutorial4.cpp.
TEACH_RETURN eoTeachInModule::TeachIN | ( | uint8_t | rorg,
 |  | uint8_t | func,
 |  | uint8_t | type,
 |  | uint32_t | device_id
 | ) |  |

handles Teach IN Message

This function uses the information passed to manually teach in a new device. If the device is already teached in SECOND_TEACH_IN will be returned and the device will not be teached in.

If a profile has been set the return value will be either EEP_TEACH_IN,NEW_DEVICE_AND_EPP

Parameters:
rorg
func
type
deviceID Id of the device to teach in
Returns:
TEACH_RETURN NO_TEACH_IN,NEW_DEVICE , SECOND_TEACH_IN, NEW_DEVICE_AND_EPP, EEP_TEACH_IN
void eoTeachInModule::TeachOut ( uint32_t id )

Removes all saved information about a device

Parameters:
id Device ID
Examples:
tutorial4.cpp, and tutorial6.cpp.
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Security API

Modules | Classes
Security API
API
Collaboration diagram for Security API:

Modules

SLF Fields
Teach Info Fields

Classes

class | eoSecureInfo
class | eoSecurity
handles EnOcean Security Telegrams More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: SLF Fields

Macros
SLF Fields
Security API
Collaboration diagram for SLF Fields:

Macros

#define | SLF_DATA_ENC_OFF 0
No Data Encryption.
#define | SLF_DATA_ENC_AES128 0x04
Encryption via AES-AES128.
#define | SLF_DATA_ENC_VAES128 0x03
Encryption via VAES-AES128.
#define | SLF_MAC_OFF (0<<3)
CMAC is off.
#define | SLF_MAC_3BYTE (1<<3)
3Byte CMAC
#define | SLF_MAC_4BYTE (2<<3)
4Byte CMAC
#define | SLF_RLC_TX_OFF (0<<5)
don't send RLC
#define | SLF_RLC_TX_ON (1<<5)
transmit RLC via TX
#define | SLF_RLC_ALGO_OFF (0<<6)
RLC OFF.
#define | SLF_RLC_ALGO_16BIT (1<<6)
2byte RLC
#define | SLF_RLC_ALGO_24BIT (2<<6)
3byte RLC

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Teach Info Fields

Macros
Teach Info Fields
Security API
Collaboration diagram for Teach Info Fields:

Macros

#define | TEACH_INFO_PSK (1<<3)
TeachInfo - Use PSK.
#define | TEACH_INFO_PTM (1<<2)
TeachInfo - PTM Type.
#define | TEACH_INFO_PTM_ROCKERA (0<<0)
TeachInfo - ROCKER A normal Teach In for PTM Type.
#define | TEACH_INFO_PTM_ROCKERB (1<<0)
TeachInfo - ROCKER B normal Teach In for PTM Type.
#define | TEACH_INFO_UNIDIR (0<<0)
TeachInfo - Unidirectional security teach-in procedure.
#define | TEACH_INFO_BIDIR (1<<0)
TeachInfo - ROCKER B normal Teach In.

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoSecureInfo Class Reference

Public Member Functions | Public Attributes
eoSecureInfo Class Reference
Security API

#include <eoSecureInfo.h>

Inheritance diagram for eoSecureInfo:
[legend]
Collaboration diagram for eoSecureInfo:
[legend]

List of all members.

Public Member Functions

uint8_t Serialize (eoArchive &arch)
Serialization Function which will be called by the eoStorageManager.

Public Attributes

uint8_t | key [16]
Passphrase Key.
uint8_t | keySize
keyLength
uint32_t | rollingCode
Rolling-code.
uint8_t | SLF
Secure Level Format.
uint8_t | teachInInfo
Teach-In Info.
uint8_t | subKey1 [16]
CMAC Sub-Key1.
uint8_t | subKey2 [16]
CMAC Sub-Key2.
uint8_t | psk [16]
Preshared key.
SEC_RESULT | securityResult
Last Secure Error.
uint32_t | previousRollingCode
The Previous Rolling code, allows to compare the old rolling code and new one.

Detailed Description

Helper Class for the eoDeviceManager, contains&stores security Information.

Examples:
Security_example.cpp.

Member Function Documentation

uint8_t eoSecureInfo::Serialize ( eoArchive & arch )
virtual

Serialization Function which will be called by the eoStorageManager.

This function will be called by the eoArchive(inside of the eoStorageManager) and allows the class to be Serialized.

Parameters:
arch archive where to Load or to Store.

Reimplemented from eoISerialize.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoSecurity Class Reference

Public Member Functions
eoSecurity Class Reference
Security API

handles EnOcean Security Telegrams More...

#include <eoSecurity.h>

List of all members.

Public Member Functions

eoReturn | ParseTeachIn (eoMessage &msgTi, eoDevice &dev)
eoReturn | CreateTeachIn (eoMessage &msgTi, eoDevice &dev)
eoReturn | Decrypt (eoMessage &msgSec, eoMessage &msgNonSec, eoDevice &dev)
eoReturn | Encrypt (eoMessage &msgNonSec, eoMessage &msgSec, eoDevice &dev)
SEC_RESULT | GetLastError ()

Detailed Description

handles EnOcean Security Telegrams

Allows you to receive and sent secured EnOcean Telegrams. After parsing a secured TeachIN telegram with the ParseTeachIn function the security Information get stored in the eoDevice::secIn field. Using the eoDevice::secIn field Secured Telegrams can be decrypted. Outgoing messages can also be encrypted using the stored Information in the eoDevice::secOut field.

Member Function Documentation

eoReturn eoSecurity::CreateTeachIn | ( | eoMessage & | msgTi,
 |  | eoDevice & | dev
 | ) |  |

Create the TeachIN Message

Parameters:
msgTi | Secure TeachIn message to create
dev | device to store eoSecureInfo to
Returns:
Examples:
Security_example.cpp.
eoReturn eoSecurity::Decrypt | ( | eoMessage & | msgSec,
 |  | eoMessage & | msgNonSec,
 |  | eoDevice & | dev
 | ) |  |

Decrypt data

Parameters:
msgSec | Message containing Secured data
msgNonSec | Message containing decrypted data after a success
dev | eoDevice containing eoSecureInfo
Returns:
eoReturn eoSecurity::Encrypt | ( | eoMessage & | msgNonSec,
 |  | eoMessage & | msgSec,
 |  | eoDevice & | dev
 | ) |  |

Encrypt data

Parameters:
msgSec | Message containing encrypted data after a success
msgNonSec | Message not decrypted Message to encrypt.
dev | eoDevice containing eoSecureInfo
Returns:
Examples:
Security_example.cpp.
SEC_RESULT eoSecurity::GetLastError ( )

Get last error code

Returns:
the last error code
Examples:
Security_example.cpp.
eoReturn eoSecurity::ParseTeachIn | ( | eoMessage & | msgTi,
 |  | eoDevice & | dev
 | ) |  |

Parse the TeachIN Message

Parameters:
msgTi | TeachIn message to parse
dev | device to store eoSecureInfo to
Returns:
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Storage API

Classes
Storage API
API
Collaboration diagram for Storage API:

Classes

class | eoRollingCodeStorage
Manages the rolling codes. More...
class | serialize_object
Serialised obejct type definition to save learned devices. More...
class | eoArchive
the base Archive More...
class | eoArchiveTXT
Archive for Human readable Text files. More...
class | eoISerialize
Interface for storing. More...
class | eoStorageManager
handles the Storage of Object More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoRollingCodeStorage Class Reference

Public Member Functions
eoRollingCodeStorage Class Reference
Storage API

Manages the rolling codes. More...

#include <eoRollingCodeStorage.h>

List of all members.

Public Member Functions

eoRollingCodeStorage ()
void | SetRLC (uint32_t id, uint32_t rlc)
eoReturn | GetRLC (uint32_t id, uint32_t &rlc)
eoReturn | RemoveID (uint32_t id)
eoReturn | Save (const char *file)
eoReturn | Load (const char *file)

Detailed Description

Manages the rolling codes.

The RollingCodeStorage helps you to manage rolling codes. Using it functions you can get the rolling code to the IDs.

Constructor & Destructor Documentation

eoRollingCodeStorage::eoRollingCodeStorage ( )

Constructor

Member Function Documentation

eoReturn eoRollingCodeStorage::GetRLC | ( | uint32_t | id,
 |  | uint32_t & | rlc
 | ) |  |

*Searches for the ID between the IDs and returns the value of rolling code.

Parameters:
id | The device ID
rlc | Value of the rolling code
eoReturn eoRollingCodeStorage::Load ( const char * file )

*Loads the files data into map data. It deletes every values in the map before loading values into the file. *Note: you have to add the extension (e.g. test.txt)

Parameters:
file Name of the file
Returns:
EO_OK or error code if could not read the file
eoReturn eoRollingCodeStorage::RemoveID ( uint32_t id )

*Searches for the ID between the IDs and delete the ID and the corresponding rolling code.

Parameters:
id The device ID
eoReturn eoRollingCodeStorage::Save ( const char * file )

*Saves the map data into file *Note: you have to add the extension (e.g. test.txt)

Parameters:
file Name of the file
Returns:
EO_OK or error code if could not create the file
void eoRollingCodeStorage::SetRLC | ( | uint32_t | id,
 |  | uint32_t | rlc
 | ) |  |

A new ID is added with the rolling code, if the ID already exists, it overwrites the previous rolling code.

Parameters:
id | The device ID
rlc | Value of the rolling code
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: serialize_object Class Reference

Public Attributes
serialize_object Class Reference
Storage API

Serialised obejct type definition to save learned devices. More...

#include <eoStorageManager.h>

Collaboration diagram for serialize_object:
[legend]

List of all members.

Public Attributes

eoISerialize * object
Serialize object.
char | name [33]
Name.
bool | hasBeenLoaded
Has been loaded.
uint32_t | uniqueID
Unique ID.

Detailed Description

Serialised obejct type definition to save learned devices.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoArchive Class Reference

Public Member Functions | Public Attributes | Protected Attributes
eoArchive Class Reference
Storage API

the base Archive More...

#include <eoArchive.h>

Inheritance diagram for eoArchive:
[legend]
Collaboration diagram for eoArchive:
[legend]

List of all members.

Public Member Functions

virtual eoArchive & | operator& (char *obj)
virtual eoArchive & | operator& (char const *obj)
virtual eoArchive & | operator& (uint32_t &obj)
virtual eoArchive & | operator& (int32_t &obj)
virtual eoArchive & | operator& (uint16_t &obj)
virtual eoArchive & | operator& (int16_t &obj)
virtual eoArchive & | operator& (uint8_t &obj)
virtual eoArchive & | operator& (int8_t &obj)
virtual eoArchive & | operator& (float &obj)
virtual eoArchive & | operator& (bool &obj)
virtual eoArchive & | operator& (eoISerialize *obj)
virtual eoArchive & | operator& (eoISerialize &obj)
virtual uint8_t | Open (const char *strBuf)
virtual void | Close ()
virtual void | startBlock (const char *BlockName)
virtual void | indent ()
virtual void | startBlock ()
virtual void | endBlock ()

Public Attributes

bool | isStoring
Flag signalising storing.
char | identifier [32]
String indentifier of the archive.

Protected Attributes

eoHeader * h
Header information with the versioning.
uint8_t | level
Actual level of the serialisation stream.
uint8_t | state
Statemaschine indicator.
bool | isName
Flag to signalise if name set.

Detailed Description

the base Archive

abstract class describing Archive Operations, for storing the & operator has been overloaded.

Member Function Documentation

virtual void eoArchive::Close ( )
virtual

Closing the Serialisation stream.

Reimplemented in eoArchiveTXT.

virtual void eoArchive::endBlock ( )
virtual

End a block in serialisation stream.

Reimplemented in eoArchiveTXT.

virtual void eoArchive::indent ( )
virtual

Make an empty line indent.

Reimplemented in eoArchiveTXT.

virtual uint8_t eoArchive::Open ( const char * strBuf )
virtual

Opens the StreamBuffer/file

Parameters:
strBuf file/stream buffer
Returns:
eoReturn

Reimplemented in eoArchiveTXT.

virtual eoArchive& eoArchive::operator& ( char * obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented in eoArchiveTXT.

virtual eoArchive& eoArchive::operator& ( char const * obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented in eoArchiveTXT.

virtual eoArchive& eoArchive::operator& ( uint32_t & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented in eoArchiveTXT.

virtual eoArchive& eoArchive::operator& ( int32_t & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented in eoArchiveTXT.

virtual eoArchive& eoArchive::operator& ( uint16_t & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented in eoArchiveTXT.

virtual eoArchive& eoArchive::operator& ( int16_t & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented in eoArchiveTXT.

virtual eoArchive& eoArchive::operator& ( uint8_t & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented in eoArchiveTXT.

virtual eoArchive& eoArchive::operator& ( int8_t & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented in eoArchiveTXT.

virtual eoArchive& eoArchive::operator& ( float & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented in eoArchiveTXT.

virtual eoArchive& eoArchive::operator& ( bool & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented in eoArchiveTXT.

virtual eoArchive& eoArchive::operator& ( eoISerialize * obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented in eoArchiveTXT.

virtual eoArchive& eoArchive::operator& ( eoISerialize & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented in eoArchiveTXT.

virtual void eoArchive::startBlock ( const char * BlockName )
virtual

Start a block in serialisation stream.

Parameters:
BlockName name of the block.

Reimplemented in eoArchiveTXT.

virtual void eoArchive::startBlock ( )
virtual

Start a block in serialisation stream.

Reimplemented in eoArchiveTXT.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoArchiveTXT Class Reference

Public Member Functions
eoArchiveTXT Class Reference
Storage API

Archive for Human readable Text files. More...

#include <eoArchiveTXT.h>

Inheritance diagram for eoArchiveTXT:
[legend]
Collaboration diagram for eoArchiveTXT:
[legend]

List of all members.

Public Member Functions

virtual eoArchive & | operator& (char const *obj)
virtual eoArchive & | operator& (char *obj)
virtual eoArchive & | operator& (uint32_t &obj)
virtual eoArchive & | operator& (int32_t &obj)
virtual eoArchive & | operator& (uint16_t &obj)
virtual eoArchive & | operator& (int16_t &obj)
virtual eoArchive & | operator& (uint8_t &obj)
virtual eoArchive & | operator& (int8_t &obj)
virtual eoArchive & | operator& (float &obj)
virtual eoArchive & | operator& (bool &obj)
virtual eoArchive & | operator& (eoISerialize *obj)
virtual eoArchive & | operator& (eoISerialize &obj)
void | ExchangeInt (int &obj)
virtual uint8_t | Open (const char *strBuf)
virtual void | Close ()
void | indent ()
void | startBlock ()
void | endBlock ()
void | startBlock (const char *BlockName)

Additional Inherited Members

- Public Attributes inherited from eoArchive
bool | isStoring
Flag signalising storing.
char | identifier [32]
String indentifier of the archive.
- Protected Attributes inherited from eoArchive
eoHeader * h
Header information with the versioning.
uint8_t | level
Actual level of the serialisation stream.
uint8_t | state
Statemaschine indicator.
bool | isName
Flag to signalise if name set.

Detailed Description

Archive for Human readable Text files.

this eoArchive is used to generate and parse Text Files for serialization. Numbers are stored as hex value.

Member Function Documentation

virtual void eoArchiveTXT::Close ( )
virtual

Closing the Serialisation stream.

Reimplemented from eoArchive.

void eoArchiveTXT::endBlock ( )
virtual

End a block in serialisation stream.

Reimplemented from eoArchive.

void eoArchiveTXT::ExchangeInt ( int & obj )

*Echange an stored integer.

Parameters:
obj Intended object.
void eoArchiveTXT::indent ( )
virtual

Make an empty line indent.

Reimplemented from eoArchive.

virtual uint8_t eoArchiveTXT::Open ( const char * strBuf )
virtual

Opens the StreamBuffer/file

Parameters:
strBuf file/stream buffer
Returns:
eoReturn

Reimplemented from eoArchive.

virtual eoArchive& eoArchiveTXT::operator& ( char const * obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented from eoArchive.

virtual eoArchive& eoArchiveTXT::operator& ( char * obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented from eoArchive.

virtual eoArchive& eoArchiveTXT::operator& ( uint32_t & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented from eoArchive.

virtual eoArchive& eoArchiveTXT::operator& ( int32_t & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented from eoArchive.

virtual eoArchive& eoArchiveTXT::operator& ( uint16_t & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented from eoArchive.

virtual eoArchive& eoArchiveTXT::operator& ( int16_t & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented from eoArchive.

virtual eoArchive& eoArchiveTXT::operator& ( uint8_t & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented from eoArchive.

virtual eoArchive& eoArchiveTXT::operator& ( int8_t & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented from eoArchive.

virtual eoArchive& eoArchiveTXT::operator& ( float & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented from eoArchive.

virtual eoArchive& eoArchiveTXT::operator& ( bool & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented from eoArchive.

virtual eoArchive& eoArchiveTXT::operator& ( eoISerialize * obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented from eoArchive.

virtual eoArchive& eoArchiveTXT::operator& ( eoISerialize & obj )
virtual

Overloaded & operator to add an object to the archive.

Parameters:
obj Obejct to be add.

Reimplemented from eoArchive.

void eoArchiveTXT::startBlock ( )
virtual

Start a block in serialisation stream.

Reimplemented from eoArchive.

void eoArchiveTXT::startBlock ( const char * BlockName )
virtual

Start a block in serialisation stream.

Parameters:
BlockName name of the block.

Reimplemented from eoArchive.

Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoISerialize Class Reference

Public Member Functions
eoISerialize Class Reference
Storage API

Interface for storing. More...

#include <eoISerialize.h>

Inheritance diagram for eoISerialize:
[legend]

List of all members.

Public Member Functions

virtual uint8_t Serialize (eoArchive &arch)
Serialization Function which will be called by the eoStorageManager.

Detailed Description

Interface for storing.

classes, which you want to Serialize have to implement the eoISerialize::Serialize(eoArchive &arch) Function

Member Function Documentation

virtual uint8_t eoISerialize::Serialize ( eoArchive & arch )
virtual

Serialization Function which will be called by the eoStorageManager.

This function will be called by the eoArchive(inside of the eoStorageManager) and allows the class to be Serialized.

Parameters:
arch archive where to Load or to Store.

Reimplemented in eoGenericProfile, eoGateway, eoProfile, eoTeachInModule, eoGPChannelInfo, eoWatcher, eoSecureInfo, eoDevice, eoIFilter, eoDeviceManager, eodBmFilter, eoIDFilter, eoHeader, and eoIWatcher.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoStorageManager Class Reference

Public Member Functions
eoStorageManager Class Reference
Storage API

handles the Storage of Object More...

#include <eoStorageManager.h>

List of all members.

Public Member Functions

eoStorageManager ()
eoStorageManager (eoArchive &archive)
eoReturn | addObject (const char *name, eoISerialize *object)
Adds an eoISerialize Object to the storageManager.
eoReturn | RemoveObject (const char *name)
Removes an ISerialize Object from the StorageManager.
eoReturn | Load (const char *strBuf)
eoReturn | Save (const char *strBuf)

Detailed Description

handles the Storage of Object

Manages for you the saving or loading of ISerialize objects, which you can add via addObject or loadObject

eoStorageManager myManager;
myManager.Add(myGateway);
myManager.Save("mySaveFile");
*
Examples:
storage_example.cpp, tutorial1.cpp, tutorial2.cpp, tutorial3.cpp, and WatcherMain.cpp.

Constructor & Destructor Documentation

eoStorageManager::eoStorageManager ( )

The standard constructor uses the eoArchiveTXT

eoStorageManager::eoStorageManager ( eoArchive & archive )

The Storage Manager Constructor

Parameters:
archive eoArchive Format to save to.

Member Function Documentation

eoReturn eoStorageManager::addObject | ( | const char * | name,
 |  | eoISerialize * | object
 | ) |  |

Adds an eoISerialize Object to the storageManager.

all Objects which have been added to the storageManager, will be handled in the save and load functionality of the Storage Manager.

Parameters:
name | The object identifier used in your Application to load/save the ISerialize object (maximal 32 characters)
object | an ISerialize object which you want to save or load
Returns:
eoReturn
Examples:
storage_example.cpp, tutorial1.cpp, tutorial2.cpp, and tutorial3.cpp.
eoReturn eoStorageManager::Load ( const char * strBuf )

Loads from the specified stream allObjects

Parameters:
strBuf
Returns:
eoReturn
Examples:
storage_example.cpp, tutorial2.cpp, and tutorial3.cpp.
eoReturn eoStorageManager::RemoveObject ( const char * name )

Removes an ISerialize Object from the StorageManager.

The eoISerialize object will be removed from the StorageManager handling

Parameters:
name The object identifier used in your Application to load/save the ISerialize object (maximal 32 characters)
Returns:
eoReturn
eoReturn eoStorageManager::Save ( const char * strBuf )

Saves your object to the specified Buffer

Parameters:
strBuf the Buffer to save to, using the choosen Archive type
Returns:
eoReturn
Examples:
storage_example.cpp, and tutorial1.cpp.
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoConverter Class Reference

Static Public Member Functions
eoConverter Class Reference
API

contains static Helper Functions More...

#include <eoConverter.h>

List of all members.

Static Public Member Functions

static eoReturn | radioToPacket (const eoTelegram &tel, eoPacket &packet)
static eoReturn | radioToPacket (const eoMessage &msg, eoPacket &packet)
static eoReturn | packetToAdvancedRadio (const eoMessage &msg, eoPacket &packet)
static eoReturn | packetToRadio (const eoPacket &packet, eoTelegram &tel)
static eoReturn | advancedPacketToRadio (const eoPacket &packet, eoTelegram &tel)
static uint8_t | TigrisToRPS (eoTelegram &inTel, eoTelegram &outTel)
static const char * | NumToHex (uint8_t num)
static uint32_t | Hash (char const *str)
static eoReturn | packetToReman (const eoPacket &packet, eoReManMessage &reManMes)
static eoReturn | remanToPacket (const eoReManMessage &reManMes, eoPacket &packet)
static eoReturn | fahrenheitToCelsius (float &value)
static eoReturn | celsiusToFahrenheit (float &value)
static eoReturn | literToMeter3 (float &value)
static eoReturn | meter3ToLiter (float &value)

Detailed Description

contains static Helper Functions

Member Function Documentation

static eoReturn eoConverter::advancedPacketToRadio | ( | const eoPacket & | packet,
 |  | eoTelegram & | tel
 | ) |  |
static

Helper function, which will convert a Advanced Packet to a Telegram

Parameters:
packet | Advanced Packet to convert
tel | Telegram to store
Returns:
eoReturn
static eoReturn eoConverter::celsiusToFahrenheit ( float & value )
static

Helper function, which will convert Celsius into Fahrenheit

Parameters:
value Value to be converted
Returns:
eoReturn
static eoReturn eoConverter::fahrenheitToCelsius ( float & value )
static

Helper function, which will convert Fahrenheit into Celsius

Parameters:
value Value to be converted
Returns:
eoReturn
static uint32_t eoConverter::Hash ( char const * str )
static

Simple hash function, which generates an uint32_t hash from a char string

Parameters:
str pointer to char string
Returns:
32bit Hash
static eoReturn eoConverter::literToMeter3 ( float & value )
static

Helper function, which will convert liter/s to m3/s

Parameters:
value Value to be converted
Returns:
eoReturn
static eoReturn eoConverter::meter3ToLiter ( float & value )
static

Helper function, which will convert m3/s to liter/s

Parameters:
value Value to be converted
Returns:
eoReturn
static const char* eoConverter::NumToHex ( uint8_t num )
static

Converts the LSB to hex Char

Parameters:
num
Returns:
0-F
static eoReturn eoConverter::packetToAdvancedRadio | ( | const eoMessage & | msg,
 |  | eoPacket & | packet
 | ) |  |
static

Helper function, which will convert a Message to Advanced Packet

Parameters:
msg | Message to convert
packet | Packet to store
Returns:
eoReturn
static eoReturn eoConverter::packetToRadio | ( | const eoPacket & | packet,
 |  | eoTelegram & | tel
 | ) |  |
static

Helper function, which will convert a Packet to a Telegram

Parameters:
packet | Packet to convert
tel | Telegram to store
Returns:
eoReturn
static eoReturn eoConverter::packetToReman | ( | const eoPacket & | packet,
 |  | eoReManMessage & | reManMes
 | ) |  |
static

Helper function, which will convert a Telegram to a Packet

Parameters:
packet | Packet to store to convert
reManMes | Remote Management Message
Returns:
eoReturn
static eoReturn eoConverter::radioToPacket | ( | const eoTelegram & | tel,
 |  | eoPacket & | packet
 | ) |  |
static

Helper function, which will convert a Telegram to a Packet

Parameters:
tel | Telegram to convert
packet | Packet to store
Returns:
eoReturn
static eoReturn eoConverter::radioToPacket | ( | const eoMessage & | msg,
 |  | eoPacket & | packet
 | ) |  |
static

Helper function, which will convert a Message to a Packet

Parameters:
msg | Message to convert
packet | Packet to store
Returns:
eoReturn
static eoReturn eoConverter::remanToPacket | ( | const eoReManMessage & | reManMes,
 |  | eoPacket & | packet
 | ) |  |
static

Helper function, which will convert a Telegram to a Packet

Parameters:
reManMes | Remote Management Message to convert
packet | Packet to store
Returns:
eoReturn
static uint8_t eoConverter::TigrisToRPS | ( | eoTelegram & | inTel,
 |  | eoTelegram & | outTel
 | ) |  |
static

Helper function which converts decrypted Tigris Telegram to RPS

Parameters:
inTel
outTel
Returns:
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoDebug Class Reference

Static Public Member Functions
eoDebug Class Reference
API

helper class for Debug Messages More...

#include <eoDebug.h>

List of all members.

Static Public Member Functions

static void | Print (const eoTelegram &tel)
static void | Print (const eoMessage &msg)
static void | Print (const eoReManMessage &reMsg)
static void | Print (const eoPacket &packet)

Detailed Description

helper class for Debug Messages

Member Function Documentation

static void eoDebug::Print ( const eoTelegram & tel )
static

Helper class, which prints debug Information for the Telegram to the console

Parameters:
tel Telegram
Examples:
Gateway_example.cpp, Gateway_SubtypeExample.cpp, GatewayFiltered_example.cpp, genericProfile_examples.cpp, HelloWorld.cpp, profile_examples.cpp, Security_example.cpp, tutorial1.cpp, tutorial6.cpp, vld_example.cpp, and WatcherMain.cpp.
static void eoDebug::Print ( const eoMessage & msg )
static

Helper class, which prints debug Information for the Message to the console

Parameters:
msg eoMessage
static void eoDebug::Print ( const eoReManMessage & reMsg )
static

Helper class, which prints debug Information for the eoReManMessage to the console

Parameters:
reMsg eoReManMessage
static void eoDebug::Print ( const eoPacket & packet )
static

Helper class, which prints debug Information from the Packet

Parameters:
packet Packet
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoTimer Class Reference

Static Public Member Functions
eoTimer Class Reference
API

tickCount helper More...

#include <eoTimer.h>

List of all members.

Static Public Member Functions

static uint32_t | GetTickCount ()
static void | Sleep (uint32_t ms)

Detailed Description

tickCount helper

Member Function Documentation

static uint32_t eoTimer::GetTickCount ( )
static

MS tick count

Returns:
returns a ms tickCount, start time is hw dependent
Examples:
GatewayFiltered_example.cpp, genericProfile_examples.cpp, tutorial1.cpp, tutorial6.cpp, and WatcherMain.cpp.
static void eoTimer::Sleep ( uint32_t ms )
static

Sleep for a specified amount of milliseconds

Returns:
void
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
o N std |
o C CO_RD_DUTYCYCLE_RESPONSE | Read actual duty cycle limit structure
o C CO_RD_FILTER_RESPONSE | Read filter response
o C CO_RD_IDBASE_RESPONSE | Read base ID response
o C CO_RD_REPEATER_RESPONSE | Read repeater response
o C CO_RD_VERSION_RESPONSE | Read version response
o C CO_READY_RESPONSE | Ready response
o C DEVICE_CONFIG | Dvice configuration response
o C EEP_ITEM |
o C eoA5EEProfile | EnOcean Equipment Profiles
o C eoAbstractMessage | Base class for all Messages
o C eoArchive | Base Archive
o C eoArchiveTXT | Archive for Human readable Text files
o C eoChainedMessage |
o C eoChainedReManMessage |
o C eoChannelInfo | Abstract class for channel information. Abstract class for channel information. From this class specific channel informations classes for Generic Profiles or EEP are derived
o C eoChunkMessage | Representing part of an message
o C eoConverter | Static Helper Functions
o C eoD2EEProfile | EnOcean Equipment Profiles
o C eodBmFilter | Uses Telegram dBm values as filter base
o C eoDebug | Helper class for Debug Messages
o C eoDevice | Class to describe an EnOcean Device
o C eoDeviceManager | Manages the devices
o C eoEEP_A502xx | The class to handle EEP a502 profiles
o C eoEEP_A504xx | The class to handle EEP a504 profiles
o C eoEEP_A505xx | The class to handle EEP a505 profiles
o C eoEEP_A506xx | The class to handle EEP a506 profiles
o C eoEEP_A507xx | The class to handle EEP a507 profiles
o C eoEEP_A508xx | The class to handle EEP a508 profiles
o C eoEEP_A509xx | The class to handle EEP a509 profiles
o C eoEEP_A510xx | The class to handle EEP a510 profiles
o C eoEEP_A511xx | The class to handle EEP a511 profiles
o C eoEEP_A512xx | The class to handle EEP a512 Automated meter reading (AMR) profiles
o C eoEEP_A513xx | The class to handle EEP a513 profiles
o C eoEEP_A514xx | The class to handle EEP a514 profiles
o C eoEEP_A520xx | The class to handle EEP a520 profiles
o C eoEEP_A530xx | The class to handle EEP a530 profiles
o C eoEEP_A537xx | The class to handle EEP a537 profiles
o C eoEEP_A538xx | The class to handle EEP a538 profiles
o C eoEEP_D200xx | The class to handle EEP D200 profiles
o C eoEEP_D201xx | The class to handle EEP D201 profiles
o C eoEEP_D202xx | The class to handle EEP D202 profiles
o C eoEEP_D203xx | The class to handle EEP D203 Secure Light and Blind Control
o C eoEEP_D204xx | The class to handle EEP D204 Secure Light and Blind Control
o C eoEEP_D205xx | The class to handle EEP D205 profiles
o C eoEEP_D206xx | The class to handle EEP D206 profiles
o C eoEEP_D210xx | The class to handle EEP D210 profiles
o C eoEEP_D220xx | The class to handle EEP D220 profiles
o C eoEEP_D230xx | The class to handle EEP D230 profiles
o C eoEEP_D231xx | The class to handle EEP D231 profiles
o C eoEEP_D232xx | The class to handle EEP D232 Automated meter reading (AMR) profiles
o C eoEEP_D240xx | The class to handle EEP D240 profiles
o C eoEEP_D2A0xx | The class to handle EEP D2A0 profiles
o C eoEEP_D500xx | The class to handle EEP d500 profiles
o C eoEEP_F602xx | The class to handle EEP f602 Rocker Switch, 2 Rocker profiles
o C eoEEP_F603xx | The class to handle EEP f603 profiles
o C eoEEP_F604xx | The class to handle EEP f604 profiles
o C eoEEP_F605xx | The class to handle EEP f605 profiles
o C eoEEP_F610xx | The class to handle EEP f610 profiles
o C eoEEPChannelInfo | Specific class for EEP channel information. Class used to decribe the EEP channels. It has the EEP_ITEM to describe the EEP channel values and the subtype - index
o C eoEEProfile | Base class for EEProfile parsing
o C eoF6EEProfile | EnOcean Equipment Profiles class for RORG F6
o C eoFilterFactory | Helper class for deserialization
o C eoGateway | EnOcean Gateway class, for handling a gateway Module
o C eoGenericProfile | The class to handle Generic Profiles
o C eoGpChainer |
o C eoGPChannelInfo | Generic Profile Channel
o C eoHeader | Helper Class for the Serializations, sets the Archive Header
o C eoIDFilter | Uses EnOcean IDs as filter base
o C eoIFilter | Filter Interface
o C eoISerialize | Interface for storing
o C eoISimpleBidirectionalProfile | An interface for profiles which support bidirectional communication, but do not indicate the direction of the messages
o C eoIWatcher | The minimal Interface for an eoWatcher class
o C eoLinuxPacketStream | PacketStream Implementation for Linux based Systems
o C eoLogger | Logs Packets
o C eoManufacturer | Manufacturer List
o C eoMessage | Message Class for communication
o C eoMessageHandler |
o C eoMSCHelper | Static Helper Functions
o C eoPacket | Class which contains a Packet
o C eoPacketStream | The base class for all PacketStreams Implementations
o C eoProc | Helper to calculate different crc
o C eoProfile | Base class for Profile parsing
o C eoProfileFactory | Creates Profiles
o C eoReCom | Remote Commissioning interface class
o C eoReManChainer |
o C eoReManMessage |
o C eoRemoteManager | Remote Manager interface class
o C eoRollingCodeStorage | Manages the rolling codes
o C eoSecTeachInChainer |
o C eoSecureInfo |
o C eoSecurity | Handles EnOcean Security Telegrams
o C eoSerialCommand | EnOcean Common Commands class, enables an easy interface for the most common commands
o C eoStorageManager | Handles the Storage of Object
o C eoTeachInModule | Handles TeachIn Messages
o C eoTelegram | Every Communication from an EnOcean Device to another one consist out of one more Telegrams. The eoTelegram class contains the payload Data from one Telegram
o C eoTimer | TickCount helper
o C eoWatcher | Example implementation of an Security Watcher Class which tries to predict DOS and Delay Attacks
o C eoWatcherFactory | Helper class for deserialization
o C eoWin32PacketStream | PacketStream Implementation for Windows based Systems
o C FLASH_READ_RESPONSE | Flash read response structure
o C GP_LINK_TABLE | Query gp teach in link table structure
o C LEARNED_SENSOR_RESPONSE | Learned sensors response structure
o C LINK_TABLE | Entry for get/set link table
o C MAILBOX_SETTINGS_RESPONSE | Mailbox settings response structure
o C PING_RESPONSE | Ping response structure
o C QUERY_APPLY_CHANGES | Apply changes struct
o C QUERY_DEVICE_CONFIG | Query device configuration
o C QUERY_FUNCTION_RESPONSE | Query function response structure
o C QUERY_ID | Query ID structure
o C QUERY_LINK_BASED_CONFIG | Query link based configuration
o C QUERY_LINK_TABLE | Query link table structure
o C QUERY_METADATA_RESPONSE | Query metadata response structure
o C QUERY_PRODUCT_ID_RESPONSE | Get product ID response
o C QUERY_RADIO_LINK_TEST | Radio link test control
o C QUERY_REPEATER_RESPONSE | Get repeater response
o C QUERY_RESET_DEFAULTS | Query reset structure
o C QUERY_SET_LEARN_MODE | Set learn mode structure
o C QUERY_SET_REPEATER_FILTER | Set repeater filter
o C QUERY_STATUS_RESPONSE | Query status response structure
o C SA_CONFIRM_LEARN_REQUEST | Confirm Learn response
o C SA_LEARN_ACK_RESPONSE | Learn SmartAck response
o C SA_RD_LEARNEDCLIENTS_RESPONSE | SmartAck learned clients response structure
o C SA_RD_LEARNMODE_RESPONSE | SmartAck read learnmode response structure
o C serialize_object | Serialised obejct type definition to save learned devices
o C TEACH_STRUCT | Teach message structure
\ C WATCH_STRUCT | Watch structure
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: CO_RD_DUTYCYCLE_RESPONSE Struct Reference

Public Attributes
CO_RD_DUTYCYCLE_RESPONSE Struct Reference

Read actual duty cycle limit structure. More...

#include <eoSerialCommand.h>

List of all members.

Public Attributes

uint8_t | availableCycle
Available duty cycle.
uint8_t | numOfSlots
Number of duty cycle slots.
uint16_t | slotPeriod
Period of one slot in seconds.
uint16_t | slotPeriodLeft
Time left in actual slot in seconds.
uint8_t | loadAfterCycle
Load available when period ends.

Detailed Description

Read actual duty cycle limit structure.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: DEVICE_CONFIG Struct Reference

Public Attributes
DEVICE_CONFIG Struct Reference

Dvice configuration response. More...

#include <eoReCom.h>

List of all members.

Public Attributes

uint16_t | index
Starting index.
uint8_t | length
Byte-Length of the rawValue.
uint32_t | rawValue
the RawValue

Detailed Description

Dvice configuration response.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: EEP_ITEM Struct Reference

Public Attributes
EEP_ITEM Struct Reference

#include <eoChannelInfo.h>

List of all members.

Public Attributes

bool | exist
Help flag if channel available.
uint16_t | bitoffs
Offset of the data value in telegram in bits.
uint16_t | bitsize
Size of the data value in telegram.
uint32_t | rangeMin
Range of the data value - minimum.
uint32_t | rangeMax
Range of the data value - maximum.
float | scaleMin
Scaling application for the data value - minimum.
float | scaleMax
Scaling application for the data value - maximum.
CHANNEL_TYPE type
CHANNEL_TYPE
uint8_t | index
Subchannel type - or index. This is only used if two of the same CHANNEL_TYPE members are available and we need to differ between them.

Detailed Description

Structure to describe the EEP Related information. It can be used in channel decoding and usage.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoAbstractMessage Class Reference

Public Member Functions | Public Attributes | Protected Member Functions
eoAbstractMessage Class Reference

base class for all Messages More...

#include <eoAbstractMessage.h>

Inheritance diagram for eoAbstractMessage:
[legend]

List of all members.

Public Member Functions

eoReturn | SetDataLength (uint16_t dataLen, bool reallocate=false)
uint16_t | GetDataLength () const
uint16_t | GetMaxLength () const

Public Attributes

uint8_t * | data
Data Pointer.
uint16_t | dataLength
Payload data length.
uint16_t | maxLength

Protected Member Functions

eoAbstractMessage (uint16_t size=1)

Detailed Description

base class for all Messages

this class describes an abstract Message. It is the base class for all real Message Applications

Constructor & Destructor Documentation

eoAbstractMessage::eoAbstractMessage ( uint16_t size = 1 )
protected

Constructor.

Parameters:
size Default size of the message.

Member Function Documentation

uint16_t eoAbstractMessage::GetDataLength ( ) const

Returns current DataLength

Returns:
data length
uint16_t eoAbstractMessage::GetMaxLength ( ) const

Gets the maximal Message Length

Returns:
maximal Data Length
eoReturn eoAbstractMessage::SetDataLength | ( | uint16_t | dataLen,
 |  | bool | reallocate = false
 | ) |  |

Gets the dataLength, when reallocate is set to true, a new data Buffer is allocated if the new Size is bigger then the max Size

Parameters:
dataLen | new dataLen Size
reallocate | Enables new allocation
Returns:
Examples:
profile_examples.cpp.

Member Data Documentation

uint16_t eoAbstractMessage::maxLength

maximal Length the message can have

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoChainedMessage Class Reference

Public Member Functions | Public Attributes
eoChainedMessage Class Reference

#include <eoChainedMessage.h>

Inheritance diagram for eoChainedMessage:
[legend]
Collaboration diagram for eoChainedMessage:
[legend]

List of all members.

Public Member Functions

eoChainedMessage (uint16_t maxSize)
eoReturn ProcessChunks ()
- Public Member Functions inherited from eoMessage
eoReturn | copyTo (eoMessage &msg) const
virtual void | Clear ()
eoMessage (uint16_t size=1)
eoMessage (const eoTelegram &tel)
- Public Member Functions inherited from eoAbstractMessage
eoReturn | SetDataLength (uint16_t dataLen, bool reallocate=false)
uint16_t | GetDataLength () const
uint16_t | GetMaxLength () const

Public Attributes

bool | received
Message has been processed.
uint8_t | telCount
Telegram Count for Messages.
uint8_t | expectedTelCount
Expected Telegram Count for Messages.
uint8_t | seq
Sequence of the chained message. Sequence is type of message indentifier.
uint16_t | expectedDataLength
Expected data length of the chained message. Information should be contained in the header.
uint16_t | sizeN
Actual Payload Datasize.
uint32_t | timeStamp
Timestamp of the first telegram. Used for Time-out functionality.
std::vector< eoChunkMessage > | dataChunks
All Messages parts are located in the dataChunks array.
- Public Attributes inherited from eoMessage
uint8_t | RORG
RORG as specified by EnOcean.
uint8_t | status
status Information from device
uint32_t | sourceID
SourceID.
uint32_t | destinationID
the destination ID
uint8_t | securityLevel
Security level of the message.
- Public Attributes inherited from eoAbstractMessage
uint8_t * | data
Data Pointer.
uint16_t | dataLength
Payload data length.
uint16_t | maxLength

Detailed Description

chainedMessage Helper Class, will be copied to normal eoMessage, when we finished receiving

Constructor & Destructor Documentation

eoChainedMessage::eoChainedMessage ( uint16_t maxSize )

Constructor.

Parameters:
maxSize defining the maximum size in bytes.

Member Function Documentation

eoReturn eoChainedMessage::ProcessChunks ( )

The Chunk messages will be processessed and saved into the ChainedMessagedatabuffer

Returns:
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoChainedReManMessage Class Reference

Public Member Functions | Public Attributes
eoChainedReManMessage Class Reference

#include <eoChainedReManMessage.h>

Inheritance diagram for eoChainedReManMessage:
[legend]
Collaboration diagram for eoChainedReManMessage:
[legend]

List of all members.

Public Member Functions

eoChainedReManMessage (uint16_t maxSize)
eoReturn | copyTo (eoReManMessage &reMsg) const
- Public Member Functions inherited from eoChainedMessage
eoChainedMessage (uint16_t maxSize)
eoReturn ProcessChunks ()
- Public Member Functions inherited from eoMessage
eoReturn | copyTo (eoMessage &msg) const
virtual void | Clear ()
eoMessage (uint16_t size=1)
eoMessage (const eoTelegram &tel)
- Public Member Functions inherited from eoAbstractMessage
eoReturn | SetDataLength (uint16_t dataLen, bool reallocate=false)
uint16_t | GetDataLength () const
uint16_t | GetMaxLength () const

Public Attributes

uint16_t | fnCode
Remote Management Function Code of the chained message.
uint16_t | manufacturerID
Manufacturer ID of the chained message.
- Public Attributes inherited from eoChainedMessage
bool | received
Message has been processed.
uint8_t | telCount
Telegram Count for Messages.
uint8_t | expectedTelCount
Expected Telegram Count for Messages.
uint8_t | seq
Sequence of the chained message. Sequence is type of message indentifier.
uint16_t | expectedDataLength
Expected data length of the chained message. Information should be contained in the header.
uint16_t | sizeN
Actual Payload Datasize.
uint32_t | timeStamp
Timestamp of the first telegram. Used for Time-out functionality.
std::vector< eoChunkMessage > | dataChunks
All Messages parts are located in the dataChunks array.
- Public Attributes inherited from eoMessage
uint8_t | RORG
RORG as specified by EnOcean.
uint8_t | status
status Information from device
uint32_t | sourceID
SourceID.
uint32_t | destinationID
the destination ID
uint8_t | securityLevel
Security level of the message.
- Public Attributes inherited from eoAbstractMessage
uint8_t * | data
Data Pointer.
uint16_t | dataLength
Payload data length.
uint16_t | maxLength

Detailed Description

chainedReManMessage Helper Class, will be copied to normal eoMessage, when we finished receiving

Constructor & Destructor Documentation

eoChainedReManMessage::eoChainedReManMessage ( uint16_t maxSize )

*Constructor.

Parameters:
maxSize Maximum size of the to be received message.

Member Function Documentation

eoReturn eoChainedReManMessage::copyTo ( eoReManMessage & reMsg ) const

*Copy function of Remote Message.

Parameters:
reMsg To be copy eoReManMessage.
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoChunkMessage Class Reference

Public Member Functions
eoChunkMessage Class Reference

Representing part of an message. More...

#include <eoChunkMessage.h>

Inheritance diagram for eoChunkMessage:
[legend]
Collaboration diagram for eoChunkMessage:
[legend]

List of all members.

Public Member Functions

eoChunkMessage (const eoChunkMessage &other)
Copy Constructor.
eoReturn | CopyFrom (eoAbstractMessage const &msg)
eoReturn | CopyDataFrom (const uint8_t *const src, const uint8_t len)
Copies len bytes of data to the internal buffer.
bool | IsReceived () const
Checks if the chunk of the message has been received.
eoChunkMessage (uint16_t size)
Constructor with defined size.
- Public Member Functions inherited from eoAbstractMessage
eoReturn | SetDataLength (uint16_t dataLen, bool reallocate=false)
uint16_t | GetDataLength () const
uint16_t | GetMaxLength () const

Additional Inherited Members

- Public Attributes inherited from eoAbstractMessage
uint8_t * | data
Data Pointer.
uint16_t | dataLength
Payload data length.
uint16_t | maxLength
- Protected Member Functions inherited from eoAbstractMessage
eoAbstractMessage (uint16_t size=1)

Detailed Description

Representing part of an message.

this class describes the part of a chained message, this is used in the ChainedMessage to store the storage parts

Constructor & Destructor Documentation

eoChunkMessage::eoChunkMessage ( const eoChunkMessage & other )

Copy Constructor.

As the eoChained message is used inside a vector and every instance needs an own databuffer a copy constructor is used!

Parameters:
other

Member Function Documentation

eoReturn eoChunkMessage::CopyDataFrom | ( | const uint8_t *const | src,
 |  | const uint8_t | len
 | ) |  |

Copies len bytes of data to the internal buffer.

This function will reallocalate the memory itself. The len bytes of data from the src will be copied

Parameters:
src | Source data
len | x bytes to copy
Returns:
eoReturn eoChunkMessage::CopyFrom ( eoAbstractMessage const & msg )

Copies from a message the data, the received flag will be set to true afterwards

Parameters:
msg an eoMessage to copy from
Returns:
EO_OK or error
bool eoChunkMessage::IsReceived ( ) const
inline

Checks if the chunk of the message has been received.

Returns:
bool param
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoFilterFactory Class Reference

Static Public Member Functions
eoFilterFactory Class Reference

helper class for deserialization More...

#include <eoFilterFactory.h>

List of all members.

Static Public Member Functions

static eoIFilter * CreateFilter (uint8_t type)

Detailed Description

helper class for deserialization

Member Function Documentation

static eoIFilter* eoFilterFactory::CreateFilter ( uint8_t type )
static

Constructor for new filters.

Parameters:
type Type of the filter according SUPPORTED_FILTERS.
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoGpChainer Class Reference

Public Member Functions
eoGpChainer Class Reference

#include <eoGpChainer.h>

List of all members.

Public Member Functions

void | CleanUpList ()
eoReturn | ParseChainedMessage (eoTelegram &tel, eoMessage &msg)
eoReturn | SendChainedMessage (const eoMessage &msg, eoGateway &gateway)

Detailed Description

Chaning of GP data messages.

Member Function Documentation

void eoGpChainer::CleanUpList ( )

Clean up the message list.

eoReturn eoGpChainer::ParseChainedMessage | ( | eoTelegram & | tel,
 |  | eoMessage & | msg
 | ) |  |

Parses a chained GenericProfiles message from several telegrams to an eoMessage

Parameters:
tel | incoming telegram
msg | resulting eoMessage
Returns:
eoReturn eoGpChainer::SendChainedMessage | ( | const eoMessage & | msg,
 |  | eoGateway & | gateway
 | ) |  |

Sends a Generic Profiles message longer than 14 bytes in multiple telegrams

Parameters:
msg | The Message to be split into telegrams
gateway | The eoGateway the telegrams are to be sent with
Returns:
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoHeader Class Reference

Public Member Functions | Public Attributes
eoHeader Class Reference

Helper Class for the Serializations, sets the Archive Header. More...

#include <eoHeader.h>

Inheritance diagram for eoHeader:
[legend]
Collaboration diagram for eoHeader:
[legend]

List of all members.

Public Member Functions

eoHeader (uint8_t majorVersion, uint8_t minorVersion, const char *handlerName)
virtual uint8_t Serialize (eoArchive &arch)
Serialization Function which will be called by the eoStorageManager.

Public Attributes

uint8_t | major
Major version of the Archive.
uint8_t | minor
Minor Version of the Archive.
char | name [32]
String name of the Archive.

Detailed Description

Helper Class for the Serializations, sets the Archive Header.

Constructor & Destructor Documentation

eoHeader::eoHeader | ( | uint8_t | majorVersion,
 |  | uint8_t | minorVersion,
 |  | const char * | handlerName
 | ) |  |

Create an eoHeadr for serialisation with specific versions.

Parameters:
majorVersion | Major version of the archive.
minorVersion | Minor version of the archive.
handlerName | Name of the archive.

Member Function Documentation

virtual uint8_t eoHeader::Serialize ( eoArchive & arch )
virtual

Serialization Function which will be called by the eoStorageManager.

This function will be called by the eoArchive(inside of the eoStorageManager) and allows the class to be Serialized.

Parameters:
arch archive where to Load or to Store.

Reimplemented from eoISerialize.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoISimpleBidirectionalProfile Class Reference

Public Member Functions | Protected Attributes
eoISimpleBidirectionalProfile Class Reference

An interface for profiles which support bidirectional communication, but do not indicate the direction of the messages. More...

#include <eoISimpleBidirectionalProfile.h>

Inheritance diagram for eoISimpleBidirectionalProfile:
[legend]

List of all members.

Public Member Functions

virtual eoReturn | SetDirection (SIMPLE_DIRECTION direction)=0
virtual eoChannelInfo * | GetOutChannel (CHANNEL_TYPE type, uint8_t subType)
virtual eoChannelInfo * | GetOutChannel (CHANNEL_TYPE type)=0
virtual eoChannelInfo * | GetOutChannel (uint8_t channelNumber)=0

Protected Attributes

SIMPLE_DIRECTION direction

Detailed Description

An interface for profiles which support bidirectional communication, but do not indicate the direction of the messages.

This interface is an helper interface for EEProfiles which communicate bidirectional, but do not indicate in the message itself which direction is used (e.g. Command Bytes). Profiles using this interface use the direction bit to indicate in which way messages should be created/ parsed. If the direction is set to eoController, eoLink is the Controller and parses the messages as Actuator messages and send messages as Controller. If the direction is set to eoActuator, eoLink simulates an Actuator device. The default direction is eoController. When Changing the direction, the values are getting invalid.

Member Function Documentation

virtual eoChannelInfo* eoISimpleBidirectionalProfile::GetOutChannel | ( | CHANNEL_TYPE | type,
 |  | uint8_t | subType
 | ) |  |
inlinevirtual

Returns the outChannel for the selected type and subtype

Parameters:
type | CHANNEL_TYPE
subType | is either the numeric "subChannelNUmber" (temperature CHannel 0,1,2,3) or a specified keyword for it(see profile)
Returns:
Pointer to Channel

Reimplemented in eoEEP_A520xx.

Here is the call graph for this function:

Here is the caller graph for this function:

virtual eoChannelInfo* eoISimpleBidirectionalProfile::GetOutChannel ( CHANNEL_TYPE type )
pure virtual

Returns the outChannel for the selected type

Parameters:
type CHANNEL_TYPE
Returns:
Pointer to ChannelInfo or Null

Implemented in eoEEP_A520xx, and eoEEP_D2A0xx.

virtual eoChannelInfo* eoISimpleBidirectionalProfile::GetOutChannel ( uint8_t channelNumber )
pure virtual

returns the pointer to eoChannelInfo for the selected outChannelNumber or NULL

Parameters:
channelNumber
Returns:
Pointer to Channel

Implemented in eoEEP_A520xx, and eoEEP_D2A0xx.

virtual eoReturn eoISimpleBidirectionalProfile::SetDirection ( SIMPLE_DIRECTION direction )
pure virtual

Set the direction of the profile, if the specific profile does not support Bidirectional mode, nothing happens.

Parameters:
direction

Implemented in eoEEP_A520xx, and eoEEP_D2A0xx.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoIWatcher Class Reference

Public Member Functions | Public Attributes
eoIWatcher Class Reference

The minimal Interface for an eoWatcher class. More...

#include <eoIWatcher.h>

Inheritance diagram for eoIWatcher:
[legend]
Collaboration diagram for eoIWatcher:
[legend]

List of all members.

Public Member Functions

virtual uint32_t | CheckSecurity (eoDevice const *const device, eoTelegram const &tel)
checks the Security of a Device after Receiving a telegram.
virtual uint8_t | Serialize (eoArchive &arch)

Public Attributes

uint8_t type
Type of the eoIWatcher, this is used for the serialization.

Detailed Description

The minimal Interface for an eoWatcher class.

The CheckSecurity is called inside Gateway and stored as internal variable. This Interface allows you to implement an own security check algorithm which is called for every received telegram. The function eoIWatcher::CheckSecurity(eoDevice const * const device,eoTelegram const &tel) is always called in the Gateway after receiving a telegram. The result of the function can be accessed using the eoGateway::GetSecWatchResult()

Member Function Documentation

virtual uint32_t eoIWatcher::CheckSecurity | ( | eoDevice const *const | device,
 |  | eoTelegram const & | tel
 | ) |  |
virtual

checks the Security of a Device after Receiving a telegram.

This function has to be called always after receiving a telegram!

Parameters:
device | pointer to eoDevice to Check
tel | last received telegram
Returns:

Reimplemented in eoWatcher.

virtual uint8_t eoIWatcher::Serialize ( eoArchive & arch )
virtual

Serialization Function which will be called by the eoStorageManager This function will be called by the eoArchive(inside of the eoStorageManager) and allows the class to be Serialized.

Parameters:
&arch Archive where to Load or to Store.

Reimplemented from eoISerialize.

Reimplemented in eoWatcher.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoLinuxPacketStream Class Reference

Public Member Functions
eoLinuxPacketStream Class Reference

PacketStream Implementation for Linux based Systems. More...

#include <eoLinuxPacketStream.h>

Inheritance diagram for eoLinuxPacketStream:
[legend]
Collaboration diagram for eoLinuxPacketStream:
[legend]

List of all members.

Public Member Functions

eoReturn | Open (const char *port)
void | Close ()
eoReturn | ReceiveByte (uint8_t *u8RxByte)
eoReturn | SendByte (uint8_t u8TxByte)
- Public Member Functions inherited from eoPacketStream
eoPacketStream ()
virtual eoReturn | Receive (eoPacket *p)
virtual eoReturn | Send (const eoPacket &p)
virtual bool | IsPacketPending ()

Detailed Description

PacketStream Implementation for Linux based Systems.

LinuxPacketStream uses a /dev/ttyxx Interface for a direct communication to an EnOcean device via UART [ESP3].

Examples:
linuxPacketStream_example.cpp, and packetStream_example.cpp.

Member Function Documentation

void eoLinuxPacketStream::Close ( )
virtual

Close the Port

Implements eoPacketStream.

eoReturn eoLinuxPacketStream::Open ( const char * port )
virtual

Tries to Open and initialize the specific port for the eoLinuxPacketstream

Parameters:
port to open; for example "/dev/ttyUSB0"
Returns:
eoReturn EO_OK if everything was ok else eoReturn PORT_ERROR

Implements eoPacketStream.

Examples:
linuxPacketStream_example.cpp.
eoReturn eoLinuxPacketStream::ReceiveByte ( uint8_t * d )
virtual
Parameters:
d Pointer where to write the Byte
Returns:
Returns a eoReturn

Implements eoPacketStream.

eoReturn eoLinuxPacketStream::SendByte ( uint8_t d )
virtual
Parameters:
d The byte to send
Returns:
Returns a eoReturn

Implements eoPacketStream.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoLogger Class Reference

Public Member Functions
eoLogger Class Reference

Logs Packets. More...

#include <eoLogger.h>

List of all members.

Public Member Functions

eoLogger ()
eoReturn | Open (const char *filename)
eoReturn Close ()
eoReturn | Log (eoPacket &p, bool flush=false)
eoReturn | Log (eoTelegram &tel, bool flush=false)
eoReturn Flush ()

Detailed Description

Logs Packets.

The eoLogger logs Packets in binary to a specified file. Each packets precedes a timestamp.

Constructor & Destructor Documentation

eoLogger::eoLogger ( )

Constructor

Member Function Documentation

eoReturn eoLogger::Close ( )

Closes the file that was opened using open()

Returns:
0 for successful closing the file.
eoReturn eoLogger::Flush ( )

Flushes the stream to file.

eoReturn eoLogger::Log | ( | eoPacket & | p,
 |  | bool | flush = false
 | ) |  |

*Logs a Packet of type Packet by appending it to the opened file with a preceding timestamp.

Parameters:
p | The Packet to be logged.
flush | If true, after logging the packet p, the file is flushed
Returns:
Returns 0 if successful.
eoReturn eoLogger::Log | ( | eoTelegram & | tel,
 |  | bool | flush = false
 | ) |  |

*Logs a Packet of type Packet by appending it to the opened file with a preceding timestamp.

Parameters:
p | The Packet to be logged.
flush | If true, after logging the packet p, the file is flushed
Returns:
Returns 0 if successful.
eoReturn eoLogger::Open ( const char * filename )

Opens a file for binary write access. Overwrites it if it exists.

Returns:
0 for successful opening the file. -1 otherwise.
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoMessageHandler Class Reference

Public Member Functions
eoMessageHandler Class Reference

#include <eoMessageHandler.h>

List of all members.

Public Member Functions

eoReturn | ProcessTelegram (eoTelegram &tel, eoMessage &msg)
eoReturn | ProcessTelegram (eoTelegram &tel, eoReManMessage &msg)
void | CleanUpChainerLists ()
eoReturn | ComposeChainedMessage (const eoMessage &msg, eoGateway &gateway)
eoReturn | ComposeChainedMessage (const eoReManMessage &reMsg, eoGateway &gateway)

Detailed Description

Helper class converting telegrams to messages and chaining.

Member Function Documentation

void eoMessageHandler::CleanUpChainerLists ( )

Calls the CleanUpList() function of each Message Chainer to delete eoChainedMessages that are timed out

Returns:
eoReturn eoMessageHandler::ComposeChainedMessage | ( | const eoMessage & | msg,
 |  | eoGateway & | gateway
 | ) |  |

Sends a long eoMessage in multiple telegrams

Parameters:
msg | eoMessage to be sent
gateway | The eoGateway the telegrams are to be sent with
Returns:
eoReturn eoMessageHandler::ComposeChainedMessage | ( | const eoReManMessage & | reMsg,
 |  | eoGateway & | gateway
 | ) |  |

Sends a long eoReManMessage in multiple telegrams

Parameters:
reMsg | eoReManMessage
gateway | The eoGateway the telegrams are to be sent with
Returns:
eoReturn eoMessageHandler::ProcessTelegram | ( | eoTelegram & | tel,
 |  | eoMessage & | msg
 | ) |  |

Processes a telegram that is part of a chained message

Parameters:
tel | incoming telegram
msg | resulting eoMessage
Returns:
eoReturn eoMessageHandler::ProcessTelegram | ( | eoTelegram & | tel,
 |  | eoReManMessage & | msg
 | ) |  |

Processes a telegram that is part of a chained message

Parameters:
tel | incoming telegram
msg | resulting eoReManMessage
Returns:
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoMSCHelper Class Reference

Public Member Functions
eoMSCHelper Class Reference

contains static Helper Functions More...

#include <eoMSCHelper.h>

List of all members.

Public Member Functions

eoReturn | GetMSCmanufacturer (MANUFACTURER_LIST *manufacturer, eoMessage &msg)
eoReturn | GetMSCpayload (uint8_t *payload, uint8_t maxDataCount, eoMessage &msg)
eoReturn | SetMSCmanufacturer (const MANUFACTURER_LIST manufacturer, eoMessage &msg)
eoReturn | SetMSCpayload (const uint8_t *payload, uint8_t dataCount, eoMessage &msg)

Detailed Description

contains static Helper Functions

The eoMSCHelper allows you to easily integrate MSC telegrams into your program.

Member Function Documentation

eoReturn eoMSCHelper::GetMSCmanufacturer | ( | MANUFACTURER_LIST * | manufacturer,
 |  | eoMessage & | msg
 | ) |  |

Get the MSC manufacturer

Parameters:
[out] | manufacturer | Pointer to the variable where the manufacturer ID should be returned
msg | eoTelegram which needs to be converted
Returns:
EO_OK or EO_ERROR
eoReturn eoMSCHelper::GetMSCpayload | ( | uint8_t * | payload,
 |  | uint8_t | maxDataCount,
 |  | eoMessage & | msg
 | ) |  |

Get the MSC payload

Parameters:
[out] | payload | Pointer to an array
maxDataCount | The size of the payload array
msg | eoTelegram which needs to be converted
Returns:
EO_OK or EO_ERROR
eoReturn eoMSCHelper::SetMSCmanufacturer | ( | const MANUFACTURER_LIST | manufacturer,
 |  | eoMessage & | msg
 | ) |  |

Set the MSC manufacturer

Parameters:
manufacturer
msg
Returns:
EO_OK
eoReturn eoMSCHelper::SetMSCpayload | ( | const uint8_t * | payload,
 |  | uint8_t | dataCount,
 |  | eoMessage & | msg
 | ) |  |

Set the MSC paylod

Parameters:
payload
dataCount
msg
Returns:
EO_OK or WRONG_PARAM
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoPacketStream Class Reference

Public Member Functions
eoPacketStream Class Reference

The base class for all PacketStreams Implementations. More...

#include <eoPacketStream.h>

Inheritance diagram for eoPacketStream:
[legend]

List of all members.

Public Member Functions

eoPacketStream ()
virtual eoReturn | Open (const char *port)=0
virtual void | Close ()=0
virtual eoReturn | Receive (eoPacket *p)
virtual eoReturn | ReceiveByte (uint8_t *d)=0
virtual eoReturn | Send (const eoPacket &p)
virtual eoReturn | SendByte (uint8_t d)=0
virtual bool | IsPacketPending ()

Detailed Description

The base class for all PacketStreams Implementations.

PacketStream is an abstract base class for the Hardware specific xyPacketStream Classes. It contains the Important PacketStream::Receive and PacketStream::Send Functions to receive and send [ESP3] Packets. The specific Hardware classed have to implement at least SendByte and ReceiveByte to get the Bytes.

Constructor & Destructor Documentation

eoPacketStream::eoPacketStream ( )

Constructor for eoPacketStream, Inits the necessary Hardware and opens the ports

Member Function Documentation

virtual void eoPacketStream::Close ( )
pure virtual

Close the Port

Implemented in eoLinuxPacketStream, and eoWin32PacketStream.

virtual bool eoPacketStream::IsPacketPending ( )
virtual

Checks if a packet is currently received through the receive line, but is not yet fully received.

Returns:
true if a packet is pending, false if no packet is currently received
virtual eoReturn eoPacketStream::Open ( const char * port )
pure virtual

Tries to Open and initialize the specific port for the eoPacketStream

Parameters:
port to open; for example "/dev/USB300"
Returns:
eoReturn EO_OK if everything was ok else eoReturn PORT_ERROR

Implemented in eoLinuxPacketStream, and eoWin32PacketStream.

virtual eoReturn eoPacketStream::Receive ( eoPacket * p )
virtual

This functions will parse all the available bytes in the Stream, and tries to find an ESP3 Packet. It will Return EO_OK if we found one, or NEW_RX_BYTE if we've received some bytes but not yet a full Packet.

Parameters:
p Pointer to eoPacket to be filled
Returns:
Returns a eoReturn
Examples:
linuxPacketStream_example.cpp, and packetStream_example.cpp.
virtual eoReturn eoPacketStream::ReceiveByte ( uint8_t * d )
pure virtual
Parameters:
d Pointer where to write the Byte
Returns:
Returns a eoReturn

Implemented in eoWin32PacketStream, and eoLinuxPacketStream.

virtual eoReturn eoPacketStream::Send ( const eoPacket & p )
virtual
Parameters:
p The eoPacket to send
Returns:
Returns a eoReturn
Examples:
linuxPacketStream_example.cpp, and packetStream_example.cpp.
virtual eoReturn eoPacketStream::SendByte ( uint8_t d )
pure virtual
Parameters:
d The byte to send
Returns:
Returns a eoReturn

Implemented in eoWin32PacketStream, and eoLinuxPacketStream.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoProc Class Reference

Static Public Member Functions
eoProc Class Reference

Helper to calculate different crc. More...

#include <eoProc.h>

List of all members.

Static Public Member Functions

static uint8_t | crc8 (uint8_t CRC, uint8_t Data)
static uint16_t | crc16 (uint16_t CRC, uint16_t Data)

Detailed Description

Helper to calculate different crc.

Member Function Documentation

static uint16_t eoProc::crc16 | ( | uint16_t | CRC,
 |  | uint16_t | Data
 | ) |  |
static

Calculates the crc

Parameters:
CRC | previous calculated crc
Data | data byte to use
Returns:
next calculated crc
static uint8_t eoProc::crc8 | ( | uint8_t | CRC,
 |  | uint8_t | Data
 | ) |  |
static

Calculates the crc

Parameters:
CRC | previous calculated crc
Data | data byte to use
Returns:
next calculated crc
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoProfileFactory Class Reference

Static Public Member Functions
eoProfileFactory Class Reference

creates Profiles More...

#include <eoProfileFactory.h>

List of all members.

Static Public Member Functions

static eoProfile * | CreateProfile (const eoMessage &msg)
Returns eoProfile based on TEACH_IN Message.
static eoProfile * | CreateProfile (const uint8_t rorg, const uint8_t func, const uint8_t type)
Returns eoProfile based on the specified rorg,func and type.

Detailed Description

creates Profiles

this helper class, helps you to create an EoProfile.

Member Function Documentation

static eoProfile* eoProfileFactory::CreateProfile ( const eoMessage & msg )
static

Returns eoProfile based on TEACH_IN Message.

This helper function, will parse the TEACH_IN Message and when the profile is supported a pointer to the eoProfile or otherwise a null Pointer.

For Generic Profiles, the GP_TI Message will parsed, and a new eoGenericProfile will be returned.

Parameters:
msg TEACH_IN Message to parse
Returns:
a Pointer to the right eoProfile or NULL
Examples:
profile_examples.cpp, Security_example.cpp, sendTelegram_example.cpp, tutorial3.cpp, and vld_example.cpp.
static eoProfile* eoProfileFactory::CreateProfile | ( | const uint8_t | rorg,
 |  | const uint8_t | func,
 |  | const uint8_t | type
 | ) |  |
static

Returns eoProfile based on the specified rorg,func and type.

This helper function, returns the specified eoProfile based on the rorg,func and type information or a null pointer if it is not supported.

Parameters:
rorg | see [EEP]
func | see [EEP]
type | see [EEP]
Returns:
a Pointer to the right eoProfile or NULL
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoReManChainer Class Reference

Public Member Functions
eoReManChainer Class Reference

#include <eoReManChainer.h>

List of all members.

Public Member Functions

void | CleanUpList ()
eoReturn | ParseChainedMessage (eoTelegram &tel, eoReManMessage &msg)
eoReturn | SendChainedMessage (const eoReManMessage &msg, eoGateway &gateway)

Detailed Description

Chaining of remote management messages

Member Function Documentation

void eoReManChainer::CleanUpList ( )

Cleans up the list of eoChainedMessage Objects by dropping the ones that are timed out

Returns:
eoReturn eoReManChainer::ParseChainedMessage | ( | eoTelegram & | tel,
 |  | eoReManMessage & | msg
 | ) |  |

Parses a chained RemoteManagement message from several telegrams to an eoMessage

Parameters:
tel | incoming telegram
msg | resulting eoMessage
Returns:
eoReturn eoReManChainer::SendChainedMessage | ( | const eoReManMessage & | msg,
 |  | eoGateway & | gateway
 | ) |  |

Sends a RemoteManagement message longer than 14 bytes in multiple telegrams

Parameters:
msg | The Message to be split into telegrams
gateway | The eoGateway the telegrams are to be sent with
Returns:
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoReManMessage Class Reference

Public Member Functions | Public Attributes
eoReManMessage Class Reference

#include <eoReManMessage.h>

Inheritance diagram for eoReManMessage:
[legend]
Collaboration diagram for eoReManMessage:
[legend]

List of all members.

Public Member Functions

uint8_t | copyTo (eoReManMessage &msg) const
eoReManMessage (uint16_t size)
- Public Member Functions inherited from eoAbstractMessage
eoReturn | SetDataLength (uint16_t dataLen, bool reallocate=false)
uint16_t | GetDataLength () const
uint16_t | GetMaxLength () const

Public Attributes

uint32_t | sourceID
EnOcean Source ID of the Remote Management Message.
uint32_t | destinationID
EnOcean Destination ID of the Remote Management Message.
uint8_t | securityLevel
Security level EnOcean ID id of the Remote Management Message.
uint16_t | fnCode
Remote Management Function Code of the Remote Management Message.
uint16_t | manufacturerID
Manufacturer ID of the Remote Management Message.
- Public Attributes inherited from eoAbstractMessage
uint8_t * | data
Data Pointer.
uint16_t | dataLength
Payload data length.
uint16_t | maxLength

Additional Inherited Members

- Protected Member Functions inherited from eoAbstractMessage
eoAbstractMessage (uint16_t size=1)

Detailed Description

Remote Management message type also with reman header.

Constructor & Destructor Documentation

eoReManMessage::eoReManMessage ( uint16_t size )

Constructor.

Parameters:
size Size of the new module.

Member Function Documentation

uint8_t eoReManMessage::copyTo ( eoReManMessage & msg ) const

Copy existing message.

Parameters:
msg To be copy message.
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoSecTeachInChainer Class Reference

Public Member Functions | Protected Attributes
eoSecTeachInChainer Class Reference

#include <eoSecTeachInChainer.h>

List of all members.

Public Member Functions

void | CleanUpList ()
eoReturn | ParseChainedMessage (eoTelegram &tel, eoMessage &msg)
eoReturn | SendChainedMessage (const eoMessage &msg, eoGateway &gateway)

Protected Attributes

id_msg_map list
List of messages to be merged.

Detailed Description

Chaining of Security Teach in telegrams.

Member Function Documentation

void eoSecTeachInChainer::CleanUpList ( )

Cleans up the list of eoChainedMessage Objects by dropping the ones that are timed out

Returns:
eoReturn eoSecTeachInChainer::ParseChainedMessage | ( | eoTelegram & | tel,
 |  | eoMessage & | msg
 | ) |  |

Parses a chained SecureTeachIn message from several telegrams to an eoMessage

Parameters:
tel | incoming telegram
msg | resulting eoMessage
Returns:
eoReturn eoSecTeachInChainer::SendChainedMessage | ( | const eoMessage & | msg,
 |  | eoGateway & | gateway
 | ) |  |

Sends a SecureTeachIn message in multiple telegrams

Parameters:
msg | The Message to be split into telegrams
gateway | The eoGateway the telegrams are to be sent with
Returns:
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoTelegram Class Reference

Public Member Functions | Public Attributes
eoTelegram Class Reference

every Communication from an EnOcean Device to another one consist out of one more Telegrams. The eoTelegram class contains the payload Data from one Telegram. More...

#include <eoTelegram.h>

Inheritance diagram for eoTelegram:
[legend]
Collaboration diagram for eoTelegram:
[legend]

List of all members.

Public Member Functions

eoTelegram (const eoTelegram &telegram)
eoTelegram (uint16_t size)
virtual void | Clear ()
- Public Member Functions inherited from eoMessage
eoReturn | copyTo (eoMessage &msg) const
eoMessage (uint16_t size=1)
eoMessage (const eoTelegram &tel)
- Public Member Functions inherited from eoAbstractMessage
eoReturn | SetDataLength (uint16_t dataLen, bool reallocate=false)
uint16_t | GetDataLength () const
uint16_t | GetMaxLength () const

Public Attributes

int8_t | dBm
strength of the last received Telegram
uint8_t | subtelCount
number of Subtelegrams
- Public Attributes inherited from eoMessage
uint8_t | RORG
RORG as specified by EnOcean.
uint8_t | status
status Information from device
uint32_t | sourceID
SourceID.
uint32_t | destinationID
the destination ID
uint8_t | securityLevel
Security level of the message.
- Public Attributes inherited from eoAbstractMessage
uint8_t * | data
Data Pointer.
uint16_t | dataLength
Payload data length.
uint16_t | maxLength

Detailed Description

every Communication from an EnOcean Device to another one consist out of one more Telegrams. The eoTelegram class contains the payload Data from one Telegram.

a Telegram coming from a Device

Constructor & Destructor Documentation

eoTelegram::eoTelegram ( const eoTelegram & telegram )

Copy Constructor

Parameters:
telegram
eoTelegram::eoTelegram ( uint16_t size )

Creates a new Telegram with the maximal datalength size

Parameters:
size datalength

Member Function Documentation

virtual void eoTelegram::Clear ( )
virtual

Clears the message

Returns:

Reimplemented from eoMessage.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoWatcher Class Reference

Public Member Functions
eoWatcher Class Reference

an example implementation of an Security Watcher Class which tries to predict DOS and Delay Attacks. More...

#include <eoWatcher.h>

Inheritance diagram for eoWatcher:
[legend]
Collaboration diagram for eoWatcher:
[legend]

List of all members.

Public Member Functions

eoWatcher (uint32_t denialWarnCount, uint32_t denialTickBetween)
EO_SEC_WATCH_RESULT | AddDevice (uint32_t const DeviceID, uint32_t const maxPerdiodTime, uint32_t const minPeriodTime, uint32_t const maxRLCDiff, uint32_t const maxWrongCmac, bool resetPeriod)
Adds a Device to watch.
EO_SEC_WATCH_RESULT | UpdateDevice (uint32_t const DeviceID, uint32_t const maxPerdiodTime, uint32_t const minPeriodTime, uint32_t const maxRLCDiff, uint32_t const maxWrongCmac, bool resetPeriod)
Update device Information.
void | RemoveDevice (uint32_t const DeviceID)
Remove a device.
uint32_t | CheckSecurity (eoDevice const *const device, eoTelegram const &tel)
checks the Security of a Device after Receiving a telegram.
EO_SEC_WATCH_RESULT | Reset (uint32_t const DeviceID)
Reset security parameters.
bool | CheckDeadDevices (std::vector< uint32_t > &deadDevicesVector)
Check for dead Devices.
void | SetDenialWarnCount (uint32_t const warnCount)
uint32_t | GetDenialWarnCount () const
void | SetDenialTickBetween (uint32_t const tickCount)
uint32_t | GetDenialTickBetween () const
uint8_t | Serialize (eoArchive &arch)

Additional Inherited Members

- Public Attributes inherited from eoIWatcher
uint8_t type
Type of the eoIWatcher, this is used for the serialization.

Detailed Description

an example implementation of an Security Watcher Class which tries to predict DOS and Delay Attacks.

This class allows to add Devices to watch for Security problems. The following scenarios are supported:

  • Denial of Service, to many telegrams are sent in a certain time period
  • Delay attack, for a periodically sending device the telegrams are arriving to late.
  • We got to many telegrams with a wrong cmac
  • The difference of the Last Rolling Code counter and the current Rolling Code counter is to high (User definied, the security api already allows a maximal difference of 64! )

This class implements a security Watcher for the scenario AN513: Robust EnOcean networks

Examples:
WatcherMain.cpp.

Constructor & Destructor Documentation

eoWatcher::eoWatcher | ( | uint32_t | denialWarnCount,
 |  | uint32_t | denialTickBetween
 | ) |  |

Constructor of the eoWatcher Helper class.

Parameters:
denialWarnCount | How many telegrams are allowed to arrive maximal with a the definied tickCount between before a DOS is created. If = 0 the function is deactivated.
denialTickBetween | If the tick count between 2 telegrams is smaller then this count, the denialCounter gets increased. If = 0 the function is deactivated.

Member Function Documentation

EO_SEC_WATCH_RESULT eoWatcher::AddDevice | ( | uint32_t const | DeviceID,
 |  | uint32_t const | maxPerdiodTime,
 |  | uint32_t const | minPeriodTime,
 |  | uint32_t const | maxRLCDiff,
 |  | uint32_t const | maxWrongCmac,
 |  | bool | resetPeriod
 | ) |  |

Adds a Device to watch.

Adds an unique device to the watcher. For periodic device a min and max Period Time should be defined. For all secure device the maximal amount of telegrams with wrong CMAC can be definied. The user can also define the maximal difference between the last and current RLC

If the device is not secure it will be added but no security features will be probably supported. If the device already exist nothing happens. If the device does not exist in the Device manager it will not be added.

Parameters:
DeviceID | the id of the device to watch
maxPerdiodTime | max Time(in ms) between 2 telegrams,=0 no max time
minPeriodTime | min Time(in ms) between 2 telegrams;=0 no min time
maxRLCDiff | max rlc difference allowed (64 is the enocen link one!)
maxWrongCmac | maximal number of telegrams with wrong cmac
resetPeriod | If true, after a Telegram has been received the period will be reset. If false the period is always extended for a valid Telegram.
Returns:
WATCH_NOT_SECURE_DEVICE or WATCH_OK or WATCH_DEVICE_ALREADY_EXIST or WATCH_DEVICE_NA
Examples:
WatcherMain.cpp.
bool eoWatcher::CheckDeadDevices ( std::vector< uint32_t > & deadDevicesVector )

Check for dead Devices.

This functions goes through the added Device List which are configured to send periodically messages. If a device did not send a telegram for longer then maxPeriodTime the devices gets added into the deadDeviceVector-

Parameters:
deadDevicesVector A vector containing the dead devices. The vector gets cleared before adding devices!
Returns:
a vector containing the ids of devices which stopped sending
Examples:
WatcherMain.cpp.
uint32_t eoWatcher::CheckSecurity | ( | eoDevice const *const | device,
 |  | eoTelegram const & | tel
 | ) |  |
virtual

checks the Security of a Device after Receiving a telegram.

This function has to be called always after receiving a telegram!

Parameters:
device | pointer to Device to Check
tel | last received telegram
Returns:

Reimplemented from eoIWatcher.

uint32_t eoWatcher::GetDenialTickBetween ( ) const
inline

Sets the time between two telegram when they are not assumed as DDOS attack telegrams

Returns:
denialTickBetween
uint32_t eoWatcher::GetDenialWarnCount ( ) const
inline

Gets the number of telegram which have to arrive faster then the denialtickbetween to generate a Assumed DOS Warning.

Returns:
denial warn count
void eoWatcher::RemoveDevice ( uint32_t const DeviceID )

Remove a device.

Removes a device from the watch list. If the device does not exist nothing happens.

Parameters:
DeviceID
EO_SEC_WATCH_RESULT eoWatcher::Reset ( uint32_t const DeviceID )

Reset security parameters.

Resets security check parameter (RLC count and CMAC wrong try count)

Parameters:
DeviceID device id
Returns:
WATCH_OK or WATCH_DEVICE_NA
uint8_t eoWatcher::Serialize ( eoArchive & arch )
virtual

Serialization Function which will be called by the eoStorageManager This function will be called by the eoArchive(inside of the eoStorageManager) and allows the class to be Serialized.

Parameters:
&arch Archive where to Load or to Store.

Reimplemented from eoIWatcher.

void eoWatcher::SetDenialTickBetween ( uint32_t const tickCount )
inline

Sets the time between two telegram when they are not assumed as DDOS attack telegrams

Parameters:
tickCount
void eoWatcher::SetDenialWarnCount ( uint32_t const warnCount )
inline

Sets the number of telegram which have to arrive faster then the denialtickbetween to generate a Assumed DOS Warning.

Parameters:
warnCount
EO_SEC_WATCH_RESULT eoWatcher::UpdateDevice | ( | uint32_t const | DeviceID,
 |  | uint32_t const | maxPerdiodTime,
 |  | uint32_t const | minPeriodTime,
 |  | uint32_t const | maxRLCDiff,
 |  | uint32_t const | maxWrongCmac,
 |  | bool | resetPeriod
 | ) |  |

Update device Information.

This functions updates the security Information of one Device. If the device does not exist, no new Device will be added.

Parameters:
DeviceID | the id of the device to update
maxPerdiodTime | max Time(in ms) between 2 telegrams,=0 no max time
minPeriodTime | min Time(in ms) between 2 telegrams;=0 no min time
maxRLCDiff | max rlc difference allowed (64 is the enocen link one!)
maxWrongCmac | maximal number of telegrams with wrong cmac
resetPeriod | If true, after a Telegram has been received the period will be reset. If false the period is always extended for a valid Telegram.
Returns:
WATCH_OK or WATCH_DEVICE_NA
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoWatcherFactory Class Reference

Static Public Member Functions
eoWatcherFactory Class Reference

helper class for deserialization More...

#include <eoWatcherFactory.h>

List of all members.

Static Public Member Functions

static eoIWatcher * CreateWatcher (uint8_t type)

Detailed Description

helper class for deserialization

Member Function Documentation

static eoIWatcher* eoWatcherFactory::CreateWatcher ( uint8_t type )
static

Constructor for new filters.

Parameters:
type Type of the filter according SUPPORTED_FILTERS.
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: eoWin32PacketStream Class Reference

Public Member Functions
eoWin32PacketStream Class Reference

PacketStream Implementation for Windows based Systems. More...

#include <eoWin32PacketStream.h>

Inheritance diagram for eoWin32PacketStream:
[legend]
Collaboration diagram for eoWin32PacketStream:
[legend]

List of all members.

Public Member Functions

eoReturn | Open (const char *port)
void | Close ()
DWORD | GetLastError ()
eoReturn | ReceiveByte (uint8_t *u8RxByte)
eoReturn | SendByte (uint8_t u8TxByte)
- Public Member Functions inherited from eoPacketStream
eoPacketStream ()
virtual eoReturn | Receive (eoPacket *p)
virtual eoReturn | Send (const eoPacket &p)
virtual bool | IsPacketPending ()

Detailed Description

PacketStream Implementation for Windows based Systems.

eoWin32PacketStream uses a \\COMxx Interface for a direct communication to an EnOcean device via UART [ESP3].

Member Function Documentation

void eoWin32PacketStream::Close ( )
virtual

Close the Port

Implements eoPacketStream.

DWORD eoWin32PacketStream::GetLastError ( )
inline

Returns the last error from the windows api

eoReturn eoWin32PacketStream::Open ( const char * port )
virtual

Tries to Open and initialize the specific port for the eoLinuxPacketstream

Parameters:
port to open; for example "\\\.\\COM0"
Returns:
eoReturn OK if everything was ok else eoReturn PORT_ERROR

Implements eoPacketStream.

eoReturn eoWin32PacketStream::ReceiveByte ( uint8_t * d )
virtual
Parameters:
d Pointer where to write the Byte
Returns:
Returns a eoReturn

Implements eoPacketStream.

eoReturn eoWin32PacketStream::SendByte ( uint8_t d )
virtual
Parameters:
d The byte to send
Returns:
Returns a eoReturn

Implements eoPacketStream.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: GP_LINK_TABLE Struct Reference

GP_LINK_TABLE Struct Reference

Query gp teach in link table structure. More...

#include <eoReCom.h>

Detailed Description

Query gp teach in link table structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: LINK_TABLE Struct Reference

Public Attributes
LINK_TABLE Struct Reference

Entry for get/set link table. More...

#include <eoReCom.h>

List of all members.

Public Attributes

uint8_t | index
Index.
uint32_t | ID
ID.
uint8_t | EEP_RORG
EEP RORG.
uint8_t | EEP_FUNC
EEP FUNC.
uint8_t | EEP_TYPE
EEP TYPE.
uint8_t | channel
Channel.

Detailed Description

Entry for get/set link table.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: QUERY_APPLY_CHANGES Struct Reference

Public Attributes
QUERY_APPLY_CHANGES Struct Reference

Apply changes struct. More...

#include <eoReCom.h>

List of all members.

Public Attributes

RECOM_CHANGES linkTableChanges
Link table changes.
RECOM_CHANGES configChanges
Configuration changes.

Detailed Description

Apply changes struct.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: QUERY_DEVICE_CONFIG Struct Reference

Public Attributes
QUERY_DEVICE_CONFIG Struct Reference

Query device configuration. More...

#include <eoReCom.h>

List of all members.

Public Attributes

uint16_t | startIndex
Starting index.
uint16_t | endIndex
Ending index.
uint8_t | length
Length.

Detailed Description

Query device configuration.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: QUERY_LINK_BASED_CONFIG Struct Reference

Public Attributes
QUERY_LINK_BASED_CONFIG Struct Reference

Query link based configuration. More...

#include <eoReCom.h>

List of all members.

Public Attributes

RECOM_TABLE_DIR tableDir
Table direction.
uint16_t | tableIndex
Link table index.
uint16_t | startIndex
Start index.
uint16_t | endIndex
End index.
uint8_t | length
Length.

Detailed Description

Query link based configuration.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: QUERY_LINK_TABLE Struct Reference

Public Attributes
QUERY_LINK_TABLE Struct Reference

Query link table structure. More...

#include <eoReCom.h>

List of all members.

Public Attributes

RECOM_TABLE_DIR tableDir
Table direction.
uint8_t | startIndex
Starting index.
uint8_t | endIndex
Ending index.

Detailed Description

Query link table structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: QUERY_METADATA_RESPONSE Struct Reference

Public Attributes
QUERY_METADATA_RESPONSE Struct Reference

Query metadata response structure. More...

#include <eoReCom.h>

List of all members.

Public Attributes

RECOM_SUPPORT remoteTeachOutbound
Remote teach outbound supported.
RECOM_SUPPORT remoteTeachInbound
Remote teach inbound supported.
RECOM_SUPPORT outboundLinkTable
Outbound link table supported.
RECOM_SUPPORT inboundLinkTable
Inbound link table supported.
uint8_t | lengthOfOutbound
Current length of outbound table.
uint8_t | maxOfOutbound
Max length of outbound table.
uint8_t | lenghtOfInbound
Current length of inbound table.
uint8_t | maxOfInbound
Max length of inbound table.

Detailed Description

Query metadata response structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: QUERY_PRODUCT_ID_RESPONSE Struct Reference

Public Attributes
QUERY_PRODUCT_ID_RESPONSE Struct Reference

Get product ID response. More...

#include <eoReCom.h>

List of all members.

Public Attributes

uint16_t | manufacturerId
Manufacturer ID.
uint32_t | productReference
Product reference.

Detailed Description

Get product ID response.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: QUERY_RADIO_LINK_TEST Struct Reference

Public Attributes
QUERY_RADIO_LINK_TEST Struct Reference

Radio link test control. More...

#include <eoReCom.h>

List of all members.

Public Attributes

bool | isEnabled
Enable/disable.
uint8_t | numOfRLT
Number of RLT slave.

Detailed Description

Radio link test control.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: QUERY_REPEATER_RESPONSE Struct Reference

QUERY_REPEATER_RESPONSE Struct Reference

Get repeater response. More...

#include <eoReCom.h>

Detailed Description

Get repeater response.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: QUERY_RESET_DEFAULTS Struct Reference

Public Attributes
QUERY_RESET_DEFAULTS Struct Reference

Query reset structure. More...

#include <eoReCom.h>

List of all members.

Public Attributes

RECOM_RESET configParam
Configuration parameters.
RECOM_RESET inboundTable
Inbound link table.
RECOM_RESET outboundTable
Outbound link table.

Detailed Description

Query reset structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: QUERY_SET_LEARN_MODE Struct Reference

Public Attributes
QUERY_SET_LEARN_MODE Struct Reference

Set learn mode structure. More...

#include <eoReCom.h>

List of all members.

Public Attributes

RECOM_LEARN_MODE mode
Learn mode.
uint8_t inboundIndex
Inbound index.

Detailed Description

Set learn mode structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: QUERY_SET_REPEATER_FILTER Struct Reference

Public Attributes
QUERY_SET_REPEATER_FILTER Struct Reference

Set repeater filter. More...

#include <eoReCom.h>

List of all members.

Public Attributes

RECOM_REPEATER_FILTER_CONTROL repeaterFunc
Filter control.
RECOM_REPEATER_FILTER_TYPE repeaterLevel
Filter type.
uint32_t value
Filter value.

Detailed Description

Set repeater filter.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: SA_CONFIRM_LEARN_REQUEST Struct Reference

Public Attributes
SA_CONFIRM_LEARN_REQUEST Struct Reference

Confirm Learn response. More...

#include <eoSerialCommand.h>

List of all members.

Public Attributes

uint8_t | priPostmaster
Already post master 0b xxxx 1xxx/Place for mailbox 0b xxxx x1xx/Good RSSI 0b xxxx xx1x/Local 0b xxxx xxx1.
uint32_t | manufacturerID
Manufacturer ID.
uint8_t | eep [3]
Code of used EEP profile.
uint8_t | rssi
Signal strength; Send case: FF/Receive case: actual RSSI.
uint32_t | postmasterID
Device ID of the Post master candidate.
uint32_t | smartAckID
This sensor would be Learn IN.
uint8_t | hopCount
Numbers of repeater hop.

Detailed Description

Confirm Learn response.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: WATCH_STRUCT Struct Reference

Public Attributes
WATCH_STRUCT Struct Reference

Watch structure. More...

#include <eoWatcher.h>

List of all members.

Public Attributes

uint32_t | maxRLCDiff
Warns if the RLC is to different!
uint32_t | minPeriodTime
min Time before a Telegram is expected
uint32_t | maxPeriodTime
max Time where a telegram is expected
uint32_t | timeLastTelegram
tick count of the last handled Telegram
uint32_t | wrongCMACUsages
current wrong cmac
uint32_t | maxWrongCmac
maximal allowed wrong CMAC for the device
bool | resetPeriod
Reset Period after every Received Telegram.

Detailed Description

Watch structure.

Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Index

Class Index
C | D | E | F | G | L | M | P | Q | S | T | W
C
eoEEP_A505xx eoEEP_F603xx eoReManChainer
Q
eoEEP_A506xx eoEEP_F604xx eoReManMessage
CO_RD_DUTYCYCLE_RESPONSE eoEEP_A507xx eoEEP_F605xx eoRemoteManager QUERY_APPLY_CHANGES
CO_RD_FILTER_RESPONSE eoEEP_A508xx eoEEP_F610xx eoRollingCodeStorage QUERY_DEVICE_CONFIG
CO_RD_IDBASE_RESPONSE eoEEP_A509xx eoEEPChannelInfo eoSecTeachInChainer QUERY_FUNCTION_RESPONSE
CO_RD_REPEATER_RESPONSE eoEEP_A510xx eoEEProfile eoSecureInfo QUERY_ID
CO_RD_VERSION_RESPONSE eoEEP_A511xx eoF6EEProfile eoSecurity QUERY_LINK_BASED_CONFIG
CO_READY_RESPONSE eoEEP_A512xx eoFilterFactory eoSerialCommand QUERY_LINK_TABLE
D
eoEEP_A513xx eoGateway eoStorageManager QUERY_METADATA_RESPONSE
eoEEP_A514xx eoGenericProfile eoTeachInModule QUERY_PRODUCT_ID_RESPONSE
DEVICE_CONFIG eoEEP_A520xx eoGpChainer eoTelegram QUERY_RADIO_LINK_TEST
E
eoEEP_A530xx eoGPChannelInfo eoTimer QUERY_REPEATER_RESPONSE
eoEEP_A537xx eoHeader eoWatcher QUERY_RESET_DEFAULTS
EEP_ITEM eoEEP_A538xx eoIDFilter eoWatcherFactory QUERY_SET_LEARN_MODE
eoA5EEProfile eoEEP_D200xx eoIFilter eoWin32PacketStream QUERY_SET_REPEATER_FILTER
eoAbstractMessage eoEEP_D201xx eoISerialize
F
QUERY_STATUS_RESPONSE
eoArchive eoEEP_D202xx eoISimpleBidirectionalProfile
S
eoArchiveTXT eoEEP_D203xx eoIWatcher FLASH_READ_RESPONSE
eoChainedMessage eoEEP_D204xx eoLinuxPacketStream
G
SA_CONFIRM_LEARN_REQUEST
eoChainedReManMessage eoEEP_D205xx eoLogger SA_LEARN_ACK_RESPONSE
eoChannelInfo eoEEP_D206xx eoManufacturer GP_LINK_TABLE SA_RD_LEARNEDCLIENTS_RESPONSE
eoChunkMessage eoEEP_D210xx eoMessage
L
SA_RD_LEARNMODE_RESPONSE
eoConverter eoEEP_D220xx eoMessageHandler serialize_object
eoD2EEProfile eoEEP_D230xx eoMSCHelper LEARNED_SENSOR_RESPONSE
T
eodBmFilter eoEEP_D231xx eoPacket LINK_TABLE
eoDebug eoEEP_D232xx eoPacketStream
M
TEACH_STRUCT
eoDevice eoEEP_D240xx eoProc
W
eoDeviceManager eoEEP_D2A0xx eoProfile MAILBOX_SETTINGS_RESPONSE
eoEEP_A502xx eoEEP_D500xx eoProfileFactory
P
WATCH_STRUCT
eoEEP_A504xx eoEEP_F602xx eoReCom
PING_RESPONSE
C | D | E | F | G | L | M | P | Q | S | T | W
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 12345]
o C CO_RD_DUTYCYCLE_RESPONSE | Read actual duty cycle limit structure
o C CO_RD_FILTER_RESPONSE | Read filter response
o C CO_RD_IDBASE_RESPONSE | Read base ID response
o C CO_RD_REPEATER_RESPONSE | Read repeater response
o C CO_RD_VERSION_RESPONSE | Read version response
o C CO_READY_RESPONSE | Ready response
o C DEVICE_CONFIG | Dvice configuration response
o C EEP_ITEM |
o C eoAbstractMessage | Base class for all Messages
| o C eoChunkMessage | Representing part of an message
| o C eoMessage | Message Class for communication
| | o C eoChainedMessage |
| | | \ C eoChainedReManMessage |
| | \ C eoTelegram | Every Communication from an EnOcean Device to another one consist out of one more Telegrams. The eoTelegram class contains the payload Data from one Telegram
| \ C eoReManMessage |
o C eoArchive | Base Archive
| \ C eoArchiveTXT | Archive for Human readable Text files
o C eoChannelInfo | Abstract class for channel information. Abstract class for channel information. From this class specific channel informations classes for Generic Profiles or EEP are derived
| o C eoEEPChannelInfo | Specific class for EEP channel information. Class used to decribe the EEP channels. It has the EEP_ITEM to describe the EEP channel values and the subtype - index
| \ C eoGPChannelInfo | Generic Profile Channel
o C eoConverter | Static Helper Functions
o C eoDebug | Helper class for Debug Messages
o C eoFilterFactory | Helper class for deserialization
o C eoGpChainer |
o C eoISerialize | Interface for storing
| o C eoDevice | Class to describe an EnOcean Device
| o C eoDeviceManager | Manages the devices
| o C eoGateway | EnOcean Gateway class, for handling a gateway Module
| o C eoGPChannelInfo | Generic Profile Channel
| o C eoHeader | Helper Class for the Serializations, sets the Archive Header
| o C eoIFilter | Filter Interface
| | o C eodBmFilter | Uses Telegram dBm values as filter base
| | \ C eoIDFilter | Uses EnOcean IDs as filter base
| o C eoIWatcher | The minimal Interface for an eoWatcher class
| | \ C eoWatcher | Example implementation of an Security Watcher Class which tries to predict DOS and Delay Attacks
| o C eoProfile | Base class for Profile parsing
| | o C eoEEProfile | Base class for EEProfile parsing
| | | o C eoA5EEProfile | EnOcean Equipment Profiles
| | | | o C eoEEP_A502xx | The class to handle EEP a502 profiles
| | | | o C eoEEP_A504xx | The class to handle EEP a504 profiles
| | | | o C eoEEP_A505xx | The class to handle EEP a505 profiles
| | | | o C eoEEP_A506xx | The class to handle EEP a506 profiles
| | | | o C eoEEP_A507xx | The class to handle EEP a507 profiles
| | | | o C eoEEP_A508xx | The class to handle EEP a508 profiles
| | | | o C eoEEP_A509xx | The class to handle EEP a509 profiles
| | | | o C eoEEP_A510xx | The class to handle EEP a510 profiles
| | | | o C eoEEP_A511xx | The class to handle EEP a511 profiles
| | | | o C eoEEP_A512xx | The class to handle EEP a512 Automated meter reading (AMR) profiles
| | | | o C eoEEP_A513xx | The class to handle EEP a513 profiles
| | | | o C eoEEP_A514xx | The class to handle EEP a514 profiles
| | | | o C eoEEP_A520xx | The class to handle EEP a520 profiles
| | | | o C eoEEP_A530xx | The class to handle EEP a530 profiles
| | | | o C eoEEP_A537xx | The class to handle EEP a537 profiles
| | | | o C eoEEP_A538xx | The class to handle EEP a538 profiles
| | | | \ C eoEEP_D500xx | The class to handle EEP d500 profiles
| | | o C eoD2EEProfile | EnOcean Equipment Profiles
| | | | o C eoEEP_D200xx | The class to handle EEP D200 profiles
| | | | o C eoEEP_D201xx | The class to handle EEP D201 profiles
| | | | o C eoEEP_D202xx | The class to handle EEP D202 profiles
| | | | o C eoEEP_D203xx | The class to handle EEP D203 Secure Light and Blind Control
| | | | o C eoEEP_D204xx | The class to handle EEP D204 Secure Light and Blind Control
| | | | o C eoEEP_D205xx | The class to handle EEP D205 profiles
| | | | o C eoEEP_D206xx | The class to handle EEP D206 profiles
| | | | o C eoEEP_D210xx | The class to handle EEP D210 profiles
| | | | o C eoEEP_D220xx | The class to handle EEP D220 profiles
| | | | o C eoEEP_D230xx | The class to handle EEP D230 profiles
| | | | o C eoEEP_D231xx | The class to handle EEP D231 profiles
| | | | o C eoEEP_D232xx | The class to handle EEP D232 Automated meter reading (AMR) profiles
| | | | o C eoEEP_D240xx | The class to handle EEP D240 profiles
| | | | \ C eoEEP_D2A0xx | The class to handle EEP D2A0 profiles
| | | \ C eoF6EEProfile | EnOcean Equipment Profiles class for RORG F6
| | | o C eoEEP_F602xx | The class to handle EEP f602 Rocker Switch, 2 Rocker profiles
| | | o C eoEEP_F603xx | The class to handle EEP f603 profiles
| | | o C eoEEP_F604xx | The class to handle EEP f604 profiles
| | | o C eoEEP_F605xx | The class to handle EEP f605 profiles
| | | \ C eoEEP_F610xx | The class to handle EEP f610 profiles
| | \ C eoGenericProfile | The class to handle Generic Profiles
| o C eoSecureInfo |
| \ C eoTeachInModule | Handles TeachIn Messages
o C eoISimpleBidirectionalProfile | An interface for profiles which support bidirectional communication, but do not indicate the direction of the messages
| o C eoEEP_A520xx | The class to handle EEP a520 profiles
| \ C eoEEP_D2A0xx | The class to handle EEP D2A0 profiles
o C eoLogger | Logs Packets
o C eoManufacturer | Manufacturer List
o C eoMessageHandler |
o C eoMSCHelper | Static Helper Functions
o C eoPacket | Class which contains a Packet
o C eoPacketStream | The base class for all PacketStreams Implementations
| o C eoLinuxPacketStream | PacketStream Implementation for Linux based Systems
| \ C eoWin32PacketStream | PacketStream Implementation for Windows based Systems
o C eoProc | Helper to calculate different crc
o C eoProfileFactory | Creates Profiles
o C eoReCom | Remote Commissioning interface class
o C eoReManChainer |
o C eoRemoteManager | Remote Manager interface class
o C eoRollingCodeStorage | Manages the rolling codes
o C eoSecTeachInChainer |
o C eoSecurity | Handles EnOcean Security Telegrams
o C eoSerialCommand | EnOcean Common Commands class, enables an easy interface for the most common commands
o C eoStorageManager | Handles the Storage of Object
o C eoTimer | TickCount helper
o C eoWatcherFactory | Helper class for deserialization
o C FLASH_READ_RESPONSE | Flash read response structure
o C GP_LINK_TABLE | Query gp teach in link table structure
o C LEARNED_SENSOR_RESPONSE | Learned sensors response structure
o C LINK_TABLE | Entry for get/set link table
o C MAILBOX_SETTINGS_RESPONSE | Mailbox settings response structure
o C PING_RESPONSE | Ping response structure
o C QUERY_APPLY_CHANGES | Apply changes struct
o C QUERY_DEVICE_CONFIG | Query device configuration
o C QUERY_FUNCTION_RESPONSE | Query function response structure
o C QUERY_ID | Query ID structure
o C QUERY_LINK_BASED_CONFIG | Query link based configuration
o C QUERY_LINK_TABLE | Query link table structure
o C QUERY_METADATA_RESPONSE | Query metadata response structure
o C QUERY_PRODUCT_ID_RESPONSE | Get product ID response
o C QUERY_RADIO_LINK_TEST | Radio link test control
o C QUERY_REPEATER_RESPONSE | Get repeater response
o C QUERY_RESET_DEFAULTS | Query reset structure
o C QUERY_SET_LEARN_MODE | Set learn mode structure
o C QUERY_SET_REPEATER_FILTER | Set repeater filter
o C QUERY_STATUS_RESPONSE | Query status response structure
o C SA_CONFIRM_LEARN_REQUEST | Confirm Learn response
o C SA_LEARN_ACK_RESPONSE | Learn SmartAck response
o C SA_RD_LEARNEDCLIENTS_RESPONSE | SmartAck learned clients response structure
o C SA_RD_LEARNMODE_RESPONSE | SmartAck read learnmode response structure
o C serialize_object | Serialised obejct type definition to save learned devices
o C TEACH_STRUCT | Teach message structure
\ C WATCH_STRUCT | Watch structure
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • Action() : eoRemoteManager
  • Add() : eoDeviceManager , eoIDFilter
  • AddChannel() : eoGenericProfile
  • AddChannelOut() : eoGenericProfile
  • AddDevice() : eoWatcher
  • AddFilter() : eoSerialCommand
  • addObject() : eoStorageManager
  • advancedMode : eoGateway
  • advancedPacketToRadio() : eoConverter
  • AllowTeachIN() : eoGenericProfile
  • apiVersion : CO_RD_VERSION_RESPONSE
  • appDescription : CO_RD_VERSION_RESPONSE
  • ApplyChanges() : eoReCom
  • appVersion : CO_RD_VERSION_RESPONSE
  • availableCycle : CO_RD_DUTYCYCLE_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • baseID : CO_RD_IDBASE_RESPONSE
  • BIST() : eoSerialCommand
  • bitoffs : eoGPChannelInfo , EEP_ITEM
  • bitsize : EEP_ITEM
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • celsiusToFahrenheit() : eoConverter
  • channel : eoEEProfile , LINK_TABLE
  • channelCount : eoEEProfile
  • CheckDeadDevices() : eoWatcher
  • CheckSecurity() : eoIWatcher , eoWatcher
  • chipID : CO_RD_VERSION_RESPONSE
  • chipVersion : CO_RD_VERSION_RESPONSE
  • CleanUpChainerLists() : eoMessageHandler
  • CleanUpList() : eoGpChainer , eoReManChainer , eoSecTeachInChainer
  • Clear() : eoMessage , eoTelegram
  • ClearChannels() : eoGenericProfile
  • ClearChannelsOut() : eoGenericProfile
  • ClearValues() : eoGenericProfile , eoProfile , eoEEP_A520xx , eoEEP_D203xx , eoEEP_D2A0xx , eoEEP_F602xx , eoEEP_F603xx
  • clientID : SA_RD_LEARNEDCLIENTS_RESPONSE
  • Close() : eoWin32PacketStream , eoArchive , eoArchiveTXT , eoGateway , eoLinuxPacketStream , eoLogger , eoPacketStream
  • codeSetFlag : QUERY_STATUS_RESPONSE
  • commands : eoGateway
  • ComposeChainedMessage() : eoMessageHandler
  • configChanges : QUERY_APPLY_CHANGES
  • configParam : QUERY_RESET_DEFAULTS
  • confirmCode : SA_LEARN_ACK_RESPONSE
  • controllerID : LEARNED_SENSOR_RESPONSE
  • CopyDataFrom() : eoChunkMessage
  • CopyFrom() : eoChunkMessage
  • copyTo() : eoMessage , eoPacket , eoReManMessage , eoChainedReManMessage
  • crc16() : eoProc
  • crc8() : eoProc
  • Create() : eoGenericProfile , eoF6EEProfile , eoGenericProfile , eoEEP_A520xx , eoProfile , eoA5EEProfile , eoEEP_D2A0xx
  • CreateFilter() : eoFilterFactory
  • CreateGPResponse() : eoTeachInModule
  • CreateProfile() : eoProfileFactory
  • CreateTeachIN() : eoProfile , eoD2EEProfile , eoA5EEProfile , eoGenericProfile
  • CreateTeachIn() : eoSecurity
  • CreateUTEResponse() : eoTeachInModule
  • CreateWatcher() : eoWatcherFactory
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • data : eoAbstractMessage , eoPacket , FLASH_READ_RESPONSE
  • dataChunks : eoChainedMessage
  • dataDirection : eoGenericProfile
  • dataLength : eoAbstractMessage , eoPacket
  • dBm : eoDevice , eoTelegram
  • Decrypt() : eoSecurity
  • DeleteAllFilter() : eoSerialCommand
  • DeleteFilter() : eoSerialCommand
  • destinationID : eoReManMessage , eoMessage
  • device : eoGateway
  • deviceManager : eoGateway
  • DutyCycleLimit() : eoSerialCommand
  • DutyCycleReadLimit() : eoSerialCommand
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • eep : SA_CONFIRM_LEARN_REQUEST
  • EEP_FUNC : LINK_TABLE
  • EEP_RORG : LINK_TABLE
  • EEP_TYPE : LINK_TABLE
  • eepItem : eoEEPChannelInfo
  • enabled : SA_RD_LEARNMODE_RESPONSE
  • EnableFilter() : eoSerialCommand
  • Encrypt() : eoSecurity
  • endBlock() : eoArchive , eoArchiveTXT
  • endIndex : QUERY_LINK_TABLE , QUERY_DEVICE_CONFIG , QUERY_LINK_BASED_CONFIG
  • eoA5EEProfile() : eoA5EEProfile
  • eoAbstractMessage() : eoAbstractMessage
  • eoChainedMessage() : eoChainedMessage
  • eoChainedReManMessage() : eoChainedReManMessage
  • eoChunkMessage() : eoChunkMessage
  • eoD2EEProfile() : eoD2EEProfile
  • eodBmFilter() : eodBmFilter
  • eoDevice() : eoDevice
  • eoDeviceManager() : eoDeviceManager
  • eoEEP_D200xx() : eoEEP_D200xx
  • eoEEP_D201xx() : eoEEP_D201xx
  • eoEEP_D202xx() : eoEEP_D202xx
  • eoEEP_D204xx() : eoEEP_D204xx
  • eoEEP_D205xx() : eoEEP_D205xx
  • eoEEP_D206xx() : eoEEP_D206xx
  • eoEEP_D210xx() : eoEEP_D210xx
  • eoEEP_D220xx() : eoEEP_D220xx
  • eoEEP_D230xx() : eoEEP_D230xx
  • eoEEP_D231xx() : eoEEP_D231xx
  • eoEEP_D240xx() : eoEEP_D240xx
  • eoEEP_D2A0xx() : eoEEP_D2A0xx
  • eoEEProfile() : eoEEProfile
  • eoGateway() : eoGateway
  • eoGenericProfile() : eoGenericProfile
  • eoGPChannelInfo() : eoGPChannelInfo
  • eoHeader() : eoHeader
  • eoLogger() : eoLogger
  • eoMessage() : eoMessage
  • eoPacket() : eoPacket
  • eoPacketStream() : eoPacketStream
  • eoProfile() : eoProfile
  • eoReCom() : eoReCom
  • eoReManMessage() : eoReManMessage
  • eoRemoteManager() : eoRemoteManager
  • eoRollingCodeStorage() : eoRollingCodeStorage
  • eoSerialCommand() : eoSerialCommand
  • eoStorageManager() : eoStorageManager
  • eoTeachInModule() : eoTeachInModule
  • eoTelegram() : eoTelegram
  • eoWatcher() : eoWatcher
  • errorCode : eoGateway
  • EventDutyCycleLimit() : eoSerialCommand
  • EventSmartAckConfirmLearn() : eoSerialCommand
  • ExchangeInt() : eoArchiveTXT
  • exist : EEP_ITEM
  • expectedDataLength : eoChainedMessage
  • expectedTelCount : eoChainedMessage
  • extended : SA_RD_LEARNMODE_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • fahrenheitToCelsius() : eoConverter
  • Filter() : eodBmFilter , eoIDFilter
  • filter : eoGateway
  • Filter() : eoIDFilter , eodBmFilter , eoIFilter
  • filterType : CO_RD_FILTER_RESPONSE
  • filterValue : CO_RD_FILTER_RESPONSE
  • flashAddress : MAILBOX_SETTINGS_RESPONSE
  • Flush() : eoLogger
  • fnCode : eoChainedReManMessage , eoReManMessage
  • func : PING_RESPONSE , eoProfile , QUERY_ID
  • functionNum : QUERY_FUNCTION_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • Get() : eoDeviceManager
  • getBufferSize() : eoPacket
  • GetChannel() : eoEEProfile , eoGenericProfile , eoEEP_A512xx , eoEEP_D240xx , eoEEP_F602xx , eoEEP_A513xx , eoEEP_F603xx , eoEEP_F604xx , eoProfile , eoEEP_A520xx , eoEEP_F605xx , eoEEP_F610xx , eoEEP_A530xx , eoEEProfile , eoProfile , eoEEP_A537xx , eoEEP_A538xx , eoProfile , eoEEP_D200xx , eoEEP_D201xx , eoEEProfile , eoGenericProfile , eoEEP_A506xx , eoEEP_D202xx , eoEEP_D205xx , eoEEP_A509xx , eoEEP_D206xx , eoEEP_D210xx , eoGenericProfile , eoEEP_A511xx , eoEEP_D220xx , eoEEP_D230xx , eoEEP_A512xx , eoEEP_D231xx , eoEEP_D232xx
  • GetChannelCount() : eoEEProfile , eoGenericProfile , eoProfile
  • GetChannelCountOut() : eoGenericProfile
  • GetChannelOut() : eoGenericProfile
  • GetDataLength() : eoAbstractMessage
  • GetDenialTickBetween() : eoWatcher
  • GetDenialWarnCount() : eoWatcher
  • GetDeviceConfig() : eoReCom
  • GetDeviceList() : eoDeviceManager
  • GetEngMax() : eoGPChannelInfo
  • GetEngMin() : eoGPChannelInfo
  • GetGPChannelType() : eoGPChannelInfo
  • GetGPLinkTable() : eoReCom
  • GetLastError() : eoSecurity , eoWin32PacketStream
  • GetLinkBasedConfig() : eoReCom
  • GetLinkTable() : eoReCom
  • GetMaxLength() : eoAbstractMessage
  • GetMetadata() : eoReCom
  • GetMSCmanufacturer() : eoMSCHelper
  • GetMSCpayload() : eoMSCHelper
  • GetName() : eoManufacturer
  • GetOutChannel() : eoISimpleBidirectionalProfile , eoEEP_A520xx , eoEEP_D2A0xx , eoISimpleBidirectionalProfile
  • GetProductId() : eoGenericProfile
  • GetProductID() : eoReCom
  • GetProfile() : eoDevice
  • GetRawValue() : eoProfile
  • GetRejected() : eoGPChannelInfo
  • GetRepeater() : eoReCom
  • GetResolution() : eoGPChannelInfo
  • GetRLC() : eoRollingCodeStorage
  • GetScaleMax() : eoGPChannelInfo
  • GetScaleMin() : eoGPChannelInfo
  • GetSecWatchResult() : eoGateway
  • GetSerialPacket() : eoSerialCommand
  • GetSubTypeChannel() : eoEEProfile , eoProfile
  • GetTickCount() : eoTimer
  • GetValue() : eoEEP_A507xx , eoEEP_A506xx , eoEEP_A505xx , eoEEP_A504xx , eoD2EEProfile , eoA5EEProfile , eoProfile , eoGenericProfile , eoEEP_D203xx , eoEEP_D231xx , eoEEP_D201xx , eoEEP_D231xx , eoEEP_D230xx , eoEEP_D232xx , eoEEP_A512xx , eoEEP_D232xx , eoEEP_D240xx , eoEEP_A513xx , eoEEP_D240xx , eoEEP_A520xx , eoEEP_F602xx , eoEEP_D500xx , eoEEP_F603xx , eoEEP_D204xx , eoEEP_F605xx , eoEEP_F604xx , eoEEP_F610xx , eoEEP_A537xx , eoEEP_D206xx , eoEEP_D205xx , eoEEP_D206xx , eoEEP_A538xx , eoEEP_D206xx , eoEEP_D210xx , eoEEP_D200xx , eoEEP_D210xx , eoEEP_D220xx , eoEEP_D205xx , eoEEP_D220xx , eoEEP_D230xx , eoEEP_D202xx , eoEEP_D231xx , eoEEP_D230xx , eoEEP_D231xx , eoEEP_D204xx , eoEEP_A510xx , eoEEP_D202xx , eoEEP_A511xx , eoEEP_A512xx , eoEEP_A513xx , eoEEP_D230xx , eoEEP_A520xx , eoEEP_D201xx , eoEEP_D2A0xx , eoEEP_A530xx , eoEEP_A537xx , eoEEP_A538xx , eoEEP_D205xx , eoEEP_D200xx , eoEEP_D201xx , eoEEP_D210xx , eoEEP_D202xx , eoEEP_A509xx , eoEEP_A510xx , eoEEP_A511xx , eoEEP_A512xx , eoEEP_A514xx , eoEEP_A520xx , eoEEP_A530xx , eoEEP_A537xx , eoEEP_A538xx , eoEEP_D200xx , eoEEP_D201xx , eoEEP_A509xx , eoEEP_A511xx , eoEEP_A513xx , eoEEP_A530xx , eoEEP_A538xx , eoEEP_A509xx , eoEEP_A511xx , eoEEP_A513xx , eoEEP_A508xx
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • h : eoArchive
  • hasBeenLoaded : serialize_object
  • Hash() : eoConverter
  • hopCount : SA_CONFIRM_LEARN_REQUEST
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • ID : eoDevice , LINK_TABLE
  • identifier : eoArchive
  • inboundIndex : QUERY_SET_LEARN_MODE
  • inboundLinkTable : QUERY_METADATA_RESPONSE
  • inboundTable : QUERY_RESET_DEFAULTS
  • indent() : eoArchiveTXT , eoArchive
  • index : EEP_ITEM , LINK_TABLE , DEVICE_CONFIG
  • Is4BSData() : eoA5EEProfile
  • isEnabled : QUERY_RADIO_LINK_TEST
  • isName : eoArchive
  • IsPacketPending() : eoPacketStream
  • IsReceived() : eoChunkMessage
  • IsSecDData() : eoProfile , eoA5EEProfile
  • isStoring : eoArchive
  • isTeachedIN() : eoTeachInModule
  • isTeachIN() : eoTeachInModule
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • key : eoSecureInfo
  • keySize : eoSecureInfo
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • lastFunc : QUERY_STATUS_RESPONSE
  • lastFuncRet : QUERY_STATUS_RESPONSE
  • lastSEQ : QUERY_STATUS_RESPONSE
  • learnedCount : LEARNED_SENSOR_RESPONSE
  • learnFilter : eoGateway
  • LearnMode : eoGateway
  • LearnModeOff() : eoGateway
  • LearnModeOn() : eoGateway
  • lenghtOfInbound : QUERY_METADATA_RESPONSE
  • length : QUERY_DEVICE_CONFIG , DEVICE_CONFIG , QUERY_LINK_BASED_CONFIG
  • lengthOfOutbound : QUERY_METADATA_RESPONSE
  • level : eoArchive
  • linkTableChanges : QUERY_APPLY_CHANGES
  • list : eoSecTeachInChainer
  • literToMeter3() : eoConverter
  • Load() : eoRollingCodeStorage , eoStorageManager
  • loadAfterCycle : CO_RD_DUTYCYCLE_RESPONSE
  • Lock() : eoRemoteManager
  • Log() : eoLogger
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • mailboxCount : MAILBOX_SETTINGS_RESPONSE
  • mailboxIndex : SA_RD_LEARNEDCLIENTS_RESPONSE
  • major : eoHeader
  • manufacturer : eoProfile
  • manufacturerID : SA_CONFIRM_LEARN_REQUEST
  • manufacturerId : QUERY_PRODUCT_ID_RESPONSE
  • manufacturerID : eoChainedReManMessage , eoReManMessage
  • manufaturerID : QUERY_FUNCTION_RESPONSE
  • maskArray : eoProfile
  • max : eoChannelInfo
  • maxdBm : eodBmFilter
  • maxLength : eoAbstractMessage
  • maxOfInbound : QUERY_METADATA_RESPONSE
  • maxOfOutbound : QUERY_METADATA_RESPONSE
  • maxPeriodTime : WATCH_STRUCT
  • maxRLCDiff : WATCH_STRUCT
  • maxWrongCmac : WATCH_STRUCT
  • message : eoGateway
  • meter3ToLiter() : eoConverter
  • min : eoChannelInfo
  • mindBm : eodBmFilter
  • minor : eoHeader
  • minPeriodTime : WATCH_STRUCT
  • mode : QUERY_SET_LEARN_MODE
  • msg : eoProfile
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • name : eoHeader , serialize_object
  • numOfRLT : QUERY_RADIO_LINK_TEST
  • numOfSlots : CO_RD_DUTYCYCLE_RESPONSE
  • NumToHex() : eoConverter
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • object : serialize_object
  • Open() : eoArchive , eoGateway , eoWin32PacketStream , eoLinuxPacketStream , eoArchiveTXT , eoLogger , eoPacketStream
  • operator!=() : eoGenericProfile , eoProfile
  • operator&() : eoArchiveTXT , eoArchive , eoArchiveTXT , eoArchive , eoArchiveTXT , eoArchive , eoArchiveTXT , eoArchive , eoArchiveTXT
  • operator==() : eoGenericProfile , eoProfile
  • optionalLength : eoPacket
  • outboundLinkTable : QUERY_METADATA_RESPONSE
  • outboundTable : QUERY_RESET_DEFAULTS
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • packet : eoGateway
  • packetToAdvancedRadio() : eoConverter
  • packetToRadio() : eoConverter
  • packetToReman() : eoConverter
  • Parse() : eoEEP_A513xx , eoEEP_D210xx , eoEEP_D220xx , eoEEP_A538xx , eoEEP_D230xx , eoEEP_D231xx , eoGenericProfile , eoEEP_D200xx , eoEEP_D240xx , eoEEP_D2A0xx , eoEEP_D201xx , eoEEP_D500xx , eoF6EEProfile , eoProfile , eoEEP_D202xx , eoEEP_D203xx , eoA5EEProfile , eoEEP_D205xx , eoEEP_D206xx
  • ParseChainedMessage() : eoGpChainer , eoReManChainer , eoSecTeachInChainer
  • ParseDeviceConfigResponse() : eoReCom
  • ParseGetGPLinkTableResponse() : eoReCom
  • ParseGetLinkTableResponse() : eoReCom
  • ParseGetMetadataResponse() : eoReCom
  • ParseGetProductIDResponse() : eoReCom
  • ParseGetRepeaterResponse() : eoReCom
  • ParseLinkBasedConfigResponse() : eoReCom
  • ParsePingAnswer() : eoRemoteManager
  • ParseQueryFunctionAnswer() : eoRemoteManager
  • ParseQueryIDAnswer() : eoRemoteManager
  • ParseQueryStatusAnswer() : eoRemoteManager
  • ParseRemoteFlashReadAnswer() : eoRemoteManager
  • ParseRemoteSmartReadLearnedSensors() : eoRemoteManager
  • ParseRemoteSmartReadMailboxSettingsAnswer() : eoRemoteManager
  • ParseSelData() : eoGenericProfile
  • ParseTeachIN() : eoGenericProfile
  • ParseTeachIn() : eoSecurity
  • ParseUTE() : eoTeachInModule
  • Ping() : eoRemoteManager
  • postmasterID : SA_RD_LEARNEDCLIENTS_RESPONSE , SA_CONFIRM_LEARN_REQUEST
  • previousRollingCode : eoSecureInfo
  • Print() : eoDebug
  • priPostmaster : SA_CONFIRM_LEARN_REQUEST
  • ProcessChunks() : eoChainedMessage
  • ProcessTelegram() : eoMessageHandler
  • productReference : QUERY_PRODUCT_ID_RESPONSE
  • psk : eoSecureInfo
  • purpose : eoGenericProfile
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • QueryFunction() : eoRemoteManager
  • QueryID() : eoRemoteManager
  • QueryStatus() : eoRemoteManager
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • RadioLinkTest() : eoReCom
  • radioToPacket() : eoConverter
  • rangeMax : EEP_ITEM
  • rangeMin : EEP_ITEM
  • rawValue : DEVICE_CONFIG
  • ReadFilter() : eoSerialCommand
  • ReadIDBase() : eoSerialCommand
  • ReadRepeater() : eoSerialCommand
  • ReadVersion() : eoSerialCommand
  • Ready() : eoSerialCommand
  • Receive() : eoGateway , eoPacketStream
  • ReceiveByte() : eoWin32PacketStream , eoLinuxPacketStream , eoPacketStream
  • received : eoChainedMessage
  • remainingWrites : CO_RD_IDBASE_RESPONSE
  • reManMessage : eoGateway
  • remanToPacket() : eoConverter
  • RemoteFlashRead() : eoRemoteManager
  • RemoteFlashWrite() : eoRemoteManager
  • RemoteLearnIn() : eoRemoteManager
  • RemoteSetLearnMode() : eoReCom
  • RemoteSmartAddMailbox() : eoRemoteManager
  • RemoteSmartDeleteMailbox() : eoRemoteManager
  • RemoteSmartLearnIn() : eoRemoteManager
  • RemoteSmartLearnOut() : eoRemoteManager
  • RemoteSmartReadLearnedSensors() : eoRemoteManager
  • RemoteSmartReadMailboxSettings() : eoRemoteManager
  • remoteTeachInbound : QUERY_METADATA_RESPONSE
  • remoteTeachOutbound : QUERY_METADATA_RESPONSE
  • Remove() : eoDeviceManager , eoIDFilter
  • RemoveAll() : eoIDFilter , eoIFilter
  • RemoveDevice() : eoWatcher
  • RemoveID() : eoRollingCodeStorage
  • RemoveObject() : eoStorageManager
  • repeaterFunc : QUERY_SET_REPEATER_FILTER
  • repeaterLevel : QUERY_SET_REPEATER_FILTER
  • repEnable : CO_RD_REPEATER_RESPONSE
  • repLevel : CO_RD_REPEATER_RESPONSE
  • Reset() : eoWatcher , eoSerialCommand
  • resetCause : CO_READY_RESPONSE
  • ResetDefaults() : eoReCom
  • resetPeriod : WATCH_STRUCT
  • responsePacket : eoGateway
  • responseTime : SA_LEARN_ACK_RESPONSE
  • rollingCode : eoSecureInfo
  • rorg : eoProfile , PING_RESPONSE
  • RORG : eoMessage
  • rorg : QUERY_ID
  • rssi : PING_RESPONSE , SA_CONFIRM_LEARN_REQUEST
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • Save() : eoRollingCodeStorage , eoStorageManager
  • Scale() : eoGPChannelInfo
  • ScaleFromRAW() : eoProfile
  • scaleMax : EEP_ITEM
  • scaleMin : EEP_ITEM
  • ScaleToFloat() : eoGPChannelInfo
  • ScaleToRAW() : eoProfile
  • secIn : eoDevice
  • secOut : eoDevice
  • security : eoGateway
  • securityLevel : eoMessage , eoReManMessage
  • securityResult : eoSecureInfo
  • secWatcher : eoGateway
  • Send() : eoGateway , eoPacketStream
  • SendByte() : eoLinuxPacketStream , eoPacketStream , eoWin32PacketStream
  • SendChainedMessage() : eoGpChainer , eoReManChainer , eoSecTeachInChainer
  • sensorID : LEARNED_SENSOR_RESPONSE
  • seq : eoChainedMessage
  • Serialize() : eoGenericProfile , eoGPChannelInfo , eoHeader , eoIDFilter , eoIFilter , eoISerialize , eoIWatcher , eoProfile , eoSecureInfo , eoTeachInModule , eoWatcher , eodBmFilter , eoDevice , eoDeviceManager , eoGateway
  • Set1BS() : eoTeachInModule
  • Set4BS() : eoTeachInModule
  • SetCode() : eoRemoteManager
  • SetCommand() : eoD2EEProfile , eoEEP_A513xx , eoEEP_A538xx , eoEEP_D200xx , eoEEP_D201xx , eoEEP_D202xx , eoEEP_D205xx , eoEEP_D206xx , eoEEP_D210xx , eoEEP_D230xx , eoEEP_D231xx , eoEEP_D240xx
  • SetDataLength() : eoAbstractMessage
  • SetDenialTickBetween() : eoWatcher
  • SetDenialWarnCount() : eoWatcher
  • SetDeviceConfig() : eoReCom
  • SetDirection() : eoEEP_A520xx , eoEEP_D2A0xx , eoISimpleBidirectionalProfile , eoEEP_A520xx
  • SetGPLinkTable() : eoReCom
  • SetLength() : eoEEP_D201xx , eoEEP_D205xx , eoEEP_D206xx , eoEEP_D210xx , eoEEP_D240xx
  • SetLinkBasedConfig() : eoReCom
  • SetLinkTable() : eoReCom
  • SetManufacturer() : eoProfile
  • SetMSCmanufacturer() : eoMSCHelper
  • SetMSCpayload() : eoMSCHelper
  • SetProductId() : eoGenericProfile
  • SetProfile() : eoDevice
  • SetRawValue() : eoProfile
  • SetRejected() : eoGPChannelInfo
  • SetRepeater() : eoReCom
  • SetRepeaterFilter() : eoReCom
  • SetRLC() : eoRollingCodeStorage
  • SetRPS() : eoTeachInModule
  • SetType() : eoGenericProfile , eoProfile , eoEEP_A502xx , eoEEP_A504xx , eoEEP_A505xx , eoEEP_A506xx , eoEEP_A507xx , eoEEP_A508xx , eoEEP_A509xx , eoEEP_A510xx , eoEEP_A511xx , eoEEP_A512xx , eoEEP_A513xx , eoEEP_A514xx , eoEEP_A520xx , eoEEP_A530xx , eoEEP_A537xx , eoEEP_A538xx , eoEEP_D200xx , eoEEP_D201xx , eoEEP_D202xx , eoEEP_D203xx , eoEEP_D204xx , eoEEP_D205xx , eoEEP_D206xx , eoEEP_D210xx , eoEEP_D220xx , eoEEP_D230xx , eoEEP_D231xx , eoEEP_D232xx , eoEEP_D240xx , eoEEP_D2A0xx , eoEEP_D500xx , eoEEP_F602xx , eoEEP_F603xx , eoEEP_F604xx , eoEEP_F605xx , eoEEP_F610xx
  • SetValue() : eoEEP_D202xx , eoEEP_D210xx , eoProfile , eoD2EEProfile , eoProfile , eoA5EEProfile , eoEEP_D206xx , eoGenericProfile , eoD2EEProfile , eoEEP_A504xx , eoEEP_A505xx , eoEEP_A506xx , eoEEP_D210xx , eoEEP_D202xx , eoEEP_D230xx , eoEEP_D204xx , eoEEP_A508xx , eoEEP_A509xx , eoEEP_A510xx , eoEEP_D205xx , eoEEP_D231xx , eoEEP_D232xx , eoEEP_A513xx , eoEEP_D202xx , eoEEP_D231xx , eoEEP_D204xx , eoEEP_A511xx , eoEEP_D232xx , eoEEP_D210xx , eoEEP_D230xx , eoEEP_D206xx , eoEEP_D205xx , eoEEP_D202xx , eoEEP_A512xx , eoEEP_D203xx , eoEEP_D240xx , eoEEP_D201xx , eoEEP_D200xx , eoEEP_A530xx , eoEEP_F604xx , eoEEP_A538xx , eoEEP_D201xx , eoEEP_A538xx , eoEEP_F610xx , eoEEP_A530xx , eoEEP_D240xx , eoEEP_A520xx , eoEEP_D200xx , eoEEP_D201xx , eoEEP_F605xx , eoEEP_A513xx , eoEEP_A514xx , eoEEP_A520xx , eoEEP_D200xx , eoEEP_D201xx , eoEEP_A537xx , eoEEP_A538xx , eoEEP_D240xx , eoEEP_D200xx , eoEEP_A537xx , eoEEP_A538xx , eoEEP_D240xx , eoEEP_A504xx , eoEEP_A511xx , eoEEP_D220xx , eoEEP_F602xx , eoEEP_D220xx , eoEEP_A530xx , eoEEP_A510xx , eoEEP_D206xx , eoEEP_D500xx , eoEEP_A512xx , eoEEP_A513xx , eoEEP_D231xx , eoEEP_D230xx , eoEEP_D2A0xx , eoEEP_A520xx , eoEEP_D232xx , eoEEP_D205xx , eoEEP_D206xx , eoEEP_A520xx , eoEEP_A513xx , eoEEP_D231xx , eoEEP_A512xx , eoEEP_A511xx , eoEEP_D230xx , eoEEP_F603xx , eoEEP_A509xx , eoEEP_A507xx , eoEEP_D210xx , eoEEP_A507xx
  • signalType : eoChannelInfo
  • Size() : eoDeviceManager
  • sizeN : eoChainedMessage
  • Sleep() : eoTimer , eoSerialCommand
  • SLF : eoSecureInfo
  • slotPeriod : CO_RD_DUTYCYCLE_RESPONSE
  • slotPeriodLeft : CO_RD_DUTYCYCLE_RESPONSE
  • SmartAckConfirmLearn() : eoSerialCommand
  • smartAckID : SA_CONFIRM_LEARN_REQUEST
  • SmartAckLearnAck() : eoSerialCommand
  • SmartAckLearnConfirm() : eoSerialCommand
  • SmartAckLearnedClients() : eoSerialCommand
  • SmartAckReadLearnMode() : eoSerialCommand
  • SmartAckReset() : eoSerialCommand
  • SmartAckSendLearnRequest() : eoSerialCommand
  • SmartAckSetPostmaster() : eoSerialCommand
  • SmartAckSetReclaimTries() : eoSerialCommand
  • SmartAckWriteLearnMode() : eoSerialCommand
  • sourceID : eoReManMessage , eoMessage
  • startBlock() : eoArchiveTXT , eoArchive
  • startIndex : QUERY_LINK_BASED_CONFIG , QUERY_LINK_TABLE , QUERY_DEVICE_CONFIG
  • state : eoArchive
  • status : eoMessage
  • stream : eoGateway
  • subKey1 : eoSecureInfo
  • subKey2 : eoSecureInfo
  • subtelCount : eoTelegram
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • tableDir : QUERY_LINK_TABLE , QUERY_LINK_BASED_CONFIG
  • tableIndex : QUERY_LINK_BASED_CONFIG
  • teachedIN : TEACH_STRUCT
  • TeachIN() : eoTeachInModule
  • teachInInfo : eoSecureInfo
  • TeachInModule : eoGateway
  • TeachOut() : eoTeachInModule
  • telCount : eoChainedMessage
  • telegram : eoGateway
  • TigrisToRPS() : eoConverter
  • timeLastTelegram : WATCH_STRUCT
  • timeStamp : eoChainedMessage
  • ToString() : eoChannelInfo
  • TriggerOutboundTeachRequest() : eoReCom
  • type : eoPacket , eoChannelInfo , eoIFilter , eoIWatcher , PING_RESPONSE , EEP_ITEM , QUERY_ID , eoProfile
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • uniqueID : serialize_object
  • UnLock() : eoRemoteManager
  • UpdateDevice() : eoWatcher
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • value : QUERY_SET_REPEATER_FILTER
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • WaitMaturity() : eoSerialCommand
  • WriteIDBase() : eoSerialCommand
  • WriteMode() : eoSerialCommand
  • WriteRepeater() : eoSerialCommand
  • wrongCMACUsages : WATCH_STRUCT
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- a -

  • Action() : eoRemoteManager
  • Add() : eoDeviceManager , eoIDFilter
  • AddChannel() : eoGenericProfile
  • AddChannelOut() : eoGenericProfile
  • AddDevice() : eoWatcher
  • AddFilter() : eoSerialCommand
  • addObject() : eoStorageManager
  • advancedPacketToRadio() : eoConverter
  • AllowTeachIN() : eoGenericProfile
  • ApplyChanges() : eoReCom
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- b -

  • BIST() : eoSerialCommand
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- c -

  • celsiusToFahrenheit() : eoConverter
  • CheckDeadDevices() : eoWatcher
  • CheckSecurity() : eoWatcher , eoIWatcher
  • CleanUpChainerLists() : eoMessageHandler
  • CleanUpList() : eoSecTeachInChainer , eoGpChainer , eoReManChainer
  • Clear() : eoMessage , eoTelegram
  • ClearChannels() : eoGenericProfile
  • ClearChannelsOut() : eoGenericProfile
  • ClearValues() : eoEEP_D203xx , eoEEP_D2A0xx , eoEEP_F602xx , eoEEP_F603xx , eoGenericProfile , eoProfile , eoEEP_A520xx
  • Close() : eoArchive , eoArchiveTXT , eoGateway , eoLinuxPacketStream , eoLogger , eoPacketStream , eoWin32PacketStream
  • ComposeChainedMessage() : eoMessageHandler
  • CopyDataFrom() : eoChunkMessage
  • CopyFrom() : eoChunkMessage
  • copyTo() : eoMessage , eoPacket , eoReManMessage , eoChainedReManMessage
  • crc16() : eoProc
  • crc8() : eoProc
  • Create() : eoEEP_A520xx , eoGenericProfile , eoF6EEProfile , eoA5EEProfile , eoEEP_D2A0xx , eoProfile , eoGenericProfile
  • CreateFilter() : eoFilterFactory
  • CreateGPResponse() : eoTeachInModule
  • CreateProfile() : eoProfileFactory
  • CreateTeachIN() : eoD2EEProfile , eoA5EEProfile , eoGenericProfile , eoProfile
  • CreateTeachIn() : eoSecurity
  • CreateUTEResponse() : eoTeachInModule
  • CreateWatcher() : eoWatcherFactory
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- d -

  • Decrypt() : eoSecurity
  • DeleteAllFilter() : eoSerialCommand
  • DeleteFilter() : eoSerialCommand
  • DutyCycleLimit() : eoSerialCommand
  • DutyCycleReadLimit() : eoSerialCommand
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- e -

  • EnableFilter() : eoSerialCommand
  • Encrypt() : eoSecurity
  • endBlock() : eoArchiveTXT , eoArchive
  • eoA5EEProfile() : eoA5EEProfile
  • eoAbstractMessage() : eoAbstractMessage
  • eoChainedMessage() : eoChainedMessage
  • eoChainedReManMessage() : eoChainedReManMessage
  • eoChunkMessage() : eoChunkMessage
  • eoD2EEProfile() : eoD2EEProfile
  • eodBmFilter() : eodBmFilter
  • eoDevice() : eoDevice
  • eoDeviceManager() : eoDeviceManager
  • eoEEP_D200xx() : eoEEP_D200xx
  • eoEEP_D201xx() : eoEEP_D201xx
  • eoEEP_D202xx() : eoEEP_D202xx
  • eoEEP_D204xx() : eoEEP_D204xx
  • eoEEP_D205xx() : eoEEP_D205xx
  • eoEEP_D206xx() : eoEEP_D206xx
  • eoEEP_D210xx() : eoEEP_D210xx
  • eoEEP_D220xx() : eoEEP_D220xx
  • eoEEP_D230xx() : eoEEP_D230xx
  • eoEEP_D231xx() : eoEEP_D231xx
  • eoEEP_D240xx() : eoEEP_D240xx
  • eoEEP_D2A0xx() : eoEEP_D2A0xx
  • eoEEProfile() : eoEEProfile
  • eoGateway() : eoGateway
  • eoGenericProfile() : eoGenericProfile
  • eoGPChannelInfo() : eoGPChannelInfo
  • eoHeader() : eoHeader
  • eoLogger() : eoLogger
  • eoMessage() : eoMessage
  • eoPacket() : eoPacket
  • eoPacketStream() : eoPacketStream
  • eoProfile() : eoProfile
  • eoReCom() : eoReCom
  • eoReManMessage() : eoReManMessage
  • eoRemoteManager() : eoRemoteManager
  • eoRollingCodeStorage() : eoRollingCodeStorage
  • eoSerialCommand() : eoSerialCommand
  • eoStorageManager() : eoStorageManager
  • eoTeachInModule() : eoTeachInModule
  • eoTelegram() : eoTelegram
  • eoWatcher() : eoWatcher
  • EventDutyCycleLimit() : eoSerialCommand
  • EventSmartAckConfirmLearn() : eoSerialCommand
  • ExchangeInt() : eoArchiveTXT
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- f -

  • fahrenheitToCelsius() : eoConverter
  • Filter() : eodBmFilter , eoIFilter , eoIDFilter , eodBmFilter
  • Flush() : eoLogger
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- g -

  • Get() : eoDeviceManager
  • getBufferSize() : eoPacket
  • GetChannel() : eoEEProfile , eoGenericProfile , eoEEP_A512xx , eoEEP_D240xx , eoEEP_F602xx , eoEEP_A513xx , eoEEP_F603xx , eoEEP_F604xx , eoProfile , eoEEP_A520xx , eoEEP_F605xx , eoEEP_F610xx , eoEEP_A530xx , eoEEProfile , eoProfile , eoEEP_A537xx , eoEEP_A538xx , eoProfile , eoEEP_D200xx , eoEEP_D201xx , eoEEProfile , eoGenericProfile , eoEEP_A506xx , eoEEP_D202xx , eoEEP_D205xx , eoEEP_A509xx , eoEEP_D206xx , eoEEP_D210xx , eoGenericProfile , eoEEP_A511xx , eoEEP_D220xx , eoEEP_D230xx , eoEEP_A512xx , eoEEP_D231xx , eoEEP_D232xx
  • GetChannelCount() : eoEEProfile , eoGenericProfile , eoProfile
  • GetChannelCountOut() : eoGenericProfile
  • GetChannelOut() : eoGenericProfile
  • GetDataLength() : eoAbstractMessage
  • GetDenialTickBetween() : eoWatcher
  • GetDenialWarnCount() : eoWatcher
  • GetDeviceConfig() : eoReCom
  • GetDeviceList() : eoDeviceManager
  • GetEngMax() : eoGPChannelInfo
  • GetEngMin() : eoGPChannelInfo
  • GetGPChannelType() : eoGPChannelInfo
  • GetGPLinkTable() : eoReCom
  • GetLastError() : eoSecurity , eoWin32PacketStream
  • GetLinkBasedConfig() : eoReCom
  • GetLinkTable() : eoReCom
  • GetMaxLength() : eoAbstractMessage
  • GetMetadata() : eoReCom
  • GetMSCmanufacturer() : eoMSCHelper
  • GetMSCpayload() : eoMSCHelper
  • GetName() : eoManufacturer
  • GetOutChannel() : eoISimpleBidirectionalProfile , eoEEP_A520xx , eoEEP_D2A0xx , eoISimpleBidirectionalProfile
  • GetProductId() : eoGenericProfile
  • GetProductID() : eoReCom
  • GetProfile() : eoDevice
  • GetRawValue() : eoProfile
  • GetRejected() : eoGPChannelInfo
  • GetRepeater() : eoReCom
  • GetResolution() : eoGPChannelInfo
  • GetRLC() : eoRollingCodeStorage
  • GetScaleMax() : eoGPChannelInfo
  • GetScaleMin() : eoGPChannelInfo
  • GetSecWatchResult() : eoGateway
  • GetSerialPacket() : eoSerialCommand
  • GetSubTypeChannel() : eoEEProfile , eoProfile
  • GetTickCount() : eoTimer
  • GetValue() : eoEEP_A507xx , eoEEP_A506xx , eoEEP_A505xx , eoEEP_A504xx , eoD2EEProfile , eoA5EEProfile , eoProfile , eoGenericProfile , eoEEP_D203xx , eoEEP_D231xx , eoEEP_D201xx , eoEEP_D231xx , eoEEP_D230xx , eoEEP_D232xx , eoEEP_A512xx , eoEEP_D232xx , eoEEP_D240xx , eoEEP_A513xx , eoEEP_D240xx , eoEEP_A520xx , eoEEP_F602xx , eoEEP_D500xx , eoEEP_F603xx , eoEEP_D204xx , eoEEP_F605xx , eoEEP_F604xx , eoEEP_F610xx , eoEEP_A537xx , eoEEP_D206xx , eoEEP_D205xx , eoEEP_D206xx , eoEEP_A538xx , eoEEP_D206xx , eoEEP_D210xx , eoEEP_D200xx , eoEEP_D210xx , eoEEP_D220xx , eoEEP_D205xx , eoEEP_D220xx , eoEEP_D230xx , eoEEP_D202xx , eoEEP_D231xx , eoEEP_D230xx , eoEEP_D231xx , eoEEP_D204xx , eoEEP_A510xx , eoEEP_D202xx , eoEEP_A511xx , eoEEP_A512xx , eoEEP_A513xx , eoEEP_D230xx , eoEEP_A520xx , eoEEP_D201xx , eoEEP_D2A0xx , eoEEP_A530xx , eoEEP_A537xx , eoEEP_A538xx , eoEEP_D205xx , eoEEP_D200xx , eoEEP_D201xx , eoEEP_D210xx , eoEEP_D202xx , eoEEP_A509xx , eoEEP_A510xx , eoEEP_A511xx , eoEEP_A512xx , eoEEP_A514xx , eoEEP_A520xx , eoEEP_A530xx , eoEEP_A537xx , eoEEP_A538xx , eoEEP_D200xx , eoEEP_D201xx , eoEEP_A509xx , eoEEP_A511xx , eoEEP_A513xx , eoEEP_A530xx , eoEEP_A538xx , eoEEP_A509xx , eoEEP_A511xx , eoEEP_A513xx , eoEEP_A508xx
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- h -

  • Hash() : eoConverter
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- i -

  • indent() : eoArchive , eoArchiveTXT
  • Is4BSData() : eoA5EEProfile
  • IsPacketPending() : eoPacketStream
  • IsReceived() : eoChunkMessage
  • IsSecDData() : eoA5EEProfile , eoProfile
  • isTeachedIN() : eoTeachInModule
  • isTeachIN() : eoTeachInModule
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- l -

  • LearnModeOff() : eoGateway
  • LearnModeOn() : eoGateway
  • literToMeter3() : eoConverter
  • Load() : eoRollingCodeStorage , eoStorageManager
  • Lock() : eoRemoteManager
  • Log() : eoLogger
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- m -

  • meter3ToLiter() : eoConverter
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- n -

  • NumToHex() : eoConverter
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- o -

  • Open() : eoArchive , eoArchiveTXT , eoLinuxPacketStream , eoLogger , eoGateway , eoPacketStream , eoWin32PacketStream
  • operator!=() : eoGenericProfile , eoProfile
  • operator&() : eoArchiveTXT , eoArchive , eoArchiveTXT , eoArchive , eoArchiveTXT , eoArchive , eoArchiveTXT , eoArchive , eoArchiveTXT , eoArchive , eoArchiveTXT
  • operator==() : eoProfile , eoGenericProfile
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- p -

  • packetToAdvancedRadio() : eoConverter
  • packetToRadio() : eoConverter
  • packetToReman() : eoConverter
  • Parse() : eoGenericProfile , eoEEP_A538xx , eoEEP_D220xx , eoEEP_D230xx , eoEEP_D200xx , eoEEP_D231xx , eoEEP_D240xx , eoProfile , eoEEP_D201xx , eoEEP_D2A0xx , eoEEP_D500xx , eoEEP_D202xx , eoF6EEProfile , eoA5EEProfile , eoEEP_D203xx , eoEEP_D205xx , eoEEP_A513xx , eoEEP_D206xx , eoEEP_D210xx
  • ParseChainedMessage() : eoGpChainer , eoReManChainer , eoSecTeachInChainer
  • ParseDeviceConfigResponse() : eoReCom
  • ParseGetGPLinkTableResponse() : eoReCom
  • ParseGetLinkTableResponse() : eoReCom
  • ParseGetMetadataResponse() : eoReCom
  • ParseGetProductIDResponse() : eoReCom
  • ParseGetRepeaterResponse() : eoReCom
  • ParseLinkBasedConfigResponse() : eoReCom
  • ParsePingAnswer() : eoRemoteManager
  • ParseQueryFunctionAnswer() : eoRemoteManager
  • ParseQueryIDAnswer() : eoRemoteManager
  • ParseQueryStatusAnswer() : eoRemoteManager
  • ParseRemoteFlashReadAnswer() : eoRemoteManager
  • ParseRemoteSmartReadLearnedSensors() : eoRemoteManager
  • ParseRemoteSmartReadMailboxSettingsAnswer() : eoRemoteManager
  • ParseSelData() : eoGenericProfile
  • ParseTeachIn() : eoSecurity
  • ParseTeachIN() : eoGenericProfile
  • ParseUTE() : eoTeachInModule
  • Ping() : eoRemoteManager
  • Print() : eoDebug
  • ProcessChunks() : eoChainedMessage
  • ProcessTelegram() : eoMessageHandler
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- q -

  • QueryFunction() : eoRemoteManager
  • QueryID() : eoRemoteManager
  • QueryStatus() : eoRemoteManager
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- r -

  • RadioLinkTest() : eoReCom
  • radioToPacket() : eoConverter
  • ReadFilter() : eoSerialCommand
  • ReadIDBase() : eoSerialCommand
  • ReadRepeater() : eoSerialCommand
  • ReadVersion() : eoSerialCommand
  • Ready() : eoSerialCommand
  • Receive() : eoGateway , eoPacketStream
  • ReceiveByte() : eoLinuxPacketStream , eoPacketStream , eoWin32PacketStream
  • remanToPacket() : eoConverter
  • RemoteFlashRead() : eoRemoteManager
  • RemoteFlashWrite() : eoRemoteManager
  • RemoteLearnIn() : eoRemoteManager
  • RemoteSetLearnMode() : eoReCom
  • RemoteSmartAddMailbox() : eoRemoteManager
  • RemoteSmartDeleteMailbox() : eoRemoteManager
  • RemoteSmartLearnIn() : eoRemoteManager
  • RemoteSmartLearnOut() : eoRemoteManager
  • RemoteSmartReadLearnedSensors() : eoRemoteManager
  • RemoteSmartReadMailboxSettings() : eoRemoteManager
  • Remove() : eoDeviceManager , eoIDFilter
  • RemoveAll() : eoIDFilter , eoIFilter
  • RemoveDevice() : eoWatcher
  • RemoveID() : eoRollingCodeStorage
  • RemoveObject() : eoStorageManager
  • Reset() : eoWatcher , eoSerialCommand
  • ResetDefaults() : eoReCom
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- s -

  • Save() : eoRollingCodeStorage , eoStorageManager
  • Scale() : eoGPChannelInfo
  • ScaleFromRAW() : eoProfile
  • ScaleToFloat() : eoGPChannelInfo
  • ScaleToRAW() : eoProfile
  • Send() : eoGateway , eoPacketStream , eoGateway
  • SendByte() : eoLinuxPacketStream , eoPacketStream , eoWin32PacketStream
  • SendChainedMessage() : eoSecTeachInChainer , eoGpChainer , eoReManChainer
  • Serialize() : eodBmFilter , eoDevice , eoDeviceManager , eoGateway , eoGenericProfile , eoGPChannelInfo , eoHeader , eoIDFilter , eoIFilter , eoISerialize , eoIWatcher , eoProfile , eoSecureInfo , eoTeachInModule , eoWatcher
  • Set1BS() : eoTeachInModule
  • Set4BS() : eoTeachInModule
  • SetCode() : eoRemoteManager
  • SetCommand() : eoD2EEProfile , eoEEP_A513xx , eoEEP_A538xx , eoEEP_D200xx , eoEEP_D201xx , eoEEP_D202xx , eoEEP_D205xx , eoEEP_D206xx , eoEEP_D210xx , eoEEP_D230xx , eoEEP_D231xx , eoEEP_D240xx
  • SetDataLength() : eoAbstractMessage
  • SetDenialTickBetween() : eoWatcher
  • SetDenialWarnCount() : eoWatcher
  • SetDeviceConfig() : eoReCom
  • SetDirection() : eoISimpleBidirectionalProfile , eoEEP_A520xx , eoEEP_D2A0xx
  • SetGPLinkTable() : eoReCom
  • SetLength() : eoEEP_D201xx , eoEEP_D205xx , eoEEP_D206xx , eoEEP_D210xx , eoEEP_D240xx
  • SetLinkBasedConfig() : eoReCom
  • SetLinkTable() : eoReCom
  • SetManufacturer() : eoProfile
  • SetMSCmanufacturer() : eoMSCHelper
  • SetMSCpayload() : eoMSCHelper
  • SetProductId() : eoGenericProfile
  • SetProfile() : eoDevice
  • SetRawValue() : eoProfile
  • SetRejected() : eoGPChannelInfo
  • SetRepeater() : eoReCom
  • SetRepeaterFilter() : eoReCom
  • SetRLC() : eoRollingCodeStorage
  • SetRPS() : eoTeachInModule
  • SetType() : eoGenericProfile , eoProfile , eoEEP_A502xx , eoEEP_A504xx , eoEEP_A505xx , eoEEP_A506xx , eoEEP_A507xx , eoEEP_A508xx , eoEEP_A509xx , eoEEP_A510xx , eoEEP_A511xx , eoEEP_A512xx , eoEEP_A513xx , eoEEP_A514xx , eoEEP_A520xx , eoEEP_A530xx , eoEEP_A537xx , eoEEP_A538xx , eoEEP_D200xx , eoEEP_D201xx , eoEEP_D202xx , eoEEP_D203xx , eoEEP_D204xx , eoEEP_D205xx , eoEEP_D206xx , eoEEP_D210xx , eoEEP_D220xx , eoEEP_D230xx , eoEEP_D231xx , eoEEP_D232xx , eoEEP_D240xx , eoEEP_D2A0xx , eoEEP_D500xx , eoEEP_F602xx , eoEEP_F603xx , eoEEP_F604xx , eoEEP_F605xx , eoEEP_F610xx
  • SetValue() : eoA5EEProfile , eoEEP_D200xx , eoProfile , eoEEP_D201xx , eoGenericProfile , eoEEP_D231xx , eoEEP_D232xx , eoEEP_A504xx , eoEEP_A505xx , eoEEP_A506xx , eoEEP_D205xx , eoEEP_A507xx , eoEEP_A508xx , eoEEP_D230xx , eoEEP_D206xx , eoEEP_D200xx , eoEEP_A510xx , eoEEP_D201xx , eoEEP_D206xx , eoEEP_D231xx , eoEEP_D205xx , eoEEP_A509xx , eoEEP_D240xx , eoEEP_D220xx , eoEEP_A512xx , eoEEP_D232xx , eoEEP_D210xx , eoEEP_F605xx , eoEEP_A513xx , eoEEP_F602xx , eoEEP_D220xx , eoEEP_D202xx , eoEEP_A520xx , eoEEP_A511xx , eoEEP_D230xx , eoEEP_D200xx , eoEEP_D210xx , eoEEP_D200xx , eoEEP_F603xx , eoEEP_A537xx , eoEEP_A530xx , eoEEP_D231xx , eoEEP_A520xx , eoEEP_A538xx , eoEEP_A513xx , eoEEP_A530xx , eoEEP_A538xx , eoEEP_D230xx , eoEEP_A512xx , eoEEP_D231xx , eoEEP_A538xx , eoEEP_A537xx , eoEEP_A538xx , eoEEP_A530xx , eoEEP_A511xx , eoD2EEProfile , eoEEP_D240xx , eoProfile , eoEEP_D204xx , eoGenericProfile , eoEEP_D203xx , eoEEP_D206xx , eoEEP_D500xx , eoEEP_D2A0xx , eoEEP_D240xx , eoEEP_D232xx , eoEEP_A510xx , eoEEP_D230xx , eoEEP_D206xx , eoEEP_D210xx , eoEEP_A512xx , eoEEP_F604xx , eoEEP_D210xx , eoEEP_D201xx , eoEEP_A520xx , eoEEP_A513xx , eoEEP_A520xx , eoEEP_D220xx , eoEEP_F610xx , eoEEP_A514xx , eoEEP_A511xx , eoEEP_A513xx , eoEEP_A511xx , eoA5EEProfile , eoD2EEProfile , eoEEP_D202xx , eoEEP_D204xx , eoEEP_D201xx , eoEEP_A504xx , eoEEP_D205xx , eoEEP_A509xx , eoEEP_A510xx , eoEEP_A509xx , eoEEP_A507xx , eoA5EEProfile , eoD2EEProfile , eoEEP_D202xx
  • Size() : eoDeviceManager
  • Sleep() : eoSerialCommand , eoTimer
  • SmartAckConfirmLearn() : eoSerialCommand
  • SmartAckLearnAck() : eoSerialCommand
  • SmartAckLearnConfirm() : eoSerialCommand
  • SmartAckLearnedClients() : eoSerialCommand
  • SmartAckReadLearnMode() : eoSerialCommand
  • SmartAckReset() : eoSerialCommand
  • SmartAckSendLearnRequest() : eoSerialCommand
  • SmartAckSetPostmaster() : eoSerialCommand
  • SmartAckSetReclaimTries() : eoSerialCommand
  • SmartAckWriteLearnMode() : eoSerialCommand
  • startBlock() : eoArchive , eoArchiveTXT
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- t -

  • TeachIN() : eoTeachInModule
  • TeachOut() : eoTeachInModule
  • TigrisToRPS() : eoConverter
  • ToString() : eoChannelInfo
  • TriggerOutboundTeachRequest() : eoReCom
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- u -

  • UnLock() : eoRemoteManager
  • UpdateDevice() : eoWatcher
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- w -

  • WaitMaturity() : eoSerialCommand
  • WriteIDBase() : eoSerialCommand
  • WriteMode() : eoSerialCommand
  • WriteRepeater() : eoSerialCommand
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • advancedMode : eoGateway
  • apiVersion : CO_RD_VERSION_RESPONSE
  • appDescription : CO_RD_VERSION_RESPONSE
  • appVersion : CO_RD_VERSION_RESPONSE
  • availableCycle : CO_RD_DUTYCYCLE_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • baseID : CO_RD_IDBASE_RESPONSE
  • bitoffs : EEP_ITEM , eoGPChannelInfo
  • bitsize : EEP_ITEM
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • channel : eoEEProfile , LINK_TABLE
  • channelCount : eoEEProfile
  • chipID : CO_RD_VERSION_RESPONSE
  • chipVersion : CO_RD_VERSION_RESPONSE
  • clientID : SA_RD_LEARNEDCLIENTS_RESPONSE
  • codeSetFlag : QUERY_STATUS_RESPONSE
  • commands : eoGateway
  • configChanges : QUERY_APPLY_CHANGES
  • configParam : QUERY_RESET_DEFAULTS
  • confirmCode : SA_LEARN_ACK_RESPONSE
  • controllerID : LEARNED_SENSOR_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • data : eoAbstractMessage , eoPacket , FLASH_READ_RESPONSE
  • dataChunks : eoChainedMessage
  • dataDirection : eoGenericProfile
  • dataLength : eoAbstractMessage , eoPacket
  • dBm : eoDevice , eoTelegram
  • destinationID : eoReManMessage , eoMessage
  • device : eoGateway
  • deviceManager : eoGateway
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • eep : SA_CONFIRM_LEARN_REQUEST
  • EEP_FUNC : LINK_TABLE
  • EEP_RORG : LINK_TABLE
  • EEP_TYPE : LINK_TABLE
  • eepItem : eoEEPChannelInfo
  • enabled : SA_RD_LEARNMODE_RESPONSE
  • endIndex : QUERY_DEVICE_CONFIG , QUERY_LINK_BASED_CONFIG , QUERY_LINK_TABLE
  • errorCode : eoGateway
  • exist : EEP_ITEM
  • expectedDataLength : eoChainedMessage
  • expectedTelCount : eoChainedMessage
  • extended : SA_RD_LEARNMODE_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • filter : eoGateway
  • filterType : CO_RD_FILTER_RESPONSE
  • filterValue : CO_RD_FILTER_RESPONSE
  • flashAddress : MAILBOX_SETTINGS_RESPONSE
  • fnCode : eoChainedReManMessage , eoReManMessage
  • func : eoProfile , QUERY_ID , PING_RESPONSE
  • functionNum : QUERY_FUNCTION_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • h : eoArchive
  • hasBeenLoaded : serialize_object
  • hopCount : SA_CONFIRM_LEARN_REQUEST
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • ID : eoDevice , LINK_TABLE
  • identifier : eoArchive
  • inboundIndex : QUERY_SET_LEARN_MODE
  • inboundLinkTable : QUERY_METADATA_RESPONSE
  • inboundTable : QUERY_RESET_DEFAULTS
  • index : DEVICE_CONFIG , LINK_TABLE , EEP_ITEM
  • isEnabled : QUERY_RADIO_LINK_TEST
  • isName : eoArchive
  • isStoring : eoArchive
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- k -

  • key : eoSecureInfo
  • keySize : eoSecureInfo
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • lastFunc : QUERY_STATUS_RESPONSE
  • lastFuncRet : QUERY_STATUS_RESPONSE
  • lastSEQ : QUERY_STATUS_RESPONSE
  • learnedCount : LEARNED_SENSOR_RESPONSE
  • learnFilter : eoGateway
  • LearnMode : eoGateway
  • lenghtOfInbound : QUERY_METADATA_RESPONSE
  • length : QUERY_DEVICE_CONFIG , DEVICE_CONFIG , QUERY_LINK_BASED_CONFIG
  • lengthOfOutbound : QUERY_METADATA_RESPONSE
  • level : eoArchive
  • linkTableChanges : QUERY_APPLY_CHANGES
  • list : eoSecTeachInChainer
  • loadAfterCycle : CO_RD_DUTYCYCLE_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • mailboxCount : MAILBOX_SETTINGS_RESPONSE
  • mailboxIndex : SA_RD_LEARNEDCLIENTS_RESPONSE
  • major : eoHeader
  • manufacturer : eoProfile
  • manufacturerID : SA_CONFIRM_LEARN_REQUEST
  • manufacturerId : QUERY_PRODUCT_ID_RESPONSE
  • manufacturerID : eoChainedReManMessage , eoReManMessage
  • manufaturerID : QUERY_FUNCTION_RESPONSE
  • maskArray : eoProfile
  • max : eoChannelInfo
  • maxdBm : eodBmFilter
  • maxLength : eoAbstractMessage
  • maxOfInbound : QUERY_METADATA_RESPONSE
  • maxOfOutbound : QUERY_METADATA_RESPONSE
  • maxPeriodTime : WATCH_STRUCT
  • maxRLCDiff : WATCH_STRUCT
  • maxWrongCmac : WATCH_STRUCT
  • message : eoGateway
  • min : eoChannelInfo
  • mindBm : eodBmFilter
  • minor : eoHeader
  • minPeriodTime : WATCH_STRUCT
  • mode : QUERY_SET_LEARN_MODE
  • msg : eoProfile
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • name : eoHeader , serialize_object
  • numOfRLT : QUERY_RADIO_LINK_TEST
  • numOfSlots : CO_RD_DUTYCYCLE_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • object : serialize_object
  • optionalLength : eoPacket
  • outboundLinkTable : QUERY_METADATA_RESPONSE
  • outboundTable : QUERY_RESET_DEFAULTS
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • packet : eoGateway
  • postmasterID : SA_CONFIRM_LEARN_REQUEST , SA_RD_LEARNEDCLIENTS_RESPONSE
  • previousRollingCode : eoSecureInfo
  • priPostmaster : SA_CONFIRM_LEARN_REQUEST
  • productReference : QUERY_PRODUCT_ID_RESPONSE
  • psk : eoSecureInfo
  • purpose : eoGenericProfile
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • rangeMax : EEP_ITEM
  • rangeMin : EEP_ITEM
  • rawValue : DEVICE_CONFIG
  • received : eoChainedMessage
  • remainingWrites : CO_RD_IDBASE_RESPONSE
  • reManMessage : eoGateway
  • remoteTeachInbound : QUERY_METADATA_RESPONSE
  • remoteTeachOutbound : QUERY_METADATA_RESPONSE
  • repeaterFunc : QUERY_SET_REPEATER_FILTER
  • repeaterLevel : QUERY_SET_REPEATER_FILTER
  • repEnable : CO_RD_REPEATER_RESPONSE
  • repLevel : CO_RD_REPEATER_RESPONSE
  • resetCause : CO_READY_RESPONSE
  • resetPeriod : WATCH_STRUCT
  • responsePacket : eoGateway
  • responseTime : SA_LEARN_ACK_RESPONSE
  • rollingCode : eoSecureInfo
  • RORG : eoMessage
  • rorg : PING_RESPONSE , QUERY_ID , eoProfile
  • rssi : PING_RESPONSE , SA_CONFIRM_LEARN_REQUEST
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • scaleMax : EEP_ITEM
  • scaleMin : EEP_ITEM
  • secIn : eoDevice
  • secOut : eoDevice
  • security : eoGateway
  • securityLevel : eoMessage , eoReManMessage
  • securityResult : eoSecureInfo
  • secWatcher : eoGateway
  • sensorID : LEARNED_SENSOR_RESPONSE
  • seq : eoChainedMessage
  • signalType : eoChannelInfo
  • sizeN : eoChainedMessage
  • SLF : eoSecureInfo
  • slotPeriod : CO_RD_DUTYCYCLE_RESPONSE
  • slotPeriodLeft : CO_RD_DUTYCYCLE_RESPONSE
  • smartAckID : SA_CONFIRM_LEARN_REQUEST
  • sourceID : eoReManMessage , eoMessage
  • startIndex : QUERY_DEVICE_CONFIG , QUERY_LINK_TABLE , QUERY_LINK_BASED_CONFIG
  • state : eoArchive
  • status : eoMessage
  • stream : eoGateway
  • subKey1 : eoSecureInfo
  • subKey2 : eoSecureInfo
  • subtelCount : eoTelegram
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • tableDir : QUERY_LINK_TABLE , QUERY_LINK_BASED_CONFIG
  • tableIndex : QUERY_LINK_BASED_CONFIG
  • teachedIN : TEACH_STRUCT
  • teachInInfo : eoSecureInfo
  • TeachInModule : eoGateway
  • telCount : eoChainedMessage
  • telegram : eoGateway
  • timeLastTelegram : WATCH_STRUCT
  • timeStamp : eoChainedMessage
  • type : eoPacket , PING_RESPONSE , eoIWatcher , QUERY_ID , EEP_ITEM , eoChannelInfo , eoIFilter , eoProfile
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • uniqueID : serialize_object
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • value : QUERY_SET_REPEATER_FILTER
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • wrongCMACUsages : WATCH_STRUCT
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File List

  • File List
  • File Members
File List
Here is a list of all documented files with brief descriptions:
[detail level 1234]
\ - SourceCode |
\ - EOLink |
o - Includes |
| o * eoAbstractMessage.h |
| o * eoApiDef.h | Dolphin API Definitions
| o * eoArchive.h | Base for Archives
| o * eoArchiveTXT.h | Human readable class
| o * eoChainedMessage.h |
| o * eoChainedReManMessage.h |
| o * eoChannelEnums.h | Contains Channel Enums
| o * eoChannelInfo.h | EoChannelInfo Class
| o * eoConverter.h | Different converter
| o * eodBmFilter.h | DBm based Filter
| o * eoDebug.h | EoDebug
| o * eoDevice.h | EoDevice
| o * eoDeviceManager.h | EoDeviceManager
| o * eoEEProfile.h | Profile base class for Enocean Equipment Profiles
| o * eoFilterFactory.h |
| o * eoGateway.h | EoGateway
| o * eoGenericProfile.h |
| o * eoGpChainer.h |
| o * eoGPChannelInfo.h | Enocean GP channel Informations
| o * eoHalTypes.h |
| o * eoHeader.h |
| o * eoIDFilter.h | EoIDFilter
| o * eoIFilter.h | EoIFilter
| o * eoISerialize.h |
| o * eoISimpleBidirectionalProfile.h |
| o * eoIWatcher.h | Watcher Header File
| o * eoLinuxPacketStream.h |
| o * eoLogger.h |
| o * eoManufacturer.h | Manufacturer list
| o * eoMessage.h |
| o * eoMessageHandler.h |
| o * eoMSCHelper.h | MSC Helper
| o * eoPacket.h |
| o * eoPacketStream.h |
| o * eoProc.h |
| o * eoProfile.h |
| o * eoProfileFactory.h |
| o * eoReCom.h | EoRemoteCommissioning
| o * eoReManChainer.h |
| o * eoReManMessage.h |
| o * eoRemoteManager.h | EoRemoteManager
| o * eoRollingCodeStorage.h |
| o * eoSecTeachInChainer.h |
| o * eoSecureInfo.h |
| o * eoSecurity.h |
| o * eoSerialCommand.h | EoSerialCommand
| o * eoStorageManager.h |
| o * eoTeachInModule.h |
| o * eoTelegram.h |
| o * eoTimer.h |
| o * eoWatcher.h | Watcher Header File
| \ * eoWatcherFactory.h |
o - Profiles |
| o * eoA5EEProfile.h |
| o * eoD2EEProfile.h |
| o * eoEEP_A502xx.h |
| o * eoEEP_A504xx.h |
| o * eoEEP_A505xx.h |
| o * eoEEP_A506xx.h |
| o * eoEEP_A507xx.h |
| o * eoEEP_A508xx.h |
| o * eoEEP_A509xx.h |
| o * eoEEP_A510xx.h |
| o * eoEEP_A511xx.h |
| o * eoEEP_A512xx.h |
| o * eoEEP_A513xx.h |
| o * eoEEP_A514xx.h |
| o * eoEEP_A520xx.h |
| o * eoEEP_A530xx.h |
| o * eoEEP_A537xx.h |
| o * eoEEP_A538xx.h |
| o * eoEEP_D200xx.h |
| o * eoEEP_D201xx.h |
| o * eoEEP_D202xx.h |
| o * eoEEP_D203xx.h |
| o * eoEEP_D204xx.h |
| o * eoEEP_D205xx.h |
| o * eoEEP_D206xx.h |
| o * eoEEP_D210xx.h |
| o * eoEEP_D220xx.h |
| o * eoEEP_D230xx.h |
| o * eoEEP_D231xx.h |
| o * eoEEP_D232xx.h |
| o * eoEEP_D240xx.h |
| o * eoEEP_D250xx.h |
| o * eoEEP_D2A0xx.h |
| o * eoEEP_D500xx.h |
| o * eoEEP_F602xx.h |
| o * eoEEP_F603xx.h |
| o * eoEEP_F604xx.h |
| o * eoEEP_F605xx.h |
| o * eoEEP_F610xx.h |
| o * eoF6EEProfile.h |
| \ * eoSpecialProfile.h | Wrapper for includes
\ * eoLink.h | EnOcean Link Main Header The Main Header to include into your Project File
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/ Directory Reference

  • SourceCode
SourceCode Directory Reference
Directory dependency graph for E:/Autobuild/EOLink/SourceCode/:

Directories

directory EOLink
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/ Directory Reference

  • SourceCode
  • EOLink
EOLink Directory Reference
Directory dependency graph for E:/Autobuild/EOLink/SourceCode/EOLink/:

Directories

directory | Includes
directory | Profiles

Files

file | config.h [code]
file | eoLink.h [code]
EnOcean Link Main Header The Main Header to include into your Project File.
file | eoVersion.h [code]
file | stdafx.h [code]
file | targetver.h [code]
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/ Directory Reference

  • SourceCode
  • EOLink
  • Includes
Includes Directory Reference
Directory dependency graph for E:/Autobuild/EOLink/SourceCode/EOLink/Includes/:

Files

file | eoAbstractMessage.h [code]
file | eoApiDef.h [code]
contains Dolphin API Definitions
file | eoArchive.h [code]
contains base for Archives
file | eoArchiveTXT.h [code]
contains human readable class
file | eoChainedMessage.h [code]
file | eoChainedReManMessage.h [code]
file | eoChannelEnums.h [code]
Contains Channel Enums.
file | eoChannelInfo.h [code]
contains the eoChannelInfo Class
file | eoChunkMessage.h [code]
file | eoConverter.h [code]
different converter
file | eodBmFilter.h [code]
contains a dBm based Filter
file | eoDebug.h [code]
eoDebug
file | eoDevice.h [code]
eoDevice
file | eoDeviceManager.h [code]
eoDeviceManager
file | eoEEProfile.h [code]
Profile base class for Enocean Equipment Profiles.
file | eoFilterFactory.h [code]
file | eoGateway.h [code]
eoGateway
file | eoGenericProfile.h [code]
file | eoGpChainer.h [code]
file | eoGPChannelInfo.h [code]
Enocean GP channel Informations.
file | eoHalTypes.h [code]
file | eoHeader.h [code]
file | eoIDFilter.h [code]
eoIDFilter
file | eoIFilter.h [code]
eoIFilter
file | eoISerialize.h [code]
file | eoISimpleBidirectionalProfile.h [code]
file | eoIWatcher.h [code]
Watcher Header File.
file | eoLinuxPacketStream.h [code]
file | eoLogger.h [code]
file | eoManufacturer.h [code]
Manufacturer list.
file | eoMessage.h [code]
file | eoMessageHandler.h [code]
file | eoMSCHelper.h [code]
MSC Helper.
file | eoPacket.h [code]
file | eoPacketStream.h [code]
file | eoProc.h [code]
file | eoProfile.h [code]
file | eoProfileFactory.h [code]
file | eoReCom.h [code]
eoRemoteCommissioning
file | eoReManChainer.h [code]
file | eoReManMessage.h [code]
file | eoRemoteManager.h [code]
eoRemoteManager
file | eoRollingCodeStorage.h [code]
file | eoSecTeachInChainer.h [code]
file | eoSecureInfo.h [code]
file | eoSecurity.h [code]
file | eoSerialCommand.h [code]
eoSerialCommand
file | eoStorageManager.h [code]
file | eoTeachInModule.h [code]
file | eoTelegram.h [code]
file | eoTimer.h [code]
file | eoWatcher.h [code]
Watcher Header File.
file | eoWatcherFactory.h [code]
file | eoWin32PacketStream.h [code]
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoAbstractMessage.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoAbstractMessage.h File Reference
#include "eoHalTypes.h"
#include "eoApiDef.h"
Include dependency graph for eoAbstractMessage.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoAbstractMessage
base class for all Messages More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoApiDef.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Macros | Enumerations
eoApiDef.h File Reference

contains Dolphin API Definitions More...

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Macros

#define BROADCAST_ID 0xFFFFFFFF
Destination broadcast ID.

Enumerations

enum eoReturn {
EO_OK = 0x00, EO_ERROR = 0x01, NOT_SUPPORTED = 0x02, WRONG_PARAM = 0x03,
OPERATION_DENIED = 0x04, TIME_OUT = 0x05, NO_RX = 0x06, ONGOING_RX = 0x07,
NEW_RX = 0x08, BUFF_FULL = 0x09, OUT_OF_RANGE = 0x0A, PORT_ERROR = 0x0B,
USER_CMD = 0x80, NOT_RECOM = 0x81, INVALID_PACKET = 0x90, NOT_IMPLEMENTED = 0xFF
}
contains all the return values from different functions More...
enum PACKET_TYPE {
PACKET_RESERVED = 0x00, PACKET_RADIO = 0x01, PACKET_RESPONSE = 0x02, PACKET_RADIO_SUB_TEL = 0x03,
PACKET_EVENT = 0x04, PACKET_COMMON_COMMAND = 0x05, PACKET_SMART_ACK_COMMAND = 0x06, PACKET_REMOTE_MAN_COMMAND = 0x07,
PACKET_PRODUCTION_COMMAND = 0x08, PACKET_RADIO_MESSAGE = 0x09, PACKET_RADIO_ADVANCED = 0x0A, PACKET_RADIO_SET = 0x0E,
PACKET_DEBUG = 0x0F
}
Packet type (ESP3) More...
enum CHOICE_TYPE {
RADIO_CHOICE_RPS = 0xF6, RADIO_CHOICE_1BS = 0xD5, RADIO_CHOICE_4BS = 0xA5, RADIO_CHOICE_HRC = 0xA3,
RADIO_CHOICE_SYS = 0xA4, RADIO_CHOICE_SYS_EX = 0xC5, RADIO_CHOICE_SM_LRN_REQ = 0xC6, RADIO_CHOICE_SM_LRN_ANS = 0xC7,
RADIO_CHOICE_RECLAIM = 0xA7, RADIO_CHOICE_SIGNAL = 0xD0, RADIO_CHOICE_ADT = 0xA6, RADIO_CHOICE_VLD = 0xD2,
RADIO_CHOICE_UTE = 0xD4, RADIO_CHOICE_MSC = 0xD1, RADIO_CHOICE_GP_SINGLE_TREQ = 0xB0, RADIO_CHOICE_GP_CHAINED_TREQ = 0xB1,
RADIO_CHOICE_GP_SINGLE_TRES = 0xB2, RADIO_CHOICE_GP_CHAINED_TRES = 0xB3, RADIO_CHOICE_GP_SINGLE_DATA = 0xB4, RADIO_CHOICE_GP_CHAINED_DATA = 0xB5,
RADIO_CHOICE_GP_SELECT_DATA = 0xB6, RADIO_CHOICE_SEC = 0x30, RADIO_CHOICE_SEC_ENCAPS = 0x31, RADIO_CHOICE_NON_SEC = 0x32,
RADIO_CHOICE_SEC_TI = 0x35
}
Telegram choice codes applies to radio telegram only. More...
enum RORG_TYPE {
RORG_RPS = 0xF6, RORG_1BS = 0xD5, RORG_4BS = 0xA5, RORG_HRC = 0xA3,
RORG_SYS = 0xA4, RORG_SYS_EX = 0xC5, RORG_SM_LRN_REQ = 0xC6, RORG_SM_LRN_ANS = 0xC7,
RORG_RECLAIM = 0xA7, RORG_SIGNAL = 0xD0, RORG_ADT = 0xA6, GP_TI = 0xB0,
GP_TR = 0xB1, GP_CD = 0xB2, GP_SD = 0xB3, RORG_VLD = 0xD2,
RORG_UTE = 0xD4, RORG_MSC = 0xD1, RORG_CDM = 0x40, RORG_SEC = 0x30,
RORG_SEC_ENCAPS = 0x31, RORG_SECD = 0x32, RORG_SEC_TI = 0x35
}
RORGS. More...

Detailed Description

contains Dolphin API Definitions

Author:
EnOcean GmBH

Enumeration Type Documentation

enum CHOICE_TYPE

Telegram choice codes applies to radio telegram only.

Enumerator:
RADIO_CHOICE_RPS

RPS telegram.

RADIO_CHOICE_1BS

1BS telegram

RADIO_CHOICE_4BS

4BS telegram

RADIO_CHOICE_HRC

HRC telegram.

RADIO_CHOICE_SYS

SYS telegram.

RADIO_CHOICE_SYS_EX

SYS_EX telegram.

RADIO_CHOICE_SM_LRN_REQ

Smart Ack Learn Request telegram.

RADIO_CHOICE_SM_LRN_ANS

Smart Ack Learn Answer telegram.

RADIO_CHOICE_RECLAIM

Smart Ack Reclaim telegram.

RADIO_CHOICE_SIGNAL

Smart Request telegram.

RADIO_CHOICE_ADT

Encapsulated addressable telegram.

RADIO_CHOICE_VLD

Variable Length Data.

RADIO_CHOICE_UTE

Universal Teach In EEP based.

RADIO_CHOICE_MSC

Manufacturer Specific Communication.

RADIO_CHOICE_GP_SINGLE_TREQ

Single Teach-In Request.

RADIO_CHOICE_GP_CHAINED_TREQ

Chained Teach-In Request.

RADIO_CHOICE_GP_SINGLE_TRES

Single Teach-In Response.

RADIO_CHOICE_GP_CHAINED_TRES

Chained Teach-In Response.

RADIO_CHOICE_GP_SINGLE_DATA

Single Data.

RADIO_CHOICE_GP_CHAINED_DATA

Chained Data.

RADIO_CHOICE_GP_SELECT_DATA

Selective data.

RADIO_CHOICE_SEC

Secure telegram.

RADIO_CHOICE_SEC_ENCAPS

Secure telegram with choice encapsulation.

RADIO_CHOICE_NON_SEC

Non-secure telegram.

RADIO_CHOICE_SEC_TI

Secure teach-in telegram.

enum eoReturn

contains all the return values from different functions

Enumerator:
EO_OK

Return values are the same as for the ESP3 command response 0x00 - Action performed. No problem detected

EO_ERROR

0x01 - Generic Error

EO_OK ... command is understood and triggered

NOT_SUPPORTED

0x02 - The functionality is not supported by that implementation

There is an error occurred

WRONG_PARAM

0x03 - There was a wrong function parameter

The functionality is not supported by that implementation

OPERATION_DENIED

0x04 - Operation denied

Wrong function parameter

TIME_OUT

Example: memory access denied (code-protected) EO-Link specific return codes 0x05 - Action couldn't be carried out within a certain time. TIME_OUT

NO_RX

0x06 - No byte or telegram received

NO_RX

ONGOING_RX

0x07 - The UART receive is ongoing

ONGOING_RX

NEW_RX

0x08 - A new byte or telegram received

NEW_RX

BUFF_FULL

0x09 - Buffer full, no space in Tx or Rx buffer

BUFF_FULL

OUT_OF_RANGE

0x0A - Generic out of range return code e.g. address is out of range or the buffer is too small

OUT_OF_RANGE

PORT_ERROR

0x0B - Error Opening Port

PORT_ERROR

USER_CMD

0x80 - User command

NOT_RECOM

0x81 Received message is not a recom message

Return codes greater than 0x80 are used for commands with special return information, not commonly useable.

INVALID_PACKET

0x90 Invalid Packet

NOT_IMPLEMENTED

0xFF - This function is not implemented

NOT_IMPLEMENTED

enum PACKET_TYPE

Packet type (ESP3)

Enumerator:
PACKET_RADIO

Reserved.

PACKET_RESPONSE

Radio telegram.

PACKET_RADIO_SUB_TEL

Response to any packet.

PACKET_EVENT

Radio subtelegram (EnOcean internal function�)

PACKET_COMMON_COMMAND

Event message.

PACKET_SMART_ACK_COMMAND

Common command.

PACKET_REMOTE_MAN_COMMAND

Smart Ack command.

PACKET_PRODUCTION_COMMAND

Remote management command.

PACKET_RADIO_MESSAGE

Production command.

PACKET_RADIO_ADVANCED

!Radio message (chained radio telegrams)

PACKET_RADIO_SET

Advanced protocol radio telegram.

PACKET_DEBUG

set radio stuff&answear

enum RORG_TYPE

RORGS.

Enumerator:
RORG_RPS

RPS telegram.

RORG_1BS

1BS telegram

RORG_4BS

4BS telegram

RORG_HRC

HRC telegram.

RORG_SYS

SYS telegram.

RORG_SYS_EX

SYS_EX telegram.

RORG_SM_LRN_REQ

Smart Ack Learn Request telegram.

RORG_SM_LRN_ANS

Smart Ack Learn Answer telegram.

RORG_RECLAIM

Smart Ack Reclaim telegram.

RORG_SIGNAL

Smart Request telegram.

RORG_ADT

Encapsulated addressable telegram.

GP_TI

Teach-in request.

GP_TR

Teach-in response.

GP_CD

Complete Data.

GP_SD

Selective data.

RORG_VLD

Variable Length Data.

RORG_UTE

Universal Teach In EEP based.

RORG_MSC

Manufacturer Specific Communication.

RORG_CDM

Chained data message.

RORG_SEC

Secure telegram without choice encapsulation.

RORG_SEC_ENCAPS

Secure telegram with choice encapsulation.

RORG_SECD

Secure telegram decrypted.

RORG_SEC_TI

Secure teach-in telegram.

Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoArchive.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoArchive.h File Reference

contains base for Archives More...

#include "eoHalTypes.h"
#include "eoISerialize.h"
#include "eoHeader.h"
Include dependency graph for eoArchive.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoArchive
the base Archive More...

Detailed Description

contains base for Archives

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoArchiveTXT.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Macros
eoArchiveTXT.h File Reference

contains human readable class More...

#include "eoArchive.h"
#include <iostream>
#include <fstream>
#include <sstream>
#include <string>
#include <string.h>
#include <map>
Include dependency graph for eoArchiveTXT.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoArchiveTXT
Archive for Human readable Text files. More...

Macros

#define | _ARCHIVE_TYPE_NAME "_HUMAN_ARCHIVE\0"
Name of the arvice.
#define | _ARCHIVE_VER_MAJOR 0
Version fo the archiver - MAJOR.
#define | _ARCHIVE_VER_MINOR 4
Version fo the archiver - MINOR.

Typedefs

typedef std::map< std::string,
std::string > 		parsed_Items

Detailed Description

contains human readable class

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoChainedMessage.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoChainedMessage.h File Reference
#include "eoMessage.h"
#include "eoChunkMessage.h"
#include <vector>
Include dependency graph for eoChainedMessage.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoChainedMessage

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoChainedReManMessage.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoChainedReManMessage.h File Reference
#include "eoChainedMessage.h"
#include "eoReManMessage.h"
Include dependency graph for eoChainedReManMessage.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoChainedReManMessage

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoChannelEnums.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Macros | Enumerations | Variables
eoChannelEnums.h File Reference

Contains Channel Enums. More...

#include "eoHalTypes.h"
Include dependency graph for eoChannelEnums.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Macros

#define | T_DATA 0x0000
Data type flag.
#define | T_FLAG 0x0F00
Flag type flag.
#define | T_ENUM 0xE000
Enum type flag.
#define | GP_ENUM 0x6000
GP enum type flag.
#define | SP_ABS 0x1000
Absolute Setpoint.
#define | SP_REL 0x2000
Relative Setpoint.
#define | NUM_SIGNAL_STRINGS 0x2C
Number of named signals.
#define | NUM_FLAG_STRINGS 0x11
Number of named flags.
#define | NUM_ENUMS_STRINGS 0x20
Number of named enums.
#define | NUM_GP_ENUMS_STRING 0x06
Number of names GP enums.

Enumerations

enum CHANNEL_TYPE {
S_RES = 0x00, S_ACCEL = 0x01, S_ACCEL_ABS = S_ACCEL + SP_ABS, S_ACCEL_REL = S_ACCEL + SP_REL,
S_ANGLE = 0x02, S_ANGLE_ABS = S_ANGLE + SP_ABS, S_ANGLE_REL = S_ANGLE + SP_REL, S_ANGVD = 0x03,
S_ANGVD_ABS = S_ANGVD + SP_ABS, S_ANGVD_REL = S_ANGVD + SP_REL, S_AREA = 0x04, S_AREA_ABS = S_AREA + SP_ABS,
S_AREA_REL = S_AREA + SP_REL, S_CONC = 0x05, S_CONC_ABS = S_CONC + SP_ABS, S_CONC_REL = S_CONC + SP_REL,
S_CURRENT = 0x06, S_CURRENT_ABS = S_CURRENT + SP_ABS, S_CURRENT_REL = S_CURRENT + SP_REL, S_DISTANCE = 0x07,
S_DISTANCE_ABS = S_DISTANCE + SP_ABS, S_DISTANCE_REL = S_DISTANCE + SP_REL, S_ELECFSTR = 0x08, S_ELECFSTR_ABS = S_ELECFSTR + SP_ABS,
S_ELECFSTR_REL = S_ELECFSTR + SP_REL, S_ENERGY = 0x09, S_ENERGY_ABS = S_ENERGY + SP_ABS, S_ENERGY_REL = S_ENERGY + SP_REL,
S_COUNTER = 0x0A, S_COUNTER_ABS = S_COUNTER + SP_ABS, S_COUNTER_REL = S_COUNTER + SP_REL, S_FORCE = 0x0B,
S_FORCE_ABS = S_FORCE + SP_ABS, S_FORCE_REL = S_FORCE + SP_REL, S_FREQ = 0x0C, S_FREQ_ABS = S_FREQ + SP_ABS,
S_FREQ_REL = S_FREQ + SP_REL, S_HEATFLUX = 0x0D, S_HEATFLUX_ABS = S_HEATFLUX + SP_ABS, S_HEATFLUX_REL = S_HEATFLUX + SP_REL,
S_IMPULSE = 0x0E, S_IMPULSE_ABS = S_IMPULSE + SP_ABS, S_IMPULSE_REL = S_IMPULSE + SP_REL, S_LUMINANCE = 0x0F,
S_LUMINANCE_ABS = S_LUMINANCE + SP_ABS, S_LUMINANCE_REL = S_LUMINANCE + SP_REL, S_MAGNETICF = 0x10, S_MAGNETICF_ABS = S_MAGNETICF + SP_ABS,
S_MAGNETICF_REL = S_MAGNETICF + SP_REL, S_MASS = 0x11, S_MASS_ABS = S_MASS + SP_ABS, S_MASS_REL = S_MASS + SP_REL,
S_MASSDENS = 0x12, S_MASSDENS_ABS = S_MASSDENS + SP_ABS, S_MASSDENS_REL = S_MASSDENS + SP_REL, S_MASSFLOW = 0x13,
S_MASSFLOW_ABS = S_MASSFLOW + SP_ABS, S_MASSFLOW_REL = S_MASSFLOW + SP_REL, S_POWER = 0x14, S_POWER_ABS = S_POWER + SP_ABS,
S_POWER_REL = S_POWER + SP_REL, S_PRESSURE = 0x15, S_PRESSURE_ABS = S_PRESSURE + SP_ABS, S_PRESSURE_REL = S_PRESSURE + SP_REL,
S_RELHUM = 0x16, S_RELHUM_ABS = S_RELHUM + SP_ABS, S_RELHUM_REL = S_RELHUM + SP_REL, S_RESIST = 0x17,
S_RESIST_ABS = S_RESIST + SP_ABS, S_RESIST_REL = S_RESIST + SP_REL, S_TEMP = 0x18, S_TEMP_ABS = S_TEMP + SP_ABS,
S_TEMP_REL = S_TEMP + SP_REL, S_TIME = 0x19, S_TIME_ABS = S_TIME + SP_ABS, S_TIME_REL = S_TIME + SP_REL,
S_TORQUE = 0x1A, S_TORQUE_ABS = S_TORQUE + SP_ABS, S_TORQUE_REL = S_TORQUE + SP_REL, S_VELOCITY = 0x1B,
S_VELOCITY_ABS = S_VELOCITY + SP_ABS, S_VELOCITY_REL = S_VELOCITY + SP_REL, S_VOLTAGE = 0x1C, S_VOLTAGE_ABS = S_VOLTAGE + SP_ABS,
S_VOLTAGE_REL = S_VOLTAGE + SP_REL, S_VOLUME = 0x1D, S_VOLUME_ABS = S_VOLUME + SP_ABS, S_VOLUME_REL = S_VOLUME + SP_REL,
S_VOLFLOW = 0x1E, S_VOLFLOW_ABS = S_VOLFLOW + SP_ABS, S_VOLFLOW_REL = S_VOLFLOW + SP_REL, S_SETPOINT = 0x1F,
S_SETPOINT_ABS = S_SETPOINT + SP_ABS, S_SETPOINT_REL = S_SETPOINT + SP_REL, S_PARTICLES = 0x20, S_PARTICLES_ABS = S_PARTICLES + SP_ABS,
S_PARTICLES_REL = S_PARTICLES + SP_REL, S_DIMMING = 0x21, S_DIMMING_ABS = S_DIMMING + SP_ABS, S_DIMMING_REL = S_DIMMING + SP_REL,
S_SOLAR_RAD = 0x22, S_SOLAR_RAD_ABS = S_SOLAR_RAD + SP_ABS, S_SOLAR_RAD_REL = S_SOLAR_RAD + SP_REL, S_PERCENTAGE = 0x23,
S_PERCENTAGE_ABS = S_PERCENTAGE + SP_ABS, S_PERCENTAGE_REL = S_PERCENTAGE + SP_REL, S_VALUE = 0x24, S_VALUE_ABS = S_VALUE + SP_ABS,
S_VALUE_REL = S_VALUE + SP_REL, S_RGB = 0x25, S_RGB_ABS = S_RGB + SP_ABS, S_RGB_REL = S_RGB + SP_REL,
S_ERROR_CODE = 0x26, S_ERROR_CODE_ABS = S_ERROR_CODE + SP_ABS, S_ERROR_CODE_REL = S_ERROR_CODE + SP_REL, S_RADON_ACTIVITY = 0x27,
S_RADON_ACTIVITY_ABS = S_RADON_ACTIVITY + SP_ABS, S_RADON_ACTIVITY_REL = S_RADON_ACTIVITY + SP_REL, S_AMPER_PER_HOUR = 0x28, S_AMPER_PER_HOUR_ABS = S_AMPER_PER_HOUR + SP_ABS,
S_AMPER_PER_HOUR_REL = S_AMPER_PER_HOUR + SP_REL, S_ROTATION_PER_MIN = 0x29, S_ROTATION_PER_MIN_ABS = S_ROTATION_PER_MIN + SP_ABS, S_ROTATION_PER_MIN_REL = S_ROTATION_PER_MIN + SP_REL,
E_ROCKER_A = T_ENUM + 0x01, E_ROCKER_B = T_ENUM + 0x02, E_ROCKER_C = T_ENUM + 0x03, E_ROCKER_D = T_ENUM + 0x04,
E_ENERGYBOW = T_ENUM + 0x05, E_MULTIPRESS = T_ENUM + 0x06, E_WINDOWHANDLE = T_ENUM + 0x07, E_FANSPEED = T_ENUM + 0x08,
E_TARIFF = T_ENUM + 0x09, E_VOC = T_ENUM + 0x0A, E_CONTROLLER_MODE = T_ENUM + 0x0B, E_ERROR_STATE = T_ENUM + 0x0C,
E_STATE = T_ENUM + 0x0D, E_END_POS = T_ENUM + 0x0E, E_OCCUPANCY = T_ENUM + 0x0F, E_USER_ACTION = T_ENUM + 0x10,
E_PRESENCE = T_ENUM + 0x11, E_DIM_VALUE = T_ENUM + 0x12, E_IO_CHANNEL = T_ENUM + 0x13, E_UNITS = T_ENUM + 0x14,
E_DAYS = T_ENUM + 0x15, E_COMMAND = T_ENUM + 0x16, E_DIRECTION = T_ENUM + 0x17, E_ROOM_SIZE = T_ENUM + 0x18,
E_KEY_DATA = T_ENUM + 0x19, E_GP_MULTIPURPOSE = GP_ENUM + 0x01, E_GP_BUILDING_MODE = GP_ENUM + 0x02, E_GP_OCCUPANCY = GP_ENUM + 0x03,
E_GP_HVAC_MODE = GP_ENUM + 0x04, E_GP_CHANGEOVER_MODE = GP_ENUM + 0x05, F_AUTO_MAN = T_FLAG + 0x01, F_BTN_PRESS = T_FLAG + 0x02,
F_BTN_TRIGGER = T_FLAG + 0x03, F_DAY_NIGHT = T_FLAG + 0x04, F_DOWN = T_FLAG + 0x05, F_GENALARM = T_FLAG + 0x06,
F_HEAT_COOL = T_FLAG + 0x07, F_HIGH_LOW = T_FLAG + 0x08, F_OCCUPIED = T_FLAG + 0x09, F_ON_OFF = T_FLAG + 0x0A,
F_OPEN_CLOSED = T_FLAG + 0x0B, F_POWERALARM = T_FLAG + 0x0C, F_START_STOP = T_FLAG + 0x0D, F_UP = T_FLAG + 0x0E,
F_VIBRATION = T_FLAG + 0x0F, F_RES = T_FLAG + 0xFF
}
enum VALUE_TYPE { VAL_CURR = 0x01, VAL_SP_ABS = 0x02, VAL_SP_REL = 0x03 }
Value types.

Variables

const char | signalStrings [NUM_SIGNAL_STRINGS][2][26]
List of named signal types. When you add a new channel type, you've to update the description!!
const char | flagStrings [NUM_FLAG_STRINGS][32]
String names for flag channles.
const char | enumStrings [NUM_ENUMS_STRINGS][32]
String names for enum channles.
const char | gpEnumString [NUM_GP_ENUMS_STRING][20]
String names for GP enum channels.

Detailed Description

Contains Channel Enums.

Author:
EnOcean GmBH

Variable Documentation

const char enumStrings[NUM_ENUMS_STRINGS][32]
Initial value:
{ "", "Rocker Button A", "Rocker Button B", "Rocker Button C", "Rocker Button D", "Energybow direction", "Multiple Buttons pressed?", "Windowhandle", "Fan Speed", "Tariff information", "VOC (Volatile organic compound)", "Controller mode", "Error state", "State", "End position", "Occupancy", "User action", "Presence", "Dim value", "Input/Output channel", "Units", "Days", "Commands" }

String names for enum channles.

const char flagStrings[NUM_FLAG_STRINGS][32]
Initial value:
{ "", "Automatic flag", "Button pressed",
"Button triggered",
"Day/Night",
"Down",
"General alarm",
"Heat (1) / cool (0)",
"High (1) / low (0)",
"Occupied (1) / unoccupied (0)",
"On (1) / off (0)",
"Open (1) / closed (0)",
"Power alarm (1)",
"Start (1) / stop (0)",
"Up 'p'",
"Vibration(1) / No vibration (0)",
}

String names for flag channles.

const char gpEnumString[NUM_GP_ENUMS_STRING][20]
Initial value:
{
"",
"Multipurpose",
"Bulding Mode",
"Occupancy Mode",
"HVAC Mode",
"Changeover Mode"
}

String names for GP enum channels.

Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoChannelInfo.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Macros
eoChannelInfo.h File Reference

contains the eoChannelInfo Class More...

#include "eoHalTypes.h"
#include "eoChannelEnums.h"
Include dependency graph for eoChannelInfo.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | EEP_ITEM
class | eoChannelInfo
Abstract class for channel information. Abstract class for channel information. From this class specific channel informations classes for Generic Profiles or EEP are derived. More...
class | eoEEPChannelInfo
Specific class for EEP channel information. Class used to decribe the EEP channels. It has the EEP_ITEM to describe the EEP channel values and the subtype - index. More...

Macros

#define | UNIT 0x00
get Unit String
#define | NAME 0x01
get String Name

Detailed Description

contains the eoChannelInfo Class

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoConverter.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Macros
eoConverter.h File Reference

different converter More...

#include "eoHalTypes.h"
#include "eoMessage.h"
#include "eoReManMessage.h"
#include "eoTelegram.h"
#include "eoPacket.h"
#include "eoApiDef.h"
Include dependency graph for eoConverter.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoConverter
contains static Helper Functions More...

Macros

#define | MINIMUM_ADVANCED_DATA_LENGTH 0x06
Define for minimum advanced protocol data length.
#define | SA_RECLAIM_DATA_LENGTH 0x05
Define for advanced SmartAck Reclaim data length.

Detailed Description

different converter

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eodBmFilter.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eodBmFilter.h File Reference

contains a dBm based Filter More...

#include "eoIFilter.h"
#include <set>
Include dependency graph for eodBmFilter.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eodBmFilter
uses Telegram dBm values as filter base More...

Detailed Description

contains a dBm based Filter

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoDebug.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoDebug.h File Reference

eoDebug More...

#include "eoHalTypes.h"
#include "eoMessage.h"
#include "eoTelegram.h"
#include "eoPacket.h"
#include "eoReManMessage.h"
Include dependency graph for eoDebug.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoDebug
helper class for Debug Messages More...

Detailed Description

eoDebug

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoDevice.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoDevice.h File Reference

eoDevice More...

#include "eoSecureInfo.h"
#include "eoProfile.h"
#include "eoISerialize.h"
#include "eoArchive.h"
Include dependency graph for eoDevice.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoDevice
a class to describe an EnOcean Device More...

Detailed Description

eoDevice

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoDeviceManager.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Typedefs
eoDeviceManager.h File Reference

eoDeviceManager More...

#include "eoHalTypes.h"
#include "eoISerialize.h"
#include <map>
Include dependency graph for eoDeviceManager.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoDeviceManager
Manages the devices. More...

Typedefs

typedef std::map< uint32_t,
eoDevice * > 		id_device_map

Detailed Description

eoDeviceManager

Author:
EnOcean GmBH

Typedef Documentation

typedef std::map<uint32_t, eoDevice*> id_device_map

A std::map using the Device ID as key, and containing eoDevice as values.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoEEProfile.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoEEProfile.h File Reference

Profile base class for Enocean Equipment Profiles. More...

#include "eoProfile.h"
Include dependency graph for eoEEProfile.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEProfile
base class for EEProfile parsing More...

Detailed Description

Profile base class for Enocean Equipment Profiles.

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoFilterFactory.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoFilterFactory.h File Reference
#include "eoIFilter.h"
Include dependency graph for eoFilterFactory.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoFilterFactory
helper class for deserialization More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoGateway.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoGateway.h File Reference

eoGateway More...

#include "eoHalTypes.h"
#include "eoApiDef.h"
#include "eoISerialize.h"
#include "eoMessage.h"
#include "eoTelegram.h"
#include "eoDevice.h"
#include "eoIFilter.h"
#include "eoPacketStream.h"
#include "eoDeviceManager.h"
#include "eoMessageHandler.h"
#include "eoSecurity.h"
#include "eoProfileFactory.h"
#include "eoTeachInModule.h"
#include "eoReManMessage.h"
#include "eoSerialCommand.h"
#include "eoIWatcher.h"
#include <queue>
Include dependency graph for eoGateway.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoGateway
EnOcean Gateway class, for handling a gateway Module. More...

Enumerations

enum RECEIVE_FLAGS {
RECV_PACKET = (1 << 0), RECV_TELEGRAM = (1 << 1), RECV_MESSAGE = (1 << 2), RECV_TEACHIN = (1 << 3),
RECV_PROFILE = (1 << 4), RECV_TELEGRAM_SEC = (1 << 5), RECV_ERROR = (1 << 6), RECV_DEVICE_ADDED = (1 << 7),
RECV_SECTEACHIN = (1 << 8), RECV_REMAN = (1 << 9)
}

Detailed Description

eoGateway

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoGenericProfile.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Macros | Enumerations
eoGenericProfile.h File Reference
#include "eoGPChannelInfo.h"
#include "eoProfile.h"
#include <vector>
Include dependency graph for eoGenericProfile.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoGenericProfile
The class to handle Generic Profiles. More...

Macros

#define | GP_MANUFACTURER_LEN 11
Length of manufacturer ID in GP LRN.
#define | GP_PURPOSE_LEN 2
Length of purpose in GP LRN.
#define | GP_DATA_DIRECTION_LEN 1
Length data direction flag ID in GP LRN.
#define | GP_MANUFACTURER_OFF 0
Specific offset for disabled channels.
#define | GP_PURPOSE_OFF 12
Specific offset for disabled channels.
#define | GP_DATA_DIRECTION_OFF 11
Specific offset for disabled channels.

Enumerations

enum | GP_HEADER_PURPOSE { GP_TEACH_IN = 0, GP_TEACH_OUT, GP_TEACH_IN_OUT, RESP_NA }
Purpose of the Teach IN Message.
enum | GP_DATA_DIRECTION { UNIDIRECTIONAL = 0, BIDIRECTIONAL }
Generic Profile Data Direction Information, informs if the Profile is unidirectional or bidirectional.

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoGpChainer.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Typedefs
eoGpChainer.h File Reference
#include "eoChainedMessage.h"
#include <map>
Include dependency graph for eoGpChainer.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoGpChainer

Typedefs

typedef std::map< uint32_t,
eoChainedMessage * > 		id_msg_map
Message container for merging.

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoGPChannelInfo.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Enumerations
eoGPChannelInfo.h File Reference

Enocean GP channel Informations. More...

#include "eoChannelInfo.h"
#include "eoApiDef.h"
#include "eoISerialize.h"
Include dependency graph for eoGPChannelInfo.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoGPChannelInfo
Generic Profile Channel. More...

Enumerations

enum GP_CHANNELTYPE { GP_TEACHIN_INFO = 0, GP_DATA, GP_FLAG, GP_ENUMERATION }
Generic Profile ChannelTypes. More...
enum GP_RESOLUTION {
GP_RES_RES = 0, GP_RES_1BIT = 1, GP_RES_2BIT = 2, GP_RES_3BIT = 3,
GP_RES_4BIT = 4, GP_RES_5BIT = 5, GP_RES_6BIT = 6, GP_RES_8BIT = 8,
GP_RES_10BIT = 10, GP_RES_12BIT = 12, GP_RES_16BIT = 16, GP_RES_20BIT = 20,
GP_RES_24BIT = 24, GP_RES_32BIT = 32
}
Generic Profile Channel Resolution.
enum GP_SCALING {
GP_SCAL_RES = 0, GP_SCAL_1, GP_SCAL_10, GP_SCAL_100,
GP_SCAL_1000, GP_SCAL_10000, GP_SCAL_100000, GP_SCAL_1000000,
GP_SCAL_10000000, GP_SCAL_0_1, GP_SCAL_0_01, GP_SCAL_0_001,
GP_SCAL_0_000001, GP_SCAL_0_000000001
}
Generic Profile Channel Scaling.

Detailed Description

Enocean GP channel Informations.

Describes the available Channeltypes,resolutions and scalings in generic profiles.

Author:
EnOcean GmBH

Enumeration Type Documentation

enum GP_CHANNELTYPE

Generic Profile ChannelTypes.

Enumerator:
GP_TEACHIN_INFO

00 Teach-in Information

GP_TEACHIN_INFO

GP_DATA

01 Complex bit values

GP_DATA

GP_FLAG

Single bit Values.

GP_FLAG

GP_ENUMERATION

Enumerated values.

GP_ENUMERATION

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoHalTypes.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Macros | Typedefs
eoHalTypes.h File Reference
#include <stdint.h>
Include dependency graph for eoHalTypes.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Macros

#define NULL 0
NULL definition.

Typedefs

typedef float float32
Floating point 32 bits.

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoHeader.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoHeader.h File Reference
#include "eoISerialize.h"
Include dependency graph for eoHeader.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoHeader
Helper Class for the Serializations, sets the Archive Header. More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoIDFilter.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Typedefs
eoIDFilter.h File Reference

eoIDFilter More...

#include "eoIFilter.h"
#include <set>
Include dependency graph for eoIDFilter.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoIDFilter
uses EnOcean IDs as filter base More...

Typedefs

typedef std::set< uint32_t > id_set
Definition of the ID Set with 32 bit EnoCean IDs.

Detailed Description

eoIDFilter

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoIFilter.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Enumerations
eoIFilter.h File Reference

eoIFilter More...

#include "eoHalTypes.h"
#include "eoMessage.h"
#include "eoTelegram.h"
#include "eoArchive.h"
Include dependency graph for eoIFilter.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoIFilter
Filter Interface. More...

Enumerations

enum SUPPORTED_FILTERS { eoIDFILTER = 1, eoDBMFILTER }

Detailed Description

eoIFilter

Author:
EnOcean GmBH

Enumeration Type Documentation

enum SUPPORTED_FILTERS

Supported filter types

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoISerialize.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoISerialize.h File Reference
#include "eoHalTypes.h"
#include "eoApiDef.h"
Include dependency graph for eoISerialize.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoISerialize
Interface for storing. More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoISimpleBidirectionalProfile.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Enumerations
eoISimpleBidirectionalProfile.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoISimpleBidirectionalProfile
An interface for profiles which support bidirectional communication, but do not indicate the direction of the messages. More...

Enumerations

enum SIMPLE_DIRECTION { eoController, eoActuator }

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoIWatcher.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Enumerations
eoIWatcher.h File Reference

Watcher Header File. More...

#include "eoDevice.h"
#include "eoTelegram.h"
Include dependency graph for eoIWatcher.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoIWatcher
The minimal Interface for an eoWatcher class. More...

Enumerations

enum SUPPORTED_WATCHER { eoWATCHER = 1 }

Detailed Description

Watcher Header File.

Author:
EnOcean GmbH

An Example Class Header, which allows the security checking of Devices.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoLinuxPacketStream.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoLinuxPacketStream.h File Reference
#include "eoPacketStream.h"
Include dependency graph for eoLinuxPacketStream.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoLinuxPacketStream
PacketStream Implementation for Linux based Systems. More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoLogger.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoLogger.h File Reference
#include "eoApiDef.h"
#include "eoPacket.h"
#include "eoTelegram.h"
#include <stdio.h>
#include <time.h>
Include dependency graph for eoLogger.h:

Go to the source code of this file.

Classes

class eoLogger
Logs Packets. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoManufacturer.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoManufacturer.h File Reference

Manufacturer list. More...

#include "eoHalTypes.h"
Include dependency graph for eoManufacturer.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | eoManufacturer
Manufacturer List. More...
#define | MAX_NAME_LENGTH 42
enum MANUFACTURER_LIST {
MANUFACTURER_RESERVED = 0x000, PEHA = 0x001, THERMOKON = 0x002, SERVODAN = 0x003,
ECHOFLEX_SOLUTIONS = 0x004, OMNIO_AG = 0x005, HARDMEIER_ELECTRONICS = 0x006, REGULVAR_INC = 0x007,
AD_HOC_ELECTRONICS = 0x008, DISTECH_CONTROLS = 0x009, KIEBACK_AND_PETER = 0x00A, ENOCEAN_GMBH = 0x00B,
PROBARE = 0x00C, ELTAKO = 0x00D, LEVITON = 0x00E, HONEYWELL = 0x00F,
SPARTAN_PERIPHERAL_DEVICES = 0x010, SIEMENS = 0x011, T_MAC = 0x012, RELIABLE_CONTROLS_CORPORATION = 0x013,
ELSNER_ELEKTRONIK_GMBH = 0x014, DIEHL_CONTROLS = 0x015, BSC_COMPUTER = 0x016, S_AND_S_REGELTECHNIK_GMBH = 0x017,
MASCO_CORPORATION = 0x018, INTESIS_SOFTWARE_SL = 0x019, VIESSMANN = 0x01A, LUTUO_TECHNOLOGY = 0x01B,
SCHNEIDER_ELECTRIC = 0x01C, SAUTER = 0x01D, BOOT_UP = 0x01E, OSRAM_SYLVANIA = 0x01F,
UNOTECH = 0x020, DELTA_CONTROLS_INC = 0x21, UNITRONIC_AG = 0x022, NANOSENSE = 0x023,
THE_S4_GROUP = 0x024, MSR_SOLUTIONS = 0x025, GE = 0x26, MAICO = 0x027,
RUSKIN_COMPANY = 0x28, MAGNUM_ENERGY_SOLUTIONS = 0x29, KMC_CONTROLS = 0x02A, ECOLOGIX_CONTROLS = 0x02B,
TRIO_2_SYS = 0x2C, AFRISO_EURO_INDEX = 0x02D, NEC_ACCESSTECHNICA_LTD = 0x030, ITEC_CORPORATION = 0x031,
SIMICX_CO_LTD = 0x32, EUROTRONIC_TECHNOLOGY_GMBH = 0x34, ART_JAPAN_CO_LTD = 0x35, TIANSU_AUTOMATION_CONTROL_SYSTE_CO_LTD = 0x36,
GRUPPO_GIORDANO_IDEA_SPA = 0x38, ALPHAEOS_AG = 0x39, TAG_TECHNOLOGIES = 0x3A, CLOUD_BUILDINGS_LTD = 0x3C,
GIGA_CONCEPT = 0x3E, SENSORTEC = 0x3F, JAEGER_DIREKT = 0x40, AIR_SYSTEM_COMPONENTS_INC = 0x41,
MULTI_USER_MANUFACTURER = 0x7FF
}
Manufacturer ID List.

Detailed Description

Manufacturer list.

Author:
EnOcean GmbH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoMessage.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoMessage.h File Reference
#include "eoAbstractMessage.h"
#include "eoHalTypes.h"
Include dependency graph for eoMessage.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoMessage
Message Class for communication. More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoMessageHandler.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoMessageHandler.h File Reference
#include "eoHalTypes.h"
#include "eoMessage.h"
#include "eoTelegram.h"
#include "eoPacket.h"
#include "eoApiDef.h"
#include "eoReManChainer.h"
#include "eoGpChainer.h"
#include "eoSecTeachInChainer.h"
Include dependency graph for eoMessageHandler.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoMessageHandler

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoMSCHelper.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoMSCHelper.h File Reference

MSC Helper. More...

#include "eoManufacturer.h"
#include "eoHalTypes.h"
#include "eoApiDef.h"
#include "eoTelegram.h"
Include dependency graph for eoMSCHelper.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoMSCHelper
contains static Helper Functions More...

Detailed Description

MSC Helper.

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoPacket.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoPacket.h File Reference
#include "eoHalTypes.h"
Include dependency graph for eoPacket.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoPacket
Class which contains a Packet. More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoPacketStream.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Macros
eoPacketStream.h File Reference
#include "eoHalTypes.h"
#include "eoApiDef.h"
#include "eoPacket.h"
Include dependency graph for eoPacketStream.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoPacketStream
The base class for all PacketStreams Implementations. More...

Macros

#define | SER_SYNCH_CODE 0x55
ESP 3 Start of Frame - before header.
#define | SER_HEADER_NR_BYTES 4
ESP 3 Header Lenght.
#define | SER_INTERBYTE_TIME_OUT 100
ESP 3 Timeout between two following bytes.

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoProc.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoProc.h File Reference
#include "eoHalTypes.h"
Include dependency graph for eoProc.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoProc
Helper to calculate different crc. More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoProfile.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoProfile.h File Reference
#include "eoApiDef.h"
#include "eoChannelInfo.h"
#include "eoHalTypes.h"
#include "eoMessage.h"
#include "eoISerialize.h"
#include "eoArchive.h"
#include "eoGPChannelInfo.h"
#include <vector>
Include dependency graph for eoProfile.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoProfile
base class for Profile parsing More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoProfileFactory.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoProfileFactory.h File Reference
#include "eoHalTypes.h"
#include "eoMessage.h"
#include "eoDevice.h"
#include "eoProfile.h"
Include dependency graph for eoProfileFactory.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoProfileFactory
creates Profiles More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoReManChainer.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Typedefs
eoReManChainer.h File Reference
#include "eoChainedMessage.h"
#include "eoChainedReManMessage.h"
#include "eoReManMessage.h"
#include <map>
Include dependency graph for eoReManChainer.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoReManChainer

Typedefs

typedef std::map< uint32_t,
eoChainedReManMessage * > 		id_reman_msg_map
Message container for merging.

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoReManMessage.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoReManMessage.h File Reference
#include "eoMessage.h"
#include "eoAbstractMessage.h"
Include dependency graph for eoReManMessage.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoReManMessage

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoRemoteManager.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Enumerations
eoRemoteManager.h File Reference

eoRemoteManager More...

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | QUERY_ID
Query ID structure. More...
struct | QUERY_FUNCTION_RESPONSE
Query function response structure. More...
struct | PING_RESPONSE
Ping response structure. More...
struct | QUERY_STATUS_RESPONSE
Query status response structure. More...
struct | FLASH_READ_RESPONSE
Flash read response structure. More...
struct | MAILBOX_SETTINGS_RESPONSE
Mailbox settings response structure. More...
struct | LEARNED_SENSOR_RESPONSE
Learned sensors response structure. More...
class | eoRemoteManager
Remote Manager interface class. More...

Enumerations

enum REMOTE_TYPE {
R_START_LEARN = 1, R_NEXT_CHANNEL, R_STOP_LEARN, R_S_SIMPLE_LEARN,
R_S_ADVANCED_LEARN, R_S_STOP_LEARN
}
Remote learn types. More...
enum FN_CODE {
FN_UNLOCK = 0x001, FN_LOCK = 0x002, FN_SETCODE = 0x003, FN_QUERYID = 0x004,
FN_QUERYID_ANSWER = 0x604, FN_ACTION = 0x005, FN_PING = 0x006, FN_PING_ANSWER = 0x606,
FN_QUERY_FUNCTION = 0x007, FN_QUERY_FUNCTION_ANSWER = 0x607, FN_QUERY_STATUS = 0x008, FN_QUERY_STATUS_ANSWER = 0x608,
FN_REMOTE_LEARNIN = 0x201, FN_REMOTE_FLASH_WRITE = 0x203, FN_REMOTE_FLASH_READ = 0x204, FN_REMOTE_FLASH_READ_ANSWER = 0x804,
FN_SMARTACK_READ = 0x205, FN_SMARTACK_READ_MAILBOX_ANSWER = 0x805, FN_SMARTACK_READ_LEARNED_SENSOR_ANSWER = 0x806, FN_SMARTACK_WRITE = 0x206
}
Function codes. More...

Detailed Description

eoRemoteManager

Author:
EnOcean GmBH

Enumeration Type Documentation

enum FN_CODE

Function codes.

Enumerator:
FN_UNLOCK

Unlock.

FN_LOCK

Lock.

FN_SETCODE

Query ID.

FN_QUERYID

Query ID.

FN_QUERYID_ANSWER

Query ID answer.

FN_ACTION

Action.

FN_PING

Ping.

FN_PING_ANSWER

Ping answer.

FN_QUERY_FUNCTION

Query function.

FN_QUERY_FUNCTION_ANSWER

Query function answer.

FN_QUERY_STATUS

Query status.

FN_QUERY_STATUS_ANSWER

Query status answer.

FN_REMOTE_LEARNIN

Remote learn in.

FN_REMOTE_FLASH_WRITE

Remote flash write.

FN_REMOTE_FLASH_READ

Remote flash read.

FN_REMOTE_FLASH_READ_ANSWER

Remote flash read answer.

FN_SMARTACK_READ

SmartACK read.

FN_SMARTACK_READ_MAILBOX_ANSWER

SmartACK read mailbox answer.

FN_SMARTACK_READ_LEARNED_SENSOR_ANSWER

SmartACK read learned sensor answer.

FN_SMARTACK_WRITE

SmartACK write.

enum REMOTE_TYPE

Remote learn types.

Enumerator:
R_START_LEARN

Start learning.

R_NEXT_CHANNEL

Next channel.

R_STOP_LEARN

Stop learning.

R_S_SIMPLE_LEARN

SmartACK start simple learn mode.

R_S_ADVANCED_LEARN

SmartACK start advanced learn mode.

R_S_STOP_LEARN

SmartACK stop learn mode.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoRollingCodeStorage.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoRollingCodeStorage.h File Reference
#include "eoHalTypes.h"
#include "eoApiDef.h"
#include <map>
Include dependency graph for eoRollingCodeStorage.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoRollingCodeStorage
Manages the rolling codes. More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoSecTeachInChainer.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Typedefs
eoSecTeachInChainer.h File Reference
#include "eoChainedMessage.h"
#include <map>
Include dependency graph for eoSecTeachInChainer.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoSecTeachInChainer

Typedefs

typedef std::map< uint32_t,
eoChainedMessage * > 		id_msg_map
Message container for merging.

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoSecureInfo.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Macros
eoSecureInfo.h File Reference
#include "api/sec_api.h"
#include "eoHalTypes.h"
#include "eoISerialize.h"
#include "eoArchive.h"
Include dependency graph for eoSecureInfo.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoSecureInfo

Macros

#define | SLF_DATA_ENC_OFF 0
No Data Encryption.
#define | SLF_DATA_ENC_AES128 0x04
Encryption via AES-AES128.
#define | SLF_DATA_ENC_VAES128 0x03
Encryption via VAES-AES128.
#define | SLF_MAC_OFF (0<<3)
CMAC is off.
#define | SLF_MAC_3BYTE (1<<3)
3Byte CMAC
#define | SLF_MAC_4BYTE (2<<3)
4Byte CMAC
#define | SLF_RLC_TX_OFF (0<<5)
don't send RLC
#define | SLF_RLC_TX_ON (1<<5)
transmit RLC via TX
#define | SLF_RLC_ALGO_OFF (0<<6)
RLC OFF.
#define | SLF_RLC_ALGO_16BIT (1<<6)
2byte RLC
#define | SLF_RLC_ALGO_24BIT (2<<6)
3byte RLC
#define | TEACH_INFO_PSK (1<<3)
TeachInfo - Use PSK.
#define | TEACH_INFO_PTM (1<<2)
TeachInfo - PTM Type.
#define | TEACH_INFO_PTM_ROCKERA (0<<0)
TeachInfo - ROCKER A normal Teach In for PTM Type.
#define | TEACH_INFO_PTM_ROCKERB (1<<0)
TeachInfo - ROCKER B normal Teach In for PTM Type.
#define | TEACH_INFO_UNIDIR (0<<0)
TeachInfo - Unidirectional security teach-in procedure.
#define | TEACH_INFO_BIDIR (1<<0)
TeachInfo - ROCKER B normal Teach In.

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoSecurity.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoSecurity.h File Reference
#include "eoMessage.h"
#include "eoDevice.h"
#include "api/sec.h"
#include "api/sec_api.h"
Include dependency graph for eoSecurity.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoSecurity
handles EnOcean Security Telegrams More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoSerialCommand.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Enumerations
eoSerialCommand.h File Reference

eoSerialCommand More...

#include "eoHalTypes.h"
#include "eoApiDef.h"
#include "eoPacket.h"
Include dependency graph for eoSerialCommand.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CO_RD_VERSION_RESPONSE
Read version response. More...
class | CO_RD_IDBASE_RESPONSE
Read base ID response. More...
class | CO_RD_REPEATER_RESPONSE
Read repeater response. More...
class | CO_RD_FILTER_RESPONSE
Read filter response. More...
struct | SA_CONFIRM_LEARN_REQUEST
Confirm Learn response. More...
class | SA_LEARN_ACK_RESPONSE
Learn SmartAck response. More...
class | CO_READY_RESPONSE
Ready response. More...
class | SA_RD_LEARNMODE_RESPONSE
SmartAck read learnmode response structure. More...
class | SA_RD_LEARNEDCLIENTS_RESPONSE
SmartAck learned clients response structure. More...
struct | CO_RD_DUTYCYCLE_RESPONSE
Read actual duty cycle limit structure. More...
class | eoSerialCommand
EnOcean Common Commands class, enables an easy interface for the most common commands. More...

Enumerations

enum COMMON_COMMAND_TYPE {
CO_WR_SLEEP = 1, CO_WR_RESET = 2, CO_RD_VERSION = 3, CO_RD_SYS_LOG = 4,
CO_WR_SYS_LOG = 5, CO_WR_BIST = 6, CO_WR_IDBASE = 7, CO_RD_IDBASE = 8,
CO_WR_REPEATER = 9, CO_RD_REPEATER = 10, CO_WR_FILTER_ADD = 11, CO_WR_FILTER_DEL = 12,
CO_WR_FILTER_DEL_ALL = 13, CO_WR_FILTER_ENABLE = 14, CO_RD_FILTER = 15, CO_WR_WAIT_MATURITY = 16,
CO_WR_SUBTEL = 17, CO_WR_MEM = 18, CO_RD_MEM = 19, CO_RD_MEM_ADDRESS = 20,
CO_RD_SECURITY = 21, CO_WR_SECURITY = 22, CO_WR_MODE = 28, CO_RD_DUTYCYCLE_LIMIT = 35
}
The most common commands for ESP3. More...
enum | FILTER_KIND { BLOCK_RADIO = 0x00, APPLY_RADIO = 0x80, BLOCK_REPEATED = 0x40, APPLY_REPEATED = 0xC0 }
Filter kinds. More...
enum | FILTER_TYPE { SOURCE_ID = 0, CHOICE = 1, DBM = 2, DESTINATION_ID = 0 }
Filter types. More...
enum | FILTER_OPERATOR { OR = 0, AND = 1 }
Filter operator. More...
enum SA_EVENT_TYPE {
SA_RECLAIM_NOT_SUCCESSFUL = 1, SA_CONFIRM_LEARN = 2, SA_LEARN_ACK = 3, SA_READY = 4,
SA_DUTYCYCLE_LIMIT = 6
}
Common command enum. More...
enum SA_CONFIRM_CODE {
SA_LEARN_IN = 0x00, SA_EEP_NOT_ACCEPTED = 0x11, SA_PM_FULL = 0x12, SA_CONTROLLER_FULL = 0x13,
SA_RSSI_NOT_GOOD = 0x14, SA_LEARN_OUT = 0x20, SA_NOT_SUPPORTED = 0xFF
}
Confirm code enum. More...
enum EC_RESET_CAUSE {
EC_VOLTAGE_DROP = 0x00, EC_RESET_PIN = 0x01, EC_WATCHDOG_TIMER = 0x02, EC_FLYWHEEL_TIMER = 0x03,
EC_PARITY_ERROR = 0x04, EC_PARITY_MEM_ERROR = 0x05, EC_MEM_ERRPR = 0x06, EC_WAKE_PIN_0 = 0x07,
EC_WAKE_PIN_1 = 0x08, EC_UNKNOWN = 0x09
}
Reset cause according ESP 3. More...
enum | WR_MODE_CODE { MODE_COMPATIBLE = 0x00, MODE_ADVANCED = 0x01 }
Types of mode. More...
enum SA_COMMAND_TYPE {
SA_WR_LEARNMODE = 1, SA_RD_LEARNMODE = 2, SA_WR_LEARNCONFIRM = 3, SA_WR_CLIENTLEARNRQ = 4,
SA_WR_RESET = 5, SA_RD_LEARNEDCLIENTS = 6, SA_WR_RECLAIMS = 7, SA_WR_POSTMASTER = 8
}
SmartAck command enum. More...
enum | SMARTACK_CONFIRM_CODE { SA_CC_LEARNIN = 0X00, SA_CC_LEARNOUT = 0X20 }
SmartAck confirm code enum send to gateway in serial command. More...
enum | SA_EXTENDED_LEARNMODE { SA_EL_SIMPLE = 0X00, SA_EL_ADVANCE = 0X01, SA_EL_ADVANCE_REP = 0X02 }
SmartAck extended learnmode enum. More...
enum | CO_DUTYCYCLE_LIMIT { CO_DUTYCYCLE_LIMIT_UNREACHED = 0x00, CO_DUTYCYCLE_LIMIT_REACHED = 0x01 }
Duty cycle limit enum. More...

Detailed Description

eoSerialCommand

Author:
EnOcean GmBH

Enumeration Type Documentation

enum CO_DUTYCYCLE_LIMIT

Duty cycle limit enum.

Enumerator:
CO_DUTYCYCLE_LIMIT_UNREACHED

Duty cycle limit released, possible to send telegrams.

CO_DUTYCYCLE_LIMIT_REACHED

Duty cycle limit reached, no more telegrams will be sent.

enum COMMON_COMMAND_TYPE

The most common commands for ESP3.

Enumerator:
CO_WR_SLEEP

Order to enter in energy saving mode.

CO_WR_RESET

Order to reset the device.

CO_RD_VERSION

Read the device (SW) version / (HW) version, chip ID etc.

CO_RD_SYS_LOG

Read system log from device databank.

CO_WR_SYS_LOG

Reset System log from device databank.

CO_WR_BIST

Perform Flash BIST operation.

CO_WR_IDBASE

Write ID range base number.

CO_RD_IDBASE

Read ID range base number.

CO_WR_REPEATER

Write Repeater Level off,1,2.

CO_RD_REPEATER

Read Repeater Level off,1,2.

CO_WR_FILTER_ADD

Add filter to filter list.

CO_WR_FILTER_DEL

Delete filter from filter list.

CO_WR_FILTER_DEL_ALL

Delete filters.

CO_WR_FILTER_ENABLE

Enable/Disable supplied filters.

CO_RD_FILTER

Read supplied filters.

CO_WR_WAIT_MATURITY

Waiting till end of maturity time before received radio telegrams will transmitted.

CO_WR_SUBTEL

Enable/Disable transmitting additional subtelegram info.

CO_WR_MEM

Write x bytes of the Flash, XRAM, RAM0 ….

CO_RD_MEM

Read x bytes of the Flash, XRAM, RAM0 ….

CO_RD_MEM_ADDRESS

Feedback about the used address and length of the config area and the Smart Ack Table.

CO_RD_SECURITY

Read security informations (level, keys)

CO_WR_SECURITY

Write security informations (level, keys)

CO_WR_MODE

Write mode, Advanced or Compatible mode.

CO_RD_DUTYCYCLE_LIMIT

Read duty cycle limit.

enum EC_RESET_CAUSE

Reset cause according ESP 3.

Enumerator:
EC_VOLTAGE_DROP

Voltage supply drop or indicates that VDD > VON.

EC_RESET_PIN

Reset caused by usage of the reset pin.

EC_WATCHDOG_TIMER

Watchdog timer counter reached the time period.

EC_FLYWHEEL_TIMER

Flywheel timer counter reached the time period.

EC_PARITY_ERROR

Parity error.

EC_PARITY_MEM_ERROR

HW Parity error in internal or external memory.

EC_MEM_ERRPR

CPU memory request does not correspond to valid memory location.

EC_WAKE_PIN_0

Wake-up pint 0 activated.

EC_WAKE_PIN_1

Wake-up pint 1 activated.

EC_UNKNOWN

Unknown reset source.

enum FILTER_KIND

Filter kinds.

Enumerator:
BLOCK_RADIO

Blocking radio filter.

APPLY_RADIO

Applying radio filter.

BLOCK_REPEATED

Block filtered repeating.

APPLY_REPEATED

Apply filtered repeating.

enum FILTER_OPERATOR

Filter operator.

Enumerator:
OR

OR composition of filters.

AND

AND composition of filters.

enum FILTER_TYPE

Filter types.

Enumerator:
SOURCE_ID

Source ID filter.

CHOICE

Choice filter.

DBM

dBm filter

DESTINATION_ID

Destination ID filter.

enum SA_COMMAND_TYPE

SmartAck command enum.

Enumerator:
SA_WR_LEARNMODE

Set/Reset Smart Ack learn mode.

SA_RD_LEARNMODE

Get Smart Ack learn mode state.

SA_WR_LEARNCONFIRM

Used for Smart Ack to add or delete a mailbox of a client.

SA_WR_CLIENTLEARNRQ

Send Smart Ack Learn request (Client)

SA_WR_RESET

Send reset command to every SA sensor.

SA_RD_LEARNEDCLIENTS

Get Smart Ack learned sensors / mailboxes.

SA_WR_RECLAIMS

Set number of reclaim attempts.

SA_WR_POSTMASTER

Activate/Deactivate Post master functionality.

enum SA_CONFIRM_CODE

Confirm code enum.

Enumerator:
SA_LEARN_IN

Learn IN.

SA_EEP_NOT_ACCEPTED

Discard Learn IN, EEP not accepted.

SA_PM_FULL

Discard Learn IN, PM has no place for further mailbox.

SA_CONTROLLER_FULL

Discard Learn IN, Controller has no place for new sensor.

SA_RSSI_NOT_GOOD

Discard Learn IN, RSSI was not good enough.

SA_LEARN_OUT

Learn OUT.

SA_NOT_SUPPORTED

Function not supported.

enum SA_EVENT_TYPE

Common command enum.

Enumerator:
SA_RECLAIM_NOT_SUCCESSFUL

Informs the backbone of a Smart Ack Client to not successful reclaim.

SA_CONFIRM_LEARN

Used for SMACK to confirm/discard learn in/out.

SA_LEARN_ACK

Inform backbone about result of learn request.

SA_READY

Inform backbone about about the readiness for operation.

SA_DUTYCYCLE_LIMIT

Informs backbone about duty cycle limit.

enum SA_EXTENDED_LEARNMODE

SmartAck extended learnmode enum.

Enumerator:
SA_EL_SIMPLE

Simple Learnmode.

SA_EL_ADVANCE

Advanced Learnmode.

SA_EL_ADVANCE_REP

Advanced Learnmode select Rep.

enum SMARTACK_CONFIRM_CODE

SmartAck confirm code enum send to gateway in serial command.

Enumerator:
SA_CC_LEARNIN

Learn IN.

SA_CC_LEARNOUT

Learn OUT.

enum WR_MODE_CODE

Types of mode.

Enumerator:
MODE_COMPATIBLE

Compatible mode (default)

MODE_ADVANCED

Advanced mode.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoStorageManager.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Macros | Typedefs
eoStorageManager.h File Reference
#include "eoArchive.h"
#include "eoHeader.h"
#include "eoISerialize.h"
#include "eoConverter.h"
#include "eoHalTypes.h"
#include <string.h>
#include <map>
Include dependency graph for eoStorageManager.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | serialize_object
Serialised obejct type definition to save learned devices. More...
class | eoStorageManager
handles the Storage of Object More...

Macros

#define EO_STORAGE_IDENTIFIER "_EOLINK_SAVE"
Storage indentifier.- can be changed.

Typedefs

typedef std::map< uint32_t,
serialize_object * > 		name_object_map
Map type definition for serialized objects.

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoTeachInModule.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Typedefs | Enumerations
eoTeachInModule.h File Reference
#include "eoHalTypes.h"
#include "eoMessage.h"
#include "eoDevice.h"
#include "eoISerialize.h"
#include <map>
Include dependency graph for eoTeachInModule.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | TEACH_STRUCT
Teach message structure. More...
class | eoTeachInModule
handles TeachIn Messages More...

Typedefs

typedef std::map< uint32_t, bool > teach_id_map
Map type definition for teached devices.

Enumerations

enum TEACH_RETURN {
NO_TEACH_IN = 0, NEW_DEVICE, EEP_TEACH_IN, NEW_DEVICE_AND_EPP,
SECURITY_TEACH_IN, SECOND_TEACH_IN, GENERIC_TEACH_IN
}
Teach process return codes. More...
enum | UTE_RESPONSE { GENERAL_REASON = 0, TEACH_IN_ACCEPTED = 1, TEACH_OUT_ACCEPTED = 2, EEP_NOT_SUPPORTED = 3 }
UTE Response codes. More...
enum | UTE_DIRECTION { UTE_DIRECTION_UNIDIRECTIONAL = 0, UTE_DIRECTION_BIDIRECTIONAL = 1 }
UTE Direction response codes. More...
enum | GP_RESPONSE_RESULT { RESP_REJECTED_GENERALLY = 0, RESP_TEACHIN, RESP_TEACHOUT, RESP_REJECTED_CHANNELS }
Result after a Teach IN.

Detailed Description

Author:
EnOcean GmBH

Enumeration Type Documentation

enum TEACH_RETURN

Teach process return codes.

Enumerator:
NO_TEACH_IN

0 -Tried to add an object with the same name, which differ!

NO_TEACH_IN

NEW_DEVICE

1 -Added a new device

NEW_DEVICE

EEP_TEACH_IN

2 - EEP teach in has been set

EEP_TEACH_IN

NEW_DEVICE_AND_EPP

3- EEP teach in and new Device

NEW_DEVICE_AND_EPP

SECURITY_TEACH_IN

4- SECURITY Teach IN

SECURITY_TEACH_IN

SECOND_TEACH_IN

5- RECEIVED A SECOND TEACH IN

SECOND_TEACH_IN

GENERIC_TEACH_IN

6- GP teach in

GP_TEACH_IN

enum UTE_DIRECTION

UTE Direction response codes.

Enumerator:
UTE_DIRECTION_UNIDIRECTIONAL

0 - Unidirectional

UTE_DIRECTION_UNIDIRECTIONAL

UTE_DIRECTION_BIDIRECTIONAL

1 - Bidirectional

UTE_DIRECTION_BIDIRECTIONAL

enum UTE_RESPONSE

UTE Response codes.

Enumerator:
GENERAL_REASON

0 - Request not accepted because of general reason

GENERAL_REASON

TEACH_IN_ACCEPTED

1 - Request accepted, teach-in successful

TEACH_IN_ACCEPTED

TEACH_OUT_ACCEPTED

2 - Request accepted, deletion of teach-in successful

TEACH_OUT_ACCEPTED

EEP_NOT_SUPPORTED

3 - Request not accepted, EEP not supported

EEP_NOT_SUPPORTED

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoTelegram.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoTelegram.h File Reference
#include "eoMessage.h"
Include dependency graph for eoTelegram.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoTelegram
every Communication from an EnOcean Device to another one consist out of one more Telegrams. The eoTelegram class contains the payload Data from one Telegram. More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoTimer.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoTimer.h File Reference
#include "eoHalTypes.h"
Include dependency graph for eoTimer.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoTimer
tickCount helper More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoWatcher.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes | Typedefs | Enumerations
eoWatcher.h File Reference

Watcher Header File. More...

#include "eoDevice.h"
#include "eoTimer.h"
#include "eoIWatcher.h"
#include <vector>
#include <map>
#include <stdint.h>
Include dependency graph for eoWatcher.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | WATCH_STRUCT
Watch structure. More...
class | eoWatcher
an example implementation of an Security Watcher Class which tries to predict DOS and Delay Attacks. More...

Typedefs

typedef std::map< uint32_t,
WATCH_STRUCT > 		watcher_id_map

Enumerations

enum EO_SEC_WATCH_RESULT {
WATCH_OK = 0, WATCH_DEVICE_NA, WATCH_DEVICE_ALREADY_EXIST, WATCH_NOT_SECURE_DEVICE,
WATCH_NOT_WATCHED_DEVICE, WATCH_DOS_ASSUMED, WATCH_DELAY_ASSUMED, WATCH_TEL_TO_EARLY,
WATCH_TEL_TO_LATE, WATCH_CMAC_OVERFLOW, WATCH_RLC_OVERFLOW
}
Security Watch Result. More...

Detailed Description

Watcher Header File.

Author:
EnOcean GmbH

An Example Class Header, which allows the security checking of Devices.

Enumeration Type Documentation

enum EO_SEC_WATCH_RESULT

Security Watch Result.

Enumerator:
WATCH_OK

Device is watched and no security issues.

WATCH_DEVICE_NA

Device does not exist.

WATCH_DEVICE_ALREADY_EXIST

Device duplicated.

WATCH_NOT_SECURE_DEVICE

You tried to added a non secure device or the watched device does not have valid security information.

WATCH_NOT_WATCHED_DEVICE

The processed device&message is not watched.

WATCH_DOS_ASSUMED

A denial of service is assumed.

WATCH_DELAY_ASSUMED

A Delay attack is assumed.

WATCH_TEL_TO_EARLY

The telegram of the watched device came to early.

WATCH_TEL_TO_LATE

The telegram of the watched device came to late.

WATCH_CMAC_OVERFLOW

The counter of maximal allowed telegrams with wrong cmacs has been reached.

WATCH_RLC_OVERFLOW

The Difference RLC of the last and current has reached the allowed one.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoWatcherFactory.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
Classes
eoWatcherFactory.h File Reference
#include "eoIWatcher.h"
Include dependency graph for eoWatcherFactory.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoWatcherFactory
helper class for deserialization More...

Detailed Description

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/ Directory Reference

  • SourceCode
  • EOLink
  • Profiles
Profiles Directory Reference
Directory dependency graph for E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/:

Files

file | eoA5EEProfile.h [code]
file | eoD2EEProfile.h [code]
file | eoEEP_A502xx.h [code]
file | eoEEP_A504xx.h [code]
file | eoEEP_A505xx.h [code]
file | eoEEP_A506xx.h [code]
file | eoEEP_A507xx.h [code]
file | eoEEP_A508xx.h [code]
file | eoEEP_A509xx.h [code]
file | eoEEP_A510xx.h [code]
file | eoEEP_A511xx.h [code]
file | eoEEP_A512xx.h [code]
file | eoEEP_A513xx.h [code]
file | eoEEP_A514xx.h [code]
file | eoEEP_A520xx.h [code]
file | eoEEP_A530xx.h [code]
file | eoEEP_A537xx.h [code]
file | eoEEP_A538xx.h [code]
file | eoEEP_D200xx.h [code]
file | eoEEP_D201xx.h [code]
file | eoEEP_D202xx.h [code]
file | eoEEP_D203xx.h [code]
file | eoEEP_D204xx.h [code]
file | eoEEP_D205xx.h [code]
file | eoEEP_D206xx.h [code]
file | eoEEP_D210xx.h [code]
file | eoEEP_D220xx.h [code]
file | eoEEP_D230xx.h [code]
file | eoEEP_D231xx.h [code]
file | eoEEP_D232xx.h [code]
file | eoEEP_D240xx.h [code]
file | eoEEP_D250xx.h [code]
file | eoEEP_D2A0xx.h [code]
file | eoEEP_D500xx.h [code]
file | eoEEP_F602xx.h [code]
file | eoEEP_F603xx.h [code]
file | eoEEP_F604xx.h [code]
file | eoEEP_F605xx.h [code]
file | eoEEP_F610xx.h [code]
file | eoF6EEProfile.h [code]
file | eoSpecialProfile.h [code]
Wrapper for includes.
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoA5EEProfile.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes | Enumerations
eoA5EEProfile.h File Reference
#include "eoEEProfile.h"
#include "eoApiDef.h"
Include dependency graph for eoA5EEProfile.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoA5EEProfile
EnOcean Equipment Profiles. More...

Enumerations

enum ENUM_FAN_SPEED_5STAGE {
STAGE_3 = 0, STAGE_2 = 1, STAGE_1 = 2, STAGE_0 = 3,
STAGE_AUTO = 4
}
Fan Speed for 5 Stages ie A5-10-01. More...
enum ENUM_FAN_SPEED_7STAGE {
SPEED_AUTO = 0, SPEED_0 = 1, SPEED_1 = 2, SPEED_2 = 3,
SPEED_3 = 4, SPEED_4 = 5, SPEED_5 = 6, SPEED_OFF = 7
}
Fan Speed for 7 Stages ie A5-10-18. More...
enum ENUM_VOC {
VOC_total = 0, VOC_Formaldehyde = 1, VOC_Benzene = 2, VOC_Styrene = 3,
VOC_Toluene = 4, VOC_Tetrachloroethylene = 5, VOC_Xylene = 6, VOC_n_Hexane = 7,
VOC_n_Octane = 8, VOC_Cyclopentane = 9, VOC_Methanol = 10, VOC_Ethanol = 11,
VOC_1_Pentanol = 12, VOC_Acetone = 13, VOC_ethylene_oxide = 14, VOC_Acetaldehyde_ue = 15,
VOC_Acetic_Acid = 16, VOC_Propionice_Acid = 17, VOC_Valeric_Acid = 18, VOC_Butyric_Acid = 19,
VOC_Ammoniac = 20, VOC_Hydrogen_Sulfide = 21, VOC_Dimethylsulfide = 22, VOC_2_Butanol = 23,
VOC_2_Methylpropanol = 24, VOC_Diethyl_ether = 25, VOC_ozone = 255
}
VOC (Volatile organic compound) Enum definition for a5-09-05.

Detailed Description

Author:
EnOcean GmbH

Enumeration Type Documentation

enum ENUM_FAN_SPEED_5STAGE

Fan Speed for 5 Stages ie A5-10-01.

Enumerator:
STAGE_3

Stage 3 0..144

STAGE_2

Stage 2 145..164

STAGE_1

Stage 1 165..189

STAGE_0

Stage 0 190..209

STAGE_AUTO

Stage Auto210..255

enum ENUM_FAN_SPEED_7STAGE

Fan Speed for 7 Stages ie A5-10-18.

Enumerator:
SPEED_AUTO

Stage Auto 0

SPEED_0

Speed 0 1

SPEED_1

Speed 1 2

SPEED_2

Speed 2 3

SPEED_3

Speed 3 4

SPEED_4

Speed 4 5

SPEED_5

Speed 5 6

SPEED_OFF

Speed Off 7

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoD2EEProfile.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoD2EEProfile.h File Reference
#include "eoEEProfile.h"
#include "eoApiDef.h"
Include dependency graph for eoD2EEProfile.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoD2EEProfile
EnOcean Equipment Profiles. More...

Detailed Description

Author:
EnOcean GmbH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A502xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A502xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A502xx.h:

Go to the source code of this file.

Classes

class eoEEP_A502xx
The class to handle EEP a502 profiles. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A504xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A504xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A504xx.h:

Go to the source code of this file.

Classes

class eoEEP_A504xx
The class to handle EEP a504 profiles. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A505xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A505xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A505xx.h:

Go to the source code of this file.

Classes

class eoEEP_A505xx
The class to handle EEP a505 profiles. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A506xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A506xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A506xx.h:

Go to the source code of this file.

Classes

class eoEEP_A506xx
The class to handle EEP a506 profiles. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A507xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A507xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A507xx.h:

Go to the source code of this file.

Classes

class eoEEP_A507xx
The class to handle EEP a507 profiles. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A508xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A508xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A508xx.h:

Go to the source code of this file.

Classes

class eoEEP_A508xx
The class to handle EEP a508 profiles. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A509xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A509xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A509xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_A509xx
The class to handle EEP a509 profiles. More...

Enumerations

enum | ENUM_PARTICLES_SIZE { PM10 = 0x00, PM2_5 = 0x01, PM1 = 0x02 }
Particle size in A5-09-07 profile. More...
enum | ENUM_RADIATION_UNIT { USV_H = 0x00, CPM = 0x01, BQ_L = 0x02, BQ_KG = 0x03 }
The unit of the radiation level in A5-09-0A profile. More...
enum | ENUM_POWER_FAILURE_DETECTION { NO_POWER_FAILURE = 0x00, POWER_FAILURE_DETECTED = 0x01 }
Power failure detection. More...

Detailed Description

Enumeration Type Documentation

enum ENUM_PARTICLES_SIZE

Particle size in A5-09-07 profile.

Enumerator:
PM10

Particles 10 0

PM2_5

Particles 2.5 1

PM1

Particles 1 2

enum ENUM_POWER_FAILURE_DETECTION

Power failure detection.

Enumerator:
NO_POWER_FAILURE

Power failure not detected 0

POWER_FAILURE_DETECTED

Power failure detected 1

enum ENUM_RADIATION_UNIT

The unit of the radiation level in A5-09-0A profile.

Enumerator:
USV_H

uSv/h 0

CPM

Cpm 1

BQ_L

Bq/L 2

BQ_KG

Bq/kg 2

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A510xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A510xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A510xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_A510xx
The class to handle EEP a510 profiles. More...

Enumerations

enum | ROP_1F_BUTTONS { OCCUPANCY = 0x00, UNOCCUPANCY = 0x01 }
Buttons for A5-10-1F profile. More...
enum | ROP_SET_POINT_MODE { ROP_ROOM_TEMP_DEFINED = 0, ROP_FROST_PROTECTION = 1, ROP_AUTOMATIC_CONTROL = 2 }
Enums for Set point mode. More...
enum | ROP_USER_ACTIVITY { ROP_NO_USER_ACTIVITY = 0, ROP_USER_INTERACTION = 1 }
Enums for User activity. More...

Detailed Description

Enumeration Type Documentation

enum ROP_1F_BUTTONS

Buttons for A5-10-1F profile.

Enumerator:
OCCUPANCY

Occupancy 0

UNOCCUPANCY

Unoccupancy 1

enum ROP_SET_POINT_MODE

Enums for Set point mode.

Enumerator:
ROP_ROOM_TEMP_DEFINED

0 Room temperature defined by SP

ROP_FROST_PROTECTION

1 Frost protection

ROP_AUTOMATIC_CONTROL

2 Automatic control

enum ROP_USER_ACTIVITY

Enums for User activity.

Enumerator:
ROP_NO_USER_ACTIVITY

0 No user action

ROP_USER_INTERACTION

1 User interaction

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A511xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A511xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A511xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_A511xx
The class to handle EEP a511 profiles. More...

Enumerations

enum CS_INDEXES {
CS_REPEATER = 0x00, CS_POWER_RELAY_TIMER = 0x01, CS_DAYLIGHT_HARVEST = 0x02, CS_DIMMING = 0x03,
CS_POWER_RELAY = 0x04, CS_ALARM = 0x05, CS_CONTROLLER_STATE = 0x06, CS_ENERGY_HOLDOFF = 0x07,
CS_ANGLE_SIGN = 0x08, CS_POSITION_VALUE = 0x09, CS_ANGLE_VALUE = 0x0A, CS_SETVICE_MODE = 0x0B,
CS_MODE_OF_POSITION = 0x0C, CS_OPERATING_HOURS = 0x0D, CS_STATUS = 0x0E, CS_RGB_RED = 0x0F,
CS_RGB_GREEN = 0x10, CS_RGB_BLUE = 0x11
}
Index enums for A5-11-xx profiles. More...
enum CS_ENERGY_UNITS {
CS_MILI_W = 0x00, CS_W = 0x01, CS_KILO_W = 0x02, CS_MEGA_W = 0x03,
CS_WH = 0x04, CS_KILO_WH = 0x05, CS_MEGA_WH = 0x06, CS_GIGA_WH = 0x07,
CS_MILI_A = 0x08, CS_A_1_10 = 0x09, CS_MILI_V = 0x0A, CS_V_1_10 = 0x0B
}
Units for A5-11-xx profiles. More...
enum | CS_ENUM_03_ERROR_STATE { CS_NO_ERROR = 0x00, CS_LAMP_ERROR = 0x01, CS_INTERNAL_ERROR = 0x02 }
3 state error code for A5-11-xx profiles More...
enum | CS_ENUM_04_ERROR_STATE { A5O_ERROR = 0x00, END_POS_NO_CONFIG = 0x01, INTERNAL_ERROR = 0x02, EXT_PERIPHERY_ERROR = 0x03 }
4 state error code for A5-11-xx profiles More...
enum | CS_ENUM_BLIND_STATE { NOT_AVAILABLE = 0x00, BLIND_STOPPED = 0x01, BLIND_OPENS = 0x02, BLIND_CLOSES = 0x03 }
Blind status for A5-11-xx profiles. More...
enum | CS_ENUM_END_POS { NO_END_POS_AVAILABLE = 0x00, NO_END_POS_REACHED = 0x01, BLIND_FULLY_OPEN = 0x02, BLIND_FULLY_CLOSE = 0x03 }
Blind end position for A5-11-xx profiles. More...
enum | CS_ENUM_CONTROLLER_MODE { HEATING = 0x00, COOLING = 0x01, OFF = 0x02 }
Controller mode for A5-11-xx profiles. More...
enum | CS_ENUM_ROOM_OCCUPANCY { OCCUPIED = 0x00, UNOCCUPIED = 0x01, STANDBY = 0x02, FROST = 0x03 }
Room occupancy for A5-11-xx profiles. More...
enum CS_FAN_STAGE {
STAGE_0_MANUAL = 0x00, STAGE_1_MANUAL = 0x01, STAGE_2_MANUAL = 0x02, STAGE_3_MANUAL = 0x03,
STAGE_0_AUTO = 0x10, STAGE_1_AUTO = 0x11, STAGE_2_AUTO = 0x12, STAGE_3_AUTO = 0x13
}
Fan speed for A5-11-xx profiles. More...
enum | CS_WORKING_MODE { WORKING_MODE_1 = 0x01, WORKING_MODE_2 = 0x02, WORKING_MODE_3 = 0x03, WORKING_MODE_4 = 0x04 }
Working mode for A5-11-05 profile. More...
enum | CS_RELAY_STATUS { CH1_OFF_CH2_OFF = 0x00, CH1_ON_CH2_OFF = 0x01, CH1_OFF_CH2_ON = 0x02, CH1_ON_CH2_ON = 0x03 }
Relay Status for A5-11-05 profile. More...

Detailed Description

Enumeration Type Documentation

enum CS_ENERGY_UNITS

Units for A5-11-xx profiles.

Enumerator:
CS_MILI_W

Mili Watt 0

CS_W

Watt 1

CS_KILO_W

Kilo Watt 2

CS_MEGA_W

Mega Watt 3

CS_WH

Watthour 4

CS_KILO_WH

Kilo Watthour 5

CS_MEGA_WH

Mega Watthour 6

CS_GIGA_WH

Giga Watthour 7

CS_MILI_A

Mili Amper 8

CS_A_1_10

1/10 Amper 9

CS_MILI_V

Mili Volt 10

CS_V_1_10

1/10 Volt 11

enum CS_ENUM_03_ERROR_STATE

3 state error code for A5-11-xx profiles

Enumerator:
CS_NO_ERROR

No error 0

CS_LAMP_ERROR

Lamp failure 1

CS_INTERNAL_ERROR

Internal failure 2

enum CS_ENUM_04_ERROR_STATE

4 state error code for A5-11-xx profiles

Enumerator:
A5O_ERROR

No error 0

END_POS_NO_CONFIG

Lamp failure 1

INTERNAL_ERROR

Internal failure 2

EXT_PERIPHERY_ERROR

Failure on the external periphery 3

enum CS_ENUM_BLIND_STATE

Blind status for A5-11-xx profiles.

Enumerator:
NOT_AVAILABLE

Not available 0

BLIND_STOPPED

Blind is stopped 1

BLIND_OPENS

Blind opens 2

BLIND_CLOSES

Blind closes 3

enum CS_ENUM_CONTROLLER_MODE

Controller mode for A5-11-xx profiles.

Enumerator:
HEATING

Heating 0

COOLING

Cooling 1

OFF

Off 2

enum CS_ENUM_END_POS

Blind end position for A5-11-xx profiles.

Enumerator:
NO_END_POS_AVAILABLE

No end-position available 0

NO_END_POS_REACHED

No end-position reached 1

BLIND_FULLY_OPEN

Blind fully open 2

BLIND_FULLY_CLOSE

Blind fully close 3

enum CS_ENUM_ROOM_OCCUPANCY

Room occupancy for A5-11-xx profiles.

Enumerator:
OCCUPIED

Occupied 0

UNOCCUPIED

Unoccupied 1

STANDBY

StandBy 2

FROST

Frost 3

enum CS_FAN_STAGE

Fan speed for A5-11-xx profiles.

Enumerator:
STAGE_0_MANUAL

Stage 0 Manual 0

STAGE_1_MANUAL

Stage 1 Manual 1

STAGE_2_MANUAL

Stage 2 Manual 2

STAGE_3_MANUAL

Stage 3 Manual 3

STAGE_0_AUTO

Stage 0 Automatic 16

STAGE_1_AUTO

Stage 1 Automatic 17

STAGE_2_AUTO

Stage 2 Automatic 18

STAGE_3_AUTO

Stage 3 Automatic 19

enum CS_INDEXES

Index enums for A5-11-xx profiles.

Enumerator:
CS_REPEATER

Repeater 0

CS_POWER_RELAY_TIMER

Power relay timer 1

CS_DAYLIGHT_HARVEST

Daylight Harvest 2

CS_DIMMING

Dimming 3

CS_POWER_RELAY

Power relay 4

CS_ALARM

Alarm 5

CS_CONTROLLER_STATE

Controller state 6

CS_ENERGY_HOLDOFF

Energy hold-off 7

CS_ANGLE_SIGN

Angle sign 8

CS_POSITION_VALUE

Position value flag 9

CS_ANGLE_VALUE

Angle value flag 10

CS_SETVICE_MODE

Service mode 11

CS_MODE_OF_POSITION

Mode of the position 12

CS_OPERATING_HOURS

Operating hours flag 13

CS_STATUS

Status 14

CS_RGB_RED

RGB red 15

CS_RGB_GREEN

RGB green 16

CS_RGB_BLUE

RGB blue 17

enum CS_RELAY_STATUS

Relay Status for A5-11-05 profile.

Enumerator:
CH1_OFF_CH2_OFF

Channel 1 off, channel 2 off 0

CH1_ON_CH2_OFF

Channel 1 on, channel 2 off 1

CH1_OFF_CH2_ON

Channel 1 off, channel 2 on 2

CH1_ON_CH2_ON

Channel 1 on, channel 2 on 3

enum CS_WORKING_MODE

Working mode for A5-11-05 profile.

Enumerator:
WORKING_MODE_1

Mode 1 0

WORKING_MODE_2

Mode 2 1

WORKING_MODE_3

Mode 3 2

WORKING_MODE_4

Mode 4 3

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A512xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A512xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A512xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_A512xx
The class to handle EEP a512 Automated meter reading (AMR) profiles. More...

Enumerations

enum | DATA_TYPE_METER_READING { CUMULATIVE = 0x00, CURRENT = 0x01 }
Data type enums for A5-12-xx profiles. More...
enum | BATTERY_LEVEL { BATTERY_LEVEL_100_75 = 0x00, BATTERY_LEVEL_75_50 = 0x01, BATTERY_LEVEL_50_25 = 0x02, BATTERY_LEVEL_25_0 = 0x03 }
Battery enums for A5-12-xx profiles. More...
enum | SENSOR_POSITION_ENUM { POSITION_NOT_POSSESSED = 0x00, POSITION_POSSESSED = 0x01 }
Sensor position enums for A5-12-05 profiles. More...
enum SENSOR_POSITION_INDEX_ENUM {
POSITION_LOCATION_0 = 0x00, POSITION_LOCATION_1 = 0x01, POSITION_LOCATION_2 = 0x02, POSITION_LOCATION_3 = 0x03,
POSITION_LOCATION_4 = 0x04, POSITION_LOCATION_5 = 0x05, POSITION_LOCATION_6 = 0x06, POSITION_LOCATION_7 = 0x07,
POSITION_LOCATION_8 = 0x08, POSITION_LOCATION_9 = 0x09
}
Sensor position index enums for A5-12-05 profiles. More...

Detailed Description

Enumeration Type Documentation

enum BATTERY_LEVEL

Battery enums for A5-12-xx profiles.

Enumerator:
BATTERY_LEVEL_100_75

Battery level 100-75% 0

BATTERY_LEVEL_75_50

Battery level 75-50% 1

BATTERY_LEVEL_50_25

Battery level 50-25% 2

BATTERY_LEVEL_25_0

Battery level 25-0% 3

enum DATA_TYPE_METER_READING

Data type enums for A5-12-xx profiles.

Enumerator:
CUMULATIVE

1 or kWh or m^3 0

CURRENT

1/s or W or liter/s 1

enum SENSOR_POSITION_ENUM

Sensor position enums for A5-12-05 profiles.

Enumerator:
POSITION_NOT_POSSESSED

Not possessed 0

POSITION_POSSESSED

Possessed 1

enum SENSOR_POSITION_INDEX_ENUM

Sensor position index enums for A5-12-05 profiles.

Enumerator:
POSITION_LOCATION_0

Location 0 0

POSITION_LOCATION_1

Location 1 1

POSITION_LOCATION_2

Location 2 2

POSITION_LOCATION_3

Location 3 3

POSITION_LOCATION_4

Location 4 4

POSITION_LOCATION_5

Location 5 5

POSITION_LOCATION_6

Location 6 6

POSITION_LOCATION_7

Location 7 7

POSITION_LOCATION_8

Location 8 8

POSITION_LOCATION_9

Location 9 9

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A513xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A513xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A513xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_A513xx
The class to handle EEP a513 profiles. More...

Enumerations

enum EA_INDEXS {
RAIN_NORAIN = 0x00, SUN_WEST = 0x01, SUN_SOUTH = 0x02, SUN_EAST = 0x03,
TIME_SECOND = 0x04, TIME_MINUTE = 0x05, TIME_HOUR = 0x06, TIME_DAY = 0x07,
TIME_MONTH = 0x08, TIME_YEAR = 0x09, TIME_SOURCE = 0x0A, AM_PM = 0x0B,
ELEVATION = 0x0C, AZIMUTH = 0x0D, LATITUDE = 0x0E, LONGITUDE = 0x0F,
TIME_FORMAT = 0x10
}
Indexes for A513xx profiles. More...
enum EA_ENUM_DAYS {
MONDAY = 0x01, TUESDAY = 0x02, WEDNESDAY = 0x03, THURSDAY = 0x04,
FRIDAY = 0x05, SATURDAY = 0x06, SUNDAY = 0x07
}
Days definition. More...
enum | EA_TIME_SOURCE { REAL_TIME_CLOCK = 0x00, GPS = 0x01 }
Time source. More...
enum | EA_AM_PM { TIME_AM = 0x00, TIME_PM = 0x01 }
AM or PM. More...
enum | EA_TIME_FORMAT { FORMAT_24 = 0x00, FORMAT_12 = 0x01 }
24 hours or 12 hours More...
enum | EA_HEMISPHERE { NORTH = 0x00, SOUTH = 0x01 }
Hemisphere source. More...

Detailed Description

Enumeration Type Documentation

enum EA_AM_PM

AM or PM.

Enumerator:
TIME_AM

AM.

TIME_PM

PM.

enum EA_ENUM_DAYS

Days definition.

Enumerator:
MONDAY

Monday.

TUESDAY

Tuesday.

WEDNESDAY

Wednesday.

THURSDAY

Thursday.

FRIDAY

Friday.

SATURDAY

Saturday.

SUNDAY

Sunday.

enum EA_HEMISPHERE

Hemisphere source.

Enumerator:
NORTH

North.

SOUTH

South.

enum EA_INDEXS

Indexes for A513xx profiles.

Enumerator:
RAIN_NORAIN

Rain / No rain.

SUN_WEST

Sun - West.

SUN_SOUTH

Sun - South.

SUN_EAST

Sun - East.

TIME_SECOND

Time - second.

TIME_MINUTE

Time - minute.

TIME_HOUR

Time - hour.

TIME_DAY

Time - day.

TIME_MONTH

Time - month.

TIME_YEAR

Time - year.

TIME_SOURCE

Time source.

AM_PM

AM or PM.

ELEVATION

Elevation.

AZIMUTH

Azimuth.

LATITUDE

Latitude.

LONGITUDE

Longitude.

TIME_FORMAT

Time format.

enum EA_TIME_FORMAT

24 hours or 12 hours

Enumerator:
FORMAT_24

24 hours

FORMAT_12

12 hours

enum EA_TIME_SOURCE

Time source.

Enumerator:
REAL_TIME_CLOCK

Real time clock.

GPS

GPS or equivalent.

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A514xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A514xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A514xx.h:

Go to the source code of this file.

Classes

class eoEEP_A514xx
The class to handle EEP a514 profiles. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A520xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A520xx.h File Reference
#include "eoA5EEProfile.h"
#include "eoISimpleBidirectionalProfile.h"
Include dependency graph for eoEEP_A520xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_A520xx
The class to handle EEP a520 profiles. More...

Enumerations

enum HVCA_INDEX {
ENERGY_INPUT = 0x00, ENERGY_STORAGE = 0x01, BATTERY_CAPACITY = 0x02, CONTACT_COVER = 0x03,
TEMPERATURE_FAIL = 0x04, WINDOW_DETECTION = 0x05, ACTUATOR_OBSTRUCTED = 0x06, RUN_INTI_SEQ = 0x07,
LIFT_SET = 0x08, VALVE_OPEN = 0x09, VALVE_CLOSED = 0x0A, SUMMER_BIT = 0x0B,
SET_POINT_SELECTION = 0x0C, SET_POINT_INVERSE = 0x0D, SELECT_FUNCTION = 0x0E, ON_OFF = 0x0F,
EXTERNAL_DISABLEMENT = 0x10, DISABLE_REMOTE_CONTROL = 0x11, OTHER_DISABLEMENT = 0x12, WINDOW_DISABLEMENT = 0x13,
KEYCARD_DISABLEMENT = 0x14, ALARM_STATE = 0x15, FAN_OVERRIDE = 0x16, CONTROLLER_STATE = 0x17,
ENERGY_HOLDOFF = 0x18, SERVICE_ON = 0x19, FEED_TEMP = 0x1A, CURRENT_TEMP = 0x1B,
MEASUREMENT_STATUS = 0x1C, STATUS_REQUEST = 0x1D, BUTTON_LOCK = 0x1E, TEMP_SELECTION = 0x1F,
FAILURE = 0x20, MEASUREMENT_CONTROL = 0x21, WAKEUP_CYCLE = 0x22, DISPLAY_ORIENTATION = 0x23
}
Index enums for A5-20-xx profiles. More...
enum HVAC_MODE {
MODE_AUTO = 0x00, MODE_HEAT = 0x01, MODE_MORING_WARMUP = 0x02, MODE_COOL = 0x03,
MODE_NIGHT_PURGE = 0x04, MODE_PRECOOL = 0x05, MODE_OFF = 0x06, MODE_TEST = 0x07,
MODE_EMERGENCY_HEAT = 0x08, MODE_FAN_ONLY = 0x09, MODE_FREE_COOL = 0x0A, MODE_ICE = 0x0B,
MODE_MAX_HEAT = 0x0C, MODE_ECONOMIC = 0x0D, MODE_DEHUMIDITY = 0x0E, MODE_CALIBRATION = 0x0F,
MODE_EMERGENCY_COOL = 0x10, MODE_EMERGENCY_STEAM = 0x11, MODE_MAX_COOL = 0x12, MODE_HVC_LOAD = 0x13,
MODE_NO_LOAD = 0x14, MODE_AUTO_HEAT = 0x1F, MODE_AUTO_COOL = 0x20
}
Mode enums for A5-20-10 profile. More...
enum HVCA_VANE_POSITION {
VANE_AUTO = 0x00, VANE_HORIZONTAL = 0x01, VANE_POS_2 = 0x02, VANE_POS_3 = 0x03,
VANE_POS_4 = 0x04, VANE_VERTICAL = 0x05, VANE_SWING = 0x06, VANE_VERT_SWING = 0x0B,
VANE_HORIZ_SWING = 0x0C, VANE_BOTH_SWING = 0x0D, VANE_STOP_SWING = 0x0E
}
Vane position enums for A5-20-10 profile. More...
enum | HVCA_ROOM_OCCUPANCY { HVCA_OCCUPIED = 0x00, HVCA_STANDBY = 0x01, HVCA_UNOCCUPIED = 0x02, HVCA_OFF = 0X03 }
Room occupancy enums for A5-20-xx profiles. More...
enum | HVCA_ROOM_OCCUPANCY_TYPE_20 { HVCA_OCCUPIED_20 = 0x00, HVCA_UNOCCUPIED_20 = 0x01, HVCA_STANDBY_20 = 0x02, HVCA_FROST_20 = 0X03 }
Room occupancy enums for A5-20-20 profile. More...
enum HVCA_FANSPEED {
HVCA_STAGE_0 = 0x00, HVCA_STAGE_1 = 0x01, HVCA_STAGE_2 = 0x02, HVCA_STAGE_3 = 0x03,
HVCA_AUTO = 0x1F
}
Fan speed enums for A5-20-20 profile. More...
enum | HVCA_CONTROLLER_MODE { HVCA_AUTO_MOD = 0x00, HVCA_HEAT_MOD = 0x01, HVCA_COOL_MOD = 0x02, HVCA_OFF_MOD = 0x03 }
Controller mode enums for A5-20-xx profiles. More...
enum HVCA_FAILURE_CODE {
MEASUREMENT_ERROR = 0x11, BATTERY_EMPTY = 0x12, FROST_PROTECTION = 0x14, BLOCKED_VALVE = 0x21,
END_POINT_DETECTION = 0x24, NO_VALVE = 0x28, NOT_TEACHED_IN = 0x31, NO_RESPONSE_FROM_CONTROLLER = 0x35,
TEACH_IN_ERROR = 0x36
}
Failure code enums. More...
enum | HVCA_MEASUREMENT_STATUS { MEASUREMENT_ACTIVE = 0x00, MEASUREMENT_INACTIVE = 0x01 }
Measurement status enums. More...
enum | HVCA_MEASUREMENT_CONTROL { MEASUREMENT_ENABLE = 0x00, MEASUREMENT_DISABLE = 0x01 }
Measurement control enums. More...
enum | HVCA_STATUS_REQUEST { STATUS_NO_CHANGE = 0x00, STATUS_REQUESTED = 0x01 }
Status request enums. More...
enum | HVCA_BUTTON_LOCK { BUTTON_UNLOCKED = 0x00, BUTTON_LOCKED = 0x01 }
Button lock status enums. More...
enum | HVCA_TEMP_SELECTION { FEED_TEMP_SELECT = 0x00, TEMP_SETPOINT_SELECT = 0x01 }
Temperature selection enums. More...
enum | HVCA_FAILURE { NO_FAILURE_FLAG = 0x00, FAILURE_FLAG = 0x01 }
Failure enums. More...
enum HVCA_WAKEUP_CYCLE {
SEC_10 = 0x00, SEC_60 = 0x01, SEC_90 = 0x02, SEC_120 = 0x03,
SEC_150 = 0x04, SEC_180 = 0x05, SEC_210 = 0x06, SEC_240 = 0x07,
SEC_270 = 0x08, SEC_300 = 0x09, SEC_330 = 0x0A, SEC_360 = 0x0B,
SEC_390 = 0x0C, SEC_420 = 0x0D, SEC_450 = 0x0E, SEC_480 = 0x0F,
SEC_510 = 0x10, SEC_540 = 0x11, SEC_570 = 0x12, SEC_600 = 0x13,
SEC_630 = 0x14, SEC_660 = 0x15, SEC_690 = 0x16, SEC_720 = 0x17,
SEC_750 = 0x18, SEC_780 = 0x19, SEC_810 = 0x1A, SEC_840 = 0x1B,
SEC_870 = 0x1C, SEC_900 = 0x1D, SEC_930 = 0x1E, SEC_960 = 0x1F,
SEC_990 = 0x20, SEC_1020 = 0x21, SEC_1050 = 0x22, SEC_1080 = 0x23,
SEC_1110 = 0x24, SEC_1140 = 0x25, SEC_1170 = 0x26, SEC_1200 = 0x27,
SEC_1230 = 0x28, SEC_1260 = 0x29, SEC_1290 = 0x2A, SEC_1320 = 0x2B,
SEC_1350 = 0x2C, SEC_1380 = 0x2D, SEC_1410 = 0x2E, SEC_1440 = 0x2F,
SEC_1470 = 0x30, SEC_1500 = 0x31, HRS_3 = 0x32, HRS_6 = 0x33,
HRS_9 = 0x34, HRS_12 = 0x35, HRS_15 = 0x36, HRS_18 = 0x37,
HRS_21 = 0x38, HRS_24 = 0x39, HRS_27 = 0x3A, HRS_30 = 0x3B,
HRS_33 = 0x3C, HRS_36 = 0x3D, HRS_39 = 0x3E, HRS_42 = 0x3F
}
Wake-up cycle enums. More...
enum | HVCA_DISPLAY_ORIENTATION { ORIENTATION_0 = 0x00, ORIENTATION_90 = 0x01, ORIENTATION_180 = 0x02, ORIENTATION_270 = 0x03 }
Display orientation enums. More...
enum | HVCA_SERVICE_COMMAND { HVCA_NO_CHANGE = 0x00, HVCA_OPEN_VALVE = 0x01, HVCA_RUN_INIT = 0x02, HVCA_CLOSE_VALVE = 0x03 }
Service command enums. More...
enum | HVCA_DIRECTION { HVCA_DIRECTION_1 = 0x00, HVCA_DIRECTION_2 = 0x01 }
Direction enums. More...

Detailed Description

Enumeration Type Documentation

enum HVAC_MODE

Mode enums for A5-20-10 profile.

Enumerator:
MODE_AUTO

Auto 0

MODE_HEAT

Heat 1

MODE_MORING_WARMUP

Morning warmup 2

MODE_COOL

Cool 3

MODE_NIGHT_PURGE

Night purge 4

MODE_PRECOOL

Precool 5

MODE_OFF

Off 6

MODE_TEST

Test 7

MODE_EMERGENCY_HEAT

Emergency heat 8

MODE_FAN_ONLY

Fan only 9

MODE_FREE_COOL

Free cool 10

MODE_ICE

Ice 11

MODE_MAX_HEAT

Max heat 12

MODE_ECONOMIC

Economic heat/cool 13

MODE_DEHUMIDITY

Dehumidification (dry) 14

MODE_CALIBRATION

Calibration 15

MODE_EMERGENCY_COOL

Emergency cool 16

MODE_EMERGENCY_STEAM

Emergency steam 17

MODE_MAX_COOL

Max cool 18

MODE_HVC_LOAD

Hvc load 19

MODE_NO_LOAD

No load 18

MODE_AUTO_HEAT

Auto heat 19

MODE_AUTO_COOL

Auto cool 20

enum HVCA_BUTTON_LOCK

Button lock status enums.

Enumerator:
BUTTON_UNLOCKED

Unlocked 0

BUTTON_LOCKED

Locked 1

enum HVCA_CONTROLLER_MODE

Controller mode enums for A5-20-xx profiles.

Enumerator:
HVCA_AUTO_MOD

Auto mode 0

HVCA_HEAT_MOD

Heating 1

HVCA_COOL_MOD

Cooling 2

HVCA_OFF_MOD

Off 3

enum HVCA_DIRECTION

Direction enums.

Enumerator:
HVCA_DIRECTION_1

Direction 1 0

HVCA_DIRECTION_2

Direction 2 1

enum HVCA_DISPLAY_ORIENTATION

Display orientation enums.

Enumerator:
ORIENTATION_0

0 0

ORIENTATION_90

90 1

ORIENTATION_180

180 2

ORIENTATION_270

270 3

enum HVCA_FAILURE

Failure enums.

Enumerator:
NO_FAILURE_FLAG

No failure 0

FAILURE_FLAG

Failure 1

enum HVCA_FAILURE_CODE

Failure code enums.

Enumerator:
MEASUREMENT_ERROR

Measurement error 17

BATTERY_EMPTY

Battery empty 18

FROST_PROTECTION

Frost protection 20

BLOCKED_VALVE

Blocked valve 33

END_POINT_DETECTION

End point detection 36

NO_VALVE

No valve 40

NOT_TEACHED_IN

Not teached in 49

NO_RESPONSE_FROM_CONTROLLER

No response from controller 53

TEACH_IN_ERROR

Teach in error 54

enum HVCA_FANSPEED

Fan speed enums for A5-20-20 profile.

Enumerator:
HVCA_STAGE_0

Stage 0 0

HVCA_STAGE_1

Stage 1 1

HVCA_STAGE_2

Stage 2 2

HVCA_STAGE_3

Stage 3 3

HVCA_AUTO

Auto 31

enum HVCA_INDEX

Index enums for A5-20-xx profiles.

Enumerator:
ENERGY_INPUT

Energy input enabled 0

ENERGY_STORAGE

Energy storage 1

BATTERY_CAPACITY

Battery capacity 2

CONTACT_COVER

Contact, cover open 3

TEMPERATURE_FAIL

Failure temperature sensor, out of range 4

WINDOW_DETECTION

Detection, window open 5

ACTUATOR_OBSTRUCTED

Actuator obstucted 6

RUN_INTI_SEQ

Run init sequence 7

LIFT_SET

Lift set 8

VALVE_OPEN

Valve open / maintenance 9

VALVE_CLOSED

Valve closed 10

SUMMER_BIT

Summer bit 11

SET_POINT_SELECTION

Set point selection

Note:
deprecated should not be accessed is done automatically 12
SET_POINT_INVERSE

Set point inverse 13

SELECT_FUNCTION

Select function 14

ON_OFF

On - off 15

EXTERNAL_DISABLEMENT

External disablement 16

DISABLE_REMOTE_CONTROL

Disable remote controller 17

OTHER_DISABLEMENT

Other disablement 18

WINDOW_DISABLEMENT

Window contact disablement 19

KEYCARD_DISABLEMENT

Key card disablement 20

ALARM_STATE

Alarm state 21

FAN_OVERRIDE

Fan override 22

CONTROLLER_STATE

Controller state 23

ENERGY_HOLDOFF

Energy hold-off / dew point 24

SERVICE_ON

Service on 25

FEED_TEMP

Feed temperature 26

CURRENT_TEMP

Current room temperature 27

MEASUREMENT_STATUS

Measurement status 28

STATUS_REQUEST

Status request 29

BUTTON_LOCK

Button lock status/control 30

TEMP_SELECTION

Temperature selection 31

FAILURE

Failure 32

MEASUREMENT_CONTROL

Measurement control 33

WAKEUP_CYCLE

Wake-up cycle 34

DISPLAY_ORIENTATION

Display orientation 35

enum HVCA_MEASUREMENT_CONTROL

Measurement control enums.

Enumerator:
MEASUREMENT_ENABLE

Enable 0

MEASUREMENT_DISABLE

Disable 1

enum HVCA_MEASUREMENT_STATUS

Measurement status enums.

Enumerator:
MEASUREMENT_ACTIVE

Active 0

MEASUREMENT_INACTIVE

Inactive 1

enum HVCA_ROOM_OCCUPANCY

Room occupancy enums for A5-20-xx profiles.

Enumerator:
HVCA_OCCUPIED

Occupied 0

HVCA_STANDBY

StandBy 1

HVCA_UNOCCUPIED

Unoccupied 2

HVCA_OFF

Off (no occupancy, no action) 3

enum HVCA_ROOM_OCCUPANCY_TYPE_20

Room occupancy enums for A5-20-20 profile.

Enumerator:
HVCA_OCCUPIED_20

Occupied 0

HVCA_UNOCCUPIED_20

Unoccupied 1

HVCA_STANDBY_20

StandBy 2

HVCA_FROST_20

Frost 3

enum HVCA_SERVICE_COMMAND

Service command enums.

Enumerator:
HVCA_NO_CHANGE

No change 0

HVCA_OPEN_VALVE

Open valve 1

HVCA_RUN_INIT

Run initialisation 2

HVCA_CLOSE_VALVE

Close valve 3

enum HVCA_STATUS_REQUEST

Status request enums.

Enumerator:
STATUS_NO_CHANGE

No change 0

STATUS_REQUESTED

Status requested 1

enum HVCA_TEMP_SELECTION

Temperature selection enums.

Enumerator:
FEED_TEMP_SELECT

Feed temperature 0

TEMP_SETPOINT_SELECT

Temperature set point 1

enum HVCA_VANE_POSITION

Vane position enums for A5-20-10 profile.

Enumerator:
VANE_AUTO

Auto 0

VANE_HORIZONTAL

Horizontal 1

VANE_POS_2

Pos 2 2

VANE_POS_3

Pos 3 3

VANE_POS_4

Pos 4 4

VANE_VERTICAL

Vertical 5

VANE_SWING

Swing 6

VANE_VERT_SWING

Vertical swing 7

VANE_HORIZ_SWING

Horizontal swing 8

VANE_BOTH_SWING

Horizontal and vertical swing 9

VANE_STOP_SWING

Stop swing 10

enum HVCA_WAKEUP_CYCLE

Wake-up cycle enums.

Enumerator:
SEC_10

10 sec 0

SEC_60

60 sec 1

SEC_90

90 sec 2

SEC_120

120 sec 3

SEC_150

150 sec 4

SEC_180

180 sec 5

SEC_210

210 sec 6

SEC_240

240 sec 7

SEC_270

270 sec 8

SEC_300

300 sec 9

SEC_330

330 sec 10

SEC_360

360 sec 11

SEC_390

390 sec 12

SEC_420

420 sec 13

SEC_450

450 sec 14

SEC_480

480 sec 15

SEC_510

510 sec 16

SEC_540

540 sec 17

SEC_570

570 sec 18

SEC_600

600 sec 19

SEC_630

630 sec 20

SEC_660

660 sec 21

SEC_690

690 sec 22

SEC_720

720 sec 23

SEC_750

750 sec 24

SEC_780

780 sec 25

SEC_810

810 sec 26

SEC_840

840 sec 27

SEC_870

870 sec 28

SEC_900

900 sec 29

SEC_930

930 sec 30

SEC_960

960 sec 31

SEC_990

990 sec 32

SEC_1020

1020 sec 33

SEC_1050

1050 sec 34

SEC_1080

1080 sec 35

SEC_1110

1110 sec 36

SEC_1140

1140 sec 37

SEC_1170

1170 sec 38

SEC_1200

1200 sec 39

SEC_1230

1230 sec 40

SEC_1260

1260 sec 41

SEC_1290

1290 sec 42

SEC_1320

1320 sec 43

SEC_1350

1350 sec 44

SEC_1380

1380 sec 45

SEC_1410

1410 sec 46

SEC_1440

1440 sec 47

SEC_1470

1470 sec 48

SEC_1500

1500 sec 49

HRS_3

3 hours 50

HRS_6

6 hours 51

HRS_9

9 hours 52

HRS_12

12 hours 53

HRS_15

15 hours 54

HRS_18

18 hours 55

HRS_21

21 hours 56

HRS_24

24 hours 57

HRS_27

27 hours 58

HRS_30

30 hours 59

HRS_33

33 hours 60

HRS_36

36 hours 61

HRS_39

39 hours 62

HRS_42

42 hours 63

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A530xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A530xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A530xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_A530xx
The class to handle EEP a530 profiles. More...

Enumerations

enum A530_INDEX {
KEY_DATA_1 = 0x00, KEY_DATA_2 = 0x01, KEY_DATA_3 = 0x02, KEY_DATA_4 = 0x03,
KEY_DATA_5 = 0x04, KEY_DATA_6 = 0x05
}
Index enums for A5-30-xx profiles. More...
enum | A530_BATTERY_VALUE { BATTERY_LOW = 0x00, BATTERY_EO_OK = 0x01 }
Battery values. More...
enum | A530_SIGNAL_TYPE { NORMAL_SIGNAL = 0x00, HEART_BEAT_SIGNAL = 0x01 }
Signal type. More...
enum ENUM_DIGITAL_INPUT {
STATUS_WAKE = 0x00, DIGITAL_IN_0 = 0x01, DIGITAL_IN_1 = 0x02, DIGITAL_IN_2 = 0x03,
DIGITAL_IN_3 = 0x04
}
Digital Inputs in A5-30-03 profile. More...

Detailed Description

Enumeration Type Documentation

enum A530_BATTERY_VALUE

Battery values.

Enumerator:
BATTERY_LOW

Battery low.

BATTERY_EO_OK

Battery OK.

enum A530_INDEX

Index enums for A5-30-xx profiles.

Enumerator:
KEY_DATA_1

1st key data 0

KEY_DATA_2

2nd key data 1

KEY_DATA_3

3rd key data 2

KEY_DATA_4

4th key data 3

KEY_DATA_5

5th key data 4

KEY_DATA_6

6th key data 5

enum A530_SIGNAL_TYPE

Signal type.

Enumerator:
NORMAL_SIGNAL

Normal signal.

HEART_BEAT_SIGNAL

Heart beat signal.

enum ENUM_DIGITAL_INPUT

Digital Inputs in A5-30-03 profile.

Enumerator:
STATUS_WAKE

Status of wake 0

DIGITAL_IN_0

Digital Input 0 1

DIGITAL_IN_1

Digital Input 1 2

DIGITAL_IN_2

Digital Input 2 3

DIGITAL_IN_3

Digital Input 3 4

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A537xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A537xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A537xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_A537xx
The class to handle EEP a537 profiles. More...

Enumerations

enum EM_INDEXS { ABS_REL_POWER = 0x00, RAND_START_DELAY = 0x01, RAND_END_DELAY = 0x02, MAX_MIN_POWER = 0x03 }
Index enums for A5-37-xx profiles. More...

Detailed Description

Enumeration Type Documentation

enum EM_INDEXS

Index enums for A5-37-xx profiles.

Enumerator:
ABS_REL_POWER

Absolute/relative power usage 0

RAND_START_DELAY

Random start delay 1

RAND_END_DELAY

Randomized end delay 2

MAX_MIN_POWER

Max/Min power usage for default DR state 3

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A538xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_A538xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_A538xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_A538xx
The class to handle EEP a538 profiles. More...

Enumerations

enum CC_INDEXS {
CC_LOCK_UNLOCK = 0x00, CC_DELAY_DURATION = 0x01, CC_SWITCHING_COMMAND = 0x02, CC_DIMMING_RANGE = 0x03,
CC_STORE_FINAL_VAL = 0x04, CC_CONTROLLER_STATE = 0x05, CC_ENERGY_HOLDOFF = 0x06, CC_SEND_STATUS = 0x07,
CC_POS_ANGLE_FLAG = 0x08, CC_SERVICE_MODE = 0x09, CC_BLIND_POSITION = 0x0A, CC_ANGLE_BLIND_POSITION = 0x0B,
CC_BLIND_OPEN_POSITION = 0x0C, CC_BLIND_OPEN_ANGLE = 0x0D, CC_BLIND_CLOSE_POSITION = 0x0E, CC_BLIND_CLOSE_ANGLE = 0x0F,
CC_RUNTIME_OPEN = 0x10, CC_RUNTIME_CLOSE = 0x11, CC_SUNBLIND_REVERSION = 0x12, CC_SET_MIN_POSITION = 0x13,
CC_SET_MAX_POSITION = 0x14, CC_FULLY_SHUT_ANGLE = 0x15, CC_FULLY_OPEN_ANGLE = 0x16, CC_POSITION_LOGIC = 0x17,
CC_DIMMING_VALUE = 0x18, CC_UP_RAMPING_TIME = 0x19, CC_DOWN_RAMPING_TIME = 0x1A, CC_SET_RAMPING_TIME = 0x1B,
CC_RGB_RED = 0x1C, CC_RGB_GREEN = 0x1D, CC_RGB_BLUE = 0x1E, CC_MIN_DIM_VALUE = 0x1F,
CC_MAX_DIM_VALUE = 0x20, CC_LAMP_OPERATING_HOUR = 0x21, CC_SCENE_NUMBER = 0x22, CC_SCENE = 0x23,
CC_ENERGY_METERING_VALUE = 0x24
}
Index enums for A5-38-xx profiles. More...
enum CC_ENERGY_UNITS {
MILI_W = 0x00, W = 0x01, KILO_W = 0x02, MEGA_W = 0x03,
WH = 0x04, KILO_WH = 0x05, MEGA_WH = 0x06, GIGA_WH = 0x07,
MILI_A = 0x08, A_1_10 = 0x09, MILI_V = 0x0A, V_1_10 = 0x0B
}
Energy unit enums for A5-38-xx profiles. More...
enum | CC_LOCKING_OPERATIONS { UNLOCK_LOCAL_OP = 0x00, LOCK_SWITCH_ON = 0x01, LOCK_SWITCH_OFF = 0x02, LOCK_LOCAL_OP = 0x03 }
Locking operation enums for A5-38-xx profiles. More...
enum CC_FUNCTIONS {
DO_NOTHING = 0x00, STOP_BLIND = 0x01, OPEN_BLIND = 0x02, CLOSE_BLIND = 0x03,
DRIVE_TO_POS = 0x04, OPEN_FOR_TIME = 0x05, CLOSE_FOR_TIME = 0x06, SET_RUNTIME_PARAM = 0x07,
SET_ANGLE = 0x08, SET_MIN_MAX = 0x09, SET_SLAT_ANGLE = 0x0A, SET_LOGIC_POS = 0x0B
}
Function enums for A5-38-08 profile (command 0x07) More...
enum CC_FUNCTIONS_TYPE_09 {
CC_DO_NOTHING = 0x00, CC_SWITCHED_OFF = 0x01, CC_SWITCHED_ON = 0x02, CC_DIMMING_UP = 0x03,
CC_DIMMING_DOWN = 0x04, CC_DIMMING_STOP = 0x05, CC_SET_VALUES = 0x06, CC_SET_RGB_VALUES = 0x07,
CC_SCENE_FUNCTION = 0x08, CC_SET_DIMMER_VALUE = 0x09, CC_SET_OP_HOURS = 0x0A, CC_LOCK_OPERATIONS = 0x0B,
CC_NEW_VALUE_METERING = 0x0C
}
Function enums for A5-38-09 profile. More...
enum CC_FAN_SPEED_5_STAGE {
CC_STAGE_0 = 0, CC_STAGE_1 = 1, CC_STAGE_2 = 2, CC_STAGE_3 = 3,
CC_STAGE_AUTO = 255
}
Fan stage enums for A5-38-xx profile. More...
enum | CC_ROOM_OCCUPANCY { CC_OCCUPIED = 0, CC_UNOCCUPIED = 1, CC_STANDBY = 2 }
Room occupancy enums for A5-38-xx profile. More...
enum | CC_CONTROLLER_MODE { CC_AUTO = 0, CC_HEATING = 1, CC_COOLING = 2, CC_OFF = 3 }
Controller mode enums for A5-38-xx profile. More...

Detailed Description

Enumeration Type Documentation

enum CC_CONTROLLER_MODE

Controller mode enums for A5-38-xx profile.

Enumerator:
CC_AUTO

Automatic mode 0

CC_HEATING

Heating 1

CC_COOLING

Cooling 2

CC_OFF

Off 3

enum CC_ENERGY_UNITS

Energy unit enums for A5-38-xx profiles.

Enumerator:
MILI_W

mW 0

W

W 1

KILO_W

kW 2

MEGA_W

MW 3

WH

Wh 4

KILO_WH

kWh 5

MEGA_WH

MWh 6

GIGA_WH

GWh 7

MILI_A

mA 8

A_1_10

1/10 A 9

MILI_V

mV 10

V_1_10

1/10 V 11

enum CC_FAN_SPEED_5_STAGE

Fan stage enums for A5-38-xx profile.

Enumerator:
CC_STAGE_0

Stage 0 0

CC_STAGE_1

Stage 1 1

CC_STAGE_2

Stage 2 2

CC_STAGE_3

Stage 3 3

CC_STAGE_AUTO

Stage Auto 255

enum CC_FUNCTIONS

Function enums for A5-38-08 profile (command 0x07)

Enumerator:
DO_NOTHING

Do nothing, status request 0

STOP_BLIND

Blind stops 1

OPEN_BLIND

Blind opens 2

CLOSE_BLIND

Blind closes 3

DRIVE_TO_POS

Blind drives to position with angle value 4

OPEN_FOR_TIME

Blind opens for time (position value) and angle (angle value) 5

CLOSE_FOR_TIME

Blind closes for time (posititon value) and angle (angle value) 6

SET_RUNTIME_PARAM

Set runtime parameters 7

SET_ANGLE

Set angle configuration 8

SET_MIN_MAX

Set min, max values 9

SET_SLAT_ANGLE

Set slat angle for shut and open position 10

SET_LOGIC_POS

Set position logic 11

enum CC_FUNCTIONS_TYPE_09

Function enums for A5-38-09 profile.

Enumerator:
CC_DO_NOTHING

Do nothing, status request 0

CC_SWITCHED_OFF

Swithced off 1

CC_SWITCHED_ON

Swithced on 2

CC_DIMMING_UP

Dimming up with ramping time 3

CC_DIMMING_DOWN

Dimming down with ramping time 4

CC_DIMMING_STOP

Dimming stops 5

CC_SET_VALUES

Set dimemr value and ramping time 6

CC_SET_RGB_VALUES

Set RGB values 7

CC_SCENE_FUNCTION

Scene function 8

CC_SET_DIMMER_VALUE

Set minimal and maximal dimmer value 9

CC_SET_OP_HOURS

Set the operating hours of the lamp 10

CC_LOCK_OPERATIONS

Locking local operations 11

CC_NEW_VALUE_METERING

Set a new value for the energy metering 12

enum CC_INDEXS

Index enums for A5-38-xx profiles.

Enumerator:
CC_LOCK_UNLOCK

Lock/Unlock 0

CC_DELAY_DURATION

Delay or duration 1

CC_SWITCHING_COMMAND

Switching commanf 2

CC_DIMMING_RANGE

Dimming range 3

CC_STORE_FINAL_VAL

Store final value 4

CC_CONTROLLER_STATE

Controller state 5

CC_ENERGY_HOLDOFF

Energy hold-off 6

CC_SEND_STATUS

Send status flag 7

CC_POS_ANGLE_FLAG

Position and Angle flag 8

CC_SERVICE_MODE

Service mode flag 9

CC_BLIND_POSITION

Blind position 10

CC_ANGLE_BLIND_POSITION

Blind angle position 11

CC_BLIND_OPEN_POSITION

Blind opens for time (position value) 12

CC_BLIND_OPEN_ANGLE

Blind opens for time (angle value) 13

CC_BLIND_CLOSE_POSITION

Blind closes for time (position value) 14

CC_BLIND_CLOSE_ANGLE

Blind closes for time (angle value) 15

CC_RUNTIME_OPEN

Set runtime parameter (open) 16

CC_RUNTIME_CLOSE

Set runtime parameter (close) 17

CC_SUNBLIND_REVERSION

Sunblind reversion time 18

CC_SET_MIN_POSITION

Set minimum position 19

CC_SET_MAX_POSITION

Set maximum position 20

CC_FULLY_SHUT_ANGLE

Set slut angle for fully shut position 21

CC_FULLY_OPEN_ANGLE

Set slut angle for fully open position 22

CC_POSITION_LOGIC

Position logic 23

CC_DIMMING_VALUE

Set dimming value 24

CC_UP_RAMPING_TIME

Set ramping up time 25

CC_DOWN_RAMPING_TIME

Set ramping down time 26

CC_SET_RAMPING_TIME

Set ramping time 27

CC_RGB_RED

RGB red 28

CC_RGB_GREEN

RGB green 29

CC_RGB_BLUE

RGB blue 30

CC_MIN_DIM_VALUE

Minimum dimming value 31

CC_MAX_DIM_VALUE

Maximum dimming value 32

CC_LAMP_OPERATING_HOUR

Lamp operating hours 33

CC_SCENE_NUMBER

Scene number 34

CC_SCENE

Scene function 35

CC_ENERGY_METERING_VALUE

Energy metering value 36

enum CC_LOCKING_OPERATIONS

Locking operation enums for A5-38-xx profiles.

Enumerator:
UNLOCK_LOCAL_OP

Unlock local operations 0

LOCK_SWITCH_ON

Locking switch on commands 1

LOCK_SWITCH_OFF

Locking switch off commands 2

LOCK_LOCAL_OP

Locking local operations 3

enum CC_ROOM_OCCUPANCY

Room occupancy enums for A5-38-xx profile.

Enumerator:
CC_OCCUPIED

Occupied 0

CC_UNOCCUPIED

Unoccupied 1

CC_STANDBY

StandBy 2

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D200xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D200xx.h File Reference
#include "eoD2EEProfile.h"
Include dependency graph for eoEEP_D200xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_D200xx
The class to handle EEP D200 profiles. More...

Enumerations

enum RCP_INDEXS {
RCP_CONFIG_VALID = 0x00, RCP_USER_NOTIFICATION = 0x01, RCP_DEW_POINT = 0x02, RCP_COOLING = 0x03,
RCP_HEATING = 0x04, RCP_FAN_MANUAL = 0x05, RCP_MORE_DATA = 0x06, RCP_KEEP_ALIVE_TIME = 0x07,
RCP_TEMP_MEASUREMENT_TIMING = 0x08, RCP_SETPOINT_STEPS = 0x09, RCP_SETPOINT_RANGE_LIMIT = 0x0A, RCP_NO_DISPLAY = 0x0B,
RCP_ROOM_TEMPERATURE_C = 0x0C, RCP_ROOM_TEMPERATURE_F = 0x0D, RCP_NOMINAL_TEMPERATURE_C = 0x0E, RCP_NOMINAL_TEMPERATURE_F = 0x0F,
RCP_DELTA_TEMP_SETPOINT_C = 0x10, RCP_DELTA_TEMP_SETPOINT_F = 0x11, RCP_DELTA_TEMP_GRAPHIC = 0x12, RCP_TIME_24_HOURS = 0x13,
RCP_TIME_AM_HOURS = 0x14, RCP_TIME_PM_HOURS = 0x15, RCP_TIME_DAY_MONTH = 0x16, RCP_TIME_MONTH_DAY = 0x17
}
Index enums for D2-00-xx profiles. More...
enum RCP_COMMANDS {
RCP_FIRST_USER_ACTION = 0x01, RCP_DISPLAY_CONTENT = 0x02, RCP_REPEATED_USER_ACTION = 0x03, RCP_MEASUREMENT_RESULT = 0x04,
RCP_SENSOR_CONFIG = 0x05
}
Command enums for D2-00-xx profiles. More...
enum | RCP_USER_ACTION { PRESENCE = 0x01, TEMP_DOWN = 0x02, TEMP_UP = 0x05, FAN = 0x06 }
User action enums for D2-00-xx profiles. More...
enum | RCP_PRESENCE { NO_CHANGE = 0x00, PRESENT = 0x01, NOT_PRESENT = 0x02, NIGHT_TIME = 0x03 }
Presence enums for D2-00-xx profiles. More...
enum RCP_5_LEVEL_FANSPEED {
RCP_DO_NOT_DISPLAY = 0x00, RCP_SPEED_LEVEL_0 = 0x01, RCP_SPEED_LEVEL_1 = 0x02, RCP_SPEED_LEVEL_2 = 0x03,
RCP_SPEED_LEVEL_3 = 0x04
}
5 level fan speed enums for D2-00-xx profiles More...
enum RCP_6_LEVEL_FANSPEED {
FAN_NO_CHANGE = 0x00, SPEED_LEVEL_0 = 0x01, SPEED_LEVEL_1 = 0x02, SPEED_LEVEL_2 = 0x03,
SPEED_LEVEL_3 = 0x04, SPEED_LEVEL_AUTO = 0x05
}
6 level fan speed enums for D2-00-xx profiles More...

Detailed Description

Enumeration Type Documentation

enum RCP_5_LEVEL_FANSPEED

5 level fan speed enums for D2-00-xx profiles

Enumerator:
RCP_DO_NOT_DISPLAY

Do not display 0

RCP_SPEED_LEVEL_0

Speed level 0 1

RCP_SPEED_LEVEL_1

Speed level 1 2

RCP_SPEED_LEVEL_2

Speed level 2 3

RCP_SPEED_LEVEL_3

Speed level 3 4

enum RCP_6_LEVEL_FANSPEED

6 level fan speed enums for D2-00-xx profiles

Enumerator:
FAN_NO_CHANGE

No change 0

SPEED_LEVEL_0

Speed level 0 1

SPEED_LEVEL_1

Speed level 1 2

SPEED_LEVEL_2

Speed level 2 3

SPEED_LEVEL_3

Speed level 3 4

SPEED_LEVEL_AUTO

Speed level Auto 5

enum RCP_COMMANDS

Command enums for D2-00-xx profiles.

Enumerator:
RCP_FIRST_USER_ACTION

First user action on RCP 1

RCP_DISPLAY_CONTENT

Display content 2

RCP_REPEATED_USER_ACTION

Repeated user action on RCP 3

RCP_MEASUREMENT_RESULT

Measurement result 4

RCP_SENSOR_CONFIG

Sensor configuration 5

enum RCP_INDEXS

Index enums for D2-00-xx profiles.

Enumerator:
RCP_CONFIG_VALID

Config valid 0

RCP_USER_NOTIFICATION

User notification 1

RCP_DEW_POINT

Dew point 2

RCP_COOLING

Cooling 3

RCP_HEATING

Heating 4

RCP_FAN_MANUAL

Fan manual 5

RCP_MORE_DATA

More data 6

RCP_KEEP_ALIVE_TIME

Kepp alive timing 7

RCP_TEMP_MEASUREMENT_TIMING

Temperature measurement timing 8

RCP_SETPOINT_STEPS

Set point steps 9

RCP_SETPOINT_RANGE_LIMIT

Set point range limit 10

RCP_NO_DISPLAY

Do not display 11

RCP_ROOM_TEMPERATURE_C

Room temperature in °C 12

RCP_ROOM_TEMPERATURE_F

Room temperature in °F 13

RCP_NOMINAL_TEMPERATURE_C

Nominal temperature in °C 14

RCP_NOMINAL_TEMPERATURE_F

Nominal temperature in °F 15

RCP_DELTA_TEMP_SETPOINT_C

Delta temperature set point in °C 16

RCP_DELTA_TEMP_SETPOINT_F

Delta temperature set point in °F 17

RCP_DELTA_TEMP_GRAPHIC

Delta temperature set point (graphical) 17

RCP_TIME_24_HOURS

Time in 24h format 18

RCP_TIME_AM_HOURS

Time in 12h format (AM) 19

RCP_TIME_PM_HOURS

Time in 12h format (PM) 20

RCP_TIME_DAY_MONTH

Date in dd.mm format 21

RCP_TIME_MONTH_DAY

Date in mm.dd format 22

enum RCP_PRESENCE

Presence enums for D2-00-xx profiles.

Enumerator:
NO_CHANGE

No change 0

PRESENT

Present 1

NOT_PRESENT

Not present 2

NIGHT_TIME

Night time reduction 3

enum RCP_USER_ACTION

User action enums for D2-00-xx profiles.

Enumerator:
PRESENCE

Presence 1

TEMP_DOWN

Temperature set point "down" or "-" 2

TEMP_UP

Temperature set point "up" or "+" 5

FAN

Fan 6

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D201xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D201xx.h File Reference
#include "eoD2EEProfile.h"
Include dependency graph for eoEEP_D201xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_D201xx
The class to handle EEP D201 profiles. More...

Enumerations

enum COMMANDS {
ACTUATOR_SET_OUTPUT = 0x01, ACTUATOR_SET_LOCAL = 0x02, ACTUATOR_STATUS_QUERY = 0x03, ACTUATOR_STATUS_RESPONSE = 0x04,
ACTUATOR_SET_MEASUREMENT = 0x05, ACTUATOR_MEASUREMENT_QUERY = 0x06, ACTUATOR_MEASUREMENT_RESPONSE = 0x07, ACTUATOR_PILOTWIRE_SET = 0x08,
ACTUATOR_PILOTWIRE_QUERY = 0x09, ACTUATOR_PILOTWIRE_RESPONSE = 0x0A
}
Command enums for D2-01-xx profiles. More...
enum VLD_ON_OFF_INDEX {
TAUGHT_IN_DEVICES = 0x00, OVER_CURRENT_SHUT = 0x01, RESET_OVER_CURRENT = 0x02, LOCAL_CONTROL = 0x03,
USER_INDICATION = 0x04, REPORT_MEASUREMENT = 0x05, RESET_MEASUREMENT = 0x06, MEASUREMENT_MODE = 0x07,
QUERY = 0x08, PWR_FAILURE = 0x09
}
Index enums for D2-01-xx profiles. More...
enum VLD_TIME_INDEX {
DIMMING_SLOW = 0x00, DIMMING_MEDIUM = 0x01, DIMMING_FAST = 0x02, MAX_SUB_TIME = 0x03,
MIN_SUB_TIME = 0x04
}
Time index enums for D2-01-xx profiles. More...
enum VLD_UNITS {
ENERGY_WS = 0x00, ENERGY_WH = 0x01, ENERGY_KWH = 0x02, POWER_W = 0x03,
POWER_KW = 0x04
}
Unit enums for D2-01-xx profiles. More...
enum VLD_DIM_VALUE {
SWITCH_TO_NEW = 0x00, DIM_TO_NEW_FAST = 0x01, DIM_TO_NEW_MED = 0x02, DIM_TO_NEW_SLOW = 0x03,
DIM_STOP = 0x04
}
Dim enums for D2-01-xx profiles. More...
enum | VLD_ERROR_LEVEL { HARDWARE_OK = 0x00, HARDWARE_WARNING = 0x01, HARDWATE_FAIL = 0x02 }
Error level enums for D2-01-xx profiles. More...
enum | VLD_DEFAULT_STATE { STATE_OFF = 0x00, STATE_ON = 0x01, PREV_STATE = 0x02 }
Default state enums for D2-01-xx profiles. More...
enum | VLD_IO_CHANNEL { ALL_SUPPORTED = 0x1E, INPUT_FOR_MAINS = 0x1F }
I/O channel enums for D2-01-xx profiles. More...
enum VLD_PILOTWIRE_MODE {
PILOTWIRE_OFF = 0x00, PILOTWIRE_COMFORT = 0x01, PILOTWIRE_ECO = 0x02, PILOTWIRE_ANTI_FREEZE = 0x03,
PILOTWIRE_COMFORT_1 = 0x04, PILOTWIRE_COMFORT_2 = 0x05
}
Pilotwire mode enums for D2-01-xx profiles. More...

Detailed Description

Enumeration Type Documentation

enum COMMANDS

Command enums for D2-01-xx profiles.

Enumerator:
ACTUATOR_SET_OUTPUT

Actuator Set Output 1

ACTUATOR_SET_LOCAL

Actuator Set Local 2

ACTUATOR_STATUS_QUERY

Actuator Status Query 3

ACTUATOR_STATUS_RESPONSE

Actuator Status Response 4

ACTUATOR_SET_MEASUREMENT

Actuator Set Measurement 5

ACTUATOR_MEASUREMENT_QUERY

Actuator Measurement Query 6

ACTUATOR_MEASUREMENT_RESPONSE

Actuator Measurement Response 7

ACTUATOR_PILOTWIRE_SET

Actuator Set Pilot Wire Mode 8

ACTUATOR_PILOTWIRE_QUERY

Actuator Pilot Wire Mode Query 9

ACTUATOR_PILOTWIRE_RESPONSE

Actuator Pilot Wire Mode Response 10

enum VLD_DEFAULT_STATE

Default state enums for D2-01-xx profiles.

Enumerator:
STATE_OFF

Defaulst state OFF or 0% 0

STATE_ON

Defaulst state ON or 100% 1

PREV_STATE

Defaulst state remember previous state 2

enum VLD_DIM_VALUE

Dim enums for D2-01-xx profiles.

Enumerator:
SWITCH_TO_NEW

Switch to new output value 0

DIM_TO_NEW_FAST

Dim to new output value - fast 1

DIM_TO_NEW_MED

Dim to new output value - medium 2

DIM_TO_NEW_SLOW

SDim to new output value - slow 3

DIM_STOP

Stop dimming 4

enum VLD_ERROR_LEVEL

Error level enums for D2-01-xx profiles.

Enumerator:
HARDWARE_OK

Hardware OK 0

HARDWARE_WARNING

Hardware warning 1

HARDWATE_FAIL

Hardware failure 2

enum VLD_IO_CHANNEL

I/O channel enums for D2-01-xx profiles.

Enumerator:
ALL_SUPPORTED

All output channels supported by the device 0

INPUT_FOR_MAINS

Input channel (from mains only) 1

enum VLD_ON_OFF_INDEX

Index enums for D2-01-xx profiles.

Enumerator:
TAUGHT_IN_DEVICES

Taught-in devices 0

OVER_CURRENT_SHUT

Over current shut down 1

RESET_OVER_CURRENT

Reset over current shut down 2

LOCAL_CONTROL

Local control 3

USER_INDICATION

User interface indication 4

REPORT_MEASUREMENT

Report measurement 5

RESET_MEASUREMENT

Reset measurement 6

MEASUREMENT_MODE

Measurement mode 7

QUERY

Query 8

PWR_FAILURE

Power failure 9

enum VLD_PILOTWIRE_MODE

Pilotwire mode enums for D2-01-xx profiles.

Enumerator:
PILOTWIRE_OFF

Off 0

PILOTWIRE_COMFORT

Comfort 1

PILOTWIRE_ECO

Eco 2

PILOTWIRE_ANTI_FREEZE

Anti-freeze 3

PILOTWIRE_COMFORT_1

Comfort 1 4

PILOTWIRE_COMFORT_2

Comfort 2 5

enum VLD_TIME_INDEX

Time index enums for D2-01-xx profiles.

Enumerator:
DIMMING_SLOW

Dimming timer slow 0

DIMMING_MEDIUM

Dimming timer medium 1

DIMMING_FAST

Dimming timer fast 2

MAX_SUB_TIME

Maximum time between two subsequent actuator 3

MIN_SUB_TIME

Minimum time between two subsequent actuator 4

enum VLD_UNITS

Unit enums for D2-01-xx profiles.

Enumerator:
ENERGY_WS

Energy in Ws 0

ENERGY_WH

Energy in Wh 1

ENERGY_KWH

Energy in kWh 2

POWER_W

Power in W 3

POWER_KW

Power in kW 4

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D202xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D202xx.h File Reference
#include "eoD2EEProfile.h"
Include dependency graph for eoEEP_D202xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_D202xx
The class to handle EEP D202 profiles. More...

Enumerations

enum | VLD_COMMANDS { SENSOR_MEASUREMENT = 0x01, SENSOR_TEST_TRIGGER = 0x02, ACTUATOR_SET = 0x03, SENSOR_QUERY = 0x04 }
Command enums for D2-02-xx profiles. More...
enum VLD_INDEXS {
VLD_SELF_TEST = 0x00, VLD_TRIGGER_ALARM = 0x01, VLD_REPORT_MEASUREMENT = 0x02, VLD_MAX_TIME = 0x03,
VLD_MIN_TIME = 0x04
}
Index enums for D2-02-xx profiles. More...
enum | VLD_SMOKE_DETECTION { NO_SMOKE = 0x00, SMOKE_IONIZATION = 0x01, SMOKE_OPTICAL = 0x02, SMOKE_BOTH = 0x03 }
Smoke detection enums for D2-02-xx profiles. More...
enum | VLD_QUERY_STATUS { QUERY_TEMP = 0x00, QUERY_LUMINANCE = 0x01, QUERY_OCCUPANCY = 0x02, QUERY_SMOPKE = 0x03 }
Query enums for D2-02-xx profiles. More...

Detailed Description

Enumeration Type Documentation

enum VLD_COMMANDS

Command enums for D2-02-xx profiles.

Enumerator:
SENSOR_MEASUREMENT

Sensor Measurement 1

SENSOR_TEST_TRIGGER

Sensor Test/Trigger 2

ACTUATOR_SET

Actuator Set Measurement 3

SENSOR_QUERY

Sensor Measurementuery 4

enum VLD_INDEXS

Index enums for D2-02-xx profiles.

Enumerator:
VLD_SELF_TEST

Self-test 0

VLD_TRIGGER_ALARM

Trigger alarm 1

VLD_REPORT_MEASUREMENT

Report measurement 2

VLD_MAX_TIME

Maximum time between two subsequent actuator 3

VLD_MIN_TIME

Minimum time between two subsequent actuator 4

enum VLD_QUERY_STATUS

Query enums for D2-02-xx profiles.

Enumerator:
QUERY_TEMP

Query temperature 0

QUERY_LUMINANCE

Query illuminaion 1

QUERY_OCCUPANCY

Query occupancy 2

QUERY_SMOPKE

Query smoke 3

enum VLD_SMOKE_DETECTION

Smoke detection enums for D2-02-xx profiles.

Enumerator:
NO_SMOKE

No smoke detected 0

SMOKE_IONIZATION

Smoke detected via ionization chamber 1

SMOKE_OPTICAL

Smoke detected via optical chamber 2

SMOKE_BOTH

Smoke detected via both chamber 3

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D203xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D203xx.h File Reference
#include "eoF6EEProfile.h"
#include "eoD2EEProfile.h"
Include dependency graph for eoEEP_D203xx.h:

Go to the source code of this file.

Classes

class eoEEP_D203xx
The class to handle EEP D203 Secure Light and Blind Control. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D204xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D204xx.h File Reference
#include "eoD2EEProfile.h"
Include dependency graph for eoEEP_D204xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_D204xx
The class to handle EEP D204 Secure Light and Blind Control. More...

Enumerations

enum NS_BATTERY_AUTONOMY {
NS_BATTERY_100_875 = 0x00, NS_BATTERY_875_75 = 0x01, NS_BATTERY_75_625 = 0x02, NS_BATTERY_625_50 = 0x03,
NS_BATTERY_50_375 = 0x04, NS_BATTERY_375_25 = 0x05, NS_BATTERY_25_125 = 0x06, NS_BATTERY_125_0 = 0x07
}
Enums for Battery autonomy. More...

Detailed Description

Enumeration Type Documentation

enum NS_BATTERY_AUTONOMY

Enums for Battery autonomy.

Enumerator:
NS_BATTERY_100_875

0 100-87.5%

NS_BATTERY_875_75

1 87.5-75%

NS_BATTERY_75_625

2 75-62.5%

NS_BATTERY_625_50

3 62.5-50%

NS_BATTERY_50_375

4 50-37.5%

NS_BATTERY_375_25

5 37.5-25%

NS_BATTERY_25_125

6 25-12.5%

NS_BATTERY_125_0

7 12.5-0%

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D205xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D205xx.h File Reference
#include "eoD2EEProfile.h"
Include dependency graph for eoEEP_D205xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_D205xx
The class to handle EEP D205 profiles. More...

Enumerations

enum | D205_INDEX_ENUM { CUR_VER_POSITION = 0x00, CUR_ROT_ANGLE = 0x01, SET_VER_DURATION = 0x02, SET_ROT_DURATION = 0x03 }
Index enums for D2-05-xx profiles. More...
enum D205_MESSAGE_ID_ENUM {
GOTO_MSG = 0x01, STOP_MSG = 0x02, QUERY_MSG = 0x03, REPLY_MSG = 0x04,
SET_PARAM_MSG = 0x05
}
Message IDs for D2-05-xx profiles. More...
enum | D205_REPOSITIONING_ENUM { REPOS_DIRECT_POS_ANG = 0x00, REPOS_UP_POS_ANG = 0x01, REPOS_DOWN_POS_ANG = 0x02 }
Repositioning enums for D2-05-xx profiles. More...
enum | D205_LOCK_MODE_ENUM { LOCK_NORMAL = 0x00, LOCK_BLOCKAGE = 0x01, LOCK_ALARM = 0x02, LOCK_DEBLOCKAGE = 0x07 }
Locking mode enums for D2-05-xx profiles. More...
enum D205_AET_ALARM_ENUM {
ALARM_NO_ACTION = 0x00, ALARM_IMMEDIATE_STOP = 0x01, ALARM_UP = 0x02, ALARM_DOWN = 0x03,
ALARM_NO_CHANGE = 0x07
}
Set alarm action enums for D2-05-xx profiles. More...

Detailed Description

Enumeration Type Documentation

enum D205_AET_ALARM_ENUM

Set alarm action enums for D2-05-xx profiles.

Enumerator:
ALARM_NO_ACTION

No action 0

ALARM_IMMEDIATE_STOP

Immediate stop 1

ALARM_UP

Go up (0%) 2

ALARM_DOWN

Go down (100%) 3

ALARM_NO_CHANGE

Deblockage / - 7

enum D205_INDEX_ENUM

Index enums for D2-05-xx profiles.

Enumerator:
CUR_VER_POSITION

Current vertical position flag 0

CUR_ROT_ANGLE

Current rotation angle flag 1

SET_VER_DURATION

Set vertical duration flag 2

SET_ROT_DURATION

Set rotation duration flag 3

enum D205_LOCK_MODE_ENUM

Locking mode enums for D2-05-xx profiles.

Enumerator:
LOCK_NORMAL

Do not change / normal 0

LOCK_BLOCKAGE

Set blockage mode / blockage mode 1

LOCK_ALARM

Set alarm mode / alarm mode 2

LOCK_DEBLOCKAGE

Deblockage / - 7

enum D205_MESSAGE_ID_ENUM

Message IDs for D2-05-xx profiles.

Enumerator:
GOTO_MSG

Goto command 1

STOP_MSG

Stop command 2

QUERY_MSG

Query command 3

REPLY_MSG

Reply command 4

SET_PARAM_MSG

Set parameters command 5

enum D205_REPOSITIONING_ENUM

Repositioning enums for D2-05-xx profiles.

Enumerator:
REPOS_DIRECT_POS_ANG

Go directly to POS/ANG 0

REPOS_UP_POS_ANG

Go up(0%) then to POS/ANG 1

REPOS_DOWN_POS_ANG

Go down(100%) then to POS/ANG 2

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D206xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D206xx.h File Reference
#include "eoD2EEProfile.h"
Include dependency graph for eoEEP_D206xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_D206xx
The class to handle EEP D206 profiles. More...

Enumerations

enum D206_INDEX_ENUM {
BURGLARY_ALARM = 0x00, PROTECTION_PLUS_ALARM = 0x01, HANDLE_POSITION = 0x02, WINDOW_STATE = 0x03,
BUTTON_1 = 0x04, BUTTON_2 = 0x05, MOTION = 0x06, VACATION_MODE = 0x07,
HANDLE_CLICK = 0x08, BATTERY_CLICK = 0x09, SENSOR_INTERVAL = 0x0A, VACATION_INTERVAL = 0x0B,
POWER_ONS = 0x0C, ALARMS = 0x0D, HANDLE_CLOSED = 0x0E, HANDLE_OPENED = 0x0F,
HANDLE_TILTED = 0x10, WINDOW_TILTS = 0x11, START_TRANSMISSION_CONFIG_SETTINGS = 0x12, START_TRANSMISSION_LOG_DATA = 0x13
}
Index enums for D2-06-xx profiles. More...
enum D206_MSG_TYPE_ENUM {
MSG_SENSOR_VALUES = 0x00, MSG_CONFIG_REPORT = 0x01, MSG_LOG_DATA_1 = 0x02, MSG_LOG_DATA_2 = 0x03,
MSG_LOG_DATA_3 = 0x04, MSG_LOG_DATA_4 = 0x05, MSG_CTRL_SETTINGS = 0x06
}
Message type enums for D2-06-xx profiles. More...

Detailed Description

Enumeration Type Documentation

enum D206_INDEX_ENUM

Index enums for D2-06-xx profiles.

Enumerator:
BURGLARY_ALARM

Burglary Alarm 0

PROTECTION_PLUS_ALARM

Protection Plus Alarm 1

HANDLE_POSITION

Handle Position 2

WINDOW_STATE

Window State 3

BUTTON_1

Button 1 4

BUTTON_2

Button 2 5

MOTION

Motion 6

VACATION_MODE

Vacation Mode 7

HANDLE_CLICK

Handled Closed Click 8

BATTERY_CLICK

Battery Low Click 9

SENSOR_INTERVAL

Sensor Update Interval 10

VACATION_INTERVAL

Vacation Blink Interval 11

POWER_ONS

Power Ons 12

ALARMS

Alarms 13

HANDLE_CLOSED

Handle Movements Closed 14

HANDLE_OPENED

Handle Movements Opened 15

HANDLE_TILTED

Handle Movements Tilted 16

WINDOW_TILTS

Window Tilts 17

START_TRANSMISSION_CONFIG_SETTINGS

Start Transmission of Configuration Settings 18

START_TRANSMISSION_LOG_DATA

Start Transmission of Log Data Packets 19

enum D206_MSG_TYPE_ENUM

Message type enums for D2-06-xx profiles.

Enumerator:
MSG_SENSOR_VALUES

Sensor Values 0

MSG_CONFIG_REPORT

Configuration Report 1

MSG_LOG_DATA_1

Log Data 01 2

MSG_LOG_DATA_2

Log Data 02 3

MSG_LOG_DATA_3

Log Data 03 4

MSG_LOG_DATA_4

Log Data 04 5

MSG_CTRL_SETTINGS

Control and Settings 6

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D210xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D210xx.h File Reference
#include "eoD2EEProfile.h"
Include dependency graph for eoEEP_D210xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_D210xx
The class to handle EEP D210 profiles. More...

Enumerations

enum D210_INDEX_ENUM {
MSG_CONTINUATION = 0x00, INFO_REQUEST_CLASS = 0x01, FEEDBACK_CLASS = 0x02, GENERAL_MSG_TYPE = 0x03,
RELHUM_VALIDITY = 0x04, FANSPEED_VALIDITY = 0x05, FANSPEED_MODE = 0x06, CUSTOM_WARNING_1 = 0x07,
CUSTOM_WARNING_2 = 0x08, MOLD_WARNING = 0x09, WINDOW_OPEN_DETECTION = 0x0A, BATTERY_STATUS = 0x0B,
SOLAR_POWERED_STATUS = 0x0C, PIR_STATUS = 0x0D, COOLING_STATUS = 0x0E, HEATING_STATUS = 0x0F,
TEMP_SETPOINT_VALIDITY = 0x10, TEMP_VALIDITY = 0x11, PIR_LOCK = 0x12, TEMP_LOCK = 0x13,
DISPLAY_LOCK = 0x14, DATE_TIME_LOCK = 0x15, TIME_PROG_LOCK = 0x16, OCCUPANCY_LOCK = 0x17,
TEMP_SETPOINT_LOCK = 0x18, FAN_SPEED_LOCK = 0x19, RADIO_COM_INTERVAL = 0x1A, KEY_LOCK = 0x1B,
DISPLAY_CONTENT = 0x1C, TEMP_SCALE = 0x1D, DAYLIGHT_SAVE = 0x1E, TIME_NOTATION = 0x1F,
TIME_CURRENT_DAY = 0x20, TIME_CURRENT_MONTH = 0x21, TIME_CURRENT_YEAR = 0x22, TIME_CURRENT_MINUTE = 0x23,
TIME_CURRENT_HOUR = 0x24, DATE_TIME_UPDATE_FLAG = 0x25, RECENT_TEMP_SETPOINT = 0x26, BUILDING_PROTECT_TEMP_SETPOINT = 0x27,
PRECOMFORT_TEMP_SETPOINT = 0x28, ECONOMY_TEMP_SETPOINT = 0x29, COMFORT_TEMP_SETPOINT = 0x2A, BUILDING_PROTECT_TEMP_SETPOINT_VALIDITY = 0x2B,
PRECOMFORT_TEMP_SETPOINT_VALIDITY = 0x2C, ECONOMY_TEMP_TEMP_SETPOINT_VALIDITY = 0x2D, COMFORT_TEMP_SETPOINT_VALIDITY = 0x2E, END_TIME_MINUTE = 0x2F,
END_TIME_HOUR = 0x30, START_TIME_MINUTE = 0x31, START_TIME_HOUR = 0x32, TIME_PROG_DELETION = 0x33
}
Index enums for D2-10-xx profiles. More...
enum D210_MESSAGE_ID_ENUM {
GENERAL_MSG = 0x00, DATA_MSG = 0x01, CONFIG_MSG = 0x02, ROOM_CONTROL_MSG = 0x03,
TIME_PROG_MSG = 0x04
}
Message IDs for D2-10-xx profiles. More...
enum | D210_MSG_CONTINUATION_ENUM { MSG_COMPLETE = 0x00, MSG_INCOMPLETE = 0x01, MSG_AUTO_CONTROL = 0x02 }
Message continuation enums for D2-10-xx profiles. More...
enum D210_INFO_REQUEST_ENUM {
ACKNOWLEDGE_REQUEST = 0x00, DATA_REQUEST = 0x01, CONFIG_REQUEST = 0x02, ROOM_CONTROL_REQUEST = 0x03,
TIME_PROG_REQUEST = 0x04
}
Information request classifier enums for D2-10-xx profiles. More...
enum | D210_FEEDBACK_CLASS_ENUM { ACKNOWLEDGE_FEEDBACK = 0x00, TEL_REPETITION_FEEDBACK = 0x01, MSG_REPETITION_FEEDBACK = 0x02 }
Feedback classifier enums for D2-10-xx profiles. More...
enum | D210_GENERAL_MSG_TYPE_ENUM { MSG_TYPE_FEEDBACK = 0x00, MSG_TYPE_INFO_REQUEST = 0x01 }
General message type enums for D2-10-xx profiles. More...
enum | D210_VALIDITY_FLAG_ENUM { VALIDITY_NO_CHANGE = 0x00, VALIDITY_VALID_VALUE = 0x01 }
Validity flag enums for D2-10-xx profiles. More...
enum | D210_FAN_SPEED_MODE_ENUM { FAN_SPEED_CENTRAL_CONTROL = 0x00, FAN_SPEED_INDIVIDUAL_CONTROL = 0x01 }
Fan speed mode enums for D2-10-xx profiles. More...
enum | D210_WINDOW_OPEN_ENUM { WINDOW_NO_CHANGE = 0x00, WINDOW_CLOSED = 0x01, WINDOW_OPEN = 0x02 }
Window open detection enums for D2-10-xx profiles. More...
enum | D210_BATTERY_STATUS_ENUM { BATTERY_VLD_NO_CHANGE = 0x00, BATTERY_VLD_GOOD = 0x01, BATTERY_VLD_LOW = 0x02, BATTERY_VLD_CRITICAL = 0x03 }
Battery status enums for D2-10-xx profiles. More...
enum | D210_SOLAR_POWERED_ENUM { SOLAR_POWERED = 0x00, NOT_SOLAR_POWERED = 0x01 }
Solar-powered status enums for D2-10-xx profiles. More...
enum | D210_PIR_STATUS_ENUM { PIR_NO_CHANGE = 0x00, PIR_NO_MOVEMENT = 0x01, PIR_MOVEMENT = 0x02, PIR_LOCKED = 0x03 }
Indicates if the PIR detected a movement. More...
enum | D210_OCCUPANCY_STATUS_ENUM { OCCUPANCY_NO_CHANGE = 0x00, OCCUPANCY_PRESSED_OCCUPIED = 0x01, OCCUPANCY_PRESSED_UNOCCUPIED = 0x02 }
Occupancy button status enums for D2-10-xx profiles. More...
enum | D210_COOLING_HEATING_STATUS_ENUM { COOLING_HEATING_NO_CHANGE = 0x00, COOLING_HEATING_ON = 0x01, COOLING_HEATING_OFF = 0x02, COOLING_HEATING_AUTO = 0x03 }
Cooling/Heating operation status enums for D2-10-xx profiles. More...
enum | D210_ROOM_CONTROL_ENUM { ROOM_CONTROL_COMFORT = 0x00, ROOM_CONTROL_ECONOMY = 0x01, ROOM_CONTROL_PRECOMFORT = 0x02, ROOM_CONTROL_BUILDING_PROTECT = 0x03 }
Room control mode enums for D2-10-xx profiles. More...
enum | D210_LOCK_ENUM { LOCKED = 0x00, UNLOCKED = 0x01 }
Lock status enums for D2-10-xx profiles. More...
enum | D210_RADIO_COM_INTERVAL_ENUM { RADIO_NO_INTERVAL = 0x00, RADIO_3_HOURS_INTERVAL = 0x3D, RADIO_12_HOURS_INTERVAL = 0x3E, RADIO_24_HOURS_INTERVAL = 0x3F }
Radio communication interval enums for D2-10-xx profiles. More...
enum D210_DISPLAY_CONTENT_ENUM {
DISPLAY_NO_CHANGE = 0x00, DISPLAY_DEFAULT = 0x01, DISPLAY_TIME = 0x02, DISPLAY_INTERNAL_TEMP = 0x03,
DISPLAY_EXTERNAL_TEMP = 0x04, DISPLAY_TEMP_SETPOINT = 0x05, DISPLAY_OFF = 0x06, DISPLAY_HUMIDITY = 0x07
}
Display content enums for D2-10-xx profiles. More...
enum | D210_TEMP_SCALE_ENUM { TEMP_SCALE_NO_CHANGE = 0x00, TEMP_SCALE_DEFAULT = 0x01, TEMP_SCALE_CELSIUS = 0x02, TEMP_SCALE_FAHRENHEIT = 0x03 }
Temperature scale enums for D2-10-xx profiles. More...
enum | D210_DAYLIGHT_SAVE_ENUM { DAYLIGHT_SUPPORTED = 0x00, DAYLIGHT_NOT_SUPPORTED = 0x01 }
Daylight saving time enums for D2-10-xx profiles. More...
enum | D210_TIME_NOTATION_ENUM { TIME_NOTATION_NO_CHANGE = 0x00, TIME_NOTATION_DEFAULT = 0x01, TIME_NOTATION_24_HOURS = 0x02, TIME_NOTATION_12_HOURS = 0x03 }
Time notation enums for D2-10-xx profiles. More...
enum | D210_DATE_TIME_UPDATE_ENUM { DATE_TIME_NO_UPDATE = 0x00, DATE_TIME_UPDATE = 0x01 }
Day / time update enums for D2-10-xx profiles. More...
enum D210_PERIOD_ENUM {
PERIOD_MONDAY_SUNDAY = 0x00, PERIOD_MONDAY_FRIDAY = 0x01, PERIOD_SATURDAY_SUNDAY = 0x02, PERIOD_MONDAY = 0x03,
PERIOD_TUESDAY = 0x04, PERIOD_WEDNESDAY = 0x05, PERIOD_THURSDAY = 0x06, PERIOD_FRIDAY = 0x07,
PERIOD_SATURDAY = 0x08, PERIOD_SUNDAY = 0x09, PERIOD_MONDAY_WEDNESDAY = 0x0A, PERIOD_TUESDAY_THURSDAY = 0x0B,
PERIOD_WEDNESDAY_FRIDAY = 0x0C, PERIOD_THURSDAY_FRIDAY = 0x0D, PERIOD_FRIDAY_SUNDAY = 0x0E, PERIOD_FRIDAY_MONDAY = 0x0F
}
Period enums for D2-10-xx profiles. More...
enum | D210_TIME_PROG_DELETION_ENUM { TIME_PROG_NO_DELETE = 0x00, TIME_PROG_DELETE = 0x01 }
Time program deletion enums for D2-10-xx profiles. More...

Detailed Description

Enumeration Type Documentation

enum D210_BATTERY_STATUS_ENUM

Battery status enums for D2-10-xx profiles.

Enumerator:
BATTERY_VLD_NO_CHANGE

No change 0

BATTERY_VLD_GOOD

Good 1

BATTERY_VLD_LOW

Low 2

BATTERY_VLD_CRITICAL

Critical 3

enum D210_COOLING_HEATING_STATUS_ENUM

Cooling/Heating operation status enums for D2-10-xx profiles.

Enumerator:
COOLING_HEATING_NO_CHANGE

No change 0

COOLING_HEATING_ON

On 1

COOLING_HEATING_OFF

Off 2

COOLING_HEATING_AUTO

Automatic 3

enum D210_DATE_TIME_UPDATE_ENUM

Day / time update enums for D2-10-xx profiles.

Enumerator:
DATE_TIME_NO_UPDATE

No update 0

DATE_TIME_UPDATE

Update 1

enum D210_DAYLIGHT_SAVE_ENUM

Daylight saving time enums for D2-10-xx profiles.

Enumerator:
DAYLIGHT_SUPPORTED

Supported 0

DAYLIGHT_NOT_SUPPORTED

Not supported 1

enum D210_DISPLAY_CONTENT_ENUM

Display content enums for D2-10-xx profiles.

Enumerator:
DISPLAY_NO_CHANGE

No change 0

DISPLAY_DEFAULT

Default 1

DISPLAY_TIME

Time 2

DISPLAY_INTERNAL_TEMP

Room temperature (internal) 3

DISPLAY_EXTERNAL_TEMP

Room temperature (external) 4

DISPLAY_TEMP_SETPOINT

Temperature set point 5

DISPLAY_OFF

Display off 6

DISPLAY_HUMIDITY

Humidity 7

enum D210_FAN_SPEED_MODE_ENUM

Fan speed mode enums for D2-10-xx profiles.

Enumerator:
FAN_SPEED_CENTRAL_CONTROL

Central fan speed control 0

FAN_SPEED_INDIVIDUAL_CONTROL

Individual fan speed control 1

enum D210_FEEDBACK_CLASS_ENUM

Feedback classifier enums for D2-10-xx profiles.

Enumerator:
ACKNOWLEDGE_FEEDBACK

Acknowledge/heartbeat 0

TEL_REPETITION_FEEDBACK

Telegram repetition request 1

MSG_REPETITION_FEEDBACK

Message repetition request 2

enum D210_GENERAL_MSG_TYPE_ENUM

General message type enums for D2-10-xx profiles.

Enumerator:
MSG_TYPE_FEEDBACK

Feedback 0

MSG_TYPE_INFO_REQUEST

Information request 1

enum D210_INDEX_ENUM

Index enums for D2-10-xx profiles.

Enumerator:
MSG_CONTINUATION

Message continuation flag 0

INFO_REQUEST_CLASS

Information request classifier 1

FEEDBACK_CLASS

Feedback classifier 2

GENERAL_MSG_TYPE

General message typer 3

RELHUM_VALIDITY

Humidity validity flag 4

FANSPEED_VALIDITY

Fan speed validity flag 5

FANSPEED_MODE

Fan speed mode 6

CUSTOM_WARNING_1

Custom warning 1 7

CUSTOM_WARNING_2

Custom warning 2 8

MOLD_WARNING

Mold warning 9

WINDOW_OPEN_DETECTION

Window open detection 10

BATTERY_STATUS

Battery status 11

SOLAR_POWERED_STATUS

Solar-powered status 12

PIR_STATUS

PIR status 13

COOLING_STATUS

Cooling operation status 14

HEATING_STATUS

Heating operation status 15

TEMP_SETPOINT_VALIDITY

Temperature set point validity 16

TEMP_VALIDITY

Temperature validity 17

PIR_LOCK

PIR status lock 18

TEMP_LOCK

Temperature scale lock 19

DISPLAY_LOCK

Display content lock 20

DATE_TIME_LOCK

Date / Time lock 21

TIME_PROG_LOCK

Time program lock 22

OCCUPANCY_LOCK

Occupancy lock 23

TEMP_SETPOINT_LOCK

Temperature set point lock 24

FAN_SPEED_LOCK

Fan speed lock 25

RADIO_COM_INTERVAL

Radio communication interval 26

KEY_LOCK

Key lock 27

DISPLAY_CONTENT

Display content 28

TEMP_SCALE

Temperature scale 29

DAYLIGHT_SAVE

Daylight saving time flag 30

TIME_NOTATION

Time notation 31

TIME_CURRENT_DAY

Day 32

TIME_CURRENT_MONTH

Month 33

TIME_CURRENT_YEAR

Year 34

TIME_CURRENT_MINUTE

Time minute 35

TIME_CURRENT_HOUR

Time hour 36

DATE_TIME_UPDATE_FLAG

Day / time update 37

RECENT_TEMP_SETPOINT

Recent temperature 38

BUILDING_PROTECT_TEMP_SETPOINT

Building protection temperature set point 39

PRECOMFORT_TEMP_SETPOINT

Pre-comfort temperature set point 40

ECONOMY_TEMP_SETPOINT

Economy temperature set point 41

COMFORT_TEMP_SETPOINT

Comfort temperature set point 42

BUILDING_PROTECT_TEMP_SETPOINT_VALIDITY

Building protection temperature set point validity 43

PRECOMFORT_TEMP_SETPOINT_VALIDITY

Pre-comfort temperature set point validity 44

ECONOMY_TEMP_TEMP_SETPOINT_VALIDITY

Economy temperature set point validity 45

COMFORT_TEMP_SETPOINT_VALIDITY

Comfort temperature set point validity 46

END_TIME_MINUTE

End time minute 47

END_TIME_HOUR

End time hour 48

START_TIME_MINUTE

Start time minute 49

START_TIME_HOUR

Start time hour 50

TIME_PROG_DELETION

Time program deletion 51

enum D210_INFO_REQUEST_ENUM

Information request classifier enums for D2-10-xx profiles.

Enumerator:
ACKNOWLEDGE_REQUEST

Acknowledge request 0

DATA_REQUEST

Data request 1

CONFIG_REQUEST

Configuration request 2

ROOM_CONTROL_REQUEST

Room control setup request 3

TIME_PROG_REQUEST

Time program request 4

enum D210_LOCK_ENUM

Lock status enums for D2-10-xx profiles.

Enumerator:
LOCKED

Lock 0

UNLOCKED

Unlocked 1

enum D210_MESSAGE_ID_ENUM

Message IDs for D2-10-xx profiles.

Enumerator:
GENERAL_MSG

General Message 0

DATA_MSG

Data Message 1

CONFIG_MSG

Configuration Message 2

ROOM_CONTROL_MSG

Room Control Setup 3

TIME_PROG_MSG

Time program Setup 4

enum D210_MSG_CONTINUATION_ENUM

Message continuation enums for D2-10-xx profiles.

Enumerator:
MSG_COMPLETE

Complete 0

MSG_INCOMPLETE

Incomplete 1

MSG_AUTO_CONTROL

Automatic message control 2

enum D210_OCCUPANCY_STATUS_ENUM

Occupancy button status enums for D2-10-xx profiles.

Enumerator:
OCCUPANCY_NO_CHANGE

No change 0

OCCUPANCY_PRESSED_OCCUPIED

Button pressed and occupied 1

OCCUPANCY_PRESSED_UNOCCUPIED

Button pressed and unoccupied 2

enum D210_PERIOD_ENUM

Period enums for D2-10-xx profiles.

Enumerator:
PERIOD_MONDAY_SUNDAY

Monday - Sunday 0

PERIOD_MONDAY_FRIDAY

Monday - Friday 1

PERIOD_SATURDAY_SUNDAY

Saturday - Sunday 2

PERIOD_MONDAY

Monday 3

PERIOD_TUESDAY

Tuesday 4

PERIOD_WEDNESDAY

Wednesday 5

PERIOD_THURSDAY

Thursday 6

PERIOD_FRIDAY

Friday 7

PERIOD_SATURDAY

Saturday 8

PERIOD_SUNDAY

Sunday 9

PERIOD_MONDAY_WEDNESDAY

Monday - Wednesday 10

PERIOD_TUESDAY_THURSDAY

Tuesday - Thursday 11

PERIOD_WEDNESDAY_FRIDAY

Wednesday - Friday 12

PERIOD_THURSDAY_FRIDAY

Thursday - Friday 13

PERIOD_FRIDAY_SUNDAY

Friday - Sunday 14

PERIOD_FRIDAY_MONDAY

Friday - Monday 15

enum D210_PIR_STATUS_ENUM

Indicates if the PIR detected a movement.

Enumerator:
PIR_NO_CHANGE

No change 0

PIR_NO_MOVEMENT

No movement detected 1

PIR_MOVEMENT

Movement 2

PIR_LOCKED

Locked 3

enum D210_RADIO_COM_INTERVAL_ENUM

Radio communication interval enums for D2-10-xx profiles.

Enumerator:
RADIO_NO_INTERVAL

No communication interval 0

RADIO_3_HOURS_INTERVAL

3 hours 61

RADIO_12_HOURS_INTERVAL

12 hours 62

RADIO_24_HOURS_INTERVAL

24 hours 63

enum D210_ROOM_CONTROL_ENUM

Room control mode enums for D2-10-xx profiles.

Enumerator:
ROOM_CONTROL_COMFORT

Comfort 0

ROOM_CONTROL_ECONOMY

Economy 1

ROOM_CONTROL_PRECOMFORT

Pre-comfort 2

ROOM_CONTROL_BUILDING_PROTECT

Building protection 3

enum D210_SOLAR_POWERED_ENUM

Solar-powered status enums for D2-10-xx profiles.

Enumerator:
SOLAR_POWERED

Solar-powered 0

NOT_SOLAR_POWERED

Not solar-powered 1

enum D210_TEMP_SCALE_ENUM

Temperature scale enums for D2-10-xx profiles.

Enumerator:
TEMP_SCALE_NO_CHANGE

No change 0

TEMP_SCALE_DEFAULT

Default 1

TEMP_SCALE_CELSIUS

Celsius 2

TEMP_SCALE_FAHRENHEIT

Fahrenheit 3

enum D210_TIME_NOTATION_ENUM

Time notation enums for D2-10-xx profiles.

Enumerator:
TIME_NOTATION_NO_CHANGE

No change 0

TIME_NOTATION_DEFAULT

Default 1

TIME_NOTATION_24_HOURS

24 hours 2

TIME_NOTATION_12_HOURS

12 hours 3

enum D210_TIME_PROG_DELETION_ENUM

Time program deletion enums for D2-10-xx profiles.

Enumerator:
TIME_PROG_NO_DELETE

No deletion 0

TIME_PROG_DELETE

Deletion 1

enum D210_VALIDITY_FLAG_ENUM

Validity flag enums for D2-10-xx profiles.

Enumerator:
VALIDITY_NO_CHANGE

No change 0

VALIDITY_VALID_VALUE

Valid value 1

enum D210_WINDOW_OPEN_ENUM

Window open detection enums for D2-10-xx profiles.

Enumerator:
WINDOW_NO_CHANGE

No change 0

WINDOW_CLOSED

Closed 1

WINDOW_OPEN

Open 2

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D220xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D220xx.h File Reference
#include "eoD2EEProfile.h"
Include dependency graph for eoEEP_D220xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_D220xx
The class to handle EEP D220 profiles. More...

Enumerations

enum VLD_FC_INDEXS {
OP_MODE = 0x00, TEMP_LEVEL = 0x01, RELHUM_CONTROL = 0x02, ROOM_SIZE_REFERENCE = 0x03,
RELHUM_THRESHOLD = 0x04, SERVICE_INFO = 0x05
}
Index enums for D2-20-xx profiles. More...
enum | VLD_FC_OP_MODE { OP_MODE_DISABLED = 0x00, OP_MODE_STANDARD_COMPLIANT = 0x01, OP_MODE_NO_CHANGE = 0x0F }
Operating mode enums. More...
enum | VLD_FC_TEMP_LEVEL { TEMP_LEVEL_LOW = 0x00, TEMP_LEVEL_NORMAL = 0x01, TEMP_LEVEL_HIGH = 0x02, TEMP_LEVEL_NO_CHANGE = 0x03 }
Temperature level enums. More...
enum | VLD_FC_ROOM_SIZE_REF { ROOM_SIZE_REF_USED = 0x00, ROOM_SIZE_REF_NOT_USED = 0x01, ROOM_SIZE_REF_DEFAULT = 0x02, ROOM_SIZE_REF_NO_CHANGE = 0x03 }
Room size reference enums. More...
enum VLD_FC_ROOM_SIZE {
ROOM_SIZE_25 = 0x00, ROOM_SIZE_25_50 = 0x01, ROOM_SIZE_50_75 = 0x02, ROOM_SIZE_75_100 = 0x03,
ROOM_SIZE_100_125 = 0x04, ROOM_SIZE_125_150 = 0x05, ROOM_SIZE_150_175 = 0x06, ROOM_SIZE_175_200 = 0x07,
ROOM_SIZE_200_225 = 0x08, ROOM_SIZE_225_250 = 0x09, ROOM_SIZE_250_275 = 0x0A, ROOM_SIZE_275_300 = 0x0B,
ROOM_SIZE_300_325 = 0x0C, ROOM_SIZE_325_350 = 0x0D, ROOM_SIZE_350 = 0x0E, ROOM_SIZE_NO_CHANGE = 0x0F
}
Room size enums. More...
enum | VLD_FC_STAGE { FC_STAGE_AUTO = 0xFD, FC_STAGE_DEFAULT = 0xFE, FC_STAGE_NO_CHANGE = 0xFF }
Fan speed stage enums. More...
enum | VLD_FC_RELHUM_CONTROL { FC_RELHUM_DISABLED = 0x00, FC_RELHUM_ENABLED = 0x01, FC_RELHUM_DEFAULT = 0x02 }
Humidity control enums. More...
enum | VLD_FC_SERVICE_INFORMATION { FC_SERVICE_NO_REPORT = 0x00, FC_SERVICE_AIR_FILTER = 0x01, FC_SERVICE_HW_ERROR = 0x02, FC_SERVICE_NOT_SUPPORTED = 0x07 }
Service information enums. More...

Detailed Description

Enumeration Type Documentation

enum VLD_FC_INDEXS

Index enums for D2-20-xx profiles.

Enumerator:
OP_MODE

Operating Mode 0

TEMP_LEVEL

Temperature Level 1

RELHUM_CONTROL

Humidity Control 2

ROOM_SIZE_REFERENCE

Room Size Reference 3

RELHUM_THRESHOLD

Humidity Threshold 4

SERVICE_INFO

Service Information 5

enum VLD_FC_OP_MODE

Operating mode enums.

Enumerator:
OP_MODE_DISABLED

Disabled 0

OP_MODE_STANDARD_COMPLIANT

Standard Compliant 1

OP_MODE_NO_CHANGE

No Change 15

enum VLD_FC_RELHUM_CONTROL

Humidity control enums.

Enumerator:
FC_RELHUM_DISABLED

Disabled 0

FC_RELHUM_ENABLED

Enabled 1

FC_RELHUM_DEFAULT

Default 2

enum VLD_FC_ROOM_SIZE

Room size enums.

Enumerator:
ROOM_SIZE_25

< 25 m² 0

ROOM_SIZE_25_50

25...50 m² 1

ROOM_SIZE_50_75

50...75 m² 2

ROOM_SIZE_75_100

75...100 m² 3

ROOM_SIZE_100_125

100...125 m² 4

ROOM_SIZE_125_150

125...150 m² 5

ROOM_SIZE_150_175

150...175 m² 6

ROOM_SIZE_175_200

175...200 m² 7

ROOM_SIZE_200_225

200...225 m² 8

ROOM_SIZE_225_250

225...250 m² 9

ROOM_SIZE_250_275

250...275 m² 10

ROOM_SIZE_275_300

275...300 m² 11

ROOM_SIZE_300_325

300...325 m² 12

ROOM_SIZE_325_350

325...350 m² 13

ROOM_SIZE_350

> 375 m² 14

ROOM_SIZE_NO_CHANGE

No Change 15

enum VLD_FC_ROOM_SIZE_REF

Room size reference enums.

Enumerator:
ROOM_SIZE_REF_USED

Used 0

ROOM_SIZE_REF_NOT_USED

Not Used 1

ROOM_SIZE_REF_DEFAULT

Default 2

ROOM_SIZE_REF_NO_CHANGE

No Change 3

enum VLD_FC_SERVICE_INFORMATION

Service information enums.

Enumerator:
FC_SERVICE_NO_REPORT

Nothing to report 0

FC_SERVICE_AIR_FILTER

Air filter error 1

FC_SERVICE_HW_ERROR

Hardware error 2

FC_SERVICE_NOT_SUPPORTED

Not supported 7

enum VLD_FC_STAGE

Fan speed stage enums.

Enumerator:
FC_STAGE_AUTO

Fan speed - Auto 253

FC_STAGE_DEFAULT

Fan speed - Default 254

FC_STAGE_NO_CHANGE

Fan speed - No changed 255

enum VLD_FC_TEMP_LEVEL

Temperature level enums.

Enumerator:
TEMP_LEVEL_LOW

Too Low 0

TEMP_LEVEL_NORMAL

Normal 1

TEMP_LEVEL_HIGH

Too High 2

TEMP_LEVEL_NO_CHANGE

No Change 3

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D230xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D230xx.h File Reference
#include "eoD2EEProfile.h"
Include dependency graph for eoEEP_D230xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_D230xx
The class to handle EEP D230 profiles. More...

Enumerations

enum MSR_COMMANDS {
MSR_SET_HEAT_CONTROLS = 0x01, MSR_HEAT_CONTROL_STATUS_QUERY = 0x02, MSR_HEAT_CONTROL_STATUS_RESPONSE = 0x03, MSR_SET_METER_CONFIGURATION = 0x06,
MSR_METER_STATUS_QUERY = 0x07, MSR_METER_READING_REPORT = 0x08
}
Command enums for D2-30-xx profiles. More...
enum MSR_CHANNELS {
MSR_CHANNEL_SUPPLY_TEMP = 0x00, MSR_CHANNEL_RETURN_TEMP = 0x01, MSR_CHANNEL_REPORT_TIME = 0x02, MSR_CHANNEL_METER_TYPE = 0x03,
MSR_CHANNEL_METER_1 = 0x04, MSR_CHANNEL_METER_2 = 0x05, MSR_CHANNEL_NUM_OF_PULSES = 0x06, MSR_CHANNEL_PRESET_VALUE = 0x07,
MSR_CHANNEL_PROTOCOL = 0x08, MSR_CHANNEL_PULSES_FACTOR = 0x09, MSR_CHANNEL_PRIMARY_ADDR = 0x0A, MSR_CHANNEL_ERROR = 0x0B,
MSR_CHANNEL_ERROR_HCH31 = 0x0C, MSR_CHANNEL_METER_ERROR = 0x0D, MSR_CHANNEL_METER_CHANNEL = 0x0E, MSR_CHANNEL_VALUE_SELECTION = 0x0F
}
Channel enums. More...
enum MSR_TIME_VALUES {
MSR_LOCAL_DEFAULT = 0x00, MSR_1_SECOND = 0x01, MSR_2_SECOND = 0x02, MSR_5_SECOND = 0x03,
MSR_10_SECOND = 0x04, MSR_20_SECOND = 0x05, MSR_50_SECOND = 0x06, MSR_100_SECOND = 0x07,
MSR_200_SECOND = 0x08, MSR_500_SECOND = 0x09, MSR_1000_SECOND = 0x0A
}
Enums for PWM signal intervals. More...
enum MSR_REPORT_TIME_VALUES {
MSR_NO_REPORT = 0x00, MSR_1_SECOND_REPORT = 0x01, MSR_3_SECOND_REPORT = 0x02, MSR_10_SECOND_REPORT = 0x03,
MSR_30_SECOND_REPORT = 0x04, MSR_100_SECOND_REPORT = 0x05, MSR_300_SECOND_REPORT = 0x06, MSR_1000_SECOND_REPORT = 0x07
}
Enums for Minimum auto reporting intervals. More...
enum | MSR_CONNECTED_VALVE { MSR_VALVE_NORM_CLOSED = 0x00, MSR_VALVE_NORM_OPEN = 0x01 }
Enums for type of connected valve. More...
enum | MSR_INIT_SEQU { MSR_NO_ACTION = 0x00, MSR_RUN_INIT_SEQU = 0x01 }
Enums for running init sequence. More...
enum MSR_ERROR_CODE {
MSR_ERROR_NO_FAULT = 0x00, MSR_ERROR_GENERAL = 0x01, MSR_ERROR_INIT_SEQU_RUNNING = 0x02, MSR_ERROR_CHANNEL_NOT_AVAILABLE = 0x03,
MSR_ERROR_TEMP_SENSOR = 0x04, MSR_ERROR_VALVE = 0x05, MSR_ERROR_TEMP_SENSOR_VALVE = 0x06
}
Enums for Status/Error. More...
enum MSR_ERROR_CODE_CH31 {
MSR_ERROR_CH31_NO_FAULT = 0x00, MSR_ERROR_CH31_GENERAL = 0x01, MSR_ERROR_CH31_SUPPLY_TEMP = 0x02, MSR_ERROR_CH31_RETURN_TEMP = 0x03,
MSR_ERROR_CH31_SUPPLY_RETURN_TEMP = 0x04
}
Enums for Status/Error if HCH = 31. More...
enum MSR_METER_ERROR_CODE {
MSR_METER_ERROR_NO_FAULT = 0x00, MSR_METER_ERROR_GENERAL = 0x01, MSR_METER_BUS_NO_CONFIG = 0x02, MSR_METER_BUS_NO_CONNECTION = 0x03,
MSR_METER_BUS_SHORTCUT = 0x04, MSR_METER_TIMEOUT = 0x05, MSR_METER_UNKNOWN_CONFIG = 0x06, MSR_METER_BUS_INIT_RUNNING = 0x07
}
Enums for Status/Error. More...
enum | MSR_METER_BUS_TYPE { MSR_BUS_TYPE_MBUS = 0x01, MSR_BUS_TYPE_S0 = 0x02, MSR_BUS_TYPE_D0 = 0x03 }
Enums for Meter bus type. More...
enum MSR_METER_UNITS {
MSR_UNIT_NO_READING = 0x00, MSR_UNIT_CURRENT_W_ACCUM_KWH = 0x01, MSR_UNIT_CURRENT_W_ACCUM_WH = 0x02, MSR_UNIT_ACCUM_KWH = 0x03,
MSR_UNIT_CURRENT_M3_ACCUM_M3 = 0x04, MSR_UNIT_CURRENT_DM3_ACCUM_DM3 = 0x05, MSR_UNIT_ACCUM_M3 = 0x06, MSR_UNIT_DIGIT_COUNTER = 0x07
}
Enums for Meter units. More...
enum MSR_VALUE_UNITS {
MSR_VALUE_W = 0x00, MSR_VALUE_WH = 0x01, MSR_VALUE_KWH = 0x02, MSR_VALUE_M3H = 0x03,
MSR_VALUE_DM3H = 0x04, MSR_VALUE_M3 = 0x05, MSR_VALUE_DM3 = 0x06, MSR_VALUE_DIGIT_COUNTER = 0x07
}
Enums for Meter units. More...
enum | MSR_FACTOR_PULSES { MSR_FACTOR_PULSES_1 = 0x00, MSR_FACTOR_PULSES_01 = 0x01, MSR_FACTOR_PULSES_001 = 0x02, MSR_FACTOR_PULSES_0001 = 0x03 }
Enums for factor of number of pulses. More...
enum | MSR_PROTOCOL { MSR_PROTOCOL_AUTO_DETECT = 0x00, MSR_PROTOCOL_SML = 0x01, MSR_PROTOCOL_DLMS = 0x02 }
Enums for D0 protocol. More...
enum | MSR_VALUE_SELECTION { MSR_VALUE_1_CURRENT = 0x00, MSR_VALUE_1_ACCU = 0x01, MSR_VALUE_2_CURRENT = 0x02, MSR_VALUE_2_ACCU = 0x03 }
Enums for Value selection. More...

Detailed Description

Enumeration Type Documentation

enum MSR_CHANNELS

Channel enums.

Enumerator:
MSR_CHANNEL_SUPPLY_TEMP

0 Supply temperature

MSR_CHANNEL_RETURN_TEMP

1 Return temperature

MSR_CHANNEL_REPORT_TIME

2 Supply temperature

MSR_CHANNEL_METER_TYPE

3 Return temperature

MSR_CHANNEL_METER_1

4 Meter 1 units

MSR_CHANNEL_METER_2

5 Meter 2 units

MSR_CHANNEL_NUM_OF_PULSES

6 Number of pulses

MSR_CHANNEL_PRESET_VALUE

7 Preset value

MSR_CHANNEL_PROTOCOL

8 Preset value

MSR_CHANNEL_PULSES_FACTOR

9 Factor of number of pulses

MSR_CHANNEL_PRIMARY_ADDR

10 Primary Address

MSR_CHANNEL_ERROR

11 Error codes for Heating controls status response

MSR_CHANNEL_ERROR_HCH31

12 Error codes for Heating controls status response if Heating channel is 31

MSR_CHANNEL_METER_ERROR

13 Meter error code

MSR_CHANNEL_METER_CHANNEL

14 Meter channel index

MSR_CHANNEL_VALUE_SELECTION

15 Value selection

enum MSR_COMMANDS

Command enums for D2-30-xx profiles.

Enumerator:
MSR_SET_HEAT_CONTROLS

1 Set heating controls output

MSR_HEAT_CONTROL_STATUS_QUERY

2 Heating controls status query

MSR_HEAT_CONTROL_STATUS_RESPONSE

3 Heating controls status response

MSR_SET_METER_CONFIGURATION

6 Set meter configuration

MSR_METER_STATUS_QUERY

7 Meter status query

MSR_METER_READING_REPORT

8 Meter reading report/status response

enum MSR_CONNECTED_VALVE

Enums for type of connected valve.

Enumerator:
MSR_VALVE_NORM_CLOSED

0 Valve normally closed

MSR_VALVE_NORM_OPEN

1 Valve normally open

enum MSR_ERROR_CODE

Enums for Status/Error.

Enumerator:
MSR_ERROR_NO_FAULT

0 No fault

MSR_ERROR_GENERAL

1 General error

MSR_ERROR_INIT_SEQU_RUNNING

2 Init sequence running

MSR_ERROR_CHANNEL_NOT_AVAILABLE

3 Channel not available

MSR_ERROR_TEMP_SENSOR

4 Temperature sensor error

MSR_ERROR_VALVE

5 Valve error

MSR_ERROR_TEMP_SENSOR_VALVE

6 Temperature sensor and Valve error

enum MSR_ERROR_CODE_CH31

Enums for Status/Error if HCH = 31.

Enumerator:
MSR_ERROR_CH31_NO_FAULT

0 No fault

MSR_ERROR_CH31_GENERAL

1 General error

MSR_ERROR_CH31_SUPPLY_TEMP

2 Supply temperature error

MSR_ERROR_CH31_RETURN_TEMP

3 Return temperature error

MSR_ERROR_CH31_SUPPLY_RETURN_TEMP

3 Error on both sensors

enum MSR_FACTOR_PULSES

Enums for factor of number of pulses.

Enumerator:
MSR_FACTOR_PULSES_1

0 1

MSR_FACTOR_PULSES_01

1 0.1

MSR_FACTOR_PULSES_001

2 0.01

MSR_FACTOR_PULSES_0001

3 0.001

enum MSR_INIT_SEQU

Enums for running init sequence.

Enumerator:
MSR_NO_ACTION

0 No action

MSR_RUN_INIT_SEQU

1 Run init sequence

enum MSR_METER_BUS_TYPE

Enums for Meter bus type.

Enumerator:
MSR_BUS_TYPE_MBUS

1 MBUS

MSR_BUS_TYPE_S0

2 S0

MSR_BUS_TYPE_D0

3 D0

enum MSR_METER_ERROR_CODE

Enums for Status/Error.

Enumerator:
MSR_METER_ERROR_NO_FAULT

0 No fault

MSR_METER_ERROR_GENERAL

1 General error

MSR_METER_BUS_NO_CONFIG

2 Bus unconfigured

MSR_METER_BUS_NO_CONNECTION

3 Bus unconnected

MSR_METER_BUS_SHORTCUT

4 Bus shortcut

MSR_METER_TIMEOUT

5 Communication timeout

MSR_METER_UNKNOWN_CONFIG

6 Unknown protocol or configuration mismatch

MSR_METER_BUS_INIT_RUNNING

7 Bus initialisation running

enum MSR_METER_UNITS

Enums for Meter units.

Enumerator:
MSR_UNIT_NO_READING

0 No reading

MSR_UNIT_CURRENT_W_ACCUM_KWH

1 Current value in W, accumulated value in kWh

MSR_UNIT_CURRENT_W_ACCUM_WH

2 Current value in W, accumulated value in Wh

MSR_UNIT_ACCUM_KWH

3 Accumulated value in kWh

MSR_UNIT_CURRENT_M3_ACCUM_M3

4 Current value in m3/h, accumulated value in m3

MSR_UNIT_CURRENT_DM3_ACCUM_DM3

5 Current value in dm3/h, accumulated value in dm3

MSR_UNIT_ACCUM_M3

6 Accumulated value in m3

MSR_UNIT_DIGIT_COUNTER

7 Digital counter

enum MSR_PROTOCOL

Enums for D0 protocol.

Enumerator:
MSR_PROTOCOL_AUTO_DETECT

0 Auto detect

MSR_PROTOCOL_SML

1 SML (Smart Message Language)

MSR_PROTOCOL_DLMS

2 DLMS (Device Language Message Specification)

enum MSR_REPORT_TIME_VALUES

Enums for Minimum auto reporting intervals.

Enumerator:
MSR_NO_REPORT

0 No auto reporting

MSR_1_SECOND_REPORT

1 1 second

MSR_3_SECOND_REPORT

2 3 seconds

MSR_10_SECOND_REPORT

3 10 seconds

MSR_30_SECOND_REPORT

4 30 seconds

MSR_100_SECOND_REPORT

5 100 seconds

MSR_300_SECOND_REPORT

6 300 seconds

MSR_1000_SECOND_REPORT

7 1000 seconds

enum MSR_TIME_VALUES

Enums for PWM signal intervals.

Enumerator:
MSR_LOCAL_DEFAULT

0 Local default/no change

MSR_1_SECOND

1 1 second

MSR_2_SECOND

2 2 seconds

MSR_5_SECOND

3 5 seconds

MSR_10_SECOND

4 10 seconds

MSR_20_SECOND

5 20 seconds

MSR_50_SECOND

6 50 seconds

MSR_100_SECOND

7 100 seconds

MSR_200_SECOND

8 200 seconds

MSR_500_SECOND

9 500 seconds

MSR_1000_SECOND

10 1000 seconds

enum MSR_VALUE_SELECTION

Enums for Value selection.

Enumerator:
MSR_VALUE_1_CURRENT

0 Meter 1, Current value

MSR_VALUE_1_ACCU

1 Meter 1, Accumulated value

MSR_VALUE_2_CURRENT

2 Meter 2, Current value

MSR_VALUE_2_ACCU

3 Meter 2, Accumulated value

enum MSR_VALUE_UNITS

Enums for Meter units.

Enumerator:
MSR_VALUE_W

0 Value in W

MSR_VALUE_WH

1 Value in Wh

MSR_VALUE_KWH

2 Value in kWh

MSR_VALUE_M3H

3 Value in m3/h

MSR_VALUE_DM3H

3 Value in dm3/h

MSR_VALUE_M3

5 Value in m3

MSR_VALUE_DM3

6 Value in dm3

MSR_VALUE_DIGIT_COUNTER

7 Digital counter

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D231xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D231xx.h File Reference
#include "eoD2EEProfile.h"
Include dependency graph for eoEEP_D231xx.h:

Go to the source code of this file.

Classes

class eoEEP_D231xx
The class to handle EEP D231 profiles. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D232xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D232xx.h File Reference
#include "eoD2EEProfile.h"
Include dependency graph for eoEEP_D232xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_D232xx
The class to handle EEP D232 Automated meter reading (AMR) profiles. More...

Enumerations

enum D323_INDEX_ENUMS { CURR_CHANNEL_1 = 0x00, CURR_CHANNEL_2 = 0x01, CURR_CHANNEL_3 = 0x02 }
Channel index enums for D2-32-xx profiles. More...

Detailed Description

Enumeration Type Documentation

enum D323_INDEX_ENUMS

Channel index enums for D2-32-xx profiles.

Enumerator:
CURR_CHANNEL_1

Current Channel 1 0

CURR_CHANNEL_2

Current Channel 1 1

CURR_CHANNEL_3

Current Channel 1 3

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D240xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D240xx.h File Reference
#include "eoD2EEProfile.h"
Include dependency graph for eoEEP_D240xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_D240xx
The class to handle EEP D240 profiles. More...

Enumerations

enum D240_INDEX_ENUM {
DRIVING_LED = 0x00, RESPONSE_MODE = 0x01, DAYLIGH_HARVEST = 0x02, STATUS_REASON = 0x03,
DIM_LEVEL_MONO = 0x04, DIM_LEVEL_RED = 0x05, DIM_LEVEL_GREEN = 0x06, DIM_LEVEL_BLUE = 0x07
}
Index enums for D2-40-xx profiles. More...
enum | D240_DRIVING_LED_ENUM { DRIVING_DISABLED = 0x00, DRIVING_ENABLED = 0x01 }
Driving LED enums for D2-40-xx profiles. More...
enum | D240_TRUE_FALSE_ENUM { D240_FALSE = 0x00, D240_TRUE = 0x01 }
True/False enums for D2-40-xx profiles. More...
enum | D240_OCCUPANCY_ENUM { D240_NOT_OCCUPIED = 0x00, D240_OCCUPIED = 0x01, D240_UNKNOWN = 0x02 }
Occupancy enums for D2-40-xx profiles. More...
enum | D240_STATUS_REASON_ENUM { OTHER_REASON = 0x00, HEARTBEAT = 0x01 }
Status reason enums for D2-40-xx profiles. More...

Detailed Description

Enumeration Type Documentation

enum D240_DRIVING_LED_ENUM

Driving LED enums for D2-40-xx profiles.

Enumerator:
DRIVING_DISABLED

Disabled 0

DRIVING_ENABLED

Enabled 1

enum D240_INDEX_ENUM

Index enums for D2-40-xx profiles.

Enumerator:
DRIVING_LED

Driving LED 0

RESPONSE_MODE

Demand Response Mode Active 1

DAYLIGH_HARVEST

Daylight Harvesting Active 2

STATUS_REASON

Status Reason 3

DIM_LEVEL_MONO

LED Monocolor 4

DIM_LEVEL_RED

LED Red 5

DIM_LEVEL_GREEN

LED Green 6

DIM_LEVEL_BLUE

LED Blue 7

enum D240_OCCUPANCY_ENUM

Occupancy enums for D2-40-xx profiles.

Enumerator:
D240_NOT_OCCUPIED

Not occupied 0

D240_OCCUPIED

Occupied 1

D240_UNKNOWN

Unknown 2

enum D240_STATUS_REASON_ENUM

Status reason enums for D2-40-xx profiles.

Enumerator:
OTHER_REASON

Other 0

HEARTBEAT

Heartbeat 1

enum D240_TRUE_FALSE_ENUM

True/False enums for D2-40-xx profiles.

Enumerator:
D240_FALSE

False 0

D240_TRUE

True 1

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D250xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D250xx.h File Reference
#include "eoD2EEProfile.h"
Include dependency graph for eoEEP_D250xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Enumerations

enum | D250xx_COMMANDS { VENTILATION_REQUEST = 0x00, VENTILATION_CONTROL = 0x01, VENTILATION_BASIC_STATUS = 0x02, VENTILATION_EXTENDED_STATUS = 0x03 }
Command enums for D2-50-xx profiles. More...
enum D250xx_INDEX {
REQUESTED_MSG_TYPE = 0x00, DIRECT_OP_MODE = 0x01, OP_MODE_CTRL = 0x02, HEAT_EXCHANGE_CTRL = 0x03,
TIMER_OP_CTRL = 0x04, SAFTEY_MODE = 0x05, SUPPLY_AIR_POS = 0x06, EXHAUST_AIR_POS = 0x07,
DEFROST_MODE = 0x08, COOLING_PROTECTION = 0x09, OUTDOOR_HEATER_STATUS = 0x0A, SUPPLY_HEATER_STATUS = 0x0B,
DRAIN_HEATER_STATUS = 0x0C, TIMER_OP_CTRL_STATUS = 0x0D, FILTER_MAINTENANCE = 0x0E, WEEKLY_PROGRAM = 0x0F,
ROOM_TEMP_CTRL = 0x10, AIR_QUALITY_1 = 0x11, AIR_QUALITY_2 = 0x12, MASTER_SLAVE_CONFIG = 0x13,
OUTDOOR_TEMP = 0x14, SUPPLY_TEMP = 0x15, INDOOR_TEMP = 0x16, EXHAUST_TEMP = 0x17,
SUPPLY_FAN_RATE = 0x18, EXHAUST_FAN_RATE = 0x19, SUPPLY_FAN_SPEED = 0x20, EXHAUST_FAN_SPEED = 0x21,
SW_VERSION = 0x22, DIGITAL_INPUT_STATUS = 0x23, DIGITAL_OUTPUT_STATUS = 0x24, INFO_MSG_STATUS = 0x25,
FAULT_STATUS = 0x26, CO2_TRHESHOLD = 0x27, AIR_QUALITY_TRHESHOLD = 0x28, ROOM_TEMP = 0x29
}
Index enums for D2-50-xx profiles. More...
enum | D250_REQUESTED_MSG_TYPE { VENTILATION_BASIC = 0x00, VENTILATION_EXTENDED = 0x01 }
Requested message enums for D2-50-xx profiles. More...
enum D250_DIRECT_OP_MODE {
DIRECT_MODE_OFF = 0x00, DIRECT_MODE_LEVEL_1 = 0x01, DIRECT_MODE_LEVEL_2 = 0x02, DIRECT_MODE_LEVEL_3 = 0x03,
DIRECT_MODE_LEVEL_4 = 0x04, DIRECT_MODE_AUTO = 0x0B, DIRECT_MODE_AUTO_OD = 0x0C, DIRECT_MODE_SUPPLY_ONLY = 0x0D,
DIRECT_MODE_SEXHAUST_ONLY = 0x0E, DIRECT_MODE_NO_ACTION = 0x0F
}
Direct operation mode enums for D2-50-xx profiles. More...
enum | D250_OP_MODE { OP_NO_ACTION = 0x00, OP_NEXT = 0x01, OP_PREVIOUS = 0x02 }
Operation mode enums for D2-50-xx profiles. More...
enum | D250_AIRFLAP_BYPASS { AIRFLAP_BYPASS_CLOSE = 0x00, AIRFLAP_BYPASS_OPEN = 0x01 }
Air flap and bypass enums for D2-50-xx profiles. More...

Detailed Description

Enumeration Type Documentation

enum D250_AIRFLAP_BYPASS

Air flap and bypass enums for D2-50-xx profiles.

Enumerator:
AIRFLAP_BYPASS_CLOSE

Air flap and bypass close 0

AIRFLAP_BYPASS_OPEN

Air flap and bypass open 1

enum D250_DIRECT_OP_MODE

Direct operation mode enums for D2-50-xx profiles.

Enumerator:
DIRECT_MODE_OFF

Off 0

DIRECT_MODE_LEVEL_1

Level 1 1

DIRECT_MODE_LEVEL_2

Level 22

DIRECT_MODE_LEVEL_3

Level 3 3

DIRECT_MODE_LEVEL_4

Level 4 4

DIRECT_MODE_AUTO

Automatic 11

DIRECT_MODE_AUTO_OD

Automatic on Demand 12

DIRECT_MODE_SUPPLY_ONLY

Supply Air Only 13

DIRECT_MODE_SEXHAUST_ONLY

Exhaust Air Only 14

DIRECT_MODE_NO_ACTION

No Action/ Keep Current Mode 15

enum D250_OP_MODE

Operation mode enums for D2-50-xx profiles.

Enumerator:
OP_NO_ACTION

No Action 0

OP_NEXT

Select Next Operation Mode (edge-trigger) 1

OP_PREVIOUS

Select Previous Operation Mode (edge-trigger) 2

enum D250_REQUESTED_MSG_TYPE

Requested message enums for D2-50-xx profiles.

Enumerator:
VENTILATION_BASIC

Ventilation Basic Status 0

VENTILATION_EXTENDED

Ventilation Extended Status 1

enum D250xx_COMMANDS

Command enums for D2-50-xx profiles.

Enumerator:
VENTILATION_REQUEST

Ventilation Remote Transmission Request 0

VENTILATION_CONTROL

Ventilation Control 1

VENTILATION_BASIC_STATUS

Ventilation Basic Status 2

VENTILATION_EXTENDED_STATUS

Ventilation Extended Status 3

enum D250xx_INDEX

Index enums for D2-50-xx profiles.

Enumerator:
REQUESTED_MSG_TYPE

Requested Message Type 0

DIRECT_OP_MODE

Direct Operation Mode Control 1

OP_MODE_CTRL

Operation Mode Control 2

HEAT_EXCHANGE_CTRL

Heat Exchanger Bypass Control 3

TIMER_OP_CTRL

Timer Operation Mode Control 4

SAFTEY_MODE

Safety Mode Status 5

SUPPLY_AIR_POS

Supply Air Flap Position 6

EXHAUST_AIR_POS

Exhaust Air Flap Position 7

DEFROST_MODE

Defrost Mode Status 8

COOLING_PROTECTION

Cooling Protection Status 9

OUTDOOR_HEATER_STATUS

Outdoor Air Heater Status 10

SUPPLY_HEATER_STATUS

Supply Air Heater Status 11

DRAIN_HEATER_STATUS

Drain Heater Status 12

TIMER_OP_CTRL_STATUS

Timer Operation Mode Control Status 13

FILTER_MAINTENANCE

Filter Maintenance Status 14

WEEKLY_PROGRAM

Weekly Timer Program Status 15

ROOM_TEMP_CTRL

Room Temperature Control Status 16

AIR_QUALITY_1

Air Quality Sensor 1 17

AIR_QUALITY_2

Air Quality Sensor 2 18

MASTER_SLAVE_CONFIG

Master/Slave Configuration Status 19

OUTDOOR_TEMP

Outdoor Air Temperature 20

SUPPLY_TEMP

Supply Air Temperature 21

INDOOR_TEMP

Indoor Air Temperature 22

EXHAUST_TEMP

Exhaust Air Temperature 23

SUPPLY_FAN_RATE

Supply Air Fan Air Flow Rate 24

EXHAUST_FAN_RATE

Exhaust Air Fan Air Flow Rate 25

SUPPLY_FAN_SPEED

Supply Fan Speed 26

EXHAUST_FAN_SPEED

Exhaust Fan Speed 27

SW_VERSION

Software Version Info 28

DIGITAL_INPUT_STATUS

Digital Input Status 29

DIGITAL_OUTPUT_STATUS

Digital Output Status 30

INFO_MSG_STATUS

Info Message Status 31

FAULT_STATUS

Fault Status 32

CO2_TRHESHOLD

CO2 Threshold 33

AIR_QUALITY_TRHESHOLD

Air Quality Threshold 34

ROOM_TEMP

Room Temperature 35

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D2A0xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D2A0xx.h File Reference
#include "eoD2EEProfile.h"
#include "eoISimpleBidirectionalProfile.h"
Include dependency graph for eoEEP_D2A0xx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoEEP_D2A0xx
The class to handle EEP D2A0 profiles. More...

Enumerations

enum | VALVE_STATUS { VALVE_STATUS_CLOSED = 0x01, VALVE_STATUS_OPENED = 0x02 }
Valve status enums for D2-A0-xx profiles. More...
enum | VALVE_REQUEST { VALVE_REQUEST_FEEDBACK = 0x00, VALVE_REQUEST_CLOSE = 0x01, VALVE_REQUEST_OPEN = 0x02, VALVE_REQUEST_CLOSE_2 = 0x03 }
Valve status request enums for D2-A0-xx profiles. More...
enum | VALVE_DIRECTION { VALVE_TO_CONTROLLER = 0x00, CONTROLLER_TO_VALVE = 0x01 }
Valve direction enums for D2-A0-xx profiles. More...

Detailed Description

Enumeration Type Documentation

enum VALVE_DIRECTION

Valve direction enums for D2-A0-xx profiles.

Enumerator:
VALVE_TO_CONTROLLER

Water valve to the controller 0

CONTROLLER_TO_VALVE

Controller to the water valve 1

enum VALVE_REQUEST

Valve status request enums for D2-A0-xx profiles.

Enumerator:
VALVE_REQUEST_FEEDBACK

Request feedback 0

VALVE_REQUEST_CLOSE

Request closing 1

VALVE_REQUEST_OPEN

Request opening 2

VALVE_REQUEST_CLOSE_2

Request closing 3

enum VALVE_STATUS

Valve status enums for D2-A0-xx profiles.

Enumerator:
VALVE_STATUS_CLOSED

Closed 1

VALVE_STATUS_OPENED

Opened 2

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D500xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_D500xx.h File Reference
#include "eoA5EEProfile.h"
Include dependency graph for eoEEP_D500xx.h:

Go to the source code of this file.

Classes

class eoEEP_D500xx
The class to handle EEP d500 profiles. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_F602xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_F602xx.h File Reference
#include "eoF6EEProfile.h"
Include dependency graph for eoEEP_F602xx.h:

Go to the source code of this file.

Classes

class eoEEP_F602xx
The class to handle EEP f602 Rocker Switch, 2 Rocker profiles. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_F603xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_F603xx.h File Reference
#include "eoF6EEProfile.h"
Include dependency graph for eoEEP_F603xx.h:

Go to the source code of this file.

Classes

class eoEEP_F603xx
The class to handle EEP f603 profiles. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_F604xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_F604xx.h File Reference
#include "eoF6EEProfile.h"
Include dependency graph for eoEEP_F604xx.h:

Go to the source code of this file.

Classes

class eoEEP_F604xx
The class to handle EEP f604 profiles. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_F605xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_F605xx.h File Reference
#include "eoF6EEProfile.h"
Include dependency graph for eoEEP_F605xx.h:

Go to the source code of this file.

Classes

class eoEEP_F605xx
The class to handle EEP f605 profiles. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_F610xx.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes
eoEEP_F610xx.h File Reference
#include "eoF6EEProfile.h"
Include dependency graph for eoEEP_F610xx.h:

Go to the source code of this file.

Classes

class eoEEP_F610xx
The class to handle EEP f610 profiles. More...

Detailed Description

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoF6EEProfile.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
Classes | Enumerations
eoF6EEProfile.h File Reference
#include "eoEEProfile.h"
Include dependency graph for eoF6EEProfile.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class eoF6EEProfile
EnOcean Equipment Profiles class for RORG F6. More...

Enumerations

enum | ENUM_ROCKER_STATE { STATE_I = 0, STATE_O = 1, STATE_NP = 2, STATE_IO = 3 }
Rocker States. More...
enum | ENUM_WINDOW_STATE { WINDOW_DOWN = 0, WINDOW_MIDDLE = 1, WINDOW_UP = 2 }
Window States. More...
enum | ENUM_ENERGY_STATE { ENERGY_RELEASED = 0, ENERGY_PRESSED = 1 }
Energybow state. More...
enum | ENUM_MULTIPRESS_STATE { MULTIPRESS_NOT = 0, MULTIPRESS_YES = 1 }
Multipress state. More...
enum | WAS_VALUES { NO_WATER = 0x00, WATER_DETECTED = 0x01 }
Enums for Water sensor values. More...

Detailed Description

Author:
EnOcean GmbH

Enumeration Type Documentation

enum ENUM_ENERGY_STATE

Energybow state.

Enumerator:
ENERGY_RELEASED

0 Energy bow pressed

ENERGY_PRESSED

1 Energy bow released

enum ENUM_MULTIPRESS_STATE

Multipress state.

Enumerator:
MULTIPRESS_NOT

0 1 or 2 buttons pressed

MULTIPRESS_YES

1 More then 2 buttons pressed

enum ENUM_ROCKER_STATE

Rocker States.

Enumerator:
STATE_I

0 xI Button Pressed

STATE_O

1 x0 Button Pressed

STATE_NP

2 Rocker Button has not been Pressed

STATE_IO

3 Both Rocker Button Pressed

enum ENUM_WINDOW_STATE

Window States.

Enumerator:
WINDOW_DOWN

0 Window Handle is at upper Position

WINDOW_MIDDLE

1 Window Handle is at middle Position

WINDOW_UP

2 Window Handle is at down Position

enum WAS_VALUES

Enums for Water sensor values.

Enumerator:
NO_WATER

0 Water not detected

WATER_DETECTED

1 Water detected

Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoSpecialProfile.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoSpecialProfile.h File Reference

Wrapper for includes. More...

#include "eoF6EEProfile.h"
#include "eoEEP_A509xx.h"
#include "eoEEP_A510xx.h"
#include "eoEEP_A511xx.h"
#include "eoEEP_A512xx.h"
#include "eoEEP_A513xx.h"
#include "eoEEP_A520xx.h"
#include "eoEEP_A530xx.h"
#include "eoEEP_A537xx.h"
#include "eoEEP_A538xx.h"
#include "eoEEP_D200xx.h"
#include "eoEEP_D201xx.h"
#include "eoEEP_D202xx.h"
#include "eoEEP_D204xx.h"
#include "eoEEP_D205xx.h"
#include "eoEEP_D206xx.h"
#include "eoEEP_D210xx.h"
#include "eoEEP_D220xx.h"
#include "eoEEP_D230xx.h"
#include "eoEEP_D232xx.h"
#include "eoEEP_D240xx.h"
#include "eoEEP_D250xx.h"
#include "eoEEP_D2A0xx.h"
Include dependency graph for eoSpecialProfile.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Detailed Description

Wrapper for includes.

Author:
EnOcean GmBH
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/eoLink.h File Reference

  • File List
  • File Members
  • SourceCode
  • EOLink
eoLink.h File Reference

EnOcean Link Main Header The Main Header to include into your Project File. More...

#include "eoVersion.h"
#include "Includes/eoAbstractMessage.h"
#include "Includes/eoApiDef.h"
#include "Includes/eoArchive.h"
#include "Includes/eoArchiveTXT.h"
#include "Includes/eoChainedMessage.h"
#include "Includes/eoChainedReManMessage.h"
#include "Includes/eoChannelEnums.h"
#include "Includes/eoChannelInfo.h"
#include "Includes/eoConverter.h"
#include "Includes/eodBmFilter.h"
#include "Includes/eoDebug.h"
#include "Includes/eoDevice.h"
#include "Includes/eoDeviceManager.h"
#include "Includes/eoEEProfile.h"
#include "Includes/eoFilterFactory.h"
#include "Includes/eoGateway.h"
#include "Includes/eoGenericProfile.h"
#include "Includes/eoGpChainer.h"
#include "Includes/eoGPChannelInfo.h"
#include "Includes/eoHeader.h"
#include "Includes/eoIDFilter.h"
#include "Includes/eoIFilter.h"
#include "Includes/eoISerialize.h"
#include "Includes/eoLinuxPacketStream.h"
#include "Includes/eoManufacturer.h"
#include "Includes/eoMessage.h"
#include "Includes/eoMessageHandler.h"
#include "Includes/eoMSCHelper.h"
#include "Includes/eoPacket.h"
#include "Includes/eoPacketStream.h"
#include "Includes/eoProc.h"
#include "Includes/eoProfileFactory.h"
#include "Includes/eoProfile.h"
#include "Includes/eoReCom.h"
#include "Includes/eoReManChainer.h"
#include "Includes/eoReManMessage.h"
#include "Includes/eoRemoteManager.h"
#include "Includes/eoRollingCodeStorage.h"
#include "Includes/eoSecTeachInChainer.h"
#include "Includes/eoSecureInfo.h"
#include "Includes/eoSecurity.h"
#include "Includes/eoSerialCommand.h"
#include "Includes/eoStorageManager.h"
#include "Includes/eoTeachInModule.h"
#include "Includes/eoTelegram.h"
#include "Includes/eoTimer.h"
#include "Includes/eoWatcherFactory.h"
#include "Includes/eoIWatcher.h"
#include "Includes/eoWatcher.h"
#include "Profiles/eoSpecialProfile.h"

Go to the source code of this file.

Detailed Description

EnOcean Link Main Header The Main Header to include into your Project File.

Author:
EnOcean GmbH
Date:
December, 13th, 2013
Version:
1.3.0.0
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- _ -

  • _ARCHIVE_TYPE_NAME : eoArchiveTXT.h
  • _ARCHIVE_VER_MAJOR : eoArchiveTXT.h
  • _ARCHIVE_VER_MINOR : eoArchiveTXT.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- a -

  • A530_BATTERY_VALUE : eoEEP_A530xx.h
  • A530_INDEX : eoEEP_A530xx.h
  • A530_SIGNAL_TYPE : eoEEP_A530xx.h
  • A5O_ERROR : eoEEP_A511xx.h
  • A_1_10 : eoEEP_A538xx.h
  • ABS_REL_POWER : eoEEP_A537xx.h
  • ACKNOWLEDGE_FEEDBACK : eoEEP_D210xx.h
  • ACKNOWLEDGE_REQUEST : eoEEP_D210xx.h
  • ACTUATOR_MEASUREMENT_QUERY : eoEEP_D201xx.h
  • ACTUATOR_MEASUREMENT_RESPONSE : eoEEP_D201xx.h
  • ACTUATOR_OBSTRUCTED : eoEEP_A520xx.h
  • ACTUATOR_PILOTWIRE_QUERY : eoEEP_D201xx.h
  • ACTUATOR_PILOTWIRE_RESPONSE : eoEEP_D201xx.h
  • ACTUATOR_PILOTWIRE_SET : eoEEP_D201xx.h
  • ACTUATOR_SET : eoEEP_D202xx.h
  • ACTUATOR_SET_LOCAL : eoEEP_D201xx.h
  • ACTUATOR_SET_MEASUREMENT : eoEEP_D201xx.h
  • ACTUATOR_SET_OUTPUT : eoEEP_D201xx.h
  • ACTUATOR_STATUS_QUERY : eoEEP_D201xx.h
  • ACTUATOR_STATUS_RESPONSE : eoEEP_D201xx.h
  • AIR_QUALITY_1 : eoEEP_D250xx.h
  • AIR_QUALITY_2 : eoEEP_D250xx.h
  • AIR_QUALITY_TRHESHOLD : eoEEP_D250xx.h
  • AIRFLAP_BYPASS_CLOSE : eoEEP_D250xx.h
  • AIRFLAP_BYPASS_OPEN : eoEEP_D250xx.h
  • ALARM_DOWN : eoEEP_D205xx.h
  • ALARM_IMMEDIATE_STOP : eoEEP_D205xx.h
  • ALARM_NO_ACTION : eoEEP_D205xx.h
  • ALARM_NO_CHANGE : eoEEP_D205xx.h
  • ALARM_STATE : eoEEP_A520xx.h
  • ALARM_UP : eoEEP_D205xx.h
  • ALARMS : eoEEP_D206xx.h
  • ALL_SUPPORTED : eoEEP_D201xx.h
  • AM_PM : eoEEP_A513xx.h
  • AND : eoSerialCommand.h
  • APPLY_RADIO : eoSerialCommand.h
  • APPLY_REPEATED : eoSerialCommand.h
  • AZIMUTH : eoEEP_A513xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- b -

  • BATTERY_CAPACITY : eoEEP_A520xx.h
  • BATTERY_CLICK : eoEEP_D206xx.h
  • BATTERY_EMPTY : eoEEP_A520xx.h
  • BATTERY_EO_OK : eoEEP_A530xx.h
  • BATTERY_LEVEL : eoEEP_A512xx.h
  • BATTERY_LEVEL_100_75 : eoEEP_A512xx.h
  • BATTERY_LEVEL_25_0 : eoEEP_A512xx.h
  • BATTERY_LEVEL_50_25 : eoEEP_A512xx.h
  • BATTERY_LEVEL_75_50 : eoEEP_A512xx.h
  • BATTERY_LOW : eoEEP_A530xx.h
  • BATTERY_STATUS : eoEEP_D210xx.h
  • BATTERY_VLD_CRITICAL : eoEEP_D210xx.h
  • BATTERY_VLD_GOOD : eoEEP_D210xx.h
  • BATTERY_VLD_LOW : eoEEP_D210xx.h
  • BATTERY_VLD_NO_CHANGE : eoEEP_D210xx.h
  • BLIND_CLOSES : eoEEP_A511xx.h
  • BLIND_FULLY_CLOSE : eoEEP_A511xx.h
  • BLIND_FULLY_OPEN : eoEEP_A511xx.h
  • BLIND_OPENS : eoEEP_A511xx.h
  • BLIND_STOPPED : eoEEP_A511xx.h
  • BLOCK_RADIO : eoSerialCommand.h
  • BLOCK_REPEATED : eoSerialCommand.h
  • BLOCKED_VALVE : eoEEP_A520xx.h
  • BQ_KG : eoEEP_A509xx.h
  • BQ_L : eoEEP_A509xx.h
  • BROADCAST_ID : eoApiDef.h
  • BUFF_FULL : eoApiDef.h
  • BUILDING_PROTECT_TEMP_SETPOINT : eoEEP_D210xx.h
  • BUILDING_PROTECT_TEMP_SETPOINT_VALIDITY : eoEEP_D210xx.h
  • BURGLARY_ALARM : eoEEP_D206xx.h
  • BUTTON_1 : eoEEP_D206xx.h
  • BUTTON_2 : eoEEP_D206xx.h
  • BUTTON_LOCK : eoEEP_A520xx.h
  • BUTTON_LOCKED : eoEEP_A520xx.h
  • BUTTON_UNLOCKED : eoEEP_A520xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- c -

  • CC_ANGLE_BLIND_POSITION : eoEEP_A538xx.h
  • CC_AUTO : eoEEP_A538xx.h
  • CC_BLIND_CLOSE_ANGLE : eoEEP_A538xx.h
  • CC_BLIND_CLOSE_POSITION : eoEEP_A538xx.h
  • CC_BLIND_OPEN_ANGLE : eoEEP_A538xx.h
  • CC_BLIND_OPEN_POSITION : eoEEP_A538xx.h
  • CC_BLIND_POSITION : eoEEP_A538xx.h
  • CC_CONTROLLER_MODE : eoEEP_A538xx.h
  • CC_CONTROLLER_STATE : eoEEP_A538xx.h
  • CC_COOLING : eoEEP_A538xx.h
  • CC_DELAY_DURATION : eoEEP_A538xx.h
  • CC_DIMMING_DOWN : eoEEP_A538xx.h
  • CC_DIMMING_RANGE : eoEEP_A538xx.h
  • CC_DIMMING_STOP : eoEEP_A538xx.h
  • CC_DIMMING_UP : eoEEP_A538xx.h
  • CC_DIMMING_VALUE : eoEEP_A538xx.h
  • CC_DO_NOTHING : eoEEP_A538xx.h
  • CC_DOWN_RAMPING_TIME : eoEEP_A538xx.h
  • CC_ENERGY_HOLDOFF : eoEEP_A538xx.h
  • CC_ENERGY_METERING_VALUE : eoEEP_A538xx.h
  • CC_ENERGY_UNITS : eoEEP_A538xx.h
  • CC_FAN_SPEED_5_STAGE : eoEEP_A538xx.h
  • CC_FULLY_OPEN_ANGLE : eoEEP_A538xx.h
  • CC_FULLY_SHUT_ANGLE : eoEEP_A538xx.h
  • CC_FUNCTIONS : eoEEP_A538xx.h
  • CC_FUNCTIONS_TYPE_09 : eoEEP_A538xx.h
  • CC_HEATING : eoEEP_A538xx.h
  • CC_INDEXS : eoEEP_A538xx.h
  • CC_LAMP_OPERATING_HOUR : eoEEP_A538xx.h
  • CC_LOCK_OPERATIONS : eoEEP_A538xx.h
  • CC_LOCK_UNLOCK : eoEEP_A538xx.h
  • CC_LOCKING_OPERATIONS : eoEEP_A538xx.h
  • CC_MAX_DIM_VALUE : eoEEP_A538xx.h
  • CC_MIN_DIM_VALUE : eoEEP_A538xx.h
  • CC_NEW_VALUE_METERING : eoEEP_A538xx.h
  • CC_OCCUPIED : eoEEP_A538xx.h
  • CC_OFF : eoEEP_A538xx.h
  • CC_POS_ANGLE_FLAG : eoEEP_A538xx.h
  • CC_POSITION_LOGIC : eoEEP_A538xx.h
  • CC_RGB_BLUE : eoEEP_A538xx.h
  • CC_RGB_GREEN : eoEEP_A538xx.h
  • CC_RGB_RED : eoEEP_A538xx.h
  • CC_ROOM_OCCUPANCY : eoEEP_A538xx.h
  • CC_RUNTIME_CLOSE : eoEEP_A538xx.h
  • CC_RUNTIME_OPEN : eoEEP_A538xx.h
  • CC_SCENE : eoEEP_A538xx.h
  • CC_SCENE_FUNCTION : eoEEP_A538xx.h
  • CC_SCENE_NUMBER : eoEEP_A538xx.h
  • CC_SEND_STATUS : eoEEP_A538xx.h
  • CC_SERVICE_MODE : eoEEP_A538xx.h
  • CC_SET_DIMMER_VALUE : eoEEP_A538xx.h
  • CC_SET_MAX_POSITION : eoEEP_A538xx.h
  • CC_SET_MIN_POSITION : eoEEP_A538xx.h
  • CC_SET_OP_HOURS : eoEEP_A538xx.h
  • CC_SET_RAMPING_TIME : eoEEP_A538xx.h
  • CC_SET_RGB_VALUES : eoEEP_A538xx.h
  • CC_SET_VALUES : eoEEP_A538xx.h
  • CC_STAGE_0 : eoEEP_A538xx.h
  • CC_STAGE_1 : eoEEP_A538xx.h
  • CC_STAGE_2 : eoEEP_A538xx.h
  • CC_STAGE_3 : eoEEP_A538xx.h
  • CC_STAGE_AUTO : eoEEP_A538xx.h
  • CC_STANDBY : eoEEP_A538xx.h
  • CC_STORE_FINAL_VAL : eoEEP_A538xx.h
  • CC_SUNBLIND_REVERSION : eoEEP_A538xx.h
  • CC_SWITCHED_OFF : eoEEP_A538xx.h
  • CC_SWITCHED_ON : eoEEP_A538xx.h
  • CC_SWITCHING_COMMAND : eoEEP_A538xx.h
  • CC_UNOCCUPIED : eoEEP_A538xx.h
  • CC_UP_RAMPING_TIME : eoEEP_A538xx.h
  • CH1_OFF_CH2_OFF : eoEEP_A511xx.h
  • CH1_OFF_CH2_ON : eoEEP_A511xx.h
  • CH1_ON_CH2_OFF : eoEEP_A511xx.h
  • CH1_ON_CH2_ON : eoEEP_A511xx.h
  • CHANNEL_TYPE : eoChannelEnums.h
  • CHOICE : eoSerialCommand.h
  • CHOICE_TYPE : eoApiDef.h
  • CLOSE_BLIND : eoEEP_A538xx.h
  • CLOSE_FOR_TIME : eoEEP_A538xx.h
  • CO2_TRHESHOLD : eoEEP_D250xx.h
  • CO_DUTYCYCLE_LIMIT : eoSerialCommand.h
  • CO_DUTYCYCLE_LIMIT_REACHED : eoSerialCommand.h
  • CO_DUTYCYCLE_LIMIT_UNREACHED : eoSerialCommand.h
  • CO_RD_DUTYCYCLE_LIMIT : eoSerialCommand.h
  • CO_RD_FILTER : eoSerialCommand.h
  • CO_RD_IDBASE : eoSerialCommand.h
  • CO_RD_MEM : eoSerialCommand.h
  • CO_RD_MEM_ADDRESS : eoSerialCommand.h
  • CO_RD_REPEATER : eoSerialCommand.h
  • CO_RD_SECURITY : eoSerialCommand.h
  • CO_RD_SYS_LOG : eoSerialCommand.h
  • CO_RD_VERSION : eoSerialCommand.h
  • CO_WR_BIST : eoSerialCommand.h
  • CO_WR_FILTER_ADD : eoSerialCommand.h
  • CO_WR_FILTER_DEL : eoSerialCommand.h
  • CO_WR_FILTER_DEL_ALL : eoSerialCommand.h
  • CO_WR_FILTER_ENABLE : eoSerialCommand.h
  • CO_WR_IDBASE : eoSerialCommand.h
  • CO_WR_MEM : eoSerialCommand.h
  • CO_WR_MODE : eoSerialCommand.h
  • CO_WR_REPEATER : eoSerialCommand.h
  • CO_WR_RESET : eoSerialCommand.h
  • CO_WR_SECURITY : eoSerialCommand.h
  • CO_WR_SLEEP : eoSerialCommand.h
  • CO_WR_SUBTEL : eoSerialCommand.h
  • CO_WR_SYS_LOG : eoSerialCommand.h
  • CO_WR_WAIT_MATURITY : eoSerialCommand.h
  • COMFORT_TEMP_SETPOINT : eoEEP_D210xx.h
  • COMFORT_TEMP_SETPOINT_VALIDITY : eoEEP_D210xx.h
  • COMMANDS : eoEEP_D201xx.h
  • COMMON_COMMAND_TYPE : eoSerialCommand.h
  • CONFIG_MSG : eoEEP_D210xx.h
  • CONFIG_REQUEST : eoEEP_D210xx.h
  • CONTACT_COVER : eoEEP_A520xx.h
  • CONTROLLER_STATE : eoEEP_A520xx.h
  • CONTROLLER_TO_VALVE : eoEEP_D2A0xx.h
  • COOLING : eoEEP_A511xx.h
  • COOLING_HEATING_AUTO : eoEEP_D210xx.h
  • COOLING_HEATING_NO_CHANGE : eoEEP_D210xx.h
  • COOLING_HEATING_OFF : eoEEP_D210xx.h
  • COOLING_HEATING_ON : eoEEP_D210xx.h
  • COOLING_PROTECTION : eoEEP_D250xx.h
  • COOLING_STATUS : eoEEP_D210xx.h
  • CPM : eoEEP_A509xx.h
  • CS_A_1_10 : eoEEP_A511xx.h
  • CS_ALARM : eoEEP_A511xx.h
  • CS_ANGLE_SIGN : eoEEP_A511xx.h
  • CS_ANGLE_VALUE : eoEEP_A511xx.h
  • CS_CONTROLLER_STATE : eoEEP_A511xx.h
  • CS_DAYLIGHT_HARVEST : eoEEP_A511xx.h
  • CS_DIMMING : eoEEP_A511xx.h
  • CS_ENERGY_HOLDOFF : eoEEP_A511xx.h
  • CS_ENERGY_UNITS : eoEEP_A511xx.h
  • CS_ENUM_03_ERROR_STATE : eoEEP_A511xx.h
  • CS_ENUM_04_ERROR_STATE : eoEEP_A511xx.h
  • CS_ENUM_BLIND_STATE : eoEEP_A511xx.h
  • CS_ENUM_CONTROLLER_MODE : eoEEP_A511xx.h
  • CS_ENUM_END_POS : eoEEP_A511xx.h
  • CS_ENUM_ROOM_OCCUPANCY : eoEEP_A511xx.h
  • CS_FAN_STAGE : eoEEP_A511xx.h
  • CS_GIGA_WH : eoEEP_A511xx.h
  • CS_INDEXES : eoEEP_A511xx.h
  • CS_INTERNAL_ERROR : eoEEP_A511xx.h
  • CS_KILO_W : eoEEP_A511xx.h
  • CS_KILO_WH : eoEEP_A511xx.h
  • CS_LAMP_ERROR : eoEEP_A511xx.h
  • CS_MEGA_W : eoEEP_A511xx.h
  • CS_MEGA_WH : eoEEP_A511xx.h
  • CS_MILI_A : eoEEP_A511xx.h
  • CS_MILI_V : eoEEP_A511xx.h
  • CS_MILI_W : eoEEP_A511xx.h
  • CS_MODE_OF_POSITION : eoEEP_A511xx.h
  • CS_NO_ERROR : eoEEP_A511xx.h
  • CS_OPERATING_HOURS : eoEEP_A511xx.h
  • CS_POSITION_VALUE : eoEEP_A511xx.h
  • CS_POWER_RELAY : eoEEP_A511xx.h
  • CS_POWER_RELAY_TIMER : eoEEP_A511xx.h
  • CS_RELAY_STATUS : eoEEP_A511xx.h
  • CS_REPEATER : eoEEP_A511xx.h
  • CS_RGB_BLUE : eoEEP_A511xx.h
  • CS_RGB_GREEN : eoEEP_A511xx.h
  • CS_RGB_RED : eoEEP_A511xx.h
  • CS_SETVICE_MODE : eoEEP_A511xx.h
  • CS_STATUS : eoEEP_A511xx.h
  • CS_V_1_10 : eoEEP_A511xx.h
  • CS_W : eoEEP_A511xx.h
  • CS_WH : eoEEP_A511xx.h
  • CS_WORKING_MODE : eoEEP_A511xx.h
  • CUMULATIVE : eoEEP_A512xx.h
  • CUR_ROT_ANGLE : eoEEP_D205xx.h
  • CUR_VER_POSITION : eoEEP_D205xx.h
  • CURR_CHANNEL_1 : eoEEP_D232xx.h
  • CURR_CHANNEL_2 : eoEEP_D232xx.h
  • CURR_CHANNEL_3 : eoEEP_D232xx.h
  • CURRENT : eoEEP_A512xx.h
  • CURRENT_TEMP : eoEEP_A520xx.h
  • CUSTOM_WARNING_1 : eoEEP_D210xx.h
  • CUSTOM_WARNING_2 : eoEEP_D210xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- d -

  • D205_AET_ALARM_ENUM : eoEEP_D205xx.h
  • D205_INDEX_ENUM : eoEEP_D205xx.h
  • D205_LOCK_MODE_ENUM : eoEEP_D205xx.h
  • D205_MESSAGE_ID_ENUM : eoEEP_D205xx.h
  • D205_REPOSITIONING_ENUM : eoEEP_D205xx.h
  • D206_INDEX_ENUM : eoEEP_D206xx.h
  • D206_MSG_TYPE_ENUM : eoEEP_D206xx.h
  • D210_BATTERY_STATUS_ENUM : eoEEP_D210xx.h
  • D210_COOLING_HEATING_STATUS_ENUM : eoEEP_D210xx.h
  • D210_DATE_TIME_UPDATE_ENUM : eoEEP_D210xx.h
  • D210_DAYLIGHT_SAVE_ENUM : eoEEP_D210xx.h
  • D210_DISPLAY_CONTENT_ENUM : eoEEP_D210xx.h
  • D210_FAN_SPEED_MODE_ENUM : eoEEP_D210xx.h
  • D210_FEEDBACK_CLASS_ENUM : eoEEP_D210xx.h
  • D210_GENERAL_MSG_TYPE_ENUM : eoEEP_D210xx.h
  • D210_INDEX_ENUM : eoEEP_D210xx.h
  • D210_INFO_REQUEST_ENUM : eoEEP_D210xx.h
  • D210_LOCK_ENUM : eoEEP_D210xx.h
  • D210_MESSAGE_ID_ENUM : eoEEP_D210xx.h
  • D210_MSG_CONTINUATION_ENUM : eoEEP_D210xx.h
  • D210_OCCUPANCY_STATUS_ENUM : eoEEP_D210xx.h
  • D210_PERIOD_ENUM : eoEEP_D210xx.h
  • D210_PIR_STATUS_ENUM : eoEEP_D210xx.h
  • D210_RADIO_COM_INTERVAL_ENUM : eoEEP_D210xx.h
  • D210_ROOM_CONTROL_ENUM : eoEEP_D210xx.h
  • D210_SOLAR_POWERED_ENUM : eoEEP_D210xx.h
  • D210_TEMP_SCALE_ENUM : eoEEP_D210xx.h
  • D210_TIME_NOTATION_ENUM : eoEEP_D210xx.h
  • D210_TIME_PROG_DELETION_ENUM : eoEEP_D210xx.h
  • D210_VALIDITY_FLAG_ENUM : eoEEP_D210xx.h
  • D210_WINDOW_OPEN_ENUM : eoEEP_D210xx.h
  • D240_DRIVING_LED_ENUM : eoEEP_D240xx.h
  • D240_FALSE : eoEEP_D240xx.h
  • D240_INDEX_ENUM : eoEEP_D240xx.h
  • D240_NOT_OCCUPIED : eoEEP_D240xx.h
  • D240_OCCUPANCY_ENUM : eoEEP_D240xx.h
  • D240_OCCUPIED : eoEEP_D240xx.h
  • D240_STATUS_REASON_ENUM : eoEEP_D240xx.h
  • D240_TRUE : eoEEP_D240xx.h
  • D240_TRUE_FALSE_ENUM : eoEEP_D240xx.h
  • D240_UNKNOWN : eoEEP_D240xx.h
  • D250_AIRFLAP_BYPASS : eoEEP_D250xx.h
  • D250_DIRECT_OP_MODE : eoEEP_D250xx.h
  • D250_OP_MODE : eoEEP_D250xx.h
  • D250_REQUESTED_MSG_TYPE : eoEEP_D250xx.h
  • D250xx_COMMANDS : eoEEP_D250xx.h
  • D250xx_INDEX : eoEEP_D250xx.h
  • D323_INDEX_ENUMS : eoEEP_D232xx.h
  • DATA_MSG : eoEEP_D210xx.h
  • DATA_REQUEST : eoEEP_D210xx.h
  • DATA_TYPE_METER_READING : eoEEP_A512xx.h
  • DATE_TIME_LOCK : eoEEP_D210xx.h
  • DATE_TIME_NO_UPDATE : eoEEP_D210xx.h
  • DATE_TIME_UPDATE : eoEEP_D210xx.h
  • DATE_TIME_UPDATE_FLAG : eoEEP_D210xx.h
  • DAYLIGH_HARVEST : eoEEP_D240xx.h
  • DAYLIGHT_NOT_SUPPORTED : eoEEP_D210xx.h
  • DAYLIGHT_SAVE : eoEEP_D210xx.h
  • DAYLIGHT_SUPPORTED : eoEEP_D210xx.h
  • DBM : eoSerialCommand.h
  • DEFROST_MODE : eoEEP_D250xx.h
  • DESTINATION_ID : eoSerialCommand.h
  • DIGITAL_IN_0 : eoEEP_A530xx.h
  • DIGITAL_IN_1 : eoEEP_A530xx.h
  • DIGITAL_IN_2 : eoEEP_A530xx.h
  • DIGITAL_IN_3 : eoEEP_A530xx.h
  • DIGITAL_INPUT_STATUS : eoEEP_D250xx.h
  • DIGITAL_OUTPUT_STATUS : eoEEP_D250xx.h
  • DIM_LEVEL_BLUE : eoEEP_D240xx.h
  • DIM_LEVEL_GREEN : eoEEP_D240xx.h
  • DIM_LEVEL_MONO : eoEEP_D240xx.h
  • DIM_LEVEL_RED : eoEEP_D240xx.h
  • DIM_STOP : eoEEP_D201xx.h
  • DIM_TO_NEW_FAST : eoEEP_D201xx.h
  • DIM_TO_NEW_MED : eoEEP_D201xx.h
  • DIM_TO_NEW_SLOW : eoEEP_D201xx.h
  • DIMMING_FAST : eoEEP_D201xx.h
  • DIMMING_MEDIUM : eoEEP_D201xx.h
  • DIMMING_SLOW : eoEEP_D201xx.h
  • DIRECT_MODE_AUTO : eoEEP_D250xx.h
  • DIRECT_MODE_AUTO_OD : eoEEP_D250xx.h
  • DIRECT_MODE_LEVEL_1 : eoEEP_D250xx.h
  • DIRECT_MODE_LEVEL_2 : eoEEP_D250xx.h
  • DIRECT_MODE_LEVEL_3 : eoEEP_D250xx.h
  • DIRECT_MODE_LEVEL_4 : eoEEP_D250xx.h
  • DIRECT_MODE_NO_ACTION : eoEEP_D250xx.h
  • DIRECT_MODE_OFF : eoEEP_D250xx.h
  • DIRECT_MODE_SEXHAUST_ONLY : eoEEP_D250xx.h
  • DIRECT_MODE_SUPPLY_ONLY : eoEEP_D250xx.h
  • DIRECT_OP_MODE : eoEEP_D250xx.h
  • DISABLE_REMOTE_CONTROL : eoEEP_A520xx.h
  • DISPLAY_CONTENT : eoEEP_D210xx.h
  • DISPLAY_DEFAULT : eoEEP_D210xx.h
  • DISPLAY_EXTERNAL_TEMP : eoEEP_D210xx.h
  • DISPLAY_HUMIDITY : eoEEP_D210xx.h
  • DISPLAY_INTERNAL_TEMP : eoEEP_D210xx.h
  • DISPLAY_LOCK : eoEEP_D210xx.h
  • DISPLAY_NO_CHANGE : eoEEP_D210xx.h
  • DISPLAY_OFF : eoEEP_D210xx.h
  • DISPLAY_ORIENTATION : eoEEP_A520xx.h
  • DISPLAY_TEMP_SETPOINT : eoEEP_D210xx.h
  • DISPLAY_TIME : eoEEP_D210xx.h
  • DO_NOTHING : eoEEP_A538xx.h
  • DRAIN_HEATER_STATUS : eoEEP_D250xx.h
  • DRIVE_TO_POS : eoEEP_A538xx.h
  • DRIVING_DISABLED : eoEEP_D240xx.h
  • DRIVING_ENABLED : eoEEP_D240xx.h
  • DRIVING_LED : eoEEP_D240xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- e -

  • E_COMMAND : eoChannelEnums.h
  • E_CONTROLLER_MODE : eoChannelEnums.h
  • E_DAYS : eoChannelEnums.h
  • E_DIM_VALUE : eoChannelEnums.h
  • E_DIRECTION : eoChannelEnums.h
  • E_END_POS : eoChannelEnums.h
  • E_ENERGYBOW : eoChannelEnums.h
  • E_ERROR_STATE : eoChannelEnums.h
  • E_FANSPEED : eoChannelEnums.h
  • E_GP_BUILDING_MODE : eoChannelEnums.h
  • E_GP_CHANGEOVER_MODE : eoChannelEnums.h
  • E_GP_HVAC_MODE : eoChannelEnums.h
  • E_GP_MULTIPURPOSE : eoChannelEnums.h
  • E_GP_OCCUPANCY : eoChannelEnums.h
  • E_IO_CHANNEL : eoChannelEnums.h
  • E_KEY_DATA : eoChannelEnums.h
  • E_MULTIPRESS : eoChannelEnums.h
  • E_OCCUPANCY : eoChannelEnums.h
  • E_PRESENCE : eoChannelEnums.h
  • E_ROCKER_A : eoChannelEnums.h
  • E_ROCKER_B : eoChannelEnums.h
  • E_ROCKER_C : eoChannelEnums.h
  • E_ROCKER_D : eoChannelEnums.h
  • E_ROOM_SIZE : eoChannelEnums.h
  • E_STATE : eoChannelEnums.h
  • E_TARIFF : eoChannelEnums.h
  • E_UNITS : eoChannelEnums.h
  • E_USER_ACTION : eoChannelEnums.h
  • E_VOC : eoChannelEnums.h
  • E_WINDOWHANDLE : eoChannelEnums.h
  • EA_AM_PM : eoEEP_A513xx.h
  • EA_ENUM_DAYS : eoEEP_A513xx.h
  • EA_HEMISPHERE : eoEEP_A513xx.h
  • EA_INDEXS : eoEEP_A513xx.h
  • EA_TIME_FORMAT : eoEEP_A513xx.h
  • EA_TIME_SOURCE : eoEEP_A513xx.h
  • EC_FLYWHEEL_TIMER : eoSerialCommand.h
  • EC_MEM_ERRPR : eoSerialCommand.h
  • EC_PARITY_ERROR : eoSerialCommand.h
  • EC_PARITY_MEM_ERROR : eoSerialCommand.h
  • EC_RESET_CAUSE : eoSerialCommand.h
  • EC_RESET_PIN : eoSerialCommand.h
  • EC_UNKNOWN : eoSerialCommand.h
  • EC_VOLTAGE_DROP : eoSerialCommand.h
  • EC_WAKE_PIN_0 : eoSerialCommand.h
  • EC_WAKE_PIN_1 : eoSerialCommand.h
  • EC_WATCHDOG_TIMER : eoSerialCommand.h
  • ECONOMY_TEMP_SETPOINT : eoEEP_D210xx.h
  • ECONOMY_TEMP_TEMP_SETPOINT_VALIDITY : eoEEP_D210xx.h
  • EEP_NOT_SUPPORTED : eoTeachInModule.h
  • EEP_TEACH_IN : eoTeachInModule.h
  • ELEVATION : eoEEP_A513xx.h
  • EM_INDEXS : eoEEP_A537xx.h
  • END_POINT_DETECTION : eoEEP_A520xx.h
  • END_POS_NO_CONFIG : eoEEP_A511xx.h
  • END_TIME_HOUR : eoEEP_D210xx.h
  • END_TIME_MINUTE : eoEEP_D210xx.h
  • ENERGY_HOLDOFF : eoEEP_A520xx.h
  • ENERGY_INPUT : eoEEP_A520xx.h
  • ENERGY_KWH : eoEEP_D201xx.h
  • ENERGY_PRESSED : eoF6EEProfile.h
  • ENERGY_RELEASED : eoF6EEProfile.h
  • ENERGY_STORAGE : eoEEP_A520xx.h
  • ENERGY_WH : eoEEP_D201xx.h
  • ENERGY_WS : eoEEP_D201xx.h
  • ENUM_DIGITAL_INPUT : eoEEP_A530xx.h
  • ENUM_ENERGY_STATE : eoF6EEProfile.h
  • ENUM_FAN_SPEED_5STAGE : eoA5EEProfile.h
  • ENUM_FAN_SPEED_7STAGE : eoA5EEProfile.h
  • ENUM_MULTIPRESS_STATE : eoF6EEProfile.h
  • ENUM_PARTICLES_SIZE : eoEEP_A509xx.h
  • ENUM_POWER_FAILURE_DETECTION : eoEEP_A509xx.h
  • ENUM_RADIATION_UNIT : eoEEP_A509xx.h
  • ENUM_ROCKER_STATE : eoF6EEProfile.h
  • ENUM_VOC : eoA5EEProfile.h
  • ENUM_WINDOW_STATE : eoF6EEProfile.h
  • enumStrings : eoChannelEnums.h
  • EO_ERROR : eoApiDef.h
  • EO_OK : eoApiDef.h
  • EO_SEC_WATCH_RESULT : eoWatcher.h
  • EO_STORAGE_IDENTIFIER : eoStorageManager.h
  • eoReComReturn : eoReCom.h
  • eoReturn : eoApiDef.h
  • EXHAUST_AIR_POS : eoEEP_D250xx.h
  • EXHAUST_FAN_RATE : eoEEP_D250xx.h
  • EXHAUST_FAN_SPEED : eoEEP_D250xx.h
  • EXHAUST_TEMP : eoEEP_D250xx.h
  • EXT_PERIPHERY_ERROR : eoEEP_A511xx.h
  • EXTERNAL_DISABLEMENT : eoEEP_A520xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- f -

  • F_AUTO_MAN : eoChannelEnums.h
  • F_BTN_PRESS : eoChannelEnums.h
  • F_BTN_TRIGGER : eoChannelEnums.h
  • F_DAY_NIGHT : eoChannelEnums.h
  • F_DOWN : eoChannelEnums.h
  • F_GENALARM : eoChannelEnums.h
  • F_HEAT_COOL : eoChannelEnums.h
  • F_HIGH_LOW : eoChannelEnums.h
  • F_OCCUPIED : eoChannelEnums.h
  • F_ON_OFF : eoChannelEnums.h
  • F_OPEN_CLOSED : eoChannelEnums.h
  • F_POWERALARM : eoChannelEnums.h
  • F_START_STOP : eoChannelEnums.h
  • F_UP : eoChannelEnums.h
  • F_VIBRATION : eoChannelEnums.h
  • FAILURE : eoEEP_A520xx.h
  • FAILURE_FLAG : eoEEP_A520xx.h
  • FAN : eoEEP_D200xx.h
  • FAN_NO_CHANGE : eoEEP_D200xx.h
  • FAN_OVERRIDE : eoEEP_A520xx.h
  • FAN_SPEED_CENTRAL_CONTROL : eoEEP_D210xx.h
  • FAN_SPEED_INDIVIDUAL_CONTROL : eoEEP_D210xx.h
  • FAN_SPEED_LOCK : eoEEP_D210xx.h
  • FANSPEED_MODE : eoEEP_D210xx.h
  • FANSPEED_VALIDITY : eoEEP_D210xx.h
  • FAULT_STATUS : eoEEP_D250xx.h
  • FC_RELHUM_DEFAULT : eoEEP_D220xx.h
  • FC_RELHUM_DISABLED : eoEEP_D220xx.h
  • FC_RELHUM_ENABLED : eoEEP_D220xx.h
  • FC_SERVICE_AIR_FILTER : eoEEP_D220xx.h
  • FC_SERVICE_HW_ERROR : eoEEP_D220xx.h
  • FC_SERVICE_NO_REPORT : eoEEP_D220xx.h
  • FC_SERVICE_NOT_SUPPORTED : eoEEP_D220xx.h
  • FC_STAGE_AUTO : eoEEP_D220xx.h
  • FC_STAGE_DEFAULT : eoEEP_D220xx.h
  • FC_STAGE_NO_CHANGE : eoEEP_D220xx.h
  • FEED_TEMP : eoEEP_A520xx.h
  • FEED_TEMP_SELECT : eoEEP_A520xx.h
  • FEEDBACK_CLASS : eoEEP_D210xx.h
  • FILTER_KIND : eoSerialCommand.h
  • FILTER_MAINTENANCE : eoEEP_D250xx.h
  • FILTER_OPERATOR : eoSerialCommand.h
  • FILTER_TYPE : eoSerialCommand.h
  • flagStrings : eoChannelEnums.h
  • float32 : eoHalTypes.h
  • FN_ACTION : eoRemoteManager.h
  • FN_CODE : eoRemoteManager.h
  • FN_LOCK : eoRemoteManager.h
  • FN_PING : eoRemoteManager.h
  • FN_PING_ANSWER : eoRemoteManager.h
  • FN_QUERY_FUNCTION : eoRemoteManager.h
  • FN_QUERY_FUNCTION_ANSWER : eoRemoteManager.h
  • FN_QUERY_STATUS : eoRemoteManager.h
  • FN_QUERY_STATUS_ANSWER : eoRemoteManager.h
  • FN_QUERYID : eoRemoteManager.h
  • FN_QUERYID_ANSWER : eoRemoteManager.h
  • FN_RECOM_ACK : eoReCom.h
  • FN_RECOM_APPLY_CHANGES : eoReCom.h
  • FN_RECOM_CODE : eoReCom.h
  • FN_RECOM_GET_DEVICE_CONFIG : eoReCom.h
  • FN_RECOM_GET_DEVICE_CONFIG_RESPONSE : eoReCom.h
  • FN_RECOM_GET_GP_TABLE : eoReCom.h
  • FN_RECOM_GET_GP_TABLE_RESPONSE : eoReCom.h
  • FN_RECOM_GET_LINK_BASED_CONFIG : eoReCom.h
  • FN_RECOM_GET_LINK_BASED_CONFIG_RESPONSE : eoReCom.h
  • FN_RECOM_GET_METADATA : eoReCom.h
  • FN_RECOM_GET_METADATA_RESPONSE : eoReCom.h
  • FN_RECOM_GET_PRODUCT_ID : eoReCom.h
  • FN_RECOM_GET_PRODUCT_RESPONSE : eoReCom.h
  • FN_RECOM_GET_REPEATER_FUNCTIONS : eoReCom.h
  • FN_RECOM_GET_REPEATER_FUNCTIONS_RESPONSE : eoReCom.h
  • FN_RECOM_GET_TABLE : eoReCom.h
  • FN_RECOM_GET_TABLE_RESPONSE : eoReCom.h
  • FN_RECOM_RADIO_LINK_TEST_CONTROL : eoReCom.h
  • FN_RECOM_RESET_TO_DEFAULTS : eoReCom.h
  • FN_RECOM_SET_DEVICE_CONFIG : eoReCom.h
  • FN_RECOM_SET_GP_TABLE : eoReCom.h
  • FN_RECOM_SET_LEARN_MODE : eoReCom.h
  • FN_RECOM_SET_LINK_BASED_CONFIG : eoReCom.h
  • FN_RECOM_SET_REPEATER_FILTER : eoReCom.h
  • FN_RECOM_SET_REPEATER_FUNCTIONS : eoReCom.h
  • FN_RECOM_SET_TABLE : eoReCom.h
  • FN_RECOM_TRIG_OUTBOUND_TEACH_REQ : eoReCom.h
  • FN_REMOTE_FLASH_READ : eoRemoteManager.h
  • FN_REMOTE_FLASH_READ_ANSWER : eoRemoteManager.h
  • FN_REMOTE_FLASH_WRITE : eoRemoteManager.h
  • FN_REMOTE_LEARNIN : eoRemoteManager.h
  • FN_SETCODE : eoRemoteManager.h
  • FN_SMARTACK_READ : eoRemoteManager.h
  • FN_SMARTACK_READ_LEARNED_SENSOR_ANSWER : eoRemoteManager.h
  • FN_SMARTACK_READ_MAILBOX_ANSWER : eoRemoteManager.h
  • FN_SMARTACK_WRITE : eoRemoteManager.h
  • FN_UNLOCK : eoRemoteManager.h
  • FORMAT_12 : eoEEP_A513xx.h
  • FORMAT_24 : eoEEP_A513xx.h
  • FRIDAY : eoEEP_A513xx.h
  • FROST : eoEEP_A511xx.h
  • FROST_PROTECTION : eoEEP_A520xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- g -

  • GENERAL_MSG : eoEEP_D210xx.h
  • GENERAL_MSG_TYPE : eoEEP_D210xx.h
  • GENERAL_REASON : eoTeachInModule.h
  • GENERIC_TEACH_IN : eoTeachInModule.h
  • GIGA_WH : eoEEP_A538xx.h
  • GOTO_MSG : eoEEP_D205xx.h
  • GP_CD : eoApiDef.h
  • GP_CHANNELTYPE : eoGPChannelInfo.h
  • GP_DATA : eoGPChannelInfo.h
  • GP_DATA_DIRECTION : eoGenericProfile.h
  • GP_DATA_DIRECTION_LEN : eoGenericProfile.h
  • GP_DATA_DIRECTION_OFF : eoGenericProfile.h
  • GP_ENUM : eoChannelEnums.h
  • GP_ENUMERATION : eoGPChannelInfo.h
  • GP_FLAG : eoGPChannelInfo.h
  • GP_HEADER_PURPOSE : eoGenericProfile.h
  • GP_MANUFACTURER_LEN : eoGenericProfile.h
  • GP_MANUFACTURER_OFF : eoGenericProfile.h
  • GP_PURPOSE_LEN : eoGenericProfile.h
  • GP_PURPOSE_OFF : eoGenericProfile.h
  • GP_RESOLUTION : eoGPChannelInfo.h
  • GP_RESPONSE_RESULT : eoTeachInModule.h
  • GP_SCALING : eoGPChannelInfo.h
  • GP_SD : eoApiDef.h
  • GP_TEACHIN_INFO : eoGPChannelInfo.h
  • GP_TI : eoApiDef.h
  • GP_TR : eoApiDef.h
  • gpEnumString : eoChannelEnums.h
  • GPS : eoEEP_A513xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- h -

  • HANDLE_CLICK : eoEEP_D206xx.h
  • HANDLE_CLOSED : eoEEP_D206xx.h
  • HANDLE_OPENED : eoEEP_D206xx.h
  • HANDLE_POSITION : eoEEP_D206xx.h
  • HANDLE_TILTED : eoEEP_D206xx.h
  • HARDWARE_OK : eoEEP_D201xx.h
  • HARDWARE_WARNING : eoEEP_D201xx.h
  • HARDWATE_FAIL : eoEEP_D201xx.h
  • HEART_BEAT_SIGNAL : eoEEP_A530xx.h
  • HEARTBEAT : eoEEP_D240xx.h
  • HEAT_EXCHANGE_CTRL : eoEEP_D250xx.h
  • HEATING : eoEEP_A511xx.h
  • HEATING_STATUS : eoEEP_D210xx.h
  • HRS_12 : eoEEP_A520xx.h
  • HRS_15 : eoEEP_A520xx.h
  • HRS_18 : eoEEP_A520xx.h
  • HRS_21 : eoEEP_A520xx.h
  • HRS_24 : eoEEP_A520xx.h
  • HRS_27 : eoEEP_A520xx.h
  • HRS_3 : eoEEP_A520xx.h
  • HRS_30 : eoEEP_A520xx.h
  • HRS_33 : eoEEP_A520xx.h
  • HRS_36 : eoEEP_A520xx.h
  • HRS_39 : eoEEP_A520xx.h
  • HRS_42 : eoEEP_A520xx.h
  • HRS_6 : eoEEP_A520xx.h
  • HRS_9 : eoEEP_A520xx.h
  • HVAC_MODE : eoEEP_A520xx.h
  • HVCA_AUTO : eoEEP_A520xx.h
  • HVCA_AUTO_MOD : eoEEP_A520xx.h
  • HVCA_BUTTON_LOCK : eoEEP_A520xx.h
  • HVCA_CLOSE_VALVE : eoEEP_A520xx.h
  • HVCA_CONTROLLER_MODE : eoEEP_A520xx.h
  • HVCA_COOL_MOD : eoEEP_A520xx.h
  • HVCA_DIRECTION : eoEEP_A520xx.h
  • HVCA_DIRECTION_1 : eoEEP_A520xx.h
  • HVCA_DIRECTION_2 : eoEEP_A520xx.h
  • HVCA_DISPLAY_ORIENTATION : eoEEP_A520xx.h
  • HVCA_FAILURE : eoEEP_A520xx.h
  • HVCA_FAILURE_CODE : eoEEP_A520xx.h
  • HVCA_FANSPEED : eoEEP_A520xx.h
  • HVCA_FROST_20 : eoEEP_A520xx.h
  • HVCA_HEAT_MOD : eoEEP_A520xx.h
  • HVCA_INDEX : eoEEP_A520xx.h
  • HVCA_MEASUREMENT_CONTROL : eoEEP_A520xx.h
  • HVCA_MEASUREMENT_STATUS : eoEEP_A520xx.h
  • HVCA_NO_CHANGE : eoEEP_A520xx.h
  • HVCA_OCCUPIED : eoEEP_A520xx.h
  • HVCA_OCCUPIED_20 : eoEEP_A520xx.h
  • HVCA_OFF : eoEEP_A520xx.h
  • HVCA_OFF_MOD : eoEEP_A520xx.h
  • HVCA_OPEN_VALVE : eoEEP_A520xx.h
  • HVCA_ROOM_OCCUPANCY : eoEEP_A520xx.h
  • HVCA_ROOM_OCCUPANCY_TYPE_20 : eoEEP_A520xx.h
  • HVCA_RUN_INIT : eoEEP_A520xx.h
  • HVCA_SERVICE_COMMAND : eoEEP_A520xx.h
  • HVCA_STAGE_0 : eoEEP_A520xx.h
  • HVCA_STAGE_1 : eoEEP_A520xx.h
  • HVCA_STAGE_2 : eoEEP_A520xx.h
  • HVCA_STAGE_3 : eoEEP_A520xx.h
  • HVCA_STANDBY : eoEEP_A520xx.h
  • HVCA_STANDBY_20 : eoEEP_A520xx.h
  • HVCA_STATUS_REQUEST : eoEEP_A520xx.h
  • HVCA_TEMP_SELECTION : eoEEP_A520xx.h
  • HVCA_UNOCCUPIED : eoEEP_A520xx.h
  • HVCA_UNOCCUPIED_20 : eoEEP_A520xx.h
  • HVCA_VANE_POSITION : eoEEP_A520xx.h
  • HVCA_WAKEUP_CYCLE : eoEEP_A520xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- i -

  • id_device_map : eoDeviceManager.h
  • id_msg_map : eoGpChainer.h , eoSecTeachInChainer.h
  • id_reman_msg_map : eoReManChainer.h
  • id_set : eoIDFilter.h
  • INDOOR_TEMP : eoEEP_D250xx.h
  • INFO_MSG_STATUS : eoEEP_D250xx.h
  • INFO_REQUEST_CLASS : eoEEP_D210xx.h
  • INPUT_FOR_MAINS : eoEEP_D201xx.h
  • INTERNAL_ERROR : eoEEP_A511xx.h
  • INVALID_PACKET : eoApiDef.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- k -

  • KEY_DATA_1 : eoEEP_A530xx.h
  • KEY_DATA_2 : eoEEP_A530xx.h
  • KEY_DATA_3 : eoEEP_A530xx.h
  • KEY_DATA_4 : eoEEP_A530xx.h
  • KEY_DATA_5 : eoEEP_A530xx.h
  • KEY_DATA_6 : eoEEP_A530xx.h
  • KEY_LOCK : eoEEP_D210xx.h
  • KEYCARD_DISABLEMENT : eoEEP_A520xx.h
  • KILO_W : eoEEP_A538xx.h
  • KILO_WH : eoEEP_A538xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- l -

  • LATITUDE : eoEEP_A513xx.h
  • LIFT_SET : eoEEP_A520xx.h
  • LOCAL_CONTROL : eoEEP_D201xx.h
  • LOCK_ALARM : eoEEP_D205xx.h
  • LOCK_BLOCKAGE : eoEEP_D205xx.h
  • LOCK_DEBLOCKAGE : eoEEP_D205xx.h
  • LOCK_LOCAL_OP : eoEEP_A538xx.h
  • LOCK_NORMAL : eoEEP_D205xx.h
  • LOCK_SWITCH_OFF : eoEEP_A538xx.h
  • LOCK_SWITCH_ON : eoEEP_A538xx.h
  • LOCKED : eoEEP_D210xx.h
  • LONGITUDE : eoEEP_A513xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- m -

  • MANUFACTURER_LIST : eoManufacturer.h
  • MASTER_SLAVE_CONFIG : eoEEP_D250xx.h
  • MAX_MIN_POWER : eoEEP_A537xx.h
  • MAX_SUB_TIME : eoEEP_D201xx.h
  • MEASUREMENT_ACTIVE : eoEEP_A520xx.h
  • MEASUREMENT_CONTROL : eoEEP_A520xx.h
  • MEASUREMENT_DISABLE : eoEEP_A520xx.h
  • MEASUREMENT_ENABLE : eoEEP_A520xx.h
  • MEASUREMENT_ERROR : eoEEP_A520xx.h
  • MEASUREMENT_INACTIVE : eoEEP_A520xx.h
  • MEASUREMENT_MODE : eoEEP_D201xx.h
  • MEASUREMENT_STATUS : eoEEP_A520xx.h
  • MEGA_W : eoEEP_A538xx.h
  • MEGA_WH : eoEEP_A538xx.h
  • MILI_A : eoEEP_A538xx.h
  • MILI_V : eoEEP_A538xx.h
  • MILI_W : eoEEP_A538xx.h
  • MIN_SUB_TIME : eoEEP_D201xx.h
  • MINIMUM_ADVANCED_DATA_LENGTH : eoConverter.h
  • MODE_ADVANCED : eoSerialCommand.h
  • MODE_AUTO : eoEEP_A520xx.h
  • MODE_AUTO_COOL : eoEEP_A520xx.h
  • MODE_AUTO_HEAT : eoEEP_A520xx.h
  • MODE_CALIBRATION : eoEEP_A520xx.h
  • MODE_COMPATIBLE : eoSerialCommand.h
  • MODE_COOL : eoEEP_A520xx.h
  • MODE_DEHUMIDITY : eoEEP_A520xx.h
  • MODE_ECONOMIC : eoEEP_A520xx.h
  • MODE_EMERGENCY_COOL : eoEEP_A520xx.h
  • MODE_EMERGENCY_HEAT : eoEEP_A520xx.h
  • MODE_EMERGENCY_STEAM : eoEEP_A520xx.h
  • MODE_FAN_ONLY : eoEEP_A520xx.h
  • MODE_FREE_COOL : eoEEP_A520xx.h
  • MODE_HEAT : eoEEP_A520xx.h
  • MODE_HVC_LOAD : eoEEP_A520xx.h
  • MODE_ICE : eoEEP_A520xx.h
  • MODE_MAX_COOL : eoEEP_A520xx.h
  • MODE_MAX_HEAT : eoEEP_A520xx.h
  • MODE_MORING_WARMUP : eoEEP_A520xx.h
  • MODE_NIGHT_PURGE : eoEEP_A520xx.h
  • MODE_NO_LOAD : eoEEP_A520xx.h
  • MODE_OFF : eoEEP_A520xx.h
  • MODE_PRECOOL : eoEEP_A520xx.h
  • MODE_TEST : eoEEP_A520xx.h
  • MOLD_WARNING : eoEEP_D210xx.h
  • MONDAY : eoEEP_A513xx.h
  • MOTION : eoEEP_D206xx.h
  • MSG_AUTO_CONTROL : eoEEP_D210xx.h
  • MSG_COMPLETE : eoEEP_D210xx.h
  • MSG_CONFIG_REPORT : eoEEP_D206xx.h
  • MSG_CONTINUATION : eoEEP_D210xx.h
  • MSG_CTRL_SETTINGS : eoEEP_D206xx.h
  • MSG_INCOMPLETE : eoEEP_D210xx.h
  • MSG_LOG_DATA_1 : eoEEP_D206xx.h
  • MSG_LOG_DATA_2 : eoEEP_D206xx.h
  • MSG_LOG_DATA_3 : eoEEP_D206xx.h
  • MSG_LOG_DATA_4 : eoEEP_D206xx.h
  • MSG_REPETITION_FEEDBACK : eoEEP_D210xx.h
  • MSG_SENSOR_VALUES : eoEEP_D206xx.h
  • MSG_TYPE_FEEDBACK : eoEEP_D210xx.h
  • MSG_TYPE_INFO_REQUEST : eoEEP_D210xx.h
  • MSR_1000_SECOND : eoEEP_D230xx.h
  • MSR_1000_SECOND_REPORT : eoEEP_D230xx.h
  • MSR_100_SECOND : eoEEP_D230xx.h
  • MSR_100_SECOND_REPORT : eoEEP_D230xx.h
  • MSR_10_SECOND : eoEEP_D230xx.h
  • MSR_10_SECOND_REPORT : eoEEP_D230xx.h
  • MSR_1_SECOND : eoEEP_D230xx.h
  • MSR_1_SECOND_REPORT : eoEEP_D230xx.h
  • MSR_200_SECOND : eoEEP_D230xx.h
  • MSR_20_SECOND : eoEEP_D230xx.h
  • MSR_2_SECOND : eoEEP_D230xx.h
  • MSR_300_SECOND_REPORT : eoEEP_D230xx.h
  • MSR_30_SECOND_REPORT : eoEEP_D230xx.h
  • MSR_3_SECOND_REPORT : eoEEP_D230xx.h
  • MSR_500_SECOND : eoEEP_D230xx.h
  • MSR_50_SECOND : eoEEP_D230xx.h
  • MSR_5_SECOND : eoEEP_D230xx.h
  • MSR_BUS_TYPE_D0 : eoEEP_D230xx.h
  • MSR_BUS_TYPE_MBUS : eoEEP_D230xx.h
  • MSR_BUS_TYPE_S0 : eoEEP_D230xx.h
  • MSR_CHANNEL_ERROR : eoEEP_D230xx.h
  • MSR_CHANNEL_ERROR_HCH31 : eoEEP_D230xx.h
  • MSR_CHANNEL_METER_1 : eoEEP_D230xx.h
  • MSR_CHANNEL_METER_2 : eoEEP_D230xx.h
  • MSR_CHANNEL_METER_CHANNEL : eoEEP_D230xx.h
  • MSR_CHANNEL_METER_ERROR : eoEEP_D230xx.h
  • MSR_CHANNEL_METER_TYPE : eoEEP_D230xx.h
  • MSR_CHANNEL_NUM_OF_PULSES : eoEEP_D230xx.h
  • MSR_CHANNEL_PRESET_VALUE : eoEEP_D230xx.h
  • MSR_CHANNEL_PRIMARY_ADDR : eoEEP_D230xx.h
  • MSR_CHANNEL_PROTOCOL : eoEEP_D230xx.h
  • MSR_CHANNEL_PULSES_FACTOR : eoEEP_D230xx.h
  • MSR_CHANNEL_REPORT_TIME : eoEEP_D230xx.h
  • MSR_CHANNEL_RETURN_TEMP : eoEEP_D230xx.h
  • MSR_CHANNEL_SUPPLY_TEMP : eoEEP_D230xx.h
  • MSR_CHANNEL_VALUE_SELECTION : eoEEP_D230xx.h
  • MSR_CHANNELS : eoEEP_D230xx.h
  • MSR_COMMANDS : eoEEP_D230xx.h
  • MSR_CONNECTED_VALVE : eoEEP_D230xx.h
  • MSR_ERROR_CH31_GENERAL : eoEEP_D230xx.h
  • MSR_ERROR_CH31_NO_FAULT : eoEEP_D230xx.h
  • MSR_ERROR_CH31_RETURN_TEMP : eoEEP_D230xx.h
  • MSR_ERROR_CH31_SUPPLY_RETURN_TEMP : eoEEP_D230xx.h
  • MSR_ERROR_CH31_SUPPLY_TEMP : eoEEP_D230xx.h
  • MSR_ERROR_CHANNEL_NOT_AVAILABLE : eoEEP_D230xx.h
  • MSR_ERROR_CODE : eoEEP_D230xx.h
  • MSR_ERROR_CODE_CH31 : eoEEP_D230xx.h
  • MSR_ERROR_GENERAL : eoEEP_D230xx.h
  • MSR_ERROR_INIT_SEQU_RUNNING : eoEEP_D230xx.h
  • MSR_ERROR_NO_FAULT : eoEEP_D230xx.h
  • MSR_ERROR_TEMP_SENSOR : eoEEP_D230xx.h
  • MSR_ERROR_TEMP_SENSOR_VALVE : eoEEP_D230xx.h
  • MSR_ERROR_VALVE : eoEEP_D230xx.h
  • MSR_FACTOR_PULSES : eoEEP_D230xx.h
  • MSR_FACTOR_PULSES_0001 : eoEEP_D230xx.h
  • MSR_FACTOR_PULSES_001 : eoEEP_D230xx.h
  • MSR_FACTOR_PULSES_01 : eoEEP_D230xx.h
  • MSR_FACTOR_PULSES_1 : eoEEP_D230xx.h
  • MSR_HEAT_CONTROL_STATUS_QUERY : eoEEP_D230xx.h
  • MSR_HEAT_CONTROL_STATUS_RESPONSE : eoEEP_D230xx.h
  • MSR_INIT_SEQU : eoEEP_D230xx.h
  • MSR_LOCAL_DEFAULT : eoEEP_D230xx.h
  • MSR_METER_BUS_INIT_RUNNING : eoEEP_D230xx.h
  • MSR_METER_BUS_NO_CONFIG : eoEEP_D230xx.h
  • MSR_METER_BUS_NO_CONNECTION : eoEEP_D230xx.h
  • MSR_METER_BUS_SHORTCUT : eoEEP_D230xx.h
  • MSR_METER_BUS_TYPE : eoEEP_D230xx.h
  • MSR_METER_ERROR_CODE : eoEEP_D230xx.h
  • MSR_METER_ERROR_GENERAL : eoEEP_D230xx.h
  • MSR_METER_ERROR_NO_FAULT : eoEEP_D230xx.h
  • MSR_METER_READING_REPORT : eoEEP_D230xx.h
  • MSR_METER_STATUS_QUERY : eoEEP_D230xx.h
  • MSR_METER_TIMEOUT : eoEEP_D230xx.h
  • MSR_METER_UNITS : eoEEP_D230xx.h
  • MSR_METER_UNKNOWN_CONFIG : eoEEP_D230xx.h
  • MSR_NO_ACTION : eoEEP_D230xx.h
  • MSR_NO_REPORT : eoEEP_D230xx.h
  • MSR_PROTOCOL : eoEEP_D230xx.h
  • MSR_PROTOCOL_AUTO_DETECT : eoEEP_D230xx.h
  • MSR_PROTOCOL_DLMS : eoEEP_D230xx.h
  • MSR_PROTOCOL_SML : eoEEP_D230xx.h
  • MSR_REPORT_TIME_VALUES : eoEEP_D230xx.h
  • MSR_RUN_INIT_SEQU : eoEEP_D230xx.h
  • MSR_SET_HEAT_CONTROLS : eoEEP_D230xx.h
  • MSR_SET_METER_CONFIGURATION : eoEEP_D230xx.h
  • MSR_TIME_VALUES : eoEEP_D230xx.h
  • MSR_UNIT_ACCUM_KWH : eoEEP_D230xx.h
  • MSR_UNIT_ACCUM_M3 : eoEEP_D230xx.h
  • MSR_UNIT_CURRENT_DM3_ACCUM_DM3 : eoEEP_D230xx.h
  • MSR_UNIT_CURRENT_M3_ACCUM_M3 : eoEEP_D230xx.h
  • MSR_UNIT_CURRENT_W_ACCUM_KWH : eoEEP_D230xx.h
  • MSR_UNIT_CURRENT_W_ACCUM_WH : eoEEP_D230xx.h
  • MSR_UNIT_DIGIT_COUNTER : eoEEP_D230xx.h
  • MSR_UNIT_NO_READING : eoEEP_D230xx.h
  • MSR_VALUE_1_ACCU : eoEEP_D230xx.h
  • MSR_VALUE_1_CURRENT : eoEEP_D230xx.h
  • MSR_VALUE_2_ACCU : eoEEP_D230xx.h
  • MSR_VALUE_2_CURRENT : eoEEP_D230xx.h
  • MSR_VALUE_DIGIT_COUNTER : eoEEP_D230xx.h
  • MSR_VALUE_DM3 : eoEEP_D230xx.h
  • MSR_VALUE_DM3H : eoEEP_D230xx.h
  • MSR_VALUE_KWH : eoEEP_D230xx.h
  • MSR_VALUE_M3 : eoEEP_D230xx.h
  • MSR_VALUE_M3H : eoEEP_D230xx.h
  • MSR_VALUE_SELECTION : eoEEP_D230xx.h
  • MSR_VALUE_UNITS : eoEEP_D230xx.h
  • MSR_VALUE_W : eoEEP_D230xx.h
  • MSR_VALUE_WH : eoEEP_D230xx.h
  • MSR_VALVE_NORM_CLOSED : eoEEP_D230xx.h
  • MSR_VALVE_NORM_OPEN : eoEEP_D230xx.h
  • MULTIPRESS_NOT : eoF6EEProfile.h
  • MULTIPRESS_YES : eoF6EEProfile.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- n -

  • NAME : eoChannelInfo.h
  • name_object_map : eoStorageManager.h
  • NEW_DEVICE : eoTeachInModule.h
  • NEW_DEVICE_AND_EPP : eoTeachInModule.h
  • NEW_RX : eoApiDef.h
  • NIGHT_TIME : eoEEP_D200xx.h
  • NO_CHANGE : eoEEP_D200xx.h
  • NO_END_POS_AVAILABLE : eoEEP_A511xx.h
  • NO_END_POS_REACHED : eoEEP_A511xx.h
  • NO_FAILURE_FLAG : eoEEP_A520xx.h
  • NO_POWER_FAILURE : eoEEP_A509xx.h
  • NO_RESPONSE_FROM_CONTROLLER : eoEEP_A520xx.h
  • NO_RX : eoApiDef.h
  • NO_SMOKE : eoEEP_D202xx.h
  • NO_TEACH_IN : eoTeachInModule.h
  • NO_VALVE : eoEEP_A520xx.h
  • NO_WATER : eoF6EEProfile.h
  • NORMAL_SIGNAL : eoEEP_A530xx.h
  • NORTH : eoEEP_A513xx.h
  • NOT_AVAILABLE : eoEEP_A511xx.h
  • NOT_IMPLEMENTED : eoApiDef.h
  • NOT_PRESENT : eoEEP_D200xx.h
  • NOT_RECOM : eoApiDef.h
  • NOT_SOLAR_POWERED : eoEEP_D210xx.h
  • NOT_SUPPORTED : eoApiDef.h
  • NOT_TEACHED_IN : eoEEP_A520xx.h
  • NS_BATTERY_100_875 : eoEEP_D204xx.h
  • NS_BATTERY_125_0 : eoEEP_D204xx.h
  • NS_BATTERY_25_125 : eoEEP_D204xx.h
  • NS_BATTERY_375_25 : eoEEP_D204xx.h
  • NS_BATTERY_50_375 : eoEEP_D204xx.h
  • NS_BATTERY_625_50 : eoEEP_D204xx.h
  • NS_BATTERY_75_625 : eoEEP_D204xx.h
  • NS_BATTERY_875_75 : eoEEP_D204xx.h
  • NS_BATTERY_AUTONOMY : eoEEP_D204xx.h
  • NULL : eoHalTypes.h
  • NUM_ENUMS_STRINGS : eoChannelEnums.h
  • NUM_FLAG_STRINGS : eoChannelEnums.h
  • NUM_GP_ENUMS_STRING : eoChannelEnums.h
  • NUM_SIGNAL_STRINGS : eoChannelEnums.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- o -

  • OCCUPANCY : eoEEP_A510xx.h
  • OCCUPANCY_LOCK : eoEEP_D210xx.h
  • OCCUPANCY_NO_CHANGE : eoEEP_D210xx.h
  • OCCUPANCY_PRESSED_OCCUPIED : eoEEP_D210xx.h
  • OCCUPANCY_PRESSED_UNOCCUPIED : eoEEP_D210xx.h
  • OCCUPIED : eoEEP_A511xx.h
  • OFF : eoEEP_A511xx.h
  • ON_OFF : eoEEP_A520xx.h
  • ONGOING_RX : eoApiDef.h
  • OP_MODE : eoEEP_D220xx.h
  • OP_MODE_CTRL : eoEEP_D250xx.h
  • OP_MODE_DISABLED : eoEEP_D220xx.h
  • OP_MODE_NO_CHANGE : eoEEP_D220xx.h
  • OP_MODE_STANDARD_COMPLIANT : eoEEP_D220xx.h
  • OP_NEXT : eoEEP_D250xx.h
  • OP_NO_ACTION : eoEEP_D250xx.h
  • OP_PREVIOUS : eoEEP_D250xx.h
  • OPEN_BLIND : eoEEP_A538xx.h
  • OPEN_FOR_TIME : eoEEP_A538xx.h
  • OPERATION_DENIED : eoApiDef.h
  • OR : eoSerialCommand.h
  • ORIENTATION_0 : eoEEP_A520xx.h
  • ORIENTATION_180 : eoEEP_A520xx.h
  • ORIENTATION_270 : eoEEP_A520xx.h
  • ORIENTATION_90 : eoEEP_A520xx.h
  • OTHER_DISABLEMENT : eoEEP_A520xx.h
  • OTHER_REASON : eoEEP_D240xx.h
  • OUT_OF_RANGE : eoApiDef.h
  • OUTDOOR_HEATER_STATUS : eoEEP_D250xx.h
  • OUTDOOR_TEMP : eoEEP_D250xx.h
  • OVER_CURRENT_SHUT : eoEEP_D201xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- p -

  • PACKET_COMMON_COMMAND : eoApiDef.h
  • PACKET_DEBUG : eoApiDef.h
  • PACKET_EVENT : eoApiDef.h
  • PACKET_PRODUCTION_COMMAND : eoApiDef.h
  • PACKET_RADIO : eoApiDef.h
  • PACKET_RADIO_ADVANCED : eoApiDef.h
  • PACKET_RADIO_MESSAGE : eoApiDef.h
  • PACKET_RADIO_SET : eoApiDef.h
  • PACKET_RADIO_SUB_TEL : eoApiDef.h
  • PACKET_REMOTE_MAN_COMMAND : eoApiDef.h
  • PACKET_RESPONSE : eoApiDef.h
  • PACKET_SMART_ACK_COMMAND : eoApiDef.h
  • PACKET_TYPE : eoApiDef.h
  • PERIOD_FRIDAY : eoEEP_D210xx.h
  • PERIOD_FRIDAY_MONDAY : eoEEP_D210xx.h
  • PERIOD_FRIDAY_SUNDAY : eoEEP_D210xx.h
  • PERIOD_MONDAY : eoEEP_D210xx.h
  • PERIOD_MONDAY_FRIDAY : eoEEP_D210xx.h
  • PERIOD_MONDAY_SUNDAY : eoEEP_D210xx.h
  • PERIOD_MONDAY_WEDNESDAY : eoEEP_D210xx.h
  • PERIOD_SATURDAY : eoEEP_D210xx.h
  • PERIOD_SATURDAY_SUNDAY : eoEEP_D210xx.h
  • PERIOD_SUNDAY : eoEEP_D210xx.h
  • PERIOD_THURSDAY : eoEEP_D210xx.h
  • PERIOD_THURSDAY_FRIDAY : eoEEP_D210xx.h
  • PERIOD_TUESDAY : eoEEP_D210xx.h
  • PERIOD_TUESDAY_THURSDAY : eoEEP_D210xx.h
  • PERIOD_WEDNESDAY : eoEEP_D210xx.h
  • PERIOD_WEDNESDAY_FRIDAY : eoEEP_D210xx.h
  • PILOTWIRE_ANTI_FREEZE : eoEEP_D201xx.h
  • PILOTWIRE_COMFORT : eoEEP_D201xx.h
  • PILOTWIRE_COMFORT_1 : eoEEP_D201xx.h
  • PILOTWIRE_COMFORT_2 : eoEEP_D201xx.h
  • PILOTWIRE_ECO : eoEEP_D201xx.h
  • PILOTWIRE_OFF : eoEEP_D201xx.h
  • PIR_LOCK : eoEEP_D210xx.h
  • PIR_LOCKED : eoEEP_D210xx.h
  • PIR_MOVEMENT : eoEEP_D210xx.h
  • PIR_NO_CHANGE : eoEEP_D210xx.h
  • PIR_NO_MOVEMENT : eoEEP_D210xx.h
  • PIR_STATUS : eoEEP_D210xx.h
  • PM1 : eoEEP_A509xx.h
  • PM10 : eoEEP_A509xx.h
  • PM2_5 : eoEEP_A509xx.h
  • PORT_ERROR : eoApiDef.h
  • POSITION_LOCATION_0 : eoEEP_A512xx.h
  • POSITION_LOCATION_1 : eoEEP_A512xx.h
  • POSITION_LOCATION_2 : eoEEP_A512xx.h
  • POSITION_LOCATION_3 : eoEEP_A512xx.h
  • POSITION_LOCATION_4 : eoEEP_A512xx.h
  • POSITION_LOCATION_5 : eoEEP_A512xx.h
  • POSITION_LOCATION_6 : eoEEP_A512xx.h
  • POSITION_LOCATION_7 : eoEEP_A512xx.h
  • POSITION_LOCATION_8 : eoEEP_A512xx.h
  • POSITION_LOCATION_9 : eoEEP_A512xx.h
  • POSITION_NOT_POSSESSED : eoEEP_A512xx.h
  • POSITION_POSSESSED : eoEEP_A512xx.h
  • POWER_FAILURE_DETECTED : eoEEP_A509xx.h
  • POWER_KW : eoEEP_D201xx.h
  • POWER_ONS : eoEEP_D206xx.h
  • POWER_W : eoEEP_D201xx.h
  • PRECOMFORT_TEMP_SETPOINT : eoEEP_D210xx.h
  • PRECOMFORT_TEMP_SETPOINT_VALIDITY : eoEEP_D210xx.h
  • PRESENCE : eoEEP_D200xx.h
  • PRESENT : eoEEP_D200xx.h
  • PREV_STATE : eoEEP_D201xx.h
  • PROTECTION_PLUS_ALARM : eoEEP_D206xx.h
  • PWR_FAILURE : eoEEP_D201xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- q -

  • QUERY : eoEEP_D201xx.h
  • QUERY_LUMINANCE : eoEEP_D202xx.h
  • QUERY_MSG : eoEEP_D205xx.h
  • QUERY_OCCUPANCY : eoEEP_D202xx.h
  • QUERY_SMOPKE : eoEEP_D202xx.h
  • QUERY_TEMP : eoEEP_D202xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- r -

  • R_NEXT_CHANNEL : eoRemoteManager.h
  • R_S_ADVANCED_LEARN : eoRemoteManager.h
  • R_S_SIMPLE_LEARN : eoRemoteManager.h
  • R_S_STOP_LEARN : eoRemoteManager.h
  • R_START_LEARN : eoRemoteManager.h
  • R_STOP_LEARN : eoRemoteManager.h
  • RADIO_12_HOURS_INTERVAL : eoEEP_D210xx.h
  • RADIO_24_HOURS_INTERVAL : eoEEP_D210xx.h
  • RADIO_3_HOURS_INTERVAL : eoEEP_D210xx.h
  • RADIO_CHOICE_1BS : eoApiDef.h
  • RADIO_CHOICE_4BS : eoApiDef.h
  • RADIO_CHOICE_ADT : eoApiDef.h
  • RADIO_CHOICE_GP_CHAINED_DATA : eoApiDef.h
  • RADIO_CHOICE_GP_CHAINED_TREQ : eoApiDef.h
  • RADIO_CHOICE_GP_CHAINED_TRES : eoApiDef.h
  • RADIO_CHOICE_GP_SELECT_DATA : eoApiDef.h
  • RADIO_CHOICE_GP_SINGLE_DATA : eoApiDef.h
  • RADIO_CHOICE_GP_SINGLE_TREQ : eoApiDef.h
  • RADIO_CHOICE_GP_SINGLE_TRES : eoApiDef.h
  • RADIO_CHOICE_HRC : eoApiDef.h
  • RADIO_CHOICE_MSC : eoApiDef.h
  • RADIO_CHOICE_NON_SEC : eoApiDef.h
  • RADIO_CHOICE_RECLAIM : eoApiDef.h
  • RADIO_CHOICE_RPS : eoApiDef.h
  • RADIO_CHOICE_SEC : eoApiDef.h
  • RADIO_CHOICE_SEC_ENCAPS : eoApiDef.h
  • RADIO_CHOICE_SEC_TI : eoApiDef.h
  • RADIO_CHOICE_SIGNAL : eoApiDef.h
  • RADIO_CHOICE_SM_LRN_ANS : eoApiDef.h
  • RADIO_CHOICE_SM_LRN_REQ : eoApiDef.h
  • RADIO_CHOICE_SYS : eoApiDef.h
  • RADIO_CHOICE_SYS_EX : eoApiDef.h
  • RADIO_CHOICE_UTE : eoApiDef.h
  • RADIO_CHOICE_VLD : eoApiDef.h
  • RADIO_COM_INTERVAL : eoEEP_D210xx.h
  • RADIO_NO_INTERVAL : eoEEP_D210xx.h
  • RAIN_NORAIN : eoEEP_A513xx.h
  • RAND_END_DELAY : eoEEP_A537xx.h
  • RAND_START_DELAY : eoEEP_A537xx.h
  • RCP_5_LEVEL_FANSPEED : eoEEP_D200xx.h
  • RCP_6_LEVEL_FANSPEED : eoEEP_D200xx.h
  • RCP_COMMANDS : eoEEP_D200xx.h
  • RCP_CONFIG_VALID : eoEEP_D200xx.h
  • RCP_COOLING : eoEEP_D200xx.h
  • RCP_DELTA_TEMP_GRAPHIC : eoEEP_D200xx.h
  • RCP_DELTA_TEMP_SETPOINT_C : eoEEP_D200xx.h
  • RCP_DELTA_TEMP_SETPOINT_F : eoEEP_D200xx.h
  • RCP_DEW_POINT : eoEEP_D200xx.h
  • RCP_DISPLAY_CONTENT : eoEEP_D200xx.h
  • RCP_DO_NOT_DISPLAY : eoEEP_D200xx.h
  • RCP_FAN_MANUAL : eoEEP_D200xx.h
  • RCP_FIRST_USER_ACTION : eoEEP_D200xx.h
  • RCP_HEATING : eoEEP_D200xx.h
  • RCP_INDEXS : eoEEP_D200xx.h
  • RCP_KEEP_ALIVE_TIME : eoEEP_D200xx.h
  • RCP_MEASUREMENT_RESULT : eoEEP_D200xx.h
  • RCP_MORE_DATA : eoEEP_D200xx.h
  • RCP_NO_DISPLAY : eoEEP_D200xx.h
  • RCP_NOMINAL_TEMPERATURE_C : eoEEP_D200xx.h
  • RCP_NOMINAL_TEMPERATURE_F : eoEEP_D200xx.h
  • RCP_PRESENCE : eoEEP_D200xx.h
  • RCP_REPEATED_USER_ACTION : eoEEP_D200xx.h
  • RCP_ROOM_TEMPERATURE_C : eoEEP_D200xx.h
  • RCP_ROOM_TEMPERATURE_F : eoEEP_D200xx.h
  • RCP_SENSOR_CONFIG : eoEEP_D200xx.h
  • RCP_SETPOINT_RANGE_LIMIT : eoEEP_D200xx.h
  • RCP_SETPOINT_STEPS : eoEEP_D200xx.h
  • RCP_SPEED_LEVEL_0 : eoEEP_D200xx.h
  • RCP_SPEED_LEVEL_1 : eoEEP_D200xx.h
  • RCP_SPEED_LEVEL_2 : eoEEP_D200xx.h
  • RCP_SPEED_LEVEL_3 : eoEEP_D200xx.h
  • RCP_TEMP_MEASUREMENT_TIMING : eoEEP_D200xx.h
  • RCP_TIME_24_HOURS : eoEEP_D200xx.h
  • RCP_TIME_AM_HOURS : eoEEP_D200xx.h
  • RCP_TIME_DAY_MONTH : eoEEP_D200xx.h
  • RCP_TIME_MONTH_DAY : eoEEP_D200xx.h
  • RCP_TIME_PM_HOURS : eoEEP_D200xx.h
  • RCP_USER_ACTION : eoEEP_D200xx.h
  • RCP_USER_NOTIFICATION : eoEEP_D200xx.h
  • REAL_TIME_CLOCK : eoEEP_A513xx.h
  • RECEIVE_FLAGS : eoGateway.h
  • RECENT_TEMP_SETPOINT : eoEEP_D210xx.h
  • RECOM_ADDR_OUT_OF_RANGE : eoReCom.h
  • RECOM_CHANGES : eoReCom.h
  • RECOM_CHANGES_APPLY : eoReCom.h
  • RECOM_CHANGES_NOT_APPLY : eoReCom.h
  • RECOM_CODE_DATA_SIZE_EXCEED : eoReCom.h
  • RECOM_DEFAULT_RESET : eoReCom.h
  • RECOM_EXIT_LEARN : eoReCom.h
  • RECOM_FILTER_DBM : eoReCom.h
  • RECOM_FILTER_DESTINATION_ID : eoReCom.h
  • RECOM_FILTER_RORG : eoReCom.h
  • RECOM_FILTER_SOURCE_ID : eoReCom.h
  • RECOM_FILTERED_REPEATER_ON : eoReCom.h
  • RECOM_INBOUND_TABLE : eoReCom.h
  • RECOM_LEARN_IN : eoReCom.h
  • RECOM_LEARN_MODE : eoReCom.h
  • RECOM_LEARN_OUT : eoReCom.h
  • RECOM_MSG_PART_NOT_RECEIVED : eoReCom.h
  • RECOM_MSG_PART_RECEIVED : eoReCom.h
  • RECOM_MSG_TIMEOUT : eoReCom.h
  • RECOM_MSG_TOO_LONG : eoReCom.h
  • RECOM_NO_CODE_SET : eoReCom.h
  • RECOM_NO_DEFAULT_RESET : eoReCom.h
  • RECOM_NOT_SEND : eoReCom.h
  • RECOM_NOT_SUPPORTED : eoReCom.h
  • RECOM_OK : eoReCom.h
  • RECOM_OUTBOUND_TABLE : eoReCom.h
  • RECOM_REPEATER_AND : eoReCom.h
  • RECOM_REPEATER_APPLY : eoReCom.h
  • RECOM_REPEATER_BLOCK : eoReCom.h
  • RECOM_REPEATER_DELETE_ALL : eoReCom.h
  • RECOM_REPEATER_DELETE_FILTER : eoReCom.h
  • RECOM_REPEATER_FILTER : eoReCom.h
  • RECOM_REPEATER_FILTER_CONTROL : eoReCom.h
  • RECOM_REPEATER_FILTER_TYPE : eoReCom.h
  • RECOM_REPEATER_FUNC : eoReCom.h
  • RECOM_REPEATER_LEVEL : eoReCom.h
  • RECOM_REPEATER_LEVEL_1 : eoReCom.h
  • RECOM_REPEATER_LEVEL_2 : eoReCom.h
  • RECOM_REPEATER_OFF : eoReCom.h
  • RECOM_REPEATER_ON : eoReCom.h
  • RECOM_REPEATER_OR : eoReCom.h
  • RECOM_RESET : eoReCom.h
  • RECOM_RPC_FAIL : eoReCom.h
  • RECOM_SUPPORT : eoReCom.h
  • RECOM_SUPPORTED : eoReCom.h
  • RECOM_TABLE_DIR : eoReCom.h
  • RECOM_WRONG_DATA : eoReCom.h
  • RECOM_WRONG_DATA_SIZE : eoReCom.h
  • RECOM_WRONG_EEP : eoReCom.h
  • RECOM_WRONG_ID : eoReCom.h
  • RECOM_WRONG_MANUFACTURER_ID : eoReCom.h
  • RECOM_WRONG_UNLOCK_CODE : eoReCom.h
  • RECV_DEVICE_ADDED : eoGateway.h
  • RECV_ERROR : eoGateway.h
  • RECV_MESSAGE : eoGateway.h
  • RECV_PACKET : eoGateway.h
  • RECV_PROFILE : eoGateway.h
  • RECV_REMAN : eoGateway.h
  • RECV_SECTEACHIN : eoGateway.h
  • RECV_TEACHIN : eoGateway.h
  • RECV_TELEGRAM : eoGateway.h
  • RECV_TELEGRAM_SEC : eoGateway.h
  • RELHUM_CONTROL : eoEEP_D220xx.h
  • RELHUM_THRESHOLD : eoEEP_D220xx.h
  • RELHUM_VALIDITY : eoEEP_D210xx.h
  • REMOTE_TYPE : eoRemoteManager.h
  • REPLY_MSG : eoEEP_D205xx.h
  • REPORT_MEASUREMENT : eoEEP_D201xx.h
  • REPOS_DIRECT_POS_ANG : eoEEP_D205xx.h
  • REPOS_DOWN_POS_ANG : eoEEP_D205xx.h
  • REPOS_UP_POS_ANG : eoEEP_D205xx.h
  • REQUESTED_MSG_TYPE : eoEEP_D250xx.h
  • RESET_MEASUREMENT : eoEEP_D201xx.h
  • RESET_OVER_CURRENT : eoEEP_D201xx.h
  • RESPONSE_MODE : eoEEP_D240xx.h
  • ROOM_CONTROL_BUILDING_PROTECT : eoEEP_D210xx.h
  • ROOM_CONTROL_COMFORT : eoEEP_D210xx.h
  • ROOM_CONTROL_ECONOMY : eoEEP_D210xx.h
  • ROOM_CONTROL_MSG : eoEEP_D210xx.h
  • ROOM_CONTROL_PRECOMFORT : eoEEP_D210xx.h
  • ROOM_CONTROL_REQUEST : eoEEP_D210xx.h
  • ROOM_SIZE_100_125 : eoEEP_D220xx.h
  • ROOM_SIZE_125_150 : eoEEP_D220xx.h
  • ROOM_SIZE_150_175 : eoEEP_D220xx.h
  • ROOM_SIZE_175_200 : eoEEP_D220xx.h
  • ROOM_SIZE_200_225 : eoEEP_D220xx.h
  • ROOM_SIZE_225_250 : eoEEP_D220xx.h
  • ROOM_SIZE_25 : eoEEP_D220xx.h
  • ROOM_SIZE_250_275 : eoEEP_D220xx.h
  • ROOM_SIZE_25_50 : eoEEP_D220xx.h
  • ROOM_SIZE_275_300 : eoEEP_D220xx.h
  • ROOM_SIZE_300_325 : eoEEP_D220xx.h
  • ROOM_SIZE_325_350 : eoEEP_D220xx.h
  • ROOM_SIZE_350 : eoEEP_D220xx.h
  • ROOM_SIZE_50_75 : eoEEP_D220xx.h
  • ROOM_SIZE_75_100 : eoEEP_D220xx.h
  • ROOM_SIZE_NO_CHANGE : eoEEP_D220xx.h
  • ROOM_SIZE_REF_DEFAULT : eoEEP_D220xx.h
  • ROOM_SIZE_REF_NO_CHANGE : eoEEP_D220xx.h
  • ROOM_SIZE_REF_NOT_USED : eoEEP_D220xx.h
  • ROOM_SIZE_REF_USED : eoEEP_D220xx.h
  • ROOM_SIZE_REFERENCE : eoEEP_D220xx.h
  • ROOM_TEMP : eoEEP_D250xx.h
  • ROOM_TEMP_CTRL : eoEEP_D250xx.h
  • ROP_1F_BUTTONS : eoEEP_A510xx.h
  • ROP_AUTOMATIC_CONTROL : eoEEP_A510xx.h
  • ROP_FROST_PROTECTION : eoEEP_A510xx.h
  • ROP_NO_USER_ACTIVITY : eoEEP_A510xx.h
  • ROP_ROOM_TEMP_DEFINED : eoEEP_A510xx.h
  • ROP_SET_POINT_MODE : eoEEP_A510xx.h
  • ROP_USER_ACTIVITY : eoEEP_A510xx.h
  • ROP_USER_INTERACTION : eoEEP_A510xx.h
  • RORG_1BS : eoApiDef.h
  • RORG_4BS : eoApiDef.h
  • RORG_ADT : eoApiDef.h
  • RORG_CDM : eoApiDef.h
  • RORG_HRC : eoApiDef.h
  • RORG_MSC : eoApiDef.h
  • RORG_RECLAIM : eoApiDef.h
  • RORG_RPS : eoApiDef.h
  • RORG_SEC : eoApiDef.h
  • RORG_SEC_ENCAPS : eoApiDef.h
  • RORG_SEC_TI : eoApiDef.h
  • RORG_SECD : eoApiDef.h
  • RORG_SIGNAL : eoApiDef.h
  • RORG_SM_LRN_ANS : eoApiDef.h
  • RORG_SM_LRN_REQ : eoApiDef.h
  • RORG_SYS : eoApiDef.h
  • RORG_SYS_EX : eoApiDef.h
  • RORG_TYPE : eoApiDef.h
  • RORG_UTE : eoApiDef.h
  • RORG_VLD : eoApiDef.h
  • RUN_INTI_SEQ : eoEEP_A520xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- s -

  • S_ACCEL : eoChannelEnums.h
  • S_ACCEL_ABS : eoChannelEnums.h
  • S_ACCEL_REL : eoChannelEnums.h
  • S_AMPER_PER_HOUR : eoChannelEnums.h
  • S_AMPER_PER_HOUR_ABS : eoChannelEnums.h
  • S_AMPER_PER_HOUR_REL : eoChannelEnums.h
  • S_ANGLE : eoChannelEnums.h
  • S_ANGLE_ABS : eoChannelEnums.h
  • S_ANGLE_REL : eoChannelEnums.h
  • S_ANGVD : eoChannelEnums.h
  • S_ANGVD_ABS : eoChannelEnums.h
  • S_ANGVD_REL : eoChannelEnums.h
  • S_AREA : eoChannelEnums.h
  • S_AREA_ABS : eoChannelEnums.h
  • S_AREA_REL : eoChannelEnums.h
  • S_CONC : eoChannelEnums.h
  • S_CONC_ABS : eoChannelEnums.h
  • S_CONC_REL : eoChannelEnums.h
  • S_COUNTER : eoChannelEnums.h
  • S_COUNTER_ABS : eoChannelEnums.h
  • S_COUNTER_REL : eoChannelEnums.h
  • S_CURRENT : eoChannelEnums.h
  • S_CURRENT_ABS : eoChannelEnums.h
  • S_CURRENT_REL : eoChannelEnums.h
  • S_DIMMING : eoChannelEnums.h
  • S_DIMMING_ABS : eoChannelEnums.h
  • S_DIMMING_REL : eoChannelEnums.h
  • S_DISTANCE : eoChannelEnums.h
  • S_DISTANCE_ABS : eoChannelEnums.h
  • S_DISTANCE_REL : eoChannelEnums.h
  • S_ELECFSTR : eoChannelEnums.h
  • S_ELECFSTR_ABS : eoChannelEnums.h
  • S_ELECFSTR_REL : eoChannelEnums.h
  • S_ENERGY : eoChannelEnums.h
  • S_ENERGY_ABS : eoChannelEnums.h
  • S_ENERGY_REL : eoChannelEnums.h
  • S_ERROR_CODE : eoChannelEnums.h
  • S_ERROR_CODE_ABS : eoChannelEnums.h
  • S_ERROR_CODE_REL : eoChannelEnums.h
  • S_FORCE : eoChannelEnums.h
  • S_FORCE_ABS : eoChannelEnums.h
  • S_FORCE_REL : eoChannelEnums.h
  • S_FREQ : eoChannelEnums.h
  • S_FREQ_ABS : eoChannelEnums.h
  • S_FREQ_REL : eoChannelEnums.h
  • S_HEATFLUX : eoChannelEnums.h
  • S_HEATFLUX_ABS : eoChannelEnums.h
  • S_HEATFLUX_REL : eoChannelEnums.h
  • S_IMPULSE : eoChannelEnums.h
  • S_IMPULSE_ABS : eoChannelEnums.h
  • S_IMPULSE_REL : eoChannelEnums.h
  • S_LUMINANCE : eoChannelEnums.h
  • S_LUMINANCE_ABS : eoChannelEnums.h
  • S_LUMINANCE_REL : eoChannelEnums.h
  • S_MAGNETICF : eoChannelEnums.h
  • S_MAGNETICF_ABS : eoChannelEnums.h
  • S_MAGNETICF_REL : eoChannelEnums.h
  • S_MASS : eoChannelEnums.h
  • S_MASS_ABS : eoChannelEnums.h
  • S_MASS_REL : eoChannelEnums.h
  • S_MASSDENS : eoChannelEnums.h
  • S_MASSDENS_ABS : eoChannelEnums.h
  • S_MASSDENS_REL : eoChannelEnums.h
  • S_MASSFLOW : eoChannelEnums.h
  • S_MASSFLOW_ABS : eoChannelEnums.h
  • S_MASSFLOW_REL : eoChannelEnums.h
  • S_PARTICLES : eoChannelEnums.h
  • S_PARTICLES_ABS : eoChannelEnums.h
  • S_PARTICLES_REL : eoChannelEnums.h
  • S_PERCENTAGE : eoChannelEnums.h
  • S_PERCENTAGE_ABS : eoChannelEnums.h
  • S_PERCENTAGE_REL : eoChannelEnums.h
  • S_POWER : eoChannelEnums.h
  • S_POWER_ABS : eoChannelEnums.h
  • S_POWER_REL : eoChannelEnums.h
  • S_PRESSURE : eoChannelEnums.h
  • S_PRESSURE_ABS : eoChannelEnums.h
  • S_PRESSURE_REL : eoChannelEnums.h
  • S_RADON_ACTIVITY : eoChannelEnums.h
  • S_RADON_ACTIVITY_ABS : eoChannelEnums.h
  • S_RADON_ACTIVITY_REL : eoChannelEnums.h
  • S_RELHUM : eoChannelEnums.h
  • S_RELHUM_ABS : eoChannelEnums.h
  • S_RELHUM_REL : eoChannelEnums.h
  • S_RES : eoChannelEnums.h
  • S_RESIST : eoChannelEnums.h
  • S_RESIST_ABS : eoChannelEnums.h
  • S_RESIST_REL : eoChannelEnums.h
  • S_RGB : eoChannelEnums.h
  • S_RGB_ABS : eoChannelEnums.h
  • S_RGB_REL : eoChannelEnums.h
  • S_ROTATION_PER_MIN : eoChannelEnums.h
  • S_ROTATION_PER_MIN_ABS : eoChannelEnums.h
  • S_ROTATION_PER_MIN_REL : eoChannelEnums.h
  • S_SETPOINT : eoChannelEnums.h
  • S_SETPOINT_ABS : eoChannelEnums.h
  • S_SETPOINT_REL : eoChannelEnums.h
  • S_SOLAR_RAD : eoChannelEnums.h
  • S_SOLAR_RAD_ABS : eoChannelEnums.h
  • S_SOLAR_RAD_REL : eoChannelEnums.h
  • S_TEMP : eoChannelEnums.h
  • S_TEMP_ABS : eoChannelEnums.h
  • S_TEMP_REL : eoChannelEnums.h
  • S_TIME : eoChannelEnums.h
  • S_TIME_ABS : eoChannelEnums.h
  • S_TIME_REL : eoChannelEnums.h
  • S_TORQUE : eoChannelEnums.h
  • S_TORQUE_ABS : eoChannelEnums.h
  • S_TORQUE_REL : eoChannelEnums.h
  • S_VALUE : eoChannelEnums.h
  • S_VALUE_ABS : eoChannelEnums.h
  • S_VALUE_REL : eoChannelEnums.h
  • S_VELOCITY : eoChannelEnums.h
  • S_VELOCITY_ABS : eoChannelEnums.h
  • S_VELOCITY_REL : eoChannelEnums.h
  • S_VOLFLOW : eoChannelEnums.h
  • S_VOLFLOW_ABS : eoChannelEnums.h
  • S_VOLFLOW_REL : eoChannelEnums.h
  • S_VOLTAGE : eoChannelEnums.h
  • S_VOLTAGE_ABS : eoChannelEnums.h
  • S_VOLTAGE_REL : eoChannelEnums.h
  • S_VOLUME : eoChannelEnums.h
  • S_VOLUME_ABS : eoChannelEnums.h
  • S_VOLUME_REL : eoChannelEnums.h
  • SA_CC_LEARNIN : eoSerialCommand.h
  • SA_CC_LEARNOUT : eoSerialCommand.h
  • SA_COMMAND_TYPE : eoSerialCommand.h
  • SA_CONFIRM_CODE : eoSerialCommand.h
  • SA_CONFIRM_LEARN : eoSerialCommand.h
  • SA_CONTROLLER_FULL : eoSerialCommand.h
  • SA_DUTYCYCLE_LIMIT : eoSerialCommand.h
  • SA_EEP_NOT_ACCEPTED : eoSerialCommand.h
  • SA_EL_ADVANCE : eoSerialCommand.h
  • SA_EL_ADVANCE_REP : eoSerialCommand.h
  • SA_EL_SIMPLE : eoSerialCommand.h
  • SA_EVENT_TYPE : eoSerialCommand.h
  • SA_EXTENDED_LEARNMODE : eoSerialCommand.h
  • SA_LEARN_ACK : eoSerialCommand.h
  • SA_LEARN_IN : eoSerialCommand.h
  • SA_LEARN_OUT : eoSerialCommand.h
  • SA_NOT_SUPPORTED : eoSerialCommand.h
  • SA_PM_FULL : eoSerialCommand.h
  • SA_RD_LEARNEDCLIENTS : eoSerialCommand.h
  • SA_RD_LEARNMODE : eoSerialCommand.h
  • SA_READY : eoSerialCommand.h
  • SA_RECLAIM_DATA_LENGTH : eoConverter.h
  • SA_RECLAIM_NOT_SUCCESSFUL : eoSerialCommand.h
  • SA_RSSI_NOT_GOOD : eoSerialCommand.h
  • SA_WR_CLIENTLEARNRQ : eoSerialCommand.h
  • SA_WR_LEARNCONFIRM : eoSerialCommand.h
  • SA_WR_LEARNMODE : eoSerialCommand.h
  • SA_WR_POSTMASTER : eoSerialCommand.h
  • SA_WR_RECLAIMS : eoSerialCommand.h
  • SA_WR_RESET : eoSerialCommand.h
  • SAFTEY_MODE : eoEEP_D250xx.h
  • SATURDAY : eoEEP_A513xx.h
  • SEC_10 : eoEEP_A520xx.h
  • SEC_1020 : eoEEP_A520xx.h
  • SEC_1050 : eoEEP_A520xx.h
  • SEC_1080 : eoEEP_A520xx.h
  • SEC_1110 : eoEEP_A520xx.h
  • SEC_1140 : eoEEP_A520xx.h
  • SEC_1170 : eoEEP_A520xx.h
  • SEC_120 : eoEEP_A520xx.h
  • SEC_1200 : eoEEP_A520xx.h
  • SEC_1230 : eoEEP_A520xx.h
  • SEC_1260 : eoEEP_A520xx.h
  • SEC_1290 : eoEEP_A520xx.h
  • SEC_1320 : eoEEP_A520xx.h
  • SEC_1350 : eoEEP_A520xx.h
  • SEC_1380 : eoEEP_A520xx.h
  • SEC_1410 : eoEEP_A520xx.h
  • SEC_1440 : eoEEP_A520xx.h
  • SEC_1470 : eoEEP_A520xx.h
  • SEC_150 : eoEEP_A520xx.h
  • SEC_1500 : eoEEP_A520xx.h
  • SEC_180 : eoEEP_A520xx.h
  • SEC_210 : eoEEP_A520xx.h
  • SEC_240 : eoEEP_A520xx.h
  • SEC_270 : eoEEP_A520xx.h
  • SEC_300 : eoEEP_A520xx.h
  • SEC_330 : eoEEP_A520xx.h
  • SEC_360 : eoEEP_A520xx.h
  • SEC_390 : eoEEP_A520xx.h
  • SEC_420 : eoEEP_A520xx.h
  • SEC_450 : eoEEP_A520xx.h
  • SEC_480 : eoEEP_A520xx.h
  • SEC_510 : eoEEP_A520xx.h
  • SEC_540 : eoEEP_A520xx.h
  • SEC_570 : eoEEP_A520xx.h
  • SEC_60 : eoEEP_A520xx.h
  • SEC_600 : eoEEP_A520xx.h
  • SEC_630 : eoEEP_A520xx.h
  • SEC_660 : eoEEP_A520xx.h
  • SEC_690 : eoEEP_A520xx.h
  • SEC_720 : eoEEP_A520xx.h
  • SEC_750 : eoEEP_A520xx.h
  • SEC_780 : eoEEP_A520xx.h
  • SEC_810 : eoEEP_A520xx.h
  • SEC_840 : eoEEP_A520xx.h
  • SEC_870 : eoEEP_A520xx.h
  • SEC_90 : eoEEP_A520xx.h
  • SEC_900 : eoEEP_A520xx.h
  • SEC_930 : eoEEP_A520xx.h
  • SEC_960 : eoEEP_A520xx.h
  • SEC_990 : eoEEP_A520xx.h
  • SECOND_TEACH_IN : eoTeachInModule.h
  • SECURITY_TEACH_IN : eoTeachInModule.h
  • SELECT_FUNCTION : eoEEP_A520xx.h
  • SENSOR_INTERVAL : eoEEP_D206xx.h
  • SENSOR_MEASUREMENT : eoEEP_D202xx.h
  • SENSOR_POSITION_ENUM : eoEEP_A512xx.h
  • SENSOR_POSITION_INDEX_ENUM : eoEEP_A512xx.h
  • SENSOR_QUERY : eoEEP_D202xx.h
  • SENSOR_TEST_TRIGGER : eoEEP_D202xx.h
  • SER_HEADER_NR_BYTES : eoPacketStream.h
  • SER_INTERBYTE_TIME_OUT : eoPacketStream.h
  • SER_SYNCH_CODE : eoPacketStream.h
  • SERVICE_INFO : eoEEP_D220xx.h
  • SERVICE_ON : eoEEP_A520xx.h
  • SET_ANGLE : eoEEP_A538xx.h
  • SET_LOGIC_POS : eoEEP_A538xx.h
  • SET_MIN_MAX : eoEEP_A538xx.h
  • SET_PARAM_MSG : eoEEP_D205xx.h
  • SET_POINT_INVERSE : eoEEP_A520xx.h
  • SET_POINT_SELECTION : eoEEP_A520xx.h
  • SET_ROT_DURATION : eoEEP_D205xx.h
  • SET_RUNTIME_PARAM : eoEEP_A538xx.h
  • SET_SLAT_ANGLE : eoEEP_A538xx.h
  • SET_VER_DURATION : eoEEP_D205xx.h
  • signalStrings : eoChannelEnums.h
  • SLF_DATA_ENC_AES128 : eoSecureInfo.h
  • SLF_DATA_ENC_OFF : eoSecureInfo.h
  • SLF_DATA_ENC_VAES128 : eoSecureInfo.h
  • SLF_MAC_3BYTE : eoSecureInfo.h
  • SLF_MAC_4BYTE : eoSecureInfo.h
  • SLF_MAC_OFF : eoSecureInfo.h
  • SLF_RLC_ALGO_16BIT : eoSecureInfo.h
  • SLF_RLC_ALGO_24BIT : eoSecureInfo.h
  • SLF_RLC_ALGO_OFF : eoSecureInfo.h
  • SLF_RLC_TX_OFF : eoSecureInfo.h
  • SLF_RLC_TX_ON : eoSecureInfo.h
  • SMARTACK_CONFIRM_CODE : eoSerialCommand.h
  • SMOKE_BOTH : eoEEP_D202xx.h
  • SMOKE_IONIZATION : eoEEP_D202xx.h
  • SMOKE_OPTICAL : eoEEP_D202xx.h
  • SOLAR_POWERED : eoEEP_D210xx.h
  • SOLAR_POWERED_STATUS : eoEEP_D210xx.h
  • SOURCE_ID : eoSerialCommand.h
  • SOUTH : eoEEP_A513xx.h
  • SP_ABS : eoChannelEnums.h
  • SP_REL : eoChannelEnums.h
  • SPEED_0 : eoA5EEProfile.h
  • SPEED_1 : eoA5EEProfile.h
  • SPEED_2 : eoA5EEProfile.h
  • SPEED_3 : eoA5EEProfile.h
  • SPEED_4 : eoA5EEProfile.h
  • SPEED_5 : eoA5EEProfile.h
  • SPEED_AUTO : eoA5EEProfile.h
  • SPEED_LEVEL_0 : eoEEP_D200xx.h
  • SPEED_LEVEL_1 : eoEEP_D200xx.h
  • SPEED_LEVEL_2 : eoEEP_D200xx.h
  • SPEED_LEVEL_3 : eoEEP_D200xx.h
  • SPEED_LEVEL_AUTO : eoEEP_D200xx.h
  • SPEED_OFF : eoA5EEProfile.h
  • STAGE_0 : eoA5EEProfile.h
  • STAGE_0_AUTO : eoEEP_A511xx.h
  • STAGE_0_MANUAL : eoEEP_A511xx.h
  • STAGE_1 : eoA5EEProfile.h
  • STAGE_1_AUTO : eoEEP_A511xx.h
  • STAGE_1_MANUAL : eoEEP_A511xx.h
  • STAGE_2 : eoA5EEProfile.h
  • STAGE_2_AUTO : eoEEP_A511xx.h
  • STAGE_2_MANUAL : eoEEP_A511xx.h
  • STAGE_3 : eoA5EEProfile.h
  • STAGE_3_AUTO : eoEEP_A511xx.h
  • STAGE_3_MANUAL : eoEEP_A511xx.h
  • STAGE_AUTO : eoA5EEProfile.h
  • STANDBY : eoEEP_A511xx.h
  • START_TIME_HOUR : eoEEP_D210xx.h
  • START_TIME_MINUTE : eoEEP_D210xx.h
  • START_TRANSMISSION_CONFIG_SETTINGS : eoEEP_D206xx.h
  • START_TRANSMISSION_LOG_DATA : eoEEP_D206xx.h
  • STATE_I : eoF6EEProfile.h
  • STATE_IO : eoF6EEProfile.h
  • STATE_NP : eoF6EEProfile.h
  • STATE_O : eoF6EEProfile.h
  • STATE_OFF : eoEEP_D201xx.h
  • STATE_ON : eoEEP_D201xx.h
  • STATUS_NO_CHANGE : eoEEP_A520xx.h
  • STATUS_REASON : eoEEP_D240xx.h
  • STATUS_REQUEST : eoEEP_A520xx.h
  • STATUS_REQUESTED : eoEEP_A520xx.h
  • STATUS_WAKE : eoEEP_A530xx.h
  • STOP_BLIND : eoEEP_A538xx.h
  • STOP_MSG : eoEEP_D205xx.h
  • SUMMER_BIT : eoEEP_A520xx.h
  • SUN_EAST : eoEEP_A513xx.h
  • SUN_SOUTH : eoEEP_A513xx.h
  • SUN_WEST : eoEEP_A513xx.h
  • SUNDAY : eoEEP_A513xx.h
  • SUPPLY_AIR_POS : eoEEP_D250xx.h
  • SUPPLY_FAN_RATE : eoEEP_D250xx.h
  • SUPPLY_FAN_SPEED : eoEEP_D250xx.h
  • SUPPLY_HEATER_STATUS : eoEEP_D250xx.h
  • SUPPLY_TEMP : eoEEP_D250xx.h
  • SUPPORTED_FILTERS : eoIFilter.h
  • SW_VERSION : eoEEP_D250xx.h
  • SWITCH_TO_NEW : eoEEP_D201xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- t -

  • T_DATA : eoChannelEnums.h
  • T_ENUM : eoChannelEnums.h
  • T_FLAG : eoChannelEnums.h
  • TAUGHT_IN_DEVICES : eoEEP_D201xx.h
  • teach_id_map : eoTeachInModule.h
  • TEACH_IN_ACCEPTED : eoTeachInModule.h
  • TEACH_IN_ERROR : eoEEP_A520xx.h
  • TEACH_INFO_BIDIR : eoSecureInfo.h
  • TEACH_INFO_PSK : eoSecureInfo.h
  • TEACH_INFO_PTM : eoSecureInfo.h
  • TEACH_INFO_PTM_ROCKERA : eoSecureInfo.h
  • TEACH_INFO_PTM_ROCKERB : eoSecureInfo.h
  • TEACH_INFO_UNIDIR : eoSecureInfo.h
  • TEACH_OUT_ACCEPTED : eoTeachInModule.h
  • TEACH_RETURN : eoTeachInModule.h
  • TEL_REPETITION_FEEDBACK : eoEEP_D210xx.h
  • TEMP_DOWN : eoEEP_D200xx.h
  • TEMP_LEVEL : eoEEP_D220xx.h
  • TEMP_LEVEL_HIGH : eoEEP_D220xx.h
  • TEMP_LEVEL_LOW : eoEEP_D220xx.h
  • TEMP_LEVEL_NO_CHANGE : eoEEP_D220xx.h
  • TEMP_LEVEL_NORMAL : eoEEP_D220xx.h
  • TEMP_LOCK : eoEEP_D210xx.h
  • TEMP_SCALE : eoEEP_D210xx.h
  • TEMP_SCALE_CELSIUS : eoEEP_D210xx.h
  • TEMP_SCALE_DEFAULT : eoEEP_D210xx.h
  • TEMP_SCALE_FAHRENHEIT : eoEEP_D210xx.h
  • TEMP_SCALE_NO_CHANGE : eoEEP_D210xx.h
  • TEMP_SELECTION : eoEEP_A520xx.h
  • TEMP_SETPOINT_LOCK : eoEEP_D210xx.h
  • TEMP_SETPOINT_SELECT : eoEEP_A520xx.h
  • TEMP_SETPOINT_VALIDITY : eoEEP_D210xx.h
  • TEMP_UP : eoEEP_D200xx.h
  • TEMP_VALIDITY : eoEEP_D210xx.h
  • TEMPERATURE_FAIL : eoEEP_A520xx.h
  • THURSDAY : eoEEP_A513xx.h
  • TIME_AM : eoEEP_A513xx.h
  • TIME_CURRENT_DAY : eoEEP_D210xx.h
  • TIME_CURRENT_HOUR : eoEEP_D210xx.h
  • TIME_CURRENT_MINUTE : eoEEP_D210xx.h
  • TIME_CURRENT_MONTH : eoEEP_D210xx.h
  • TIME_CURRENT_YEAR : eoEEP_D210xx.h
  • TIME_DAY : eoEEP_A513xx.h
  • TIME_FORMAT : eoEEP_A513xx.h
  • TIME_HOUR : eoEEP_A513xx.h
  • TIME_MINUTE : eoEEP_A513xx.h
  • TIME_MONTH : eoEEP_A513xx.h
  • TIME_NOTATION : eoEEP_D210xx.h
  • TIME_NOTATION_12_HOURS : eoEEP_D210xx.h
  • TIME_NOTATION_24_HOURS : eoEEP_D210xx.h
  • TIME_NOTATION_DEFAULT : eoEEP_D210xx.h
  • TIME_NOTATION_NO_CHANGE : eoEEP_D210xx.h
  • TIME_OUT : eoApiDef.h
  • TIME_PM : eoEEP_A513xx.h
  • TIME_PROG_DELETE : eoEEP_D210xx.h
  • TIME_PROG_DELETION : eoEEP_D210xx.h
  • TIME_PROG_LOCK : eoEEP_D210xx.h
  • TIME_PROG_MSG : eoEEP_D210xx.h
  • TIME_PROG_NO_DELETE : eoEEP_D210xx.h
  • TIME_PROG_REQUEST : eoEEP_D210xx.h
  • TIME_SECOND : eoEEP_A513xx.h
  • TIME_SOURCE : eoEEP_A513xx.h
  • TIME_YEAR : eoEEP_A513xx.h
  • TIMER_OP_CTRL : eoEEP_D250xx.h
  • TIMER_OP_CTRL_STATUS : eoEEP_D250xx.h
  • TUESDAY : eoEEP_A513xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- u -

  • UNIT : eoChannelInfo.h
  • UNLOCK_LOCAL_OP : eoEEP_A538xx.h
  • UNLOCKED : eoEEP_D210xx.h
  • UNOCCUPANCY : eoEEP_A510xx.h
  • UNOCCUPIED : eoEEP_A511xx.h
  • USER_CMD : eoApiDef.h
  • USER_INDICATION : eoEEP_D201xx.h
  • USV_H : eoEEP_A509xx.h
  • UTE_DIRECTION : eoTeachInModule.h
  • UTE_DIRECTION_BIDIRECTIONAL : eoTeachInModule.h
  • UTE_DIRECTION_UNIDIRECTIONAL : eoTeachInModule.h
  • UTE_RESPONSE : eoTeachInModule.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- v -

  • V_1_10 : eoEEP_A538xx.h
  • VACATION_INTERVAL : eoEEP_D206xx.h
  • VACATION_MODE : eoEEP_D206xx.h
  • VALIDITY_NO_CHANGE : eoEEP_D210xx.h
  • VALIDITY_VALID_VALUE : eoEEP_D210xx.h
  • VALUE_TYPE : eoChannelEnums.h
  • VALVE_CLOSED : eoEEP_A520xx.h
  • VALVE_DIRECTION : eoEEP_D2A0xx.h
  • VALVE_OPEN : eoEEP_A520xx.h
  • VALVE_REQUEST : eoEEP_D2A0xx.h
  • VALVE_REQUEST_CLOSE : eoEEP_D2A0xx.h
  • VALVE_REQUEST_CLOSE_2 : eoEEP_D2A0xx.h
  • VALVE_REQUEST_FEEDBACK : eoEEP_D2A0xx.h
  • VALVE_REQUEST_OPEN : eoEEP_D2A0xx.h
  • VALVE_STATUS : eoEEP_D2A0xx.h
  • VALVE_STATUS_CLOSED : eoEEP_D2A0xx.h
  • VALVE_STATUS_OPENED : eoEEP_D2A0xx.h
  • VALVE_TO_CONTROLLER : eoEEP_D2A0xx.h
  • VANE_AUTO : eoEEP_A520xx.h
  • VANE_BOTH_SWING : eoEEP_A520xx.h
  • VANE_HORIZ_SWING : eoEEP_A520xx.h
  • VANE_HORIZONTAL : eoEEP_A520xx.h
  • VANE_POS_2 : eoEEP_A520xx.h
  • VANE_POS_3 : eoEEP_A520xx.h
  • VANE_POS_4 : eoEEP_A520xx.h
  • VANE_STOP_SWING : eoEEP_A520xx.h
  • VANE_SWING : eoEEP_A520xx.h
  • VANE_VERT_SWING : eoEEP_A520xx.h
  • VANE_VERTICAL : eoEEP_A520xx.h
  • VENTILATION_BASIC : eoEEP_D250xx.h
  • VENTILATION_BASIC_STATUS : eoEEP_D250xx.h
  • VENTILATION_CONTROL : eoEEP_D250xx.h
  • VENTILATION_EXTENDED : eoEEP_D250xx.h
  • VENTILATION_EXTENDED_STATUS : eoEEP_D250xx.h
  • VENTILATION_REQUEST : eoEEP_D250xx.h
  • VLD_COMMANDS : eoEEP_D202xx.h
  • VLD_DEFAULT_STATE : eoEEP_D201xx.h
  • VLD_DIM_VALUE : eoEEP_D201xx.h
  • VLD_ERROR_LEVEL : eoEEP_D201xx.h
  • VLD_FC_INDEXS : eoEEP_D220xx.h
  • VLD_FC_OP_MODE : eoEEP_D220xx.h
  • VLD_FC_RELHUM_CONTROL : eoEEP_D220xx.h
  • VLD_FC_ROOM_SIZE : eoEEP_D220xx.h
  • VLD_FC_ROOM_SIZE_REF : eoEEP_D220xx.h
  • VLD_FC_SERVICE_INFORMATION : eoEEP_D220xx.h
  • VLD_FC_STAGE : eoEEP_D220xx.h
  • VLD_FC_TEMP_LEVEL : eoEEP_D220xx.h
  • VLD_INDEXS : eoEEP_D202xx.h
  • VLD_IO_CHANNEL : eoEEP_D201xx.h
  • VLD_MAX_TIME : eoEEP_D202xx.h
  • VLD_MIN_TIME : eoEEP_D202xx.h
  • VLD_ON_OFF_INDEX : eoEEP_D201xx.h
  • VLD_PILOTWIRE_MODE : eoEEP_D201xx.h
  • VLD_QUERY_STATUS : eoEEP_D202xx.h
  • VLD_REPORT_MEASUREMENT : eoEEP_D202xx.h
  • VLD_SELF_TEST : eoEEP_D202xx.h
  • VLD_SMOKE_DETECTION : eoEEP_D202xx.h
  • VLD_TIME_INDEX : eoEEP_D201xx.h
  • VLD_TRIGGER_ALARM : eoEEP_D202xx.h
  • VLD_UNITS : eoEEP_D201xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented file members with links to the documentation:

- w -

  • W : eoEEP_A538xx.h
  • WAKEUP_CYCLE : eoEEP_A520xx.h
  • WAS_VALUES : eoF6EEProfile.h
  • WATCH_CMAC_OVERFLOW : eoWatcher.h
  • WATCH_DELAY_ASSUMED : eoWatcher.h
  • WATCH_DEVICE_ALREADY_EXIST : eoWatcher.h
  • WATCH_DEVICE_NA : eoWatcher.h
  • WATCH_DOS_ASSUMED : eoWatcher.h
  • WATCH_NOT_SECURE_DEVICE : eoWatcher.h
  • WATCH_NOT_WATCHED_DEVICE : eoWatcher.h
  • WATCH_OK : eoWatcher.h
  • WATCH_RLC_OVERFLOW : eoWatcher.h
  • WATCH_TEL_TO_EARLY : eoWatcher.h
  • WATCH_TEL_TO_LATE : eoWatcher.h
  • WATER_DETECTED : eoF6EEProfile.h
  • WEDNESDAY : eoEEP_A513xx.h
  • WEEKLY_PROGRAM : eoEEP_D250xx.h
  • WH : eoEEP_A538xx.h
  • WINDOW_CLOSED : eoEEP_D210xx.h
  • WINDOW_DETECTION : eoEEP_A520xx.h
  • WINDOW_DISABLEMENT : eoEEP_A520xx.h
  • WINDOW_DOWN : eoF6EEProfile.h
  • WINDOW_MIDDLE : eoF6EEProfile.h
  • WINDOW_NO_CHANGE : eoEEP_D210xx.h
  • WINDOW_OPEN : eoEEP_D210xx.h
  • WINDOW_OPEN_DETECTION : eoEEP_D210xx.h
  • WINDOW_STATE : eoEEP_D206xx.h
  • WINDOW_TILTS : eoEEP_D206xx.h
  • WINDOW_UP : eoF6EEProfile.h
  • WORKING_MODE_1 : eoEEP_A511xx.h
  • WORKING_MODE_2 : eoEEP_A511xx.h
  • WORKING_MODE_3 : eoEEP_A511xx.h
  • WORKING_MODE_4 : eoEEP_A511xx.h
  • WR_MODE_CODE : eoSerialCommand.h
  • WRONG_PARAM : eoApiDef.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • enumStrings : eoChannelEnums.h
  • flagStrings : eoChannelEnums.h
  • gpEnumString : eoChannelEnums.h
  • signalStrings : eoChannelEnums.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • float32 : eoHalTypes.h
  • id_device_map : eoDeviceManager.h
  • id_msg_map : eoGpChainer.h , eoSecTeachInChainer.h
  • id_reman_msg_map : eoReManChainer.h
  • id_set : eoIDFilter.h
  • name_object_map : eoStorageManager.h
  • teach_id_map : eoTeachInModule.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • A530_BATTERY_VALUE : eoEEP_A530xx.h
  • A530_INDEX : eoEEP_A530xx.h
  • A530_SIGNAL_TYPE : eoEEP_A530xx.h

- b -

  • BATTERY_LEVEL : eoEEP_A512xx.h

- c -

  • CC_CONTROLLER_MODE : eoEEP_A538xx.h
  • CC_ENERGY_UNITS : eoEEP_A538xx.h
  • CC_FAN_SPEED_5_STAGE : eoEEP_A538xx.h
  • CC_FUNCTIONS : eoEEP_A538xx.h
  • CC_FUNCTIONS_TYPE_09 : eoEEP_A538xx.h
  • CC_INDEXS : eoEEP_A538xx.h
  • CC_LOCKING_OPERATIONS : eoEEP_A538xx.h
  • CC_ROOM_OCCUPANCY : eoEEP_A538xx.h
  • CHANNEL_TYPE : eoChannelEnums.h
  • CHOICE_TYPE : eoApiDef.h
  • CO_DUTYCYCLE_LIMIT : eoSerialCommand.h
  • COMMANDS : eoEEP_D201xx.h
  • COMMON_COMMAND_TYPE : eoSerialCommand.h
  • CS_ENERGY_UNITS : eoEEP_A511xx.h
  • CS_ENUM_03_ERROR_STATE : eoEEP_A511xx.h
  • CS_ENUM_04_ERROR_STATE : eoEEP_A511xx.h
  • CS_ENUM_BLIND_STATE : eoEEP_A511xx.h
  • CS_ENUM_CONTROLLER_MODE : eoEEP_A511xx.h
  • CS_ENUM_END_POS : eoEEP_A511xx.h
  • CS_ENUM_ROOM_OCCUPANCY : eoEEP_A511xx.h
  • CS_FAN_STAGE : eoEEP_A511xx.h
  • CS_INDEXES : eoEEP_A511xx.h
  • CS_RELAY_STATUS : eoEEP_A511xx.h
  • CS_WORKING_MODE : eoEEP_A511xx.h

- d -

  • D205_AET_ALARM_ENUM : eoEEP_D205xx.h
  • D205_INDEX_ENUM : eoEEP_D205xx.h
  • D205_LOCK_MODE_ENUM : eoEEP_D205xx.h
  • D205_MESSAGE_ID_ENUM : eoEEP_D205xx.h
  • D205_REPOSITIONING_ENUM : eoEEP_D205xx.h
  • D206_INDEX_ENUM : eoEEP_D206xx.h
  • D206_MSG_TYPE_ENUM : eoEEP_D206xx.h
  • D210_BATTERY_STATUS_ENUM : eoEEP_D210xx.h
  • D210_COOLING_HEATING_STATUS_ENUM : eoEEP_D210xx.h
  • D210_DATE_TIME_UPDATE_ENUM : eoEEP_D210xx.h
  • D210_DAYLIGHT_SAVE_ENUM : eoEEP_D210xx.h
  • D210_DISPLAY_CONTENT_ENUM : eoEEP_D210xx.h
  • D210_FAN_SPEED_MODE_ENUM : eoEEP_D210xx.h
  • D210_FEEDBACK_CLASS_ENUM : eoEEP_D210xx.h
  • D210_GENERAL_MSG_TYPE_ENUM : eoEEP_D210xx.h
  • D210_INDEX_ENUM : eoEEP_D210xx.h
  • D210_INFO_REQUEST_ENUM : eoEEP_D210xx.h
  • D210_LOCK_ENUM : eoEEP_D210xx.h
  • D210_MESSAGE_ID_ENUM : eoEEP_D210xx.h
  • D210_MSG_CONTINUATION_ENUM : eoEEP_D210xx.h
  • D210_OCCUPANCY_STATUS_ENUM : eoEEP_D210xx.h
  • D210_PERIOD_ENUM : eoEEP_D210xx.h
  • D210_PIR_STATUS_ENUM : eoEEP_D210xx.h
  • D210_RADIO_COM_INTERVAL_ENUM : eoEEP_D210xx.h
  • D210_ROOM_CONTROL_ENUM : eoEEP_D210xx.h
  • D210_SOLAR_POWERED_ENUM : eoEEP_D210xx.h
  • D210_TEMP_SCALE_ENUM : eoEEP_D210xx.h
  • D210_TIME_NOTATION_ENUM : eoEEP_D210xx.h
  • D210_TIME_PROG_DELETION_ENUM : eoEEP_D210xx.h
  • D210_VALIDITY_FLAG_ENUM : eoEEP_D210xx.h
  • D210_WINDOW_OPEN_ENUM : eoEEP_D210xx.h
  • D240_DRIVING_LED_ENUM : eoEEP_D240xx.h
  • D240_INDEX_ENUM : eoEEP_D240xx.h
  • D240_OCCUPANCY_ENUM : eoEEP_D240xx.h
  • D240_STATUS_REASON_ENUM : eoEEP_D240xx.h
  • D240_TRUE_FALSE_ENUM : eoEEP_D240xx.h
  • D250_AIRFLAP_BYPASS : eoEEP_D250xx.h
  • D250_DIRECT_OP_MODE : eoEEP_D250xx.h
  • D250_OP_MODE : eoEEP_D250xx.h
  • D250_REQUESTED_MSG_TYPE : eoEEP_D250xx.h
  • D250xx_COMMANDS : eoEEP_D250xx.h
  • D250xx_INDEX : eoEEP_D250xx.h
  • D323_INDEX_ENUMS : eoEEP_D232xx.h
  • DATA_TYPE_METER_READING : eoEEP_A512xx.h

- e -

  • EA_AM_PM : eoEEP_A513xx.h
  • EA_ENUM_DAYS : eoEEP_A513xx.h
  • EA_HEMISPHERE : eoEEP_A513xx.h
  • EA_INDEXS : eoEEP_A513xx.h
  • EA_TIME_FORMAT : eoEEP_A513xx.h
  • EA_TIME_SOURCE : eoEEP_A513xx.h
  • EC_RESET_CAUSE : eoSerialCommand.h
  • EM_INDEXS : eoEEP_A537xx.h
  • ENUM_DIGITAL_INPUT : eoEEP_A530xx.h
  • ENUM_ENERGY_STATE : eoF6EEProfile.h
  • ENUM_FAN_SPEED_5STAGE : eoA5EEProfile.h
  • ENUM_FAN_SPEED_7STAGE : eoA5EEProfile.h
  • ENUM_MULTIPRESS_STATE : eoF6EEProfile.h
  • ENUM_PARTICLES_SIZE : eoEEP_A509xx.h
  • ENUM_POWER_FAILURE_DETECTION : eoEEP_A509xx.h
  • ENUM_RADIATION_UNIT : eoEEP_A509xx.h
  • ENUM_ROCKER_STATE : eoF6EEProfile.h
  • ENUM_VOC : eoA5EEProfile.h
  • ENUM_WINDOW_STATE : eoF6EEProfile.h
  • EO_SEC_WATCH_RESULT : eoWatcher.h
  • eoReComReturn : eoReCom.h
  • eoReturn : eoApiDef.h

- f -

  • FILTER_KIND : eoSerialCommand.h
  • FILTER_OPERATOR : eoSerialCommand.h
  • FILTER_TYPE : eoSerialCommand.h
  • FN_CODE : eoRemoteManager.h
  • FN_RECOM_CODE : eoReCom.h

- g -

  • GP_CHANNELTYPE : eoGPChannelInfo.h
  • GP_DATA_DIRECTION : eoGenericProfile.h
  • GP_HEADER_PURPOSE : eoGenericProfile.h
  • GP_RESOLUTION : eoGPChannelInfo.h
  • GP_RESPONSE_RESULT : eoTeachInModule.h
  • GP_SCALING : eoGPChannelInfo.h

- h -

  • HVAC_MODE : eoEEP_A520xx.h
  • HVCA_BUTTON_LOCK : eoEEP_A520xx.h
  • HVCA_CONTROLLER_MODE : eoEEP_A520xx.h
  • HVCA_DIRECTION : eoEEP_A520xx.h
  • HVCA_DISPLAY_ORIENTATION : eoEEP_A520xx.h
  • HVCA_FAILURE : eoEEP_A520xx.h
  • HVCA_FAILURE_CODE : eoEEP_A520xx.h
  • HVCA_FANSPEED : eoEEP_A520xx.h
  • HVCA_INDEX : eoEEP_A520xx.h
  • HVCA_MEASUREMENT_CONTROL : eoEEP_A520xx.h
  • HVCA_MEASUREMENT_STATUS : eoEEP_A520xx.h
  • HVCA_ROOM_OCCUPANCY : eoEEP_A520xx.h
  • HVCA_ROOM_OCCUPANCY_TYPE_20 : eoEEP_A520xx.h
  • HVCA_SERVICE_COMMAND : eoEEP_A520xx.h
  • HVCA_STATUS_REQUEST : eoEEP_A520xx.h
  • HVCA_TEMP_SELECTION : eoEEP_A520xx.h
  • HVCA_VANE_POSITION : eoEEP_A520xx.h
  • HVCA_WAKEUP_CYCLE : eoEEP_A520xx.h

- m -

  • MANUFACTURER_LIST : eoManufacturer.h
  • MSR_CHANNELS : eoEEP_D230xx.h
  • MSR_COMMANDS : eoEEP_D230xx.h
  • MSR_CONNECTED_VALVE : eoEEP_D230xx.h
  • MSR_ERROR_CODE : eoEEP_D230xx.h
  • MSR_ERROR_CODE_CH31 : eoEEP_D230xx.h
  • MSR_FACTOR_PULSES : eoEEP_D230xx.h
  • MSR_INIT_SEQU : eoEEP_D230xx.h
  • MSR_METER_BUS_TYPE : eoEEP_D230xx.h
  • MSR_METER_ERROR_CODE : eoEEP_D230xx.h
  • MSR_METER_UNITS : eoEEP_D230xx.h
  • MSR_PROTOCOL : eoEEP_D230xx.h
  • MSR_REPORT_TIME_VALUES : eoEEP_D230xx.h
  • MSR_TIME_VALUES : eoEEP_D230xx.h
  • MSR_VALUE_SELECTION : eoEEP_D230xx.h
  • MSR_VALUE_UNITS : eoEEP_D230xx.h

- n -

  • NS_BATTERY_AUTONOMY : eoEEP_D204xx.h

- p -

  • PACKET_TYPE : eoApiDef.h

- r -

  • RCP_5_LEVEL_FANSPEED : eoEEP_D200xx.h
  • RCP_6_LEVEL_FANSPEED : eoEEP_D200xx.h
  • RCP_COMMANDS : eoEEP_D200xx.h
  • RCP_INDEXS : eoEEP_D200xx.h
  • RCP_PRESENCE : eoEEP_D200xx.h
  • RCP_USER_ACTION : eoEEP_D200xx.h
  • RECEIVE_FLAGS : eoGateway.h
  • RECOM_CHANGES : eoReCom.h
  • RECOM_LEARN_MODE : eoReCom.h
  • RECOM_REPEATER_FILTER : eoReCom.h
  • RECOM_REPEATER_FILTER_CONTROL : eoReCom.h
  • RECOM_REPEATER_FILTER_TYPE : eoReCom.h
  • RECOM_REPEATER_FUNC : eoReCom.h
  • RECOM_REPEATER_LEVEL : eoReCom.h
  • RECOM_RESET : eoReCom.h
  • RECOM_SUPPORT : eoReCom.h
  • RECOM_TABLE_DIR : eoReCom.h
  • REMOTE_TYPE : eoRemoteManager.h
  • ROP_1F_BUTTONS : eoEEP_A510xx.h
  • ROP_SET_POINT_MODE : eoEEP_A510xx.h
  • ROP_USER_ACTIVITY : eoEEP_A510xx.h
  • RORG_TYPE : eoApiDef.h

- s -

  • SA_COMMAND_TYPE : eoSerialCommand.h
  • SA_CONFIRM_CODE : eoSerialCommand.h
  • SA_EVENT_TYPE : eoSerialCommand.h
  • SA_EXTENDED_LEARNMODE : eoSerialCommand.h
  • SENSOR_POSITION_ENUM : eoEEP_A512xx.h
  • SENSOR_POSITION_INDEX_ENUM : eoEEP_A512xx.h
  • SMARTACK_CONFIRM_CODE : eoSerialCommand.h
  • SUPPORTED_FILTERS : eoIFilter.h

- t -

  • TEACH_RETURN : eoTeachInModule.h

- u -

  • UTE_DIRECTION : eoTeachInModule.h
  • UTE_RESPONSE : eoTeachInModule.h

- v -

  • VALUE_TYPE : eoChannelEnums.h
  • VALVE_DIRECTION : eoEEP_D2A0xx.h
  • VALVE_REQUEST : eoEEP_D2A0xx.h
  • VALVE_STATUS : eoEEP_D2A0xx.h
  • VLD_COMMANDS : eoEEP_D202xx.h
  • VLD_DEFAULT_STATE : eoEEP_D201xx.h
  • VLD_DIM_VALUE : eoEEP_D201xx.h
  • VLD_ERROR_LEVEL : eoEEP_D201xx.h
  • VLD_FC_INDEXS : eoEEP_D220xx.h
  • VLD_FC_OP_MODE : eoEEP_D220xx.h
  • VLD_FC_RELHUM_CONTROL : eoEEP_D220xx.h
  • VLD_FC_ROOM_SIZE : eoEEP_D220xx.h
  • VLD_FC_ROOM_SIZE_REF : eoEEP_D220xx.h
  • VLD_FC_SERVICE_INFORMATION : eoEEP_D220xx.h
  • VLD_FC_STAGE : eoEEP_D220xx.h
  • VLD_FC_TEMP_LEVEL : eoEEP_D220xx.h
  • VLD_INDEXS : eoEEP_D202xx.h
  • VLD_IO_CHANNEL : eoEEP_D201xx.h
  • VLD_ON_OFF_INDEX : eoEEP_D201xx.h
  • VLD_PILOTWIRE_MODE : eoEEP_D201xx.h
  • VLD_QUERY_STATUS : eoEEP_D202xx.h
  • VLD_SMOKE_DETECTION : eoEEP_D202xx.h
  • VLD_TIME_INDEX : eoEEP_D201xx.h
  • VLD_UNITS : eoEEP_D201xx.h

- w -

  • WAS_VALUES : eoF6EEProfile.h
  • WR_MODE_CODE : eoSerialCommand.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • A5O_ERROR : eoEEP_A511xx.h
  • A_1_10 : eoEEP_A538xx.h
  • ABS_REL_POWER : eoEEP_A537xx.h
  • ACKNOWLEDGE_FEEDBACK : eoEEP_D210xx.h
  • ACKNOWLEDGE_REQUEST : eoEEP_D210xx.h
  • ACTUATOR_MEASUREMENT_QUERY : eoEEP_D201xx.h
  • ACTUATOR_MEASUREMENT_RESPONSE : eoEEP_D201xx.h
  • ACTUATOR_OBSTRUCTED : eoEEP_A520xx.h
  • ACTUATOR_PILOTWIRE_QUERY : eoEEP_D201xx.h
  • ACTUATOR_PILOTWIRE_RESPONSE : eoEEP_D201xx.h
  • ACTUATOR_PILOTWIRE_SET : eoEEP_D201xx.h
  • ACTUATOR_SET : eoEEP_D202xx.h
  • ACTUATOR_SET_LOCAL : eoEEP_D201xx.h
  • ACTUATOR_SET_MEASUREMENT : eoEEP_D201xx.h
  • ACTUATOR_SET_OUTPUT : eoEEP_D201xx.h
  • ACTUATOR_STATUS_QUERY : eoEEP_D201xx.h
  • ACTUATOR_STATUS_RESPONSE : eoEEP_D201xx.h
  • AIR_QUALITY_1 : eoEEP_D250xx.h
  • AIR_QUALITY_2 : eoEEP_D250xx.h
  • AIR_QUALITY_TRHESHOLD : eoEEP_D250xx.h
  • AIRFLAP_BYPASS_CLOSE : eoEEP_D250xx.h
  • AIRFLAP_BYPASS_OPEN : eoEEP_D250xx.h
  • ALARM_DOWN : eoEEP_D205xx.h
  • ALARM_IMMEDIATE_STOP : eoEEP_D205xx.h
  • ALARM_NO_ACTION : eoEEP_D205xx.h
  • ALARM_NO_CHANGE : eoEEP_D205xx.h
  • ALARM_STATE : eoEEP_A520xx.h
  • ALARM_UP : eoEEP_D205xx.h
  • ALARMS : eoEEP_D206xx.h
  • ALL_SUPPORTED : eoEEP_D201xx.h
  • AM_PM : eoEEP_A513xx.h
  • AND : eoSerialCommand.h
  • APPLY_RADIO : eoSerialCommand.h
  • APPLY_REPEATED : eoSerialCommand.h
  • AZIMUTH : eoEEP_A513xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • BATTERY_CAPACITY : eoEEP_A520xx.h
  • BATTERY_CLICK : eoEEP_D206xx.h
  • BATTERY_EMPTY : eoEEP_A520xx.h
  • BATTERY_EO_OK : eoEEP_A530xx.h
  • BATTERY_LEVEL_100_75 : eoEEP_A512xx.h
  • BATTERY_LEVEL_25_0 : eoEEP_A512xx.h
  • BATTERY_LEVEL_50_25 : eoEEP_A512xx.h
  • BATTERY_LEVEL_75_50 : eoEEP_A512xx.h
  • BATTERY_LOW : eoEEP_A530xx.h
  • BATTERY_STATUS : eoEEP_D210xx.h
  • BATTERY_VLD_CRITICAL : eoEEP_D210xx.h
  • BATTERY_VLD_GOOD : eoEEP_D210xx.h
  • BATTERY_VLD_LOW : eoEEP_D210xx.h
  • BATTERY_VLD_NO_CHANGE : eoEEP_D210xx.h
  • BLIND_CLOSES : eoEEP_A511xx.h
  • BLIND_FULLY_CLOSE : eoEEP_A511xx.h
  • BLIND_FULLY_OPEN : eoEEP_A511xx.h
  • BLIND_OPENS : eoEEP_A511xx.h
  • BLIND_STOPPED : eoEEP_A511xx.h
  • BLOCK_RADIO : eoSerialCommand.h
  • BLOCK_REPEATED : eoSerialCommand.h
  • BLOCKED_VALVE : eoEEP_A520xx.h
  • BQ_KG : eoEEP_A509xx.h
  • BQ_L : eoEEP_A509xx.h
  • BUFF_FULL : eoApiDef.h
  • BUILDING_PROTECT_TEMP_SETPOINT : eoEEP_D210xx.h
  • BUILDING_PROTECT_TEMP_SETPOINT_VALIDITY : eoEEP_D210xx.h
  • BURGLARY_ALARM : eoEEP_D206xx.h
  • BUTTON_1 : eoEEP_D206xx.h
  • BUTTON_2 : eoEEP_D206xx.h
  • BUTTON_LOCK : eoEEP_A520xx.h
  • BUTTON_LOCKED : eoEEP_A520xx.h
  • BUTTON_UNLOCKED : eoEEP_A520xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • CC_ANGLE_BLIND_POSITION : eoEEP_A538xx.h
  • CC_AUTO : eoEEP_A538xx.h
  • CC_BLIND_CLOSE_ANGLE : eoEEP_A538xx.h
  • CC_BLIND_CLOSE_POSITION : eoEEP_A538xx.h
  • CC_BLIND_OPEN_ANGLE : eoEEP_A538xx.h
  • CC_BLIND_OPEN_POSITION : eoEEP_A538xx.h
  • CC_BLIND_POSITION : eoEEP_A538xx.h
  • CC_CONTROLLER_STATE : eoEEP_A538xx.h
  • CC_COOLING : eoEEP_A538xx.h
  • CC_DELAY_DURATION : eoEEP_A538xx.h
  • CC_DIMMING_DOWN : eoEEP_A538xx.h
  • CC_DIMMING_RANGE : eoEEP_A538xx.h
  • CC_DIMMING_STOP : eoEEP_A538xx.h
  • CC_DIMMING_UP : eoEEP_A538xx.h
  • CC_DIMMING_VALUE : eoEEP_A538xx.h
  • CC_DO_NOTHING : eoEEP_A538xx.h
  • CC_DOWN_RAMPING_TIME : eoEEP_A538xx.h
  • CC_ENERGY_HOLDOFF : eoEEP_A538xx.h
  • CC_ENERGY_METERING_VALUE : eoEEP_A538xx.h
  • CC_FULLY_OPEN_ANGLE : eoEEP_A538xx.h
  • CC_FULLY_SHUT_ANGLE : eoEEP_A538xx.h
  • CC_HEATING : eoEEP_A538xx.h
  • CC_LAMP_OPERATING_HOUR : eoEEP_A538xx.h
  • CC_LOCK_OPERATIONS : eoEEP_A538xx.h
  • CC_LOCK_UNLOCK : eoEEP_A538xx.h
  • CC_MAX_DIM_VALUE : eoEEP_A538xx.h
  • CC_MIN_DIM_VALUE : eoEEP_A538xx.h
  • CC_NEW_VALUE_METERING : eoEEP_A538xx.h
  • CC_OCCUPIED : eoEEP_A538xx.h
  • CC_OFF : eoEEP_A538xx.h
  • CC_POS_ANGLE_FLAG : eoEEP_A538xx.h
  • CC_POSITION_LOGIC : eoEEP_A538xx.h
  • CC_RGB_BLUE : eoEEP_A538xx.h
  • CC_RGB_GREEN : eoEEP_A538xx.h
  • CC_RGB_RED : eoEEP_A538xx.h
  • CC_RUNTIME_CLOSE : eoEEP_A538xx.h
  • CC_RUNTIME_OPEN : eoEEP_A538xx.h
  • CC_SCENE : eoEEP_A538xx.h
  • CC_SCENE_FUNCTION : eoEEP_A538xx.h
  • CC_SCENE_NUMBER : eoEEP_A538xx.h
  • CC_SEND_STATUS : eoEEP_A538xx.h
  • CC_SERVICE_MODE : eoEEP_A538xx.h
  • CC_SET_DIMMER_VALUE : eoEEP_A538xx.h
  • CC_SET_MAX_POSITION : eoEEP_A538xx.h
  • CC_SET_MIN_POSITION : eoEEP_A538xx.h
  • CC_SET_OP_HOURS : eoEEP_A538xx.h
  • CC_SET_RAMPING_TIME : eoEEP_A538xx.h
  • CC_SET_RGB_VALUES : eoEEP_A538xx.h
  • CC_SET_VALUES : eoEEP_A538xx.h
  • CC_STAGE_0 : eoEEP_A538xx.h
  • CC_STAGE_1 : eoEEP_A538xx.h
  • CC_STAGE_2 : eoEEP_A538xx.h
  • CC_STAGE_3 : eoEEP_A538xx.h
  • CC_STAGE_AUTO : eoEEP_A538xx.h
  • CC_STANDBY : eoEEP_A538xx.h
  • CC_STORE_FINAL_VAL : eoEEP_A538xx.h
  • CC_SUNBLIND_REVERSION : eoEEP_A538xx.h
  • CC_SWITCHED_OFF : eoEEP_A538xx.h
  • CC_SWITCHED_ON : eoEEP_A538xx.h
  • CC_SWITCHING_COMMAND : eoEEP_A538xx.h
  • CC_UNOCCUPIED : eoEEP_A538xx.h
  • CC_UP_RAMPING_TIME : eoEEP_A538xx.h
  • CH1_OFF_CH2_OFF : eoEEP_A511xx.h
  • CH1_OFF_CH2_ON : eoEEP_A511xx.h
  • CH1_ON_CH2_OFF : eoEEP_A511xx.h
  • CH1_ON_CH2_ON : eoEEP_A511xx.h
  • CHOICE : eoSerialCommand.h
  • CLOSE_BLIND : eoEEP_A538xx.h
  • CLOSE_FOR_TIME : eoEEP_A538xx.h
  • CO2_TRHESHOLD : eoEEP_D250xx.h
  • CO_DUTYCYCLE_LIMIT_REACHED : eoSerialCommand.h
  • CO_DUTYCYCLE_LIMIT_UNREACHED : eoSerialCommand.h
  • CO_RD_DUTYCYCLE_LIMIT : eoSerialCommand.h
  • CO_RD_FILTER : eoSerialCommand.h
  • CO_RD_IDBASE : eoSerialCommand.h
  • CO_RD_MEM : eoSerialCommand.h
  • CO_RD_MEM_ADDRESS : eoSerialCommand.h
  • CO_RD_REPEATER : eoSerialCommand.h
  • CO_RD_SECURITY : eoSerialCommand.h
  • CO_RD_SYS_LOG : eoSerialCommand.h
  • CO_RD_VERSION : eoSerialCommand.h
  • CO_WR_BIST : eoSerialCommand.h
  • CO_WR_FILTER_ADD : eoSerialCommand.h
  • CO_WR_FILTER_DEL : eoSerialCommand.h
  • CO_WR_FILTER_DEL_ALL : eoSerialCommand.h
  • CO_WR_FILTER_ENABLE : eoSerialCommand.h
  • CO_WR_IDBASE : eoSerialCommand.h
  • CO_WR_MEM : eoSerialCommand.h
  • CO_WR_MODE : eoSerialCommand.h
  • CO_WR_REPEATER : eoSerialCommand.h
  • CO_WR_RESET : eoSerialCommand.h
  • CO_WR_SECURITY : eoSerialCommand.h
  • CO_WR_SLEEP : eoSerialCommand.h
  • CO_WR_SUBTEL : eoSerialCommand.h
  • CO_WR_SYS_LOG : eoSerialCommand.h
  • CO_WR_WAIT_MATURITY : eoSerialCommand.h
  • COMFORT_TEMP_SETPOINT : eoEEP_D210xx.h
  • COMFORT_TEMP_SETPOINT_VALIDITY : eoEEP_D210xx.h
  • CONFIG_MSG : eoEEP_D210xx.h
  • CONFIG_REQUEST : eoEEP_D210xx.h
  • CONTACT_COVER : eoEEP_A520xx.h
  • CONTROLLER_STATE : eoEEP_A520xx.h
  • CONTROLLER_TO_VALVE : eoEEP_D2A0xx.h
  • COOLING : eoEEP_A511xx.h
  • COOLING_HEATING_AUTO : eoEEP_D210xx.h
  • COOLING_HEATING_NO_CHANGE : eoEEP_D210xx.h
  • COOLING_HEATING_OFF : eoEEP_D210xx.h
  • COOLING_HEATING_ON : eoEEP_D210xx.h
  • COOLING_PROTECTION : eoEEP_D250xx.h
  • COOLING_STATUS : eoEEP_D210xx.h
  • CPM : eoEEP_A509xx.h
  • CS_A_1_10 : eoEEP_A511xx.h
  • CS_ALARM : eoEEP_A511xx.h
  • CS_ANGLE_SIGN : eoEEP_A511xx.h
  • CS_ANGLE_VALUE : eoEEP_A511xx.h
  • CS_CONTROLLER_STATE : eoEEP_A511xx.h
  • CS_DAYLIGHT_HARVEST : eoEEP_A511xx.h
  • CS_DIMMING : eoEEP_A511xx.h
  • CS_ENERGY_HOLDOFF : eoEEP_A511xx.h
  • CS_GIGA_WH : eoEEP_A511xx.h
  • CS_INTERNAL_ERROR : eoEEP_A511xx.h
  • CS_KILO_W : eoEEP_A511xx.h
  • CS_KILO_WH : eoEEP_A511xx.h
  • CS_LAMP_ERROR : eoEEP_A511xx.h
  • CS_MEGA_W : eoEEP_A511xx.h
  • CS_MEGA_WH : eoEEP_A511xx.h
  • CS_MILI_A : eoEEP_A511xx.h
  • CS_MILI_V : eoEEP_A511xx.h
  • CS_MILI_W : eoEEP_A511xx.h
  • CS_MODE_OF_POSITION : eoEEP_A511xx.h
  • CS_NO_ERROR : eoEEP_A511xx.h
  • CS_OPERATING_HOURS : eoEEP_A511xx.h
  • CS_POSITION_VALUE : eoEEP_A511xx.h
  • CS_POWER_RELAY : eoEEP_A511xx.h
  • CS_POWER_RELAY_TIMER : eoEEP_A511xx.h
  • CS_REPEATER : eoEEP_A511xx.h
  • CS_RGB_BLUE : eoEEP_A511xx.h
  • CS_RGB_GREEN : eoEEP_A511xx.h
  • CS_RGB_RED : eoEEP_A511xx.h
  • CS_SETVICE_MODE : eoEEP_A511xx.h
  • CS_STATUS : eoEEP_A511xx.h
  • CS_V_1_10 : eoEEP_A511xx.h
  • CS_W : eoEEP_A511xx.h
  • CS_WH : eoEEP_A511xx.h
  • CUMULATIVE : eoEEP_A512xx.h
  • CUR_ROT_ANGLE : eoEEP_D205xx.h
  • CUR_VER_POSITION : eoEEP_D205xx.h
  • CURR_CHANNEL_1 : eoEEP_D232xx.h
  • CURR_CHANNEL_2 : eoEEP_D232xx.h
  • CURR_CHANNEL_3 : eoEEP_D232xx.h
  • CURRENT : eoEEP_A512xx.h
  • CURRENT_TEMP : eoEEP_A520xx.h
  • CUSTOM_WARNING_1 : eoEEP_D210xx.h
  • CUSTOM_WARNING_2 : eoEEP_D210xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • D240_FALSE : eoEEP_D240xx.h
  • D240_NOT_OCCUPIED : eoEEP_D240xx.h
  • D240_OCCUPIED : eoEEP_D240xx.h
  • D240_TRUE : eoEEP_D240xx.h
  • D240_UNKNOWN : eoEEP_D240xx.h
  • DATA_MSG : eoEEP_D210xx.h
  • DATA_REQUEST : eoEEP_D210xx.h
  • DATE_TIME_LOCK : eoEEP_D210xx.h
  • DATE_TIME_NO_UPDATE : eoEEP_D210xx.h
  • DATE_TIME_UPDATE : eoEEP_D210xx.h
  • DATE_TIME_UPDATE_FLAG : eoEEP_D210xx.h
  • DAYLIGH_HARVEST : eoEEP_D240xx.h
  • DAYLIGHT_NOT_SUPPORTED : eoEEP_D210xx.h
  • DAYLIGHT_SAVE : eoEEP_D210xx.h
  • DAYLIGHT_SUPPORTED : eoEEP_D210xx.h
  • DBM : eoSerialCommand.h
  • DEFROST_MODE : eoEEP_D250xx.h
  • DESTINATION_ID : eoSerialCommand.h
  • DIGITAL_IN_0 : eoEEP_A530xx.h
  • DIGITAL_IN_1 : eoEEP_A530xx.h
  • DIGITAL_IN_2 : eoEEP_A530xx.h
  • DIGITAL_IN_3 : eoEEP_A530xx.h
  • DIGITAL_INPUT_STATUS : eoEEP_D250xx.h
  • DIGITAL_OUTPUT_STATUS : eoEEP_D250xx.h
  • DIM_LEVEL_BLUE : eoEEP_D240xx.h
  • DIM_LEVEL_GREEN : eoEEP_D240xx.h
  • DIM_LEVEL_MONO : eoEEP_D240xx.h
  • DIM_LEVEL_RED : eoEEP_D240xx.h
  • DIM_STOP : eoEEP_D201xx.h
  • DIM_TO_NEW_FAST : eoEEP_D201xx.h
  • DIM_TO_NEW_MED : eoEEP_D201xx.h
  • DIM_TO_NEW_SLOW : eoEEP_D201xx.h
  • DIMMING_FAST : eoEEP_D201xx.h
  • DIMMING_MEDIUM : eoEEP_D201xx.h
  • DIMMING_SLOW : eoEEP_D201xx.h
  • DIRECT_MODE_AUTO : eoEEP_D250xx.h
  • DIRECT_MODE_AUTO_OD : eoEEP_D250xx.h
  • DIRECT_MODE_LEVEL_1 : eoEEP_D250xx.h
  • DIRECT_MODE_LEVEL_2 : eoEEP_D250xx.h
  • DIRECT_MODE_LEVEL_3 : eoEEP_D250xx.h
  • DIRECT_MODE_LEVEL_4 : eoEEP_D250xx.h
  • DIRECT_MODE_NO_ACTION : eoEEP_D250xx.h
  • DIRECT_MODE_OFF : eoEEP_D250xx.h
  • DIRECT_MODE_SEXHAUST_ONLY : eoEEP_D250xx.h
  • DIRECT_MODE_SUPPLY_ONLY : eoEEP_D250xx.h
  • DIRECT_OP_MODE : eoEEP_D250xx.h
  • DISABLE_REMOTE_CONTROL : eoEEP_A520xx.h
  • DISPLAY_CONTENT : eoEEP_D210xx.h
  • DISPLAY_DEFAULT : eoEEP_D210xx.h
  • DISPLAY_EXTERNAL_TEMP : eoEEP_D210xx.h
  • DISPLAY_HUMIDITY : eoEEP_D210xx.h
  • DISPLAY_INTERNAL_TEMP : eoEEP_D210xx.h
  • DISPLAY_LOCK : eoEEP_D210xx.h
  • DISPLAY_NO_CHANGE : eoEEP_D210xx.h
  • DISPLAY_OFF : eoEEP_D210xx.h
  • DISPLAY_ORIENTATION : eoEEP_A520xx.h
  • DISPLAY_TEMP_SETPOINT : eoEEP_D210xx.h
  • DISPLAY_TIME : eoEEP_D210xx.h
  • DO_NOTHING : eoEEP_A538xx.h
  • DRAIN_HEATER_STATUS : eoEEP_D250xx.h
  • DRIVE_TO_POS : eoEEP_A538xx.h
  • DRIVING_DISABLED : eoEEP_D240xx.h
  • DRIVING_ENABLED : eoEEP_D240xx.h
  • DRIVING_LED : eoEEP_D240xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • E_COMMAND : eoChannelEnums.h
  • E_CONTROLLER_MODE : eoChannelEnums.h
  • E_DAYS : eoChannelEnums.h
  • E_DIM_VALUE : eoChannelEnums.h
  • E_DIRECTION : eoChannelEnums.h
  • E_END_POS : eoChannelEnums.h
  • E_ENERGYBOW : eoChannelEnums.h
  • E_ERROR_STATE : eoChannelEnums.h
  • E_FANSPEED : eoChannelEnums.h
  • E_GP_BUILDING_MODE : eoChannelEnums.h
  • E_GP_CHANGEOVER_MODE : eoChannelEnums.h
  • E_GP_HVAC_MODE : eoChannelEnums.h
  • E_GP_MULTIPURPOSE : eoChannelEnums.h
  • E_GP_OCCUPANCY : eoChannelEnums.h
  • E_IO_CHANNEL : eoChannelEnums.h
  • E_KEY_DATA : eoChannelEnums.h
  • E_MULTIPRESS : eoChannelEnums.h
  • E_OCCUPANCY : eoChannelEnums.h
  • E_PRESENCE : eoChannelEnums.h
  • E_ROCKER_A : eoChannelEnums.h
  • E_ROCKER_B : eoChannelEnums.h
  • E_ROCKER_C : eoChannelEnums.h
  • E_ROCKER_D : eoChannelEnums.h
  • E_ROOM_SIZE : eoChannelEnums.h
  • E_STATE : eoChannelEnums.h
  • E_TARIFF : eoChannelEnums.h
  • E_UNITS : eoChannelEnums.h
  • E_USER_ACTION : eoChannelEnums.h
  • E_VOC : eoChannelEnums.h
  • E_WINDOWHANDLE : eoChannelEnums.h
  • EC_FLYWHEEL_TIMER : eoSerialCommand.h
  • EC_MEM_ERRPR : eoSerialCommand.h
  • EC_PARITY_ERROR : eoSerialCommand.h
  • EC_PARITY_MEM_ERROR : eoSerialCommand.h
  • EC_RESET_PIN : eoSerialCommand.h
  • EC_UNKNOWN : eoSerialCommand.h
  • EC_VOLTAGE_DROP : eoSerialCommand.h
  • EC_WAKE_PIN_0 : eoSerialCommand.h
  • EC_WAKE_PIN_1 : eoSerialCommand.h
  • EC_WATCHDOG_TIMER : eoSerialCommand.h
  • ECONOMY_TEMP_SETPOINT : eoEEP_D210xx.h
  • ECONOMY_TEMP_TEMP_SETPOINT_VALIDITY : eoEEP_D210xx.h
  • EEP_NOT_SUPPORTED : eoTeachInModule.h
  • EEP_TEACH_IN : eoTeachInModule.h
  • ELEVATION : eoEEP_A513xx.h
  • END_POINT_DETECTION : eoEEP_A520xx.h
  • END_POS_NO_CONFIG : eoEEP_A511xx.h
  • END_TIME_HOUR : eoEEP_D210xx.h
  • END_TIME_MINUTE : eoEEP_D210xx.h
  • ENERGY_HOLDOFF : eoEEP_A520xx.h
  • ENERGY_INPUT : eoEEP_A520xx.h
  • ENERGY_KWH : eoEEP_D201xx.h
  • ENERGY_PRESSED : eoF6EEProfile.h
  • ENERGY_RELEASED : eoF6EEProfile.h
  • ENERGY_STORAGE : eoEEP_A520xx.h
  • ENERGY_WH : eoEEP_D201xx.h
  • ENERGY_WS : eoEEP_D201xx.h
  • EO_ERROR : eoApiDef.h
  • EO_OK : eoApiDef.h
  • EXHAUST_AIR_POS : eoEEP_D250xx.h
  • EXHAUST_FAN_RATE : eoEEP_D250xx.h
  • EXHAUST_FAN_SPEED : eoEEP_D250xx.h
  • EXHAUST_TEMP : eoEEP_D250xx.h
  • EXT_PERIPHERY_ERROR : eoEEP_A511xx.h
  • EXTERNAL_DISABLEMENT : eoEEP_A520xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • F_AUTO_MAN : eoChannelEnums.h
  • F_BTN_PRESS : eoChannelEnums.h
  • F_BTN_TRIGGER : eoChannelEnums.h
  • F_DAY_NIGHT : eoChannelEnums.h
  • F_DOWN : eoChannelEnums.h
  • F_GENALARM : eoChannelEnums.h
  • F_HEAT_COOL : eoChannelEnums.h
  • F_HIGH_LOW : eoChannelEnums.h
  • F_OCCUPIED : eoChannelEnums.h
  • F_ON_OFF : eoChannelEnums.h
  • F_OPEN_CLOSED : eoChannelEnums.h
  • F_POWERALARM : eoChannelEnums.h
  • F_START_STOP : eoChannelEnums.h
  • F_UP : eoChannelEnums.h
  • F_VIBRATION : eoChannelEnums.h
  • FAILURE : eoEEP_A520xx.h
  • FAILURE_FLAG : eoEEP_A520xx.h
  • FAN : eoEEP_D200xx.h
  • FAN_NO_CHANGE : eoEEP_D200xx.h
  • FAN_OVERRIDE : eoEEP_A520xx.h
  • FAN_SPEED_CENTRAL_CONTROL : eoEEP_D210xx.h
  • FAN_SPEED_INDIVIDUAL_CONTROL : eoEEP_D210xx.h
  • FAN_SPEED_LOCK : eoEEP_D210xx.h
  • FANSPEED_MODE : eoEEP_D210xx.h
  • FANSPEED_VALIDITY : eoEEP_D210xx.h
  • FAULT_STATUS : eoEEP_D250xx.h
  • FC_RELHUM_DEFAULT : eoEEP_D220xx.h
  • FC_RELHUM_DISABLED : eoEEP_D220xx.h
  • FC_RELHUM_ENABLED : eoEEP_D220xx.h
  • FC_SERVICE_AIR_FILTER : eoEEP_D220xx.h
  • FC_SERVICE_HW_ERROR : eoEEP_D220xx.h
  • FC_SERVICE_NO_REPORT : eoEEP_D220xx.h
  • FC_SERVICE_NOT_SUPPORTED : eoEEP_D220xx.h
  • FC_STAGE_AUTO : eoEEP_D220xx.h
  • FC_STAGE_DEFAULT : eoEEP_D220xx.h
  • FC_STAGE_NO_CHANGE : eoEEP_D220xx.h
  • FEED_TEMP : eoEEP_A520xx.h
  • FEED_TEMP_SELECT : eoEEP_A520xx.h
  • FEEDBACK_CLASS : eoEEP_D210xx.h
  • FILTER_MAINTENANCE : eoEEP_D250xx.h
  • FN_ACTION : eoRemoteManager.h
  • FN_LOCK : eoRemoteManager.h
  • FN_PING : eoRemoteManager.h
  • FN_PING_ANSWER : eoRemoteManager.h
  • FN_QUERY_FUNCTION : eoRemoteManager.h
  • FN_QUERY_FUNCTION_ANSWER : eoRemoteManager.h
  • FN_QUERY_STATUS : eoRemoteManager.h
  • FN_QUERY_STATUS_ANSWER : eoRemoteManager.h
  • FN_QUERYID : eoRemoteManager.h
  • FN_QUERYID_ANSWER : eoRemoteManager.h
  • FN_RECOM_ACK : eoReCom.h
  • FN_RECOM_APPLY_CHANGES : eoReCom.h
  • FN_RECOM_GET_DEVICE_CONFIG : eoReCom.h
  • FN_RECOM_GET_DEVICE_CONFIG_RESPONSE : eoReCom.h
  • FN_RECOM_GET_GP_TABLE : eoReCom.h
  • FN_RECOM_GET_GP_TABLE_RESPONSE : eoReCom.h
  • FN_RECOM_GET_LINK_BASED_CONFIG : eoReCom.h
  • FN_RECOM_GET_LINK_BASED_CONFIG_RESPONSE : eoReCom.h
  • FN_RECOM_GET_METADATA : eoReCom.h
  • FN_RECOM_GET_METADATA_RESPONSE : eoReCom.h
  • FN_RECOM_GET_PRODUCT_ID : eoReCom.h
  • FN_RECOM_GET_PRODUCT_RESPONSE : eoReCom.h
  • FN_RECOM_GET_REPEATER_FUNCTIONS : eoReCom.h
  • FN_RECOM_GET_REPEATER_FUNCTIONS_RESPONSE : eoReCom.h
  • FN_RECOM_GET_TABLE : eoReCom.h
  • FN_RECOM_GET_TABLE_RESPONSE : eoReCom.h
  • FN_RECOM_RADIO_LINK_TEST_CONTROL : eoReCom.h
  • FN_RECOM_RESET_TO_DEFAULTS : eoReCom.h
  • FN_RECOM_SET_DEVICE_CONFIG : eoReCom.h
  • FN_RECOM_SET_GP_TABLE : eoReCom.h
  • FN_RECOM_SET_LEARN_MODE : eoReCom.h
  • FN_RECOM_SET_LINK_BASED_CONFIG : eoReCom.h
  • FN_RECOM_SET_REPEATER_FILTER : eoReCom.h
  • FN_RECOM_SET_REPEATER_FUNCTIONS : eoReCom.h
  • FN_RECOM_SET_TABLE : eoReCom.h
  • FN_RECOM_TRIG_OUTBOUND_TEACH_REQ : eoReCom.h
  • FN_REMOTE_FLASH_READ : eoRemoteManager.h
  • FN_REMOTE_FLASH_READ_ANSWER : eoRemoteManager.h
  • FN_REMOTE_FLASH_WRITE : eoRemoteManager.h
  • FN_REMOTE_LEARNIN : eoRemoteManager.h
  • FN_SETCODE : eoRemoteManager.h
  • FN_SMARTACK_READ : eoRemoteManager.h
  • FN_SMARTACK_READ_LEARNED_SENSOR_ANSWER : eoRemoteManager.h
  • FN_SMARTACK_READ_MAILBOX_ANSWER : eoRemoteManager.h
  • FN_SMARTACK_WRITE : eoRemoteManager.h
  • FN_UNLOCK : eoRemoteManager.h
  • FORMAT_12 : eoEEP_A513xx.h
  • FORMAT_24 : eoEEP_A513xx.h
  • FRIDAY : eoEEP_A513xx.h
  • FROST : eoEEP_A511xx.h
  • FROST_PROTECTION : eoEEP_A520xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • GENERAL_MSG : eoEEP_D210xx.h
  • GENERAL_MSG_TYPE : eoEEP_D210xx.h
  • GENERAL_REASON : eoTeachInModule.h
  • GENERIC_TEACH_IN : eoTeachInModule.h
  • GIGA_WH : eoEEP_A538xx.h
  • GOTO_MSG : eoEEP_D205xx.h
  • GP_CD : eoApiDef.h
  • GP_DATA : eoGPChannelInfo.h
  • GP_ENUMERATION : eoGPChannelInfo.h
  • GP_FLAG : eoGPChannelInfo.h
  • GP_SD : eoApiDef.h
  • GP_TEACHIN_INFO : eoGPChannelInfo.h
  • GP_TI : eoApiDef.h
  • GP_TR : eoApiDef.h
  • GPS : eoEEP_A513xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • HANDLE_CLICK : eoEEP_D206xx.h
  • HANDLE_CLOSED : eoEEP_D206xx.h
  • HANDLE_OPENED : eoEEP_D206xx.h
  • HANDLE_POSITION : eoEEP_D206xx.h
  • HANDLE_TILTED : eoEEP_D206xx.h
  • HARDWARE_OK : eoEEP_D201xx.h
  • HARDWARE_WARNING : eoEEP_D201xx.h
  • HARDWATE_FAIL : eoEEP_D201xx.h
  • HEART_BEAT_SIGNAL : eoEEP_A530xx.h
  • HEARTBEAT : eoEEP_D240xx.h
  • HEAT_EXCHANGE_CTRL : eoEEP_D250xx.h
  • HEATING : eoEEP_A511xx.h
  • HEATING_STATUS : eoEEP_D210xx.h
  • HRS_12 : eoEEP_A520xx.h
  • HRS_15 : eoEEP_A520xx.h
  • HRS_18 : eoEEP_A520xx.h
  • HRS_21 : eoEEP_A520xx.h
  • HRS_24 : eoEEP_A520xx.h
  • HRS_27 : eoEEP_A520xx.h
  • HRS_3 : eoEEP_A520xx.h
  • HRS_30 : eoEEP_A520xx.h
  • HRS_33 : eoEEP_A520xx.h
  • HRS_36 : eoEEP_A520xx.h
  • HRS_39 : eoEEP_A520xx.h
  • HRS_42 : eoEEP_A520xx.h
  • HRS_6 : eoEEP_A520xx.h
  • HRS_9 : eoEEP_A520xx.h
  • HVCA_AUTO : eoEEP_A520xx.h
  • HVCA_AUTO_MOD : eoEEP_A520xx.h
  • HVCA_CLOSE_VALVE : eoEEP_A520xx.h
  • HVCA_COOL_MOD : eoEEP_A520xx.h
  • HVCA_DIRECTION_1 : eoEEP_A520xx.h
  • HVCA_DIRECTION_2 : eoEEP_A520xx.h
  • HVCA_FROST_20 : eoEEP_A520xx.h
  • HVCA_HEAT_MOD : eoEEP_A520xx.h
  • HVCA_NO_CHANGE : eoEEP_A520xx.h
  • HVCA_OCCUPIED : eoEEP_A520xx.h
  • HVCA_OCCUPIED_20 : eoEEP_A520xx.h
  • HVCA_OFF : eoEEP_A520xx.h
  • HVCA_OFF_MOD : eoEEP_A520xx.h
  • HVCA_OPEN_VALVE : eoEEP_A520xx.h
  • HVCA_RUN_INIT : eoEEP_A520xx.h
  • HVCA_STAGE_0 : eoEEP_A520xx.h
  • HVCA_STAGE_1 : eoEEP_A520xx.h
  • HVCA_STAGE_2 : eoEEP_A520xx.h
  • HVCA_STAGE_3 : eoEEP_A520xx.h
  • HVCA_STANDBY : eoEEP_A520xx.h
  • HVCA_STANDBY_20 : eoEEP_A520xx.h
  • HVCA_UNOCCUPIED : eoEEP_A520xx.h
  • HVCA_UNOCCUPIED_20 : eoEEP_A520xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • INDOOR_TEMP : eoEEP_D250xx.h
  • INFO_MSG_STATUS : eoEEP_D250xx.h
  • INFO_REQUEST_CLASS : eoEEP_D210xx.h
  • INPUT_FOR_MAINS : eoEEP_D201xx.h
  • INTERNAL_ERROR : eoEEP_A511xx.h
  • INVALID_PACKET : eoApiDef.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- k -

  • KEY_DATA_1 : eoEEP_A530xx.h
  • KEY_DATA_2 : eoEEP_A530xx.h
  • KEY_DATA_3 : eoEEP_A530xx.h
  • KEY_DATA_4 : eoEEP_A530xx.h
  • KEY_DATA_5 : eoEEP_A530xx.h
  • KEY_DATA_6 : eoEEP_A530xx.h
  • KEY_LOCK : eoEEP_D210xx.h
  • KEYCARD_DISABLEMENT : eoEEP_A520xx.h
  • KILO_W : eoEEP_A538xx.h
  • KILO_WH : eoEEP_A538xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • LATITUDE : eoEEP_A513xx.h
  • LIFT_SET : eoEEP_A520xx.h
  • LOCAL_CONTROL : eoEEP_D201xx.h
  • LOCK_ALARM : eoEEP_D205xx.h
  • LOCK_BLOCKAGE : eoEEP_D205xx.h
  • LOCK_DEBLOCKAGE : eoEEP_D205xx.h
  • LOCK_LOCAL_OP : eoEEP_A538xx.h
  • LOCK_NORMAL : eoEEP_D205xx.h
  • LOCK_SWITCH_OFF : eoEEP_A538xx.h
  • LOCK_SWITCH_ON : eoEEP_A538xx.h
  • LOCKED : eoEEP_D210xx.h
  • LONGITUDE : eoEEP_A513xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • MASTER_SLAVE_CONFIG : eoEEP_D250xx.h
  • MAX_MIN_POWER : eoEEP_A537xx.h
  • MAX_SUB_TIME : eoEEP_D201xx.h
  • MEASUREMENT_ACTIVE : eoEEP_A520xx.h
  • MEASUREMENT_CONTROL : eoEEP_A520xx.h
  • MEASUREMENT_DISABLE : eoEEP_A520xx.h
  • MEASUREMENT_ENABLE : eoEEP_A520xx.h
  • MEASUREMENT_ERROR : eoEEP_A520xx.h
  • MEASUREMENT_INACTIVE : eoEEP_A520xx.h
  • MEASUREMENT_MODE : eoEEP_D201xx.h
  • MEASUREMENT_STATUS : eoEEP_A520xx.h
  • MEGA_W : eoEEP_A538xx.h
  • MEGA_WH : eoEEP_A538xx.h
  • MILI_A : eoEEP_A538xx.h
  • MILI_V : eoEEP_A538xx.h
  • MILI_W : eoEEP_A538xx.h
  • MIN_SUB_TIME : eoEEP_D201xx.h
  • MODE_ADVANCED : eoSerialCommand.h
  • MODE_AUTO : eoEEP_A520xx.h
  • MODE_AUTO_COOL : eoEEP_A520xx.h
  • MODE_AUTO_HEAT : eoEEP_A520xx.h
  • MODE_CALIBRATION : eoEEP_A520xx.h
  • MODE_COMPATIBLE : eoSerialCommand.h
  • MODE_COOL : eoEEP_A520xx.h
  • MODE_DEHUMIDITY : eoEEP_A520xx.h
  • MODE_ECONOMIC : eoEEP_A520xx.h
  • MODE_EMERGENCY_COOL : eoEEP_A520xx.h
  • MODE_EMERGENCY_HEAT : eoEEP_A520xx.h
  • MODE_EMERGENCY_STEAM : eoEEP_A520xx.h
  • MODE_FAN_ONLY : eoEEP_A520xx.h
  • MODE_FREE_COOL : eoEEP_A520xx.h
  • MODE_HEAT : eoEEP_A520xx.h
  • MODE_HVC_LOAD : eoEEP_A520xx.h
  • MODE_ICE : eoEEP_A520xx.h
  • MODE_MAX_COOL : eoEEP_A520xx.h
  • MODE_MAX_HEAT : eoEEP_A520xx.h
  • MODE_MORING_WARMUP : eoEEP_A520xx.h
  • MODE_NIGHT_PURGE : eoEEP_A520xx.h
  • MODE_NO_LOAD : eoEEP_A520xx.h
  • MODE_OFF : eoEEP_A520xx.h
  • MODE_PRECOOL : eoEEP_A520xx.h
  • MODE_TEST : eoEEP_A520xx.h
  • MOLD_WARNING : eoEEP_D210xx.h
  • MONDAY : eoEEP_A513xx.h
  • MOTION : eoEEP_D206xx.h
  • MSG_AUTO_CONTROL : eoEEP_D210xx.h
  • MSG_COMPLETE : eoEEP_D210xx.h
  • MSG_CONFIG_REPORT : eoEEP_D206xx.h
  • MSG_CONTINUATION : eoEEP_D210xx.h
  • MSG_CTRL_SETTINGS : eoEEP_D206xx.h
  • MSG_INCOMPLETE : eoEEP_D210xx.h
  • MSG_LOG_DATA_1 : eoEEP_D206xx.h
  • MSG_LOG_DATA_2 : eoEEP_D206xx.h
  • MSG_LOG_DATA_3 : eoEEP_D206xx.h
  • MSG_LOG_DATA_4 : eoEEP_D206xx.h
  • MSG_REPETITION_FEEDBACK : eoEEP_D210xx.h
  • MSG_SENSOR_VALUES : eoEEP_D206xx.h
  • MSG_TYPE_FEEDBACK : eoEEP_D210xx.h
  • MSG_TYPE_INFO_REQUEST : eoEEP_D210xx.h
  • MSR_1000_SECOND : eoEEP_D230xx.h
  • MSR_1000_SECOND_REPORT : eoEEP_D230xx.h
  • MSR_100_SECOND : eoEEP_D230xx.h
  • MSR_100_SECOND_REPORT : eoEEP_D230xx.h
  • MSR_10_SECOND : eoEEP_D230xx.h
  • MSR_10_SECOND_REPORT : eoEEP_D230xx.h
  • MSR_1_SECOND : eoEEP_D230xx.h
  • MSR_1_SECOND_REPORT : eoEEP_D230xx.h
  • MSR_200_SECOND : eoEEP_D230xx.h
  • MSR_20_SECOND : eoEEP_D230xx.h
  • MSR_2_SECOND : eoEEP_D230xx.h
  • MSR_300_SECOND_REPORT : eoEEP_D230xx.h
  • MSR_30_SECOND_REPORT : eoEEP_D230xx.h
  • MSR_3_SECOND_REPORT : eoEEP_D230xx.h
  • MSR_500_SECOND : eoEEP_D230xx.h
  • MSR_50_SECOND : eoEEP_D230xx.h
  • MSR_5_SECOND : eoEEP_D230xx.h
  • MSR_BUS_TYPE_D0 : eoEEP_D230xx.h
  • MSR_BUS_TYPE_MBUS : eoEEP_D230xx.h
  • MSR_BUS_TYPE_S0 : eoEEP_D230xx.h
  • MSR_CHANNEL_ERROR : eoEEP_D230xx.h
  • MSR_CHANNEL_ERROR_HCH31 : eoEEP_D230xx.h
  • MSR_CHANNEL_METER_1 : eoEEP_D230xx.h
  • MSR_CHANNEL_METER_2 : eoEEP_D230xx.h
  • MSR_CHANNEL_METER_CHANNEL : eoEEP_D230xx.h
  • MSR_CHANNEL_METER_ERROR : eoEEP_D230xx.h
  • MSR_CHANNEL_METER_TYPE : eoEEP_D230xx.h
  • MSR_CHANNEL_NUM_OF_PULSES : eoEEP_D230xx.h
  • MSR_CHANNEL_PRESET_VALUE : eoEEP_D230xx.h
  • MSR_CHANNEL_PRIMARY_ADDR : eoEEP_D230xx.h
  • MSR_CHANNEL_PROTOCOL : eoEEP_D230xx.h
  • MSR_CHANNEL_PULSES_FACTOR : eoEEP_D230xx.h
  • MSR_CHANNEL_REPORT_TIME : eoEEP_D230xx.h
  • MSR_CHANNEL_RETURN_TEMP : eoEEP_D230xx.h
  • MSR_CHANNEL_SUPPLY_TEMP : eoEEP_D230xx.h
  • MSR_CHANNEL_VALUE_SELECTION : eoEEP_D230xx.h
  • MSR_ERROR_CH31_GENERAL : eoEEP_D230xx.h
  • MSR_ERROR_CH31_NO_FAULT : eoEEP_D230xx.h
  • MSR_ERROR_CH31_RETURN_TEMP : eoEEP_D230xx.h
  • MSR_ERROR_CH31_SUPPLY_RETURN_TEMP : eoEEP_D230xx.h
  • MSR_ERROR_CH31_SUPPLY_TEMP : eoEEP_D230xx.h
  • MSR_ERROR_CHANNEL_NOT_AVAILABLE : eoEEP_D230xx.h
  • MSR_ERROR_GENERAL : eoEEP_D230xx.h
  • MSR_ERROR_INIT_SEQU_RUNNING : eoEEP_D230xx.h
  • MSR_ERROR_NO_FAULT : eoEEP_D230xx.h
  • MSR_ERROR_TEMP_SENSOR : eoEEP_D230xx.h
  • MSR_ERROR_TEMP_SENSOR_VALVE : eoEEP_D230xx.h
  • MSR_ERROR_VALVE : eoEEP_D230xx.h
  • MSR_FACTOR_PULSES_0001 : eoEEP_D230xx.h
  • MSR_FACTOR_PULSES_001 : eoEEP_D230xx.h
  • MSR_FACTOR_PULSES_01 : eoEEP_D230xx.h
  • MSR_FACTOR_PULSES_1 : eoEEP_D230xx.h
  • MSR_HEAT_CONTROL_STATUS_QUERY : eoEEP_D230xx.h
  • MSR_HEAT_CONTROL_STATUS_RESPONSE : eoEEP_D230xx.h
  • MSR_LOCAL_DEFAULT : eoEEP_D230xx.h
  • MSR_METER_BUS_INIT_RUNNING : eoEEP_D230xx.h
  • MSR_METER_BUS_NO_CONFIG : eoEEP_D230xx.h
  • MSR_METER_BUS_NO_CONNECTION : eoEEP_D230xx.h
  • MSR_METER_BUS_SHORTCUT : eoEEP_D230xx.h
  • MSR_METER_ERROR_GENERAL : eoEEP_D230xx.h
  • MSR_METER_ERROR_NO_FAULT : eoEEP_D230xx.h
  • MSR_METER_READING_REPORT : eoEEP_D230xx.h
  • MSR_METER_STATUS_QUERY : eoEEP_D230xx.h
  • MSR_METER_TIMEOUT : eoEEP_D230xx.h
  • MSR_METER_UNKNOWN_CONFIG : eoEEP_D230xx.h
  • MSR_NO_ACTION : eoEEP_D230xx.h
  • MSR_NO_REPORT : eoEEP_D230xx.h
  • MSR_PROTOCOL_AUTO_DETECT : eoEEP_D230xx.h
  • MSR_PROTOCOL_DLMS : eoEEP_D230xx.h
  • MSR_PROTOCOL_SML : eoEEP_D230xx.h
  • MSR_RUN_INIT_SEQU : eoEEP_D230xx.h
  • MSR_SET_HEAT_CONTROLS : eoEEP_D230xx.h
  • MSR_SET_METER_CONFIGURATION : eoEEP_D230xx.h
  • MSR_UNIT_ACCUM_KWH : eoEEP_D230xx.h
  • MSR_UNIT_ACCUM_M3 : eoEEP_D230xx.h
  • MSR_UNIT_CURRENT_DM3_ACCUM_DM3 : eoEEP_D230xx.h
  • MSR_UNIT_CURRENT_M3_ACCUM_M3 : eoEEP_D230xx.h
  • MSR_UNIT_CURRENT_W_ACCUM_KWH : eoEEP_D230xx.h
  • MSR_UNIT_CURRENT_W_ACCUM_WH : eoEEP_D230xx.h
  • MSR_UNIT_DIGIT_COUNTER : eoEEP_D230xx.h
  • MSR_UNIT_NO_READING : eoEEP_D230xx.h
  • MSR_VALUE_1_ACCU : eoEEP_D230xx.h
  • MSR_VALUE_1_CURRENT : eoEEP_D230xx.h
  • MSR_VALUE_2_ACCU : eoEEP_D230xx.h
  • MSR_VALUE_2_CURRENT : eoEEP_D230xx.h
  • MSR_VALUE_DIGIT_COUNTER : eoEEP_D230xx.h
  • MSR_VALUE_DM3 : eoEEP_D230xx.h
  • MSR_VALUE_DM3H : eoEEP_D230xx.h
  • MSR_VALUE_KWH : eoEEP_D230xx.h
  • MSR_VALUE_M3 : eoEEP_D230xx.h
  • MSR_VALUE_M3H : eoEEP_D230xx.h
  • MSR_VALUE_W : eoEEP_D230xx.h
  • MSR_VALUE_WH : eoEEP_D230xx.h
  • MSR_VALVE_NORM_CLOSED : eoEEP_D230xx.h
  • MSR_VALVE_NORM_OPEN : eoEEP_D230xx.h
  • MULTIPRESS_NOT : eoF6EEProfile.h
  • MULTIPRESS_YES : eoF6EEProfile.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • NEW_DEVICE : eoTeachInModule.h
  • NEW_DEVICE_AND_EPP : eoTeachInModule.h
  • NEW_RX : eoApiDef.h
  • NIGHT_TIME : eoEEP_D200xx.h
  • NO_CHANGE : eoEEP_D200xx.h
  • NO_END_POS_AVAILABLE : eoEEP_A511xx.h
  • NO_END_POS_REACHED : eoEEP_A511xx.h
  • NO_FAILURE_FLAG : eoEEP_A520xx.h
  • NO_POWER_FAILURE : eoEEP_A509xx.h
  • NO_RESPONSE_FROM_CONTROLLER : eoEEP_A520xx.h
  • NO_RX : eoApiDef.h
  • NO_SMOKE : eoEEP_D202xx.h
  • NO_TEACH_IN : eoTeachInModule.h
  • NO_VALVE : eoEEP_A520xx.h
  • NO_WATER : eoF6EEProfile.h
  • NORMAL_SIGNAL : eoEEP_A530xx.h
  • NORTH : eoEEP_A513xx.h
  • NOT_AVAILABLE : eoEEP_A511xx.h
  • NOT_IMPLEMENTED : eoApiDef.h
  • NOT_PRESENT : eoEEP_D200xx.h
  • NOT_RECOM : eoApiDef.h
  • NOT_SOLAR_POWERED : eoEEP_D210xx.h
  • NOT_SUPPORTED : eoApiDef.h
  • NOT_TEACHED_IN : eoEEP_A520xx.h
  • NS_BATTERY_100_875 : eoEEP_D204xx.h
  • NS_BATTERY_125_0 : eoEEP_D204xx.h
  • NS_BATTERY_25_125 : eoEEP_D204xx.h
  • NS_BATTERY_375_25 : eoEEP_D204xx.h
  • NS_BATTERY_50_375 : eoEEP_D204xx.h
  • NS_BATTERY_625_50 : eoEEP_D204xx.h
  • NS_BATTERY_75_625 : eoEEP_D204xx.h
  • NS_BATTERY_875_75 : eoEEP_D204xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • OCCUPANCY : eoEEP_A510xx.h
  • OCCUPANCY_LOCK : eoEEP_D210xx.h
  • OCCUPANCY_NO_CHANGE : eoEEP_D210xx.h
  • OCCUPANCY_PRESSED_OCCUPIED : eoEEP_D210xx.h
  • OCCUPANCY_PRESSED_UNOCCUPIED : eoEEP_D210xx.h
  • OCCUPIED : eoEEP_A511xx.h
  • OFF : eoEEP_A511xx.h
  • ON_OFF : eoEEP_A520xx.h
  • ONGOING_RX : eoApiDef.h
  • OP_MODE : eoEEP_D220xx.h
  • OP_MODE_CTRL : eoEEP_D250xx.h
  • OP_MODE_DISABLED : eoEEP_D220xx.h
  • OP_MODE_NO_CHANGE : eoEEP_D220xx.h
  • OP_MODE_STANDARD_COMPLIANT : eoEEP_D220xx.h
  • OP_NEXT : eoEEP_D250xx.h
  • OP_NO_ACTION : eoEEP_D250xx.h
  • OP_PREVIOUS : eoEEP_D250xx.h
  • OPEN_BLIND : eoEEP_A538xx.h
  • OPEN_FOR_TIME : eoEEP_A538xx.h
  • OPERATION_DENIED : eoApiDef.h
  • OR : eoSerialCommand.h
  • ORIENTATION_0 : eoEEP_A520xx.h
  • ORIENTATION_180 : eoEEP_A520xx.h
  • ORIENTATION_270 : eoEEP_A520xx.h
  • ORIENTATION_90 : eoEEP_A520xx.h
  • OTHER_DISABLEMENT : eoEEP_A520xx.h
  • OTHER_REASON : eoEEP_D240xx.h
  • OUT_OF_RANGE : eoApiDef.h
  • OUTDOOR_HEATER_STATUS : eoEEP_D250xx.h
  • OUTDOOR_TEMP : eoEEP_D250xx.h
  • OVER_CURRENT_SHUT : eoEEP_D201xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • PACKET_COMMON_COMMAND : eoApiDef.h
  • PACKET_DEBUG : eoApiDef.h
  • PACKET_EVENT : eoApiDef.h
  • PACKET_PRODUCTION_COMMAND : eoApiDef.h
  • PACKET_RADIO : eoApiDef.h
  • PACKET_RADIO_ADVANCED : eoApiDef.h
  • PACKET_RADIO_MESSAGE : eoApiDef.h
  • PACKET_RADIO_SET : eoApiDef.h
  • PACKET_RADIO_SUB_TEL : eoApiDef.h
  • PACKET_REMOTE_MAN_COMMAND : eoApiDef.h
  • PACKET_RESPONSE : eoApiDef.h
  • PACKET_SMART_ACK_COMMAND : eoApiDef.h
  • PERIOD_FRIDAY : eoEEP_D210xx.h
  • PERIOD_FRIDAY_MONDAY : eoEEP_D210xx.h
  • PERIOD_FRIDAY_SUNDAY : eoEEP_D210xx.h
  • PERIOD_MONDAY : eoEEP_D210xx.h
  • PERIOD_MONDAY_FRIDAY : eoEEP_D210xx.h
  • PERIOD_MONDAY_SUNDAY : eoEEP_D210xx.h
  • PERIOD_MONDAY_WEDNESDAY : eoEEP_D210xx.h
  • PERIOD_SATURDAY : eoEEP_D210xx.h
  • PERIOD_SATURDAY_SUNDAY : eoEEP_D210xx.h
  • PERIOD_SUNDAY : eoEEP_D210xx.h
  • PERIOD_THURSDAY : eoEEP_D210xx.h
  • PERIOD_THURSDAY_FRIDAY : eoEEP_D210xx.h
  • PERIOD_TUESDAY : eoEEP_D210xx.h
  • PERIOD_TUESDAY_THURSDAY : eoEEP_D210xx.h
  • PERIOD_WEDNESDAY : eoEEP_D210xx.h
  • PERIOD_WEDNESDAY_FRIDAY : eoEEP_D210xx.h
  • PILOTWIRE_ANTI_FREEZE : eoEEP_D201xx.h
  • PILOTWIRE_COMFORT : eoEEP_D201xx.h
  • PILOTWIRE_COMFORT_1 : eoEEP_D201xx.h
  • PILOTWIRE_COMFORT_2 : eoEEP_D201xx.h
  • PILOTWIRE_ECO : eoEEP_D201xx.h
  • PILOTWIRE_OFF : eoEEP_D201xx.h
  • PIR_LOCK : eoEEP_D210xx.h
  • PIR_LOCKED : eoEEP_D210xx.h
  • PIR_MOVEMENT : eoEEP_D210xx.h
  • PIR_NO_CHANGE : eoEEP_D210xx.h
  • PIR_NO_MOVEMENT : eoEEP_D210xx.h
  • PIR_STATUS : eoEEP_D210xx.h
  • PM1 : eoEEP_A509xx.h
  • PM10 : eoEEP_A509xx.h
  • PM2_5 : eoEEP_A509xx.h
  • PORT_ERROR : eoApiDef.h
  • POSITION_LOCATION_0 : eoEEP_A512xx.h
  • POSITION_LOCATION_1 : eoEEP_A512xx.h
  • POSITION_LOCATION_2 : eoEEP_A512xx.h
  • POSITION_LOCATION_3 : eoEEP_A512xx.h
  • POSITION_LOCATION_4 : eoEEP_A512xx.h
  • POSITION_LOCATION_5 : eoEEP_A512xx.h
  • POSITION_LOCATION_6 : eoEEP_A512xx.h
  • POSITION_LOCATION_7 : eoEEP_A512xx.h
  • POSITION_LOCATION_8 : eoEEP_A512xx.h
  • POSITION_LOCATION_9 : eoEEP_A512xx.h
  • POSITION_NOT_POSSESSED : eoEEP_A512xx.h
  • POSITION_POSSESSED : eoEEP_A512xx.h
  • POWER_FAILURE_DETECTED : eoEEP_A509xx.h
  • POWER_KW : eoEEP_D201xx.h
  • POWER_ONS : eoEEP_D206xx.h
  • POWER_W : eoEEP_D201xx.h
  • PRECOMFORT_TEMP_SETPOINT : eoEEP_D210xx.h
  • PRECOMFORT_TEMP_SETPOINT_VALIDITY : eoEEP_D210xx.h
  • PRESENCE : eoEEP_D200xx.h
  • PRESENT : eoEEP_D200xx.h
  • PREV_STATE : eoEEP_D201xx.h
  • PROTECTION_PLUS_ALARM : eoEEP_D206xx.h
  • PWR_FAILURE : eoEEP_D201xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- q -

  • QUERY : eoEEP_D201xx.h
  • QUERY_LUMINANCE : eoEEP_D202xx.h
  • QUERY_MSG : eoEEP_D205xx.h
  • QUERY_OCCUPANCY : eoEEP_D202xx.h
  • QUERY_SMOPKE : eoEEP_D202xx.h
  • QUERY_TEMP : eoEEP_D202xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • R_NEXT_CHANNEL : eoRemoteManager.h
  • R_S_ADVANCED_LEARN : eoRemoteManager.h
  • R_S_SIMPLE_LEARN : eoRemoteManager.h
  • R_S_STOP_LEARN : eoRemoteManager.h
  • R_START_LEARN : eoRemoteManager.h
  • R_STOP_LEARN : eoRemoteManager.h
  • RADIO_12_HOURS_INTERVAL : eoEEP_D210xx.h
  • RADIO_24_HOURS_INTERVAL : eoEEP_D210xx.h
  • RADIO_3_HOURS_INTERVAL : eoEEP_D210xx.h
  • RADIO_CHOICE_1BS : eoApiDef.h
  • RADIO_CHOICE_4BS : eoApiDef.h
  • RADIO_CHOICE_ADT : eoApiDef.h
  • RADIO_CHOICE_GP_CHAINED_DATA : eoApiDef.h
  • RADIO_CHOICE_GP_CHAINED_TREQ : eoApiDef.h
  • RADIO_CHOICE_GP_CHAINED_TRES : eoApiDef.h
  • RADIO_CHOICE_GP_SELECT_DATA : eoApiDef.h
  • RADIO_CHOICE_GP_SINGLE_DATA : eoApiDef.h
  • RADIO_CHOICE_GP_SINGLE_TREQ : eoApiDef.h
  • RADIO_CHOICE_GP_SINGLE_TRES : eoApiDef.h
  • RADIO_CHOICE_HRC : eoApiDef.h
  • RADIO_CHOICE_MSC : eoApiDef.h
  • RADIO_CHOICE_NON_SEC : eoApiDef.h
  • RADIO_CHOICE_RECLAIM : eoApiDef.h
  • RADIO_CHOICE_RPS : eoApiDef.h
  • RADIO_CHOICE_SEC : eoApiDef.h
  • RADIO_CHOICE_SEC_ENCAPS : eoApiDef.h
  • RADIO_CHOICE_SEC_TI : eoApiDef.h
  • RADIO_CHOICE_SIGNAL : eoApiDef.h
  • RADIO_CHOICE_SM_LRN_ANS : eoApiDef.h
  • RADIO_CHOICE_SM_LRN_REQ : eoApiDef.h
  • RADIO_CHOICE_SYS : eoApiDef.h
  • RADIO_CHOICE_SYS_EX : eoApiDef.h
  • RADIO_CHOICE_UTE : eoApiDef.h
  • RADIO_CHOICE_VLD : eoApiDef.h
  • RADIO_COM_INTERVAL : eoEEP_D210xx.h
  • RADIO_NO_INTERVAL : eoEEP_D210xx.h
  • RAIN_NORAIN : eoEEP_A513xx.h
  • RAND_END_DELAY : eoEEP_A537xx.h
  • RAND_START_DELAY : eoEEP_A537xx.h
  • RCP_CONFIG_VALID : eoEEP_D200xx.h
  • RCP_COOLING : eoEEP_D200xx.h
  • RCP_DELTA_TEMP_GRAPHIC : eoEEP_D200xx.h
  • RCP_DELTA_TEMP_SETPOINT_C : eoEEP_D200xx.h
  • RCP_DELTA_TEMP_SETPOINT_F : eoEEP_D200xx.h
  • RCP_DEW_POINT : eoEEP_D200xx.h
  • RCP_DISPLAY_CONTENT : eoEEP_D200xx.h
  • RCP_DO_NOT_DISPLAY : eoEEP_D200xx.h
  • RCP_FAN_MANUAL : eoEEP_D200xx.h
  • RCP_FIRST_USER_ACTION : eoEEP_D200xx.h
  • RCP_HEATING : eoEEP_D200xx.h
  • RCP_KEEP_ALIVE_TIME : eoEEP_D200xx.h
  • RCP_MEASUREMENT_RESULT : eoEEP_D200xx.h
  • RCP_MORE_DATA : eoEEP_D200xx.h
  • RCP_NO_DISPLAY : eoEEP_D200xx.h
  • RCP_NOMINAL_TEMPERATURE_C : eoEEP_D200xx.h
  • RCP_NOMINAL_TEMPERATURE_F : eoEEP_D200xx.h
  • RCP_REPEATED_USER_ACTION : eoEEP_D200xx.h
  • RCP_ROOM_TEMPERATURE_C : eoEEP_D200xx.h
  • RCP_ROOM_TEMPERATURE_F : eoEEP_D200xx.h
  • RCP_SENSOR_CONFIG : eoEEP_D200xx.h
  • RCP_SETPOINT_RANGE_LIMIT : eoEEP_D200xx.h
  • RCP_SETPOINT_STEPS : eoEEP_D200xx.h
  • RCP_SPEED_LEVEL_0 : eoEEP_D200xx.h
  • RCP_SPEED_LEVEL_1 : eoEEP_D200xx.h
  • RCP_SPEED_LEVEL_2 : eoEEP_D200xx.h
  • RCP_SPEED_LEVEL_3 : eoEEP_D200xx.h
  • RCP_TEMP_MEASUREMENT_TIMING : eoEEP_D200xx.h
  • RCP_TIME_24_HOURS : eoEEP_D200xx.h
  • RCP_TIME_AM_HOURS : eoEEP_D200xx.h
  • RCP_TIME_DAY_MONTH : eoEEP_D200xx.h
  • RCP_TIME_MONTH_DAY : eoEEP_D200xx.h
  • RCP_TIME_PM_HOURS : eoEEP_D200xx.h
  • RCP_USER_NOTIFICATION : eoEEP_D200xx.h
  • REAL_TIME_CLOCK : eoEEP_A513xx.h
  • RECENT_TEMP_SETPOINT : eoEEP_D210xx.h
  • RECOM_ADDR_OUT_OF_RANGE : eoReCom.h
  • RECOM_CHANGES_APPLY : eoReCom.h
  • RECOM_CHANGES_NOT_APPLY : eoReCom.h
  • RECOM_CODE_DATA_SIZE_EXCEED : eoReCom.h
  • RECOM_DEFAULT_RESET : eoReCom.h
  • RECOM_EXIT_LEARN : eoReCom.h
  • RECOM_FILTER_DBM : eoReCom.h
  • RECOM_FILTER_DESTINATION_ID : eoReCom.h
  • RECOM_FILTER_RORG : eoReCom.h
  • RECOM_FILTER_SOURCE_ID : eoReCom.h
  • RECOM_FILTERED_REPEATER_ON : eoReCom.h
  • RECOM_INBOUND_TABLE : eoReCom.h
  • RECOM_LEARN_IN : eoReCom.h
  • RECOM_LEARN_OUT : eoReCom.h
  • RECOM_MSG_PART_NOT_RECEIVED : eoReCom.h
  • RECOM_MSG_PART_RECEIVED : eoReCom.h
  • RECOM_MSG_TIMEOUT : eoReCom.h
  • RECOM_MSG_TOO_LONG : eoReCom.h
  • RECOM_NO_CODE_SET : eoReCom.h
  • RECOM_NO_DEFAULT_RESET : eoReCom.h
  • RECOM_NOT_SEND : eoReCom.h
  • RECOM_NOT_SUPPORTED : eoReCom.h
  • RECOM_OK : eoReCom.h
  • RECOM_OUTBOUND_TABLE : eoReCom.h
  • RECOM_REPEATER_AND : eoReCom.h
  • RECOM_REPEATER_APPLY : eoReCom.h
  • RECOM_REPEATER_BLOCK : eoReCom.h
  • RECOM_REPEATER_DELETE_ALL : eoReCom.h
  • RECOM_REPEATER_DELETE_FILTER : eoReCom.h
  • RECOM_REPEATER_LEVEL_1 : eoReCom.h
  • RECOM_REPEATER_LEVEL_2 : eoReCom.h
  • RECOM_REPEATER_OFF : eoReCom.h
  • RECOM_REPEATER_ON : eoReCom.h
  • RECOM_REPEATER_OR : eoReCom.h
  • RECOM_RPC_FAIL : eoReCom.h
  • RECOM_SUPPORTED : eoReCom.h
  • RECOM_WRONG_DATA : eoReCom.h
  • RECOM_WRONG_DATA_SIZE : eoReCom.h
  • RECOM_WRONG_EEP : eoReCom.h
  • RECOM_WRONG_ID : eoReCom.h
  • RECOM_WRONG_MANUFACTURER_ID : eoReCom.h
  • RECOM_WRONG_UNLOCK_CODE : eoReCom.h
  • RECV_DEVICE_ADDED : eoGateway.h
  • RECV_ERROR : eoGateway.h
  • RECV_MESSAGE : eoGateway.h
  • RECV_PACKET : eoGateway.h
  • RECV_PROFILE : eoGateway.h
  • RECV_REMAN : eoGateway.h
  • RECV_SECTEACHIN : eoGateway.h
  • RECV_TEACHIN : eoGateway.h
  • RECV_TELEGRAM : eoGateway.h
  • RECV_TELEGRAM_SEC : eoGateway.h
  • RELHUM_CONTROL : eoEEP_D220xx.h
  • RELHUM_THRESHOLD : eoEEP_D220xx.h
  • RELHUM_VALIDITY : eoEEP_D210xx.h
  • REPLY_MSG : eoEEP_D205xx.h
  • REPORT_MEASUREMENT : eoEEP_D201xx.h
  • REPOS_DIRECT_POS_ANG : eoEEP_D205xx.h
  • REPOS_DOWN_POS_ANG : eoEEP_D205xx.h
  • REPOS_UP_POS_ANG : eoEEP_D205xx.h
  • REQUESTED_MSG_TYPE : eoEEP_D250xx.h
  • RESET_MEASUREMENT : eoEEP_D201xx.h
  • RESET_OVER_CURRENT : eoEEP_D201xx.h
  • RESPONSE_MODE : eoEEP_D240xx.h
  • ROOM_CONTROL_BUILDING_PROTECT : eoEEP_D210xx.h
  • ROOM_CONTROL_COMFORT : eoEEP_D210xx.h
  • ROOM_CONTROL_ECONOMY : eoEEP_D210xx.h
  • ROOM_CONTROL_MSG : eoEEP_D210xx.h
  • ROOM_CONTROL_PRECOMFORT : eoEEP_D210xx.h
  • ROOM_CONTROL_REQUEST : eoEEP_D210xx.h
  • ROOM_SIZE_100_125 : eoEEP_D220xx.h
  • ROOM_SIZE_125_150 : eoEEP_D220xx.h
  • ROOM_SIZE_150_175 : eoEEP_D220xx.h
  • ROOM_SIZE_175_200 : eoEEP_D220xx.h
  • ROOM_SIZE_200_225 : eoEEP_D220xx.h
  • ROOM_SIZE_225_250 : eoEEP_D220xx.h
  • ROOM_SIZE_25 : eoEEP_D220xx.h
  • ROOM_SIZE_250_275 : eoEEP_D220xx.h
  • ROOM_SIZE_25_50 : eoEEP_D220xx.h
  • ROOM_SIZE_275_300 : eoEEP_D220xx.h
  • ROOM_SIZE_300_325 : eoEEP_D220xx.h
  • ROOM_SIZE_325_350 : eoEEP_D220xx.h
  • ROOM_SIZE_350 : eoEEP_D220xx.h
  • ROOM_SIZE_50_75 : eoEEP_D220xx.h
  • ROOM_SIZE_75_100 : eoEEP_D220xx.h
  • ROOM_SIZE_NO_CHANGE : eoEEP_D220xx.h
  • ROOM_SIZE_REF_DEFAULT : eoEEP_D220xx.h
  • ROOM_SIZE_REF_NO_CHANGE : eoEEP_D220xx.h
  • ROOM_SIZE_REF_NOT_USED : eoEEP_D220xx.h
  • ROOM_SIZE_REF_USED : eoEEP_D220xx.h
  • ROOM_SIZE_REFERENCE : eoEEP_D220xx.h
  • ROOM_TEMP : eoEEP_D250xx.h
  • ROOM_TEMP_CTRL : eoEEP_D250xx.h
  • ROP_AUTOMATIC_CONTROL : eoEEP_A510xx.h
  • ROP_FROST_PROTECTION : eoEEP_A510xx.h
  • ROP_NO_USER_ACTIVITY : eoEEP_A510xx.h
  • ROP_ROOM_TEMP_DEFINED : eoEEP_A510xx.h
  • ROP_USER_INTERACTION : eoEEP_A510xx.h
  • RORG_1BS : eoApiDef.h
  • RORG_4BS : eoApiDef.h
  • RORG_ADT : eoApiDef.h
  • RORG_CDM : eoApiDef.h
  • RORG_HRC : eoApiDef.h
  • RORG_MSC : eoApiDef.h
  • RORG_RECLAIM : eoApiDef.h
  • RORG_RPS : eoApiDef.h
  • RORG_SEC : eoApiDef.h
  • RORG_SEC_ENCAPS : eoApiDef.h
  • RORG_SEC_TI : eoApiDef.h
  • RORG_SECD : eoApiDef.h
  • RORG_SIGNAL : eoApiDef.h
  • RORG_SM_LRN_ANS : eoApiDef.h
  • RORG_SM_LRN_REQ : eoApiDef.h
  • RORG_SYS : eoApiDef.h
  • RORG_SYS_EX : eoApiDef.h
  • RORG_UTE : eoApiDef.h
  • RORG_VLD : eoApiDef.h
  • RUN_INTI_SEQ : eoEEP_A520xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • S_ACCEL : eoChannelEnums.h
  • S_ACCEL_ABS : eoChannelEnums.h
  • S_ACCEL_REL : eoChannelEnums.h
  • S_AMPER_PER_HOUR : eoChannelEnums.h
  • S_AMPER_PER_HOUR_ABS : eoChannelEnums.h
  • S_AMPER_PER_HOUR_REL : eoChannelEnums.h
  • S_ANGLE : eoChannelEnums.h
  • S_ANGLE_ABS : eoChannelEnums.h
  • S_ANGLE_REL : eoChannelEnums.h
  • S_ANGVD : eoChannelEnums.h
  • S_ANGVD_ABS : eoChannelEnums.h
  • S_ANGVD_REL : eoChannelEnums.h
  • S_AREA : eoChannelEnums.h
  • S_AREA_ABS : eoChannelEnums.h
  • S_AREA_REL : eoChannelEnums.h
  • S_CONC : eoChannelEnums.h
  • S_CONC_ABS : eoChannelEnums.h
  • S_CONC_REL : eoChannelEnums.h
  • S_COUNTER : eoChannelEnums.h
  • S_COUNTER_ABS : eoChannelEnums.h
  • S_COUNTER_REL : eoChannelEnums.h
  • S_CURRENT : eoChannelEnums.h
  • S_CURRENT_ABS : eoChannelEnums.h
  • S_CURRENT_REL : eoChannelEnums.h
  • S_DIMMING : eoChannelEnums.h
  • S_DIMMING_ABS : eoChannelEnums.h
  • S_DIMMING_REL : eoChannelEnums.h
  • S_DISTANCE : eoChannelEnums.h
  • S_DISTANCE_ABS : eoChannelEnums.h
  • S_DISTANCE_REL : eoChannelEnums.h
  • S_ELECFSTR : eoChannelEnums.h
  • S_ELECFSTR_ABS : eoChannelEnums.h
  • S_ELECFSTR_REL : eoChannelEnums.h
  • S_ENERGY : eoChannelEnums.h
  • S_ENERGY_ABS : eoChannelEnums.h
  • S_ENERGY_REL : eoChannelEnums.h
  • S_ERROR_CODE : eoChannelEnums.h
  • S_ERROR_CODE_ABS : eoChannelEnums.h
  • S_ERROR_CODE_REL : eoChannelEnums.h
  • S_FORCE : eoChannelEnums.h
  • S_FORCE_ABS : eoChannelEnums.h
  • S_FORCE_REL : eoChannelEnums.h
  • S_FREQ : eoChannelEnums.h
  • S_FREQ_ABS : eoChannelEnums.h
  • S_FREQ_REL : eoChannelEnums.h
  • S_HEATFLUX : eoChannelEnums.h
  • S_HEATFLUX_ABS : eoChannelEnums.h
  • S_HEATFLUX_REL : eoChannelEnums.h
  • S_IMPULSE : eoChannelEnums.h
  • S_IMPULSE_ABS : eoChannelEnums.h
  • S_IMPULSE_REL : eoChannelEnums.h
  • S_LUMINANCE : eoChannelEnums.h
  • S_LUMINANCE_ABS : eoChannelEnums.h
  • S_LUMINANCE_REL : eoChannelEnums.h
  • S_MAGNETICF : eoChannelEnums.h
  • S_MAGNETICF_ABS : eoChannelEnums.h
  • S_MAGNETICF_REL : eoChannelEnums.h
  • S_MASS : eoChannelEnums.h
  • S_MASS_ABS : eoChannelEnums.h
  • S_MASS_REL : eoChannelEnums.h
  • S_MASSDENS : eoChannelEnums.h
  • S_MASSDENS_ABS : eoChannelEnums.h
  • S_MASSDENS_REL : eoChannelEnums.h
  • S_MASSFLOW : eoChannelEnums.h
  • S_MASSFLOW_ABS : eoChannelEnums.h
  • S_MASSFLOW_REL : eoChannelEnums.h
  • S_PARTICLES : eoChannelEnums.h
  • S_PARTICLES_ABS : eoChannelEnums.h
  • S_PARTICLES_REL : eoChannelEnums.h
  • S_PERCENTAGE : eoChannelEnums.h
  • S_PERCENTAGE_ABS : eoChannelEnums.h
  • S_PERCENTAGE_REL : eoChannelEnums.h
  • S_POWER : eoChannelEnums.h
  • S_POWER_ABS : eoChannelEnums.h
  • S_POWER_REL : eoChannelEnums.h
  • S_PRESSURE : eoChannelEnums.h
  • S_PRESSURE_ABS : eoChannelEnums.h
  • S_PRESSURE_REL : eoChannelEnums.h
  • S_RADON_ACTIVITY : eoChannelEnums.h
  • S_RADON_ACTIVITY_ABS : eoChannelEnums.h
  • S_RADON_ACTIVITY_REL : eoChannelEnums.h
  • S_RELHUM : eoChannelEnums.h
  • S_RELHUM_ABS : eoChannelEnums.h
  • S_RELHUM_REL : eoChannelEnums.h
  • S_RES : eoChannelEnums.h
  • S_RESIST : eoChannelEnums.h
  • S_RESIST_ABS : eoChannelEnums.h
  • S_RESIST_REL : eoChannelEnums.h
  • S_RGB : eoChannelEnums.h
  • S_RGB_ABS : eoChannelEnums.h
  • S_RGB_REL : eoChannelEnums.h
  • S_ROTATION_PER_MIN : eoChannelEnums.h
  • S_ROTATION_PER_MIN_ABS : eoChannelEnums.h
  • S_ROTATION_PER_MIN_REL : eoChannelEnums.h
  • S_SETPOINT : eoChannelEnums.h
  • S_SETPOINT_ABS : eoChannelEnums.h
  • S_SETPOINT_REL : eoChannelEnums.h
  • S_SOLAR_RAD : eoChannelEnums.h
  • S_SOLAR_RAD_ABS : eoChannelEnums.h
  • S_SOLAR_RAD_REL : eoChannelEnums.h
  • S_TEMP : eoChannelEnums.h
  • S_TEMP_ABS : eoChannelEnums.h
  • S_TEMP_REL : eoChannelEnums.h
  • S_TIME : eoChannelEnums.h
  • S_TIME_ABS : eoChannelEnums.h
  • S_TIME_REL : eoChannelEnums.h
  • S_TORQUE : eoChannelEnums.h
  • S_TORQUE_ABS : eoChannelEnums.h
  • S_TORQUE_REL : eoChannelEnums.h
  • S_VALUE : eoChannelEnums.h
  • S_VALUE_ABS : eoChannelEnums.h
  • S_VALUE_REL : eoChannelEnums.h
  • S_VELOCITY : eoChannelEnums.h
  • S_VELOCITY_ABS : eoChannelEnums.h
  • S_VELOCITY_REL : eoChannelEnums.h
  • S_VOLFLOW : eoChannelEnums.h
  • S_VOLFLOW_ABS : eoChannelEnums.h
  • S_VOLFLOW_REL : eoChannelEnums.h
  • S_VOLTAGE : eoChannelEnums.h
  • S_VOLTAGE_ABS : eoChannelEnums.h
  • S_VOLTAGE_REL : eoChannelEnums.h
  • S_VOLUME : eoChannelEnums.h
  • S_VOLUME_ABS : eoChannelEnums.h
  • S_VOLUME_REL : eoChannelEnums.h
  • SA_CC_LEARNIN : eoSerialCommand.h
  • SA_CC_LEARNOUT : eoSerialCommand.h
  • SA_CONFIRM_LEARN : eoSerialCommand.h
  • SA_CONTROLLER_FULL : eoSerialCommand.h
  • SA_DUTYCYCLE_LIMIT : eoSerialCommand.h
  • SA_EEP_NOT_ACCEPTED : eoSerialCommand.h
  • SA_EL_ADVANCE : eoSerialCommand.h
  • SA_EL_ADVANCE_REP : eoSerialCommand.h
  • SA_EL_SIMPLE : eoSerialCommand.h
  • SA_LEARN_ACK : eoSerialCommand.h
  • SA_LEARN_IN : eoSerialCommand.h
  • SA_LEARN_OUT : eoSerialCommand.h
  • SA_NOT_SUPPORTED : eoSerialCommand.h
  • SA_PM_FULL : eoSerialCommand.h
  • SA_RD_LEARNEDCLIENTS : eoSerialCommand.h
  • SA_RD_LEARNMODE : eoSerialCommand.h
  • SA_READY : eoSerialCommand.h
  • SA_RECLAIM_NOT_SUCCESSFUL : eoSerialCommand.h
  • SA_RSSI_NOT_GOOD : eoSerialCommand.h
  • SA_WR_CLIENTLEARNRQ : eoSerialCommand.h
  • SA_WR_LEARNCONFIRM : eoSerialCommand.h
  • SA_WR_LEARNMODE : eoSerialCommand.h
  • SA_WR_POSTMASTER : eoSerialCommand.h
  • SA_WR_RECLAIMS : eoSerialCommand.h
  • SA_WR_RESET : eoSerialCommand.h
  • SAFTEY_MODE : eoEEP_D250xx.h
  • SATURDAY : eoEEP_A513xx.h
  • SEC_10 : eoEEP_A520xx.h
  • SEC_1020 : eoEEP_A520xx.h
  • SEC_1050 : eoEEP_A520xx.h
  • SEC_1080 : eoEEP_A520xx.h
  • SEC_1110 : eoEEP_A520xx.h
  • SEC_1140 : eoEEP_A520xx.h
  • SEC_1170 : eoEEP_A520xx.h
  • SEC_120 : eoEEP_A520xx.h
  • SEC_1200 : eoEEP_A520xx.h
  • SEC_1230 : eoEEP_A520xx.h
  • SEC_1260 : eoEEP_A520xx.h
  • SEC_1290 : eoEEP_A520xx.h
  • SEC_1320 : eoEEP_A520xx.h
  • SEC_1350 : eoEEP_A520xx.h
  • SEC_1380 : eoEEP_A520xx.h
  • SEC_1410 : eoEEP_A520xx.h
  • SEC_1440 : eoEEP_A520xx.h
  • SEC_1470 : eoEEP_A520xx.h
  • SEC_150 : eoEEP_A520xx.h
  • SEC_1500 : eoEEP_A520xx.h
  • SEC_180 : eoEEP_A520xx.h
  • SEC_210 : eoEEP_A520xx.h
  • SEC_240 : eoEEP_A520xx.h
  • SEC_270 : eoEEP_A520xx.h
  • SEC_300 : eoEEP_A520xx.h
  • SEC_330 : eoEEP_A520xx.h
  • SEC_360 : eoEEP_A520xx.h
  • SEC_390 : eoEEP_A520xx.h
  • SEC_420 : eoEEP_A520xx.h
  • SEC_450 : eoEEP_A520xx.h
  • SEC_480 : eoEEP_A520xx.h
  • SEC_510 : eoEEP_A520xx.h
  • SEC_540 : eoEEP_A520xx.h
  • SEC_570 : eoEEP_A520xx.h
  • SEC_60 : eoEEP_A520xx.h
  • SEC_600 : eoEEP_A520xx.h
  • SEC_630 : eoEEP_A520xx.h
  • SEC_660 : eoEEP_A520xx.h
  • SEC_690 : eoEEP_A520xx.h
  • SEC_720 : eoEEP_A520xx.h
  • SEC_750 : eoEEP_A520xx.h
  • SEC_780 : eoEEP_A520xx.h
  • SEC_810 : eoEEP_A520xx.h
  • SEC_840 : eoEEP_A520xx.h
  • SEC_870 : eoEEP_A520xx.h
  • SEC_90 : eoEEP_A520xx.h
  • SEC_900 : eoEEP_A520xx.h
  • SEC_930 : eoEEP_A520xx.h
  • SEC_960 : eoEEP_A520xx.h
  • SEC_990 : eoEEP_A520xx.h
  • SECOND_TEACH_IN : eoTeachInModule.h
  • SECURITY_TEACH_IN : eoTeachInModule.h
  • SELECT_FUNCTION : eoEEP_A520xx.h
  • SENSOR_INTERVAL : eoEEP_D206xx.h
  • SENSOR_MEASUREMENT : eoEEP_D202xx.h
  • SENSOR_QUERY : eoEEP_D202xx.h
  • SENSOR_TEST_TRIGGER : eoEEP_D202xx.h
  • SERVICE_INFO : eoEEP_D220xx.h
  • SERVICE_ON : eoEEP_A520xx.h
  • SET_ANGLE : eoEEP_A538xx.h
  • SET_LOGIC_POS : eoEEP_A538xx.h
  • SET_MIN_MAX : eoEEP_A538xx.h
  • SET_PARAM_MSG : eoEEP_D205xx.h
  • SET_POINT_INVERSE : eoEEP_A520xx.h
  • SET_POINT_SELECTION : eoEEP_A520xx.h
  • SET_ROT_DURATION : eoEEP_D205xx.h
  • SET_RUNTIME_PARAM : eoEEP_A538xx.h
  • SET_SLAT_ANGLE : eoEEP_A538xx.h
  • SET_VER_DURATION : eoEEP_D205xx.h
  • SMOKE_BOTH : eoEEP_D202xx.h
  • SMOKE_IONIZATION : eoEEP_D202xx.h
  • SMOKE_OPTICAL : eoEEP_D202xx.h
  • SOLAR_POWERED : eoEEP_D210xx.h
  • SOLAR_POWERED_STATUS : eoEEP_D210xx.h
  • SOURCE_ID : eoSerialCommand.h
  • SOUTH : eoEEP_A513xx.h
  • SPEED_0 : eoA5EEProfile.h
  • SPEED_1 : eoA5EEProfile.h
  • SPEED_2 : eoA5EEProfile.h
  • SPEED_3 : eoA5EEProfile.h
  • SPEED_4 : eoA5EEProfile.h
  • SPEED_5 : eoA5EEProfile.h
  • SPEED_AUTO : eoA5EEProfile.h
  • SPEED_LEVEL_0 : eoEEP_D200xx.h
  • SPEED_LEVEL_1 : eoEEP_D200xx.h
  • SPEED_LEVEL_2 : eoEEP_D200xx.h
  • SPEED_LEVEL_3 : eoEEP_D200xx.h
  • SPEED_LEVEL_AUTO : eoEEP_D200xx.h
  • SPEED_OFF : eoA5EEProfile.h
  • STAGE_0 : eoA5EEProfile.h
  • STAGE_0_AUTO : eoEEP_A511xx.h
  • STAGE_0_MANUAL : eoEEP_A511xx.h
  • STAGE_1 : eoA5EEProfile.h
  • STAGE_1_AUTO : eoEEP_A511xx.h
  • STAGE_1_MANUAL : eoEEP_A511xx.h
  • STAGE_2 : eoA5EEProfile.h
  • STAGE_2_AUTO : eoEEP_A511xx.h
  • STAGE_2_MANUAL : eoEEP_A511xx.h
  • STAGE_3 : eoA5EEProfile.h
  • STAGE_3_AUTO : eoEEP_A511xx.h
  • STAGE_3_MANUAL : eoEEP_A511xx.h
  • STAGE_AUTO : eoA5EEProfile.h
  • STANDBY : eoEEP_A511xx.h
  • START_TIME_HOUR : eoEEP_D210xx.h
  • START_TIME_MINUTE : eoEEP_D210xx.h
  • START_TRANSMISSION_CONFIG_SETTINGS : eoEEP_D206xx.h
  • START_TRANSMISSION_LOG_DATA : eoEEP_D206xx.h
  • STATE_I : eoF6EEProfile.h
  • STATE_IO : eoF6EEProfile.h
  • STATE_NP : eoF6EEProfile.h
  • STATE_O : eoF6EEProfile.h
  • STATE_OFF : eoEEP_D201xx.h
  • STATE_ON : eoEEP_D201xx.h
  • STATUS_NO_CHANGE : eoEEP_A520xx.h
  • STATUS_REASON : eoEEP_D240xx.h
  • STATUS_REQUEST : eoEEP_A520xx.h
  • STATUS_REQUESTED : eoEEP_A520xx.h
  • STATUS_WAKE : eoEEP_A530xx.h
  • STOP_BLIND : eoEEP_A538xx.h
  • STOP_MSG : eoEEP_D205xx.h
  • SUMMER_BIT : eoEEP_A520xx.h
  • SUN_EAST : eoEEP_A513xx.h
  • SUN_SOUTH : eoEEP_A513xx.h
  • SUN_WEST : eoEEP_A513xx.h
  • SUNDAY : eoEEP_A513xx.h
  • SUPPLY_AIR_POS : eoEEP_D250xx.h
  • SUPPLY_FAN_RATE : eoEEP_D250xx.h
  • SUPPLY_FAN_SPEED : eoEEP_D250xx.h
  • SUPPLY_HEATER_STATUS : eoEEP_D250xx.h
  • SUPPLY_TEMP : eoEEP_D250xx.h
  • SW_VERSION : eoEEP_D250xx.h
  • SWITCH_TO_NEW : eoEEP_D201xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • TAUGHT_IN_DEVICES : eoEEP_D201xx.h
  • TEACH_IN_ACCEPTED : eoTeachInModule.h
  • TEACH_IN_ERROR : eoEEP_A520xx.h
  • TEACH_OUT_ACCEPTED : eoTeachInModule.h
  • TEL_REPETITION_FEEDBACK : eoEEP_D210xx.h
  • TEMP_DOWN : eoEEP_D200xx.h
  • TEMP_LEVEL : eoEEP_D220xx.h
  • TEMP_LEVEL_HIGH : eoEEP_D220xx.h
  • TEMP_LEVEL_LOW : eoEEP_D220xx.h
  • TEMP_LEVEL_NO_CHANGE : eoEEP_D220xx.h
  • TEMP_LEVEL_NORMAL : eoEEP_D220xx.h
  • TEMP_LOCK : eoEEP_D210xx.h
  • TEMP_SCALE : eoEEP_D210xx.h
  • TEMP_SCALE_CELSIUS : eoEEP_D210xx.h
  • TEMP_SCALE_DEFAULT : eoEEP_D210xx.h
  • TEMP_SCALE_FAHRENHEIT : eoEEP_D210xx.h
  • TEMP_SCALE_NO_CHANGE : eoEEP_D210xx.h
  • TEMP_SELECTION : eoEEP_A520xx.h
  • TEMP_SETPOINT_LOCK : eoEEP_D210xx.h
  • TEMP_SETPOINT_SELECT : eoEEP_A520xx.h
  • TEMP_SETPOINT_VALIDITY : eoEEP_D210xx.h
  • TEMP_UP : eoEEP_D200xx.h
  • TEMP_VALIDITY : eoEEP_D210xx.h
  • TEMPERATURE_FAIL : eoEEP_A520xx.h
  • THURSDAY : eoEEP_A513xx.h
  • TIME_AM : eoEEP_A513xx.h
  • TIME_CURRENT_DAY : eoEEP_D210xx.h
  • TIME_CURRENT_HOUR : eoEEP_D210xx.h
  • TIME_CURRENT_MINUTE : eoEEP_D210xx.h
  • TIME_CURRENT_MONTH : eoEEP_D210xx.h
  • TIME_CURRENT_YEAR : eoEEP_D210xx.h
  • TIME_DAY : eoEEP_A513xx.h
  • TIME_FORMAT : eoEEP_A513xx.h
  • TIME_HOUR : eoEEP_A513xx.h
  • TIME_MINUTE : eoEEP_A513xx.h
  • TIME_MONTH : eoEEP_A513xx.h
  • TIME_NOTATION : eoEEP_D210xx.h
  • TIME_NOTATION_12_HOURS : eoEEP_D210xx.h
  • TIME_NOTATION_24_HOURS : eoEEP_D210xx.h
  • TIME_NOTATION_DEFAULT : eoEEP_D210xx.h
  • TIME_NOTATION_NO_CHANGE : eoEEP_D210xx.h
  • TIME_OUT : eoApiDef.h
  • TIME_PM : eoEEP_A513xx.h
  • TIME_PROG_DELETE : eoEEP_D210xx.h
  • TIME_PROG_DELETION : eoEEP_D210xx.h
  • TIME_PROG_LOCK : eoEEP_D210xx.h
  • TIME_PROG_MSG : eoEEP_D210xx.h
  • TIME_PROG_NO_DELETE : eoEEP_D210xx.h
  • TIME_PROG_REQUEST : eoEEP_D210xx.h
  • TIME_SECOND : eoEEP_A513xx.h
  • TIME_SOURCE : eoEEP_A513xx.h
  • TIME_YEAR : eoEEP_A513xx.h
  • TIMER_OP_CTRL : eoEEP_D250xx.h
  • TIMER_OP_CTRL_STATUS : eoEEP_D250xx.h
  • TUESDAY : eoEEP_A513xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • UNLOCK_LOCAL_OP : eoEEP_A538xx.h
  • UNLOCKED : eoEEP_D210xx.h
  • UNOCCUPANCY : eoEEP_A510xx.h
  • UNOCCUPIED : eoEEP_A511xx.h
  • USER_CMD : eoApiDef.h
  • USER_INDICATION : eoEEP_D201xx.h
  • USV_H : eoEEP_A509xx.h
  • UTE_DIRECTION_BIDIRECTIONAL : eoTeachInModule.h
  • UTE_DIRECTION_UNIDIRECTIONAL : eoTeachInModule.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • V_1_10 : eoEEP_A538xx.h
  • VACATION_INTERVAL : eoEEP_D206xx.h
  • VACATION_MODE : eoEEP_D206xx.h
  • VALIDITY_NO_CHANGE : eoEEP_D210xx.h
  • VALIDITY_VALID_VALUE : eoEEP_D210xx.h
  • VALVE_CLOSED : eoEEP_A520xx.h
  • VALVE_OPEN : eoEEP_A520xx.h
  • VALVE_REQUEST_CLOSE : eoEEP_D2A0xx.h
  • VALVE_REQUEST_CLOSE_2 : eoEEP_D2A0xx.h
  • VALVE_REQUEST_FEEDBACK : eoEEP_D2A0xx.h
  • VALVE_REQUEST_OPEN : eoEEP_D2A0xx.h
  • VALVE_STATUS_CLOSED : eoEEP_D2A0xx.h
  • VALVE_STATUS_OPENED : eoEEP_D2A0xx.h
  • VALVE_TO_CONTROLLER : eoEEP_D2A0xx.h
  • VANE_AUTO : eoEEP_A520xx.h
  • VANE_BOTH_SWING : eoEEP_A520xx.h
  • VANE_HORIZ_SWING : eoEEP_A520xx.h
  • VANE_HORIZONTAL : eoEEP_A520xx.h
  • VANE_POS_2 : eoEEP_A520xx.h
  • VANE_POS_3 : eoEEP_A520xx.h
  • VANE_POS_4 : eoEEP_A520xx.h
  • VANE_STOP_SWING : eoEEP_A520xx.h
  • VANE_SWING : eoEEP_A520xx.h
  • VANE_VERT_SWING : eoEEP_A520xx.h
  • VANE_VERTICAL : eoEEP_A520xx.h
  • VENTILATION_BASIC : eoEEP_D250xx.h
  • VENTILATION_BASIC_STATUS : eoEEP_D250xx.h
  • VENTILATION_CONTROL : eoEEP_D250xx.h
  • VENTILATION_EXTENDED : eoEEP_D250xx.h
  • VENTILATION_EXTENDED_STATUS : eoEEP_D250xx.h
  • VENTILATION_REQUEST : eoEEP_D250xx.h
  • VLD_MAX_TIME : eoEEP_D202xx.h
  • VLD_MIN_TIME : eoEEP_D202xx.h
  • VLD_REPORT_MEASUREMENT : eoEEP_D202xx.h
  • VLD_SELF_TEST : eoEEP_D202xx.h
  • VLD_TRIGGER_ALARM : eoEEP_D202xx.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • W : eoEEP_A538xx.h
  • WAKEUP_CYCLE : eoEEP_A520xx.h
  • WATCH_CMAC_OVERFLOW : eoWatcher.h
  • WATCH_DELAY_ASSUMED : eoWatcher.h
  • WATCH_DEVICE_ALREADY_EXIST : eoWatcher.h
  • WATCH_DEVICE_NA : eoWatcher.h
  • WATCH_DOS_ASSUMED : eoWatcher.h
  • WATCH_NOT_SECURE_DEVICE : eoWatcher.h
  • WATCH_NOT_WATCHED_DEVICE : eoWatcher.h
  • WATCH_OK : eoWatcher.h
  • WATCH_RLC_OVERFLOW : eoWatcher.h
  • WATCH_TEL_TO_EARLY : eoWatcher.h
  • WATCH_TEL_TO_LATE : eoWatcher.h
  • WATER_DETECTED : eoF6EEProfile.h
  • WEDNESDAY : eoEEP_A513xx.h
  • WEEKLY_PROGRAM : eoEEP_D250xx.h
  • WH : eoEEP_A538xx.h
  • WINDOW_CLOSED : eoEEP_D210xx.h
  • WINDOW_DETECTION : eoEEP_A520xx.h
  • WINDOW_DISABLEMENT : eoEEP_A520xx.h
  • WINDOW_DOWN : eoF6EEProfile.h
  • WINDOW_MIDDLE : eoF6EEProfile.h
  • WINDOW_NO_CHANGE : eoEEP_D210xx.h
  • WINDOW_OPEN : eoEEP_D210xx.h
  • WINDOW_OPEN_DETECTION : eoEEP_D210xx.h
  • WINDOW_STATE : eoEEP_D206xx.h
  • WINDOW_TILTS : eoEEP_D206xx.h
  • WINDOW_UP : eoF6EEProfile.h
  • WORKING_MODE_1 : eoEEP_A511xx.h
  • WORKING_MODE_2 : eoEEP_A511xx.h
  • WORKING_MODE_3 : eoEEP_A511xx.h
  • WORKING_MODE_4 : eoEEP_A511xx.h
  • WRONG_PARAM : eoApiDef.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: File Members

  • File List
  • File Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • b
  • e
  • g
  • m
  • n
  • s
  • t
  • u

- _ -

  • _ARCHIVE_TYPE_NAME : eoArchiveTXT.h
  • _ARCHIVE_VER_MAJOR : eoArchiveTXT.h
  • _ARCHIVE_VER_MINOR : eoArchiveTXT.h

- b -

  • BROADCAST_ID : eoApiDef.h

- e -

  • EO_STORAGE_IDENTIFIER : eoStorageManager.h

- g -

  • GP_DATA_DIRECTION_LEN : eoGenericProfile.h
  • GP_DATA_DIRECTION_OFF : eoGenericProfile.h
  • GP_ENUM : eoChannelEnums.h
  • GP_MANUFACTURER_LEN : eoGenericProfile.h
  • GP_MANUFACTURER_OFF : eoGenericProfile.h
  • GP_PURPOSE_LEN : eoGenericProfile.h
  • GP_PURPOSE_OFF : eoGenericProfile.h

- m -

  • MINIMUM_ADVANCED_DATA_LENGTH : eoConverter.h

- n -

  • NAME : eoChannelInfo.h
  • NULL : eoHalTypes.h
  • NUM_ENUMS_STRINGS : eoChannelEnums.h
  • NUM_FLAG_STRINGS : eoChannelEnums.h
  • NUM_GP_ENUMS_STRING : eoChannelEnums.h
  • NUM_SIGNAL_STRINGS : eoChannelEnums.h

- s -

  • SA_RECLAIM_DATA_LENGTH : eoConverter.h
  • SER_HEADER_NR_BYTES : eoPacketStream.h
  • SER_INTERBYTE_TIME_OUT : eoPacketStream.h
  • SER_SYNCH_CODE : eoPacketStream.h
  • SLF_DATA_ENC_AES128 : eoSecureInfo.h
  • SLF_DATA_ENC_OFF : eoSecureInfo.h
  • SLF_DATA_ENC_VAES128 : eoSecureInfo.h
  • SLF_MAC_3BYTE : eoSecureInfo.h
  • SLF_MAC_4BYTE : eoSecureInfo.h
  • SLF_MAC_OFF : eoSecureInfo.h
  • SLF_RLC_ALGO_16BIT : eoSecureInfo.h
  • SLF_RLC_ALGO_24BIT : eoSecureInfo.h
  • SLF_RLC_ALGO_OFF : eoSecureInfo.h
  • SLF_RLC_TX_OFF : eoSecureInfo.h
  • SLF_RLC_TX_ON : eoSecureInfo.h
  • SP_ABS : eoChannelEnums.h
  • SP_REL : eoChannelEnums.h

- t -

  • T_DATA : eoChannelEnums.h
  • T_ENUM : eoChannelEnums.h
  • T_FLAG : eoChannelEnums.h
  • TEACH_INFO_BIDIR : eoSecureInfo.h
  • TEACH_INFO_PSK : eoSecureInfo.h
  • TEACH_INFO_PTM : eoSecureInfo.h
  • TEACH_INFO_PTM_ROCKERA : eoSecureInfo.h
  • TEACH_INFO_PTM_ROCKERB : eoSecureInfo.h
  • TEACH_INFO_UNIDIR : eoSecureInfo.h

- u -

  • UNIT : eoChannelInfo.h
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Examples

Examples
Here is a list of all examples:
  • commands_example.cpp
  • deviceManager_example.cpp
  • Gateway_example.cpp
  • Gateway_SubtypeExample.cpp
  • GatewayFiltered_example.cpp
  • genericProfile_examples.cpp
  • HelloWorld.cpp
  • linuxPacketStream_example.cpp
  • packetStream_example.cpp
  • profile_examples.cpp
  • Security_example.cpp
  • sendTelegram_example.cpp
  • storage_example.cpp
  • tutorial1.cpp
  • tutorial2.cpp
  • tutorial3.cpp
  • tutorial4.cpp
  • tutorial5.cpp
  • tutorial6.cpp
  • vld_example.cpp
  • WatcherMain.cpp
Generated on Wed Nov 18 2015 17:24:51 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: commands_example.cpp

commands_example.cpp
/*
File: commands_example.cpp
brief
Example Program which uses eoCommonCommand to set and receive settings from the tcm300 module
*/
#define SER_PORT "/dev/ttyUSB0"
#define SAVE_CONFIG "./learned.txt"
#include "./eoLink.h"
#include <stdio.h>
int commands_example() {
eoGateway gateway; //= eoGateway();
//adding eoIDFilter to the gateWay
if (gateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return -1;
}
eoSerialCommand cmd(&gateway);
//Read Sw and HW version of the device
CO_RD_VERSION_RESPONSE version;
if (cmd.ReadVersion(version) == EO_OK)
{
printf("%s %i.%i.%i.%i, ID:0x%08X on %s\n",
version.appDescription,
version.appVersion[0], version.appVersion[1], version.appVersion[2], version.appVersion[3],
version.chipID,
SER_PORT);
}
//Failed to read the version of the device
else
{
printf("Failed to retrieve USB300 version\n");
return -1;
}
//Perform a built in self test
if (cmd.BIST() == EO_OK)
printf ("Successful BIST performed!\n");
//Failed BIST
else
{
printf("Failed to perform BIST\n");
return -1;
}
//Read device ID base
CO_RD_IDBASE_RESPONSE baseID;
if (cmd.ReadIDBase(baseID) == EO_OK)
printf("Base ID: %08X, %i writes left\n", baseID.baseID, baseID.remainingWrites);
else
{
printf("Failed to retrieve USB300 base ID\n");
return -1;
}
//Write repeater
uint8_t repLevel = 1;
if (cmd.WriteRepeater(true, repLevel) == EO_OK)
printf("Repeater added!\n");
else
{
printf("Failed to add repeater\n");
return -1;
}
//Read repeater
CO_RD_REPEATER_RESPONSE repeater;
if (cmd.ReadRepeater(repeater) == EO_OK)
printf("Enabled: %s, Level: %i\n", repeater.repEnable ? "true":"false", repeater.repLevel);
else
{
printf("Failed to read repetear\n");
return -1;
}
//Add filter
if (cmd.AddFilter(CHOICE,0x11223344, BLOCK_RADIO) == EO_OK)
printf("Filter added!\n");
else
{
printf("Failed to add filter\n");
return -1;
}
//Read filter
CO_RD_FILTER_RESPONSE filter[1];
uint8_t filterCount;
if (cmd.ReadFilter(filter, &filterCount, 1) == EO_OK)
printf("Filter type: %i, Filter value: 0x%08X\n", filter[0].filterType, filter[0].filterValue);
else
{
printf("Failed to read filter\n");
return -1;
}
//Delete filter
if (cmd.DeleteFilter(CHOICE, 0x11223344) == EO_OK)
printf("Filter deleted\n");
else
{
printf("Failed to delete filter\n");
return -1;
}
//Enable filter
if (cmd.EnableFilter(true, OR) == EO_OK)
printf("Filter enabled\n");
else
{
printf("Failed to enable filter\n");
return -1;
}
//Delete all filter
if (cmd.DeleteAllFilter() == EO_OK)
printf("All filter has been deleted!\n");
else
{
printf("Failed to delete all filter\n");
return -1;
}
//Wait maturity time
if (cmd.WaitMaturity(true) == EO_OK)
printf("Maturity turned on\n");
else
{
printf("Failed to turn on maturity\n");
return -1;
}
return 0;
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: deviceManager_example.cpp

deviceManager_example.cpp
/*
File: deviceManager_example.cpp
Example Program which creates a DeviceManager, and adds some Devices, modifies a Device and then deletes a Device;
*/
#include "eoLink.h"
#include <stdio.h>
void deviceManagerExample()
{
printf("Example Program which creates a Device, and queries for it\n");
eoDeviceManager myDeviceManager = eoDeviceManager();
eoDevice * myDevice;
/*
* Adding some devices
*/
myDeviceManager.Add(0x80C0001);
myDeviceManager.Add(0x80C0002);
myDeviceManager.Add(0x80C0003);
//Add also returns a pointer to the Device
myDevice = myDeviceManager.Add(0x80C0004);
//Now we change the value of the Device
printf("Last inserted id was 0x%08X\n",myDevice->ID);
printf("Changing the dBm value to 32 and then we try to add the same device again\n");
myDevice->dBm=32;
//If we try to add the same Device again, the function returns a pointer to the existing Device
myDevice = myDeviceManager.Add(0x80C0004);
//As the Device already existed we get the already changed dBm
printf("Id is: 0x%08X dBm %d\n",myDevice->ID,myDevice->dBm);
myDevice = myDeviceManager.Get(0x80C0002);
//always check for NULL when using .Get()
if(myDevice!=NULL)
printf("ID should be 0x80C0002 and the ID is 0x%08X\n",myDevice->ID);
//This device does not exist
myDevice = myDeviceManager.Get(0x80C0005);
if(myDevice!=NULL)
printf("This should not happen, as we get a NULL pointer if the device doesn't exist\n");
else
printf("The device 0x80C0005 does not exist!\n");
//Now we remove an existing Device
myDeviceManager.Remove(0x80C0004);
myDevice = myDeviceManager.Get(0x80C0004);
if(myDevice!=NULL)
printf("And this also does not happen\n");
else
printf("The device 0x80C0004 has been deleted!\n");
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Gateway_example.cpp

Gateway_example.cpp
/*
File: Gateway_example.cpp
Example Program which opens a connection to the connected device, and handles received packages.
*/
#define SER_PORT "/dev/ttyUSB1"
#include "./eoLink.h"
#include <stdio.h>
//Testing main.c
void gatewayExample()
{
eoGateway gateway;
uint16_t recv;
if (gateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return ;
}
printf("EnOcean-Link Gateway\n");
//we set now the automatic RPS-Teach-IN information
gateway.TeachInModule->SetRPS(0x02,0x01);
//Activate LearnMode
gateway.LearnMode=true;
while (1)
{
//eoGateway is normally in LearnMode, to unset LearnMode, set LearnMode to false
//gateway.LearnMode=false;
recv = gateway.Receive();
if (recv & RECV_TELEGRAM)
{
eoDebug::Print(gateway.telegram);
}
else
{
if (recv & RECV_PACKET)
eoDebug::Print(gateway.packet);
}
if ((recv & RECV_TEACHIN))
{
eoProfile *profile = gateway.device->GetProfile();
printf("Device %08X Learned-In EEP: %02X-%02X-%02X\n", gateway.device->ID, profile->rorg, profile->func, profile->type );
for (int i = 0; i<profile->GetChannelCount(); i++)
{
printf("%s %.2f ... %.2f %s\n", profile->GetChannel(i)->ToString(NAME), profile->GetChannel(i)->min, profile->GetChannel(i)->max, profile->GetChannel(i)->ToString(UNIT));
}
}
if (recv & RECV_PROFILE)
{
printf("Device %08X\n", gateway.device->ID);
eoProfile *profile = gateway.device->GetProfile();
float f;
uint8_t t;
for (int i = 0; i<profile->GetChannelCount(); i++)
{
if (profile->GetValue( profile->GetChannel(i)->type, f) ==EO_OK)
printf("%s %.2f %s\n", profile->GetChannel(i)->ToString(NAME),f,profile->GetChannel(i)->ToString(UNIT));
if (profile->GetValue( profile->GetChannel(i)->type, t) ==EO_OK)
printf("%s %u \n", profile->GetChannel(i)->ToString(NAME),t);
}
}
}
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Gateway_SubtypeExample.cpp

Gateway_SubtypeExample.cpp
/*
File: Gateway_SubtypeExample.cpp
Example Program which opens a connection to the connected device, and handles received packages.
*/
#define SER_PORT "/dev/ttyUSB1"
#include "./eoLink.h"
#include <stdio.h>
#include <list>
#include <algorithm>
//Testing main.c
void gatewaySubtypeExample()
{
eoGateway gateway;
uint16_t recv;
if (gateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return ;
}
printf("EnOcean-Link Gateway\n");
//we set now the automatic RPS-Teach-IN information
gateway.TeachInModule->SetRPS(0x02,0x01);
//Activate LearnMode
gateway.LearnMode=true;
while (1)
{
//eoGateway is normally in LearnMode, to unset LearnMode, set LearnMode to false
//gateway.LearnMode=false;
recv = gateway.Receive();
if (recv & RECV_TELEGRAM)
{
eoDebug::Print(gateway.telegram);
}
else
{
if (recv & RECV_PACKET)
eoDebug::Print(gateway.packet);
}
if ((recv & RECV_TEACHIN))
{
eoProfile *profile = gateway.device->GetProfile();
printf("Device %08X Learned-In EEP: %02X-%02X-%02X\n", gateway.device->ID, profile->rorg, profile->func, profile->type );
for (int i = 0; i<profile->GetChannelCount(); i++)
{
printf("%s %.2f ... %.2f %s\n", profile->GetChannel(i)->ToString(NAME), profile->GetChannel(i)->min, profile->GetChannel(i)->max, profile->GetChannel(i)->ToString(UNIT));
}
}
if (recv & RECV_PROFILE)
{
printf("Device %08X\n", gateway.device->ID);
eoProfile *profile = gateway.device->GetProfile();
float f;
uint8_t c;
std::list <CHANNEL_TYPE> typeList;
for (int i = 0; i<profile->GetChannelCount(); i++)
{
//Check if the found channel has been before
if (typeList.end() != std::find(typeList.begin(), typeList.end(), profile->GetChannel(i)->type))
continue;
std::vector< eoEEPChannelInfo * > subTypes;
profile->GetSubTypeChannel(profile->GetChannel(i)->type,subTypes);
//Loop through the subtype channels
for (std::vector< eoEEPChannelInfo * >::iterator it=subTypes.begin();it<subTypes.end();it++)
{
//Find the channel with subtype
eoEEPChannelInfo* chan = *it;
if (profile->GetValue(chan->eepItem->type,f,chan->eepItem->index) == EO_OK)
printf("%s %.2f %s\n", chan->ToString(NAME),f,chan->ToString(UNIT));
if (profile->GetValue(chan->eepItem->type,c,chan->eepItem->index) == EO_OK)
printf("%s %u \n", chan->ToString(NAME),c);
}
//Save it so not checking the same channel more than once
typeList.push_back(profile->GetChannel(i)->type);
}
}
}
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: GatewayFiltered_example.cpp

GatewayFiltered_example.cpp
/*
File: GatewayFiltered_example.cpp
This example, shows you how to implement a gateway, which is in learnMode in the first 10seconds after Starting Up.
Using the an eodBmFilter as LearnFilter, only near field telegrams are used to learn IN.
For rps we add manually an EEP.
All the learned IN Devices will be added to an eoIDFilter, and used in the normal mode, to filter out other Devices.
*/
#define SER_PORT "/dev/ttyUSB0"//this has to be changed accordingly to your pc/embedded system
#include "./eoLink.h"
#include <stdio.h>
void gatewayFitleredExample()
{
eoGateway gateway;
//adding eoIDFilter to the gateWay
eoIDFilter* myFilter = new eoIDFilter();
gateway.filter=myFilter;
uint32_t learnTime;
uint16_t recv;
if (gateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return ;
}
printf("EnOcean-Link Gateway LearnMode\n");
//we set now the automatic RPS-Teach-IN information to RPS-Rocker
gateway.TeachInModule->SetRPS(0x02,0x01);
//100sec learnmode
learnTime=eoTimer::GetTickCount()+1000*10;
uint32_t time=eoTimer::GetTickCount();
//adding a dBm Filter as learnFilter
eodBmFilter* learnFilter = new eodBmFilter();
gateway.learnFilter = learnFilter;
learnFilter->maxdBm=-0;
learnFilter->mindBm=-60;
//Activate LearnMode
gateway.LearnMode=true;
while(learnTime>time)
{
time=eoTimer::GetTickCount();
recv = gateway.Receive();
if (recv & RECV_TEACHIN)
{
myFilter->Add(gateway.telegram.sourceID);
eoDebug::Print(gateway.telegram);
//print teach_in Information
eoProfile *profile = gateway.device->GetProfile();
if(profile!=NULL)
{
printf("Device %08X Learned-In EEP: %02X-%02X-%02X\n", gateway.device->ID, profile->rorg, profile->func, profile->type );
for (int i = 0; i<profile->GetChannelCount(); i++)
{
printf("%s %.2f ... %.2f %s\n", profile->GetChannel(i)->ToString(NAME), profile->GetChannel(i)->min, profile->GetChannel(i)->max, profile->GetChannel(i)->ToString(UNIT));
}
}
}
}
gateway.LearnMode=false;
printf("EnOcean-Link Gateway FilterdMode\n");
while (1)
{
recv = gateway.Receive();
if (recv & RECV_PROFILE)
{
printf("Device %08X\n", gateway.device->ID);
eoProfile *profile = gateway.device->GetProfile();
float f;
uint8_t t;
for (int i = 0; i<profile->GetChannelCount(); i++)
{
//get the channel value if it is a float
if (profile->GetValue( profile->GetChannel(i)->type, f) ==EO_OK)
printf("%s %.2f %s\n", profile->GetChannel(i)->ToString(NAME),f,profile->GetChannel(i)->ToString(UNIT));
//get the channel value if it is an uint
if (profile->GetValue( profile->GetChannel(i)->type, t) ==EO_OK)
printf("%s %u \n", profile->GetChannel(i)->ToString(NAME),t);
}
}
else if (recv & RECV_TELEGRAM)
{
eoDebug::Print(gateway.telegram);
}
}
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: genericProfile_examples.cpp

genericProfile_examples.cpp
/*
File: genericProfile_example.cpp
Example Program which creates a generic Profile, with some Channels.
*/
#include "./eoLink.h"
#include <stdio.h>
#define SER_PORT "/dev/ttyUSB0"//this has to be changed accordingly to your pc/embedded system
void genericProfileExamples() {
eoMessage msg(511);
/*In the first step we create a new GenericProfile class, as
* Generic Profile messages can be quite big so we reserve a big internal message space
*/
eoGenericProfile *gpProf = new eoGenericProfile(64);
if (gpProf == NULL) {
printf("Unable to create GenericProfile");
return;
}
printf("Created a new GP, trying to add some Channels\n");
//Adding some inbound channels
//These channels are not supported in SetValue function as they are inbound channels!
//now we add some Temperature Channels
if (gpProf->AddChannel(S_TEMP, GP_RES_8BIT, 40, 0, GP_SCAL_1, GP_SCAL_1,
VAL_CURR) != EO_OK) {
printf("Failed to add the first Temperature Channel");
return;
}
if (gpProf->AddChannel(S_TEMP, GP_RES_16BIT, 20, -20, GP_SCAL_1, GP_SCAL_1,
VAL_CURR) != EO_OK) {
printf("Failed to add the second Temperature Channel");
return;
}
//and a Flag CHannel
if (gpProf->AddChannel(F_GENALARM, VAL_CURR) != EO_OK) {
printf("Failed to add the Alarm Flag Channel");
return;
}
//now we just print the Channel Information again
for (int i = 0; i < gpProf->GetChannelCount(); i++) {
printf("%s %.2f ... %.2f %s\n", gpProf->GetChannel(i)->ToString(NAME),
gpProf->GetChannel(i)->min, gpProf->GetChannel(i)->max,
gpProf->GetChannel(i)->ToString(UNIT));
}
//We now add the outbound channels
//add a temperature channel
if (gpProf->AddChannelOut(S_TEMP, GP_RES_8BIT, 30, -10, GP_SCAL_1,
GP_SCAL_1, VAL_CURR) != EO_OK) {
printf("Failed to add the first Temperature Channel");
return;
}
//and an On/Off Flag CHannel
if (gpProf->AddChannelOut(F_ON_OFF, VAL_CURR) != EO_OK) {
printf("Failed to add the On/Off Flag Channel");
return;
}
//now we just print the Channel Information again
for (int i = 0; i < gpProf->GetChannelCountOut(); i++) {
printf("%s %.2f ... %.2f %s\n", gpProf->GetChannel(i)->ToString(NAME),
gpProf->GetChannel(i)->min, gpProf->GetChannel(i)->max,
gpProf->GetChannel(i)->ToString(UNIT));
}
//afterwards we can create a TeachIN message
if (gpProf->CreateTeachIN(msg) != EO_OK) {
printf("Teach IN creation failed");
return;
}
eoDebug::Print(msg);
//Clear Values and set Message to rigth type
gpProf->ClearValues();
//Set the values for the outbound channels
gpProf->SetValue(S_TEMP, (float) 20);
gpProf->SetValue(F_ON_OFF, (uint8_t) 1);
//now we have a prepares message with the flags
gpProf->Create(msg);
eoDebug::Print(msg);
}
void genericProfileWorkingExamples() {
/*
* This example is a working example for receiving GP teach in and to create a bidirectional communication
*/
eoGateway gateway;
eoMessage msg(512);
uint16_t recv;
if (gateway.Open(SER_PORT) != EO_OK) {
printf("Failed to open USB300\n");
return;
}
printf("EnOcean-Link Gateway\n");
//Activate LearnMode
gateway.LearnMode = true;
while (1)
{
//eoGateway is normally in LearnMode, to unset LearnMode, set LearnMode to false
//gateway.LearnMode=false;
recv = gateway.Receive();
if ((recv & RECV_TEACHIN)) {
eoProfile *profile = gateway.device->GetProfile();
profile->rorg == 0x0B && profile->func,
profile->type ?
profile->rorg, profile->func, profile->type :
printf(
"Device %08X Learned-In EEP: %02X-%02X-%02X\n",
gateway.device->ID, profile->rorg,
profile->func, profile->type);
for (int i = 0; i < profile->GetChannelCount(); i++) {
printf("%s %.2f ... %.2f %s\n",
profile->GetChannel(i)->ToString(NAME),
profile->GetChannel(i)->min,
profile->GetChannel(i)->max,
profile->GetChannel(i)->ToString(UNIT));
}
/**************** ONLY FOR CHANNEL REJECTION ******************/
//check if it is bidirectional and want to reject channel
if ((gateway.telegram.data[1] >> 4 & 1) == 0x01) {
//If you want to reject any channels
//Note: if you reject any channel, those channels will not be parsed!
for (int i = 0; i < profile->GetChannelCount(); i++) {
if (profile->GetChannel(i)->type == S_TEMP)
((eoGPChannelInfo*) profile->GetChannel(i))->SetRejected(
1);
}
}
/**************** ONLY FOR CHANNEL REJECTION END ******************/
//reply is always necessary even if it is a unidirectional device
gateway.TeachInModule->CreateGPResponse(msg, 0x7FF,
gateway.message.sourceID, RESP_REJECTED_CHANNELS, profile);
gateway.Send(msg);
/****************** ONLY IF THERE ARE ANY REJECTED CHANNELS **********************/
//the device should reply in 500ms if it does not accept teach in
uint32_t timer = eoTimer::GetTickCount() + 500;
uint32_t limit = eoTimer::GetTickCount();
gateway.LearnMode = false;
while (timer > limit) {
limit = eoTimer::GetTickCount();
recv = gateway.Receive();
if (recv & RECV_PROFILE) {
printf("Device did not accept teach in request!");
break;
}
}
/**************** ONLY IF THERE ARE ANY REJECTED CHANNELS END ********************/
break;
}
}
while (1) {
recv = gateway.Receive();
if (recv & RECV_PROFILE) {
printf("Device %08X\n", gateway.device->ID);
eoProfile *profile = gateway.device->GetProfile();
float f;
uint8_t t;
for (int i = 0; i < profile->GetChannelCount(); i++) {
//get the channel value if it is a float
if (profile->GetValue(profile->GetChannel(i)->type, f) == EO_OK)
printf("%s %.2f %s\n",
profile->GetChannel(i)->ToString(NAME), f,
profile->GetChannel(i)->ToString(UNIT));
//get the channel value if it is an uint
if (profile->GetValue(profile->GetChannel(i)->type, t) == EO_OK)
printf("%s %u \n", profile->GetChannel(i)->ToString(NAME),
t);
}
//Set values for the outbound channels
profile->SetValue(F_ON_OFF, (uint8_t) 1);
profile->Create(msg);
gateway.Send(msg);
}
}
gateway.Close();
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: HelloWorld.cpp

HelloWorld.cpp
#ifdef WIN32
#include <windows.h>
#define SER_PORT "\\\\.\\COM43" //COM43
#else
#define SER_PORT "/dev/ttyUSB0"
#endif
#include "./eoLink.h"
#include <stdio.h>
int main(int argc, const char* argv[]) {
uint16_t recv;
CO_RD_VERSION_RESPONSE version;
//First a Gateway will be defined
eoGateway myGateway;
//This tries to open an connection to the USB300 or fails otherwise
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return 0;
}
printf("Hello to the world of eoLink\n");
if(myGateway.commands.ReadVersion(version)==EO_OK)
printf("%s %i.%i.%i.%i, ID:0x%08X on %s\n",
version.appDescription,
version.appVersion[0], version.appVersion[1], version.appVersion[2], version.appVersion[3],
version.chipID,
SER_PORT);
while(1)
{
recv = myGateway.Receive();
if (recv & RECV_TELEGRAM)
eoDebug::Print(myGateway.telegram);
}
return 0;
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: linuxPacketStream_example.cpp

linuxPacketStream_example.cpp
/*
File: packetStream_example.cpp
Example Program which opens a Generic Packet Stream and tries to read the Version of the connected Device
*/
#define SER_PORT "/dev/ttyUSB0"
#include "eoLink.h"
#include <stdio.h>
//Testing main.c
void linuxPacketStreamExample()
{
eoLinuxPacketStream ps;
//Reserves 128bytes for the PacketBuffer
eoPacket p;
printf("Example Program which queries the USB300 SW Version\n");
if(ps.Open(SER_PORT)!=EO_OK)
{
printf("Error Opening the port \n");
return ;
}
else
printf("Port is Open \n");
//Compare ESP3 Spec, we ask for the SW_Version
p.type=PACKET_COMMON_COMMAND;
p.dataLength=1;
p.optionalLength=0;
p.data[0]=3;
ps.Send(p);
//Now we wait until we get a package
while(ps.Receive(&p)!=EO_OK);
printf("Read Version Ok; Connected to:\n");
printf("%s V %d.%d.%d.%d \n",&p.data[17],p.data[1],p.data[2],p.data[3],p.data[4]);
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: packetStream_example.cpp

packetStream_example.cpp
/*
File: packetStream_example.cpp
Example Program which opens a Generic Packet Stream and tries to read the Version of the connected Device
*/
#include <stdio.h>
#include "eoLink.h"
void PacketStreamExample()
{
printf("Example Program to show how a 'Generic Packet Stream' works \n");
eoLinuxPacketStream ps;
eoPacket p;
//Compare ESP3 Spec, we ask for the SW_Version
p.type=PACKET_COMMON_COMMAND;
p.dataLength=1;
p.optionalLength=0;
p.data[0]=3;
ps.Send(p);
//Now we wait until we get a package
while(ps.Receive(&p)!=EO_OK);
printf("Read Version Ok; Connected to:\n");
printf("%s V %d.%d.%d.%d \n",&p.data[17],p.data[1],p.data[2],p.data[3],p.data[4]);
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: profile_examples.cpp

profile_examples.cpp
/*
File: profile_example.cpp
Example Program which creates manually two new Profiles,
one Profile will receive values and the other one will send values
*/
#include "eoLink.h"
#include <stdio.h>
void profileExamples()
{
//Simulated msg with EEP-A5-02-05 Telegram
//Temperature: 26.67° and DataTelegram
float tmpValue;
eoMessage myMessage = eoMessage(4);
myMessage.SetDataLength(4);
myMessage.RORG=0xA5;
myMessage.data[0]=0x00;
myMessage.data[1]=0x00;
myMessage.data[2]=0x55;//26.67°
myMessage.data[3]=0x08;//DataTelegram
//This is the Profile to handle the received Data
eoProfile *recProf = eoProfileFactory::CreateProfile(0xA5,0x02,0x05);
if(recProf==NULL)
return;
//And this profile will generate msg to send
eoProfile *sendProf = eoProfileFactory::CreateProfile(0xA5,0x02,0x30);
if(sendProf==NULL)
return;
//Parse our Message
recProf->Parse(myMessage);
eoDebug::Print(myMessage);
//get the Temperature
if(recProf->GetValue(S_TEMP,tmpValue)!=EO_OK)
return;
//Now we set the same Temperature in our sendProfile
sendProf->ClearValues();
sendProf->SetValue(S_TEMP,tmpValue);
//myMessage contains now an EEP-A5-02-30 data with the temperature 26.67°
sendProf->Create(myMessage);
eoDebug::Print(myMessage);
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Security_example.cpp

Security_example.cpp
#define SER_PORT "/dev/ttyUSB0"
#include "./eoLink.h"
#include <stdio.h>
const uint8_t pskVector[16] ={0x54,0x6F,0x62,0x69,0x20,0x52,0x6F,0x63,0x6B,0x74,0x20,0x50,0x53,0x4B,0x21,0x00};
const uint8_t keyVector[16] ={0x45,0x6E,0x4F,0x63,0x65,0x61,0x6E,0x20,0x47,0x6D,0x62,0x48,0x2E,0x31,0x33,0x00};
void securedPTM()
{
eoGateway myGateway;
eoSerialCommand cmd(&myGateway);
//Destination ID is the broadcoast ID
const uint32_t destID=0xFFFFFFFF;
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return ;
}
else
{
printf("EnOcean-Link Gateway\n");
}
//Read Sw and HW version of the device
CO_RD_VERSION_RESPONSE version;
if (cmd.ReadVersion(version) == EO_OK)
{
printf("%s %i.%i.%i.%i, ID:0x%08X on %s\n",
version.appDescription,
version.appVersion[0], version.appVersion[1], version.appVersion[2], version.appVersion[3],
version.chipID,
SER_PORT);
}
//Failed to read the version of the device
else
{
printf("Failed to retrieve USB300 version\n");
return ;
}
//Preparing the security Information we add an outgoing device
myGateway.deviceManager->Add(destID);
eoDevice &myDevice=*(myGateway.deviceManager->Get(destID));
//we get the Outgoing eoSecureInfo and set the security Paramters
eoSecureInfo &devOut = myDevice.secOut;
/* We want to sent data using the AES128 standard with a 3byte CMAC using 2bytes RollingCode.
* The rolling code will not be sent
*/
devOut.SLF=SLF_DATA_ENC_VAES128|SLF_MAC_3BYTE|SLF_RLC_ALGO_16BIT;
/* To sent secure messages we need to set a key, the size of the key and the rollingCode. */
memcpy(devOut.key,keyVector,sizeof(keyVector));
devOut.keySize=16;
devOut.rollingCode=0x3E2D;
/* We set the Teach Information that this telegram is sent by a PTM pressing the ROCKERA buttons */
devOut.teachInInfo=TEACH_INFO_PTM|TEACH_INFO_PTM_ROCKERA;
/* */
eoMessage TeachInMessage(30);
TeachInMessage.destinationID=destID;
if(myGateway.security.CreateTeachIn(TeachInMessage,myDevice)==EO_OK)
{
printf("Sending TeachIn Message \n");
eoDebug::Print(TeachInMessage);
myGateway.Send(TeachInMessage);
}
else
{
printf("Could not encrypt TeachIn message: %d \n",myGateway.security.GetLastError());
}
eoMessage unsecureMsg(1);
eoMessage secureMsg(14);
unsecureMsg.destinationID=destID;
eoProfile* securePTM=eoProfileFactory::CreateProfile(0xD2,0x03,0x00);
securePTM->SetValue(E_ROCKER_B,(uint8_t)0);
securePTM->SetValue(E_ROCKER_A,(uint8_t)0);
securePTM->SetValue(E_ENERGYBOW,(uint8_t)1);
securePTM->Create(unsecureMsg);
eoDebug::Print(unsecureMsg);
//The secure PTM does not encapsulate its real RORG, so we've to change it
unsecureMsg.RORG=RORG_SECD;
if(myGateway.security.Encrypt(unsecureMsg,secureMsg,myDevice)==EO_OK)
{
printf("Sending Encrypted Message\n");
eoDebug::Print(secureMsg);
myGateway.Send(secureMsg);
}
else
{
printf("Could not encrypt Message: %d \n",myGateway.security.GetLastError());
}
securePTM->SetValue(E_ROCKER_B,(uint8_t)0);
securePTM->SetValue(E_ROCKER_A,(uint8_t)1);
securePTM->SetValue(E_ENERGYBOW,(uint8_t)0);
securePTM->Create(unsecureMsg);
eoDebug::Print(unsecureMsg);
//The secure PTM does not encapsulate its real RORG, so we've to change it
unsecureMsg.RORG=RORG_SECD;
if(myGateway.security.Encrypt(unsecureMsg,secureMsg,myDevice)==EO_OK)
{
printf("Sending Encrypted Message\n");
eoDebug::Print(secureMsg);
myGateway.Send(secureMsg);
}
else
{
printf("Could not encrypt Message: %d \n",myGateway.security.GetLastError());
}
delete securePTM;
return;
}
void securedSTM()
{
eoGateway myGateway;
eoSerialCommand cmd(&myGateway);
//Destination ID is the broadcoast ID
const uint32_t destID=0xFFFFFFFF;
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return ;
}
else
{
printf("EnOcean-Link Gateway\n");
}
//Read Sw and HW version of the device
CO_RD_VERSION_RESPONSE version;
if (cmd.ReadVersion(version) == EO_OK)
{
printf("%s %i.%i.%i.%i, ID:0x%08X on %s\n",
version.appDescription,
version.appVersion[0], version.appVersion[1], version.appVersion[2], version.appVersion[3],
version.chipID,
SER_PORT);
}
//Failed to read the version of the device
else
{
printf("Failed to retrieve USB300 version\n");
return ;
}
//Preparing the security Information we add an outgoing device
myGateway.deviceManager->Add(destID);
eoDevice &myDevice=*(myGateway.deviceManager->Get(destID));
//we get the Outgoing eoSecureInfo and set the security Paramters
eoSecureInfo &devOut = myDevice.secOut;
/* We want to sent data using the AES128 standard with a 3byte CMAC using 3bytes RollingCode.
* The rolling code will not be sent
*/
devOut.SLF=SLF_DATA_ENC_VAES128|SLF_MAC_3BYTE|SLF_RLC_ALGO_24BIT;
/* To sent secure messages we need to set a key, the size of the key and the rollingCode. */
memcpy(devOut.key,keyVector,sizeof(keyVector));
memcpy(devOut.psk,pskVector,sizeof(pskVector));
devOut.keySize=16;
devOut.rollingCode=0xC0FFEE;
/* We set the Teach Information that this telegram uses a psk */
devOut.teachInInfo=TEACH_INFO_PSK;
/* */
eoMessage TeachInMessage(30);
TeachInMessage.destinationID=destID;
if(myGateway.security.CreateTeachIn(TeachInMessage,myDevice)==EO_OK)
{
printf("Sending TeachIn Message \n");
eoDebug::Print(TeachInMessage);
myGateway.Send(TeachInMessage);
}
else
{
printf("Could not encrypt TeachIn message: %d \n",myGateway.security.GetLastError());
}
eoMessage unsecureMsg(4);
eoMessage secureMsg(32);
unsecureMsg.destinationID=destID;
eoProfile* secureSTM=eoProfileFactory::CreateProfile(0xA5,0x02,0x04);
secureSTM->CreateTeachIN(unsecureMsg);
eoDebug::Print(unsecureMsg);
//sent an encrypted eep teach in
if(myGateway.security.Encrypt(unsecureMsg,secureMsg,myDevice)==EO_OK)
{
printf("Sending Encrypted Message\n");
eoDebug::Print(secureMsg);
myGateway.Send(secureMsg);
}
else
{
printf("Could not encrypt Message: %d \n",myGateway.security.GetLastError());
}
//Now sent a few temperatures fast
for(int temp=-10;temp<30;temp+=5)
{
secureSTM->SetValue(S_TEMP,(float)temp);
secureSTM->Create(unsecureMsg);
eoDebug::Print(unsecureMsg);
if(myGateway.security.Encrypt(unsecureMsg,secureMsg,myDevice)==EO_OK)
{
printf("Sending Encrypted Message\n");
eoDebug::Print(secureMsg);
myGateway.Send(secureMsg);
}
else
{
printf("Could not encrypt Message: %d \n",myGateway.security.GetLastError());
}
}
delete secureSTM;
return;
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: sendTelegram_example.cpp

sendTelegram_example.cpp
#define SER_PORT "/dev/ttyUSB0"//this has to be changed accordingly to your pc/embedded system
#include "./eoLink.h"
#include <stdio.h>
void sendTelegramExample()
{
eoGateway gateway;
//adding eoIDFilter to the gateWay
eoIDFilter * myFilter = new eoIDFilter();
gateway.filter=myFilter;
if (gateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return ;
}
eoProfile *sendProf = eoProfileFactory::CreateProfile(0xF6,0x02,0x01);
//Parse our Message
eoMessage mytel = eoMessage(1);
sendProf->SetValue(E_ROCKER_B,(uint8_t)0);
sendProf->SetValue(E_ROCKER_A,(uint8_t)0);
sendProf->SetValue(E_ENERGYBOW,(uint8_t)1);
sendProf->Create(mytel);
gateway.Send(mytel);
float f;
uint8_t t;
printf("Send telegram with:");
for (int i = 0; i<sendProf->GetChannelCount(); i++)
{
//get the channel value if it is a float
if (sendProf->GetValue( sendProf->GetChannel(i)->type, f) ==EO_OK)
printf("%s %.2f %s\n", sendProf->GetChannel(i)->ToString(NAME),f,sendProf->GetChannel(i)->ToString(UNIT));
//get the channel value if it is an uint
if (sendProf->GetValue( sendProf->GetChannel(i)->type, t) ==EO_OK)
printf("%s %u \n", sendProf->GetChannel(i)->ToString(NAME),t);
}
sendProf->ClearValues();
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: storage_example.cpp

storage_example.cpp
/*
File: Storage_example.cpp
Example how to add an Gateway to the Storage Manager and Load and Save a File
*/
#define SER_PORT "/dev/ttyUSB1"
#include "./eoLink.h"
#include <stdio.h>
//Testing main.c
void storageExample()
{
eoGateway gateway ;
eoStorageManager myStore = eoStorageManager();
//adds the Object Gateway to the storage manager
myStore.addObject("Gateway",&gateway);
//now when you load a file, and it contains a Block Gateway, the Gateway will be loaded
if(myStore.Load("./eoLinkSave.txt")!=EO_OK)
{
printf("could not load Storage!");
}
/*
* main application
*/
//every Object which has been added to the storageManager will be saved to the output File
if(myStore.Save("./eoLinkSave.txt")!=EO_OK)
{
printf("could not save Storage!");
}
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: tutorial1.cpp

tutorial1.cpp
#ifdef WIN32
#include <windows.h>
#define SER_PORT "\\\\.\\COM43" //COM43
#else
#define SER_PORT "/dev/ttyUSB0"
#endif
#define SAVE_CONFIG "./learned.txt"
#define LEARN_TIME_S 1
#include "./eoLink.h"
#include <stdio.h>
int main(int argc, const char* argv[]) {
//First a Gateway and a storageManager will be definied
eoGateway myGateway;
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return 0;
}
printf("EnOcean-Link Gateway LearnMode\n");
//adding a dBm Filter as learnFilter
eodBmFilter * learnFilter = new eodBmFilter();
myGateway.learnFilter = learnFilter;
learnFilter->maxdBm=-0;
learnFilter->mindBm=-60;
//the eoIDFilter will allow our Gateway application to filter all the unwanted Telegrams
eoIDFilter * myFilter = new eoIDFilter();
myGateway.filter=myFilter;
//recv stores the return Value of the Gateway
uint16_t recv;
//As RPS Telegrams don't have a teach IN Telegram, we need to set the wished profiled for an automated Teach IN
myGateway.TeachInModule->SetRPS(0x02,0x01);
//Set the learnTime and update the time
uint32_t learnTime=eoTimer::GetTickCount()+LEARN_TIME_S*10000;
uint32_t time=eoTimer::GetTickCount();
//Activate LearnMode
myGateway.LearnMode=true;
while(learnTime>time)
{
//updates the time, using the HAL getTickCount function
time=eoTimer::GetTickCount();
//the Gateway::Receive() Functions returns different flags, depending on the Packet we got
recv = myGateway.Receive();
//as we're in LearnMode currently we only want to process Teach_IN Telegrams(as specified in EEP)
if (recv & RECV_TEACHIN)
{
//add the Source ID to the Normale Mode Filter
myFilter->Add(myGateway.telegram.sourceID);
//Print out the Message to stdout
eoDebug::Print(myGateway.telegram);
//If the TeachIN process was successfull and we got a Profile print out the Message!
eoProfile *profile = myGateway.device->GetProfile();
if(profile!=NULL)
{
printf("Device %08X Learned-In EEP: %02X-%02X-%02X\n", myGateway.device->ID, profile->rorg, profile->func, profile->type );
for (int i = 0; i<profile->GetChannelCount(); i++)
{
printf("%s %.2f ... %.2f %s\n", profile->GetChannel(i)->ToString(NAME), profile->GetChannel(i)->min, profile->GetChannel(i)->max, profile->GetChannel(i)->ToString(UNIT));
}
}
}
}
//After the Teach IN Process we want to store the configuration of the Gateway, so you could use the learned in Devices for the
//next Project
//Deactivate LearnMode
myGateway.LearnMode=false;
eoStorageManager myStore;
//adding our Gateway to the StorageManager allows the storage Manager to save it
myStore.addObject("Gateway",&myGateway);
printf("Storing the Config\n");
myStore.Save(SAVE_CONFIG);
printf("EnOcean-Link Gateway FilterdMode\n");
while (1)
{
recv = myGateway.Receive();
if (recv & RECV_MESSAGE)
{
//Resend received telegrams
myGateway.Send(myGateway.message);
eoDebug::Print(myGateway.telegram);
}
//If we got a valid Profile Telegram which is not a Learn IN we print the received Values
if (recv & RECV_PROFILE)
{
printf("Device %08X\n", myGateway.device->ID);
eoProfile *profile = myGateway.device->GetProfile();
float f;
uint8_t t;
for (int i = 0; i<profile->GetChannelCount(); i++)
{
//get the channel value if it is a float
if (profile->GetValue( profile->GetChannel(i)->type, f) ==EO_OK)
printf("%s %.2f %s\n", profile->GetChannel(i)->ToString(NAME),f,profile->GetChannel(i)->ToString(UNIT));
//get the channel value if it is an uint
if (profile->GetValue( profile->GetChannel(i)->type, t) ==EO_OK)
printf("%s %u \n", profile->GetChannel(i)->ToString(NAME),t);
}
}
}
return 0;
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: tutorial2.cpp

tutorial2.cpp
#define SER_PORT "/dev/USB300"
#define LOAD_CONFIG "./learned.txt"
#include "./eoLink.h"
#include <stdio.h>
int main(int argc, const char* argv[]) {
eoGateway myGateway;
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return 0;
}
//Loading the prepared Configuartion
eoStorageManager myStore;
myStore.addObject("Gateway",&myGateway);
printf("Prepare to Load Config \n");
myStore.Load(LOAD_CONFIG);
uint16_t recv;
//we use in this example a 1BS Telegram, to send an Alarm Flag, which type of messsage is not specified!
eoMessage myMessage = eoMessage(1);
myMessage.RORG=RORG_1BS;
myMessage.data[0]=0xFF;
printf("Gateway is running \n");
while (1)
{
recv = myGateway.Receive();
if (recv & RECV_PROFILE)
{
printf("Device %08X\n", myGateway.device->ID);
eoProfile *profile = myGateway.device->GetProfile();
float f;
if (profile->GetValue( S_TEMP, f) ==EO_OK)
{
printf(" %.2f \n", f);
//our value is higher then 30° send the warning message!
if(f>30.0)
myGateway.Send(myMessage);
}
}
}
return 0;
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: tutorial3.cpp

tutorial3.cpp
#define SER_PORT "/dev/USB300"
#define LOAD_CONFIG "./Tutorial2.txt"
#include "./eoLink.h"
#include <stdio.h>
int main(int argc, const char* argv[]) {
eoGateway myGateway;
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return 0;
}
//Loading the prepared Configuartion
eoStorageManager myStore;
myStore.addObject("Gateway",&myGateway);
myStore.Load(LOAD_CONFIG);
printf("Loaded Config \n");
uint16_t recv;
//As we send a 4BS Telegram, we need 4 data bytes
eoMessage myMessage = eoMessage(4);
//Creates a profile to create 4BS telegrams.
eoProfile *sendProfile = eoProfileFactory::CreateProfile(0xA5,0x02,0x20);
if(sendProfile!=NULL)
sendProfile->CreateTeachIN(myMessage);
myGateway.Send(myMessage);
while (1)
{
recv = myGateway.Receive();
//Got a Profile
if (recv & RECV_PROFILE)
{
printf("Device %08X\n", myGateway.device->ID);
eoProfile *profile = myGateway.device->GetProfile();
float f;
//with a Temperature
if (profile->GetValue( S_TEMP, f) ==EO_OK)
{
printf(" %.2f \n", f);
if(sendProfile==NULL)
continue;
//Use the eoProfile to set the temperature value
if(sendProfile->SetValue(S_TEMP,f)==EO_OK)
{
//and send a Temperature Telegram
if(sendProfile->Create(myMessage)==EO_OK)
myGateway.Send(myMessage);
}
}
}
}
return 0;
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: tutorial4.cpp

tutorial4.cpp
#define SER_PORT "/dev/USB300"
#define SAVE_CONFIG "./learned.txt"
#define LEARN_TIME_S 1
#include "./eoLink.h"
#include <stdio.h>
int main(int argc, const char* argv[]) {
eoGateway myGateway;
uint16_t recv=0;
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return 0;
}
myGateway.TeachInModule->SetRPS(0x02,0x01);
myGateway.TeachInModule->Set1BS(0x00,0x01);
while (1)
{
recv = myGateway.Receive();
//Got a Profile
if (recv & RECV_SECTEACHIN)
{
myGateway.TeachInModule->TeachOut(myGateway.message.sourceID);
}
else if (recv & RECV_TEACHIN)
{
myGateway.TeachInModule->TeachIN(myGateway.message);
}
}
return 0;
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: tutorial5.cpp

tutorial5.cpp
#define SER_PORT "/dev/ttyUSB0"
#define SAVE_CONFIG "./learned.txt"
#define LEARN_TIME_S 1
#include "./eoLink.h"
#include <stdio.h>
#include <stdint.h>
int main(int argc, const char* argv[]) {
eoGateway myGateway;
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return 0;
}
eoSerialCommand cmd(&myGateway);
//Read Sw and HW version of the device
CO_RD_VERSION_RESPONSE version;
if (cmd.ReadVersion(version) == EO_OK)
{
printf("%s %i.%i.%i.%i, ID:0x%08X on %s\n",
version.appDescription,
version.appVersion[0], version.appVersion[1], version.appVersion[2], version.appVersion[3],
version.chipID,
SER_PORT);
}
//Failed to read the version of the device
else
{
printf("Failed to retrieve USB300 version\n");
return -1;
}
//Perform a built in self test
if (cmd.BIST() == EO_OK)
printf ("Successful BIST performed!\n");
//Failed BIST
else
{
printf("Failed to perform BIST\n");
return -1;
}
//Read device ID base
CO_RD_IDBASE_RESPONSE baseID;
if (cmd.ReadIDBase(baseID) == EO_OK)
printf("Base ID: %08X, %i writes left\n", baseID.baseID, baseID.remainingWrites);
else
{
printf("Failed to retrieve USB300 base ID\n");
return -1;
}
//Write repeater
uint8_t repLevel = 1;
if (cmd.WriteRepeater(true, repLevel) == EO_OK)
printf("Repeater added!\n");
else
{
printf("Failed to add repeater\n");
return -1;
}
//Read repeater
CO_RD_REPEATER_RESPONSE repeater;
if (cmd.ReadRepeater(repeater) == EO_OK)
printf("Enabled: %s, Level: %i\n", repeater.repEnable ? "true":"false", repeater.repLevel);
else
{
printf("Failed to read repetear\n");
return -1;
}
//Add filter
if (cmd.AddFilter(CHOICE,0x11223344, BLOCK_RADIO) == EO_OK)
printf("Filter added!\n");
else
{
printf("Failed to add filter\n");
return -1;
}
//Read filter
CO_RD_FILTER_RESPONSE filter[1];
uint8_t filterCount;
if (cmd.ReadFilter(filter, &filterCount, 1) == EO_OK)
printf("Filter type: %i, Filter value: 0x%08X\n", filter[0].filterType, filter[0].filterValue);
else
{
printf("Failed to read filter\n");
return -1;
}
//Delete filter
if (cmd.DeleteFilter(CHOICE, 0x11223344) == EO_OK)
printf("Filter deleted\n");
else
{
printf("Failed to delete filter\n");
return -1;
}
//Enable filter
if (cmd.EnableFilter(true, OR) == EO_OK)
printf("Filter enabled\n");
else
{
printf("Failed to enable filter\n");
return -1;
}
//Delete all filter
if (cmd.DeleteAllFilter() == EO_OK)
printf("All filter has been deleted!\n");
else
{
printf("Failed to delete all filter\n");
return -1;
}
//Wait maturity time
if (cmd.WaitMaturity(true) == EO_OK)
printf("Maturity turned on\n");
else
{
printf("Failed to turn on maturity\n");
return -1;
}
return 0;
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: tutorial6.cpp

tutorial6.cpp
#define SER_PORT "/dev/ttyUSB0"
#define LEARN_TIME_S 10
#include "./eoLink.h"
#include <stdint.h>
#include <stdio.h>
#include <map>
bool openGateway(eoGateway &myGateway)
{
bool retValue=true;
eoSerialCommand cmd(&myGateway);
CO_RD_VERSION_RESPONSE version;
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
retValue=false;
}
if (retValue&&cmd.ReadVersion(version) == EO_OK)
{
printf("%s %i.%i.%i.%i, ID:0x%08X on %s\n",
version.appDescription,
version.appVersion[0], version.appVersion[1], version.appVersion[2], version.appVersion[3],
version.chipID,
SER_PORT);
}
//Failed to read the version of the device
else
{
retValue=false;
}
return retValue;
}
void learnInMode(eoGateway &myGateway,eoGenericProfile &genericTemperatureProfiles,std::map<uint32_t,uint8_t> &devToID)
{
//recv stores the return Value of the Gateway
uint16_t recv;
//As RPS Telegrams don't have a teach IN Telegram, we need to set the wished profiled for an automated Teach IN
//Set the learnTime and update the time
uint32_t learnTime=eoTimer::GetTickCount()+30*1000;
uint32_t time=eoTimer::GetTickCount();
//Activate LearnMode
myGateway.LearnMode=true;
while(learnTime>time)
{
//updates the time, using the HAL getTickCount function
time=eoTimer::GetTickCount();
//the Gateway::Receive() Functions returns different flags, depending on the Packet we got
recv = myGateway.Receive();
//as we're in LearnMode currently we only want to process Teach_IN Telegrams(as specified in EEP)
if ((recv & RECV_TEACHIN))
{
eoProfile *profile = myGateway.device->GetProfile();
if(profile != NULL && profile->rorg == 0xA5 && profile->func == 0x02)
{
//add the Source ID to the Normale Mode Filter
((eoIDFilter*)myGateway.filter)->Add(myGateway.telegram.sourceID);
//Print out the Message to stdout
eoDebug::Print(myGateway.telegram);
//If the TeachIN process was successfull and we got a Profile print out the Message!
eoChannelInfo* tempChannel=profile->GetChannel(S_TEMP);
//Outgoing channels need to be added using the .AddChannelOut
//For the Generic CHannel information we are using the eep informations, we use 10BIt resoluation as
// the A5-02-xx profiles using maximal 10bits
genericTemperatureProfiles.AddChannelOut(S_TEMP,GP_RES_10BIT,(int8_t)tempChannel->max,(int8_t)tempChannel->min,GP_SCAL_1,GP_SCAL_1,VAL_CURR);
devToID[myGateway.device->ID]=devToID.size()-1;
}
else //The profile ist not an A5-02-xx, teach it out
{
myGateway.TeachInModule->TeachOut(myGateway.device->ID);
}
}
}
//Create and send a teach In Message
eoMessage teachMessage(128);
genericTemperatureProfiles.CreateTeachIN(teachMessage);
myGateway.Send(teachMessage);
//Deactivate LearnMode
myGateway.LearnMode=false;
}
void operatingMode(eoGateway &myGateway,eoGenericProfile &genericTemperatureProfiles,std::map<uint32_t,uint8_t> &devToID)
{
uint16_t recv;
while (1)
{
//recv stores the return Value of the Gateway
recv = myGateway.Receive();
if (recv & RECV_PROFILE)
{
eoDebug::Print(myGateway.message);
//We received the Profile message and update our Temperature in the gpProfile and send the gpMessage
eoProfile* tempProfile = myGateway.device->GetProfile();
float temperature;
if (tempProfile->GetValue( S_TEMP, temperature) ==EO_OK)
{
eoMessage gpMessage(128);
genericTemperatureProfiles.SetValue(S_TEMP,temperature,devToID[myGateway.device->ID]);
genericTemperatureProfiles.Create(gpMessage);
myGateway.Send(gpMessage);
eoDebug::Print(gpMessage);
}
}
}
}
int main(int argc, const char* argv[]) {
//First a Gateway and a storageManager will be definied
eoGateway myGateway;
//Empty Generic Profile
eoGenericProfile genericTemperatureProfiles;
std::map<uint32_t,uint8_t> devToID;
if(openGateway(myGateway))
{
eodBmFilter * learnFilter = new eodBmFilter();
myGateway.learnFilter = learnFilter;
learnFilter->maxdBm=-0;
learnFilter->mindBm=-60;
//the eoIDFilter will allow our Gateway application to filter all the unwanted Telegrams
eoIDFilter * myFilter = new eoIDFilter();
myGateway.filter=myFilter;
printf("EnOcean-Link Gateway LearnMode\n");
learnInMode(myGateway,genericTemperatureProfiles,devToID);
printf("Learn Mode off\n");
operatingMode(myGateway,genericTemperatureProfiles,devToID);
delete learnFilter;
delete myFilter;
}
return 0;
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: vld_example.cpp

vld_example.cpp
/*
File: vld_example.cpp
brief: Example Program which uses UTE teach in
*/
#define SER_PORT "/dev/ttyUSB0"
#include "./eoLink.h"
#include <stdio.h>
int vld_example() {
eoGateway gateway; //= eoGateway();
//adding eoIDFilter to the gateWay
if (gateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return -1;
}
uint16_t recv;
gateway.LearnMode=true;
while(1)
{
//the Gateway::Receive() Functions returns different flags, depending on the Packet we got
recv = gateway.Receive();
//as we're in LearnMode currently we only want to process Teach_IN Telegrams(as specified in EEP)
if (recv & RECV_TEACHIN)
{
//Print out the Message to stdout
eoDebug::Print(gateway.telegram);
//If the TeachIN process was successfull and we got a Profile print out the Message!
eoProfile *profile = gateway.device->GetProfile();
if(profile!=NULL)
{
printf("Device %08X Learned-In EEP: %02X-%02X-%02X\n", gateway.device->ID, profile->rorg, profile->func, profile->type );
for (int i = 0; i<profile->GetChannelCount(); i++)
{
printf("%s %.2f ... %.2f %s\n", profile->GetChannel(i)->ToString(NAME), profile->GetChannel(i)->min, profile->GetChannel(i)->max, profile->GetChannel(i)->ToString(UNIT));
}
}
//If incoming telegram is UTE telegram
if (gateway.telegram.RORG == RORG_UTE)
{
//Creating the UTE response depending on the incoming teachIN telegram
eoMessage response = eoMessage(10);
gateway.TeachInModule->CreateUTEResponse(gateway.telegram, response, TEACH_IN_ACCEPTED, UTE_DIRECTION_BIDIRECTIONAL);
//Send the UTE response
gateway.Send(response);
}
}
}
return 0;
}
int vld_sendExample()
{
eoGateway gateway;
//adding eoIDFilter to the gateWay
eoIDFilter* myFilter = new eoIDFilter();
gateway.filter=myFilter;
if (gateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return -1;
}
printf("EnOcean-Link Gateway VLD send example\n");
eoMessage msg(255);
eoProfile * prof = new eoProfile();
prof = eoProfileFactory::CreateProfile(0xD2,0x01,0x08);
if (prof == NULL)
return -1;
// Starting with setting the command
prof->SetValue(E_COMMAND, (uint8_t)ACTUATOR_SET_OUTPUT);
// Setting the values of the specified command
prof->SetValue(E_DIM_VALUE, (uint8_t)DIM_TO_NEW_FAST);
prof->SetValue(E_IO_CHANNEL, (uint8_t)0x10);
prof->SetValue(S_PERCENTAGE, (float)0x5A);
prof->Create(msg);
gateway.Send(msg);
printf("Set output\n");
// Sending Actuator Status Query
prof->SetValue(E_COMMAND, (uint8_t)ACTUATOR_STATUS_QUERY);
prof->SetValue(E_IO_CHANNEL, (uint8_t)0x1F);
prof->Create(msg);
gateway.Send(msg);
printf("Sent query\n");
// Waiting for a response
while(1)
{
uint16_t recv = gateway.Receive();
if (recv & RECV_PACKET)
{
if (gateway.packet.data[0] == 0xD2 && (gateway.packet.data[1] & 0x0F) == ACTUATOR_STATUS_RESPONSE)
break;
}
}
// Parsing the received value
uint8_t val;
prof->GetValue(E_ERROR_STATE, val);
if (val != HARDWARE_OK)
{
printf("Hardware error!\n");
return -1;
}
printf("Hardware is fine\n");
// Sending measurement response
prof->SetValue(E_COMMAND, (uint8_t)ACTUATOR_MEASUREMENT_RESPONSE);
// Setting the values of the specified command
prof->SetValue(S_ENERGY, (float)123456, ENERGY_WH);
prof->SetValue(E_IO_CHANNEL, (uint8_t)0x1F);
prof->Create(msg);
gateway.Send(msg);
return 0;
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: WatcherMain.cpp

WatcherMain.cpp
#ifdef WIN32
#include <windows.h>
#define SER_PORT "\\\\.\\COM35" //COM4
#else
#define SER_PORT "/dev/ttyUSB1"
#endif
#define LEARN_TIME_S 1
#include <stdint.h>
#include "eoLink.h"
#include <stdio.h>
//Easy Handler for the different Security Issues
void HandleSecResult(EO_SEC_WATCH_RESULT watchRes)
{
switch(watchRes)
{
case(WATCH_OK):
break;
case(WATCH_DEVICE_NA):
break;
case(WATCH_DEVICE_ALREADY_EXIST):
break;
case(WATCH_NOT_SECURE_DEVICE):
break;
case(WATCH_NOT_WATCHED_DEVICE):
break;
case(WATCH_DOS_ASSUMED):
printf("Possible DOS detected \n");
break;
case(WATCH_TEL_TO_EARLY):
break;
case(WATCH_TEL_TO_LATE):
break;
case(WATCH_CMAC_OVERFLOW):
break;
case(WATCH_RLC_OVERFLOW):
break;
case(WATCH_DELAY_ASSUMED):
printf("A possible delay Attack detected \n");
break;
default:
printf("The Security watcher returned a not valid value!\n");
break;
}
}
int main(int argc, const char* argv[])
{
setvbuf(stdout, NULL, _IONBF, 0);
setvbuf(stderr, NULL, _IONBF, 0);
eoGateway myGateway;
//10 telegrams allowed with less then 100ms between them(maturity time)
eoWatcher* myWatcher=new eoWatcher(10,100);
myGateway.secWatcher= myWatcher;
CO_RD_VERSION_RESPONSE version;
printf("Opening Connection to USB300 \n");
if (myGateway.Open(SER_PORT)!=EO_OK)
{
printf("Failed to open USB300\n");
return 0;
}
printf("EnOcean-Link Gateway LearnMode\n");
//adding a dBm Filter as learnFilter
if(myGateway.commands.ReadVersion(version)==EO_OK)
{
printf("%s %i.%i.%i.%i, ID:0x%08X on %s\n",
version.appDescription,
version.appVersion[0], version.appVersion[1], version.appVersion[2], version.appVersion[3],
version.chipID,
SER_PORT);
}
//recv stores the return Value of the Gateway
uint16_t recv;
//As RPS Telegrams don't have a teach IN Telegram, we need to set the wished profiled for an automated Teach IN
myGateway.TeachInModule->SetRPS(0x02,0x01);
//Set the learnTime and update the time
uint32_t learnTime=eoTimer::GetTickCount()+LEARN_TIME_S*10000;
uint32_t time=eoTimer::GetTickCount();
//Activate LearnMode
myGateway.LearnModeOn();
while(learnTime>time)
{
//updates the time, using the HAL getTickCount function
time=eoTimer::GetTickCount();
//the Gateway::Receive() Functions returns different flags, depending on the Packet we got
recv = myGateway.Receive();
//as we're in LearnMode currently we only want to process Teach_IN Telegrams(as specified in EEP)
if (recv & RECV_TEACHIN)
{
//Print out the Message to stdout
eoDebug::Print(myGateway.telegram);
//If the TeachIN process was successfull and we got a Profile print out the Message!
eoProfile *profile = myGateway.device->GetProfile();
if(profile!=NULL)
{
printf("Device %08X Learned-In EEP: %02X-%02X-%02X\n", myGateway.device->ID, profile->rorg, profile->func, profile->type );
for (int i = 0; i<profile->GetChannelCount(); i++)
{
printf("%s %.2f ... %.2f %s\n", profile->GetChannel(i)->ToString(NAME), profile->GetChannel(i)->min, profile->GetChannel(i)->max, profile->GetChannel(i)->ToString(UNIT));
}
}
}
}
//We add our example device, which we expect to send every 10sec and at least every 100ms.
//The device Specific RLC Window is 10, and if we receive 5 Telegrams with a wrong CMAC we get an Error.
//After each received Telegram the expted tel Period is reseted (Meaning maxPeriodTime and minPeriodTime count from
//the moment we got this Telegram
myWatcher->AddDevice(0x0102CD1C,10000,100,10,5,true);
eoStorageManager myStore;
myGateway.LearnModeOff();
std::vector<uint32_t> deadDevices;
uint32_t lastTick=eoTimer::GetTickCount();;
while (1)
{
time=eoTimer::GetTickCount();
recv = myGateway.Receive();
if (recv & RECV_TELEGRAM)
{
eoDebug::Print(myGateway.telegram);
HandleSecResult((EO_SEC_WATCH_RESULT)myGateway.GetSecWatchResult());
}
//If we got a valid Profile Telegram which is not a Learn IN we print the received Values
if (recv & RECV_PROFILE)
{
printf("Device %08X\n", myGateway.device->ID);
eoProfile *profile = myGateway.device->GetProfile();
float f;
uint8_t t;
for (int i = 0; i<profile->GetChannelCount(); i++)
{
//get the channel value if it is a float
if (profile->GetValue( profile->GetChannel(i)->type, f) ==EO_OK)
printf("%s %.2f %s\n", profile->GetChannel(i)->ToString(NAME),f,profile->GetChannel(i)->ToString(UNIT));
//get the channel value if it is an uint
if (profile->GetValue( profile->GetChannel(i)->type, t) ==EO_OK)
printf("%s %u \n", profile->GetChannel(i)->ToString(NAME),t);
}
}
//If know for all Devices to have certain Periods, we could also add an CheckForDeadDevice and inform the user
if((time-lastTick)>1000)
{
if(myWatcher->CheckDeadDevices(deadDevices))
{
for(std::vector<uint32_t>::const_iterator it = deadDevices.begin(); it != deadDevices.end(); ++it)
{
printf("Possible Dead Device %u \n",*it);
}
}
lastTick=time;
}
}
delete myWatcher;
return 0;
}
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

CO_RD_FILTER_RESPONSE Member List

This is the complete list of members for CO_RD_FILTER_RESPONSE, including all inherited members.

filterType | CO_RD_FILTER_RESPONSE
filterValue | CO_RD_FILTER_RESPONSE
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

CO_RD_IDBASE_RESPONSE Member List

This is the complete list of members for CO_RD_IDBASE_RESPONSE, including all inherited members.

baseID | CO_RD_IDBASE_RESPONSE
remainingWrites | CO_RD_IDBASE_RESPONSE
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

CO_RD_REPEATER_RESPONSE Member List

This is the complete list of members for CO_RD_REPEATER_RESPONSE, including all inherited members.

repEnable | CO_RD_REPEATER_RESPONSE
repLevel | CO_RD_REPEATER_RESPONSE
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

CO_RD_VERSION_RESPONSE Member List

This is the complete list of members for CO_RD_VERSION_RESPONSE, including all inherited members.

apiVersion | CO_RD_VERSION_RESPONSE
appDescription | CO_RD_VERSION_RESPONSE
appVersion | CO_RD_VERSION_RESPONSE
chipID | CO_RD_VERSION_RESPONSE
chipVersion | CO_RD_VERSION_RESPONSE
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

CO_READY_RESPONSE Member List

This is the complete list of members for CO_READY_RESPONSE, including all inherited members.

resetCause CO_READY_RESPONSE
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

SA_LEARN_ACK_RESPONSE Member List

This is the complete list of members for SA_LEARN_ACK_RESPONSE, including all inherited members.

confirmCode | SA_LEARN_ACK_RESPONSE
responseTime | SA_LEARN_ACK_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

SA_RD_LEARNEDCLIENTS_RESPONSE Member List

This is the complete list of members for SA_RD_LEARNEDCLIENTS_RESPONSE, including all inherited members.

clientID | SA_RD_LEARNEDCLIENTS_RESPONSE
mailboxIndex | SA_RD_LEARNEDCLIENTS_RESPONSE
postmasterID | SA_RD_LEARNEDCLIENTS_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

SA_RD_LEARNMODE_RESPONSE Member List

This is the complete list of members for SA_RD_LEARNMODE_RESPONSE, including all inherited members.

enabled | SA_RD_LEARNMODE_RESPONSE
extended | SA_RD_LEARNMODE_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

TEACH_STRUCT Member List

This is the complete list of members for TEACH_STRUCT, including all inherited members.

teachedIN TEACH_STRUCT
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoA5EEProfile Member List

This is the complete list of members for eoA5EEProfile, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoA5EEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoA5EEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoA5EEProfile | virtual
eoEEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value) | eoProfile | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoProfile | virtual
SetValue(CHANNEL_TYPE type, float value) | eoA5EEProfile | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoA5EEProfile | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoA5EEProfile | virtual
eoEEProfile::SetValue(CHANNEL_TYPE type, uint8_t value) | eoProfile | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoAbstractMessage Member List

This is the complete list of members for eoAbstractMessage, including all inherited members.

data | eoAbstractMessage |
dataLength | eoAbstractMessage |
eoAbstractMessage(uint16_t size=1) | eoAbstractMessage | protected
GetDataLength() const | eoAbstractMessage |
GetMaxLength() const | eoAbstractMessage |
maxLength | eoAbstractMessage |
SetDataLength(uint16_t dataLen, bool reallocate=false) | eoAbstractMessage |
~eoAbstractMessage() (defined in eoAbstractMessage) | eoAbstractMessage | protectedvirtual
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoArchive Member List

This is the complete list of members for eoArchive, including all inherited members.

Close() | eoArchive | virtual
endBlock() | eoArchive | virtual
eoArchive() (defined in eoArchive) | eoArchive |
h | eoArchive | protected
identifier | eoArchive |
indent() | eoArchive | virtual
isName | eoArchive | protected
isStoring | eoArchive |
level | eoArchive | protected
Open(const char *strBuf) | eoArchive | virtual
operator&(char *obj) | eoArchive | virtual
operator&(char const *obj) | eoArchive | virtual
operator&(uint32_t &obj) | eoArchive | virtual
operator&(int32_t &obj) | eoArchive | virtual
operator&(uint16_t &obj) | eoArchive | virtual
operator&(int16_t &obj) | eoArchive | virtual
operator&(uint8_t &obj) | eoArchive | virtual
operator&(int8_t &obj) | eoArchive | virtual
operator&(float &obj) | eoArchive | virtual
operator&(bool &obj) | eoArchive | virtual
operator&(eoISerialize *obj) | eoArchive | virtual
operator&(eoISerialize &obj) | eoArchive | virtual
startBlock(const char *BlockName) | eoArchive | virtual
startBlock() | eoArchive | virtual
state | eoArchive | protected
~eoArchive() (defined in eoArchive) | eoArchive | virtual
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoArchiveTXT Member List

This is the complete list of members for eoArchiveTXT, including all inherited members.

Close() | eoArchiveTXT | virtual
endBlock() | eoArchiveTXT | virtual
eoArchive() (defined in eoArchive) | eoArchive |
eoArchiveTXT() (defined in eoArchiveTXT) | eoArchiveTXT |
ExchangeInt(int &obj) | eoArchiveTXT |
h | eoArchive | protected
identifier | eoArchive |
indent() | eoArchiveTXT | virtual
isName | eoArchive | protected
isStoring | eoArchive |
level | eoArchive | protected
Open(const char *strBuf) | eoArchiveTXT | virtual
operator&(char const *obj) | eoArchiveTXT | virtual
operator&(char *obj) | eoArchiveTXT | virtual
operator&(uint32_t &obj) | eoArchiveTXT | virtual
operator&(int32_t &obj) | eoArchiveTXT | virtual
operator&(uint16_t &obj) | eoArchiveTXT | virtual
operator&(int16_t &obj) | eoArchiveTXT | virtual
operator&(uint8_t &obj) | eoArchiveTXT | virtual
operator&(int8_t &obj) | eoArchiveTXT | virtual
operator&(float &obj) | eoArchiveTXT | virtual
operator&(bool &obj) | eoArchiveTXT | virtual
operator&(eoISerialize *obj) | eoArchiveTXT | virtual
operator&(eoISerialize &obj) | eoArchiveTXT | virtual
startBlock() | eoArchiveTXT | virtual
startBlock(const char *BlockName) | eoArchiveTXT | virtual
state | eoArchive | protected
~eoArchive() (defined in eoArchive) | eoArchive | virtual
~eoArchiveTXT() (defined in eoArchiveTXT) | eoArchiveTXT | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoChainedMessage Member List

This is the complete list of members for eoChainedMessage, including all inherited members.

Clear() | eoMessage | virtual
copyTo(eoMessage &msg) const | eoMessage |
data | eoAbstractMessage |
dataChunks | eoChainedMessage |
dataLength | eoAbstractMessage |
destinationID | eoMessage |
eoAbstractMessage(uint16_t size=1) | eoAbstractMessage | protected
eoChainedMessage(uint16_t maxSize) | eoChainedMessage |
eoMessage(uint16_t size=1) | eoMessage |
eoMessage(const eoTelegram &tel) | eoMessage |
expectedDataLength | eoChainedMessage |
expectedTelCount | eoChainedMessage |
GetDataLength() const | eoAbstractMessage |
GetMaxLength() const | eoAbstractMessage |
maxLength | eoAbstractMessage |
ProcessChunks() | eoChainedMessage |
received | eoChainedMessage |
RORG | eoMessage |
securityLevel | eoMessage |
seq | eoChainedMessage |
SetDataLength(uint16_t dataLen, bool reallocate=false) | eoAbstractMessage |
sizeN | eoChainedMessage |
sourceID | eoMessage |
status | eoMessage |
telCount | eoChainedMessage |
timeStamp | eoChainedMessage |
~eoAbstractMessage() (defined in eoAbstractMessage) | eoAbstractMessage | protectedvirtual
~eoChainedMessage() (defined in eoChainedMessage) | eoChainedMessage | virtual
~eoMessage() (defined in eoMessage) | eoMessage | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoChainedReManMessage Member List

This is the complete list of members for eoChainedReManMessage, including all inherited members.

Clear() | eoMessage | virtual
copyTo(eoReManMessage &reMsg) const | eoChainedReManMessage |
eoChainedMessage::copyTo(eoMessage &msg) const | eoMessage |
data | eoAbstractMessage |
dataChunks | eoChainedMessage |
dataLength | eoAbstractMessage |
destinationID | eoMessage |
eoAbstractMessage(uint16_t size=1) | eoAbstractMessage | protected
eoChainedMessage(uint16_t maxSize) | eoChainedMessage |
eoChainedReManMessage(uint16_t maxSize) | eoChainedReManMessage |
eoMessage(uint16_t size=1) | eoMessage |
eoMessage(const eoTelegram &tel) | eoMessage |
expectedDataLength | eoChainedMessage |
expectedTelCount | eoChainedMessage |
fnCode | eoChainedReManMessage |
GetDataLength() const | eoAbstractMessage |
GetMaxLength() const | eoAbstractMessage |
manufacturerID | eoChainedReManMessage |
maxLength | eoAbstractMessage |
ProcessChunks() | eoChainedMessage |
received | eoChainedMessage |
RORG | eoMessage |
securityLevel | eoMessage |
seq | eoChainedMessage |
SetDataLength(uint16_t dataLen, bool reallocate=false) | eoAbstractMessage |
sizeN | eoChainedMessage |
sourceID | eoMessage |
status | eoMessage |
telCount | eoChainedMessage |
timeStamp | eoChainedMessage |
~eoAbstractMessage() (defined in eoAbstractMessage) | eoAbstractMessage | protectedvirtual
~eoChainedMessage() (defined in eoChainedMessage) | eoChainedMessage | virtual
~eoChainedReManMessage() (defined in eoChainedReManMessage) | eoChainedReManMessage | virtual
~eoMessage() (defined in eoMessage) | eoMessage | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoChannelInfo Member List

This is the complete list of members for eoChannelInfo, including all inherited members.

max | eoChannelInfo
min | eoChannelInfo
signalType | eoChannelInfo
ToString(uint8_t strType) | eoChannelInfo
type | eoChannelInfo
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoChunkMessage Member List

This is the complete list of members for eoChunkMessage, including all inherited members.

CopyDataFrom(const uint8_t *const src, const uint8_t len) | eoChunkMessage |
CopyFrom(eoAbstractMessage const &msg) | eoChunkMessage |
data | eoAbstractMessage |
dataLength | eoAbstractMessage |
eoAbstractMessage(uint16_t size=1) | eoAbstractMessage | protected
eoChunkMessage(const eoChunkMessage &other) | eoChunkMessage |
eoChunkMessage(uint16_t size) | eoChunkMessage |
eoChunkMessage() (defined in eoChunkMessage) | eoChunkMessage |
GetDataLength() const | eoAbstractMessage |
GetMaxLength() const | eoAbstractMessage |
IsReceived() const | eoChunkMessage | inline
maxLength | eoAbstractMessage |
SetDataLength(uint16_t dataLen, bool reallocate=false) | eoAbstractMessage |
~eoAbstractMessage() (defined in eoAbstractMessage) | eoAbstractMessage | protectedvirtual
~eoChunkMessage() (defined in eoChunkMessage) | eoChunkMessage | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoConverter Member List

This is the complete list of members for eoConverter, including all inherited members.

advancedPacketToRadio(const eoPacket &packet, eoTelegram &tel) | eoConverter | static
celsiusToFahrenheit(float &value) | eoConverter | static
fahrenheitToCelsius(float &value) | eoConverter | static
Hash(char const *str) | eoConverter | static
literToMeter3(float &value) | eoConverter | static
meter3ToLiter(float &value) | eoConverter | static
NumToHex(uint8_t num) | eoConverter | static
packetToAdvancedRadio(const eoMessage &msg, eoPacket &packet) | eoConverter | static
packetToRadio(const eoPacket &packet, eoTelegram &tel) | eoConverter | static
packetToReman(const eoPacket &packet, eoReManMessage &reManMes) | eoConverter | static
radioToPacket(const eoTelegram &tel, eoPacket &packet) | eoConverter | static
radioToPacket(const eoMessage &msg, eoPacket &packet) | eoConverter | static
remanToPacket(const eoReManMessage &reManMes, eoPacket &packet) | eoConverter | static
TigrisToRPS(eoTelegram &inTel, eoTelegram &outTel) | eoConverter | static
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoD2EEProfile Member List

This is the complete list of members for eoD2EEProfile, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoD2EEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoD2EEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoD2EEProfile | virtual
eoEEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value) | eoProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoD2EEProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoProfile | virtual
SetValue(CHANNEL_TYPE type, float value) | eoD2EEProfile | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoD2EEProfile | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoD2EEProfile | virtual
eoEEProfile::SetValue(CHANNEL_TYPE type, uint8_t value) | eoProfile | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoDebug Member List

This is the complete list of members for eoDebug, including all inherited members.

Print(const eoTelegram &tel) | eoDebug | static
Print(const eoMessage &msg) | eoDebug | static
Print(const eoReManMessage &reMsg) | eoDebug | static
Print(const eoPacket &packet) | eoDebug | static
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoDevice Member List

This is the complete list of members for eoDevice, including all inherited members.

dBm | eoDevice |
eoDevice() (defined in eoDevice) | eoDevice |
eoDevice(uint32_t id) | eoDevice |
eoISerialize() (defined in eoISerialize) | eoISerialize |
GetProfile() const | eoDevice |
ID | eoDevice |
secIn | eoDevice |
secOut | eoDevice |
Serialize(eoArchive &a) | eoDevice | virtual
SetProfile(eoProfile *myProfile) | eoDevice |
SetProfile(const uint8_t rorg, const uint8_t func, const uint8_t type) | eoDevice |
~eoDevice() (defined in eoDevice) | eoDevice | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoDeviceManager Member List

This is the complete list of members for eoDeviceManager, including all inherited members.

Add(uint32_t id) | eoDeviceManager |
eoDeviceManager() | eoDeviceManager |
eoISerialize() (defined in eoISerialize) | eoISerialize |
Get(uint32_t id) | eoDeviceManager |
GetDeviceList() const | eoDeviceManager |
Remove(uint32_t id) | eoDeviceManager |
Serialize(eoArchive &a) | eoDeviceManager | virtual
Size() const | eoDeviceManager |
~eoDeviceManager() (defined in eoDeviceManager) | eoDeviceManager |
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A502xx Member List

This is the complete list of members for eoEEP_A502xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A502xx() (defined in eoEEP_A502xx) | eoEEP_A502xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoA5EEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoA5EEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoA5EEProfile | virtual
eoEEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value) | eoProfile | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A502xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoA5EEProfile | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoA5EEProfile | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoA5EEProfile | virtual
eoEEProfile::SetValue(CHANNEL_TYPE type, uint8_t value) | eoProfile | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A502xx() (defined in eoEEP_A502xx) | eoEEP_A502xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A504xx Member List

This is the complete list of members for eoEEP_A504xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A504xx() (defined in eoEEP_A504xx) | eoEEP_A504xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_A504xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_A504xx | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoA5EEProfile | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoA5EEProfile | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A504xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_A504xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_A504xx | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoA5EEProfile | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoA5EEProfile | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A504xx() (defined in eoEEP_A504xx) | eoEEP_A504xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A505xx Member List

This is the complete list of members for eoEEP_A505xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A505xx() (defined in eoEEP_A505xx) | eoEEP_A505xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_A505xx | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value) | eoA5EEProfile | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoA5EEProfile | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoA5EEProfile | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A505xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_A505xx | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value) | eoA5EEProfile | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoA5EEProfile | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoA5EEProfile | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A505xx() (defined in eoEEP_A505xx) | eoEEP_A505xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A506xx Member List

This is the complete list of members for eoEEP_A506xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A506xx() (defined in eoEEP_A506xx) | eoEEP_A506xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type) | eoEEP_A506xx | virtual
eoA5EEProfile::GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
eoA5EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_A506xx | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoA5EEProfile | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoA5EEProfile | virtual
eoEEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value) | eoProfile | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A506xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_A506xx | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoA5EEProfile | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoA5EEProfile | virtual
eoEEProfile::SetValue(CHANNEL_TYPE type, uint8_t value) | eoProfile | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A506xx() (defined in eoEEP_A506xx) | eoEEP_A506xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A507xx Member List

This is the complete list of members for eoEEP_A507xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A507xx() (defined in eoEEP_A507xx) | eoEEP_A507xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_A507xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_A507xx | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoA5EEProfile | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoA5EEProfile | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A507xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_A507xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_A507xx | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoA5EEProfile | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoA5EEProfile | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A507xx() (defined in eoEEP_A507xx) | eoEEP_A507xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A508xx Member List

This is the complete list of members for eoEEP_A508xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A508xx() (defined in eoEEP_A508xx) | eoEEP_A508xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_A508xx | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value) | eoA5EEProfile | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoA5EEProfile | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoA5EEProfile | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A508xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_A508xx | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value) | eoA5EEProfile | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoA5EEProfile | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoA5EEProfile | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A508xx() (defined in eoEEP_A508xx) | eoEEP_A508xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A509xx Member List

This is the complete list of members for eoEEP_A509xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A509xx() (defined in eoEEP_A509xx) | eoEEP_A509xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_A509xx | virtual
eoA5EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoA5EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_A509xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_A509xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_A509xx | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoA5EEProfile | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A509xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_A509xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_A509xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_A509xx | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoA5EEProfile | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A509xx() (defined in eoEEP_A509xx) | eoEEP_A509xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A510xx Member List

This is the complete list of members for eoEEP_A510xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A510xx() (defined in eoEEP_A510xx) | eoEEP_A510xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_A510xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag) | eoEEP_A510xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_A510xx | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoA5EEProfile | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A510xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_A510xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t subFlag) | eoEEP_A510xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_A510xx | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoA5EEProfile | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A510xx() (defined in eoEEP_A510xx) | eoEEP_A510xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A511xx Member List

This is the complete list of members for eoEEP_A511xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A511xx() (defined in eoEEP_A511xx) | eoEEP_A511xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_A511xx | virtual
eoA5EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoA5EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_A511xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_A511xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_A511xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_A511xx | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A511xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_A511xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_A511xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_A511xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_A511xx | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A511xx() (defined in eoEEP_A511xx) | eoEEP_A511xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A512xx Member List

This is the complete list of members for eoEEP_A512xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A512xx() (defined in eoEEP_A512xx) | eoEEP_A512xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type) | eoEEP_A512xx | virtual
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_A512xx | virtual
eoA5EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_A512xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_A512xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_A512xx | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoA5EEProfile | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A512xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_A512xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_A512xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_A512xx | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoA5EEProfile | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A512xx() (defined in eoEEP_A512xx) | eoEEP_A512xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A513xx Member List

This is the complete list of members for eoEEP_A513xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A513xx() (defined in eoEEP_A513xx) | eoEEP_A513xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_A513xx | virtual
eoA5EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoA5EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_A513xx | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_A513xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_A513xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_A513xx | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &m) | eoEEP_A513xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoEEP_A513xx |
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A513xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_A513xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_A513xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_A513xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_A513xx | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A513xx() (defined in eoEEP_A513xx) | eoEEP_A513xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A514xx Member List

This is the complete list of members for eoEEP_A514xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A514xx() (defined in eoEEP_A514xx) | eoEEP_A514xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_A514xx | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value) | eoA5EEProfile | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoA5EEProfile | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoA5EEProfile | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A514xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_A514xx | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value) | eoA5EEProfile | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoA5EEProfile | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoA5EEProfile | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A514xx() (defined in eoEEP_A514xx) | eoEEP_A514xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A520xx Member List

This is the complete list of members for eoEEP_A520xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoEEP_A520xx | virtual
Create(eoMessage &m) | eoEEP_A520xx | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
direction (defined in eoISimpleBidirectionalProfile) | eoISimpleBidirectionalProfile | protected
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A520xx() (defined in eoEEP_A520xx) | eoEEP_A520xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoISimpleBidirectionalProfile() (defined in eoISimpleBidirectionalProfile) | eoISimpleBidirectionalProfile | inline
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subFlag) | eoEEP_A520xx | virtual
eoA5EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoA5EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetOutChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEP_A520xx | virtual
GetOutChannel(CHANNEL_TYPE type) | eoEEP_A520xx | virtual
GetOutChannel(uint8_t channelNumber) | eoEEP_A520xx | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_A520xx | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_A520xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_A520xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_A520xx | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetDirection(HVCA_DIRECTION direction) | eoEEP_A520xx |
SetDirection(SIMPLE_DIRECTION directionToSet) | eoEEP_A520xx | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A520xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_A520xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_A520xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_A520xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_A520xx | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A520xx() (defined in eoEEP_A520xx) | eoEEP_A520xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoISimpleBidirectionalProfile() (defined in eoISimpleBidirectionalProfile) | eoISimpleBidirectionalProfile | inlinevirtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A530xx Member List

This is the complete list of members for eoEEP_A530xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A530xx() (defined in eoEEP_A530xx) | eoEEP_A530xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_A530xx | virtual
eoA5EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoA5EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_A530xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_A530xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_A530xx | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoA5EEProfile | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A530xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_A530xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_A530xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_A530xx | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoA5EEProfile | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A530xx() (defined in eoEEP_A530xx) | eoEEP_A530xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A537xx Member List

This is the complete list of members for eoEEP_A537xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A537xx() (defined in eoEEP_A537xx) | eoEEP_A537xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_A537xx | virtual
eoA5EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoA5EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_A537xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_A537xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_A537xx | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoA5EEProfile | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoA5EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A537xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_A537xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_A537xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_A537xx | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoA5EEProfile | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A537xx() (defined in eoEEP_A537xx) | eoEEP_A537xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_A538xx Member List

This is the complete list of members for eoEEP_A538xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_A538xx() (defined in eoEEP_A538xx) | eoEEP_A538xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_A538xx | virtual
eoA5EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoA5EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_A538xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_A538xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_A538xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_A538xx | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &m) | eoEEP_A538xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoEEP_A538xx |
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_A538xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_A538xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_A538xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_A538xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_A538xx | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_A538xx() (defined in eoEEP_A538xx) | eoEEP_A538xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D2A0xx Member List

This is the complete list of members for eoEEP_D2A0xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoEEP_D2A0xx | virtual
Create(eoMessage &m) | eoEEP_D2A0xx | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
direction (defined in eoISimpleBidirectionalProfile) | eoISimpleBidirectionalProfile | protected
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEP_D2A0xx(uint16_t size=1) | eoEEP_D2A0xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoISimpleBidirectionalProfile() (defined in eoISimpleBidirectionalProfile) | eoISimpleBidirectionalProfile | inline
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetOutChannel(CHANNEL_TYPE type) | eoEEP_D2A0xx | virtual
GetOutChannel(uint8_t channelNumber) | eoEEP_D2A0xx | virtual
eoISimpleBidirectionalProfile::GetOutChannel(CHANNEL_TYPE type, uint8_t subType) | eoISimpleBidirectionalProfile | inlinevirtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D2A0xx | virtual
eoD2EEProfile::GetValue(CHANNEL_TYPE type, float &value) | eoD2EEProfile | virtual
eoD2EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoD2EEProfile | virtual
eoD2EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoD2EEProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoEEP_D2A0xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoD2EEProfile | virtual
SetDirection(VALVE_DIRECTION direction) | eoEEP_D2A0xx |
SetDirection(SIMPLE_DIRECTION directionToSet) | eoEEP_D2A0xx | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D2A0xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D2A0xx | virtual
eoD2EEProfile::SetValue(CHANNEL_TYPE type, float value) | eoD2EEProfile | virtual
eoD2EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoD2EEProfile | virtual
eoD2EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoD2EEProfile | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEP_D2A0xx() (defined in eoEEP_D2A0xx) | eoEEP_D2A0xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoISimpleBidirectionalProfile() (defined in eoISimpleBidirectionalProfile) | eoISimpleBidirectionalProfile | inlinevirtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D200xx Member List

This is the complete list of members for eoEEP_D200xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEP_D200xx(uint16_t size=10) | eoEEP_D200xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_D200xx | virtual
eoD2EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoD2EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D200xx | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_D200xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_D200xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_D200xx | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoEEP_D200xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoEEP_D200xx | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D200xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D200xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_D200xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_D200xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_D200xx | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEP_D200xx() (defined in eoEEP_D200xx) | eoEEP_D200xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D201xx Member List

This is the complete list of members for eoEEP_D201xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEP_D201xx(uint16_t size=10) | eoEEP_D201xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_D201xx | virtual
eoD2EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoD2EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D201xx | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_D201xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_D201xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_D201xx | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoEEP_D201xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoEEP_D201xx | virtual
SetLength(uint8_t type) | eoEEP_D201xx | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D201xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D201xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_D201xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_D201xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_D201xx | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEP_D201xx() (defined in eoEEP_D201xx) | eoEEP_D201xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D202xx Member List

This is the complete list of members for eoEEP_D202xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEP_D202xx(uint16_t size=10) | eoEEP_D202xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_D202xx | virtual
eoD2EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoD2EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D202xx | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_D202xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_D202xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_D202xx | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoEEP_D202xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoEEP_D202xx | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D202xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D202xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_D202xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_D202xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_D202xx | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEP_D202xx() (defined in eoEEP_D202xx) | eoEEP_D202xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D203xx Member List

This is the complete list of members for eoEEP_D203xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoEEP_D203xx | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEP_D203xx() (defined in eoEEP_D203xx) | eoEEP_D203xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D203xx | virtual
eoD2EEProfile::GetValue(CHANNEL_TYPE type, float &value) | eoD2EEProfile | virtual
eoD2EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoD2EEProfile | virtual
eoD2EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoD2EEProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoEEP_D203xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoD2EEProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D203xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D203xx | virtual
eoD2EEProfile::SetValue(CHANNEL_TYPE type, float value) | eoD2EEProfile | virtual
eoD2EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoD2EEProfile | virtual
eoD2EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoD2EEProfile | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEP_D203xx() (defined in eoEEP_D203xx) | eoEEP_D203xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D204xx Member List

This is the complete list of members for eoEEP_D204xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEP_D204xx(uint16_t size=4) | eoEEP_D204xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D204xx | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_D204xx | virtual
eoD2EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoD2EEProfile | virtual
eoD2EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoD2EEProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoD2EEProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D204xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D204xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_D204xx | virtual
eoD2EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoD2EEProfile | virtual
eoD2EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoD2EEProfile | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEP_D204xx() (defined in eoEEP_D204xx) | eoEEP_D204xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D205xx Member List

This is the complete list of members for eoEEP_D205xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEP_D205xx(uint16_t size=10) | eoEEP_D205xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_D205xx | virtual
eoD2EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoD2EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D205xx | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_D205xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_D205xx | virtual
eoD2EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoD2EEProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoEEP_D205xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoEEP_D205xx | virtual
SetLength(uint8_t type) | eoEEP_D205xx | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D205xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D205xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_D205xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_D205xx | virtual
eoD2EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoD2EEProfile | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEP_D205xx() (defined in eoEEP_D205xx) | eoEEP_D205xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D206xx Member List

This is the complete list of members for eoEEP_D206xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEP_D206xx(uint16_t size=10) | eoEEP_D206xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_D206xx | virtual
eoD2EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoD2EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D206xx | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_D206xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_D206xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_D206xx | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoEEP_D206xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoEEP_D206xx | virtual
SetLength(uint8_t type) | eoEEP_D206xx | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D206xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D206xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_D206xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_D206xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_D206xx | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEP_D206xx() (defined in eoEEP_D206xx) | eoEEP_D206xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D210xx Member List

This is the complete list of members for eoEEP_D210xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEP_D210xx(uint16_t size=10) | eoEEP_D210xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_D210xx | virtual
eoD2EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoD2EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D210xx | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_D210xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_D210xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_D210xx | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoEEP_D210xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoEEP_D210xx | virtual
SetLength(uint8_t type) | eoEEP_D210xx | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D210xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D210xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_D210xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_D210xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_D210xx | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEP_D210xx() (defined in eoEEP_D210xx) | eoEEP_D210xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D220xx Member List

This is the complete list of members for eoEEP_D220xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEP_D220xx(uint16_t size=4) | eoEEP_D220xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_D220xx | virtual
eoD2EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoD2EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D220xx | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_D220xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_D220xx | virtual
eoD2EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoD2EEProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoEEP_D220xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoD2EEProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D220xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D220xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_D220xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_D220xx | virtual
eoD2EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoD2EEProfile | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEP_D220xx() (defined in eoEEP_D220xx) | eoEEP_D220xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D230xx Member List

This is the complete list of members for eoEEP_D230xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEP_D230xx(uint16_t size=10) | eoEEP_D230xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subFlag) | eoEEP_D230xx | virtual
eoD2EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoD2EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D230xx | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_D230xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_D230xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_D230xx | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoEEP_D230xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoEEP_D230xx | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D230xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D230xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_D230xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_D230xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_D230xx | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEP_D230xx() (defined in eoEEP_D230xx) | eoEEP_D230xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D231xx Member List

This is the complete list of members for eoEEP_D231xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEP_D231xx(uint16_t size=10) | eoEEP_D231xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subFlag) | eoEEP_D231xx | virtual
eoD2EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoD2EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D231xx | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_D231xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_D231xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_D231xx | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoEEP_D231xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoEEP_D231xx | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D231xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D231xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_D231xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_D231xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_D231xx | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEP_D231xx() (defined in eoEEP_D231xx) | eoEEP_D231xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D232xx Member List

This is the complete list of members for eoEEP_D232xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEP_D232xx() (defined in eoEEP_D232xx) | eoEEP_D232xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_D232xx | virtual
eoD2EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoD2EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_D232xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D232xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_D232xx | virtual
eoD2EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoD2EEProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoD2EEProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D232xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_D232xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D232xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_D232xx | virtual
eoD2EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoD2EEProfile | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEP_D232xx() (defined in eoEEP_D232xx) | eoEEP_D232xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D240xx Member List

This is the complete list of members for eoEEP_D240xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoD2EEProfile | virtual
eoD2EEProfile(uint16_t size=4) | eoD2EEProfile |
eoEEP_D240xx(uint16_t size=4) | eoEEP_D240xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t index) | eoEEP_D240xx | virtual
eoD2EEProfile::GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
eoD2EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D240xx | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoEEP_D240xx | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoEEP_D240xx | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoEEP_D240xx | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoEEP_D240xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetCommand(uint8_t cmd) | eoEEP_D240xx | virtual
SetLength(uint8_t type) | eoEEP_D240xx | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D240xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D240xx | virtual
SetValue(CHANNEL_TYPE type, float value) | eoEEP_D240xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoEEP_D240xx | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoEEP_D240xx | virtual
type | eoProfile |
~eoD2EEProfile() (defined in eoD2EEProfile) | eoD2EEProfile | virtual
~eoEEP_D240xx() (defined in eoEEP_D240xx) | eoEEP_D240xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_D500xx Member List

This is the complete list of members for eoEEP_D500xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoA5EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoA5EEProfile | virtual
eoA5EEProfile(uint16_t size=4) | eoA5EEProfile |
eoEEP_D500xx() (defined in eoEEP_D500xx) | eoEEP_D500xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_D500xx | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value) | eoA5EEProfile | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t index) | eoA5EEProfile | virtual
eoA5EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index) | eoA5EEProfile | virtual
Is4BSData(const eoMessage &m) | eoA5EEProfile |
IsSecDData(const eoMessage &m) | eoA5EEProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoEEP_D500xx | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_D500xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_D500xx | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value) | eoA5EEProfile | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index) | eoA5EEProfile | virtual
eoA5EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t index) | eoA5EEProfile | virtual
type | eoProfile |
~eoA5EEProfile() (defined in eoA5EEProfile) | eoA5EEProfile | virtual
~eoEEP_D500xx() (defined in eoEEP_D500xx) | eoEEP_D500xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_F602xx Member List

This is the complete list of members for eoEEP_F602xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoEEP_F602xx | virtual
Create(eoMessage &msg) | eoF6EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoProfile | virtual
eoEEP_F602xx() (defined in eoEEP_F602xx) | eoEEP_F602xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoF6EEProfile() (defined in eoF6EEProfile) | eoF6EEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type) | eoEEP_F602xx | virtual
eoF6EEProfile::GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
eoF6EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_F602xx | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, float &value) | eoProfile | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag) | eoProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoF6EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_F602xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_F602xx | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, float value) | eoProfile | virtual
type | eoProfile |
~eoEEP_F602xx() (defined in eoEEP_F602xx) | eoEEP_F602xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoF6EEProfile() (defined in eoF6EEProfile) | eoF6EEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_F603xx Member List

This is the complete list of members for eoEEP_F603xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoEEP_F603xx | virtual
Create(eoMessage &msg) | eoF6EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoProfile | virtual
eoEEP_F603xx() (defined in eoEEP_F603xx) | eoEEP_F603xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoF6EEProfile() (defined in eoF6EEProfile) | eoF6EEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type) | eoEEP_F603xx | virtual
eoF6EEProfile::GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
eoF6EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_F603xx | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, float &value) | eoProfile | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag) | eoProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoF6EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_F603xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_F603xx | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, float value) | eoProfile | virtual
type | eoProfile |
~eoEEP_F603xx() (defined in eoEEP_F603xx) | eoEEP_F603xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoF6EEProfile() (defined in eoF6EEProfile) | eoF6EEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_F604xx Member List

This is the complete list of members for eoEEP_F604xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &msg) | eoF6EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoProfile | virtual
eoEEP_F604xx() (defined in eoEEP_F604xx) | eoEEP_F604xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoF6EEProfile() (defined in eoF6EEProfile) | eoF6EEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type) | eoEEP_F604xx | virtual
eoF6EEProfile::GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
eoF6EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_F604xx | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, float &value) | eoProfile | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag) | eoProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoF6EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_F604xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_F604xx | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, float value) | eoProfile | virtual
type | eoProfile |
~eoEEP_F604xx() (defined in eoEEP_F604xx) | eoEEP_F604xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoF6EEProfile() (defined in eoF6EEProfile) | eoF6EEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_F605xx Member List

This is the complete list of members for eoEEP_F605xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &msg) | eoF6EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoProfile | virtual
eoEEP_F605xx() (defined in eoEEP_F605xx) | eoEEP_F605xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoF6EEProfile() (defined in eoF6EEProfile) | eoF6EEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type) | eoEEP_F605xx | virtual
eoF6EEProfile::GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
eoF6EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_F605xx | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, float &value) | eoProfile | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag) | eoProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoF6EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_F605xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_F605xx | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, float value) | eoProfile | virtual
type | eoProfile |
~eoEEP_F605xx() (defined in eoEEP_F605xx) | eoEEP_F605xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoF6EEProfile() (defined in eoF6EEProfile) | eoF6EEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEP_F610xx Member List

This is the complete list of members for eoEEP_F610xx, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &msg) | eoF6EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoProfile | virtual
eoEEP_F610xx() (defined in eoEEP_F610xx) | eoEEP_F610xx |
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoF6EEProfile() (defined in eoF6EEProfile) | eoF6EEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type) | eoEEP_F610xx | virtual
eoF6EEProfile::GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
eoF6EEProfile::GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoEEP_F610xx | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, float &value) | eoProfile | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag) | eoProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoF6EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoEEP_F610xx | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoEEP_F610xx | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, float value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t subFlag) | eoProfile | virtual
eoF6EEProfile::SetValue(CHANNEL_TYPE type, float value) | eoProfile | virtual
type | eoProfile |
~eoEEP_F610xx() (defined in eoEEP_F610xx) | eoEEP_F610xx | virtual
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoF6EEProfile() (defined in eoF6EEProfile) | eoF6EEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEPChannelInfo Member List

This is the complete list of members for eoEEPChannelInfo, including all inherited members.

eepItem | eoEEPChannelInfo
max | eoChannelInfo
min | eoChannelInfo
signalType | eoChannelInfo
ToString(uint8_t strType) | eoChannelInfo
type | eoChannelInfo
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoEEProfile Member List

This is the complete list of members for eoEEProfile, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoProfile | virtual
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoProfile | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag) | eoProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag) | eoProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoProfile | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t subFlag) | eoProfile | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t subFlag) | eoProfile | virtual
SetValue(CHANNEL_TYPE type, float value) | eoProfile | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoProfile | virtual
type | eoProfile |
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoF6EEProfile Member List

This is the complete list of members for eoF6EEProfile, including all inherited members.

channel | eoEEProfile | protected
channelCount | eoEEProfile | protected
ClearValues() | eoProfile | virtual
Create(eoMessage &msg) | eoF6EEProfile | virtual
CreateTeachIN(eoMessage &m) | eoProfile | virtual
eoEEProfile(uint16_t size=4) | eoEEProfile |
eoF6EEProfile() (defined in eoF6EEProfile) | eoF6EEProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoEEProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoEEProfile | virtual
GetChannel(uint8_t channelNumber) | eoEEProfile | virtual
GetChannelCount() const | eoEEProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoEEProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoProfile | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag) | eoProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag) | eoProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoF6EEProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoProfile | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t subFlag) | eoProfile | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t subFlag) | eoProfile | virtual
SetValue(CHANNEL_TYPE type, float value) | eoProfile | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoProfile | virtual
type | eoProfile |
~eoEEProfile() (defined in eoEEProfile) | eoEEProfile | virtual
~eoF6EEProfile() (defined in eoF6EEProfile) | eoF6EEProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoFilterFactory Member List

This is the complete list of members for eoFilterFactory, including all inherited members.

CreateFilter(uint8_t type) | eoFilterFactory | static
eoFilterFactory() (defined in eoFilterFactory) | eoFilterFactory |
~eoFilterFactory() (defined in eoFilterFactory) | eoFilterFactory | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoGPChannelInfo Member List

This is the complete list of members for eoGPChannelInfo, including all inherited members.

bitoffs | eoGPChannelInfo |
eoGPChannelInfo() | eoGPChannelInfo |
eoGPChannelInfo(CHANNEL_TYPE type, GP_RESOLUTION resolution, int8_t engMaximum, int8_t engMinimum, GP_SCALING scaleMaximum, GP_SCALING scaleMinimum) | eoGPChannelInfo |
eoISerialize() (defined in eoISerialize) | eoISerialize |
GetEngMax() const | eoGPChannelInfo |
GetEngMin() const | eoGPChannelInfo |
GetGPChannelType() const | eoGPChannelInfo |
GetRejected() | eoGPChannelInfo |
GetResolution() const | eoGPChannelInfo |
GetScaleMax() const | eoGPChannelInfo |
GetScaleMin() const | eoGPChannelInfo |
max | eoChannelInfo |
min | eoChannelInfo |
Scale(int8_t engMaximum) | eoGPChannelInfo |
ScaleToFloat(GP_SCALING scale) | eoGPChannelInfo | static
Serialize(eoArchive &a) | eoGPChannelInfo | virtual
SetRejected(uint8_t rejected) | eoGPChannelInfo |
signalType | eoChannelInfo |
ToString(uint8_t strType) | eoChannelInfo |
type | eoChannelInfo |
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoGateway Member List

This is the complete list of members for eoGateway, including all inherited members.

advancedMode | eoGateway |
Close() | eoGateway |
commands | eoGateway |
device | eoGateway |
deviceManager | eoGateway |
eoGateway() | eoGateway |
eoGateway(eoDeviceManager *devManager) | eoGateway |
eoGateway(eoPacketStream *str) | eoGateway |
eoGateway(eoPacketStream *str, eoDeviceManager *devManager) | eoGateway |
eoGateway(eoPacketStream *str, eoDeviceManager *devManager, eoIFilter *normFilter, eoIFilter *lrnFilter) | eoGateway |
eoISerialize() (defined in eoISerialize) | eoISerialize |
errorCode | eoGateway |
filter | eoGateway |
GetSecWatchResult() const | eoGateway | inline
learnFilter | eoGateway |
LearnMode | eoGateway |
LearnModeOff() | eoGateway | inline
LearnModeOn() | eoGateway | inline
message | eoGateway |
Open(const char *port) | eoGateway |
packet | eoGateway |
Receive() | eoGateway |
reManMessage | eoGateway |
responsePacket | eoGateway |
security | eoGateway |
secWatcher | eoGateway |
Send(const eoPacket &p) | eoGateway |
Send(const eoMessage &msg) | eoGateway |
Send(const eoReManMessage &reMsg) | eoGateway | virtual
Serialize(eoArchive &arch) | eoGateway | virtual
stream | eoGateway |
TeachInModule | eoGateway |
telegram | eoGateway |
~eoGateway() (defined in eoGateway) | eoGateway | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoGenericProfile Member List

This is the complete list of members for eoGenericProfile, including all inherited members.

AddChannel(CHANNEL_TYPE type, GP_RESOLUTION resolution, int8_t engMaximum, int8_t engMinimum, GP_SCALING scaleMaximum, GP_SCALING scaleMinimum, VALUE_TYPE valueType) | eoGenericProfile |
AddChannel(CHANNEL_TYPE type, VALUE_TYPE valueType) | eoGenericProfile |
AddChannel(CHANNEL_TYPE type, GP_RESOLUTION resolution, VALUE_TYPE valueType) | eoGenericProfile |
AddChannelOut(CHANNEL_TYPE type, GP_RESOLUTION resolution, int8_t engMaximum, int8_t engMinimum, GP_SCALING scaleMaximum, GP_SCALING scaleMinimum, VALUE_TYPE valueType) | eoGenericProfile |
AddChannelOut(CHANNEL_TYPE type, VALUE_TYPE valueType) | eoGenericProfile |
AddChannelOut(CHANNEL_TYPE type, GP_RESOLUTION resolution, VALUE_TYPE valueType) | eoGenericProfile |
AllowTeachIN() | eoGenericProfile |
ClearChannels() | eoGenericProfile |
ClearChannelsOut() | eoGenericProfile |
ClearValues() | eoGenericProfile | virtual
Create(eoMessage &m, std::vector< int > channelNumbers) | eoGenericProfile |
Create(eoMessage &msg) | eoGenericProfile | virtual
CreateTeachIN(eoMessage &msg) | eoGenericProfile | virtual
dataDirection | eoGenericProfile |
eoGenericProfile() (defined in eoGenericProfile) | eoGenericProfile |
eoGenericProfile(uint16_t msgLength) | eoGenericProfile |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type) | eoGenericProfile | virtual
GetChannel(uint8_t channelNumber) | eoGenericProfile | virtual
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoGenericProfile | virtual
GetChannelCount() const | eoGenericProfile | virtual
GetChannelCountOut() const | eoGenericProfile |
GetChannelOut(CHANNEL_TYPE type) | eoGenericProfile |
GetChannelOut(uint8_t channelNumber) | eoGenericProfile |
GetChannelOut(CHANNEL_TYPE type, uint8_t subType) | eoGenericProfile |
GetProductId() | eoGenericProfile |
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoGenericProfile | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag) | eoGenericProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoGenericProfile | virtual
eoProfile::GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag) | eoProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoGenericProfile &othProfile) const | eoGenericProfile |
eoProfile::operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoGenericProfile &othProfile) const | eoGenericProfile |
eoProfile::operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoGenericProfile | virtual
ParseSelData(const eoMessage &msg) | eoGenericProfile |
ParseTeachIN(const eoMessage &msg) | eoGenericProfile |
purpose | eoGenericProfile |
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoGenericProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetProductId(const uint32_t prodId) | eoGenericProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoGenericProfile | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t subFlag) | eoGenericProfile | virtual
SetValue(CHANNEL_TYPE type, float value) | eoGenericProfile | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoGenericProfile | virtual
eoProfile::SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t subFlag) | eoProfile | virtual
type | eoProfile |
~eoGenericProfile() (defined in eoGenericProfile) | eoGenericProfile | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoGpChainer Member List

This is the complete list of members for eoGpChainer, including all inherited members.

CleanUpList() | eoGpChainer |
eoGpChainer() (defined in eoGpChainer) | eoGpChainer |
ParseChainedMessage(eoTelegram &tel, eoMessage &msg) | eoGpChainer |
SendChainedMessage(const eoMessage &msg, eoGateway &gateway) | eoGpChainer |
~eoGpChainer() (defined in eoGpChainer) | eoGpChainer | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoHeader Member List

This is the complete list of members for eoHeader, including all inherited members.

eoHeader() (defined in eoHeader) | eoHeader |
eoHeader(uint8_t majorVersion, uint8_t minorVersion, const char *handlerName) | eoHeader |
eoISerialize() (defined in eoISerialize) | eoISerialize |
major | eoHeader |
minor | eoHeader |
name | eoHeader |
Serialize(eoArchive &arch) | eoHeader | virtual
~eoHeader() (defined in eoHeader) | eoHeader | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoIDFilter Member List

This is the complete list of members for eoIDFilter, including all inherited members.

Add(uint32_t id) | eoIDFilter |
eoIDFilter() (defined in eoIDFilter) | eoIDFilter |
eoIFilter() (defined in eoIFilter) | eoIFilter |
eoISerialize() (defined in eoISerialize) | eoISerialize |
Filter(eoMessage &msg) | eoIDFilter | virtual
Filter(eoTelegram &tel) | eoIDFilter | virtual
Remove(uint32_t id) | eoIDFilter |
RemoveAll() | eoIDFilter | virtual
Serialize(eoArchive &arch) | eoIDFilter | virtual
type | eoIFilter |
~eoIDFilter() (defined in eoIDFilter) | eoIDFilter | virtual
~eoIFilter() (defined in eoIFilter) | eoIFilter | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoIFilter Member List

This is the complete list of members for eoIFilter, including all inherited members.

eoIFilter() (defined in eoIFilter) | eoIFilter |
eoISerialize() (defined in eoISerialize) | eoISerialize |
Filter(eoMessage &msg) | eoIFilter | virtual
Filter(eoTelegram &tel) | eoIFilter | virtual
RemoveAll() | eoIFilter | virtual
Serialize(eoArchive &arch) | eoIFilter | virtual
type | eoIFilter |
~eoIFilter() (defined in eoIFilter) | eoIFilter | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoISerialize Member List

This is the complete list of members for eoISerialize, including all inherited members.

eoISerialize() (defined in eoISerialize) | eoISerialize |
Serialize(eoArchive &arch) | eoISerialize | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoISimpleBidirectionalProfile Member List

This is the complete list of members for eoISimpleBidirectionalProfile, including all inherited members.

direction (defined in eoISimpleBidirectionalProfile) | eoISimpleBidirectionalProfile | protected
eoISimpleBidirectionalProfile() (defined in eoISimpleBidirectionalProfile) | eoISimpleBidirectionalProfile | inline
GetOutChannel(CHANNEL_TYPE type, uint8_t subType) | eoISimpleBidirectionalProfile | inlinevirtual
GetOutChannel(CHANNEL_TYPE type)=0 | eoISimpleBidirectionalProfile | pure virtual
GetOutChannel(uint8_t channelNumber)=0 | eoISimpleBidirectionalProfile | pure virtual
SetDirection(SIMPLE_DIRECTION direction)=0 | eoISimpleBidirectionalProfile | pure virtual
~eoISimpleBidirectionalProfile() (defined in eoISimpleBidirectionalProfile) | eoISimpleBidirectionalProfile | inlinevirtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoIWatcher Member List

This is the complete list of members for eoIWatcher, including all inherited members.

CheckSecurity(eoDevice const *const device, eoTelegram const &tel) | eoIWatcher | virtual
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoIWatcher() (defined in eoIWatcher) | eoIWatcher |
Serialize(eoArchive &arch) | eoIWatcher | virtual
type | eoIWatcher |
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoIWatcher() (defined in eoIWatcher) | eoIWatcher | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoLinuxPacketStream Member List

This is the complete list of members for eoLinuxPacketStream, including all inherited members.

Close() | eoLinuxPacketStream | virtual
eoLinuxPacketStream() (defined in eoLinuxPacketStream) | eoLinuxPacketStream |
eoPacketStream() | eoPacketStream |
IsPacketPending() | eoPacketStream | virtual
Open(const char *port) | eoLinuxPacketStream | virtual
Receive(eoPacket *p) | eoPacketStream | virtual
ReceiveByte(uint8_t *u8RxByte) | eoLinuxPacketStream | virtual
Send(const eoPacket &p) | eoPacketStream | virtual
SendByte(uint8_t u8TxByte) | eoLinuxPacketStream | virtual
~eoLinuxPacketStream() (defined in eoLinuxPacketStream) | eoLinuxPacketStream | virtual
~eoPacketStream() (defined in eoPacketStream) | eoPacketStream | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoLogger Member List

This is the complete list of members for eoLogger, including all inherited members.

Close() | eoLogger |
eoLogger() | eoLogger |
Flush() | eoLogger |
Log(eoPacket &p, bool flush=false) | eoLogger |
Log(eoTelegram &tel, bool flush=false) | eoLogger |
Open(const char *filename) | eoLogger |
~eoLogger() (defined in eoLogger) | eoLogger | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoMSCHelper Member List

This is the complete list of members for eoMSCHelper, including all inherited members.

GetMSCmanufacturer(MANUFACTURER_LIST *manufacturer, eoMessage &msg) | eoMSCHelper
GetMSCpayload(uint8_t *payload, uint8_t maxDataCount, eoMessage &msg) | eoMSCHelper
SetMSCmanufacturer(const MANUFACTURER_LIST manufacturer, eoMessage &msg) | eoMSCHelper
SetMSCpayload(const uint8_t *payload, uint8_t dataCount, eoMessage &msg) | eoMSCHelper
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoManufacturer Member List

This is the complete list of members for eoManufacturer, including all inherited members.

GetName(const uint16_t manufacturerID) | eoManufacturer | static
~eoManufacturer() (defined in eoManufacturer) | eoManufacturer | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoMessage Member List

This is the complete list of members for eoMessage, including all inherited members.

Clear() | eoMessage | virtual
copyTo(eoMessage &msg) const | eoMessage |
data | eoAbstractMessage |
dataLength | eoAbstractMessage |
destinationID | eoMessage |
eoAbstractMessage(uint16_t size=1) | eoAbstractMessage | protected
eoMessage(uint16_t size=1) | eoMessage |
eoMessage(const eoTelegram &tel) | eoMessage |
GetDataLength() const | eoAbstractMessage |
GetMaxLength() const | eoAbstractMessage |
maxLength | eoAbstractMessage |
RORG | eoMessage |
securityLevel | eoMessage |
SetDataLength(uint16_t dataLen, bool reallocate=false) | eoAbstractMessage |
sourceID | eoMessage |
status | eoMessage |
~eoAbstractMessage() (defined in eoAbstractMessage) | eoAbstractMessage | protectedvirtual
~eoMessage() (defined in eoMessage) | eoMessage | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoMessageHandler Member List

This is the complete list of members for eoMessageHandler, including all inherited members.

CleanUpChainerLists() | eoMessageHandler |
ComposeChainedMessage(const eoMessage &msg, eoGateway &gateway) | eoMessageHandler |
ComposeChainedMessage(const eoReManMessage &reMsg, eoGateway &gateway) | eoMessageHandler |
eoMessageHandler() (defined in eoMessageHandler) | eoMessageHandler |
ProcessTelegram(eoTelegram &tel, eoMessage &msg) | eoMessageHandler |
ProcessTelegram(eoTelegram &tel, eoReManMessage &msg) | eoMessageHandler |
~eoMessageHandler() (defined in eoMessageHandler) | eoMessageHandler | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoPacket Member List

This is the complete list of members for eoPacket, including all inherited members.

copyTo(eoPacket &packet) | eoPacket |
data | eoPacket |
dataLength | eoPacket |
eoPacket() | eoPacket |
eoPacket(uint8_t *dataBuffer, uint16_t size) | eoPacket |
eoPacket(uint16_t size) | eoPacket |
eoPacket(eoPacket &packet) | eoPacket |
getBufferSize() | eoPacket |
optionalLength | eoPacket |
type | eoPacket |
~eoPacket() (defined in eoPacket) | eoPacket | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoPacketStream Member List

This is the complete list of members for eoPacketStream, including all inherited members.

Close()=0 | eoPacketStream | pure virtual
eoPacketStream() | eoPacketStream |
IsPacketPending() | eoPacketStream | virtual
Open(const char *port)=0 | eoPacketStream | pure virtual
Receive(eoPacket *p) | eoPacketStream | virtual
ReceiveByte(uint8_t *d)=0 | eoPacketStream | pure virtual
Send(const eoPacket &p) | eoPacketStream | virtual
SendByte(uint8_t d)=0 | eoPacketStream | pure virtual
~eoPacketStream() (defined in eoPacketStream) | eoPacketStream | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoProc Member List

This is the complete list of members for eoProc, including all inherited members.

crc16(uint16_t CRC, uint16_t Data) | eoProc | static
crc8(uint8_t CRC, uint8_t Data) | eoProc | static
eoProc() (defined in eoProc) | eoProc |
~eoProc() (defined in eoProc) | eoProc | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoProfile Member List

This is the complete list of members for eoProfile, including all inherited members.

ClearValues() | eoProfile | virtual
Create(eoMessage &m) | eoProfile | virtual
CreateTeachIN(eoMessage &m) | eoProfile | virtual
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoProfile(uint16_t size=0) | eoProfile |
func | eoProfile |
GetChannel(CHANNEL_TYPE type, uint8_t subType) | eoProfile | virtual
GetChannel(CHANNEL_TYPE type) | eoProfile | virtual
GetChannel(uint8_t channelNumber) | eoProfile | virtual
GetChannelCount() const | eoProfile | virtual
GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
GetSubTypeChannel(CHANNEL_TYPE type, std::vector< eoEEPChannelInfo * > &vector) | eoProfile | virtual
GetValue(CHANNEL_TYPE type, float &value) | eoProfile | virtual
GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag) | eoProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag) | eoProfile | virtual
GetValue(CHANNEL_TYPE type, uint8_t &value) | eoProfile | virtual
IsSecDData(const eoMessage &message) | eoProfile | virtual
manufacturer | eoProfile |
maskArray | eoProfile | protectedstatic
msg | eoProfile | protected
operator!=(const eoProfile &othProfile) const | eoProfile | virtual
operator==(const eoProfile &othProfile) const | eoProfile | virtual
Parse(const eoMessage &msg) | eoProfile | virtual
rorg | eoProfile |
ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax) | eoProfile | protected
Serialize(eoArchive &a) | eoProfile | virtual
SetManufacturer(uint16_t manufacturerID) | eoProfile |
SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size) | eoProfile | protectedstatic
SetType(uint8_t type) | eoProfile | virtual
SetValue(CHANNEL_TYPE type, float value, uint8_t subFlag) | eoProfile | virtual
SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t subFlag) | eoProfile | virtual
SetValue(CHANNEL_TYPE type, float value) | eoProfile | virtual
SetValue(CHANNEL_TYPE type, uint8_t value) | eoProfile | virtual
type | eoProfile |
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoProfile() (defined in eoProfile) | eoProfile | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoProfileFactory Member List

This is the complete list of members for eoProfileFactory, including all inherited members.

CreateProfile(const eoMessage &msg) | eoProfileFactory | static
CreateProfile(const uint8_t rorg, const uint8_t func, const uint8_t type) | eoProfileFactory | static
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoReCom Member List

This is the complete list of members for eoReCom, including all inherited members.

ApplyChanges(QUERY_APPLY_CHANGES const &changes, uint32_t destinationID) | eoReCom
eoReCom(eoGateway *gateway) | eoReCom
GetDeviceConfig(QUERY_DEVICE_CONFIG const &deviceConf, uint32_t destinationID) | eoReCom
GetGPLinkTable(GP_LINK_TABLE const &query, uint32_t destinationID) | eoReCom
GetLinkBasedConfig(QUERY_LINK_BASED_CONFIG const &linkConfig, uint32_t destinationID) | eoReCom
GetLinkTable(QUERY_LINK_TABLE const &query, uint32_t const destinationID) | eoReCom
GetMetadata(uint32_t destinationID) | eoReCom
GetProductID(uint32_t destinationID=BROADCAST_ID) | eoReCom
GetRepeater(uint32_t destinationID) | eoReCom
ParseDeviceConfigResponse(std::vector< DEVICE_CONFIG > &deviceConf) const | eoReCom
ParseGetGPLinkTableResponse(GP_LINK_TABLE &query) const | eoReCom
ParseGetLinkTableResponse(std::vector< LINK_TABLE > &response, RECOM_TABLE_DIR &tableDir) const | eoReCom
ParseGetMetadataResponse(QUERY_METADATA_RESPONSE &response) const | eoReCom
ParseGetProductIDResponse(QUERY_PRODUCT_ID_RESPONSE &response) const | eoReCom
ParseGetRepeaterResponse(REPEATER_FUNCTIONS &response) const | eoReCom
ParseLinkBasedConfigResponse(std::vector< LINK_BASED_CONFIG > &linkConfig) const | eoReCom
RadioLinkTest(QUERY_RADIO_LINK_TEST const &radioLink, uint32_t destinationID) | eoReCom
RemoteSetLearnMode(QUERY_SET_LEARN_MODE const &learnMode, uint32_t destinationID) | eoReCom
ResetDefaults(QUERY_RESET_DEFAULTS const &defaults, uint32_t destinationID) | eoReCom
SetDeviceConfig(std::vector< DEVICE_CONFIG > const &deviceConf, uint32_t destinationID) | eoReCom
SetGPLinkTable(GP_LINK_TABLE const &query, uint32_t destinationID) | eoReCom
SetLinkBasedConfig(std::vector< LINK_BASED_CONFIG > const &linkConfig, uint32_t destinationID) | eoReCom
SetLinkTable(std::vector< LINK_TABLE > const &query, RECOM_TABLE_DIR tableDir, uint32_t destinationID) | eoReCom
SetRepeater(REPEATER_FUNCTIONS const &repeaterFunc, uint32_t destinationID) | eoReCom
SetRepeaterFilter(QUERY_SET_REPEATER_FILTER const &repeaterFunc, uint32_t destinationID) | eoReCom
TriggerOutboundTeachRequest(uint8_t channel, uint32_t destinationID) | eoReCom
~eoReCom() (defined in eoReCom) | eoReCom
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoReManChainer Member List

This is the complete list of members for eoReManChainer, including all inherited members.

CleanUpList() | eoReManChainer |
eoReManChainer() (defined in eoReManChainer) | eoReManChainer |
ParseChainedMessage(eoTelegram &tel, eoReManMessage &msg) | eoReManChainer |
SendChainedMessage(const eoReManMessage &msg, eoGateway &gateway) | eoReManChainer |
~eoReManChainer() (defined in eoReManChainer) | eoReManChainer | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoReManMessage Member List

This is the complete list of members for eoReManMessage, including all inherited members.

copyTo(eoReManMessage &msg) const | eoReManMessage |
data | eoAbstractMessage |
dataLength | eoAbstractMessage |
destinationID | eoReManMessage |
eoAbstractMessage(uint16_t size=1) | eoAbstractMessage | protected
eoReManMessage(uint16_t size) | eoReManMessage |
fnCode | eoReManMessage |
GetDataLength() const | eoAbstractMessage |
GetMaxLength() const | eoAbstractMessage |
manufacturerID | eoReManMessage |
maxLength | eoAbstractMessage |
securityLevel | eoReManMessage |
SetDataLength(uint16_t dataLen, bool reallocate=false) | eoAbstractMessage |
sourceID | eoReManMessage |
~eoAbstractMessage() (defined in eoAbstractMessage) | eoAbstractMessage | protectedvirtual
~eoReManMessage() (defined in eoReManMessage) | eoReManMessage | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoRemoteManager Member List

This is the complete list of members for eoRemoteManager, including all inherited members.

Action(const uint32_t destinationID) | eoRemoteManager
eoRemoteManager(eoGateway *gateway) | eoRemoteManager
Lock(const uint32_t securityCode, const uint32_t destinationID) | eoRemoteManager
ParsePingAnswer(PING_RESPONSE &response) | eoRemoteManager
ParseQueryFunctionAnswer(QUERY_FUNCTION_RESPONSE *response, uint8_t maxIDCount, uint8_t &IDCount) | eoRemoteManager
ParseQueryIDAnswer(QUERY_ID &response) | eoRemoteManager
ParseQueryStatusAnswer(QUERY_STATUS_RESPONSE &response) | eoRemoteManager
ParseRemoteFlashReadAnswer(FLASH_READ_RESPONSE *response, uint16_t *dataCount, uint8_t maxDataCount) | eoRemoteManager
ParseRemoteSmartReadLearnedSensors(LEARNED_SENSOR_RESPONSE *response, uint8_t *learnedCount, uint8_t maxLearnedCount) | eoRemoteManager
ParseRemoteSmartReadMailboxSettingsAnswer(MAILBOX_SETTINGS_RESPONSE &response) | eoRemoteManager
Ping(const uint32_t destinationID) | eoRemoteManager
QueryFunction(const uint32_t destinationID) | eoRemoteManager
QueryID(const QUERY_ID &msg) | eoRemoteManager
QueryStatus(const uint32_t destinationID) | eoRemoteManager
RemoteFlashRead(const uint32_t destinationID, const uint16_t &memoryAddress, const uint16_t numOfBytes) | eoRemoteManager
RemoteFlashWrite(const uint32_t destinationID, const uint16_t &memoryAddress, const uint16_t numOfBytes, const uint8_t data[]) | eoRemoteManager
RemoteLearnIn(const uint32_t destinationID, REMOTE_TYPE learnFlag) | eoRemoteManager
RemoteSmartAddMailbox(const uint32_t destinationID, const uint8_t mailboxIndex, const uint32_t sensorID, const uint32_t postmasterID) | eoRemoteManager
RemoteSmartDeleteMailbox(const uint32_t destinationID, const uint8_t mailboxIndex) | eoRemoteManager
RemoteSmartLearnIn(const uint32_t destinationID, const uint8_t learnCount, const uint32_t sensorID, const uint32_t controllerID) | eoRemoteManager
RemoteSmartLearnOut(const uint32_t destinationID, const uint8_t learnCount, const uint32_t sensorID, const uint32_t controllerID) | eoRemoteManager
RemoteSmartReadLearnedSensors(const uint32_t destinationID) | eoRemoteManager
RemoteSmartReadMailboxSettings(const uint32_t destinationID) | eoRemoteManager
SetCode(const uint32_t securityCode, const uint32_t destinationID) | eoRemoteManager
UnLock(const uint32_t securityCode, const uint32_t destinationID) | eoRemoteManager
~eoRemoteManager() (defined in eoRemoteManager) | eoRemoteManager
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoRollingCodeStorage Member List

This is the complete list of members for eoRollingCodeStorage, including all inherited members.

eoRollingCodeStorage() | eoRollingCodeStorage |
GetRLC(uint32_t id, uint32_t &rlc) | eoRollingCodeStorage |
Load(const char *file) | eoRollingCodeStorage |
RemoveID(uint32_t id) | eoRollingCodeStorage |
Save(const char *file) | eoRollingCodeStorage |
SetRLC(uint32_t id, uint32_t rlc) | eoRollingCodeStorage |
~eoRollingCodeStorage() (defined in eoRollingCodeStorage) | eoRollingCodeStorage | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoSecTeachInChainer Member List

This is the complete list of members for eoSecTeachInChainer, including all inherited members.

CleanUpList() | eoSecTeachInChainer |
eoSecTeachInChainer() (defined in eoSecTeachInChainer) | eoSecTeachInChainer |
list | eoSecTeachInChainer | protected
ParseChainedMessage(eoTelegram &tel, eoMessage &msg) | eoSecTeachInChainer |
SendChainedMessage(const eoMessage &msg, eoGateway &gateway) | eoSecTeachInChainer |
~eoSecTeachInChainer() (defined in eoSecTeachInChainer) | eoSecTeachInChainer | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoSecureInfo Member List

This is the complete list of members for eoSecureInfo, including all inherited members.

eoISerialize() (defined in eoISerialize) | eoISerialize |
eoSecureInfo() (defined in eoSecureInfo) | eoSecureInfo |
key | eoSecureInfo |
keySize | eoSecureInfo |
previousRollingCode | eoSecureInfo |
psk | eoSecureInfo |
rollingCode | eoSecureInfo |
securityResult | eoSecureInfo |
Serialize(eoArchive &arch) | eoSecureInfo | virtual
SLF | eoSecureInfo |
subKey1 | eoSecureInfo |
subKey2 | eoSecureInfo |
teachInInfo | eoSecureInfo |
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoSecureInfo() (defined in eoSecureInfo) | eoSecureInfo | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoSecurity Member List

This is the complete list of members for eoSecurity, including all inherited members.

CreateTeachIn(eoMessage &msgTi, eoDevice &dev) | eoSecurity |
Decrypt(eoMessage &msgSec, eoMessage &msgNonSec, eoDevice &dev) | eoSecurity |
Encrypt(eoMessage &msgNonSec, eoMessage &msgSec, eoDevice &dev) | eoSecurity |
eoSecurity() (defined in eoSecurity) | eoSecurity |
GetLastError() | eoSecurity |
ParseTeachIn(eoMessage &msgTi, eoDevice &dev) | eoSecurity |
~eoSecurity() (defined in eoSecurity) | eoSecurity | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoSerialCommand Member List

This is the complete list of members for eoSerialCommand, including all inherited members.

AddFilter(const FILTER_TYPE filterType, const uint32_t filterValue, const FILTER_KIND filterKind) | eoSerialCommand |
BIST() | eoSerialCommand |
DeleteAllFilter() | eoSerialCommand |
DeleteFilter(const FILTER_TYPE filterType, const uint32_t filterValue) | eoSerialCommand |
DutyCycleLimit(CO_DUTYCYCLE_LIMIT limit) | eoSerialCommand |
DutyCycleReadLimit(CO_RD_DUTYCYCLE_RESPONSE &response) | eoSerialCommand |
EnableFilter(const bool filterEnabled, const FILTER_OPERATOR filterOperator) | eoSerialCommand |
eoSerialCommand(eoGateway *gateway) | eoSerialCommand |
EventDutyCycleLimit(CO_DUTYCYCLE_LIMIT &request) | eoSerialCommand |
EventSmartAckConfirmLearn(SA_CONFIRM_LEARN_REQUEST &request) | eoSerialCommand |
GetSerialPacket() | eoSerialCommand |
ReadFilter(CO_RD_FILTER_RESPONSE *filter, uint8_t *filterCount, uint8_t maxFilterCount) | eoSerialCommand |
ReadIDBase(CO_RD_IDBASE_RESPONSE &response) | eoSerialCommand |
ReadRepeater(CO_RD_REPEATER_RESPONSE &response) | eoSerialCommand |
ReadVersion(CO_RD_VERSION_RESPONSE &version) | eoSerialCommand |
Ready(CO_READY_RESPONSE &response) | eoSerialCommand |
Reset() | eoSerialCommand |
Sleep(const uint32_t sleepPeriod) | eoSerialCommand |
SmartAckConfirmLearn(uint16_t responseTime, SA_CONFIRM_CODE confirmCode) | eoSerialCommand |
SmartAckLearnAck(SA_LEARN_ACK_RESPONSE &response) | eoSerialCommand |
SmartAckLearnConfirm(uint16_t responseTime, SMARTACK_CONFIRM_CODE confirmCode, uint32_t postmasterID, uint32_t clientID) | eoSerialCommand |
SmartAckLearnedClients(SA_RD_LEARNEDCLIENTS_RESPONSE *clients, uint8_t *learnedCount, uint8_t maxLearnedCount) | eoSerialCommand |
SmartAckReadLearnMode(SA_RD_LEARNMODE_RESPONSE &response) | eoSerialCommand |
SmartAckReset(uint32_t clientID) | eoSerialCommand |
SmartAckSendLearnRequest(uint16_t manufacturerID, uint32_t EEP) | eoSerialCommand |
SmartAckSetPostmaster(uint8_t mailboxCount) | eoSerialCommand |
SmartAckSetReclaimTries(uint8_t reclaimCount) | eoSerialCommand |
SmartAckWriteLearnMode(bool enable, SA_EXTENDED_LEARNMODE extended, uint32_t timeout) | eoSerialCommand |
WaitMaturity(const bool waitMaturity) | eoSerialCommand |
WriteIDBase(const uint32_t baseID) | eoSerialCommand |
WriteMode(WR_MODE_CODE mode) | eoSerialCommand |
WriteRepeater(bool repEnable, const uint8_t repLevel) | eoSerialCommand |
~eoSerialCommand() (defined in eoSerialCommand) | eoSerialCommand | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoStorageManager Member List

This is the complete list of members for eoStorageManager, including all inherited members.

addObject(const char *name, eoISerialize *object) | eoStorageManager |
eoStorageManager() | eoStorageManager |
eoStorageManager(eoArchive &archive) | eoStorageManager |
Load(const char *strBuf) | eoStorageManager |
RemoveObject(const char *name) | eoStorageManager |
Save(const char *strBuf) | eoStorageManager |
~eoStorageManager() (defined in eoStorageManager) | eoStorageManager | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoTeachInModule Member List

This is the complete list of members for eoTeachInModule, including all inherited members.

CreateGPResponse(eoMessage &msg, uint16_t manId, uint32_t destinationId, GP_RESPONSE_RESULT response, eoProfile *profile) | eoTeachInModule |
CreateUTEResponse(eoMessage &teachInUTE, eoMessage &responseUTE, UTE_RESPONSE type, UTE_DIRECTION direction) | eoTeachInModule |
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoTeachInModule(eoDeviceManager *eoDevManager, eoSecurity *sec) | eoTeachInModule |
isTeachedIN(eoMessage &telegram) | eoTeachInModule |
isTeachedIN(eoDevice &dev) | eoTeachInModule |
isTeachIN(eoMessage &telegram) | eoTeachInModule | static
ParseUTE(eoMessage &msg) | eoTeachInModule |
Serialize(eoArchive &arch) | eoTeachInModule | virtual
Set1BS(uint8_t func, uint8_t type) | eoTeachInModule |
Set4BS(uint8_t func, uint8_t type) | eoTeachInModule |
SetRPS(uint8_t func, uint8_t type) | eoTeachInModule |
TeachIN(eoMessage &m) | eoTeachInModule |
TeachIN(uint8_t rorg, uint8_t func, uint8_t type, uint32_t device_id) | eoTeachInModule |
TeachOut(uint32_t id) | eoTeachInModule |
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoTeachInModule() (defined in eoTeachInModule) | eoTeachInModule | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoTelegram Member List

This is the complete list of members for eoTelegram, including all inherited members.

Clear() | eoTelegram | virtual
copyTo(eoMessage &msg) const | eoMessage |
data | eoAbstractMessage |
dataLength | eoAbstractMessage |
dBm | eoTelegram |
destinationID | eoMessage |
eoAbstractMessage(uint16_t size=1) | eoAbstractMessage | protected
eoMessage(uint16_t size=1) | eoMessage |
eoMessage(const eoTelegram &tel) | eoMessage |
eoTelegram(const eoTelegram &telegram) | eoTelegram |
eoTelegram(uint16_t size) | eoTelegram |
GetDataLength() const | eoAbstractMessage |
GetMaxLength() const | eoAbstractMessage |
maxLength | eoAbstractMessage |
RORG | eoMessage |
securityLevel | eoMessage |
SetDataLength(uint16_t dataLen, bool reallocate=false) | eoAbstractMessage |
sourceID | eoMessage |
status | eoMessage |
subtelCount | eoTelegram |
~eoAbstractMessage() (defined in eoAbstractMessage) | eoAbstractMessage | protectedvirtual
~eoMessage() (defined in eoMessage) | eoMessage | virtual
~eoTelegram() (defined in eoTelegram) | eoTelegram | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoTimer Member List

This is the complete list of members for eoTimer, including all inherited members.

eoTimer() (defined in eoTimer) | eoTimer |
GetTickCount() | eoTimer | static
Sleep(uint32_t ms) | eoTimer | static
~eoTimer() (defined in eoTimer) | eoTimer | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoWatcher Member List

This is the complete list of members for eoWatcher, including all inherited members.

AddDevice(uint32_t const DeviceID, uint32_t const maxPerdiodTime, uint32_t const minPeriodTime, uint32_t const maxRLCDiff, uint32_t const maxWrongCmac, bool resetPeriod) | eoWatcher |
CheckDeadDevices(std::vector< uint32_t > &deadDevicesVector) | eoWatcher |
CheckSecurity(eoDevice const *const device, eoTelegram const &tel) | eoWatcher | virtual
eoISerialize() (defined in eoISerialize) | eoISerialize |
eoIWatcher() (defined in eoIWatcher) | eoIWatcher |
eoWatcher() (defined in eoWatcher) | eoWatcher |
eoWatcher(uint32_t denialWarnCount, uint32_t denialTickBetween) | eoWatcher |
GetDenialTickBetween() const | eoWatcher | inline
GetDenialWarnCount() const | eoWatcher | inline
RemoveDevice(uint32_t const DeviceID) | eoWatcher |
Reset(uint32_t const DeviceID) | eoWatcher |
Serialize(eoArchive &arch) | eoWatcher | virtual
SetDenialTickBetween(uint32_t const tickCount) | eoWatcher | inline
SetDenialWarnCount(uint32_t const warnCount) | eoWatcher | inline
type | eoIWatcher |
UpdateDevice(uint32_t const DeviceID, uint32_t const maxPerdiodTime, uint32_t const minPeriodTime, uint32_t const maxRLCDiff, uint32_t const maxWrongCmac, bool resetPeriod) | eoWatcher |
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
~eoIWatcher() (defined in eoIWatcher) | eoIWatcher | virtual
~eoWatcher() (defined in eoWatcher) | eoWatcher | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoWatcherFactory Member List

This is the complete list of members for eoWatcherFactory, including all inherited members.

CreateWatcher(uint8_t type) | eoWatcherFactory | static
eoWatcherFactory() (defined in eoWatcherFactory) | eoWatcherFactory |
~eoWatcherFactory() (defined in eoWatcherFactory) | eoWatcherFactory | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eoWin32PacketStream Member List

This is the complete list of members for eoWin32PacketStream, including all inherited members.

Close() | eoWin32PacketStream | virtual
eoPacketStream() | eoPacketStream |
eoWin32PacketStream() (defined in eoWin32PacketStream) | eoWin32PacketStream |
GetLastError() | eoWin32PacketStream | inline
IsPacketPending() | eoPacketStream | virtual
Open(const char *port) | eoWin32PacketStream | virtual
Receive(eoPacket *p) | eoPacketStream | virtual
ReceiveByte(uint8_t *u8RxByte) | eoWin32PacketStream | virtual
Send(const eoPacket &p) | eoPacketStream | virtual
SendByte(uint8_t u8TxByte) | eoWin32PacketStream | virtual
~eoPacketStream() (defined in eoPacketStream) | eoPacketStream | virtual
~eoWin32PacketStream() (defined in eoWin32PacketStream) | eoWin32PacketStream | virtual
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

eodBmFilter Member List

This is the complete list of members for eodBmFilter, including all inherited members.

eodBmFilter() | eodBmFilter |
eodBmFilter(int8_t maxDBm, int8_t minDBm) | eodBmFilter |
eoIFilter() (defined in eoIFilter) | eoIFilter |
eoISerialize() (defined in eoISerialize) | eoISerialize |
Filter(eoMessage &msg) | eodBmFilter | virtual
Filter(eoTelegram &tel) | eodBmFilter | virtual
maxdBm | eodBmFilter |
mindBm | eodBmFilter |
RemoveAll() | eoIFilter | virtual
Serialize(eoArchive &arch) | eodBmFilter | virtual
type | eoIFilter |
~eodBmFilter() (defined in eodBmFilter) | eodBmFilter | virtual
~eoIFilter() (defined in eoIFilter) | eoIFilter | virtual
~eoISerialize() (defined in eoISerialize) | eoISerialize | virtual
Generated on Wed Nov 18 2015 17:24:49 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

serialize_object Member List

This is the complete list of members for serialize_object, including all inherited members.

hasBeenLoaded | serialize_object
name | serialize_object
object | serialize_object
uniqueID | serialize_object
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/config.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
config.h
1 /* config.h. Generated from config.h.in by configure. */
2 /* config.h.in. Generated from configure.ac by autoheader. */
3
4 /* Define to 1 if you have the `alarm' function. */
5 #define HAVE_ALARM 1
6
7 /* Define to 1 if you have the `bzero' function. */
8 #define HAVE_BZERO 1
9
10 /* Define to 1 if you have the `clock_gettime' function. */
11 #define HAVE_CLOCK_GETTIME 1
12
13 /* Define to 1 if you have the <dlfcn.h> header file. */
14 #define HAVE_DLFCN_H 1
15
16 /* Define to 1 if you have the <fcntl.h> header file. */
17 #define HAVE_FCNTL_H 1
18
19 /* Define to 1 if you have the <inttypes.h> header file. */
20 #define HAVE_INTTYPES_H 1
21
22 /* Define to 1 if you have the `localtime_r' function. */
23 #define HAVE_LOCALTIME_R 1
24
25 /* Define to 1 if you have the <memory.h> header file. */
26 #define HAVE_MEMORY_H 1
27
28 /* Define to 1 if you have the `memset' function. */
29 #define HAVE_MEMSET 1
30
31 /* Define to 1 if stdbool.h conforms to C99. */
32 #define HAVE_STDBOOL_H 1
33
34 /* Define to 1 if you have the <stdint.h> header file. */
35 #define HAVE_STDINT_H 1
36
37 /* Define to 1 if you have the <stdlib.h> header file. */
38 #define HAVE_STDLIB_H 1
39
40 /* Define to 1 if you have the `strerror' function. */
41 #define HAVE_STRERROR 1
42
43 /* Define to 1 if you have the <strings.h> header file. */
44 #define HAVE_STRINGS_H 1
45
46 /* Define to 1 if you have the <string.h> header file. */
47 #define HAVE_STRING_H 1
48
49 /* Define to 1 if you have the <sys/stat.h> header file. */
50 #define HAVE_SYS_STAT_H 1
51
52 /* Define to 1 if you have the <sys/types.h> header file. */
53 #define HAVE_SYS_TYPES_H 1
54
55 /* Define to 1 if you have the <termios.h> header file. */
56 #define HAVE_TERMIOS_H 1
57
58 /* Define to 1 if you have the <unistd.h> header file. */
59 #define HAVE_UNISTD_H 1
60
61 /* Define to 1 if the system has the type `_Bool'. */
62 #define HAVE__BOOL 1
63
64 /* Define to the sub-directory in which libtool stores uninstalled libraries.
65 */
66 #define LT_OBJDIR ".libs/"
67
68 /* Name of package */
69 #define PACKAGE "eoLink"
70
71 /* Define to the address where bug reports for this package should be sent. */
72 #define PACKAGE_BUGREPORT "marian.honsch@enocean.com"
73
74 /* Define to the full name of this package. */
75 #define PACKAGE_NAME "EnOcean Link"
76
77 /* Define to the full name and version of this package. */
78 #define PACKAGE_STRING "EnOcean Link 1.3.x.x"
79
80 /* Define to the one symbol short name of this package. */
81 #define PACKAGE_TARNAME "eoLink"
82
83 /* Define to the home page for this package. */
84 #define PACKAGE_URL "http://www.enocean.com/en/enocean-software/enocean-link/"
85
86 /* Define to the version of this package. */
87 #define PACKAGE_VERSION "1.3.x.x"
88
89 /* Define to 1 if you have the ANSI C header files. */
90 #define STDC_HEADERS 1
91
92 /* Version number of package */
93 #define VERSION "1.3.x.x"
94
95 /* Define for Solaris 2.5.1 so the uint32_t typedef from <sys/synch.h>,
96 <pthread.h>, or <semaphore.h> is not used. If the typedef were allowed, the
97 #define below would cause a syntax error. */
98 /* #undef _UINT32_T */
99
100 /* Define for Solaris 2.5.1 so the uint64_t typedef from <sys/synch.h>,
101 <pthread.h>, or <semaphore.h> is not used. If the typedef were allowed, the
102 #define below would cause a syntax error. */
103 /* #undef _UINT64_T */
104
105 /* Define for Solaris 2.5.1 so the uint8_t typedef from <sys/synch.h>,
106 <pthread.h>, or <semaphore.h> is not used. If the typedef were allowed, the
107 #define below would cause a syntax error. */
108 /* #undef _UINT8_T */
109
110 /* Define to `__inline__' or `__inline' if that's what the C compiler
111 calls it, or to nothing if 'inline' is not supported under any name. */
112 #ifndef __cplusplus
113 /* #undef inline */
114 #endif
115
116 /* Define to the type of a signed integer type of width exactly 16 bits if
117 such a type exists and the standard includes do not define it. */
118 /* #undef int16_t */
119
120 /* Define to the type of a signed integer type of width exactly 32 bits if
121 such a type exists and the standard includes do not define it. */
122 /* #undef int32_t */
123
124 /* Define to the type of a signed integer type of width exactly 8 bits if such
125 a type exists and the standard includes do not define it. */
126 /* #undef int8_t */
127
128 /* Define to `unsigned int' if <sys/types.h> does not define. */
129 /* #undef size_t */
130
131 /* Define to the type of an unsigned integer type of width exactly 16 bits if
132 such a type exists and the standard includes do not define it. */
133 /* #undef uint16_t */
134
135 /* Define to the type of an unsigned integer type of width exactly 32 bits if
136 such a type exists and the standard includes do not define it. */
137 /* #undef uint32_t */
138
139 /* Define to the type of an unsigned integer type of width exactly 64 bits if
140 such a type exists and the standard includes do not define it. */
141 /* #undef uint64_t */
142
143 /* Define to the type of an unsigned integer type of width exactly 8 bits if
144 such a type exists and the standard includes do not define it. */
145 /* #undef uint8_t */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/ -> Includes Relation

  • SourceCode
  • EOLink

EOLink → Includes Relation

File in SourceCode/EOLink | Includes file in SourceCode/EOLink/Includes
Profiles / eoA5EEProfile.h | eoApiDef.h
Profiles / eoA5EEProfile.h | eoEEProfile.h
Profiles / eoD2EEProfile.h | eoApiDef.h
Profiles / eoD2EEProfile.h | eoEEProfile.h
Profiles / eoEEP_A520xx.h | eoISimpleBidirectionalProfile.h
Profiles / eoEEP_D2A0xx.h | eoISimpleBidirectionalProfile.h
Profiles / eoF6EEProfile.h | eoEEProfile.h
eoLink.h | eoAbstractMessage.h
eoLink.h | eoApiDef.h
eoLink.h | eoArchive.h
eoLink.h | eoArchiveTXT.h
eoLink.h | eoChainedMessage.h
eoLink.h | eoChainedReManMessage.h
eoLink.h | eoChannelEnums.h
eoLink.h | eoChannelInfo.h
eoLink.h | eoConverter.h
eoLink.h | eodBmFilter.h
eoLink.h | eoDebug.h
eoLink.h | eoDevice.h
eoLink.h | eoDeviceManager.h
eoLink.h | eoEEProfile.h
eoLink.h | eoFilterFactory.h
eoLink.h | eoGateway.h
eoLink.h | eoGenericProfile.h
eoLink.h | eoGpChainer.h
eoLink.h | eoGPChannelInfo.h
eoLink.h | eoHeader.h
eoLink.h | eoIDFilter.h
eoLink.h | eoIFilter.h
eoLink.h | eoISerialize.h
eoLink.h | eoIWatcher.h
eoLink.h | eoLinuxPacketStream.h
eoLink.h | eoManufacturer.h
eoLink.h | eoMessage.h
eoLink.h | eoMessageHandler.h
eoLink.h | eoMSCHelper.h
eoLink.h | eoPacket.h
eoLink.h | eoPacketStream.h
eoLink.h | eoProc.h
eoLink.h | eoProfile.h
eoLink.h | eoProfileFactory.h
eoLink.h | eoReCom.h
eoLink.h | eoReManChainer.h
eoLink.h | eoReManMessage.h
eoLink.h | eoRemoteManager.h
eoLink.h | eoRollingCodeStorage.h
eoLink.h | eoSecTeachInChainer.h
eoLink.h | eoSecureInfo.h
eoLink.h | eoSecurity.h
eoLink.h | eoSerialCommand.h
eoLink.h | eoStorageManager.h
eoLink.h | eoTeachInModule.h
eoLink.h | eoTelegram.h
eoLink.h | eoTimer.h
eoLink.h | eoWatcher.h
eoLink.h | eoWatcherFactory.h
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/ -> Profiles Relation

  • SourceCode
  • EOLink

EOLink → Profiles Relation

File in SourceCode/EOLink | Includes file in SourceCode/EOLink/Profiles
eoLink.h | eoSpecialProfile.h
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/ -> Includes Relation

  • SourceCode
  • EOLink
  • Profiles

Profiles → Includes Relation

File in SourceCode/EOLink/Profiles | Includes file in SourceCode/EOLink/Includes
eoA5EEProfile.h | eoApiDef.h
eoA5EEProfile.h | eoEEProfile.h
eoD2EEProfile.h | eoApiDef.h
eoD2EEProfile.h | eoEEProfile.h
eoEEP_A520xx.h | eoISimpleBidirectionalProfile.h
eoEEP_D2A0xx.h | eoISimpleBidirectionalProfile.h
eoF6EEProfile.h | eoEEProfile.h
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoA5EEProfile.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoA5EEProfile.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #ifndef EOA5EEPROFILE_H_
29 #define EOA5EEPROFILE_H_
30
36 #include "eoEEProfile.h"
37 #include "eoApiDef.h"
39 typedef enum
40 {
42 STAGE_3 = 0,
44 STAGE_2 = 1,
46 STAGE_1 = 2,
48 STAGE_0 = 3,
50 STAGE_AUTO = 4
51
52 } ENUM_FAN_SPEED_5STAGE;
53
55 typedef enum
56 {
58 SPEED_AUTO = 0,
60 SPEED_0 = 1,
62 SPEED_1 = 2,
64 SPEED_2 = 3,
66 SPEED_3 = 4,
68 SPEED_4 = 5,
70 SPEED_5 = 6,
72 SPEED_OFF = 7
73
74 } ENUM_FAN_SPEED_7STAGE;
75
77 typedef enum
78 {
79 VOC_total = 0,
80 VOC_Formaldehyde = 1,
81 VOC_Benzene = 2,
82 VOC_Styrene = 3,
83 VOC_Toluene = 4,
84 VOC_Tetrachloroethylene = 5,
85 VOC_Xylene = 6,
86 VOC_n_Hexane = 7,
87 VOC_n_Octane = 8,
88 VOC_Cyclopentane = 9,
89 VOC_Methanol = 10,
90 VOC_Ethanol = 11,
91 VOC_1_Pentanol = 12,
92 VOC_Acetone = 13,
93 VOC_ethylene_oxide = 14,
94 VOC_Acetaldehyde_ue = 15,
95 VOC_Acetic_Acid = 16,
96 VOC_Propionice_Acid = 17,
97 VOC_Valeric_Acid = 18,
98 VOC_Butyric_Acid = 19,
99 VOC_Ammoniac = 20,
100 VOC_Hydrogen_Sulfide = 21,
101 VOC_Dimethylsulfide = 22,
102 VOC_2_Butanol = 23,
103 VOC_2_Methylpropanol = 24,
104 VOC_Diethyl_ether = 25,
105 VOC_ozone = 255
106 } ENUM_VOC;
107
115 class eoA5EEProfile: public eoEEProfile
116 {
117 public:
122 eoA5EEProfile(uint16_t size = 4);
123 virtual ~eoA5EEProfile();
124
125 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
126 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
127 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
128 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
129 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
130 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
131 virtual eoReturn Create(eoMessage &m);
132 virtual eoReturn CreateTeachIN(eoMessage &m);
133 virtual eoReturn Parse(const eoMessage &msg);
139 bool Is4BSData(const eoMessage &m);
140
141 bool IsSecDData(const eoMessage &m);
142 };
145 #endif /* EOEEPPROFILE_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoAbstractMessage.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoAbstractMessage.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
35 #ifndef EOABSTRACTMESSAGE_H_
36 #define EOABSTRACTMESSAGE_H_
37 #include "eoHalTypes.h"
38 #include "eoApiDef.h"
45 class eoAbstractMessage
46 {
47
48 public:
49
51 uint8_t* data;
53 uint16_t dataLength;
57 uint16_t maxLength;
58
66 eoReturn SetDataLength(uint16_t dataLen, bool reallocate = false);
71 uint16_t GetDataLength() const;
76 uint16_t GetMaxLength() const;
77
78 protected:
83 eoAbstractMessage(uint16_t size=1);
84 virtual ~eoAbstractMessage();
85
86 };
87
88 #endif /* EOABSTRACTMESSAGE_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoApiDef.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoApiDef.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef API_DEF_H_
34 #define API_DEF_H_
35
40 typedef enum
41 {
44 EO_OK = 0x00,
45
46 EO_ERROR = 0x01,
47
48 NOT_SUPPORTED = 0x02,
49
50 WRONG_PARAM = 0x03,
51
52 OPERATION_DENIED = 0x04,
53
54
55 TIME_OUT = 0x05,
56
57 NO_RX = 0x06,
58
59 ONGOING_RX = 0x07,
60
61 NEW_RX = 0x08,
62
63 BUFF_FULL = 0x09,
64
65 OUT_OF_RANGE = 0x0A,
66
67 PORT_ERROR = 0x0B,
68
69 USER_CMD = 0x80,
70
71 NOT_RECOM = 0x81,
73 INVALID_PACKET=0x90,
75 NOT_IMPLEMENTED = 0xFF
76 } eoReturn;
77
79 typedef enum
80 {
81 PACKET_RESERVED = 0x00,
82 PACKET_RADIO = 0x01,
83 PACKET_RESPONSE = 0x02,
84 PACKET_RADIO_SUB_TEL = 0x03,
85 PACKET_EVENT = 0x04,
86 PACKET_COMMON_COMMAND = 0x05,
87 PACKET_SMART_ACK_COMMAND = 0x06,
88 PACKET_REMOTE_MAN_COMMAND = 0x07,
89 PACKET_PRODUCTION_COMMAND = 0x08,
90 PACKET_RADIO_MESSAGE = 0x09,
91 PACKET_RADIO_ADVANCED = 0x0A,
92 PACKET_RADIO_SET = 0x0E,
93 PACKET_DEBUG = 0x0F
94 } PACKET_TYPE;
95
97 typedef enum
98 {
100 RADIO_CHOICE_RPS = 0xF6,
102 RADIO_CHOICE_1BS = 0xD5,
104 RADIO_CHOICE_4BS = 0xA5,
106 RADIO_CHOICE_HRC = 0xA3,
108 RADIO_CHOICE_SYS = 0xA4,
110 RADIO_CHOICE_SYS_EX = 0xC5,
112 RADIO_CHOICE_SM_LRN_REQ = 0xC6,
114 RADIO_CHOICE_SM_LRN_ANS = 0xC7,
116 RADIO_CHOICE_RECLAIM = 0xA7,
118 RADIO_CHOICE_SIGNAL = 0xD0,
120 RADIO_CHOICE_ADT = 0xA6,
122 RADIO_CHOICE_VLD = 0xD2,
124 RADIO_CHOICE_UTE = 0xD4,
126 RADIO_CHOICE_MSC = 0xD1,
128 RADIO_CHOICE_GP_SINGLE_TREQ = 0xB0,
130 RADIO_CHOICE_GP_CHAINED_TREQ = 0xB1,
132 RADIO_CHOICE_GP_SINGLE_TRES = 0xB2,
134 RADIO_CHOICE_GP_CHAINED_TRES = 0xB3,
136 RADIO_CHOICE_GP_SINGLE_DATA = 0xB4,
138 RADIO_CHOICE_GP_CHAINED_DATA = 0xB5,
140 RADIO_CHOICE_GP_SELECT_DATA = 0xB6,
142 RADIO_CHOICE_SEC = 0x30,
144 RADIO_CHOICE_SEC_ENCAPS = 0x31,
146 RADIO_CHOICE_NON_SEC = 0x32,
148 RADIO_CHOICE_SEC_TI = 0x35
149
150 } CHOICE_TYPE;
152 typedef enum
153 {
155 RORG_RPS = 0xF6,
157 RORG_1BS = 0xD5,
159 RORG_4BS = 0xA5,
161 RORG_HRC = 0xA3,
163 RORG_SYS = 0xA4,
165 RORG_SYS_EX = 0xC5,
167 RORG_SM_LRN_REQ = 0xC6,
169 RORG_SM_LRN_ANS = 0xC7,
171 RORG_RECLAIM = 0xA7,
173 RORG_SIGNAL = 0xD0,
175 RORG_ADT = 0xA6,
177 GP_TI = 0xB0,
179 GP_TR = 0xB1,
181 GP_CD = 0xB2,
183 GP_SD = 0xB3,
185 RORG_VLD = 0xD2,
187 RORG_UTE = 0xD4,
189 RORG_MSC = 0xD1,
191 RORG_CDM = 0x40,
193 RORG_SEC = 0x30,
195 RORG_SEC_ENCAPS = 0x31,
197 RORG_SECD = 0x32,
199 RORG_SEC_TI = 0x35
200 } RORG_TYPE;
201
202
204 #define BROADCAST_ID 0xFFFFFFFF
205
206 #endif /* API_DEF_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoArchive.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoArchive.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef _EOARCHIVE_H_
34 #define _EOARCHIVE_H_
35 #include "eoHalTypes.h"
36 #include "eoISerialize.h"
37 #include "eoHeader.h"
38
46 class eoArchive
47 {
48
49 public:
50 eoArchive();
51
52 virtual ~eoArchive();
57 virtual eoArchive& operator &(char *obj);
62 virtual eoArchive& operator &(char const *obj);
67 virtual eoArchive& operator &(uint32_t &obj);
72 virtual eoArchive& operator &(int32_t &obj);
77 virtual eoArchive& operator &(uint16_t &obj);
82 virtual eoArchive& operator &(int16_t &obj);
87 virtual eoArchive& operator &(uint8_t &obj);
92 virtual eoArchive& operator &(int8_t &obj);
97 virtual eoArchive& operator &(float& obj);
102 virtual eoArchive& operator &(bool &obj);
107 virtual eoArchive& operator &(eoISerialize *obj);
112 virtual eoArchive& operator &(eoISerialize &obj);
118 virtual uint8_t Open(const char * strBuf);
122 virtual void Close();
123
128 virtual void startBlock(const char* BlockName);
129
133 virtual void indent();
137 virtual void startBlock();
141 virtual void endBlock();
142
144 bool isStoring;
146 char identifier[32];
147 protected:
149 eoHeader *h;
151 uint8_t level;
153 uint8_t state;
155 bool isName;
156
157 private:
158 //debug
159 };
163 #endif // !defined(EA_8062E719_2E73_4ad7_9D7D_AA6996E0FCB1__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoArchiveTXT.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoArchiveTXT.h
Go to the documentation of this file.
1
6 #if !defined(_EOARCHIVETXT_H)
7 #define _EOARCHIVETXT_H
8
9 #include "eoArchive.h"
10
11 #include <iostream>
12 #include <fstream>
13 #include <sstream>
14 #include <string>
15 #include <string.h>
16 #include <map>
17
19 #define _ARCHIVE_TYPE_NAME "_HUMAN_ARCHIVE\0"
20
21 #define _ARCHIVE_VER_MAJOR 0
22
23 #define _ARCHIVE_VER_MINOR 4
24
32 typedef std::map<std::string, std::string> parsed_Items;
33 class eoArchiveTXT: public eoArchive
34 {
35 public:
36 eoArchiveTXT();
37
38 virtual ~eoArchiveTXT();
39
40 virtual eoArchive& operator &(char const *obj);
41 virtual eoArchive& operator &(char *obj);
42 // virtual eoArchive& operator &(int &obj);
43 virtual eoArchive& operator &(uint32_t &obj);
44 virtual eoArchive& operator &(int32_t &obj);
45 virtual eoArchive& operator &(uint16_t &obj);
46 virtual eoArchive& operator &(int16_t &obj);
47 virtual eoArchive& operator &(uint8_t &obj);
48 virtual eoArchive& operator &(int8_t &obj);
49 virtual eoArchive& operator &(float& obj);
50 virtual eoArchive& operator &(bool &obj);
51 virtual eoArchive& operator &(eoISerialize *obj);
52 virtual eoArchive& operator &(eoISerialize &obj);
57 void ExchangeInt(int &obj);
58
59 virtual uint8_t Open(const char * strBuf);
60 virtual void Close();
61
62
63 void indent();
64 void startBlock();
65 void endBlock();
66
67 void startBlock(const char* BlockName);
68 private:
69 std::fstream myFile;
70
71 // identifier for the current Level...
72 std::string curName;
73
74 bool newBlock;
75 parsed_Items blockItems;
76 eoReturn ParseFile();
77 eoReturn ParseBlock(std::string blockName);
78 static std::ostream& indent(std::ostream &s, uint8_t level);
79 static std::ostream& startBlock(std::ostream &s, uint8_t level);
80 static std::ostream& endBlock(std::ostream &s, uint8_t level);
81
82 };
86 #endif
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoChainedMessage.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoChainedMessage.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
34 #include "eoMessage.h"
35 #include "eoChunkMessage.h"
36 #include <vector>
37 #ifndef EOCHAINEDMESSAGE_H_
38 #define EOCHAINEDMESSAGE_H_
39
43 class eoChainedMessage: public eoMessage
44 {
45 public:
47 bool received;
49 uint8_t telCount;
51 uint8_t expectedTelCount;
53 uint8_t seq;
55 uint16_t expectedDataLength;
57 uint16_t sizeN;
58
59
61 uint32_t timeStamp;
62
64 std::vector<eoChunkMessage> dataChunks;
65
66 public:
71 eoChainedMessage(uint16_t maxSize);
72
77 eoReturn ProcessChunks();
78
79 virtual ~eoChainedMessage();
80
81 };
82
83 #endif /* EOCHAINEDMESSAGE_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoChainedReManMessage.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoChainedReManMessage.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
34 #ifndef EOCHAINEDREMANMESSAGE_H_
35 #define EOCHAINEDREMANMESSAGE_H_
36
37 #include "eoChainedMessage.h"
38 #include "eoReManMessage.h"
39
44 class eoChainedReManMessage: public eoChainedMessage
45 {
46
47 public:
49 uint16_t fnCode;
51 uint16_t manufacturerID;
56 eoChainedReManMessage(uint16_t maxSize);
57
62 eoReturn copyTo(eoReManMessage &reMsg) const;
63
64 virtual ~eoChainedReManMessage();
65 };
66
67 #endif /* EOCHAINEDREMANMESSAGE_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoChannelEnums.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoChannelEnums.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef _eoCHANNELENUMS_H
34 #define _eoCHANNELENUMS_H
35
36 #include "eoHalTypes.h"
37 //STOP CHANGING THEM!
38
40 #define T_DATA 0x0000
41
43 #define T_FLAG 0x0F00
44
45 #define T_ENUM 0xE000
46
47 #define GP_ENUM 0x6000
48
50 #define SP_ABS 0x1000
51
52 #define SP_REL 0x2000
53
55 #define NUM_SIGNAL_STRINGS 0x2C
56
57 const char signalStrings[NUM_SIGNAL_STRINGS][2][26] =
58 {
59 { "N/A", "N/A" },
60 { "Acceleration", "m/s^2" }, // 00000001 = Acceleration m/s^2
61 { "Angle", "degrees" }, // 00000010 = Angle degrees
62 { "Angular velocity", "degrees/s" },
63 { "Area", "m^2" },
64 { "Concentration", "ppm" },
65 { "Current", "A" },
66 { "Distance", "meters" },
67 { "Electric field strength", "V/m" },
68 { "Energy", "J(W*s)" }, //W*s is the same as joule
69 { "Enumeration", "N/A" },
70 { "Force", "Newtons" },
71 { "Frequency", "Hz" },
72 { "Heat flux density", "W/m^2/s" },
73 { "Impulse", "N*s/kg" },
74 { "Luminance intensity", "Lux" },
75 { "Magnetic field strength", "A/m" },
76 { "Mass", "kg" },
77 { "Mass density", "kg/m^3" },
78 { "Mass flow", "kg/s" },
79 { "Power", "Watts" },
80 { "Pressure", "Pascals" },
81 { "Relative humidity", "Percent" },
82 { "Resistance", "Ohms" },
83 { "Temperature", "Deg C" },
84 { "Time", "Seconds" },
85 { "Torque", "N*m" },
86 { "Velocity", "m/s" },
87 { "Voltage", "Volts" },
88 { "Volume", "m^3" },
89 { "Volumetric Flow", "m^3/s" },
90 { "Set point", "number" },
91 { "Particles", "ug/m^3" },
92 { "Dimming", "n/a" },
93 { "Solar radiation", "W/m^2" },
94 { "Percentage", "%" },
95 { "Value", "n/a" },
96 { "RGB", "n/a" },
97 { "Error code", "n/a" },
98 { "Radon Activity", "Bq/m3" },
99 { "Amper hour", "A/h" },
100 { "Rotation", "1/min" }
101 };
102
104 #define NUM_FLAG_STRINGS 0x11
105
106 const char flagStrings[NUM_FLAG_STRINGS][32] =
107 { "", "Automatic flag", "Button pressed", // 00000010 = Button pressed (1 when pressed, 0 when not changed)
108 "Button triggered", // 00000100 = Button triggered *
109 "Day/Night", // 00000101 = Day(1) / night(0)
110 "Down", // 00000110 = Down "-" (1 when pressed)
111 "General alarm", // 00000111 = General alarm (1)
112 "Heat (1) / cool (0)", // 00001000 = Heat (1) / cool (0)
113 "High (1) / low (0)", // 00001001 = High (1) / low (0)
114 "Occupied (1) / unoccupied (0)",// 00001010 = Occupied (1) / unoccupied (0)
115 "On (1) / off (0)", // 00001011 = On (1) / off (0)
116 "Open (1) / closed (0)", // 00001100 = Open (1) / closed (0)
117 "Power alarm (1)", // 00001101 = Power alarm (1)
118 "Start (1) / stop (0)", // 00001110 = Start (1) / stop (0)
119 "Up 'p'", // 00001111 = Up "+" (1 when pressed)
120 "Vibration(1) / No vibration (0)", // 00010000 = Vibration (1) / No vibration (0)
121 };
122
124 #define NUM_ENUMS_STRINGS 0x20
125
126 const char enumStrings[NUM_ENUMS_STRINGS][32] =
127 { "", "Rocker Button A", "Rocker Button B", "Rocker Button C", "Rocker Button D", "Energybow direction", "Multiple Buttons pressed?", "Windowhandle", "Fan Speed", "Tariff information", "VOC (Volatile organic compound)", "Controller mode", "Error state", "State", "End position", "Occupancy", "User action", "Presence", "Dim value", "Input/Output channel", "Units", "Days", "Commands" };
128
130 #define NUM_GP_ENUMS_STRING 0x06
131
132 const char gpEnumString[NUM_GP_ENUMS_STRING][20] =
133 {
134 "",
135 "Multipurpose",
136 "Bulding Mode",
137 "Occupancy Mode",
138 "HVAC Mode",
139 "Changeover Mode"
140 };
141
148 typedef enum
149 {
150
151 S_RES = 0x00,
152 // Signal data types - float
154 S_ACCEL = 0x01, // 00000001 = Acceleration m/s^2
156 S_ACCEL_ABS = S_ACCEL + SP_ABS, // Absolute setpoint
158 S_ACCEL_REL = S_ACCEL + SP_REL, // Relative setpoint
160 S_ANGLE = 0x02, // 00000010 = Angle degrees
162 S_ANGLE_ABS = S_ANGLE + SP_ABS, // Absolute setpoint
164 S_ANGLE_REL = S_ANGLE + SP_REL, // Relative setpoint
166 S_ANGVD = 0x03, // 00000011 = Angular velocity degrees/s
168 S_ANGVD_ABS = S_ANGVD + SP_ABS, // Absolute setpoint
170 S_ANGVD_REL = S_ANGVD + SP_REL, // Relative setpoint
172 S_AREA = 0x04, // 00000100 = Area m^2
174 S_AREA_ABS = S_AREA + SP_ABS, // Absolute setpoint
176 S_AREA_REL = S_AREA + SP_REL, // Relative setpoint
178 S_CONC = 0x05, // 00000101 = Concentration ppm
180 S_CONC_ABS = S_CONC + SP_ABS, // Absolute setpoint
182 S_CONC_REL = S_CONC + SP_REL, // Relative setpoint
184 S_CURRENT = 0x06, // 00000110 = Current Amps
186 S_CURRENT_ABS = S_CURRENT + SP_ABS, // Absolute setpoint
188 S_CURRENT_REL = S_CURRENT + SP_REL, // Relative setpoint
190 S_DISTANCE = 0x07, // 00000111 = Distance meters
192 S_DISTANCE_ABS = S_DISTANCE + SP_ABS, // Absolute setpoint
194 S_DISTANCE_REL = S_DISTANCE + SP_REL, // Relative setpoint
196 S_ELECFSTR = 0x08, // 00001000 = Electric field strength V/m
198 S_ELECFSTR_ABS = S_ELECFSTR + SP_ABS, // Absolute setpoint
200 S_ELECFSTR_REL = S_ELECFSTR + SP_REL, // Relative setpoint
202 S_ENERGY = 0x09, // 00001001 = Energy J - W*s
204 S_ENERGY_ABS = S_ENERGY + SP_ABS, // Absolute setpoint
206 S_ENERGY_REL = S_ENERGY + SP_REL, // Relative setpoint
208 S_COUNTER = 0x0A, // 00001010 = Counter
210 S_COUNTER_ABS = S_COUNTER + SP_ABS, // Absolute setpoint
212 S_COUNTER_REL = S_COUNTER + SP_REL, // Relative setpoint
214 S_FORCE = 0x0B, // 00001011 = Force Newtons
216 S_FORCE_ABS = S_FORCE + SP_ABS, // Absolute setpoint
218 S_FORCE_REL = S_FORCE + SP_REL, // Relative setpoint
220 S_FREQ = 0x0C, // 00001100 = Frequency Hz
222 S_FREQ_ABS = S_FREQ + SP_ABS, // Absolute setpoint
224 S_FREQ_REL = S_FREQ + SP_REL, // Relative setpoint
226 S_HEATFLUX = 0x0D, // 00001101 = Heat flux density W/m^2/s
228 S_HEATFLUX_ABS = S_HEATFLUX + SP_ABS, // Absolute setpoint
230 S_HEATFLUX_REL = S_HEATFLUX + SP_REL, // Relative setpoint
232 S_IMPULSE = 0x0E, // 00001110 = Impulse N*s/kg
234 S_IMPULSE_ABS = S_IMPULSE + SP_ABS, // Absolute setpoint
236 S_IMPULSE_REL = S_IMPULSE + SP_REL, // Relative setpoint
238 S_LUMINANCE = 0x0F, // 00001111 = Luminance intensity Lux
240 S_LUMINANCE_ABS = S_LUMINANCE + SP_ABS, // Absolute setpoint
242 S_LUMINANCE_REL = S_LUMINANCE + SP_REL, // Relative setpoint
244 S_MAGNETICF = 0x10, // 00010000 = Magnetic field strength A/m
246 S_MAGNETICF_ABS = S_MAGNETICF + SP_ABS, // Absolute setpoint
248 S_MAGNETICF_REL = S_MAGNETICF + SP_REL, // Relative setpoint
250 S_MASS = 0x11, // 00010001 = Mass kg
252 S_MASS_ABS = S_MASS + SP_ABS, // Absolute setpoint
254 S_MASS_REL = S_MASS + SP_REL, // Relative setpoint
256 S_MASSDENS = 0x12, // 00010010 = Mass density kg/m^3
258 S_MASSDENS_ABS = S_MASSDENS + SP_ABS, // Absolute setpoint
260 S_MASSDENS_REL = S_MASSDENS + SP_REL, // Relative setpoint
262 S_MASSFLOW = 0x13, // 00010011 = Mass flow kg/s
264 S_MASSFLOW_ABS = S_MASSFLOW + SP_ABS, // Absolute setpoint
266 S_MASSFLOW_REL = S_MASSFLOW + SP_REL, // Relative setpoint
268 S_POWER = 0x14, // 00010100 = Power Watts
270 S_POWER_ABS = S_POWER + SP_ABS, // Absolute setpoint
272 S_POWER_REL = S_POWER + SP_REL, // Relative setpoint
274 S_PRESSURE = 0x15, // 00010101 = Pressure Pascals/in Pa
276 S_PRESSURE_ABS = S_PRESSURE + SP_ABS, // Absolute setpoint
278 S_PRESSURE_REL = S_PRESSURE + SP_REL, // Relative setpoint
280 S_RELHUM = 0x16, // 00010110 = Relative humidity Percent
282 S_RELHUM_ABS = S_RELHUM + SP_ABS, // Absolute setpoint
284 S_RELHUM_REL = S_RELHUM + SP_REL, // Relative setpoint
286 S_RESIST = 0x17, // 00010111 = Resistance Ohms
288 S_RESIST_ABS = S_RESIST + SP_ABS, // Absolute setpoint
290 S_RESIST_REL = S_RESIST + SP_REL, // Relative setpoint
292 S_TEMP = 0x18, // 00011000 = Temperature Deg C
294 S_TEMP_ABS = S_TEMP + SP_ABS, // Absolute setpoint
296 S_TEMP_REL = S_TEMP + SP_REL, // Relative setpoint
298 S_TIME = 0x19, // 00011001 = Time Seconds
300 S_TIME_ABS = S_TIME + SP_ABS, // Absolute setpoint
302 S_TIME_REL = S_TIME + SP_REL, // Relative setpoint
304 S_TORQUE = 0x1A, // 00011010 = Torque N*m
306 S_TORQUE_ABS = S_TORQUE + SP_ABS, // Absolute setpoint
308 S_TORQUE_REL = S_TORQUE + SP_REL, // Relative setpoint
310 S_VELOCITY = 0x1B, // 00011011 = Velocity m/s
312 S_VELOCITY_ABS = S_VELOCITY + SP_ABS, // Absolute setpoint
314 S_VELOCITY_REL = S_VELOCITY + SP_REL, // Relative setpoint
316 S_VOLTAGE = 0x1C, // 00011100 = Voltage Volts
318 S_VOLTAGE_ABS = S_VOLTAGE + SP_ABS, // Absolute setpoint
320 S_VOLTAGE_REL = S_VOLTAGE + SP_REL, // Relative setpoint
322 S_VOLUME = 0x1D, // 00011101 = Volume m^3
324 S_VOLUME_ABS = S_VOLUME + SP_ABS, // Absolute setpoint
326 S_VOLUME_REL = S_VOLUME + SP_REL, // Relative setpoint
328 S_VOLFLOW = 0x1E, // 00011110 = Volumetric Flow m^3/s
330 S_VOLFLOW_ABS = S_VOLFLOW + SP_ABS, // Absolute setpoint
332 S_VOLFLOW_REL = S_VOLFLOW + SP_REL, // Relative setpoint
334 S_SETPOINT = 0x1F, // 00011111 = Setpoint
336 S_SETPOINT_ABS = S_SETPOINT + SP_ABS, // Absolute setpoint
338 S_SETPOINT_REL = S_SETPOINT + SP_REL, // Relative setpoint
340 S_PARTICLES = 0x20, // 00100000 = Particles ug/m^3
342 S_PARTICLES_ABS = S_PARTICLES + SP_ABS, // Absolute setpoint
344 S_PARTICLES_REL = S_PARTICLES + SP_REL, // Relative setpoint
346 S_DIMMING = 0x21, // 00100001 = Dimming
348 S_DIMMING_ABS = S_DIMMING + SP_ABS, // Absolute setpoint
350 S_DIMMING_REL = S_DIMMING + SP_REL, // Relative setpoint
352 S_SOLAR_RAD = 0x22, // 00100010 = Solar radiation
354 S_SOLAR_RAD_ABS = S_SOLAR_RAD + SP_ABS, // Absolute setpoint
356 S_SOLAR_RAD_REL = S_SOLAR_RAD + SP_REL, // Relative setpoint
358 S_PERCENTAGE = 0x23, // 00100011 = Percentage %
360 S_PERCENTAGE_ABS = S_PERCENTAGE + SP_ABS, // Absolute setpoint
362 S_PERCENTAGE_REL = S_PERCENTAGE + SP_REL, // Relative setpoint
364 S_VALUE = 0x24, // 00100100 = Value
366 S_VALUE_ABS = S_VALUE + SP_ABS, // Absolute setpoint
368 S_VALUE_REL = S_VALUE + SP_REL, // Relative setpoint
370 S_RGB = 0x25, // 00100101 = RGB
372 S_RGB_ABS = S_RGB + SP_ABS, // Absolute setpoint
374 S_RGB_REL = S_RGB + SP_REL, // Relative setpoint
376 S_ERROR_CODE = 0x26, // 00100110 = Error code
378 S_ERROR_CODE_ABS = S_ERROR_CODE + SP_ABS, // Absolute setpoint
380 S_ERROR_CODE_REL = S_ERROR_CODE + SP_REL, // Relative setpoint
382 S_RADON_ACTIVITY = 0x27, // 00100111 = Radon Activity
384 S_RADON_ACTIVITY_ABS = S_RADON_ACTIVITY + SP_ABS, // Absolute setpoint
386 S_RADON_ACTIVITY_REL = S_RADON_ACTIVITY + SP_REL, // Relative setpoint
388 S_AMPER_PER_HOUR = 0x28, // 00101000 = A/h
390 S_AMPER_PER_HOUR_ABS = S_AMPER_PER_HOUR + SP_ABS, // Absolute setpoint
392 S_AMPER_PER_HOUR_REL = S_AMPER_PER_HOUR + SP_REL, // Relative setpoint
394 S_ROTATION_PER_MIN = 0x29, // 00101001 = 1/min
396 S_ROTATION_PER_MIN_ABS = S_ROTATION_PER_MIN + SP_ABS, // Absolute setpoint
398 S_ROTATION_PER_MIN_REL = S_ROTATION_PER_MIN + SP_REL, // Relative setpoint
399
400 //Enum flags...
401
403 E_ROCKER_A = T_ENUM + 0x01, // Rocker A Button Information 0=I,1=O,2=Not pressed
405 E_ROCKER_B = T_ENUM + 0x02, // Rocker B Button Information 0=I,1=O,2=Not pressed
407 E_ROCKER_C = T_ENUM + 0x03, // Rocker B Button Information 0=I,1=O,2=Not pressed
409 E_ROCKER_D = T_ENUM + 0x04, // Rocker B Button Information 0=I,1=O,2=Not pressed
411 E_ENERGYBOW = T_ENUM + 0x05, // Energy Bow pressed releases or pressed
413 E_MULTIPRESS = T_ENUM + 0x06,// Rocker 1 Button Information 3 or more buttons pressed
415 E_WINDOWHANDLE = T_ENUM + 0x07, // Window handle enum
417 E_FANSPEED = T_ENUM + 0x08,
419 E_TARIFF = T_ENUM + 0x09,
421 E_VOC = T_ENUM + 0x0A,
423 E_CONTROLLER_MODE = T_ENUM + 0x0B,
425 E_ERROR_STATE = T_ENUM + 0x0C, //Error state
427 E_STATE = T_ENUM + 0x0D, //State
429 E_END_POS = T_ENUM + 0x0E, //End position
431 E_OCCUPANCY = T_ENUM + 0x0F, //Room occupancy
433 E_USER_ACTION = T_ENUM + 0x10, //User Action
435 E_PRESENCE = T_ENUM + 0x11, //Presence
437 E_DIM_VALUE = T_ENUM + 0x12, //Dim value
439 E_IO_CHANNEL = T_ENUM + 0x13, //Input/Output channel
441 E_UNITS = T_ENUM + 0x14, //Unit
443 E_DAYS = T_ENUM + 0x15, //Days
445 E_COMMAND = T_ENUM + 0x16, //Commands
447 E_DIRECTION = T_ENUM + 0x17, //Directions
449 E_ROOM_SIZE = T_ENUM + 0x18, //Room Size
451 E_KEY_DATA = T_ENUM + 0x19, //Room Size
452
453 //GP enum flags
454
456 E_GP_MULTIPURPOSE = GP_ENUM + 0x01,
458 E_GP_BUILDING_MODE = GP_ENUM + 0x02,
460 E_GP_OCCUPANCY = GP_ENUM + 0x03,
462 E_GP_HVAC_MODE = GP_ENUM + 0x04,
464 E_GP_CHANGEOVER_MODE = GP_ENUM + 0x05,
465
466 // Flag data types - uint8_t
468 F_AUTO_MAN = T_FLAG + 0x01, // 00000001 = Automatic (1) / manual (0)
470 F_BTN_PRESS = T_FLAG + 0x02,// 00000010 = Button pressed (1 when pressed, 0 when not changed)
472 F_BTN_TRIGGER = T_FLAG + 0x03, // 00000011 = Button triggered *
474 F_DAY_NIGHT = T_FLAG + 0x04, // 00000100 = Day(1) / night(0)
476 F_DOWN = T_FLAG + 0x05, // 00000101 = Down "-" (1 when pressed)
478 F_GENALARM = T_FLAG + 0x06, // 00000101 = General alarm (1)
480 F_HEAT_COOL = T_FLAG + 0x07, // 00000111 = Heat (1) / cool (0)
482 F_HIGH_LOW = T_FLAG + 0x08, // 00001000 = High (1) / low (0)
484 F_OCCUPIED = T_FLAG + 0x09, // 00001001 = Occupied (1) / unoccupied (0)
486 F_ON_OFF = T_FLAG + 0x0A, // 00001010 = On (1) / off (0)
488 F_OPEN_CLOSED = T_FLAG + 0x0B, // 00001011 = Open (1) / closed (0)
490 F_POWERALARM = T_FLAG + 0x0C, // 00001100 = Power alarm (1)
492 F_START_STOP = T_FLAG + 0x0D, // 00001101 = Start (1) / stop (0)
494 F_UP = T_FLAG + 0x0E, // 00001110 = Up "+" (1 when pressed)
496 F_VIBRATION = T_FLAG + 0x0F,// 00001111 = Vibration (1) / No vibration (0)
497 F_RES = T_FLAG + 0xFF //< F_RES
498
499 } CHANNEL_TYPE;
500
502 typedef enum
503 {
504 VAL_CURR = 0x01, // 01 = Current value
505 VAL_SP_ABS = 0x02, // 10 = Setpoint absolute
506 VAL_SP_REL = 0x03 // 11 = Setpoint relative
507 } VALUE_TYPE;
508
509 #endif // _CHANNELENUMS_H
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoChannelInfo.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoChannelInfo.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef _eoCHANNELINFO_H
34 #define _eoCHANNELINFO_H
35
36 #include "eoHalTypes.h"
37 #include "eoChannelEnums.h"
39 #define UNIT 0x00
40
41 #define NAME 0x01
42
47 typedef struct
48 {
50 bool exist;
52 uint16_t bitoffs;
54 uint16_t bitsize;
56 uint32_t rangeMin;
58 uint32_t rangeMax;
60 float scaleMin;
62 float scaleMax;
64 CHANNEL_TYPE type;
66 uint8_t index;
67 } EEP_ITEM;
68
69
75 class eoChannelInfo
76 {
77 public:
79 CHANNEL_TYPE type;
81 VALUE_TYPE signalType;
83 float min;
85 float max;
91 const char* ToString(uint8_t strType);
92 };
93
99 class eoEEPChannelInfo: public eoChannelInfo
100 {
101 public:
103 const EEP_ITEM* eepItem;
104 };
105
106 #endif // _CHANNELINFO_H
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoChunkMessage.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoChunkMessage.h
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
35 #ifndef EOCHUNKMESSAGE_H_
36 #define EOCHUNKMESSAGE_H_
37 #include "eoAbstractMessage.h"
38 #include "eoHalTypes.h"
39
46 class eoChunkMessage : public eoAbstractMessage
47 {
48
49 private:
53 bool received;
54
55 public:
64 eoChunkMessage( const eoChunkMessage& other );
65
71 eoReturn CopyFrom(eoAbstractMessage const &msg);
72
82 eoReturn CopyDataFrom(const uint8_t* const src,const uint8_t len);
87 bool IsReceived() const { return received; };
88
92 eoChunkMessage(uint16_t size);
93 eoChunkMessage();
94 virtual ~eoChunkMessage();
95
96 };
97
98 #endif /* EOABSTRACTMESSAGE_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoConverter.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoConverter.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #if !defined(_EOCONVERTER_H_)
34 #define _EOCONVERTER_H_
35
36 #include "eoHalTypes.h"
37 #include "eoMessage.h"
38 #include "eoReManMessage.h"
39 #include "eoTelegram.h"
40 #include "eoPacket.h"
41 #include "eoApiDef.h"
42
44 #define MINIMUM_ADVANCED_DATA_LENGTH 0x06
45
46 #define SA_RECLAIM_DATA_LENGTH 0x05
47
52 class eoConverter
53 {
54 public:
61 static eoReturn radioToPacket(const eoTelegram &tel, eoPacket &packet);
68 static eoReturn radioToPacket(const eoMessage &msg, eoPacket &packet);
75 static eoReturn packetToAdvancedRadio(const eoMessage &msg, eoPacket &packet);
83 static eoReturn packetToRadio(const eoPacket &packet, eoTelegram &tel);
91 static eoReturn advancedPacketToRadio(const eoPacket &packet, eoTelegram &tel);
98 static uint8_t TigrisToRPS(eoTelegram &inTel, eoTelegram &outTel);
104 static const char * NumToHex(uint8_t num);
110 static uint32_t Hash(char const * str);
117 static eoReturn packetToReman(const eoPacket &packet, eoReManMessage &reManMes);
124 static eoReturn remanToPacket(const eoReManMessage &reManMes, eoPacket &packet);
130 static eoReturn fahrenheitToCelsius(float &value);
136 static eoReturn celsiusToFahrenheit(float &value);
142 static eoReturn literToMeter3(float &value);
148 static eoReturn meter3ToLiter(float &value);
149 };
150
151 #endif /* _EOCONVERTER_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoD2EEProfile.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoD2EEProfile.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #ifndef EOD2EEPROFILE_H_
29 #define EOD2EEPROFILE_H_
30
36 #include "eoEEProfile.h"
37 #include "eoApiDef.h"
38
46 class eoD2EEProfile: public eoEEProfile
47 {
48 public:
53 eoD2EEProfile(uint16_t size = 4);
54 virtual ~eoD2EEProfile();
55
56 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
57 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
58 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
59 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
60 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
61 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
62 virtual eoReturn CreateTeachIN(eoMessage &m);
68 virtual eoReturn SetCommand(uint8_t cmd);
69 };
72 #endif /* EOEEPPROFILE_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoDebug.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoDebug.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EODEBUG_H_
34 #define EODEBUG_H_
35
36 #include "eoHalTypes.h"
37 #include "eoMessage.h"
38 #include "eoTelegram.h"
39 #include "eoPacket.h"
40 #include "eoReManMessage.h"
45 class eoDebug
46 {
47 public:
52 static void Print(const eoTelegram &tel);
57 static void Print(const eoMessage &msg);
62 static void Print(const eoReManMessage &reMsg);
67 static void Print(const eoPacket &packet);
68
69 };
70
71 #endif /* EODEBUG_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoDevice.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoDevice.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #if !defined(EO_DEVICE_H)
34 #define EO_DEVICE_H
35
36 #include "eoSecureInfo.h"
37 #include "eoProfile.h"
38 #include "eoISerialize.h"
39 #include "eoArchive.h"
45 class eoDevice: public eoISerialize
46 {
47
48 public:
49 eoDevice();
54 eoDevice(uint32_t id);
55 virtual ~eoDevice();
61 eoReturn SetProfile(eoProfile* myProfile);
70 eoReturn SetProfile(const uint8_t rorg, const uint8_t func, const uint8_t type);
75 eoProfile* GetProfile() const;
79 int8_t dBm;
83 uint32_t ID;
87 eoSecureInfo secIn;
91 eoSecureInfo secOut;
92
93 uint8_t Serialize(eoArchive &a);
94
95 private:
96 eoProfile *profile;
97
98 };
99 #endif // !defined(EO_DEVICE_H)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoDeviceManager.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoDeviceManager.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #if !defined(_DEVICE_MANAGER_H)
34 #define _DEVICE_MANAGER_H
35
36 class eoDevice;
37 class eoArchive;
38 #include "eoHalTypes.h"
39 #include "eoISerialize.h"
40
41 #include <map>
45 typedef std::map<uint32_t, eoDevice*> id_device_map;
51 class eoDeviceManager: public eoISerialize
52 {
53
54 public:
58 eoDeviceManager();
59 ~eoDeviceManager();
66 eoDevice* Add(uint32_t id);
72 eoDevice* Get(uint32_t id);
77 void Remove(uint32_t id);
82 const id_device_map & GetDeviceList() const;
87 uint32_t Size() const;
88
89 uint8_t Serialize(eoArchive &a);
90
91 private:
92 id_device_map list;
93
94 };
95
96 #endif // !defined(_DEVICE_MANAGER_H)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A502xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A502xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_A502_H__INCLUDED_)
31 #define eoEEP_A502_H__INCLUDED_
32 #include "eoA5EEProfile.h"
71 class eoEEP_A502xx: public eoA5EEProfile
72 {
73
74 public:
75 eoReturn SetType(uint8_t type);
76 eoEEP_A502xx();
77 virtual ~eoEEP_A502xx();
78 };
81 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A504xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A504xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_A504_H__INCLUDED_)
31 #define eoEEP_A504_H__INCLUDED_
32
35 #include "eoA5EEProfile.h"
57 class eoEEP_A504xx: public eoA5EEProfile
58 {
59
60 public:
61 eoEEP_A504xx();
62 virtual ~eoEEP_A504xx();
63
64 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
65 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
66 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
67 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
68 eoReturn SetType(uint8_t type);
69 };
72 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A505xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A505xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_A505_H__INCLUDED_)
31 #define eoEEP_A505_H__INCLUDED_
32
35 #include "eoA5EEProfile.h"
47 class eoEEP_A505xx: public eoA5EEProfile
48 {
49 public:
50 eoEEP_A505xx();
51 virtual ~eoEEP_A505xx();
52
53 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
54 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
55 eoReturn SetType(uint8_t type);
56 };
59 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A506xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A506xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_A506_H__INCLUDED_)
31 #define eoEEP_A506_H__INCLUDED_
32
35 #include "eoA5EEProfile.h"
59 class eoEEP_A506xx: public eoA5EEProfile
60 {
61
62 public:
63 eoReturn SetType(uint8_t type);
64 eoReturn SetValue(CHANNEL_TYPE type, float value);
65 eoReturn GetValue(CHANNEL_TYPE type, float &value);
66 eoEEP_A506xx();
67 virtual ~eoEEP_A506xx();
68 virtual eoChannelInfo* GetChannel(CHANNEL_TYPE type);
69 };
72 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A507xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A507xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_A507_H__INCLUDED_)
31 #define eoEEP_A507_H__INCLUDED_
32
35 #include "eoA5EEProfile.h"
57 class eoEEP_A507xx: public eoA5EEProfile
58 {
59
60 public:
61 eoReturn SetType(uint8_t type);
62
63 eoEEP_A507xx();
64 virtual ~eoEEP_A507xx();
65 eoReturn GetValue(CHANNEL_TYPE type, float &value);
66 eoReturn SetValue(CHANNEL_TYPE type, float value);
67 eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
68 eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
69 };
72 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A508xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A508xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_A508_H__INCLUDED_)
31 #define eoEEP_A508_H__INCLUDED_
32
35 #include "eoA5EEProfile.h"
52 class eoEEP_A508xx: public eoA5EEProfile
53 {
54
55 public:
56 eoReturn SetType(uint8_t type);
57 eoEEP_A508xx();
58 virtual ~eoEEP_A508xx();
59
60 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
61 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
62 };
65 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A509xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A509xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_A509_H__INCLUDED_)
29 #define eoEEP_A509_H__INCLUDED_
30
33 #include "eoA5EEProfile.h"
118
119 typedef enum
120 {
122 PM10 = 0x00,
124 PM2_5 = 0x01,
126 PM1 = 0x02
127 } ENUM_PARTICLES_SIZE;
128
130 typedef enum
131 {
133 USV_H = 0x00,
135 CPM = 0x01,
137 BQ_L = 0x02,
139 BQ_KG = 0x03
140 } ENUM_RADIATION_UNIT;
141
143 typedef enum
144 {
146 NO_POWER_FAILURE = 0x00,
148 POWER_FAILURE_DETECTED = 0x01
149 } ENUM_POWER_FAILURE_DETECTION;
150
151 class eoEEP_A509xx: public eoA5EEProfile
152 {
153
154 public:
155 eoReturn SetType(uint8_t type);
156 eoEEP_A509xx();
157 virtual ~eoEEP_A509xx();
158
159 eoReturn GetValue(CHANNEL_TYPE type, float &value);
160 eoReturn SetValue(CHANNEL_TYPE type, float value);
161 eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
162 eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
163 eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
164 eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
165
166 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
167 };
168
169 #endif
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A510xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A510xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_A510_H__INCLUDED_)
29 #define eoEEP_A510_H__INCLUDED_
30
33 #include "eoA5EEProfile.h"
328
329 typedef enum
330 {
332 OCCUPANCY = 0x00, //Occupancy button
334 UNOCCUPANCY = 0x01 //Unoccupancy button
335 } ROP_1F_BUTTONS;
336
338 typedef enum
339 {
341 ROP_ROOM_TEMP_DEFINED = 0,
343 ROP_FROST_PROTECTION = 1,
345 ROP_AUTOMATIC_CONTROL = 2
346 } ROP_SET_POINT_MODE;
347
349 typedef enum
350 {
352 ROP_NO_USER_ACTIVITY = 0,
354 ROP_USER_INTERACTION = 1
355 } ROP_USER_ACTIVITY;
356
357 class eoEEP_A510xx: public eoA5EEProfile
358 {
359
360 public:
361 eoReturn SetType(uint8_t type);
362
363 eoEEP_A510xx();
364 virtual ~eoEEP_A510xx();
365 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
366 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);
367 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
368 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t subFlag);
369 eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
370 eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
371 };
374 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A511xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A511xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_A511_H__INCLUDED_)
29 #define eoEEP_A511_H__INCLUDED_
30
33 #include "eoA5EEProfile.h"
109
110 typedef enum
111 {
113 CS_REPEATER = 0x00,
115 CS_POWER_RELAY_TIMER = 0x01,
117 CS_DAYLIGHT_HARVEST = 0x02,
119 CS_DIMMING = 0x03,
121 CS_POWER_RELAY = 0x04,
123 CS_ALARM = 0x05,
125 CS_CONTROLLER_STATE = 0x06,
127 CS_ENERGY_HOLDOFF = 0x07,
129 CS_ANGLE_SIGN = 0x08,
131 CS_POSITION_VALUE = 0x09,
133 CS_ANGLE_VALUE = 0x0A,
135 CS_SETVICE_MODE = 0x0B,
137 CS_MODE_OF_POSITION = 0x0C,
139 CS_OPERATING_HOURS = 0x0D,
141 CS_STATUS = 0x0E,
143 CS_RGB_RED = 0x0F,
145 CS_RGB_GREEN = 0x10,
147 CS_RGB_BLUE = 0x11
148
149 } CS_INDEXES;
150
152 typedef enum
153 {
155 CS_MILI_W = 0x00,
157 CS_W = 0x01,
159 CS_KILO_W = 0x02,
161 CS_MEGA_W = 0x03,
163 CS_WH = 0x04,
165 CS_KILO_WH = 0x05,
167 CS_MEGA_WH = 0x06,
169 CS_GIGA_WH = 0x07,
171 CS_MILI_A = 0x08,
173 CS_A_1_10 = 0x09,
175 CS_MILI_V = 0x0A,
177 CS_V_1_10 = 0x0B
178 } CS_ENERGY_UNITS;
179
181 typedef enum
182 {
184 CS_NO_ERROR = 0x00,
186 CS_LAMP_ERROR = 0x01,
188 CS_INTERNAL_ERROR = 0x02
189 } CS_ENUM_03_ERROR_STATE;
190
192 typedef enum
193 {
195 A5O_ERROR = 0x00,
197 END_POS_NO_CONFIG = 0x01,
199 INTERNAL_ERROR = 0x02,
201 EXT_PERIPHERY_ERROR = 0x03
202 } CS_ENUM_04_ERROR_STATE;
203
205 typedef enum
206 {
208 NOT_AVAILABLE = 0x00,
210 BLIND_STOPPED = 0x01,
212 BLIND_OPENS = 0x02,
214 BLIND_CLOSES = 0x03
215 } CS_ENUM_BLIND_STATE;
216
218 typedef enum
219 {
221 NO_END_POS_AVAILABLE = 0x00,
223 NO_END_POS_REACHED = 0x01,
225 BLIND_FULLY_OPEN = 0x02,
227 BLIND_FULLY_CLOSE = 0x03
228 } CS_ENUM_END_POS;
229
231 typedef enum
232 {
234 HEATING = 0x00,
236 COOLING = 0x01,
238 OFF = 0x02
239 } CS_ENUM_CONTROLLER_MODE;
240
242 typedef enum
243 {
245 OCCUPIED = 0x00,
247 UNOCCUPIED = 0x01,
249 STANDBY = 0x02,
251 FROST = 0x03
252 } CS_ENUM_ROOM_OCCUPANCY;
253
255 typedef enum
256 {
258 STAGE_0_MANUAL = 0x00,
260 STAGE_1_MANUAL = 0x01,
262 STAGE_2_MANUAL = 0x02,
264 STAGE_3_MANUAL = 0x03,
266 STAGE_0_AUTO = 0x10,
268 STAGE_1_AUTO = 0x11,
270 STAGE_2_AUTO = 0x12,
272 STAGE_3_AUTO = 0x13
273 } CS_FAN_STAGE;
274
276 typedef enum
277 {
279 WORKING_MODE_1 = 0x01,
281 WORKING_MODE_2 = 0x02,
283 WORKING_MODE_3 = 0x03,
285 WORKING_MODE_4 = 0x04
286 } CS_WORKING_MODE;
287
289 typedef enum
290 {
292 CH1_OFF_CH2_OFF = 0x00,
294 CH1_ON_CH2_OFF = 0x01,
296 CH1_OFF_CH2_ON = 0x02,
298 CH1_ON_CH2_ON = 0x03
299 } CS_RELAY_STATUS;
300
301 class eoEEP_A511xx: public eoA5EEProfile
302 {
303
304 public:
305 eoReturn SetType(uint8_t type);
306
307 eoEEP_A511xx();
308 virtual ~eoEEP_A511xx();
309 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
310 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
311 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
312 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
313
314 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
315 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
316 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
317 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
318
319 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
320 };
323 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A512xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A512xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_A512_H__INCLUDED_)
31 #define eoEEP_A512_H__INCLUDED_
32
35 #include "eoA5EEProfile.h"
106
107 typedef enum
108 {
110 CUMULATIVE = 0x00,
112 CURRENT = 0x01
113 } DATA_TYPE_METER_READING;
114
116 typedef enum
117 {
119 BATTERY_LEVEL_100_75 = 0x00,
121 BATTERY_LEVEL_75_50 = 0x01,
123 BATTERY_LEVEL_50_25 = 0x02,
125 BATTERY_LEVEL_25_0 = 0x03
126 } BATTERY_LEVEL;
127
129 typedef enum
130 {
132 POSITION_NOT_POSSESSED = 0x00,
134 POSITION_POSSESSED = 0x01
135 } SENSOR_POSITION_ENUM;
136
138 typedef enum
139 {
141 POSITION_LOCATION_0 = 0x00,
143 POSITION_LOCATION_1 = 0x01,
145 POSITION_LOCATION_2 = 0x02,
147 POSITION_LOCATION_3 = 0x03,
149 POSITION_LOCATION_4 = 0x04,
151 POSITION_LOCATION_5 = 0x05,
153 POSITION_LOCATION_6 = 0x06,
155 POSITION_LOCATION_7 = 0x07,
157 POSITION_LOCATION_8 = 0x08,
159 POSITION_LOCATION_9 = 0x09
160 } SENSOR_POSITION_INDEX_ENUM;
161
162 class eoEEP_A512xx: public eoA5EEProfile
163 {
164
165 public:
166 eoReturn SetType(uint8_t type);
167
168 eoEEP_A512xx();
169 virtual ~eoEEP_A512xx();
170 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
171 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
172 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
173 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
174 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
175 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
176
177 virtual eoChannelInfo* GetChannel(CHANNEL_TYPE type);
178 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
179 private:
180 eoReturn CalculateDivisorAndRawValue(float value, uint32_t & rawValue);
181 };
184 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A513xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A513xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_A513_H__INCLUDED_)
31 #define eoEEP_A513_H__INCLUDED_
32
35 #include "eoA5EEProfile.h"
109 typedef enum
110 {
112 RAIN_NORAIN = 0x00,
114 SUN_WEST = 0x01,
116 SUN_SOUTH = 0x02,
118 SUN_EAST = 0x03,
120 TIME_SECOND = 0x04,
122 TIME_MINUTE = 0x05,
124 TIME_HOUR = 0x06,
126 TIME_DAY = 0x07,
128 TIME_MONTH = 0x08,
130 TIME_YEAR = 0x09,
132 TIME_SOURCE = 0x0A,
134 AM_PM = 0x0B,
136 ELEVATION = 0x0C,
138 AZIMUTH = 0x0D,
140 LATITUDE = 0x0E,
142 LONGITUDE = 0x0F,
144 TIME_FORMAT = 0x10
145 } EA_INDEXS;
146
151 typedef enum
152 {
154 MONDAY = 0x01,
156 TUESDAY = 0x02,
158 WEDNESDAY = 0x03,
160 THURSDAY = 0x04,
162 FRIDAY = 0x05,
164 SATURDAY = 0x06,
166 SUNDAY = 0x07
167 } EA_ENUM_DAYS;
168
173 typedef enum
174 {
176 REAL_TIME_CLOCK = 0x00,
178 GPS = 0x01
179 } EA_TIME_SOURCE;
180
185 typedef enum
186 {
188 TIME_AM = 0x00,
190 TIME_PM = 0x01
191 } EA_AM_PM;
192
197 typedef enum
198 {
200 FORMAT_24 = 0x00,
202 FORMAT_12 = 0x01
203 } EA_TIME_FORMAT;
204
209 typedef enum
210 {
212 NORTH = 0x00,
214 SOUTH = 0x01
215 } EA_HEMISPHERE;
216
217 class eoEEP_A513xx: public eoA5EEProfile
218 {
219 private:
220 uint8_t cmd;
221
222 public:
223 eoReturn SetType(uint8_t type);
224 eoEEP_A513xx();
225 virtual ~eoEEP_A513xx();
226
227 eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
228 eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
229 eoReturn GetValue(CHANNEL_TYPE type, float &value);
230 eoReturn SetValue(CHANNEL_TYPE type, float value);
231
232 eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
233 eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
234 eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
235 eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
236
237 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
243 eoReturn SetCommand(uint8_t cmd);
244
245 eoReturn Parse(const eoMessage &m);
246 };
247
248 #endif
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A514xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A514xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_A514_H__INCLUDED_)
31 #define eoEEP_A514_H__INCLUDED_
32
35 #include "eoA5EEProfile.h"
93 class eoEEP_A514xx: public eoA5EEProfile
94 {
95
96 public:
97 eoReturn SetType(uint8_t type);
98 eoEEP_A514xx();
99 virtual ~eoEEP_A514xx();
100
101 eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
102 eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
103 };
104
105 #endif
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A520xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A520xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_A520_H__INCLUDED_)
29 #define eoEEP_A520_H__INCLUDED_
30
33 #include "eoA5EEProfile.h"
34 #include "eoISimpleBidirectionalProfile.h"
178
179 typedef enum
180 {
182 ENERGY_INPUT = 0x00,
184 ENERGY_STORAGE = 0x01,
186 BATTERY_CAPACITY = 0x02,
188 CONTACT_COVER = 0x03,
190 TEMPERATURE_FAIL = 0x04,
192 WINDOW_DETECTION = 0x05,
194 ACTUATOR_OBSTRUCTED = 0x06,
196 RUN_INTI_SEQ = 0x07,
198 LIFT_SET = 0x08,
200 VALVE_OPEN = 0x09,
202 VALVE_CLOSED = 0x0A,
204 SUMMER_BIT = 0x0B,
206 SET_POINT_SELECTION = 0x0C,
208 SET_POINT_INVERSE = 0x0D,
210 SELECT_FUNCTION = 0x0E,
212 ON_OFF = 0x0F,
214 EXTERNAL_DISABLEMENT = 0x10,
216 DISABLE_REMOTE_CONTROL = 0x11,
218 OTHER_DISABLEMENT = 0x12,
220 WINDOW_DISABLEMENT = 0x13,
222 KEYCARD_DISABLEMENT = 0x14,
224 ALARM_STATE = 0x15,
226 FAN_OVERRIDE = 0x16,
228 CONTROLLER_STATE = 0x17,
230 ENERGY_HOLDOFF = 0x18,
232 SERVICE_ON = 0x19,
234 FEED_TEMP = 0x1A,
236 CURRENT_TEMP = 0x1B,
238 MEASUREMENT_STATUS = 0x1C,
240 STATUS_REQUEST = 0x1D,
242 BUTTON_LOCK = 0x1E,
244 TEMP_SELECTION = 0x1F,
246 FAILURE = 0x20,
248 MEASUREMENT_CONTROL = 0x21,
250 WAKEUP_CYCLE = 0x22,
252 DISPLAY_ORIENTATION = 0x23
253 } HVCA_INDEX;
254
256 typedef enum
257 {
259 MODE_AUTO = 0x00,
261 MODE_HEAT = 0x01,
263 MODE_MORING_WARMUP = 0x02,
265 MODE_COOL = 0x03,
267 MODE_NIGHT_PURGE = 0x04,
269 MODE_PRECOOL = 0x05,
271 MODE_OFF = 0x06,
273 MODE_TEST = 0x07,
275 MODE_EMERGENCY_HEAT = 0x08,
277 MODE_FAN_ONLY = 0x09,
279 MODE_FREE_COOL = 0x0A,
281 MODE_ICE = 0x0B,
283 MODE_MAX_HEAT = 0x0C,
285 MODE_ECONOMIC = 0x0D,
287 MODE_DEHUMIDITY = 0x0E,
289 MODE_CALIBRATION = 0x0F,
291 MODE_EMERGENCY_COOL = 0x10,
293 MODE_EMERGENCY_STEAM = 0x11,
295 MODE_MAX_COOL = 0x12,
297 MODE_HVC_LOAD = 0x13,
299 MODE_NO_LOAD = 0x14,
301 MODE_AUTO_HEAT = 0x1F,
303 MODE_AUTO_COOL = 0x20
304 } HVAC_MODE;
305
307 typedef enum
308 {
310 VANE_AUTO = 0x00,
312 VANE_HORIZONTAL = 0x01,
314 VANE_POS_2 = 0x02,
316 VANE_POS_3 = 0x03,
318 VANE_POS_4 = 0x04,
320 VANE_VERTICAL = 0x05,
322 VANE_SWING = 0x06,
324 VANE_VERT_SWING = 0x0B,
326 VANE_HORIZ_SWING = 0x0C,
328 VANE_BOTH_SWING = 0x0D,
330 VANE_STOP_SWING = 0x0E
331 } HVCA_VANE_POSITION;
332
334 typedef enum
335 {
337 HVCA_OCCUPIED = 0x00,
339 HVCA_STANDBY = 0x01,
341 HVCA_UNOCCUPIED = 0x02,
343 HVCA_OFF = 0X03
344 } HVCA_ROOM_OCCUPANCY;
345
347 typedef enum
348 {
350 HVCA_OCCUPIED_20 = 0x00,
352 HVCA_UNOCCUPIED_20 = 0x01,
354 HVCA_STANDBY_20 = 0x02,
356 HVCA_FROST_20 = 0X03
357 } HVCA_ROOM_OCCUPANCY_TYPE_20;
358
360 typedef enum
361 {
363 HVCA_STAGE_0 = 0x00,
365 HVCA_STAGE_1 = 0x01,
367 HVCA_STAGE_2 = 0x02,
369 HVCA_STAGE_3 = 0x03,
371 HVCA_AUTO = 0x1F
372 } HVCA_FANSPEED;
373
375 typedef enum
376 {
378 HVCA_AUTO_MOD = 0x00,
380 HVCA_HEAT_MOD = 0x01,
382 HVCA_COOL_MOD = 0x02,
384 HVCA_OFF_MOD = 0x03
385 } HVCA_CONTROLLER_MODE;
386
388 typedef enum
389 {
391 MEASUREMENT_ERROR = 0x11,
393 BATTERY_EMPTY = 0x12,
395 FROST_PROTECTION = 0x14,
397 BLOCKED_VALVE = 0x21,
399 END_POINT_DETECTION = 0x24,
401 NO_VALVE = 0x28,
403 NOT_TEACHED_IN = 0x31,
405 NO_RESPONSE_FROM_CONTROLLER = 0x35,
407 TEACH_IN_ERROR = 0x36
408 } HVCA_FAILURE_CODE;
409
411 typedef enum
412 {
414 MEASUREMENT_ACTIVE = 0x00,
416 MEASUREMENT_INACTIVE = 0x01
417 } HVCA_MEASUREMENT_STATUS;
418
420 typedef enum
421 {
423 MEASUREMENT_ENABLE = 0x00,
425 MEASUREMENT_DISABLE = 0x01
426 } HVCA_MEASUREMENT_CONTROL;
427
429 typedef enum
430 {
432 STATUS_NO_CHANGE = 0x00,
434 STATUS_REQUESTED = 0x01
435 } HVCA_STATUS_REQUEST;
436
438 typedef enum
439 {
441 BUTTON_UNLOCKED = 0x00,
443 BUTTON_LOCKED = 0x01
444 } HVCA_BUTTON_LOCK;
445
447 typedef enum
448 {
450 FEED_TEMP_SELECT = 0x00,
452 TEMP_SETPOINT_SELECT = 0x01
453 } HVCA_TEMP_SELECTION;
454
456 typedef enum
457 {
459 NO_FAILURE_FLAG = 0x00,
461 FAILURE_FLAG = 0x01
462 } HVCA_FAILURE;
463
465 typedef enum
466 {
468 SEC_10 = 0x00,
470 SEC_60 = 0x01,
472 SEC_90 = 0x02,
474 SEC_120 = 0x03,
476 SEC_150 = 0x04,
478 SEC_180 = 0x05,
480 SEC_210 = 0x06,
482 SEC_240 = 0x07,
484 SEC_270 = 0x08,
486 SEC_300 = 0x09,
488 SEC_330 = 0x0A,
490 SEC_360 = 0x0B,
492 SEC_390 = 0x0C,
494 SEC_420 = 0x0D,
496 SEC_450 = 0x0E,
498 SEC_480 = 0x0F,
500 SEC_510 = 0x10,
502 SEC_540 = 0x11,
504 SEC_570 = 0x12,
506 SEC_600 = 0x13,
508 SEC_630 = 0x14,
510 SEC_660 = 0x15,
512 SEC_690 = 0x16,
514 SEC_720 = 0x17,
516 SEC_750 = 0x18,
518 SEC_780 = 0x19,
520 SEC_810 = 0x1A,
522 SEC_840 = 0x1B,
524 SEC_870 = 0x1C,
526 SEC_900 = 0x1D,
528 SEC_930 = 0x1E,
530 SEC_960 = 0x1F,
532 SEC_990 = 0x20,
534 SEC_1020 = 0x21,
536 SEC_1050 = 0x22,
538 SEC_1080 = 0x23,
540 SEC_1110 = 0x24,
542 SEC_1140 = 0x25,
544 SEC_1170 = 0x26,
546 SEC_1200 = 0x27,
548 SEC_1230 = 0x28,
550 SEC_1260 = 0x29,
552 SEC_1290 = 0x2A,
554 SEC_1320 = 0x2B,
556 SEC_1350 = 0x2C,
558 SEC_1380 = 0x2D,
560 SEC_1410 = 0x2E,
562 SEC_1440 = 0x2F,
564 SEC_1470 = 0x30,
566 SEC_1500 = 0x31,
568 HRS_3 = 0x32,
570 HRS_6 = 0x33,
572 HRS_9 = 0x34,
574 HRS_12 = 0x35,
576 HRS_15 = 0x36,
578 HRS_18 = 0x37,
580 HRS_21 = 0x38,
582 HRS_24 = 0x39,
584 HRS_27 = 0x3A,
586 HRS_30 = 0x3B,
588 HRS_33 = 0x3C,
590 HRS_36 = 0x3D,
592 HRS_39 = 0x3E,
594 HRS_42 = 0x3F
595 } HVCA_WAKEUP_CYCLE;
596
598 typedef enum
599 {
601 ORIENTATION_0 = 0x00,
603 ORIENTATION_90 = 0x01,
605 ORIENTATION_180 = 0x02,
607 ORIENTATION_270 = 0x03
608 } HVCA_DISPLAY_ORIENTATION;
609
611 typedef enum
612 {
614 HVCA_NO_CHANGE = 0x00,
616 HVCA_OPEN_VALVE = 0x01,
618 HVCA_RUN_INIT = 0x02,
620 HVCA_CLOSE_VALVE = 0x03
621 } HVCA_SERVICE_COMMAND;
622
624 typedef enum
625 {
627 HVCA_DIRECTION_1 = 0x00,
629 HVCA_DIRECTION_2 = 0x01
630 } HVCA_DIRECTION;
631
632 class eoEEP_A520xx: public eoA5EEProfile, public eoISimpleBidirectionalProfile
633 {
634
635 private:
636 eoMessage outMessage;
637 eoEEPChannelInfo *outChannels;
638 uint8_t outChannelCount;
639 //internal helper tries to set the channel for Direction and type
640 eoReturn SetChannels(SIMPLE_DIRECTION direction,uint8_t type);
641 public:
642 eoReturn SetType(uint8_t type);
643 eoEEP_A520xx();
644 virtual ~eoEEP_A520xx();
645
646 eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
647 eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
648 eoReturn GetValue(CHANNEL_TYPE type, float &value);
649 eoReturn SetValue(CHANNEL_TYPE type, float value);
650 eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
651 eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
652 eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
653 eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
654 virtual eoReturn Create(eoMessage &m);
655 virtual eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t subFlag);
656
657 virtual eoChannelInfo* GetOutChannel(CHANNEL_TYPE type, uint8_t subType);
658 virtual eoChannelInfo* GetOutChannel(CHANNEL_TYPE type);
659 virtual eoChannelInfo* GetOutChannel(uint8_t channelNumber);
666 eoReturn SetDirection(HVCA_DIRECTION direction);
667 virtual eoReturn SetDirection(SIMPLE_DIRECTION directionToSet);
668 virtual void ClearValues();
669 };
670
671 #endif
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A530xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A530xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_A530_H__INCLUDED_)
29 #define eoEEP_A530_H__INCLUDED_
30
33 #include "eoA5EEProfile.h"
96
97 typedef enum
98 {
100 KEY_DATA_1 = 0x00,
102 KEY_DATA_2 = 0x01,
104 KEY_DATA_3 = 0x02,
106 KEY_DATA_4 = 0x03,
108 KEY_DATA_5 = 0x04,
110 KEY_DATA_6 = 0x05
111 } A530_INDEX;
112
114 typedef enum
115 {
117 BATTERY_LOW = 0x00,
119 BATTERY_EO_OK = 0x01
120 } A530_BATTERY_VALUE;
121
123 typedef enum
124 {
126 NORMAL_SIGNAL = 0x00,
128 HEART_BEAT_SIGNAL = 0x01
129 } A530_SIGNAL_TYPE;
130
132 typedef enum
133 {
135 STATUS_WAKE = 0x00,
137 DIGITAL_IN_0 = 0x01,
139 DIGITAL_IN_1 = 0x02,
141 DIGITAL_IN_2 = 0x03,
143 DIGITAL_IN_3 = 0x04
144 } ENUM_DIGITAL_INPUT;
145
146 class eoEEP_A530xx: public eoA5EEProfile
147 {
148
149 public:
150 eoEEP_A530xx();
151 virtual ~eoEEP_A530xx();
152
153 eoReturn SetType(uint8_t type);
154 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
155 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
156 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
157 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
158 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
159 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
160
161 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
162 };
165 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A537xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A537xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_A537_H__INCLUDED_)
29 #define eoEEP_A537_H__INCLUDED_
30
33 #include "eoA5EEProfile.h"
54
55 typedef enum
56 {
58 ABS_REL_POWER = 0x00,
60 RAND_START_DELAY = 0x01,
62 RAND_END_DELAY = 0x02,
64 MAX_MIN_POWER = 0x03
65 } EM_INDEXS;
66
67 class eoEEP_A537xx: public eoA5EEProfile
68 {
69
70 public:
71 eoEEP_A537xx();
72 virtual ~eoEEP_A537xx();
73
74 eoReturn SetType(uint8_t type);
75 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
76 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
77 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
78 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
79
80 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
81 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
82
83 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
84 };
87 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_A538xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_A538xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_A538_H__INCLUDED_)
29 #define eoEEP_A538_H__INCLUDED_
30
33 #include "eoA5EEProfile.h"
133
134 typedef enum
135 {
137 CC_LOCK_UNLOCK = 0x00,
139 CC_DELAY_DURATION = 0x01,
141 CC_SWITCHING_COMMAND = 0x02,
143 CC_DIMMING_RANGE = 0x03,
145 CC_STORE_FINAL_VAL = 0x04,
147 CC_CONTROLLER_STATE = 0x05,
149 CC_ENERGY_HOLDOFF = 0x06,
151 CC_SEND_STATUS = 0x07,
153 CC_POS_ANGLE_FLAG = 0x08,
155 CC_SERVICE_MODE = 0x09,
157 CC_BLIND_POSITION = 0x0A,
159 CC_ANGLE_BLIND_POSITION = 0x0B,
161 CC_BLIND_OPEN_POSITION = 0x0C,
163 CC_BLIND_OPEN_ANGLE = 0x0D,
165 CC_BLIND_CLOSE_POSITION = 0x0E,
167 CC_BLIND_CLOSE_ANGLE = 0x0F,
169 CC_RUNTIME_OPEN = 0x10,
171 CC_RUNTIME_CLOSE = 0x11,
173 CC_SUNBLIND_REVERSION = 0x12,
175 CC_SET_MIN_POSITION = 0x13,
177 CC_SET_MAX_POSITION = 0x14,
179 CC_FULLY_SHUT_ANGLE = 0x15,
181 CC_FULLY_OPEN_ANGLE = 0x16,
183 CC_POSITION_LOGIC = 0x17,
185 CC_DIMMING_VALUE = 0x18,
187 CC_UP_RAMPING_TIME = 0x19,
189 CC_DOWN_RAMPING_TIME = 0x1A,
191 CC_SET_RAMPING_TIME = 0x1B,
193 CC_RGB_RED = 0x1C,
195 CC_RGB_GREEN = 0x1D,
197 CC_RGB_BLUE = 0x1E,
199 CC_MIN_DIM_VALUE = 0x1F,
201 CC_MAX_DIM_VALUE = 0x20,
203 CC_LAMP_OPERATING_HOUR = 0x21,
205 CC_SCENE_NUMBER = 0x22,
207 CC_SCENE = 0x23,
209 CC_ENERGY_METERING_VALUE = 0x24
210 } CC_INDEXS;
211
213 typedef enum
214 {
216 MILI_W = 0x00,
218 W = 0x01,
220 KILO_W = 0x02,
222 MEGA_W = 0x03,
224 WH = 0x04,
226 KILO_WH = 0x05,
228 MEGA_WH = 0x06,
230 GIGA_WH = 0x07,
232 MILI_A = 0x08,
234 A_1_10 = 0x09,
236 MILI_V = 0x0A,
238 V_1_10 = 0x0B
239 } CC_ENERGY_UNITS;
240
242 typedef enum
243 {
245 UNLOCK_LOCAL_OP = 0x00,
247 LOCK_SWITCH_ON = 0x01,
249 LOCK_SWITCH_OFF = 0x02,
251 LOCK_LOCAL_OP = 0x03
252 } CC_LOCKING_OPERATIONS;
253
255 typedef enum
256 {
258 DO_NOTHING = 0x00,
260 STOP_BLIND = 0x01,
262 OPEN_BLIND = 0x02,
264 CLOSE_BLIND = 0x03,
266 DRIVE_TO_POS = 0x04,
268 OPEN_FOR_TIME = 0x05,
270 CLOSE_FOR_TIME = 0x06,
272 SET_RUNTIME_PARAM = 0x07,
274 SET_ANGLE = 0x08,
276 SET_MIN_MAX = 0x09,
278 SET_SLAT_ANGLE = 0x0A,
280 SET_LOGIC_POS = 0x0B
281 } CC_FUNCTIONS;
282
284 typedef enum
285 {
287 CC_DO_NOTHING = 0x00,
289 CC_SWITCHED_OFF = 0x01,
291 CC_SWITCHED_ON = 0x02,
293 CC_DIMMING_UP = 0x03,
295 CC_DIMMING_DOWN = 0x04,
297 CC_DIMMING_STOP = 0x05,
299 CC_SET_VALUES = 0x06,
301 CC_SET_RGB_VALUES = 0x07,
303 CC_SCENE_FUNCTION = 0x08,
305 CC_SET_DIMMER_VALUE = 0x09,
307 CC_SET_OP_HOURS = 0x0A,
309 CC_LOCK_OPERATIONS = 0x0B,
311 CC_NEW_VALUE_METERING = 0x0C
312 } CC_FUNCTIONS_TYPE_09;
313
315 typedef enum
316 {
318 CC_STAGE_0 = 0,
320 CC_STAGE_1 = 1,
322 CC_STAGE_2 = 2,
324 CC_STAGE_3 = 3,
326 CC_STAGE_AUTO = 255
327 } CC_FAN_SPEED_5_STAGE;
328
330 typedef enum
331 {
333 CC_OCCUPIED = 0,
335 CC_UNOCCUPIED = 1,
337 CC_STANDBY = 2
338 } CC_ROOM_OCCUPANCY;
339
341 typedef enum
342 {
344 CC_AUTO = 0,
346 CC_HEATING = 1,
348 CC_COOLING = 2,
350 CC_OFF = 3
351 } CC_CONTROLLER_MODE;
352
353 class eoEEP_A538xx: public eoA5EEProfile
354 {
355 private:
356 uint8_t cmd;
357
358 public:
359 eoEEP_A538xx();
360 virtual ~eoEEP_A538xx();
361
362 eoReturn SetType(uint8_t type);
363 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
364 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
365 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
366 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
367
368 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
369 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
370 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
371 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
372
373 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
379 eoReturn SetCommand(uint8_t cmd);
380
381 eoReturn Parse(const eoMessage &m);
382 };
385 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D2A0xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D2A0xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_D2A0_H__INCLUDED_)
29 #define eoEEP_D2A0_H__INCLUDED_
30
33 #include "eoD2EEProfile.h"
34 #include "eoISimpleBidirectionalProfile.h"
61
62 typedef enum
63 {
65 VALVE_STATUS_CLOSED = 0x01,
67 VALVE_STATUS_OPENED = 0x02
68 } VALVE_STATUS;
69
71 typedef enum
72 {
74 VALVE_REQUEST_FEEDBACK = 0x00,
76 VALVE_REQUEST_CLOSE = 0x01,
78 VALVE_REQUEST_OPEN = 0x02,
80 VALVE_REQUEST_CLOSE_2 = 0x03
81 } VALVE_REQUEST;
82
84 typedef enum
85 {
87 VALVE_TO_CONTROLLER = 0x00,
89 CONTROLLER_TO_VALVE = 0x01
90 } VALVE_DIRECTION;
91
92 class eoEEP_D2A0xx: public eoD2EEProfile, public eoISimpleBidirectionalProfile
93 {
94 private:
95 VALVE_DIRECTION oldDirection;
96 eoMessage outMessage;
97 eoEEPChannelInfo *outChannels;
98 uint8_t outChannelCount;
99 //internal helper tries to set the channel for Direction and type
100 eoReturn SetChannels(SIMPLE_DIRECTION direction,uint8_t type);
101 public:
102 eoReturn SetType(uint8_t type);
103 eoReturn Parse(const eoMessage &msg);
108 eoEEP_D2A0xx(uint16_t size = 1);
109 virtual ~eoEEP_D2A0xx();
110 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
111 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
112
118 eoReturn SetDirection(VALVE_DIRECTION direction);
119 virtual eoReturn Create(eoMessage &m);
120
121 virtual eoChannelInfo* GetOutChannel(CHANNEL_TYPE type);
122 virtual eoChannelInfo* GetOutChannel(uint8_t channelNumber);
123 virtual eoReturn SetDirection(SIMPLE_DIRECTION directionToSet);
124
125 virtual void ClearValues();
126 };
129 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D200xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D200xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_D200_H__INCLUDED_)
29 #define eoEEP_D200_H__INCLUDED_
30
33 #include "eoD2EEProfile.h"
108
109 typedef enum
110 {
112 RCP_CONFIG_VALID = 0x00,
114 RCP_USER_NOTIFICATION = 0x01,
116 RCP_DEW_POINT = 0x02,
118 RCP_COOLING = 0x03,
120 RCP_HEATING = 0x04,
122 RCP_FAN_MANUAL = 0x05,
124 RCP_MORE_DATA = 0x06,
126 RCP_KEEP_ALIVE_TIME = 0x07,
128 RCP_TEMP_MEASUREMENT_TIMING = 0x08,
130 RCP_SETPOINT_STEPS = 0x09,
132 RCP_SETPOINT_RANGE_LIMIT = 0x0A,
134 RCP_NO_DISPLAY = 0x0B,
136 RCP_ROOM_TEMPERATURE_C = 0x0C,
138 RCP_ROOM_TEMPERATURE_F = 0x0D,
140 RCP_NOMINAL_TEMPERATURE_C = 0x0E,
142 RCP_NOMINAL_TEMPERATURE_F = 0x0F,
144 RCP_DELTA_TEMP_SETPOINT_C = 0x10,
146 RCP_DELTA_TEMP_SETPOINT_F = 0x11,
148 RCP_DELTA_TEMP_GRAPHIC = 0x12,
150 RCP_TIME_24_HOURS = 0x13,
152 RCP_TIME_AM_HOURS = 0x14,
154 RCP_TIME_PM_HOURS = 0x15,
156 RCP_TIME_DAY_MONTH = 0x16,
158 RCP_TIME_MONTH_DAY = 0x17
159 } RCP_INDEXS;
160
162 typedef enum
163 {
165 RCP_FIRST_USER_ACTION = 0x01,
167 RCP_DISPLAY_CONTENT = 0x02,
169 RCP_REPEATED_USER_ACTION = 0x03,
171 RCP_MEASUREMENT_RESULT = 0x04,
173 RCP_SENSOR_CONFIG = 0x05
174 } RCP_COMMANDS;
175
177 typedef enum
178 {
180 PRESENCE = 0x01,
182 TEMP_DOWN = 0x02,
184 TEMP_UP = 0x05,
186 FAN = 0x06
187 } RCP_USER_ACTION;
188
190 typedef enum
191 {
193 NO_CHANGE = 0x00,
195 PRESENT = 0x01,
197 NOT_PRESENT = 0x02,
199 NIGHT_TIME = 0x03
200 } RCP_PRESENCE;
201
203 typedef enum
204 {
206 RCP_DO_NOT_DISPLAY = 0x00,
208 RCP_SPEED_LEVEL_0 = 0x01,
210 RCP_SPEED_LEVEL_1 = 0x02,
212 RCP_SPEED_LEVEL_2 = 0x03,
214 RCP_SPEED_LEVEL_3 = 0x04
215 } RCP_5_LEVEL_FANSPEED;
216
218 typedef enum
219 {
221 FAN_NO_CHANGE = 0x00,
223 SPEED_LEVEL_0 = 0x01,
225 SPEED_LEVEL_1 = 0x02,
227 SPEED_LEVEL_2 = 0x03,
229 SPEED_LEVEL_3 = 0x04,
231 SPEED_LEVEL_AUTO = 0x05
232 } RCP_6_LEVEL_FANSPEED;
233
234 class eoEEP_D200xx: public eoD2EEProfile
235 {
236 private:
237 uint8_t cmd;
238
239 public:
240 eoReturn SetType(uint8_t type);
241 eoReturn Parse(const eoMessage &msg);
246 eoEEP_D200xx(uint16_t size = 10);
247 virtual ~eoEEP_D200xx();
248 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
249 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
250 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
251 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
252 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
253 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
254 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
255 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
256
257 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
258 virtual eoReturn SetCommand(uint8_t cmd);
259 };
262 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D201xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D201xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_D201_H__INCLUDED_)
29 #define eoEEP_D201_H__INCLUDED_
30
33 #include "eoD2EEProfile.h"
149
150 typedef enum
151 {
153 ACTUATOR_SET_OUTPUT = 0x01,
155 ACTUATOR_SET_LOCAL = 0x02,
157 ACTUATOR_STATUS_QUERY = 0x03,
159 ACTUATOR_STATUS_RESPONSE = 0x04,
161 ACTUATOR_SET_MEASUREMENT = 0x05,
163 ACTUATOR_MEASUREMENT_QUERY = 0x06,
165 ACTUATOR_MEASUREMENT_RESPONSE = 0x07,
167 ACTUATOR_PILOTWIRE_SET = 0x08,
169 ACTUATOR_PILOTWIRE_QUERY = 0x09,
171 ACTUATOR_PILOTWIRE_RESPONSE = 0x0A
172 } COMMANDS;
173
175 typedef enum
176 {
178 TAUGHT_IN_DEVICES = 0x00,
180 OVER_CURRENT_SHUT = 0x01,
182 RESET_OVER_CURRENT = 0x02,
184 LOCAL_CONTROL = 0x03,
186 USER_INDICATION = 0x04,
188 REPORT_MEASUREMENT = 0x05,
190 RESET_MEASUREMENT = 0x06,
192 MEASUREMENT_MODE = 0x07,
194 QUERY = 0x08,
196 PWR_FAILURE = 0x09
197 } VLD_ON_OFF_INDEX;
198
200 typedef enum
201 {
203 DIMMING_SLOW = 0x00,
205 DIMMING_MEDIUM = 0x01,
207 DIMMING_FAST = 0x02,
209 MAX_SUB_TIME = 0x03,
211 MIN_SUB_TIME = 0x04
212 } VLD_TIME_INDEX;
213
215 typedef enum
216 {
218 ENERGY_WS = 0x00,
220 ENERGY_WH = 0x01,
222 ENERGY_KWH = 0x02,
224 POWER_W = 0x03,
226 POWER_KW = 0x04
227 } VLD_UNITS;
228
230 typedef enum
231 {
233 SWITCH_TO_NEW = 0x00,
235 DIM_TO_NEW_FAST = 0x01,
237 DIM_TO_NEW_MED = 0x02,
239 DIM_TO_NEW_SLOW = 0x03,
241 DIM_STOP = 0x04
242 } VLD_DIM_VALUE;
243
245 typedef enum
246 {
248 HARDWARE_OK = 0x00,
250 HARDWARE_WARNING = 0x01,
252 HARDWATE_FAIL = 0x02
253 } VLD_ERROR_LEVEL;
254
256 typedef enum
257 {
259 STATE_OFF = 0x00,
261 STATE_ON = 0x01,
263 PREV_STATE = 0x02
264 } VLD_DEFAULT_STATE;
265
267 typedef enum
268 {
270 ALL_SUPPORTED = 0x1E,
272 INPUT_FOR_MAINS = 0x1F
273 } VLD_IO_CHANNEL;
274
276 typedef enum
277 {
279 PILOTWIRE_OFF = 0x00,
281 PILOTWIRE_COMFORT = 0x01,
283 PILOTWIRE_ECO = 0x02,
285 PILOTWIRE_ANTI_FREEZE = 0x03,
287 PILOTWIRE_COMFORT_1 = 0x04,
289 PILOTWIRE_COMFORT_2 = 0x05
290 } VLD_PILOTWIRE_MODE;
291
292 class eoEEP_D201xx: public eoD2EEProfile
293 {
294 private:
295 uint8_t cmd;
296
297 public:
298 eoReturn SetType(uint8_t type);
299 eoReturn Parse(const eoMessage &msg);
304 eoEEP_D201xx(uint16_t size = 10);
305 virtual ~eoEEP_D201xx();
306 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
307 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
308 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
309 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
310 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
311 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
312 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
313 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
314
315 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
321 virtual eoReturn SetLength (uint8_t type);
322 virtual eoReturn SetCommand(uint8_t cmd);
323 };
326 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D202xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D202xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_D202_H__INCLUDED_)
29 #define eoEEP_D202_H__INCLUDED_
30
33 #include "eoD2EEProfile.h"
79
80 typedef enum
81 {
83 SENSOR_MEASUREMENT = 0x01,
85 SENSOR_TEST_TRIGGER = 0x02,
87 ACTUATOR_SET = 0x03,
89 SENSOR_QUERY = 0x04
90 } VLD_COMMANDS;
91
93 typedef enum
94 {
96 VLD_SELF_TEST = 0x00,
98 VLD_TRIGGER_ALARM = 0x01,
100 VLD_REPORT_MEASUREMENT = 0x02,
102 VLD_MAX_TIME = 0x03,
104 VLD_MIN_TIME = 0x04
105 } VLD_INDEXS;
106
108 typedef enum
109 {
111 NO_SMOKE = 0x00,
113 SMOKE_IONIZATION = 0x01,
115 SMOKE_OPTICAL = 0x02,
117 SMOKE_BOTH = 0x03
118 } VLD_SMOKE_DETECTION;
119
121 typedef enum
122 {
124 QUERY_TEMP = 0x00,
126 QUERY_LUMINANCE = 0x01,
128 QUERY_OCCUPANCY = 0x02,
130 QUERY_SMOPKE = 0x03
131 } VLD_QUERY_STATUS;
132
133 class eoEEP_D202xx: public eoD2EEProfile
134 {
135 private:
136 uint8_t cmd;
137
138 public:
139 eoReturn SetType(uint8_t type);
140 eoReturn Parse(const eoMessage &msg);
145 eoEEP_D202xx(uint16_t size = 10);
146 virtual ~eoEEP_D202xx();
147 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
148 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
149 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
150 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
151 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
152 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
153 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
154 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
155 virtual eoReturn SetCommand(uint8_t cmd);
156 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
157 };
160 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D203xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D203xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_D203_H__INCLUDED_)
31 #define eoEEP_D203_H__INCLUDED_
32
35 #include "eoF6EEProfile.h"
36 #include "eoD2EEProfile.h"
65 class eoEEP_D203xx: public eoD2EEProfile
66 {
67 private:
68 eoReturn RockerHelper();
69 uint8_t RockerSetHelper();
70 uint8_t rockerA;
71 uint8_t rockerB;
72 bool energybowReleased;
73 bool multipress;
74 public:
75 eoReturn SetType(uint8_t type);
76 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
77 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
78 void ClearValues();
79 virtual eoReturn Parse(const eoMessage &msg);
80
81 eoEEP_D203xx();
82 virtual ~eoEEP_D203xx();
83 };
86 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D204xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D204xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_D204_H__INCLUDED_)
31 #define eoEEP_D204_H__INCLUDED_
32
35 #include "eoD2EEProfile.h"
178
179 typedef enum
180 {
182 NS_BATTERY_100_875 = 0x00,
184 NS_BATTERY_875_75 = 0x01,
186 NS_BATTERY_75_625 = 0x02,
188 NS_BATTERY_625_50 = 0x03,
190 NS_BATTERY_50_375 = 0x04,
192 NS_BATTERY_375_25 = 0x05,
194 NS_BATTERY_25_125 = 0x06,
196 NS_BATTERY_125_0 = 0x07
197 } NS_BATTERY_AUTONOMY;
198
199 class eoEEP_D204xx: public eoD2EEProfile
200 {
201 public:
206 eoEEP_D204xx(uint16_t size = 4);
207 virtual ~eoEEP_D204xx();
208 eoReturn SetType(uint8_t type);
209 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
210 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
211 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
212 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
213 };
216 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D205xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D205xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_D205_H__INCLUDED_)
29 #define eoEEP_D205_H__INCLUDED_
30
33 #include "eoD2EEProfile.h"
83
84 typedef enum
85 {
87 CUR_VER_POSITION = 0x00,
89 CUR_ROT_ANGLE = 0x01,
91 SET_VER_DURATION = 0x02,
93 SET_ROT_DURATION = 0x03
94 } D205_INDEX_ENUM;
95
97 typedef enum
98 {
100 GOTO_MSG = 0x01,
102 STOP_MSG = 0x02,
104 QUERY_MSG = 0x03,
106 REPLY_MSG = 0x04,
108 SET_PARAM_MSG = 0x05
109 } D205_MESSAGE_ID_ENUM;
110
112 typedef enum
113 {
115 REPOS_DIRECT_POS_ANG = 0x00,
117 REPOS_UP_POS_ANG = 0x01,
119 REPOS_DOWN_POS_ANG = 0x02
120 } D205_REPOSITIONING_ENUM;
121
123 typedef enum
124 {
126 LOCK_NORMAL = 0x00,
128 LOCK_BLOCKAGE = 0x01,
130 LOCK_ALARM = 0x02,
132 LOCK_DEBLOCKAGE = 0x07
133 } D205_LOCK_MODE_ENUM;
134
136 typedef enum
137 {
139 ALARM_NO_ACTION = 0x00,
141 ALARM_IMMEDIATE_STOP = 0x01,
143 ALARM_UP = 0x02,
145 ALARM_DOWN = 0x03,
147 ALARM_NO_CHANGE = 0x07
148 } D205_AET_ALARM_ENUM;
149
150 class eoEEP_D205xx: public eoD2EEProfile
151 {
152 private:
153 uint8_t cmd;
154
155 public:
156 eoReturn SetType(uint8_t type);
157 eoReturn Parse(const eoMessage &msg);
162 eoEEP_D205xx(uint16_t size = 10);
163 virtual ~eoEEP_D205xx();
164 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
165 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
166 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
167 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
168 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
169 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
170
171 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
177 virtual eoReturn SetLength (uint8_t type);
178 virtual eoReturn SetCommand(uint8_t cmd);
179 };
182 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D206xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D206xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_D206_H__INCLUDED_)
29 #define eoEEP_D206_H__INCLUDED_
30
33 #include "eoD2EEProfile.h"
108
109 typedef enum
110 {
112 BURGLARY_ALARM = 0x00,
114 PROTECTION_PLUS_ALARM = 0x01,
116 HANDLE_POSITION = 0x02,
118 WINDOW_STATE = 0x03,
120 BUTTON_1 = 0x04,
122 BUTTON_2 = 0x05,
124 MOTION = 0x06,
126 VACATION_MODE = 0x07,
128 HANDLE_CLICK = 0x08,
130 BATTERY_CLICK = 0x09,
132 SENSOR_INTERVAL = 0x0A,
134 VACATION_INTERVAL = 0x0B,
136 POWER_ONS = 0x0C,
138 ALARMS = 0x0D,
140 HANDLE_CLOSED = 0x0E,
142 HANDLE_OPENED = 0x0F,
144 HANDLE_TILTED = 0x10,
146 WINDOW_TILTS = 0x11,
148 START_TRANSMISSION_CONFIG_SETTINGS = 0x12,
150 START_TRANSMISSION_LOG_DATA = 0x13
151 } D206_INDEX_ENUM;
152
154 typedef enum
155 {
157 MSG_SENSOR_VALUES = 0x00,
159 MSG_CONFIG_REPORT = 0x01,
161 MSG_LOG_DATA_1 = 0x02,
163 MSG_LOG_DATA_2 = 0x03,
165 MSG_LOG_DATA_3 = 0x04,
167 MSG_LOG_DATA_4 = 0x05,
169 MSG_CTRL_SETTINGS = 0x06
170 } D206_MSG_TYPE_ENUM;
171
172 class eoEEP_D206xx: public eoD2EEProfile
173 {
174 private:
175 uint8_t cmd;
176
177 public:
178 eoReturn SetType(uint8_t type);
179 eoReturn Parse(const eoMessage &msg);
184 eoEEP_D206xx(uint16_t size = 10);
185 virtual ~eoEEP_D206xx();
186 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
187 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
188 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
189 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
190 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
191 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
192 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
193 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
194
195 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
201 virtual eoReturn SetLength (uint8_t type);
202 virtual eoReturn SetCommand(uint8_t cmd);
203 };
206 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D210xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D210xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_D210_H__INCLUDED_)
29 #define eoEEP_D210_H__INCLUDED_
30
33 #include "eoD2EEProfile.h"
133
134 typedef enum
135 {
137 MSG_CONTINUATION = 0x00,
139 INFO_REQUEST_CLASS = 0x01,
141 FEEDBACK_CLASS = 0x02,
143 GENERAL_MSG_TYPE = 0x03,
145 RELHUM_VALIDITY = 0x04,
147 FANSPEED_VALIDITY = 0x05,
149 FANSPEED_MODE = 0x06,
151 CUSTOM_WARNING_1 = 0x07,
153 CUSTOM_WARNING_2 = 0x08,
155 MOLD_WARNING = 0x09,
157 WINDOW_OPEN_DETECTION = 0x0A,
159 BATTERY_STATUS = 0x0B,
161 SOLAR_POWERED_STATUS = 0x0C,
163 PIR_STATUS = 0x0D,
165 COOLING_STATUS = 0x0E,
167 HEATING_STATUS = 0x0F,
169 TEMP_SETPOINT_VALIDITY = 0x10,
171 TEMP_VALIDITY = 0x11,
173 PIR_LOCK = 0x12,
175 TEMP_LOCK = 0x13,
177 DISPLAY_LOCK = 0x14,
179 DATE_TIME_LOCK = 0x15,
181 TIME_PROG_LOCK = 0x16,
183 OCCUPANCY_LOCK = 0x17,
185 TEMP_SETPOINT_LOCK = 0x18,
187 FAN_SPEED_LOCK = 0x19,
189 RADIO_COM_INTERVAL = 0x1A,
191 KEY_LOCK = 0x1B,
193 DISPLAY_CONTENT = 0x1C,
195 TEMP_SCALE = 0x1D,
197 DAYLIGHT_SAVE = 0x1E,
199 TIME_NOTATION = 0x1F,
201 TIME_CURRENT_DAY = 0x20,
203 TIME_CURRENT_MONTH = 0x21,
205 TIME_CURRENT_YEAR = 0x22,
207 TIME_CURRENT_MINUTE = 0x23,
209 TIME_CURRENT_HOUR = 0x24,
211 DATE_TIME_UPDATE_FLAG = 0x25,
213 RECENT_TEMP_SETPOINT = 0x26,
215 BUILDING_PROTECT_TEMP_SETPOINT = 0x27,
217 PRECOMFORT_TEMP_SETPOINT = 0x28,
219 ECONOMY_TEMP_SETPOINT = 0x29,
221 COMFORT_TEMP_SETPOINT = 0x2A,
223 BUILDING_PROTECT_TEMP_SETPOINT_VALIDITY = 0x2B,
225 PRECOMFORT_TEMP_SETPOINT_VALIDITY = 0x2C,
227 ECONOMY_TEMP_TEMP_SETPOINT_VALIDITY = 0x2D,
229 COMFORT_TEMP_SETPOINT_VALIDITY = 0x2E,
231 END_TIME_MINUTE = 0x2F,
233 END_TIME_HOUR = 0x30,
235 START_TIME_MINUTE = 0x31,
237 START_TIME_HOUR = 0x32,
239 TIME_PROG_DELETION = 0x33
240 } D210_INDEX_ENUM;
241
243 typedef enum
244 {
246 GENERAL_MSG = 0x00,
248 DATA_MSG = 0x01,
250 CONFIG_MSG = 0x02,
252 ROOM_CONTROL_MSG = 0x03,
254 TIME_PROG_MSG = 0x04
255 } D210_MESSAGE_ID_ENUM;
256
258 typedef enum
259 {
261 MSG_COMPLETE = 0x00,
263 MSG_INCOMPLETE = 0x01,
265 MSG_AUTO_CONTROL = 0x02
266 } D210_MSG_CONTINUATION_ENUM;
267
269 typedef enum
270 {
272 ACKNOWLEDGE_REQUEST = 0x00,
274 DATA_REQUEST = 0x01,
276 CONFIG_REQUEST = 0x02,
278 ROOM_CONTROL_REQUEST = 0x03,
280 TIME_PROG_REQUEST = 0x04
281 } D210_INFO_REQUEST_ENUM;
282
284 typedef enum
285 {
287 ACKNOWLEDGE_FEEDBACK = 0x00,
289 TEL_REPETITION_FEEDBACK = 0x01,
291 MSG_REPETITION_FEEDBACK = 0x02
292 } D210_FEEDBACK_CLASS_ENUM;
293
295 typedef enum
296 {
298 MSG_TYPE_FEEDBACK = 0x00,
300 MSG_TYPE_INFO_REQUEST = 0x01
301 } D210_GENERAL_MSG_TYPE_ENUM;
302
304 typedef enum
305 {
307 VALIDITY_NO_CHANGE = 0x00,
309 VALIDITY_VALID_VALUE = 0x01
310 } D210_VALIDITY_FLAG_ENUM;
311
313 typedef enum
314 {
316 FAN_SPEED_CENTRAL_CONTROL = 0x00,
318 FAN_SPEED_INDIVIDUAL_CONTROL = 0x01
319 } D210_FAN_SPEED_MODE_ENUM;
320
321
323 typedef enum
324 {
326 WINDOW_NO_CHANGE = 0x00,
328 WINDOW_CLOSED = 0x01,
330 WINDOW_OPEN = 0x02
331 } D210_WINDOW_OPEN_ENUM;
332
334 typedef enum
335 {
337 BATTERY_VLD_NO_CHANGE = 0x00,
339 BATTERY_VLD_GOOD = 0x01,
341 BATTERY_VLD_LOW = 0x02,
343 BATTERY_VLD_CRITICAL = 0x03
344 } D210_BATTERY_STATUS_ENUM;
345
347 typedef enum
348 {
350 SOLAR_POWERED = 0x00,
352 NOT_SOLAR_POWERED = 0x01
353 } D210_SOLAR_POWERED_ENUM;
354
356 typedef enum
357 {
359 PIR_NO_CHANGE = 0x00,
361 PIR_NO_MOVEMENT = 0x01,
363 PIR_MOVEMENT = 0x02,
365 PIR_LOCKED = 0x03
366 } D210_PIR_STATUS_ENUM;
367
369 typedef enum
370 {
372 OCCUPANCY_NO_CHANGE = 0x00,
374 OCCUPANCY_PRESSED_OCCUPIED = 0x01,
376 OCCUPANCY_PRESSED_UNOCCUPIED = 0x02
377 } D210_OCCUPANCY_STATUS_ENUM;
378
380 typedef enum
381 {
383 COOLING_HEATING_NO_CHANGE = 0x00,
385 COOLING_HEATING_ON = 0x01,
387 COOLING_HEATING_OFF = 0x02,
389 COOLING_HEATING_AUTO = 0x03
390 } D210_COOLING_HEATING_STATUS_ENUM;
391
393 typedef enum
394 {
396 ROOM_CONTROL_COMFORT = 0x00,
398 ROOM_CONTROL_ECONOMY = 0x01,
400 ROOM_CONTROL_PRECOMFORT = 0x02,
402 ROOM_CONTROL_BUILDING_PROTECT = 0x03
403 } D210_ROOM_CONTROL_ENUM;
404
406 typedef enum
407 {
409 LOCKED = 0x00,
411 UNLOCKED = 0x01
412 } D210_LOCK_ENUM;
413
415 typedef enum
416 {
418 RADIO_NO_INTERVAL= 0x00,
420 RADIO_3_HOURS_INTERVAL = 0x3D,
422 RADIO_12_HOURS_INTERVAL = 0x3E,
424 RADIO_24_HOURS_INTERVAL = 0x3F
425 } D210_RADIO_COM_INTERVAL_ENUM;
426
428 typedef enum
429 {
431 DISPLAY_NO_CHANGE= 0x00,
433 DISPLAY_DEFAULT = 0x01,
435 DISPLAY_TIME = 0x02,
437 DISPLAY_INTERNAL_TEMP = 0x03,
439 DISPLAY_EXTERNAL_TEMP = 0x04,
441 DISPLAY_TEMP_SETPOINT = 0x05,
443 DISPLAY_OFF = 0x06,
445 DISPLAY_HUMIDITY = 0x07
446 } D210_DISPLAY_CONTENT_ENUM;
447
449 typedef enum
450 {
452 TEMP_SCALE_NO_CHANGE = 0x00,
454 TEMP_SCALE_DEFAULT = 0x01,
456 TEMP_SCALE_CELSIUS = 0x02,
458 TEMP_SCALE_FAHRENHEIT = 0x03
459 } D210_TEMP_SCALE_ENUM;
460
462 typedef enum
463 {
465 DAYLIGHT_SUPPORTED = 0x00,
467 DAYLIGHT_NOT_SUPPORTED = 0x01
468 } D210_DAYLIGHT_SAVE_ENUM;
469
471 typedef enum
472 {
474 TIME_NOTATION_NO_CHANGE = 0x00,
476 TIME_NOTATION_DEFAULT = 0x01,
478 TIME_NOTATION_24_HOURS = 0x02,
480 TIME_NOTATION_12_HOURS = 0x03
481 } D210_TIME_NOTATION_ENUM;
482
484 typedef enum
485 {
487 DATE_TIME_NO_UPDATE = 0x00,
489 DATE_TIME_UPDATE = 0x01
490 } D210_DATE_TIME_UPDATE_ENUM;
491
493 typedef enum
494 {
496 PERIOD_MONDAY_SUNDAY = 0x00,
498 PERIOD_MONDAY_FRIDAY = 0x01,
500 PERIOD_SATURDAY_SUNDAY = 0x02,
502 PERIOD_MONDAY = 0x03,
504 PERIOD_TUESDAY = 0x04,
506 PERIOD_WEDNESDAY = 0x05,
508 PERIOD_THURSDAY = 0x06,
510 PERIOD_FRIDAY = 0x07,
512 PERIOD_SATURDAY = 0x08,
514 PERIOD_SUNDAY = 0x09,
516 PERIOD_MONDAY_WEDNESDAY = 0x0A,
518 PERIOD_TUESDAY_THURSDAY = 0x0B,
520 PERIOD_WEDNESDAY_FRIDAY = 0x0C,
522 PERIOD_THURSDAY_FRIDAY = 0x0D,
524 PERIOD_FRIDAY_SUNDAY = 0x0E,
526 PERIOD_FRIDAY_MONDAY = 0x0F
527 } D210_PERIOD_ENUM;
528
530 typedef enum
531 {
533 TIME_PROG_NO_DELETE = 0x00,
535 TIME_PROG_DELETE = 0x01
536 } D210_TIME_PROG_DELETION_ENUM;
537
538 class eoEEP_D210xx: public eoD2EEProfile
539 {
540 private:
541 uint8_t cmd;
542
543 public:
544 eoReturn SetType(uint8_t type);
545 eoReturn Parse(const eoMessage &msg);
550 eoEEP_D210xx(uint16_t size = 10);
551 virtual ~eoEEP_D210xx();
552 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
553 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
554 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
555 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
556 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
557 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
558 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
559 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
560
561 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
567 virtual eoReturn SetLength (uint8_t type);
568 virtual eoReturn SetCommand(uint8_t cmd);
569 };
572 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D220xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D220xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_D220_H__INCLUDED_)
29 #define eoEEP_D220_H__INCLUDED_
30
33 #include "eoD2EEProfile.h"
107
108 typedef enum
109 {
111 OP_MODE = 0x00,
113 TEMP_LEVEL = 0x01,
115 RELHUM_CONTROL = 0x02,
117 ROOM_SIZE_REFERENCE = 0x03,
119 RELHUM_THRESHOLD = 0x04,
121 SERVICE_INFO = 0x05
122 } VLD_FC_INDEXS;
123
125 typedef enum
126 {
128 OP_MODE_DISABLED = 0x00,
130 OP_MODE_STANDARD_COMPLIANT = 0x01,
132 OP_MODE_NO_CHANGE = 0x0F
133 } VLD_FC_OP_MODE;
134
136 typedef enum
137 {
139 TEMP_LEVEL_LOW = 0x00,
141 TEMP_LEVEL_NORMAL = 0x01,
143 TEMP_LEVEL_HIGH = 0x02,
145 TEMP_LEVEL_NO_CHANGE = 0x03
146 } VLD_FC_TEMP_LEVEL;
147
149 typedef enum
150 {
152 ROOM_SIZE_REF_USED = 0x00,
154 ROOM_SIZE_REF_NOT_USED = 0x01,
156 ROOM_SIZE_REF_DEFAULT = 0x02,
158 ROOM_SIZE_REF_NO_CHANGE = 0x03
159 } VLD_FC_ROOM_SIZE_REF;
160
162 typedef enum
163 {
165 ROOM_SIZE_25 = 0x00,
167 ROOM_SIZE_25_50 = 0x01,
169 ROOM_SIZE_50_75 = 0x02,
171 ROOM_SIZE_75_100 = 0x03,
173 ROOM_SIZE_100_125 = 0x04,
175 ROOM_SIZE_125_150 = 0x05,
177 ROOM_SIZE_150_175 = 0x06,
179 ROOM_SIZE_175_200 = 0x07,
181 ROOM_SIZE_200_225 = 0x08,
183 ROOM_SIZE_225_250 = 0x09,
185 ROOM_SIZE_250_275 = 0x0A,
187 ROOM_SIZE_275_300 = 0x0B,
189 ROOM_SIZE_300_325 = 0x0C,
191 ROOM_SIZE_325_350 = 0x0D,
193 ROOM_SIZE_350 = 0x0E,
195 ROOM_SIZE_NO_CHANGE = 0x0F
196 } VLD_FC_ROOM_SIZE;
197
199 typedef enum
200 {
202 FC_STAGE_AUTO = 0xFD,
204 FC_STAGE_DEFAULT = 0xFE,
206 FC_STAGE_NO_CHANGE = 0xFF
207 } VLD_FC_STAGE;
208
210 typedef enum
211 {
213 FC_RELHUM_DISABLED = 0x00,
215 FC_RELHUM_ENABLED = 0x01,
217 FC_RELHUM_DEFAULT = 0x02
218 } VLD_FC_RELHUM_CONTROL;
219
221 typedef enum
222 {
224 FC_SERVICE_NO_REPORT = 0x00,
226 FC_SERVICE_AIR_FILTER = 0x01,
228 FC_SERVICE_HW_ERROR = 0x02,
230 FC_SERVICE_NOT_SUPPORTED = 0x07
231 } VLD_FC_SERVICE_INFORMATION;
232
233 class eoEEP_D220xx: public eoD2EEProfile
234 {
235 private:
236 uint8_t direction;
237
238 public:
239 eoReturn SetType(uint8_t type);
240 eoReturn Parse(const eoMessage &msg);
245 eoEEP_D220xx(uint16_t size = 4);
246 virtual ~eoEEP_D220xx();
247 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
248 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
249 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
250 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
251 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
252 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
253
254 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
255 };
258 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D230xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D230xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_D230_H__INCLUDED_)
29 #define eoEEP_D230_H__INCLUDED_
30
33 #include "eoD2EEProfile.h"
129
130 typedef enum
131 {
133 MSR_SET_HEAT_CONTROLS = 0x01,
135 MSR_HEAT_CONTROL_STATUS_QUERY = 0x02,
137 MSR_HEAT_CONTROL_STATUS_RESPONSE = 0x03,
139 MSR_SET_METER_CONFIGURATION = 0x06,
141 MSR_METER_STATUS_QUERY = 0x07,
143 MSR_METER_READING_REPORT = 0x08
144 }MSR_COMMANDS;
145
147 typedef enum
148 {
150 MSR_CHANNEL_SUPPLY_TEMP = 0x00,
152 MSR_CHANNEL_RETURN_TEMP = 0x01,
154 MSR_CHANNEL_REPORT_TIME = 0x02,
156 MSR_CHANNEL_METER_TYPE = 0x03,
158 MSR_CHANNEL_METER_1 = 0x04,
160 MSR_CHANNEL_METER_2 = 0x05,
162 MSR_CHANNEL_NUM_OF_PULSES = 0x06,
164 MSR_CHANNEL_PRESET_VALUE = 0x07,
166 MSR_CHANNEL_PROTOCOL = 0x08,
168 MSR_CHANNEL_PULSES_FACTOR = 0x09,
170 MSR_CHANNEL_PRIMARY_ADDR = 0x0A,
172 MSR_CHANNEL_ERROR = 0x0B,
174 MSR_CHANNEL_ERROR_HCH31 = 0x0C,
176 MSR_CHANNEL_METER_ERROR = 0x0D,
178 MSR_CHANNEL_METER_CHANNEL = 0x0E,
180 MSR_CHANNEL_VALUE_SELECTION = 0x0F
181 } MSR_CHANNELS;
182
184 typedef enum
185 {
187 MSR_LOCAL_DEFAULT = 0x00,
189 MSR_1_SECOND = 0x01,
191 MSR_2_SECOND = 0x02,
193 MSR_5_SECOND = 0x03,
195 MSR_10_SECOND = 0x04,
197 MSR_20_SECOND = 0x05,
199 MSR_50_SECOND = 0x06,
201 MSR_100_SECOND = 0x07,
203 MSR_200_SECOND = 0x08,
205 MSR_500_SECOND = 0x09,
207 MSR_1000_SECOND = 0x0A
208 } MSR_TIME_VALUES; //MSR because of the submitter
209
211 typedef enum
212 {
214 MSR_NO_REPORT = 0x00,
216 MSR_1_SECOND_REPORT = 0x01,
218 MSR_3_SECOND_REPORT = 0x02,
220 MSR_10_SECOND_REPORT = 0x03,
222 MSR_30_SECOND_REPORT = 0x04,
224 MSR_100_SECOND_REPORT = 0x05,
226 MSR_300_SECOND_REPORT = 0x06,
228 MSR_1000_SECOND_REPORT = 0x07
229 } MSR_REPORT_TIME_VALUES; //MSR because of the submitter
230
232 typedef enum
233 {
235 MSR_VALVE_NORM_CLOSED = 0x00,
237 MSR_VALVE_NORM_OPEN = 0x01
238 } MSR_CONNECTED_VALVE;
239
241 typedef enum
242 {
244 MSR_NO_ACTION = 0x00,
246 MSR_RUN_INIT_SEQU = 0x01
247 } MSR_INIT_SEQU;
248
250 typedef enum
251 {
253 MSR_ERROR_NO_FAULT = 0x00,
255 MSR_ERROR_GENERAL = 0x01,
257 MSR_ERROR_INIT_SEQU_RUNNING = 0x02,
259 MSR_ERROR_CHANNEL_NOT_AVAILABLE = 0x03,
261 MSR_ERROR_TEMP_SENSOR = 0x04,
263 MSR_ERROR_VALVE = 0x05,
265 MSR_ERROR_TEMP_SENSOR_VALVE = 0x06
266 } MSR_ERROR_CODE;
267
269 typedef enum
270 {
272 MSR_ERROR_CH31_NO_FAULT = 0x00,
274 MSR_ERROR_CH31_GENERAL = 0x01,
276 MSR_ERROR_CH31_SUPPLY_TEMP = 0x02,
278 MSR_ERROR_CH31_RETURN_TEMP = 0x03,
280 MSR_ERROR_CH31_SUPPLY_RETURN_TEMP = 0x04
281 } MSR_ERROR_CODE_CH31;
282
284 typedef enum
285 {
287 MSR_METER_ERROR_NO_FAULT = 0x00,
289 MSR_METER_ERROR_GENERAL = 0x01,
291 MSR_METER_BUS_NO_CONFIG = 0x02,
293 MSR_METER_BUS_NO_CONNECTION = 0x03,
295 MSR_METER_BUS_SHORTCUT = 0x04,
297 MSR_METER_TIMEOUT = 0x05,
299 MSR_METER_UNKNOWN_CONFIG = 0x06,
301 MSR_METER_BUS_INIT_RUNNING = 0x07
302 } MSR_METER_ERROR_CODE;
303
305 typedef enum
306 {
308 MSR_BUS_TYPE_MBUS = 0x01,
310 MSR_BUS_TYPE_S0 = 0x02,
312 MSR_BUS_TYPE_D0 = 0x03
313 } MSR_METER_BUS_TYPE;
314
316 typedef enum
317 {
319 MSR_UNIT_NO_READING = 0x00,
321 MSR_UNIT_CURRENT_W_ACCUM_KWH = 0x01,
323 MSR_UNIT_CURRENT_W_ACCUM_WH = 0x02,
325 MSR_UNIT_ACCUM_KWH = 0x03,
327 MSR_UNIT_CURRENT_M3_ACCUM_M3 = 0x04,
329 MSR_UNIT_CURRENT_DM3_ACCUM_DM3 = 0x05,
331 MSR_UNIT_ACCUM_M3 = 0x06,
333 MSR_UNIT_DIGIT_COUNTER = 0x07
334 } MSR_METER_UNITS;
335
337 typedef enum
338 {
340 MSR_VALUE_W = 0x00,
342 MSR_VALUE_WH = 0x01,
344 MSR_VALUE_KWH = 0x02,
346 MSR_VALUE_M3H = 0x03,
348 MSR_VALUE_DM3H = 0x04,
350 MSR_VALUE_M3 = 0x05,
352 MSR_VALUE_DM3 = 0x06,
354 MSR_VALUE_DIGIT_COUNTER = 0x07
355 } MSR_VALUE_UNITS;
356
358 typedef enum
359 {
361 MSR_FACTOR_PULSES_1 = 0x00,
363 MSR_FACTOR_PULSES_01 = 0x01,
365 MSR_FACTOR_PULSES_001 = 0x02,
367 MSR_FACTOR_PULSES_0001 = 0x03
368 } MSR_FACTOR_PULSES;
369
371 typedef enum
372 {
374 MSR_PROTOCOL_AUTO_DETECT = 0x00,
376 MSR_PROTOCOL_SML = 0x01,
378 MSR_PROTOCOL_DLMS = 0x02
379 } MSR_PROTOCOL;
380
382 typedef enum
383 {
385 MSR_VALUE_1_CURRENT = 0x00,
387 MSR_VALUE_1_ACCU = 0x01,
389 MSR_VALUE_2_CURRENT = 0x02,
391 MSR_VALUE_2_ACCU = 0x03
392 } MSR_VALUE_SELECTION;
393
394 class eoEEP_D230xx: public eoD2EEProfile
395 {
396 private:
397 uint8_t cmd;
398
399 public:
400 eoReturn SetType(uint8_t type);
401 eoReturn Parse(const eoMessage &msg);
406 eoEEP_D230xx(uint16_t size = 10);
407 virtual ~eoEEP_D230xx();
408 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
409 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
410 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
411 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
412 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
413 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
414 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
415 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
416
417 virtual eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t subFlag);
418 virtual eoReturn SetCommand(uint8_t cmd);
419 };
422 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D231xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D231xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_D231_H__INCLUDED_)
29 #define eoEEP_D231_H__INCLUDED_
30
33 #include "eoD2EEProfile.h"
99 class eoEEP_D231xx: public eoD2EEProfile
100 {
101 private:
102 uint8_t cmd;
103
104 public:
105 eoReturn SetType(uint8_t type);
106 eoReturn Parse(const eoMessage &msg);
111 eoEEP_D231xx(uint16_t size = 10);
112 virtual ~eoEEP_D231xx();
113 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
114 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
115 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
116 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
117 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
118 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
119 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
120 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
121
122 virtual eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t subFlag);
123 virtual eoReturn SetCommand(uint8_t cmd);
124 };
127 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D232xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D232xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_D232_H__INCLUDED_)
31 #define eoEEP_D232_H__INCLUDED_
32
35 #include "eoD2EEProfile.h"
69
70 typedef enum
71 {
73 CURR_CHANNEL_1 = 0x00,
75 CURR_CHANNEL_2 = 0x01,
77 CURR_CHANNEL_3 = 0x02
78 } D323_INDEX_ENUMS;
79
80 class eoEEP_D232xx: public eoD2EEProfile
81 {
82
83 public:
84 eoReturn SetType(uint8_t type);
85
86 eoEEP_D232xx();
87 virtual ~eoEEP_D232xx();
88 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
89 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
90 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
91 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
92 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
93 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
94
95 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
96 };
99 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D240xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D240xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_D240_H__INCLUDED_)
29 #define eoEEP_D240_H__INCLUDED_
30
33 #include "eoD2EEProfile.h"
71
72 typedef enum
73 {
75 DRIVING_LED = 0x00,
77 RESPONSE_MODE = 0x01,
79 DAYLIGH_HARVEST = 0x02,
81 STATUS_REASON = 0x03,
83 DIM_LEVEL_MONO = 0x04,
85 DIM_LEVEL_RED = 0x05,
87 DIM_LEVEL_GREEN = 0x06,
89 DIM_LEVEL_BLUE = 0x07
90 } D240_INDEX_ENUM;
91
93 typedef enum
94 {
96 DRIVING_DISABLED = 0x00,
98 DRIVING_ENABLED = 0x01
99 } D240_DRIVING_LED_ENUM;
100
102 typedef enum
103 {
105 D240_FALSE = 0x00,
107 D240_TRUE = 0x01
108 } D240_TRUE_FALSE_ENUM;
109
111 typedef enum
112 {
114 D240_NOT_OCCUPIED = 0x00,
116 D240_OCCUPIED = 0x01,
118 D240_UNKNOWN = 0x02
119 } D240_OCCUPANCY_ENUM;
120
122 typedef enum
123 {
125 OTHER_REASON = 0x00,
127 HEARTBEAT = 0x01
128 } D240_STATUS_REASON_ENUM;
129
130 class eoEEP_D240xx: public eoD2EEProfile
131 {
132 private:
133 uint8_t cmd;
134
135 public:
136 eoReturn SetType(uint8_t type);
137 eoReturn Parse(const eoMessage &msg);
142 eoEEP_D240xx(uint16_t size = 4);
143 virtual ~eoEEP_D240xx();
144 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
145 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
146 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
147 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
148 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
149 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
150 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
151 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
152
153 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
159 virtual eoReturn SetLength (uint8_t type);
160 virtual eoReturn SetCommand(uint8_t cmd);
161 };
164 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D250xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D250xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(eoEEP_D250_H__INCLUDED_)
29 #define eoEEP_D250_H__INCLUDED_
30
33 #include "eoD2EEProfile.h"
104
105 typedef enum
106 {
108 VENTILATION_REQUEST = 0x00,
110 VENTILATION_CONTROL = 0x01,
112 VENTILATION_BASIC_STATUS = 0x02,
114 VENTILATION_EXTENDED_STATUS = 0x03
115 } D250xx_COMMANDS;
116
118 typedef enum
119 {
121 REQUESTED_MSG_TYPE = 0x00,
123 DIRECT_OP_MODE = 0x01,
125 OP_MODE_CTRL = 0x02,
127 HEAT_EXCHANGE_CTRL = 0x03,
129 TIMER_OP_CTRL = 0x04,
131 SAFTEY_MODE = 0x05,
133 SUPPLY_AIR_POS = 0x06,
135 EXHAUST_AIR_POS = 0x07,
137 DEFROST_MODE = 0x08,
139 COOLING_PROTECTION = 0x09,
141 OUTDOOR_HEATER_STATUS = 0x0A,
143 SUPPLY_HEATER_STATUS = 0x0B,
145 DRAIN_HEATER_STATUS = 0x0C,
147 TIMER_OP_CTRL_STATUS = 0x0D,
149 FILTER_MAINTENANCE = 0x0E,
151 WEEKLY_PROGRAM = 0x0F,
153 ROOM_TEMP_CTRL = 0x10,
155 AIR_QUALITY_1 = 0x11,
157 AIR_QUALITY_2 = 0x12,
159 MASTER_SLAVE_CONFIG = 0x13,
161 OUTDOOR_TEMP = 0x14,
163 SUPPLY_TEMP = 0x15,
165 INDOOR_TEMP = 0x16,
167 EXHAUST_TEMP = 0x17,
169 SUPPLY_FAN_RATE = 0x18,
171 EXHAUST_FAN_RATE = 0x19,
173 SUPPLY_FAN_SPEED = 0x20,
175 EXHAUST_FAN_SPEED = 0x21,
177 SW_VERSION = 0x22,
179 DIGITAL_INPUT_STATUS = 0x23,
181 DIGITAL_OUTPUT_STATUS = 0x24,
183 INFO_MSG_STATUS = 0x25,
185 FAULT_STATUS = 0x26,
187 CO2_TRHESHOLD = 0x27,
189 AIR_QUALITY_TRHESHOLD = 0x28,
191 ROOM_TEMP = 0x29
192 } D250xx_INDEX;
193
195 typedef enum
196 {
198 VENTILATION_BASIC = 0x00,
200 VENTILATION_EXTENDED = 0x01
201 } D250_REQUESTED_MSG_TYPE;
202
204 typedef enum
205 {
207 DIRECT_MODE_OFF = 0x00,
209 DIRECT_MODE_LEVEL_1 = 0x01,
211 DIRECT_MODE_LEVEL_2 = 0x02,
213 DIRECT_MODE_LEVEL_3 = 0x03,
215 DIRECT_MODE_LEVEL_4 = 0x04,
217 DIRECT_MODE_AUTO = 0x0B,
219 DIRECT_MODE_AUTO_OD = 0x0C,
221 DIRECT_MODE_SUPPLY_ONLY = 0x0D,
223 DIRECT_MODE_SEXHAUST_ONLY = 0x0E,
225 DIRECT_MODE_NO_ACTION = 0x0F
226 } D250_DIRECT_OP_MODE;
227
229 typedef enum
230 {
232 OP_NO_ACTION = 0x00,
234 OP_NEXT = 0x01,
236 OP_PREVIOUS = 0x02
237 } D250_OP_MODE;
238
240 typedef enum
241 {
243 AIRFLAP_BYPASS_CLOSE = 0x00,
245 AIRFLAP_BYPASS_OPEN = 0x01
246 } D250_AIRFLAP_BYPASS;
247
248 class eoEEP_D250xx: public eoD2EEProfile
249 {
250 private:
251 uint8_t cmd;
252
253 public:
254 eoReturn SetType(uint8_t type);
255 eoReturn Parse(const eoMessage &msg);
260 eoEEP_D250xx(uint16_t size = 10);
261 virtual ~eoEEP_D250xx();
262 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
263 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
264 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t index);
265 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t index);
266 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
267 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
268 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t index);
269 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t index);
270
271 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t index);
277 virtual eoReturn SetLength (uint8_t type);
278 virtual eoReturn SetCommand(uint8_t cmd);
279 };
282 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_D500xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_D500xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_D500_H__INCLUDED_)
31 #define eoEEP_D500_H__INCLUDED_
32
35 #include "eoA5EEProfile.h"
46 class eoEEP_D500xx: public eoA5EEProfile
47 {
48
49 public:
50 eoReturn SetType(uint8_t type);
51 eoReturn Parse(const eoMessage &msg);
52
53 eoEEP_D500xx();
54 virtual ~eoEEP_D500xx();
55 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
56 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
57 };
60 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_F602xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_F602xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_F602_H__INCLUDED_)
31 #define eoEEP_F602_H__INCLUDED_
32
35 #include "eoF6EEProfile.h"
59 class eoEEP_F602xx: public eoF6EEProfile
60 {
61 private:
62 eoReturn RockerHelper();
63 uint8_t rockerA;
64 uint8_t rockerB;
65 public:
66 eoReturn SetType(uint8_t type);
67 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
68 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
69
70 eoEEP_F602xx();
71 virtual ~eoEEP_F602xx();
72 virtual eoChannelInfo* GetChannel(CHANNEL_TYPE type);
73 void ClearValues();
74 };
77 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_F603xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_F603xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_F603_H__INCLUDED_)
31 #define eoEEP_F603_H__INCLUDED_
32
35 #include "eoF6EEProfile.h"
51 class eoEEP_F603xx: public eoF6EEProfile
52 {
53 private:
54 eoReturn RockerHelper();
55 uint8_t rockerA;
56 uint8_t rockerB;
57 uint8_t rockerC;
58 uint8_t rockerD;
59
60 public:
61 eoReturn SetType(uint8_t type);
62 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
63 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
64 void ClearValues();
65 eoEEP_F603xx();
66 virtual ~eoEEP_F603xx();
67 virtual eoChannelInfo* GetChannel(CHANNEL_TYPE type);
68 };
71 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_F604xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_F604xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_F604_H__INCLUDED_)
31 #define eoEEP_F604_H__INCLUDED_
32
35 #include "eoF6EEProfile.h"
46 class eoEEP_F604xx: public eoF6EEProfile
47 {
48
49 public:
50 eoReturn SetType(uint8_t type);
51 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
52 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
53 //eoEEP_A502xx();
54 eoEEP_F604xx();
55 virtual ~eoEEP_F604xx();
56 virtual eoChannelInfo* GetChannel(CHANNEL_TYPE type);
57 };
60 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_F605xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_F605xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_F605_H__INCLUDED_)
31 #define eoEEP_F605_H__INCLUDED_
32
35 #include "eoF6EEProfile.h"
47 class eoEEP_F605xx: public eoF6EEProfile
48 {
49
50 public:
51 eoReturn SetType(uint8_t type);
52 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
53 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
54 //eoEEP_A502xx();
55 eoEEP_F605xx();
56 virtual ~eoEEP_F605xx();
57 virtual eoChannelInfo* GetChannel(CHANNEL_TYPE type);
58 };
61 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoEEP_F610xx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoEEP_F610xx.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(eoEEP_F610_H__INCLUDED_)
31 #define eoEEP_F610_H__INCLUDED_
32
35 #include "eoF6EEProfile.h"
47 class eoEEP_F610xx: public eoF6EEProfile
48 {
49
50 public:
51 eoReturn SetType(uint8_t type);
52 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
53 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
54
55 eoEEP_F610xx();
56 virtual ~eoEEP_F610xx();
57 virtual eoChannelInfo* GetChannel(CHANNEL_TYPE type);
58 };
61 #endif // !defined(EA_259BDE62_FE41_490e_8B3E_427A72922C4A__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoEEProfile.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoEEProfile.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
34 #ifndef EO_EEPROFILE_H_
35 #define EO_EEPROFILE_H_
36
37 #include "eoProfile.h"
38
50 class eoEEProfile: public eoProfile
51 {
52 public:
57 eoEEProfile(uint16_t size = 4);
58 virtual ~eoEEProfile();
59
60 //virtual bool operator==(const eoProfile &othProfile) const;
61 //virtual bool operator!=(const eoProfile &othProfile) const;
79 virtual eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t subType);
80 virtual eoChannelInfo* GetChannel(CHANNEL_TYPE type);
81 virtual eoChannelInfo* GetChannel(uint8_t channelNumber);
82 virtual eoReturn GetSubTypeChannel(CHANNEL_TYPE type, std::vector<eoEEPChannelInfo*>& vector);
83
84 //virtual eoReturn SetType(uint8_t type);
85
86 virtual uint8_t GetChannelCount() const;
87
88 protected:
90 eoEEPChannelInfo* channel;
92 uint8_t channelCount;
93
94 };
99 #endif /* EOEEPROFILE_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoF6EEProfile.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoF6EEProfile.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
32 #include "eoEEProfile.h"
33 #ifndef EOF6EEPROFILE_H_
34 #define EOF6EEPROFILE_H_
35
36 typedef enum
37 {
39 STATE_I = 0,
41 STATE_O = 1,
43 STATE_NP = 2,
45 STATE_IO = 3
46 } ENUM_ROCKER_STATE;
47
49 typedef enum
50 {
52 WINDOW_DOWN = 0,
54 WINDOW_MIDDLE = 1,
56 WINDOW_UP = 2
57 } ENUM_WINDOW_STATE;
58
60 typedef enum
61 {
63 ENERGY_RELEASED = 0,
65 ENERGY_PRESSED = 1
66
67 } ENUM_ENERGY_STATE;
68
70 typedef enum
71 {
73 MULTIPRESS_NOT = 0,
75 MULTIPRESS_YES = 1
76 } ENUM_MULTIPRESS_STATE;
77
79 typedef enum
80 {
82 NO_WATER = 0x00,
84 WATER_DETECTED = 0x01
85 } WAS_VALUES;
93 class eoF6EEProfile: public eoEEProfile
94 {
95 public:
96 eoF6EEProfile();
97
98 virtual eoReturn Create(eoMessage &msg);
99 virtual eoReturn Parse(const eoMessage &msg);
100 virtual ~eoF6EEProfile();
101
102 };
105 #endif /* EOEEPPROFILE_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoFilterFactory.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoFilterFactory.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EOFILTERFACTORY_H_
34 #define EOFILTERFACTORY_H_
35
36 #include "eoIFilter.h"
37
42 class eoFilterFactory
43 {
44 public:
45 eoFilterFactory();
46 virtual ~eoFilterFactory();
51 static eoIFilter * CreateFilter(uint8_t type);
52 };
53
54 #endif /* EOFILTERFACTORY_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoGPChannelInfo.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoGPChannelInfo.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
35 #ifndef EOGPCHANNELINFO_H_
36 #define EOGPCHANNELINFO_H_
37 #include "eoChannelInfo.h"
38 #include "eoApiDef.h"
39 #include "eoISerialize.h"
44 typedef enum
45 {
47 GP_TEACHIN_INFO = 0,
48
49 GP_DATA,
50
51 GP_FLAG,
52
53 GP_ENUMERATION
54 } GP_CHANNELTYPE;
59 typedef enum
60 {
61 GP_RES_RES = 0,
62 GP_RES_1BIT = 1,
63 GP_RES_2BIT = 2,
64 GP_RES_3BIT = 3,
65 GP_RES_4BIT = 4,
66 GP_RES_5BIT = 5,
67 GP_RES_6BIT = 6,
68 GP_RES_8BIT = 8,
69 GP_RES_10BIT = 10,
70 GP_RES_12BIT = 12,
71 GP_RES_16BIT = 16,
72 GP_RES_20BIT = 20,
73 GP_RES_24BIT = 24,
74 GP_RES_32BIT = 32
75 } GP_RESOLUTION;
80 typedef enum
81 {
82 GP_SCAL_RES = 0,
83 GP_SCAL_1,
84 GP_SCAL_10,
85 GP_SCAL_100,
86 GP_SCAL_1000,
87 GP_SCAL_10000,
88 GP_SCAL_100000,
89 GP_SCAL_1000000,
90 GP_SCAL_10000000,
91 GP_SCAL_0_1,
92 GP_SCAL_0_01,
93 GP_SCAL_0_001,
94 GP_SCAL_0_000001,
95 GP_SCAL_0_000000001
96 } GP_SCALING;
97
108 class eoGPChannelInfo: public eoChannelInfo, public eoISerialize
109 {
110
112 //uint16_t u2ChannelType;
114 //uint16_t u8SignalType:8; == signal type
116 //uint16_t u2ValueType:2; // = valueFormat
117 private:
118 void CalculateMin();
119 void CalculateMax();
121 GP_RESOLUTION res; //:4;
122
124 GP_SCALING scaleMin; //:4;
126 GP_SCALING scaleMax; //:4;
127
128 int8_t engMax;
129 int8_t engMin;
130 uint8_t rejected;
131 public:
132
136 eoGPChannelInfo();
146 eoGPChannelInfo(CHANNEL_TYPE type, GP_RESOLUTION resolution, int8_t engMaximum, int8_t engMinimum, GP_SCALING scaleMaximum, GP_SCALING scaleMinimum);
148 uint16_t bitoffs;
149
151 GP_CHANNELTYPE GetGPChannelType() const;
152
154 GP_RESOLUTION GetResolution() const;
155 //eoReturn SetResolution(GP_RESOLUTION resolution);
156
158 int8_t GetEngMax() const;
163 eoReturn Scale(int8_t engMaximum);
164
166 int8_t GetEngMin() const;
167 //eoReturn SetEngMin(int8_t engMinimum);
168
170 GP_SCALING GetScaleMax() const;
171 //eoReturn SetScaleMax(GP_SCALING scaleMaximum);
172
174 GP_SCALING GetScaleMin() const;
175
177 void SetRejected(uint8_t rejected);
178
180 uint8_t GetRejected();
181
186 static float ScaleToFloat(GP_SCALING scale);
191 uint8_t Serialize(eoArchive &a);
192 };
193
194 #endif /* EOGPCHANNELINFO_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoGateway.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoGateway.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #if !defined(_EO_GATEWAY_H)
34 #define _EO_GATEWAY_H
35
36 #include "eoHalTypes.h"
37 #include "eoApiDef.h"
38 #include "eoISerialize.h"
39 #include "eoMessage.h"
40 #include "eoTelegram.h"
41 #include "eoDevice.h"
42 #include "eoIFilter.h"
43 #include "eoPacketStream.h"
44 #include "eoDeviceManager.h"
45 #include "eoMessageHandler.h"
46 #include "eoSecurity.h"
47 #include "eoProfileFactory.h"
48 #include "eoTeachInModule.h"
49 #include "eoReManMessage.h"
50 #include "eoSerialCommand.h"
51 #include "eoIWatcher.h"
52 #include <queue>
53
60 typedef enum
61 {
63 RECV_PACKET = (1 << 0),
64
65 RECV_TELEGRAM = (1 << 1),
66
67 RECV_MESSAGE = (1 << 2),
68
69 RECV_TEACHIN = (1 << 3),
70
71 RECV_PROFILE = (1 << 4),
72
73 RECV_TELEGRAM_SEC = (1 << 5),
74
75 RECV_ERROR = (1 << 6),
76
77 RECV_DEVICE_ADDED = (1 << 7),
78
79 RECV_SECTEACHIN = (1 << 8),
80
81 RECV_REMAN = (1 << 9)
82 } RECEIVE_FLAGS;
129 class eoGateway: public eoISerialize
130 {
131 public:
133 inline void LearnModeOn()
134 {
135 LearnMode = true;
136 }
138 inline void LearnModeOff()
139 {
140 LearnMode = false;
141 }
143 eoPacketStream *stream;
145 eoTeachInModule* TeachInModule;
147 eoDeviceManager *deviceManager;
150 eoIFilter *filter;
153 eoIFilter *learnFilter;
155 eoIWatcher *secWatcher;
157 uint32_t GetSecWatchResult() const{ return secWatchResult; }
159 bool LearnMode;
161 uint8_t errorCode;
163 eoDevice *device;
165 eoPacket packet;
167 eoPacket responsePacket;
169 eoTelegram telegram;
171 eoMessage message;
173 eoReManMessage reManMessage;
175 eoSerialCommand commands;
177 bool advancedMode;
181 eoGateway();
186 eoGateway(eoDeviceManager *devManager);
191 eoGateway(eoPacketStream *str);
197 eoGateway(eoPacketStream *str, eoDeviceManager *devManager);
198
206 eoGateway(eoPacketStream *str, eoDeviceManager *devManager, eoIFilter * normFilter, eoIFilter * lrnFilter);
207
208 virtual ~eoGateway();
233 uint16_t Receive();
234
242 eoReturn Send(const eoPacket &p);
248 eoReturn Send(const eoMessage &msg);
254 virtual eoReturn Send(const eoReManMessage &reMsg);
260 eoReturn Open(const char *port);
261
263 eoSecurity security;
267 void Close();
268 uint8_t Serialize(eoArchive &arch);
269
270 private:
271 void defaultConstructor();
272
273 eoMessageHandler msgHandler;
274
275 uint16_t flags;
276 uint32_t secWatchResult;
277 void LearnIN();
278
279 std::deque<eoPacket*> packet_queue;
280
281 eoReturn learnHandler(eoTelegram &recvTelegram); //Handles received telegram in learnMode
282 eoReturn secHandler(eoTelegram &recvTelegram); //Handles secure telegram
283 eoReturn normalHandler(eoTelegram &recvTelegram); //Handles received telegram in normalMode
284 };
287 #endif // !defined(_EO_GATEWAY_H)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoGenericProfile.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoGenericProfile.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
29
30 #if !defined(EO_GENERIC_PROFILE_H)
31 #define EO_GENERIC_PROFILE_H
32 #include "eoGPChannelInfo.h"
33 #include "eoProfile.h"
34 #include <vector>
36 #define GP_MANUFACTURER_LEN 11
37
38 #define GP_PURPOSE_LEN 2
39
40 #define GP_DATA_DIRECTION_LEN 1
41
43 #define GP_MANUFACTURER_OFF 0
44
45 #define GP_PURPOSE_OFF 12
46
47 #define GP_DATA_DIRECTION_OFF 11
48
52 typedef enum
53 {
54 GP_TEACH_IN = 0, GP_TEACH_OUT, GP_TEACH_IN_OUT, RESP_NA
55 } GP_HEADER_PURPOSE;
60 typedef enum
61 {
62 UNIDIRECTIONAL = 0, BIDIRECTIONAL
63 } GP_DATA_DIRECTION;
73 class eoGenericProfile: public eoProfile
74 {
75 public:
76 eoGenericProfile();
81 eoGenericProfile(uint16_t msgLength);
82
84 GP_HEADER_PURPOSE purpose;
86 GP_DATA_DIRECTION dataDirection;
87
88 virtual ~eoGenericProfile();
93 void AllowTeachIN();
97 bool operator==(const eoGenericProfile &othProfile) const;
101 bool operator!=(const eoGenericProfile &othProfile) const;
112 eoReturn CreateTeachIN(eoMessage &msg);
121 eoReturn Create(eoMessage &m,std::vector<int> channelNumbers);
127 eoReturn ParseSelData(const eoMessage &msg);
133 eoReturn ParseTeachIN(const eoMessage &msg);
144 eoReturn Parse(const eoMessage &msg);
145
146 eoReturn GetValue(CHANNEL_TYPE type, float &value);
147
148 eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag);
149
150 eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
151
152 eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t subFlag);
153
154 eoReturn SetValue(CHANNEL_TYPE type, float value);
155
156 eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
157
158 eoReturn SetType(uint8_t type);
159 //eoReturn AddChannel(eoGPChannelInfo myChannel);
171 eoReturn AddChannel(CHANNEL_TYPE type, GP_RESOLUTION resolution, int8_t engMaximum, int8_t engMinimum, GP_SCALING scaleMaximum, GP_SCALING scaleMinimum, VALUE_TYPE valueType);
183 eoReturn AddChannelOut(CHANNEL_TYPE type, GP_RESOLUTION resolution, int8_t engMaximum, int8_t engMinimum, GP_SCALING scaleMaximum, GP_SCALING scaleMinimum, VALUE_TYPE valueType);
190 eoReturn AddChannel(CHANNEL_TYPE type, VALUE_TYPE valueType);
197 eoReturn AddChannelOut(CHANNEL_TYPE type, VALUE_TYPE valueType);
205 eoReturn AddChannel(CHANNEL_TYPE type, GP_RESOLUTION resolution, VALUE_TYPE valueType);
213 eoReturn AddChannelOut(CHANNEL_TYPE type, GP_RESOLUTION resolution, VALUE_TYPE valueType);
219 eoChannelInfo* GetChannel(CHANNEL_TYPE type);
225 eoChannelInfo* GetChannel(uint8_t channelNumber);
231 eoChannelInfo* GetChannelOut(CHANNEL_TYPE type);
237 eoChannelInfo* GetChannelOut(uint8_t channelNumber);
248 eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t subType);
256 eoChannelInfo* GetChannelOut(CHANNEL_TYPE type, uint8_t subType);
261 uint8_t GetChannelCount() const;
266 uint8_t GetChannelCountOut() const;
270 void ClearChannels();
274 void ClearChannelsOut();
275 /*
276 * Clears Channel Information and internal buffer
277 */
278 void ClearValues();
279
280 uint8_t Serialize(eoArchive &a);
285 uint32_t GetProductId();
290 void SetProductId(const uint32_t prodId);
291
292 virtual eoReturn Create(eoMessage &msg);
293
294 private:
295
296 eoReturn CreateChannels(const eoMessage &msg);
297 std::vector<eoGPChannelInfo> gpChannels;
298 std::vector<eoGPChannelInfo> gpChannelsOut;
299 uint16_t curBitOffset;
300 uint16_t curBitOffsetOut;
301
302 bool parseTeachIn;
303 uint32_t productId;
304 };
305 #endif // !defined(EA_4EAE7E47_D018_4877_903B_B66D2DDE6E02__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoGpChainer.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoGpChainer.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
34 #ifndef EOGPCHAINER_H_
35 #define EOGPCHAINER_H_
36
37 #include "eoChainedMessage.h"
38 class eoGateway;
39
40 #include <map>
42 typedef std::map<uint32_t, eoChainedMessage*> id_msg_map;
43
48 class eoGpChainer
49 {
50
51 public:
52 eoGpChainer();
53 virtual ~eoGpChainer();
57 void CleanUpList();
58
65 eoReturn ParseChainedMessage(eoTelegram &tel, eoMessage &msg);
66
73 eoReturn SendChainedMessage(const eoMessage &msg, eoGateway &gateway);
74
75 private:
76
87 eoChainedMessage* GetChainedMessage(const eoTelegram &tel,eoReturn &retValue);
99 eoReturn AddParsedChainedMessage(eoTelegram const &tel, eoMessage &msg,eoChainedMessage* chm);
100 id_msg_map list;
101 uint8_t seq;
102 };
103 #endif
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoHalTypes.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoHalTypes.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef HAL_TYPES_H
34 #define HAL_TYPES_H
35
36 #include <stdint.h>
37
38 #ifdef __cplusplus
39 extern "C"
40 {
41 #endif
42
43 #ifndef NULL
44
45 #define NULL 0
46 #endif
47 /***********************************************************************************
48 * TYPEDEFS
49 */
50
51
52 typedef float float32;
53
54 #ifdef __cplusplus
55 }
56 #endif
57 #endif
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoHeader.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoHeader.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EOHEADER_H_
34 #define EOHEADER_H_
35
36 #include "eoISerialize.h"
37
42 class eoHeader: public eoISerialize
43 {
44 public:
45 eoHeader();
52 eoHeader(uint8_t majorVersion, uint8_t minorVersion, const char* handlerName);
54 uint8_t major;
56 uint8_t minor;
58 char name[32];
59 virtual ~eoHeader();
60 virtual uint8_t Serialize(eoArchive &arch);
61 };
62
63 #endif /* HEADER_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoIDFilter.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoIDFilter.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EO_ID_FILTER_H
34 #define EO_ID_FILTER_H
35
36 #include "eoIFilter.h"
37
38 #include <set>
40 typedef std::set<uint32_t> id_set;
41
52 class eoIDFilter: public eoIFilter
53 {
54 private:
55 std::set<uint32_t> idset;
56 public:
57 eoIDFilter();
58 virtual ~eoIDFilter();
59
65 bool Filter(eoMessage &msg);
66
72 bool Filter(eoTelegram &tel);
73
74 public:
75
76 virtual uint8_t Serialize(eoArchive &arch);
77
82 void Add(uint32_t id);
83
88 void Remove(uint32_t id);
89
93 void RemoveAll();
94 };
99 #endif // !defined(EO_ID_FILTER_H)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoIFilter.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoIFilter.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EOI_FILTER_H
34 #define EOI_FILTER_H
35
36 #include "eoHalTypes.h"
37 #include "eoMessage.h"
38 #include "eoTelegram.h"
39 #include "eoArchive.h"
40
45 typedef enum
46 {
47 eoIDFILTER = 1,
48 eoDBMFILTER
49 } SUPPORTED_FILTERS;
50
61 class eoIFilter: public eoISerialize
62 {
63
64 public:
66 uint8_t type;
67 eoIFilter();
68
69 virtual ~eoIFilter();
70
76 virtual bool Filter(eoMessage &msg);
77
83 virtual bool Filter(eoTelegram &tel);
84
90 virtual uint8_t Serialize(eoArchive &arch);
91
95 virtual void RemoveAll();
96
97 };
101 #endif // !defined(EOI_FILTER_H)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoISerialize.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoISerialize.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #include "eoHalTypes.h"
34 #include "eoApiDef.h"
35
36 #ifndef EOISERIALIZE_H_
37 #define EOISERIALIZE_H_
38
39 class eoArchive;
40
48 class eoISerialize
49 {
50
51 public:
52
53 eoISerialize();
54 virtual ~eoISerialize();
60 virtual uint8_t Serialize(eoArchive &arch);
61 };
65 #endif /* ISERIALIZE_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoISimpleBidirectionalProfile.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoISimpleBidirectionalProfile.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef __EOISIMPLEBIDIRECTIONALPROFILE_INCLUDED_
34 #define __EOISIMPLEBIDIRECTIONALPROFILE_INCLUDED_
35 typedef enum
36 {
37 eoController,
38 eoActuator
39 } SIMPLE_DIRECTION;
50 class eoISimpleBidirectionalProfile
51 {
52 public:
53 eoISimpleBidirectionalProfile() {direction=eoController;};
54
55 virtual ~eoISimpleBidirectionalProfile() {};
60 virtual eoReturn SetDirection(SIMPLE_DIRECTION direction)=0;
61
68 virtual eoChannelInfo* GetOutChannel(CHANNEL_TYPE type, uint8_t subType) { return GetOutChannel(type); };
69
75 virtual eoChannelInfo* GetOutChannel(CHANNEL_TYPE type) = 0;
76
82 virtual eoChannelInfo* GetOutChannel(uint8_t channelNumber) = 0;
83 protected:
84 SIMPLE_DIRECTION direction;
85
86 };
87
88 #endif
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoIWatcher.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoIWatcher.h
Go to the documentation of this file.
1
8 #include "eoDevice.h"
9 #include "eoTelegram.h"
10
11 #ifndef EOIWATCHER_H_
12 #define EOIWATCHER_H_
13
14 typedef enum
15 {
16 eoWATCHER = 1
17 } SUPPORTED_WATCHER;
18
28 class eoIWatcher : public eoISerialize
29 {
30 public:
32 uint8_t type;
33 eoIWatcher();
34
44 virtual uint32_t CheckSecurity(eoDevice const * const device,eoTelegram const &tel);
50 virtual uint8_t Serialize(eoArchive &arch);
51 virtual ~eoIWatcher();
52 private:
53
54 };
55
56 #endif /* EOWATCHER_H_ */
57
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/eoLink.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
eoLink.h
Go to the documentation of this file.
1
218 #ifndef EOLINK_H_
219 #define EOLINK_H_
220 #include "eoVersion.h"
221 /*
222 #include "Includes/eoApiDef.h"
223 #include "Includes/eoHalTypes.h"
224 #include "Includes/eoDebug.h"
225 #include "Includes/eoConverter.h"
226 #include "Includes/eoGateway.h"
227 #include "Includes/eoDevice.h"
228 #include "Includes/eoStorageManager.h"
229 #include "Includes/eoPacketStream.h"
230 #include "Includes/eoTimer.h"
231 #include "Includes/eoIFilter.h"
232 #include "Includes/eoIDFilter.h"
233 #include "Includes/eodBmFilter.h"
234 #include "Includes/eoFilterFactory.h"
235 #include "Includes/eoProfileFactory.h"
236 #include "Includes/eoRemoteManager.h"
237 #include "Includes/eoSerialCommand.h"
238 #include "Storage/eoRollingCodeStorage.h"
239 #include "Includes/eoReManChainer.h"
240 #include "Includes/eoGenericProfile.h"
241 */
242 #include "Includes/eoAbstractMessage.h"
243 #include "Includes/eoApiDef.h"
244 #include "Includes/eoArchive.h"
245 #include "Includes/eoArchiveTXT.h"
246 #include "Includes/eoChainedMessage.h"
247 #include "Includes/eoChainedReManMessage.h"
248 #include "Includes/eoChannelEnums.h"
249 #include "Includes/eoChannelInfo.h"
250 #include "Includes/eoConverter.h"
251 #include "Includes/eodBmFilter.h"
252 #include "Includes/eoDebug.h"
253 #include "Includes/eoDevice.h"
254 #include "Includes/eoDeviceManager.h"
255 #include "Includes/eoEEProfile.h"
256 #include "Includes/eoFilterFactory.h"
257 #include "Includes/eoGateway.h"
258 #include "Includes/eoGenericProfile.h"
259 #include "Includes/eoGpChainer.h"
260 #include "Includes/eoGPChannelInfo.h"
261 #include "Includes/eoHalTypes.h"
262 #include "Includes/eoHeader.h"
263 #include "Includes/eoIDFilter.h"
264 #include "Includes/eoIFilter.h"
265 #include "Includes/eoISerialize.h"
266 #include "Includes/eoLinuxPacketStream.h"
267 #include "Includes/eoManufacturer.h"
268 #include "Includes/eoMessage.h"
269 #include "Includes/eoMessageHandler.h"
270 #include "Includes/eoMSCHelper.h"
271 #include "Includes/eoPacket.h"
272 #include "Includes/eoPacketStream.h"
273 #include "Includes/eoProc.h"
274 #include "Includes/eoProfileFactory.h"
275 #include "Includes/eoProfile.h"
276 #include "Includes/eoReCom.h"
277 #include "Includes/eoReManChainer.h"
278 #include "Includes/eoReManMessage.h"
279 #include "Includes/eoReCom.h"
280 #include "Includes/eoRemoteManager.h"
281 #include "Includes/eoRollingCodeStorage.h"
282 #include "Includes/eoSecTeachInChainer.h"
283 #include "Includes/eoSecureInfo.h"
284 #include "Includes/eoSecurity.h"
285 #include "Includes/eoSerialCommand.h"
286 #include "Includes/eoStorageManager.h"
287 #include "Includes/eoTeachInModule.h"
288 #include "Includes/eoTelegram.h"
289 #include "Includes/eoTimer.h"
290 #include "Includes/eoWatcherFactory.h"
291 #include "Includes/eoIWatcher.h"
292 #include "Includes/eoWatcher.h"
293 #include "Profiles/eoSpecialProfile.h"
294
295 #endif /* EOLINK_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoLinuxPacketStream.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoLinuxPacketStream.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EO_LINUX_PACKET_STREAM_H_
34 #define EO_LINUX_PACKET_STREAM_H_
35
36 #include "eoPacketStream.h"
37
45 class eoLinuxPacketStream: public eoPacketStream
46 {
47
48 public:
49 eoLinuxPacketStream();
50 virtual ~eoLinuxPacketStream();
56 eoReturn Open(const char * port);
60 void Close();
61
62 eoReturn ReceiveByte(uint8_t* u8RxByte);
63 eoReturn SendByte(uint8_t u8TxByte);
64 private:
65 int fd;
66 static const uint8_t buffSize = 128;
67 uint8_t buf[buffSize];
68 uint8_t numBytes;
69 uint8_t curByte;
70
71 };
72 #endif // !defined(EO_LINUX_PACKET_STREAM_H_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoLogger.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoLogger.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
28 #if !defined(_EO_LOGGER_H)
29 #define _EO_LOGGER_H
30
32
33 #include "eoApiDef.h"
34 #include "eoPacket.h"
35 #include "eoTelegram.h"
36 #include <stdio.h>
37 #include <time.h>
38
44 class eoLogger
45 {
46
47 public:
51 eoLogger();
52
53 virtual ~eoLogger();
58 eoReturn Open(const char *filename);
63 eoReturn Close();
70 eoReturn Log(eoPacket &p, bool flush = false);
77 eoReturn Log(eoTelegram &tel, bool flush = false);
81 eoReturn Flush();
82
83 private:
84 FILE* logFile;
85 #ifdef WIN32
86 #else
87 tm myTimeStruct;
88 #endif
89 };
90
91 #endif // !defined(_EO_LOGGER_H)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoMSCHelper.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoMSCHelper.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #if !defined(_EOMSCHELPER_H_)
34 #define _EOMSCHELPER_H_
35
36 #include "eoManufacturer.h"
37 #include "eoHalTypes.h"
38 #include "eoApiDef.h"
39 #include "eoTelegram.h"
40
46 class eoMSCHelper
47 {
48 public:
55 eoReturn GetMSCmanufacturer(MANUFACTURER_LIST *manufacturer, eoMessage &msg);
63 eoReturn GetMSCpayload(uint8_t *payload, uint8_t maxDataCount, eoMessage &msg);
70 eoReturn SetMSCmanufacturer(const MANUFACTURER_LIST manufacturer, eoMessage &msg);
78 eoReturn SetMSCpayload(const uint8_t *payload, uint8_t dataCount, eoMessage &msg);
79 };
80
81 #endif /* _EOMSCHELPER_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoManufacturer.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoManufacturer.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef __EOMANUFACTURER_H
34 #define __EOMANUFACTURER_H
35
36 #include "eoHalTypes.h"
37
42
43 typedef enum
44 {
45 MANUFACTURER_RESERVED = 0x000,
46 PEHA = 0x001,
47 THERMOKON = 0x002,
48 SERVODAN = 0x003,
49 ECHOFLEX_SOLUTIONS = 0x004,
50 OMNIO_AG = 0x005,
51 HARDMEIER_ELECTRONICS = 0x006,
52 REGULVAR_INC = 0x007,
53 AD_HOC_ELECTRONICS = 0x008,
54 DISTECH_CONTROLS = 0x009,
55 KIEBACK_AND_PETER = 0x00A,
56 ENOCEAN_GMBH = 0x00B,
57 PROBARE = 0x00C,
58 ELTAKO = 0x00D,
59 LEVITON = 0x00E,
60 HONEYWELL = 0x00F,
61 SPARTAN_PERIPHERAL_DEVICES = 0x010,
62 SIEMENS = 0x011,
63 T_MAC = 0x012,
64 RELIABLE_CONTROLS_CORPORATION = 0x013,
65 ELSNER_ELEKTRONIK_GMBH = 0x014,
66 DIEHL_CONTROLS = 0x015,
67 BSC_COMPUTER = 0x016,
68 S_AND_S_REGELTECHNIK_GMBH = 0x017,
69 MASCO_CORPORATION = 0x018,
70 INTESIS_SOFTWARE_SL = 0x019,
71 VIESSMANN = 0x01A,
72 LUTUO_TECHNOLOGY = 0x01B,
73 SCHNEIDER_ELECTRIC = 0x01C,
74 SAUTER = 0x01D,
75 BOOT_UP = 0x01E,
76 OSRAM_SYLVANIA = 0x01F,
77 UNOTECH = 0x020,
78 DELTA_CONTROLS_INC = 0x21,
79 UNITRONIC_AG = 0x022,
80 NANOSENSE = 0x023,
81 THE_S4_GROUP = 0x024,
82 MSR_SOLUTIONS = 0x025,
83 GE = 0x26,
84 MAICO = 0x027,
85 RUSKIN_COMPANY = 0x28,
86 MAGNUM_ENERGY_SOLUTIONS = 0x29,
87 KMC_CONTROLS = 0x02A,
88 ECOLOGIX_CONTROLS = 0x02B,
89 TRIO_2_SYS = 0x2C,
90 AFRISO_EURO_INDEX = 0x02D,
91 NEC_ACCESSTECHNICA_LTD = 0x030,
92 ITEC_CORPORATION = 0x031,
93 SIMICX_CO_LTD = 0x32,
94 EUROTRONIC_TECHNOLOGY_GMBH = 0x34,
95 ART_JAPAN_CO_LTD = 0x35,
96 TIANSU_AUTOMATION_CONTROL_SYSTE_CO_LTD = 0x36,
97 GRUPPO_GIORDANO_IDEA_SPA = 0x38,
98 ALPHAEOS_AG = 0x39,
99 TAG_TECHNOLOGIES = 0x3A,
100 CLOUD_BUILDINGS_LTD = 0x3C,
101 GIGA_CONCEPT = 0x3E,
102 SENSORTEC = 0x3F,
103 JAEGER_DIREKT = 0x40,
104 AIR_SYSTEM_COMPONENTS_INC = 0x41,
105 MULTI_USER_MANUFACTURER = 0x7FF
106 } MANUFACTURER_LIST;
107
108 #define MAX_NAME_LENGTH 42
109
115 class eoManufacturer
116 {
117 private:
118
119 const static char list[][MAX_NAME_LENGTH];
120 const static char listDefault[2][MAX_NAME_LENGTH];
121
122 public:
123 virtual ~eoManufacturer();
124
129 static const char* GetName(const uint16_t manufacturerID);
130 };
136 #endif // __EOMANUFACTURER_H
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoMessage.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoMessage.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EO_MESSAGE_H_
34 #define EO_MESSAGE_H_
35
36 #include "eoAbstractMessage.h"
37 #include "eoHalTypes.h"
38
46 class eoTelegram;
47 class eoMessage : public eoAbstractMessage
48 {
49 public:
55 eoReturn copyTo(eoMessage &msg) const;
60 virtual void Clear();
65 eoMessage(uint16_t size=1);
70 eoMessage(const eoTelegram &tel);
71
72
73 virtual ~eoMessage();
74
76 uint8_t RORG;
78 uint8_t status;
79
88 uint32_t sourceID;
90 uint32_t destinationID;
92 uint8_t securityLevel;
93
94 protected:
95
96 };
97 #endif
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoMessageHandler.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoMessageHandler.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
34 #ifndef EOMESSAGEHANDLER_H_
35 #define EOMESSAGEHANDLER_H_
36
37 #include "eoHalTypes.h"
38 #include "eoMessage.h"
39 #include "eoTelegram.h"
40 #include "eoPacket.h"
41 #include "eoApiDef.h"
42 #include "eoReManChainer.h"
43 #include "eoGpChainer.h"
44 #include "eoSecTeachInChainer.h"
45
46 class eoChainedMessage;
47 class eoGateway;
48
53 class eoMessageHandler
54 {
55 private:
56 eoReManChainer remanChainer;
57 eoGpChainer gpChainer;
58 eoSecTeachInChainer secTeachInChainer;
59
60 public:
61 eoMessageHandler();
62 virtual ~eoMessageHandler();
63
70 eoReturn ProcessTelegram(eoTelegram &tel, eoMessage &msg);
77 eoReturn ProcessTelegram(eoTelegram &tel, eoReManMessage &msg);
78
83 void CleanUpChainerLists();
84
91 eoReturn ComposeChainedMessage(const eoMessage &msg, eoGateway &gateway);
98 eoReturn ComposeChainedMessage(const eoReManMessage &reMsg, eoGateway &gateway);
99 };
100
101 #endif /* EOMESSAGEHANDLER_H_ */
102
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoPacket.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoPacket.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #if !defined(EO_PACKET_H)
34 #define EO_PACKET_H
35
36 #include "eoHalTypes.h"
37
43 class eoPacket
44 {
45
46 public:
51 eoPacket();
52
59 eoPacket(uint8_t* dataBuffer, uint16_t size);
64 eoPacket(uint16_t size);
65
70 eoPacket(eoPacket &packet);
71
72 virtual ~eoPacket();
73
78 uint16_t getBufferSize();
79
85 uint8_t copyTo(eoPacket &packet);
86
90 uint8_t* data;
91
95 uint16_t dataLength;
96
100 uint8_t optionalLength;
101
105 uint8_t type;
106
107 private:
108 uint16_t bufferSize;
109 bool externalBuffer;
110
111 };
112 #endif // !defined(EO_PACKET_H)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoPacketStream.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoPacketStream.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
34 #if !defined(EO_PACKETSTREAM_H)
35 #define EO_PACKETSTREAM_H
36
37 #include "eoHalTypes.h"
38 #include "eoApiDef.h"
39 #include "eoPacket.h"
40
41 /****************************Defines******************************/
43 #define SER_SYNCH_CODE 0x55
44
45 #define SER_HEADER_NR_BYTES 4
46
47 #define SER_INTERBYTE_TIME_OUT 100
48
58 class eoPacketStream
59 {
60 private:
61 typedef enum
62 {
64 GET_SYNC_STATE = 0,
66 GET_HEADER_STATE,
68 CHECK_CRC8H_STATE,
70 GET_DATA_STATE,
72 CHECK_CRC8D_STATE
73
74 } STATES_GET_PACKET;
75
77 uint8_t u8CRC;
79 uint16_t u16Count;
81 STATES_GET_PACKET u8State;
83 uint32_t u32LastTimeoutCheckTickCount;
85 uint32_t u32LastByteReceivedTickCount;
87 eoPacket receivePacket;
88
89 public:
93 eoPacketStream();
94 virtual ~eoPacketStream();
95
101 virtual eoReturn Open(const char *port) = 0;
105 virtual void Close() = 0;
106
115 virtual eoReturn Receive(eoPacket *p);
121 virtual eoReturn ReceiveByte(uint8_t *d) = 0;
127 virtual eoReturn Send(const eoPacket &p);
133 virtual eoReturn SendByte(uint8_t d) = 0;
138 virtual bool IsPacketPending();
139
140 };
141 #endif // !defined(EO_PACKETSTREAM_H)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoProc.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoProc.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef PROC_H_
34 #define PROC_H_
35 #include "eoHalTypes.h"
36
41 class eoProc
42 {
43 public:
44 eoProc();
45 virtual ~eoProc();
52 static uint8_t crc8(uint8_t CRC, uint8_t Data);
59 static uint16_t crc16(uint16_t CRC, uint16_t Data);
60
61 private:
62 const static uint8_t CRC8Table[256];
63 const static uint16_t CRC16Table[256];
64 };
65
66 #endif /* PROC_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoProfile.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoProfile.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef __EOPROFILE_INCLUDED_
34 #define __EOPROFILE_INCLUDED_
35
36 #include "eoApiDef.h"
37 #include "eoChannelInfo.h"
38 #include "eoHalTypes.h"
39 #include "eoMessage.h"
40 #include "eoISerialize.h"
41 #include "eoArchive.h"
42 #include "eoGPChannelInfo.h"
43 #include <vector>
44
61 class eoProfile: public eoISerialize
62 {
63 public:
65 uint8_t rorg;
67 uint8_t func;
69 uint8_t type;
71 uint16_t manufacturer;
72
76 eoProfile(uint16_t size = 0);
77 virtual ~eoProfile();
78
84 virtual bool operator==(const eoProfile &othProfile) const;
85
91 virtual bool operator!=(const eoProfile &othProfile) const;
92
98 virtual bool IsSecDData(const eoMessage &message);
102 virtual void ClearValues();
103 //virtual int LearnIn(uint8_t rorg, uint8_t func, uint8_t type);
104 //virtual void LearnIn(Message m, Device d);
111 virtual eoReturn Create(eoMessage &m);
118 virtual eoReturn CreateTeachIN(eoMessage &m);
125 virtual eoReturn Parse(const eoMessage &msg);
136 //virtual uint8_t GetValue(uint8_t chanNumb,uint16_t &type, float &value);//?
137 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value);
138
150 virtual eoReturn GetValue(CHANNEL_TYPE type, float &value, uint8_t subFlag);
162 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value, uint8_t subFlag);
174 virtual eoReturn SetValue(CHANNEL_TYPE type, float value, uint8_t subFlag);
186 virtual eoReturn GetValue(CHANNEL_TYPE type, uint8_t &value);
198 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value, uint8_t subFlag);
199
211 virtual eoReturn SetValue(CHANNEL_TYPE type, float value);
222 virtual eoReturn SetValue(CHANNEL_TYPE type, uint8_t value);
229 virtual eoChannelInfo* GetChannel(CHANNEL_TYPE type, uint8_t subType);
230
236 virtual eoChannelInfo* GetChannel(CHANNEL_TYPE type);
237
243 virtual eoChannelInfo* GetChannel(uint8_t channelNumber);
244
251 virtual eoReturn GetSubTypeChannel(CHANNEL_TYPE type, std::vector<eoEEPChannelInfo*>& vector);
252
259 virtual eoReturn SetType(uint8_t type);
260
261 virtual uint8_t Serialize(eoArchive &a);
266 virtual uint8_t GetChannelCount() const;
267
272 eoReturn SetManufacturer (uint16_t manufacturerID);
273
274 private:
275
276 static uint16_t BitIdxToByte(const uint16_t &bitIdx);
277 protected:
278 //char profileString[10];
279 eoMessage msg;
292 float ScaleFromRAW(uint32_t rawValue, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax);
305 uint32_t ScaleToRAW(float value, uint32_t rangeMin, uint32_t rangeMax, float scaleMin, float scaleMax);
306
308 const static uint8_t maskArray[8];
318 static eoReturn GetRawValue(const eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size);
319
330 static eoReturn SetRawValue(eoMessage &msg, uint32_t &value, uint16_t offset, uint8_t size);
331
332 };
333 //static eoProfile emptyProfile = eoProfile(0);
337 #endif // __EOPROFILE_INCLUDED_
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoProfileFactory.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoProfileFactory.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EO_PROFILE_FACTORY_H_
34 #define EO_PROFILE_FACTORY_H_
35
36 #include "eoHalTypes.h"
37 #include "eoMessage.h"
38
39 #include "eoDevice.h"
40 #include "eoProfile.h"
41
47 class eoProfileFactory
48 {
49
50 public:
60 static eoProfile* CreateProfile(const eoMessage &msg);
69 static eoProfile* CreateProfile(const uint8_t rorg, const uint8_t func, const uint8_t type);
70 };
71 #endif
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoReCom.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoReCom.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EO_REMOTE_COMISSIONING_H_
34 #define EO_REMOTE_COMISSIONING_H_
35 #include "eoGateway.h"
36 #include "eoGenericProfile.h"
45 typedef enum
46 {
48 RECOM_OK = 0x00,
50 RECOM_WRONG_ID = 0x01,
52 RECOM_WRONG_UNLOCK_CODE = 0x02,
54 RECOM_WRONG_EEP = 0x03,
56 RECOM_WRONG_MANUFACTURER_ID = 0x04,
58 RECOM_WRONG_DATA_SIZE = 0x05,
60 RECOM_NO_CODE_SET = 0x06,
62 RECOM_NOT_SEND = 0x07,
64 RECOM_RPC_FAIL = 0x08,
66 RECOM_MSG_TIMEOUT = 0x09,
68 RECOM_MSG_TOO_LONG = 0x0A,
70 RECOM_MSG_PART_RECEIVED = 0x0B,
72 RECOM_MSG_PART_NOT_RECEIVED = 0x0C,
74 RECOM_ADDR_OUT_OF_RANGE = 0x0D,
76 RECOM_CODE_DATA_SIZE_EXCEED = 0x0E,
78 RECOM_WRONG_DATA = 0x0F
79 } eoReComReturn;
80
85 typedef enum
86 {
88 FN_RECOM_ACK = 0x240, //Remote Commissioning Acknowledge
90 FN_RECOM_GET_METADATA = 0x210, //Get Link Table Metadata Query
92 FN_RECOM_GET_METADATA_RESPONSE = 0x810, //Get Link Table Metadata Response
94 FN_RECOM_GET_TABLE = 0x211, //Get Link Table Query
96 FN_RECOM_GET_TABLE_RESPONSE = 0x811, //Get Link Table Response
98 FN_RECOM_SET_TABLE = 0x212, //Set Link Table Query
100 FN_RECOM_GET_GP_TABLE = 0x213, //Get Link Table GP Entry Query
102 FN_RECOM_GET_GP_TABLE_RESPONSE = 0x813, //Get Link Table GP Entry Response
104 FN_RECOM_SET_GP_TABLE = 0x214, //Set Link Table GP Entry Query
106 FN_RECOM_SET_LEARN_MODE = 0x220, //Remote Set Learn Mode
108 FN_RECOM_TRIG_OUTBOUND_TEACH_REQ = 0x221, //Trigger Outbound Remote Teach Request
110 FN_RECOM_GET_DEVICE_CONFIG = 0x230, //Get Device Configuration Query
112 FN_RECOM_GET_DEVICE_CONFIG_RESPONSE = 0x830, //Get Device Configuration Response
114 FN_RECOM_SET_DEVICE_CONFIG = 0x231, //Set Device Configuration Query
116 FN_RECOM_GET_LINK_BASED_CONFIG = 0x232, //Get Link Based Configuration Query
118 FN_RECOM_GET_LINK_BASED_CONFIG_RESPONSE = 0x832, //Get Link Based Configuration Response
120 FN_RECOM_SET_LINK_BASED_CONFIG = 0x233, //Set Link Based Configuration Query
122 FN_RECOM_APPLY_CHANGES = 0x226, //Apply Changes Command
124 FN_RECOM_RESET_TO_DEFAULTS = 0x224, //Reset to Defaults
126 FN_RECOM_RADIO_LINK_TEST_CONTROL = 0x225, //Radio Link Test Control
128 FN_RECOM_GET_PRODUCT_ID = 0x227, //Get Product ID Query
130 FN_RECOM_GET_PRODUCT_RESPONSE = 0x827, //Get Product ID Response
132 FN_RECOM_GET_REPEATER_FUNCTIONS = 0x250, //Get Repeater Functions Query
134 FN_RECOM_GET_REPEATER_FUNCTIONS_RESPONSE = 0x850, //Get Repeater Functions Response
136 FN_RECOM_SET_REPEATER_FUNCTIONS = 0x251, //Set Repeater Functions Query
138 FN_RECOM_SET_REPEATER_FILTER = 0x252 //Set Repeater Filter Query
139 } FN_RECOM_CODE;
140
142 typedef enum
143 {
145 RECOM_NOT_SUPPORTED = 0x00,
147 RECOM_SUPPORTED = 0x01
148 } RECOM_SUPPORT;
149
151 typedef enum
152 {
154 RECOM_INBOUND_TABLE = 0x00,
156 RECOM_OUTBOUND_TABLE = 0x01
157 } RECOM_TABLE_DIR;
158
160 typedef enum
161 {
163 RECOM_CHANGES_NOT_APPLY = 0x00,
165 RECOM_CHANGES_APPLY = 0x01
166 } RECOM_CHANGES;
167
169 typedef enum
170 {
172 RECOM_LEARN_IN = 0x00,
174 RECOM_LEARN_OUT = 0x01,
176 RECOM_EXIT_LEARN = 0x02
177 } RECOM_LEARN_MODE;
178
180 typedef enum
181 {
183 RECOM_NO_DEFAULT_RESET = 0x00,
185 RECOM_DEFAULT_RESET = 0x01
186 } RECOM_RESET;
187
189 typedef enum
190 {
192 RECOM_REPEATER_OFF = 0x00,
194 RECOM_REPEATER_ON = 0x01,
196 RECOM_FILTERED_REPEATER_ON = 0x02
197 } RECOM_REPEATER_FUNC;
198
200 typedef enum
201 {
203 RECOM_REPEATER_LEVEL_1 = 0x01,
205 RECOM_REPEATER_LEVEL_2 = 0x02
206 } RECOM_REPEATER_LEVEL;
207
209 typedef enum
210 {
212 RECOM_REPEATER_AND = 0x00,
214 RECOM_REPEATER_OR = 0x01
215 } RECOM_REPEATER_FILTER;
216
218 typedef enum
219 {
221 RECOM_REPEATER_BLOCK = 0x00,
223 RECOM_REPEATER_APPLY = 0x01,
225 RECOM_REPEATER_DELETE_FILTER = 0x02,
227 RECOM_REPEATER_DELETE_ALL = 0x03
228 } RECOM_REPEATER_FILTER_CONTROL;
229
231 typedef enum
232 {
234 RECOM_FILTER_SOURCE_ID = 0x00,
236 RECOM_FILTER_RORG = 0x01,
238 RECOM_FILTER_DBM = 0x02,
240 RECOM_FILTER_DESTINATION_ID = 0x03
241 } RECOM_REPEATER_FILTER_TYPE;
242
247 typedef struct
248 {
250 RECOM_SUPPORT remoteTeachOutbound;
252 RECOM_SUPPORT remoteTeachInbound;
254 RECOM_SUPPORT outboundLinkTable;
256 RECOM_SUPPORT inboundLinkTable;
258 uint8_t lengthOfOutbound;
260 uint8_t maxOfOutbound;
262 uint8_t lenghtOfInbound;
264 uint8_t maxOfInbound;
265 } QUERY_METADATA_RESPONSE;
266
271 typedef struct
272 {
274 RECOM_TABLE_DIR tableDir;
276 uint8_t startIndex;
278 uint8_t endIndex;
279 } QUERY_LINK_TABLE;
280
285 typedef struct gplinkTable
286 {
288 RECOM_TABLE_DIR tableDir;
290 uint8_t index;
292 uint8_t length;
294 uint8_t * gp_ti;
296 gplinkTable() : length(0),gp_ti(NULL){};
297 } GP_LINK_TABLE;
298
303 typedef struct
304 {
306 uint8_t index;
308 uint32_t ID;
310 uint8_t EEP_RORG;
312 uint8_t EEP_FUNC;
314 uint8_t EEP_TYPE;
316 uint8_t channel;
317 } LINK_TABLE;
318
323 typedef struct
324 {
326 RECOM_LEARN_MODE mode;
328 uint8_t inboundIndex;
329 } QUERY_SET_LEARN_MODE;
330
335 typedef struct
336 {
338 uint16_t startIndex;
340 uint16_t endIndex;
342 uint8_t length;
343 } QUERY_DEVICE_CONFIG;
344
349 typedef struct
350 {
352 uint16_t index;
354 uint8_t length;
356 uint32_t rawValue;
357 } DEVICE_CONFIG;
358
363 typedef struct
364 {
366 RECOM_TABLE_DIR tableDir;
368 uint16_t tableIndex;
370 uint16_t startIndex;
372 uint16_t endIndex;
374 uint8_t length;
375 } QUERY_LINK_BASED_CONFIG;
380 typedef struct
381 {
383 RECOM_TABLE_DIR tableDir;
385 uint8_t tableIndex;
387 uint16_t index;
389 uint8_t length;
391 uint32_t rawValue;
392 } LINK_BASED_CONFIG;
393
394
399 typedef struct
400 {
402 RECOM_CHANGES linkTableChanges;
404 RECOM_CHANGES configChanges;
405 } QUERY_APPLY_CHANGES;
406
411 typedef struct
412 {
414 RECOM_RESET configParam;
416 RECOM_RESET inboundTable;
418 RECOM_RESET outboundTable;
419 } QUERY_RESET_DEFAULTS;
420
425 typedef struct
426 {
428 bool isEnabled;
430 uint8_t numOfRLT;
431 } QUERY_RADIO_LINK_TEST;
432
437 typedef struct
438 {
440 uint16_t manufacturerId;
442 uint32_t productReference;
443 } QUERY_PRODUCT_ID_RESPONSE;
444
449 typedef struct
450 {
452 RECOM_REPEATER_FUNC repeaterFunc;
454 RECOM_REPEATER_LEVEL repeaterLevel;
456 RECOM_REPEATER_FILTER repeaterFilter;
457 } REPEATER_FUNCTIONS;
458
463 typedef struct
464 {
466 RECOM_REPEATER_FILTER_CONTROL repeaterFunc;
468 RECOM_REPEATER_FILTER_TYPE repeaterLevel;
470 uint32_t value;
471 } QUERY_SET_REPEATER_FILTER;
472
482 class eoReCom
483 {
484 private:
485 eoGateway *gateway;
486 eoReManMessage reManMessage;
487 eoReturn initPacket(FN_RECOM_CODE const fnCode, uint8_t const length);
488
489 eoReturn GetRawValue(uint8_t length,uint8_t offset,eoReManMessage const &reManMessage,uint32_t &value) const;
490
491 eoReturn SetRawValue(uint8_t length,uint8_t offset,eoReManMessage &reManMessage,uint32_t const &value) const;
492 public:
497 eoReCom(eoGateway *gateway);
498 ~eoReCom();
499
507 eoReturn GetMetadata(uint32_t destinationID);
515 eoReturn ParseGetMetadataResponse(QUERY_METADATA_RESPONSE &response) const;
524 eoReturn GetLinkTable(QUERY_LINK_TABLE const &query, uint32_t const destinationID);
533 eoReturn ParseGetLinkTableResponse(std::vector<LINK_TABLE> &response, RECOM_TABLE_DIR &tableDir) const;
543 eoReturn SetLinkTable(std::vector<LINK_TABLE> const &query, RECOM_TABLE_DIR tableDir, uint32_t destinationID);
552 eoReturn GetGPLinkTable(GP_LINK_TABLE const &query, uint32_t destinationID);
559 eoReturn ParseGetGPLinkTableResponse(GP_LINK_TABLE &query) const;
569 eoReturn SetGPLinkTable(GP_LINK_TABLE const &query, uint32_t destinationID);
570
579 eoReturn RemoteSetLearnMode(QUERY_SET_LEARN_MODE const &learnMode, uint32_t destinationID);
588 eoReturn TriggerOutboundTeachRequest(uint8_t channel, uint32_t destinationID);
597 eoReturn GetDeviceConfig(QUERY_DEVICE_CONFIG const &deviceConf, uint32_t destinationID);
603 eoReturn ParseDeviceConfigResponse(std::vector<DEVICE_CONFIG> &deviceConf) const;
613 eoReturn SetDeviceConfig(std::vector<DEVICE_CONFIG> const &deviceConf, uint32_t destinationID);
622 eoReturn GetLinkBasedConfig(QUERY_LINK_BASED_CONFIG const &linkConfig, uint32_t destinationID);
634 eoReturn SetLinkBasedConfig(std::vector<LINK_BASED_CONFIG> const &linkConfig, uint32_t destinationID);
640 eoReturn ParseLinkBasedConfigResponse(std::vector<LINK_BASED_CONFIG> &linkConfig) const;
649 eoReturn ApplyChanges(QUERY_APPLY_CHANGES const &changes, uint32_t destinationID);
658 eoReturn ResetDefaults(QUERY_RESET_DEFAULTS const &defaults, uint32_t destinationID);
667 eoReturn RadioLinkTest(QUERY_RADIO_LINK_TEST const &radioLink, uint32_t destinationID);
675 eoReturn GetProductID(uint32_t destinationID = BROADCAST_ID);
686 eoReturn ParseGetProductIDResponse(QUERY_PRODUCT_ID_RESPONSE &response) const;
696 eoReturn GetRepeater(uint32_t destinationID);
704 eoReturn ParseGetRepeaterResponse(REPEATER_FUNCTIONS &response) const;
713 eoReturn SetRepeater(REPEATER_FUNCTIONS const &repeaterFunc, uint32_t destinationID);
722 eoReturn SetRepeaterFilter(QUERY_SET_REPEATER_FILTER const &repeaterFunc, uint32_t destinationID);
723
724 };
728 #endif // !defined(EA_4BFBF49B_3520_48f7_BACB_B62331BA4509__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoReManChainer.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoReManChainer.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
33 #ifndef EOREMANCHAINER_H_
34 #define EOREMANCHAINER_H_
35
36 class eoGateway;
37
38 #include "eoChainedMessage.h"
39 #include "eoChainedReManMessage.h"
40 #include "eoReManMessage.h"
41
42 #include <map>
44 typedef std::map<uint32_t, eoChainedReManMessage*> id_reman_msg_map;
45
50 class eoReManChainer
51 {
52 private:
53 id_reman_msg_map list;
54 uint8_t seq;
55
56 public:
57 eoReManChainer();
58 virtual ~eoReManChainer();
59
64 void CleanUpList();
65
72 eoReturn ParseChainedMessage(eoTelegram &tel, eoReManMessage &msg);
73
80 eoReturn SendChainedMessage(const eoReManMessage &msg, eoGateway &gateway);
81
82 };
83
84 #endif
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoReManMessage.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoReManMessage.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EO_REMAN_MESSAGE_H_
34 #define EO_REMAN_MESSAGE_H_
35
36 #include "eoMessage.h"
37 #include "eoAbstractMessage.h"
38
43 class eoReManMessage : public eoAbstractMessage
44 {
45
46 public:
48 uint32_t sourceID;
50 uint32_t destinationID;
52 uint8_t securityLevel;
54 uint16_t fnCode;
56 uint16_t manufacturerID;
57
62 uint8_t copyTo(eoReManMessage &msg) const;
67 eoReManMessage(uint16_t size);
68 virtual ~eoReManMessage();
69
70 };
71 #endif // !defined(EA_62F3D1F6_4D2F_4f34_8D5B_6745CA8C9AE8__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoRemoteManager.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoRemoteManager.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EO_REMOTE_MANAGER_H_
34 #define EO_REMOTE_MANAGER_H_
35
36
41 typedef enum
42 {
44 R_START_LEARN = 1, //Start learn
46 R_NEXT_CHANNEL, //Next channel
48 R_STOP_LEARN, //Stop learn
50 R_S_SIMPLE_LEARN, //SmartACK start simple learn mode
52 R_S_ADVANCED_LEARN, //SmartACK start advanced learn mode
54 R_S_STOP_LEARN //SmartACK stop learn
55 } REMOTE_TYPE;
56
61 typedef enum
62 {
64 FN_UNLOCK = 0x001, //Unlock
66 FN_LOCK = 0x002, //Lock
68 FN_SETCODE = 0x003, //Set code
70 FN_QUERYID = 0x004, //Query ID
72 FN_QUERYID_ANSWER = 0x604, //Query ID answer
74 FN_ACTION = 0x005, //Action
76 FN_PING = 0x006, //Ping
78 FN_PING_ANSWER = 0x606, //Ping answer
80 FN_QUERY_FUNCTION = 0x007, //Query function
82 FN_QUERY_FUNCTION_ANSWER = 0x607, //Query function answer
84 FN_QUERY_STATUS = 0x008, //Query status
86 FN_QUERY_STATUS_ANSWER = 0x608, //Query status answer
88 FN_REMOTE_LEARNIN = 0x201, //Remote learn in
90 FN_REMOTE_FLASH_WRITE = 0x203, //Remote flash write
92 FN_REMOTE_FLASH_READ = 0x204, //Remote flash read
94 FN_REMOTE_FLASH_READ_ANSWER = 0x804, //Remote flash read answer
96 FN_SMARTACK_READ = 0x205, //SmartACK read
98 FN_SMARTACK_READ_MAILBOX_ANSWER = 0x805, //SmartACK read mailbox answer
100 FN_SMARTACK_READ_LEARNED_SENSOR_ANSWER = 0x806, //SmartACK read learned sensor answer
102 FN_SMARTACK_WRITE = 0x206 //SmartACK write
103 } FN_CODE;
104
109 typedef struct
110 {
112 uint8_t rorg; //EEP RORG 8 bits
114 uint8_t func; //EEP Function 6 bits
116 uint8_t type; //EEP Type 7 bits
117 } QUERY_ID;
118
123 typedef struct
124 {
126 uint16_t functionNum; //Function number
128 uint16_t manufaturerID; //Manufacturer ID
129 } QUERY_FUNCTION_RESPONSE;
130
135 typedef struct
136 {
138 uint8_t rorg; //EEP RORG
140 uint8_t func; //EEP Function
142 uint8_t type; //EEP Type
144 int8_t rssi; //RSSI of the pinged device
145 } PING_RESPONSE;
146
151 typedef struct
152 {
154 bool codeSetFlag; //Code set flag
156 uint8_t lastSEQ; //Last SEQ
158 uint16_t lastFunc; //Last function code
160 uint8_t lastFuncRet; //Last function return code
161 } QUERY_STATUS_RESPONSE;
162
167 typedef struct
168 {
170 uint8_t data; //Read data
171 } FLASH_READ_RESPONSE;
172
177 typedef struct
178 {
180 uint16_t flashAddress;//SmartAck flash address where the settings are stored
182 uint16_t mailboxCount; //Number of mailboxes
183 } MAILBOX_SETTINGS_RESPONSE;
184
189 typedef struct
190 {
192 uint32_t sensorID; //Device ID of the sensor
194 uint32_t controllerID; //Device ID of the controller
196 uint8_t learnedCount; //Number of learned in devices
197 } LEARNED_SENSOR_RESPONSE;
202 class eoRemoteManager
203 {
204 private:
205 eoGateway *gateway;
206 eoReManMessage reManMessage;
207
208 public:
213 eoRemoteManager(eoGateway *gateway);
214 ~eoRemoteManager();
215
216 public:
225 eoReturn UnLock(const uint32_t securityCode, const uint32_t destinationID);
234 eoReturn Lock(const uint32_t securityCode, const uint32_t destinationID);
243 eoReturn SetCode(const uint32_t securityCode, const uint32_t destinationID);
249 eoReturn Action(const uint32_t destinationID);
260 eoReturn Ping(const uint32_t destinationID);
268 eoReturn ParsePingAnswer(PING_RESPONSE &response);
276 eoReturn QueryID(const QUERY_ID &msg);
281 eoReturn ParseQueryIDAnswer(QUERY_ID &response);
289 eoReturn QueryFunction(const uint32_t destinationID);
296 eoReturn ParseQueryFunctionAnswer(QUERY_FUNCTION_RESPONSE *response, uint8_t maxIDCount, uint8_t &IDCount);
305 eoReturn QueryStatus(const uint32_t destinationID);
310 eoReturn ParseQueryStatusAnswer(QUERY_STATUS_RESPONSE &response);
319 eoReturn RemoteLearnIn(const uint32_t destinationID, REMOTE_TYPE learnFlag);
330 eoReturn RemoteFlashWrite(const uint32_t destinationID, const uint16_t &memoryAddress, const uint16_t numOfBytes, const uint8_t data[]);
340 eoReturn RemoteFlashRead(const uint32_t destinationID, const uint16_t &memoryAddress, const uint16_t numOfBytes);
347 eoReturn ParseRemoteFlashReadAnswer(FLASH_READ_RESPONSE *response, uint16_t *dataCount, uint8_t maxDataCount);
355 eoReturn RemoteSmartReadMailboxSettings(const uint32_t destinationID);
360 eoReturn ParseRemoteSmartReadMailboxSettingsAnswer(MAILBOX_SETTINGS_RESPONSE &response);
368 eoReturn RemoteSmartReadLearnedSensors(const uint32_t destinationID);
375 eoReturn ParseRemoteSmartReadLearnedSensors(LEARNED_SENSOR_RESPONSE *response, uint8_t *learnedCount, uint8_t maxLearnedCount);
385 eoReturn RemoteSmartAddMailbox(const uint32_t destinationID, const uint8_t mailboxIndex, const uint32_t sensorID, const uint32_t postmasterID);
391 eoReturn RemoteSmartDeleteMailbox(const uint32_t destinationID, const uint8_t mailboxIndex);
399 eoReturn RemoteSmartLearnIn(const uint32_t destinationID, const uint8_t learnCount, const uint32_t sensorID, const uint32_t controllerID);
407 eoReturn RemoteSmartLearnOut(const uint32_t destinationID, const uint8_t learnCount, const uint32_t sensorID, const uint32_t controllerID);
408
409 };
410
411 #endif // !defined(EA_4BFBF49B_3520_48f7_BACB_B62331BA4509__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoRollingCodeStorage.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoRollingCodeStorage.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
34 #ifndef EOROLLINGCODESTORAGE_H_
35 #define EOROLLINGCODESTORAGE_H_
36
37 #include "eoHalTypes.h"
38 #include "eoApiDef.h"
39
40 #include <map>
41
42 using namespace std;
43
49 class eoRollingCodeStorage
50 {
51 private:
55 map<uint32_t, uint32_t> list;
56 public:
60 eoRollingCodeStorage();
61 virtual ~eoRollingCodeStorage();
62
63 public:
70 void SetRLC(uint32_t id, uint32_t rlc);
76 eoReturn GetRLC(uint32_t id, uint32_t &rlc);
81 eoReturn RemoveID(uint32_t id);
82
83 public:
90 eoReturn Save(const char* file);
97 eoReturn Load(const char* file);
98 };
99
100 #endif /* EOROLLINGCODESTORAGE_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoSecTeachInChainer.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoSecTeachInChainer.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
34 #ifndef EOSECTEACHINCHAINER_H_
35 #define EOSECTEACHINCHAINER_H_
36
37 #include "eoChainedMessage.h"
38 class eoGateway;
39
40 #include <map>
42 typedef std::map<uint32_t, eoChainedMessage*> id_msg_map;
43
48 class eoSecTeachInChainer
49 {
50 protected:
52 id_msg_map list;
53 public:
54 eoSecTeachInChainer();
55 virtual ~eoSecTeachInChainer();
56
61 void CleanUpList();
62
69 eoReturn ParseChainedMessage(eoTelegram &tel, eoMessage &msg);
76 eoReturn SendChainedMessage(const eoMessage &msg, eoGateway &gateway);
77
78 };
79
80 #endif // !defined(EOSECTEACHINCHAINER_H_)
81
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoSecureInfo.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoSecureInfo.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EO_SEC_INFO_H_
34 #define EO_SEC_INFO_H_
35
36 #include "api/sec_api.h"
37 #include "eoHalTypes.h"
38 #include "eoISerialize.h"
39 #include "eoArchive.h"
40
46
47 #define SLF_DATA_ENC_OFF 0
48
49 #define SLF_DATA_ENC_AES128 0x04
50
51 #define SLF_DATA_ENC_VAES128 0x03
52
53 #define SLF_MAC_OFF (0<<3)
54
55 #define SLF_MAC_3BYTE (1<<3)
56
57 #define SLF_MAC_4BYTE (2<<3)
58
59 #define SLF_RLC_TX_OFF (0<<5)
60
61 #define SLF_RLC_TX_ON (1<<5)
62
63 #define SLF_RLC_ALGO_OFF (0<<6)
64
65 #define SLF_RLC_ALGO_16BIT (1<<6)
66
67 #define SLF_RLC_ALGO_24BIT (2<<6)
68
77
78 #define TEACH_INFO_PSK (1<<3)
79
80 #define TEACH_INFO_PTM (1<<2)
81
83 #define TEACH_INFO_PTM_ROCKERA (0<<0)
84
85 #define TEACH_INFO_PTM_ROCKERB (1<<0)
86
88 #define TEACH_INFO_UNIDIR (0<<0)
89
90 #define TEACH_INFO_BIDIR (1<<0)
91
98 class eoSecureInfo: public eoISerialize
99 {
100
101 public:
102 eoSecureInfo();
103 virtual ~eoSecureInfo();
104 uint8_t Serialize(eoArchive &arch);
105 public:
107 uint8_t key[16];
109 uint8_t keySize;
111 uint32_t rollingCode;
113 uint8_t SLF;
115 uint8_t teachInInfo;
117 uint8_t subKey1[16];
119 uint8_t subKey2[16];
121 uint8_t psk[16];
123 SEC_RESULT securityResult;
125 uint32_t previousRollingCode;
126 };
127 #endif // !defined(EO_SEC_INFO_H_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoSecurity.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoSecurity.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EO_SECURITY_H_
34 #define EO_SECURITY_H_
35 #include "eoMessage.h"
36 #include "eoDevice.h"
37 #include "api/sec.h"
38 #include "api/sec_api.h"
39
50 class eoSecurity
51 {
52 private:
53 MESSAGE_TYPE msg;
54 MESSAGE_TYPE msgTmp;
55 SECU_TYPE info;
56
57 SEC_RESULT lastResult;
58
59 public:
60 eoSecurity();
61 virtual ~eoSecurity();
68 eoReturn ParseTeachIn(eoMessage &msgTi, eoDevice &dev);
75 eoReturn CreateTeachIn (eoMessage &msgTi, eoDevice &dev);
83 eoReturn Decrypt(eoMessage &msgSec, eoMessage &msgNonSec, eoDevice &dev);
91 eoReturn Encrypt(eoMessage &msgNonSec, eoMessage &msgSec, eoDevice &dev);
96 SEC_RESULT GetLastError();
97
98 private:
100 static eoReturn MessageToType(eoMessage const &msg, MESSAGE_TYPE &mt);
101 static eoReturn TypeToMessage(MESSAGE_TYPE const &mt, eoMessage &msg);
102 static eoReturn TypeToSecuInfo(SECU_TYPE const &it, eoSecureInfo &info);
103 static eoReturn SecuInfoToType(eoSecureInfo const &info, SECU_TYPE &it) ;
104
105 };
106 #endif // !defined(EA_C4479453_0471_4430_829A_098DBBFB613D__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoSerialCommand.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoSerialCommand.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
34 #ifndef EOSERIALCOMMAND_H_
35 #define EOSERIALCOMMAND_H_
36 #include "eoHalTypes.h"
37 #include "eoApiDef.h"
38 #include "eoPacket.h"
39 class eoGateway;
40
41
46 typedef enum
47 {
49 CO_WR_SLEEP = 1,
51 CO_WR_RESET = 2,
53 CO_RD_VERSION = 3,
55 CO_RD_SYS_LOG = 4,
57 CO_WR_SYS_LOG = 5,
59 CO_WR_BIST = 6,
61 CO_WR_IDBASE = 7,
63 CO_RD_IDBASE = 8,
65 CO_WR_REPEATER = 9,
67 CO_RD_REPEATER = 10,
69 CO_WR_FILTER_ADD = 11,
71 CO_WR_FILTER_DEL = 12,
73 CO_WR_FILTER_DEL_ALL = 13,
75 CO_WR_FILTER_ENABLE = 14,
77 CO_RD_FILTER = 15,
79 CO_WR_WAIT_MATURITY = 16,
81 CO_WR_SUBTEL = 17,
83 CO_WR_MEM = 18,
85 CO_RD_MEM = 19,
87 CO_RD_MEM_ADDRESS = 20,
89 CO_RD_SECURITY = 21,
91 CO_WR_SECURITY = 22,
93 CO_WR_MODE = 28,
95 CO_RD_DUTYCYCLE_LIMIT = 35
96 } COMMON_COMMAND_TYPE;
97
99 typedef enum
100 {
102 BLOCK_RADIO = 0x00,
104 APPLY_RADIO = 0x80,
106 BLOCK_REPEATED = 0x40,
108 APPLY_REPEATED = 0xC0
109 } FILTER_KIND;
110
112 typedef enum
113 {
115 SOURCE_ID = 0,
117 CHOICE = 1,
119 DBM = 2,
121 DESTINATION_ID = 0
122 } FILTER_TYPE;
123
125 typedef enum
126 {
128 OR = 0,
130 AND = 1
131 } FILTER_OPERATOR;
132
134 typedef struct
135 {
137 uint8_t appVersion[4]; //Application versions
139 char appDescription[16]; //Applications description
141 uint8_t apiVersion[4]; //API version
143 uint32_t chipID; //Unique ID
145 uint32_t chipVersion; //Reserved for internal use
146 } CO_RD_VERSION_RESPONSE;
147
149 typedef struct
150 {
152 uint32_t baseID; //Base ID
154 uint8_t remainingWrites; //Remaining write cycles for Base ID
155 } CO_RD_IDBASE_RESPONSE;
156
158 typedef struct
159 {
161 bool repEnable; //Repeater enable
163 uint8_t repLevel; //Repeater level
164 } CO_RD_REPEATER_RESPONSE;
165
167 typedef struct
168 {
170 FILTER_TYPE filterType; //Filter type
172 uint32_t filterValue; //Filter value
173 } CO_RD_FILTER_RESPONSE;
174
176 typedef enum
177 {
179 SA_RECLAIM_NOT_SUCCESSFUL = 1,
181 SA_CONFIRM_LEARN = 2,
183 SA_LEARN_ACK = 3,
185 SA_READY = 4,
187 SA_DUTYCYCLE_LIMIT = 6
188 } SA_EVENT_TYPE;
189
191 typedef enum
192 {
193 SA_LEARN_IN = 0x00,
195 SA_EEP_NOT_ACCEPTED = 0x11,
197 SA_PM_FULL = 0x12,
199 SA_CONTROLLER_FULL = 0x13,
201 SA_RSSI_NOT_GOOD = 0x14,
203 SA_LEARN_OUT = 0x20,
205 SA_NOT_SUPPORTED = 0xFF
206 } SA_CONFIRM_CODE;
207
209 typedef enum
210 {
212 EC_VOLTAGE_DROP = 0x00,
214 EC_RESET_PIN = 0x01,
216 EC_WATCHDOG_TIMER = 0x02,
218 EC_FLYWHEEL_TIMER = 0x03,
220 EC_PARITY_ERROR = 0x04,
222 EC_PARITY_MEM_ERROR = 0x05,
224 EC_MEM_ERRPR = 0x06,
226 EC_WAKE_PIN_0 = 0x07,
228 EC_WAKE_PIN_1 = 0x08,
230 EC_UNKNOWN = 0x09
231 } EC_RESET_CAUSE;
232
234 typedef enum
235 {
237 MODE_COMPATIBLE = 0x00,
239 MODE_ADVANCED = 0x01
240 } WR_MODE_CODE;
241
243 typedef struct
244 {
246 uint8_t priPostmaster;
248 uint32_t manufacturerID;
250 uint8_t eep[3];
252 uint8_t rssi;
254 uint32_t postmasterID;
256 uint32_t smartAckID;
258 uint8_t hopCount;
259 } SA_CONFIRM_LEARN_REQUEST;
260
262 typedef struct
263 {
265 uint16_t responseTime;
267 SA_CONFIRM_CODE confirmCode;
268 } SA_LEARN_ACK_RESPONSE;
269
271 typedef struct
272 {
274 EC_RESET_CAUSE resetCause;
275 } CO_READY_RESPONSE;
276
278 typedef enum
279 {
281 SA_WR_LEARNMODE = 1,
283 SA_RD_LEARNMODE = 2,
285 SA_WR_LEARNCONFIRM = 3,
287 SA_WR_CLIENTLEARNRQ = 4,
289 SA_WR_RESET = 5,
291 SA_RD_LEARNEDCLIENTS = 6,
293 SA_WR_RECLAIMS = 7,
295 SA_WR_POSTMASTER = 8
296 } SA_COMMAND_TYPE;
297
299 typedef enum
300 {
302 SA_CC_LEARNIN = 0X00,
304 SA_CC_LEARNOUT = 0X20
305 } SMARTACK_CONFIRM_CODE;
306
308 typedef enum
309 {
311 SA_EL_SIMPLE = 0X00,
313 SA_EL_ADVANCE = 0X01,
315 SA_EL_ADVANCE_REP = 0X02
316 } SA_EXTENDED_LEARNMODE;
317
319 typedef struct
320 {
322 bool enabled;
324 SA_EXTENDED_LEARNMODE extended;
325 } SA_RD_LEARNMODE_RESPONSE;
326
328 typedef struct
329 {
331 uint32_t clientID;
333 uint32_t postmasterID;
335 uint8_t mailboxIndex;
336
337 } SA_RD_LEARNEDCLIENTS_RESPONSE;
338
340 typedef enum
341 {
343 CO_DUTYCYCLE_LIMIT_UNREACHED = 0x00,
345 CO_DUTYCYCLE_LIMIT_REACHED = 0x01
346 } CO_DUTYCYCLE_LIMIT;
347
349 typedef struct
350 {
352 uint8_t availableCycle;
354 uint8_t numOfSlots;
356 uint16_t slotPeriod;
358 uint16_t slotPeriodLeft;
360 uint8_t loadAfterCycle;
361 } CO_RD_DUTYCYCLE_RESPONSE;
362
363
369 class eoSerialCommand
370 {
371
372 public:
377 eoSerialCommand(eoGateway *gateway);
378 virtual ~eoSerialCommand();
384 eoReturn Sleep(const uint32_t sleepPeriod);
389 eoReturn Reset();
395 eoReturn ReadVersion(CO_RD_VERSION_RESPONSE &version);
400 eoReturn BIST();
406 eoReturn WriteIDBase(const uint32_t baseID);
412 eoReturn ReadIDBase(CO_RD_IDBASE_RESPONSE &response);
419 eoReturn WriteRepeater(bool repEnable, const uint8_t repLevel);
425 eoReturn ReadRepeater(CO_RD_REPEATER_RESPONSE &response);
433 eoReturn AddFilter(const FILTER_TYPE filterType, const uint32_t filterValue, const FILTER_KIND filterKind);
440 eoReturn DeleteFilter(const FILTER_TYPE filterType, const uint32_t filterValue);
445 eoReturn DeleteAllFilter();
452 eoReturn EnableFilter(const bool filterEnabled, const FILTER_OPERATOR filterOperator);
460 eoReturn ReadFilter(CO_RD_FILTER_RESPONSE *filter, uint8_t *filterCount, uint8_t maxFilterCount);
466 eoReturn WaitMaturity(const bool waitMaturity);
473 eoReturn SmartAckConfirmLearn(uint16_t responseTime, SA_CONFIRM_CODE confirmCode);
479 eoReturn SmartAckLearnAck(SA_LEARN_ACK_RESPONSE &response);
485 eoReturn Ready(CO_READY_RESPONSE &response);
493 eoReturn SmartAckWriteLearnMode(bool enable, SA_EXTENDED_LEARNMODE extended, uint32_t timeout);
499 eoReturn SmartAckReadLearnMode(SA_RD_LEARNMODE_RESPONSE &response);
508 eoReturn SmartAckLearnConfirm(uint16_t responseTime, SMARTACK_CONFIRM_CODE confirmCode, uint32_t postmasterID, uint32_t clientID);
515 eoReturn SmartAckSendLearnRequest(uint16_t manufacturerID, uint32_t EEP);
521 eoReturn SmartAckReset(uint32_t clientID);
529 eoReturn SmartAckLearnedClients(SA_RD_LEARNEDCLIENTS_RESPONSE *clients, uint8_t *learnedCount, uint8_t maxLearnedCount);
535 eoReturn SmartAckSetReclaimTries(uint8_t reclaimCount);
541 eoReturn SmartAckSetPostmaster(uint8_t mailboxCount);
546 eoReturn EventSmartAckConfirmLearn (SA_CONFIRM_LEARN_REQUEST &request);
551 eoReturn WriteMode (WR_MODE_CODE mode);
557 eoReturn DutyCycleReadLimit(CO_RD_DUTYCYCLE_RESPONSE &response);
562 eoReturn EventDutyCycleLimit (CO_DUTYCYCLE_LIMIT &request);
567 eoReturn DutyCycleLimit (CO_DUTYCYCLE_LIMIT limit);
572 eoPacket GetSerialPacket();
573 private:
574 eoGateway *gateway;
575 eoReturn initPacket(uint8_t type, uint8_t command, uint8_t length);
576 eoPacket serialPacket;
577 };
578
579 #endif /* EOSERIALCOMMAND_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Profiles/eoSpecialProfile.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Profiles
eoSpecialProfile.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
34 #ifndef SPECIALPROFILE_H_
35 #define SPECIALPROFILE_H_
36
37 #include "eoF6EEProfile.h"
38 #include "eoEEP_A509xx.h"
39 #include "eoEEP_A510xx.h"
40 #include "eoEEP_A511xx.h"
41 #include "eoEEP_A512xx.h"
42 #include "eoEEP_A513xx.h"
43 #include "eoEEP_A520xx.h"
44 #include "eoEEP_A530xx.h"
45 #include "eoEEP_A537xx.h"
46 #include "eoEEP_A538xx.h"
47 #include "eoEEP_D200xx.h"
48 #include "eoEEP_D201xx.h"
49 #include "eoEEP_D202xx.h"
50 #include "eoEEP_D204xx.h"
51 #include "eoEEP_D205xx.h"
52 #include "eoEEP_D206xx.h"
53 #include "eoEEP_D210xx.h"
54 #include "eoEEP_D220xx.h"
55 #include "eoEEP_D230xx.h"
56 #include "eoEEP_D232xx.h"
57 #include "eoEEP_D240xx.h"
58 #include "eoEEP_D250xx.h"
59 #include "eoEEP_D2A0xx.h"
60
61
62 #endif /* SPECIALPROFILE_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoStorageManager.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoStorageManager.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #include "eoArchive.h"
34 #include "eoHeader.h"
35 #include "eoISerialize.h"
36 #include "eoConverter.h"
37 #include "eoHalTypes.h"
38 #include <string.h>
39 #include <map>
40
41 #ifndef EO_STORAGE_MANAGER_H_
42 #define EO_STORAGE_MANAGER_H_
43
45 #define EO_STORAGE_IDENTIFIER "_EOLINK_SAVE"
46
48 typedef struct
49 {
51 eoISerialize *object;
53 char name[33];
54 //seems that i don't need this...
56 bool hasBeenLoaded;
58 uint32_t uniqueID;
59 } serialize_object;
60
62 typedef std::map<uint32_t, serialize_object*> name_object_map;
63
77 class eoStorageManager
78 {
79
80 public:
84 eoStorageManager();
89 eoStorageManager(eoArchive &archive);
90 virtual ~eoStorageManager();
98 eoReturn addObject(const char * name, eoISerialize *object);
99
106 eoReturn RemoveObject(const char * name);
112 eoReturn Load(const char * strBuf);
118 eoReturn Save(const char * strBuf);
119
120
121 private:
122 name_object_map list;
123 eoArchive * arch;
124 };
128 #endif // !defined(EA_E73F2DAC_8C52_496f_8AAC_BA2DE5B7E9B8__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoTeachInModule.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoTeachInModule.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EO_TEACH_IN_MODULE_H_
34 #define EO_TEACH_IN_MODULE_H_
35 #include "eoHalTypes.h"
36 #include "eoMessage.h"
37 #include "eoDevice.h"
38 #include "eoISerialize.h"
39 class eoDeviceManager;
40 class eoSecurity;
41
42 #include <map>
43
45 typedef struct
46 {
48 bool teachedIN;
49 } TEACH_STRUCT;
50
52 typedef enum
53 {
55 NO_TEACH_IN = 0,
56
57 NEW_DEVICE,
58
59 EEP_TEACH_IN,
60
61 NEW_DEVICE_AND_EPP,
62
63 SECURITY_TEACH_IN,
64
65 SECOND_TEACH_IN,
66
67 GENERIC_TEACH_IN
68 } TEACH_RETURN;
69
71 typedef enum
72 {
74 GENERAL_REASON = 0,
75
76 TEACH_IN_ACCEPTED = 1,
77
78 TEACH_OUT_ACCEPTED = 2,
79
80 EEP_NOT_SUPPORTED = 3
81 } UTE_RESPONSE;
82
84 typedef enum
85 {
87 UTE_DIRECTION_UNIDIRECTIONAL = 0,
88
89 UTE_DIRECTION_BIDIRECTIONAL = 1
90 } UTE_DIRECTION;
91
96 typedef enum
97 {
98 RESP_REJECTED_GENERALLY = 0,
99 RESP_TEACHIN,
100 RESP_TEACHOUT,
101 RESP_REJECTED_CHANNELS
102 } GP_RESPONSE_RESULT;
103
105 typedef std::map<uint32_t, bool> teach_id_map;
115 class eoTeachInModule : public eoISerialize
116 {
117
118 public:
124 eoTeachInModule(eoDeviceManager *eoDevManager, eoSecurity *sec);
125 virtual ~eoTeachInModule();
126
132 void SetRPS(uint8_t func, uint8_t type);
138 void Set1BS(uint8_t func, uint8_t type);
144 void Set4BS(uint8_t func, uint8_t type);
163 TEACH_RETURN TeachIN(eoMessage &m);
164
178 TEACH_RETURN TeachIN(uint8_t rorg,uint8_t func,uint8_t type,uint32_t device_id);
179
184 void TeachOut(uint32_t id);
190 static bool isTeachIN(eoMessage &telegram);
196 bool isTeachedIN(eoMessage &telegram) ;
202 bool isTeachedIN(eoDevice &dev) ;
208 eoReturn ParseUTE (eoMessage &msg);
217 eoReturn CreateUTEResponse (eoMessage &teachInUTE, eoMessage &responseUTE, UTE_RESPONSE type, UTE_DIRECTION direction);
218
228 eoReturn CreateGPResponse (eoMessage &msg, uint16_t manId, uint32_t destinationId, GP_RESPONSE_RESULT response, eoProfile *profile);
229
235 virtual uint8_t Serialize(eoArchive &arch);
236
237 private:
238 teach_id_map teachInformation;
239 eoSecurity *security;
240 eoDeviceManager * deviceManager;
241 uint8_t rps_func, rps_type, bs1_func, bs1_type, bs4_func, bs4_type, ute_rorg, ute_func, ute_type;
242
243 };
247 #endif // !defined(EA_62DB5BA2_ABF0_41c3_9291_81B05C9C37AD__INCLUDED_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoTelegram.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoTelegram.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EO_TELERGAM_H_
34 #define EO_TELERGAM_H_
35
36 #include "eoMessage.h"
42 class eoTelegram: public eoMessage
43 {
44
45 public:
50 eoTelegram(const eoTelegram& telegram);
55 eoTelegram(uint16_t size);
56 virtual ~eoTelegram();
57
58 public:
59 virtual void Clear();
60 //uint8_t status;
62 int8_t dBm;
64 uint8_t subtelCount;
65
66 };
67 #endif // !defined(EO_TELERGAM_H_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoTimer.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoTimer.h
Go to the documentation of this file.
1
7 #ifndef EO_TIMER_H
8 #define EO_TIMER_H
9 #include "eoHalTypes.h"
10
15 class eoTimer
16 {
17
18 public:
19 eoTimer();
20 virtual ~eoTimer();
25 static uint32_t GetTickCount();
26
31 static void Sleep(uint32_t ms);
32 };
33
34 #endif // !defined(EO_TIMER_H)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/eoVersion.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
eoVersion.h
1 #ifndef EOVERSION_H_
2 #define EOVERSION_H_
3
4 #define EOLINK_VERSION_MAIN 1
5
6 #define EOLINK_VERSION_BETA 7
7
8 #define EOLINK_VERSION_ALPHA 0
9
10 #define EOLINK_VERSION_POINT 0
11 #endif //__AUTOBUILD_H__
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoWatcher.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoWatcher.h
Go to the documentation of this file.
1
8 #include "eoDevice.h"
9 #include "eoTimer.h"
10 #include "eoIWatcher.h"
11 #ifndef EOWATCHER_H_
12 #define EOWATCHER_H_
13 #include <vector>
14 #include <map>
15 #include <stdint.h>
17 typedef enum
18 {
20 WATCH_OK = 0,
22 WATCH_DEVICE_NA,
24 WATCH_DEVICE_ALREADY_EXIST,
26 WATCH_NOT_SECURE_DEVICE,
28 WATCH_NOT_WATCHED_DEVICE,
30 WATCH_DOS_ASSUMED,
32 WATCH_DELAY_ASSUMED,
34 WATCH_TEL_TO_EARLY,
36 WATCH_TEL_TO_LATE,
38 WATCH_CMAC_OVERFLOW,
40 WATCH_RLC_OVERFLOW
41
42 } EO_SEC_WATCH_RESULT;
43
44
46 typedef struct
47 {
49 uint32_t maxRLCDiff;
51 uint32_t minPeriodTime;
53 uint32_t maxPeriodTime;
55 uint32_t timeLastTelegram;
57 uint32_t wrongCMACUsages;
59 uint32_t maxWrongCmac;
61 bool resetPeriod;
62 } WATCH_STRUCT;
63
64 typedef std::map<uint32_t, WATCH_STRUCT> watcher_id_map;
79 class eoWatcher : public eoIWatcher
80 {
81 public:
82 eoWatcher();
91 eoWatcher(uint32_t denialWarnCount,uint32_t denialTickBetween);
111 EO_SEC_WATCH_RESULT AddDevice(uint32_t const DeviceID,uint32_t const maxPerdiodTime,uint32_t const minPeriodTime,uint32_t const maxRLCDiff,uint32_t const maxWrongCmac,bool resetPeriod);
126 EO_SEC_WATCH_RESULT UpdateDevice(uint32_t const DeviceID,uint32_t const maxPerdiodTime,uint32_t const minPeriodTime,uint32_t const maxRLCDiff,uint32_t const maxWrongCmac,bool resetPeriod);
134 void RemoveDevice(uint32_t const DeviceID);
144 uint32_t CheckSecurity(eoDevice const * const device,eoTelegram const &tel);
145
153 EO_SEC_WATCH_RESULT Reset(uint32_t const DeviceID);
163 bool CheckDeadDevices(std::vector<uint32_t> &deadDevicesVector);
164
169 void SetDenialWarnCount(uint32_t const warnCount){denialWarnCount=warnCount;}
174 uint32_t GetDenialWarnCount() const{return denialWarnCount;}
179 void SetDenialTickBetween(uint32_t const tickCount){denialTickBetween=tickCount;}
184 uint32_t GetDenialTickBetween() const{return denialTickBetween;}
185 uint8_t Serialize(eoArchive &arch);
186 virtual ~eoWatcher();
187 private:
189 uint32_t denialCounter;
191 uint32_t tickOfLastTelegram;
192
194 uint32_t denialWarnCount;
196 uint32_t denialTickBetween;
198 watcher_id_map watchedMap;
204 EO_SEC_WATCH_RESULT DeviceCheck(eoDevice const * const device);
205 };
206
207 #endif /* EOWATCHER_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoWatcherFactory.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoWatcherFactory.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EOWATCHERFACTORY_H_
34 #define EOWATCHERFACTORY_H_
35
36 #include "eoIWatcher.h"
37
42 class eoWatcherFactory
43 {
44 public:
45 eoWatcherFactory();
46 virtual ~eoWatcherFactory();
51 static eoIWatcher * CreateWatcher(uint8_t type);
52
53 };
54
55 #endif /* EOFILTERFACTORY_H_ */
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eoWin32PacketStream.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eoWin32PacketStream.h
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #ifndef EO_WIN32_PACKET_STREAM_H_
34 #define EO_WIN32_PACKET_STREAM_H_
35
36 #include "eoPacketStream.h"
37 #include <windows.h>
38
45 class eoWin32PacketStream: public eoPacketStream
46 {
47
48 public:
49 eoWin32PacketStream();
50 virtual ~eoWin32PacketStream();
56 eoReturn Open(const char * port);
60 void Close();
64 DWORD GetLastError(){ return error;};
65 eoReturn ReceiveByte(uint8_t* u8RxByte);
66 eoReturn SendByte(uint8_t u8TxByte);
67 private:
68 int fd;
69 static const uint8_t buffSize = 128;
70 DWORD error;
71 uint8_t buf[buffSize];
72 uint8_t numBytes;
73 uint8_t curByte;
74 HANDLE portOpen;
75 COMMTIMEOUTS m_Comtimeout;
76 DCB DCBParam;
77
78 };
79 #endif // !defined(EO_WIN32_PACKET_STREAM_H_)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/Includes/eodBmFilter.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
  • Includes
eodBmFilter.h
Go to the documentation of this file.
1 /******************************************************************************
2 DISCLAIMER
3
4 THIS SOFTWARE PRODUCT ("SOFTWARE") IS PROPRIETARY TO ENOCEAN GMBH, OBERHACHING,
5 GERMANY (THE "OWNER") AND IS PROTECTED BY COPYRIGHT AND INTERNATIONAL TREATIES OR
6 PROTECTED AS TRADE SECRET OR AS OTHER INTELLECTUAL PROPERTY RIGHT. ALL RIGHTS, TITLE AND
7 INTEREST IN AND TO THE SOFTWARE, INCLUDING ANY COPYRIGHT, TRADE SECRET OR ANY OTHER
8 INTELLECTUAL PROPERTY EMBODIED IN THE SOFTWARE, AND ANY RIGHTS TO REPRODUCE,
9 DISTRIBUTE, MODIFY, DISPLAY OR OTHERWISE USE THE SOFTWARE SHALL EXCLUSIVELY VEST IN THE
10 OWNER. ANY UNAUTHORIZED REPRODUCTION, DISTRIBUTION, MODIFICATION, DISPLAY OR OTHER
11 USE OF THE SOFTWARE WITHOUT THE EXPLICIT PERMISSION OF OWNER IS PROHIBITED AND WILL
12 CONSTITUTE AN INFRINGEMENT OF THE OWNER'S RIGHT AND MAY BE SUBJECT TO CIVIL OR
13 CRIMINAL SANCTION.
14
15 THIS SOFTWARE IS PROVIDED BY THE OWNER "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
16 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
17 FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN PARTICULAR, THE OWNER DOES NOT WARRANT
18 THAT THE SOFTWARE SHALL BE ERROR FREE AND WORKS WITHOUT INTERRUPTION.
19
20 IN NO EVENT SHALL THE OWNER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
21 EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
22 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
23 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
24 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
25 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
26 ******************************************************************************/
27
33 #if !defined(EO_DBM_FILTER_H)
34 #define EO_DBM_FILTER_H
35
36 #include "eoIFilter.h"
37 #include <set>
38
50 class eodBmFilter: public eoIFilter
51 {
52 private:
53 std::set<uint32_t> idset;
54 public:
55
59 eodBmFilter();
60
66 eodBmFilter(int8_t maxDBm, int8_t minDBm);
67 virtual ~eodBmFilter();
68
74 bool Filter(eoMessage &msg);
75
81 bool Filter(eoTelegram &tel);
82
83 public:
84
85 virtual uint8_t Serialize(eoArchive &arch);
87 int8_t maxdBm;
89 int8_t mindBm;
90
91 };
96 #endif // !defined(EO_DBM_FILTER_H)
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };
/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };
/* Class not documented with doxygen comments */
class Undocumented { };
/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };
/*! A template class */
template<class T> class Templ { };
/*! Class that is inherited using protected inheritance */
class ProtectedBase { };
/*! Class that is inherited using private inheritance */
class PrivateBase { };
/*! Class that is used by the Inherited class */
class Used { };
/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
protected ProtectedBase,
private PrivateBase,
public Undocumented,
public Templ<int>
{
private:
Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Related Pages

Related Pages
Here is a list of all related documentation pages:
[detail level 12]
o Compile
o Changelog
o References
o Step by Step
o Testing EnOcean Link
o Trial License Agreement
\ Tutorials
  o Tutorial 1
  o Tutorial 2
  o Tutorial 3
  o Tutorial 4
  o Tutorial 5
  o Tutorial 6
  \ Security Watcher Example
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/stdafx.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
stdafx.h
1 // stdafx.h : include file for standard system include files,
2 // or project specific include files that are used frequently, but
3 // are changed infrequently
4 //
5
6 #pragma once
7
8 #include "targetver.h"
9
10 #define WIN32_LEAN_AND_MEAN // Exclude rarely-used stuff from Windows headers
11
12
13
14 // TODO: reference additional headers your program requires here
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

CO_RD_DUTYCYCLE_RESPONSE Member List

This is the complete list of members for CO_RD_DUTYCYCLE_RESPONSE, including all inherited members.

availableCycle | CO_RD_DUTYCYCLE_RESPONSE
loadAfterCycle | CO_RD_DUTYCYCLE_RESPONSE
numOfSlots | CO_RD_DUTYCYCLE_RESPONSE
slotPeriod | CO_RD_DUTYCYCLE_RESPONSE
slotPeriodLeft | CO_RD_DUTYCYCLE_RESPONSE
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

DEVICE_CONFIG Member List

This is the complete list of members for DEVICE_CONFIG, including all inherited members.

index | DEVICE_CONFIG
length | DEVICE_CONFIG
rawValue | DEVICE_CONFIG
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

EEP_ITEM Member List

This is the complete list of members for EEP_ITEM, including all inherited members.

bitoffs | EEP_ITEM
bitsize | EEP_ITEM
exist | EEP_ITEM
index | EEP_ITEM
rangeMax | EEP_ITEM
rangeMin | EEP_ITEM
scaleMax | EEP_ITEM
scaleMin | EEP_ITEM
type | EEP_ITEM
Generated on Wed Nov 18 2015 17:24:48 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

FLASH_READ_RESPONSE Member List

This is the complete list of members for FLASH_READ_RESPONSE, including all inherited members.

data FLASH_READ_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

LEARNED_SENSOR_RESPONSE Member List

This is the complete list of members for LEARNED_SENSOR_RESPONSE, including all inherited members.

controllerID | LEARNED_SENSOR_RESPONSE
learnedCount | LEARNED_SENSOR_RESPONSE
sensorID | LEARNED_SENSOR_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

LINK_TABLE Member List

This is the complete list of members for LINK_TABLE, including all inherited members.

channel | LINK_TABLE
EEP_FUNC | LINK_TABLE
EEP_RORG | LINK_TABLE
EEP_TYPE | LINK_TABLE
ID | LINK_TABLE
index | LINK_TABLE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

MAILBOX_SETTINGS_RESPONSE Member List

This is the complete list of members for MAILBOX_SETTINGS_RESPONSE, including all inherited members.

flashAddress | MAILBOX_SETTINGS_RESPONSE
mailboxCount | MAILBOX_SETTINGS_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

PING_RESPONSE Member List

This is the complete list of members for PING_RESPONSE, including all inherited members.

func | PING_RESPONSE
rorg | PING_RESPONSE
rssi | PING_RESPONSE
type | PING_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

QUERY_APPLY_CHANGES Member List

This is the complete list of members for QUERY_APPLY_CHANGES, including all inherited members.

configChanges | QUERY_APPLY_CHANGES
linkTableChanges | QUERY_APPLY_CHANGES
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

QUERY_DEVICE_CONFIG Member List

This is the complete list of members for QUERY_DEVICE_CONFIG, including all inherited members.

endIndex | QUERY_DEVICE_CONFIG
length | QUERY_DEVICE_CONFIG
startIndex | QUERY_DEVICE_CONFIG
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

QUERY_FUNCTION_RESPONSE Member List

This is the complete list of members for QUERY_FUNCTION_RESPONSE, including all inherited members.

functionNum | QUERY_FUNCTION_RESPONSE
manufaturerID | QUERY_FUNCTION_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

QUERY_ID Member List

This is the complete list of members for QUERY_ID, including all inherited members.

func | QUERY_ID
rorg | QUERY_ID
type | QUERY_ID
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

QUERY_LINK_BASED_CONFIG Member List

This is the complete list of members for QUERY_LINK_BASED_CONFIG, including all inherited members.

endIndex | QUERY_LINK_BASED_CONFIG
length | QUERY_LINK_BASED_CONFIG
startIndex | QUERY_LINK_BASED_CONFIG
tableDir | QUERY_LINK_BASED_CONFIG
tableIndex | QUERY_LINK_BASED_CONFIG
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

QUERY_LINK_TABLE Member List

This is the complete list of members for QUERY_LINK_TABLE, including all inherited members.

endIndex | QUERY_LINK_TABLE
startIndex | QUERY_LINK_TABLE
tableDir | QUERY_LINK_TABLE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

QUERY_METADATA_RESPONSE Member List

This is the complete list of members for QUERY_METADATA_RESPONSE, including all inherited members.

inboundLinkTable | QUERY_METADATA_RESPONSE
lenghtOfInbound | QUERY_METADATA_RESPONSE
lengthOfOutbound | QUERY_METADATA_RESPONSE
maxOfInbound | QUERY_METADATA_RESPONSE
maxOfOutbound | QUERY_METADATA_RESPONSE
outboundLinkTable | QUERY_METADATA_RESPONSE
remoteTeachInbound | QUERY_METADATA_RESPONSE
remoteTeachOutbound | QUERY_METADATA_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

QUERY_PRODUCT_ID_RESPONSE Member List

This is the complete list of members for QUERY_PRODUCT_ID_RESPONSE, including all inherited members.

manufacturerId | QUERY_PRODUCT_ID_RESPONSE
productReference | QUERY_PRODUCT_ID_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

QUERY_RADIO_LINK_TEST Member List

This is the complete list of members for QUERY_RADIO_LINK_TEST, including all inherited members.

isEnabled | QUERY_RADIO_LINK_TEST
numOfRLT | QUERY_RADIO_LINK_TEST
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

QUERY_RESET_DEFAULTS Member List

This is the complete list of members for QUERY_RESET_DEFAULTS, including all inherited members.

configParam | QUERY_RESET_DEFAULTS
inboundTable | QUERY_RESET_DEFAULTS
outboundTable | QUERY_RESET_DEFAULTS
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

QUERY_SET_LEARN_MODE Member List

This is the complete list of members for QUERY_SET_LEARN_MODE, including all inherited members.

inboundIndex | QUERY_SET_LEARN_MODE
mode | QUERY_SET_LEARN_MODE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

QUERY_SET_REPEATER_FILTER Member List

This is the complete list of members for QUERY_SET_REPEATER_FILTER, including all inherited members.

repeaterFunc | QUERY_SET_REPEATER_FILTER
repeaterLevel | QUERY_SET_REPEATER_FILTER
value | QUERY_SET_REPEATER_FILTER
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

QUERY_STATUS_RESPONSE Member List

This is the complete list of members for QUERY_STATUS_RESPONSE, including all inherited members.

codeSetFlag | QUERY_STATUS_RESPONSE
lastFunc | QUERY_STATUS_RESPONSE
lastFuncRet | QUERY_STATUS_RESPONSE
lastSEQ | QUERY_STATUS_RESPONSE
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

SA_CONFIRM_LEARN_REQUEST Member List

This is the complete list of members for SA_CONFIRM_LEARN_REQUEST, including all inherited members.

eep | SA_CONFIRM_LEARN_REQUEST
hopCount | SA_CONFIRM_LEARN_REQUEST
manufacturerID | SA_CONFIRM_LEARN_REQUEST
postmasterID | SA_CONFIRM_LEARN_REQUEST
priPostmaster | SA_CONFIRM_LEARN_REQUEST
rssi | SA_CONFIRM_LEARN_REQUEST
smartAckID | SA_CONFIRM_LEARN_REQUEST
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: Member List

WATCH_STRUCT Member List

This is the complete list of members for WATCH_STRUCT, including all inherited members.

maxPeriodTime | WATCH_STRUCT
maxRLCDiff | WATCH_STRUCT
maxWrongCmac | WATCH_STRUCT
minPeriodTime | WATCH_STRUCT
resetPeriod | WATCH_STRUCT
timeLastTelegram | WATCH_STRUCT
wrongCMACUsages | WATCH_STRUCT
Generated on Wed Nov 18 2015 17:24:50 for EnOcean Link by doxygen 1.8.1.1


EnOcean Link: E:/Autobuild/EOLink/SourceCode/EOLink/targetver.h Source File

  • File List
  • File Members
  • SourceCode
  • EOLink
targetver.h
1 #pragma once
2
3 // Including SDKDDKVer.h defines the highest available Windows platform.
4
5 // If you wish to build your application for a previous Windows platform, include WinSDKVer.h and
6 // set the _WIN32_WINNT macro to the platform you wish to support before including SDKDDKVer.h.
7
8 #include <SDKDDKVer.h>
Generated on Wed Nov 18 2015 17:24:47 for EnOcean Link by doxygen 1.8.1.1