welcome

GLScene

OpenGL Solution for Delphi,
C++Builder & Lazarus

Maintained by Eric Grange and GLS Team, based on Mike Lischke's GLScene

Website: http://glscene.org

Project page:http://sourceforge/projects/glscene/

GLScene is an OpenGL based 3D library for Delphi, C++Builder and Lazarus. It provides visual components and objects allowing description and rendering of 3D scenes in an easy, no-hassle, yet powerfull manner. GLScene runs on Windows, Linux, Mac OS X, FreeBSD and more platforms.

GLScene is not just an OpenGL wrapper or library of utilities, it has grown to become a set of founding classes for a generic 3D engine with Rapid Application Development in mind. GLScene allows you to quickly design and render 3D scenes without having to learn the intricacies of OpenGL, if you know how to design form applications, you'll easily master the basic operations of TGLScene. The library comes with a large collections of demos showcasing the ease of use, and demonstrating RAD wasn't done at the expense of CPU/GPU horsepower.

GLScene is released to the public as open-source under Mozilla Public Licence .


GLScene v.1.1.2: All Units

All Units

Name | Description
AnimationUtils
ApplicationFileIO ApplicationFileIO<p>

Components and fonction that abstract file I/O access for an application.<br> Allows re-routing file reads to reads from a single archive file f.i.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPPB compatibility: used TAFIOFileStreamEvent as procedure instead of function for GLS_CPPB <li>25/08/10 - DaStr - Fixed compiler warnings <li>25/07/10 - Yar - Added TGLSResourceStream class and CreateResourceStream string <li>23/01/10 - Yar - Change LoadFromStream to dynamic <li>29/01/07 - DaStr - Moved registration to GLSceneRegister.pas <li>02/08/04 - LR, YHC - BCB corrections: fixed BCB Compiler error "E2370 Simple type name expected" <li>05/06/03 - EG - TDataFile moved in from GLMisc <li>31/01/03 - EG - Added FileExists mechanism <li>21/11/02 - EG - Creation </ul></font>

AsyncTimer
BaseClasses Base classes for GLScene.<p>

<b>History : </b><font size=-1><ul> <li>24/03/11 - Yar - Added Notification method to TGLUpdateAbleObject <li>05/10/08 - DanB - Creation, from GLMisc.pas + other places </ul></font>

Bass
BumpMapping Some useful methods for setting up bump maps.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records with arrays <li>08/07/04 - LR - Replace Graphics by GLCrossPlatform for Linux <li>30/03/04 - SG - Minor optimizations <li>22/09/03 - SG - Partially fixed tangent space normal map creation, Fixed normal blending coefficients <li>18/09/03 - SG - Added methods for creating normal maps, CreateTangentSpaceNormalMap is a little buggy <li>28/07/03 - SG - Creation </ul></font>

cgGL
CGPostTransformationShader CGPostTransformationShader<p>

A shader that uses a texture to distort the view by adjusting texture coordinates. Does not have any practical use, but is fun to play around with.<p>

<b>History : </b><font size=-1><ul> <li>22/04/10 - Yar - Fixes after GLState revision <li>05/04/07 - DaStr - Contributed to GLScene <li>04/11/06 - DaStr - Creation (based on demo by Rick)

Const3DS
CurvesAndSurfaces CurvesAndSurfaces<p>

Bezier and B-Spline Curve and Surface Routines.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>31/03/07 - DaStr - Added $I GLScene.inc <li>11/05/04 - SG - Some fixes for BSpline calculations (rational BSplines are still still broken). Minor knot vector changes. <li>20/08/03 - SG - Removed weights realizing it's an inefficient way to do things, control points should be weighted before being used to calculate a surface or curve. <li>18/08/03 - SG - Added weights to calculations. <li>17/07/03 - SG - Added surface routines. Minor changes to procedure parameters. <li>10/07/03 - SG - Creation </ul></font>

DDSImage DDSImage<p> Alternative for DDS unit with more supported formats of flat image: Alpha8, Luminance8, R3G3B2, RGB5A1, RGBA4, Alpha8Luminance8, Luminance16, R5G6B5, RGB8, R10G10B10A2, RGBA8, RGBA16, R16F, RGBA16F, R32F, RGBA32F, GR16, GR16F, GR32F, Compressed RGB S3TC DXT1, Compressed RGBA S3TC DXT1, Compressed RGBA S3TC DXT3, Compressed RGBA S3TC DXT5 But it down color to RGBA8 because becomes to TGLBitmap Good for preview picture in OpenDialog, so you may include both DDSImage (preview) and GLFileDDS (loading)

<b>History : </b><font size=-1><ul> <li>23/10/10 - Yar - Removed PBuffer <li>23/08/10 - Yar - Changes after PBuffer upgrade <li>20/05/10 - Yar - Fixes for Linux x64 <li>21/03/10 - Yar - Added Linux support (thanks to Rustam Asmandiarov aka Predator) <li>24/01/10 - Yar - Improved FPC compatibility <li>21/01/10 - Yar - Creation </ul><p>

dws2Classes DelphiWebScriptII symbol creation for base Delphi classes.<p>

<b>History : </b><font size=-1><ul> <li>27/04/2004 - SG - Creation </ul></font>

dws2GLScene DelphiWebScriptII symbol creation for base GLScene classes.<p>

This unit is dependent on dws2Classes and dws2VectorGeometry. These components must be associated with the same compiler for the GLScene classes to inherit from.<p>

<b>History : </b><font size=-1><ul> <li>27/04/2004 - SG - Creation </ul></font>

dws2HelperFunc Helper functions for creating class, properties and method symbols in DelphiWebScriptII.<p>

<b>History : </b><font size=-1><ul> <li>27/04/2004 - SG - Creation </ul></font>

dws2OpenGLAdapter DelphiWebScriptII symbol creation for OpenGL procedures and functions.<p>

This unit is still under development.<p>

<b>History : </b><font size=-1><ul> <li>16/01/2011 - Yar - Rename to dws2OpenGLAdapter, update to current main package <li>08/10/2008 - DanB - Split AddUnitSymbols into two procedures, to prevent error <li>23/09/2004 - SG - Added main GL constants and a few procedures <li>21/09/2004 - SG - Creation </ul></font>

dws2VectorGeometry DelphiWebScriptII symbol creation for VectorGeometry types and functions.<p>

<b>History : </b><font size=-1><ul> <li>27/04/2004 - SG - Creation </ul></font>

DXTC DXTC<p>

DXTC (also S3TC) decoding.<br> Adapted from DevIL image library (http://openil.sourceforge.net)<p>

<b>History : </b><font size=-1><ul> <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>05/03/10 - Yar - Added float types in GLEnumToDDSHeader <li>23/01/10 - Yar - Added more support DX9 DDS color formats and DX11 DXGI constants to future <li>31/03/07 - DaStr - Added $I GLScene.inc <li>03/09/04 - SG - Delphi 5 compatibilty fixes (Ivan Lee Herring) <li>01/09/04 - SG - Creation </ul></font>

FGUILayoutEditor
File3DS
FileB3D FileB3D<p>

File streaming class for the B3D loader<p>

<b>History :</b><font size=-1><ul> <li>24/07/09 - DaStr - Got rid of compiler hints <li>29/05/08 - DaStr - Added $I GLScene.inc <li>22/12/05 - Mathx - Added to the GLScene Project. </ul></font>

FileGL2 FileGL2<p>

Ghoul2 (GLM/GLA) file format loading structures<p>

Note: Also referred to as MDX (MDXM/MDXA) format in C source.<p>

<b>History :</b><font size=-1><ul> <li>09/05/03 - SG - Fixed compressed bone pool <li>01/04/03 - SG - Finished GLM/GLA loading procedures <li>25/03/03 - SG - Creation </ul></font>

FileMD2 FileMD2<p>

MD2 file loader<p>

<b>Historique : </b><font size=-1><ul> <li>28/08/10 - Yar - Bugfix for FPC 2.5.1 (Thanks Predator) <li>04/03/10 - DanB - TFileMD2.LoadFromStream now uses CharInSet <li>31/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>25/08/03 - Php - Added FreeLists & degibbered LoadFromStream <li>21/07/00 - Egg - Added frame names (Roger Cao/Carlos A. Rivero) <li>07/06/00 - Egg - Added Header, reduced dependencies, LoadFromFile replaced with LoadFromStream, some cleanup & optimizations </ul></font>

FileMD3
FileNMF
FileOCT FileOCT<p>

Loader for FSRad OCT files.<p>

<b>History : </b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>02/04/07 - DaStr - Added $I GLScene.inc <li>30/01/03 - Egg - Creation </ul></font>

FileX FileX<p>

Simple X format support for Delphi (Microsoft's favorite format)<p>

<b>History : </b><font size=-1><ul> <li>04/10/10 - Yar - Fixed TDXFileHeader type (thanks JironBach) <li>07/11/09 - DaStr - Initial version (Added from the GLScene-Lazarus SVN) </ul></font>

FLibMaterialPicker Egg<p>

Allows choosing a material in a material library<p>

<b>Historique : </b><font size=-1><ul> <li>05/09/08 - DanB - Removed Kylix support <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>19/12/06 - DaStr - LBMaterials.OnDblClick now handled <li>03/07/04 - LR - Make change for Linux <li>14/02/00 - Egg - Creation </ul></font>

FLibMaterialPickerLCL Egg<p>

Allows choosing a material in a material library<p>

<b>Historique : </b><font size=-1><ul>

</ul></font>

FMaterialEditorForm FMaterialEditorForm<p>

Editor window for a material (with preview).<p>

<b>Historique : </b><font size=-1><ul> <li>07/05/10 - Yar - Fixed PolygonMode and texture image class lookup <li>05/10/08 - DanB - Removed Kylix support <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>19/12/06 - DaStr - All comboboxes get their Items using RTTI (thanks to dikoe Kenguru for the reminder and Roman Ganz for the code) <li>03/07/04 - LR - Make change for Linux <li>24/03/00 - Egg - Added Blending <li>06/02/00 - Egg - Creation </ul></font>

FMaterialEditorFormLCL FMaterialEditorForm<p>

Editor window for a material (with preview).<p>

<b>Historique : </b><font size=-1><ul> <li>08/06/10 - Yar - Bugfixed asignment edition result to material </ul></font>

fmod
fmoddyn
fmoderrors
fmodpresets
fmodtypes
FRColorEditor FRColorEditor<p>

RGB+Alpha color editor.<p>

<b>Historique : </b><font size=-1><ul> <li>24/04/09 - DanB - removed some ifdef MSWINDOWS, which were actually for Kylix <li>05/09/08 - DanB - Removed Kylix support <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>03/07/04 - LR - Make change for Linux <li>06/02/00 - Egg - Creation </ul></font>

FRColorEditorLCL FRColorEditor<p>

RGB+Alpha color editor.<p>

<b>Historique : </b><font size=-1><ul>

</ul></font>

FRFaceEditor FRFaceEditor<p>

Editor fram for a TGLFaceProperties.<p>

<b>Historique : </b><font size=-1><ul> <li>05/09/08 - DanB - Removed Kylix support <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>19/12/06 - DaStr - TRFaceEditor.SetGLFaceProperties bugfixed - Shiness and PoligonMode are now updated when FaceProperties are assigned <li>03/07/04 - LR - Make change for Linux <li>06/02/00 - Egg - Creation </ul></font>

FRFaceEditorLCL FRFaceEditor<p>

Editor fram for a TGLFaceProperties.<p>

<b>Historique : </b><font size=-1><ul>

</ul></font>

FRMaterialPreview FRMaterialPreview<p>

Material Preview frame.<p>

<b>Historique : </b><font size=-1><ul> <li>12/07/07 - DaStr - Improved Cross-Platform compatibility (Bugtracker ID = 1684432) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>16/12/06 - DaStr - Editor enhanced <li>03/07/04 - LR - Make change for Linux <li>06/02/00 - Egg - Creation </ul></font>

FRMaterialPreviewLCL
FRTextureEdit
FRTextureEditLCL
FRTrackBarEdit FRTrackBarEdit<p>

Frame combining a TrackBar and an Edit.<p>

<b>Historique : </b><font size=-1><ul> <li>05/10/08 - DanB - Removed Kylix support <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>19/12/06 - DaStr - Fixed bug in SetValue, SetValueMin, SetValueMax when changing these values didn't change the Edit's Text <li>03/07/04 - LR - Make change for Linux <li>06/02/00 - Egg - Creation </ul></font>

FRTrackBarEditLCL FRTrackBarEdit<p>

Frame combining a TrackBar and an Edit.<p>

<b>Historique : </b><font size=-1><ul>

</ul></font>

FRUniformEditor FRUniformEditor<p>

<b>History : </b><font size=-1><ul> <li>23/03/11 - Yar - Creation </ul>

FShaderMemo
FVectorEditor FVectorEditor<p>

Editor for a vector.<p>

<b>Historique : </b><font size=-1><ul> <li>05/10/08 - DanB - Removed Kylix support <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>03/07/04 - LR - Make change for Linux <li>?/?/? - - Creation </ul></font>

FVectorEditorLCL FVectorEditor<p>

Editor for a vector.<p>

<b>Historique : </b><font size=-1><ul>

</ul></font>

FXCollectionEditor
FXCollectionEditorLCL Egg<p>

Edits a TXCollection<p>

<b>Historique : </b><font size=-1><ul> <li>20/05/10 - Yar - Fixes for Linux x64 <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>03/07/04 - LR - Make change for Linux <li>12/07/03 - DanB - Fixed crash when owner deleted <li>27/02/02 - Egg - Fixed crash after item deletion <li>11/04/00 - Egg - Fixed crashes in IDE <li>06/04/00 - Egg - Creation </ul></font>

GeometryBB
GeometryCoordinates GeometryCoordinates<p>

Helper functions to convert between different three dimensional coordinate systems. Room for optimisations.<p>

<b>History : </b><font size=-1><ul> <li>30/04/03 - EG - Hyperbolic functions moved to VectorGeometry.pas <li>30/04/03 - ARH - Remove math.pas dependency <li>24/04/03 - ARH - Double versions added <li>10/04/03 - ARH - Added ProlateSpheroidal,OblateSpheroidal, BiPolarCylindrical <li>09/04/03 - ARH - Initial Version (Cylindrical,Spherical) </ul>

GLAnimatedSprite GLAnimatedSprite<p>

A sprite that uses a scrolling texture for animation.<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>10/04/08 - DaStr - Added a Delpi 5 interface bug work-around to TSpriteAnimation (BugTracker ID = 1938988) <li>25/03/07 - DaStr - Added GLCrossPlatform to uses for Delphi5 compatibility <li>14/03/07 - DaStr - Added IGLMaterialLibrarySupported to TSpriteAnimation Published TGLAnimatedSprite.Visible Fixed TGLAnimatedSprite.SetMaterialLibrary (subcribed for notification) <li>21/07/04 - SG - Added Margins to Animations, Added comments. <li>20/07/04 - SG - Added FrameRate (alternative for Interval), Added Interval to Animations, will override sprite interval if not equal to zero. Some minor fixes. <li>13/07/04 - SG - Creation </ul></font>

GLAsmShader GLAsmShader<p>

TGLAsmShader is a wrapper for all ARB shaders<p> This component is only a template and has to be replaced with a proper version by someone who uses ARB shaders more then me.

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Upgraded program hadles <li>04/06/10 - Yar - Replace OpenGL functons to OpenGLAdapter <li>28/07/09 - DaStr - Added GeomertyShader support (thanks YarUnderoaker) <li>24/07/09 - DaStr - TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) <li>20/03/07 - DaStr - TGLCustomAsmShader now generates its own events All outside stuff moved back to TGLPhongShader <li>22/02/07 - DaStr - Initial version (contributed to GLScene)

Previous version history: v1.0 12 March '2005 Creation v1.1 31 October '2006 TGLCustomAsmShader.DoUnApply() Fix TGLAsmShader has more stuff in the published section

GLAsyncHDS GLAsyncHDS<p>

Implements a HDS Filter that generates HeightData tiles in a seperate thread.<p>

This component is a THeightDataSourceFilter, which uses a THeightDataSourceThread, to asyncronously search the HeightData cache for any queued tiles. When found, it then prepares the queued tile in its own THeightDataThread.

This allows the GUI to remain responsive, and prevents freezes when new tiles are being prepared. Although this keeps the framerate up, it may cause holes in the terrain to show, if the HeightDataThreads cant keep up with the TerrainRenderer's requests for new tiles. <p>

<b>History : </b><font size=-1><ul> <li>22/04/10 - Yar - Fixes after GLState revision <li>11/10/07 - DaStr - Added $I GLScene.inc, removed unused dependancy <li>25/03/07 - DaStr - Replaced Dialogs with GLCrossPlatform for Delphi5 compatibility <li>22/03/07 - LIN - Added UseDirtyTiles property - Specifies how dirty tiles are replaced. <li>22/03/07 - LIN - Data is now prepared in 3 stages: BeforePreparingData : (Main Thread) PreparingData : (Sub-Thread) (Main Thread if MaxThreads=0) AfterPreparingData : (Main Thread) <li>05/03/07 - LIN - Added ThreadCount and WaitFor <li>12/02/07 - LIN - Creation </ul></font>

GLAtmosphere GLAtmosphere <p>

This unit contains classes that imitate an atmosphere around a planet.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>19/03/11 - Yar - Added setters for Low and High atmosphere colors <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>03/04/07 - DaStr - Optimized TGLCustomAtmosphere.DoRender Fixed SetPlanetRadius and SetAtmosphereRadius <li>21/03/07 - DaStr - Cleaned up "uses" section (thanks Burkhard Carstens) (Bugtracker ID = 1684432) <li>01/03/07 - DaStr - Fixed TGLAtmosphereBlendingMode (old version did not generate RTTI) Added default values to all properties <li>15/02/07 - DaStr - Added TGLCustomAtmosphere.AxisAlignedDimensionsUnscaled <li>07/02/07 - DaStr - Initial version (donated to GLScene)

Comments: 1) Eats a lot of CPU (reduces FPS from 1240 to 520 on my PC with cSlices=100) 2) Alpha in LowAtmColor, HighAtmColor is ignored.

Previous version history: v1.0 06 February '2005 Creation (based on demo "Earth" by Eric Grange) v1.1 28 February '2005 Don't remmember what... v1.2 16 March '2005 Small improvements, including ability to load files using short (not full) paths v1.3 21 March '2005 Positioning bugfix!!! v1.4 3 October '2005 Camera parameter no longer needed "Enabled" is now a property LoadFromMemory added SaveToFile, SaveToMemory added Normal error message v1.5 4 November '2005 BlendingMode1,2 added TogleBlengindMode added LoadFromMemory bugfix v1.6 28 February '2006 Became a standard GLScene object, child of TglBaseSceneObject Range bug fixed, along with a bug, the caused Atmosphere to draw itseft incorrectly on some occasions Demo inhanced New Load/Save code v1.6.2 05 June '2006 Assign() added Alpha in LowAtmColor, HighAtmColor was removed from Loading/saving code v1.6.4 07 July '2006 All variables in the class converted into properties TStrangeCustomAtmosphere added v1.6.6 08 October '2006 Made compatible with the new persistance mechanism v1.7 22 October '2006 Notification() and SetSun() added v1.8 08 February '2007 TStrangeCustomAtmosphere.Assign fixed Blending mode Integer —> Enumeration Donated to GLScene

GLAVIRecorder GLAVIRecorder<p>

Component to make it easy to record GLScene frames into an AVI file<p>

<b>History : </b><font size=-1><ul> <li>12/07/07 - DaStr - Improved Cross-Platform compatibility (Bugtracker ID = 1684432) <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTracekrID=1681585) <li>29/01/07 - DaStr - Moved registration to GLSceneRegister.pas <li>01/06/05 - NelC - Replaced property GLFullScreenViewer with GLNonVisualViewer <li>26/01/05 - JAJ - Can now operate with a GLFullScreenViewer <li>22/10/04 - EG - Can now operate without a SceneViewer <li>13/05/04 - EG - Added irmBitBlt mode (now the default mode) <li>05/01/04 - EG - Added Recording function and ability to record arbitrary bitmap, Added OnPostProcessEvent <li>08/07/03 - NelC - Fixed access violation on exit (thx Solerman Kaplon) and minor updates <li>11/12/01 - EG - Minor changes for compatibility with JEDI VfW.pas <li<02/03/01 - EG - Added TAVIImageRetrievalMode <li>24/02/01 - NelC - Creation and initial code </ul></font>

GLBaseMeshSilhouette
GLBehaviours GLBehaviours<p>

Standard TGLBehaviour subclasses for GLScene<p>

<b>History : </b><font size=-1><ul> <li>08/05/08 - DaStr - Added a global GetInertia() function <li>19/12/06 - DaStr - TGLBAcceleration.Create - creates Inertia right away, thus displaying it in the XCollection Editor TGLBAcceleration.DoProgress - raises an exception when required Inertia component is deleted by user <li>24/09/02 - Egg - Support for negative rotation speeds (Marco Chong) <li>02/10/00 - Egg - Fixed TGLBInertia.DoProgress (DamplingEnabled bug) <li>09/10/00 - Egg - Fixed ApplyTranslationAcceleration & ApplyForce <li>11/08/00 - Egg - Fixed translation bug with root level objects & Inertia <li>10/04/00 - Egg - Improved persistence logic <li>06/04/00 - Egg - Added Damping stuff to inertia <li>05/04/00 - Egg - Creation </ul></font>

GLBitmapFont GLBitmapFont<p>

Bitmap Fonts management classes for GLScene<p>

<b>History : </b><font size=-1><ul> <li>20/11/12 - PW - CPP compatibility: replaced direct access to some properties with records <li>01/09/11 - Yar - Bugfixed StartASCII, StopASCII properties for non-Unicode compiler <li>30/06/11 - DaStr - Bugfixed TBitmapFontRanges.Add(for AnsiChar) <li>16/05/11 - Yar - Redesign to use multiple textures (by Gabriel Corneanu) <li>13/05/11 - Yar - Adapted to unicode (by Gabriel Corneanu) <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>05/07/10 - Yar - Now HSpace and VSpace can take negative values (thanks Sandor Domokos) (BugtrackerID = 3024975) <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>24/02/10 - Yar - Bugfix in TGLCustomBitmapFont.PrepareImage when image is not RGBA8 <li>25/01/10 - Yar - Replace Char to AnsiChar <li>11/11/09 - DaStr - Added Delphi 2009 compatibility (thanks mal) <li>16/10/08 - UweR - Removed unneeded typecast in TBitmapFontRange.SetStartGlyphIdx <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>22/12/06 - LC - Fixed TGLCustomBitmapFont.RenderString, it now unbinds the texture. Bugtracker ID=1619243 (thanks Da Stranger) <li>09/03/05 - EG - Fixed space width during rendering <li>12/15/04 - Eugene Kryukov - Moved FCharRects to protected declaration in TGLCustomBitmapFont <li>18/10/04 - NelC - Fixed a texture reset bug in RenderString <li>02/08/04 - LR, YHC - BCB corrections: use record instead array <li>28/06/04 - LR - Change TTextLayout to TGLTextLayout for Linux <li>27/06/04 - NelC - Added TGLFlatText.Assign <li>01/03/04 - SG - TGLCustomBitmapFont.RenderString now saves GL_CURRENT_BIT state <li>01/07/03 - EG - TGLCustomBitmapFont.TextOut now saves and restore state <li>07/05/03 - EG - TGLFlatText Notification fix, added Options <li>30/10/02 - EG - Added TGLFlatText <li>29/09/02 - EG - Added TexCoords LUT, faster RenderString, removed TBitmapFontRange.Widths <li>28/09/02 - EG - Introduced TGLCustomBitmapFont <li>06/09/02 - JAJ - Prepared for TGLWindowsBitmapFont <li>28/08/02 - EG - Repaired fixed CharWidth, variable CharWidth not yet repaired <li>12/08/02 - JAJ - Merged Dual Development, Alpha Channel and CharWidth are now side by side <li>UNKNOWN - EG - Added Alpha Channel. <li>02/06/02 - JAJ - Modified to flexible character width <li>20/01/02 - EG - Dropped 'Graphics' dependency <li>10/09/01 - EG - Fixed visibility of tile 0 <li>12/08/01 - EG - Completely rewritten handles management <li>21/02/01 - EG - Now XOpenGL based (multitexture) <li>15/01/01 - EG - Creation </ul></font>

GLBlur GLBlur<p>

Applies a blur effect over the viewport.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>30/01/08 - Mrqzzz - Several changes to GLBlur. Added Advenced Blur. Looks good now :) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>06/04/07 - DaStr - Fixed TGLMotionBlur.InitializeObject - component can only be disabled in run-time <li>03/04/07 - DaStr - Optimized TGLMotionBlur.DoRender - now component checks for supported extensions only once <li>25/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>22/03/07 - DaStr - Added checks to TGLMotionBlur for supported extensions TGLMotionBlur is not rendered when picking now <li>25/02/07 - DaStr - Added DesignTime check in TGLMotionBlur.DoRender <li>23/02/07 - DaStr - TGLMotionBlur.StoreIntensity bugfixed TGLBlur - default values added to all properties, Made some cosmetic and alignment changes <li>20/02/07 - DaStr - TGLMotionBlur added (based on ToxBlur by Dave Gravel) Added some default values to TGLBlur <li>11/06/04 - Mrqzzz - Creation </ul></font>

GLBSP
GLBumpmapHDS Implements a HDS that automatically generates an elevation bumpmap.<p>

The object-space elevation bumpmap can be used for dynamic terrain lighting.<p> A bumpmap texture is generated for each terrain tile, and placed into a TGLMaterialLibrary.

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>22/01/10 - Yar - Added GLTextureFormat to uses <li>13/02/07 - LIN- Thread-safe, for use with TGLAsyncHDS Also takes advantage of texture-coodrinates, calculated by HeightDataSource <li>02/02/07 - LIN- GLBumpmapHDS is now derived from THeightDataSourceFilter. HeightDataSource replaces ElevationHDS. (More efficient, since it no longer has to copy and release the entire Source HDS's THeightData object.) <li>01/02/07 - LIN- Added 'MaxTextures' property. if the MaterialLibrary.Materials.Count > MaxTextures, then unused textures are deleted. Set MaxTextures=0 to disable Auto-deletes, and manage your normal-map textures manually.

WARNING: If you use THeightData.MaterialName, instead of THeightData.LibMaterial, then HeightData does NOT register the texture as being used. So make sure MaxTextures=0 if you use MaterialName.

<li>25/01/07 - LIN- Replaced 'StartPreparingData' and 'GenerateBumpmap' functions. Now supports a TGLBitmap with multiple tiles. Now works with HeightTileFileHDS. World texture coordinates for individual textures are now calculated, (TGLLibMaterial.TextureOffset and TGLLibMaterial.TextureScale) Bugfix: Terrain position no longer jumps when InfiniteWrap is turned off. <li>15/04/04 - EG - Fixed hdsNone support (Phil Scadden) <li>20/03/04 - EG - Works, reasonnably seamless but still quite inefficient <li>20/02/04 - EG - Creation </ul></font>

GLBumpShader GLBumpShader<p>

A shader that applies bump mapping.<p>

Notes: The normal map is expected to be the primary texture.<p>

The secondary texture is used for the diffuse texture, to enable set boDiffuseTexture2 in the BumpOptions property.<p>

The tertiary texture is used for the specular texture, to enable set boSpecularTexture3 in the BumpOptions property. The SpecularMode determines the specular highlight calculation (Blinn or Phong), smOff disables specular highlights in the shader.<p>

External tangent bump space expects tangent data under GL_TEXTURE1_ARB and binormal data under GL_TEXTURE2_ARB.<p>

The boUseSecondaryTexCoords bump option tells the shader to use the secondary texture coordinates for the diffuse and specular texture lookups.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Upgraded program hadles <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>31/03/07 - DaStr - Added $I GLScene.inc <li>25/02/07 - DaStr - Moved registration to GLSceneRegister.pas <li>15/04/05 - SG - Added parallax offset mapping for the BasicARBfp bump method (experimental) Height data is expected in the normal map alpha channel. <li>21/12/04 - SG - Added light attenutation support through the boLightAttenutation option in the BumpOptions property. <li>27/10/04 - SG - Added boUseSecondaryTexCoords option to BumpOptions <li>11/10/04 - SG - Added SpecularMode to define the specular highlight equation, Removed the boDisableSpecular bump option (depricated). <li>06/10/04 - SG - Added special functions for generating the ARB programs which replace the string constants. <li>02/10/04 - SG - Changed render order a little, minimum texture units is now 2 for dot3 texcombiner bump method. Changed vertex programs to accept local program params, now only 1 vertex and 1 fragment program is required for all lights. Vertex programs now apply the primary texture matrix. <li>30/09/04 - SG - Added fragment program logic, Added bmBasicARBFP bump method, bsTangentExternal bump space and associated ARB programs, Various name changes and fixes <li>28/09/04 - SG - Vertex programs now use ARB_position_invariant option. <li>29/06/04 - SG - Quaternion tangent space fix in tangent bump vertex program. <li>23/06/04 - SG - Added bsTangent option to TBumpSpace, Added tangent space light vector vertex program. <li>22/06/04 - SG - Creation. </ul></font>

GLCadencer GLCadencer<p>

Cadencing composant for GLScene (ease Progress processing)<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: restored GetCurrenttime instead of GetCurrentTime <li>07/08/11 - Yar - Added OnTotalProgress event, which happens after all iterations with fixed delta time (thanks Controller) <li>06/02/11 - Predator - Improved TGLCadencer for Lazarus <li>29/11/10 - Yar - Changed TASAPHandler.FMessageTime type to unsigned (thanks olkondr) <li>21/11/09 - DaStr - Bugfixed FSubscribedCadenceableComponents (thanks Roshal Sasha) <li>09/11/09 - DaStr - Improved FPC compatibility (thanks Predator) (BugtrackerID = 2893580) <li>21/09/07 - DaStr - Added TGLCadencer.SetCurrentTime() <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTracekrID=1681585) <li>02/08/04 - LR, YHC - BCB corrections: changed GetCurrentTime to GetCurrenttime <li>28/06/04 - LR - Added some ifdef Win32 for Linux <li>20/10/03 - EG - Fixed issues about cadencer destruction <li>29/08/03 - EG - Added MinDeltaTime and FixedDeltaTime <li>21/08/03 - EG - Fixed Application.OnIdle reset bug (Solerman Kaplon) <li>04/07/03 - EG - Improved TimeMultiplier transitions (supports zero) <li>06/06/03 - EG - Added cmApplicationIdle Mode <li>19/05/03 - EG - Added Reset (Roberto Bussola) <li>04/03/02 - EG - Added SetTimeMultiplier <li>01/07/02 - EG - Added TGLCadencedComponent <li>05/12/01 - EG - Fix in subscription mechanism (D6 IDE freezes gone?) <li>30/11/01 - EG - Added IsBusy (thx Chris S) <li>08/09/01 - EG - Added MaxDeltaTime limiter <li>23/08/01 - EG - No more "deprecated" warning for Delphi6 <li>12/08/01 - EG - Protection against "timer flood" <li>19/07/01 - EG - Fixed Memory Leak in RegisterASAPCadencer, Added speed limiter TASAPHandler.WndProc <li>01/02/01 - EG - Fixed "Freezing" when Enabled set to False <li>08/10/00 - EG - Added TASAPHandler to support multiple ASAP cadencers <li>19/06/00 - EG - Fixed TGLCadencer.Notification <li>14/04/00 - EG - Minor fixes <li>13/04/00 - EG - Creation </ul></font>

GLCameraController
GLCanvas GLCanvas<p>

Implements a basic Canvas-like interface over for OpenGL.<p> This class can be used for generic OpenGL applications and has no dependencies to the GLScene core units (only to base units).<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records, Replaced direct access to PenAlpha property with GetPenAlpha method <li>05/02/11 - Yar - Now PenColor setter always direct set color <li>03/10/10 - Yar - Added RoundRect (thanks eric129) <li>21/09/10 - Yar - Added Arc, ArcTo (thanks µAlexx) <li>03/09/10 - Yar - Added FillRectGradient, FillEllipseGradient (thanks µAlexx) <li>23/08/10 - Yar - Replaced OpenGL1x functions to OpenGLAdapter <li>04/04/10 - Yar - Fixes after GLState revision <li>07/11/09 - DaStr - Some cosmetic fixes. Overloaded TGLCanvas.EllipseBB(), TGLCanvas.Ellipse(), TGLCanvas.FillEllipse() <li>31/07/07 - DaStr - Added missing StopPrimitive call to TGLCanvas.FillRect (Bugtracker ID = 1775528) <li>06/06/07 - DaStr - Removed ConvertColorVector and ConvertWinColor (now in GLColor.pas) Added GLColor to uses (BugtrackerID = 1732211) Removed TColor declaration (now in GLCrossPlatform.pas) <li>02/08/04 - LR, YHC - BCB corrections: used record instead array Replaced direct access of some properties by a getter and a setter <li>08/07/04 - LR - Replace Graphics and TPoint by GLCrossPlatform for Linux <li>13/01/04 - EG - Polyline/Polygon fix <li>07/05/03 - EG - SetPenWidth now correctly stops the primitive <li>08/01/03 - EG - StopPrimitive now public <li>09/12/02 - EG - Now properly disables fog <li>20/11/02 - EG - Now uses Types/Windows TPoint (D5 & D6 tested only) <li>01/10/02 - EG - Added Polygon & Polyline <li>04/03/02 - EG - Added FrameRect and FillRect <li>31/01/02 - EG - Texture3D/CubeMap only disabled if supported <li>24/01/02 - EG - Added PenAlpha <li>19/01/02 - EG - Creation </ul></font>

GLCelShader GLCelShader<p>

A shader that applies cel shading through a vertex program and shade definition texture.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Upgraded program hadles <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>22/01/10 - Yar - Added bmp32.Blank:=false for memory allocation <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>31/03/07 - DaStr - Added $I GLScene.inc <li>21/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>25/02/07 - DaStr - Moved registration to GLSceneRegister.pas <li>28/09/04 - SG - Vertex program now uses ARB_position_invariant option. <li>09/06/04 - SG - Added OutlineColor, vertex programs now use GL state. <li>28/05/04 - SG - Creation. </ul></font>

GLCgBombShader GLCgBombShader<p>

Just a good looking shader. And my first one;) <p>

<b>History :</b><font size=-1><ul> <li>22/04/10 - Yar - Fixes after GLState revision <li>24/07/09 - DaStr - TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) <li>14/03/07 - DaStr - Bugfixed TGLCustomCGBombShader.DoInitialize (Shader is disabled if GradientTexture is not assigned) <li>14/03/07 - DaStr - Bugfixed TGLCustomCGBombShader.SetMaterialLibrary Alpha is not stored now Added design-time checks <li>22/02/07 - DaStr - Initial version (contributed to GLScene)

Previous version history: v1.0 08 March '2006 Creation (based on NVIdia's FXComposer demo shader) v1.1 04 April '2006 I found a way to use the Current Texture! See the TextureSource property for details... v1.2 14 August '2006 TGLCgBombShader became child of TGLCgShader to support IShaderSuppoted TShaderTextureSource added v1.3 19 August '2006 TGLCustomCGBombShader added GLS_OPTIMIZATIONS support added TGLCustomCGBombShader.Set[Main/Gradient]Texture() updated Cadencer stuff abstracted into TCadencableCustomCgShader

GLCgRegister GLCgRegister<p>

Registration unit for CG shader.<p>

<b>History :</b><font size=-1><ul> <li>11/11/09 - DaStr - Improved FPC compatibility (thanks Predator) (BugtrackerID = 2893580) <li>23/02/07 - DaStr - Initial version

GLCgShader GLCgShader<p>

Base Cg shader classes.<p>

<b>History :</b><font size=-1><ul> <li>19/12/12 - PW - Added CPPB compatibility: changed cg.lib's name of function GetProfileString to GetProfileStringA <li>26/03/11 - Yar - Added SetAsMatrix to TCgParameter <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>22/04/10 - Yar - Fixes after GLState revision <li>24/07/09 - DaStr - TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) <li>15/03/08 - DaStr - Fixups for vIgnoreContextActivationFailures mode (BugTracker ID = 1914782) <li>24/03/07 - DaStr - Improved Cross-Platform compatibility (BugTracker ID = 1684432) <li>23/02/07 - DaStr- Added TCgProgram.ManualNotification <li>23/02/07 - DaStr- Added TCadencableCustomCgShader Added EGLCGShaderException with TCustomCgShader: Added ShaderSupported, Moved all properties from "public" and "published" to the "protected" section. DoInitialize fixed to catch compilation errors Moved registration to GLCgRegister.pas Added more stuff to RegisterClasses() <li>29/04/06 - PhP - Fixed TCgProgram.Finalize (Achim Hannes) <li>24/10/04 - NelC - Added SetAsScalar for boolean input, IncludeFilePath <li>10/09/04 - NelC - Added global function IsCgProfileSupported <li>07/09/04 - NelC - Added TCgProgram.Precision (Cg 1.3) <li>07/09/04 - NelC - Added profiles VP40, FP40 (Cg 1.3 beta 2), Added option OutputCompilerWarnings <li>23/04/04 - NelC - Now ManageTexture is false by default (Cg 1.2.1) <li>24/03/04 - NelC - Added GetLatestProfile <li>21/03/04 - NelC - Added TCgFragmentProgram.ManageTexture (Cg 1.2) Added TCustomCgShader.IsProfileSupported <li>16/02/04 - NelC - Added TCgParameter.SetParameterPointer <li>13/02/04 - NelC - Replaced two overloaded TCgProgram.SetParam's with SetStateMatrix and SetTexture <li>05/02/04 - NelC - Fixed type checking for Half and Fixed, Added TCgParameter.SetToTextureOf <li>01/02/04 - NelC - Now reports source CgProgram or CgParameter of errors <li>20/01/04 - NelC - Updated shader event handlers with Sender object, Fixed dynamic array passing bug in CheckValueType <li>03/01/04 - NelC - Shortened event handler names using 'VP' and 'FP', Added TCustomCgShader.LoadShaderPrograms, TCgProgram.SetParam, Minor change in texture type checking <li>01/08/03 - NelC - Simplified type checking in SetAsStateMatrix <li>04/07/03 - NelC - Added TCustomCgShader.OnInitialize, Moved VertexProgram & FragmentProgram of TCustomCgShader to published for easy acccess from OnInitialize <li>02/07/03 - NelC - Added more value-setting methods <li>01/07/03 - NelC - TCgProgram.ListCompilation now outputs line breaks <li>27/06/03 - NelC - Added value-setting functions for TCgParameter, TCgProgram.DirectParamByName & DirectProfile, and Profile property for TCgVertexProgram & TCgFragmentProgram <li>24/06/03 - NelC - Initial adoptation to Cg 1.1 Final. Now automatically uses latest hardware-supported profile and use callback to show error message <li>29/05/03 - RoC - Cg 1.1 Depreciated_api compatible <li>25/09/02 - EG - Cg Beta 2/2.1 compatible, now uses ARBVP <li>19/06/02 - EG - Improved OO wrapper <li>18/06/02 - EG - Creation </ul></font>

GLCollision GLCollision<p>

Collision-detection management for GLScene<p>

<b>Historique : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>21/01/11 - DanB - Added "inherited" call to TGLBCollision.WriteToFiler <li>03/04/07 - DaStr - Added "public" to TCollisionNode for FPC compatibility <li>30/03/07 - DaStr - Added $I GLScene.inc <li>19/10/06 - LC - Fixed memory leak in TCollisionManager.CheckCollisions. Bugtracker ID=1548618 <li>02/08/04 - LR, YHC - BCB corrections: use record instead array <li>09/05/03 - DanB - fixed for collisions with bounding-box unproperly defined (min>max) <li>09/05/03 - DanB - Added FastCheckCubeVsFace (Matheus Degiovani) <li>13/02/03 - DanB - New collision code, and support for scaled objects <li>22/02/01 - Egg - Included new collision code by Uwe Raabe <li>08/08/00 - Egg - Fixed TGLBCollision.Assign <li>16/07/00 - Egg - Added support for all bounding modes (most are un-tested) <li>23/05/00 - Egg - Creation </ul></font>

GLColor GLColor<p>

All color types, constants and utilities should go here<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPPB compatibility: restored $NODEFINE directives <li>04/11/10 - DaStr - Removed dependancy from OpenGL (this time for good) <li>24/10/10 - DaStr - Removed dependancy from OpenGL <li>23/08/10 - Yar - Added OpenGLTokens to uses <li>31/05/10 - Yar - Fixed warnings for Delhi2009/2010 <li>04/03/10 - DanB - TGLColorManager.GetColor now uses CharInSet <li>05/10/08 - DanB - Moved TGLColor/ TGLColorManager in from GLTexture.pas <li>06/06/07 - DaStr - Initial version (BugtrackerID = 1732211) (separated from GLTexture.pas and GLCrossPlatform.pas) </ul>

GLCompositeImage GLCompositeImage<p>

This class is required for loading images such classes as TGLDDSImage, TGLO3TCImage, TGLHDRImage etc.

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>22/02/10 - Yar - Added LoadFromStream (thanks to mif) <li>23/01/10 - Yar - Replaced TextureFormat to TextureFormatEx <li>21/01/10 - Yar - Creation </ul><p>

GLConsole GLConsole <p>

The console is a popdown window that appears on a game for text output/input.<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>02/04/07 - DaStr - All cross-version stuff abstracted into GLCrossPlatform <li>30/03/07 - DaStr - Replaced GLWin32Viewer with GLViewer <li>25/02/07 - DaStr - Made some fixes for Delphi5 compatibility <li>23/02/07 - DaStr - Cosmetic changes, replaced some strings with resource strings from GLStrings.pas <li>15/02/07 - DaStr - Some properties are not stored now, because they are read directly from HUDSprite and HUDText <li>07/02/07 - DaStr - Initial version (donated to GLScene)

What is different compared to the original component? 1) Can be aded to any object, not just the root one 2) Has a *wide* range of built-in commands 3) TGLConsoleCommand.UnknownCommand added it is set to True, if no internal command recognized 4) Internal console help added 5) By default does not remove quotes ("), but this option can be turned on (property RemoveQuotes) 6) Command list added. All user commands are saved there 7) All previously typed commands can be accessed in a usual way (arrow up/down) 8) Commands can be auto-completed by pressing TConsoleControls.AutoCompleteCommand key, or setting AutoCompleteCommandsOnKeyPress, AutoCompleteCommandsOnEnter to True Dbl-pressing the key, defined in the TConsoleControls.AutoCompleteCommand property, gives you a list of all posible internal-external commands that start with your letters 9) Batch command execution support added 10) Short help is shown when user calls the global 'help' function Long help is shown elsewhere 11) Show command help by "/?", "-?", "–?" etc 12) Assign() added for every class

TODO: [new command] Redirection with the | operator, like in any othe console (optional) [new command] File browser stuff... (this one's optional ;)

Blinking cursor, "Delete" key support Allow long lines to continue on the next line May be SceneViewer should be a TControl to support the FullScreenViewer...

Previous version history: v1.0 23 November '2005 Creation (based on TGLConsole from http://caperaven.co.za/ v1.1 17 June '2006 Load/Save stuff upgraded v1.2 07 July '2006 Component completely rewritten (New command classes added) v1.2.4 31 August '2006 A few memory leaks fixed TGLCustomConsole.Size added Fixed a bug in TGLCustomConsole.RefreshHud "Console.Color" command fixed Bug with saving of TypedCommands fixed v1.2.5 11 September '2006 TGLCustomConsole.AutoCompleteCommand() bugfixed v1.2.6 08 October '2006 Made compatible with the new persistance mechanism 1.3 23 October '2006 TGLCustomConsole made descendant of TGLBaseSceneObject 1.4 07 February '2007 TGLCustomConsole.NumLines bugfixed TGLCustomConsole.RefreshHud bugfixed TGLConsoleCommand.GetDisplayName added TGLConsoleCommand default values added TGLConsoleStringList.Changed fixed TGLConsoleOptions added (united 4 Boolean properties) Code ready to be donated to GLScene

GLContext GLContext<p>

Prototypes and base implementation of TGLContext.<p>

<b>History : </b><font size=-1><ul> <li>01/06/11 - Yar - Now number of rendering contexts is unlimited (by Gabriel Corneanu) <li>13/05/11 - Yar - Made indexing for context's handles to improve speed of operations <li>24/03/11 - Yar - Added preparation arrangement to TGLContext, TGLContextHandle <li>24/11/10 - Yar - Added TGLBooleanOcclusionQueryHandle <li>14/10/10 - Yar - Added ServiceContext in separate thread, procedure AddTaskForServiceContext <li>16/09/10 - YP - Fixes param assertion to display missing attrib, uniform or varying by name <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter Added to TGLContext property PipelineTransformation Added feature of debug context creating Improved TGLContextHandle destroying Added TGLARBVertexProgramHandle, TGLARBFragmentProgramHandle, TGLARBGeometryProgramHandle <li>02/08/10 - DaStr - Bugfixed TGLContextHandle.DestroyHandle() <li>18/07/10 - Yar - Added TGLTessControlShaderHandle, TGLTessEvaluationShaderHandle, TGLSamplerHandle <li>17/06/10 - Yar - Added IsDataNeedUpdate, NotifyDataUpdated, NotifyChangesOfData to TGLContextHandle <li>02/05/10 - Yar - Fixes for Linux x64. Make outputDevice HWND type. <li>02/05/10 - Yar - Handles are universal for contexts. You can use one handle in different contexts, regardless of the compatibility of contexts. <li>01/05/10 - Yar - Added buffer objects state cashing <li>22/04/10 - Yar - Fixes after GLState revision <li>18/03/10 - Yar - Added MapBufferRange, Flush to TGLBufferObjectHandle <li>06/03/10 - Yar - Added to TGLProgramHandle BindFragDataLocation, GetUniformOffset, GetUniformBlockIndex <li>05/03/10 - DanB - More state added to TGLStateCache <li>22/02/10 - DanB - Added TGLContext.GLStates, to be used to cache global per-context state. Removed BindedGLSLProgram since it should be per-context state. <li>21/02/10 - Yar - Added function BindedGLSLProgram <li>08/01/10 - DaStr - Added TGLFramebufferHandle.AttachLayer() Added more AntiAliasing modes (thanks YarUndeoaker) <li>13/12/09 - DaStr - Modified for multithread support (thanks Controller) <li>30/08/09 - DanB - renamed vIgnoreContextActivationFailures to vContextActivationFailureOccurred + re-enabled it's original behaviour (fixes major memory leak). <li>30/08/09 - DanB - Added TGLTransformFeedbackBufferHandle, TGLTextureBufferHandle, TGLUniformBufferHandle, TGLVertexArrayHandle, TGLFramebufferHandle, TGLRenderbufferHandle <li>24/08/09 - DaStr - Added TGLProgramHandle.GetVaryingLocation(), AddActiveVarying() (thanks YarUnderoaker) <li>21/08/09 - DanB - TGLQueryHandle.GetTarget no longer a class function, for earlier Delphi compatibility <li>13/08/09 - DanB - Added timer & primitive queries. Occlusion queries now use OpenGL 1.5+ queries, instead of GL_NV_occlusion_query extension <li>10/06/09 - DanB - removed OpenGL error handling code, it already exists in OpenGL1x.pas <li>16/03/08 - DanB - moved MRT_BUFFERS into unit from opengl1x.pas rewrite, and added some experimental geometry shader code <li>15/03/08 - DaStr - Fixups for vIgnoreContextActivationFailures mode (BugTracker ID = 1914782) <li>06/11/07 - LC - moved vIgnoreContextActivationFailures to "Interface" section <li>24/06/06 - LC - Refactored TGLVBOHandle, introduced TGLBufferObjectHandle and TGLPackPBOHandle/TGLUnpackPBOHandle <li>15/02/07 - DaStr - Added more parameters to TGLProgramHandle TGLProgramHandle.Name is now a property <li>15/02/07 - DaStr - Integer -> Cardinal because $R- was removed in GLScene.pas <li>15/09/06 - NC - TGLContextHandle.handle as Integer -> Cardinal <li>11/09/06 - NC - Added TGLProgramHandle.Name, TGLProgramHandle.Uniform2f, SetUniform*, support for Multiple-Render-Target <li>25/04/04 - EG - Added TGLOcclusionQueryHandle.Active <li>25/09/03 - EG - Added TGLVBOHandle <li>20/09/03 - EG - Added TGLOcclusionQueryHandle <li>30/01/02 - EG - Added TGLVirtualHandle <li>29/01/02 - EG - Improved recovery for context creation failures <li>28/01/02 - EG - Activation failures always ignored <li>21/01/02 - EG - Activation failures now ignored if application is terminating (workaround for some weird ICDs) <li>15/12/01 - EG - Added support for AlphaBits <li>30/11/01 - EG - Added TGLContextAcceleration <li>06/09/01 - EG - Win32Context moved to new GLWin32Context unit <li>04/09/01 - EG - Added ChangeIAttrib, support for 16bits depth buffer <li>25/08/01 - EG - Added pbuffer support and CreateMemoryContext interface <li>24/08/01 - EG - Fixed PropagateSharedContext <li>12/08/01 - EG - Handles management completed <li>22/07/01 - EG - Creation (glcontext.omm) </ul></font>

GLCoordinates
GLCrossPlatform GLCrossPlatform<p>

Cross platform support functions and types for GLScene.<p>

Ultimately, *no* cross-platform or cross-version defines should be present in the core GLScene units, and have all moved here instead.<p>

<b>Historique : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: restored $NODEFINE to remove redeclarations of RGB, GLPoint, GLRect and some other types <li>30/06/11 - DaStr - Added CharToWideChar() <li>19/06/11 - Yar - Added IsDirectoryWriteable <li>15/04/11 - AsmRu - Added GetPlatformInfo, GetPlatformVersion <li>19/03/11 - Yar - Added procedure FixPathDelimiter, RelativePath <li>04/11/10 - DaStr - Added functions missing in Delphi5 and Delphi6: TAssertErrorProc, GetValueFromStringsIndex and some types <li>31/10/10 - Yar - Added GLSTime <li>18/10/10 - Yar - Added functions FloatToHalf, HalfToFloat (Thanks to Fantom) <li>04/09/10 - Yar - Added IsDesignTime variable, SetExeDirectory <li>15/06/10 - Yar - Replace Shell to fpSystem <li>04/03/10 - DanB - Added CharInSet, for Delphi versions < 2009 <li>07/01/10 - DaStr - Bugfixed GetDeviceCapabilities() for Unix (thanks Predator) <li>17/12/09 - DaStr - Moved screen utility functions to GLScreen.pas (thanks Predator) <li>11/11/09 - DaStr - Added GLS_FONT_CHARS_COUNT constant <li>07/11/09 - DaStr - Improved FPC compatibility (BugtrackerID = 2893580) (thanks Predator) <li>24/08/09 - DaStr - Added IncludeTrailingPathDelimiter for Delphi 5 <li>03/06/09 - DanB - Re-added Sleep procedure, for Delphi 5 <li>07/05/09 - DanB - Added FindUnitName (to provide functionality of TObject.UnitName, on prior versions of Delphi) <li>24/03/09 - DanB - Moved Dialog utility functions to GLUtils.pas, new ShowHTMLUrl procedure <li>19/03/09 - DanB - Removed some Kylix IFDEFs, and other changes mostly affecting D5/FPC <li>29/05/08 - DaStr - Added StrToFloatDef(), TryStrToFloat() <li>10/04/08 - DaStr - Added TGLComponent (BugTracker ID = 1938988) <li>07/04/08 - DaStr - Added IsInfinite, IsNan <li>18/11/07 - DaStr - Added ptrInt and PtrUInt types (BugtrackerID = 1833830) (thanks Dje and Burkhard Carstens) <li>06/06/07 - DaStr - Added WORD type Got rid of GLTexture.pas dependancy Moved GetRValue, GetGValue, GetBValue, InitWinColors to GLColor.pas (BugtrackerID = 1732211) <li>02/04/07 - DaStr - Added MakeSubComponent Fixed some IFDEFs to separate FPC from Kylix <li>25/03/07 - DaStr - Replaced some UNIX IFDEFs with KYLIX Added IdentToColor, ColorToIdent, ColorToString, AnsiStartsText, IsSubComponent Added TPoint, PPoint, TRect, PRect, TPicture, TGraphic, TBitmap, TTextLayout, TMouseButton, TMouseEvent, TKeyEvent, TKeyPressEvent Added IInterface, S_OK, E_NOINTERFACE, glKey_PRIOR, glKey_NEXT, glKey_CONTROL <li>24/03/07 - DaStr - Added TPenStyle, TPenMode, TBrushStyle, more color constants, Added "Application" function <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTracekrID=1681585) <li>02/08/04 - LR, YHC - BCB corrections: Added namespace 'Graphics' to TGLBitmap use $NODEFINE to remove declarations of duplicate variables <li>08/07/04 - LR - Added clBlack <li>03/07/04 - LR - Added constant for Keyboard (glKey_TAB, ...) Added function GLOKMessageBox to avoid the uses of Forms Added other abstraction calls Added procedure ShowHTMLUrl for unit Info.pas Added GLShowCursor, GLSetCursorPos, GLGetCursorPos, GLGetScreenWidth, GLGetScreenHeight for GLNavigation Added GLGetTickCount for GLFPSMovement <li>28/06/04 - LR - Added TGLTextLayout, GLLoadBitmapFromInstance Added GetDeviceCapabilities to replace the old function <li>30/05/03 - EG - Added RDTSC and RDTSC-based precision timing for non-WIN32 <li>22/01/02 - EG - Added OpenPictureDialog, ApplicationTerminated <li>07/01/02 - EG - Added QuestionDialog and SavePictureDialog, Added PrecisionTimer funcs <li>06/12/01 - EG - Added several abstraction calls <li>31/08/01 - EG - Creation </ul></font>

GLCustomShader GLCustomShader<p>

A collection of pure abstract classes - descendants of TGLShader, which are used for purpose of not having to write the same stuff all over and over again in your own shader classes. It also contains a procedures and function that can be used in all shaders.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>15/16/10 - Yar - Rewrited static procedures (InitTexture, etc.) <li>04/06/10 - Yar - Added unsigned integer uniforms <li>22/04/10 - Yar - Fixes after GLState revision <li>22/01/10 - Yar - Added to TGLCustomShaderParameter property AsTexture <li>25/10/09 - DaStr - Updated TGLGeometryProgram (thanks YarUnderoaker) <li>24/08/09 - DaStr - Separated TGLShaderProgram into TGLVertexProgram, TGLFragmentProgram and TGLGeometryProgram Added TGLCustomShaderParameter.AsUniformBuffer (thanks YarUnderoaker) <li>28/07/09 - DaStr - Added GeometryShader support (thanks YarUnderoaker) Fixed TGLCustomShader.[...]Program serialization <li>24/07/09 - DaStr - Added TGLCustomShader.DebugMode Fixed spelling mistake in TGLShaderUnAplyEvent Added TGLShaderFogSupport, IsFogEnabled() <li>03/04/07 - DaStr - Added TGLCustomShaderParameter.AsFloat and AsInteger <li>25/03/07 - DaStr - Added TGLCustomShaderParameter.SetToTextureOf <li>20/03/07 - DaStr - Added DrawTexturedScreenQuad[4/5/6] "TextureType" parameter renamed to "TextureTarget" Finished working on TGLCustomShaderParameter <li>04/03/07 - DaStr - Added IGLPostShader <li>03/03/07 - DaStr - Added TGLCustomShaderParameter (beta state) <li>22/02/07 - DaStr - Initial version (contributed to GLScene)

What different shader prefixes might mean:

ML - Multi Light - Shader supports up to 8 lights. Attributes such as [Ambient/Diffuse/Specular] Colors are taken from the current OpenGL state (that means from TGLLightSource too) In all other cases shader supports only one light, position of which is taken from the first registered OpenGL light.

What different shader suffixes might mean:

MP - Manual Parameters - [Ambient/Diffuse/Specular] Colors have to be set manualy as shader's properties. In all other cases they are taken from the current OpenGL state (that means from TGLLightSource too)

MT - Manual Main Texture - Main Texture is taken not from the current texture, that is applied to the rendered object, but has to be set manualy as shader's property In all other cases it is taken from the current texture, that is applied to the rendered object

AM - All Manual - MP + MMT

AST - Auto Secondary Textures - All other textures are taken from the textures, that are applied to the rendered object after the main one (like the one in TGLLIbMaterial.Texture2Name, or any other textures that are applied to the object manualy using TGLMaterial.Apply or Direct OpenGL API) In all other cases they are taken from the shader's properties

Previous version history: v1.0 11 March '2006 Creation, separated from GLSLShader v1.1 06 August '2006 TGLCustomShader.HandleShaderNotSupportedException added TGLCustomShader.ShaderNotSupportedExceptionMessage added v1.2 14 August '2006 IGLShaderSupported separated TGLShaderTextureSource added v1.2.2 19 August '2006 IMultiShaderCompatible added v1.2.4 24 August '2006 TGLCustomShader.ParameterTexture[1-3]D added v1.2.6 04 September '2006 Minor fixes v1.3 04 November '2006 TGLShaderUnUplyEvent added OnApply, OnUnApply, OnInitialize moved to the protected section (Un)ApplyBlendingMode added (Get/Set)ParameterTexture[1/2/3]DHandle added InitTexture(), DrawTexturedScreenQuad() added (Get/Set)ParameterCustomTextureHandle support added v1.3.2 16 December '2006 Added shader Naming convention in the comments STR_SHADER_NEEDS_AT_LEAST_ONE_LIGHT_SOURCE moved here from StrangeGLSLBumpShader vStrangeShaderClassList and all shader registration utility functions added v1.3.4 18 February '2007 StrangeTextureUtilities dependancy removed Updated to the latest CVS version of GLScene

GLDCE GLDCE<p>

How to use: - Add a DCEManager to you form and configure its properties - Add a Dynamic Collision Behavior to you object - Add a Static Collision behaviour to objects which yours will collide - You can choose the shape of your static object - csEllipsoid, csBox - csFreeform MUST BE A TGLFreeform, otherwise will raise errors - csTerrain MUST BE A TGLTerrainRenderer, same condition above - Active: Disable or enable the behaviour for this object - Friction: is a value aprox. between 0 (no friction) and 100 (no movement) - Layer: An object collides only with lower or equal layers - Size: is used for Ellipsoids (Radius) / Boxes (Dimensions) - Solid: Object still generate collision events but it doesn't "block" the dynamic object - UseGravity: You can disable the gravity for that object - SlideOrBounce: The object can bounce like a ball or slide like an FPS - BounceFactor: Restituition factor, 1 means that it will bounce forever

<b>History : </b><font size=-1><ul> <li>21/01/01 - DanB - Added "inherited" call to TGLDCEDynamic/TGLDCEStatic.WriteToFiler <li>18/09/10 - YP - Moved published behaviours' events to public (they cannot be restored by the filer) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>29/01/07 - DaStr - Moved registration to GLSceneRegister.pas <li>01/07/05 - MathX - Fixed memory leak on contactPoints (moveByDistance method) <li>23/01/05 - LucasG - Code reorganized, many fixes and some new features <li>19/11/04 - GAK - Added standardised collision selection (optionally use same selection criteria as other collision system) <li>17/11/04 - LucasG - Added support for static box colliders <li>17/11/04 - LucasG - Added UseGravity property to behaviour <li>14/11/04 - LucasG - Fixed average friction calculation <li>14/11/04 - LucasG - Added AirFriction property to DCEManager <li>13/11/04 - LucasG - Added Active property to behaviour <li>17/11/04 - LucasG - Added support for static box colliders <li>17/11/04 - LucasG - Added UseGravity property to behaviour <li>14/11/04 - LucasG - Fixed average friction calculation <li>14/11/04 - LucasG - Added AirFriction property to DCEManager <li>13/11/04 - LucasG - Added Active property to behaviour <li>03/09/04 - LucasG - First release <li>29/07/04 - LucasG - Creation </ul></font>

GLDCEMisc GLDCEMisc<p>

Miscelaneous functions used by DCE (Dynamic Collision Engine).

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>30/03/07 - DaStr - Added $I GLScene.inc <li>23/01/05 - LucasG - Code reorganized, many fixes and some new features <li>03/09/04 - LucasG - First release <li>29/07/04 - LucasG - Creation </ul></font>

GLDWS2Objects Base classes and logic for DelphiWebScriptII enabled objects in GLScene<p>

<b>History : </b><font size=-1><ul> <li>04/11/2004 - SG - Moved TGLDelphiWebScriptII to GLScriptDWS2 unit. <li>06/04/2004 - SG - Creation </ul></font>

GLDynamicTexture GLDynamicTexture<p>

Adds a dynamic texture image, which allows for easy updating of texture data.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>20/02/10 - DanB - Fix for TGLDynamicTextureImage.GetTexSize <li>23/01/10 - Yar - Replaced TextureFormat to TextureFormatEx simplify GetBitsPerPixel and GetDataFormat <li>22/01/10 - Yar - Added GLTextureFormat to uses <li>08/10/08 - DanB - added FriendlyName/FriendlyDescription <li>16/10/07 - LC - Added DirtyRectangle to allow partial updates. <li>12/07/07 - DaStr - Added $I GLScene.inc <li>25/06/07 - LC - Added SysUtils (needed for AllocMem on D7 and down). <li>25/06/07 - LC - Fixed a bug where resizing a texture would fail. Introduced new methods for freeing PBO and buffer. <li>24/06/07 - LC - Creation </ul></font>

GLEllipseCollision GLEllipseCollision<p>

Ellipsoid collision functions (mainly used by DCE).

<b>History : </b><font size=-1><ul> <li>30/03/07 - DaStr - Added $I GLScene.inc <li>09/05/05 - Mathx - Protection agains float error on getLowestRoot <li>23/01/05 - LucasG - Code reorganized, many fixes and some new features <li>03/09/04 - LucasG - First release <li>29/07/04 - LucasG - Creation </ul></font>

GLEParticleMasksManager GLEParticleMasksManager<p>

A pretty particle mask effect manager.<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>24/03/07 - Improved Cross-Platform compatibility (BugTracker ID = 1684432) Got rid of Types dependancy <li>29/01/07 - DaStr - Initial version (donated to GLScene by Kenneth Poulter)

Original Header:

GLEParticleMasksManager.pas This unit is part of GLE - GLScene Game Utilities Engine set by Kenneth Poulter difacane@telkomsa.net Module Number: 37

Description: This is merely an addon to GLScene, since i don't want to edit GLScene's source code directly and make changes (since GLScene's source code constantly changes). What the manager does is to provide a basic tool for newly created particles to be modified (their position currently). Their position is set from 3 different masks, which create a "virtual" 3d object... meaning, an actual 3d object is not created, but an outline for particles or any other objects are positioned.

ActualUsage: Create the component, create a new ParticleMask, set the material library, set the materials, and use the procedures provided in the managers root. positioning and scaling applicable aswell.

The images should be

Licenses: Removed. Donated to GLScene's Code Base as long as the author (Kenneth Poulter) is not altered in this file. Theft of code also is not allowed, although alterations are allowed.

History: 28/12/2005 - Added - LX,LY,LZ for correct positioning; Rotating; GenerateParticleMaskFromProjection; Targeting Objects (scales, positions and rotation of object applies) 27/12/2005 - Added - Scale and Positioning 27/12/2005 - Improved code speed significantly (could do better) 26/12/2005 - Creation of base code from experimentation

GLExplosionFx GLExplosionFx<p>

TGLBExplosionFX Effect<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>23/02/07 - DaStr - Fixed TGLBExplosionFx.Create (TGLCoordinatesStyle stuff) <li>23/12/04 - PhP - GLScene Headerized, replaced some VectorXXX functions with XXXVector procedures <li>07/03/04 - Matheus Degiovani - Creation </ul></font>

Description: this effect explodes a mesh object into triangles that fly over. You can define a default direction, in wich case the pieces of the mesh will follow that direction, only rotating, or if you define a null vector as the direction, a vector will be calculated for each triangle, based on the normal vector of that triangle, with a little random addition so things look better. Pretty neat :)<p>

Note: the owner of this behaviour should be any class that derives from TGLBaseMesh class or any other class derived from TGLBaseMesh. Also, the structure of the mesh is lost after the caching of information, so if you'll need the mesh after exploding it, you'll have to save the MeshObjects property of the mesh, OR load it again.

GLExtrusion
GLFBO GLFBO<p>

Implements FBO support for GLScene.

Original author of the unit is Riz. Modified by C4 and YarUnderoaker (hope, I didn't miss anybody).

<b>History : </b><font size=-1><ul> <li>16/10/11 - Yar - Fixes for depth-stencil texture <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>16/05/10 - Yar - Added multisampling support (thanks C4) <li>22/04/10 - Yar - Fixes after GLState revision <li>15/04/10 - Yar - Bugfix missing FBO state changing (thanks C4) <li>23/01/10 - Yar - Replaced TextureFormat to TextureFormatEx <li>22/01/10 - Yar - Adapted to Handles of GLContext, texture target unification, level and layer control <li>11/11/09 - DaStr - Added $I GLScene.inc <li>09/11/09 - DaStr - Initial version (contributed to GLScene) </ul></font>

GLFBORenderer
GLFeedback GLFeedback<p>

A scene object encapsulating the OpenGL feedback buffer.<p>

This object, when Active, will render it's children using the GL_FEEDBACK render mode. This will render the children into the feedback Buffer rather than into the frame buffer.<p>

Mesh data can be extracted from the buffer using the BuildMeshFromBuffer procedure. For custom parsing of the buffer use the Buffer SingleList. The Buffered property will indicate if there is valid data in the buffer.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>01/03/11 - Yar - Added Colors list to BuildMeshFromBuffer <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>15/06/10 - Yar - Bugfixed face culling on in feedback mode drawing (thanks Radli) <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>23/07/04 - SG - Creation. </ul></font>

GLFile3DS GLFile3DS<p>

3DStudio 3DS vector file format implementation.<p>

<b>History :</b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>30/06/11 - DaStr - Properly fixed range check bug <li>15/12/10 - YP - Disable and re-enable range-check only if needed <li>14/12/10 - DaStr - Added a work-around for a range-check bug Bugfixed a case when material texture was turned on when it should not be enabled <li>14/10/10 - YP - Fixed rotate only vertices of TGLFile3DSMeshObject <li>11/10/10 - YP - New vGLFile3DS_LoadedStaticFrame option Fixed ExtractTriangles when vGLFile3DS_LoadedStaticFrame is ON Fixed GetExtents when vGLFile3DS_LoadedStaticFrame is ON <li>07/10/10 - YP - Fixed vGLFile3DS_FixDefaultUpAxisY Fixed first frame index (it's 0 not 1) <li>29/09/10 - YP - Fixed invalid frame limits (SegBegin-SegEnd), wrong SetFrameOffset in Lerp and MorphTo, wrong Frame test in InterpolateValue <li>24/09/10 - YP - Added vGLFile3DS_FixDefaultUpAxisY global option <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>xx/xx/xx - xxx - Fixes for Linux x64 <li>08/11/09 - DaStr - Improved FPC compatibility (thanks Predator) (BugtrackerID = 2893580) <li>07/06/08 - DaStr - Added vGLFile3DS_EnableAnimation option Implemented TGLFile3DSDummyObject.ExtractTriangles() <li>29/04/08 - DaStr - Fixed memory leak in TGLFile3DSCameraObject <li>27/04/08 - DaStr - TGL3DSVectorFile.UseTextureEx converted into a global variable and disabled by default <li>12/04/08 - DaStr - Added TGL3DSVectorFile.UseTextureEx option (Bugtracker ID = 1940451) <li>06/04/08 - DaStr - Added animation support (by Lexer, Luca Burlizzi, Dave Gravel, mif, Oxygen and a bit myself) <li>05/11/07 - DaStr - Fixed transparency issue. <li>31/03/07 - DaStr - Added $I GLScene.inc <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>28/01/07 - DaStr - Added transparency and opacity texture support (thanks DIVON) <li>09/12/04 - LR - Add Integer cast line 94 for Linux <li>25/10/04 - SG - Added lightmap (3DS IllumMap) support <li>05/06/03 - SG - Separated from GLVectorFileObjects.pas </ul></font>

GLFile3DSSceneObjects GLFile3DSSceneObjects<p>

3ds-specific scene objects.<p>

<b>History :</b><font size=-1><ul> <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>17/05/08 - DaStr - Added vGLFile3DSSceneObjects_RenderCameraAndLights <li>06/04/08 - DaStr - Initial version (by Lexer) </ul></font>

GLFileASE GLFileASE<p>

ASE (ASCI Scene Export) file format support for GLScene<p>

<b>History :</b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to arrays of records <li>21/06/08 - DaStr - Bugfixed GetFaceGroup() (Thanks Beon) <li>29/05/08 - DaStr - Made compatible with Delphi 5 <li>27/12/07 - DaStr - Added skipping unknown file sections Improved ASE material objects structure: Material can keep up to 12 texture maps SubMaterial can keep up to 12 texture maps Added ability to select texture, lightmap ASE material/submaterial maps Bugfixed parsing failures on unknown section found (all above changes were made by MaX) <li>19/05/07 - DaStr - Initial version (contributed by MaX)

Parser supported features list: blablabla :)

GLFileB3D
GLFileBMP GLFileBMP<p>

Graphic engine friendly loading of BMP image.

<b>History : </b><font size=-1><ul> <li>04/04/11 - Yar - Creation </ul><p>

GLFileDDS GLFileDDS<p>

DDS File support for GLScene.

<b>History : </b><font size=-1><ul> <li>04/11/10 - DaStr - Added Delphi5 and Delphi6 compatibility <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>06/06/10 - Yar - Fixes for Linux x64 <li>08/05/10 - Yar - Removed check for residency in AssignFromTexture <li>22/04/10 - Yar - Fixes after GLState revision <li>01/03/10 - Yar - Added control of texture detail level <li>27/01/10 - Yar - Bugfix in BlockOffset with negative result <li>23/11/10 - DaStr - Added $I GLScene.inc <li>23/01/10 - Yar - Added to AssignFromTexture CurrentFormat parameter Fixed cube map saving bug <li>20/01/10 - Yar - Creation </ul><p>

GLFileGL2 GLFileGL2<p>

Vector file object loading of Ghoul2 model and animation files into GLScene.<p>

<b>History :</b><font size=-1><ul> <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>22/10/03 - SG - Animation fixes, removed skeletal reconstruction <li>25/03/03 - SG - Creation. </ul></font>

GLFileGTS GLFileGTS<p>

GTS (GNU Triangulated Surface) vector file format implementation.<p>

<b>History :</b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>31/03/07 - DaStr - Added $I GLScene.inc <li>05/06/03 - SG - Separated from GLVectorFileObjects.pas </ul></font>

GLFileHDR GLFileHDR<p>

HDR File support for GLScene.

<b>History : </b><font size=-1><ul> <li>04/11/10 - DaStr - Added Delphi5 and Delphi6 compatibility <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>08/05/10 - Yar - Removed check for residency in AssignFromTexture <li>22/04/10 - Yar - Fixes after GLState revision <li>23/11/10 - DaStr - Added $I GLScene.inc <li>23/01/10 - Yar - Added to AssignFromTexture CurrentFormat parameter <li>20/01/10 - Yar - Creation </ul><p>

GLFileJPEG GLFileJPEG<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>29/06/10 - Yar - Improved FPC compatibility <li>29/04/10 - Yar - Bugfixed loading of fliped image (thanks mif) <li>27/02/10 - Yar - Creation </ul><p>

GLFileLMTS
GLFileLWO GLFileLWO<p>

Support-code to load Lightwave LWO Files (v6.0+, partial support).<p>

<b>History : </b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>30/03/07 - DaStr - Added $I GLScene.inc$I GLScene.inc <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>14/11/02 - EG - Added header, fixed warnings <li>16/11/02 - BJ - Added smooth normals with crease angle <li>17/11/02 - BJ - Added 2 and 4 point ngons -> triangles <li>17/11/02 - BJ - Added Enviroment Map Image -> Cubic Projection Map </ul><p>

Original code: "Brian Johns" <brianjohns1@hotmail.com>

GLFileMD2 GLFileMD2<p>

Quake2 MD2 vector file format implementation.<p>

<b>History :</b><font size=-1><ul> <li>28/08/10 - Yar - Bugfix for FPC 2.5.1 (Thanks Predator) <li>31/03/07 - DaStr - Added $I GLScene.inc <li>05/06/03 - SG - Separated from GLVectorFileObjects.pas </ul></font>

GLFileMD3
GLFileMD5 GLFileMD5<p>

Doom3 MD5 mesh and animation vector file format implementation.<p>

<b>History :</b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>02/12/04 - SG - Updated to support MD5 version 10, version 6 support has been dropped. <li>01/06/04 - SG - Initial </ul></font>

GLFileMDC
GLFileMP3 GLFileMP3<p>

Support for MP3 format.<p>

<b>History : </b><font size=-1><ul> <li>25/07/09 - DaStr - Added $I GLScene.inc <li>06/05/09 - DanB - Creation from split from GLSoundFileObjects.pas </ul></font>

GLFileMS3D GLFileMS3D<p>

Support for MS3D file format.<p>

<b>History :</b><font size=-1><ul> <li>24/11/10 - Yar - Foxed range check error <li>22/06/10 - Yar - Added checking of existing material in material library <li>31/05/10 - Yar - Fixes for Linux x64 <li>04/23/10 - TL - Animations now load properly (note: All animations must be full key frames. All bones selected in MS3D) The entire animation will be available in TActor.Animations[0] <li>04/23/10 - TL - Added support for double sided textures. To make a double sided texture, you must set the transparency slider to the left just a little bit in MS3D. This loader will notice that, and turn off backface culling for that group. <li>04/23/10 - TL - Added weighted vertex animations <li>04/23/10 - TL - Fixed the way normals are loaded. They will now be loaded properly. <li>04/23/10 - TL - Added support to read the comments section of MS3D files.

<li>16/10/08 - UweR - Compatibility fix for Delphi 2009: MaterialIndex is now Byte instead of Char <li>31/03/07 - DaStr - Added $I GLScene.inc <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>19/12/04 - PhP - Added capabilities function <li>28/10/03 - SG - Partly implemented skeletal animation, asynchronous animations will fail however. <li>03/06/03 - EG - Added header, now self-registers </ul></font>

GLFileNMF
GLFileNurbs GLFileNurbs<p>

Nurbs surfaces vector file loading.<p>

<b>History :</b><font size=-1><ul> <li>11/08/03 - SG - Some minor changes <li>05/08/03 - SG - Initial, adapted LoadFromStream from earlier tests with GLNurbsSurface (depricated), originally coded by Eric Grange. </ul></font>

GLFileO3TC GLFileO3TC<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>31/05/10 - Yar - Fixes for Linux x64 <li>08/05/10 - Yar - Removed check for residency in AssignFromTexture <li>22/04/10 - Yar - Fixes after GLState revision <li>27/01/10 - Yar - Bugfix in BlockOffset with negative result <li>23/11/10 - DaStr - Added $I GLScene.inc <li>23/01/10 - Yar - Added to AssignFromTexture CurrentFormat parameter Fixed cube map loading bug <li>20/01/10 - Yar - Creation </ul><p>

GLFileOBJ GLFileOBJ<p>

Support-Code to load Wavefront OBJ Files into TGLFreeForm-Components in GLScene.<p> Note that you must manually add this unit to one of your project's uses to enable support for OBJ & OBJF at run-time.<p>

<b>History : </b><font size=-1><ul>

<li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records

<li>26/06/12 - YP - Split groups in their own mesh instead of a new facegroup (see globale var vGLFileOBJ_SplitMesh, enabled by default) <li>20/06/12 - YP - Get TexturePaths from MaterialLibrary when loading materials

<li>30/06/11 - DaStr - Added ability to assign meshes <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>04/03/10 - DanB - Now uses CharInSet <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>20/05/08 - mrqzzz - Added RegisterClass(TOBJFGVertexNormalTexIndexList) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>11/07/05 - DaStr - Improved Cross-Platform compatibility (BugTracker ID = 1684432) <li>11/07/05 - Wet - Added multi meshobject support <li>09/09/03 - Jaj - Added TriangleStrip and TriangleFan support to save.. <li>10/07/03 - Egg - Improved robustness of material loading <li>02/06/03 - Egg - Undone Jaj changes, they broke standard OBJ support <li>30/01/03 - Egg - Normals extraction <li>29/01/03 - Jaj - Fixed to allow load of simple triangle meshes... ('V','VN','VT') <li>23/01/03 - Egg - Can now export TFGIndexTexCoordList (untextured) <li>25/11/02 - Egg - Improved mtl import (d and illum commands) <li>22/11/02 - Egg - Supports OBJ files using #9 in place of #32, fixed leak, some code cleanup/rearrangements, support for mtllib and usemtl commands <li>18/08/01 - Egg - '$' now allowed as alternate comment, AddToTriangles override <li>03/10/00 - Egg - Fixed TGLOBJVectorFile.LoadFromStream.ReadFace <li>08/10/00 - Egg - Added standard header, basic htmlification of old header, removed specific trim funcs, renamed TMBAGLOBJVectorFile to TGLOBJVectorFile </ul><p>

(c) 2000 Marian Aldenhövel<br> Hainstraße 8<br> 53121 Bonn<br> info@MBA-Software.de<p>

License:<br>

Contributed to Eric Grange and GLScene, same licensing, batteries not included.<p>

History:<p>

26.9.2000: - OBJF-Support (t- and q-lines) see http://www.cs.sunysb.edu/˜stripe/<br> 18.9.2000: - Bugfixing. - SaveTo-Methods.<br> 14.9.2000: - Calculate normals where missing in the file. - Collect Facegroups by Name and do not start a new one for every 'g'-line in the file. - Relative indexing in 'f'-lines.<br> 13.9.2000: - Start of this project as an exercise to get familiar with<br> a) the OBJ-Format and<br> b) GLScene internals<br> Midterm-goal: Import what Poser 4 exports and display it correctly in an GLScene.<br>

GLFileOCT GLFileOCT<p>

Support-code to load OCT Files into TGLFreeForm-Components in GLScene.<br> (OCT being the format output from FSRad, http://www.fluidstudios.com/fsrad.html).<p>

<b>History : </b><font size=-1><ul> <li>19/06/11 - Yar - Fixed problem with image converting in Lazarus (thanks to Johannes Pretorius, Bugtracker ID = 3322324) <li>22/01/10 - Yar - Added GLTextureFormat to uses <li>31/03/07 - DaStr - Added $I GLScene.inc <li>19/09/03 - EG - "Lighmap" -&gt; "LightMap" <li>06/05/03 - mrqzzz - added Gamma and Brightness correction variables (vGLFileOCTLightmapBrightness, vGLFileOCTLightmapGammaCorrection) <li>02/02/03 - EG - Creation </ul><p>

GLFilePAK GLFilePAK<p>

<b>History : </b><font size=-1><ul> <li>04/06/10 - Yar - Added to GLScene (Created by Rustam Asmandiarov aka Predator) </ul><p>

GLFilePGM
GLFilePLY GLFilePLY<p>

PLY (Stanford Triangle Format) vector file format implementation.<p>

<b>History :</b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>31/03/07 - DaStr - Added $I GLScene.inc <li>05/06/03 - SG - Separated from GLVectorFileObjects.pas </ul></font>

GLFilePNG GLFilePNG<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>31/05/10 - Yar - Fixes for Linux x64 <li>08/05/10 - Yar - Removed check for residency in AssignFromTexture <li>22/04/10 - Yar - Fixes after GLState revision <li>16/03/10 - Yar - Improved FPC compatibility <li>05/03/10 - Yar - Creation </ul><p>

GLFileQ3BSP GLFileQ3BSP<p>

Support-code to load Q3BSP Files into TGLFreeForm-Components in GLScene.<p> Note that you must manually add this unit to one of your project's uses to enable support for OBJ & OBJF at run-time.<p>

<b>History : </b><font size=-1><ul> <li>19/06/11 - Yar - Fixed problem with image converting in Lazarus (thanks to Johannes Pretorius, Bugtracker ID = 3322324) <li>06/06/10 - Yar - Added VectorTypes to uses <li>22/01/10 - Yar - Added GLTextureFormat to uses <li>31/03/07 - DaStr - Added $I GLScene.inc <li>31/01/03 - EG - Materials support <li>30/01/03 - EG - Creation </ul><p>

GLFileSMD GLFileSMD<p>

SMD vector file format implementation.<p>

<b>History :</b><font size=-1><ul> <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>28/01/07 - DaStr - Optimized bone weights loading a bit <li>14/01/07 - DaStr - Fixed bone weights for HL2 models (thanks DIVON) <li>24/01/05 - SG - Fix for comma decimal separator in save function (dikoe Kenguru) <li>30/03/04 - EG - Basic Half-Life2/XSI support <li>05/06/03 - SG - Separated from GLVectorFileObjects.pas </ul></font>

GLFileSTL GLFileSTL<p>

Support-code to load STL Files into TGLFreeForm-Components in GLScene.<p> Note that you must manually add this unit to one of your project's uses to enable support for STL files at run-time.<p>

<b>History : </b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>22/11/02 - EG - Write capability now properly declared <li>17/10/02 - EG - Created from split of GLVectorFileObjects, ASCII STL support (Adem) </ul><p>

GLFileTGA GLFileTGA<p>

Graphic engine friendly loading of TGA image.

<b>History : </b><font size=-1><ul> <li>04/04/11 - Yar - Creation </ul><p>

GLFileTIN GLFileTIN<p>

TIN (Triangular Irregular Network) vector file format implementation.<p>

<b>History :</b><font size=-1><ul> <li>05/06/03 - SG - Separated from GLVectorFileObjects.pas </ul></font>

GLFileVRML GLFileVRML<p>

Preliminary VRML vector file support for GLScene.<p> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <b>History :</b><font size=-1><ul> <li>29/03/07 - DaStr - RecursNodes bugfixed (thanks Burkhard Carstens) <li>25/01/05 - SG - Improved auto-normal generation using creaseAngle, Added Normal and TexCoord reading, Fixes for the polygon tessellation routine (Carsten Pohl) <li>18/01/05 - SG - Added polygon tessellation routine to decompose a polygon mesh to a triangle mesh <li>14/01/05 - SG - Added to CVS </ul></font>

GLFileWAV GLFileWAV<p>

Support for Windows WAV format.<p>

<b>History : </b><font size=-1><ul> <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>25/07/09 - DaStr - Added $I GLScene.inc <li>26/05/09 - DanB - Fix for LengthInBytes when chunks occur after data chunk <li>06/05/09 - DanB - Creation from split from GLSoundFileObjects.pas </ul></font>

GlFileX GlFileX<p>

Simple X format support for Delphi (Microsoft's favorite format)<p>

<b>History : </b><font size=-1><ul> <li>07/11/09 - DaStr - Initial version (Added from the GLScene-Lazarus SVN) </ul></font>

<b>Previous version history : </b><font size=-1><ul> $Log$ Revision 1.1 2009/11/07 22:12:25 da_stranger Initial version (Added from the GLScene-Lazarus SVN)

Revision 1.1 2006/01/10 20:50:44 z0m3ie recheckin to make shure that all is lowercase

Revision 1.1 2006/01/09 21:02:31 z0m3ie *** empty log message ***

Revision 1.3 2005/12/04 16:53:04 z0m3ie renamed everything to lowercase to get better codetools support and avoid unit finding bugs

Revision 1.2 2005/08/03 00:41:38 z0m3ie - added automatical generated History from CVS </ul></font>

GLFileZLIB GLFileZLIB<p>

<b>History : </b><font size=-1><ul> <li>22/08/10 - DaStr - Removed warnings, converted comments from Unicode to ASCII <li>04/06/10 - Yar - Added to GLScene (Created by Rustam Asmandiarov aka Predator) </ul><p>

GLFireFX GLFireFX<p>

Fire special effect<p>

<b>Historique : </b><font size=-1><ul> <li>21/01/01 - DanB - Added "inherited" call to TGLBFireFX.WriteToFiler <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>14/06/10 - Yar - Bugfixed in TGLBFireFX.ReadFromFiler when assertion off (thanks olkondr) <li>22/04/10 - Yar - Fixes after GLState revision <li>11/04/10 - Yar - Replaced glNewList to GLState.NewList in TGLBFireFX.Render <li>05/03/10 - DanB - More state added to TGLStateCache <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>14/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>23/02/07 - DaStr - Fixed TGLFireFXManager.Create (TGLCoordinatesStyle stuff) <li>21/02/02 - EG - Added GetOrCreateFireFX helper functions <li>09/12/01 - EG - Added NoZWrite property <li>12/08/01 - EG - Fixed leak (color objects) <li>09/03/01 - EG - Fixed MaxParticles change, added RingExplosion <li>08/03/01 - EG - Revisited the effect and added new parameters, dropped/renamed some, started documentation (just started) <li>13/01/01 - EG - Another matrix compatibility update <li>22/12/00 - EG - Compatibility for new Matrix rules, and sometime ago, added in all new props from Danjel Grosar <li>11/08/00 - EG - A few speedups/enhancements <li>08/08/00 - EG - Creation, based on Roger Cao's "FireEffectUnit" </ul></font>

GLFPSMovement
GLFullScreenViewer
GLGameMenu GLGameMenu<p>

Manages a basic game menu UI<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>31/05/10 - Yar - Fixed for Linux x64 <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>04/09/07 - DaStr - Fixed memory leak in TGLGameMenu (BugtrackerID = 1787617) (thanks Pierre Lemerle) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>26/03/07 - DaveK - back to TGLSceneObject for Material support <li>16/02/07 - DaStr & DaveK - TGLGameMenu.MouseMenuSelect bugfixed (again) Component made descendant of TGLBaseSceneObject IGLMaterialLibrarySupported added <li>20/12/06 - DaStr - TGLGameMenu.MouseMenuSelect bugfixed (thanks to Predator) <li>03/27/06 - DaveK - added mouse selection support <li>03/03/05 - EG - Creation </ul></font>

GLGeomObjects
GLGizmo
GLGizmoEx
GLGLUTesselation GLGLUTesselation<p>

Code to generate triangle strips and fans for polygons.

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>06/06/10 - Yar - Fixed warnings <li>26/11/09 - DaStr - Improved Lazarus compatibility (BugtrackerID = 2893580) <li>10/03/09 - DanB - DoTesselate now accepts TGLBaseMesh instead of TGLFreeform, so can now use TGLActor with it too <li>29/05/08 - DaStr - Added $I GLScene.inc <li>08/09/03 - Jaj - Added single outline polygon support

</ul><p>

License:<br>

Contributed to GLScene.<p>

GLGLXContext GLGLXContext<p>

GLX specific Context.<p>

<b>History : </b><font size=-1><ul> <li>29/08/10 - Yar - Rewrite DoCreateContext, added CSAA antialiasing <li>18/06/10 - Yar - Improved memory context and context sharing <li>11/06/10 - Yar - Fixed uses section after lazarus-0.9.29.26033 release <li>06/06/10 - Yar - Fixes for Linux x64. DoActivate method now check contexts difference <li>21/04/10 - Yar - Added support for GLX versions lower than 1.3 (by Rustam Asmandiarov aka Predator) <li>06/04/10 - Yar - Update to GLX 1.3-1.4, added PBuffer, forward context creation (by Rustam Asmandiarov aka Predator) <li>07/11/09 - DaStr - Improved FPC compatibility (BugtrackerID = 2893580) (thanks Predator) <li>10/06/09 - DanB - Added to main GLScene CVS repository (from GLScene-Lazarus). <li>14/01/05 - CU - Creation </ul></font>

GLGraph
GLGraphics GLGraphics<p>

Utility class and functions to manipulate a bitmap in OpenGL's default byte order (GL_RGBA vs TBitmap's GL_BGRA)<p>

Note: TGLBitmap32 has support for Alex Denissov's Graphics32 library (http://www.g32.org), just make sure the GLS_Graphics32_SUPPORT conditionnal is active in GLScene.inc and recompile.<p>

Note: TGLBitmap32 has support for Alex Denissov's Graphics32 library (http://www.g32.org), just make sure the GLS_Graphics32_SUPPORT conditionnal is active in GLScene.inc and recompile.<p>

<b>Historique : </b><font size=-1><ul> <li>25/11/11 - YP - Assertion removed from AssignFromBitmap32 <li>10/05/11 - Yar - Now VerticalReverseOnAssignFromBitmap works for AssignToBitmap <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>18/07/10 - Yar - Raname TGLBitmap32 to TGLImage <li>20/06/10 - Yar - Added in TRasterFileFormatsList.FindFromStream JPG singnature <li>14/06/10 - YP - PngImage support added (thanks to Sergio Alexandre Gianezini) <li>20/05/10 - Yar - Fixes for Linux x64 Replace OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>28/03/10 - Yar - Added glGenerateMipmap when used forward context <li>08/03/10 - Yar - Added in TRasterFileFormatsList.FindFromStream PNG singnature Added forward context cheking to circumvent deprecations <li>01/03/10 - Yar - Bugfix when texture, which has lower mip-levels than the standard number is not rendered (thanks to Controller) <li>23/02/10 - Yar - Solved problem of TGLBitmap with width of which is not a multiple of four. Added in AssignFrom24BitsBitmap, AssignFrom32BitsBitmap using extension GL_EXT_bgra <li>22/02/10 - Yar - Added FindFromStream to TRasterFileFormatsList (thanks to mif) <li>10/02/10 - Yar - Bugfix in RegisterAsOpenGLTexture with Cubemap mipmaping <li>27/01/10 - Yar - Bugfix in BlockOffset with negative result Return to GL_SGIS_generate_mipmap <li>23/01/10 - Yar - Added to AssignFromTexture CurrentFormat parameter <li>22/01/10 - Yar - Added TRasterFileFormat, TGLBaseImage classes TGLBitmap32 now derived from TGLBaseImage and can contain all types of image (with mipmap level, texture array, volume texture) any kind of color and data formats of OpenGL remake RegisterAsOpenGLTexture <li>10/11/09 - DaStr - Updated TGLBitmap32.RegisterAsOpenGLTexture() - fixed TextureFormat and ColorFormat (thanks YarUnderoaker) Improved FPC compatibility (BugtrackerID = 2893580) (thanks Predator) <li>24/03/07 - DaStr - Moved TGLMinFilter and TGLMagFilter from GLUtils.pas to GLGraphics.pas (BugTracker ID = 1923844) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>14/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>23/01/07 - LIN- Added TGLBitmap32.AssignToBitmap : Converts a TGLBitmap32 back into a TBitmap <li>12/09/06 - NC - Added TGLBitmap32.Blank <li>18/10/05 - NC - GL_ARB_texture_non_power_of_two, GL_TEXTURE_2D for float texture <li>06/10/04 - NC - Now uses GL_TEXTURE_RECTANGLE_NV for all float texture types <li>04/10/04 - NC - Added support for float texture <li>05/09/03 - EG - Added TGLBitmap32.DownSampleByFactor2 <li>04/07/03 - EG - Added RGBA brightness/gamma correction support <li>13/05/03 - EG - Added GrayScaleToNormalMap <li>26/08/02 - EG - Fixed loading of 1D horiz textures from 24 bits bitmaps <li>16/06/02 - EG - AssignFrom32BitsBitmap fix for single-line bitmaps <li>29/01/02 - EG - Fixed ScanLine Index bug with empty bitmaps <li>20/01/02 - EG - Fixed BGR24/RGB24 last pixel transfer <li>17/01/02 - EG - Faster assignments from bitmaps (approx. x2), Added AssignFromBitmap24WithoutRGBSwap <li>28/12/01 - EG - Graphics32 support added <li>15/12/01 - EG - Texture target support <li>14/09/01 - EG - Use of vFileStreamClass <li>31/08/01 - EG - 24bits Bitmaps are now made opaque by default <li>12/08/01 - EG - Now detects and uses GL_SGIS_generate_mipmap <li>20/02/01 - EG - Fixed SetHeight & SetWidth (thx Nelson Chu) <li>14/02/01 - EG - Simplified RegisterAsOpenGLTexture <li>15/01/01 - EG - Fixed RegisterAsOpenGLTexture (clamping) <li>14/01/01 - EG - Fixed isEmpty (was invalid for rectangles) <li>08/10/00 - EG - Fixed RegisterAsOpenGLTexture and Assign(nil) <li>25/09/00 - EG - First operational code <li>19/08/00 - EG - Creation </ul></font>

GLGui GLGui<p>

In GL windows management classes and structures<p>

<b>History : </b><font size=-1><ul> <li>15/04/11 - Yar - Added TGLGuiLayout.Assign <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>11/06/10 - YP - Link GUI elements to their parent <li>06/06/10 - Yar - Fixed warnings <li>30/03/07 - DaStr - Added $I GLScene.inc, cosmetic changes <li>17/02/07 - DaStr - TGLGuiElement.Create - vectors creation fixed Changed some types from TGLCoordinates to TGLCoordinates2 Removed some empty lines <li>16/12/05 - DK - Removed GuiSkinEditorFormUnit dependancy <li>30/11/04 - DB - Fixed memory leaks (thanks dikoe Kenguru) <li>16/07/03 - EG - TGLBaseGuiObject moved in along with RecursiveVisible mechanism <li>25/11/02 - EG - TGLGuiLayout.Clear fix (Sternas Stefanos) <li>06/09/02 - JAJ - Updated and added to CVS.. <li>01/06/02 - JAJ - Base Unit built.. </ul></font>

GLHeightData
GLHeightTileFileHDS GLHeightTileFileHDS<p>

HeightDataSource for the HTF (HeightTileFile) format.<p>

<b>History : </b><font size=-1><ul> <li>10/03/09 - DanB - Bug fix for invisible terrain, now changes heightdata.DataState to hdsPreparing in StartPreparingData <li>30/03/07 - DaStr - Added $I GLScene.inc <li>15/02/07 - LIN -Added OpenHTF function, for direct access to the HeightTileFile object. <li>25/01/07 - LIN -Added Width and Height properties to GLHeightTileFieHDS <li>19/01/07 - LIN -Bug fix/workaround: Added 'Inverted' property to GLHeightTileFieHDS Set Inverted to false, if you DONT want your rendered terrain to be a mirror image of your height data. (Defaults to true, so it doesnt affect existing apps); <li>29/01/03 - EG - Creation </ul></font>

GLHiddenLineShader GLHiddenLineShader<p>

A shader that renders hidden (back-faced) lines differently from visible (front) lines. Polygon offset is used to displace fragments depths a little so that there is no z-fighting in rendering the same geometry multiple times.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>06/06/07 - DaStr - Added $I GLScene.inc Added GLColor to uses (BugtrackerID = 1732211) <li>25/02/07 - DaStr - Moved registration to GLSceneRegister.pas <li>25/09/04 - NelC - Fixed bug of disabled blend (thx Carlos) <li>05/02/04 - NelC - Fixed memory leak in TGLHiddenLineShader.Destroy (thx Achim Hammes) <li>13/12/03 - NelC - Added SurfaceLit, ShadeModel <li>05/12/03 - NelC - Added ForceMaterial <li>03/12/03 - NelC - Creation. Modified from the HiddenLineShader in the multipass demo. </ul></font>

GLHUDObjects
GLImposter GLImposter<p>

Imposter building and rendering implementation for GLScene.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: used direct HPPEMIT for TLoadingImposterEvent as procedure instead of function in Delphi <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>23/02/07 - DaStr - Fixed TGLFireFXManager.Create (TGLCoordinatesStyle stuff) <li>02/08/04 - LR, YHC - BCB corrections: use record instead array fixed BCB Compiler error "E2370 Simple type name expected" <li>07/05/04 - EG - Perspective distortion properly applied <li>06/05/04 - EG - Fixes, improvements, clean ups <li>04/05/04 - EG - Reworked architecture <li>14/04/04 - SG - Fixed texture clamping for old cards and switched to GL_NEAREST texture sampling. <li>24/03/04 - SG - Initial. </ul></font><p>

GLKeyboard GLKeyboard<p>

Provides on demand state of any key on the keyboard as well as a set of utility functions for working with virtual keycodes.<p>

Note that windows maps the mouse buttons to virtual key codes too, and you can use the functions/classes in this unit to check mouse buttons too.<br> See "Virtual-Key Codes" in the Win32 programmers réferences for a list of key code constants (VK_* constants are declared in the "Windows" unit).<p>

<b>Historique : </b><font size=-1><ul> <li>07/11/09 - DaStr - Improved FPC compatibility and moved to the /Source/Platform/ directory (BugtrackerID = 2893580) (thanks Predator) <li>28/03/07 - DaStr - Renamed from Keyboard.pas (BugTracker ID = 1678646) <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTrackerID=1681585) <li>19/12/06 - DaS - Added additional string constants and made all existing 'Mixed Case', not 'UPPERCASE' KeyNameToVirtualKeyCode optimized, Fixed comments to KeyNameToVirtualKeyCode() function <li>17/11/03 - Egg - Fixed IsKeyDown (VK) (A. P. Mohrenweiser) <li>09/10/00 - Egg - Fixed VirtualKeyCodeToKeyName <li>03/08/00 - Egg - Creation, partly based Silicon Commander code </ul></font>

GLLCLViewer GLLCLViewer<p>

A FPC specific Scene viewer.

<b>History : </b><font size=-1><ul> <li>02/06/10 - Yar - Fixes for Linux x64 <li>28/04/10 - Yar - Fixed conditions for windows platform Added Render method (by Rustam Asmandiarov aka Predator) <li>02/04/10 - Yar - Bugfix bad graphics under Windows (by Rustam Asmandiarov aka Predator) <li>22/12/09 - DaStr - Published TabStop, TabOrder, OnEnter, OnExit properties (thanks Yury Plashenkov) <li>07/11/09 - DaStr - Improved FPC compatibility (BugtrackerID = 2893580) (thanks Predator) <li>13/07/09 - DanB - added the FieldOfView property + reduced OpenGL dependencies <li>10/04/08 - DaStr - Bugfixed TGLSceneViewer.Notification() (thanks z80maniac) (Bugtracker ID = 1936108) <li>12/09/07 - DaStr - Removed old IFDEFs. Moved SetupVSync() to GLViewer.pas (Bugtracker ID = 1786279) <li>04/06/04 - EG - Created from GLWin32Viewer </ul></font>

GLLensFlare GLLensFlare<p>

Lens flare object.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>13/03/09 - DanB - changed glReadPixels/glTexImage2D calls to glCopyTexImage2D <li>10/10/08 - DanB - changed Lensflare buildlists to use rci.cameraPosition instead of Scene.CurrentGLCamera.DistanceTo <li>08/08/07 - Lin - Bugfix for AutoZTest: Lensflare is no longer occluded by objects BEHIND the flare. <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Moved all UNSAFE_TYPE, UNSAFE_CODE checks to GLSCene.inc <li>25/03/07 - DaStr - UNSAFE_TYPE and UNSAFE_CODE warnings are now ignored <li>23/03/07 - DaStr - Added missing parameters in procedure's implementation (thanks Burkhard Carstens) (Bugtracker ID = 1681409) <li>22/03/07 - DaStr - Cleanup after previous fix - now object does not igore its children in picking state Removed "unsafe type/unsafe code" warnings <li>15/03/07 - DaStr - Removed flicker that occured when LensFlare was rendered in a picking state (BugTracker ID = 1681031) <li>19/04/04 - EG - Fixed occlusion test and pojection matrix stack issues <li>16/04/04 - EG - Added StreakAngle <li>15/04/04 - EG - Texture-based Lens-flare moved to GLTexLensFlare, replaced gradient arrays with design-time editable colors <li>25/09/03 - EG - Increased occlusion testing robustness <li>20/09/03 - EG - Can now use occlusion testing/query for AutoZTest <li>19/09/03 - EG - Misc. cleanup, added PreRender <li>18/08/03 - SG - Added TGLTextureLensFlare (Tobias Peirick) <li>26/03/03 - EG - Framerate independant glow transitions (Tobias Peirick) <li>08/12/02 - EG - Added AutoZTest <li>29/10/02 - EG - Initial, added defaults and encapsulation, fixed positionning, RandSeed now preserved, minor speedup </ul></font><p>

Author : Tobias Peirick<br> eMail : peirick@onlinehome.de<br> Homepage: http://www.TobSoft.de

GLLinePFX GLLinePFX<p>

A PFX whose particles are lines

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>12/10/08 - DanB - updated to use RCI <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>20/02/05 - EG - Creation </ul></font>

GLManager GLManager<p>

Managers are used to manage many different kinds of clients in GLScene. They are registered so that when clients are loaded, the client can look up the manager + register themselves with it.<p>

<b>History : </b><font size=-1><ul> <li>11/11/09 - DaStr - Added $I GLScene.inc <li>05/10/08 - DanB - Created from GLTexture.pas split </ul></font>

GLMaterial GLMaterial<p>

Handles all the material + material library stuff.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPPB compatibility: used dummy instead abstract methods in TGLShader and TGLAbstractLibMaterial for GLS_CPPB <li>11/03/11 - Yar - Extracted abstract classes from TGLLibMaterial, TGLLibMaterials, TGLMaterialLibrary <li>20/02/11 - Yar - Fixed TGLShader's virtual handle behavior with multicontext situation <li>07/01/11 - Yar - Added separate blending function factors for alpha in TGLBlendingParameters <li>20/10/10 - Yar - Added property TextureRotate to TGLLibMaterial, make TextureMatrix writable <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>07/05/10 - Yar - Fixed TGLMaterial.Assign (BugTracker ID = 2998153) <li>22/04/10 - Yar - Fixes after GLState revision <li>06/03/10 - Yar - Added to TGLDepthProperties DepthClamp property <li>05/03/10 - DanB - More state added to TGLStateCache <li>21/02/10 - Yar - Added TGLDepthProperties, optimization of switching states <li>22/01/10 - Yar - Remove Texture.Border and added MappingRCoordinates, MappingQCoordinates to WriteToFiler, ReadFromFiler <li>07/01/10 - DaStr - TexturePaths are now cross-platform (thanks Predator) <li>22/12/09 - DaStr - Updated TGLMaterialLibrary.WriteToFiler(), ReadFromFiler() (thanks dAlex) Small update for blending constants <li>13/12/09 - DaStr - Added a temporary work-around for multithread mode (thanks Controller) Added TGLBlendingParameters and bmCustom blending mode(thanks DungeonLords, Fantom) Fixed code formating in some places <li>24/08/09 - DaStr - Updated TGLLibMaterial.DoOnTextureNeeded: Replaced IncludeTrailingBackslash() with IncludeTrailingPathDelimiter() <li>28/07/09 - DaStr - Updated TGLShader.GetStardardNotSupportedMessage() to use component name instead class name <li>24/07/09 - DaStr - TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) <li>14/07/09 - DaStr - Added $I GLScene.inc <li>08/10/08 - DanB - Created from split from GLTexture.pas, Textures + materials are no longer so tightly bound </ul></font>

GLMaterialEx GLMaterialEx<p>

Handles extended material and it components: textures, samplers, combiners, shaders and etc.

Features: - material can contain different level of applying accordingly to hardware i.e. Feateres scaling. - if automatically or by user selected level failed, material down to lower level. - direct state access can be used for uniforms setting. - economy mode for texture bindig to active units, i.e. if textures less than maximum units may be not one binding occur per frame.

<b>History : </b><font size=-1><ul> <li>13/04/11 - Yar - Added TGLASMVertexProgram, fixed multitexturing <li>11/04/11 - Yar - Added texture internal storing and streaming (yet only 2D images) <li>11/03/11 - Yar - Created </ul></font>

GLMaterialMultiProxy GLMaterialMultiProxy<p>

Implements a multi-proxy object, useful for discreet LOD.<p> Allows assign a unique material for each proxy master.<p>

<b>History : </b><font size=-1><ul> <li>30/08/10 - Yar - Fixed transformation in TGLMaterialMultiProxy.DoRender <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>10/04/08 - DaStr - Added a Delpi 5 interface bug work-around to TGLMaterialMultiProxyMaster (BugTracker ID = 1938988) <li>25/03/07 - Added GLCrossPlatform to uses for Delphi5 compatibility <li>17/02/07 - DaStr - Initial version (contributed to GLScene) </ul></font>

What changed compared to GLMultiProxy: 1) Allows assign a unique material for each proxy master 2) TGLMaterialMultiProxyMaster: FDistanceMin, FDistanceMax removed 3) TGLMaterialMultiProxy = class(TGLBaseSceneObject)!!! 4) TGLMaterialMultiProxyMaster.Visible removed 5) TGLMaterialMultiProxy.MaterialLibrary added 6) TGLMaterialMultiProxyMaster.MasterLibMaterial added 7) TGLMaterialMultiProxyMasters.Add overloaded 8) Implemented a new mechanizm of connecting TGLLibMaterial and TGLLibMaterialName (they are connected on assigning, not while rendering; full persistency support; allows to assign directly to TGLLibMaterial) 9) VCL-style code formating

Previous version history: v1.0 12 December '2005 Creation (based on MultiProxy.pas) v1.0.1 18 June '2006 Some IFDEFs added v1.0.2 20 December '2006 STRANGE_GLSCENE_VERSION checks removed v1.1 17 February '2007 Made design-time compatible

GLMaterialScript
GLMesh
GLMeshBuilder Build mesh objects.

How often do you miss a BuildSphereMesh function for testing or editors?

Well this unit is intended to solve that problem. We want fast, flexible functions with lots of options...

Original Author: Joen Joensen. Contributed to the GLScene community.

Features: BuildCube, BuildCylinder.

<b>History : </b><font size=-1><ul> <li>22/01/10 - Yar - Added VectorTypes to uses <li>29/11/03 - JAJ - Created and Submitted to GLScene. <li>21/07/03 - JAJ - Added BuildCylinder2 submitted by Gorka? </ul></font>

GLMeshCSG GLMeshCSG<p>

Constructive Solid Geometry in GLScene.

The CSG system uses BSP to optimize what triangles it considers. Its kept on a mesh basis to simplyfy things, it allways generates new BSP's, even if the meshes allready had BSP optimization.

Author: Joen Joensen. Contributed to the GLScene community.

Features: CSG_Union, CSG_Subtraction, CSG_Intersection.

<b>History : </b><font size=-1><ul> <li>06/06/10 - Yar - Added VectorTypes to uses <li>30/03/07 - DaStr - Added $I GLScene.inc <li>18/07/04 - JAJ - Bug fix, causing triangles to dissapear, once in a while. <li>29/11/03 - JAJ - Created and Submitted to GLScene. </ul></font>

GLMeshOptimizer Mesh optimization for GLScene.<p>

<b>History : </b><font size=-1><ul> <li>27/11/07 - mrqzzz - added FacesSmooth InvertNormals parameter. Now smoothes correctly. <li>21/08/03 - EG - Added basic mooStandardize support <li>03/06/03 - EG - Creation </ul></font>

GLMirror GLMirror<p>

Implements a basic, stencil-based mirror (as in Mark Kilgard's demo).<p>

It is strongly recommended to read and understand the explanations in the materials/mirror demo before using this component.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>15/12/08- Paul Robello - corrected call to FOnEndRenderingMirrors <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>18/07/04 - Orlando - added custom shapes <li>13/02/03 - DanB - added TGLMirror.AxisAlignedDimensionsUnscaled <li>13/11/02 - EG - Fixed TGLMirror.DoRender transform <li>06/11/02 - EG - Fixed Stencil setup <li>30/10/02 - EG - Added OnBegin/EndRenderingMirrors <li>25/10/02 - EG - Fixed Stencil cleanup <li>22/02/01 - EG - Fixed change notification, Fixed special effects support (PFX, etc.) <li>07/12/01 - EG - Creation </ul></font>

GLMovement GLMovement<p>

Movement path behaviour by Roger Cao<p>

Note: It is recommended to set TGLMovementPath.RotationMode = rmUpDirection, but the default value is rmTurnPitchRoll for backwards compatibility.

<b>Historique : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records Replaced direct access to properties by methods GetPositionCoordinate, GetRotationCoordinate, GetScaleCoordinate, GetDirectionCoordinate and GetUpCoordinate <li>21/01/01 - DanB - Added "inherited" call to TGLMovement.WriteToFiler <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>12/11/09 - DaStr - Bugfix after previous commit <li>25/10/09 - DaStr - Bugfixed TGLMovementPath.StartTime (thanks Zsolt Laky) <li>14/03/09 - DanB - Changes to Start/StopAllMovements due to TGLScene.Cameras removal <li>05/10/08 - DaStr - Added Delphi5 compatibility <li>21/06/08 - DaStr - A lot of cosmetic fixes Bugfixed same position rotation / scale interpolation in TGLMovementPath.CalculateState() Bugfixed destroying TGLMovement with multiple paths. Added TGLMovementPath.RotationMode (Bugtracker ID = 1999464) (thanks VirusX) <li>02/04/07 - DaStr - All cross-version stuff abstracted into GLCrossPlatform <li>25/03/07 - DaStr - Small fix for Delphi5 compatibility <li>15/02/07 - DaStr - Fixed TGLMovementPath.SetShowPath - SubComponent support <li>27/10/06 - LC - Fixed memory leak in TGLMovementPath. Bugtracker ID=1548615 (thanks Da Stranger) <li>28/09/04 - Mrqzzz - Fixed bug in proc. Interpolation (skipped a line from Carlos' code, oops) <li>09/09/04 - Mrqzzz - CalculateState change by Carlos (NG) to make speed interpolated between nodes <li>20/11/01 - Egg - DoProgress fix suggested by Philipp Pammler (NG) <li>14/01/01 - Egg - Minor changes, integrated to v0.8RC2, still needed: use of standard classes and documentation <li>22/09/00 - RoC - Added StartAllPathTravel and StopAllPathTravel methods <li>24/08/00 - RoC - TGLMovement and relative class added </ul></font>

GLMultiMaterialShader GLMultiMaterialShader<p>

A shader that applies a render pass for each material in its assigned MaterialLibrary.<p>

<b>History : </b><font size=-1><ul> <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - Added more state to TGLStateCache <li>03/07/09 - DanB - bug fix to allow multi-pass materials to be used by TGLMultiMaterialShader <li>20/01/09 - Mrqzzz - Published property "Shaderstyle" (allows f.ex to have multiple textures using lightmaps) <li>25/10/07 - Mrqzzz - commented "glPushAttrib(GL_ALL_ATTRIB_BITS);" in DoApply and "glPopAttrib;" in DoUnapply, which seems to fix issues with other objects and materials in the scene.

<li>25/02/07 - DaStr - Moved registration to GLSceneRegister.pas <li>24/05/04 - Mrqzzz - Re-added design-time rendering option (seems stable now) <li>29/07/03 - SG - Removed design-time rendering option (shader unstable at design-time) <li>29/07/03 - SG - Creation </ul></font>

GLMultiPolygon
GLMultiProxy Implements a multi-proxy objects, useful for discreet LOD.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>19/12/06 - DaS - Fixed a bug in TGLMultiProxy.Destroy <li>26/11/03 - EG - Added bounding, raycast and silhouette proxying <li>25/11/03 - EG - Added per-master visibility boolean <li>24/11/03 - EG - Creation </ul></font>

GLMultisampleImage GLMultisampleImage<p>

This unit provides support for two new types of "multisample textures" - two-dimensional and two-dimensional array - as well as mechanisms to fetch a specific sample from such a texture in a shader, and to attach such textures to FBOs for rendering.

<b>History : </b><font size=-1><ul> <li>04/11/10- DaStr - Added $I GLScene.inc <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>16/05/10 - Yar - Creation (thanks to C4) </ul></font>

GLNavigator GLNavigator<p>

Unit for navigating TGLBaseObjects.<p>

<b>History : </b><font size=-1><ul> <li>20/02/07 - DaStr - Moved Notification(), SetObject(), SetUseVirtualUp(), SetVirtualUp(), CalcRight() to the "protected" section Private "point1" renamed to FPrevPoint Updated comments TGLNavigator.SetObject made virtual <li>19/02/07 - DaStr - TGLNavigator.Create - FVirtualUp creation fixed Added default values to TGLNavigator and TGLUserInterface <li>29/01/07 - DaStr - Moved registration to GLSceneRegister.pas <li>08/03/06 - ur - Fixed warnigs for Delphi 2006 <li>31/10/05 - Mathx - Fixed bug 1340637 relating to freeNotifications on the TGLUserInterface component. <li>18/12/04 - PhP - Added FlyForward <li>03/07/04 - LR - Added GLShowCursor, GLSetCursorPos, GLGetCursorPos, GLGetScreenWidth, GLGetScreenHeight for Linux compatibility <li>11/05/04 - JAJ - Added some features and fixed a bug. <li>01/06/03 - JAJ - Added notification to movingobject... <li>01/06/03 - fig - CurrentHangle implementet... <li>14/07/02 - EG - InvertMouse (Joen A. Joensen) <li>18/03/02 - EG - Added MouseLookActive property, Fixed framerate dependency <li>15/03/02 - JAJ - Structure Change - Mouselook moved to newly created TGLUserInterface. <li>15/03/02 - RMCH - Added Mouselook capability. <li>09/11/00 - JAJ - First submitted. Base Class TGLNavigator included. </ul></font>

GLNewtonRegister
GLNGDManager
GLNodes
GLObjectManager GLObjectManager<p>

The object manager is used for registering classes together with a category, description + icon, so that they can be displayed visually. This can then be used by run-time or design-time scene editors for choosing which scene objects to place into a scene.<p>

TODO: add some notification code, so that when a scene object is registered/ unregistered, any editor that is using the object manager can be notified.

<b>History : </b><font size=-1><ul> <li>11/11/09 - DaStr - Improved FPC compatibility (thanks Predator) (BugtrackerID = 2893580) <li>25/07/09 - DaStr - Added $I GLScene.inc <li>26/03/09 - DanB - Added PopulateMenuWithRegisteredSceneObjects procedure. <li>14/03/09 - DanB - Created by moving TObjectManager in from GLSceneRegister.pas, made some slight adjustments to allow resources being loaded from separate packages. </ul></font>

GLObjects
GLODECustomColliders GLODECustomColliders<p>

Custom ODE collider implementations.<p>

<b>Credits : </b><font size=-1><ul> <li>Heightfield collider code originally adapted from Mattias Fagerlund's DelphiODE terrain collision demo. Website: http://www.cambrianlabs.com/Mattias/DelphiODE </ul>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: restored records with arrays instead of vector arrays <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>08/11/09 - DaStr - Improved FPC compatibility (thanks Predator) (BugtrackerID = 2893580) <li>12/04/08 - DaStr - Cleaned up uses section (thanks Sandor Domokos) (BugtrackerID = 1808373) <li>06/02/08 - Mrqzzz - Upgrade to ODE 0.9 (by Paul Robello) Fixed reference to odeimport <li>25/12/07 - DaStr - Fixed memory leak in TGLODECustomCollider.Destroy() (thanks Sandor Domokos) (BugtrackerID = 1808373) <li>10/10/07 - Mrqzzz - Fixed reference ODEGL.ODERToGLSceneMatrix <li>07/10/07 - Mrqzzz - Added reference to ODEGL <li>11/09/07 - Mrqzzz - Added reference to ODEImport <li>07/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) Added $I GLScene.inc <li>08/12/04 - SG - Added contact point rendering to TGLODECustomCollider. <li>07/12/04 - SG - Added new TGLODECustomCollider class, Geom collide code now uses Resolution to determine the number of contact points to generate. <li>19/11/04 - SG - Changed TGLODETerrainCollider to TGLODEHeightField which now inherits from TGLODEBehaviour and works for both TGLTerrainRenderer and TGLHeightField objects. Added Capsule, Cylinder and Cone collider code for the heightfield collider. <li>23/04/04 - SG - Removed freeform static collider <li>29/10/03 - SG - Fix for GLODETerrainCollider (Matheus Degiovani) <li>30/07/03 - SG - Creation. </ul>

GLODEManager GLODEManager<p>

An ODE Manager for GLScene.<p>

Where can I find ... ?<ul> <li>GLScene (http://glscene.org) <li>Open Dynamics Engine (http://opende.sourceforge.org) <li>DelphiODE (http://www.cambrianlabs.com/Mattias/DelphiODE) </ul>

Notes: This code is still being developed so any part of it may change at anytime. To install use the GLS_ODE?.dpk in the GLScene/Delphi? folder.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>21/01/01 - DanB - Added "inherited" call to TODEElementPlane.WriteToFiler <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>14/06/10 - YP - Sub-element translation code in CalibrateCenterOfMass removed <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>08/12/08 - PR - dBodySetMass no longer accepts zero mass. check added joint parms now have a 1 appended to them for first parm example dParamLoStop is now dParamLoStop1 <li>17/10/08 - DanB - changed some NotifyChange(Sender) calls to NotifyChange(Self) <li>12/04/08 - DaStr - Cleaned up uses section (thanks Sandor Domokos) (BugtrackerID = 1808373) <li>10/04/08 - DaStr - Removed compiler hints from TGLODEDynamic.AddNewElement() <li>19/03/08 - Mrqzzz - by DAlex : Added different geom colors; Don't create contact between static objects; In Destroying procedures placed to last line the "Inherited" <li>28/02/08 - Mrqzzz - Changed Axis2 to XHMGVector on universal joint creation in TODEJointUniversal.Create <li>06/02/08 - Mrqzzz - Upgrade to ODE 0.9 (upgrade by by Paul Robello; fixes for runtime creation) <li>25/12/07 - DaStr - Fixed access violation in TGLODEManager.Destroy() (thanks Sandor Domokos) (BugtrackerID = 1808371) <li>30/11/07 - Mrqzzz - Changed parameters in OnCollision event (TODEObjectCollisionEvent) <li>10/10/07 - Mrqzzz - Fixed in TGLODEDynamic.AlignObject the explocit reference to ODEGL.ODERToGLSceneMatrix(m,Rˆ,posˆ) to avoid ambiguous overloading <li>08/09/07 - Mrqzzz - small changes in unit references (last reference is to odeimport) in order to make GLODEManager compatible with non-GLODEManager based ODE worlds Added public property "ContactGroup" <li>24/08/07 - Mrqzzz - Updated GetSurfaceFromObject to support correctly Trimesh collision <li>07/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>01/03/05 - Mrqzzz - Moved in TODEJointBase protected code from Loaded to public DoLoaded. <li>20/12/04 - SG - TGLODEStatic objects now realign geoms on step, Fix for Hinge2 and Universal joints, Fix for TGLODEDynamic.Enabled property persistence. <li>10/12/04 - SG - Added TODEElementPlane, Fixed TODEElementCone.Render function. <li>09/12/04 - Mathx - Added getX and getOrCreateX functions. <li>19/11/04 - SG - Major structural changes/improvements, Dropped TGLBaseSceneObject style object in favour of TGLBehaviour style ones, TGLODEBaseBehaviour is now TGLODEBehaviour, TGLODEDynamicBehaviour is now TGLODEDynamic, TGLODEStaticBehaviour is now TGLODEStatic, Added TODEJointParams to handle joint axis parameters, Added RenderPoint to GLODEManager to handle rendering. <li>17/11/04 - SG - Changed Deinitialize to Finalize, Changed TGLODEDummy to TGLODEDynamicDummy. <li>09/11/04 - SG - Fixed problems with contact geom generation (k00m). <li>03/05/04 - SG - Tri-mesh and various fixes/enhancements. <li>23/04/04 - SG - Fixes for object registration, Exception raised now if ODE fails to initialize at run-time. <li>21/04/04 - SG - Changed to dynamic linking DelphiODE, Design-time no longer makes any DelphiODE calls. <li>15/04/04 - SG - Added OnCustomCollision event to TGLODEManager. <li>14/04/04 - SG - Minor DelphiODE compatibility changes. <li>30/03/04 - SG - Joint objects are now fully persistent. <li>05/03/04 - SG - SetSurfaceMode fix (Alex) <li>25/02/04 - SG - Added the GLODEStaticBehaviour. <li>24/02/04 - SG - Added the static GLODETerrain collider. <li>23/02/04 - SG - Fix for design to real time gravity persistence. Added cone, cylinder and tri-mesh elements. Other various fixes/enhancements. <li>28/01/04 - SG - Added TGLODEStaticDummy. Fixed Element alignment code. Other minor fixes/changes. <li>13/11/03 - SG - Fixed bug with destroying geoms, manager now forces registered objects to Deinitialize. Fixed up some comments. <li>12/11/03 - SG - Fixed bug with TGLODEManager.Collision <li>01/09/03 - SG - Changed all relevant floating point types to TdReal, Changed Read/Write Single/Double to Read/Write Float. <li>19/08/03 - SG - Added GetBodyFromGLSceneObject (Dan Bartlett), Added StepFast and FastIterations to GLODEManager. <li>11/08/03 - SG - Added some force/torque methods to dynamic objects. <li>30/07/03 - SG - Split terrain collider into GLODECustomColliders unit. <li>25/07/03 - SG - Fixed Manager property persistence, other minor changes. <li>24/07/03 - SG - ReadFromFiler and WriteToFiler routines added, improved object and joint initialization system. Manager properties not persitent in joints and behaviours. <li>26/06/03 - EG - Replaced TObjectList with TPersistentObjectList, dropped Contnrs dependency (D5 compatibility) <li>23/06/03 - SG - Added GLODETerrainCollider, an implementation from DelphiODE terrain demo (buggy caused assertion error in GLHeightData.pas). <li>13/06/03 - SG - Added more joints. <li>11/06/03 - SG - Base joint classes implemented and added hinge joint. <li>09/06/03 - SG - Added OnCollision event for ODE Objects and Behaviours. <li>08/06/03 - SG - Added rolling friction (experimental). <li>06/06/03 - SG - Added cylinder element (experimental). <li>04/06/03 - SG - Changes to structures, added TGLODEDynamicBehaviour. <li>30/05/03 - SG - Added capsule element and plane object, Fixed problems with Collision callback method. <li>29/05/03 - SG - Better GetCollisionSurface code (thanks to Mattias Fagerlund). <li>28/05/03 - SG - Some fixes to ODE Elements (thanks to Mattias Fagerlund). Added TGLODEDummy.CalibrateCenterOfMass <li>01/03/03 - SG - Creation. </ul>

GLODERagdoll GLODERagdoll<p>

TGLRagdoll extended using Open Dynamics Engine (ODE). <p>

<b>History :</b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: used records with arrays instead of vector arrays <li>13/07/08 - Mrqzzz - replaced constants "cDensity" and "cMass" with global vars "vGLODERagdoll_cDensity" and "vGLODERagdoll_cMass" <li>11/05/08 - Mrqzzz - replaced TGLCube with TODERagdollCube (contains reference to Bone and Ragdoll, useful in collision events) <li>28/02/08 - Mrqzzz - prevent ODE 0.9 "bNormalizationResult failed" error in TODERagdollBone.Start. Fixed a memory leak in TODERagdollBone.Stop <li>05/02/08 - Mrqzzz - upgrade to ODE 0.9 (by paul Robello) <li>09/11/05 - LucasG - Fixed joints to be relative to the body <li>07/11/05 - LucasG - Alignment (Using Stuart's AlignToMatrix function) <li>02/11/05 - LucasG - First version created. </ul></font>

GLODERegister
GLODESkeletonColliders GLODESkeletonColliders<p>

Skeleton colliders for defining and controlling ODE geoms.<p>

<b>History :</b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: restored records with arrays instead of vector arrays <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>12/04/08 - DaStr - Cleaned up uses section (thanks Sandor Domokos) (BugtrackerID = 1808373) <li>06/02/08 - Mrqzzz - Upgrade to ODE 0.9 (replaced references, and CCilinder (ode 0.8) with Capsule(ode 0.9)) <li>02/08/04 - LR, YHC - BCB corrections: use record instead array <li>04/12/03 - SG - Creation. </ul></font>

GLOutlineShader GLOutlineShader<p>

A simple shader that adds an outline to an object. <p>

Limitations: <br> <li> 1. Object can be transparent (color alpha < 1) if it doesn't overlap itself. Texture transparency doesn't work. <li> 2. Doesn't work with objects (e.g. TGLFreeForm) having it's own color array. <li> 3. Doesn't Works with visible backfaces.<p>

<b>History : </b><font size=-1><ul> <li>12/02/11 - Yar - Added skipping shader when enabled stencil test to avvoid conflict with shadow volume <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>06/06/07 - DaStr - Added $I GLScene.inc Added GLColor to uses (BugtrackerID = 1732211) <li>25/02/07 - DaStr - Moved registration to GLSceneRegister.pas <li>05/06/04 - NelC - Fixed bug with textured object <li>14/12/03 - NelC - Removed BlendLine, automatically determine if blend <li>20/10/03 - NelC - Removed unnecessary properties. Shader now honors rci.ignoreMaterials. <li>04/09/03 - NelC - Converted into a component from the TOutlineShader in the multipass demo. </ul></font>

GLParametricSurfaces GLParametricSurfaces<p>

Parametric surface implementation (like Bezier and BSpline surfaces) for GLScene.<p>

Notes: The MOParametricSurface is a TMeshObject descendant that can be used to render parametric surfaces. The Renderer property defines if the surface should be rendered using OpenGL mesh evaluators (through GLU Nurbs for BSplines) or through GLScene using the CurvesAndSurfaces.pas routines to generate the mesh vertices and then rendered through the standard TMeshObject render routine. Please note that BSplines aren't correctly handled yet in the CurvesAndSurfaces unit so the output mesh in GLScene rendering mode is wrong. I'll have it fixed when I know what's going wrong. The GLU Nurbs and glMeshEval Beziers work well though.<p>

The FGBezierSurface is a face group decendant that renders the surface using mesh evaluators. The ControlPointIndices point to the mesh object vertices much the same as vertex indices for other face group flavours. The MinU, MaxU, MinV and MaxV properties allow for drawing specific parts of the bezier surface, which can be used to blend a patch with other patches.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>05/03/10 - DanB - More state added to TGLStateCache <li>31/03/07 - DaStr - Added $I GLScene.inc <li>11/05/04 - SG - Mesh building and texture coord fixes. <li>05/02/04 - SG - Added FGBezierSurface facegroup descendant. <li>20/08/03 - SG - Weighted control points. <li>18/07/03 - SG - Creation. </ul></font>

GLParticleFX GLParticleFX<p>

Base classes for scene-wide blended particles FX.<p>

These provide a mechanism to render heterogenous particles systems with per particle depth-sorting (allowing correct rendering of interwoven separate fire and smoke particle systems for instance).<p>

<b>History : </b><font size=-1><ul> <li>21/01/01 - DanB - Added "inherited" call to TGLParticleFXEffect.WriteToFiler <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>22/01/10 - Yar - Added bmp32.Blank:=false for memory allocation and fix RegisterAsOpenGLTexture <li>12/10/08 - DanB - fix to TGLLifeColoredPFXManager.ComputeRotateAngle (it used lck.FDoScale instead of lck.FDoRotate), made more use of RCI instead of accessing via global variables. Changed order of transformations when rendering particles, now does rotation+scaling before translation. Disabled FRotationCenter, <li>15/02/08 - Mrqzzz - Fixed SizeScale in Lifetimes of TGLBaseSpritePFXManager (was ignored) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>02/04/07 - DaStr - TPFXLifeColors now inherits from TOwnedCollection (thanks Burkhard Carstens) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>14/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>24/01/07 - DaStr - TGLSourcePFXEffect.Burst and TGLBaseSpritePFXManager.RenderParticle bugfixed TGLLifeColoredPFXManager.RotateVertexBuf bugfixed (all based on old code) <li>28/10/06 - LC - Fixed access violation in TGLParticleFXRenderer. Bugtracker ID=1585907 (thanks Da Stranger) <li>19/10/06 - LC - Fixed memory leak in TGLParticleFXManager. Bugtracker ID=1551866 (thanks Dave Gravel) <li>08/10/05 - Mathx - Fixed access violation when a PFXManager was removed from form but a particleFX still had a reference to it (added the FUsers property). Butracker ID=783625. <li>17/02/05 - EG - Restored correct PFXSource.Burst relative/absolute behaviour, EffectsScale support not added back (no clue what it does... Mrqz?) <li>23/11/04 - SG - Fixed memory leak in TGLLifeColoredPFXManager (kenguru) <li>03/10/04 - Mrqzzz - added property TGLParticleFXEffect.DisabledIfOwnerInvisible. Fixed PositionDispersionRange to honour VelocityMode=svmRelative <li>25/09/04 - Graham Kennedy - Fixed restore of currentTexturingMode <li>09/09/04 - Mrqzzz - added property TGLParticleFXEffect.EffectScale allowing different scaling of effect with same manager. TGLParticleFXEffect.ArchiveVersion updated to 4 <li>02/08/04 - LR, YHC - BCB corrections: use record instead array Replace direct access of some properties by a getter and a setter. fixed undefined TPFXRegion error in BCB <li>29/08/04 - Mrqzzz - fixed particles initial position when VelocityMode=svmRelative <li>28/08/04 - Mrqzzz - fixed particles direction when VelocityMode=svmRelative <li>09/07/04 - Mrqzzz - small fixup (TGLSourcePFXEffect.WriteToFiler Archive V.4) <li>08/07/04 - Eugene Kryukov - Added rotation for particles, RotateAngle in LifeColor. And added AbsoluteRotation for TGLDynamicPFXManager <li>25/04/04 - EG - Added friction, Life sizes, multiple sprites per texture and sprites sharing <li>24/04/04 - Mrqzzz - Added property "enabled" to TGLSourcePFXEffect <li>15/04/04 - EG - AspectRatio and Rotation added to sprite PFX, improved texturing mode switches <li>26/05/03 - EG - Improved TGLParticleFXRenderer.BuildList <li>05/11/02 - EG - Enable per-manager blending mode control <li>27/01/02 - EG - Added TGLLifeColoredPFXManager, TGLBaseSpritePFXManager and TGLPointLightPFXManager. <li>23/01/02 - EG - Added ZWrite and BlendingMode to the PFX renderer, minor sort and render optims <li>22/01/02 - EG - Another RenderParticle color lerp fix (GliGli) <li>20/01/02 - EG - Several optimization (35% faster on Volcano bench) <li>18/01/02 - EG - RenderParticle color lerp fix (GliGli) <li>08/09/01 - EG - Creation (GLParticleFX.omm) </ul></font>

GLParticles GLParticles<p>

Particle systems for GLScene, based on replication of full-featured scene objects.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>27/07/04 - EG - Added KillParticles <li>18/04/04 - EG - Added Before/After events <li>12/07/01 - EG - Fixed FEdgeColor memory leak <li>18/07/01 - EG - VisibilityCulling compatibility changes <li>17/04/00 - EG - Added Assign, Removed ActivateParticle <li>16/04/00 - EG - Creation </ul></font>

GLPerlin
GLPerlinBase GLScene<p>

Functions for generating perlin noise.<p>

<b>History : </b><font size=-1><ul> <li>20/05/10 - Yar - Fixes for Linux x64 <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Cosmetic fixes for FPC compatibility. <li>29/01/03 - JaJ - Submitted to GLScene. </ul></font>

GLPerlinPFX GLPerlinPFX<p>

PFX particle effects revolving around the use of Perlin noise.<p>

<b>History : </b><font size=-1><ul> <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/01/10 - Yar - Added bmp32.Blank:=false for memory allocation <li>30/03/07 - DaStr - Added $I GLScene.inc <li>16/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>15/04/04 - Mrqzzz - Fixed range check error suggested by Graham Kennedy <li>15/04/04 - EG - Creation </ul></font>

GLPhongShader GLPhongShader<p>

An ARBvp1.0 + ARBfp1.0 shader that implements phong shading.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>28/07/09 - DaStr - Small changes and simplifications <li>24/07/09 - DaStr - TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) <li>20/03/07 - DaStr - Moved some of the stuff from TGLCustomAsmShader back here <li>25/02/07 - DaStr - Completely replaced with a descendant of TGLCustomAsmShader. <li>11/10/04 - SG - Creation. </ul></font>

GLPipelineTransformation GLPipelineTransformation<p>

<b>History : </b><font size=-1><ul> <li>11/05/11 - Yar - Ranamed TGLPipelineTransformation to TGLTransformation <li>16/11/10 - Yar - Added NormalModelMatrix <li>23/08/10 - Yar - Creation </ul></font>

GLPolyhedron Standard polyhedrons.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses <li>20/01/04 - SG - Added TGLIcosahedron <li>21/07/03 - EG - Creation from GLObjects split </ul></font>

GLPortal GLPortal<p>

Portal Rendering support for GLScene.<p>

The portal structures are subclasses of the Mesh structures, with a "sector" being assimilated to a "MeshObject" and sector polygons to facegroups.<p>

<b>Historique : </b><font size=-1><ul> <li>30/03/07 - DaStr - Added $I GLScene.inc <li>30/01/03 - Egg - Completed class registration <li>13/08/00 - Egg - Creation </ul></font>

GLPostEffects GLPostEffects<p>

A collection of components that generate post effects.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>28/05/08 - DaStr - Fixed AV in TGLPostEffect.MakeDistortEffect() Got rid of all R- hacks <li>10/04/08 - DaStr - Added a Delpi 5 interface bug work-around to TGLPostShaderCollectionItem.SetShader() (BugTracker ID = 1938988) <li>16/08/07 - DaStr - Added pepBlur preset (by Paul van Dinther) <li>25/03/07 - DaStr - Small fix for Delphi5 compatibility <li>23/03/07 - DaStr - Added TGLPostShaderHolder.Assign <li>20/03/07 - DaStr - Fixed TGLPostShaderHolder.DoRender <li>09/03/07 - DaStr - Added pepNightVision preset (thanks Roman Ganz) Changed back all Trunc() calls to Round() <li>07/03/07 - DaStr - Moved "Weird" effect to the demo Added "Distort" effect Modified "RedNoise" to simple monochrome noise (preset renamed to "Noise") Made "Negative" effect really negative, instead swapping R and B channels Changed all Round() calls to Trunc() Removed all TGLPostEffectColor typecasts (All above changes were made by Michail Glukhov) TGLPostEffect and TGLPostShaderHolder are not rendered when DrawState=dsPicking (suggested by Riz) <li>04/03/07 - DaStr - Added TGLPostShaderHolder <li>02/03/07 - DaStr - TGLOnCustomPostEffectEvent now passes rci pepNone preset does not call gl[Read/Draw]Pixels <li>23/02/07 - DaStr - Initial version of TGLPostEffect (based on OldCity demo by FedeX) </ul></font>

GLProcTextures GLProcTextures<p>

Procedural textures.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>22/01/10 - Yar - Added bmp32.Blank:=false for memory allocation, Depth dimension, NativeTextureTarget becomes property <li>16/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>01/10/04 - ilh - Added SetPermFromData and SetPermToDefault moved PERM array to protected from inside Noise procedure so it can be changed by SetPermFromData and SetPermToDefault Added FNoiseRandSeed property so a Seed can be set Starts with a random Generated Seed... One must be set to BE Seeded <li>11/12/02 - ??? - Initial, procedural perlin noise texture code by Tobias Peirick </ul></font><p>

I used the following references for my implementation:<p>

http://freespace.virgin.net/hugo.elias/models/m_perlin.htm<br> http://freespace.virgin.net/hugo.elias/models/m_clouds.htm<br> http://www.delphi3d.net<p>

Tobias Peirick

GLProjectedTextures GLProjectedTextures<p>

Implements projected textures through a GLScene object.

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed const cBase matrix <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>15/06/05 - Mathx - Added the Style property and inverse rendering <li>07/05/05 - Mathx - Support for tmBlend textures (by Ruben Javier) <li>01/10/04 - SG - Initial (by Matheus Degiovani) </ul></font>

GLProxyObjects GLProxyObjects<p>

Implements specific proxying classes.<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>25/12/09 - DaStr - Bugfixed TGLActorProxy.RayCastIntersect() in aarMorph mode (thanks Vovik) <li>22/12/09 - DaStr - Added TGLActorProxy.AnimationMode (thanks Vovik) Removed TGLActorProxy.Interval (was not used) <li>18/06/08 - mrqzzz - Don't raise error when setting animation to an ActorProxy and no MasterObject is defined <li>15/03/08 - DaStr - Fixup after previous update: removed all hints and warnings, TGLActorProxy now has two versions of RayCastIntersect() <li>06/02/08 - mrqzzz - Added a "RayCastIntersect" overload for Actorproxy <li>07/11/07 - mrqzzz - Added "OnBeforeRender" event to Actorproxy allowing to apply extra transformations (f.ex: bone rotations) to the referenced Actor in order to have the proxy render these changes. <li>07/11/07 - mrqzzz - Added "StoredBoneNames" property <li>07/11/07 - mrqzzz - Added "BoneMatrix(Boneidndex|boneName)" function and StoreBonesMatrix property for TGLActorProxy (To read each ActorProxy's individual Bone matrices, f.ex to align a weapon in it's hand) <li>06/11/07 - mrqzzz - Added MaterialLibrary and LibMaterialName for TGLActorProxy (allows different materials on proxy actors sharing same master) <li>06/11/07 - mrqzzz - Added public readonly properties for TGLActorProxy (CurrentFrame,StartFrame,Endframe,etc..) <li>05/10/07 - DaStr - Bugfixed TGLMaterialProxy.DoRender (Bugtracker ID = 1808666) <li>04/09/07 - DaStr - Added TGLMaterialProxy Cleaned up this unit a bit <li>10/05/07 - DaStr - Bugfixed TGLColorProxy.DoRender (thanks Paul Robello) (Bugtracker ID = 1716692) <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>25/02/07 - Made TGLActorProxy.SetAnimation a bit safer <li>20/02/07 - DaStr - Redeclared MasterObject of TGLColorProxy and TGLFreeFormProxy Added TGLActorProxy (based on a demo published on the newsgroup by don't know who...) <li>18/12/03 - Dave - Dropped "Object" from "ProxyObject" class names <li>17/12/03 - Dave - Changed class check in Octree code to Assert <li>17/12/03 - Dave+Dan - Added OctreeSphereSweep <li>06/12/03 - EG - Creation from GLScene.pas split </ul></font>

GLRagdoll GLRagdoll<p>

Base abstract ragdoll class. Should be extended to use any physics system. <p>

<b>History :</b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to arrays of records <li>23/08/10 - Yar - Added VectorTypes to uses <li>09/11/05 - LucasG - Fixed joint and few small things <li>07/11/05 - LucasG - Fixed bone position and rotation (Align to animation) <li>02/11/05 - LucasG - First version created. </ul></font>

GLRenderContextInfo GLRenderContextInfo<p>

Stores contextual info useful during rendering methods.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Removed modelViewMatrix, lightDisableCounter. Added PipelineTransformation. <li>22/02/10 - Yar - Added bufferLighting, bufferFog, bufferDepthTest to TRenderContextInfo <li>14/03/09 - DanB - Removed IsVolumeClipped functions, instead replaced with IsVolumeClipped functions in VectorGeometry.pas that use TFrustrum <li>09/10/08 - DanB - Added TRenderContextClippingInfo + IsVolumeClipped functions from VectorGeometry.pas, added nearClippingDistance <li>05/10/08 - DanB - Created from GLTexture.pas split </ul></font>

GLROAMPatch GLROAMPatch<p>

Class for managing a ROAM (square) patch.<p>

<b>History : </b><font size=-1><ul> <li>22/08/10 - DaStr - Fixed compiler warning <li>27/07/10 - YP - Safe tesselation operation to avoid AV after a memory shift <li>26/07/10 - YP - Invalid range test when splitting, we need to check space for n and n+1 <li>20/05/10 - Yar - Fixes for Linux x64 <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>30/03/07 - DaStr - Added $I GLScene.inc <li>19/10/06 - LC - Added code to gracefully handle the case when MaxCLODTriangles is reached. It will now increase the buffer instead of not splitting. Bugtracker ID=1574111 <li>09/10/06 - Lin - Added OnMaxCLODTrianglesReached event. <li>09/06/06 - Lin - Bugfix: Stop splitting Triangles when MaxCLODTriangles is reached (prevents Access Violations) <li>10/06/05 - Mathx - Protection against cards that have GL_EXT_compiled_vertex_array but not GL_EXT_draw_range_elements <li>25/04/04 - EG - Occlusion testing support <li>06/02/03 - EG - Adaptative variance computation <li>03/12/02 - EG - Minor ROAM tessel/render optimizations <li>15/06/02 - EG - Fixed patch rendering bug "introduced" by TBaseList fix <li>24/02/02 - EG - Hybrid ROAM-stripifier engine <li>10/09/01 - EG - Creation </ul></font>

GLSArchiveManager | <b>History : </b><font size=-1><ul> <li>04/06/10 - Yar - Added to GLScene (Created by Rustam Asmandiarov aka Predator) </ul></font>
GLScene GLScene<p>

Base classes and structures for GLScene.<p>

<b>History : </b><font size=-1><ul> <li>03/02/13 - Yar - Added master's scale transformation to TGLProxyObject (thanks to Dmitriy aka buh) <li>20/11/12 - PW - Added CPP compatibility: changed arrays of vectors to records with arrays <li>15/10/11 - YP - Don't set GLSelection buffer size, it's automatically done in the repeat until loop <li>02/09/11 - Yar - Added csPerspectiveKeepFOV to TGLCamera.CameraStyle (thanks benok1) <li>30/06/11 - DaStr - Bugfixed VisibilityCulling in vcObjectBased mode <li>04/05/11 - Vince - Fix picking problems with Ortho2D Camera <li>21/11/10 - Yar - Added design time navigation <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>25/10/10 - Yar - Bugfixed TGLSceneBuffer.CopyToTexture <li>08/09/10 - Yar - Added gloabal var vCurrentRenderingObject (Thanks Controller) <li>02/09/10 - Yar - Added GLSelection to uses. Improved TGLSceneBuffer.PickObjects for 64-bit OSes <li>29/08/10 - Yar - Bugfixed TGLSceneBuffer.DoStructuralChange when component loading causing excessive context recreation <li>23/08/10 - Yar - Removed all critical deprecated OpenGL function from rendering cycle. Now TGLSceneBuffer can work with forward core context. Pipeline transformation and lighting becomes abststract. <li>18/06/10 - Yar - Replaced OpenGL1x functions to OpenGLAdapter. Changed AddBuffer to improved GLX context sharing. <li>31/05/10 - Yar - Fixes for Linux x64 <li>31/05/10 - Yar - Added roSoftwareMode Buffer.ContextOptions <li>22/04/10 - Yar - Fixes after GLState revision <li>11/04/10 - Yar - Replaced glNewList to GLState.NewList in TGLBaseSceneObject.GetHandle <li>06/04/10 - Yar - Removed double camera freeing in TGLSceneBuffer.Destroy (thanks to Rustam Asmandiarov aka Predator) <li>06/03/10 - Yar - Renamed ModelViewMatrix to ViewMatrix, added ModelMatrix All function working with ModelViewMatrix now deprecated Added roForwardContext to buffer options <li>05/03/10 - DanB - More state added to TGLStateCache <li>22/02/10 - DanB - Moved TGLSceneBuffer.GLStates to TGLContext.GLStates <li>22/02/10 - Yar - Added Push/PopProjectionMatrix to TGLSceneBuffer Optimization of switching states <li>14/03/09 - DanB - Moved RenderScene from TGLScene to TGLSceneBuffer, removed TGLScene.Cameras, place cameras inside scene instead. TGLObjectEffect no longer has "buffer" parameter in render events. <li>24/11/08 - DanB - TGLBaseSceneObject.Assign no longer changes scene of destination object (thanks Alan G.) <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 changed PChar to Pointer where possible <li>12/10/08 - DanB - added nearClippingDistance to RCI <li>09/10/08 - DanB - removed TGLScene.RenderedObject, moved TGLProgressEvent to BaseClasses <li>20/04/08 - DaStr - Added a AABB cauching mechanism to TGLBaseSceneObject TGLDirectOpenGL's dimentions are now all all zeros (all above changes were made by Pascal) <li>15/03/08 - DaStr - Implemented TGLProxyObject.BarycenterAbsolutePosition() <li>16/02/08 - Mrqzzz - Other fix to ResetAndPitchTurnRoll by Pete,Dan Bartlett <li>12/02/08 - Mrqzzz - Dave Gravel fixed ResetAndPitchTurnRoll <li>20/01/08 - DaStr - Bugfixed TGLBaseSceneObject.MoveChild[First/Last]() (thanks "_") (BugTracker ID = 1857974) Converted the TGLBaseSceneObject.AbsoluteMatrix() function into a property (and added a Set method) Added TGLBaseSceneObject.AbsoluteLeft() <li>19/09/07 - DaStr - Made some changes to TGLBaseSceneObject Bounding Box calculations (BugTracker ID = 1797491) <li>17/09/07 - DaStr - Fixed TGLScene.RenderScene (InitializableObjects stuff) (BugTracker ID = 1796358) Moved TGLBaseSceneObject.SetScene to the protected section <li>10/09/07 - DaStr - TGLBaseSceneObject: Added AxisAlignedBoundingBoxAbsolute Bugfixed GetAbsoluteScale <li>08/09/07 - DaStr - Added TGLBaseSceneObject.Absolute[Affine]Scale <li>18/06/07 - DaStr - Fixed bug which caused objects' order to get inverted (BugtrackerID = 1739180) (thanks Burkhard Carstens) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>03/04/07 - DaStr - GLS_DELPHI_5_UP renamed to GLS_DELPHI_4_DOWN for FPC compatibility (thanks Burkhard Carstens) <li>29/03/07 - DaStr - GLS_WANT_DATA removed Added IGLInitializable, TGLInitializableObjectList Added TGLScene.InitializableObjects <li>28/03/07 - DaStr - Added more explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) Fixed TGLBaseSceneObject.Destroy (potential AV) <li>26/03/07 - aidave - Added MoveFirst, MoveLast <li>26/03/07 - aidave - Added MoveChildFirst, MoveChildLast <li>25/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>14/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>10/03/07 - DaStr - TGLSceneBuffer's Events are not stored now (thanks Burkhard Carstens) (BugtrackerID = 1678654) <li>15/02/07 - DaStr - TGLBaseSceneObject.GetChildren bugfixed (subcomponent support) <li>09/02/07 - DaStr - TGLBaseSceneObject.ExchangeChildren(Safe) added (thanks apo_pq) Global $R- removed <li>07/02/07 - DaStr - TGLBaseSceneObject.Remove bugfixed (subcomponent support) TGLBaseSceneObject.HasSubChildren added <li>20/12/06 - DaStr - TGLBaseSceneObject: AbsoluteAffine[Position/Direction/up] added Affine[Right/LeftVector] added OnAddedToParent Event and DoOnAddedToParent() procedure added DistanceTo() and SqrDistanceTo() overloaded Support for GLS_OPTIMIZATIONS added <li>19/10/06 - LC - Fixed TGLSceneBuffer.OrthoScreenToWorld. Bugtracker ID=1537765 (thanks dikoe) <li>19/10/06 - LC - Removed unused assignment in TGLSceneBuffer.SaveAsFloatToFile <li>13/09/06 - NelC - Added TGLSceneBuffer.SaveAsFloatToFile <li>12/09/06 - NelC - Added roNoDepthBufferClear, support for Multiple-Render-Target <li>17/07/06 - PvD - Fixed TGLSceneBuffer.OrthoScreenToWorld sometimes translates screen coordinates incorrectly <li>08/03/06 - ur - added global OptSaveGLStack variable for "arbitrary" deep scene trees <li>06/03/06 - Mathx - Fixed Freeze/Melt (thanks Fig) <li>04/12/04 - MF - Changed FieldOfView to work with degrees (not radians) <li>04/12/04 - MF - Added GLCamera.SetFieldOfView and GLCamera.GetFieldOfView, formula by Ivan Sivak Jr. <li>04/10/04 - NelC - Added support for 64bit and 128bit color depth (float pbuffer) <li>07/07/04 - Mrqzzz - TGLbaseSceneObject.Remove checks if removed object is actually a child (Uffe Hammer) <li>25/02/04 - Mrqzzz - Added TGLSCene.RenderedObject <li>25/02/04 - EG - Children no longer owned <li>13/02/04 - NelC - Added option Modal for ShowInfo <li>04/02/04 - SG - Added roNoSwapBuffers option to TContextOptions (Juergen Abel) <li>09/01/04 - EG - Added TGLCameraInvariantObject <li>06/12/03 - EG - TGLColorProxy moved to new GLProxyObjects unit, GLVectorFileObjects dependency cut. <li>06/12/03 - EG - New FramesPerSecond logic <li>04/12/03 - Dave - Added ProxyObject.OctreeRayCastIntersect <li>26/12/03 - EG - Removed last TList dependencies <li>05/12/03 - Dave - Added GLCamera.PointInFront - Dave - Remade Data property to use Tag <li>05/11/03 - EG - Data pointer made optional (GLS_WANT_DATA define), applications should use VCL's standard (ie. "Tag") <li>04/11/03 - Dave - Added Data pointer to GLSceneBaseObject <li>24/10/03 - NelC - Fixed texture-flipped bug in cubemap generation <li>21/08/03 - EG - Added osRenderNearestFirst <li>28/07/03 - aidave - Added TGLColorProxyObject <li>22/07/03 - EG - LocalMatrix now a PMatrix, FListHandle and FChildren are now autocreating <li>17/07/03 - EG - Removed TTransformationMode and related code <li>16/07/03 - EG - TGLBaseGuiObject moved to GLGui along with RecursiveVisible mechanism <li>19/06/03 - DanB - Added TGLBaseSceneObject.GetOrCreateBehaviour/Effect <li>11/06/03 - Egg - Added CopyToTexture for buffer <li>10/06/03 - Egg - Fixed issue with SetXxxxAngle (Domin) <li>07/06/03 - Egg - Added Buffer.AmbientColor <li>06/06/03 - Egg - Added roNoColorBufferClear <li>21/05/03 - Egg - RenderToBitmap RC setup fixes (Yurik) <li>07/05/03 - Egg - TGLSceneBuffer now invokes BeforeRender and PostRender events even when no camera has been specified <li>13/02/03 - DanB - added unscaled Dimensions and Bounding Box methods <li>03/01/03 - JAJ - Added TGLBaseGuiObject as minimal base GUI class. <li>31/12/02 - JAJ - NotifyHide/NotifyShow implemented. Crucial for the Gui system. <li>14/10/02 - Egg - Camera.TargetObject explicitly registered for notifications <li>07/10/02 - Egg - Fixed Remove/Add/Insert (sublights registration bug) <li>04/09/02 - Egg - BoundingBox computation now based on AABB code, Fixed TGLSceneBuffer.PixelRayToWorld <li>27/08/02 - Egg - Added TGLProxyObject.RayCastIntersect (Matheus Degiovani), Fixed PixelRayToWorld <li>22/08/02 - Egg - Fixed src LocalMatrix computation on Assign <li>12/08/02 - Egg - Fixed Effects persistence 'Assert' issue (David Alcelay), TGLSceneBuffer.PickObjects now preserves ProjMatrix <li>13/07/02 - Egg - Fixed CurrentStates computation <li>01/07/02 - Egg - Fixed XOpenGL picking state <li>03/06/02 - Egg - TGLSceneBuffer.DestroyRC now removes buffer from scene's list <li>30/05/02 - Egg - Fixed light movements not triggering viewer redraw issue, lights no longer 'invisible' (sub objects get rendered) <li>05/04/02 - Egg - Fixed XOpenGL initialization/reinitialization <li>13/03/02 - Egg - Fixed camera-switch loss of "reactivity" <li>08/03/02 - Egg - Fixed InvAbsoluteMatrix/AbsoluteMatrix decoupling <li>05/03/02 - Egg - Added MoveObjectAround <li>04/03/02 - Egg - CoordinateChanged default rightVector based on X, then Y <li>27/02/02 - Egg - Added DepthPrecision and ColorDepth to buffer, ResetAndPitchTurnRoll, ShadeModel (Chris Strahm) <li>26/02/02 - Egg - DestroyHandle/DestroyHandles split, Fixed PickObjects guess count (Steffen Xonna) <li>22/02/02 - Egg - Push/pop ModelView matrix for buffer <li>07/02/02 - Egg - Faster InvAbsoluteMatrix computation <li>06/02/02 - Egg - ValidateTransformations phased out <li>05/02/02 - Egg - Added roNoColorBuffer <li>03/02/02 - Egg - InfoForm registration mechanism, AbsolutePosition promoted to read/write property <li>27/01/02 - Egg - Added TGLCamera.RotateObject, fixed SetMatrix, added RotateAbsolute, ResetRotations <li>21/01/02 - Egg - More graceful recovery for ICDs without pbuffer support <li>10/01/02 - Egg - Fixed init of stCullFace in SetupRenderingContext, MoveAroundTarget/AdjustDistanceToTarget absolute pos fix <li>07/01/02 - Egg - Added some doc, reduced dependencies, RenderToBitmap fixes <li>28/12/01 - Egg - Event persistence change (GliGli / Dephi bug), LoadFromStream fix (noeska) <li>16/12/01 - Egg - Cube maps support (textures and dynamic rendering) <li>15/12/01 - Egg - Added support for AlphaBits <li>12/12/01 - Egg - Introduced TGLNonVisualViewer, TGLSceneViewer moved to GLWin32Viewer <li>07/12/01 - Egg - Added TGLBaseSceneObject.PointTo <li>06/12/01 - Egg - Published OnDblClik and misc. events (Chris S), Some cross-platform cleanups <li>05/12/01 - Egg - MoveAroundTarget fix (Phil Scadden) <li>30/11/01 - Egg - Hardware acceleration detection support, Added Camera.SceneScale (based on code by Chris S) <li>24/09/01 - Egg - TGLProxyObject loop rendering protection <li>14/09/01 - Egg - Use of vFileStreamClass <li>04/09/01 - Egg - Texture binding cache <li>25/08/01 - Egg - Support for WGL_EXT_swap_control (VSync control), Added TGLMemoryViewer <li>24/08/01 - Egg - TGLSceneViewer broken, TGLSceneBuffer born <li>23/08/01 - Lin - Added PixelDepthToDistance function (Rene Lindsay) <li>23/08/01 - Lin - Added ScreenToVector function (Rene Lindsay) <li>23/08/01 - Lin - Fixed PixelRayToWorld no longer requires the camera to have a TargetObject set. (Rene Lindsay) <li>22/08/01 - Egg - Fixed ocStructure not being reset for osDirectDraw objects, Added Absolute-Local conversion helpers, glPopName fix (Puthoon) <li>20/08/01 - Egg - SetParentComponent now accepts 'nil' (Uwe Raabe) <li>19/08/01 - Egg - Default RayCastIntersect is now Sphere <li>16/08/01 - Egg - Dropped Prepare/FinishObject (became obsolete), new CameraStyle (Ortho2D) <li>12/08/01 - Egg - Completely rewritten handles management, Faster camera switching <li>29/07/01 - Egg - Added pooTransformation <li>19/07/01 - Egg - Focal lengths in the ]0; 1[ range are now allowed (beware!) <li>18/07/01 - Egg - Added VisibilityCulling <li>09/07/01 - Egg - Added BoundingBox methods based on code from Jacques Tur <li>08/07/01 - Egg - Fixes from Simon George added in (HDC, contexts and leaks related in TGLSceneViewer), dropped the TCanvas, Added PixelRayToWorld (by Rene Lindsay) <li>06/07/01 - Egg - Fixed Turn/Roll/Pitch Angle Normalization issue <li>04/07/01 - Egg - Minor VectorTypes related changes <li>25/06/01 - Egg - Added osIgnoreDepthBuffer to TObjectStyles <li>20/03/01 - Egg - LoadFromFile & LoadFromStream fixes by Uwe Raabe <li>16/03/01 - Egg - SaveToFile/LoadFromFile additions/fixes by Uwe Raabe <li>14/03/01 - Egg - Streaming fixes by Uwe Raabe <li>03/03/01 - Egg - Added Stencil buffer support <li>02/03/01 - Egg - Added TGLSceneViewer.CreateSnapShot <li>01/03/01 - Egg - Fixed initialization of rci.proxySubObject (broke picking) <li>26/02/01 - Egg - Added support for GL_NV_fog_distance <li>25/02/01 - Egg - Proxy's subobjects are now pushed onto the picking stack <li>22/02/01 - Egg - Changed to InvAbsoluteMatrix code by Uwe Raabe <li>15/02/01 - Egg - Added SubObjects picking code by Alan Ferguson <li>31/01/01 - Egg - Fixed Delphi4 issue in TGLProxyObject.Notification, Invisible objects are no longer depth-sorted <li>21/01/01 - Egg - Simplified TGLBaseSceneObject.SetName <li>17/01/01 - Egg - New TGLCamera.MoveAroundTarget code by Alan Ferguson, Fixed TGLBaseSceneObject.SetName (thx Jacques Tur), Fixed AbsolutePosition/AbsoluteMatrix <li>13/01/01 - Egg - All transformations are now always relative, GlobalMatrix removed/merged with AbsoluteMatrix <li>10/01/01 - Egg - If OpenGL is unavailable, TGLSceneViewer will now work as a regular (blank) WinControl <li>08/01/01 - Egg - Added DoRender for TGLLightSource & TGLCamera <li>04/01/01 - Egg - Fixed Picking (broken by Camera-Sprite fix) <li>22/12/00 - Egg - Fixed error detection in DoDestroyList <li>20/12/00 - Egg - Fixed bug with deleting/freeing a branch with cameras <li>18/12/00 - Egg - Fixed deactivation of Fog (wouldn't deactivate) <li>11/12/00 - Egg - Changed ConstAttenuation default to 0 (VCL persistence bug) <li>05/11/00 - Egg - Completed Screen->World function set, finalized rendering logic change, added orthogonal projection <li>03/11/00 - Egg - Fixed sorting pb with osRenderBlendedLast, Changed camera/world matrix logic, WorldToScreen/WorldToScreen now working <li>30/10/00 - Egg - Fixes for FindChild (thx Steven Cao) <li>12/10/00 - Egg - Added some doc <li>08/10/00 - Egg - Fixed assignment HDC/display list quirk <li>08/10/00 - Egg - Based on work by Roger Cao : Rotation property in TGLBaseSceneObject, Fix in LoadFromfile to avoid name changing and lighting error, Added LoadFromTextFile and SaveToTextFile, Added FindSceneObject <li>25/09/00 - Egg - Added Null checks for SetDirection and SetUp <li>13/08/00 - Egg - Fixed TGLCamera.Apply when camera is not targeting, Added clipping support stuff <li>06/08/00 - Egg - TGLCoordinates moved to GLMisc <li>23/07/00 - Egg - Added GetPixelColor/Depth <li>19/07/00 - Egg - Fixed OpenGL states messup introduces with new logic, Fixed StructureChanged clear flag bug (thanks Roger Cao) <li>15/07/00 - Egg - Altered "Render" logic to allow relative rendering, TProxyObject now renders children too <li>13/07/00 - Egg - Completed (?) memory-leak fixes <li>12/07/00 - Egg - Added 'Hint' property to TGLCustomSceneObject, Completed TGLBaseSceneObject.Assign, Fixed memory loss in TGLBaseSceneObject (Scaling), Many changes to list destruction scheme <li>11/07/00 - Egg - Eased up propagation in Structure/TransformationChanged <li>28/06/00 - Egg - Added ObjectStyle to TGLBaseSceneObject, various changes to the list/handle mechanism <li>22/06/00 - Egg - Added TLightStyle (suggestion by Roger Cao) <li>19/06/00 - Egg - Optimized SetXxxAngle <li>09/06/00 - Egg - First row of Geometry-related upgrades <li>07/06/00 - Egg - Removed dependency to 'Math', RenderToFile <-> Bitmap Overload (Aaron Hochwimmer) <li>28/05/00 - Egg - AxesBuildList now available as a procedure, Un-re-fixed TGLLightSource.DestroyList, Fixed RenderToBitmap <li>26/05/00 - Egg - Slightly changed DrawAxes to avoid a bug in nVidia OpenGL <li>23/05/00 - Egg - Added first set of collision-detection methods <li>22/05/00 - Egg - SetXxxxAngle now properly assigns to FXxxxAngle <li>08/05/00 - Egg - Added Absolute?Vector funcs to TGLBaseSceneObject <li>08/05/00 - RoC - Fixes in TGLScene.LoadFromFile, TGLLightSource.DestroyList <li>26/04/00 - Egg - TagFloat now available in TGLBaseSceneObject, Added TGLProxyObject <li>18/04/00 - Egg - Added TGLObjectEffect structures, TGLCoordinates.CreateInitialized <li>17/04/00 - Egg - Fixed BaseSceneObject.Assign (wasn't duping children), Removed CreateSceneObject, Optimized TGLSceneViewer.Invalidate <li>16/04/00 - Egg - Splitted Render to Render + RenderChildren <li>11/04/00 - Egg - Added TGLBaseSceneObject.SetScene (thanks Uwe) and fixed various funcs accordingly <li>10/04/00 - Egg - Improved persistence logic for behaviours, Added RegisterGLBehaviourNameChangeEvent <li>06/04/00 - Egg - RebuildMatrix should be slightly faster now <li>05/04/00 - Egg - Added TGLBehaviour stuff, Angles are now public stuff in TGLBaseSceneObject <li>26/03/00 - Egg - Added TagFloat to TGLCustomSceneObject, Parent is now longer copied in "Assign" <li>22/03/00 - Egg - TGLStates moved to GLMisc, Removed TGLCamera.FModified stuff, Fixed position bug in TGLScene.SetupLights <li>20/03/00 - Egg - PickObjects now uses "const" and has helper funcs, Dissolved TGLRenderOptions into material and face props (RIP), Joystick stuff moved to a separate unit and component <li>19/03/00 - Egg - Added DoProgress method and event <li>18/03/00 - Egg - Fixed a few "Assign" I forgot to update after adding props, Added bmAdditive blending mode <li>14/03/00 - Egg - Added RegisterGLBaseSceneObjectNameChangeEvent, Added BarycenterXxx and SqrDistance funcs, Fixed (?) AbsolutePosition, Added ResetPerformanceMonitor <li>14/03/00 - Egg - Added SaveToFile, LoadFromFile to GLScene, <li>03/03/00 - Egg - Disabled woTransparent handling <li>12/02/00 - Egg - Added Material Library <li>10/02/00 - Egg - Added Initialize to TGLCoordinates <li>09/02/00 - Egg - All GLScene objects now begin with 'TGL', OpenGL now initialized upon first create of a TGLSceneViewer <li>07/02/00 - Egg - Added ImmaterialSceneObject, Added Camera handling funcs : MoveAroundTarget, AdjustDistanceToTarget, DistanceToTarget, ScreenDeltaToVector, TGLCoordinates.Translate, Deactivated "specials" (ain't working yet), Scaling now a TGLCoordinates <li>06/02/00 - Egg - balanced & secured all context activations, added Assert & try..finally & default galore, OpenGLError renamed to EOpenGLError, ShowErrorXxx funcs renamed to RaiseOpenGLError, fixed CreateSceneObject (was wrongly requiring a TCustomForm), fixed DoJoystickCapture error handling, added TGLUpdateAbleObject <li>05/02/00 - Egg - Javadocisation, fixes and enhancements :<br> TGLSceneViewer.SetContextOptions, TActiveMode -> TJoystickDesignMode, TGLCamera.TargetObject and TGLCamera.AutoLeveling, TGLBaseSceneObject.CoordinateChanged </ul></font>

GLScene.FMX.Viewer
GLSceneEdit GLSceneEdit<p>

Scene Editor, for adding + removing scene objects within the Delphi IDE.<p>

<b>History : </b><font size=-1><ul> <li>20/01/10 - Yar - TGLSceneEditorForm.IsPastePossible now uses CharInSet <li>20/01/10 - Yar - Added Expand and Collapse buttons (thanks to lolo) <li>14/03/09 - DanB - Removed Cameras node, instead cameras are now placed into scene <li>19/03/08 - mrqzzz - Little change to "stay on top" (references self, not GLSceneEditorForm ) <li>17/03/08 - mrqzzz - By dAlex: Added "stay on top" button <li>12/07/07 - DaStr - Improved cross-platform compatibility (BugTrackerID=1684432) <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>25/03/07 - DaStr - Abstracted IsSubComponent for Delphi5 compatibility <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTrackerID=1681585) <li>07/02/07 - DaStr - TGLSceneEditorForm.ACDeleteObjectExecute bugfixed TGLSceneEditorForm.AddNodes - removed warning (all for proper Subcomponent support) <li>20/01/07 - DaStr - TGLSceneEditorForm.ACCutExecute bugfixed <li>19/12/06 - DaStr - TGLSceneEditorForm.AddNodes bugfixed - SubComponents are no longer displayed in the Editor (BugTraker ID = 1585913) <li>24/06/06 - PvD - Fixed bug with DELETE key when editing name in Treeview <li>03/07/04 - LR - Updated for Linux <li>18/12/04 - PhP - Added support for deleting objects/effects/behaviours by pressing "Delete" <li>03/07/04 - LR - Make change for Linux <li>14/12/03 - EG - Paste fix (Mrqzzz) <li>31/06/03 - EG - Cosmetic changes, form position/state now saved to the registry <li>21/06/03 - DanB - Added behaviours/effects listviews <li>22/01/02 - EG - Fixed controls state after drag/drop (Anton Zhuchkov) <li>06/08/00 - EG - Added basic Clipboard support <li>14/05/00 - EG - Added workaround for VCL DesignInfo bug (thx Nelson Chu) <li>28/04/00 - EG - Fixed new objects not being immediately reco by IDE <li>26/04/00 - EG - Added support for objects categories <li>17/04/00 - EG - Added access to TInfoForm <li>16/04/00 - EG - Fixed occasionnal crash when rebuilding GLScene dpk while GLSceneEdit is visible <li>10/04/00 - EG - Minor Create/Release change <li>24/03/00 - EG - Fixed SetScene not updating enablings <li>13/03/00 - EG - Object names (ie. node text) is now properly adjusted when a GLScene object is renamed, Added Load/Save whole scene <li>07/02/00 - EG - Fixed notification logic <li>06/02/00 - EG - DragDrop now starts after moving the mouse a little, Form is now auto-creating, fixed Notification, Added actionlist and moveUp/moveDown <li>05/02/00 - EG - Fixed DragDrop, added root nodes auto-expansion </ul></font>

GLSceneEditLCL GLSceneEdit<p>

Scene Editor, for adding + removing scene objects within the Delphi IDE.<p>

<b>History : </b><font size=-1><ul> <li>20/05/10 - Yar - Fixes for Linux x64 <li>18/05/10 - Yar - Fixed for Lazarus-0.9.29-25483 (thanks Predator) <li>26/03/10 - Yar - Added Expand and Collapse buttons, fix for Unix-based systems (thanks to Rustam Asmandiarov aka Predator) <li>14/03/09 - DanB - Removed Cameras node, instead cameras are now placed into scene <li>19/03/08 - mrqzzz - Little change to "stay on top" (references self, not GLSceneEditorForm ) <li>17/03/08 - mrqzzz - By dAlex: Added "stay on top" button <li>12/07/07 - DaStr - Improved cross-platform compatibility (BugTrackerID=1684432) <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>25/03/07 - DaStr - Abstracted IsSubComponent for Delphi5 compatibility <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTrackerID=1681585) <li>07/02/07 - DaStr - TGLSceneEditorForm.ACDeleteObjectExecute bugfixed TGLSceneEditorForm.AddNodes - removed warning (all for proper Subcomponent support) <li>20/01/07 - DaStr - TGLSceneEditorForm.ACCutExecute bugfixed <li>19/12/06 - DaStr - TGLSceneEditorForm.AddNodes bugfixed - SubComponents are no longer displayed in the Editor (BugTraker ID = 1585913) <li>24/06/06 - PvD - Fixed bug with DELETE key when editing name in Treeview <li>03/07/04 - LR - Updated for Linux <li>18/12/04 - PhP - Added support for deleting objects/effects/behaviours by pressing "Delete" <li>03/07/04 - LR - Make change for Linux <li>14/12/03 - EG - Paste fix (Mrqzzz) <li>31/06/03 - EG - Cosmetic changes, form position/state now saved to the registry <li>21/06/03 - DanB - Added behaviours/effects listviews <li>22/01/02 - EG - Fixed controls state after drag/drop (Anton Zhuchkov) <li>06/08/00 - EG - Added basic Clipboard support <li>14/05/00 - EG - Added workaround for VCL DesignInfo bug (thx Nelson Chu) <li>28/04/00 - EG - Fixed new objects not being immediately reco by IDE <li>26/04/00 - EG - Added support for objects categories <li>17/04/00 - EG - Added access to TInfoForm <li>16/04/00 - EG - Fixed occasionnal crash when rebuilding GLScene dpk while GLSceneEdit is visible <li>10/04/00 - EG - Minor Create/Release change <li>24/03/00 - EG - Fixed SetScene not updating enablings <li>13/03/00 - EG - Object names (ie. node text) is now properly adjusted when a GLScene object is renamed, Added Load/Save whole scene <li>07/02/00 - EG - Fixed notification logic <li>06/02/00 - EG - DragDrop now starts after moving the mouse a little, Form is now auto-creating, fixed Notification, Added actionlist and moveUp/moveDown <li>05/02/00 - EG - Fixed DragDrop, added root nodes auto-expansion </ul></font>

GLSceneForm
GLSceneFormDesign GLSceneFormDesign<p>

<b>History : </b><font size=-1><ul> <li>03/04/11 - Yar - Added three project wizard for Delphi <li>05/12/10 - PREDATOR - Added three form wizard and three project wizard for Lazarus <li>23/08/10 - Yar - Creation </ul></font>

GLSceneRegister GLSceneRegister<p>

Registration unit for GLScene library components, property editors and IDE experts.<p>

<b>History : </b><font size=-1><ul> <li>15/06/11 - Yar - Improved GetGLSceneVersion (by lolo) <li>04/06/10 - Yar - Added GLSArchiveManager <li>20/04/10 - Yar - Added GLSLanguage <li>08/04/10 - Yar - Added code belonged section GLS_EXPERIMENTAL <li>22/01/10 - Yar - Added GLCompositeImage, GLFileDDS, GLFileO3TC, GLFileHDR to uses <li>07/05/09 - DanB - Added TGLSoundLibrarySelectionEditor, TGLBaseSceneObjectSelectionEditor <li>14/03/09 - DanB - Split TObjectManager to GLObjectManager.pas. Moved property editors to interface section, and made their methods public. <li>08/10/08 - DanB - Added DynamicTexture unit (to allow choosing this at designtime) + register TGLSLPostBlurShader <li>05/10/08 - DanB - Change required due Texture/TextureImageEditor separation + GLMisc split, tidied up some old ifdefs <li>24/03/08 - DaStr - Moved TGLMinFilter and TGLMagFilter from GLUtils.pas to GLGraphics.pas (BugTracker ID = 1923844) <li>21/03/08 - DaStr - Renamed TMMat to TGLTextureSharingShaderMaterial <li>17/03/08 - mrqzzz - Registered TGLTextureSharingShader <li>20/01/08 - DaStr - Registered TGLCapsule (thanks Dave Gravel) Registered TGLGizmo <li>06/11/07 - mrqzzz - Registered material picker for TGLActorProxy <li>18/09/07 - DaStr - Added TGLMaterialProxy, TGLAbsoluteHUDText, TGLResolutionIndependantHUDText <li>12/07/07 - DaStr - Improved Cross-Platform compatibility (Bugtracker ID = 1684432) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>23/03/07 - fig - Added TGLSLProjectedTextures <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTrackerID=1681585) <li>14/03/07 - DaStr - SpriteAnimation now makes use of TGLLibMaterialName's property editor <li>04/03/07 - DaStr - Added TGLPostShaderHolder <li>28/02/07 - LIN - Added GLShadowHDS <li>25/02/07 - DaStr - Added TGLPostEffect Moved all terrain components to a separate tab Moved all shader components registration here <li>23/02/07 - DaStr - Added TGLSLShader, TGLSLDiffuseSpecularShader, TGLSLBumpShader, TGLAsmShader, TGLShaderCombiner TGLSmoothNavigator, TGLSmoothUserInterface Moved TGLLibMaterialNameProperty to the interface section <li>21/02/07 - DaStr - Added TGLActorProxy and TGLMotionBlur <li>16/02/07 - DaStr - Added GLMaterialMultiProxy <li>15/02/07 - DaStr - Added GLConsole and GLAtmosphere <li>13/02/07 - LIN - Added GLAsyncHDS and GLTexturedHDS <li>06/02/07 - DaStr - Added GLSimpleNavigation <li>29/01/07 - DaStr - Added GLEParticleMasksManager, moved registration procedures from other units to this one <li>21/01/07 - DaStr - TGLLibMaterialNameProperty.Edit fixed (to support IGLMaterialLibrarySupported) <li>23/12/04 - PhP - "Animated Sprite" moved to advanced objects category <li>13/10/04 - MRQZZZ - Added GLTrail <li>03/07/04 - LR - Completly review to take account designtime for Linux Note a problem with TGLColorProperty <li>28/06/04 - LR - Changed LoadBitmap to GLLoadBitmapFromInstance <li>12/04/04 - EG - LibMaterialName property editor for SkyBox <li>22/08/02 - EG - RegisterPropertiesInCategory (Robin Gerrets) <li>08/04/02 - EG - Added verb to TGLSceneEditor <li>26/01/02 - EG - Color property drawing in D6 too now <li>22/08/01 - EG - D6 related changes <li>08/07/01 - EG - Register for TGLExtrusionSolid (Uwe Raabe) <li>18/02/01 - EG - Added Terrain/HeightData objects <li>21/01/01 - EG - Enhanced GetAttributes for some property editors <li>09/10/00 - EG - Added registration for TGLMultiPolygon <li>09/06/00 - EG - Added TSoundFileProperty & TSoundNameProperty <li>23/05/00 - EG - Added GLCollision <li>16/05/00 - EG - Delphi 4 Compatibility <li>28/04/00 - EG - Removed ObjectStock in TObjectManager (was useless) <li>26/04/00 - EG - Added Categories in ObjectManager, enhanced GetRegisteredSceneObjects <li>16/04/00 - EG - Objects icons are now loaded from ressources using ClassName (more VCL-like) <li>11/04/00 - EG - Components now install under 'GLScene', Fixed DestroySceneObjectList (thanks Uwe Raabe) <li>06/04/00 - EG - Added TGLBehavioursProperty <li>18/03/00 - EG - Added TGLImageClassProperty <li>13/03/00 - EG - Updated TGLTextureImageProperty <li>14/02/00 - EG - Added MaterialLibrary editor and picker <li>09/02/00 - EG - ObjectManager moved in, ObjectManager is now fully object-oriented and encapsulated <li>06/02/00 - EG - Fixed TGLScenedEditor logic (was causing Delphi IDE crashes on package unload) <li>05/02/00 - EG - Added TGLColorProperty and TGLCoordinatesProperty </ul></font>

GLSceneRegisterLCL GLSceneRegisterLCL<p>

Registration unit for GLScene library components, property editors and IDE experts for Lazarus.<p>

<b>History :</b><font size=-1><ul> <li>04/06/10 - Yar - Added GLSArchiveManager Fixes for Linux x64 <li>20/04/10 - Yar - Added GLSLanguage <li>08/04/10 - Yar - Added code belonged section GLS_EXPERIMENTAL <li>22/01/10 - Yar - Added GLCompositeImage, GLFileDDS, GLFileO3TC, GLFileHDR to uses <li>07/01/10 - DaStr - Added GLLCLFullScreenViewer and improved TResolutionProperty (thanks Predator) <li>24/11/09 - DanB - Removed some more windows only units <li>22/11/09 - DaStr - Improved Unix compatibility (again) <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>24/03/08 - DaStr - Initial version </ul></font>

GLSceneRegisterWinOnlyLCL GLSceneRegisterWinOnlyLCL<p>

Contains registration for Design-Time Lazarus Windows-Only units.<p> Because of Lazarus'es limitations, these need to be separated from the main GLSceneRegisterLCL.pas

<b>History :</b><font size=-1><ul> <li>07/01/10 - DaStr - Removed GLLCLFullScreenViewer because it became cross-platform (thanks Predator) <li>24/11/09 - DanB - Added some more windows only units <li>22/11/09 - DaStr - Initial version (by Predator) </ul></font>

GLSceneToolbar
GLSComputingRegister GLSComputingRegister<p>

Registration unit for GLScene Computing package.<p>

<b>History : </b><font size=-1><ul> <li>05/03/11 - Yar - Added TCUDAConstant, TCUDAFuncParam <li>22/08/10 - Yar - Some improvements for FPC (thanks Predator) <li>09/06/10 - Yar - Added dropdown list ProjectModule for TGLSCUDACompiler <li>19/03/10 - Yar - Creation </ul></font>

GLScreen GLScreen<p>

Routines to interact with the screen/desktop.<p>

<b>Historique : </b><font size=-1><ul> <li>04/11/10 - DaStr - Added Delphi5 and Delphi6 compatibility <li>06/06/10 - Yar - Fixed warnings <li>13/04/10 - Yar - Fixed conditional for delphi (thanks mif) <li>07/01/10 - DaStr - Enhanced cross-platform compatibility (thanks Predator) <li>17/12/09 - DaStr - Added screen utility functions from GLCrossPlatform.pas (thanks Predator) <li>07/11/09 - DaStr - Improved FPC compatibility and moved to the /Source/Platform/ directory (BugtrackerID = 2893580) (thanks Predator) <li>23/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>03/07/04 - LR - Suppress CurrentScreenColorDepth because there are in GLCrossPlatform <li>24/07/03 - EG - Video modes now read on request only, removed the non-standard low-res video modes <li>27/09/02 - EG - Added Ability to set display frequency <li>27/07/01 - EG - Removed the "absolute" in RestoreDefaultMode <li>08/02/00 - EG - TLowResMode & TVideoMode packed (wins 5 kb) <li>06/02/00 - EG - Javadocisation, added "default"s to properties </ul></font>

GLScriptBase An abstract scripting interface for GLScene<p>

This unit provides the base methods for compiling and executing scripts as well as calling scripted functions. No scripting APIs are implemented here, only abstracted functions.<p>

<b>History : </b><font size=-1><ul> <li>04/11/2004 - SG - Creation </ul></font>

GLScriptDWS2 DelphiWebScriptII implementation for the GLScene scripting layer.<p>

<b>History : </b><font size=-1><ul> <li>04/11/2004 - SG - Creation </ul></font>

GLScriptPython Python implementation for the GLScene scripting layer.<p>

This unit is experimental.<p>

<b>History : </b><font size=-1><ul> <li>11/11/2004 - SG - Creation </ul></font>

GLSCrossXML GLSCrossXML<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Creation </ul></font>

GLSCUDA
GLSCUDACompiler
GLSCUDAContext
GLSCUDAEditor GLSCUDAEditor<p>

Editor of TGLSCUDA.<p>

<b>History : </b><font size=-1><ul> <li>22/08/10 - Yar - Some improvements for FPC (thanks Predator) <li>19/03/10 - Yar - Creation </ul></font>

GLSCUDAFFTPlan
GLSCUDAGraphics GLSCUDAGraphics<p>

<b>History : </b><font size=-1><ul> <li>05/03/11 - Yar - Moved and remake TGLFeedBackMesh from experimental to GLSCUDAGraphics, removed TGLFactory mediator component Added to TGLFeedBackMesh vertex attribute collection <li>01/04/10 - Yar - Creation </ul></font><p>

GLSCUDAParser GLSCUDAParser <p>

Helper unit for parsing CU modules and get information about.<p> kernel's functions, textures, shared and constants memory.<p>

<b>History : </b><font size=-1><ul> <li>13/04/11 - Yar - Added Ptx parsing to get real function's KernelName <li>17/02/11 - Yar - Now parse module instead of compiler product <li>19/03/10 - Yar - Creation </ul></font><p>

GLSDL SDL<p>

<b>History : </b><font size=-1><ul> <li>22/01/13 - PW - Supplied with CPPB compatibility by suppressing $EXTERNALSYM ... directives <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>07/06/07 - DaStr - Added $I GLScene.inc <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTracekrID=1681585) </ul></font>

GLSDLContext GLSDLContext<p>

SDL specific Context and Viewer.<p>

NOTA: SDL notifies use of context destruction *after* it happened, this prevents clean release of allocated stuff and requires a temporary switch to "ignore OpenGL errors" mode during destruction, thus potentially leaking memory (depending on hardware drivers willingness to perform automatic releases)<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>06/06/10 - Yar - Make outputDevice HWND type <li>15/02/07 - DaStr - Integer -> Cardinal because $R- was removed in GLScene.pas <li>11/09/06 - NC - Changes for Multiple-Render-Target <li>12/12/01 - EG - Creation </ul></font>

GLSDLWindow
GLSelection
GLShaderCombiner GLShaderCombiner<p>

Allows to combine shaders in different sequences. Note, that can't just take 2 random shaders and combine them, because shaders often override the objects material and vertex data with a total disregard to what existed before it. But in some cases, especially with multipass shaders, this unit does magic and allows to reuse and upgrade previously written shaders.<p>

<b>History : </b><font size=-1><ul> <li>23/02/07 - DaStr - Initial version (contributed to GLScene)

Previous version history: v1.0 02 November '2006 Creation

GLShadowHDS Implements an HDS that automatically generates a terrain lightmap texture.<p> <b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/01/10 - Yar - Added GLTextureFormat to uses <li>13/11/07 - LIN - Added SkipGenerate flag. Set to true in "OnSourceDataFetched" to generate a blank shadow map. Then load your cached Shadowmap during OnThreadBmp32 event. <li>17/07/07 - LIN - Added OnThreadBmp32 event. This event can be used to modify the lightmap, before it is sent to texture memory. When used with TAsyncHDS, this event runs in the HeightData thread, and NOT in the main thread, so make sure code in this event is thread-safe. <li>22/03/07 - LIN - Thread-safe. (Now works with TGLAsyncHDS) <li>02/03/07 - LIN - Now works with InfiniteWrap terrain <li>14/02/07 - LIN - Creation </ul></font>

Issues:1:Ambient and Diffuse light properties can not be set to 0, to avoid what seems to be a Delphi bug: If a property of type 'Single' is set to 0, Delphi seems to skip the property's set method at startup, and just uses the default value instead. (Does anyone know a better workaround?) 2:Subsampling is not currently supported. 3:If the light vector's y component is not 0 then the shadow edges may be a bit jagged, due to the crude Bresenham line algorythm that was used. You can hide this by increasing SoftRange though. 5:At some light angles, rounding errors cause various artifacts: (Black tile edges / slight mis-alignments /etc.) 6:Applying materials ocasionally causes AV's

PS. The RayCastShadowHeight function returns the height of the shadow at a point on the terrain. This, and the LightVector may come in handy for implementing shadow volumes?

GLShadowPlane GLShadowPlane<p>

Implements a basic shadow plane.<p>

It is strongly recommended to read and understand the explanations in the materials/mirror demo before using this component.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/06/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>22/02/10 - Yar - Optimization of switching states <li>12/03/09 - DanB - Bug-fix for scissor test on recent NVidia drivers <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>02/08/04 - LR, YHC - BCB corrections: use record instead array <li>23/03/04 - EG - Added spoTransparent <li>29/11/03 - EG - Scissors turned of if camera is withing bounding volume <li>30/10/02 - EG - Added OnBegin/EndRenderingShadows <li>25/10/02 - EG - Fixed Stencil cleanup and shadow projection bug <li>02/10/02 - EG - Added spoScissor <li>23/09/02 - EG - Creation (from GLMirror and Mattias FagerLund ShadowPlane.pas) </ul></font>

GLShadowVolume GLShadowVolumes<p>

Implements basic shadow volumes support.<p>

Be aware that only objects that support silhouette determination have a chance to cast correct shadows. Transparent/blended/shader objects among the receivers or the casters will be rendered incorrectly.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>31/05/10 - Yar - Fixes forLinux x64 <li>01/05/10 - Yar - Moved ignoreBlendingRequests and ignoreDepthRequests behind RenderChildren <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>31/03/07 - DaStr - Fixed issue with invalid typecasting (thanks Burkhard Carstens) (Bugtracker ID = 1692016) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>08/12/04 - DB - Fixed bug in TGLShadowVolumeCaster.SetCaster <li>02/12/04 - MF - Added some documentation <li>23/03/04 - EG - Added Active property <li>29/11/03 - MF - Removed a "feature" that would draw the shadow of (hierarchially) invisible objects <li>27/11/03 - MF - TGLShadowVolumeCaster now registers with the FCaster for delete notification <li>11/06/03 - EG - Added silhouette cache <li>04/06/03 - EG - Creation (based on code from Mattias Fagerlund) </ul></font>

GLSilhouette GLSilhouette<p>

Enhanced silhouette classes.<p>

Introduces more evolved/specific silhouette generation and management classes.<p>

CAUTION : both connectivity classes leak memory.<p>

<b>History : </b><font size=-1><ul> <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>16/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>26/09/03 - EG - Improved performance of TConnectivity data construction <li>19/06/03 - MF - Split up Connectivity classes <li>10/06/03 - EG - Creation (based on code from Mattias Fagerlund) </ul></font>

GLSimpleNavigation GLSimpleNavigation<p>

A simple component written by request from someone at the www.glscene.ru forums.<p> Allows to view the FPS and do the usual Zoom and MoveAroundTarget stuff <p> that all demos usually have in themselves. All that is just by dropping <p> this component on the form.<p>

<b>History : </b><font size=-1><ul> <li>14/12/10 - DaStr - Fixed compiler hint <li>12/12/10 - Yar - Adapted to using with TGLSceneForm <li>01/07/10 - Yar - Fixed zooming for FPC (by Rustam Asmandiarov aka Predator) <li>17/06/10 - YP - Fixed Zoom in/out inconsistence (mousewheel up/down inverted) <li>11/06/10 - YP - Fixed wheeldata can be equal to 0 in FormMouseWheel (div by 0 exception) <li>21/01/10 - Yar - Bugfixed zooming in design time (BugtrackerID = 2936266) <li>25/12/09 - DaStr - Added OnMouseMove event (thanks YarUnderoaker) <li>18/10/09 - DaStr - Added snoShowFPS option (thanks YarUnderoaker) Fixed a small bug with FPS string <li>29/09/07 - DaStr - Component now automaticly detects Form Caption <li>24/03/07 - DaStr - Replaced GLWin32Viewer with GLViewer (thanks Burkhard Carstens) (Bugtracker ID = 1684432) Got rid of Types dependancy <li>20/03/07 - DaStr - Improved SceneViewer detection <li>02/03/07 - DaStr - Added default values to all properties Added TGLSimpleNavigationOptions Added TGLSimpleNavigationKeyCombination Some renamings Added TGLSimpleNavigation.Assign MouseWheel is now handled by default <li>06/02/07 - DaStr - Creation (donated to GLScene) </ul></font><p>

Previous version history: v1.0 08 May '2006 Creation v1.1 04 September '2006 FreeNotification fix Automatic Form detection fix v1.2 11 September '2006 Automatic SceneViewer detection FormCaption added v1.3 06 February '2007 FPS is only updated in Run-Time now Donated to GLScene

GLSJPG JPG<p>

<b>Historique : </b><font size=-1><ul> <li>27/02/10 - Yar - Added to GLScene from Mike Lischke GraphicEx package </ul></font>

GLSkyBox GLSkyBox<p>

A TGLImmaterialSceneObject drawing 6 quads (plus another quad as "Cloud" plane) for use as a skybox always centered on the camera.<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>26/03/09 - DanB - Skybox is now a TGLCameraInvariantObject <li>10/10/08 - DanB - changed Skybox DoRender to use rci instead of Scene.CurrentGLCamera <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>21/01/07 - DaStr - Added IGLMaterialLibrarySupported support <li>12/04/04 - EG - Added Style property, multipass support <li>27/11/03 - EG - Cleanup and fixes <li>09/11/03 - MRQZZZ - mandatory changes suggested by Eric. <li>02/09/03 - MRQZZZ - Creation </ul></font>

GLSkydome GLSkydome<p>

Skydome object<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>24/03/11 - Yar - Added esoDepthTest to TEarthSkydomeOption (Drawing sky dome latest with depth test reduce pixels overdraw) <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>10/10/08 - DanB - changed Skydome buildlists to use rci instead of Scene.CurrentGLCamera <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Moved all UNSAFE_TYPE, UNSAFE_CODE checks to GLSCene.inc <li>25/03/07 - DaStr - Fixed compiler directives for Delphi5 compatibility <li>22/03/07 - DaStr - Removed "unsafe type/unsafe code" warnings <li>19/12/06 - DaStr - TSkyDomeStars.AddRandomStars() overloaded <li>29/06/06 - PvD - Fixed small bug to properly deal with polygon fill <li>20/01/05 - Mathx - Added the ExtendedOptions of the EarthSkyDome <li>02/08/04 - LR, YHC - BCB corrections: use record instead array <li>09/01/04 - EG - Now based on TGLCameraInvariantObject <li>04/08/03 - SG - Fixed small bug with random star creation <li>17/06/03 - EG - Fixed PolygonMode (Carlos Ferreira) <li>26/02/02 - EG - Enhanced star support (generation and twinkle), Skydome now 'exports' its coordinate system to children <li>21/01/02 - EG - Skydome position now properly ignored <li>23/09/01 - EG - Fixed and improved TGLEarthSkyDome <li>26/08/01 - EG - Added SkyDomeStars <li>12/08/01 - EG - DepthMask no set to False during rendering <li>18/07/01 - EG - VisibilityCulling compatibility changes <li>12/03/01 - EG - Reversed polar caps orientation <li>28/01/01 - EG - Fixed TSkyDomeBand rendering (vertex coordinates) <li>18/01/01 - EG - First working version of TGLEarthSkyDome <li>14/01/01 - EG - Creation </ul></font>

GLSLanguage Eng Language created to localize your application. In Delphi, the text is encoded using Ansi cp1251 and can not be encoded \ decoding. In Lazarus has the ability to upload text from any encoding. Ru TLanguage ñîçäàí äëÿ ëîêàëèçàöèè âàøåãî ïðèëîæåíèÿ. Â Äåëôè òåêñò èìååò êîäèðîâêó Ansi cp1251 è íå ïîäëåæûò êîäèðîâêå\äåêîäèðîâêå. Â Ëàçàðóñå èìååòñÿ âîçìîæíîñòü çàãðóæàòü òåêñò èç ëþáîé êîäèðîâêè.

<b>History : </b><font size=-1><ul> <li>04/11/10 - DaStr - Added Delphi5 and Delphi6 compatibility <li>20/04/10 - Yar - Added to GLScene (Created by Rustam Asmandiarov aka Predator) </ul></font>

GLSLBumpShader GLSLBumpShader<p>

A GLSL shader that applies bump mapping.<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>20/10/10 - Yar - Bugfixed memory leak <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>07/01/10 - DaStr - Bugfixed all DoInitialize() calls (thanks YarUnderoaker) <li>24/07/09 - DaStr - TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) Fixed a bug with "fRDotV" clamping, which occured on all GeForce 8x and later graphic cards <li>20/03/07 - DaStr - Made changes related to the new parameter passing model <li>06/03/07 - DaStr - Again replaced DecimalSeparator stuff with a single Str procedure (thanks Uwe Raabe) <li>03/03/07 - DaStr - Made compatible with Delphi6 <li>22/02/07 - DaStr - Initial version (contributed to GLScene)

This is a collection of GLSL Bump shaders, comes in these variaties (to know what these abriviations mean, see GLCustomShader.pas):

- TGLSLBumpShader - TGLSLBumpShaderMT - TGLSLBumpShaderAM

- TGLSLMLBumpShader - TGLSLMLBumpShaderMT

Notes: 1) Alpha is a synthetic property, in real life your should set each color's Alpha individualy 2) TGLSLMLBumpShader takes all Light parameters directly from OpenGL (that includes TGLLightSource's)

TODO: 1) Implement IGLShaderDescription in all shaders.

Previous version history: v1.0 03 September '2006 Creation v1.1 09 September '2006 Camera Positioning bugfix Artefacts on the non-lit side removed v1.2 16 September '2006 Shader made ATI-compatible v1.2.2 02 November '2006 Small optimization if Do(Un)Apply v1.3 27 November '2006 TGLCustomGLSLMLBumpShaderMT added v1.3.2 30 November '2006 LightCompensation added gl_FragColor() calculation optimized a bit v1.4 16 December '2006 All Shaders renamed according to the new naming convention SCS_SHADER_NEEDS_AT_LEAST_ONE_LIGHT_SOURCE moved to GLCustomShader TGLBaseCustomGLSLBumpShader, TGLBaseMatlibGLSLBumpShader(MT) abstracted 7 diferent versions of this shader added All shaders made design-time compatible v1.4.2 18 December '2006 MultiLight versions of this shader bugfixed (the specular light was sometimes "cut") The use of SpecularMap made optional v1.4.6 20 December '2006 TGLBaseMatlibGLSLBumpShader and TGLBaseCustomGLSLBumpShader merged The use of NormalMap is optional MultiLight shaders optimized a bit v1.4.8 06 February '2007 IGLMaterialLibrarySupported renamed to IGLMaterialLibrarySupported v1.5 16 February '2007 Updated to the latest CVS version of GLscene v1.5.2 18 February '2007 Removed the StrangeTextureUtilities dependancy

GLSLDiffuseSpecularShader GLSLDiffuseSpecularShader<p>

This is a collection of GLSL diffuse-specular shaders.<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/10/10 - Yar - Bugfixed memory leak <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>07/01/10 - DaStr - Bugfixed all DoInitialize() calls (thanks YarUnderoaker) <li>25/07/09 - DaStr - Fixed a bug with "dot(reflect_vec, LightVector)" clamping which occured on all GeForce 8x and later graphic cards <li>24/07/09 - DaStr - Added Fog support for single-light shaders and fixed a bug with material Alpha (thanks Controller) <li>02/09/07 - LC - Fixed texture bug in TGLSLMLDiffuseSpecularShader. (Bugtracker ID = 1786286) <li>03/04/07 - LC - Shader didn't respect the texture matrix. Changed vertex shader to fix this. (Bugtracker ID = 1693389) <li>20/03/07 - DaStr - Made changes related to the new parameter passing model <li>06/03/07 - DaStr - Again replaced DecimalSeparator stuff with a single Str procedure (thanks Uwe Raabe) <li>03/03/07 - DaStr - Made compatible with Delphi6 Added more stuff to RegisterClasses() <li>21/02/07 - DaStr - Initial version (contributed to GLScene)

This is a collection of GLSL Diffuse Specular shaders, comes in these variaties (to know what these suffixes and prefixes mean see GLCustomShader.pas): - TGLSLDiffuseSpecularShader - TGLSLDiffuseSpecularShaderMT - TGLSLDiffuseSpecularShaderAM

- TGLSLMLDiffuseSpecularShader - TGLSLMLDiffuseSpecularShaderMT

Notes: 1) Alpha is a synthetic property, in real life your should set each color's Alpha individualy 2) TGLSLDiffuseSpecularShader takes all Light parameters directly from OpenGL (that includes TGLLightSource's)

Previous version history: v1.0 01 November '2006 Creation v1.1 19 December '2006 TGLBaseCustomGLSLDiffuseSpecular[MT] abstracted 5 different versions of this shader added v1.1.2 06 February '2007 IGLMaterialLibrarySupported renamed to IGLMaterialLibrarySupported v1.2 16 February '2007 Updated to the latest CVS version of GLScene

GLSLog
GLSLParameter GLSLParameter<p>

<b>History : </b><font size=-1><ul> <li>14/03/11 - Yar - Creation </ul>

GLSLPostBlurShader GLSLPostBlurShader <p>

A shader that blurs the entire scene.<p>

<b>History : </b><font size=-1><ul> <li>22/04/10 - Yar - Fixes after GLState revision < Added VectorTypes to uses <li>16/04/07 - DaStr - Shader made ATI compatible <li>05/04/07 - DaStr - Initial version (contributed to GLScene)

Previous version history: v1.0 04 November '2006 Creation (based on RenderMonkey demo) v1.1 04 March '2007 IGLPostShader support added v1.2 30 March '2007 TGLCustomGLSLPostBlurShaderSceneObject removed Shader now supports GL_TEXTURE_RECTANGLE_ARB

GLSLProjectedTextures
GLSLShader GLSLShader<p>

TGLSLShader is a wrapper for GLS shaders.<p>

<b>History : </b><font size=-1><ul> <li>09/02/13 - Yar - Added OnApplyEx event where is TGLLibMaterial as Sender (thanks to Dmitriy Buharin) <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>18/02/11 - Yar - Fixed transform feedback varyings activation <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>02/06/10 - Yar - Replace OpenGL functions to OpenGLAdapter Added unsigned integer uniforms <li>22/04/10 - Yar - Fixes after GLState revision <li>02/04/10 - Yar - Added GetActiveAttribs to TGLCustomGLSLShader <li>04/11/09 - DaStr - Added default value to TGLCustomGLSLShader.TransformFeedBackMode <li>26/10/09 - DaStr - Updated GeometryShader support (thanks YarUnderoaker) <li>24/08/09 - DaStr - Added GeometryShader support (thanks YarUnderoaker) <li>24/07/09 - DaStr - Added support for TGLCustomShader.DebugMode Fixed spelling mistake in TGLShaderUnAplyEvent TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) Bugfixed TGLCustomGLSLShader.DoInitialize() - now shader cleanes up correctly if failed to initialize <li>15/03/08 - DaStr - Fixups for vIgnoreContextActivationFailures mode (BugTracker ID = 1914782) <li>25/12/07 - DaStr - Fix-up for previous update (BugtrackerID = 1772477) <li>12/08/07 - LC - TGLSLShaderParameter.SetAsCustomTexture now restores the active texture unit (BugtrackerID = 1772477) <li>12/07/07 - DaStr - TGLSLInitializedShaderParameters removed because even if implemented, it could not give a significant performance increase <li>30/03/07 - fig - Changed OnInitialize event to be fired after linking, but before validation. This can now be used to set texture units for different sampler types (1D/2D/3D) before validation, which fixes a bug (or complies to strict validation) with ATI drivers <li>30/03/07 - DaStr - Bugfixed TGLCustomGLSLShader.DoUnApply (Result was not initialized) <li>20/03/07 - DaStr - TGLCustomGLSLShader now generates its own events Added TGLSLShaderParameter Added TGLCustomGLSLShader.DoInitialPass Added TGLCustomGLSLShader.Param[] <li>21/02/07 - DaStr - Initial version (contributed to GLScene)

Previous version history: v1.0 11 March '2006 Creation v1.1 06 August '2006 TGLCustomGLSLShader.DoInitialize bugfixed v1.1.2 24 August '2006 TGLCustomShader.SetParameterTexture[1-3]D added v1.1.4 09 September '2006 Fixed a memory leak which occured when enabling / disabling the shader several times v1.1.6 22 September '2006 DoUnApply fixed (suggested by Nelsol Chu) v1.2 04 November '2006 function GetGLSLProg added (just in case) TGLSLShader has more published properties Bugfix in DoInitialize (when no shader is active) (Get/Set)ParameterTexture[1/2/3]DHandle added (Get/Set)ParameterCustomTextureHandle support added v1.2.4 22 November '2006 TGLProgramHandle.Name is now used Assign() bugfixed Fixed a possible bug in DoInitialize (Handle was freed, but not nil'ed)

GLSMBASS GLSMBASS<p>

BASS based sound-manager (http://www.un4seen.com/music/, free for freeware).<p>

Unsupported feature(s) :<ul> <li>sound source velocity <li>looping (sounds are played either once or forever) <li>source priorities (not relevant, channels are not limited) </ul><p>

<b>History : </b><font size=-1><ul> <li>07/01/10 - DaStr - Fixed a bug with an initial Paused or Muted state of sound source and with sscSample in aSource.Changes <li>07/11/09 - DaStr - Improved FPC compatibility (thanks Predator) (BugtrackerID = 2893580) <li>21/03/08 - DanB - Updated to BASS Version 2.3 <li>15/03/08 - DaStr - Added $I GLScene.inc <li>09/05/04 - GAK - Updated to BASS Version 2.0, and swapped to Dynamic DLL loading <li>24/09/02 - EG - BASS activation errors no longer result in Asserts (ignored) <li>27/02/02 - EG - Added 3D Factors and Environment support <li>05/02/02 - EG - BASS 1.4 compatibility <li>05/02/01 - EG - Fixed TGLSMBASS.CPUUsagePercent <li>13/01/01 - EG - Creation (compat BASS 0.8) </ul></font>

GLSMemo GLSMemo<p>

<b>History : </b><font size=-1><ul> <li>30/03/11 - Yar - Initial version (based on kpMemo by Konstantin Polyakov http://kpolyakov.narod.ru/) </ul></font>

GLSMFMOD GLSMFMOD<p>

FMOD based sound-manager (http://www.fmod.org/, free for freeware).<p>

Unsupported feature(s) :<ul> <li>sound source velocity <li>looping (sounds are played either once or forever) <li>sound cones </ul><p>

<b>History : </b><font size=-1><ul> <li>07/01/10 - DaStr - Fixed a bug with an initial Paused or Muted state of sound source and with sscSample in aSource.Changes <li>17/03/08 - mrqzzz - Fixed "Consant cannot be pased as var parameter" in NotifyEnvironmentChanged <li>15/03/08 - DaStr - Updated to Fmod v3.7.4 (thanks Chen, Pei) <li>07/06/07 - DaStr - Added $I GLScene.inc <li>18/10/03 - EG - Dynamic support is back <li>18/09/03 - ARH - updated for fmod 3.7 <li>24/09/02 - EG - FMOD activation errors no longer result in Asserts (ignored) <li>28/08/02 - EG - Fixed EAX capability detection <li>27/08/02 - EG - Now uses dynamically linked version by Steve Williams, Added support for EAX environments <li>26/08/02 - EG - Updated to FMOD 3.6 <li>27/02/02 - EG - Updated to FMOD 3.5, added 3D Factors <li>05/02/02 - EG - Updated to FMOD 3.4, now uses DSound by default <li>13/01/01 - EG - Updated for API 3.3 compatibility <li>09/06/00 - EG - Creation </ul></font>

GLSModuleLoader
GLSmoothNavigator GLSmoothNavigator<p>

An extention of TGLNavigator, which allows to move objects with inertia Note: it is not completely FPS-independant. Only Moving code is, but MoveAroundTarget, Turn[Vertical/Horizontal] and AdjustDistanceTo[..] is not.

Don't know why, but when I make their code identical, these function stop working completely. So you probably have to call the AutoScaleParameters procedure once in a while for it to adjust to the current framerate. If someone knows a better way to solve this issue, please contact me via glscene newsgroups.<p>

<b>History : </b><font size=-1><ul> <li>30/06/11 - DaStr - Converted many procedures to functions Bugfixed Assign() in some places Added "Cutoff" property instead of fixed EPS values <li>02/06/11 - DaStr - DeltaTime is now Double, like in Cadencer Added CustomAnimatedItems <li>28/05/11 - DaStr - Added the AdjustDistanceTo[..]Ex procedures <li>25/02/07 - DaStr - Added the AdjustDistanceTo[..] procedures <li>23/02/07 - DaStr - Initial version (contributed to GLScene)

TODO: 1) Scale "Old values" too, when callin the Scale parameter procedure to avoid the temporary "freeze" of controls. 2) AddImpulse procedures.

Previous version history: v1.0 10 December '2005 Creation v1.0.2 11 December '2005 TurnMaxAngle added v1.1 04 March '2006 Inertia became FPS-independant TGLSmoothNavigatorParameters added v1.1.6 18 February '2007 Merged with GLInertedUserInterface.pas All parameters moved into separate classes Added MoveAroudTargetWithInertia v1.2 23 February '2007 Finally made it trully FPS-independant Added default values to every property Contributed to GLScene

GLSMOpenAL GLSMOpenAL<p>

OpenAL based sound-manager (http://www.openal.org).<p> OpenAL drivers can be download from the OpenAL site or your soundcard manufacturer's website.<p>

Unsupported feature(s) :<ul> <li>Accepts only simple *uncompressed* WAV files (8/16 bits, mono/stereo) <li>Dynamic loading/unloading <li>Global 3D parameters <li>Environments <li>CPUUsagePercent <li>No system in place to limit number of sources playing simultaneously, can crash if too playing at once. <li>??? </ul><p>

<b>History : </b><font size=-1><ul> <li>11/11/09 - DaStr - Added $I GLScene.inc <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>25/03/08 - DanB - Added design-time support, linked to new OpenAL headers (see OpenAL.pas). <li>??/??/03 - Mrqzz - Creation </ul></font>

GLSMWaveOut GLSMWaveOut<p>

Basic sound manager based on WinMM <p>

<b>History : </b><font size=-1><ul> <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>25/07/09 - DaStr - Added $I GLScene.inc <li>30/05/09 - DanB - Fixes for AV when sound finishes, and was repeating the same code more than necessary. <li>24/04/09 - DanB - Creation, split from GLSound.pas, to remove windows dependency </ul></font>

GLSound GLSound<p>

Base classes and interface for GLScene Sound System<p>

<b>History : </b><font size=-1><ul> <li>24/04/11 - Yar - Bugfixed TGLSoundSample.Assign (thanks to Anonymous) <li>06/06/10 - Yar - Fixed warnings <li>06/05/09 - DanB - Split TGLSMWaveOut to GLSMWaveOut.pas, to remove windows dependancy <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>22/07/02 - EG - SetMute/SetPause fix (Sternas Stefanos) <li>02/07/02 - EG - Persistence fix (MP3 / Sternas Stefanos) <li>05/03/02 - EG - TGLBSoundEmitter.Loaded <li>27/02/02 - EG - Added 3D Factors, special listener-is-camera support <li>13/01/01 - EG - Added CPUUsagePercent <li>09/06/00 - EG - Various enhancements <li>04/06/00 - EG - Creation </ul></font>

GLSoundFileObjects GLSoundFileFormat<p>

Support classes for loading various fileformats.<p> These classes work together like vector file formats or Delphi's TGraphic classes.<p>

<b>Historique : </b><font size=-1><ul> <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>13/07/09 - DanB - replaced sAllFilter with glsAllFilter (for FPC) <li>30/05/09 - DanB - TGLSoundSampling.WaveFormat now returns correct nBlockAlign, cbSize. <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>07/06/07 - DaStr - Added $I GLScene.inc <li>26/01/05 - JAJ - Removed leak formed by never freeing vSoundFileFormats. Reported by Dikoe Kenguru. <li>16/03/01 - Egg - TGLWAVFile.Capabilities <li>16/07/00 - Egg - Made use of new TDataFile class <li>09/06/00 - Egg - Added WAVDataSize <li>04/06/00 - Egg - Creation </ul></font>

GLSpaceText
GLSpatialPartitioning GLSpatialPartitioning<p>

<p>Spatial partitioning related code that also uses GLScene objects

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>06/06/10 - Yar - Added VectorTypes to uses <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>24/03/07 - DaStr - Replaced GLWin32Viewer with GLViewer (thanks Burkhard Carstens) (Bugtracker ID = 1684432) <li>06/03/07 - DaStr - Removed obsolete FPC IFDEF's <li>19/12/06 - DaStr - Old version of ExtendedFrustumMakeFromSceneViewer function restored as an overloaded version of the new one <li>04/11/05 - Mathx - Corrections related to bug 1335349 (ExtendedFrustumMakeFromSceneViewer supporting more than just regular TGLSceneViewer). <li>03/12/04 - MF - Created </ul></font>

GLStarRecord GLStarRecord<p>

Unit to interface with simple star records aimed for background skies.<p>

<b>History : </b><font size=-1><ul> <li>05/07/03 - EG - Creation </ul></font>

GLState
GLStrings GLStrings<p>

String constants that are used in many GLScene units<p>

<b>History :</b><font size=-1><ul> <li>16/09/10 - YP - Added glsUnknownParam <li>23/02/07 - DaStr - Added glsDot, glsUnsupportedType, glsUncompatibleTypes, glsUnknownType, glsShaderNeedsAtLeastOneLightSource(Ex), glsCadencerNotDefined(Ex), glsSceneViewerNotDefined <li>16/02/07 - DaStr - Added glsOCProxyObjects, glsError, glsErrorEx, glsMatLibNotDefined, glsMaterialNotFoundInMatlib(Ex) <li>26/08/02 - EG - Added missing header, added glsUnknownExtension </ul></font>

GLSVfw
GLSZLibEx ZLibEx<p>

<b>Historique : </b><font size=-1><ul> <li>07/05/10 - Yar - Fixed for Linux x64 <li>06/05/10 - Yar - Added to GLScene (contributed by oleg matrozov) </ul></font>

{***************************************************************************** * * * copyright (c) 2000-2010 base2 technologies * * copyright (c) 1995-2002 Borland Software Corporation * * * * revision history * * 2010.05.02 added ZDelfateEx and ZInflateEx * * 2010.04.20 added TZ*Buffer classes * * 2010.04.15 moved core zlib routines to separate unit (ZLibExApi.pas) * * added ZDeflate* and ZInflate* * * 2010.04.14 fixed ZInternalCompress loops * * fixed ZInternalDecompress loops * * updated ZInternalCompressStream loops * * updated ZInternalDecompressStream loops * * 2010.01.27 updated for delphi 2010 * * 2009.04.14 added overloaded string routines for AnsiString and * * UnicodeString * * 2009.01.28 updated for delphi 2009 String (UnicodeString) * * 2008.05.15 added TStreamPos type for Stream.Position variants * * added TCustomZStream.Stream* methods * * 2007.08.17 modified TZCompressionStream.Write to use Write instead of * * WriteBuffer * * 2007.03.15 moved gzip routines to separate unit (ZLibExGZ.pas) * * 2006.10.07 fixed EZLibError constructor for c++ builder compatibility * * 2006.03.28 moved Z_DEFLATED to interface section * * added custom compression levels zcLevel1 thru zcLevel9 * * 2006.03.27 added ZCompressStreamWeb * * 2006.03.24 added ZAdler32 and ZCrc32 * * 2005.11.29 changed FStreamPos to Int64 for delphi 6+ * * 2005.03.04 modified ZInternalCompressStream loops * * modified ZInternalDecompressStream loops * * 2005.02.07 fixed ZInternalCompressStream loop conditions * * fixed ZInternalDecompressStream loop conditions * * 2005.01.11 added ZCompressStrWeb * * 2003.04.14 added ZCompress2 and ZDecompress2 * * added ZCompressStr2 and ZDecompressStr2 * * added ZCompressStream2 and ZDecompressStream2 * * added overloaded T*Stream constructors to support * * InflateInit2 and DeflateInit2 * * fixed ZDecompressStream to use ZDecompressCheck instead of * * ZCompressCheck * * 2001.11.27 enhanced TZDecompressionStream.Read to adjust source * * stream position upon end of compression data * * fixed endless loop in TZDecompressionStream.Read when * * destination count was greater than uncompressed data * * 2001.10.26 renamed unit to integrate "nicely" with delphi 6 * * 2000.11.24 added soFromEnd condition to TZDecompressionStream.Seek * * added ZCompressStream and ZDecompressStream * * 2000.06.13 optimized, fixed, rewrote, and enhanced the zlib.pas unit * * included on the delphi cd (zlib version 1.1.3) * * * * acknowledgments * * erik turner * * 2001.10.26 Z*Stream routines * * * * david bennion * * 2001.11.27 finding the nasty little endless loop quirk with the * * TZDecompressionStream.Read method * * * * luigi sandon * * 2005.02.07 pointing out the missing loop condition (Z_STREAM_END) * * in ZInternalCompressStream and * * ZInternalDecompressStream * * * * ferry van genderen * * 2005.03.04 assisting me fine tune and beta test * * ZInternalCompressStream and ZInternalDecompressStream * * * * j. rathlev * * 2005.11.28 pointing out the FStreamPos and TStream.Position type * * inconsistency * * * * anders johansen * * 2006.10.07 pointing out the ELibError constructor incompatibility * * with c++ builder * * * * marcin szafranski * * 2009.01.28 beta testing the delphi 2009 changes * * * * iztok kacin * * 2009.04.14 assisting me design and further improve support for * * delphi 2009 * * * * oleg matrozov * * 2010.04.14 pointing out the missing loop condition (avail_in > 0) * * in ZInternalCompress and ZInternalDecompress * * 2010.04.20 prototyping and assisting with the TZ*Buffer classes * *****************************************************************************

GLSZLibExApi ZLibEx<p>

<b>Historique : </b><font size=-1><ul> <li>16/02/11 - PREDATOR - Added support for Mac OS X. Tested on Mac OS X 10.6.5. <li>18/05/10 - Yar - Changed to dynamic library loading for FPC (by Predator) <li>06/05/10 - Yar - Added to GLScene (contributed by oleg matrozov) </ul></font>

****************************************************************************** * ZLibExApi.pas * * * * copyright (c) 2000-2010 base2 technologies * * copyright (c) 1995-2002 Borland Software Corporation * * * * revision history * * 2010.04.20 updated to zlib version 1.2.5 * * 2010.04.15 updated to zlib version 1.2.4 * * 2005.07.25 updated to zlib version 1.2.3 * * 2005.01.11 updated to zlib version 1.2.2 * * 2004.01.06 updated to zlib version 1.2.1 * * 2002.03.15 updated to zlib version 1.1.4 * * * * acknowledgments * * burak kalayci * * 2002.03.15 informing me about the zlib 1.1.4 update * * 2004.01.06 informing me about the zlib 1.2.1 update * * * * vicente sanchez-alarcos * * 2005.01.11 informing me about the zlib 1.2.2 update * * * * mathijs van veluw * * 2005.07.25 informing me about the zlib 1.2.3 update * *****************************************************************************

GLS_CL
GLS_CL_GL
GLS_CL_Platform
GLS_CUDA_API
GLS_CUDA_FourierTransform
GLS_CUDA_ParallelPrimitives
GLS_CUDA_Runtime
GLS_CUDA_Utility GLS_CUDA_Utility<p>

Wraper of cutil.<p>

<b>History : </b><font size=-1><ul> <li>02/03/10 - Yar - Creation </ul></font>

GLS_VDPAU_API
GLS_VDPAU_X11
GLTeapot GLTeapot<p>

Implements the standard Teapot, build from evaluators.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>30/03/07 - DaStr - Added $I GLScene.inc <li>21/07/03 - EG - Creation from GLObjects split </ul></font>

GLTerrainRenderer GLTerrainRenderer<p>

GLScene's brute-force terrain renderer.<p>

<b>History : </b><font size=-1><ul> <li>10/01/13 - PW - Added CPP compatibility: considered sensitivity to upper case characters in identifiers <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>15/08/10 - Yar - Return missing part of code in BuildList <li>20/05/10 - Yar - Fixes for Linux x64 <li>20/07/07 - LC - Fixed a problem when camera is far away from the terrain bounds. (Bugtracker ID = 1757733) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Cosmetic fixes for FPC compatibility <li>27/03/07 - Lin- Added TileManagement flags. - Helps prevent tile cache fushes. <li>19/03/07 - Lin- Added IgnoredByRenderer flag to THeightData. Helps manage duplicate tiles, when a dirty tile is being replaced. <li>16/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>08/02/07 - Lin- Ignore tiles that are not hdsReady (Prevents crashes when threading) <li>30/01/07 - Lin- Added HashedTileCount - Counts the tiles in the buffer <li>19/10/06 - LC - Changed the behaviour of OnMaxCLODTrianglesReached <li>09/10/06 - Lin- Added OnMaxCLODTrianglesReached event.(Rene Lindsay) <li>01/09/04 - SG - Fix for RayCastIntersect (Alan Rose) <li>02/08/04 - LR, YHC - BCB corrections: use record instead array <li>25/04/04 - EG - Occlusion testing support <li>13/01/04 - EG - Leak fix (Phil Scadden) <li>05/11/03 - SG - Fixed minuscule bug in RayCastIntersect (thanks Michael) <li>06/02/03 - EG - Fixed speculative range computation, better hashkey <li>14/01/03 - EG - RayCastIntersect normals fix (Stuart Gooding) <li>24/09/02 - EG - Added RayCastIntersect (Stuart Gooding) <li>28/08/02 - EG - Now longer wrongly requests hdtByte (Phil Scadden), Terrain bounds limiting event (Erazem Polutnik) <li>10/07/02 - EG - Added support for "holes" in the elevation data <li>16/06/02 - EG - Added support for multi-material terrains <li>24/02/02 - EG - Hybrid ROAM-stripifier engine <li>18/12/01 - EG - Vertex-cache aware stripifier (+10% on GeForce) <li>12/08/01 - EG - Completely rewritten handles management <li>21/07/01 - EG - Added Notication registration in SetHeightDataSource <li>04/03/01 - EG - Completed for first release <li>12/02/01 - EG - Creation </ul></font><p>

NOTA : multi-materials terrain support is not yet optimized to minimize texture switches (in case of resued tile textures).

GLTexCombineShader GLTexCombineShader<p>

A shader that allows texture combiner setup.<p>

<b>History : </b><font size=-1><ul> <li>05/03/11 - Yar - Added combiner's commands cache <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>24/07/09 - DaStr - TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) <li>03/04/07 - DaStr - Added $I GLScene.inc <li>25/02/07 - DaStr - Moved registration to GLSceneRegister.pas <li>23/05/03 - EG - Added support for binding two extra texture units <li>16/05/03 - EG - Creation </ul></font>

GLTexLensFlare GLTexLensFlare<p>

Texture-based Lens flare object.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>30/03/07 - DaStr - Added $I GLScene.inc <li>23/03/07 - DaStr - Added missing parameters in procedure's implementation (thanks Burkhard Carstens) (Bugtracker ID = 1681409) <li>25/09/03 - EG - Creation from GLLensFlare split </ul></font><p>

GLTexture GLTexture<p>

Handles all the color and texture stuff.<p>

<b>History : </b><font size=-1><ul> <li>04/01/13 - PW - Moved cubic map texture consts CmtPX..CmtNZ from GLColor unit to here <li>10/11/12 - PW - Added CPPB compatibility: used dummy instead abstract methods, restored definition of TGLCubeMapTarget as integer type <li>12/05/11 - Yar - Added KeepImageAfterTransfer for TGLTexture <li>04/10/10 - Yar - Improved multycontext features for TGLTexture <li>23/08/10 - Yar - Added OpenGLTokens to uses <li>21/05/10 - Yar - Removed TGLFloatDataImage, replace OpenGL1x functions to OpenGLAdapter <li>16/05/10 - Yar - Added protected method IsSelfLoading and LoadTexture to TGLTextureImage <li>14/05/10 - Yar - Fixed UnpackAlignment in PrepareParams <li>09/05/10 - Yar - Fixed texture compression (thanks Hacker) <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - Removed disabling Texture Rect/CubeMap/3D, since disabling will cause errors on hardware that doesn't support them <li>05/03/10 - DanB - More state added to TGLStateCache <li>23/01/10 - Yar - Added TextureFormatEx to TGLTexture and tfExtended to TGLTextureFormat (thanks mif for idea) <li>22/01/10 - Yar - Added GLTextureFormat to uses, 1D, 3D, array, cube map array target support, texture error indication, TGLTextureImage ResorceName property, Depth property, NativeTextureTarget becomes property <li>07/01/10 - DaStr - Added tmAdd TextureMode and enhanced documentation (thanks DungeonLords) Removed IncludeTrailingBackslash function <li>10/11/09 - DaStr - Added more texture formats (thanks YarUnderoaker) <li>04/06/09 - DanB - Delphi 5 fix <li>17/10/08 - DanB - changed some NotifyChange(Sender) calls to NotifyChange(Self) <li>08/10/08 - DanB - split materials related stuff into GLMaterial.pas <li>06/10/08 - DanB - added Assert check for trying to create texture images <li>05/10/08 - DanB - separated texture image editor from texture unit moved color related stuff to GLColor.pas moved TRenderContextInfo into separate unit <li>12/04/08 - DaStr - Bugfixed TGLTextureExItem.Create() (thanks dAlex) (BugTracker ID = 1940451) <li>10/04/08 - DaStr - Added a Delpi 5 interface bug work-around to TGLMaterial (BugTracker ID = 1938988) <li>08/02/08 - Mrqzzz - Added tiaBottomRightPointColorTransparent <li>29/07/07 - LC - Modified how tmmEyeLinear is applied, see Bugtracker ID = 1762966. <li>06/06/07 - DaStr - Moved all color types, constants and functions to GLColor.pas (Bugtracker ID = 1732211) <li>31/03/07 - DaStr - Bugfixed TGLTexture.Assign (missed some properties) (Bugtracker ID = 1692012) (thanks Zapology) <li>28/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>23/03/07 - DaStr - Added missing parameters in procedure's implementation (thanks Burkhard Carstens) (Bugtracker ID = 1681409) <li>06/03/07 - DaStr - Removed obsolete FPC IFDEF's (thanks Burkhard Carstens) (Bugtracker ID = 1678642) <li>14/03/07 - DaStr - TGLPicFileImage now provides correct Width and Height (BugtrackerID = 1680742) <li>09/03/07 - DaStr - Added TGLMaterial.GetActualPrimaryMaterial, GetLibMaterial Bugfixed TGLColor.Initialize and TGLColor.Destroy (thanks Burkhard Carstens) (BugtrackerID = 1678650) <li>04/03/07 - DaStr - Added TGLTextureTarget, [Encode/Decode]GLTextureTarget <li>23/02/07 - DaStr - Added TGLShaderClass, TGLShaderFailedInitAction, EGLShaderException Added TGLShader.HandleFailedInitialization, ShaderSupported, GetStardardNotSupportedMessage, FailedInitAction Added default value for TGLShader.ShaderStyle Fixed TGLShader.InitializeShader Fixed TGLTextureExItem.Create (TGLCoordinatesStyle stuff) <li>16/02/07 - DaStr - Global $Q- removed Added TGLLibMaterials.GetTextureIndex, GetMaterialIndex, GetNameOfTexture, GetNameOfLibMaterial Added TGLMaterialLibrary.TextureByName, GetNameOfTexture, GetNameOfLibMaterial <li>01/02/07 - LIN - Added TGLLibMaterial.IsUsed : true if texture has registered users <li>23/01/07 - LIN - Added TGLTextureImage.AssignToBitmap : Converts the TextureImage to a TBitmap <li>23/01/07 - LIN - Added TGLTextureImage.AsBitmap : Returns the TextureImage as a TBitmap <li>22/01/07 - DaStr - IGLMaterialLibrarySupported abstracted TGLLibMaterial.TextureOffset/TextureScale.FStyle bugfxed (thanks Ian Mac) <li>20/12/06 - DaStr - TGLColorManager.Enumcolors overloaded TGLShader.Apply bugfixed, TGLShader.Assign added <li>19/10/06 - LC - Fixed TGLLibMaterial.UnApply so it doesn't unapply a 2nd texture that was never applied. Bugtracker ID=1234085 <li>19/10/06 - LC - Fixed TGLLibMaterial.Assign. Bugtracker ID=1549843 (thanks Zapology) <li>15/09/06 - NC - TGLShader.handle as Integer -> Cardinal <li>12/09/06 - NC - Added GetFloatTexImage and SetFloatTexImage <li>06/03/05 - EG - FTextureEx now autocreated (like FTexture) <li>30/11/04 - EG - No longer stores TextureEx if empty <li>06/10/04 - NC - Corrected filtering param. setting for float texture, Now keep using GL_TEXTURE_RECTANGLE_NV for TGLFloatDataImage <li>05/10/04 - SG - Added Material.TextureEx (texture extension) <li>04/10/04 - NC - Added TGLFloatDataImage <li>02/08/04 - LR, YHC - BCB corrections: Added dummy method for the abstract problem Changed type of TGLCubeMapTarget to integer <li>03/07/04 - LR - Move InitWinColors to GLCrossPlatform Replace TGraphics, TBitmap by TGLGraphics, TGLBitmap <li>29/06/04 - SG - Added bmModulate blending mode <li>08/04/04 - EG - Added AddMaterialsFromXxxx logic <li>04/09/03 - EG - Added TGLShader.Enabled <li>02/09/03 - EG - Added TGLColor.HSVA <li>28/07/03 - aidave - Added TGLColor.RandomColor <li>24/07/03 - EG - Introduced TGLTextureImageEditor mechanism <li>04/07/03 - EG - Material.Texture now autocreating, added per-texture brightness and gamma correction <li>13/06/03 - EG - cubemap images can now be saved/restored as a whole <li>05/06/03 - EG - Assign fixes (Andrzej Kaluza) <li>23/05/03 - EG - More generic libmaterial registration <li>08/12/02 - EG - Added tiaInverseLuminance <li>13/11/02 - EG - Added tmmCubeMapLight0 <li>18/10/02 - EG - CubeMap texture matrix now setup for 2nd texture unit too <li>24/07/02 - EG - Added TGLLibMaterials.DeleteUnusedMaterials <li>13/07/02 - EG - Improved materials when lighting is off <li>10/07/02 - EG - Added basic protection against cyclic material refs <li>08/07/02 - EG - Multipass support <li>18/06/02 - EG - Added TGLShader <li>26/01/02 - EG - Makes use of new xglBegin/EndUpdate mechanism <li>24/01/02 - EG - Added vUseDefaultSets mechanism, TGLPictureImage no longer systematically creates a TPicture <li>21/01/02 - EG - Fixed OnTextureNeeded calls (Leonel) <li>20/01/02 - EG - Fixed texture memory use report error <li>10/01/02 - EG - Added Material.FaceCulling, default texture filters are now Linear/MipMap <li>07/01/02 - EG - Added renderDPI to rci <li>16/12/01 - EG - Added support for cube maps (texture and mappings) <li>30/11/01 - EG - Texture-compression related errors now ignored (unsupported formats) <li>14/09/01 - EG - Use of vFileStreamClass <li>06/09/01 - EG - No longers depends on 'Windows' <li>04/09/01 - EG - Texture binding cache <li>31/08/01 - EG - tiaDefault wasn't honoured (Rene Lindsay) <li>25/08/01 - EG - Added TGLBlankImage <li>16/08/01 - EG - drawState now part of TRenderContextInfo <li>15/08/01 - EG - TexGen support (object_linear, eye_linear and sphere_map) <li>13/08/01 - EG - Fixed OnTextureNeeded handling (paths for mat lib) <li>12/08/01 - EG - Completely rewritten handles management <li>27/07/01 - EG - TGLLibMaterials now a TOwnedCollection <li>19/07/01 - EG - Added "Enabled" to TGLTexture <li>28/06/01 - EG - Added AddTextureMaterial TGraphic variant <li>14/03/01 - EG - Streaming fixes by Uwe Raabe <li>08/03/01 - EG - TGLPicFileImage.GetBitmap32 now resets filename if not found <li>01/03/01 - EG - Fixed TGLMaterial.DestroyHandle, Added Texture2 notifications and material cacheing <li>26/02/01 - EG - Added support for GL_EXT_texture_filter_anisotropic <li>23/02/01 - EG - Fixed texture matrix messup (second was using first) <li>21/02/01 - EG - Minor fix for TextureImageRequiredMemory, TexGen calls now based on XOpenGL <li>14/02/01 - EG - Added support for texture format & texture compression <li>31/01/01 - EG - Added Multitexture support <li>28/01/01 - EG - Added MaterialOptions <li>15/01/01 - EG - Enhanced TGLPicFileImage.LoadFromFile <li>13/01/01 - EG - New helper functions for TGLMaterialLibrary <li>08/01/01 - EG - Not-so-clean fix for TGLTexture.Destroy... better fix will require awareness of rendering contexts... <li>06/12/00 - EG - Added PrepareBuildList mechanism <li>16/10/00 - EG - Fix in TGLPictureImage.Assign <li>25/09/00 - EG - New texture management implemented <li>13/08/00 - EG - Added AddTextureMaterial <li>06/08/00 - EG - File not found error now happens only once per texture, also added some more doc and texture transforms support to TGLLibMaterial <li>27/07/00 - EG - TGLPictureImage.Assign now accepts TGraphic & TPicture, Added max texture size clamping <li>15/07/00 - EG - Upgrade for new list/handle destruction scheme <li>05/07/00 - EG - Added tiaTopLeftPointColorTransparent <li>28/06/00 - EG - Added asserts for missing texture files <li>01/06/00 - EG - Added ReloadTexture (support for texture library), Fixed persistence of material names in a texture library <li>28/05/00 - EG - TGLColor now has NotifyChange support for TGLBaseSceneObject <li>23/04/00 - EG - Fixed bugs with TGLPicFileImage & TGLPersistentImage, Added tiaOpaque <li>17/04/00 - EG - Added Assign to DummyCube and Sprite <li>16/04/00 - EG - Added TGLPicFileImage.Assign <li>26/03/00 - EG - Finally fixed nasty bug in TGLMaterial.Free <li>22/03/00 - EG - Added BeginUpdate/EndUpdate to TGLPictureImage, Made use of [Un]SetGLState in TGLMaterial (gain = 7-10% on T&L intensive rendering), TGLTexBaseClass is no more (RIP) <li>21/03/00 - EG - TGLMaterial props are now longer stored when it is linked to a material library entry, Added TGLPictureImage (split from TGLPersistentImage), TGLPicFileImage has been updated and reactivated, ColorManager is now autocreated and non longer force-linked. <li>19/03/00 - EG - Added SaveToXxxx & LoadFromXxxx to TGLMaterialLibrary <li>18/03/00 - EG - Added GetGLTextureImageClassesAsStrings, Added FindGLTextureImageClassByFriendlyName, FChanges states now ignored in TGLTexture.GetHandle, Added SaveToFile/LoadFromFile to TextureImage <li>17/03/00 - EG - Added tiaLuminance <li>14/03/00 - EG - Added RegisterGLTextureImageClass stuff, Added ImageAlpha <li>13/03/00 - EG - Changed TGLTextureImage image persistence again, Added "Edit" method for texture image classes, TMagFilter/TMinFilter -> TGLMagFilter/TGLMinFilter <li>03/03/00 - EG - Removed TImagePath, Started major rework of the whole TGLTextureImage stuff, Fixed and optimized TGLTexture.PrepareImage <li>12/02/00 - EG - Added Material Library <li>10/02/00 - EG - Fixed crash when texture is empty <li>08/02/00 - EG - Added AsWinColor & DeclareCurrentAsDefault to TGLColor, fixed notification on material property setXxx methods, Objects now begin with 'TGL' <li>07/02/00 - EG - "Update"s renamed to "NotifyChange"s <li>06/02/00 - EG - RoundUpToPowerOf2, RoundDownToPowerOf2 and IsPowerOf2 moved to GLMisc, added TGLPersistentImage.Assign, fixed TGLMaterial.Assign, disable inheritance stuff in TGLFaceProperties.Apply (needs fixing), Diffuse & ambient color now default to openGL values <li>05/02/00 - EG - Javadocisation, fixes and enhancements :<br> TGLColor.Update, ConvertWinColor, TPicImage, TGLMaterial.Apply </ul></font>

GLTextureCombiners GLTextureCombiners<p>

Texture combiners setup utility functions.<p>

<b>History : </b><font size=-1><ul> <li>05/03/11 - Yar - Added combiner's commands cache <li>23/08/10 - Yar - Added OpenGLTokens to uses <li>18/06/10 - Yar - Replaced OpenGL functions to OpenGLAdapter <li>02/04/07 - DaStr - Added $I GLScene.inc <li>17/12/03 - EG - Alpha and RGB channels separate combination now supported <li>23/05/03 - EG - All tex units now accepted as target <li>22/05/03 - EG - Fixed GL_ADD_SIGNED_ARB parsing, better error reporting <li>16/05/03 - EG - Creation </ul></font>

GLTexturedHDS Implements a HDS, which automatically maps textures onto a parent HDS .<p> This HDS links to and extracts its height data from a parent HDS. (like TGLHeightTileFile)

The HDS also links to a TGLMaterial Library, and maps ALL textures from the selected Material Library onto the terrain, WITHOUT using Multitexturing. The position and scale of each texture is determined by the material's own TextureOffset and TextureScale properties. This makes it easy to tile many textures onto a single, continuous TGLTerrainRenderer.

If two or more textures in the library overlap, the top texture is used.( ie.the later one in the list)

WARNING: Only one base texture is mapped onto each terrain tile, so, make sure your texture edges are alligned to height tile edges, or gaps will show. (Of course you can still multitexture in a detail texture too.)

<b>History : </b><font size=-1><ul> <li>22/01/07 - LIN - Added 'TileSize' and 'TilesPerTexture' properties Removed 'Active' property Now works with both TGLHeightTileFileHDS AND TGLBitmapHDS <li>19/01/07 - LIN - Creation </ul></font>

GLTextureFormat GLTextureFormat<p>

<b>History : </b><font size=-1><ul> <li>10/05/12 - Yar - Fixed extension checking for float texture (thnaks Nelson Chu) <li>03/08/10 - Yar - Added SNORM texture format <li>15/06/10 - Yar - Replace OpenGL1x extensions to OpenGLAdapter <li>22/04/10 - Yar - Moved TGLTextureTarget <li>23/01/10 - Yar - Separated GLTextureFormat and GLInternalFormat GLTextureFormat moved to GLTexture <li>21/01/10 - Yar - Creation </ul><p>

GLTextureImageEditors GLTextureImageEditors<p>

Standard texture image editors for standard texture image classes.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPPB compatibility: used dummy method instead abstract class function Edit for GLS_CPPB <li>22/01/10 - Yar - Added to TGLBlankImage property editor ability to set the depth <li>03/07/04 - LR - Make change for Linux <li>24/07/03 - EG - Creation </ul></font>

GLTextureSharingShader GLTextureSharingShader (originally GlProxMultiMatShader)<p> <p> This shader allows to apply multiple textures, gathering them from existing materials. This allows saving resources, since you can reference the textures of any material in any materialLibrary. Note that actually the component references a Material (not a texture) but it uses that material's texture. The referenced material settings will be ignored, but the texture's settings (like TextureMode, ImageGamma, ImageBrightness) will be used. Instead the local material settings (listed in the collection) will be used. </p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/08/10 - Yar - Fixed light state changes <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>10/04/08 - DaStr - Added a Delpi 5 interface bug work-around (BugTracker ID = 1938988). TGLTextureSharingShaderMaterial.GetTextureSharingShader() is now more safe <li>24/03/08 - DaStr - Small fixups with setting LibMaterial and for Delphi 5 compatibility (thanks Pascal) <li>21/03/08 - DaStr - Reformated according to VCL standard, made some renamings <li>17/03/08 - mrqzzz - Added IGLMaterialLibrarySupported, moved registration <li>14/03/08 - Pascal - Initial version (contributed to GLScene)

GLThorFX
GLTilePlane GLTilePlane<p>

Implements a tiled texture plane.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>23/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>19/08/05 - Mathx - Made index of materials start from 0 not from 1 (thanks to uhfath) <li>23/03/04 - EG - Added NoZWrite <li>09/01/04 - EG - Creation </ul></font>

GLTimeEventsMgr GLTimeEventsMgr<p> by GliGli

Time based events mannager using the Cadencer<p> can be useful to make animations with GlScene<p>

<b>History : </b><font size=-1><ul> <li>07/01/10 - DaStr - Added TGLTimeEventsMGR.Reset() Fixed code formating <li>25/11/09 - DanB - Changed TTimeEvent.Name from ShortString to String <li>11/10/07 - DaStr - TTimeEvent.SetEnabled now updates StartTime to Cadencers's current time. (Thanks Lukasz Sokol) (BugTracker ID = 1811141) <li>28/03/07 - DaStr - Cosmetic fix for FPC compatibility <li>29/01/07 - DaStr - Moved registration to GLSceneRegister.pas <li>07/02/02 - EG - Added Notification, DoEvent, ElapsedTime and changed Event type

GLTrail GLTrail<p>

Creates a trail-like mesh. Based on Jason Lanford's demo. <p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>03/04/07 - DaStr - Added default values to some properties Added TGLTrail.AntiZFightOffset Subscribed for Notification in TGLTrail.SetTrailObject <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>19/12/06 - DaS - msRight (TMarkStyle) support added <li>09/12/04 - LR - Suppress windows uses <li>12/10/04 - Mrqzzz - Creation (Based on Jason Lanford's demo - june 2003) </ul></font>

GLTree GLTree<p>

Dynamic tree generation in GLScene<p>

This code was adapted from the nVidia Tree Demo: http://developer.nvidia.com/object/Procedural_Tree.html<p>

History:<ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>13/01/07 - DaStr - Added changes proposed by Tim "Sivael" Kapuœciñski [sivael@gensys.pl] Modified the code to create much more realistic trees - added third branch for every node and modified constants to make the tree look more "alive". Also removed the "fractal effect" that ocurred, when rendering with the older engine - the leaves and branches were much more "in order". Added Center* declarations, CenterBranchConstant, Added AutoRebuild flag. <li>02/08/04 - LR, YHC - BCB corrections: use record instead array <li>14/04/04 - SG - Added AutoCenter property. <li>03/03/04 - SG - Added GetExtents and AxisAlignedDimensionsUnscaled. <li>24/11/03 - SG - Creation. </ul>

Some info: <ul>CenterBranchConstant</ul> - Defines, how big the central branch is. When around 50% it makes a small branch inside the tree, for higher values much more branches and leaves are created, so either use it with low depth, or set it to zero, and have two-branched tree. Default : 0.5 <ul>"AutoRebuild" flag</ul> - Rebuild tree after property change. Default: True

GLTypes GLTypes<p> Defines vector types for geometry only aiming to imply compatibility of GLScene for Delphi with C+Builder. Do not include any other units in uses clause <p>

<b>History : </b><font size=-1><ul> <li>12/12/12 - PW - Added TGLVector's and TGLMatrix's types <li>11/11/11 - PW - Creation. Defined TGLPoint, TGLPolygon and TGLPolyhedron types </ul>

GLUserShader GLUserShader<p>

A shader that passes control of the DoApply and DoUnApply methods through published events. This component is designed to make it a little easier to implement a customized shader. Be sure to keep the shader balanced by returning the OpenGL state to how you found it.<p>

<b>History : </b><font size=-1><ul> <li>25/02/07 - DaStr - Moved registration to GLSceneRegister.pas <li>05/08/03 - SG - Creation </ul></font>

GLUtils GLUtils<p>

Miscellaneous support utilities & classes.<p>

<b>History : </b><font size=-1><ul> <li>02/01/13 - Yar - Added SetGLSceneMediaDir <li>07/01/11 - Yar - Added SaveModelDialog, OpenModelDialog <li>04/03/10 - DanB - Now uses CharInSet <li>27/05/09 - DanB - re-added TryStrToFloat, since it ignores user's locale. <li>24/03/09 - DanB - removed TryStrToFloat (exists in SysUtils or GLCrossPlatform already) changed StrToFloatDef to accept only 1 param + now overloaded <li>24/03/09 - DanB - Moved Dialog utilities here from GLCrossPlatform, because they work on all platforms (with FPC) <li>16/10/08 - UweR - corrected typo in TryStringToColorAdvanced parameter <li>16/10/08 - DanB - renamed Save/LoadStringFromFile to Save/LoadAnsiStringFromFile <li>24/03/08 - DaStr - Removed OpenGL1x dependancy Moved TGLMinFilter and TGLMagFilter from GLUtils.pas to GLGraphics.pas (BugTracker ID = 1923844) <li>25/03/07 - DaStr - Replaced StrUtils with GLCrossPlatform <li>23/03/07 - DaStr - Removed compiler warnings caused by SaveComponentToFile and LoadComponentFromFile <li>22/03/07 - DaStr - Added SaveComponentToFile, LoadComponentFromFile <li>07/02/07 - DaStr - Added StringToColorAdvanced() functions <li>05/09/03 - EG - Creation from GLMisc split </ul></font>

GLVectorFileObjects GLVectorFileObjects<p>

Vector File related objects for GLScene<p>

<b>History :</b><font size=-1><ul>

<li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>11/07/12 - YP - Added BarycenterPosition and BarycenterOffset New centering option macRestorePosition <li>02/07/11 - DaStr - Replaced TAABB.Revision with TMeshObject.FExtentCacheRevision <li>30/06/11 - DaStr - TGLBaseMesh.BarycenterAbsolutePosition() now uses caching <li>23/02/11 - Yar - Added extent caching to TMeshObject <li>03/12/10 - Yar - Added mesh visibility checking in TMeshObjectList.ExtractTriangles (thnaks to Sandor Domokos) <li>23/08/10 - Yar - Added OpenGLTokens to uses <li>23/07/10 - Yar - Bugfixed TSkeleton.WriteToFiler (thanks E-Cone) <li>11/06/10 - Yar - Bugfixed binary reading TGLMeshObject for FPC Replace OpenGL1x functions to OpenGLAdapter. Fixes for Linux x64 <li>22/04/10 - Yar - Fixes after GLState revision <li>11/04/10 - Yar - Replaced function InsideList to GLState.InsideList <li>05/03/10 - DanB - More state added to TGLStateCache <li>25/12/09 - DaStr - Separated TGLActor.DoAnimate() from TGLActor.BuildList() <li>16/01/09 - DanB - re-disable VBOs in display list to prevent AV on ATI cards <li>27/11/08 - DanB - fix to TFGVertexIndexList.BuildList <li>05/10/08 - DaStr - Added GLSM format backward compatibility after MeshObject.LightMapTexCoords update (thanks Uwe Raabe) (Bugtracker ID = 2140994) <li>03/10/08 - DanB - Added Delphi 2009 (Unicode) support <li>22/06/08 - DaStr - TMeshObject.LightMapTexCoords converted to TAffineVectorList (thanks Ast) (Bugtracker ID = 2000089) <li>07/06/08 - DaStr - Implemented TBaseMeshObject.Assign(), TMeshObject.Assign() <li>20/05/08 - Mrqzzz - Fixed memory leak in TSkeletonMeshObject.Destroy (thanks Dave Gravel) <li>17/05/08 - DaStr - Added TSkeleton.MorphInvisibleParts (thanks andron13 and Veon (BugtrackerID = 1966020) Added vGLVectorFileObjectsEnableVBOByDefault <li>01/05/08 - DaStr - Implemented TGLBaseMesh.BarycenterAbsolutePosition() Bugfixed TGLBaseMesh.AxisAlignedDimensionsUnscaled() <li>06/04/08 - DaStr - TMeshObjectList.MorphTo() and Lerp() are now virtual <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>16/05/07 - PvD - Applied fixes to skeletonmesh to fix problems with physics engines. (Bugtracker ID = 1719652) <li>15/05/07 - LC - Added workaround for ATI bug in TFGVertexIndexList. (Bugtracker ID = 1719611) <li>13/05/07 - LC - Fixed AV bug in TMeshObject.BufferArrays (Bugtracker ID = 1718033) <li>03/04/07 - LC - Added VBO support for TextureEx (Bugtracker ID = 1693378) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>25/03/07 - LC - Added VBO support to TFGVertexIndexList, depends on MeshObject owner's UseVBO status <li>25/03/07 - LC - Fixed VBO bug. Bugtracker ID=1687665 <li>16/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>21/02/07 - DaStr - Added TMeshObjectList.BuildTangentSpace, UseVBO Added TGLActor.SetCurrentFrameDirect <li>19/02/07 - LC - Added some VBO support <li>19/10/06 - LC - Fixed bug in TGLActor.SetCurrentFrame. Bugtracker ID=1580511 <li>04/10/06 - PhP - fixed TGLActor.SetCurrentFrame (thanks dikoe) <li>05/12/05 - PhP - fixed TFGIndexTexCoordList.BuildList (thanks fig) <li>10/11/05 - Mathx - Added LastLoadedFilename to TGLBaseMesh (RFE 955083). <li>09/11/05 - Mathx - Added isSwitchingAnimation to TGLActor. <li>05/09/05 - Mathx - Fixed TSkeletonMeshObject read/write filer (thanks to Zapology) <li>04/07/05 - Mathx - Protection against picking mode texture mapping errors <li>27/01/05 - Mathx - BuildOctree can now specify an (optional) TreeDepth. <li>11/01/05 - SG - Another fix for TGLBaseMesh.Assign (dikoe Kenguru) <li>11/01/05 - SG - Fix for TGLBaseMesh.Assign when assigning actors <li>26/11/04 - MRQZZZ - by Uwe Raabe : fixed TBaseMeshObject.BuildNormals <li>26/11/04 - MRQZZZ - Added "Rendered" property to TGLBaseMesh in order to prevent rendering of the GLBaseMesh but allowing the rendering of it's children <li>25/11/04 - SG - Fixed memory leak in TMeshObject (dikoe Kenguru) <li>24/11/04 - MF - Added OctreePointInMesh <li>03/10/04 - MRQZZZ - Fixed memory leak (FAutoScaling.Free) in TGLBaseMesh.Destroy; (thanks Jan Zizka) <li>24/09/04 - SG - Added GetTriangleData/SetTriangleData functions, Added TexCoordsEx, Binormals, Tangents, Added BuildTangentSpace function (experimental). <li>23/07/04 - SG - Added fgmmQuad case for TFGVertexIndexList.TraingleCount (Thanks fig). <li>02/08/04 - LR, YHC - BCB corrections: use record instead array moved TBlendedLerpInfo to top of declaration <li>18/07/04 - LR - Suppress Consts in uses <li>20/06/04 - MRQZZZ - Added AutoScaling property to GLBaseMesh to scale a mesh after loading (like Autocentering) <li>30/03/04 - EG - Added TSkeletonBoneList.BoneCount <li>23/03/04 - SG - External positions added to skeleton blended lerps. AutoUpdate flag added to skeleton collider list. <li>09/03/04 - SG - TFGIndexTexCoordList.BuildList can now use per vertex color <li>29/01/04 - SG - Fix for ApplyCurrentSkeletonFrame with multiple bones per vertex. Mesh reassembles correctly now (tested up to 4 bones per vertex). <li>03/12/03 - SG - Added TSkeletonCollider and TSkeletonColliderList Added Colliders (TSkeletonColliderList) to TSkeleton <li>24/10/03 - SG - Various fixes for multiple bones per vertex <li>21/09/03 - MRQZZZ - Added "aamLoopBackward" to AnimationMode property <li>19/09/03 - EG - "Lighmap" -&gt; "LightMap" <li>01/09/03 - SG - Added skeleton frame conversion methods to convert between Rotations and Quaternions. <li>27/08/03 - SG - Fixed AddWeightedBone for multiple bones per vertex <li>13/08/03 - SG - Added quaternion transforms for skeletal animation <li>12/08/03 - SG - Fixed a tiny bug in TSkeleton.MorphMesh <li>08/07/03 - EG - Fixed puny bug in skeletal normals transformation <li>05/06/03 - SG - Split SMD, MD2, 3DS, PLY, TIN and GTS code into separate units, FileFormats\GLFile???.pas <li>16/05/03 - SG - Fixed OpenGL error caused by glColorMaterial in TMeshObject.BuildList <li>08/05/03 - DanB - added OctreeAABBIntersect (Matheus Degiovani) <li>07/05/03 - SG - Added TGLSMDVectorFile.SaveToFile method and [read,write] capabilities <li>17/04/03 - SG - Added TMeshObjectList.FindMeshByName method <li>01/04/03 - SG - Fixed TGLBaseMesh.Assign <li>13/02/03 - DanB - added AxisAlignedDimensionsUnscaled <li>03/02/03 - EG - Faster PrepareBuildList logic <li>31/01/03 - EG - Added MaterialCache logic <li>30/01/03 - EG - Fixed color array enable/disable (Nelson Chu), Normals extraction and extraction standardization <li>27/01/03 - EG - Assign support, fixed MorphableMeshObjects persistence <li>16/01/03 - EG - Updated multiples Bones per vertex transformation code, now makes use of CVAs <li>14/01/03 - EG - Added DisableOpenGLArrays <li>09/01/03 - EG - Added Clear methods for MeshObjects <li>25/11/02 - EG - Colors and TexCoords lists now disabled if ignoreMaterials is true <li>23/10/02 - EG - Faster .GTS and .PLY imports (parsing) <li>22/10/02 - EG - Added actor options, fixed skeleton normals transform (thx Marcus) <li>21/10/02 - EG - Read support for .GTS (GNU Triangulated Surface library) <li>18/10/02 - EG - FindExtByIndex (Adem) <li>17/10/02 - EG - TGLSTLVectorFile moved to new GLFileSTL unit <li>04/09/02 - EG - Fixed TGLBaseMesh.AxisAlignedDimensions <li>23/08/02 - EG - Added TGLBaseMesh.Visible <li>23/07/02 - EG - TGLBaseMesh.LoadFromStream fix (D. Angilella) <li>13/07/02 - EG - AutoCenter on barycenter <li>22/03/02 - EG - TGLAnimationControler basics now functional <li>13/03/02 - EG - Octree support (experimental) <li>18/02/02 - EG - Fixed persistence of skeletal meshes <li>04/01/02 - EG - Added basic RayCastIntersect implementation <li>17/12/01 - EG - Upgraded TGLActor.Synchronize (smooth transitions support) <li>30/11/01 - EG - Added smooth transitions (based on Mrqzzz code) <li>14/09/01 - EG - Use of vFileStreamClass <li>18/08/01 - EG - Added TriangleCount methods, STL export, PLY import <li>15/08/01 - EG - FaceGroups can now be rendered by material group (activate with RenderingOption "moroGroupByMaterial") <li>14/08/01 - EG - Added TSkeletonBoneList and support for skeleton with multiple root bones, updated SMD loader <li>13/08/01 - EG - Improved/fixed SMD loader <li>12/08/01 - EG - Completely rewritten handles management, Fixed TActorAnimation.Assign, Fixed persistence <li>08/08/01 - EG - Added TGLBaseMesh.AxisAlignedDimensions <li>19/07/01 - EG - AutoCentering is now a property of TGLBaseMesh, 3DS loader no longer auto-centers, Added ExtractTriangles and related methods <li>18/07/01 - EG - VisibilityCulling compatibility changes <li>19/06/01 - EG - StrToFloat outlawed and replaced by StrToFloatDef <li>25/03/01 - EG - Added TGLAnimationControler <li>18/03/01 - EG - Added basic Skeleton structures & SMD importer <li>16/03/01 - EG - Introduced new PersistentClasses <li>15/03/01 - EG - Fix in TActorAnimation.SetEndFrame (thx David Costa) <li>08/03/01 - EG - TGL3DSVectorFile now loads materials for TGLBaseMesh <li>26/02/01 - EG - Added TBaseMeshObject & BuildNormals, MD2 normals auto-builded <li>21/02/01 - EG - Now XOpenGL based (multitexture) <li>15/01/01 - EG - Added Translate methods <li>10/01/01 - EG - Fixed in TGLBaseMesh.DoRender for RenderChildren states <li>08/01/01 - EG - Fixed TGLBaseMesh.BuildList messup of attrib states <li>22/12/00 - EG - Fixed non-interpolated TGLActor animation (was freezing), Fixed TGLBaseMesh.DoRender messup of attrib states <li>18/12/00 - EG - TFGIndexTexCoordList now supports normals (automatically), NormalsOrientation code moved to TGLBaseMesh <li>11/12/00 - EG - Fix for NormalOrientation (3DS importer) <li>06/12/00 - EG - Added PrepareBuildList mechanism <li>08/10/00 - EG - Removed TGLOBJVectorFile, use GLFileOBJ instead <li>13/08/00 - EG - Enhancements for Portal Rendering support, Added utility methods & triangle fans <li>10/08/00 - EG - Added CurrentAnimation, fixed TMeshObject.GetExtents <li>21/07/00 - EG - Vastly improved memory use and mechanisms for MD2/TGLActor <li>19/07/00 - EG - Introduced enhanced mesh structure <li>16/07/00 - EG - Made use of new TDataFile class <li>15/07/00 - EG - FreeForm can now handle 3DS files with multiple textures, Added TGLBaseMesh.GetExtents <li>28/06/00 - EG - Support for "ObjectStyle" <li>23/06/00 - EG - Reversed "t" texture coord for MD2, TActorAnimations can now load/save <li>21/06/00 - EG - Added frame change events to TGLActor, Added TActorAnimations collection <li>19/06/00 - EG - Completed smooth movement interpolation for TGLActor <li>07/06/00 - EG - TVectorFile now longers assumes a TGLFreeForm as Owner, Added generic TVectorFile.LoadFromFile <li>26/05/00 - EG - Removed dependency to GLObjects, TGLFreeForm now may use InterleavedArrays instead of IndexedArrays (better BuildList compatibility) <li>22/04/00 - EG - Fixed Material handlings in TGLFreeForm, inverted CCW/CW convention for 3DS Release3 <li>11/04/00 - EG - Removed unnecessary code in finalization (thanks Uwe) <li>09/02/00 - EG - Creation from split of GLObjects, fixed class registrations and formats unregistration </ul></font>

GLVerletClasses GLVerletClasses<p>

Classes and functions that make integration between verlets and glscene objects easy.

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added VectorTypes to uses <li>13/04/04 - MF - Verlet call now uses TVerletProgressTimes <li>06/03/04 - MF - Creation </ul>

GLVerletClothify GLVerletClothify<p>

Methods for turning a TGLBaseMesh into a Verlet cloth / jelly<p>

<b>History : </b><font size=-1><ul> <li>16/09/10 - YP - Created public NodeList property of TFaceExtractor, it allow us to nail some vertex <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>06/06/10 - Yar - Fixed warnings <li>05/03/10 - DanB - More state added to TGLStateCache <li>22/02/10 - Yar - Optimization of switching states <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Added explicit pointer dereferencing (even more) <li>16/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>27/05/04 - MF - Added some length information to edges <li>24/06/03 - MF - Removed several embarrassing warnings <li>17/06/03 - MF - Creation </ul>

GLVerletSkeletonColliders GLVerletSkeletonColliders<p>

Skeleton colliders for defining and controlling verlet constraints.<p>

<b>History :</b><font size=-1><ul> <li>11/12/03 - SG - Now uses AddToVerletWorld to build the constraints. <li>08/10/03 - SG - Creation. </ul></font>

GLVfsPAK GLVfsPAK<p>

Support-code for loading files from Quake II PAK Files.<p> When instance is created all LoadFromFile methods using ApplicationFileIO mechanism will be pointed into PAK file.<p> You can change current PAK file by ActivePak variable.<p>

<b>History :</b><font size=-1><ul> <li>16/10/2008 - UweR - Compatibility fix for Delphi 2009 <li>31/03/2007 - DaStr - Added $I GLScene.inc <li>29/01/2007 - DaStr - Moved registration to GLSceneRegister.pas <li>26/10/2006 - LC - Fixed memory leak in TGLVfsPAK.LoadFromFile. Bugtracker ID=1585215 (thanks Da Stranger) <li>18/10/2004 - Orchestraman - PAKCreateFileStream, Fixed an error when trying to load an image file in material editor during design time. It Loads the file from the Hard Disk. <li>14/10/2004 - Orchestraman - PAKCreateFileStream, PAKFileStreamExists procedures redirect the streaming to hard disk if pack file does not exist. <li>04/10/2004 - Orchestraman - Fixed bug in LoadFromFile. The compressor object is created when the file is signed as compressed. <li>04/10/2004 - Orchestraman - Fixed bug in Constructor. The inherited constructor of TComponent didn't run when the component was created by the component pallete. <li>03/08/2004 - Orchestraman - Add LZRW1 compression. <li>19/04/04 - PSz - Creation </ul></font>

<b>Notes on Compression feature :</b><font size=-1><ul>

</ul></font>

GLViewer GLViewer<p>

Platform independant viewer.<p>

History: <li>13/06/12 - Yar - Bugfix synchronization control for Mac OS (thanks to pchev) <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>30/04/10 - Yar - Added vertical synchronization cntrol for Linux (by Rustam Asmandiarov aka Predato) <li>17/09/07 - DaStr - Replaced $IFNDEF KYLIX to $IFDEF MSWINDOWS in SetupVSync() because wgl* functions are Windows-specific <li>12/09/07 - DaStr - Fixed SetupVSync() function (Bugtracker ID = 1786279) Made cross-platform code easier to read <li>12/07/07 - DaStr - Added SetupVSync <li>30/03/07 - DaStr - Another update after the previous fix (removed class()) Added TVSyncMode type and constants. <li>24/03/07 - DaStr - Update for Windows after the previous fix <li>21/03/07 - DaStr - Improved Cross-Platform compatibility (thanks Burkhard Carstens) (Bugtracker ID = 1684432) <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTrackerID=1681585) <li>24/01/02 - EG - Initial version

GLWaterPlane GLWaterPlane<p>

A plane simulating animated water<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>30/03/07 - DaStr - Added $I GLScene.inc <li>22/09/04 - R.Cao - Added AxisAlignedDimensionsUnscaled to fix visibility culling <li>02/04/03 - EG - More optimizations, mask support <li>01/04/03 - EG - Cleanup and optimizations <li>14/11/03 - Mrqzzz - Tried "CreateRippleAtWorldPos" to work at any position/rotation, but need expert's help.. :( <li>13/11/03 - Mrqzzz - Tried to add timing indipendence (quite not precise yet) <li>12/11/03 - Mrqzzz - Added some properties & small optims added <li>01/01/03 - Sternas Stefanos - Original code </ul></font>

<p>The Original Code is part of Cosmos4D<br> http://users.hol.gr/˜sternas/<br> Sternas Stefanos 2003

GLWidgetContext GLWidgetContext<p>

Widget specific Context.<p> GLWidgetContext replaces old GLLinGTKContext.<p>

<b>History : </b><font size=-1><ul> <li>11/06/10 - Yar - Fixed uses section after lazarus-0.9.29.26033 release <li>02/05/10 - Yar - Fixes for Linux x64 <li>21/04/10 - Yar - Fixed conditions (by Rustam Asmandiarov aka Predator) <li>06/04/10 - Yar - Added to GLScene (Created by Rustam Asmandiarov aka Predator) </ul></font>

GLWin32Context GLWin32Context<p>

Win32 specific Context.<p>

<b>History : </b><font size=-1><ul> <li>11/09/11 - Yar - Added layers support (not tested because need Quadro or FireFX VGA) <li>18/07/11 - Yar - Added ability of creating OpenGL ES 2.0 profile context <li>03/12/10 - Yar - Fixed window tracking (thanks to Gabriel Corneanu) <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens. Improved context creation. <li>18/06/10 - Yar - Changed context sharing method for similarity to GLX <li>06/06/10 - Yar - Moved forward context creation to DoCreateContext make outputDevice HWND type <li>19/05/10 - Yar - Added choice between hardware and software acceleration <li>06/05/10 - Yar - Added vLastVendor clearing when multithreading is enabled <li>06/04/10 - Yar - Added DoGetHandles to TGLWin32Context (thanks Rustam Asmandiarov aka Predator) <li>28/03/10 - Yar - Added 3.3 forward context creation and eliminate memory leaks when multithreading <li>06/03/10 - Yar - Added forward context creation in TGLWin32Context.DoActivate <li>20/02/10 - DanB - Allow double-buffered memory viewers, if you want single buffered, or no swapping, then change buffer options instead. Some changes from Cardinal to the appropriate HDC /HGLRC type. <li>15/01/10 - DaStr - Bugfixed TGLWin32Context.ChooseWGLFormat() (BugtrackerID = 2933081) (thanks YarUndeoaker) <li>08/01/10 - DaStr - Added more AntiAliasing modes (thanks YarUndeoaker) <li>13/12/09 - DaStr - Modified for multithread support (thanks Controller) <li>30/08/09 - DanB - vIgnoreContextActivationFailures renamed to vContextActivationFailureOccurred + check removed. <li>06/11/07 - mrqzzz - Ignore ContextActivation failure if GLContext.vIgnoreContextActivationFailures=true <li>15/02/07 - DaStr - Integer -> Cardinal because $R- was removed in GLScene.pas <li>11/09/06 - NC - Added support for Multiple-Render-Target <li>03/10/04 - NC - Added float texture support <li>03/07/02 - EG - ChooseWGLFormat Kyro fix (Patrick Chevalley) <li>13/03/02 - EG - aaDefault now prefers non-AA when possible <li>03/03/02 - EG - Fixed aaNone mode (AA specifically off) <li>01/03/02 - EG - Fixed CurrentPixelFormatIsHardwareAccelerated <li>22/02/02 - EG - Unified ChooseWGLFormat for visual & non-visual <li>21/02/02 - EG - AntiAliasing support *experimental* (Chris N. Strahm) <li>05/02/02 - EG - Fixed UnTrackWindow <li>03/02/02 - EG - Added experimental Hook-based window tracking <li>29/01/02 - EG - Improved recovery for ICDs without pbuffer support <li>21/01/02 - EG - More graceful recovery for ICDs without pbuffer support <li>07/01/02 - EG - DoCreateMemoryContext now retrieved topDC when needed <li>15/12/01 - EG - Added support for AlphaBits <li>30/11/01 - EG - Hardware acceleration support now detected <li>20/11/01 - EG - New temp HWnd code for memory contexts (improved compat.) <li>04/09/01 - EG - Added ChangeIAttrib, support for 16bits depth buffer <li>25/08/01 - EG - Added pbuffer support and CreateMemoryContext interface <li>24/08/01 - EG - Fixed PropagateSharedContext <li>12/08/01 - EG - Handles management completed <li>22/07/01 - EG - Creation (glcontext.omm) </ul></font>

GLWin32Viewer GLWin32Viewer<p>

Win32 specific Scene viewer.<p>

<b>History : </b><font size=-1><ul> <li>03/02/13 - Yar - Added Touch Events (thanks to nelsonchu) <li>28/09/11 - YP - Added support for keyboard arrows via WM_GETDLGCODE <li>23/08/10 - Yar - Moved TVSyncMode to GLContext <li>22/12/09 - DaStr - Published TabStop, TabOrder, OnEnter, OnExit properties (thanks Yury Plashenkov) <li>10/11/09 - DaStr - Added Delphi 2010 OnGesture and Touch support <li>13/03/09 - DanB - Removed OpenGL dependencies <li>10/04/08 - DaStr - Bugfixed TGLSceneViewer.Notification() (thanks z80maniac) (Bugtracker ID = 1936108) <li>12/09/07 - DaStr - Removed old IFDEFs. Moved SetupVSync() to GLViewer.pas (Bugtracker ID = 1786279) <li>04/12/04 - DaStr - OnMouseWheel, OnMouseWheelDown, OnMouseWheelUp are now published in TGLSceneViewer <li>04/12/04 - MF - Added FieldOfView, formula by Ivan Sivak Jr. <li>24/07/03 - EG - FullScreen Viewer moved to GLWin32FullScreenViewer <li>11/06/03 - EG - Now uses ViewerBeforeChange to adjust VSync <li>29/10/02 - EG - Added MouseEnter/Leave/InControl <li>27/09/02 - EG - Added Ability to set display frequency <li>22/08/02 - EG - Added TGLSceneViewer.RecreateWnd <li>19/08/02 - EG - Added GetHandle <li>14/03/02 - EG - No longer invalidates while rendering <li>11/02/02 - EG - Fixed BeforeRender <li>29/01/02 - EG - New StayOnTop/Maximize logic (Richard Smuts) <li>22/01/02 - EG - Added TGLFullScreenViewer <li>28/12/01 - EG - Event persistence change (GliGli / Dephi bug) <li>12/12/01 - EG - Creation (split from GLScene.pas) </ul></font>

GLWindows GLWindows<p>

OpenGL windows management classes and structures<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records, renamed lowercase sender and accept to uppercase Sender and Accept <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>11/06/10 - YP - Link GUI elements to their parent <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>17/10/08 - DanB - reversed order of vertices in TGLCustomControl.InternalRender, which fixes the GUIPaint demo <li>27/04/08 - DaStr - Fixed bug in TGLButton.InternalRender() (thanks Nicoara Adrian) (BugtrackerID = 1952711) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>20/12/06 - DaStr - Added: TGLEdit.ReadOnly, TGLScrollbar.Locked, TGLStringGrid.ColSelect <li>10/11/05 - Mathx - Fixed TGLPopupMenu stack overflow on method internalRender. Related to bug 1193909. <li>24/05/02 - JAJ - Base Unit built on basis of Jan Horn's demo at (http://www.sulaco.co.za/opengl/windows.zip) <li>01/06/02 - JAJ - After not having received Jan Horn's blessing, the system have been revised all parts have been rewritten. <li>01/01/03 - JAJ - Updated so that focused controls pass focus on hide... <li>05/01/03 - JAJ - Cleaned up the DesignTime AccessViolations... <li>07/01/03 - JAJ - Jeremy Darling modified the TGLEdit's Render, more updates on TGLEdit expected... <li>18/01/03 - JAJ - Added TGLStringList, TGLScrollbar, TGLPopupMenu... <li>08/08/03 - PS - Added Horizontal to GLScrollbar... <li>14/08/03 - SG - Fixed TGLBaseComponent.SetGuiLayout (Joen Joensen) <li>08/08/03 - JAJ - Merged PS's and SG's update... Added TitleOffset... <li>03/07/04 - LR - Added constant for Keyboard (glKey_TAB, ...) Added function GLOKMessageBox to avoid the uses of Forms Replace TColor, TBitmap, TMouseEvent, TKeyEvent, ... by TGLColor, TGLBitmap, TGLMouseEvent, TGLKeyEvent, ... <li>25/01/05 - AX - Corrected AlphaChannel default value, must be 1 TGLButton, TGLForm - AlphaChannel behaviour text. Added events OnMouseEnter/OnMouseLeave for all controls <li>05/02/05 - AX - TGLLabel correct layout depending on Aligment and TextLayout. </ul></font>

GLWindowsFont GLWindowsFont<p>

TFont Import into a BitmapFont using variable width...<p>

<b>History : </b><font size=-1><ul> <li>29/05/11 - Yar - Unicode support for Unix OSes (by Gabriel Corneanu) <li>16/05/11 - Yar - Redesign to use multiple textures (by Gabriel Corneanu) <li>13/05/11 - Yar - Adapted to unicode (by Gabriel Corneanu) <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>06/06/10 - Yar - Added VectorTypes to uses <li>25/01/10 - Yar - Bugfix in LoadWindowsFont with zero width of char (thanks olkondr) Replace Char to AnsiChar <li>11/11/09 - DaStr - Added Delphi 2009 compatibility (thanks mal) <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTracekrID=1681585) <li>12/15/04 - Eugene Kryukov - Added TGLStoredBitmapFont <li>03/07/04 - LR - Added ifdef for Graphics uses <li>29/09/02 - EG - Fixed transparency, style fixes, prop defaults fixed, dropped interface dependency, texture size auto computed, fixed italics spacing, uses LUM+ALPHA texture <li>06/09/02 - JAJ - Fixed alot of bugs... Expecially designtime updating bugs.. <li>12/08/02 - JAJ - Made into a standalone unit... </ul></font>

GLzBuffer
GuiSkinEditorFormUnit GuiSkinEditorFormUnit<p>

Editor for Gui skin.<p>

<b>Historique : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>04/03/10 - DanB - Now uses CharInSet <li>05/10/08 - DanB - removed Kylix support, changed uses clause <li>07/06/08 - DaStr - Updated TGUISkinEditor.AddElement() to use SetPoint2D() (thanks Nicoara Adrian) <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>18/02/07 - DaStr - Fixed range check error. <li>22/02/05 - Mathx - Fixed Delphi 5 support. <li>16/12/05 - aidave - moved GUIComponentDialog in from GLGui.pas<br> <li>03/10/05 - adirex - XP styles and panels problem<br> <li>24/01/05 - adirex - Focus rect for selection<br> Huge editor enchancements. Too many to write them all :) <li>03/07/04 - LR - Make change for Linux <li>?/?/? - - Creation </ul></font>

GuiSkinEditorFormUnitLCL GuiSkinEditorFormUnit<p>

Editor for Gui skin.<p>

<b>Historique : </b><font size=-1><ul> <li>26/08/10 - Yar - Fixed ImageWndProc (thnaks Predator) </ul></font>

HDRImage HDRImage<p> Good for preview picture in OpenDialog, so you may include both HDRImage (preview) and GLFileHDR (loading)

<li>23/10/10 - Yar - Removed PBuffer <li>23/08/10 - Yar - Changes after PBuffer upgrade <li>21/03/10 - Yar - Added Linux support (thanks to Rustam Asmandiarov aka Predator) <li>24/01/10 - Yar - Improved FPC compatibility <li>21/01/10 - Yar - Creation </ul></font>

HeightTileFile HeightTileFile<p>

Access to large tiled height data files.<p>

Performance vs Raw file accesses (for perfect tile match):<ul> <li>Cached data:<ul> <li>"Smooth" terrain 1:2 to 1:10 <li>Random terrain 1:1 </ul> <li>Non-cached data:<ul> <li>"Smooth" terrain 1:100 to 1:1000 <li>Random terrain 1:100 </ul> </ul><p>

<b>Historique : </b><font size=-1><ul> <li>20/05/10 - Yar - Fixes for Linux x64 <li>30/03/07 - DaStr - Added $I GLScene.inc <li>21/12/01 - Egg - Creation </ul></font>

ImageUtils
Info
InfoLCL Informations on OpenGL driver.<p>

<b>History : </b><font size=-1><ul> <li>04/05/10 - Yar - Redecoration (thanks Conferno and Predator) </ul></font>

Joystick Joystick<p>

Component for handling joystick messages<p>

<b>Historique : </b><font size=-1><ul> <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTracekrID=1681585) <li>29/01/02 - Egg - Added NoCaptureErrors <li>18/12/00 - Egg - Fix for supporting 2 joysticks simultaneously <li>14/04/00 - Egg - Various minor to major fixes, the component should now work properly for the 4 first buttons and XY axis <li>20/03/00 - Egg - Creation from GLScene's TGLJoystick </ul></font>

LIBFREETYPE LIBFREETYPE<p>

<b>Historique : </b><font size=-1><ul> <li>21/01/11 - Yar - Creation </ul></font>

LIBPNG LIBPNG<p>

<b>Historique : </b><font size=-1><ul> <li>30/06/11 - DaStr - Fixed compiler crash for Delphi7 <li>16/02/11 - PREDATOR - Added support for Mac OS X. Tested on Mac OS X 10.6.5. <li>01/04/10 - Yar - Bugfix when Delphi not use optimization (thanks Lampogolovii) <li>15/03/10 - Yar - Fixed memory leak (thanks Lampogolovii) <li>05/03/10 - Yar - Creation </ul></font>

LWObjects
MeshUtils MeshUtils.<p>

General utilities for mesh manipulations.<p>

<b>History : </b><font size=-1><ul> <li>20/05/10 - Yar - Fixes for Linux x64 <li>26/02/10 - Yar - Added functions to work with adjacent triangles <li>30/03/07 - DaStr - Added $I GLScene.inc <li>29/07/03 - PVD - Fixed bug in RemapReferences limiting lists to 32768 items <li>29/07/03 - SG - Fixed small bug in ConvertStripToList (indexed vectors variant) <li>05/03/03 - EG - Added RemapIndicesToIndicesMap <li>20/01/03 - EG - Added UnifyTrianglesWinding <li>15/01/03 - EG - Added ConvertStripToList, ConvertIndexedListToList <li>13/01/03 - EG - Added InvertTrianglesWinding, BuildNonOrientedEdgesList, SubdivideTriangles <li>10/03/02 - EG - Added WeldVertices, RemapTrianglesIndices and IncreaseCoherency <li>04/11/01 - EG - Optimized RemapAndCleanupReferences and BuildNormals <li>02/11/01 - EG - BuildVectorCountOptimizedIndices three times faster, StripifyMesh slightly faster <li>18/08/01 - EG - Creation </ul></font>

NewtonImport
NewtonImport_JointLibrary
O3TCImage O3TCImage<p> Good for preview picture in OpenDialog, so you may include both O3TCImage (preview) and GLFileO3TC (loading)

<li>23/10/10 - Yar - Removed PBuffer <li>23/08/10 - Yar - Changes after PBuffer upgrade <li>21/03/10 - Yar - Added Linux support (thanks to Rustam Asmandiarov aka Predator) <li>24/01/10 - Yar - Improved FPC compatibility <li>21/01/10 - Yar - Creation </ul></font>

Octree
ODEGL
ODEImport
openal
OpenGL1x OpenGL1x<p>

OpenGL 1.x import unit for GLScene. Unit remains "general purpose", but with a more "pragmatic" approach :)<p>

This unit is based on OpenGL12.pas orginally written by Mike Lischke, please refer to OpenGL12.pas header.<p>

<b>History : </b><font size=-1><ul> <li>23/01/11 - DanB - Entry points now use procedural types from OpenGLTokens.pas Added OpenGL 4.1 + ARB extensions Switched to use GLS_REGIONS define <li>23/08/10 - Yar - Moved tokens part to OpenGLTokens.pas <li>22/07/10 - Yar - Added GL_ARB_debug_output constant <li>01/06/10 - Yar - Fixes for Linux x64 <li>31/05/10 - Yar - Added WGL_NV_gpu_affinity <li>12/05/10 - Yar - Added GL_ARB_texture_compression_bptc <li>04/05/10 - Yar - Added GL_S3_s3tc extension (thanks to Rustam Asmandiarov aka Predator) <li>01/05/10 - DanB - Fixed glGetTransformFeedbackVarying params <li>16/04/10 - Yar - Added Graphics Remedy's Extensions <li>28/03/10 - DanB - Added missing OpenGL 3.1/3.2 function lookups + added bindless graphics extensions <li>18/03/10 - Yar - Added more GLX extensions (thanks to Rustam Asmandiarov aka Predator) <li>12/03/10 - DanB - OpenGL 3.3/4.0 support (new ARB extensions), removed _ARB suffix from functions/procedures in GL_ARB_draw_buffers_blend + GL_ARB_sample_shading <li>04/03/10 - DanB - Organised core into relevant + deprecated sections, fixed a couple of function params + misc changes. <li>12/02/10 - Yar - Added GL_AMD_vertex_shader_tessellator <li>07/02/10 - Yar - Added GL_NV_primitive_restart <li>21/01/10 - DaStr - Bugfixed wglChoosePixelFormatARB() and wglCreatePbufferARB() parameters <li>07/01/10 - DaStr - Added WGL_COLOR_SAMPLES_NV (thanks YarUndeoaker) <li>25/12/09 - DaStr - Added GL_NV_copy_image, GL_LUMINANCE_INTEGER, GL_LUMINANCE_ALPHA_INTEGER extentions and constants Re-added $region declarations (thanks YarUndeoaker) <li>13/12/09 - DaStr - Added missing stdcall/cdecl modifiers <li>25/10/09 - DaStr - Added some texture compression extensions and updated glTransformFeedbackVaryings()(thanks YarUndeoaker) <li>28/09/09 - DaStr - Added some NVidia-specific extensions (thanks YarUndeoaker) <li>30/08/09 - DanB - GLsync changed to NativeInt, fixes to glBindBufferRange calls <li>14/08/09 - DanB - Added missing GL_ARB_framebuffer_object extension check + fixed typo <li>04/08/09 - DanB - OpenGL 3.1/3.2 support + new ARB extensions added <li>28/07/09 - DaStr - Added GL_GEOMETRY_PROGRAM_NV and related extensions <li>20/01/08 - DanB - Fix due to Delphi6 not containing UInt64 <li>05/10/08 - DanB - Moved error handling code here from GLContext.pas OpenGL 3.0 support, new core features + ARB extensions <li>23/03/08 - DanB - Added more Vendor/EXT extensions <li>17/03/08 - mrqzzz - uncommented some constants "GL_NORMAL_MAP_EXT,..." to keep compatibility with dws2OpenGL1x. <li>16/03/08 - DanB - Major rewrite of unit, including: OpenGL 1.3, 1.4, 1.5, 2.0, 2.1 support. removed TRCOptions (not used). moved MRT_BUFFERS constant to GLContext.pas (isn't core openGL). several new ARB extensions added. several new Vendor/EXT exensions added. new function IsOpenGLVersionMet added. restructured unit so extensions are in numerical order. <li>17/06/07 - LC - Added GL_ARB_pixel_buffer_object, GL_EXT_pixel_buffer_object <li>22/03/07 - DaStr - Removed GetTextureRectangle (had many useless checks) <li>16/03/07 - DaStr - Dropped Kylix support in favor of FPC (thanks Burkhard Carstens) (BugTracekrID=1681585) <li>09/03/07 - DaStr - Added GL_ARB_draw_buffers (thanks riz) <li>03/03/07 - DaStr - Added GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT <li>02/03/07 - DaStr - Added GL_[ARB/EXT]_texture_rectangle Added GetTextureRectangle <li>10/01/07 - LC - Added GL_EXT_framebuffer_object <li>11/09/06 - NC - Added GL_ARB_texture_float, GL_ARB_texture_non_power_of_two <li>13/10/04 - NC - Added GL_ATI_draw_buffers <li>08/10/04 - LR - Added const in the prototype of the following function for compatibility : TGLUTessCombineProc, TGLUTessCombineDataProc, gluPickMatrix gluProject, gluUnProject, gluTessVertex, gluLoadSamplingMatrices <li>04/10/04 - NC - Added GL_ATI_texture_float, WGL_ATI_pixel_format_float, WGL_NV_float_buffer, GL_NV_float_buffer <li>08/07/04 - LR - Change case for Linux <li>05/07/04 - LR - Corrections for Linux. Now glX function are directly load by external action (like for Windows). So i suppress the function LoadLinuxOpenGL. <li>28/06/04 - LR - Removed ..\ from the GLScene.inc <li>24/06/04 - SG - Added GL_ARB_fragment_program <li>17/05/04 - EG - Dropped EXT_vertex_array (assumed as standard) <li>06/04/04 - EG - Added GL_ARB_shader_objects, GL_ARB_vertex_shader and GL_ARB_fragment_shader, dropped a few oldies <li>13/02/04 - EG - Added GL_NV_texture_rectangle <li>18/11/03 - EG - Fixed binding of core extensions, added GL_ARB_depth_texture and GL_ARB_shadow support <li>20/09/03 - EG - Added GL_NV_occlusion_query, dropped some more oldies <li>09/09/03 - EG - Added GL_ARB_vertex_buffer_object, dropped some oldies <li>04/09/03 - EG - Added GL_ARB_vertex_program <li>23/07/03 - EG - Creation from OpenGL12.pas "morph": classic OpenGL calls made static, obsolete/rare extensions support dropped </ul></font>

OpenGLAdapter
OpenGLTokens OpenGLTokens<p>

<b>History : </b><font size=-1><ul> <li>17/12/12 - PW - Added CPP compatibility: changed PWGLSwap to PWGLswap to exclude ambiquity with 'Winapi::Windows::PWGLSwap' <li>21/08/11 - Yar - Added OpenGL ES <li>31/07/11 - Yar - Added types and constants for GL_NV_Path_rendering <li>23/01/11 - DanB - Added OpenGL procedural types, OpenGL 4.1 + ARB extensions <li>14/10/10 - Yar - Moved GLU types and constants from OpenGL1x <li>03/08/10 - Yar - Moved from OpenGL1x types and constants </ul></font>

PerlinNoise PerlinNoise.<p>

Classes and function for generation of PerlinNoise.<p>

<b>History : </b><font size=-1><ul> <li>31/08/10 - Bugfixed range error in TPerlin3DNoise.Initialize <li>30/03/07 - DaStr - Added $I GLScene.inc <li>14/04/04 - EG - Creation </ul></font>

Loosely based on Tom Nuydens's (www.delphi3d.com) Noise.pas unit, itself based on http://students.vassar.edu/mazucker/code/perlin-noise-math-faq.html Darwin Peachey's chapter in "Texturing & Modeling: A Procedural Approach" Further bugs are mine :)

PersistentClasses PersistentClasses<p>

Base persistence classes.<p>

These classes are used in GLScene, but are designed for generic purpose.<br> They implement a slightly different persistence mechanism than that of the VCL, allowing for object-level versioning (100% backward compatibility) and full polymorphic persistence.<p>

Internal Note: stripped down versions of XClasses & XLists.<p>

<b>History : </b><font size=-1><ul> <li>10/05/12 - Yar - Patched TBinaryReader.ReadFloat/WriteFloat for Win64 (thanks Massimo Zanoletti) In future need to replase extended floating point type! <li>06/12/10 - DaStr - Added GUID to IPersistentObject <li>19/08/10 - Yar - Fixed WriteWideString for empty strings <li>20/05/10 - Yar - Fixes for Linux x64 <li>07/11/09 - DaStr - Improved FPC compatibility (BugtrackerID = 2893580) <li>16/10/08 - UweR - Delphi 2009 compatibility fix for TPersistentObject, TTextReader and TTextWriter <li>16/10/08 - DanB - Delphi 2009 compatibility fix for TBinaryReader.ReadString / WriteString <li>10/04/08 - DaStr - Added classes TGLInterfacedPersistent and TGLInterfacedCollectionItem (BugTracker ID = 1938988) <li>11/02/08 - DaStr - Bugfixed TPersistentObjectList.Move() once again (BugTracker ID = 1857974) (thanks Yann PAPOUIN and Burkhard Carstens) <li>04/02/08 - DaStr - Bugfixed TPersistentObjectList.Move() (BugTracker ID = 1857974) <li>06/03/07 - DaStr - Added TGLOwnedPersistent <li>04/01/04 - EG - Fixed ReadString & ReadWideString for empty strings (thx Kenguru) <li>28/06/04 - LR - Removed ..\ from the GLScene.inc <li>08/12/03 - EG - TBinaryReader/Writer no longer rely on VCL TReader/TWriter <li>26/12/03 - EG - Added sorting support to TPersistentObjectList + misc. changes <li>04/09/03 - EG - Improved some TPersistentObjectList methods <li>12/02/03 - EG - Added IPersistentObject <li>09/09/01 - EG - Optimized Pack (x2.5) <li>14/08/01 - EG - Added AfterObjectCreatedByReader <li>03/08/01 - EG - Big update with addition of Virtual filers <li>24/07/01 - EG - D6-related changes <li>15/03/01 - EG - Creation </ul></font><p>

PictureRegisteredFormats PictureRegisteredFormats<p>

Hacks into the VCL to access the list of TPicture registered TGraphic formats<p>

<b>History : </b><font size=-1><ul> <li>19/06/11 - Yar - Improved for Lazarus (thanks to Johannes Pretorius, Bugtracker ID = 1586936) <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>19/09/10 - YP - Range check auto disabled in HackTPictureRegisteredFormats <li>31/05/10 - Yar - Fixes for Linux x64 <li>25/01/10 - DaStr - Updated warning about a possible crash while using the 'Use Debug DCUs' compiler option (BugTrackerID=1586936) <li>10/11/09 - DaStr - Replaced all Delphi2005+ IFDEFs with a single one <li>07/11/09 - DaStr - Improved FPC compatibility (BugtrackerID = 2893580) (thanks Predator) <li>16/10/08 - UweR - Added IFDEF for Delphi 2009 <li>06/04/08 - DanB - Change to HackTPictureRegisteredFormats due to Char changing size in Delphi 2009 <li>06/04/08 - DaStr - Added IFDEFs for Delphi 5 compatibility <li>20/12/06 - DaStr - Added a warning about optimization turned off in HackTPictureRegisteredFormats (BugTrackerID=1586936) <li>08/03/06 - ur - Added Delphi 2006 support <li>28/02/05 - EG - Added BPL support <li>24/02/05 - EG - Creation </ul></font>

PlugInIntf PlugInManagerPropEditor<p>

An interface unit to GLScene plug-ins.<p> For more information see help file for writing plug-ins.<p>

<b>History : </b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 PlugIn interface stays at PAnsiChar <li>02/04/07 - DaStr - Added $I GLScene.inc <li>28/07/01 - EG - Creation </ul></font>

PlugInManager
PlugInManagerPropEditor
Polynomials Polynomials.<p>

********* IN PROGRESS - LIMITED PRECISION **********

Utility functions for manipulationg and solving polynomials.<p>

Direct solving is supported for polynoms up to the 4th degree.<p>

Polynom solving code based on Jochen Schwarze (schwarze@isa.de) solver published in Graphics Gem (1990).<p>

Adapted to pascal by Eric Grange (egrange@glscene.org), if you find errors, they are probably mine. Note that contrary to the original code, the functions accept 'zero' values for any of the parameters.<br> I also made some changes for certain limit cases that (seemingly) weren't properly handled, these are marked by comments in the code.<p>

<b>History : </b><font size=-1><ul> <li>30/03/07 - DaStr - Added $I GLScene.inc <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>21/07/02 - EG - Added MinPositiveCoef <li>14/01/02 - EG - Switched to Jochen Schwarze's solver, droped complex stuff, added utility funcs <li>22/08/01 - EG - Some fixes, qtcrt still no up to what I expected <li>21/08/01 - EG - Creation </ul></font>

Q3BSP Q3BSP<p>

Simple Quake III BSP file loader.<p>

<b>History : </b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>30/01/03 - Egg - Creation, based on Philip Stefou's document and bits from Jan Horn's loader </ul></font>

Q3MD3 Q3MD3<p>

Helper classes and methods for Quake3 MD3 actors<p>

History : 14/04/03 - SG - Streamlined the TMD3TagList.LoadFromStream a little 04/04/03 - SG - Changes made to LoadQ3Skin procedure (as suggested by Mrqzzz) 03/04/03 - SG - Added LoadQ3Skin procedure 01/04/03 - Mrqzzz - "LEGS_" animations read from .CFG fixed 17/02/03 - SG - Creation

RegisterXCollection RegisterXCollection<p>

Register TXCollection property editor<p>

<b>History : </b><font size=-1><ul> <li>20/05/10 - Yar - Fixes for Linux x64 <li>11/11/09 - DaStr - Improved FPC compatibility (thanks Predator) (BugtrackerID = 2893580) <li>03/07/04 - LR - Removed ..\ from the GLScene.inc <li>16/04/00 - Egg - Creation </ul></font>

RGBE
ScreenSaver ScreenSaver<p>

Component for making screen-savers an easy task<p>

<b>History : </b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTracekrID=1681585) <li>09/07/01 - Egg - Fix in PreviewSaver (from Marco Dissel) <li>12/04/00 - Egg - Added ssoEnhancedMouseMoveDetection <li>11/04/00 - Egg - Creation </ul></font>

Parts of this code are based on DeskSpin sample by Tom Nuydens (http://www.gamedeveloper.org/delphi3d/).<p>

NB : The password stuff does NOT work under NT, dll references I found in Tom's sample simply did not exist under my NT4...

SpatialPartitioning
Spline Spline<p>

Cubic spline interpolation functions<p>

<b>History : </b><font size=-1><ul> <li>30/12/12 - PW - Restored CPP compatibility with record arrays <li>08/07/04 - LR - Removed ../ from the GLScene.inc <li>16/07/02 - Egg - Added methods to access slope per axis <li>28/05/00 - Egg - Javadocisation, minor changes & optimizations, Renamed TSpline to TCubicSpline, added W component and a bunch of helper methods <li>20/05/00 - RoC - Created, based on the C source code from Eric </ul></font>

TGA TGA<p>

Simple TGA formats supports for Delphi.<br> Currently supports only 24 and 32 bits RGB formats (uncompressed and RLE compressed).<p>

Based on David McDuffee's document from www.wotsit.org<p>

<b>History : </b><font size=-1><ul> <li>07/03/11 - Yar - Removed LazTGA, added workaround of ScanLine for Lazarus <li>20/04/10 - Yar - Removed registration for FPC (thanks to Rustam Asmandiarov aka Predator) <li>07/01/10 - DaStr - TTGAImage is now replaced by LazTGA.TTGAImage in Lazarus (thanks Predator) <li>08/07/04 - LR - Uses of Graphics replaced by GLCrossPlatform for Linux <li>21/11/02 - Egg - Creation </ul></font>

Types3DS
TypesB3D TypesB3D<p>

Types used on the B3D file loader<p>

<b>History :</b><font size=-1><ul> <li>22/12/05 - Mathx - Added to the GLScene Project. </ul></font>

TypesMD2
TypesMDC TypesMDC<p>

Types for Return to Castle Wolfenstein's MDC file format.<p>

Original code by Osman Turan (osmanturancom@yahoo.com)<p>

<b>History :</b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>18/12/04 - PhP - fixed constants, improve performance <li>11/05/04 - SG - Added to CVS <li>07/02/04 - OT - Creation (Osman Turan) </ul></font>

TypesMS3D TypesMS3D<p>

Types and structures for the MS3D file format.<p>

<b>Historique : </b><font size=-1><ul> <li>27/04/10 - Yar - Added more types (by TL) <li>24/07/09 - DaStr - TMS3DGroup.MaterialIndex is now Shortint (BugtrackerID = 2353633) <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>06/06/07 - DaStr - Added $I GLScene.inc Added GLColor to uses (BugtrackerID = 1732211) <li>31/08/03 - DanB - Some code standardisation (by Philipp) <li>16/06/03 - EG - Updated headers <li>10/03/03 - Matt - Creation </ul></font>

TypesSTL
uPSI_ApplicationFileIO
uPSI_GLStrings
uPSI_GLUtils
uPSI_PersistentClasses
uPSI_VectorGeometry
uPSI_VectorLists
uPSI_VectorTypes
uPSI_XCollection
Utils3DS Utils3DS<p>

Utility functions for the universal 3DS file reader and writer (TFile3DS). Essentially, the functions here are the heart of the import library as they deal actually with the database and chunks.

<b>History :</b><font size=-1><ul> <li>19/06/11 - Yar - Bugfixed undefined result of GetKFSegment (thanks to Johannes Pretorius, Bugtracker ID = 3319394) <li>12/06/10 - Yar - Fixes for Linux x64 <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>02/11/07 - DaStr - Fixed incorrect positioning when importing 3ds animation (Bugtracker ID = 1824372) Fixed memory leaks in the FreeChunkData() procedure (Bugtracker ID = 1823781) Added a standard GLScene header <li>30/03/07 - DaStr - Added $I GLScene.inc <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>09/03/07 - DaStr - Fixed a potential AV in two InitMeshObj procedures (thanks Burkhard Carstens) (BugtrackerID = 1678649) <li>27/10/06 - LC - Fixed memory leak in RelMeshObjField (Bugtracker ID = 1585639) <li>12/08/02 - EG - ReadMatEntryChunk fix / COLOR_F chunk (coerni) </ul></font>

(c) Copyright 1999, Dipl. Ing. Mike Lischke (public@lischke-online.de)

VectorGeometry VectorGeometry<p>

Base classes and structures for GLScene.<p>

Most common functions/procedures come in various flavours (using overloads), the naming convention is :<ul> <li>TypeOperation: functions returning a result, or accepting a "var" as last parameter to place result (VectorAdd, VectorCrossProduct...) <li>OperationType : procedures taking as first parameter a "var" that will be used as operand and result (AddVector, CombineVector...) </ul><p> As a general rule, procedures implementations (asm or not) are the fastest (up to 800% faster than function equivalents), due to reduced return value duplication overhead (the exception being the matrix operations).<p>

For better performance, it is recommended <b>not</b> to use the "Math" unit that comes with Delphi, and only use functions/procedures from this unit (the single-based functions have been optimized and are up to 100% faster, than extended-based ones from "Math").<p>

3DNow! SIMD instructions are automatically detected and used in *some* of the functions/procedures, typical gains (over FPU implementation) are approx a 100% speed increase on K6-2/3, and 20-60% on K7, and sometimes more (f.i. 650% on 4x4 matrix multiplication for the K6, 300% for RSqrt on K7).<p>

Cyrix, NexGen and other "exotic" CPUs may fault in the 3DNow! detection (initialization section), comment out or replace with your own detection routines if you want to support these. All AMD processors after K5, and all Intel processors after Pentium should be immune to this.<p>

<b>History : </b><font size=-1><ul>

<li>20/11/12 - PW - Added CPP compatibility using records instead arrays for vectors, moved IsPointInPolygon from GLGizmoEx; <li>05/06/12 - Maverick - Added SegmentPlaneIntersection routine <li>10/05/12 - Maverick - Added quad/disk intersection routines, c3PIdiv2 constant, some asm blocks <li>10/05/12 - Maverick - Added plane/triangle intersection routines, overloaded plane routines, linelinedistance routine <li>28/03/12 - Maverick - Added IsColinear test and Vector2d dot product <li>19/12/11 - Yar - Added VectorAdd for 2d vector (thanks microalexx)

<li>10/06/11 - DaStr - Added some Vector2f routines Overloaded some procedures to accept both 3f and 4f vectors Marked some methods as inline Added SignStrict, MoveObjectAround(), GetSafeTurnAngle(), RectanglesIntersect(), RectangleContains(), AngleBetweenVectors(), ShiftObjectFromCenter() <li>11/05/11 - Yar - Added ClampInteger <li>25/11/10 - DaStr - Added InterpolateExp() and itExp mode <li>04/11/10 - DaStr - Removed duplicate standard type definitions <li>09/08/10 - Yar - Added CreateLookAtMatrix, CreateMatrixFromFrustum, CreatePerspectiveMatrix, CreateOrthoMatrix, CreatePickMatrix, Project, UnProject <li>14/06/10 - Yar - Added VectorArrayLerp for TTexPointArray <li>06/06/10 - Yar - Fixed warnings for FPC <li>15/04/10 - Yar - Bugfixed vector normalization on Intel processors (thanks mif) (BugTracker ID = 2987779) <li>02/04/10 - Yar - Added inline directive for small vector operations <li>12/03/09 - DanB - Added overloaded versions of IsVolumeClipped <li>09/10/08 - DanB - moved TRenderContextClippingInfo + IsVolumeClipped functions that use TRenderContextClippingInfo to GLRenderContextInfo.pas <li>21/02/07 - DaStr - Bugfixed InterpolatePower() to support negative Base and not round Exponent parameters <li>12/02/08 - Mrqzzz - Removed cPIdiv360, not needed anymore, by Pete,Dan Bartlett <li>12/02/08 - Mrqzzz - Dave Gravel added const cPIdiv360 to fix ResetAndPitchTurnRoll <li>18/11/07 - DaStr - Added MatrixInvert(), VectorDivide() functions <li>19/09/07 - DaStr - Added AddPoint() and PointAdd() procedures <li>18/09/07 - DaStr - Added two more overloaded versions of VectorScale() <li>29/08/07 - LC - Fixed BarycentricCoordinates to work with triangles in yz plane <li>27/08/07 - DaStr - Bugfixed VectorAffineFltToDbl and VectorFltToDbl (thanks Biot!) (BugTracker ID = 1782005) <li>23/08/07 - LC - Added BarycentricCoordinates <li>16/04/07 - DaStr - Removed TMatrix[3/4][w/e] types (declared in VectorTypes.pas) <li>25/03/07 - DaStr - Replaced Types with GLCrossPlatform for Delphi 5 support Added YZHmgVector and XZHmgVector <li>21/03/07 - DaStr - Bugfixed MatrixDecompose (thanks Burkhard Carstens) (BugTrackerID=1684438) <li>06/03/07 - DaStr - Added InterpolateXXX and MatrixLerp functions <li>03/03/07 - DaStr - Added [Vector/Matrix/Rect]Equals, Vector[2/3/4][i/f/s/b/d]Make Added Vector[More/Less](Equal)Then <li>15/02/07 - DaStr - Returned to old code formating style <li>29/01/07 - DaStr - Added IntersectSphereBox (Thanks to dikoe Kenguru) <li>23/01/07 - fig - Added TexpointEquals() function <li>13/01/07 - DaStr - Added RayCastBoxIntersect and IntersectTriangleBox (Thanx to dikoe Kenguru) Deleted types that were duplicated (BugTrackerID = 1586318), some other types moved to VectorTypes unit <li>07/04/06 - DB - Fixed VectorArrayLerp_3DNow (affine) for n<=1 (dikoe Kenguru) <li>02/12/04 - MF - Added IsVolumeClipped overload that uses Frustum instead of rcci <li>02/08/04 - LR, YHC - BCB corrections: use record instead array move PAffineVectorArray, PVectorArray and PMatrixArray to VectorTypes Unit <li>08/07/04 - LR - Removed ../ from the GLScene.inc <li>26/10/03 - EG - Renamed from "Geometry.pas" to "VectorGeometry.pas" <li>17/10/03 - EG - Optimized Min/MaxInteger, some of the Min/MaxFloat <li>13/08/03 - SG - Added TQuaternionArray, PQuaternionArray and PQuaternion <li>21/07/03 - EG - Added RoundInt, faster Round/Round64, updated Power <li>04/07/03 - EG - New VectorCombine overload, some optimizations <li>18/06/03 - MF - Added PointSegmentClosestPoint, PointSegmentDistance, PointLineClosestPoint and PointLineDistance. <li>26/05/03 - EG - NO_ASM variant creation completed <li>22/05/03 - EG - All vSIMD asm tests should now be under GEOMETRY_NO_ASM control <li>20/05/03 - EG - Added MakeParallelProjectionMatrix <li>13/05/03 - EG - 3DNow! optimization for ClampValue <li>30/04/03 - EG - Hyperbolic trig functions (Aaron Hochwimmer) <li>14/02/03 - EG - Added ScaleAndRound <li>28/01/03 - EG - Affine matrix inversion and related functions (Dan Barlett) <li>29/10/02 - EG - New MinFloat overloads (Bob) <li>04/09/02 - EG - New Abs/Max functions, VectorTransform(affine, hmgMatrix) now considers the matrix as 4x3 (was 3x3) <li>21/08/02 - EG - Added Pack/UnPackRotationMatrix <li>13/08/02 - EG - Added Area functions <li>20/07/02 - EG - Fixed RayCastTriangleIntersect "backward" hits <li>05/07/02 - EG - Started adding non-asm variants (GEOMETRY_NO_ASM) <li>22/02/02 - EG - Temporary Quaternion fix for VectorAngleLerp <li>12/02/02 - EG - Added QuaternionFromEuler (Alex Grigny de Castro) <li>11/02/02 - EG - Non-spinned QuaternionSlerp (Alex Grigny de Castro) <li>07/02/02 - EG - Added AnglePreservingMatrixInvert <li>30/01/02 - EG - New Quaternion<->Matrix code (Alex Grigny de Castro) <li>29/01/02 - EG - Fixed AngleLerp, added DistanceBetweenAngles (Alex Grigny de Castro) <li>20/01/02 - EG - Added VectorArrayAdd, ScaleFloatArray, OffsetFloatArray <li>11/01/02 - EG - 3DNow Optim for VectorAdd (hmg) <li>10/01/02 - EG - Fixed VectorEquals ("True" wasn't Pascal compliant "1"), 3DNow optims for vector mormalizations (affine), Added RSqrt <li>04/01/02 - EG - Updated/fixed RayCastTriangleIntersect <li>13/12/01 - EG - Fixed MakeReflectionMatrix <li>02/11/01 - EG - Faster mode for PrepareSinCosCache (by Nelson Chu) <li>22/08/01 - EG - Some new overloads <li>19/08/01 - EG - Added sphere raycasting functions <li>08/08/01 - EG - Added MaxFloat overloads <li>24/07/01 - EG - VectorAngle renamed to VectorAngleCosine to avoid confusions <li>06/07/01 - EG - Added NormalizeDegAngle <li>04/07/01 - EG - Now uses VectorTypes <li>18/03/01 - EG - Added AngleLerp and NormalizeAngle <li>15/03/01 - EG - Added Int, Ceil and Floor, faster "Frac" <li>06/03/01 - EG - Fix in PointInPolygon by Pavel Vassiliev <li>04/03/01 - EG - Added NormalizeVectorArray <li>03/03/01 - EG - Added MakeReflectionMatrix <li>02/03/01 - EG - New PointInPolygon code by Pavel Vassiliev <li>25/02/01 - EG - Fixed 'VectorSubstract', added VectorArrayLerp and a few minors <li>22/02/01 - EG - Added MinXYZ/MaxXYZ variants and Plane-Line intersection <li>21/02/01 - EG - Added Sign, MinFloat & MaxFloat <li>15/02/01 - EG - Faster Vector Transforms (3DNow! optimizations) <li>14/02/01 - EG - Faster Matrix multiplications (3DNow! & FPU optimizations), Added support for FPU-only sections <li>05/02/01 - EG - Faster VectorEquals <li>21/01/01 - EG - Fixed MakePoint/Vector affine variants (thx Jacques Tur) <li>17/01/00 - EG - VectoAdd return type fix (thx Jacques Tur), also added a few new overloads <li>05/11/00 - EG - Added RayCastPlaneIntersect <li>08/10/00 - EG - Added SetMatrix <li>13/08/00 - EG - Added Plane geometry support <li>06/08/00 - EG - Various minor additions <li>16/07/00 - EG - Added some new mixed vector/scalar funcs and new overloads <li>12/07/00 - EG - New overloads and replacements for Power, Trunc, Frac & Round <li>25/06/00 - EG - End of major update <li>13/06/00 - EG - Start of major update <li>09/06/00 - EG - Some additions and fixes in preparation for major changes <li>05/06/00 - EG - Added VectorLength overloads <li>26/05/00 - EG - [0..0] arrays changed to [0..cMaxArray] <li>23/05/00 - EG - Added intersection functions, Replaced some xxxAffinexxx funcs with overloads <li>22/03/00 - EG - Added MakeShadowMatrix (adapted from "OpenGL SuperBible" book) <li>21/03/00 - EG - Removed PWordArray (was a SysUtils's duplicate) <li>06/02/00 - EG - Added VectorEquals <li>05/02/00 - EG - Added some "const", more still needed, Added overloads for some of the MakeXXXVector funcs, Added homogeneous vector consts, VectorSpacing </ul>

VectorLists VectorLists<p>

Misc. lists of vectors and entities<p>

<b>History : </b><font size=-1><ul> <li>23/02/11 - Yar - Added Revision mechanism to TAffineVectorList <li>15/12/10 - DaStr - Added Min() and Max() for TSingleList and TDoubleList <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>24/08/10 - Yar - Added to T4ByteList more overload of Add method <li>11/06/10 - Yar - Bugfixed binary reading TTexPointList for FPC <li>20/05/10 - Yar - Fixes for Linux x64 <li>27/02/10 - Yar - Added TLongWordList <li>06/02/10 - Yar - Added methods to TSingleList Added T4ByteList <li>25/11/09 - DanB - Fixed FastQuickSortLists for 64bit (thanks YarUnderoaker) ASM code protected with IFDEFs <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>01/03/08 - DaStr - Added Borland-style persistency support to TBaseList <li>29/03/07 - DaStr - Added more explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>25/01/07 - DaStr - Reformated code according to VCL standard Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>23/01/07 - fig - Added FindOrAdd() or IndexOf() to TTexpointList <li>16/01/07 - DaStr - Added TDoubleList <li>28/06/04 - LR - Removed ..\ from the GLScene.inc <li>03/09/03 - EG - Added TBaseList.Move, faster TIntegerList.Offset <li>22/08/03 - EG - Faster FastQuickSortLists <li>13/08/03 - SG - Added TQuaternionList <li>05/06/03 - EG - Added MinInteger, some TIntegerList optimizations <li>03/06/03 - EG - Added TIntegerList.BinarySearch and AddSorted (Mattias Fagerlund) <li>22/01/03 - EG - Added AddIntegers <li>20/01/03 - EG - Added TIntegerList.SortAndRemoveDuplicates <li>22/10/02 - EG - Added TransformXxxx to TAffineVectorList <li>04/07/02 - EG - Fixed TIntegerList.Add( 2 at once ) <li>15/06/02 - EG - Added TBaseListOption stuff <li>28/05/02 - EG - TBaseList.SetCount now properly resets new items <li>23/02/02 - EG - Added TBaseList.UseMemory <li>20/01/02 - EG - Now uses new funcs Add/ScaleVectorArray and VectorArrayAdd <li>06/12/01 - EG - Added Sort & MaxInteger to TIntegerList <li>04/12/01 - EG - Added TIntegerList.IndexOf <li>18/08/01 - EG - Fixed TAffineVectorList.Add (list) <li>03/08/01 - EG - Added TIntegerList.AddSerie <li>19/07/01 - EG - Added TAffineVectorList.Add (list variant) <li>18/03/01 - EG - Additions and enhancements <li>16/03/01 - EG - Introduced new PersistentClasses <li>04/03/01 - EG - Optimized TAffineVectorList.Normalize (x2 speed on K7) <li>26/02/01 - EG - VectorArrayLerp 3DNow optimized (x2 speed on K7) <li>08/08/00 - EG - Added TSingleList <li>20/07/00 - EG - Creation </ul></font>

VectorTypes VectorTypes<p>

Defines base vector types for use in Geometry.pas and OpenGL1x.pas.<p>

The sole aim of this unit is to limit dependency between the Geometry and OpenGL1x units by introducing the base compatibility types (and only the *base* types).<p>

Conventions:<ul> <li><b>d</b> is used for Double precision floating points values (64 bits) <li><b>f</b> is used for Single precision floating points values (32 bits) <li><b>i</b> is used for 32 bits signed integers (longint) <li><b>s</b> is uses for 16 bits signed integers (smallint) </ul>

Note : D3D types untested.<p>

<b>History : </b><font size=-1><ul> <li>18/12/12 - PW - Restored CPP compatibility: changed arrays to records <li>21/02/11 - Yar - Added half and signed byte vectors <li>03/03/07 - DaStr - Added TMatrix2[d/d/i/s/b/e/w/p] types <li>13/01/07 - DaStr - Added T[Matrix/Vector][2/3/4][e/w/p] types <li>19/12/04 - PhP - Added byte vectors <li>02/08/04 - LR, YHC - BCB corrections: use record instead array move PAffineVectorArray, PVectorArray and PMatrixArray from VectorGeometry to this Unit <li>28/06/04 - LR - Removed ..\ from the GLScene.inc <li>24/08/03 - PhP - Added smallint vectors <li>04/07/01 - EG - Creation </ul>

VerletClasses VerletClasses<p>

Base Verlet modelling/simulation classes.<p> This unit is generic, GLScene-specific sub-classes are in GLVerletClasses.<p>

Note that currently, the SatisfyConstraintForEdge methods push the nodes in the edge uniformly - it should push the closer node more for correct physics. It's a matter of leverage. <p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>25/11/09 - DanB - Fix for TVerletGlobalConstraint.TranslateKickbackTorque <li>31/03/07 - DaStr - Added $I GLScene.inc <li>14/04/04 - MF - Fixed force for springs, was referring to deltaP... <li>13/04/04 - MF - Minor drag changes <li>13/04/04 - EG - Added TVCHeightField and TVCSlider, fixed TVCFloor and TVFSpring, altered the way world Drag operates <li>06/03/04 - MF - Small updates to accomodate hair <li>11/07/03 - EG - Optimized TVCCube collider <li>11/07/03 - MF - A bit of a documentation effort <li>10/07/03 - MF - Verlets now use spatial partitioning objects to speed up space queries <li>10/07/03 - MF - Renaming TVerletAssembly to TVerletWorld <li>24/06/03 - MF - Added force kickbacks for integration with external physics. Needs to be split into force+torque and add friction to the kickback <li>19/06/03 - MF - Added TVerletGlobalConstraint.SatisfyConstraintForEdge and implemented for TVCSphere and TVCCapsule <li>19/06/03 - MF - Added friction to TVCCylinder <li>19/06/03 - MF - Added surface normals to all colliders - surface normal is identical to Normalize(Movement)! <li>18/06/03 - MF - Moved FrictionRatio to TVerletGlobalFrictionConstraint <li>18/06/03 - EG - Updated TVCCapsule <li>18/06/03 - MF - Updated TVCFloor to use a normal and a point <li>18/06/03 - MF - Added TVCCapsule <li>17/06/03 - MF - Added TVFAirResistance <li>17/06/03 - MF - Added TVCCube collider <li>16/06/03 - MF - Fixed TVFSpring.SetRestlengthToCurrent <li>24/07/02 - EG - Added TVCCylinder <li>18/07/02 - EG - Improved forces & constraints <li>23/06/02 - EG - Stricter encapsulation, fixed some leaks, Various optimizations (+25%) <li>21/06/02 - EG - Creation (original code by Mattias Fagerlund) </ul>

VerletHairClasses VerletHairClasses<p>

Creates a single strand of hair using verlet classes. Can be used to simulate ropes, fur or hair.<p>

<b>History : </b><font size=-1><ul> <li>29/05/08 - DaStr - Added $I GLScene.inc <li>06/03/04 - MF - Creation </ul>

VRMLParser VRMLParser<p>

VRML file format parser.<p>

<b>History :</b><font size=-1><ul> <li>02/04/07 - DaStr - Added $I GLScene.inc <li>29/03/07 - DaStr - Added missing parameters in procedure's implementation (thanks Burkhard Carstens) (Bugtracker ID = 1681409) <li>25/01/05 - SG - Added ShapeHints (creaseAngle), Normal and TexCoord support <li>14/01/05 - SG - Added to CVS </ul></font>

XCollection XCollection<p>

A polymorphism-enabled TCollection-like set of classes<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPPB compatibility: used dummy method instead abstract definition in class function FriendlyName for GLS_CPPB <li>20/01/11 - DanB - TXCollectionItem no longer sets initial Name = FriendlyName <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>31/08/10 - Yar - Bugfixed TXCollectionItem.ReadFromFiler when Assertion off <li>07/11/09 - DaStr - Added DEBUG_XCOLLECTION option <li>10/04/08 - DaStr - TXCollectionItem now descends from TGLInterfacedPersistent (BugTracker ID = 1938988) <li>08/12/04 - SG - Added TXCollectionItem.CanAddTo class function <li>02/08/04 - LR, YHC - BCB corrections: use record instead array Add dummy method for the abstract problem <li>03/07/04 - LR - Removed ..\ from the GLScene.inc <li>12/07/03 - DanB - Added (De)RegisterXCollectionDestroyEvent <li>19/06/03 - DanB - Added TXCollection.GetOrCreate <li>18/02/01 - EG - Fixed TXCollectionItem.Destroy (count decrementation) <li>02/02/01 - EG - CanAdd now virtual <li>09/06/00 - EG - Added GetByClass <li>23/05/00 - EG - Added "Loaded" mechanism <li>17/04/00 - EG - Optimized TXCollection.Assign <li>16/04/00 - EG - Creation from GLScene split </ul></font>

XOpenGL XOpenGL<p>

"Alternate" OpenGL functions to handle multi-texturing.<p>

Using this functions allows specifying none/one/multiple ARB multi-texture coordinates with standard texture specification call.<p>

Before using any of the xglTexCoordXxxx fonctions, call one of the xglMapTexCoordToXxxx functions to establish the redirectors.<p>

This unit is Open-Source under MPL<br> Copyright 2001 - Eric Grange (egrange@glscene.org)<br> http://glscene.org<p>

<b>History :</b><ul> <li>25/11/10 - Yar - Wrapped multitexturing in TGLMultitextureCoordinator class <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>29/03/10 - Yar - Replaced MULTITHREADOPENGL to GLS_MULTITHREAD (thanks Controler) <li>16/03/07 - DaStr - Dropped Kylix support in favor of FPC (thanks Burkhard Carstens) (BugTracekrID=1681585) <li>08/07/04 - LR - Removed ../ from the GLScene.inc <li>23/05/03 - EG - Support for arbitrary (complex) mappings <li>01/02/03 - EG - Added State stack <li>01/07/02 - EG - Added mtcmUndefined, fixed initial state <li>03/01/02 - EG - Added xglDisableClientState <li>26/01/02 - EG - Added xglBegin/EndUpdate mechanism <li>21/12/01 - EG - Fixed xglTexCoordPointer and xglEnableClientState <li>18/12/01 - EG - Added xglEnableClientState <li>24/08/01 - EG - Now supports MULTITHREADOPENGL (same as OpenGL1x) <li>17/08/01 - EG - Made declarations Kylix compatible (cdecl vs stdcall) <li>16/08/01 - EG - Renamed xglMapTextCoordMode to xglMapTexCoordMode <li>14/08/01 - EG - Added xglMapTexCoordToSecond <li>21/02/01 - EG - Added TexGen and vertex arrays mappings </ul>

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:47


GLScene v.1.1.2: AnimationUtils

Unit AnimationUtils

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Functions and Procedures

function Tweener(Current, Target: TAffineVector; Time, Duration: Single; EaseType: TEaseType): TAffineVector; overload;
function Tweener(Current, Target: TVector; Time, Duration: Single; EaseType: TEaseType): TVector; overload;
function Tweener(Current, Target: Single; Time, Duration: Single; EaseType: TEaseType): Single; overload;

Types

TEaseType = (...);

Description

Functions and Procedures

function Tweener(Current, Target: TAffineVector; Time, Duration: Single; EaseType: TEaseType): TAffineVector; overload;
function Tweener(Current, Target: TVector; Time, Duration: Single; EaseType: TEaseType): TVector; overload;
function Tweener(Current, Target: Single; Time, Duration: Single; EaseType: TEaseType): Single; overload;

Types

TEaseType = (...);
Values
  • etLinear:
  • etQuadIn:
  • etQuadOut:
  • etQuadInOut:
  • etQuadOutIn:
  • etCubicIn:
  • etCubicOut:
  • etCubicInOut:
  • etCubicOutIn:
  • etQuintIn:
  • etQuintOut:
  • etQuintInOut:
  • etQuintOutIn:
  • etSineIn:
  • etSineOut:
  • etSineInOut:
  • etSineOutIn:
  • etCircIn:
  • etCircOut:
  • etCircInOut:
  • etCircOutIn:
  • etExpoIn:
  • etExpoOut:
  • etExpoInOut:
  • etExpoOutIn:
  • etElasticIn:
  • etElasticOut:
  • etElasticInOut:
  • etElasticOutIn:
  • etBackIn:
  • etBackOut:
  • etBackInOut:
  • etBackOutIn:
  • etBounceIn:
  • etBounceOut:
  • etBounceInOut:
  • etBounceOutIn:
Generated by PasDoc 0.11.0 on 2013-02-10 19:36:58


GLScene v.1.1.2: ApplicationFileIO

Unit ApplicationFileIO

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

ApplicationFileIO<p>

Components and fonction that abstract file I/O access for an application.<br> Allows re-routing file reads to reads from a single archive file f.i.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPPB compatibility: used TAFIOFileStreamEvent as procedure instead of function for GLS_CPPB <li>25/08/10 - DaStr - Fixed compiler warnings <li>25/07/10 - Yar - Added TGLSResourceStream class and CreateResourceStream string <li>23/01/10 - Yar - Change LoadFromStream to dynamic <li>29/01/07 - DaStr - Moved registration to GLSceneRegister.pas <li>02/08/04 - LR, YHC - BCB corrections: fixed BCB Compiler error "E2370 Simple type name expected" <li>05/06/03 - EG - TDataFile moved in from GLMisc <li>31/01/03 - EG - Added FileExists mechanism <li>21/11/02 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TApplicationFileIO |
Class TDataFile |

Functions and Procedures

function ApplicationFileIODefined: Boolean;
function CreateFileStream(const fileName: string; mode: Word = fmOpenRead + fmShareDenyNone): TStream;
function FileStreamExists(const fileName: string): Boolean;
function CreateResourceStream(const ResName: string; ResType: PChar): TGLSResourceStream;
function StrToGLSResType(const AStrRes: string): TGLSApplicationResource;

Types

TGLSApplicationResource = (...);
TAFIOCreateFileStream = function(const fileName: string; mode: Word): TStream;
TAFIOFileStreamExists = function(const fileName: string): Boolean;
TAFIOFileStreamEvent = procedure (const fileName : String; mode : Word;var stream : TStream) of object;
TAFIOFileStreamExistsEvent = function(const fileName: string): Boolean of object;
TDataFileCapability = (...);
TDataFileCapabilities = set of TDataFileCapability;
TDataFileClass = class of TDataFile;
TGLSResourceStream = TLazarusResourceStream;

Constants

GLS_RC_DDS_Type = 'DDS';
GLS_RC_JPG_Type = 'JPG';
GLS_RC_XML_Type = 'XML';
GLS_RC_String_Type = 'STR';

Variables

vAFIOCreateFileStream: TAFIOCreateFileStream = nil;
vAFIOFileStreamExists: TAFIOFileStreamExists = nil;

Description

Functions and Procedures

function ApplicationFileIODefined: Boolean;

Returns true if an ApplicationFileIO has been defined

function CreateFileStream(const fileName: string; mode: Word = fmOpenRead + fmShareDenyNone): TStream;

Creates a file stream corresponding to the fileName.<p> If the file does not exists, an exception will be triggered.<br> Default mechanism creates a regular TFileStream, the 'mode' parameter is similar to the one for TFileStream.

function FileStreamExists(const fileName: string): Boolean;

Queries is a file stream corresponding to the fileName exists.<p>

function CreateResourceStream(const ResName: string; ResType: PChar): TGLSResourceStream;

Create a resource stream.

function StrToGLSResType(const AStrRes: string): TGLSApplicationResource;

Types

TGLSApplicationResource = (...);
Values
  • aresNone:
  • aresSplash:
  • aresTexture:
  • aresMaterial:
  • aresSampler:
  • aresFont:
  • aresMesh:
TAFIOCreateFileStream = function(const fileName: string; mode: Word): TStream;
TAFIOFileStreamExists = function(const fileName: string): Boolean;
TAFIOFileStreamEvent = procedure (const fileName : String; mode : Word;var stream : TStream) of object;
TAFIOFileStreamExistsEvent = function(const fileName: string): Boolean of object;
TDataFileCapability = (...);
Values
  • dfcRead:
  • dfcWrite:
TDataFileCapabilities = set of TDataFileCapability;
TDataFileClass = class of TDataFile;
TGLSResourceStream = TLazarusResourceStream;

Constants

GLS_RC_DDS_Type = 'DDS';
GLS_RC_JPG_Type = 'JPG';
GLS_RC_XML_Type = 'XML';
GLS_RC_String_Type = 'STR';

Variables

vAFIOCreateFileStream: TAFIOCreateFileStream = nil;
vAFIOFileStreamExists: TAFIOFileStreamExists = nil;
Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: ApplicationFileIO: Class TApplicationFileIO

Class TApplicationFileIO

Description Hierarchy Fields Methods Properties

Unit

ApplicationFileIO

Declaration

type TApplicationFileIO = class(TComponent)

Description

Allows specifying a custom behaviour for ApplicationFileIO's CreateFileStream.<p> The component should be considered a helper only, you can directly specify a function via the vAFIOCreateFileStream variable.<br> If multiple TApplicationFileIO components exist in the application, the last one created will be the active one.

Hierarchy

  • TComponent
  • TApplicationFileIO

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published | property OnFileStream: TAFIOFileStreamEvent read FOnFileStream write FOnFileStream;
Published | property OnFileStreamExists: TAFIOFileStreamExistsEvent read FOnFileStreamExists write FOnFileStreamExists;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;

Properties

Published property OnFileStream: TAFIOFileStreamEvent read FOnFileStream write FOnFileStream;

Event that allows you to specify a stream for the file.<p> Destruction of the stream is at the discretion of the code that invoked CreateFileStream. Return nil to let the default mechanism take place (ie. attempt a regular file system access).

Published property OnFileStreamExists: TAFIOFileStreamExistsEvent read FOnFileStreamExists write FOnFileStreamExists;

Event that allows you to specify if a stream for the file exists.<p>

Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: ApplicationFileIO: Class TDataFile

Class TDataFile

Unit

ApplicationFileIO

Declaration

type TDataFile = class(TGLUpdateAbleObject)

Description

Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; virtual;
Public | function CreateCopy(AOwner: TPersistent): TDataFile; dynamic;
Public | procedure Initialize; dynamic;
Public | procedure LoadFromFile(const fileName: string); dynamic;
Public | procedure LoadFromStream(stream: TStream); dynamic;
Public | procedure SaveToFile(const fileName: string); dynamic;
Public | procedure SaveToStream(stream: TStream); dynamic;

Properties

Public property ResourceName: string read FResourceName write SetResourceName;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; virtual;

Describes what the TDataFile is capable of.<p> Default value is [dfcRead].

Public function CreateCopy(AOwner: TPersistent): TDataFile; dynamic;

Duplicates Self and returns a copy.<p> Subclasses should override this method to duplicate their data.

Public procedure Initialize; dynamic;
Public procedure LoadFromFile(const fileName: string); dynamic;
Public procedure LoadFromStream(stream: TStream); dynamic;
Public procedure SaveToFile(const fileName: string); dynamic;
Public procedure SaveToStream(stream: TStream); dynamic;

Properties

Public property ResourceName: string read FResourceName write SetResourceName;

Optionnal resource name.<p> When using LoadFromFile/SaveToFile, the filename is placed in it, when using the Stream variants, the caller may place the resource name in it for parser use.

Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: AsyncTimer

Unit AsyncTimer

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TAsyncTimer |

Constants

cDEFAULT_TIMER_INTERVAL = 1000;

Description

Constants

cDEFAULT_TIMER_INTERVAL = 1000;
Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: AsyncTimer: Class TAsyncTimer

Class TAsyncTimer

Unit

AsyncTimer

Declaration

type TAsyncTimer = class(TComponent)

Description

Hierarchy

  • TComponent
  • TAsyncTimer

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function GetInterval: Word;
Protected | function GetThreadPriority: TThreadPriority;
Protected | procedure DoTimer;
Protected | procedure SetEnabled(Value: Boolean);
Protected | procedure SetInterval(Value: Word);
Protected | procedure SetThreadPriority(Value: TThreadPriority);

Properties

Published | property Enabled: Boolean read FEnabled write SetEnabled default False;
Published | property Interval: Word read GetInterval write SetInterval default cDEFAULT_TIMER_INTERVAL;
Published | property OnTimer: TNotifyEvent read FOnTimer write FOnTimer;
Published | property ThreadPriority: TThreadPriority read GetThreadPriority write SetThreadPriority default tpTimeCritical;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function GetInterval: Word;
Protected function GetThreadPriority: TThreadPriority;
Protected procedure DoTimer;
Protected procedure SetEnabled(Value: Boolean);
Protected procedure SetInterval(Value: Word);
Protected procedure SetThreadPriority(Value: TThreadPriority);

Properties

Published property Enabled: Boolean read FEnabled write SetEnabled default False;
Published property Interval: Word read GetInterval write SetInterval default cDEFAULT_TIMER_INTERVAL;
Published property OnTimer: TNotifyEvent read FOnTimer write FOnTimer;
Published property ThreadPriority: TThreadPriority read GetThreadPriority write SetThreadPriority default tpTimeCritical;
Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: BaseClasses

Unit BaseClasses

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Base classes for GLScene.<p>

<b>History : </b><font size=-1><ul> <li>24/03/11 - Yar - Added Notification method to TGLUpdateAbleObject <li>05/10/08 - DanB - Creation, from GLMisc.pas + other places </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TProgressTimes |
Interface IGLNotifyAble |
Interface IGLProgessAble |
Class TGLUpdateAbleObject |
Class TGLCadenceAbleComponent |
Class TGLUpdateAbleComponent |
Class TNotifyCollection |

Types

TGLProgressEvent = procedure(Sender: TObject; const deltaTime, newTime: Double) of object;

Description

Types

TGLProgressEvent = procedure(Sender: TObject; const deltaTime, newTime: Double) of object;

Progression event for time-base animations/simulations.<p> deltaTime is the time delta since last progress and newTime is the new time after the progress event is completed.

Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: BaseClasses: record TProgressTimes

record TProgressTimes

Unit

BaseClasses

Declaration

type TProgressTimes = record

Description

Overview

Fields

deltaTime: Double
newTime: Double

Description

Fields

deltaTime: Double
newTime: Double
Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: BaseClasses: Interface IGLNotifyAble

Interface IGLNotifyAble

Unit

BaseClasses

Declaration

type IGLNotifyAble = interface(IInterface)

Description

Hierarchy

  • IInterface
  • IGLNotifyAble

Overview

Methods

Public procedure NotifyChange(Sender: TObject);

Description

Methods

Public procedure NotifyChange(Sender: TObject);
Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: BaseClasses: Interface IGLProgessAble

Interface IGLProgessAble

Unit

BaseClasses

Declaration

type IGLProgessAble = interface(IInterface)

Description

Hierarchy

  • IInterface
  • IGLProgessAble

Overview

Methods

Public procedure DoProgress(const progressTime: TProgressTimes);

Description

Methods

Public procedure DoProgress(const progressTime: TProgressTimes);
Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: BaseClasses: Class TGLUpdateAbleObject

Class TGLUpdateAbleObject

Unit

BaseClasses

Declaration

type TGLUpdateAbleObject = class(TGLInterfacedPersistent, IGLNotifyAble)

Description

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject

Overview

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Public | function GetOwner: TPersistent; override;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure Notification(Sender: TObject; Operation: TOperation); virtual;
Public | procedure NotifyChange(Sender: TObject); virtual;

Properties

Public | property OnNotifyChange: TNotifyEvent read FOnNotifyChange write FOnNotifyChange;
Public | property Owner: TPersistent read FOwner;
Public | property Updating: Integer read FUpdating;

Description

Methods

Public constructor Create(AOwner: TPersistent); virtual;
Public function GetOwner: TPersistent; override;
Public procedure BeginUpdate;
Public procedure EndUpdate;
Public procedure Notification(Sender: TObject; Operation: TOperation); virtual;
Public procedure NotifyChange(Sender: TObject); virtual;

Properties

Public property OnNotifyChange: TNotifyEvent read FOnNotifyChange write FOnNotifyChange;
Public property Owner: TPersistent read FOwner;
Public property Updating: Integer read FUpdating;
Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: BaseClasses: Class TGLCadenceAbleComponent

Class TGLCadenceAbleComponent

Unit

BaseClasses

Declaration

type TGLCadenceAbleComponent = class(TGLComponent, IGLProgessAble)

Description

A base class describing the "cadenceing" interface.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent

Overview

Methods

Public procedure DoProgress(const progressTime: TProgressTimes); virtual;

Description

Methods

Public procedure DoProgress(const progressTime: TProgressTimes); virtual;
Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: BaseClasses: Class TGLUpdateAbleComponent

Class TGLUpdateAbleComponent

Unit

BaseClasses

Declaration

type TGLUpdateAbleComponent = class(TGLCadenceAbleComponent, IGLNotifyAble)

Description

A base class describing the "update" interface.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent

Overview

Methods

Public procedure NotifyChange(Sender: TObject); virtual;

Description

Methods

Public procedure NotifyChange(Sender: TObject); virtual;
Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: BaseClasses: Class TNotifyCollection

Class TNotifyCollection

Unit

BaseClasses

Declaration

type TNotifyCollection = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TNotifyCollection

Overview

Methods

Public | constructor Create(AOwner: TPersistent; AItemClass: TCollectionItemClass);
Protected | procedure Update(item: TCollectionItem); override;

Properties

Public property OnNotifyChange: TNotifyEvent read FOnNotifyChange write FOnNotifyChange;

Description

Methods

Public constructor Create(AOwner: TPersistent; AItemClass: TCollectionItemClass);
Protected procedure Update(item: TCollectionItem); override;

Properties

Public property OnNotifyChange: TNotifyEvent read FOnNotifyChange write FOnNotifyChange;
Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: Bass

Unit Bass

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record BASS_INFO |
record BASS_RECORDINFO |
record BASS_CHANNELINFO |
record BASS_PLUGINFORM |
record BASS_PLUGININFO |
record BASS_SAMPLE |
record BASS_3DVECTOR |
record BASS_FXCHORUS |
record BASS_FXCOMPRESSOR |
record BASS_FXDISTORTION |
record BASS_FXECHO |
record BASS_FXFLANGER |
record BASS_FXGARGLE |
record BASS_FXI3DL2REVERB |
record BASS_FXPARAMEQ |
record BASS_FXREVERB |

Functions and Procedures

function BASS_SPEAKER_N(n: DWORD): DWORD;
function MAKEMUSICPOS(order,row: DWORD): DWORD;
function BASS_SetEAXPreset(env: Integer): BOOL;
function BASS_Load(LibName: PChar ): Boolean;
procedure BASS_UnLoad;
Function BASS_IsLoaded:boolean;

Types

DWORD = cardinal;
BOOL = LongBool;
FLOAT = Single;
QWORD = int64;
HMUSIC = DWORD;
HSAMPLE = DWORD;
HCHANNEL = DWORD;
HSTREAM = DWORD;
HRECORD = DWORD;
HSYNC = DWORD;
HDSP = DWORD;
HFX = DWORD;
HPLUGIN = DWORD;
PBASS_PLUGINFORMS = ˆTBASS_PLUGINFORMS;
TBASS_PLUGINFORMS = array[0..maxInt div sizeOf(BASS_PLUGINFORM) - 1] of BASS_PLUGINFORM;
PBASS_PLUGININFO = ˆBASS_PLUGININFO;
STREAMPROC = function(handle: HSTREAM; buffer: Pointer; length: DWORD; user: DWORD): DWORD; stdcall;
STREAMFILEPROC = function(action, param1, param2, user: DWORD): DWORD; stdcall;
DOWNLOADPROC = procedure(buffer: Pointer; length: DWORD; user: DWORD); stdcall;
SYNCPROC = procedure(handle: HSYNC; channel, data: DWORD; user: DWORD); stdcall;
DSPPROC = procedure(handle: HDSP; channel: DWORD; buffer: Pointer; length: DWORD; user: DWORD); stdcall;
RECORDPROC = function(handle: HRECORD; buffer: Pointer; length: DWORD; user: DWORD): BOOL; stdcall;
TBASSModuleHandle = HINST;

Constants

BASSVERSION = $203;
BASS_DLL = 'bass.dll';
DW_ERROR = Cardinal(-1);
QW_ERROR = Int64(-1);
BASS_OK = 0;
BASS_ERROR_MEM = 1;
BASS_ERROR_FILEOPEN = 2;
BASS_ERROR_DRIVER = 3;
BASS_ERROR_BUFLOST = 4;
BASS_ERROR_HANDLE = 5;
BASS_ERROR_FORMAT = 6;
BASS_ERROR_POSITION = 7;
BASS_ERROR_INIT = 8;
BASS_ERROR_START = 9;
BASS_ERROR_ALREADY = 14;
BASS_ERROR_NOPAUSE = 16;
BASS_ERROR_NOCHAN = 18;
BASS_ERROR_ILLTYPE = 19;
BASS_ERROR_ILLPARAM = 20;
BASS_ERROR_NO3D = 21;
BASS_ERROR_NOEAX = 22;
BASS_ERROR_DEVICE = 23;
BASS_ERROR_NOPLAY = 24;
BASS_ERROR_FREQ = 25;
BASS_ERROR_NOTFILE = 27;
BASS_ERROR_NOHW = 29;
BASS_ERROR_EMPTY = 31;
BASS_ERROR_NONET = 32;
BASS_ERROR_CREATE = 33;
BASS_ERROR_NOFX = 34;
BASS_ERROR_PLAYING = 35;
BASS_ERROR_NOTAVAIL = 37;
BASS_ERROR_DECODE = 38;
BASS_ERROR_DX = 39;
BASS_ERROR_TIMEOUT = 40;
BASS_ERROR_FILEFORM = 41;
BASS_ERROR_SPEAKER = 42;
BASS_ERROR_VERSION = 43;
BASS_ERROR_CODEC = 44;
BASS_ERROR_UNKNOWN = -1;
BASS_DEVICE_8BITS = 1;
BASS_DEVICE_MONO = 2;
BASS_DEVICE_3D = 4;
BASS_DEVICE_LATENCY = 256;
BASS_DEVICE_SPEAKERS = 2048;
BASS_DEVICE_NOSPEAKER = 4096;
BASS_OBJECT_DS = 1;
BASS_OBJECT_DS3DL = 2;
DSCAPS_CONTINUOUSRATE = $00000010;
DSCAPS_EMULDRIVER = $00000020;
DSCAPS_CERTIFIED = $00000040;
DSCAPS_SECONDARYMONO = $00000100;
DSCAPS_SECONDARYSTEREO = $00000200;
DSCAPS_SECONDARY8BIT = $00000400;
DSCAPS_SECONDARY16BIT = $00000800;
DSCCAPS_EMULDRIVER = DSCAPS_EMULDRIVER;
DSCCAPS_CERTIFIED = DSCAPS_CERTIFIED;
WAVE_FORMAT_1M08 = $00000001;
WAVE_FORMAT_1S08 = $00000002;
WAVE_FORMAT_1M16 = $00000004;
WAVE_FORMAT_1S16 = $00000008;
WAVE_FORMAT_2M08 = $00000010;
WAVE_FORMAT_2S08 = $00000020;
WAVE_FORMAT_2M16 = $00000040;
WAVE_FORMAT_2S16 = $00000080;
WAVE_FORMAT_4M08 = $00000100;
WAVE_FORMAT_4S08 = $00000200;
WAVE_FORMAT_4M16 = $00000400;
WAVE_FORMAT_4S16 = $00000800;
BASS_SAMPLE_8BITS = 1;
BASS_SAMPLE_FLOAT = 256;
BASS_SAMPLE_MONO = 2;
BASS_SAMPLE_LOOP = 4;
BASS_SAMPLE_3D = 8;
BASS_SAMPLE_SOFTWARE = 16;
BASS_SAMPLE_MUTEMAX = 32;
BASS_SAMPLE_VAM = 64;
BASS_SAMPLE_FX = 128;
BASS_SAMPLE_OVER_VOL = $10000;
BASS_SAMPLE_OVER_POS = $20000;
BASS_SAMPLE_OVER_DIST = $30000;
BASS_STREAM_PRESCAN = $20000;
BASS_MP3_SETPOS = BASS_STREAM_PRESCAN;
BASS_STREAM_AUTOFREE = $40000;
BASS_STREAM_RESTRATE = $80000;
BASS_STREAM_BLOCK = $100000;
BASS_STREAM_DECODE = $200000;
BASS_STREAM_STATUS = $800000;
BASS_MUSIC_FLOAT = BASS_SAMPLE_FLOAT;
BASS_MUSIC_MONO = BASS_SAMPLE_MONO;
BASS_MUSIC_LOOP = BASS_SAMPLE_LOOP;
BASS_MUSIC_3D = BASS_SAMPLE_3D;
BASS_MUSIC_FX = BASS_SAMPLE_FX;
BASS_MUSIC_AUTOFREE = BASS_STREAM_AUTOFREE;
BASS_MUSIC_DECODE = BASS_STREAM_DECODE;
BASS_MUSIC_PRESCAN = BASS_STREAM_PRESCAN;
BASS_MUSIC_CALCLEN = BASS_MUSIC_PRESCAN;
BASS_MUSIC_RAMP = $200;
BASS_MUSIC_RAMPS = $400;
BASS_MUSIC_SURROUND = $800;
BASS_MUSIC_SURROUND2 = $1000;
BASS_MUSIC_FT2MOD = $2000;
BASS_MUSIC_PT1MOD = $4000;
BASS_MUSIC_NONINTER = $10000;
BASS_MUSIC_POSRESET = $8000;
BASS_MUSIC_POSRESETEX = $400000;
BASS_MUSIC_STOPBACK = $80000;
BASS_MUSIC_NOSAMPLE = $100000;
BASS_SPEAKER_FRONT = $1000000;
BASS_SPEAKER_REAR = $2000000;
BASS_SPEAKER_CENLFE = $3000000;
BASS_SPEAKER_REAR2 = $4000000;
BASS_SPEAKER_LEFT = $10000000;
BASS_SPEAKER_RIGHT = $20000000;
BASS_SPEAKER_FRONTLEFT = BASS_SPEAKER_FRONT or BASS_SPEAKER_LEFT;
BASS_SPEAKER_FRONTRIGHT = BASS_SPEAKER_FRONT or BASS_SPEAKER_RIGHT;
BASS_SPEAKER_REARLEFT = BASS_SPEAKER_REAR or BASS_SPEAKER_LEFT;
BASS_SPEAKER_REARRIGHT = BASS_SPEAKER_REAR or BASS_SPEAKER_RIGHT;
BASS_SPEAKER_CENTER = BASS_SPEAKER_CENLFE or BASS_SPEAKER_LEFT;
BASS_SPEAKER_LFE = BASS_SPEAKER_CENLFE or BASS_SPEAKER_RIGHT;
BASS_SPEAKER_REAR2LEFT = BASS_SPEAKER_REAR2 or BASS_SPEAKER_LEFT;
BASS_SPEAKER_REAR2RIGHT = BASS_SPEAKER_REAR2 or BASS_SPEAKER_RIGHT;
BASS_UNICODE = $80000000;
BASS_RECORD_PAUSE = $8000;
BASS_VAM_HARDWARE = 1;
BASS_VAM_SOFTWARE = 2;
BASS_VAM_TERM_TIME = 4;
BASS_VAM_TERM_DIST = 8;
BASS_VAM_TERM_PRIO = 16;
BASS_CTYPE_SAMPLE = 1;
BASS_CTYPE_RECORD = 2;
BASS_CTYPE_STREAM = $10000;
BASS_CTYPE_STREAM_OGG = $10002;
BASS_CTYPE_STREAM_MP1 = $10003;
BASS_CTYPE_STREAM_MP2 = $10004;
BASS_CTYPE_STREAM_MP3 = $10005;
BASS_CTYPE_STREAM_AIFF = $10006;
BASS_CTYPE_STREAM_WAV = $40000;
BASS_CTYPE_STREAM_WAV_PCM = $50001;
BASS_CTYPE_STREAM_WAV_FLOAT = $50003;
BASS_CTYPE_MUSIC_MOD = $20000;
BASS_CTYPE_MUSIC_MTM = $20001;
BASS_CTYPE_MUSIC_S3M = $20002;
BASS_CTYPE_MUSIC_XM = $20003;
BASS_CTYPE_MUSIC_IT = $20004;
BASS_CTYPE_MUSIC_MO3 = $00100;
BASS_3DMODE_NORMAL = 0;
BASS_3DMODE_RELATIVE = 1;
BASS_3DMODE_OFF = 2;
EAX_ENVIRONMENT_GENERIC = 0;
EAX_ENVIRONMENT_PADDEDCELL = 1;
EAX_ENVIRONMENT_ROOM = 2;
EAX_ENVIRONMENT_BATHROOM = 3;
EAX_ENVIRONMENT_LIVINGROOM = 4;
EAX_ENVIRONMENT_STONEROOM = 5;
EAX_ENVIRONMENT_AUDITORIUM = 6;
EAX_ENVIRONMENT_CONCERTHALL = 7;
EAX_ENVIRONMENT_CAVE = 8;
EAX_ENVIRONMENT_ARENA = 9;
EAX_ENVIRONMENT_HANGAR = 10;
EAX_ENVIRONMENT_CARPETEDHALLWAY = 11;
EAX_ENVIRONMENT_HALLWAY = 12;
EAX_ENVIRONMENT_STONECORRIDOR = 13;
EAX_ENVIRONMENT_ALLEY = 14;
EAX_ENVIRONMENT_FOREST = 15;
EAX_ENVIRONMENT_CITY = 16;
EAX_ENVIRONMENT_MOUNTAINS = 17;
EAX_ENVIRONMENT_QUARRY = 18;
EAX_ENVIRONMENT_PLAIN = 19;
EAX_ENVIRONMENT_PARKINGLOT = 20;
EAX_ENVIRONMENT_SEWERPIPE = 21;
EAX_ENVIRONMENT_UNDERWATER = 22;
EAX_ENVIRONMENT_DRUGGED = 23;
EAX_ENVIRONMENT_DIZZY = 24;
EAX_ENVIRONMENT_PSYCHOTIC = 25;
EAX_ENVIRONMENT_COUNT = 26;
BASS_3DALG_DEFAULT = 0;
BASS_3DALG_OFF = 1;
BASS_3DALG_FULL = 2;
BASS_3DALG_LIGHT = 3;
BASS_SYNC_POS = 0;
BASS_SYNC_END = 2;
BASS_SYNC_META = 4;
BASS_SYNC_SLIDE = 5;
BASS_SYNC_STALL = 6;
BASS_SYNC_DOWNLOAD = 7;
BASS_SYNC_FREE = 8;
BASS_SYNC_SETPOS = 11;
BASS_SYNC_MUSICPOS = 10;
BASS_SYNC_MUSICINST = 1;
BASS_SYNC_MUSICFX = 3;
BASS_SYNC_MESSAGE = $20000000;
BASS_SYNC_MIXTIME = $40000000;
BASS_SYNC_ONETIME = $80000000;
BASS_ACTIVE_STOPPED = 0;
BASS_ACTIVE_PLAYING = 1;
BASS_ACTIVE_STALLED = 2;
BASS_ACTIVE_PAUSED = 3;
BASS_SLIDE_FREQ = 1;
BASS_SLIDE_VOL = 2;
BASS_SLIDE_PAN = 4;
BASS_DATA_AVAILABLE = 0;
BASS_DATA_FLOAT = $40000000;
BASS_DATA_FFT512 = $80000000;
BASS_DATA_FFT1024 = $80000001;
BASS_DATA_FFT2048 = $80000002;
BASS_DATA_FFT4096 = $80000003;
BASS_DATA_FFT8192 = $80000004;
BASS_DATA_FFT_INDIVIDUAL = $10;
BASS_DATA_FFT_NOWINDOW = $20;
BASS_TAG_ID3 = 0;
BASS_TAG_ID3V2 = 1;
BASS_TAG_OGG = 2;
BASS_TAG_HTTP = 3;
BASS_TAG_ICY = 4;
BASS_TAG_META = 5;
BASS_TAG_VENDOR = 9;
BASS_TAG_LYRICS3 = 10;
BASS_TAG_RIFF_INFO = $100;
BASS_TAG_MUSIC_NAME = $10000;
BASS_TAG_MUSIC_MESSAGE = $10001;
BASS_TAG_MUSIC_INST = $10100;
BASS_TAG_MUSIC_SAMPLE = $10300;
BASS_FX_CHORUS = 0;
BASS_FX_COMPRESSOR = 1;
BASS_FX_DISTORTION = 2;
BASS_FX_ECHO = 3;
BASS_FX_FLANGER = 4;
BASS_FX_GARGLE = 5;
BASS_FX_I3DL2REVERB = 6;
BASS_FX_PARAMEQ = 7;
BASS_FX_REVERB = 8;
BASS_FX_PHASE_NEG_180 = 0;
BASS_FX_PHASE_NEG_90 = 1;
BASS_FX_PHASE_ZERO = 2;
BASS_FX_PHASE_90 = 3;
BASS_FX_PHASE_180 = 4;
BASS_INPUT_OFF = $10000;
BASS_INPUT_ON = $20000;
BASS_INPUT_LEVEL = $40000;
BASS_INPUT_TYPE_MASK = $ff000000;
BASS_INPUT_TYPE_UNDEF = $00000000;
BASS_INPUT_TYPE_DIGITAL = $01000000;
BASS_INPUT_TYPE_LINE = $02000000;
BASS_INPUT_TYPE_MIC = $03000000;
BASS_INPUT_TYPE_SYNTH = $04000000;
BASS_INPUT_TYPE_CD = $05000000;
BASS_INPUT_TYPE_PHONE = $06000000;
BASS_INPUT_TYPE_SPEAKER = $07000000;
BASS_INPUT_TYPE_WAVE = $08000000;
BASS_INPUT_TYPE_AUX = $09000000;
BASS_INPUT_TYPE_ANALOG = $0a000000;
BASS_NET_TIMEOUT = 0;
BASS_NET_BUFFER = 1;
BASS_FILEPOS_CURRENT = 0;
BASS_FILEPOS_DECODE = BASS_FILEPOS_CURRENT;
BASS_FILEPOS_DOWNLOAD = 1;
BASS_FILEPOS_END = 2;
BASS_FILEPOS_START = 3;
BASS_FILEPOS_CONNECTED = 4;
BASS_FILE_CLOSE = 0;
BASS_FILE_READ = 1;
BASS_FILE_LEN = 3;
BASS_FILE_SEEK = 4;
BASS_STREAMPROC_END = $80000000;
BASS_MUSIC_ATTRIB_AMPLIFY = 0;
BASS_MUSIC_ATTRIB_PANSEP = 1;
BASS_MUSIC_ATTRIB_PSCALER = 2;
BASS_MUSIC_ATTRIB_BPM = 3;
BASS_MUSIC_ATTRIB_SPEED = 4;
BASS_MUSIC_ATTRIB_VOL_GLOBAL = 5;
BASS_MUSIC_ATTRIB_VOL_CHAN = $100;
BASS_MUSIC_ATTRIB_VOL_INST = $200;
BASS_CONFIG_BUFFER = 0;
BASS_CONFIG_UPDATEPERIOD = 1;
BASS_CONFIG_MAXVOL = 3;
BASS_CONFIG_GVOL_SAMPLE = 4;
BASS_CONFIG_GVOL_STREAM = 5;
BASS_CONFIG_GVOL_MUSIC = 6;
BASS_CONFIG_CURVE_VOL = 7;
BASS_CONFIG_CURVE_PAN = 8;
BASS_CONFIG_FLOATDSP = 9;
BASS_CONFIG_3DALGORITHM = 10;
BASS_CONFIG_NET_TIMEOUT = 11;
BASS_CONFIG_NET_BUFFER = 12;
BASS_CONFIG_PAUSE_NOPLAY = 13;
BASS_CONFIG_NET_PREBUF = 15;
BASS_CONFIG_NET_AGENT = 16;
BASS_CONFIG_NET_PROXY = 17;
BASS_CONFIG_NET_PASSIVE = 18;
BASS_CONFIG_REC_BUFFER = 19;
BASS_CONFIG_NET_PLAYLIST = 21;
BASS_CONFIG_MUSIC_VIRTUAL = 22;

Variables

BASS_SetConfig: function(option, value: DWORD): DWORD; stdcall;
BASS_GetConfig: function(option: DWORD): DWORD; stdcall;
BASS_GetVersion: function(): DWORD; stdcall;
BASS_GetDeviceDescription: function(device: DWORD): PAnsiChar; stdcall;
BASS_ErrorGetCode: function(): Integer; stdcall;
BASS_Init: function(device: Integer; freq, flags: DWORD; win: HWND; clsid: PGUID): BOOL; stdcall;
BASS_SetDevice: function(device: DWORD): BOOL; stdcall;
BASS_GetDevice: function(): DWORD; stdcall;
BASS_Free: function(): BOOL; stdcall;
BASS_GetDSoundObject: function(obj: DWORD): Pointer; stdcall;
BASS_GetInfo: function(var info: BASS_INFO): BOOL; stdcall;
BASS_Update: function(): BOOL; stdcall;
BASS_GetCPU: function(): FLOAT; stdcall;
BASS_Start: function(): BOOL; stdcall;
BASS_Stop: function(): BOOL; stdcall;
BASS_Pause: function(): BOOL; stdcall;
BASS_SetVolume: function(volume: DWORD): BOOL; stdcall;
BASS_GetVolume: function(): Integer; stdcall;
BASS_PluginLoad: function(filename: PAnsiChar; flags: DWORD): HPLUGIN; stdcall;
BASS_PluginFree: function(handle: HPLUGIN): BOOL; stdcall;
BASS_PluginGetInfo: function(handle: HPLUGIN): PBASS_PLUGININFO; stdcall;
BASS_Set3DFactors: function(distf, rollf, doppf: FLOAT): BOOL; stdcall;
BASS_Get3DFactors: function(var distf, rollf, doppf: FLOAT): BOOL; stdcall;
BASS_Set3DPosition: function(var pos, vel, front, top: BASS_3DVECTOR): BOOL; stdcall;
BASS_Get3DPosition: function(var pos, vel, front, top: BASS_3DVECTOR): BOOL; stdcall;
BASS_Apply3D: procedure(); stdcall;
BASS_SetEAXParameters: function(env: Integer; vol, decay, damp: FLOAT): BOOL; stdcall;
BASS_GetEAXParameters: function(var env: DWORD; var vol, decay, damp: FLOAT): BOOL; stdcall;
BASS_MusicLoad: function(mem: BOOL; f: Pointer; offset, length, flags, freq: DWORD): HMUSIC; stdcall;
BASS_MusicFree: function(handle: HMUSIC): BOOL; stdcall;
BASS_MusicSetAttribute: function(handle: HMUSIC; attrib,value: DWORD): DWORD; stdcall;
BASS_MusicGetAttribute: function(handle: HMUSIC; attrib: DWORD): DWORD; stdcall;
BASS_MusicGetOrders: function(handle: HMUSIC): DWORD; stdcall;
BASS_MusicGetOrderPosition: function(handle: HMUSIC): DWORD; stdcall;
BASS_SampleLoad: function(mem: BOOL; f: Pointer; offset, length, max, flags: DWORD): HSAMPLE; stdcall;
BASS_SampleCreate: function(length, freq, chans, max, flags: DWORD): Pointer; stdcall;
BASS_SampleCreateDone: function(): HSAMPLE; stdcall;
BASS_SampleFree: function(handle: HSAMPLE): BOOL; stdcall;
BASS_SampleGetInfo: function(handle: HSAMPLE; var info: BASS_SAMPLE): BOOL; stdcall;
BASS_SampleSetInfo: function(handle: HSAMPLE; var info: BASS_SAMPLE): BOOL; stdcall;
BASS_SampleGetChannel: function(handle: HSAMPLE; onlynew: BOOL): HCHANNEL; stdcall;
BASS_SampleGetChannels: function(handle: HSAMPLE; channels: Pointer): DWORD; stdcall;
BASS_SampleStop: function(handle: HSAMPLE): BOOL; stdcall;
BASS_StreamCreate: function(freq, chans, flags: DWORD; proc: Pointer; user: DWORD): HSTREAM; stdcall;
BASS_StreamCreateFile: function(mem: BOOL; f: Pointer; offset, length, flags: DWORD): HSTREAM; stdcall;
BASS_StreamCreateURL: function(url: PAnsiChar; offset: DWORD; flags: DWORD; proc: DOWNLOADPROC; user: DWORD):HSTREAM; stdcall;
BASS_StreamCreateFileUser: function(buffered: BOOL; flags: DWORD; proc: STREAMFILEPROC; user: DWORD): HSTREAM; stdcall;
BASS_StreamFree: function(handle: HSTREAM): BOOL; stdcall;
BASS_StreamGetFilePosition: function(handle:HSTREAM; mode:DWORD) : DWORD; stdcall;
BASS_RecordGetDeviceDescription: function(devnum: DWORD):PAnsiChar; stdcall;
BASS_RecordInit: function(device: Integer):BOOL; stdcall;
BASS_RecordSetDevice: function(device: DWORD): BOOL; stdcall;
BASS_RecordGetDevice: function(): DWORD; stdcall;
BASS_RecordFree: function():BOOL; stdcall;
BASS_RecordGetInfo: function(var info:BASS_RECORDINFO):BOOL; stdcall;
BASS_RecordGetInputName: function(input:Integer):PAnsiChar; stdcall;
BASS_RecordSetInput: function(input:Integer; setting:DWORD):BOOL; stdcall;
BASS_RecordGetInput: function(input:Integer):DWORD; stdcall;
BASS_RecordStart: function(freq,chans,flags:DWORD; proc:RECORDPROC; user:DWORD):HRECORD; stdcall;
BASS_ChannelBytes2Seconds: function(handle: DWORD; pos: QWORD): FLOAT; stdcall;
BASS_ChannelSeconds2Bytes: function(handle: DWORD; pos: FLOAT): QWORD; stdcall;
BASS_ChannelGetDevice: function(handle: DWORD): DWORD; stdcall;
BASS_ChannelSetDevice: function(handle, device: DWORD): BOOL; stdcall;
BASS_ChannelIsActive: function(handle: DWORD): DWORD; stdcall;
BASS_ChannelGetInfo: function(handle: DWORD; var info:BASS_CHANNELINFO):BOOL; stdcall;
BASS_ChannelGetTags: function(handle: HSTREAM; tags : DWORD): PAnsiChar; stdcall;
BASS_ChannelSetFlags: function(handle, flags: DWORD): BOOL; stdcall;
BASS_ChannelPreBuf: function(handle, length: DWORD): BOOL; stdcall;
BASS_ChannelPlay: function(handle: DWORD; restart: BOOL): BOOL; stdcall;
BASS_ChannelStop: function(handle: DWORD): BOOL; stdcall;
BASS_ChannelPause: function(handle: DWORD): BOOL; stdcall;
BASS_ChannelSetAttributes: function(handle: DWORD; freq, volume, pan: Integer): BOOL; stdcall;
BASS_ChannelGetAttributes: function(handle: DWORD; var freq, volume: DWORD; var pan: Integer): BOOL; stdcall;
BASS_ChannelSlideAttributes: function(handle: DWORD; freq, volume, pan: Integer; time: DWORD): BOOL; stdcall;
BASS_ChannelIsSliding: function(handle: DWORD): DWORD; stdcall;
BASS_ChannelSet3DAttributes: function(handle: DWORD; mode: Integer; min, max: FLOAT; iangle, oangle, outvol: Integer): BOOL; stdcall;
BASS_ChannelGet3DAttributes: function(handle: DWORD; var mode: DWORD; var min, max: FLOAT; var iangle, oangle, outvol: DWORD): BOOL; stdcall;
BASS_ChannelSet3DPosition: function(handle: DWORD; var pos, orient, vel: BASS_3DVECTOR): BOOL; stdcall;
BASS_ChannelGet3DPosition: function(handle: DWORD; var pos, orient, vel: BASS_3DVECTOR): BOOL; stdcall;
BASS_ChannelGetLength: function(handle: DWORD): QWORD; stdcall;
BASS_ChannelSetPosition: function(handle: DWORD; pos: QWORD): BOOL; stdcall;
BASS_ChannelGetPosition: function(handle: DWORD): QWORD; stdcall;
BASS_ChannelGetLevel: function(handle: DWORD): DWORD; stdcall;
BASS_ChannelGetData: function(handle: DWORD; buffer: Pointer; length: DWORD): DWORD; stdcall;
BASS_ChannelSetSync: function(handle: DWORD; stype: DWORD; param: QWORD; proc: SYNCPROC; user: DWORD): HSYNC; stdcall;
BASS_ChannelRemoveSync: function(handle: DWORD; sync: HSYNC): BOOL; stdcall;
BASS_ChannelSetDSP: function(handle: DWORD; proc: DSPPROC; user: DWORD; priority: Integer): HDSP; stdcall;
BASS_ChannelRemoveDSP: function(handle: DWORD; dsp: HDSP): BOOL; stdcall;
BASS_ChannelSetEAXMix: function(handle: DWORD; mix: FLOAT): BOOL; stdcall;
BASS_ChannelGetEAXMix: function(handle: DWORD; var mix: FLOAT): BOOL; stdcall;
BASS_ChannelSetLink: function(handle, chan: DWORD): BOOL; stdcall;
BASS_ChannelRemoveLink: function(handle, chan: DWORD): BOOL; stdcall;
BASS_ChannelSetFX: function(handle, etype: DWORD; priority: Integer): HFX; stdcall;
BASS_ChannelRemoveFX: function(handle: DWORD; fx: HFX): BOOL; stdcall;
BASS_FXSetParameters: function(handle: HFX; par: Pointer): BOOL; stdcall;
BASS_FXGetParameters: function(handle: HFX; par: Pointer): BOOL; stdcall;
BASS_FXReset: function(handle: HFX): BOOL; stdcall;

Description

Functions and Procedures

function BASS_SPEAKER_N(n: DWORD): DWORD;
function MAKEMUSICPOS(order,row: DWORD): DWORD;
function BASS_SetEAXPreset(env: Integer): BOOL;
function BASS_Load(LibName: PChar ): Boolean;
procedure BASS_UnLoad;
Function BASS_IsLoaded:boolean;

Types

DWORD = cardinal;
BOOL = LongBool;
FLOAT = Single;
QWORD = int64;
HMUSIC = DWORD;
HSAMPLE = DWORD;
HCHANNEL = DWORD;
HSTREAM = DWORD;
HRECORD = DWORD;
HSYNC = DWORD;
HDSP = DWORD;
HFX = DWORD;
HPLUGIN = DWORD;
PBASS_PLUGINFORMS = ˆTBASS_PLUGINFORMS;
TBASS_PLUGINFORMS = array[0..maxInt div sizeOf(BASS_PLUGINFORM) - 1] of BASS_PLUGINFORM;
PBASS_PLUGININFO = ˆBASS_PLUGININFO;
STREAMPROC = function(handle: HSTREAM; buffer: Pointer; length: DWORD; user: DWORD): DWORD; stdcall;
STREAMFILEPROC = function(action, param1, param2, user: DWORD): DWORD; stdcall;
DOWNLOADPROC = procedure(buffer: Pointer; length: DWORD; user: DWORD); stdcall;
SYNCPROC = procedure(handle: HSYNC; channel, data: DWORD; user: DWORD); stdcall;
DSPPROC = procedure(handle: HDSP; channel: DWORD; buffer: Pointer; length: DWORD; user: DWORD); stdcall;
RECORDPROC = function(handle: HRECORD; buffer: Pointer; length: DWORD; user: DWORD): BOOL; stdcall;
TBASSModuleHandle = HINST;

Constants

BASSVERSION = $203;
BASS_DLL = 'bass.dll';
DW_ERROR = Cardinal(-1);
QW_ERROR = Int64(-1);
BASS_OK = 0;
BASS_ERROR_MEM = 1;
BASS_ERROR_FILEOPEN = 2;
BASS_ERROR_DRIVER = 3;
BASS_ERROR_BUFLOST = 4;
BASS_ERROR_HANDLE = 5;
BASS_ERROR_FORMAT = 6;
BASS_ERROR_POSITION = 7;
BASS_ERROR_INIT = 8;
BASS_ERROR_START = 9;
BASS_ERROR_ALREADY = 14;
BASS_ERROR_NOPAUSE = 16;
BASS_ERROR_NOCHAN = 18;
BASS_ERROR_ILLTYPE = 19;
BASS_ERROR_ILLPARAM = 20;
BASS_ERROR_NO3D = 21;
BASS_ERROR_NOEAX = 22;
BASS_ERROR_DEVICE = 23;
BASS_ERROR_NOPLAY = 24;
BASS_ERROR_FREQ = 25;
BASS_ERROR_NOTFILE = 27;
BASS_ERROR_NOHW = 29;
BASS_ERROR_EMPTY = 31;
BASS_ERROR_NONET = 32;
BASS_ERROR_CREATE = 33;
BASS_ERROR_NOFX = 34;
BASS_ERROR_PLAYING = 35;
BASS_ERROR_NOTAVAIL = 37;
BASS_ERROR_DECODE = 38;
BASS_ERROR_DX = 39;
BASS_ERROR_TIMEOUT = 40;
BASS_ERROR_FILEFORM = 41;
BASS_ERROR_SPEAKER = 42;
BASS_ERROR_VERSION = 43;
BASS_ERROR_CODEC = 44;
BASS_ERROR_UNKNOWN = -1;
BASS_DEVICE_8BITS = 1;
BASS_DEVICE_MONO = 2;
BASS_DEVICE_3D = 4;
BASS_DEVICE_LATENCY = 256;
BASS_DEVICE_SPEAKERS = 2048;
BASS_DEVICE_NOSPEAKER = 4096;
BASS_OBJECT_DS = 1;
BASS_OBJECT_DS3DL = 2;
DSCAPS_CONTINUOUSRATE = $00000010;
DSCAPS_EMULDRIVER = $00000020;
DSCAPS_CERTIFIED = $00000040;
DSCAPS_SECONDARYMONO = $00000100;
DSCAPS_SECONDARYSTEREO = $00000200;
DSCAPS_SECONDARY8BIT = $00000400;
DSCAPS_SECONDARY16BIT = $00000800;
DSCCAPS_EMULDRIVER = DSCAPS_EMULDRIVER;
DSCCAPS_CERTIFIED = DSCAPS_CERTIFIED;
WAVE_FORMAT_1M08 = $00000001;
WAVE_FORMAT_1S08 = $00000002;
WAVE_FORMAT_1M16 = $00000004;
WAVE_FORMAT_1S16 = $00000008;
WAVE_FORMAT_2M08 = $00000010;
WAVE_FORMAT_2S08 = $00000020;
WAVE_FORMAT_2M16 = $00000040;
WAVE_FORMAT_2S16 = $00000080;
WAVE_FORMAT_4M08 = $00000100;
WAVE_FORMAT_4S08 = $00000200;
WAVE_FORMAT_4M16 = $00000400;
WAVE_FORMAT_4S16 = $00000800;
BASS_SAMPLE_8BITS = 1;
BASS_SAMPLE_FLOAT = 256;
BASS_SAMPLE_MONO = 2;
BASS_SAMPLE_LOOP = 4;
BASS_SAMPLE_3D = 8;
BASS_SAMPLE_SOFTWARE = 16;
BASS_SAMPLE_MUTEMAX = 32;
BASS_SAMPLE_VAM = 64;
BASS_SAMPLE_FX = 128;
BASS_SAMPLE_OVER_VOL = $10000;
BASS_SAMPLE_OVER_POS = $20000;
BASS_SAMPLE_OVER_DIST = $30000;
BASS_STREAM_PRESCAN = $20000;
BASS_MP3_SETPOS = BASS_STREAM_PRESCAN;
BASS_STREAM_AUTOFREE = $40000;
BASS_STREAM_RESTRATE = $80000;
BASS_STREAM_BLOCK = $100000;
BASS_STREAM_DECODE = $200000;
BASS_STREAM_STATUS = $800000;
BASS_MUSIC_FLOAT = BASS_SAMPLE_FLOAT;
BASS_MUSIC_MONO = BASS_SAMPLE_MONO;
BASS_MUSIC_LOOP = BASS_SAMPLE_LOOP;
BASS_MUSIC_3D = BASS_SAMPLE_3D;
BASS_MUSIC_FX = BASS_SAMPLE_FX;
BASS_MUSIC_AUTOFREE = BASS_STREAM_AUTOFREE;
BASS_MUSIC_DECODE = BASS_STREAM_DECODE;
BASS_MUSIC_PRESCAN = BASS_STREAM_PRESCAN;
BASS_MUSIC_CALCLEN = BASS_MUSIC_PRESCAN;
BASS_MUSIC_RAMP = $200;
BASS_MUSIC_RAMPS = $400;
BASS_MUSIC_SURROUND = $800;
BASS_MUSIC_SURROUND2 = $1000;
BASS_MUSIC_FT2MOD = $2000;
BASS_MUSIC_PT1MOD = $4000;
BASS_MUSIC_NONINTER = $10000;
BASS_MUSIC_POSRESET = $8000;
BASS_MUSIC_POSRESETEX = $400000;
BASS_MUSIC_STOPBACK = $80000;
BASS_MUSIC_NOSAMPLE = $100000;
BASS_SPEAKER_FRONT = $1000000;
BASS_SPEAKER_REAR = $2000000;
BASS_SPEAKER_CENLFE = $3000000;
BASS_SPEAKER_REAR2 = $4000000;
BASS_SPEAKER_LEFT = $10000000;
BASS_SPEAKER_RIGHT = $20000000;
BASS_SPEAKER_FRONTLEFT = BASS_SPEAKER_FRONT or BASS_SPEAKER_LEFT;
BASS_SPEAKER_FRONTRIGHT = BASS_SPEAKER_FRONT or BASS_SPEAKER_RIGHT;
BASS_SPEAKER_REARLEFT = BASS_SPEAKER_REAR or BASS_SPEAKER_LEFT;
BASS_SPEAKER_REARRIGHT = BASS_SPEAKER_REAR or BASS_SPEAKER_RIGHT;
BASS_SPEAKER_CENTER = BASS_SPEAKER_CENLFE or BASS_SPEAKER_LEFT;
BASS_SPEAKER_LFE = BASS_SPEAKER_CENLFE or BASS_SPEAKER_RIGHT;
BASS_SPEAKER_REAR2LEFT = BASS_SPEAKER_REAR2 or BASS_SPEAKER_LEFT;
BASS_SPEAKER_REAR2RIGHT = BASS_SPEAKER_REAR2 or BASS_SPEAKER_RIGHT;
BASS_UNICODE = $80000000;
BASS_RECORD_PAUSE = $8000;
BASS_VAM_HARDWARE = 1;
BASS_VAM_SOFTWARE = 2;
BASS_VAM_TERM_TIME = 4;
BASS_VAM_TERM_DIST = 8;
BASS_VAM_TERM_PRIO = 16;
BASS_CTYPE_SAMPLE = 1;
BASS_CTYPE_RECORD = 2;
BASS_CTYPE_STREAM = $10000;
BASS_CTYPE_STREAM_OGG = $10002;
BASS_CTYPE_STREAM_MP1 = $10003;
BASS_CTYPE_STREAM_MP2 = $10004;
BASS_CTYPE_STREAM_MP3 = $10005;
BASS_CTYPE_STREAM_AIFF = $10006;
BASS_CTYPE_STREAM_WAV = $40000;
BASS_CTYPE_STREAM_WAV_PCM = $50001;
BASS_CTYPE_STREAM_WAV_FLOAT = $50003;
BASS_CTYPE_MUSIC_MOD = $20000;
BASS_CTYPE_MUSIC_MTM = $20001;
BASS_CTYPE_MUSIC_S3M = $20002;
BASS_CTYPE_MUSIC_XM = $20003;
BASS_CTYPE_MUSIC_IT = $20004;
BASS_CTYPE_MUSIC_MO3 = $00100;
BASS_3DMODE_NORMAL = 0;
BASS_3DMODE_RELATIVE = 1;
BASS_3DMODE_OFF = 2;
EAX_ENVIRONMENT_GENERIC = 0;
EAX_ENVIRONMENT_PADDEDCELL = 1;
EAX_ENVIRONMENT_ROOM = 2;
EAX_ENVIRONMENT_BATHROOM = 3;
EAX_ENVIRONMENT_LIVINGROOM = 4;
EAX_ENVIRONMENT_STONEROOM = 5;
EAX_ENVIRONMENT_AUDITORIUM = 6;
EAX_ENVIRONMENT_CONCERTHALL = 7;
EAX_ENVIRONMENT_CAVE = 8;
EAX_ENVIRONMENT_ARENA = 9;
EAX_ENVIRONMENT_HANGAR = 10;
EAX_ENVIRONMENT_CARPETEDHALLWAY = 11;
EAX_ENVIRONMENT_HALLWAY = 12;
EAX_ENVIRONMENT_STONECORRIDOR = 13;
EAX_ENVIRONMENT_ALLEY = 14;
EAX_ENVIRONMENT_FOREST = 15;
EAX_ENVIRONMENT_CITY = 16;
EAX_ENVIRONMENT_MOUNTAINS = 17;
EAX_ENVIRONMENT_QUARRY = 18;
EAX_ENVIRONMENT_PLAIN = 19;
EAX_ENVIRONMENT_PARKINGLOT = 20;
EAX_ENVIRONMENT_SEWERPIPE = 21;
EAX_ENVIRONMENT_UNDERWATER = 22;
EAX_ENVIRONMENT_DRUGGED = 23;
EAX_ENVIRONMENT_DIZZY = 24;
EAX_ENVIRONMENT_PSYCHOTIC = 25;
EAX_ENVIRONMENT_COUNT = 26;
BASS_3DALG_DEFAULT = 0;
BASS_3DALG_OFF = 1;
BASS_3DALG_FULL = 2;
BASS_3DALG_LIGHT = 3;
BASS_SYNC_POS = 0;
BASS_SYNC_END = 2;
BASS_SYNC_META = 4;
BASS_SYNC_SLIDE = 5;
BASS_SYNC_STALL = 6;
BASS_SYNC_DOWNLOAD = 7;
BASS_SYNC_FREE = 8;
BASS_SYNC_SETPOS = 11;
BASS_SYNC_MUSICPOS = 10;
BASS_SYNC_MUSICINST = 1;
BASS_SYNC_MUSICFX = 3;
BASS_SYNC_MESSAGE = $20000000;
BASS_SYNC_MIXTIME = $40000000;
BASS_SYNC_ONETIME = $80000000;
BASS_ACTIVE_STOPPED = 0;
BASS_ACTIVE_PLAYING = 1;
BASS_ACTIVE_STALLED = 2;
BASS_ACTIVE_PAUSED = 3;
BASS_SLIDE_FREQ = 1;
BASS_SLIDE_VOL = 2;
BASS_SLIDE_PAN = 4;
BASS_DATA_AVAILABLE = 0;
BASS_DATA_FLOAT = $40000000;
BASS_DATA_FFT512 = $80000000;
BASS_DATA_FFT1024 = $80000001;
BASS_DATA_FFT2048 = $80000002;
BASS_DATA_FFT4096 = $80000003;
BASS_DATA_FFT8192 = $80000004;
BASS_DATA_FFT_INDIVIDUAL = $10;
BASS_DATA_FFT_NOWINDOW = $20;
BASS_TAG_ID3 = 0;
BASS_TAG_ID3V2 = 1;
BASS_TAG_OGG = 2;
BASS_TAG_HTTP = 3;
BASS_TAG_ICY = 4;
BASS_TAG_META = 5;
BASS_TAG_VENDOR = 9;
BASS_TAG_LYRICS3 = 10;
BASS_TAG_RIFF_INFO = $100;
BASS_TAG_MUSIC_NAME = $10000;
BASS_TAG_MUSIC_MESSAGE = $10001;
BASS_TAG_MUSIC_INST = $10100;
BASS_TAG_MUSIC_SAMPLE = $10300;
BASS_FX_CHORUS = 0;
BASS_FX_COMPRESSOR = 1;
BASS_FX_DISTORTION = 2;
BASS_FX_ECHO = 3;
BASS_FX_FLANGER = 4;
BASS_FX_GARGLE = 5;
BASS_FX_I3DL2REVERB = 6;
BASS_FX_PARAMEQ = 7;
BASS_FX_REVERB = 8;
BASS_FX_PHASE_NEG_180 = 0;
BASS_FX_PHASE_NEG_90 = 1;
BASS_FX_PHASE_ZERO = 2;
BASS_FX_PHASE_90 = 3;
BASS_FX_PHASE_180 = 4;
BASS_INPUT_OFF = $10000;
BASS_INPUT_ON = $20000;
BASS_INPUT_LEVEL = $40000;
BASS_INPUT_TYPE_MASK = $ff000000;
BASS_INPUT_TYPE_UNDEF = $00000000;
BASS_INPUT_TYPE_DIGITAL = $01000000;
BASS_INPUT_TYPE_LINE = $02000000;
BASS_INPUT_TYPE_MIC = $03000000;
BASS_INPUT_TYPE_SYNTH = $04000000;
BASS_INPUT_TYPE_CD = $05000000;
BASS_INPUT_TYPE_PHONE = $06000000;
BASS_INPUT_TYPE_SPEAKER = $07000000;
BASS_INPUT_TYPE_WAVE = $08000000;
BASS_INPUT_TYPE_AUX = $09000000;
BASS_INPUT_TYPE_ANALOG = $0a000000;
BASS_NET_TIMEOUT = 0;
BASS_NET_BUFFER = 1;
BASS_FILEPOS_CURRENT = 0;
BASS_FILEPOS_DECODE = BASS_FILEPOS_CURRENT;
BASS_FILEPOS_DOWNLOAD = 1;
BASS_FILEPOS_END = 2;
BASS_FILEPOS_START = 3;
BASS_FILEPOS_CONNECTED = 4;
BASS_FILE_CLOSE = 0;
BASS_FILE_READ = 1;
BASS_FILE_LEN = 3;
BASS_FILE_SEEK = 4;
BASS_STREAMPROC_END = $80000000;
BASS_MUSIC_ATTRIB_AMPLIFY = 0;
BASS_MUSIC_ATTRIB_PANSEP = 1;
BASS_MUSIC_ATTRIB_PSCALER = 2;
BASS_MUSIC_ATTRIB_BPM = 3;
BASS_MUSIC_ATTRIB_SPEED = 4;
BASS_MUSIC_ATTRIB_VOL_GLOBAL = 5;
BASS_MUSIC_ATTRIB_VOL_CHAN = $100;
BASS_MUSIC_ATTRIB_VOL_INST = $200;
BASS_CONFIG_BUFFER = 0;
BASS_CONFIG_UPDATEPERIOD = 1;
BASS_CONFIG_MAXVOL = 3;
BASS_CONFIG_GVOL_SAMPLE = 4;
BASS_CONFIG_GVOL_STREAM = 5;
BASS_CONFIG_GVOL_MUSIC = 6;
BASS_CONFIG_CURVE_VOL = 7;
BASS_CONFIG_CURVE_PAN = 8;
BASS_CONFIG_FLOATDSP = 9;
BASS_CONFIG_3DALGORITHM = 10;
BASS_CONFIG_NET_TIMEOUT = 11;
BASS_CONFIG_NET_BUFFER = 12;
BASS_CONFIG_PAUSE_NOPLAY = 13;
BASS_CONFIG_NET_PREBUF = 15;
BASS_CONFIG_NET_AGENT = 16;
BASS_CONFIG_NET_PROXY = 17;
BASS_CONFIG_NET_PASSIVE = 18;
BASS_CONFIG_REC_BUFFER = 19;
BASS_CONFIG_NET_PLAYLIST = 21;
BASS_CONFIG_MUSIC_VIRTUAL = 22;

Variables

BASS_SetConfig: function(option, value: DWORD): DWORD; stdcall;
BASS_GetConfig: function(option: DWORD): DWORD; stdcall;
BASS_GetVersion: function(): DWORD; stdcall;
BASS_GetDeviceDescription: function(device: DWORD): PAnsiChar; stdcall;
BASS_ErrorGetCode: function(): Integer; stdcall;
BASS_Init: function(device: Integer; freq, flags: DWORD; win: HWND; clsid: PGUID): BOOL; stdcall;
BASS_SetDevice: function(device: DWORD): BOOL; stdcall;
BASS_GetDevice: function(): DWORD; stdcall;
BASS_Free: function(): BOOL; stdcall;
BASS_GetDSoundObject: function(obj: DWORD): Pointer; stdcall;
BASS_GetInfo: function(var info: BASS_INFO): BOOL; stdcall;
BASS_Update: function(): BOOL; stdcall;
BASS_GetCPU: function(): FLOAT; stdcall;
BASS_Start: function(): BOOL; stdcall;
BASS_Stop: function(): BOOL; stdcall;
BASS_Pause: function(): BOOL; stdcall;
BASS_SetVolume: function(volume: DWORD): BOOL; stdcall;
BASS_GetVolume: function(): Integer; stdcall;
BASS_PluginLoad: function(filename: PAnsiChar; flags: DWORD): HPLUGIN; stdcall;
BASS_PluginFree: function(handle: HPLUGIN): BOOL; stdcall;
BASS_PluginGetInfo: function(handle: HPLUGIN): PBASS_PLUGININFO; stdcall;
BASS_Set3DFactors: function(distf, rollf, doppf: FLOAT): BOOL; stdcall;
BASS_Get3DFactors: function(var distf, rollf, doppf: FLOAT): BOOL; stdcall;
BASS_Set3DPosition: function(var pos, vel, front, top: BASS_3DVECTOR): BOOL; stdcall;
BASS_Get3DPosition: function(var pos, vel, front, top: BASS_3DVECTOR): BOOL; stdcall;
BASS_Apply3D: procedure(); stdcall;
BASS_SetEAXParameters: function(env: Integer; vol, decay, damp: FLOAT): BOOL; stdcall;
BASS_GetEAXParameters: function(var env: DWORD; var vol, decay, damp: FLOAT): BOOL; stdcall;
BASS_MusicLoad: function(mem: BOOL; f: Pointer; offset, length, flags, freq: DWORD): HMUSIC; stdcall;
BASS_MusicFree: function(handle: HMUSIC): BOOL; stdcall;
BASS_MusicSetAttribute: function(handle: HMUSIC; attrib,value: DWORD): DWORD; stdcall;
BASS_MusicGetAttribute: function(handle: HMUSIC; attrib: DWORD): DWORD; stdcall;
BASS_MusicGetOrders: function(handle: HMUSIC): DWORD; stdcall;
BASS_MusicGetOrderPosition: function(handle: HMUSIC): DWORD; stdcall;
BASS_SampleLoad: function(mem: BOOL; f: Pointer; offset, length, max, flags: DWORD): HSAMPLE; stdcall;
BASS_SampleCreate: function(length, freq, chans, max, flags: DWORD): Pointer; stdcall;
BASS_SampleCreateDone: function(): HSAMPLE; stdcall;
BASS_SampleFree: function(handle: HSAMPLE): BOOL; stdcall;
BASS_SampleGetInfo: function(handle: HSAMPLE; var info: BASS_SAMPLE): BOOL; stdcall;
BASS_SampleSetInfo: function(handle: HSAMPLE; var info: BASS_SAMPLE): BOOL; stdcall;
BASS_SampleGetChannel: function(handle: HSAMPLE; onlynew: BOOL): HCHANNEL; stdcall;
BASS_SampleGetChannels: function(handle: HSAMPLE; channels: Pointer): DWORD; stdcall;
BASS_SampleStop: function(handle: HSAMPLE): BOOL; stdcall;
BASS_StreamCreate: function(freq, chans, flags: DWORD; proc: Pointer; user: DWORD): HSTREAM; stdcall;
BASS_StreamCreateFile: function(mem: BOOL; f: Pointer; offset, length, flags: DWORD): HSTREAM; stdcall;
BASS_StreamCreateURL: function(url: PAnsiChar; offset: DWORD; flags: DWORD; proc: DOWNLOADPROC; user: DWORD):HSTREAM; stdcall;
BASS_StreamCreateFileUser: function(buffered: BOOL; flags: DWORD; proc: STREAMFILEPROC; user: DWORD): HSTREAM; stdcall;
BASS_StreamFree: function(handle: HSTREAM): BOOL; stdcall;
BASS_StreamGetFilePosition: function(handle:HSTREAM; mode:DWORD) : DWORD; stdcall;
BASS_RecordGetDeviceDescription: function(devnum: DWORD):PAnsiChar; stdcall;
BASS_RecordInit: function(device: Integer):BOOL; stdcall;
BASS_RecordSetDevice: function(device: DWORD): BOOL; stdcall;
BASS_RecordGetDevice: function(): DWORD; stdcall;
BASS_RecordFree: function():BOOL; stdcall;
BASS_RecordGetInfo: function(var info:BASS_RECORDINFO):BOOL; stdcall;
BASS_RecordGetInputName: function(input:Integer):PAnsiChar; stdcall;
BASS_RecordSetInput: function(input:Integer; setting:DWORD):BOOL; stdcall;
BASS_RecordGetInput: function(input:Integer):DWORD; stdcall;
BASS_RecordStart: function(freq,chans,flags:DWORD; proc:RECORDPROC; user:DWORD):HRECORD; stdcall;
BASS_ChannelBytes2Seconds: function(handle: DWORD; pos: QWORD): FLOAT; stdcall;
BASS_ChannelSeconds2Bytes: function(handle: DWORD; pos: FLOAT): QWORD; stdcall;
BASS_ChannelGetDevice: function(handle: DWORD): DWORD; stdcall;
BASS_ChannelSetDevice: function(handle, device: DWORD): BOOL; stdcall;
BASS_ChannelIsActive: function(handle: DWORD): DWORD; stdcall;
BASS_ChannelGetInfo: function(handle: DWORD; var info:BASS_CHANNELINFO):BOOL; stdcall;
BASS_ChannelGetTags: function(handle: HSTREAM; tags : DWORD): PAnsiChar; stdcall;
BASS_ChannelSetFlags: function(handle, flags: DWORD): BOOL; stdcall;
BASS_ChannelPreBuf: function(handle, length: DWORD): BOOL; stdcall;
BASS_ChannelPlay: function(handle: DWORD; restart: BOOL): BOOL; stdcall;
BASS_ChannelStop: function(handle: DWORD): BOOL; stdcall;
BASS_ChannelPause: function(handle: DWORD): BOOL; stdcall;
BASS_ChannelSetAttributes: function(handle: DWORD; freq, volume, pan: Integer): BOOL; stdcall;
BASS_ChannelGetAttributes: function(handle: DWORD; var freq, volume: DWORD; var pan: Integer): BOOL; stdcall;
BASS_ChannelSlideAttributes: function(handle: DWORD; freq, volume, pan: Integer; time: DWORD): BOOL; stdcall;
BASS_ChannelIsSliding: function(handle: DWORD): DWORD; stdcall;
BASS_ChannelSet3DAttributes: function(handle: DWORD; mode: Integer; min, max: FLOAT; iangle, oangle, outvol: Integer): BOOL; stdcall;
BASS_ChannelGet3DAttributes: function(handle: DWORD; var mode: DWORD; var min, max: FLOAT; var iangle, oangle, outvol: DWORD): BOOL; stdcall;
BASS_ChannelSet3DPosition: function(handle: DWORD; var pos, orient, vel: BASS_3DVECTOR): BOOL; stdcall;
BASS_ChannelGet3DPosition: function(handle: DWORD; var pos, orient, vel: BASS_3DVECTOR): BOOL; stdcall;
BASS_ChannelGetLength: function(handle: DWORD): QWORD; stdcall;
BASS_ChannelSetPosition: function(handle: DWORD; pos: QWORD): BOOL; stdcall;
BASS_ChannelGetPosition: function(handle: DWORD): QWORD; stdcall;
BASS_ChannelGetLevel: function(handle: DWORD): DWORD; stdcall;
BASS_ChannelGetData: function(handle: DWORD; buffer: Pointer; length: DWORD): DWORD; stdcall;
BASS_ChannelSetSync: function(handle: DWORD; stype: DWORD; param: QWORD; proc: SYNCPROC; user: DWORD): HSYNC; stdcall;
BASS_ChannelRemoveSync: function(handle: DWORD; sync: HSYNC): BOOL; stdcall;
BASS_ChannelSetDSP: function(handle: DWORD; proc: DSPPROC; user: DWORD; priority: Integer): HDSP; stdcall;
BASS_ChannelRemoveDSP: function(handle: DWORD; dsp: HDSP): BOOL; stdcall;
BASS_ChannelSetEAXMix: function(handle: DWORD; mix: FLOAT): BOOL; stdcall;
BASS_ChannelGetEAXMix: function(handle: DWORD; var mix: FLOAT): BOOL; stdcall;
BASS_ChannelSetLink: function(handle, chan: DWORD): BOOL; stdcall;
BASS_ChannelRemoveLink: function(handle, chan: DWORD): BOOL; stdcall;
BASS_ChannelSetFX: function(handle, etype: DWORD; priority: Integer): HFX; stdcall;
BASS_ChannelRemoveFX: function(handle: DWORD; fx: HFX): BOOL; stdcall;
BASS_FXSetParameters: function(handle: HFX; par: Pointer): BOOL; stdcall;
BASS_FXGetParameters: function(handle: HFX; par: Pointer): BOOL; stdcall;
BASS_FXReset: function(handle: HFX): BOOL; stdcall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: Bass: record BASS_INFO

record BASS_INFO

Unit

Bass

Declaration

type BASS_INFO = record

Description

Overview

Fields

flags: DWORD;
hwsize: DWORD;
hwfree: DWORD;
freesam: DWORD;
free3d: DWORD;
minrate: DWORD;
maxrate: DWORD;
eax: BOOL;
minbuf: DWORD;
dsver: DWORD;
latency: DWORD;
initflags: DWORD;
speakers: DWORD;
driver: PAnsiChar;
freq: DWORD;

Description

Fields

flags: DWORD;
hwsize: DWORD;
hwfree: DWORD;
freesam: DWORD;
free3d: DWORD;
minrate: DWORD;
maxrate: DWORD;
eax: BOOL;
minbuf: DWORD;
dsver: DWORD;
latency: DWORD;
initflags: DWORD;
speakers: DWORD;
driver: PAnsiChar;
freq: DWORD;
Generated by PasDoc 0.11.0 on 2013-02-10 19:36:59


GLScene v.1.1.2: Bass: record BASS_RECORDINFO

record BASS_RECORDINFO

Unit

Bass

Declaration

type BASS_RECORDINFO = record

Description

Overview

Fields

flags: DWORD;
formats: DWORD;
inputs: DWORD;
singlein: BOOL;
driver: PAnsiChar;
freq: DWORD;

Description

Fields

flags: DWORD;
formats: DWORD;
inputs: DWORD;
singlein: BOOL;
driver: PAnsiChar;
freq: DWORD;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Bass: record BASS_CHANNELINFO

record BASS_CHANNELINFO

Unit

Bass

Declaration

type BASS_CHANNELINFO = record

Description

Overview

Fields

freq: DWORD;
chans: DWORD;
flags: DWORD;
ctype: DWORD;
origres: DWORD;
plugin: HPLUGIN;

Description

Fields

freq: DWORD;
chans: DWORD;
flags: DWORD;
ctype: DWORD;
origres: DWORD;
plugin: HPLUGIN;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Bass: record BASS_PLUGINFORM

record BASS_PLUGINFORM

Unit

Bass

Declaration

type BASS_PLUGINFORM = record

Description

Overview

Fields

ctype: DWORD;
name: PAnsiChar;
exts: PAnsiChar;

Description

Fields

ctype: DWORD;
name: PAnsiChar;
exts: PAnsiChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Bass: record BASS_PLUGININFO

record BASS_PLUGININFO

Unit

Bass

Declaration

type BASS_PLUGININFO = record

Description

Overview

Fields

version: DWORD;
formatc: DWORD;
formats: PBASS_PLUGINFORMS;

Description

Fields

version: DWORD;
formatc: DWORD;
formats: PBASS_PLUGINFORMS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Bass: record BASS_SAMPLE

record BASS_SAMPLE

Unit

Bass

Declaration

type BASS_SAMPLE = record

Description

Overview

Fields

freq: DWORD;
volume: DWORD;
pan: Integer;
flags: DWORD;
length: DWORD;
max: DWORD;
origres: DWORD;
chans: DWORD;
mingap: DWORD;
mode3d: DWORD;
mindist: FLOAT;
maxdist: FLOAT;
iangle: DWORD;
oangle: DWORD;
outvol: DWORD;
vam: DWORD;
priority: DWORD;

Description

Fields

freq: DWORD;
volume: DWORD;
pan: Integer;
flags: DWORD;
length: DWORD;
max: DWORD;
origres: DWORD;
chans: DWORD;
mingap: DWORD;
mode3d: DWORD;
mindist: FLOAT;
maxdist: FLOAT;
iangle: DWORD;
oangle: DWORD;
outvol: DWORD;
vam: DWORD;
priority: DWORD;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Bass: record BASS_3DVECTOR

record BASS_3DVECTOR

Unit

Bass

Declaration

type BASS_3DVECTOR = record

Description

Overview

Fields

x: FLOAT;
y: FLOAT;
z: FLOAT;

Description

Fields

x: FLOAT;
y: FLOAT;
z: FLOAT;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Bass: record BASS_FXCHORUS

record BASS_FXCHORUS

Unit

Bass

Declaration

type BASS_FXCHORUS = record

Description

Overview

Fields

fWetDryMix: FLOAT;
fDepth: FLOAT;
fFeedback: FLOAT;
fFrequency: FLOAT;
lWaveform: DWORD;
fDelay: FLOAT;
lPhase: DWORD;

Description

Fields

fWetDryMix: FLOAT;
fDepth: FLOAT;
fFeedback: FLOAT;
fFrequency: FLOAT;
lWaveform: DWORD;
fDelay: FLOAT;
lPhase: DWORD;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Bass: record BASS_FXCOMPRESSOR

record BASS_FXCOMPRESSOR

Unit

Bass

Declaration

type BASS_FXCOMPRESSOR = record

Description

Overview

Fields

fGain: FLOAT;
fAttack: FLOAT;
fRelease: FLOAT;
fThreshold: FLOAT;
fRatio: FLOAT;
fPredelay: FLOAT;

Description

Fields

fGain: FLOAT;
fAttack: FLOAT;
fRelease: FLOAT;
fThreshold: FLOAT;
fRatio: FLOAT;
fPredelay: FLOAT;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Bass: record BASS_FXDISTORTION

record BASS_FXDISTORTION

Unit

Bass

Declaration

type BASS_FXDISTORTION = record

Description

Overview

Fields

fGain: FLOAT;
fEdge: FLOAT;
fPostEQCenterFrequency: FLOAT;
fPostEQBandwidth: FLOAT;
fPreLowpassCutoff: FLOAT;

Description

Fields

fGain: FLOAT;
fEdge: FLOAT;
fPostEQCenterFrequency: FLOAT;
fPostEQBandwidth: FLOAT;
fPreLowpassCutoff: FLOAT;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Bass: record BASS_FXECHO

record BASS_FXECHO

Unit

Bass

Declaration

type BASS_FXECHO = record

Description

Overview

Fields

fWetDryMix: FLOAT;
fFeedback: FLOAT;
fLeftDelay: FLOAT;
fRightDelay: FLOAT;
lPanDelay: BOOL;

Description

Fields

fWetDryMix: FLOAT;
fFeedback: FLOAT;
fLeftDelay: FLOAT;
fRightDelay: FLOAT;
lPanDelay: BOOL;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Bass: record BASS_FXFLANGER

record BASS_FXFLANGER

Unit

Bass

Declaration

type BASS_FXFLANGER = record

Description

Overview

Fields

fWetDryMix: FLOAT;
fDepth: FLOAT;
fFeedback: FLOAT;
fFrequency: FLOAT;
lWaveform: DWORD;
fDelay: FLOAT;
lPhase: DWORD;

Description

Fields

fWetDryMix: FLOAT;
fDepth: FLOAT;
fFeedback: FLOAT;
fFrequency: FLOAT;
lWaveform: DWORD;
fDelay: FLOAT;
lPhase: DWORD;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Bass: record BASS_FXGARGLE

record BASS_FXGARGLE

Unit

Bass

Declaration

type BASS_FXGARGLE = record

Description

Overview

Fields

dwRateHz: DWORD;
dwWaveShape: DWORD;

Description

Fields

dwRateHz: DWORD;
dwWaveShape: DWORD;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Bass: record BASS_FXI3DL2REVERB

record BASS_FXI3DL2REVERB

Unit

Bass

Declaration

type BASS_FXI3DL2REVERB = record

Description

Overview

Fields

lRoom: Longint;
lRoomHF: Longint;
flRoomRolloffFactor: FLOAT;
flDecayTime: FLOAT;
flDecayHFRatio: FLOAT;
lReflections: Longint;
flReflectionsDelay: FLOAT;
lReverb: Longint;
flReverbDelay: FLOAT;
flDiffusion: FLOAT;
flDensity: FLOAT;
flHFReference: FLOAT;

Description

Fields

lRoom: Longint;
lRoomHF: Longint;
flRoomRolloffFactor: FLOAT;
flDecayTime: FLOAT;
flDecayHFRatio: FLOAT;
lReflections: Longint;
flReflectionsDelay: FLOAT;
lReverb: Longint;
flReverbDelay: FLOAT;
flDiffusion: FLOAT;
flDensity: FLOAT;
flHFReference: FLOAT;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Bass: record BASS_FXPARAMEQ

record BASS_FXPARAMEQ

Unit

Bass

Declaration

type BASS_FXPARAMEQ = record

Description

Overview

Fields

fCenter: FLOAT;
fBandwidth: FLOAT;
fGain: FLOAT;

Description

Fields

fCenter: FLOAT;
fBandwidth: FLOAT;
fGain: FLOAT;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Bass: record BASS_FXREVERB

record BASS_FXREVERB

Unit

Bass

Declaration

type BASS_FXREVERB = record

Description

Overview

Fields

fInGain: FLOAT;
fReverbMix: FLOAT;
fReverbTime: FLOAT;
fHighFreqRTRatio: FLOAT;

Description

Fields

fInGain: FLOAT;
fReverbMix: FLOAT;
fReverbTime: FLOAT;
fHighFreqRTRatio: FLOAT;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: BumpMapping

Unit BumpMapping

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Some useful methods for setting up bump maps.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records with arrays <li>08/07/04 - LR - Replace Graphics by GLCrossPlatform for Linux <li>30/03/04 - SG - Minor optimizations <li>22/09/03 - SG - Partially fixed tangent space normal map creation, Fixed normal blending coefficients <li>18/09/03 - SG - Added methods for creating normal maps, CreateTangentSpaceNormalMap is a little buggy <li>28/07/03 - SG - Creation </ul></font>

Overview

Functions and Procedures

procedure CalcObjectSpaceLightVectors(Light : TAffineVector; Vertices: TAffineVectorList; Colors: TVectorList);
procedure SetupTangentSpace(Vertices, Normals, TexCoords, Tangents, BiNormals : TAffineVectorList);
procedure CalcTangentSpaceLightVectors(Light : TAffineVector; Vertices, Normals, Tangents, BiNormals : TAffineVectorList; Colors: TVectorList);
function CreateObjectSpaceNormalMap(Width, Height : Integer; HiNormals,HiTexCoords : TAffineVectorList) : TGLBitmap;
function CreateTangentSpaceNormalMap(Width, Height : Integer; HiNormals, HiTexCoords, LoNormals, LoTexCoords, Tangents, BiNormals : TAffineVectorList) : TGLBitmap;

Types

TNormalMapSpace = (...);

Description

Functions and Procedures

procedure CalcObjectSpaceLightVectors(Light : TAffineVector; Vertices: TAffineVectorList; Colors: TVectorList);
procedure SetupTangentSpace(Vertices, Normals, TexCoords, Tangents, BiNormals : TAffineVectorList);
procedure CalcTangentSpaceLightVectors(Light : TAffineVector; Vertices, Normals, Tangents, BiNormals : TAffineVectorList; Colors: TVectorList);
function CreateObjectSpaceNormalMap(Width, Height : Integer; HiNormals,HiTexCoords : TAffineVectorList) : TGLBitmap;
function CreateTangentSpaceNormalMap(Width, Height : Integer; HiNormals, HiTexCoords, LoNormals, LoTexCoords, Tangents, BiNormals : TAffineVectorList) : TGLBitmap;

Types

TNormalMapSpace = (...);
Values
  • nmsObject:
  • nmsTangent:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: cgGL

Unit cgGL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Functions and Procedures

function cgGLIsProfileSupported(profile: TCGprofile): TCGbool; cdecl; external CgGLlibrary;
procedure cgGLEnableProfile(profile: TCGprofile); cdecl; external CgGLlibrary;
procedure cgGLDisableProfile(profile: TCGprofile); cdecl; external CgGLlibrary;
function cgGLGetLatestProfile(profile_type: TCGGLenum): TCGprofile; cdecl; external CgGLlibrary;
procedure cgGLSetOptimalOptions(profile: TCGprofile); cdecl; external CgGLlibrary;
procedure cgGLLoadProgram(_program: PCGprogram); cdecl; external CgGLlibrary;
function cgGLIsProgramLoaded(_program: PCGprogram): TCGbool; cdecl; external CgGLlibrary;
procedure cgGLBindProgram(_program: PCGprogram); cdecl; external CgGLlibrary;
procedure cgGLUnbindProgram(profile: TCGprofile); cdecl; external CgGLlibrary;
function cgGLGetProgramID(_program: PCGprogram): GLuint; cdecl; external CgGLlibrary;
procedure cgGLSetParameter1f(param: PCGparameter; x: Single); cdecl; external CgGLlibrary;
procedure cgGLSetParameter2f(param: PCGparameter; x, y: Single); cdecl; external CgGLlibrary;
procedure cgGLSetParameter3f(param: PCGparameter; x, y, z: Single); cdecl; external CgGLlibrary;
procedure cgGLSetParameter4f(param: PCGparameter; x, y, z, w: Single); cdecl; external CgGLlibrary;
procedure cgGLSetParameter1fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameter2fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameter3fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameter4fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameter1d(param: PCGparameter; x: Double); cdecl; external CgGLlibrary;
procedure cgGLSetParameter2d(param: PCGparameter; x, y: Double); cdecl; external CgGLlibrary;
procedure cgGLSetParameter3d(param: PCGparameter; x, y, z: Double); cdecl; external CgGLlibrary;
procedure cgGLSetParameter4d(param: PCGparameter; x, y, z, w: Double); cdecl; external CgGLlibrary;
procedure cgGLSetParameter1dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameter2dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameter3dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameter4dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameter1f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameter2f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameter3f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameter4f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameter1d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameter2d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameter3d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameter4d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray1f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray2f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray3f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray4f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray1d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray2d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray3d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray4d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray1f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray2f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray3f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray4f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray1d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray2d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray3d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray4d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterPointer(param: PCGparameter; fsize: GLint; _type: TGLenum; stride: GLsizei; const _pointer: Pointer); cdecl; external CgGLlibrary;
procedure cgGLEnableClientState(param: PCGparameter); cdecl; external CgGLlibrary;
procedure cgGLDisableClientState(param: PCGparameter); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterdr(param: PCGparameter; const matrix: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterfr(param: PCGparameter; const matrix: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterdc(param: PCGparameter; const matrix: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterfc(param: PCGparameter; const matrix: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterdr(param: PCGparameter; matrix: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterfr(param: PCGparameter; matrix: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterdc(param: PCGparameter; matrix: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterfc(param: PCGparameter; matrix: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetStateMatrixParameter(param: PCGparameter; matrix: TCGGLenum; transform: TCGGLenum); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterArrayfc(param: PCGparameter; offset, nelements: Longint; const matrices: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterArrayfr(param: PCGparameter; offset, nelements: Longint; const matrices: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterArraydc(param: PCGparameter; offset, nelements: Longint; const matrices: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterArraydr(param: PCGparameter; offset, nelements: Longint; const matrices: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterArrayfc(param: PCGparameter; offset, nelements: Longint; matrices: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterArrayfr(param: PCGparameter; offset, nelements: Longint; matrices: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterArraydc(param: PCGparameter; offset, nelements: Longint; matrices: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterArraydr(param: PCGparameter; offset, nelements: Longint; matrices: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetTextureParameter(param: PCGparameter; texobj: TGLuint); cdecl; external CgGLlibrary;
function cgGLGetTextureParameter(param: PCGparameter): TGLuint; cdecl; external CgGLlibrary;
procedure cgGLEnableTextureParameter(param: PCGparameter); cdecl; external CgGLlibrary;
procedure cgGLDisableTextureParameter(param: PCGparameter); cdecl; external CgGLlibrary;
function cgGLGetTextureEnum(param: PCGparameter): TGLenum; cdecl; external CgGLlibrary;
procedure cgGLSetManageTextureParameters(ctx: PCGcontext; flag: TCGbool); cdecl; external CgGLlibrary;
function cgGLGetManageTextureParameters(ctx: PCGcontext): TCGbool; cdecl; external CgGLlibrary;

Types

TCGGLenum = TGLEnum;
CGGLenum = TCGGLenum;

Constants

CgGLlibrary = 'cgGL.dll';
CG_GL_MATRIX_IDENTITY = 0;
CG_GL_MATRIX_TRANSPOSE = 1;
CG_GL_MATRIX_INVERSE = 2;
CG_GL_MATRIX_INVERSE_TRANSPOSE = 3;
CG_GL_MODELVIEW_MATRIX = 4;
CG_GL_PROJECTION_MATRIX = 5;
CG_GL_TEXTURE_MATRIX = 6;
CG_GL_MODELVIEW_PROJECTION_MATRIX = 7;
CG_GL_VERTEX = 8;
CG_GL_FRAGMENT = 9;

Description

Functions and Procedures

function cgGLIsProfileSupported(profile: TCGprofile): TCGbool; cdecl; external CgGLlibrary;
procedure cgGLEnableProfile(profile: TCGprofile); cdecl; external CgGLlibrary;
procedure cgGLDisableProfile(profile: TCGprofile); cdecl; external CgGLlibrary;
function cgGLGetLatestProfile(profile_type: TCGGLenum): TCGprofile; cdecl; external CgGLlibrary;
procedure cgGLSetOptimalOptions(profile: TCGprofile); cdecl; external CgGLlibrary;
procedure cgGLLoadProgram(_program: PCGprogram); cdecl; external CgGLlibrary;
function cgGLIsProgramLoaded(_program: PCGprogram): TCGbool; cdecl; external CgGLlibrary;
procedure cgGLBindProgram(_program: PCGprogram); cdecl; external CgGLlibrary;
procedure cgGLUnbindProgram(profile: TCGprofile); cdecl; external CgGLlibrary;
function cgGLGetProgramID(_program: PCGprogram): GLuint; cdecl; external CgGLlibrary;
procedure cgGLSetParameter1f(param: PCGparameter; x: Single); cdecl; external CgGLlibrary;
procedure cgGLSetParameter2f(param: PCGparameter; x, y: Single); cdecl; external CgGLlibrary;
procedure cgGLSetParameter3f(param: PCGparameter; x, y, z: Single); cdecl; external CgGLlibrary;
procedure cgGLSetParameter4f(param: PCGparameter; x, y, z, w: Single); cdecl; external CgGLlibrary;
procedure cgGLSetParameter1fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameter2fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameter3fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameter4fv(param: PCGparameter; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameter1d(param: PCGparameter; x: Double); cdecl; external CgGLlibrary;
procedure cgGLSetParameter2d(param: PCGparameter; x, y: Double); cdecl; external CgGLlibrary;
procedure cgGLSetParameter3d(param: PCGparameter; x, y, z: Double); cdecl; external CgGLlibrary;
procedure cgGLSetParameter4d(param: PCGparameter; x, y, z, w: Double); cdecl; external CgGLlibrary;
procedure cgGLSetParameter1dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameter2dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameter3dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameter4dv(param: PCGparameter; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameter1f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameter2f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameter3f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameter4f(param: PCGparameter; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameter1d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameter2d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameter3d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameter4d(param: PCGparameter; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray1f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray2f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray3f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray4f(param: PCGparameter; offset, nelements: Longint; const v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray1d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray2d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray3d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterArray4d(param: PCGparameter; offset, nelements: Longint; const v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray1f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray2f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray3f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray4f(param: PCGparameter; offset, nelements: Longint; v: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray1d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray2d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray3d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetParameterArray4d(param: PCGparameter; offset, nelements: Longint; v: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetParameterPointer(param: PCGparameter; fsize: GLint; _type: TGLenum; stride: GLsizei; const _pointer: Pointer); cdecl; external CgGLlibrary;
procedure cgGLEnableClientState(param: PCGparameter); cdecl; external CgGLlibrary;
procedure cgGLDisableClientState(param: PCGparameter); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterdr(param: PCGparameter; const matrix: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterfr(param: PCGparameter; const matrix: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterdc(param: PCGparameter; const matrix: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterfc(param: PCGparameter; const matrix: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterdr(param: PCGparameter; matrix: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterfr(param: PCGparameter; matrix: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterdc(param: PCGparameter; matrix: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterfc(param: PCGparameter; matrix: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetStateMatrixParameter(param: PCGparameter; matrix: TCGGLenum; transform: TCGGLenum); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterArrayfc(param: PCGparameter; offset, nelements: Longint; const matrices: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterArrayfr(param: PCGparameter; offset, nelements: Longint; const matrices: PSingle); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterArraydc(param: PCGparameter; offset, nelements: Longint; const matrices: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetMatrixParameterArraydr(param: PCGparameter; offset, nelements: Longint; const matrices: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterArrayfc(param: PCGparameter; offset, nelements: Longint; matrices: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterArrayfr(param: PCGparameter; offset, nelements: Longint; matrices: PSingle); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterArraydc(param: PCGparameter; offset, nelements: Longint; matrices: PDouble); cdecl; external CgGLlibrary;
procedure cgGLGetMatrixParameterArraydr(param: PCGparameter; offset, nelements: Longint; matrices: PDouble); cdecl; external CgGLlibrary;
procedure cgGLSetTextureParameter(param: PCGparameter; texobj: TGLuint); cdecl; external CgGLlibrary;
function cgGLGetTextureParameter(param: PCGparameter): TGLuint; cdecl; external CgGLlibrary;
procedure cgGLEnableTextureParameter(param: PCGparameter); cdecl; external CgGLlibrary;
procedure cgGLDisableTextureParameter(param: PCGparameter); cdecl; external CgGLlibrary;
function cgGLGetTextureEnum(param: PCGparameter): TGLenum; cdecl; external CgGLlibrary;
procedure cgGLSetManageTextureParameters(ctx: PCGcontext; flag: TCGbool); cdecl; external CgGLlibrary;
function cgGLGetManageTextureParameters(ctx: PCGcontext): TCGbool; cdecl; external CgGLlibrary;

Types

TCGGLenum = TGLEnum;
CGGLenum = TCGGLenum;

Constants

CgGLlibrary = 'cgGL.dll';
CG_GL_MATRIX_IDENTITY = 0;
CG_GL_MATRIX_TRANSPOSE = 1;
CG_GL_MATRIX_INVERSE = 2;
CG_GL_MATRIX_INVERSE_TRANSPOSE = 3;
CG_GL_MODELVIEW_MATRIX = 4;
CG_GL_PROJECTION_MATRIX = 5;
CG_GL_TEXTURE_MATRIX = 6;
CG_GL_MODELVIEW_PROJECTION_MATRIX = 7;
CG_GL_VERTEX = 8;
CG_GL_FRAGMENT = 9;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: CGPostTransformationShader

Unit CGPostTransformationShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

CGPostTransformationShader<p>

A shader that uses a texture to distort the view by adjusting texture coordinates. Does not have any practical use, but is fun to play around with.<p>

<b>History : </b><font size=-1><ul> <li>22/04/10 - Yar - Fixes after GLState revision <li>05/04/07 - DaStr - Contributed to GLScene <li>04/11/06 - DaStr - Creation (based on demo by Rick)

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCustomCGPostTransformationShader |
Class TGLCGPostTransformationShader |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: CGPostTransformationShader: Class TGLCustomCGPostTransformationShader

Class TGLCustomCGPostTransformationShader

Unit

CGPostTransformationShader

Declaration

type TGLCustomCGPostTransformationShader = class(TCustomCGShader, IGLPostShader)

Description

no description available, TCustomCGShader description follows
no description available, TGLShader description follows

Generic, abstract shader class.<p> Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities.<br> Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TCustomCgShader
  • TGLCustomCGPostTransformationShader

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Protected | function GetTextureTarget: TGLTextureTarget;
Protected | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected | procedure DoUseTempTexture(const TempTexture: TGLTextureHandle; TextureTarget: TGLTextureTarget);

Properties

Public | property TransformationPower: Single read FTransformationPower write FTransformationPower;
Public | property TransformationTexture: TGLTexture read FTransformationTexture write FTransformationTexture;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Protected function GetTextureTarget: TGLTextureTarget;
Protected procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected procedure DoUseTempTexture(const TempTexture: TGLTextureHandle; TextureTarget: TGLTextureTarget);

Properties

Public property TransformationPower: Single read FTransformationPower write FTransformationPower;
Public property TransformationTexture: TGLTexture read FTransformationTexture write FTransformationTexture;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: CGPostTransformationShader: Class TGLCGPostTransformationShader

Class TGLCGPostTransformationShader

Unit

CGPostTransformationShader

Declaration

type TGLCGPostTransformationShader = class(TGLCustomCGPostTransformationShader)

Description

no description available, TGLCustomCGPostTransformationShader description follows
no description available, TCustomCGShader description follows
no description available, TGLShader description follows

Generic, abstract shader class.<p> Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities.<br> Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TCustomCgShader
  • TGLCustomCGPostTransformationShader
  • TGLCGPostTransformationShader

Overview

Properties

Published | property TransformationPower;
Published | property TransformationTexture;

Description

Properties

Published property TransformationPower;
Published property TransformationTexture;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:00


GLScene v.1.1.2: Const3DS

Unit Const3DS

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Constants

Error3DS_NO_MEM = 'Not enough memory to complete operation.';
Error3DS_INVALID_ARG = 'The argument passed to the function is invalid.'#13+ 'Usually caused by a nil pointer or an out of range numeric argument.';
Error3DS_INVALID_DATA = 'The structure passed as an argument to the function has'#13+ 'invalid or out of range data in its fields.';
Error3DS_INVALID_CHUNK = 'An invalid Chunk structure was encountered while reading'#13+ 'the database. Usually caused by a corrupt database or file.';
Error3DS_INVALID_DATABASE = 'The database passed as an argument has not be created yet.';
Error3DS_WRONG_DATABASE = 'The database passed as an argument is the wrong kind of'#13+ 'database for this function.';
Error3DS_UNFOUND_CHUNK = 'The database is missing important file chunks needed to'#13+ 'fill out the requested structure. Usually caused by a corrupt database or file.';
Error3DS_WRONG_OBJECT = 'The Name passed to the functions exists but is not the type of object asked for.'#13+ 'For example asking for a mesh object with the GetCameraByName3DS function.';
Error3DS_NO_SUCH_FILE = 'The FileName passed as an argument for reading does not exist.';
Error3DS_INIT_FAILED = 'Failed to initialize structure passed as an argument.';
Error3DS_OPENING_FILE = 'Could not open requested file.';
Error3DS_CLOSING_FILE = 'Could not close requested file.';
Error3DS_READING_FILE = 'Error occured while reading file.';
Error3DS_CREATING_DATABASE = 'Error occured while creating database.';
Error3DS_READING_DATABASE = 'Error occured while reading database.';
Error3DS_WRITING_DATABASE = 'Error occured while writing database.';
Error3DS_WRITING_FILE = 'Error occured while writing file.';
Error3DS_STRING_TOO_LONG = 'String encountered in file structure or as an argument was longer than expected.'#13+ 'Possibly caused by an uninitialed pointer corrupt file or database.';
Error3DS_GET_FAIL = 'Failed to get new data from database.';
Error3DS_PUT_FAIL = 'Failed to add new data to the database.';
Error3DS_INVALID_INDEX = 'Invalid index %d.';
FaceCAVisable3DS = $0001;
FaceBCVisable3DS = $0002;
FaceABVisable3DS = $0004;
FaceUWrap3DS = $0008;
FaceVWrap3DS = $0010;
KeyUsesTension3DS = $01;
KeyUsesCont3DS = $02;
KeyUsesBias3DS = $04;
KeyUsesEaseTo3DS = $08;
KeyUsesEaseFrom3DS = $10;
TrackSingle3DS = $0000;
TrackLoops3DS = $0003;
TrackRepeats3DS = $0002;
TrackLockX3DS = $0008;
TrackLockY3DS = $0010;
TrackLockZ3DS = $0020;
TrackNoLinkX3DS = $0100;
TrackNoLinkY3DS = $0200;
TrackNoLinkZ3DS = $0400;
DefPoint3DS : TPoint3DS = (X: 0; Y: 0; Z: 0);
DefTextVert3DS : TTexVert3DS = (U: 0; V: 0);
DefFace3DS : TFace3DS = (v1: 0; v2: 1; v3: 2; Flag: 0);
DefTrackHeader3DS : TTrackHeader3DS = (Flags: 0; nu1: 0; nu2: 0; KeyCount: 1);
DefKeyHeader3DS : TKeyHeader3DS = (Time: 0; RFlags: 0; Tension: 0; Continuity: 0; Bias: 0; EaseTo: 0; EaseFrom: 0);
DefObjMat3DS : TObjMat3DS = (NameStr: ''; NFaces: 0; FaceIndex: nil);
DefKFRotKey3DS : TKFRotKey3DS = (Angle: 0; X: 0; Y: 0; Z: 1);
LayerFogBgnd = $100000;
NoFalloff = $0;
TopFalloff = $2;
BottomFalloff = $1;
InitNoExtras3DS = $0000;
InitVertexArray3DS = $0001;
InitTextArray3DS = $0002;
InitFaceArray3DS = $0004;
InitMatArray3DS = $0008;
InitSmoothArray3DS = $0010;
InitProcData3DS = $0020;
InitVFlagArray3DS = $0040;
RelVertexArray3ds = $0001;
RelTextArray3ds = $0002;
RelFaceArray3ds = $0004;
RelMatArray3ds = $0008;
RelSmoothArray3ds = $0010;
RelProcData3ds = $0020;
RelVFlagArray3ds = $0040;
RelAll3DS = $FFFF;
Smooth01Group3DS = $00000001;
Smooth02Group3DS = $00000002;
Smooth03Group3DS = $00000004;
Smooth04Group3DS = $00000008;
Smooth05Group3DS = $00000010;
Smooth06Group3DS = $00000020;
Smooth07Group3DS = $00000030;
Smooth08Group3DS = $00000080;
Smooth09Group3DS = $00000100;
Smooth10Group3DS = $00000200;
Smooth11Group3DS = $00000400;
Smooth12Group3DS = $00000800;
Smooth13Group3DS = $00001000;
Smooth14Group3DS = $00002000;
Smooth15Group3DS = $00004000;
Smooth16Group3DS = $00008000;
Smooth17Group3DS = $00010000;
Smooth18Group3DS = $00020000;
Smooth19Group3DS = $00040000;
Smooth20Group3DS = $00080000;
Smooth21Group3DS = $00100000;
Smooth22Group3DS = $00200000;
Smooth23Group3DS = $00400000;
Smooth24Group3DS = $00800000;
Smooth25Group3DS = $01000000;
Smooth26Group3DS = $02000000;
Smooth27Group3DS = $04000000;
Smooth28Group3DS = $08000000;
Smooth29Group3DS = $10000000;
Smooth30Group3DS = $20000000;
Smooth31Group3DS = $40000000;
Smooth32Group3DS = $80000000;
DummyName3DS = '$$$DUMMY';
KfNodeOff3DS = 1 shl 3;
KfHideNode3DS = 1 shl 11;
KfFastNode3DS = 1 shl 12;
KfNodeHasPath3DS = 1;
KfNodeAutoSmooth3DS = 1 shl 1;
KfNodeFrozen3DS = 1 shl 2;
KfMotionBlur3DS = 1 shl 4;
KfBlurBranch3DS = 1 shl 5;
KfMorphMtl3DS = 1 shl 6;
KfMorphOb3DS = 1 shl 7;
FileNameStrMax3DS = 512;
FileAttrStrMax3DS = 128;
MasterScaleMin3DS = 0;
LoShadowBiasMin3DS = 0;
HiShadowBiasMin3DS = 0;
ShadowMapSizeMin3DS = 0;
ShadowSamplesMin3DS = 0;
ShadowRangeMin3DS = 0;
ShadowFilterMin3DS = 1;
ShadowFilterMax3DS = 10;
BitMapStrMax3DS = 12;
VGradientMin3DS = 0;
VGradientMax3DS = 1;
FogMin3DS = 0;
FogMax3DS = 1;
DistanceCueMin3DS = 0;
DistanceCueMax3DS = 1;
ViewCameraStrMax3DS = 10;
MatNameStrMax3DS = 16;
MatShadingMin3DS = 0;
MatShadingMax3DS = 3;
MatACubicFMin3DS = 1;
MatACubicAMin3DS = 0;
MatACubicAMax3DS = 3;
ACubicFirst3DS = $09;
ACubicFlat3DS = $11;
PointArrayMin3DS = 3;
FaceArrayMin3DS = 1;
MshMatGroupMin3DS = 1;
MshMatGroupStrMax3DS = 16;
ProcNameStrMax3DS = 12;
DLSpotlightMin3DS = 0;
DLSpotlightMax3DS = 160;
DLLocalShadow2SMin3DS = 10;
DLLocalShadow2SMax3DS = 4096;
DLLocalShadow2FMin3DS = 1;
DLLocalShadow2FMax3DS = 10;
ColorFMin3DS = 0;
ColorFMax3DS = 1;
IntPercentageMax3DS = 100;
FloatPercentageMax3DS = 1;
MatMapNameStrMax3DS = 12;
NamedObjectStrMax3DS = 10;
NCameraFOVMin3DS = 0.00025;
NCameraFOVMax3DS = 160;
NCameraFocMin3DS = 10.7813;
NCameraFocMax3DS = 10000000;
KFHdrStrMax3DS = 12;
NodeHdrStrMax3DS = 10;
InstanceNameStrMax3DS = 10;
MorphTrackStrMax3DS = 10;
MorphSmoothMin3DS = 0;
MorphSmoothMax3DS = 360;
KFTensionMin3DS = -1;
KFTensionMax3DS = 1;
KFContinuityMin3DS = -1;
KFContinuityMax3DS = 1;
KFBiasMin3DS = -1;
KFBiasMax3DS = 1;
KFEaseToMin3DS = 0;
KFEaseToMax3DS = 1;
KFEaseFromMin3DS = 0;
KFEaseFromMax3DS = 1;
TrackHeaderKeysMin3DS = 1;
ColTrackTagMin3DS = 0;
ColTrackTagMax3DS = 1;
FOVTrackTagMin3DS = NCameraFOVMin3DS;
FOVTrackTagMax3DS = NCameraFOVMax3DS;
HotTrackTagMin3DS = 0;
HotTrackTagMax3DS = 160;
FallTrackTagMin3DS = 0;
FallTrackTagMax3DS = 160;
KNoID = -1;
TEX_DECAL = 1;
TEX_MIRROR = 1 shl 1;
TEX_UNUSED1 = 1 shl 2;
TEX_INVERT = 1 shl 3;
TEX_NOWRAP = 1 shl 4;
TEX_SAT = 1 shl 5;
TEX_ALPHA_SOURCE = 1 shl 6;
TEX_TINT = 1 shl 7;
TEX_DONT_USE_ALPHA = 1 shl 8;
TEX_RGB_TINT = 1 shl 9;
NODE_RENDOB_HIDE = 1 shl 2;
NODE_OFF = 1 shl 3;
ATKEY1 = 1 shl 4;
ATKEY2 = 1 shl 5;
ATKEY3 = 1 shl 6;
ATKEY4 = 1 shl 7;
ATKEY5 = 1 shl 8;
ATKEYFLAGS = ATKEY1 or ATKEY2 or ATKEY3 or ATKEY4 or ATKEY5;
MARK_NODE = 1 shl 9;
DISABLE_NODE = 1 shl 10;
HIDE_NODE = 1 shl 11;
FAST_NODE = 1 shl 12;
PRIMARY_NODE = 1 shl 14;
NODE_CALC_PATH = 1 shl 15;
NODE_HAS_PATH = 1;
NODE_AUTO_SMOOTH = 1 shl 1;
NODE_FROZEN = 1 shl 2;
NODE_ANI_HIDDEN = 1 shl 3;
NODE_MOTION_BLUR = 1 shl 4;
NODE_BLUR_BRANCH = 1 shl 5;
NODE_MORPH_MTL = 1 shl 6;
NODE_MORPH_OB = 1 shl 7;
NULL_CHUNK = $0000;
ChunkType = $0995;
ChunkUnique = $0996;
NotChunk = $0997;
Container = $0998;
IsChunk = $0999;
DUMMY = $FFFF;
POINT_ARRAY_ENTRY = $F110;
POINT_FLAG_ARRAY_ENTRY = $F111;
FACE_ARRAY_ENTRY = $F120;
MSH_MAT_GROUP_ENTRY = $F130;
TEX_VERTS_ENTRY = $F140;
SMOOTH_GROUP_ENTRY = $F150;
POS_TRACK_TAG_KEY = $F020;
ROT_TRACK_TAG_KEY = $F021;
SCL_TRACK_TAG_KEY = $F022;
FOV_TRACK_TAG_KEY = $F023;
ROLL_TRACK_TAG_KEY = $F024;
COL_TRACK_TAG_KEY = $F025;
MORPH_TRACK_TAG_KEY = $F026;
HOT_TRACK_TAG_KEY = $F027;
FALL_TRACK_TAG_KEY = $F028;
M3DMAGIC = $4D4D;
SMAGIC = $2D2D;
LMAGIC = $2D3D;
MLIBMAGIC = $3DAA;
MATMAGIC = $3DFF;
M3D_VERSION = $0002;
M3D_KFVERSION = $0005;
MDATA = $3D3D;
MESH_VERSION = $3D3E;
COLOR_F = $0010;
COLOR_24 = $0011;
LIN_COLOR_24 = $0012;
LIN_COLOR_F = $0013;
INT_PERCENTAGE = $0030;
FLOAT_PERCENTAGE = $0031;
MASTER_SCALE = $0100;
BIT_MAP = $1100;
USE_BIT_MAP = $1101;
SOLID_BGND = $1200;
USE_SOLID_BGND = $1201;
V_GRADIENT = $1300;
USE_V_GRADIENT = $1301;
LO_SHADOW_BIAS = $1400;
HI_SHADOW_BIAS = $1410;
SHADOW_MAP_SIZE = $1420;
SHADOW_SAMPLES = $1430;
SHADOW_RANGE = $1440;
SHADOW_FILTER = $1450;
RAY_BIAS = $1460;
O_CONSTS = $1500;
AMBIENT_LIGHT = $2100;
FOG = $2200;
USE_FOG = $2201;
FOG_BGND = $2210;
DISTANCE_CUE = $2300;
USE_DISTANCE_CUE = $2301;
LAYER_FOG = $2302;
USE_LAYER_FOG = $2303;
DCUE_BGND = $2310;
DEFAULT_VIEW = $3000;
VIEW_TOP = $3010;
VIEW_BOTTOM = $3020;
VIEW_LEFT = $3030;
VIEW_RIGHT = $3040;
VIEW_FRONT = $3050;
VIEW_BACK = $3060;
VIEW_USER = $3070;
VIEW_CAMERA = $3080;
VIEW_WINDOW = $3090;
NAMED_OBJECT = $4000;
OBJ_HIDDEN = $4010;
OBJ_VIS_LOFTER = $4011;
OBJ_DOESNT_CAST = $4012;
OBJ_MATTE = $4013;
OBJ_FAST = $4014;
OBJ_PROCEDURAL = $4015;
OBJ_FROZEN = $4016;
OBJ_DONT_RCVSHADOW = $4017;
N_TRI_OBJECT = $4100;
POINT_ARRAY = $4110;
POINT_FLAG_ARRAY = $4111;
FACE_ARRAY = $4120;
MSH_MAT_GROUP = $4130;
OLD_MAT_GROUP = $4131;
TEX_VERTS = $4140;
SMOOTH_GROUP = $4150;
MESH_MATRIX = $4160;
MESH_COLOR = $4165;
MESH_TEXTURE_INFO = $4170;
PROC_NAME = $4181;
PROC_DATA = $4182;
MSH_BOXMAP = $4190;
N_D_L_OLD = $4400;
N_CAM_OLD = $4500;
N_DIRECT_LIGHT = $4600;
DL_SPOTLIGHT = $4610;
DL_OFF = $4620;
DL_ATTENUATE = $4625;
DL_RAYSHAD = $4627;
DL_SHADOWED = $4630;
DL_LOCAL_SHADOW = $4640;
DL_LOCAL_SHADOW2 = $4641;
DL_SEE_CONE = $4650;
DL_SPOT_RECTANGULAR = $4651;
DL_SPOT_OVERSHOOT = $4652;
DL_SPOT_PROJECTOR = $4653;
DL_EXCLUDE = $4654;
DL_RANGE = $4655;
DL_SPOT_ROLL = $4656;
DL_SPOT_ASPECT = $4657;
DL_RAY_BIAS = $4658;
DL_INNER_RANGE = $4659;
DL_OUTER_RANGE = $465A;
DL_MULTIPLIER = $465B;
N_AMBIENT_LIGHT = $4680;
N_CAMERA = $4700;
CAM_SEE_CONE = $4710;
CAM_RANGES = $4720;
HIERARCHY = $4F00;
PARENT_OBJECT = $4F10;
PIVOT_OBJECT = $4F20;
PIVOT_LIMITS = $4F30;
PIVOT_ORDER = $4F40;
XLATE_RANGE = $4F50;
POLY_2D = $5000;
SHAPE_OK = $5010;
SHAPE_NOT_OK = $5011;
SHAPE_HOOK = $5020;
PATH_3D = $6000;
PATH_MATRIX = $6005;
SHAPE_2D = $6010;
M_SCALE = $6020;
M_TWIST = $6030;
M_TEETER = $6040;
M_FIT = $6050;
M_BEVEL = $6060;
XZ_CURVE = $6070;
YZ_CURVE = $6080;
INTERPCT = $6090;
DEFORM_LIMIT = $60A0;
USE_CONTOUR = $6100;
USE_TWEEN = $6110;
USE_SCALE = $6120;
USE_TWIST = $6130;
USE_TEETER = $6140;
USE_FIT = $6150;
USE_BEVEL = $6160;
VIEWPORT_LAYOUT_OLD = $7000;
VIEWPORT_DATA_OLD = $7010;
VIEWPORT_LAYOUT = $7001;
VIEWPORT_DATA = $7011;
VIEWPORT_DATA_3 = $7012;
VIEWPORT_SIZE = $7020;
NETWORK_VIEW = $7030;
XDATA_SECTION = $8000;
XDATA_ENTRY = $8001;
XDATA_APPNAME = $8002;
XDATA_STRING = $8003;
XDATA_FLOAT = $8004;
XDATA_DOUBLE = $8005;
XDATA_SHORT = $8006;
XDATA_LONG = $8007;
XDATA_VOID = $8008;
XDATA_GROUP = $8009;
XDATA_RFU6 = $800A;
XDATA_RFU5 = $800B;
XDATA_RFU4 = $800C;
XDATA_RFU3 = $800D;
XDATA_RFU2 = $800E;
XDATA_RFU1 = $800F;
PARENT_NAME = $80F0;
MAT_ENTRY = $AFFF;
MAT_NAME = $A000;
MAT_AMBIENT = $A010;
MAT_DIFFUSE = $A020;
MAT_SPECULAR = $A030;
MAT_SHININESS = $A040;
MAT_SHIN2PCT = $A041;
MAT_SHIN3PCT = $A042;
MAT_TRANSPARENCY = $A050;
MAT_XPFALL = $A052;
MAT_REFBLUR = $A053;
MAT_SELF_ILLUM = $A080;
MAT_TWO_SIDE = $A081;
MAT_DECAL = $A082;
MAT_ADDITIVE = $A083;
MAT_SELF_ILPCT = $A084;
MAT_WIRE = $A085;
MAT_SUPERSMP = $A086;
MAT_WIRESIZE = $A087;
MAT_FACEMAP = $A088;
MAT_XPFALLIN = $A08A;
MAT_PHONGSOFT = $A08C;
MAT_WIREABS = $A08E;
MAT_SHADING = $A100;
MAT_TEXMAP = $A200;
MAT_OPACMAP = $A210;
MAT_REFLMAP = $A220;
MAT_BUMPMAP = $A230;
MAT_SPECMAP = $A204;
MAT_USE_XPFALL = $A240;
MAT_USE_REFBLUR = $A250;
MAT_BUMP_PERCENT = $A252;
MAT_MAPNAME = $A300;
MAT_ACUBIC = $A310;
MAT_SXP_TEXT_DATA = $A320;
MAT_SXP_TEXT2_DATA = $A321;
MAT_SXP_OPAC_DATA = $A322;
MAT_SXP_BUMP_DATA = $A324;
MAT_SXP_SPEC_DATA = $A325;
MAT_SXP_SHIN_DATA = $A326;
MAT_SXP_SELFI_DATA = $A328;
MAT_SXP_TEXT_MASKDATA = $A32A;
MAT_SXP_TEXT2_MASKDATA = $A32C;
MAT_SXP_OPAC_MASKDATA = $A32E;
MAT_SXP_BUMP_MASKDATA = $A330;
MAT_SXP_SPEC_MASKDATA = $A332;
MAT_SXP_SHIN_MASKDATA = $A334;
MAT_SXP_SELFI_MASKDATA = $A336;
MAT_SXP_REFL_MASKDATA = $A338;
MAT_TEX2MAP = $A33A;
MAT_SHINMAP = $A33C;
MAT_SELFIMAP = $A33D;
MAT_TEXMASK = $A33E;
MAT_TEX2MASK = $A340;
MAT_OPACMASK = $A342;
MAT_BUMPMASK = $A344;
MAT_SHINMASK = $A346;
MAT_SPECMASK = $A348;
MAT_SELFIMASK = $A34A;
MAT_REFLMASK = $A34C;
MAT_MAP_TILINGOLD = $A350;
MAT_MAP_TILING = $A351;
MAT_MAP_TEXBLUR_OLD = $A352;
MAT_MAP_TEXBLUR = $A353;
MAT_MAP_USCALE = $A354;
MAT_MAP_VSCALE = $A356;
MAT_MAP_UOFFSET = $A358;
MAT_MAP_VOFFSET = $A35A;
MAT_MAP_ANG = $A35C;
MAT_MAP_COL1 = $A360;
MAT_MAP_COL2 = $A362;
MAT_MAP_RCOL = $A364;
MAT_MAP_GCOL = $A366;
MAT_MAP_BCOL = $A368;
KFDATA = $B000;
KFHDR = $B00A;
AMBIENT_NODE_TAG = $B001;
OBJECT_NODE_TAG = $B002;
CAMERA_NODE_TAG = $B003;
TARGET_NODE_TAG = $B004;
LIGHT_NODE_TAG = $B005;
L_TARGET_NODE_TAG = $B006;
SPOTLIGHT_NODE_TAG = $B007;
KFSEG = $B008;
KFCURTIME = $B009;
NODE_HDR = $B010;
INSTANCE_NAME = $B011;
PRESCALE = $B012;
PIVOT = $B013;
BOUNDBOX = $B014;
MORPH_SMOOTH = $B015;
POS_TRACK_TAG = $B020;
ROT_TRACK_TAG = $B021;
SCL_TRACK_TAG = $B022;
FOV_TRACK_TAG = $B023;
ROLL_TRACK_TAG = $B024;
COL_TRACK_TAG = $B025;
MORPH_TRACK_TAG = $B026;
HOT_TRACK_TAG = $B027;
FALL_TRACK_TAG = $B028;
HIDE_TRACK_TAG = $B029;
NODE_ID = $B030;
CMAGIC = $C23D;
C_MDRAWER = $C010;
C_TDRAWER = $C020;
C_SHPDRAWER = $C030;
C_MODDRAWER = $C040;
C_RIPDRAWER = $C050;
C_TXDRAWER = $C060;
C_PDRAWER = $C062;
C_MTLDRAWER = $C064;
C_FLIDRAWER = $C066;
C_CUBDRAWER = $C067;
C_MFILE = $C070;
C_SHPFILE = $C080;
C_MODFILE = $C090;
C_RIPFILE = $C0A0;
C_TXFILE = $C0B0;
C_PFILE = $C0B2;
C_MTLFILE = $C0B4;
C_FLIFILE = $C0B6;
C_PALFILE = $C0B8;
C_TX_STRING = $C0C0;
C_CONSTS = $C0D0;
C_SNAPS = $C0E0;
C_GRIDS = $C0F0;
C_ASNAPS = $C100;
C_GRID_RANGE = $C110;
C_RENDTYPE = $C120;
C_PROGMODE = $C130;
C_PREVMODE = $C140;
C_MODWMODE = $C150;
C_MODMODEL = $C160;
C_ALL_LINES = $C170;
C_BACK_TYPE = $C180;
C_MD_CS = $C190;
C_MD_CE = $C1A0;
C_MD_SML = $C1B0;
C_MD_SMW = $C1C0;
C_LOFT_WITH_TEXTURE = $C1C3;
C_LOFT_L_REPEAT = $C1C4;
C_LOFT_W_REPEAT = $C1C5;
C_LOFT_UV_NORMALIZE = $C1C6;
C_WELD_LOFT = $C1C7;
C_MD_PDET = $C1D0;
C_MD_SDET = $C1E0;
C_RGB_RMODE = $C1F0;
C_RGB_HIDE = $C200;
C_RGB_MAPSW = $C202;
C_RGB_TWOSIDE = $C204;
C_RGB_SHADOW = $C208;
C_RGB_AA = $C210;
C_RGB_OVW = $C220;
C_RGB_OVH = $C230;
C_RGB_PICTYPE = $C240;
C_RGB_OUTPUT = $C250;
C_RGB_TODISK = $C253;
C_RGB_COMPRESS = $C254;
C_JPEG_COMPRESSION = $C255;
C_RGB_DISPDEV = $C256;
C_RGB_HARDDEV = $C259;
C_RGB_PATH = $C25A;
C_BITMAP_DRAWER = $C25B;
C_RGB_FILE = $C260;
C_RGB_OVASPECT = $C270;
C_RGB_ANIMTYPE = $C271;
C_RENDER_ALL = $C272;
C_REND_FROM = $C273;
C_REND_TO = $C274;
C_REND_NTH = $C275;
C_PAL_TYPE = $C276;
C_RND_TURBO = $C277;
C_RND_MIP = $C278;
C_BGND_METHOD = $C279;
C_AUTO_REFLECT = $C27A;
C_VP_FROM = $C27B;
C_VP_TO = $C27C;
C_VP_NTH = $C27D;
C_REND_TSTEP = $C27E;
C_VP_TSTEP = $C27F;
C_SRDIAM = $C280;
C_SRDEG = $C290;
C_SRSEG = $C2A0;
C_SRDIR = $C2B0;
C_HETOP = $C2C0;
C_HEBOT = $C2D0;
C_HEHT = $C2E0;
C_HETURNS = $C2F0;
C_HEDEG = $C300;
C_HESEG = $C310;
C_HEDIR = $C320;
C_QUIKSTUFF = $C330;
C_SEE_LIGHTS = $C340;
C_SEE_CAMERAS = $C350;
C_SEE_3D = $C360;
C_MESHSEL = $C370;
C_MESHUNSEL = $C380;
C_POLYSEL = $C390;
C_POLYUNSEL = $C3A0;
C_SHPLOCAL = $C3A2;
C_MSHLOCAL = $C3A4;
C_NUM_FORMAT = $C3B0;
C_ARCH_DENOM = $C3C0;
C_IN_DEVICE = $C3D0;
C_MSCALE = $C3E0;
C_COMM_PORT = $C3F0;
C_TAB_BASES = $C400;
C_TAB_DIVS = $C410;
C_MASTER_SCALES = $C420;
C_SHOW_1STVERT = $C430;
C_SHAPER_OK = $C440;
C_LOFTER_OK = $C450;
C_EDITOR_OK = $C460;
C_KEYFRAMER_OK = $C470;
C_PICKSIZE = $C480;
C_MAPTYPE = $C490;
C_MAP_DISPLAY = $C4A0;
C_TILE_XY = $C4B0;
C_MAP_XYZ = $C4C0;
C_MAP_SCALE = $C4D0;
C_MAP_MATRIX_OLD = $C4E0;
C_MAP_MATRIX = $C4E1;
C_MAP_WID_HT = $C4F0;
C_OBNAME = $C500;
C_CAMNAME = $C510;
C_LTNAME = $C520;
C_CUR_MNAME = $C525;
C_CURMTL_FROM_MESH = $C526;
C_GET_SHAPE_MAKE_FACES = $C527;
C_DETAIL = $C530;
C_VERTMARK = $C540;
C_MSHAX = $C550;
C_MSHCP = $C560;
C_USERAX = $C570;
C_SHOOK = $C580;
C_RAX = $C590;
C_STAPE = $C5A0;
C_LTAPE = $C5B0;
C_ETAPE = $C5C0;
C_KTAPE = $C5C8;
C_SPHSEGS = $C5D0;
C_GEOSMOOTH = $C5E0;
C_HEMISEGS = $C5F0;
C_PRISMSEGS = $C600;
C_PRISMSIDES = $C610;
C_TUBESEGS = $C620;
C_TUBESIDES = $C630;
C_TORSEGS = $C640;
C_TORSIDES = $C650;
C_CONESIDES = $C660;
C_CONESEGS = $C661;
C_NGPARMS = $C670;
C_PTHLEVEL = $C680;
C_MSCSYM = $C690;
C_MFTSYM = $C6A0;
C_MTTSYM = $C6B0;
C_SMOOTHING = $C6C0;
C_MODICOUNT = $C6D0;
C_FONTSEL = $C6E0;
C_TESS_TYPE = $C6f0;
C_TESS_TENSION = $C6f1;
C_SEG_START = $C700;
C_SEG_END = $C705;
C_CURTIME = $C710;
C_ANIMLENGTH = $C715;
C_PV_FROM = $C720;
C_PV_TO = $C725;
C_PV_DOFNUM = $C730;
C_PV_RNG = $C735;
C_PV_NTH = $C740;
C_PV_TYPE = $C745;
C_PV_METHOD = $C750;
C_PV_FPS = $C755;
C_VTR_FRAMES = $C765;
C_VTR_HDTL = $C770;
C_VTR_HD = $C771;
C_VTR_TL = $C772;
C_VTR_IN = $C775;
C_VTR_PK = $C780;
C_VTR_SH = $C785;
C_WORK_MTLS = $C790;
C_WORK_MTLS_2 = $C792;
C_WORK_MTLS_3 = $C793;
C_WORK_MTLS_4 = $C794;
C_WORK_MTLS_5 = $CB00;
C_WORK_MTLS_6 = $CB01;
C_WORK_MTLS_7 = $CB02;
C_WORK_MTLS_8 = $CB03;
C_WORKMTL = $CB04;
C_SXP_TEXT_DATA = $CB10;
C_SXP_TEXT2_DATA = $CB20;
C_SXP_OPAC_DATA = $CB11;
C_SXP_BUMP_DATA = $CB12;
C_SXP_SPEC_DATA = $CB24;
C_SXP_SHIN_DATA = $CB13;
C_SXP_SELFI_DATA = $CB28;
C_SXP_TEXT_MASKDATA = $CB30;
C_SXP_TEXT2_MASKDATA = $CB32;
C_SXP_OPAC_MASKDATA = $CB34;
C_SXP_BUMP_MASKDATA = $CB36;
C_SXP_SPEC_MASKDATA = $CB38;
C_SXP_SHIN_MASKDATA = $CB3A;
C_SXP_SELFI_MASKDATA = $C3CB;
C_SXP_REFL_MASKDATA = $CB3E;
C_BGTYPE = $C7A1;
C_MEDTILE = $C7B0;
C_LO_CONTRAST = $C7D0;
C_HI_CONTRAST = $C7D1;
C_FROZ_DISPLAY = $C7E0;
C_BOOLWELD = $C7f0;
C_BOOLTYPE = $C7f1;
C_ANG_THRESH = $C900;
C_SS_THRESH = $C901;
C_TEXTURE_BLUR_DEFAULT = $C903;
C_MAPDRAWER = $CA00;
C_MAPDRAWER1 = $CA01;
C_MAPDRAWER2 = $CA02;
C_MAPDRAWER3 = $CA03;
C_MAPDRAWER4 = $CA04;
C_MAPDRAWER5 = $CA05;
C_MAPDRAWER6 = $CA06;
C_MAPDRAWER7 = $CA07;
C_MAPDRAWER8 = $CA08;
C_MAPDRAWER9 = $CA09;
C_MAPDRAWER_ENTRY = $CA10;
C_BACKUP_FILE = $CA20;
C_DITHER_256 = $CA21;
C_SAVE_LAST = $CA22;
C_USE_ALPHA = $CA23;
C_TGA_DEPTH = $CA24;
C_REND_FIELDS = $CA25;
C_REFLIP = $CA26;
C_SEL_ITEMTOG = $CA27;
C_SEL_RESET = $CA28;
C_STICKY_KEYINF = $CA29;
C_WELD_THRESHOLD = $CA2A;
C_ZCLIP_POINT = $CA2B;
C_ALPHA_SPLIT = $CA2C;
C_KF_SHOW_BACKFACE = $CA30;
C_OPTIMIZE_LOFT = $CA40;
C_TENS_DEFAULT = $CA42;
C_CONT_DEFAULT = $CA44;
C_BIAS_DEFAULT = $CA46;
C_DXFNAME_SRC = $CA50;
C_AUTO_WELD = $CA60;
C_AUTO_UNIFY = $CA70;
C_AUTO_SMOOTH = $CA80;
C_DXF_SMOOTH_ANG = $CA90;
C_SMOOTH_ANG = $CAA0;
C_NET_USE_VPOST = $CC00;
C_NET_USE_GAMMA = $CC10;
C_NET_FIELD_ORDER = $CC20;
C_BLUR_FRAMES = $CD00;
C_BLUR_SAMPLES = $CD10;
C_BLUR_DUR = $CD20;
C_HOT_METHOD = $CD30;
C_HOT_CHECK = $CD40;
C_PIXEL_SIZE = $CD50;
C_DISP_GAMMA = $CD60;
C_FBUF_GAMMA = $CD70;
C_FILE_OUT_GAMMA = $CD80;
C_FILE_IN_GAMMA = $CD82;
C_GAMMA_CORRECT = $CD84;
C_APPLY_DISP_GAMMA = $CD90;
C_APPLY_FBUF_GAMMA = $CDA0;
C_APPLY_FILE_GAMMA = $CDB0;
C_FORCE_WIRE = $CDC0;
C_RAY_SHADOWS = $CDD0;
C_MASTER_AMBIENT = $CDE0;
C_SUPER_SAMPLE = $CDF0;
C_OBJECT_MBLUR = $CE00;
C_MBLUR_DITHER = $CE10;
C_DITHER_24 = $CE20;
C_SUPER_BLACK = $CE30;
C_SAFE_FRAME = $CE40;
C_VIEW_PRES_RATIO = $CE50;
C_BGND_PRES_RATIO = $CE60;
C_NTH_SERIAL_NUM = $CE70;
VPDATA = $D000;
P_QUEUE_ENTRY = $D100;
P_QUEUE_IMAGE = $D110;
P_QUEUE_USEIGAMMA = $D114;
P_QUEUE_PROC = $D120;
P_QUEUE_SOLID = $D130;
P_QUEUE_GRADIENT = $D140;
P_QUEUE_KF = $D150;
P_QUEUE_MOTBLUR = $D152;
P_QUEUE_MB_REPEAT = $D153;
P_QUEUE_NONE = $D160;
P_QUEUE_RESIZE = $D180;
P_QUEUE_OFFSET = $D185;
P_QUEUE_ALIGN = $D190;
P_CUSTOM_SIZE = $D1a0;
P_ALPH_NONE = $D210;
P_ALPH_PSEUDO = $D220;
P_ALPH_OP_PSEUDO = $D221;
P_ALPH_BLUR = $D222;
P_ALPH_PCOL = $D225;
P_ALPH_C0 = $D230;
P_ALPH_OP_KEY = $D231;
P_ALPH_KCOL = $D235;
P_ALPH_OP_NOCONV = $D238;
P_ALPH_IMAGE = $D240;
P_ALPH_ALPHA = $D250;
P_ALPH_QUES = $D260;
P_ALPH_QUEIMG = $D265;
P_ALPH_CUTOFF = $D270;
P_ALPHANEG = $D280;
P_TRAN_NONE = $D300;
P_TRAN_IMAGE = $D310;
P_TRAN_FRAMES = $D312;
P_TRAN_FADEIN = $D320;
P_TRAN_FADEOUT = $D330;
P_TRANNEG = $D340;
P_RANGES = $D400;
P_PROC_DATA = $D500;
NodeTagCount = 6;
NodeTags: array[1..NodeTagCount] of Word = (TARGET_NODE_TAG, OBJECT_NODE_TAG, CAMERA_NODE_TAG, LIGHT_NODE_TAG, L_TARGET_NODE_TAG, SPOTLIGHT_NODE_TAG );

Description

Constants

Error3DS_NO_MEM = 'Not enough memory to complete operation.';
Error3DS_INVALID_ARG = 'The argument passed to the function is invalid.'#13+ 'Usually caused by a nil pointer or an out of range numeric argument.';
Error3DS_INVALID_DATA = 'The structure passed as an argument to the function has'#13+ 'invalid or out of range data in its fields.';
Error3DS_INVALID_CHUNK = 'An invalid Chunk structure was encountered while reading'#13+ 'the database. Usually caused by a corrupt database or file.';
Error3DS_INVALID_DATABASE = 'The database passed as an argument has not be created yet.';
Error3DS_WRONG_DATABASE = 'The database passed as an argument is the wrong kind of'#13+ 'database for this function.';
Error3DS_UNFOUND_CHUNK = 'The database is missing important file chunks needed to'#13+ 'fill out the requested structure. Usually caused by a corrupt database or file.';
Error3DS_WRONG_OBJECT = 'The Name passed to the functions exists but is not the type of object asked for.'#13+ 'For example asking for a mesh object with the GetCameraByName3DS function.';
Error3DS_NO_SUCH_FILE = 'The FileName passed as an argument for reading does not exist.';
Error3DS_INIT_FAILED = 'Failed to initialize structure passed as an argument.';
Error3DS_OPENING_FILE = 'Could not open requested file.';
Error3DS_CLOSING_FILE = 'Could not close requested file.';
Error3DS_READING_FILE = 'Error occured while reading file.';
Error3DS_CREATING_DATABASE = 'Error occured while creating database.';
Error3DS_READING_DATABASE = 'Error occured while reading database.';
Error3DS_WRITING_DATABASE = 'Error occured while writing database.';
Error3DS_WRITING_FILE = 'Error occured while writing file.';
Error3DS_STRING_TOO_LONG = 'String encountered in file structure or as an argument was longer than expected.'#13+ 'Possibly caused by an uninitialed pointer corrupt file or database.';
Error3DS_GET_FAIL = 'Failed to get new data from database.';
Error3DS_PUT_FAIL = 'Failed to add new data to the database.';
Error3DS_INVALID_INDEX = 'Invalid index %d.';
FaceCAVisable3DS = $0001;
FaceBCVisable3DS = $0002;
FaceABVisable3DS = $0004;
FaceUWrap3DS = $0008;
FaceVWrap3DS = $0010;
KeyUsesTension3DS = $01;
KeyUsesCont3DS = $02;
KeyUsesBias3DS = $04;
KeyUsesEaseTo3DS = $08;
KeyUsesEaseFrom3DS = $10;
TrackSingle3DS = $0000;
TrackLoops3DS = $0003;
TrackRepeats3DS = $0002;
TrackLockX3DS = $0008;
TrackLockY3DS = $0010;
TrackLockZ3DS = $0020;
TrackNoLinkX3DS = $0100;
TrackNoLinkY3DS = $0200;
TrackNoLinkZ3DS = $0400;
DefPoint3DS : TPoint3DS = (X: 0; Y: 0; Z: 0);
DefTextVert3DS : TTexVert3DS = (U: 0; V: 0);
DefFace3DS : TFace3DS = (v1: 0; v2: 1; v3: 2; Flag: 0);
DefTrackHeader3DS : TTrackHeader3DS = (Flags: 0; nu1: 0; nu2: 0; KeyCount: 1);
DefKeyHeader3DS : TKeyHeader3DS = (Time: 0; RFlags: 0; Tension: 0; Continuity: 0; Bias: 0; EaseTo: 0; EaseFrom: 0);
DefObjMat3DS : TObjMat3DS = (NameStr: ''; NFaces: 0; FaceIndex: nil);
DefKFRotKey3DS : TKFRotKey3DS = (Angle: 0; X: 0; Y: 0; Z: 1);
LayerFogBgnd = $100000;
NoFalloff = $0;
TopFalloff = $2;
BottomFalloff = $1;
InitNoExtras3DS = $0000;
InitVertexArray3DS = $0001;
InitTextArray3DS = $0002;
InitFaceArray3DS = $0004;
InitMatArray3DS = $0008;
InitSmoothArray3DS = $0010;
InitProcData3DS = $0020;
InitVFlagArray3DS = $0040;
RelVertexArray3ds = $0001;
RelTextArray3ds = $0002;
RelFaceArray3ds = $0004;
RelMatArray3ds = $0008;
RelSmoothArray3ds = $0010;
RelProcData3ds = $0020;
RelVFlagArray3ds = $0040;
RelAll3DS = $FFFF;
Smooth01Group3DS = $00000001;
Smooth02Group3DS = $00000002;
Smooth03Group3DS = $00000004;
Smooth04Group3DS = $00000008;
Smooth05Group3DS = $00000010;
Smooth06Group3DS = $00000020;
Smooth07Group3DS = $00000030;
Smooth08Group3DS = $00000080;
Smooth09Group3DS = $00000100;
Smooth10Group3DS = $00000200;
Smooth11Group3DS = $00000400;
Smooth12Group3DS = $00000800;
Smooth13Group3DS = $00001000;
Smooth14Group3DS = $00002000;
Smooth15Group3DS = $00004000;
Smooth16Group3DS = $00008000;
Smooth17Group3DS = $00010000;
Smooth18Group3DS = $00020000;
Smooth19Group3DS = $00040000;
Smooth20Group3DS = $00080000;
Smooth21Group3DS = $00100000;
Smooth22Group3DS = $00200000;
Smooth23Group3DS = $00400000;
Smooth24Group3DS = $00800000;
Smooth25Group3DS = $01000000;
Smooth26Group3DS = $02000000;
Smooth27Group3DS = $04000000;
Smooth28Group3DS = $08000000;
Smooth29Group3DS = $10000000;
Smooth30Group3DS = $20000000;
Smooth31Group3DS = $40000000;
Smooth32Group3DS = $80000000;
DummyName3DS = '$$$DUMMY';
KfNodeOff3DS = 1 shl 3;
KfHideNode3DS = 1 shl 11;
KfFastNode3DS = 1 shl 12;
KfNodeHasPath3DS = 1;
KfNodeAutoSmooth3DS = 1 shl 1;
KfNodeFrozen3DS = 1 shl 2;
KfMotionBlur3DS = 1 shl 4;
KfBlurBranch3DS = 1 shl 5;
KfMorphMtl3DS = 1 shl 6;
KfMorphOb3DS = 1 shl 7;
FileNameStrMax3DS = 512;
FileAttrStrMax3DS = 128;
MasterScaleMin3DS = 0;
LoShadowBiasMin3DS = 0;
HiShadowBiasMin3DS = 0;
ShadowMapSizeMin3DS = 0;
ShadowSamplesMin3DS = 0;
ShadowRangeMin3DS = 0;
ShadowFilterMin3DS = 1;
ShadowFilterMax3DS = 10;
BitMapStrMax3DS = 12;
VGradientMin3DS = 0;
VGradientMax3DS = 1;
FogMin3DS = 0;
FogMax3DS = 1;
DistanceCueMin3DS = 0;
DistanceCueMax3DS = 1;
ViewCameraStrMax3DS = 10;
MatNameStrMax3DS = 16;
MatShadingMin3DS = 0;
MatShadingMax3DS = 3;
MatACubicFMin3DS = 1;
MatACubicAMin3DS = 0;
MatACubicAMax3DS = 3;
ACubicFirst3DS = $09;
ACubicFlat3DS = $11;
PointArrayMin3DS = 3;
FaceArrayMin3DS = 1;
MshMatGroupMin3DS = 1;
MshMatGroupStrMax3DS = 16;
ProcNameStrMax3DS = 12;
DLSpotlightMin3DS = 0;
DLSpotlightMax3DS = 160;
DLLocalShadow2SMin3DS = 10;
DLLocalShadow2SMax3DS = 4096;
DLLocalShadow2FMin3DS = 1;
DLLocalShadow2FMax3DS = 10;
ColorFMin3DS = 0;
ColorFMax3DS = 1;
IntPercentageMax3DS = 100;
FloatPercentageMax3DS = 1;
MatMapNameStrMax3DS = 12;
NamedObjectStrMax3DS = 10;
NCameraFOVMin3DS = 0.00025;
NCameraFOVMax3DS = 160;
NCameraFocMin3DS = 10.7813;
NCameraFocMax3DS = 10000000;
KFHdrStrMax3DS = 12;
NodeHdrStrMax3DS = 10;
InstanceNameStrMax3DS = 10;
MorphTrackStrMax3DS = 10;
MorphSmoothMin3DS = 0;
MorphSmoothMax3DS = 360;
KFTensionMin3DS = -1;
KFTensionMax3DS = 1;
KFContinuityMin3DS = -1;
KFContinuityMax3DS = 1;
KFBiasMin3DS = -1;
KFBiasMax3DS = 1;
KFEaseToMin3DS = 0;
KFEaseToMax3DS = 1;
KFEaseFromMin3DS = 0;
KFEaseFromMax3DS = 1;
TrackHeaderKeysMin3DS = 1;
ColTrackTagMin3DS = 0;
ColTrackTagMax3DS = 1;
FOVTrackTagMin3DS = NCameraFOVMin3DS;
FOVTrackTagMax3DS = NCameraFOVMax3DS;
HotTrackTagMin3DS = 0;
HotTrackTagMax3DS = 160;
FallTrackTagMin3DS = 0;
FallTrackTagMax3DS = 160;
KNoID = -1;
TEX_DECAL = 1;
TEX_MIRROR = 1 shl 1;
TEX_UNUSED1 = 1 shl 2;
TEX_INVERT = 1 shl 3;
TEX_NOWRAP = 1 shl 4;
TEX_SAT = 1 shl 5;
TEX_ALPHA_SOURCE = 1 shl 6;
TEX_TINT = 1 shl 7;
TEX_DONT_USE_ALPHA = 1 shl 8;
TEX_RGB_TINT = 1 shl 9;
NODE_RENDOB_HIDE = 1 shl 2;
NODE_OFF = 1 shl 3;
ATKEY1 = 1 shl 4;
ATKEY2 = 1 shl 5;
ATKEY3 = 1 shl 6;
ATKEY4 = 1 shl 7;
ATKEY5 = 1 shl 8;
ATKEYFLAGS = ATKEY1 or ATKEY2 or ATKEY3 or ATKEY4 or ATKEY5;
MARK_NODE = 1 shl 9;
DISABLE_NODE = 1 shl 10;
HIDE_NODE = 1 shl 11;
FAST_NODE = 1 shl 12;
PRIMARY_NODE = 1 shl 14;
NODE_CALC_PATH = 1 shl 15;
NODE_HAS_PATH = 1;
NODE_AUTO_SMOOTH = 1 shl 1;
NODE_FROZEN = 1 shl 2;
NODE_ANI_HIDDEN = 1 shl 3;
NODE_MOTION_BLUR = 1 shl 4;
NODE_BLUR_BRANCH = 1 shl 5;
NODE_MORPH_MTL = 1 shl 6;
NODE_MORPH_OB = 1 shl 7;
NULL_CHUNK = $0000;
ChunkType = $0995;
ChunkUnique = $0996;
NotChunk = $0997;
Container = $0998;
IsChunk = $0999;
DUMMY = $FFFF;
POINT_ARRAY_ENTRY = $F110;
POINT_FLAG_ARRAY_ENTRY = $F111;
FACE_ARRAY_ENTRY = $F120;
MSH_MAT_GROUP_ENTRY = $F130;
TEX_VERTS_ENTRY = $F140;
SMOOTH_GROUP_ENTRY = $F150;
POS_TRACK_TAG_KEY = $F020;
ROT_TRACK_TAG_KEY = $F021;
SCL_TRACK_TAG_KEY = $F022;
FOV_TRACK_TAG_KEY = $F023;
ROLL_TRACK_TAG_KEY = $F024;
COL_TRACK_TAG_KEY = $F025;
MORPH_TRACK_TAG_KEY = $F026;
HOT_TRACK_TAG_KEY = $F027;
FALL_TRACK_TAG_KEY = $F028;
M3DMAGIC = $4D4D;
SMAGIC = $2D2D;
LMAGIC = $2D3D;
MLIBMAGIC = $3DAA;
MATMAGIC = $3DFF;
M3D_VERSION = $0002;
M3D_KFVERSION = $0005;
MDATA = $3D3D;
MESH_VERSION = $3D3E;
COLOR_F = $0010;
COLOR_24 = $0011;
LIN_COLOR_24 = $0012;
LIN_COLOR_F = $0013;
INT_PERCENTAGE = $0030;
FLOAT_PERCENTAGE = $0031;
MASTER_SCALE = $0100;
BIT_MAP = $1100;
USE_BIT_MAP = $1101;
SOLID_BGND = $1200;
USE_SOLID_BGND = $1201;
V_GRADIENT = $1300;
USE_V_GRADIENT = $1301;
LO_SHADOW_BIAS = $1400;
HI_SHADOW_BIAS = $1410;
SHADOW_MAP_SIZE = $1420;
SHADOW_SAMPLES = $1430;
SHADOW_RANGE = $1440;
SHADOW_FILTER = $1450;
RAY_BIAS = $1460;
O_CONSTS = $1500;
AMBIENT_LIGHT = $2100;
FOG = $2200;
USE_FOG = $2201;
FOG_BGND = $2210;
DISTANCE_CUE = $2300;
USE_DISTANCE_CUE = $2301;
LAYER_FOG = $2302;
USE_LAYER_FOG = $2303;
DCUE_BGND = $2310;
DEFAULT_VIEW = $3000;
VIEW_TOP = $3010;
VIEW_BOTTOM = $3020;
VIEW_LEFT = $3030;
VIEW_RIGHT = $3040;
VIEW_FRONT = $3050;
VIEW_BACK = $3060;
VIEW_USER = $3070;
VIEW_CAMERA = $3080;
VIEW_WINDOW = $3090;
NAMED_OBJECT = $4000;
OBJ_HIDDEN = $4010;
OBJ_VIS_LOFTER = $4011;
OBJ_DOESNT_CAST = $4012;
OBJ_MATTE = $4013;
OBJ_FAST = $4014;
OBJ_PROCEDURAL = $4015;
OBJ_FROZEN = $4016;
OBJ_DONT_RCVSHADOW = $4017;
N_TRI_OBJECT = $4100;
POINT_ARRAY = $4110;
POINT_FLAG_ARRAY = $4111;
FACE_ARRAY = $4120;
MSH_MAT_GROUP = $4130;
OLD_MAT_GROUP = $4131;
TEX_VERTS = $4140;
SMOOTH_GROUP = $4150;
MESH_MATRIX = $4160;
MESH_COLOR = $4165;
MESH_TEXTURE_INFO = $4170;
PROC_NAME = $4181;
PROC_DATA = $4182;
MSH_BOXMAP = $4190;
N_D_L_OLD = $4400;
N_CAM_OLD = $4500;
N_DIRECT_LIGHT = $4600;
DL_SPOTLIGHT = $4610;
DL_OFF = $4620;
DL_ATTENUATE = $4625;
DL_RAYSHAD = $4627;
DL_SHADOWED = $4630;
DL_LOCAL_SHADOW = $4640;
DL_LOCAL_SHADOW2 = $4641;
DL_SEE_CONE = $4650;
DL_SPOT_RECTANGULAR = $4651;
DL_SPOT_OVERSHOOT = $4652;
DL_SPOT_PROJECTOR = $4653;
DL_EXCLUDE = $4654;
DL_RANGE = $4655;
DL_SPOT_ROLL = $4656;
DL_SPOT_ASPECT = $4657;
DL_RAY_BIAS = $4658;
DL_INNER_RANGE = $4659;
DL_OUTER_RANGE = $465A;
DL_MULTIPLIER = $465B;
N_AMBIENT_LIGHT = $4680;
N_CAMERA = $4700;
CAM_SEE_CONE = $4710;
CAM_RANGES = $4720;
HIERARCHY = $4F00;
PARENT_OBJECT = $4F10;
PIVOT_OBJECT = $4F20;
PIVOT_LIMITS = $4F30;
PIVOT_ORDER = $4F40;
XLATE_RANGE = $4F50;
POLY_2D = $5000;
SHAPE_OK = $5010;
SHAPE_NOT_OK = $5011;
SHAPE_HOOK = $5020;
PATH_3D = $6000;
PATH_MATRIX = $6005;
SHAPE_2D = $6010;
M_SCALE = $6020;
M_TWIST = $6030;
M_TEETER = $6040;
M_FIT = $6050;
M_BEVEL = $6060;
XZ_CURVE = $6070;
YZ_CURVE = $6080;
INTERPCT = $6090;
DEFORM_LIMIT = $60A0;
USE_CONTOUR = $6100;
USE_TWEEN = $6110;
USE_SCALE = $6120;
USE_TWIST = $6130;
USE_TEETER = $6140;
USE_FIT = $6150;
USE_BEVEL = $6160;
VIEWPORT_LAYOUT_OLD = $7000;
VIEWPORT_DATA_OLD = $7010;
VIEWPORT_LAYOUT = $7001;
VIEWPORT_DATA = $7011;
VIEWPORT_DATA_3 = $7012;
VIEWPORT_SIZE = $7020;
NETWORK_VIEW = $7030;
XDATA_SECTION = $8000;
XDATA_ENTRY = $8001;
XDATA_APPNAME = $8002;
XDATA_STRING = $8003;
XDATA_FLOAT = $8004;
XDATA_DOUBLE = $8005;
XDATA_SHORT = $8006;
XDATA_LONG = $8007;
XDATA_VOID = $8008;
XDATA_GROUP = $8009;
XDATA_RFU6 = $800A;
XDATA_RFU5 = $800B;
XDATA_RFU4 = $800C;
XDATA_RFU3 = $800D;
XDATA_RFU2 = $800E;
XDATA_RFU1 = $800F;
PARENT_NAME = $80F0;
MAT_ENTRY = $AFFF;
MAT_NAME = $A000;
MAT_AMBIENT = $A010;
MAT_DIFFUSE = $A020;
MAT_SPECULAR = $A030;
MAT_SHININESS = $A040;
MAT_SHIN2PCT = $A041;
MAT_SHIN3PCT = $A042;
MAT_TRANSPARENCY = $A050;
MAT_XPFALL = $A052;
MAT_REFBLUR = $A053;
MAT_SELF_ILLUM = $A080;
MAT_TWO_SIDE = $A081;
MAT_DECAL = $A082;
MAT_ADDITIVE = $A083;
MAT_SELF_ILPCT = $A084;
MAT_WIRE = $A085;
MAT_SUPERSMP = $A086;
MAT_WIRESIZE = $A087;
MAT_FACEMAP = $A088;
MAT_XPFALLIN = $A08A;
MAT_PHONGSOFT = $A08C;
MAT_WIREABS = $A08E;
MAT_SHADING = $A100;
MAT_TEXMAP = $A200;
MAT_OPACMAP = $A210;
MAT_REFLMAP = $A220;
MAT_BUMPMAP = $A230;
MAT_SPECMAP = $A204;
MAT_USE_XPFALL = $A240;
MAT_USE_REFBLUR = $A250;
MAT_BUMP_PERCENT = $A252;
MAT_MAPNAME = $A300;
MAT_ACUBIC = $A310;
MAT_SXP_TEXT_DATA = $A320;
MAT_SXP_TEXT2_DATA = $A321;
MAT_SXP_OPAC_DATA = $A322;
MAT_SXP_BUMP_DATA = $A324;
MAT_SXP_SPEC_DATA = $A325;
MAT_SXP_SHIN_DATA = $A326;
MAT_SXP_SELFI_DATA = $A328;
MAT_SXP_TEXT_MASKDATA = $A32A;
MAT_SXP_TEXT2_MASKDATA = $A32C;
MAT_SXP_OPAC_MASKDATA = $A32E;
MAT_SXP_BUMP_MASKDATA = $A330;
MAT_SXP_SPEC_MASKDATA = $A332;
MAT_SXP_SHIN_MASKDATA = $A334;
MAT_SXP_SELFI_MASKDATA = $A336;
MAT_SXP_REFL_MASKDATA = $A338;
MAT_TEX2MAP = $A33A;
MAT_SHINMAP = $A33C;
MAT_SELFIMAP = $A33D;
MAT_TEXMASK = $A33E;
MAT_TEX2MASK = $A340;
MAT_OPACMASK = $A342;
MAT_BUMPMASK = $A344;
MAT_SHINMASK = $A346;
MAT_SPECMASK = $A348;
MAT_SELFIMASK = $A34A;
MAT_REFLMASK = $A34C;
MAT_MAP_TILINGOLD = $A350;
MAT_MAP_TILING = $A351;
MAT_MAP_TEXBLUR_OLD = $A352;
MAT_MAP_TEXBLUR = $A353;
MAT_MAP_USCALE = $A354;
MAT_MAP_VSCALE = $A356;
MAT_MAP_UOFFSET = $A358;
MAT_MAP_VOFFSET = $A35A;
MAT_MAP_ANG = $A35C;
MAT_MAP_COL1 = $A360;
MAT_MAP_COL2 = $A362;
MAT_MAP_RCOL = $A364;
MAT_MAP_GCOL = $A366;
MAT_MAP_BCOL = $A368;
KFDATA = $B000;
KFHDR = $B00A;
AMBIENT_NODE_TAG = $B001;
OBJECT_NODE_TAG = $B002;
CAMERA_NODE_TAG = $B003;
TARGET_NODE_TAG = $B004;
LIGHT_NODE_TAG = $B005;
L_TARGET_NODE_TAG = $B006;
SPOTLIGHT_NODE_TAG = $B007;
KFSEG = $B008;
KFCURTIME = $B009;
NODE_HDR = $B010;
INSTANCE_NAME = $B011;
PRESCALE = $B012;
PIVOT = $B013;
BOUNDBOX = $B014;
MORPH_SMOOTH = $B015;
POS_TRACK_TAG = $B020;
ROT_TRACK_TAG = $B021;
SCL_TRACK_TAG = $B022;
FOV_TRACK_TAG = $B023;
ROLL_TRACK_TAG = $B024;
COL_TRACK_TAG = $B025;
MORPH_TRACK_TAG = $B026;
HOT_TRACK_TAG = $B027;
FALL_TRACK_TAG = $B028;
HIDE_TRACK_TAG = $B029;
NODE_ID = $B030;
CMAGIC = $C23D;
C_MDRAWER = $C010;
C_TDRAWER = $C020;
C_SHPDRAWER = $C030;
C_MODDRAWER = $C040;
C_RIPDRAWER = $C050;
C_TXDRAWER = $C060;
C_PDRAWER = $C062;
C_MTLDRAWER = $C064;
C_FLIDRAWER = $C066;
C_CUBDRAWER = $C067;
C_MFILE = $C070;
C_SHPFILE = $C080;
C_MODFILE = $C090;
C_RIPFILE = $C0A0;
C_TXFILE = $C0B0;
C_PFILE = $C0B2;
C_MTLFILE = $C0B4;
C_FLIFILE = $C0B6;
C_PALFILE = $C0B8;
C_TX_STRING = $C0C0;
C_CONSTS = $C0D0;
C_SNAPS = $C0E0;
C_GRIDS = $C0F0;
C_ASNAPS = $C100;
C_GRID_RANGE = $C110;
C_RENDTYPE = $C120;
C_PROGMODE = $C130;
C_PREVMODE = $C140;
C_MODWMODE = $C150;
C_MODMODEL = $C160;
C_ALL_LINES = $C170;
C_BACK_TYPE = $C180;
C_MD_CS = $C190;
C_MD_CE = $C1A0;
C_MD_SML = $C1B0;
C_MD_SMW = $C1C0;
C_LOFT_WITH_TEXTURE = $C1C3;
C_LOFT_L_REPEAT = $C1C4;
C_LOFT_W_REPEAT = $C1C5;
C_LOFT_UV_NORMALIZE = $C1C6;
C_WELD_LOFT = $C1C7;
C_MD_PDET = $C1D0;
C_MD_SDET = $C1E0;
C_RGB_RMODE = $C1F0;
C_RGB_HIDE = $C200;
C_RGB_MAPSW = $C202;
C_RGB_TWOSIDE = $C204;
C_RGB_SHADOW = $C208;
C_RGB_AA = $C210;
C_RGB_OVW = $C220;
C_RGB_OVH = $C230;
C_RGB_PICTYPE = $C240;
C_RGB_OUTPUT = $C250;
C_RGB_TODISK = $C253;
C_RGB_COMPRESS = $C254;
C_JPEG_COMPRESSION = $C255;
C_RGB_DISPDEV = $C256;
C_RGB_HARDDEV = $C259;
C_RGB_PATH = $C25A;
C_BITMAP_DRAWER = $C25B;
C_RGB_FILE = $C260;
C_RGB_OVASPECT = $C270;
C_RGB_ANIMTYPE = $C271;
C_RENDER_ALL = $C272;
C_REND_FROM = $C273;
C_REND_TO = $C274;
C_REND_NTH = $C275;
C_PAL_TYPE = $C276;
C_RND_TURBO = $C277;
C_RND_MIP = $C278;
C_BGND_METHOD = $C279;
C_AUTO_REFLECT = $C27A;
C_VP_FROM = $C27B;
C_VP_TO = $C27C;
C_VP_NTH = $C27D;
C_REND_TSTEP = $C27E;
C_VP_TSTEP = $C27F;
C_SRDIAM = $C280;
C_SRDEG = $C290;
C_SRSEG = $C2A0;
C_SRDIR = $C2B0;
C_HETOP = $C2C0;
C_HEBOT = $C2D0;
C_HEHT = $C2E0;
C_HETURNS = $C2F0;
C_HEDEG = $C300;
C_HESEG = $C310;
C_HEDIR = $C320;
C_QUIKSTUFF = $C330;
C_SEE_LIGHTS = $C340;
C_SEE_CAMERAS = $C350;
C_SEE_3D = $C360;
C_MESHSEL = $C370;
C_MESHUNSEL = $C380;
C_POLYSEL = $C390;
C_POLYUNSEL = $C3A0;
C_SHPLOCAL = $C3A2;
C_MSHLOCAL = $C3A4;
C_NUM_FORMAT = $C3B0;
C_ARCH_DENOM = $C3C0;
C_IN_DEVICE = $C3D0;
C_MSCALE = $C3E0;
C_COMM_PORT = $C3F0;
C_TAB_BASES = $C400;
C_TAB_DIVS = $C410;
C_MASTER_SCALES = $C420;
C_SHOW_1STVERT = $C430;
C_SHAPER_OK = $C440;
C_LOFTER_OK = $C450;
C_EDITOR_OK = $C460;
C_KEYFRAMER_OK = $C470;
C_PICKSIZE = $C480;
C_MAPTYPE = $C490;
C_MAP_DISPLAY = $C4A0;
C_TILE_XY = $C4B0;
C_MAP_XYZ = $C4C0;
C_MAP_SCALE = $C4D0;
C_MAP_MATRIX_OLD = $C4E0;
C_MAP_MATRIX = $C4E1;
C_MAP_WID_HT = $C4F0;
C_OBNAME = $C500;
C_CAMNAME = $C510;
C_LTNAME = $C520;
C_CUR_MNAME = $C525;
C_CURMTL_FROM_MESH = $C526;
C_GET_SHAPE_MAKE_FACES = $C527;
C_DETAIL = $C530;
C_VERTMARK = $C540;
C_MSHAX = $C550;
C_MSHCP = $C560;
C_USERAX = $C570;
C_SHOOK = $C580;
C_RAX = $C590;
C_STAPE = $C5A0;
C_LTAPE = $C5B0;
C_ETAPE = $C5C0;
C_KTAPE = $C5C8;
C_SPHSEGS = $C5D0;
C_GEOSMOOTH = $C5E0;
C_HEMISEGS = $C5F0;
C_PRISMSEGS = $C600;
C_PRISMSIDES = $C610;
C_TUBESEGS = $C620;
C_TUBESIDES = $C630;
C_TORSEGS = $C640;
C_TORSIDES = $C650;
C_CONESIDES = $C660;
C_CONESEGS = $C661;
C_NGPARMS = $C670;
C_PTHLEVEL = $C680;
C_MSCSYM = $C690;
C_MFTSYM = $C6A0;
C_MTTSYM = $C6B0;
C_SMOOTHING = $C6C0;
C_MODICOUNT = $C6D0;
C_FONTSEL = $C6E0;
C_TESS_TYPE = $C6f0;
C_TESS_TENSION = $C6f1;
C_SEG_START = $C700;
C_SEG_END = $C705;
C_CURTIME = $C710;
C_ANIMLENGTH = $C715;
C_PV_FROM = $C720;
C_PV_TO = $C725;
C_PV_DOFNUM = $C730;
C_PV_RNG = $C735;
C_PV_NTH = $C740;
C_PV_TYPE = $C745;
C_PV_METHOD = $C750;
C_PV_FPS = $C755;
C_VTR_FRAMES = $C765;
C_VTR_HDTL = $C770;
C_VTR_HD = $C771;
C_VTR_TL = $C772;
C_VTR_IN = $C775;
C_VTR_PK = $C780;
C_VTR_SH = $C785;
C_WORK_MTLS = $C790;
C_WORK_MTLS_2 = $C792;
C_WORK_MTLS_3 = $C793;
C_WORK_MTLS_4 = $C794;
C_WORK_MTLS_5 = $CB00;
C_WORK_MTLS_6 = $CB01;
C_WORK_MTLS_7 = $CB02;
C_WORK_MTLS_8 = $CB03;
C_WORKMTL = $CB04;
C_SXP_TEXT_DATA = $CB10;
C_SXP_TEXT2_DATA = $CB20;
C_SXP_OPAC_DATA = $CB11;
C_SXP_BUMP_DATA = $CB12;
C_SXP_SPEC_DATA = $CB24;
C_SXP_SHIN_DATA = $CB13;
C_SXP_SELFI_DATA = $CB28;
C_SXP_TEXT_MASKDATA = $CB30;
C_SXP_TEXT2_MASKDATA = $CB32;
C_SXP_OPAC_MASKDATA = $CB34;
C_SXP_BUMP_MASKDATA = $CB36;
C_SXP_SPEC_MASKDATA = $CB38;
C_SXP_SHIN_MASKDATA = $CB3A;
C_SXP_SELFI_MASKDATA = $C3CB;
C_SXP_REFL_MASKDATA = $CB3E;
C_BGTYPE = $C7A1;
C_MEDTILE = $C7B0;
C_LO_CONTRAST = $C7D0;
C_HI_CONTRAST = $C7D1;
C_FROZ_DISPLAY = $C7E0;
C_BOOLWELD = $C7f0;
C_BOOLTYPE = $C7f1;
C_ANG_THRESH = $C900;
C_SS_THRESH = $C901;
C_TEXTURE_BLUR_DEFAULT = $C903;
C_MAPDRAWER = $CA00;
C_MAPDRAWER1 = $CA01;
C_MAPDRAWER2 = $CA02;
C_MAPDRAWER3 = $CA03;
C_MAPDRAWER4 = $CA04;
C_MAPDRAWER5 = $CA05;
C_MAPDRAWER6 = $CA06;
C_MAPDRAWER7 = $CA07;
C_MAPDRAWER8 = $CA08;
C_MAPDRAWER9 = $CA09;
C_MAPDRAWER_ENTRY = $CA10;
C_BACKUP_FILE = $CA20;
C_DITHER_256 = $CA21;
C_SAVE_LAST = $CA22;
C_USE_ALPHA = $CA23;
C_TGA_DEPTH = $CA24;
C_REND_FIELDS = $CA25;
C_REFLIP = $CA26;
C_SEL_ITEMTOG = $CA27;
C_SEL_RESET = $CA28;
C_STICKY_KEYINF = $CA29;
C_WELD_THRESHOLD = $CA2A;
C_ZCLIP_POINT = $CA2B;
C_ALPHA_SPLIT = $CA2C;
C_KF_SHOW_BACKFACE = $CA30;
C_OPTIMIZE_LOFT = $CA40;
C_TENS_DEFAULT = $CA42;
C_CONT_DEFAULT = $CA44;
C_BIAS_DEFAULT = $CA46;
C_DXFNAME_SRC = $CA50;
C_AUTO_WELD = $CA60;
C_AUTO_UNIFY = $CA70;
C_AUTO_SMOOTH = $CA80;
C_DXF_SMOOTH_ANG = $CA90;
C_SMOOTH_ANG = $CAA0;
C_NET_USE_VPOST = $CC00;
C_NET_USE_GAMMA = $CC10;
C_NET_FIELD_ORDER = $CC20;
C_BLUR_FRAMES = $CD00;
C_BLUR_SAMPLES = $CD10;
C_BLUR_DUR = $CD20;
C_HOT_METHOD = $CD30;
C_HOT_CHECK = $CD40;
C_PIXEL_SIZE = $CD50;
C_DISP_GAMMA = $CD60;
C_FBUF_GAMMA = $CD70;
C_FILE_OUT_GAMMA = $CD80;
C_FILE_IN_GAMMA = $CD82;
C_GAMMA_CORRECT = $CD84;
C_APPLY_DISP_GAMMA = $CD90;
C_APPLY_FBUF_GAMMA = $CDA0;
C_APPLY_FILE_GAMMA = $CDB0;
C_FORCE_WIRE = $CDC0;
C_RAY_SHADOWS = $CDD0;
C_MASTER_AMBIENT = $CDE0;
C_SUPER_SAMPLE = $CDF0;
C_OBJECT_MBLUR = $CE00;
C_MBLUR_DITHER = $CE10;
C_DITHER_24 = $CE20;
C_SUPER_BLACK = $CE30;
C_SAFE_FRAME = $CE40;
C_VIEW_PRES_RATIO = $CE50;
C_BGND_PRES_RATIO = $CE60;
C_NTH_SERIAL_NUM = $CE70;
VPDATA = $D000;
P_QUEUE_ENTRY = $D100;
P_QUEUE_IMAGE = $D110;
P_QUEUE_USEIGAMMA = $D114;
P_QUEUE_PROC = $D120;
P_QUEUE_SOLID = $D130;
P_QUEUE_GRADIENT = $D140;
P_QUEUE_KF = $D150;
P_QUEUE_MOTBLUR = $D152;
P_QUEUE_MB_REPEAT = $D153;
P_QUEUE_NONE = $D160;
P_QUEUE_RESIZE = $D180;
P_QUEUE_OFFSET = $D185;
P_QUEUE_ALIGN = $D190;
P_CUSTOM_SIZE = $D1a0;
P_ALPH_NONE = $D210;
P_ALPH_PSEUDO = $D220;
P_ALPH_OP_PSEUDO = $D221;
P_ALPH_BLUR = $D222;
P_ALPH_PCOL = $D225;
P_ALPH_C0 = $D230;
P_ALPH_OP_KEY = $D231;
P_ALPH_KCOL = $D235;
P_ALPH_OP_NOCONV = $D238;
P_ALPH_IMAGE = $D240;
P_ALPH_ALPHA = $D250;
P_ALPH_QUES = $D260;
P_ALPH_QUEIMG = $D265;
P_ALPH_CUTOFF = $D270;
P_ALPHANEG = $D280;
P_TRAN_NONE = $D300;
P_TRAN_IMAGE = $D310;
P_TRAN_FRAMES = $D312;
P_TRAN_FADEIN = $D320;
P_TRAN_FADEOUT = $D330;
P_TRANNEG = $D340;
P_RANGES = $D400;
P_PROC_DATA = $D500;
NodeTagCount = 6;
NodeTags: array[1..NodeTagCount] of Word = (TARGET_NODE_TAG, OBJECT_NODE_TAG, CAMERA_NODE_TAG, LIGHT_NODE_TAG, L_TARGET_NODE_TAG, SPOTLIGHT_NODE_TAG );
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:01


GLScene v.1.1.2: CurvesAndSurfaces

Unit CurvesAndSurfaces

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

CurvesAndSurfaces<p>

Bezier and B-Spline Curve and Surface Routines.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>31/03/07 - DaStr - Added $I GLScene.inc <li>11/05/04 - SG - Some fixes for BSpline calculations (rational BSplines are still still broken). Minor knot vector changes. <li>20/08/03 - SG - Removed weights realizing it's an inefficient way to do things, control points should be weighted before being used to calculate a surface or curve. <li>18/08/03 - SG - Added weights to calculations. <li>17/07/03 - SG - Added surface routines. Minor changes to procedure parameters. <li>10/07/03 - SG - Creation </ul></font>

Overview

Functions and Procedures

function BezierCurvePoint(t : single; n : integer; cp : PAffineVectorArray) : TAffineVector;
function BezierSurfacePoint(s,t : single; m,n : integer; cp : PAffineVectorArray) : TAffineVector;
procedure GenerateBezierCurve(Steps : Integer; ControlPoints, Vertices : TAffineVectorList);
procedure GenerateBezierSurface(Steps, Width, Height : Integer; ControlPoints, Vertices : TAffineVectorList);
function BSplinePoint(t : single; n,k : integer; knots : PSingleArray; cp : PAffineVectorArray) : TAffineVector;
function BSplineSurfacePoint(s,t : single; m,n,k1,k2 : integer; uknots, vknots : PSingleArray; cp : PAffineVectorArray) : TAffineVector;
procedure GenerateBSpline(Steps,Order : Integer; KnotVector : TSingleList; ControlPoints, Vertices : TAffineVectorList);
procedure GenerateBSplineSurface(Steps, UOrder, VOrder, Width, Height : Integer; UKnotVector, VKnotVector : TSingleList; ControlPoints, Vertices : TAffineVectorList);
procedure GenerateKnotVector(KnotVector : TSingleList; NumberOfPoints, Order : Integer; Continuity : TBSplineContinuity);

Types

TBSplineContinuity = (...);

Description

Functions and Procedures

function BezierCurvePoint(t : single; n : integer; cp : PAffineVectorArray) : TAffineVector;
function BezierSurfacePoint(s,t : single; m,n : integer; cp : PAffineVectorArray) : TAffineVector;
procedure GenerateBezierCurve(Steps : Integer; ControlPoints, Vertices : TAffineVectorList);
procedure GenerateBezierSurface(Steps, Width, Height : Integer; ControlPoints, Vertices : TAffineVectorList);
function BSplinePoint(t : single; n,k : integer; knots : PSingleArray; cp : PAffineVectorArray) : TAffineVector;
function BSplineSurfacePoint(s,t : single; m,n,k1,k2 : integer; uknots, vknots : PSingleArray; cp : PAffineVectorArray) : TAffineVector;
procedure GenerateBSpline(Steps,Order : Integer; KnotVector : TSingleList; ControlPoints, Vertices : TAffineVectorList);
procedure GenerateBSplineSurface(Steps, UOrder, VOrder, Width, Height : Integer; UKnotVector, VKnotVector : TSingleList; ControlPoints, Vertices : TAffineVectorList);
procedure GenerateKnotVector(KnotVector : TSingleList; NumberOfPoints, Order : Integer; Continuity : TBSplineContinuity);

Types

TBSplineContinuity = (...);
Values
  • bscUniformNonPeriodic:
  • bscUniformPeriodic:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:01


GLScene v.1.1.2: DDSImage

Unit DDSImage

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

DDSImage<p> Alternative for DDS unit with more supported formats of flat image: Alpha8, Luminance8, R3G3B2, RGB5A1, RGBA4, Alpha8Luminance8, Luminance16, R5G6B5, RGB8, R10G10B10A2, RGBA8, RGBA16, R16F, RGBA16F, R32F, RGBA32F, GR16, GR16F, GR32F, Compressed RGB S3TC DXT1, Compressed RGBA S3TC DXT1, Compressed RGBA S3TC DXT3, Compressed RGBA S3TC DXT5 But it down color to RGBA8 because becomes to TGLBitmap Good for preview picture in OpenDialog, so you may include both DDSImage (preview) and GLFileDDS (loading)

<b>History : </b><font size=-1><ul> <li>23/10/10 - Yar - Removed PBuffer <li>23/08/10 - Yar - Changes after PBuffer upgrade <li>20/05/10 - Yar - Fixes for Linux x64 <li>21/03/10 - Yar - Added Linux support (thanks to Rustam Asmandiarov aka Predator) <li>24/01/10 - Yar - Improved FPC compatibility <li>21/01/10 - Yar - Creation </ul><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TDDSImage |
Class EDDSException |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:01


GLScene v.1.1.2: DDSImage: Class TDDSImage

Class TDDSImage

Unit

DDSImage

Declaration

type TDDSImage = class(TGLBitmap)

Description

no description available, TGLBitmap description follows

Hierarchy

  • TDDSImage

Overview

Methods

Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public procedure LoadFromStream(stream: TStream); override;
Public procedure SaveToStream(stream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:01


GLScene v.1.1.2: DDSImage: Class EDDSException

Class EDDSException

Unit

DDSImage

Declaration

type EDDSException = class(Exception)

Description

Hierarchy

  • Exception
  • EDDSException
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:01


GLScene v.1.1.2: dws2Classes

Unit dws2Classes

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

DelphiWebScriptII symbol creation for base Delphi classes.<p>

<b>History : </b><font size=-1><ul> <li>27/04/2004 - SG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class Tdws2ClassesUnit |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:01


GLScene v.1.1.2: dws2Classes: Class Tdws2ClassesUnit

Class Tdws2ClassesUnit

Unit

dws2Classes

Declaration

type Tdws2ClassesUnit = class(Tdws2UnitComponent)

Description

Hierarchy

  • Tdws2UnitComponent
  • Tdws2ClassesUnit

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Protected | procedure AddUnitSymbols(SymbolTable: TSymbolTable); override;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Protected procedure AddUnitSymbols(SymbolTable: TSymbolTable); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:01


GLScene v.1.1.2: dws2GLScene

Unit dws2GLScene

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

DelphiWebScriptII symbol creation for base GLScene classes.<p>

This unit is dependent on dws2Classes and dws2VectorGeometry. These components must be associated with the same compiler for the GLScene classes to inherit from.<p>

<b>History : </b><font size=-1><ul> <li>27/04/2004 - SG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class Tdws2GLSceneUnit |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:01


GLScene v.1.1.2: dws2GLScene: Class Tdws2GLSceneUnit

Class Tdws2GLSceneUnit

Unit

dws2GLScene

Declaration

type Tdws2GLSceneUnit = class(Tdws2UnitComponent)

Description

Hierarchy

  • Tdws2UnitComponent
  • Tdws2GLSceneUnit

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Protected | procedure AddUnitSymbols(SymbolTable: TSymbolTable); override;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Protected procedure AddUnitSymbols(SymbolTable: TSymbolTable); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:01


GLScene v.1.1.2: dws2HelperFunc

Unit dws2HelperFunc

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Helper functions for creating class, properties and method symbols in DelphiWebScriptII.<p>

<b>History : </b><font size=-1><ul> <li>27/04/2004 - SG - Creation </ul></font>

Overview

Functions and Procedures

procedure AddForwardDeclaration(ClassName: String; SymbolTable : TSymbolTable);
function AddClassSymbol(SymbolTable : TSymbolTable; Name, Ancestor : String) : TSymbol;
procedure AddPropertyToClass(Name, DataType, ReadAccess, WriteAccess, IndexDataType: String; IsDefault : Boolean; ClassSym: TClassSymbol; Table: TSymbolTable);
procedure ValidateExternalObject(ExtObject : TObject; ObjClass : TClass);

Description

Functions and Procedures

procedure AddForwardDeclaration(ClassName: String; SymbolTable : TSymbolTable);
function AddClassSymbol(SymbolTable : TSymbolTable; Name, Ancestor : String) : TSymbol;
procedure AddPropertyToClass(Name, DataType, ReadAccess, WriteAccess, IndexDataType: String; IsDefault : Boolean; ClassSym: TClassSymbol; Table: TSymbolTable);
procedure ValidateExternalObject(ExtObject : TObject; ObjClass : TClass);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:01


GLScene v.1.1.2: dws2OpenGLAdapter

Unit dws2OpenGLAdapter

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

DelphiWebScriptII symbol creation for OpenGL procedures and functions.<p>

This unit is still under development.<p>

<b>History : </b><font size=-1><ul> <li>16/01/2011 - Yar - Rename to dws2OpenGLAdapter, update to current main package <li>08/10/2008 - DanB - Split AddUnitSymbols into two procedures, to prevent error <li>23/09/2004 - SG - Added main GL constants and a few procedures <li>21/09/2004 - SG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class Tdws2OpenGLUnit |

Functions and Procedures

procedure Register;

Constants

TypCardinalID : TBaseTypeId = 10;
TypByteID : TBaseTypeId = 11;

Description

Functions and Procedures

procedure Register;

Constants

TypCardinalID : TBaseTypeId = 10;
TypByteID : TBaseTypeId = 11;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:01


GLScene v.1.1.2: dws2OpenGLAdapter: Class Tdws2OpenGLUnit

Class Tdws2OpenGLUnit

Unit

dws2OpenGLAdapter

Declaration

type Tdws2OpenGLUnit = class(Tdws2UnitComponent)

Description

Hierarchy

  • Tdws2UnitComponent
  • Tdws2OpenGLUnit

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Protected | procedure AddExtensionUnitSymbols(SymbolTable: TSymbolTable);
Protected | procedure AddUnitSymbols(SymbolTable: TSymbolTable); override;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Protected procedure AddExtensionUnitSymbols(SymbolTable: TSymbolTable);
Protected procedure AddUnitSymbols(SymbolTable: TSymbolTable); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:01


GLScene v.1.1.2: dws2VectorGeometry

Unit dws2VectorGeometry

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

DelphiWebScriptII symbol creation for VectorGeometry types and functions.<p>

<b>History : </b><font size=-1><ul> <li>27/04/2004 - SG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class Tdws2VectorGeometryUnit |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:01


GLScene v.1.1.2: dws2VectorGeometry: Class Tdws2VectorGeometryUnit

Class Tdws2VectorGeometryUnit

Unit

dws2VectorGeometry

Declaration

type Tdws2VectorGeometryUnit = class(Tdws2UnitComponent)

Description

Hierarchy

  • Tdws2UnitComponent
  • Tdws2VectorGeometryUnit

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Protected | procedure AddUnitSymbols(SymbolTable: TSymbolTable); override;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Protected procedure AddUnitSymbols(SymbolTable: TSymbolTable); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:01


GLScene v.1.1.2: DXTC

Unit DXTC

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

DXTC<p>

DXTC (also S3TC) decoding.<br> Adapted from DevIL image library (http://openil.sourceforge.net)<p>

<b>History : </b><font size=-1><ul> <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>05/03/10 - Yar - Added float types in GLEnumToDDSHeader <li>23/01/10 - Yar - Added more support DX9 DDS color formats and DX11 DXGI constants to future <li>31/03/07 - DaStr - Added $I GLScene.inc <li>03/09/04 - SG - Delphi 5 compatibilty fixes (Ivan Lee Herring) <li>01/09/04 - SG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TDDPIXELFORMAT |
record TDDSURFACEDESC2 |
record TDDSHeader |
record DXTColBlock |
record DXT3AlphaBlock |
record DXT5AlphaBlock |
record TDDS_HEADER_DXT10 |
record TGLImageDataFormat |

Functions and Procedures

procedure DecodeDXT1toBitmap32( encData, decData : PByteArray; w,h : Integer; var trans : Boolean);
procedure DecodeDXT3toBitmap32(encData, decData : PByteArray; w,h : Integer);
procedure DecodeDXT5toBitmap32(encData, decData : PByteArray; w,h : Integer);
procedure flip_blocks_dxtc1( data : PGLubyte; numBlocks: integer);
procedure flip_blocks_dxtc3( data : PGLubyte; numBlocks: integer);
procedure flip_blocks_dxtc5( data : PGLubyte; numBlocks: integer);
procedure flip_dxt5_alpha ( block : PDXT5AlphaBlock);
function DDSHeaderToGLEnum(const DX9header: TDDSHeader; const DX11header: TDDS_HEADER_DXT10; const useDX11: Boolean; out iFormat: TGLInternalFormat; out colorFormat: GLEnum; out dataType: GLenum; out bpe: Integer): Boolean;
function GLEnumToDDSHeader(var DX9header: TDDSHeader; var DX11header: TDDS_HEADER_DXT10; const useDX11: Boolean; const iFormat: TGLInternalFormat; const colorFormat: GLEnum; const dataType: GLenum; const bpe: Integer): Boolean;
function FindDDSCompatibleDataFormat(const iFormat: TGLInternalFormat; out colorFormat: TGLEnum; out dataType: TGLEnum): Boolean;

Types

PDXTColBlock = ˆDXTColBlock;
PDXT3AlphaBlock = ˆDXT3AlphaBlock;
PDXT5AlphaBlock = ˆDXT5AlphaBlock;
TFOURCC = array[0..3] of AnsiChar;

Constants

DDSD_CAPS = $00000001;
DDSD_HEIGHT = $00000002;
DDSD_WIDTH = $00000004;
DDSD_PITCH = $00000008;
DDSD_PIXELFORMAT = $00001000;
DDSD_MIPMAPCOUNT = $00020000;
DDSD_LINEARSIZE = $00080000;
DDSD_DEPTH = $00800000;
DDPF_ALPHAPIXELS = $00000001;
DDPF_A = $00000002;
DDPF_FOURCC = $00000004;
DDPF_RGB = $00000040;
DDPF_RGBA = $00000041;
DDPF_L = $00020000;
DDPF_LA = $00020001;
DDSCAPS_COMPLEX = $00000008;
DDSCAPS_TEXTURE = $00001000;
DDSCAPS_MIPMAP = $00400000;
DDSCAPS2_CUBEMAP = $00000200;
DDSCAPS2_CUBEMAP_POSITIVEX = $00000400;
DDSCAPS2_CUBEMAP_NEGATIVEX = $00000800;
DDSCAPS2_CUBEMAP_POSITIVEY = $00001000;
DDSCAPS2_CUBEMAP_NEGATIVEY = $00002000;
DDSCAPS2_CUBEMAP_POSITIVEZ = $00004000;
DDSCAPS2_CUBEMAP_NEGATIVEZ = $00008000;
DDSCAPS2_VOLUME = $00200000;
DXGI_FORMAT_FORCE_UINT = -1;
DXGI_FORMAT_UNKNOWN = 0;
DXGI_FORMAT_R32G32B32A32_TYPELESS = 1;
DXGI_FORMAT_R32G32B32A32_FLOAT = 2;
DXGI_FORMAT_R32G32B32A32_UINT = 3;
DXGI_FORMAT_R32G32B32A32_SINT = 4;
DXGI_FORMAT_R32G32B32_TYPELESS = 5;
DXGI_FORMAT_R32G32B32_FLOAT = 6;
DXGI_FORMAT_R32G32B32_UINT = 7;
DXGI_FORMAT_R32G32B32_SINT = 8;
DXGI_FORMAT_R16G16B16A16_TYPELESS = 9;
DXGI_FORMAT_R16G16B16A16_FLOAT = 10;
DXGI_FORMAT_R16G16B16A16_UNORM = 11;
DXGI_FORMAT_R16G16B16A16_UINT = 12;
DXGI_FORMAT_R16G16B16A16_SNORM = 13;
DXGI_FORMAT_R16G16B16A16_SINT = 14;
DXGI_FORMAT_R32G32_TYPELESS = 15;
DXGI_FORMAT_R32G32_FLOAT = 16;
DXGI_FORMAT_R32G32_UINT = 17;
DXGI_FORMAT_R32G32_SINT = 18;
DXGI_FORMAT_R32G8X24_TYPELESS = 19;
DXGI_FORMAT_D32_FLOAT_S8X24_UINT = 20;
DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS = 21;
DXGI_FORMAT_X32_TYPELESS_G8X24_UINT = 22;
DXGI_FORMAT_R10G10B10A2_TYPELESS = 23;
DXGI_FORMAT_R10G10B10A2_UNORM = 24;
DXGI_FORMAT_R10G10B10A2_UINT = 25;
DXGI_FORMAT_R11G11B10_FLOAT = 26;
DXGI_FORMAT_R8G8B8A8_TYPELESS = 27;
DXGI_FORMAT_R8G8B8A8_UNORM = 28;
DXGI_FORMAT_R8G8B8A8_UNORM_SRGB = 29;
DXGI_FORMAT_R8G8B8A8_UINT = 30;
DXGI_FORMAT_R8G8B8A8_SNORM = 31;
DXGI_FORMAT_R8G8B8A8_SINT = 32;
DXGI_FORMAT_R16G16_TYPELESS = 33;
DXGI_FORMAT_R16G16_FLOAT = 34;
DXGI_FORMAT_R16G16_UNORM = 35;
DXGI_FORMAT_R16G16_UINT = 36;
DXGI_FORMAT_R16G16_SNORM = 37;
DXGI_FORMAT_R16G16_SINT = 38;
DXGI_FORMAT_R32_TYPELESS = 39;
DXGI_FORMAT_D32_FLOAT = 40;
DXGI_FORMAT_R32_FLOAT = 41;
DXGI_FORMAT_R32_UINT = 42;
DXGI_FORMAT_R32_SINT = 43;
DXGI_FORMAT_R24G8_TYPELESS = 44;
DXGI_FORMAT_D24_UNORM_S8_UINT = 45;
DXGI_FORMAT_R24_UNORM_X8_TYPELESS = 46;
DXGI_FORMAT_X24_TYPELESS_G8_UINT = 47;
DXGI_FORMAT_R8G8_TYPELESS = 48;
DXGI_FORMAT_R8G8_UNORM = 49;
DXGI_FORMAT_R8G8_UINT = 50;
DXGI_FORMAT_R8G8_SNORM = 51;
DXGI_FORMAT_R8G8_SINT = 52;
DXGI_FORMAT_R16_TYPELESS = 53;
DXGI_FORMAT_R16_FLOAT = 54;
DXGI_FORMAT_D16_UNORM = 55;
DXGI_FORMAT_R16_UNORM = 56;
DXGI_FORMAT_R16_UINT = 57;
DXGI_FORMAT_R16_SNORM = 58;
DXGI_FORMAT_R16_SINT = 59;
DXGI_FORMAT_R8_TYPELESS = 60;
DXGI_FORMAT_R8_UNORM = 61;
DXGI_FORMAT_R8_UINT = 62;
DXGI_FORMAT_R8_SNORM = 63;
DXGI_FORMAT_R8_SINT = 64;
DXGI_FORMAT_A8_UNORM = 65;
DXGI_FORMAT_R1_UNORM = 66;
DXGI_FORMAT_R9G9B9E5_SHAREDEXP = 67;
DXGI_FORMAT_R8G8_B8G8_UNORM = 68;
DXGI_FORMAT_G8R8_G8B8_UNORM = 69;
DXGI_FORMAT_BC1_TYPELESS = 70;
DXGI_FORMAT_BC1_UNORM = 71;
DXGI_FORMAT_BC1_UNORM_SRGB = 72;
DXGI_FORMAT_BC2_TYPELESS = 73;
DXGI_FORMAT_BC2_UNORM = 74;
DXGI_FORMAT_BC2_UNORM_SRGB = 75;
DXGI_FORMAT_BC3_TYPELESS = 76;
DXGI_FORMAT_BC3_UNORM = 77;
DXGI_FORMAT_BC3_UNORM_SRGB = 78;
DXGI_FORMAT_BC4_TYPELESS = 79;
DXGI_FORMAT_BC4_UNORM = 80;
DXGI_FORMAT_BC4_SNORM = 81;
DXGI_FORMAT_BC5_TYPELESS = 82;
DXGI_FORMAT_BC5_UNORM = 83;
DXGI_FORMAT_BC5_SNORM = 84;
DXGI_FORMAT_B5G6R5_UNORM = 85;
DXGI_FORMAT_B5G5R5A1_UNORM = 86;
DXGI_FORMAT_B8G8R8A8_UNORM = 87;
DXGI_FORMAT_B8G8R8X8_UNORM = 88;
DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM = 89;
DXGI_FORMAT_B8G8R8A8_TYPELESS = 90;
DXGI_FORMAT_B8G8R8A8_UNORM_SRGB = 91;
DXGI_FORMAT_B8G8R8X8_TYPELESS = 92;
DXGI_FORMAT_B8G8R8X8_UNORM_SRGB = 93;
DXGI_FORMAT_BC6H_TYPELESS = 94;
DXGI_FORMAT_BC6H_UF16 = 95;
DXGI_FORMAT_BC6H_SF16 = 96;
DXGI_FORMAT_BC7_TYPELESS = 97;
DXGI_FORMAT_BC7_UNORM = 98;
DXGI_FORMAT_BC7_UNORM_SRGB = 99;
D3D11_RESOURCE_DIMENSION_UNKNOWN = 0;
D3D11_RESOURCE_DIMENSION_BUFFER = 1;
D3D11_RESOURCE_DIMENSION_TEXTURE1D = 2;
D3D11_RESOURCE_DIMENSION_TEXTURE2D = 3;
D3D11_RESOURCE_DIMENSION_TEXTURE3D = 4;
FOURCC_UNKNOWN = 0;
FOURCC_R8G8B8 = 20;
FOURCC_A8R8G8B8 = 21;
FOURCC_X8R8G8B8 = 22;
FOURCC_R5G6B5 = 23;
FOURCC_X1R5G5B5 = 24;
FOURCC_A1R5G5B5 = 25;
FOURCC_A4R4G4B4 = 26;
FOURCC_R3G3B2 = 27;
FOURCC_A8 = 28;
FOURCC_A8R3G3B2 = 29;
FOURCC_X4R4G4B4 = 30;
FOURCC_A2B10G10R10 = 31;
FOURCC_A8B8G8R8 = 32;
FOURCC_X8B8G8R8 = 33;
FOURCC_G16R16 = 34;
FOURCC_A2R10G10B10 = 35;
FOURCC_A16B16G16R16 = 36;
FOURCC_L8 = 50;
FOURCC_A8L8 = 51;
FOURCC_A4L4 = 52;
FOURCC_DXT1 = $31545844;
FOURCC_DXT2 = $32545844;
FOURCC_DXT3 = $33545844;
FOURCC_DXT4 = $34545844;
FOURCC_DXT5 = $35545844;
FOURCC_ATI1 = $31495441;
FOURCC_ATI2 = $32495441;
FOURCC_D16_LOCKABLE = 70;
FOURCC_D32 = 71;
FOURCC_D24X8 = 77;
FOURCC_D16 = 80;
FOURCC_D32F_LOCKABLE = 82;
FOURCC_L16 = 81;
FOURCC_R16F = 111;
FOURCC_G16R16F = 112;
FOURCC_A16B16G16R16F = 113;
FOURCC_R32F = 114;
FOURCC_G32R32F = 115;
FOURCC_A32B32G32R32F = 116;
FOURCC_DX10 = $47495844;
cImageDataFormat8bits: array[0..3] of TGLImageDataFormat = ( (ColorFlag: DDPF_RGB; RBits: $E0; GBits: $1C; BBits: $03; ABits: $00; colorFormat: GL_RGB; TexFormat: tfR3_G3_B2; dType: GL_UNSIGNED_BYTE_3_3_2), (ColorFlag: DDPF_LA; RBits: $0F; GBits: $00; BBits: $00; ABits: $F0; colorFormat: GL_LUMINANCE_ALPHA; TexFormat: tfLUMINANCE4_ALPHA4; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_A; RBits: $00; GBits: $00; BBits: $00; ABits: $FF; colorFormat: GL_ALPHA; TexFormat: tfALPHA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_L; RBits: $FF; GBits: $00; BBits: $00; ABits: $00; colorFormat: GL_LUMINANCE; TexFormat: tfLUMINANCE8; dType: GL_UNSIGNED_BYTE) );
cImageDataFormat16bits: array[0..4] of TGLImageDataFormat = ( (ColorFlag: DDPF_RGBA; RBits: $0F00; GBits: $F0; BBits: $0F; ABits: $F000; colorFormat: GL_BGRA; TexFormat: tfRGBA4; dType: GL_UNSIGNED_SHORT_4_4_4_4_REV), (ColorFlag: DDPF_RGB; RBits: $F800; GBits: $07E0; BBits: $1F; ABits: $00; colorFormat: GL_RGB; TexFormat: tfRGB5; dType: GL_UNSIGNED_SHORT_5_6_5), (ColorFlag: DDPF_L; RBits: $FFFF; GBits: $00; BBits: $00; ABits: $00; colorFormat: GL_LUMINANCE; TexFormat: tfLUMINANCE16; dType: GL_UNSIGNED_SHORT), (ColorFlag: DDPF_LA; RBits: $FF; GBits: $00; BBits: $00; ABits: $FF00; colorFormat: GL_LUMINANCE_ALPHA; TexFormat: tfLUMINANCE8_ALPHA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_RGBA; RBits: $7C00; GBits: $03E0; BBits: $1F; ABits: $8000; colorFormat: GL_BGRA; TexFormat: tfRGB5_A1; dType: GL_UNSIGNED_SHORT_1_5_5_5_REV) );
cImageDataFormat24bits: array[0..0] of TGLImageDataFormat = ( (ColorFlag: DDPF_RGB; RBits: $FF0000; GBits: $FF00; BBits: $FF; ABits: $00; colorFormat: GL_BGR; TexFormat: tfRGB8; dType: GL_UNSIGNED_BYTE) );
cImageDataFormat32bits: array[0..6] of TGLImageDataFormat = ( (ColorFlag: DDPF_RGBA; RBits: $FF; GBits: $FF00; BBits: $FF0000; ABits: $FF000000; colorFormat: GL_RGBA; TexFormat: tfRGBA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_RGBA; RBits: $FF0000; GBits: $FF00; BBits: $FF; ABits: $FF000000; colorFormat: GL_BGRA; TexFormat: tfRGBA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_RGBA; RBits: $3FF00000; GBits: $0FFC00; BBits: $03FF; ABits: $0C0000000; colorFormat: GL_RGBA; TexFormat: tfRGB10_A2; dType: GL_UNSIGNED_INT_2_10_10_10_REV), (ColorFlag: DDPF_RGBA; RBits: $03FF; GBits: $FFC00; BBits: $3FF00000; ABits: $C0000000; colorFormat: GL_BGRA; TexFormat: tfRGB10_A2; dType: GL_UNSIGNED_INT_2_10_10_10_REV), (ColorFlag: DDPF_RGBA; RBits: $FF0000; GBits: $FF00; BBits: $FF; ABits: $FF000000; colorFormat: GL_BGRA; TexFormat: tfRGB8; dType: GL_UNSIGNED_INT_8_8_8_8), (ColorFlag: DDPF_RGBA; RBits: $FF; GBits: $FF00; BBits: $FF0000; ABits: $FF000000; colorFormat: GL_RGBA; TexFormat: tfRGB8; dType: GL_UNSIGNED_INT_8_8_8_8), (ColorFlag: DDPF_RGB; RBits: $FFFF; GBits: $FFFF0000; BBits: $00; ABits: $00; colorFormat: GL_RG; TexFormat: tfRG16; dType: GL_UNSIGNED_SHORT) );

Description

Functions and Procedures

procedure DecodeDXT1toBitmap32( encData, decData : PByteArray; w,h : Integer; var trans : Boolean);
procedure DecodeDXT3toBitmap32(encData, decData : PByteArray; w,h : Integer);
procedure DecodeDXT5toBitmap32(encData, decData : PByteArray; w,h : Integer);
procedure flip_blocks_dxtc1( data : PGLubyte; numBlocks: integer);
procedure flip_blocks_dxtc3( data : PGLubyte; numBlocks: integer);
procedure flip_blocks_dxtc5( data : PGLubyte; numBlocks: integer);
procedure flip_dxt5_alpha ( block : PDXT5AlphaBlock);
function DDSHeaderToGLEnum(const DX9header: TDDSHeader; const DX11header: TDDS_HEADER_DXT10; const useDX11: Boolean; out iFormat: TGLInternalFormat; out colorFormat: GLEnum; out dataType: GLenum; out bpe: Integer): Boolean;
function GLEnumToDDSHeader(var DX9header: TDDSHeader; var DX11header: TDDS_HEADER_DXT10; const useDX11: Boolean; const iFormat: TGLInternalFormat; const colorFormat: GLEnum; const dataType: GLenum; const bpe: Integer): Boolean;
function FindDDSCompatibleDataFormat(const iFormat: TGLInternalFormat; out colorFormat: TGLEnum; out dataType: TGLEnum): Boolean;

Types

PDXTColBlock = ˆDXTColBlock;
PDXT3AlphaBlock = ˆDXT3AlphaBlock;
PDXT5AlphaBlock = ˆDXT5AlphaBlock;
TFOURCC = array[0..3] of AnsiChar;

Constants

DDSD_CAPS = $00000001;
DDSD_HEIGHT = $00000002;
DDSD_WIDTH = $00000004;
DDSD_PITCH = $00000008;
DDSD_PIXELFORMAT = $00001000;
DDSD_MIPMAPCOUNT = $00020000;
DDSD_LINEARSIZE = $00080000;
DDSD_DEPTH = $00800000;
DDPF_ALPHAPIXELS = $00000001;
DDPF_A = $00000002;
DDPF_FOURCC = $00000004;
DDPF_RGB = $00000040;
DDPF_RGBA = $00000041;
DDPF_L = $00020000;
DDPF_LA = $00020001;
DDSCAPS_COMPLEX = $00000008;
DDSCAPS_TEXTURE = $00001000;
DDSCAPS_MIPMAP = $00400000;
DDSCAPS2_CUBEMAP = $00000200;
DDSCAPS2_CUBEMAP_POSITIVEX = $00000400;
DDSCAPS2_CUBEMAP_NEGATIVEX = $00000800;
DDSCAPS2_CUBEMAP_POSITIVEY = $00001000;
DDSCAPS2_CUBEMAP_NEGATIVEY = $00002000;
DDSCAPS2_CUBEMAP_POSITIVEZ = $00004000;
DDSCAPS2_CUBEMAP_NEGATIVEZ = $00008000;
DDSCAPS2_VOLUME = $00200000;
DXGI_FORMAT_FORCE_UINT = -1;
DXGI_FORMAT_UNKNOWN = 0;
DXGI_FORMAT_R32G32B32A32_TYPELESS = 1;
DXGI_FORMAT_R32G32B32A32_FLOAT = 2;
DXGI_FORMAT_R32G32B32A32_UINT = 3;
DXGI_FORMAT_R32G32B32A32_SINT = 4;
DXGI_FORMAT_R32G32B32_TYPELESS = 5;
DXGI_FORMAT_R32G32B32_FLOAT = 6;
DXGI_FORMAT_R32G32B32_UINT = 7;
DXGI_FORMAT_R32G32B32_SINT = 8;
DXGI_FORMAT_R16G16B16A16_TYPELESS = 9;
DXGI_FORMAT_R16G16B16A16_FLOAT = 10;
DXGI_FORMAT_R16G16B16A16_UNORM = 11;
DXGI_FORMAT_R16G16B16A16_UINT = 12;
DXGI_FORMAT_R16G16B16A16_SNORM = 13;
DXGI_FORMAT_R16G16B16A16_SINT = 14;
DXGI_FORMAT_R32G32_TYPELESS = 15;
DXGI_FORMAT_R32G32_FLOAT = 16;
DXGI_FORMAT_R32G32_UINT = 17;
DXGI_FORMAT_R32G32_SINT = 18;
DXGI_FORMAT_R32G8X24_TYPELESS = 19;
DXGI_FORMAT_D32_FLOAT_S8X24_UINT = 20;
DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS = 21;
DXGI_FORMAT_X32_TYPELESS_G8X24_UINT = 22;
DXGI_FORMAT_R10G10B10A2_TYPELESS = 23;
DXGI_FORMAT_R10G10B10A2_UNORM = 24;
DXGI_FORMAT_R10G10B10A2_UINT = 25;
DXGI_FORMAT_R11G11B10_FLOAT = 26;
DXGI_FORMAT_R8G8B8A8_TYPELESS = 27;
DXGI_FORMAT_R8G8B8A8_UNORM = 28;
DXGI_FORMAT_R8G8B8A8_UNORM_SRGB = 29;
DXGI_FORMAT_R8G8B8A8_UINT = 30;
DXGI_FORMAT_R8G8B8A8_SNORM = 31;
DXGI_FORMAT_R8G8B8A8_SINT = 32;
DXGI_FORMAT_R16G16_TYPELESS = 33;
DXGI_FORMAT_R16G16_FLOAT = 34;
DXGI_FORMAT_R16G16_UNORM = 35;
DXGI_FORMAT_R16G16_UINT = 36;
DXGI_FORMAT_R16G16_SNORM = 37;
DXGI_FORMAT_R16G16_SINT = 38;
DXGI_FORMAT_R32_TYPELESS = 39;
DXGI_FORMAT_D32_FLOAT = 40;
DXGI_FORMAT_R32_FLOAT = 41;
DXGI_FORMAT_R32_UINT = 42;
DXGI_FORMAT_R32_SINT = 43;
DXGI_FORMAT_R24G8_TYPELESS = 44;
DXGI_FORMAT_D24_UNORM_S8_UINT = 45;
DXGI_FORMAT_R24_UNORM_X8_TYPELESS = 46;
DXGI_FORMAT_X24_TYPELESS_G8_UINT = 47;
DXGI_FORMAT_R8G8_TYPELESS = 48;
DXGI_FORMAT_R8G8_UNORM = 49;
DXGI_FORMAT_R8G8_UINT = 50;
DXGI_FORMAT_R8G8_SNORM = 51;
DXGI_FORMAT_R8G8_SINT = 52;
DXGI_FORMAT_R16_TYPELESS = 53;
DXGI_FORMAT_R16_FLOAT = 54;
DXGI_FORMAT_D16_UNORM = 55;
DXGI_FORMAT_R16_UNORM = 56;
DXGI_FORMAT_R16_UINT = 57;
DXGI_FORMAT_R16_SNORM = 58;
DXGI_FORMAT_R16_SINT = 59;
DXGI_FORMAT_R8_TYPELESS = 60;
DXGI_FORMAT_R8_UNORM = 61;
DXGI_FORMAT_R8_UINT = 62;
DXGI_FORMAT_R8_SNORM = 63;
DXGI_FORMAT_R8_SINT = 64;
DXGI_FORMAT_A8_UNORM = 65;
DXGI_FORMAT_R1_UNORM = 66;
DXGI_FORMAT_R9G9B9E5_SHAREDEXP = 67;
DXGI_FORMAT_R8G8_B8G8_UNORM = 68;
DXGI_FORMAT_G8R8_G8B8_UNORM = 69;
DXGI_FORMAT_BC1_TYPELESS = 70;
DXGI_FORMAT_BC1_UNORM = 71;
DXGI_FORMAT_BC1_UNORM_SRGB = 72;
DXGI_FORMAT_BC2_TYPELESS = 73;
DXGI_FORMAT_BC2_UNORM = 74;
DXGI_FORMAT_BC2_UNORM_SRGB = 75;
DXGI_FORMAT_BC3_TYPELESS = 76;
DXGI_FORMAT_BC3_UNORM = 77;
DXGI_FORMAT_BC3_UNORM_SRGB = 78;
DXGI_FORMAT_BC4_TYPELESS = 79;
DXGI_FORMAT_BC4_UNORM = 80;
DXGI_FORMAT_BC4_SNORM = 81;
DXGI_FORMAT_BC5_TYPELESS = 82;
DXGI_FORMAT_BC5_UNORM = 83;
DXGI_FORMAT_BC5_SNORM = 84;
DXGI_FORMAT_B5G6R5_UNORM = 85;
DXGI_FORMAT_B5G5R5A1_UNORM = 86;
DXGI_FORMAT_B8G8R8A8_UNORM = 87;
DXGI_FORMAT_B8G8R8X8_UNORM = 88;
DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM = 89;
DXGI_FORMAT_B8G8R8A8_TYPELESS = 90;
DXGI_FORMAT_B8G8R8A8_UNORM_SRGB = 91;
DXGI_FORMAT_B8G8R8X8_TYPELESS = 92;
DXGI_FORMAT_B8G8R8X8_UNORM_SRGB = 93;
DXGI_FORMAT_BC6H_TYPELESS = 94;
DXGI_FORMAT_BC6H_UF16 = 95;
DXGI_FORMAT_BC6H_SF16 = 96;
DXGI_FORMAT_BC7_TYPELESS = 97;
DXGI_FORMAT_BC7_UNORM = 98;
DXGI_FORMAT_BC7_UNORM_SRGB = 99;
D3D11_RESOURCE_DIMENSION_UNKNOWN = 0;
D3D11_RESOURCE_DIMENSION_BUFFER = 1;
D3D11_RESOURCE_DIMENSION_TEXTURE1D = 2;
D3D11_RESOURCE_DIMENSION_TEXTURE2D = 3;
D3D11_RESOURCE_DIMENSION_TEXTURE3D = 4;
FOURCC_UNKNOWN = 0;
FOURCC_R8G8B8 = 20;
FOURCC_A8R8G8B8 = 21;
FOURCC_X8R8G8B8 = 22;
FOURCC_R5G6B5 = 23;
FOURCC_X1R5G5B5 = 24;
FOURCC_A1R5G5B5 = 25;
FOURCC_A4R4G4B4 = 26;
FOURCC_R3G3B2 = 27;
FOURCC_A8 = 28;
FOURCC_A8R3G3B2 = 29;
FOURCC_X4R4G4B4 = 30;
FOURCC_A2B10G10R10 = 31;
FOURCC_A8B8G8R8 = 32;
FOURCC_X8B8G8R8 = 33;
FOURCC_G16R16 = 34;
FOURCC_A2R10G10B10 = 35;
FOURCC_A16B16G16R16 = 36;
FOURCC_L8 = 50;
FOURCC_A8L8 = 51;
FOURCC_A4L4 = 52;
FOURCC_DXT1 = $31545844;
FOURCC_DXT2 = $32545844;
FOURCC_DXT3 = $33545844;
FOURCC_DXT4 = $34545844;
FOURCC_DXT5 = $35545844;
FOURCC_ATI1 = $31495441;
FOURCC_ATI2 = $32495441;
FOURCC_D16_LOCKABLE = 70;
FOURCC_D32 = 71;
FOURCC_D24X8 = 77;
FOURCC_D16 = 80;
FOURCC_D32F_LOCKABLE = 82;
FOURCC_L16 = 81;
FOURCC_R16F = 111;
FOURCC_G16R16F = 112;
FOURCC_A16B16G16R16F = 113;
FOURCC_R32F = 114;
FOURCC_G32R32F = 115;
FOURCC_A32B32G32R32F = 116;
FOURCC_DX10 = $47495844;
cImageDataFormat8bits: array[0..3] of TGLImageDataFormat = ( (ColorFlag: DDPF_RGB; RBits: $E0; GBits: $1C; BBits: $03; ABits: $00; colorFormat: GL_RGB; TexFormat: tfR3_G3_B2; dType: GL_UNSIGNED_BYTE_3_3_2), (ColorFlag: DDPF_LA; RBits: $0F; GBits: $00; BBits: $00; ABits: $F0; colorFormat: GL_LUMINANCE_ALPHA; TexFormat: tfLUMINANCE4_ALPHA4; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_A; RBits: $00; GBits: $00; BBits: $00; ABits: $FF; colorFormat: GL_ALPHA; TexFormat: tfALPHA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_L; RBits: $FF; GBits: $00; BBits: $00; ABits: $00; colorFormat: GL_LUMINANCE; TexFormat: tfLUMINANCE8; dType: GL_UNSIGNED_BYTE) );
cImageDataFormat16bits: array[0..4] of TGLImageDataFormat = ( (ColorFlag: DDPF_RGBA; RBits: $0F00; GBits: $F0; BBits: $0F; ABits: $F000; colorFormat: GL_BGRA; TexFormat: tfRGBA4; dType: GL_UNSIGNED_SHORT_4_4_4_4_REV), (ColorFlag: DDPF_RGB; RBits: $F800; GBits: $07E0; BBits: $1F; ABits: $00; colorFormat: GL_RGB; TexFormat: tfRGB5; dType: GL_UNSIGNED_SHORT_5_6_5), (ColorFlag: DDPF_L; RBits: $FFFF; GBits: $00; BBits: $00; ABits: $00; colorFormat: GL_LUMINANCE; TexFormat: tfLUMINANCE16; dType: GL_UNSIGNED_SHORT), (ColorFlag: DDPF_LA; RBits: $FF; GBits: $00; BBits: $00; ABits: $FF00; colorFormat: GL_LUMINANCE_ALPHA; TexFormat: tfLUMINANCE8_ALPHA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_RGBA; RBits: $7C00; GBits: $03E0; BBits: $1F; ABits: $8000; colorFormat: GL_BGRA; TexFormat: tfRGB5_A1; dType: GL_UNSIGNED_SHORT_1_5_5_5_REV) );
cImageDataFormat24bits: array[0..0] of TGLImageDataFormat = ( (ColorFlag: DDPF_RGB; RBits: $FF0000; GBits: $FF00; BBits: $FF; ABits: $00; colorFormat: GL_BGR; TexFormat: tfRGB8; dType: GL_UNSIGNED_BYTE) );
cImageDataFormat32bits: array[0..6] of TGLImageDataFormat = ( (ColorFlag: DDPF_RGBA; RBits: $FF; GBits: $FF00; BBits: $FF0000; ABits: $FF000000; colorFormat: GL_RGBA; TexFormat: tfRGBA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_RGBA; RBits: $FF0000; GBits: $FF00; BBits: $FF; ABits: $FF000000; colorFormat: GL_BGRA; TexFormat: tfRGBA8; dType: GL_UNSIGNED_BYTE), (ColorFlag: DDPF_RGBA; RBits: $3FF00000; GBits: $0FFC00; BBits: $03FF; ABits: $0C0000000; colorFormat: GL_RGBA; TexFormat: tfRGB10_A2; dType: GL_UNSIGNED_INT_2_10_10_10_REV), (ColorFlag: DDPF_RGBA; RBits: $03FF; GBits: $FFC00; BBits: $3FF00000; ABits: $C0000000; colorFormat: GL_BGRA; TexFormat: tfRGB10_A2; dType: GL_UNSIGNED_INT_2_10_10_10_REV), (ColorFlag: DDPF_RGBA; RBits: $FF0000; GBits: $FF00; BBits: $FF; ABits: $FF000000; colorFormat: GL_BGRA; TexFormat: tfRGB8; dType: GL_UNSIGNED_INT_8_8_8_8), (ColorFlag: DDPF_RGBA; RBits: $FF; GBits: $FF00; BBits: $FF0000; ABits: $FF000000; colorFormat: GL_RGBA; TexFormat: tfRGB8; dType: GL_UNSIGNED_INT_8_8_8_8), (ColorFlag: DDPF_RGB; RBits: $FFFF; GBits: $FFFF0000; BBits: $00; ABits: $00; colorFormat: GL_RG; TexFormat: tfRG16; dType: GL_UNSIGNED_SHORT) );
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: DXTC: record TDDPIXELFORMAT

record TDDPIXELFORMAT

Unit

DXTC

Declaration

type TDDPIXELFORMAT = record

Description

Overview

Fields

dwSize: Cardinal;
dwFlags: Cardinal;
dwFourCC: Cardinal;
dwRGBBitCount: Cardinal;
dwRBitMask: Cardinal;
dwGBitMask: Cardinal;
dwBBitMask: Cardinal;
dwRGBAlphaBitMask: Cardinal;

Description

Fields

dwSize: Cardinal;
dwFlags: Cardinal;
dwFourCC: Cardinal;
dwRGBBitCount: Cardinal;
dwRBitMask: Cardinal;
dwGBitMask: Cardinal;
dwBBitMask: Cardinal;
dwRGBAlphaBitMask: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: DXTC: record TDDSURFACEDESC2

record TDDSURFACEDESC2

Unit

DXTC

Declaration

type TDDSURFACEDESC2 = record

Description

Overview

Fields

dwSize: Cardinal;
dwFlags: Cardinal;
dwHeight: Cardinal;
dwWidth: Cardinal;
dwPitchOrLinearSize: Cardinal;
dwDepth: Cardinal;
dwMipMapCount: Cardinal;
dwReserved1: array[0..10] of Cardinal;
ddpf: TDDPIXELFORMAT;
dwCaps: Cardinal;
dwCaps2: Cardinal;
dwCaps3: Cardinal;
dwCaps4: Cardinal;
dwReserved2: Cardinal;

Description

Fields

dwSize: Cardinal;
dwFlags: Cardinal;
dwHeight: Cardinal;
dwWidth: Cardinal;
dwPitchOrLinearSize: Cardinal;
dwDepth: Cardinal;

The number of bytes per scan line in an uncompressed texture; the total number of bytes in the top level texture for a compressed texture.

dwMipMapCount: Cardinal;

The number of bytes per scan line in an uncompressed texture; the total number of bytes in the top level texture for a compressed texture.

dwReserved1: array[0..10] of Cardinal;
ddpf: TDDPIXELFORMAT;
dwCaps: Cardinal;
dwCaps2: Cardinal;
dwCaps3: Cardinal;
dwCaps4: Cardinal;
dwReserved2: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: DXTC: record TDDSHeader

record TDDSHeader

Unit

DXTC

Declaration

type TDDSHeader = record

Description

Overview

Fields

Magic: Cardinal;
SurfaceFormat: TDDSURFACEDESC2;

Description

Fields

Magic: Cardinal;
SurfaceFormat: TDDSURFACEDESC2;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: DXTC: record DXTColBlock

record DXTColBlock

Unit

DXTC

Declaration

type DXTColBlock = record

Description

Overview

Fields

col0: GLushort;
col1: GLushort;
row: array[0..3] of GLubyte;

Description

Fields

col0: GLushort;
col1: GLushort;
row: array[0..3] of GLubyte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: DXTC: record DXT3AlphaBlock

record DXT3AlphaBlock

Unit

DXTC

Declaration

type DXT3AlphaBlock = record

Description

Overview

Fields

row: array[0..3] of GLushort;

Description

Fields

row: array[0..3] of GLushort;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: DXTC: record DXT5AlphaBlock

record DXT5AlphaBlock

Unit

DXTC

Declaration

type DXT5AlphaBlock = record

Description

Overview

Fields

alpha0: GLubyte;
alpha1: GLubyte;
row: array[0..5] of GLubyte;

Description

Fields

alpha0: GLubyte;
alpha1: GLubyte;
row: array[0..5] of GLubyte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: DXTC: record TDDS_HEADER_DXT10

record TDDS_HEADER_DXT10

Unit

DXTC

Declaration

type TDDS_HEADER_DXT10 = record

Description

Overview

Fields

dxgiFormat: Integer;
resourceDimension: Integer;
miscFlag: Cardinal;
arraySize: Cardinal;
reserved: Cardinal;

Description

Fields

dxgiFormat: Integer;
resourceDimension: Integer;
miscFlag: Cardinal;
arraySize: Cardinal;
reserved: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: DXTC: record TGLImageDataFormat

record TGLImageDataFormat

Unit

DXTC

Declaration

type TGLImageDataFormat = record

Description

Overview

Fields

ColorFlag: Cardinal;
RBits: Cardinal;
GBits: Cardinal;
BBits: Cardinal;
ABits: Cardinal;
colorFormat: GLEnum;
TexFormat: TGLInternalFormat;
dType: GLenum;

Description

Fields

ColorFlag: Cardinal;
RBits: Cardinal;
GBits: Cardinal;
BBits: Cardinal;
ABits: Cardinal;
colorFormat: GLEnum;
TexFormat: TGLInternalFormat;
dType: GLenum;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: FGUILayoutEditor

Unit FGUILayoutEditor

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class Tlayouts_form |

Functions and Procedures

function GUILayoutEditorForm: Tlayouts_form;
procedure ReleaseGUILayoutEditor;

Description

Functions and Procedures

function GUILayoutEditorForm: Tlayouts_form;
procedure ReleaseGUILayoutEditor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: FGUILayoutEditor: Class Tlayouts_form

Class Tlayouts_form

Unit

FGUILayoutEditor

Declaration

type Tlayouts_form = class(TForm)

Description

Hierarchy

  • TForm
  • Tlayouts_form

Overview

Fields

Published | Panel1: TPanel;
Published | Panel2: TPanel;
Published | items_list: TListBox;
Published | x_label: TLabel;
Published | y_label: TLabel;
Published | open_image_button: TBitBtn;
Published | open_button: TBitBtn;
Published | save_button: TBitBtn;
Published | OpenDialog1: TOpenDialog;
Published | SaveDialog1: TSaveDialog;
Published | delete_item_button: TBitBtn;
Published | add_button: TBitBtn;
Published | Label1: TLabel;
Published | Label2: TLabel;
Published | left_edit: TSpinEdit;
Published | top_edit: TSpinEdit;
Published | Label3: TLabel;
Published | Label4: TLabel;
Published | height_edit: TSpinEdit;
Published | width_edit: TSpinEdit;
Published | Label5: TLabel;
Published | name_edit: TEdit;
Published | elements_grid: TStringGrid;
Published | Panel3: TPanel;
Published | BitBtn4: TBitBtn;
Published | BitBtn5: TBitBtn;
Published | ScrollBox1: TScrollBox;
Published | Image2: TImage;
Published | PaintBox1: TPaintBox;
Published | Image1: TImage;
Published | BitBtn6: TBitBtn;
Published | BitBtn1: TBitBtn;
Published | GLGuiLayout1: TGLGuiLayout;

Methods

Published | procedure add_buttonClick(Sender: TObject);
Published | procedure BitBtn4Click(Sender: TObject);
Published | procedure BitBtn6Click(Sender: TObject);
Published | procedure delete_item_buttonClick(Sender: TObject);
Published | procedure elements_gridClick(Sender: TObject);
Published | procedure elements_gridDblClick(Sender: TObject);
Published | procedure FormCreate(Sender: TObject);
Published | procedure height_editChange(Sender: TObject);
Published | procedure Image1MouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure Image1MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published | procedure Image1MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure items_listClick(Sender: TObject);
Published | procedure left_editChange(Sender: TObject);
Published | procedure name_editExit(Sender: TObject);
Published | procedure name_editKeyPress(Sender: TObject; var Key: Char);
Published | procedure open_buttonClick(Sender: TObject);
Published | procedure open_image_buttonClick(Sender: TObject);
Published | procedure save_buttonClick(Sender: TObject);
Published | procedure top_editChange(Sender: TObject);
Published | procedure width_editChange(Sender: TObject);
Public | procedure Execute(AGUILayout: TGLGuiLayout);

Properties

Public property EnabledSpins: Boolean read GetEnabledSpins write SetEnabledSpins;

Description

Fields

Published Panel1: TPanel;
Published Panel2: TPanel;
Published items_list: TListBox;
Published x_label: TLabel;
Published y_label: TLabel;
Published open_image_button: TBitBtn;
Published open_button: TBitBtn;
Published save_button: TBitBtn;
Published OpenDialog1: TOpenDialog;
Published SaveDialog1: TSaveDialog;
Published delete_item_button: TBitBtn;
Published add_button: TBitBtn;
Published Label1: TLabel;
Published Label2: TLabel;
Published left_edit: TSpinEdit;
Published top_edit: TSpinEdit;
Published Label3: TLabel;
Published Label4: TLabel;
Published height_edit: TSpinEdit;
Published width_edit: TSpinEdit;
Published Label5: TLabel;
Published name_edit: TEdit;
Published elements_grid: TStringGrid;
Published Panel3: TPanel;
Published BitBtn4: TBitBtn;
Published BitBtn5: TBitBtn;
Published ScrollBox1: TScrollBox;
Published Image2: TImage;
Published PaintBox1: TPaintBox;
Published Image1: TImage;
Published BitBtn6: TBitBtn;
Published BitBtn1: TBitBtn;
Published GLGuiLayout1: TGLGuiLayout;

Methods

Published procedure add_buttonClick(Sender: TObject);
Published procedure BitBtn4Click(Sender: TObject);
Published procedure BitBtn6Click(Sender: TObject);
Published procedure delete_item_buttonClick(Sender: TObject);
Published procedure elements_gridClick(Sender: TObject);
Published procedure elements_gridDblClick(Sender: TObject);
Published procedure FormCreate(Sender: TObject);
Published procedure height_editChange(Sender: TObject);
Published procedure Image1MouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure Image1MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published procedure Image1MouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure items_listClick(Sender: TObject);
Published procedure left_editChange(Sender: TObject);
Published procedure name_editExit(Sender: TObject);
Published procedure name_editKeyPress(Sender: TObject; var Key: Char);
Published procedure open_buttonClick(Sender: TObject);
Published procedure open_image_buttonClick(Sender: TObject);
Published procedure save_buttonClick(Sender: TObject);
Published procedure top_editChange(Sender: TObject);
Published procedure width_editChange(Sender: TObject);
Public procedure Execute(AGUILayout: TGLGuiLayout);

Properties

Public property EnabledSpins: Boolean read GetEnabledSpins write SetEnabledSpins;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: File3DS

Unit File3DS

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMaterialList |
Class TObjectList |
Class TKeyFramer |
Class TFile3DS |

Types

TLoadProgress = procedure(StreamPos, StreamMax: Longint) of object;

Description

Types

TLoadProgress = procedure(StreamPos, StreamMax: Longint) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: File3DS: Class TMaterialList

Class TMaterialList

Unit

File3DS

Declaration

type TMaterialList = class(TObject)

Description

Hierarchy

  • TObject
  • TMaterialList

Overview

Methods

Public | constructor Create(AOwner: TFile3DS); virtual;
Public | destructor Destroy; override;
Public | procedure ClearList;

Properties

Public | property Count: Integer read GetCount;
Public | property Material[Index: Integer]: PMaterial3DS read GetMaterial;
Public | property MaterialByName[const Name: String]: PMaterial3DS read GetMaterialByName;

Description

Methods

Public constructor Create(AOwner: TFile3DS); virtual;
Public destructor Destroy; override;
Public procedure ClearList;

Properties

Public property Count: Integer read GetCount;
Public property Material[Index: Integer]: PMaterial3DS read GetMaterial;
Public property MaterialByName[const Name: String]: PMaterial3DS read GetMaterialByName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: File3DS: Class TObjectList

Class TObjectList

Unit

File3DS

Declaration

type TObjectList = class(TObject)

Description

Hierarchy

  • TObject
  • TObjectList

Overview

Methods

Public | constructor Create(AOwner: TFile3DS); virtual;
Public | destructor Destroy; override;
Public | procedure ClearLists;

Properties

Public | property Camera[Index: Integer]: PCamera3DS read GetCamera;
Public | property CameraCount: Integer read GetCamCount;
Public | property Mesh[Index: Integer]: PMesh3DS read GetMesh;
Public | property MeshCount: Integer read GetMeshObjectCount;
Public | property OmniLight[Index: Integer]: PLight3DS read GetOmniLight;
Public | property OmniLightCount: Integer read GetOmniCount;
Public | property SpotLight[Index: Integer]: PLight3DS read GetSpotLight;
Public | property SpotLightCount: Integer read GetSpotCount;

Description

Methods

Public constructor Create(AOwner: TFile3DS); virtual;
Public destructor Destroy; override;
Public procedure ClearLists;

Properties

Public property Camera[Index: Integer]: PCamera3DS read GetCamera;
Public property CameraCount: Integer read GetCamCount;
Public property Mesh[Index: Integer]: PMesh3DS read GetMesh;
Public property MeshCount: Integer read GetMeshObjectCount;
Public property OmniLight[Index: Integer]: PLight3DS read GetOmniLight;
Public property OmniLightCount: Integer read GetOmniCount;
Public property SpotLight[Index: Integer]: PLight3DS read GetSpotLight;
Public property SpotLightCount: Integer read GetSpotCount;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: File3DS: Class TKeyFramer

Class TKeyFramer

Unit

File3DS

Declaration

type TKeyFramer = class(TObject)

Description

Hierarchy

  • TObject
  • TKeyFramer

Overview

Methods

Public | constructor Create(AOwner: TFile3DS); virtual;
Public | destructor Destroy; override;
Public | procedure ClearLists;

Properties

Public | property AmbientLightMotion: PKFAmbient3DS read GetAmbientMotion;
Public | property CameraMotion[Index: Integer]: PKFCamera3DS read GetCameraMotion;
Public | property CameraMotionCount: Integer read GetCamMotionCount;
Public | property MeshMotion[Index: Integer]: PKFMesh3DS read GetMeshMotion;
Public | property MeshMotionCount: Integer read GetMeshMotionCount;
Public | property OmniLightMotion[Index: Integer]: PKFOmni3DS read GetOmniLightMotion;
Public | property OmniLightMotionCount: Integer read GetOmniMotionCount;
Public | property Settings: TKFSets3DS read GetKFSets;
Public | property SpotLightMotion[Index: Integer]: PKFSpot3DS read GetSpotLightMotion;
Public | property SpotLightMotionCount: Integer read GetSpotMotionCount;

Description

Methods

Public constructor Create(AOwner: TFile3DS); virtual;
Public destructor Destroy; override;
Public procedure ClearLists;

Properties

Public property AmbientLightMotion: PKFAmbient3DS read GetAmbientMotion;
Public property CameraMotion[Index: Integer]: PKFCamera3DS read GetCameraMotion;
Public property CameraMotionCount: Integer read GetCamMotionCount;
Public property MeshMotion[Index: Integer]: PKFMesh3DS read GetMeshMotion;
Public property MeshMotionCount: Integer read GetMeshMotionCount;
Public property OmniLightMotion[Index: Integer]: PKFOmni3DS read GetOmniLightMotion;
Public property OmniLightMotionCount: Integer read GetOmniMotionCount;
Public property Settings: TKFSets3DS read GetKFSets;
Public property SpotLightMotion[Index: Integer]: PKFSpot3DS read GetSpotLightMotion;
Public property SpotLightMotionCount: Integer read GetSpotMotionCount;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: File3DS: Class TFile3DS

Class TFile3DS

Unit

File3DS

Declaration

type TFile3DS = class(TObject)

Description

Hierarchy

  • TObject
  • TFile3DS

Overview

Methods

Public | constructor Create; virtual;
Public | constructor CreateFromFile(const FileName: String); virtual;
Public | destructor Destroy; override;
Public | function InitChunkData(Chunk: PChunk3DS): Pointer;
Public | function ReadByte: Byte;
Public | function ReadCardinal: Cardinal;
Public | function ReadDouble: Double;
Public | function ReadFace: TFace3DS;
Public | function ReadInteger: Integer;
Public | function ReadKeyHeader: TKeyHeader3DS;
Public | function ReadPoint: TPoint3DS;
Public | function ReadShort: SmallInt;
Public | function ReadSingle: Single;
Public | function ReadString: PChar3DS;
Public | function ReadTexVert: TTexVert3DS;
Public | function ReadTrackHeader: TTrackHeader3DS;
Public | function ReadWord: Word;
Protected | function FindNodeByID(ID: SmallInt): PNodeList;
Protected | function GetChunkNodeID(Chunk: PChunk3DS): SmallInt;
Protected | function IsNode(Tag: Word): Boolean;
Public | procedure ClearLists;
Public | procedure DumpDataBase(Strings: TStrings; DumpLevel: TDumpLevel);
Public | procedure FinishHeader(StartPos, EndPos: Cardinal);
Public | procedure LoadFromFile(const FileName: String);
Public | procedure LoadFromStream(const aStream: TStream);
Public | procedure ReadChunkData(Chunk: PChunk3DS);
Public | procedure ReadData(Size: Integer; Data: Pointer);
Public | procedure ReadHeader(var ChunkType: Word; var ChunkSize: Cardinal);
Public | procedure SeekChild(Chunk: PChunk3DS);
Public | procedure Skip(AValue: Integer);
Public | procedure WriteByte(AValue: Byte);
Public | procedure WriteCardinal(AValue: Cardinal);
Public | procedure WriteData(Size: Integer; Data: Pointer);
Public | procedure WriteDouble(AValue: Double);
Public | procedure WriteFace(F: TFace3DS);
Public | procedure WriteFixedString(const AValue: String3DS; Len: Integer);
Public | procedure WriteHeader(ChunkType: Word; ChunkSize: Cardinal);
Public | procedure WriteInteger(AValue: Integer);
Public | procedure WriteKeyHeader(K: TKeyHeader3DS);
Public | procedure WritePoint(P: TPoint3DS);
Public | procedure WriteShort(AValue: SmallInt);
Public | procedure WriteSingle(AValue: Single);
Public | procedure WriteString(const AValue: String3DS);
Public | procedure WriteTexVertex(T: TTexVert3DS);
Public | procedure WriteTrackHeader(T: TTrackHeader3DS);
Public | procedure WriteWord(AValue: Word);
Protected | procedure AddToNodeList(Chunk: PChunk3DS);
Protected | procedure AssignParentNames;
Protected | procedure CheckListNodeIDs;
Protected | procedure CreateDatabase;
Protected | procedure InitDatabase;
Protected | procedure KFAddParentName(Chunk: PChunk3DS; Name: String3DS);
Protected | procedure MakeNode(var Node: PNodeList);
Protected | procedure ParseDatabase;
Protected | procedure ReadChildren(Parent: PChunk3DS);
Protected | procedure ReadXDataEntryChildren(Parent: PChunk3DS);
Protected | procedure ReleaseDatabase;
Protected | procedure ReleaseNodeList;
Protected | procedure ReleaseStream;

Properties

Public | property Atmosphere: TAtmosphere3DS read GetAtmosphereData;
Public | property Background: TBackground3DS read GetBackgroundData;
Public | property DatabaseRelease: TReleaseLevel read GetDatabaseRelease;
Public | property DatabaseType: TDBType3DS read GetDatabaseType;
Public | property FileName: String read FFileName;
Public | property KeyFramer: TKeyFramer read FKeyFramer;
Public | property Materials: TMaterialList read FMaterialList;
Public | property MeshRelease: TReleaseLevel read GetMeshRelease;
Public | property MeshSettings: TMeshSet3DS read GetMeshSettings;
Public | property Objects: TObjectList read FObjectList;
Public | property OnLoadProgress: TLoadProgress read FOnLoadProgress write FOnLoadProgress;
Public | property Viewport: TViewport3DS read GetViewportData;

Description

Methods

Public constructor Create; virtual;
Public constructor CreateFromFile(const FileName: String); virtual;
Public destructor Destroy; override;
Public function InitChunkData(Chunk: PChunk3DS): Pointer;
Public function ReadByte: Byte;
Public function ReadCardinal: Cardinal;
Public function ReadDouble: Double;
Public function ReadFace: TFace3DS;
Public function ReadInteger: Integer;
Public function ReadKeyHeader: TKeyHeader3DS;
Public function ReadPoint: TPoint3DS;
Public function ReadShort: SmallInt;
Public function ReadSingle: Single;
Public function ReadString: PChar3DS;
Public function ReadTexVert: TTexVert3DS;
Public function ReadTrackHeader: TTrackHeader3DS;
Public function ReadWord: Word;
Protected function FindNodeByID(ID: SmallInt): PNodeList;
Protected function GetChunkNodeID(Chunk: PChunk3DS): SmallInt;
Protected function IsNode(Tag: Word): Boolean;
Public procedure ClearLists;
Public procedure DumpDataBase(Strings: TStrings; DumpLevel: TDumpLevel);
Public procedure FinishHeader(StartPos, EndPos: Cardinal);
Public procedure LoadFromFile(const FileName: String);
Public procedure LoadFromStream(const aStream: TStream);
Public procedure ReadChunkData(Chunk: PChunk3DS);
Public procedure ReadData(Size: Integer; Data: Pointer);
Public procedure ReadHeader(var ChunkType: Word; var ChunkSize: Cardinal);
Public procedure SeekChild(Chunk: PChunk3DS);
Public procedure Skip(AValue: Integer);
Public procedure WriteByte(AValue: Byte);
Public procedure WriteCardinal(AValue: Cardinal);
Public procedure WriteData(Size: Integer; Data: Pointer);
Public procedure WriteDouble(AValue: Double);
Public procedure WriteFace(F: TFace3DS);
Public procedure WriteFixedString(const AValue: String3DS; Len: Integer);
Public procedure WriteHeader(ChunkType: Word; ChunkSize: Cardinal);
Public procedure WriteInteger(AValue: Integer);
Public procedure WriteKeyHeader(K: TKeyHeader3DS);
Public procedure WritePoint(P: TPoint3DS);
Public procedure WriteShort(AValue: SmallInt);
Public procedure WriteSingle(AValue: Single);
Public procedure WriteString(const AValue: String3DS);
Public procedure WriteTexVertex(T: TTexVert3DS);
Public procedure WriteTrackHeader(T: TTrackHeader3DS);
Public procedure WriteWord(AValue: Word);
Protected procedure AddToNodeList(Chunk: PChunk3DS);
Protected procedure AssignParentNames;
Protected procedure CheckListNodeIDs;
Protected procedure CreateDatabase;
Protected procedure InitDatabase;
Protected procedure KFAddParentName(Chunk: PChunk3DS; Name: String3DS);
Protected procedure MakeNode(var Node: PNodeList);
Protected procedure ParseDatabase;
Protected procedure ReadChildren(Parent: PChunk3DS);
Protected procedure ReadXDataEntryChildren(Parent: PChunk3DS);
Protected procedure ReleaseDatabase;
Protected procedure ReleaseNodeList;
Protected procedure ReleaseStream;

Properties

Public property Atmosphere: TAtmosphere3DS read GetAtmosphereData;
Public property Background: TBackground3DS read GetBackgroundData;
Public property DatabaseRelease: TReleaseLevel read GetDatabaseRelease;
Public property DatabaseType: TDBType3DS read GetDatabaseType;
Public property FileName: String read FFileName;
Public property KeyFramer: TKeyFramer read FKeyFramer;
Public property Materials: TMaterialList read FMaterialList;
Public property MeshRelease: TReleaseLevel read GetMeshRelease;
Public property MeshSettings: TMeshSet3DS read GetMeshSettings;
Public property Objects: TObjectList read FObjectList;
Public property OnLoadProgress: TLoadProgress read FOnLoadProgress write FOnLoadProgress;
Public property Viewport: TViewport3DS read GetViewportData;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: FileB3D

Unit FileB3D

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FileB3D<p>

File streaming class for the B3D loader<p>

<b>History :</b><font size=-1><ul> <li>24/07/09 - DaStr - Got rid of compiler hints <li>29/05/08 - DaStr - Added $I GLScene.inc <li>22/12/05 - Mathx - Added to the GLScene Project. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TB3DMaterial |
Class TB3DTexture |
Class TB3DNode |
Class TFileB3D |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: FileB3D: Class TB3DMaterial

Class TB3DMaterial

Unit

FileB3D

Declaration

type TB3DMaterial = class(TObject)

Description

Hierarchy

  • TObject
  • TB3DMaterial

Overview

Fields

Public MaterialData: TBRUSChunk;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function GetMaterialName: string;

Description

Fields

Public MaterialData: TBRUSChunk;

Methods

Public constructor Create;
Public destructor Destroy; override;
Public function GetMaterialName: string;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: FileB3D: Class TB3DTexture

Class TB3DTexture

Unit

FileB3D

Declaration

type TB3DTexture = class(TObject)

Description

Hierarchy

  • TObject
  • TB3DTexture

Overview

Fields

Public TextureData: TTEXSChunk;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function GetTextureName: string;

Description

Fields

Public TextureData: TTEXSChunk;

Methods

Public constructor Create;
Public destructor Destroy; override;
Public function GetTextureName: string;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: FileB3D: Class TB3DNode

Class TB3DNode

Unit

FileB3D

Declaration

type TB3DNode = class(TObject)

Description

Hierarchy

  • TObject
  • TB3DNode

Overview

Fields

Public NodeData: PNODEChunk;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function GetNodeName: string;
Public | procedure DestroyNodeData(Node: PNODEChunk);

Description

Fields

Public NodeData: PNODEChunk;

Methods

Public constructor Create;
Public destructor Destroy; override;
Public function GetNodeName: string;
Public procedure DestroyNodeData(Node: PNODEChunk);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: FileB3D: Class TFileB3D

Class TFileB3D

Unit

FileB3D

Declaration

type TFileB3D = class(TObject)

Description

Hierarchy

  • TObject
  • TFileB3D

Overview

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | procedure Check;
Public | procedure LoadFromStream(aStream : TStream);

Properties

Public | property Materials: TStringList read fMaterials;
Public | property Nodes: TB3DNode read fNodes;
Public | property Textures: TStringList read fTextures;

Description

Methods

Public constructor Create; virtual;
Public destructor Destroy; override;
Public procedure Check;
Public procedure LoadFromStream(aStream : TStream);

Properties

Public property Materials: TStringList read fMaterials;
Public property Nodes: TB3DNode read fNodes;
Public property Textures: TStringList read fTextures;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: FileGL2

Unit FileGL2

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FileGL2<p>

Ghoul2 (GLM/GLA) file format loading structures<p>

Note: Also referred to as MDX (MDXM/MDXA) format in C source.<p>

<b>History :</b><font size=-1><ul> <li>09/05/03 - SG - Fixed compressed bone pool <li>01/04/03 - SG - Finished GLM/GLA loading procedures <li>25/03/03 - SG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TGLMHeader |
record TGLMSurfaceHeirachy |
record TGLMSurfaceHeader |
record TGLMTriangle |
record TGLMVertex |
record TGLMSurface |
record TGLMLODInfo |
record TGLMLODs |
record TGLAHeader |
record TGLASkeleton |
Class TFileGLM |
Class TFileGLA |

Functions and Procedures

function G2_GetVertWeights(vert:TGLMVertex):Integer;
function G2_GetVertBoneIndex(vert:TGLMVertex; iWeightNum:Integer):Integer;
function G2_GetVertBoneWeight(vert:TGLMVertex; iWeightNum:Cardinal; var fTotalWeight:Single; const iNumWeights:Cardinal):single;
procedure MC_UnCompressQuat(var mat : TMatrix; const comp : TGLACompQuatBone);

Types

TGLMSurfaceHeirachyOffsets = array of integer;
TGLMLODSurfaceOffsets = array of integer;
TGLABone = array[0..2] of TVector4f;
TGLACompQuatBone = array[0..6] of Word;
TGLASkeletonOffsets = array of integer;

Description

Functions and Procedures

function G2_GetVertWeights(vert:TGLMVertex):Integer;
function G2_GetVertBoneIndex(vert:TGLMVertex; iWeightNum:Integer):Integer;
function G2_GetVertBoneWeight(vert:TGLMVertex; iWeightNum:Cardinal; var fTotalWeight:Single; const iNumWeights:Cardinal):single;
procedure MC_UnCompressQuat(var mat : TMatrix; const comp : TGLACompQuatBone);

Types

TGLMSurfaceHeirachyOffsets = array of integer;
TGLMLODSurfaceOffsets = array of integer;
TGLABone = array[0..2] of TVector4f;
TGLACompQuatBone = array[0..6] of Word;
TGLASkeletonOffsets = array of integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: FileGL2: record TGLMHeader

record TGLMHeader

Unit

FileGL2

Declaration

type TGLMHeader = record

Description

Overview

Fields

fileID: array[0..3] of char;
version: integer;
strFile: array[0..63] of char;
animName: array[0..63] of char;
animIndex: integer;
numBones: integer;
numLODs: integer;
ofsLODs: integer;
numSurfaces: integer;
ofsSurfHierarchy: integer;
ofsEnd: integer;

Description

Fields

fileID: array[0..3] of char;
version: integer;
strFile: array[0..63] of char;
animName: array[0..63] of char;
animIndex: integer;
numBones: integer;
numLODs: integer;
ofsLODs: integer;
numSurfaces: integer;
ofsSurfHierarchy: integer;
ofsEnd: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: FileGL2: record TGLMSurfaceHeirachy

record TGLMSurfaceHeirachy

Unit

FileGL2

Declaration

type TGLMSurfaceHeirachy = record

Description

Overview

Fields

name: array[0..63] of Char;
flags: LongWord;
shader: array[0..63] of Char;
shaderIndex: integer;
parentIndex: integer;
numChildren: integer;
childIndices: array of integer;

Description

Fields

name: array[0..63] of Char;
flags: LongWord;
shader: array[0..63] of Char;
shaderIndex: integer;
parentIndex: integer;
numChildren: integer;
childIndices: array of integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:02


GLScene v.1.1.2: FileGL2: record TGLMSurfaceHeader

record TGLMSurfaceHeader

Unit

FileGL2

Declaration

type TGLMSurfaceHeader = record

Description

Overview

Fields

ident: integer;
thisSurfaceIndex: integer;
ofsHeader: integer;
numVerts: integer;
ofsVerts: integer;
numTriangles: integer;
ofsTriangles: integer;
numBoneReferences: integer;
ofsBoneReferences: integer;
ofsEnd: integer;

Description

Fields

ident: integer;
thisSurfaceIndex: integer;
ofsHeader: integer;
numVerts: integer;
ofsVerts: integer;
numTriangles: integer;
ofsTriangles: integer;
numBoneReferences: integer;
ofsBoneReferences: integer;
ofsEnd: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileGL2: record TGLMTriangle

record TGLMTriangle

Unit

FileGL2

Declaration

type TGLMTriangle = record

Description

Overview

Fields

indices: array[0..2] of integer;

Description

Fields

indices: array[0..2] of integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileGL2: record TGLMVertex

record TGLMVertex

Unit

FileGL2

Declaration

type TGLMVertex = record

Description

Overview

Fields

normal: TVector3f;
vertex: TVector3f;
uiNumWeightsAndBoneIndices: Cardinal;
BoneWeightings: array[0..3] of Byte;

Description

Fields

normal: TVector3f;
vertex: TVector3f;
uiNumWeightsAndBoneIndices: Cardinal;
BoneWeightings: array[0..3] of Byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileGL2: record TGLMSurface

record TGLMSurface

Unit

FileGL2

Declaration

type TGLMSurface = record

Description

Overview

Fields

SurfaceHeader: TGLMSurfaceHeader;
Triangles: array of TGLMTriangle;
Vertices: array of TGLMVertex;
TexCoords: array of TVector2f;
BoneReferences: array of Integer;

Description

Fields

SurfaceHeader: TGLMSurfaceHeader;
Triangles: array of TGLMTriangle;
Vertices: array of TGLMVertex;
TexCoords: array of TVector2f;
BoneReferences: array of Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileGL2: record TGLMLODInfo

record TGLMLODInfo

Unit

FileGL2

Declaration

type TGLMLODInfo = record

Description

Overview

Fields

ofsEnd: integer;

Description

Fields

ofsEnd: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileGL2: record TGLMLODs

record TGLMLODs

Unit

FileGL2

Declaration

type TGLMLODs = record

Description

Overview

Fields

LODInfo: TGLMLODInfo;
LODSurfaceOffsets: TGLMLODSurfaceOffsets;
Surfaces: array of TGLMSurface;

Description

Fields

LODInfo: TGLMLODInfo;
LODSurfaceOffsets: TGLMLODSurfaceOffsets;
Surfaces: array of TGLMSurface;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileGL2: record TGLAHeader

record TGLAHeader

Unit

FileGL2

Declaration

type TGLAHeader = record

Description

Overview

Fields

fileID: array[0..3] of char;
version: integer;
Name: array[0..63] of char;
fScale: single;
numFrames: integer;
ofsFrames: integer;
numBones: integer;
ofsCompBonePool: integer;
ofsSkel: integer;
ofsEnd: integer;

Description

Fields

fileID: array[0..3] of char;
version: integer;
Name: array[0..63] of char;
fScale: single;
numFrames: integer;
ofsFrames: integer;
numBones: integer;
ofsCompBonePool: integer;
ofsSkel: integer;
ofsEnd: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileGL2: record TGLASkeleton

record TGLASkeleton

Unit

FileGL2

Declaration

type TGLASkeleton = record

Description

Overview

Fields

name: array[0..63] of char;
flags: LongWord;
parent: Integer;
BasePoseMat: TGLABone;
BasePoseMatInv: TGLABone;
numChildren: Integer;
children: array of Integer;

Description

Fields

name: array[0..63] of char;
flags: LongWord;
parent: Integer;
BasePoseMat: TGLABone;
BasePoseMatInv: TGLABone;
numChildren: Integer;
children: array of Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileGL2: Class TFileGLM

Class TFileGLM

Unit

FileGL2

Declaration

type TFileGLM = class(TObject)

Description

Hierarchy

  • TObject
  • TFileGLM

Overview

Fields

Public | ModelHeader: TGLMHeader;
Public | SurfaceHeirachyOffsets: TGLMSurfaceHeirachyOffsets;
Public | SurfaceHeirachy: array of TGLMSurfaceHeirachy;
Public | LODs: array of TGLMLODs;

Methods

Public procedure LoadFromStream(aStream : TStream);

Description

Fields

Public ModelHeader: TGLMHeader;
Public SurfaceHeirachyOffsets: TGLMSurfaceHeirachyOffsets;
Public SurfaceHeirachy: array of TGLMSurfaceHeirachy;
Public LODs: array of TGLMLODs;

Methods

Public procedure LoadFromStream(aStream : TStream);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileGL2: Class TFileGLA

Class TFileGLA

Unit

FileGL2

Declaration

type TFileGLA = class(TObject)

Description

Hierarchy

  • TObject
  • TFileGLA

Overview

Fields

Public | AnimHeader: TGLAHeader;
Public | SkeletonOffsets: TGLASkeletonOffsets;
Public | Skeleton: array of TGLASkeleton;
Public | BoneIndices: array of Integer;
Public | CompBonePool: array of TGLACompQuatBone;

Methods

Public | function GetCompressedMatrix(Frame,Bone : Integer):TGLACompQuatBone;
Public | function GetUnCompressedMatrix(Frame,Bone : Integer):TMatrix;
Public | procedure LoadFromStream(aStream : TStream);

Description

Fields

Public AnimHeader: TGLAHeader;
Public SkeletonOffsets: TGLASkeletonOffsets;
Public Skeleton: array of TGLASkeleton;
Public BoneIndices: array of Integer;
Public CompBonePool: array of TGLACompQuatBone;

Methods

Public function GetCompressedMatrix(Frame,Bone : Integer):TGLACompQuatBone;
Public function GetUnCompressedMatrix(Frame,Bone : Integer):TMatrix;
Public procedure LoadFromStream(aStream : TStream);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileMD2

Unit FileMD2

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FileMD2<p>

MD2 file loader<p>

<b>Historique : </b><font size=-1><ul> <li>28/08/10 - Yar - Bugfix for FPC 2.5.1 (Thanks Predator) <li>04/03/10 - DanB - TFileMD2.LoadFromStream now uses CharInSet <li>31/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>25/08/03 - Php - Added FreeLists & degibbered LoadFromStream <li>21/07/00 - Egg - Added frame names (Roger Cao/Carlos A. Rivero) <li>07/06/00 - Egg - Added Header, reduced dependencies, LoadFromFile replaced with LoadFromStream, some cleanup & optimizations </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TFileMD2 |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileMD2: Class TFileMD2

Class TFileMD2

Unit

FileMD2

Declaration

type TFileMD2 = class(TObject)

Description

Hierarchy

  • TObject
  • TFileMD2

Overview

Fields

Public | fIndexList: TIndexList;
Public | fVertexList: TVertexList;
Public | FrameNames: TStrings;

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | procedure LoadFromStream(aStream : TStream);

Properties

Public | property iFrames: longInt read FiFrames;
Public | property IndexList: TIndexList read fIndexList;
Public | property iTriangles: longInt read FiTriangles;
Public | property iVertices: longInt read FiVertices;
Public | property VertexList: TVertexList read fVertexList;

Description

Fields

Public fIndexList: TIndexList;
Public fVertexList: TVertexList;
Public FrameNames: TStrings;

Methods

Public constructor Create; virtual;
Public destructor Destroy; override;
Public procedure LoadFromStream(aStream : TStream);

Properties

Public property iFrames: longInt read FiFrames;
Public property IndexList: TIndexList read fIndexList;
Public property iTriangles: longInt read FiTriangles;
Public property iVertices: longInt read FiVertices;
Public property VertexList: TVertexList read fVertexList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileMD3

Unit FileMD3

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TMD3Tag |
record TMD3Bone |
record TMD3Triangle |
record TMD3Face |
record TMD3TexCoord |
record TMD3Skin |
record TMD3Header |
record TMD3MeshHeader |
record TMD3MeshData |
Class TFileMD3 |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileMD3: record TMD3Tag

record TMD3Tag

Unit

FileMD3

Declaration

type TMD3Tag = record

Description

Overview

Fields

strName: array[0..63] of AnsiChar;
vPosition: TVector3f;
rotation: TMatrix3f;

Description

Fields

strName: array[0..63] of AnsiChar;
vPosition: TVector3f;
rotation: TMatrix3f;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileMD3: record TMD3Bone

record TMD3Bone

Unit

FileMD3

Declaration

type TMD3Bone = record

Description

Overview

Fields

mins: TVector3f;
maxs: TVector3f;
position: TVector3f;
scale: single;
creator: array[0..15] of AnsiChar;

Description

Fields

mins: TVector3f;
maxs: TVector3f;
position: TVector3f;
scale: single;
creator: array[0..15] of AnsiChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileMD3: record TMD3Triangle

record TMD3Triangle

Unit

FileMD3

Declaration

type TMD3Triangle = record

Description

Overview

Fields

vertex: TVector3s;
normal: TVector2b;

Description

Fields

vertex: TVector3s;
normal: TVector2b;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileMD3: record TMD3Face

record TMD3Face

Unit

FileMD3

Declaration

type TMD3Face = record

Description

Overview

Fields

vertexIndices: TVector3i;

Description

Fields

vertexIndices: TVector3i;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileMD3: record TMD3TexCoord

record TMD3TexCoord

Unit

FileMD3

Declaration

type TMD3TexCoord = record

Description

Overview

Fields

textureCoord: TVector2f;

Description

Fields

textureCoord: TVector2f;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileMD3: record TMD3Skin

record TMD3Skin

Unit

FileMD3

Declaration

type TMD3Skin = record

Description

Overview

Fields

strName: array[0..63] of AnsiChar;
shaderIndex: Integer;

Description

Fields

strName: array[0..63] of AnsiChar;
shaderIndex: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileMD3: record TMD3Header

record TMD3Header

Unit

FileMD3

Declaration

type TMD3Header = record

Description

Overview

Fields

fileID: array[0..3] of AnsiChar;
version: integer;
strFile: array[0..63] of AnsiChar;
flags: integer;
numFrames: integer;
numTags: integer;
numMeshes: integer;
numMaxSkins: integer;
headerSize: integer;
tagStart: integer;
tagEnd: integer;
fileSize: integer;

Description

Fields

fileID: array[0..3] of AnsiChar;
version: integer;
strFile: array[0..63] of AnsiChar;
flags: integer;
numFrames: integer;
numTags: integer;
numMeshes: integer;
numMaxSkins: integer;
headerSize: integer;
tagStart: integer;
tagEnd: integer;
fileSize: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileMD3: record TMD3MeshHeader

record TMD3MeshHeader

Unit

FileMD3

Declaration

type TMD3MeshHeader = record

Description

Overview

Fields

meshID: array[0..3] of AnsiChar;
strName: array[0..63] of AnsiChar;
flags: integer;
numMeshFrames: integer;
numSkins: integer;
numVertices: integer;
numTriangles: integer;
triStart: integer;
headerSize: integer;
uvStart: integer;
vertexStart: integer;
meshSize: integer;

Description

Fields

meshID: array[0..3] of AnsiChar;
strName: array[0..63] of AnsiChar;
flags: integer;
numMeshFrames: integer;
numSkins: integer;
numVertices: integer;
numTriangles: integer;
triStart: integer;
headerSize: integer;
uvStart: integer;
vertexStart: integer;
meshSize: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileMD3: record TMD3MeshData

record TMD3MeshData

Unit

FileMD3

Declaration

type TMD3MeshData = record

Description

Overview

Fields

MeshHeader: TMD3MeshHeader;
Skins: array of TMD3Skin;
Triangles: array of TMD3Face;
TexCoords: array of TMD3TexCoord;
Vertices: array of TMD3Triangle;

Description

Fields

MeshHeader: TMD3MeshHeader;
Skins: array of TMD3Skin;
Triangles: array of TMD3Face;
TexCoords: array of TMD3TexCoord;
Vertices: array of TMD3Triangle;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileMD3: Class TFileMD3

Class TFileMD3

Unit

FileMD3

Declaration

type TFileMD3 = class(TObject)

Description

Hierarchy

  • TObject
  • TFileMD3

Overview

Fields

Public | ModelHeader: TMD3Header;
Public | Bones: array of TMD3Bone;
Public | Tags: array of TMD3Tag;
Public | MeshData: array of TMD3MeshData;

Methods

Public procedure LoadFromStream(aStream : TStream);

Description

Fields

Public ModelHeader: TMD3Header;
Public Bones: array of TMD3Bone;
Public Tags: array of TMD3Tag;
Public MeshData: array of TMD3MeshData;

Methods

Public procedure LoadFromStream(aStream : TStream);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileNMF

Unit FileNMF

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TNmHeader |
record TNmRawTriangle |
Class TFileNMF |

Constants

NMF_HEADER_TAG = 'NMF ';
NMF_TRIANGLE_TAG = 'TRIS';

Description

Constants

NMF_HEADER_TAG = 'NMF ';
NMF_TRIANGLE_TAG = 'TRIS';
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileNMF: record TNmHeader

record TNmHeader

Unit

FileNMF

Declaration

type TNmHeader = record

Description

Overview

Fields

hdr: array[0..3] of AnsiChar;
size: cardinal;

Description

Fields

hdr: array[0..3] of AnsiChar;
size: cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileNMF: record TNmRawTriangle

record TNmRawTriangle

Unit

FileNMF

Declaration

type TNmRawTriangle = record

Description

Overview

Fields

vert: array[0..2] of TAffineVector;
norm: array[0..2] of TAffineVector;
texCoord: array[0..2] of TTexPoint;

Description

Fields

vert: array[0..2] of TAffineVector;
norm: array[0..2] of TAffineVector;
texCoord: array[0..2] of TTexPoint;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileNMF: Class TFileNMF

Class TFileNMF

Unit

FileNMF

Declaration

type TFileNMF = class(TObject)

Description

Hierarchy

  • TObject
  • TFileNMF

Overview

Fields

Public | FileHeader: TNmHeader;
Public | TrisHeader: TNmHeader;
Public | NumTris: Integer;
Public | RawTriangles: array of TNmRawTriangle;

Methods

Public | procedure LoadFromStream(Stream : TStream);
Public | procedure SaveToStream(Stream : TStream);

Description

Fields

Public FileHeader: TNmHeader;
Public TrisHeader: TNmHeader;
Public NumTris: Integer;
Public RawTriangles: array of TNmRawTriangle;

Methods

Public procedure LoadFromStream(Stream : TStream);
Public procedure SaveToStream(Stream : TStream);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileOCT

Unit FileOCT

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FileOCT<p>

Loader for FSRad OCT files.<p>

<b>History : </b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>02/04/07 - DaStr - Added $I GLScene.inc <li>30/01/03 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TOCTHeader |
record TOCTVertex |
record TOCTFace |
record TOCTTexture |
record TOCTLightmap |
record TOCTLight |
Class TOCTFile |

Types

POCTFace = ˆTOCTFace;
POCTLightmap = ˆTOCTLightmap;

Description

Types

POCTFace = ˆTOCTFace;
POCTLightmap = ˆTOCTLightmap;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileOCT: record TOCTHeader

record TOCTHeader

Unit

FileOCT

Declaration

type TOCTHeader = record

Description

Overview

Fields

numVerts: Integer;
numFaces: Integer;
numTextures: Integer;
numLightmaps: Integer;
numLights: Integer;

Description

Fields

numVerts: Integer;
numFaces: Integer;
numTextures: Integer;
numLightmaps: Integer;
numLights: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileOCT: record TOCTVertex

record TOCTVertex

Unit

FileOCT

Declaration

type TOCTVertex = record

Description

Overview

Fields

tv: TTexPoint;
lv: TTexpoint;
pos: TAffineVector;

Description

Fields

tv: TTexPoint;
lv: TTexpoint;
pos: TAffineVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileOCT: record TOCTFace

record TOCTFace

Unit

FileOCT

Declaration

type TOCTFace = record

Description

Overview

Fields

start: Integer;
num: Integer;
id: Integer;
lid: Integer;
p: THmgPlane;

Description

Fields

start: Integer;
num: Integer;
id: Integer;
lid: Integer;
p: THmgPlane;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileOCT: record TOCTTexture

record TOCTTexture

Unit

FileOCT

Declaration

type TOCTTexture = record

Description

Overview

Fields

id: Integer;
Name: array [0..63] of AnsiChar;

Description

Fields

id: Integer;
Name: array [0..63] of AnsiChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileOCT: record TOCTLightmap

record TOCTLightmap

Unit

FileOCT

Declaration

type TOCTLightmap = record

Description

Overview

Fields

id: Integer;
map: array [0..49151] of Byte;

Description

Fields

id: Integer;
map: array [0..49151] of Byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileOCT: record TOCTLight

record TOCTLight

Unit

FileOCT

Declaration

type TOCTLight = record

Description

Overview

Fields

pos: TAffineVector;
color: TAffineVector;
intensity: Integer;

Description

Fields

pos: TAffineVector;
color: TAffineVector;
intensity: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileOCT: Class TOCTFile

Class TOCTFile

Unit

FileOCT

Declaration

type TOCTFile = class(TObject)

Description

Hierarchy

  • TObject
  • TOCTFile

Overview

Fields

Public | Header: TOCTHeader;
Public | Vertices: array of TOCTVertex;
Public | Faces: array of TOCTFace;
Public | Textures: array of TOCTTexture;
Public | Lightmaps: array of TOCTLightmap;
Public | Lights: array of TOCTLight;
Public | PlayerPos: TAffineVector;

Methods

Public | constructor Create(octStream : TStream); overload;
Public | constructor Create; overload;
Public | procedure AddLight(const lightPos : TAffineVector; const lightColor : TVector; lightIntensity : Integer);
Public | procedure AddTriangles(vertexCoords : TAffineVectorList; texMapCoords : TAffineVectorList; const textureName : String);
Public | procedure SaveToStream(aStream : TStream);

Description

Fields

Public Header: TOCTHeader;
Public Vertices: array of TOCTVertex;
Public Faces: array of TOCTFace;
Public Textures: array of TOCTTexture;
Public Lightmaps: array of TOCTLightmap;
Public Lights: array of TOCTLight;
Public PlayerPos: TAffineVector;

Methods

Public constructor Create(octStream : TStream); overload;
Public constructor Create; overload;
Public procedure AddLight(const lightPos : TAffineVector; const lightColor : TVector; lightIntensity : Integer);
Public procedure AddTriangles(vertexCoords : TAffineVectorList; texMapCoords : TAffineVectorList; const textureName : String);
Public procedure SaveToStream(aStream : TStream);

Saves content to stream in OCT format.<p> The Header is automatically prepared before streaming.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileX

Unit FileX

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FileX<p>

Simple X format support for Delphi (Microsoft's favorite format)<p>

<b>History : </b><font size=-1><ul> <li>04/10/10 - Yar - Fixed TDXFileHeader type (thanks JironBach) <li>07/11/09 - DaStr - Initial version (Added from the GLScene-Lazarus SVN) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TDXFileHeader |
Class TDXNode |
Class TDXMaterial |
Class TDXMaterialList |
Class TDXFrame |
Class TDXMesh |
Class TDXFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileX: record TDXFileHeader

record TDXFileHeader

Unit

FileX

Declaration

type TDXFileHeader = record

Description

Overview

Fields

Magic: array[0..3] of AnsiChar;
Major: array[0..1] of AnsiChar;
Minor: array[0..1] of AnsiChar;
FileType: array[0..3] of AnsiChar;
FloatType: array[0..3] of AnsiChar;

Description

Fields

Magic: array[0..3] of AnsiChar;
Major: array[0..1] of AnsiChar;
Minor: array[0..1] of AnsiChar;
FileType: array[0..3] of AnsiChar;
FloatType: array[0..3] of AnsiChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileX: Class TDXNode

Class TDXNode

Unit

FileX

Declaration

type TDXNode = class(TList)

Description

Hierarchy

  • TList
  • TDXNode

Overview

Methods

Public | constructor Create; virtual;
Public | constructor CreateOwned(AOwner : TDXNode);
Public | procedure Clear; override;

Properties

Public | property Items[index : Integer]: TDXNode read GetItem;
Public | property Name : String read FName write FName;
Public | property Owner : TDXNode read FOwner;
Public | property TypeName : String read FTypeName write FTypeName;

Description

Methods

Public constructor Create; virtual;
Public constructor CreateOwned(AOwner : TDXNode);
Public procedure Clear; override;

Properties

Public property Items[index : Integer]: TDXNode read GetItem;
Public property Name : String read FName write FName;
Public property Owner : TDXNode read FOwner;
Public property TypeName : String read FTypeName write FTypeName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileX: Class TDXMaterial

Class TDXMaterial

Unit

FileX

Declaration

type TDXMaterial = class(TPersistentObject)

Description

no description available, TPersistentObject description follows

Base class for persistent objects.<p> The base requirement is implementation of ReadFromFiler & WriteToFiler in sub-classes, the immediate benefits are support of streaming (to stream, file or string), assignment and cloning.<br> The other requirement being the use of a virtual constructor, which allows polymorphic construction (don't forget to register your subclasses).<p> Note that TPersistentObject implements IUnknown, but does *not* implement reference counting.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TDXMaterial

Overview

Methods

Public constructor CreateOwned(AOwner : TDXMaterialList);

Properties

Public | property Diffuse : TVector4f read FDiffuse write FDiffuse;
Public | property Emissive : TVector3f read FEmissive write FEmissive;
Public | property SpecPower : Single read FSpecPower write FSpecPower;
Public | property Specular : TVector3f read FSpecular write FSpecular;
Public | property Texture : String read FTexture write FTexture;

Description

Methods

Public constructor CreateOwned(AOwner : TDXMaterialList);

Properties

Public property Diffuse : TVector4f read FDiffuse write FDiffuse;
Public property Emissive : TVector3f read FEmissive write FEmissive;
Public property SpecPower : Single read FSpecPower write FSpecPower;
Public property Specular : TVector3f read FSpecular write FSpecular;
Public property Texture : String read FTexture write FTexture;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileX: Class TDXMaterialList

Class TDXMaterialList

Unit

FileX

Declaration

type TDXMaterialList = class(TDXNode)

Description

no description available, TDXNode description follows

Hierarchy

  • TList
  • TDXNode
  • TDXMaterialList

Overview

Properties

Public property Items[index : Integer]: TDXMaterial read GetMaterial;

Description

Properties

Public property Items[index : Integer]: TDXMaterial read GetMaterial;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileX: Class TDXFrame

Class TDXFrame

Unit

FileX

Declaration

type TDXFrame = class(TDXNode)

Description

no description available, TDXNode description follows

Hierarchy

  • TList
  • TDXNode
  • TDXFrame

Overview

Methods

Public | constructor Create; override;
Public | function GlobalMatrix : TMatrix;

Properties

Public property Matrix : TMatrix read FMatrix write FMatrix;

Description

Methods

Public constructor Create; override;
Public function GlobalMatrix : TMatrix;

Properties

Public property Matrix : TMatrix read FMatrix write FMatrix;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileX: Class TDXMesh

Class TDXMesh

Unit

FileX

Declaration

type TDXMesh = class(TDXNode)

Description

no description available, TDXNode description follows

Hierarchy

  • TList
  • TDXNode
  • TDXMesh

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;

Properties

Public | property MaterialIndices : TIntegerList read FMaterialIndices;
Public | property MaterialList : TDXMaterialList read FMaterialList;
Public | property NormalIndices : TIntegerList read FNormalIndices;
Public | property Normals : TAffineVectorList read FNormals;
Public | property TexCoords : TAffineVectorList read FTexCoords;
Public | property VertCountIndices : TIntegerList read FVertCountIndices;
Public | property VertexIndices : TIntegerList read FVertexIndices;
Public | property Vertices : TAffineVectorList read FVertices;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;

Properties

Public property MaterialIndices : TIntegerList read FMaterialIndices;
Public property MaterialList : TDXMaterialList read FMaterialList;
Public property NormalIndices : TIntegerList read FNormalIndices;
Public property Normals : TAffineVectorList read FNormals;
Public property TexCoords : TAffineVectorList read FTexCoords;
Public property VertCountIndices : TIntegerList read FVertCountIndices;
Public property VertexIndices : TIntegerList read FVertexIndices;
Public property Vertices : TAffineVectorList read FVertices;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FileX: Class TDXFile

Class TDXFile

Unit

FileX

Declaration

type TDXFile = class(TObject)

Description

Hierarchy

  • TObject
  • TDXFile

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure LoadFromStream(Stream : TStream);
Protected | procedure ParseBinary(Stream : TStream);
Protected | procedure ParseText(Stream : TStream);

Properties

Public | property Header : TDXFileHeader read FHeader;
Public | property RootNode : TDXNode read FRootNode;

Description

Methods

Public constructor Create;
Public destructor Destroy; override;
Public procedure LoadFromStream(Stream : TStream);
Protected procedure ParseBinary(Stream : TStream);
Protected procedure ParseText(Stream : TStream);

Properties

Public property Header : TDXFileHeader read FHeader;
Public property RootNode : TDXNode read FRootNode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FLibMaterialPicker

Unit FLibMaterialPicker

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Egg<p>

Allows choosing a material in a material library<p>

<b>Historique : </b><font size=-1><ul> <li>05/09/08 - DanB - Removed Kylix support <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>19/12/06 - DaStr - LBMaterials.OnDblClick now handled <li>03/07/04 - LR - Make change for Linux <li>14/02/00 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TLibMaterialPicker |

Functions and Procedures

function LibMaterialPicker: TLibMaterialPicker;
procedure ReleaseLibMaterialPicker;

Description

Functions and Procedures

function LibMaterialPicker: TLibMaterialPicker;
procedure ReleaseLibMaterialPicker;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FLibMaterialPicker: Class TLibMaterialPicker

Class TLibMaterialPicker

Unit

FLibMaterialPicker

Declaration

type TLibMaterialPicker = class(TForm)

Description

Hierarchy

  • TForm
  • TLibMaterialPicker

Overview

Fields

Published | LBMaterials: TListBox;
Published | Label1: TLabel;
Published | Label2: TLabel;
Published | BBOk: TBitBtn;
Published | BBCancel: TBitBtn;
Published | MPPreview: TRMaterialPreview;

Methods

Public | function Execute(var materialName: TGLLibMaterialName; materialLibrary: TGLAbstractMaterialLibrary): Boolean;
Published | procedure LBMaterialsClick(Sender: TObject);
Published | procedure LBMaterialsDblClick(Sender: TObject);
Published | procedure LBMaterialsKeyPress(Sender: TObject; var Key: Char);

Description

Fields

Published LBMaterials: TListBox;
Published Label1: TLabel;
Published Label2: TLabel;
Published BBOk: TBitBtn;
Published BBCancel: TBitBtn;
Published MPPreview: TRMaterialPreview;

Methods

Public function Execute(var materialName: TGLLibMaterialName; materialLibrary: TGLAbstractMaterialLibrary): Boolean;
Published procedure LBMaterialsClick(Sender: TObject);
Published procedure LBMaterialsDblClick(Sender: TObject);
Published procedure LBMaterialsKeyPress(Sender: TObject; var Key: Char);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FLibMaterialPickerLCL

Unit FLibMaterialPickerLCL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Egg<p>

Allows choosing a material in a material library<p>

<b>Historique : </b><font size=-1><ul>

</ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TLibMaterialPicker |

Functions and Procedures

function LibMaterialPicker: TLibMaterialPicker;
procedure ReleaseLibMaterialPicker;

Description

Functions and Procedures

function LibMaterialPicker: TLibMaterialPicker;
procedure ReleaseLibMaterialPicker;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FLibMaterialPickerLCL: Class TLibMaterialPicker

Class TLibMaterialPicker

Unit

FLibMaterialPickerLCL

Declaration

type TLibMaterialPicker = class(TForm)

Description

Hierarchy

  • TForm
  • TLibMaterialPicker

Overview

Fields

Published | LBMaterials: TListBox;
Published | Label1: TLabel;
Published | Label2: TLabel;
Published | BBOk: TBitBtn;
Published | BBCancel: TBitBtn;
Published | GLScene1: TGLScene;
Published | SceneViewer: TGLSceneViewer;
Published | CBObject: TComboBox;
Published | Camera: TGLCamera;
Published | Cube: TGLCube;
Published | Sphere: TGLSphere;
Published | LightSource: TGLLightSource;
Published | CBBackground: TComboBox;
Published | BackGroundSprite: TGLHUDSprite;
Published | Cone: TGLCone;
Published | Teapot: TGLTeapot;
Published | World: TGLDummyCube;
Published | Light: TGLDummyCube;
Published | FireSphere: TGLSphere;
Published | GLMaterialLibrary: TGLMaterialLibrary;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function Execute(var materialName: TGLLibMaterialName; materialLibrary: TGLAbstractMaterialLibrary): boolean;
Published | procedure CBBackgroundChange(Sender: TObject);
Published | procedure CBObjectChange(Sender: TObject);
Published | procedure LBMaterialsClick(Sender: TObject);
Published | procedure LBMaterialsDblClick(Sender: TObject);
Published | procedure LBMaterialsKeyPress(Sender: TObject; var Key: char);
Published | procedure SceneViewerMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: integer);
Published | procedure SceneViewerMouseMove(Sender: TObject; Shift: TShiftState; X, Y: integer);
Published | procedure SceneViewerMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: integer; MousePos: TPoint; var Handled: boolean);

Description

Fields

Published LBMaterials: TListBox;
Published Label1: TLabel;
Published Label2: TLabel;
Published BBOk: TBitBtn;
Published BBCancel: TBitBtn;
Published GLScene1: TGLScene;
Published SceneViewer: TGLSceneViewer;
Published CBObject: TComboBox;
Published Camera: TGLCamera;
Published Cube: TGLCube;
Published Sphere: TGLSphere;
Published LightSource: TGLLightSource;
Published CBBackground: TComboBox;
Published BackGroundSprite: TGLHUDSprite;
Published Cone: TGLCone;
Published Teapot: TGLTeapot;
Published World: TGLDummyCube;
Published Light: TGLDummyCube;
Published FireSphere: TGLSphere;
Published GLMaterialLibrary: TGLMaterialLibrary;

Methods

Public constructor Create(AOwner: TComponent); override;
Public function Execute(var materialName: TGLLibMaterialName; materialLibrary: TGLAbstractMaterialLibrary): boolean;
Published procedure CBBackgroundChange(Sender: TObject);
Published procedure CBObjectChange(Sender: TObject);
Published procedure LBMaterialsClick(Sender: TObject);
Published procedure LBMaterialsDblClick(Sender: TObject);
Published procedure LBMaterialsKeyPress(Sender: TObject; var Key: char);
Published procedure SceneViewerMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: integer);
Published procedure SceneViewerMouseMove(Sender: TObject; Shift: TShiftState; X, Y: integer);
Published procedure SceneViewerMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: integer; MousePos: TPoint; var Handled: boolean);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FMaterialEditorForm

Unit FMaterialEditorForm

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FMaterialEditorForm<p>

Editor window for a material (with preview).<p>

<b>Historique : </b><font size=-1><ul> <li>07/05/10 - Yar - Fixed PolygonMode and texture image class lookup <li>05/10/08 - DanB - Removed Kylix support <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>19/12/06 - DaStr - All comboboxes get their Items using RTTI (thanks to dikoe Kenguru for the reminder and Roman Ganz for the code) <li>03/07/04 - LR - Make change for Linux <li>24/03/00 - Egg - Added Blending <li>06/02/00 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMaterialEditorForm |

Functions and Procedures

function MaterialEditorForm: TMaterialEditorForm;
procedure ReleaseMaterialEditorForm;

Description

Functions and Procedures

function MaterialEditorForm: TMaterialEditorForm;
procedure ReleaseMaterialEditorForm;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FMaterialEditorForm: Class TMaterialEditorForm

Class TMaterialEditorForm

Unit

FMaterialEditorForm

Declaration

type TMaterialEditorForm = class(TForm)

Description

Hierarchy

  • TForm
  • TMaterialEditorForm

Overview

Fields

Published | PageControl1: TPageControl;
Published | TSFront: TTabSheet;
Published | TSBack: TTabSheet;
Published | TSTexture: TTabSheet;
Published | FEFront: TRFaceEditor;
Published | FEBack: TRFaceEditor;
Published | GroupBox1: TGroupBox;
Published | MPPreview: TRMaterialPreview;
Published | BBOk: TBitBtn;
Published | BBCancel: TBitBtn;
Published | RTextureEdit: TRTextureEdit;
Published | CBBlending: TComboBox;
Published | Label1: TLabel;
Published | Label2: TLabel;
Published | CBPolygonMode: TComboBox;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function Execute(AMaterial: TGLMaterial): Boolean;
Published | procedure OnMaterialChanged(Sender: TObject);

Description

Fields

Published PageControl1: TPageControl;
Published TSFront: TTabSheet;
Published TSBack: TTabSheet;
Published TSTexture: TTabSheet;
Published FEFront: TRFaceEditor;
Published FEBack: TRFaceEditor;
Published GroupBox1: TGroupBox;
Published MPPreview: TRMaterialPreview;
Published BBOk: TBitBtn;
Published BBCancel: TBitBtn;
Published RTextureEdit: TRTextureEdit;
Published CBBlending: TComboBox;
Published Label1: TLabel;
Published Label2: TLabel;
Published CBPolygonMode: TComboBox;

Methods

Public constructor Create(AOwner: TComponent); override;
Public function Execute(AMaterial: TGLMaterial): Boolean;
Published procedure OnMaterialChanged(Sender: TObject);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FMaterialEditorFormLCL

Unit FMaterialEditorFormLCL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FMaterialEditorForm<p>

Editor window for a material (with preview).<p>

<b>Historique : </b><font size=-1><ul> <li>08/06/10 - Yar - Bugfixed asignment edition result to material </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMaterialEditorForm |

Functions and Procedures

function MaterialEditorForm: TMaterialEditorForm;
procedure ReleaseMaterialEditorForm;

Description

Functions and Procedures

function MaterialEditorForm: TMaterialEditorForm;
procedure ReleaseMaterialEditorForm;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: FMaterialEditorFormLCL: Class TMaterialEditorForm

Class TMaterialEditorForm

Unit

FMaterialEditorFormLCL

Declaration

type TMaterialEditorForm = class(TForm)

Description

Hierarchy

  • TForm
  • TMaterialEditorForm

Overview

Fields

Published | CBPolygonMode: TComboBox;
Published | Label2: TLabel;
Published | PageControl1: TPageControl;
Published | TSFront: TTabSheet;
Published | TSBack: TTabSheet;
Published | TSTexture: TTabSheet;
Published | GroupBox1: TGroupBox;
Published | BBOk: TBitBtn;
Published | BBCancel: TBitBtn;
Published | RTextureEdit: TRTextureEdit;
Published | CBBlending: TComboBox;
Published | Label1: TLabel;
Published | GLScene1: TGLScene;
Published | SceneViewer: TGLSceneViewer;
Published | CBObject: TComboBox;
Published | Camera: TGLCamera;
Published | Cube: TGLCube;
Published | Sphere: TGLSphere;
Published | LightSource: TGLLightSource;
Published | CBBackground: TComboBox;
Published | BackGroundSprite: TGLHUDSprite;
Published | Cone: TGLCone;
Published | Teapot: TGLTeapot;
Published | World: TGLDummyCube;
Published | Light: TGLDummyCube;
Published | FireSphere: TGLSphere;
Published | GLMaterialLibrary: TGLMaterialLibrary;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function Execute(AMaterial: TGLMaterial): boolean;
Published | procedure CBBackgroundChange(Sender: TObject);
Published | procedure CBObjectChange(Sender: TObject);
Published | procedure OnMaterialChanged(Sender: TObject);
Published | procedure SceneViewerMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: integer);
Published | procedure SceneViewerMouseMove(Sender: TObject; Shift: TShiftState; X, Y: integer);
Published | procedure SceneViewerMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: integer; MousePos: TPoint; var Handled: boolean);

Description

Fields

Published CBPolygonMode: TComboBox;
Published Label2: TLabel;
Published PageControl1: TPageControl;
Published TSFront: TTabSheet;
Published TSBack: TTabSheet;
Published TSTexture: TTabSheet;
Published GroupBox1: TGroupBox;
Published BBOk: TBitBtn;
Published BBCancel: TBitBtn;
Published RTextureEdit: TRTextureEdit;
Published CBBlending: TComboBox;
Published Label1: TLabel;
Published GLScene1: TGLScene;
Published SceneViewer: TGLSceneViewer;
Published CBObject: TComboBox;
Published Camera: TGLCamera;
Published Cube: TGLCube;
Published Sphere: TGLSphere;
Published LightSource: TGLLightSource;
Published CBBackground: TComboBox;
Published BackGroundSprite: TGLHUDSprite;
Published Cone: TGLCone;
Published Teapot: TGLTeapot;
Published World: TGLDummyCube;
Published Light: TGLDummyCube;
Published FireSphere: TGLSphere;
Published GLMaterialLibrary: TGLMaterialLibrary;

Methods

Public constructor Create(AOwner: TComponent); override;
Public function Execute(AMaterial: TGLMaterial): boolean;
Published procedure CBBackgroundChange(Sender: TObject);
Published procedure CBObjectChange(Sender: TObject);
Published procedure OnMaterialChanged(Sender: TObject);
Published procedure SceneViewerMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: integer);
Published procedure SceneViewerMouseMove(Sender: TObject; Shift: TShiftState; X, Y: integer);
Published procedure SceneViewerMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: integer; MousePos: TPoint; var Handled: boolean);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:03


GLScene v.1.1.2: fmod

Unit fmod

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Functions and Procedures

function FMOD_Load(LibName: PChar): Boolean;
procedure FMOD_Unload;
function FSOUND_SetOutput(OutputType: TFSoundOutputTypes): ByteBool; stdcall;
function FSOUND_SetDriver(Driver: Integer): ByteBool; stdcall;
function FSOUND_SetMixer(Mixer: TFSoundMixerTypes): ByteBool; stdcall;
function FSOUND_SetBufferSize(LenMs: Integer): ByteBool; stdcall;
function FSOUND_SetHWND(Hwnd: THandle): ByteBool; stdcall;
function FSOUND_SetMinHardwareChannels(Min: Integer): ByteBool; stdcall;
function FSOUND_SetMaxHardwareChannels(Max: Integer): ByteBool; stdcall;
function FSOUND_SetMemorySystem(Pool: Pointer; PoolLen: Integer; UserAlloc: TFSoundAllocCallback; UserRealloc: TFSoundReallocCallback; UserFree: TFSoundFreeCallback): ByteBool; stdcall;
function FSOUND_Init(MixRate: Integer; MaxSoftwareChannels: Integer; Flags: Cardinal): ByteBool; stdcall;
procedure FSOUND_Close; stdcall;
procedure FSOUND_Update; stdcall;
procedure FSOUND_SetSpeakerMode(SpeakerMode: Cardinal); stdcall;
procedure FSOUND_SetSFXMasterVolume(Volume: Integer); stdcall;
procedure FSOUND_SetPanSeperation(PanSep: Single); stdcall;
procedure FSOUND_File_SetCallbacks(OpenCallback: TFSoundOpenCallback; CloseCallback: TFSoundCloseCallback; ReadCallback: TFSoundReadCallback; SeekCallback: TFSoundSeekCallback; TellCallback: TFSoundTellCallback); stdcall;
function FSOUND_GetError: TFModErrors; stdcall;
function FSOUND_GetVersion: Single; stdcall;
function FSOUND_GetOutput: TFSoundOutputTypes; stdcall;
function FSOUND_GetOutputHandle: Pointer; stdcall;
function FSOUND_GetDriver: Integer; stdcall;
function FSOUND_GetMixer: TFSoundMixerTypes; stdcall;
function FSOUND_GetNumDrivers: Integer; stdcall;
function FSOUND_GetDriverName(Id: Integer): PAnsiChar; stdcall;
function FSOUND_GetDriverCaps(Id: Integer; var Caps: Cardinal): ByteBool; stdcall;
function FSOUND_GetOutputRate: Integer; stdcall;
function FSOUND_GetMaxChannels: Integer; stdcall;
function FSOUND_GetMaxSamples: Integer; stdcall;
function FSOUND_GetSFXMasterVolume: Integer; stdcall;
function FSOUND_GetNumHWChannels(var num2d: Integer; var num3d: Integer; var total: Integer): ByteBool; stdcall;
function FSOUND_GetChannelsPlaying: Integer; stdcall;
function FSOUND_GetCPUUsage: Single; stdcall;
procedure FSOUND_GetMemoryStats(var CurrentAlloced: Cardinal; var MaxAlloced: Cardinal); stdcall;
function FSOUND_Sample_Load(Index: Integer; const NameOrData: PAnsiChar; Mode: Cardinal; Offset: Integer; Length: Integer): PFSoundSample; stdcall;
function FSOUND_Sample_Alloc(Index: Integer; Length: Integer; Mode: Cardinal; DefFreq: Integer; DefVol: Integer; DefPan: Integer; DefPri: Integer): PFSoundSample; stdcall;
procedure FSOUND_Sample_Free(Sptr: PFSoundSample); stdcall;
function FSOUND_Sample_Upload(Sptr: PFSoundSample; SrcData: Pointer; Mode: Cardinal): ByteBool; stdcall;
function FSOUND_Sample_Lock(Sptr: PFSoundSample; Offset: Integer; Length: Integer; var Ptr1: Pointer; var Ptr2: Pointer; var Len1: Cardinal; var Len2: Cardinal): ByteBool; stdcall;
function FSOUND_Sample_Unlock(Sptr: PFSoundSample; Ptr1: Pointer; Ptr2: Pointer; Len1: Cardinal; Len2: Cardinal): ByteBool; stdcall;
function FSOUND_Sample_SetMode(Sptr: PFSoundSample; Mode: Cardinal): ByteBool; stdcall;
function FSOUND_Sample_SetLoopPoints(Sptr: PFSoundSample; LoopStart, LoopEnd: Integer): ByteBool; stdcall;
function FSOUND_Sample_SetDefaults(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri: Integer): ByteBool; stdcall;
function FSOUND_Sample_SetDefaultsEx(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri, VarFreq, VarVol, VarPan: Integer): ByteBool; stdcall;
function FSOUND_Sample_SetMinMaxDistance(Sptr: PFSoundSample; Min, Max: Single): ByteBool; stdcall;
function FSOUND_Sample_SetMaxPlaybacks(Sptr: PFSoundSample; Max: Integer): ByteBool; stdcall;
function FSOUND_Sample_Get(SampNo: Integer): PFSoundSample; stdcall;
function FSOUND_Sample_GetName(Sptr: PFSoundSample): PAnsiChar; stdcall;
function FSOUND_Sample_GetLength(Sptr: PFSoundSample): Cardinal; stdcall;
function FSOUND_Sample_GetLoopPoints(Sptr: PFSoundSample; var LoopStart: Integer; var LoopEnd: Integer): ByteBool; stdcall;
function FSOUND_Sample_GetDefaults(Sptr: PFSoundSample; var DefFreq: Integer; var DefVol: Integer; var DefPan: Integer; var DefPri: Integer): ByteBool; stdcall;
function FSOUND_Sample_GetDefaultsEx(Sptr: PFSoundSample; var DefFreq: Integer; var DefVol: Integer; var DefPan: Integer; var DefPri: Integer;var VarFreq: Integer; var VarVol: Integer; var VarPan: Integer): ByteBool; stdcall;
function FSOUND_Sample_GetMode(Sptr: PFSoundSample): Cardinal; stdcall;
function FSOUND_Sample_GetMinMaxDistance(Sptr: PFSoundSample; var Min: Single; var Max: Single): ByteBool; stdcall;
function FSOUND_PlaySound(Channel: Integer; Sptr: PFSoundSample): Integer; stdcall;
function FSOUND_PlaySoundEx(Channel: Integer; Sptr: PFSoundSample; Dsp: PFSoundDSPUnit; StartPaused: ByteBool): Integer; stdcall;
function FSOUND_StopSound(Channel: Integer): ByteBool; stdcall;
function FSOUND_SetFrequency(Channel: Integer; Freq: Integer): ByteBool; stdcall;
function FSOUND_SetVolume(Channel: Integer; Vol: Integer): ByteBool; stdcall;
function FSOUND_SetVolumeAbsolute(Channel: Integer; Vol: Integer): ByteBool; stdcall;
function FSOUND_SetPan(Channel: Integer; Pan: Integer): ByteBool; stdcall;
function FSOUND_SetSurround(Channel: Integer; Surround: ByteBool): ByteBool; stdcall;
function FSOUND_SetMute(Channel: Integer; Mute: ByteBool): ByteBool; stdcall;
function FSOUND_SetPriority(Channel: Integer; Priority: Integer): ByteBool; stdcall;
function FSOUND_SetReserved(Channel: Integer; Reserved: ByteBool): ByteBool; stdcall;
function FSOUND_SetPaused(Channel: Integer; Paused: ByteBool): ByteBool; stdcall;
function FSOUND_SetLoopMode(Channel: Integer; LoopMode: Cardinal): ByteBool; stdcall;
function FSOUND_SetCurrentPosition(Channel: Integer; Offset: Cardinal): ByteBool; stdcall;
function FSOUND_3D_SetAttributes(Channel: Integer; Pos: PFSoundVector; Vel: PFSoundVector): ByteBool; stdcall;
function FSOUND_3D_SetMinMaxDistance(Channel: Integer; Min: Single; Max: Single): ByteBool; stdcall;
function FSOUND_IsPlaying(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetFrequency(Channel: Integer): Integer; stdcall;
function FSOUND_GetVolume(Channel: Integer): Integer; stdcall;
function FSOUND_GetAmplitude(Channel: Integer): Integer; stdcall;
function FSOUND_GetPan(Channel: Integer): Integer; stdcall;
function FSOUND_GetSurround(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetMute(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetPriority(Channel: Integer): Integer; stdcall;
function FSOUND_GetReserved(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetPaused(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetLoopMode(Channel: Integer): Cardinal; stdcall;
function FSOUND_GetCurrentPosition(Channel: Integer): Cardinal; stdcall;
function FSOUND_GetCurrentSample(Channel: Integer): PFSoundSample; stdcall;
function FSOUND_GetCurrentLevels(Channel: Integer; l, r: PSingle): ByteBool; stdcall;
function FSOUND_GetNumSubChannels(Channel: Integer): Integer; stdcall;
function FSOUND_GetSubChannel(Channel: Integer; SubChannel: Integer): Integer; stdcall;
function FSOUND_3D_GetAttributes(Channel: Integer; Pos: PFSoundVector; Vel: PFSoundVector): ByteBool; stdcall;
function FSOUND_3D_GetMinMaxDistance(Channel: Integer; var Min: Single; var Max: Single): ByteBool; stdcall;
procedure FSOUND_3D_Listener_SetCurrent(current: Integer); stdcall;
procedure FSOUND_3D_Listener_SetAttributes(Pos: PFSoundVector; Vel: PFSoundVector; fx: Single; fy: Single; fz: Single; tx: Single; ty: Single; tz: Single); stdcall;
procedure FSOUND_3D_Listener_GetAttributes(Pos: PFSoundVector; Vel: PFSoundVector; fx: PSingle; fy: PSingle; fz: PSingle; tx: PSingle; ty: PSingle; tz: PSingle); stdcall;
procedure FSOUND_3D_SetDopplerFactor(Scale: Single); stdcall;
procedure FSOUND_3D_SetDistanceFactor(Scale: Single); stdcall;
procedure FSOUND_3D_SetRolloffFactor(Scale: Single); stdcall;
function FSOUND_FX_Enable(Channel: Integer; Fx: TFSoundFXModes): Integer; stdcall;
function FSOUND_FX_Disable(Channel: Integer): ByteBool; stdcall;
function FSOUND_FX_SetChorus(FXId: Integer; WetDryMix, Depth, Feedback, Frequency: Single; Waveform: Integer; Delay: Single; Phase: Integer): ByteBool; stdcall;
function FSOUND_FX_SetCompressor(FXId: Integer; Gain, Attack, Release, Threshold, Ratio, Predelay: Single): ByteBool; stdcall;
function FSOUND_FX_SetDistortion(FXId: Integer; Gain, Edge, PostEQCenterFrequency, PostEQBandwidth, PreLowpassCutoff: Single): ByteBool; stdcall;
function FSOUND_FX_SetEcho(FXId: Integer; WetDryMix, Feedback, LeftDelay, RightDelay: Single; PanDelay: Integer): ByteBool; stdcall;
function FSOUND_FX_SetFlanger(FXId: Integer; WetDryMix, Depth, Feedback, Frequency: Single; Waveform: Integer; Delay: Single; Phase: Integer): ByteBool; stdcall;
function FSOUND_FX_SetGargle(FXId, RateHz, WaveShape: Integer): ByteBool; stdcall;
function FSOUND_FX_SetI3DL2Reverb(FXId, Room, RoomHF: Integer; RoomRolloffFactor, DecayTime, DecayHFRatio: Single; Reflections: Integer; ReflectionsDelay: Single; Reverb: Integer; ReverbDelay, Diffusion, Density, HFReference: Single): ByteBool; stdcall;
function FSOUND_FX_SetParamEQ(FXId: Integer; Center, Bandwidth, Gain: Single): ByteBool; stdcall;
function FSOUND_FX_SetWavesReverb(FXId: Integer; InGain, ReverbMix, ReverbTime, HighFreqRTRatio: Single): ByteBool; stdcall;
function FSOUND_Stream_SetBufferSize(Ms: Integer): ByteBool; stdcall;
function FSOUND_Stream_Open(const name_or_data: PAnsiChar; Mode: Cardinal; Offset: Integer; Length: Integer): PFSoundStream; stdcall;
function FSOUND_Stream_Create(Callback: TFSoundStreamCallback; Length: Integer; Mode: Cardinal; SampleRate: Integer; UserData: Integer): PFSoundStream; stdcall;
function FSOUND_Stream_Close(Stream: PFSoundStream): ByteBool; stdcall;
function FSOUND_Stream_Play(Channel: Integer; Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_PlayEx(Channel: Integer; Stream: PFSoundStream; Dsp: PFSoundDSPUnit; StartPaused: ByteBool): Integer; stdcall;
function FSOUND_Stream_Stop(Stream: PFSoundStream): ByteBool; stdcall;
function FSOUND_Stream_SetPosition(Stream: PFSoundStream; Position: Cardinal): ByteBool; stdcall;
function FSOUND_Stream_GetPosition(Stream: PFSoundStream): Cardinal; stdcall;
function FSOUND_Stream_SetTime(Stream: PFSoundStream; Ms: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetTime(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_GetLength(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_GetLengthMs(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_SetMode(Stream: PFSoundStream; mode: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetMode(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_SetLoopPoints(Stream: PFSoundStream; LoopStartPCM, LoopEndPCM: Integer): ByteBool; stdcall;
function FSOUND_Stream_SetLoopCount(Stream: PFSoundStream; Count: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetOpenState(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_GetSample(Stream: PFSoundStream): PFSoundSample; stdcall;
function FSOUND_Stream_CreateDSP(Stream: PFSoundStream; Callback: TFSoundDSPCallback; Priority: Integer; Param: Integer): PFSoundDSPUnit; stdcall;
function FSOUND_Stream_SetEndCallback(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: Integer): ByteBool; stdcall;
function FSOUND_Stream_SetSyncCallback(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: Integer): ByteBool; stdcall;
function FSOUND_Stream_AddSyncPoint(Stream: PFSoundStream; PCMOffset: Cardinal; Name: PAnsiChar): PFSyncPoint; stdcall;
function FSOUND_Stream_DeleteSyncPoint(Point: PFSyncPoint): ByteBool; stdcall;
function FSOUND_Stream_GetNumSyncPoints(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_GetSyncPoint(Stream: PFSoundStream; Index: Integer): PFSyncPoint; stdcall;
function FSOUND_Stream_GetSyncPointInfo(Point: PFSyncPoint; var PCMOffset: Cardinal): PAnsiChar; stdcall;
function FSOUND_Stream_SetSubStream(Stream: PFSoundStream; Index: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetNumSubStreams(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_SetSubStreamSentence(Stream: PFSoundStream; var SentenceList: Cardinal; NumItems: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetNumTagFields(Stream: PFSoundStream; var Num: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetTagField(Stream: PFSoundStream; Num: Integer; var TagType: TFSoundTagFieldType; var Name: PAnsiChar; var Value: Pointer; var Length: Integer): ByteBool; stdcall;
function FSOUND_Stream_FindTagField(Stream: PFSoundStream; TagType: TFSoundTagFieldType; Name: PAnsiChar; var Value: Pointer; var Length: Integer): ByteBool; stdcall;
function FSOUND_Stream_Net_SetProxy(Proxy: PAnsiChar): ByteBool; stdcall;
function FSOUND_Stream_Net_GetLastServerStatus(): PAnsiChar; stdcall;
function FSOUND_Stream_Net_SetBufferProperties(BufferSize: Integer; PreBuffer_Percent: Integer; ReBuffer_Percent: Integer): ByteBool; stdcall;
function FSOUND_Stream_Net_GetBufferProperties(var Buffersize: Integer; var PreBuffer_Percent: Integer; var ReBuffer_Percent: Integer): ByteBool; stdcall;
function FSOUND_Stream_Net_SetMetadataCallback(Stream: PFSoundStream; Callback: TFMetaDataCallback; UserData: Integer): ByteBool; stdcall;
function FSOUND_Stream_Net_GetStatus(Stream: PFSoundStream; var Status: TFSoundStreamNetStatus; var BufferPercentUsed: Integer; var BitRate: Integer; var Flags: Cardinal): ByteBool; stdcall;
function FSOUND_CD_Play(Drive: Byte; Track: Integer): ByteBool; stdcall;
procedure FSOUND_CD_SetPlayMode(Drive: Byte; Mode: Integer); stdcall;
function FSOUND_CD_Stop(Drive: Byte): ByteBool; stdcall;
function FSOUND_CD_SetPaused(Drive: Byte; Paused: ByteBool): ByteBool; stdcall;
function FSOUND_CD_SetVolume(Drive: Byte; Volume: Integer): ByteBool; stdcall;
function FSOUND_CD_SetTrackTime(Drive: Byte; ms: Integer): ByteBool; stdcall;
function FSOUND_CD_OpenTray(Drive: Byte; Open: Byte): ByteBool; stdcall;
function FSOUND_CD_GetPaused(Drive: Byte): ByteBool; stdcall;
function FSOUND_CD_GetTrack(Drive: Byte): Integer; stdcall;
function FSOUND_CD_GetNumTracks(Drive: Byte): Integer; stdcall;
function FSOUND_CD_GetVolume(Drive: Byte): Integer; stdcall;
function FSOUND_CD_GetTrackLength(Drive: Byte; Track: Integer): Integer; stdcall;
function FSOUND_CD_GetTrackTime(Drive: Byte): Integer; stdcall;
function FSOUND_DSP_Create(Callback: TFSoundDSPCallback; Priority: Integer; Param: Integer): PFSoundDSPUnit; stdcall;
procedure FSOUND_DSP_Free(DSPUnit: PFSoundDSPUnit); stdcall;
procedure FSOUND_DSP_SetPriority(DSPUnit: PFSoundDSPUnit; Priority: Integer); stdcall;
function FSOUND_DSP_GetPriority(DSPUnit: PFSoundDSPUnit): Integer; stdcall;
procedure FSOUND_DSP_SetActive(DSPUnit: PFSoundDSPUnit; Active: ByteBool); stdcall;
function FSOUND_DSP_GetActive(DSPUnit: PFSoundDSPUnit): ByteBool; stdcall;
function FSOUND_DSP_GetClearUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_GetSFXUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_GetMusicUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_GetFFTUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_GetClipAndCopyUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_MixBuffers(DestBuffer: Pointer; SrcBuffer: Pointer; Len: Integer; Freq: Integer; Vol: Integer; Pan: Integer; Mode: Cardinal): ByteBool; stdcall;
procedure FSOUND_DSP_ClearMixBuffer; stdcall;
function FSOUND_DSP_GetBufferLength: Integer; stdcall;
function FSOUND_DSP_GetBufferLengthTotal: Integer; stdcall;
function FSOUND_DSP_GetSpectrum: PSingle; stdcall;
function FSOUND_Reverb_SetProperties(var Prop: TFSoundReverbProperties): ByteBool; stdcall;
function FSOUND_Reverb_GetProperties(var Prop: TFSoundReverbProperties): ByteBool; stdcall;
function FSOUND_Reverb_SetChannelProperties(Channel: Integer; var Prop: TFSoundReverbChannelProperties): ByteBool; stdcall;
function FSOUND_Reverb_GetChannelProperties(Channel: Integer; var Prop: TFSoundReverbChannelProperties): ByteBool; stdcall;
function FSOUND_Record_SetDriver(OutputType: Integer): ByteBool; stdcall;
function FSOUND_Record_GetNumDrivers: Integer; stdcall;
function FSOUND_Record_GetDriverName(Id: Integer): PAnsiChar; stdcall;
function FSOUND_Record_GetDriver: Integer; stdcall;
function FSOUND_Record_StartSample(Sptr: PFSoundSample; Loop: ByteBool): ByteBool; stdcall;
function FSOUND_Record_Stop: ByteBool; stdcall;
function FSOUND_Record_GetPosition: Integer; stdcall;
function FMUSIC_LoadSong(const Name: PAnsiChar): PFMusicModule; stdcall;
function FMUSIC_LoadSongEx(Name_Or_Data: Pointer; Offset: Integer; Length: Integer; Mode: Cardinal; var SampleList: Integer; SampleListNum: Integer): PFMusicModule; stdcall;
function FMUSIC_GetOpenState(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_FreeSong(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_PlaySong(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_StopSong(Module: PFMusicModule): ByteBool; stdcall;
procedure FMUSIC_StopAllSongs; stdcall;
function FMUSIC_SetZxxCallback(Module: PFMusicModule; Callback: TFMusicCallback): ByteBool; stdcall;
function FMUSIC_SetRowCallback(Module: PFMusicModule; Callback: TFMusicCallback; RowStep: Integer): ByteBool; stdcall;
function FMUSIC_SetOrderCallback(Module: PFMusicModule; Callback: TFMusicCallback; OrderStep: Integer): ByteBool; stdcall;
function FMUSIC_SetInstCallback(Module: PFMusicModule; Callback: TFMusicCallback; Instrument: Integer): ByteBool; stdcall;
function FMUSIC_SetSample(Module: PFMusicModule; SampNo: Integer; Sptr: PFSoundSample): ByteBool; stdcall;
function FMUSIC_SetUserData(Module: PFMusicModule; userdata: Integer): ByteBool; stdcall;
function FMUSIC_OptimizeChannels(Module: PFMusicModule; MaxChannels: Integer; MinVolume: Integer): ByteBool; stdcall;
function FMUSIC_SetReverb(Reverb: ByteBool): ByteBool; stdcall;
function FMUSIC_SetLooping(Module: PFMusicModule; Looping: ByteBool): ByteBool; stdcall;
function FMUSIC_SetOrder(Module: PFMusicModule; Order: Integer): ByteBool; stdcall;
function FMUSIC_SetPaused(Module: PFMusicModule; Pause: ByteBool): ByteBool; stdcall;
function FMUSIC_SetMasterVolume(Module: PFMusicModule; Volume: Integer): ByteBool; stdcall;
function FMUSIC_SetMasterSpeed(Module: PFMusicModule; speed: Single): ByteBool; stdcall;
function FMUSIC_SetPanSeperation(Module: PFMusicModule; PanSep: Single): ByteBool; stdcall;
function FMUSIC_GetName(Module: PFMusicModule): PAnsiChar; stdcall;
function FMUSIC_GetType(Module: PFMusicModule): TFMusicTypes; stdcall;
function FMUSIC_GetNumOrders(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetNumPatterns(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetNumInstruments(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetNumSamples(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetNumChannels(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetSample(Module: PFMusicModule; SampNo: Integer): PFSoundSample; stdcall;
function FMUSIC_GetPatternLength(Module: PFMusicModule; OrderNo: Integer): Integer; stdcall;
function FMUSIC_IsFinished(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_IsPlaying(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_GetMasterVolume(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetGlobalVolume(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetOrder(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetPattern(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetSpeed(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetBPM(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetRow(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetPaused(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_GetTime(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetRealChannel(Module: PFMusicModule; modchannel: Integer): Integer; stdcall;
function FMUSIC_GetUserData(Module: PFMusicModule): Integer; stdcall;

Description

Functions and Procedures

function FMOD_Load(LibName: PChar): Boolean;
procedure FMOD_Unload;
function FSOUND_SetOutput(OutputType: TFSoundOutputTypes): ByteBool; stdcall;
function FSOUND_SetDriver(Driver: Integer): ByteBool; stdcall;
function FSOUND_SetMixer(Mixer: TFSoundMixerTypes): ByteBool; stdcall;
function FSOUND_SetBufferSize(LenMs: Integer): ByteBool; stdcall;
function FSOUND_SetHWND(Hwnd: THandle): ByteBool; stdcall;
function FSOUND_SetMinHardwareChannels(Min: Integer): ByteBool; stdcall;
function FSOUND_SetMaxHardwareChannels(Max: Integer): ByteBool; stdcall;
function FSOUND_SetMemorySystem(Pool: Pointer; PoolLen: Integer; UserAlloc: TFSoundAllocCallback; UserRealloc: TFSoundReallocCallback; UserFree: TFSoundFreeCallback): ByteBool; stdcall;
function FSOUND_Init(MixRate: Integer; MaxSoftwareChannels: Integer; Flags: Cardinal): ByteBool; stdcall;
procedure FSOUND_Close; stdcall;
procedure FSOUND_Update; stdcall;
procedure FSOUND_SetSpeakerMode(SpeakerMode: Cardinal); stdcall;
procedure FSOUND_SetSFXMasterVolume(Volume: Integer); stdcall;
procedure FSOUND_SetPanSeperation(PanSep: Single); stdcall;
procedure FSOUND_File_SetCallbacks(OpenCallback: TFSoundOpenCallback; CloseCallback: TFSoundCloseCallback; ReadCallback: TFSoundReadCallback; SeekCallback: TFSoundSeekCallback; TellCallback: TFSoundTellCallback); stdcall;
function FSOUND_GetError: TFModErrors; stdcall;
function FSOUND_GetVersion: Single; stdcall;
function FSOUND_GetOutput: TFSoundOutputTypes; stdcall;
function FSOUND_GetOutputHandle: Pointer; stdcall;
function FSOUND_GetDriver: Integer; stdcall;
function FSOUND_GetMixer: TFSoundMixerTypes; stdcall;
function FSOUND_GetNumDrivers: Integer; stdcall;
function FSOUND_GetDriverName(Id: Integer): PAnsiChar; stdcall;
function FSOUND_GetDriverCaps(Id: Integer; var Caps: Cardinal): ByteBool; stdcall;
function FSOUND_GetOutputRate: Integer; stdcall;
function FSOUND_GetMaxChannels: Integer; stdcall;
function FSOUND_GetMaxSamples: Integer; stdcall;
function FSOUND_GetSFXMasterVolume: Integer; stdcall;
function FSOUND_GetNumHWChannels(var num2d: Integer; var num3d: Integer; var total: Integer): ByteBool; stdcall;
function FSOUND_GetChannelsPlaying: Integer; stdcall;
function FSOUND_GetCPUUsage: Single; stdcall;
procedure FSOUND_GetMemoryStats(var CurrentAlloced: Cardinal; var MaxAlloced: Cardinal); stdcall;
function FSOUND_Sample_Load(Index: Integer; const NameOrData: PAnsiChar; Mode: Cardinal; Offset: Integer; Length: Integer): PFSoundSample; stdcall;
function FSOUND_Sample_Alloc(Index: Integer; Length: Integer; Mode: Cardinal; DefFreq: Integer; DefVol: Integer; DefPan: Integer; DefPri: Integer): PFSoundSample; stdcall;
procedure FSOUND_Sample_Free(Sptr: PFSoundSample); stdcall;
function FSOUND_Sample_Upload(Sptr: PFSoundSample; SrcData: Pointer; Mode: Cardinal): ByteBool; stdcall;
function FSOUND_Sample_Lock(Sptr: PFSoundSample; Offset: Integer; Length: Integer; var Ptr1: Pointer; var Ptr2: Pointer; var Len1: Cardinal; var Len2: Cardinal): ByteBool; stdcall;
function FSOUND_Sample_Unlock(Sptr: PFSoundSample; Ptr1: Pointer; Ptr2: Pointer; Len1: Cardinal; Len2: Cardinal): ByteBool; stdcall;
function FSOUND_Sample_SetMode(Sptr: PFSoundSample; Mode: Cardinal): ByteBool; stdcall;
function FSOUND_Sample_SetLoopPoints(Sptr: PFSoundSample; LoopStart, LoopEnd: Integer): ByteBool; stdcall;
function FSOUND_Sample_SetDefaults(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri: Integer): ByteBool; stdcall;
function FSOUND_Sample_SetDefaultsEx(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri, VarFreq, VarVol, VarPan: Integer): ByteBool; stdcall;
function FSOUND_Sample_SetMinMaxDistance(Sptr: PFSoundSample; Min, Max: Single): ByteBool; stdcall;
function FSOUND_Sample_SetMaxPlaybacks(Sptr: PFSoundSample; Max: Integer): ByteBool; stdcall;
function FSOUND_Sample_Get(SampNo: Integer): PFSoundSample; stdcall;
function FSOUND_Sample_GetName(Sptr: PFSoundSample): PAnsiChar; stdcall;
function FSOUND_Sample_GetLength(Sptr: PFSoundSample): Cardinal; stdcall;
function FSOUND_Sample_GetLoopPoints(Sptr: PFSoundSample; var LoopStart: Integer; var LoopEnd: Integer): ByteBool; stdcall;
function FSOUND_Sample_GetDefaults(Sptr: PFSoundSample; var DefFreq: Integer; var DefVol: Integer; var DefPan: Integer; var DefPri: Integer): ByteBool; stdcall;
function FSOUND_Sample_GetDefaultsEx(Sptr: PFSoundSample; var DefFreq: Integer; var DefVol: Integer; var DefPan: Integer; var DefPri: Integer;var VarFreq: Integer; var VarVol: Integer; var VarPan: Integer): ByteBool; stdcall;
function FSOUND_Sample_GetMode(Sptr: PFSoundSample): Cardinal; stdcall;
function FSOUND_Sample_GetMinMaxDistance(Sptr: PFSoundSample; var Min: Single; var Max: Single): ByteBool; stdcall;
function FSOUND_PlaySound(Channel: Integer; Sptr: PFSoundSample): Integer; stdcall;
function FSOUND_PlaySoundEx(Channel: Integer; Sptr: PFSoundSample; Dsp: PFSoundDSPUnit; StartPaused: ByteBool): Integer; stdcall;
function FSOUND_StopSound(Channel: Integer): ByteBool; stdcall;
function FSOUND_SetFrequency(Channel: Integer; Freq: Integer): ByteBool; stdcall;
function FSOUND_SetVolume(Channel: Integer; Vol: Integer): ByteBool; stdcall;
function FSOUND_SetVolumeAbsolute(Channel: Integer; Vol: Integer): ByteBool; stdcall;
function FSOUND_SetPan(Channel: Integer; Pan: Integer): ByteBool; stdcall;
function FSOUND_SetSurround(Channel: Integer; Surround: ByteBool): ByteBool; stdcall;
function FSOUND_SetMute(Channel: Integer; Mute: ByteBool): ByteBool; stdcall;
function FSOUND_SetPriority(Channel: Integer; Priority: Integer): ByteBool; stdcall;
function FSOUND_SetReserved(Channel: Integer; Reserved: ByteBool): ByteBool; stdcall;
function FSOUND_SetPaused(Channel: Integer; Paused: ByteBool): ByteBool; stdcall;
function FSOUND_SetLoopMode(Channel: Integer; LoopMode: Cardinal): ByteBool; stdcall;
function FSOUND_SetCurrentPosition(Channel: Integer; Offset: Cardinal): ByteBool; stdcall;
function FSOUND_3D_SetAttributes(Channel: Integer; Pos: PFSoundVector; Vel: PFSoundVector): ByteBool; stdcall;
function FSOUND_3D_SetMinMaxDistance(Channel: Integer; Min: Single; Max: Single): ByteBool; stdcall;
function FSOUND_IsPlaying(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetFrequency(Channel: Integer): Integer; stdcall;
function FSOUND_GetVolume(Channel: Integer): Integer; stdcall;
function FSOUND_GetAmplitude(Channel: Integer): Integer; stdcall;
function FSOUND_GetPan(Channel: Integer): Integer; stdcall;
function FSOUND_GetSurround(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetMute(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetPriority(Channel: Integer): Integer; stdcall;
function FSOUND_GetReserved(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetPaused(Channel: Integer): ByteBool; stdcall;
function FSOUND_GetLoopMode(Channel: Integer): Cardinal; stdcall;
function FSOUND_GetCurrentPosition(Channel: Integer): Cardinal; stdcall;
function FSOUND_GetCurrentSample(Channel: Integer): PFSoundSample; stdcall;
function FSOUND_GetCurrentLevels(Channel: Integer; l, r: PSingle): ByteBool; stdcall;
function FSOUND_GetNumSubChannels(Channel: Integer): Integer; stdcall;
function FSOUND_GetSubChannel(Channel: Integer; SubChannel: Integer): Integer; stdcall;
function FSOUND_3D_GetAttributes(Channel: Integer; Pos: PFSoundVector; Vel: PFSoundVector): ByteBool; stdcall;
function FSOUND_3D_GetMinMaxDistance(Channel: Integer; var Min: Single; var Max: Single): ByteBool; stdcall;
procedure FSOUND_3D_Listener_SetCurrent(current: Integer); stdcall;
procedure FSOUND_3D_Listener_SetAttributes(Pos: PFSoundVector; Vel: PFSoundVector; fx: Single; fy: Single; fz: Single; tx: Single; ty: Single; tz: Single); stdcall;
procedure FSOUND_3D_Listener_GetAttributes(Pos: PFSoundVector; Vel: PFSoundVector; fx: PSingle; fy: PSingle; fz: PSingle; tx: PSingle; ty: PSingle; tz: PSingle); stdcall;
procedure FSOUND_3D_SetDopplerFactor(Scale: Single); stdcall;
procedure FSOUND_3D_SetDistanceFactor(Scale: Single); stdcall;
procedure FSOUND_3D_SetRolloffFactor(Scale: Single); stdcall;
function FSOUND_FX_Enable(Channel: Integer; Fx: TFSoundFXModes): Integer; stdcall;
function FSOUND_FX_Disable(Channel: Integer): ByteBool; stdcall;
function FSOUND_FX_SetChorus(FXId: Integer; WetDryMix, Depth, Feedback, Frequency: Single; Waveform: Integer; Delay: Single; Phase: Integer): ByteBool; stdcall;
function FSOUND_FX_SetCompressor(FXId: Integer; Gain, Attack, Release, Threshold, Ratio, Predelay: Single): ByteBool; stdcall;
function FSOUND_FX_SetDistortion(FXId: Integer; Gain, Edge, PostEQCenterFrequency, PostEQBandwidth, PreLowpassCutoff: Single): ByteBool; stdcall;
function FSOUND_FX_SetEcho(FXId: Integer; WetDryMix, Feedback, LeftDelay, RightDelay: Single; PanDelay: Integer): ByteBool; stdcall;
function FSOUND_FX_SetFlanger(FXId: Integer; WetDryMix, Depth, Feedback, Frequency: Single; Waveform: Integer; Delay: Single; Phase: Integer): ByteBool; stdcall;
function FSOUND_FX_SetGargle(FXId, RateHz, WaveShape: Integer): ByteBool; stdcall;
function FSOUND_FX_SetI3DL2Reverb(FXId, Room, RoomHF: Integer; RoomRolloffFactor, DecayTime, DecayHFRatio: Single; Reflections: Integer; ReflectionsDelay: Single; Reverb: Integer; ReverbDelay, Diffusion, Density, HFReference: Single): ByteBool; stdcall;
function FSOUND_FX_SetParamEQ(FXId: Integer; Center, Bandwidth, Gain: Single): ByteBool; stdcall;
function FSOUND_FX_SetWavesReverb(FXId: Integer; InGain, ReverbMix, ReverbTime, HighFreqRTRatio: Single): ByteBool; stdcall;
function FSOUND_Stream_SetBufferSize(Ms: Integer): ByteBool; stdcall;
function FSOUND_Stream_Open(const name_or_data: PAnsiChar; Mode: Cardinal; Offset: Integer; Length: Integer): PFSoundStream; stdcall;
function FSOUND_Stream_Create(Callback: TFSoundStreamCallback; Length: Integer; Mode: Cardinal; SampleRate: Integer; UserData: Integer): PFSoundStream; stdcall;
function FSOUND_Stream_Close(Stream: PFSoundStream): ByteBool; stdcall;
function FSOUND_Stream_Play(Channel: Integer; Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_PlayEx(Channel: Integer; Stream: PFSoundStream; Dsp: PFSoundDSPUnit; StartPaused: ByteBool): Integer; stdcall;
function FSOUND_Stream_Stop(Stream: PFSoundStream): ByteBool; stdcall;
function FSOUND_Stream_SetPosition(Stream: PFSoundStream; Position: Cardinal): ByteBool; stdcall;
function FSOUND_Stream_GetPosition(Stream: PFSoundStream): Cardinal; stdcall;
function FSOUND_Stream_SetTime(Stream: PFSoundStream; Ms: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetTime(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_GetLength(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_GetLengthMs(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_SetMode(Stream: PFSoundStream; mode: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetMode(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_SetLoopPoints(Stream: PFSoundStream; LoopStartPCM, LoopEndPCM: Integer): ByteBool; stdcall;
function FSOUND_Stream_SetLoopCount(Stream: PFSoundStream; Count: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetOpenState(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_GetSample(Stream: PFSoundStream): PFSoundSample; stdcall;
function FSOUND_Stream_CreateDSP(Stream: PFSoundStream; Callback: TFSoundDSPCallback; Priority: Integer; Param: Integer): PFSoundDSPUnit; stdcall;
function FSOUND_Stream_SetEndCallback(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: Integer): ByteBool; stdcall;
function FSOUND_Stream_SetSyncCallback(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: Integer): ByteBool; stdcall;
function FSOUND_Stream_AddSyncPoint(Stream: PFSoundStream; PCMOffset: Cardinal; Name: PAnsiChar): PFSyncPoint; stdcall;
function FSOUND_Stream_DeleteSyncPoint(Point: PFSyncPoint): ByteBool; stdcall;
function FSOUND_Stream_GetNumSyncPoints(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_GetSyncPoint(Stream: PFSoundStream; Index: Integer): PFSyncPoint; stdcall;
function FSOUND_Stream_GetSyncPointInfo(Point: PFSyncPoint; var PCMOffset: Cardinal): PAnsiChar; stdcall;
function FSOUND_Stream_SetSubStream(Stream: PFSoundStream; Index: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetNumSubStreams(Stream: PFSoundStream): Integer; stdcall;
function FSOUND_Stream_SetSubStreamSentence(Stream: PFSoundStream; var SentenceList: Cardinal; NumItems: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetNumTagFields(Stream: PFSoundStream; var Num: Integer): ByteBool; stdcall;
function FSOUND_Stream_GetTagField(Stream: PFSoundStream; Num: Integer; var TagType: TFSoundTagFieldType; var Name: PAnsiChar; var Value: Pointer; var Length: Integer): ByteBool; stdcall;
function FSOUND_Stream_FindTagField(Stream: PFSoundStream; TagType: TFSoundTagFieldType; Name: PAnsiChar; var Value: Pointer; var Length: Integer): ByteBool; stdcall;
function FSOUND_Stream_Net_SetProxy(Proxy: PAnsiChar): ByteBool; stdcall;
function FSOUND_Stream_Net_GetLastServerStatus(): PAnsiChar; stdcall;
function FSOUND_Stream_Net_SetBufferProperties(BufferSize: Integer; PreBuffer_Percent: Integer; ReBuffer_Percent: Integer): ByteBool; stdcall;
function FSOUND_Stream_Net_GetBufferProperties(var Buffersize: Integer; var PreBuffer_Percent: Integer; var ReBuffer_Percent: Integer): ByteBool; stdcall;
function FSOUND_Stream_Net_SetMetadataCallback(Stream: PFSoundStream; Callback: TFMetaDataCallback; UserData: Integer): ByteBool; stdcall;
function FSOUND_Stream_Net_GetStatus(Stream: PFSoundStream; var Status: TFSoundStreamNetStatus; var BufferPercentUsed: Integer; var BitRate: Integer; var Flags: Cardinal): ByteBool; stdcall;
function FSOUND_CD_Play(Drive: Byte; Track: Integer): ByteBool; stdcall;
procedure FSOUND_CD_SetPlayMode(Drive: Byte; Mode: Integer); stdcall;
function FSOUND_CD_Stop(Drive: Byte): ByteBool; stdcall;
function FSOUND_CD_SetPaused(Drive: Byte; Paused: ByteBool): ByteBool; stdcall;
function FSOUND_CD_SetVolume(Drive: Byte; Volume: Integer): ByteBool; stdcall;
function FSOUND_CD_SetTrackTime(Drive: Byte; ms: Integer): ByteBool; stdcall;
function FSOUND_CD_OpenTray(Drive: Byte; Open: Byte): ByteBool; stdcall;
function FSOUND_CD_GetPaused(Drive: Byte): ByteBool; stdcall;
function FSOUND_CD_GetTrack(Drive: Byte): Integer; stdcall;
function FSOUND_CD_GetNumTracks(Drive: Byte): Integer; stdcall;
function FSOUND_CD_GetVolume(Drive: Byte): Integer; stdcall;
function FSOUND_CD_GetTrackLength(Drive: Byte; Track: Integer): Integer; stdcall;
function FSOUND_CD_GetTrackTime(Drive: Byte): Integer; stdcall;
function FSOUND_DSP_Create(Callback: TFSoundDSPCallback; Priority: Integer; Param: Integer): PFSoundDSPUnit; stdcall;
procedure FSOUND_DSP_Free(DSPUnit: PFSoundDSPUnit); stdcall;
procedure FSOUND_DSP_SetPriority(DSPUnit: PFSoundDSPUnit; Priority: Integer); stdcall;
function FSOUND_DSP_GetPriority(DSPUnit: PFSoundDSPUnit): Integer; stdcall;
procedure FSOUND_DSP_SetActive(DSPUnit: PFSoundDSPUnit; Active: ByteBool); stdcall;
function FSOUND_DSP_GetActive(DSPUnit: PFSoundDSPUnit): ByteBool; stdcall;
function FSOUND_DSP_GetClearUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_GetSFXUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_GetMusicUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_GetFFTUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_GetClipAndCopyUnit: PFSoundDSPUnit; stdcall;
function FSOUND_DSP_MixBuffers(DestBuffer: Pointer; SrcBuffer: Pointer; Len: Integer; Freq: Integer; Vol: Integer; Pan: Integer; Mode: Cardinal): ByteBool; stdcall;
procedure FSOUND_DSP_ClearMixBuffer; stdcall;
function FSOUND_DSP_GetBufferLength: Integer; stdcall;
function FSOUND_DSP_GetBufferLengthTotal: Integer; stdcall;
function FSOUND_DSP_GetSpectrum: PSingle; stdcall;
function FSOUND_Reverb_SetProperties(var Prop: TFSoundReverbProperties): ByteBool; stdcall;
function FSOUND_Reverb_GetProperties(var Prop: TFSoundReverbProperties): ByteBool; stdcall;
function FSOUND_Reverb_SetChannelProperties(Channel: Integer; var Prop: TFSoundReverbChannelProperties): ByteBool; stdcall;
function FSOUND_Reverb_GetChannelProperties(Channel: Integer; var Prop: TFSoundReverbChannelProperties): ByteBool; stdcall;
function FSOUND_Record_SetDriver(OutputType: Integer): ByteBool; stdcall;
function FSOUND_Record_GetNumDrivers: Integer; stdcall;
function FSOUND_Record_GetDriverName(Id: Integer): PAnsiChar; stdcall;
function FSOUND_Record_GetDriver: Integer; stdcall;
function FSOUND_Record_StartSample(Sptr: PFSoundSample; Loop: ByteBool): ByteBool; stdcall;
function FSOUND_Record_Stop: ByteBool; stdcall;
function FSOUND_Record_GetPosition: Integer; stdcall;
function FMUSIC_LoadSong(const Name: PAnsiChar): PFMusicModule; stdcall;
function FMUSIC_LoadSongEx(Name_Or_Data: Pointer; Offset: Integer; Length: Integer; Mode: Cardinal; var SampleList: Integer; SampleListNum: Integer): PFMusicModule; stdcall;
function FMUSIC_GetOpenState(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_FreeSong(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_PlaySong(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_StopSong(Module: PFMusicModule): ByteBool; stdcall;
procedure FMUSIC_StopAllSongs; stdcall;
function FMUSIC_SetZxxCallback(Module: PFMusicModule; Callback: TFMusicCallback): ByteBool; stdcall;
function FMUSIC_SetRowCallback(Module: PFMusicModule; Callback: TFMusicCallback; RowStep: Integer): ByteBool; stdcall;
function FMUSIC_SetOrderCallback(Module: PFMusicModule; Callback: TFMusicCallback; OrderStep: Integer): ByteBool; stdcall;
function FMUSIC_SetInstCallback(Module: PFMusicModule; Callback: TFMusicCallback; Instrument: Integer): ByteBool; stdcall;
function FMUSIC_SetSample(Module: PFMusicModule; SampNo: Integer; Sptr: PFSoundSample): ByteBool; stdcall;
function FMUSIC_SetUserData(Module: PFMusicModule; userdata: Integer): ByteBool; stdcall;
function FMUSIC_OptimizeChannels(Module: PFMusicModule; MaxChannels: Integer; MinVolume: Integer): ByteBool; stdcall;
function FMUSIC_SetReverb(Reverb: ByteBool): ByteBool; stdcall;
function FMUSIC_SetLooping(Module: PFMusicModule; Looping: ByteBool): ByteBool; stdcall;
function FMUSIC_SetOrder(Module: PFMusicModule; Order: Integer): ByteBool; stdcall;
function FMUSIC_SetPaused(Module: PFMusicModule; Pause: ByteBool): ByteBool; stdcall;
function FMUSIC_SetMasterVolume(Module: PFMusicModule; Volume: Integer): ByteBool; stdcall;
function FMUSIC_SetMasterSpeed(Module: PFMusicModule; speed: Single): ByteBool; stdcall;
function FMUSIC_SetPanSeperation(Module: PFMusicModule; PanSep: Single): ByteBool; stdcall;
function FMUSIC_GetName(Module: PFMusicModule): PAnsiChar; stdcall;
function FMUSIC_GetType(Module: PFMusicModule): TFMusicTypes; stdcall;
function FMUSIC_GetNumOrders(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetNumPatterns(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetNumInstruments(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetNumSamples(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetNumChannels(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetSample(Module: PFMusicModule; SampNo: Integer): PFSoundSample; stdcall;
function FMUSIC_GetPatternLength(Module: PFMusicModule; OrderNo: Integer): Integer; stdcall;
function FMUSIC_IsFinished(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_IsPlaying(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_GetMasterVolume(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetGlobalVolume(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetOrder(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetPattern(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetSpeed(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetBPM(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetRow(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetPaused(Module: PFMusicModule): ByteBool; stdcall;
function FMUSIC_GetTime(Module: PFMusicModule): Integer; stdcall;
function FMUSIC_GetRealChannel(Module: PFMusicModule; modchannel: Integer): Integer; stdcall;
function FMUSIC_GetUserData(Module: PFMusicModule): Integer; stdcall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:05


GLScene v.1.1.2: fmoddyn

Unit fmoddyn

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Functions and Procedures

function FMOD_Load(LibName: PChar = nil): boolean;
procedure FMOD_Unload;

Variables

FSOUND_SetOutput: function(OutputType: TFSoundOutputTypes): bytebool; stdcall;
FSOUND_SetDriver: function(Driver: integer): bytebool; stdcall;
FSOUND_SetMixer: function(Mixer: TFSoundMixerTypes): bytebool; stdcall;
FSOUND_SetBufferSize: function(LenMs: integer): bytebool; stdcall;
FSOUND_SetHWND: function(Hwnd: THandle): bytebool; stdcall;
FSOUND_SetMinHardwareChannels: function(Min: integer): bytebool; stdcall;
FSOUND_SetMaxHardwareChannels: function(Max: integer): bytebool; stdcall;
FSOUND_SetMemorySystem: function(Pool: Pointer; PoolLen: integer; UserAlloc: TFSoundAllocCallback; UserRealloc: TFSoundReallocCallback; UserFree: TFSoundFreeCallback): bytebool; stdcall;
FSOUND_Init: function(MixRate: integer; MaxSoftwareChannels: integer; Flags: cardinal): bytebool; stdcall;
FSOUND_Close: procedure; stdcall;
FSOUND_Update: procedure; stdcall;
FSOUND_SetSpeakerMode: procedure(SpeakerMode: cardinal); stdcall;
FSOUND_SetSFXMasterVolume: procedure(Volume: integer); stdcall;
FSOUND_SetPanSeperation: procedure(PanSep: single); stdcall;
FSOUND_File_SetCallbacks: procedure(OpenCallback: TFSoundOpenCallback; CloseCallback: TFSoundCloseCallback; ReadCallback: TFSoundReadCallback; SeekCallback: TFSoundSeekCallback; TellCallback: TFSoundTellCallback); stdcall;
FSOUND_GetError: function: TFModErrors; stdcall;
FSOUND_GetVersion: function: single; stdcall;
FSOUND_GetOutput: function: TFSoundOutputTypes; stdcall;
FSOUND_GetOutputHandle: function: Pointer; stdcall;
FSOUND_GetDriver: function: integer; stdcall;
FSOUND_GetMixer: function: TFSoundMixerTypes; stdcall;
FSOUND_GetNumDrivers: function: integer; stdcall;
FSOUND_GetDriverName: function(Id: integer): PChar; stdcall;
FSOUND_GetDriverCaps: function(Id: integer; var Caps: cardinal): bytebool; stdcall;
FSOUND_GetOutputRate: function: integer; stdcall;
FSOUND_GetMaxChannels: function: integer; stdcall;
FSOUND_GetMaxSamples: function: integer; stdcall;
FSOUND_GetSpeakerMode: function: integer; stdcall;
FSOUND_GetSFXMasterVolume: function: integer; stdcall;
FSOUND_GetNumHWChannels: function(var Num2D: integer; var Num3D: integer; var Total: integer): bytebool; stdcall;
FSOUND_GetChannelsPlaying: function: integer; stdcall;
FSOUND_GetCPUUsage: function: single; stdcall;
FSOUND_GetMemoryStats: procedure(var CurrentAlloced: cardinal; var MaxAlloced: cardinal); stdcall;
FSOUND_Sample_Load: function(Index: integer; const NameOrData: PChar; Mode: cardinal; Offset: integer; Length: integer): PFSoundSample; stdcall;
FSOUND_Sample_Alloc: function(Index: integer; Length: integer; Mode: cardinal; DefFreq: integer; DefVol: integer; DefPan: integer; DefPri: integer): PFSoundSample; stdcall;
FSOUND_Sample_Free: procedure(Sptr: PFSoundSample); stdcall;
FSOUND_Sample_Upload: function(Sptr: PFSoundSample; SrcData: Pointer; Mode: cardinal): bytebool; stdcall;
FSOUND_Sample_Lock: function(Sptr: PFSoundSample; Offset: integer; Length: integer; var Ptr1: Pointer; var Ptr2: Pointer; var Len1: cardinal; var Len2: cardinal): bytebool; stdcall;
FSOUND_Sample_Unlock: function(Sptr: PFSoundSample; Ptr1: Pointer; Ptr2: Pointer; Len1: cardinal; Len2: cardinal): bytebool; stdcall;
FSOUND_Sample_SetMode: function(Sptr: PFSoundSample; Mode: cardinal): bytebool; stdcall;
FSOUND_Sample_SetLoopPoints: function(Sptr: PFSoundSample; LoopStart, LoopEnd: integer): bytebool; stdcall;
FSOUND_Sample_SetDefaults: function(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri: integer): bytebool; stdcall;
FSOUND_Sample_SetDefaultsEx: function(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri, VarFreq, VarVol, VarPan: integer): bytebool; stdcall;
FSOUND_Sample_SetMinMaxDistance: function(Sptr: PFSoundSample; Min, Max: single): bytebool; stdcall;
FSOUND_Sample_SetMaxPlaybacks: function(Sptr: PFSoundSample; Max: integer): bytebool; stdcall;
FSOUND_Sample_Get: function(SampNo: integer): PFSoundSample; stdcall;
FSOUND_Sample_GetName: function(Sptr: PFSoundSample): PChar; stdcall;
FSOUND_Sample_GetLength: function(Sptr: PFSoundSample): cardinal; stdcall;
FSOUND_Sample_GetLoopPoints: function(Sptr: PFSoundSample; var LoopStart: integer; var LoopEnd: integer): bytebool; stdcall;
FSOUND_Sample_GetDefaults: function(Sptr: PFSoundSample; var DefFreq: integer; var DefVol: integer; var DefPan: integer; var DefPri: integer): bytebool; stdcall;
FSOUND_Sample_GetDefaultsEx: function(Sptr: PFSoundSample; var DefFreq: integer; var DefVol: integer; var DefPan: integer; var DefPri: integer; var VarFreq: integer; var VarVol: integer; var VarPan): bytebool; stdcall;
FSOUND_Sample_GetMode: function(Sptr: PFSoundSample): cardinal; stdcall;
FSOUND_Sample_GetMinMaxDistance: function(Sptr: PFSoundSample; var Min: single; var Max: single): bytebool; stdcall;
FSOUND_PlaySound: function(Channel: integer; Sptr: PFSoundSample): integer; stdcall;
FSOUND_PlaySoundEx: function(Channel: integer; Sptr: PFSoundSample; Dsp: PFSoundDSPUnit; StartPaused: bytebool): integer; stdcall;
FSOUND_StopSound: function(Channel: integer): bytebool; stdcall;
FSOUND_SetFrequency: function(Channel: integer; Freq: integer): bytebool; stdcall;
FSOUND_SetVolume: function(Channel: integer; Vol: integer): bytebool; stdcall;
FSOUND_SetVolumeAbsolute: function(Channel: integer; Vol: integer): bytebool; stdcall;
FSOUND_SetPan: function(Channel: integer; Pan: integer): bytebool; stdcall;
FSOUND_SetSurround: function(Channel: integer; Surround: bytebool): bytebool; stdcall;
FSOUND_SetMute: function(Channel: integer; Mute: bytebool): bytebool; stdcall;
FSOUND_SetPriority: function(Channel: integer; Priority: integer): bytebool; stdcall;
FSOUND_SetReserved: function(Channel: integer; Reserved: bytebool): bytebool; stdcall;
FSOUND_SetPaused: function(Channel: integer; Paused: bytebool): bytebool; stdcall;
FSOUND_SetLoopMode: function(Channel: integer; LoopMode: cardinal): bytebool; stdcall;
FSOUND_SetCurrentPosition: function(Channel: integer; Offset: cardinal): bytebool; stdcall;
FSOUND_3D_SetAttributes: function(Channel: integer; Pos: PFSoundVector; Vel: PFSoundVector): bytebool; stdcall;
FSOUND_3D_SetMinMaxDistance: function(Channel: integer; Min: single; Max: single): bytebool; stdcall;
FSOUND_IsPlaying: function(Channel: integer): bytebool; stdcall;
FSOUND_GetFrequency: function(Channel: integer): integer; stdcall;
FSOUND_GetVolume: function(Channel: integer): integer; stdcall;
FSOUND_GetAmplitude: function(Channel: integer): integer; stdcall;
FSOUND_GetPan: function(Channel: integer): integer; stdcall;
FSOUND_GetSurround: function(Channel: integer): bytebool; stdcall;
FSOUND_GetMute: function(Channel: integer): bytebool; stdcall;
FSOUND_GetPriority: function(Channel: integer): integer; stdcall;
FSOUND_GetReserved: function(Channel: integer): bytebool; stdcall;
FSOUND_GetPaused: function(Channel: integer): bytebool; stdcall;
FSOUND_GetLoopMode: function(Channel: integer): cardinal; stdcall;
FSOUND_GetCurrentPosition: function(Channel: integer): cardinal; stdcall;
FSOUND_GetCurrentSample: function(Channel: integer): PFSoundSample; stdcall;
FSOUND_GetCurrentLevels: function(Channel: integer; L, R: PSingle): bytebool; stdcall;
FSOUND_GetNumSubChannels: function(Channel: integer): integer; stdcall;
FSOUND_GetSubChannel: function(Channel: integer; SubChannel: integer): integer; stdcall;
FSOUND_3D_GetAttributes: function(Channel: integer; Pos: PFSoundVector; Vel: PFSoundVector): bytebool; stdcall;
FSOUND_3D_GetMinMaxDistance: function(Channel: integer; var Min: single; var Max: single): bytebool; stdcall;
FSOUND_3D_Listener_SetCurrent: procedure(current: integer); stdcall;
FSOUND_3D_Listener_SetAttributes: procedure(Pos: PFSoundVector; Vel: PFSoundVector; fx: single; fy: single; fz: single; tx: single; ty: single; tz: single); stdcall;
FSOUND_3D_Listener_GetAttributes: procedure(Pos: PFSoundVector; Vel: PFSoundVector; fx: PSingle; fy: PSingle; fz: PSingle; tx: PSingle; ty: PSingle; tz: PSingle); stdcall;
FSOUND_3D_SetDopplerFactor: procedure(Scale: single); stdcall;
FSOUND_3D_SetDistanceFactor: procedure(Scale: single); stdcall;
FSOUND_3D_SetRolloffFactor: procedure(Scale: single); stdcall;
FSOUND_FX_Enable: function(Channel: integer; Fx: TFSoundFXModes): integer; stdcall;
FSOUND_FX_Disable: function(Channel: integer): bytebool; stdcall;
FSOUND_FX_SetChorus: function(FXId: integer; WetDryMix, Depth, Feedback, Frequency: single; Waveform: integer; Delay: single; Phase: integer): bytebool; stdcall;
FSOUND_FX_SetCompressor: function(FXId: integer; Gain, Attack, Release, Threshold, Ratio, Predelay: single): bytebool; stdcall;
FSOUND_FX_SetDistortion: function(FXId: integer; Gain, Edge, PostEQCenterFrequency, PostEQBandwidth, PreLowpassCutoff: single): bytebool; stdcall;
FSOUND_FX_SetEcho: function(FXId: integer; WetDryMix, Feedback, LeftDelay, RightDelay: single; PanDelay: integer): bytebool; stdcall;
FSOUND_FX_SetFlanger: function(FXId: integer; WetDryMix, Depth, Feedback, Frequency: single; Waveform: integer; Delay: single; Phase: integer): bytebool; stdcall;
FSOUND_FX_SetGargle: function(FXId, RateHz, WaveShape: integer): bytebool; stdcall;
FSOUND_FX_SetI3DL2Reverb: function(FXId, Room, RoomHF: integer; RoomRolloffFactor, DecayTime, DecayHFRatio: single; Reflections: integer; ReflectionsDelay: single; Reverb: integer; ReverbDelay, Diffusion, Density, HFReference: single): bytebool; stdcall;
FSOUND_FX_SetParamEQ: function(FXId: integer; Center, Bandwidth, Gain: single): bytebool; stdcall;
FSOUND_FX_SetWavesReverb: function(FXId: integer; InGain, ReverbMix, ReverbTime, HighFreqRTRatio: single): bytebool; stdcall;
FSOUND_Stream_SetBufferSize: function(Ms: integer): bytebool; stdcall;
FSOUND_Stream_Open: function(const name_or_data: PChar; Mode: cardinal; Offset: integer; Length: integer): PFSoundStream; stdcall;
FSOUND_Stream_Create: function(Callback: TFSoundStreamCallback; Length: integer; Mode: cardinal; SampleRate: integer; UserData: integer): PFSoundStream; stdcall;
FSOUND_Stream_Close: function(Stream: PFSoundStream): bytebool; stdcall;
FSOUND_Stream_Play: function(Channel: integer; Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_PlayEx: function(Channel: integer; Stream: PFSoundStream; Dsp: PFSoundDSPUnit; StartPaused: bytebool): integer; stdcall;
FSOUND_Stream_Stop: function(Stream: PFSoundStream): bytebool; stdcall;
FSOUND_Stream_SetPosition: function(Stream: PFSoundStream; Position: cardinal): bytebool; stdcall;
FSOUND_Stream_GetPosition: function(Stream: PFSoundStream): cardinal; stdcall;
FSOUND_Stream_SetTime: function(Stream: PFSoundStream; Ms: integer): bytebool; stdcall;
FSOUND_Stream_GetTime: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_GetLength: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_GetLengthMs: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_SetMode: function(Stream: PFSoundStream; mode: integer): bytebool; stdcall;
FSOUND_Stream_GetMode: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_SetLoopPoints: function(Stream: PFSoundStream; LoopStartPCM, LoopEndPCM: integer): bytebool; stdcall;
FSOUND_Stream_SetLoopCount: function(Stream: PFSoundStream; Count: integer): bytebool; stdcall;
FSOUND_Stream_GetOpenState: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_GetSample: function(Stream: PFSoundStream): PFSoundSample; stdcall;
FSOUND_Stream_CreateDSP: function(Stream: PFSoundStream; Callback: TFSoundDSPCallback; Priority: integer; Param: integer): PFSoundDSPUnit; stdcall;
FSOUND_Stream_SetEndCallback: function(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: integer): bytebool; stdcall;
FSOUND_Stream_SetSyncCallback: function(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: integer): bytebool; stdcall;
FSOUND_Stream_AddSyncPoint: function(Stream: PFSoundStream; PCMOffset: cardinal; Name: PChar): PFSyncPoint; stdcall;
FSOUND_Stream_DeleteSyncPoint: function(Point: PFSyncPoint): bytebool; stdcall;
FSOUND_Stream_GetNumSyncPoints: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_GetSyncPoint: function(Stream: PFSoundStream; Index: integer): PFSyncPoint; stdcall;
FSOUND_Stream_GetSyncPointInfo: function(Point: PFSyncPoint; var PCMOffset: cardinal): integer; stdcall;
FSOUND_Stream_SetSubStream: function(Stream: PFSoundStream; Index: integer): bytebool; stdcall;
FSOUND_Stream_GetNumSubStreams: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_SetSubStreamSentence: function(Stream: PFSoundStream; var sentencelist: cardinal; numitems: integer): bytebool; stdcall;
FSOUND_Stream_GetNumTagFields: function(Stream: PFSoundStream; var Num: integer): bytebool; stdcall;
FSOUND_Stream_GetTagField: function(Stream: PFSoundStream; Num: integer; var _Type: TFSoundTagFieldType; var Name: PChar; var Value: Pointer; var Length: integer): bytebool; stdcall;
FSOUND_Stream_FindTagField: function(Stream: PFSoundStream; _Type: TFSoundTagFieldType; Name: PChar; var Value: Pointer; var Length: integer): bytebool; stdcall;
FSOUND_Stream_Net_SetProxy: function(Proxy: PChar): bytebool; stdcall;
FSOUND_Stream_Net_GetLastServerStatus: function: PChar; stdcall;
FSOUND_Stream_Net_SetBufferProperties: function(BufferSize: integer; PreBuffer_Percent: integer; ReBuffer_Percent: integer): bytebool; stdcall;
FSOUND_Stream_Net_GetBufferProperties: function(var Buffersize: integer; var PreBuffer_Percent: integer; var ReBuffer_Percent: integer): bytebool; stdcall;
FSOUND_Stream_Net_SetMetadataCallback: function(Stream: PFSoundStream; Callback: TFMetaDataCallback; UserData: integer): bytebool; stdcall;
FSOUND_Stream_Net_GetStatus: function(Stream: PFSoundStream; var Status: TFSoundStreamNetStatus; var BufferPercentUsed: integer; var BitRate: integer; var Flags: cardinal): bytebool; stdcall;
FSOUND_CD_Play: function(Drive: byte; Track: integer): bytebool; stdcall;
FSOUND_CD_SetPlayMode: procedure(Drive: byte; Mode: integer); stdcall;
FSOUND_CD_Stop: function(Drive: byte): bytebool; stdcall;
FSOUND_CD_SetPaused: function(Drive: byte; Paused: bytebool): bytebool; stdcall;
FSOUND_CD_SetVolume: function(Drive: byte; Volume: integer): bytebool; stdcall;
FSOUND_CD_SetTrackTime: function(Drive: byte; ms: integer): bytebool; stdcall;
FSOUND_CD_OpenTray: function(Drive: byte; Open: byte): bytebool; stdcall;
FSOUND_CD_GetPaused: function(Drive: byte): bytebool; stdcall;
FSOUND_CD_GetTrack: function(Drive: byte): integer; stdcall;
FSOUND_CD_GetNumTracks: function(Drive: byte): integer; stdcall;
FSOUND_CD_GetVolume: function(Drive: byte): integer; stdcall;
FSOUND_CD_GetTrackLength: function(Drive: byte; Track: integer): integer; stdcall;
FSOUND_CD_GetTrackTime: function(Drive: byte): integer; stdcall;
FSOUND_DSP_Create: function(Callback: TFSoundDSPCallback; Priority: integer; Param: integer): PFSoundDSPUnit; stdcall;
FSOUND_DSP_Free: procedure(DSPUnit: PFSoundDSPUnit); stdcall;
FSOUND_DSP_SetPriority: procedure(DSPUnit: PFSoundDSPUnit; Priority: integer); stdcall;
FSOUND_DSP_GetPriority: function(DSPUnit: PFSoundDSPUnit): integer; stdcall;
FSOUND_DSP_SetActive: procedure(DSPUnit: PFSoundDSPUnit; Active: bytebool); stdcall;
FSOUND_DSP_GetActive: function(DSPUnit: PFSoundDSPUnit): bytebool; stdcall;
FSOUND_DSP_GetClearUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_GetSFXUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_GetMusicUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_GetClipAndCopyUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_GetFFTUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_MixBuffers: function(DestBuffer: Pointer; SrcBuffer: Pointer; Len: integer; Freq: integer; Vol: integer; Pan: integer; Mode: cardinal): bytebool; stdcall;
FSOUND_DSP_ClearMixBuffer: procedure; stdcall;
FSOUND_DSP_GetBufferLength: function: integer; stdcall;
FSOUND_DSP_GetBufferLengthTotal: function: integer; stdcall;
FSOUND_DSP_GetSpectrum: function: PSingle; stdcall;
FSOUND_Reverb_SetProperties: function(const Prop: TFSoundReverbProperties): bytebool; stdcall;
FSOUND_Reverb_GetProperties: function(var Prop: TFSoundReverbProperties): bytebool; stdcall;
FSOUND_Reverb_SetChannelProperties: function(Channel: integer; var Prop: TFSoundReverbChannelProperties): bytebool; stdcall;
FSOUND_Reverb_GetChannelProperties: function(Channel: integer; var Prop: TFSoundReverbChannelProperties): bytebool; stdcall;
FSOUND_Record_SetDriver: function(OutputType: integer): bytebool; stdcall;
FSOUND_Record_GetNumDrivers: function: integer; stdcall;
FSOUND_Record_GetDriverName: function(Id: integer): PChar; stdcall;
FSOUND_Record_GetDriver: function: integer; stdcall;
FSOUND_Record_StartSample: function(Sptr: PFSoundSample; Loop: bytebool): bytebool; stdcall;
FSOUND_Record_Stop: function: bytebool; stdcall;
FSOUND_Record_GetPosition: function: integer; stdcall;
FMUSIC_LoadSong: function(const Name: PChar): PFMusicModule; stdcall;
FMUSIC_LoadSongEx: function(Name_Or_Data: Pointer; Offset: integer; Length: integer; Mode: cardinal; var SampleList: integer; SampleListNum: integer): PFMusicModule; stdcall;
FMUSIC_GetOpenState: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_FreeSong: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_PlaySong: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_StopSong: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_StopAllSongs: procedure; stdcall;
FMUSIC_SetZxxCallback: function(Module: PFMusicModule; Callback: TFMusicCallback): bytebool; stdcall;
FMUSIC_SetRowCallback: function(Module: PFMusicModule; Callback: TFMusicCallback; RowStep: integer): bytebool; stdcall;
FMUSIC_SetOrderCallback: function(Module: PFMusicModule; Callback: TFMusicCallback; OrderStep: integer): bytebool; stdcall;
FMUSIC_SetInstCallback: function(Module: PFMusicModule; Callback: TFMusicCallback; Instrument: integer): bytebool; stdcall;
FMUSIC_SetSample: function(Module: PFMusicModule; SampNo: integer; Sptr: PFSoundSample): bytebool; stdcall;
FMUSIC_SetUserData: function(Module: PFMusicModule; userdata: integer): bytebool; stdcall;
FMUSIC_OptimizeChannels: function(Module: PFMusicModule; MaxChannels: integer; MinVolume: integer): bytebool; stdcall;
FMUSIC_SetReverb: function(Reverb: bytebool): bytebool; stdcall;
FMUSIC_SetLooping: function(Module: PFMusicModule; Looping: bytebool): bytebool; stdcall;
FMUSIC_SetOrder: function(Module: PFMusicModule; Order: integer): bytebool; stdcall;
FMUSIC_SetPaused: function(Module: PFMusicModule; Pause: bytebool): bytebool; stdcall;
FMUSIC_SetMasterVolume: function(Module: PFMusicModule; Volume: integer): bytebool; stdcall;
FMUSIC_SetMasterSpeed: function(Module: PFMusicModule; Speed: single): bytebool; stdcall;
FMUSIC_SetPanSeperation: function(Module: PFMusicModule; PanSep: single): bytebool; stdcall;
FMUSIC_GetName: function(Module: PFMusicModule): PChar; stdcall;
FMUSIC_GetType: function(Module: PFMusicModule): TFMusicTypes; stdcall;
FMUSIC_GetNumOrders: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetNumPatterns: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetNumInstruments: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetNumSamples: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetNumChannels: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetSample: function(Module: PFMusicModule; SampNo: integer): PFSoundSample; stdcall;
FMUSIC_GetPatternLength: function(Module: PFMusicModule; OrderNo: integer): integer; stdcall;
FMUSIC_IsFinished: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_IsPlaying: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_GetMasterVolume: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetGlobalVolume: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetOrder: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetPattern: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetSpeed: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetBPM: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetRow: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetPaused: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_GetTime: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetRealChannel: function(Module: PFMusicModule; ModChannel: integer): integer; stdcall;
FMUSIC_GetUserData: function(Module: PFMusicModule): integer; stdcall;

Description

Functions and Procedures

function FMOD_Load(LibName: PChar = nil): boolean;
procedure FMOD_Unload;

Variables

FSOUND_SetOutput: function(OutputType: TFSoundOutputTypes): bytebool; stdcall;
FSOUND_SetDriver: function(Driver: integer): bytebool; stdcall;
FSOUND_SetMixer: function(Mixer: TFSoundMixerTypes): bytebool; stdcall;
FSOUND_SetBufferSize: function(LenMs: integer): bytebool; stdcall;
FSOUND_SetHWND: function(Hwnd: THandle): bytebool; stdcall;
FSOUND_SetMinHardwareChannels: function(Min: integer): bytebool; stdcall;
FSOUND_SetMaxHardwareChannels: function(Max: integer): bytebool; stdcall;
FSOUND_SetMemorySystem: function(Pool: Pointer; PoolLen: integer; UserAlloc: TFSoundAllocCallback; UserRealloc: TFSoundReallocCallback; UserFree: TFSoundFreeCallback): bytebool; stdcall;
FSOUND_Init: function(MixRate: integer; MaxSoftwareChannels: integer; Flags: cardinal): bytebool; stdcall;
FSOUND_Close: procedure; stdcall;
FSOUND_Update: procedure; stdcall;
FSOUND_SetSpeakerMode: procedure(SpeakerMode: cardinal); stdcall;
FSOUND_SetSFXMasterVolume: procedure(Volume: integer); stdcall;
FSOUND_SetPanSeperation: procedure(PanSep: single); stdcall;
FSOUND_File_SetCallbacks: procedure(OpenCallback: TFSoundOpenCallback; CloseCallback: TFSoundCloseCallback; ReadCallback: TFSoundReadCallback; SeekCallback: TFSoundSeekCallback; TellCallback: TFSoundTellCallback); stdcall;
FSOUND_GetError: function: TFModErrors; stdcall;
FSOUND_GetVersion: function: single; stdcall;
FSOUND_GetOutput: function: TFSoundOutputTypes; stdcall;
FSOUND_GetOutputHandle: function: Pointer; stdcall;
FSOUND_GetDriver: function: integer; stdcall;
FSOUND_GetMixer: function: TFSoundMixerTypes; stdcall;
FSOUND_GetNumDrivers: function: integer; stdcall;
FSOUND_GetDriverName: function(Id: integer): PChar; stdcall;
FSOUND_GetDriverCaps: function(Id: integer; var Caps: cardinal): bytebool; stdcall;
FSOUND_GetOutputRate: function: integer; stdcall;
FSOUND_GetMaxChannels: function: integer; stdcall;
FSOUND_GetMaxSamples: function: integer; stdcall;
FSOUND_GetSpeakerMode: function: integer; stdcall;
FSOUND_GetSFXMasterVolume: function: integer; stdcall;
FSOUND_GetNumHWChannels: function(var Num2D: integer; var Num3D: integer; var Total: integer): bytebool; stdcall;
FSOUND_GetChannelsPlaying: function: integer; stdcall;
FSOUND_GetCPUUsage: function: single; stdcall;
FSOUND_GetMemoryStats: procedure(var CurrentAlloced: cardinal; var MaxAlloced: cardinal); stdcall;
FSOUND_Sample_Load: function(Index: integer; const NameOrData: PChar; Mode: cardinal; Offset: integer; Length: integer): PFSoundSample; stdcall;
FSOUND_Sample_Alloc: function(Index: integer; Length: integer; Mode: cardinal; DefFreq: integer; DefVol: integer; DefPan: integer; DefPri: integer): PFSoundSample; stdcall;
FSOUND_Sample_Free: procedure(Sptr: PFSoundSample); stdcall;
FSOUND_Sample_Upload: function(Sptr: PFSoundSample; SrcData: Pointer; Mode: cardinal): bytebool; stdcall;
FSOUND_Sample_Lock: function(Sptr: PFSoundSample; Offset: integer; Length: integer; var Ptr1: Pointer; var Ptr2: Pointer; var Len1: cardinal; var Len2: cardinal): bytebool; stdcall;
FSOUND_Sample_Unlock: function(Sptr: PFSoundSample; Ptr1: Pointer; Ptr2: Pointer; Len1: cardinal; Len2: cardinal): bytebool; stdcall;
FSOUND_Sample_SetMode: function(Sptr: PFSoundSample; Mode: cardinal): bytebool; stdcall;
FSOUND_Sample_SetLoopPoints: function(Sptr: PFSoundSample; LoopStart, LoopEnd: integer): bytebool; stdcall;
FSOUND_Sample_SetDefaults: function(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri: integer): bytebool; stdcall;
FSOUND_Sample_SetDefaultsEx: function(Sptr: PFSoundSample; DefFreq, DefVol, DefPan, DefPri, VarFreq, VarVol, VarPan: integer): bytebool; stdcall;
FSOUND_Sample_SetMinMaxDistance: function(Sptr: PFSoundSample; Min, Max: single): bytebool; stdcall;
FSOUND_Sample_SetMaxPlaybacks: function(Sptr: PFSoundSample; Max: integer): bytebool; stdcall;
FSOUND_Sample_Get: function(SampNo: integer): PFSoundSample; stdcall;
FSOUND_Sample_GetName: function(Sptr: PFSoundSample): PChar; stdcall;
FSOUND_Sample_GetLength: function(Sptr: PFSoundSample): cardinal; stdcall;
FSOUND_Sample_GetLoopPoints: function(Sptr: PFSoundSample; var LoopStart: integer; var LoopEnd: integer): bytebool; stdcall;
FSOUND_Sample_GetDefaults: function(Sptr: PFSoundSample; var DefFreq: integer; var DefVol: integer; var DefPan: integer; var DefPri: integer): bytebool; stdcall;
FSOUND_Sample_GetDefaultsEx: function(Sptr: PFSoundSample; var DefFreq: integer; var DefVol: integer; var DefPan: integer; var DefPri: integer; var VarFreq: integer; var VarVol: integer; var VarPan): bytebool; stdcall;
FSOUND_Sample_GetMode: function(Sptr: PFSoundSample): cardinal; stdcall;
FSOUND_Sample_GetMinMaxDistance: function(Sptr: PFSoundSample; var Min: single; var Max: single): bytebool; stdcall;
FSOUND_PlaySound: function(Channel: integer; Sptr: PFSoundSample): integer; stdcall;
FSOUND_PlaySoundEx: function(Channel: integer; Sptr: PFSoundSample; Dsp: PFSoundDSPUnit; StartPaused: bytebool): integer; stdcall;
FSOUND_StopSound: function(Channel: integer): bytebool; stdcall;
FSOUND_SetFrequency: function(Channel: integer; Freq: integer): bytebool; stdcall;
FSOUND_SetVolume: function(Channel: integer; Vol: integer): bytebool; stdcall;
FSOUND_SetVolumeAbsolute: function(Channel: integer; Vol: integer): bytebool; stdcall;
FSOUND_SetPan: function(Channel: integer; Pan: integer): bytebool; stdcall;
FSOUND_SetSurround: function(Channel: integer; Surround: bytebool): bytebool; stdcall;
FSOUND_SetMute: function(Channel: integer; Mute: bytebool): bytebool; stdcall;
FSOUND_SetPriority: function(Channel: integer; Priority: integer): bytebool; stdcall;
FSOUND_SetReserved: function(Channel: integer; Reserved: bytebool): bytebool; stdcall;
FSOUND_SetPaused: function(Channel: integer; Paused: bytebool): bytebool; stdcall;
FSOUND_SetLoopMode: function(Channel: integer; LoopMode: cardinal): bytebool; stdcall;
FSOUND_SetCurrentPosition: function(Channel: integer; Offset: cardinal): bytebool; stdcall;
FSOUND_3D_SetAttributes: function(Channel: integer; Pos: PFSoundVector; Vel: PFSoundVector): bytebool; stdcall;
FSOUND_3D_SetMinMaxDistance: function(Channel: integer; Min: single; Max: single): bytebool; stdcall;
FSOUND_IsPlaying: function(Channel: integer): bytebool; stdcall;
FSOUND_GetFrequency: function(Channel: integer): integer; stdcall;
FSOUND_GetVolume: function(Channel: integer): integer; stdcall;
FSOUND_GetAmplitude: function(Channel: integer): integer; stdcall;
FSOUND_GetPan: function(Channel: integer): integer; stdcall;
FSOUND_GetSurround: function(Channel: integer): bytebool; stdcall;
FSOUND_GetMute: function(Channel: integer): bytebool; stdcall;
FSOUND_GetPriority: function(Channel: integer): integer; stdcall;
FSOUND_GetReserved: function(Channel: integer): bytebool; stdcall;
FSOUND_GetPaused: function(Channel: integer): bytebool; stdcall;
FSOUND_GetLoopMode: function(Channel: integer): cardinal; stdcall;
FSOUND_GetCurrentPosition: function(Channel: integer): cardinal; stdcall;
FSOUND_GetCurrentSample: function(Channel: integer): PFSoundSample; stdcall;
FSOUND_GetCurrentLevels: function(Channel: integer; L, R: PSingle): bytebool; stdcall;
FSOUND_GetNumSubChannels: function(Channel: integer): integer; stdcall;
FSOUND_GetSubChannel: function(Channel: integer; SubChannel: integer): integer; stdcall;
FSOUND_3D_GetAttributes: function(Channel: integer; Pos: PFSoundVector; Vel: PFSoundVector): bytebool; stdcall;
FSOUND_3D_GetMinMaxDistance: function(Channel: integer; var Min: single; var Max: single): bytebool; stdcall;
FSOUND_3D_Listener_SetCurrent: procedure(current: integer); stdcall;
FSOUND_3D_Listener_SetAttributes: procedure(Pos: PFSoundVector; Vel: PFSoundVector; fx: single; fy: single; fz: single; tx: single; ty: single; tz: single); stdcall;
FSOUND_3D_Listener_GetAttributes: procedure(Pos: PFSoundVector; Vel: PFSoundVector; fx: PSingle; fy: PSingle; fz: PSingle; tx: PSingle; ty: PSingle; tz: PSingle); stdcall;
FSOUND_3D_SetDopplerFactor: procedure(Scale: single); stdcall;
FSOUND_3D_SetDistanceFactor: procedure(Scale: single); stdcall;
FSOUND_3D_SetRolloffFactor: procedure(Scale: single); stdcall;
FSOUND_FX_Enable: function(Channel: integer; Fx: TFSoundFXModes): integer; stdcall;
FSOUND_FX_Disable: function(Channel: integer): bytebool; stdcall;
FSOUND_FX_SetChorus: function(FXId: integer; WetDryMix, Depth, Feedback, Frequency: single; Waveform: integer; Delay: single; Phase: integer): bytebool; stdcall;
FSOUND_FX_SetCompressor: function(FXId: integer; Gain, Attack, Release, Threshold, Ratio, Predelay: single): bytebool; stdcall;
FSOUND_FX_SetDistortion: function(FXId: integer; Gain, Edge, PostEQCenterFrequency, PostEQBandwidth, PreLowpassCutoff: single): bytebool; stdcall;
FSOUND_FX_SetEcho: function(FXId: integer; WetDryMix, Feedback, LeftDelay, RightDelay: single; PanDelay: integer): bytebool; stdcall;
FSOUND_FX_SetFlanger: function(FXId: integer; WetDryMix, Depth, Feedback, Frequency: single; Waveform: integer; Delay: single; Phase: integer): bytebool; stdcall;
FSOUND_FX_SetGargle: function(FXId, RateHz, WaveShape: integer): bytebool; stdcall;
FSOUND_FX_SetI3DL2Reverb: function(FXId, Room, RoomHF: integer; RoomRolloffFactor, DecayTime, DecayHFRatio: single; Reflections: integer; ReflectionsDelay: single; Reverb: integer; ReverbDelay, Diffusion, Density, HFReference: single): bytebool; stdcall;
FSOUND_FX_SetParamEQ: function(FXId: integer; Center, Bandwidth, Gain: single): bytebool; stdcall;
FSOUND_FX_SetWavesReverb: function(FXId: integer; InGain, ReverbMix, ReverbTime, HighFreqRTRatio: single): bytebool; stdcall;
FSOUND_Stream_SetBufferSize: function(Ms: integer): bytebool; stdcall;
FSOUND_Stream_Open: function(const name_or_data: PChar; Mode: cardinal; Offset: integer; Length: integer): PFSoundStream; stdcall;
FSOUND_Stream_Create: function(Callback: TFSoundStreamCallback; Length: integer; Mode: cardinal; SampleRate: integer; UserData: integer): PFSoundStream; stdcall;
FSOUND_Stream_Close: function(Stream: PFSoundStream): bytebool; stdcall;
FSOUND_Stream_Play: function(Channel: integer; Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_PlayEx: function(Channel: integer; Stream: PFSoundStream; Dsp: PFSoundDSPUnit; StartPaused: bytebool): integer; stdcall;
FSOUND_Stream_Stop: function(Stream: PFSoundStream): bytebool; stdcall;
FSOUND_Stream_SetPosition: function(Stream: PFSoundStream; Position: cardinal): bytebool; stdcall;
FSOUND_Stream_GetPosition: function(Stream: PFSoundStream): cardinal; stdcall;
FSOUND_Stream_SetTime: function(Stream: PFSoundStream; Ms: integer): bytebool; stdcall;
FSOUND_Stream_GetTime: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_GetLength: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_GetLengthMs: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_SetMode: function(Stream: PFSoundStream; mode: integer): bytebool; stdcall;
FSOUND_Stream_GetMode: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_SetLoopPoints: function(Stream: PFSoundStream; LoopStartPCM, LoopEndPCM: integer): bytebool; stdcall;
FSOUND_Stream_SetLoopCount: function(Stream: PFSoundStream; Count: integer): bytebool; stdcall;
FSOUND_Stream_GetOpenState: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_GetSample: function(Stream: PFSoundStream): PFSoundSample; stdcall;
FSOUND_Stream_CreateDSP: function(Stream: PFSoundStream; Callback: TFSoundDSPCallback; Priority: integer; Param: integer): PFSoundDSPUnit; stdcall;
FSOUND_Stream_SetEndCallback: function(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: integer): bytebool; stdcall;
FSOUND_Stream_SetSyncCallback: function(Stream: PFSoundStream; Callback: TFSoundStreamCallback; UserData: integer): bytebool; stdcall;
FSOUND_Stream_AddSyncPoint: function(Stream: PFSoundStream; PCMOffset: cardinal; Name: PChar): PFSyncPoint; stdcall;
FSOUND_Stream_DeleteSyncPoint: function(Point: PFSyncPoint): bytebool; stdcall;
FSOUND_Stream_GetNumSyncPoints: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_GetSyncPoint: function(Stream: PFSoundStream; Index: integer): PFSyncPoint; stdcall;
FSOUND_Stream_GetSyncPointInfo: function(Point: PFSyncPoint; var PCMOffset: cardinal): integer; stdcall;
FSOUND_Stream_SetSubStream: function(Stream: PFSoundStream; Index: integer): bytebool; stdcall;
FSOUND_Stream_GetNumSubStreams: function(Stream: PFSoundStream): integer; stdcall;
FSOUND_Stream_SetSubStreamSentence: function(Stream: PFSoundStream; var sentencelist: cardinal; numitems: integer): bytebool; stdcall;
FSOUND_Stream_GetNumTagFields: function(Stream: PFSoundStream; var Num: integer): bytebool; stdcall;
FSOUND_Stream_GetTagField: function(Stream: PFSoundStream; Num: integer; var _Type: TFSoundTagFieldType; var Name: PChar; var Value: Pointer; var Length: integer): bytebool; stdcall;
FSOUND_Stream_FindTagField: function(Stream: PFSoundStream; _Type: TFSoundTagFieldType; Name: PChar; var Value: Pointer; var Length: integer): bytebool; stdcall;
FSOUND_Stream_Net_SetProxy: function(Proxy: PChar): bytebool; stdcall;
FSOUND_Stream_Net_GetLastServerStatus: function: PChar; stdcall;
FSOUND_Stream_Net_SetBufferProperties: function(BufferSize: integer; PreBuffer_Percent: integer; ReBuffer_Percent: integer): bytebool; stdcall;
FSOUND_Stream_Net_GetBufferProperties: function(var Buffersize: integer; var PreBuffer_Percent: integer; var ReBuffer_Percent: integer): bytebool; stdcall;
FSOUND_Stream_Net_SetMetadataCallback: function(Stream: PFSoundStream; Callback: TFMetaDataCallback; UserData: integer): bytebool; stdcall;
FSOUND_Stream_Net_GetStatus: function(Stream: PFSoundStream; var Status: TFSoundStreamNetStatus; var BufferPercentUsed: integer; var BitRate: integer; var Flags: cardinal): bytebool; stdcall;
FSOUND_CD_Play: function(Drive: byte; Track: integer): bytebool; stdcall;
FSOUND_CD_SetPlayMode: procedure(Drive: byte; Mode: integer); stdcall;
FSOUND_CD_Stop: function(Drive: byte): bytebool; stdcall;
FSOUND_CD_SetPaused: function(Drive: byte; Paused: bytebool): bytebool; stdcall;
FSOUND_CD_SetVolume: function(Drive: byte; Volume: integer): bytebool; stdcall;
FSOUND_CD_SetTrackTime: function(Drive: byte; ms: integer): bytebool; stdcall;
FSOUND_CD_OpenTray: function(Drive: byte; Open: byte): bytebool; stdcall;
FSOUND_CD_GetPaused: function(Drive: byte): bytebool; stdcall;
FSOUND_CD_GetTrack: function(Drive: byte): integer; stdcall;
FSOUND_CD_GetNumTracks: function(Drive: byte): integer; stdcall;
FSOUND_CD_GetVolume: function(Drive: byte): integer; stdcall;
FSOUND_CD_GetTrackLength: function(Drive: byte; Track: integer): integer; stdcall;
FSOUND_CD_GetTrackTime: function(Drive: byte): integer; stdcall;
FSOUND_DSP_Create: function(Callback: TFSoundDSPCallback; Priority: integer; Param: integer): PFSoundDSPUnit; stdcall;
FSOUND_DSP_Free: procedure(DSPUnit: PFSoundDSPUnit); stdcall;
FSOUND_DSP_SetPriority: procedure(DSPUnit: PFSoundDSPUnit; Priority: integer); stdcall;
FSOUND_DSP_GetPriority: function(DSPUnit: PFSoundDSPUnit): integer; stdcall;
FSOUND_DSP_SetActive: procedure(DSPUnit: PFSoundDSPUnit; Active: bytebool); stdcall;
FSOUND_DSP_GetActive: function(DSPUnit: PFSoundDSPUnit): bytebool; stdcall;
FSOUND_DSP_GetClearUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_GetSFXUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_GetMusicUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_GetClipAndCopyUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_GetFFTUnit: function: PFSoundDSPUnit; stdcall;
FSOUND_DSP_MixBuffers: function(DestBuffer: Pointer; SrcBuffer: Pointer; Len: integer; Freq: integer; Vol: integer; Pan: integer; Mode: cardinal): bytebool; stdcall;
FSOUND_DSP_ClearMixBuffer: procedure; stdcall;
FSOUND_DSP_GetBufferLength: function: integer; stdcall;
FSOUND_DSP_GetBufferLengthTotal: function: integer; stdcall;
FSOUND_DSP_GetSpectrum: function: PSingle; stdcall;
FSOUND_Reverb_SetProperties: function(const Prop: TFSoundReverbProperties): bytebool; stdcall;
FSOUND_Reverb_GetProperties: function(var Prop: TFSoundReverbProperties): bytebool; stdcall;
FSOUND_Reverb_SetChannelProperties: function(Channel: integer; var Prop: TFSoundReverbChannelProperties): bytebool; stdcall;
FSOUND_Reverb_GetChannelProperties: function(Channel: integer; var Prop: TFSoundReverbChannelProperties): bytebool; stdcall;
FSOUND_Record_SetDriver: function(OutputType: integer): bytebool; stdcall;
FSOUND_Record_GetNumDrivers: function: integer; stdcall;
FSOUND_Record_GetDriverName: function(Id: integer): PChar; stdcall;
FSOUND_Record_GetDriver: function: integer; stdcall;
FSOUND_Record_StartSample: function(Sptr: PFSoundSample; Loop: bytebool): bytebool; stdcall;
FSOUND_Record_Stop: function: bytebool; stdcall;
FSOUND_Record_GetPosition: function: integer; stdcall;
FMUSIC_LoadSong: function(const Name: PChar): PFMusicModule; stdcall;
FMUSIC_LoadSongEx: function(Name_Or_Data: Pointer; Offset: integer; Length: integer; Mode: cardinal; var SampleList: integer; SampleListNum: integer): PFMusicModule; stdcall;
FMUSIC_GetOpenState: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_FreeSong: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_PlaySong: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_StopSong: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_StopAllSongs: procedure; stdcall;
FMUSIC_SetZxxCallback: function(Module: PFMusicModule; Callback: TFMusicCallback): bytebool; stdcall;
FMUSIC_SetRowCallback: function(Module: PFMusicModule; Callback: TFMusicCallback; RowStep: integer): bytebool; stdcall;
FMUSIC_SetOrderCallback: function(Module: PFMusicModule; Callback: TFMusicCallback; OrderStep: integer): bytebool; stdcall;
FMUSIC_SetInstCallback: function(Module: PFMusicModule; Callback: TFMusicCallback; Instrument: integer): bytebool; stdcall;
FMUSIC_SetSample: function(Module: PFMusicModule; SampNo: integer; Sptr: PFSoundSample): bytebool; stdcall;
FMUSIC_SetUserData: function(Module: PFMusicModule; userdata: integer): bytebool; stdcall;
FMUSIC_OptimizeChannels: function(Module: PFMusicModule; MaxChannels: integer; MinVolume: integer): bytebool; stdcall;
FMUSIC_SetReverb: function(Reverb: bytebool): bytebool; stdcall;
FMUSIC_SetLooping: function(Module: PFMusicModule; Looping: bytebool): bytebool; stdcall;
FMUSIC_SetOrder: function(Module: PFMusicModule; Order: integer): bytebool; stdcall;
FMUSIC_SetPaused: function(Module: PFMusicModule; Pause: bytebool): bytebool; stdcall;
FMUSIC_SetMasterVolume: function(Module: PFMusicModule; Volume: integer): bytebool; stdcall;
FMUSIC_SetMasterSpeed: function(Module: PFMusicModule; Speed: single): bytebool; stdcall;
FMUSIC_SetPanSeperation: function(Module: PFMusicModule; PanSep: single): bytebool; stdcall;
FMUSIC_GetName: function(Module: PFMusicModule): PChar; stdcall;
FMUSIC_GetType: function(Module: PFMusicModule): TFMusicTypes; stdcall;
FMUSIC_GetNumOrders: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetNumPatterns: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetNumInstruments: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetNumSamples: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetNumChannels: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetSample: function(Module: PFMusicModule; SampNo: integer): PFSoundSample; stdcall;
FMUSIC_GetPatternLength: function(Module: PFMusicModule; OrderNo: integer): integer; stdcall;
FMUSIC_IsFinished: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_IsPlaying: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_GetMasterVolume: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetGlobalVolume: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetOrder: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetPattern: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetSpeed: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetBPM: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetRow: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetPaused: function(Module: PFMusicModule): bytebool; stdcall;
FMUSIC_GetTime: function(Module: PFMusicModule): integer; stdcall;
FMUSIC_GetRealChannel: function(Module: PFMusicModule; ModChannel: integer): integer; stdcall;
FMUSIC_GetUserData: function(Module: PFMusicModule): integer; stdcall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: fmoderrors

Unit fmoderrors

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Functions and Procedures

function FMOD_ErrorString(ErrorCode: TFModErrors): PChar;

Description

Functions and Procedures

function FMOD_ErrorString(ErrorCode: TFModErrors): PChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: fmodpresets

Unit fmodpresets

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Constants

FSOUND_PRESET_OFF: TFSoundReverbProperties = (Environment: 0; EnvSize: 7.5; EnvDiffusion: 1.00; Room: -10000; RoomHF: -10000; RoomLF: 0; DecayTime: 1.00; DecayHFRatio: 1.00; DecayLFRatio: 1.0; Reflections: -2602; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 200; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 0.0; Density: 0.0; Flags: $33f);
FSOUND_PRESET_GENERIC: TFSoundReverbProperties = (Environment: 0; EnvSize: 7.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -100; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.83; DecayLFRatio: 1.0; Reflections: -2602; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 200; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_PADDEDCELL: TFSoundReverbProperties = (Environment: 1; EnvSize: 1.4; EnvDiffusion: 1.00; Room: -1000; RoomHF: -6000; RoomLF: 0; DecayTime: 0.17; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -1204; ReflectionsDelay: 0.001; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 207; ReverbDelay: 0.002; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_ROOM: TFSoundReverbProperties = (Environment: 2; EnvSize: 1.9; EnvDiffusion: 1.00; Room: -1000; RoomHF: -454; RoomLF: 0; DecayTime: 0.40; DecayHFRatio: 0.83; DecayLFRatio: 1.0; Reflections: -1646; ReflectionsDelay: 0.002; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 53; ReverbDelay: 0.003; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_BATHROOM: TFSoundReverbProperties = (Environment: 3; EnvSize: 1.4; EnvDiffusion: 1.00; Room: -1000; RoomHF: -1200; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.54; DecayLFRatio: 1.0; Reflections: -370; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 1030; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 60.0; Flags: $3f);
FSOUND_PRESET_LIVINGROOM: TFSoundReverbProperties = (Environment: 4; EnvSize: 2.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -6000; RoomLF: 0; DecayTime: 0.50; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -1376; ReflectionsDelay: 0.003; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1104; ReverbDelay: 0.004; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_STONEROOM: TFSoundReverbProperties = (Environment: 5; EnvSize: 11.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: -300; RoomLF: 0; DecayTime: 2.31; DecayHFRatio: 0.64; DecayLFRatio: 1.0; Reflections: -711; ReflectionsDelay: 0.012; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 83; ReverbDelay: 0.017; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_AUDITORIUM: TFSoundReverbProperties = (Environment: 6; EnvSize: 21.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: -476; RoomLF: 0; DecayTime: 4.32; DecayHFRatio: 0.59; DecayLFRatio: 1.0; Reflections: -789; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-289; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_CONCERTHALL: TFSoundReverbProperties = (Environment: 7; EnvSize: 19.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: -500; RoomLF: 0; DecayTime: 3.92; DecayHFRatio: 0.70; DecayLFRatio: 1.0; Reflections: -1230; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-2; ReverbDelay: 0.029; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_CAVE: TFSoundReverbProperties = (Environment: 8; EnvSize: 14.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: 0; RoomLF: 0; DecayTime: 2.91; DecayHFRatio: 1.30; DecayLFRatio: 1.0; Reflections: -602; ReflectionsDelay: 0.015; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-302; ReverbDelay: 0.022; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_ARENA: TFSoundReverbProperties = (Environment: 9; EnvSize: 36.2; EnvDiffusion: 1.00; Room: -1000; RoomHF: -698; RoomLF: 0; DecayTime: 7.24; DecayHFRatio: 0.33; DecayLFRatio: 1.0; Reflections: -1166; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 16; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_HANGAR: TFSoundReverbProperties = (Environment: 10; EnvSize: 50.3; EnvDiffusion: 1.00; Room: -1000; RoomHF: -1000; RoomLF: 0; DecayTime: 10.05; DecayHFRatio: 0.23; DecayLFRatio: 1.0; Reflections: -602; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 198; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_CARPETTEDHALLWAY: TFSoundReverbProperties = (Environment: 11; EnvSize: 1.9; EnvDiffusion: 1.00; Room: -1000; RoomHF: -4000; RoomLF: 0; DecayTime: 0.30; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -1831; ReflectionsDelay: 0.002; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1630; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_HALLWAY: TFSoundReverbProperties = (Environment: 12; EnvSize: 1.8; EnvDiffusion: 1.00; Room: -1000; RoomHF: -300; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.59; DecayLFRatio: 1.0; Reflections: -1219; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 441; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_STONECORRIDOR: TFSoundReverbProperties = (Environment: 13; EnvSize: 13.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -237; RoomLF: 0; DecayTime: 2.70; DecayHFRatio: 0.79; DecayLFRatio: 1.0; Reflections: -1214; ReflectionsDelay: 0.013; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 395; ReverbDelay: 0.020; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_ALLEY: TFSoundReverbProperties = (Environment: 14; EnvSize: 7.5; EnvDiffusion: 0.30; Room: -1000; RoomHF: -270; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.86; DecayLFRatio: 1.0; Reflections: -1204; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-4; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.125; EchoDepth: 0.95; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_FOREST: TFSoundReverbProperties = (Environment: 15; EnvSize: 38.0; EnvDiffusion: 0.30; Room: -1000; RoomHF: -3300; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.54; DecayLFRatio: 1.0; Reflections: -2560; ReflectionsDelay: 0.162; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-229; ReverbDelay: 0.088; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.125; EchoDepth: 1.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 79.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_CITY: TFSoundReverbProperties = (Environment: 16; EnvSize: 7.5; EnvDiffusion: 0.50; Room: -1000; RoomHF: -800; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.67; DecayLFRatio: 1.0; Reflections: -2273; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1691; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 50.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_MOUNTAINS: TFSoundReverbProperties = (Environment: 17; EnvSize: 100.0; EnvDiffusion: 0.27; Room: -1000; RoomHF: -2500; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.21; DecayLFRatio: 1.0; Reflections: -2780; ReflectionsDelay: 0.300; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1434; ReverbDelay: 0.100; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 1.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 27.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_QUARRY: TFSoundReverbProperties = (Environment: 18; EnvSize: 17.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -1000; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.83; DecayLFRatio: 1.0; Reflections: -10000;ReflectionsDelay: 0.061; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 500; ReverbDelay: 0.025; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.125; EchoDepth: 0.70; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_PLAIN: TFSoundReverbProperties = (Environment: 19; EnvSize: 42.5; EnvDiffusion: 0.21; Room: -1000; RoomHF: -2000; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.50; DecayLFRatio: 1.0; Reflections: -2466; ReflectionsDelay: 0.179; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1926; ReverbDelay: 0.100; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 1.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 21.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_PARKINGLOT: TFSoundReverbProperties = (Environment: 20; EnvSize: 8.3; EnvDiffusion: 1.00; Room: -1000; RoomHF: 0; RoomLF: 0; DecayTime: 1.65; DecayHFRatio: 1.50; DecayLFRatio: 1.0; Reflections: -1363; ReflectionsDelay: 0.008; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1153; ReverbDelay: 0.012; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_SEWERPIPE: TFSoundReverbProperties = (Environment: 21; EnvSize: 1.7; EnvDiffusion: 0.80; Room: -1000; RoomHF: -1000; RoomLF: 0; DecayTime: 2.81; DecayHFRatio: 0.14; DecayLFRatio: 1.0; Reflections: 429; ReflectionsDelay: 0.014; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 1023; ReverbDelay: 0.021; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 80.0; Density: 60.0; Flags: $3f);
FSOUND_PRESET_UNDERWATER: TFSoundReverbProperties = (Environment: 22; EnvSize: 1.8; EnvDiffusion: 1.00; Room: -1000; RoomHF: -4000; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -449; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 1700; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 1.18; ModulationDepth: 0.348; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_DRUGGED: TFSoundReverbProperties = (Environment: 23; EnvSize: 1.9; EnvDiffusion: 0.50; Room: -1000; RoomHF: 0; RoomLF: 0; DecayTime: 8.39; DecayHFRatio: 1.39; DecayLFRatio: 1.0; Reflections: -115; ReflectionsDelay: 0.002; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 985; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 1.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_DIZZY: TFSoundReverbProperties = (Environment: 24; EnvSize: 1.8; EnvDiffusion: 0.60; Room: -1000; RoomHF: -400; RoomLF: 0; DecayTime: 17.23; DecayHFRatio: 0.56; DecayLFRatio: 1.0; Reflections: -1713; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-613; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 1.00; ModulationTime: 0.81; ModulationDepth: 0.310; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_PSYCHOTIC: TFSoundReverbProperties = (Environment: 25; EnvSize: 1.0; EnvDiffusion: 0.50; Room: -1000; RoomHF: -151; RoomLF: 0; DecayTime: 7.56; DecayHFRatio: 0.91; DecayLFRatio: 1.0; Reflections: -626; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 774; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 4.00; ModulationDepth: 1.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);

Description

Constants

FSOUND_PRESET_OFF: TFSoundReverbProperties = (Environment: 0; EnvSize: 7.5; EnvDiffusion: 1.00; Room: -10000; RoomHF: -10000; RoomLF: 0; DecayTime: 1.00; DecayHFRatio: 1.00; DecayLFRatio: 1.0; Reflections: -2602; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 200; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 0.0; Density: 0.0; Flags: $33f);
FSOUND_PRESET_GENERIC: TFSoundReverbProperties = (Environment: 0; EnvSize: 7.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -100; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.83; DecayLFRatio: 1.0; Reflections: -2602; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 200; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_PADDEDCELL: TFSoundReverbProperties = (Environment: 1; EnvSize: 1.4; EnvDiffusion: 1.00; Room: -1000; RoomHF: -6000; RoomLF: 0; DecayTime: 0.17; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -1204; ReflectionsDelay: 0.001; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 207; ReverbDelay: 0.002; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_ROOM: TFSoundReverbProperties = (Environment: 2; EnvSize: 1.9; EnvDiffusion: 1.00; Room: -1000; RoomHF: -454; RoomLF: 0; DecayTime: 0.40; DecayHFRatio: 0.83; DecayLFRatio: 1.0; Reflections: -1646; ReflectionsDelay: 0.002; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 53; ReverbDelay: 0.003; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_BATHROOM: TFSoundReverbProperties = (Environment: 3; EnvSize: 1.4; EnvDiffusion: 1.00; Room: -1000; RoomHF: -1200; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.54; DecayLFRatio: 1.0; Reflections: -370; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 1030; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 60.0; Flags: $3f);
FSOUND_PRESET_LIVINGROOM: TFSoundReverbProperties = (Environment: 4; EnvSize: 2.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -6000; RoomLF: 0; DecayTime: 0.50; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -1376; ReflectionsDelay: 0.003; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1104; ReverbDelay: 0.004; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_STONEROOM: TFSoundReverbProperties = (Environment: 5; EnvSize: 11.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: -300; RoomLF: 0; DecayTime: 2.31; DecayHFRatio: 0.64; DecayLFRatio: 1.0; Reflections: -711; ReflectionsDelay: 0.012; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 83; ReverbDelay: 0.017; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_AUDITORIUM: TFSoundReverbProperties = (Environment: 6; EnvSize: 21.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: -476; RoomLF: 0; DecayTime: 4.32; DecayHFRatio: 0.59; DecayLFRatio: 1.0; Reflections: -789; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-289; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_CONCERTHALL: TFSoundReverbProperties = (Environment: 7; EnvSize: 19.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: -500; RoomLF: 0; DecayTime: 3.92; DecayHFRatio: 0.70; DecayLFRatio: 1.0; Reflections: -1230; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-2; ReverbDelay: 0.029; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_CAVE: TFSoundReverbProperties = (Environment: 8; EnvSize: 14.6; EnvDiffusion: 1.00; Room: -1000; RoomHF: 0; RoomLF: 0; DecayTime: 2.91; DecayHFRatio: 1.30; DecayLFRatio: 1.0; Reflections: -602; ReflectionsDelay: 0.015; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-302; ReverbDelay: 0.022; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_ARENA: TFSoundReverbProperties = (Environment: 9; EnvSize: 36.2; EnvDiffusion: 1.00; Room: -1000; RoomHF: -698; RoomLF: 0; DecayTime: 7.24; DecayHFRatio: 0.33; DecayLFRatio: 1.0; Reflections: -1166; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 16; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_HANGAR: TFSoundReverbProperties = (Environment: 10; EnvSize: 50.3; EnvDiffusion: 1.00; Room: -1000; RoomHF: -1000; RoomLF: 0; DecayTime: 10.05; DecayHFRatio: 0.23; DecayLFRatio: 1.0; Reflections: -602; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 198; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_CARPETTEDHALLWAY: TFSoundReverbProperties = (Environment: 11; EnvSize: 1.9; EnvDiffusion: 1.00; Room: -1000; RoomHF: -4000; RoomLF: 0; DecayTime: 0.30; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -1831; ReflectionsDelay: 0.002; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1630; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_HALLWAY: TFSoundReverbProperties = (Environment: 12; EnvSize: 1.8; EnvDiffusion: 1.00; Room: -1000; RoomHF: -300; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.59; DecayLFRatio: 1.0; Reflections: -1219; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 441; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_STONECORRIDOR: TFSoundReverbProperties = (Environment: 13; EnvSize: 13.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -237; RoomLF: 0; DecayTime: 2.70; DecayHFRatio: 0.79; DecayLFRatio: 1.0; Reflections: -1214; ReflectionsDelay: 0.013; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 395; ReverbDelay: 0.020; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_ALLEY: TFSoundReverbProperties = (Environment: 14; EnvSize: 7.5; EnvDiffusion: 0.30; Room: -1000; RoomHF: -270; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.86; DecayLFRatio: 1.0; Reflections: -1204; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-4; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.125; EchoDepth: 0.95; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_FOREST: TFSoundReverbProperties = (Environment: 15; EnvSize: 38.0; EnvDiffusion: 0.30; Room: -1000; RoomHF: -3300; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.54; DecayLFRatio: 1.0; Reflections: -2560; ReflectionsDelay: 0.162; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-229; ReverbDelay: 0.088; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.125; EchoDepth: 1.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 79.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_CITY: TFSoundReverbProperties = (Environment: 16; EnvSize: 7.5; EnvDiffusion: 0.50; Room: -1000; RoomHF: -800; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.67; DecayLFRatio: 1.0; Reflections: -2273; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1691; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 50.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_MOUNTAINS: TFSoundReverbProperties = (Environment: 17; EnvSize: 100.0; EnvDiffusion: 0.27; Room: -1000; RoomHF: -2500; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.21; DecayLFRatio: 1.0; Reflections: -2780; ReflectionsDelay: 0.300; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1434; ReverbDelay: 0.100; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 1.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 27.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_QUARRY: TFSoundReverbProperties = (Environment: 18; EnvSize: 17.5; EnvDiffusion: 1.00; Room: -1000; RoomHF: -1000; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.83; DecayLFRatio: 1.0; Reflections: -10000;ReflectionsDelay: 0.061; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 500; ReverbDelay: 0.025; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.125; EchoDepth: 0.70; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_PLAIN: TFSoundReverbProperties = (Environment: 19; EnvSize: 42.5; EnvDiffusion: 0.21; Room: -1000; RoomHF: -2000; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.50; DecayLFRatio: 1.0; Reflections: -2466; ReflectionsDelay: 0.179; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1926; ReverbDelay: 0.100; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 1.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 21.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_PARKINGLOT: TFSoundReverbProperties = (Environment: 20; EnvSize: 8.3; EnvDiffusion: 1.00; Room: -1000; RoomHF: 0; RoomLF: 0; DecayTime: 1.65; DecayHFRatio: 1.50; DecayLFRatio: 1.0; Reflections: -1363; ReflectionsDelay: 0.008; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-1153; ReverbDelay: 0.012; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_SEWERPIPE: TFSoundReverbProperties = (Environment: 21; EnvSize: 1.7; EnvDiffusion: 0.80; Room: -1000; RoomHF: -1000; RoomLF: 0; DecayTime: 2.81; DecayHFRatio: 0.14; DecayLFRatio: 1.0; Reflections: 429; ReflectionsDelay: 0.014; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 1023; ReverbDelay: 0.021; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 0.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 80.0; Density: 60.0; Flags: $3f);
FSOUND_PRESET_UNDERWATER: TFSoundReverbProperties = (Environment: 22; EnvSize: 1.8; EnvDiffusion: 1.00; Room: -1000; RoomHF: -4000; RoomLF: 0; DecayTime: 1.49; DecayHFRatio: 0.10; DecayLFRatio: 1.0; Reflections: -449; ReflectionsDelay: 0.007; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 1700; ReverbDelay: 0.011; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 1.18; ModulationDepth: 0.348; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $3f);
FSOUND_PRESET_DRUGGED: TFSoundReverbProperties = (Environment: 23; EnvSize: 1.9; EnvDiffusion: 0.50; Room: -1000; RoomHF: 0; RoomLF: 0; DecayTime: 8.39; DecayHFRatio: 1.39; DecayLFRatio: 1.0; Reflections: -115; ReflectionsDelay: 0.002; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 985; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 0.25; ModulationDepth: 1.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_DIZZY: TFSoundReverbProperties = (Environment: 24; EnvSize: 1.8; EnvDiffusion: 0.60; Room: -1000; RoomHF: -400; RoomLF: 0; DecayTime: 17.23; DecayHFRatio: 0.56; DecayLFRatio: 1.0; Reflections: -1713; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb:-613; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 1.00; ModulationTime: 0.81; ModulationDepth: 0.310; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);
FSOUND_PRESET_PSYCHOTIC: TFSoundReverbProperties = (Environment: 25; EnvSize: 1.0; EnvDiffusion: 0.50; Room: -1000; RoomHF: -151; RoomLF: 0; DecayTime: 7.56; DecayHFRatio: 0.91; DecayLFRatio: 1.0; Reflections: -626; ReflectionsDelay: 0.020; ReflectionsPan: (0.0, 0.0, 0.0); Reverb: 774; ReverbDelay: 0.030; ReverbPan: (0.0, 0.0, 0.0); EchoTime: 0.250; EchoDepth: 0.00; ModulationTime: 4.00; ModulationDepth: 1.000; AirAbsorptionHF: -5.0; HFReference: 5000.0; LFReference: 250.0; RoomRolloffFactor: 0.0; Diffusion: 100.0; Density: 100.0; Flags: $1f);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: fmodtypes

Unit fmodtypes

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TFSoundVector |
record TFSoundReverbProperties |
record TFSoundReverbChannelProperties |
record TFSoundTOCTag |

Types

PFSoundSample = Pointer;
PFSoundStream = Pointer;
PFSoundDSPUnit = Pointer;
PFMusicModule = Pointer;
PFSyncPoint = Pointer;
PFSoundVector = ˆTFSoundVector;
TFSoundStreamCallback = function (Stream: PFSoundStream; Buff: Pointer; Length, Param: Integer): ByteBool; stdcall;
TFSoundDSPCallback = function (OriginalBuffer: Pointer; NewBuffer: Pointer; Length, Param: Integer): Pointer; stdcall;
TFMusicCallback = procedure (Module: PFMusicModule; Param: Byte); stdcall;
TFSoundOpenCallback = function (Name: PChar): Cardinal; stdcall;
TFSoundCloseCallback = procedure (Handle: Cardinal); stdcall;
TFSoundReadCallback = function (Buffer: Pointer; Size: Cardinal; Handle: Cardinal): Cardinal; stdcall;
TFSoundSeekCallback = procedure (Handle: Cardinal; Pos: Cardinal; Mode: Byte); stdcall;
TFSoundTellCallback = function (Handle: Cardinal): Cardinal; stdcall;
TFSoundAllocCallback = function(Size: Cardinal): Pointer; stdcall;
TFSoundReallocCallback = function(Ptr: Pointer; Size: Cardinal): Pointer; stdcall;
TFSoundFreeCallback = procedure(Ptr: Pointer); stdcall;
TFMetaDataCallback = function(Name: PChar; Value: PChar; userdata: Integer): ByteBool; stdcall;
TFModErrors = (...);
TFSoundOutputTypes = (...);
TFSoundMixerTypes = (...);
TFMusicTypes = (...);
TFSoundFXModes = (...);
TFSoundSpeakerModes = (...);
FSOUND_SPEAKERMODES = TFSoundSpeakerModes;
TFSoundStreamNetStatus = (...);
TFSoundTagFieldType = (...);

Constants

FMOD_VERSION: Single = 3.75;
FSOUND_DSP_DEFAULTPRIORITY_CLEARUNIT = 0;
FSOUND_DSP_DEFAULTPRIORITY_SFXUNIT = 100;
FSOUND_DSP_DEFAULTPRIORITY_MUSICUNIT = 200;
FSOUND_DSP_DEFAULTPRIORITY_USER = 300;
FSOUND_DSP_DEFAULTPRIORITY_FFTUNIT = 900;
FSOUND_DSP_DEFAULTPRIORITY_CLIPANDCOPYUNIT = 1000;
FSOUND_CAPS_HARDWARE = $1;
FSOUND_CAPS_EAX2 = $2;
FSOUND_CAPS_EAX3 = $10;
FSOUND_LOOP_OFF = $00000001;
FSOUND_LOOP_NORMAL = $00000002;
FSOUND_LOOP_BIDI = $00000004;
FSOUND_8BITS = $00000008;
FSOUND_16BITS = $00000010;
FSOUND_MONO = $00000020;
FSOUND_STEREO = $00000040;
FSOUND_UNSIGNED = $00000080;
FSOUND_SIGNED = $00000100;
FSOUND_DELTA = $00000200;
FSOUND_IT214 = $00000400;
FSOUND_IT215 = $00000800;
FSOUND_HW3D = $00001000;
FSOUND_2D = $00002000;
FSOUND_STREAMABLE = $00004000;
FSOUND_LOADMEMORY = $00008000;
FSOUND_LOADRAW = $00010000;
FSOUND_MPEGACCURATE = $00020000;
FSOUND_FORCEMONO = $00040000;
FSOUND_HW2D = $00080000;
FSOUND_ENABLEFX = $00100000;
FSOUND_MPEGHALFRATE = $00200000;
FSOUND_XADPCM = $00400000;
FSOUND_VAG = $00800000;
FSOUND_NONBLOCKING = $01000000;
FSOUND_GCADPCM = $02000000;
FSOUND_MULTICHANNEL = $04000000;
FSOUND_USECORE0 = $08000000;
FSOUND_USECORE1 = $10000000;
FSOUND_LOADMEMORYIOP = $20000000;
FSOUND_NORMAL = (FSOUND_16BITS or FSOUND_SIGNED or FSOUND_MONO);
FSOUND_CD_PLAYCONTINUOUS = 0;
FSOUND_CD_PLAYONCE = 1;
FSOUND_CD_PLAYLOOPED = 2;
FSOUND_CD_PLAYRANDOM = 3;
FSOUND_FREE = -1;
FSOUND_UNMANAGED = -2;
FSOUND_ALL = -3;
FSOUND_STEREOPAN = -1;
FSOUND_SYSTEMCHANNEL = -1000;
FSOUND_SYSTEMSAMPLE = -1000;
FSOUND_REVERBFLAGS_DECAYTIMESCALE = $00000001;
FSOUND_REVERBFLAGS_REFLECTIONSSCALE = $00000002;
FSOUND_REVERBFLAGS_REFLECTIONSDELAYSCALE = $00000004;
FSOUND_REVERBFLAGS_REVERBSCALE = $00000008;
FSOUND_REVERBFLAGS_REVERBDELAYSCALE = $00000010;
FSOUND_REVERBFLAGS_DECAYHFLIMIT = $00000020;
FSOUND_REVERBFLAGS_ECHOTIMESCALE = $00000040;
FSOUND_REVERBFLAGS_MODULATIONTIMESCALE = $00000080;
FSOUND_REVERB_FLAGS_CORE0 = $00000100;
FSOUND_REVERB_FLAGS_CORE1 = $00000200;
FSOUND_REVERBFLAGS_DEFAULT = FSOUND_REVERBFLAGS_DECAYTIMESCALE or FSOUND_REVERBFLAGS_REFLECTIONSSCALE or FSOUND_REVERBFLAGS_REFLECTIONSDELAYSCALE or FSOUND_REVERBFLAGS_REVERBSCALE or FSOUND_REVERBFLAGS_REVERBDELAYSCALE or FSOUND_REVERBFLAGS_DECAYHFLIMIT or FSOUND_REVERB_FLAGS_CORE0 or FSOUND_REVERB_FLAGS_CORE1;
FSOUND_REVERB_CHANNELFLAGS_DIRECTHFAUTO = $01;
FSOUND_REVERB_CHANNELFLAGS_ROOMAUTO = $02;
FSOUND_REVERB_CHANNELFLAGS_ROOMHFAUTO = $04;
FSOUND_REVERB_CHANNELFLAGS_DEFAULT = FSOUND_REVERB_CHANNELFLAGS_DIRECTHFAUTO or FSOUND_REVERB_CHANNELFLAGS_ROOMAUTO or FSOUND_REVERB_CHANNELFLAGS_ROOMHFAUTO;
FSOUND_INIT_USEDEFAULTMIDISYNTH = $01;
FSOUND_INIT_GLOBALFOCUS = $02;
FSOUND_INIT_ENABLESYSTEMCHANNELFX = $04;
FSOUND_INIT_ACCURATEVULEVELS = $08;
FSOUND_INIT_PS2_DISABLECORE0REVERB = $10;
FSOUND_INIT_PS2_DISABLECORE1REVERB = $20;
FSOUND_INIT_PS2_SWAPDMACORES = $40;
FSOUND_INIT_DONTLATENCYADJUST = $80;
FSOUND_INIT_GC_INITLIBS = $100;
FSOUND_INIT_STREAM_FROM_MAIN_THREAD = $200;
FSOUND_INIT_PS2_USEVOLUMERAMPING = $400;
FSOUND_INIT_DSOUND_DEFERRED = $800;
FSOUND_INIT_DSOUND_HRTF_LIGHT = $1000;
FSOUND_INIT_DSOUND_HRTF_FULL = $2000;
FSOUND_INIT_XBOX_REMOVEHEADROOM = $4000;
FSOUND_INIT_PSP_SILENCEONUNDERRUN = $8000;
FSOUND_PROTOCOL_SHOUTCAST = $00000001;
FSOUND_PROTOCOL_ICECAST = $00000002;
FSOUND_PROTOCOL_HTTP = $00000004;
FSOUND_FORMAT_MPEG = $00010000;
FSOUND_FORMAT_OGGVORBIS = $00020000;

Description

Types

PFSoundSample = Pointer;
PFSoundStream = Pointer;
PFSoundDSPUnit = Pointer;
PFMusicModule = Pointer;
PFSyncPoint = Pointer;
PFSoundVector = ˆTFSoundVector;
TFSoundStreamCallback = function (Stream: PFSoundStream; Buff: Pointer; Length, Param: Integer): ByteBool; stdcall;
TFSoundDSPCallback = function (OriginalBuffer: Pointer; NewBuffer: Pointer; Length, Param: Integer): Pointer; stdcall;
TFMusicCallback = procedure (Module: PFMusicModule; Param: Byte); stdcall;
TFSoundOpenCallback = function (Name: PChar): Cardinal; stdcall;
TFSoundCloseCallback = procedure (Handle: Cardinal); stdcall;
TFSoundReadCallback = function (Buffer: Pointer; Size: Cardinal; Handle: Cardinal): Cardinal; stdcall;
TFSoundSeekCallback = procedure (Handle: Cardinal; Pos: Cardinal; Mode: Byte); stdcall;
TFSoundTellCallback = function (Handle: Cardinal): Cardinal; stdcall;
TFSoundAllocCallback = function(Size: Cardinal): Pointer; stdcall;
TFSoundReallocCallback = function(Ptr: Pointer; Size: Cardinal): Pointer; stdcall;
TFSoundFreeCallback = procedure(Ptr: Pointer); stdcall;
TFMetaDataCallback = function(Name: PChar; Value: PChar; userdata: Integer): ByteBool; stdcall;
TFModErrors = (...);
Values
  • FMOD_ERR_NONE:
  • FMOD_ERR_BUSY:
  • FMOD_ERR_UNINITIALIZED:
  • FMOD_ERR_INIT:
  • FMOD_ERR_ALLOCATED:
  • FMOD_ERR_PLAY:
  • FMOD_ERR_OUTPUT_FORMAT:
  • FMOD_ERR_COOPERATIVELEVEL:
  • FMOD_ERR_CREATEBUFFER:
  • FMOD_ERR_FILE_NOTFOUND:
  • FMOD_ERR_FILE_FORMAT:
  • FMOD_ERR_FILE_BAD:
  • FMOD_ERR_MEMORY:
  • FMOD_ERR_VERSION:
  • FMOD_ERR_INVALID_PARAM:
  • FMOD_ERR_NO_EAX:
  • FMOD_ERR_CHANNEL_ALLOC:
  • FMOD_ERR_RECORD:
  • FMOD_ERR_MEDIAPLAYER:
  • FMOD_ERR_CDDEVICE:
TFSoundOutputTypes = (...);
Values
  • FSOUND_OUTPUT_NOSOUND:
  • FSOUND_OUTPUT_WINMM:
  • FSOUND_OUTPUT_DSOUND:
  • FSOUND_OUTPUT_A3D:
  • FSOUND_OUTPUT_OSS:
  • FSOUND_OUTPUT_ESD:
  • FSOUND_OUTPUT_ALSA:
  • FSOUND_OUTPUT_ASIO:
  • FSOUND_OUTPUT_XBOX:
  • FSOUND_OUTPUT_PS2:
  • FSOUND_OUTPUT_MAC:
  • FSOUND_OUTPUT_GC:
  • FSOUND_OUTPUT_PSP:
  • FSOUND_OUTPUT_NOSOUND_NONREALTIME:
TFSoundMixerTypes = (...);
Values
  • FSOUND_MIXER_AUTODETECT:
  • FSOUND_MIXER_BLENDMODE:
  • FSOUND_MIXER_MMXP5:
  • FSOUND_MIXER_MMXP6:
  • FSOUND_MIXER_QUALITY_AUTODETECT:
  • FSOUND_MIXER_QUALITY_FPU:
  • FSOUND_MIXER_QUALITY_MMXP5:
  • FSOUND_MIXER_QUALITY_MMXP6:
  • FSOUND_MIXER_MONO:
  • FSOUND_MIXER_QUALITY_MONO:
  • FSOUND_MIXER_MAX:
TFMusicTypes = (...);
Values
  • FMUSIC_TYPE_NONE:
  • FMUSIC_TYPE_MOD:
  • FMUSIC_TYPE_S3M:
  • FMUSIC_TYPE_XM:
  • FMUSIC_TYPE_IT:
  • FMUSIC_TYPE_MIDI:
  • FMUSIC_TYPE_FSB:
TFSoundFXModes = (...);
Values
  • FSOUND_FX_CHORUS:
  • FSOUND_FX_COMPRESSOR:
  • FSOUND_FX_DISTORTION:
  • FSOUND_FX_ECHO:
  • FSOUND_FX_FLANGER:
  • FSOUND_FX_GARGLE:
  • FSOUND_FX_I3DL2REVERB:
  • FSOUND_FX_PARAMEQ:
  • FSOUND_FX_WAVES_REVERB:
  • FSOUND_FX_MAX:
TFSoundSpeakerModes = (...);
Values
  • FSOUND_SPEAKERMODE_DOLBYDIGITAL:
  • FSOUND_SPEAKERMODE_HEADPHONES:
  • FSOUND_SPEAKERMODE_MONO:
  • FSOUND_SPEAKERMODE_QUAD:
  • FSOUND_SPEAKERMODE_STEREO:
  • FSOUND_SPEAKERMODE_SURROUND:
  • FSOUND_SPEAKERMODE_DTS:
FSOUND_SPEAKERMODES = TFSoundSpeakerModes;
TFSoundStreamNetStatus = (...);
Values
  • FSOUND_STREAM_NET_NOTCONNECTED:
  • FSOUND_STREAM_NET_CONNECTING:
  • FSOUND_STREAM_NET_BUFFERING:
  • FSOUND_STREAM_NET_READY:
  • FSOUND_STREAM_NET_ERROR:
TFSoundTagFieldType = (...);
Values
  • FSOUND_TAGFIELD_VORBISCOMMENT:
  • FSOUND_TAGFIELD_ID3V1:
  • FSOUND_TAGFIELD_ID3V2:
  • FSOUND_TAGFIELD_SHOUTCAST:
  • FSOUND_TAGFIELD_ICECAST:
  • FSOUND_TAGFIELD_ASF:

Constants

FMOD_VERSION: Single = 3.75;
FSOUND_DSP_DEFAULTPRIORITY_CLEARUNIT = 0;
FSOUND_DSP_DEFAULTPRIORITY_SFXUNIT = 100;
FSOUND_DSP_DEFAULTPRIORITY_MUSICUNIT = 200;
FSOUND_DSP_DEFAULTPRIORITY_USER = 300;
FSOUND_DSP_DEFAULTPRIORITY_FFTUNIT = 900;
FSOUND_DSP_DEFAULTPRIORITY_CLIPANDCOPYUNIT = 1000;
FSOUND_CAPS_HARDWARE = $1;
FSOUND_CAPS_EAX2 = $2;
FSOUND_CAPS_EAX3 = $10;
FSOUND_LOOP_OFF = $00000001;
FSOUND_LOOP_NORMAL = $00000002;
FSOUND_LOOP_BIDI = $00000004;
FSOUND_8BITS = $00000008;
FSOUND_16BITS = $00000010;
FSOUND_MONO = $00000020;
FSOUND_STEREO = $00000040;
FSOUND_UNSIGNED = $00000080;
FSOUND_SIGNED = $00000100;
FSOUND_DELTA = $00000200;
FSOUND_IT214 = $00000400;
FSOUND_IT215 = $00000800;
FSOUND_HW3D = $00001000;
FSOUND_2D = $00002000;
FSOUND_STREAMABLE = $00004000;
FSOUND_LOADMEMORY = $00008000;
FSOUND_LOADRAW = $00010000;
FSOUND_MPEGACCURATE = $00020000;
FSOUND_FORCEMONO = $00040000;
FSOUND_HW2D = $00080000;
FSOUND_ENABLEFX = $00100000;
FSOUND_MPEGHALFRATE = $00200000;
FSOUND_XADPCM = $00400000;
FSOUND_VAG = $00800000;
FSOUND_NONBLOCKING = $01000000;
FSOUND_GCADPCM = $02000000;
FSOUND_MULTICHANNEL = $04000000;
FSOUND_USECORE0 = $08000000;
FSOUND_USECORE1 = $10000000;
FSOUND_LOADMEMORYIOP = $20000000;
FSOUND_NORMAL = (FSOUND_16BITS or FSOUND_SIGNED or FSOUND_MONO);
FSOUND_CD_PLAYCONTINUOUS = 0;
FSOUND_CD_PLAYONCE = 1;
FSOUND_CD_PLAYLOOPED = 2;
FSOUND_CD_PLAYRANDOM = 3;
FSOUND_FREE = -1;
FSOUND_UNMANAGED = -2;
FSOUND_ALL = -3;
FSOUND_STEREOPAN = -1;
FSOUND_SYSTEMCHANNEL = -1000;
FSOUND_SYSTEMSAMPLE = -1000;
FSOUND_REVERBFLAGS_DECAYTIMESCALE = $00000001;
FSOUND_REVERBFLAGS_REFLECTIONSSCALE = $00000002;
FSOUND_REVERBFLAGS_REFLECTIONSDELAYSCALE = $00000004;
FSOUND_REVERBFLAGS_REVERBSCALE = $00000008;
FSOUND_REVERBFLAGS_REVERBDELAYSCALE = $00000010;
FSOUND_REVERBFLAGS_DECAYHFLIMIT = $00000020;
FSOUND_REVERBFLAGS_ECHOTIMESCALE = $00000040;
FSOUND_REVERBFLAGS_MODULATIONTIMESCALE = $00000080;
FSOUND_REVERB_FLAGS_CORE0 = $00000100;
FSOUND_REVERB_FLAGS_CORE1 = $00000200;
FSOUND_REVERBFLAGS_DEFAULT = FSOUND_REVERBFLAGS_DECAYTIMESCALE or FSOUND_REVERBFLAGS_REFLECTIONSSCALE or FSOUND_REVERBFLAGS_REFLECTIONSDELAYSCALE or FSOUND_REVERBFLAGS_REVERBSCALE or FSOUND_REVERBFLAGS_REVERBDELAYSCALE or FSOUND_REVERBFLAGS_DECAYHFLIMIT or FSOUND_REVERB_FLAGS_CORE0 or FSOUND_REVERB_FLAGS_CORE1;
FSOUND_REVERB_CHANNELFLAGS_DIRECTHFAUTO = $01;
FSOUND_REVERB_CHANNELFLAGS_ROOMAUTO = $02;
FSOUND_REVERB_CHANNELFLAGS_ROOMHFAUTO = $04;
FSOUND_REVERB_CHANNELFLAGS_DEFAULT = FSOUND_REVERB_CHANNELFLAGS_DIRECTHFAUTO or FSOUND_REVERB_CHANNELFLAGS_ROOMAUTO or FSOUND_REVERB_CHANNELFLAGS_ROOMHFAUTO;
FSOUND_INIT_USEDEFAULTMIDISYNTH = $01;
FSOUND_INIT_GLOBALFOCUS = $02;
FSOUND_INIT_ENABLESYSTEMCHANNELFX = $04;
FSOUND_INIT_ACCURATEVULEVELS = $08;
FSOUND_INIT_PS2_DISABLECORE0REVERB = $10;
FSOUND_INIT_PS2_DISABLECORE1REVERB = $20;
FSOUND_INIT_PS2_SWAPDMACORES = $40;
FSOUND_INIT_DONTLATENCYADJUST = $80;
FSOUND_INIT_GC_INITLIBS = $100;
FSOUND_INIT_STREAM_FROM_MAIN_THREAD = $200;
FSOUND_INIT_PS2_USEVOLUMERAMPING = $400;
FSOUND_INIT_DSOUND_DEFERRED = $800;
FSOUND_INIT_DSOUND_HRTF_LIGHT = $1000;
FSOUND_INIT_DSOUND_HRTF_FULL = $2000;
FSOUND_INIT_XBOX_REMOVEHEADROOM = $4000;
FSOUND_INIT_PSP_SILENCEONUNDERRUN = $8000;
FSOUND_PROTOCOL_SHOUTCAST = $00000001;
FSOUND_PROTOCOL_ICECAST = $00000002;
FSOUND_PROTOCOL_HTTP = $00000004;
FSOUND_FORMAT_MPEG = $00010000;
FSOUND_FORMAT_OGGVORBIS = $00020000;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: fmodtypes: record TFSoundVector

record TFSoundVector

Unit

fmodtypes

Declaration

type TFSoundVector = record

Description

Overview

Fields

x: Single;
y: Single;
z: Single;

Description

Fields

x: Single;
y: Single;
z: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: fmodtypes: record TFSoundReverbProperties

record TFSoundReverbProperties

Unit

fmodtypes

Declaration

type TFSoundReverbProperties = record

Description

Overview

Fields

Environment: Cardinal;
EnvSize: Single;
EnvDiffusion: Single;
Room: Integer;
RoomHF: Integer;
RoomLF: Integer;
DecayTime: Single;
DecayHFRatio: Single;
DecayLFRatio: Single;
Reflections: Integer;
ReflectionsDelay: Single;
ReflectionsPan: array [0..2] of Single;
Reverb: Integer;
ReverbDelay: Single;
ReverbPan: array [0..2] of Single;
EchoTime: Single;
EchoDepth: Single;
ModulationTime: Single;
ModulationDepth: Single;
AirAbsorptionHF: Single;
HFReference: Single;
LFReference: Single;
RoomRolloffFactor: Single;
Diffusion: Single;
Density: Single;
Flags: Cardinal;

Description

Fields

Environment: Cardinal;
EnvSize: Single;
EnvDiffusion: Single;
Room: Integer;
RoomHF: Integer;
RoomLF: Integer;
DecayTime: Single;
DecayHFRatio: Single;
DecayLFRatio: Single;
Reflections: Integer;
ReflectionsDelay: Single;
ReflectionsPan: array [0..2] of Single;
Reverb: Integer;
ReverbDelay: Single;
ReverbPan: array [0..2] of Single;
EchoTime: Single;
EchoDepth: Single;
ModulationTime: Single;
ModulationDepth: Single;
AirAbsorptionHF: Single;
HFReference: Single;
LFReference: Single;
RoomRolloffFactor: Single;
Diffusion: Single;
Density: Single;
Flags: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: fmodtypes: record TFSoundReverbChannelProperties

record TFSoundReverbChannelProperties

Unit

fmodtypes

Declaration

type TFSoundReverbChannelProperties = record

Description

Overview

Fields

Direct: Integer;
DirectHF: Integer;
Room: Integer;
RoomHF: Integer;
Obstruction: Integer;
ObstructionLFRatio: Single;
Occlusion: Integer;
OcclusionLFRatio: Single;
OcclusionRoomRatio: Single;
OcclusionDirectRatio: Single;
Exclusion: Integer;
ExclusionLFRatio: Single;
OutsideVolumeHF: Integer;
DopplerFactor: Single;
RolloffFactor: Single;
RoomRolloffFactor: Single;
AirAbsorptionFactor: Single;
Flags: Integer;

Description

Fields

Direct: Integer;
DirectHF: Integer;
Room: Integer;
RoomHF: Integer;
Obstruction: Integer;
ObstructionLFRatio: Single;
Occlusion: Integer;
OcclusionLFRatio: Single;
OcclusionRoomRatio: Single;
OcclusionDirectRatio: Single;
Exclusion: Integer;
ExclusionLFRatio: Single;
OutsideVolumeHF: Integer;
DopplerFactor: Single;
RolloffFactor: Single;
RoomRolloffFactor: Single;
AirAbsorptionFactor: Single;
Flags: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: fmodtypes: record TFSoundTOCTag

record TFSoundTOCTag

Unit

fmodtypes

Declaration

type TFSoundTOCTag = record

Description

Overview

Fields

Name: array [0..3] of AnsiChar;
NumTracks: Integer;
Min: array [0..99] of Integer;
Sec: array [0..99] of Integer;
Frame: array [0..99] of Integer;

Description

Fields

Name: array [0..3] of AnsiChar;
NumTracks: Integer;
Min: array [0..99] of Integer;
Sec: array [0..99] of Integer;
Frame: array [0..99] of Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: FRColorEditor

Unit FRColorEditor

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FRColorEditor<p>

RGB+Alpha color editor.<p>

<b>Historique : </b><font size=-1><ul> <li>24/04/09 - DanB - removed some ifdef MSWINDOWS, which were actually for Kylix <li>05/09/08 - DanB - Removed Kylix support <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>03/07/04 - LR - Make change for Linux <li>06/02/00 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRColorEditor |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: FRColorEditor: Class TRColorEditor

Class TRColorEditor

Unit

FRColorEditor

Declaration

type TRColorEditor = class(TFrame)

Description

Hierarchy

  • TFrame
  • TRColorEditor

Overview

Fields

Published | Label1: TLabel;
Published | Label2: TLabel;
Published | Label3: TLabel;
Published | Label4: TLabel;
Published | PAPreview: TPanel;
Published | ColorDialog: TColorDialog;
Published | Panel1: TPanel;
Published | ColorEditorPaintBox: TPaintBox;
Published | RedEdit: TEdit;
Published | GreenEdit: TEdit;
Published | BlueEdit: TEdit;
Published | AlphaEdit: TEdit;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | Destructor Destroy; override;
Published | procedure AlphaEditChange(Sender: TObject);
Published | procedure BlueEditChange(Sender: TObject);
Published | procedure ColorEditorPaintBoxMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure ColorEditorPaintBoxMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published | procedure ColorEditorPaintBoxMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure ColorEditorPaintBoxPaint(Sender: TObject);
Published | procedure FrameResize(Sender: TObject);
Published | procedure GreenEditChange(Sender: TObject);
Published | procedure PAPreviewDblClick(Sender: TObject);
Published | procedure RedEditChange(Sender: TObject);
Published | procedure TBEChange(Sender: TObject);

Properties

Public | property Color : THomogeneousFltVector read GetColor write SetColor;
Published | property OnChange : TNotifyEvent read FOnChange write FOnChange;

Description

Fields

Published Label1: TLabel;
Published Label2: TLabel;
Published Label3: TLabel;
Published Label4: TLabel;
Published PAPreview: TPanel;
Published ColorDialog: TColorDialog;
Published Panel1: TPanel;
Published ColorEditorPaintBox: TPaintBox;
Published RedEdit: TEdit;
Published GreenEdit: TEdit;
Published BlueEdit: TEdit;
Published AlphaEdit: TEdit;

Methods

Public constructor Create(AOwner: TComponent); override;
Public Destructor Destroy; override;
Published procedure AlphaEditChange(Sender: TObject);
Published procedure BlueEditChange(Sender: TObject);
Published procedure ColorEditorPaintBoxMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure ColorEditorPaintBoxMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published procedure ColorEditorPaintBoxMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure ColorEditorPaintBoxPaint(Sender: TObject);
Published procedure FrameResize(Sender: TObject);
Published procedure GreenEditChange(Sender: TObject);
Published procedure PAPreviewDblClick(Sender: TObject);
Published procedure RedEditChange(Sender: TObject);
Published procedure TBEChange(Sender: TObject);

Properties

Public property Color : THomogeneousFltVector read GetColor write SetColor;
Published property OnChange : TNotifyEvent read FOnChange write FOnChange;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: FRColorEditorLCL

Unit FRColorEditorLCL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FRColorEditor<p>

RGB+Alpha color editor.<p>

<b>Historique : </b><font size=-1><ul>

</ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRColorEditor |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: FRColorEditorLCL: Class TRColorEditor

Class TRColorEditor

Unit

FRColorEditorLCL

Declaration

type TRColorEditor = class(TFrame)

Description

Hierarchy

  • TFrame
  • TRColorEditor

Overview

Fields

Published | Label1: TLabel;
Published | Label2: TLabel;
Published | Label3: TLabel;
Published | Label4: TLabel;
Published | PAPreview: TPanel;
Published | ColorDialog: TColorDialog;
Published | Panel1: TPanel;
Published | ColorEditorPaintBox: TPaintBox;
Published | RedEdit: TEdit;
Published | GreenEdit: TEdit;
Published | BlueEdit: TEdit;
Published | AlphaEdit: TEdit;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | Destructor Destroy; override;
Published | procedure AlphaEditChange(Sender: TObject);
Published | procedure BlueEditChange(Sender: TObject);
Published | procedure ColorEditorPaintBoxMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure ColorEditorPaintBoxMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published | procedure ColorEditorPaintBoxMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure ColorEditorPaintBoxPaint(Sender: TObject);
Published | procedure FrameResize(Sender: TObject);
Published | procedure GreenEditChange(Sender: TObject);
Published | procedure PAPreviewDblClick(Sender: TObject);
Published | procedure RedEditChange(Sender: TObject);
Published | procedure TBEChange(Sender: TObject);

Properties

Public | property EditedColor : THomogeneousFltVector read GetEditedColor write SetEditedColor;
Published | property OnChange : TNotifyEvent read FOnChange write FOnChange;

Description

Fields

Published Label1: TLabel;
Published Label2: TLabel;
Published Label3: TLabel;
Published Label4: TLabel;
Published PAPreview: TPanel;
Published ColorDialog: TColorDialog;
Published Panel1: TPanel;
Published ColorEditorPaintBox: TPaintBox;
Published RedEdit: TEdit;
Published GreenEdit: TEdit;
Published BlueEdit: TEdit;
Published AlphaEdit: TEdit;

Methods

Public constructor Create(AOwner: TComponent); override;
Public Destructor Destroy; override;
Published procedure AlphaEditChange(Sender: TObject);
Published procedure BlueEditChange(Sender: TObject);
Published procedure ColorEditorPaintBoxMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure ColorEditorPaintBoxMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published procedure ColorEditorPaintBoxMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure ColorEditorPaintBoxPaint(Sender: TObject);
Published procedure FrameResize(Sender: TObject);
Published procedure GreenEditChange(Sender: TObject);
Published procedure PAPreviewDblClick(Sender: TObject);
Published procedure RedEditChange(Sender: TObject);
Published procedure TBEChange(Sender: TObject);

Properties

Public property EditedColor : THomogeneousFltVector read GetEditedColor write SetEditedColor;
Published property OnChange : TNotifyEvent read FOnChange write FOnChange;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: FRFaceEditor

Unit FRFaceEditor

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FRFaceEditor<p>

Editor fram for a TGLFaceProperties.<p>

<b>Historique : </b><font size=-1><ul> <li>05/09/08 - DanB - Removed Kylix support <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>19/12/06 - DaStr - TRFaceEditor.SetGLFaceProperties bugfixed - Shiness and PoligonMode are now updated when FaceProperties are assigned <li>03/07/04 - LR - Make change for Linux <li>06/02/00 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRFaceEditor |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: FRFaceEditor: Class TRFaceEditor

Class TRFaceEditor

Unit

FRFaceEditor

Declaration

type TRFaceEditor = class(TFrame)

Description

Hierarchy

  • TFrame
  • TRFaceEditor

Overview

Fields

Published | PageControl: TPageControl;
Published | TSAmbient: TTabSheet;
Published | TSDiffuse: TTabSheet;
Published | TSEmission: TTabSheet;
Published | TSSpecular: TTabSheet;
Published | CEAmbiant: TRColorEditor;
Published | Label1: TLabel;
Published | TBEShininess: TRTrackBarEdit;
Published | ImageList: TImageList;
Published | CEDiffuse: TRColorEditor;
Published | CEEmission: TRColorEditor;
Published | CESpecular: TRColorEditor;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Published | procedure TBEShininessTrackBarChange(Sender: TObject);

Properties

Public | property FaceProperties : TGLFaceProperties read FFaceProperties write SetGLFaceProperties;
Public | property OnChange : TNotifyEvent read FOnChange write FOnChange;

Description

Fields

Published PageControl: TPageControl;
Published TSAmbient: TTabSheet;
Published TSDiffuse: TTabSheet;
Published TSEmission: TTabSheet;
Published TSSpecular: TTabSheet;
Published CEAmbiant: TRColorEditor;
Published Label1: TLabel;
Published TBEShininess: TRTrackBarEdit;
Published ImageList: TImageList;
Published CEDiffuse: TRColorEditor;
Published CEEmission: TRColorEditor;
Published CESpecular: TRColorEditor;

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Published procedure TBEShininessTrackBarChange(Sender: TObject);

Properties

Public property FaceProperties : TGLFaceProperties read FFaceProperties write SetGLFaceProperties;
Public property OnChange : TNotifyEvent read FOnChange write FOnChange;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: FRFaceEditorLCL

Unit FRFaceEditorLCL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FRFaceEditor<p>

Editor fram for a TGLFaceProperties.<p>

<b>Historique : </b><font size=-1><ul>

</ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRFaceEditor |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: FRFaceEditorLCL: Class TRFaceEditor

Class TRFaceEditor

Unit

FRFaceEditorLCL

Declaration

type TRFaceEditor = class(TFrame)

Description

Hierarchy

  • TFrame
  • TRFaceEditor

Overview

Fields

Published | PageControl: TPageControl;
Published | TSAmbient: TTabSheet;
Published | TSDiffuse: TTabSheet;
Published | TSEmission: TTabSheet;
Published | TSSpecular: TTabSheet;
Published | CEAmbiant: TRColorEditor;
Published | Label1: TLabel;
Published | TBEShininess: TRTrackBarEdit;
Published | ImageList: TImageList;
Published | CEDiffuse: TRColorEditor;
Published | CEEmission: TRColorEditor;
Published | CESpecular: TRColorEditor;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Published | procedure TBEShininessTrackBarChange(Sender: TObject);

Properties

Public | property FaceProperties : TGLFaceProperties read FFaceProperties write SetGLFaceProperties;
Public | property OnChange : TNotifyEvent read FOnChange write FOnChange;

Description

Fields

Published PageControl: TPageControl;
Published TSAmbient: TTabSheet;
Published TSDiffuse: TTabSheet;
Published TSEmission: TTabSheet;
Published TSSpecular: TTabSheet;
Published CEAmbiant: TRColorEditor;
Published Label1: TLabel;
Published TBEShininess: TRTrackBarEdit;
Published ImageList: TImageList;
Published CEDiffuse: TRColorEditor;
Published CEEmission: TRColorEditor;
Published CESpecular: TRColorEditor;

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Published procedure TBEShininessTrackBarChange(Sender: TObject);

Properties

Public property FaceProperties : TGLFaceProperties read FFaceProperties write SetGLFaceProperties;
Public property OnChange : TNotifyEvent read FOnChange write FOnChange;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: FRMaterialPreview

Unit FRMaterialPreview

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FRMaterialPreview<p>

Material Preview frame.<p>

<b>Historique : </b><font size=-1><ul> <li>12/07/07 - DaStr - Improved Cross-Platform compatibility (Bugtracker ID = 1684432) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>16/12/06 - DaStr - Editor enhanced <li>03/07/04 - LR - Make change for Linux <li>06/02/00 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRMaterialPreview |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:07


GLScene v.1.1.2: FRMaterialPreview: Class TRMaterialPreview

Class TRMaterialPreview

Unit

FRMaterialPreview

Declaration

type TRMaterialPreview = class(TFrame)

Description

Hierarchy

  • TFrame
  • TRMaterialPreview

Overview

Fields

Published | GLScene1: TGLScene;
Published | SceneViewer: TGLSceneViewer;
Published | CBObject: TComboBox;
Published | Camera: TGLCamera;
Published | Cube: TGLCube;
Published | Sphere: TGLSphere;
Published | LightSource: TGLLightSource;
Published | CBBackground: TComboBox;
Published | BackGroundSprite: TGLHUDSprite;
Published | Cone: TGLCone;
Published | Teapot: TGLTeapot;
Published | World: TGLDummyCube;
Published | Light: TGLDummyCube;
Published | FireSphere: TGLSphere;
Published | GLMaterialLibrary: TGLMaterialLibrary;

Methods

Public | constructor Create(AOwner : TComponent); override;
Published | procedure CBBackgroundChange(Sender: TObject);
Published | procedure CBObjectChange(Sender: TObject);
Published | procedure SceneViewerMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure SceneViewerMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published | procedure SceneViewerMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);

Properties

Public | property LibMaterial : TGLAbstractLibMaterial read GetLibMaterial write SetLibMaterial;
Public | property Material : TGLMaterial read GetMaterial write SetMaterial;

Description

Fields

Published GLScene1: TGLScene;
Published SceneViewer: TGLSceneViewer;
Published CBObject: TComboBox;
Published Camera: TGLCamera;
Published Cube: TGLCube;
Published Sphere: TGLSphere;
Published LightSource: TGLLightSource;
Published CBBackground: TComboBox;
Published BackGroundSprite: TGLHUDSprite;
Published Cone: TGLCone;
Published Teapot: TGLTeapot;
Published World: TGLDummyCube;
Published Light: TGLDummyCube;
Published FireSphere: TGLSphere;
Published GLMaterialLibrary: TGLMaterialLibrary;

Methods

Public constructor Create(AOwner : TComponent); override;
Published procedure CBBackgroundChange(Sender: TObject);
Published procedure CBObjectChange(Sender: TObject);
Published procedure SceneViewerMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure SceneViewerMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published procedure SceneViewerMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);

Properties

Public property LibMaterial : TGLAbstractLibMaterial read GetLibMaterial write SetLibMaterial;
Public property Material : TGLMaterial read GetMaterial write SetMaterial;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FRMaterialPreviewLCL

Unit FRMaterialPreviewLCL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRMaterialPreview |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FRMaterialPreviewLCL: Class TRMaterialPreview

Class TRMaterialPreview

Unit

FRMaterialPreviewLCL

Declaration

type TRMaterialPreview = class(TFrame)

Description

Hierarchy

  • TFrame
  • TRMaterialPreview

Overview

Fields

Published | GLMemoryViewer1: TGLMemoryViewer;
Published | GLScene1: TGLScene;
Published | CBObject: TComboBox;
Published | Camera: TGLCamera;
Published | Cube: TGLCube;
Published | imgFull: TImage;
Published | Sphere: TGLSphere;
Published | LightSource: TGLLightSource;
Published | CBBackground: TComboBox;
Published | BackGroundSprite: TGLHUDSprite;
Published | Cone: TGLCone;
Published | Teapot: TGLTeapot;
Published | Timer1: TTimer;
Published | World: TGLDummyCube;
Published | Light: TGLDummyCube;
Published | FireSphere: TGLSphere;
Published | GLMaterialLibrary: TGLMaterialLibrary;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Published | procedure CBBackgroundChange(Sender: TObject);
Published | procedure CBObjectChange(Sender: TObject);
Published | procedure imgFullMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure imgFullMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published | procedure imgFullMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);
Published | procedure imgFullResize(Sender: TObject);
Published | procedure Timer1Timer(Sender: TObject);
Public | Procedure Render;

Properties

Public property Material : TGLMaterial read GetMaterial write SetMaterial;

Description

Fields

Published GLMemoryViewer1: TGLMemoryViewer;
Published GLScene1: TGLScene;
Published CBObject: TComboBox;
Published Camera: TGLCamera;
Published Cube: TGLCube;
Published imgFull: TImage;
Published Sphere: TGLSphere;
Published LightSource: TGLLightSource;
Published CBBackground: TComboBox;
Published BackGroundSprite: TGLHUDSprite;
Published Cone: TGLCone;
Published Teapot: TGLTeapot;
Published Timer1: TTimer;
Published World: TGLDummyCube;
Published Light: TGLDummyCube;
Published FireSphere: TGLSphere;
Published GLMaterialLibrary: TGLMaterialLibrary;

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Published procedure CBBackgroundChange(Sender: TObject);
Published procedure CBObjectChange(Sender: TObject);
Published procedure imgFullMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure imgFullMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published procedure imgFullMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);
Published procedure imgFullResize(Sender: TObject);
Published procedure Timer1Timer(Sender: TObject);
Public Procedure Render;

Properties

Public property Material : TGLMaterial read GetMaterial write SetMaterial;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FRTextureEdit

Unit FRTextureEdit

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRTextureEdit |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FRTextureEdit: Class TRTextureEdit

Class TRTextureEdit

Unit

FRTextureEdit

Declaration

type TRTextureEdit = class(TFrame)

Description

Hierarchy

  • TFrame
  • TRTextureEdit

Overview

Fields

Published | Label2: TLabel;
Published | SBEditImage: TSpeedButton;
Published | CBMagFilter: TComboBox;
Published | Label3: TLabel;
Published | Label4: TLabel;
Published | CBMinFilter: TComboBox;
Published | CBTextureMode: TComboBox;
Published | Label1: TLabel;
Published | Label5: TLabel;
Published | CBTextureWrap: TComboBox;
Published | CBDisabled: TCheckBox;
Published | CBImageClass: TComboBox;
Published | CBImageAlpha: TComboBox;
Published | Label6: TLabel;
Published | CBFilteringQuality: TComboBox;
Published | Label7: TLabel;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Published | procedure CBDisabledClick(Sender: TObject);
Published | procedure CBFilteringQualityChange(Sender: TObject);
Published | procedure CBImageAlphaChange(Sender: TObject);
Published | procedure CBImageClassChange(Sender: TObject);
Published | procedure CBMagFilterChange(Sender: TObject);
Published | procedure CBMinFilterChange(Sender: TObject);
Published | procedure CBTextureModeChange(Sender: TObject);
Published | procedure CBTextureWrapChange(Sender: TObject);
Published | procedure SBEditImageClick(Sender: TObject);
Protected | procedure DoOnChange; dynamic;
Protected | procedure SetTexture(const val: TGLTexture);

Properties

Public | property OnChange: TNotifyEvent read FOnChange write FOnChange;
Public | property Texture: TGLTexture read FTexture write SetTexture;

Description

Fields

Published Label2: TLabel;
Published SBEditImage: TSpeedButton;
Published CBMagFilter: TComboBox;
Published Label3: TLabel;
Published Label4: TLabel;
Published CBMinFilter: TComboBox;
Published CBTextureMode: TComboBox;
Published Label1: TLabel;
Published Label5: TLabel;
Published CBTextureWrap: TComboBox;
Published CBDisabled: TCheckBox;
Published CBImageClass: TComboBox;
Published CBImageAlpha: TComboBox;
Published Label6: TLabel;
Published CBFilteringQuality: TComboBox;
Published Label7: TLabel;

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Published procedure CBDisabledClick(Sender: TObject);
Published procedure CBFilteringQualityChange(Sender: TObject);
Published procedure CBImageAlphaChange(Sender: TObject);
Published procedure CBImageClassChange(Sender: TObject);
Published procedure CBMagFilterChange(Sender: TObject);
Published procedure CBMinFilterChange(Sender: TObject);
Published procedure CBTextureModeChange(Sender: TObject);
Published procedure CBTextureWrapChange(Sender: TObject);
Published procedure SBEditImageClick(Sender: TObject);
Protected procedure DoOnChange; dynamic;
Protected procedure SetTexture(const val: TGLTexture);

Properties

Public property OnChange: TNotifyEvent read FOnChange write FOnChange;
Public property Texture: TGLTexture read FTexture write SetTexture;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FRTextureEditLCL

Unit FRTextureEditLCL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRTextureEdit |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FRTextureEditLCL: Class TRTextureEdit

Class TRTextureEdit

Unit

FRTextureEditLCL

Declaration

type TRTextureEdit = class(TFrame)

Description

Hierarchy

  • TFrame
  • TRTextureEdit

Overview

Fields

Published | CBFilteringQuality: TComboBox;
Published | Label2: TLabel;
Published | Label7: TLabel;
Published | SBEditImage: TSpeedButton;
Published | CBMagFilter: TComboBox;
Published | Label3: TLabel;
Published | Label4: TLabel;
Published | CBMinFilter: TComboBox;
Published | CBTextureMode: TComboBox;
Published | Label1: TLabel;
Published | Label5: TLabel;
Published | CBTextureWrap: TComboBox;
Published | CBDisabled: TCheckBox;
Published | CBImageClass: TComboBox;
Published | CBImageAlpha: TComboBox;
Published | Label6: TLabel;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Published | procedure CBDisabledClick(Sender: TObject);
Published | procedure CBFilteringQualityChange(Sender: TObject);
Published | procedure CBImageAlphaChange(Sender: TObject);
Published | procedure CBImageClassChange(Sender: TObject);
Published | procedure CBMagFilterChange(Sender: TObject);
Published | procedure CBMinFilterChange(Sender: TObject);
Published | procedure CBTextureModeChange(Sender: TObject);
Published | procedure CBTextureWrapChange(Sender: TObject);
Published | procedure SBEditImageClick(Sender: TObject);
Protected | procedure DoOnChange; dynamic;
Protected | procedure SetTexture(const val: TGLTexture);

Properties

Public | property OnChange: TNotifyEvent read FOnChange write FOnChange;
Public | property Texture: TGLTexture read FTexture write SetTexture;

Description

Fields

Published CBFilteringQuality: TComboBox;
Published Label2: TLabel;
Published Label7: TLabel;
Published SBEditImage: TSpeedButton;
Published CBMagFilter: TComboBox;
Published Label3: TLabel;
Published Label4: TLabel;
Published CBMinFilter: TComboBox;
Published CBTextureMode: TComboBox;
Published Label1: TLabel;
Published Label5: TLabel;
Published CBTextureWrap: TComboBox;
Published CBDisabled: TCheckBox;
Published CBImageClass: TComboBox;
Published CBImageAlpha: TComboBox;
Published Label6: TLabel;

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Published procedure CBDisabledClick(Sender: TObject);
Published procedure CBFilteringQualityChange(Sender: TObject);
Published procedure CBImageAlphaChange(Sender: TObject);
Published procedure CBImageClassChange(Sender: TObject);
Published procedure CBMagFilterChange(Sender: TObject);
Published procedure CBMinFilterChange(Sender: TObject);
Published procedure CBTextureModeChange(Sender: TObject);
Published procedure CBTextureWrapChange(Sender: TObject);
Published procedure SBEditImageClick(Sender: TObject);
Protected procedure DoOnChange; dynamic;
Protected procedure SetTexture(const val: TGLTexture);

Properties

Public property OnChange: TNotifyEvent read FOnChange write FOnChange;
Public property Texture: TGLTexture read FTexture write SetTexture;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FRTrackBarEdit

Unit FRTrackBarEdit

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FRTrackBarEdit<p>

Frame combining a TrackBar and an Edit.<p>

<b>Historique : </b><font size=-1><ul> <li>05/10/08 - DanB - Removed Kylix support <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>19/12/06 - DaStr - Fixed bug in SetValue, SetValueMin, SetValueMax when changing these values didn't change the Edit's Text <li>03/07/04 - LR - Make change for Linux <li>06/02/00 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRTrackBarEdit |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FRTrackBarEdit: Class TRTrackBarEdit

Class TRTrackBarEdit

Unit

FRTrackBarEdit

Declaration

type TRTrackBarEdit = class(TFrame)

Description

Hierarchy

  • TFrame
  • TRTrackBarEdit

Overview

Fields

Published | TrackBar: TTrackBar;
Published | Edit: TEdit;

Methods

Published | procedure EditChange(Sender: TObject);
Published | procedure TrackBarChange(Sender: TObject);

Properties

Public | property Value : Integer read GetValue write SetValue;
Public | property ValueMax : Integer read GetValueMax write SetValueMax;
Public | property ValueMin : Integer read GetValueMin write SetValueMin;

Description

Fields

Published TrackBar: TTrackBar;
Published Edit: TEdit;

Methods

Published procedure EditChange(Sender: TObject);
Published procedure TrackBarChange(Sender: TObject);

Properties

Public property Value : Integer read GetValue write SetValue;
Public property ValueMax : Integer read GetValueMax write SetValueMax;
Public property ValueMin : Integer read GetValueMin write SetValueMin;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FRTrackBarEditLCL

Unit FRTrackBarEditLCL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FRTrackBarEdit<p>

Frame combining a TrackBar and an Edit.<p>

<b>Historique : </b><font size=-1><ul>

</ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRTrackBarEdit |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FRTrackBarEditLCL: Class TRTrackBarEdit

Class TRTrackBarEdit

Unit

FRTrackBarEditLCL

Declaration

type TRTrackBarEdit = class(TFrame)

Description

Hierarchy

  • TFrame
  • TRTrackBarEdit

Overview

Fields

Published | TrackBar: TTrackBar;
Published | Edit: TEdit;

Methods

Published | procedure EditChange(Sender: TObject);
Published | procedure TrackBarChange(Sender: TObject);

Properties

Public | property Value : Integer read GetValue write SetValue;
Public | property ValueMax : Integer read GetValueMax write SetValueMax;
Public | property ValueMin : Integer read GetValueMin write SetValueMin;

Description

Fields

Published TrackBar: TTrackBar;
Published Edit: TEdit;

Methods

Published procedure EditChange(Sender: TObject);
Published procedure TrackBarChange(Sender: TObject);

Properties

Public property Value : Integer read GetValue write SetValue;
Public property ValueMax : Integer read GetValueMax write SetValueMax;
Public property ValueMin : Integer read GetValueMin write SetValueMin;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FRUniformEditor

Unit FRUniformEditor

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FRUniformEditor<p>

<b>History : </b><font size=-1><ul> <li>23/03/11 - Yar - Creation </ul>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TShaderUniformEditor |

Functions and Procedures

function ShaderUniformEditor: TShaderUniformEditor;
procedure ReleaseShaderUniformEditor;

Description

Functions and Procedures

function ShaderUniformEditor: TShaderUniformEditor;
procedure ReleaseShaderUniformEditor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FRUniformEditor: Class TShaderUniformEditor

Class TShaderUniformEditor

Unit

FRUniformEditor

Declaration

type TShaderUniformEditor = class(TForm)

Description

Hierarchy

  • TForm
  • TShaderUniformEditor

Overview

Fields

Published | LBUniforms: TListBox;
Published | Labe1: TLabel;
Published | AutoSetBox: TComboBox;
Published | SamplerBox: TComboBox;
Published | Panel1: TPanel;
Published | RedGroup: TRadioGroup;
Published | GreenGroup: TRadioGroup;
Published | BlueGroup: TRadioGroup;
Published | AlphaGroup: TRadioGroup;
Published | Label1: TLabel;
Published | Label2: TLabel;
Published | Label3: TLabel;
Published | Label4: TLabel;
Published | TextureBox: TComboBox;
Published | Button1: TButton;

Methods

Published | procedure AutoSetBoxChange(Sender: TObject);
Published | procedure ColorGroupClick(Sender: TObject);
Published | procedure FormDestroy(Sender: TObject);
Published | procedure LBUniformsClick(Sender: TObject);
Published | procedure LBUniformsKeyPress(Sender: TObject; var Key: Char);
Published | procedure SamplerBoxChange(Sender: TObject);
Published | procedure TextureBoxChange(Sender: TObject);
Public | procedure AddSamplerName(const S: string);
Public | procedure AddTextureName(const S: string);
Public | procedure AddUniform(AValue: IShaderParameter);
Public | procedure Clear;
Public | procedure Execute;

Description

Fields

Published LBUniforms: TListBox;
Published Labe1: TLabel;
Published AutoSetBox: TComboBox;
Published SamplerBox: TComboBox;
Published Panel1: TPanel;
Published RedGroup: TRadioGroup;
Published GreenGroup: TRadioGroup;
Published BlueGroup: TRadioGroup;
Published AlphaGroup: TRadioGroup;
Published Label1: TLabel;
Published Label2: TLabel;
Published Label3: TLabel;
Published Label4: TLabel;
Published TextureBox: TComboBox;
Published Button1: TButton;

Methods

Published procedure AutoSetBoxChange(Sender: TObject);
Published procedure ColorGroupClick(Sender: TObject);
Published procedure FormDestroy(Sender: TObject);
Published procedure LBUniformsClick(Sender: TObject);
Published procedure LBUniformsKeyPress(Sender: TObject; var Key: Char);
Published procedure SamplerBoxChange(Sender: TObject);
Published procedure TextureBoxChange(Sender: TObject);
Public procedure AddSamplerName(const S: string);
Public procedure AddTextureName(const S: string);
Public procedure AddUniform(AValue: IShaderParameter);
Public procedure Clear;
Public procedure Execute;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FShaderMemo

Unit FShaderMemo

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLShaderEditor |

Functions and Procedures

function GLShaderEditorForm: TGLShaderEditor;
procedure ReleaseGLShaderEditor;

Description

Functions and Procedures

function GLShaderEditorForm: TGLShaderEditor;
procedure ReleaseGLShaderEditor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FShaderMemo: Class TGLShaderEditor

Class TGLShaderEditor

Unit

FShaderMemo

Declaration

type TGLShaderEditor = class(TForm)

Description

Hierarchy

  • TForm
  • TGLShaderEditor

Overview

Fields

Published | ImageList: TImageList;
Published | ToolBar: TToolBar;
Published | TBOpen: TToolButton;
Published | TBSave: TToolButton;
Published | TBStayOnTop: TToolButton;
Published | TBHelp: TToolButton;
Published | ToolButton2: TToolButton;
Published | TBCopy: TToolButton;
Published | TBPaste: TToolButton;
Published | TBCut: TToolButton;
Published | ToolButton10: TToolButton;
Published | TBTemplate: TToolButton;
Published | TBUndo: TToolButton;
Published | TBRedo: TToolButton;
Published | ToolButton4: TToolButton;
Published | GLSLMemo: TGLSSynHiMemo;
Published | OpenDialog: TOpenDialog;
Published | SaveDialog: TSaveDialog;
Published | TemplateMenu: TPopupMenu;
Published | GLSL120: TMenuItem;
Published | GLSL330: TMenuItem;
Published | GLSL400: TMenuItem;
Published | N1: TMenuItem;
Published | N2: TMenuItem;
Published | CompilatorLog: TMemo;
Published | TBIncIndent: TToolButton;
Published | TBDecIndent: TToolButton;
Published | TBComment: TToolButton;
Published | TBUncoment: TToolButton;
Published | ToolButton1: TToolButton;
Published | Panel1: TPanel;
Published | CancelButton: TButton;
Published | OKButton: TButton;
Published | CheckButton: TButton;
Published | Splitter1: TSplitter;

Methods

Published | procedure CheckButtonClick(Sender: TObject);
Published | procedure FormCreate(Sender: TObject);
Published | procedure FormDestroy(Sender: TObject);
Published | procedure FormShow(Sender: TObject);
Published | procedure GLSLMemoGutterClick(Sender: TObject; LineNo: Integer);
Published | procedure GLSLMemoGutterDraw(Sender: TObject; ACanvas: TCanvas; LineNo: Integer; rct: TRect);
Published | procedure GLSLMemoUndoChange(Sender: TObject; CanUndo, CanRedo: Boolean);
Published | procedure TBCommentClick(Sender: TObject);
Published | procedure TBCopyClick(Sender: TObject);
Published | procedure TBCutClick(Sender: TObject);
Published | procedure TBDecIndentClick(Sender: TObject);
Published | procedure TBIncIndentClick(Sender: TObject);
Published | procedure TBOpenClick(Sender: TObject);
Published | procedure TBPasteClick(Sender: TObject);
Published | procedure TBRedoClick(Sender: TObject);
Published | procedure TBSaveClick(Sender: TObject);
Published | procedure TBStayOnTopClick(Sender: TObject);
Published | procedure TBUncomentClick(Sender: TObject);
Published | procedure TBUndoClick(Sender: TObject);

Properties

Public property OnCheck: TNotifyEvent read FOnCheck write FOnCheck;

Description

Fields

Published ImageList: TImageList;
Published ToolBar: TToolBar;
Published TBOpen: TToolButton;
Published TBSave: TToolButton;
Published TBStayOnTop: TToolButton;
Published TBHelp: TToolButton;
Published ToolButton2: TToolButton;
Published TBCopy: TToolButton;
Published TBPaste: TToolButton;
Published TBCut: TToolButton;
Published ToolButton10: TToolButton;
Published TBTemplate: TToolButton;
Published TBUndo: TToolButton;
Published TBRedo: TToolButton;
Published ToolButton4: TToolButton;
Published GLSLMemo: TGLSSynHiMemo;
Published OpenDialog: TOpenDialog;
Published SaveDialog: TSaveDialog;
Published TemplateMenu: TPopupMenu;
Published GLSL120: TMenuItem;
Published GLSL330: TMenuItem;
Published GLSL400: TMenuItem;
Published N1: TMenuItem;
Published N2: TMenuItem;
Published CompilatorLog: TMemo;
Published TBIncIndent: TToolButton;
Published TBDecIndent: TToolButton;
Published TBComment: TToolButton;
Published TBUncoment: TToolButton;
Published ToolButton1: TToolButton;
Published Panel1: TPanel;
Published CancelButton: TButton;
Published OKButton: TButton;
Published CheckButton: TButton;
Published Splitter1: TSplitter;

Methods

Published procedure CheckButtonClick(Sender: TObject);
Published procedure FormCreate(Sender: TObject);
Published procedure FormDestroy(Sender: TObject);
Published procedure FormShow(Sender: TObject);
Published procedure GLSLMemoGutterClick(Sender: TObject; LineNo: Integer);
Published procedure GLSLMemoGutterDraw(Sender: TObject; ACanvas: TCanvas; LineNo: Integer; rct: TRect);
Published procedure GLSLMemoUndoChange(Sender: TObject; CanUndo, CanRedo: Boolean);
Published procedure TBCommentClick(Sender: TObject);
Published procedure TBCopyClick(Sender: TObject);
Published procedure TBCutClick(Sender: TObject);
Published procedure TBDecIndentClick(Sender: TObject);
Published procedure TBIncIndentClick(Sender: TObject);
Published procedure TBOpenClick(Sender: TObject);
Published procedure TBPasteClick(Sender: TObject);
Published procedure TBRedoClick(Sender: TObject);
Published procedure TBSaveClick(Sender: TObject);
Published procedure TBStayOnTopClick(Sender: TObject);
Published procedure TBUncomentClick(Sender: TObject);
Published procedure TBUndoClick(Sender: TObject);

Properties

Public property OnCheck: TNotifyEvent read FOnCheck write FOnCheck;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FVectorEditor

Unit FVectorEditor

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FVectorEditor<p>

Editor for a vector.<p>

<b>Historique : </b><font size=-1><ul> <li>05/10/08 - DanB - Removed Kylix support <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>03/07/04 - LR - Make change for Linux <li>?/?/? - - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TVectorEditorForm |

Functions and Procedures

function VectorEditorForm : TVectorEditorForm;
procedure ReleaseVectorEditorForm;

Description

Functions and Procedures

function VectorEditorForm : TVectorEditorForm;
procedure ReleaseVectorEditorForm;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FVectorEditor: Class TVectorEditorForm

Class TVectorEditorForm

Unit

FVectorEditor

Declaration

type TVectorEditorForm = class(TForm)

Description

Hierarchy

  • TForm
  • TVectorEditorForm

Overview

Fields

Published | EDx: TEdit;
Published | Label1: TLabel;
Published | Label2: TLabel;
Published | Label3: TLabel;
Published | EDy: TEdit;
Published | EDz: TEdit;
Published | BBok: TBitBtn;
Published | BBcancel: TBitBtn;
Published | IMx: TImage;
Published | IMy: TImage;
Published | IMz: TImage;
Published | SpeedButton1: TSpeedButton;
Published | SBmX: TSpeedButton;
Published | SpeedButton3: TSpeedButton;
Published | SBmY: TSpeedButton;
Published | SpeedButton5: TSpeedButton;
Published | SBmZ: TSpeedButton;
Published | SpeedButton7: TSpeedButton;
Published | SBUnit: TSpeedButton;
Published | SpeedButton9: TSpeedButton;
Published | Bevel1: TBevel;
Published | SBInvert: TSpeedButton;

Methods

Public | function Execute(var x, y, z : Single) : Boolean;
Published | procedure EDxChange(Sender: TObject);
Published | procedure EDyChange(Sender: TObject);
Published | procedure EDzChange(Sender: TObject);
Published | procedure SBInvertClick(Sender: TObject);
Published | procedure SBmXClick(Sender: TObject);
Published | procedure SBmYClick(Sender: TObject);
Published | procedure SBmZClick(Sender: TObject);
Published | procedure SBUnitClick(Sender: TObject);
Published | procedure SpeedButton9Click(Sender: TObject);
Published | procedure TBnullClick(Sender: TObject);
Published | procedure TBxClick(Sender: TObject);
Published | procedure TByClick(Sender: TObject);
Published | procedure TBzClick(Sender: TObject);

Description

Fields

Published EDx: TEdit;
Published Label1: TLabel;
Published Label2: TLabel;
Published Label3: TLabel;
Published EDy: TEdit;
Published EDz: TEdit;
Published BBok: TBitBtn;
Published BBcancel: TBitBtn;
Published IMx: TImage;
Published IMy: TImage;
Published IMz: TImage;
Published SpeedButton1: TSpeedButton;
Published SBmX: TSpeedButton;
Published SpeedButton3: TSpeedButton;
Published SBmY: TSpeedButton;
Published SpeedButton5: TSpeedButton;
Published SBmZ: TSpeedButton;
Published SpeedButton7: TSpeedButton;
Published SBUnit: TSpeedButton;
Published SpeedButton9: TSpeedButton;
Published Bevel1: TBevel;
Published SBInvert: TSpeedButton;

Methods

Public function Execute(var x, y, z : Single) : Boolean;
Published procedure EDxChange(Sender: TObject);
Published procedure EDyChange(Sender: TObject);
Published procedure EDzChange(Sender: TObject);
Published procedure SBInvertClick(Sender: TObject);
Published procedure SBmXClick(Sender: TObject);
Published procedure SBmYClick(Sender: TObject);
Published procedure SBmZClick(Sender: TObject);
Published procedure SBUnitClick(Sender: TObject);
Published procedure SpeedButton9Click(Sender: TObject);
Published procedure TBnullClick(Sender: TObject);
Published procedure TBxClick(Sender: TObject);
Published procedure TByClick(Sender: TObject);
Published procedure TBzClick(Sender: TObject);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FVectorEditorLCL

Unit FVectorEditorLCL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

FVectorEditor<p>

Editor for a vector.<p>

<b>Historique : </b><font size=-1><ul>

</ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TVectorEditorForm |

Functions and Procedures

function VectorEditorForm : TVectorEditorForm;
procedure ReleaseVectorEditorForm;

Description

Functions and Procedures

function VectorEditorForm : TVectorEditorForm;
procedure ReleaseVectorEditorForm;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FVectorEditorLCL: Class TVectorEditorForm

Class TVectorEditorForm

Unit

FVectorEditorLCL

Declaration

type TVectorEditorForm = class(TForm)

Description

Hierarchy

  • TForm
  • TVectorEditorForm

Overview

Fields

Published | EDx: TEdit;
Published | Label1: TLabel;
Published | Label2: TLabel;
Published | Label3: TLabel;
Published | EDy: TEdit;
Published | EDz: TEdit;
Published | BBok: TBitBtn;
Published | BBcancel: TBitBtn;
Published | IMx: TImage;
Published | IMy: TImage;
Published | IMz: TImage;
Published | SpeedButton1: TSpeedButton;
Published | SBmX: TSpeedButton;
Published | SpeedButton3: TSpeedButton;
Published | SBmY: TSpeedButton;
Published | SpeedButton5: TSpeedButton;
Published | SBmZ: TSpeedButton;
Published | SpeedButton7: TSpeedButton;
Published | SBUnit: TSpeedButton;
Published | SpeedButton9: TSpeedButton;
Published | Bevel1: TBevel;
Published | SBInvert: TSpeedButton;

Methods

Public | function Execute(var x, y, z : Single) : Boolean;
Published | procedure EDxChange(Sender: TObject);
Published | procedure EDyChange(Sender: TObject);
Published | procedure EDzChange(Sender: TObject);
Published | procedure SBInvertClick(Sender: TObject);
Published | procedure SBmXClick(Sender: TObject);
Published | procedure SBmYClick(Sender: TObject);
Published | procedure SBmZClick(Sender: TObject);
Published | procedure SBUnitClick(Sender: TObject);
Published | procedure SpeedButton9Click(Sender: TObject);
Published | procedure TBnullClick(Sender: TObject);
Published | procedure TBxClick(Sender: TObject);
Published | procedure TByClick(Sender: TObject);
Published | procedure TBzClick(Sender: TObject);

Description

Fields

Published EDx: TEdit;
Published Label1: TLabel;
Published Label2: TLabel;
Published Label3: TLabel;
Published EDy: TEdit;
Published EDz: TEdit;
Published BBok: TBitBtn;
Published BBcancel: TBitBtn;
Published IMx: TImage;
Published IMy: TImage;
Published IMz: TImage;
Published SpeedButton1: TSpeedButton;
Published SBmX: TSpeedButton;
Published SpeedButton3: TSpeedButton;
Published SBmY: TSpeedButton;
Published SpeedButton5: TSpeedButton;
Published SBmZ: TSpeedButton;
Published SpeedButton7: TSpeedButton;
Published SBUnit: TSpeedButton;
Published SpeedButton9: TSpeedButton;
Published Bevel1: TBevel;
Published SBInvert: TSpeedButton;

Methods

Public function Execute(var x, y, z : Single) : Boolean;
Published procedure EDxChange(Sender: TObject);
Published procedure EDyChange(Sender: TObject);
Published procedure EDzChange(Sender: TObject);
Published procedure SBInvertClick(Sender: TObject);
Published procedure SBmXClick(Sender: TObject);
Published procedure SBmYClick(Sender: TObject);
Published procedure SBmZClick(Sender: TObject);
Published procedure SBUnitClick(Sender: TObject);
Published procedure SpeedButton9Click(Sender: TObject);
Published procedure TBnullClick(Sender: TObject);
Published procedure TBxClick(Sender: TObject);
Published procedure TByClick(Sender: TObject);
Published procedure TBzClick(Sender: TObject);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FXCollectionEditor

Unit FXCollectionEditor

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TXCollectionEditor |

Functions and Procedures

function XCollectionEditor: TXCollectionEditor;
procedure ReleaseXCollectionEditor;

Description

Functions and Procedures

function XCollectionEditor: TXCollectionEditor;
procedure ReleaseXCollectionEditor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FXCollectionEditor: Class TXCollectionEditor

Class TXCollectionEditor

Unit

FXCollectionEditor

Declaration

type TXCollectionEditor = class(TForm)

Description

Hierarchy

  • TForm
  • TXCollectionEditor

Overview

Fields

Published | ListView: TListView;
Published | PMListView: TPopupMenu;
Published | ActionList: TActionList;
Published | ACRemove: TAction;
Published | ACMoveUp: TAction;
Published | ACMoveDown: TAction;
Published | ImageList: TImageList;
Published | MIAdd: TMenuItem;
Published | N1: TMenuItem;
Published | N2: TMenuItem;
Published | Moveup1: TMenuItem;
Published | Movedown1: TMenuItem;
Published | ToolBar1: TToolBar;
Published | TBAdd: TToolButton;
Published | ToolButton2: TToolButton;
Published | ToolButton3: TToolButton;
Published | ToolButton4: TToolButton;
Published | ToolButton5: TToolButton;
Published | ToolButton6: TToolButton;
Published | PMToolBar: TPopupMenu;

Methods

Published | procedure ACMoveDownExecute(Sender: TObject);
Published | procedure ACMoveUpExecute(Sender: TObject);
Published | procedure ACRemoveExecute(Sender: TObject);
Published | procedure FormCreate(Sender: TObject);
Published | procedure FormDestroy(Sender: TObject);
Published | procedure FormHide(Sender: TObject);
Published | procedure ListViewChange(Sender: TObject; Item: TListItem; Change: TItemChange);
Published | procedure PMListViewPopup(Sender: TObject);
Published | procedure PMToolBarPopup(Sender: TObject);
Published | procedure TBAddClick(Sender: TObject);
Public | procedure SetXCollection(aXCollection: TXCollection; designer: IFormDesigner );
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Description

Fields

Published ListView: TListView;
Published PMListView: TPopupMenu;
Published ActionList: TActionList;
Published ACRemove: TAction;
Published ACMoveUp: TAction;
Published ACMoveDown: TAction;
Published ImageList: TImageList;
Published MIAdd: TMenuItem;
Published N1: TMenuItem;
Published N2: TMenuItem;
Published Moveup1: TMenuItem;
Published Movedown1: TMenuItem;
Published ToolBar1: TToolBar;
Published TBAdd: TToolButton;
Published ToolButton2: TToolButton;
Published ToolButton3: TToolButton;
Published ToolButton4: TToolButton;
Published ToolButton5: TToolButton;
Published ToolButton6: TToolButton;
Published PMToolBar: TPopupMenu;

Methods

Published procedure ACMoveDownExecute(Sender: TObject);
Published procedure ACMoveUpExecute(Sender: TObject);
Published procedure ACRemoveExecute(Sender: TObject);
Published procedure FormCreate(Sender: TObject);
Published procedure FormDestroy(Sender: TObject);
Published procedure FormHide(Sender: TObject);
Published procedure ListViewChange(Sender: TObject; Item: TListItem; Change: TItemChange);
Published procedure PMListViewPopup(Sender: TObject);
Published procedure PMToolBarPopup(Sender: TObject);
Published procedure TBAddClick(Sender: TObject);
Public procedure SetXCollection(aXCollection: TXCollection; designer: IFormDesigner );
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FXCollectionEditorLCL

Unit FXCollectionEditorLCL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Egg<p>

Edits a TXCollection<p>

<b>Historique : </b><font size=-1><ul> <li>20/05/10 - Yar - Fixes for Linux x64 <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>03/07/04 - LR - Make change for Linux <li>12/07/03 - DanB - Fixed crash when owner deleted <li>27/02/02 - Egg - Fixed crash after item deletion <li>11/04/00 - Egg - Fixed crashes in IDE <li>06/04/00 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TXCollectionEditor |

Functions and Procedures

function XCollectionEditor: TXCollectionEditor;
procedure ReleaseXCollectionEditor;

Description

Functions and Procedures

function XCollectionEditor: TXCollectionEditor;
procedure ReleaseXCollectionEditor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: FXCollectionEditorLCL: Class TXCollectionEditor

Class TXCollectionEditor

Unit

FXCollectionEditorLCL

Declaration

type TXCollectionEditor = class(TForm)

Description

Hierarchy

  • TForm
  • TXCollectionEditor

Overview

Fields

Published | ListView: TListView;
Published | PMListView: TPopupMenu;
Published | ActionList: TActionList;
Published | ACRemove: TAction;
Published | ACMoveUp: TAction;
Published | ACMoveDown: TAction;
Published | ImageList: TImageList;
Published | MIAdd: TMenuItem;
Published | N1: TMenuItem;
Published | N2: TMenuItem;
Published | Moveup1: TMenuItem;
Published | Movedown1: TMenuItem;
Published | ToolBar1: TToolBar;
Published | TBAdd: TToolButton;
Published | ToolButton2: TToolButton;
Published | ToolButton3: TToolButton;
Published | ToolButton4: TToolButton;
Published | ToolButton5: TToolButton;
Published | ToolButton6: TToolButton;
Published | PMToolBar: TPopupMenu;

Methods

Published | procedure ACMoveDownExecute(Sender: TObject);
Published | procedure ACMoveUpExecute(Sender: TObject);
Published | procedure ACRemoveExecute(Sender: TObject);
Published | procedure FormCreate(Sender: TObject);
Published | procedure FormDestroy(Sender: TObject);
Published | procedure FormHide(Sender: TObject);
Published | procedure ListViewChange(Sender: TObject; Item: TListItem; Change: TItemChange);
Published | procedure ListViewClick(Sender: TObject);
Published | procedure PMListViewPopup(Sender: TObject);
Published | procedure PMToolBarPopup(Sender: TObject);
Published | procedure TBAddClick(Sender: TObject);
Public | procedure SetXCollection(aXCollection: TXCollection);

Description

Fields

Published ListView: TListView;
Published PMListView: TPopupMenu;
Published ActionList: TActionList;
Published ACRemove: TAction;
Published ACMoveUp: TAction;
Published ACMoveDown: TAction;
Published ImageList: TImageList;
Published MIAdd: TMenuItem;
Published N1: TMenuItem;
Published N2: TMenuItem;
Published Moveup1: TMenuItem;
Published Movedown1: TMenuItem;
Published ToolBar1: TToolBar;
Published TBAdd: TToolButton;
Published ToolButton2: TToolButton;
Published ToolButton3: TToolButton;
Published ToolButton4: TToolButton;
Published ToolButton5: TToolButton;
Published ToolButton6: TToolButton;
Published PMToolBar: TPopupMenu;

Methods

Published procedure ACMoveDownExecute(Sender: TObject);
Published procedure ACMoveUpExecute(Sender: TObject);
Published procedure ACRemoveExecute(Sender: TObject);
Published procedure FormCreate(Sender: TObject);
Published procedure FormDestroy(Sender: TObject);
Published procedure FormHide(Sender: TObject);
Published procedure ListViewChange(Sender: TObject; Item: TListItem; Change: TItemChange);
Published procedure ListViewClick(Sender: TObject);
Published procedure PMListViewPopup(Sender: TObject);
Published procedure PMToolBarPopup(Sender: TObject);
Published procedure TBAddClick(Sender: TObject);
Public procedure SetXCollection(aXCollection: TXCollection);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:08


GLScene v.1.1.2: GeometryBB

Unit GeometryBB

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record THmgBoundingBox |
record TAABB |
record TBSphere |
record TClipRect |

Functions and Procedures

function BoundingBoxesAreEqual(const ABoundingBox1, ABoundingBox2 : THmgBoundingBox): Boolean; overload;
function BoundingBoxesAreEqual(const ABoundingBox1, ABoundingBox2 : PHmgBoundingBox): Boolean; overload;
function AddBB(var C1: THmgBoundingBox; const C2: THmgBoundingBox) : THmgBoundingBox;
procedure AddAABB(var Aabb: TAABB; const Aabb1: TAABB);
procedure SetBB(var C: THmgBoundingBox; const V: TVector);
procedure SetAABB(var Bb: TAABB; const V: TVector);
procedure BBTransform(var C: THmgBoundingBox; const M: TMatrix);
procedure AABBTransform(var Bb: TAABB; const M: TMatrix);
procedure AABBScale(var Bb: TAABB; const V: TAffineVector);
function BBMinX(const C: THmgBoundingBox): Single;
function BBMaxX(const C: THmgBoundingBox): Single;
function BBMinY(const C: THmgBoundingBox): Single;
function BBMaxY(const C: THmgBoundingBox): Single;
function BBMinZ(const C: THmgBoundingBox): Single;
function BBMaxZ(const C: THmgBoundingBox): Single;
procedure AABBInclude(var Bb: TAABB; const P: TAffineVector);
procedure AABBFromSweep(var SweepAABB: TAABB; const Start, Dest: TVector; const Radius: Single);
function AABBIntersection(const Aabb1, Aabb2: TAABB): TAABB;
function BBToAABB(const ABB: THmgBoundingBox): TAABB;
function AABBToBB(const AnAABB: TAABB): THmgBoundingBox; overload;
function AABBToBB(const AnAABB: TAABB; const M: TMatrix) : THmgBoundingBox; overload;
procedure OffsetAABB(var Aabb: TAABB; const Delta: TAffineVector); overload;
procedure OffsetAABB(var Aabb: TAABB; const Delta: TVector); overload;
procedure OffsetBB(var Bb: THmgBoundingBox; const Delta: TAffineVector); overload;
procedure OffsetBB(var Bb: THmgBoundingBox; const Delta: TVector); overload;
procedure OffsetBBPoint(var Bb: THmgBoundingBox; const Delta: TVector); overload;
function IntersectAABBs(const Aabb1, Aabb2: TAABB; const M1To2, M2To1: TMatrix) : Boolean; overload;
function IntersectAABBsAbsoluteXY(const Aabb1, Aabb2: TAABB): Boolean;
function IntersectAABBsAbsoluteXZ(const Aabb1, Aabb2: TAABB): Boolean;
function IntersectAABBsAbsolute(const Aabb1, Aabb2: TAABB): Boolean;
function AABBFitsInAABBAbsolute(const Aabb1, Aabb2: TAABB): Boolean;
function PointInAABB(const P: TAffineVector; const Aabb: TAABB) : Boolean; overload;
function PointInAABB(const P: TVector; const Aabb: TAABB): Boolean; overload;
function PlaneIntersectAABB(Normal: TAffineVector; D: Single; Aabb: TAABB): Boolean;
function PlaneAABBIntersection(const plane : THmgPlane; const AABB : TAABB) : TAffineVectorList;
function TriangleIntersectAABB(const Aabb: TAABB; const V1, V2, V3: TAffineVector): Boolean;
procedure ExtractAABBCorners(const AABB: TAABB; var AABBCorners: TAABBCorners);
procedure AABBToBSphere(const AABB: TAABB; var BSphere: TBSphere);
procedure BSphereToAABB(const BSphere: TBSphere; var AABB: TAABB); overload;
function BSphereToAABB(const Center: TAffineVector; Radius: Single) : TAABB; overload;
function BSphereToAABB(const Center: TVector; Radius: Single): TAABB; overload;
function AABBContainsAABB(const MainAABB, TestAABB: TAABB): TSpaceContains;
function BSphereContainsAABB(const MainBSphere: TBSphere; const TestAABB: TAABB) : TSpaceContains;
function BSphereContainsBSphere(const MainBSphere, TestBSphere: TBSphere) : TSpaceContains;
function AABBContainsBSphere(const MainAABB: TAABB; const TestBSphere: TBSphere) : TSpaceContains;
function PlaneContainsBSphere(const Location, Normal: TAffineVector; const TestBSphere: TBSphere): TSpaceContains;
function FrustumContainsBSphere(const Frustum: TFrustum; const TestBSphere: TBSphere): TSpaceContains;
function FrustumContainsAABB(const Frustum: TFrustum; const TestAABB: TAABB) : TSpaceContains;
function ClipToAABB(const V: TAffineVector; const AABB: TAABB): TAffineVector;
function BSphereIntersectsBSphere(const MainBSphere, TestBSphere: TBSphere): Boolean;
procedure IncludeInClipRect(var ClipRect: TClipRect; X, Y: Single);
function AABBToClipRect(const Aabb: TAABB; ModelViewProjection: TMatrix; ViewportSizeX, ViewportSizeY: Integer): TClipRect;
function RayCastAABBIntersect(const RayOrigin, RayDirection: TVector; const Aabb: TAABB; out TNear, TFar: Single): Boolean; overload;
function RayCastAABBIntersect(const RayOrigin, RayDirection: TVector; const Aabb: TAABB; IntersectPoint: PVector = nil): Boolean; overload;

Types

PHmgBoundingBox = ˆTHmgBoundingBox;
PAABB = ˆTAABB;
TSpaceContains = (...);
TAABBCorners = array [0 .. 7] of TAffineVector;
TPlanIndices = array [0 .. 3] of Integer;
TPlanBB = array [0 .. 5] of TPlanIndices;
TDirPlan = array [0 .. 5] of Integer;

Constants

NullBoundingBox: THmgBoundingBox = (BBox:((X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1)));
CBBFront: TPlanIndices = (0, 1, 2, 3);
CBBBack: TPlanIndices = (4, 5, 6, 7);
CBBLeft: TPlanIndices = (0, 4, 7, 3);
CBBRight: TPlanIndices = (1, 5, 6, 2);
CBBTop: TPlanIndices = (0, 1, 5, 4);
CBBBottom: TPlanIndices = (2, 3, 7, 6);
CBBPlans: TPlanBB = ((0, 1, 2, 3), (4, 5, 6, 7), (0, 4, 7, 3), (1, 5, 6, 2), (0, 1, 5, 4), (2, 3, 7, 6));
CDirPlan: TDirPlan = (0, 0, 1, 1, 2, 2);

Description

Functions and Procedures

function BoundingBoxesAreEqual(const ABoundingBox1, ABoundingBox2 : THmgBoundingBox): Boolean; overload;
function BoundingBoxesAreEqual(const ABoundingBox1, ABoundingBox2 : PHmgBoundingBox): Boolean; overload;
function AddBB(var C1: THmgBoundingBox; const C2: THmgBoundingBox) : THmgBoundingBox;
procedure AddAABB(var Aabb: TAABB; const Aabb1: TAABB);
procedure SetBB(var C: THmgBoundingBox; const V: TVector);
procedure SetAABB(var Bb: TAABB; const V: TVector);
procedure BBTransform(var C: THmgBoundingBox; const M: TMatrix);
procedure AABBTransform(var Bb: TAABB; const M: TMatrix);
procedure AABBScale(var Bb: TAABB; const V: TAffineVector);
function BBMinX(const C: THmgBoundingBox): Single;
function BBMaxX(const C: THmgBoundingBox): Single;
function BBMinY(const C: THmgBoundingBox): Single;
function BBMaxY(const C: THmgBoundingBox): Single;
function BBMinZ(const C: THmgBoundingBox): Single;
function BBMaxZ(const C: THmgBoundingBox): Single;
procedure AABBInclude(var Bb: TAABB; const P: TAffineVector);
procedure AABBFromSweep(var SweepAABB: TAABB; const Start, Dest: TVector; const Radius: Single);
function AABBIntersection(const Aabb1, Aabb2: TAABB): TAABB;
function BBToAABB(const ABB: THmgBoundingBox): TAABB;
function AABBToBB(const AnAABB: TAABB): THmgBoundingBox; overload;
function AABBToBB(const AnAABB: TAABB; const M: TMatrix) : THmgBoundingBox; overload;
procedure OffsetAABB(var Aabb: TAABB; const Delta: TAffineVector); overload;
procedure OffsetAABB(var Aabb: TAABB; const Delta: TVector); overload;
procedure OffsetBB(var Bb: THmgBoundingBox; const Delta: TAffineVector); overload;
procedure OffsetBB(var Bb: THmgBoundingBox; const Delta: TVector); overload;
procedure OffsetBBPoint(var Bb: THmgBoundingBox; const Delta: TVector); overload;
function IntersectAABBs(const Aabb1, Aabb2: TAABB; const M1To2, M2To1: TMatrix) : Boolean; overload;
function IntersectAABBsAbsoluteXY(const Aabb1, Aabb2: TAABB): Boolean;
function IntersectAABBsAbsoluteXZ(const Aabb1, Aabb2: TAABB): Boolean;
function IntersectAABBsAbsolute(const Aabb1, Aabb2: TAABB): Boolean;
function AABBFitsInAABBAbsolute(const Aabb1, Aabb2: TAABB): Boolean;
function PointInAABB(const P: TAffineVector; const Aabb: TAABB) : Boolean; overload;
function PointInAABB(const P: TVector; const Aabb: TAABB): Boolean; overload;
function PlaneIntersectAABB(Normal: TAffineVector; D: Single; Aabb: TAABB): Boolean;
function PlaneAABBIntersection(const plane : THmgPlane; const AABB : TAABB) : TAffineVectorList;

Compute the intersection between a plane and the AABB

function TriangleIntersectAABB(const Aabb: TAABB; const V1, V2, V3: TAffineVector): Boolean;
procedure ExtractAABBCorners(const AABB: TAABB; var AABBCorners: TAABBCorners);
procedure AABBToBSphere(const AABB: TAABB; var BSphere: TBSphere);
procedure BSphereToAABB(const BSphere: TBSphere; var AABB: TAABB); overload;
function BSphereToAABB(const Center: TAffineVector; Radius: Single) : TAABB; overload;
function BSphereToAABB(const Center: TVector; Radius: Single): TAABB; overload;
function AABBContainsAABB(const MainAABB, TestAABB: TAABB): TSpaceContains;
function BSphereContainsAABB(const MainBSphere: TBSphere; const TestAABB: TAABB) : TSpaceContains;
function BSphereContainsBSphere(const MainBSphere, TestBSphere: TBSphere) : TSpaceContains;
function AABBContainsBSphere(const MainAABB: TAABB; const TestBSphere: TBSphere) : TSpaceContains;
function PlaneContainsBSphere(const Location, Normal: TAffineVector; const TestBSphere: TBSphere): TSpaceContains;
function FrustumContainsBSphere(const Frustum: TFrustum; const TestBSphere: TBSphere): TSpaceContains;
function FrustumContainsAABB(const Frustum: TFrustum; const TestAABB: TAABB) : TSpaceContains;
function ClipToAABB(const V: TAffineVector; const AABB: TAABB): TAffineVector;
function BSphereIntersectsBSphere(const MainBSphere, TestBSphere: TBSphere): Boolean;
procedure IncludeInClipRect(var ClipRect: TClipRect; X, Y: Single);
function AABBToClipRect(const Aabb: TAABB; ModelViewProjection: TMatrix; ViewportSizeX, ViewportSizeY: Integer): TClipRect;
function RayCastAABBIntersect(const RayOrigin, RayDirection: TVector; const Aabb: TAABB; out TNear, TFar: Single): Boolean; overload;
function RayCastAABBIntersect(const RayOrigin, RayDirection: TVector; const Aabb: TAABB; IntersectPoint: PVector = nil): Boolean; overload;

Types

PHmgBoundingBox = ˆTHmgBoundingBox;
PAABB = ˆTAABB;
TSpaceContains = (...);
Values
  • ScNoOverlap:
  • ScContainsFully:
  • ScContainsPartially:
TAABBCorners = array [0 .. 7] of TAffineVector;
TPlanIndices = array [0 .. 3] of Integer;
TPlanBB = array [0 .. 5] of TPlanIndices;
TDirPlan = array [0 .. 5] of Integer;

Constants

NullBoundingBox: THmgBoundingBox = (BBox:((X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1), (X: 0; Y: 0; Z: 0; W: 1)));
CBBFront: TPlanIndices = (0, 1, 2, 3);
CBBBack: TPlanIndices = (4, 5, 6, 7);
CBBLeft: TPlanIndices = (0, 4, 7, 3);
CBBRight: TPlanIndices = (1, 5, 6, 2);
CBBTop: TPlanIndices = (0, 1, 5, 4);
CBBBottom: TPlanIndices = (2, 3, 7, 6);
CBBPlans: TPlanBB = ((0, 1, 2, 3), (4, 5, 6, 7), (0, 4, 7, 3), (1, 5, 6, 2), (0, 1, 5, 4), (2, 3, 7, 6));
CDirPlan: TDirPlan = (0, 0, 1, 1, 2, 2);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GeometryBB: record THmgBoundingBox

record THmgBoundingBox

Unit

GeometryBB

Declaration

type THmgBoundingBox = record

Description

Overview

Fields

BBox: array [0 .. 7] of TVector;

Description

Fields

BBox: array [0 .. 7] of TVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GeometryBB: record TAABB

record TAABB

Unit

GeometryBB

Declaration

type TAABB = record

Description

Overview

Fields

Min: TAffineVector;
Max: TAffineVector;

Description

Fields

Min: TAffineVector;
Max: TAffineVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GeometryBB: record TBSphere

record TBSphere

Unit

GeometryBB

Declaration

type TBSphere = record

Description

Overview

Fields

Center: TAffineVector;
Radius: Single;

Description

Fields

Center: TAffineVector;
Radius: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GeometryBB: record TClipRect

record TClipRect

Unit

GeometryBB

Declaration

type TClipRect = record

Description

Overview

Fields

Left: Single;
Top: Single;
Right: Single;
Bottom: Single;

Description

Fields

Left: Single;
Top: Single;
Right: Single;
Bottom: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GeometryCoordinates

Unit GeometryCoordinates

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GeometryCoordinates<p>

Helper functions to convert between different three dimensional coordinate systems. Room for optimisations.<p>

<b>History : </b><font size=-1><ul> <li>30/04/03 - EG - Hyperbolic functions moved to VectorGeometry.pas <li>30/04/03 - ARH - Remove math.pas dependency <li>24/04/03 - ARH - Double versions added <li>10/04/03 - ARH - Added ProlateSpheroidal,OblateSpheroidal, BiPolarCylindrical <li>09/04/03 - ARH - Initial Version (Cylindrical,Spherical) </ul>

Overview

Functions and Procedures

procedure Cylindrical_Cartesian(const r,theta,z1:single;var x,y,z:single); overload;
procedure Cylindrical_Cartesian(const r,theta,z1:double;var x,y,z:double); overload;
procedure Cylindrical_Cartesian(const r,theta,z1:single;var x,y,z:single; var ierr:integer); overload;
procedure Cylindrical_Cartesian(const r,theta,z1:double;var x,y,z:double; var ierr:integer); overload;
procedure Cartesian_Cylindrical(const x,y,z1:single; var r,theta,z:single); overload;
procedure Cartesian_Cylindrical(const x,y,z1:double; var r,theta,z:double); overload;
procedure Spherical_Cartesian(const r,theta,phi:single;var x,y,z:single); overload;
procedure Spherical_Cartesian(const r,theta,phi:double;var x,y,z:double); overload;
procedure Spherical_Cartesian(const r,theta,phi:single;var x,y,z:single; var ierr:integer); overload;
procedure Spherical_Cartesian(const r,theta,phi:double;var x,y,z:double; var ierr:integer); overload;
procedure Cartesian_Spherical(const x,y,z:single; var r,theta,phi:single); overload;
procedure Cartesian_Spherical(const v : TAffineVector; var r, theta, phi : Single); overload;
procedure Cartesian_Spherical(const x,y,z:double; var r,theta,phi:double); overload;
procedure ProlateSpheroidal_Cartesian(const xi,eta,phi,a:single; var x,y,z:single); overload;
procedure ProlateSpheroidal_Cartesian(const xi,eta,phi,a:double; var x,y,z:double); overload;
procedure ProlateSpheroidal_Cartesian(const xi,eta,phi,a:single; var x,y,z:single; var ierr:integer); overload;
procedure ProlateSpheroidal_Cartesian(const xi,eta,phi,a:double; var x,y,z:double; var ierr:integer); overload;
procedure OblateSpheroidal_Cartesian(const xi,eta,phi,a:single; var x,y,z:single); overload;
procedure OblateSpheroidal_Cartesian(const xi,eta,phi,a:double; var x,y,z:double); overload;
procedure OblateSpheroidal_Cartesian(const xi,eta,phi,a:single; var x,y,z:single; var ierr:integer); overload;
procedure OblateSpheroidal_Cartesian(const xi,eta,phi,a:double; var x,y,z:double; var ierr:integer); overload;
procedure BipolarCylindrical_Cartesian(const u,v,z1,a:single; var x,y,z:single); overload;
procedure BipolarCylindrical_Cartesian(const u,v,z1,a:double; var x,y,z:double); overload;
procedure BipolarCylindrical_Cartesian(const u,v,z1,a:single; var x,y,z:single; var ierr:integer); overload;
procedure BipolarCylindrical_Cartesian(const u,v,z1,a:double; var x,y,z:double; var ierr:integer); overload;

Description

Functions and Procedures

procedure Cylindrical_Cartesian(const r,theta,z1:single;var x,y,z:single); overload;

Convert cylindrical to cartesian [single]. theta in rad

procedure Cylindrical_Cartesian(const r,theta,z1:double;var x,y,z:double); overload;

Convert cylindrical to cartesian [double]. theta in rads

procedure Cylindrical_Cartesian(const r,theta,z1:single;var x,y,z:single; var ierr:integer); overload;

Convert cylindrical to cartesian [single] (with error check). theta in rad

procedure Cylindrical_Cartesian(const r,theta,z1:double;var x,y,z:double; var ierr:integer); overload;

Convert cylindrical to cartesian [double] (with error check). theta in rad

procedure Cartesian_Cylindrical(const x,y,z1:single; var r,theta,z:single); overload;

Convert cartesian to cylindrical [single]

procedure Cartesian_Cylindrical(const x,y,z1:double; var r,theta,z:double); overload;

Convert cartesion to cylindrical [double]

procedure Spherical_Cartesian(const r,theta,phi:single;var x,y,z:single); overload;

Convert spherical to cartesion. [single] theta,phi in rads

procedure Spherical_Cartesian(const r,theta,phi:double;var x,y,z:double); overload;

Convert spherical to cartesion. [double] theta,phi in rads

procedure Spherical_Cartesian(const r,theta,phi:single;var x,y,z:single; var ierr:integer); overload;

Convert spherical to cartesian [single] (with error check).theta,phi in rad

procedure Spherical_Cartesian(const r,theta,phi:double;var x,y,z:double; var ierr:integer); overload;

Convert spherical to cartesian [double] (with error check).theta,phi in rad

procedure Cartesian_Spherical(const x,y,z:single; var r,theta,phi:single); overload;

Convert cartesian to spherical [single]

procedure Cartesian_Spherical(const v : TAffineVector; var r, theta, phi : Single); overload;
procedure Cartesian_Spherical(const x,y,z:double; var r,theta,phi:double); overload;

Convert cartesion to spherical [double]

procedure ProlateSpheroidal_Cartesian(const xi,eta,phi,a:single; var x,y,z:single); overload;

Convert Prolate-Spheroidal to Cartesian. [single] eta, phi in rad

procedure ProlateSpheroidal_Cartesian(const xi,eta,phi,a:double; var x,y,z:double); overload;

Convert Prolate-Spheroidal to Cantesian. [double] eta,phi in rad

procedure ProlateSpheroidal_Cartesian(const xi,eta,phi,a:single; var x,y,z:single; var ierr:integer); overload;

Convert Prolate-Spheroidal to Cartesian [single](with error check). eta,phi in rad

procedure ProlateSpheroidal_Cartesian(const xi,eta,phi,a:double; var x,y,z:double; var ierr:integer); overload;

Convert Prolate-Spheroidal to Cartesian [single](with error check). eta,phi in rad

procedure OblateSpheroidal_Cartesian(const xi,eta,phi,a:single; var x,y,z:single); overload;

Convert Oblate-Spheroidal to Cartesian. [Single] eta, phi in rad

procedure OblateSpheroidal_Cartesian(const xi,eta,phi,a:double; var x,y,z:double); overload;

Convert Oblate-Spheroidal to Cartesian. [Double] eta, phi in rad

procedure OblateSpheroidal_Cartesian(const xi,eta,phi,a:single; var x,y,z:single; var ierr:integer); overload;

Convert Oblate-Spheroidal to Cartesian (with error check). eta,phi in rad

procedure OblateSpheroidal_Cartesian(const xi,eta,phi,a:double; var x,y,z:double; var ierr:integer); overload;

Convert Oblate-Spheroidal to Cartesian (with error check).[Double] eta,phi in rad

procedure BipolarCylindrical_Cartesian(const u,v,z1,a:single; var x,y,z:single); overload;

Convert Bipolar to Cartesian. u in rad

procedure BipolarCylindrical_Cartesian(const u,v,z1,a:double; var x,y,z:double); overload;

Convert Bipolar to Cartesian. [Double] u in rad

procedure BipolarCylindrical_Cartesian(const u,v,z1,a:single; var x,y,z:single; var ierr:integer); overload;

Convert Bipolar to Cartesian (with error check). u in rad

procedure BipolarCylindrical_Cartesian(const u,v,z1,a:double; var x,y,z:double; var ierr:integer); overload;

Convert Bipolar to Cartesian (with error check). [Double] u in rad

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAnimatedSprite

Unit GLAnimatedSprite

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLAnimatedSprite<p>

A sprite that uses a scrolling texture for animation.<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>10/04/08 - DaStr - Added a Delpi 5 interface bug work-around to TSpriteAnimation (BugTracker ID = 1938988) <li>25/03/07 - DaStr - Added GLCrossPlatform to uses for Delphi5 compatibility <li>14/03/07 - DaStr - Added IGLMaterialLibrarySupported to TSpriteAnimation Published TGLAnimatedSprite.Visible Fixed TGLAnimatedSprite.SetMaterialLibrary (subcribed for notification) <li>21/07/04 - SG - Added Margins to Animations, Added comments. <li>20/07/04 - SG - Added FrameRate (alternative for Interval), Added Interval to Animations, will override sprite interval if not equal to zero. Some minor fixes. <li>13/07/04 - SG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TSpriteAnimFrame |
Class TSpriteAnimFrameList |
Class TSpriteAnimMargins |
Class TSpriteAnimation |
Class TSpriteAnimationList |
Class TGLAnimatedSprite |

Types

TSpriteFrameDimensions = (...);
TSpriteAnimationMode = (...);

Description

Types

TSpriteFrameDimensions = (...);

Determines if the texture coordinates are Automatically generated from the Animations properties or if they are Manually set through the Frames collection.

Values
  • sfdAuto:
  • sfdManual:
TSpriteAnimationMode = (...);

Sets the current animation playback mode: <ul> <li>samNone - No playback, the animation does not progress. <li>samPlayOnce - Plays the animation once then switches to samNone. <li>samLoop - Play the animation forward in a continuous loop. <li>samLoopBackward - Same as samLoop but reversed direction. <li>samBounceForward - Plays forward and switches to samBounceBackward when EndFrame is reached. <li>samBounceBackward - Plays backward and switches to samBounceForward when StartFrame is reached. </ul>.

Values
  • samNone:
  • samPlayOnce:
  • samLoop:
  • samBounceForward:
  • samBounceBackward:
  • samLoopBackward:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAnimatedSprite: Class TSpriteAnimFrame

Class TSpriteAnimFrame

Unit

GLAnimatedSprite

Declaration

type TSpriteAnimFrame = class(TXCollectionItem)

Description

Used by the SpriteAnimation when Dimensions are set manual. The animation will use the offsets, width and height to determine the texture coodinates for this frame.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TSpriteAnimFrame

Overview

Methods

Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure SetHeight(const Value: Integer);
Protected | procedure SetOffsetX(const Value: Integer);
Protected | procedure SetOffsetY(const Value: Integer);
Protected | procedure SetWidth(const Value: Integer);
Protected | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property Height: Integer read FHeight write SetHeight;
Published | property OffsetX: Integer read FOffsetX write SetOffsetX;
Published | property OffsetY: Integer read FOffsetY write SetOffsetY;
Published | property Width: Integer read FWidth write SetWidth;

Description

Methods

Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure SetHeight(const Value: Integer);
Protected procedure SetOffsetX(const Value: Integer);
Protected procedure SetOffsetY(const Value: Integer);
Protected procedure SetWidth(const Value: Integer);
Protected procedure WriteToFiler(writer: TWriter); override;

Properties

Published property Height: Integer read FHeight write SetHeight;
Published property OffsetX: Integer read FOffsetX write SetOffsetX;
Published property OffsetY: Integer read FOffsetY write SetOffsetY;
Published property Width: Integer read FWidth write SetWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAnimatedSprite: Class TSpriteAnimFrameList

Class TSpriteAnimFrameList

Unit

GLAnimatedSprite

Declaration

type TSpriteAnimFrameList = class(TXCollection)

Description

The XCollection used for the TSpriteAnimFrame object.

Hierarchy

  • TPersistent
  • TXCollection
  • TSpriteAnimFrameList

Overview

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | class function ItemsClass: TXCollectionItemClass; override;

Description

Methods

Public constructor Create(aOwner: TPersistent); override;
Public class function ItemsClass: TXCollectionItemClass; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAnimatedSprite: Class TSpriteAnimMargins

Class TSpriteAnimMargins

Unit

GLAnimatedSprite

Declaration

type TSpriteAnimMargins = class(TPersistent)

Description

Used to mask the auto generated frames. The Left, Top, Right and Bottom properties determines the number of pixels to be cropped from each corresponding side of the frame. Only applicable to auto dimensions.

Hierarchy

  • TPersistent
  • TSpriteAnimMargins

Overview

Methods

Public | constructor Create(Animation: TSpriteAnimation);
Protected | procedure DoChanged;
Protected | procedure SetBottom(const Value: Integer);
Protected | procedure SetLeft(const Value: Integer);
Protected | procedure SetRight(const Value: Integer);
Protected | procedure SetTop(const Value: Integer);

Properties

Published | property Bottom: Integer read FBottom write SetBottom;
Published | property Left: Integer read FLeft write SetLeft;
Public | property Owner: TSpriteAnimation read FOwner;
Published | property Right: Integer read FRight write SetRight;
Published | property Top: Integer read FTop write SetTop;

Description

Methods

Public constructor Create(Animation: TSpriteAnimation);
Protected procedure DoChanged;
Protected procedure SetBottom(const Value: Integer);
Protected procedure SetLeft(const Value: Integer);
Protected procedure SetRight(const Value: Integer);
Protected procedure SetTop(const Value: Integer);

Properties

Published property Bottom: Integer read FBottom write SetBottom;
Published property Left: Integer read FLeft write SetLeft;
Public property Owner: TSpriteAnimation read FOwner;
Published property Right: Integer read FRight write SetRight;
Published property Top: Integer read FTop write SetTop;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAnimatedSprite: Class TSpriteAnimation

Class TSpriteAnimation

Unit

GLAnimatedSprite

Declaration

type TSpriteAnimation = class(TXCollectionItem, IGLMaterialLibrarySupported)

Description

Animations define how the texture coordinates for each offset are to be determined.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TSpriteAnimation

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Protected | function GetFrameRate: Single;
Protected | function GetLibMaterialCached: TGLLibMaterial;
Protected | function GetMaterialLibrary: TGLAbstractMaterialLibrary; virtual;
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure SetCurrentFrame(const Value: Integer);
Protected | procedure SetDimensions(const Value: TSpriteFrameDimensions);
Protected | procedure SetFrameHeight(const Value: Integer);
Protected | procedure SetFrameRate(const Value: Single);
Protected | procedure SetFrameWidth(const Value: Integer);
Protected | procedure SetInterval(const Value: Integer);
Protected | procedure SetLibMaterialName(const val: TGLLibMaterialName);
Protected | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property CurrentFrame: Integer read FCurrentFrame write SetCurrentFrame;
Published | property Dimensions: TSpriteFrameDimensions read FDimensions write SetDimensions;
Published | property EndFrame: Integer read FEndFrame write FEndFrame;
Published | property FrameHeight: Integer read FFrameHeight write SetFrameHeight;
Published | property FrameRate: Single read GetFrameRate write SetFrameRate;
Published | property Frames: TSpriteAnimFrameList read FFrames;
Published | property FrameWidth: Integer read FFrameWidth write SetFrameWidth;
Published | property Interval: Integer read FInterval write SetInterval;
Public | property LibMaterialCached: TGLLibMaterial read GetLibMaterialCached;
Published | property LibMaterialName: TGLLibMaterialName read FLibMaterialName write SetLibMaterialName;
Published | property Margins: TSpriteAnimMargins read FMargins;
Published | property StartFrame: Integer read FStartFrame write FStartFrame;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Protected function GetFrameRate: Single;
Protected function GetLibMaterialCached: TGLLibMaterial;
Protected function GetMaterialLibrary: TGLAbstractMaterialLibrary; virtual;
Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure SetCurrentFrame(const Value: Integer);
Protected procedure SetDimensions(const Value: TSpriteFrameDimensions);
Protected procedure SetFrameHeight(const Value: Integer);
Protected procedure SetFrameRate(const Value: Single);
Protected procedure SetFrameWidth(const Value: Integer);
Protected procedure SetInterval(const Value: Integer);
Protected procedure SetLibMaterialName(const val: TGLLibMaterialName);
Protected procedure WriteToFiler(writer: TWriter); override;

Properties

Published property CurrentFrame: Integer read FCurrentFrame write SetCurrentFrame;

The current showing frame for this animation.

Published property Dimensions: TSpriteFrameDimensions read FDimensions write SetDimensions;

Automatic or manual texture coordinate generation.

Published property EndFrame: Integer read FEndFrame write FEndFrame;

Defines the ending frame for auto dimension animations.

Published property FrameHeight: Integer read FFrameHeight write SetFrameHeight;

Height of each frame in an auto dimension animation.

Published property FrameRate: Single read GetFrameRate write SetFrameRate;

The number of frames per second for the animation. Will automatically calculate the Interval value when set. Precision will depend on Interval since Interval has priority.

Published property Frames: TSpriteAnimFrameList read FFrames;

Manual dimension animation frames. Stores the offsets and dimensions for each frame in the animation.

Published property FrameWidth: Integer read FFrameWidth write SetFrameWidth;

Width of each frame in an auto dimension animation.

Published property Interval: Integer read FInterval write SetInterval;

The number of milliseconds between each frame in the animation. Will automatically calculate the FrameRate value when set. Will override the TGLAnimatedSprite Interval is greater than zero.

Public property LibMaterialCached: TGLLibMaterial read GetLibMaterialCached;
Published property LibMaterialName: TGLLibMaterialName read FLibMaterialName write SetLibMaterialName;

The name of the lib material the sprites associated material library for this animation.

Published property Margins: TSpriteAnimMargins read FMargins;

Sets cropping margins for auto dimension animations.

Published property StartFrame: Integer read FStartFrame write FStartFrame;

Defines the starting frame for auto dimension animations.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAnimatedSprite: Class TSpriteAnimationList

Class TSpriteAnimationList

Unit

GLAnimatedSprite

Declaration

type TSpriteAnimationList = class(TXCollection)

Description

A collection for storing TSpriteAnimation objects.

Hierarchy

  • TPersistent
  • TXCollection
  • TSpriteAnimationList

Overview

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | class function ItemsClass: TXCollectionItemClass; override;

Description

Methods

Public constructor Create(aOwner: TPersistent); override;
Public class function ItemsClass: TXCollectionItemClass; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAnimatedSprite: Class TGLAnimatedSprite

Class TGLAnimatedSprite

Unit

GLAnimatedSprite

Declaration

type TGLAnimatedSprite = class(TGLBaseSceneObject)

Description

An animated version of the TGLSprite using offset texture coordinate animation.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLAnimatedSprite

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function GetFrameRate: Single;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Public | procedure NextFrame;
Protected | procedure DefineProperties(Filer: TFiler); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure ReadAnimations(Stream: TStream);
Protected | procedure SetAnimationIndex(const val: Integer);
Protected | procedure SetAnimationMode(const val: TSpriteAnimationMode);
Protected | procedure SetFrameRate(const Value: Single);
Protected | procedure SetInterval(const val: Integer);
Protected | procedure SetMaterialLibrary(const val: TGLMaterialLibrary);
Protected | procedure SetMirrorU(const val: Boolean);
Protected | procedure SetMirrorV(const val: Boolean);
Protected | procedure SetPixelRatio(const val: Integer);
Protected | procedure SetRotation(const val: Integer);
Protected | procedure WriteAnimations(Stream: TStream);

Properties

Published | property AnimationIndex: Integer read FAnimationIndex write SetAnimationIndex;
Published | property AnimationMode: TSpriteAnimationMode read FAnimationMode write SetAnimationMode;
Published | property Animations: TSpriteAnimationList read FAnimations;
Published | property FrameRate: Single read GetFrameRate write SetFrameRate;
Published | property Interval: Integer read FInterval write SetInterval;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MirrorU: Boolean read FMirrorU write SetMirrorU;
Published | property MirrorV: Boolean read FMirrorV write SetMirrorV;
Published | property OnEndFrameReached: TNotifyEvent read FOnEndFrameReached write FOnEndFrameReached;
Published | property OnFrameChanged: TNotifyEvent read FOnFrameChanged write FOnFrameChanged;
Published | property OnStartFrameReached: TNotifyEvent read FOnStartFrameReached write FOnStartFrameReached;
Published | property PixelRatio: Integer read FPixelRatio write SetPixelRatio;
Published | property Position;
Published | property Rotation: Integer read FRotation write SetRotation;
Published | property Scale;
Published | property Visible;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function GetFrameRate: Single;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Public procedure NextFrame;

Steps the current animation to the next frame

Protected procedure DefineProperties(Filer: TFiler); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure ReadAnimations(Stream: TStream);
Protected procedure SetAnimationIndex(const val: Integer);
Protected procedure SetAnimationMode(const val: TSpriteAnimationMode);
Protected procedure SetFrameRate(const Value: Single);
Protected procedure SetInterval(const val: Integer);
Protected procedure SetMaterialLibrary(const val: TGLMaterialLibrary);
Protected procedure SetMirrorU(const val: Boolean);
Protected procedure SetMirrorV(const val: Boolean);
Protected procedure SetPixelRatio(const val: Integer);
Protected procedure SetRotation(const val: Integer);
Protected procedure WriteAnimations(Stream: TStream);

Properties

Published property AnimationIndex: Integer read FAnimationIndex write SetAnimationIndex;

Index of the sprite animation to be used.

Published property AnimationMode: TSpriteAnimationMode read FAnimationMode write SetAnimationMode;

Playback mode for the current animation.

Published property Animations: TSpriteAnimationList read FAnimations;

A collection of animations. Stores the settings for animating then sprite.

Published property FrameRate: Single read GetFrameRate write SetFrameRate;

Sets the frames per second for the current animation. Automatically calculates the Interval. Precision will be restricted to the values of Interval since Interval takes priority.

Published property Interval: Integer read FInterval write SetInterval;

Sets the number of milliseconds between each frame. Will recalculate the Framerate when set. Will be overridden by the TSpriteAnimation Interval if it is greater than zero.

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

The material library that stores the lib materials for the animations.

Published property MirrorU: Boolean read FMirrorU write SetMirrorU;

Mirror the generated texture coords in the U axis.

Published property MirrorV: Boolean read FMirrorV write SetMirrorV;

Mirror the generated texture coords in the V axis.

Published property OnEndFrameReached: TNotifyEvent read FOnEndFrameReached write FOnEndFrameReached;

An event fired when the animation reaches the end frame.

Published property OnFrameChanged: TNotifyEvent read FOnFrameChanged write FOnFrameChanged;

An event fired when the animation changes to it's next frame.

Published property OnStartFrameReached: TNotifyEvent read FOnStartFrameReached write FOnStartFrameReached;

An event fired when the animation reaches the start frame.

Published property PixelRatio: Integer read FPixelRatio write SetPixelRatio;

Used to automatically calculate the width and height of a sprite based on the size of the frame it is showing. For example, if PixelRatio is set to 100 and the current animation frame is 100 pixels wide it will set the width of the sprite to 1. If the frame is 50 pixels widtdh the sprite will be 0.5 wide.

Published property Position;
Published property Rotation: Integer read FRotation write SetRotation;

Rotates the sprite (in degrees).

Published property Scale;
Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAsmShader

Unit GLAsmShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLAsmShader<p>

TGLAsmShader is a wrapper for all ARB shaders<p> This component is only a template and has to be replaced with a proper version by someone who uses ARB shaders more then me.

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Upgraded program hadles <li>04/06/10 - Yar - Replace OpenGL functons to OpenGLAdapter <li>28/07/09 - DaStr - Added GeomertyShader support (thanks YarUnderoaker) <li>24/07/09 - DaStr - TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) <li>20/03/07 - DaStr - TGLCustomAsmShader now generates its own events All outside stuff moved back to TGLPhongShader <li>22/02/07 - DaStr - Initial version (contributed to GLScene)

Previous version history: v1.0 12 March '2005 Creation v1.1 31 October '2006 TGLCustomAsmShader.DoUnApply() Fix TGLAsmShader has more stuff in the published section

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLAsmShaderParameter |
Class TGLCustomAsmShader |
Class TGLAsmShader |

Types

TGLAsmShaderEvent = procedure(Shader: TGLCustomAsmShader) of object;
TGLAsmShaderUnUplyEvent = procedure(Shader: TGLCustomAsmShader; var ThereAreMorePasses: Boolean) of object;

Description

Types

TGLAsmShaderEvent = procedure(Shader: TGLCustomAsmShader) of object;
TGLAsmShaderUnUplyEvent = procedure(Shader: TGLCustomAsmShader; var ThereAreMorePasses: Boolean) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAsmShader: Class TGLAsmShaderParameter

Class TGLAsmShaderParameter

Unit

GLAsmShader

Declaration

type TGLAsmShaderParameter = class(TGLCustomShaderParameter)

Description

no description available, TGLCustomShaderParameter description follows

Wrapper around a parameter of the main program.

Hierarchy

  • TObject
  • TGLCustomShaderParameter
  • TGLAsmShaderParameter
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAsmShader: Class TGLCustomAsmShader

Class TGLCustomAsmShader

Unit

GLAsmShader

Declaration

type TGLCustomAsmShader = class(TGLCustomShader)

Description

no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomAsmShader

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ShaderSupported: Boolean; override;
Protected | function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure ApplyShaderPrograms;
Protected | procedure DestroyARBPrograms; virtual;
Protected | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected | procedure DoFinalize; override;
Protected | procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;
Protected | procedure UnApplyShaderPrograms;

Properties

Protected | property OnApply: TGLAsmShaderEvent read FOnApply write FOnApply;
Protected | property OnInitialize: TGLAsmShaderEvent read FOnInitialize write FOnInitialize;
Protected | property OnUnApply: TGLAsmShaderUnUplyEvent read FOnUnApply write FOnUnApply;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function ShaderSupported: Boolean; override;
Protected function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Public procedure Assign(Source: TPersistent); override;
Protected procedure ApplyShaderPrograms;
Protected procedure DestroyARBPrograms; virtual;
Protected procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected procedure DoFinalize; override;
Protected procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;
Protected procedure UnApplyShaderPrograms;

Properties

Protected property OnApply: TGLAsmShaderEvent read FOnApply write FOnApply;
Protected property OnInitialize: TGLAsmShaderEvent read FOnInitialize write FOnInitialize;
Protected property OnUnApply: TGLAsmShaderUnUplyEvent read FOnUnApply write FOnUnApply;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAsmShader: Class TGLAsmShader

Class TGLAsmShader

Unit

GLAsmShader

Declaration

type TGLAsmShader = class(TGLCustomAsmShader)

Description

no description available, TGLCustomAsmShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomAsmShader
  • TGLAsmShader

Overview

Properties

Published | property FailedInitAction;
Published | property FragmentProgram;
Published | property GeometryProgram;
Published | property OnApply;
Published | property OnInitialize;
Published | property OnUnApply;
Published | property ShaderStyle;
Published | property VertexProgram;

Description

Properties

Published property FailedInitAction;
Published property FragmentProgram;
Published property GeometryProgram;
Published property OnApply;
Published property OnInitialize;
Published property OnUnApply;
Published property ShaderStyle;
Published property VertexProgram;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAsyncHDS

Unit GLAsyncHDS

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLAsyncHDS<p>

Implements a HDS Filter that generates HeightData tiles in a seperate thread.<p>

This component is a THeightDataSourceFilter, which uses a THeightDataSourceThread, to asyncronously search the HeightData cache for any queued tiles. When found, it then prepares the queued tile in its own THeightDataThread.

This allows the GUI to remain responsive, and prevents freezes when new tiles are being prepared. Although this keeps the framerate up, it may cause holes in the terrain to show, if the HeightDataThreads cant keep up with the TerrainRenderer's requests for new tiles. <p>

<b>History : </b><font size=-1><ul> <li>22/04/10 - Yar - Fixes after GLState revision <li>11/10/07 - DaStr - Added $I GLScene.inc, removed unused dependancy <li>25/03/07 - DaStr - Replaced Dialogs with GLCrossPlatform for Delphi5 compatibility <li>22/03/07 - LIN - Added UseDirtyTiles property - Specifies how dirty tiles are replaced. <li>22/03/07 - LIN - Data is now prepared in 3 stages: BeforePreparingData : (Main Thread) PreparingData : (Sub-Thread) (Main Thread if MaxThreads=0) AfterPreparingData : (Main Thread) <li>05/03/07 - LIN - Added ThreadCount and WaitFor <li>12/02/07 - LIN - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLAsyncHDS |
Class TGLAsyncHDThread |

Types

TIdleEvent = procedure(Sender:TGLAsyncHDS;TilesUpdated:boolean) of object;
TNewTilePreparedEvent = procedure (Sender : TGLAsyncHDS; heightData : THeightData) of object;
TUseDirtyTiles = (...);

Description

Types

TIdleEvent = procedure(Sender:TGLAsyncHDS;TilesUpdated:boolean) of object;
TNewTilePreparedEvent = procedure (Sender : TGLAsyncHDS; heightData : THeightData) of object;
TUseDirtyTiles = (...);

TUseDirtyTiles determines if/how dirty tiles are displayed and when they are released. <ul> <li>TUseDirtyTiles <li> <li> When a tile is maked as dirty, a replacement is queued immediately. <li> However, the replacement cant be used until the HDThread has finished preparing it. <li> Dirty tiles can be deleted as soon as they are no longer used/displayed.

Possible states for a TUseDirtyTiles.<p> <li>hdsNever : Dirty tiles get released immediately, leaving a hole in the terrain, until the replacement is hdsReady. <li>hdsUntilReplaced : Dirty tiles are used, until the HDThread has finished preparing the queued replacement. <li>hdsUntilAllReplaced : Waits until the HDSThread has finished preparing ALL queued tiles, <li> before allowing the renderer to switch over to the new set of tiles. <li> (This prevents a fading checkerbox effect.) </ul>

Values
  • dtNever:
  • dtUntilReplaced:
  • dtUntilAllReplaced:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAsyncHDS: Class TGLAsyncHDS

Class TGLAsyncHDS

Unit

GLAsyncHDS

Declaration

type TGLAsyncHDS = class(THeightDataSourceFilter)

Description

no description available, THeightDataSourceFilter description follows
no description available, THeightDataSource description follows

Hierarchy

  • TComponent
  • THeightDataSource
  • THeightDataSourceFilter
  • TGLAsyncHDS

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ThreadCount:integer;
Public | function TilesUpdated:boolean;
Public | procedure BeforePreparingData(heightData : THeightData); override;
Public | procedure NewTilePrepared(heightData:THeightData);
Public | procedure StartPreparingData(heightData : THeightData); override;
Public | procedure ThreadIsIdle; override;
Public | procedure TilesUpdatedFlagReset;
Public | procedure WaitFor(TimeOut:integer=2000);

Properties

Published | property Active;
Published | property MaxThreads;
Published | property OnIdle : TIdleEvent read FOnIdleEvent write FOnIdleEvent;
Published | property OnNewTilePrepared : TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;
Published | property UseDirtyTiles : TUseDirtyTiles read FUseDirtyTiles write FUseDirtyTiles;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function ThreadCount:integer;
Public function TilesUpdated:boolean;
Public procedure BeforePreparingData(heightData : THeightData); override;
Public procedure NewTilePrepared(heightData:THeightData);
Public procedure StartPreparingData(heightData : THeightData); override;
Public procedure ThreadIsIdle; override;
Public procedure TilesUpdatedFlagReset;
Public procedure WaitFor(TimeOut:integer=2000);

Properties

Published property Active;
Published property MaxThreads;
Published property OnIdle : TIdleEvent read FOnIdleEvent write FOnIdleEvent;
Published property OnNewTilePrepared : TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;
Published property UseDirtyTiles : TUseDirtyTiles read FUseDirtyTiles write FUseDirtyTiles;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAsyncHDS: Class TGLAsyncHDThread

Class TGLAsyncHDThread

Unit

GLAsyncHDS

Declaration

type TGLAsyncHDThread = class(THeightDataThread)

Description

no description available, THeightDataThread description follows

Hierarchy

  • TThread
  • THeightDataThread
  • TGLAsyncHDThread

Overview

Fields

Public | Owner: TGLAsyncHDS;
Public | HDS: THeightDataSource;

Methods

Public | Procedure Execute; override;
Public | Procedure Sync;

Description

Fields

Public Owner: TGLAsyncHDS;
Public HDS: THeightDataSource;

Methods

Public Procedure Execute; override;
Public Procedure Sync;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAtmosphere

Unit GLAtmosphere

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLAtmosphere <p>

This unit contains classes that imitate an atmosphere around a planet.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>19/03/11 - Yar - Added setters for Low and High atmosphere colors <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>03/04/07 - DaStr - Optimized TGLCustomAtmosphere.DoRender Fixed SetPlanetRadius and SetAtmosphereRadius <li>21/03/07 - DaStr - Cleaned up "uses" section (thanks Burkhard Carstens) (Bugtracker ID = 1684432) <li>01/03/07 - DaStr - Fixed TGLAtmosphereBlendingMode (old version did not generate RTTI) Added default values to all properties <li>15/02/07 - DaStr - Added TGLCustomAtmosphere.AxisAlignedDimensionsUnscaled <li>07/02/07 - DaStr - Initial version (donated to GLScene)

Comments: 1) Eats a lot of CPU (reduces FPS from 1240 to 520 on my PC with cSlices=100) 2) Alpha in LowAtmColor, HighAtmColor is ignored.

Previous version history: v1.0 06 February '2005 Creation (based on demo "Earth" by Eric Grange) v1.1 28 February '2005 Don't remmember what... v1.2 16 March '2005 Small improvements, including ability to load files using short (not full) paths v1.3 21 March '2005 Positioning bugfix!!! v1.4 3 October '2005 Camera parameter no longer needed "Enabled" is now a property LoadFromMemory added SaveToFile, SaveToMemory added Normal error message v1.5 4 November '2005 BlendingMode1,2 added TogleBlengindMode added LoadFromMemory bugfix v1.6 28 February '2006 Became a standard GLScene object, child of TglBaseSceneObject Range bug fixed, along with a bug, the caused Atmosphere to draw itseft incorrectly on some occasions Demo inhanced New Load/Save code v1.6.2 05 June '2006 Assign() added Alpha in LowAtmColor, HighAtmColor was removed from Loading/saving code v1.6.4 07 July '2006 All variables in the class converted into properties TStrangeCustomAtmosphere added v1.6.6 08 October '2006 Made compatible with the new persistance mechanism v1.7 22 October '2006 Notification() and SetSun() added v1.8 08 February '2007 TStrangeCustomAtmosphere.Assign fixed Blending mode Integer —> Enumeration Donated to GLScene

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLAtmosphereException |
Class TGLCustomAtmosphere |
Class TGLAtmosphere |

Types

TGLAtmosphereBlendingMode = (...);

Description

Types

TGLAtmosphereBlendingMode = (...);

With aabmOneMinusSrcAlpha atmosphere is transparent to other objects, but has problems, which are best seen when the Atmosphere radius is big.

With bmOneMinusDstColor atmosphere doesn't have these problems, but offers limited transparency (when you look closely on the side).

Values
  • abmOneMinusDstColor:
  • abmOneMinusSrcAlpha:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAtmosphere: Class EGLAtmosphereException

Class EGLAtmosphereException

Unit

GLAtmosphere

Declaration

type EGLAtmosphereException = class(Exception)

Description

Hierarchy

  • Exception
  • EGLAtmosphereException
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:09


GLScene v.1.1.2: GLAtmosphere: Class TGLCustomAtmosphere

Class TGLCustomAtmosphere

Unit

GLAtmosphere

Declaration

type TGLCustomAtmosphere = class(TGLBaseSceneObject)

Description

This class imitates an atmosphere around a planet.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomAtmosphere

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled : TVector; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure SetOptimalAtmosphere(const ARadius: Single);
Public | procedure SetOptimalAtmosphere2(const ARadius: Single);
Public | procedure TogleBlendingMode;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Public | property AtmosphereRadius: Single read FAtmosphereRadius write SetAtmosphereRadius stored StoreAtmosphereRadius;
Public | property BlendingMode: TGLAtmosphereBlendingMode read FBlendingMode write FBlendingMode default abmOneMinusSrcAlpha;
Public | property HighAtmColor: TGLColor read FHighAtmColor write SetHighAtmColor stored StoreHighAtmColor;
Public | property LowAtmColor: TGLColor read FLowAtmColor write SetLowAtmColor stored StoreLowAtmColor;
Public | property Opacity: Single read FOpacity write FOpacity stored StoreOpacity;
Public | property PlanetRadius: Single read FPlanetRadius write SetPlanetRadius stored StorePlanetRadius;
Public | property Slices: Integer read FSlices write SetSlices default 60;
Public | property Sun: TglBaseSceneObject read FSun write SetSun;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensionsUnscaled : TVector; override;

Used to determine extents.

Public procedure Assign(Source: TPersistent); override;

Standard component stuff.

Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Main rendering procedure.

Public procedure SetOptimalAtmosphere(const ARadius: Single);
Public procedure SetOptimalAtmosphere2(const ARadius: Single);
Public procedure TogleBlendingMode;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Public property AtmosphereRadius: Single read FAtmosphereRadius write SetAtmosphereRadius stored StoreAtmosphereRadius;

AtmosphereRadius > PlanetRadius!!!

Public property BlendingMode: TGLAtmosphereBlendingMode read FBlendingMode write FBlendingMode default abmOneMinusSrcAlpha;
Public property HighAtmColor: TGLColor read FHighAtmColor write SetHighAtmColor stored StoreHighAtmColor;
Public property LowAtmColor: TGLColor read FLowAtmColor write SetLowAtmColor stored StoreLowAtmColor;

Use value slightly lower than actual radius, for antialiasing effect.

Public property Opacity: Single read FOpacity write FOpacity stored StoreOpacity;
Public property PlanetRadius: Single read FPlanetRadius write SetPlanetRadius stored StorePlanetRadius;
Public property Slices: Integer read FSlices write SetSlices default 60;
Public property Sun: TglBaseSceneObject read FSun write SetSun;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLAtmosphere: Class TGLAtmosphere

Class TGLAtmosphere

Unit

GLAtmosphere

Declaration

type TGLAtmosphere = class(TGLCustomAtmosphere)

Description

no description available, TGLCustomAtmosphere description follows

This class imitates an atmosphere around a planet.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomAtmosphere
  • TGLAtmosphere

Overview

Properties

Published | property AtmosphereRadius;
Published | property Behaviours;
Published | property BlendingMode;
Published | property Effects;
Published | property HighAtmColor;
Published | property LowAtmColor;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property Opacity;
Published | property PlanetRadius;
Published | property Position;
Published | property ShowAxes;
Published | property Slices;
Published | property Sun;
Published | property Visible;

Description

Properties

Published property AtmosphereRadius;
Published property Behaviours;
Published property BlendingMode;
Published property Effects;
Published property HighAtmColor;
Published property LowAtmColor;
Published property ObjectsSorting;
Published property OnProgress;
Published property Opacity;
Published property PlanetRadius;
Published property Position;
Published property ShowAxes;
Published property Slices;
Published property Sun;
Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLAVIRecorder

Unit GLAVIRecorder

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLAVIRecorder<p>

Component to make it easy to record GLScene frames into an AVI file<p>

<b>History : </b><font size=-1><ul> <li>12/07/07 - DaStr - Improved Cross-Platform compatibility (Bugtracker ID = 1684432) <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTracekrID=1681585) <li>29/01/07 - DaStr - Moved registration to GLSceneRegister.pas <li>01/06/05 - NelC - Replaced property GLFullScreenViewer with GLNonVisualViewer <li>26/01/05 - JAJ - Can now operate with a GLFullScreenViewer <li>22/10/04 - EG - Can now operate without a SceneViewer <li>13/05/04 - EG - Added irmBitBlt mode (now the default mode) <li>05/01/04 - EG - Added Recording function and ability to record arbitrary bitmap, Added OnPostProcessEvent <li>08/07/03 - NelC - Fixed access violation on exit (thx Solerman Kaplon) and minor updates <li>11/12/01 - EG - Minor changes for compatibility with JEDI VfW.pas <li<02/03/01 - EG - Added TAVIImageRetrievalMode <li>24/02/01 - NelC - Creation and initial code </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TAVIRecorder |

Types

TAVICompressor = (...);
PAVIStream = ˆIAVIStream;
TAVISizeRestriction = (...);
TAVIRecorderState = (...);
TAVIImageRetrievalMode = (...);
TAVIRecorderPostProcessEvent = procedure (Sender : TObject; frame : TBitmap) of object;

Description

Types

TAVICompressor = (...);
Values
  • acDefault:
  • acShowDialog:
  • acDivX:
PAVIStream = ˆIAVIStream;
TAVISizeRestriction = (...);

Frame size restriction.<p> Forces frame dimensions to be a multiple of 2, 4, or 8. Some compressors require this. e.g. DivX 5.2.1 requires mutiples of 2.

Values
  • srNoRestriction:
  • srForceBlock2x2:
  • srForceBlock4x4:
  • srForceBlock8x8:
TAVIRecorderState = (...);
Values
  • rsNone:
  • rsRecording:
TAVIImageRetrievalMode = (...);

Image retrieval mode for frame capture.<p> Following modes are supported:<p> <li>irmSnapShot : retrieve OpenGL framebuffer content using glReadPixels <li>irmRenderToBitmap : renders the whole scene to a bitmap, this is the slowest mode, but it won't be affected by driver-side specifics. <li>irmBitBlt : tranfers the framebuffer using the BitBlt function, usually the fastest solution </ul>

Values
  • irmSnapShot:
  • irmRenderToBitmap:
  • irmBitBlt:
TAVIRecorderPostProcessEvent = procedure (Sender : TObject; frame : TBitmap) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLAVIRecorder: Class TAVIRecorder

Class TAVIRecorder

Unit

GLAVIRecorder

Declaration

type TAVIRecorder = class(TComponent)

Description

Component to make it easy to record GLScene frames into an AVI file.

Hierarchy

  • TComponent
  • TAVIRecorder

Overview

Fields

Protected | FGLSceneViewer: TGLSceneViewer;
Protected | FGLNonVisualViewer: TGLNonVisualViewer;
Protected | FCompressor: TAVICompressor;

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Public | function CreateAVIFile(DPI : integer = 0) : boolean;
Public | function Recording : Boolean;
Protected | function Restricted(s:integer):integer;
Public | procedure AddAVIFrame(bmp : TBitmap); overload;
Public | procedure AddAVIFrame; overload;
Public | procedure CloseAVIFile(UserAbort : boolean = false);
Protected | procedure InternalAddAVIFrame;

Properties

Published | property Compressor : TAVICompressor read FCompressor write FCompressor default acDefault;
Published | property Filename : String read FAVIFilename write FAVIFilename;
Published | property FPS : byte read FFPS write FFPS default 25;
Published | property GLNonVisualViewer : TGLNonVisualViewer read FGLNonVisualViewer write SetGLNonVisualViewer;
Published | property GLSceneViewer : TGLSceneViewer read FGLSceneViewer write SetGLSceneViewer;
Published | property Height : integer read FHeight write SetHeight;
Published | property ImageRetrievalMode : TAVIImageRetrievalMode read FImageRetrievalMode write FImageRetrievalMode default irmBitBlt;
Published | property OnPostProcessEvent : TAVIRecorderPostProcessEvent read FOnPostProcessEvent write FOnPostProcessEvent;
Published | property SizeRestriction : TAVISizeRestriction read FSizeRestriction write SetSizeRestriction default srForceBlock8x8;
Published | property Width : integer read FWidth write SetWidth;

Description

Fields

Protected FGLSceneViewer: TGLSceneViewer;
Protected FGLNonVisualViewer: TGLNonVisualViewer;
Protected FCompressor: TAVICompressor;

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Public function CreateAVIFile(DPI : integer = 0) : boolean;
Public function Recording : Boolean;
Protected function Restricted(s:integer):integer;
Public procedure AddAVIFrame(bmp : TBitmap); overload;
Public procedure AddAVIFrame; overload;
Public procedure CloseAVIFile(UserAbort : boolean = false);
Protected procedure InternalAddAVIFrame;

Properties

Published property Compressor : TAVICompressor read FCompressor write FCompressor default acDefault;
Published property Filename : String read FAVIFilename write FAVIFilename;
Published property FPS : byte read FFPS write FFPS default 25;
Published property GLNonVisualViewer : TGLNonVisualViewer read FGLNonVisualViewer write SetGLNonVisualViewer;
Published property GLSceneViewer : TGLSceneViewer read FGLSceneViewer write SetGLSceneViewer;
Published property Height : integer read FHeight write SetHeight;
Published property ImageRetrievalMode : TAVIImageRetrievalMode read FImageRetrievalMode write FImageRetrievalMode default irmBitBlt;
Published property OnPostProcessEvent : TAVIRecorderPostProcessEvent read FOnPostProcessEvent write FOnPostProcessEvent;
Published property SizeRestriction : TAVISizeRestriction read FSizeRestriction write SetSizeRestriction default srForceBlock8x8;
Published property Width : integer read FWidth write SetWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBaseMeshSilhouette

Unit GLBaseMeshSilhouette

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TFaceGroupConnectivity |
Class TGLBaseMeshConnectivity |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBaseMeshSilhouette: Class TFaceGroupConnectivity

Class TFaceGroupConnectivity

Unit

GLBaseMeshSilhouette

Declaration

type TFaceGroupConnectivity = class(TConnectivity)

Description

no description available, TConnectivity description follows
no description available, TBaseConnectivity description follows

Hierarchy

  • TObject
  • TBaseConnectivity
  • TConnectivity
  • TFaceGroupConnectivity

Overview

Methods

Public | constructor Create(APrecomputeFaceNormal: boolean); override;
Public | constructor CreateFromMesh(aMeshObject: TMeshObject; APrecomputeFaceNormal: boolean);
Public | destructor Destroy; override;
Public | procedure Clear; override;
Public | procedure RebuildEdgeList;

Properties

Public property MeshObject: TMeshObject read FMeshObject write SetMeshObject;

Description

Methods

Public constructor Create(APrecomputeFaceNormal: boolean); override;
Public constructor CreateFromMesh(aMeshObject: TMeshObject; APrecomputeFaceNormal: boolean);
Public destructor Destroy; override;
Public procedure Clear; override;
Public procedure RebuildEdgeList;

Properties

Public property MeshObject: TMeshObject read FMeshObject write SetMeshObject;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBaseMeshSilhouette: Class TGLBaseMeshConnectivity

Class TGLBaseMeshConnectivity

Unit

GLBaseMeshSilhouette

Declaration

type TGLBaseMeshConnectivity = class(TBaseConnectivity)

Description

no description available, TBaseConnectivity description follows

Hierarchy

  • TObject
  • TBaseConnectivity
  • TGLBaseMeshConnectivity

Overview

Methods

Public | constructor Create(APrecomputeFaceNormal: boolean); override;
Public | constructor CreateFromMesh(aGLBaseMesh: TGLBaseMesh);
Public | destructor Destroy; override;
Protected | function GetEdgeCount: integer; override;
Protected | function GetFaceCount: integer; override;
Public | procedure Clear(SaveFaceGroupConnectivity: boolean);
Public | procedure CreateSilhouette(const silhouetteParameters: TGLSilhouetteParameters; var aSilhouette: TGLSilhouette; AddToSilhouette: boolean); override;
Public | procedure RebuildEdgeList;

Properties

Public | property ConnectivityCount: integer read GetConnectivityCount;
Public | property FaceGroupConnectivity[i: integer]: TFaceGroupConnectivity read GetFaceGroupConnectivity;
Public | property GLBaseMesh: TGLBaseMesh read FGLBaseMesh write SetGLBaseMesh;

Description

Methods

Public constructor Create(APrecomputeFaceNormal: boolean); override;
Public constructor CreateFromMesh(aGLBaseMesh: TGLBaseMesh);
Public destructor Destroy; override;
Protected function GetEdgeCount: integer; override;
Protected function GetFaceCount: integer; override;
Public procedure Clear(SaveFaceGroupConnectivity: boolean);
Public procedure CreateSilhouette(const silhouetteParameters: TGLSilhouetteParameters; var aSilhouette: TGLSilhouette; AddToSilhouette: boolean); override;
Public procedure RebuildEdgeList;

Properties

Public property ConnectivityCount: integer read GetConnectivityCount;
Public property FaceGroupConnectivity[i: integer]: TFaceGroupConnectivity read GetFaceGroupConnectivity;
Public property GLBaseMesh: TGLBaseMesh read FGLBaseMesh write SetGLBaseMesh;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBehaviours

Unit GLBehaviours

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLBehaviours<p>

Standard TGLBehaviour subclasses for GLScene<p>

<b>History : </b><font size=-1><ul> <li>08/05/08 - DaStr - Added a global GetInertia() function <li>19/12/06 - DaStr - TGLBAcceleration.Create - creates Inertia right away, thus displaying it in the XCollection Editor TGLBAcceleration.DoProgress - raises an exception when required Inertia component is deleted by user <li>24/09/02 - Egg - Support for negative rotation speeds (Marco Chong) <li>02/10/00 - Egg - Fixed TGLBInertia.DoProgress (DamplingEnabled bug) <li>09/10/00 - Egg - Fixed ApplyTranslationAcceleration & ApplyForce <li>11/08/00 - Egg - Fixed translation bug with root level objects & Inertia <li>10/04/00 - Egg - Improved persistence logic <li>06/04/00 - Egg - Added Damping stuff to inertia <li>05/04/00 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLDamping |
Class TGLBInertia |
Class TGLBAcceleration |

Functions and Procedures

function GetInertia(const AGLSceneObject: TGLBaseSceneObject): TGLBInertia;
function GetOrCreateInertia(behaviours: TGLBehaviours): TGLBInertia; overload;
function GetOrCreateInertia(obj: TGLBaseSceneObject): TGLBInertia; overload;
function GetOrCreateAcceleration(behaviours: TGLBehaviours): TGLBAcceleration; overload;
function GetOrCreateAcceleration(obj: TGLBaseSceneObject): TGLBAcceleration; overload;

Description

Functions and Procedures

function GetInertia(const AGLSceneObject: TGLBaseSceneObject): TGLBInertia;

Returns or creates the TGLBInertia within the given behaviours.<p> This helper function is convenient way to access a TGLBInertia.

function GetOrCreateInertia(behaviours: TGLBehaviours): TGLBInertia; overload;
function GetOrCreateInertia(obj: TGLBaseSceneObject): TGLBInertia; overload;
function GetOrCreateAcceleration(behaviours: TGLBehaviours): TGLBAcceleration; overload;

Returns or creates the TGLBAcceleration within the given behaviours.<p> This helper function is convenient way to access a TGLBAcceleration.

function GetOrCreateAcceleration(obj: TGLBaseSceneObject): TGLBAcceleration; overload;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBehaviours: Class TGLDamping

Class TGLDamping

Unit

GLBehaviours

Declaration

type TGLDamping = class(TGLUpdateAbleObject)

Description

Holds parameters for TGLScene basic damping model.<p> Damping is modeled by calculating a force from the speed, this force can then be transformed to an acceleration is you know the object's mass.<br> Formulas :<ul> <li>damping = constant + linear * Speed + quadratic * Speedˆ2 <li>accel = damping / Mass </ul> That's just basic physics :). A note on the components :<ul> <li>constant : use it for solid friction (will stop abruptly an object after decreasing its speed. <li>linear : linear friction damping. <li>quadratic : expresses viscosity. </ul>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLDamping

Overview

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function AsString(const damping: TGLDamping): string;
Public | function Calculate(speed, deltaTime: double): double;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(reader: TReader);
Public | procedure SetDamping(const constant: single = 0; const linear: single = 0; const quadratic: single = 0);
Public | procedure WriteToFiler(writer: TWriter);

Properties

Published | property Constant: single read FConstant write FConstant;
Published | property Linear: single read FLinear write FLinear;
Published | property Quadratic: single read FQuadratic write FQuadratic;

Description

Methods

Public constructor Create(aOwner: TPersistent); override;
Public destructor Destroy; override;
Public function AsString(const damping: TGLDamping): string;

Returns a "[constant; linear; quadractic]" string

Public function Calculate(speed, deltaTime: double): double;

Calculates attenuated speed over deltaTime.<p> Integration step is 0.01 sec, and the following formula is applied at each step: constant+linear*speed+quadratic*speedˆ2

Public procedure Assign(Source: TPersistent); override;
Public procedure ReadFromFiler(reader: TReader);
Public procedure SetDamping(const constant: single = 0; const linear: single = 0; const quadratic: single = 0);

Sets all damping parameters in a single call.

Public procedure WriteToFiler(writer: TWriter);

Properties

Published property Constant: single read FConstant write FConstant;
Published property Linear: single read FLinear write FLinear;
Published property Quadratic: single read FQuadratic write FQuadratic;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBehaviours: Class TGLBInertia

Class TGLBInertia

Unit

GLBehaviours

Declaration

type TGLBInertia = class(TGLBehaviour)

Description

Simple translation and rotation Inertia behaviour.<p> Stores translation and rotation speeds, to which you can apply accelerations.<p> Note that the rotation model is not physical, so feel free to contribute a "realworld" inertia class with realistic, axis-free, rotation inertia if this approximation does not suits your needs :).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBInertia

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | class function UniqueItem: boolean; override;
Public | procedure ApplyForce(const deltaTime: double; const force: TVector);
Public | procedure ApplyTorque(const deltaTime: double; const turnTorque, rollTorque, pitchTorque: single);
Public | procedure ApplyTranslationAcceleration(const deltaTime: double; const accel: TVector);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Public | procedure MirrorTranslation;
Public | procedure SurfaceBounce(const surfaceNormal: TVector; restitution: single);
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure SetRotationDamping(const val: TGLDamping);
Protected | procedure SetTranslationDamping(const val: TGLDamping);
Protected | procedure SetTranslationSpeed(const val: TGLCoordinates);
Protected | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property DampingEnabled: boolean read FDampingEnabled write FDampingEnabled;
Published | property Mass: single read FMass write FMass;
Published | property PitchSpeed: single read FPitchSpeed write FPitchSpeed;
Published | property RollSpeed: single read FRollSpeed write FRollSpeed;
Published | property RotationDamping: TGLDamping read FRotationDamping write SetRotationDamping;
Published | property TranslationDamping: TGLDamping read FTranslationDamping write SetTranslationDamping;
Published | property TranslationSpeed: TGLCoordinates read FTranslationSpeed write SetTranslationSpeed;
Published | property TurnSpeed: single read FTurnSpeed write FTurnSpeed;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Public class function UniqueItem: boolean; override;
Public procedure ApplyForce(const deltaTime: double; const force: TVector);

Applies a timed force to the inertia.<p> If Mass is null, nothing is done.

Public procedure ApplyTorque(const deltaTime: double; const turnTorque, rollTorque, pitchTorque: single);

Applies a timed torque to the inertia (yuck!).<p> This gets a "yuck!" because it is as false as the rest of the rotation model.

Public procedure ApplyTranslationAcceleration(const deltaTime: double; const accel: TVector);

Adds time-proportionned acceleration to the speed.

Public procedure Assign(Source: TPersistent); override;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Public procedure MirrorTranslation;

Inverts the translation vector.<p>

Public procedure SurfaceBounce(const surfaceNormal: TVector; restitution: single);

Bounce speed as if hitting a surface.<p> restitution is the coefficient of restituted energy (1=no energy loss, 0=no bounce). The normal is NOT assumed to be normalized.

Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure SetRotationDamping(const val: TGLDamping);
Protected procedure SetTranslationDamping(const val: TGLDamping);
Protected procedure SetTranslationSpeed(const val: TGLCoordinates);
Protected procedure WriteToFiler(writer: TWriter); override;

Properties

Published property DampingEnabled: boolean read FDampingEnabled write FDampingEnabled;

Enable/Disable damping (damping has a high cpu-cycle cost).<p> Damping is enabled by default.

Published property Mass: single read FMass write FMass;
Published property PitchSpeed: single read FPitchSpeed write FPitchSpeed;
Published property RollSpeed: single read FRollSpeed write FRollSpeed;
Published property RotationDamping: TGLDamping read FRotationDamping write SetRotationDamping;

Damping applied to rotation speed (yuck!).<br> Well, this one is not "exact", like TranslationDamping, and neither it is "physical" since I'm reusing the mass and... and... well don't show this to your science teacher 8).<br> Anyway that's easier to use than the realworld formulas, calculated faster, and properly used can give a good illusion of reality.

Published property TranslationDamping: TGLDamping read FTranslationDamping write SetTranslationDamping;

Damping applied to translation speed.<br> Note that it is not "exactly" applied, ie. if damping would stop your object after 0.5 time unit, and your progression steps are of 1 time unit, there will be an integration error of 0.5 time unit.

Published property TranslationSpeed: TGLCoordinates read FTranslationSpeed write SetTranslationSpeed;
Published property TurnSpeed: single read FTurnSpeed write FTurnSpeed;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBehaviours: Class TGLBAcceleration

Class TGLBAcceleration

Unit

GLBehaviours

Declaration

type TGLBAcceleration = class(TGLBehaviour)

Description

Applies a constant acceleration to a TGLBInertia.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBAcceleration

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | class function UniqueItem: boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure SetAcceleration(const val: TGLCoordinates);
Protected | procedure WriteToFiler(writer: TWriter); override;

Properties

Published property Acceleration: TGLCoordinates read FAcceleration write FAcceleration;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Public class function UniqueItem: boolean; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure SetAcceleration(const val: TGLCoordinates);
Protected procedure WriteToFiler(writer: TWriter); override;

Properties

Published property Acceleration: TGLCoordinates read FAcceleration write FAcceleration;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBitmapFont

Unit GLBitmapFont

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLBitmapFont<p>

Bitmap Fonts management classes for GLScene<p>

<b>History : </b><font size=-1><ul> <li>20/11/12 - PW - CPP compatibility: replaced direct access to some properties with records <li>01/09/11 - Yar - Bugfixed StartASCII, StopASCII properties for non-Unicode compiler <li>30/06/11 - DaStr - Bugfixed TBitmapFontRanges.Add(for AnsiChar) <li>16/05/11 - Yar - Redesign to use multiple textures (by Gabriel Corneanu) <li>13/05/11 - Yar - Adapted to unicode (by Gabriel Corneanu) <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>05/07/10 - Yar - Now HSpace and VSpace can take negative values (thanks Sandor Domokos) (BugtrackerID = 3024975) <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>24/02/10 - Yar - Bugfix in TGLCustomBitmapFont.PrepareImage when image is not RGBA8 <li>25/01/10 - Yar - Replace Char to AnsiChar <li>11/11/09 - DaStr - Added Delphi 2009 compatibility (thanks mal) <li>16/10/08 - UweR - Removed unneeded typecast in TBitmapFontRange.SetStartGlyphIdx <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>22/12/06 - LC - Fixed TGLCustomBitmapFont.RenderString, it now unbinds the texture. Bugtracker ID=1619243 (thanks Da Stranger) <li>09/03/05 - EG - Fixed space width during rendering <li>12/15/04 - Eugene Kryukov - Moved FCharRects to protected declaration in TGLCustomBitmapFont <li>18/10/04 - NelC - Fixed a texture reset bug in RenderString <li>02/08/04 - LR, YHC - BCB corrections: use record instead array <li>28/06/04 - LR - Change TTextLayout to TGLTextLayout for Linux <li>27/06/04 - NelC - Added TGLFlatText.Assign <li>01/03/04 - SG - TGLCustomBitmapFont.RenderString now saves GL_CURRENT_BIT state <li>01/07/03 - EG - TGLCustomBitmapFont.TextOut now saves and restore state <li>07/05/03 - EG - TGLFlatText Notification fix, added Options <li>30/10/02 - EG - Added TGLFlatText <li>29/09/02 - EG - Added TexCoords LUT, faster RenderString, removed TBitmapFontRange.Widths <li>28/09/02 - EG - Introduced TGLCustomBitmapFont <li>06/09/02 - JAJ - Prepared for TGLWindowsBitmapFont <li>28/08/02 - EG - Repaired fixed CharWidth, variable CharWidth not yet repaired <li>12/08/02 - JAJ - Merged Dual Development, Alpha Channel and CharWidth are now side by side <li>UNKNOWN - EG - Added Alpha Channel. <li>02/06/02 - JAJ - Modified to flexible character width <li>20/01/02 - EG - Dropped 'Graphics' dependency <li>10/09/01 - EG - Fixed visibility of tile 0 <li>12/08/01 - EG - Completely rewritten handles management <li>21/02/01 - EG - Now XOpenGL based (multitexture) <li>15/01/01 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TBitmapFontRange |
Class TBitmapFontRanges |
record TCharInfo |
Class TGLCustomBitmapFont |
Class TGLBitmapFont |
Class TGLFlatText |

Types

PCharInfo = ˆTCharInfo;
TGLFlatTextOption = (...);
TGLFlatTextOptions = set of TGLFlatTextOption;

Description

Types

PCharInfo = ˆTCharInfo;
TGLFlatTextOption = (...);
Values
  • ftoTwoSided:
TGLFlatTextOptions = set of TGLFlatTextOption;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBitmapFont: Class TBitmapFontRange

Class TBitmapFontRange

Unit

GLBitmapFont

Declaration

type TBitmapFontRange = class(TCollectionItem)

Description

An individual character range in a bitmap font.<p> A range allows mapping ASCII characters to character tiles in a font bitmap, tiles are enumerated line then column (raster).

Hierarchy

  • TCollectionItem
  • TBitmapFontRange

Overview

Fields

Protected | FStartASCII: WideChar;
Protected | FStopASCII: WideChar;
Protected | FStartGlyphIdx: Integer;
Protected | FStopGlyphIdx: Integer;
Protected | FCharCount: Integer;

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange;
Protected | procedure SetStartASCII(const val: WideString);
Protected | procedure SetStartGlyphIdx(val: Integer);
Protected | procedure SetStopASCII(const val: WideString);

Properties

Published | property CharCount: integer read FCharCount;
Published | property StartASCII: WideString read GetStartASCII write SetStartASCII;
Published | property StartGlyphIdx: Integer read FStartGlyphIdx write SetStartGlyphIdx;
Published | property StopASCII: WideString read GetStopASCII write SetStopASCII;
Published | property StopGlyphIdx: Integer read FStopGlyphIdx;

Description

Fields

Protected FStartASCII: WideChar;
Protected FStopASCII: WideChar;
Protected FStartGlyphIdx: Integer;
Protected FStopGlyphIdx: Integer;
Protected FCharCount: Integer;

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure NotifyChange;
Protected procedure SetStartASCII(const val: WideString);
Protected procedure SetStartGlyphIdx(val: Integer);
Protected procedure SetStopASCII(const val: WideString);

Properties

Published property CharCount: integer read FCharCount;
Published property StartASCII: WideString read GetStartASCII write SetStartASCII;
Published property StartGlyphIdx: Integer read FStartGlyphIdx write SetStartGlyphIdx;
Published property StopASCII: WideString read GetStopASCII write SetStopASCII;
Published property StopGlyphIdx: Integer read FStopGlyphIdx;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBitmapFont: Class TBitmapFontRanges

Class TBitmapFontRanges

Unit

GLBitmapFont

Declaration

type TBitmapFontRanges = class(TCollection)

Description

Hierarchy

  • TCollection
  • TBitmapFontRanges

Overview

Fields

Protected FOwner: TComponent;

Methods

Public | constructor Create(AOwner: TComponent);
Public | destructor Destroy; override;
Public | function Add: TBitmapFontRange; overload;
Public | function Add(const startASCII, stopASCII: WideChar): TBitmapFontRange; overload;
Public | function Add(const startASCII, stopASCII: AnsiChar): TBitmapFontRange; overload;
Public | function CharacterToTileIndex(aChar: widechar): Integer;
Public | function FindItemID(ID: Integer): TBitmapFontRange;
Public | function TileIndexToChar(aIndex: integer): widechar;
Protected | function CalcCharacterCount: Integer;
Protected | function GetItems(index: Integer): TBitmapFontRange;
Protected | function GetOwner: TPersistent; override;
Public | procedure NotifyChange;
Protected | procedure SetItems(index: Integer; const val: TBitmapFontRange);
Protected | procedure Update(Item: TCollectionItem); override;

Properties

Public | property CharacterCount: Integer read FCharCount;
Public | property Items[index: Integer]: TBitmapFontRange read GetItems write SetItems;

Description

Fields

Protected FOwner: TComponent;

Methods

Public constructor Create(AOwner: TComponent);
Public destructor Destroy; override;
Public function Add: TBitmapFontRange; overload;
Public function Add(const startASCII, stopASCII: WideChar): TBitmapFontRange; overload;
Public function Add(const startASCII, stopASCII: AnsiChar): TBitmapFontRange; overload;
Public function CharacterToTileIndex(aChar: widechar): Integer;

Converts an ASCII character into a tile index.<p> Return -1 if character cannot be rendered.

Public function FindItemID(ID: Integer): TBitmapFontRange;
Public function TileIndexToChar(aIndex: integer): widechar;
Protected function CalcCharacterCount: Integer;
Protected function GetItems(index: Integer): TBitmapFontRange;
Protected function GetOwner: TPersistent; override;
Public procedure NotifyChange;
Protected procedure SetItems(index: Integer; const val: TBitmapFontRange);
Protected procedure Update(Item: TCollectionItem); override;

Properties

Public property CharacterCount: Integer read FCharCount;

Total number of characters in the ranges; cached for performance

Public property Items[index: Integer]: TBitmapFontRange read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBitmapFont: record TCharInfo

record TCharInfo

Unit

GLBitmapFont

Declaration

type TCharInfo = record

Description

Overview

Fields

l: word;
t: word;
w: word;

Description

Fields

l: word;
t: word;
w: word;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBitmapFont: Class TGLCustomBitmapFont

Class TGLCustomBitmapFont

Unit

GLBitmapFont

Declaration

type TGLCustomBitmapFont = class(TGLUpdateAbleComponent)

Description

Provides access to individual characters in a BitmapFont.<p> Only fixed-width bitmap fonts are supported, the characters are enumerated in a raster fashion (line then column).<br> Transparency is all or nothing, the transparent color being that of the top left pixel of the Glyphs bitmap.<p> Performance note: as usual, for best performance, you base font bitmap dimensions should be close to a power of two, and have at least 1 pixel spacing between characters (horizontally and vertically) to avoid artefacts when rendering with linear filtering.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomBitmapFont

Overview

Fields

Protected | FChars: array of TCharInfo;
Protected | FCharsLoaded: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CalcStringWidth(const aText: UnicodeString): Integer; overload; virtual;
Public | function CharacterCount: integer; virtual;
Public | function CharacterToTileIndex(aChar: widechar): Integer; virtual;
Public | function GetCharWidth(ch: widechar): Integer;
Public | function TextWidth(const text: UnicodeString): Integer;
Public | function TileIndexToChar(aIndex: integer): widechar; virtual;
Protected | function CharactersPerRow: Integer;
Protected | function TextureFormat: Integer; dynamic;
Public | procedure CheckTexture(var ARci: TRenderContextInfo);
Public | procedure RegisterUser(anObject: TGLBaseSceneObject); virtual;
Public | procedure RenderString(var ARci: TRenderContextInfo; const aText: UnicodeString; aAlignment: TAlignment; aLayout: TGLTextLayout; const aColor: TColorVector; aPosition: PVector = nil; aReverseY: Boolean = False); overload; virtual;
Public | procedure TextOut(var rci: TRenderContextInfo; x, y: Single; const text: UnicodeString; const color: TColor); overload;
Public | procedure TextOut(var rci: TRenderContextInfo; x, y: Single; const text: UnicodeString; const color: TColorVector); overload;
Public | procedure UnRegisterUser(anObject: TGLBaseSceneObject); virtual;
Protected | procedure FreeTextureHandle; dynamic;
Protected | procedure GetCharTexCoords(ch: widechar; var topLeft, bottomRight: TTexPoint);
Protected | procedure GetICharTexCoords(var ARci: TRenderContextInfo; chi: Integer; out topLeft, bottomRight: TTexPoint);
Protected | procedure InvalidateUsers;
Protected | procedure OnGlyphsChanged(Sender: TObject);
Protected | procedure PrepareImage(var ARci: TRenderContextInfo); virtual;
Protected | procedure PrepareParams(var ARci: TRenderContextInfo);
Protected | procedure ResetCharWidths(w: Integer = -1);
Protected | procedure SetCharHeight(const val: Integer);
Protected | procedure SetCharWidth(const val: Integer);
Protected | procedure SetCharWidths(index, value: Integer);
Protected | procedure SetGlyphs(const val: TGLPicture);
Protected | procedure SetGlyphsAlpha(val: TGLTextureImageAlpha);
Protected | procedure SetGlyphsIntervalX(const val: Integer);
Protected | procedure SetGlyphsIntervalY(const val: Integer);
Protected | procedure SetHSpace(const val: Integer);
Protected | procedure SetMagFilter(AValue: TGLMagFilter);
Protected | procedure SetMinFilter(AValue: TGLMinFilter);
Protected | procedure SetRanges(const val: TBitmapFontRanges);
Protected | procedure SetVSpace(const val: Integer);
Protected | procedure TextureChanged;

Properties

Public | property CharHeight: Integer read FCharHeight write SetCharHeight default 16;
Protected | property CharWidth: Integer read FCharWidth write SetCharWidth default 16;
Protected | property Glyphs: TGLPicture read FGlyphs write SetGlyphs;
Protected | property GlyphsAlpha: TGLTextureImageAlpha read FGlyphsAlpha write FGlyphsAlpha default tiaDefault;
Protected | property GlyphsIntervalX: Integer read FGlyphsIntervalX write SetGlyphsIntervalX;
Protected | property GlyphsIntervalY: Integer read FGlyphsIntervalY write SetGlyphsIntervalY;
Protected | property HSpace: Integer read FHSpace write SetHSpace default 1;
Protected | property HSpaceFix: Integer read FHSpaceFix write FHSpaceFix;
Protected | property MagFilter: TGLMagFilter read FMagFilter write SetMagFilter default maLinear;
Protected | property MinFilter: TGLMinFilter read FMinFilter write SetMinFilter default miLinear;
Protected | property Ranges: TBitmapFontRanges read FRanges write SetRanges;
Public | property TextureHeight: integer read FTextureHeight write FTextureHeight;
Public | property TextureWidth : integer read FTextureWidth write FTextureWidth;
Protected | property VSpace: Integer read FVSpace write SetVSpace default 1;

Description

Fields

Protected FChars: array of TCharInfo;
Protected FCharsLoaded: boolean;

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function CalcStringWidth(const aText: UnicodeString): Integer; overload; virtual;

Get the actual pixel width for this string.

Public function CharacterCount: integer; virtual;
Public function CharacterToTileIndex(aChar: widechar): Integer; virtual;
Public function GetCharWidth(ch: widechar): Integer;

Get the actual width for this char.

Public function TextWidth(const text: UnicodeString): Integer;
Public function TileIndexToChar(aIndex: integer): widechar; virtual;
Protected function CharactersPerRow: Integer;
Protected function TextureFormat: Integer; dynamic;
Public procedure CheckTexture(var ARci: TRenderContextInfo);
Public procedure RegisterUser(anObject: TGLBaseSceneObject); virtual;
Public procedure RenderString(var ARci: TRenderContextInfo; const aText: UnicodeString; aAlignment: TAlignment; aLayout: TGLTextLayout; const aColor: TColorVector; aPosition: PVector = nil; aReverseY: Boolean = False); overload; virtual;

Renders the given string at current position or at position given by the optional position variable.<p> The current matrix is blindly used, meaning you can render all kinds of rotated and linear distorted text with this method, OpenGL Enable states are also possibly altered.

Public procedure TextOut(var rci: TRenderContextInfo; x, y: Single; const text: UnicodeString; const color: TColor); overload;
Public procedure TextOut(var rci: TRenderContextInfo; x, y: Single; const text: UnicodeString; const color: TColorVector); overload;

A simpler canvas-style TextOut helper for RenderString.<p> The rendering is reversed along Y by default, to allow direct use with TGLCanvas

Public procedure UnRegisterUser(anObject: TGLBaseSceneObject); virtual;
Protected procedure FreeTextureHandle; dynamic;
Protected procedure GetCharTexCoords(ch: widechar; var topLeft, bottomRight: TTexPoint);
Protected procedure GetICharTexCoords(var ARci: TRenderContextInfo; chi: Integer; out topLeft, bottomRight: TTexPoint);
Protected procedure InvalidateUsers;
Protected procedure OnGlyphsChanged(Sender: TObject);
Protected procedure PrepareImage(var ARci: TRenderContextInfo); virtual;
Protected procedure PrepareParams(var ARci: TRenderContextInfo);
Protected procedure ResetCharWidths(w: Integer = -1);
Protected procedure SetCharHeight(const val: Integer);
Protected procedure SetCharWidth(const val: Integer);
Protected procedure SetCharWidths(index, value: Integer);
Protected procedure SetGlyphs(const val: TGLPicture);
Protected procedure SetGlyphsAlpha(val: TGLTextureImageAlpha);
Protected procedure SetGlyphsIntervalX(const val: Integer);
Protected procedure SetGlyphsIntervalY(const val: Integer);
Protected procedure SetHSpace(const val: Integer);
Protected procedure SetMagFilter(AValue: TGLMagFilter);
Protected procedure SetMinFilter(AValue: TGLMinFilter);
Protected procedure SetRanges(const val: TBitmapFontRanges);
Protected procedure SetVSpace(const val: Integer);
Protected procedure TextureChanged;

Properties

Public property CharHeight: Integer read FCharHeight write SetCharHeight default 16;

Height of a single character.

Protected property CharWidth: Integer read FCharWidth write SetCharWidth default 16;

Width of a single character.

Protected property Glyphs: TGLPicture read FGlyphs write SetGlyphs;

A single bitmap containing all the characters.<p> The transparent color is that of the top left pixel.

Protected property GlyphsAlpha: TGLTextureImageAlpha read FGlyphsAlpha write FGlyphsAlpha default tiaDefault;
Protected property GlyphsIntervalX: Integer read FGlyphsIntervalX write SetGlyphsIntervalX;

Nb of horizontal pixels between two columns in the Glyphs.

Protected property GlyphsIntervalY: Integer read FGlyphsIntervalY write SetGlyphsIntervalY;

Nb of vertical pixels between two rows in the Glyphs.

Protected property HSpace: Integer read FHSpace write SetHSpace default 1;

Pixels in between rendered characters (horizontally).

Protected property HSpaceFix: Integer read FHSpaceFix write FHSpaceFix;

Horizontal spacing fix offset.<p> This property is for internal use, and is added to the hspacing of each character when rendering, typically to fix extra spacing.

Protected property MagFilter: TGLMagFilter read FMagFilter write SetMagFilter default maLinear;
Protected property MinFilter: TGLMinFilter read FMinFilter write SetMinFilter default miLinear;
Protected property Ranges: TBitmapFontRanges read FRanges write SetRanges;

Ranges allow converting between ASCII and tile indexes.<p> See TGLCustomBitmapFontRange.

Public property TextureHeight: integer read FTextureHeight write FTextureHeight;
Public property TextureWidth : integer read FTextureWidth write FTextureWidth;
Protected property VSpace: Integer read FVSpace write SetVSpace default 1;

Pixels in between rendered lines (vertically).

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBitmapFont: Class TGLBitmapFont

Class TGLBitmapFont

Unit

GLBitmapFont

Declaration

type TGLBitmapFont = class(TGLCustomBitmapFont)

Description

See TGLCustomBitmapFont.<p> This class only publuishes some of the properties.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomBitmapFont
  • TGLBitmapFont

Overview

Properties

Published | property CharHeight;
Published | property CharWidth;
Published | property Glyphs;
Published | property GlyphsAlpha;
Published | property GlyphsIntervalX;
Published | property GlyphsIntervalY;
Published | property HSpace;
Published | property MagFilter;
Published | property MinFilter;
Published | property Ranges;
Published | property VSpace;

Description

Properties

Published property CharHeight;
Published property CharWidth;
Published property Glyphs;
Published property GlyphsAlpha;
Published property GlyphsIntervalX;
Published property GlyphsIntervalY;
Published property HSpace;
Published property MagFilter;
Published property MinFilter;
Published property Ranges;
Published property VSpace;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBitmapFont: Class TGLFlatText

Class TGLFlatText

Unit

GLBitmapFont

Declaration

type TGLFlatText = class(TGLImmaterialSceneObject)

Description

A 2D text displayed and positionned in 3D coordinates.<p> The FlatText uses a character font defined and stored by a TGLBitmapFont component. Default character scale is 1 font pixel = 1 space unit.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLFlatText

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetAlignment(const val: TAlignment);
Protected | procedure SetBitmapFont(const val: TGLCustomBitmapFont);
Protected | procedure SetLayout(const val: TGLTextLayout);
Protected | procedure SetModulateColor(const val: TGLColor);
Protected | procedure SetOptions(const val: TGLFlatTextOptions);
Protected | procedure SetText(const val: UnicodeString);

Properties

Published | property Alignment: TAlignment read FAlignment write SetAlignment;
Published | property BitmapFont: TGLCustomBitmapFont read FBitmapFont write SetBitmapFont;
Published | property Layout: TGLTextLayout read FLayout write SetLayout;
Published | property ModulateColor: TGLColor read FModulateColor write SetModulateColor;
Published | property Options: TGLFlatTextOptions read FOptions write SetOptions;
Published | property Text: UnicodeString read FText write SetText;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetAlignment(const val: TAlignment);
Protected procedure SetBitmapFont(const val: TGLCustomBitmapFont);
Protected procedure SetLayout(const val: TGLTextLayout);
Protected procedure SetModulateColor(const val: TGLColor);
Protected procedure SetOptions(const val: TGLFlatTextOptions);
Protected procedure SetText(const val: UnicodeString);

Properties

Published property Alignment: TAlignment read FAlignment write SetAlignment;

Controls the text alignment (horizontal).<p> Possible values : taLeftJustify, taRightJustify, taCenter

Published property BitmapFont: TGLCustomBitmapFont read FBitmapFont write SetBitmapFont;

Refers the bitmap font to use.<p> The referred bitmap font component stores and allows access to individual character bitmaps.

Published property Layout: TGLTextLayout read FLayout write SetLayout;

Controls the text layout (vertical).<p> Possible values : tlTop, tlCenter, tlBottom

Published property ModulateColor: TGLColor read FModulateColor write SetModulateColor;

Color modulation, can be used for fade in/out too.

Published property Options: TGLFlatTextOptions read FOptions write SetOptions;

Flat text options.<p> <ul><li>ftoTwoSided : when set the text will be visible from its two sides even if faceculling is on (at the scene-level). </ul>

Published property Text: UnicodeString read FText write SetText;

Text to render.<p> Be aware that only the characters available in the bitmap font will be rendered. CR LF sequences are allowed.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBlur

Unit GLBlur

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLBlur<p>

Applies a blur effect over the viewport.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>30/01/08 - Mrqzzz - Several changes to GLBlur. Added Advenced Blur. Looks good now :) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>06/04/07 - DaStr - Fixed TGLMotionBlur.InitializeObject - component can only be disabled in run-time <li>03/04/07 - DaStr - Optimized TGLMotionBlur.DoRender - now component checks for supported extensions only once <li>25/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>22/03/07 - DaStr - Added checks to TGLMotionBlur for supported extensions TGLMotionBlur is not rendered when picking now <li>25/02/07 - DaStr - Added DesignTime check in TGLMotionBlur.DoRender <li>23/02/07 - DaStr - TGLMotionBlur.StoreIntensity bugfixed TGLBlur - default values added to all properties, Made some cosmetic and alignment changes <li>20/02/07 - DaStr - TGLMotionBlur added (based on ToxBlur by Dave Gravel) Added some default values to TGLBlur <li>11/06/04 - Mrqzzz - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TRGBPixel |
Class EGLMotionBlurException |
Class TGLBlur |
Class TGLMotionBlur |

Types

TGLBlurPreset = (...);
TGLBlurkind = (...);
TRGBPixelBuffer = array of TRGBPixel;
TGLAdvancedBlurImagePrepareEvent = procedure(Sender: TObject; BMP32: TGLBitmap32; var DoBlur: boolean) of object;

Description

Types

TGLBlurPreset = (...);
Values
  • pNone:
  • pGlossy:
  • pBeastView:
  • pOceanDepth:
  • pDream:
  • pOverBlur:
  • pAdvancedBlur:
TGLBlurkind = (...);
Values
  • bNone:
  • bSimple:
  • bAdvanced:
TRGBPixelBuffer = array of TRGBPixel;
TGLAdvancedBlurImagePrepareEvent = procedure(Sender: TObject; BMP32: TGLBitmap32; var DoBlur: boolean) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBlur: record TRGBPixel

record TRGBPixel

Unit

GLBlur

Declaration

type TRGBPixel = record

Description

Overview

Fields

R: TGLubyte;
G: TGLubyte;
B: TGLubyte;

Description

Fields

R: TGLubyte;
G: TGLubyte;
B: TGLubyte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBlur: Class EGLMotionBlurException

Class EGLMotionBlurException

Unit

GLBlur

Declaration

type EGLMotionBlurException = class(Exception)

Description

Hierarchy

  • Exception
  • EGLMotionBlurException
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:10


GLScene v.1.1.2: GLBlur: Class TGLBlur

Class TGLBlur

Unit

GLBlur

Declaration

type TGLBlur = class(TGLHUDSprite)

Description

no description available, TGLHUDSprite description follows
no description available, TGLSprite description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLSprite
  • TGLHUDSprite
  • TGLBlur

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property AdvancedBlurAmp: single read FAdvancedBlurAmp write SetAdvancedBlurAmp;
Published | property AdvancedBlurHiClamp: byte read FAdvancedBlurHiClamp write SetAdvancedBlurHiClamp;
Published | property AdvancedBlurLowClamp: byte read FAdvancedBlurLowClamp write SetAdvancedBlurLowClamp;
Published | property AdvancedBlurPasses: integer read FAdvancedBlurPasses write SetAdvancedBlurPasses;
Published | property Blur: TGLBlurKind read FBlur write SetBlur;
Published | property BlurBottom: Single read FBlurBottom write FBlurBottom stored StoreBlurBottom;
Published | property BlurDeltaTime: Double read FBlurDeltaTime write FBlurDeltaTime stored StoreBlurDeltaTime;
Published | property BlurLeft: Single read FBlurLeft write FBlurLeft stored StoreBlurLeft;
Published | property BlurRight: Single read FBlurRight write FBlurRight stored StoreBlurRight;
Published | property BlurSelf: boolean read FBlurSelf write SetBlurSelf;
Published | property BlurTop: Single read FBlurTop write FBlurTop stored StoreBlurTop;
Published | property OnAdvancedBlurImagePrepareEvent: TGLAdvancedBlurImagePrepareEvent read FOnAdvancedBlurImagePrepareEvent write SetOnAdvancedBlurImagePrepareEvent;
Published | property OnAfterTargetRender: TNotifyEvent read FOnAfterTargetRender write SetOnAfterTargetRender;
Published | property OnBeforeTargetRender: TNotifyEvent read FOnBeforeTargetRender write SetOnBeforeTargetRender;
Published | property Preset: TGLBlurPreset read FPreset write SetPreset stored false;
Published | property RenderBackgroundColor: TColor read FRenderBackgroundColor write SetRenderBackgroundColor;
Published | property RenderHeight: Integer read FRenderHeight write SetRenderHeight default 256;
Published | property RenderWidth: Integer read FRenderWidth write SetRenderWidth default 256;
Published | property TargetObject: TGLbaseSceneObject read FTargetObject write SetTargetObject;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published property AdvancedBlurAmp: single read FAdvancedBlurAmp write SetAdvancedBlurAmp;
Published property AdvancedBlurHiClamp: byte read FAdvancedBlurHiClamp write SetAdvancedBlurHiClamp;
Published property AdvancedBlurLowClamp: byte read FAdvancedBlurLowClamp write SetAdvancedBlurLowClamp;
Published property AdvancedBlurPasses: integer read FAdvancedBlurPasses write SetAdvancedBlurPasses;
Published property Blur: TGLBlurKind read FBlur write SetBlur;
Published property BlurBottom: Single read FBlurBottom write FBlurBottom stored StoreBlurBottom;
Published property BlurDeltaTime: Double read FBlurDeltaTime write FBlurDeltaTime stored StoreBlurDeltaTime;
Published property BlurLeft: Single read FBlurLeft write FBlurLeft stored StoreBlurLeft;
Published property BlurRight: Single read FBlurRight write FBlurRight stored StoreBlurRight;
Published property BlurSelf: boolean read FBlurSelf write SetBlurSelf;
Published property BlurTop: Single read FBlurTop write FBlurTop stored StoreBlurTop;
Published property OnAdvancedBlurImagePrepareEvent: TGLAdvancedBlurImagePrepareEvent read FOnAdvancedBlurImagePrepareEvent write SetOnAdvancedBlurImagePrepareEvent;
Published property OnAfterTargetRender: TNotifyEvent read FOnAfterTargetRender write SetOnAfterTargetRender;
Published property OnBeforeTargetRender: TNotifyEvent read FOnBeforeTargetRender write SetOnBeforeTargetRender;
Published property Preset: TGLBlurPreset read FPreset write SetPreset stored false;
Published property RenderBackgroundColor: TColor read FRenderBackgroundColor write SetRenderBackgroundColor;
Published property RenderHeight: Integer read FRenderHeight write SetRenderHeight default 256;
Published property RenderWidth: Integer read FRenderWidth write SetRenderWidth default 256;
Published property TargetObject: TGLbaseSceneObject read FTargetObject write SetTargetObject;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLBlur: Class TGLMotionBlur

Class TGLMotionBlur

Unit

GLBlur

Declaration

type TGLMotionBlur = class(TGLCustomSceneObject, IGLInitializable)

Description

This component blurs everything thatis rendered BEFORE it. So if you want part of your scene blured, the other not blured, make sure that the other part is rendered after this component. It is fast and does not require shaders.

Note: it is FPS-dependant. Also also can produce a "blury trail effect", which stays on the screen until something new is rendered over it. It can be overcome by changing the Material.FrontProperties.Diffuse property. This, however, also has a drawback - the picture becomes more blured altogether. For example, if your backgroud color is Black, set the Material.FrontProperties.Diffuse to White. If it is White, set Material.FrontProperties.Diffuse to Black. I haven't tried any others, but I hope you get the idea ;)

I've seen this effect in different Bruring components, even in shaders, but if anyone knows another way to fix this issue - please post it on the glscene newsgroup.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLMotionBlur

Overview

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | function SupportsRequiredExtensions: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected | procedure DoOnAddedToParent; override;
Protected | procedure InitializeObject(ASender: TObject; const ARci: TRenderContextInfo); virtual;

Properties

Published | property Behaviours;
Published | property Effects;
Published | property Hint;
Published | property Intensity: Single read FIntensity write FIntensity stored StoreIntensity;
Published | property OnProgress;
Published | property Visible;

Description

Methods

Public constructor Create(aOwner: TComponent); override;
Public function SupportsRequiredExtensions: Boolean;

This function is only valid AFTER OpenGL has been initialized.

Public procedure Assign(Source: TPersistent); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected procedure DoOnAddedToParent; override;
Protected procedure InitializeObject(ASender: TObject; const ARci: TRenderContextInfo); virtual;

Properties

Published property Behaviours;
Published property Effects;
Published property Hint;
Published property Intensity: Single read FIntensity write FIntensity stored StoreIntensity;

The more the intensity, the more blur you have.

Published property OnProgress;
Published property Visible;

From TGLBaseSceneObject.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLBSP

Unit GLBSP

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TBSPCullingSphere |
record TBSPRenderContextInfo |
Class TBSPClusterVisibility |
Class TBSPMeshObject |
Class TFGBSPNode |

Types

TBSPRenderSort = (...);

Description

Types

TBSPRenderSort = (...);
Values
  • rsNone:
  • rsBackToFront:
  • rsFrontToBack:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLBSP: record TBSPCullingSphere

record TBSPCullingSphere

Unit

GLBSP

Declaration

type TBSPCullingSphere = record

Description

Overview

Fields

position: TVector;
radius: Single;

Description

Fields

position: TVector;
radius: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLBSP: record TBSPRenderContextInfo

record TBSPRenderContextInfo

Unit

GLBSP

Declaration

type TBSPRenderContextInfo = record

Description

Overview

Fields

cameraLocal: TVector;
rci: PRenderContextInfo;
faceGroups: TList;
cullingSpheres: array of TBSPCullingSphere;

Description

Fields

cameraLocal: TVector;
rci: PRenderContextInfo;
faceGroups: TList;
cullingSpheres: array of TBSPCullingSphere;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLBSP: Class TBSPClusterVisibility

Class TBSPClusterVisibility

Unit

GLBSP

Declaration

type TBSPClusterVisibility = class(TObject)

Description

Hierarchy

  • TObject
  • TBSPClusterVisibility

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Protected | function GetVisibility(Source, Destination: Integer): Boolean;
Public | procedure SetData(Source: PByte; NumClusters: Integer);
Protected | procedure SetCount(NumClusters: Integer);
Protected | procedure SetVisibility(Source, Destination: Integer; const Value: Boolean);

Properties

Public | property Count: Integer read FCount write SetCount;
Public | property Visibility[src, dst: Integer]: Boolean read GetVisibility write SetVisibility;

Description

Methods

Public constructor Create;
Public destructor Destroy; override;
Protected function GetVisibility(Source, Destination: Integer): Boolean;
Public procedure SetData(Source: PByte; NumClusters: Integer);
Protected procedure SetCount(NumClusters: Integer);
Protected procedure SetVisibility(Source, Destination: Integer; const Value: Boolean);

Properties

Public property Count: Integer read FCount write SetCount;
Public property Visibility[src, dst: Integer]: Boolean read GetVisibility write SetVisibility;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLBSP: Class TBSPMeshObject

Class TBSPMeshObject

Unit

GLBSP

Declaration

type TBSPMeshObject = class(TMeshObject)

Description

no description available, TMeshObject description follows

Base mesh class.<p> Introduces base methods and properties for mesh objects.<p> Subclasses are named "TMOxxx".

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseMeshObject
  • TMeshObject
  • TBSPMeshObject

Overview

Methods

Public | constructor CreateOwned(AOwner: TMeshObjectList);
Public | destructor Destroy; override;
Public | function AverageDepth: Single;
Public | function FindNodeByPoint(aPoint: TVector): TFGBSPNode;
Public | procedure BuildList(var mrci: TRenderContextInfo); override;
Public | procedure CleanupUnusedNodes;

Properties

Public | property ClusterVisibility: TBSPClusterVisibility read FClusterVisibility;
Public | property RenderSort: TBSPRenderSort read FRenderSort write FRenderSort;
Public | property UseClusterVisibility: Boolean read FUseClusterVisibility write FUseClusterVisibility;

Description

Methods

Public constructor CreateOwned(AOwner: TMeshObjectList);
Public destructor Destroy; override;
Public function AverageDepth: Single;
Public function FindNodeByPoint(aPoint: TVector): TFGBSPNode;
Public procedure BuildList(var mrci: TRenderContextInfo); override;
Public procedure CleanupUnusedNodes;

Properties

Public property ClusterVisibility: TBSPClusterVisibility read FClusterVisibility;
Public property RenderSort: TBSPRenderSort read FRenderSort write FRenderSort;
Public property UseClusterVisibility: Boolean read FUseClusterVisibility write FUseClusterVisibility;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLBSP: Class TFGBSPNode

Class TFGBSPNode

Unit

GLBSP

Declaration

type TFGBSPNode = class(TFGVertexIndexList)

Description

no description available, TFGVertexIndexList description follows

A face group based on an indexlist.<p> The index list refers to items in the mesh object (vertices, normals, etc.), that are all considered in sync, the render is obtained issueing the items in the order given by the vertices.<p>

Hierarchy

  • TPersistent
  • TPersistentObject
  • TFaceGroup
  • TFGVertexIndexList
  • TFGBSPNode

Overview

Methods

Public | constructor CreateOwned(AOwner: TFaceGroups); override;
Public | destructor Destroy; override;
Public | function FindSplitPlane(triangleSplitCost: Single = 1; triangleImbalanceCost: Single = 0.5): THmgPlane;
Protected | function AddLerp(iA, iB: Integer; fB, fA: Single): Integer;
Protected | function AddLerpIfDistinct(iA, iB, iMid: Integer): Integer;
Public | procedure CollectBackToFront(var bsprci: TBSPRenderContextInfo);
Public | procedure CollectFrontToBack(var bsprci: TBSPRenderContextInfo);
Public | procedure CollectNoSort(var bsprci: TBSPRenderContextInfo);
Public | procedure EvaluateSplitPlane(const splitPlane: THmgPlane; var nbTriangleSplit: Integer; var nbPositiveTriangles: Integer; var nbNegativeTriangles: Integer);
Public | procedure FixTJunctions(const tJunctionsCandidates: TIntegerList);
Public | procedure IsCulled(const bsprci: TBSPRenderContextInfo; var positive, negative: Boolean);
Public | procedure PerformSplit(const splitPlane: THmgPlane; const maxTrianglesPerLeaf: Integer = MaxInt);

Properties

Public | property Cluster: Integer read FCluster write FCluster;
Public | property NegativeSubNodeIndex: Integer read FNegativeSubNodeIndex write FNegativeSubNodeIndex;
Public | property PositiveSubNodeIndex: Integer read FPositiveSubNodeIndex write FPositiveSubNodeIndex;
Public | property splitPlane: THmgPlane read FSplitPlane write FSplitPlane;

Description

Methods

Public constructor CreateOwned(AOwner: TFaceGroups); override;
Public destructor Destroy; override;
Public function FindSplitPlane(triangleSplitCost: Single = 1; triangleImbalanceCost: Single = 0.5): THmgPlane;
Protected function AddLerp(iA, iB: Integer; fB, fA: Single): Integer;
Protected function AddLerpIfDistinct(iA, iB, iMid: Integer): Integer;
Public procedure CollectBackToFront(var bsprci: TBSPRenderContextInfo);
Public procedure CollectFrontToBack(var bsprci: TBSPRenderContextInfo);
Public procedure CollectNoSort(var bsprci: TBSPRenderContextInfo);
Public procedure EvaluateSplitPlane(const splitPlane: THmgPlane; var nbTriangleSplit: Integer; var nbPositiveTriangles: Integer; var nbNegativeTriangles: Integer);
Public procedure FixTJunctions(const tJunctionsCandidates: TIntegerList);
Public procedure IsCulled(const bsprci: TBSPRenderContextInfo; var positive, negative: Boolean);
Public procedure PerformSplit(const splitPlane: THmgPlane; const maxTrianglesPerLeaf: Integer = MaxInt);

Properties

Public property Cluster: Integer read FCluster write FCluster;
Public property NegativeSubNodeIndex: Integer read FNegativeSubNodeIndex write FNegativeSubNodeIndex;
Public property PositiveSubNodeIndex: Integer read FPositiveSubNodeIndex write FPositiveSubNodeIndex;
Public property splitPlane: THmgPlane read FSplitPlane write FSplitPlane;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLBumpmapHDS

Unit GLBumpmapHDS

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Implements a HDS that automatically generates an elevation bumpmap.<p>

The object-space elevation bumpmap can be used for dynamic terrain lighting.<p> A bumpmap texture is generated for each terrain tile, and placed into a TGLMaterialLibrary.

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>22/01/10 - Yar - Added GLTextureFormat to uses <li>13/02/07 - LIN- Thread-safe, for use with TGLAsyncHDS Also takes advantage of texture-coodrinates, calculated by HeightDataSource <li>02/02/07 - LIN- GLBumpmapHDS is now derived from THeightDataSourceFilter. HeightDataSource replaces ElevationHDS. (More efficient, since it no longer has to copy and release the entire Source HDS's THeightData object.) <li>01/02/07 - LIN- Added 'MaxTextures' property. if the MaterialLibrary.Materials.Count > MaxTextures, then unused textures are deleted. Set MaxTextures=0 to disable Auto-deletes, and manage your normal-map textures manually.

WARNING: If you use THeightData.MaterialName, instead of THeightData.LibMaterial, then HeightData does NOT register the texture as being used. So make sure MaxTextures=0 if you use MaterialName.

<li>25/01/07 - LIN- Replaced 'StartPreparingData' and 'GenerateBumpmap' functions. Now supports a TGLBitmap with multiple tiles. Now works with HeightTileFileHDS. World texture coordinates for individual textures are now calculated, (TGLLibMaterial.TextureOffset and TGLLibMaterial.TextureScale) Bugfix: Terrain position no longer jumps when InfiniteWrap is turned off. <li>15/04/04 - EG - Fixed hdsNone support (Phil Scadden) <li>20/03/04 - EG - Works, reasonnably seamless but still quite inefficient <li>20/02/04 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBumpmapHDS |

Types

TNewTilePreparedEvent = procedure(Sender: TGLBumpmapHDS; heightData: THeightData; normalMapMaterial: TGLLibMaterial) of object;

Description

Types

TNewTilePreparedEvent = procedure(Sender: TGLBumpmapHDS; heightData: THeightData; normalMapMaterial: TGLLibMaterial) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLBumpmapHDS: Class TGLBumpmapHDS

Class TGLBumpmapHDS

Unit

GLBumpmapHDS

Declaration

type TGLBumpmapHDS = class(THeightDataSourceFilter)

Description

An Height Data Source that generates elevation bumpmaps automatically.<p> The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where bumpmaps will be placed.

Hierarchy

  • TComponent
  • THeightDataSource
  • THeightDataSourceFilter
  • TGLBumpmapHDS

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function StoreBumpScale: Boolean;
Public | procedure GenerateNormalMap(heightData: THeightData; normalMap: TGLBitmap32; scale: Single);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure PreparingData(heightData: THeightData); override;
Public | procedure Release(aHeightData: THeightData); override;
Public | procedure TrimTextureCache(MaxTextureCount: integer);
Protected | procedure SetBumpmapLibrary(const val: TGLMaterialLibrary);
Protected | procedure SetBumpScale(const val: Single);
Protected | procedure SetSubSampling(const val: Integer);
Protected | procedure Trim(MaxTextureCount: integer);

Properties

Published | property BumpmapLibrary: TGLMaterialLibrary read FBumpmapLibrary write SetBumpmapLibrary;
Published | property BumpScale: Single read FBumpScale write SetBumpScale stored StoreBumpScale;
Published | property MaxPoolSize;
Published | property MaxTextures: integer read FMaxTextures write FMaxTextures;
Published | property OnNewTilePrepared: TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;
Published | property OnSourceDataFetched;
Published | property SubSampling: Integer read FSubSampling write SetSubSampling default 1;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function StoreBumpScale: Boolean;
Public procedure GenerateNormalMap(heightData: THeightData; normalMap: TGLBitmap32; scale: Single);
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure PreparingData(heightData: THeightData); override;
Public procedure Release(aHeightData: THeightData); override;
Public procedure TrimTextureCache(MaxTextureCount: integer);
Protected procedure SetBumpmapLibrary(const val: TGLMaterialLibrary);
Protected procedure SetBumpScale(const val: Single);
Protected procedure SetSubSampling(const val: Integer);
Protected procedure Trim(MaxTextureCount: integer);

Properties

Published property BumpmapLibrary: TGLMaterialLibrary read FBumpmapLibrary write SetBumpmapLibrary;
Published property BumpScale: Single read FBumpScale write SetBumpScale stored StoreBumpScale;
Published property MaxPoolSize;
Published property MaxTextures: integer read FMaxTextures write FMaxTextures;

If MaxTextures>0 then the Bumpmap library is trimmed down to size whenever the texture count is larger than MaxTextures. The oldest, unused texture is trimmed first. However, if you used THeightData.MaterialName, instead of THeightData.LibMaterial, then the THeightData component does not register the texture as being used. So, if you use THeightData.MaterialName then make sure MaxTextures=0. If MaxTextures=0 or if treads(GLAsyncHDS) are used, then the texture cache is NOT trimmed automatically. You will have to manually trim the cache from the main thread, by calling 'TrimTextureCache'. (GLAsyncHDS.OnIdle is a good place.)

Published property OnNewTilePrepared: TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;
Published property OnSourceDataFetched;
Published property SubSampling: Integer read FSubSampling write SetSubSampling default 1;

Specifies the amount of subsampling for the bump texture.<p> This value must be a power of 2, and is used to divide the height tile resolution to determine the bump texture resolution (f.i. a tile size of 128 with a subsampling of 4 will result in textures of a resolution of 32x32. SubSampling won't allow texture resolution to get below 16x16 (minimal bumpmap resolution).

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLBumpShader

Unit GLBumpShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLBumpShader<p>

A shader that applies bump mapping.<p>

Notes: The normal map is expected to be the primary texture.<p>

The secondary texture is used for the diffuse texture, to enable set boDiffuseTexture2 in the BumpOptions property.<p>

The tertiary texture is used for the specular texture, to enable set boSpecularTexture3 in the BumpOptions property. The SpecularMode determines the specular highlight calculation (Blinn or Phong), smOff disables specular highlights in the shader.<p>

External tangent bump space expects tangent data under GL_TEXTURE1_ARB and binormal data under GL_TEXTURE2_ARB.<p>

The boUseSecondaryTexCoords bump option tells the shader to use the secondary texture coordinates for the diffuse and specular texture lookups.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Upgraded program hadles <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>31/03/07 - DaStr - Added $I GLScene.inc <li>25/02/07 - DaStr - Moved registration to GLSceneRegister.pas <li>15/04/05 - SG - Added parallax offset mapping for the BasicARBfp bump method (experimental) Height data is expected in the normal map alpha channel. <li>21/12/04 - SG - Added light attenutation support through the boLightAttenutation option in the BumpOptions property. <li>27/10/04 - SG - Added boUseSecondaryTexCoords option to BumpOptions <li>11/10/04 - SG - Added SpecularMode to define the specular highlight equation, Removed the boDisableSpecular bump option (depricated). <li>06/10/04 - SG - Added special functions for generating the ARB programs which replace the string constants. <li>02/10/04 - SG - Changed render order a little, minimum texture units is now 2 for dot3 texcombiner bump method. Changed vertex programs to accept local program params, now only 1 vertex and 1 fragment program is required for all lights. Vertex programs now apply the primary texture matrix. <li>30/09/04 - SG - Added fragment program logic, Added bmBasicARBFP bump method, bsTangentExternal bump space and associated ARB programs, Various name changes and fixes <li>28/09/04 - SG - Vertex programs now use ARB_position_invariant option. <li>29/06/04 - SG - Quaternion tangent space fix in tangent bump vertex program. <li>23/06/04 - SG - Added bsTangent option to TBumpSpace, Added tangent space light vector vertex program. <li>22/06/04 - SG - Creation. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBumpShader |

Types

TBumpMethod = (...);
TBumpSpace = (...);
TBumpOption = (...);
TBumpOptions = set of TBumpOption;
TSpecularMode = (...);

Description

Types

TBumpMethod = (...);
Values
  • bmDot3TexCombiner:
  • bmBasicARBFP:
TBumpSpace = (...);
Values
  • bsObject:
  • bsTangentExternal:
  • bsTangentQuaternion:
TBumpOption = (...);
Values
  • boDiffuseTexture2:
  • boSpecularTexture3:
  • boUseSecondaryTexCoords:
  • boLightAttenuation:
  • boParallaxMapping:
TBumpOptions = set of TBumpOption;
TSpecularMode = (...);
Values
  • smOff:
  • smBlinn:
  • smPhong:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLBumpShader: Class TGLBumpShader

Class TGLBumpShader

Unit

GLBumpShader

Declaration

type TGLBumpShader = class(TGLShader)

Description

A generic bump shader.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLBumpShader

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Public | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected | procedure DeleteFragmentPrograms;
Protected | procedure DeleteVertexPrograms;
Protected | procedure Loaded; override;
Protected | procedure SetBumpMethod(const Value: TBumpMethod);
Protected | procedure SetBumpOptions(const Value: TBumpOptions);
Protected | procedure SetBumpSpace(const Value: TBumpSpace);
Protected | procedure SetDesignTimeEnabled(const Value: Boolean);
Protected | procedure SetParallaxOffset(const Value: Single);
Protected | procedure SetSpecularMode(const Value: TSpecularMode);

Properties

Published | property BumpMethod: TBumpMethod read FBumpMethod write SetBumpMethod;
Published | property BumpOptions: TBumpOptions read FBumpOptions write SetBumpOptions;
Published | property BumpSpace: TBumpSpace read FBumpSpace write SetBumpSpace;
Published | property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled;
Published | property ParallaxOffset: Single read FParallaxOffset write SetParallaxOffset;
Published | property SpecularMode: TSpecularMode read FSpecularMode write SetSpecularMode;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Public procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected procedure DeleteFragmentPrograms;
Protected procedure DeleteVertexPrograms;
Protected procedure Loaded; override;
Protected procedure SetBumpMethod(const Value: TBumpMethod);
Protected procedure SetBumpOptions(const Value: TBumpOptions);
Protected procedure SetBumpSpace(const Value: TBumpSpace);
Protected procedure SetDesignTimeEnabled(const Value: Boolean);
Protected procedure SetParallaxOffset(const Value: Single);
Protected procedure SetSpecularMode(const Value: TSpecularMode);

Properties

Published property BumpMethod: TBumpMethod read FBumpMethod write SetBumpMethod;
Published property BumpOptions: TBumpOptions read FBumpOptions write SetBumpOptions;
Published property BumpSpace: TBumpSpace read FBumpSpace write SetBumpSpace;
Published property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled;
Published property ParallaxOffset: Single read FParallaxOffset write SetParallaxOffset;
Published property SpecularMode: TSpecularMode read FSpecularMode write SetSpecularMode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLCadencer

Unit GLCadencer

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLCadencer<p>

Cadencing composant for GLScene (ease Progress processing)<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: restored GetCurrenttime instead of GetCurrentTime <li>07/08/11 - Yar - Added OnTotalProgress event, which happens after all iterations with fixed delta time (thanks Controller) <li>06/02/11 - Predator - Improved TGLCadencer for Lazarus <li>29/11/10 - Yar - Changed TASAPHandler.FMessageTime type to unsigned (thanks olkondr) <li>21/11/09 - DaStr - Bugfixed FSubscribedCadenceableComponents (thanks Roshal Sasha) <li>09/11/09 - DaStr - Improved FPC compatibility (thanks Predator) (BugtrackerID = 2893580) <li>21/09/07 - DaStr - Added TGLCadencer.SetCurrentTime() <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTracekrID=1681585) <li>02/08/04 - LR, YHC - BCB corrections: changed GetCurrentTime to GetCurrenttime <li>28/06/04 - LR - Added some ifdef Win32 for Linux <li>20/10/03 - EG - Fixed issues about cadencer destruction <li>29/08/03 - EG - Added MinDeltaTime and FixedDeltaTime <li>21/08/03 - EG - Fixed Application.OnIdle reset bug (Solerman Kaplon) <li>04/07/03 - EG - Improved TimeMultiplier transitions (supports zero) <li>06/06/03 - EG - Added cmApplicationIdle Mode <li>19/05/03 - EG - Added Reset (Roberto Bussola) <li>04/03/02 - EG - Added SetTimeMultiplier <li>01/07/02 - EG - Added TGLCadencedComponent <li>05/12/01 - EG - Fix in subscription mechanism (D6 IDE freezes gone?) <li>30/11/01 - EG - Added IsBusy (thx Chris S) <li>08/09/01 - EG - Added MaxDeltaTime limiter <li>23/08/01 - EG - No more "deprecated" warning for Delphi6 <li>12/08/01 - EG - Protection against "timer flood" <li>19/07/01 - EG - Fixed Memory Leak in RegisterASAPCadencer, Added speed limiter TASAPHandler.WndProc <li>01/02/01 - EG - Fixed "Freezing" when Enabled set to False <li>08/10/00 - EG - Added TASAPHandler to support multiple ASAP cadencers <li>19/06/00 - EG - Fixed TGLCadencer.Notification <li>14/04/00 - EG - Minor fixes <li>13/04/00 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCadencer |
Class TGLCustomCadencedComponent |
Class TGLCadencedComponent |

Types

TGLCadencerMode = (...);
TGLCadencerTimeReference = (...);

Description

Types

TGLCadencerMode = (...);

Determines how the TGLCadencer operates.<p> - cmManual : you must trigger progress manually (in your code)<br> - cmASAP : progress is triggered As Soon As Possible after a previous progress (uses windows messages). - cmApplicationIdle : will hook Application.OnIdle, this will overwrite any previous event handle, and only one cadencer may be in this mode.

Values
  • cmManual:
  • cmASAP:
  • cmApplicationIdle:
TGLCadencerTimeReference = (...);

Determines which time reference the TGLCadencer should use.<p> - cmRTC : the Real Time Clock is used (precise over long periods, but not accurate to the millisecond, may limit your effective framerate to less than 50 FPS on some systems)<br> - cmPerformanceCounter : the windows performance counter is used (nice precision, may derive over long periods, this is the default option as it allows the smoothest animation on fast systems)<br> - cmExternal : the CurrentTime property is used

Values
  • cmRTC:
  • cmPerformanceCounter:
  • cmExternal:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLCadencer: Class TGLCadencer

Class TGLCadencer

Unit

GLCadencer

Declaration

type TGLCadencer = class(TComponent)

Description

This component allows auto-progression of animation.<p> Basicly dropping this component and linking it to your TGLScene will send it real-time progression events (time will be measured in seconds) while keeping the CPU 100% busy if possible (ie. if things change in your scene).<p> The progression time (the one you'll see in you progression events) is calculated using (CurrentTime-OriginTime)*TimeMultiplier, CurrentTime being either manually or automatically updated using TimeReference (setting CurrentTime does NOT trigger progression).

Hierarchy

  • TComponent
  • TGLCadencer

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetCurrenttime: Double;
Public | function IsBusy: Boolean;
Protected | function GetRawReferenceTime: Double;
Protected | function StoreTimeMultiplier: Boolean;
Public | procedure Progress;
Public | procedure Reset;
Public | procedure Subscribe(aComponent: TGLCadenceAbleComponent);
Public | procedure UnSubscribe(aComponent: TGLCadenceAbleComponent);
Protected | procedure Loaded; override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure OnIdleEvent(Sender: TObject; var Done: Boolean);
Protected | procedure RestartASAP;
Protected | procedure SetEnabled(const val: Boolean);
Protected | procedure SetMode(const val: TGLCadencerMode);
Protected | procedure SetScene(const val: TGLScene);
Protected | procedure SetTimeMultiplier(const val: Double);
Protected | procedure SetTimeReference(const val: TGLCadencerTimeReference);

Properties

Public | property CurrentTime: Double read FCurrentTime write SetCurrentTime;
Published | property Enabled: Boolean read FEnabled write SetEnabled default True;
Published | property FixedDeltaTime: Double read FFixedDeltaTime write FFixedDeltaTime;
Published | property MaxDeltaTime: Double read FMaxDeltaTime write FMaxDeltaTime;
Published | property MinDeltaTime: Double read FMinDeltaTime write FMinDeltaTime;
Published | property Mode: TGLCadencerMode read FMode write SetMode default cmASAP;
Published | property OnProgress: TGLProgressEvent read FOnProgress write FOnProgress;
Published | property OnTotalProgress : TGLProgressEvent read FOnTotalProgress write FOnTotalProgress;
Public | property OriginTime: Double read FOriginTime write FOriginTime;
Published | property Scene: TGLScene read FScene write SetScene;
Published | property SleepLength: Integer read FSleepLength write FSleepLength default -1;
Published | property TimeMultiplier: Double read FTimeMultiplier write SetTimeMultiplier stored StoreTimeMultiplier;
Published | property TimeReference: TGLCadencerTimeReference read FTimeReference write SetTimeReference default cmPerformanceCounter;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function GetCurrenttime: Double;

Adjusts CurrentTime if necessary, then returns its value.

Public function IsBusy: Boolean;

Returns True if a "Progress" is underway.<p> Be aware that as long as IsBusy is True, the Cadencer may be sending messages and progression calls to cadenceable components and scenes.

Protected function GetRawReferenceTime: Double;

Returns raw ref time (no multiplier, no offset)

Protected function StoreTimeMultiplier: Boolean;
Public procedure Progress;

Allows to manually trigger a progression.<p> Time stuff is handled automatically.<br> If cadencer is disabled, this functions does nothing.

Public procedure Reset;

Reset the time parameters and returns to zero.<p>

Public procedure Subscribe(aComponent: TGLCadenceAbleComponent);
Public procedure UnSubscribe(aComponent: TGLCadenceAbleComponent);
Protected procedure Loaded; override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure OnIdleEvent(Sender: TObject; var Done: Boolean);
Protected procedure RestartASAP;
Protected procedure SetEnabled(const val: Boolean);
Protected procedure SetMode(const val: TGLCadencerMode);
Protected procedure SetScene(const val: TGLScene);
Protected procedure SetTimeMultiplier(const val: Double);
Protected procedure SetTimeReference(const val: TGLCadencerTimeReference);

Properties

Public property CurrentTime: Double read FCurrentTime write SetCurrentTime;

Current time (manually or automatically set, see TimeReference).

Published property Enabled: Boolean read FEnabled write SetEnabled default True;

Enables/Disables cadencing.<p> Disabling won't cause a jump when restarting, it is working like a play/pause (ie. may modify OriginTime to keep things smooth).

Published property FixedDeltaTime: Double read FFixedDeltaTime write FFixedDeltaTime;

Fixed time-step value for progression events.<p> If superior to zero, progression steps will happen with that fixed delta time. The progression remains time based, so zero to N events may be fired depending on the actual deltaTime (if deltaTime is inferior to FixedDeltaTime, no event will be fired, if it is superior to two times FixedDeltaTime, two events will be fired, etc.).<br> This option allows to use fixed time steps in simulations (while the animation and rendering itself may happen at a lower or higher framerate).

Published property MaxDeltaTime: Double read FMaxDeltaTime write FMaxDeltaTime;

Maximum value for deltaTime in progression events.<p> If null or negative, no max deltaTime is defined, otherwise, whenever an event whose actual deltaTime would be superior to MaxDeltaTime occurs, deltaTime is clamped to this max, and the extra time is hidden by the cadencer (it isn't visible in CurrentTime either).<br> This option allows to limit progression rate in simulations where high values would result in errors/random behaviour.

Published property MinDeltaTime: Double read FMinDeltaTime write FMinDeltaTime;

Minimum value for deltaTime in progression events.<p> If superior to zero, this value specifies the minimum time step between two progression events.<br> This option allows to limit progression rate in simulations where low values would result in errors/random behaviour.

Published property Mode: TGLCadencerMode read FMode write SetMode default cmASAP;

Adjusts how progression events are triggered.<p> See TGLCadencerMode.

Published property OnProgress: TGLProgressEvent read FOnProgress write FOnProgress;

Happens AFTER scene was progressed.

Published property OnTotalProgress : TGLProgressEvent read FOnTotalProgress write FOnTotalProgress;

Happens AFTER all iterations with fixed delta time.

Public property OriginTime: Double read FOriginTime write FOriginTime;

Value soustracted to current time to obtain progression time.

Published property Scene: TGLScene read FScene write SetScene;

The TGLScene that will be cadenced (progressed).

Published property SleepLength: Integer read FSleepLength write FSleepLength default -1;

Allows relinquishing time to other threads/processes.<p> A "sleep" is issued BEFORE each progress if SleepLength>=0 (see help for the "sleep" procedure in delphi for details).

Published property TimeMultiplier: Double read FTimeMultiplier write SetTimeMultiplier stored StoreTimeMultiplier;

Multiplier applied to the time reference.<p> Zero isn't an allowed value, and be aware that if negative values are accepted, they may not be supported by other GLScene objects.<br> Changing the TimeMultiplier will alter OriginTime.

Published property TimeReference: TGLCadencerTimeReference read FTimeReference write SetTimeReference default cmPerformanceCounter;

Defines how CurrentTime is updated.<p> See TGLCadencerTimeReference.<br> Dynamically changeing the TimeReference may cause a "jump".

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLCadencer: Class TGLCustomCadencedComponent

Class TGLCustomCadencedComponent

Unit

GLCadencer

Declaration

type TGLCustomCadencedComponent = class(TGLUpdateAbleComponent)

Description

Adds a property to connect/subscribe to a cadencer.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent

Overview

Methods

Public | destructor Destroy; override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetCadencer(const val: TGLCadencer);

Properties

Protected property Cadencer: TGLCadencer read FCadencer write SetCadencer;

Description

Methods

Public destructor Destroy; override;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetCadencer(const val: TGLCadencer);

Properties

Protected property Cadencer: TGLCadencer read FCadencer write SetCadencer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLCadencer: Class TGLCadencedComponent

Class TGLCadencedComponent

Unit

GLCadencer

Declaration

type TGLCadencedComponent = class(TGLCustomCadencedComponent)

Description

no description available, TGLCustomCadencedComponent description follows

Adds a property to connect/subscribe to a cadencer.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent

Overview

Properties

Published property Cadencer;

Description

Properties

Published property Cadencer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLCameraController

Unit GLCameraController

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLCameraController |
Class TGLCameraJobList |
Class TGLCameraJob |
Class TGLMoveToPosJob |
Class TGLZoomToDistanceJob |
Class TGLOrbitToPosJob |
Class TGLSmoothOrbitToPos |
Class TGLOrbitToPosAdvJob |
Class TGLSmoothOrbitToPosAdvJob |
Class TGLCameraController |

Types

TGLCameraJobEvent = procedure(Sender : TGLCameraJob) of object;

Description

Types

TGLCameraJobEvent = procedure(Sender : TGLCameraJob) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLCameraController: Class EGLCameraController

Class EGLCameraController

Unit

GLCameraController

Declaration

type EGLCameraController = class(Exception)

Description

Hierarchy

  • Exception
  • EGLCameraController
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLCameraController: Class TGLCameraJobList

Class TGLCameraJobList

Unit

GLCameraController

Declaration

type TGLCameraJobList = class(TObjectList)

Description

no description available, TObjectList description follows

Hierarchy

  • TObject
  • TObjectList
  • TGLCameraJobList

Overview

Methods

Public | constructor Create(AController: TGLCameraController);
Public | function Add(ACameraJob: TGLCameraJob): integer;
Public | function First: TGLCameraJob;
Public | function Last: TGLCameraJob;

Properties

Public property Items[const AIndex: integer]: TGLCameraJob read GetCameraJob write SetCameraJob;

Description

Methods

Public constructor Create(AController: TGLCameraController);
Public function Add(ACameraJob: TGLCameraJob): integer;
Public function First: TGLCameraJob;
Public function Last: TGLCameraJob;

Properties

Public property Items[const AIndex: integer]: TGLCameraJob read GetCameraJob write SetCameraJob;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLCameraController: Class TGLCameraJob

Class TGLCameraJob

Unit

GLCameraController

Declaration

type TGLCameraJob = class(TObject)

Description

Hierarchy

  • TObject
  • TGLCameraJob

Overview

Fields

Protected | FAbort: boolean;
Protected | FInit: boolean;
Protected | FRunning: Boolean;
Protected | FElapsedTime: Double;
Protected | FDeltaTime: Double;
Protected | FStartTime: Double;
Protected | FProceedTime: Double;

Methods

Public | constructor Create(const AJoblist : TGLCameraJobList); virtual;
Public | destructor Destroy; override;
Public | procedure Abort;
Public | procedure Init; virtual; abstract;
Public | procedure Step; virtual; abstract;

Properties

Public | property ElapsedTime: Double read FElapsedTime write FElapsedTime;
Public | property ProceedTime: Double read FProceedTime write FProceedTime;
Public | property Running: Boolean read FRunning write FRunning;
Public | property StartTime: Double read FStartTime write FStartTime;

Description

Fields

Protected FAbort: boolean;
Protected FInit: boolean;
Protected FRunning: Boolean;
Protected FElapsedTime: Double;
Protected FDeltaTime: Double;
Protected FStartTime: Double;
Protected FProceedTime: Double;

Methods

Public constructor Create(const AJoblist : TGLCameraJobList); virtual;
Public destructor Destroy; override;
Public procedure Abort;
Public procedure Init; virtual; abstract;
Public procedure Step; virtual; abstract;

Properties

Public property ElapsedTime: Double read FElapsedTime write FElapsedTime;
Public property ProceedTime: Double read FProceedTime write FProceedTime;
Public property Running: Boolean read FRunning write FRunning;
Public property StartTime: Double read FStartTime write FStartTime;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLCameraController: Class TGLMoveToPosJob

Class TGLMoveToPosJob

Unit

GLCameraController

Declaration

type TGLMoveToPosJob = class(TGLCameraJob)

Description

no description available, TGLCameraJob description follows

Hierarchy

  • TObject
  • TGLCameraJob
  • TGLMoveToPosJob

Overview

Fields

Public | X: Double;
Public | Y: Double;
Public | Z: Double;
Public | Time: Double;

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Properties

Public | property FinalPos: TVector read FFinalPos;
Public | property InitialPos: TVector read FInitialPos;

Description

Fields

Public X: Double;
Public Y: Double;
Public Z: Double;
Public Time: Double;

Methods

Public procedure Init; override;
Public procedure Step; override;

Properties

Public property FinalPos: TVector read FFinalPos;
Public property InitialPos: TVector read FInitialPos;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLCameraController: Class TGLZoomToDistanceJob

Class TGLZoomToDistanceJob

Unit

GLCameraController

Declaration

type TGLZoomToDistanceJob = class(TGLCameraJob)

Description

no description available, TGLCameraJob description follows

Hierarchy

  • TObject
  • TGLCameraJob
  • TGLZoomToDistanceJob

Overview

Fields

Public | Distance: Double;
Public | Time: Double;

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Properties

Public | property FinalPos: TVector read FFinalPos;
Public | property InitialPos: TVector read FInitialPos;

Description

Fields

Public Distance: Double;
Public Time: Double;

Methods

Public procedure Init; override;
Public procedure Step; override;

Properties

Public property FinalPos: TVector read FFinalPos;
Public property InitialPos: TVector read FInitialPos;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLCameraController: Class TGLOrbitToPosJob

Class TGLOrbitToPosJob

Unit

GLCameraController

Declaration

type TGLOrbitToPosJob = class(TGLCameraJob)

Description

no description available, TGLCameraJob description follows

Hierarchy

  • TObject
  • TGLCameraJob
  • TGLOrbitToPosJob

Overview

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Properties

Public | property CameraUpVector: TVector read FCameraUpVector;
Public | property FinalPos: TVector read FFinalPos;
Public | property RotateSpeed: TVector2f read FRotateSpeed;
Public | property TargetPosition: TVector read FTargetPosition;
Public | property Time: Double read FTime;

Description

Methods

Public procedure Init; override;
Public procedure Step; override;

Properties

Public property CameraUpVector: TVector read FCameraUpVector;
Public property FinalPos: TVector read FFinalPos;
Public property RotateSpeed: TVector2f read FRotateSpeed;
Public property TargetPosition: TVector read FTargetPosition;
Public property Time: Double read FTime;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLCameraController: Class TGLSmoothOrbitToPos

Class TGLSmoothOrbitToPos

Unit

GLCameraController

Declaration

type TGLSmoothOrbitToPos = class(TGLOrbitToPosJob)

Description

no description available, TGLOrbitToPosJob description follows
no description available, TGLCameraJob description follows

Hierarchy

  • TObject
  • TGLCameraJob
  • TGLOrbitToPosJob
  • TGLSmoothOrbitToPos

Overview

Methods

Public | constructor Create(const AJoblist : TGLCameraJobList); override;
Public | procedure Step; override;

Properties

Public | property CutoffAngle: Single read FCutoffAngle write FCutoffAngle;
Public | property NeedToRecalculateZoom: Boolean read FNeedToRecalculateZoom write FNeedToRecalculateZoom;

Description

Methods

Public constructor Create(const AJoblist : TGLCameraJobList); override;
Public procedure Step; override;

Properties

Public property CutoffAngle: Single read FCutoffAngle write FCutoffAngle;
Public property NeedToRecalculateZoom: Boolean read FNeedToRecalculateZoom write FNeedToRecalculateZoom;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:11


GLScene v.1.1.2: GLCameraController: Class TGLOrbitToPosAdvJob

Class TGLOrbitToPosAdvJob

Unit

GLCameraController

Declaration

type TGLOrbitToPosAdvJob = class(TGLCameraJob)

Description

no description available, TGLCameraJob description follows

Hierarchy

  • TObject
  • TGLCameraJob
  • TGLOrbitToPosAdvJob

Overview

Fields

Public | X: Double;
Public | Y: Double;
Public | Z: Double;
Public | Time: Double;
Public | PreferUpAxis: Boolean;

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Properties

Public | property FinalPos: TVector read FFinalPos;
Public | property InitialDir: TVector read FInitialDir;
Public | property InitialPos: TVector read FInitialPos;
Public | property InitialUp: TVector read FInitialUp;

Description

Fields

Public X: Double;
Public Y: Double;
Public Z: Double;
Public Time: Double;
Public PreferUpAxis: Boolean;

Methods

Public procedure Init; override;
Public procedure Step; override;

Properties

Public property FinalPos: TVector read FFinalPos;
Public property InitialDir: TVector read FInitialDir;
Public property InitialPos: TVector read FInitialPos;
Public property InitialUp: TVector read FInitialUp;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCameraController: Class TGLSmoothOrbitToPosAdvJob

Class TGLSmoothOrbitToPosAdvJob

Unit

GLCameraController

Declaration

type TGLSmoothOrbitToPosAdvJob = class(TGLOrbitToPosAdvJob)

Description

no description available, TGLOrbitToPosAdvJob description follows
no description available, TGLCameraJob description follows

Hierarchy

  • TObject
  • TGLCameraJob
  • TGLOrbitToPosAdvJob
  • TGLSmoothOrbitToPosAdvJob

Overview

Methods

Public | procedure Init; override;
Public | procedure Step; override;

Description

Methods

Public procedure Init; override;
Public procedure Step; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCameraController: Class TGLCameraController

Class TGLCameraController

Unit

GLCameraController

Declaration

type TGLCameraController = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLCameraController

Overview

Methods

Public | constructor Create(AOwner:TComponent); override;
Public | destructor Destroy; override;
Public | function MoveToPos(x,y,z,time:double): TGLMoveToPosJob;
Public | function OrbitToPos(x,y,z,time:double): TGLOrbitToPosJob;
Public | function OrbitToPosAdvanced(x,y,z,time:double; PreferUpAxis: Boolean = True): TGLOrbitToPosAdvJob;
Public | function OrbitToPosAdvancedSmooth(const x,y,z, time: double; const ASmoothNavigator: TGLNavigatorSmoothChangeVector; const PreferUpAxis: Boolean = True): TGLSmoothOrbitToPosAdvJob;
Public | function OrbitToPosSmooth(const ATargetPosition: TVector; const ATime: Double; const ASmoothNavigator: TGLNavigatorSmoothChangeVector; const AFNeedToRecalculateZoom: Boolean; const ACameraUpVector: PVector = nil): TGLSmoothOrbitToPos;
Public | function ZoomToDistance(Distance,Time:double): TGLZoomToDistanceJob;
Public | procedure SafeOrbitAndZoomToPos(x,y,z:double);
Public | procedure Step(const deltaTime, newTime: Double);
Public | procedure StopMovement;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property Camera: TGLBaseSceneObject read FCamera write SetCamera;
Public | property CameraJobList: TGLCameraJobList read FCameraJobList;
Published | property CameraTarget: TGLBaseSceneObject read FCameraTarget write SetCameraTarget;
Published | property OnJobAdded : TGLCameraJobEvent read FOnJobAdded write SetOnJobAdded;
Published | property OnJobFinished : TGLCameraJobEvent read FOnJobFinished write SetOnJobFinished;
Published | property OnJobStep : TGLCameraJobEvent read FOnJobStep write SetOnJobStep;
Published | property soSafeDistance: double read FsoSafeDist write FsoSafeDist;
Published | property soTimeToOrbit: double read FsoTimeToOrbit write FsoTimeToOrbit;
Published | property soTimeToSafePlacement: double read FsoTimeToSafePlacement write FsoTimeToSafePlacement;
Published | property soTimeToZoomBackIn: double read FsoTimeToZoomBackIn write FsoTimeToZoomBackIn;

Description

Methods

Public constructor Create(AOwner:TComponent); override;
Public destructor Destroy; override;
Public function MoveToPos(x,y,z,time:double): TGLMoveToPosJob;
Public function OrbitToPos(x,y,z,time:double): TGLOrbitToPosJob;
Public function OrbitToPosAdvanced(x,y,z,time:double; PreferUpAxis: Boolean = True): TGLOrbitToPosAdvJob;
Public function OrbitToPosAdvancedSmooth(const x,y,z, time: double; const ASmoothNavigator: TGLNavigatorSmoothChangeVector; const PreferUpAxis: Boolean = True): TGLSmoothOrbitToPosAdvJob;
Public function OrbitToPosSmooth(const ATargetPosition: TVector; const ATime: Double; const ASmoothNavigator: TGLNavigatorSmoothChangeVector; const AFNeedToRecalculateZoom: Boolean; const ACameraUpVector: PVector = nil): TGLSmoothOrbitToPos;
Public function ZoomToDistance(Distance,Time:double): TGLZoomToDistanceJob;
Public procedure SafeOrbitAndZoomToPos(x,y,z:double);
Public procedure Step(const deltaTime, newTime: Double);
Public procedure StopMovement;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published property Camera: TGLBaseSceneObject read FCamera write SetCamera;
Public property CameraJobList: TGLCameraJobList read FCameraJobList;
Published property CameraTarget: TGLBaseSceneObject read FCameraTarget write SetCameraTarget;
Published property OnJobAdded : TGLCameraJobEvent read FOnJobAdded write SetOnJobAdded;
Published property OnJobFinished : TGLCameraJobEvent read FOnJobFinished write SetOnJobFinished;
Published property OnJobStep : TGLCameraJobEvent read FOnJobStep write SetOnJobStep;
Published property soSafeDistance: double read FsoSafeDist write FsoSafeDist;
Published property soTimeToOrbit: double read FsoTimeToOrbit write FsoTimeToOrbit;
Published property soTimeToSafePlacement: double read FsoTimeToSafePlacement write FsoTimeToSafePlacement;
Published property soTimeToZoomBackIn: double read FsoTimeToZoomBackIn write FsoTimeToZoomBackIn;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCanvas

Unit GLCanvas

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLCanvas<p>

Implements a basic Canvas-like interface over for OpenGL.<p> This class can be used for generic OpenGL applications and has no dependencies to the GLScene core units (only to base units).<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records, Replaced direct access to PenAlpha property with GetPenAlpha method <li>05/02/11 - Yar - Now PenColor setter always direct set color <li>03/10/10 - Yar - Added RoundRect (thanks eric129) <li>21/09/10 - Yar - Added Arc, ArcTo (thanks µAlexx) <li>03/09/10 - Yar - Added FillRectGradient, FillEllipseGradient (thanks µAlexx) <li>23/08/10 - Yar - Replaced OpenGL1x functions to OpenGLAdapter <li>04/04/10 - Yar - Fixes after GLState revision <li>07/11/09 - DaStr - Some cosmetic fixes. Overloaded TGLCanvas.EllipseBB(), TGLCanvas.Ellipse(), TGLCanvas.FillEllipse() <li>31/07/07 - DaStr - Added missing StopPrimitive call to TGLCanvas.FillRect (Bugtracker ID = 1775528) <li>06/06/07 - DaStr - Removed ConvertColorVector and ConvertWinColor (now in GLColor.pas) Added GLColor to uses (BugtrackerID = 1732211) Removed TColor declaration (now in GLCrossPlatform.pas) <li>02/08/04 - LR, YHC - BCB corrections: used record instead array Replaced direct access of some properties by a getter and a setter <li>08/07/04 - LR - Replace Graphics and TPoint by GLCrossPlatform for Linux <li>13/01/04 - EG - Polyline/Polygon fix <li>07/05/03 - EG - SetPenWidth now correctly stops the primitive <li>08/01/03 - EG - StopPrimitive now public <li>09/12/02 - EG - Now properly disables fog <li>20/11/02 - EG - Now uses Types/Windows TPoint (D5 & D6 tested only) <li>01/10/02 - EG - Added Polygon & Polyline <li>04/03/02 - EG - Added FrameRect and FillRect <li>31/01/02 - EG - Texture3D/CubeMap only disabled if supported <li>24/01/02 - EG - Added PenAlpha <li>19/01/02 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCanvas |

Types

TArcDirection = (...);

Description

Types

TArcDirection = (...);
Values
  • adCounterClockWise:
  • adClockWise:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCanvas: Class TGLCanvas

Class TGLCanvas

Unit

GLCanvas

Declaration

type TGLCanvas = class(TObject)

Description

A simple Canvas-like interface for OpenGL.<p> This class implements a small "shell" for 2D operations in OpenGL, it operates over the current OpenGL context and provides methods for drawing lines, ellipses and points.<br> This class is typically used by creating an instance, using it for drawing, and freeing the instance. When drawing (0, 0) is the top left corner.<br> All coordinates are internally maintained with floating point precision.<p> Several states are cached and it is of primary importance not to invoke OpenGL directly throughout the life of an instance (at the cost of unespected behaviour).

Hierarchy

  • TObject
  • TGLCanvas

Overview

Methods

Public | constructor Create(bufferSizeX, bufferSizeY: Integer; const baseTransform: TMatrix); overload;
Public | constructor Create(bufferSizeX, bufferSizeY: Integer); overload;
Public | destructor Destroy; override;
Protected | function GetPenAlpha: Single;
Public | procedure Arc(const x1, y1, x2, y2, x3, y3, x4, y4: Integer); overload;
Public | procedure Arc(const x1, y1, x2, y2, x3, y3, x4, y4: Single); overload;
Public | procedure Arc(const x1, y1, x2, y2: Single; AngleBegin, AngleEnd: Single); overload;
Public | procedure ArcTo(const x1, y1, x2, y2, x3, y3, x4, y4: Single); overload;
Public | procedure ArcTo(const x1, y1, x2, y2: Single; AngleBegin, AngleEnd: Single); overload;
Public | procedure ArcTo(const x1, y1, x2, y2, x3, y3, x4, y4: Integer); overload;
Public | procedure Ellipse(const x, y: Single; const Radius: Single); overload;
Public | procedure Ellipse(const x, y: Single; const xRadius, yRadius: Single); overload;
Public | procedure Ellipse(const x, y: Integer; const xRadius, yRadius: Single); overload;
Public | procedure EllipseBB(const x1, y1, x2, y2: Single); overload;
Public | procedure EllipseBB(const x1, y1, x2, y2: Integer); overload;
Public | procedure FillEllipse(const x, y: Integer; const xRadius, yRadius: Single); overload;
Public | procedure FillEllipse(const x, y: Single; const Radius: Single); overload;
Public | procedure FillEllipse(const x, y: Single; const xRadius, yRadius: Single); overload;
Public | procedure FillEllipseGradient(const x, y, xRadius, yRadius: Single; const edgeColor: TColorVector); overload;
Public | procedure FillEllipseGradient(const x, y, Radius: Single; const edgeColor: TColorVector); overload;
Public | procedure FillEllipseGradient(const x, y: Integer; const xRadius, yRadius: Integer; const edgeColor: TColorVector); overload;
Public | procedure FillRect(const x1, y1, x2, y2: Single); overload;
Public | procedure FillRect(const x1, y1, x2, y2: Integer); overload;
Public | procedure FillRectGradient(const x1, y1, x2, y2: Integer; const x1y1Color, x2y1Color, x2y2Color, x1y2Color: TColorVector); overload;
Public | procedure FillRectGradient(const x1, y1, x2, y2: Single; const x1y1Color, x2y1Color, x2y2Color, x1y2Color: TColorVector); overload;
Public | procedure FrameRect(const x1, y1, x2, y2: Single); overload;
Public | procedure FrameRect(const x1, y1, x2, y2: Integer); overload;
Public | procedure InvertYAxis;
Public | procedure Line(const x1, y1, x2, y2: Single); overload;
Public | procedure Line(const x1, y1, x2, y2: Integer); overload;
Public | procedure LineTo(const x, y: Single); overload;
Public | procedure LineTo(const x, y: Integer); overload;
Public | procedure LineToRel(const x, y: Single); overload;
Public | procedure LineToRel(const x, y: Integer); overload;
Public | procedure MoveTo(const x, y: Integer); overload;
Public | procedure MoveTo(const x, y: Single); overload;
Public | procedure MoveToRel(const x, y: Single); overload;
Public | procedure MoveToRel(const x, y: Integer); overload;
Public | procedure PlotPixel(const x, y: Single); overload;
Public | procedure PlotPixel(const x, y: Integer); overload;
Public | procedure Polygon(const points: array of TGLPoint);
Public | procedure Polyline(const points: array of TGLPoint);
Public | procedure RoundRect(const x1, y1, x2, y2, xr, yr: Integer); overload;
Public | procedure RoundRect(const x1, y1, x2, y2, xr, yr: Single); overload;
Public | procedure StopPrimitive;
Protected | procedure BackupOpenGLStates;
Protected | procedure DrawArc(x1, y1, x2, y2: Single; AngleBegin, AngleEnd: Single; UpdateCurrentPos: Boolean); overload;
Protected | procedure DrawArc(x1, y1, x2, y2, x3, y3, x4, y4: Single; UpdateCurrentPos: Boolean); overload;
Protected | procedure EllipseVertices(x, y, xRadius, yRadius: Single);
Protected | procedure NormalizePoint(const x1, y1, x2, y2: Single; const x, y: Single; pX, pY: PSingle);
Protected | procedure SetPenAlpha(const val: Single);
Protected | procedure SetPenColor(const val: TColor);
Protected | procedure SetPenWidth(const val: Integer);
Protected | procedure StartPrimitive(const primitiveType: Integer);
Protected | procedure SwapSingle(pX, pY: PSingle);

Properties

Public | property ArcDirection: TArcDirection read FArcDirection write FArcDirection;
Public | property CanvasSizeX: Integer read FBufferSizeX;
Public | property CanvasSizeY: Integer read FBufferSizeY;
Public | property PenAlpha : Single read GetPenAlpha write SetPenAlpha;
Public | property PenColor: TColor read FPenColor write SetPenColor;
Public | property PenWidth: Integer read FPenWidth write SetPenWidth;

Description

Methods

Public constructor Create(bufferSizeX, bufferSizeY: Integer; const baseTransform: TMatrix); overload;
Public constructor Create(bufferSizeX, bufferSizeY: Integer); overload;
Public destructor Destroy; override;
Protected function GetPenAlpha: Single;
Public procedure Arc(const x1, y1, x2, y2, x3, y3, x4, y4: Integer); overload;

Draw an elliptical arc.<p> The points (x1, y1) and (x2, y2) specify the bounding rectangle.<p> An ellipse formed by the specified bounding rectangle defines the curve of the arc.<p> The arc extends in the current drawing direction from the point where it intersects the radial from the center of the bounding rectangle to the (x3, y3) point.<p> The arc ends where it intersects the radial from the center of the bounding rectangle to the (x4, y4) point.<p> If the starting point and ending point are the same, a complete ellipse is drawn.<p> Use the ArcDirection property to get and set the current drawing direction for a device context.<p> The default drawing direction is counterclockwise.

Public procedure Arc(const x1, y1, x2, y2, x3, y3, x4, y4: Single); overload;
Public procedure Arc(const x1, y1, x2, y2: Single; AngleBegin, AngleEnd: Single); overload;
Public procedure ArcTo(const x1, y1, x2, y2, x3, y3, x4, y4: Single); overload;
Public procedure ArcTo(const x1, y1, x2, y2: Single; AngleBegin, AngleEnd: Single); overload;
Public procedure ArcTo(const x1, y1, x2, y2, x3, y3, x4, y4: Integer); overload;

Same as Arc but update the current position.

Public procedure Ellipse(const x, y: Single; const Radius: Single); overload;
Public procedure Ellipse(const x, y: Single; const xRadius, yRadius: Single); overload;
Public procedure Ellipse(const x, y: Integer; const xRadius, yRadius: Single); overload;

Draws and ellipse centered at (x, y) with given radiuses.

Public procedure EllipseBB(const x1, y1, x2, y2: Single); overload;
Public procedure EllipseBB(const x1, y1, x2, y2: Integer); overload;

Draws an ellipse with (x1,y1)-(x2, y2) bounding rectangle.

Public procedure FillEllipse(const x, y: Integer; const xRadius, yRadius: Single); overload;

Draw a filled ellipse.

Public procedure FillEllipse(const x, y: Single; const Radius: Single); overload;
Public procedure FillEllipse(const x, y: Single; const xRadius, yRadius: Single); overload;
Public procedure FillEllipseGradient(const x, y, xRadius, yRadius: Single; const edgeColor: TColorVector); overload;

Draw a filled gradient ellipse.<p> OpenGL will use the last PenColor and PenAlpha as the center color and do gradient to edge of ellipse using the edgeColor parameter.

Public procedure FillEllipseGradient(const x, y, Radius: Single; const edgeColor: TColorVector); overload;
Public procedure FillEllipseGradient(const x, y: Integer; const xRadius, yRadius: Integer; const edgeColor: TColorVector); overload;
Public procedure FillRect(const x1, y1, x2, y2: Single); overload;
Public procedure FillRect(const x1, y1, x2, y2: Integer); overload;

Draw the (x1,y1)-(x2, y2) rectangle (filled with PenColor).

Public procedure FillRectGradient(const x1, y1, x2, y2: Integer; const x1y1Color, x2y1Color, x2y2Color, x1y2Color: TColorVector); overload;
Public procedure FillRectGradient(const x1, y1, x2, y2: Single; const x1y1Color, x2y1Color, x2y2Color, x1y2Color: TColorVector); overload;

Draw the (x1,y1)-(x2, y2) rectangle (filled with given gradient's color).

Public procedure FrameRect(const x1, y1, x2, y2: Single); overload;
Public procedure FrameRect(const x1, y1, x2, y2: Integer); overload;

Draw the (x1,y1)-(x2, y2) rectangle's frame (border).

Public procedure InvertYAxis;

Inverts the orientation of the Y Axis.<p> If (0, 0) was in the top left corner, it will move to the bottom left corner or vice-versa.

Public procedure Line(const x1, y1, x2, y2: Single); overload;
Public procedure Line(const x1, y1, x2, y2: Integer); overload;

Draws a line from (x1, y1) to (x2, y2).<p> The current position is NOT updated.

Public procedure LineTo(const x, y: Single); overload;
Public procedure LineTo(const x, y: Integer); overload;

Draws a line from current position to given coordinate.<p> Current position is updated.

Public procedure LineToRel(const x, y: Single); overload;
Public procedure LineToRel(const x, y: Integer); overload;
Public procedure MoveTo(const x, y: Integer); overload;

Updates the current position (absolute coords).

Public procedure MoveTo(const x, y: Single); overload;
Public procedure MoveToRel(const x, y: Single); overload;
Public procedure MoveToRel(const x, y: Integer); overload;

Updates the current position (relative coords).

Public procedure PlotPixel(const x, y: Single); overload;
Public procedure PlotPixel(const x, y: Integer); overload;

Plots a pixel at given coordinate.<p> PenWidth affects pixel size.<br> The current position is NOT updated.

Public procedure Polygon(const points: array of TGLPoint);

Similar to Polyline but also connects the last point to the first.

Public procedure Polyline(const points: array of TGLPoint);

Draws the set of lines defined by connecting the points.<p> Similar to invoking MoveTo on the first point, then LineTo on all the following points.

Public procedure RoundRect(const x1, y1, x2, y2, xr, yr: Integer); overload;
Public procedure RoundRect(const x1, y1, x2, y2, xr, yr: Single); overload;
Public procedure StopPrimitive;

Stops the current internal primitive.<p> This function is invoked automatically by TGLCanvas when changeing primitives, you should directly call if you want to render your own stuff intertwined with TGLCanvas drawings. In that case, call it before your own OpenGL calls.

Protected procedure BackupOpenGLStates;
Protected procedure DrawArc(x1, y1, x2, y2: Single; AngleBegin, AngleEnd: Single; UpdateCurrentPos: Boolean); overload;
Protected procedure DrawArc(x1, y1, x2, y2, x3, y3, x4, y4: Single; UpdateCurrentPos: Boolean); overload;
Protected procedure EllipseVertices(x, y, xRadius, yRadius: Single);
Protected procedure NormalizePoint(const x1, y1, x2, y2: Single; const x, y: Single; pX, pY: PSingle);
Protected procedure SetPenAlpha(const val: Single);
Protected procedure SetPenColor(const val: TColor);
Protected procedure SetPenWidth(const val: Integer);
Protected procedure StartPrimitive(const primitiveType: Integer);
Protected procedure SwapSingle(pX, pY: PSingle);

Properties

Public property ArcDirection: TArcDirection read FArcDirection write FArcDirection;
Public property CanvasSizeX: Integer read FBufferSizeX;
Public property CanvasSizeY: Integer read FBufferSizeY;
Public property PenAlpha : Single read GetPenAlpha write SetPenAlpha;

Current Pen Alpha channel (from 0.0 to 1.0)

Public property PenColor: TColor read FPenColor write SetPenColor;

Current Pen Color.

Public property PenWidth: Integer read FPenWidth write SetPenWidth;

Current Pen Width.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCelShader

Unit GLCelShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLCelShader<p>

A shader that applies cel shading through a vertex program and shade definition texture.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Upgraded program hadles <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>22/01/10 - Yar - Added bmp32.Blank:=false for memory allocation <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>31/03/07 - DaStr - Added $I GLScene.inc <li>21/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>25/02/07 - DaStr - Moved registration to GLSceneRegister.pas <li>28/09/04 - SG - Vertex program now uses ARB_position_invariant option. <li>09/06/04 - SG - Added OutlineColor, vertex programs now use GL state. <li>28/05/04 - SG - Creation. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCelShader |

Types

TGLCelShaderOption = (...);
TGLCelShaderOptions = set of TGLCelShaderOption;
TGLCelShaderGetIntensity = procedure(Sender: TObject; var intensity: Byte) of object;

Description

Types

TGLCelShaderOption = (...);

Cel shading options.<p> csoOutlines: Render a second outline pass. csoTextured: Allows for a primary texture that the cel shading is modulated with and forces the shade definition to render as a second texture.

Values
  • csoOutlines:
  • csoTextured:
  • csoNoBuildShadeTexture:
TGLCelShaderOptions = set of TGLCelShaderOption;
TGLCelShaderGetIntensity = procedure(Sender: TObject; var intensity: Byte) of object;

An event for user defined cel intensity.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCelShader: Class TGLCelShader

Class TGLCelShader

Unit

GLCelShader

Declaration

type TGLCelShader = class(TGLShader)

Description

A generic cel shader.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCelShader

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected | function GenerateVertexProgram: string;
Public | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected | procedure BuildShadeTexture;
Protected | procedure Loaded; override;
Protected | procedure SetCelShaderOptions(const val: TGLCelShaderOptions);
Protected | procedure SetOutlineColor(const val: TGLColor);
Protected | procedure SetOutlineWidth(const val: Single);

Properties

Published | property CelShaderOptions: TGLCelShaderOptions read FCelShaderOptions write SetCelShaderOptions;
Published | property OnGetIntensity: TGLCelShaderGetIntensity read FOnGetIntensity write FOnGetIntensity;
Published | property OutlineColor: TGLColor read FOutlineColor write SetOutlineColor;
Published | property OutlineWidth: Single read FOutlineWidth write SetOutlineWidth;
Public | property ShadeTexture: TGLTexture read FShadeTexture;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected function GenerateVertexProgram: string;
Public procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected procedure BuildShadeTexture;
Protected procedure Loaded; override;
Protected procedure SetCelShaderOptions(const val: TGLCelShaderOptions);
Protected procedure SetOutlineColor(const val: TGLColor);
Protected procedure SetOutlineWidth(const val: Single);

Properties

Published property CelShaderOptions: TGLCelShaderOptions read FCelShaderOptions write SetCelShaderOptions;
Published property OnGetIntensity: TGLCelShaderGetIntensity read FOnGetIntensity write FOnGetIntensity;
Published property OutlineColor: TGLColor read FOutlineColor write SetOutlineColor;
Published property OutlineWidth: Single read FOutlineWidth write SetOutlineWidth;
Public property ShadeTexture: TGLTexture read FShadeTexture;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCgBombShader

Unit GLCgBombShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLCgBombShader<p>

Just a good looking shader. And my first one;) <p>

<b>History :</b><font size=-1><ul> <li>22/04/10 - Yar - Fixes after GLState revision <li>24/07/09 - DaStr - TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) <li>14/03/07 - DaStr - Bugfixed TGLCustomCGBombShader.DoInitialize (Shader is disabled if GradientTexture is not assigned) <li>14/03/07 - DaStr - Bugfixed TGLCustomCGBombShader.SetMaterialLibrary Alpha is not stored now Added design-time checks <li>22/02/07 - DaStr - Initial version (contributed to GLScene)

Previous version history: v1.0 08 March '2006 Creation (based on NVIdia's FXComposer demo shader) v1.1 04 April '2006 I found a way to use the Current Texture! See the TextureSource property for details... v1.2 14 August '2006 TGLCgBombShader became child of TGLCgShader to support IShaderSuppoted TShaderTextureSource added v1.3 19 August '2006 TGLCustomCGBombShader added GLS_OPTIMIZATIONS support added TGLCustomCGBombShader.Set[Main/Gradient]Texture() updated Cadencer stuff abstracted into TCadencableCustomCgShader

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLCgBombShaderException |
Class TGLCustomCGBombShader |
Class TGLCgBombShader |

Types

TGLCgBombShaderTextureSource = (...);

Description

Types

TGLCgBombShaderTextureSource = (...);
Values
  • stsPrimaryTexture:
  • stsSecondadyTexture:
  • stsThirdTexture:
  • stsUserSelectedTexture:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCgBombShader: Class EGLCgBombShaderException

Class EGLCgBombShaderException

Unit

GLCgBombShader

Declaration

type EGLCgBombShaderException = class(EGLCGShaderException)

Description

no description available, EGLCGShaderException description follows
no description available, EGLShaderException description follows

Hierarchy

  • Exception
  • EGLShaderException
  • EGLCGShaderException
  • EGLCgBombShaderException
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCgBombShader: Class TGLCustomCGBombShader

Class TGLCustomCGBombShader

Unit

GLCgBombShader

Declaration

type TGLCustomCGBombShader = class(TCadencableCustomCgShader, IGLMaterialLibrarySupported)

Description

Just a good-looking shader.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TCustomCgShader
  • TCadencableCustomCgShader
  • TGLCustomCGBombShader

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Protected | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected | procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure OnApplyFP(CgProgram: TCgProgram; Sender: TObject); virtual;
Protected | procedure OnApplyVP(CgProgram: TCgProgram; Sender: TObject); virtual;
Protected | procedure OnUnApplyFP(CgProgram: TCgProgram); virtual;
Protected | procedure SetMaterialLibrary(const Value: TGLAbstractMaterialLibrary); virtual;

Properties

Public | property Alpha: Single read FAlpha write FAlpha;
Public | property ColorRange: Single read FColorRange write FColorRange stored StoreColorRange;
Public | property ColorSharpness: Single read FColorSharpness write FColorSharpness stored StoreColorSharpness;
Public | property Displacement: Single read FDisplacement write FDisplacement stored StoreDisplacement;
Public | property GradientTexture: TGLTexture read FGradientTexture write SetGradientTexture;
Public | property GradientTextureName: TGLLibMaterialName read GetGradientTextureName write SetGradientTextureName;
Public | property GradientTextureShare: Single read FGradientTextureShare write FGradientTextureShare stored StoreGradientTextureShare;
Public | property MainTexture: TGLTexture read FMainTexture write SetMainTexture;
Public | property MainTextureName: TGLLibMaterialName read GetMainTextureName write SetMainTextureName;
Public | property MainTextureShare: Single read FMainTextureShare write FMainTextureShare stored StoreMainTextureShare;
Public | property MainTextureSource: TGLCgBombShaderTextureSource read FMainTextureSource write FMainTextureSource;
Public | property MaterialLibrary: TGLAbstractMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public | property Sharpness: Single read FSharpness write FSharpness stored StoreSharpness;
Public | property Speed: Single read FSpeed write FSpeed stored StoreSpeed;
Public | property TurbDensity: Single read FTurbDensity write FTurbDensity stored StoreTurbDensity;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Protected procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure OnApplyFP(CgProgram: TCgProgram; Sender: TObject); virtual;
Protected procedure OnApplyVP(CgProgram: TCgProgram; Sender: TObject); virtual;
Protected procedure OnUnApplyFP(CgProgram: TCgProgram); virtual;
Protected procedure SetMaterialLibrary(const Value: TGLAbstractMaterialLibrary); virtual;

Properties

Public property Alpha: Single read FAlpha write FAlpha;
Public property ColorRange: Single read FColorRange write FColorRange stored StoreColorRange;
Public property ColorSharpness: Single read FColorSharpness write FColorSharpness stored StoreColorSharpness;
Public property Displacement: Single read FDisplacement write FDisplacement stored StoreDisplacement;
Public property GradientTexture: TGLTexture read FGradientTexture write SetGradientTexture;
Public property GradientTextureName: TGLLibMaterialName read GetGradientTextureName write SetGradientTextureName;
Public property GradientTextureShare: Single read FGradientTextureShare write FGradientTextureShare stored StoreGradientTextureShare;
Public property MainTexture: TGLTexture read FMainTexture write SetMainTexture;
Public property MainTextureName: TGLLibMaterialName read GetMainTextureName write SetMainTextureName;
Public property MainTextureShare: Single read FMainTextureShare write FMainTextureShare stored StoreMainTextureShare;
Public property MainTextureSource: TGLCgBombShaderTextureSource read FMainTextureSource write FMainTextureSource;
Public property MaterialLibrary: TGLAbstractMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public property Sharpness: Single read FSharpness write FSharpness stored StoreSharpness;
Public property Speed: Single read FSpeed write FSpeed stored StoreSpeed;
Public property TurbDensity: Single read FTurbDensity write FTurbDensity stored StoreTurbDensity;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCgBombShader: Class TGLCgBombShader

Class TGLCgBombShader

Unit

GLCgBombShader

Declaration

type TGLCgBombShader = class(TGLCustomCGBombShader)

Description

no description available, TGLCustomCGBombShader description follows

Just a good-looking shader.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TCustomCgShader
  • TCadencableCustomCgShader
  • TGLCustomCGBombShader
  • TGLCgBombShader

Overview

Methods

Protected | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected | procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure OnApplyFP(CgProgram: TCgProgram; Sender: TObject); override;
Protected | procedure OnApplyVP(CgProgram: TCgProgram; Sender: TObject); override;
Protected | procedure OnUnApplyFP(CgProgram: TCgProgram); override;

Properties

Published | property Alpha;
Published | property Cadencer;
Published | property ColorRange;
Published | property ColorSharpness;
Published | property DesignEnable;
Published | property Displacement;
Published | property GradientTextureName;
Published | property GradientTextureShare;
Published | property MainTextureName;
Published | property MainTextureShare;
Published | property MaterialLibrary;
Published | property Sharpness;
Published | property Speed;
Published | property TurbDensity;

Description

Methods

Protected procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure OnApplyFP(CgProgram: TCgProgram; Sender: TObject); override;
Protected procedure OnApplyVP(CgProgram: TCgProgram; Sender: TObject); override;
Protected procedure OnUnApplyFP(CgProgram: TCgProgram); override;

Properties

Published property Alpha;
Published property Cadencer;
Published property ColorRange;
Published property ColorSharpness;
Published property DesignEnable;
Published property Displacement;
Published property GradientTextureName;
Published property GradientTextureShare;
Published property MainTextureName;
Published property MainTextureShare;
Published property MaterialLibrary;
Published property Sharpness;
Published property Speed;
Published property TurbDensity;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCgRegister

Unit GLCgRegister

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLCgRegister<p>

Registration unit for CG shader.<p>

<b>History :</b><font size=-1><ul> <li>11/11/09 - DaStr - Improved FPC compatibility (thanks Predator) (BugtrackerID = 2893580) <li>23/02/07 - DaStr - Initial version

Overview

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCgShader

Unit GLCgShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLCgShader<p>

Base Cg shader classes.<p>

<b>History :</b><font size=-1><ul> <li>19/12/12 - PW - Added CPPB compatibility: changed cg.lib's name of function GetProfileString to GetProfileStringA <li>26/03/11 - Yar - Added SetAsMatrix to TCgParameter <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>22/04/10 - Yar - Fixes after GLState revision <li>24/07/09 - DaStr - TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) <li>15/03/08 - DaStr - Fixups for vIgnoreContextActivationFailures mode (BugTracker ID = 1914782) <li>24/03/07 - DaStr - Improved Cross-Platform compatibility (BugTracker ID = 1684432) <li>23/02/07 - DaStr- Added TCgProgram.ManualNotification <li>23/02/07 - DaStr- Added TCadencableCustomCgShader Added EGLCGShaderException with TCustomCgShader: Added ShaderSupported, Moved all properties from "public" and "published" to the "protected" section. DoInitialize fixed to catch compilation errors Moved registration to GLCgRegister.pas Added more stuff to RegisterClasses() <li>29/04/06 - PhP - Fixed TCgProgram.Finalize (Achim Hannes) <li>24/10/04 - NelC - Added SetAsScalar for boolean input, IncludeFilePath <li>10/09/04 - NelC - Added global function IsCgProfileSupported <li>07/09/04 - NelC - Added TCgProgram.Precision (Cg 1.3) <li>07/09/04 - NelC - Added profiles VP40, FP40 (Cg 1.3 beta 2), Added option OutputCompilerWarnings <li>23/04/04 - NelC - Now ManageTexture is false by default (Cg 1.2.1) <li>24/03/04 - NelC - Added GetLatestProfile <li>21/03/04 - NelC - Added TCgFragmentProgram.ManageTexture (Cg 1.2) Added TCustomCgShader.IsProfileSupported <li>16/02/04 - NelC - Added TCgParameter.SetParameterPointer <li>13/02/04 - NelC - Replaced two overloaded TCgProgram.SetParam's with SetStateMatrix and SetTexture <li>05/02/04 - NelC - Fixed type checking for Half and Fixed, Added TCgParameter.SetToTextureOf <li>01/02/04 - NelC - Now reports source CgProgram or CgParameter of errors <li>20/01/04 - NelC - Updated shader event handlers with Sender object, Fixed dynamic array passing bug in CheckValueType <li>03/01/04 - NelC - Shortened event handler names using 'VP' and 'FP', Added TCustomCgShader.LoadShaderPrograms, TCgProgram.SetParam, Minor change in texture type checking <li>01/08/03 - NelC - Simplified type checking in SetAsStateMatrix <li>04/07/03 - NelC - Added TCustomCgShader.OnInitialize, Moved VertexProgram & FragmentProgram of TCustomCgShader to published for easy acccess from OnInitialize <li>02/07/03 - NelC - Added more value-setting methods <li>01/07/03 - NelC - TCgProgram.ListCompilation now outputs line breaks <li>27/06/03 - NelC - Added value-setting functions for TCgParameter, TCgProgram.DirectParamByName & DirectProfile, and Profile property for TCgVertexProgram & TCgFragmentProgram <li>24/06/03 - NelC - Initial adoptation to Cg 1.1 Final. Now automatically uses latest hardware-supported profile and use callback to show error message <li>29/05/03 - RoC - Cg 1.1 Depreciated_api compatible <li>25/09/02 - EG - Cg Beta 2/2.1 compatible, now uses ARBVP <li>19/06/02 - EG - Improved OO wrapper <li>18/06/02 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLCGShaderException |
Class TCgProgram |
Class TCgParameter |
Class TCgVertexProgram |
Class TCgFragmentProgram |
Class TCustomCgShader |
Class TCadencableCustomCgShader |
Class TCgShader |

Functions and Procedures

function IsCgProfileSupported(Profile: TcgProfile): boolean;

Types

TCgApplyEvent = procedure (CgProgram : TCgProgram; Sender : TObject) of object;
TCgUnApplyEvent = procedure (CgProgram : TCgProgram) of object;
TCgShaderEvent = procedure (CgShader : TCustomCgShader) of object;
TcgProgramType = (...);
TCgVPProfile = (...);
TCgFPProfile = (...);
TPrecisionSetting = (...);

Variables

IncludeFilePath: string;

Description

Functions and Procedures

function IsCgProfileSupported(Profile: TcgProfile): boolean;

Types

TCgApplyEvent = procedure (CgProgram : TCgProgram; Sender : TObject) of object;
TCgUnApplyEvent = procedure (CgProgram : TCgProgram) of object;
TCgShaderEvent = procedure (CgShader : TCustomCgShader) of object;
TcgProgramType = (...);
Values
  • ptVertex:
  • ptFragment:
TCgVPProfile = (...);
Values
  • vpDetectLatest:
  • vp20:
  • vp30:
  • vp40:
  • arbvp1:
TCgFPProfile = (...);
Values
  • fpDetectLatest:
  • fp20:
  • fp30:
  • fp40:
  • arbfp1:
TPrecisionSetting = (...);
Values
  • psFull:
  • psFast:

Variables

IncludeFilePath: string;

Set IncludeFilePath to indicate where to find your include file for your Cg source files. This avoids error from the Cg Compiler when the current directory is not the right path as the shader is being compiled.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCgShader: Class EGLCGShaderException

Class EGLCGShaderException

Unit

GLCgShader

Declaration

type EGLCGShaderException = class(EGLShaderException)

Description

no description available, EGLShaderException description follows

Hierarchy

  • Exception
  • EGLShaderException
  • EGLCGShaderException
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCgShader: Class TCgProgram

Class TCgProgram

Unit

GLCgShader

Declaration

type TCgProgram = class(TGLUpdateAbleObject)

Description

Wrapper around a Cg program.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TCgProgram

Overview

Fields

Protected | FProgramType: TcgProgramType;
Protected | FProfile: TcgProfile;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function DirectParamByName(const name : String) : PCGparameter;
Public | function GetLatestProfile: TcgProfile; virtual; abstract;
Public | function GetProfileStringA : string;
Public | function LongName : string;
Public | function ParamByName(const name : String) : TCgParameter;
Public | function ParamCount : Integer;
Protected | function GetParam(index : String) : TCgParameter;
Public | procedure Apply(var rci : TRenderContextInfo; Sender : TObject);
Public | procedure Finalize;
Public | procedure Initialize; dynamic;
Public | procedure ListCompilation(Output : TStrings);
Public | procedure ListParameters(Output : TStrings);
Public | procedure LoadFromFile(const fileName : String);
Public | procedure SetParam(ParamName: string; SingleVal : Single); overload;
Public | procedure SetParam(ParamName: string; const Vector4fVal : TVector4f); overload;
Public | procedure SetParam(ParamName: string; const Vector3fVal : TVector3f); overload;
Public | procedure SetParam(ParamName: string; const Vector2fVal : TVector2f); overload;
Public | procedure SetStateMatrix(ParamName: string; matrix, Transform: Cardinal);
Public | procedure SetTexture(ParamName: string; TextureID : Cardinal);
Public | procedure UnApply(var rci : TRenderContextInfo);
Protected | procedure AddParamsItem(const Param : PCGParameter);
Protected | procedure BuildParamsList;
Protected | procedure ClearParamsList;
Protected | procedure SetCode(const val : TStrings);
Protected | procedure SetProgramName(const val : String);

Properties

Published | property Code : TStrings read FCode write SetCode;
Public | property DirectProfile : TcgProfile read FProfile write FProfile;
Published | property Enabled : boolean read FEnabled write FEnabled default True;
Public | property ManualNotification: Boolean read GetManualNotification write SetManualNotification default False;
Published | property OnApply : TCgApplyEvent read FOnApply write FOnApply;
Public | property OnProgramChanged : TNotifyEvent read FOnProgramChanged write FOnProgramChanged;
Published | property OnUnApply : TCgUnApplyEvent read FOnUnApply write FOnUnApply;
Public | property Param[index : String]: TCgParameter read GetParam;
Public | property Params : TList read FParams;
Published | property Precision : TPrecisionSetting read FPrecision write SetPrecision default psFull;
Published | property ProgramName : String read FProgramName write SetProgramName;

Description

Fields

Protected FProgramType: TcgProgramType;
Protected FProfile: TcgProfile;

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public function DirectParamByName(const name : String) : PCGparameter;
Public function GetLatestProfile: TcgProfile; virtual; abstract;
Public function GetProfileStringA : string;
Public function LongName : string;
Public function ParamByName(const name : String) : TCgParameter;

ParamByName returns CgParameter; returns nil if not found.

Public function ParamCount : Integer;
Protected function GetParam(index : String) : TCgParameter;
Public procedure Apply(var rci : TRenderContextInfo; Sender : TObject);
Public procedure Finalize;
Public procedure Initialize; dynamic;
Public procedure ListCompilation(Output : TStrings);
Public procedure ListParameters(Output : TStrings);
Public procedure LoadFromFile(const fileName : String);
Public procedure SetParam(ParamName: string; SingleVal : Single); overload;
Public procedure SetParam(ParamName: string; const Vector4fVal : TVector4f); overload;
Public procedure SetParam(ParamName: string; const Vector3fVal : TVector3f); overload;
Public procedure SetParam(ParamName: string; const Vector2fVal : TVector2f); overload;
Public procedure SetStateMatrix(ParamName: string; matrix, Transform: Cardinal);
Public procedure SetTexture(ParamName: string; TextureID : Cardinal);
Public procedure UnApply(var rci : TRenderContextInfo);
Protected procedure AddParamsItem(const Param : PCGParameter);
Protected procedure BuildParamsList;

Build a list of parameters used in the shader code.<p> Iteratively queries all parameters so that we can manage and access them easily. Currently only collects leaf parameters i.e. data structure is not retrieved.

Protected procedure ClearParamsList;
Protected procedure SetCode(const val : TStrings);
Protected procedure SetProgramName(const val : String);

Properties

Published property Code : TStrings read FCode write SetCode;
Public property DirectProfile : TcgProfile read FProfile write FProfile;

Direct access to the profile. <p> Set Profile of the sub-classes to any but DetectLatest if you want to specify the profile directly.

Published property Enabled : boolean read FEnabled write FEnabled default True;
Public property ManualNotification: Boolean read GetManualNotification write SetManualNotification default False;

If True, that shader is not reset when TCgProgram' parameters change.

Published property OnApply : TCgApplyEvent read FOnApply write FOnApply;
Public property OnProgramChanged : TNotifyEvent read FOnProgramChanged write FOnProgramChanged;
Published property OnUnApply : TCgUnApplyEvent read FOnUnApply write FOnUnApply;
Public property Param[index : String]: TCgParameter read GetParam;

Use Param instead of ParamByName if you want implicit check for the existence of your requested parameter.

Public property Params : TList read FParams;
Published property Precision : TPrecisionSetting read FPrecision write SetPrecision default psFull;

Precision controls data precision of GPU operation. <p> Possible options are 16-bit (psFast) or 32-bit (psFull). 16-bit operation is generally faster.

Published property ProgramName : String read FProgramName write SetProgramName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:12


GLScene v.1.1.2: GLCgShader: Class TCgParameter

Class TCgParameter

Unit

GLCgShader

Declaration

type TCgParameter = class(TObject)

Description

Wrapper around a Cg parameter of the main program.

Hierarchy

  • TObject
  • TCgParameter

Overview

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | function LongName : string;
Protected | function TypeMismatchMessage : string;
Public | procedure DisableClientState;
Public | procedure DisableTexture;
Public | procedure EnableClientState;
Public | procedure EnableTexture;
Public | procedure SetAsMatrix(const val: TMatrix4f);
Public | procedure SetAsScalar(const val : Single); overload;
Public | procedure SetAsScalar(const val : boolean); overload;
Public | procedure SetAsStateMatrix(matrix, Transform: Cardinal);
Public | procedure SetAsTexture(TextureID : Cardinal);
Public | procedure SetAsTexture1D(TextureID : Cardinal);
Public | procedure SetAsTexture2D(TextureID : Cardinal);
Public | procedure SetAsTexture3D(TextureID : Cardinal);
Public | procedure SetAsTextureCUBE(TextureID : Cardinal);
Public | procedure SetAsTextureRECT(TextureID : Cardinal);
Public | procedure SetAsVector(const val : array of single); overload;
Public | procedure SetAsVector(const val : TVector2f); overload;
Public | procedure SetAsVector(const val : TVector3f); overload;
Public | procedure SetAsVector(const val : TVector4f); overload;
Public | procedure SetParameterPointer(Values : TVectorList); overload;
Public | procedure SetParameterPointer(Values : TAffineVectorList); overload;
Public | procedure SetToTextureOf(LibMaterial : TGLLibMaterial);
Protected | procedure CheckAllScalarTypes;
Protected | procedure CheckAllTextureTypes;
Protected | procedure CheckAllVector2fTypes;
Protected | procedure CheckAllVector3fTypes;
Protected | procedure CheckAllVector4fTypes;
Protected | procedure CheckValueType(aType : TCGtype); overload;
Protected | procedure CheckValueType(const types : array of TCGtype); overload;
Protected | procedure SetAsVector2f(const val : TVector2f);
Protected | procedure SetAsVector3f(const val : TVector3f);
Protected | procedure SetAsVector4f(const val : TVector4f);

Properties

Public | property AsAffineVector : TAffineVector write SetAsVector3f;
Public | property AsVector : TVector write SetAsVector4f;
Public | property AsVector2f : TVector2f write SetAsVector2f;
Public | property Direction : TCGenum read FDirection write FDirection;
Public | property Handle : PCGparameter read FHandle write FHandle;
Public | property Name : String read FName;
Public | property Owner : TCgProgram read FOwner;
Public | property ValueType : TCGtype read FValueType;
Public | property Variability : TCGenum read FVariability write FVariability;

Description

Methods

Public constructor Create; virtual;
Public destructor Destroy; override;
Public function LongName : string;

LongName retruns ShaderName.[program type].ProgramName.ParamName.

Protected function TypeMismatchMessage : string;
Public procedure DisableClientState;
Public procedure DisableTexture;
Public procedure EnableClientState;
Public procedure EnableTexture;
Public procedure SetAsMatrix(const val: TMatrix4f);
Public procedure SetAsScalar(const val : Single); overload;

Procedures for setting uniform pamareters.<p> Implicitly check for data type.

Public procedure SetAsScalar(const val : boolean); overload;
Public procedure SetAsStateMatrix(matrix, Transform: Cardinal);
Public procedure SetAsTexture(TextureID : Cardinal);
Public procedure SetAsTexture1D(TextureID : Cardinal);
Public procedure SetAsTexture2D(TextureID : Cardinal);
Public procedure SetAsTexture3D(TextureID : Cardinal);
Public procedure SetAsTextureCUBE(TextureID : Cardinal);
Public procedure SetAsTextureRECT(TextureID : Cardinal);
Public procedure SetAsVector(const val : array of single); overload;

This overloaded SetAsVector accepts open array as input. e.g. SetAsVector([0.1, 0.2]). Array length must between 1-4.

Public procedure SetAsVector(const val : TVector2f); overload;
Public procedure SetAsVector(const val : TVector3f); overload;
Public procedure SetAsVector(const val : TVector4f); overload;
Public procedure SetParameterPointer(Values : TVectorList); overload;

Procedures for setting varying parameters with an array of values.

Public procedure SetParameterPointer(Values : TAffineVectorList); overload;
Public procedure SetToTextureOf(LibMaterial : TGLLibMaterial);

SetToTextureOf determines texture type on-the-fly.

Protected procedure CheckAllScalarTypes;
Protected procedure CheckAllTextureTypes;
Protected procedure CheckAllVector2fTypes;
Protected procedure CheckAllVector3fTypes;
Protected procedure CheckAllVector4fTypes;
Protected procedure CheckValueType(aType : TCGtype); overload;
Protected procedure CheckValueType(const types : array of TCGtype); overload;
Protected procedure SetAsVector2f(const val : TVector2f);
Protected procedure SetAsVector3f(const val : TVector3f);
Protected procedure SetAsVector4f(const val : TVector4f);

Properties

Public property AsAffineVector : TAffineVector write SetAsVector3f;
Public property AsVector : TVector write SetAsVector4f;
Public property AsVector2f : TVector2f write SetAsVector2f;
Public property Direction : TCGenum read FDirection write FDirection;
Public property Handle : PCGparameter read FHandle write FHandle;
Public property Name : String read FName;
Public property Owner : TCgProgram read FOwner;
Public property ValueType : TCGtype read FValueType;
Public property Variability : TCGenum read FVariability write FVariability;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:13


GLScene v.1.1.2: GLCgShader: Class TCgVertexProgram

Class TCgVertexProgram

Unit

GLCgShader

Declaration

type TCgVertexProgram = class(TCgProgram)

Description

no description available, TCgProgram description follows

Wrapper around a Cg program.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TCgProgram
  • TCgVertexProgram

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | function GetLatestProfile: TcgProfile; override;

Properties

Published property Profile : TCgVPProfile read FVPProfile write SetVPProfile default vpDetectLatest;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public function GetLatestProfile: TcgProfile; override;

Properties

Published property Profile : TCgVPProfile read FVPProfile write SetVPProfile default vpDetectLatest;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:13


GLScene v.1.1.2: GLCgShader: Class TCgFragmentProgram

Class TCgFragmentProgram

Unit

GLCgShader

Declaration

type TCgFragmentProgram = class(TCgProgram)

Description

no description available, TCgProgram description follows

Wrapper around a Cg program.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TCgProgram
  • TCgFragmentProgram

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | function GetLatestProfile: TcgProfile; override;
Public | procedure Initialize; override;

Properties

Published | property ManageTexture : boolean read FManageTexture write SetManageTexture default false;
Published | property Profile : TCgFPProfile read FFPProfile write SetFPProfile default fpDetectLatest;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public function GetLatestProfile: TcgProfile; override;
Public procedure Initialize; override;

Properties

Published property ManageTexture : boolean read FManageTexture write SetManageTexture default false;
Published property Profile : TCgFPProfile read FFPProfile write SetFPProfile default fpDetectLatest;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:13


GLScene v.1.1.2: GLCgShader: Class TCustomCgShader

Class TCustomCgShader

Unit

GLCgShader

Declaration

type TCustomCgShader = class(TGLShader)

Description

no description available, TGLShader description follows

Generic, abstract shader class.<p> Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities.<br> Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TCustomCgShader

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ShaderSupported: Boolean; override;
Protected | function DoUnApply(var rci : TRenderContextInfo) : Boolean; override;
Protected | function GetOnApplyFragmentProgram : TCgApplyEvent;
Protected | function GetOnApplyVertexProgram : TCgApplyEvent;
Protected | function GetOnInitialize : TCgShaderEvent;
Protected | function GetOnUnApplyFragmentProgram : TCgUnApplyEvent;
Protected | function GetOnUnApplyVertexProgram : TCgUnApplyEvent;
Protected | function IsProfileSupported(Profile: TcgProfile): boolean;
Public | procedure LoadShaderPrograms(const VPFilename, FPFilename : string);
Protected | procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure DoFinalize; override;
Protected | procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure SetFragmentProgram(const val : TCgFragmentProgram);
Protected | procedure SetOnApplyFragmentProgram(const val : TCgApplyEvent);
Protected | procedure SetOnApplyVertexProgram(const val : TCgApplyEvent);
Protected | procedure SetOnInitialize(const val : TCgShaderEvent);
Protected | procedure SetOnUnApplyFragmentProgram(const val : TCgUnApplyEvent);
Protected | procedure SetOnUnApplyVertexProgram(const val : TCgUnApplyEvent);
Protected | procedure SetVertexProgram(const val : TCgVertexProgram);

Properties

Protected | property DesignEnable : Boolean read FDesignEnable write FDesignEnable default False;
Protected | property FragmentProgram : TCgFragmentProgram read FFragmentProgram write SetFragmentProgram;
Protected | property OnApplyFP : TCgApplyEvent read GetOnApplyFragmentProgram write SetOnApplyFragmentProgram;
Protected | property OnApplyVP : TCgApplyEvent read GetOnApplyVertexProgram write SetOnApplyVertexProgram;
Protected | property OnInitialize : TCgShaderEvent read GetOnInitialize write SetOnInitialize;
Protected | property OnUnApplyFP : TCgUnApplyEvent read GetOnUnApplyFragmentProgram write SetOnUnApplyFragmentProgram;
Protected | property OnUnApplyVP : TCgUnApplyEvent read GetOnUnApplyVertexProgram write SetOnUnApplyVertexProgram;
Protected | property VertexProgram : TCgVertexProgram read FVertexProgram write SetVertexProgram;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function ShaderSupported: Boolean; override;
Protected function DoUnApply(var rci : TRenderContextInfo) : Boolean; override;
Protected function GetOnApplyFragmentProgram : TCgApplyEvent;
Protected function GetOnApplyVertexProgram : TCgApplyEvent;
Protected function GetOnInitialize : TCgShaderEvent;
Protected function GetOnUnApplyFragmentProgram : TCgUnApplyEvent;
Protected function GetOnUnApplyVertexProgram : TCgUnApplyEvent;
Protected function IsProfileSupported(Profile: TcgProfile): boolean;
Public procedure LoadShaderPrograms(const VPFilename, FPFilename : string);
Protected procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure DoFinalize; override;
Protected procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure SetFragmentProgram(const val : TCgFragmentProgram);
Protected procedure SetOnApplyFragmentProgram(const val : TCgApplyEvent);
Protected procedure SetOnApplyVertexProgram(const val : TCgApplyEvent);
Protected procedure SetOnInitialize(const val : TCgShaderEvent);
Protected procedure SetOnUnApplyFragmentProgram(const val : TCgUnApplyEvent);
Protected procedure SetOnUnApplyVertexProgram(const val : TCgUnApplyEvent);
Protected procedure SetVertexProgram(const val : TCgVertexProgram);

Properties

Protected property DesignEnable : Boolean read FDesignEnable write FDesignEnable default False;
Protected property FragmentProgram : TCgFragmentProgram read FFragmentProgram write SetFragmentProgram;
Protected property OnApplyFP : TCgApplyEvent read GetOnApplyFragmentProgram write SetOnApplyFragmentProgram;
Protected property OnApplyVP : TCgApplyEvent read GetOnApplyVertexProgram write SetOnApplyVertexProgram;
Protected property OnInitialize : TCgShaderEvent read GetOnInitialize write SetOnInitialize;

OnInitialize can be use to set parameters that need to be set once only. See demo "Cg Texture" for example.

Protected property OnUnApplyFP : TCgUnApplyEvent read GetOnUnApplyFragmentProgram write SetOnUnApplyFragmentProgram;
Protected property OnUnApplyVP : TCgUnApplyEvent read GetOnUnApplyVertexProgram write SetOnUnApplyVertexProgram;
Protected property VertexProgram : TCgVertexProgram read FVertexProgram write SetVertexProgram;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:13


GLScene v.1.1.2: GLCgShader: Class TCadencableCustomCgShader

Class TCadencableCustomCgShader

Unit

GLCgShader

Declaration

type TCadencableCustomCgShader = class(TCustomCgShader)

Description

Allows to use a Cadencer, which is used for noise generation in many shaders.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TCustomCgShader
  • TCadencableCustomCgShader

Overview

Methods

Protected | procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Public property Cadencer: TGLCadencer read FCadencer write SetCadencer;

Description

Methods

Protected procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Public property Cadencer: TGLCadencer read FCadencer write SetCadencer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:13


GLScene v.1.1.2: GLCgShader: Class TCgShader

Class TCgShader

Unit

GLCgShader

Declaration

type TCgShader = class(TCustomCgShader)

Description

no description available, TCustomCgShader description follows
no description available, TGLShader description follows

Generic, abstract shader class.<p> Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities.<br> Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TCustomCgShader
  • TCgShader

Overview

Properties

Published | property DesignEnable;
Published | property FailedInitAction;
Published | property FragmentProgram;
Published | property OnApplyFP;
Published | property OnApplyVP;
Published | property OnInitialize;
Published | property OnUnApplyFP;
Published | property OnUnApplyVP;
Published | property ShaderStyle;
Published | property VertexProgram;

Description

Properties

Published property DesignEnable;
Published property FailedInitAction;
Published property FragmentProgram;
Published property OnApplyFP;
Published property OnApplyVP;
Published property OnInitialize;
Published property OnUnApplyFP;
Published property OnUnApplyVP;
Published property ShaderStyle;
Published property VertexProgram;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:13


GLScene v.1.1.2: GLCollision

Unit GLCollision

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLCollision<p>

Collision-detection management for GLScene<p>

<b>Historique : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>21/01/11 - DanB - Added "inherited" call to TGLBCollision.WriteToFiler <li>03/04/07 - DaStr - Added "public" to TCollisionNode for FPC compatibility <li>30/03/07 - DaStr - Added $I GLScene.inc <li>19/10/06 - LC - Fixed memory leak in TCollisionManager.CheckCollisions. Bugtracker ID=1548618 <li>02/08/04 - LR, YHC - BCB corrections: use record instead array <li>09/05/03 - DanB - fixed for collisions with bounding-box unproperly defined (min>max) <li>09/05/03 - DanB - Added FastCheckCubeVsFace (Matheus Degiovani) <li>13/02/03 - DanB - New collision code, and support for scaled objects <li>22/02/01 - Egg - Included new collision code by Uwe Raabe <li>08/08/00 - Egg - Fixed TGLBCollision.Assign <li>16/07/00 - Egg - Added support for all bounding modes (most are un-tested) <li>23/05/00 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCollisionManager |
Class TGLBCollision |

Functions and Procedures

function FastCheckPointVsPoint(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckPointVsSphere(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckPointVsEllipsoid(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckPointVsCube(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckSphereVsPoint(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckSphereVsSphere(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckSphereVsEllipsoid(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckSphereVsCube(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckEllipsoidVsPoint(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckEllipsoidVsSphere(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckEllipsoidVsEllipsoid(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckEllipsoidVsCube(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckCubeVsPoint(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckCubeVsSphere(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckCubeVsEllipsoid(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckCubeVsCube(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckCubeVsFace(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckFaceVsCube(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckFaceVsFace(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function IntersectCubes(obj1, obj2 : TGLBaseSceneObject) : Boolean; overload;
function GetOrCreateCollision(behaviours : TGLBehaviours) : TGLBCollision; overload;
function GetOrCreateCollision(obj : TGLBaseSceneObject) : TGLBCollision; overload;

Types

TObjectCollisionEvent = procedure (Sender : TObject; object1, object2 : TGLBaseSceneObject) of object;
TCollisionBoundingMode = (...);
TFastCollisionChecker = function (obj1, obj2 : TGLBaseSceneObject) : Boolean;
PFastCollisionChecker = ˆTFastCollisionChecker;

Description

Functions and Procedures

function FastCheckPointVsPoint(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckPointVsSphere(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckPointVsEllipsoid(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckPointVsCube(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckSphereVsPoint(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckSphereVsSphere(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckSphereVsEllipsoid(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckSphereVsCube(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckEllipsoidVsPoint(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckEllipsoidVsSphere(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckEllipsoidVsEllipsoid(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckEllipsoidVsCube(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckCubeVsPoint(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckCubeVsSphere(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckCubeVsEllipsoid(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckCubeVsCube(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckCubeVsFace(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckFaceVsCube(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function FastCheckFaceVsFace(obj1, obj2 : TGLBaseSceneObject) : Boolean;
function IntersectCubes(obj1, obj2 : TGLBaseSceneObject) : Boolean; overload;

Returns true when the bounding box cubes does intersect the other.<p> Also true when the one cube does contain the other completely.

function GetOrCreateCollision(behaviours : TGLBehaviours) : TGLBCollision; overload;

Returns or creates the TGLBCollision within the given behaviours.<p> This helper function is convenient way to access a TGLBCollision.

function GetOrCreateCollision(obj : TGLBaseSceneObject) : TGLBCollision; overload;

Returns or creates the TGLBCollision within the given object's behaviours.<p> This helper function is convenient way to access a TGLBCollision.

Types

TObjectCollisionEvent = procedure (Sender : TObject; object1, object2 : TGLBaseSceneObject) of object;
TCollisionBoundingMode = (...);

Defines how fine collision bounding is for a particular object.<p> Possible values are :<ul> <li>cbmPoint : the object is punctual and may only collide with volumes <li>cbmSphere : the object is defined by its bounding sphere (sphere radius is the max of axis-aligned dimensions) <li>cbmEllipsoid the object is defined by its bounding axis-aligned ellipsoid <li>cbmCube : the object is defined by a bounding axis-aligned "cube" <li>cbmFaces : the object is defined by its faces (needs object-level support, if unavalaible, uses cbmCube code) </ul>

Values
  • cbmPoint:
  • cbmSphere:
  • cbmEllipsoid:
  • cbmCube:
  • cbmFaces:
TFastCollisionChecker = function (obj1, obj2 : TGLBaseSceneObject) : Boolean;
PFastCollisionChecker = ˆTFastCollisionChecker;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:13


GLScene v.1.1.2: GLCollision: Class TCollisionManager

Class TCollisionManager

Unit

GLCollision

Declaration

type TCollisionManager = class(TComponent)

Description

Hierarchy

  • TComponent
  • TCollisionManager

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure CheckCollisions;
Protected | procedure DeRegisterAllClients;
Protected | procedure DeRegisterClient(aClient : TGLBCollision);
Protected | procedure RegisterClient(aClient : TGLBCollision);

Properties

Published property OnCollision : TObjectCollisionEvent read FOnCollision write FOnCollision;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure CheckCollisions;
Protected procedure DeRegisterAllClients;
Protected procedure DeRegisterClient(aClient : TGLBCollision);
Protected procedure RegisterClient(aClient : TGLBCollision);

Properties

Published property OnCollision : TObjectCollisionEvent read FOnCollision write FOnCollision;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:13


GLScene v.1.1.2: GLCollision: Class TGLBCollision

Class TGLBCollision

Unit

GLCollision

Declaration

type TGLBCollision = class(TGLBehaviour)

Description

Collision detection behaviour.<p> Allows an object to register to a TCollisionManager and be accounted for in collision-detection and distance calculation mechanisms.<p> An object may have multiple TGLBCollision, registered to multiple collision managers, however if multiple behaviours share the same manager, only one of them will be accounted for, others will be ignored.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBCollision

Overview

Methods

Public | constructor Create(aOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure Loaded; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetGroupIndex(const value : Integer);
Protected | procedure SetManager(const val : TCollisionManager);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property BoundingMode : TCollisionBoundingMode read FBoundingMode write FBoundingMode;
Published | property GroupIndex : Integer read FGroupIndex write SetGroupIndex;
Published | property Manager : TCollisionManager read FManager write SetManager;

Description

Methods

Public constructor Create(aOwner : TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Public procedure Assign(Source: TPersistent); override;
Protected procedure Loaded; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetGroupIndex(const value : Integer);
Protected procedure SetManager(const val : TCollisionManager);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property BoundingMode : TCollisionBoundingMode read FBoundingMode write FBoundingMode;
Published property GroupIndex : Integer read FGroupIndex write SetGroupIndex;
Published property Manager : TCollisionManager read FManager write SetManager;

Refers the collision manager.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:13


GLScene v.1.1.2: GLColor

Unit GLColor

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLColor<p>

All color types, constants and utilities should go here<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPPB compatibility: restored $NODEFINE directives <li>04/11/10 - DaStr - Removed dependancy from OpenGL (this time for good) <li>24/10/10 - DaStr - Removed dependancy from OpenGL <li>23/08/10 - Yar - Added OpenGLTokens to uses <li>31/05/10 - Yar - Fixed warnings for Delhi2009/2010 <li>04/03/10 - DanB - TGLColorManager.GetColor now uses CharInSet <li>05/10/08 - DanB - Moved TGLColor/ TGLColorManager in from GLTexture.pas <li>06/06/07 - DaStr - Initial version (BugtrackerID = 1732211) (separated from GLTexture.pas and GLCrossPlatform.pas) </ul>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLColor |
record TColorEntry |
Class TGLColorManager |

Functions and Procedures

function ColorManager: TGLColorManager;
procedure RegisterColor(const aName : String; const aColor : TColorVector);
procedure UnRegisterColor(const aName : String);
function GetRValue(rgb: DWORD): Byte;
function GetGValue(rgb: DWORD): Byte;
function GetBValue(rgb: DWORD): Byte;
procedure InitGLSceneColors;
function ConvertWinColor(aColor: TColor; alpha : Single = 1) : TColorVector;
function ConvertColorVector(const AColor: TColorVector): TColor; overload;
function ConvertColorVector(const AColor: TColorVector; intensity: Single): TColor; overload;
function ConvertRGBColor(const aColor: array of Byte): TColorVector;

Types

PColorVector = ˆTColorVector;
TColorVector = TVector4f;
PRGBColor = ˆTRGBColor;
TRGBColor = TVector3b;
PColorEntry = ˆTColorEntry;

Constants

clForeground = TColor(-1);
clButton = TColor(-2);
clLight = TColor(-3);
clMidlight = TColor(-4);
clDark = TColor(-5);
clMid = TColor(-6);
clText = TColor(-7);
clBrightText = TColor(-8);
clButtonText = TColor(-9);
clBase = TColor(-10);
clBackground = TColor(-11);
clShadow = TColor(-12);
clHighlight = TColor(-13);
clHighlightedText = TColor(-14);
cloNormal = 32;
cloDisabled = 64;
cloActive = 96;
clNormalForeground = TColor(clForeground - cloNormal);
clNormalButton = TColor(clButton - cloNormal);
clNormalLight = TColor(clLight - cloNormal);
clNormalMidlight = TColor(clMidlight - cloNormal);
clNormalDark = TColor(clDark - cloNormal);
clNormalMid = TColor(clMid - cloNormal);
clNormalText = TColor(clText - cloNormal);
clNormalBrightText = TColor(clBrightText - cloNormal);
clNormalButtonText = TColor(clButtonText - cloNormal);
clNormalBase = TColor(clBase - cloNormal);
clNormalBackground = TColor(clBackground - cloNormal);
clNormalShadow = TColor(clShadow - cloNormal);
clNormalHighlight = TColor(clHighlight - cloNormal);
clNormalHighlightedText = TColor(clHighlightedText - cloNormal);
clDisabledForeground = TColor(clForeground - cloDisabled);
clDisabledButton = TColor(clButton - cloDisabled);
clDisabledLight = TColor(clLight - cloDisabled);
clDisabledMidlight = TColor(clMidlight - cloDisabled);
clDisabledDark = TColor(clDark - cloDisabled);
clDisabledMid = TColor(clMid - cloDisabled);
clDisabledText = TColor(clText - cloDisabled);
clDisabledBrightText = TColor(clBrightText - cloDisabled);
clDisabledButtonText = TColor(clButtonText - cloDisabled);
clDisabledBase = TColor(clBase - cloDisabled);
clDisabledBackground = TColor(clBackground - cloDisabled);
clDisabledShadow = TColor(clShadow - cloDisabled);
clDisabledHighlight = TColor(clHighlight - cloDisabled);
clDisabledHighlightedText = TColor(clHighlightedText - cloDisabled);
clActiveForeground = TColor(clForeground - cloActive);
clActiveButton = TColor(clButton - cloActive);
clActiveLight = TColor(clLight - cloActive);
clActiveMidlight = TColor(clMidlight - cloActive);
clActiveDark = TColor(clDark - cloActive);
clActiveMid = TColor(clMid - cloActive);
clActiveText = TColor(clText - cloActive);
clActiveBrightText = TColor(clBrightText - cloActive);
clActiveButtonText = TColor(clButtonText - cloActive);
clActiveBase = TColor(clBase - cloActive);
clActiveBackground = TColor(clBackground - cloActive);
clActiveShadow = TColor(clShadow - cloActive);
clActiveHighlight = TColor(clHighlight - cloActive);
clActiveHighlightedText = TColor(clHighlightedText - cloActive);
clFirstSpecialColor = clActiveHighlightedText;
clMask = clWhite;
clDontMask = clBlack;
clrScrollBar : TColorVector = (X:0;Y:0;Z:0;W:1);
clrBackground : TColorVector = (X:0;Y:0;Z:0;W:1);
clrActiveCaption : TColorVector = (X:0;Y:0;Z:0;W:1);
clrInactiveCaption : TColorVector = (X:0;Y:0;Z:0;W:1);
clrMenu : TColorVector = (X:0;Y:0;Z:0;W:1);
clrWindow : TColorVector = (X:0;Y:0;Z:0;W:1);
clrWindowFrame : TColorVector = (X:0;Y:0;Z:0;W:1);
clrMenuText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrWindowText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrCaptionText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrActiveBorder : TColorVector = (X:0;Y:0;Z:0;W:1);
clrInactiveBorder : TColorVector = (X:0;Y:0;Z:0;W:1);
clrAppWorkSpace : TColorVector = (X:0;Y:0;Z:0;W:1);
clrHighlight : TColorVector = (X:0;Y:0;Z:0;W:1);
clrHighlightText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrBtnFace : TColorVector = (X:0;Y:0;Z:0;W:1);
clrBtnShadow : TColorVector = (X:0;Y:0;Z:0;W:1);
clrGrayText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrBtnText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrInactiveCaptionText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrBtnHighlight : TColorVector = (X:0;Y:0;Z:0;W:1);
clr3DDkShadow : TColorVector = (X:0;Y:0;Z:0;W:1);
clr3DLight : TColorVector = (X:0;Y:0;Z:0;W:1);
clrInfoText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrInfoBk : TColorVector = (X:0;Y:0;Z:0;W:1);
clrTransparent : TColorVector = (X:0; Y:0; Z:0; W:0);
clrBlack : TColorVector = (X:0; Y:0; Z:0; W:1);
clrGray05 : TColorVector = (X:0.05; Y:0.05; Z:0.05; W:1);
clrGray10 : TColorVector = (X:0.10; Y:0.10; Z:0.10; W:1);
clrGray15 : TColorVector = (X:0.15; Y:0.15; Z:0.15; W:1);
clrGray20 : TColorVector = (X:0.20; Y:0.20; Z:0.20; W:1);
clrGray25 : TColorVector = (X:0.25; Y:0.25; Z:0.25; W:1);
clrGray30 : TColorVector = (X:0.30; Y:0.30; Z:0.30; W:1);
clrGray35 : TColorVector = (X:0.35; Y:0.35; Z:0.35; W:1);
clrGray40 : TColorVector = (X:0.40; Y:0.40; Z:0.40; W:1);
clrGray45 : TColorVector = (X:0.45; Y:0.45; Z:0.45; W:1);
clrGray50 : TColorVector = (X:0.50; Y:0.50; Z:0.50; W:1);
clrGray55 : TColorVector = (X:0.55; Y:0.55; Z:0.55; W:1);
clrGray60 : TColorVector = (X:0.60; Y:0.60; Z:0.60; W:1);
clrGray65 : TColorVector = (X:0.65; Y:0.65; Z:0.65; W:1);
clrGray70 : TColorVector = (X:0.70; Y:0.70; Z:0.70; W:1);
clrGray75 : TColorVector = (X:0.75; Y:0.75; Z:0.75; W:1);
clrGray80 : TColorVector = (X:0.80; Y:0.80; Z:0.80; W:1);
clrGray85 : TColorVector = (X:0.85; Y:0.85; Z:0.85; W:1);
clrGray90 : TColorVector = (X:0.90; Y:0.90; Z:0.90; W:1);
clrGray95 : TColorVector = (X:0.95; Y:0.95; Z:0.95; W:1);
clrWhite : TColorVector = (X:1; Y:1; Z:1; W:1);
clrDimGray : TColorVector = (X:0.329412; Y:0.329412; Z:0.329412; W:1);
clrGray : TColorVector = (X:0.752941; Y:0.752941; Z:0.752941; W:1);
clrLightGray : TColorVector = (X:0.658824; Y:0.658824; Z:0.658824; W:1);
clrAquamarine : TColorVector = (X:0.439216; Y:0.858824; Z:0.576471; W:1);
clrBlueViolet : TColorVector = (X:0.62352; Y:0.372549; Z:0.623529; W:1);
clrBrown : TColorVector = (X:0.647059; Y:0.164706; Z:0.164706; W:1);
clrCadetBlue : TColorVector = (X:0.372549; Y:0.623529; Z:0.623529; W:1);
clrCoral : TColorVector = (X:1; Y:0.498039; Z:0.0; W:1);
clrCornflowerBlue : TColorVector = (X:0.258824; Y:0.258824; Z:0.435294; W:1);
clrDarkGreen : TColorVector = (X:0.184314; Y:0.309804; Z:0.184314; W:1);
clrDarkOliveGreen : TColorVector = (X:0.309804; Y:0.309804; Z:0.184314; W:1);
clrDarkOrchid : TColorVector = (X:0.6; Y:0.196078; Z:0.8; W:1);
clrDarkSlateBlue : TColorVector = (X:0.419608; Y:0.137255; Z:0.556863; W:1);
clrDarkSlateGray : TColorVector = (X:0.184314; Y:0.309804; Z:0.309804; W:1);
clrDarkSlateGrey : TColorVector = (X:0.184314; Y:0.309804; Z:0.309804; W:1);
clrDarkTurquoise : TColorVector = (X:0.439216; Y:0.576471; Z:0.858824; W:1);
clrFirebrick : TColorVector = (X:0.556863; Y:0.137255; Z:0.137255; W:1);
clrForestGreen : TColorVector = (X:0.137255; Y:0.556863; Z:0.137255; W:1);
clrGold : TColorVector = (X:0.8; Y:0.498039; Z:0.196078; W:1);
clrGoldenrod : TColorVector = (X:0.858824; Y:0.858824; Z:0.439216; W:1);
clrGreenYellow : TColorVector = (X:0.576471; Y:0.858824; Z:0.439216; W:1);
clrIndian : TColorVector = (X:0.309804; Y:0.184314; Z:0.184314; W:1);
clrKhaki : TColorVector = (X:0.623529; Y:0.623529; Z:0.372549; W:1);
clrLightBlue : TColorVector = (X:0.74902; Y:0.847059; Z:0.847059; W:1);
clrLightSteelBlue : TColorVector = (X:0.560784; Y:0.560784; Z:0.737255; W:1);
clrLimeGreen : TColorVector = (X:0.196078; Y:0.8; Z:0.196078; W:1);
clrMaroon : TColorVector = (X:0.556863; Y:0.137255; Z:0.419608; W:1);
clrMediumAquamarine : TColorVector = (X:0.196078; Y:0.8; Z:0.6; W:1);
clrMediumBlue : TColorVector = (X:0.196078; Y:0.196078; Z:0.8; W:1);
clrMediumForestGreen : TColorVector = (X:0.419608; Y:0.556863; Z:0.137255; W:1);
clrMediumGoldenrod : TColorVector = (X:0.917647; Y:0.917647; Z:0.678431; W:1);
clrMediumOrchid : TColorVector = (X:0.576471; Y:0.439216; Z:0.858824; W:1);
clrMediumSeaGreen : TColorVector = (X:0.258824; Y:0.435294; Z:0.258824; W:1);
clrMediumSlateBlue : TColorVector = (X:0.498039; Y:0; Z:1; W:1);
clrMediumSpringGreen : TColorVector = (X:0.498039; Y:1; Z:0; W:1);
clrMediumTurquoise : TColorVector = (X:0.439216; Y:0.858824; Z:0.858824; W:1);
clrMediumViolet : TColorVector = (X:0.858824; Y:0.439216; Z:0.576471; W:1);
clrMidnightBlue : TColorVector = (X:0.184314; Y:0.184314; Z:0.309804; W:1);
clrNavy : TColorVector = (X:0.137255; Y:0.137255; Z:0.556863; W:1);
clrNavyBlue : TColorVector = (X:0.137255; Y:0.137255; Z:0.556863; W:1);
clrOrange : TColorVector = (X:1; Y:0.5; Z:0.0; W:1);
clrOrangeRed : TColorVector = (X:1; Y:0.25; Z:0; W:1);
clrOrchid : TColorVector = (X:0.858824; Y:0.439216; Z:0.858824; W:1);
clrPaleGreen : TColorVector = (X:0.560784; Y:0.737255; Z:0.560784; W:1);
clrPink : TColorVector = (X:0.737255; Y:0.560784; Z:0.560784; W:1);
clrPlum : TColorVector = (X:0.917647; Y:0.678431; Z:0.917647; W:1);
clrSalmon : TColorVector = (X:0.435294; Y:0.258824; Z:0.258824; W:1);
clrSeaGreen : TColorVector = (X:0.137255; Y:0.556863; Z:0.419608; W:1);
clrSienna : TColorVector = (X:0.556863; Y:0.419608; Z:0.137255; W:1);
clrSkyBlue : TColorVector = (X:0.196078; Y:0.6; Z:0.8; W:1);
clrSlateBlue : TColorVector = (X:0; Y:0.498039; Z:1; W:1);
clrSpringGreen : TColorVector = (X:0; Y:1; Z:0.498039; W:1);
clrSteelBlue : TColorVector = (X:0.137255; Y:0.419608; Z:0.556863; W:1);
clrTan : TColorVector = (X:0.858824; Y:0.576471; Z:0.439216; W:1);
clrThistle : TColorVector = (X:0.847059; Y:0.74902; Z:0.847059; W:1);
clrTurquoise : TColorVector = (X:0.678431; Y:0.917647; Z:0.917647; W:1);
clrViolet : TColorVector = (X:0.309804; Y:0.184314; Z:0.309804; W:1);
clrVioletRed : TColorVector = (X:0.8; Y:0.196078; Z:0.6; W:1);
clrWheat : TColorVector = (X:0.847059; Y:0.847059; Z:0.74902; W:1);
clrYellowGreen : TColorVector = (X:0.6; Y:0.8; Z:0.196078; W:1);
clrSummerSky : TColorVector = (X:0.22; Y:0.69; Z:0.87; W:1);
clrRichBlue : TColorVector = (X:0.35; Y:0.35; Z:0.67; W:1);
clrBrass : TColorVector = (X:0.71; Y:0.65; Z:0.26; W:1);
clrCopper : TColorVector = (X:0.72; Y:0.45; Z:0.20; W:1);
clrBronze : TColorVector = (X:0.55; Y:0.47; Z:0.14; W:1);
clrBronze2 : TColorVector = (X:0.65; Y:0.49; Z:0.24; W:1);
clrSilver : TColorVector = (X:0.90; Y:0.91; Z:0.98; W:1);
clrBrightGold : TColorVector = (X:0.85; Y:0.85; Z:0.10; W:1);
clrOldGold : TColorVector = (X:0.81; Y:0.71; Z:0.23; W:1);
clrFeldspar : TColorVector = (X:0.82; Y:0.57; Z:0.46; W:1);
clrQuartz : TColorVector = (X:0.85; Y:0.85; Z:0.95; W:1);
clrNeonPink : TColorVector = (X:1.00; Y:0.43; Z:0.78; W:1);
clrDarkPurple : TColorVector = (X:0.53; Y:0.12; Z:0.47; W:1);
clrNeonBlue : TColorVector = (X:0.30; Y:0.30; Z:1.00; W:1);
clrCoolCopper : TColorVector = (X:0.85; Y:0.53; Z:0.10; W:1);
clrMandarinOrange : TColorVector = (X:0.89; Y:0.47; Z:0.20; W:1);
clrLightWood : TColorVector = (X:0.91; Y:0.76; Z:0.65; W:1);
clrMediumWood : TColorVector = (X:0.65; Y:0.50; Z:0.39; W:1);
clrDarkWood : TColorVector = (X:0.52; Y:0.37; Z:0.26; W:1);
clrSpicyPink : TColorVector = (X:1.00; Y:0.11; Z:0.68; W:1);
clrSemiSweetChoc : TColorVector = (X:0.42; Y:0.26; Z:0.15; W:1);
clrBakersChoc : TColorVector = (X:0.36; Y:0.20; Z:0.09; W:1);
clrFlesh : TColorVector = (X:0.96; Y:0.80; Z:0.69; W:1);
clrNewTan : TColorVector = (X:0.92; Y:0.78; Z:0.62; W:1);
clrNewMidnightBlue : TColorVector = (X:0.00; Y:0.00; Z:0.61; W:1);
clrVeryDarkBrown : TColorVector = (X:0.35; Y:0.16; Z:0.14; W:1);
clrDarkBrown : TColorVector = (X:0.36; Y:0.25; Z:0.20; W:1);
clrDarkTan : TColorVector = (X:0.59; Y:0.41; Z:0.31; W:1);
clrGreenCopper : TColorVector = (X:0.32; Y:0.49; Z:0.46; W:1);
clrDkGreenCopper : TColorVector = (X:0.29; Y:0.46; Z:0.43; W:1);
clrDustyRose : TColorVector = (X:0.52; Y:0.39; Z:0.39; W:1);
clrHuntersGreen : TColorVector = (X:0.13; Y:0.37; Z:0.31; W:1);
clrScarlet : TColorVector = (X:0.55; Y:0.09; Z:0.09; W:1);
clrMediumPurple : TColorVector = (X:0.73; Y:0.16; Z:0.96; W:1);
clrLightPurple : TColorVector = (X:0.87; Y:0.58; Z:0.98; W:1);
clrVeryLightPurple : TColorVector = (X:0.94; Y:0.81; Z:0.99; W:1);
clrGreen : TColorVector = (X:0; Y:0.5; Z:0; W:1);
clrOlive : TColorVector = (X:0.5; Y:0.5; Z:1; W:1);
clrPurple : TColorVector = (X:1; Y:0; Z:1; W:1);
clrTeal : TColorVector = (X:0; Y:0.5; Z:0.5; W:1);
clrRed : TColorVector = (X:1; Y:0; Z:0; W:1);
clrLime : TColorVector = (X:0; Y:1; Z:0; W:1);
clrYellow : TColorVector = (X:1; Y:1; Z:0; W:1);
clrBlue : TColorVector = (X:0; Y:0; Z:1; W:1);
clrFuchsia : TColorVector = (X:1; Y:0; Z:1; W:1);
clrAqua : TColorVector = (X:0; Y:1; Z:1; W:1);
cDefaultNormalMapScale = 0.125;

Variables

vUseDefaultColorSets: Boolean = False;

Description

Functions and Procedures

function ColorManager: TGLColorManager;
procedure RegisterColor(const aName : String; const aColor : TColorVector);
procedure UnRegisterColor(const aName : String);
function GetRValue(rgb: DWORD): Byte;
function GetGValue(rgb: DWORD): Byte;
function GetBValue(rgb: DWORD): Byte;
procedure InitGLSceneColors;
function ConvertWinColor(aColor: TColor; alpha : Single = 1) : TColorVector;

Converts a delphi color into its RGB fragments and correct range.

function ConvertColorVector(const AColor: TColorVector): TColor; overload;

Converts a color vector (containing float values)

function ConvertColorVector(const AColor: TColorVector; intensity: Single): TColor; overload;

Converts a color vector (containing float values) and alter intensity.<p> intensity is in [0..1]

function ConvertRGBColor(const aColor: array of Byte): TColorVector;

Converts RGB components into a color vector with correct range

Types

PColorVector = ˆTColorVector;
TColorVector = TVector4f;
PRGBColor = ˆTRGBColor;
TRGBColor = TVector3b;
PColorEntry = ˆTColorEntry;

Constants

clForeground = TColor(-1);
clButton = TColor(-2);
clLight = TColor(-3);
clMidlight = TColor(-4);
clDark = TColor(-5);
clMid = TColor(-6);
clText = TColor(-7);
clBrightText = TColor(-8);
clButtonText = TColor(-9);
clBase = TColor(-10);
clBackground = TColor(-11);
clShadow = TColor(-12);
clHighlight = TColor(-13);
clHighlightedText = TColor(-14);
cloNormal = 32;
cloDisabled = 64;
cloActive = 96;
clNormalForeground = TColor(clForeground - cloNormal);
clNormalButton = TColor(clButton - cloNormal);
clNormalLight = TColor(clLight - cloNormal);
clNormalMidlight = TColor(clMidlight - cloNormal);
clNormalDark = TColor(clDark - cloNormal);
clNormalMid = TColor(clMid - cloNormal);
clNormalText = TColor(clText - cloNormal);
clNormalBrightText = TColor(clBrightText - cloNormal);
clNormalButtonText = TColor(clButtonText - cloNormal);
clNormalBase = TColor(clBase - cloNormal);
clNormalBackground = TColor(clBackground - cloNormal);
clNormalShadow = TColor(clShadow - cloNormal);
clNormalHighlight = TColor(clHighlight - cloNormal);
clNormalHighlightedText = TColor(clHighlightedText - cloNormal);
clDisabledForeground = TColor(clForeground - cloDisabled);
clDisabledButton = TColor(clButton - cloDisabled);
clDisabledLight = TColor(clLight - cloDisabled);
clDisabledMidlight = TColor(clMidlight - cloDisabled);
clDisabledDark = TColor(clDark - cloDisabled);
clDisabledMid = TColor(clMid - cloDisabled);
clDisabledText = TColor(clText - cloDisabled);
clDisabledBrightText = TColor(clBrightText - cloDisabled);
clDisabledButtonText = TColor(clButtonText - cloDisabled);
clDisabledBase = TColor(clBase - cloDisabled);
clDisabledBackground = TColor(clBackground - cloDisabled);
clDisabledShadow = TColor(clShadow - cloDisabled);
clDisabledHighlight = TColor(clHighlight - cloDisabled);
clDisabledHighlightedText = TColor(clHighlightedText - cloDisabled);
clActiveForeground = TColor(clForeground - cloActive);
clActiveButton = TColor(clButton - cloActive);
clActiveLight = TColor(clLight - cloActive);
clActiveMidlight = TColor(clMidlight - cloActive);
clActiveDark = TColor(clDark - cloActive);
clActiveMid = TColor(clMid - cloActive);
clActiveText = TColor(clText - cloActive);
clActiveBrightText = TColor(clBrightText - cloActive);
clActiveButtonText = TColor(clButtonText - cloActive);
clActiveBase = TColor(clBase - cloActive);
clActiveBackground = TColor(clBackground - cloActive);
clActiveShadow = TColor(clShadow - cloActive);
clActiveHighlight = TColor(clHighlight - cloActive);
clActiveHighlightedText = TColor(clHighlightedText - cloActive);
clFirstSpecialColor = clActiveHighlightedText;
clMask = clWhite;
clDontMask = clBlack;
clrScrollBar : TColorVector = (X:0;Y:0;Z:0;W:1);
clrBackground : TColorVector = (X:0;Y:0;Z:0;W:1);
clrActiveCaption : TColorVector = (X:0;Y:0;Z:0;W:1);
clrInactiveCaption : TColorVector = (X:0;Y:0;Z:0;W:1);
clrMenu : TColorVector = (X:0;Y:0;Z:0;W:1);
clrWindow : TColorVector = (X:0;Y:0;Z:0;W:1);
clrWindowFrame : TColorVector = (X:0;Y:0;Z:0;W:1);
clrMenuText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrWindowText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrCaptionText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrActiveBorder : TColorVector = (X:0;Y:0;Z:0;W:1);
clrInactiveBorder : TColorVector = (X:0;Y:0;Z:0;W:1);
clrAppWorkSpace : TColorVector = (X:0;Y:0;Z:0;W:1);
clrHighlight : TColorVector = (X:0;Y:0;Z:0;W:1);
clrHighlightText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrBtnFace : TColorVector = (X:0;Y:0;Z:0;W:1);
clrBtnShadow : TColorVector = (X:0;Y:0;Z:0;W:1);
clrGrayText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrBtnText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrInactiveCaptionText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrBtnHighlight : TColorVector = (X:0;Y:0;Z:0;W:1);
clr3DDkShadow : TColorVector = (X:0;Y:0;Z:0;W:1);
clr3DLight : TColorVector = (X:0;Y:0;Z:0;W:1);
clrInfoText : TColorVector = (X:0;Y:0;Z:0;W:1);
clrInfoBk : TColorVector = (X:0;Y:0;Z:0;W:1);
clrTransparent : TColorVector = (X:0; Y:0; Z:0; W:0);
clrBlack : TColorVector = (X:0; Y:0; Z:0; W:1);
clrGray05 : TColorVector = (X:0.05; Y:0.05; Z:0.05; W:1);
clrGray10 : TColorVector = (X:0.10; Y:0.10; Z:0.10; W:1);
clrGray15 : TColorVector = (X:0.15; Y:0.15; Z:0.15; W:1);
clrGray20 : TColorVector = (X:0.20; Y:0.20; Z:0.20; W:1);
clrGray25 : TColorVector = (X:0.25; Y:0.25; Z:0.25; W:1);
clrGray30 : TColorVector = (X:0.30; Y:0.30; Z:0.30; W:1);
clrGray35 : TColorVector = (X:0.35; Y:0.35; Z:0.35; W:1);
clrGray40 : TColorVector = (X:0.40; Y:0.40; Z:0.40; W:1);
clrGray45 : TColorVector = (X:0.45; Y:0.45; Z:0.45; W:1);
clrGray50 : TColorVector = (X:0.50; Y:0.50; Z:0.50; W:1);
clrGray55 : TColorVector = (X:0.55; Y:0.55; Z:0.55; W:1);
clrGray60 : TColorVector = (X:0.60; Y:0.60; Z:0.60; W:1);
clrGray65 : TColorVector = (X:0.65; Y:0.65; Z:0.65; W:1);
clrGray70 : TColorVector = (X:0.70; Y:0.70; Z:0.70; W:1);
clrGray75 : TColorVector = (X:0.75; Y:0.75; Z:0.75; W:1);
clrGray80 : TColorVector = (X:0.80; Y:0.80; Z:0.80; W:1);
clrGray85 : TColorVector = (X:0.85; Y:0.85; Z:0.85; W:1);
clrGray90 : TColorVector = (X:0.90; Y:0.90; Z:0.90; W:1);
clrGray95 : TColorVector = (X:0.95; Y:0.95; Z:0.95; W:1);
clrWhite : TColorVector = (X:1; Y:1; Z:1; W:1);
clrDimGray : TColorVector = (X:0.329412; Y:0.329412; Z:0.329412; W:1);
clrGray : TColorVector = (X:0.752941; Y:0.752941; Z:0.752941; W:1);
clrLightGray : TColorVector = (X:0.658824; Y:0.658824; Z:0.658824; W:1);
clrAquamarine : TColorVector = (X:0.439216; Y:0.858824; Z:0.576471; W:1);
clrBlueViolet : TColorVector = (X:0.62352; Y:0.372549; Z:0.623529; W:1);
clrBrown : TColorVector = (X:0.647059; Y:0.164706; Z:0.164706; W:1);
clrCadetBlue : TColorVector = (X:0.372549; Y:0.623529; Z:0.623529; W:1);
clrCoral : TColorVector = (X:1; Y:0.498039; Z:0.0; W:1);
clrCornflowerBlue : TColorVector = (X:0.258824; Y:0.258824; Z:0.435294; W:1);
clrDarkGreen : TColorVector = (X:0.184314; Y:0.309804; Z:0.184314; W:1);
clrDarkOliveGreen : TColorVector = (X:0.309804; Y:0.309804; Z:0.184314; W:1);
clrDarkOrchid : TColorVector = (X:0.6; Y:0.196078; Z:0.8; W:1);
clrDarkSlateBlue : TColorVector = (X:0.419608; Y:0.137255; Z:0.556863; W:1);
clrDarkSlateGray : TColorVector = (X:0.184314; Y:0.309804; Z:0.309804; W:1);
clrDarkSlateGrey : TColorVector = (X:0.184314; Y:0.309804; Z:0.309804; W:1);
clrDarkTurquoise : TColorVector = (X:0.439216; Y:0.576471; Z:0.858824; W:1);
clrFirebrick : TColorVector = (X:0.556863; Y:0.137255; Z:0.137255; W:1);
clrForestGreen : TColorVector = (X:0.137255; Y:0.556863; Z:0.137255; W:1);
clrGold : TColorVector = (X:0.8; Y:0.498039; Z:0.196078; W:1);
clrGoldenrod : TColorVector = (X:0.858824; Y:0.858824; Z:0.439216; W:1);
clrGreenYellow : TColorVector = (X:0.576471; Y:0.858824; Z:0.439216; W:1);
clrIndian : TColorVector = (X:0.309804; Y:0.184314; Z:0.184314; W:1);
clrKhaki : TColorVector = (X:0.623529; Y:0.623529; Z:0.372549; W:1);
clrLightBlue : TColorVector = (X:0.74902; Y:0.847059; Z:0.847059; W:1);
clrLightSteelBlue : TColorVector = (X:0.560784; Y:0.560784; Z:0.737255; W:1);
clrLimeGreen : TColorVector = (X:0.196078; Y:0.8; Z:0.196078; W:1);
clrMaroon : TColorVector = (X:0.556863; Y:0.137255; Z:0.419608; W:1);
clrMediumAquamarine : TColorVector = (X:0.196078; Y:0.8; Z:0.6; W:1);
clrMediumBlue : TColorVector = (X:0.196078; Y:0.196078; Z:0.8; W:1);
clrMediumForestGreen : TColorVector = (X:0.419608; Y:0.556863; Z:0.137255; W:1);
clrMediumGoldenrod : TColorVector = (X:0.917647; Y:0.917647; Z:0.678431; W:1);
clrMediumOrchid : TColorVector = (X:0.576471; Y:0.439216; Z:0.858824; W:1);
clrMediumSeaGreen : TColorVector = (X:0.258824; Y:0.435294; Z:0.258824; W:1);
clrMediumSlateBlue : TColorVector = (X:0.498039; Y:0; Z:1; W:1);
clrMediumSpringGreen : TColorVector = (X:0.498039; Y:1; Z:0; W:1);
clrMediumTurquoise : TColorVector = (X:0.439216; Y:0.858824; Z:0.858824; W:1);
clrMediumViolet : TColorVector = (X:0.858824; Y:0.439216; Z:0.576471; W:1);
clrMidnightBlue : TColorVector = (X:0.184314; Y:0.184314; Z:0.309804; W:1);
clrNavy : TColorVector = (X:0.137255; Y:0.137255; Z:0.556863; W:1);
clrNavyBlue : TColorVector = (X:0.137255; Y:0.137255; Z:0.556863; W:1);
clrOrange : TColorVector = (X:1; Y:0.5; Z:0.0; W:1);
clrOrangeRed : TColorVector = (X:1; Y:0.25; Z:0; W:1);
clrOrchid : TColorVector = (X:0.858824; Y:0.439216; Z:0.858824; W:1);
clrPaleGreen : TColorVector = (X:0.560784; Y:0.737255; Z:0.560784; W:1);
clrPink : TColorVector = (X:0.737255; Y:0.560784; Z:0.560784; W:1);
clrPlum : TColorVector = (X:0.917647; Y:0.678431; Z:0.917647; W:1);
clrSalmon : TColorVector = (X:0.435294; Y:0.258824; Z:0.258824; W:1);
clrSeaGreen : TColorVector = (X:0.137255; Y:0.556863; Z:0.419608; W:1);
clrSienna : TColorVector = (X:0.556863; Y:0.419608; Z:0.137255; W:1);
clrSkyBlue : TColorVector = (X:0.196078; Y:0.6; Z:0.8; W:1);
clrSlateBlue : TColorVector = (X:0; Y:0.498039; Z:1; W:1);
clrSpringGreen : TColorVector = (X:0; Y:1; Z:0.498039; W:1);
clrSteelBlue : TColorVector = (X:0.137255; Y:0.419608; Z:0.556863; W:1);
clrTan : TColorVector = (X:0.858824; Y:0.576471; Z:0.439216; W:1);
clrThistle : TColorVector = (X:0.847059; Y:0.74902; Z:0.847059; W:1);
clrTurquoise : TColorVector = (X:0.678431; Y:0.917647; Z:0.917647; W:1);
clrViolet : TColorVector = (X:0.309804; Y:0.184314; Z:0.309804; W:1);
clrVioletRed : TColorVector = (X:0.8; Y:0.196078; Z:0.6; W:1);
clrWheat : TColorVector = (X:0.847059; Y:0.847059; Z:0.74902; W:1);
clrYellowGreen : TColorVector = (X:0.6; Y:0.8; Z:0.196078; W:1);
clrSummerSky : TColorVector = (X:0.22; Y:0.69; Z:0.87; W:1);
clrRichBlue : TColorVector = (X:0.35; Y:0.35; Z:0.67; W:1);
clrBrass : TColorVector = (X:0.71; Y:0.65; Z:0.26; W:1);
clrCopper : TColorVector = (X:0.72; Y:0.45; Z:0.20; W:1);
clrBronze : TColorVector = (X:0.55; Y:0.47; Z:0.14; W:1);
clrBronze2 : TColorVector = (X:0.65; Y:0.49; Z:0.24; W:1);
clrSilver : TColorVector = (X:0.90; Y:0.91; Z:0.98; W:1);
clrBrightGold : TColorVector = (X:0.85; Y:0.85; Z:0.10; W:1);
clrOldGold : TColorVector = (X:0.81; Y:0.71; Z:0.23; W:1);
clrFeldspar : TColorVector = (X:0.82; Y:0.57; Z:0.46; W:1);
clrQuartz : TColorVector = (X:0.85; Y:0.85; Z:0.95; W:1);
clrNeonPink : TColorVector = (X:1.00; Y:0.43; Z:0.78; W:1);
clrDarkPurple : TColorVector = (X:0.53; Y:0.12; Z:0.47; W:1);
clrNeonBlue : TColorVector = (X:0.30; Y:0.30; Z:1.00; W:1);
clrCoolCopper : TColorVector = (X:0.85; Y:0.53; Z:0.10; W:1);
clrMandarinOrange : TColorVector = (X:0.89; Y:0.47; Z:0.20; W:1);
clrLightWood : TColorVector = (X:0.91; Y:0.76; Z:0.65; W:1);
clrMediumWood : TColorVector = (X:0.65; Y:0.50; Z:0.39; W:1);
clrDarkWood : TColorVector = (X:0.52; Y:0.37; Z:0.26; W:1);
clrSpicyPink : TColorVector = (X:1.00; Y:0.11; Z:0.68; W:1);
clrSemiSweetChoc : TColorVector = (X:0.42; Y:0.26; Z:0.15; W:1);
clrBakersChoc : TColorVector = (X:0.36; Y:0.20; Z:0.09; W:1);
clrFlesh : TColorVector = (X:0.96; Y:0.80; Z:0.69; W:1);
clrNewTan : TColorVector = (X:0.92; Y:0.78; Z:0.62; W:1);
clrNewMidnightBlue : TColorVector = (X:0.00; Y:0.00; Z:0.61; W:1);
clrVeryDarkBrown : TColorVector = (X:0.35; Y:0.16; Z:0.14; W:1);
clrDarkBrown : TColorVector = (X:0.36; Y:0.25; Z:0.20; W:1);
clrDarkTan : TColorVector = (X:0.59; Y:0.41; Z:0.31; W:1);
clrGreenCopper : TColorVector = (X:0.32; Y:0.49; Z:0.46; W:1);
clrDkGreenCopper : TColorVector = (X:0.29; Y:0.46; Z:0.43; W:1);
clrDustyRose : TColorVector = (X:0.52; Y:0.39; Z:0.39; W:1);
clrHuntersGreen : TColorVector = (X:0.13; Y:0.37; Z:0.31; W:1);
clrScarlet : TColorVector = (X:0.55; Y:0.09; Z:0.09; W:1);
clrMediumPurple : TColorVector = (X:0.73; Y:0.16; Z:0.96; W:1);
clrLightPurple : TColorVector = (X:0.87; Y:0.58; Z:0.98; W:1);
clrVeryLightPurple : TColorVector = (X:0.94; Y:0.81; Z:0.99; W:1);
clrGreen : TColorVector = (X:0; Y:0.5; Z:0; W:1);
clrOlive : TColorVector = (X:0.5; Y:0.5; Z:1; W:1);
clrPurple : TColorVector = (X:1; Y:0; Z:1; W:1);
clrTeal : TColorVector = (X:0; Y:0.5; Z:0.5; W:1);
clrRed : TColorVector = (X:1; Y:0; Z:0; W:1);
clrLime : TColorVector = (X:0; Y:1; Z:0; W:1);
clrYellow : TColorVector = (X:1; Y:1; Z:0; W:1);
clrBlue : TColorVector = (X:0; Y:0; Z:1; W:1);
clrFuchsia : TColorVector = (X:1; Y:0; Z:1; W:1);
clrAqua : TColorVector = (X:0; Y:1; Z:1; W:1);
cDefaultNormalMapScale = 0.125;

Variables

vUseDefaultColorSets: Boolean = False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:13


GLScene v.1.1.2: GLColor: Class TGLColor

Class TGLColor

Unit

GLColor

Declaration

type TGLColor = class(TGLUpdateAbleObject)

Description

Wraps an OpenGL color.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLColor

Overview

Methods

Public | constructor Create(AOwner : TPersistent); override;
Public | constructor CreateInitialized(AOwner : TPersistent; const color : TColorVector; changeEvent : TNotifyEvent = nil);
Public | destructor Destroy; override;
Public | function AsAddress : PSingle;
Protected | function GetHSVA : TVector;
Public | procedure Assign(Source : TPersistent); override;
Public | procedure Initialize(const color : TColorVector);
Public | procedure NotifyChange(Sender : TObject); override;
Public | procedure RandomColor;
Public | procedure SetColor(red, green, blue : Single; alpha : Single = 1); overload;
Protected | procedure DefineProperties(Filer: TFiler); override;
Protected | procedure ReadData(Stream: TStream);
Protected | procedure SetHSVA(const hsva : TVector);
Protected | procedure WriteData(Stream: TStream);

Properties

Public | property Alpha: Single index 3 read GetColorComponent write SetColorComponent;
Public | property AsWinColor : TColor read GetAsWinColor write SetAsWinColor;
Public | property Blue: Single index 2 read GetColorComponent write SetColorComponent;
Public | property Color : TColorVector read FColor write SetColorVector;
Public | property DefaultColor : TColorVector read FColor;
Public | property DirectColor : TColorVector read FColor write SetDirectColorVector;
Public | property Green: Single index 1 read GetColorComponent write SetColorComponent;
Public | property HSVA : TVector read GetHSVA write SetHSVA;
Public | property Red: Single index 0 read GetColorComponent write SetColorComponent;

Description

Methods

Public constructor Create(AOwner : TPersistent); override;
Public constructor CreateInitialized(AOwner : TPersistent; const color : TColorVector; changeEvent : TNotifyEvent = nil);
Public destructor Destroy; override;
Public function AsAddress : PSingle;
Protected function GetHSVA : TVector;
Public procedure Assign(Source : TPersistent); override;
Public procedure Initialize(const color : TColorVector);
Public procedure NotifyChange(Sender : TObject); override;
Public procedure RandomColor;
Public procedure SetColor(red, green, blue : Single; alpha : Single = 1); overload;
Protected procedure DefineProperties(Filer: TFiler); override;
Protected procedure ReadData(Stream: TStream);
Protected procedure SetHSVA(const hsva : TVector);
Protected procedure WriteData(Stream: TStream);

Properties

Public property Alpha: Single index 3 read GetColorComponent write SetColorComponent;
Public property AsWinColor : TColor read GetAsWinColor write SetAsWinColor;
Public property Blue: Single index 2 read GetColorComponent write SetColorComponent;
Public property Color : TColorVector read FColor write SetColorVector;
Public property DefaultColor : TColorVector read FColor;
Public property DirectColor : TColorVector read FColor write SetDirectColorVector;
Public property Green: Single index 1 read GetColorComponent write SetColorComponent;
Public property HSVA : TVector read GetHSVA write SetHSVA;
Public property Red: Single index 0 read GetColorComponent write SetColorComponent;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLColor: record TColorEntry

record TColorEntry

Unit

GLColor

Declaration

type TColorEntry = record

Description

Overview

Fields

Name: String[31];
Color: TColorVector;

Description

Fields

Name: String[31];
Color: TColorVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLColor: Class TGLColorManager

Class TGLColorManager

Unit

GLColor

Declaration

type TGLColorManager = class(TList)

Description

Hierarchy

  • TList
  • TGLColorManager

Overview

Methods

Public | destructor Destroy; override;
Public | function FindColor(const aName: String): TColorVector;
Public | function GetColor(const aName: String): TColorVector;
Public | function GetColorName(const aColor: TColorVector): String;
Public | procedure AddColor(const aName: String; const aColor: TColorVector);
Public | procedure EnumColors(Proc: TGetStrProc); overload;
Public | procedure EnumColors(AValues: TStrings); overload;
Public | procedure RegisterDefaultColors;
Public | procedure RemoveColor(const aName: String);

Description

Methods

Public destructor Destroy; override;
Public function FindColor(const aName: String): TColorVector;
Public function GetColor(const aName: String): TColorVector;

Convert a clrXxxx or a '<red green blue alpha> to a color vector

Public function GetColorName(const aColor: TColorVector): String;
Public procedure AddColor(const aName: String; const aColor: TColorVector);
Public procedure EnumColors(Proc: TGetStrProc); overload;
Public procedure EnumColors(AValues: TStrings); overload;
Public procedure RegisterDefaultColors;
Public procedure RemoveColor(const aName: String);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLCompositeImage

Unit GLCompositeImage

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLCompositeImage<p>

This class is required for loading images such classes as TGLDDSImage, TGLO3TCImage, TGLHDRImage etc.

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>22/02/10 - Yar - Added LoadFromStream (thanks to mif) <li>23/01/10 - Yar - Replaced TextureFormat to TextureFormatEx <li>21/01/10 - Yar - Creation </ul><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCompositeImage |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLCompositeImage: Class TGLCompositeImage

Class TGLCompositeImage

Unit

GLCompositeImage

Declaration

type TGLCompositeImage = class(TGLTextureImage)

Description

no description available, TGLTextureImage description follows

Base class for texture image data.<p> Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source).<br> SubClasses should be registered using RegisterGLTextureImageClass to allow proper persistence and editability in the IDE experts.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLCompositeImage

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TGLBitmap32; override;
Protected | function GetDepth: Integer; override;
Protected | function GetHeight: Integer; override;
Protected | function GetTextureTarget: TGLTextureTarget; override;
Protected | function GetWidth: Integer; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure LoadFromStream(const AStream: TStream);
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;
Protected | procedure SetDepth(val: Integer);
Protected | procedure SetHeight(val: Integer);
Protected | procedure SetWidth(val: Integer);

Properties

Published | property Depth: Integer read GetDepth write SetDepth;
Published | property Height: Integer read GetHeight write SetHeight;
Public | property NativeTextureTarget;
Published | property Width: Integer read GetWidth write SetWidth;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Public function GetBitmap32: TGLBitmap32; override;
Protected function GetDepth: Integer; override;
Protected function GetHeight: Integer; override;
Protected function GetTextureTarget: TGLTextureTarget; override;
Protected function GetWidth: Integer; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadFromFile(const fileName: string); override;
Public procedure LoadFromStream(const AStream: TStream);
Public procedure ReleaseBitmap32; override;
Public procedure SaveToFile(const fileName: string); override;
Protected procedure SetDepth(val: Integer);
Protected procedure SetHeight(val: Integer);
Protected procedure SetWidth(val: Integer);

Properties

Published property Depth: Integer read GetDepth write SetDepth;
Published property Height: Integer read GetHeight write SetHeight;
Public property NativeTextureTarget;
Published property Width: Integer read GetWidth write SetWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLConsole

Unit GLConsole

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLConsole <p>

The console is a popdown window that appears on a game for text output/input.<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>02/04/07 - DaStr - All cross-version stuff abstracted into GLCrossPlatform <li>30/03/07 - DaStr - Replaced GLWin32Viewer with GLViewer <li>25/02/07 - DaStr - Made some fixes for Delphi5 compatibility <li>23/02/07 - DaStr - Cosmetic changes, replaced some strings with resource strings from GLStrings.pas <li>15/02/07 - DaStr - Some properties are not stored now, because they are read directly from HUDSprite and HUDText <li>07/02/07 - DaStr - Initial version (donated to GLScene)

What is different compared to the original component? 1) Can be aded to any object, not just the root one 2) Has a *wide* range of built-in commands 3) TGLConsoleCommand.UnknownCommand added it is set to True, if no internal command recognized 4) Internal console help added 5) By default does not remove quotes ("), but this option can be turned on (property RemoveQuotes) 6) Command list added. All user commands are saved there 7) All previously typed commands can be accessed in a usual way (arrow up/down) 8) Commands can be auto-completed by pressing TConsoleControls.AutoCompleteCommand key, or setting AutoCompleteCommandsOnKeyPress, AutoCompleteCommandsOnEnter to True Dbl-pressing the key, defined in the TConsoleControls.AutoCompleteCommand property, gives you a list of all posible internal-external commands that start with your letters 9) Batch command execution support added 10) Short help is shown when user calls the global 'help' function Long help is shown elsewhere 11) Show command help by "/?", "-?", "–?" etc 12) Assign() added for every class

TODO: [new command] Redirection with the | operator, like in any othe console (optional) [new command] File browser stuff... (this one's optional ;)

Blinking cursor, "Delete" key support Allow long lines to continue on the next line May be SceneViewer should be a TControl to support the FullScreenViewer...

Previous version history: v1.0 23 November '2005 Creation (based on TGLConsole from http://caperaven.co.za/ v1.1 17 June '2006 Load/Save stuff upgraded v1.2 07 July '2006 Component completely rewritten (New command classes added) v1.2.4 31 August '2006 A few memory leaks fixed TGLCustomConsole.Size added Fixed a bug in TGLCustomConsole.RefreshHud "Console.Color" command fixed Bug with saving of TypedCommands fixed v1.2.5 11 September '2006 TGLCustomConsole.AutoCompleteCommand() bugfixed v1.2.6 08 October '2006 Made compatible with the new persistance mechanism 1.3 23 October '2006 TGLCustomConsole made descendant of TGLBaseSceneObject 1.4 07 February '2007 TGLCustomConsole.NumLines bugfixed TGLCustomConsole.RefreshHud bugfixed TGLConsoleCommand.GetDisplayName added TGLConsoleCommand default values added TGLConsoleStringList.Changed fixed TGLConsoleOptions added (united 4 Boolean properties) Code ready to be donated to GLScene

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLConsoleException |
record TGLUserInputCommand |
Class TGLConsoleStringList |
Class TGLConsoleCommand |
Class TGLConsoleCommandList |
Class TGLConsoleControls |
Class TGLCustomConsole |
Class TGLConsole |

Types

TGLConsoleOption = (...);
TGLConsoleOptions = set of TGLConsoleOption;
TGLlConsoleEvent = procedure(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand) of object;
TGLConsoleMatchList = set of 0..CONSOLE_MAX_COMMANDS ;

Constants

CONSOLE_MAX_COMMANDS = 120;

Description

Types

TGLConsoleOption = (...);
Values
  • coAutoCompleteCommandsOnKeyPress:
  • coAutoCompleteCommandsOnEnter:
  • coShowConsoleHelpIfUnknownCommand:
  • coRemoveQuotes:
TGLConsoleOptions = set of TGLConsoleOption;
TGLlConsoleEvent = procedure(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand) of object;

Event called when used presses the "Enter"

TGLConsoleMatchList = set of 0..CONSOLE_MAX_COMMANDS ;

Constants

CONSOLE_MAX_COMMANDS = 120;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLConsole: Class EGLConsoleException

Class EGLConsoleException

Unit

GLConsole

Declaration

type EGLConsoleException = class(Exception)

Description

Hierarchy

  • Exception
  • EGLConsoleException
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLConsole: record TGLUserInputCommand

record TGLUserInputCommand

Unit

GLConsole

Declaration

type TGLUserInputCommand = record

Description

Stores info on a command. A command is a parsed input line. Should be transformed into a class, I think...

Overview

Fields

CommandCount: Integer;
Strings: array of string;
UnknownCommand: Boolean;

Description

Fields

CommandCount: Integer;
Strings: array of string;
UnknownCommand: Boolean;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLConsole: Class TGLConsoleStringList

Class TGLConsoleStringList

Unit

GLConsole

Declaration

type TGLConsoleStringList = class(TStringList)

Description

Hierarchy

  • TStringList
  • TGLConsoleStringList

Overview

Methods

Public | constructor Create(const Owner: TGLCustomConsole);
Public | function CommandExists(const Command: string): Boolean;
Protected | function GetOwner: TPersistent; override;
Protected | procedure Changed; override;

Description

Methods

Public constructor Create(const Owner: TGLCustomConsole);
Public function CommandExists(const Command: string): Boolean;
Protected function GetOwner: TPersistent; override;
Protected procedure Changed; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLConsole: Class TGLConsoleCommand

Class TGLConsoleCommand

Unit

GLConsole

Declaration

type TGLConsoleCommand = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLConsoleCommand

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ShowHelp; virtual;
Public | procedure ShowShortHelp; virtual;
Protected | procedure DoOnCommand(var UserInputCommand: TGLUserInputCommand); virtual;
Protected | procedure ShowInvalidNumberOfArgumentsError(const ShowHelpAfter: Boolean = True); virtual;
Protected | procedure ShowInvalidUseOfCommandError; virtual;

Properties

Published | property CommandName: string read FCommandName write SetCommandName;
Published | property Enabled: Boolean read FEnabled write FEnabled default True;
Published | property LongHelp: TStringList read FLongHelp;
Published | property OnCommand: TGLlConsoleEvent read FOnCommand write FOnCommand;
Published | property OnHelp: TNotifyEvent read FOnHelp write FOnHelp;
Published | property ShortHelp: string read FShortHelp write FShortHelp;
Published | property SilentDisabled: Boolean read FSilentDisabled write FSilentDisabled default False;
Published | property Visible: Boolean read FVisible write FVisible default True;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure ShowHelp; virtual;
Public procedure ShowShortHelp; virtual;
Protected procedure DoOnCommand(var UserInputCommand: TGLUserInputCommand); virtual;
Protected procedure ShowInvalidNumberOfArgumentsError(const ShowHelpAfter: Boolean = True); virtual;
Protected procedure ShowInvalidUseOfCommandError; virtual;

Properties

Published property CommandName: string read FCommandName write SetCommandName;
Published property Enabled: Boolean read FEnabled write FEnabled default True;

Disabled commands won't execute

Published property LongHelp: TStringList read FLongHelp;
Published property OnCommand: TGLlConsoleEvent read FOnCommand write FOnCommand;
Published property OnHelp: TNotifyEvent read FOnHelp write FOnHelp;
Published property ShortHelp: string read FShortHelp write FShortHelp;
Published property SilentDisabled: Boolean read FSilentDisabled write FSilentDisabled default False;

If command is disabled and user calls it, no error report will be generated if SilentDisabled is enabled

Published property Visible: Boolean read FVisible write FVisible default True;

Hidden commands won't show when user requests command list or uses auto-complete

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLConsole: Class TGLConsoleCommandList

Class TGLConsoleCommandList

Unit

GLConsole

Declaration

type TGLConsoleCommandList = class(TCollection)

Description

Hierarchy

  • TCollection
  • TGLConsoleCommandList

Overview

Methods

Public | constructor Create(const AOwner: TGLCustomConsole);
Public | destructor Destroy; override;
Public | function Add: TGLConsoleCommand; overload;
Public | function CommandExists(const Command: string): Boolean;
Public | function GetCommandIndex(const Command: string): Integer;
Public | function LastConsoleCommand: TGLConsoleCommand;
Protected | function GetOwner: TPersistent; override;
Public | procedure SortCommands(const Ascending: Boolean = True);

Properties

Public property Items[const Index: Integer]: TGLConsoleCommand read GetItems;

Description

Methods

Public constructor Create(const AOwner: TGLCustomConsole);
Public destructor Destroy; override;
Public function Add: TGLConsoleCommand; overload;
Public function CommandExists(const Command: string): Boolean;
Public function GetCommandIndex(const Command: string): Integer;
Public function LastConsoleCommand: TGLConsoleCommand;
Protected function GetOwner: TPersistent; override;
Public procedure SortCommands(const Ascending: Boolean = True);

Properties

Public property Items[const Index: Integer]: TGLConsoleCommand read GetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLConsole: Class TGLConsoleControls

Class TGLConsoleControls

Unit

GLConsole

Declaration

type TGLConsoleControls = class(TPersistent)

Description

Hierarchy

  • TPersistent
  • TGLConsoleControls

Overview

Methods

Public | constructor Create(AOwner: TPersistent);
Protected | function GetOwner: TPersistent; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property AutoCompleteCommand: Byte read FAutoCompleteCommand write FAutoCompleteCommand default glKey_CONTROL;
Published | property DblClickDelay: Integer read FDblClickDelay write FDblClickDelay default 300;
Published | property NavigateDown: Byte read FNavigateDown write FNavigateDown default glKey_END;
Published | property NavigatePageDown: Byte read FNavigatePageDown write FNavigatePageDown default glKey_NEXT;
Published | property NavigatePageUp: Byte read FNavigatePageUp write FNavigatePageUp default glKey_PRIOR;
Published | property NavigateUp: Byte read FNavigateUp write FNavigateUp default glKey_HOME;
Published | property NextCommand: Byte read FNextCommand write FNextCommand default glKey_DOWN;
Published | property PreviousCommand: Byte read FPreviousCommand write FPreviousCommand default glKey_UP;

Description

Methods

Public constructor Create(AOwner: TPersistent);
Protected function GetOwner: TPersistent; override;
Public procedure Assign(Source: TPersistent); override;

Properties

Published property AutoCompleteCommand: Byte read FAutoCompleteCommand write FAutoCompleteCommand default glKey_CONTROL;
Published property DblClickDelay: Integer read FDblClickDelay write FDblClickDelay default 300;
Published property NavigateDown: Byte read FNavigateDown write FNavigateDown default glKey_END;
Published property NavigatePageDown: Byte read FNavigatePageDown write FNavigatePageDown default glKey_NEXT;
Published property NavigatePageUp: Byte read FNavigatePageUp write FNavigatePageUp default glKey_PRIOR;
Published property NavigateUp: Byte read FNavigateUp write FNavigateUp default glKey_HOME;
Published property NextCommand: Byte read FNextCommand write FNextCommand default glKey_DOWN;
Published property PreviousCommand: Byte read FPreviousCommand write FPreviousCommand default glKey_UP;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLConsole: Class TGLCustomConsole

Class TGLCustomConsole

Unit

GLConsole

Declaration

type TGLCustomConsole = class(TGLBaseSceneObject)

Description

TGLCustomConsole

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomConsole

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function GetFontColor: TColor; virtual;
Protected | function GetHUDSpriteColor: TColor; virtual;
Protected | function NumLines: Integer; virtual;
Protected | function ParseString(str, caract: string): TGLUserInputCommand; virtual;
Public | procedure AddLine(const str: string);
Public | procedure ClearTypedCommands;
Public | procedure ExecuteCommand(const Command: string);
Public | procedure ExecuteCommands(const Commands: TStrings);
Public | procedure NavigateDown;
Public | procedure NavigatePageDown;
Public | procedure NavigatePageUp;
Public | procedure NavigateUp;
Public | procedure ProcessKeyDown(const key: word); virtual;
Public | procedure ProcessKeyPress(const c: Char); virtual;
Public | procedure RefreshHudSize; virtual;
Protected | procedure AutoCompleteCommand(var MatchCount: Integer; var AdditionalCommandsMatchList: TGLConsoleMatchList; var CommandsMatchList: TGLConsoleMatchList); overload;
Protected | procedure AutoCompleteCommand; overload; virtual;
Protected | procedure CommandIssued(var UserInputCommand: TGLUserInputCommand); virtual;
Protected | procedure DoOnCommandIssued(var UserInputCommand: TGLUserInputCommand); virtual;
Protected | procedure FixCommand(var UserInputCommand: TGLUserInputCommand); virtual;
Protected | procedure GetHelpInternalCommandRename(Sender: TObject); virtual;
Protected | procedure HandleUnknownCommand(const Command: string); virtual;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure ProcessInput; virtual;
Protected | procedure ProcessInternalCommandClearScreen(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected | procedure ProcessInternalCommandConsoleClearTypedCommands(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected | procedure ProcessInternalCommandConsoleColor(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected | procedure ProcessInternalCommandConsoleHide(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected | procedure ProcessInternalCommandConsoleRename(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected | procedure ProcessInternalCommandHelp(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected | procedure ProcessInternalCommandSystemDate(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected | procedure ProcessInternalCommandSystemTime(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected | procedure ProcessInternalCommandViewerAntiAliasing(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected | procedure ProcessInternalCommandViewerFPS(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected | procedure ProcessInternalCommandViewerResetPerformanceMonitor(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected | procedure ProcessInternalCommandViewerVSync(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected | procedure RefreshHud; virtual;
Protected | procedure RegisterBuiltInCommands; virtual;
Protected | procedure SetFontColor(const Color: TColor); virtual;
Protected | procedure SetHUDSpriteColor(const Color: TColor); virtual;
Protected | procedure SetName(const Value: TComponentName); override;
Protected | procedure ShowConsoleHelp; virtual;

Properties

Public | property AdditionalCommands: TGLConsoleStringList read FAdditionalCommands;
Public | property ColsoleLog: TStringList read FColsoleLog;
Public | property Commands: TGLConsoleCommandList read FCommands;
Public | property Controls: TGLConsoleControls read FControls;
Public | property Font: TGLCustomBitmapFont read GetFont write SetFont stored False;
Public | property FontColor: TColor read GetFontColor write SetFontColor stored False;
Public | property Hint: string read FHint write FHint;
Public | property HudSprite: TGLHudSprite read FHudSprite;
Public | property HUDSpriteColor: TColor read GetHUDSpriteColor write SetHUDSpriteColor stored False;
Public | property HudText: TGLHudText read FHudText;
Public | property InputLine: string read FInputLine write FInputLine;
Public | property OnCommandIssued: TGLlConsoleEvent read FOnCommandIssued write FOnCommandIssued;
Public | property Options: TGLConsoleOptions read FOptions write FOptions;
Public | property SceneViewer: TGLSceneViewer read FSceneViewer write SetSceneViewer;
Public | property Size: Single read FSize write SetSize;
Public | property TypedCommands: TStringList read FTypedCommands;
Public | property Visible default False;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function GetFontColor: TColor; virtual;
Protected function GetHUDSpriteColor: TColor; virtual;
Protected function NumLines: Integer; virtual;
Protected function ParseString(str, caract: string): TGLUserInputCommand; virtual;
Public procedure AddLine(const str: string);

Adds a line (which is not treated as a command).

Public procedure ClearTypedCommands;

TypedCommands are cleared and current command index is reset.

Public procedure ExecuteCommand(const Command: string);
Public procedure ExecuteCommands(const Commands: TStrings);
Public procedure NavigateDown;
Public procedure NavigatePageDown;
Public procedure NavigatePageUp;
Public procedure NavigateUp;

Navigation through code from outside

Public procedure ProcessKeyDown(const key: word); virtual;
Public procedure ProcessKeyPress(const c: Char); virtual;

Methods: User *must* call these methodsin his code.

Public procedure RefreshHudSize; virtual;

Refreshes the size of the hud to reflect changes on the viewer. Should be called whenever the viewer's size changes.

Protected procedure AutoCompleteCommand(var MatchCount: Integer; var AdditionalCommandsMatchList: TGLConsoleMatchList; var CommandsMatchList: TGLConsoleMatchList); overload;
Protected procedure AutoCompleteCommand; overload; virtual;

Auto Complete Command

Protected procedure CommandIssued(var UserInputCommand: TGLUserInputCommand); virtual;

Command interpreters

Protected procedure DoOnCommandIssued(var UserInputCommand: TGLUserInputCommand); virtual;

Misc

Protected procedure FixCommand(var UserInputCommand: TGLUserInputCommand); virtual;
Protected procedure GetHelpInternalCommandRename(Sender: TObject); virtual;
Protected procedure HandleUnknownCommand(const Command: string); virtual;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure ProcessInput; virtual;
Protected procedure ProcessInternalCommandClearScreen(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected procedure ProcessInternalCommandConsoleClearTypedCommands(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected procedure ProcessInternalCommandConsoleColor(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected procedure ProcessInternalCommandConsoleHide(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected procedure ProcessInternalCommandConsoleRename(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected procedure ProcessInternalCommandHelp(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;

Internal command handlers:

Protected procedure ProcessInternalCommandSystemDate(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected procedure ProcessInternalCommandSystemTime(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected procedure ProcessInternalCommandViewerAntiAliasing(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected procedure ProcessInternalCommandViewerFPS(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected procedure ProcessInternalCommandViewerResetPerformanceMonitor(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected procedure ProcessInternalCommandViewerVSync(const ConsoleCommand: TGLConsoleCommand; const Console: TGLCustomConsole; var Command: TGLUserInputCommand); virtual;
Protected procedure RefreshHud; virtual;

Refreshes the Hud (clip lines outside the visible console).

Protected procedure RegisterBuiltInCommands; virtual;

Register built-in commands (onCreate)

Protected procedure SetFontColor(const Color: TColor); virtual;
Protected procedure SetHUDSpriteColor(const Color: TColor); virtual;
Protected procedure SetName(const Value: TComponentName); override;
Protected procedure ShowConsoleHelp; virtual;

Properties

Public property AdditionalCommands: TGLConsoleStringList read FAdditionalCommands;

Aditional commands can be registered to participate in command auto-completion. They can be interpreted in the global OnCommandIssued event handler.

Public property ColsoleLog: TStringList read FColsoleLog;

list of commands that user typed and console's responces.

Public property Commands: TGLConsoleCommandList read FCommands;

Commands have events that are called when user types a sertauin command

Public property Controls: TGLConsoleControls read FControls;

User controls.

Public property Font: TGLCustomBitmapFont read GetFont write SetFont stored False;
Public property FontColor: TColor read GetFontColor write SetFontColor stored False;

Changes the console font color.

Public property Hint: string read FHint write FHint;

Standard stuff

Public property HudSprite: TGLHudSprite read FHudSprite;
Public property HUDSpriteColor: TColor read GetHUDSpriteColor write SetHUDSpriteColor stored False;
Public property HudText: TGLHudText read FHudText;
Public property InputLine: string read FInputLine write FInputLine;

Where user enters his commands.

Public property OnCommandIssued: TGLlConsoleEvent read FOnCommandIssued write FOnCommandIssued;
Public property Options: TGLConsoleOptions read FOptions write FOptions;
Public property SceneViewer: TGLSceneViewer read FSceneViewer write SetSceneViewer;

Visual stuff.

Public property Size: Single read FSize write SetSize;

Allows to change consol's height from 0 to 1.

Public property TypedCommands: TStringList read FTypedCommands;

List of commands that user typed.

Public property Visible default False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLConsole: Class TGLConsole

Class TGLConsole

Unit

GLConsole

Declaration

type TGLConsole = class(TGLCustomConsole)

Description

no description available, TGLCustomConsole description follows

TGLCustomConsole

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomConsole
  • TGLConsole

Overview

Properties

Published | property AdditionalCommands;
Published | property ColsoleLog;
Published | property Commands;
Published | property Controls;
Published | property Font;
Published | property FontColor;
Published | property Hint;
Published | property HudSprite;
Published | property HUDSpriteColor;
Published | property HudText;
Published | property InputLine;
Published | property ObjectsSorting;
Published | property OnCommandIssued;
Published | property OnProgress;
Published | property Options;
Published | property SceneViewer;
Published | property Tag;
Published | property TypedCommands;
Published | property Visible;

Description

Properties

Published property AdditionalCommands;
Published property ColsoleLog;
Published property Commands;
Published property Controls;
Published property Font;
Published property FontColor;
Published property Hint;
Published property HudSprite;
Published property HUDSpriteColor;
Published property HudText;
Published property InputLine;
Published property ObjectsSorting;
Published property OnCommandIssued;
Published property OnProgress;
Published property Options;
Published property SceneViewer;
Published property Tag;
Published property TypedCommands;
Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLContext

Unit GLContext

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLContext<p>

Prototypes and base implementation of TGLContext.<p>

<b>History : </b><font size=-1><ul> <li>01/06/11 - Yar - Now number of rendering contexts is unlimited (by Gabriel Corneanu) <li>13/05/11 - Yar - Made indexing for context's handles to improve speed of operations <li>24/03/11 - Yar - Added preparation arrangement to TGLContext, TGLContextHandle <li>24/11/10 - Yar - Added TGLBooleanOcclusionQueryHandle <li>14/10/10 - Yar - Added ServiceContext in separate thread, procedure AddTaskForServiceContext <li>16/09/10 - YP - Fixes param assertion to display missing attrib, uniform or varying by name <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter Added to TGLContext property PipelineTransformation Added feature of debug context creating Improved TGLContextHandle destroying Added TGLARBVertexProgramHandle, TGLARBFragmentProgramHandle, TGLARBGeometryProgramHandle <li>02/08/10 - DaStr - Bugfixed TGLContextHandle.DestroyHandle() <li>18/07/10 - Yar - Added TGLTessControlShaderHandle, TGLTessEvaluationShaderHandle, TGLSamplerHandle <li>17/06/10 - Yar - Added IsDataNeedUpdate, NotifyDataUpdated, NotifyChangesOfData to TGLContextHandle <li>02/05/10 - Yar - Fixes for Linux x64. Make outputDevice HWND type. <li>02/05/10 - Yar - Handles are universal for contexts. You can use one handle in different contexts, regardless of the compatibility of contexts. <li>01/05/10 - Yar - Added buffer objects state cashing <li>22/04/10 - Yar - Fixes after GLState revision <li>18/03/10 - Yar - Added MapBufferRange, Flush to TGLBufferObjectHandle <li>06/03/10 - Yar - Added to TGLProgramHandle BindFragDataLocation, GetUniformOffset, GetUniformBlockIndex <li>05/03/10 - DanB - More state added to TGLStateCache <li>22/02/10 - DanB - Added TGLContext.GLStates, to be used to cache global per-context state. Removed BindedGLSLProgram since it should be per-context state. <li>21/02/10 - Yar - Added function BindedGLSLProgram <li>08/01/10 - DaStr - Added TGLFramebufferHandle.AttachLayer() Added more AntiAliasing modes (thanks YarUndeoaker) <li>13/12/09 - DaStr - Modified for multithread support (thanks Controller) <li>30/08/09 - DanB - renamed vIgnoreContextActivationFailures to vContextActivationFailureOccurred + re-enabled it's original behaviour (fixes major memory leak). <li>30/08/09 - DanB - Added TGLTransformFeedbackBufferHandle, TGLTextureBufferHandle, TGLUniformBufferHandle, TGLVertexArrayHandle, TGLFramebufferHandle, TGLRenderbufferHandle <li>24/08/09 - DaStr - Added TGLProgramHandle.GetVaryingLocation(), AddActiveVarying() (thanks YarUnderoaker) <li>21/08/09 - DanB - TGLQueryHandle.GetTarget no longer a class function, for earlier Delphi compatibility <li>13/08/09 - DanB - Added timer & primitive queries. Occlusion queries now use OpenGL 1.5+ queries, instead of GL_NV_occlusion_query extension <li>10/06/09 - DanB - removed OpenGL error handling code, it already exists in OpenGL1x.pas <li>16/03/08 - DanB - moved MRT_BUFFERS into unit from opengl1x.pas rewrite, and added some experimental geometry shader code <li>15/03/08 - DaStr - Fixups for vIgnoreContextActivationFailures mode (BugTracker ID = 1914782) <li>06/11/07 - LC - moved vIgnoreContextActivationFailures to "Interface" section <li>24/06/06 - LC - Refactored TGLVBOHandle, introduced TGLBufferObjectHandle and TGLPackPBOHandle/TGLUnpackPBOHandle <li>15/02/07 - DaStr - Added more parameters to TGLProgramHandle TGLProgramHandle.Name is now a property <li>15/02/07 - DaStr - Integer -> Cardinal because $R- was removed in GLScene.pas <li>15/09/06 - NC - TGLContextHandle.handle as Integer -> Cardinal <li>11/09/06 - NC - Added TGLProgramHandle.Name, TGLProgramHandle.Uniform2f, SetUniform*, support for Multiple-Render-Target <li>25/04/04 - EG - Added TGLOcclusionQueryHandle.Active <li>25/09/03 - EG - Added TGLVBOHandle <li>20/09/03 - EG - Added TGLOcclusionQueryHandle <li>30/01/02 - EG - Added TGLVirtualHandle <li>29/01/02 - EG - Improved recovery for context creation failures <li>28/01/02 - EG - Activation failures always ignored <li>21/01/02 - EG - Activation failures now ignored if application is terminating (workaround for some weird ICDs) <li>15/12/01 - EG - Added support for AlphaBits <li>30/11/01 - EG - Added TGLContextAcceleration <li>06/09/01 - EG - Win32Context moved to new GLWin32Context unit <li>04/09/01 - EG - Added ChangeIAttrib, support for 16bits depth buffer <li>25/08/01 - EG - Added pbuffer support and CreateMemoryContext interface <li>24/08/01 - EG - Fixed PropagateSharedContext <li>12/08/01 - EG - Handles management completed <li>22/07/01 - EG - Creation (glcontext.omm) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TFinishTaskEvent |
record TServiceContextTask |
Class TAbstractMultitextureCoordinator |
Class TGLContext |
Class TGLScreenControlingContext |
record TGLRCHandle |
Class TGLContextHandle |
Class TGLVirtualHandle |
Class TGLVirtualHandleTransf |
Class TGLListHandle |
Class TGLTextureHandle |
Class TGLSamplerHandle |
Class TGLQueryHandle |
Class TGLOcclusionQueryHandle |
Class TGLBooleanOcclusionQueryHandle |
Class TGLTimerQueryHandle |
Class TGLPrimitiveQueryHandle |
Class TGLBufferObjectHandle |
Class TGLVBOHandle |
Class TGLVBOArrayBufferHandle |
Class TGLVBOElementArrayHandle |
Class TGLPackPBOHandle |
Class TGLUnpackPBOHandle |
Class TGLTransformFeedbackBufferHandle |
Class TGLTextureBufferHandle |
Class TGLUniformBufferHandle |
Class TGLVertexArrayHandle |
Class TGLFramebufferHandle |
Class TGLRenderbufferHandle |
Class TGLARBProgramHandle |
Class TGLARBVertexProgramHandle |
Class TGLARBFragmentProgramHandle |
Class TGLARBGeometryProgramHandle |
Class TGLSLHandle |
Class TGLShaderHandle |
Class TGLVertexShaderHandle |
Class TGLGeometryShaderHandle |
Class TGLFragmentShaderHandle |
Class TGLTessControlShaderHandle |
Class TGLTessEvaluationShaderHandle |
Class TGLProgramHandle |
record TGLContextNotification |
Class TGLContextManager |
Class EGLContext |
Class EPBuffer |
Class EGLShader |

Functions and Procedures

procedure RegisterGLContextClass(aGLContextClass: TGLContextClass);
function CurrentGLContext: TGLContext;
function SafeCurrentGLContext: TGLContext;
function GL: TGLExtensionsAndEntryPoints;
function IsMainThread: Boolean;
function IsServiceContextAvaible: Boolean;
function GetServiceWindow: TForm;
procedure AddTaskForServiceContext(ATask: TTaskProcedure; FinishEvent: TFinishTaskEvent = nil);

Types

TGLRCOption = (...);
TGLRCOptions = set of TGLRCOption;
TGLContextLayer = (...);
TTaskProcedure = procedure of object; stdcall;
TServiceContextTaskList = GThreadList < TServiceContextTask > ;
TAbstractMultitextureCoordinatorClass = class of TAbstractMultitextureCoordinator;
TGLContextAcceleration = (...);
TGLAntiAliasing = (...);
TVSyncMode = (...);
TGLContextClass = class of TGLContext;
PGLRCHandle = ˆTGLRCHandle;
TOnPrepareHandleData = procedure(AContext: TGLContext) of object;
TGLVirtualHandleEvent = procedure(Sender: TGLVirtualHandle; var handle: TGLuint) of object;
TGLFramebufferStatus = (...);
TGLShaderHandleClass = class of TGLShaderHandle;

Constants

MRT_BUFFERS: array[0..3] of GLenum = (GL_FRONT_LEFT, GL_AUX0, GL_AUX1, GL_AUX2);
cIncompatibleContexts = 'Incompatible contexts';
cDeleteContextFailed = 'Delete context failed';
cContextActivationFailed = 'Context activation failed: %X, %s';
cContextDeactivationFailed = 'Context deactivation failed';
cUnableToCreateLegacyContext = 'Unable to create legacy context';
cNoActiveRC = 'No active rendering context';
glsFailedToShare = 'DoCreateContext - Failed to share contexts';

Variables

GLContextManager: TGLContextManager;
vIgnoreOpenGLErrors: Boolean = False;
vContextActivationFailureOccurred: Boolean = false;
vMultitextureCoordinatorClass: TAbstractMultitextureCoordinatorClass;

Description

Functions and Procedures

procedure RegisterGLContextClass(aGLContextClass: TGLContextClass);

Drivers should register themselves via this function.

function CurrentGLContext: TGLContext;

The TGLContext that is the currently active context, if any.<p> Returns nil if no context is active.

function SafeCurrentGLContext: TGLContext;
function GL: TGLExtensionsAndEntryPoints;
function IsMainThread: Boolean;
function IsServiceContextAvaible: Boolean;
function GetServiceWindow: TForm;
procedure AddTaskForServiceContext(ATask: TTaskProcedure; FinishEvent: TFinishTaskEvent = nil);

Types

TGLRCOption = (...);
Values
  • rcoDoubleBuffered:
  • rcoStereo:
  • rcoDebug:
  • rcoOGL_ES:
TGLRCOptions = set of TGLRCOption;
TGLContextLayer = (...);
Values
  • clUnderlay2:
  • clUnderlay1:
  • clMainPlane:
  • clOverlay1:
  • clOverlay2:
TTaskProcedure = procedure of object; stdcall;
TServiceContextTaskList = GThreadList < TServiceContextTask > ;
TAbstractMultitextureCoordinatorClass = class of TAbstractMultitextureCoordinator;
TGLContextAcceleration = (...);
Values
  • chaUnknown:
  • chaHardware:
  • chaSoftware:
TGLAntiAliasing = (...);
Values
  • aaDefault:
  • aaNone:
  • aa2x:
  • aa2xHQ:
  • aa4x:
  • aa4xHQ:
  • aa6x:
  • aa8x:
  • aa16x:
  • csa8x:
  • csa8xHQ:
  • csa16x:
  • csa16xHQ:
TVSyncMode = (...);
Values
  • vsmSync:
  • vsmNoSync:
TGLContextClass = class of TGLContext;
PGLRCHandle = ˆTGLRCHandle;
TOnPrepareHandleData = procedure(AContext: TGLContext) of object;
TGLVirtualHandleEvent = procedure(Sender: TGLVirtualHandle; var handle: TGLuint) of object;
TGLFramebufferStatus = (...);
Values
  • fsComplete:
  • fsIncompleteAttachment:
  • fsIncompleteMissingAttachment:
  • fsIncompleteDuplicateAttachment:
  • fsIncompleteDimensions:
  • fsIncompleteFormats:
  • fsIncompleteDrawBuffer:
  • fsIncompleteReadBuffer:
  • fsUnsupported:
  • fsIncompleteMultisample:
  • fsStatusError:
TGLShaderHandleClass = class of TGLShaderHandle;

Constants

MRT_BUFFERS: array[0..3] of GLenum = (GL_FRONT_LEFT, GL_AUX0, GL_AUX1, GL_AUX2);
cIncompatibleContexts = 'Incompatible contexts';
cDeleteContextFailed = 'Delete context failed';
cContextActivationFailed = 'Context activation failed: %X, %s';
cContextDeactivationFailed = 'Context deactivation failed';
cUnableToCreateLegacyContext = 'Unable to create legacy context';
cNoActiveRC = 'No active rendering context';
glsFailedToShare = 'DoCreateContext - Failed to share contexts';

Variables

GLContextManager: TGLContextManager;
vIgnoreOpenGLErrors: Boolean = False;
vContextActivationFailureOccurred: Boolean = false;
vMultitextureCoordinatorClass: TAbstractMultitextureCoordinatorClass;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLContext: Class TFinishTaskEvent

Class TFinishTaskEvent

Unit

GLContext

Declaration

type TFinishTaskEvent = class(TEvent)

Description

Hierarchy

  • TEvent
  • TFinishTaskEvent

Overview

Methods

Public constructor Create; reintroduce;

Description

Methods

Public constructor Create; reintroduce;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLContext: record TServiceContextTask

record TServiceContextTask

Unit

GLContext

Declaration

type TServiceContextTask = record

Description

Overview

Fields

Task: TTaskProcedure;
Event: TFinishTaskEvent;

Description

Fields

Task: TTaskProcedure;
Event: TFinishTaskEvent;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLContext: Class TAbstractMultitextureCoordinator

Class TAbstractMultitextureCoordinator

Unit

GLContext

Declaration

type TAbstractMultitextureCoordinator = class(TObject)

Description

Hierarchy

  • TObject
  • TAbstractMultitextureCoordinator

Overview

Fields

Protected FOwner: TGLContext;

Methods

Public constructor Create(AOwner: TGLContext); virtual;

Description

Fields

Protected FOwner: TGLContext;

Methods

Public constructor Create(AOwner: TGLContext); virtual;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLContext: Class TGLContext

Class TGLContext

Unit

GLContext

Declaration

type TGLContext = class(TObject)

Description

Wrapper around an OpenGL rendering context.<p> The aim of this class is to offer platform-independant initialization, activation and management of OpenGL rendering context. The class also offers notifications event and error/problems detection.<br> This is a virtual abstract a class, and platform-specific subclasses must be used.<br> All rendering context share the same lists.

Hierarchy

  • TObject
  • TGLContext

Overview

Fields

Protected | FGL: TGLExtensionsAndEntryPoints;
Protected | FXGL: TAbstractMultitextureCoordinator;
Protected | FGLStates: TGLStateCache;
Protected | FTransformation: TGLTransformation;
Protected | FAcceleration: TGLContextAcceleration;
Protected | FLayer: TGLContextLayer;
Protected | FSharedContexts: TThreadList;
Protected | FLock: TCriticalSection;

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | function FindCompatibleContext: TGLContext;
Public | function IsValid: Boolean; virtual; abstract;
Public | function RenderOutputDevice: Pointer; virtual; abstract;
Protected | function DoShareLists(aContext: TGLContext): Boolean; virtual; abstract;
Protected | function GetXGL: TAbstractMultitextureCoordinator;
Protected | class function ServiceContext: TGLContext;
Public | procedure Activate;
Public | procedure CreateContext(ADeviceHandle: HDC); overload;
Public | procedure CreateMemoryContext(outputDevice: HWND; width, height: Integer; BufferCount: integer = 1);
Public | procedure Deactivate;
Public | procedure DestroyAllHandles;
Public | procedure DestroyContext;
Public | procedure PrepareHandlesData;
Public | procedure ShareLists(aContext: TGLContext);
Public | procedure SwapBuffers; virtual; abstract;
Protected | procedure DoActivate; virtual; abstract;
Protected | procedure DoCreateContext(ADeviceHandle: HDC); virtual; abstract;
Protected | procedure DoCreateMemoryContext(outputDevice: HWND; width, height: Integer; BufferCount: integer = 1); virtual; abstract;
Protected | procedure DoDeactivate; virtual; abstract;
Protected | procedure DoDestroyContext; virtual; abstract;
Protected | procedure MakeGLCurrent;
Protected | procedure PropagateSharedContext;

Properties

Public | property Acceleration: TGLContextAcceleration read FAcceleration write SetAcceleration;
Public | property AccumBits: Integer read FAccumBits write SetAccumBits;
Public | property Active: Boolean read GetActive write SetActive;
Public | property AlphaBits: Integer read FAlphaBits write SetAlphaBits;
Public | property AntiAliasing: TGLAntiAliasing read FAntiAliasing write SetAntiAliasing;
Public | property AuxBuffers: Integer read FAuxBuffers write SetAuxBuffers;
Public | property ColorBits: Integer read FColorBits write SetColorBits;
Public | property DepthBits: Integer read FDepthBits write SetDepthBits;
Public | property GL: TGLExtensionsAndEntryPoints read FGL;
Public | property GLStates: TGLStateCache read FGLStates;
Public | property IsPraparationNeed: Boolean read FIsPraparationNeed;
Public | property Layer: TGLContextLayer read FLayer write SetLayer;
Public | property Manager: TGLContextManager read FManager;
Public | property MultitextureCoordinator: TAbstractMultitextureCoordinator read GetXGL;
Public | property OnDestroyContext: TNotifyEvent read FOnDestroyContext write FOnDestroyContext;
Public | property Options: TGLRCOptions read FOptions write SetOptions;
Public | property PipelineTransformation: TGLTransformation read FTransformation;
Public | property StencilBits: Integer read FStencilBits write SetStencilBits;

Description

Fields

Protected FGL: TGLExtensionsAndEntryPoints;
Protected FXGL: TAbstractMultitextureCoordinator;
Protected FGLStates: TGLStateCache;
Protected FTransformation: TGLTransformation;
Protected FAcceleration: TGLContextAcceleration;
Protected FLayer: TGLContextLayer;
Protected FSharedContexts: TThreadList;
Protected FLock: TCriticalSection;

Methods

Public constructor Create; virtual;
Public destructor Destroy; override;
Public function FindCompatibleContext: TGLContext;

Returns the first compatible context that isn't self in the shares.

Public function IsValid: Boolean; virtual; abstract;

Returns true if the context is valid.<p> A context is valid from the time it has been successfully created to the time of its destruction.

Public function RenderOutputDevice: Pointer; virtual; abstract;
Protected function DoShareLists(aContext: TGLContext): Boolean; virtual; abstract;
Protected function GetXGL: TAbstractMultitextureCoordinator;
Protected class function ServiceContext: TGLContext;
Public procedure Activate;

Activates the context.<p> A context can be activated multiple times (and must be deactivated the same number of times), but this function will fail if another context is already active.

Public procedure CreateContext(ADeviceHandle: HDC); overload;

Creates the context.<p> This method must be invoked before the context can be used.

Public procedure CreateMemoryContext(outputDevice: HWND; width, height: Integer; BufferCount: integer = 1);

Creates an in-memory context.<p> The function should fail if no hardware-accelerated memory context can be created (the CreateContext method can handle software OpenGL contexts).

Public procedure Deactivate;

Deactivates the context.<p> Will fail if the context is not active or another context has been activated.

Public procedure DestroyAllHandles;
Public procedure DestroyContext;

Destroy the context.<p> Will fail if no context has been created.<br> The method will first invoke the OnDestroyContext event, then attempts to deactivate the context (if it is active) before destroying it.

Public procedure PrepareHandlesData;

Call OnPrepare for all handles.<p>

Public procedure ShareLists(aContext: TGLContext);

Setup display list sharing between two rendering contexts.<p> Both contexts must have the same pixel format.

Public procedure SwapBuffers; virtual; abstract;

Request to swap front and back buffers if they were defined.

Protected procedure DoActivate; virtual; abstract;
Protected procedure DoCreateContext(ADeviceHandle: HDC); virtual; abstract;
Protected procedure DoCreateMemoryContext(outputDevice: HWND; width, height: Integer; BufferCount: integer = 1); virtual; abstract;
Protected procedure DoDeactivate; virtual; abstract;
Protected procedure DoDestroyContext; virtual; abstract;
Protected procedure MakeGLCurrent;
Protected procedure PropagateSharedContext;

Properties

Public property Acceleration: TGLContextAcceleration read FAcceleration write SetAcceleration;

Indicates if the context is hardware-accelerated.

Public property AccumBits: Integer read FAccumBits write SetAccumBits;

Accumulation buffer bits for the rendering context

Public property Active: Boolean read GetActive write SetActive;

Allows reading and defining the activity for the context.<p> The methods of this property are just wrappers around calls to Activate and Deactivate.

Public property AlphaBits: Integer read FAlphaBits write SetAlphaBits;

Alpha bits for the rendering context

Public property AntiAliasing: TGLAntiAliasing read FAntiAliasing write SetAntiAliasing;

AntiAliasing option.<p> Ignored if not hardware supported, currently based on ARB_multisample.

Public property AuxBuffers: Integer read FAuxBuffers write SetAuxBuffers;

Auxiliary buffers bits for the rendering context

Public property ColorBits: Integer read FColorBits write SetColorBits;

Color bits for the rendering context

Public property DepthBits: Integer read FDepthBits write SetDepthBits;

Depth bits for the rendering context

Public property GL: TGLExtensionsAndEntryPoints read FGL;

Access to OpenGL command and extension.

Public property GLStates: TGLStateCache read FGLStates;

An application-side cache of global per-context OpenGL states and parameters

Public property IsPraparationNeed: Boolean read FIsPraparationNeed;
Public property Layer: TGLContextLayer read FLayer write SetLayer;

Specifies the layer plane that the rendering context is bound to.

Public property Manager: TGLContextManager read FManager;

Context manager reference

Public property MultitextureCoordinator: TAbstractMultitextureCoordinator read GetXGL;
Public property OnDestroyContext: TNotifyEvent read FOnDestroyContext write FOnDestroyContext;

Triggered whenever the context is destroyed.<p> This events happens *before* the context has been actually destroyed, OpenGL resource cleanup can still occur here.

Public property Options: TGLRCOptions read FOptions write SetOptions;

Rendering context options.

Public property PipelineTransformation: TGLTransformation read FTransformation;
Public property StencilBits: Integer read FStencilBits write SetStencilBits;

Stencil bits for the rendering context

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:14


GLScene v.1.1.2: GLContext: Class TGLScreenControlingContext

Class TGLScreenControlingContext

Unit

GLContext

Declaration

type TGLScreenControlingContext = class(TGLContext)

Description

A TGLContext with screen control property and methods.<p> This variety of contexts is for drivers that access windows and OpenGL through an intermediate opaque cross-platform API.<p> TGLSceneViewer won't use them, TGLMemoryViewer may be able to use them, but most of the time they will be accessed through a specific viewer class/subclass.

Hierarchy

  • TObject
  • TGLContext
  • TGLScreenControlingContext

Overview

Properties

Public | property FullScreen: Boolean read FFullScreen write FFullScreen;
Public | property Height: Integer read FHeight write FHeight;
Public | property Width: Integer read FWidth write FWidth;

Description

Properties

Public property FullScreen: Boolean read FFullScreen write FFullScreen;
Public property Height: Integer read FHeight write FHeight;
Public property Width: Integer read FWidth write FWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: record TGLRCHandle

record TGLRCHandle

Unit

GLContext

Declaration

type TGLRCHandle = record

Description

Overview

Fields

FRenderingContext: TGLContext;
FHandle: TGLuint;
FChanged: Boolean;

Description

Fields

FRenderingContext: TGLContext;
FHandle: TGLuint;
FChanged: Boolean;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLContextHandle

Class TGLContextHandle

Unit

GLContext

Declaration

type TGLContextHandle = class(TObject)

Description

Wrapper around an OpenGL context handle.<p> This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TGLListHandle and TGLTextureHandle subclasses.

Hierarchy

  • TObject
  • TGLContextHandle

Overview

Methods

Public | constructor Create; virtual;
Public | constructor CreateAndAllocate(failIfAllocationFailed: Boolean = True);
Public | destructor Destroy; override;
Public | function AllocateHandle: TGLuint;
Public | function IsAllocatedForContext(AContext: TGLContext = nil): Boolean;
Public | function IsDataComplitelyUpdated: Boolean;
Public | function IsDataNeedUpdate: Boolean;
Public | function IsShared: Boolean;
Public | class function IsSupported: Boolean; virtual;
Protected | function DoAllocateHandle: Cardinal; virtual; abstract;
Protected | class function IsValid(const ID: GLuint): Boolean; virtual;
Protected | class function Transferable: Boolean; virtual;
Public | procedure DestroyHandle;
Public | procedure NotifyChangesOfData;
Public | procedure NotifyDataUpdated;
Protected | procedure ContextDestroying;
Protected | procedure DoDestroyHandle(var AHandle: TGLuint); virtual; abstract;

Properties

Public | property Handle: TGLuint read GetHandle;
Public | property OnPrapare: TOnPrepareHandleData read FOnPrepare write FOnPrepare;
Public | property RenderingContext: TGLContext read GetContext;

Description

Methods

Public constructor Create; virtual;
Public constructor CreateAndAllocate(failIfAllocationFailed: Boolean = True);
Public destructor Destroy; override;
Public function AllocateHandle: TGLuint;
Public function IsAllocatedForContext(AContext: TGLContext = nil): Boolean;
Public function IsDataComplitelyUpdated: Boolean;

Return True if data updated in all contexts.

Public function IsDataNeedUpdate: Boolean;

Return True is data need update in current context.

Public function IsShared: Boolean;
Public class function IsSupported: Boolean; virtual;

Checks if required extensions / OpenGL version are met

Protected function DoAllocateHandle: Cardinal; virtual; abstract;
Protected class function IsValid(const ID: GLuint): Boolean; virtual;
Protected class function Transferable: Boolean; virtual;

Specifies if the handle can be transfered across shared contexts

Public procedure DestroyHandle;
Public procedure NotifyChangesOfData;

Notify the data was changed through all context.

Public procedure NotifyDataUpdated;

Notify the data was updated in current context.

Protected procedure ContextDestroying;

Invoked by when there is no compatible context left for relocation

Protected procedure DoDestroyHandle(var AHandle: TGLuint); virtual; abstract;

Properties

Public property Handle: TGLuint read GetHandle;

Return OpenGL identifier in current context.

Public property OnPrapare: TOnPrepareHandleData read FOnPrepare write FOnPrepare;
Public property RenderingContext: TGLContext read GetContext;

Return current rendering context if handle is allocated in it or first context where handle is allocated.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLVirtualHandle

Class TGLVirtualHandle

Unit

GLContext

Declaration

type TGLVirtualHandle = class(TGLContextHandle)

Description

A context handle with event-based handle allocation and destruction.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLVirtualHandle

Overview

Methods

Protected | function DoAllocateHandle: Cardinal; override;
Protected | class function Transferable: Boolean; override;
Protected | procedure DoDestroyHandle(var AHandle: TGLuint); override;

Properties

Public | property OnAllocate: TGLVirtualHandleEvent read FOnAllocate write FOnAllocate;
Public | property OnDestroy: TGLVirtualHandleEvent read FOnDestroy write FOnDestroy;
Public | property Tag: Integer read FTag write FTag;

Description

Methods

Protected function DoAllocateHandle: Cardinal; override;
Protected class function Transferable: Boolean; override;
Protected procedure DoDestroyHandle(var AHandle: TGLuint); override;

Properties

Public property OnAllocate: TGLVirtualHandleEvent read FOnAllocate write FOnAllocate;
Public property OnDestroy: TGLVirtualHandleEvent read FOnDestroy write FOnDestroy;
Public property Tag: Integer read FTag write FTag;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLVirtualHandleTransf

Class TGLVirtualHandleTransf

Unit

GLContext

Declaration

type TGLVirtualHandleTransf = class(TGLVirtualHandle)

Description

Transferable virtual handle.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLVirtualHandle
  • TGLVirtualHandleTransf

Overview

Methods

Protected class function Transferable: Boolean; override;

Description

Methods

Protected class function Transferable: Boolean; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLListHandle

Class TGLListHandle

Unit

GLContext

Declaration

type TGLListHandle = class(TGLContextHandle)

Description

Manages a handle to a display list.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLListHandle

Overview

Methods

Protected | function DoAllocateHandle: Cardinal; override;
Protected | class function IsValid(const ID: GLuint): Boolean; override;
Public | procedure CallList;
Public | procedure EndList;
Public | procedure NewList(mode: Cardinal);
Protected | procedure DoDestroyHandle(var AHandle: TGLuint); override;

Description

Methods

Protected function DoAllocateHandle: Cardinal; override;
Protected class function IsValid(const ID: GLuint): Boolean; override;
Public procedure CallList;
Public procedure EndList;
Public procedure NewList(mode: Cardinal);
Protected procedure DoDestroyHandle(var AHandle: TGLuint); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLTextureHandle

Class TGLTextureHandle

Unit

GLContext

Declaration

type TGLTextureHandle = class(TGLContextHandle)

Description

Manages a handle to a texture.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLTextureHandle

Overview

Methods

Protected | function DoAllocateHandle: Cardinal; override;
Protected | class function IsValid(const ID: GLuint): Boolean; override;
Protected | procedure DoDestroyHandle(var AHandle: TGLuint); override;

Properties

Public property Target: TGLTextureTarget read FTarget write SetTarget;

Description

Methods

Protected function DoAllocateHandle: Cardinal; override;
Protected class function IsValid(const ID: GLuint): Boolean; override;
Protected procedure DoDestroyHandle(var AHandle: TGLuint); override;

Properties

Public property Target: TGLTextureTarget read FTarget write SetTarget;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLSamplerHandle

Class TGLSamplerHandle

Unit

GLContext

Declaration

type TGLSamplerHandle = class(TGLContextHandle)

Description

Manages a handle to a sampler.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSamplerHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Protected | function DoAllocateHandle: Cardinal; override;
Protected | class function IsValid(const ID: GLuint): Boolean; override;
Protected | procedure DoDestroyHandle(var AHandle: TGLuint); override;

Description

Methods

Public class function IsSupported: Boolean; override;
Protected function DoAllocateHandle: Cardinal; override;
Protected class function IsValid(const ID: GLuint): Boolean; override;
Protected procedure DoDestroyHandle(var AHandle: TGLuint); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLQueryHandle

Class TGLQueryHandle

Unit

GLContext

Declaration

type TGLQueryHandle = class(TGLContextHandle)

Description

Manages a handle to a query.<br> Do not use this class directly, use one of its subclasses instead.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLQueryHandle

Overview

Methods

Public | function CounterBits: integer;
Public | function IsResultAvailable: boolean;
Public | function QueryResultBool: TGLboolean;
Public | function QueryResultInt: TGLInt;
Public | function QueryResultInt64: TGLint64EXT;
Public | function QueryResultUInt: TGLUInt;
Public | function QueryResultUInt64: TGLuint64EXT;
Protected | function DoAllocateHandle: Cardinal; override;
Protected | function GetQueryType: TQueryType; virtual; abstract;
Protected | function GetTarget: TGLuint; virtual; abstract;
Protected | class function IsValid(const ID: GLuint): Boolean; override;
Protected | class function Transferable: Boolean; override;
Public | procedure BeginQuery;
Public | procedure EndQuery;
Protected | procedure DoDestroyHandle(var AHandle: TGLuint); override;

Properties

Public | property Active: Boolean read FActive;
Public | property QueryType: TQueryType read GetQueryType;
Public | property Target: TGLuint read GetTarget;

Description

Methods

Public function CounterBits: integer;
Public function IsResultAvailable: boolean;
Public function QueryResultBool: TGLboolean;
Public function QueryResultInt: TGLInt;
Public function QueryResultInt64: TGLint64EXT;
Public function QueryResultUInt: TGLUInt;
Public function QueryResultUInt64: TGLuint64EXT;
Protected function DoAllocateHandle: Cardinal; override;
Protected function GetQueryType: TQueryType; virtual; abstract;
Protected function GetTarget: TGLuint; virtual; abstract;
Protected class function IsValid(const ID: GLuint): Boolean; override;
Protected class function Transferable: Boolean; override;
Public procedure BeginQuery;
Public procedure EndQuery;
Protected procedure DoDestroyHandle(var AHandle: TGLuint); override;

Properties

Public property Active: Boolean read FActive;

True if within a Begin/EndQuery.

Public property QueryType: TQueryType read GetQueryType;
Public property Target: TGLuint read GetTarget;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLOcclusionQueryHandle

Class TGLOcclusionQueryHandle

Unit

GLContext

Declaration

type TGLOcclusionQueryHandle = class(TGLQueryHandle)

Description

Manages a handle to an occlusion query.<br> Requires OpenGL 1.5+<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLQueryHandle
  • TGLOcclusionQueryHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | function PixelCount: Integer;
Protected | function GetQueryType: TQueryType; override;
Protected | function GetTarget: TGLuint; override;

Description

Methods

Public class function IsSupported: Boolean; override;
Public function PixelCount: Integer;
Protected function GetQueryType: TQueryType; override;
Protected function GetTarget: TGLuint; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLBooleanOcclusionQueryHandle

Class TGLBooleanOcclusionQueryHandle

Unit

GLContext

Declaration

type TGLBooleanOcclusionQueryHandle = class(TGLQueryHandle)

Description

no description available, TGLQueryHandle description follows

Manages a handle to a query.<br> Do not use this class directly, use one of its subclasses instead.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLQueryHandle
  • TGLBooleanOcclusionQueryHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Protected | function GetQueryType: TQueryType; override;
Protected | function GetTarget: TGLuint; override;

Description

Methods

Public class function IsSupported: Boolean; override;
Protected function GetQueryType: TQueryType; override;
Protected function GetTarget: TGLuint; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLTimerQueryHandle

Class TGLTimerQueryHandle

Unit

GLContext

Declaration

type TGLTimerQueryHandle = class(TGLQueryHandle)

Description

Manages a handle to a timer query.<br> Requires GL_EXT_timer_query extension.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLQueryHandle
  • TGLTimerQueryHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | function Time: Integer;
Protected | function GetQueryType: TQueryType; override;
Protected | function GetTarget: TGLuint; override;

Description

Methods

Public class function IsSupported: Boolean; override;
Public function Time: Integer;
Protected function GetQueryType: TQueryType; override;
Protected function GetTarget: TGLuint; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLPrimitiveQueryHandle

Class TGLPrimitiveQueryHandle

Unit

GLContext

Declaration

type TGLPrimitiveQueryHandle = class(TGLQueryHandle)

Description

Manages a handle to a primitive query.<br> Requires OpenGL 3.0+<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLQueryHandle
  • TGLPrimitiveQueryHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | function PrimitivesGenerated: Integer;
Protected | function GetQueryType: TQueryType; override;
Protected | function GetTarget: TGLuint; override;

Description

Methods

Public class function IsSupported: Boolean; override;
Public function PrimitivesGenerated: Integer;
Protected function GetQueryType: TQueryType; override;
Protected function GetTarget: TGLuint; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLBufferObjectHandle

Class TGLBufferObjectHandle

Unit

GLContext

Declaration

type TGLBufferObjectHandle = class(TGLContextHandle)

Description

Manages a handle to a Buffer Object.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.<br>

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle

Overview

Methods

Public | constructor CreateFromData(p: Pointer; size: Integer; bufferUsage: TGLuint);
Public | class function IsSupported: Boolean; override;
Public | function MapBuffer(access: TGLuint): Pointer;
Public | function MapBufferRange(offset: TGLint; len: TGLsizei; access: TGLbitfield): Pointer;
Public | function UnmapBuffer: Boolean;
Protected | function DoAllocateHandle: Cardinal; override;
Protected | function GetTarget: TGLuint; virtual; abstract;
Protected | class function IsValid(const ID: GLuint): Boolean; override;
Public | procedure Bind; virtual; abstract;
Public | procedure BindBase(index: TGLuint); virtual;
Public | procedure BindBufferData(p: Pointer; size: Integer; bufferUsage: TGLuint);
Public | procedure BindRange(index: TGLuint; offset: TGLintptr; size: TGLsizeiptr); virtual;
Public | procedure BufferData(p: Pointer; size: Integer; bufferUsage: TGLuint);
Public | procedure BufferSubData(offset, size: Integer; p: Pointer);
Public | procedure Flush(offset: TGLint; len: TGLsizei);
Public | procedure UnBind; virtual; abstract;
Public | procedure UnBindBase(index: TGLuint); virtual;
Protected | procedure DoDestroyHandle(var AHandle: TGLuint); override;

Properties

Public | property BufferSize: Integer read FSize;
Public | property Target: TGLuint read GetTarget;

Description

Methods

Public constructor CreateFromData(p: Pointer; size: Integer; bufferUsage: TGLuint);

Creates the buffer object buffer and initializes it.

Public class function IsSupported: Boolean; override;
Public function MapBuffer(access: TGLuint): Pointer;

Map buffer content to memory.<p> Values for access are GL_READ_ONLY_ARB, GL_WRITE_ONLY_ARB and GL_READ_WRITE_ARB.<p> Valid only if the buffer has been bound, must be followed by an UnmapBuffer, only one buffer may be mapped at a time.

Public function MapBufferRange(offset: TGLint; len: TGLsizei; access: TGLbitfield): Pointer;
Public function UnmapBuffer: Boolean;

Unmap buffer content from memory.<p> Must follow a MapBuffer, and happen before the buffer is unbound.

Protected function DoAllocateHandle: Cardinal; override;
Protected function GetTarget: TGLuint; virtual; abstract;
Protected class function IsValid(const ID: GLuint): Boolean; override;
Public procedure Bind; virtual; abstract;
Public procedure BindBase(index: TGLuint); virtual;

Equivalent to calling BindRange with offset = 0, and size = the size of buffer.

Public procedure BindBufferData(p: Pointer; size: Integer; bufferUsage: TGLuint);

Invokes Bind then BufferData

Public procedure BindRange(index: TGLuint; offset: TGLintptr; size: TGLsizeiptr); virtual;

Bind a buffer object to an indexed target, used by transform feedback buffer objects and uniform buffer objects. (OpenGL 3.0+)

Public procedure BufferData(p: Pointer; size: Integer; bufferUsage: TGLuint);

Specifies buffer content.<p> Common bufferUsage values are GL_STATIC_DRAW_ARB for data that will change rarely, but be used often, GL_STREAM_DRAW_ARB for data specified once but used only a few times, and GL_DYNAMIC_DRAW_ARB for data that is re-specified very often.<p> Valid only if the buffer has been bound.

Public procedure BufferSubData(offset, size: Integer; p: Pointer);

Updates part of an already existing buffer.<p> offset and size indicate which part of the data in the buffer is to bo modified and p where the data should be taken from.

Public procedure Flush(offset: TGLint; len: TGLsizei);
Public procedure UnBind; virtual; abstract;

Note that it is not necessary to UnBind before Binding another buffer.

Public procedure UnBindBase(index: TGLuint); virtual;
Protected procedure DoDestroyHandle(var AHandle: TGLuint); override;

Properties

Public property BufferSize: Integer read FSize;
Public property Target: TGLuint read GetTarget;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLVBOHandle

Class TGLVBOHandle

Unit

GLContext

Declaration

type TGLVBOHandle = class(TGLBufferObjectHandle)

Description

Manages a handle to an Vertex Buffer Object.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.<br> Do not use this class directly, use one of its subclasses instead.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLVBOHandle

Overview

Properties

Public property VBOTarget: TGLuint read GetVBOTarget;

Description

Properties

Public property VBOTarget: TGLuint read GetVBOTarget;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLVBOArrayBufferHandle

Class TGLVBOArrayBufferHandle

Unit

GLContext

Declaration

type TGLVBOArrayBufferHandle = class(TGLVBOHandle)

Description

Manages a handle to VBO Array Buffer.<p> Typically used to store vertices, normals, texcoords, etc.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLVBOHandle
  • TGLVBOArrayBufferHandle

Overview

Methods

Protected | function GetTarget: TGLuint; override;
Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Protected function GetTarget: TGLuint; override;
Public procedure Bind; override;
Public procedure UnBind; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLVBOElementArrayHandle

Class TGLVBOElementArrayHandle

Unit

GLContext

Declaration

type TGLVBOElementArrayHandle = class(TGLVBOHandle)

Description

Manages a handle to VBO Element Array Buffer.<p> Typically used to store vertex indices.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLVBOHandle
  • TGLVBOElementArrayHandle

Overview

Methods

Protected | function GetTarget: TGLuint; override;
Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Protected function GetTarget: TGLuint; override;
Public procedure Bind; override;
Public procedure UnBind; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLPackPBOHandle

Class TGLPackPBOHandle

Unit

GLContext

Declaration

type TGLPackPBOHandle = class(TGLBufferObjectHandle)

Description

Manages a handle to PBO Pixel Pack Buffer.<p> When bound, commands such as ReadPixels write their data into a buffer object.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLPackPBOHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Protected | function GetTarget: TGLuint; override;
Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Public class function IsSupported: Boolean; override;
Protected function GetTarget: TGLuint; override;
Public procedure Bind; override;
Public procedure UnBind; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLUnpackPBOHandle

Class TGLUnpackPBOHandle

Unit

GLContext

Declaration

type TGLUnpackPBOHandle = class(TGLBufferObjectHandle)

Description

Manages a handle to PBO Pixel Unpack Buffer.<p> When bound, commands such as DrawPixels read their data from a buffer object.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLUnpackPBOHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Protected | function GetTarget: TGLuint; override;
Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Public class function IsSupported: Boolean; override;
Protected function GetTarget: TGLuint; override;
Public procedure Bind; override;
Public procedure UnBind; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLTransformFeedbackBufferHandle

Class TGLTransformFeedbackBufferHandle

Unit

GLContext

Declaration

type TGLTransformFeedbackBufferHandle = class(TGLBufferObjectHandle)

Description

Manages a handle to a Transform Feedback Buffer Object.<p> Transform feedback buffers can be used to capture vertex data from the vertex or geometry shader stage to perform further processing without going on to the fragment shader stage.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLTransformFeedbackBufferHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Protected | function GetTarget: TGLuint; override;
Public | procedure BeginTransformFeedback(primitiveMode: TGLenum);
Public | procedure Bind; override;
Public | procedure BindBase(index: TGLuint); override;
Public | procedure BindRange(index: TGLuint; offset: TGLintptr; size: TGLsizeiptr); override;
Public | procedure EndTransformFeedback();
Public | procedure UnBind; override;
Public | procedure UnBindBase(index: TGLuint); override;

Description

Methods

Public class function IsSupported: Boolean; override;
Protected function GetTarget: TGLuint; override;
Public procedure BeginTransformFeedback(primitiveMode: TGLenum);
Public procedure Bind; override;
Public procedure BindBase(index: TGLuint); override;
Public procedure BindRange(index: TGLuint; offset: TGLintptr; size: TGLsizeiptr); override;
Public procedure EndTransformFeedback();
Public procedure UnBind; override;
Public procedure UnBindBase(index: TGLuint); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLTextureBufferHandle

Class TGLTextureBufferHandle

Unit

GLContext

Declaration

type TGLTextureBufferHandle = class(TGLBufferObjectHandle)

Description

Manages a handle to a Buffer Texture. (TBO)

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLTextureBufferHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Protected | function GetTarget: TGLuint; override;
Public | procedure Bind; override;
Public | procedure UnBind; override;

Description

Methods

Public class function IsSupported: Boolean; override;
Protected function GetTarget: TGLuint; override;
Public procedure Bind; override;
Public procedure UnBind; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLUniformBufferHandle

Class TGLUniformBufferHandle

Unit

GLContext

Declaration

type TGLUniformBufferHandle = class(TGLBufferObjectHandle)

Description

Manages a handle to a Uniform Buffer Object (UBO). Uniform buffer objects store "uniform blocks"; groups of uniforms that can be passed as a group into a GLSL program.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLBufferObjectHandle
  • TGLUniformBufferHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Protected | function GetTarget: TGLuint; override;
Public | procedure Bind; override;
Public | procedure BindBase(index: TGLuint); override;
Public | procedure BindRange(index: TGLuint; offset: TGLintptr; size: TGLsizeiptr); override;
Public | procedure UnBind; override;
Public | procedure UnBindBase(index: TGLuint); override;

Description

Methods

Public class function IsSupported: Boolean; override;
Protected function GetTarget: TGLuint; override;
Public procedure Bind; override;
Public procedure BindBase(index: TGLuint); override;
Public procedure BindRange(index: TGLuint; offset: TGLintptr; size: TGLsizeiptr); override;
Public procedure UnBind; override;
Public procedure UnBindBase(index: TGLuint); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLVertexArrayHandle

Class TGLVertexArrayHandle

Unit

GLContext

Declaration

type TGLVertexArrayHandle = class(TGLContextHandle)

Description

Manages a handle to a Vertex Array Object (VAO). Vertex array objects are used to rapidly switch between large sets of array state.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLVertexArrayHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Protected | function DoAllocateHandle: Cardinal; override;
Protected | class function IsValid(const ID: GLuint): Boolean; override;
Protected | class function Transferable: Boolean; override;
Public | procedure Bind;
Public | procedure UnBind;
Protected | procedure DoDestroyHandle(var AHandle: TGLuint); override;

Description

Methods

Public class function IsSupported: Boolean; override;
Protected function DoAllocateHandle: Cardinal; override;
Protected class function IsValid(const ID: GLuint): Boolean; override;
Protected class function Transferable: Boolean; override;
Public procedure Bind;
Public procedure UnBind;
Protected procedure DoDestroyHandle(var AHandle: TGLuint); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLFramebufferHandle

Class TGLFramebufferHandle

Unit

GLContext

Declaration

type TGLFramebufferHandle = class(TGLContextHandle)

Description

Manages a handle to a Framebuffer Object (FBO). Framebuffer objects provide a way of drawing to rendering destinations other than the buffers provided to the GL by the window-system. One or more "framebuffer-attachable images" can be attached to a Framebuffer for uses such as: offscreen rendering, "render to texture" + "multiple render targets" (MRT). There are several types of framebuffer-attachable images: - The image of a renderbuffer object, which is always 2D. - A single level of a 1D texture, which is treated as a 2D image with a height of one. - A single level of a 2D or rectangle texture. - A single face of a cube map texture level, which is treated as a 2D image. - A single layer of a 1D or 2D array texture or 3D texture, which is treated as a 2D image. Additionally, an entire level of a 3D texture, cube map texture, or 1D or 2D array texture can be attached to an attachment point. Such attachments are treated as an array of 2D images, arranged in layers, and the corresponding attachment point is considered to be layered.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLFramebufferHandle

Overview

Methods

Public | function GetAttachmentObjectName(target: TGLenum; attachment: TGLenum): TGLint;
Public | function GetAttachmentObjectType(target: TGLenum; attachment: TGLenum): TGLint;
Public | function GetAttachmentParameter(target: TGLenum; attachment: TGLenum; pname: TGLenum): TGLint;
Public | function GetStatus: TGLFramebufferStatus;
Public | function GetStringStatus(out clarification: string): TGLFramebufferStatus;
Public | class function IsSupported: Boolean; override;
Protected | function DoAllocateHandle: Cardinal; override;
Protected | class function IsValid(const ID: GLuint): Boolean; override;
Protected | class function Transferable: Boolean; override;
Public | procedure Attach1DTexture(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint);
Public | procedure Attach2DTexture(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint);
Public | procedure Attach3DTexture(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint; layer: TGLint);
Public | procedure AttachLayer(target: TGLenum; attachment: TGLenum; texture: TGLuint; level: TGLint; layer: TGLint);
Public | procedure AttachRenderBuffer(target: TGLenum; attachment: TGLenum; renderbuffertarget: TGLenum; renderbuffer: TGLuint);
Public | procedure AttachTexture(target: TGLenum; attachment: TGLenum; texture: TGLuint; level: TGLint);
Public | procedure AttachTextureLayer(target: TGLenum; attachment: TGLenum; texture: TGLuint; level: TGLint; layer: TGLint);
Public | procedure Bind;
Public | procedure BindForDrawing;
Public | procedure BindForReading;
Public | procedure Blit(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: TGLenum);
Public | procedure UnBind;
Public | procedure UnBindForDrawing;
Public | procedure UnBindForReading;
Protected | procedure DoDestroyHandle(var AHandle: TGLuint); override;

Description

Methods

Public function GetAttachmentObjectName(target: TGLenum; attachment: TGLenum): TGLint;
Public function GetAttachmentObjectType(target: TGLenum; attachment: TGLenum): TGLint;
Public function GetAttachmentParameter(target: TGLenum; attachment: TGLenum; pname: TGLenum): TGLint;
Public function GetStatus: TGLFramebufferStatus;
Public function GetStringStatus(out clarification: string): TGLFramebufferStatus;
Public class function IsSupported: Boolean; override;
Protected function DoAllocateHandle: Cardinal; override;
Protected class function IsValid(const ID: GLuint): Boolean; override;
Protected class function Transferable: Boolean; override;
Public procedure Attach1DTexture(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint);
Public procedure Attach2DTexture(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint);
Public procedure Attach3DTexture(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint; layer: TGLint);
Public procedure AttachLayer(target: TGLenum; attachment: TGLenum; texture: TGLuint; level: TGLint; layer: TGLint);
Public procedure AttachRenderBuffer(target: TGLenum; attachment: TGLenum; renderbuffertarget: TGLenum; renderbuffer: TGLuint);
Public procedure AttachTexture(target: TGLenum; attachment: TGLenum; texture: TGLuint; level: TGLint);
Public procedure AttachTextureLayer(target: TGLenum; attachment: TGLenum; texture: TGLuint; level: TGLint; layer: TGLint);
Public procedure Bind;
Public procedure BindForDrawing;
Public procedure BindForReading;
Public procedure Blit(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: TGLenum);
Public procedure UnBind;

Note that it is not necessary to unbind before binding another framebuffer.

Public procedure UnBindForDrawing;
Public procedure UnBindForReading;
Protected procedure DoDestroyHandle(var AHandle: TGLuint); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLRenderbufferHandle

Class TGLRenderbufferHandle

Unit

GLContext

Declaration

type TGLRenderbufferHandle = class(TGLContextHandle)

Description

Manages a handle to a Renderbuffer Object. A Renderbuffer is a "framebuffer-attachable image" for generalized offscreen rendering and it also provides a means to support rendering to GL logical buffer types which have no corresponding texture format (stencil, accum, etc).

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLRenderbufferHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Protected | function DoAllocateHandle: Cardinal; override;
Protected | class function IsValid(const ID: GLuint): Boolean; override;
Public | procedure Bind;
Public | procedure SetStorage(internalformat: TGLenum; width, height: TGLsizei);
Public | procedure SetStorageMultisample(internalformat: TGLenum; samples: TGLsizei; width, height: TGLsizei);
Public | procedure UnBind;
Protected | procedure DoDestroyHandle(var AHandle: TGLuint); override;

Description

Methods

Public class function IsSupported: Boolean; override;
Protected function DoAllocateHandle: Cardinal; override;
Protected class function IsValid(const ID: GLuint): Boolean; override;
Public procedure Bind;
Public procedure SetStorage(internalformat: TGLenum; width, height: TGLsizei);
Public procedure SetStorageMultisample(internalformat: TGLenum; samples: TGLsizei; width, height: TGLsizei);
Public procedure UnBind;
Protected procedure DoDestroyHandle(var AHandle: TGLuint); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLARBProgramHandle

Class TGLARBProgramHandle

Unit

GLContext

Declaration

type TGLARBProgramHandle = class(TGLContextHandle)

Description

no description available, TGLContextHandle description follows

Wrapper around an OpenGL context handle.<p> This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TGLListHandle and TGLTextureHandle subclasses.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLARBProgramHandle

Overview

Methods

Protected | function DoAllocateHandle: Cardinal; override;
Protected | class function GetTarget: TGLenum; virtual; abstract;
Protected | class function IsValid(const ID: GLuint): Boolean; override;
Public | procedure Bind;
Public | procedure Disable;
Public | procedure Enable;
Public | procedure LoadARBProgram(AText: string);
Protected | procedure DoDestroyHandle(var AHandle: TGLuint); override;

Properties

Public | property InfoLog: string read FInfoLog;
Public | property Ready: Boolean read FReady;

Description

Methods

Protected function DoAllocateHandle: Cardinal; override;
Protected class function GetTarget: TGLenum; virtual; abstract;
Protected class function IsValid(const ID: GLuint): Boolean; override;
Public procedure Bind;
Public procedure Disable;
Public procedure Enable;
Public procedure LoadARBProgram(AText: string);
Protected procedure DoDestroyHandle(var AHandle: TGLuint); override;

Properties

Public property InfoLog: string read FInfoLog;
Public property Ready: Boolean read FReady;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLARBVertexProgramHandle

Class TGLARBVertexProgramHandle

Unit

GLContext

Declaration

type TGLARBVertexProgramHandle = class(TGLARBProgramHandle)

Description

no description available, TGLARBProgramHandle description follows
no description available, TGLContextHandle description follows

Wrapper around an OpenGL context handle.<p> This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TGLListHandle and TGLTextureHandle subclasses.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLARBProgramHandle
  • TGLARBVertexProgramHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Protected | class function GetTarget: TGLenum; override;

Description

Methods

Public class function IsSupported: Boolean; override;
Protected class function GetTarget: TGLenum; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLARBFragmentProgramHandle

Class TGLARBFragmentProgramHandle

Unit

GLContext

Declaration

type TGLARBFragmentProgramHandle = class(TGLARBProgramHandle)

Description

no description available, TGLARBProgramHandle description follows
no description available, TGLContextHandle description follows

Wrapper around an OpenGL context handle.<p> This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TGLListHandle and TGLTextureHandle subclasses.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLARBProgramHandle
  • TGLARBFragmentProgramHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Protected | class function GetTarget: TGLenum; override;

Description

Methods

Public class function IsSupported: Boolean; override;
Protected class function GetTarget: TGLenum; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLARBGeometryProgramHandle

Class TGLARBGeometryProgramHandle

Unit

GLContext

Declaration

type TGLARBGeometryProgramHandle = class(TGLARBProgramHandle)

Description

no description available, TGLARBProgramHandle description follows
no description available, TGLContextHandle description follows

Wrapper around an OpenGL context handle.<p> This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TGLListHandle and TGLTextureHandle subclasses.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLARBProgramHandle
  • TGLARBGeometryProgramHandle

Overview

Methods

Public | class function IsSupported: Boolean; override;
Protected | class function GetTarget: TGLenum; override;

Description

Methods

Public class function IsSupported: Boolean; override;
Protected class function GetTarget: TGLenum; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLSLHandle

Class TGLSLHandle

Unit

GLContext

Declaration

type TGLSLHandle = class(TGLContextHandle)

Description

Base class for GLSL handles (programs and shaders).<p> Do not use this class directly, use one of its subclasses instead.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle

Overview

Methods

Public | function InfoLog: string;
Public | class function IsSupported: Boolean; override;
Protected | procedure DoDestroyHandle(var AHandle: TGLuint); override;

Description

Methods

Public function InfoLog: string;
Public class function IsSupported: Boolean; override;
Protected procedure DoDestroyHandle(var AHandle: TGLuint); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLShaderHandle

Class TGLShaderHandle

Unit

GLContext

Declaration

type TGLShaderHandle = class(TGLSLHandle)

Description

Manages a handle to a Shader Object.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.<br> Do not use this class directly, use one of its subclasses instead.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle
  • TGLShaderHandle

Overview

Methods

Public | function CompileShader: Boolean;
Protected | function DoAllocateHandle: Cardinal; override;
Protected | class function IsValid(const ID: GLuint): Boolean; override;
Public | procedure ShaderSource(const source: AnsiString); overload;

Properties

Public property ShaderType: Cardinal read FShaderType;

Description

Methods

Public function CompileShader: Boolean;

Returns True if compilation sucessful

Protected function DoAllocateHandle: Cardinal; override;
Protected class function IsValid(const ID: GLuint): Boolean; override;
Public procedure ShaderSource(const source: AnsiString); overload;

Properties

Public property ShaderType: Cardinal read FShaderType;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLVertexShaderHandle

Class TGLVertexShaderHandle

Unit

GLContext

Declaration

type TGLVertexShaderHandle = class(TGLShaderHandle)

Description

Manages a handle to a Vertex Shader Object.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle
  • TGLShaderHandle
  • TGLVertexShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;
Public class function IsSupported: Boolean; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLGeometryShaderHandle

Class TGLGeometryShaderHandle

Unit

GLContext

Declaration

type TGLGeometryShaderHandle = class(TGLShaderHandle)

Description

Manages a handle to a Geometry Shader Object.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle
  • TGLShaderHandle
  • TGLGeometryShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;
Public class function IsSupported: Boolean; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLFragmentShaderHandle

Class TGLFragmentShaderHandle

Unit

GLContext

Declaration

type TGLFragmentShaderHandle = class(TGLShaderHandle)

Description

Manages a handle to a Fragment Shader Object.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle
  • TGLShaderHandle
  • TGLFragmentShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;
Public class function IsSupported: Boolean; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLTessControlShaderHandle

Class TGLTessControlShaderHandle

Unit

GLContext

Declaration

type TGLTessControlShaderHandle = class(TGLShaderHandle)

Description

Manages a handle to a Tessellation Control Shader Object.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle
  • TGLShaderHandle
  • TGLTessControlShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;
Public class function IsSupported: Boolean; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLTessEvaluationShaderHandle

Class TGLTessEvaluationShaderHandle

Unit

GLContext

Declaration

type TGLTessEvaluationShaderHandle = class(TGLShaderHandle)

Description

Manages a handle to a Tessellation Evaluation Shader Object.

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle
  • TGLShaderHandle
  • TGLTessEvaluationShaderHandle

Overview

Methods

Public | constructor Create; override;
Public | class function IsSupported: Boolean; override;

Description

Methods

Public constructor Create; override;
Public class function IsSupported: Boolean; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLProgramHandle

Class TGLProgramHandle

Unit

GLContext

Declaration

type TGLProgramHandle = class(TGLSLHandle)

Description

Manages a GLSL Program Object.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.<br>

Hierarchy

  • TObject
  • TGLContextHandle
  • TGLSLHandle
  • TGLProgramHandle

Overview

Methods

Public | constructor Create; override;
Public | function GetAttribLocation(const aName: string): Integer;
Public | function GetUniformBlockIndex(const aName: string): Integer;
Public | function GetUniformBufferSize(const aName: string): Integer;
Public | function GetUniformLocation(const aName: string): Integer;
Public | function GetUniformOffset(const aName: string): PGLInt;
Public | function GetVaryingLocation(const aName: string): Integer;
Public | class function IsValid(const ID: GLuint): Boolean; override;
Public | function LinkProgram: Boolean;
Public | function ValidateProgram: Boolean;
Protected | function DoAllocateHandle: cardinal; override;
Public | procedure AddActiveVarying(const aName: string);
Public | procedure AddShader(shaderType: TGLShaderHandleClass; const shaderSource: string; treatWarningsAsErrors: Boolean = False);
Public | procedure AttachObject(shader: TGLShaderHandle);
Public | procedure BindAttribLocation(index: Integer; const aName: string);
Public | procedure BindFragDataLocation(index: Integer; const aName: string);
Public | procedure DetachAllObject;
Public | procedure EndUseProgramObject;
Public | procedure SetUniformf(const index: string; const val: TVector2f); overload;
Public | procedure SetUniformf(const index: string; const val: single); overload;
Public | procedure SetUniformf(const index: string; const val: TVector4f); overload;
Public | procedure SetUniformf(const index: string; const val: TVector3f); overload;
Public | procedure SetUniformi(const index: string; const val: TVector4i); overload;
Public | procedure SetUniformi(const index: string; const val: integer); overload;
Public | procedure SetUniformi(const index: string; const val: TVector2i); overload;
Public | procedure SetUniformi(const index: string; const val: TVector3i); overload;
Public | procedure UseProgramObject;

Properties

Public | property Name: string read FName write FName;
Public | property Uniform1f[const index: string]: Single read GetUniform1f write SetUniform1f;
Public | property Uniform1i[const index: string]: Integer read GetUniform1i write SetUniform1i;
Public | property Uniform2f[const index: string]: TVector2f read GetUniform2f write SetUniform2f;
Public | property Uniform2i[const index: string]: TVector2i read GetUniform2i write SetUniform2i;
Public | property Uniform3f[const index: string]: TAffineVector read GetUniform3f write SetUniform3f;
Public | property Uniform3i[const index: string]: TVector3i read GetUniform3i write SetUniform3i;
Public | property Uniform4f[const index: string]: TVector read GetUniform4f write SetUniform4f;
Public | property Uniform4i[const index: string]: TVector4i read GetUniform4i write SetUniform4i;
Public | property UniformBuffer[const index: string]: TGLUniformBufferHandle write SetUniformBuffer;
Public | property UniformMatrix2fv[const index: string]: TMatrix2f read GetUniformMatrix2fv write SetUniformMatrix2fv;
Public | property UniformMatrix3fv[const index: string]: TMatrix3f read GetUniformMatrix3fv write SetUniformMatrix3fv;
Public | property UniformMatrix4fv[const index: string]: TMatrix read GetUniformMatrix4fv write SetUniformMatrix4fv;
Public | property UniformTextureHandle[const index: string; const TextureIndex: Integer; const TextureTarget: TGLTextureTarget]: Cardinal read GetUniformTextureHandle write SetUniformTextureHandle;

Description

Methods

Public constructor Create; override;
Public function GetAttribLocation(const aName: string): Integer;
Public function GetUniformBlockIndex(const aName: string): Integer;
Public function GetUniformBufferSize(const aName: string): Integer;
Public function GetUniformLocation(const aName: string): Integer;
Public function GetUniformOffset(const aName: string): PGLInt;
Public function GetVaryingLocation(const aName: string): Integer;
Public class function IsValid(const ID: GLuint): Boolean; override;
Public function LinkProgram: Boolean;
Public function ValidateProgram: Boolean;
Protected function DoAllocateHandle: cardinal; override;
Public procedure AddActiveVarying(const aName: string);
Public procedure AddShader(shaderType: TGLShaderHandleClass; const shaderSource: string; treatWarningsAsErrors: Boolean = False);

Compile and attach a new shader.<p> Raises an EGLShader exception in case of failure.

Public procedure AttachObject(shader: TGLShaderHandle);
Public procedure BindAttribLocation(index: Integer; const aName: string);
Public procedure BindFragDataLocation(index: Integer; const aName: string);
Public procedure DetachAllObject;
Public procedure EndUseProgramObject;
Public procedure SetUniformf(const index: string; const val: TVector2f); overload;
Public procedure SetUniformf(const index: string; const val: single); overload;
Public procedure SetUniformf(const index: string; const val: TVector4f); overload;
Public procedure SetUniformf(const index: string; const val: TVector3f); overload;
Public procedure SetUniformi(const index: string; const val: TVector4i); overload;
Public procedure SetUniformi(const index: string; const val: integer); overload;
Public procedure SetUniformi(const index: string; const val: TVector2i); overload;
Public procedure SetUniformi(const index: string; const val: TVector3i); overload;
Public procedure UseProgramObject;

Properties

Public property Name: string read FName write FName;
Public property Uniform1f[const index: string]: Single read GetUniform1f write SetUniform1f;
Public property Uniform1i[const index: string]: Integer read GetUniform1i write SetUniform1i;

Shader parameters.

Public property Uniform2f[const index: string]: TVector2f read GetUniform2f write SetUniform2f;
Public property Uniform2i[const index: string]: TVector2i read GetUniform2i write SetUniform2i;
Public property Uniform3f[const index: string]: TAffineVector read GetUniform3f write SetUniform3f;
Public property Uniform3i[const index: string]: TVector3i read GetUniform3i write SetUniform3i;
Public property Uniform4f[const index: string]: TVector read GetUniform4f write SetUniform4f;
Public property Uniform4i[const index: string]: TVector4i read GetUniform4i write SetUniform4i;
Public property UniformBuffer[const index: string]: TGLUniformBufferHandle write SetUniformBuffer;
Public property UniformMatrix2fv[const index: string]: TMatrix2f read GetUniformMatrix2fv write SetUniformMatrix2fv;
Public property UniformMatrix3fv[const index: string]: TMatrix3f read GetUniformMatrix3fv write SetUniformMatrix3fv;
Public property UniformMatrix4fv[const index: string]: TMatrix read GetUniformMatrix4fv write SetUniformMatrix4fv;
Public property UniformTextureHandle[const index: string; const TextureIndex: Integer; const TextureTarget: TGLTextureTarget]: Cardinal read GetUniformTextureHandle write SetUniformTextureHandle;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: record TGLContextNotification

record TGLContextNotification

Unit

GLContext

Declaration

type TGLContextNotification = record

Description

Overview

Fields

obj: TObject;
event: TNotifyEvent;

Description

Fields

obj: TObject;
event: TNotifyEvent;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class TGLContextManager

Class TGLContextManager

Unit

GLContext

Declaration

type TGLContextManager = class(TObject)

Description

Stores and manages all the TGLContext objects.<p>

Hierarchy

  • TObject
  • TGLContextManager

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function ContextCount: Integer;
Public | function CreateContext(AClass: TGLContextClass = nil): TGLContext;
Public | procedure DestroyAllHandles;
Public | procedure LastContextDestroyNotification(anObject: TObject; anEvent: TNotifyEvent);
Public | procedure NotifyPreparationNeed;
Public | procedure RemoveNotification(anObject: TObject);
Public | procedure Terminate;
Protected | procedure ContextCreatedBy(aContext: TGLContext);
Protected | procedure CreateServiceContext;
Protected | procedure DestroyingContextBy(aContext: TGLContext);
Protected | procedure Lock;
Protected | procedure QueueTaskDepleted; register;
Protected | procedure RegisterContext(aContext: TGLContext);
Protected | procedure UnLock;
Protected | procedure UnRegisterContext(aContext: TGLContext);

Properties

Protected | property ServiceContext: TGLContext read FServiceContext;
Protected | property ServiceStarter: TEvent read FServiceStarter;

Description

Methods

Public constructor Create;
Public destructor Destroy; override;
Public function ContextCount: Integer;

Returns the number of TGLContext object.<p> This is *not* the number of OpenGL rendering contexts!

Public function CreateContext(AClass: TGLContextClass = nil): TGLContext;

Returns an appropriate, ready-to use context.<p> The returned context should be freed by caller.

Public procedure DestroyAllHandles;

Request all contexts to destroy all their handles.

Public procedure LastContextDestroyNotification(anObject: TObject; anEvent: TNotifyEvent);

Registers a new object to notify when the last context is destroyed.<p> When the last rendering context is destroyed, the 'anEvent' will be invoked with 'anObject' as parameter.<br> Note that the registration is kept until the notification is triggered or a RemoveNotification on 'anObject' is issued.

Public procedure NotifyPreparationNeed;

Notify all contexts about necessity of handles preparation.

Public procedure RemoveNotification(anObject: TObject);

Unregisters an object from the notification lists.<p>

Public procedure Terminate;

Marks the context manager for termination

Protected procedure ContextCreatedBy(aContext: TGLContext);
Protected procedure CreateServiceContext;

Create a special service and resource-keeper context.

Protected procedure DestroyingContextBy(aContext: TGLContext);
Protected procedure Lock;
Protected procedure QueueTaskDepleted; register;
Protected procedure RegisterContext(aContext: TGLContext);
Protected procedure UnLock;
Protected procedure UnRegisterContext(aContext: TGLContext);

Properties

Protected property ServiceContext: TGLContext read FServiceContext;
Protected property ServiceStarter: TEvent read FServiceStarter;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class EGLContext

Class EGLContext

Unit

GLContext

Declaration

type EGLContext = class(Exception)

Description

Hierarchy

  • Exception
  • EGLContext
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class EPBuffer

Class EPBuffer

Unit

GLContext

Declaration

type EPBuffer = class(Exception)

Description

Hierarchy

  • Exception
  • EPBuffer
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLContext: Class EGLShader

Class EGLShader

Unit

GLContext

Declaration

type EGLShader = class(EGLContext)

Description

no description available, EGLContext description follows

Hierarchy

  • Exception
  • EGLContext
  • EGLShader
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLCoordinates

Unit GLCoordinates

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCustomCoordinates |
Class TGLCoordinates2 |
Class TGLCoordinates3 |
Class TGLCoordinates4 |
Interface IGLCoordinatesUpdateAble |
Class TGLCoordinatesUpdateAbleComponent |

Types

TGLCoordinatesStyle = (...);
TGLCoordinates = TGLCoordinates3;

Variables

VUseDefaultCoordinateSets: Boolean = False;

Description

Types

TGLCoordinatesStyle = (...);
Values
  • CsPoint2D:
  • CsPoint:
  • CsVector:
  • CsUnknown:
TGLCoordinates = TGLCoordinates3;

Variables

VUseDefaultCoordinateSets: Boolean = False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLCoordinates: Class TGLCustomCoordinates

Class TGLCustomCoordinates

Unit

GLCoordinates

Declaration

type TGLCustomCoordinates = class(TGLUpdateAbleObject)

Description

no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLCustomCoordinates

Overview

Methods

Public | constructor CreateInitialized(AOwner: TPersistent; const AValue: TVector; const AStyle: TGLCoordinatesStyle = CsUnknown);
Public | destructor Destroy; override;
Public | function AsAddress: PGLFloat;
Public | function Equals(const AVector: TVector): Boolean; reintroduce;
Public | function MaxXYZ: Single;
Public | function VectorLength: TGLFloat;
Public | function VectorNorm: TGLFloat;
Public | procedure AddScaledVector(const Factor: Single; const TranslationVector: TAffineVector); overload;
Public | procedure AddScaledVector(const Factor: Single; const TranslationVector: TVector); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Initialize(const Value: TVector);
Public | procedure Invert;
Public | procedure Normalize;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure ReadFromFiler(Reader: TReader);
Public | procedure Rotate(const AnAxis: TVector; AnAngle: Single); overload;
Public | procedure Rotate(const AnAxis: TAffineVector; AnAngle: Single); overload;
Public | procedure Scale(Factor: Single);
Public | procedure SetPoint(const V: TVector); overload;
Public | procedure SetPoint(const V: TAffineVector); overload;
Public | procedure SetPoint(const X, Y, Z: Single); overload;
Public | procedure SetPoint2D(const X, Y: Single); overload;
Public | procedure SetPoint2D(const Vector: TVector2f); overload;
Public | procedure SetPoint2D(const Vector: TVector); overload;
Public | procedure SetPoint2D(const Vector: TAffineVector); overload;
Public | procedure SetToZero;
Public | procedure SetVector(const V: TVector); overload;
Public | procedure SetVector(const X, Y: Single; Z: Single = 0); overload;
Public | procedure SetVector(const X, Y, Z, W: Single); overload;
Public | procedure SetVector(const V: TAffineVector); overload;
Public | procedure Translate(const TranslationVector: TAffineVector); overload;
Public | procedure Translate(const TranslationVector: TVector); overload;
Public | procedure WriteToFiler(Writer: TWriter);
Protected | procedure DefineProperties(Filer: TFiler); override;
Protected | procedure ReadData(Stream: TStream);
Protected | procedure SetDirectVector(const V: TVector);
Protected | procedure WriteData(Stream: TStream);

Properties

Public | property AsAffineVector: TAffineVector read GetAsAffineVector write SetAsAffineVector;
Public | property AsPoint2D: TVector2f read GetAsPoint2D write SetAsPoint2D;
Public | property AsString: String read GetAsString;
Public | property AsVector: TVector read FCoords write SetAsVector;
Public | property Coordinate[const AIndex: Integer]: TGLFloat read GetCoordinate write SetCoordinate;
Public | property DirectVector: TVector read FCoords write SetDirectVector;
Public | property DirectW: TGLFloat index 3 read GetDirectCoordinate write SetDirectCoordinate;
Public | property DirectX: TGLFloat index 0 read GetDirectCoordinate write SetDirectCoordinate;
Public | property DirectY: TGLFloat index 1 read GetDirectCoordinate write SetDirectCoordinate;
Public | property DirectZ: TGLFloat index 2 read GetDirectCoordinate write SetDirectCoordinate;
Public | property Style: TGLCoordinatesStyle read FStyle write FStyle;
Public | property W: TGLFloat index 3 read GetCoordinate write SetCoordinate;
Public | property X: TGLFloat index 0 read GetCoordinate write SetCoordinate;
Public | property Y: TGLFloat index 1 read GetCoordinate write SetCoordinate;
Public | property Z: TGLFloat index 2 read GetCoordinate write SetCoordinate;

Description

Methods

Public constructor CreateInitialized(AOwner: TPersistent; const AValue: TVector; const AStyle: TGLCoordinatesStyle = CsUnknown);
Public destructor Destroy; override;
Public function AsAddress: PGLFloat;
Public function Equals(const AVector: TVector): Boolean; reintroduce;
Public function MaxXYZ: Single;
Public function VectorLength: TGLFloat;
Public function VectorNorm: TGLFloat;
Public procedure AddScaledVector(const Factor: Single; const TranslationVector: TAffineVector); overload;
Public procedure AddScaledVector(const Factor: Single; const TranslationVector: TVector); overload;
Public procedure Assign(Source: TPersistent); override;
Public procedure Initialize(const Value: TVector);
Public procedure Invert;
Public procedure Normalize;
Public procedure NotifyChange(Sender: TObject); override;
Public procedure ReadFromFiler(Reader: TReader);
Public procedure Rotate(const AnAxis: TVector; AnAngle: Single); overload;
Public procedure Rotate(const AnAxis: TAffineVector; AnAngle: Single); overload;
Public procedure Scale(Factor: Single);
Public procedure SetPoint(const V: TVector); overload;
Public procedure SetPoint(const V: TAffineVector); overload;
Public procedure SetPoint(const X, Y, Z: Single); overload;
Public procedure SetPoint2D(const X, Y: Single); overload;
Public procedure SetPoint2D(const Vector: TVector2f); overload;
Public procedure SetPoint2D(const Vector: TVector); overload;
Public procedure SetPoint2D(const Vector: TAffineVector); overload;
Public procedure SetToZero;
Public procedure SetVector(const V: TVector); overload;
Public procedure SetVector(const X, Y: Single; Z: Single = 0); overload;
Public procedure SetVector(const X, Y, Z, W: Single); overload;
Public procedure SetVector(const V: TAffineVector); overload;
Public procedure Translate(const TranslationVector: TAffineVector); overload;
Public procedure Translate(const TranslationVector: TVector); overload;
Public procedure WriteToFiler(Writer: TWriter);
Protected procedure DefineProperties(Filer: TFiler); override;
Protected procedure ReadData(Stream: TStream);
Protected procedure SetDirectVector(const V: TVector);
Protected procedure WriteData(Stream: TStream);

Properties

Public property AsAffineVector: TAffineVector read GetAsAffineVector write SetAsAffineVector;
Public property AsPoint2D: TVector2f read GetAsPoint2D write SetAsPoint2D;
Public property AsString: String read GetAsString;
Public property AsVector: TVector read FCoords write SetAsVector;
Public property Coordinate[const AIndex: Integer]: TGLFloat read GetCoordinate write SetCoordinate;
Public property DirectVector: TVector read FCoords write SetDirectVector;
Public property DirectW: TGLFloat index 3 read GetDirectCoordinate write SetDirectCoordinate;
Public property DirectX: TGLFloat index 0 read GetDirectCoordinate write SetDirectCoordinate;
Public property DirectY: TGLFloat index 1 read GetDirectCoordinate write SetDirectCoordinate;
Public property DirectZ: TGLFloat index 2 read GetDirectCoordinate write SetDirectCoordinate;
Public property Style: TGLCoordinatesStyle read FStyle write FStyle;
Public property W: TGLFloat index 3 read GetCoordinate write SetCoordinate;
Public property X: TGLFloat index 0 read GetCoordinate write SetCoordinate;
Public property Y: TGLFloat index 1 read GetCoordinate write SetCoordinate;
Public property Z: TGLFloat index 2 read GetCoordinate write SetCoordinate;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLCoordinates: Class TGLCoordinates2

Class TGLCoordinates2

Unit

GLCoordinates

Declaration

type TGLCoordinates2 = class(TGLCustomCoordinates)

Description

no description available, TGLCustomCoordinates description follows
no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLCustomCoordinates
  • TGLCoordinates2

Overview

Properties

Published | property X stored False;
Published | property Y stored False;

Description

Properties

Published property X stored False;
Published property Y stored False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLCoordinates: Class TGLCoordinates3

Class TGLCoordinates3

Unit

GLCoordinates

Declaration

type TGLCoordinates3 = class(TGLCustomCoordinates)

Description

no description available, TGLCustomCoordinates description follows
no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLCustomCoordinates
  • TGLCoordinates3

Overview

Properties

Published | property X stored False;
Published | property Y stored False;
Published | property Z stored False;

Description

Properties

Published property X stored False;
Published property Y stored False;
Published property Z stored False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLCoordinates: Class TGLCoordinates4

Class TGLCoordinates4

Unit

GLCoordinates

Declaration

type TGLCoordinates4 = class(TGLCustomCoordinates)

Description

no description available, TGLCustomCoordinates description follows
no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLCustomCoordinates
  • TGLCoordinates4

Overview

Properties

Published | property W stored False;
Published | property X stored False;
Published | property Y stored False;
Published | property Z stored False;

Description

Properties

Published property W stored False;
Published property X stored False;
Published property Y stored False;
Published property Z stored False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLCoordinates: Interface IGLCoordinatesUpdateAble

Interface IGLCoordinatesUpdateAble

Unit

GLCoordinates

Declaration

type IGLCoordinatesUpdateAble = interface(IInterface)

Description

Hierarchy

  • IInterface
  • IGLCoordinatesUpdateAble

Overview

Methods

Public procedure CoordinateChanged(Sender: TGLCustomCoordinates);

Description

Methods

Public procedure CoordinateChanged(Sender: TGLCustomCoordinates);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLCoordinates: Class TGLCoordinatesUpdateAbleComponent

Class TGLCoordinatesUpdateAbleComponent

Unit

GLCoordinates

Declaration

type TGLCoordinatesUpdateAbleComponent = class(TGLUpdateAbleComponent, IGLCoordinatesUpdateAble)

Description

no description available, TGLUpdateAbleComponent description follows

A base class describing the "update" interface.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent

Overview

Methods

Public procedure CoordinateChanged(Sender: TGLCustomCoordinates); virtual; abstract;

Description

Methods

Public procedure CoordinateChanged(Sender: TGLCustomCoordinates); virtual; abstract;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:15


GLScene v.1.1.2: GLCrossPlatform

Unit GLCrossPlatform

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLCrossPlatform<p>

Cross platform support functions and types for GLScene.<p>

Ultimately, *no* cross-platform or cross-version defines should be present in the core GLScene units, and have all moved here instead.<p>

<b>Historique : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: restored $NODEFINE to remove redeclarations of RGB, GLPoint, GLRect and some other types <li>30/06/11 - DaStr - Added CharToWideChar() <li>19/06/11 - Yar - Added IsDirectoryWriteable <li>15/04/11 - AsmRu - Added GetPlatformInfo, GetPlatformVersion <li>19/03/11 - Yar - Added procedure FixPathDelimiter, RelativePath <li>04/11/10 - DaStr - Added functions missing in Delphi5 and Delphi6: TAssertErrorProc, GetValueFromStringsIndex and some types <li>31/10/10 - Yar - Added GLSTime <li>18/10/10 - Yar - Added functions FloatToHalf, HalfToFloat (Thanks to Fantom) <li>04/09/10 - Yar - Added IsDesignTime variable, SetExeDirectory <li>15/06/10 - Yar - Replace Shell to fpSystem <li>04/03/10 - DanB - Added CharInSet, for Delphi versions < 2009 <li>07/01/10 - DaStr - Bugfixed GetDeviceCapabilities() for Unix (thanks Predator) <li>17/12/09 - DaStr - Moved screen utility functions to GLScreen.pas (thanks Predator) <li>11/11/09 - DaStr - Added GLS_FONT_CHARS_COUNT constant <li>07/11/09 - DaStr - Improved FPC compatibility (BugtrackerID = 2893580) (thanks Predator) <li>24/08/09 - DaStr - Added IncludeTrailingPathDelimiter for Delphi 5 <li>03/06/09 - DanB - Re-added Sleep procedure, for Delphi 5 <li>07/05/09 - DanB - Added FindUnitName (to provide functionality of TObject.UnitName, on prior versions of Delphi) <li>24/03/09 - DanB - Moved Dialog utility functions to GLUtils.pas, new ShowHTMLUrl procedure <li>19/03/09 - DanB - Removed some Kylix IFDEFs, and other changes mostly affecting D5/FPC <li>29/05/08 - DaStr - Added StrToFloatDef(), TryStrToFloat() <li>10/04/08 - DaStr - Added TGLComponent (BugTracker ID = 1938988) <li>07/04/08 - DaStr - Added IsInfinite, IsNan <li>18/11/07 - DaStr - Added ptrInt and PtrUInt types (BugtrackerID = 1833830) (thanks Dje and Burkhard Carstens) <li>06/06/07 - DaStr - Added WORD type Got rid of GLTexture.pas dependancy Moved GetRValue, GetGValue, GetBValue, InitWinColors to GLColor.pas (BugtrackerID = 1732211) <li>02/04/07 - DaStr - Added MakeSubComponent Fixed some IFDEFs to separate FPC from Kylix <li>25/03/07 - DaStr - Replaced some UNIX IFDEFs with KYLIX Added IdentToColor, ColorToIdent, ColorToString, AnsiStartsText, IsSubComponent Added TPoint, PPoint, TRect, PRect, TPicture, TGraphic, TBitmap, TTextLayout, TMouseButton, TMouseEvent, TKeyEvent, TKeyPressEvent Added IInterface, S_OK, E_NOINTERFACE, glKey_PRIOR, glKey_NEXT, glKey_CONTROL <li>24/03/07 - DaStr - Added TPenStyle, TPenMode, TBrushStyle, more color constants, Added "Application" function <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTracekrID=1681585) <li>02/08/04 - LR, YHC - BCB corrections: Added namespace 'Graphics' to TGLBitmap use $NODEFINE to remove declarations of duplicate variables <li>08/07/04 - LR - Added clBlack <li>03/07/04 - LR - Added constant for Keyboard (glKey_TAB, ...) Added function GLOKMessageBox to avoid the uses of Forms Added other abstraction calls Added procedure ShowHTMLUrl for unit Info.pas Added GLShowCursor, GLSetCursorPos, GLGetCursorPos, GLGetScreenWidth, GLGetScreenHeight for GLNavigation Added GLGetTickCount for GLFPSMovement <li>28/06/04 - LR - Added TGLTextLayout, GLLoadBitmapFromInstance Added GetDeviceCapabilities to replace the old function <li>30/05/03 - EG - Added RDTSC and RDTSC-based precision timing for non-WIN32 <li>22/01/02 - EG - Added OpenPictureDialog, ApplicationTerminated <li>07/01/02 - EG - Added QuestionDialog and SavePictureDialog, Added PrecisionTimer funcs <li>06/12/01 - EG - Added several abstraction calls <li>31/08/01 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TPlatformInfo |
Class TGLComponent |

Functions and Procedures

function GLPoint(const x, y: Integer): TGLPoint;
function RGB(const r, g, b: Byte): TColor;
function GLRect(const aLeft, aTop, aRight, aBottom: Integer): TGLRect;
procedure InflateGLRect(var aRect: TGLRect; dx, dy: Integer);
procedure IntersectGLRect(var aRect: TGLRect; const rect2: TGLRect);
function PtInRect(const Rect: TGLRect; const P: TPoint): Boolean;
procedure RaiseLastOSError;
function GetDeviceLogicalPixelsX(device: HDC): Integer;
function GetCurrentColorDepth: Integer;
function PixelFormatToColorBits(aPixelFormat: TPixelFormat): Integer;
function BitmapScanLine(aBitmap: TGLBitmap; aRow: Integer): Pointer;
procedure FixPathDelimiter(var S: string);
function RelativePath(const S: string): string;
procedure QueryPerformanceCounter(var val: Int64);
function QueryPerformanceFrequency(var val: Int64): Boolean;
function StartPrecisionTimer: Int64;
function PrecisionTimerLap(const precisionTimer: Int64): Double;
function StopPrecisionTimer(const precisionTimer: Int64): Double;
function GLSTime: Double;
function RDTSC: Int64;
function GLOKMessageBox(const Text, Caption: string): Integer;
procedure GLLoadBitmapFromInstance(Instance: LongInt; ABitmap: TBitmap; AName: string);
procedure ShowHTMLUrl(Url: string);
function GLGetTickCount: int64;
procedure SetExeDirectory;
function GetDecimalSeparator: Char;
procedure SetDecimalSeparator(AValue: Char);
function AnsiStartsText(const ASubText, AText: string): Boolean;
function IsSubComponent(const AComponent: TComponent): Boolean;
procedure MakeSubComponent(const AComponent: TComponent; const Value: Boolean);
function CharInSet(C: AnsiChar; const CharSet: TSysCharSet): Boolean; overload;
function CharInSet(C: WideChar; const CharSet: TSysCharSet): Boolean; overload;
function FloatToHalf(Float: Single): THalfFloat;
function HalfToFloat(Half: THalfFloat): Single;
function GetValueFromStringsIndex(const AStrings: TStrings; const AIndex: Integer): string;
function GetPlatformInfo: TPlatformInfo;
function GetPlatformVersion : TPlatformVersion;
function GetPlatformVersionStr : string;
function IsDirectoryWriteable(const AName: string): Boolean;
function CharToWideChar(const AChar: AnsiChar): WideChar;

Types

TGLPoint = TPoint;
PGLPoint = ˆTGLPoint;
TGLRect = TRect;
PGLRect = ˆTGLRect;
TDelphiColor = TColor;
TGLPicture = TPicture;
TGLGraphic = TGraphic;
TGLBitmap = TBitmap;
TGraphicClass = class of TGraphic;
TGLTextLayout = (...);
TGLMouseButton = (...);
TGLMouseEvent = procedure(Sender: TObject; Button: TGLMouseButton; Shift: TShiftState; X, Y: Integer) of object;
TGLMouseMoveEvent = TMouseMoveEvent;
TGLKeyEvent = TKeyEvent;
TGLKeyPressEvent = TKeyPressEvent;
TPlatformVersion = (...);
EGLOSError = EOSError;
DWORD = System.DWORD;
TPoint = Types.TPoint;
PPoint = ˆTPoint;
TRect = Types.TRect;
PRect = ˆTRect;
TProjectTargetNameFunc = function(): string;
THalfFloat = type Word;
PHalfFloat = ˆTHalfFloat;

Constants

glpf8Bit = pf8bit;
glpf24bit = pf24bit;
glpf32Bit = pf32bit;
glpfDevice = pfDevice;
glKey_TAB = VK_TAB;
glKey_SPACE = VK_SPACE;
glKey_RETURN = VK_RETURN;
glKey_DELETE = VK_DELETE;
glKey_LEFT = VK_LEFT;
glKey_RIGHT = VK_RIGHT;
glKey_HOME = VK_HOME;
glKey_END = VK_END;
glKey_CANCEL = VK_CANCEL;
glKey_UP = VK_UP;
glKey_DOWN = VK_DOWN;
glKey_PRIOR = VK_PRIOR;
glKey_NEXT = VK_NEXT;
glKey_CONTROL = VK_CONTROL;
psInsideFrame = psSolid;
glsAllFilter: string = 'All';
GLS_FONT_CHARS_COUNT = 256;

Variables

IsDesignTime: Boolean = False;
vProjectTargetName: TProjectTargetNameFunc;

Description

Functions and Procedures

function GLPoint(const x, y: Integer): TGLPoint;
function RGB(const r, g, b: Byte): TColor;

Builds a TColor from Red Green Blue components.

function GLRect(const aLeft, aTop, aRight, aBottom: Integer): TGLRect;
procedure InflateGLRect(var aRect: TGLRect; dx, dy: Integer);

Increases or decreases the width and height of the specified rectangle.<p> Adds dx units to the left and right ends of the rectangle and dy units to the top and bottom.

procedure IntersectGLRect(var aRect: TGLRect; const rect2: TGLRect);
function PtInRect(const Rect: TGLRect; const P: TPoint): Boolean;
procedure RaiseLastOSError;
function GetDeviceLogicalPixelsX(device: HDC): Integer;

Number of pixels per logical inch along the screen width for the device.<p> Under Win32 awaits a HDC and returns its LOGPIXELSX.

function GetCurrentColorDepth: Integer;

Number of bits per pixel for the current desktop resolution.

function PixelFormatToColorBits(aPixelFormat: TPixelFormat): Integer;

Returns the number of color bits associated to the given pixel format.

function BitmapScanLine(aBitmap: TGLBitmap; aRow: Integer): Pointer;

Returns the bitmap's scanline for the specified row.

procedure FixPathDelimiter(var S: string);

Replace path delimiter to delimiter of the current platform.

function RelativePath(const S: string): string;

Remove if possible part of path witch leads to project executable.

procedure QueryPerformanceCounter(var val: Int64);

Returns the current value of the highest-resolution counter.<p> If the platform has none, should return a value derived from the highest precision time reference available, avoiding, if possible, timers that allocate specific system resources.

function QueryPerformanceFrequency(var val: Int64): Boolean;

Returns the frequency of the counter used by QueryPerformanceCounter.<p> Return value is in ticks per second (Hz), returns False if no precision counter is available.

function StartPrecisionTimer: Int64;

Starts a precision timer.<p> Returned value should just be considered as 'handle', even if it ain't so. Default platform implementation is to use QueryPerformanceCounter and QueryPerformanceFrequency, if higher precision references are available, they should be used. The timer will and must be stopped/terminated/released with StopPrecisionTimer.

function PrecisionTimerLap(const precisionTimer: Int64): Double;

Computes time elapsed since timer start.<p> Return time lap in seconds.

function StopPrecisionTimer(const precisionTimer: Int64): Double;

Computes time elapsed since timer start and stop timer.<p> Return time lap in seconds.

function GLSTime: Double;

Returns time in milisecond from application start.<p>

function RDTSC: Int64;

Returns the number of CPU cycles since startup.<p> Use the similarly named CPU instruction.

function GLOKMessageBox(const Text, Caption: string): Integer;
procedure GLLoadBitmapFromInstance(Instance: LongInt; ABitmap: TBitmap; AName: string);
procedure ShowHTMLUrl(Url: string);
function GLGetTickCount: int64;
procedure SetExeDirectory;
function GetDecimalSeparator: Char;
procedure SetDecimalSeparator(AValue: Char);
function AnsiStartsText(const ASubText, AText: string): Boolean;
function IsSubComponent(const AComponent: TComponent): Boolean;
procedure MakeSubComponent(const AComponent: TComponent; const Value: Boolean);
function CharInSet(C: AnsiChar; const CharSet: TSysCharSet): Boolean; overload;
function CharInSet(C: WideChar; const CharSet: TSysCharSet): Boolean; overload;
function FloatToHalf(Float: Single): THalfFloat;
function HalfToFloat(Half: THalfFloat): Single;
function GetValueFromStringsIndex(const AStrings: TStrings; const AIndex: Integer): string;
function GetPlatformInfo: TPlatformInfo;
function GetPlatformVersion : TPlatformVersion;
function GetPlatformVersionStr : string;
function IsDirectoryWriteable(const AName: string): Boolean;

Determine if the directory is writable.<p>

function CharToWideChar(const AChar: AnsiChar): WideChar;

Types

TGLPoint = TPoint;
PGLPoint = ˆTGLPoint;
TGLRect = TRect;
PGLRect = ˆTGLRect;
TDelphiColor = TColor;
TGLPicture = TPicture;
TGLGraphic = TGraphic;
TGLBitmap = TBitmap;
TGraphicClass = class of TGraphic;
TGLTextLayout = (...);
Values
  • tlTop:
  • tlCenter:
  • tlBottom:
TGLMouseButton = (...);
Values
  • mbLeft:
  • mbRight:
  • mbMiddle:
TGLMouseEvent = procedure(Sender: TObject; Button: TGLMouseButton; Shift: TShiftState; X, Y: Integer) of object;
TGLMouseMoveEvent = TMouseMoveEvent;
TGLKeyEvent = TKeyEvent;
TGLKeyPressEvent = TKeyPressEvent;
TPlatformVersion = (...);
Values
  • pvUnknown:
  • pvWin95:
  • pvWin98:
  • pvWinME:
  • pvWinNT3:
  • pvWinNT4:
  • pvWin2000:
  • pvWinXP:
  • pvWin2003:
  • pvWinVista:
  • pvWinSeven:
  • pvWin2008:
  • pvWinNew:
  • pvLinuxArc:
  • pvLinuxDebian:
  • pvLinuxopenSUSE:
  • pvLinuxFedora:
  • pvLinuxGentoo:
  • pvLinuxMandriva:
  • pvLinuxRedHat:
  • pvLinuxTurboLinux:
  • pvLinuxUbuntu:
  • pvLinuxXandros:
  • pvLinuxOracle:
  • pvAppleMacOSX:
EGLOSError = EOSError;
DWORD = System.DWORD;
TPoint = Types.TPoint;
PPoint = ˆTPoint;
TRect = Types.TRect;
PRect = ˆTRect;
TProjectTargetNameFunc = function(): string;
THalfFloat = type Word;
PHalfFloat = ˆTHalfFloat;

Constants

glpf8Bit = pf8bit;
glpf24bit = pf24bit;
glpf32Bit = pf32bit;
glpfDevice = pfDevice;
glKey_TAB = VK_TAB;
glKey_SPACE = VK_SPACE;
glKey_RETURN = VK_RETURN;
glKey_DELETE = VK_DELETE;
glKey_LEFT = VK_LEFT;
glKey_RIGHT = VK_RIGHT;
glKey_HOME = VK_HOME;
glKey_END = VK_END;
glKey_CANCEL = VK_CANCEL;
glKey_UP = VK_UP;
glKey_DOWN = VK_DOWN;
glKey_PRIOR = VK_PRIOR;
glKey_NEXT = VK_NEXT;
glKey_CONTROL = VK_CONTROL;
psInsideFrame = psSolid;
glsAllFilter: string = 'All';
GLS_FONT_CHARS_COUNT = 256;

Variables

IsDesignTime: Boolean = False;
vProjectTargetName: TProjectTargetNameFunc;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLCrossPlatform: record TPlatformInfo

record TPlatformInfo

Unit

GLCrossPlatform

Declaration

type TPlatformInfo = record

Description

Overview

Fields

Major: DWORD;
Minor: DWORD;
Revision: DWORD;
Version: string;
PlatformId:DWORD;
ID: string;
CodeName: string;
Description: string;
ProductBuildVersion: string;

Description

Fields

Major: DWORD;
Minor: DWORD;
Revision: DWORD;
Version: string;
PlatformId:DWORD;
ID: string;
CodeName: string;
Description: string;
ProductBuildVersion: string;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLCrossPlatform: Class TGLComponent

Class TGLComponent

Unit

GLCrossPlatform

Declaration

type TGLComponent = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLComponent
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLCustomShader

Unit GLCustomShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLCustomShader<p>

A collection of pure abstract classes - descendants of TGLShader, which are used for purpose of not having to write the same stuff all over and over again in your own shader classes. It also contains a procedures and function that can be used in all shaders.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>15/16/10 - Yar - Rewrited static procedures (InitTexture, etc.) <li>04/06/10 - Yar - Added unsigned integer uniforms <li>22/04/10 - Yar - Fixes after GLState revision <li>22/01/10 - Yar - Added to TGLCustomShaderParameter property AsTexture <li>25/10/09 - DaStr - Updated TGLGeometryProgram (thanks YarUnderoaker) <li>24/08/09 - DaStr - Separated TGLShaderProgram into TGLVertexProgram, TGLFragmentProgram and TGLGeometryProgram Added TGLCustomShaderParameter.AsUniformBuffer (thanks YarUnderoaker) <li>28/07/09 - DaStr - Added GeometryShader support (thanks YarUnderoaker) Fixed TGLCustomShader.[...]Program serialization <li>24/07/09 - DaStr - Added TGLCustomShader.DebugMode Fixed spelling mistake in TGLShaderUnAplyEvent Added TGLShaderFogSupport, IsFogEnabled() <li>03/04/07 - DaStr - Added TGLCustomShaderParameter.AsFloat and AsInteger <li>25/03/07 - DaStr - Added TGLCustomShaderParameter.SetToTextureOf <li>20/03/07 - DaStr - Added DrawTexturedScreenQuad[4/5/6] "TextureType" parameter renamed to "TextureTarget" Finished working on TGLCustomShaderParameter <li>04/03/07 - DaStr - Added IGLPostShader <li>03/03/07 - DaStr - Added TGLCustomShaderParameter (beta state) <li>22/02/07 - DaStr - Initial version (contributed to GLScene)

What different shader prefixes might mean:

ML - Multi Light - Shader supports up to 8 lights. Attributes such as [Ambient/Diffuse/Specular] Colors are taken from the current OpenGL state (that means from TGLLightSource too) In all other cases shader supports only one light, position of which is taken from the first registered OpenGL light.

What different shader suffixes might mean:

MP - Manual Parameters - [Ambient/Diffuse/Specular] Colors have to be set manualy as shader's properties. In all other cases they are taken from the current OpenGL state (that means from TGLLightSource too)

MT - Manual Main Texture - Main Texture is taken not from the current texture, that is applied to the rendered object, but has to be set manualy as shader's property In all other cases it is taken from the current texture, that is applied to the rendered object

AM - All Manual - MP + MMT

AST - Auto Secondary Textures - All other textures are taken from the textures, that are applied to the rendered object after the main one (like the one in TGLLIbMaterial.Texture2Name, or any other textures that are applied to the object manualy using TGLMaterial.Apply or Direct OpenGL API) In all other cases they are taken from the shader's properties

Previous version history: v1.0 11 March '2006 Creation, separated from GLSLShader v1.1 06 August '2006 TGLCustomShader.HandleShaderNotSupportedException added TGLCustomShader.ShaderNotSupportedExceptionMessage added v1.2 14 August '2006 IGLShaderSupported separated TGLShaderTextureSource added v1.2.2 19 August '2006 IMultiShaderCompatible added v1.2.4 24 August '2006 TGLCustomShader.ParameterTexture[1-3]D added v1.2.6 04 September '2006 Minor fixes v1.3 04 November '2006 TGLShaderUnUplyEvent added OnApply, OnUnApply, OnInitialize moved to the protected section (Un)ApplyBlendingMode added (Get/Set)ParameterTexture[1/2/3]DHandle added InitTexture(), DrawTexturedScreenQuad() added (Get/Set)ParameterCustomTextureHandle support added v1.3.2 16 December '2006 Added shader Naming convention in the comments STR_SHADER_NEEDS_AT_LEAST_ONE_LIGHT_SOURCE moved here from StrangeGLSLBumpShader vStrangeShaderClassList and all shader registration utility functions added v1.3.4 18 February '2007 StrangeTextureUtilities dependancy removed Updated to the latest CVS version of GLScene

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLCustomShaderException |
Interface IGLShaderDescription |
Interface IGLPostShader |
Class TGLCustomShader |
Class TGLShaderProgram |
Class TGLVertexProgram |
Class TGLFragmentProgram |
Class TGLGeometryProgram |
Class TGLCustomShaderParameter |

Functions and Procedures

procedure ApplyBlendingModeEx(const BlendingMode: TGLBlendingModeEx);
procedure UnApplyBlendingModeEx;
procedure InitTexture( const TextureHandle: Cardinal; const TextureSize: TGLSize; const TextureTarget: TGLTextureTarget = ttTexture2D);
procedure DrawTexturedScreenQuad;
procedure DrawTexturedScreenQuad2(const ViewPortSize: TGLSize);
procedure DrawTexturedScreenQuad3;
procedure DrawTexturedScreenQuad4(const ViewPortSize: TGLSize);
procedure DrawTexturedScreenQuad5(const ViewPortSize: TGLSize);
procedure DrawTexturedScreenQuad6(const ViewPortSize: TGLSize);
procedure CopyScreentoTexture(const ViewPortSize: TGLSize; const TextureTarget: Word = GL_TEXTURE_2D);
procedure CopyScreentoTexture2(const ViewPortSize: TGLSize; const TextureTarget: Word = GL_TEXTURE_2D);
function IsFogEnabled(const AFogSupportMode: TGLShaderFogSupport; var rci: TRenderContextInfo): Boolean;
procedure GetActiveLightsList(const ALightIDs: TIntegerList);

Types

TGLShaderFogSupport = (...);
TGLTransformFeedBackMode = (...);
TGLShaderEvent = procedure(Shader: TGLCustomShader) of object;
TGLShaderUnAplyEvent = procedure(Shader: TGLCustomShader; var ThereAreMorePasses: Boolean) of object;
TGLLightSourceEnum = 1..glsShaderMaxLightSources;
TGLLightSourceSet = set of TGLLightSourceEnum;
TGLBlendingModeEx = (...);

Constants

glsShaderMaxLightSources = 8;

Description

Functions and Procedures

procedure ApplyBlendingModeEx(const BlendingMode: TGLBlendingModeEx);
procedure UnApplyBlendingModeEx;
procedure InitTexture( const TextureHandle: Cardinal; const TextureSize: TGLSize; const TextureTarget: TGLTextureTarget = ttTexture2D);
procedure DrawTexturedScreenQuad;
procedure DrawTexturedScreenQuad2(const ViewPortSize: TGLSize);
procedure DrawTexturedScreenQuad3;
procedure DrawTexturedScreenQuad4(const ViewPortSize: TGLSize);
procedure DrawTexturedScreenQuad5(const ViewPortSize: TGLSize);
procedure DrawTexturedScreenQuad6(const ViewPortSize: TGLSize);
procedure CopyScreentoTexture(const ViewPortSize: TGLSize; const TextureTarget: Word = GL_TEXTURE_2D);
procedure CopyScreentoTexture2(const ViewPortSize: TGLSize; const TextureTarget: Word = GL_TEXTURE_2D);
function IsFogEnabled(const AFogSupportMode: TGLShaderFogSupport; var rci: TRenderContextInfo): Boolean;
procedure GetActiveLightsList(const ALightIDs: TIntegerList);

Types

TGLShaderFogSupport = (...);
Values
  • sfsEnabled:
  • sfsDisabled:
  • sfsAuto:
TGLTransformFeedBackMode = (...);
Values
  • tfbmInterleaved:
  • tfbmSeparate:
TGLShaderEvent = procedure(Shader: TGLCustomShader) of object;
TGLShaderUnAplyEvent = procedure(Shader: TGLCustomShader; var ThereAreMorePasses: Boolean) of object;
TGLLightSourceEnum = 1..glsShaderMaxLightSources;
TGLLightSourceSet = set of TGLLightSourceEnum;
TGLBlendingModeEx = (...);

Adds two more blending modes to standard ones. Not sure how to name them or if they should be included in TBlending mode, so I created a new type here.

Values
  • bmxOpaque:
  • bmxTransparency:
  • bmxAdditive:
  • bmxAlphaTest50:
  • bmxAlphaTest100:
  • bmxModulate:
  • bmxDestColorOne:
  • bmxDestAlphaOne:

Constants

glsShaderMaxLightSources = 8;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLCustomShader: Class EGLCustomShaderException

Class EGLCustomShaderException

Unit

GLCustomShader

Declaration

type EGLCustomShaderException = class(EGLShaderException)

Description

no description available, EGLShaderException description follows

Hierarchy

  • Exception
  • EGLShaderException
  • EGLCustomShaderException
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLCustomShader: Interface IGLShaderDescription

Interface IGLShaderDescription

Unit

GLCustomShader

Declaration

type IGLShaderDescription = interface(IInterface)

Description

This interface describes user shaders, in order to be able to access them via a unified interface. If user shader does not support some option, don't raise an axception, just ignore it.

Hierarchy

  • IInterface
  • IGLShaderDescription

Overview

Methods

Public | function GetShaderAlpha: Single;
Public | function GetShaderDescription: string;
Public | procedure GetShaderColorParams(var AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Public | procedure GetShaderMiscParameters(var ACadencer: TGLCadencer; var AMatLib: TGLMaterialLibrary; var ALightSources: TGLLightSourceSet);
Public | procedure GetShaderTextures(var Textures: array of TGLTexture);
Public | procedure SetShaderAlpha(const Value: Single);
Public | procedure SetShaderColorParams(const AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Public | procedure SetShaderMiscParameters(const ACadencer: TGLCadencer; const AMatLib: TGLMaterialLibrary; const ALightSources: TGLLightSourceSet);
Public | procedure SetShaderTextures(const Textures: array of TGLTexture);

Description

Methods

Public function GetShaderAlpha: Single;
Public function GetShaderDescription: string;
Public procedure GetShaderColorParams(var AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Public procedure GetShaderMiscParameters(var ACadencer: TGLCadencer; var AMatLib: TGLMaterialLibrary; var ALightSources: TGLLightSourceSet);
Public procedure GetShaderTextures(var Textures: array of TGLTexture);
Public procedure SetShaderAlpha(const Value: Single);
Public procedure SetShaderColorParams(const AAmbientColor, ADiffuseColor, ASpecularcolor: TVector4f);
Public procedure SetShaderMiscParameters(const ACadencer: TGLCadencer; const AMatLib: TGLMaterialLibrary; const ALightSources: TGLLightSourceSet);
Public procedure SetShaderTextures(const Textures: array of TGLTexture);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLCustomShader: Interface IGLPostShader

Interface IGLPostShader

Unit

GLCustomShader

Declaration

type IGLPostShader = interface(IInterface)

Description

Used in the TGLPostShaderHolder component.

Hierarchy

  • IInterface
  • IGLPostShader

Overview

Methods

Public | function GetTextureTarget: TGLTextureTarget;
Public | procedure DoUseTempTexture(const TempTexture: TGLTextureHandle; TextureTarget: TGLTextureTarget);

Description

Methods

Public function GetTextureTarget: TGLTextureTarget;

Called to determine if it is compatible.

Public procedure DoUseTempTexture(const TempTexture: TGLTextureHandle; TextureTarget: TGLTextureTarget);

Called on every pass.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLCustomShader: Class TGLCustomShader

Class TGLCustomShader

Unit

GLCustomShader

Declaration

type TGLCustomShader = class(TGLShader)

Description

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader

Overview

Fields

Protected FDebugMode: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadShaderPrograms(const VPFilename, FPFilename: string; GPFilename: string = '');
Protected | procedure SetDebugMode(const Value: Boolean); virtual;

Properties

Protected | property DebugMode: Boolean read FDebugMode write SetDebugMode default False;
Protected | property FragmentProgram: TGLFragmentProgram read FFragmentProgram write SetFragmentProgram stored StoreFragmentProgram;
Protected | property GeometryProgram: TGLGeometryProgram read FGeometryProgram write SetGeometryProgram stored StoreGeometryProgram;
Protected | property TagObject: TObject read FTagObject write FTagObject default nil;
Protected | property VertexProgram: TGLVertexProgram read FVertexProgram write SetVertexProgram stored StoreVertexProgram;

Description

Fields

Protected FDebugMode: Boolean;

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadShaderPrograms(const VPFilename, FPFilename: string; GPFilename: string = '');
Protected procedure SetDebugMode(const Value: Boolean); virtual;

Properties

Protected property DebugMode: Boolean read FDebugMode write SetDebugMode default False;

Treats warnings as errors and displays this error, instead of a general shader-not-supported message.

Protected property FragmentProgram: TGLFragmentProgram read FFragmentProgram write SetFragmentProgram stored StoreFragmentProgram;
Protected property GeometryProgram: TGLGeometryProgram read FGeometryProgram write SetGeometryProgram stored StoreGeometryProgram;
Protected property TagObject: TObject read FTagObject write FTagObject default nil;
Protected property VertexProgram: TGLVertexProgram read FVertexProgram write SetVertexProgram stored StoreVertexProgram;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLCustomShader: Class TGLShaderProgram

Class TGLShaderProgram

Unit

GLCustomShader

Declaration

type TGLShaderProgram = class(TPersistent)

Description

A custom shader program.

Hierarchy

  • TPersistent
  • TGLShaderProgram

Overview

Methods

Public | constructor Create(const AParent: TGLCustomShader); virtual;
Public | destructor Destroy; override;
Protected | function GetOwner: TPersistent; override;
Public | procedure Apply; virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const AFileName: string);

Properties

Published | property Code: TStrings read FCode write SetCode;
Published | property Enabled: Boolean read FEnabled write SetEnabled default False;

Description

Methods

Public constructor Create(const AParent: TGLCustomShader); virtual;
Public destructor Destroy; override;
Protected function GetOwner: TPersistent; override;
Public procedure Apply; virtual;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadFromFile(const AFileName: string);

Properties

Published property Code: TStrings read FCode write SetCode;
Published property Enabled: Boolean read FEnabled write SetEnabled default False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLCustomShader: Class TGLVertexProgram

Class TGLVertexProgram

Unit

GLCustomShader

Declaration

type TGLVertexProgram = class(TGLShaderProgram)

Description

no description available, TGLShaderProgram description follows

A custom shader program.

Hierarchy

  • TPersistent
  • TGLShaderProgram
  • TGLVertexProgram

Overview

Properties

Published | property Code;
Published | property Enabled;

Description

Properties

Published property Code;
Published property Enabled;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLCustomShader: Class TGLFragmentProgram

Class TGLFragmentProgram

Unit

GLCustomShader

Declaration

type TGLFragmentProgram = class(TGLShaderProgram)

Description

no description available, TGLShaderProgram description follows

A custom shader program.

Hierarchy

  • TPersistent
  • TGLShaderProgram
  • TGLFragmentProgram

Overview

Properties

Published | property Code;
Published | property Enabled;

Description

Properties

Published property Code;
Published property Enabled;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLCustomShader: Class TGLGeometryProgram

Class TGLGeometryProgram

Unit

GLCustomShader

Declaration

type TGLGeometryProgram = class(TGLShaderProgram)

Description

no description available, TGLShaderProgram description follows

A custom shader program.

Hierarchy

  • TPersistent
  • TGLShaderProgram
  • TGLGeometryProgram

Overview

Methods

Public constructor Create(const AParent: TGLCustomShader); override;

Properties

Published | property Code;
Published | property Enabled;
Published | property InputPrimitiveType: TGLgsInTypes read FInputPrimitiveType write SetInputPrimitiveType default gsInPoints;
Published | property OutputPrimitiveType: TGLgsOutTypes read FOutputPrimitiveType write SetOutputPrimitiveType default gsOutPoints;
Published | property VerticesOut: TGLint read FVerticesOut write SetVerticesOut default 0;

Description

Methods

Public constructor Create(const AParent: TGLCustomShader); override;

Properties

Published property Code;
Published property Enabled;
Published property InputPrimitiveType: TGLgsInTypes read FInputPrimitiveType write SetInputPrimitiveType default gsInPoints;
Published property OutputPrimitiveType: TGLgsOutTypes read FOutputPrimitiveType write SetOutputPrimitiveType default gsOutPoints;
Published property VerticesOut: TGLint read FVerticesOut write SetVerticesOut default 0;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLCustomShader: Class TGLCustomShaderParameter

Class TGLCustomShaderParameter

Unit

GLCustomShader

Declaration

type TGLCustomShaderParameter = class(TObject)

Description

Wrapper around a parameter of the main program.

Hierarchy

  • TObject
  • TGLCustomShaderParameter

Overview

Methods

Protected | function GetAsCustomTexture(const TextureIndex: Integer; TextureTarget: TGLTextureTarget): Cardinal; virtual; abstract;
Protected | function GetAsMatrix2f: TMatrix2f; virtual; abstract;
Protected | function GetAsMatrix3f: TMatrix3f; virtual; abstract;
Protected | function GetAsMatrix4f: TMatrix4f; virtual; abstract;
Protected | function GetAsUniformBuffer: GLenum; virtual; abstract;
Protected | function GetAsVector1f: Single; virtual; abstract;
Protected | function GetAsVector1i: Integer; virtual; abstract;
Protected | function GetAsVector1ui: GLuint; virtual; abstract;
Protected | function GetAsVector2f: TVector2f; virtual; abstract;
Protected | function GetAsVector2i: TVector2i; virtual; abstract;
Protected | function GetAsVector2ui: TVector2ui; virtual; abstract;
Protected | function GetAsVector3f: TVector3f; virtual; abstract;
Protected | function GetAsVector3i: TVector3i; virtual; abstract;
Protected | function GetAsVector3ui: TVector3ui; virtual; abstract;
Protected | function GetAsVector4f: TVector; virtual; abstract;
Protected | function GetAsVector4i: TVector4i; virtual; abstract;
Protected | function GetAsVector4ui: TVector4ui; virtual; abstract;
Public | procedure SetAsVectorF(const Values: array of Single); overload;
Public | procedure SetAsVectorI(const Values: array of Integer); overload;
Public | procedure SetToTextureOf(const LibMaterial: TGLLibMaterial; const TextureIndex: Integer); overload;
Public | procedure SetToTextureOf(const Texture: TGLTexture; const TextureIndex: Integer); overload;
Protected | procedure SetAsCustomTexture(const TextureIndex: Integer; TextureTarget: TGLTextureTarget; const Value: Cardinal); virtual; abstract;
Protected | procedure SetAsMatrix2f(const Value: TMatrix2f); virtual; abstract;
Protected | procedure SetAsMatrix3f(const Value: TMatrix3f); virtual; abstract;
Protected | procedure SetAsMatrix4f(const Value: TMatrix4f); virtual; abstract;
Protected | procedure SetAsTexture(const TextureIndex: Integer; const Value: TGLTexture);
Protected | procedure SetAsTexture1D(const TextureIndex: Integer; const Value: TGLTexture);
Protected | procedure SetAsTexture2D(const TextureIndex: Integer; const Value: TGLTexture);
Protected | procedure SetAsTexture3D(const TextureIndex: Integer; const Value: TGLTexture);
Protected | procedure SetAsTextureCube(const TextureIndex: Integer; const Value: TGLTexture);
Protected | procedure SetAsTextureRect(const TextureIndex: Integer; const Value: TGLTexture);
Protected | procedure SetAsUniformBuffer(UBO: GLenum); virtual; abstract;
Protected | procedure SetAsVector1f(const Value: Single); virtual; abstract;
Protected | procedure SetAsVector1i(const Value: Integer); virtual; abstract;
Protected | procedure SetAsVector1ui(const Value: GLuint); virtual; abstract;
Protected | procedure SetAsVector2f(const Value: TVector2f); virtual; abstract;
Protected | procedure SetAsVector2i(const Value: TVector2i); virtual; abstract;
Protected | procedure SetAsVector2ui(const Value: TVector2ui); virtual; abstract;
Protected | procedure SetAsVector3f(const Value: TVector3f); virtual; abstract;
Protected | procedure SetAsVector3i(const Value: TVector3i); virtual; abstract;
Protected | procedure SetAsVector3ui(const Value: TVector3ui); virtual; abstract;
Protected | procedure SetAsVector4f(const Value: TVector4f); virtual; abstract;
Protected | procedure SetAsVector4i(const Value: TVector4i); virtual; abstract;
Protected | procedure SetAsVector4ui(const Value: TVector4ui); virtual; abstract;

Properties

Public | property AsAffineVector: TAffineVector read GetAsVector3f write SetAsVector3f;
Public | property AsCustomTexture[const TextureIndex: Integer; TextureTarget: TGLTextureTarget]: Cardinal read GetAsCustomTexture write SetAsCustomTexture;
Public | property AsFloat: Single read GetAsVector1f write SetAsVector1f;
Public | property AsInteger: Integer read GetAsVector1i write SetAsVector1i;
Public | property AsMatrix2f: TMatrix2f read GetAsMatrix2f write SetAsMatrix2f;
Public | property AsMatrix3f: TMatrix3f read GetAsMatrix3f write SetAsMatrix3f;
Public | property AsMatrix4f: TMatrix4f read GetAsMatrix4f write SetAsMatrix4f;
Public | property AsTexture [const TextureIndex: Integer]: TGLTexture write SetAsTexture;
Public | property AsTexture1D [const TextureIndex: Integer]: TGLTexture write SetAsTexture1D;
Public | property AsTexture2D [const TextureIndex: Integer]: TGLTexture write SetAsTexture2D;
Public | property AsTexture3D [const TextureIndex: Integer]: TGLTexture write SetAsTexture3D;
Public | property AsTextureCube[const TextureIndex: Integer]: TGLTexture write SetAsTextureCube;
Public | property AsTextureRect[const TextureIndex: Integer]: TGLTexture write SetAsTextureRect;
Public | property AsUniformBuffer: GLenum read GetAsUniformBuffer write SetAsUniformBuffer;
Public | property AsVector: TVector read GetAsVector4f write SetAsVector4f;
Public | property AsVector1f: Single read GetAsVector1f write SetAsVector1f;
Public | property AsVector1i: Integer read GetAsVector1i write SetAsVector1i;
Public | property AsVector1ui: GLuint read GetAsVector1ui write SetAsVector1ui;
Public | property AsVector2f: TVector2f read GetAsVector2f write SetAsVector2f;
Public | property AsVector2i: TVector2i read GetAsVector2i write SetAsVector2i;
Public | property AsVector2ui: TVector2ui read GetAsVector2ui write SetAsVector2ui;
Public | property AsVector3f: TVector3f read GetAsVector3f write SetAsVector3f;
Public | property AsVector3i: TVector3i read GetAsVector3i write SetAsVector3i;
Public | property AsVector3ui: TVector3ui read GetAsVector3ui write SetAsVector3ui;
Public | property AsVector4f: TVector4f read GetAsVector4f write SetAsVector4f;
Public | property AsVector4i: TVector4i read GetAsVector4i write SetAsVector4i;
Public | property AsVector4ui: TVector4ui read GetAsVector4ui write SetAsVector4ui;

Description

Methods

Protected function GetAsCustomTexture(const TextureIndex: Integer; TextureTarget: TGLTextureTarget): Cardinal; virtual; abstract;
Protected function GetAsMatrix2f: TMatrix2f; virtual; abstract;
Protected function GetAsMatrix3f: TMatrix3f; virtual; abstract;
Protected function GetAsMatrix4f: TMatrix4f; virtual; abstract;
Protected function GetAsUniformBuffer: GLenum; virtual; abstract;
Protected function GetAsVector1f: Single; virtual; abstract;
Protected function GetAsVector1i: Integer; virtual; abstract;
Protected function GetAsVector1ui: GLuint; virtual; abstract;
Protected function GetAsVector2f: TVector2f; virtual; abstract;
Protected function GetAsVector2i: TVector2i; virtual; abstract;
Protected function GetAsVector2ui: TVector2ui; virtual; abstract;
Protected function GetAsVector3f: TVector3f; virtual; abstract;
Protected function GetAsVector3i: TVector3i; virtual; abstract;
Protected function GetAsVector3ui: TVector3ui; virtual; abstract;
Protected function GetAsVector4f: TVector; virtual; abstract;
Protected function GetAsVector4i: TVector4i; virtual; abstract;
Protected function GetAsVector4ui: TVector4ui; virtual; abstract;
Public procedure SetAsVectorF(const Values: array of Single); overload;

This overloaded SetAsVector accepts open array as input. e.g. SetAsVectorF([0.1, 0.2]). Array length must between 1-4.

Public procedure SetAsVectorI(const Values: array of Integer); overload;
Public procedure SetToTextureOf(const LibMaterial: TGLLibMaterial; const TextureIndex: Integer); overload;

SetToTextureOf determines texture type on-the-fly.

Public procedure SetToTextureOf(const Texture: TGLTexture; const TextureIndex: Integer); overload;
Protected procedure SetAsCustomTexture(const TextureIndex: Integer; TextureTarget: TGLTextureTarget; const Value: Cardinal); virtual; abstract;
Protected procedure SetAsMatrix2f(const Value: TMatrix2f); virtual; abstract;
Protected procedure SetAsMatrix3f(const Value: TMatrix3f); virtual; abstract;
Protected procedure SetAsMatrix4f(const Value: TMatrix4f); virtual; abstract;
Protected procedure SetAsTexture(const TextureIndex: Integer; const Value: TGLTexture);
Protected procedure SetAsTexture1D(const TextureIndex: Integer; const Value: TGLTexture);
Protected procedure SetAsTexture2D(const TextureIndex: Integer; const Value: TGLTexture);
Protected procedure SetAsTexture3D(const TextureIndex: Integer; const Value: TGLTexture);
Protected procedure SetAsTextureCube(const TextureIndex: Integer; const Value: TGLTexture);
Protected procedure SetAsTextureRect(const TextureIndex: Integer; const Value: TGLTexture);
Protected procedure SetAsUniformBuffer(UBO: GLenum); virtual; abstract;
Protected procedure SetAsVector1f(const Value: Single); virtual; abstract;
Protected procedure SetAsVector1i(const Value: Integer); virtual; abstract;
Protected procedure SetAsVector1ui(const Value: GLuint); virtual; abstract;
Protected procedure SetAsVector2f(const Value: TVector2f); virtual; abstract;
Protected procedure SetAsVector2i(const Value: TVector2i); virtual; abstract;
Protected procedure SetAsVector2ui(const Value: TVector2ui); virtual; abstract;
Protected procedure SetAsVector3f(const Value: TVector3f); virtual; abstract;
Protected procedure SetAsVector3i(const Value: TVector3i); virtual; abstract;
Protected procedure SetAsVector3ui(const Value: TVector3ui); virtual; abstract;
Protected procedure SetAsVector4f(const Value: TVector4f); virtual; abstract;
Protected procedure SetAsVector4i(const Value: TVector4i); virtual; abstract;
Protected procedure SetAsVector4ui(const Value: TVector4ui); virtual; abstract;

Properties

Public property AsAffineVector: TAffineVector read GetAsVector3f write SetAsVector3f;
Public property AsCustomTexture[const TextureIndex: Integer; TextureTarget: TGLTextureTarget]: Cardinal read GetAsCustomTexture write SetAsCustomTexture;
Public property AsFloat: Single read GetAsVector1f write SetAsVector1f;

Standard types.

Public property AsInteger: Integer read GetAsVector1i write SetAsVector1i;
Public property AsMatrix2f: TMatrix2f read GetAsMatrix2f write SetAsMatrix2f;

Matrix Types.

Public property AsMatrix3f: TMatrix3f read GetAsMatrix3f write SetAsMatrix3f;
Public property AsMatrix4f: TMatrix4f read GetAsMatrix4f write SetAsMatrix4f;
Public property AsTexture [const TextureIndex: Integer]: TGLTexture write SetAsTexture;

Texture Types.

Public property AsTexture1D [const TextureIndex: Integer]: TGLTexture write SetAsTexture1D;
Public property AsTexture2D [const TextureIndex: Integer]: TGLTexture write SetAsTexture2D;
Public property AsTexture3D [const TextureIndex: Integer]: TGLTexture write SetAsTexture3D;
Public property AsTextureCube[const TextureIndex: Integer]: TGLTexture write SetAsTextureCube;
Public property AsTextureRect[const TextureIndex: Integer]: TGLTexture write SetAsTextureRect;
Public property AsUniformBuffer: GLenum read GetAsUniformBuffer write SetAsUniformBuffer;
Public property AsVector: TVector read GetAsVector4f write SetAsVector4f;

GLScene-friendly properties.

Public property AsVector1f: Single read GetAsVector1f write SetAsVector1f;

Float vector types.

Public property AsVector1i: Integer read GetAsVector1i write SetAsVector1i;

Integer vector types.

Public property AsVector1ui: GLuint read GetAsVector1ui write SetAsVector1ui;

Unsigned integer vector types.

Public property AsVector2f: TVector2f read GetAsVector2f write SetAsVector2f;
Public property AsVector2i: TVector2i read GetAsVector2i write SetAsVector2i;
Public property AsVector2ui: TVector2ui read GetAsVector2ui write SetAsVector2ui;
Public property AsVector3f: TVector3f read GetAsVector3f write SetAsVector3f;
Public property AsVector3i: TVector3i read GetAsVector3i write SetAsVector3i;
Public property AsVector3ui: TVector3ui read GetAsVector3ui write SetAsVector3ui;
Public property AsVector4f: TVector4f read GetAsVector4f write SetAsVector4f;
Public property AsVector4i: TVector4i read GetAsVector4i write SetAsVector4i;
Public property AsVector4ui: TVector4ui read GetAsVector4ui write SetAsVector4ui;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLDCE

Unit GLDCE

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLDCE<p>

How to use: - Add a DCEManager to you form and configure its properties - Add a Dynamic Collision Behavior to you object - Add a Static Collision behaviour to objects which yours will collide - You can choose the shape of your static object - csEllipsoid, csBox - csFreeform MUST BE A TGLFreeform, otherwise will raise errors - csTerrain MUST BE A TGLTerrainRenderer, same condition above - Active: Disable or enable the behaviour for this object - Friction: is a value aprox. between 0 (no friction) and 100 (no movement) - Layer: An object collides only with lower or equal layers - Size: is used for Ellipsoids (Radius) / Boxes (Dimensions) - Solid: Object still generate collision events but it doesn't "block" the dynamic object - UseGravity: You can disable the gravity for that object - SlideOrBounce: The object can bounce like a ball or slide like an FPS - BounceFactor: Restituition factor, 1 means that it will bounce forever

<b>History : </b><font size=-1><ul> <li>21/01/01 - DanB - Added "inherited" call to TGLDCEDynamic/TGLDCEStatic.WriteToFiler <li>18/09/10 - YP - Moved published behaviours' events to public (they cannot be restored by the filer) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>29/01/07 - DaStr - Moved registration to GLSceneRegister.pas <li>01/07/05 - MathX - Fixed memory leak on contactPoints (moveByDistance method) <li>23/01/05 - LucasG - Code reorganized, many fixes and some new features <li>19/11/04 - GAK - Added standardised collision selection (optionally use same selection criteria as other collision system) <li>17/11/04 - LucasG - Added support for static box colliders <li>17/11/04 - LucasG - Added UseGravity property to behaviour <li>14/11/04 - LucasG - Fixed average friction calculation <li>14/11/04 - LucasG - Added AirFriction property to DCEManager <li>13/11/04 - LucasG - Added Active property to behaviour <li>17/11/04 - LucasG - Added support for static box colliders <li>17/11/04 - LucasG - Added UseGravity property to behaviour <li>14/11/04 - LucasG - Fixed average friction calculation <li>14/11/04 - LucasG - Added AirFriction property to DCEManager <li>13/11/04 - LucasG - Added Active property to behaviour <li>03/09/04 - LucasG - First release <li>29/07/04 - LucasG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TDCECollision |
Class TGLDCEManager |
Class TGLDCEStatic |
Class TGLDCEDynamic |

Functions and Procedures

function GetOrCreateDCEStatic(behaviours : TGLBehaviours) : TGLDCEStatic; overload;
function GetOrCreateDCEStatic(obj : TGLBaseSceneObject) : TGLDCEStatic; overload;
function GetOrCreateDCEDynamic(behaviours : TGLBehaviours) : TGLDCEDynamic; overload;
function GetOrCreateDCEDynamic(obj : TGLBaseSceneObject) : TGLDCEDynamic; overload;

Types

TDCEShape = (...);
TDCECollisionSelection = (...);
TDCECollisionEvent = procedure (Sender : TObject; object1, object2 : TGLBaseSceneObject; CollisionInfo: TDCECollision) of object;
TDCEObjectCollisionEvent = procedure (Sender : TObject; ObjectCollided : TGLBaseSceneObject; CollisionInfo: TDCECollision) of object;
TDCESlideOrBounce = (...);

Description

Functions and Procedures

function GetOrCreateDCEStatic(behaviours : TGLBehaviours) : TGLDCEStatic; overload;
function GetOrCreateDCEStatic(obj : TGLBaseSceneObject) : TGLDCEStatic; overload;
function GetOrCreateDCEDynamic(behaviours : TGLBehaviours) : TGLDCEDynamic; overload;
function GetOrCreateDCEDynamic(obj : TGLBaseSceneObject) : TGLDCEDynamic; overload;

Types

TDCEShape = (...);
Values
  • csEllipsoid:
  • csBox:
  • csFreeform:
  • csTerrain:
TDCECollisionSelection = (...);

Indicates which type of layer comparison is made when trying to detect collisions between 2 bodies (A and B). Possible values are: <ul> <li>ccsDCEStandard: Collides bodies if A.layer <= B.layer <li>ccsCollisionStandard: Collides bodies if either A or B have layer equal to zero or if their layers are different. <li>ccsHybrid: Collides bodies if either one of the previous checks would pass (i.e. if the layer of either body is equal to 0 or if A.layer <= B.layer) *and* if both layers are positive (that is, turns off collision for bodies whose layer is < 0) </ul>

Values
  • ccsDCEStandard:
  • ccsCollisionStandard:
  • ccsHybrid:
TDCECollisionEvent = procedure (Sender : TObject; object1, object2 : TGLBaseSceneObject; CollisionInfo: TDCECollision) of object;
TDCEObjectCollisionEvent = procedure (Sender : TObject; ObjectCollided : TGLBaseSceneObject; CollisionInfo: TDCECollision) of object;
TDCESlideOrBounce = (...);
Values
  • csbSlide:
  • csbBounce:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLDCE: record TDCECollision

record TDCECollision

Unit

GLDCE

Declaration

type TDCECollision = record

Description

Overview

Fields

Position: TAffineVector;
Normal: TAffineVector;
Bounce: TAffineVector;
Nearest: Boolean;
RootCollision:boolean;
Distance:single;

Description

Fields

Position: TAffineVector;
Normal: TAffineVector;
Bounce: TAffineVector;
Nearest: Boolean;
RootCollision:boolean;
Distance:single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLDCE: Class TGLDCEManager

Class TGLDCEManager

Unit

GLDCE

Declaration

type TGLDCEManager = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLDCEManager

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function MoveByDistance(var Body: TGLDCEDynamic; deltaS, deltaAbsS: TAffineVector): Single;
Public | procedure Step(deltaTime: Double);
Protected | procedure DeRegisterAllDynamics;
Protected | procedure DeRegisterAllStatics;
Protected | procedure DeRegisterDynamic(aClient : TGLDCEDynamic);
Protected | procedure DeRegisterStatic(aClient : TGLDCEStatic);
Protected | procedure RegisterDynamic(aClient : TGLDCEDynamic);
Protected | procedure RegisterStatic(aClient : TGLDCEStatic);

Properties

Public | property DynamicCount: Integer read GetDynamicCount;
Published | property Gravity : Single read FGravity write FGravity;
Published | property ManualStep: Boolean read FManualStep write FManualStep;
Published | property MovimentScale : Single read FMovimentScale write FMovimentScale;
Published | property OnCollision : TDCECollisionEvent read FOnCollision write FOnCollision;
Published | property StandardiseLayers: TDCECollisionSelection read FStandardiseLayers write FStandardiseLayers;
Public | property StaticCount: Integer read GetStaticCount;
Published | property WorldDirection : TGLCoordinates read FWorldDirection write SetWorldDirection;
Published | property WorldScale : Single read FWorldScale write SetWorldScale;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function MoveByDistance(var Body: TGLDCEDynamic; deltaS, deltaAbsS: TAffineVector): Single;
Public procedure Step(deltaTime: Double);
Protected procedure DeRegisterAllDynamics;
Protected procedure DeRegisterAllStatics;
Protected procedure DeRegisterDynamic(aClient : TGLDCEDynamic);
Protected procedure DeRegisterStatic(aClient : TGLDCEStatic);
Protected procedure RegisterDynamic(aClient : TGLDCEDynamic);
Protected procedure RegisterStatic(aClient : TGLDCEStatic);

Properties

Public property DynamicCount: Integer read GetDynamicCount;
Published property Gravity : Single read FGravity write FGravity;
Published property ManualStep: Boolean read FManualStep write FManualStep;
Published property MovimentScale : Single read FMovimentScale write FMovimentScale;
Published property OnCollision : TDCECollisionEvent read FOnCollision write FOnCollision;
Published property StandardiseLayers: TDCECollisionSelection read FStandardiseLayers write FStandardiseLayers;
Public property StaticCount: Integer read GetStaticCount;
Published property WorldDirection : TGLCoordinates read FWorldDirection write SetWorldDirection;
Published property WorldScale : Single read FWorldScale write SetWorldScale;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLDCE: Class TGLDCEStatic

Class TGLDCEStatic

Unit

GLDCE

Declaration

type TGLDCEStatic = class(TGLBehaviour)

Description

no description available, TGLBehaviour description follows

Ancestor for non-rendering behaviours.<p> This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLObjectEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLDCEStatic

Overview

Methods

Public | constructor Create(aOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure Loaded; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetManager(const val : TGLDCEManager);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property Active : Boolean read FActive write FActive;
Published | property BounceFactor : Single read FBounceFactor write SetBounceFactor;
Published | property Friction : Single read FFriction write SetFriction;
Published | property Layer : Integer read FLayer write FLayer;
Published | property Manager : TGLDCEManager read FManager write SetManager;
Public | property OnCollision : TDCEObjectCollisionEvent read FOnCollision write FOnCollision;
Published | property Shape : TDCEShape read FShape write SetShape;
Published | property Size : TGLCoordinates read FSize write SetSize;
Published | property Solid : Boolean read FSolid write FSolid;

Description

Methods

Public constructor Create(aOwner : TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Public procedure Assign(Source: TPersistent); override;
Protected procedure Loaded; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetManager(const val : TGLDCEManager);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Active : Boolean read FActive write FActive;
Published property BounceFactor : Single read FBounceFactor write SetBounceFactor;
Published property Friction : Single read FFriction write SetFriction;
Published property Layer : Integer read FLayer write FLayer;
Published property Manager : TGLDCEManager read FManager write SetManager;
Public property OnCollision : TDCEObjectCollisionEvent read FOnCollision write FOnCollision;
Published property Shape : TDCEShape read FShape write SetShape;
Published property Size : TGLCoordinates read FSize write SetSize;
Published property Solid : Boolean read FSolid write FSolid;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:16


GLScene v.1.1.2: GLDCE: Class TGLDCEDynamic

Class TGLDCEDynamic

Unit

GLDCE

Declaration

type TGLDCEDynamic = class(TGLBehaviour)

Description

no description available, TGLBehaviour description follows

Ancestor for non-rendering behaviours.<p> This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLObjectEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLDCEDynamic

Overview

Methods

Public | constructor Create(aOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Public | procedure ApplyAbsAccel(x,y,z: Single); overload;
Public | procedure ApplyAbsAccel(NewAccel: TAffineVector); overload;
Public | procedure ApplyAccel(x,y,z: Single); overload;
Public | procedure ApplyAccel(NewAccel: TAffineVector); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoMove(deltaTime: Double);
Public | procedure DoProgress(const progressTime : TProgressTimes); override;
Public | procedure Jump(jHeight, jSpeed: Single);
Public | procedure Move(deltaS: TAffineVector; deltaTime: Double);
Public | procedure MoveTo(Position: TAffineVector; Amount: Single);
Public | procedure StopAbsAccel;
Public | procedure StopAccel;
Protected | procedure Loaded; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetManager(const val : TGLDCEManager);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property Active : Boolean read FActive write FActive;
Published | property BounceFactor : Single read FBounceFactor write SetBounceFactor;
Published | property Friction : Single read FFriction write SetFriction;
Public | property InGround : Boolean read FInGround;
Published | property Layer : Integer read FLayer write FLayer;
Published | property Manager : TGLDCEManager read FManager write SetManager;
Public | property MaxRecursionDepth: byte read FMaxRecursionDepth write FMaxRecursionDepth;
Public | property OnCollision : TDCEObjectCollisionEvent read FOnCollision write FOnCollision;
Published | property Size : TGLCoordinates read FSize write SetSize;
Published | property SlideOrBounce: TDCESlideOrBounce read FSlideOrBounce write FSlideOrBounce;
Published | property Solid : Boolean read FSolid write FSolid;
Public | property Speed : TAffineVector read FSpeed write FSpeed;
Published | property UseGravity : Boolean read FUseGravity write FUseGravity;

Description

Methods

Public constructor Create(aOwner : TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Public procedure ApplyAbsAccel(x,y,z: Single); overload;
Public procedure ApplyAbsAccel(NewAccel: TAffineVector); overload;
Public procedure ApplyAccel(x,y,z: Single); overload;
Public procedure ApplyAccel(NewAccel: TAffineVector); overload;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoMove(deltaTime: Double);
Public procedure DoProgress(const progressTime : TProgressTimes); override;
Public procedure Jump(jHeight, jSpeed: Single);
Public procedure Move(deltaS: TAffineVector; deltaTime: Double);
Public procedure MoveTo(Position: TAffineVector; Amount: Single);
Public procedure StopAbsAccel;
Public procedure StopAccel;
Protected procedure Loaded; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetManager(const val : TGLDCEManager);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Active : Boolean read FActive write FActive;
Published property BounceFactor : Single read FBounceFactor write SetBounceFactor;
Published property Friction : Single read FFriction write SetFriction;
Public property InGround : Boolean read FInGround;
Published property Layer : Integer read FLayer write FLayer;
Published property Manager : TGLDCEManager read FManager write SetManager;
Public property MaxRecursionDepth: byte read FMaxRecursionDepth write FMaxRecursionDepth;
Public property OnCollision : TDCEObjectCollisionEvent read FOnCollision write FOnCollision;
Published property Size : TGLCoordinates read FSize write SetSize;
Published property SlideOrBounce: TDCESlideOrBounce read FSlideOrBounce write FSlideOrBounce;
Published property Solid : Boolean read FSolid write FSolid;
Public property Speed : TAffineVector read FSpeed write FSpeed;
Published property UseGravity : Boolean read FUseGravity write FUseGravity;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLDCEMisc

Unit GLDCEMisc

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLDCEMisc<p>

Miscelaneous functions used by DCE (Dynamic Collision Engine).

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>30/03/07 - DaStr - Added $I GLScene.inc <li>23/01/05 - LucasG - Code reorganized, many fixes and some new features <li>03/09/04 - LucasG - First release <li>29/07/04 - LucasG - Creation </ul></font>

Overview

Functions and Procedures

procedure ECSetCollisionRange(var MovePack: TECMovePack);
procedure ECResetColliders(var MovePack: TECMovePack);
procedure ECAddFreeForm(var MovePack: TECMovePack; FreeForm: TGLBaseSceneObject; Solid: Boolean; ObjectID: Integer);
procedure ECAddBox(var MovePack: TECMovePack; BoxObj: TGLBaseSceneObject; BoxSize: TAffineVector; Solid: Boolean; ObjectID: Integer);
procedure ECAddTerrain(var MovePack: TECMovePack; TerrainRenderer: TGLTerrainRenderer; Resolution: Single; Solid: Boolean; ObjectID: Integer);
procedure ECAddEllipsoid(var MovePack: TECMovePack; ePos, eRadius: TAffineVector; Solid: Boolean; ObjectID: Integer);

Constants

DCEBox: array [0..35] of TAffineVector = ( (X: 1; Y:-1; Z:-1), (X: 1; Y: 1; Z:-1), (X: 1; Y:-1; Z: 1), (X: 1; Y: 1; Z:-1), (X: 1; Y: 1; Z: 1), (X: 1; Y:-1; Z: 1), (X: 1; Y: 1; Z:-1), (X:-1; Y: 1; Z:-1), (X:-1; Y: 1; Z: 1), (X: 1; Y: 1; Z: 1), (X: 1; Y: 1; Z:-1), (X:-1; Y: 1; Z: 1), (X:-1; Y: 1; Z: 1), (X:-1; Y:-1; Z: 1), (X: 1; Y:-1; Z: 1), (X: 1; Y: 1; Z: 1), (X:-1; Y: 1; Z: 1), (X: 1; Y:-1; Z: 1), (X:-1; Y:-1; Z: 1), (X:-1; Y: 1; Z: 1), (X:-1; Y: 1; Z:-1), (X:-1; Y:-1; Z:-1), (X:-1; Y:-1; Z: 1), (X:-1; Y: 1; Z:-1), (X: 1; Y:-1; Z: 1), (X:-1; Y:-1; Z: 1), (X: 1; Y:-1; Z:-1), (X:-1; Y:-1; Z: 1), (X:-1; Y:-1; Z:-1), (X: 1; Y:-1; Z:-1), (X: 1; Y: 1; Z:-1), (X: 1; Y:-1; Z:-1), (X:-1; Y: 1; Z:-1), (X: 1; Y:-1; Z:-1), (X:-1; Y:-1; Z:-1), (X:-1; Y: 1; Z:-1) );

Description

Functions and Procedures

procedure ECSetCollisionRange(var MovePack: TECMovePack);
procedure ECResetColliders(var MovePack: TECMovePack);
procedure ECAddFreeForm(var MovePack: TECMovePack; FreeForm: TGLBaseSceneObject; Solid: Boolean; ObjectID: Integer);
procedure ECAddBox(var MovePack: TECMovePack; BoxObj: TGLBaseSceneObject; BoxSize: TAffineVector; Solid: Boolean; ObjectID: Integer);
procedure ECAddTerrain(var MovePack: TECMovePack; TerrainRenderer: TGLTerrainRenderer; Resolution: Single; Solid: Boolean; ObjectID: Integer);
procedure ECAddEllipsoid(var MovePack: TECMovePack; ePos, eRadius: TAffineVector; Solid: Boolean; ObjectID: Integer);

Constants

DCEBox: array [0..35] of TAffineVector = ( (X: 1; Y:-1; Z:-1), (X: 1; Y: 1; Z:-1), (X: 1; Y:-1; Z: 1), (X: 1; Y: 1; Z:-1), (X: 1; Y: 1; Z: 1), (X: 1; Y:-1; Z: 1), (X: 1; Y: 1; Z:-1), (X:-1; Y: 1; Z:-1), (X:-1; Y: 1; Z: 1), (X: 1; Y: 1; Z: 1), (X: 1; Y: 1; Z:-1), (X:-1; Y: 1; Z: 1), (X:-1; Y: 1; Z: 1), (X:-1; Y:-1; Z: 1), (X: 1; Y:-1; Z: 1), (X: 1; Y: 1; Z: 1), (X:-1; Y: 1; Z: 1), (X: 1; Y:-1; Z: 1), (X:-1; Y:-1; Z: 1), (X:-1; Y: 1; Z: 1), (X:-1; Y: 1; Z:-1), (X:-1; Y:-1; Z:-1), (X:-1; Y:-1; Z: 1), (X:-1; Y: 1; Z:-1), (X: 1; Y:-1; Z: 1), (X:-1; Y:-1; Z: 1), (X: 1; Y:-1; Z:-1), (X:-1; Y:-1; Z: 1), (X:-1; Y:-1; Z:-1), (X: 1; Y:-1; Z:-1), (X: 1; Y: 1; Z:-1), (X: 1; Y:-1; Z:-1), (X:-1; Y: 1; Z:-1), (X: 1; Y:-1; Z:-1), (X:-1; Y:-1; Z:-1), (X:-1; Y: 1; Z:-1) );
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLDWS2Objects

Unit GLDWS2Objects

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Base classes and logic for DelphiWebScriptII enabled objects in GLScene<p>

<b>History : </b><font size=-1><ul> <li>04/11/2004 - SG - Moved TGLDelphiWebScriptII to GLScriptDWS2 unit. <li>06/04/2004 - SG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLDWS2ActiveBehaviour |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLDWS2Objects: Class TGLDWS2ActiveBehaviour

Class TGLDWS2ActiveBehaviour

Unit

GLDWS2Objects

Declaration

type TGLDWS2ActiveBehaviour = class(TGLBehaviour)

Description

no description available, TGLBehaviour description follows

Ancestor for non-rendering behaviours.<p> This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLObjectEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLDWS2ActiveBehaviour

Overview

Methods

Public | constructor Create(AOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName : String; override;
Public | procedure DoProgress(const ProgressTimes : TProgressTimes); override;
Public | procedure InvalidateScript;
Protected | procedure Loaded; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property Active : Boolean read FActive write SetActive;
Published | property Compiler : TGLDelphiWebScriptII read FCompiler write SetCompiler;
Public | property DWS2Program : TProgram read FDWS2Program;
Published | property Script : TStringList read FScript write SetScript;

Description

Methods

Public constructor Create(AOwner : TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyName : String; override;
Public procedure DoProgress(const ProgressTimes : TProgressTimes); override;
Public procedure InvalidateScript;
Protected procedure Loaded; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Active : Boolean read FActive write SetActive;
Published property Compiler : TGLDelphiWebScriptII read FCompiler write SetCompiler;
Public property DWS2Program : TProgram read FDWS2Program;
Published property Script : TStringList read FScript write SetScript;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLDynamicTexture

Unit GLDynamicTexture

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLDynamicTexture<p>

Adds a dynamic texture image, which allows for easy updating of texture data.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>20/02/10 - DanB - Fix for TGLDynamicTextureImage.GetTexSize <li>23/01/10 - Yar - Replaced TextureFormat to TextureFormatEx simplify GetBitsPerPixel and GetDataFormat <li>22/01/10 - Yar - Added GLTextureFormat to uses <li>08/10/08 - DanB - added FriendlyName/FriendlyDescription <li>16/10/07 - LC - Added DirtyRectangle to allow partial updates. <li>12/07/07 - DaStr - Added $I GLScene.inc <li>25/06/07 - LC - Added SysUtils (needed for AllocMem on D7 and down). <li>25/06/07 - LC - Fixed a bug where resizing a texture would fail. Introduced new methods for freeing PBO and buffer. <li>24/06/07 - LC - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLDynamicTextureImage |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLDynamicTexture: Class TGLDynamicTextureImage

Class TGLDynamicTextureImage

Unit

GLDynamicTexture

Declaration

type TGLDynamicTextureImage = class(TGLBlankImage)

Description

Allows for fast updating of the texture at runtime.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLBlankImage
  • TGLDynamicTextureImage

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Protected | function GetBitsPerPixel: integer;
Protected | function GetDataFormat: integer;
Protected | function GetTexSize: integer;
Protected | function GetTextureFormat: integer;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure FreeBuffer;
Protected | procedure FreePBO;

Properties

Protected | property BitsPerPixel: integer read GetBitsPerPixel;
Public | property Data: pointer read FData;
Protected | property DataFormat: integer read GetDataFormat;
Public | property DirtyRectangle: TGLRect read FDirtyRect write SetDirtyRectangle;
Protected | property TextureFormat: integer read GetTextureFormat;
Public | property UseBGR: boolean read FUseBGR write FUseBGR;
Public | property UsePBO: boolean read FUsePBO write SetUsePBO;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Protected function GetBitsPerPixel: integer;
Protected function GetDataFormat: integer;
Protected function GetTexSize: integer;
Protected function GetTextureFormat: integer;
Public procedure BeginUpdate;

Must be called before using the Data pointer.<p> Rendering context must be active!

Public procedure EndUpdate;

Must be called after data is changed.<p> This will upload the new data.

Public procedure NotifyChange(Sender: TObject); override;
Protected procedure FreeBuffer;
Protected procedure FreePBO;

Properties

Protected property BitsPerPixel: integer read GetBitsPerPixel;
Public property Data: pointer read FData;

Pointer to buffer data.<p> Will be nil outside a BeginUpdate / EndUpdate block.

Protected property DataFormat: integer read GetDataFormat;
Public property DirtyRectangle: TGLRect read FDirtyRect write SetDirtyRectangle;

Marks the dirty rectangle inside the texture.<p> BeginUpdate sets it to ((0, 0), (Width, Height)), ie the entire texture. Override it if you're only changing a small piece of the texture. Note that the Data pointer is relative to the DirtyRectangle, NOT the entire texture.

Protected property TextureFormat: integer read GetTextureFormat;
Public property UseBGR: boolean read FUseBGR write FUseBGR;

Indicates that the data is stored as BGR(A) instead of RGB(A).<p> The default is to use BGR(A).

Public property UsePBO: boolean read FUsePBO write SetUsePBO;

Enables or disables use of a PBO. Default is true.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLEllipseCollision

Unit GLEllipseCollision

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLEllipseCollision<p>

Ellipsoid collision functions (mainly used by DCE).

<b>History : </b><font size=-1><ul> <li>30/03/07 - DaStr - Added $I GLScene.inc <li>09/05/05 - Mathx - Protection agains float error on getLowestRoot <li>23/01/05 - LucasG - Code reorganized, many fixes and some new features <li>03/09/04 - LucasG - First release <li>29/07/04 - LucasG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TECPlane |
record TECObjectInfo |
record TECTriangle |
record TECTriMesh |
record TECFreeForm |
record TECCollider |
record TECContact |
record TECCollisionPacket |
record TECMovePack |

Functions and Procedures

function VectorDivide(const v, divider : TAffineVector): TAffineVector;
procedure CollideAndSlide(var MP: TECMovePack);
procedure CollideWithWorld(var MP: TECMovePack; pos, vel: TAffineVector; var HasCollided: Boolean);

Types

TECTriMeshList = Array of TECTriMesh;
TECFreeFormList = Array of TECFreeForm;
TECColliderShape = (...);
TECColliderList = Array of TECCollider;
TECContactList = Array of TECContact;

Constants

cECCloseDistance : Single = 0.005;

Variables

debug_tri: Array of TECTriangle;

Description

Functions and Procedures

function VectorDivide(const v, divider : TAffineVector): TAffineVector;
procedure CollideAndSlide(var MP: TECMovePack);
procedure CollideWithWorld(var MP: TECMovePack; pos, vel: TAffineVector; var HasCollided: Boolean);

Types

TECTriMeshList = Array of TECTriMesh;
TECFreeFormList = Array of TECFreeForm;
TECColliderShape = (...);
Values
  • csEllipsoid:
  • csPoint:
TECColliderList = Array of TECCollider;
TECContactList = Array of TECContact;

Constants

cECCloseDistance : Single = 0.005;

Variables

debug_tri: Array of TECTriangle;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLEllipseCollision: Class TECPlane

Class TECPlane

Unit

GLEllipseCollision

Declaration

type TECPlane = class(TObject)

Description

Hierarchy

  • TObject
  • TECPlane

Overview

Fields

Public | Equation: array [0..3] of Single;
Public | Origin: TAffineVector;
Public | Normal: TAffineVector;

Methods

Public | function isFrontFacingTo(const Direction: TAffineVector): Boolean;
Public | function signedDistanceTo(const Point: TAffineVector): Single;
Public | procedure MakePlane(const nOrigin, nNormal: TAffineVector); overload;
Public | procedure MakePlane(const p1, p2, p3: TAffineVector); overload;

Description

Fields

Public Equation: array [0..3] of Single;
Public Origin: TAffineVector;
Public Normal: TAffineVector;

Methods

Public function isFrontFacingTo(const Direction: TAffineVector): Boolean;
Public function signedDistanceTo(const Point: TAffineVector): Single;
Public procedure MakePlane(const nOrigin, nNormal: TAffineVector); overload;
Public procedure MakePlane(const p1, p2, p3: TAffineVector); overload;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLEllipseCollision: record TECObjectInfo

record TECObjectInfo

Unit

GLEllipseCollision

Declaration

type TECObjectInfo = record

Description

Overview

Fields

AbsoluteMatrix: TMatrix;
Solid: Boolean;
IsDynamic: Boolean;
ObjectID: Integer;

Description

Fields

AbsoluteMatrix: TMatrix;
Solid: Boolean;
IsDynamic: Boolean;
ObjectID: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLEllipseCollision: record TECTriangle

record TECTriangle

Unit

GLEllipseCollision

Declaration

type TECTriangle = record

Description

Overview

Fields

p1: TAffineVector;
p2: TAffineVector;
p3: TAffineVector;

Description

Fields

p1: TAffineVector;
p2: TAffineVector;
p3: TAffineVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLEllipseCollision: record TECTriMesh

record TECTriMesh

Unit

GLEllipseCollision

Declaration

type TECTriMesh = record

Description

Overview

Fields

Triangles: Array of TECTriangle;
ObjectInfo: TECObjectInfo;

Description

Fields

Triangles: Array of TECTriangle;
ObjectInfo: TECObjectInfo;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLEllipseCollision: record TECFreeForm

record TECFreeForm

Unit

GLEllipseCollision

Declaration

type TECFreeForm = record

Description

Overview

Fields

OctreeNodes: array of POctreeNode;
triangleFiler: ˆTAffineVectorList;
InvertedNormals: Boolean;
ObjectInfo: TECObjectInfo;

Description

Fields

OctreeNodes: array of POctreeNode;
triangleFiler: ˆTAffineVectorList;
InvertedNormals: Boolean;
ObjectInfo: TECObjectInfo;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLEllipseCollision: record TECCollider

record TECCollider

Unit

GLEllipseCollision

Declaration

type TECCollider = record

Description

Overview

Fields

Position: TAffineVector;
Radius: TAffineVector;
Shape: TECColliderShape;
ObjectInfo: TECObjectInfo;

Description

Fields

Position: TAffineVector;
Radius: TAffineVector;
Shape: TECColliderShape;
ObjectInfo: TECObjectInfo;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLEllipseCollision: record TECContact

record TECContact

Unit

GLEllipseCollision

Declaration

type TECContact = record

Description

Overview

Fields

Position: TAffineVector;
SurfaceNormal: TAffineVector;
Distance: Single;
ObjectInfo: TECObjectInfo;

Description

Fields

Position: TAffineVector;
SurfaceNormal: TAffineVector;
Distance: Single;
ObjectInfo: TECObjectInfo;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLEllipseCollision: record TECCollisionPacket

record TECCollisionPacket

Unit

GLEllipseCollision

Declaration

type TECCollisionPacket = record

Description

Overview

Fields

velocity: TAffineVector;
normalizedVelocity: TAffineVector;
basePoint: TAffineVector;
foundCollision: Boolean;
nearestDistance: Single;
NearestObject: Integer;
intersectionPoint: TAffineVector;
intersectionNormal: TAffineVector;

Description

Fields

velocity: TAffineVector;
normalizedVelocity: TAffineVector;
basePoint: TAffineVector;
foundCollision: Boolean;
nearestDistance: Single;
NearestObject: Integer;
intersectionPoint: TAffineVector;
intersectionNormal: TAffineVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLEllipseCollision: record TECMovePack

record TECMovePack

Unit

GLEllipseCollision

Declaration

type TECMovePack = record

Description

Overview

Fields

TriMeshes: TECTriMeshList;
Freeforms: TECFreeFormList;
Colliders: TECColliderList;
Position: TAffineVector;
Velocity: TAffineVector;
Gravity: TAffineVector;
Radius: TAffineVector;
ObjectInfo: TECObjectInfo;
CollisionRange: Single;
UnitScale: Double;
MaxRecursionDepth: Byte;
CP: TECCollisionPacket;
collisionRecursionDepth: Byte;
ResultPos: TAffineVector;
NearestObject: Integer;
VelocityCollided: Boolean;
GravityCollided: Boolean;
GroundNormal: TAffineVector;
Contacts: TECContactList

Description

Fields

TriMeshes: TECTriMeshList;
Freeforms: TECFreeFormList;
Colliders: TECColliderList;
Position: TAffineVector;
Velocity: TAffineVector;
Gravity: TAffineVector;
Radius: TAffineVector;
ObjectInfo: TECObjectInfo;
CollisionRange: Single;
UnitScale: Double;
MaxRecursionDepth: Byte;
CP: TECCollisionPacket;
collisionRecursionDepth: Byte;
ResultPos: TAffineVector;
NearestObject: Integer;
VelocityCollided: Boolean;
GravityCollided: Boolean;
GroundNormal: TAffineVector;
Contacts: TECContactList
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLEParticleMasksManager

Unit GLEParticleMasksManager

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLEParticleMasksManager<p>

A pretty particle mask effect manager.<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>24/03/07 - Improved Cross-Platform compatibility (BugTracker ID = 1684432) Got rid of Types dependancy <li>29/01/07 - DaStr - Initial version (donated to GLScene by Kenneth Poulter)

Original Header:

GLEParticleMasksManager.pas This unit is part of GLE - GLScene Game Utilities Engine set by Kenneth Poulter difacane@telkomsa.net Module Number: 37

Description: This is merely an addon to GLScene, since i don't want to edit GLScene's source code directly and make changes (since GLScene's source code constantly changes). What the manager does is to provide a basic tool for newly created particles to be modified (their position currently). Their position is set from 3 different masks, which create a "virtual" 3d object... meaning, an actual 3d object is not created, but an outline for particles or any other objects are positioned.

ActualUsage: Create the component, create a new ParticleMask, set the material library, set the materials, and use the procedures provided in the managers root. positioning and scaling applicable aswell.

The images should be

Licenses: Removed. Donated to GLScene's Code Base as long as the author (Kenneth Poulter) is not altered in this file. Theft of code also is not allowed, although alterations are allowed.

History: 28/12/2005 - Added - LX,LY,LZ for correct positioning; Rotating; GenerateParticleMaskFromProjection; Targeting Objects (scales, positions and rotation of object applies) 27/12/2005 - Added - Scale and Positioning 27/12/2005 - Improved code speed significantly (could do better) 26/12/2005 - Creation of base code from experimentation

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLEParticleMask |
Class TGLEParticleMasks |
Class TGLEParticleMasksManager |

Types

TGLEProjectedParticleMask = (...);

Description

Types

TGLEProjectedParticleMask = (...);
Values
  • pptXMask:
  • pptYMask:
  • pptZMask:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLEParticleMasksManager: Class TGLEParticleMask

Class TGLEParticleMask

Unit

GLEParticleMasksManager

Declaration

type TGLEParticleMask = class(TCollectionItem, IGLMaterialLibrarySupported)

Description

Hierarchy

  • TCollectionItem
  • TGLEParticleMask

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure GenerateMaskFromProjection(FromMask, ToMask: TGLEProjectedParticleMask; Depth: Integer);
Public | procedure Pitch(Angle: Single);
Public | procedure Roll(Angle: Single);
Public | procedure Turn(Angle: Single);
Public | procedure UpdateExtents;

Properties

Published | property BackgroundColor: TDelphiColor read FBackgroundColor write FBackgroundColor;
Published | property MaskColor: TDelphiColor read FMaskColor write FMaskColor;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property Name: string read FName write SetName;
Published | property PitchAngle: Single read FPitchAngle write FPitchAngle;
Published | property Position: TGLCoordinates read FPosition write FPosition;
Published | property RollAngle: Single read FRollAngle write FRollAngle;
Published | property Scale: TGLCoordinates read FScale write FScale;
Published | property TurnAngle: Single read FTurnAngle write FTurnAngle;
Published | property XMask: TGLLibMaterialName read FXMask write SetXMask;
Published | property YMask: TGLLibMaterialName read FYMask write SetYMask;
Published | property ZMask: TGLLibMaterialName read FZMask write SetZMask;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure GenerateMaskFromProjection(FromMask, ToMask: TGLEProjectedParticleMask; Depth: Integer);
Public procedure Pitch(Angle: Single);
Public procedure Roll(Angle: Single);
Public procedure Turn(Angle: Single);
Public procedure UpdateExtents;

Properties

Published property BackgroundColor: TDelphiColor read FBackgroundColor write FBackgroundColor;
Published property MaskColor: TDelphiColor read FMaskColor write FMaskColor;
Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published property Name: string read FName write SetName;
Published property PitchAngle: Single read FPitchAngle write FPitchAngle;
Published property Position: TGLCoordinates read FPosition write FPosition;
Published property RollAngle: Single read FRollAngle write FRollAngle;
Published property Scale: TGLCoordinates read FScale write FScale;
Published property TurnAngle: Single read FTurnAngle write FTurnAngle;
Published property XMask: TGLLibMaterialName read FXMask write SetXMask;
Published property YMask: TGLLibMaterialName read FYMask write SetYMask;
Published property ZMask: TGLLibMaterialName read FZMask write SetZMask;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLEParticleMasksManager: Class TGLEParticleMasks

Class TGLEParticleMasks

Unit

GLEParticleMasksManager

Declaration

type TGLEParticleMasks = class(TCollection)

Description

Hierarchy

  • TCollection
  • TGLEParticleMasks

Overview

Fields

Protected Owner: TComponent;

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLEParticleMask;
Protected | function GetItems(Index: Integer): TGLEParticleMask;
Protected | function GetOwner: TPersistent; override;
Protected | procedure SetItems(Index: Integer; const Val: TGLEParticleMask);

Properties

Public property Items[Index: Integer]: TGLEParticleMask read GetItems write SetItems;

Description

Fields

Protected Owner: TComponent;

Methods

Public constructor Create(AOwner: TComponent);
Public function Add: TGLEParticleMask;
Protected function GetItems(Index: Integer): TGLEParticleMask;
Protected function GetOwner: TPersistent; override;
Protected procedure SetItems(Index: Integer; const Val: TGLEParticleMask);

Properties

Public property Items[Index: Integer]: TGLEParticleMask read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLEParticleMasksManager: Class TGLEParticleMasksManager

Class TGLEParticleMasksManager

Unit

GLEParticleMasksManager

Declaration

type TGLEParticleMasksManager = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLEParticleMasksManager

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateParticlePositionFromMask(MaskName: string): TVector3f;
Public | function ParticleMaskByName(MaskName: string): TGLEParticleMask;
Public | function TargetParticlePositionFromMask(TargetObject: TGLBaseSceneObject; MaskName: string): TVector3f;
Public | procedure SetParticlePositionFromMask(Particle: TGLParticle; MaskName: string);
Public | procedure SetParticlePositionFromMaskTarget(Particle: TGLParticle; MaskName: string; TargetObject: TGLBaseSceneObject);
Protected | procedure ApplyOrthoGraphic(var Vec: TVector3f; Mask: TGLEParticleMask);
Protected | procedure ApplyRotation(var Vec: TVector3f; Mask: TGLEParticleMask);
Protected | procedure ApplyRotationTarget(var Vec: TVector3f; Mask: TGLEParticleMask; TargetObject: TGLBaseSceneObject);
Protected | procedure ApplyScaleAndPosition(var Vec: TVector3f; Mask: TGLEParticleMask);
Protected | procedure ApplyScaleAndPositionTarget(var Vec: TVector3f; Mask: TGLEParticleMask; TargetObject: TGLBaseSceneObject);
Protected | procedure FindParticlePosition(var Vec: TVector3f; Mask: TGLEParticleMask);

Properties

Published property ParticleMasks: TGLEParticleMasks read FParticleMasks write FParticleMasks;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function CreateParticlePositionFromMask(MaskName: string): TVector3f;
Public function ParticleMaskByName(MaskName: string): TGLEParticleMask;
Public function TargetParticlePositionFromMask(TargetObject: TGLBaseSceneObject; MaskName: string): TVector3f;
Public procedure SetParticlePositionFromMask(Particle: TGLParticle; MaskName: string);
Public procedure SetParticlePositionFromMaskTarget(Particle: TGLParticle; MaskName: string; TargetObject: TGLBaseSceneObject);
Protected procedure ApplyOrthoGraphic(var Vec: TVector3f; Mask: TGLEParticleMask);
Protected procedure ApplyRotation(var Vec: TVector3f; Mask: TGLEParticleMask);
Protected procedure ApplyRotationTarget(var Vec: TVector3f; Mask: TGLEParticleMask; TargetObject: TGLBaseSceneObject);
Protected procedure ApplyScaleAndPosition(var Vec: TVector3f; Mask: TGLEParticleMask);
Protected procedure ApplyScaleAndPositionTarget(var Vec: TVector3f; Mask: TGLEParticleMask; TargetObject: TGLBaseSceneObject);
Protected procedure FindParticlePosition(var Vec: TVector3f; Mask: TGLEParticleMask);

Properties

Published property ParticleMasks: TGLEParticleMasks read FParticleMasks write FParticleMasks;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLExplosionFx

Unit GLExplosionFx

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLExplosionFx<p>

TGLBExplosionFX Effect<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>23/02/07 - DaStr - Fixed TGLBExplosionFx.Create (TGLCoordinatesStyle stuff) <li>23/12/04 - PhP - GLScene Headerized, replaced some VectorXXX functions with XXXVector procedures <li>07/03/04 - Matheus Degiovani - Creation </ul></font>

Description: this effect explodes a mesh object into triangles that fly over. You can define a default direction, in wich case the pieces of the mesh will follow that direction, only rotating, or if you define a null vector as the direction, a vector will be calculated for each triangle, based on the normal vector of that triangle, with a little random addition so things look better. Pretty neat :)<p>

Note: the owner of this behaviour should be any class that derives from TGLBaseMesh class or any other class derived from TGLBaseMesh. Also, the structure of the mesh is lost after the caching of information, so if you'll need the mesh after exploding it, you'll have to save the MeshObjects property of the mesh, OR load it again.

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBExplosionFX |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLExplosionFx: Class TGLBExplosionFX

Class TGLBExplosionFX

Unit

GLExplosionFx

Declaration

type TGLBExplosionFX = class(TGLObjectPreEffect)

Description

no description available, TGLObjectPreEffect description follows

An object effect that gets rendered before owner object's render.<p> The current OpenGL matrices and material are that of the owner object.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLObjectEffect
  • TGLObjectPreEffect
  • TGLBExplosionFX

Overview

Methods

Public | constructor Create(aOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Public | procedure Render(var rci : TRenderContextInfo); override;
Public | procedure Reset;
Protected | procedure CacheInfo;

Properties

Published | property Direction: TGLCoordinates read FDirection write SetDirection;
Protected | property DirList: TAffineVectorList read FDirList write SetDirList;
Public | property Enabled: boolean read FEnabled write SetEnabled;
Protected | property FaceCount: integer read FFAceCount write FFaceCount;
Published | property MaxSteps: integer read FMaxSteps write FMaxSteps;
Protected | property PosList: TAffineVectorList read FPosList write SetPosList;
Protected | property RotList: TAffineVectorList read FRotList write SetRotList;
Published | property Speed: single read FSpeed write FSpeed;
Public | property Step: integer read FStep;
Protected | property TriList: TAffineVectorList read FTriList write SetTriList;

Description

Methods

Public constructor Create(aOwner : TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Public procedure Render(var rci : TRenderContextInfo); override;
Public procedure Reset;
Protected procedure CacheInfo;

Properties

Published property Direction: TGLCoordinates read FDirection write SetDirection;
Protected property DirList: TAffineVectorList read FDirList write SetDirList;
Public property Enabled: boolean read FEnabled write SetEnabled;
Protected property FaceCount: integer read FFAceCount write FFaceCount;
Published property MaxSteps: integer read FMaxSteps write FMaxSteps;
Protected property PosList: TAffineVectorList read FPosList write SetPosList;
Protected property RotList: TAffineVectorList read FRotList write SetRotList;
Published property Speed: single read FSpeed write FSpeed;
Public property Step: integer read FStep;
Protected property TriList: TAffineVectorList read FTriList write SetTriList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLExtrusion

Unit GLExtrusion

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLRevolutionSolid |
Class TGLExtrusionSolid |
Class TGLPipeNode |
Class TGLPipeNodes |
Class TGLPipe |

Types

TExtrusionSolidPart = (...);
TExtrusionSolidParts = set of TExtrusionSolidPart;
TRevolutionSolidPart = (...);
TRevolutionSolidParts = set of TRevolutionSolidPart;
TPipePart = (...);
TPipeParts = set of TPipePart;
TPipeNodesColorMode = (...);
TPipeTexCoordMode = (...);
TPipeNormalMode = (...);

Description

Types

TExtrusionSolidPart = (...);
Values
  • espOutside:
  • espInside:
  • espStartPolygon:
  • espStopPolygon:
TExtrusionSolidParts = set of TExtrusionSolidPart;
TRevolutionSolidPart = (...);
Values
  • rspOutside:
  • rspInside:
  • rspStartPolygon:
  • rspStopPolygon:
TRevolutionSolidParts = set of TRevolutionSolidPart;
TPipePart = (...);
Values
  • ppOutside:
  • ppInside:
  • ppStartDisk:
  • ppStopDisk:
TPipeParts = set of TPipePart;
TPipeNodesColorMode = (...);
Values
  • pncmNone:
  • pncmEmission:
  • pncmAmbient:
  • pncmDiffuse:
  • pncmAmbientAndDiffuse:
TPipeTexCoordMode = (...);
Values
  • ptcmDefault:
  • ptcmManual:
TPipeNormalMode = (...);
Values
  • pnmDefault:
  • pnmAdvanced:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLExtrusion: Class TGLRevolutionSolid

Class TGLRevolutionSolid

Unit

GLExtrusion

Declaration

type TGLRevolutionSolid = class(TGLPolygonBase)

Description

A solid object generated by rotating a curve along the Y axis.<p> The curve is described by the Nodes and SplineMode properties, and it is rotated in the trigonometrical direction (CCW when seen from Y->INF).<p> The TGLRevolutionSolid can also be used to render regular helicoidions, by setting a non-null YOffsetPerTurn, and adjusting start/finish angles to make more than one revolution.<p> If you want top/bottom caps, just add a first/last node that will make the curve start/finish on the Y axis.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPolygonBase
  • TGLRevolutionSolid

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Protected | function StoreStopAngle: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure StructureChanged; override;
Protected | procedure SetNormalDirection(const val: TNormalDirection);
Protected | procedure SetNormals(const val: TNormalSmoothing);
Protected | procedure SetParts(const val: TRevolutionSolidParts);
Protected | procedure SetSlices(const val: Integer);
Protected | procedure SetStartAngle(const val: Single);
Protected | procedure SetStopAngle(const val: Single);
Protected | procedure SetYOffsetPerTurn(const val: Single);

Properties

Published | property NormalDirection: TNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Normals: TNormalSmoothing read FNormals write SetNormals default nsFlat;
Published | property Parts: TRevolutionSolidParts read FParts write SetParts default [rspOutside];
Published | property Slices: Integer read FSlices write SetSlices default 16;
Published | property StartAngle: Single read FStartAngle write SetStartAngle;
Published | property StopAngle: Single read FStopAngle write SetStopAngle stored StoreStopAngle;
Public | property TriangleCount: Integer read FTriangleCount;
Published | property YOffsetPerTurn: Single read FYOffsetPerTurn write SetYOffsetPerTurn;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Protected function StoreStopAngle: Boolean;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure StructureChanged; override;
Protected procedure SetNormalDirection(const val: TNormalDirection);
Protected procedure SetNormals(const val: TNormalSmoothing);
Protected procedure SetParts(const val: TRevolutionSolidParts);
Protected procedure SetSlices(const val: Integer);
Protected procedure SetStartAngle(const val: Single);
Protected procedure SetStopAngle(const val: Single);
Protected procedure SetYOffsetPerTurn(const val: Single);

Properties

Published property NormalDirection: TNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published property Normals: TNormalSmoothing read FNormals write SetNormals default nsFlat;
Published property Parts: TRevolutionSolidParts read FParts write SetParts default [rspOutside];

Parts of the rotation solid to be generated for rendering.<p> rspInside and rspOutside are generated from the curve and make the inside/outside as long as NormalDirection=ndOutside and the solid is described by the curve that goes from top to bottom.<p> Start/StopPolygon are tesselated from the curve (considered as closed).

Published property Slices: Integer read FSlices write SetSlices default 16;

Number of slices per turn (360Щ.

Published property StartAngle: Single read FStartAngle write SetStartAngle;
Published property StopAngle: Single read FStopAngle write SetStopAngle stored StoreStopAngle;
Public property TriangleCount: Integer read FTriangleCount;

Number of triangles used for rendering.

Published property YOffsetPerTurn: Single read FYOffsetPerTurn write SetYOffsetPerTurn;

Y offset applied to the curve position for each turn.<p> This amount is applied proportionnally, for instance if your curve is a small circle, off from the Y axis, with a YOffset set to 0 (zero), you will get a torus, but with a non null value, you will get a small helicoidal spring.<p> This can be useful for rendering, lots of helicoidal objects from screws, to nails to stairs etc.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:17


GLScene v.1.1.2: GLExtrusion: Class TGLExtrusionSolid

Class TGLExtrusionSolid

Unit

GLExtrusion

Declaration

type TGLExtrusionSolid = class(TMultiPolygonBase)

Description

no description available, TMultiPolygonBase description follows

Multipolygon is defined with multiple contours.<p> The contours have to be in the X-Y plane, otherwise they are projected to it (this is done automatically by the tesselator).<br> The plane normal is pointing in +Z. All contours are automatically closed, so there is no need to specify the last node equal to the first one.<br> Contours should be defined counterclockwise, the first contour (index = 0) is taken as is, all following are reversed. This means you can define the outer contour first and the holes and cutouts after that. If you give the following contours in clockwise order, the first contour is extended.<p>

TMultiPolygonBase will take the input contours and let the tesselator make an outline from it (this is done in RetreiveOutline). This outline is used for Rendering. Only when there are changes in the contours, the outline will be recalculated. The ouline in fact is a list of VectorLists.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TMultiPolygonBase
  • TGLExtrusionSolid

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure StructureChanged; override;
Protected | procedure SetNormalDirection(const val: TNormalDirection);
Protected | procedure SetNormals(const val: TNormalSmoothing);
Protected | procedure SetParts(const val: TExtrusionSolidParts);
Protected | procedure SetStacks(const val: Integer);

Properties

Published | property Height: TGLFloat read FHeight write SetHeight;
Published | property MinSmoothAngle: Single read FMinSmoothAngle write SetMinSmoothAngle;
Published | property NormalDirection: TNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Normals: TNormalSmoothing read FNormals write SetNormals default nsFlat;
Published | property Parts: TExtrusionSolidParts read FParts write SetParts default [espOutside];
Published | property Stacks: Integer read FStacks write SetStacks default 1;
Public | property TriangleCount: Integer read FTriangleCount;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure StructureChanged; override;
Protected procedure SetNormalDirection(const val: TNormalDirection);
Protected procedure SetNormals(const val: TNormalSmoothing);
Protected procedure SetParts(const val: TExtrusionSolidParts);
Protected procedure SetStacks(const val: Integer);

Properties

Published property Height: TGLFloat read FHeight write SetHeight;
Published property MinSmoothAngle: Single read FMinSmoothAngle write SetMinSmoothAngle;
Published property NormalDirection: TNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published property Normals: TNormalSmoothing read FNormals write SetNormals default nsFlat;
Published property Parts: TExtrusionSolidParts read FParts write SetParts default [espOutside];
Published property Stacks: Integer read FStacks write SetStacks default 1;
Public property TriangleCount: Integer read FTriangleCount;

Number of triangles used for rendering.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLExtrusion: Class TGLPipeNode

Class TGLPipeNode

Unit

GLExtrusion

Declaration

type TGLPipeNode = class(TGLNode)

Description

no description available, TGLNode description follows

Hierarchy

  • TCollectionItem
  • TGLNode
  • TGLPipeNode

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Protected | function StoreRadiusFactor: Boolean;
Protected | function StoreTexCoordT: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure ColorChanged(sender: TObject);
Protected | procedure SetColor(const val: TGLColor);
Protected | procedure SetRadiusFactor(const val: Single);

Properties

Published | property Color: TGLColor read FColor write SetColor;
Published | property RadiusFactor: Single read FRadiusFactor write SetRadiusFactor stored StoreRadiusFactor;
Published | property TexCoordT: Single read FTexCoordT write FTexCoordT stored StoreTexCoordT;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Protected function StoreRadiusFactor: Boolean;
Protected function StoreTexCoordT: Boolean;
Public procedure Assign(Source: TPersistent); override;
Protected procedure ColorChanged(sender: TObject);
Protected procedure SetColor(const val: TGLColor);
Protected procedure SetRadiusFactor(const val: Single);

Properties

Published property Color: TGLColor read FColor write SetColor;
Published property RadiusFactor: Single read FRadiusFactor write SetRadiusFactor stored StoreRadiusFactor;
Published property TexCoordT: Single read FTexCoordT write FTexCoordT stored StoreTexCoordT;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLExtrusion: Class TGLPipeNodes

Class TGLPipeNodes

Unit

GLExtrusion

Declaration

type TGLPipeNodes = class(TGLLinesNodes)

Description

no description available, TGLLinesNodes description follows
no description available, TGLNodes description follows

Hierarchy

  • TOwnedCollection
  • TGLNodes
  • TGLLinesNodes
  • TGLPipeNodes

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLPipeNode;
Public | function FindItemID(ID: Integer): TGLPipeNode;
Protected | function GetItems(index: Integer): TGLPipeNode;
Protected | procedure SetItems(index: Integer; const val: TGLPipeNode);

Properties

Public property Items[index: Integer]: TGLPipeNode read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);
Public function Add: TGLPipeNode;
Public function FindItemID(ID: Integer): TGLPipeNode;
Protected function GetItems(index: Integer): TGLPipeNode;
Protected procedure SetItems(index: Integer; const val: TGLPipeNode);

Properties

Public property Items[index: Integer]: TGLPipeNode read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLExtrusion: Class TGLPipe

Class TGLPipe

Unit

GLExtrusion

Declaration

type TGLPipe = class(TGLPolygonBase)

Description

A solid object generated by extruding a circle along a trajectory.<p> Texture coordinates NOT supported yet.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPolygonBase
  • TGLPipe

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function StoreRadius: Boolean;
Protected | function StoreTextCoordTileS: Boolean;
Protected | function StoreTextCoordTileT: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure CreateNodes; override;
Protected | procedure SetNodesColorMode(const val: TPipeNodesColorMode);
Protected | procedure SetNormalMode(const val: TPipeNormalMode);
Protected | procedure SetNormalSmoothAngle(const val: Single);
Protected | procedure SetParts(const val: TPipeParts);
Protected | procedure SetRadius(const val: Single);
Protected | procedure SetSlices(const val: Integer);
Protected | procedure SetTextCoordMode(const val: TPipeTexCoordMode);
Protected | procedure SetTextCoordTileS(const val: Single);
Protected | procedure SetTextCoordTileT(const val: Single);

Properties

Published | property NodesColorMode: TPipeNodesColorMode read FNodesColorMode write SetNodesColorMode default pncmNone;
Published | property NormalMode: TPipeNormalMode read FNormalMode write SetNormalMode default pnmDefault;
Published | property NormalSmoothAngle: Single read FNormalSmoothAngle write SetNormalSmoothAngle;
Published | property Parts: TPipeParts read FParts write SetParts default [ppOutside];
Published | property Radius: Single read FRadius write SetRadius;
Published | property Slices: Integer read FSlices write SetSlices default 16;
Published | property TexCoordMode: TPipeTexCoordMode read FTextCoordMode write SetTextCoordMode default ptcmDefault;
Published | property TexCoordTileS: Single read FTextCoordTileS write SetTextCoordTileS stored StoreTextCoordTileS;
Published | property TexCoordTileT: Single read FTextCoordTileT write SetTextCoordTileT stored StoreTextCoordTileT;
Public | property TriangleCount: Integer read FTriangleCount;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function StoreRadius: Boolean;
Protected function StoreTextCoordTileS: Boolean;
Protected function StoreTextCoordTileT: Boolean;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure CreateNodes; override;
Protected procedure SetNodesColorMode(const val: TPipeNodesColorMode);
Protected procedure SetNormalMode(const val: TPipeNormalMode);
Protected procedure SetNormalSmoothAngle(const val: Single);
Protected procedure SetParts(const val: TPipeParts);
Protected procedure SetRadius(const val: Single);
Protected procedure SetSlices(const val: Integer);
Protected procedure SetTextCoordMode(const val: TPipeTexCoordMode);
Protected procedure SetTextCoordTileS(const val: Single);
Protected procedure SetTextCoordTileT(const val: Single);

Properties

Published property NodesColorMode: TPipeNodesColorMode read FNodesColorMode write SetNodesColorMode default pncmNone;
Published property NormalMode: TPipeNormalMode read FNormalMode write SetNormalMode default pnmDefault;
Published property NormalSmoothAngle: Single read FNormalSmoothAngle write SetNormalSmoothAngle;
Published property Parts: TPipeParts read FParts write SetParts default [ppOutside];
Published property Radius: Single read FRadius write SetRadius;
Published property Slices: Integer read FSlices write SetSlices default 16;
Published property TexCoordMode: TPipeTexCoordMode read FTextCoordMode write SetTextCoordMode default ptcmDefault;
Published property TexCoordTileS: Single read FTextCoordTileS write SetTextCoordTileS stored StoreTextCoordTileS;
Published property TexCoordTileT: Single read FTextCoordTileT write SetTextCoordTileT stored StoreTextCoordTileT;
Public property TriangleCount: Integer read FTriangleCount;

Number of triangles used for rendering.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFBO

Unit GLFBO

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFBO<p>

Implements FBO support for GLScene.

Original author of the unit is Riz. Modified by C4 and YarUnderoaker (hope, I didn't miss anybody).

<b>History : </b><font size=-1><ul> <li>16/10/11 - Yar - Fixes for depth-stencil texture <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>16/05/10 - Yar - Added multisampling support (thanks C4) <li>22/04/10 - Yar - Fixes after GLState revision <li>15/04/10 - Yar - Bugfix missing FBO state changing (thanks C4) <li>23/01/10 - Yar - Replaced TextureFormat to TextureFormatEx <li>22/01/10 - Yar - Adapted to Handles of GLContext, texture target unification, level and layer control <li>11/11/09 - DaStr - Added $I GLScene.inc <li>09/11/09 - DaStr - Initial version (contributed to GLScene) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLRenderbuffer |
Class TGLDepthRBO |
Class TGLStencilRBO |
Class TGLFrameBuffer |

Types

TGLStencilPrecision = (...);

Constants

MaxColorAttachments = 32;

Description

Types

TGLStencilPrecision = (...);
Values
  • spDefault:
  • sp1bit:
  • sp4bits:
  • sp8bits:
  • sp16bits:

Constants

MaxColorAttachments = 32;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFBO: Class TGLRenderbuffer

Class TGLRenderbuffer

Unit

GLFBO

Declaration

type TGLRenderbuffer = class(TObject)

Description

Hierarchy

  • TObject
  • TGLRenderbuffer

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Protected | function GetInternalFormat: cardinal; virtual; abstract;
Public | procedure Bind;
Public | procedure Unbind;
Protected | procedure InvalidateStorage;

Properties

Public | property Handle: TGLuint read GetHandle;
Public | property Height: Integer read FHeight write SetHeight;
Public | property Width: Integer read FWidth write SetWidth;

Description

Methods

Public constructor Create;
Public destructor Destroy; override;
Protected function GetInternalFormat: cardinal; virtual; abstract;
Public procedure Bind;
Public procedure Unbind;
Protected procedure InvalidateStorage;

Properties

Public property Handle: TGLuint read GetHandle;

Handle to the OpenGL render buffer object.<p> If the handle hasn't already been allocated, it will be allocated by this call (ie. do not use if no OpenGL context is active!)

Public property Height: Integer read FHeight write SetHeight;
Public property Width: Integer read FWidth write SetWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFBO: Class TGLDepthRBO

Class TGLDepthRBO

Unit

GLFBO

Declaration

type TGLDepthRBO = class(TGLRenderbuffer)

Description

no description available, TGLRenderbuffer description follows

Hierarchy

  • TObject
  • TGLRenderbuffer
  • TGLDepthRBO

Overview

Methods

Public | constructor Create;
Protected | function GetInternalFormat: cardinal; override;

Properties

Public property DepthPrecision: TGLDepthPrecision read FDepthPrecision write SetDepthPrecision;

Description

Methods

Public constructor Create;
Protected function GetInternalFormat: cardinal; override;

Properties

Public property DepthPrecision: TGLDepthPrecision read FDepthPrecision write SetDepthPrecision;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFBO: Class TGLStencilRBO

Class TGLStencilRBO

Unit

GLFBO

Declaration

type TGLStencilRBO = class(TGLRenderbuffer)

Description

no description available, TGLRenderbuffer description follows

Hierarchy

  • TObject
  • TGLRenderbuffer
  • TGLStencilRBO

Overview

Methods

Public | constructor Create;
Protected | function GetInternalFormat: cardinal; override;

Properties

Public property StencilPrecision: TGLStencilPrecision read FStencilPrecision write SetStencilPrecision;

Description

Methods

Public constructor Create;
Protected function GetInternalFormat: cardinal; override;

Properties

Public property StencilPrecision: TGLStencilPrecision read FStencilPrecision write SetStencilPrecision;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFBO: Class TGLFrameBuffer

Class TGLFrameBuffer

Unit

GLFBO

Declaration

type TGLFrameBuffer = class(TObject)

Description

Hierarchy

  • TObject
  • TGLFrameBuffer

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function GetStringStatus(out clarification: string): TGLFramebufferStatus;
Public | procedure AttachDepthBuffer(DepthBuffer: TGLDepthRBO); overload;
Public | procedure AttachDepthTexture(Texture: TGLTexture); overload;
Public | procedure AttachStencilBuffer(StencilBuffer: TGLStencilRBO); overload;
Public | procedure AttachTexture(n: Cardinal; Texture: TGLTexture); overload;
Public | procedure Bind;
Public | procedure DetachDepthBuffer;
Public | procedure DetachDepthTexture;
Public | procedure DetachStencilBuffer;
Public | procedure DetachTexture(n: Cardinal);
Public | procedure PostRender(const PostGenerateMipmap: Boolean);
Public | procedure PreRender;
Public | procedure Render(var rci: TRenderContextInfo; baseObject: TGLBaseSceneObject);
Public | procedure Unbind;
Protected | procedure AttachTexture( const attachment: TGLenum; const textarget: TGLenum; const texture: TGLuint; const level: TGLint; const layer: TGLint); overload;
Protected | procedure ReattachTextures;

Properties

Public | property Handle: TGLFramebufferHandle read FFrameBufferHandle;
Public | property Height: Integer read FHeight write SetHeight;
Public | property Layer: Integer read FLayer write SetLayer;
Public | property Level: Integer read FLevel write SetLevel;
Public | property Status: TGLFramebufferStatus read GetStatus;
Public | property Width: Integer read FWidth write SetWidth;

Description

Methods

Public constructor Create;
Public destructor Destroy; override;
Public function GetStringStatus(out clarification: string): TGLFramebufferStatus;
Public procedure AttachDepthBuffer(DepthBuffer: TGLDepthRBO); overload;
Public procedure AttachDepthTexture(Texture: TGLTexture); overload;
Public procedure AttachStencilBuffer(StencilBuffer: TGLStencilRBO); overload;
Public procedure AttachTexture(n: Cardinal; Texture: TGLTexture); overload;
Public procedure Bind;
Public procedure DetachDepthBuffer;
Public procedure DetachDepthTexture;
Public procedure DetachStencilBuffer;
Public procedure DetachTexture(n: Cardinal);
Public procedure PostRender(const PostGenerateMipmap: Boolean);
Public procedure PreRender;
Public procedure Render(var rci: TRenderContextInfo; baseObject: TGLBaseSceneObject);
Public procedure Unbind;
Protected procedure AttachTexture( const attachment: TGLenum; const textarget: TGLenum; const texture: TGLuint; const level: TGLint; const layer: TGLint); overload;
Protected procedure ReattachTextures;

Properties

Public property Handle: TGLFramebufferHandle read FFrameBufferHandle;
Public property Height: Integer read FHeight write SetHeight;
Public property Layer: Integer read FLayer write SetLayer;
Public property Level: Integer read FLevel write SetLevel;
Public property Status: TGLFramebufferStatus read GetStatus;
Public property Width: Integer read FWidth write SetWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFBORenderer

Unit GLFBORenderer

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLFBORenderer |

Types

TGLEnabledRenderBuffer = (...);
TGLEnabledRenderBuffers = set of TGLEnabledRenderBuffer;
TGLFBOTargetVisibility = (...);
TGLFBOClearOption = (...);
TGLFBOClearOptions = set of TGLFBOClearOption;

Description

Types

TGLEnabledRenderBuffer = (...);
Values
  • erbDepth:
  • erbStencil:
TGLEnabledRenderBuffers = set of TGLEnabledRenderBuffer;
TGLFBOTargetVisibility = (...);
Values
  • tvDefault:
  • tvFBOOnly:
TGLFBOClearOption = (...);
Values
  • coColorBufferClear:
  • coDepthBufferClear:
  • coStencilBufferClear:
  • coUseBufferBackground:
TGLFBOClearOptions = set of TGLFBOClearOption;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFBORenderer: Class TGLFBORenderer

Class TGLFBORenderer

Unit

GLFBORenderer

Declaration

type TGLFBORenderer = class(TGLBaseSceneObject, IGLMaterialLibrarySupported)

Description

no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLFBORenderer

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf: Boolean; ARenderChildren: Boolean); override;
Protected | procedure ApplyCamera(var ARci: TRenderContextInfo);
Protected | procedure DoAfterRender(var ARci: TRenderContextInfo);
Protected | procedure DoBeforeRender(var ARci: TRenderContextInfo);
Protected | procedure DoPostInitialize;
Protected | procedure DoPreInitialize;
Protected | procedure ForceDimensions(Texture: TGLTexture);
Protected | procedure Initialize;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure RenderToFBO(var ARci: TRenderContextInfo);
Protected | procedure UnApplyCamera(var ARci: TRenderContextInfo);

Properties

Published | property Active: Boolean read GetVisible write SetVisible default True;
Published | property AfterRender: TDirectRenderEvent read FAfterRender write FAfterRender;
Published | property Aspect: Single read FAspect write FAspect stored StoreAspect;
Published | property BackgroundColor: TGLColor read FBackgroundColor write SetBackgroundColor;
Published | property BeforeRender: TDirectRenderEvent read FBeforeRender write FBeforeRender;
Published | property Camera: TGLCamera read FCamera write SetCamera;
Published | property ClearOptions: TGLFBOClearOptions read FClearOptions write FClearOptions;
Published | property ColorTextureName: TGLLibMaterialName read FColorTextureName write SetColorTextureName;
Published | property DepthTextureName: TGLLibMaterialName read FDepthTextureName write SetDepthTextureName;
Published | property EnabledRenderBuffers: TGLEnabledRenderBuffers read FEnabledRenderBuffers write SetEnabledRenderBuffers;
Published | property ForceTextureDimensions: Boolean read FForceTextureDimensions write SetForceTextureDimentions default True;
Protected | property HasColor: Boolean read FHasColor;
Protected | property HasDepth: Boolean read FHasDepth;
Protected | property HasStencil: Boolean read FHasStencil;
Published | property Height: Integer read FHeight write SetHeight default 256;
Public | property Layer: Integer read GetLayer write SetLayer;
Public | property Level: Integer read GetLevel write SetLevel;
Published | property MaterialLibrary: TGLAbstractMaterialLibrary read GetMaterialLibrary write SetMaterialLibrary;
Published | property PickableTarget: Boolean read GetPickable write SetPickable default False;
Published | property PostGenerateMipmap: Boolean read FPostGenerateMipmap write SetPostGenerateMipmap default True;
Published | property PostInitialize: TNotifyEvent read FPostInitialize write FPostInitialize;
Published | property PreInitialize: TNotifyEvent read FPreInitialize write FPreInitialize;
Published | property RootObject: TGLBaseSceneObject read FRootObject write SetRootObject;
Published | property SceneScaleFactor: Single read FSceneScaleFactor write FSceneScaleFactor stored StoreSceneScaleFactor;
Published | property StencilPrecision: TGLStencilPrecision read FStencilPrecision write SetStencilPrecision default spDefault;
Published | property TargetVisibility: TGLFBOTargetVisibility read FTargetVisibility write SetTargetVisibility default tvDefault;
Published | property UseLibraryAsMultiTarget: Boolean read FUseLibraryAsMultiTarget write SetUseLibraryAsMultiTarget default False;
Protected | property Viewport: TRectangle read GetViewport;
Published | property Width: Integer read FWidth write SetWidth default 256;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf: Boolean; ARenderChildren: Boolean); override;
Protected procedure ApplyCamera(var ARci: TRenderContextInfo);
Protected procedure DoAfterRender(var ARci: TRenderContextInfo);
Protected procedure DoBeforeRender(var ARci: TRenderContextInfo);
Protected procedure DoPostInitialize;
Protected procedure DoPreInitialize;
Protected procedure ForceDimensions(Texture: TGLTexture);
Protected procedure Initialize;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure RenderToFBO(var ARci: TRenderContextInfo);
Protected procedure UnApplyCamera(var ARci: TRenderContextInfo);

Properties

Published property Active: Boolean read GetVisible write SetVisible default True;
Published property AfterRender: TDirectRenderEvent read FAfterRender write FAfterRender;
Published property Aspect: Single read FAspect write FAspect stored StoreAspect;
Published property BackgroundColor: TGLColor read FBackgroundColor write SetBackgroundColor;
Published property BeforeRender: TDirectRenderEvent read FBeforeRender write FBeforeRender;
Published property Camera: TGLCamera read FCamera write SetCamera;
Published property ClearOptions: TGLFBOClearOptions read FClearOptions write FClearOptions;
Published property ColorTextureName: TGLLibMaterialName read FColorTextureName write SetColorTextureName;
Published property DepthTextureName: TGLLibMaterialName read FDepthTextureName write SetDepthTextureName;
Published property EnabledRenderBuffers: TGLEnabledRenderBuffers read FEnabledRenderBuffers write SetEnabledRenderBuffers;
Published property ForceTextureDimensions: Boolean read FForceTextureDimensions write SetForceTextureDimentions default True;
Protected property HasColor: Boolean read FHasColor;
Protected property HasDepth: Boolean read FHasDepth;
Protected property HasStencil: Boolean read FHasStencil;
Published property Height: Integer read FHeight write SetHeight default 256;
Public property Layer: Integer read GetLayer write SetLayer;
Public property Level: Integer read GetLevel write SetLevel;
Published property MaterialLibrary: TGLAbstractMaterialLibrary read GetMaterialLibrary write SetMaterialLibrary;
Published property PickableTarget: Boolean read GetPickable write SetPickable default False;
Published property PostGenerateMipmap: Boolean read FPostGenerateMipmap write SetPostGenerateMipmap default True;
Published property PostInitialize: TNotifyEvent read FPostInitialize write FPostInitialize;
Published property PreInitialize: TNotifyEvent read FPreInitialize write FPreInitialize;
Published property RootObject: TGLBaseSceneObject read FRootObject write SetRootObject;
Published property SceneScaleFactor: Single read FSceneScaleFactor write FSceneScaleFactor stored StoreSceneScaleFactor;
Published property StencilPrecision: TGLStencilPrecision read FStencilPrecision write SetStencilPrecision default spDefault;
Published property TargetVisibility: TGLFBOTargetVisibility read FTargetVisibility write SetTargetVisibility default tvDefault;
Published property UseLibraryAsMultiTarget: Boolean read FUseLibraryAsMultiTarget write SetUseLibraryAsMultiTarget default False;
Protected property Viewport: TRectangle read GetViewport;
Published property Width: Integer read FWidth write SetWidth default 256;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFeedback

Unit GLFeedback

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFeedback<p>

A scene object encapsulating the OpenGL feedback buffer.<p>

This object, when Active, will render it's children using the GL_FEEDBACK render mode. This will render the children into the feedback Buffer rather than into the frame buffer.<p>

Mesh data can be extracted from the buffer using the BuildMeshFromBuffer procedure. For custom parsing of the buffer use the Buffer SingleList. The Buffered property will indicate if there is valid data in the buffer.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>01/03/11 - Yar - Added Colors list to BuildMeshFromBuffer <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>15/06/10 - Yar - Bugfixed face culling on in feedback mode drawing (thanks Radli) <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>23/07/04 - SG - Creation. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLFeedback |

Types

TFeedbackMode = (...);

Description

Types

TFeedbackMode = (...);
Values
  • fm2D:
  • fm3D:
  • fm3DColor:
  • fm3DColorTexture:
  • fm4DColorTexture:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFeedback: Class TGLFeedback

Class TGLFeedback

Unit

GLFeedback

Declaration

type TGLFeedback = class(TGLBaseSceneObject)

Description

An object encapsulating the OpenGL feedback rendering mode.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLFeedback

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildMeshFromBuffer( Vertices: TAffineVectorList = nil; Normals: TAffineVectorList = nil; Colors: TVectorList = nil; TexCoords: TAffineVectorList = nil; VertexIndices: TIntegerList = nil);
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected | procedure SetMaxBufferSize(const Value: Cardinal);
Protected | procedure SetMode(const Value: TFeedbackMode);

Properties

Published | property Active: Boolean read FActive write FActive;
Public | property Buffer: TSingleList read FBuffer;
Public | property Buffered: Boolean read FBuffered;
Public | property CorrectionScaling: Single read FCorrectionScaling;
Published | property MaxBufferSize: Cardinal read FMaxBufferSize write SetMaxBufferSize;
Published | property Mode: TFeedbackMode read FMode write SetMode;
Published | property Visible;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure BuildMeshFromBuffer( Vertices: TAffineVectorList = nil; Normals: TAffineVectorList = nil; Colors: TVectorList = nil; TexCoords: TAffineVectorList = nil; VertexIndices: TIntegerList = nil);

Parse the the feedback buffer for polygon data and build a mesh into the assigned lists.

Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected procedure SetMaxBufferSize(const Value: Cardinal);
Protected procedure SetMode(const Value: TFeedbackMode);

Properties

Published property Active: Boolean read FActive write FActive;

Toggles the feedback rendering

Public property Buffer: TSingleList read FBuffer;

The feedback buffer

Public property Buffered: Boolean read FBuffered;

True when there is data in the buffer ready for parsing

Public property CorrectionScaling: Single read FCorrectionScaling;

Vertex positions in the buffer needs to be scaled by CorrectionScaling to get correct coordinates.

Published property MaxBufferSize: Cardinal read FMaxBufferSize write SetMaxBufferSize;

Maximum size allocated for the feedback buffer

Published property Mode: TFeedbackMode read FMode write SetMode;

The type of data that is collected in the feedback buffer

Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFile3DS

Unit GLFile3DS

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFile3DS<p>

3DStudio 3DS vector file format implementation.<p>

<b>History :</b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>30/06/11 - DaStr - Properly fixed range check bug <li>15/12/10 - YP - Disable and re-enable range-check only if needed <li>14/12/10 - DaStr - Added a work-around for a range-check bug Bugfixed a case when material texture was turned on when it should not be enabled <li>14/10/10 - YP - Fixed rotate only vertices of TGLFile3DSMeshObject <li>11/10/10 - YP - New vGLFile3DS_LoadedStaticFrame option Fixed ExtractTriangles when vGLFile3DS_LoadedStaticFrame is ON Fixed GetExtents when vGLFile3DS_LoadedStaticFrame is ON <li>07/10/10 - YP - Fixed vGLFile3DS_FixDefaultUpAxisY Fixed first frame index (it's 0 not 1) <li>29/09/10 - YP - Fixed invalid frame limits (SegBegin-SegEnd), wrong SetFrameOffset in Lerp and MorphTo, wrong Frame test in InterpolateValue <li>24/09/10 - YP - Added vGLFile3DS_FixDefaultUpAxisY global option <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>xx/xx/xx - xxx - Fixes for Linux x64 <li>08/11/09 - DaStr - Improved FPC compatibility (thanks Predator) (BugtrackerID = 2893580) <li>07/06/08 - DaStr - Added vGLFile3DS_EnableAnimation option Implemented TGLFile3DSDummyObject.ExtractTriangles() <li>29/04/08 - DaStr - Fixed memory leak in TGLFile3DSCameraObject <li>27/04/08 - DaStr - TGL3DSVectorFile.UseTextureEx converted into a global variable and disabled by default <li>12/04/08 - DaStr - Added TGL3DSVectorFile.UseTextureEx option (Bugtracker ID = 1940451) <li>06/04/08 - DaStr - Added animation support (by Lexer, Luca Burlizzi, Dave Gravel, mif, Oxygen and a bit myself) <li>05/11/07 - DaStr - Fixed transparency issue. <li>31/03/07 - DaStr - Added $I GLScene.inc <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>28/01/07 - DaStr - Added transparency and opacity texture support (thanks DIVON) <li>09/12/04 - LR - Add Integer cast line 94 for Linux <li>25/10/04 - SG - Added lightmap (3DS IllumMap) support <li>05/06/03 - SG - Separated from GLVectorFileObjects.pas </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLFile3DS |
packed record TGLFile3DSAnimationData |
Class TGLFile3DSAnimationKeys |
Class TGLFile3DSScaleAnimationKeys |
Class TGLFile3DSRotationAnimationKeys |
Class TGLFile3DSPositionAnimationKeys |
Class TGLFile3DSColorAnimationKeys |
Class TTGLFile3DSPositionAnimationKeys |
Class TGLFile3DSSpotLightCutOffAnimationKeys |
Class TGLFile3DSLightHotSpotAnimationKeys |
Class TGLFile3DSRollAnimationKeys |
Class TGLFile3DSAnimationKeyList |
Class TGLFile3DSDummyObject |
Class TGLFile3DSMeshObject |
Class TGLFile3DSOmniLightObject |
Class TGLFile3DSSpotLightObject |
Class TGLFile3DSCameraObject |
Class TGL3DSVectorFile |

Types

TGLFile3DSAnimKeysClassType = (...);

Variables

vGLFile3DS_UseTextureEx: boolean = False;
vGLFile3DS_EnableAnimation: boolean = False;
vGLFile3DS_FixDefaultUpAxisY: boolean = False;
vGLFile3DS_LoadedStaticFrame: integer = -1;

Description

Types

TGLFile3DSAnimKeysClassType = (...);

Used only for serialization. There probably is a more efficient way to do it.

Values
  • ctScale:
  • ctRot:
  • ctPos:
  • ctCol:
  • ctTPos:
  • ctFall:
  • ctHot:
  • ctRoll:

Variables

vGLFile3DS_UseTextureEx: boolean = False;

If enabled, advanced parameters will be loaded from a 3ds file (TextureScale, TextureOffset), but it might break backwards compatibility. If disabled, it won't break anything, but some parameters will not be loaded correctly from a 3ds file. Also there is a significant drop in FPS when this option is on (for unknown reasons), so it is off by default.

vGLFile3DS_EnableAnimation: boolean = False;

If enabled, allows 3ds animation and fixes loading of some 3ds models, but has a few bugs: - TGLFreeForm.AutoCentering does now work correctly. - TMeshObject.vertices return values different from TMeshObject.ExtractTriangles()

vGLFile3DS_FixDefaultUpAxisY: boolean = False;

If enabled, a -90 degrees (-PI/2) rotation will occured on X Axis. By design 3dsmax has a Z Up-Axis, after the rotation the Up axis will be Y. (Note: you need vGLFile3DS_EnableAnimation = true)

vGLFile3DS_LoadedStaticFrame: integer = -1;

If >= 0, then the vertices list will be updated with selected frame animation data. (Note: you need vGLFile3DS_EnableAnimation = true). Be aware that in that case animation will not be usable, it is made to be used with a static mesh like GLFreeForm.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFile3DS: Class EGLFile3DS

Class EGLFile3DS

Unit

GLFile3DS

Declaration

type EGLFile3DS = class(Exception)

Description

Hierarchy

  • Exception
  • EGLFile3DS
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFile3DS: packed record TGLFile3DSAnimationData

packed record TGLFile3DSAnimationData

Unit

GLFile3DS

Declaration

type TGLFile3DSAnimationData = packed record

Description

TGLFile3DSAnimationData. A record that holds all the information that is used during 3ds animation.

Overview

Fields

ModelMatrix: TMatrix;
Color: TVector;
TargetPos: TAffineVector;
SpotLightCutOff: single;
HotSpot: single;
Roll: single;

Description

Fields

ModelMatrix: TMatrix;
Color: TVector;
TargetPos: TAffineVector;
SpotLightCutOff: single;
HotSpot: single;
Roll: single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFile3DS: Class TGLFile3DSAnimationKeys

Class TGLFile3DSAnimationKeys

Unit

GLFile3DS

Declaration

type TGLFile3DSAnimationKeys = class(TPersistentObject)

Description

TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLFile3DSAnimationKeys

Overview

Methods

Protected | function InterpolateValue(const AValues: array of TKFRotKey3DS; const AFrame: real): TMatrix; overload;
Protected | function InterpolateValue(const AValues: array of TAffineVector; const AFrame: real): TAffineVector; overload;
Protected | function InterpolateValue(const AValues: array of single; const AFrame: real): single; overload;
Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); virtual; abstract;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); virtual;
Public | procedure ReadFromFiler(Reader: TVirtualReader); override;
Public | procedure WriteToFiler(Writer: TVirtualWriter); override;

Description

Methods

Protected function InterpolateValue(const AValues: array of TKFRotKey3DS; const AFrame: real): TMatrix; overload;
Protected function InterpolateValue(const AValues: array of TAffineVector; const AFrame: real): TAffineVector; overload;
Protected function InterpolateValue(const AValues: array of single; const AFrame: real): single; overload;
Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); virtual; abstract;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); virtual;
Public procedure ReadFromFiler(Reader: TVirtualReader); override;
Public procedure WriteToFiler(Writer: TVirtualWriter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFile3DS: Class TGLFile3DSScaleAnimationKeys

Class TGLFile3DSScaleAnimationKeys

Unit

GLFile3DS

Declaration

type TGLFile3DSScaleAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

no description available, TGLFile3DSAnimationKeys description follows

TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLFile3DSAnimationKeys
  • TGLFile3DSScaleAnimationKeys

Overview

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TVirtualReader); override;
Public | procedure WriteToFiler(Writer: TVirtualWriter); override;

Description

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public procedure ReadFromFiler(Reader: TVirtualReader); override;
Public procedure WriteToFiler(Writer: TVirtualWriter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFile3DS: Class TGLFile3DSRotationAnimationKeys

Class TGLFile3DSRotationAnimationKeys

Unit

GLFile3DS

Declaration

type TGLFile3DSRotationAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

no description available, TGLFile3DSAnimationKeys description follows

TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLFile3DSAnimationKeys
  • TGLFile3DSRotationAnimationKeys

Overview

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TVirtualReader); override;
Public | procedure WriteToFiler(Writer: TVirtualWriter); override;

Description

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public procedure ReadFromFiler(Reader: TVirtualReader); override;
Public procedure WriteToFiler(Writer: TVirtualWriter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFile3DS: Class TGLFile3DSPositionAnimationKeys

Class TGLFile3DSPositionAnimationKeys

Unit

GLFile3DS

Declaration

type TGLFile3DSPositionAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

no description available, TGLFile3DSAnimationKeys description follows

TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLFile3DSAnimationKeys
  • TGLFile3DSPositionAnimationKeys

Overview

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TVirtualReader); override;
Public | procedure WriteToFiler(Writer: TVirtualWriter); override;

Description

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public procedure ReadFromFiler(Reader: TVirtualReader); override;
Public procedure WriteToFiler(Writer: TVirtualWriter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFile3DS: Class TGLFile3DSColorAnimationKeys

Class TGLFile3DSColorAnimationKeys

Unit

GLFile3DS

Declaration

type TGLFile3DSColorAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

no description available, TGLFile3DSAnimationKeys description follows

TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLFile3DSAnimationKeys
  • TGLFile3DSColorAnimationKeys

Overview

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TVirtualReader); override;
Public | procedure WriteToFiler(Writer: TVirtualWriter); override;

Description

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public procedure ReadFromFiler(Reader: TVirtualReader); override;
Public procedure WriteToFiler(Writer: TVirtualWriter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFile3DS: Class TTGLFile3DSPositionAnimationKeys

Class TTGLFile3DSPositionAnimationKeys

Unit

GLFile3DS

Declaration

type TTGLFile3DSPositionAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

no description available, TGLFile3DSAnimationKeys description follows

TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLFile3DSAnimationKeys
  • TTGLFile3DSPositionAnimationKeys

Overview

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TVirtualReader); override;
Public | procedure WriteToFiler(Writer: TVirtualWriter); override;

Description

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public procedure ReadFromFiler(Reader: TVirtualReader); override;
Public procedure WriteToFiler(Writer: TVirtualWriter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFile3DS: Class TGLFile3DSSpotLightCutOffAnimationKeys

Class TGLFile3DSSpotLightCutOffAnimationKeys

Unit

GLFile3DS

Declaration

type TGLFile3DSSpotLightCutOffAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

no description available, TGLFile3DSAnimationKeys description follows

TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLFile3DSAnimationKeys
  • TGLFile3DSSpotLightCutOffAnimationKeys

Overview

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TVirtualReader); override;
Public | procedure WriteToFiler(Writer: TVirtualWriter); override;

Description

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public procedure ReadFromFiler(Reader: TVirtualReader); override;
Public procedure WriteToFiler(Writer: TVirtualWriter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFile3DS: Class TGLFile3DSLightHotSpotAnimationKeys

Class TGLFile3DSLightHotSpotAnimationKeys

Unit

GLFile3DS

Declaration

type TGLFile3DSLightHotSpotAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

no description available, TGLFile3DSAnimationKeys description follows

TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLFile3DSAnimationKeys
  • TGLFile3DSLightHotSpotAnimationKeys

Overview

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TVirtualReader); override;
Public | procedure WriteToFiler(Writer: TVirtualWriter); override;

Description

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public procedure ReadFromFiler(Reader: TVirtualReader); override;
Public procedure WriteToFiler(Writer: TVirtualWriter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFile3DS: Class TGLFile3DSRollAnimationKeys

Class TGLFile3DSRollAnimationKeys

Unit

GLFile3DS

Declaration

type TGLFile3DSRollAnimationKeys = class(TGLFile3DSAnimationKeys)

Description

no description available, TGLFile3DSAnimationKeys description follows

TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLFile3DSAnimationKeys
  • TGLFile3DSRollAnimationKeys

Overview

Methods

Public | procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public | procedure ReadFromFiler(Reader: TVirtualReader); override;
Public | procedure WriteToFiler(Writer: TVirtualWriter); override;

Description

Methods

Public procedure Apply(var DataTransf: TGLFile3DSAnimationData; const AFrame: real); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadData(const ANumKeys: integer; const Keys: PKeyHeaderList; const AData: Pointer); override;
Public procedure ReadFromFiler(Reader: TVirtualReader); override;
Public procedure WriteToFiler(Writer: TVirtualWriter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:18


GLScene v.1.1.2: GLFile3DS: Class TGLFile3DSAnimationKeyList

Class TGLFile3DSAnimationKeyList

Unit

GLFile3DS

Declaration

type TGLFile3DSAnimationKeyList = class(TPersistentObject)

Description

no description available, TPersistentObject description follows

Base class for persistent objects.<p> The base requirement is implementation of ReadFromFiler & WriteToFiler in sub-classes, the immediate benefits are support of streaming (to stream, file or string), assignment and cloning.<br> The other requirement being the use of a virtual constructor, which allows polymorphic construction (don't forget to register your subclasses).<p> Note that TPersistentObject implements IUnknown, but does *not* implement reference counting.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLFile3DSAnimationKeyList

Overview

Methods

Public | destructor Destroy; override;
Public | procedure AddKeys(const AItem: TGLFile3DSAnimationKeys);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ClearKeys;
Public | procedure ReadFromFiler(Reader: TVirtualReader); override;
Public | procedure WriteToFiler(Writer: TVirtualWriter); override;
Protected | procedure ApplyAnimKeys(var DataTransf: TGLFile3DSAnimationData; const AFrame: real);

Description

Methods

Public destructor Destroy; override;
Public procedure AddKeys(const AItem: TGLFile3DSAnimationKeys);
Public procedure Assign(Source: TPersistent); override;
Public procedure ClearKeys;
Public procedure ReadFromFiler(Reader: TVirtualReader); override;
Public procedure WriteToFiler(Writer: TVirtualWriter); override;
Protected procedure ApplyAnimKeys(var DataTransf: TGLFile3DSAnimationData; const AFrame: real);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFile3DS: Class TGLFile3DSDummyObject

Class TGLFile3DSDummyObject

Unit

GLFile3DS

Declaration

type TGLFile3DSDummyObject = class(TMorphableMeshObject)

Description

TGLFile3DSDummyObject. A 3ds-specific TMorphableMeshObject.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseMeshObject
  • TMeshObject
  • TMorphableMeshObject
  • TGLFile3DSDummyObject

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function ExtractTriangles(texCoords: TAffineVectorList = nil; normals: TAffineVectorList = nil): TAffineVectorList; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure GetExtents(out min, max: TAffineVector); override;
Public | procedure Lerp(morphTargetIndex1, morphTargetIndex2: integer; lerpFactor: single); override;
Public | procedure LoadAnimation(const AData: Pointer); virtual;
Public | procedure MorphTo(morphTargetIndex: integer); override;
Public | procedure ReadFromFiler(Reader: TVirtualReader); override;
Public | procedure SetFrame(const AFrame: real); virtual;
Public | procedure WriteToFiler(Writer: TVirtualWriter); override;

Properties

Public | property AnimList: TGLFile3DSAnimationKeyList read FAnimList;
Public | property Parent: TGLFile3DSDummyObject read FParent write FParent;
Public | property RefrenceTransf: TGLFile3DSAnimationData read FRefTranf write FRefTranf;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function ExtractTriangles(texCoords: TAffineVectorList = nil; normals: TAffineVectorList = nil): TAffineVectorList; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure GetExtents(out min, max: TAffineVector); override;
Public procedure Lerp(morphTargetIndex1, morphTargetIndex2: integer; lerpFactor: single); override;
Public procedure LoadAnimation(const AData: Pointer); virtual;
Public procedure MorphTo(morphTargetIndex: integer); override;
Public procedure ReadFromFiler(Reader: TVirtualReader); override;
Public procedure SetFrame(const AFrame: real); virtual;
Public procedure WriteToFiler(Writer: TVirtualWriter); override;

Properties

Public property AnimList: TGLFile3DSAnimationKeyList read FAnimList;
Public property Parent: TGLFile3DSDummyObject read FParent write FParent;
Public property RefrenceTransf: TGLFile3DSAnimationData read FRefTranf write FRefTranf;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFile3DS: Class TGLFile3DSMeshObject

Class TGLFile3DSMeshObject

Unit

GLFile3DS

Declaration

type TGLFile3DSMeshObject = class(TGLFile3DSDummyObject)

Description

TGLFile3DSDummyObject. A 3ds-specific mesh object.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseMeshObject
  • TMeshObject
  • TMorphableMeshObject
  • TGLFile3DSDummyObject
  • TGLFile3DSMeshObject

Overview

Methods

Public | procedure BuildList(var ARci: TRenderContextInfo); override;
Public | procedure LoadAnimation(const AData: Pointer); override;

Description

Methods

Public procedure BuildList(var ARci: TRenderContextInfo); override;
Public procedure LoadAnimation(const AData: Pointer); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFile3DS: Class TGLFile3DSOmniLightObject

Class TGLFile3DSOmniLightObject

Unit

GLFile3DS

Declaration

type TGLFile3DSOmniLightObject = class(TGLFile3DSDummyObject)

Description

TGLFile3DSDummyObject. A 3ds-specific omni light.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseMeshObject
  • TMeshObject
  • TMorphableMeshObject
  • TGLFile3DSDummyObject
  • TGLFile3DSOmniLightObject

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadAnimation(const AData: Pointer); override;
Public | procedure LoadData(const AOwner: TGLBaseMesh; const AData: PLight3DS); virtual;
Public | procedure ReadFromFiler(Reader: TVirtualReader); override;
Public | procedure SetFrame(const AFrame: real); override;
Public | procedure WriteToFiler(Writer: TVirtualWriter); override;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadAnimation(const AData: Pointer); override;
Public procedure LoadData(const AOwner: TGLBaseMesh; const AData: PLight3DS); virtual;
Public procedure ReadFromFiler(Reader: TVirtualReader); override;
Public procedure SetFrame(const AFrame: real); override;
Public procedure WriteToFiler(Writer: TVirtualWriter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFile3DS: Class TGLFile3DSSpotLightObject

Class TGLFile3DSSpotLightObject

Unit

GLFile3DS

Declaration

type TGLFile3DSSpotLightObject = class(TGLFile3DSOmniLightObject)

Description

TGLFile3DSSpotLightObject. A 3ds-specific spot light.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseMeshObject
  • TMeshObject
  • TMorphableMeshObject
  • TGLFile3DSDummyObject
  • TGLFile3DSOmniLightObject
  • TGLFile3DSSpotLightObject

Overview

Methods

Public | procedure LoadAnimation(const AData: Pointer); override;
Public | procedure LoadData(const AOwner: TGLBaseMesh; const AData: PLight3DS); override;
Public | procedure SetFrame(const AFrame: real); override;

Description

Methods

Public procedure LoadAnimation(const AData: Pointer); override;
Public procedure LoadData(const AOwner: TGLBaseMesh; const AData: PLight3DS); override;
Public procedure SetFrame(const AFrame: real); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFile3DS: Class TGLFile3DSCameraObject

Class TGLFile3DSCameraObject

Unit

GLFile3DS

Declaration

type TGLFile3DSCameraObject = class(TGLFile3DSDummyObject)

Description

TGLFile3DSCameraObject. A 3ds-specific camera.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseMeshObject
  • TMeshObject
  • TMorphableMeshObject
  • TGLFile3DSDummyObject
  • TGLFile3DSCameraObject

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure LoadAnimation(const AData: Pointer); override;
Public | procedure LoadData(Owner: TGLBaseMesh; AData: PCamera3DS);
Public | procedure ReadFromFiler(Reader: TVirtualReader); override;
Public | procedure SetFrame(const AFrame: real); override;
Public | procedure WriteToFiler(Writer: TVirtualWriter); override;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public procedure LoadAnimation(const AData: Pointer); override;
Public procedure LoadData(Owner: TGLBaseMesh; AData: PCamera3DS);
Public procedure ReadFromFiler(Reader: TVirtualReader); override;
Public procedure SetFrame(const AFrame: real); override;
Public procedure WriteToFiler(Writer: TVirtualWriter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFile3DS: Class TGL3DSVectorFile

Class TGL3DSVectorFile

Unit

GLFile3DS

Declaration

type TGL3DSVectorFile = class(TVectorFile)

Description

The 3DStudio vector file.<p> Uses an upgraded version if a 3DS import library by Mike Lischke.<p> (http://www.lishcke-online.de). A 3DS file may contain material information and require textures when loading.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGL3DSVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFile3DSSceneObjects

Unit GLFile3DSSceneObjects

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFile3DSSceneObjects<p>

3ds-specific scene objects.<p>

<b>History :</b><font size=-1><ul> <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>17/05/08 - DaStr - Added vGLFile3DSSceneObjects_RenderCameraAndLights <li>06/04/08 - DaStr - Initial version (by Lexer) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLFile3DSLight |
Class TGLFile3DSCamera |
Class TGLFile3DSActor |
Class TGLFile3DSFreeForm |

Variables

vGLFile3DSSceneObjects_RenderCameraAndLights: Boolean = False;

Description

Variables

vGLFile3DSSceneObjects_RenderCameraAndLights: Boolean = False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFile3DSSceneObjects: Class TGLFile3DSLight

Class TGLFile3DSLight

Unit

GLFile3DSSceneObjects

Declaration

type TGLFile3DSLight = class(TGLLightSource)

Description

no description available, TGLLightSource description follows

Standard light source.<p> The standard GLScene light source covers spotlights, omnidirectionnal and parallel sources (see TLightStyle).<br> Lights are colored, have distance attenuation parameters and are turned on/off through their Shining property.<p> Lightsources are managed in a specific object by the TGLScene for rendering purposes. The maximum number of light source in a scene is limited by the OpenGL implementation (8 lights are supported under most ICDs), though the more light you use, the slower rendering may get. If you want to render many more light/lightsource, you may have to resort to other techniques like lightmapping.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLLightSource
  • TGLFile3DSLight

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;
Public | procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property HotSpot: Single read FHotSpot write FHotSpot;
Published | property Multipler: Single read FMultipler write FMultipler;
Published | property SpotTargetPos: TGLCoordinates read FTargetPos;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;
Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published property HotSpot: Single read FHotSpot write FHotSpot;
Published property Multipler: Single read FMultipler write FMultipler;
Published property SpotTargetPos: TGLCoordinates read FTargetPos;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFile3DSSceneObjects: Class TGLFile3DSCamera

Class TGLFile3DSCamera

Unit

GLFile3DSSceneObjects

Declaration

type TGLFile3DSCamera = class(TGLCamera)

Description

no description available, TGLCamera description follows

Camera object.<p> This object is commonly referred by TGLSceneViewer and defines a position, direction, focal length, depth of view... all the properties needed for defining a point of view and optical characteristics.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCamera
  • TGLFile3DSCamera

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;
Public | procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property CameraTargetPos: TGLCoordinates read FTargetPos;
Published | property RollAngle;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;
Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published property CameraTargetPos: TGLCoordinates read FTargetPos;
Published property RollAngle;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFile3DSSceneObjects: Class TGLFile3DSActor

Class TGLFile3DSActor

Unit

GLFile3DSSceneObjects

Declaration

type TGLFile3DSActor = class(TGLActor)

Description

no description available, TGLActor description follows

Mesh class specialized in animated meshes.<p> The TGLActor provides a quick interface to animated meshes based on morph or skeleton frames, it is capable of performing frame interpolation and animation blending (via TGLAnimationControler components).

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLActor
  • TGLFile3DSActor

Overview

Methods

Protected procedure DefineProperties(Filer: TFiler); override;

Description

Methods

Protected procedure DefineProperties(Filer: TFiler); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFile3DSSceneObjects: Class TGLFile3DSFreeForm

Class TGLFile3DSFreeForm

Unit

GLFile3DSSceneObjects

Declaration

type TGLFile3DSFreeForm = class(TGLFreeForm)

Description

no description available, TGLFreeForm description follows

Container objects for a vector file mesh.<p> FreeForms allows loading and rendering vector files (like 3DStudio ".3DS" file) in GLScene. Meshes can be loaded with the LoadFromFile method.<p> A FreeForm may contain more than one mesh, but they will all be handled as a single object in a scene.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLFreeForm
  • TGLFile3DSFreeForm

Overview

Fields

Public FRefMat: TMatrix;

Methods

Public | constructor Create(AOWner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function BarycenterAbsolutePosition: TVector; override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;
Protected | procedure DefineProperties(Filer: TFiler); override;

Properties

Published | property Rot3DS: TGLCoordinates4 read FRot3DS;
Published | property Scale3DS: TGLCoordinates4 read FScale3DS;
Published | property S_Rot3DS: TGLCoordinates4 read FS_Rot3DS;

Description

Fields

Public FRefMat: TMatrix;

Methods

Public constructor Create(AOWner: TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function BarycenterAbsolutePosition: TVector; override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;
Protected procedure DefineProperties(Filer: TFiler); override;

Properties

Published property Rot3DS: TGLCoordinates4 read FRot3DS;
Published property Scale3DS: TGLCoordinates4 read FScale3DS;
Published property S_Rot3DS: TGLCoordinates4 read FS_Rot3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileASE

Unit GLFileASE

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileASE<p>

ASE (ASCI Scene Export) file format support for GLScene<p>

<b>History :</b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to arrays of records <li>21/06/08 - DaStr - Bugfixed GetFaceGroup() (Thanks Beon) <li>29/05/08 - DaStr - Made compatible with Delphi 5 <li>27/12/07 - DaStr - Added skipping unknown file sections Improved ASE material objects structure: Material can keep up to 12 texture maps SubMaterial can keep up to 12 texture maps Added ability to select texture, lightmap ASE material/submaterial maps Bugfixed parsing failures on unknown section found (all above changes were made by MaX) <li>19/05/07 - DaStr - Initial version (contributed by MaX)

Parser supported features list: blablabla :)

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TGLASEFaceTexure |
record TGLASEFaceTexureChannels |
record TGLASESmoothingGroups |
Class TGLASEFace |
Class TGLASEFaceList |
Class TGLASEMeshObject |
record TGLASEMaterialTextureMap |
record TGLASEMaterialTextureMaps |
record TGLASESubMaterial |
record TGLASESubMaterialList |
Class TGLASEMaterial |
Class TGLASEMaterialList |
Class TGLASEVectorFile |

Functions and Procedures

procedure ASESetPreferredTexture(aMap: TASETextureMap; aSubMaterialIndex: Integer = -1);
procedure ASESetPreferredLightmap(aMap: TASETextureMap; aSubMaterialIndex: Integer = -1);

Types

TASETextureMap = (...);

Constants

GL_ASE_MAX_TEXURE_CHANNELS = 12;
GL_ASE_MAX_SUBMATERIALS = 5;
GL_ASE_MAX_SMOOTH_GROUPS = 5;
GL_ASE_MAX_TEXTURE_MAPS = 12;

Description

Functions and Procedures

procedure ASESetPreferredTexture(aMap: TASETextureMap; aSubMaterialIndex: Integer = -1);
procedure ASESetPreferredLightmap(aMap: TASETextureMap; aSubMaterialIndex: Integer = -1);

Types

TASETextureMap = (...);
Values
  • tmGeneric:
  • tmAmbient:
  • tmDiffuse:
  • tmSpecular:
  • tmShine:
  • tmShinestrength:
  • tmSelfillum:
  • tmOpacity:
  • tmFiltercolor:
  • tmBump:
  • tmReflect:
  • tmRefract:

Constants

GL_ASE_MAX_TEXURE_CHANNELS = 12;
GL_ASE_MAX_SUBMATERIALS = 5;
GL_ASE_MAX_SMOOTH_GROUPS = 5;
GL_ASE_MAX_TEXTURE_MAPS = 12;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileASE: record TGLASEFaceTexure

record TGLASEFaceTexure

Unit

GLFileASE

Declaration

type TGLASEFaceTexure = record

Description

Overview

Fields

Idx0: Integer;
Idx1: Integer;
Idx2: Integer;

Description

Fields

Idx0: Integer;
Idx1: Integer;
Idx2: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileASE: record TGLASEFaceTexureChannels

record TGLASEFaceTexureChannels

Unit

GLFileASE

Declaration

type TGLASEFaceTexureChannels = record

Description

Overview

Fields

Count: Integer;
ChanelTexture: array [0..GL_ASE_MAX_TEXURE_CHANNELS - 1] of TGLASEFaceTexure;

Description

Fields

Count: Integer;
ChanelTexture: array [0..GL_ASE_MAX_TEXURE_CHANNELS - 1] of TGLASEFaceTexure;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileASE: record TGLASESmoothingGroups

record TGLASESmoothingGroups

Unit

GLFileASE

Declaration

type TGLASESmoothingGroups = record

Description

Overview

Fields

Count: Integer;
Groups: array [0..GL_ASE_MAX_SMOOTH_GROUPS] of Integer;

Description

Fields

Count: Integer;
Groups: array [0..GL_ASE_MAX_SMOOTH_GROUPS] of Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileASE: Class TGLASEFace

Class TGLASEFace

Unit

GLFileASE

Declaration

type TGLASEFace = class(TObject)

Description

Hierarchy

  • TObject
  • TGLASEFace

Overview

Methods

Public constructor Create;

Properties

Public | property Normal: TAffineVector read FNormal;
Public | property Normal1: TAffineVector read FN[0];
Public | property Normal2: TAffineVector read FN[1];
Public | property Normal3: TAffineVector read FN[2];
Public | property Smoothing: TGLASESmoothingGroups read FSmoothing;
Public | property SubMaterialID: Integer read FSubMaterialID;
Public | property TextChannels: TGLASEFaceTexureChannels read FTextChannels;
Public | property VertIdx1: Integer read FV[0];
Public | property VertIdx2: Integer read FV[1];
Public | property VertIdx3: Integer read FV[2];

Description

Methods

Public constructor Create;

Properties

Public property Normal: TAffineVector read FNormal;
Public property Normal1: TAffineVector read FN[0];
Public property Normal2: TAffineVector read FN[1];
Public property Normal3: TAffineVector read FN[2];
Public property Smoothing: TGLASESmoothingGroups read FSmoothing;
Public property SubMaterialID: Integer read FSubMaterialID;
Public property TextChannels: TGLASEFaceTexureChannels read FTextChannels;
Public property VertIdx1: Integer read FV[0];
Public property VertIdx2: Integer read FV[1];
Public property VertIdx3: Integer read FV[2];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileASE: Class TGLASEFaceList

Class TGLASEFaceList

Unit

GLFileASE

Declaration

type TGLASEFaceList = class(TObject)

Description

Hierarchy

  • TObject
  • TGLASEFaceList

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function Add: TGLASEFace;
Public | procedure Clear;
Public | procedure Delete(aIndex: Integer);

Properties

Public | property Count: Integer read GetCount;
Public | property Face[Index: Integer]: TGLASEFace read GetFace;

Description

Methods

Public constructor Create;
Public destructor Destroy; override;
Public function Add: TGLASEFace;
Public procedure Clear;
Public procedure Delete(aIndex: Integer);

Properties

Public property Count: Integer read GetCount;
Public property Face[Index: Integer]: TGLASEFace read GetFace;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileASE: Class TGLASEMeshObject

Class TGLASEMeshObject

Unit

GLFileASE

Declaration

type TGLASEMeshObject = class(TObject)

Description

Hierarchy

  • TObject
  • TGLASEMeshObject

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Properties

Public | property Faces: TGLASEFaceList read FFaces;
Public | property HasNormals: Boolean read FHasNormals;
Public | property InheritedPosition: TAffineVector read FInheritedPosition;
Public | property InheritedRotation: TAffineVector read FInheritedRotation;
Public | property InheritedScale: TAffineVector read FInheritedScale;
Public | property MaterialID: Integer read FMaterialID;
Public | property Matrix: TMatrix read FMatrix;
Public | property Position: TVector read FPosition;
Public | property RotationAngle: Single read FRotationAngle;
Public | property RotationAxis: TAffineVector read FRotationAxis;
Public | property Scale: TAffineVector read FScale;
Public | property ScaleAxis: TAffineVector read FScaleAxis;
Public | property ScaleAxisAngle: Single read FScaleAxisAngle;
Public | property TextChannel[Channel: Integer]: TAffineVectorList read GetTextChannel;
Public | property TextChannelsCount: Integer read FTexChannelsCount;
Public | property Vertices: TAffineVectorList read FVertices;

Description

Methods

Public constructor Create;
Public destructor Destroy; override;

Properties

Public property Faces: TGLASEFaceList read FFaces;
Public property HasNormals: Boolean read FHasNormals;
Public property InheritedPosition: TAffineVector read FInheritedPosition;
Public property InheritedRotation: TAffineVector read FInheritedRotation;
Public property InheritedScale: TAffineVector read FInheritedScale;
Public property MaterialID: Integer read FMaterialID;
Public property Matrix: TMatrix read FMatrix;
Public property Position: TVector read FPosition;
Public property RotationAngle: Single read FRotationAngle;
Public property RotationAxis: TAffineVector read FRotationAxis;
Public property Scale: TAffineVector read FScale;
Public property ScaleAxis: TAffineVector read FScaleAxis;
Public property ScaleAxisAngle: Single read FScaleAxisAngle;
Public property TextChannel[Channel: Integer]: TAffineVectorList read GetTextChannel;
Public property TextChannelsCount: Integer read FTexChannelsCount;
Public property Vertices: TAffineVectorList read FVertices;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileASE: record TGLASEMaterialTextureMap

record TGLASEMaterialTextureMap

Unit

GLFileASE

Declaration

type TGLASEMaterialTextureMap = record

Description

Overview

Fields

Kind: string;
Name: string;
_Class: string;
No: Integer;
Amount: Single;
Bitmap: string;
UOffset: Single;
VOffset: Single;
UTiling: Single;
VTiling: Single;
Angle: Single;
Blur: Single;
BlurOffset: Single;
NouseAmount: Single;
NoiseSize: Single;
NoiseLevel: Integer;
NoisePhase: Single;

Description

Fields

Kind: string;
Name: string;
_Class: string;
No: Integer;
Amount: Single;
Bitmap: string;
UOffset: Single;
VOffset: Single;
UTiling: Single;
VTiling: Single;
Angle: Single;
Blur: Single;
BlurOffset: Single;
NouseAmount: Single;
NoiseSize: Single;
NoiseLevel: Integer;
NoisePhase: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileASE: record TGLASEMaterialTextureMaps

record TGLASEMaterialTextureMaps

Unit

GLFileASE

Declaration

type TGLASEMaterialTextureMaps = record

Description

Overview

Fields

Map: array [0..GL_ASE_MAX_TEXTURE_MAPS - 1] of TGLASEMaterialTextureMap;
Count: Integer;

Description

Fields

Map: array [0..GL_ASE_MAX_TEXTURE_MAPS - 1] of TGLASEMaterialTextureMap;
Count: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileASE: record TGLASESubMaterial

record TGLASESubMaterial

Unit

GLFileASE

Declaration

type TGLASESubMaterial = record

Description

Overview

Fields

Name: string;
Ambient: TAffineVector;
Diffuse: TAffineVector;
Specular: TAffineVector;
Shiness: Single;
ShineStrength: Single;
Transparency: Single;
WireSize: Single;
SelfIllumination: Single;
TextureMaps: TGLASEMaterialTextureMaps;

Description

Fields

Name: string;
Ambient: TAffineVector;
Diffuse: TAffineVector;
Specular: TAffineVector;
Shiness: Single;
ShineStrength: Single;
Transparency: Single;
WireSize: Single;
SelfIllumination: Single;
TextureMaps: TGLASEMaterialTextureMaps;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileASE: record TGLASESubMaterialList

record TGLASESubMaterialList

Unit

GLFileASE

Declaration

type TGLASESubMaterialList = record

Description

Overview

Fields

SubMaterial: array [0..GL_ASE_MAX_SUBMATERIALS - 1] of TGLASESubMaterial;
Count: Integer;

Description

Fields

SubMaterial: array [0..GL_ASE_MAX_SUBMATERIALS - 1] of TGLASESubMaterial;
Count: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileASE: Class TGLASEMaterial

Class TGLASEMaterial

Unit

GLFileASE

Declaration

type TGLASEMaterial = class(TObject)

Description

Hierarchy

  • TObject
  • TGLASEMaterial

Overview

Methods

Public constructor Create;

Properties

Public | property Ambient: TAffineVector read FAmbient;
Public | property Diffuse: TAffineVector read FDiffuse;
Public | property Name: string read FName;
Public | property Shiness: Single read FShiness;
Public | property ShineStrength: Single read FShineStrength;
Public | property Specular: TAffineVector read FSpecular;
Public | property SubMaterials: TGLASESubMaterialList read FSubMaterials;
Public | property TextureMaps: TGLASEMaterialTextureMaps read FTextureMaps;
Public | property Transparency: Single read FTransparency;
Public | property WireSize: Single read FWireSize;

Description

Methods

Public constructor Create;

Properties

Public property Ambient: TAffineVector read FAmbient;
Public property Diffuse: TAffineVector read FDiffuse;
Public property Name: string read FName;
Public property Shiness: Single read FShiness;
Public property ShineStrength: Single read FShineStrength;
Public property Specular: TAffineVector read FSpecular;
Public property SubMaterials: TGLASESubMaterialList read FSubMaterials;
Public property TextureMaps: TGLASEMaterialTextureMaps read FTextureMaps;
Public property Transparency: Single read FTransparency;
Public property WireSize: Single read FWireSize;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileASE: Class TGLASEMaterialList

Class TGLASEMaterialList

Unit

GLFileASE

Declaration

type TGLASEMaterialList = class(TObject)

Description

Hierarchy

  • TObject
  • TGLASEMaterialList

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function Add: TGLASEMaterial;
Public | procedure Clear;
Public | procedure Delete(aIndex: Integer);

Properties

Public | property Count: Integer read GetCount;
Public | property Material[Index: Integer]: TGLASEMaterial read GetMaterial;

Description

Methods

Public constructor Create;
Public destructor Destroy; override;
Public function Add: TGLASEMaterial;
Public procedure Clear;
Public procedure Delete(aIndex: Integer);

Properties

Public property Count: Integer read GetCount;
Public property Material[Index: Integer]: TGLASEMaterial read GetMaterial;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileASE: Class TGLASEVectorFile

Class TGLASEVectorFile

Unit

GLFileASE

Declaration

type TGLASEVectorFile = class(TVectorFile)

Description

no description available, TVectorFile description follows

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLASEVectorFile

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Properties

Public | property CastShadow: Boolean read FCastShadow;
Public | property Comment: string read FComment;
Public | property Header: string read FHeader;
Public | property MotionBlur: Boolean read FMotionBlur;
Public | property RECVShadow: Boolean read FRECVShadow;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public class function Capabilities: TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream: TStream); override;

Properties

Public property CastShadow: Boolean read FCastShadow;
Public property Comment: string read FComment;
Public property Header: string read FHeader;
Public property MotionBlur: Boolean read FMotionBlur;
Public property RECVShadow: Boolean read FRECVShadow;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileB3D

Unit GLFileB3D

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLB3DVectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileB3D: Class TGLB3DVectorFile

Class TGLB3DVectorFile

Unit

GLFileB3D

Declaration

type TGLB3DVectorFile = class(TVectorFile)

Description

no description available, TVectorFile description follows

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLB3DVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(AStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure LoadFromStream(AStream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileBMP

Unit GLFileBMP

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileBMP<p>

Graphic engine friendly loading of BMP image.

<b>History : </b><font size=-1><ul> <li>04/04/11 - Yar - Creation </ul><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBMPImage |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileBMP: Class TGLBMPImage

Class TGLBMPImage

Unit

GLFileBMP

Declaration

type TGLBMPImage = class(TGLBaseImage)

Description

no description available, TGLBaseImage description follows
no description available, TDataFile description follows

Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TGLBaseImage
  • TGLBMPImage

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLuint; textureTarget: TGLTextureTarget; const CurrentFormat: boolean; const intFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLuint; textureTarget: TGLTextureTarget; const CurrentFormat: boolean; const intFormat: TGLInternalFormat); reintroduce;
Public procedure LoadFromFile(const filename: string); override;
Public procedure LoadFromStream(stream: TStream); override;
Public procedure SaveToFile(const filename: string); override;
Public procedure SaveToStream(stream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileDDS

Unit GLFileDDS

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileDDS<p>

DDS File support for GLScene.

<b>History : </b><font size=-1><ul> <li>04/11/10 - DaStr - Added Delphi5 and Delphi6 compatibility <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>06/06/10 - Yar - Fixes for Linux x64 <li>08/05/10 - Yar - Removed check for residency in AssignFromTexture <li>22/04/10 - Yar - Fixes after GLState revision <li>01/03/10 - Yar - Added control of texture detail level <li>27/01/10 - Yar - Bugfix in BlockOffset with negative result <li>23/11/10 - DaStr - Added $I GLScene.inc <li>23/01/10 - Yar - Added to AssignFromTexture CurrentFormat parameter Fixed cube map saving bug <li>20/01/10 - Yar - Creation </ul><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLDDSImage |

Types

TGLDDSDetailLevels = (...);

Variables

vDDSDetailLevel: TGLDDSDetailLevels = ddsHighDet;

Description

Types

TGLDDSDetailLevels = (...);
Values
  • ddsHighDet:
  • ddsMediumDet:
  • ddsLowDet:

Variables

vDDSDetailLevel: TGLDDSDetailLevels = ddsHighDet;

Variable determines which resolution to use textures, high - it loads all levels, midle - skipped the first level, low - skipped the first two levels.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileDDS: Class TGLDDSImage

Class TGLDDSImage

Unit

GLFileDDS

Declaration

type TGLDDSImage = class(TGLBaseImage)

Description

no description available, TGLBaseImage description follows
no description available, TDataFile description follows

Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TGLBaseImage
  • TGLDDSImage

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLuint; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLuint; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;

Assigns from any Texture.

Public procedure LoadFromFile(const filename: string); override;
Public procedure LoadFromStream(stream: TStream); override;
Public procedure SaveToFile(const filename: string); override;
Public procedure SaveToStream(stream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileGL2

Unit GLFileGL2

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileGL2<p>

Vector file object loading of Ghoul2 model and animation files into GLScene.<p>

<b>History :</b><font size=-1><ul> <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>22/10/03 - SG - Animation fixes, removed skeletal reconstruction <li>25/03/03 - SG - Creation. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLGLMVectorFile |
Class TGLGLAVectorFile |

Variables

vGhoul2LevelOfDetail: Integer = 0;
vGhoul2MaxBonesPerVertex: Integer = 4;

Description

Variables

vGhoul2LevelOfDetail: Integer = 0;
vGhoul2MaxBonesPerVertex: Integer = 4;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileGL2: Class TGLGLMVectorFile

Class TGLGLMVectorFile

Unit

GLFileGL2

Declaration

type TGLGLMVectorFile = class(TVectorFile)

Description

no description available, TVectorFile description follows

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLGLMVectorFile

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream : TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileGL2: Class TGLGLAVectorFile

Class TGLGLAVectorFile

Unit

GLFileGL2

Declaration

type TGLGLAVectorFile = class(TVectorFile)

Description

no description available, TVectorFile description follows

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLGLAVectorFile

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream : TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileGTS

Unit GLFileGTS

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileGTS<p>

GTS (GNU Triangulated Surface) vector file format implementation.<p>

<b>History :</b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>31/03/07 - DaStr - Added $I GLScene.inc <li>05/06/03 - SG - Separated from GLVectorFileObjects.pas </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLGTSVectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileGTS: Class TGLGTSVectorFile

Class TGLGTSVectorFile

Unit

GLFileGTS

Declaration

type TGLGTSVectorFile = class(TVectorFile)

Description

The GTS vector file (GNU Triangulated Surface library).<p> It is a simple text format, with indexed vertices. The first line contains the number of vertices, the number of edges and the number of faces separated by spaces.<br> Following lines contain the x/y/z coordinates of vertices, then the edges (two indices) and the faces (three indices).<br> http://gts.sourceforge.net/

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLGTSVectorFile

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream : TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileHDR

Unit GLFileHDR

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileHDR<p>

HDR File support for GLScene.

<b>History : </b><font size=-1><ul> <li>04/11/10 - DaStr - Added Delphi5 and Delphi6 compatibility <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>08/05/10 - Yar - Removed check for residency in AssignFromTexture <li>22/04/10 - Yar - Fixes after GLState revision <li>23/11/10 - DaStr - Added $I GLScene.inc <li>23/01/10 - Yar - Added to AssignFromTexture CurrentFormat parameter <li>20/01/10 - Yar - Creation </ul><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLHDRImage |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileHDR: Class TGLHDRImage

Class TGLHDRImage

Unit

GLFileHDR

Declaration

type TGLHDRImage = class(TGLBaseImage)

Description

no description available, TGLBaseImage description follows
no description available, TDataFile description follows

Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TGLBaseImage
  • TGLHDRImage

Overview

Fields

Protected | fGamma: Single;
Protected | fExposure: Single;
Protected | fProgramType: string[16];

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLuint; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;

Properties

Public | property Exposure: Single read fExposure;
Public | property Gamma: Single read fGamma;
Public | property ProgramType: Ansistring read GetProgramType write SetProgramType;

Description

Fields

Protected fGamma: Single;
Protected fExposure: Single;
Protected fProgramType: string[16];

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLuint; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;
Public procedure LoadFromFile(const filename: string); override;
Public procedure LoadFromStream(stream: TStream); override;

Properties

Public property Exposure: Single read fExposure;
Public property Gamma: Single read fGamma;
Public property ProgramType: Ansistring read GetProgramType write SetProgramType;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileJPEG

Unit GLFileJPEG

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileJPEG<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>29/06/10 - Yar - Improved FPC compatibility <li>29/04/10 - Yar - Bugfixed loading of fliped image (thanks mif) <li>27/02/10 - Yar - Creation </ul><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLJPEGImage |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileJPEG: Class TGLJPEGImage

Class TGLJPEGImage

Unit

GLFileJPEG

Declaration

type TGLJPEGImage = class(TGLBaseImage)

Description

no description available, TGLBaseImage description follows
no description available, TDataFile description follows

Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TGLBaseImage
  • TGLJPEGImage

Overview

Methods

Public | constructor Create; override;
Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLuint; textureTarget: TGLTextureTarget; const CurrentFormat: boolean; const intFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;

Properties

Public | property Dither: boolean read FDither write FDither;
Public | property DivScale: longword read FDivScale write FDivScale;
Public | property ProgressiveEncoding: boolean read FProgressiveEncoding;
Public | property Smoothing: boolean read FSmoothing write SetSmoothing;

Description

Methods

Public constructor Create; override;
Public class function Capabilities: TDataFileCapabilities; override;
Public procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLuint; textureTarget: TGLTextureTarget; const CurrentFormat: boolean; const intFormat: TGLInternalFormat); reintroduce;

Assigns from any Texture.

Public procedure LoadFromFile(const filename: string); override;
Public procedure LoadFromStream(stream: TStream); override;
Public procedure SaveToFile(const filename: string); override;
Public procedure SaveToStream(stream: TStream); override;

Properties

Public property Dither: boolean read FDither write FDither;
Public property DivScale: longword read FDivScale write FDivScale;
Public property ProgressiveEncoding: boolean read FProgressiveEncoding;
Public property Smoothing: boolean read FSmoothing write SetSmoothing;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileLMTS

Unit GLFileLMTS

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TLMTS_Header |
record TLMTS_TexData |
record TLMTS_Subset |
record TLMTS_Vertex |
record TLMTS |
record TMaterialInfo |
Class TGLLMTSVectorFile |

Types

PLMTS_Header = ˆTLMTS_Header;
PLMTS_TexData = ˆTLMTS_TexData;
PLMTS_Subset = ˆTLMTS_Subset;
PLMTS_Vertex = ˆTLMTS_Vertex;
PLMTS = ˆTLMTS;

Constants

C_LMTS_ID = $53544D4C;
C_LMTS_VER = 4;
C_LMTS_SUBS = $53425553;
C_LMTS_TEXT = $54584554;
C_LMTS_TRIS = $53495254;
C_LMTS_TEXFNLEN = 255;

Description

Types

PLMTS_Header = ˆTLMTS_Header;
PLMTS_TexData = ˆTLMTS_TexData;
PLMTS_Subset = ˆTLMTS_Subset;
PLMTS_Vertex = ˆTLMTS_Vertex;
PLMTS = ˆTLMTS;

Constants

C_LMTS_ID = $53544D4C;
C_LMTS_VER = 4;
C_LMTS_SUBS = $53425553;
C_LMTS_TEXT = $54584554;
C_LMTS_TRIS = $53495254;
C_LMTS_TEXFNLEN = 255;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileLMTS: record TLMTS_Header

record TLMTS_Header

Unit

GLFileLMTS

Declaration

type TLMTS_Header = record

Description

Overview

Fields

ID: cardinal;
Ver: cardinal;
headerSize: cardinal;
nTexts: word;
nSubsets: word;
nTris: cardinal;
subSize: word;
vtxSize: word;

Description

Fields

ID: cardinal;
Ver: cardinal;
headerSize: cardinal;
nTexts: word;
nSubsets: word;
nTris: cardinal;
subSize: word;
vtxSize: word;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileLMTS: record TLMTS_TexData

record TLMTS_TexData

Unit

GLFileLMTS

Declaration

type TLMTS_TexData = record

Description

Overview

Fields

fName: array [0 .. C_LMTS_TEXFNLEN] of ansichar;
Flags: word;

Description

Fields

fName: array [0 .. C_LMTS_TEXFNLEN] of ansichar;
Flags: word;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileLMTS: record TLMTS_Subset

record TLMTS_Subset

Unit

GLFileLMTS

Declaration

type TLMTS_Subset = record

Description

Overview

Fields

Offset: longint;
Count: longint;
TextID1: word;
TextID2: word;

Description

Fields

Offset: longint;
Count: longint;
TextID1: word;
TextID2: word;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileLMTS: record TLMTS_Vertex

record TLMTS_Vertex

Unit

GLFileLMTS

Declaration

type TLMTS_Vertex = record

Description

Overview

Fields

x: single;
y: single;
z: single;
u1: single;
v1: single;
u2: single;
v2: single;

Description

Fields

x: single;
y: single;
z: single;
u1: single;
v1: single;
u2: single;
v2: single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileLMTS: record TLMTS

record TLMTS

Unit

GLFileLMTS

Declaration

type TLMTS = record

Description

Overview

Fields

header: TLMTS_Header;
usrData: pointer;
usrSize: cardinal;
texData: pointer;
subsets: pointer;
tris: pointer;
ok: boolean;

Description

Fields

header: TLMTS_Header;
usrData: pointer;
usrSize: cardinal;
texData: pointer;
subsets: pointer;
tris: pointer;
ok: boolean;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileLMTS: record TMaterialInfo

record TMaterialInfo

Unit

GLFileLMTS

Declaration

type TMaterialInfo = record

Description

Overview

Fields

FShininess: TShininess;
BShininess: TShininess;
FAmbient: TVector;
FDiffuse: TVector;
FEmission: TVector;
FSpecular: TVector;
BAmbient: TVector;
BDiffuse: TVector;
BEmission: TVector;
BSpecular: TVector;
ImageAlpha: TGLTextureImageAlpha;
magFilter: TGLMagFilter;
minFilter: TGLMinFilter;
TextureMode: TGLTextureMode;
TextureWrap: TGLTextureWrap;
Blendingmode: TBlendingMode;
FaceCulling: TFaceCulling;
mathash: integer;

Description

Fields

FShininess: TShininess;
BShininess: TShininess;
FAmbient: TVector;
FDiffuse: TVector;
FEmission: TVector;
FSpecular: TVector;
BAmbient: TVector;
BDiffuse: TVector;
BEmission: TVector;
BSpecular: TVector;
ImageAlpha: TGLTextureImageAlpha;
magFilter: TGLMagFilter;
minFilter: TGLMinFilter;
TextureMode: TGLTextureMode;
TextureWrap: TGLTextureWrap;
Blendingmode: TBlendingMode;
FaceCulling: TFaceCulling;
mathash: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileLMTS: Class TGLLMTSVectorFile

Class TGLLMTSVectorFile

Unit

GLFileLMTS

Declaration

type TGLLMTSVectorFile = class(TVectorFile)

Description

no description available, TVectorFile description follows

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLLMTSVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream: TStream); override;
Public procedure SaveToStream(aStream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileLWO

Unit GLFileLWO

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileLWO<p>

Support-code to load Lightwave LWO Files (v6.0+, partial support).<p>

<b>History : </b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>30/03/07 - DaStr - Added $I GLScene.inc$I GLScene.inc <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>14/11/02 - EG - Added header, fixed warnings <li>16/11/02 - BJ - Added smooth normals with crease angle <li>17/11/02 - BJ - Added 2 and 4 point ngons -> triangles <li>17/11/02 - BJ - Added Enviroment Map Image -> Cubic Projection Map </ul><p>

Original code: "Brian Johns" <brianjohns1@hotmail.com>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLLWOVectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileLWO: Class TGLLWOVectorFile

Class TGLLWOVectorFile

Unit

GLFileLWO

Declaration

type TGLLWOVectorFile = class(TVectorFile)

Description

no description available, TVectorFile description follows

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLLWOVectorFile

Overview

Methods

Public procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public procedure LoadFromStream(aStream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileMD2

Unit GLFileMD2

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileMD2<p>

Quake2 MD2 vector file format implementation.<p>

<b>History :</b><font size=-1><ul> <li>28/08/10 - Yar - Bugfix for FPC 2.5.1 (Thanks Predator) <li>31/03/07 - DaStr - Added $I GLScene.inc <li>05/06/03 - SG - Separated from GLVectorFileObjects.pas </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMD2VectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileMD2: Class TGLMD2VectorFile

Class TGLMD2VectorFile

Unit

GLFileMD2

Declaration

type TGLMD2VectorFile = class(TVectorFile)

Description

The MD2 vector file (Quake2 actor file).<p> Stores a set of "frames" describing the different postures of the actor, it may be animated by TGLActor. The "Skin" must be loaded indepentendly (the whole mesh uses a single texture bitmap).<p> Based on code by Roger Cao.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLMD2VectorFile

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream : TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileMD3

Unit GLFileMD3

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMD3VectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileMD3: Class TGLMD3VectorFile

Class TGLMD3VectorFile

Unit

GLFileMD3

Declaration

type TGLMD3VectorFile = class(TVectorFile)

Description

no description available, TVectorFile description follows

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLMD3VectorFile

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream : TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileMD5

Unit GLFileMD5

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileMD5<p>

Doom3 MD5 mesh and animation vector file format implementation.<p>

<b>History :</b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>02/12/04 - SG - Updated to support MD5 version 10, version 6 support has been dropped. <li>01/06/04 - SG - Initial </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMD5VectorFile |

Variables

vMD5TextureExtensions: TStringList;

Description

Variables

vMD5TextureExtensions: TStringList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileMD5: Class TGLMD5VectorFile

Class TGLMD5VectorFile

Unit

GLFileMD5

Declaration

type TGLMD5VectorFile = class(TVectorFile)

Description

no description available, TVectorFile description follows

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLMD5VectorFile

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream : TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileMDC

Unit GLFileMDC

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMDCVectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileMDC: Class TGLMDCVectorFile

Class TGLMDCVectorFile

Unit

GLFileMDC

Declaration

type TGLMDCVectorFile = class(TVectorFile)

Description

no description available, TVectorFile description follows

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLMDCVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(AStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure LoadFromStream(AStream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileMP3

Unit GLFileMP3

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileMP3<p>

Support for MP3 format.<p>

<b>History : </b><font size=-1><ul> <li>25/07/09 - DaStr - Added $I GLScene.inc <li>06/05/09 - DanB - Creation from split from GLSoundFileObjects.pas </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMP3File |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileMP3: Class TGLMP3File

Class TGLMP3File

Unit

GLFileMP3

Declaration

type TGLMP3File = class(TGLSoundFile)

Description

Support for MP3 format.<p> *Partial* support only, access to PCMData is NOT supported.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TGLSoundFile
  • TGLMP3File

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | function CreateCopy(AOwner: TPersistent) : TDataFile; override;
Public | function LengthInBytes : Integer; override;
Public | function PCMData : Pointer; override;
Public | function WAVData : Pointer; override;
Public | function WAVDataSize : Integer; override;
Public | procedure LoadFromStream(Stream: TStream); override;
Public | procedure PlayOnWaveOut; override;
Public | procedure SaveToStream(Stream: TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public function CreateCopy(AOwner: TPersistent) : TDataFile; override;
Public function LengthInBytes : Integer; override;
Public function PCMData : Pointer; override;
Public function WAVData : Pointer; override;
Public function WAVDataSize : Integer; override;
Public procedure LoadFromStream(Stream: TStream); override;
Public procedure PlayOnWaveOut; override;
Public procedure SaveToStream(Stream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileMS3D

Unit GLFileMS3D

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileMS3D<p>

Support for MS3D file format.<p>

<b>History :</b><font size=-1><ul> <li>24/11/10 - Yar - Foxed range check error <li>22/06/10 - Yar - Added checking of existing material in material library <li>31/05/10 - Yar - Fixes for Linux x64 <li>04/23/10 - TL - Animations now load properly (note: All animations must be full key frames. All bones selected in MS3D) The entire animation will be available in TActor.Animations[0] <li>04/23/10 - TL - Added support for double sided textures. To make a double sided texture, you must set the transparency slider to the left just a little bit in MS3D. This loader will notice that, and turn off backface culling for that group. <li>04/23/10 - TL - Added weighted vertex animations <li>04/23/10 - TL - Fixed the way normals are loaded. They will now be loaded properly. <li>04/23/10 - TL - Added support to read the comments section of MS3D files.

<li>16/10/08 - UweR - Compatibility fix for Delphi 2009: MaterialIndex is now Byte instead of Char <li>31/03/07 - DaStr - Added $I GLScene.inc <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>19/12/04 - PhP - Added capabilities function <li>28/10/03 - SG - Partly implemented skeletal animation, asynchronous animations will fail however. <li>03/06/03 - EG - Added header, now self-registers </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMS3DVectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileMS3D: Class TGLMS3DVectorFile

Class TGLMS3DVectorFile

Unit

GLFileMS3D

Declaration

type TGLMS3DVectorFile = class(TVectorFile)

Description

The MilkShape vector file.<p> By Mattias Fagerlund, mattias@cambrianlabs.com. Yada yada. Eric rules!

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLMS3DVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileNMF

Unit GLFileNMF

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLNMFVectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileNMF: Class TGLNMFVectorFile

Class TGLNMFVectorFile

Unit

GLFileNMF

Declaration

type TGLNMFVectorFile = class(TVectorFile)

Description

no description available, TVectorFile description follows

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLNMFVectorFile

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;
Public | procedure SaveToStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream : TStream); override;
Public procedure SaveToStream(aStream : TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileNurbs

Unit GLFileNurbs

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileNurbs<p>

Nurbs surfaces vector file loading.<p>

<b>History :</b><font size=-1><ul> <li>11/08/03 - SG - Some minor changes <li>05/08/03 - SG - Initial, adapted LoadFromStream from earlier tests with GLNurbsSurface (depricated), originally coded by Eric Grange. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLNurbsVectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileNurbs: Class TGLNurbsVectorFile

Class TGLNurbsVectorFile

Unit

GLFileNurbs

Declaration

type TGLNurbsVectorFile = class(TVectorFile)

Description

no description available, TVectorFile description follows

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLNurbsVectorFile

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | procedure LoadFromStream(stream : TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public procedure LoadFromStream(stream : TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileO3TC

Unit GLFileO3TC

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileO3TC<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>31/05/10 - Yar - Fixes for Linux x64 <li>08/05/10 - Yar - Removed check for residency in AssignFromTexture <li>22/04/10 - Yar - Fixes after GLState revision <li>27/01/10 - Yar - Bugfix in BlockOffset with negative result <li>23/11/10 - DaStr - Added $I GLScene.inc <li>23/01/10 - Yar - Added to AssignFromTexture CurrentFormat parameter Fixed cube map loading bug <li>20/01/10 - Yar - Creation </ul><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLO3TCImage |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:19


GLScene v.1.1.2: GLFileO3TC: Class TGLO3TCImage

Class TGLO3TCImage

Unit

GLFileO3TC

Declaration

type TGLO3TCImage = class(TGLBaseImage)

Description

no description available, TGLBaseImage description follows
no description available, TDataFile description follows

Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TGLBaseImage
  • TGLO3TCImage

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLuint; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLuint; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;
Public procedure LoadFromFile(const filename: string); override;
Public procedure LoadFromStream(stream: TStream); override;
Public procedure SaveToFile(const filename: string); override;
Public procedure SaveToStream(stream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileOBJ

Unit GLFileOBJ

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileOBJ<p>

Support-Code to load Wavefront OBJ Files into TGLFreeForm-Components in GLScene.<p> Note that you must manually add this unit to one of your project's uses to enable support for OBJ & OBJF at run-time.<p>

<b>History : </b><font size=-1><ul>

<li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records

<li>26/06/12 - YP - Split groups in their own mesh instead of a new facegroup (see globale var vGLFileOBJ_SplitMesh, enabled by default) <li>20/06/12 - YP - Get TexturePaths from MaterialLibrary when loading materials

<li>30/06/11 - DaStr - Added ability to assign meshes <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>04/03/10 - DanB - Now uses CharInSet <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>20/05/08 - mrqzzz - Added RegisterClass(TOBJFGVertexNormalTexIndexList) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>11/07/05 - DaStr - Improved Cross-Platform compatibility (BugTracker ID = 1684432) <li>11/07/05 - Wet - Added multi meshobject support <li>09/09/03 - Jaj - Added TriangleStrip and TriangleFan support to save.. <li>10/07/03 - Egg - Improved robustness of material loading <li>02/06/03 - Egg - Undone Jaj changes, they broke standard OBJ support <li>30/01/03 - Egg - Normals extraction <li>29/01/03 - Jaj - Fixed to allow load of simple triangle meshes... ('V','VN','VT') <li>23/01/03 - Egg - Can now export TFGIndexTexCoordList (untextured) <li>25/11/02 - Egg - Improved mtl import (d and illum commands) <li>22/11/02 - Egg - Supports OBJ files using #9 in place of #32, fixed leak, some code cleanup/rearrangements, support for mtllib and usemtl commands <li>18/08/01 - Egg - '$' now allowed as alternate comment, AddToTriangles override <li>03/10/00 - Egg - Fixed TGLOBJVectorFile.LoadFromStream.ReadFace <li>08/10/00 - Egg - Added standard header, basic htmlification of old header, removed specific trim funcs, renamed TMBAGLOBJVectorFile to TGLOBJVectorFile </ul><p>

(c) 2000 Marian Aldenhövel<br> Hainstraße 8<br> 53121 Bonn<br> info@MBA-Software.de<p>

License:<br>

Contributed to Eric Grange and GLScene, same licensing, batteries not included.<p>

History:<p>

26.9.2000: - OBJF-Support (t- and q-lines) see http://www.cs.sunysb.edu/˜stripe/<br> 18.9.2000: - Bugfixing. - SaveTo-Methods.<br> 14.9.2000: - Calculate normals where missing in the file. - Collect Facegroups by Name and do not start a new one for every 'g'-line in the file. - Relative indexing in 'f'-lines.<br> 13.9.2000: - Start of this project as an exercise to get familiar with<br> a) the OBJ-Format and<br> b) GLScene internals<br> Midterm-goal: Import what Poser 4 exports and display it correctly in an GLScene.<br>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLOBJVectorFile |
Class EGLOBJFileError |
Class TGLMTLFile |

Constants

BufSize = 10240;
LineLen = 100;

Variables

vGLFileOBJ_SplitMesh: boolean = False;

Description

Constants

BufSize = 10240;
LineLen = 100;

Variables

vGLFileOBJ_SplitMesh: boolean = False;

If enabled, main mesh will be splitted into multiple mesh from facegroup data.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileOBJ: Class TGLOBJVectorFile

Class TGLOBJVectorFile

Unit

GLFileOBJ

Declaration

type TGLOBJVectorFile = class(TVectorFile)

Description

no description available, TVectorFile description follows

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLOBJVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;
Protected | procedure CalcMissingOBJNormals(mesh: TMeshObject);
Protected | procedure Error(const msg: string);
Protected | procedure ReadLine;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream: TStream); override;
Public procedure SaveToStream(aStream: TStream); override;
Protected procedure CalcMissingOBJNormals(mesh: TMeshObject);
Protected procedure Error(const msg: string);
Protected procedure ReadLine;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileOBJ: Class EGLOBJFileError

Class EGLOBJFileError

Unit

GLFileOBJ

Declaration

type EGLOBJFileError = class(Exception)

Description

Hierarchy

  • Exception
  • EGLOBJFileError

Overview

Properties

Public property LineNo: Integer read FLineNo;

Description

Properties

Public property LineNo: Integer read FLineNo;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileOBJ: Class TGLMTLFile

Class TGLMTLFile

Unit

GLFileOBJ

Declaration

type TGLMTLFile = class(TStringList)

Description

A simple class that know how to extract infos from a mtl file.<p> mtl files are companion files of the obj, they store material information. Guessed content (imported ones denoted with a '*', please help if you know more):<ul> <li>materials begin with a 'newmtl' command followed by material name <li>*Kd command defines the diffuse color <li>*map_Kd command defines the diffuse texture image <li>*Ka/map_Ka define the ambient color and texmap <li>*Ks/map_Ks define the specular color and texmap <li>map_Bump specifies the bump map <li>*d specifies transparency (alpha-channel, range [0; 1]) <li>map_d specifies the opcaity texture map <li>Ns defines the specular exponent or shininess or phong specular (?) <li>Ni is the refraction index (greater than 1) <li>*illum defines the illumination model (0 for no lighting, 1 for ambient and diffuse, 2 for full lighting) </ul>

Hierarchy

  • TStringList
  • TGLMTLFile

Overview

Methods

Public | function MaterialStringProperty(const materialName, propertyName: string): string;
Public | function MaterialVectorProperty(const materialName, propertyName: string; const defaultValue: TVector): TVector;
Public | procedure Prepare;

Description

Methods

Public function MaterialStringProperty(const materialName, propertyName: string): string;
Public function MaterialVectorProperty(const materialName, propertyName: string; const defaultValue: TVector): TVector;
Public procedure Prepare;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileOCT

Unit GLFileOCT

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileOCT<p>

Support-code to load OCT Files into TGLFreeForm-Components in GLScene.<br> (OCT being the format output from FSRad, http://www.fluidstudios.com/fsrad.html).<p>

<b>History : </b><font size=-1><ul> <li>19/06/11 - Yar - Fixed problem with image converting in Lazarus (thanks to Johannes Pretorius, Bugtracker ID = 3322324) <li>22/01/10 - Yar - Added GLTextureFormat to uses <li>31/03/07 - DaStr - Added $I GLScene.inc <li>19/09/03 - EG - "Lighmap" -&gt; "LightMap" <li>06/05/03 - mrqzzz - added Gamma and Brightness correction variables (vGLFileOCTLightmapBrightness, vGLFileOCTLightmapGammaCorrection) <li>02/02/03 - EG - Creation </ul><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLOCTVectorFile |

Variables

vGLFileOCTLightmapBrightness: single = 1;
vGLFileOCTLightmapGammaCorrection: single = 1;
vGLFileOCTAllocateMaterials: boolean = True;

Description

Variables

vGLFileOCTLightmapBrightness: single = 1;
vGLFileOCTLightmapGammaCorrection: single = 1;
vGLFileOCTAllocateMaterials: boolean = True;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileOCT: Class TGLOCTVectorFile

Class TGLOCTVectorFile

Unit

GLFileOCT

Declaration

type TGLOCTVectorFile = class(TVectorFile)

Description

The OCT vector file (FSRad output).<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLOCTVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFilePAK

Unit GLFilePAK

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFilePAK<p>

<b>History : </b><font size=-1><ul> <li>04/06/10 - Yar - Added to GLScene (Created by Rustam Asmandiarov aka Predator) </ul><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TPakHeader |
record TFileSection |
Class TPAKArchive |

Constants

SIGN = 'PACK';

Description

Constants

SIGN = 'PACK';
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFilePAK: record TPakHeader

record TPakHeader

Unit

GLFilePAK

Declaration

type TPakHeader = record

Description

Overview

Fields

Signature: array[0..3] of AnsiChar;
DirOffset: integer;
DirLength: integer;

Description

Fields

Signature: array[0..3] of AnsiChar;
DirOffset: integer;
DirLength: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFilePAK: record TFileSection

record TFileSection

Unit

GLFilePAK

Declaration

type TFileSection = record

Description

Overview

Fields

FileName: array[0..119] of AnsiChar;
FilePos: integer;
FileLength: integer;

Description

Fields

FileName: array[0..119] of AnsiChar;
FilePos: integer;
FileLength: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFilePAK: Class TPAKArchive

Class TPAKArchive

Unit

GLFilePAK

Declaration

type TPAKArchive = class(TBaseArchive)

Description

no description available, TBaseArchive description follows
no description available, TDataFile description follows

Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TBaseArchive
  • TPAKArchive

Overview

Methods

Public | function ContentExists(ContentName: string): boolean; override;
Public | function GetContent(Stream: TStream; index: integer): TStream; override;
Public | function GetContent(index: integer): TStream; override;
Public | function GetContent(ContentName: string): TStream; override;
Public | function GetContentSize(ContentName: string): integer; override;
Public | function GetContentSize(index: integer): integer; override;
Public | procedure AddFromFile(FileName, Path: string); override;
Public | procedure AddFromStream(ContentName, Path: string; FS: TStream); override;
Public | procedure Clear; override;
Public | procedure Extract(index: integer; NewName: string); override;
Public | procedure Extract(ContentName, NewName: string); override;
Public | procedure LoadFromFile(const FileName: string); override;
Public | procedure RemoveContent(ContentName: string); override;
Public | procedure RemoveContent(index: integer); override;
Protected | Procedure SetCompressionLevel(aValue: TCompressionLevel); override;

Properties

Public property ContentCount: integer Read GetContentCount;

Description

Methods

Public function ContentExists(ContentName: string): boolean; override;
Public function GetContent(Stream: TStream; index: integer): TStream; override;
Public function GetContent(index: integer): TStream; override;
Public function GetContent(ContentName: string): TStream; override;
Public function GetContentSize(ContentName: string): integer; override;
Public function GetContentSize(index: integer): integer; override;
Public procedure AddFromFile(FileName, Path: string); override;
Public procedure AddFromStream(ContentName, Path: string; FS: TStream); override;
Public procedure Clear; override;
Public procedure Extract(index: integer; NewName: string); override;
Public procedure Extract(ContentName, NewName: string); override;
Public procedure LoadFromFile(const FileName: string); override;
Public procedure RemoveContent(ContentName: string); override;
Public procedure RemoveContent(index: integer); override;
Protected Procedure SetCompressionLevel(aValue: TCompressionLevel); override;

Properties

Public property ContentCount: integer Read GetContentCount;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFilePGM

Unit GLFilePGM

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPGMImage |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFilePGM: Class TGLPGMImage

Class TGLPGMImage

Unit

GLFilePGM

Declaration

type TGLPGMImage = class(TGLBaseImage)

Description

no description available, TGLBaseImage description follows
no description available, TDataFile description follows

Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TGLBaseImage
  • TGLPGMImage

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLenum; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLenum; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;
Public procedure LoadFromFile(const filename: string); override;
Public procedure LoadFromStream(stream: TStream); override;
Public procedure SaveToFile(const filename: string); override;
Public procedure SaveToStream(stream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFilePLY

Unit GLFilePLY

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFilePLY<p>

PLY (Stanford Triangle Format) vector file format implementation.<p>

<b>History :</b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>31/03/07 - DaStr - Added $I GLScene.inc <li>05/06/03 - SG - Separated from GLVectorFileObjects.pas </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPLYVectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFilePLY: Class TGLPLYVectorFile

Class TGLPLYVectorFile

Unit

GLFilePLY

Declaration

type TGLPLYVectorFile = class(TVectorFile)

Description

The PLY vector file aka Stanford Triangle Format.<p> This is a format for storing graphical objects that are described as a collection of polygons. The format is extensible, supports variations and subformats. This importer only works for the simplest variant (triangles without specified normals, and will ignore most header specifications.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLPLYVectorFile

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream : TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFilePNG

Unit GLFilePNG

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFilePNG<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>31/05/10 - Yar - Fixes for Linux x64 <li>08/05/10 - Yar - Removed check for residency in AssignFromTexture <li>22/04/10 - Yar - Fixes after GLState revision <li>16/03/10 - Yar - Improved FPC compatibility <li>05/03/10 - Yar - Creation </ul><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPNGImage |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFilePNG: Class TGLPNGImage

Class TGLPNGImage

Unit

GLFilePNG

Declaration

type TGLPNGImage = class(TGLBaseImage)

Description

no description available, TGLBaseImage description follows
no description available, TDataFile description follows

Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TGLBaseImage
  • TGLPNGImage

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLuint; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLuint; textureTarget: TGLTextureTarget; const CurrentFormat: Boolean; const intFormat: TGLInternalFormat); reintroduce;

Assigns from any Texture.

Public procedure LoadFromFile(const filename: string); override;
Public procedure LoadFromStream(stream: TStream); override;
Public procedure SaveToFile(const filename: string); override;
Public procedure SaveToStream(stream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileQ3BSP

Unit GLFileQ3BSP

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileQ3BSP<p>

Support-code to load Q3BSP Files into TGLFreeForm-Components in GLScene.<p> Note that you must manually add this unit to one of your project's uses to enable support for OBJ & OBJF at run-time.<p>

<b>History : </b><font size=-1><ul> <li>19/06/11 - Yar - Fixed problem with image converting in Lazarus (thanks to Johannes Pretorius, Bugtracker ID = 3322324) <li>06/06/10 - Yar - Added VectorTypes to uses <li>22/01/10 - Yar - Added GLTextureFormat to uses <li>31/03/07 - DaStr - Added $I GLScene.inc <li>31/01/03 - EG - Materials support <li>30/01/03 - EG - Creation </ul><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLQ3BSPVectorFile |

Variables

vQ3BSPLightmapGammaCorrection: Single = 2.5;
vQ3BSPLightmapBrightness: Single = 2;
vGLFileQ3BSPLoadMaterials: boolean = True;

Description

Variables

vQ3BSPLightmapGammaCorrection: Single = 2.5;
vQ3BSPLightmapBrightness: Single = 2;
vGLFileQ3BSPLoadMaterials: boolean = True;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileQ3BSP: Class TGLQ3BSPVectorFile

Class TGLQ3BSPVectorFile

Unit

GLFileQ3BSP

Declaration

type TGLQ3BSPVectorFile = class(TVectorFile)

Description

The Q3BSP vector file (Quake III BSP).<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLQ3BSPVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileSMD

Unit GLFileSMD

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileSMD<p>

SMD vector file format implementation.<p>

<b>History :</b><font size=-1><ul> <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>28/01/07 - DaStr - Optimized bone weights loading a bit <li>14/01/07 - DaStr - Fixed bone weights for HL2 models (thanks DIVON) <li>24/01/05 - SG - Fix for comma decimal separator in save function (dikoe Kenguru) <li>30/03/04 - EG - Basic Half-Life2/XSI support <li>05/06/03 - SG - Separated from GLVectorFileObjects.pas </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSMDVectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileSMD: Class TGLSMDVectorFile

Class TGLSMDVectorFile

Unit

GLFileSMD

Declaration

type TGLSMDVectorFile = class(TVectorFile)

Description

The SMD vector file is Half-life's skeleton format.<p> The SMD is a text-based file format. They come in two flavors: one that old Skeleton and triangle (mesh) data, and animation files that store Skeleton frames.<p> This reader curently reads both, but requires that the main file (the one with mesh data) be read first.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLSMDVectorFile

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;
Public | procedure SaveToStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream : TStream); override;
Public procedure SaveToStream(aStream : TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileSTL

Unit GLFileSTL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileSTL<p>

Support-code to load STL Files into TGLFreeForm-Components in GLScene.<p> Note that you must manually add this unit to one of your project's uses to enable support for STL files at run-time.<p>

<b>History : </b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>22/11/02 - EG - Write capability now properly declared <li>17/10/02 - EG - Created from split of GLVectorFileObjects, ASCII STL support (Adem) </ul><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSTLVectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileSTL: Class TGLSTLVectorFile

Class TGLSTLVectorFile

Unit

GLFileSTL

Declaration

type TGLSTLVectorFile = class(TVectorFile)

Description

The STL vector file (stereolithography format).<p> It is a list of the triangular surfaces that describe a computer generated solid model. This is the standard input for most rapid prototyping machines.<p> There are two flavors of STL, the "text" and the "binary", this class reads both, but exports only the "binary" version.<p> Original Binary importer code by Paul M. Bearne, Text importer by Adem.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLSTLVectorFile

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream: TStream); override;
Public procedure SaveToStream(aStream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileTGA

Unit GLFileTGA

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileTGA<p>

Graphic engine friendly loading of TGA image.

<b>History : </b><font size=-1><ul> <li>04/04/11 - Yar - Creation </ul><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTGAImage |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileTGA: Class TGLTGAImage

Class TGLTGAImage

Unit

GLFileTGA

Declaration

type TGLTGAImage = class(TGLBaseImage)

Description

no description available, TGLBaseImage description follows
no description available, TDataFile description follows

Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TGLBaseImage
  • TGLTGAImage

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLuint; textureTarget: TGLTextureTarget; const CurrentFormat: boolean; const intFormat: TGLInternalFormat); reintroduce;
Public | procedure LoadFromFile(const filename: string); override;
Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToFile(const filename: string); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure AssignFromTexture(textureContext: TGLContext; const textureHandle: TGLuint; textureTarget: TGLTextureTarget; const CurrentFormat: boolean; const intFormat: TGLInternalFormat); reintroduce;
Public procedure LoadFromFile(const filename: string); override;
Public procedure LoadFromStream(stream: TStream); override;
Public procedure SaveToFile(const filename: string); override;
Public procedure SaveToStream(stream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileTIN

Unit GLFileTIN

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileTIN<p>

TIN (Triangular Irregular Network) vector file format implementation.<p>

<b>History :</b><font size=-1><ul> <li>05/06/03 - SG - Separated from GLVectorFileObjects.pas </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTINVectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileTIN: Class TGLTINVectorFile

Class TGLTINVectorFile

Unit

GLFileTIN

Declaration

type TGLTINVectorFile = class(TVectorFile)

Description

The TIN vector file (triangle irregular network).<p> It is a simple text format, with one triangle record per line, no materials, no texturing (there may be more, but I never saw anything in this files).<p> This format is encountered in the DEM/DTED world and used in place of grids.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLTINVectorFile

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream : TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileVRML

Unit GLFileVRML

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileVRML<p>

Preliminary VRML vector file support for GLScene.<p> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <b>History :</b><font size=-1><ul> <li>29/03/07 - DaStr - RecursNodes bugfixed (thanks Burkhard Carstens) <li>25/01/05 - SG - Improved auto-normal generation using creaseAngle, Added Normal and TexCoord reading, Fixes for the polygon tessellation routine (Carsten Pohl) <li>18/01/05 - SG - Added polygon tessellation routine to decompose a polygon mesh to a triangle mesh <li>14/01/05 - SG - Added to CVS </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLVRMLVectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileVRML: Class TGLVRMLVectorFile

Class TGLVRMLVectorFile

Unit

GLFileVRML

Declaration

type TGLVRMLVectorFile = class(TVectorFile)

Description

no description available, TVectorFile description follows

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLVRMLVectorFile

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream : TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileWAV

Unit GLFileWAV

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileWAV<p>

Support for Windows WAV format.<p>

<b>History : </b><font size=-1><ul> <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>25/07/09 - DaStr - Added $I GLScene.inc <li>26/05/09 - DanB - Fix for LengthInBytes when chunks occur after data chunk <li>06/05/09 - DanB - Creation from split from GLSoundFileObjects.pas </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLWAVFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileWAV: Class TGLWAVFile

Class TGLWAVFile

Unit

GLFileWAV

Declaration

type TGLWAVFile = class(TGLSoundFile)

Description

Support for Windows WAV format.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TGLSoundFile
  • TGLWAVFile

Overview

Methods

Public | class function Capabilities : TDataFileCapabilities; override;
Public | function CreateCopy(AOwner: TPersistent) : TDataFile; override;
Public | function LengthInBytes : Integer; override;
Public | function PCMData : Pointer; override;
Public | function WAVData : Pointer; override;
Public | function WAVDataSize : Integer; override;
Public | procedure LoadFromStream(Stream: TStream); override;
Public | procedure PlayOnWaveOut; override;
Public | procedure SaveToStream(Stream: TStream); override;

Description

Methods

Public class function Capabilities : TDataFileCapabilities; override;
Public function CreateCopy(AOwner: TPersistent) : TDataFile; override;
Public function LengthInBytes : Integer; override;
Public function PCMData : Pointer; override;
Public function WAVData : Pointer; override;
Public function WAVDataSize : Integer; override;
Public procedure LoadFromStream(Stream: TStream); override;
Public procedure PlayOnWaveOut; override;
Public procedure SaveToStream(Stream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GlFileX

Unit GlFileX

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GlFileX<p>

Simple X format support for Delphi (Microsoft's favorite format)<p>

<b>History : </b><font size=-1><ul> <li>07/11/09 - DaStr - Initial version (Added from the GLScene-Lazarus SVN) </ul></font>

<b>Previous version history : </b><font size=-1><ul> $Log$ Revision 1.1 2009/11/07 22:12:25 da_stranger Initial version (Added from the GLScene-Lazarus SVN)

Revision 1.1 2006/01/10 20:50:44 z0m3ie recheckin to make shure that all is lowercase

Revision 1.1 2006/01/09 21:02:31 z0m3ie *** empty log message ***

Revision 1.3 2005/12/04 16:53:04 z0m3ie renamed everything to lowercase to get better codetools support and avoid unit finding bugs

Revision 1.2 2005/08/03 00:41:38 z0m3ie - added automatical generated History from CVS </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLXVectorFile |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GlFileX: Class TGLXVectorFile

Class TGLXVectorFile

Unit

GlFileX

Declaration

type TGLXVectorFile = class(TVectorFile)

Description

no description available, TVectorFile description follows

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLXVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream : TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream : TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileZLIB

Unit GLFileZLIB

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFileZLIB<p>

<b>History : </b><font size=-1><ul> <li>22/08/10 - DaStr - Removed warnings, converted comments from Unicode to ASCII <li>04/06/10 - Yar - Added to GLScene (Created by Rustam Asmandiarov aka Predator) </ul><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TZLibHeader |
record TFileSection |
Class TZLibArchive |

Constants

SIGN = 'ZLIB';

Description

Constants

SIGN = 'ZLIB';
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileZLIB: record TZLibHeader

record TZLibHeader

Unit

GLFileZLIB

Declaration

type TZLibHeader = record

Description

Overview

Fields

Signature: array[0..3] of AnsiChar;
DirOffset: integer;
DirLength: integer;

Description

Fields

Signature: array[0..3] of AnsiChar;
DirOffset: integer;
DirLength: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileZLIB: record TFileSection

record TFileSection

Unit

GLFileZLIB

Declaration

type TFileSection = record

Description

Overview

Fields

FileName: array[0..119] of AnsiChar;
FilePos: integer;
FileLength: integer;
CbrMode: TCompressionLevel;

Description

Fields

FileName: array[0..119] of AnsiChar;
FilePos: integer;
FileLength: integer;
CbrMode: TCompressionLevel;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFileZLIB: Class TZLibArchive

Class TZLibArchive

Unit

GLFileZLIB

Declaration

type TZLibArchive = class(TBaseArchive)

Description

no description available, TBaseArchive description follows
no description available, TDataFile description follows

Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TBaseArchive
  • TZLibArchive

Overview

Methods

Public | destructor Destroy; override;
Public | function ContentExists(ContentName: string): boolean; override;
Public | function GetContent(index: integer): TStream; override;
Public | function GetContent(ContentName: string): TStream; override;
Public | function GetContent(aStream: TStream; index: integer): TStream; override;
Public | function GetContentSize(index: integer): integer; override;
Public | function GetContentSize(ContentName: string): integer; override;
Public | procedure AddFromFile(FileName, Path: string); override;
Public | procedure AddFromStream(ContentName, Path: string; FS: TStream); override;
Public | procedure Clear; override;
Public | procedure Extract(index: integer; NewName: string); override;
Public | procedure Extract(ContentName, NewName: string); override;
Public | procedure LoadFromFile(const FileName: string); override;
Public | procedure RemoveContent(index: integer); overload; override;
Public | procedure RemoveContent(ContentName: string); overload; override;

Properties

Public property ContentCount: integer Read GetContentCount;

Description

Methods

Public destructor Destroy; override;
Public function ContentExists(ContentName: string): boolean; override;
Public function GetContent(index: integer): TStream; override;
Public function GetContent(ContentName: string): TStream; override;
Public function GetContent(aStream: TStream; index: integer): TStream; override;
Public function GetContentSize(index: integer): integer; override;
Public function GetContentSize(ContentName: string): integer; override;
Public procedure AddFromFile(FileName, Path: string); override;
Public procedure AddFromStream(ContentName, Path: string; FS: TStream); override;
Public procedure Clear; override;
Public procedure Extract(index: integer; NewName: string); override;
Public procedure Extract(ContentName, NewName: string); override;
Public procedure LoadFromFile(const FileName: string); override;
Public procedure RemoveContent(index: integer); overload; override;
Public procedure RemoveContent(ContentName: string); overload; override;

Properties

Public property ContentCount: integer Read GetContentCount;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFireFX

Unit GLFireFX

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLFireFX<p>

Fire special effect<p>

<b>Historique : </b><font size=-1><ul> <li>21/01/01 - DanB - Added "inherited" call to TGLBFireFX.WriteToFiler <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>14/06/10 - Yar - Bugfixed in TGLBFireFX.ReadFromFiler when assertion off (thanks olkondr) <li>22/04/10 - Yar - Fixes after GLState revision <li>11/04/10 - Yar - Replaced glNewList to GLState.NewList in TGLBFireFX.Render <li>05/03/10 - DanB - More state added to TGLStateCache <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>14/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>23/02/07 - DaStr - Fixed TGLFireFXManager.Create (TGLCoordinatesStyle stuff) <li>21/02/02 - EG - Added GetOrCreateFireFX helper functions <li>09/12/01 - EG - Added NoZWrite property <li>12/08/01 - EG - Fixed leak (color objects) <li>09/03/01 - EG - Fixed MaxParticles change, added RingExplosion <li>08/03/01 - EG - Revisited the effect and added new parameters, dropped/renamed some, started documentation (just started) <li>13/01/01 - EG - Another matrix compatibility update <li>22/12/00 - EG - Compatibility for new Matrix rules, and sometime ago, added in all new props from Danjel Grosar <li>11/08/00 - EG - A few speedups/enhancements <li>08/08/00 - EG - Creation, based on Roger Cao's "FireEffectUnit" </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TFireParticle |
Class TGLFireFXManager |
Class TGLBFireFX |

Functions and Procedures

function GetOrCreateFireFX(effects: TGLObjectEffects): TGLBFireFX; overload;
function GetOrCreateFireFX(obj: TGLBaseSceneObject): TGLBFireFX; overload;

Types

PFireParticle = ˆTFireParticle;
TFireParticleArray = array[0..MAXINT shr 6] of TFireParticle;
PFireParticleArray = ˆTFireParticleArray;

Description

Functions and Procedures

function GetOrCreateFireFX(effects: TGLObjectEffects): TGLBFireFX; overload;

Returns or creates the TGLBFireFX within the given behaviours.<p> This helper function is convenient way to access a TGLBFireFX.

function GetOrCreateFireFX(obj: TGLBaseSceneObject): TGLBFireFX; overload;

Returns or creates the TGLBFireFX within the given object's behaviours.<p> This helper function is convenient way to access a TGLBFireFX.

Types

PFireParticle = ˆTFireParticle;
TFireParticleArray = array[0..MAXINT shr 6] of TFireParticle;
PFireParticleArray = ˆTFireParticleArray;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFireFX: record TFireParticle

record TFireParticle

Unit

GLFireFX

Declaration

type TFireParticle = record

Description

Overview

Fields

Position: TVector;
Speed: TVector;
Alpha: Single;
TimeToLive: Single;
LifeLength: Single;

Description

Fields

Position: TVector;
Speed: TVector;
Alpha: Single;
TimeToLive: Single;
LifeLength: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFireFX: Class TGLFireFXManager

Class TGLFireFXManager

Unit

GLFireFX

Declaration

type TGLFireFXManager = class(TGLCadenceAbleComponent)

Description

Fire special effect manager.<p> Defines the looks and behaviour of a particle system that can be made to look fire-like.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLFireFXManager

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function StoreParticleSize: Boolean;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Public | procedure FireInit;
Public | procedure IsotropicExplosion(minInitialSpeed, maxInitialSpeed, lifeBoostFactor: Single; nbParticles: Integer = -1);
Public | procedure RingExplosion(minInitialSpeed, maxInitialSpeed, lifeBoostFactor: Single; const ringVectorX, ringVectorY: TAffineVector; nbParticles: Integer = -1);
Protected | procedure AffParticle3d(Color2: TColorVector; const mat: TMatrix);
Protected | procedure CalcFire(deltaTime: Double; ParticleInterval, ParticleLife: Single; FireAlpha: Single);
Protected | procedure DeRegisterAllClients;
Protected | procedure DeRegisterClient(aClient: TGLBFireFX);
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure RegisterClient(aClient: TGLBFireFX);
Protected | procedure SetCadencer(const val: TGLCadencer);
Protected | procedure SetFireDir(const val: TGLCoordinates);
Protected | procedure SetInitialDir(const val: TGLCoordinates);
Protected | procedure SetInnerColor(const val: TGLcolor);
Protected | procedure SetMaxParticles(const val: Integer);
Protected | procedure SetOuterColor(const val: TGLcolor);
Protected | procedure SetReference(const val: TGLBaseSceneObject);

Properties

Published | property Cadencer: TGLCadencer read FCadencer write SetCadencer;
Published | property Disabled: Boolean read FDisabled write FDisabled;
Published | property FireBurst: Single read FFireBurst write FFireBurst;
Published | property FireCrown: Single read FFireCrown write FFireCrown;
Published | property FireDensity: Single read FFireDensity write FFireDensity;
Published | property FireDir: TGLCoordinates read FFireDir write SetFireDir;
Published | property FireEvaporation: Single read FFireEvaporation write FFireEvaporation;
Published | property FireRadius: Single read FFireRadius write FFireRadius;
Published | property InitialDir: TGLCoordinates read FInitialDir write SetInitialDir;
Published | property InnerColor: TGLcolor read FInnerColor write SetInnerColor;
Published | property MaxParticles: Integer read FMaxParticles write SetMaxParticles default 256;
Published | property NoZWrite: Boolean read FNoZWrite write FNoZWrite default True;
Published | property OuterColor: TGLcolor read FOuterColor write SetOuterColor;
Public | property ParticleCount: Integer read NP;
Published | property ParticleInterval: Single read FParticleInterval write FParticleInterval;
Published | property ParticleLife: Integer read FParticleLife write FParticleLife default 3;
Published | property ParticleSize: Single read FParticleSize write FParticleSize stored StoreParticleSize;
Published | property Paused: Boolean read FPaused write FPaused;
Published | property Reference: TGLBaseSceneObject read FReference write SetReference;
Published | property UseInterval: Boolean read FUseInterval write FUseInterval;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function StoreParticleSize: Boolean;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Public procedure FireInit;

Reinitializes the fire.

Public procedure IsotropicExplosion(minInitialSpeed, maxInitialSpeed, lifeBoostFactor: Single; nbParticles: Integer = -1);

Spawns a large quantity of particles to simulate an isotropic explosion.<p> This method generates an isotropic explosion, i.e. there is no privilegied direction in the initial vector.

Public procedure RingExplosion(minInitialSpeed, maxInitialSpeed, lifeBoostFactor: Single; const ringVectorX, ringVectorY: TAffineVector; nbParticles: Integer = -1);

Spawns a large quantity of particles to simulate a ring explosion.<p> This method generates a ring explosion. The plane of the ring is described by ringVectorX/Y, which should be of unit length (but you may not make them of unit length if you want "elliptic" rings).

Protected procedure AffParticle3d(Color2: TColorVector; const mat: TMatrix);
Protected procedure CalcFire(deltaTime: Double; ParticleInterval, ParticleLife: Single; FireAlpha: Single);
Protected procedure DeRegisterAllClients;
Protected procedure DeRegisterClient(aClient: TGLBFireFX);
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure RegisterClient(aClient: TGLBFireFX);
Protected procedure SetCadencer(const val: TGLCadencer);
Protected procedure SetFireDir(const val: TGLCoordinates);
Protected procedure SetInitialDir(const val: TGLCoordinates);
Protected procedure SetInnerColor(const val: TGLcolor);
Protected procedure SetMaxParticles(const val: Integer);
Protected procedure SetOuterColor(const val: TGLcolor);
Protected procedure SetReference(const val: TGLBaseSceneObject);

Properties

Published property Cadencer: TGLCadencer read FCadencer write SetCadencer;

The cadencer that will "drive" the animation of the system.

Published property Disabled: Boolean read FDisabled write FDisabled;

If true, no new particles are spawn.<p> But current ones continue to live and die.

Published property FireBurst: Single read FFireBurst write FFireBurst;
Published property FireCrown: Single read FFireCrown write FFireCrown;

Adjust a crown (circular) radius on which particles are spawned.<p> With a value of zero, the particles are spawned in the FireRadius cube around the origin, with a non zero value, they appear in a torus of major radius FireCrown, and minor radius FireRadius*1.73.

Published property FireDensity: Single read FFireDensity write FFireDensity;
Published property FireDir: TGLCoordinates read FFireDir write SetFireDir;

Adjusts the acceleration direction (abs coordinates).

Published property FireEvaporation: Single read FFireEvaporation write FFireEvaporation;
Published property FireRadius: Single read FFireRadius write FFireRadius;

Adjusts the random birth radius for particles (actually a birth cube).

Published property InitialDir: TGLCoordinates read FInitialDir write SetInitialDir;

Adjusts the initial direction (abs coordinates).

Published property InnerColor: TGLcolor read FInnerColor write SetInnerColor;

Inner color of a particle.

Published property MaxParticles: Integer read FMaxParticles write SetMaxParticles default 256;

Maximum number of simultaneous particles in the system.

Published property NoZWrite: Boolean read FNoZWrite write FNoZWrite default True;

Particle's render won't write to Z-Buffer

Published property OuterColor: TGLcolor read FOuterColor write SetOuterColor;

Outer color of a particle.

Public property ParticleCount: Integer read NP;

Current Nb of particles.

Published property ParticleInterval: Single read FParticleInterval write FParticleInterval;

Interval between particles births (in sec).<p> The interval may not be honoured if MawParticles is reached.

Published property ParticleLife: Integer read FParticleLife write FParticleLife default 3;

Life length of particle.

Published property ParticleSize: Single read FParticleSize write FParticleSize stored StoreParticleSize;

Size of the particle, in absolute units.

Published property Paused: Boolean read FPaused write FPaused;

When paused, the fire animation is freezed.

Published property Reference: TGLBaseSceneObject read FReference write SetReference;

Specifies an optional object whose position to use as reference.<p> This property allows switching between static/shared fires (for fireplaces or static torches) and dynamic fire trails.<br> The absolute position of the reference object is 'central' spawning point for new particles, usually, the object will be the one and only one on which the effect is applied.

Published property UseInterval: Boolean read FUseInterval write FUseInterval;

Enable/disable use of ParticleInterval.<p> If true ParticleInterval is used, if False, the system will attempt to maintain a particle count of MaxParticles, by spawning new particles to replace the dead ones ASAP.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFireFX: Class TGLBFireFX

Class TGLBFireFX

Unit

GLFireFX

Declaration

type TGLBFireFX = class(TGLObjectPostEffect)

Description

Fire special effect.<p> This effect works as a client of TFireFXManager

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLObjectEffect
  • TGLObjectPostEffect
  • TGLBFireFX

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Render(var rci: TRenderContextInfo); override;
Protected | procedure Loaded; override;
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure SetManager(const val: TGLFireFXManager);
Protected | procedure WriteToFiler(writer: TWriter); override;

Properties

Published property Manager: TGLFireFXManager read FManager write SetManager;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure Render(var rci: TRenderContextInfo); override;
Protected procedure Loaded; override;
Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure SetManager(const val: TGLFireFXManager);
Protected procedure WriteToFiler(writer: TWriter); override;

Properties

Published property Manager: TGLFireFXManager read FManager write SetManager;

Refers the collision manager.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFPSMovement

Unit GLFPSMovement

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TContactPoint |
Class TCollisionState |
Class TCollisionStates |
Class TGLMapCollectionItem |
Class TGLMapCollection |
Class TGLFPSMovementManager |
Class TGLBFPSMovement |

Functions and Procedures

function GetFPSMovement(behaviours: TGLBehaviours): TGLBFPSMovement; overload;
function GetFPSMovement(obj: TGLBaseSceneObject): TGLBFPSMovement; overload;
function GetOrCreateFPSMovement(behaviours: TGLBehaviours) : TGLBFPSMovement; overload;
function GetOrCreateFPSMovement(obj: TGLBaseSceneObject) : TGLBFPSMovement; overload;

Types

TGLMapCollectionItemClass = class of TGLMapCollectionItem;

Description

Functions and Procedures

function GetFPSMovement(behaviours: TGLBehaviours): TGLBFPSMovement; overload;
function GetFPSMovement(obj: TGLBaseSceneObject): TGLBFPSMovement; overload;
function GetOrCreateFPSMovement(behaviours: TGLBehaviours) : TGLBFPSMovement; overload;
function GetOrCreateFPSMovement(obj: TGLBaseSceneObject) : TGLBFPSMovement; overload;

Types

TGLMapCollectionItemClass = class of TGLMapCollectionItem;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFPSMovement: record TContactPoint

record TContactPoint

Unit

GLFPSMovement

Declaration

type TContactPoint = record

Description

Overview

Fields

intPoint: TVector;
intNormal: TVector;

Description

Fields

intPoint: TVector;
intNormal: TVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFPSMovement: Class TCollisionState

Class TCollisionState

Unit

GLFPSMovement

Declaration

type TCollisionState = class(TObject)

Description

Hierarchy

  • TObject
  • TCollisionState

Overview

Fields

Public | Position: TVector;
Public | Contact: TContactPoint;
Public | Time: Int64;

Description

Fields

Public Position: TVector;
Public Contact: TContactPoint;
Public Time: Int64;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFPSMovement: Class TCollisionStates

Class TCollisionStates

Unit

GLFPSMovement

Declaration

type TCollisionStates = class(TList)

Description

Hierarchy

  • TList
  • TCollisionStates
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFPSMovement: Class TGLMapCollectionItem

Class TGLMapCollectionItem

Unit

GLFPSMovement

Declaration

type TGLMapCollectionItem = class(TXCollectionItem)

Description

no description available, TXCollectionItem description follows

Base class for implementing a XCollection item.<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation </ul>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLMapCollectionItem

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | class function FriendlyName: String; override;
Protected | procedure Loaded; override;
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property CollisionGroup: integer read FCollisionGroup write FCollisionGroup;
Published | property Map: TGLFreeForm read FMap write setMap;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;
Public class function FriendlyName: String; override;
Protected procedure Loaded; override;
Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure WriteToFiler(writer: TWriter); override;

Properties

Published property CollisionGroup: integer read FCollisionGroup write FCollisionGroup;
Published property Map: TGLFreeForm read FMap write setMap;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFPSMovement: Class TGLMapCollection

Class TGLMapCollection

Unit

GLFPSMovement

Declaration

type TGLMapCollection = class(TXCollection)

Description

no description available, TXCollection description follows

Holds a list of TXCollectionItem objects.<p> This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList and persistence classes (XClasses & XLists), if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than Borland's lists and persistence mechanisms (and unlike Borland's, with polymorphism-support and full backward compatibility).

Hierarchy

  • TPersistent
  • TXCollection
  • TGLMapCollection

Overview

Methods

Public | function addMap(Map: TGLFreeForm; CollisionGroup: integer = 0) : TGLMapCollectionItem;
Public | function findMap(mapFreeForm: TGLFreeForm): TGLMapCollectionItem;
Public | class function ItemsClass: TXCollectionItemClass; override;

Description

Methods

Public function addMap(Map: TGLFreeForm; CollisionGroup: integer = 0) : TGLMapCollectionItem;
Public function findMap(mapFreeForm: TGLFreeForm): TGLMapCollectionItem;
Public class function ItemsClass: TXCollectionItemClass; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFPSMovement: Class TGLFPSMovementManager

Class TGLFPSMovementManager

Unit

GLFPSMovement

Declaration

type TGLFPSMovementManager = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLFPSMovementManager

Overview

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function SphereSweepAndSlide(freeform: TGLFreeForm; behaviour: TGLBFPSMovement; SphereStart: TVector; var Velocity, newPosition: TVector; sphereRadius: single) : boolean; overload;
Public | procedure SphereSweepAndSlide(behaviour: TGLBFPSMovement; SphereStart: TVector; var Velocity, newPosition: TVector; sphereRadius: single); overload;
Protected | procedure DefineProperties(Filer: TFiler); override;
Protected | procedure Loaded; override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure ReadMaps(stream: TStream);
Protected | procedure WriteMaps(stream: TStream);

Properties

Published | property DisplayTime: integer read FDisplayTime write FDisplayTime;
Published | property Maps: TGLMapCollection read FMaps write FMaps;
Published | property MovementScale: single read FMovementScale write FMovementScale;
Published | property Navigator: TGLNavigator read FNavigator write SetNavigator;
Published | property Scene: TGLScene read FScene write setScene;

Description

Methods

Public constructor Create(aOwner: TComponent); override;
Public destructor Destroy; override;
Public function SphereSweepAndSlide(freeform: TGLFreeForm; behaviour: TGLBFPSMovement; SphereStart: TVector; var Velocity, newPosition: TVector; sphereRadius: single) : boolean; overload;
Public procedure SphereSweepAndSlide(behaviour: TGLBFPSMovement; SphereStart: TVector; var Velocity, newPosition: TVector; sphereRadius: single); overload;
Protected procedure DefineProperties(Filer: TFiler); override;
Protected procedure Loaded; override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure ReadMaps(stream: TStream);
Protected procedure WriteMaps(stream: TStream);

Properties

Published property DisplayTime: integer read FDisplayTime write FDisplayTime;
Published property Maps: TGLMapCollection read FMaps write FMaps;
Published property MovementScale: single read FMovementScale write FMovementScale;
Published property Navigator: TGLNavigator read FNavigator write SetNavigator;
Published property Scene: TGLScene read FScene write setScene;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFPSMovement: Class TGLBFPSMovement

Class TGLBFPSMovement

Unit

GLFPSMovement

Declaration

type TGLBFPSMovement = class(TGLBehaviour)

Description

no description available, TGLBehaviour description follows

Ancestor for non-rendering behaviours.<p> This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLObjectEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBFPSMovement

Overview

Fields

Public Velocity: TVector;

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Public | Procedure MoveForward(Distance: single);
Public | Procedure StrafeHorizontal(Distance: single);
Public | Procedure StrafeVertical(Distance: single);
Public | Procedure Straighten;
Public | Procedure TurnHorizontal(Angle: single);
Public | Procedure TurnVertical(Angle: single);
Protected | procedure Loaded; override;
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property CollisionGroup: integer read FCollisionGroup write FCollisionGroup;
Published | property GravityEnabled: boolean read FGravityEnabled write FGravityEnabled;
Published | property Manager: TGLFPSMovementManager read FManager write FManager;
Published | property ShowArrows: boolean read FShowArrows write setShowArrows;
Published | property sphereRadius: single read FSphereRadius write FSphereRadius;

Description

Fields

Public Velocity: TVector;

Methods

Public constructor Create(aOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyName: string; override;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Public Procedure MoveForward(Distance: single);
Public Procedure StrafeHorizontal(Distance: single);
Public Procedure StrafeVertical(Distance: single);
Public Procedure Straighten;
Public Procedure TurnHorizontal(Angle: single);
Public Procedure TurnVertical(Angle: single);
Protected procedure Loaded; override;
Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure WriteToFiler(writer: TWriter); override;

Properties

Published property CollisionGroup: integer read FCollisionGroup write FCollisionGroup;
Published property GravityEnabled: boolean read FGravityEnabled write FGravityEnabled;
Published property Manager: TGLFPSMovementManager read FManager write FManager;
Published property ShowArrows: boolean read FShowArrows write setShowArrows;
Published property sphereRadius: single read FSphereRadius write FSphereRadius;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFullScreenViewer

Unit GLFullScreenViewer

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLFullScreenViewer |

Functions and Procedures

procedure Register;

Types

TGLScreenDepth = (...);

Description

Functions and Procedures

procedure Register;

Types

TGLScreenDepth = (...);
Values
  • sd8bits:
  • sd16bits:
  • sd24bits:
  • sd32bits:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:20


GLScene v.1.1.2: GLFullScreenViewer: Class TGLFullScreenViewer

Class TGLFullScreenViewer

Unit

GLFullScreenViewer

Declaration

type TGLFullScreenViewer = class(TGLNonVisualViewer)

Description

no description available, TGLNonVisualViewer description follows

Base class for non-visual viewer.<p> Non-visual viewer may actually render visuals, but they are non-visual (ie. non interactive) at design time. Such viewers include memory or full-screen viewers.

Hierarchy

  • TComponent
  • TGLNonVisualViewer
  • TGLFullScreenViewer

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function FramesPerSecond: Single;
Public | function FramesPerSecondText(decimals: Integer = 1): String;
Public | function LastFrameTime: Single;
Protected | function GetHandle: HWND;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure ReActivate;
Public | procedure Render(baseObject: TGLBaseSceneObject = nil); override;
Public | procedure ResetPerformanceMonitor;
Public | procedure UseCurrentResolution;
Protected | procedure BindFormEvents;
Protected | procedure DoActivate(Sender: TObject);
Protected | procedure DoBeforeRender(Sender: TObject);
Protected | procedure DoBufferChange(Sender: TObject); override;
Protected | procedure DoBufferStructuralChange(Sender: TObject); override;
Protected | procedure DoCloseQuery(Sender: TObject; var CanClose: Boolean);
Protected | procedure DoDeactivate(Sender: TObject);
Protected | procedure DoFormDestroy(Sender: TObject);
Protected | procedure DoPaint(Sender: TObject);
Protected | procedure Shutdown;
Protected | procedure Startup;

Properties

Public | property Active: Boolean read FActive write SetActive;
Published | property Cursor: TCursor read FCursor write SetCursor default crDefault;
Published | property Form: TForm read FForm write SetForm;
Public | property Handle: HWND read GetHandle;
Published | property ManualRendering: Boolean read FManualRendering write SetManualRendering;
Published | property OnClick: TNotifyEvent read FOnClick write SetOnClick;
Published | property OnClose: TCloseEvent read FOnClose write SetOnClose;
Published | property OnCloseQuery: TCloseQueryEvent read FOnCloseQuery write SetOnCloseQuery;
Published | property OnDblClick: TNotifyEvent read FOnDblClick write SetOnDblClick;
Published | property OnKeyDown: TKeyEvent read FOnKeyDown write SetOnKeyDown;
Published | property OnKeyPress: TKeyPressEvent read FOnKeyPress write SetOnKeyPress;
Published | property OnKeyUp: TKeyEvent read FOnKeyUp write SetOnKeyUp;
Published | property OnMouseDown: TMouseEvent read FOnMouseDown write SetOnMouseDown;
Published | property OnMouseMove: TMouseMoveEvent read FOnMouseMove write SetOnMouseMove;
Published | property OnMouseUp: TMouseEvent read FOnMouseUp write SetOnMouseUp;
Published | property OnMouseWheel: TMouseWheelEvent read FOnMouseWheel write SetOnMouseWheel;
Published | property OnMouseWheelDown: TMouseWheelUpDownEvent read FOnMouseWheelDown write SetOnMouseWheelDown;
Published | property OnMouseWheelUp: TMouseWheelUpDownEvent read FOnMouseWheelUp write SetOnMouseWheelUp;
Published | property PopupMenu: TPopupMenu read FPopupMenu write SetPopupMenu;
Published | property RefreshRate: Integer read FRefreshRate write FRefreshRate;
Public | property RenderDC: HWND read FOwnDC;
Published | property ScreenDepth: TGLScreenDepth read FScreenDepth write SetScreenDepth default sd32bits;
Published | property StayOnTop: Boolean read FStayOnTop write SetStayOnTop default False;
Published | property VSync: TVSyncMode read FVSync write FVSync default vsmSync;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function FramesPerSecond: Single;
Public function FramesPerSecondText(decimals: Integer = 1): String;
Public function LastFrameTime: Single;
Protected function GetHandle: HWND;
Public procedure BeginUpdate;
Public procedure EndUpdate;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure ReActivate;
Public procedure Render(baseObject: TGLBaseSceneObject = nil); override;
Public procedure ResetPerformanceMonitor;
Public procedure UseCurrentResolution;
Protected procedure BindFormEvents;
Protected procedure DoActivate(Sender: TObject);
Protected procedure DoBeforeRender(Sender: TObject);
Protected procedure DoBufferChange(Sender: TObject); override;
Protected procedure DoBufferStructuralChange(Sender: TObject); override;
Protected procedure DoCloseQuery(Sender: TObject; var CanClose: Boolean);
Protected procedure DoDeactivate(Sender: TObject);
Protected procedure DoFormDestroy(Sender: TObject);
Protected procedure DoPaint(Sender: TObject);
Protected procedure Shutdown;
Protected procedure Startup;

Properties

Public property Active: Boolean read FActive write SetActive;
Published property Cursor: TCursor read FCursor write SetCursor default crDefault;
Published property Form: TForm read FForm write SetForm;
Public property Handle: HWND read GetHandle;
Published property ManualRendering: Boolean read FManualRendering write SetManualRendering;
Published property OnClick: TNotifyEvent read FOnClick write SetOnClick;
Published property OnClose: TCloseEvent read FOnClose write SetOnClose;
Published property OnCloseQuery: TCloseQueryEvent read FOnCloseQuery write SetOnCloseQuery;
Published property OnDblClick: TNotifyEvent read FOnDblClick write SetOnDblClick;
Published property OnKeyDown: TKeyEvent read FOnKeyDown write SetOnKeyDown;
Published property OnKeyPress: TKeyPressEvent read FOnKeyPress write SetOnKeyPress;
Published property OnKeyUp: TKeyEvent read FOnKeyUp write SetOnKeyUp;
Published property OnMouseDown: TMouseEvent read FOnMouseDown write SetOnMouseDown;
Published property OnMouseMove: TMouseMoveEvent read FOnMouseMove write SetOnMouseMove;
Published property OnMouseUp: TMouseEvent read FOnMouseUp write SetOnMouseUp;
Published property OnMouseWheel: TMouseWheelEvent read FOnMouseWheel write SetOnMouseWheel;
Published property OnMouseWheelDown: TMouseWheelUpDownEvent read FOnMouseWheelDown write SetOnMouseWheelDown;
Published property OnMouseWheelUp: TMouseWheelUpDownEvent read FOnMouseWheelUp write SetOnMouseWheelUp;
Published property PopupMenu: TPopupMenu read FPopupMenu write SetPopupMenu;
Published property RefreshRate: Integer read FRefreshRate write FRefreshRate;
Public property RenderDC: HWND read FOwnDC;
Published property ScreenDepth: TGLScreenDepth read FScreenDepth write SetScreenDepth default sd32bits;
Published property StayOnTop: Boolean read FStayOnTop write SetStayOnTop default False;
Published property VSync: TVSyncMode read FVSync write FVSync default vsmSync;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:21


GLScene v.1.1.2: GLGameMenu

Unit GLGameMenu

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLGameMenu<p>

Manages a basic game menu UI<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>31/05/10 - Yar - Fixed for Linux x64 <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>04/09/07 - DaStr - Fixed memory leak in TGLGameMenu (BugtrackerID = 1787617) (thanks Pierre Lemerle) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>26/03/07 - DaveK - back to TGLSceneObject for Material support <li>16/02/07 - DaStr & DaveK - TGLGameMenu.MouseMenuSelect bugfixed (again) Component made descendant of TGLBaseSceneObject IGLMaterialLibrarySupported added <li>20/12/06 - DaStr - TGLGameMenu.MouseMenuSelect bugfixed (thanks to Predator) <li>03/27/06 - DaveK - added mouse selection support <li>03/03/05 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLGameMenu |

Types

TGLGameMenuScale = (...);

Description

Types

TGLGameMenuScale = (...);
Values
  • gmsNormal:
  • gms1024x768:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:21


GLScene v.1.1.2: GLGameMenu: Class TGLGameMenu

Class TGLGameMenu

Unit

GLGameMenu

Declaration

type TGLGameMenu = class(TGLSceneObject, IGLMaterialLibrarySupported)

Description

Classic game menu interface made of several lines.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLGameMenu

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function GetEnabled(AIndex: Integer): Boolean;
Protected | function GetSelectedText: string;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure MouseMenuSelect(const X, Y: integer);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure SelectNext;
Public | procedure SelectPrev;
Protected | procedure ItemsChanged(Sender: TObject);
Protected | procedure SetActiveColor(AValue: TGLColor);
Protected | procedure SetBackColor(AValue: TGLColor);
Protected | procedure SetDisabledColor(AValue: TGLColor);
Protected | procedure SetEnabled(AIndex: Integer; AValue: Boolean);
Protected | procedure SetFont(AValue: TGLCustomBitmapFont);
Protected | procedure SetInactiveColor(AValue: TGLColor);
Protected | procedure SetItems(AValue: TStrings);
Protected | procedure SetMarginHorz(AValue: Integer);
Protected | procedure SetMarginVert(AValue: Integer);
Protected | procedure SetMaterialLibrary(AValue: TGLMaterialLibrary);
Protected | procedure SetMenuScale(AValue: TGLGameMenuScale);
Protected | procedure SetSelected(AValue: Integer);
Protected | procedure SetSpacing(AValue: Integer);
Protected | procedure SetTitleHeight(AValue: Integer);
Protected | procedure SetTitleMaterialName(const AValue: string);
Protected | procedure SetTitleWidth(AValue: Integer);

Properties

Published | property ActiveColor: TGLColor read FActiveColor write SetActiveColor;
Published | property BackColor: TGLColor read FBackColor write SetBackColor;
Published | property Behaviours;
Published | property BoxBottom: integer read FBoxBottom;
Published | property BoxLeft: integer read FBoxLeft;
Published | property BoxRight: integer read FBoxRight;
Published | property BoxTop: integer read FBoxTop;
Published | property DisabledColor: TGLColor read FDisabledColor write SetDisabledColor;
Published | property Effects;
Public | property Enabled[AIndex: Integer]: Boolean read GetEnabled write SetEnabled;
Published | property Font: TGLCustomBitmapFont read FFont write SetFont;
Published | property InactiveColor: TGLColor read FInactiveColor write SetInactiveColor;
Published | property Items: TStrings read FItems write SetItems;
Published | property MarginHorz: Integer read FMarginHorz write SetMarginHorz default 16;
Published | property MarginVert: Integer read FMarginVert write SetMarginVert default 16;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MenuScale: TGLGameMenuScale read FMenuScale write SetMenuScale default gmsNormal;
Published | property MenuTop: integer read FMenuTop;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property OnSelectedChanged: TNotifyEvent read FOnSelectedChanged write FOnSelectedChanged;
Published | property Position;
Published | property Selected: Integer read FSelected write SetSelected default -1;
Public | property SelectedText: string read GetSelectedText;
Published | property Spacing: Integer read FSpacing write SetSpacing default 16;
Published | property TitleHeight: Integer read FTitleHeight write SetTitleHeight default 0;
Published | property TitleMaterialName: string read FTitleMaterialName write SetTitleMaterialName;
Published | property TitleWidth: Integer read FTitleWidth write SetTitleWidth default 0;
Published | property VisibilityCulling;
Published | property Visible;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function GetEnabled(AIndex: Integer): Boolean;
Protected function GetSelectedText: string;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure MouseMenuSelect(const X, Y: integer);
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure SelectNext;
Public procedure SelectPrev;
Protected procedure ItemsChanged(Sender: TObject);
Protected procedure SetActiveColor(AValue: TGLColor);
Protected procedure SetBackColor(AValue: TGLColor);
Protected procedure SetDisabledColor(AValue: TGLColor);
Protected procedure SetEnabled(AIndex: Integer; AValue: Boolean);
Protected procedure SetFont(AValue: TGLCustomBitmapFont);
Protected procedure SetInactiveColor(AValue: TGLColor);
Protected procedure SetItems(AValue: TStrings);
Protected procedure SetMarginHorz(AValue: Integer);
Protected procedure SetMarginVert(AValue: Integer);
Protected procedure SetMaterialLibrary(AValue: TGLMaterialLibrary);
Protected procedure SetMenuScale(AValue: TGLGameMenuScale);
Protected procedure SetSelected(AValue: Integer);
Protected procedure SetSpacing(AValue: Integer);
Protected procedure SetTitleHeight(AValue: Integer);
Protected procedure SetTitleMaterialName(const AValue: string);
Protected procedure SetTitleWidth(AValue: Integer);

Properties

Published property ActiveColor: TGLColor read FActiveColor write SetActiveColor;
Published property BackColor: TGLColor read FBackColor write SetBackColor;
Published property Behaviours;
Published property BoxBottom: integer read FBoxBottom;
Published property BoxLeft: integer read FBoxLeft;
Published property BoxRight: integer read FBoxRight;
Published property BoxTop: integer read FBoxTop;
Published property DisabledColor: TGLColor read FDisabledColor write SetDisabledColor;
Published property Effects;
Public property Enabled[AIndex: Integer]: Boolean read GetEnabled write SetEnabled;
Published property Font: TGLCustomBitmapFont read FFont write SetFont;
Published property InactiveColor: TGLColor read FInactiveColor write SetInactiveColor;
Published property Items: TStrings read FItems write SetItems;
Published property MarginHorz: Integer read FMarginHorz write SetMarginHorz default 16;
Published property MarginVert: Integer read FMarginVert write SetMarginVert default 16;
Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published property MenuScale: TGLGameMenuScale read FMenuScale write SetMenuScale default gmsNormal;
Published property MenuTop: integer read FMenuTop;
Published property ObjectsSorting;
Published property OnProgress;
Published property OnSelectedChanged: TNotifyEvent read FOnSelectedChanged write FOnSelectedChanged;
Published property Position;
Published property Selected: Integer read FSelected write SetSelected default -1;
Public property SelectedText: string read GetSelectedText;
Published property Spacing: Integer read FSpacing write SetSpacing default 16;
Published property TitleHeight: Integer read FTitleHeight write SetTitleHeight default 0;
Published property TitleMaterialName: string read FTitleMaterialName write SetTitleMaterialName;
Published property TitleWidth: Integer read FTitleWidth write SetTitleWidth default 0;
Published property VisibilityCulling;
Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:21


GLScene v.1.1.2: GLGeomObjects

Unit GLGeomObjects

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLDisk |
Class TGLCylinderBase |
Class TGLCone |
Class TGLCylinder |
Class TGLCapsule |
Class TGLAnnulus |
Class TGLTorus |
Class TGLArrowLine |
Class TGLArrowArc |
Class TGLPolygon |
Class TGLFrustrum |

Types

TConePart = (...);
TConeParts = set of TConePart;
TCylinderPart = (...);
TCylinderParts = set of TCylinderPart;
TCylinderAlignment = (...);
TAnnulusPart = (...);
TAnnulusParts = set of TAnnulusPart;
TTorusPart = (...);
TTorusParts = set of TTorusPart;
TArrowLinePart = (...);
TArrowLineParts = set of TArrowLinePart;
TArrowHeadStackingStyle = (...);
TArrowArcPart = (...);
TArrowArcParts = set of TArrowArcPart;
TPolygonPart = (...);
TPolygonParts = set of TPolygonPart;
TFrustrumPart = (...);
TFrustrumParts = set of TFrustrumPart;

Constants

cAllFrustrumParts = [fpTop, fpBottom, fpFront, fpBack, fpLeft, fpRight];

Description

Types

TConePart = (...);
Values
  • coSides:
  • coBottom:
TConeParts = set of TConePart;
TCylinderPart = (...);
Values
  • cySides:
  • cyBottom:
  • cyTop:
TCylinderParts = set of TCylinderPart;
TCylinderAlignment = (...);
Values
  • caCenter:
  • caTop:
  • caBottom:
TAnnulusPart = (...);
Values
  • anInnerSides:
  • anOuterSides:
  • anBottom:
  • anTop:
TAnnulusParts = set of TAnnulusPart;
TTorusPart = (...);
Values
  • toSides:
  • toStartDisk:
  • toStopDisk:
TTorusParts = set of TTorusPart;
TArrowLinePart = (...);
Values
  • alLine:
  • alTopArrow:
  • alBottomArrow:
TArrowLineParts = set of TArrowLinePart;
TArrowHeadStackingStyle = (...);
Values
  • ahssStacked:
  • ahssCentered:
  • ahssIncluded:
TArrowArcPart = (...);
Values
  • aaArc:
  • aaTopArrow:
  • aaBottomArrow:
TArrowArcParts = set of TArrowArcPart;
TPolygonPart = (...);
Values
  • ppTop:
  • ppBottom:
TPolygonParts = set of TPolygonPart;
TFrustrumPart = (...);
Values
  • fpTop:
  • fpBottom:
  • fpFront:
  • fpBack:
  • fpLeft:
  • fpRight:
TFrustrumParts = set of TFrustrumPart;

Constants

cAllFrustrumParts = [fpTop, fpBottom, fpFront, fpBack, fpLeft, fpRight];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:21


GLScene v.1.1.2: GLGeomObjects: Class TGLDisk

Class TGLDisk

Unit

GLGeomObjects

Declaration

type TGLDisk = class(TGLQuadricObject)

Description

no description available, TGLQuadricObject description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLDisk

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Published | property InnerRadius: TGLFloat read FInnerRadius write SetInnerRadius;
Published | property Loops: TGLInt read FLoops write SetLoops default 2;
Published | property OuterRadius: TGLFloat read FOuterRadius write SetOuterRadius;
Published | property Slices: TGLInt read FSlices write SetSlices default 16;
Published | property StartAngle: TGLFloat read FStartAngle write SetStartAngle;
Published | property SweepAngle: TGLFloat read FSweepAngle write SetSweepAngle;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Published property InnerRadius: TGLFloat read FInnerRadius write SetInnerRadius;
Published property Loops: TGLInt read FLoops write SetLoops default 2;
Published property OuterRadius: TGLFloat read FOuterRadius write SetOuterRadius;
Published property Slices: TGLInt read FSlices write SetSlices default 16;
Published property StartAngle: TGLFloat read FStartAngle write SetStartAngle;
Published property SweepAngle: TGLFloat read FSweepAngle write SetSweepAngle;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:21


GLScene v.1.1.2: GLGeomObjects: Class TGLCylinderBase

Class TGLCylinderBase

Unit

GLGeomObjects

Declaration

type TGLCylinderBase = class(TGLQuadricObject)

Description

no description available, TGLQuadricObject description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLCylinderBase

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;
Protected | function GetTopRadius: Single; virtual;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure SetBottomRadius(const aValue: Single);
Protected | procedure SetHeight(const aValue: Single);
Protected | procedure SetLoops(aValue: TGLInt);
Protected | procedure SetSlices(aValue: TGLInt);
Protected | procedure SetStacks(aValue: TGLInt);

Properties

Published | property BottomRadius: TGLFloat read FBottomRadius write SetBottomRadius;
Published | property Height: TGLFloat read FHeight write SetHeight;
Published | property Loops: TGLInt read FLoops write SetLoops default 1;
Published | property Slices: TGLInt read FSlices write SetSlices default 16;
Published | property Stacks: TGLInt read FStacks write SetStacks default 4;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;
Protected function GetTopRadius: Single; virtual;
Public procedure Assign(Source: TPersistent); override;
Protected procedure SetBottomRadius(const aValue: Single);
Protected procedure SetHeight(const aValue: Single);
Protected procedure SetLoops(aValue: TGLInt);
Protected procedure SetSlices(aValue: TGLInt);
Protected procedure SetStacks(aValue: TGLInt);

Properties

Published property BottomRadius: TGLFloat read FBottomRadius write SetBottomRadius;
Published property Height: TGLFloat read FHeight write SetHeight;
Published property Loops: TGLInt read FLoops write SetLoops default 1;
Published property Slices: TGLInt read FSlices write SetSlices default 16;
Published property Stacks: TGLInt read FStacks write SetStacks default 4;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:21


GLScene v.1.1.2: GLGeomObjects: Class TGLCone

Class TGLCone

Unit

GLGeomObjects

Declaration

type TGLCone = class(TGLCylinderBase)

Description

no description available, TGLCylinderBase description follows
no description available, TGLQuadricObject description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLCylinderBase
  • TGLCone

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Protected | function GetTopRadius: Single; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure SetParts(aValue: TConeParts);

Properties

Published property Parts: TConeParts read FParts write SetParts default [coSides, coBottom];

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Protected function GetTopRadius: Single; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure SetParts(aValue: TConeParts);

Properties

Published property Parts: TConeParts read FParts write SetParts default [coSides, coBottom];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:21


GLScene v.1.1.2: GLGeomObjects: Class TGLCylinder

Class TGLCylinder

Unit

GLGeomObjects

Declaration

type TGLCylinder = class(TGLCylinderBase)

Description

no description available, TGLCylinderBase description follows
no description available, TGLQuadricObject description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLCylinderBase
  • TGLCylinder

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Protected | function GetTopRadius: Single; override;
Public | procedure Align(const startPoint, endPoint: TAffineVector); overload;
Public | procedure Align(const startObj, endObj: TGLBaseSceneObject); overload;
Public | procedure Align(const startPoint, endPoint: TVector); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure SetAlignment(val: TCylinderAlignment);
Protected | procedure SetParts(aValue: TCylinderParts);
Protected | procedure SetTopRadius(const aValue: Single);

Properties

Published | property Alignment: TCylinderAlignment read FAlignment write SetAlignment default caCenter;
Published | property Parts: TCylinderParts read FParts write SetParts default [cySides, cyBottom, cyTop];
Published | property TopRadius: TGLFloat read FTopRadius write SetTopRadius;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Protected function GetTopRadius: Single; override;
Public procedure Align(const startPoint, endPoint: TAffineVector); overload;
Public procedure Align(const startObj, endObj: TGLBaseSceneObject); overload;
Public procedure Align(const startPoint, endPoint: TVector); overload;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure SetAlignment(val: TCylinderAlignment);
Protected procedure SetParts(aValue: TCylinderParts);
Protected procedure SetTopRadius(const aValue: Single);

Properties

Published property Alignment: TCylinderAlignment read FAlignment write SetAlignment default caCenter;
Published property Parts: TCylinderParts read FParts write SetParts default [cySides, cyBottom, cyTop];
Published property TopRadius: TGLFloat read FTopRadius write SetTopRadius;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:21


GLScene v.1.1.2: GLGeomObjects: Class TGLCapsule

Class TGLCapsule

Unit

GLGeomObjects

Declaration

type TGLCapsule = class(TGLSceneObject)

Description

no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLCapsule

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public | procedure Align(const startPoint, endPoint: TVector); overload;
Public | procedure Align(const startPoint, endPoint: TAffineVector); overload;
Public | procedure Align(const startObj, endObj: TGLBaseSceneObject); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure SetAlignment(val: TCylinderAlignment);
Protected | procedure SetHeight(const aValue: Single);
Protected | procedure SetParts(aValue: TCylinderParts);
Protected | procedure SetRadius(const aValue: Single);
Protected | procedure SetSlices(const aValue: integer);
Protected | procedure SetStacks(const aValue: integer);

Properties

Published | property Alignment: TCylinderAlignment read FAlignment write SetAlignment default caCenter;
Published | property Height: TGLFloat read FHeight write SetHeight;
Published | property Parts: TCylinderParts read FParts write SetParts default [cySides, cyBottom, cyTop];
Published | property Radius: TGLFloat read FRadius write SetRadius;
Published | property Slices: TGLInt read FSlices write SetSlices;
Published | property Stacks: TGLInt read FStacks write SetStacks;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public procedure Align(const startPoint, endPoint: TVector); overload;
Public procedure Align(const startPoint, endPoint: TAffineVector); overload;
Public procedure Align(const startObj, endObj: TGLBaseSceneObject); overload;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure SetAlignment(val: TCylinderAlignment);
Protected procedure SetHeight(const aValue: Single);
Protected procedure SetParts(aValue: TCylinderParts);
Protected procedure SetRadius(const aValue: Single);
Protected procedure SetSlices(const aValue: integer);
Protected procedure SetStacks(const aValue: integer);

Properties

Published property Alignment: TCylinderAlignment read FAlignment write SetAlignment default caCenter;
Published property Height: TGLFloat read FHeight write SetHeight;
Published property Parts: TCylinderParts read FParts write SetParts default [cySides, cyBottom, cyTop];
Published property Radius: TGLFloat read FRadius write SetRadius;
Published property Slices: TGLInt read FSlices write SetSlices;
Published property Stacks: TGLInt read FStacks write SetStacks;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:21


GLScene v.1.1.2: GLGeomObjects: Class TGLAnnulus

Class TGLAnnulus

Unit

GLGeomObjects

Declaration

type TGLAnnulus = class(TGLCylinderBase)

Description

no description available, TGLCylinderBase description follows
no description available, TGLQuadricObject description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLCylinderBase
  • TGLAnnulus

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure SetBottomInnerRadius(const aValue: Single);
Protected | procedure SetParts(aValue: TAnnulusParts);
Protected | procedure SetTopInnerRadius(const aValue: Single);
Protected | procedure SetTopRadius(const aValue: Single);

Properties

Published | property BottomInnerRadius: TGLFloat read FBottomInnerRadius write SetBottomInnerRadius;
Published | property Parts: TAnnulusParts read FParts write SetParts default [anInnerSides, anOuterSides, anBottom, anTop];
Published | property TopInnerRadius: TGLFloat read FTopInnerRadius write SetTopInnerRadius;
Published | property TopRadius: TGLFloat read FTopRadius write SetTopRadius;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure SetBottomInnerRadius(const aValue: Single);
Protected procedure SetParts(aValue: TAnnulusParts);
Protected procedure SetTopInnerRadius(const aValue: Single);
Protected procedure SetTopRadius(const aValue: Single);

Properties

Published property BottomInnerRadius: TGLFloat read FBottomInnerRadius write SetBottomInnerRadius;
Published property Parts: TAnnulusParts read FParts write SetParts default [anInnerSides, anOuterSides, anBottom, anTop];
Published property TopInnerRadius: TGLFloat read FTopInnerRadius write SetTopInnerRadius;
Published property TopRadius: TGLFloat read FTopRadius write SetTopRadius;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:21


GLScene v.1.1.2: GLGeomObjects: Class TGLTorus

Class TGLTorus

Unit

GLGeomObjects

Declaration

type TGLTorus = class(TGLSceneObject)

Description

no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLTorus

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure SetMajorRadius(const aValue: Single);
Protected | procedure SetMinorRadius(const aValue: Single);
Protected | procedure SetParts(aValue: TTorusParts);
Protected | procedure SetRings(aValue: Cardinal);
Protected | procedure SetSides(aValue: Cardinal);
Protected | procedure SetStartAngle(const aValue: Single);
Protected | procedure SetStopAngle(const aValue: Single);

Properties

Published | property MajorRadius: Single read FMajorRadius write SetMajorRadius;
Published | property MinorRadius: Single read FMinorRadius write SetMinorRadius;
Published | property Parts: TTorusParts read FParts write SetParts default [toSides];
Published | property Rings: Cardinal read FRings write SetRings default 25;
Published | property Sides: Cardinal read FSides write SetSides default 15;
Published | property StartAngle: Single read FStartAngle write SetStartAngle;
Published | property StopAngle: Single read FStopAngle write SetStopAngle;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure SetMajorRadius(const aValue: Single);
Protected procedure SetMinorRadius(const aValue: Single);
Protected procedure SetParts(aValue: TTorusParts);
Protected procedure SetRings(aValue: Cardinal);
Protected procedure SetSides(aValue: Cardinal);
Protected procedure SetStartAngle(const aValue: Single);
Protected procedure SetStopAngle(const aValue: Single);

Properties

Published property MajorRadius: Single read FMajorRadius write SetMajorRadius;
Published property MinorRadius: Single read FMinorRadius write SetMinorRadius;
Published property Parts: TTorusParts read FParts write SetParts default [toSides];
Published property Rings: Cardinal read FRings write SetRings default 25;
Published property Sides: Cardinal read FSides write SetSides default 15;
Published property StartAngle: Single read FStartAngle write SetStartAngle;
Published property StopAngle: Single read FStopAngle write SetStopAngle;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:22


GLScene v.1.1.2: GLGeomObjects: Class TGLArrowLine

Class TGLArrowLine

Unit

GLGeomObjects

Declaration

type TGLArrowLine = class(TGLCylinderBase)

Description

no description available, TGLCylinderBase description follows
no description available, TGLQuadricObject description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLCylinderBase
  • TGLArrowLine

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure SetBottomArrowHeadHeight(const aValue: Single);
Protected | procedure SetBottomArrowHeadRadius(const aValue: Single);
Protected | procedure SetHeadStackingStyle(const val: TArrowHeadStackingStyle);
Protected | procedure SetParts(aValue: TArrowLineParts);
Protected | procedure SetTopArrowHeadHeight(const aValue: Single);
Protected | procedure SetTopArrowHeadRadius(const aValue: Single);
Protected | procedure SetTopRadius(const aValue: Single);

Properties

Published | property BottomArrowHeadHeight: TGLFloat read fBottomArrowHeadHeight write SetBottomArrowHeadHeight;
Published | property BottomArrowHeadRadius: TGLFloat read fBottomArrowHeadRadius write SetBottomArrowHeadRadius;
Published | property HeadStackingStyle: TArrowHeadStackingStyle read FHeadStackingStyle write SetHeadStackingStyle default ahssStacked;
Published | property Parts: TArrowLineParts read FParts write SetParts default [alLine, alTopArrow];
Published | property TopArrowHeadHeight: TGLFloat read fTopArrowHeadHeight write SetTopArrowHeadHeight;
Published | property TopArrowHeadRadius: TGLFloat read fTopArrowHeadRadius write SetTopArrowHeadRadius;
Published | property TopRadius: TGLFloat read FTopRadius write SetTopRadius;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure SetBottomArrowHeadHeight(const aValue: Single);
Protected procedure SetBottomArrowHeadRadius(const aValue: Single);
Protected procedure SetHeadStackingStyle(const val: TArrowHeadStackingStyle);
Protected procedure SetParts(aValue: TArrowLineParts);
Protected procedure SetTopArrowHeadHeight(const aValue: Single);
Protected procedure SetTopArrowHeadRadius(const aValue: Single);
Protected procedure SetTopRadius(const aValue: Single);

Properties

Published property BottomArrowHeadHeight: TGLFloat read fBottomArrowHeadHeight write SetBottomArrowHeadHeight;
Published property BottomArrowHeadRadius: TGLFloat read fBottomArrowHeadRadius write SetBottomArrowHeadRadius;
Published property HeadStackingStyle: TArrowHeadStackingStyle read FHeadStackingStyle write SetHeadStackingStyle default ahssStacked;
Published property Parts: TArrowLineParts read FParts write SetParts default [alLine, alTopArrow];
Published property TopArrowHeadHeight: TGLFloat read fTopArrowHeadHeight write SetTopArrowHeadHeight;
Published property TopArrowHeadRadius: TGLFloat read fTopArrowHeadRadius write SetTopArrowHeadRadius;
Published property TopRadius: TGLFloat read FTopRadius write SetTopRadius;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:22


GLScene v.1.1.2: GLGeomObjects: Class TGLArrowArc

Class TGLArrowArc

Unit

GLGeomObjects

Declaration

type TGLArrowArc = class(TGLCylinderBase)

Description

no description available, TGLCylinderBase description follows
no description available, TGLQuadricObject description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLCylinderBase
  • TGLArrowArc

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure SetArcRadius(const aValue: Single);
Protected | procedure SetBottomArrowHeadHeight(const aValue: Single);
Protected | procedure SetBottomArrowHeadRadius(const aValue: Single);
Protected | procedure SetHeadStackingStyle(const val: TArrowHeadStackingStyle);
Protected | procedure SetParts(aValue: TArrowArcParts);
Protected | procedure SetStartAngle(const aValue: Single);
Protected | procedure SetStopAngle(const aValue: Single);
Protected | procedure SetTopArrowHeadHeight(const aValue: Single);
Protected | procedure SetTopArrowHeadRadius(const aValue: Single);
Protected | procedure SetTopRadius(const aValue: Single);

Properties

Published | property ArcRadius: TGLFloat read fArcRadius write SetArcRadius;
Published | property BottomArrowHeadHeight: TGLFloat read fBottomArrowHeadHeight write SetBottomArrowHeadHeight;
Published | property BottomArrowHeadRadius: TGLFloat read fBottomArrowHeadRadius write SetBottomArrowHeadRadius;
Published | property HeadStackingStyle: TArrowHeadStackingStyle read FHeadStackingStyle write SetHeadStackingStyle default ahssStacked;
Published | property Parts: TArrowArcParts read FParts write SetParts default [aaArc, aaTopArrow];
Published | property StartAngle: TGLFloat read FStartAngle write SetStartAngle;
Published | property StopAngle: TGLFloat read FStopAngle write SetStopAngle;
Published | property TopArrowHeadHeight: TGLFloat read fTopArrowHeadHeight write SetTopArrowHeadHeight;
Published | property TopArrowHeadRadius: TGLFloat read fTopArrowHeadRadius write SetTopArrowHeadRadius;
Published | property TopRadius: TGLFloat read FTopRadius write SetTopRadius;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure SetArcRadius(const aValue: Single);
Protected procedure SetBottomArrowHeadHeight(const aValue: Single);
Protected procedure SetBottomArrowHeadRadius(const aValue: Single);
Protected procedure SetHeadStackingStyle(const val: TArrowHeadStackingStyle);
Protected procedure SetParts(aValue: TArrowArcParts);
Protected procedure SetStartAngle(const aValue: Single);
Protected procedure SetStopAngle(const aValue: Single);
Protected procedure SetTopArrowHeadHeight(const aValue: Single);
Protected procedure SetTopArrowHeadRadius(const aValue: Single);
Protected procedure SetTopRadius(const aValue: Single);

Properties

Published property ArcRadius: TGLFloat read fArcRadius write SetArcRadius;
Published property BottomArrowHeadHeight: TGLFloat read fBottomArrowHeadHeight write SetBottomArrowHeadHeight;
Published property BottomArrowHeadRadius: TGLFloat read fBottomArrowHeadRadius write SetBottomArrowHeadRadius;
Published property HeadStackingStyle: TArrowHeadStackingStyle read FHeadStackingStyle write SetHeadStackingStyle default ahssStacked;
Published property Parts: TArrowArcParts read FParts write SetParts default [aaArc, aaTopArrow];
Published property StartAngle: TGLFloat read FStartAngle write SetStartAngle;
Published property StopAngle: TGLFloat read FStopAngle write SetStopAngle;
Published property TopArrowHeadHeight: TGLFloat read fTopArrowHeadHeight write SetTopArrowHeadHeight;
Published property TopArrowHeadRadius: TGLFloat read fTopArrowHeadRadius write SetTopArrowHeadRadius;
Published property TopRadius: TGLFloat read FTopRadius write SetTopRadius;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:22


GLScene v.1.1.2: GLGeomObjects: Class TGLPolygon

Class TGLPolygon

Unit

GLGeomObjects

Declaration

type TGLPolygon = class(TGLPolygonBase)

Description

no description available, TGLPolygonBase description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPolygonBase
  • TGLPolygon

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure SetParts(const val: TPolygonParts);

Properties

Published property Parts: TPolygonParts read FParts write SetParts default [ppTop, ppBottom];

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure SetParts(const val: TPolygonParts);

Properties

Published property Parts: TPolygonParts read FParts write SetParts default [ppTop, ppBottom];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:22


GLScene v.1.1.2: GLGeomObjects: Class TGLFrustrum

Class TGLFrustrum

Unit

GLGeomObjects

Declaration

type TGLFrustrum = class(TGLSceneObject)

Description

no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLFrustrum

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedBoundingBoxUnscaled: TAABB;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function TopDepth: TGLFloat;
Public | function TopWidth: TGLFloat;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure DefineProperties(Filer: TFiler); override;
Protected | procedure ReadData(Stream: TStream);
Protected | procedure WriteData(Stream: TStream);

Properties

Published | property ApexHeight: TGLFloat read FApexHeight write SetApexHeight stored False;
Published | property BaseDepth: TGLFloat read FBaseDepth write SetBaseDepth stored False;
Published | property BaseWidth: TGLFloat read FBaseWidth write SetBaseWidth stored False;
Published | property Height: TGLFloat read FHeight write SetHeight stored False;
Published | property NormalDirection: TNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Parts: TFrustrumParts read FParts write SetParts default cAllFrustrumParts;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function AxisAlignedBoundingBoxUnscaled: TAABB;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function TopDepth: TGLFloat;
Public function TopWidth: TGLFloat;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure DefineProperties(Filer: TFiler); override;
Protected procedure ReadData(Stream: TStream);
Protected procedure WriteData(Stream: TStream);

Properties

Published property ApexHeight: TGLFloat read FApexHeight write SetApexHeight stored False;
Published property BaseDepth: TGLFloat read FBaseDepth write SetBaseDepth stored False;
Published property BaseWidth: TGLFloat read FBaseWidth write SetBaseWidth stored False;
Published property Height: TGLFloat read FHeight write SetHeight stored False;
Published property NormalDirection: TNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published property Parts: TFrustrumParts read FParts write SetParts default cAllFrustrumParts;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:22


GLScene v.1.1.2: GLGizmo

Unit GLGizmo

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLGizmoUndoItem |
Class TGLGizmoUndoCollection |
Class TGLGizmoRayCastHitData |
Class TGLGizmoPickCube |
Class TGLGizmoPickTorus |
Class TGLGizmo |

Types

TGLGizmoElement = (...);
TGLGizmoElements = set of TGLGizmoElement;
TGLGizmoVisibleInfoLabel = (...);
TGLGizmoVisibleInfoLabels = set of TGLGizmoVisibleInfoLabel;
TGLGizmoAxis = (...);
TGLGizmoOperation = (...);
TGLGizmoAcceptEvent = procedure(Sender: TObject; var Obj: TGLBaseSceneObject; var Accept: Boolean; var Dimensions: TVector) of object;
TGLGizmoUpdateEvent = procedure(Sender: TObject; Obj: TGLBaseSceneObject; Axis: TGLGizmoAxis; Operation: TGLGizmoOperation; var Vector: TVector) of object;
TGLGizmoPickMode = (...);

Description

Types

TGLGizmoElement = (...);
Values
  • geMove:
  • geRotate:
  • geScale:
  • geAxisLabel:
  • geObjectInfos:
  • geBoundingBox:
TGLGizmoElements = set of TGLGizmoElement;
TGLGizmoVisibleInfoLabel = (...);
Values
  • vliName:
  • vliOperation:
  • vliCoords:
TGLGizmoVisibleInfoLabels = set of TGLGizmoVisibleInfoLabel;
TGLGizmoAxis = (...);
Values
  • gaNone:
  • gaX:
  • gaY:
  • gaZ:
  • gaXY:
  • gaXZ:
  • gaYZ:
TGLGizmoOperation = (...);
Values
  • gopMove:
  • gopRotate:
  • gopScale:
  • gopNone:
  • gpMoveGizmo:
  • GpRotateGizmo:
TGLGizmoAcceptEvent = procedure(Sender: TObject; var Obj: TGLBaseSceneObject; var Accept: Boolean; var Dimensions: TVector) of object;
TGLGizmoUpdateEvent = procedure(Sender: TObject; Obj: TGLBaseSceneObject; Axis: TGLGizmoAxis; Operation: TGLGizmoOperation; var Vector: TVector) of object;
TGLGizmoPickMode = (...);
Values
  • pmGetPickedObjects:
  • pmRayCast:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:22


GLScene v.1.1.2: GLGizmo: Class TGLGizmoUndoItem

Class TGLGizmoUndoItem

Unit

GLGizmo

Declaration

type TGLGizmoUndoItem = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLGizmoUndoItem

Overview

Methods

Public | constructor Create(AOwner: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetGizmo: TGLGizmo;
Protected | function GetParent: TGLGizmoUndoCollection;
Public | procedure AssignFromObject(const AObject: TGLCustomSceneObject);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); virtual;
Protected | procedure DoUndo; virtual;

Properties

Published | property EffectedObject: TGLCustomSceneObject read FEffectedObject write SetEffectedObject;
Published | property OldAutoScaling: TGLCoordinates read FOldAutoScaling write SetOldAutoScaling;
Published | property OldLibMaterialName: string read FOldLibMaterialName write FOldLibMaterialName;
Public | property OldMatrix: TMatrix read FOldMatrix write SetOldMatrix;

Description

Methods

Public constructor Create(AOwner: TCollection); override;
Public destructor Destroy; override;
Protected function GetGizmo: TGLGizmo;
Protected function GetParent: TGLGizmoUndoCollection;
Public procedure AssignFromObject(const AObject: TGLCustomSceneObject);
Public procedure Notification(AComponent: TComponent; Operation: TOperation); virtual;
Protected procedure DoUndo; virtual;

Properties

Published property EffectedObject: TGLCustomSceneObject read FEffectedObject write SetEffectedObject;
Published property OldAutoScaling: TGLCoordinates read FOldAutoScaling write SetOldAutoScaling;
Published property OldLibMaterialName: string read FOldLibMaterialName write FOldLibMaterialName;
Public property OldMatrix: TMatrix read FOldMatrix write SetOldMatrix;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:22


GLScene v.1.1.2: GLGizmo: Class TGLGizmoUndoCollection

Class TGLGizmoUndoCollection

Unit

GLGizmo

Declaration

type TGLGizmoUndoCollection = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLGizmoUndoCollection

Overview

Methods

Public | function Add: TGLGizmoUndoItem;
Protected | function GetParent: TGLGizmo;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation);
Public | procedure RemoveByObject(const AObject: TGLCustomSceneObject);

Properties

Public property Items[const Index: Integer]: TGLGizmoUndoItem read GetItems write SetItems;

Description

Methods

Public function Add: TGLGizmoUndoItem;
Protected function GetParent: TGLGizmo;
Public procedure Notification(AComponent: TComponent; Operation: TOperation);
Public procedure RemoveByObject(const AObject: TGLCustomSceneObject);

Properties

Public property Items[const Index: Integer]: TGLGizmoUndoItem read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:22


GLScene v.1.1.2: GLGizmo: Class TGLGizmoRayCastHitData

Class TGLGizmoRayCastHitData

Unit

GLGizmo

Declaration

type TGLGizmoRayCastHitData = class(TPersistent)

Description

Hierarchy

  • TPersistent
  • TGLGizmoRayCastHitData

Overview

Fields

Public | Obj: TGLBaseSceneObject;
Public | Point: TVector;

Description

Fields

Public Obj: TGLBaseSceneObject;
Public Point: TVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:22


GLScene v.1.1.2: GLGizmo: Class TGLGizmoPickCube

Class TGLGizmoPickCube

Unit

GLGizmo

Declaration

type TGLGizmoPickCube = class(TGLCube)

Description

no description available, TGLCube description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLCube
  • TGLGizmoPickCube
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:22


GLScene v.1.1.2: GLGizmo: Class TGLGizmoPickTorus

Class TGLGizmoPickTorus

Unit

GLGizmo

Declaration

type TGLGizmoPickTorus = class(TGLTorus)

Description

no description available, TGLTorus description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLTorus
  • TGLGizmoPickTorus
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:22


GLScene v.1.1.2: GLGizmo: Class TGLGizmo

Class TGLGizmo

Unit

GLGizmo

Declaration

type TGLGizmo = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLGizmo

Overview

Fields

Public PickableObjectsWithRayCast: TList;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetPickedObjectPoint(const Obj: TGLBaseSceneObject): TVector;
Public | procedure Loaded; override;
Public | procedure LooseSelection; virtual;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure SetVisible(const AValue: Boolean);
Public | procedure UndoAdd(const AObject: TGLCustomSceneObject);
Public | procedure UpdateGizmo(const NewDimensions: TVector); overload;
Public | procedure UpdateGizmo; overload;
Public | procedure ViewerMouseDown(const X, Y: Integer);
Public | procedure ViewerMouseMove(const X, Y: Integer);
Public | procedure ViewerMouseUp(const X, Y: Integer);

Properties

Published | property AutoZoom: Boolean read FAutoZoom write FAutoZoom;
Published | property AutoZoomFactor: Single read FAutoZoomFactor write FAutoZoomFactor;
Published | property BoundingBoxColor: TGLColor read FBoundingBoxColor write SetBoundingBoxColor;
Published | property Enabled: Boolean read FEnabled write FEnabled default False;
Published | property ExcludeObjects: Boolean read FExcludeObjects write FExcludeObjects;
Published | property ExcludeObjectsList: TStrings read FExcludeObjectsList write SetExcludeObjectsList;
Published | property ForceAxis: Boolean read FForceAxis write FForceAxis;
Published | property ForceOperation: Boolean read FForceOperation write FForceoperation;
Published | property ForceUniformScale: Boolean read FForceUniformScale write FForceUniformScale;
Published | property GizmoElements: TGLGizmoElements read FGizmoElements write SetGizmoElements;
Published | property GizmoThickness: Single read FGizmoThickness write SeTGLGizmoThickness;
Published | property LabelFont: TGLCustomBitmapFont read FLabelFont write SetLabelFont default nil;
Published | property MoveCoef: Single read FMoveCoef write FMoveCoef;
Published | property NoZWrite: Boolean read FNoZWrite write FNoZWrite;
Published | property OnBeforeSelect: TGLGizmoAcceptEvent read FOnBeforeSelect write FOnBeforeSelect;
Published | property OnBeforeUpdate: TGLGizmoUpdateEvent read FOnBeforeUpdate write FOnBeforeUpdate;
Published | property OnSelectionLost: TNotifyEvent read FOnSelectionLost write FOnSelectionLost;
Published | property Operation: TGLGizmoOperation read FOperation write FOperation;
Published | property PickMode: TGLGizmoPickMode read FPickMode write FPickMode default PmGetPickedObjects;
Public | property RootGizmo: TGLBaseSceneObject read FRootGizmo write SetRootGizmo;
Published | property RotationCoef: Single read FRotationCoef write FRotationCoef;
Published | property ScaleCoef: Single read FScaleCoef write FScaleCoef;
Published | property SelAxis: TGLGizmoAxis read FSelAxis write FSelAxis;
Published | property SelectedColor: TGLColor read FSelectedColor write SetSelectedColor;
Published | property SelectedObj: TGLBaseSceneObject read FSelectedObj write SetSelectedObj;
Published | property Viewer: TGLSceneViewer read FViewer write SetViewer;
Published | property VisibleInfoLabels: TGLGizmoVisibleInfoLabels read FVisibleVisibleInfoLabels write SeTGLGizmoVisibleInfoLabels;
Published | property VisibleInfoLabelsColor: TGLColor read FVisibleInfoLabelsColor write SetVisibleInfoLabelsColor;
Published | property ZoomFactor: Single read FZoomFactor write FZoomFactor;

Description

Fields

Public PickableObjectsWithRayCast: TList;

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function GetPickedObjectPoint(const Obj: TGLBaseSceneObject): TVector;
Public procedure Loaded; override;
Public procedure LooseSelection; virtual;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure SetVisible(const AValue: Boolean);
Public procedure UndoAdd(const AObject: TGLCustomSceneObject);
Public procedure UpdateGizmo(const NewDimensions: TVector); overload;
Public procedure UpdateGizmo; overload;
Public procedure ViewerMouseDown(const X, Y: Integer);
Public procedure ViewerMouseMove(const X, Y: Integer);
Public procedure ViewerMouseUp(const X, Y: Integer);

Properties

Published property AutoZoom: Boolean read FAutoZoom write FAutoZoom;
Published property AutoZoomFactor: Single read FAutoZoomFactor write FAutoZoomFactor;
Published property BoundingBoxColor: TGLColor read FBoundingBoxColor write SetBoundingBoxColor;
Published property Enabled: Boolean read FEnabled write FEnabled default False;
Published property ExcludeObjects: Boolean read FExcludeObjects write FExcludeObjects;
Published property ExcludeObjectsList: TStrings read FExcludeObjectsList write SetExcludeObjectsList;
Published property ForceAxis: Boolean read FForceAxis write FForceAxis;
Published property ForceOperation: Boolean read FForceOperation write FForceoperation;
Published property ForceUniformScale: Boolean read FForceUniformScale write FForceUniformScale;
Published property GizmoElements: TGLGizmoElements read FGizmoElements write SetGizmoElements;
Published property GizmoThickness: Single read FGizmoThickness write SeTGLGizmoThickness;
Published property LabelFont: TGLCustomBitmapFont read FLabelFont write SetLabelFont default nil;
Published property MoveCoef: Single read FMoveCoef write FMoveCoef;
Published property NoZWrite: Boolean read FNoZWrite write FNoZWrite;
Published property OnBeforeSelect: TGLGizmoAcceptEvent read FOnBeforeSelect write FOnBeforeSelect;
Published property OnBeforeUpdate: TGLGizmoUpdateEvent read FOnBeforeUpdate write FOnBeforeUpdate;
Published property OnSelectionLost: TNotifyEvent read FOnSelectionLost write FOnSelectionLost;
Published property Operation: TGLGizmoOperation read FOperation write FOperation;
Published property PickMode: TGLGizmoPickMode read FPickMode write FPickMode default PmGetPickedObjects;
Public property RootGizmo: TGLBaseSceneObject read FRootGizmo write SetRootGizmo;
Published property RotationCoef: Single read FRotationCoef write FRotationCoef;
Published property ScaleCoef: Single read FScaleCoef write FScaleCoef;
Published property SelAxis: TGLGizmoAxis read FSelAxis write FSelAxis;
Published property SelectedColor: TGLColor read FSelectedColor write SetSelectedColor;
Published property SelectedObj: TGLBaseSceneObject read FSelectedObj write SetSelectedObj;
Published property Viewer: TGLSceneViewer read FViewer write SetViewer;
Published property VisibleInfoLabels: TGLGizmoVisibleInfoLabels read FVisibleVisibleInfoLabels write SeTGLGizmoVisibleInfoLabels;
Published property VisibleInfoLabelsColor: TGLColor read FVisibleInfoLabelsColor write SetVisibleInfoLabelsColor;
Published property ZoomFactor: Single read FZoomFactor write FZoomFactor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:22


GLScene v.1.1.2: GLGizmoEx

Unit GLGizmoEx

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLGizmoExObjectItem |
Class TGLGizmoExObjectCollection |
Class TGLGizmoExActionHistoryItem |
Class TGLGizmoExActionHistoryCollection |
Class TGLGizmoExUIFrustrum |
Class TGLGizmoExUISphere |
Class TGLGizmoExUIDisk |
Class TGLGizmoExUITorus |
Class TGLGizmoExUIPolygon |
Class TGLGizmoExUIArrowLine |
Class TGLGizmoExUILines |
Class TGLGizmoExUIFlatText |
Class TGLGizmoEx |

Types

TGLGizmoExVisibleInfoLabel = (...);
TGLGizmoExVisibleInfoLabels = set of TGLGizmoExVisibleInfoLabel;
TInfoLabelCoordType = (...);
TGLGizmoExAxis = (...);
TGLGizmoExSelectionRegion = (...);
TGLGizmoExReferenceCoordinateSystem = (...);
TGLGizmoExSelRec = array of TPoint;
TGLGizmoExOperation = (...);
TGLGizmoExOperationMode = (...);
TGLGizmoExAcceptEvent = procedure(Sender: TObject; var objs: TGLPickList) of object;
TGLGizmoExAxisSelected = procedure(Sender: TObject; var Axis: TGLGizmoExAxis) of object;
TGLGizmoExPickMode = (...);

Description

Types

TGLGizmoExVisibleInfoLabel = (...);
Values
  • vliName:
  • vliOperation:
  • vliCoords:
TGLGizmoExVisibleInfoLabels = set of TGLGizmoExVisibleInfoLabel;
TInfoLabelCoordType = (...);
Values
  • ilcChanging:
  • ilcChangeRate:
TGLGizmoExAxis = (...);
Values
  • gaNone:
  • gaX:
  • gaY:
  • gaZ:
  • gaXY:
  • gaXZ:
  • gaYZ:
  • gaXYZ:
TGLGizmoExSelectionRegion = (...);
Values
  • gsrRectangular:
  • gsrCircular:
  • gsrFence:
  • gsrLasso:
TGLGizmoExReferenceCoordinateSystem = (...);
Values
  • rcsView:
  • rcsLocal:
TGLGizmoExSelRec = array of TPoint;
TGLGizmoExOperation = (...);
Values
  • gopMove:
  • gopRotate:
  • gopScale:
  • gopNone:
TGLGizmoExOperationMode = (...);
Values
  • gomNone:
  • gomSelect:
  • gomMove:
  • gomRotate:
  • gomScale:
TGLGizmoExAcceptEvent = procedure(Sender: TObject; var objs: TGLPickList) of object;
TGLGizmoExAxisSelected = procedure(Sender: TObject; var Axis: TGLGizmoExAxis) of object;
TGLGizmoExPickMode = (...);
Values
  • pmGetPickedObjects:
  • pmRayCast:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:22


GLScene v.1.1.2: GLGizmoEx: Class TGLGizmoExObjectItem

Class TGLGizmoExObjectItem

Unit

GLGizmoEx

Declaration

type TGLGizmoExObjectItem = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLGizmoExObjectItem

Overview

Methods

Public | constructor Create(AOwner: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetGizmo: TGLGizmoEx;
Protected | function GetParent: TGLGizmoExObjectCollection;
Public | procedure AssignFromObject(const AObject: TGLBaseSceneObject; AssignAndRemoveObj: Boolean = False);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); virtual;
Protected | procedure DoUndo;

Properties

Published | property EffectedObject: TGLBaseSceneobject read FEffectedObject write SetEffectedObject;
Public | property GizmoTmpRoot: TGLBaseSceneObject read FGizmoTmpRoot write FGizmoTmpRoot;
Public | property OldMatrix: TMatrix read FOldMatrix write SetOldMatrix;

Description

Methods

Public constructor Create(AOwner: TCollection); override;
Public destructor Destroy; override;
Protected function GetGizmo: TGLGizmoEx;
Protected function GetParent: TGLGizmoExObjectCollection;
Public procedure AssignFromObject(const AObject: TGLBaseSceneObject; AssignAndRemoveObj: Boolean = False);
Public procedure Notification(AComponent: TComponent; Operation: TOperation); virtual;
Protected procedure DoUndo;

Properties

Published property EffectedObject: TGLBaseSceneobject read FEffectedObject write SetEffectedObject;
Public property GizmoTmpRoot: TGLBaseSceneObject read FGizmoTmpRoot write FGizmoTmpRoot;
Public property OldMatrix: TMatrix read FOldMatrix write SetOldMatrix;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:22


GLScene v.1.1.2: GLGizmoEx: Class TGLGizmoExObjectCollection

Class TGLGizmoExObjectCollection

Unit

GLGizmoEx

Declaration

type TGLGizmoExObjectCollection = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLGizmoExObjectCollection

Overview

Methods

Public | function Add: TGLGizmoExObjectItem;
Protected | function GetParent: TGLGizmoEx;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation);
Public | procedure RemoveByObject(const AObject: TGLCustomSceneObject);
Protected | procedure DoUndo;

Properties

Public property Items[const Index: Integer]: TGLGizmoExObjectItem read GetItems write SetItems;

Description

Methods

Public function Add: TGLGizmoExObjectItem;
Protected function GetParent: TGLGizmoEx;
Public procedure Notification(AComponent: TComponent; Operation: TOperation);
Public procedure RemoveByObject(const AObject: TGLCustomSceneObject);
Protected procedure DoUndo;

Properties

Public property Items[const Index: Integer]: TGLGizmoExObjectItem read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGizmoEx: Class TGLGizmoExActionHistoryItem

Class TGLGizmoExActionHistoryItem

Unit

GLGizmoEx

Declaration

type TGLGizmoExActionHistoryItem = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLGizmoExActionHistoryItem

Overview

Methods

Public | constructor Create(AOwner: TCollection); override;
Public | destructor Destroy; override;

Properties

Public | property BaseObject: TObject read FObject write SetObject;
Public | property GizmoObjectCollection: TGLGizmoExObjectCollection read FGizmoObjectCollection write SetGizmoObjectCollection;

Description

Methods

Public constructor Create(AOwner: TCollection); override;
Public destructor Destroy; override;

Properties

Public property BaseObject: TObject read FObject write SetObject;
Public property GizmoObjectCollection: TGLGizmoExObjectCollection read FGizmoObjectCollection write SetGizmoObjectCollection;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGizmoEx: Class TGLGizmoExActionHistoryCollection

Class TGLGizmoExActionHistoryCollection

Unit

GLGizmoEx

Declaration

type TGLGizmoExActionHistoryCollection = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLGizmoExActionHistoryCollection

Overview

Methods

Public | constructor Create(AOwner: TPersistent; ItemClass: TCollectionItemClass);
Public | function Redo: TGLGizmoExActionHistoryItem;
Public | function Undo: TGLGizmoExActionHistoryItem;
Public | procedure AddObject(obj: TObject);
Public | procedure AddObjects(objs: TGLPickList);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation);
Public | procedure RemoveObjects(objs: TGLPickList);

Properties

Public | property GizmoTmpRoot: TGLBaseSceneObject read FGizmoTmpRoot write FGizmoTmpRoot;
Public | property ItemIndex: Integer read FItemIndex write FItemIndex;
Public | property Items[const Index: Integer]: TGLGizmoExActionHistoryItem read GetItems write SetItems;
Public | property MaxCount: Integer read FItemsMaxCount write FItemsMaxCount;

Description

Methods

Public constructor Create(AOwner: TPersistent; ItemClass: TCollectionItemClass);
Public function Redo: TGLGizmoExActionHistoryItem;
Public function Undo: TGLGizmoExActionHistoryItem;
Public procedure AddObject(obj: TObject);
Public procedure AddObjects(objs: TGLPickList);
Public procedure Notification(AComponent: TComponent; Operation: TOperation);
Public procedure RemoveObjects(objs: TGLPickList);

Properties

Public property GizmoTmpRoot: TGLBaseSceneObject read FGizmoTmpRoot write FGizmoTmpRoot;
Public property ItemIndex: Integer read FItemIndex write FItemIndex;
Public property Items[const Index: Integer]: TGLGizmoExActionHistoryItem read GetItems write SetItems;
Public property MaxCount: Integer read FItemsMaxCount write FItemsMaxCount;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGizmoEx: Class TGLGizmoExUIFrustrum

Class TGLGizmoExUIFrustrum

Unit

GLGizmoEx

Declaration

type TGLGizmoExUIFrustrum = class(TGLFrustrum)

Description

no description available, TGLFrustrum description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLFrustrum
  • TGLGizmoExUIFrustrum

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGizmoEx: Class TGLGizmoExUISphere

Class TGLGizmoExUISphere

Unit

GLGizmoEx

Declaration

type TGLGizmoExUISphere = class(TGLSphere)

Description

no description available, TGLSphere description follows
no description available, TGLQuadricObject description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLSphere
  • TGLGizmoExUISphere

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGizmoEx: Class TGLGizmoExUIDisk

Class TGLGizmoExUIDisk

Unit

GLGizmoEx

Declaration

type TGLGizmoExUIDisk = class(TGLDisk)

Description

no description available, TGLDisk description follows
no description available, TGLQuadricObject description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLDisk
  • TGLGizmoExUIDisk

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGizmoEx: Class TGLGizmoExUITorus

Class TGLGizmoExUITorus

Unit

GLGizmoEx

Declaration

type TGLGizmoExUITorus = class(TGLTorus)

Description

no description available, TGLTorus description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLTorus
  • TGLGizmoExUITorus

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGizmoEx: Class TGLGizmoExUIPolygon

Class TGLGizmoExUIPolygon

Unit

GLGizmoEx

Declaration

type TGLGizmoExUIPolygon = class(TGLPolygon)

Description

no description available, TGLPolygon description follows
no description available, TGLPolygonBase description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPolygonBase
  • TGLPolygon
  • TGLGizmoExUIPolygon

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGizmoEx: Class TGLGizmoExUIArrowLine

Class TGLGizmoExUIArrowLine

Unit

GLGizmoEx

Declaration

type TGLGizmoExUIArrowLine = class(TGLArrowLine)

Description

no description available, TGLArrowLine description follows
no description available, TGLCylinderBase description follows
no description available, TGLQuadricObject description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLCylinderBase
  • TGLArrowLine
  • TGLGizmoExUIArrowLine

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGizmoEx: Class TGLGizmoExUILines

Class TGLGizmoExUILines

Unit

GLGizmoEx

Declaration

type TGLGizmoExUILines = class(TGLLines)

Description

no description available, TGLLines description follows
no description available, TGLNodedLines description follows
no description available, TGLLineBase description follows
no description available, TGLImmaterialSceneObject description follows

Base class for objects that do not have a published "material".<p> Note that the material is available in public properties, but isn't applied automatically before invoking BuildList.<br> Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLLineBase
  • TGLNodedLines
  • TGLLines
  • TGLGizmoExUILines

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGizmoEx: Class TGLGizmoExUIFlatText

Class TGLGizmoExUIFlatText

Unit

GLGizmoEx

Declaration

type TGLGizmoExUIFlatText = class(TGLFlatText)

Description

no description available, TGLFlatText description follows

A 2D text displayed and positionned in 3D coordinates.<p> The FlatText uses a character font defined and stored by a TGLBitmapFont component. Default character scale is 1 font pixel = 1 space unit.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLFlatText
  • TGLGizmoExUIFlatText

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Public property NoZWrite: Boolean read FNoZWrite write FNoZWrite;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGizmoEx: Class TGLGizmoEx

Class TGLGizmoEx

Unit

GLGizmoEx

Declaration

type TGLGizmoEx = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLGizmoEx

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Redo: TGLGizmoExActionHistoryItem;
Public | function Undo: TGLGizmoExActionHistoryItem;
Public | procedure Loaded; override;
Public | procedure LooseCursorSelection;
Public | procedure LooseSelection; virtual;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure RemoveSelectedObjects;
Public | procedure UndoAdd(const AObject: TObject);
Public | procedure UpdateGizmo; overload;
Public | procedure ViewerMouseDown(const X, Y: Integer);
Public | procedure ViewerMouseMove(const X, Y: Integer);
Public | procedure ViewerMouseUp(const X, Y: Integer);

Properties

Published | property AntiAliasedLines: Boolean read FAntiAliasedLines write SetAALines default True;
Published | property AutoZoom: Boolean read FAutoZoom write FAutoZoom default True;
Published | property AutoZoomFactor: Single read FAutoZoomFactor write SetAutoZoomFactor;
Published | property BoundingBoxColor: TGLColor read FBoundingBoxColor write SetBoundingBoxColor;
Public | property CanAddObjToSelectionList: Boolean read FCanAddObjToSelectionList write FCanAddObjToSelectionList;
Published | property CanChangeWithChildren: Boolean read FCanChangeWithChildren write SetCanChangeWithChildren;
Public | property CanRemoveObjFromSelectionList: Boolean read FCanRemoveObjFromSelectionList write FCanRemoveObjFromSelectionList;
Public | property CursorSelectingRegion: Boolean read FShowMultiSelecting;
Published | property EnableActionHistory: Boolean read FEnableHistory write FEnableHistory default True;
Published | property Enabled: Boolean read FEnabled write FEnabled default True;
Published | property EnableLoopCursorMoving: Boolean read FEnableLoopCursorMoving write SetEnableLoopCursorMoving default True;
Published | property EnableMultiSelection: Boolean read FEnableMultiSelection write SetEnableMultiSelection default True;
Published | property ExcludeClassname: Boolean read FExcludeClassname write FExcludeClassname;
Published | property ExcludeClassnameList: TStrings read FExcludeClassnameList write SetExcludeClassnameList;
Published | property ExcludeObjects: Boolean read FExcludeObjects write FExcludeObjects;
Published | property ExcludeObjectsList: TStrings read FExcludeObjectsList write SetExcludeObjectsList;
Published | property GizmoThickness: Single read FGizmoThickness write SeTGLGizmoExThickness;
Public | property GizmoTmpRoot: TGLBaseSceneObject read FGizmoTmpRoot write SetGizmoTmpRoot;
Published | property HistoryStepsCount: Integer read FHistoryStepsCount write SetHistoryStepsCount;
Published | property InfoLabelCoordType: TInfoLabelCoordType read fInfoLabelCoordType write SetInfoLabelCoordType default ilcChangeRate;
Published | property LabelFont: TGLCustomBitmapFont read FLabelFont write SetLabelFont default nil;
Published | property MoveCoef: Single read FMoveCoef write FMoveCoef;
Published | property NoZWrite: Boolean read FNoZWrite write SetNoZWrite default True;
Published | property OnAxisSelected: TGLGizmoExAxisSelected read FOnAxisSelected write FOnAxisSelected;
Published | property OnOperationChange: TNotifyEvent read FOnOperationChange write FOnOperationChange;
Published | property OnOperationModeChange: TNotifyEvent read FOnOperationModeChange write FOnOperationModeChange;
Published | property OnSelect: TGLGizmoExAcceptEvent read FOnSelect write FOnSelect;
Published | property OnSelectionLost: TNotifyEvent read FOnSelectionLost write FOnSelectionLost;
Published | property OnUpdate: TNotifyEvent read FOnUpdate write FOnUpdate;
Published | property OperationMode: TGLGizmoExOperationMode read FOperationMode write SetOperationMode default gomSelect;
Published | property PickMode: TGLGizmoExPickMode read FPickMode write SetPickMode default pmGetPickedObjects;
Published | property ReferenceCoordSystem: TGLGizmoExReferenceCoordinateSystem read FReferenceCoordSystem write SetReferenceCoordSystem default rcsView;
Public | property RootGizmo: TGLBaseSceneObject read FRootGizmo write SetRootGizmo;
Public | property RootObjects: TGLBaseSceneObject read FRootObjects write SetRootObjects;
Published | property RotationCoef: Single read FRotationCoef write FRotationCoef;
Published | property ScaleCoef: Single read FScaleCoef write FScaleCoef;
Published | property SelectedColor: TGLColor read FSelectedColor write SetSelectedColor;
Published | property SelectedObj: TGLBaseSceneObject read GetSelectedObj write SetSelectedObj;
Published | property SelectedObjects: TGLPickList read GetPickList write SetPickList;
Published | property SelectionRegion: TGLGizmoExSelectionRegion read FSelectionRegion write SetSelectionRegion default gsrRectangular;
Published | property SelectionRegionColor: TGLColor read FSelectionRegionColor write SetSelectionRegionColor;
Published | property ShowAxisLabel: Boolean read FShowAxisLabel write SetShowAxisLabel default True;
Published | property ShowBoundingBox: Boolean read FShowBoundingBox write SetShowBoundingBox default True;
Published | property ShowObjectInfos: Boolean read FShowObjectInfos write SetShowObjectInfos default True;
Published | property Viewer: TGLSceneViewer read FViewer write SetViewer;
Published | property Visible: Boolean read GetVisible write SetVisible;
Published | property VisibleInfoLabels: TGLGizmoExVisibleInfoLabels read FVisibleVisibleInfoLabels write SeTGLGizmoExVisibleInfoLabels;
Published | property VisibleInfoLabelsColor: TGLColor read FVisibleInfoLabelsColor write SetVisibleInfoLabelsColor;
Published | property ZoomFactor: Single read FZoomFactor write SetZoomFactor;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function Redo: TGLGizmoExActionHistoryItem;
Public function Undo: TGLGizmoExActionHistoryItem;
Public procedure Loaded; override;
Public procedure LooseCursorSelection;
Public procedure LooseSelection; virtual;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure RemoveSelectedObjects;
Public procedure UndoAdd(const AObject: TObject);
Public procedure UpdateGizmo; overload;
Public procedure ViewerMouseDown(const X, Y: Integer);
Public procedure ViewerMouseMove(const X, Y: Integer);
Public procedure ViewerMouseUp(const X, Y: Integer);

Properties

Published property AntiAliasedLines: Boolean read FAntiAliasedLines write SetAALines default True;
Published property AutoZoom: Boolean read FAutoZoom write FAutoZoom default True;
Published property AutoZoomFactor: Single read FAutoZoomFactor write SetAutoZoomFactor;
Published property BoundingBoxColor: TGLColor read FBoundingBoxColor write SetBoundingBoxColor;
Public property CanAddObjToSelectionList: Boolean read FCanAddObjToSelectionList write FCanAddObjToSelectionList;
Published property CanChangeWithChildren: Boolean read FCanChangeWithChildren write SetCanChangeWithChildren;
Public property CanRemoveObjFromSelectionList: Boolean read FCanRemoveObjFromSelectionList write FCanRemoveObjFromSelectionList;
Public property CursorSelectingRegion: Boolean read FShowMultiSelecting;
Published property EnableActionHistory: Boolean read FEnableHistory write FEnableHistory default True;
Published property Enabled: Boolean read FEnabled write FEnabled default True;

Use the property OperationMode=gomNone to unactivate gizmo and make it invisible

Published property EnableLoopCursorMoving: Boolean read FEnableLoopCursorMoving write SetEnableLoopCursorMoving default True;
Published property EnableMultiSelection: Boolean read FEnableMultiSelection write SetEnableMultiSelection default True;
Published property ExcludeClassname: Boolean read FExcludeClassname write FExcludeClassname;
Published property ExcludeClassnameList: TStrings read FExcludeClassnameList write SetExcludeClassnameList;
Published property ExcludeObjects: Boolean read FExcludeObjects write FExcludeObjects;
Published property ExcludeObjectsList: TStrings read FExcludeObjectsList write SetExcludeObjectsList;
Published property GizmoThickness: Single read FGizmoThickness write SeTGLGizmoExThickness;
Public property GizmoTmpRoot: TGLBaseSceneObject read FGizmoTmpRoot write SetGizmoTmpRoot;
Published property HistoryStepsCount: Integer read FHistoryStepsCount write SetHistoryStepsCount;
Published property InfoLabelCoordType: TInfoLabelCoordType read fInfoLabelCoordType write SetInfoLabelCoordType default ilcChangeRate;
Published property LabelFont: TGLCustomBitmapFont read FLabelFont write SetLabelFont default nil;
Published property MoveCoef: Single read FMoveCoef write FMoveCoef;
Published property NoZWrite: Boolean read FNoZWrite write SetNoZWrite default True;
Published property OnAxisSelected: TGLGizmoExAxisSelected read FOnAxisSelected write FOnAxisSelected;
Published property OnOperationChange: TNotifyEvent read FOnOperationChange write FOnOperationChange;
Published property OnOperationModeChange: TNotifyEvent read FOnOperationModeChange write FOnOperationModeChange;
Published property OnSelect: TGLGizmoExAcceptEvent read FOnSelect write FOnSelect;
Published property OnSelectionLost: TNotifyEvent read FOnSelectionLost write FOnSelectionLost;
Published property OnUpdate: TNotifyEvent read FOnUpdate write FOnUpdate;
Published property OperationMode: TGLGizmoExOperationMode read FOperationMode write SetOperationMode default gomSelect;
Published property PickMode: TGLGizmoExPickMode read FPickMode write SetPickMode default pmGetPickedObjects;
Published property ReferenceCoordSystem: TGLGizmoExReferenceCoordinateSystem read FReferenceCoordSystem write SetReferenceCoordSystem default rcsView;
Public property RootGizmo: TGLBaseSceneObject read FRootGizmo write SetRootGizmo;
Public property RootObjects: TGLBaseSceneObject read FRootObjects write SetRootObjects;
Published property RotationCoef: Single read FRotationCoef write FRotationCoef;
Published property ScaleCoef: Single read FScaleCoef write FScaleCoef;
Published property SelectedColor: TGLColor read FSelectedColor write SetSelectedColor;
Published property SelectedObj: TGLBaseSceneObject read GetSelectedObj write SetSelectedObj;
Published property SelectedObjects: TGLPickList read GetPickList write SetPickList;
Published property SelectionRegion: TGLGizmoExSelectionRegion read FSelectionRegion write SetSelectionRegion default gsrRectangular;
Published property SelectionRegionColor: TGLColor read FSelectionRegionColor write SetSelectionRegionColor;
Published property ShowAxisLabel: Boolean read FShowAxisLabel write SetShowAxisLabel default True;
Published property ShowBoundingBox: Boolean read FShowBoundingBox write SetShowBoundingBox default True;
Published property ShowObjectInfos: Boolean read FShowObjectInfos write SetShowObjectInfos default True;
Published property Viewer: TGLSceneViewer read FViewer write SetViewer;
Published property Visible: Boolean read GetVisible write SetVisible;
Published property VisibleInfoLabels: TGLGizmoExVisibleInfoLabels read FVisibleVisibleInfoLabels write SeTGLGizmoExVisibleInfoLabels;
Published property VisibleInfoLabelsColor: TGLColor read FVisibleInfoLabelsColor write SetVisibleInfoLabelsColor;
Published property ZoomFactor: Single read FZoomFactor write SetZoomFactor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGLUTesselation

Unit GLGLUTesselation

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLGLUTesselation<p>

Code to generate triangle strips and fans for polygons.

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>06/06/10 - Yar - Fixed warnings <li>26/11/09 - DaStr - Improved Lazarus compatibility (BugtrackerID = 2893580) <li>10/03/09 - DanB - DoTesselate now accepts TGLBaseMesh instead of TGLFreeform, so can now use TGLActor with it too <li>29/05/08 - DaStr - Added $I GLScene.inc <li>08/09/03 - Jaj - Added single outline polygon support

</ul><p>

License:<br>

Contributed to GLScene.<p>

Overview

Functions and Procedures

procedure DoTesselate(Vertexes: TAffineVectorList; Mesh: TGLBaseMesh; normal: PAffineVector = nil; invertNormals: Boolean = False);

Description

Functions and Procedures

procedure DoTesselate(Vertexes: TAffineVectorList; Mesh: TGLBaseMesh; normal: PAffineVector = nil; invertNormals: Boolean = False);

Tesselates the polygon outlined by the Vertexes. And addeds them to the first facegroup of the Mesh.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGLXContext

Unit GLGLXContext

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLGLXContext<p>

GLX specific Context.<p>

<b>History : </b><font size=-1><ul> <li>29/08/10 - Yar - Rewrite DoCreateContext, added CSAA antialiasing <li>18/06/10 - Yar - Improved memory context and context sharing <li>11/06/10 - Yar - Fixed uses section after lazarus-0.9.29.26033 release <li>06/06/10 - Yar - Fixes for Linux x64. DoActivate method now check contexts difference <li>21/04/10 - Yar - Added support for GLX versions lower than 1.3 (by Rustam Asmandiarov aka Predator) <li>06/04/10 - Yar - Update to GLX 1.3-1.4, added PBuffer, forward context creation (by Rustam Asmandiarov aka Predator) <li>07/11/09 - DaStr - Improved FPC compatibility (BugtrackerID = 2893580) (thanks Predator) <li>10/06/09 - DanB - Added to main GLScene CVS repository (from GLScene-Lazarus). <li>14/01/05 - CU - Creation </ul></font>

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGraph

Unit GLGraph

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSamplingScale |
Class TGLHeightField |
Class TGLXYZGrid |

Types

THeightFieldGetHeightEvent = procedure(const x, y: Single; var z: Single; var Color: TColorVector; var TexPoint: TTexPoint) of object;
THeightFieldGetHeight2Event = procedure(Sender: TObject; const x, y: Single; var z: Single; var Color: TColorVector; var TexPoint: TTexPoint) of object;
THeightFieldOption = (...);
THeightFieldOptions = set of THeightFieldOption;
THeightFieldColorMode = (...);
TXYZGridPart = (...);
TXYZGridParts = set of TXYZGridPart;
TXYZGridLinesStyle = (...);

Description

Types

THeightFieldGetHeightEvent = procedure(const x, y: Single; var z: Single; var Color: TColorVector; var TexPoint: TTexPoint) of object;
THeightFieldGetHeight2Event = procedure(Sender: TObject; const x, y: Single; var z: Single; var Color: TColorVector; var TexPoint: TTexPoint) of object;
THeightFieldOption = (...);
Values
  • hfoTextureCoordinates:
  • hfoTwoSided:
THeightFieldOptions = set of THeightFieldOption;
THeightFieldColorMode = (...);
Values
  • hfcmNone:
  • hfcmEmission:
  • hfcmAmbient:
  • hfcmDiffuse:
  • hfcmAmbientAndDiffuse:
TXYZGridPart = (...);
Values
  • gpX:
  • gpY:
  • gpZ:
TXYZGridParts = set of TXYZGridPart;
TXYZGridLinesStyle = (...);
Values
  • glsLine:
  • glsSegments:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:23


GLScene v.1.1.2: GLGraph: Class TGLSamplingScale

Class TGLSamplingScale

Unit

GLGraph

Declaration

type TGLSamplingScale = class(TGLUpdateAbleObject)

Description

no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLSamplingScale

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function IsValid: Boolean;
Public | function MaxStepCount: Integer;
Public | function StepBase: Single;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure SetBaseStepMaxToVars(var Base, Step, Max: Single; SamplingEnabled: Boolean = True);
Protected | procedure SetMax(const val: Single);
Protected | procedure SetMin(const val: Single);
Protected | procedure SetOrigin(const val: Single);
Protected | procedure SetStep(const val: Single);

Properties

Published | property Max: Single read FMax write SetMax;
Published | property Min: Single read FMin write SetMin;
Published | property Origin: Single read FOrigin write SetOrigin;
Published | property Step: Single read FStep write SetStep;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public function IsValid: Boolean;
Public function MaxStepCount: Integer;
Public function StepBase: Single;
Public procedure Assign(Source: TPersistent); override;
Public procedure SetBaseStepMaxToVars(var Base, Step, Max: Single; SamplingEnabled: Boolean = True);
Protected procedure SetMax(const val: Single);
Protected procedure SetMin(const val: Single);
Protected procedure SetOrigin(const val: Single);
Protected procedure SetStep(const val: Single);

Properties

Published property Max: Single read FMax write SetMax;
Published property Min: Single read FMin write SetMin;
Published property Origin: Single read FOrigin write SetOrigin;
Published property Step: Single read FStep write SetStep;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGraph: Class TGLHeightField

Class TGLHeightField

Unit

GLGraph

Declaration

type TGLHeightField = class(TGLSceneObject)

Description

no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLHeightField

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure DefaultHeightField(const x, y: Single; var z: Single; var Color: TColorVector; var TexPoint: TTexPoint);
Protected | procedure Height2Field(const x, y: Single; var z: Single; var Color: TColorVector; var texPoint: TTexPoint);
Protected | procedure SetColorMode(const val: THeightFieldColorMode);
Protected | procedure SetOnGetHeight(const val: THeightFieldGetHeightEvent);
Protected | procedure SetOnGetHeight2(const val: THeightFieldGetHeight2Event);
Protected | procedure SetOptions(const val: THeightFieldOptions);
Protected | procedure SetXSamplingScale(const val: TGLSamplingScale);
Protected | procedure SetYSamplingScale(const val: TGLSamplingScale);

Properties

Published | property ColorMode: THeightFieldColorMode read FColorMode write SetColorMode default hfcmNone;
Published | property OnGetHeight: THeightFieldGetHeightEvent read FOnGetHeight write SetOnGetHeight;
Published | property OnGetHeight2: THeightFieldGetHeight2Event read FOnGetHeight2 write SetOnGetHeight2;
Published | property Options: THeightFieldOptions read FOptions write SetOptions default [hfoTwoSided];
Public | property TriangleCount: Integer read FTriangleCount;
Published | property XSamplingScale: TGLSamplingScale read FXSamplingScale write SetXSamplingScale;
Published | property YSamplingScale: TGLSamplingScale read FYSamplingScale write SetYSamplingScale;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure NotifyChange(Sender: TObject); override;
Protected procedure DefaultHeightField(const x, y: Single; var z: Single; var Color: TColorVector; var TexPoint: TTexPoint);
Protected procedure Height2Field(const x, y: Single; var z: Single; var Color: TColorVector; var texPoint: TTexPoint);
Protected procedure SetColorMode(const val: THeightFieldColorMode);
Protected procedure SetOnGetHeight(const val: THeightFieldGetHeightEvent);
Protected procedure SetOnGetHeight2(const val: THeightFieldGetHeight2Event);
Protected procedure SetOptions(const val: THeightFieldOptions);
Protected procedure SetXSamplingScale(const val: TGLSamplingScale);
Protected procedure SetYSamplingScale(const val: TGLSamplingScale);

Properties

Published property ColorMode: THeightFieldColorMode read FColorMode write SetColorMode default hfcmNone;
Published property OnGetHeight: THeightFieldGetHeightEvent read FOnGetHeight write SetOnGetHeight;
Published property OnGetHeight2: THeightFieldGetHeight2Event read FOnGetHeight2 write SetOnGetHeight2;
Published property Options: THeightFieldOptions read FOptions write SetOptions default [hfoTwoSided];
Public property TriangleCount: Integer read FTriangleCount;
Published property XSamplingScale: TGLSamplingScale read FXSamplingScale write SetXSamplingScale;
Published property YSamplingScale: TGLSamplingScale read FYSamplingScale write SetYSamplingScale;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGraph: Class TGLXYZGrid

Class TGLXYZGrid

Unit

GLGraph

Declaration

type TGLXYZGrid = class(TGLLineBase)

Description

no description available, TGLLineBase description follows
no description available, TGLImmaterialSceneObject description follows

Base class for objects that do not have a published "material".<p> Note that the material is available in public properties, but isn't applied automatically before invoking BuildList.<br> Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLLineBase
  • TGLXYZGrid

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure SetLinesSmoothing(const val: Boolean);
Protected | procedure SetLinesStyle(const val: TXYZGridLinesStyle);
Protected | procedure SetParts(const val: TXYZGridParts);
Protected | procedure SetXSamplingScale(const val: TGLSamplingScale);
Protected | procedure SetYSamplingScale(const val: TGLSamplingScale);
Protected | procedure SetZSamplingScale(const val: TGLSamplingScale);

Properties

Published | property LinesSmoothing: Boolean write SetLinesSmoothing stored False;
Published | property LinesStyle: TXYZGridLinesStyle read FLinesStyle write SetLinesStyle default glsSegments;
Published | property Parts: TXYZGridParts read FParts write SetParts default [gpX, gpY];
Published | property XSamplingScale: TGLSamplingScale read FXSamplingScale write SetXSamplingScale;
Published | property YSamplingScale: TGLSamplingScale read FYSamplingScale write SetYSamplingScale;
Published | property ZSamplingScale: TGLSamplingScale read FZSamplingScale write SetZSamplingScale;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure NotifyChange(Sender: TObject); override;
Protected procedure SetLinesSmoothing(const val: Boolean);
Protected procedure SetLinesStyle(const val: TXYZGridLinesStyle);
Protected procedure SetParts(const val: TXYZGridParts);
Protected procedure SetXSamplingScale(const val: TGLSamplingScale);
Protected procedure SetYSamplingScale(const val: TGLSamplingScale);
Protected procedure SetZSamplingScale(const val: TGLSamplingScale);

Properties

Published property LinesSmoothing: Boolean write SetLinesSmoothing stored False;
Published property LinesStyle: TXYZGridLinesStyle read FLinesStyle write SetLinesStyle default glsSegments;
Published property Parts: TXYZGridParts read FParts write SetParts default [gpX, gpY];
Published property XSamplingScale: TGLSamplingScale read FXSamplingScale write SetXSamplingScale;
Published property YSamplingScale: TGLSamplingScale read FYSamplingScale write SetYSamplingScale;
Published property ZSamplingScale: TGLSamplingScale read FZSamplingScale write SetZSamplingScale;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGraphics

Unit GLGraphics

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLGraphics<p>

Utility class and functions to manipulate a bitmap in OpenGL's default byte order (GL_RGBA vs TBitmap's GL_BGRA)<p>

Note: TGLBitmap32 has support for Alex Denissov's Graphics32 library (http://www.g32.org), just make sure the GLS_Graphics32_SUPPORT conditionnal is active in GLScene.inc and recompile.<p>

Note: TGLBitmap32 has support for Alex Denissov's Graphics32 library (http://www.g32.org), just make sure the GLS_Graphics32_SUPPORT conditionnal is active in GLScene.inc and recompile.<p>

<b>Historique : </b><font size=-1><ul> <li>25/11/11 - YP - Assertion removed from AssignFromBitmap32 <li>10/05/11 - Yar - Now VerticalReverseOnAssignFromBitmap works for AssignToBitmap <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>18/07/10 - Yar - Raname TGLBitmap32 to TGLImage <li>20/06/10 - Yar - Added in TRasterFileFormatsList.FindFromStream JPG singnature <li>14/06/10 - YP - PngImage support added (thanks to Sergio Alexandre Gianezini) <li>20/05/10 - Yar - Fixes for Linux x64 Replace OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>28/03/10 - Yar - Added glGenerateMipmap when used forward context <li>08/03/10 - Yar - Added in TRasterFileFormatsList.FindFromStream PNG singnature Added forward context cheking to circumvent deprecations <li>01/03/10 - Yar - Bugfix when texture, which has lower mip-levels than the standard number is not rendered (thanks to Controller) <li>23/02/10 - Yar - Solved problem of TGLBitmap with width of which is not a multiple of four. Added in AssignFrom24BitsBitmap, AssignFrom32BitsBitmap using extension GL_EXT_bgra <li>22/02/10 - Yar - Added FindFromStream to TRasterFileFormatsList (thanks to mif) <li>10/02/10 - Yar - Bugfix in RegisterAsOpenGLTexture with Cubemap mipmaping <li>27/01/10 - Yar - Bugfix in BlockOffset with negative result Return to GL_SGIS_generate_mipmap <li>23/01/10 - Yar - Added to AssignFromTexture CurrentFormat parameter <li>22/01/10 - Yar - Added TRasterFileFormat, TGLBaseImage classes TGLBitmap32 now derived from TGLBaseImage and can contain all types of image (with mipmap level, texture array, volume texture) any kind of color and data formats of OpenGL remake RegisterAsOpenGLTexture <li>10/11/09 - DaStr - Updated TGLBitmap32.RegisterAsOpenGLTexture() - fixed TextureFormat and ColorFormat (thanks YarUnderoaker) Improved FPC compatibility (BugtrackerID = 2893580) (thanks Predator) <li>24/03/07 - DaStr - Moved TGLMinFilter and TGLMagFilter from GLUtils.pas to GLGraphics.pas (BugTracker ID = 1923844) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>14/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>23/01/07 - LIN- Added TGLBitmap32.AssignToBitmap : Converts a TGLBitmap32 back into a TBitmap <li>12/09/06 - NC - Added TGLBitmap32.Blank <li>18/10/05 - NC - GL_ARB_texture_non_power_of_two, GL_TEXTURE_2D for float texture <li>06/10/04 - NC - Now uses GL_TEXTURE_RECTANGLE_NV for all float texture types <li>04/10/04 - NC - Added support for float texture <li>05/09/03 - EG - Added TGLBitmap32.DownSampleByFactor2 <li>04/07/03 - EG - Added RGBA brightness/gamma correction support <li>13/05/03 - EG - Added GrayScaleToNormalMap <li>26/08/02 - EG - Fixed loading of 1D horiz textures from 24 bits bitmaps <li>16/06/02 - EG - AssignFrom32BitsBitmap fix for single-line bitmaps <li>29/01/02 - EG - Fixed ScanLine Index bug with empty bitmaps <li>20/01/02 - EG - Fixed BGR24/RGB24 last pixel transfer <li>17/01/02 - EG - Faster assignments from bitmaps (approx. x2), Added AssignFromBitmap24WithoutRGBSwap <li>28/12/01 - EG - Graphics32 support added <li>15/12/01 - EG - Texture target support <li>14/09/01 - EG - Use of vFileStreamClass <li>31/08/01 - EG - 24bits Bitmaps are now made opaque by default <li>12/08/01 - EG - Now detects and uses GL_SGIS_generate_mipmap <li>20/02/01 - EG - Fixed SetHeight & SetWidth (thx Nelson Chu) <li>14/02/01 - EG - Simplified RegisterAsOpenGLTexture <li>15/01/01 - EG - Fixed RegisterAsOpenGLTexture (clamping) <li>14/01/01 - EG - Fixed isEmpty (was invalid for rectangles) <li>08/10/00 - EG - Fixed RegisterAsOpenGLTexture and Assign(nil) <li>25/09/00 - EG - First operational code <li>19/08/00 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TGLPixel24 |
packed record TGLPixel32 |
record TGLImageLevelDesc |
Class TGLBaseImage |
Class TGLImage |
Class TRasterFileFormat |
Class TRasterFileFormatsList |
Class EInvalidRasterFile |

Functions and Procedures

procedure Div2(var Value: Integer);
procedure BGR24ToRGB24(src, dest: Pointer; pixelCount: Integer);
procedure BGR24ToRGBA32(src, dest: Pointer; pixelCount: Integer);
procedure RGB24ToRGBA32(src, dest: Pointer; pixelCount: Integer);
procedure BGRA32ToRGBA32(src, dest: Pointer; pixelCount: Integer);
procedure GammaCorrectRGBArray(base: Pointer; pixelCount: Integer; gamma: Single);
procedure BrightenRGBArray(base: Pointer; pixelCount: Integer; factor: Single);
function GetRasterFileFormats: TRasterFileFormatsList;
function RasterFileFormatExtensionByIndex(index: Integer): string;
procedure RegisterRasterFormat(const AExtension, ADescription: string; AClass: TGLBaseImageClass);
procedure UnregisterRasterFormat(AClass: TGLBaseImageClass);
function GetImageLodNumber(w, h, d: integer; IsVolume: Boolean): Integer;

Types

PGLPixel24 = ˆTGLPixel24;
PGLPixel32 = ˆTGLPixel32;
TGLPixel32Array = array[0..MaxInt shr 3] of TGLPixel32;
PGLPixel32Array = ˆTGLPixel32Array;
TGLLODStreamingState = (...);
TGLImageLODRange = 0..15;
TGLImagePiramid = array[TGLImageLODRange] of TGLImageLevelDesc;
TGLBaseImageClass = class of TGLBaseImage;
TGLBitmap32 = TGLImage;

Variables

vVerticalFlipDDS: Boolean = true;

Description

Functions and Procedures

procedure Div2(var Value: Integer);
procedure BGR24ToRGB24(src, dest: Pointer; pixelCount: Integer);
procedure BGR24ToRGBA32(src, dest: Pointer; pixelCount: Integer);
procedure RGB24ToRGBA32(src, dest: Pointer; pixelCount: Integer);
procedure BGRA32ToRGBA32(src, dest: Pointer; pixelCount: Integer);
procedure GammaCorrectRGBArray(base: Pointer; pixelCount: Integer; gamma: Single);
procedure BrightenRGBArray(base: Pointer; pixelCount: Integer; factor: Single);
function GetRasterFileFormats: TRasterFileFormatsList;

Read access to the list of registered vector file formats

function RasterFileFormatExtensionByIndex(index: Integer): string;

Returns an extension by its index in the internal image files dialogs filter.<p> Use InternalImageFileFormatsFilter to obtain the filter.

procedure RegisterRasterFormat(const AExtension, ADescription: string; AClass: TGLBaseImageClass);
procedure UnregisterRasterFormat(AClass: TGLBaseImageClass);
function GetImageLodNumber(w, h, d: integer; IsVolume: Boolean): Integer;

Return an optimal number of texture pyramid

Types

PGLPixel24 = ˆTGLPixel24;
PGLPixel32 = ˆTGLPixel32;
TGLPixel32Array = array[0..MaxInt shr 3] of TGLPixel32;
PGLPixel32Array = ˆTGLPixel32Array;
TGLLODStreamingState = (...);
Values
  • ssKeeping:
  • ssLoading:
  • ssLoaded:
  • ssTransfered:
TGLImageLODRange = 0..15;
TGLImagePiramid = array[TGLImageLODRange] of TGLImageLevelDesc;
TGLBaseImageClass = class of TGLBaseImage;
TGLBitmap32 = TGLImage;

Variables

vVerticalFlipDDS: Boolean = true;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGraphics: packed record TGLPixel24

packed record TGLPixel24

Unit

GLGraphics

Declaration

type TGLPixel24 = packed record

Description

Overview

Fields

r: Byte;
g: Byte;
b: Byte;

Description

Fields

r: Byte;
g: Byte;
b: Byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGraphics: packed record TGLPixel32

packed record TGLPixel32

Unit

GLGraphics

Declaration

type TGLPixel32 = packed record

Description

Overview

Fields

r: Byte;
g: Byte;
b: Byte;
a: Byte;

Description

Fields

r: Byte;
g: Byte;
b: Byte;
a: Byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGraphics: record TGLImageLevelDesc

record TGLImageLevelDesc

Unit

GLGraphics

Declaration

type TGLImageLevelDesc = record

Description

Overview

Fields

Width: Integer;
Height: Integer;
Depth: Integer;
PBO: TGLUnpackPBOHandle;
MapAddress: Pointer;
Offset: LongWord;
StreamOffset: LongWord;
Size: LongWord;
State: TGLLODStreamingState;

Description

Fields

Width: Integer;
Height: Integer;
Depth: Integer;
PBO: TGLUnpackPBOHandle;
MapAddress: Pointer;
Offset: LongWord;
StreamOffset: LongWord;
Size: LongWord;
State: TGLLODStreamingState;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGraphics: Class TGLBaseImage

Class TGLBaseImage

Unit

GLGraphics

Declaration

type TGLBaseImage = class(TDataFile)

Description

no description available, TDataFile description follows

Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TGLBaseImage

Overview

Fields

Protected | fData: PGLPixel32Array;
Protected | FLOD: TGLImagePiramid;
Protected | fLevelCount: TGLImageLODRange;
Protected | fColorFormat: TGLEnum;
Protected | fInternalFormat: TGLInternalFormat;
Protected | fDataType: TGLEnum;
Protected | fElementSize: Integer;
Protected | fCubeMap: Boolean;
Protected | fTextureArray: Boolean;

Methods

Public | constructor Create; reintroduce; virtual;
Public | destructor Destroy; override;
Public | function AssignFromTexture( AHandle: TGLTextureHandle; const CastToFormat: Boolean; const intFormat: TGLInternalFormat = tfRGBA8; const colorFormat: TGLenum = 0; const dataType: TGLenum = 0): Boolean; virtual;
Public | function ConvertCrossToCubeMap: Boolean;
Public | function ConvertToVolume(const col, row: Integer; const MakeArray: Boolean): Boolean;
Public | function DataSize: PtrUint;
Public | function GetTextureTarget: TGLTextureTarget;
Public | function IsCompressed: Boolean;
Public | function IsEmpty: Boolean;
Public | function IsVolume: Boolean;
Protected | function GetData: PGLPixel32Array; virtual;
Protected | function GetDepth: Integer;
Protected | function GetHeight: Integer;
Protected | function GetLevelAddress(ALevel: Byte): Pointer; overload;
Protected | function GetLevelAddress(ALevel, AFace: Byte): Pointer; overload;
Protected | function GetLevelDepth(ALOD: TGLImageLODRange): Integer;
Protected | function GetLevelHeight(ALOD: TGLImageLODRange): Integer;
Protected | function GetLevelOffset(ALOD: TGLImageLODRange): Integer;
Protected | function GetLevelPBO(ALOD: TGLImageLODRange): TGLUnpackPBOHandle;
Protected | function GetLevelSizeInByte(ALOD: TGLImageLODRange): Integer;
Protected | function GetLevelStreamingState(ALOD: TGLImageLODRange): TGLLODStreamingState;
Protected | function GetLevelWidth(ALOD: TGLImageLODRange): Integer;
Protected | function GetWidth: Integer;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure GenerateMipmap(AFilter: TImageFilterFunction); virtual;
Public | procedure Narrow;
Public | procedure RegisterAsOpenGLTexture( AHandle: TGLTextureHandle; aMipmapGen: Boolean; aTexFormat: TGLEnum; out texWidth: integer; out texHeight: integer; out texDepth: integer); virtual;
Public | procedure SetErrorImage;
Public | procedure UnMipmap; virtual;
Public | procedure UpdateLevelsInfo;
Protected | procedure DoStreaming;
Protected | procedure LoadHeader;
Protected | procedure SaveHeader;
Protected | procedure SetLevelStreamingState(ALOD: TGLImageLODRange; AState: TGLLODStreamingState);
Protected | procedure StartStreaming;

Properties

Public | property ColorFormat: TGLenum read fColorFormat;
Public | property CubeMap: Boolean read fCubeMap;
Public | property Data: PGLPixel32Array read GetData;
Public | property DataType: GLenum read fDataType;
Public | property ElementSize: Integer read fElementSize;
Public | property InternalFormat: TGLInternalFormat read FInternalFormat;
Public | property LevelCount: TGLImageLODRange read fLevelCount;
Public | property LevelDepth[ALOD: TGLImageLODRange]: Integer read GetLevelDepth;
Public | property LevelHeight[ALOD: TGLImageLODRange]: Integer read GetLevelHeight;
Public | property LevelOffset[ALOD: TGLImageLODRange]: Integer read GetLevelOffset;
Public | property LevelPixelBuffer[ALOD: TGLImageLODRange]: TGLUnpackPBOHandle read GetLevelPBO;
Public | property LevelSizeInByte[ALOD: TGLImageLODRange]: Integer read GetLevelSizeInByte;
Public | property LevelStreamingState[ALOD: TGLImageLODRange]: TGLLODStreamingState read GetLevelStreamingState write SetLevelStreamingState;
Public | property LevelWidth[ALOD: TGLImageLODRange]: Integer read GetLevelWidth;
Public | property TextureArray: Boolean read fTextureArray;

Description

Fields

Protected fData: PGLPixel32Array;
Protected FLOD: TGLImagePiramid;
Protected fLevelCount: TGLImageLODRange;
Protected fColorFormat: TGLEnum;
Protected fInternalFormat: TGLInternalFormat;
Protected fDataType: TGLEnum;
Protected fElementSize: Integer;
Protected fCubeMap: Boolean;
Protected fTextureArray: Boolean;

Methods

Public constructor Create; reintroduce; virtual;
Public destructor Destroy; override;
Public function AssignFromTexture( AHandle: TGLTextureHandle; const CastToFormat: Boolean; const intFormat: TGLInternalFormat = tfRGBA8; const colorFormat: TGLenum = 0; const dataType: TGLenum = 0): Boolean; virtual;

Assigns from any Texture.

Public function ConvertCrossToCubeMap: Boolean;

Convert vertical cross format of non compressed, non mipmaped image to six face of cube map

Public function ConvertToVolume(const col, row: Integer; const MakeArray: Boolean): Boolean;

Convert flat image to volume by dividing it into slice.

Public function DataSize: PtrUint;

Return size in byte of all image

Public function GetTextureTarget: TGLTextureTarget;
Public function IsCompressed: Boolean;
Public function IsEmpty: Boolean;

True if the bitmap is empty (ie. width or height is zero).

Public function IsVolume: Boolean;
Protected function GetData: PGLPixel32Array; virtual;
Protected function GetDepth: Integer;
Protected function GetHeight: Integer;
Protected function GetLevelAddress(ALevel: Byte): Pointer; overload;
Protected function GetLevelAddress(ALevel, AFace: Byte): Pointer; overload;
Protected function GetLevelDepth(ALOD: TGLImageLODRange): Integer;
Protected function GetLevelHeight(ALOD: TGLImageLODRange): Integer;
Protected function GetLevelOffset(ALOD: TGLImageLODRange): Integer;
Protected function GetLevelPBO(ALOD: TGLImageLODRange): TGLUnpackPBOHandle;
Protected function GetLevelSizeInByte(ALOD: TGLImageLODRange): Integer;
Protected function GetLevelStreamingState(ALOD: TGLImageLODRange): TGLLODStreamingState;
Protected function GetLevelWidth(ALOD: TGLImageLODRange): Integer;
Protected function GetWidth: Integer;
Public procedure Assign(Source: TPersistent); override;
Public procedure GenerateMipmap(AFilter: TImageFilterFunction); virtual;

Generate LOD pyramid

Public procedure Narrow;

Narrow image data to simple RGBA8 ubyte

Public procedure RegisterAsOpenGLTexture( AHandle: TGLTextureHandle; aMipmapGen: Boolean; aTexFormat: TGLEnum; out texWidth: integer; out texHeight: integer; out texDepth: integer); virtual;

Registers the bitmap's content as an OpenGL texture map.

Public procedure SetErrorImage;

Set image of error.

Public procedure UnMipmap; virtual;

Leave top level and remove other

Public procedure UpdateLevelsInfo;

Recalculate levels information based on first level.

Protected procedure DoStreaming;
Protected procedure LoadHeader;
Protected procedure SaveHeader;
Protected procedure SetLevelStreamingState(ALOD: TGLImageLODRange; AState: TGLLODStreamingState);
Protected procedure StartStreaming;

Properties

Public property ColorFormat: TGLenum read fColorFormat;
Public property CubeMap: Boolean read fCubeMap;
Public property Data: PGLPixel32Array read GetData;

Direct Access to image data

Public property DataType: GLenum read fDataType;
Public property ElementSize: Integer read fElementSize;
Public property InternalFormat: TGLInternalFormat read FInternalFormat;
Public property LevelCount: TGLImageLODRange read fLevelCount;

Number of levels.

Public property LevelDepth[ALOD: TGLImageLODRange]: Integer read GetLevelDepth;
Public property LevelHeight[ALOD: TGLImageLODRange]: Integer read GetLevelHeight;
Public property LevelOffset[ALOD: TGLImageLODRange]: Integer read GetLevelOffset;

LOD offset in byte

Public property LevelPixelBuffer[ALOD: TGLImageLODRange]: TGLUnpackPBOHandle read GetLevelPBO;
Public property LevelSizeInByte[ALOD: TGLImageLODRange]: Integer read GetLevelSizeInByte;

LOD size in byte

Public property LevelStreamingState[ALOD: TGLImageLODRange]: TGLLODStreamingState read GetLevelStreamingState write SetLevelStreamingState;
Public property LevelWidth[ALOD: TGLImageLODRange]: Integer read GetLevelWidth;
Public property TextureArray: Boolean read fTextureArray;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGraphics: Class TGLImage

Class TGLImage

Unit

GLGraphics

Declaration

type TGLImage = class(TGLBaseImage)

Description

Contains and manipulates a 32 bits (24+8) bitmap.<p> This is the base class for preparing and manipulating textures in GLScene, this function does not rely on a windows handle and should be used for in-memory manipulations only.<br> 16 bits textures are automatically converted to 24 bits and an opaque (255) alpha channel is assumed for all planes, the byte order is as specified in GL_RGBA. If 32 bits is used in this class, it can however output 16 bits texture data for use in OpenGL.<p> The class has support for registering its content as a texture, as well as for directly drawing/reading from the current OpenGL buffer.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TGLBaseImage
  • TGLImage

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function Create32BitsBitmap: TGLBitmap;
Protected | function GetScanLine(index: Integer): PGLPixel32Array;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure AssignFromBitmap24WithoutRGBSwap(aBitmap: TGLBitmap);
Public | procedure AssignFromTexture2D(textureHandle: TGLTextureHandle); overload;
Public | procedure AssignFromTexture2D(textureHandle: Cardinal); overload;
Public | procedure AssignToBitmap(aBitmap: TGLBitmap);
Public | procedure BrightnessCorrection(const factor: Single);
Public | procedure DownSampleByFactor2;
Public | procedure DrawPixels(const x, y: Single);
Public | procedure GammaCorrection(const gamma: Single);
Public | procedure GenerateMipmap(AFilter: TImageFilterFunction); override;
Public | procedure GrayScaleToNormalMap(const scale: Single; wrapX: Boolean = True; wrapY: Boolean = True);
Public | procedure InvertAlpha;
Public | procedure NormalizeNormalMap;
Public | procedure ReadPixels(const area: TGLRect);
Public | procedure SetAlphaFromIntensity;
Public | procedure SetAlphaToFloatValue(const aValue: Single);
Public | procedure SetAlphaToValue(const aValue: Byte);
Public | procedure SetAlphaTransparentForColor(const aColor: TColor); overload;
Public | procedure SetAlphaTransparentForColor(const aColor: TGLPixel32); overload;
Public | procedure SetAlphaTransparentForColor(const aColor: TGLPixel24); overload;
Public | procedure SetColorFormatDataType(const AColorFormat, ADataType: GLenum);
Public | procedure SqrtAlpha;
Public | procedure UnMipmap; override;
Protected | procedure AssignFrom24BitsBitmap(aBitmap: TGLBitmap);
Protected | procedure AssignFrom32BitsBitmap(aBitmap: TGLBitmap);
Protected | procedure SetArray(const val: Boolean);
Protected | procedure SetBlank(const Value: boolean);
Protected | procedure SetCubeMap(const val: Boolean);
Protected | procedure SetDepth(const val: Integer);
Protected | procedure SetHeight(const val: Integer);
Protected | procedure SetWidth(val: Integer);

Properties

Public | property Blank: boolean read FBlank write SetBlank;
Public | property ColorFormat: GLenum read fColorFormat;
Public | property CubeMap: Boolean read fCubeMap write SetCubeMap;
Public | property DataType: GLenum read fDataType;
Public | property Depth: Integer read GetDepth write SetDepth;
Public | property ElementSize: Integer read fElementSize;
Public | property Height: Integer read GetHeight write SetHeight;
Public | property InternalFormat: TGLInternalFormat read FInternalFormat write FInternalFormat;
Public | property ScanLine[index: Integer]: PGLPixel32Array read GetScanLine;
Public | property TextureArray: Boolean read fTextureArray write SetArray;
Public | property VerticalReverseOnAssignFromBitmap: Boolean read FVerticalReverseOnAssignFromBitmap write FVerticalReverseOnAssignFromBitmap;
Public | property Width: Integer read GetWidth write SetWidth;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function Create32BitsBitmap: TGLBitmap;

Create a 32 bits TBitmap from self content.

Protected function GetScanLine(index: Integer): PGLPixel32Array;
Public procedure Assign(Source: TPersistent); override;

Accepts TGLImage and TGraphic subclasses.

Public procedure AssignFromBitmap24WithoutRGBSwap(aBitmap: TGLBitmap);

Assigns from a 24 bits bitmap without swapping RGB.<p> This is faster than a regular assignment, but R and B channels will be reversed (from what you would view in a TImage). Suitable if you do your own drawing and reverse RGB on the drawing side.<br> If you're after speed, don't forget to set the bitmap's dimensions to a power of two!

Public procedure AssignFromTexture2D(textureHandle: TGLTextureHandle); overload;

Assigns from a Texture handle.<p> If the handle is invalid, the bitmap32 will be empty.

Public procedure AssignFromTexture2D(textureHandle: Cardinal); overload;

Assigns from a 2D Texture.<p> The context which holds the texture must be active and the texture handle valid.

Public procedure AssignToBitmap(aBitmap: TGLBitmap);
Public procedure BrightnessCorrection(const factor: Single);

Apply a brightness (scaled saturating) correction to the RGB components.

Public procedure DownSampleByFactor2;

Downsample the bitmap by a factor of 2 in both dimensions.<p> If one of the dimensions is 1 or less, does nothing.

Public procedure DrawPixels(const x, y: Single);

Draws the whole bitmap at given position in the current OpenGL context.<p> This function must be called with a rendering context active.<p> Blending and Alpha channel functions are not altered by this function and must be adjusted separately.

Public procedure GammaCorrection(const gamma: Single);

Apply a gamma correction to the RGB components.

Public procedure GenerateMipmap(AFilter: TImageFilterFunction); override;

Generate level of detail.

Public procedure GrayScaleToNormalMap(const scale: Single; wrapX: Boolean = True; wrapY: Boolean = True);

Converts a grayscale 'elevation' bitmap to normal map.<p> Actually, only the Green component in the original bitmap is used.

Public procedure InvertAlpha;

Inverts the AlphaChannel component.<p> What was transparent becomes opaque and vice-versa.

Public procedure NormalizeNormalMap;

Assumes the bitmap content is a normal map and normalizes all pixels.<p>

Public procedure ReadPixels(const area: TGLRect);

Reads the given area from the current active OpenGL rendering context.<p> The best spot for reading pixels is within a SceneViewer's PostRender event : the scene has been fully rendered and the OpenGL context is still active.

Public procedure SetAlphaFromIntensity;

Set Alpha channel values to the pixel intensity.<p> The intensity is calculated as the mean of RGB components.

Public procedure SetAlphaToFloatValue(const aValue: Single);

Set Alpha channel values to given float [0..1] value.

Public procedure SetAlphaToValue(const aValue: Byte);

Set Alpha channel values to given byte value.

Public procedure SetAlphaTransparentForColor(const aColor: TColor); overload;

Set Alpha channel to 0 for pixels of given color, 255 for others).<p> This makes pixels of given color totally transparent while the others are completely opaque.

Public procedure SetAlphaTransparentForColor(const aColor: TGLPixel32); overload;
Public procedure SetAlphaTransparentForColor(const aColor: TGLPixel24); overload;
Public procedure SetColorFormatDataType(const AColorFormat, ADataType: GLenum);

Recast image OpenGL data type and color format.

Public procedure SqrtAlpha;

AlphaChannel components are replaced by their sqrt.<p>

Public procedure UnMipmap; override;

Clear all levels except first.

Protected procedure AssignFrom24BitsBitmap(aBitmap: TGLBitmap);
Protected procedure AssignFrom32BitsBitmap(aBitmap: TGLBitmap);
Protected procedure SetArray(const val: Boolean);
Protected procedure SetBlank(const Value: boolean);
Protected procedure SetCubeMap(const val: Boolean);
Protected procedure SetDepth(const val: Integer);
Protected procedure SetHeight(const val: Integer);
Protected procedure SetWidth(val: Integer);

Properties

Public property Blank: boolean read FBlank write SetBlank;

Set Blank to true if you actually don't need to allocate data in main menory.<p> Useful for textures that are generated by the GPU on the fly.

Public property ColorFormat: GLenum read fColorFormat;

OpenGL color format

Public property CubeMap: Boolean read fCubeMap write SetCubeMap;
Public property DataType: GLenum read fDataType;

OpenGL data type

Public property Depth: Integer read GetDepth write SetDepth;

Depth of the bitmap.

Public property ElementSize: Integer read fElementSize;

Size in bytes of pixel or block

Public property Height: Integer read GetHeight write SetHeight;

Height of the bitmap.

Public property InternalFormat: TGLInternalFormat read FInternalFormat write FInternalFormat;

Recommended texture internal format

Public property ScanLine[index: Integer]: PGLPixel32Array read GetScanLine;

Access to a specific Bitmap ScanLine.<p> index should be in the [0; Height[ range.<p> Warning : this function is NOT protected against invalid indexes, and invoking it is invalid if the bitmap is Empty.

Public property TextureArray: Boolean read fTextureArray write SetArray;
Public property VerticalReverseOnAssignFromBitmap: Boolean read FVerticalReverseOnAssignFromBitmap write FVerticalReverseOnAssignFromBitmap;
Public property Width: Integer read GetWidth write SetWidth;

Width of the bitmap.<p>

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGraphics: Class TRasterFileFormat

Class TRasterFileFormat

Unit

GLGraphics

Declaration

type TRasterFileFormat = class(TObject)

Description

Hierarchy

  • TObject
  • TRasterFileFormat

Overview

Fields

Public | BaseImageClass: TGLBaseImageClass;
Public | Extension: string;
Public | Description: string;
Public | DescResID: Integer;

Description

Fields

Public BaseImageClass: TGLBaseImageClass;
Public Extension: string;
Public Description: string;
Public DescResID: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGraphics: Class TRasterFileFormatsList

Class TRasterFileFormatsList

Unit

GLGraphics

Declaration

type TRasterFileFormatsList = class(TPersistentObjectList)

Description

Stores registered raster file formats.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TRasterFileFormatsList

Overview

Methods

Public | destructor Destroy; override;
Public | function FindExt(ext: string): TGLBaseImageClass;
Public | function FindExtByIndex(index: Integer; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False): string;
Public | function FindFromFileName(const fileName: string): TGLBaseImageClass;
Public | function FindFromStream(const AStream: TStream): TGLBaseImageClass;
Public | procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TGLBaseImageClass);
Public | procedure BuildFilterStrings(imageFileClass: TGLBaseImageClass; var descriptions, filters: string; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False);
Public | procedure Remove(AClass: TGLBaseImageClass);

Description

Methods

Public destructor Destroy; override;
Public function FindExt(ext: string): TGLBaseImageClass;
Public function FindExtByIndex(index: Integer; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False): string;
Public function FindFromFileName(const fileName: string): TGLBaseImageClass;
Public function FindFromStream(const AStream: TStream): TGLBaseImageClass;
Public procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TGLBaseImageClass);
Public procedure BuildFilterStrings(imageFileClass: TGLBaseImageClass; var descriptions, filters: string; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False);
Public procedure Remove(AClass: TGLBaseImageClass);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGraphics: Class EInvalidRasterFile

Class EInvalidRasterFile

Unit

GLGraphics

Declaration

type EInvalidRasterFile = class(Exception)

Description

Hierarchy

  • Exception
  • EInvalidRasterFile
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGui

Unit GLGui

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLGui<p>

In GL windows management classes and structures<p>

<b>History : </b><font size=-1><ul> <li>15/04/11 - Yar - Added TGLGuiLayout.Assign <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>11/06/10 - YP - Link GUI elements to their parent <li>06/06/10 - Yar - Fixed warnings <li>30/03/07 - DaStr - Added $I GLScene.inc, cosmetic changes <li>17/02/07 - DaStr - TGLGuiElement.Create - vectors creation fixed Changed some types from TGLCoordinates to TGLCoordinates2 Removed some empty lines <li>16/12/05 - DK - Removed GuiSkinEditorFormUnit dependancy <li>30/11/04 - DB - Fixed memory leaks (thanks dikoe Kenguru) <li>16/07/03 - EG - TGLBaseGuiObject moved in along with RecursiveVisible mechanism <li>25/11/02 - EG - TGLGuiLayout.Clear fix (Sternas Stefanos) <li>06/09/02 - JAJ - Updated and added to CVS.. <li>01/06/02 - JAJ - Base Unit built.. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBaseGuiObject |
record TGUIRect |
Class TGLGuiElement |
Class TGLGuiElementList |
Class TGLGuiComponent |
Class TGLGuiComponentList |
Class TGLGuiLayout |

Functions and Procedures

function IsInRect(const R: TGUIRect; X, Y: Single): Boolean;

Types

TGUIAlignments = (...);
TGUIDrawResult = array[TGUIAlignments] of TGUIRect;
TGLGuiElementName = string;
TGLGuiComponentName = string;

Constants

GuiNullRect: TGUIRect = (X1: 0.0; Y1: 0.0; X2: 0.0; Y2: 0.0; XTiles: 0.0; YTiles: 0.0);

Description

Functions and Procedures

function IsInRect(const R: TGUIRect; X, Y: Single): Boolean;

Types

TGUIAlignments = (...);
Values
  • GLAlTopLeft:
  • GLAlTop:
  • GLAlTopRight:
  • GLAlLeft:
  • GLAlCenter:
  • GLAlRight:
  • GLAlBottomLeft:
  • GLAlBottom:
  • GLAlBottomRight:
  • GLAlBorder:
TGUIDrawResult = array[TGUIAlignments] of TGUIRect;
TGLGuiElementName = string;
TGLGuiComponentName = string;

Constants

GuiNullRect: TGUIRect = (X1: 0.0; Y1: 0.0; X2: 0.0; Y2: 0.0; XTiles: 0.0; YTiles: 0.0);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGui: Class TGLBaseGuiObject

Class TGLBaseGuiObject

Unit

GLGui

Declaration

type TGLBaseGuiObject = class(TGLBaseSceneObject)

Description

no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Protected | function GetLeft: TGLFloat;
Protected | function GetTop: TGLFloat;
Public | procedure AddChild(AChild: TGLBaseSceneObject); override;
Public | procedure Insert(aIndex: Integer; aChild: TGLBaseSceneObject); override;
Protected | procedure NotifyHide; dynamic;
Protected | procedure NotifyShow; dynamic;
Protected | procedure SetHeight(const val: Single);
Protected | procedure SetLeft(const Value: TGLFloat);
Protected | procedure SetTop(const Value: TGLFloat);
Protected | procedure SetVisible(aValue: Boolean); override;
Protected | procedure SetWidth(const val: Single);

Properties

Public | property Height: Single read FHeight write SetHeight;
Public | property Left: TGLFloat read GetLeft write SetLeft;
Public | property RecursiveVisible: Boolean read FRecursiveVisible;
Public | property Top: TGLFloat read GetTop write SetTop;
Public | property Width: Single read FWidth write SetWidth;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Protected function GetLeft: TGLFloat;
Protected function GetTop: TGLFloat;
Public procedure AddChild(AChild: TGLBaseSceneObject); override;
Public procedure Insert(aIndex: Integer; aChild: TGLBaseSceneObject); override;
Protected procedure NotifyHide; dynamic;

self notification on hide. Also notifies children.

Protected procedure NotifyShow; dynamic;

child notification on show. Also notifies children.

Protected procedure SetHeight(const val: Single);
Protected procedure SetLeft(const Value: TGLFloat);
Protected procedure SetTop(const Value: TGLFloat);
Protected procedure SetVisible(aValue: Boolean); override;
Protected procedure SetWidth(const val: Single);

Properties

Public property Height: Single read FHeight write SetHeight;

GuiComponent Height in 3D world units.

Public property Left: TGLFloat read GetLeft write SetLeft;

GuiComponent Left in 3D world units.

Public property RecursiveVisible: Boolean read FRecursiveVisible;
Public property Top: TGLFloat read GetTop write SetTop;

GuiComponent Top in 3D world units.

Public property Width: Single read FWidth write SetWidth;

GuiComponent Width in 3D world units.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGui: record TGUIRect

record TGUIRect

Unit

GLGui

Declaration

type TGUIRect = record

Description

Overview

Fields

X1: TGLFloat;
Y1: TGLFloat;
X2: TGLFloat;
Y2: TGLFloat;
XTiles: TGLFloat;
YTiles: TGLFloat;

Description

Fields

X1: TGLFloat;
Y1: TGLFloat;
X2: TGLFloat;
Y2: TGLFloat;
XTiles: TGLFloat;
YTiles: TGLFloat;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGui: Class TGLGuiElement

Class TGLGuiElement

Unit

GLGui

Declaration

type TGLGuiElement = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLGuiElement

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Public | procedure AssignTo(Dest: TPersistent); override;
Protected | procedure SetName(const val: TGLGuiElementName);

Properties

Published | property Align: TGUIAlignments read FAlign write FAlign;
Published | property BottomRight: TGLCoordinates2 read FBottomRight write FBottomRight;
Published | property Name: TGLGuiElementName read FName write SetName;
Published | property Scale: TGLCoordinates2 read FScale write FScale;
Published | property TopLeft: TGLCoordinates2 read FTopLeft write FTopLeft;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Public procedure AssignTo(Dest: TPersistent); override;
Protected procedure SetName(const val: TGLGuiElementName);

Properties

Published property Align: TGUIAlignments read FAlign write FAlign;
Published property BottomRight: TGLCoordinates2 read FBottomRight write FBottomRight;
Published property Name: TGLGuiElementName read FName write SetName;
Published property Scale: TGLCoordinates2 read FScale write FScale;
Published property TopLeft: TGLCoordinates2 read FTopLeft write FTopLeft;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGui: Class TGLGuiElementList

Class TGLGuiElementList

Unit

GLGui

Declaration

type TGLGuiElementList = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLGuiElementList

Overview

Methods

Public | constructor Create(AOwner: TGLGuiComponent);
Public | function GetOwner: TPersistent; override;
Public | function IndexOf(const Item: TGLGuiElement): Integer;
Protected | function GetItems(index: Integer): TGLGuiElement;
Public | procedure AssignTo(Dest: TPersistent); override;
Protected | procedure SetItems(index: Integer; const val: TGLGuiElement);

Properties

Public property Items[index: Integer]: TGLGuiElement read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TGLGuiComponent);
Public function GetOwner: TPersistent; override;
Public function IndexOf(const Item: TGLGuiElement): Integer;
Protected function GetItems(index: Integer): TGLGuiElement;
Public procedure AssignTo(Dest: TPersistent); override;
Protected procedure SetItems(index: Integer; const val: TGLGuiElement);

Properties

Public property Items[index: Integer]: TGLGuiElement read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGui: Class TGLGuiComponent

Class TGLGuiComponent

Unit

GLGui

Declaration

type TGLGuiComponent = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLGuiComponent

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function GetOwnerList: TGLGuiComponentList;
Protected | function GetDisplayName: string; override;
Public | procedure AssignTo(Dest: TPersistent); override;
Public | procedure RenderToArea(X1, Y1, X2, Y2: TGLFloat; var Res: TGUIDrawResult; Refresh: Boolean = True; Scale: TGLFloat = 1);
Protected | procedure SetName(const val: TGLGuiComponentName);

Properties

Published | property Elements: TGLGuiElementList read FElements write FElements;
Published | property Name: TGLGuiComponentName read FName write SetName;
Public | property Owner: TGLGuiComponentList read GetOwnerList;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Public function GetOwnerList: TGLGuiComponentList;
Protected function GetDisplayName: string; override;
Public procedure AssignTo(Dest: TPersistent); override;
Public procedure RenderToArea(X1, Y1, X2, Y2: TGLFloat; var Res: TGUIDrawResult; Refresh: Boolean = True; Scale: TGLFloat = 1);
Protected procedure SetName(const val: TGLGuiComponentName);

Properties

Published property Elements: TGLGuiElementList read FElements write FElements;
Published property Name: TGLGuiComponentName read FName write SetName;
Public property Owner: TGLGuiComponentList read GetOwnerList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGui: Class TGLGuiComponentList

Class TGLGuiComponentList

Unit

GLGui

Declaration

type TGLGuiComponentList = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLGuiComponentList

Overview

Methods

Public | constructor Create(AOwner: TGLGuiLayout);
Public | function FindItem(name: TGLGuiComponentName): TGLGuiComponent;
Public | function GetOwner: TPersistent; override;
Protected | function GetItems(index: Integer): TGLGuiComponent;
Protected | procedure SetItems(index: Integer; const val: TGLGuiComponent);

Properties

Public property Items[index: Integer]: TGLGuiComponent read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TGLGuiLayout);
Public function FindItem(name: TGLGuiComponentName): TGLGuiComponent;
Public function GetOwner: TPersistent; override;
Protected function GetItems(index: Integer): TGLGuiComponent;
Protected procedure SetItems(index: Integer; const val: TGLGuiComponent);

Properties

Public property Items[index: Integer]: TGLGuiComponent read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLGui: Class TGLGuiLayout

Class TGLGuiLayout

Unit

GLGui

Declaration

type TGLGuiLayout = class(TGLUpdateableComponent)

Description

no description available, TGLUpdateableComponent description follows

A base class describing the "update" interface.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLGuiLayout

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure AddGuiComponent(Component: TGLUpdateableComponent);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Clear;
Public | procedure LoadFromFile(FN: string);
Public | procedure LoadFromStream(Stream: TStream);
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure RemoveGuiComponent(Component: TGLUpdateableComponent);
Public | procedure SaveToFile(FN: string);
Public | procedure SaveToStream(Stream: TStream);
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetFileName(newName: string);

Properties

Published | property BitmapFont: TGLCustomBitmapFont read FBitmapFont write FBitmapFont;
Published | property FileName: string read FFileName write SetFileName;
Published | property GuiComponents: TGLGuiComponentList read FGuiComponents write FGuiComponents;
Published | property Material: TGLMaterial read FMaterial write FMaterial;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure AddGuiComponent(Component: TGLUpdateableComponent);
Public procedure Assign(Source: TPersistent); override;
Public procedure Clear;
Public procedure LoadFromFile(FN: string);
Public procedure LoadFromStream(Stream: TStream);
Public procedure NotifyChange(Sender: TObject); override;
Public procedure RemoveGuiComponent(Component: TGLUpdateableComponent);
Public procedure SaveToFile(FN: string);
Public procedure SaveToStream(Stream: TStream);
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetFileName(newName: string);

Properties

Published property BitmapFont: TGLCustomBitmapFont read FBitmapFont write FBitmapFont;
Published property FileName: string read FFileName write SetFileName;
Published property GuiComponents: TGLGuiComponentList read FGuiComponents write FGuiComponents;
Published property Material: TGLMaterial read FMaterial write FMaterial;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:24


GLScene v.1.1.2: GLHeightData

Unit GLHeightData

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class THeightDataSource |
record THeightDataUser |
Class THeightData |
Class THeightDataThread |
Class TGLBitmapHDS |
Class TGLCustomHDS |
Class TGLTerrainBaseHDS |
Class THeightDataSourceFilter |

Types

TByteArray = array [0 .. MaxInt div (2*SizeOf(Byte))] of Byte;
TByteRaster = array [0 .. MaxInt div (2*SizeOf(Pointer))] of PByteArray;
PByteRaster = ˆTByteRaster;
TSmallintArray = array [0 .. MaxInt div (2*SizeOf(SmallInt))] of SmallInt;
PSmallIntArray = ˆTSmallintArray;
TSmallIntRaster = array [0 .. MaxInt div (2*SizeOf(Pointer))] of PSmallIntArray;
PSmallIntRaster = ˆTSmallIntRaster;
TSingleRaster = array [0 .. MaxInt div (2*SizeOf(Pointer))] of PSingleArray;
PSingleRaster = ˆTSingleRaster;
THeightDataClass = class of THeightData;
THeightDataType = (...);
THDTextureCoordinatesMode = (...);
THeightDataState = (...);
TOnHeightDataDirtyEvent = procedure(sender: THeightData) of object;
TStartPreparingDataEvent = procedure(HeightData: THeightData) of object;
TMarkDirtyEvent = procedure(const area: TGLRect) of object;
TSourceDataFetchedEvent = procedure(sender: THeightDataSourceFilter; HeightData: THeightData) of object;

Description

Types

TByteArray = array [0 .. MaxInt div (2*SizeOf(Byte))] of Byte;
TByteRaster = array [0 .. MaxInt div (2*SizeOf(Pointer))] of PByteArray;
PByteRaster = ˆTByteRaster;
TSmallintArray = array [0 .. MaxInt div (2*SizeOf(SmallInt))] of SmallInt;
PSmallIntArray = ˆTSmallintArray;
TSmallIntRaster = array [0 .. MaxInt div (2*SizeOf(Pointer))] of PSmallIntArray;
PSmallIntRaster = ˆTSmallIntRaster;
TSingleRaster = array [0 .. MaxInt div (2*SizeOf(Pointer))] of PSingleArray;
PSingleRaster = ˆTSingleRaster;
THeightDataClass = class of THeightData;
THeightDataType = (...);
Values
  • hdtByte:
  • hdtSmallInt:
  • hdtSingle:
  • hdtDefault:
THDTextureCoordinatesMode = (...);
Values
  • tcmWorld:
  • tcmLocal:
THeightDataState = (...);
Values
  • hdsQueued:
  • hdsPreparing:
  • hdsReady:
  • hdsNone:
TOnHeightDataDirtyEvent = procedure(sender: THeightData) of object;
TStartPreparingDataEvent = procedure(HeightData: THeightData) of object;
TMarkDirtyEvent = procedure(const area: TGLRect) of object;
TSourceDataFetchedEvent = procedure(sender: THeightDataSourceFilter; HeightData: THeightData) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHeightData: Class THeightDataSource

Class THeightDataSource

Unit

GLHeightData

Declaration

type THeightDataSource = class(TComponent)

Description

Hierarchy

  • TComponent
  • THeightDataSource

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetData(XLeft, YTop, Size: Integer; DataType: THeightDataType) : THeightData; virtual;
Public | function Height: Integer; virtual; abstract;
Public | function InterpolatedHeight(x, y: Single; tileSize: Integer) : Single; virtual;
Public | function PreLoad(XLeft, YTop, Size: Integer; DataType: THeightDataType) : THeightData; virtual;
Public | function Width: Integer; virtual; abstract;
Protected | function FindMatchInList(XLeft, YTop, size: Integer; DataType: THeightDataType): THeightData;
Protected | function HashKey(XLeft, YTop: Integer): Integer;
Public | procedure AfterPreparingData(HeightData: THeightData); virtual;
Public | procedure BeforePreparingData(HeightData: THeightData); virtual;
Public | procedure CleanUp;
Public | procedure Clear;
Public | procedure MarkDirty; overload;
Public | procedure MarkDirty(const Area: TGLRect); overload; virtual;
Public | procedure MarkDirty(XLeft, YTop, xRight, yBottom: Integer); overload;
Public | procedure PreloadReplacement(aHeightData: THeightData);
Public | procedure Release(aHeightData: THeightData); virtual;
Public | procedure StartPreparingData(HeightData: THeightData); virtual;
Public | procedure TextureCoordinates(HeightData: THeightData; Stretch: boolean = false);
Public | procedure ThreadIsIdle; virtual;
Protected | procedure SetMaxThreads(const Val: Integer);

Properties

Public | property Data: TThreadList read FData;
Public | property DefaultHeight: Single read FDefaultHeight write FDefaultHeight;
Protected | property HeightDataClass: THeightDataClass read FHeightDataClass write FHeightDataClass;
Public | property MaxPoolSize: Integer read FMaxPoolSize write FMaxPoolSize;
Public | property MaxThreads: Integer read FMaxThreads write SetMaxThreads;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function GetData(XLeft, YTop, Size: Integer; DataType: THeightDataType) : THeightData; virtual;
Public function Height: Integer; virtual; abstract;
Public function InterpolatedHeight(x, y: Single; tileSize: Integer) : Single; virtual;
Public function PreLoad(XLeft, YTop, Size: Integer; DataType: THeightDataType) : THeightData; virtual;
Public function Width: Integer; virtual; abstract;
Protected function FindMatchInList(XLeft, YTop, size: Integer; DataType: THeightDataType): THeightData;
Protected function HashKey(XLeft, YTop: Integer): Integer;
Public procedure AfterPreparingData(HeightData: THeightData); virtual;
Public procedure BeforePreparingData(HeightData: THeightData); virtual;
Public procedure CleanUp;
Public procedure Clear;
Public procedure MarkDirty; overload;
Public procedure MarkDirty(const Area: TGLRect); overload; virtual;
Public procedure MarkDirty(XLeft, YTop, xRight, yBottom: Integer); overload;
Public procedure PreloadReplacement(aHeightData: THeightData);
Public procedure Release(aHeightData: THeightData); virtual;
Public procedure StartPreparingData(HeightData: THeightData); virtual;
Public procedure TextureCoordinates(HeightData: THeightData; Stretch: boolean = false);
Public procedure ThreadIsIdle; virtual;
Protected procedure SetMaxThreads(const Val: Integer);

Properties

Public property Data: TThreadList read FData;
Public property DefaultHeight: Single read FDefaultHeight write FDefaultHeight;
Protected property HeightDataClass: THeightDataClass read FHeightDataClass write FHeightDataClass;
Public property MaxPoolSize: Integer read FMaxPoolSize write FMaxPoolSize;
Public property MaxThreads: Integer read FMaxThreads write SetMaxThreads;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHeightData: record THeightDataUser

record THeightDataUser

Unit

GLHeightData

Declaration

type THeightDataUser = record

Description

Overview

Fields

user: TObject;
event: TOnHeightDataDirtyEvent;

Description

Fields

user: TObject;
event: TOnHeightDataDirtyEvent;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHeightData: Class THeightData

Class THeightData

Unit

GLHeightData

Declaration

type THeightData = class(TGLUpdateAbleObject)

Description

no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • THeightData

Overview

Fields

Protected | FThread: THeightDataThread;
Public | OldVersion: THeightData;
Public | NewVersion: THeightData;
Public | DontUse: boolean;

Methods

Public | constructor Create(AOwner: THeightDataSource; aXLeft, aYTop, aSize: Integer; aDataType: THeightDataType); reintroduce; virtual;
Public | destructor Destroy; override;
Public | function ByteHeight(x, y: Integer): Byte;
Public | function Height(x, y: Integer): Single;
Public | function InterpolatedHeight(x, y: Single): Single;
Public | function Normal(x, y: Integer; const scale: TAffineVector) : TAffineVector; virtual;
Public | function NormalAtNode(x, y: Integer; const scale: TAffineVector) : TAffineVector; virtual;
Public | function OverlapsArea(const area: TGLRect): boolean;
Public | function SingleHeight(x, y: Integer): Single;
Public | function SmallIntHeight(x, y: Integer): SmallInt;
Protected | function GetHeightMax: Single;
Protected | function GetHeightMin: Single;
Public | procedure Allocate(const val: THeightDataType); dynamic;
Public | procedure MarkDirty;
Public | procedure RegisterUse;
Public | procedure Release;
Protected | procedure SetDataType(const val: THeightDataType);
Protected | procedure SetLibMaterial(LibMaterial: TGLLibMaterial);
Protected | procedure SetMaterialName(const MaterialName: string);

Properties

Public | property ByteData: PByteArray read FByteData;
Public | property ByteRaster: PByteRaster read FByteRaster;
Public | property DataSize: Integer read FDataSize;
Public | property DataState: THeightDataState read FDataState write FDataState;
Public | property DataType: THeightDataType read FDataType write SetDataType;
Public | property Dirty: boolean read FDirty write FDirty;
Public | property HeightMax: Single read GetHeightMax write FHeightMax;
Public | property HeightMin: Single read GetHeightMin write FHeightMin;
Public | property LibMaterial: TGLLibMaterial read FLibMaterial write SetLibMaterial;
Public | property MaterialName: String read FMaterialName write SetMaterialName;
Public | property ObjectTag: TObject read FObjectTag write FObjectTag;
Public | property OnDestroy: TNotifyEvent read FOnDestroy write FOnDestroy;
Public | property Owner: THeightDataSource read FOwner;
Public | property SingleData: PSingleArray read FSingleData;
Public | property SingleRaster: PSingleRaster read FSingleRaster;
Public | property Size: Integer read FSize;
Public | property SmallIntData: PSmallIntArray read FSmallIntData;
Public | property SmallIntRaster: PSmallIntRaster read FSmallIntRaster;
Public | property Tag: Integer read FTag write FTag;
Public | property Tag2: Integer read FTag2 write FTag2;
Public | property TextureCoordinatesMode: THDTextureCoordinatesMode read FTextureCoordinatesMode write FTextureCoordinatesMode;
Public | property TextureCoordinatesOffset: TTexPoint read FTCOffset write FTCOffset;
Public | property TextureCoordinatesScale: TTexPoint read FTCScale write FTCScale;
Public | property Thread: THeightDataThread read FThread write FThread;
Public | property UseCounter: Integer read FUseCounter;
Public | property XLeft: Integer read FXLeft;
Public | property YTop: Integer read FYTop;

Description

Fields

Protected FThread: THeightDataThread;
Public OldVersion: THeightData;
Public NewVersion: THeightData;
Public DontUse: boolean;

Methods

Public constructor Create(AOwner: THeightDataSource; aXLeft, aYTop, aSize: Integer; aDataType: THeightDataType); reintroduce; virtual;
Public destructor Destroy; override;
Public function ByteHeight(x, y: Integer): Byte;
Public function Height(x, y: Integer): Single;
Public function InterpolatedHeight(x, y: Single): Single;
Public function Normal(x, y: Integer; const scale: TAffineVector) : TAffineVector; virtual;
Public function NormalAtNode(x, y: Integer; const scale: TAffineVector) : TAffineVector; virtual;
Public function OverlapsArea(const area: TGLRect): boolean;
Public function SingleHeight(x, y: Integer): Single;
Public function SmallIntHeight(x, y: Integer): SmallInt;
Protected function GetHeightMax: Single;
Protected function GetHeightMin: Single;
Public procedure Allocate(const val: THeightDataType); dynamic;
Public procedure MarkDirty;
Public procedure RegisterUse;
Public procedure Release;
Protected procedure SetDataType(const val: THeightDataType);
Protected procedure SetLibMaterial(LibMaterial: TGLLibMaterial);
Protected procedure SetMaterialName(const MaterialName: string);

Properties

Public property ByteData: PByteArray read FByteData;
Public property ByteRaster: PByteRaster read FByteRaster;
Public property DataSize: Integer read FDataSize;
Public property DataState: THeightDataState read FDataState write FDataState;
Public property DataType: THeightDataType read FDataType write SetDataType;
Public property Dirty: boolean read FDirty write FDirty;
Public property HeightMax: Single read GetHeightMax write FHeightMax;
Public property HeightMin: Single read GetHeightMin write FHeightMin;
Public property LibMaterial: TGLLibMaterial read FLibMaterial write SetLibMaterial;
Public property MaterialName: String read FMaterialName write SetMaterialName;
Public property ObjectTag: TObject read FObjectTag write FObjectTag;
Public property OnDestroy: TNotifyEvent read FOnDestroy write FOnDestroy;
Public property Owner: THeightDataSource read FOwner;
Public property SingleData: PSingleArray read FSingleData;
Public property SingleRaster: PSingleRaster read FSingleRaster;
Public property Size: Integer read FSize;
Public property SmallIntData: PSmallIntArray read FSmallIntData;
Public property SmallIntRaster: PSmallIntRaster read FSmallIntRaster;
Public property Tag: Integer read FTag write FTag;
Public property Tag2: Integer read FTag2 write FTag2;
Public property TextureCoordinatesMode: THDTextureCoordinatesMode read FTextureCoordinatesMode write FTextureCoordinatesMode;
Public property TextureCoordinatesOffset: TTexPoint read FTCOffset write FTCOffset;
Public property TextureCoordinatesScale: TTexPoint read FTCScale write FTCScale;
Public property Thread: THeightDataThread read FThread write FThread;
Public property UseCounter: Integer read FUseCounter;
Public property XLeft: Integer read FXLeft;
Public property YTop: Integer read FYTop;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHeightData: Class THeightDataThread

Class THeightDataThread

Unit

GLHeightData

Declaration

type THeightDataThread = class(TThread)

Description

Hierarchy

  • TThread
  • THeightDataThread

Overview

Fields

Protected FHeightData: THeightData;

Methods

Public destructor Destroy; override;

Properties

Public property HeightData: THeightData read FHeightData write FHeightData;

Description

Fields

Protected FHeightData: THeightData;

Methods

Public destructor Destroy; override;

Properties

Public property HeightData: THeightData read FHeightData write FHeightData;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHeightData: Class TGLBitmapHDS

Class TGLBitmapHDS

Unit

GLHeightData

Declaration

type TGLBitmapHDS = class(THeightDataSource)

Description

no description available, THeightDataSource description follows

Hierarchy

  • TComponent
  • THeightDataSource
  • TGLBitmapHDS

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Height: Integer; override;
Public | function Width: Integer; override;
Protected | function GetScanLine(y: Integer): PByteArray;
Public | procedure MarkDirty(const area: TGLRect); override;
Public | procedure StartPreparingData(HeightData: THeightData); override;
Protected | procedure CreateMonochromeBitmap(Size: Integer);
Protected | procedure FreeMonochromeBitmap;
Protected | procedure OnPictureChanged(sender: TObject);
Protected | procedure SetInfiniteWrap(val: boolean);
Protected | procedure SetInverted(val: boolean);
Protected | procedure SetPicture(const val: TGLPicture);

Properties

Published | property InfiniteWrap: boolean read FInfiniteWrap write SetInfiniteWrap default True;
Published | property Inverted: boolean read FInverted write SetInverted default True;
Published | property MaxPoolSize;
Published | property Picture: TGLPicture read FPicture write SetPicture;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function Height: Integer; override;
Public function Width: Integer; override;
Protected function GetScanLine(y: Integer): PByteArray;
Public procedure MarkDirty(const area: TGLRect); override;
Public procedure StartPreparingData(HeightData: THeightData); override;
Protected procedure CreateMonochromeBitmap(Size: Integer);
Protected procedure FreeMonochromeBitmap;
Protected procedure OnPictureChanged(sender: TObject);
Protected procedure SetInfiniteWrap(val: boolean);
Protected procedure SetInverted(val: boolean);
Protected procedure SetPicture(const val: TGLPicture);

Properties

Published property InfiniteWrap: boolean read FInfiniteWrap write SetInfiniteWrap default True;
Published property Inverted: boolean read FInverted write SetInverted default True;
Published property MaxPoolSize;
Published property Picture: TGLPicture read FPicture write SetPicture;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHeightData: Class TGLCustomHDS

Class TGLCustomHDS

Unit

GLHeightData

Declaration

type TGLCustomHDS = class(THeightDataSource)

Description

no description available, THeightDataSource description follows

Hierarchy

  • TComponent
  • THeightDataSource
  • TGLCustomHDS

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure MarkDirty(const area: TGLRect); override;
Public | procedure StartPreparingData(HeightData: THeightData); override;

Properties

Published | property MaxPoolSize;
Published | property OnMarkDirtyEvent: TMarkDirtyEvent read FOnMarkDirty write FOnMarkDirty;
Published | property OnStartPreparingData: TStartPreparingDataEvent read FOnStartPreparingData write FOnStartPreparingData;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure MarkDirty(const area: TGLRect); override;
Public procedure StartPreparingData(HeightData: THeightData); override;

Properties

Published property MaxPoolSize;
Published property OnMarkDirtyEvent: TMarkDirtyEvent read FOnMarkDirty write FOnMarkDirty;
Published property OnStartPreparingData: TStartPreparingDataEvent read FOnStartPreparingData write FOnStartPreparingData;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHeightData: Class TGLTerrainBaseHDS

Class TGLTerrainBaseHDS

Unit

GLHeightData

Declaration

type TGLTerrainBaseHDS = class(THeightDataSource)

Description

no description available, THeightDataSource description follows

Hierarchy

  • TComponent
  • THeightDataSource
  • TGLTerrainBaseHDS

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure StartPreparingData(HeightData: THeightData); override;

Properties

Published property MaxPoolSize;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure StartPreparingData(HeightData: THeightData); override;

Properties

Published property MaxPoolSize;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHeightData: Class THeightDataSourceFilter

Class THeightDataSourceFilter

Unit

GLHeightData

Declaration

type THeightDataSourceFilter = class(THeightDataSource)

Description

no description available, THeightDataSource description follows

Hierarchy

  • TComponent
  • THeightDataSource
  • THeightDataSourceFilter

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Height: Integer; override;
Public | function Width: Integer; override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure Release(aHeightData: THeightData); override;
Public | procedure StartPreparingData(HeightData: THeightData); override;
Protected | procedure PreparingData(HeightData: THeightData); virtual; abstract;
Protected | procedure SetHDS(val: THeightDataSource);

Properties

Published | property Active: boolean read FActive write FActive;
Published | property HeightDataSource: THeightDataSource read FHDS write SetHDS;
Published | property MaxPoolSize;
Public | property OnSourceDataFetched: TSourceDataFetchedEvent read FOnSourceDataFetched write FOnSourceDataFetched;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function Height: Integer; override;
Public function Width: Integer; override;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure Release(aHeightData: THeightData); override;
Public procedure StartPreparingData(HeightData: THeightData); override;
Protected procedure PreparingData(HeightData: THeightData); virtual; abstract;
Protected procedure SetHDS(val: THeightDataSource);

Properties

Published property Active: boolean read FActive write FActive;
Published property HeightDataSource: THeightDataSource read FHDS write SetHDS;
Published property MaxPoolSize;
Public property OnSourceDataFetched: TSourceDataFetchedEvent read FOnSourceDataFetched write FOnSourceDataFetched;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHeightTileFileHDS

Unit GLHeightTileFileHDS

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLHeightTileFileHDS<p>

HeightDataSource for the HTF (HeightTileFile) format.<p>

<b>History : </b><font size=-1><ul> <li>10/03/09 - DanB - Bug fix for invisible terrain, now changes heightdata.DataState to hdsPreparing in StartPreparingData <li>30/03/07 - DaStr - Added $I GLScene.inc <li>15/02/07 - LIN -Added OpenHTF function, for direct access to the HeightTileFile object. <li>25/01/07 - LIN -Added Width and Height properties to GLHeightTileFieHDS <li>19/01/07 - LIN -Bug fix/workaround: Added 'Inverted' property to GLHeightTileFieHDS Set Inverted to false, if you DONT want your rendered terrain to be a mirror image of your height data. (Defaults to true, so it doesnt affect existing apps); <li>29/01/03 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLHeightTileFileHDS |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHeightTileFileHDS: Class TGLHeightTileFileHDS

Class TGLHeightTileFileHDS

Unit

GLHeightTileFileHDS

Declaration

type TGLHeightTileFileHDS = class(THeightDataSource)

Description

An Height Data Source for the HTF format.<p>

Hierarchy

  • TComponent
  • THeightDataSource
  • TGLHeightTileFileHDS

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Height:integer; override;
Public | function OpenHTF:THeightTileFile;
Public | function Width :integer; override;
Public | procedure StartPreparingData(HeightData : THeightData); override;
Protected | procedure SetHTFFileName(const val : String);
Protected | procedure SetInfiniteWrap(val : Boolean);
Protected | procedure SetInverted(val : Boolean);
Protected | procedure SetMinElevation(val : Integer);

Properties

Published | property DefaultHeight;
Published | property HTFFileName : String read FHTFFileName write SetHTFFileName;
Published | property InfiniteWrap : Boolean read FInfiniteWrap write SetInfiniteWrap default True;
Published | property Inverted : Boolean read FInverted write SetInverted default True;
Published | property MaxPoolSize;
Published | property MinElevation : Integer read FMinElevation write SetMinElevation default -32768;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function Height:integer; override;
Public function OpenHTF:THeightTileFile;
Public function Width :integer; override;
Public procedure StartPreparingData(HeightData : THeightData); override;
Protected procedure SetHTFFileName(const val : String);
Protected procedure SetInfiniteWrap(val : Boolean);
Protected procedure SetInverted(val : Boolean);
Protected procedure SetMinElevation(val : Integer);

Properties

Published property DefaultHeight;
Published property HTFFileName : String read FHTFFileName write SetHTFFileName;

FileName of the HTF file.<p> Note that it is accessed via the services of ApplicationFileIO, so this may not necessarily be a regular file on a disk...

Published property InfiniteWrap : Boolean read FInfiniteWrap write SetInfiniteWrap default True;

If true the height field is wrapped indefinetely.

Published property Inverted : Boolean read FInverted write SetInverted default True;

If true the height data is inverted.(Top to bottom)

Published property MaxPoolSize;
Published property MinElevation : Integer read FMinElevation write SetMinElevation default -32768;

Minimum elevation of the tiles that are considered to exist.<p> This property can typically be used to hide underwater tiles.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHiddenLineShader

Unit GLHiddenLineShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLHiddenLineShader<p>

A shader that renders hidden (back-faced) lines differently from visible (front) lines. Polygon offset is used to displace fragments depths a little so that there is no z-fighting in rendering the same geometry multiple times.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>06/06/07 - DaStr - Added $I GLScene.inc Added GLColor to uses (BugtrackerID = 1732211) <li>25/02/07 - DaStr - Moved registration to GLSceneRegister.pas <li>25/09/04 - NelC - Fixed bug of disabled blend (thx Carlos) <li>05/02/04 - NelC - Fixed memory leak in TGLHiddenLineShader.Destroy (thx Achim Hammes) <li>13/12/03 - NelC - Added SurfaceLit, ShadeModel <li>05/12/03 - NelC - Added ForceMaterial <li>03/12/03 - NelC - Creation. Modified from the HiddenLineShader in the multipass demo. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLLineSettings |
Class TGLHiddenLineShader |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHiddenLineShader: Class TGLLineSettings

Class TGLLineSettings

Unit

GLHiddenLineShader

Declaration

type TGLLineSettings = class(TGLUpdateAbleObject)

Description

no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLLineSettings

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | procedure Apply(var rci: TRenderContextInfo);
Public | procedure UnApply(var rci: TRenderContextInfo);

Properties

Published | property Color: TGLColor read FColor write SetColor;
Published | property ForceMaterial: Boolean read FForceMaterial write SetForceMaterial default false;
Published | property Pattern: TGLushort read FPattern write SetPattern default $FFFF;
Published | property Width: Single read FWidth write SetWidth;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public procedure Apply(var rci: TRenderContextInfo);
Public procedure UnApply(var rci: TRenderContextInfo);

Properties

Published property Color: TGLColor read FColor write SetColor;
Published property ForceMaterial: Boolean read FForceMaterial write SetForceMaterial default false;

Set ForceMaterial to true to enforce the application of the line settings for objects that sets their own color, line width and pattern.

Published property Pattern: TGLushort read FPattern write SetPattern default $FFFF;
Published property Width: Single read FWidth write SetWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHiddenLineShader: Class TGLHiddenLineShader

Class TGLHiddenLineShader

Unit

GLHiddenLineShader

Declaration

type TGLHiddenLineShader = class(TGLShader)

Description

no description available, TGLShader description follows

Generic, abstract shader class.<p> Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities.<br> Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLHiddenLineShader

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;

Properties

Published | property BackgroundColor: TGLColor read FBackgroundColor write SetBackgroundColor;
Published | property BackLine: TGLLineSettings read FBackLine write FBackLine;
Published | property FrontLine: TGLLineSettings read FFrontLine write FFrontLine;
Published | property LineSmooth: Boolean read FlineSmooth write SetlineSmooth default false;
Published | property ShadeModel: TGLShadeModel read FShadeModel write SetShadeModel default smDefault;
Published | property Solid: Boolean read FSolid write SetSolid default false;
Published | property SurfaceLit: Boolean read FLighting write SetLighting default true;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;

Properties

Published property BackgroundColor: TGLColor read FBackgroundColor write SetBackgroundColor;

Color used for solid fill.

Published property BackLine: TGLLineSettings read FBackLine write FBackLine;
Published property FrontLine: TGLLineSettings read FFrontLine write FFrontLine;
Published property LineSmooth: Boolean read FlineSmooth write SetlineSmooth default false;

Line smoothing control

Published property ShadeModel: TGLShadeModel read FShadeModel write SetShadeModel default smDefault;

Shade model.<p> Default is "Smooth".<p>

Published property Solid: Boolean read FSolid write SetSolid default false;

Solid controls if you can see through the front-line wireframe.

Published property SurfaceLit: Boolean read FLighting write SetLighting default true;

When Solid is True, determines if lighting or background color is used.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHUDObjects

Unit GLHUDObjects

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLHUDSprite |
Class TGLHUDText |
Class TGLAbsoluteHUDText |
Class TGLResolutionIndependantHUDText |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHUDObjects: Class TGLHUDSprite

Class TGLHUDSprite

Unit

GLHUDObjects

Declaration

type TGLHUDSprite = class(TGLSprite)

Description

no description available, TGLSprite description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLSprite
  • TGLHUDSprite

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Protected | procedure SetXTiles(const val: Integer);
Protected | procedure SetYTiles(const val: Integer);

Properties

Published | property Height stored StoreHeight;
Published | property Width stored StoreWidth;
Published | property XTiles: Integer read FXTiles write SetXTiles default 1;
Published | property YTiles: Integer read FYTiles write SetYTiles default 1;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Protected procedure SetXTiles(const val: Integer);
Protected procedure SetYTiles(const val: Integer);

Properties

Published property Height stored StoreHeight;
Published property Width stored StoreWidth;
Published property XTiles: Integer read FXTiles write SetXTiles default 1;
Published property YTiles: Integer read FYTiles write SetYTiles default 1;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHUDObjects: Class TGLHUDText

Class TGLHUDText

Unit

GLHUDObjects

Declaration

type TGLHUDText = class(TGLImmaterialSceneObject)

Description

no description available, TGLImmaterialSceneObject description follows

Base class for objects that do not have a published "material".<p> Note that the material is available in public properties, but isn't applied automatically before invoking BuildList.<br> Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLHUDText

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure RenderTextAtPosition(const X, Y, Z: Single; var rci: TRenderContextInfo);
Protected | procedure SetAlignment(const val: TAlignment);
Protected | procedure SetBitmapFont(const val: TGLCustomBitmapFont);
Protected | procedure SetLayout(const val: TGLTextLayout);
Protected | procedure SetModulateColor(const val: TGLColor);
Protected | procedure SetRotation(const val: Single);
Protected | procedure SetText(const val: UnicodeString);

Properties

Published | property Alignment: TAlignment read FAlignment write SetAlignment default taLeftJustify;
Published | property BitmapFont: TGLCustomBitmapFont read FBitmapFont write SetBitmapFont;
Published | property Layout: TGLTextLayout read FLayout write SetLayout default tlTop;
Published | property ModulateColor: TGLColor read FModulateColor write SetModulateColor;
Published | property Rotation: Single read FRotation write SetRotation;
Published | property Text: UnicodeString read FText write SetText;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure RenderTextAtPosition(const X, Y, Z: Single; var rci: TRenderContextInfo);
Protected procedure SetAlignment(const val: TAlignment);
Protected procedure SetBitmapFont(const val: TGLCustomBitmapFont);
Protected procedure SetLayout(const val: TGLTextLayout);
Protected procedure SetModulateColor(const val: TGLColor);
Protected procedure SetRotation(const val: Single);
Protected procedure SetText(const val: UnicodeString);

Properties

Published property Alignment: TAlignment read FAlignment write SetAlignment default taLeftJustify;
Published property BitmapFont: TGLCustomBitmapFont read FBitmapFont write SetBitmapFont;
Published property Layout: TGLTextLayout read FLayout write SetLayout default tlTop;
Published property ModulateColor: TGLColor read FModulateColor write SetModulateColor;
Published property Rotation: Single read FRotation write SetRotation;
Published property Text: UnicodeString read FText write SetText;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHUDObjects: Class TGLAbsoluteHUDText

Class TGLAbsoluteHUDText

Unit

GLHUDObjects

Declaration

type TGLAbsoluteHUDText = class(TGLHUDText)

Description

no description available, TGLHUDText description follows
no description available, TGLImmaterialSceneObject description follows

Base class for objects that do not have a published "material".<p> Note that the material is available in public properties, but isn't applied automatically before invoking BuildList.<br> Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLHUDText
  • TGLAbsoluteHUDText

Overview

Methods

Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Description

Methods

Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLHUDObjects: Class TGLResolutionIndependantHUDText

Class TGLResolutionIndependantHUDText

Unit

GLHUDObjects

Declaration

type TGLResolutionIndependantHUDText = class(TGLHUDText)

Description

no description available, TGLHUDText description follows
no description available, TGLImmaterialSceneObject description follows

Base class for objects that do not have a published "material".<p> Note that the material is available in public properties, but isn't applied automatically before invoking BuildList.<br> Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLHUDText
  • TGLResolutionIndependantHUDText

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLImposter

Unit GLImposter

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLImposter<p>

Imposter building and rendering implementation for GLScene.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: used direct HPPEMIT for TLoadingImposterEvent as procedure instead of function in Delphi <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>23/02/07 - DaStr - Fixed TGLFireFXManager.Create (TGLCoordinatesStyle stuff) <li>02/08/04 - LR, YHC - BCB corrections: use record instead array fixed BCB Compiler error "E2370 Simple type name expected" <li>07/05/04 - EG - Perspective distortion properly applied <li>06/05/04 - EG - Fixes, improvements, clean ups <li>04/05/04 - EG - Reworked architecture <li>14/04/04 - SG - Fixed texture clamping for old cards and switched to GL_NEAREST texture sampling. <li>24/03/04 - SG - Initial. </ul></font><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TImposter |
Class TGLImposterBuilder |
Class TGLStaticImposterBuilderCorona |
record TCoronaTangentLookup |
Class TGLStaticImposterBuilderCoronas |
Class TStaticImposter |
Class TGLStaticImposterBuilder |
Class TGLDynamicImposterBuilder |
Class TGLImposter |

Types

TImposterOption = (...);
TImposterOptions = set of TImposterOption;
TLoadingImposterEvent = function (Sender : TObject; impostoredObject : TGLBaseSceneObject; destImposter : TImposter) : TGLBitmap32 of object;
TImposterLoadedEvent = procedure (Sender : TObject; impostoredObject : TGLBaseSceneObject; destImposter : TImposter) of object;
TImposterReference = (...);
TSIBLigthing = (...);

Constants

cDefaultImposterOptions = [impoBlended, impoAlphaTest];

Description

Types

TImposterOption = (...);

Imposter rendering options.<p> Following options are supported:<ul> <li>impoBlended : the imposters are transparently blended during renders, this will smooth their edges but requires them to be rendered sorted from back to front <li>impoAlphaTest : alpha test is used to eliminate transparent pixels, the alpha treshold is adjusted by the AlphaTreshold property <li>impoNearestFiltering : use nearest texture filtering (the alternative is linear filtering) <li>impoPerspectiveCorrection : activates a special imposter rendering projection suitable for distorting the sprites when seen from a level angle of view with a wide focal camera (think trees/grass when walking in a forest), if not active, the imposter sprites are camera-facing </ul>

Values
  • impoBlended:
  • impoAlphaTest:
  • impoNearestFiltering:
  • impoPerspectiveCorrection:
TImposterOptions = set of TImposterOption;
TLoadingImposterEvent = function (Sender : TObject; impostoredObject : TGLBaseSceneObject; destImposter : TImposter) : TGLBitmap32 of object;
TImposterLoadedEvent = procedure (Sender : TObject; impostoredObject : TGLBaseSceneObject; destImposter : TImposter) of object;
TImposterReference = (...);
Values
  • irCenter:
  • irTop:
  • irBottom:
TSIBLigthing = (...);
Values
  • siblNoLighting:
  • siblStaticLighting:
  • siblLocalLighting:

Constants

cDefaultImposterOptions = [impoBlended, impoAlphaTest];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:25


GLScene v.1.1.2: GLImposter: Class TImposter

Class TImposter

Unit

GLImposter

Declaration

type TImposter = class(TObject)

Description

Base class for imposters manipulation and handling.<br> Rendering imposters is performed by three methods, BeginRender must be invoked first, then Render for each of the impostr This class assumes a single impostor per texture.

Note: Remeber to enable Destination Alpha on your viewer.

Hierarchy

  • TObject
  • TImposter

Overview

Fields

Protected | FVx: TVector;
Protected | FVy: TVector;
Protected | FStaticOffset: TVector;
Protected | FQuad: array[0..3] of TVector;
Protected | FStaticScale: Single;

Methods

Public | constructor Create(aBuilder: TGLImposterBuilder); virtual;
Public | destructor Destroy; override;
Public | procedure BeginRender(var rci: TRenderContextInfo); virtual;
Public | procedure EndRender(var rci: TRenderContextInfo); virtual;
Public | procedure Render(var rci: TRenderContextInfo; const objPos, localCameraPos: TVector; size: Single); virtual;
Public | procedure RenderOnce(var rci: TRenderContextInfo; const objPos, localCameraPos: TVector; size: Single);
Protected | procedure PrepareTexture(var rci: TRenderContextInfo); dynamic;
Protected | procedure RenderQuad(const texExtents, objPos: TVector; size: Single);

Properties

Public | property AspectRatio: Single read FAspectRatio write FAspectRatio;
Public | property Builder: TGLImposterBuilder read FBuilder;
Public | property ImpostoredObject: TGLBaseSceneObject read FImpostoredObject write FImpostoredObject;
Public | property Modulated: Boolean read FModulated write FModulated;
Public | property Texture: TGLTextureHandle read FTexture;

Description

Fields

Protected FVx: TVector;
Protected FVy: TVector;
Protected FStaticOffset: TVector;
Protected FQuad: array[0..3] of TVector;
Protected FStaticScale: Single;

Methods

Public constructor Create(aBuilder: TGLImposterBuilder); virtual;
Public destructor Destroy; override;
Public procedure BeginRender(var rci: TRenderContextInfo); virtual;
Public procedure EndRender(var rci: TRenderContextInfo); virtual;
Public procedure Render(var rci: TRenderContextInfo; const objPos, localCameraPos: TVector; size: Single); virtual;
Public procedure RenderOnce(var rci: TRenderContextInfo; const objPos, localCameraPos: TVector; size: Single);
Protected procedure PrepareTexture(var rci: TRenderContextInfo); dynamic;
Protected procedure RenderQuad(const texExtents, objPos: TVector; size: Single);

Properties

Public property AspectRatio: Single read FAspectRatio write FAspectRatio;
Public property Builder: TGLImposterBuilder read FBuilder;
Public property ImpostoredObject: TGLBaseSceneObject read FImpostoredObject write FImpostoredObject;
Public property Modulated: Boolean read FModulated write FModulated;
Public property Texture: TGLTextureHandle read FTexture;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLImposter: Class TGLImposterBuilder

Class TGLImposterBuilder

Unit

GLImposter

Declaration

type TGLImposterBuilder = class(TGLUpdateAbleComponent)

Description

Abstract ImposterBuilder class.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLImposterBuilder

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ImposterFor(impostoredObject: TGLBaseSceneObject): TImposter;
Protected | function CreateNewImposter: TImposter; virtual;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure RequestImposterFor(impostoredObject: TGLBaseSceneObject);
Public | procedure UnRequestImposterFor(impostoredObject: TGLBaseSceneObject);
Protected | procedure DoPrepareImposter(var rci: TRenderContextInfo; impostoredObject: TGLBaseSceneObject; destImposter: TImposter); virtual; abstract;
Protected | procedure DoUserSpecifiedImposter( var rci: TRenderContextInfo; destImposter: TImposter; bmp32: TGLBitmap32); virtual;
Protected | procedure InitializeImpostorTexture(const textureSize: TGLPoint);
Protected | procedure PrepareImposters(Sender: TObject; var rci: TRenderContextInfo); virtual;
Protected | procedure RenderPointFreed(Sender: TObject);
Protected | procedure SetBackColor(AValue: TGLColor);
Protected | procedure SetBuildOffset(AValue: TGLCoordinates);
Protected | procedure SetImposterReference(AValue: TImposterReference);
Protected | procedure SetRenderPoint(AValue: TGLRenderPoint);
Protected | procedure UnregisterImposter(imposter: TImposter);

Properties

Published | property AlphaTreshold: Single read FAlphaTreshold write FAlphaTreshold;
Published | property BackColor: TGLColor read FBackColor write SetBackColor;
Published | property BuildOffset: TGLCoordinates read FBuildOffset write SetBuildOffset;
Published | property ImposterOptions: TImposterOptions read FImposterOptions write FImposterOptions default cDefaultImposterOptions;
Published | property ImposterReference: TImposterReference read FImposterReference write SetImposterReference default irCenter;
Protected | property ImposterRegister: TPersistentObjectList read FImposterRegister;
Published | property OnImposterLoaded: TImposterLoadedEvent read FOnImposterLoaded write FOnImposterLoaded;
Published | property OnLoadingImposter: TLoadingImposterEvent read FOnLoadingImposter write FOnLoadingImposter;
Published | property RenderPoint: TGLRenderPoint read FRenderPoint write SetRenderPoint;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function ImposterFor(impostoredObject: TGLBaseSceneObject): TImposter;

Returns a valid imposter for the specified object.<p> Imposter must have been requested first, and the builder given an opportunity to prepare it before it can be available.

Protected function CreateNewImposter: TImposter; virtual;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure NotifyChange(Sender: TObject); override;
Public procedure RequestImposterFor(impostoredObject: TGLBaseSceneObject);

Request an imposter to be prepared for the specified object.

Public procedure UnRequestImposterFor(impostoredObject: TGLBaseSceneObject);

Tells the imposter for the specified object is no longer needed.

Protected procedure DoPrepareImposter(var rci: TRenderContextInfo; impostoredObject: TGLBaseSceneObject; destImposter: TImposter); virtual; abstract;
Protected procedure DoUserSpecifiedImposter( var rci: TRenderContextInfo; destImposter: TImposter; bmp32: TGLBitmap32); virtual;
Protected procedure InitializeImpostorTexture(const textureSize: TGLPoint);
Protected procedure PrepareImposters(Sender: TObject; var rci: TRenderContextInfo); virtual;
Protected procedure RenderPointFreed(Sender: TObject);
Protected procedure SetBackColor(AValue: TGLColor);
Protected procedure SetBuildOffset(AValue: TGLCoordinates);
Protected procedure SetImposterReference(AValue: TImposterReference);
Protected procedure SetRenderPoint(AValue: TGLRenderPoint);
Protected procedure UnregisterImposter(imposter: TImposter);

Properties

Published property AlphaTreshold: Single read FAlphaTreshold write FAlphaTreshold;

Alpha testing teshold.<p>

Published property BackColor: TGLColor read FBackColor write SetBackColor;

Background color for impostor rendering.<p> Typically, you'll want to leave the alpha channel to zero, and pick as RGB as color that matches the impostor'ed objects edge colors most.

Published property BuildOffset: TGLCoordinates read FBuildOffset write SetBuildOffset;

Offset applied to the impostor'ed object during imposter construction.<p> Can be used to manually tune the centering of objects.

Published property ImposterOptions: TImposterOptions read FImposterOptions write FImposterOptions default cDefaultImposterOptions;

Imposter rendering options.

Published property ImposterReference: TImposterReference read FImposterReference write SetImposterReference default irCenter;

Determines how the imposter are handled.<p> This is the reference point for imposters, impostor'ed objects that are centered should use irCenter, those whose bottom is the origin should use irBottom, etc.

Protected property ImposterRegister: TPersistentObjectList read FImposterRegister;
Published property OnImposterLoaded: TImposterLoadedEvent read FOnImposterLoaded write FOnImposterLoaded;

Event fired after preparing/loading an imposter.<p> This events gives an opportunity to save the imposter after it has been loaded or prepared.

Published property OnLoadingImposter: TLoadingImposterEvent read FOnLoadingImposter write FOnLoadingImposter;

Event fired before preparing/loading an imposter.<p> If an already prepared version of the importer is available, place it in the TGLBitmap32 the event shall return (the bitmap will be freed by the imposter builder). If a bitmap is specified, it will be used in place of what automatic generation could have generated.

Published property RenderPoint: TGLRenderPoint read FRenderPoint write SetRenderPoint;

Specifies the render point at which the impostor texture(s) can be prepared.<p> For best result, the render point should happen in viewer that has a destination alpha (otherwise, impostors will be opaque).

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLImposter: Class TGLStaticImposterBuilderCorona

Class TGLStaticImposterBuilderCorona

Unit

GLImposter

Declaration

type TGLStaticImposterBuilderCorona = class(TCollectionItem)

Description

Describes a set of orientation in a corona fashion.

Hierarchy

  • TCollectionItem
  • TGLStaticImposterBuilderCorona

Overview

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure SetElevation(AValue: Single);
Protected | procedure SetSamples(AValue: Integer);

Properties

Published | property Elevation: Single read FElevation write SetElevation;
Published | property Samples: Integer read FSamples write SetSamples default 8;

Description

Methods

Public constructor Create(ACollection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;
Protected procedure SetElevation(AValue: Single);
Protected procedure SetSamples(AValue: Integer);

Properties

Published property Elevation: Single read FElevation write SetElevation;
Published property Samples: Integer read FSamples write SetSamples default 8;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLImposter: record TCoronaTangentLookup

record TCoronaTangentLookup

Unit

GLImposter

Declaration

type TCoronaTangentLookup = record

Description

Overview

Fields

minTan: Single;
maxTan: Single;
corona: TGLStaticImposterBuilderCorona;

Description

Fields

minTan: Single;
maxTan: Single;
corona: TGLStaticImposterBuilderCorona;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLImposter: Class TGLStaticImposterBuilderCoronas

Class TGLStaticImposterBuilderCoronas

Unit

GLImposter

Declaration

type TGLStaticImposterBuilderCoronas = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLStaticImposterBuilderCoronas

Overview

Methods

Public | constructor Create(AOwner: TPersistent);
Public | function Add: TGLStaticImposterBuilderCorona; overload;
Public | function Add(const elevation: Single; samples: Integer): TGLStaticImposterBuilderCorona; overload;
Public | function SampleCount: Integer;
Protected | function CoronaForElevationTangent(aTangent: Single): TGLStaticImposterBuilderCorona;
Protected | function GetItems(AIndex: Integer): TGLStaticImposterBuilderCorona;
Public | procedure EndUpdate; override;
Public | procedure NotifyChange; virtual;
Protected | procedure PrepareCoronaTangentLookup;
Protected | procedure PrepareSampleBaseIndices;
Protected | procedure SetItems(AIndex: Integer; const AValue: TGLStaticImposterBuilderCorona);
Protected | procedure Update(Item: TCollectionItem); override;

Properties

Public property Items[AIndex: Integer]: TGLStaticImposterBuilderCorona read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent);
Public function Add: TGLStaticImposterBuilderCorona; overload;
Public function Add(const elevation: Single; samples: Integer): TGLStaticImposterBuilderCorona; overload;
Public function SampleCount: Integer;
Protected function CoronaForElevationTangent(aTangent: Single): TGLStaticImposterBuilderCorona;
Protected function GetItems(AIndex: Integer): TGLStaticImposterBuilderCorona;
Public procedure EndUpdate; override;
Public procedure NotifyChange; virtual;
Protected procedure PrepareCoronaTangentLookup;
Protected procedure PrepareSampleBaseIndices;
Protected procedure SetItems(AIndex: Integer; const AValue: TGLStaticImposterBuilderCorona);
Protected procedure Update(Item: TCollectionItem); override;

Properties

Public property Items[AIndex: Integer]: TGLStaticImposterBuilderCorona read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLImposter: Class TStaticImposter

Class TStaticImposter

Unit

GLImposter

Declaration

type TStaticImposter = class(TImposter)

Description

Imposter class whose texture contains several views from different angles.

Hierarchy

  • TObject
  • TImposter
  • TStaticImposter

Overview

Methods

Public procedure Render(var rci: TRenderContextInfo; const objPos, localCameraPos: TVector; size: Single); override;

Description

Methods

Public procedure Render(var rci: TRenderContextInfo; const objPos, localCameraPos: TVector; size: Single); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLImposter: Class TGLStaticImposterBuilder

Class TGLStaticImposterBuilder

Unit

GLImposter

Declaration

type TGLStaticImposterBuilder = class(TGLImposterBuilder)

Description

Builds imposters whose texture is a catalog of prerendered views.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLImposterBuilder
  • TGLStaticImposterBuilder

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function TextureFillRatio: Single;
Protected | function ComputeOptimalTextureSize: TGLPoint;
Protected | function CreateNewImposter: TImposter; override;
Protected | function GetTextureSizeInfo: string;
Protected | function StoreSamplesAlphaScale: Boolean;
Protected | function StoreSamplingRatioBias: Boolean;
Public | procedure Render(var rci: TRenderContextInfo; impostoredObject: TGLBaseSceneObject; destImposter: TImposter);
Protected | procedure ComputeStaticParams(destImposter: TImposter);
Protected | procedure DoPrepareImposter(var rci: TRenderContextInfo; impostoredObject: TGLBaseSceneObject; destImposter: TImposter); override;
Protected | procedure DoUserSpecifiedImposter( var rci: TRenderContextInfo; destImposter: TImposter; bmp32: TGLBitmap32); override;
Protected | procedure SetCoronas(AValue: TGLStaticImposterBuilderCoronas);
Protected | procedure SetLighting(AValue: TSIBLigthing);
Protected | procedure SetSamplesAlphaScale(AValue: Single);
Protected | procedure SetSampleSize(AValue: Integer);
Protected | procedure SetSamplingRatioBias(AValue: Single);
Protected | procedure SetTextureSizeInfo(const texSize: string);

Properties

Published | property Coronas: TGLStaticImposterBuilderCoronas read FCoronas write SetCoronas;
Published | property Lighting: TSIBLigthing read FLighting write FLighting default siblStaticLighting;
Published | property SamplesAlphaScale: Single read FSamplesAlphaScale write SetSamplesAlphaScale stored StoreSamplesAlphaScale;
Published | property SampleSize: Integer read FSampleSize write SetSampleSize default 32;
Public | property SamplesPerAxis: TGLPoint read FSamplesPerAxis;
Published | property SamplingRatioBias: Single read FSamplingRatioBias write SetSamplingRatioBias stored StoreSamplingRatioBias;
Public | property TextureSize: TGLPoint read FTextureSize;
Published | property TextureSizeInfo: string read GetTextureSizeInfo write SetTextureSizeInfo stored False;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function TextureFillRatio: Single;

Ratio (0..1) of the texture that will be used by samples.<p> If this value is below 1, you're wasting texture space and may as well increase the number of samples.

Protected function ComputeOptimalTextureSize: TGLPoint;

Computes the optimal texture size that would be able to hold all samples.

Protected function CreateNewImposter: TImposter; override;
Protected function GetTextureSizeInfo: string;
Protected function StoreSamplesAlphaScale: Boolean;
Protected function StoreSamplingRatioBias: Boolean;
Public procedure Render(var rci: TRenderContextInfo; impostoredObject: TGLBaseSceneObject; destImposter: TImposter);

Render imposter texture.<p> Buffer and object must be compatible, RC must have been activated.

Protected procedure ComputeStaticParams(destImposter: TImposter);
Protected procedure DoPrepareImposter(var rci: TRenderContextInfo; impostoredObject: TGLBaseSceneObject; destImposter: TImposter); override;
Protected procedure DoUserSpecifiedImposter( var rci: TRenderContextInfo; destImposter: TImposter; bmp32: TGLBitmap32); override;
Protected procedure SetCoronas(AValue: TGLStaticImposterBuilderCoronas);
Protected procedure SetLighting(AValue: TSIBLigthing);
Protected procedure SetSamplesAlphaScale(AValue: Single);
Protected procedure SetSampleSize(AValue: Integer);
Protected procedure SetSamplingRatioBias(AValue: Single);
Protected procedure SetTextureSizeInfo(const texSize: string);

Properties

Published property Coronas: TGLStaticImposterBuilderCoronas read FCoronas write SetCoronas;

Description of the samples looking orientations.

Published property Lighting: TSIBLigthing read FLighting write FLighting default siblStaticLighting;

Lighting mode to apply during samples construction.

Published property SamplesAlphaScale: Single read FSamplesAlphaScale write SetSamplesAlphaScale stored StoreSamplesAlphaScale;

Scale factor apply to the sample alpha channel.<p> Main use is to saturate the samples alpha channel, and make fully opaque what would have been partially transparent, while leaving fully transparent what was fully transparent.

Published property SampleSize: Integer read FSampleSize write SetSampleSize default 32;

Size of the imposter samples (square).

Public property SamplesPerAxis: TGLPoint read FSamplesPerAxis;
Published property SamplingRatioBias: Single read FSamplingRatioBias write SetSamplingRatioBias stored StoreSamplingRatioBias;

Size ratio applied to the impostor'ed objects during sampling.<p> Values greater than one can be used to "fill" the samples more by scaling up the object. This is especially useful when the impostor'ed object doesn't fill its bounding sphere, and/or if the outer details are not relevant for impostoring.

Public property TextureSize: TGLPoint read FTextureSize;

Meaningful only after imposter texture has been prepared.

Published property TextureSizeInfo: string read GetTextureSizeInfo write SetTextureSizeInfo stored False;

Dummy property that returns the size of the imposter texture.<p> This property is essentially here as a helper at design time, to give you the requirements your coronas and samplesize parameters imply.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLImposter: Class TGLDynamicImposterBuilder

Class TGLDynamicImposterBuilder

Unit

GLImposter

Declaration

type TGLDynamicImposterBuilder = class(TGLImposterBuilder)

Description

no description available, TGLImposterBuilder description follows

Abstract ImposterBuilder class.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLImposterBuilder
  • TGLDynamicImposterBuilder

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | procedure SetMinDistance(const AValue: Single);

Properties

Published | property MaxTexSize: Integer read FMaxTexSize write FMaxTexSize;
Published | property MinDistance: Single read FMinDistance write SetMinDistance;
Published | property MinTexSize: Integer read FMinTexSize write FMinTexSize;
Published | property Tolerance: Single read FTolerance write FTolerance;
Published | property UseMatrixError: Boolean read FUseMatrixError write FUseMatrixError;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected procedure SetMinDistance(const AValue: Single);

Properties

Published property MaxTexSize: Integer read FMaxTexSize write FMaxTexSize;
Published property MinDistance: Single read FMinDistance write SetMinDistance;
Published property MinTexSize: Integer read FMinTexSize write FMinTexSize;
Published property Tolerance: Single read FTolerance write FTolerance;
Published property UseMatrixError: Boolean read FUseMatrixError write FUseMatrixError;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLImposter: Class TGLImposter

Class TGLImposter

Unit

GLImposter

Declaration

type TGLImposter = class(TGLImmaterialSceneObject)

Description

no description available, TGLImmaterialSceneObject description follows

Base class for objects that do not have a published "material".<p> Note that the material is available in public properties, but isn't applied automatically before invoking BuildList.<br> Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLImposter

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetBuilder(const AValue: TGLImposterBuilder);
Protected | procedure SetImpostoredObject(const AValue: TGLBaseSceneObject);

Properties

Published | property Builder: TGLImposterBuilder read FBuilder write SetBuilder;
Published | property ImpostoredObject: TGLBaseSceneObject read FImpostoredObject write SetImpostoredObject;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetBuilder(const AValue: TGLImposterBuilder);
Protected procedure SetImpostoredObject(const AValue: TGLBaseSceneObject);

Properties

Published property Builder: TGLImposterBuilder read FBuilder write SetBuilder;
Published property ImpostoredObject: TGLBaseSceneObject read FImpostoredObject write SetImpostoredObject;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLKeyboard

Unit GLKeyboard

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLKeyboard<p>

Provides on demand state of any key on the keyboard as well as a set of utility functions for working with virtual keycodes.<p>

Note that windows maps the mouse buttons to virtual key codes too, and you can use the functions/classes in this unit to check mouse buttons too.<br> See "Virtual-Key Codes" in the Win32 programmers réferences for a list of key code constants (VK_* constants are declared in the "Windows" unit).<p>

<b>Historique : </b><font size=-1><ul> <li>07/11/09 - DaStr - Improved FPC compatibility and moved to the /Source/Platform/ directory (BugtrackerID = 2893580) (thanks Predator) <li>28/03/07 - DaStr - Renamed from Keyboard.pas (BugTracker ID = 1678646) <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTrackerID=1681585) <li>19/12/06 - DaS - Added additional string constants and made all existing 'Mixed Case', not 'UPPERCASE' KeyNameToVirtualKeyCode optimized, Fixed comments to KeyNameToVirtualKeyCode() function <li>17/11/03 - Egg - Fixed IsKeyDown (VK) (A. P. Mohrenweiser) <li>09/10/00 - Egg - Fixed VirtualKeyCodeToKeyName <li>03/08/00 - Egg - Creation, partly based Silicon Commander code </ul></font>

Overview

Functions and Procedures

function IsKeyDown(c : Char) : Boolean; overload;
function IsKeyDown(vk : TVirtualKeyCode) : Boolean; overload;
function KeyPressed(minVkCode : TVirtualKeyCode = 0) : TVirtualKeyCode;
function VirtualKeyCodeToKeyName(vk : TVirtualKeyCode) : String;
function KeyNameToVirtualKeyCode(const keyName : String) : TVirtualKeyCode;
function CharToVirtualKeyCode(c : Char) : TVirtualKeyCode;
procedure KeyboardNotifyWheelMoved(wheelDelta : Integer);

Types

TVirtualKeyCode = Integer;

Constants

VK_MOUSEWHEELUP = VK_F23;
VK_MOUSEWHEELDOWN = VK_F24;

Variables

vLastWheelDelta: Integer;

Description

Functions and Procedures

function IsKeyDown(c : Char) : Boolean; overload;

Check if the key corresponding to the given Char is down.<p> The character is mapped to the <i>main keyboard</i> only, and not to the numeric keypad.<br> The Shift/Ctrl/Alt state combinations that may be required to type the character are ignored (ie. 'a' is equivalent to 'A', and on my french keyboard, '5' = '(' = '[' since they all share the same physical key).

function IsKeyDown(vk : TVirtualKeyCode) : Boolean; overload;

Check if the given virtual key is down.<p> This function is just a wrapper for GetAsyncKeyState.

function KeyPressed(minVkCode : TVirtualKeyCode = 0) : TVirtualKeyCode;

Returns the first pressed key whose virtual key code is >= to minVkCode.<p> If no key is pressed, the return value is -1, this function does NOT wait for user input.<br> If you don't care about multiple key presses, just don't use the parameter.

function VirtualKeyCodeToKeyName(vk : TVirtualKeyCode) : String;

Converts a virtual key code to its name.<p> The name is expressed using the locale windows options.

function KeyNameToVirtualKeyCode(const keyName : String) : TVirtualKeyCode;

Converts a key name to its virtual key code.<p> The comparison is **NOT** case-sensitive, if no match is found, returns -1.<p> The name is expressed using the locale windows options, except for mouse buttons which are translated to 'LBUTTON', 'MBUTTON' and 'RBUTTON'.

function CharToVirtualKeyCode(c : Char) : TVirtualKeyCode;

Returns the virtual keycode corresponding to the given char.<p> The returned code is untranslated, f.i. 'a' and 'A' will give the same result. A return value of -1 means that the characted cannot be entered using the keyboard.

procedure KeyboardNotifyWheelMoved(wheelDelta : Integer);

Use this procedure to notify a wheel movement and have it resurfaced as key stroke.<p> Honoured by IsKeyDown and KeyPressed

Types

TVirtualKeyCode = Integer;

Constants

VK_MOUSEWHEELUP = VK_F23;
VK_MOUSEWHEELDOWN = VK_F24;

Variables

vLastWheelDelta: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLLCLViewer

Unit GLLCLViewer

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLLCLViewer<p>

A FPC specific Scene viewer.

<b>History : </b><font size=-1><ul> <li>02/06/10 - Yar - Fixes for Linux x64 <li>28/04/10 - Yar - Fixed conditions for windows platform Added Render method (by Rustam Asmandiarov aka Predator) <li>02/04/10 - Yar - Bugfix bad graphics under Windows (by Rustam Asmandiarov aka Predator) <li>22/12/09 - DaStr - Published TabStop, TabOrder, OnEnter, OnExit properties (thanks Yury Plashenkov) <li>07/11/09 - DaStr - Improved FPC compatibility (BugtrackerID = 2893580) (thanks Predator) <li>13/07/09 - DanB - added the FieldOfView property + reduced OpenGL dependencies <li>10/04/08 - DaStr - Bugfixed TGLSceneViewer.Notification() (thanks z80maniac) (Bugtracker ID = 1936108) <li>12/09/07 - DaStr - Removed old IFDEFs. Moved SetupVSync() to GLViewer.pas (Bugtracker ID = 1786279) <li>04/06/04 - EG - Created from GLWin32Viewer </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSceneViewer |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLLCLViewer: Class TGLSceneViewer

Class TGLSceneViewer

Unit

GLLCLViewer

Declaration

type TGLSceneViewer = class(TWinControl)

Description

Component where the GLScene objects get rendered.<p> This component delimits the area where OpenGL renders the scene, it represents the 3D scene viewed from a camera (specified in the camera property). This component can also render to a file or to a bitmap.<p> It is primarily a windowed component, but it can handle full-screen operations : simply make this component fit the whole screen (use a borderless form).<p> This viewer also allows to define rendering options such a fog, face culling, depth testing, etc. and can take care of framerate calculation.<p>

Hierarchy

  • TWinControl
  • TGLSceneViewer

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateSnapShotBitmap: TBitmap;
Public | function FramesPerSecond: single;
Public | function FramesPerSecondText(decimals: integer = 1): string;
Public | function LastFrameTime: single;
Protected | function GetAfterRender: TNotifyEvent;
Protected | function GetBeforeRender: TNotifyEvent;
Protected | function GetCamera: TGLCamera;
Protected | function GetPostRender: TNotifyEvent;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure Render;
Public | procedure ResetPerformanceMonitor;
Protected | procedure CreateParams(var Params: TCreateParams); override;
Protected | procedure CreateWnd; override;
Protected | procedure DestroyWnd; override;
Protected | procedure DoBeforeRender(Sender: TObject); dynamic;
Protected | procedure DoBufferChange(Sender: TObject); virtual;
Protected | procedure DoBufferStructuralChange(Sender: TObject); dynamic;
Protected | procedure Loaded; override;
Protected | procedure SetAfterRender(const val: TNotifyEvent);
Protected | procedure SetBeforeRender(const val: TNotifyEvent);
Protected | procedure SetBuffer(const val: TGLSceneBuffer);
Protected | procedure SetCamera(const val: TGLCamera);
Protected | procedure SetPostRender(const val: TNotifyEvent);

Properties

Published | property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;
Published | property Align;
Published | property Anchors;
Published | property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;
Published | property Buffer: TGLSceneBuffer read FBuffer write SetBuffer;
Published | property Camera: TGLCamera read GetCamera write SetCamera;
Published | property DragCursor;
Published | property DragMode;
Published | property Enabled;
Published | property FieldOfView: single read GetFieldOfView write SetFieldOfView;
Published | property HelpContext;
Published | property Hint;
Public | property IsRenderingContextAvailable: boolean read GetIsRenderingContextAvailable;
Public | property MouseInControl: boolean read FMouseInControl;
Published | property OnClick;
Published | property OnContextPopup;
Published | property OnDblClick;
Published | property OnDragDrop;
Published | property OnDragOver;
Published | property OnEndDrag;
Published | property OnEnter;
Published | property OnExit;
Published | property OnKeyDown;
Published | property OnKeyUp;
Published | property OnMouseDown;
Published | property OnMouseEnter: TNotifyEvent read FOnMouseEnter write FOnMouseEnter;
Published | property OnMouseLeave: TNotifyEvent read FOnMouseLeave write FOnMouseLeave;
Published | property OnMouseMove;
Published | property OnMouseUp;
Published | property OnMouseWheel;
Published | property OnMouseWheelDown;
Published | property OnMouseWheelUp;
Published | property OnStartDrag;
Published | property PopupMenu;
Published | property PostRender: TNotifyEvent read GetPostRender write SetPostRender;
Public | property RenderDC: HWND read FOwnDC;
Published | property TabOrder;
Published | property TabStop;
Published | property Visible;
Published | property VSync: TVSyncMode read FVSync write FVSync default vsmNoSync;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function CreateSnapShotBitmap: TBitmap;
Public function FramesPerSecond: single;
Public function FramesPerSecondText(decimals: integer = 1): string;
Public function LastFrameTime: single;
Protected function GetAfterRender: TNotifyEvent;
Protected function GetBeforeRender: TNotifyEvent;
Protected function GetCamera: TGLCamera;
Protected function GetPostRender: TNotifyEvent;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure Render;
Public procedure ResetPerformanceMonitor;
Protected procedure CreateParams(var Params: TCreateParams); override;
Protected procedure CreateWnd; override;
Protected procedure DestroyWnd; override;
Protected procedure DoBeforeRender(Sender: TObject); dynamic;
Protected procedure DoBufferChange(Sender: TObject); virtual;
Protected procedure DoBufferStructuralChange(Sender: TObject); dynamic;
Protected procedure Loaded; override;
Protected procedure SetAfterRender(const val: TNotifyEvent);
Protected procedure SetBeforeRender(const val: TNotifyEvent);
Protected procedure SetBuffer(const val: TGLSceneBuffer);
Protected procedure SetCamera(const val: TGLCamera);
Protected procedure SetPostRender(const val: TNotifyEvent);

Properties

Published property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;

Called after rendering.<p> You cannot issue OpenGL calls in this event, if you want to do your own OpenGL stuff, use the PostRender event.

Published property Align;
Published property Anchors;
Published property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;

Triggered before the scene's objects get rendered.<p> You may use this event to execute your own OpenGL rendering.

Published property Buffer: TGLSceneBuffer read FBuffer write SetBuffer;

Access to buffer properties.

Published property Camera: TGLCamera read GetCamera write SetCamera;

Camera from which the scene is rendered.

Published property DragCursor;
Published property DragMode;
Published property Enabled;
Published property FieldOfView: single read GetFieldOfView write SetFieldOfView;

Returns or sets the field of view for the viewer, in degrees.<p> This value depends on the camera and the width and height of the scene. The value isn't persisted, if the width/height or camera.focallength is changed, FieldOfView is changed also.

Published property HelpContext;
Published property Hint;
Public property IsRenderingContextAvailable: boolean read GetIsRenderingContextAvailable;

Makes TWinControl's RecreateWnd public.<p> This procedure allows to work around limitations in some OpenGL drivers (like MS Software OpenGL) that are not able to share lists between RCs that already have display lists.

Public property MouseInControl: boolean read FMouseInControl;
Published property OnClick;
Published property OnContextPopup;
Published property OnDblClick;
Published property OnDragDrop;
Published property OnDragOver;
Published property OnEndDrag;
Published property OnEnter;
Published property OnExit;
Published property OnKeyDown;
Published property OnKeyUp;
Published property OnMouseDown;
Published property OnMouseEnter: TNotifyEvent read FOnMouseEnter write FOnMouseEnter;
Published property OnMouseLeave: TNotifyEvent read FOnMouseLeave write FOnMouseLeave;
Published property OnMouseMove;
Published property OnMouseUp;
Published property OnMouseWheel;
Published property OnMouseWheelDown;
Published property OnMouseWheelUp;
Published property OnStartDrag;
Published property PopupMenu;
Published property PostRender: TNotifyEvent read GetPostRender write SetPostRender;

Triggered just after all the scene's objects have been rendered.<p> The OpenGL context is still active in this event, and you may use it to execute your own OpenGL rendering.<p>

Public property RenderDC: HWND read FOwnDC;
Published property TabOrder;
Published property TabStop;
Published property Visible;
Published property VSync: TVSyncMode read FVSync write FVSync default vsmNoSync;

Specifies if the refresh should be synchronized with the VSync signal.<p> If the underlying OpenGL ICD does not support the WGL_EXT_swap_control extension, this property is ignored.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLLensFlare

Unit GLLensFlare

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLLensFlare<p>

Lens flare object.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>13/03/09 - DanB - changed glReadPixels/glTexImage2D calls to glCopyTexImage2D <li>10/10/08 - DanB - changed Lensflare buildlists to use rci.cameraPosition instead of Scene.CurrentGLCamera.DistanceTo <li>08/08/07 - Lin - Bugfix for AutoZTest: Lensflare is no longer occluded by objects BEHIND the flare. <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Moved all UNSAFE_TYPE, UNSAFE_CODE checks to GLSCene.inc <li>25/03/07 - DaStr - UNSAFE_TYPE and UNSAFE_CODE warnings are now ignored <li>23/03/07 - DaStr - Added missing parameters in procedure's implementation (thanks Burkhard Carstens) (Bugtracker ID = 1681409) <li>22/03/07 - DaStr - Cleanup after previous fix - now object does not igore its children in picking state Removed "unsafe type/unsafe code" warnings <li>15/03/07 - DaStr - Removed flicker that occured when LensFlare was rendered in a picking state (BugTracker ID = 1681031) <li>19/04/04 - EG - Fixed occlusion test and pojection matrix stack issues <li>16/04/04 - EG - Added StreakAngle <li>15/04/04 - EG - Texture-based Lens-flare moved to GLTexLensFlare, replaced gradient arrays with design-time editable colors <li>25/09/03 - EG - Increased occlusion testing robustness <li>20/09/03 - EG - Can now use occlusion testing/query for AutoZTest <li>19/09/03 - EG - Misc. cleanup, added PreRender <li>18/08/03 - SG - Added TGLTextureLensFlare (Tobias Peirick) <li>26/03/03 - EG - Framerate independant glow transitions (Tobias Peirick) <li>08/12/02 - EG - Added AutoZTest <li>29/10/02 - EG - Initial, added defaults and encapsulation, fixed positionning, RandSeed now preserved, minor speedup </ul></font><p>

Author : Tobias Peirick<br> eMail : peirick@onlinehome.de<br> Homepage: http://www.TobSoft.de

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLFlareGradient |
Class TGLLensFlare |

Types

TFlareElement = (...);
TFlareElements = set of TFlareElement;

Constants

cDefaultFlareElements = [feGlow, feRing, feStreaks, feRays, feSecondaries];

Description

Types

TFlareElement = (...);
Values
  • feGlow:
  • feRing:
  • feStreaks:
  • feRays:
  • feSecondaries:
TFlareElements = set of TFlareElement;

Constants

cDefaultFlareElements = [feGlow, feRing, feStreaks, feRays, feSecondaries];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLLensFlare: Class TGLFlareGradient

Class TGLFlareGradient

Unit

GLLensFlare

Declaration

type TGLFlareGradient = class(TGLUpdateAbleObject)

Description

The actual gradients between two colors are, of course, calculated by OpenGL.<p> The start and end colors of a gradient are stored to represent the color of lens flare elements.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLFlareGradient

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | constructor CreateInitialized(AOwner: TPersistent; const fromColor, toColor: TColorVector);
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure SetFromColor(const val: TGLColor);
Protected | procedure SetToColor(const val: TGLColor);

Properties

Published | property FromColor: TGLColor read FFromColor write SetFromColor;
Published | property ToColor: TGLColor read FToColor write SetToColor;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public constructor CreateInitialized(AOwner: TPersistent; const fromColor, toColor: TColorVector);
Public destructor Destroy; override;
Public procedure Assign(Source: TPersistent); override;
Protected procedure SetFromColor(const val: TGLColor);
Protected procedure SetToColor(const val: TGLColor);

Properties

Published property FromColor: TGLColor read FFromColor write SetFromColor;
Published property ToColor: TGLColor read FToColor write SetToColor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLLensFlare: Class TGLLensFlare

Class TGLLensFlare

Unit

GLLensFlare

Declaration

type TGLLensFlare = class(TGLBaseSceneObject)

Description

no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLLensFlare

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function StoreSqueeze: Boolean;
Protected | function StoreStreakWidth: Boolean;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure PreRender(activeBuffer: TGLSceneBuffer);
Protected | procedure PreRenderEvent(Sender: TObject; var rci: TRenderContextInfo);
Protected | procedure PreRenderPointFreed(Sender: TObject);
Protected | procedure RenderRays(StateCache: TGLStateCache; const size: Single);
Protected | procedure RenderRing;
Protected | procedure RenderSecondaries(const posVector: TAffineVector);
Protected | procedure RenderStreaks(StateCache: TGLStateCache);
Protected | procedure SetAutoZTest(aValue: Boolean);
Protected | procedure SetDynamic(aValue: Boolean);
Protected | procedure SetElements(aValue: TFlareElements);
Protected | procedure SetGlowGradient(const val: TGLFlareGradient);
Protected | procedure SetNumSecs(aValue: Integer);
Protected | procedure SetNumStreaks(aValue: Integer);
Protected | procedure SetPreRenderPoint(const val: TGLRenderPoint);
Protected | procedure SetRaysGradient(const val: TGLFlareGradient);
Protected | procedure SetResolution(aValue: Integer);
Protected | procedure SetRingGradient(const val: TGLFlareGradient);
Protected | procedure SetSecondariesGradient(const val: TGLFlareGradient);
Protected | procedure SetSeed(aValue: Integer);
Protected | procedure SetSize(aValue: Integer);
Protected | procedure SetSqueeze(aValue: Single);
Protected | procedure SetStreakAngle(aValue: Single);
Protected | procedure SetStreaksGradient(const val: TGLFlareGradient);
Protected | procedure SetStreakWidth(aValue: Single);
Protected | procedure SetupRenderingOptions(StateCache: TGLStateCache);

Properties

Published | property AutoZTest: Boolean read FAutoZTest write SetAutoZTest default True;
Published | property Behaviours;
Published | property Dynamic: Boolean read FDynamic write FDynamic default True;
Published | property Effects;
Published | property Elements: TFlareElements read FElements write SetElements default cDefaultFlareElements;
Public | property FlareInstantaneousSize: Single read FCurrSize write FCurrSize;
Published | property FlareIsNotOccluded: Boolean read FFlareIsNotOccluded write FFlareIsNotOccluded;
Published | property GlowGradient: TGLFlareGradient read FGlowGradient write SetGlowGradient;
Published | property NumSecs: Integer read FNumSecs write SetNumSecs default 8;
Published | property NumStreaks: Integer read FNumStreaks write SetNumStreaks default 4;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property Position;
Published | property PreRenderPoint: TGLRenderPoint read FPreRenderPoint write SetPreRenderPoint;
Published | property RaysGradient: TGLFlareGradient read FRaysGradient;
Published | property Resolution: Integer read FResolution write SetResolution default 64;
Published | property RingGradient: TGLFlareGradient read FRingGradient;
Published | property SecondariesGradient: TGLFlareGradient read FSecondariesGradient;
Published | property Seed: Integer read FSeed write SetSeed;
Published | property Size: Integer read FSize write SetSize default 50;
Published | property Squeeze: Single read FSqueeze write SetSqueeze stored StoreSqueeze;
Published | property StreakAngle: Single read FStreakAngle write SetStreakAngle;
Published | property StreaksGradient: TGLFlareGradient read FStreaksGradient;
Published | property StreakWidth: Single read FStreakWidth write SetStreakWidth stored StoreStreakWidth;
Published | property Visible;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function StoreSqueeze: Boolean;
Protected function StoreStreakWidth: Boolean;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure PreRender(activeBuffer: TGLSceneBuffer);

Prepares pre-rendered texture to speed up actual rendering.<p> Will use the currently active context as scratch space, and will automatically do nothing if things have already been prepared, thus you can invoke it systematically in a Viewer.BeforeRender event f.i.

Protected procedure PreRenderEvent(Sender: TObject; var rci: TRenderContextInfo);
Protected procedure PreRenderPointFreed(Sender: TObject);
Protected procedure RenderRays(StateCache: TGLStateCache; const size: Single);
Protected procedure RenderRing;
Protected procedure RenderSecondaries(const posVector: TAffineVector);
Protected procedure RenderStreaks(StateCache: TGLStateCache);
Protected procedure SetAutoZTest(aValue: Boolean);
Protected procedure SetDynamic(aValue: Boolean);
Protected procedure SetElements(aValue: TFlareElements);
Protected procedure SetGlowGradient(const val: TGLFlareGradient);
Protected procedure SetNumSecs(aValue: Integer);
Protected procedure SetNumStreaks(aValue: Integer);
Protected procedure SetPreRenderPoint(const val: TGLRenderPoint);
Protected procedure SetRaysGradient(const val: TGLFlareGradient);
Protected procedure SetResolution(aValue: Integer);
Protected procedure SetRingGradient(const val: TGLFlareGradient);
Protected procedure SetSecondariesGradient(const val: TGLFlareGradient);
Protected procedure SetSeed(aValue: Integer);
Protected procedure SetSize(aValue: Integer);
Protected procedure SetSqueeze(aValue: Single);
Protected procedure SetStreakAngle(aValue: Single);
Protected procedure SetStreaksGradient(const val: TGLFlareGradient);
Protected procedure SetStreakWidth(aValue: Single);
Protected procedure SetupRenderingOptions(StateCache: TGLStateCache);

Properties

Published property AutoZTest: Boolean read FAutoZTest write SetAutoZTest default True;

Automatically computes FlareIsNotOccluded depending on ZBuffer test.<p> Not that the automated test may use test result from the previous frame into the next (to avoid a rendering stall).

Published property Behaviours;
Published property Dynamic: Boolean read FDynamic write FDynamic default True;

Is the flare size adjusted dynamically?<p> If true, the flare size will be grown and reduced over a few frames when it switches between occluded and non-occluded states. This requires animation to be active, but results in a smoother appearance.<br> When false, flare will either be at full size or hidden.<p> The flare is always considered non-dynamic at design-time.

Published property Effects;
Published property Elements: TFlareElements read FElements write SetElements default cDefaultFlareElements;

Which elements should be rendered?

Public property FlareInstantaneousSize: Single read FCurrSize write FCurrSize;

Access to the Flare's current size.<p> Flares decay or grow back over several frames, depending on their occlusion status, and this property allows to track or manually alter this instantaneous size.

Published property FlareIsNotOccluded: Boolean read FFlareIsNotOccluded write FFlareIsNotOccluded;

Is the LensFlare not occluded?.<p> If false the flare will fade away, if true, it will fade in and stay. This value is automatically updated if AutoZTest is set.

Published property GlowGradient: TGLFlareGradient read FGlowGradient write SetGlowGradient;
Published property NumSecs: Integer read FNumSecs write SetNumSecs default 8;

Number of secondary flares.

Published property NumStreaks: Integer read FNumStreaks write SetNumStreaks default 4;

Number of streaks.

Published property ObjectsSorting;
Published property OnProgress;
Published property Position;
Published property PreRenderPoint: TGLRenderPoint read FPreRenderPoint write SetPreRenderPoint;

PreRender point for pre-rendered flare textures.<p> See PreRender method for more details.

Published property RaysGradient: TGLFlareGradient read FRaysGradient;
Published property Resolution: Integer read FResolution write SetResolution default 64;

Number of segments used when rendering circles.

Published property RingGradient: TGLFlareGradient read FRingGradient;
Published property SecondariesGradient: TGLFlareGradient read FSecondariesGradient;
Published property Seed: Integer read FSeed write SetSeed;

Random seed

Published property Size: Integer read FSize write SetSize default 50;

MaxRadius of the flare.

Published property Squeeze: Single read FSqueeze write SetSqueeze stored StoreSqueeze;

To create elliptic flares.

Published property StreakAngle: Single read FStreakAngle write SetStreakAngle;

Angle of the streaks (in degrees)

Published property StreaksGradient: TGLFlareGradient read FStreaksGradient;
Published property StreakWidth: Single read FStreakWidth write SetStreakWidth stored StoreStreakWidth;

Width of the streaks.

Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLLinePFX

Unit GLLinePFX

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLLinePFX<p>

A PFX whose particles are lines

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>12/10/08 - DanB - updated to use RCI <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>20/02/05 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLLineParticle |
Class TGLLinePFXManager |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLLinePFX: Class TGLLineParticle

Class TGLLineParticle

Unit

GLLinePFX

Declaration

type TGLLineParticle = class(TGLParticle)

Description

Linear particle.<p>

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLParticle
  • TGLLineParticle

Overview

Methods

Public | procedure ReadFromFiler(reader : TVirtualReader); override;
Public | procedure WriteToFiler(writer : TVirtualWriter); override;

Properties

Public | property Direction : TAffineVector read FDirection write FDirection;
Public | property Length : Single read FLength write FLength;

Description

Methods

Public procedure ReadFromFiler(reader : TVirtualReader); override;
Public procedure WriteToFiler(writer : TVirtualWriter); override;

Properties

Public property Direction : TAffineVector read FDirection write FDirection;

Direction of the line.

Public property Length : Single read FLength write FLength;

Length of the line

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLLinePFX: Class TGLLinePFXManager

Class TGLLinePFXManager

Unit

GLLinePFX

Declaration

type TGLLinePFXManager = class(TGLLifeColoredPFXManager)

Description

Polygonal particles FX manager.<p> The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available.<br> If you render large particles and don't have T&L acceleration, consider using TGLPointLightPFXManager.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager
  • TGLLinePFXManager

Overview

Methods

Public | constructor Create(aOwner : TComponent); override;
Public | destructor Destroy; override;
Public | function CreateParticle : TGLParticle; override;
Public | class function ParticlesClass : TGLParticleClass; override;
Protected | function StoreDefaultLength : Boolean;
Protected | function TexturingMode : Cardinal; override;
Protected | procedure BeginParticles(var rci: TRenderContextInfo); override;
Protected | procedure EndParticles(var rci: TRenderContextInfo); override;
Protected | procedure FinalizeRendering(var rci: TRenderContextInfo); override;
Protected | procedure InitializeRendering(var rci: TRenderContextInfo); override;
Protected | procedure RenderParticle(var rci: TRenderContextInfo; aParticle : TGLParticle); override;

Properties

Published | property ColorInner;
Published | property ColorOuter;
Published | property DefaultLength : Single read FDefaultLength write FDefaultLength stored StoreDefaultLength;
Published | property LifeColors;
Published | property ParticleSize;

Description

Methods

Public constructor Create(aOwner : TComponent); override;
Public destructor Destroy; override;
Public function CreateParticle : TGLParticle; override;
Public class function ParticlesClass : TGLParticleClass; override;
Protected function StoreDefaultLength : Boolean;
Protected function TexturingMode : Cardinal; override;
Protected procedure BeginParticles(var rci: TRenderContextInfo); override;
Protected procedure EndParticles(var rci: TRenderContextInfo); override;
Protected procedure FinalizeRendering(var rci: TRenderContextInfo); override;
Protected procedure InitializeRendering(var rci: TRenderContextInfo); override;
Protected procedure RenderParticle(var rci: TRenderContextInfo; aParticle : TGLParticle); override;

Properties

Published property ColorInner;
Published property ColorOuter;
Published property DefaultLength : Single read FDefaultLength write FDefaultLength stored StoreDefaultLength;
Published property LifeColors;
Published property ParticleSize;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLManager

Unit GLManager

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLManager<p>

Managers are used to manage many different kinds of clients in GLScene. They are registered so that when clients are loaded, the client can look up the manager + register themselves with it.<p>

<b>History : </b><font size=-1><ul> <li>11/11/09 - DaStr - Added $I GLScene.inc <li>05/10/08 - DanB - Created from GLTexture.pas split </ul></font>

Overview

Functions and Procedures

procedure RegisterManager(aManager : TComponent);
procedure DeRegisterManager(aManager : TComponent);
function FindManager(classType : TComponentClass; const managerName : String) : TComponent;

Description

Functions and Procedures

procedure RegisterManager(aManager : TComponent);
procedure DeRegisterManager(aManager : TComponent);
function FindManager(classType : TComponentClass; const managerName : String) : TComponent;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:26


GLScene v.1.1.2: GLMaterial

Unit GLMaterial

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLMaterial<p>

Handles all the material + material library stuff.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPPB compatibility: used dummy instead abstract methods in TGLShader and TGLAbstractLibMaterial for GLS_CPPB <li>11/03/11 - Yar - Extracted abstract classes from TGLLibMaterial, TGLLibMaterials, TGLMaterialLibrary <li>20/02/11 - Yar - Fixed TGLShader's virtual handle behavior with multicontext situation <li>07/01/11 - Yar - Added separate blending function factors for alpha in TGLBlendingParameters <li>20/10/10 - Yar - Added property TextureRotate to TGLLibMaterial, make TextureMatrix writable <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>07/05/10 - Yar - Fixed TGLMaterial.Assign (BugTracker ID = 2998153) <li>22/04/10 - Yar - Fixes after GLState revision <li>06/03/10 - Yar - Added to TGLDepthProperties DepthClamp property <li>05/03/10 - DanB - More state added to TGLStateCache <li>21/02/10 - Yar - Added TGLDepthProperties, optimization of switching states <li>22/01/10 - Yar - Remove Texture.Border and added MappingRCoordinates, MappingQCoordinates to WriteToFiler, ReadFromFiler <li>07/01/10 - DaStr - TexturePaths are now cross-platform (thanks Predator) <li>22/12/09 - DaStr - Updated TGLMaterialLibrary.WriteToFiler(), ReadFromFiler() (thanks dAlex) Small update for blending constants <li>13/12/09 - DaStr - Added a temporary work-around for multithread mode (thanks Controller) Added TGLBlendingParameters and bmCustom blending mode(thanks DungeonLords, Fantom) Fixed code formating in some places <li>24/08/09 - DaStr - Updated TGLLibMaterial.DoOnTextureNeeded: Replaced IncludeTrailingBackslash() with IncludeTrailingPathDelimiter() <li>28/07/09 - DaStr - Updated TGLShader.GetStardardNotSupportedMessage() to use component name instead class name <li>24/07/09 - DaStr - TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) <li>14/07/09 - DaStr - Added $I GLScene.inc <li>08/10/08 - DanB - Created from split from GLTexture.pas, Textures + materials are no longer so tightly bound </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Interface IGLMaterialLibrarySupported |
Class TGLShader |
Class TGLFaceProperties |
Class TGLDepthProperties |
Class TGLBlendingParameters |
Class TGLMaterial |
Class TGLAbstractLibMaterial |
Class TGLLibMaterial |
Class TGLAbstractLibMaterials |
Class TGLLibMaterials |
Class TGLAbstractMaterialLibrary |
Class TGLMaterialLibrary |

Types

TGLShaderStyle = (...);
TGLShaderFailedInitAction = (...);
TGLShaderClass = class of TGLShader;
TShininess = 0..128;
TGLLibMaterialName = string;
TGlAlphaFunc = TComparisonFunction;
TBlendingMode = (...);
TFaceCulling = (...);
TMaterialOption = (...);
TMaterialOptions = set of TMaterialOption;

Description

Types

TGLShaderStyle = (...);

Define GLShader style application relatively to a material.<ul> <li>ssHighLevel: shader is applied before material application, and unapplied after material unapplication <li>ssLowLevel: shader is applied after material application, and unapplied before material unapplication <li>ssReplace: shader is applied in place of the material (and material is completely ignored) </ul>

Values
  • ssHighLevel:
  • ssLowLevel:
  • ssReplace:
TGLShaderFailedInitAction = (...);

Defines what to do if for some reason shader failed to initialize.<ul> <li>fiaSilentdisable: just disable it <li>fiaRaiseHandledException: raise an exception, and handle it right away (usefull, when debigging within Delphi) <li>fiaRaiseStardardException: raises the exception with a string from this function GetStardardNotSupportedMessage <li>fiaReRaiseException: Re-raises the exception <li>fiaGenerateEvent: Handles the exception, but generates an event that user can respond to. For example, he can try to compile a substitude shader, or replace it by a material. Note: HandleFailedInitialization does *not* create this event, it is left to user shaders which may chose to override this procedure. Commented out, because not sure if this option should exist, let other generations of developers decide ;) </ul>

Values
  • fiaSilentDisable:
  • fiaRaiseStandardException:
  • fiaRaiseHandledException:
  • fiaReRaiseException:
TGLShaderClass = class of TGLShader;
TShininess = 0..128;
TGLLibMaterialName = string;
TGlAlphaFunc = TComparisonFunction;
TBlendingMode = (...);

Simplified blending options.<p> bmOpaque : disable blending<br> bmTransparency : uses standard alpha blending<br> bmAdditive : activates additive blending (with saturation)<br> bmAlphaTest50 : uses opaque blending, with alpha-testing at 50% (full transparency if alpha is below 0.5, full opacity otherwise)<br> bmAlphaTest100 : uses opaque blending, with alpha-testing at 100%<br> bmModulate : uses modulation blending<br> bmCustom : uses TGLBlendingParameters options

Values
  • bmOpaque:
  • bmTransparency:
  • bmAdditive:
  • bmAlphaTest50:
  • bmAlphaTest100:
  • bmModulate:
  • bmCustom:
TFaceCulling = (...);
Values
  • fcBufferDefault:
  • fcCull:
  • fcNoCull:
TMaterialOption = (...);

Control special rendering options for a material.<p> moIgnoreFog : fog is deactivated when the material is rendered

Values
  • moIgnoreFog:
  • moNoLighting:
TMaterialOptions = set of TMaterialOption;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterial: Interface IGLMaterialLibrarySupported

Interface IGLMaterialLibrarySupported

Unit

GLMaterial

Declaration

type IGLMaterialLibrarySupported = interface(IInterface)

Description

Hierarchy

  • IInterface
  • IGLMaterialLibrarySupported

Overview

Methods

Public function GetMaterialLibrary: TGLAbstractMaterialLibrary;

Description

Methods

Public function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterial: Class TGLShader

Class TGLShader

Unit

GLMaterial

Declaration

type TGLShader = class(TGLUpdateAbleComponent)

Description

Generic, abstract shader class.<p> Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities.<br> Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ShaderSupported: Boolean; virtual;
Public | function UnApply(var rci: TRenderContextInfo): Boolean;
Protected | function DoUnApply(var rci: TRenderContextInfo): Boolean; virtual; abstract;
Protected | function GetShaderInitialized: Boolean;
Protected | function GetStardardNotSupportedMessage: string; virtual;
Public | procedure Apply(var rci: TRenderContextInfo; Sender: TObject);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); virtual; abstract;
Protected | procedure DoFinalize; dynamic;
Protected | procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); dynamic;
Protected | procedure FinalizeShader;
Protected | procedure HandleFailedInitialization(const LastErrorMessage: string = ''); virtual;
Protected | procedure InitializeShader(var rci: TRenderContextInfo; Sender: TObject);
Protected | procedure OnVirtualHandleAllocate(sender: TGLVirtualHandle; var handle: Cardinal);
Protected | procedure OnVirtualHandleDestroy(sender: TGLVirtualHandle; var handle: Cardinal);
Protected | procedure RegisterUser(libMat: TGLLibMaterial);
Protected | procedure SetEnabled(val: Boolean);
Protected | procedure UnRegisterUser(libMat: TGLLibMaterial);

Properties

Published | property Enabled: Boolean read FEnabled write SetEnabled default True;
Public | property FailedInitAction: TGLShaderFailedInitAction read FFailedInitAction write FFailedInitAction default fiaRaiseStandardException;
Protected | property ShaderActive: Boolean read FShaderActive;
Protected | property ShaderInitialized: Boolean read GetShaderInitialized;
Public | property ShaderStyle: TGLShaderStyle read FShaderStyle write FShaderStyle default ssLowLevel;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function ShaderSupported: Boolean; virtual;

Defines if shader is supported by hardware/drivers. Default - always supported. Descendants are encouraged to override this function.

Public function UnApply(var rci: TRenderContextInfo): Boolean;

UnApply shader.<p> When returning True, the caller is expected to perform a multipass rendering by re-rendering then invoking UnApply again, until a "False" is returned.

Protected function DoUnApply(var rci: TRenderContextInfo): Boolean; virtual; abstract;

Request to un-apply the shader.<p> Subclasses can assume the shader has been applied previously.<br> Return True to request a multipass.

Protected function GetShaderInitialized: Boolean;
Protected function GetStardardNotSupportedMessage: string; virtual;

May be this should be a function inside HandleFailedInitialization...

Public procedure Apply(var rci: TRenderContextInfo; Sender: TObject);

Apply shader to OpenGL state machine.

Public procedure Assign(Source: TPersistent); override;
Public procedure BeginUpdate;
Public procedure EndUpdate;
Public procedure NotifyChange(Sender: TObject); override;

Subclasses should invoke this function when shader properties are altered. This procedure can also be used to reset/recompile the shader.

Protected procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); virtual; abstract;

Request to apply the shader.<p> Always followed by a DoUnApply when the shader is no longer needed.

Protected procedure DoFinalize; dynamic;

Invoked once, before the destruction of context or release of shader.<p> The call happens with the OpenGL context being active.

Protected procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); dynamic;

Invoked once, before the first call to DoApply.<p> The call happens with the OpenGL context being active.

Protected procedure FinalizeShader;
Protected procedure HandleFailedInitialization(const LastErrorMessage: string = ''); virtual;

Used by the DoInitialize procedure of descendant classes to raise errors.

Protected procedure InitializeShader(var rci: TRenderContextInfo; Sender: TObject);
Protected procedure OnVirtualHandleAllocate(sender: TGLVirtualHandle; var handle: Cardinal);
Protected procedure OnVirtualHandleDestroy(sender: TGLVirtualHandle; var handle: Cardinal);
Protected procedure RegisterUser(libMat: TGLLibMaterial);
Protected procedure SetEnabled(val: Boolean);
Protected procedure UnRegisterUser(libMat: TGLLibMaterial);

Properties

Published property Enabled: Boolean read FEnabled write SetEnabled default True;

Turns on/off shader application.<p> Note that this only turns on/off the shader application, if the ShaderStyle is ssReplace, the material won't be applied even if the shader is disabled.

Public property FailedInitAction: TGLShaderFailedInitAction read FFailedInitAction write FFailedInitAction default fiaRaiseStandardException;

Defines what to do if for some reason shader failed to initialize. Note, that in some cases it cannon be determined by just checking the required OpenGL extentions. You need to try to compile and link the shader - only at that stage you might catch an error

Protected property ShaderActive: Boolean read FShaderActive;
Protected property ShaderInitialized: Boolean read GetShaderInitialized;
Public property ShaderStyle: TGLShaderStyle read FShaderStyle write FShaderStyle default ssLowLevel;

Shader application style (default is ssLowLevel).

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterial: Class TGLFaceProperties

Class TGLFaceProperties

Unit

GLMaterial

Declaration

type TGLFaceProperties = class(TGLUpdateAbleObject)

Description

Stores basic face lighting properties.<p> The lighting is described with the standard ambient/diffuse/emission/specular properties that behave like those of most rendering tools.<br> You also have control over shininess (governs specular lighting) and polygon mode (lines / fill).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLFaceProperties

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | procedure Apply(var rci: TRenderContextInfo; aFace: TCullFaceMode);
Public | procedure ApplyNoLighting(var rci: TRenderContextInfo; aFace: TCullFaceMode);
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure SetAmbient(AValue: TGLColor);
Protected | procedure SetDiffuse(AValue: TGLColor);
Protected | procedure SetEmission(AValue: TGLColor);
Protected | procedure SetShininess(AValue: TShininess);
Protected | procedure SetSpecular(AValue: TGLColor);

Properties

Published | property Ambient: TGLColor read FAmbient write SetAmbient;
Published | property Diffuse: TGLColor read FDiffuse write SetDiffuse;
Published | property Emission: TGLColor read FEmission write SetEmission;
Published | property Shininess: TShininess read FShininess write SetShininess default 0;
Published | property Specular: TGLColor read FSpecular write SetSpecular;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public procedure Apply(var rci: TRenderContextInfo; aFace: TCullFaceMode);
Public procedure ApplyNoLighting(var rci: TRenderContextInfo; aFace: TCullFaceMode);
Public procedure Assign(Source: TPersistent); override;
Protected procedure SetAmbient(AValue: TGLColor);
Protected procedure SetDiffuse(AValue: TGLColor);
Protected procedure SetEmission(AValue: TGLColor);
Protected procedure SetShininess(AValue: TShininess);
Protected procedure SetSpecular(AValue: TGLColor);

Properties

Published property Ambient: TGLColor read FAmbient write SetAmbient;
Published property Diffuse: TGLColor read FDiffuse write SetDiffuse;
Published property Emission: TGLColor read FEmission write SetEmission;
Published property Shininess: TShininess read FShininess write SetShininess default 0;
Published property Specular: TGLColor read FSpecular write SetSpecular;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterial: Class TGLDepthProperties

Class TGLDepthProperties

Unit

GLMaterial

Declaration

type TGLDepthProperties = class(TGLUpdateAbleObject)

Description

no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLDepthProperties

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Protected | function StoreZFar: Boolean;
Protected | function StoreZNear: Boolean;
Public | procedure Apply(var rci: TRenderContextInfo);
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure SetCompareFunc(Value: TGLDepthCompareFunc);
Protected | procedure SetDepthClamp(Value: boolean);
Protected | procedure SetDepthTest(Value: boolean);
Protected | procedure SetDepthWrite(Value: boolean);
Protected | procedure SetZFar(Value: Single);
Protected | procedure SetZNear(Value: Single);

Properties

Published | property DepthClamp: Boolean read FDepthClamp write SetDepthClamp default False;
Published | property DepthCompareFunction: TDepthFunction read FCompareFunc write SetCompareFunc default cfLequal;
Published | property DepthTest: boolean read FDepthTest write SetDepthTest default True;
Published | property DepthWrite: boolean read FDepthWrite write SetDepthWrite default True;
Published | property ZFar: Single read FZFar write SetZFar stored StoreZFar;
Published | property ZNear: Single read FZNear write SetZNear stored StoreZNear;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Protected function StoreZFar: Boolean;
Protected function StoreZNear: Boolean;
Public procedure Apply(var rci: TRenderContextInfo);
Public procedure Assign(Source: TPersistent); override;
Protected procedure SetCompareFunc(Value: TGLDepthCompareFunc);
Protected procedure SetDepthClamp(Value: boolean);
Protected procedure SetDepthTest(Value: boolean);
Protected procedure SetDepthWrite(Value: boolean);
Protected procedure SetZFar(Value: Single);
Protected procedure SetZNear(Value: Single);

Properties

Published property DepthClamp: Boolean read FDepthClamp write SetDepthClamp default False;

Enable clipping depth to the near and far planes

Published property DepthCompareFunction: TDepthFunction read FCompareFunc write SetCompareFunc default cfLequal;

Specifies the function used to compare each incoming pixel depth value with the depth value present in the depth buffer.

Published property DepthTest: boolean read FDepthTest write SetDepthTest default True;

DepthTest enabling.<p> When DepthTest is enabled, objects closer to the camera will hide farther ones (via use of Z-Buffering).<br> When DepthTest is disabled, the latest objects drawn/rendered overlap all previous objects, whatever their distance to the camera.<br> Even when DepthTest is enabled, objects may chose to ignore depth testing through the osIgnoreDepthBuffer of their ObjectStyle property.

Published property DepthWrite: boolean read FDepthWrite write SetDepthWrite default True;

If True, object will not write to Z-Buffer.

Published property ZFar: Single read FZFar write SetZFar stored StoreZFar;

Specifies the mapping of the far clipping plane to window coordinates. The initial value is 1.

Published property ZNear: Single read FZNear write SetZNear stored StoreZNear;

Specifies the mapping of the near clipping plane to window coordinates. The initial value is 0.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterial: Class TGLBlendingParameters

Class TGLBlendingParameters

Unit

GLMaterial

Declaration

type TGLBlendingParameters = class(TGLUpdateAbleObject)

Description

no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLBlendingParameters

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | procedure Apply(var rci: TRenderContextInfo);

Properties

Published | property AlphaBlendFuncDFactor: TBlendFunction read FAlphaBlendFuncDFactor write SetAlphaBlendFuncDFactor default bfOneMinusSrcAlpha;
Published | property AlphaBlendFuncSFactor: TBlendFunction read FAlphaBlendFuncSFactor write SetAlphaBlendFuncSFactor default bfSrcAlpha;
Published | property AlphaFuncRef: TGLclampf read FAlphaFuncRef write SetAlphaFuncRef stored StoreAlphaFuncRef;
Published | property AlphaFunctType: TGlAlphaFunc read FAlphaFuncType write SetAlphaFuncType default cfGreater;
Published | property BlendFuncDFactor: TBlendFunction read FBlendFuncDFactor write SetBlendFuncDFactor default bfOneMinusSrcAlpha;
Published | property BlendFuncSFactor: TBlendFunction read FBlendFuncSFactor write SetBlendFuncSFactor default bfSrcAlpha;
Published | property SeparateBlendFunc: Boolean read FSeparateBlendFunc write SetSeparateBlendFunc default False;
Published | property UseAlphaFunc: Boolean read FUseAlphaFunc write SetUseAlphaFunc default False;
Published | property UseBlendFunc: Boolean read FUseBlendFunc write SetUseBlendFunc default True;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public procedure Apply(var rci: TRenderContextInfo);

Properties

Published property AlphaBlendFuncDFactor: TBlendFunction read FAlphaBlendFuncDFactor write SetAlphaBlendFuncDFactor default bfOneMinusSrcAlpha;
Published property AlphaBlendFuncSFactor: TBlendFunction read FAlphaBlendFuncSFactor write SetAlphaBlendFuncSFactor default bfSrcAlpha;
Published property AlphaFuncRef: TGLclampf read FAlphaFuncRef write SetAlphaFuncRef stored StoreAlphaFuncRef;
Published property AlphaFunctType: TGlAlphaFunc read FAlphaFuncType write SetAlphaFuncType default cfGreater;
Published property BlendFuncDFactor: TBlendFunction read FBlendFuncDFactor write SetBlendFuncDFactor default bfOneMinusSrcAlpha;
Published property BlendFuncSFactor: TBlendFunction read FBlendFuncSFactor write SetBlendFuncSFactor default bfSrcAlpha;
Published property SeparateBlendFunc: Boolean read FSeparateBlendFunc write SetSeparateBlendFunc default False;
Published property UseAlphaFunc: Boolean read FUseAlphaFunc write SetUseAlphaFunc default False;
Published property UseBlendFunc: Boolean read FUseBlendFunc write SetUseBlendFunc default True;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterial: Class TGLMaterial

Class TGLMaterial

Unit

GLMaterial

Declaration

type TGLMaterial = class(TGLUpdateAbleObject, IGLMaterialLibrarySupported, IGLNotifyAble, IGLTextureNotifyAble)

Description

Describes a rendering material.<p> A material is basicly a set of face properties (front and back) that take care of standard material rendering parameters (diffuse, ambient, emission and specular) and texture mapping.<br> An instance of this class is available for almost all objects in GLScene to allow quick definition of material properties. It can link to a TGLLibMaterial (taken for a material library).<p> The TGLLibMaterial has more adavanced properties (like texture transforms) and provides a standard way of sharing definitions and texture maps.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLMaterial

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function Blended: Boolean;
Public | function GetActualPrimaryMaterial: TGLMaterial;
Public | function GetActualPrimaryTexture: TGLTexture;
Public | function GetLibMaterial: TGLLibMaterial;
Public | function HasSecondaryTexture: Boolean;
Public | function MaterialIsLinkedToLib: Boolean;
Public | function UnApply(var rci: TRenderContextInfo): Boolean;
Protected | function GetBackProperties: TGLFaceProperties;
Protected | function GetTexture: TGLTexture;
Protected | function GetTextureEx: TGLTextureEx;
Protected | function StoreMaterialProps: Boolean;
Protected | function StoreTextureEx: Boolean;
Public | procedure Apply(var rci: TRenderContextInfo);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DestroyHandles;
Public | procedure Loaded;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure NotifyTexMapChange(Sender: TObject);
Public | procedure PrepareBuildList;
Public | procedure QuickAssignMaterial(const MaterialLibrary: TGLMaterialLibrary; const Material: TGLLibMaterial);
Protected | procedure NotifyLibMaterialDestruction;
Protected | procedure SetBackProperties(Values: TGLFaceProperties);
Protected | procedure SetBlendingMode(const val: TBlendingMode);
Protected | procedure SetBlendingParams(const Value: TGLBlendingParameters);
Protected | procedure SetDepthProperties(Values: TGLDepthProperties);
Protected | procedure SetFaceCulling(const val: TFaceCulling);
Protected | procedure SetFrontProperties(Values: TGLFaceProperties);
Protected | procedure SetLibMaterialName(const val: TGLLibMaterialName);
Protected | procedure SetMaterialLibrary(const val: TGLAbstractMaterialLibrary);
Protected | procedure SetMaterialOptions(const val: TMaterialOptions);
Protected | procedure SetPolygonMode(AValue: TPolygonMode);
Protected | procedure SetTexture(ATexture: TGLTexture);
Protected | procedure SetTextureEx(const value: TGLTextureEx);

Properties

Published | property BackProperties: TGLFaceProperties read GetBackProperties write SetBackProperties stored StoreMaterialProps;
Published | property BlendingMode: TBlendingMode read FBlendingMode write SetBlendingMode stored StoreMaterialProps default bmOpaque;
Published | property BlendingParams: TGLBlendingParameters read FBlendingParams write SetBlendingParams;
Published | property DepthProperties: TGLDepthProperties read FDepthProperties write SetDepthProperties stored StoreMaterialProps;
Published | property FaceCulling: TFaceCulling read FFaceCulling write SetFaceCulling default fcBufferDefault;
Published | property FrontProperties: TGLFaceProperties read FFrontProperties write SetFrontProperties stored StoreMaterialProps;
Published | property LibMaterialName: TGLLibMaterialName read FLibMaterialName write SetLibMaterialName;
Published | property MaterialLibrary: TGLAbstractMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MaterialOptions: TMaterialOptions read FMaterialOptions write SetMaterialOptions default [];
Published | property PolygonMode: TPolygonMode read FPolygonMode write SetPolygonMode default pmFill;
Published | property Texture: TGLTexture read GetTexture write SetTexture stored StoreMaterialProps;
Published | property TextureEx: TGLTextureEx read GetTextureEx write SetTextureEx stored StoreTextureEx;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public function Blended: Boolean;

Returns True if the material is blended.<p> Will return the libmaterial's blending if it is linked to a material library.

Public function GetActualPrimaryMaterial: TGLMaterial;

Gets the primary Material either from material library or the texture property

Public function GetActualPrimaryTexture: TGLTexture;

Gets the primary texture either from material library or the texture property

Public function GetLibMaterial: TGLLibMaterial;

Return the LibMaterial (see LibMaterialName)

Public function HasSecondaryTexture: Boolean;

True if the material has a secondary texture

Public function MaterialIsLinkedToLib: Boolean;

True if the material comes from the library instead of the texture property

Public function UnApply(var rci: TRenderContextInfo): Boolean;

Restore non-standard material states that were altered;<p> A return value of True is a multipass request.

Protected function GetBackProperties: TGLFaceProperties;
Protected function GetTexture: TGLTexture;
Protected function GetTextureEx: TGLTextureEx;
Protected function StoreMaterialProps: Boolean;

Back, Front, Texture and blending not stored if linked to a LibMaterial

Protected function StoreTextureEx: Boolean;
Public procedure Apply(var rci: TRenderContextInfo);
Public procedure Assign(Source: TPersistent); override;
Public procedure DestroyHandles;
Public procedure Loaded;
Public procedure NotifyChange(Sender: TObject); override;
Public procedure NotifyTexMapChange(Sender: TObject);
Public procedure PrepareBuildList;
Public procedure QuickAssignMaterial(const MaterialLibrary: TGLMaterialLibrary; const Material: TGLLibMaterial);
Protected procedure NotifyLibMaterialDestruction;
Protected procedure SetBackProperties(Values: TGLFaceProperties);
Protected procedure SetBlendingMode(const val: TBlendingMode);
Protected procedure SetBlendingParams(const Value: TGLBlendingParameters);
Protected procedure SetDepthProperties(Values: TGLDepthProperties);
Protected procedure SetFaceCulling(const val: TFaceCulling);
Protected procedure SetFrontProperties(Values: TGLFaceProperties);
Protected procedure SetLibMaterialName(const val: TGLLibMaterialName);
Protected procedure SetMaterialLibrary(const val: TGLAbstractMaterialLibrary);
Protected procedure SetMaterialOptions(const val: TMaterialOptions);
Protected procedure SetPolygonMode(AValue: TPolygonMode);
Protected procedure SetTexture(ATexture: TGLTexture);
Protected procedure SetTextureEx(const value: TGLTextureEx);

Properties

Published property BackProperties: TGLFaceProperties read GetBackProperties write SetBackProperties stored StoreMaterialProps;
Published property BlendingMode: TBlendingMode read FBlendingMode write SetBlendingMode stored StoreMaterialProps default bmOpaque;
Published property BlendingParams: TGLBlendingParameters read FBlendingParams write SetBlendingParams;
Published property DepthProperties: TGLDepthProperties read FDepthProperties write SetDepthProperties stored StoreMaterialProps;
Published property FaceCulling: TFaceCulling read FFaceCulling write SetFaceCulling default fcBufferDefault;
Published property FrontProperties: TGLFaceProperties read FFrontProperties write SetFrontProperties stored StoreMaterialProps;
Published property LibMaterialName: TGLLibMaterialName read FLibMaterialName write SetLibMaterialName;
Published property MaterialLibrary: TGLAbstractMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published property MaterialOptions: TMaterialOptions read FMaterialOptions write SetMaterialOptions default [];
Published property PolygonMode: TPolygonMode read FPolygonMode write SetPolygonMode default pmFill;
Published property Texture: TGLTexture read GetTexture write SetTexture stored StoreMaterialProps;
Published property TextureEx: TGLTextureEx read GetTextureEx write SetTextureEx stored StoreTextureEx;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterial: Class TGLAbstractLibMaterial

Class TGLAbstractLibMaterial

Unit

GLMaterial

Declaration

type TGLAbstractLibMaterial = class(TCollectionItem, IGLMaterialLibrarySupported, IGLNotifyAble)

Description

Hierarchy

  • TCollectionItem
  • TGLAbstractLibMaterial

Overview

Fields

Protected | FUserList: TList;
Protected | FName: TGLLibMaterialName;
Protected | FNameHashKey: Integer;
Protected | FTag: Integer;
Protected | FNotifying: Boolean;

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | function Blended: Boolean; virtual;
Public | function IsUsed: boolean;
Public | function UnApply(var ARci: TRenderContextInfo): Boolean; virtual; abstract;
Protected | class function ComputeNameHashKey(const name: string): Integer;
Protected | function GetDisplayName: string; override;
Protected | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Protected | function QueryInterface(const IID: TGUID; out Obj): HResult; stdcall;
Protected | function _AddRef: Integer; stdcall;
Protected | function _Release: Integer; stdcall;
Public | procedure Apply(var ARci: TRenderContextInfo); virtual; abstract;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange(Sender: TObject); virtual;
Public | procedure NotifyUsers;
Public | procedure RegisterUser(libMaterial: TGLLibMaterial); overload;
Public | procedure RegisterUser(comp: TGLUpdateAbleComponent); overload;
Public | procedure RegisterUser(obj: TGLUpdateAbleObject); overload;
Public | procedure UnregisterUser(obj: TGLUpdateAbleObject); overload;
Public | procedure UnregisterUser(comp: TGLUpdateAbleComponent); overload;
Public | procedure UnregisterUser(libMaterial: TGLLibMaterial); overload;
Protected | procedure Loaded; virtual; abstract;
Protected | procedure SetName(const val: TGLLibMaterialName);

Properties

Public | property MaterialLibrary: TGLAbstractMaterialLibrary read GetMaterialLibrary;
Published | property Name: TGLLibMaterialName read FName write SetName;
Public | property NameHashKey: Integer read FNameHashKey;
Published | property Tag: Integer read FTag write FTag;

Description

Fields

Protected FUserList: TList;
Protected FName: TGLLibMaterialName;
Protected FNameHashKey: Integer;
Protected FTag: Integer;
Protected FNotifying: Boolean;

Methods

Public constructor Create(ACollection: TCollection); override;
Public destructor Destroy; override;
Public function Blended: Boolean; virtual;
Public function IsUsed: boolean;
Public function UnApply(var ARci: TRenderContextInfo): Boolean; virtual; abstract;

Restore non-standard material states that were altered

Protected class function ComputeNameHashKey(const name: string): Integer;
Protected function GetDisplayName: string; override;
Protected function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Protected function QueryInterface(const IID: TGUID; out Obj): HResult; stdcall;
Protected function _AddRef: Integer; stdcall;
Protected function _Release: Integer; stdcall;
Public procedure Apply(var ARci: TRenderContextInfo); virtual; abstract;
Public procedure Assign(Source: TPersistent); override;
Public procedure NotifyChange(Sender: TObject); virtual;
Public procedure NotifyUsers;
Public procedure RegisterUser(libMaterial: TGLLibMaterial); overload;
Public procedure RegisterUser(comp: TGLUpdateAbleComponent); overload;
Public procedure RegisterUser(obj: TGLUpdateAbleObject); overload;
Public procedure UnregisterUser(obj: TGLUpdateAbleObject); overload;
Public procedure UnregisterUser(comp: TGLUpdateAbleComponent); overload;
Public procedure UnregisterUser(libMaterial: TGLLibMaterial); overload;
Protected procedure Loaded; virtual; abstract;
Protected procedure SetName(const val: TGLLibMaterialName);

Properties

Public property MaterialLibrary: TGLAbstractMaterialLibrary read GetMaterialLibrary;
Published property Name: TGLLibMaterialName read FName write SetName;
Public property NameHashKey: Integer read FNameHashKey;
Published property Tag: Integer read FTag write FTag;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterial: Class TGLLibMaterial

Class TGLLibMaterial

Unit

GLMaterial

Declaration

type TGLLibMaterial = class(TGLAbstractLibMaterial, IGLTextureNotifyAble)

Description

Material in a material library.<p> Introduces Texture transformations (offset and scale). Those transformations are available only for lib materials to minimize the memory cost of basic materials (which are used in almost all objects).

Hierarchy

  • TCollectionItem
  • TGLAbstractLibMaterial
  • TGLLibMaterial

Overview

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | function Blended: Boolean; override;
Public | function UnApply(var ARci: TRenderContextInfo): Boolean; override;
Protected | function StoreTextureRotate: Boolean;
Public | procedure Apply(var ARci: TRenderContextInfo); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyTexMapChange(Sender: TObject);
Public | procedure NotifyUsersOfTexMapChange;
Public | procedure PrepareBuildList;
Protected | procedure CalculateTextureMatrix;
Protected | procedure DestroyHandles;
Protected | procedure DoOnTextureNeeded(Sender: TObject; var textureFileName: string);
Protected | procedure Loaded; override;
Protected | procedure OnNotifyChange(Sender: TObject);
Protected | procedure SetMaterial(const val: TGLMaterial);
Protected | procedure SetShader(const val: TGLShader);
Protected | procedure SetTexture2Name(const val: TGLLibMaterialName);
Protected | procedure SetTextureMatrix(const Value: TMatrix);
Protected | procedure SetTextureOffset(const val: TGLCoordinates);
Protected | procedure SetTextureRotate(Value: Single);
Protected | procedure SetTextureScale(const val: TGLCoordinates);

Properties

Published | property Material: TGLMaterial read FMaterial write SetMaterial;
Published | property Shader: TGLShader read FShader write SetShader;
Published | property Texture2Name: TGLLibMaterialName read FTexture2Name write SetTexture2Name;
Public | property TextureMatrix: TMatrix read FTextureMatrix write SetTextureMatrix;
Public | property TextureMatrixIsIdentity: boolean read FTextureMatrixIsIdentity;
Published | property TextureOffset: TGLCoordinates read FTextureOffset write SetTextureOffset;
Published | property TextureRotate: Single read FTextureRotate write SetTextureRotate stored StoreTextureRotate;
Published | property TextureScale: TGLCoordinates read FTextureScale write SetTextureScale;

Description

Methods

Public constructor Create(ACollection: TCollection); override;
Public destructor Destroy; override;
Public function Blended: Boolean; override;
Public function UnApply(var ARci: TRenderContextInfo): Boolean; override;

Restore non-standard material states that were altered

Protected function StoreTextureRotate: Boolean;
Public procedure Apply(var ARci: TRenderContextInfo); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure NotifyTexMapChange(Sender: TObject);
Public procedure NotifyUsersOfTexMapChange;
Public procedure PrepareBuildList;
Protected procedure CalculateTextureMatrix;
Protected procedure DestroyHandles;
Protected procedure DoOnTextureNeeded(Sender: TObject; var textureFileName: string);
Protected procedure Loaded; override;
Protected procedure OnNotifyChange(Sender: TObject);
Protected procedure SetMaterial(const val: TGLMaterial);
Protected procedure SetShader(const val: TGLShader);
Protected procedure SetTexture2Name(const val: TGLLibMaterialName);
Protected procedure SetTextureMatrix(const Value: TMatrix);
Protected procedure SetTextureOffset(const val: TGLCoordinates);
Protected procedure SetTextureRotate(Value: Single);
Protected procedure SetTextureScale(const val: TGLCoordinates);

Properties

Published property Material: TGLMaterial read FMaterial write SetMaterial;
Published property Shader: TGLShader read FShader write SetShader;

Optionnal shader for the material.

Published property Texture2Name: TGLLibMaterialName read FTexture2Name write SetTexture2Name;

Reference to the second texture.<p> The referred LibMaterial *must* be in the same material library.<p> Second textures are supported only through ARB multitexturing (ignored if not supported).

Public property TextureMatrix: TMatrix read FTextureMatrix write SetTextureMatrix;
Public property TextureMatrixIsIdentity: boolean read FTextureMatrixIsIdentity;
Published property TextureOffset: TGLCoordinates read FTextureOffset write SetTextureOffset;

Texture offset in texture coordinates.<p> The offset is applied <i>after</i> scaling.

Published property TextureRotate: Single read FTextureRotate write SetTextureRotate stored StoreTextureRotate;
Published property TextureScale: TGLCoordinates read FTextureScale write SetTextureScale;

Texture coordinates scaling.<p> Scaling is applied <i>before</i> applying the offset, and is applied to the texture coordinates, meaning that a scale factor of (2, 2, 2) will make your texture look twice <i>smaller</i>.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterial: Class TGLAbstractLibMaterials

Class TGLAbstractLibMaterials

Unit

GLMaterial

Declaration

type TGLAbstractLibMaterials = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLAbstractLibMaterials

Overview

Methods

Public | function MakeUniqueName(const nameRoot: TGLLibMaterialName): TGLLibMaterialName; virtual;
Protected | function GetMaterial(const AName: TGLLibMaterialName): TGLAbstractLibMaterial; inline;
Protected | procedure Loaded;

Description

Methods

Public function MakeUniqueName(const nameRoot: TGLLibMaterialName): TGLLibMaterialName; virtual;
Protected function GetMaterial(const AName: TGLLibMaterialName): TGLAbstractLibMaterial; inline;
Protected procedure Loaded;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterial: Class TGLLibMaterials

Class TGLLibMaterials

Unit

GLMaterial

Declaration

type TGLLibMaterials = class(TGLAbstractLibMaterials)

Description

A collection of materials, mainly used in material libraries.

Hierarchy

  • TOwnedCollection
  • TGLAbstractLibMaterials
  • TGLLibMaterials

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLLibMaterial;
Public | function FindItemID(ID: Integer): TGLLibMaterial;
Public | function GetLibMaterialByName(const AName: TGLLibMaterialName): TGLLibMaterial;
Public | function GetMaterialIndex(const Material: TGLMaterial): Integer;
Public | function GetNameOfLibMaterial(const Material: TGLLibMaterial): TGLLibMaterialName;
Public | function GetNameOfTexture(const Texture: TGLTexture): TGLLibMaterialName;
Public | function GetTextureIndex(const Texture: TGLTexture): Integer;
Public | function IndexOf(const Item: TGLLibMaterial): Integer;
Public | function Owner: TPersistent;
Protected | function GetItems(index: Integer): TGLLibMaterial;
Public | procedure DeleteUnusedMaterials;
Public | procedure PrepareBuildList;
Protected | procedure DestroyHandles;
Protected | procedure SetItems(index: Integer; const val: TGLLibMaterial);

Properties

Public property Items[index: Integer]: TGLLibMaterial read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);
Public function Add: TGLLibMaterial;
Public function FindItemID(ID: Integer): TGLLibMaterial;
Public function GetLibMaterialByName(const AName: TGLLibMaterialName): TGLLibMaterial;
Public function GetMaterialIndex(const Material: TGLMaterial): Integer;

Returns index of this Material if it exists.

Public function GetNameOfLibMaterial(const Material: TGLLibMaterial): TGLLibMaterialName;

Returns name of this Material if it exists.

Public function GetNameOfTexture(const Texture: TGLTexture): TGLLibMaterialName;

Returns name of this Texture if it exists.

Public function GetTextureIndex(const Texture: TGLTexture): Integer;

Returns index of this Texture if it exists.

Public function IndexOf(const Item: TGLLibMaterial): Integer;
Public function Owner: TPersistent;
Protected function GetItems(index: Integer): TGLLibMaterial;
Public procedure DeleteUnusedMaterials;

Deletes all the unused materials in the collection.<p> A material is considered unused if no other material or updateable object references it. WARNING: For this to work, objects that use the textuere, have to REGISTER to the texture.

Public procedure PrepareBuildList;
Protected procedure DestroyHandles;
Protected procedure SetItems(index: Integer; const val: TGLLibMaterial);

Properties

Public property Items[index: Integer]: TGLLibMaterial read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterial: Class TGLAbstractMaterialLibrary

Class TGLAbstractMaterialLibrary

Unit

GLMaterial

Declaration

type TGLAbstractMaterialLibrary = class(TGLCadenceAbleComponent)

Description

no description available, TGLCadenceAbleComponent description follows

A base class describing the "cadenceing" interface.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLAbstractMaterialLibrary

Overview

Fields

Protected | FMaterials: TGLAbstractLibMaterials;
Protected | FLastAppliedMaterial: TGLAbstractLibMaterial;
Protected | FTexturePaths: string;
Protected | FTexturePathList: TStringList;

Methods

Public | function ApplyMaterial(const AName: string; var ARci: TRenderContextInfo): Boolean; virtual;
Public | function UnApplyMaterial(var ARci: TRenderContextInfo): Boolean; virtual;
Public | procedure SetNamesToTStrings(AStrings: TStrings);
Protected | procedure Loaded; override;
Protected | procedure SetTexturePaths(const val: string);

Properties

Protected property TexturePaths: string read FTexturePaths write SetTexturePaths;

Description

Fields

Protected FMaterials: TGLAbstractLibMaterials;
Protected FLastAppliedMaterial: TGLAbstractLibMaterial;
Protected FTexturePaths: string;
Protected FTexturePathList: TStringList;

Methods

Public function ApplyMaterial(const AName: string; var ARci: TRenderContextInfo): Boolean; virtual;

Applies the material of given name.<p> Returns False if the material could not be found. ake sure this call is balanced with a corresponding UnApplyMaterial (or an assertion will be triggered in the destructor).<br> If a material is already applied, and has not yet been unapplied, an assertion will be triggered.

Public function UnApplyMaterial(var ARci: TRenderContextInfo): Boolean; virtual;

Un-applies the last applied material.<p> Use this function in conjunction with ApplyMaterial.<br> If no material was applied, an assertion will be triggered.

Public procedure SetNamesToTStrings(AStrings: TStrings);
Protected procedure Loaded; override;
Protected procedure SetTexturePaths(const val: string);

Properties

Protected property TexturePaths: string read FTexturePaths write SetTexturePaths;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterial: Class TGLMaterialLibrary

Class TGLMaterialLibrary

Unit

GLMaterial

Declaration

type TGLMaterialLibrary = class(TGLAbstractMaterialLibrary)

Description

Stores a set of materials, to be used and shared by scene objects.<p> Use a material libraries for storing commonly used materials, it provides an efficient way to share texture and material data among many objects, thus reducing memory needs and rendering time.<p> Materials in a material library also feature advanced control properties like texture coordinates transforms.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLAbstractMaterialLibrary
  • TGLMaterialLibrary

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AddTextureMaterial(const materialName: string; graphic: TGLGraphic): TGLLibMaterial; overload;
Public | function AddTextureMaterial(const materialName, fileName: string; persistent: Boolean = True): TGLLibMaterial; overload;
Public | function GetNameOfLibMaterial(const LibMat: TGLLibMaterial): TGLLibMaterialName;
Public | function GetNameOfTexture(const Texture: TGLTexture): TGLLibMaterialName;
Public | function LibMaterialByName(const AName: TGLLibMaterialName): TGLLibMaterial;
Public | function TextureByName(const LibMatName: TGLLibMaterialName): TGLTexture;
Protected | function GetMaterials: TGLLibMaterials;
Protected | function StoreMaterials: Boolean;
Public | procedure AddMaterialsFromFile(const fileName: string);
Public | procedure AddMaterialsFromStream(aStream: TStream);
Public | procedure DestroyHandles;
Public | procedure LoadFromFile(const fileName: string);
Public | procedure LoadFromStream(aStream: TStream); dynamic;
Public | procedure ReadFromFiler(reader: TVirtualReader);
Public | procedure SaveToFile(const fileName: string);
Public | procedure SaveToStream(aStream: TStream); dynamic;
Public | procedure WriteToFiler(writer: TVirtualWriter);
Protected | procedure SetMaterials(const val: TGLLibMaterials);

Properties

Published | property Materials: TGLLibMaterials read GetMaterials write SetMaterials stored StoreMaterials;
Published | property OnTextureNeeded: TTextureNeededEvent read FOnTextureNeeded write FOnTextureNeeded;
Published | property TexturePaths;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AddTextureMaterial(const materialName: string; graphic: TGLGraphic): TGLLibMaterial; overload;

Add a "standard" texture material.<p> TGLGraphic based variant.

Public function AddTextureMaterial(const materialName, fileName: string; persistent: Boolean = True): TGLLibMaterial; overload;

Add a "standard" texture material.<p> "standard" means linear texturing mode with mipmaps and texture modulation mode with default-strength color components.<br> If persistent is True, the image will be loaded persistently in memory (via a TGLPersistentImage), if false, it will be unloaded after upload to OpenGL (via TGLPicFileImage).

Public function GetNameOfLibMaterial(const LibMat: TGLLibMaterial): TGLLibMaterialName;

Returns name of Material if any exists.

Public function GetNameOfTexture(const Texture: TGLTexture): TGLLibMaterialName;

Returns name of texture if any exists.

Public function LibMaterialByName(const AName: TGLLibMaterialName): TGLLibMaterial;

Returns libMaterial of given name if any exists.

Public function TextureByName(const LibMatName: TGLLibMaterialName): TGLTexture;

Returns Texture of given material's name if any exists.

Protected function GetMaterials: TGLLibMaterials;
Protected function StoreMaterials: Boolean;
Public procedure AddMaterialsFromFile(const fileName: string);
Public procedure AddMaterialsFromStream(aStream: TStream);
Public procedure DestroyHandles;
Public procedure LoadFromFile(const fileName: string);
Public procedure LoadFromStream(aStream: TStream); dynamic;
Public procedure ReadFromFiler(reader: TVirtualReader);
Public procedure SaveToFile(const fileName: string);

Save library content to a file.<p> Recommended extension : .GLML<br> Currently saves only texture, ambient, diffuse, emission and specular colors.

Public procedure SaveToStream(aStream: TStream); dynamic;
Public procedure WriteToFiler(writer: TVirtualWriter);
Protected procedure SetMaterials(const val: TGLLibMaterials);

Properties

Published property Materials: TGLLibMaterials read GetMaterials write SetMaterials stored StoreMaterials;

The materials collection.

Published property OnTextureNeeded: TTextureNeededEvent read FOnTextureNeeded write FOnTextureNeeded;

This event is fired whenever a texture needs to be loaded from disk.<p> The event is triggered before even attempting to load the texture, and before TexturePaths is used.

Published property TexturePaths;

Paths to lookup when attempting to load a texture.<p> You can specify multiple paths when loading a texture, the separator being the semi-colon ';' character. Directories are looked up from first to last, the first file name match is used.<br> The current directory is always implicit and checked last.<p> Note that you can also use the OnTextureNeeded event to provide a filename.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterialEx

Unit GLMaterialEx

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLMaterialEx<p>

Handles extended material and it components: textures, samplers, combiners, shaders and etc.

Features: - material can contain different level of applying accordingly to hardware i.e. Feateres scaling. - if automatically or by user selected level failed, material down to lower level. - direct state access can be used for uniforms setting. - economy mode for texture bindig to active units, i.e. if textures less than maximum units may be not one binding occur per frame.

<b>History : </b><font size=-1><ul> <li>13/04/11 - Yar - Added TGLASMVertexProgram, fixed multitexturing <li>11/04/11 - Yar - Added texture internal storing and streaming (yet only 2D images) <li>11/03/11 - Yar - Created </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBaseMaterialCollectionItem |
Class TGLLibMaterialProperty |
Class TGLTextureSampler |
Class TGLAbstractTexture |
Class TGLTextureImageEx |
Class TGLFrameBufferAttachment |
Class TGLTextureSwizzling |
Class TGLTextureProperties |
Class TGLFixedFunctionProperties |
Class TGLTextureCombiner |
Class TGLASMVertexProgram |
Class TGLMultitexturingProperties |
Class TGLShaderEx |
Class TGLAbstractShaderUniform |
Class TGLShaderUniform |
Class TGLShaderUniformDSA |
Class TGLShaderUniformTexture |
Class TGLBaseShaderModel |
Class TGLShaderModel3 |
Class TGLShaderModel4 |
Class TGLShaderModel5 |
Class TGLLibMaterialEx |
Class TGLLibMaterialsEx |
Class TGLMatLibComponents |
Class TGLMaterialLibraryEx |

Functions and Procedures

procedure RegisterGLMaterialExNameChangeEvent(AEvent: TNotifyEvent);
procedure DeRegisterGLMaterialExNameChangeEvent(AEvent: TNotifyEvent);

Types

TGLMaterialComponentName = string;
TOnAsmProgSetting = procedure(Sender: TGLASMVertexProgram; var ARci: TRenderContextInfo) of object;
TOnUniformInitialize = procedure(Sender: TGLBaseShaderModel) of object;
TOnUniformSetting = procedure(Sender: TGLBaseShaderModel; var ARci: TRenderContextInfo) of object;
CGLBaseMaterialCollectionItem = class of TGLBaseMaterialCollectionItem;
TMipmapGenerationMode = (...);
TLightDir2TexEnvColor = (...);
TGLShaderType = (...);
CGLAbstractShaderUniform = class of TGLAbstractShaderUniform;

Description

Functions and Procedures

procedure RegisterGLMaterialExNameChangeEvent(AEvent: TNotifyEvent);
procedure DeRegisterGLMaterialExNameChangeEvent(AEvent: TNotifyEvent);

Types

TGLMaterialComponentName = string;
TOnAsmProgSetting = procedure(Sender: TGLASMVertexProgram; var ARci: TRenderContextInfo) of object;
TOnUniformInitialize = procedure(Sender: TGLBaseShaderModel) of object;
TOnUniformSetting = procedure(Sender: TGLBaseShaderModel; var ARci: TRenderContextInfo) of object;
CGLBaseMaterialCollectionItem = class of TGLBaseMaterialCollectionItem;
TMipmapGenerationMode = (...);
Values
  • mgmNoMip:
  • mgmLeaveExisting:
  • mgmOnFly:
  • mgmBoxFilter:
  • mgmTriangleFilter:
  • mgmHermiteFilter:
  • mgmBellFilter:
  • mgmSplineFilter:
  • mgmLanczos3Filter:
  • mgmMitchellFilter:
TLightDir2TexEnvColor = (...);
Values
  • l2eNone:
  • l2eEnvColor0:
  • l2eEnvColor1:
  • l2eEnvColor2:
  • l2eEnvColor3:
TGLShaderType = (...);
Values
  • shtVertex:
  • shtControl:
  • shtEvaluation:
  • shtGeometry:
  • shtFragment:
CGLAbstractShaderUniform = class of TGLAbstractShaderUniform;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterialEx: Class TGLBaseMaterialCollectionItem

Class TGLBaseMaterialCollectionItem

Unit

GLMaterialEx

Declaration

type TGLBaseMaterialCollectionItem = class(TXCollectionItem, IGLMaterialLibrarySupported)

Description

no description available, TXCollectionItem description follows

Base class for implementing a XCollection item.<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation </ul>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem

Overview

Methods

Public | destructor Destroy; override;
Public | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Public | function GetUserCount: Integer;
Public | procedure RegisterUser(AUser: TGLUpdateAbleObject);
Public | procedure UnregisterUser(AUser: TGLUpdateAbleObject);
Protected | procedure DoOnPrepare(Sender: TGLContext); virtual; abstract;
Protected | procedure NotifyChange(Sender: TObject); virtual;
Protected | procedure SetName(const AValue: TGLMaterialComponentName); override;

Properties

Published | property DefferedInit: Boolean read FDefferedInit write FDefferedInit default False;
Public | property IsValid: Boolean read FIsValid;
Public | property MaterialLibrary: TGLMaterialLibraryEx read GetMaterialLibraryEx;
Published | property Name: TGLMaterialComponentName read GetName write SetName;
Protected | property UserList: TPersistentObjectList read GetUserList;

Description

Methods

Public destructor Destroy; override;
Public function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Public function GetUserCount: Integer;
Public procedure RegisterUser(AUser: TGLUpdateAbleObject);
Public procedure UnregisterUser(AUser: TGLUpdateAbleObject);
Protected procedure DoOnPrepare(Sender: TGLContext); virtual; abstract;
Protected procedure NotifyChange(Sender: TObject); virtual;
Protected procedure SetName(const AValue: TGLMaterialComponentName); override;

Properties

Published property DefferedInit: Boolean read FDefferedInit write FDefferedInit default False;

Run-time flag, indicate that resource should initialize in case of failure material's level.

Public property IsValid: Boolean read FIsValid;
Public property MaterialLibrary: TGLMaterialLibraryEx read GetMaterialLibraryEx;
Published property Name: TGLMaterialComponentName read GetName write SetName;
Protected property UserList: TPersistentObjectList read GetUserList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterialEx: Class TGLLibMaterialProperty

Class TGLLibMaterialProperty

Unit

GLMaterialEx

Declaration

type TGLLibMaterialProperty = class(TGLUpdateAbleObject, IGLMaterialLibrarySupported)

Description

no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLLibMaterialProperty

Overview

Fields

Protected | FEnabled: Boolean;
Protected | FNextPassName: TGLLibMaterialName;

Methods

Public | function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Protected | function GetMaterial: TGLLibMaterialEx;
Protected | function GetMaterialLibraryEx: TGLMaterialLibraryEx;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure Loaded; virtual;
Protected | procedure SetEnabled(AValue: Boolean); virtual;
Protected | procedure SetNextPass(const AValue: TGLLibMaterialName);

Properties

Published | property Enabled: Boolean read FEnabled write SetEnabled;
Public | property MaterialLibrary: TGLMaterialLibraryEx read GetMaterialLibraryEx;
Protected | property NextPass: TGLLibMaterialName read FNextPassName write SetNextPass;

Description

Fields

Protected FEnabled: Boolean;
Protected FNextPassName: TGLLibMaterialName;

Methods

Public function GetMaterialLibrary: TGLAbstractMaterialLibrary;
Protected function GetMaterial: TGLLibMaterialEx;
Protected function GetMaterialLibraryEx: TGLMaterialLibraryEx;
Public procedure NotifyChange(Sender: TObject); override;
Protected procedure Loaded; virtual;
Protected procedure SetEnabled(AValue: Boolean); virtual;
Protected procedure SetNextPass(const AValue: TGLLibMaterialName);

Properties

Published property Enabled: Boolean read FEnabled write SetEnabled;
Public property MaterialLibrary: TGLMaterialLibraryEx read GetMaterialLibraryEx;
Protected property NextPass: TGLLibMaterialName read FNextPassName write SetNextPass;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:27


GLScene v.1.1.2: GLMaterialEx: Class TGLTextureSampler

Class TGLTextureSampler

Unit

GLMaterialEx

Declaration

type TGLTextureSampler = class(TGLBaseMaterialCollectionItem)

Description

no description available, TGLBaseMaterialCollectionItem description follows
no description available, TXCollectionItem description follows

Base class for implementing a XCollection item.<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation </ul>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem
  • TGLTextureSampler

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | procedure Apply(var ARci: TRenderContextInfo);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoOnPrepare(Sender: TGLContext); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure UnApply(var ARci: TRenderContextInfo);
Protected | procedure ReadFromFiler(AReader: TReader); override;
Protected | procedure WriteToFiler(AWriter: TWriter); override;

Properties

Published | property BorderColor: TGLColor read FBorderColor write SetBorderColor;
Published | property CompareFunc: TDepthFunction read FCompareFunc write SetCompareFunc default cfLEqual;
Published | property CompareMode: TGLTextureCompareMode read FCompareMode write SetCompareMode default tcmNone;
Published | property FilteringQuality: TGLTextureFilteringQuality read FFilteringQuality write SetFilteringQuality default tfAnisotropic;
Public | property Handle: TGLSamplerHandle read FHandle;
Published | property LodBias: Integer read FLODBias write SetLODBias default 0;
Published | property MagFilter: TGLMagFilter read FMagFilter write SetMagFilter default maLinear;
Published | property MinFilter: TGLMinFilter read FMinFilter write SetMinFilter default miLinearMipMapLinear;
Published | property sRGB_Encode: Boolean read FDecodeSRGB write SetDecodeSRGB default True;
Published | property WrapX: TGLSeparateTextureWrap index 0 read GetWrap write SetWrap default twRepeat;
Published | property WrapY: TGLSeparateTextureWrap index 1 read GetWrap write SetWrap default twRepeat;
Published | property WrapZ: TGLSeparateTextureWrap index 2 read GetWrap write SetWrap default twRepeat;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyName: string; override;
Public procedure Apply(var ARci: TRenderContextInfo);
Public procedure Assign(Source: TPersistent); override;
Public procedure DoOnPrepare(Sender: TGLContext); override;
Public procedure NotifyChange(Sender: TObject); override;
Public procedure UnApply(var ARci: TRenderContextInfo);
Protected procedure ReadFromFiler(AReader: TReader); override;
Protected procedure WriteToFiler(AWriter: TWriter); override;

Properties

Published property BorderColor: TGLColor read FBorderColor write SetBorderColor;
Published property CompareFunc: TDepthFunction read FCompareFunc write SetCompareFunc default cfLEqual;
Published property CompareMode: TGLTextureCompareMode read FCompareMode write SetCompareMode default tcmNone;
Published property FilteringQuality: TGLTextureFilteringQuality read FFilteringQuality write SetFilteringQuality default tfAnisotropic;
Public property Handle: TGLSamplerHandle read FHandle;
Published property LodBias: Integer read FLODBias write SetLODBias default 0;
Published property MagFilter: TGLMagFilter read FMagFilter write SetMagFilter default maLinear;

Texture magnification filter.

Published property MinFilter: TGLMinFilter read FMinFilter write SetMinFilter default miLinearMipMapLinear;

Texture minification filter.

Published property sRGB_Encode: Boolean read FDecodeSRGB write SetDecodeSRGB default True;

Force retrieving the undecoded sRGB data from the texture and manipulate that directly.

Published property WrapX: TGLSeparateTextureWrap index 0 read GetWrap write SetWrap default twRepeat;
Published property WrapY: TGLSeparateTextureWrap index 1 read GetWrap write SetWrap default twRepeat;
Published property WrapZ: TGLSeparateTextureWrap index 2 read GetWrap write SetWrap default twRepeat;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:28


GLScene v.1.1.2: GLMaterialEx: Class TGLAbstractTexture

Class TGLAbstractTexture

Unit

GLMaterialEx

Declaration

type TGLAbstractTexture = class(TGLBaseMaterialCollectionItem)

Description

no description available, TGLBaseMaterialCollectionItem description follows
no description available, TXCollectionItem description follows

Base class for implementing a XCollection item.<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation </ul>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem
  • TGLAbstractTexture

Overview

Fields

Protected | FHandle: TGLTextureHandle;
Protected | FInternalFormat: TGLInternalFormat;
Protected | FWidth: Integer;
Protected | FHeight: Integer;
Protected | FDepth: Integer;
Protected | FSwizzles: TSwizzleVector;
Protected | FApplicableSampler: TGLTextureSampler;
Protected | FLastSampler: TGLTextureSampler;

Methods

Protected | function GetTextureTarget: TGLTextureTarget;
Protected | procedure Apply(var ARci: TRenderContextInfo); virtual; abstract;
Protected | procedure UnApply(var ARci: TRenderContextInfo); virtual; abstract;

Properties

Public | property Handle: TGLTextureHandle read FHandle;
Published | property Shape: TGLTextureTarget read GetTextureTarget;

Description

Fields

Protected FHandle: TGLTextureHandle;
Protected FInternalFormat: TGLInternalFormat;
Protected FWidth: Integer;
Protected FHeight: Integer;
Protected FDepth: Integer;
Protected FSwizzles: TSwizzleVector;
Protected FApplicableSampler: TGLTextureSampler;
Protected FLastSampler: TGLTextureSampler;

Methods

Protected function GetTextureTarget: TGLTextureTarget;
Protected procedure Apply(var ARci: TRenderContextInfo); virtual; abstract;
Protected procedure UnApply(var ARci: TRenderContextInfo); virtual; abstract;

Properties

Public property Handle: TGLTextureHandle read FHandle;
Published property Shape: TGLTextureTarget read GetTextureTarget;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:28


GLScene v.1.1.2: GLMaterialEx: Class TGLTextureImageEx

Class TGLTextureImageEx

Unit

GLMaterialEx

Declaration

type TGLTextureImageEx = class(TGLAbstractTexture)

Description

no description available, TGLAbstractTexture description follows
no description available, TGLBaseMaterialCollectionItem description follows
no description available, TXCollectionItem description follows

Base class for implementing a XCollection item.<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation </ul>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem
  • TGLAbstractTexture
  • TGLTextureImageEx

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | procedure Apply(var ARci: TRenderContextInfo); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoOnPrepare(Sender: TGLContext); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure UnApply(var ARci: TRenderContextInfo); override;
Protected | procedure ReadFromFiler(AReader: TReader); override;
Protected | procedure WriteToFiler(AWriter: TWriter); override;

Properties

Published | property Compression: TGLTextureCompression read FCompression write SetCompression default tcDefault;
Published | property HeightToNormalScale: Single read FHeightToNormalScale write SetNormalMapScale stored StoreNormalMapScale;
Published | property ImageAlpha: TGLTextureImageAlpha read FImageAlpha write SetImageAlpha default tiaDefault;
Published | property ImageBrightness: Single read FImageBrightness write SetImageBrightness stored StoreBrightness;
Published | property ImageGamma: Single read FImageGamma write SetImageGamma stored StoreGamma;
Published | property InternalDepth: Integer read FDepth;
Published | property InternalFormat: TGLInternalFormat read FInternalFormat write SetInternalFormat default tfRGBA8;
Published | property InternalHeight: Integer read FHeight;
Published | property InternallyStored: Boolean read FInternallyStored write SetInternallyStored default False;
Published | property InternalWidth: Integer read FWidth;
Published | property MipGenMode: TMipmapGenerationMode read FMipGenMode write SetMipGenMode default mgmOnFly;
Published | property SourceFile: string read FSourceFile write SetSourceFile;
Published | property UseStreaming: Boolean read FUseStreaming write SetUseStreaming default False;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyName: string; override;
Public procedure Apply(var ARci: TRenderContextInfo); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoOnPrepare(Sender: TGLContext); override;
Public procedure NotifyChange(Sender: TObject); override;
Public procedure UnApply(var ARci: TRenderContextInfo); override;
Protected procedure ReadFromFiler(AReader: TReader); override;
Protected procedure WriteToFiler(AWriter: TWriter); override;

Properties

Published property Compression: TGLTextureCompression read FCompression write SetCompression default tcDefault;

Texture compression control.<p> If True the compressed TextureFormat variant (the OpenGL ICD must support GL_ARB_texture_compression, or this option is ignored).

Published property HeightToNormalScale: Single read FHeightToNormalScale write SetNormalMapScale stored StoreNormalMapScale;

Normal Map scaling.<p> Force normal map generation from height map and controls the intensity of the bumps.

Published property ImageAlpha: TGLTextureImageAlpha read FImageAlpha write SetImageAlpha default tiaDefault;

Automatic Image Alpha setting.<p> Allows to control how and if the image's Alpha channel (transparency) is computed.

Published property ImageBrightness: Single read FImageBrightness write SetImageBrightness stored StoreBrightness;

Texture brightness correction.<p> This correction is applied upon loading a TGLTextureImage, it's a simple saturating scaling applied to the RGB components of the 32 bits image, before it is passed to OpenGL, and before gamma correction (if any).

Published property ImageGamma: Single read FImageGamma write SetImageGamma stored StoreGamma;

Texture gamma correction.<p> The gamma correction is applied upon loading a TGLTextureImage, applied to the RGB components of the 32 bits image, before it is passed to OpenGL, after brightness correction (if any).

Published property InternalDepth: Integer read FDepth;
Published property InternalFormat: TGLInternalFormat read FInternalFormat write SetInternalFormat default tfRGBA8;
Published property InternalHeight: Integer read FHeight;
Published property InternallyStored: Boolean read FInternallyStored write SetInternallyStored default False;

Force to store image levels in separate files in ready to transfer format.

Published property InternalWidth: Integer read FWidth;
Published property MipGenMode: TMipmapGenerationMode read FMipGenMode write SetMipGenMode default mgmOnFly;

Mipmap generation mode.

Published property SourceFile: string read FSourceFile write SetSourceFile;

Source file path and name.

Published property UseStreaming: Boolean read FUseStreaming write SetUseStreaming default False;

Enable streaming loading.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:28


GLScene v.1.1.2: GLMaterialEx: Class TGLFrameBufferAttachment

Class TGLFrameBufferAttachment

Unit

GLMaterialEx

Declaration

type TGLFrameBufferAttachment = class(TGLAbstractTexture)

Description

no description available, TGLAbstractTexture description follows
no description available, TGLBaseMaterialCollectionItem description follows
no description available, TXCollectionItem description follows

Base class for implementing a XCollection item.<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation </ul>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem
  • TGLAbstractTexture
  • TGLFrameBufferAttachment

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | procedure Apply(var ARci: TRenderContextInfo); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoOnPrepare(Sender: TGLContext); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure UnApply(var ARci: TRenderContextInfo); override;
Protected | procedure ReadFromFiler(AReader: TReader); override;
Protected | procedure WriteToFiler(AWriter: TWriter); override;

Properties

Published | property CubeMap: Boolean read FCubeMap write SetCubeMap default False;
Published | property FixedSamplesLocation: Boolean read FFixedSamplesLocation write SetFixedSamplesLocation default False;
Published | property InternalDepth: Integer read FDepth write SetDepth default 0;
Published | property InternalFormat: TGLInternalFormat read FInternalFormat write SetInternalFormat default tfRGBA8;
Published | property InternalHeight: Integer read FHeight write SetHeight default 256;
Published | property InternalWidth: Integer read FWidth write SetWidth default 256;
Published | property Layered: Boolean read FLayered write SetLayered default False;
Published | property OnlyWrite: Boolean read FOnlyWrite write SetOnlyWrite default False;
Published | property Samples: Integer read FSamples write SetSamples default -1;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyName: string; override;
Public procedure Apply(var ARci: TRenderContextInfo); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoOnPrepare(Sender: TGLContext); override;
Public procedure NotifyChange(Sender: TObject); override;
Public procedure UnApply(var ARci: TRenderContextInfo); override;
Protected procedure ReadFromFiler(AReader: TReader); override;
Protected procedure WriteToFiler(AWriter: TWriter); override;

Properties

Published property CubeMap: Boolean read FCubeMap write SetCubeMap default False;

Force target be cube map.

Published property FixedSamplesLocation: Boolean read FFixedSamplesLocation write SetFixedSamplesLocation default False;

FixedSamplesLocation flag makes image will use identical sample locations and the same number of samples for all texels in the image, and the sample locations will not depend on the internalformat or size of the image.

Published property InternalDepth: Integer read FDepth write SetDepth default 0;
Published property InternalFormat: TGLInternalFormat read FInternalFormat write SetInternalFormat default tfRGBA8;
Published property InternalHeight: Integer read FHeight write SetHeight default 256;
Published property InternalWidth: Integer read FWidth write SetWidth default 256;
Published property Layered: Boolean read FLayered write SetLayered default False;

Force targe be texture array.

Published property OnlyWrite: Boolean read FOnlyWrite write SetOnlyWrite default False;

This flag makes use render buffer as target which makes it impossible to read it as texture, but improves efficiency.

Published property Samples: Integer read FSamples write SetSamples default -1;

Number of samples. Positive value makes texture be multisample.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:28


GLScene v.1.1.2: GLMaterialEx: Class TGLTextureSwizzling

Class TGLTextureSwizzling

Unit

GLMaterialEx

Declaration

type TGLTextureSwizzling = class(TGLUpdateAbleObject)

Description

Swizzle the components of a texture fetches in shader or fixed-function pipeline.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLTextureSwizzling

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ReadFromFiler(AReader: TReader);
Public | procedure WriteToFiler(AWriter: TWriter);

Properties

Published | property AlphaFrom: TGLTextureSwizzle index 3 read GetSwizzle write SetSwizzle stored StoreSwizzle;
Published | property BlueFrom: TGLTextureSwizzle index 2 read GetSwizzle write SetSwizzle stored StoreSwizzle;
Published | property GreenFrom: TGLTextureSwizzle index 1 read GetSwizzle write SetSwizzle stored StoreSwizzle;
Published | property RedFrom: TGLTextureSwizzle index 0 read GetSwizzle write SetSwizzle stored StoreSwizzle;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure ReadFromFiler(AReader: TReader);
Public procedure WriteToFiler(AWriter: TWriter);

Properties

Published property AlphaFrom: TGLTextureSwizzle index 3 read GetSwizzle write SetSwizzle stored StoreSwizzle;
Published property BlueFrom: TGLTextureSwizzle index 2 read GetSwizzle write SetSwizzle stored StoreSwizzle;
Published property GreenFrom: TGLTextureSwizzle index 1 read GetSwizzle write SetSwizzle stored StoreSwizzle;
Published property RedFrom: TGLTextureSwizzle index 0 read GetSwizzle write SetSwizzle stored StoreSwizzle;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:28


GLScene v.1.1.2: GLMaterialEx: Class TGLTextureProperties

Class TGLTextureProperties

Unit

GLMaterialEx

Declaration

type TGLTextureProperties = class(TGLLibMaterialProperty)

Description

no description available, TGLLibMaterialProperty description follows
no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLLibMaterialProperty
  • TGLTextureProperties

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function IsValid: Boolean;
Public | procedure Apply(var ARci: TRenderContextInfo);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Notification(Sender: TObject; Operation: TOperation); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure UnApply(var ARci: TRenderContextInfo);
Protected | procedure Loaded; override;

Properties

Published | property EnvColor: TGLColor read FEnvColor write SetEnvColor;
Published | property LibSamplerName: TGLMaterialComponentName read GetLibSamplerName write SetLibSamplerName;
Published | property LibTextureName: TGLMaterialComponentName read GetLibTextureName write SetLibTextureName;
Published | property MappingMode: TGLTextureMappingMode read FMappingMode write SetMappingMode default tmmUser;
Published | property MappingQCoordinates: TGLCoordinates4 read GetMappingQCoordinates write SetMappingQCoordinates stored StoreMappingQCoordinates;
Published | property MappingRCoordinates: TGLCoordinates4 read GetMappingRCoordinates write SetMappingRCoordinates stored StoreMappingRCoordinates;
Published | property MappingSCoordinates: TGLCoordinates4 read GetMappingSCoordinates write SetMappingSCoordinates stored StoreMappingSCoordinates;
Published | property MappingTCoordinates: TGLCoordinates4 read GetMappingTCoordinates write SetMappingTCoordinates stored StoreMappingTCoordinates;
Published | property Swizzling: TGLTextureSwizzling read FSwizzling write SetSwizzling stored StoreSwizzling;
Public | property TextureMatrix: TMatrix read FTextureMatrix write SetTextureMatrix;
Published | property TextureOffset: TGLCoordinates read GetTextureOffset write SetTextureOffset stored StoreTextureOffset;
Published | property TextureRotate: Single read FTextureRotate write SetTextureRotate stored StoreTextureRotate;
Published | property TextureScale: TGLCoordinates read GetTextureScale write SetTextureScale stored StoreTextureScale;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public function IsValid: Boolean;
Public procedure Apply(var ARci: TRenderContextInfo);
Public procedure Assign(Source: TPersistent); override;
Public procedure Notification(Sender: TObject; Operation: TOperation); override;
Public procedure NotifyChange(Sender: TObject); override;
Public procedure UnApply(var ARci: TRenderContextInfo);
Protected procedure Loaded; override;

Properties

Published property EnvColor: TGLColor read FEnvColor write SetEnvColor;

Texture Environment color.

Published property LibSamplerName: TGLMaterialComponentName read GetLibSamplerName write SetLibSamplerName;
Published property LibTextureName: TGLMaterialComponentName read GetLibTextureName write SetLibTextureName;
Published property MappingMode: TGLTextureMappingMode read FMappingMode write SetMappingMode default tmmUser;

Texture coordinates mapping mode.<p> This property controls automatic texture coordinates generation.

Published property MappingQCoordinates: TGLCoordinates4 read GetMappingQCoordinates write SetMappingQCoordinates stored StoreMappingQCoordinates;
Published property MappingRCoordinates: TGLCoordinates4 read GetMappingRCoordinates write SetMappingRCoordinates stored StoreMappingRCoordinates;
Published property MappingSCoordinates: TGLCoordinates4 read GetMappingSCoordinates write SetMappingSCoordinates stored StoreMappingSCoordinates;

Texture mapping coordinates mode for S, T, R and Q axis.<p> This property stores the coordinates for automatic texture coordinates generation.

Published property MappingTCoordinates: TGLCoordinates4 read GetMappingTCoordinates write SetMappingTCoordinates stored StoreMappingTCoordinates;
Published property Swizzling: TGLTextureSwizzling read FSwizzling write SetSwizzling stored StoreSwizzling;

Texture color fetching parameters.

Public property TextureMatrix: TMatrix read FTextureMatrix write SetTextureMatrix;
Published property TextureOffset: TGLCoordinates read GetTextureOffset write SetTextureOffset stored StoreTextureOffset;
Published property TextureRotate: Single read FTextureRotate write SetTextureRotate stored StoreTextureRotate;

Texture coordinates rotating.<p> Rotating is applied after applying offset and scale, and rotate ST direction around R axis.

Published property TextureScale: TGLCoordinates read GetTextureScale write SetTextureScale stored StoreTextureScale;

Texture coordinates scaling.<p> Scaling is applied before applying the offset, and is applied to the texture coordinates, meaning that a scale factor of (2, 2, 2) will make your texture look twice <i>smaller</i>.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:28


GLScene v.1.1.2: GLMaterialEx: Class TGLFixedFunctionProperties

Class TGLFixedFunctionProperties

Unit

GLMaterialEx

Declaration

type TGLFixedFunctionProperties = class(TGLLibMaterialProperty)

Description

no description available, TGLLibMaterialProperty description follows
no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLLibMaterialProperty
  • TGLFixedFunctionProperties

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function Blended: Boolean;
Public | procedure Apply(var ARci: TRenderContextInfo);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure UnApply(var ARci: TRenderContextInfo);

Properties

Published | property BackProperties: TGLFaceProperties read GetBackProperties write SetBackProperties;
Published | property BlendingMode: TBlendingMode read FBlendingMode write SetBlendingMode default bmOpaque;
Published | property BlendingParams: TGLBlendingParameters read FBlendingParams write SetBlendingParams;
Published | property DepthProperties: TGLDepthProperties read FDepthProperties write SetDepthProperties;
Published | property FaceCulling: TFaceCulling read FFaceCulling write SetFaceCulling default fcBufferDefault;
Published | property FrontProperties: TGLFaceProperties read FFrontProperties write SetFrontProperties;
Published | property MaterialOptions: TMaterialOptions read FMaterialOptions write SetMaterialOptions default [];
Published | property NextPass;
Published | property PolygonMode: TPolygonMode read FPolygonMode write SetPolygonMode default pmFill;
Published | property Texture: TGLTextureProperties read FTexProp write SetTexProp;
Published | property TextureMode: TGLTextureMode read FTextureMode write SetTextureMode default tmDecal;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public function Blended: Boolean;

Returns True if the material is blended.<p>

Public procedure Apply(var ARci: TRenderContextInfo);
Public procedure Assign(Source: TPersistent); override;
Public procedure UnApply(var ARci: TRenderContextInfo);

Properties

Published property BackProperties: TGLFaceProperties read GetBackProperties write SetBackProperties;
Published property BlendingMode: TBlendingMode read FBlendingMode write SetBlendingMode default bmOpaque;
Published property BlendingParams: TGLBlendingParameters read FBlendingParams write SetBlendingParams;
Published property DepthProperties: TGLDepthProperties read FDepthProperties write SetDepthProperties;
Published property FaceCulling: TFaceCulling read FFaceCulling write SetFaceCulling default fcBufferDefault;
Published property FrontProperties: TGLFaceProperties read FFrontProperties write SetFrontProperties;
Published property MaterialOptions: TMaterialOptions read FMaterialOptions write SetMaterialOptions default [];
Published property NextPass;

Next pass of FFP.

Published property PolygonMode: TPolygonMode read FPolygonMode write SetPolygonMode default pmFill;
Published property Texture: TGLTextureProperties read FTexProp write SetTexProp;
Published property TextureMode: TGLTextureMode read FTextureMode write SetTextureMode default tmDecal;

Texture application mode.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:28


GLScene v.1.1.2: GLMaterialEx: Class TGLTextureCombiner

Class TGLTextureCombiner

Unit

GLMaterialEx

Declaration

type TGLTextureCombiner = class(TGLBaseMaterialCollectionItem)

Description

no description available, TGLBaseMaterialCollectionItem description follows
no description available, TXCollectionItem description follows

Base class for implementing a XCollection item.<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation </ul>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem
  • TGLTextureCombiner

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoOnPrepare(Sender: TGLContext); override;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure ReadFromFiler(AReader: TReader); override;
Protected | procedure WriteToFiler(AWriter: TWriter); override;

Properties

Published property Script: TStringList read FScript write SetScript;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyName: string; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoOnPrepare(Sender: TGLContext); override;
Public procedure NotifyChange(Sender: TObject); override;
Protected procedure ReadFromFiler(AReader: TReader); override;
Protected procedure WriteToFiler(AWriter: TWriter); override;

Properties

Published property Script: TStringList read FScript write SetScript;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:28


GLScene v.1.1.2: GLMaterialEx: Class TGLASMVertexProgram

Class TGLASMVertexProgram

Unit

GLMaterialEx

Declaration

type TGLASMVertexProgram = class(TGLBaseMaterialCollectionItem)

Description

no description available, TGLBaseMaterialCollectionItem description follows
no description available, TXCollectionItem description follows

Base class for implementing a XCollection item.<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation </ul>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem
  • TGLASMVertexProgram

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoOnPrepare(Sender: TGLContext); override;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure ReadFromFiler(AReader: TReader); override;
Protected | procedure WriteToFiler(AWriter: TWriter); override;

Properties

Public | property Handle: TGLARBVertexProgramHandle read GetHandle;
Published | property InfoLog: string read FInfoLog;
Published | property Source: TStringList read FSource write SetSource;
Published | property SourceFile: string read FSourceFile write SetSourceFile;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyName: string; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoOnPrepare(Sender: TGLContext); override;
Public procedure NotifyChange(Sender: TObject); override;
Protected procedure ReadFromFiler(AReader: TReader); override;
Protected procedure WriteToFiler(AWriter: TWriter); override;

Properties

Public property Handle: TGLARBVertexProgramHandle read GetHandle;
Published property InfoLog: string read FInfoLog;
Published property Source: TStringList read FSource write SetSource;
Published property SourceFile: string read FSourceFile write SetSourceFile;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialEx: Class TGLMultitexturingProperties

Class TGLMultitexturingProperties

Unit

GLMaterialEx

Declaration

type TGLMultitexturingProperties = class(TGLLibMaterialProperty)

Description

no description available, TGLLibMaterialProperty description follows
no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLLibMaterialProperty
  • TGLMultitexturingProperties

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function IsValid: Boolean;
Public | procedure Apply(var ARci: TRenderContextInfo);
Public | procedure Notification(Sender: TObject; Operation: TOperation); override;
Public | procedure UnApply(var ARci: TRenderContextInfo);
Protected | procedure Loaded; override;

Properties

Published | property LibAsmProgName: string read GetLibAsmProgName write SetLibAsmProgName;
Published | property LibCombinerName: string read GetLibCombinerName write SetLibCombinerName;
Published | property LightDirTo: TLightDir2TexEnvColor read FLightDir write FLightDir default l2eNone;
Published | property LightSourceIndex: Integer read FLightSourceIndex write SetLightSourceIndex default 0;
Published | property NextPass;
Published | property Texture0: TGLTextureProperties index 0 read GetTexProps write SetTexProps;
Published | property Texture1: TGLTextureProperties index 1 read GetTexProps write SetTexProps;
Published | property Texture2: TGLTextureProperties index 2 read GetTexProps write SetTexProps;
Published | property Texture3: TGLTextureProperties index 3 read GetTexProps write SetTexProps;
Published | property TextureMode: TGLTextureMode read FTextureMode write SetTextureMode default tmDecal;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public function IsValid: Boolean;
Public procedure Apply(var ARci: TRenderContextInfo);
Public procedure Notification(Sender: TObject; Operation: TOperation); override;
Public procedure UnApply(var ARci: TRenderContextInfo);
Protected procedure Loaded; override;

Properties

Published property LibAsmProgName: string read GetLibAsmProgName write SetLibAsmProgName;
Published property LibCombinerName: string read GetLibCombinerName write SetLibCombinerName;
Published property LightDirTo: TLightDir2TexEnvColor read FLightDir write FLightDir default l2eNone;

Pass light source direction to enviroment color of choosen texture. Vector in model space.

Published property LightSourceIndex: Integer read FLightSourceIndex write SetLightSourceIndex default 0;

Specify index of light source for LightDirTo.

Published property NextPass;

Next pass of combiner.

Published property Texture0: TGLTextureProperties index 0 read GetTexProps write SetTexProps;
Published property Texture1: TGLTextureProperties index 1 read GetTexProps write SetTexProps;
Published property Texture2: TGLTextureProperties index 2 read GetTexProps write SetTexProps;
Published property Texture3: TGLTextureProperties index 3 read GetTexProps write SetTexProps;
Published property TextureMode: TGLTextureMode read FTextureMode write SetTextureMode default tmDecal;

Texture application mode.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialEx: Class TGLShaderEx

Class TGLShaderEx

Unit

GLMaterialEx

Declaration

type TGLShaderEx = class(TGLBaseMaterialCollectionItem)

Description

no description available, TGLBaseMaterialCollectionItem description follows
no description available, TXCollectionItem description follows

Base class for implementing a XCollection item.<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation </ul>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseMaterialCollectionItem
  • TGLShaderEx

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoOnPrepare(Sender: TGLContext); override;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure ReadFromFiler(AReader: TReader); override;
Protected | procedure WriteToFiler(AWriter: TWriter); override;

Properties

Published | property GeometryInput: TGLgsInTypes read FGeometryInput write SetGeometryInput default gsInPoints;
Published | property GeometryOutput: TGLgsOutTypes read FGeometryOutput write SetGeometryOutput default gsOutPoints;
Published | property GeometryVerticesOut: TGLint read FGeometryVerticesOut write SetGeometryVerticesOut default 1;
Public | property Handle: TGLShaderHandle read GetHandle;
Published | property InfoLog: string read FInfoLog;
Published | property ShaderType: TGLShaderType read FShaderType write SetShaderType default shtVertex;
Published | property Source: TStringList read FSource write SetSource;
Published | property SourceFile: string read FSourceFile write SetSourceFile;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyName: string; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoOnPrepare(Sender: TGLContext); override;
Public procedure NotifyChange(Sender: TObject); override;
Protected procedure ReadFromFiler(AReader: TReader); override;
Protected procedure WriteToFiler(AWriter: TWriter); override;

Properties

Published property GeometryInput: TGLgsInTypes read FGeometryInput write SetGeometryInput default gsInPoints;
Published property GeometryOutput: TGLgsOutTypes read FGeometryOutput write SetGeometryOutput default gsOutPoints;
Published property GeometryVerticesOut: TGLint read FGeometryVerticesOut write SetGeometryVerticesOut default 1;
Public property Handle: TGLShaderHandle read GetHandle;
Published property InfoLog: string read FInfoLog;
Published property ShaderType: TGLShaderType read FShaderType write SetShaderType default shtVertex;
Published property Source: TStringList read FSource write SetSource;
Published property SourceFile: string read FSourceFile write SetSourceFile;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialEx: Class TGLAbstractShaderUniform

Class TGLAbstractShaderUniform

Unit

GLMaterialEx

Declaration

type TGLAbstractShaderUniform = class(TGLUpdateAbleObject, IShaderParameter)

Description

no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLAbstractShaderUniform

Overview

Fields

Protected | FName: string;
Protected | FNameHashCode: Integer;
Protected | FType: TGLSLDataType;
Protected | FSamplerType: TGLSLSamplerType;

Methods

Protected | function GetAutoSetMethod: string; virtual;
Protected | function GetFloat: Single; virtual;
Protected | function GetGLSLSamplerType: TGLSLSamplerType;
Protected | function GetGLSLType: TGLSLDataType;
Protected | function GetInt: TGLint; virtual;
Protected | function GetIVec2: TVector2i; virtual;
Protected | function GetIVec3: TVector3i; virtual;
Protected | function GetIVec4: TVector4i; virtual;
Protected | function GetMat2: TMatrix2f; virtual;
Protected | function GetMat3: TMatrix3f; virtual;
Protected | function GetMat4: TMatrix4f; virtual;
Protected | function GetName: string;
Protected | function GetSamplerName: string; virtual;
Protected | function GetTextureName: string; virtual;
Protected | function GetTextureSwizzle: TSwizzleVector; virtual;
Protected | function GetUInt: TGLuint; virtual;
Protected | function GetUVec2: TVector2ui; virtual;
Protected | function GetUVec3: TVector3ui; virtual;
Protected | function GetUVec4: TVector4ui; virtual;
Protected | function GetVec2: TVector2f; virtual;
Protected | function GetVec3: TVector3f; virtual;
Protected | function GetVec4: TVector; virtual;
Protected | procedure Apply(var ARci: TRenderContextInfo); virtual;
Protected | procedure ReadFromFiler(AReader: TReader); virtual;
Protected | procedure SetAutoSetMethod(const AValue: string); virtual;
Protected | procedure SetFloat(const Value: TGLFloat); virtual;
Protected | procedure SetFloatArray(const Values: PGLFloat; Count: Integer); virtual;
Protected | procedure SetInt(const Value: Integer); virtual;
Protected | procedure SetIntArray(const Values: PGLInt; Count: Integer); virtual;
Protected | procedure SetIVec2(const Value: TVector2i); virtual;
Protected | procedure SetIVec3(const Value: TVector3i); virtual;
Protected | procedure SetIVec4(const Value: TVector4i); virtual;
Protected | procedure SetMat2(const Value: TMatrix2f); virtual;
Protected | procedure SetMat3(const Value: TMatrix3f); virtual;
Protected | procedure SetMat4(const Value: TMatrix4f); virtual;
Protected | procedure SetSamplerName(const AValue: string); virtual;
Protected | procedure SetTextureName(const AValue: string); virtual;
Protected | procedure SetTextureSwizzle(const AValue: TSwizzleVector); virtual;
Protected | procedure SetUInt(const Value: GLuint); virtual;
Protected | procedure SetUIntArray(const Values: PGLUInt; Count: Integer); virtual;
Protected | procedure SetUVec2(const Value: TVector2ui); virtual;
Protected | procedure SetUVec3(const Value: TVector3ui); virtual;
Protected | procedure SetUVec4(const Value: TVector4ui); virtual;
Protected | procedure SetVec2(const Value: TVector2f); virtual;
Protected | procedure SetVec3(const Value: TVector3f); virtual;
Protected | procedure SetVec4(const Value: TVector4f); virtual;
Protected | procedure WriteToFiler(AWriter: TWriter); virtual;

Description

Fields

Protected FName: string;
Protected FNameHashCode: Integer;
Protected FType: TGLSLDataType;
Protected FSamplerType: TGLSLSamplerType;

Methods

Protected function GetAutoSetMethod: string; virtual;
Protected function GetFloat: Single; virtual;
Protected function GetGLSLSamplerType: TGLSLSamplerType;
Protected function GetGLSLType: TGLSLDataType;
Protected function GetInt: TGLint; virtual;
Protected function GetIVec2: TVector2i; virtual;
Protected function GetIVec3: TVector3i; virtual;
Protected function GetIVec4: TVector4i; virtual;
Protected function GetMat2: TMatrix2f; virtual;
Protected function GetMat3: TMatrix3f; virtual;
Protected function GetMat4: TMatrix4f; virtual;
Protected function GetName: string;
Protected function GetSamplerName: string; virtual;
Protected function GetTextureName: string; virtual;
Protected function GetTextureSwizzle: TSwizzleVector; virtual;
Protected function GetUInt: TGLuint; virtual;
Protected function GetUVec2: TVector2ui; virtual;
Protected function GetUVec3: TVector3ui; virtual;
Protected function GetUVec4: TVector4ui; virtual;
Protected function GetVec2: TVector2f; virtual;
Protected function GetVec3: TVector3f; virtual;
Protected function GetVec4: TVector; virtual;
Protected procedure Apply(var ARci: TRenderContextInfo); virtual;
Protected procedure ReadFromFiler(AReader: TReader); virtual;
Protected procedure SetAutoSetMethod(const AValue: string); virtual;
Protected procedure SetFloat(const Value: TGLFloat); virtual;
Protected procedure SetFloatArray(const Values: PGLFloat; Count: Integer); virtual;
Protected procedure SetInt(const Value: Integer); virtual;
Protected procedure SetIntArray(const Values: PGLInt; Count: Integer); virtual;
Protected procedure SetIVec2(const Value: TVector2i); virtual;
Protected procedure SetIVec3(const Value: TVector3i); virtual;
Protected procedure SetIVec4(const Value: TVector4i); virtual;
Protected procedure SetMat2(const Value: TMatrix2f); virtual;
Protected procedure SetMat3(const Value: TMatrix3f); virtual;
Protected procedure SetMat4(const Value: TMatrix4f); virtual;
Protected procedure SetSamplerName(const AValue: string); virtual;
Protected procedure SetTextureName(const AValue: string); virtual;
Protected procedure SetTextureSwizzle(const AValue: TSwizzleVector); virtual;
Protected procedure SetUInt(const Value: GLuint); virtual;
Protected procedure SetUIntArray(const Values: PGLUInt; Count: Integer); virtual;
Protected procedure SetUVec2(const Value: TVector2ui); virtual;
Protected procedure SetUVec3(const Value: TVector3ui); virtual;
Protected procedure SetUVec4(const Value: TVector4ui); virtual;
Protected procedure SetVec2(const Value: TVector2f); virtual;
Protected procedure SetVec3(const Value: TVector3f); virtual;
Protected procedure SetVec4(const Value: TVector4f); virtual;
Protected procedure WriteToFiler(AWriter: TWriter); virtual;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialEx: Class TGLShaderUniform

Class TGLShaderUniform

Unit

GLMaterialEx

Declaration

type TGLShaderUniform = class(TGLAbstractShaderUniform, IShaderParameter)

Description

no description available, TGLAbstractShaderUniform description follows
no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLAbstractShaderUniform
  • TGLShaderUniform

Overview

Fields

Protected | FLocation: TGLint;
Protected | FStoreProgram: TGLuint;
Protected | FAutoSet: TUniformAutoSetMethod;

Methods

Protected | function GetAutoSetMethod: string; override;
Protected | function GetFloat: Single; override;
Protected | function GetInt: TGLint; override;
Protected | function GetIVec2: TVector2i; override;
Protected | function GetIVec3: TVector3i; override;
Protected | function GetIVec4: TVector4i; override;
Protected | function GetMat2: TMatrix2f; override;
Protected | function GetMat3: TMatrix3f; override;
Protected | function GetMat4: TMatrix4f; override;
Protected | function GetProgram: TGLuint; inline;
Protected | function GetUInt: TGLuint; override;
Protected | function GetUVec2: TVector2ui; override;
Protected | function GetUVec3: TVector3ui; override;
Protected | function GetUVec4: TVector4ui; override;
Protected | function GetVec2: TVector2f; override;
Protected | function GetVec3: TVector3f; override;
Protected | function GetVec4: TVector; override;
Public | procedure Apply(var ARci: TRenderContextInfo); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure SetFloatArray(const Values: PGLFloat; Count: Integer); override;
Public | procedure SetIntArray(const Values: PGLInt; Count: Integer); override;
Public | procedure SetUIntArray(const Values: PGLUInt; Count: Integer); override;
Protected | procedure PopProgram; inline;
Protected | procedure PushProgram; inline;
Protected | procedure ReadFromFiler(AReader: TReader); override;
Protected | procedure SetAutoSetMethod(const AValue: string); override;
Protected | procedure SetFloat(const Value: TGLFloat); override;
Protected | procedure SetInt(const Value: Integer); override;
Protected | procedure SetIVec2(const Value: TVector2i); override;
Protected | procedure SetIVec3(const Value: TVector3i); override;
Protected | procedure SetIVec4(const Value: TVector4i); override;
Protected | procedure SetMat2(const Value: TMatrix2f); override;
Protected | procedure SetMat3(const Value: TMatrix3f); override;
Protected | procedure SetMat4(const Value: TMatrix4f); override;
Protected | procedure SetUInt(const Value: GLuint); override;
Protected | procedure SetUVec2(const Value: TVector2ui); override;
Protected | procedure SetUVec3(const Value: TVector3ui); override;
Protected | procedure SetUVec4(const Value: TVector4ui); override;
Protected | procedure SetVec2(const Value: TVector2f); override;
Protected | procedure SetVec3(const Value: TVector3f); override;
Protected | procedure SetVec4(const Value: TVector4f); override;
Protected | procedure WriteToFiler(AWriter: TWriter); override;

Properties

Public | property GLSLType: TGLSLDataType read GetGLSLType;
Public | property Location: TGLint read FLocation;
Public | property Name: string read GetName;

Description

Fields

Protected FLocation: TGLint;
Protected FStoreProgram: TGLuint;
Protected FAutoSet: TUniformAutoSetMethod;

Methods

Protected function GetAutoSetMethod: string; override;
Protected function GetFloat: Single; override;
Protected function GetInt: TGLint; override;
Protected function GetIVec2: TVector2i; override;
Protected function GetIVec3: TVector3i; override;
Protected function GetIVec4: TVector4i; override;
Protected function GetMat2: TMatrix2f; override;
Protected function GetMat3: TMatrix3f; override;
Protected function GetMat4: TMatrix4f; override;
Protected function GetProgram: TGLuint; inline;
Protected function GetUInt: TGLuint; override;
Protected function GetUVec2: TVector2ui; override;
Protected function GetUVec3: TVector3ui; override;
Protected function GetUVec4: TVector4ui; override;
Protected function GetVec2: TVector2f; override;
Protected function GetVec3: TVector3f; override;
Protected function GetVec4: TVector; override;
Public procedure Apply(var ARci: TRenderContextInfo); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure SetFloatArray(const Values: PGLFloat; Count: Integer); override;
Public procedure SetIntArray(const Values: PGLInt; Count: Integer); override;
Public procedure SetUIntArray(const Values: PGLUInt; Count: Integer); override;
Protected procedure PopProgram; inline;
Protected procedure PushProgram; inline;
Protected procedure ReadFromFiler(AReader: TReader); override;
Protected procedure SetAutoSetMethod(const AValue: string); override;
Protected procedure SetFloat(const Value: TGLFloat); override;
Protected procedure SetInt(const Value: Integer); override;
Protected procedure SetIVec2(const Value: TVector2i); override;
Protected procedure SetIVec3(const Value: TVector3i); override;
Protected procedure SetIVec4(const Value: TVector4i); override;
Protected procedure SetMat2(const Value: TMatrix2f); override;
Protected procedure SetMat3(const Value: TMatrix3f); override;
Protected procedure SetMat4(const Value: TMatrix4f); override;
Protected procedure SetUInt(const Value: GLuint); override;
Protected procedure SetUVec2(const Value: TVector2ui); override;
Protected procedure SetUVec3(const Value: TVector3ui); override;
Protected procedure SetUVec4(const Value: TVector4ui); override;
Protected procedure SetVec2(const Value: TVector2f); override;
Protected procedure SetVec3(const Value: TVector3f); override;
Protected procedure SetVec4(const Value: TVector4f); override;
Protected procedure WriteToFiler(AWriter: TWriter); override;

Properties

Public property GLSLType: TGLSLDataType read GetGLSLType;
Public property Location: TGLint read FLocation;
Public property Name: string read GetName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialEx: Class TGLShaderUniformDSA

Class TGLShaderUniformDSA

Unit

GLMaterialEx

Declaration

type TGLShaderUniformDSA = class(TGLShaderUniform)

Description

no description available, TGLShaderUniform description follows
no description available, TGLAbstractShaderUniform description follows
no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLAbstractShaderUniform
  • TGLShaderUniform
  • TGLShaderUniformDSA

Overview

Methods

Public | procedure SetFloatArray(const Values: PGLFloat; Count: Integer); override;
Public | procedure SetIntArray(const Values: PGLInt; Count: Integer); override;
Public | procedure SetUIntArray(const Values: PGLUInt; Count: Integer); override;
Protected | procedure SetFloat(const Value: TGLFloat); override;
Protected | procedure SetInt(const Value: Integer); override;
Protected | procedure SetIVec2(const Value: TVector2i); override;
Protected | procedure SetIVec3(const Value: TVector3i); override;
Protected | procedure SetIVec4(const Value: TVector4i); override;
Protected | procedure SetMat2(const Value: TMatrix2f); override;
Protected | procedure SetMat3(const Value: TMatrix3f); override;
Protected | procedure SetMat4(const Value: TMatrix4f); override;
Protected | procedure SetUInt(const Value: GLuint); override;
Protected | procedure SetUVec2(const Value: TVector2ui); override;
Protected | procedure SetUVec3(const Value: TVector3ui); override;
Protected | procedure SetUVec4(const Value: TVector4ui); override;
Protected | procedure SetVec2(const Value: TVector2f); override;
Protected | procedure SetVec3(const Value: TVector3f); override;
Protected | procedure SetVec4(const Value: TVector4f); override;

Description

Methods

Public procedure SetFloatArray(const Values: PGLFloat; Count: Integer); override;
Public procedure SetIntArray(const Values: PGLInt; Count: Integer); override;
Public procedure SetUIntArray(const Values: PGLUInt; Count: Integer); override;
Protected procedure SetFloat(const Value: TGLFloat); override;
Protected procedure SetInt(const Value: Integer); override;
Protected procedure SetIVec2(const Value: TVector2i); override;
Protected procedure SetIVec3(const Value: TVector3i); override;
Protected procedure SetIVec4(const Value: TVector4i); override;
Protected procedure SetMat2(const Value: TMatrix2f); override;
Protected procedure SetMat3(const Value: TMatrix3f); override;
Protected procedure SetMat4(const Value: TMatrix4f); override;
Protected procedure SetUInt(const Value: GLuint); override;
Protected procedure SetUVec2(const Value: TVector2ui); override;
Protected procedure SetUVec3(const Value: TVector3ui); override;
Protected procedure SetUVec4(const Value: TVector4ui); override;
Protected procedure SetVec2(const Value: TVector2f); override;
Protected procedure SetVec3(const Value: TVector3f); override;
Protected procedure SetVec4(const Value: TVector4f); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialEx: Class TGLShaderUniformTexture

Class TGLShaderUniformTexture

Unit

GLMaterialEx

Declaration

type TGLShaderUniformTexture = class(TGLShaderUniform)

Description

no description available, TGLShaderUniform description follows
no description available, TGLAbstractShaderUniform description follows
no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLAbstractShaderUniform
  • TGLShaderUniform
  • TGLShaderUniformTexture

Overview

Fields

Protected | FLibTexureName: TGLMaterialComponentName;
Protected | FLibSamplerName: TGLMaterialComponentName;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Protected | function GetSamplerName: string; override;
Protected | function GetTextureName: string; override;
Protected | function GetTextureSwizzle: TSwizzleVector; override;
Public | procedure Apply(var ARci: TRenderContextInfo); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Notification(Sender: TObject; Operation: TOperation); override;
Protected | procedure Loaded;
Protected | procedure ReadFromFiler(AReader: TReader); override;
Protected | procedure SetSamplerName(const AValue: string); override;
Protected | procedure SetTextureName(const AValue: string); override;
Protected | procedure SetTextureSwizzle(const AValue: TSwizzleVector); override;
Protected | procedure WriteToFiler(AWriter: TWriter); override;

Properties

Public | property GLSLSampler: TGLSLSamplerType read GetGLSLSamplerType;
Public | property LibSamplerName: TGLMaterialComponentName read GetSamplerName write SetSamplerName;
Public | property LibTextureName: TGLMaterialComponentName read GetTextureName write SetTextureName;
Public | property Swizzling: TSwizzleVector read GetTextureSwizzle write SetTextureSwizzle;

Description

Fields

Protected FLibTexureName: TGLMaterialComponentName;
Protected FLibSamplerName: TGLMaterialComponentName;

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Protected function GetSamplerName: string; override;
Protected function GetTextureName: string; override;
Protected function GetTextureSwizzle: TSwizzleVector; override;
Public procedure Apply(var ARci: TRenderContextInfo); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure Notification(Sender: TObject; Operation: TOperation); override;
Protected procedure Loaded;
Protected procedure ReadFromFiler(AReader: TReader); override;
Protected procedure SetSamplerName(const AValue: string); override;
Protected procedure SetTextureName(const AValue: string); override;
Protected procedure SetTextureSwizzle(const AValue: TSwizzleVector); override;
Protected procedure WriteToFiler(AWriter: TWriter); override;

Properties

Public property GLSLSampler: TGLSLSamplerType read GetGLSLSamplerType;
Public property LibSamplerName: TGLMaterialComponentName read GetSamplerName write SetSamplerName;
Public property LibTextureName: TGLMaterialComponentName read GetTextureName write SetTextureName;
Public property Swizzling: TSwizzleVector read GetTextureSwizzle write SetTextureSwizzle;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialEx: Class TGLBaseShaderModel

Class TGLBaseShaderModel

Unit

GLMaterialEx

Declaration

type TGLBaseShaderModel = class(TGLLibMaterialProperty)

Description

no description available, TGLLibMaterialProperty description follows
no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLLibMaterialProperty
  • TGLBaseShaderModel

Overview

Fields

Protected | FHandle: TGLProgramHandle;
Protected | FLibShaderName: array[TGLShaderType] of string;
Protected | FShaders: array[TGLShaderType] of TGLShaderEx;
Protected | FIsValid: Boolean;
Protected | FInfoLog: string;
Protected | FUniforms: TPersistentObjectList;
Protected | FAutoFill: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Protected | function GetLibShaderName(AType: TGLShaderType): string;
Protected | function GetUniform(const AName: string): IShaderParameter;
Protected | class function IsSupported: Boolean; virtual; abstract;
Public | procedure Apply(var ARci: TRenderContextInfo); virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoOnPrepare(Sender: TGLContext);
Public | procedure GetUniformNames(Proc: TGetStrProc);
Public | procedure Notification(Sender: TObject; Operation: TOperation); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure UnApply(var ARci: TRenderContextInfo); virtual;
Protected | procedure DefineProperties(Filer: TFiler); override;
Protected | procedure Loaded; override;
Protected | procedure ReadUniforms(AStream: TStream);
Protected | class procedure ReleaseUniforms(AList: TPersistentObjectList);
Protected | procedure SetLibShaderName(AType: TGLShaderType; const AValue: string);
Protected | procedure WriteUniforms(AStream: TStream);

Properties

Published | property AutoFillOfUniforms: Boolean read FAutoFill write FAutoFill stored False;
Public | property Handle: TGLProgramHandle read FHandle;
Published | property InfoLog: string read FInfoLog;
Public | property IsValid: Boolean read FIsValid;
Protected | property LibFragmentShaderName: TGLMaterialComponentName index shtFragment read GetLibShaderName write SetLibShaderName;
Protected | property LibGeometryShaderName: TGLMaterialComponentName index shtGeometry read GetLibShaderName write SetLibShaderName;
Protected | property LibTessControlShaderName: TGLMaterialComponentName index shtControl read GetLibShaderName write SetLibShaderName;
Protected | property LibTessEvalShaderName: TGLMaterialComponentName index shtEvaluation read GetLibShaderName write SetLibShaderName;
Protected | property LibVertexShaderName: TGLMaterialComponentName index shtVertex read GetLibShaderName write SetLibShaderName;
Published | property NextPass;
Public | property Uniforms[const AName: string]: IShaderParameter read GetUniform;

Description

Fields

Protected FHandle: TGLProgramHandle;
Protected FLibShaderName: array[TGLShaderType] of string;
Protected FShaders: array[TGLShaderType] of TGLShaderEx;
Protected FIsValid: Boolean;
Protected FInfoLog: string;
Protected FUniforms: TPersistentObjectList;
Protected FAutoFill: Boolean;

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Protected function GetLibShaderName(AType: TGLShaderType): string;
Protected function GetUniform(const AName: string): IShaderParameter;
Protected class function IsSupported: Boolean; virtual; abstract;
Public procedure Apply(var ARci: TRenderContextInfo); virtual;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoOnPrepare(Sender: TGLContext);
Public procedure GetUniformNames(Proc: TGetStrProc);
Public procedure Notification(Sender: TObject; Operation: TOperation); override;
Public procedure NotifyChange(Sender: TObject); override;
Public procedure UnApply(var ARci: TRenderContextInfo); virtual;
Protected procedure DefineProperties(Filer: TFiler); override;
Protected procedure Loaded; override;
Protected procedure ReadUniforms(AStream: TStream);
Protected class procedure ReleaseUniforms(AList: TPersistentObjectList);
Protected procedure SetLibShaderName(AType: TGLShaderType; const AValue: string);
Protected procedure WriteUniforms(AStream: TStream);

Properties

Published property AutoFillOfUniforms: Boolean read FAutoFill write FAutoFill stored False;
Public property Handle: TGLProgramHandle read FHandle;
Published property InfoLog: string read FInfoLog;
Public property IsValid: Boolean read FIsValid;
Protected property LibFragmentShaderName: TGLMaterialComponentName index shtFragment read GetLibShaderName write SetLibShaderName;
Protected property LibGeometryShaderName: TGLMaterialComponentName index shtGeometry read GetLibShaderName write SetLibShaderName;
Protected property LibTessControlShaderName: TGLMaterialComponentName index shtControl read GetLibShaderName write SetLibShaderName;
Protected property LibTessEvalShaderName: TGLMaterialComponentName index shtEvaluation read GetLibShaderName write SetLibShaderName;
Protected property LibVertexShaderName: TGLMaterialComponentName index shtVertex read GetLibShaderName write SetLibShaderName;
Published property NextPass;
Public property Uniforms[const AName: string]: IShaderParameter read GetUniform;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialEx: Class TGLShaderModel3

Class TGLShaderModel3

Unit

GLMaterialEx

Declaration

type TGLShaderModel3 = class(TGLBaseShaderModel)

Description

no description available, TGLBaseShaderModel description follows
no description available, TGLLibMaterialProperty description follows
no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLLibMaterialProperty
  • TGLBaseShaderModel
  • TGLShaderModel3

Overview

Methods

Public class function IsSupported: Boolean; override;

Properties

Published | property LibFragmentShaderName;
Published | property LibVertexShaderName;

Description

Methods

Public class function IsSupported: Boolean; override;

Properties

Published property LibFragmentShaderName;
Published property LibVertexShaderName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialEx: Class TGLShaderModel4

Class TGLShaderModel4

Unit

GLMaterialEx

Declaration

type TGLShaderModel4 = class(TGLBaseShaderModel)

Description

no description available, TGLBaseShaderModel description follows
no description available, TGLLibMaterialProperty description follows
no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLLibMaterialProperty
  • TGLBaseShaderModel
  • TGLShaderModel4

Overview

Methods

Public class function IsSupported: Boolean; override;

Properties

Published | property LibFragmentShaderName;
Published | property LibGeometryShaderName;
Published | property LibVertexShaderName;

Description

Methods

Public class function IsSupported: Boolean; override;

Properties

Published property LibFragmentShaderName;
Published property LibGeometryShaderName;
Published property LibVertexShaderName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialEx: Class TGLShaderModel5

Class TGLShaderModel5

Unit

GLMaterialEx

Declaration

type TGLShaderModel5 = class(TGLBaseShaderModel)

Description

no description available, TGLBaseShaderModel description follows
no description available, TGLLibMaterialProperty description follows
no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLLibMaterialProperty
  • TGLBaseShaderModel
  • TGLShaderModel5

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | procedure Apply(var ARci: TRenderContextInfo); override;
Public | procedure UnApply(var ARci: TRenderContextInfo); override;

Properties

Published | property LibFragmentShaderName;
Published | property LibGeometryShaderName;
Published | property LibTessControlShaderName;
Published | property LibTessEvalShaderName;
Published | property LibVertexShaderName;

Description

Methods

Public class function IsSupported: Boolean; override;
Public procedure Apply(var ARci: TRenderContextInfo); override;
Public procedure UnApply(var ARci: TRenderContextInfo); override;

Properties

Published property LibFragmentShaderName;
Published property LibGeometryShaderName;
Published property LibTessControlShaderName;
Published property LibTessEvalShaderName;
Published property LibVertexShaderName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialEx: Class TGLLibMaterialEx

Class TGLLibMaterialEx

Unit

GLMaterialEx

Declaration

type TGLLibMaterialEx = class(TGLAbstractLibMaterial)

Description

no description available, TGLAbstractLibMaterial description follows

Hierarchy

  • TCollectionItem
  • TGLAbstractLibMaterial
  • TGLLibMaterialEx

Overview

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | function Blended: Boolean; override;
Public | function UnApply(var ARci: TRenderContextInfo): Boolean; override;
Public | procedure Apply(var ARci: TRenderContextInfo); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure DoOnPrepare(Sender: TGLContext);
Protected | procedure Loaded; override;
Protected | procedure RemoveDefferedInit;

Properties

Published | property ApplicableLevel: TGLMaterialLevel read FApplicableLevel write SetLevel default mlAuto;
Published | property FixedFunction: TGLFixedFunctionProperties read FFixedFunc write SetFixedFunc;
Published | property Multitexturing: TGLMultitexturingProperties read FMultitexturing write SetMultitexturing;
Published | property OnAsmProgSetting: TOnAsmProgSetting read FOnAsmProgSetting write FOnAsmProgSetting;
Published | property OnSM3UniformInitialize: TOnUniformInitialize read FOnSM3UniformInit write FOnSM3UniformInit;
Published | property OnSM3UniformSetting: TOnUniformSetting read FOnSM3UniformSetting write FOnSM3UniformSetting;
Published | property OnSM4UniformInitialize: TOnUniformInitialize read FOnSM4UniformInit write FOnSM4UniformInit;
Published | property OnSM4UniformSetting: TOnUniformSetting read FOnSM4UniformSetting write FOnSM4UniformSetting;
Published | property OnSM5UniformInitialize: TOnUniformInitialize read FOnSM5UniformInit write FOnSM5UniformInit;
Published | property OnSM5UniformSetting: TOnUniformSetting read FOnSM5UniformSetting write FOnSM5UniformSetting;
Published | property SelectedLevel: TGLMaterialLevel read FSelectedLevel;
Published | property ShaderModel3: TGLShaderModel3 read FSM3 write SetSM3;
Published | property ShaderModel4: TGLShaderModel4 read FSM4 write SetSM4;
Published | property ShaderModel5: TGLShaderModel5 read FSM5 write SetSM5;

Description

Methods

Public constructor Create(ACollection: TCollection); override;
Public destructor Destroy; override;
Public function Blended: Boolean; override;
Public function UnApply(var ARci: TRenderContextInfo): Boolean; override;
Public procedure Apply(var ARci: TRenderContextInfo); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure NotifyChange(Sender: TObject); override;
Protected procedure DoOnPrepare(Sender: TGLContext);
Protected procedure Loaded; override;
Protected procedure RemoveDefferedInit;

Properties

Published property ApplicableLevel: TGLMaterialLevel read FApplicableLevel write SetLevel default mlAuto;
Published property FixedFunction: TGLFixedFunctionProperties read FFixedFunc write SetFixedFunc;
Published property Multitexturing: TGLMultitexturingProperties read FMultitexturing write SetMultitexturing;
Published property OnAsmProgSetting: TOnAsmProgSetting read FOnAsmProgSetting write FOnAsmProgSetting;
Published property OnSM3UniformInitialize: TOnUniformInitialize read FOnSM3UniformInit write FOnSM3UniformInit;
Published property OnSM3UniformSetting: TOnUniformSetting read FOnSM3UniformSetting write FOnSM3UniformSetting;
Published property OnSM4UniformInitialize: TOnUniformInitialize read FOnSM4UniformInit write FOnSM4UniformInit;
Published property OnSM4UniformSetting: TOnUniformSetting read FOnSM4UniformSetting write FOnSM4UniformSetting;
Published property OnSM5UniformInitialize: TOnUniformInitialize read FOnSM5UniformInit write FOnSM5UniformInit;
Published property OnSM5UniformSetting: TOnUniformSetting read FOnSM5UniformSetting write FOnSM5UniformSetting;
Published property SelectedLevel: TGLMaterialLevel read FSelectedLevel;
Published property ShaderModel3: TGLShaderModel3 read FSM3 write SetSM3;
Published property ShaderModel4: TGLShaderModel4 read FSM4 write SetSM4;
Published property ShaderModel5: TGLShaderModel5 read FSM5 write SetSM5;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialEx: Class TGLLibMaterialsEx

Class TGLLibMaterialsEx

Unit

GLMaterialEx

Declaration

type TGLLibMaterialsEx = class(TGLAbstractLibMaterials)

Description

no description available, TGLAbstractLibMaterials description follows

Hierarchy

  • TOwnedCollection
  • TGLAbstractLibMaterials
  • TGLLibMaterialsEx

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLLibMaterialEx;
Public | function FindItemID(ID: Integer): TGLLibMaterialEx;
Public | function GetLibMaterialByName(const AName: TGLLibMaterialName): TGLLibMaterialEx;
Public | function IndexOf(const Item: TGLLibMaterialEx): Integer;
Public | function MaterialLibrary: TGLMaterialLibraryEx;
Protected | function GetItems(AIndex: Integer): TGLLibMaterialEx;
Protected | procedure SetItems(AIndex: Integer; const AValue: TGLLibMaterialEx);

Properties

Public property Items[index: Integer]: TGLLibMaterialEx read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);
Public function Add: TGLLibMaterialEx;
Public function FindItemID(ID: Integer): TGLLibMaterialEx;
Public function GetLibMaterialByName(const AName: TGLLibMaterialName): TGLLibMaterialEx;
Public function IndexOf(const Item: TGLLibMaterialEx): Integer;
Public function MaterialLibrary: TGLMaterialLibraryEx;
Protected function GetItems(AIndex: Integer): TGLLibMaterialEx;
Protected procedure SetItems(AIndex: Integer; const AValue: TGLLibMaterialEx);

Properties

Public property Items[index: Integer]: TGLLibMaterialEx read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialEx: Class TGLMatLibComponents

Class TGLMatLibComponents

Unit

GLMaterialEx

Declaration

type TGLMatLibComponents = class(TXCollection)

Description

no description available, TXCollection description follows

Holds a list of TXCollectionItem objects.<p> This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList and persistence classes (XClasses & XLists), if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than Borland's lists and persistence mechanisms (and unlike Borland's, with polymorphism-support and full backward compatibility).

Hierarchy

  • TPersistent
  • TXCollection
  • TGLMatLibComponents

Overview

Methods

Public | function GetAsmProgByName(const AName: TGLMaterialComponentName): TGLASMVertexProgram;
Public | function GetAttachmentByName(const AName: TGLMaterialComponentName): TGLFrameBufferAttachment;
Public | function GetCombinerByName(const AName: TGLMaterialComponentName): TGLTextureCombiner;
Public | function GetItemByName(const AName: TGLMaterialComponentName): TGLBaseMaterialCollectionItem;
Public | function GetNamePath: string; override;
Public | function GetSamplerByName(const AName: TGLMaterialComponentName): TGLTextureSampler;
Public | function GetShaderByName(const AName: TGLMaterialComponentName): TGLShaderEx;
Public | function GetTextureByName(const AName: TGLMaterialComponentName): TGLAbstractTexture;
Public | class function ItemsClass: TXCollectionItemClass; override;
Public | function MakeUniqueName(const AName: TGLMaterialComponentName): TGLMaterialComponentName;
Protected | function GetItems(index: Integer): TGLBaseMaterialCollectionItem;

Properties

Public property Items[index: Integer]: TGLBaseMaterialCollectionItem read GetItems;

Description

Methods

Public function GetAsmProgByName(const AName: TGLMaterialComponentName): TGLASMVertexProgram;
Public function GetAttachmentByName(const AName: TGLMaterialComponentName): TGLFrameBufferAttachment;
Public function GetCombinerByName(const AName: TGLMaterialComponentName): TGLTextureCombiner;
Public function GetItemByName(const AName: TGLMaterialComponentName): TGLBaseMaterialCollectionItem;
Public function GetNamePath: string; override;
Public function GetSamplerByName(const AName: TGLMaterialComponentName): TGLTextureSampler;
Public function GetShaderByName(const AName: TGLMaterialComponentName): TGLShaderEx;
Public function GetTextureByName(const AName: TGLMaterialComponentName): TGLAbstractTexture;
Public class function ItemsClass: TXCollectionItemClass; override;
Public function MakeUniqueName(const AName: TGLMaterialComponentName): TGLMaterialComponentName;
Protected function GetItems(index: Integer): TGLBaseMaterialCollectionItem;

Properties

Public property Items[index: Integer]: TGLBaseMaterialCollectionItem read GetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialEx: Class TGLMaterialLibraryEx

Class TGLMaterialLibraryEx

Unit

GLMaterialEx

Declaration

type TGLMaterialLibraryEx = class(TGLAbstractMaterialLibrary)

Description

no description available, TGLAbstractMaterialLibrary description follows
no description available, TGLCadenceAbleComponent description follows

A base class describing the "cadenceing" interface.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLAbstractMaterialLibrary
  • TGLMaterialLibraryEx

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AddAsmProg(const AName: TGLMaterialComponentName): TGLASMVertexProgram;
Public | function AddAttachment(const AName: TGLMaterialComponentName): TGLFrameBufferAttachment;
Public | function AddCombiner(const AName: TGLMaterialComponentName): TGLTextureCombiner;
Public | function AddSampler(const AName: TGLMaterialComponentName): TGLTextureSampler;
Public | function AddShader(const AName: TGLMaterialComponentName): TGLShaderEx;
Public | function AddTexture(const AName: TGLMaterialComponentName): TGLTextureImageEx;
Protected | function GetMaterials: TGLLibMaterialsEx;
Protected | function StoreMaterials: Boolean;
Public | procedure GetNames(Proc: TGetStrProc; AClass: CGLBaseMaterialCollectionItem); overload;
Public | procedure SetLevelForAll(const ALevel: TGLMaterialLevel);
Protected | procedure DefineProperties(Filer: TFiler); override;
Protected | procedure Loaded; override;
Protected | procedure ReadComponents(AStream: TStream);
Protected | procedure SetComponents(AValue: TGLMatLibComponents);
Protected | procedure SetMaterials(AValue: TGLLibMaterialsEx);
Protected | procedure WriteComponents(AStream: TStream);

Properties

Published | property Components: TGLMatLibComponents read FComponents write SetComponents;
Published | property Materials: TGLLibMaterialsEx read GetMaterials write SetMaterials stored StoreMaterials;
Published | property TexturePaths;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AddAsmProg(const AName: TGLMaterialComponentName): TGLASMVertexProgram;
Public function AddAttachment(const AName: TGLMaterialComponentName): TGLFrameBufferAttachment;
Public function AddCombiner(const AName: TGLMaterialComponentName): TGLTextureCombiner;
Public function AddSampler(const AName: TGLMaterialComponentName): TGLTextureSampler;
Public function AddShader(const AName: TGLMaterialComponentName): TGLShaderEx;
Public function AddTexture(const AName: TGLMaterialComponentName): TGLTextureImageEx;
Protected function GetMaterials: TGLLibMaterialsEx;
Protected function StoreMaterials: Boolean;
Public procedure GetNames(Proc: TGetStrProc; AClass: CGLBaseMaterialCollectionItem); overload;
Public procedure SetLevelForAll(const ALevel: TGLMaterialLevel);
Protected procedure DefineProperties(Filer: TFiler); override;
Protected procedure Loaded; override;
Protected procedure ReadComponents(AStream: TStream);
Protected procedure SetComponents(AValue: TGLMatLibComponents);
Protected procedure SetMaterials(AValue: TGLLibMaterialsEx);
Protected procedure WriteComponents(AStream: TStream);

Properties

Published property Components: TGLMatLibComponents read FComponents write SetComponents;
Published property Materials: TGLLibMaterialsEx read GetMaterials write SetMaterials stored StoreMaterials;

The materials collection.

Published property TexturePaths;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialMultiProxy

Unit GLMaterialMultiProxy

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLMaterialMultiProxy<p>

Implements a multi-proxy object, useful for discreet LOD.<p> Allows assign a unique material for each proxy master.<p>

<b>History : </b><font size=-1><ul> <li>30/08/10 - Yar - Fixed transformation in TGLMaterialMultiProxy.DoRender <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>10/04/08 - DaStr - Added a Delpi 5 interface bug work-around to TGLMaterialMultiProxyMaster (BugTracker ID = 1938988) <li>25/03/07 - Added GLCrossPlatform to uses for Delphi5 compatibility <li>17/02/07 - DaStr - Initial version (contributed to GLScene) </ul></font>

What changed compared to GLMultiProxy: 1) Allows assign a unique material for each proxy master 2) TGLMaterialMultiProxyMaster: FDistanceMin, FDistanceMax removed 3) TGLMaterialMultiProxy = class(TGLBaseSceneObject)!!! 4) TGLMaterialMultiProxyMaster.Visible removed 5) TGLMaterialMultiProxy.MaterialLibrary added 6) TGLMaterialMultiProxyMaster.MasterLibMaterial added 7) TGLMaterialMultiProxyMasters.Add overloaded 8) Implemented a new mechanizm of connecting TGLLibMaterial and TGLLibMaterialName (they are connected on assigning, not while rendering; full persistency support; allows to assign directly to TGLLibMaterial) 9) VCL-style code formating

Previous version history: v1.0 12 December '2005 Creation (based on MultiProxy.pas) v1.0.1 18 June '2006 Some IFDEFs added v1.0.2 20 December '2006 STRANGE_GLSCENE_VERSION checks removed v1.1 17 February '2007 Made design-time compatible

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMaterialMultiProxyMaster |
Class TGLMaterialMultiProxyMasters |
Class TGLMaterialMultiProxy |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialMultiProxy: Class TGLMaterialMultiProxyMaster

Class TGLMaterialMultiProxyMaster

Unit

GLMaterialMultiProxy

Declaration

type TGLMaterialMultiProxyMaster = class(TGLInterfacedCollectionItem, IGLMaterialLibrarySupported)

Description

MasterObject description for a MultiProxy object.

Hierarchy

  • TCollectionItem
  • TGLInterfacedCollectionItem
  • TGLMaterialMultiProxyMaster

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function OwnerObject: TGLMaterialMultiProxy;
Protected | function GetDisplayName: string; override;
Protected | function GetDistanceMax: Single;
Protected | function GetDistanceMin: Single;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange;
Protected | procedure SetDistanceMax(const Val: Single);
Protected | procedure SetDistanceMin(const Val: Single);
Protected | procedure SetMasterObject(const Val: TGLBaseSceneObject);

Properties

Published | property DistanceMax: Single read GetDistanceMax write SetDistanceMax;
Published | property DistanceMin: Single read GetDistanceMin write SetDistanceMin;
Public | property MasterLibMaterial: TGLLibMaterial read FMasterLibMaterial write FMasterLibMaterial stored False;
Published | property MasterLibMaterialName: TGLLibMaterialName read GetMasterLibMaterialName write SetMasterLibMaterialName;
Published | property MasterObject: TGLBaseSceneObject read FMasterObject write SetMasterObject;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Public function OwnerObject: TGLMaterialMultiProxy;
Protected function GetDisplayName: string; override;
Protected function GetDistanceMax: Single;
Protected function GetDistanceMin: Single;
Public procedure Assign(Source: TPersistent); override;
Public procedure NotifyChange;
Protected procedure SetDistanceMax(const Val: Single);
Protected procedure SetDistanceMin(const Val: Single);
Protected procedure SetMasterObject(const Val: TGLBaseSceneObject);

Properties

Published property DistanceMax: Single read GetDistanceMax write SetDistanceMax;

Maximum visibility Distance (exclusive).

Published property DistanceMin: Single read GetDistanceMin write SetDistanceMin;

Minimum visibility Distance (inclusive).

Public property MasterLibMaterial: TGLLibMaterial read FMasterLibMaterial write FMasterLibMaterial stored False;

Specifies the Material, that current master object will use. Provides a faster way to access FMasterLibMaterial, compared to MasterLibMaterialName

Published property MasterLibMaterialName: TGLLibMaterialName read GetMasterLibMaterialName write SetMasterLibMaterialName;

Specifies the Material, that current master object will use.

Published property MasterObject: TGLBaseSceneObject read FMasterObject write SetMasterObject;

Specifies the Master object which will be proxy'ed.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialMultiProxy: Class TGLMaterialMultiProxyMasters

Class TGLMaterialMultiProxyMasters

Unit

GLMaterialMultiProxy

Declaration

type TGLMaterialMultiProxyMasters = class(TOwnedCollection)

Description

Collection of TGLMaterialMultiProxyMaster.

Hierarchy

  • TOwnedCollection
  • TGLMaterialMultiProxyMasters

Overview

Methods

Public | constructor Create(AOwner: TPersistent);
Public | function Add: TGLMaterialMultiProxyMaster; overload;
Public | function Add(Master: TGLBaseSceneObject; DistanceMin, DistanceMax: Single): TGLMaterialMultiProxyMaster; overload;
Public | function Add(Master: TGLBaseSceneObject; MasterLibMaterial: TGLLibMaterial; DistanceMin, DistanceMax: Single): TGLMaterialMultiProxyMaster; overload;
Protected | function GetItems(index: Integer): TGLMaterialMultiProxyMaster;
Public | procedure EndUpdate; override;
Public | procedure NotifyChange;
Protected | procedure Notification(AComponent: TComponent); virtual;
Protected | procedure SetItems(index: Integer; const Val: TGLMaterialMultiProxyMaster);
Protected | procedure Update(Item: TCollectionItem); override;

Properties

Public property Items[index: Integer]: TGLMaterialMultiProxyMaster read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent);
Public function Add: TGLMaterialMultiProxyMaster; overload;
Public function Add(Master: TGLBaseSceneObject; DistanceMin, DistanceMax: Single): TGLMaterialMultiProxyMaster; overload;
Public function Add(Master: TGLBaseSceneObject; MasterLibMaterial: TGLLibMaterial; DistanceMin, DistanceMax: Single): TGLMaterialMultiProxyMaster; overload;
Protected function GetItems(index: Integer): TGLMaterialMultiProxyMaster;
Public procedure EndUpdate; override;
Public procedure NotifyChange;
Protected procedure Notification(AComponent: TComponent); virtual;
Protected procedure SetItems(index: Integer; const Val: TGLMaterialMultiProxyMaster);
Protected procedure Update(Item: TCollectionItem); override;

Properties

Public property Items[index: Integer]: TGLMaterialMultiProxyMaster read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialMultiProxy: Class TGLMaterialMultiProxy

Class TGLMaterialMultiProxy

Unit

GLMaterialMultiProxy

Declaration

type TGLMaterialMultiProxy = class(TGLBaseSceneObject)

Description

Multiple Proxy object.<p> This proxy has multiple Master objects, which are individually made visible depending on a Distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation.<p> For dimensionsn raycasting and silhouette purposes, the first Master is used (item zero in the MasterObjects collection).

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLMaterialMultiProxy

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; override;
Protected | function PrimaryMaster: TGLBaseSceneObject;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetMasterObjects(const Val: TGLMaterialMultiProxyMasters);

Properties

Published | property Behaviours;
Published | property Direction;
Published | property Effects;
Published | property MasterObjects: TGLMaterialMultiProxyMasters read FMasterObjects write SetMasterObjects;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property Visible;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;
Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; override;
Protected function PrimaryMaster: TGLBaseSceneObject;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetMasterObjects(const Val: TGLMaterialMultiProxyMasters);

Properties

Published property Behaviours;
Published property Direction;
Published property Effects;
Published property MasterObjects: TGLMaterialMultiProxyMasters read FMasterObjects write SetMasterObjects;
Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published property ObjectsSorting;
Published property OnProgress;
Published property PitchAngle;
Published property Position;
Published property RollAngle;
Published property Scale;
Published property ShowAxes;
Published property TurnAngle;
Published property Up;
Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialScript

Unit GLMaterialScript

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLShaderItem |
Class TGLShaderItems |
Class TGLMaterialLibraryItem |
Class TGLMaterialLibraryItems |
Class TGLMaterialScripter |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:29


GLScene v.1.1.2: GLMaterialScript: Class TGLShaderItem

Class TGLShaderItem

Unit

GLMaterialScript

Declaration

type TGLShaderItem = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLShaderItem

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Name: string read FName write SetName;
Published | property Shader: TGLShader read FShader write SetShader;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;

Properties

Published property Name: string read FName write SetName;
Published property Shader: TGLShader read FShader write SetShader;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMaterialScript: Class TGLShaderItems

Class TGLShaderItems

Unit

GLMaterialScript

Declaration

type TGLShaderItems = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLShaderItems

Overview

Methods

Public constructor Create(AOwner: TPersistent);

Properties

Public property Items[Index: Integer]: TGLShaderItem read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent);

Properties

Public property Items[Index: Integer]: TGLShaderItem read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMaterialScript: Class TGLMaterialLibraryItem

Class TGLMaterialLibraryItem

Unit

GLMaterialScript

Declaration

type TGLMaterialLibraryItem = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLMaterialLibraryItem

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property Name: string read FName write SetName;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;

Properties

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published property Name: string read FName write SetName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMaterialScript: Class TGLMaterialLibraryItems

Class TGLMaterialLibraryItems

Unit

GLMaterialScript

Declaration

type TGLMaterialLibraryItems = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLMaterialLibraryItems

Overview

Methods

Public constructor Create(AOwner: TPersistent);

Properties

Public property Items[Index: Integer]: TGLMaterialLibraryItem read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent);

Properties

Public property Items[Index: Integer]: TGLMaterialLibraryItem read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMaterialScript: Class TGLMaterialScripter

Class TGLMaterialScripter

Unit

GLMaterialScript

Declaration

type TGLMaterialScripter = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLMaterialScripter

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure CompileScript;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property AppendToMaterialLibrary: Boolean read FAppend write SetAppend;
Public | property DebugMemo: TMemo read FMemo write SetMemo;
Published | property MaterialLibraries: TGLMaterialLibraryItems read FMaterialLibraryItems write SeTGLMaterialLibraryItems;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property OverwriteToMaterialLibrary: Boolean read FOverwrite write SetOverwrite;
Published | property Script: TStrings read FScript write SetScript;
Published | property Shaders: TGLShaderItems read FShaderItems write SeTGLShaderItems;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure CompileScript;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published property AppendToMaterialLibrary: Boolean read FAppend write SetAppend;
Public property DebugMemo: TMemo read FMemo write SetMemo;
Published property MaterialLibraries: TGLMaterialLibraryItems read FMaterialLibraryItems write SeTGLMaterialLibraryItems;
Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published property OverwriteToMaterialLibrary: Boolean read FOverwrite write SetOverwrite;
Published property Script: TStrings read FScript write SetScript;
Published property Shaders: TGLShaderItems read FShaderItems write SeTGLShaderItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMesh

Unit GLMesh

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TVertexData |
Class TVertexList |
Class TGLMesh |

Types

TMeshMode = (...);
TVertexMode = (...);
PVertexData = ˆTVertexData;
TVertexDataArray = array[0..(MAXINT shr 6)] of TVertexData;
PVertexDataArray = ˆTVertexDataArray;

Constants

cMeshModeToGLEnum: array[Low(TMeshMode)..High(TMeshMode) ] of TGLEnum = (GL_TRIANGLE_STRIP, GL_TRIANGLE_FAN, GL_TRIANGLES, GL_QUAD_STRIP, GL_QUADS, GL_POLYGON);
cVertexModeToGLEnum: array[Low(TVertexMode)..High(TVertexMode) ] of TGLEnum = (GL_V3F, GL_N3F_V3F, GL_C4F_N3F_V3F, GL_T2F_C4F_N3F_V3F, GL_T2F_N3F_V3F, GL_T2F_V3F);

Description

Types

TMeshMode = (...);
Values
  • mmTriangleStrip:
  • mmTriangleFan:
  • mmTriangles:
  • mmQuadStrip:
  • mmQuads:
  • mmPolygon:
TVertexMode = (...);
Values
  • vmV:
  • vmVN:
  • vmVNC:
  • vmVNCT:
  • vmVNT:
  • vmVT:
PVertexData = ˆTVertexData;
TVertexDataArray = array[0..(MAXINT shr 6)] of TVertexData;
PVertexDataArray = ˆTVertexDataArray;

Constants

cMeshModeToGLEnum: array[Low(TMeshMode)..High(TMeshMode) ] of TGLEnum = (GL_TRIANGLE_STRIP, GL_TRIANGLE_FAN, GL_TRIANGLES, GL_QUAD_STRIP, GL_QUADS, GL_POLYGON);
cVertexModeToGLEnum: array[Low(TVertexMode)..High(TVertexMode) ] of TGLEnum = (GL_V3F, GL_N3F_V3F, GL_C4F_N3F_V3F, GL_T2F_C4F_N3F_V3F, GL_T2F_N3F_V3F, GL_T2F_V3F);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMesh: packed record TVertexData

packed record TVertexData

Unit

GLMesh

Declaration

type TVertexData = packed record

Description

Overview

Fields

textCoord: TTexPoint;
color: TVector;
normal: TAffineVector;
coord: TVertex;

Description

Fields

textCoord: TTexPoint;
color: TVector;
normal: TAffineVector;
coord: TVertex;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMesh: Class TVertexList

Class TVertexList

Unit

GLMesh

Declaration

type TVertexList = class(TGLUpdateAbleObject)

Description

no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TVertexList

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function CreateInterpolatedCoords(list2: TVertexList; lerpFactor: Single) : TVertexList;
Public | function SumVertexCoords: TAffineVector;
Protected | function GetFirstColor: PGLFloat;
Protected | function GetFirstEntry: PGLFloat;
Protected | function GetFirstNormal: PGLFloat;
Protected | function GetFirstTexPoint: PGLFloat;
Protected | function GetFirstVertex: PGLFloat;
Protected | function GetLocked: Boolean;
Protected | function GetVertexColor(index: Integer): TVector4f;
Protected | function GetVertexCoord(index: Integer): TAffineVector;
Protected | function GetVertexNormal(index: Integer): TAffineVector;
Protected | function GetVertexTexCoord(index: Integer): TTexPoint;
Protected | function GetVertices(index: Integer): TVertexData;
Public | procedure AddVertex(const vertexData: TVertexData); overload;
Public | procedure AddVertex(const vertex: TVertex; const normal: TAffineVector; const color: TColorVector); overload;
Public | procedure AddVertex(const vertex: TVertex; const normal: TAffineVector); overload;
Public | procedure AddVertex(const aVertex: TVertex; const aNormal: TAffineVector; const aColor: TColorVector; const aTexPoint: TTexPoint); overload;
Public | procedure AddVertex3(const vd1, vd2, vd3: TVertexData); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Clear;
Public | procedure DefineOpenGLArrays;
Public | procedure DuplicateVertex(index: Integer);
Public | procedure EnterLockSection;
Public | procedure GetExtents(var min, max: TAffineVector);
Public | procedure LeaveLockSection;
Public | procedure NormalizeNormals;
Public | procedure Translate(const v: TAffineVector);
Protected | procedure Grow;
Protected | procedure SetCapacity(const val: Integer);
Protected | procedure SetGrowth(const val: Integer);
Protected | procedure SetLocked(val: Boolean);
Protected | procedure SetVertexColor(index: Integer; const val: TVector4f);
Protected | procedure SetVertexCoord(index: Integer; const val: TAffineVector);
Protected | procedure SetVertexNormal(index: Integer; const val: TAffineVector);
Protected | procedure SetVertexTexCoord(index: Integer; const val: TTexPoint);
Protected | procedure SetVertices(index: Integer; const val: TVertexData);

Properties

Public | property Capacity: Integer read FCapacity write SetCapacity;
Public | property Count: Integer read FCount;
Public | property FirstColor: PGLFloat read GetFirstColor;
Public | property FirstEntry: PGLFloat read GetFirstEntry;
Public | property FirstNormal: PGLFloat read GetFirstNormal;
Public | property FirstTexPoint: PGLFloat read GetFirstTexPoint;
Public | property FirstVertex: PGLFloat read GetFirstVertex;
Public | property Growth: Integer read FGrowth write SetGrowth;
Public | property Locked: Boolean read GetLocked write SetLocked;
Public | property VertexColor[index: Integer]: TVector4f read GetVertexColor write SetVertexColor;
Public | property VertexCoord[index: Integer]: TAffineVector read GetVertexCoord write SetVertexCoord;
Public | property VertexNormal[index: Integer]: TAffineVector read GetVertexNormal write SetVertexNormal;
Public | property VertexTexCoord[index: Integer]: TTexPoint read GetVertexTexCoord write SetVertexTexCoord;
Public | property Vertices[index: Integer]: TVertexData read GetVertices write SetVertices;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public function CreateInterpolatedCoords(list2: TVertexList; lerpFactor: Single) : TVertexList;
Public function SumVertexCoords: TAffineVector;
Protected function GetFirstColor: PGLFloat;
Protected function GetFirstEntry: PGLFloat;
Protected function GetFirstNormal: PGLFloat;
Protected function GetFirstTexPoint: PGLFloat;
Protected function GetFirstVertex: PGLFloat;
Protected function GetLocked: Boolean;
Protected function GetVertexColor(index: Integer): TVector4f;
Protected function GetVertexCoord(index: Integer): TAffineVector;
Protected function GetVertexNormal(index: Integer): TAffineVector;
Protected function GetVertexTexCoord(index: Integer): TTexPoint;
Protected function GetVertices(index: Integer): TVertexData;
Public procedure AddVertex(const vertexData: TVertexData); overload;
Public procedure AddVertex(const vertex: TVertex; const normal: TAffineVector; const color: TColorVector); overload;
Public procedure AddVertex(const vertex: TVertex; const normal: TAffineVector); overload;
Public procedure AddVertex(const aVertex: TVertex; const aNormal: TAffineVector; const aColor: TColorVector; const aTexPoint: TTexPoint); overload;
Public procedure AddVertex3(const vd1, vd2, vd3: TVertexData); overload;
Public procedure Assign(Source: TPersistent); override;
Public procedure Clear;
Public procedure DefineOpenGLArrays;
Public procedure DuplicateVertex(index: Integer);
Public procedure EnterLockSection;
Public procedure GetExtents(var min, max: TAffineVector);
Public procedure LeaveLockSection;
Public procedure NormalizeNormals;
Public procedure Translate(const v: TAffineVector);
Protected procedure Grow;
Protected procedure SetCapacity(const val: Integer);
Protected procedure SetGrowth(const val: Integer);
Protected procedure SetLocked(val: Boolean);
Protected procedure SetVertexColor(index: Integer; const val: TVector4f);
Protected procedure SetVertexCoord(index: Integer; const val: TAffineVector);
Protected procedure SetVertexNormal(index: Integer; const val: TAffineVector);
Protected procedure SetVertexTexCoord(index: Integer; const val: TTexPoint);
Protected procedure SetVertices(index: Integer; const val: TVertexData);

Properties

Public property Capacity: Integer read FCapacity write SetCapacity;
Public property Count: Integer read FCount;
Public property FirstColor: PGLFloat read GetFirstColor;
Public property FirstEntry: PGLFloat read GetFirstEntry;
Public property FirstNormal: PGLFloat read GetFirstNormal;
Public property FirstTexPoint: PGLFloat read GetFirstTexPoint;
Public property FirstVertex: PGLFloat read GetFirstVertex;
Public property Growth: Integer read FGrowth write SetGrowth;
Public property Locked: Boolean read GetLocked write SetLocked;
Public property VertexColor[index: Integer]: TVector4f read GetVertexColor write SetVertexColor;
Public property VertexCoord[index: Integer]: TAffineVector read GetVertexCoord write SetVertexCoord;
Public property VertexNormal[index: Integer]: TAffineVector read GetVertexNormal write SetVertexNormal;
Public property VertexTexCoord[index: Integer]: TTexPoint read GetVertexTexCoord write SetVertexTexCoord;
Public property Vertices[index: Integer]: TVertexData read GetVertices write SetVertices;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMesh: Class TGLMesh

Class TGLMesh

Unit

GLMesh

Declaration

type TGLMesh = class(TGLSceneObject)

Description

no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLMesh

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure CalcNormals(Frontface: TFaceWinding);
Public | procedure StructureChanged; override;
Protected | procedure SetMode(AValue: TMeshMode);
Protected | procedure SetVertexMode(AValue: TVertexMode);
Protected | procedure SetVertices(AValue: TVertexList);
Protected | procedure VerticesChanged(Sender: TObject);

Properties

Published | property Mode: TMeshMode read FMode write SetMode;
Published | property VertexMode: TVertexMode read FVertexMode write SetVertexMode default vmVNCT;
Public | property Vertices: TVertexList read FVertices write SetVertices;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure CalcNormals(Frontface: TFaceWinding);
Public procedure StructureChanged; override;
Protected procedure SetMode(AValue: TMeshMode);
Protected procedure SetVertexMode(AValue: TVertexMode);
Protected procedure SetVertices(AValue: TVertexList);
Protected procedure VerticesChanged(Sender: TObject);

Properties

Published property Mode: TMeshMode read FMode write SetMode;
Published property VertexMode: TVertexMode read FVertexMode write SetVertexMode default vmVNCT;
Public property Vertices: TVertexList read FVertices write SetVertices;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMeshBuilder

Unit GLMeshBuilder

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Build mesh objects.

How often do you miss a BuildSphereMesh function for testing or editors?

Well this unit is intended to solve that problem. We want fast, flexible functions with lots of options...

Original Author: Joen Joensen. Contributed to the GLScene community.

Features: BuildCube, BuildCylinder.

<b>History : </b><font size=-1><ul> <li>22/01/10 - Yar - Added VectorTypes to uses <li>29/11/03 - JAJ - Created and Submitted to GLScene. <li>21/07/03 - JAJ - Added BuildCylinder2 submitted by Gorka? </ul></font>

Overview

Functions and Procedures

Procedure BuildCube(Mesh : TMeshObject; Position, Scale : TAffineVector);
Procedure BuildCylinder(Mesh : TMeshObject; Position, Scale : TAffineVector; Slices : Integer);
Procedure BuildCylinder2(Mesh : TMeshObject; Position, Scale : TAffineVector; TopRadius,BottomRadius,Height: single; Slices : Integer);

Description

Functions and Procedures

Procedure BuildCube(Mesh : TMeshObject; Position, Scale : TAffineVector);
Procedure BuildCylinder(Mesh : TMeshObject; Position, Scale : TAffineVector; Slices : Integer);
Procedure BuildCylinder2(Mesh : TMeshObject; Position, Scale : TAffineVector; TopRadius,BottomRadius,Height: single; Slices : Integer);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMeshCSG

Unit GLMeshCSG

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLMeshCSG<p>

Constructive Solid Geometry in GLScene.

The CSG system uses BSP to optimize what triangles it considers. Its kept on a mesh basis to simplyfy things, it allways generates new BSP's, even if the meshes allready had BSP optimization.

Author: Joen Joensen. Contributed to the GLScene community.

Features: CSG_Union, CSG_Subtraction, CSG_Intersection.

<b>History : </b><font size=-1><ul> <li>06/06/10 - Yar - Added VectorTypes to uses <li>30/03/07 - DaStr - Added $I GLScene.inc <li>18/07/04 - JAJ - Bug fix, causing triangles to dissapear, once in a while. <li>29/11/03 - JAJ - Created and Submitted to GLScene. </ul></font>

Overview

Functions and Procedures

procedure CSG_Operation(obj1, obj2: TMeshObject; Operation: TCSGOperation; Res: TMeshObject; const MaterialName1, MaterialName2: string);

Types

TCSGOperation = (...);

Description

Functions and Procedures

procedure CSG_Operation(obj1, obj2: TMeshObject; Operation: TCSGOperation; Res: TMeshObject; const MaterialName1, MaterialName2: string);

Types

TCSGOperation = (...);
Values
  • CSG_Union:
  • CSG_Subtraction:
  • CSG_Intersection:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMeshOptimizer

Unit GLMeshOptimizer

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Mesh optimization for GLScene.<p>

<b>History : </b><font size=-1><ul> <li>27/11/07 - mrqzzz - added FacesSmooth InvertNormals parameter. Now smoothes correctly. <li>21/08/03 - EG - Added basic mooStandardize support <li>03/06/03 - EG - Creation </ul></font>

Overview

Functions and Procedures

procedure OptimizeMesh(aList : TMeshObjectList; options : TMeshOptimizerOptions); overload;
procedure OptimizeMesh(aList : TMeshObjectList); overload;
procedure OptimizeMesh(aMeshObject : TMeshObject; options : TMeshOptimizerOptions); overload;
procedure OptimizeMesh(aMeshObject : TMeshObject); overload;
procedure FacesSmooth(aMeshObj: TMeshObject; aWeldDistance: Single=0.0000001; aThreshold: Single=35.0; InvertNormals:boolean=false);

Types

TMeshOptimizerOption = (...);
TMeshOptimizerOptions = set of TMeshOptimizerOption;

Variables

vDefaultMeshOptimizerOptions: TMeshOptimizerOptions = [mooStandardize, mooVertexCache, mooSortByMaterials, mooMergeObjects];

Description

Functions and Procedures

procedure OptimizeMesh(aList : TMeshObjectList; options : TMeshOptimizerOptions); overload;
procedure OptimizeMesh(aList : TMeshObjectList); overload;
procedure OptimizeMesh(aMeshObject : TMeshObject; options : TMeshOptimizerOptions); overload;
procedure OptimizeMesh(aMeshObject : TMeshObject); overload;
procedure FacesSmooth(aMeshObj: TMeshObject; aWeldDistance: Single=0.0000001; aThreshold: Single=35.0; InvertNormals:boolean=false);

Types

TMeshOptimizerOption = (...);
Values
  • mooStandardize:
  • mooVertexCache:
  • mooSortByMaterials:
  • mooMergeObjects:
TMeshOptimizerOptions = set of TMeshOptimizerOption;

Variables

vDefaultMeshOptimizerOptions: TMeshOptimizerOptions = [mooStandardize, mooVertexCache, mooSortByMaterials, mooMergeObjects];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMirror

Unit GLMirror

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLMirror<p>

Implements a basic, stencil-based mirror (as in Mark Kilgard's demo).<p>

It is strongly recommended to read and understand the explanations in the materials/mirror demo before using this component.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>15/12/08- Paul Robello - corrected call to FOnEndRenderingMirrors <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>18/07/04 - Orlando - added custom shapes <li>13/02/03 - DanB - added TGLMirror.AxisAlignedDimensionsUnscaled <li>13/11/02 - EG - Fixed TGLMirror.DoRender transform <li>06/11/02 - EG - Fixed Stencil setup <li>30/10/02 - EG - Added OnBegin/EndRenderingMirrors <li>25/10/02 - EG - Fixed Stencil cleanup <li>22/02/01 - EG - Fixed change notification, Fixed special effects support (PFX, etc.) <li>07/12/01 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMirror |

Types

TMirrorOption = (...);
TMirrorOptions = set of TMirrorOption;
TMirrorShapes = (...);

Constants

cDefaultMirrorOptions = [moUseStencil];

Description

Types

TMirrorOption = (...);
Values
  • moUseStencil:
  • moOpaque:
  • moMirrorPlaneClip:
  • moClearZBuffer:
TMirrorOptions = set of TMirrorOption;
TMirrorShapes = (...);
Values
  • msRect:
  • msDisk:

Constants

cDefaultMirrorOptions = [moUseStencil];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMirror: Class TGLMirror

Class TGLMirror

Unit

GLMirror

Declaration

type TGLMirror = class(TGLSceneObject)

Description

A simple plane mirror.<p> This mirror requires a stencil buffer for optimal rendering!<p> The object is a mix between a plane and a proxy object, in that the plane defines the mirror's surface, while the proxy part is used to reference the objects that should be mirrored (it is legal to self-mirror, but no self-mirror visuals will be rendered).<p> It is strongly recommended to read and understand the explanations in the materials/mirror demo before using this component.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLMirror

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Protected | function GetRadius: single;
Protected | function GetSlices: TGLInt;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var ARci: TRenderContextInfo); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected | procedure ClearZBufferArea(aBuffer: TGLSceneBuffer);
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetHeight(AValue: TGLFloat);
Protected | procedure SetMirrorObject(const val: TGLBaseSceneObject);
Protected | procedure SetMirrorOptions(const val: TMirrorOptions);
Protected | procedure SetRadius(const aValue: Single);
Protected | procedure SetShape(aValue: TMirrorShapes);
Protected | procedure SetSlices(const aValue: TGLInt);
Protected | procedure SetWidth(AValue: TGLFloat);

Properties

Published | property Height: TGLFloat read FHeight write SetHeight;
Published | property MirrorObject: TGLBaseSceneObject read FMirrorObject write SetMirrorObject;
Published | property MirrorOptions: TMirrorOptions read FMirrorOptions write SetMirrorOptions default cDefaultMirrorOptions;
Published | property OnBeginRenderingMirrors: TNotifyEvent read FOnBeginRenderingMirrors write FOnBeginRenderingMirrors;
Published | property OnEndRenderingMirrors: TNotifyEvent read FOnEndRenderingMirrors write FOnEndRenderingMirrors;
Published | property Radius: TGLFloat read FRadius write SetRadius;
Published | property Shape: TMirrorShapes read FShape write SetShape default msRect;
Published | property Slices: TGLInt read FSlices write SetSlices default 16;
Published | property Width: TGLFloat read FWidth write SetWidth;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Protected function GetRadius: single;
Protected function GetSlices: TGLInt;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var ARci: TRenderContextInfo); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected procedure ClearZBufferArea(aBuffer: TGLSceneBuffer);
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetHeight(AValue: TGLFloat);
Protected procedure SetMirrorObject(const val: TGLBaseSceneObject);
Protected procedure SetMirrorOptions(const val: TMirrorOptions);
Protected procedure SetRadius(const aValue: Single);
Protected procedure SetShape(aValue: TMirrorShapes);
Protected procedure SetSlices(const aValue: TGLInt);
Protected procedure SetWidth(AValue: TGLFloat);

Properties

Published property Height: TGLFloat read FHeight write SetHeight;
Published property MirrorObject: TGLBaseSceneObject read FMirrorObject write SetMirrorObject;

Selects the object to mirror.<p> If nil, the whole scene is mirrored.

Published property MirrorOptions: TMirrorOptions read FMirrorOptions write SetMirrorOptions default cDefaultMirrorOptions;

Controls rendering options.<p> <ul> <li>moUseStencil: mirror area is stenciled, prevents reflected objects to be visible on the sides of the mirror (stencil buffer must be active in the viewer) <li>moOpaque: mirror is opaque (ie. painted with background color) <li>moMirrorPlaneClip: a ClipPlane is defined to prevent reflections from popping out of the mirror (for objects behind or halfway through) <li>moClearZBuffer: mirror area's ZBuffer is cleared so that background objects don't interfere with reflected objects (reflected objects must be rendered AFTER the mirror in the hierarchy). Works only along with stenciling. </ul>

Published property OnBeginRenderingMirrors: TNotifyEvent read FOnBeginRenderingMirrors write FOnBeginRenderingMirrors;

Fired before the object's mirror images are rendered.

Published property OnEndRenderingMirrors: TNotifyEvent read FOnEndRenderingMirrors write FOnEndRenderingMirrors;

Fired after the object's mirror images are rendered.

Published property Radius: TGLFloat read FRadius write SetRadius;
Published property Shape: TMirrorShapes read FShape write SetShape default msRect;
Published property Slices: TGLInt read FSlices write SetSlices default 16;
Published property Width: TGLFloat read FWidth write SetWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMovement

Unit GLMovement

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLMovement<p>

Movement path behaviour by Roger Cao<p>

Note: It is recommended to set TGLMovementPath.RotationMode = rmUpDirection, but the default value is rmTurnPitchRoll for backwards compatibility.

<b>Historique : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records Replaced direct access to properties by methods GetPositionCoordinate, GetRotationCoordinate, GetScaleCoordinate, GetDirectionCoordinate and GetUpCoordinate <li>21/01/01 - DanB - Added "inherited" call to TGLMovement.WriteToFiler <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>12/11/09 - DaStr - Bugfix after previous commit <li>25/10/09 - DaStr - Bugfixed TGLMovementPath.StartTime (thanks Zsolt Laky) <li>14/03/09 - DanB - Changes to Start/StopAllMovements due to TGLScene.Cameras removal <li>05/10/08 - DaStr - Added Delphi5 compatibility <li>21/06/08 - DaStr - A lot of cosmetic fixes Bugfixed same position rotation / scale interpolation in TGLMovementPath.CalculateState() Bugfixed destroying TGLMovement with multiple paths. Added TGLMovementPath.RotationMode (Bugtracker ID = 1999464) (thanks VirusX) <li>02/04/07 - DaStr - All cross-version stuff abstracted into GLCrossPlatform <li>25/03/07 - DaStr - Small fix for Delphi5 compatibility <li>15/02/07 - DaStr - Fixed TGLMovementPath.SetShowPath - SubComponent support <li>27/10/06 - LC - Fixed memory leak in TGLMovementPath. Bugtracker ID=1548615 (thanks Da Stranger) <li>28/09/04 - Mrqzzz - Fixed bug in proc. Interpolation (skipped a line from Carlos' code, oops) <li>09/09/04 - Mrqzzz - CalculateState change by Carlos (NG) to make speed interpolated between nodes <li>20/11/01 - Egg - DoProgress fix suggested by Philipp Pammler (NG) <li>14/01/01 - Egg - Minor changes, integrated to v0.8RC2, still needed: use of standard classes and documentation <li>22/09/00 - RoC - Added StartAllPathTravel and StopAllPathTravel methods <li>24/08/00 - RoC - TGLMovement and relative class added </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPathNode |
Class TGLPathNodes |
Class TGLMovementPath |
Class TGLMovementPaths |
Class TGLMovement |

Functions and Procedures

function GetMovement(const behaviours: TGLBehaviours): TGLMovement; overload;
function GetMovement(const obj: TGLBaseSceneObject): TGLMovement; overload;
function GetOrCreateMovement(const behaviours: TGLBehaviours): TGLMovement; overload;
function GetOrCreateMovement(const obj: TGLBaseSceneObject): TGLMovement; overload;
procedure StartAllMovements(const Scene: TGLScene; const StartCamerasMove, StartObjectsMove: Boolean);
procedure StopAllMovements(const Scene: TGLScene; const StopCamerasMove, StopObjectsMove: Boolean);

Types

TGLMovementRotationMode = (...);
TPathTravelStartEvent = procedure (Sender: TObject; Path: TGLMovementPath) of object;
TPathTravelStopEvent = procedure (Sender: TObject; Path: TGLMovementPath; var Looped: boolean) of object;

Description

Functions and Procedures

function GetMovement(const behaviours: TGLBehaviours): TGLMovement; overload;
function GetMovement(const obj: TGLBaseSceneObject): TGLMovement; overload;
function GetOrCreateMovement(const behaviours: TGLBehaviours): TGLMovement; overload;
function GetOrCreateMovement(const obj: TGLBaseSceneObject): TGLMovement; overload;
procedure StartAllMovements(const Scene: TGLScene; const StartCamerasMove, StartObjectsMove: Boolean);
procedure StopAllMovements(const Scene: TGLScene; const StopCamerasMove, StopObjectsMove: Boolean);

Types

TGLMovementRotationMode = (...);
Values
  • rmTurnPitchRoll:
  • rmUpDirection:
TPathTravelStartEvent = procedure (Sender: TObject; Path: TGLMovementPath) of object;
TPathTravelStopEvent = procedure (Sender: TObject; Path: TGLMovementPath; var Looped: boolean) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMovement: Class TGLPathNode

Class TGLPathNode

Unit

GLMovement

Declaration

type TGLPathNode = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLPathNode

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function EqualNode(const aNode: TGLPathNode): boolean;
Public | function PositionAsAddress: PGLFloat;
Public | function RotationAsAddress: PGLFloat;
Public | function ScaleAsAddress: PGLFloat;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure InitializeByObject(const Obj: TGLBaseSceneObject);
Protected | procedure ReadFromFiler(reader : TReader);
Protected | procedure WriteToFiler(writer : TWriter);

Properties

Public | property DirectionAsVector: TVector read FDirection write FDirection;
Published | property DirectionX: TGLFloat index 0 Read GetDirectionCoordinate Write SetDirectionCoordinate;
Published | property DirectionY: TGLFloat index 1 Read GetDirectionCoordinate Write SetDirectionCoordinate;
Published | property DirectionZ: TGLFloat index 2 Read GetDirectionCoordinate Write SetDirectionCoordinate;
Published | property PitchAngle: TGLFloat index 0 Read GetRotationCoordinate Write SetRotationCoordinate;
Public | property PositionAsVector: TVector Read FPosition Write SetPositionAsVector;
Published | property RollAngle: TGLFloat index 2 Read GetRotationCoordinate Write SetRotationCoordinate;
Public | property RotationAsVector: TVector Read FRotation Write SetRotationAsVector;
Public | property ScaleAsVector: TVector Read FScale Write SetScaleAsVector;
Published | property ScaleX: TGLFloat index 0 Read GetScaleCoordinate Write SetScaleCoordinate;
Published | property ScaleY: TGLFloat index 1 Read GetScaleCoordinate Write SetScaleCoordinate;
Published | property ScaleZ: TGLFloat index 2 Read GetScaleCoordinate Write SetScaleCoordinate;
Published | property Speed: single Read FSpeed Write SetSpeed;
Published | property TurnAngle: TGLFloat index 1 Read GetRotationCoordinate Write SetRotationCoordinate;
Public | property UpAsVector: TVector read FUp write FUp;
Published | property UpX: TGLFloat index 0 Read GetUpCoordinate Write SetUpCoordinate;
Published | property UpY: TGLFloat index 1 Read GetUpCoordinate Write SetUpCoordinate;
Published | property UpZ: TGLFloat index 2 Read GetUpCoordinate Write SetUpCoordinate;
Published | property X: TGLFloat index 0 Read GetPositionCoordinate Write SetPositionCoordinate;
Published | property Y: TGLFloat index 1 Read GetPositionCoordinate Write SetPositionCoordinate;
Published | property Z: TGLFloat index 2 Read GetPositionCoordinate Write SetPositionCoordinate;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Public function EqualNode(const aNode: TGLPathNode): boolean;

Warning: does not take speed into account.

Public function PositionAsAddress: PGLFloat;
Public function RotationAsAddress: PGLFloat;
Public function ScaleAsAddress: PGLFloat;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure InitializeByObject(const Obj: TGLBaseSceneObject);
Protected procedure ReadFromFiler(reader : TReader);
Protected procedure WriteToFiler(writer : TWriter);

Properties

Public property DirectionAsVector: TVector read FDirection write FDirection;
Published property DirectionX: TGLFloat index 0 Read GetDirectionCoordinate Write SetDirectionCoordinate;
Published property DirectionY: TGLFloat index 1 Read GetDirectionCoordinate Write SetDirectionCoordinate;
Published property DirectionZ: TGLFloat index 2 Read GetDirectionCoordinate Write SetDirectionCoordinate;
Published property PitchAngle: TGLFloat index 0 Read GetRotationCoordinate Write SetRotationCoordinate;
Public property PositionAsVector: TVector Read FPosition Write SetPositionAsVector;
Published property RollAngle: TGLFloat index 2 Read GetRotationCoordinate Write SetRotationCoordinate;
Public property RotationAsVector: TVector Read FRotation Write SetRotationAsVector;

Rotation.X means PitchAngle, Rotation.Y means TurnAngle, Rotation.Z means RollAngle.

Public property ScaleAsVector: TVector Read FScale Write SetScaleAsVector;
Published property ScaleX: TGLFloat index 0 Read GetScaleCoordinate Write SetScaleCoordinate;
Published property ScaleY: TGLFloat index 1 Read GetScaleCoordinate Write SetScaleCoordinate;
Published property ScaleZ: TGLFloat index 2 Read GetScaleCoordinate Write SetScaleCoordinate;
Published property Speed: single Read FSpeed Write SetSpeed;
Published property TurnAngle: TGLFloat index 1 Read GetRotationCoordinate Write SetRotationCoordinate;
Public property UpAsVector: TVector read FUp write FUp;
Published property UpX: TGLFloat index 0 Read GetUpCoordinate Write SetUpCoordinate;
Published property UpY: TGLFloat index 1 Read GetUpCoordinate Write SetUpCoordinate;
Published property UpZ: TGLFloat index 2 Read GetUpCoordinate Write SetUpCoordinate;
Published property X: TGLFloat index 0 Read GetPositionCoordinate Write SetPositionCoordinate;
Published property Y: TGLFloat index 1 Read GetPositionCoordinate Write SetPositionCoordinate;
Published property Z: TGLFloat index 2 Read GetPositionCoordinate Write SetPositionCoordinate;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMovement: Class TGLPathNodes

Class TGLPathNodes

Unit

GLMovement

Declaration

type TGLPathNodes = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLPathNodes

Overview

Methods

Public | constructor Create(aOwner: TGLMovementPath);
Public | function Add: TGLPathNode;
Public | function FindItemID(const ID: integer): TGLPathNode;
Public | function GetOwnerMovementPath: TGLMovementPath;
Protected | function GetItems(const index: integer): TGLPathNode;
Public | procedure NotifyChange; virtual;
Protected | procedure SetItems(const index: integer; const val: TGLPathNode);

Properties

Public property Items[const index: integer]: TGLPathNode Read GetItems Write SetItems;

Description

Methods

Public constructor Create(aOwner: TGLMovementPath);
Public function Add: TGLPathNode;
Public function FindItemID(const ID: integer): TGLPathNode;
Public function GetOwnerMovementPath: TGLMovementPath;
Protected function GetItems(const index: integer): TGLPathNode;
Public procedure NotifyChange; virtual;
Protected procedure SetItems(const index: integer; const val: TGLPathNode);

Properties

Public property Items[const index: integer]: TGLPathNode Read GetItems Write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:30


GLScene v.1.1.2: GLMovement: Class TGLMovementPath

Class TGLMovementPath

Unit

GLMovement

Declaration

type TGLMovementPath = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLMovementPath

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function AddNode: TGLPathNode; overload;
Public | function AddNode(const Node: TGLPathNode): TGLPathNode; overload;
Public | function AddNodeFromObject(const Obj: TGLBaseSceneObject): TGLPathNode;
Public | function DeleteNode(const Node: TGLPathNode): TGLPathNode; overload;
Public | function DeleteNode(const Index: integer): TGLPathNode; overload;
Public | function GetMovement: TGLMovement;
Public | function InsertNode(const Index: integer): TGLPathNode; overload;
Public | function InsertNode(const Node: TGLPathNode; const Index: integer): TGLPathNode; overload;
Public | function InsertNodeFromObject(const Obj: TGLBaseSceneObject; const Index: integer): TGLPathNode;
Public | function NextNode: integer;
Public | function NodeDistance(const Node1, Node2: TGLPathNode): double;
Public | function PrevNode: integer;
Protected | function CanTravel: boolean;
Protected | function GetCollection: TGLMovementPaths;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure CalculateState(const CurrentTime: double);
Public | procedure ClearNodes;
Public | procedure TravelPath(const Start: boolean); overload;
Public | procedure TravelPath(const Start: boolean; const aStartTime: double); overload;
Public | procedure UpdatePathLine;
Protected | procedure ReadFromFiler(reader : TReader);
Protected | procedure WriteToFiler(writer : TWriter);

Properties

Public | property CurrentNode: TGLPathNode Read FCurrentNode;
Public | property CurrentNodeIndex: integer Read FCurrentNodeIndex Write SetCurrentNodeIndex;
Published | property EstimateTime: double Read FEstimateTime;
Public | property InTravel: boolean Read FInTravel;
Published | property Looped: boolean Read FLooped Write FLooped;
Published | property Name: string Read FName Write FName;
Public | property NodeCount: integer Read GetNodeCount;
Published | property Nodes: TGLPathNodes Read FNodes;
Public | property OnTravelStart: TNotifyEvent Read FOnTravelStart Write FOnTravelStart;
Public | property OnTravelStop: TNotifyEvent Read FOnTravelStop Write FOnTravelStop;
Published | property PathSplineMode: TLineSplineMode read FPathSplineMode write SetPathSplineMode default lsmLines;
Published | property RotationMode: TGLMovementRotationMode read FRotationMode write FRotationMode default rmTurnPitchRoll;
Published | property ShowPath: Boolean read FShowPath write SetShowPath;
Published | property StartTime: double Read FStartTime Write SetStartTime;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Public function AddNode: TGLPathNode; overload;
Public function AddNode(const Node: TGLPathNode): TGLPathNode; overload;
Public function AddNodeFromObject(const Obj: TGLBaseSceneObject): TGLPathNode;
Public function DeleteNode(const Node: TGLPathNode): TGLPathNode; overload;
Public function DeleteNode(const Index: integer): TGLPathNode; overload;
Public function GetMovement: TGLMovement;
Public function InsertNode(const Index: integer): TGLPathNode; overload;
Public function InsertNode(const Node: TGLPathNode; const Index: integer): TGLPathNode; overload;
Public function InsertNodeFromObject(const Obj: TGLBaseSceneObject; const Index: integer): TGLPathNode;
Public function NextNode: integer;
Public function NodeDistance(const Node1, Node2: TGLPathNode): double;
Public function PrevNode: integer;
Protected function CanTravel: boolean;
Protected function GetCollection: TGLMovementPaths;
Public procedure Assign(Source: TPersistent); override;
Public procedure CalculateState(const CurrentTime: double);
Public procedure ClearNodes;
Public procedure TravelPath(const Start: boolean); overload;
Public procedure TravelPath(const Start: boolean; const aStartTime: double); overload;
Public procedure UpdatePathLine;
Protected procedure ReadFromFiler(reader : TReader);
Protected procedure WriteToFiler(writer : TWriter);

Properties

Public property CurrentNode: TGLPathNode Read FCurrentNode;
Public property CurrentNodeIndex: integer Read FCurrentNodeIndex Write SetCurrentNodeIndex;
Published property EstimateTime: double Read FEstimateTime;
Public property InTravel: boolean Read FInTravel;
Published property Looped: boolean Read FLooped Write FLooped;
Published property Name: string Read FName Write FName;
Public property NodeCount: integer Read GetNodeCount;
Published property Nodes: TGLPathNodes Read FNodes;
Public property OnTravelStart: TNotifyEvent Read FOnTravelStart Write FOnTravelStart;
Public property OnTravelStop: TNotifyEvent Read FOnTravelStop Write FOnTravelStop;
Published property PathSplineMode: TLineSplineMode read FPathSplineMode write SetPathSplineMode default lsmLines;

This property is currently ignored.

Published property RotationMode: TGLMovementRotationMode read FRotationMode write FRotationMode default rmTurnPitchRoll;
Published property ShowPath: Boolean read FShowPath write SetShowPath;
Published property StartTime: double Read FStartTime Write SetStartTime;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMovement: Class TGLMovementPaths

Class TGLMovementPaths

Unit

GLMovement

Declaration

type TGLMovementPaths = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLMovementPaths

Overview

Methods

Public | constructor Create(aOwner: TGLMovement);
Public | function Add: TGLMovementPath;
Public | function FindItemID(const ID: integer): TGLMovementPath;
Protected | function GetItems(const index: integer): TGLMovementPath;
Protected | function GetMovement: TGLMovement;
Public | procedure NotifyChange; virtual;
Protected | procedure SetItems(const index: integer; const val: TGLMovementPath);

Properties

Public property Items[const index: integer]: TGLMovementPath Read GetItems Write SetItems;

Description

Methods

Public constructor Create(aOwner: TGLMovement);
Public function Add: TGLMovementPath;
Public function FindItemID(const ID: integer): TGLMovementPath;
Protected function GetItems(const index: integer): TGLMovementPath;
Protected function GetMovement: TGLMovement;
Public procedure NotifyChange; virtual;
Protected procedure SetItems(const index: integer; const val: TGLMovementPath);

Properties

Public property Items[const index: integer]: TGLMovementPath Read GetItems Write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMovement: Class TGLMovement

Class TGLMovement

Unit

GLMovement

Declaration

type TGLMovement = class(TGLBehaviour)

Description

no description available, TGLBehaviour description follows

Ancestor for non-rendering behaviours.<p> This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLObjectEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLMovement

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | function AddPath(aObject: TGLBaseSceneObject): TGLMovementPath; overload;
Public | function AddPath: TGLMovementPath; overload;
Public | function AddPath(Path: TGLMovementPath): TGLMovementPath; overload;
Public | function DeletePath: TGLMovementPath; overload;
Public | function DeletePath(Index: integer): TGLMovementPath; overload;
Public | function DeletePath(Path: TGLMovementPath): TGLMovementPath; overload;
Public | function FirstPath: integer;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function LastPath: integer;
Public | function NextPath: integer;
Public | function PrevPath: integer;
Public | class function UniqueItem: boolean; override;
Protected | function GetSceneObject: TGLBaseSceneObject;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ClearPaths;
Public | procedure DoProgress(const progressTime : TProgressTimes); override;
Public | procedure StartPathTravel;
Public | procedure StopPathTravel;
Protected | procedure PathTravelStart(Sender: TObject);
Protected | procedure PathTravelStop(Sender: TObject);
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property ActivePath: TGLMovementPath Read GetActivePath Write SetActivePath;
Published | property ActivePathIndex: integer Read FActivePathIndex Write SetActivePathIndex;
Published | property AutoStartNextPath: boolean Read FAutoStartNextPath Write FAutoStartNextPath;
Public | property OnAllPathTravelledOver: TNotifyEvent Read FOnAllPathTravelledOver Write FOnAllPathTravelledOver;
Public | property OnPathTravelStart: TPathTravelStartEvent Read FOnPathTravelStart Write FOnPathTravelStart;
Public | property OnPathTravelStop: TPathTravelStopEvent Read FOnPathTravelStop Write FOnPathTravelStop;
Public | property PathCount: integer Read GetPathCount;
Published | property Paths: TGLMovementPaths Read FPaths;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;
Public destructor Destroy; override;
Public function AddPath(aObject: TGLBaseSceneObject): TGLMovementPath; overload;
Public function AddPath: TGLMovementPath; overload;
Public function AddPath(Path: TGLMovementPath): TGLMovementPath; overload;
Public function DeletePath: TGLMovementPath; overload;
Public function DeletePath(Index: integer): TGLMovementPath; overload;
Public function DeletePath(Path: TGLMovementPath): TGLMovementPath; overload;
Public function FirstPath: integer;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Public function LastPath: integer;
Public function NextPath: integer;
Public function PrevPath: integer;
Public class function UniqueItem: boolean; override;
Protected function GetSceneObject: TGLBaseSceneObject;
Public procedure Assign(Source: TPersistent); override;
Public procedure ClearPaths;
Public procedure DoProgress(const progressTime : TProgressTimes); override;
Public procedure StartPathTravel;
Public procedure StopPathTravel;
Protected procedure PathTravelStart(Sender: TObject);
Protected procedure PathTravelStop(Sender: TObject);
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property ActivePath: TGLMovementPath Read GetActivePath Write SetActivePath;
Published property ActivePathIndex: integer Read FActivePathIndex Write SetActivePathIndex;
Published property AutoStartNextPath: boolean Read FAutoStartNextPath Write FAutoStartNextPath;
Public property OnAllPathTravelledOver: TNotifyEvent Read FOnAllPathTravelledOver Write FOnAllPathTravelledOver;
Public property OnPathTravelStart: TPathTravelStartEvent Read FOnPathTravelStart Write FOnPathTravelStart;
Public property OnPathTravelStop: TPathTravelStopEvent Read FOnPathTravelStop Write FOnPathTravelStop;
Public property PathCount: integer Read GetPathCount;
Published property Paths: TGLMovementPaths Read FPaths;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultiMaterialShader

Unit GLMultiMaterialShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLMultiMaterialShader<p>

A shader that applies a render pass for each material in its assigned MaterialLibrary.<p>

<b>History : </b><font size=-1><ul> <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - Added more state to TGLStateCache <li>03/07/09 - DanB - bug fix to allow multi-pass materials to be used by TGLMultiMaterialShader <li>20/01/09 - Mrqzzz - Published property "Shaderstyle" (allows f.ex to have multiple textures using lightmaps) <li>25/10/07 - Mrqzzz - commented "glPushAttrib(GL_ALL_ATTRIB_BITS);" in DoApply and "glPopAttrib;" in DoUnapply, which seems to fix issues with other objects and materials in the scene.

<li>25/02/07 - DaStr - Moved registration to GLSceneRegister.pas <li>24/05/04 - Mrqzzz - Re-added design-time rendering option (seems stable now) <li>29/07/03 - SG - Removed design-time rendering option (shader unstable at design-time) <li>29/07/03 - SG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMultiMaterialShader |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultiMaterialShader: Class TGLMultiMaterialShader

Class TGLMultiMaterialShader

Unit

GLMultiMaterialShader

Declaration

type TGLMultiMaterialShader = class(TGLShader)

Description

no description available, TGLShader description follows

Generic, abstract shader class.<p> Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities.<br> Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLMultiMaterialShader

Overview

Methods

Public | constructor Create(aOwner : TComponent); override;
Protected | function DoUnApply(var rci : TRenderContextInfo) : Boolean; override;
Protected | procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure SetMaterialLibrary(const val : TGLMaterialLibrary);

Properties

Published | property MaterialLibrary : TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property ShaderStyle: TGLShaderStyle read FShaderStyle write SetShaderStyle;
Published | property VisibleAtDesignTime : boolean read FVisibleAtDesignTime write SetVisibleAtDesignTime;

Description

Methods

Public constructor Create(aOwner : TComponent); override;
Protected function DoUnApply(var rci : TRenderContextInfo) : Boolean; override;
Protected procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure SetMaterialLibrary(const val : TGLMaterialLibrary);

Properties

Published property MaterialLibrary : TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published property ShaderStyle: TGLShaderStyle read FShaderStyle write SetShaderStyle;
Published property VisibleAtDesignTime : boolean read FVisibleAtDesignTime write SetVisibleAtDesignTime;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultiPolygon

Unit GLMultiPolygon

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLContourNodes |
Class TGLContour |
Class TGLContours |
Class TPolygonList |
Class TMultiPolygonBase |
Class TGLMultiPolygon |

Types

TGLContourClass = class of TGLContour;

Description

Types

TGLContourClass = class of TGLContour;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultiPolygon: Class TGLContourNodes

Class TGLContourNodes

Unit

GLMultiPolygon

Declaration

type TGLContourNodes = class(TGLNodes)

Description

no description available, TGLNodes description follows

Hierarchy

  • TOwnedCollection
  • TGLNodes
  • TGLContourNodes

Overview

Methods

Public procedure NotifyChange; override;

Description

Methods

Public procedure NotifyChange; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultiPolygon: Class TGLContour

Class TGLContour

Unit

GLMultiPolygon

Declaration

type TGLContour = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLContour

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure CreateNodes; dynamic;
Protected | procedure NodesChanged(Sender: TObject);

Properties

Published | property Description: string read FDescription write SetDescription;
Published | property Division: Integer read FDivision write SetDivision default 10;
Published | property Nodes: TGLContourNodes read FNodes write SetNodes;
Published | property SplineMode: TLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;
Protected procedure CreateNodes; dynamic;
Protected procedure NodesChanged(Sender: TObject);

Properties

Published property Description: string read FDescription write SetDescription;
Published property Division: Integer read FDivision write SetDivision default 10;

Number of divisions for each segment in spline modes.<p> Minimum 1 (disabled), ignored in lsmLines mode.

Published property Nodes: TGLContourNodes read FNodes write SetNodes;

The nodes list.<p>

Published property SplineMode: TLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Default spline drawing mode.<p> This mode is used only for the curve, not for the rotation path.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultiPolygon: Class TGLContours

Class TGLContours

Unit

GLMultiPolygon

Declaration

type TGLContours = class(TNotifyCollection)

Description

no description available, TNotifyCollection description follows

Hierarchy

  • TOwnedCollection
  • TNotifyCollection
  • TGLContours

Overview

Methods

Public | constructor Create(AOwner: TComponent); overload;
Public | function Add: TGLContour;
Public | function FindItemID(ID: Integer): TGLContour;
Public | procedure GetExtents(var min, max: TAffineVector);

Properties

Public property Items[index: Integer]: TGLContour read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent); overload;
Public function Add: TGLContour;
Public function FindItemID(ID: Integer): TGLContour;
Public procedure GetExtents(var min, max: TAffineVector);

Properties

Public property Items[index: Integer]: TGLContour read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultiPolygon: Class TPolygonList

Class TPolygonList

Unit

GLMultiPolygon

Declaration

type TPolygonList = class(TPersistentObjectList)

Description

no description available, TPersistentObjectList description follows

A persistent Object list.<p> Similar to TList but works on TObject items and has facilities for persistence of contained data. Unlike the VCL's TObjectList, this one does NOT free its objects upon destruction or Clear, use Clean and CleanFree for that, and as such can be used for object referral lists too.<br> But only TPersistentObject items will be streamed appropriately.<p> The list can be used in a stack-like fashion with Push & Pop, and can perform basic boolean set operations.<p> Note: the IndexOf implementation is up to 3 times faster than that of TList

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TPolygonList

Overview

Methods

Public procedure Add;

Properties

Public | property AktList: TAffineVectorList read FAktList;
Public | property List[I: Integer]: TAffineVectorList read GetList;

Description

Methods

Public procedure Add;

Properties

Public property AktList: TAffineVectorList read FAktList;
Public property List[I: Integer]: TAffineVectorList read GetList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultiPolygon: Class TMultiPolygonBase

Class TMultiPolygonBase

Unit

GLMultiPolygon

Declaration

type TMultiPolygonBase = class(TGLSceneObject)

Description

Multipolygon is defined with multiple contours.<p> The contours have to be in the X-Y plane, otherwise they are projected to it (this is done automatically by the tesselator).<br> The plane normal is pointing in +Z. All contours are automatically closed, so there is no need to specify the last node equal to the first one.<br> Contours should be defined counterclockwise, the first contour (index = 0) is taken as is, all following are reversed. This means you can define the outer contour first and the holes and cutouts after that. If you give the following contours in clockwise order, the first contour is extended.<p>

TMultiPolygonBase will take the input contours and let the tesselator make an outline from it (this is done in RetreiveOutline). This outline is used for Rendering. Only when there are changes in the contours, the outline will be recalculated. The ouline in fact is a list of VectorLists.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TMultiPolygonBase

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | procedure AddNode(const i: Integer; const X, Y, Z: TGLfloat); overload;
Public | procedure AddNode(const i: Integer; const coords: TGLCoordinates); overload;
Public | procedure AddNode(const i: Integer; const value: TVector); overload;
Public | procedure AddNode(const i: Integer; const value: TAffineVector); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure StructureChanged; override;
Protected | procedure ContourChanged(Sender: TObject); virtual;
Protected | procedure RenderTesselatedPolygon(textured: Boolean; normal: PAffineVector; invertNormals: Boolean);
Protected | procedure RetrieveOutline(List: TPolygonList);

Properties

Published | property Contours: TGLContours read FContours write SetContours;
Public | property ContoursNormal: TAffineVector read FContoursNormal write SetContoursNormal;
Public | property Outline: TPolygonList read GetOutline;
Public | property Path[i: Integer]: TGLContourNodes read GetPath write SetPath;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public procedure AddNode(const i: Integer; const X, Y, Z: TGLfloat); overload;
Public procedure AddNode(const i: Integer; const coords: TGLCoordinates); overload;
Public procedure AddNode(const i: Integer; const value: TVector); overload;
Public procedure AddNode(const i: Integer; const value: TAffineVector); overload;
Public procedure Assign(Source: TPersistent); override;
Public procedure StructureChanged; override;
Protected procedure ContourChanged(Sender: TObject); virtual;
Protected procedure RenderTesselatedPolygon(textured: Boolean; normal: PAffineVector; invertNormals: Boolean);
Protected procedure RetrieveOutline(List: TPolygonList);

Properties

Published property Contours: TGLContours read FContours write SetContours;
Public property ContoursNormal: TAffineVector read FContoursNormal write SetContoursNormal;
Public property Outline: TPolygonList read GetOutline;
Public property Path[i: Integer]: TGLContourNodes read GetPath write SetPath;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultiPolygon: Class TGLMultiPolygon

Class TGLMultiPolygon

Unit

GLMultiPolygon

Declaration

type TGLMultiPolygon = class(TMultiPolygonBase)

Description

A polygon that can have holes and multiple contours.<p> Use the Path property to access a contour or one of the AddNode methods to add a node to a contour (contours are allocated automatically).

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TMultiPolygonBase
  • TGLMultiPolygon

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure SetParts(const value: TPolygonParts);

Properties

Published property Parts: TPolygonParts read FParts write SetParts default [ppTop, ppBottom];

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure SetParts(const value: TPolygonParts);

Properties

Published property Parts: TPolygonParts read FParts write SetParts default [ppTop, ppBottom];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultiProxy

Unit GLMultiProxy

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Implements a multi-proxy objects, useful for discreet LOD.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>19/12/06 - DaS - Fixed a bug in TGLMultiProxy.Destroy <li>26/11/03 - EG - Added bounding, raycast and silhouette proxying <li>25/11/03 - EG - Added per-master visibility boolean <li>24/11/03 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMultiProxyMaster |
Class TGLMultiProxyMasters |
Class TGLMultiProxy |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultiProxy: Class TGLMultiProxyMaster

Class TGLMultiProxyMaster

Unit

GLMultiProxy

Declaration

type TGLMultiProxyMaster = class(TCollectionItem)

Description

MasterObject description for a MultiProxy object.

Hierarchy

  • TCollectionItem
  • TGLMultiProxyMaster

Overview

Methods

Public | constructor Create(Collection : TCollection); override;
Public | destructor Destroy; override;
Public | function OwnerObject : TGLMultiProxy;
Protected | function GetDisplayName : String; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange;
Protected | procedure SetDistanceMax(const val : Single);
Protected | procedure SetDistanceMin(const val : Single);
Protected | procedure SetMasterObject(const val : TGLBaseSceneObject);
Protected | procedure SetVisible(const val : Boolean);

Properties

Published | property DistanceMax : Single read FDistanceMax write SetDistanceMax;
Published | property DistanceMin : Single read FDistanceMin write SetDistanceMin;
Published | property MasterObject : TGLBaseSceneObject read FMasterObject write SetMasterObject;
Published | property Visible : Boolean read FVisible write SetVisible default True;

Description

Methods

Public constructor Create(Collection : TCollection); override;
Public destructor Destroy; override;
Public function OwnerObject : TGLMultiProxy;
Protected function GetDisplayName : String; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure NotifyChange;
Protected procedure SetDistanceMax(const val : Single);
Protected procedure SetDistanceMin(const val : Single);
Protected procedure SetMasterObject(const val : TGLBaseSceneObject);
Protected procedure SetVisible(const val : Boolean);

Properties

Published property DistanceMax : Single read FDistanceMax write SetDistanceMax;

Maximum visibility distance (exclusive).

Published property DistanceMin : Single read FDistanceMin write SetDistanceMin;

Minimum visibility distance (inclusive).

Published property MasterObject : TGLBaseSceneObject read FMasterObject write SetMasterObject;

Specifies the Master object which will be proxy'ed.

Published property Visible : Boolean read FVisible write SetVisible default True;

Determines if the master object can be visible (proxy'ed).<p> Note: the master object's distance also has to be within DistanceMin and DistanceMax.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultiProxy: Class TGLMultiProxyMasters

Class TGLMultiProxyMasters

Unit

GLMultiProxy

Declaration

type TGLMultiProxyMasters = class(TOwnedCollection)

Description

Collection of TGLMultiProxyMaster.

Hierarchy

  • TOwnedCollection
  • TGLMultiProxyMasters

Overview

Methods

Public | constructor Create(AOwner : TPersistent);
Public | function Add : TGLMultiProxyMaster; overload;
Public | function Add(master : TGLBaseSceneObject; distanceMin, distanceMax : Single) : TGLMultiProxyMaster; overload;
Protected | function GetItems(index : Integer) : TGLMultiProxyMaster;
Public | procedure EndUpdate; override;
Public | procedure Notification(AComponent: TComponent);
Public | procedure NotifyChange;
Protected | procedure SetItems(index : Integer; const val : TGLMultiProxyMaster);
Protected | procedure Update(Item: TCollectionItem); override;

Properties

Public property Items[index : Integer]: TGLMultiProxyMaster read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner : TPersistent);
Public function Add : TGLMultiProxyMaster; overload;
Public function Add(master : TGLBaseSceneObject; distanceMin, distanceMax : Single) : TGLMultiProxyMaster; overload;
Protected function GetItems(index : Integer) : TGLMultiProxyMaster;
Public procedure EndUpdate; override;
Public procedure Notification(AComponent: TComponent);
Public procedure NotifyChange;
Protected procedure SetItems(index : Integer; const val : TGLMultiProxyMaster);
Protected procedure Update(Item: TCollectionItem); override;

Properties

Public property Items[index : Integer]: TGLMultiProxyMaster read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultiProxy: Class TGLMultiProxy

Class TGLMultiProxy

Unit

GLMultiProxy

Declaration

type TGLMultiProxy = class(TGLSceneObject)

Description

Multiple Proxy object.<p> This proxy has multiple master objects, which are individually made visible depending on a distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation.<p> For dimensionsn raycasting and silhouette purposes, the first master is used (item zero in the MasterObjects collection).

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLMultiProxy

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled : TVector; override;
Public | function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters) : TGLSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector : TVector; intersectPoint : PVector = nil; intersectNormal : PVector = nil) : Boolean; override;
Protected | function PrimaryMaster : TGLBaseSceneObject;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci : TRenderContextInfo; renderSelf, renderChildren : Boolean); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetMasterObjects(const val : TGLMultiProxyMasters);

Properties

Published | property Behaviours;
Published | property Direction;
Published | property MasterObjects : TGLMultiProxyMasters read FMasterObjects write SetMasterObjects;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property Visible;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensionsUnscaled : TVector; override;
Public function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters) : TGLSilhouette; override;
Public function RayCastIntersect(const rayStart, rayVector : TVector; intersectPoint : PVector = nil; intersectNormal : PVector = nil) : Boolean; override;
Protected function PrimaryMaster : TGLBaseSceneObject;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoRender(var rci : TRenderContextInfo; renderSelf, renderChildren : Boolean); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetMasterObjects(const val : TGLMultiProxyMasters);

Properties

Published property Behaviours;
Published property Direction;
Published property MasterObjects : TGLMultiProxyMasters read FMasterObjects write SetMasterObjects;
Published property ObjectsSorting;
Published property OnProgress;
Published property PitchAngle;
Published property Position;
Published property RollAngle;
Published property Scale;
Published property ShowAxes;
Published property TurnAngle;
Published property Up;
Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultisampleImage

Unit GLMultisampleImage

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLMultisampleImage<p>

This unit provides support for two new types of "multisample textures" - two-dimensional and two-dimensional array - as well as mechanisms to fetch a specific sample from such a texture in a shader, and to attach such textures to FBOs for rendering.

<b>History : </b><font size=-1><ul> <li>04/11/10- DaStr - Added $I GLScene.inc <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>16/05/10 - Yar - Creation (thanks to C4) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMultisampleImage |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLMultisampleImage: Class TGLMultisampleImage

Class TGLMultisampleImage

Unit

GLMultisampleImage

Declaration

type TGLMultisampleImage = class(TGLTextureImage)

Description

no description available, TGLTextureImage description follows

Base class for texture image data.<p> Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source).<br> SubClasses should be registered using RegisterGLTextureImageClass to allow proper persistence and editability in the IDE experts.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLMultisampleImage

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TGLBitmap32; override;
Public | class function IsSelfLoading: Boolean; override;
Protected | function GetDepth: Integer; override;
Protected | function GetHeight: Integer; override;
Protected | function GetTextureTarget: TGLTextureTarget; override;
Protected | function GetWidth: Integer; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure LoadTexture(AInternalFormat: TGLInternalFormat); override;
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;

Properties

Published | property Depth: Integer read GetDepth write SetDepth default 0;
Published | property FixedSamplesLocation: Boolean read FFixedSamplesLocation write SetFixedSamplesLocation;
Published | property Height: Integer read GetHeight write SetHeight default 256;
Public | property NativeTextureTarget;
Published | property SamplesCount: Integer read FSamplesCount write SetSamplesCount default 0;
Published | property Width: Integer read GetWidth write SetWidth default 256;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Public function GetBitmap32: TGLBitmap32; override;
Public class function IsSelfLoading: Boolean; override;
Protected function GetDepth: Integer; override;
Protected function GetHeight: Integer; override;
Protected function GetTextureTarget: TGLTextureTarget; override;
Protected function GetWidth: Integer; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadFromFile(const fileName: string); override;
Public procedure LoadTexture(AInternalFormat: TGLInternalFormat); override;
Public procedure ReleaseBitmap32; override;
Public procedure SaveToFile(const fileName: string); override;

Properties

Published property Depth: Integer read GetDepth write SetDepth default 0;
Published property FixedSamplesLocation: Boolean read FFixedSamplesLocation write SetFixedSamplesLocation;
Published property Height: Integer read GetHeight write SetHeight default 256;

Width of the blank image (for memory allocation).

Public property NativeTextureTarget;
Published property SamplesCount: Integer read FSamplesCount write SetSamplesCount default 0;
Published property Width: Integer read GetWidth write SetWidth default 256;

Width of the blank image (for memory allocation).

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLNavigator

Unit GLNavigator

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLNavigator<p>

Unit for navigating TGLBaseObjects.<p>

<b>History : </b><font size=-1><ul> <li>20/02/07 - DaStr - Moved Notification(), SetObject(), SetUseVirtualUp(), SetVirtualUp(), CalcRight() to the "protected" section Private "point1" renamed to FPrevPoint Updated comments TGLNavigator.SetObject made virtual <li>19/02/07 - DaStr - TGLNavigator.Create - FVirtualUp creation fixed Added default values to TGLNavigator and TGLUserInterface <li>29/01/07 - DaStr - Moved registration to GLSceneRegister.pas <li>08/03/06 - ur - Fixed warnigs for Delphi 2006 <li>31/10/05 - Mathx - Fixed bug 1340637 relating to freeNotifications on the TGLUserInterface component. <li>18/12/04 - PhP - Added FlyForward <li>03/07/04 - LR - Added GLShowCursor, GLSetCursorPos, GLGetCursorPos, GLGetScreenWidth, GLGetScreenHeight for Linux compatibility <li>11/05/04 - JAJ - Added some features and fixed a bug. <li>01/06/03 - JAJ - Added notification to movingobject... <li>01/06/03 - fig - CurrentHangle implementet... <li>14/07/02 - EG - InvertMouse (Joen A. Joensen) <li>18/03/02 - EG - Added MouseLookActive property, Fixed framerate dependency <li>15/03/02 - JAJ - Structure Change - Mouselook moved to newly created TGLUserInterface. <li>15/03/02 - RMCH - Added Mouselook capability. <li>09/11/00 - JAJ - First submitted. Base Class TGLNavigator included. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLNavigator |
Class TGLUserInterface |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLNavigator: Class TGLNavigator

Class TGLNavigator

Unit

GLNavigator

Declaration

type TGLNavigator = class(TComponent)

Description

TGLNavigator is the component for moving a TGLBaseSceneObject, and all Classes based on it, this includes all the objects from the Scene Editor.<p>

The four calls to get you started is <ul> <li>TurnHorisontal : it turns left and right. <li>TurnVertical : it turns up and down. <li>MoveForward : moves back and forth. <li>FlyForward : moves back and forth in the movingobject's direction </ul> The three properties to get you started is <ul> <li>MovingObject : The Object that you are moving. <li>UseVirtualUp : When UseVirtualUp is set you navigate Quake style. If it isn't it's more like Descent. <li>AngleLock : Allows you to block the Vertical angles. Should only be used in conjunction with UseVirtualUp. <li>MoveUpWhenMovingForward : Changes movement from Quake to Arcade Airplane... (no tilt and flying) <li>InvertHorizontalSteeringWhenUpsideDown : When using virtual up, and vertically rotating beyond 90 degrees, will make steering seem inverted, so we "invert" back to normal. </ul>

Hierarchy

  • TComponent
  • TGLNavigator

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function CalcRight: TVector;
Public | procedure FlyForward(Distance: single);
Public | procedure LoadState(Stream: TStream);
Public | procedure MoveForward(Distance: single);
Public | procedure SaveState(Stream: TStream);
Public | procedure StrafeHorizontal(Distance: single);
Public | procedure StrafeVertical(Distance: single);
Public | procedure Straighten;
Public | procedure TurnHorizontal(Angle: single);
Public | procedure TurnVertical(Angle: single);
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetObject(NewObject: TGLBaseSceneObject); virtual;
Protected | procedure SetUseVirtualUp(UseIt: boolean);
Protected | procedure SetVirtualUp(Up: TGLCoordinates);

Properties

Published | property AngleLock: boolean read FAngleLock write FAngleLock default False;
Published | property AutoUpdateObject: boolean read FAutoUpdateObject write FAutoUpdateObject default False;
Public | property CurrentHAngle: single read FCurrentHAngle;
Public | property CurrentVAngle: single read FCurrentVAngle;
Published | property InvertHorizontalSteeringWhenUpsideDown: boolean read FInvertHorizontalSteeringWhenUpsideDown write FInvertHorizontalSteeringWhenUpsideDown default False;
Published | property MaxAngle: single read FMaxAngle write FMaxAngle;
Published | property MinAngle: single read FMinAngle write FMinAngle;
Published | property MoveUpWhenMovingForward: boolean read FMoveUpWhenMovingForward write FMoveUpWhenMovingForward default False;
Published | property MovingObject: TGLBaseSceneObject read FObject write SetObject;
Published | property UseVirtualUp: boolean read FUseVirtualUp write SetUseVirtualUp default False;
Published | property VirtualUp: TGLCoordinates read FVirtualUp write SetVirtualUp;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function CalcRight: TVector;
Public procedure FlyForward(Distance: single);
Public procedure LoadState(Stream: TStream);
Public procedure MoveForward(Distance: single);
Public procedure SaveState(Stream: TStream);
Public procedure StrafeHorizontal(Distance: single);
Public procedure StrafeVertical(Distance: single);
Public procedure Straighten;
Public procedure TurnHorizontal(Angle: single);
Public procedure TurnVertical(Angle: single);
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetObject(NewObject: TGLBaseSceneObject); virtual;
Protected procedure SetUseVirtualUp(UseIt: boolean);
Protected procedure SetVirtualUp(Up: TGLCoordinates);

Properties

Published property AngleLock: boolean read FAngleLock write FAngleLock default False;
Published property AutoUpdateObject: boolean read FAutoUpdateObject write FAutoUpdateObject default False;
Public property CurrentHAngle: single read FCurrentHAngle;
Public property CurrentVAngle: single read FCurrentVAngle;
Published property InvertHorizontalSteeringWhenUpsideDown: boolean read FInvertHorizontalSteeringWhenUpsideDown write FInvertHorizontalSteeringWhenUpsideDown default False;
Published property MaxAngle: single read FMaxAngle write FMaxAngle;
Published property MinAngle: single read FMinAngle write FMinAngle;
Published property MoveUpWhenMovingForward: boolean read FMoveUpWhenMovingForward write FMoveUpWhenMovingForward default False;
Published property MovingObject: TGLBaseSceneObject read FObject write SetObject;
Published property UseVirtualUp: boolean read FUseVirtualUp write SetUseVirtualUp default False;
Published property VirtualUp: TGLCoordinates read FVirtualUp write SetVirtualUp;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLNavigator: Class TGLUserInterface

Class TGLUserInterface

Unit

GLNavigator

Declaration

type TGLUserInterface = class(TComponent)

Description

TGLUserInterface is the component which reads the userinput and transform it into action.<p>

The four calls to get you started is <ul> <li>MouseLookActivate : set us up the bomb. <li>MouseLookDeActivate : defuses it. <li>Mouselook(deltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works every where!) <li>MouseUpdate : Resets mouse position so that you don't notice that the mouse is limited to the screen should be called after Mouselook. </ul> The four properties to get you started are: <ul> <li>InvertMouse : Inverts the mouse Y axis. <li>MouseSpeed : Also known as mouse sensitivity. <li>GLNavigator : The Navigator which receives the user movement. <li>GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras.... </ul>

Hierarchy

  • TComponent
  • TGLUserInterface

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function IsMouseLookOn: Boolean;
Public | function MouseLook : Boolean;
Public | procedure MouseLookActivate;
Public | procedure MouseLookActiveToggle;
Public | procedure MouseLookDeactivate;
Public | procedure MouseUpdate;
Public | procedure TurnHorizontal(Angle : Double);
Public | procedure TurnVertical(Angle : Double);
Protected | procedure Notification(AComponent: TComponent; operation: TOperation); override;

Properties

Published | property GLNavigator: TGLNavigator read FGLNavigator write setNavigator;
Published | property GLVertNavigator: TGLNavigator read FGLVertNavigator write setVertNavigator;
Published | property InvertMouse: boolean read FInvertMouse write FInvertMouse default False;
Public | property MouseLookActive : Boolean read FMouseActive write SetMouseLookActive;
Published | property MouseSpeed: single read FMouseSpeed write FMouseSpeed;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function IsMouseLookOn: Boolean;
Public function MouseLook : Boolean;
Public procedure MouseLookActivate;
Public procedure MouseLookActiveToggle;
Public procedure MouseLookDeactivate;
Public procedure MouseUpdate;
Public procedure TurnHorizontal(Angle : Double);
Public procedure TurnVertical(Angle : Double);
Protected procedure Notification(AComponent: TComponent; operation: TOperation); override;

Properties

Published property GLNavigator: TGLNavigator read FGLNavigator write setNavigator;
Published property GLVertNavigator: TGLNavigator read FGLVertNavigator write setVertNavigator;
Published property InvertMouse: boolean read FInvertMouse write FInvertMouse default False;
Public property MouseLookActive : Boolean read FMouseActive write SetMouseLookActive;
Published property MouseSpeed: single read FMouseSpeed write FMouseSpeed;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLNewtonRegister

Unit GLNewtonRegister

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Functions and Procedures

procedure register;

Description

Functions and Procedures

procedure register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:31


GLScene v.1.1.2: GLNGDManager

Unit GLNGDManager

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record THeightField |
Class TGLNGDBehaviourList |
Class TNGDDebugOption |
Class TGLNGDManager |
Class TGLNGDBehaviour |
Class TGLNGDDynamic |
Class TGLNGDStatic |
Class TNGDSurfaceItem |
Class TNGDSurfacePair |
Class TNGDJointPivot |
Class TNGDJointPin |
Class TNGDJointPin2 |
Class TNGDJointBallAndSocket |
Class TNGDJointHinge |
Class TNGDJointSlider |
Class TNGDJointKinematicController |
Class TNGDJoint |

Functions and Procedures

function GetNGDStatic(Obj: TGLBaseSceneObject): TGLNGDStatic;
function GetOrCreateNGDStatic(Obj: TGLBaseSceneObject): TGLNGDStatic;
function GetNGDDynamic(Obj: TGLBaseSceneObject): TGLNGDDynamic;
function GetOrCreateNGDDynamic(Obj: TGLBaseSceneObject): TGLNGDDynamic;
function GetBodyFromGLSceneObject(Obj: TGLBaseSceneObject): PNewtonBody;

Types

NGDFloat = NewtonImport.Float;
PNGDFloat = ˆNGDFloat;
TNGDSolverModels = (...);
TNGDFrictionModels = (...);
TNGDPickedActions = (...);
TNGDManagerDebug = (...);
TNGDManagerDebugs = set of TNGDManagerDebug;
TNGDNewtonCollisions = (...);
TNGDNewtonJoints = (...);
TCollisionIteratorEvent = procedure(const userData: Pointer; vertexCount: Integer; const cfaceArray: PNGDFloat; faceId: Integer) of object;
TApplyForceAndTorqueEvent = procedure(const cbody: PNewtonBody; timestep: NGDFloat; threadIndex: Integer) of object;
TSetTransformEvent = procedure(const cbody: PNewtonBody; const cmatrix: PNGDFloat; threadIndex: Integer) of object;
TSerializeEvent = procedure(serializeHandle: Pointer; const cbuffer: Pointer; size: Cardinal) of object;
TDeSerializeEvent = procedure(serializeHandle: Pointer; buffer: Pointer; size: Cardinal) of object;
TAABBOverlapEvent = function(const cmaterial: PNewtonMaterial; const cbody0: PNewtonBody; const cbody1: PNewtonBody; threadIndex: Integer): Boolean of object;
TContactProcessEvent = procedure(const ccontact: PNewtonJoint; timestep: NGDFloat; threadIndex: Integer) of object;

Description

Functions and Procedures

function GetNGDStatic(Obj: TGLBaseSceneObject): TGLNGDStatic;
function GetOrCreateNGDStatic(Obj: TGLBaseSceneObject): TGLNGDStatic;
function GetNGDDynamic(Obj: TGLBaseSceneObject): TGLNGDDynamic;
function GetOrCreateNGDDynamic(Obj: TGLBaseSceneObject): TGLNGDDynamic;
function GetBodyFromGLSceneObject(Obj: TGLBaseSceneObject): PNewtonBody;

Types

NGDFloat = NewtonImport.Float;
PNGDFloat = ˆNGDFloat;
TNGDSolverModels = (...);
Values
  • smExact = 0:
  • smLinear1:
  • smLinear2:
  • smLinear3:
  • smLinear4:
  • smLinear5:
  • smLinear6:
  • smLinear7:
  • smLinear8:
  • smLinear9:
TNGDFrictionModels = (...);
Values
  • fmExact = 0:
  • fmAdaptive:
TNGDPickedActions = (...);
Values
  • paAttach = 0:
  • paMove:
  • paDetach:
TNGDManagerDebug = (...);
Values
  • mdShowGeometry:
  • mdShowAABB:
  • mdShowCenterOfMass:
  • mdShowContact:
  • mdShowJoint:
  • mdShowForce:
  • mdShowAppliedForce:
  • mdShowAppliedVelocity:
TNGDManagerDebugs = set of TNGDManagerDebug;
TNGDNewtonCollisions = (...);
Values
  • nc_Primitive = 0:
  • nc_Convex:
  • nc_BBox:
  • nc_BSphere:
  • nc_Tree:
  • nc_Mesh:
  • nc_Null:
  • nc_HeightField:
  • nc_NGDFile:
TNGDNewtonJoints = (...);
Values
  • nj_BallAndSocket:
  • nj_Hinge:
  • nj_Slider:
  • nj_Corkscrew:
  • nj_Universal:
  • nj_CustomBallAndSocket:
  • nj_CustomHinge:
  • nj_CustomSlider:
  • nj_UpVector:
  • nj_KinematicController:
TCollisionIteratorEvent = procedure(const userData: Pointer; vertexCount: Integer; const cfaceArray: PNGDFloat; faceId: Integer) of object;
TApplyForceAndTorqueEvent = procedure(const cbody: PNewtonBody; timestep: NGDFloat; threadIndex: Integer) of object;
TSetTransformEvent = procedure(const cbody: PNewtonBody; const cmatrix: PNGDFloat; threadIndex: Integer) of object;
TSerializeEvent = procedure(serializeHandle: Pointer; const cbuffer: Pointer; size: Cardinal) of object;
TDeSerializeEvent = procedure(serializeHandle: Pointer; buffer: Pointer; size: Cardinal) of object;
TAABBOverlapEvent = function(const cmaterial: PNewtonMaterial; const cbody0: PNewtonBody; const cbody1: PNewtonBody; threadIndex: Integer): Boolean of object;
TContactProcessEvent = procedure(const ccontact: PNewtonJoint; timestep: NGDFloat; threadIndex: Integer) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:32


GLScene v.1.1.2: GLNGDManager: record THeightField

record THeightField

Unit

GLNGDManager

Declaration

type THeightField = record

Description

Overview

Fields

heightArray: array of Word;
width: Integer;
depth: Integer;
gridDiagonals: Boolean;
widthDepthScale: Single;
heightScale: Single;

Description

Fields

heightArray: array of Word;
width: Integer;
depth: Integer;
gridDiagonals: Boolean;
widthDepthScale: Single;
heightScale: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:32


GLScene v.1.1.2: GLNGDManager: Class TGLNGDBehaviourList

Class TGLNGDBehaviourList

Unit

GLNGDManager

Declaration

type TGLNGDBehaviourList = class(TList)

Description

Hierarchy

  • TList
  • TGLNGDBehaviourList

Overview

Methods

Protected | function GetBehav(index: Integer): TGLNGDBehaviour;
Protected | procedure PutBehav(index: Integer; Item: TGLNGDBehaviour);

Properties

Public property ItemsBehav[index: Integer]: TGLNGDBehaviour read GetBehav write PutBehav;

Description

Methods

Protected function GetBehav(index: Integer): TGLNGDBehaviour;
Protected procedure PutBehav(index: Integer; Item: TGLNGDBehaviour);

Properties

Public property ItemsBehav[index: Integer]: TGLNGDBehaviour read GetBehav write PutBehav;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:32


GLScene v.1.1.2: GLNGDManager: Class TNGDDebugOption

Class TNGDDebugOption

Unit

GLNGDManager

Declaration

type TNGDDebugOption = class(TPersistent)

Description

Hierarchy

  • TPersistent
  • TNGDDebugOption

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | destructor Destroy; override;

Properties

Published | property AABBColor: TGLColor read FAABBColor write FAABBColor;
Published | property AABBColorSleep : TGLColor read FAABBColorSleep write FAABBColorSleep;
Published | property AppliedForceColor : TGLColor read FAppliedForceColor write FAppliedForceColor;
Published | property AppliedVelocityColor : TGLColor read FAppliedVelocityColor write FAppliedVelocityColor;
Published | property CenterOfMassColor : TGLColor read FCenterOfMassColor write FCenterOfMassColor;
Published | property ContactColor: TGLColor read FContactColor write FContactColor;
Published | property CustomColor: TGLColor read FCustomColor write FCustomColor;
Published | property DotAxisSize: Single read FDotAxisSize write SetDotAxisSize stored StoredDotAxis;
Published | property ForceColor: TGLColor read FForceColor write FForceColor;
Published | property GeomColorDyn: TGLColor read FGeomColorDyn write FGeomColorDyn;
Published | property GeomColorStat: TGLColor read FGeomColorStat write FGeomColorStat;
Published | property JointAxisColor : TGLColor read FJointAxisColor write FJointAxisColor;
Published | property JointPivotColor : TGLColor read FJointPivotColor write FJointPivotColor;
Published | property NGDManagerDebugs: TNGDManagerDebugs read FNGDManagerDebugs write SetNGDManagerDebugs default[];

Description

Methods

Public constructor Create(AOwner: TComponent);
Public destructor Destroy; override;

Properties

Published property AABBColor: TGLColor read FAABBColor write FAABBColor;
Published property AABBColorSleep : TGLColor read FAABBColorSleep write FAABBColorSleep;
Published property AppliedForceColor : TGLColor read FAppliedForceColor write FAppliedForceColor;
Published property AppliedVelocityColor : TGLColor read FAppliedVelocityColor write FAppliedVelocityColor;
Published property CenterOfMassColor : TGLColor read FCenterOfMassColor write FCenterOfMassColor;
Published property ContactColor: TGLColor read FContactColor write FContactColor;
Published property CustomColor: TGLColor read FCustomColor write FCustomColor;
Published property DotAxisSize: Single read FDotAxisSize write SetDotAxisSize stored StoredDotAxis;
Published property ForceColor: TGLColor read FForceColor write FForceColor;
Published property GeomColorDyn: TGLColor read FGeomColorDyn write FGeomColorDyn;
Published property GeomColorStat: TGLColor read FGeomColorStat write FGeomColorStat;
Published property JointAxisColor : TGLColor read FJointAxisColor write FJointAxisColor;
Published property JointPivotColor : TGLColor read FJointPivotColor write FJointPivotColor;
Published property NGDManagerDebugs: TNGDManagerDebugs read FNGDManagerDebugs write SetNGDManagerDebugs default[];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:32


GLScene v.1.1.2: GLNGDManager: Class TGLNGDManager

Class TGLNGDManager

Unit

GLNGDManager

Declaration

type TGLNGDManager = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLNGDManager

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function GetBodyCount: Integer;
Protected | function GetConstraintCount: Integer;
Public | procedure Step(deltatime: Single);
Protected | procedure AddNode(const coords: TGLCustomCoordinates); overload;
Protected | procedure AddNode(const Value: TAffineVector); overload;
Protected | procedure AddNode(const Value: TVector); overload;
Protected | procedure AddNode(const X, Y, Z: Single); overload;
Protected | procedure Loaded; override;
Protected | procedure NotifyChange(Sender: TObject);
Protected | procedure NotifyWorldSizeChange(Sender: TObject);
Protected | procedure RebuildAllJoint(Sender: TObject);
Protected | procedure RebuildAllMaterial;
Protected | procedure SetFrictionModel(const Value: TNGDFrictionModels);
Protected | procedure SetGLLines(const Value: TGLLines);
Protected | procedure SetMinimumFrameRate(const Value: Integer);
Protected | procedure SetSolverModel(const Value: TNGDSolverModels);
Protected | procedure SetThreadCount(const Value: Integer);
Protected | procedure SetVisible(const Value: Boolean);
Protected | procedure SetVisibleAtRunTime(const Value: Boolean);

Properties

Published | property DebugOption: TNGDDebugOption read FNGDDebugOption write FNGDDebugOption;
Published | property DllVersion: Integer read FDllVersion;
Published | property FrictionModel: TNGDFrictionModels read FFrictionModel write SetFrictionModel default fmExact;
Published | property Gravity: TGLCoordinates read FGravity write FGravity;
Published | property Line: TGLLines read FGLLines write SetGLLines;
Published | property MinimumFrameRate: Integer read FMinimumFrameRate write SetMinimumFrameRate default 60;
Published | property NewtonBodyCount: Integer read GetBodyCount;
Published | property NewtonConstraintCount: Integer read GetConstraintCount;
Published | property NewtonJoint: TOwnedCollection read FNewtonJointGroup write FNewtonJointGroup;
Published | property NewtonSurfaceItem : TCollection read FNewtonSurfaceItem write FNewtonSurfaceItem;
Published | property NewtonSurfacePair: TOwnedCollection read FNewtonSurfacePair write FNewtonSurfacePair;
Published | property SolverModel: TNGDSolverModels read FSolverModel write SetSolverModel default smExact;
Published | property ThreadCount : Integer read FThreadCount write SetThreadCount default 1;
Published | property Visible: Boolean read FVisible write SetVisible default True;
Published | property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;
Published | property WorldSizeMax : TGLCoordinates read FWorldSizeMax write FWorldSizeMax;
Published | property WorldSizeMin : TGLCoordinates read FWorldSizeMin write FWorldSizeMin;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function GetBodyCount: Integer;
Protected function GetConstraintCount: Integer;
Public procedure Step(deltatime: Single);
Protected procedure AddNode(const coords: TGLCustomCoordinates); overload;
Protected procedure AddNode(const Value: TAffineVector); overload;
Protected procedure AddNode(const Value: TVector); overload;
Protected procedure AddNode(const X, Y, Z: Single); overload;
Protected procedure Loaded; override;
Protected procedure NotifyChange(Sender: TObject);
Protected procedure NotifyWorldSizeChange(Sender: TObject);
Protected procedure RebuildAllJoint(Sender: TObject);
Protected procedure RebuildAllMaterial;
Protected procedure SetFrictionModel(const Value: TNGDFrictionModels);
Protected procedure SetGLLines(const Value: TGLLines);
Protected procedure SetMinimumFrameRate(const Value: Integer);
Protected procedure SetSolverModel(const Value: TNGDSolverModels);
Protected procedure SetThreadCount(const Value: Integer);
Protected procedure SetVisible(const Value: Boolean);
Protected procedure SetVisibleAtRunTime(const Value: Boolean);

Properties

Published property DebugOption: TNGDDebugOption read FNGDDebugOption write FNGDDebugOption;
Published property DllVersion: Integer read FDllVersion;
Published property FrictionModel: TNGDFrictionModels read FFrictionModel write SetFrictionModel default fmExact;
Published property Gravity: TGLCoordinates read FGravity write FGravity;
Published property Line: TGLLines read FGLLines write SetGLLines;
Published property MinimumFrameRate: Integer read FMinimumFrameRate write SetMinimumFrameRate default 60;
Published property NewtonBodyCount: Integer read GetBodyCount;
Published property NewtonConstraintCount: Integer read GetConstraintCount;
Published property NewtonJoint: TOwnedCollection read FNewtonJointGroup write FNewtonJointGroup;
Published property NewtonSurfaceItem : TCollection read FNewtonSurfaceItem write FNewtonSurfaceItem;
Published property NewtonSurfacePair: TOwnedCollection read FNewtonSurfacePair write FNewtonSurfacePair;
Published property SolverModel: TNGDSolverModels read FSolverModel write SetSolverModel default smExact;
Published property ThreadCount : Integer read FThreadCount write SetThreadCount default 1;
Published property Visible: Boolean read FVisible write SetVisible default True;
Published property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;
Published property WorldSizeMax : TGLCoordinates read FWorldSizeMax write FWorldSizeMax;
Published property WorldSizeMin : TGLCoordinates read FWorldSizeMin write FWorldSizeMin;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:32


GLScene v.1.1.2: GLNGDManager: Class TGLNGDBehaviour

Class TGLNGDBehaviour

Unit

GLNGDManager

Declaration

type TGLNGDBehaviour = class(TGLBehaviour)

Description

no description available, TGLBehaviour description follows

Ancestor for non-rendering behaviours.<p> This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLObjectEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLNGDBehaviour

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function UniqueItem: Boolean; override;
Protected | function GetBBoxCollision(): PNewtonCollision;
Protected | function GetBSphereCollision(): PNewtonCollision;
Protected | function GetConvexCollision(): PNewtonCollision;
Protected | function GetHeightFieldCollision(): PNewtonCollision;
Protected | function GetMeshCollision(): PNewtonCollision;
Protected | function GetNewtonBodyAABB: TAABB;
Protected | function GetNewtonBodyMatrix: TMatrix;
Protected | function GetNGDFileCollision(): PNewtonCollision;
Protected | function GetNullCollision(): PNewtonCollision;
Protected | function GetPrimitiveCollision(): PNewtonCollision;
Protected | function GetTreeCollision(): PNewtonCollision;
Protected | function StoredTolerance: Boolean;
Public | procedure DeSerialize(filename: string);
Public | procedure Reinitialize;
Public | procedure Serialize(filename: string);
Protected | procedure Finalize; virtual;
Protected | procedure Initialize; virtual;
Protected | procedure Loaded; override;
Protected | class procedure NewtonCollisionIterator(const userData: Pointer; vertexCount: Integer; const faceArray: PNGDFloat; faceId: Integer); static; cdecl;
Protected | class procedure NewtonDeserialize(serializeHandle: Pointer; buffer: Pointer; size: Cardinal); static; cdecl;
Protected | class procedure NewtonSerialize(serializeHandle: Pointer; const buffer: Pointer; size: Cardinal); static; cdecl;
Protected | procedure OnCollisionIteratorEvent(const userData: Pointer; vertexCount: Integer; const cfaceArray: PNGDFloat; faceId: Integer);
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure Render; virtual;
Protected | procedure SetContinuousCollisionMode(const Value: Boolean);
Protected | procedure SetHeightFieldOptions(const Value: THeightField);
Protected | procedure SetManager(Value: TGLNGDManager);
Protected | procedure SetNewtonBodyMatrix(const Value: TMatrix);
Protected | procedure SetNGDNewtonCollisions(const Value: TNGDNewtonCollisions);
Protected | procedure SetNGDSurfaceItem(const Value: TNGDSurfaceItem);
Protected | procedure UpdCollision; virtual;
Protected | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property ContinuousCollisionMode : Boolean read FContinuousCollisionMode write SetContinuousCollisionMode default False;
Published | property ConvexCollisionTolerance : Single read FConvexCollisionTolerance write FConvexCollisionTolerance stored StoredTolerance;
Published | property FileCollision: string read FFileCollision write FFileCollision;
Public | property HeightFieldOptions: THeightField read FHeightFieldOptions write SetHeightFieldOptions;
Public | property Initialized: Boolean read FInitialized;
Published | property Manager: TGLNGDManager read FManager write SetManager;
Public | property NewtonBodyAABB: TAABB read GetNewtonBodyAABB;
Public | property NewtonBodyMatrix: TMatrix read GetNewtonBodyMatrix write SetNewtonBodyMatrix;
Published | property NGDNewtonCollisions : TNGDNewtonCollisions read FNGDNewtonCollisions write SetNGDNewtonCollisions default nc_Primitive;
Published | property NGDSurfaceItem: TNGDSurfaceItem read FNGDSurfaceItem write SetNGDSurfaceItem;
Published | property TreeCollisionOptimize: Boolean read FTreeCollisionOptimize write FTreeCollisionOptimize default True;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function UniqueItem: Boolean; override;
Protected function GetBBoxCollision(): PNewtonCollision;
Protected function GetBSphereCollision(): PNewtonCollision;
Protected function GetConvexCollision(): PNewtonCollision;
Protected function GetHeightFieldCollision(): PNewtonCollision;
Protected function GetMeshCollision(): PNewtonCollision;
Protected function GetNewtonBodyAABB: TAABB;
Protected function GetNewtonBodyMatrix: TMatrix;
Protected function GetNGDFileCollision(): PNewtonCollision;
Protected function GetNullCollision(): PNewtonCollision;
Protected function GetPrimitiveCollision(): PNewtonCollision;
Protected function GetTreeCollision(): PNewtonCollision;
Protected function StoredTolerance: Boolean;
Public procedure DeSerialize(filename: string);
Public procedure Reinitialize;
Public procedure Serialize(filename: string);
Protected procedure Finalize; virtual;
Protected procedure Initialize; virtual;
Protected procedure Loaded; override;
Protected class procedure NewtonCollisionIterator(const userData: Pointer; vertexCount: Integer; const faceArray: PNGDFloat; faceId: Integer); static; cdecl;
Protected class procedure NewtonDeserialize(serializeHandle: Pointer; buffer: Pointer; size: Cardinal); static; cdecl;
Protected class procedure NewtonSerialize(serializeHandle: Pointer; const buffer: Pointer; size: Cardinal); static; cdecl;
Protected procedure OnCollisionIteratorEvent(const userData: Pointer; vertexCount: Integer; const cfaceArray: PNGDFloat; faceId: Integer);
Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure Render; virtual;
Protected procedure SetContinuousCollisionMode(const Value: Boolean);
Protected procedure SetHeightFieldOptions(const Value: THeightField);
Protected procedure SetManager(Value: TGLNGDManager);
Protected procedure SetNewtonBodyMatrix(const Value: TMatrix);
Protected procedure SetNGDNewtonCollisions(const Value: TNGDNewtonCollisions);
Protected procedure SetNGDSurfaceItem(const Value: TNGDSurfaceItem);
Protected procedure UpdCollision; virtual;
Protected procedure WriteToFiler(writer: TWriter); override;

Properties

Published property ContinuousCollisionMode : Boolean read FContinuousCollisionMode write SetContinuousCollisionMode default False;
Published property ConvexCollisionTolerance : Single read FConvexCollisionTolerance write FConvexCollisionTolerance stored StoredTolerance;
Published property FileCollision: string read FFileCollision write FFileCollision;
Public property HeightFieldOptions: THeightField read FHeightFieldOptions write SetHeightFieldOptions;
Public property Initialized: Boolean read FInitialized;
Published property Manager: TGLNGDManager read FManager write SetManager;
Public property NewtonBodyAABB: TAABB read GetNewtonBodyAABB;
Public property NewtonBodyMatrix: TMatrix read GetNewtonBodyMatrix write SetNewtonBodyMatrix;
Published property NGDNewtonCollisions : TNGDNewtonCollisions read FNGDNewtonCollisions write SetNGDNewtonCollisions default nc_Primitive;
Published property NGDSurfaceItem: TNGDSurfaceItem read FNGDSurfaceItem write SetNGDSurfaceItem;
Published property TreeCollisionOptimize: Boolean read FTreeCollisionOptimize write FTreeCollisionOptimize default True;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:32


GLScene v.1.1.2: GLNGDManager: Class TGLNGDDynamic

Class TGLNGDDynamic

Unit

GLNGDManager

Declaration

type TGLNGDDynamic = class(TGLNGDBehaviour)

Description

no description available, TGLNGDBehaviour description follows
no description available, TGLBehaviour description follows

Ancestor for non-rendering behaviours.<p> This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLObjectEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLNGDBehaviour
  • TGLNGDDynamic

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | function GetOmega: TVector;
Public | function GetVelocity: TVector;
Public | procedure AddImpulse(const veloc, pointposit: TVector);
Public | procedure SetOmega(const Omega: TVector);
Public | procedure SetVelocity(const Velocity: TVector);
Protected | procedure Finalize; override;
Protected | procedure Initialize; override;
Protected | procedure Loaded; override;
Protected | class procedure NewtonApplyForceAndTorque(const body: PNewtonBody; timestep: NGDFloat; threadIndex: Integer); static; cdecl;
Protected | class procedure NewtonSetTransform(const body: PNewtonBody; const matrix: PNGDFloat; threadIndex: Integer); static; cdecl;
Protected | procedure NotifyAngularDampingChange(Sender: TObject);
Protected | procedure NotifyCenterOfMassChange(Sender: TObject);
Protected | procedure OnApplyForceAndTorqueEvent(const cbody: PNewtonBody; timestep: NGDFloat; threadIndex: Integer);
Protected | procedure OnSetTransformEvent(const cbody: PNewtonBody; const cmatrix: PNGDFloat; threadIndex: Integer);
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure Render; override;
Protected | procedure SetAutoSleep(const Value: Boolean);
Protected | procedure SetDensity(const Value: Single); virtual;
Protected | procedure SetLinearDamping(const Value: Single);
Protected | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property AngularDamping : TGLCoordinates read FAngularDamping write FAngularDamping;
Published | property AppliedForce: TGLCoordinates read FAppliedForce;
Published | property AppliedOmega: TGLCoordinates read FAppliedOmega;
Published | property AppliedTorque: TGLCoordinates read FAppliedTorque;
Published | property AppliedVelocity: TGLCoordinates read FAppliedVelocity;
Published | property AutoSleep: Boolean read FAutoSleep write SetAutoSleep default True;
Published | property CenterOfMass : TGLCoordinates read FCenterOfMass write FCenterOfMass;
Public | property CustomForceAndTorqueEvent : TApplyForceAndTorqueEvent read FCustomForceAndTorqueEvent write FCustomForceAndTorqueEvent;
Published | property Density : Single read FDensity write SetDensity stored StoredDensity;
Published | property Force: TGLCoordinates read FForce write FForce;
Published | property LinearDamping : Single read FLinearDamping write SetLinearDamping stored StoredLinearDamping;
Published | property Mass: Single read FMass;
Published | property NullCollisionVolume : Single read FNullCollisionVolume write FNullCollisionVolume stored StoredNullCollisionVolume;
Published | property Omega: TVector read GetOmega write SetOmega;
Published | property Torque: TGLCoordinates read FTorque write FTorque;
Published | property UseGravity : Boolean read FUseGravity write FUseGravity default True;
Published | property Velocity: TVector read GetVelocity write SetVelocity;
Published | property Volume: Single read FVolume;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyName: string; override;
Public function GetOmega: TVector;
Public function GetVelocity: TVector;
Public procedure AddImpulse(const veloc, pointposit: TVector);
Public procedure SetOmega(const Omega: TVector);
Public procedure SetVelocity(const Velocity: TVector);
Protected procedure Finalize; override;
Protected procedure Initialize; override;
Protected procedure Loaded; override;
Protected class procedure NewtonApplyForceAndTorque(const body: PNewtonBody; timestep: NGDFloat; threadIndex: Integer); static; cdecl;
Protected class procedure NewtonSetTransform(const body: PNewtonBody; const matrix: PNGDFloat; threadIndex: Integer); static; cdecl;
Protected procedure NotifyAngularDampingChange(Sender: TObject);
Protected procedure NotifyCenterOfMassChange(Sender: TObject);
Protected procedure OnApplyForceAndTorqueEvent(const cbody: PNewtonBody; timestep: NGDFloat; threadIndex: Integer);
Protected procedure OnSetTransformEvent(const cbody: PNewtonBody; const cmatrix: PNGDFloat; threadIndex: Integer);
Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure Render; override;
Protected procedure SetAutoSleep(const Value: Boolean);
Protected procedure SetDensity(const Value: Single); virtual;
Protected procedure SetLinearDamping(const Value: Single);
Protected procedure WriteToFiler(writer: TWriter); override;

Properties

Published property AngularDamping : TGLCoordinates read FAngularDamping write FAngularDamping;
Published property AppliedForce: TGLCoordinates read FAppliedForce;
Published property AppliedOmega: TGLCoordinates read FAppliedOmega;
Published property AppliedTorque: TGLCoordinates read FAppliedTorque;
Published property AppliedVelocity: TGLCoordinates read FAppliedVelocity;
Published property AutoSleep: Boolean read FAutoSleep write SetAutoSleep default True;
Published property CenterOfMass : TGLCoordinates read FCenterOfMass write FCenterOfMass;
Public property CustomForceAndTorqueEvent : TApplyForceAndTorqueEvent read FCustomForceAndTorqueEvent write FCustomForceAndTorqueEvent;
Published property Density : Single read FDensity write SetDensity stored StoredDensity;
Published property Force: TGLCoordinates read FForce write FForce;
Published property LinearDamping : Single read FLinearDamping write SetLinearDamping stored StoredLinearDamping;
Published property Mass: Single read FMass;
Published property NullCollisionVolume : Single read FNullCollisionVolume write FNullCollisionVolume stored StoredNullCollisionVolume;
Published property Omega: TVector read GetOmega write SetOmega;
Published property Torque: TGLCoordinates read FTorque write FTorque;
Published property UseGravity : Boolean read FUseGravity write FUseGravity default True;
Published property Velocity: TVector read GetVelocity write SetVelocity;
Published property Volume: Single read FVolume;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:32


GLScene v.1.1.2: GLNGDManager: Class TGLNGDStatic

Class TGLNGDStatic

Unit

GLNGDManager

Declaration

type TGLNGDStatic = class(TGLNGDBehaviour)

Description

no description available, TGLNGDBehaviour description follows
no description available, TGLBehaviour description follows

Ancestor for non-rendering behaviours.<p> This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLObjectEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLNGDBehaviour
  • TGLNGDStatic

Overview

Methods

Public | class function FriendlyName: string; override;
Protected | procedure Render; override;

Description

Methods

Public class function FriendlyName: string; override;
Protected procedure Render; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:32


GLScene v.1.1.2: GLNGDManager: Class TNGDSurfaceItem

Class TNGDSurfaceItem

Unit

GLNGDManager

Declaration

type TNGDSurfaceItem = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TNGDSurfaceItem

Overview

Methods

Protected | function GetDisplayName: string; override;
Protected | procedure SetDisplayName(const Value: string); override;

Properties

Published | property DisplayName;
Published | property ID;

Description

Methods

Protected function GetDisplayName: string; override;
Protected procedure SetDisplayName(const Value: string); override;

Properties

Published property DisplayName;
Published property ID;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:32


GLScene v.1.1.2: GLNGDManager: Class TNGDSurfacePair

Class TNGDSurfacePair

Unit

GLNGDManager

Declaration

type TNGDSurfacePair = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TNGDSurfacePair

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | procedure SetMaterialItems(const item1, item2: TNGDSurfaceItem);

Properties

Published | property AABBOverlapEvent: TAABBOverlapEvent read FAABBOverlapEvent write FAABBOverlapEvent;
Published | property Collidable : Boolean read FCollidable write SetCollidable default True;
Published | property ContactProcessEvent : TContactProcessEvent read FContactProcessEvent write FContactProcessEvent;
Published | property ContinuousCollisionMode : Boolean read FContinuousCollisionMode write SetContinuousCollisionMode default False;
Published | property Elasticity: Single read FElasticity write SetElasticity stored StoredElasticity;
Published | property KineticFriction : Single read FKineticFriction write SetKineticFriction stored StoredKineticFriction;
Public | property NGDSurfaceItem1: TNGDSurfaceItem read FNGDSurfaceItem1;
Public | property NGDSurfaceItem2: TNGDSurfaceItem read FNGDSurfaceItem2;
Published | property Softness: Single read FSoftness write SetSoftness stored StoredSoftness;
Published | property StaticFriction : Single read FStaticFriction write SetStaticFriction stored StoredStaticFriction;
Published | property Thickness : Boolean read FThickness write SetThickness default False;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public procedure SetMaterialItems(const item1, item2: TNGDSurfaceItem);

Properties

Published property AABBOverlapEvent: TAABBOverlapEvent read FAABBOverlapEvent write FAABBOverlapEvent;
Published property Collidable : Boolean read FCollidable write SetCollidable default True;
Published property ContactProcessEvent : TContactProcessEvent read FContactProcessEvent write FContactProcessEvent;
Published property ContinuousCollisionMode : Boolean read FContinuousCollisionMode write SetContinuousCollisionMode default False;
Published property Elasticity: Single read FElasticity write SetElasticity stored StoredElasticity;
Published property KineticFriction : Single read FKineticFriction write SetKineticFriction stored StoredKineticFriction;
Public property NGDSurfaceItem1: TNGDSurfaceItem read FNGDSurfaceItem1;
Public property NGDSurfaceItem2: TNGDSurfaceItem read FNGDSurfaceItem2;
Published property Softness: Single read FSoftness write SetSoftness stored StoredSoftness;
Published property StaticFriction : Single read FStaticFriction write SetStaticFriction stored StoredStaticFriction;
Published property Thickness : Boolean read FThickness write SetThickness default False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLNGDManager: Class TNGDJointPivot

Class TNGDJointPivot

Unit

GLNGDManager

Declaration

type TNGDJointPivot = class(TPersistent)

Description

Hierarchy

  • TPersistent
  • TNGDJointPivot

Overview

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TNGDJoint); virtual;
Public | destructor Destroy; override;

Properties

Published property PivotPoint: TGLCoordinates read FPivotPoint write FPivotPoint;

Description

Methods

Public constructor Create(AOwner: TComponent; aOuter: TNGDJoint); virtual;
Public destructor Destroy; override;

Properties

Published property PivotPoint: TGLCoordinates read FPivotPoint write FPivotPoint;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLNGDManager: Class TNGDJointPin

Class TNGDJointPin

Unit

GLNGDManager

Declaration

type TNGDJointPin = class(TNGDJointPivot)

Description

no description available, TNGDJointPivot description follows

Hierarchy

  • TPersistent
  • TNGDJointPivot
  • TNGDJointPin

Overview

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TNGDJoint); override;
Public | destructor Destroy; override;

Properties

Published property PinDirection : TGLCoordinates read FPinDirection write FPinDirection;

Description

Methods

Public constructor Create(AOwner: TComponent; aOuter: TNGDJoint); override;
Public destructor Destroy; override;

Properties

Published property PinDirection : TGLCoordinates read FPinDirection write FPinDirection;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLNGDManager: Class TNGDJointPin2

Class TNGDJointPin2

Unit

GLNGDManager

Declaration

type TNGDJointPin2 = class(TNGDJointPin)

Description

no description available, TNGDJointPin description follows
no description available, TNGDJointPivot description follows

Hierarchy

  • TPersistent
  • TNGDJointPivot
  • TNGDJointPin
  • TNGDJointPin2

Overview

Methods

Public | constructor Create(AOwner: TComponent; aOuter: TNGDJoint); override;
Public | destructor Destroy; override;

Properties

Published property PinDirection2 : TGLCoordinates read FPinDirection2 write FPinDirection2;

Description

Methods

Public constructor Create(AOwner: TComponent; aOuter: TNGDJoint); override;
Public destructor Destroy; override;

Properties

Published property PinDirection2 : TGLCoordinates read FPinDirection2 write FPinDirection2;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLNGDManager: Class TNGDJointBallAndSocket

Class TNGDJointBallAndSocket

Unit

GLNGDManager

Declaration

type TNGDJointBallAndSocket = class(TNGDJointPivot)

Description

no description available, TNGDJointPivot description follows

Hierarchy

  • TPersistent
  • TNGDJointPivot
  • TNGDJointBallAndSocket

Overview

Methods

Public constructor Create(AOwner: TComponent; aOuter: TNGDJoint); override;

Properties

Published | property ConeAngle: Single read FConeAngle write SetConeAngle stored StoredConeAngle;
Published | property MaxTwistAngle : Single read FMaxTwistAngle write SetMaxTwistAngle stored StoredMaxTwistAngle;
Published | property MinTwistAngle : Single read FMinTwistAngle write SetMinTwistAngle stored StoredMinTwistAngle;

Description

Methods

Public constructor Create(AOwner: TComponent; aOuter: TNGDJoint); override;

Properties

Published property ConeAngle: Single read FConeAngle write SetConeAngle stored StoredConeAngle;
Published property MaxTwistAngle : Single read FMaxTwistAngle write SetMaxTwistAngle stored StoredMaxTwistAngle;
Published property MinTwistAngle : Single read FMinTwistAngle write SetMinTwistAngle stored StoredMinTwistAngle;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLNGDManager: Class TNGDJointHinge

Class TNGDJointHinge

Unit

GLNGDManager

Declaration

type TNGDJointHinge = class(TNGDJointPin)

Description

no description available, TNGDJointPin description follows
no description available, TNGDJointPivot description follows

Hierarchy

  • TPersistent
  • TNGDJointPivot
  • TNGDJointPin
  • TNGDJointHinge

Overview

Methods

Public constructor Create(AOwner: TComponent; aOuter: TNGDJoint); override;

Properties

Published | property MaxAngle: Single read FMaxAngle write SetMaxAngle stored StoredMaxAngle;
Published | property MinAngle: Single read FMinAngle write SetMinAngle stored StoredMinAngle;

Description

Methods

Public constructor Create(AOwner: TComponent; aOuter: TNGDJoint); override;

Properties

Published property MaxAngle: Single read FMaxAngle write SetMaxAngle stored StoredMaxAngle;
Published property MinAngle: Single read FMinAngle write SetMinAngle stored StoredMinAngle;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLNGDManager: Class TNGDJointSlider

Class TNGDJointSlider

Unit

GLNGDManager

Declaration

type TNGDJointSlider = class(TNGDJointPin)

Description

no description available, TNGDJointPin description follows
no description available, TNGDJointPivot description follows

Hierarchy

  • TPersistent
  • TNGDJointPivot
  • TNGDJointPin
  • TNGDJointSlider

Overview

Methods

Public constructor Create(AOwner: TComponent; aOuter: TNGDJoint); override;

Properties

Published | property MaxDistance: Single read FMaxDistance write SetMaxDistance stored StoredMaxDistance;
Published | property MinDistance: Single read FMinDistance write SetMinDistance stored StoredMinDistance;

Description

Methods

Public constructor Create(AOwner: TComponent; aOuter: TNGDJoint); override;

Properties

Published property MaxDistance: Single read FMaxDistance write SetMaxDistance stored StoredMaxDistance;
Published property MinDistance: Single read FMinDistance write SetMinDistance stored StoredMinDistance;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLNGDManager: Class TNGDJointKinematicController

Class TNGDJointKinematicController

Unit

GLNGDManager

Declaration

type TNGDJointKinematicController = class(TPersistent)

Description

Hierarchy

  • TPersistent
  • TNGDJointKinematicController

Overview

Methods

Public constructor Create();

Properties

Published | property AngularFriction : Single read FAngularFriction write FAngularFriction stored StoredAngularFriction;
Published | property LinearFriction : Single read FLinearFriction write FLinearFriction stored StoredLinearFriction;
Published | property PickModeLinear : Boolean read FPickModeLinear write FPickModeLinear default False;

Description

Methods

Public constructor Create();

Properties

Published property AngularFriction : Single read FAngularFriction write FAngularFriction stored StoredAngularFriction;
Published property LinearFriction : Single read FLinearFriction write FLinearFriction stored StoredLinearFriction;
Published property PickModeLinear : Boolean read FPickModeLinear write FPickModeLinear default False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLNGDManager: Class TNGDJoint

Class TNGDJoint

Unit

GLNGDManager

Declaration

type TNGDJoint = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TNGDJoint

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | procedure KinematicControllerPick(pickpoint: TVector; PickedActions: TNGDPickedActions);

Properties

Published | property BallAndSocketOptions : TNGDJointPivot read FBallAndSocketOptions write FBallAndSocketOptions;
Published | property ChildObject: TGLBaseSceneObject read FChildObject write SetChildObject;
Published | property CollisionState : Boolean read FCollisionState write SetCollisionState default False;
Published | property CorkscrewOptions : TNGDJointPin read FCorkscrewOptions write FCorkscrewOptions;
Published | property CustomBallAndSocketOptions : TNGDJointBallAndSocket read FCustomBallAndSocketOptions write FCustomBallAndSocketOptions;
Published | property CustomHingeOptions: TNGDJointHinge read FCustomHingeOptions write FCustomHingeOptions;
Published | property CustomSliderOptions : TNGDJointSlider read FCustomSliderOptions write FCustomSliderOptions;
Published | property HingeOptions: TNGDJointPin read FHingeOptions write FHingeOptions;
Published | property JointType: TNGDNewtonJoints read FJointType write SetJointType;
Published | property KinematicControllerOptions : TNGDJointKinematicController read FKinematicOptions write FKinematicOptions;
Published | property ParentObject: TGLBaseSceneObject read FParentObject write SetParentObject;
Published | property SliderOptions : TNGDJointPin read FSliderOptions write FSliderOptions;
Published | property Stiffness: Single read FStiffness write SetStiffness stored StoredStiffness;
Published | property UniversalOptions : TNGDJointPin2 read FUniversalOptions write FUniversalOptions;
Published | property UPVectorDirection : TGLCoordinates read FUPVectorDirection write FUPVectorDirection;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Public procedure KinematicControllerPick(pickpoint: TVector; PickedActions: TNGDPickedActions);

Properties

Published property BallAndSocketOptions : TNGDJointPivot read FBallAndSocketOptions write FBallAndSocketOptions;
Published property ChildObject: TGLBaseSceneObject read FChildObject write SetChildObject;
Published property CollisionState : Boolean read FCollisionState write SetCollisionState default False;
Published property CorkscrewOptions : TNGDJointPin read FCorkscrewOptions write FCorkscrewOptions;
Published property CustomBallAndSocketOptions : TNGDJointBallAndSocket read FCustomBallAndSocketOptions write FCustomBallAndSocketOptions;
Published property CustomHingeOptions: TNGDJointHinge read FCustomHingeOptions write FCustomHingeOptions;
Published property CustomSliderOptions : TNGDJointSlider read FCustomSliderOptions write FCustomSliderOptions;
Published property HingeOptions: TNGDJointPin read FHingeOptions write FHingeOptions;
Published property JointType: TNGDNewtonJoints read FJointType write SetJointType;
Published property KinematicControllerOptions : TNGDJointKinematicController read FKinematicOptions write FKinematicOptions;
Published property ParentObject: TGLBaseSceneObject read FParentObject write SetParentObject;
Published property SliderOptions : TNGDJointPin read FSliderOptions write FSliderOptions;
Published property Stiffness: Single read FStiffness write SetStiffness stored StoredStiffness;
Published property UniversalOptions : TNGDJointPin2 read FUniversalOptions write FUniversalOptions;
Published property UPVectorDirection : TGLCoordinates read FUPVectorDirection write FUPVectorDirection;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLNodes

Unit GLNodes

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLNode |
Class TGLNodes |

Types

TGLNodesClass = class of TGLNodes;

Description

Types

TGLNodesClass = class of TGLNodes;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLNodes: Class TGLNode

Class TGLNode

Unit

GLNodes

Declaration

type TGLNode = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLNode

Overview

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | function AsAddress: PGLFloat;
Protected | function GetDisplayName: string; override;
Protected | function StoreCoordinate(AIndex: Integer): Boolean;
Public | procedure Assign(Source: TPersistent); override;

Properties

Public | property AsAffineVector: TAffineVector read GetAsAffineVector write SetAsAffineVector;
Public | property AsVector: TVector read FCoords write SetAsVector;
Public | property TagObject: TObject read FTagObject write FTagObject;
Public | property W: TGLFloat index 3 read GetCoordinate write SetCoordinate stored StoreCoordinate;
Published | property X: TGLFloat index 0 read GetCoordinate write SetCoordinate stored StoreCoordinate;
Published | property Y: TGLFloat index 1 read GetCoordinate write SetCoordinate stored StoreCoordinate;
Published | property Z: TGLFloat index 2 read GetCoordinate write SetCoordinate stored StoreCoordinate;

Description

Methods

Public constructor Create(ACollection: TCollection); override;
Public destructor Destroy; override;
Public function AsAddress: PGLFloat;
Protected function GetDisplayName: string; override;
Protected function StoreCoordinate(AIndex: Integer): Boolean;
Public procedure Assign(Source: TPersistent); override;

Properties

Public property AsAffineVector: TAffineVector read GetAsAffineVector write SetAsAffineVector;
Public property AsVector: TVector read FCoords write SetAsVector;
Public property TagObject: TObject read FTagObject write FTagObject;
Public property W: TGLFloat index 3 read GetCoordinate write SetCoordinate stored StoreCoordinate;
Published property X: TGLFloat index 0 read GetCoordinate write SetCoordinate stored StoreCoordinate;
Published property Y: TGLFloat index 1 read GetCoordinate write SetCoordinate stored StoreCoordinate;
Published property Z: TGLFloat index 2 read GetCoordinate write SetCoordinate stored StoreCoordinate;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLNodes: Class TGLNodes

Class TGLNodes

Unit

GLNodes

Declaration

type TGLNodes = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLNodes

Overview

Methods

Public | constructor Create(AOwner: TPersistent; AItemClass: TCollectionItemClass = nil);
Public | function Add: TGLNode;
Public | function Barycenter: TAffineVector;
Public | function CreateCopy(AOwner: TPersistent): TGLNodes;
Public | function CreateNewCubicSpline: TCubicSpline;
Public | function FindItemID(ID: Integer): TGLNode;
Public | function First: TGLNode;
Public | function Last: TGLNode;
Public | function Normal: TAffineVector;
Public | function Vector(I: Integer): TAffineVector;
Protected | function GetItems(Index: Integer): TGLNode;
Public | procedure AddNode(const Value: TVector); overload;
Public | procedure AddNode(const Value: TAffineVector); overload;
Public | procedure AddNode(const Coords: TGLCustomCoordinates); overload;
Public | procedure AddNode(const X, Y, Z: TGLfloat); overload;
Public | procedure AddXYArc(XRadius, YRadius: Single; StartAngle, StopAngle: Single; NbSegments: Integer; const Center: TAffineVector);
Public | procedure EndUpdate; override;
Public | procedure GetExtents(var Min, Max: TAffineVector);
Public | procedure NotifyChange; virtual;
Public | procedure RenderTesselatedPolygon(ATextured: Boolean; ANormal: PAffineVector = nil; ASplineDivisions: Integer = 1; AInvertNormals: Boolean = False);
Public | procedure RotateAroundX(Angle: Single);
Public | procedure RotateAroundY(Angle: Single);
Public | procedure RotateAroundZ(Angle: Single);
Public | procedure Scale(const Fv: TAffineVector); overload;
Public | procedure Scale(F: Single); overload;
Public | procedure Translate(const Tv: TAffineVector);
Protected | procedure SetItems(Index: Integer; const Val: TGLNode);
Protected | procedure Update(Item: TCollectionItem); override;

Properties

Public property Items[index: Integer]: TGLNode read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent; AItemClass: TCollectionItemClass = nil);
Public function Add: TGLNode;
Public function Barycenter: TAffineVector;
Public function CreateCopy(AOwner: TPersistent): TGLNodes;
Public function CreateNewCubicSpline: TCubicSpline;
Public function FindItemID(ID: Integer): TGLNode;
Public function First: TGLNode;
Public function Last: TGLNode;
Public function Normal: TAffineVector;
Public function Vector(I: Integer): TAffineVector;
Protected function GetItems(Index: Integer): TGLNode;
Public procedure AddNode(const Value: TVector); overload;
Public procedure AddNode(const Value: TAffineVector); overload;
Public procedure AddNode(const Coords: TGLCustomCoordinates); overload;
Public procedure AddNode(const X, Y, Z: TGLfloat); overload;
Public procedure AddXYArc(XRadius, YRadius: Single; StartAngle, StopAngle: Single; NbSegments: Integer; const Center: TAffineVector);
Public procedure EndUpdate; override;
Public procedure GetExtents(var Min, Max: TAffineVector);
Public procedure NotifyChange; virtual;
Public procedure RenderTesselatedPolygon(ATextured: Boolean; ANormal: PAffineVector = nil; ASplineDivisions: Integer = 1; AInvertNormals: Boolean = False);
Public procedure RotateAroundX(Angle: Single);
Public procedure RotateAroundY(Angle: Single);
Public procedure RotateAroundZ(Angle: Single);
Public procedure Scale(const Fv: TAffineVector); overload;
Public procedure Scale(F: Single); overload;
Public procedure Translate(const Tv: TAffineVector);
Protected procedure SetItems(Index: Integer; const Val: TGLNode);
Protected procedure Update(Item: TCollectionItem); override;

Properties

Public property Items[index: Integer]: TGLNode read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLObjectManager

Unit GLObjectManager

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLObjectManager<p>

The object manager is used for registering classes together with a category, description + icon, so that they can be displayed visually. This can then be used by run-time or design-time scene editors for choosing which scene objects to place into a scene.<p>

TODO: add some notification code, so that when a scene object is registered/ unregistered, any editor that is using the object manager can be notified.

<b>History : </b><font size=-1><ul> <li>11/11/09 - DaStr - Improved FPC compatibility (thanks Predator) (BugtrackerID = 2893580) <li>25/07/09 - DaStr - Added $I GLScene.inc <li>26/03/09 - DanB - Added PopulateMenuWithRegisteredSceneObjects procedure. <li>14/03/09 - DanB - Created by moving TObjectManager in from GLSceneRegister.pas, made some slight adjustments to allow resources being loaded from separate packages. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TGLSceneObjectEntry |
Class TObjectManager |

Types

PSceneObjectEntry = ˆTGLSceneObjectEntry;

Description

Types

PSceneObjectEntry = ˆTGLSceneObjectEntry;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLObjectManager: record TGLSceneObjectEntry

record TGLSceneObjectEntry

Unit

GLObjectManager

Declaration

type TGLSceneObjectEntry = record

Description

Overview

Fields

ObjectClass: TGLSceneObjectClass;
Name: string;
Category: string;
Index: Integer;
ImageIndex: Integer;

Description

Fields

ObjectClass: TGLSceneObjectClass;
Name: string;
Category: string;
Index: Integer;
ImageIndex: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLObjectManager: Class TObjectManager

Class TObjectManager

Unit

GLObjectManager

Declaration

type TObjectManager = class(TComponent)

Description

Hierarchy

  • TComponent
  • TObjectManager

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetCategory(ASceneObject: TGLSceneObjectClass): string;
Public | function GetClassFromIndex(Index: Integer): TGLSceneObjectClass;
Public | function GetImageIndex(ASceneObject: TGLSceneObjectClass): Integer;
Protected | function FindSceneObjectClass(AObjectClass: TGLSceneObjectClass; const ASceneObject: string = ''): PSceneObjectEntry;
Public | procedure CreateDefaultObjectIcons;
Public | procedure GetRegisteredSceneObjects(ObjectList: TStringList);
Public | procedure PopulateMenuWithRegisteredSceneObjects(AMenuItem: TMenuItem; aClickEvent: TNotifyEvent);
Public | procedure RegisterSceneObject(ASceneObject: TGLSceneObjectClass; const aName, aCategory: string; ResourceModule: Cardinal; ResourceName: string = ''); overload;
Public | procedure UnRegisterSceneObject(ASceneObject: TGLSceneObjectClass);
Protected | procedure DestroySceneObjectList;

Properties

Public | property CameraRootIndex: Integer read FCameraRootIndex;
Public | property LightsourceRootIndex: Integer read FLightsourceRootIndex;
Public | property ObjectIcons: TImageList read FObjectIcons;
Public | property ObjectRootIndex: Integer read FObjectRootIndex;
Public | property SceneRootIndex: Integer read FSceneRootIndex;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function GetCategory(ASceneObject: TGLSceneObjectClass): string;
Public function GetClassFromIndex(Index: Integer): TGLSceneObjectClass;
Public function GetImageIndex(ASceneObject: TGLSceneObjectClass): Integer;
Protected function FindSceneObjectClass(AObjectClass: TGLSceneObjectClass; const ASceneObject: string = ''): PSceneObjectEntry;
Public procedure CreateDefaultObjectIcons;
Public procedure GetRegisteredSceneObjects(ObjectList: TStringList);
Public procedure PopulateMenuWithRegisteredSceneObjects(AMenuItem: TMenuItem; aClickEvent: TNotifyEvent);
Public procedure RegisterSceneObject(ASceneObject: TGLSceneObjectClass; const aName, aCategory: string; ResourceModule: Cardinal; ResourceName: string = ''); overload;

Registers a stock object and adds it to the stock object list

Public procedure UnRegisterSceneObject(ASceneObject: TGLSceneObjectClass);

Unregisters a stock object and removes it from the stock object list

Protected procedure DestroySceneObjectList;

Properties

Public property CameraRootIndex: Integer read FCameraRootIndex;
Public property LightsourceRootIndex: Integer read FLightsourceRootIndex;
Public property ObjectIcons: TImageList read FObjectIcons;
Public property ObjectRootIndex: Integer read FObjectRootIndex;
Public property SceneRootIndex: Integer read FSceneRootIndex;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLObjects

Unit GLObjects

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TVertexRec |
Class TGLDummyCube |
Class TGLPlane |
Class TGLSprite |
Class TGLPointParameters |
Class TGLPoints |
Class TGLLinesNode |
Class TGLLinesNodes |
Class TGLLineBase |
Class TGLNodedLines |
Class TGLLines |
Class TGLCube |
Class TGLQuadricObject |
Class TGLSphere |
Class TGLPolygonBase |

Functions and Procedures

procedure CubeWireframeBuildList(var rci: TRenderContextInfo; size: TGLFloat; stipple: Boolean; const Color: TColorVector);
procedure DodecahedronBuildList;
procedure IcosahedronBuildList;

Types

TGLVisibilityDeterminationEvent = function(Sender: TObject; var rci: TRenderContextInfo): Boolean of object;
PVertexRec = ˆTVertexRec;
TPlaneStyle = (...);
TPlaneStyles = set of TPlaneStyle;
TGLPointStyle = (...);
TLineNodesAspect = (...);
TLineSplineMode = (...);
TLinesOption = (...);
TLinesOptions = set of TLinesOption;
TCubePart = (...);
TCubeParts = set of TCubePart;
TNormalSmoothing = (...);
TAngleLimit1 = -90 .. 90;
TAngleLimit2 = 0 .. 360;
TCapType = (...);

Variables

TangentAttributeName: AnsiString = 'Tangent';
BinormalAttributeName: AnsiString = 'Binormal';

Description

Functions and Procedures

procedure CubeWireframeBuildList(var rci: TRenderContextInfo; size: TGLFloat; stipple: Boolean; const Color: TColorVector);
procedure DodecahedronBuildList;
procedure IcosahedronBuildList;

Types

TGLVisibilityDeterminationEvent = function(Sender: TObject; var rci: TRenderContextInfo): Boolean of object;
PVertexRec = ˆTVertexRec;
TPlaneStyle = (...);
Values
  • psSingleQuad:
  • psTileTexture:
TPlaneStyles = set of TPlaneStyle;
TGLPointStyle = (...);
Values
  • psSquare:
  • psRound:
  • psSmooth:
  • psSmoothAdditive:
  • psSquareAdditive:
TLineNodesAspect = (...);
Values
  • lnaInvisible:
  • lnaAxes:
  • lnaCube:
  • lnaDodecahedron:
TLineSplineMode = (...);
Values
  • lsmLines:
  • lsmCubicSpline:
  • lsmBezierSpline:
  • lsmNURBSCurve:
  • lsmSegments:
  • lsmLoop:
TLinesOption = (...);
Values
  • loUseNodeColorForLines:
  • loColorLogicXor:
TLinesOptions = set of TLinesOption;
TCubePart = (...);
Values
  • cpTop:
  • cpBottom:
  • cpFront:
  • cpBack:
  • cpLeft:
  • cpRight:
TCubeParts = set of TCubePart;
TNormalSmoothing = (...);
Values
  • nsFlat:
  • nsSmooth:
  • nsNone:
TAngleLimit1 = -90 .. 90;
TAngleLimit2 = 0 .. 360;
TCapType = (...);
Values
  • ctNone:
  • ctCenter:
  • ctFlat:

Variables

TangentAttributeName: AnsiString = 'Tangent';
BinormalAttributeName: AnsiString = 'Binormal';
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLObjects: record TVertexRec

record TVertexRec

Unit

GLObjects

Declaration

type TVertexRec = record

Description

Overview

Fields

Position: TVector3f;
Normal: TVector3f;
Binormal: TVector3f;
Tangent: TVector3f;
TexCoord: TVector2f;

Description

Fields

Position: TVector3f;
Normal: TVector3f;
Binormal: TVector3f;
Tangent: TVector3f;
TexCoord: TVector2f;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLObjects: Class TGLDummyCube

Class TGLDummyCube

Unit

GLObjects

Declaration

type TGLDummyCube = class(TGLCameraInvariantObject)

Description

no description available, TGLCameraInvariantObject description follows

Base class for camera invariant objects.<p> Camera invariant objects bypass camera settings, such as camera position (object is always centered on camera) or camera orientation (object always has same orientation as camera).

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLCameraInvariantObject
  • TGLDummyCube

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function BarycenterAbsolutePosition: TVector; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure StructureChanged; override;
Protected | procedure SetAmalgamate(const val: Boolean);
Protected | procedure SetCubeSize(const val: TGLFloat);
Protected | procedure SetEdgeColor(const val: TGLColor);
Protected | procedure SetVisibleAtRunTime(const val: Boolean);

Properties

Published | property Amalgamate: Boolean read FAmalgamate write SetAmalgamate default False;
Published | property CamInvarianceMode default cimNone;
Published | property CubeSize: TGLFloat read FCubeSize write SetCubeSize;
Published | property EdgeColor: TGLColor read FEdgeColor write SetEdgeColor;
Published | property OnVisibilityDetermination: TGLVisibilityDeterminationEvent read FOnVisibilityDetermination write FOnVisibilityDetermination;
Published | property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function BarycenterAbsolutePosition: TVector; override;
Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public procedure StructureChanged; override;
Protected procedure SetAmalgamate(const val: Boolean);
Protected procedure SetCubeSize(const val: TGLFloat);
Protected procedure SetEdgeColor(const val: TGLColor);
Protected procedure SetVisibleAtRunTime(const val: Boolean);

Properties

Published property Amalgamate: Boolean read FAmalgamate write SetAmalgamate default False;
Published property CamInvarianceMode default cimNone;
Published property CubeSize: TGLFloat read FCubeSize write SetCubeSize;
Published property EdgeColor: TGLColor read FEdgeColor write SetEdgeColor;
Published property OnVisibilityDetermination: TGLVisibilityDeterminationEvent read FOnVisibilityDetermination write FOnVisibilityDetermination;
Published property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLObjects: Class TGLPlane

Class TGLPlane

Unit

GLObjects

Declaration

type TGLPlane = class(TGLSceneObject)

Description

no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPlane

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;
Public | function PointDistance(const aPoint: TVector): Single;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public | function ScreenRect(aBuffer: TGLSceneBuffer): TGLRect;
Protected | function StoreXScope: Boolean;
Protected | function StoreYScope: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure SetHeight(const aValue: Single);
Protected | procedure SetStyle(const val: TPlaneStyles);
Protected | procedure SetWidth(const aValue: Single);
Protected | procedure SetXOffset(const Value: TGLFloat);
Protected | procedure SetXScope(const Value: TGLFloat);
Protected | procedure SetXTiles(const Value: Cardinal);
Protected | procedure SetYOffset(const Value: TGLFloat);
Protected | procedure SetYScope(const Value: TGLFloat);
Protected | procedure SetYTiles(const Value: Cardinal);

Properties

Published | property Height: TGLFloat read FHeight write SetHeight;
Published | property Style: TPlaneStyles read FStyle write SetStyle default [psSingleQuad, psTileTexture];
Published | property Width: TGLFloat read FWidth write SetWidth;
Published | property XOffset: TGLFloat read FXOffset write SetXOffset;
Published | property XScope: TGLFloat read FXScope write SetXScope stored StoreXScope;
Published | property XTiles: Cardinal read FXTiles write SetXTiles default 1;
Published | property YOffset: TGLFloat read FYOffset write SetYOffset;
Published | property YScope: TGLFloat read FYScope write SetYScope stored StoreYScope;
Published | property YTiles: Cardinal read FYTiles write SetYTiles default 1;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;
Public function PointDistance(const aPoint: TVector): Single;
Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public function ScreenRect(aBuffer: TGLSceneBuffer): TGLRect;
Protected function StoreXScope: Boolean;
Protected function StoreYScope: Boolean;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure SetHeight(const aValue: Single);
Protected procedure SetStyle(const val: TPlaneStyles);
Protected procedure SetWidth(const aValue: Single);
Protected procedure SetXOffset(const Value: TGLFloat);
Protected procedure SetXScope(const Value: TGLFloat);
Protected procedure SetXTiles(const Value: Cardinal);
Protected procedure SetYOffset(const Value: TGLFloat);
Protected procedure SetYScope(const Value: TGLFloat);
Protected procedure SetYTiles(const Value: Cardinal);

Properties

Published property Height: TGLFloat read FHeight write SetHeight;
Published property Style: TPlaneStyles read FStyle write SetStyle default [psSingleQuad, psTileTexture];
Published property Width: TGLFloat read FWidth write SetWidth;
Published property XOffset: TGLFloat read FXOffset write SetXOffset;
Published property XScope: TGLFloat read FXScope write SetXScope stored StoreXScope;
Published property XTiles: Cardinal read FXTiles write SetXTiles default 1;
Published property YOffset: TGLFloat read FYOffset write SetYOffset;
Published property YScope: TGLFloat read FYScope write SetYScope stored StoreYScope;
Published property YTiles: Cardinal read FYTiles write SetYTiles default 1;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:33


GLScene v.1.1.2: GLObjects: Class TGLSprite

Class TGLSprite

Unit

GLObjects

Declaration

type TGLSprite = class(TGLSceneObject)

Description

no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLSprite

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Protected | function StoreAlphaChannel: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure SetSize(const Width, Height: TGLFloat);
Public | procedure SetSquareSize(const size: TGLFloat);
Protected | procedure SetAlphaChannel(const val: Single);
Protected | procedure SetHeight(const val: TGLFloat);
Protected | procedure SetMirrorU(const val: Boolean);
Protected | procedure SetMirrorV(const val: Boolean);
Protected | procedure SetRotation(const val: TGLFloat);
Protected | procedure SetWidth(const val: TGLFloat);

Properties

Published | property AlphaChannel: Single read FAlphaChannel write SetAlphaChannel stored StoreAlphaChannel;
Published | property Height: TGLFloat read FHeight write SetHeight;
Published | property MirrorU: Boolean read FMirrorU write SetMirrorU default False;
Published | property MirrorV: Boolean read FMirrorV write SetMirrorV default False;
Published | property Rotation: TGLFloat read FRotation write SetRotation;
Published | property Width: TGLFloat read FWidth write SetWidth;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Protected function StoreAlphaChannel: Boolean;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure SetSize(const Width, Height: TGLFloat);
Public procedure SetSquareSize(const size: TGLFloat);
Protected procedure SetAlphaChannel(const val: Single);
Protected procedure SetHeight(const val: TGLFloat);
Protected procedure SetMirrorU(const val: Boolean);
Protected procedure SetMirrorV(const val: Boolean);
Protected procedure SetRotation(const val: TGLFloat);
Protected procedure SetWidth(const val: TGLFloat);

Properties

Published property AlphaChannel: Single read FAlphaChannel write SetAlphaChannel stored StoreAlphaChannel;
Published property Height: TGLFloat read FHeight write SetHeight;
Published property MirrorU: Boolean read FMirrorU write SetMirrorU default False;
Published property MirrorV: Boolean read FMirrorV write SetMirrorV default False;
Published property Rotation: TGLFloat read FRotation write SetRotation;
Published property Width: TGLFloat read FWidth write SetWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLObjects: Class TGLPointParameters

Class TGLPointParameters

Unit

GLObjects

Declaration

type TGLPointParameters = class(TGLUpdateAbleObject)

Description

no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLPointParameters

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | procedure Apply;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure UnApply;
Protected | procedure DefineProperties(Filer: TFiler); override;
Protected | procedure ReadData(Stream: TStream);
Protected | procedure SetDistanceAttenuation(const val: TGLCoordinates);
Protected | procedure SetEnabled(const val: Boolean);
Protected | procedure SetFadeTresholdSize(const val: Single);
Protected | procedure SetMaxSize(const val: Single);
Protected | procedure SetMinSize(const val: Single);
Protected | procedure WriteData(Stream: TStream);

Properties

Published | property DistanceAttenuation: TGLCoordinates read FDistanceAttenuation write SetDistanceAttenuation;
Published | property Enabled: Boolean read FEnabled write SetEnabled default False;
Published | property FadeTresholdSize: Single read FFadeTresholdSize write SetFadeTresholdSize stored False;
Published | property MaxSize: Single read FMaxSize write SetMaxSize stored False;
Published | property MinSize: Single read FMinSize write SetMinSize stored False;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public procedure Apply;
Public procedure Assign(Source: TPersistent); override;
Public procedure UnApply;
Protected procedure DefineProperties(Filer: TFiler); override;
Protected procedure ReadData(Stream: TStream);
Protected procedure SetDistanceAttenuation(const val: TGLCoordinates);
Protected procedure SetEnabled(const val: Boolean);
Protected procedure SetFadeTresholdSize(const val: Single);
Protected procedure SetMaxSize(const val: Single);
Protected procedure SetMinSize(const val: Single);
Protected procedure WriteData(Stream: TStream);

Properties

Published property DistanceAttenuation: TGLCoordinates read FDistanceAttenuation write SetDistanceAttenuation;
Published property Enabled: Boolean read FEnabled write SetEnabled default False;
Published property FadeTresholdSize: Single read FFadeTresholdSize write SetFadeTresholdSize stored False;
Published property MaxSize: Single read FMaxSize write SetMaxSize stored False;
Published property MinSize: Single read FMinSize write SetMinSize stored False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLObjects: Class TGLPoints

Class TGLPoints

Unit

GLObjects

Declaration

type TGLPoints = class(TGLImmaterialSceneObject)

Description

no description available, TGLImmaterialSceneObject description follows

Base class for objects that do not have a published "material".<p> Note that the material is available in public properties, but isn't applied automatically before invoking BuildList.<br> Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLPoints

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function StoreSize: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure SetColors(const val: TVectorList);
Protected | procedure SetNoZWrite(const val: Boolean);
Protected | procedure SetPointParameters(const val: TGLPointParameters);
Protected | procedure SetPositions(const val: TAffineVectorList);
Protected | procedure SetSize(const val: Single);
Protected | procedure SetStatic(const val: Boolean);
Protected | procedure SetStyle(const val: TGLPointStyle);

Properties

Public | property Colors: TVectorList read FColors write SetColors;
Published | property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;
Published | property PointParameters: TGLPointParameters read FPointParameters write SetPointParameters;
Public | property Positions: TAffineVectorList read FPositions write SetPositions;
Published | property size: Single read FSize write SetSize stored StoreSize;
Published | property Static: Boolean read FStatic write SetStatic;
Published | property Style: TGLPointStyle read FStyle write SetStyle default psSquare;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function StoreSize: Boolean;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure SetColors(const val: TVectorList);
Protected procedure SetNoZWrite(const val: Boolean);
Protected procedure SetPointParameters(const val: TGLPointParameters);
Protected procedure SetPositions(const val: TAffineVectorList);
Protected procedure SetSize(const val: Single);
Protected procedure SetStatic(const val: Boolean);
Protected procedure SetStyle(const val: TGLPointStyle);

Properties

Public property Colors: TVectorList read FColors write SetColors;
Published property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;
Published property PointParameters: TGLPointParameters read FPointParameters write SetPointParameters;
Public property Positions: TAffineVectorList read FPositions write SetPositions;
Published property size: Single read FSize write SetSize stored StoreSize;
Published property Static: Boolean read FStatic write SetStatic;
Published property Style: TGLPointStyle read FStyle write SetStyle default psSquare;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLObjects: Class TGLLinesNode

Class TGLLinesNode

Unit

GLObjects

Declaration

type TGLLinesNode = class(TGLNode)

Description

no description available, TGLNode description follows

Hierarchy

  • TCollectionItem
  • TGLNode
  • TGLLinesNode

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Protected | function StoreColor: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure OnColorChange(Sender: TObject);
Protected | procedure SetColor(const val: TGLColor);

Properties

Published property Color: TGLColor read FColor write SetColor stored StoreColor;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Protected function StoreColor: Boolean;
Public procedure Assign(Source: TPersistent); override;
Protected procedure OnColorChange(Sender: TObject);
Protected procedure SetColor(const val: TGLColor);

Properties

Published property Color: TGLColor read FColor write SetColor stored StoreColor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLObjects: Class TGLLinesNodes

Class TGLLinesNodes

Unit

GLObjects

Declaration

type TGLLinesNodes = class(TGLNodes)

Description

no description available, TGLNodes description follows

Hierarchy

  • TOwnedCollection
  • TGLNodes
  • TGLLinesNodes

Overview

Methods

Public | constructor Create(AOwner: TComponent); overload;
Public | procedure NotifyChange; override;

Description

Methods

Public constructor Create(AOwner: TComponent); overload;
Public procedure NotifyChange; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLObjects: Class TGLLineBase

Class TGLLineBase

Unit

GLObjects

Declaration

type TGLLineBase = class(TGLImmaterialSceneObject)

Description

no description available, TGLImmaterialSceneObject description follows

Base class for objects that do not have a published "material".<p> Note that the material is available in public properties, but isn't applied automatically before invoking BuildList.<br> Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLLineBase

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function StoreLineWidth: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure SetAntiAliased(const val: Boolean);
Protected | procedure SetLineColor(const Value: TGLColor);
Protected | procedure SetLinePattern(const Value: TGLushort);
Protected | procedure SetLineWidth(const val: Single);
Protected | procedure SetupLineStyle(var rci: TRenderContextInfo);

Properties

Published | property AntiAliased: Boolean read FAntiAliased write SetAntiAliased default False;
Published | property LineColor: TGLColor read FLineColor write SetLineColor;
Published | property LinePattern: TGLushort read FLinePattern write SetLinePattern default $FFFF;
Published | property LineWidth: Single read FLineWidth write SetLineWidth stored StoreLineWidth;
Published | property Visible;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function StoreLineWidth: Boolean;
Public procedure Assign(Source: TPersistent); override;
Public procedure NotifyChange(Sender: TObject); override;
Protected procedure SetAntiAliased(const val: Boolean);
Protected procedure SetLineColor(const Value: TGLColor);
Protected procedure SetLinePattern(const Value: TGLushort);
Protected procedure SetLineWidth(const val: Single);
Protected procedure SetupLineStyle(var rci: TRenderContextInfo);

Properties

Published property AntiAliased: Boolean read FAntiAliased write SetAntiAliased default False;
Published property LineColor: TGLColor read FLineColor write SetLineColor;
Published property LinePattern: TGLushort read FLinePattern write SetLinePattern default $FFFF;
Published property LineWidth: Single read FLineWidth write SetLineWidth stored StoreLineWidth;
Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLObjects: Class TGLNodedLines

Class TGLNodedLines

Unit

GLObjects

Declaration

type TGLNodedLines = class(TGLLineBase)

Description

no description available, TGLLineBase description follows
no description available, TGLImmaterialSceneObject description follows

Base class for objects that do not have a published "material".<p> Note that the material is available in public properties, but isn't applied automatically before invoking BuildList.<br> Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLLineBase
  • TGLNodedLines

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Protected | function StoreNodeSize: Boolean;
Public | procedure AddNode(const Value: TVector); overload;
Public | procedure AddNode(const coords: TGLCoordinates); overload;
Public | procedure AddNode(const X, Y, Z: TGLFloat); overload;
Public | procedure AddNode(const Value: TAffineVector); overload;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure DrawNode(var rci: TRenderContextInfo; X, Y, Z: Single; Color: TGLColor);
Protected | procedure OnNodeColorChanged(Sender: TObject);
Protected | procedure SetNodeColor(const Value: TGLColor);
Protected | procedure SetNodes(const aNodes: TGLLinesNodes);
Protected | procedure SetNodesAspect(const Value: TLineNodesAspect);
Protected | procedure SetNodeSize(const val: Single);

Properties

Published | property NodeColor: TGLColor read FNodeColor write SetNodeColor;
Published | property Nodes: TGLLinesNodes read FNodes write SetNodes;
Published | property NodesAspect: TLineNodesAspect read FNodesAspect write SetNodesAspect default lnaAxes;
Published | property NodeSize: Single read FNodeSize write SetNodeSize stored StoreNodeSize;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Protected function StoreNodeSize: Boolean;
Public procedure AddNode(const Value: TVector); overload;
Public procedure AddNode(const coords: TGLCoordinates); overload;
Public procedure AddNode(const X, Y, Z: TGLFloat); overload;
Public procedure AddNode(const Value: TAffineVector); overload;
Public procedure Assign(Source: TPersistent); override;
Protected procedure DrawNode(var rci: TRenderContextInfo; X, Y, Z: Single; Color: TGLColor);
Protected procedure OnNodeColorChanged(Sender: TObject);
Protected procedure SetNodeColor(const Value: TGLColor);
Protected procedure SetNodes(const aNodes: TGLLinesNodes);
Protected procedure SetNodesAspect(const Value: TLineNodesAspect);
Protected procedure SetNodeSize(const val: Single);

Properties

Published property NodeColor: TGLColor read FNodeColor write SetNodeColor;
Published property Nodes: TGLLinesNodes read FNodes write SetNodes;
Published property NodesAspect: TLineNodesAspect read FNodesAspect write SetNodesAspect default lnaAxes;
Published property NodeSize: Single read FNodeSize write SetNodeSize stored StoreNodeSize;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLObjects: Class TGLLines

Class TGLLines

Unit

GLObjects

Declaration

type TGLLines = class(TGLNodedLines)

Description

no description available, TGLNodedLines description follows
no description available, TGLLineBase description follows
no description available, TGLImmaterialSceneObject description follows

Base class for objects that do not have a published "material".<p> Note that the material is available in public properties, but isn't applied automatically before invoking BuildList.<br> Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLLineBase
  • TGLNodedLines
  • TGLLines

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure SetDivision(const Value: Integer);
Protected | procedure SetNURBSOrder(const val: Integer);
Protected | procedure SetNURBSTolerance(const val: Single);
Protected | procedure SetOptions(const val: TLinesOptions);
Protected | procedure SetSplineMode(const val: TLineSplineMode);

Properties

Published | property Division: Integer read FDivision write SetDivision default 10;
Public | property NURBSKnots: TSingleList read FNURBSKnots;
Public | property NURBSOrder: Integer read FNURBSOrder write SetNURBSOrder;
Public | property NURBSTolerance: Single read FNURBSTolerance write SetNURBSTolerance;
Published | property Options: TLinesOptions read FOptions write SetOptions;
Published | property SplineMode: TLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure SetDivision(const Value: Integer);
Protected procedure SetNURBSOrder(const val: Integer);
Protected procedure SetNURBSTolerance(const val: Single);
Protected procedure SetOptions(const val: TLinesOptions);
Protected procedure SetSplineMode(const val: TLineSplineMode);

Properties

Published property Division: Integer read FDivision write SetDivision default 10;
Public property NURBSKnots: TSingleList read FNURBSKnots;
Public property NURBSOrder: Integer read FNURBSOrder write SetNURBSOrder;
Public property NURBSTolerance: Single read FNURBSTolerance write SetNURBSTolerance;
Published property Options: TLinesOptions read FOptions write SetOptions;
Published property SplineMode: TLineSplineMode read FSplineMode write SetSplineMode default lsmLines;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLObjects: Class TGLCube

Class TGLCube

Unit

GLObjects

Declaration

type TGLCube = class(TGLSceneObject)

Description

no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLCube

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure DefineProperties(Filer: TFiler); override;
Protected | procedure ReadData(Stream: TStream);
Protected | procedure WriteData(Stream: TStream);

Properties

Published | property CubeDepth: TGLFloat index 2 read GetCubeWHD write SetCubeWHD stored False;
Published | property CubeHeight: TGLFloat index 1 read GetCubeWHD write SetCubeWHD stored False;
Published | property CubeWidth: TGLFloat index 0 read GetCubeWHD write SetCubeWHD stored False;
Published | property NormalDirection: TNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Parts: TCubeParts read FParts write SetParts default [cpTop, cpBottom, cpFront, cpBack, cpLeft, cpRight];

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;
Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure DefineProperties(Filer: TFiler); override;
Protected procedure ReadData(Stream: TStream);
Protected procedure WriteData(Stream: TStream);

Properties

Published property CubeDepth: TGLFloat index 2 read GetCubeWHD write SetCubeWHD stored False;
Published property CubeHeight: TGLFloat index 1 read GetCubeWHD write SetCubeWHD stored False;
Published property CubeWidth: TGLFloat index 0 read GetCubeWHD write SetCubeWHD stored False;
Published property NormalDirection: TNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published property Parts: TCubeParts read FParts write SetParts default [cpTop, cpBottom, cpFront, cpBack, cpLeft, cpRight];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLObjects: Class TGLQuadricObject

Class TGLQuadricObject

Unit

GLObjects

Declaration

type TGLQuadricObject = class(TGLSceneObject)

Description

no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure SetInvertedQuadricOrientation(quadric: PGLUquadricObj);
Protected | procedure SetNormalDirection(aValue: TNormalDirection);
Protected | procedure SetNormalQuadricOrientation(quadric: PGLUquadricObj);
Protected | procedure SetNormals(aValue: TNormalSmoothing);
Protected | procedure SetupQuadricParams(quadric: PGLUquadricObj);

Properties

Published | property NormalDirection: TNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published | property Normals: TNormalSmoothing read FNormals write SetNormals default nsSmooth;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure Assign(Source: TPersistent); override;
Protected procedure SetInvertedQuadricOrientation(quadric: PGLUquadricObj);
Protected procedure SetNormalDirection(aValue: TNormalDirection);
Protected procedure SetNormalQuadricOrientation(quadric: PGLUquadricObj);
Protected procedure SetNormals(aValue: TNormalSmoothing);
Protected procedure SetupQuadricParams(quadric: PGLUquadricObj);

Properties

Published property NormalDirection: TNormalDirection read FNormalDirection write SetNormalDirection default ndOutside;
Published property Normals: TNormalSmoothing read FNormals write SetNormals default nsSmooth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLObjects: Class TGLSphere

Class TGLSphere

Unit

GLObjects

Declaration

type TGLSphere = class(TGLQuadricObject)

Description

no description available, TGLQuadricObject description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLQuadricObject
  • TGLSphere

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Published | property Bottom: TAngleLimit1 read FBottom write SetBottom default -90;
Published | property BottomCap: TCapType read FBottomCap write SetBottomCap default ctNone;
Published | property Radius: TGLFloat read FRadius write SetRadius;
Published | property Slices: TGLInt read FSlices write SetSlices default 16;
Published | property Stacks: TGLInt read FStacks write SetStacks default 16;
Published | property Start: TAngleLimit2 read FStart write SetStart default 0;
Published | property Stop: TAngleLimit2 read FStop write SetStop default 360;
Published | property Top: TAngleLimit1 read FTop write SetTop default 90;
Published | property TopCap: TCapType read FTopCap write SetTopCap default ctNone;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function GenerateSilhouette(const silhouetteParameters : TGLSilhouetteParameters): TGLSilhouette; override;
Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil) : Boolean; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;

Properties

Published property Bottom: TAngleLimit1 read FBottom write SetBottom default -90;
Published property BottomCap: TCapType read FBottomCap write SetBottomCap default ctNone;
Published property Radius: TGLFloat read FRadius write SetRadius;
Published property Slices: TGLInt read FSlices write SetSlices default 16;
Published property Stacks: TGLInt read FStacks write SetStacks default 16;
Published property Start: TAngleLimit2 read FStart write SetStart default 0;
Published property Stop: TAngleLimit2 read FStop write SetStop default 360;
Published property Top: TAngleLimit1 read FTop write SetTop default 90;
Published property TopCap: TCapType read FTopCap write SetTopCap default ctNone;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLObjects: Class TGLPolygonBase

Class TGLPolygonBase

Unit

GLObjects

Declaration

type TGLPolygonBase = class(TGLSceneObject)

Description

no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPolygonBase

Overview

Fields

Protected FNodes: TGLNodes;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure AddNode(const X, Y, Z: TGLFloat); overload;
Public | procedure AddNode(const coords: TGLCoordinates); overload;
Public | procedure AddNode(const Value: TAffineVector); overload;
Public | procedure AddNode(const Value: TVector); overload;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure CreateNodes; dynamic;
Protected | procedure SetDivision(const Value: Integer);
Protected | procedure SetNodes(const aNodes: TGLNodes);
Protected | procedure SetSplineMode(const val: TLineSplineMode);

Properties

Published | property Division: Integer read FDivision write SetDivision default 10;
Published | property Nodes: TGLNodes read FNodes write SetNodes;
Published | property SplineMode: TLineSplineMode read FSplineMode write SetSplineMode default lsmLines;

Description

Fields

Protected FNodes: TGLNodes;

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure AddNode(const X, Y, Z: TGLFloat); overload;
Public procedure AddNode(const coords: TGLCoordinates); overload;
Public procedure AddNode(const Value: TAffineVector); overload;
Public procedure AddNode(const Value: TVector); overload;
Public procedure Assign(Source: TPersistent); override;
Public procedure NotifyChange(Sender: TObject); override;
Protected procedure CreateNodes; dynamic;
Protected procedure SetDivision(const Value: Integer);
Protected procedure SetNodes(const aNodes: TGLNodes);
Protected procedure SetSplineMode(const val: TLineSplineMode);

Properties

Published property Division: Integer read FDivision write SetDivision default 10;
Published property Nodes: TGLNodes read FNodes write SetNodes;
Published property SplineMode: TLineSplineMode read FSplineMode write SetSplineMode default lsmLines;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLODECustomColliders

Unit GLODECustomColliders

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLODECustomColliders<p>

Custom ODE collider implementations.<p>

<b>Credits : </b><font size=-1><ul> <li>Heightfield collider code originally adapted from Mattias Fagerlund's DelphiODE terrain collision demo. Website: http://www.cambrianlabs.com/Mattias/DelphiODE </ul>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: restored records with arrays instead of vector arrays <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>08/11/09 - DaStr - Improved FPC compatibility (thanks Predator) (BugtrackerID = 2893580) <li>12/04/08 - DaStr - Cleaned up uses section (thanks Sandor Domokos) (BugtrackerID = 1808373) <li>06/02/08 - Mrqzzz - Upgrade to ODE 0.9 (by Paul Robello) Fixed reference to odeimport <li>25/12/07 - DaStr - Fixed memory leak in TGLODECustomCollider.Destroy() (thanks Sandor Domokos) (BugtrackerID = 1808373) <li>10/10/07 - Mrqzzz - Fixed reference ODEGL.ODERToGLSceneMatrix <li>07/10/07 - Mrqzzz - Added reference to ODEGL <li>11/09/07 - Mrqzzz - Added reference to ODEImport <li>07/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) Added $I GLScene.inc <li>08/12/04 - SG - Added contact point rendering to TGLODECustomCollider. <li>07/12/04 - SG - Added new TGLODECustomCollider class, Geom collide code now uses Resolution to determine the number of contact points to generate. <li>19/11/04 - SG - Changed TGLODETerrainCollider to TGLODEHeightField which now inherits from TGLODEBehaviour and works for both TGLTerrainRenderer and TGLHeightField objects. Added Capsule, Cylinder and Cone collider code for the heightfield collider. <li>23/04/04 - SG - Removed freeform static collider <li>29/10/03 - SG - Fix for GLODETerrainCollider (Matheus Degiovani) <li>30/07/03 - SG - Creation. </ul>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TContactPoint |
Class TGLODECustomCollider |
Class TGLODEHeightField |

Functions and Procedures

function GetODEHeightField(obj: TGLBaseSceneObject): TGLODEHeightField;
function GetOrCreateODEHeightField(obj: TGLBaseSceneObject): TGLODEHeightField;

Description

Functions and Procedures

function GetODEHeightField(obj: TGLBaseSceneObject): TGLODEHeightField;
function GetOrCreateODEHeightField(obj: TGLBaseSceneObject): TGLODEHeightField;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLODECustomColliders: Class TContactPoint

Class TContactPoint

Unit

GLODECustomColliders

Declaration

type TContactPoint = class(TObject)

Description

Hierarchy

  • TObject
  • TContactPoint

Overview

Fields

Public | Position: TAffineVector;
Public | Normal: TAffineVector;
Public | Depth: Single;

Description

Fields

Public Position: TAffineVector;
Public Normal: TAffineVector;
Public Depth: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLODECustomColliders: Class TGLODECustomCollider

Class TGLODECustomCollider

Unit

GLODECustomColliders

Declaration

type TGLODECustomCollider = class(TGLODEBehaviour)

Description

The custom collider is designed for generic contact handling. There is a contact point generator for sphere, box, capped cylinder, cylinder and cone geoms.<p>

Once the contact points for a collision are generated the abstract Collide function is called to generate the depth and the contact position and normal. These points are then sorted and the deepest are applied to ODE.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLODEBehaviour
  • TGLODECustomCollider

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Protected | function ApplyContacts(o1, o2: PdxGeom; flags: Integer; contact: PdContactGeom; skip: Integer): Integer;
Protected | function Collide(aPos: TAffineVector; var Depth: Single; var cPos, cNorm: TAffineVector): Boolean; virtual; abstract;
Public | procedure Render(var rci: TRenderContextInfo); override;
Protected | procedure AddContact(pos: TAffineVector); overload;
Protected | procedure AddContact(x, y, z: TdReal); overload;
Protected | procedure ClearContacts;
Protected | procedure Finalize; override;
Protected | procedure Initialize; override;
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure SetContactColor(const Value: TGLColor);
Protected | procedure SetContactResolution(const Value: Single);
Protected | procedure SetPointSize(const Value: Single);
Protected | procedure SetRenderContacts(const Value: Boolean);
Protected | procedure SetTransform(ATransform: TMatrix);
Protected | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property ContactColor: TGLColor read FContactColor write SetContactColor;
Published | property ContactResolution: Single read FContactResolution write SetContactResolution;
Public | property Geom: PdxGeom read FGeom;
Published | property PointSize: Single read FPointSize write SetPointSize;
Published | property RenderContacts: Boolean read FRenderContacts write SetRenderContacts;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;
Public destructor Destroy; override;
Protected function ApplyContacts(o1, o2: PdxGeom; flags: Integer; contact: PdContactGeom; skip: Integer): Integer;

Sort the current contact list and apply the deepest to ODE.

Protected function Collide(aPos: TAffineVector; var Depth: Single; var cPos, cNorm: TAffineVector): Boolean; virtual; abstract;

Test a position for a collision and fill out the contact information.

Public procedure Render(var rci: TRenderContextInfo); override;
Protected procedure AddContact(pos: TAffineVector); overload;
Protected procedure AddContact(x, y, z: TdReal); overload;

Add a contact point to the list for ApplyContacts to processes.

Protected procedure ClearContacts;

Clears the contact list so it's ready for another collision.

Protected procedure Finalize; override;
Protected procedure Initialize; override;
Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure SetContactColor(const Value: TGLColor);
Protected procedure SetContactResolution(const Value: Single);
Protected procedure SetPointSize(const Value: Single);
Protected procedure SetRenderContacts(const Value: Boolean);
Protected procedure SetTransform(ATransform: TMatrix);

Set the transform used that transforms contact points generated with AddContact.

Protected procedure WriteToFiler(writer: TWriter); override;

Properties

Published property ContactColor: TGLColor read FContactColor write SetContactColor;

Contact point rendering color.

Published property ContactResolution: Single read FContactResolution write SetContactResolution;

Defines the resolution of the contact points created for the colliding Geom. The number of contact points generated change base don the size of the object and the ContactResolution. Lower values generate higher resolution contact boundaries, and thus smoother but slower collisions.

Public property Geom: PdxGeom read FGeom;
Published property PointSize: Single read FPointSize write SetPointSize;

Contact point rendering size (in pixels).

Published property RenderContacts: Boolean read FRenderContacts write SetRenderContacts;

Toggle contact point rendering on and off. (Rendered through the assigned Manager.RenderPoint.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLODECustomColliders: Class TGLODEHeightField

Class TGLODEHeightField

Unit

GLODECustomColliders

Declaration

type TGLODEHeightField = class(TGLODECustomCollider)

Description

Add this behaviour to a TGLHeightField or TGLTerrainRenderer to enable height based collisions for spheres, boxes, capped cylinders, cylinders and cones.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLODEBehaviour
  • TGLODECustomCollider
  • TGLODEHeightField

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | class function CanAddTo(collection: TXCollection): Boolean; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | class function UniqueItem: Boolean; override;
Protected | function Collide(aPos: TAffineVector; var Depth: Single; var cPos, cNorm: TAffineVector): Boolean; override;
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure WriteToFiler(writer: TWriter); override;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;
Public class function CanAddTo(collection: TXCollection): Boolean; override;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Public class function UniqueItem: Boolean; override;
Protected function Collide(aPos: TAffineVector; var Depth: Single; var cPos, cNorm: TAffineVector): Boolean; override;
Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure WriteToFiler(writer: TWriter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLODEManager

Unit GLODEManager

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLODEManager<p>

An ODE Manager for GLScene.<p>

Where can I find ... ?<ul> <li>GLScene (http://glscene.org) <li>Open Dynamics Engine (http://opende.sourceforge.org) <li>DelphiODE (http://www.cambrianlabs.com/Mattias/DelphiODE) </ul>

Notes: This code is still being developed so any part of it may change at anytime. To install use the GLS_ODE?.dpk in the GLScene/Delphi? folder.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>21/01/01 - DanB - Added "inherited" call to TODEElementPlane.WriteToFiler <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>14/06/10 - YP - Sub-element translation code in CalibrateCenterOfMass removed <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>08/12/08 - PR - dBodySetMass no longer accepts zero mass. check added joint parms now have a 1 appended to them for first parm example dParamLoStop is now dParamLoStop1 <li>17/10/08 - DanB - changed some NotifyChange(Sender) calls to NotifyChange(Self) <li>12/04/08 - DaStr - Cleaned up uses section (thanks Sandor Domokos) (BugtrackerID = 1808373) <li>10/04/08 - DaStr - Removed compiler hints from TGLODEDynamic.AddNewElement() <li>19/03/08 - Mrqzzz - by DAlex : Added different geom colors; Don't create contact between static objects; In Destroying procedures placed to last line the "Inherited" <li>28/02/08 - Mrqzzz - Changed Axis2 to XHMGVector on universal joint creation in TODEJointUniversal.Create <li>06/02/08 - Mrqzzz - Upgrade to ODE 0.9 (upgrade by by Paul Robello; fixes for runtime creation) <li>25/12/07 - DaStr - Fixed access violation in TGLODEManager.Destroy() (thanks Sandor Domokos) (BugtrackerID = 1808371) <li>30/11/07 - Mrqzzz - Changed parameters in OnCollision event (TODEObjectCollisionEvent) <li>10/10/07 - Mrqzzz - Fixed in TGLODEDynamic.AlignObject the explocit reference to ODEGL.ODERToGLSceneMatrix(m,Rˆ,posˆ) to avoid ambiguous overloading <li>08/09/07 - Mrqzzz - small changes in unit references (last reference is to odeimport) in order to make GLODEManager compatible with non-GLODEManager based ODE worlds Added public property "ContactGroup" <li>24/08/07 - Mrqzzz - Updated GetSurfaceFromObject to support correctly Trimesh collision <li>07/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>01/03/05 - Mrqzzz - Moved in TODEJointBase protected code from Loaded to public DoLoaded. <li>20/12/04 - SG - TGLODEStatic objects now realign geoms on step, Fix for Hinge2 and Universal joints, Fix for TGLODEDynamic.Enabled property persistence. <li>10/12/04 - SG - Added TODEElementPlane, Fixed TODEElementCone.Render function. <li>09/12/04 - Mathx - Added getX and getOrCreateX functions. <li>19/11/04 - SG - Major structural changes/improvements, Dropped TGLBaseSceneObject style object in favour of TGLBehaviour style ones, TGLODEBaseBehaviour is now TGLODEBehaviour, TGLODEDynamicBehaviour is now TGLODEDynamic, TGLODEStaticBehaviour is now TGLODEStatic, Added TODEJointParams to handle joint axis parameters, Added RenderPoint to GLODEManager to handle rendering. <li>17/11/04 - SG - Changed Deinitialize to Finalize, Changed TGLODEDummy to TGLODEDynamicDummy. <li>09/11/04 - SG - Fixed problems with contact geom generation (k00m). <li>03/05/04 - SG - Tri-mesh and various fixes/enhancements. <li>23/04/04 - SG - Fixes for object registration, Exception raised now if ODE fails to initialize at run-time. <li>21/04/04 - SG - Changed to dynamic linking DelphiODE, Design-time no longer makes any DelphiODE calls. <li>15/04/04 - SG - Added OnCustomCollision event to TGLODEManager. <li>14/04/04 - SG - Minor DelphiODE compatibility changes. <li>30/03/04 - SG - Joint objects are now fully persistent. <li>05/03/04 - SG - SetSurfaceMode fix (Alex) <li>25/02/04 - SG - Added the GLODEStaticBehaviour. <li>24/02/04 - SG - Added the static GLODETerrain collider. <li>23/02/04 - SG - Fix for design to real time gravity persistence. Added cone, cylinder and tri-mesh elements. Other various fixes/enhancements. <li>28/01/04 - SG - Added TGLODEStaticDummy. Fixed Element alignment code. Other minor fixes/changes. <li>13/11/03 - SG - Fixed bug with destroying geoms, manager now forces registered objects to Deinitialize. Fixed up some comments. <li>12/11/03 - SG - Fixed bug with TGLODEManager.Collision <li>01/09/03 - SG - Changed all relevant floating point types to TdReal, Changed Read/Write Single/Double to Read/Write Float. <li>19/08/03 - SG - Added GetBodyFromGLSceneObject (Dan Bartlett), Added StepFast and FastIterations to GLODEManager. <li>11/08/03 - SG - Added some force/torque methods to dynamic objects. <li>30/07/03 - SG - Split terrain collider into GLODECustomColliders unit. <li>25/07/03 - SG - Fixed Manager property persistence, other minor changes. <li>24/07/03 - SG - ReadFromFiler and WriteToFiler routines added, improved object and joint initialization system. Manager properties not persitent in joints and behaviours. <li>26/06/03 - EG - Replaced TObjectList with TPersistentObjectList, dropped Contnrs dependency (D5 compatibility) <li>23/06/03 - SG - Added GLODETerrainCollider, an implementation from DelphiODE terrain demo (buggy caused assertion error in GLHeightData.pas). <li>13/06/03 - SG - Added more joints. <li>11/06/03 - SG - Base joint classes implemented and added hinge joint. <li>09/06/03 - SG - Added OnCollision event for ODE Objects and Behaviours. <li>08/06/03 - SG - Added rolling friction (experimental). <li>06/06/03 - SG - Added cylinder element (experimental). <li>04/06/03 - SG - Changes to structures, added TGLODEDynamicBehaviour. <li>30/05/03 - SG - Added capsule element and plane object, Fixed problems with Collision callback method. <li>29/05/03 - SG - Better GetCollisionSurface code (thanks to Mattias Fagerlund). <li>28/05/03 - SG - Some fixes to ODE Elements (thanks to Mattias Fagerlund). Added TGLODEDummy.CalibrateCenterOfMass <li>01/03/03 - SG - Creation. </ul>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLODEManager |
Class TODECollisionSurface |
Class TGLODEBehaviour |
Class TGLODEDynamic |
Class TGLODEStatic |
Class TODEElements |
Class TODEElementBase |
Class TODEElementBox |
Class TODEElementSphere |
Class TODEElementCapsule |
Class TODEElementCylinder |
Class TODEElementTriMesh |
Class TODEElementPlane |
Class TODEJoints |
Class TGLODEJointList |
Class TODEJointBase |
Class TODEJointParams |
Class TODEJointHinge |
Class TODEJointBall |
Class TODEJointSlider |
Class TODEJointFixed |
Class TODEJointHinge2 |
Class TODEJointUniversal |

Functions and Procedures

procedure nearCallBack(Data:Pointer; o1,o2:PdxGeom); cdecl;
function GetBodyFromObject(anObject : TObject):PdxBody;
function GetBodyFromGLSceneObject(anObject : TGLBaseSceneObject):PdxBody;
function GetSurfaceFromObject(anObject : TObject):TODECollisionSurface;
procedure RegisterGLSceneObject(anObject : TGLBaseSceneObject);
procedure UnregisterGLSceneObject(anObject : TGLBaseSceneObject);
function GetGLSceneObject(anObjectName : String) : TGLBaseSceneObject;
function GetOdeStatic(obj: TGLBaseSceneObject): TGLODEStatic;
function GetOrCreateOdeStatic(obj: TGLBaseSceneObject): TGLODEStatic;
function GetOdeDynamic(obj: TGLBaseSceneObject): TGLODEDynamic;
function GetOrCreateOdeDynamic(obj: TGLBaseSceneObject): TGLODEDynamic;

Types

TODECustomCollisionEvent = procedure (Geom1, Geom2 : PdxGeom) of object;
TODECollisionEvent = procedure (Sender : TObject; Object1, Object2 : TObject; var Contact:TdContact; var HandleCollision:Boolean) of object;
TODEObjectCollisionEvent = procedure (Sender : TObject; Object2 : TObject; var Contact:TdContact; var HandleCollision:Boolean) of object;
TODECollisionSurfaceMode = (...);
TSurfaceModes = set of TODECollisionSurfaceMode;
TODESolverMethod = (...);
TODEElementClass = class of TODEElementBase;
TJointOption = (...);
TJointOptions = set of TJointOption;
TODESetParamCallback = function (Param : Integer; const Value : TdReal) : Boolean of object;
TODEGetParamCallback = function (Param : Integer; var Value : TdReal) : Boolean of object;

Variables

vGLODEObjectRegister: TList;

Description

Functions and Procedures

procedure nearCallBack(Data:Pointer; o1,o2:PdxGeom); cdecl;

ODE nearCallBack, throws near callback to the collision procedure of the ODE manager linked by the Data pointer.

function GetBodyFromObject(anObject : TObject):PdxBody;

Helper functions for extracting data from objects with different inheritance.

function GetBodyFromGLSceneObject(anObject : TGLBaseSceneObject):PdxBody;
function GetSurfaceFromObject(anObject : TObject):TODECollisionSurface;
procedure RegisterGLSceneObject(anObject : TGLBaseSceneObject);
procedure UnregisterGLSceneObject(anObject : TGLBaseSceneObject);
function GetGLSceneObject(anObjectName : String) : TGLBaseSceneObject;
function GetOdeStatic(obj: TGLBaseSceneObject): TGLODEStatic;
function GetOrCreateOdeStatic(obj: TGLBaseSceneObject): TGLODEStatic;
function GetOdeDynamic(obj: TGLBaseSceneObject): TGLODEDynamic;
function GetOrCreateOdeDynamic(obj: TGLBaseSceneObject): TGLODEDynamic;

Types

TODECustomCollisionEvent = procedure (Geom1, Geom2 : PdxGeom) of object;
TODECollisionEvent = procedure (Sender : TObject; Object1, Object2 : TObject; var Contact:TdContact; var HandleCollision:Boolean) of object;
TODEObjectCollisionEvent = procedure (Sender : TObject; Object2 : TObject; var Contact:TdContact; var HandleCollision:Boolean) of object;
TODECollisionSurfaceMode = (...);
Values
  • csmMu2:
  • csmFDir1:
  • csmBounce:
  • csmSoftERP:
  • csmSoftCFM:
  • csmMotion1:
  • csmMotion2:
  • csmSlip1:
  • csmSlip2:
TSurfaceModes = set of TODECollisionSurfaceMode;
TODESolverMethod = (...);
Values
  • osmDefault:
  • osmStepFast:
  • osmQuickStep:
TODEElementClass = class of TODEElementBase;
TJointOption = (...);
Values
  • joBothObjectsMustBeAssigned:
TJointOptions = set of TJointOption;
TODESetParamCallback = function (Param : Integer; const Value : TdReal) : Boolean of object;
TODEGetParamCallback = function (Param : Integer; var Value : TdReal) : Boolean of object;

Variables

vGLODEObjectRegister: TList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:34


GLScene v.1.1.2: GLODEManager: Class TGLODEManager

Class TGLODEManager

Unit

GLODEManager

Declaration

type TGLODEManager = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLODEManager

Overview

Methods

Public | constructor Create(AOwner:TComponent); override;
Public | destructor Destroy; override;
Protected | function GetODEBehaviour(index : Integer) : TGLODEBehaviour;
Public | procedure NotifyChange(Sender : TObject);
Public | procedure Step(deltaTime:double);
Protected | procedure CalcContact(Object1, Object2 : TObject; var Contact:TdContact);
Protected | procedure Collision(g1,g2:PdxGeom);
Protected | procedure GeomColorChangeDynD(Sender: TObject);
Protected | procedure GeomColorChangeDynE(Sender: TObject);
Protected | procedure GeomColorChangeStat(Sender: TObject);
Protected | procedure GravityChange(Sender:TObject);
Protected | procedure Loaded; override;
Protected | procedure RegisterODEBehaviour(ODEBehaviour : TGLODEBehaviour);
Protected | procedure RenderEvent(Sender : TObject; var rci : TRenderContextInfo);
Protected | procedure RenderPointFreed(Sender : TObject);
Protected | procedure SetGeomColorDynD(const Value: TGLColor);
Protected | procedure SetGeomColorDynE(const Value: TGLColor);
Protected | procedure SetGeomColorStat(const Value: TGLColor);
Protected | procedure SetGravity(value:TGLCoordinates);
Protected | procedure SetIterations(const val : Integer);
Protected | procedure SetMaxContacts(const Value : Integer);
Protected | procedure SetRenderPoint(const value : TGLRenderPoint);
Protected | procedure SetVisible(const Value: Boolean);
Protected | procedure SetVisibleAtRunTime(const Value: Boolean);
Protected | procedure UnregisterODEBehaviour(ODEBehaviour : TGLODEBehaviour);

Properties

Public | property ContactGroup : TdJointGroupID read FContactGroup;
Published | property GeomColorDynD: TGLColor read FGeomColorDynD write SetGeomColorDynD;
Published | property GeomColorDynE: TGLColor read FGeomColorDynE write SetGeomColorDynE;
Published | property GeomColorStat: TGLColor read FGeomColorStat write SetGeomColorStat;
Published | property Gravity : TGLCoordinates read FGravity write SetGravity;
Published | property Iterations : Integer read FIterations write SetIterations;
Published | property MaxContacts : Integer read FMaxContacts write SetMaxContacts;
Public | property NumContactJoints : integer read FNumContactJoints;
Protected | property ODEBehaviours[index : Integer]: TGLODEBehaviour read GetODEBehaviour;
Published | property OnCollision : TODECollisionEvent read FOnCollision write FOnCollision;
Published | property OnCustomCollision : TODECustomCollisionEvent read FOnCustomCollision write FOnCustomCollision;
Published | property RenderPoint : TGLRenderPoint read FRenderPoint write SetRenderPoint;
Published | property Solver : TODESolverMethod read FSolver write FSolver;
Public | property Space : PdxSpace read FSpace;
Published | property Visible : Boolean read FVisible write SetVisible;
Published | property VisibleAtRunTime : Boolean read FVisibleAtRunTime write SetVisibleAtRunTime;
Public | property World : PdxWorld read FWorld;

Description

Methods

Public constructor Create(AOwner:TComponent); override;
Public destructor Destroy; override;
Protected function GetODEBehaviour(index : Integer) : TGLODEBehaviour;
Public procedure NotifyChange(Sender : TObject);
Public procedure Step(deltaTime:double);
Protected procedure CalcContact(Object1, Object2 : TObject; var Contact:TdContact);
Protected procedure Collision(g1,g2:PdxGeom);
Protected procedure GeomColorChangeDynD(Sender: TObject);
Protected procedure GeomColorChangeDynE(Sender: TObject);
Protected procedure GeomColorChangeStat(Sender: TObject);
Protected procedure GravityChange(Sender:TObject);
Protected procedure Loaded; override;
Protected procedure RegisterODEBehaviour(ODEBehaviour : TGLODEBehaviour);
Protected procedure RenderEvent(Sender : TObject; var rci : TRenderContextInfo);
Protected procedure RenderPointFreed(Sender : TObject);
Protected procedure SetGeomColorDynD(const Value: TGLColor);
Protected procedure SetGeomColorDynE(const Value: TGLColor);
Protected procedure SetGeomColorStat(const Value: TGLColor);
Protected procedure SetGravity(value:TGLCoordinates);
Protected procedure SetIterations(const val : Integer);
Protected procedure SetMaxContacts(const Value : Integer);
Protected procedure SetRenderPoint(const value : TGLRenderPoint);
Protected procedure SetVisible(const Value: Boolean);
Protected procedure SetVisibleAtRunTime(const Value: Boolean);
Protected procedure UnregisterODEBehaviour(ODEBehaviour : TGLODEBehaviour);

Properties

Public property ContactGroup : TdJointGroupID read FContactGroup;
Published property GeomColorDynD: TGLColor read FGeomColorDynD write SetGeomColorDynD;
Published property GeomColorDynE: TGLColor read FGeomColorDynE write SetGeomColorDynE;
Published property GeomColorStat: TGLColor read FGeomColorStat write SetGeomColorStat;
Published property Gravity : TGLCoordinates read FGravity write SetGravity;
Published property Iterations : Integer read FIterations write SetIterations;
Published property MaxContacts : Integer read FMaxContacts write SetMaxContacts;
Public property NumContactJoints : integer read FNumContactJoints;
Protected property ODEBehaviours[index : Integer]: TGLODEBehaviour read GetODEBehaviour;
Published property OnCollision : TODECollisionEvent read FOnCollision write FOnCollision;
Published property OnCustomCollision : TODECustomCollisionEvent read FOnCustomCollision write FOnCustomCollision;
Published property RenderPoint : TGLRenderPoint read FRenderPoint write SetRenderPoint;
Published property Solver : TODESolverMethod read FSolver write FSolver;
Public property Space : PdxSpace read FSpace;
Published property Visible : Boolean read FVisible write SetVisible;
Published property VisibleAtRunTime : Boolean read FVisibleAtRunTime write SetVisibleAtRunTime;
Public property World : PdxWorld read FWorld;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODECollisionSurface

Class TODECollisionSurface

Unit

GLODEManager

Declaration

type TODECollisionSurface = class(TPersistent)

Description

Hierarchy

  • TPersistent
  • TODECollisionSurface

Overview

Methods

Public | constructor Create(AOwner : TPersistent);
Public | function GetOwner: TPersistent; override;
Protected | function GetBounce : TdReal;
Protected | function GetBounce_Vel : TdReal;
Protected | function GetMotion1 : TdReal;
Protected | function GetMotion2 : TdReal;
Protected | function GetMu : TdReal;
Protected | function GetMu2 : TdReal;
Protected | function GetSlip1 : TdReal;
Protected | function GetSlip2 : TdReal;
Protected | function GetSoftCFM : TdReal;
Protected | function GetSoftERP : TdReal;
Protected | function GetSurfaceMode : TSurfaceModes;
Public | procedure Assign(Source : TPersistent); override;
Protected | procedure ReadFromFiler(reader : TReader);
Protected | procedure SetBounce(value : TdReal);
Protected | procedure SetBounce_Vel(value : TdReal);
Protected | procedure SetMotion1(value : TdReal);
Protected | procedure SetMotion2(value : TdReal);
Protected | procedure SetMu(value : TdReal);
Protected | procedure SetMu2(value : TdReal);
Protected | procedure SetSlip1(value : TdReal);
Protected | procedure SetSlip2(value : TdReal);
Protected | procedure SetSoftCFM(value : TdReal);
Protected | procedure SetSoftERP(value : TdReal);
Protected | procedure SetSurfaceMode(value:TSurfaceModes);
Protected | procedure WriteToFiler(writer : TWriter);

Properties

Published | property Bounce : TdReal read GetBounce write SetBounce;
Published | property Bounce_Vel : TdReal read GetBounce_Vel write SetBounce_Vel;
Published | property Motion1 : TdReal read GetMotion1 write SetMotion1;
Published | property Motion2 : TdReal read GetMotion2 write SetMotion2;
Published | property Mu : TdReal read GetMu write SetMu;
Published | property Mu2 : TdReal read GetMu2 write SetMu2;
Published | property RollingFrictionCoeff : Single read FRFCoeff write FRFCoeff;
Published | property RollingFrictionEnabled : Boolean read FRFEnabled write FRFEnabled;
Published | property Slip1 : TdReal read GetSlip1 write SetSlip1;
Published | property Slip2 : TdReal read GetSlip2 write SetSlip2;
Published | property SoftCFM : TdReal read GetSoftCFM write SetSoftCFM;
Published | property SoftERP : TdReal read GetSoftERP write SetSoftERP;
Published | property SurfaceMode : TSurfaceModes read GetSurfaceMode write SetSurfaceMode;

Description

Methods

Public constructor Create(AOwner : TPersistent);
Public function GetOwner: TPersistent; override;
Protected function GetBounce : TdReal;
Protected function GetBounce_Vel : TdReal;
Protected function GetMotion1 : TdReal;
Protected function GetMotion2 : TdReal;
Protected function GetMu : TdReal;
Protected function GetMu2 : TdReal;
Protected function GetSlip1 : TdReal;
Protected function GetSlip2 : TdReal;
Protected function GetSoftCFM : TdReal;
Protected function GetSoftERP : TdReal;
Protected function GetSurfaceMode : TSurfaceModes;
Public procedure Assign(Source : TPersistent); override;
Protected procedure ReadFromFiler(reader : TReader);
Protected procedure SetBounce(value : TdReal);
Protected procedure SetBounce_Vel(value : TdReal);
Protected procedure SetMotion1(value : TdReal);
Protected procedure SetMotion2(value : TdReal);
Protected procedure SetMu(value : TdReal);
Protected procedure SetMu2(value : TdReal);
Protected procedure SetSlip1(value : TdReal);
Protected procedure SetSlip2(value : TdReal);
Protected procedure SetSoftCFM(value : TdReal);
Protected procedure SetSoftERP(value : TdReal);
Protected procedure SetSurfaceMode(value:TSurfaceModes);
Protected procedure WriteToFiler(writer : TWriter);

Properties

Published property Bounce : TdReal read GetBounce write SetBounce;
Published property Bounce_Vel : TdReal read GetBounce_Vel write SetBounce_Vel;
Published property Motion1 : TdReal read GetMotion1 write SetMotion1;
Published property Motion2 : TdReal read GetMotion2 write SetMotion2;
Published property Mu : TdReal read GetMu write SetMu;
Published property Mu2 : TdReal read GetMu2 write SetMu2;
Published property RollingFrictionCoeff : Single read FRFCoeff write FRFCoeff;
Published property RollingFrictionEnabled : Boolean read FRFEnabled write FRFEnabled;
Published property Slip1 : TdReal read GetSlip1 write SetSlip1;
Published property Slip2 : TdReal read GetSlip2 write SetSlip2;
Published property SoftCFM : TdReal read GetSoftCFM write SetSoftCFM;
Published property SoftERP : TdReal read GetSoftERP write SetSoftERP;
Published property SurfaceMode : TSurfaceModes read GetSurfaceMode write SetSurfaceMode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TGLODEBehaviour

Class TGLODEBehaviour

Unit

GLODEManager

Declaration

type TGLODEBehaviour = class(TGLBehaviour)

Description

Basis structures for GLScene behaviour style implementations.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLODEBehaviour

Overview

Methods

Public | constructor Create(AOwner : TXCollection); override;
Public | destructor Destroy; override;
Protected | function GetAbsoluteMatrix : TMatrix;
Public | procedure NotifyChange(Sender : TObject);
Public | procedure Reinitialize;
Public | procedure Render(var rci : TRenderContextInfo); virtual;
Protected | procedure Finalize; virtual;
Protected | procedure Initialize; virtual;
Protected | procedure Loaded; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetManager(Value : TGLODEManager);
Protected | procedure SetSurface(value:TODECollisionSurface);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Public | property AbsoluteMatrix : TMatrix read GetAbsoluteMatrix;
Public | property Initialized : Boolean read FInitialized;
Published | property Manager : TGLODEManager read FManager write SetManager;
Published | property OnCollision : TODEObjectCollisionEvent read FOnCollision write FOnCollision;
Published | property Surface : TODECollisionSurface read FSurface write SetSurface;

Description

Methods

Public constructor Create(AOwner : TXCollection); override;
Public destructor Destroy; override;
Protected function GetAbsoluteMatrix : TMatrix;
Public procedure NotifyChange(Sender : TObject);
Public procedure Reinitialize;
Public procedure Render(var rci : TRenderContextInfo); virtual;
Protected procedure Finalize; virtual;
Protected procedure Initialize; virtual;
Protected procedure Loaded; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetManager(Value : TGLODEManager);
Protected procedure SetSurface(value:TODECollisionSurface);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Public property AbsoluteMatrix : TMatrix read GetAbsoluteMatrix;
Public property Initialized : Boolean read FInitialized;
Published property Manager : TGLODEManager read FManager write SetManager;
Published property OnCollision : TODEObjectCollisionEvent read FOnCollision write FOnCollision;
Published property Surface : TODECollisionSurface read FSurface write SetSurface;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TGLODEDynamic

Class TGLODEDynamic

Unit

GLODEManager

Declaration

type TGLODEDynamic = class(TGLODEBehaviour)

Description

no description available, TGLODEBehaviour description follows

Basis structures for GLScene behaviour style implementations.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLODEBehaviour
  • TGLODEDynamic

Overview

Methods

Public | constructor Create(AOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | function AddNewElement(AChild:TODEElementClass):TODEElementBase; dynamic;
Public | function CalculateMass : TdMass;
Public | class function FriendlyName : String; override;
Public | class function UniqueItem : Boolean; override;
Protected | function GetEnabled : Boolean;
Protected | function GetMass : TdMass;
Public | procedure AddForce(Force : TAffineVector);
Public | procedure AddForceAtPos(Force, Pos : TAffineVector);
Public | procedure AddForceAtRelPos(Force, Pos : TAffineVector);
Public | procedure AddRelForce(Force : TAffineVector);
Public | procedure AddRelForceAtPos(Force, Pos : TAffineVector);
Public | procedure AddRelForceAtRelPos(Force, Pos : TAffineVector);
Public | procedure AddRelTorque(Torque : TAffineVector);
Public | procedure AddTorque(Torque : TAffineVector);
Public | procedure AlignObject;
Public | procedure CalibrateCenterOfMass;
Public | procedure Render(var rci : TRenderContextInfo); override;
Protected | procedure AlignBodyToMatrix(Mat: TMatrix);
Protected | procedure Finalize; override;
Protected | procedure Initialize; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure RegisterJoint(Joint : TODEJointBase);
Protected | procedure SetEnabled(const Value : Boolean);
Protected | procedure SetMass(const Value : TdMass);
Protected | procedure UnregisterJoint(Joint : TODEJointBase);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Public | property Body : PdxBody read FBody;
Published | property Elements : TODEElements read FElements;
Published | property Enabled : Boolean read GetEnabled write SetEnabled;
Public | property Mass : TdMass read GetMass write SetMass;

Description

Methods

Public constructor Create(AOwner : TXCollection); override;
Public destructor Destroy; override;
Public function AddNewElement(AChild:TODEElementClass):TODEElementBase; dynamic;
Public function CalculateMass : TdMass;
Public class function FriendlyName : String; override;
Public class function UniqueItem : Boolean; override;
Protected function GetEnabled : Boolean;
Protected function GetMass : TdMass;
Public procedure AddForce(Force : TAffineVector);
Public procedure AddForceAtPos(Force, Pos : TAffineVector);
Public procedure AddForceAtRelPos(Force, Pos : TAffineVector);
Public procedure AddRelForce(Force : TAffineVector);
Public procedure AddRelForceAtPos(Force, Pos : TAffineVector);
Public procedure AddRelForceAtRelPos(Force, Pos : TAffineVector);
Public procedure AddRelTorque(Torque : TAffineVector);
Public procedure AddTorque(Torque : TAffineVector);
Public procedure AlignObject;
Public procedure CalibrateCenterOfMass;
Public procedure Render(var rci : TRenderContextInfo); override;
Protected procedure AlignBodyToMatrix(Mat: TMatrix);
Protected procedure Finalize; override;
Protected procedure Initialize; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure RegisterJoint(Joint : TODEJointBase);
Protected procedure SetEnabled(const Value : Boolean);
Protected procedure SetMass(const Value : TdMass);
Protected procedure UnregisterJoint(Joint : TODEJointBase);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Public property Body : PdxBody read FBody;
Published property Elements : TODEElements read FElements;
Published property Enabled : Boolean read GetEnabled write SetEnabled;
Public property Mass : TdMass read GetMass write SetMass;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TGLODEStatic

Class TGLODEStatic

Unit

GLODEManager

Declaration

type TGLODEStatic = class(TGLODEBehaviour)

Description

no description available, TGLODEBehaviour description follows

Basis structures for GLScene behaviour style implementations.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLODEBehaviour
  • TGLODEStatic

Overview

Methods

Public | constructor Create(AOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | function AddNewElement(AChild:TODEElementClass):TODEElementBase; dynamic;
Public | class function FriendlyName : String; override;
Public | class function UniqueItem : Boolean; override;
Public | procedure Render(var rci : TRenderContextInfo); override;
Protected | procedure AlignElements;
Protected | procedure Finalize; override;
Protected | procedure Initialize; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Elements : TODEElements read FElements;

Description

Methods

Public constructor Create(AOwner : TXCollection); override;
Public destructor Destroy; override;
Public function AddNewElement(AChild:TODEElementClass):TODEElementBase; dynamic;
Public class function FriendlyName : String; override;
Public class function UniqueItem : Boolean; override;
Public procedure Render(var rci : TRenderContextInfo); override;
Protected procedure AlignElements;
Protected procedure Finalize; override;
Protected procedure Initialize; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Elements : TODEElements read FElements;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEElements

Class TODEElements

Unit

GLODEManager

Declaration

type TODEElements = class(TXCollection)

Description

no description available, TXCollection description follows

Holds a list of TXCollectionItem objects.<p> This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList and persistence classes (XClasses & XLists), if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than Borland's lists and persistence mechanisms (and unlike Borland's, with polymorphism-support and full backward compatibility).

Hierarchy

  • TPersistent
  • TXCollection
  • TODEElements

Overview

Methods

Public | destructor Destroy; override;
Public | class function ItemsClass : TXCollectionItemClass; override;
Public | procedure Finalize;
Public | procedure Initialize;
Public | procedure NotifyChange(Sender : TObject);
Public | procedure Render(var rci : TRenderContextInfo);

Properties

Public property Element[index : integer]: TODEElementBase read GetElement;

Description

Methods

Public destructor Destroy; override;
Public class function ItemsClass : TXCollectionItemClass; override;
Public procedure Finalize;
Public procedure Initialize;
Public procedure NotifyChange(Sender : TObject);
Public procedure Render(var rci : TRenderContextInfo);

Properties

Public property Element[index : integer]: TODEElementBase read GetElement;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEElementBase

Class TODEElementBase

Unit

GLODEManager

Declaration

type TODEElementBase = class(TXCollectionItem)

Description

no description available, TXCollectionItem description follows

Base class for implementing a XCollection item.<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation </ul>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TODEElementBase

Overview

Methods

Public | constructor Create(AOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | function AbsoluteMatrix:TMatrix;
Public | function AbsolutePosition:TAffineVector;
Protected | function CalculateMass : TdMass; virtual;
Protected | function GetMatrix: TMatrix;
Protected | function IsODEInitialized : Boolean;
Public | procedure Render(var rci : TRenderContextInfo); virtual;
Protected | procedure AlignGeomElementToMatrix(Mat:TMatrix); virtual;
Protected | procedure CoordinateChanged(Sender : TObject);
Protected | procedure Finalize; virtual;
Protected | procedure Initialize; virtual;
Protected | procedure NotifyChange(Sender:TObject);
Protected | procedure ODERebuild; virtual;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure RebuildMatrix;
Protected | procedure RebuildVectors;
Protected | procedure SetDensity(const Value: TdReal);
Protected | procedure SetDirection(const Value : TGLCoordinates);
Protected | procedure SetGeomElement(aGeom : PdxGeom);
Protected | procedure SetMatrix(const Value: TMatrix);
Protected | procedure SetPosition(const Value : TGLCoordinates);
Protected | procedure SetUp(const Value : TGLCoordinates);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property Density : TdReal read FDensity write SetDensity;
Published | property Direction : TGLCoordinates read FDirection write SetDirection;
Public | property Geom : PdxGeom read FGeomElement;
Public | property GeomTransform : PdxGeom read FGeomTransform;
Public | property Initialized : Boolean read FInitialized;
Public | property Matrix : TMatrix read GetMatrix write SetMatrix;
Published | property Position : TGLCoordinates read FPosition write SetPosition;
Published | property Up : TGLCoordinates read FUp write SetUp;

Description

Methods

Public constructor Create(AOwner : TXCollection); override;
Public destructor Destroy; override;
Public function AbsoluteMatrix:TMatrix;
Public function AbsolutePosition:TAffineVector;
Protected function CalculateMass : TdMass; virtual;
Protected function GetMatrix: TMatrix;
Protected function IsODEInitialized : Boolean;
Public procedure Render(var rci : TRenderContextInfo); virtual;
Protected procedure AlignGeomElementToMatrix(Mat:TMatrix); virtual;
Protected procedure CoordinateChanged(Sender : TObject);
Protected procedure Finalize; virtual;
Protected procedure Initialize; virtual;
Protected procedure NotifyChange(Sender:TObject);
Protected procedure ODERebuild; virtual;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure RebuildMatrix;
Protected procedure RebuildVectors;
Protected procedure SetDensity(const Value: TdReal);
Protected procedure SetDirection(const Value : TGLCoordinates);
Protected procedure SetGeomElement(aGeom : PdxGeom);
Protected procedure SetMatrix(const Value: TMatrix);
Protected procedure SetPosition(const Value : TGLCoordinates);
Protected procedure SetUp(const Value : TGLCoordinates);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Density : TdReal read FDensity write SetDensity;
Published property Direction : TGLCoordinates read FDirection write SetDirection;
Public property Geom : PdxGeom read FGeomElement;
Public property GeomTransform : PdxGeom read FGeomTransform;
Public property Initialized : Boolean read FInitialized;
Public property Matrix : TMatrix read GetMatrix write SetMatrix;
Published property Position : TGLCoordinates read FPosition write SetPosition;
Published property Up : TGLCoordinates read FUp write SetUp;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEElementBox

Class TODEElementBox

Unit

GLODEManager

Declaration

type TODEElementBox = class(TODEElementBase)

Description

ODE box implementation.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TODEElementBase
  • TODEElementBox

Overview

Methods

Public | constructor Create(AOwner : TXCollection); override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Public | class function ItemCategory : String; override;
Protected | function CalculateMass : TdMass; override;
Protected | function GetBoxDepth : TdReal;
Protected | function GetBoxHeight : TdReal;
Protected | function GetBoxWidth : TdReal;
Public | procedure Render(var rci : TRenderContextInfo); override;
Protected | procedure Initialize; override;
Protected | procedure ODERebuild; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetBoxDepth(const Value: TdReal);
Protected | procedure SetBoxHeight(const Value: TdReal);
Protected | procedure SetBoxWidth(const Value: TdReal);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property BoxDepth : TdReal read GetBoxDepth write SetBoxDepth;
Published | property BoxHeight : TdReal read GetBoxHeight write SetBoxHeight;
Published | property BoxWidth : TdReal read GetBoxWidth write SetBoxWidth;

Description

Methods

Public constructor Create(AOwner : TXCollection); override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Public class function ItemCategory : String; override;
Protected function CalculateMass : TdMass; override;
Protected function GetBoxDepth : TdReal;
Protected function GetBoxHeight : TdReal;
Protected function GetBoxWidth : TdReal;
Public procedure Render(var rci : TRenderContextInfo); override;
Protected procedure Initialize; override;
Protected procedure ODERebuild; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetBoxDepth(const Value: TdReal);
Protected procedure SetBoxHeight(const Value: TdReal);
Protected procedure SetBoxWidth(const Value: TdReal);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property BoxDepth : TdReal read GetBoxDepth write SetBoxDepth;
Published property BoxHeight : TdReal read GetBoxHeight write SetBoxHeight;
Published property BoxWidth : TdReal read GetBoxWidth write SetBoxWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEElementSphere

Class TODEElementSphere

Unit

GLODEManager

Declaration

type TODEElementSphere = class(TODEElementBase)

Description

ODE sphere implementation.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TODEElementBase
  • TODEElementSphere

Overview

Methods

Public | constructor Create(AOwner : TXCollection); override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Public | class function ItemCategory : String; override;
Protected | function CalculateMass : TdMass; override;
Protected | function GetRadius : TdReal;
Public | procedure Render(var rci : TRenderContextInfo); override;
Protected | procedure Initialize; override;
Protected | procedure ODERebuild; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetRadius(const Value: TdReal);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Radius : TdReal read GetRadius write SetRadius;

Description

Methods

Public constructor Create(AOwner : TXCollection); override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Public class function ItemCategory : String; override;
Protected function CalculateMass : TdMass; override;
Protected function GetRadius : TdReal;
Public procedure Render(var rci : TRenderContextInfo); override;
Protected procedure Initialize; override;
Protected procedure ODERebuild; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetRadius(const Value: TdReal);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Radius : TdReal read GetRadius write SetRadius;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEElementCapsule

Class TODEElementCapsule

Unit

GLODEManager

Declaration

type TODEElementCapsule = class(TODEElementBase)

Description

ODE capped cylinder implementation.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TODEElementBase
  • TODEElementCapsule

Overview

Methods

Public | constructor Create(AOwner : TXCollection); override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Public | class function ItemCategory : String; override;
Protected | function CalculateMass : TdMass; override;
Protected | function GetLength : TdReal;
Protected | function GetRadius : TdReal;
Public | procedure Render(var rci : TRenderContextInfo); override;
Protected | procedure Initialize; override;
Protected | procedure ODERebuild; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetLength(const Value: TdReal);
Protected | procedure SetRadius(const Value: TdReal);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property Length : TdReal read GetLength write SetLength;
Published | property Radius : TdReal read GetRadius write SetRadius;

Description

Methods

Public constructor Create(AOwner : TXCollection); override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Public class function ItemCategory : String; override;
Protected function CalculateMass : TdMass; override;
Protected function GetLength : TdReal;
Protected function GetRadius : TdReal;
Public procedure Render(var rci : TRenderContextInfo); override;
Protected procedure Initialize; override;
Protected procedure ODERebuild; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetLength(const Value: TdReal);
Protected procedure SetRadius(const Value: TdReal);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Length : TdReal read GetLength write SetLength;
Published property Radius : TdReal read GetRadius write SetRadius;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEElementCylinder

Class TODEElementCylinder

Unit

GLODEManager

Declaration

type TODEElementCylinder = class(TODEElementBase)

Description

ODE cylinder implementation.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TODEElementBase
  • TODEElementCylinder

Overview

Methods

Public | constructor Create(AOwner:TXCollection); override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Public | class function ItemCategory : String; override;
Protected | function CalculateMass : TdMass; override;
Protected | function GetLength : TdReal;
Protected | function GetRadius : TdReal;
Public | procedure Render(var rci : TRenderContextInfo); override;
Protected | procedure Initialize; override;
Protected | procedure ODERebuild; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetLength(const Value: TdReal);
Protected | procedure SetRadius(const Value: TdReal);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property Length : TdReal read GetLength write SetLength;
Published | property Radius : TdReal read GetRadius write SetRadius;

Description

Methods

Public constructor Create(AOwner:TXCollection); override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Public class function ItemCategory : String; override;
Protected function CalculateMass : TdMass; override;
Protected function GetLength : TdReal;
Protected function GetRadius : TdReal;
Public procedure Render(var rci : TRenderContextInfo); override;
Protected procedure Initialize; override;
Protected procedure ODERebuild; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetLength(const Value: TdReal);
Protected procedure SetRadius(const Value: TdReal);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Length : TdReal read GetLength write SetLength;
Published property Radius : TdReal read GetRadius write SetRadius;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEElementTriMesh

Class TODEElementTriMesh

Unit

GLODEManager

Declaration

type TODEElementTriMesh = class(TODEElementBase)

Description

ODE tri-mesh implementation.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TODEElementBase
  • TODEElementTriMesh

Overview

Methods

Public | constructor Create(AOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Public | class function ItemCategory : String; override;
Protected | function CalculateMass : TdMass; override;
Public | procedure RefreshTriMeshData;
Protected | procedure Finalize; override;
Protected | procedure Initialize; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetIndices(const Value : TIntegerList);
Protected | procedure SetVertices(const Value : TAffineVectorList);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Public | property Indices : TIntegerList read FIndices write SetIndices;
Public | property Vertices : TAffineVectorList read FVertices write SetVertices;

Description

Methods

Public constructor Create(AOwner : TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Public class function ItemCategory : String; override;
Protected function CalculateMass : TdMass; override;
Public procedure RefreshTriMeshData;
Protected procedure Finalize; override;
Protected procedure Initialize; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetIndices(const Value : TIntegerList);
Protected procedure SetVertices(const Value : TAffineVectorList);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Public property Indices : TIntegerList read FIndices write SetIndices;
Public property Vertices : TAffineVectorList read FVertices write SetVertices;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEElementPlane

Class TODEElementPlane

Unit

GLODEManager

Declaration

type TODEElementPlane = class(TODEElementBase)

Description

ODE plane implementation.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TODEElementBase
  • TODEElementPlane

Overview

Methods

Public | class function CanAddTo(collection : TXCollection) : Boolean; override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Public | class function ItemCategory : String; override;
Protected | procedure AlignGeomElementToMatrix(Mat:TMatrix); override;
Protected | procedure Initialize; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure WriteToFiler(writer : TWriter); override;

Description

Methods

Public class function CanAddTo(collection : TXCollection) : Boolean; override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Public class function ItemCategory : String; override;
Protected procedure AlignGeomElementToMatrix(Mat:TMatrix); override;
Protected procedure Initialize; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure WriteToFiler(writer : TWriter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEJoints

Class TODEJoints

Unit

GLODEManager

Declaration

type TODEJoints = class(TXCollection)

Description

An XCollection decendant for ODE Joints.

Hierarchy

  • TPersistent
  • TXCollection
  • TODEJoints

Overview

Methods

Public | class function ItemsClass : TXCollectionItemClass; override;
Protected | function GetJoint(index: integer): TODEJointBase;
Public | procedure Finalize;
Public | procedure Initialize;

Properties

Public property Joint[index:integer]: TODEJointBase read GetJoint;

Description

Methods

Public class function ItemsClass : TXCollectionItemClass; override;
Protected function GetJoint(index: integer): TODEJointBase;
Public procedure Finalize;
Public procedure Initialize;

Properties

Public property Joint[index:integer]: TODEJointBase read GetJoint;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TGLODEJointList

Class TGLODEJointList

Unit

GLODEManager

Declaration

type TGLODEJointList = class(TComponent)

Description

Component front-end for storing ODE Joints.

Hierarchy

  • TComponent
  • TGLODEJointList

Overview

Methods

Public | constructor Create(AOwner:TComponent); override;
Public | destructor Destroy; override;
Protected | procedure DefineProperties(Filer: TFiler); override;
Protected | procedure Loaded; override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure ReadJoints(stream : TStream);
Protected | procedure WriteJoints(stream : TStream);

Properties

Published property Joints : TODEJoints read FJoints;

Description

Methods

Public constructor Create(AOwner:TComponent); override;
Public destructor Destroy; override;
Protected procedure DefineProperties(Filer: TFiler); override;
Protected procedure Loaded; override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure ReadJoints(stream : TStream);
Protected procedure WriteJoints(stream : TStream);

Properties

Published property Joints : TODEJoints read FJoints;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEJointBase

Class TODEJointBase

Unit

GLODEManager

Declaration

type TODEJointBase = class(TXCollectionItem)

Description

Base structures for ODE Joints.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TODEJointBase

Overview

Methods

Public | constructor Create(aOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | function IsAttached : Boolean;
Protected | function IsODEInitialized : Boolean;
Public | procedure DoLoaded;
Public | procedure Finalize; virtual;
Public | procedure Initialize; virtual;
Public | procedure StructureChanged; virtual;
Protected | procedure Attach;
Protected | procedure Loaded; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure RegisterJointWithObject(Obj : TGLBaseSceneObject);
Protected | procedure SetEnabled(const Value : Boolean);
Protected | procedure SetJointOptions(const Value : TJointOptions);
Protected | procedure SetManager(const Value : TGLODEManager);
Protected | procedure SetObject1(const Value : TGLBaseSceneObject);
Protected | procedure SetObject2(const Value : TGLBaseSceneObject);
Protected | procedure UnregisterJointWithObject(Obj : TGLBaseSceneObject);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property Enabled : Boolean read FEnabled write SetEnabled;
Public | property Initialized : Boolean read FInitialized;
Public | property JointID : TdJointID read FJointID;
Protected | property JointOptions : TJointOptions read FJointOptions write SetJointOptions;
Published | property Manager : TGLODEManager read FManager write SetManager;
Published | property Object1 : TGLBaseSceneObject read FObject1 write SetObject1;
Published | property Object2 : TGLBaseSceneObject read FObject2 write SetObject2;

Description

Methods

Public constructor Create(aOwner : TXCollection); override;
Public destructor Destroy; override;
Public function IsAttached : Boolean;
Protected function IsODEInitialized : Boolean;
Public procedure DoLoaded;
Public procedure Finalize; virtual;
Public procedure Initialize; virtual;
Public procedure StructureChanged; virtual;
Protected procedure Attach;
Protected procedure Loaded; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure RegisterJointWithObject(Obj : TGLBaseSceneObject);
Protected procedure SetEnabled(const Value : Boolean);
Protected procedure SetJointOptions(const Value : TJointOptions);
Protected procedure SetManager(const Value : TGLODEManager);
Protected procedure SetObject1(const Value : TGLBaseSceneObject);
Protected procedure SetObject2(const Value : TGLBaseSceneObject);
Protected procedure UnregisterJointWithObject(Obj : TGLBaseSceneObject);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Enabled : Boolean read FEnabled write SetEnabled;
Public property Initialized : Boolean read FInitialized;
Public property JointID : TdJointID read FJointID;
Protected property JointOptions : TJointOptions read FJointOptions write SetJointOptions;
Published property Manager : TGLODEManager read FManager write SetManager;
Published property Object1 : TGLBaseSceneObject read FObject1 write SetObject1;
Published property Object2 : TGLBaseSceneObject read FObject2 write SetObject2;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEJointParams

Class TODEJointParams

Unit

GLODEManager

Declaration

type TODEJointParams = class(TPersistent)

Description

Hierarchy

  • TPersistent
  • TODEJointParams

Overview

Methods

Public | constructor Create(AOwner : TPersistent);
Public | function GetOwner : TPersistent; override;
Protected | function GetBounce : TdReal;
Protected | function GetCFM : TdReal;
Protected | function GetFMax : TdReal;
Protected | function GetFudgeFactor : TdReal;
Protected | function GetHiStop : TdReal;
Protected | function GetLoStop : TdReal;
Protected | function GetStopCFM : TdReal;
Protected | function GetStopERP : TdReal;
Protected | function GetSuspensionCFM : TdReal;
Protected | function GetSuspensionERP : TdReal;
Protected | function GetVel : TdReal;
Public | procedure ApplyFlagged;
Public | procedure Assign(Source : TPersistent); override;
Protected | procedure ReadFromFiler(reader : TReader);
Protected | procedure SetBounce(const Value : TdReal);
Protected | procedure SetCFM(const Value : TdReal);
Protected | procedure SetFMax(const Value : TdReal);
Protected | procedure SetFudgeFactor(const Value : TdReal);
Protected | procedure SetHiStop(const Value : TdReal);
Protected | procedure SetLoStop(const Value : TdReal);
Protected | procedure SetStopCFM(const Value : TdReal);
Protected | procedure SetStopERP(const Value : TdReal);
Protected | procedure SetSuspensionCFM(const Value : TdReal);
Protected | procedure SetSuspensionERP(const Value : TdReal);
Protected | procedure SetVel(const Value : TdReal);
Protected | procedure WriteToFiler(writer : TWriter);

Properties

Published | property Bounce : TdReal read GetBounce write SetBounce;
Published | property CFM : TdReal read GetCFM write SetCFM;
Published | property FMax : TdReal read GetFMax write SetFMax;
Published | property FudgeFactor : TdReal read GetFudgeFactor write SetFudgeFactor;
Public | property GetCallback : TODEGetParamCallback read FGetCallback write FGetCallback;
Published | property HiStop : TdReal read GetHiStop write SetHiStop;
Published | property LoStop : TdReal read GetLoStop write SetLoStop;
Public | property SetCallback : TODESetParamCallback read FSetCallback write FSetCallback;
Published | property StopCFM : TdReal read GetStopCFM write SetStopCFM;
Published | property StopERP : TdReal read GetStopERP write SetStopERP;
Published | property SuspensionCFM : TdReal read GetSuspensionCFM write SetSuspensionCFM;
Published | property SuspensionERP : TdReal read GetSuspensionERP write SetSuspensionERP;
Published | property Vel : TdReal read GetVel write SetVel;

Description

Methods

Public constructor Create(AOwner : TPersistent);
Public function GetOwner : TPersistent; override;
Protected function GetBounce : TdReal;
Protected function GetCFM : TdReal;
Protected function GetFMax : TdReal;
Protected function GetFudgeFactor : TdReal;
Protected function GetHiStop : TdReal;
Protected function GetLoStop : TdReal;
Protected function GetStopCFM : TdReal;
Protected function GetStopERP : TdReal;
Protected function GetSuspensionCFM : TdReal;
Protected function GetSuspensionERP : TdReal;
Protected function GetVel : TdReal;
Public procedure ApplyFlagged;
Public procedure Assign(Source : TPersistent); override;
Protected procedure ReadFromFiler(reader : TReader);
Protected procedure SetBounce(const Value : TdReal);
Protected procedure SetCFM(const Value : TdReal);
Protected procedure SetFMax(const Value : TdReal);
Protected procedure SetFudgeFactor(const Value : TdReal);
Protected procedure SetHiStop(const Value : TdReal);
Protected procedure SetLoStop(const Value : TdReal);
Protected procedure SetStopCFM(const Value : TdReal);
Protected procedure SetStopERP(const Value : TdReal);
Protected procedure SetSuspensionCFM(const Value : TdReal);
Protected procedure SetSuspensionERP(const Value : TdReal);
Protected procedure SetVel(const Value : TdReal);
Protected procedure WriteToFiler(writer : TWriter);

Properties

Published property Bounce : TdReal read GetBounce write SetBounce;
Published property CFM : TdReal read GetCFM write SetCFM;
Published property FMax : TdReal read GetFMax write SetFMax;
Published property FudgeFactor : TdReal read GetFudgeFactor write SetFudgeFactor;
Public property GetCallback : TODEGetParamCallback read FGetCallback write FGetCallback;
Published property HiStop : TdReal read GetHiStop write SetHiStop;
Published property LoStop : TdReal read GetLoStop write SetLoStop;
Public property SetCallback : TODESetParamCallback read FSetCallback write FSetCallback;
Published property StopCFM : TdReal read GetStopCFM write SetStopCFM;
Published property StopERP : TdReal read GetStopERP write SetStopERP;
Published property SuspensionCFM : TdReal read GetSuspensionCFM write SetSuspensionCFM;
Published property SuspensionERP : TdReal read GetSuspensionERP write SetSuspensionERP;
Published property Vel : TdReal read GetVel write SetVel;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEJointHinge

Class TODEJointHinge

Unit

GLODEManager

Declaration

type TODEJointHinge = class(TODEJointBase)

Description

ODE hinge joint implementation.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TODEJointBase
  • TODEJointHinge

Overview

Methods

Public | constructor Create(aOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Protected | function GetAxisParam(Param : Integer; var Value : TdReal) : Boolean;
Protected | function SetAxisParam(Param : Integer; const Value : TdReal) : Boolean;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;
Protected | procedure AnchorChange(Sender : TObject);
Protected | procedure AxisChange(Sender : TObject);
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetAnchor(const Value : TGLCoordinates);
Protected | procedure SetAxis(const Value : TGLCoordinates);
Protected | procedure SetAxisParams(const Value : TODEJointParams);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property Anchor : TGLCoordinates read FAnchor write SetAnchor;
Published | property Axis : TGLCoordinates read FAxis write SetAxis;
Published | property AxisParams : TODEJointParams read FAxisParams write SetAxisParams;

Description

Methods

Public constructor Create(aOwner : TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Protected function GetAxisParam(Param : Integer; var Value : TdReal) : Boolean;
Protected function SetAxisParam(Param : Integer; const Value : TdReal) : Boolean;
Public procedure Initialize; override;
Public procedure StructureChanged; override;
Protected procedure AnchorChange(Sender : TObject);
Protected procedure AxisChange(Sender : TObject);
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetAnchor(const Value : TGLCoordinates);
Protected procedure SetAxis(const Value : TGLCoordinates);
Protected procedure SetAxisParams(const Value : TODEJointParams);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Anchor : TGLCoordinates read FAnchor write SetAnchor;
Published property Axis : TGLCoordinates read FAxis write SetAxis;
Published property AxisParams : TODEJointParams read FAxisParams write SetAxisParams;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEJointBall

Class TODEJointBall

Unit

GLODEManager

Declaration

type TODEJointBall = class(TODEJointBase)

Description

ODE ball joint implementation.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TODEJointBase
  • TODEJointBall

Overview

Methods

Public | constructor Create(aOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;
Protected | procedure AnchorChange(Sender : TObject);
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetAnchor(const Value : TGLCoordinates);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Anchor : TGLCoordinates read FAnchor write SetAnchor;

Description

Methods

Public constructor Create(aOwner : TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Public procedure Initialize; override;
Public procedure StructureChanged; override;
Protected procedure AnchorChange(Sender : TObject);
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetAnchor(const Value : TGLCoordinates);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Anchor : TGLCoordinates read FAnchor write SetAnchor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEJointSlider

Class TODEJointSlider

Unit

GLODEManager

Declaration

type TODEJointSlider = class(TODEJointBase)

Description

ODE slider joint implementation.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TODEJointBase
  • TODEJointSlider

Overview

Methods

Public | constructor Create(aOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Protected | function GetAxisParam(Param : Integer; var Value : TdReal) : Boolean;
Protected | function SetAxisParam(Param : Integer; const Value : TdReal) : Boolean;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;
Protected | procedure AxisChange(Sender : TObject);
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetAxis(const Value : TGLCoordinates);
Protected | procedure SetAxisParams(const Value : TODEJointParams);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property Axis : TGLCoordinates read FAxis write SetAxis;
Published | property AxisParams : TODEJointParams read FAxisParams write SetAxisParams;

Description

Methods

Public constructor Create(aOwner : TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Protected function GetAxisParam(Param : Integer; var Value : TdReal) : Boolean;
Protected function SetAxisParam(Param : Integer; const Value : TdReal) : Boolean;
Public procedure Initialize; override;
Public procedure StructureChanged; override;
Protected procedure AxisChange(Sender : TObject);
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetAxis(const Value : TGLCoordinates);
Protected procedure SetAxisParams(const Value : TODEJointParams);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Axis : TGLCoordinates read FAxis write SetAxis;
Published property AxisParams : TODEJointParams read FAxisParams write SetAxisParams;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEJointFixed

Class TODEJointFixed

Unit

GLODEManager

Declaration

type TODEJointFixed = class(TODEJointBase)

Description

ODE fixed joint implementation.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TODEJointBase
  • TODEJointFixed

Overview

Methods

Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Public | procedure Initialize; override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure WriteToFiler(writer : TWriter); override;

Description

Methods

Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Public procedure Initialize; override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure WriteToFiler(writer : TWriter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:35


GLScene v.1.1.2: GLODEManager: Class TODEJointHinge2

Class TODEJointHinge2

Unit

GLODEManager

Declaration

type TODEJointHinge2 = class(TODEJointBase)

Description

ODE hinge2 joint implementation.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TODEJointBase
  • TODEJointHinge2

Overview

Methods

Public | constructor Create(aOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Protected | function GetAxis1Param(Param : Integer; var Value : TdReal) : Boolean;
Protected | function GetAxis2Param(Param : Integer; var Value : TdReal) : Boolean;
Protected | function SetAxis1Param(Param : Integer; const Value : TdReal) : Boolean;
Protected | function SetAxis2Param(Param : Integer; const Value : TdReal) : Boolean;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;
Protected | procedure AnchorChange(Sender : TObject);
Protected | procedure Axis1Change(Sender : TObject);
Protected | procedure Axis2Change(Sender : TObject);
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetAnchor(const Value : TGLCoordinates);
Protected | procedure SetAxis1(const Value : TGLCoordinates);
Protected | procedure SetAxis1Params(const Value : TODEJointParams);
Protected | procedure SetAxis2(const Value : TGLCoordinates);
Protected | procedure SetAxis2Params(const Value : TODEJointParams);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property Anchor : TGLCoordinates read FAnchor write SetAnchor;
Published | property Axis1 : TGLCoordinates read FAxis1 write SetAxis1;
Published | property Axis1Params : TODEJointParams read FAxis1Params write SetAxis1Params;
Published | property Axis2 : TGLCoordinates read FAxis2 write SetAxis2;
Published | property Axis2Params : TODEJointParams read FAxis2Params write SetAxis2Params;

Description

Methods

Public constructor Create(aOwner : TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Protected function GetAxis1Param(Param : Integer; var Value : TdReal) : Boolean;
Protected function GetAxis2Param(Param : Integer; var Value : TdReal) : Boolean;
Protected function SetAxis1Param(Param : Integer; const Value : TdReal) : Boolean;
Protected function SetAxis2Param(Param : Integer; const Value : TdReal) : Boolean;
Public procedure Initialize; override;
Public procedure StructureChanged; override;
Protected procedure AnchorChange(Sender : TObject);
Protected procedure Axis1Change(Sender : TObject);
Protected procedure Axis2Change(Sender : TObject);
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetAnchor(const Value : TGLCoordinates);
Protected procedure SetAxis1(const Value : TGLCoordinates);
Protected procedure SetAxis1Params(const Value : TODEJointParams);
Protected procedure SetAxis2(const Value : TGLCoordinates);
Protected procedure SetAxis2Params(const Value : TODEJointParams);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Anchor : TGLCoordinates read FAnchor write SetAnchor;
Published property Axis1 : TGLCoordinates read FAxis1 write SetAxis1;
Published property Axis1Params : TODEJointParams read FAxis1Params write SetAxis1Params;
Published property Axis2 : TGLCoordinates read FAxis2 write SetAxis2;
Published property Axis2Params : TODEJointParams read FAxis2Params write SetAxis2Params;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODEManager: Class TODEJointUniversal

Class TODEJointUniversal

Unit

GLODEManager

Declaration

type TODEJointUniversal = class(TODEJointBase)

Description

ODE universal joint implementation.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TODEJointBase
  • TODEJointUniversal

Overview

Methods

Public | constructor Create(aOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Protected | function GetAxis1Param(Param : Integer; var Value : TdReal) : Boolean;
Protected | function GetAxis2Param(Param : Integer; var Value : TdReal) : Boolean;
Protected | function SetAxis1Param(Param : Integer; const Value : TdReal) : Boolean;
Protected | function SetAxis2Param(Param : Integer; const Value : TdReal) : Boolean;
Public | procedure Initialize; override;
Public | procedure StructureChanged; override;
Protected | procedure AnchorChange(Sender : TObject);
Protected | procedure Axis1Change(Sender : TObject);
Protected | procedure Axis2Change(Sender : TObject);
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetAnchor(const Value : TGLCoordinates);
Protected | procedure SetAxis1(const Value : TGLCoordinates);
Protected | procedure SetAxis1Params(const Value : TODEJointParams);
Protected | procedure SetAxis2(const Value : TGLCoordinates);
Protected | procedure SetAxis2Params(const Value : TODEJointParams);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property Anchor : TGLCoordinates read FAnchor write SetAnchor;
Published | property Axis1 : TGLCoordinates read FAxis1 write SetAxis1;
Published | property Axis1Params : TODEJointParams read FAxis1Params write SetAxis1Params;
Published | property Axis2 : TGLCoordinates read FAxis2 write SetAxis2;
Published | property Axis2Params : TODEJointParams read FAxis2Params write SetAxis2Params;

Description

Methods

Public constructor Create(aOwner : TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Protected function GetAxis1Param(Param : Integer; var Value : TdReal) : Boolean;
Protected function GetAxis2Param(Param : Integer; var Value : TdReal) : Boolean;
Protected function SetAxis1Param(Param : Integer; const Value : TdReal) : Boolean;
Protected function SetAxis2Param(Param : Integer; const Value : TdReal) : Boolean;
Public procedure Initialize; override;
Public procedure StructureChanged; override;
Protected procedure AnchorChange(Sender : TObject);
Protected procedure Axis1Change(Sender : TObject);
Protected procedure Axis2Change(Sender : TObject);
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetAnchor(const Value : TGLCoordinates);
Protected procedure SetAxis1(const Value : TGLCoordinates);
Protected procedure SetAxis1Params(const Value : TODEJointParams);
Protected procedure SetAxis2(const Value : TGLCoordinates);
Protected procedure SetAxis2Params(const Value : TODEJointParams);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Anchor : TGLCoordinates read FAnchor write SetAnchor;
Published property Axis1 : TGLCoordinates read FAxis1 write SetAxis1;
Published property Axis1Params : TODEJointParams read FAxis1Params write SetAxis1Params;
Published property Axis2 : TGLCoordinates read FAxis2 write SetAxis2;
Published property Axis2Params : TODEJointParams read FAxis2Params write SetAxis2Params;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODERagdoll

Unit GLODERagdoll

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLODERagdoll<p>

TGLRagdoll extended using Open Dynamics Engine (ODE). <p>

<b>History :</b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: used records with arrays instead of vector arrays <li>13/07/08 - Mrqzzz - replaced constants "cDensity" and "cMass" with global vars "vGLODERagdoll_cDensity" and "vGLODERagdoll_cMass" <li>11/05/08 - Mrqzzz - replaced TGLCube with TODERagdollCube (contains reference to Bone and Ragdoll, useful in collision events) <li>28/02/08 - Mrqzzz - prevent ODE 0.9 "bNormalizationResult failed" error in TODERagdollBone.Start. Fixed a memory leak in TODERagdollBone.Stop <li>05/02/08 - Mrqzzz - upgrade to ODE 0.9 (by paul Robello) <li>09/11/05 - LucasG - Fixed joints to be relative to the body <li>07/11/05 - LucasG - Alignment (Using Stuart's AlignToMatrix function) <li>02/11/05 - LucasG - First version created. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TODERagdollCube |
Class TODERagdollWorld |
Class TODERagdollDummyJoint |
Class TODERagdollHingeJoint |
Class TODERagdollUniversalJoint |
Class TODERagdollBone |
Class TODERagdoll |

Constants

cMaxContacts = 4;

Variables

vGLODERagdoll_cDensity: Single;
vGLODERagdoll_cMass: Single;

Description

Constants

cMaxContacts = 4;

Variables

vGLODERagdoll_cDensity: Single;
vGLODERagdoll_cMass: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODERagdoll: Class TODERagdollCube

Class TODERagdollCube

Unit

GLODERagdoll

Declaration

type TODERagdollCube = class(TGLCube)

Description

no description available, TGLCube description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLCube
  • TODERagdollCube

Overview

Fields

Public | Bone:TODERagdollBone;
Public | Ragdoll:TODERagdoll;

Description

Fields

Public Bone:TODERagdollBone;
Public Ragdoll:TODERagdoll;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODERagdoll: Class TODERagdollWorld

Class TODERagdollWorld

Unit

GLODERagdoll

Declaration

type TODERagdollWorld = class(TObject)

Description

Hierarchy

  • TObject
  • TODERagdollWorld

Overview

Methods

Public | constructor Create;
Public | constructor CreateFrom(World: PdxWorld; Space: PdxSpace; ContactGroup: TdJointGroupID);
Public | destructor Destroy; override;
Public | procedure WorldUpdate;

Properties

Public | property ContactGroup: TdJointGroupID read FContactGroup;
Public | property Ragdoll: TODERagdoll read FRagdoll;
Public | property Space: PdxSpace read FSpace;
Public | property World: PdxWorld read FWorld;

Description

Methods

Public constructor Create;
Public constructor CreateFrom(World: PdxWorld; Space: PdxSpace; ContactGroup: TdJointGroupID);

Create the world from any existing ODE world

Public destructor Destroy; override;
Public procedure WorldUpdate;

Properties

Public property ContactGroup: TdJointGroupID read FContactGroup;
Public property Ragdoll: TODERagdoll read FRagdoll;
Public property Space: PdxSpace read FSpace;
Public property World: PdxWorld read FWorld;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODERagdoll: Class TODERagdollDummyJoint

Class TODERagdollDummyJoint

Unit

GLODERagdoll

Declaration

type TODERagdollDummyJoint = class(TRagdollJoint)

Description

no description available, TRagdollJoint description follows

Hierarchy

  • TObject
  • TRagdollJoint
  • TODERagdollDummyJoint
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODERagdoll: Class TODERagdollHingeJoint

Class TODERagdollHingeJoint

Unit

GLODERagdoll

Declaration

type TODERagdollHingeJoint = class(TRagdollJoint)

Description

no description available, TRagdollJoint description follows

Hierarchy

  • TObject
  • TRagdollJoint
  • TODERagdollHingeJoint

Overview

Methods

Public constructor Create(Axis: TAffineVector; ParamLoStop: Single; ParamHiStop: Single);

Properties

Public | property Axis : TAffineVector read FAxis;
Public | property ParamHiStop: Single read FParamHiStop write FParamHiStop;
Public | property ParamLoStop: Single read FParamLoStop write FParamLoStop;

Description

Methods

Public constructor Create(Axis: TAffineVector; ParamLoStop: Single; ParamHiStop: Single);

Properties

Public property Axis : TAffineVector read FAxis;
Public property ParamHiStop: Single read FParamHiStop write FParamHiStop;
Public property ParamLoStop: Single read FParamLoStop write FParamLoStop;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODERagdoll: Class TODERagdollUniversalJoint

Class TODERagdollUniversalJoint

Unit

GLODERagdoll

Declaration

type TODERagdollUniversalJoint = class(TODERagdollHingeJoint)

Description

no description available, TODERagdollHingeJoint description follows
no description available, TRagdollJoint description follows

Hierarchy

  • TObject
  • TRagdollJoint
  • TODERagdollHingeJoint
  • TODERagdollUniversalJoint

Overview

Methods

Public constructor Create(Axis: TAffineVector; ParamLoStop: Single; ParamHiStop: Single; Axis2: TAffineVector; ParamLoStop2: Single; ParamHiStop2: Single);

Properties

Public | property Axis2 : TAffineVector read FAxis2;
Public | property ParamHiStop2: Single read FParamHiStop2 write FParamHiStop2;
Public | property ParamLoStop2: Single read FParamLoStop2 write FParamLoStop2;

Description

Methods

Public constructor Create(Axis: TAffineVector; ParamLoStop: Single; ParamHiStop: Single; Axis2: TAffineVector; ParamLoStop2: Single; ParamHiStop2: Single);

Properties

Public property Axis2 : TAffineVector read FAxis2;
Public property ParamHiStop2: Single read FParamHiStop2 write FParamHiStop2;
Public property ParamLoStop2: Single read FParamLoStop2 write FParamLoStop2;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODERagdoll: Class TODERagdollBone

Class TODERagdollBone

Unit

GLODERagdoll

Declaration

type TODERagdollBone = class(TRagdollBone)

Description

no description available, TRagdollBone description follows
no description available, TRagdollBoneList description follows
no description available, TPersistentObjectList description follows

A persistent Object list.<p> Similar to TList but works on TObject items and has facilities for persistence of contained data. Unlike the VCL's TObjectList, this one does NOT free its objects upon destruction or Clear, use Clean and CleanFree for that, and as such can be used for object referral lists too.<br> But only TPersistentObject items will be streamed appropriately.<p> The list can be used in a stack-like fashion with Push & Pop, and can perform basic boolean set operations.<p> Note: the IndexOf implementation is up to 3 times faster than that of TList

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TRagdollBoneList
  • TRagdollBone
  • TODERagdollBone

Overview

Methods

Public | constructor Create(Ragdoll: TODERagdoll);
Public | constructor CreateOwned(aOwner : TODERagdollBone);
Protected | procedure Align; override;
Protected | procedure Start; override;
Protected | procedure Stop; override;
Protected | procedure Update; override;

Properties

Public | property Body: PdxBody read FBody;
Public | property Geom: PdxGeom read FGeom;

Description

Methods

Public constructor Create(Ragdoll: TODERagdoll);
Public constructor CreateOwned(aOwner : TODERagdollBone);
Protected procedure Align; override;
Protected procedure Start; override;
Protected procedure Stop; override;
Protected procedure Update; override;

Properties

Public property Body: PdxBody read FBody;
Public property Geom: PdxGeom read FGeom;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODERagdoll: Class TODERagdoll

Class TODERagdoll

Unit

GLODERagdoll

Declaration

type TODERagdoll = class(TGLRagdoll)

Description

no description available, TGLRagdoll description follows
no description available, TPersistentObject description follows

Base class for persistent objects.<p> The base requirement is implementation of ReadFromFiler & WriteToFiler in sub-classes, the immediate benefits are support of streaming (to stream, file or string), assignment and cloning.<br> The other requirement being the use of a virtual constructor, which allows polymorphic construction (don't forget to register your subclasses).<p> Note that TPersistentObject implements IUnknown, but does *not* implement reference counting.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLRagdoll
  • TODERagdoll

Overview

Methods

Public constructor Create(AOwner : TGLBaseMesh);

Properties

Public | property GLSceneRoot: TGLBaseSceneObject read FGLSceneRoot write FGLSceneRoot;
Public | property ODEWorld: TODERagdollWorld read FODEWorld write FODEWorld;
Public | property ShowBoundingBoxes: Boolean read FShowBoundingBoxes write FShowBoundingBoxes;

Description

Methods

Public constructor Create(AOwner : TGLBaseMesh);

Properties

Public property GLSceneRoot: TGLBaseSceneObject read FGLSceneRoot write FGLSceneRoot;
Public property ODEWorld: TODERagdollWorld read FODEWorld write FODEWorld;
Public property ShowBoundingBoxes: Boolean read FShowBoundingBoxes write FShowBoundingBoxes;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODERegister

Unit GLODERegister

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODESkeletonColliders

Unit GLODESkeletonColliders

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLODESkeletonColliders<p>

Skeleton colliders for defining and controlling ODE geoms.<p>

<b>History :</b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: restored records with arrays instead of vector arrays <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>12/04/08 - DaStr - Cleaned up uses section (thanks Sandor Domokos) (BugtrackerID = 1808373) <li>06/02/08 - Mrqzzz - Upgrade to ODE 0.9 (replaced references, and CCilinder (ode 0.8) with Capsule(ode 0.9)) <li>02/08/04 - LR, YHC - BCB corrections: use record instead array <li>04/12/03 - SG - Creation. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TSCODEBase |
Class TSCODESphere |
Class TSCODECCylinder |
Class TSCODEBox |

Functions and Procedures

procedure AddSCODEGeomsToODESpace( colliders : TSkeletonColliderList; space : PdxSpace);

Description

Functions and Procedures

procedure AddSCODEGeomsToODESpace( colliders : TSkeletonColliderList; space : PdxSpace);

After loading call this function to add all the geoms in a skeleton collider list to a given ODE space.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODESkeletonColliders: Class TSCODEBase

Class TSCODEBase

Unit

GLODESkeletonColliders

Declaration

type TSCODEBase = class(TSkeletonCollider)

Description

Base ODE skeleton collider class.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSkeletonCollider
  • TSCODEBase

Overview

Methods

Public | procedure AddToSpace(Space : PdxSpace); virtual;
Public | procedure AlignCollider; override;
Public | procedure ReadFromFiler(reader : TVirtualReader); override;
Public | procedure WriteToFiler(writer : TVirtualWriter); override;

Properties

Public property Geom : PdxGeom read FGeom;

Description

Methods

Public procedure AddToSpace(Space : PdxSpace); virtual;
Public procedure AlignCollider; override;
Public procedure ReadFromFiler(reader : TVirtualReader); override;
Public procedure WriteToFiler(writer : TVirtualWriter); override;

Properties

Public property Geom : PdxGeom read FGeom;

The geoms are created through the AddToSpace procedure.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODESkeletonColliders: Class TSCODESphere

Class TSCODESphere

Unit

GLODESkeletonColliders

Declaration

type TSCODESphere = class(TSCODEBase)

Description

Sphere shaped ODE geom in a skeleton collider.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSkeletonCollider
  • TSCODEBase
  • TSCODESphere

Overview

Methods

Public | constructor Create; override;
Public | procedure AddToSpace(Space : PdxSpace); override;
Public | procedure ReadFromFiler(reader : TVirtualReader); override;
Public | procedure WriteToFiler(writer : TVirtualWriter); override;
Protected | procedure SetRadius(const val : Single);

Properties

Public property Radius : Single read FRadius write SetRadius;

Description

Methods

Public constructor Create; override;
Public procedure AddToSpace(Space : PdxSpace); override;
Public procedure ReadFromFiler(reader : TVirtualReader); override;
Public procedure WriteToFiler(writer : TVirtualWriter); override;
Protected procedure SetRadius(const val : Single);

Properties

Public property Radius : Single read FRadius write SetRadius;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODESkeletonColliders: Class TSCODECCylinder

Class TSCODECCylinder

Unit

GLODESkeletonColliders

Declaration

type TSCODECCylinder = class(TSCODEBase)

Description

Capsule (sphere capped cylinder) shaped ODE geom in a skeleton collider.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSkeletonCollider
  • TSCODEBase
  • TSCODECCylinder

Overview

Methods

Public | constructor Create; override;
Public | procedure AddToSpace(Space : PdxSpace); override;
Public | procedure ReadFromFiler(reader : TVirtualReader); override;
Public | procedure WriteToFiler(writer : TVirtualWriter); override;
Protected | procedure SetLength(const val : Single);
Protected | procedure SetRadius(const val : Single);

Properties

Public | property Length : Single read FLength write SetLength;
Public | property Radius : Single read FRadius write SetRadius;

Description

Methods

Public constructor Create; override;
Public procedure AddToSpace(Space : PdxSpace); override;
Public procedure ReadFromFiler(reader : TVirtualReader); override;
Public procedure WriteToFiler(writer : TVirtualWriter); override;
Protected procedure SetLength(const val : Single);
Protected procedure SetRadius(const val : Single);

Properties

Public property Length : Single read FLength write SetLength;
Public property Radius : Single read FRadius write SetRadius;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLODESkeletonColliders: Class TSCODEBox

Class TSCODEBox

Unit

GLODESkeletonColliders

Declaration

type TSCODEBox = class(TSCODEBase)

Description

Box shaped ODE geom in a skeleton collider.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSkeletonCollider
  • TSCODEBase
  • TSCODEBox

Overview

Methods

Public | constructor Create; override;
Public | procedure AddToSpace(Space : PdxSpace); override;
Public | procedure ReadFromFiler(reader : TVirtualReader); override;
Public | procedure WriteToFiler(writer : TVirtualWriter); override;
Protected | procedure SetBoxDepth(const val : Single);
Protected | procedure SetBoxHeight(const val : Single);
Protected | procedure SetBoxWidth(const val : Single);

Properties

Public | property BoxDepth : Single read FBoxDepth write SetBoxDepth;
Public | property BoxHeight : Single read FBoxHeight write SetBoxHeight;
Public | property BoxWidth : Single read FBoxWidth write SetBoxWidth;

Description

Methods

Public constructor Create; override;
Public procedure AddToSpace(Space : PdxSpace); override;
Public procedure ReadFromFiler(reader : TVirtualReader); override;
Public procedure WriteToFiler(writer : TVirtualWriter); override;
Protected procedure SetBoxDepth(const val : Single);
Protected procedure SetBoxHeight(const val : Single);
Protected procedure SetBoxWidth(const val : Single);

Properties

Public property BoxDepth : Single read FBoxDepth write SetBoxDepth;
Public property BoxHeight : Single read FBoxHeight write SetBoxHeight;
Public property BoxWidth : Single read FBoxWidth write SetBoxWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLOutlineShader

Unit GLOutlineShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLOutlineShader<p>

A simple shader that adds an outline to an object. <p>

Limitations: <br> <li> 1. Object can be transparent (color alpha < 1) if it doesn't overlap itself. Texture transparency doesn't work. <li> 2. Doesn't work with objects (e.g. TGLFreeForm) having it's own color array. <li> 3. Doesn't Works with visible backfaces.<p>

<b>History : </b><font size=-1><ul> <li>12/02/11 - Yar - Added skipping shader when enabled stencil test to avvoid conflict with shadow volume <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>06/06/07 - DaStr - Added $I GLScene.inc Added GLColor to uses (BugtrackerID = 1732211) <li>25/02/07 - DaStr - Moved registration to GLSceneRegister.pas <li>05/06/04 - NelC - Fixed bug with textured object <li>14/12/03 - NelC - Removed BlendLine, automatically determine if blend <li>20/10/03 - NelC - Removed unnecessary properties. Shader now honors rci.ignoreMaterials. <li>04/09/03 - NelC - Converted into a component from the TOutlineShader in the multipass demo. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLOutlineShader |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLOutlineShader: Class TGLOutlineShader

Class TGLOutlineShader

Unit

GLOutlineShader

Declaration

type TGLOutlineShader = class(TGLShader)

Description

no description available, TGLShader description follows

Generic, abstract shader class.<p> Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities.<br> Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLOutlineShader

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;

Properties

Published | property LineColor: TGLColor read FLineColor write FLineColor;
Published | property LineSmooth: Boolean read FOutlineSmooth write SetOutlineSmooth default false;
Published | property LineWidth: Single read FOutlineWidth write SetOutlineWidth;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;

Properties

Published property LineColor: TGLColor read FLineColor write FLineColor;
Published property LineSmooth: Boolean read FOutlineSmooth write SetOutlineSmooth default false;

Line smoothing control

Published property LineWidth: Single read FOutlineWidth write SetOutlineWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLParametricSurfaces

Unit GLParametricSurfaces

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLParametricSurfaces<p>

Parametric surface implementation (like Bezier and BSpline surfaces) for GLScene.<p>

Notes: The MOParametricSurface is a TMeshObject descendant that can be used to render parametric surfaces. The Renderer property defines if the surface should be rendered using OpenGL mesh evaluators (through GLU Nurbs for BSplines) or through GLScene using the CurvesAndSurfaces.pas routines to generate the mesh vertices and then rendered through the standard TMeshObject render routine. Please note that BSplines aren't correctly handled yet in the CurvesAndSurfaces unit so the output mesh in GLScene rendering mode is wrong. I'll have it fixed when I know what's going wrong. The GLU Nurbs and glMeshEval Beziers work well though.<p>

The FGBezierSurface is a face group decendant that renders the surface using mesh evaluators. The ControlPointIndices point to the mesh object vertices much the same as vertex indices for other face group flavours. The MinU, MaxU, MinV and MaxV properties allow for drawing specific parts of the bezier surface, which can be used to blend a patch with other patches.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>05/03/10 - DanB - More state added to TGLStateCache <li>31/03/07 - DaStr - Added $I GLScene.inc <li>11/05/04 - SG - Mesh building and texture coord fixes. <li>05/02/04 - SG - Added FGBezierSurface facegroup descendant. <li>20/08/03 - SG - Weighted control points. <li>18/07/03 - SG - Creation. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMOParametricSurface |
Class TFGBezierSurface |

Types

TParametricSurfaceRenderer = (...);
TParametricSurfaceBasis = (...);

Description

Types

TParametricSurfaceRenderer = (...);

psrGLScene tells the surface to render using GLScene code to build the mesh, whereas, psrOpenGL uses glEvalMesh2 or gluNurbsRenderer calls to render the surface.

Values
  • psrGLScene:
  • psrOpenGL:
TParametricSurfaceBasis = (...);

psbBezier indicates building the surface with Bernstein basis functions, no knot or order properties are used. psbBSpline indicates building the surface using BSpline basis functions, these require orders and knot vectors to define the control point influences on the surface.

Values
  • psbBezier:
  • psbBSpline:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLParametricSurfaces: Class TMOParametricSurface

Class TMOParametricSurface

Unit

GLParametricSurfaces

Declaration

type TMOParametricSurface = class(TMeshObject)

Description

no description available, TMeshObject description follows

Base mesh class.<p> Introduces base methods and properties for mesh objects.<p> Subclasses are named "TMOxxx".

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseMeshObject
  • TMeshObject
  • TMOParametricSurface

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci: TRenderContextInfo); override;
Public | procedure Clear; override;
Public | procedure GenerateMesh;
Public | procedure Prepare; override;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;

Properties

Public | property AutoKnots: Boolean read FAutoKnots write FAutoKnots;
Public | property Basis: TParametricSurfaceBasis read FBasis write SetBasis;
Public | property Continuity: TBSplineContinuity read FContinuity write FContinuity;
Public | property ControlPoints: TAffineVectorList read FControlPoints write SetControlPoints;
Public | property CountU: Integer read FCountU write FCountU;
Public | property CountV: Integer read FCountV write FCountV;
Public | property KnotsU: TSingleList read FKnotsU write SetKnotsU;
Public | property KnotsV: TSingleList read FKnotsV write SetKnotsV;
Public | property OrderU: Integer read FOrderU write FOrderU;
Public | property OrderV: Integer read FOrderV write FOrderV;
Public | property Renderer: TParametricSurfaceRenderer read FRenderer write SetRenderer;
Public | property Resolution: Integer read FResolution write FResolution;
Public | property Weights: TSingleList read FWeights write SetWeights;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public procedure BuildList(var mrci: TRenderContextInfo); override;
Public procedure Clear; override;
Public procedure GenerateMesh;

Generates a mesh approximation of the surface defined by the properties below. This is used to construct the mesh when using Renderer = psrGLScene. If you want to render using OpenGL calls but would like to obtain the mesh data also use this call to generate the mesh data. Fills in Vertices, Normals, etc.

Public procedure Prepare; override;
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure WriteToFiler(writer: TVirtualWriter); override;

Properties

Public property AutoKnots: Boolean read FAutoKnots write FAutoKnots;

Automatically generate the knot vectors based on the Continuity. Only applies to BSpline surfaces.

Public property Basis: TParametricSurfaceBasis read FBasis write SetBasis;

Basis determines the style of curve, psbBezier or psbBSpline

Public property Continuity: TBSplineContinuity read FContinuity write FContinuity;
Public property ControlPoints: TAffineVectorList read FControlPoints write SetControlPoints;

Control points define the parametric surface.

Public property CountU: Integer read FCountU write FCountU;

CountU and CountV describe the number of control points in the U and V direciton. Basically a control point width and height in (u,v) space.

Public property CountV: Integer read FCountV write FCountV;
Public property KnotsU: TSingleList read FKnotsU write SetKnotsU;

KnotsU and KnotsV are the knot vectors in the U and V direction. Knots define the continuity of curves and how control points influence the parametric values to build the surface.

Public property KnotsV: TSingleList read FKnotsV write SetKnotsV;
Public property OrderU: Integer read FOrderU write FOrderU;

OrderU and OrderV defines the curve order in the U and V direction

Public property OrderV: Integer read FOrderV write FOrderV;
Public property Renderer: TParametricSurfaceRenderer read FRenderer write SetRenderer;

Determines whether to use OpenGL calls (psrOpenGL) or the GLScene mesh objects (psrGLScene) to render the surface.

Public property Resolution: Integer read FResolution write FResolution;

Defines how fine the resultant mesh will be. Higher values create finer meshes. Resolution = 50 would produce a 50x50 mesh. The GLU Nurbs rendering uses resolution as the U_STEP and V_STEP using the sampling method GLU_DOMAIN_DISTANCE, so the resolution works a little differently there.

Public property Weights: TSingleList read FWeights write SetWeights;

Weights define how much a control point effects the surface.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLParametricSurfaces: Class TFGBezierSurface

Class TFGBezierSurface

Unit

GLParametricSurfaces

Declaration

type TFGBezierSurface = class(TFaceGroup)

Description

A 3d bezier surface implemented through facegroups. The ControlPointIndices is an index to control points stored in the MeshObject.Vertices affine vector list. Similarly the TexCoordIndices point to the owner MeshObject.TexCoords, one for each control point. CountU and CountV define the width and height of the surface. Resolution sets the detail level of the mesh evaluation. MinU, MaxU, MinV and MaxV define the region of the surface to be rendered, this is especially useful for blending with neighbouring patches.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TFaceGroup
  • TFGBezierSurface

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci: TRenderContextInfo); override;
Public | procedure Prepare; override;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure SetControlPointIndices(const Value: TIntegerList);
Protected | procedure SetTexCoordIndices(const Value: TIntegerList);

Properties

Public | property ControlPointIndices: TIntegerList read FControlPointIndices write SetControlPointIndices;
Public | property CountU: Integer read FCountU write FCountU;
Public | property CountV: Integer read FCountV write FCountV;
Public | property MaxU: Single read FMaxU write FMaxU;
Public | property MaxV: Single read FMaxV write FMaxV;
Public | property MinU: Single read FMinU write FMinU;
Public | property MinV: Single read FMinV write FMinV;
Public | property Resolution: Integer read FResolution write FResolution;
Public | property TexCoordIndices: TIntegerList read FTexCoordIndices write SetTexCoordIndices;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public procedure BuildList(var mrci: TRenderContextInfo); override;
Public procedure Prepare; override;
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure SetControlPointIndices(const Value: TIntegerList);
Protected procedure SetTexCoordIndices(const Value: TIntegerList);

Properties

Public property ControlPointIndices: TIntegerList read FControlPointIndices write SetControlPointIndices;
Public property CountU: Integer read FCountU write FCountU;
Public property CountV: Integer read FCountV write FCountV;
Public property MaxU: Single read FMaxU write FMaxU;
Public property MaxV: Single read FMaxV write FMaxV;
Public property MinU: Single read FMinU write FMinU;
Public property MinV: Single read FMinV write FMinV;
Public property Resolution: Integer read FResolution write FResolution;
Public property TexCoordIndices: TIntegerList read FTexCoordIndices write SetTexCoordIndices;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLParticleFX

Unit GLParticleFX

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLParticleFX<p>

Base classes for scene-wide blended particles FX.<p>

These provide a mechanism to render heterogenous particles systems with per particle depth-sorting (allowing correct rendering of interwoven separate fire and smoke particle systems for instance).<p>

<b>History : </b><font size=-1><ul> <li>21/01/01 - DanB - Added "inherited" call to TGLParticleFXEffect.WriteToFiler <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>22/01/10 - Yar - Added bmp32.Blank:=false for memory allocation and fix RegisterAsOpenGLTexture <li>12/10/08 - DanB - fix to TGLLifeColoredPFXManager.ComputeRotateAngle (it used lck.FDoScale instead of lck.FDoRotate), made more use of RCI instead of accessing via global variables. Changed order of transformations when rendering particles, now does rotation+scaling before translation. Disabled FRotationCenter, <li>15/02/08 - Mrqzzz - Fixed SizeScale in Lifetimes of TGLBaseSpritePFXManager (was ignored) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>02/04/07 - DaStr - TPFXLifeColors now inherits from TOwnedCollection (thanks Burkhard Carstens) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>14/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>24/01/07 - DaStr - TGLSourcePFXEffect.Burst and TGLBaseSpritePFXManager.RenderParticle bugfixed TGLLifeColoredPFXManager.RotateVertexBuf bugfixed (all based on old code) <li>28/10/06 - LC - Fixed access violation in TGLParticleFXRenderer. Bugtracker ID=1585907 (thanks Da Stranger) <li>19/10/06 - LC - Fixed memory leak in TGLParticleFXManager. Bugtracker ID=1551866 (thanks Dave Gravel) <li>08/10/05 - Mathx - Fixed access violation when a PFXManager was removed from form but a particleFX still had a reference to it (added the FUsers property). Butracker ID=783625. <li>17/02/05 - EG - Restored correct PFXSource.Burst relative/absolute behaviour, EffectsScale support not added back (no clue what it does... Mrqz?) <li>23/11/04 - SG - Fixed memory leak in TGLLifeColoredPFXManager (kenguru) <li>03/10/04 - Mrqzzz - added property TGLParticleFXEffect.DisabledIfOwnerInvisible. Fixed PositionDispersionRange to honour VelocityMode=svmRelative <li>25/09/04 - Graham Kennedy - Fixed restore of currentTexturingMode <li>09/09/04 - Mrqzzz - added property TGLParticleFXEffect.EffectScale allowing different scaling of effect with same manager. TGLParticleFXEffect.ArchiveVersion updated to 4 <li>02/08/04 - LR, YHC - BCB corrections: use record instead array Replace direct access of some properties by a getter and a setter. fixed undefined TPFXRegion error in BCB <li>29/08/04 - Mrqzzz - fixed particles initial position when VelocityMode=svmRelative <li>28/08/04 - Mrqzzz - fixed particles direction when VelocityMode=svmRelative <li>09/07/04 - Mrqzzz - small fixup (TGLSourcePFXEffect.WriteToFiler Archive V.4) <li>08/07/04 - Eugene Kryukov - Added rotation for particles, RotateAngle in LifeColor. And added AbsoluteRotation for TGLDynamicPFXManager <li>25/04/04 - EG - Added friction, Life sizes, multiple sprites per texture and sprites sharing <li>24/04/04 - Mrqzzz - Added property "enabled" to TGLSourcePFXEffect <li>15/04/04 - EG - AspectRatio and Rotation added to sprite PFX, improved texturing mode switches <li>26/05/03 - EG - Improved TGLParticleFXRenderer.BuildList <li>05/11/02 - EG - Enable per-manager blending mode control <li>27/01/02 - EG - Added TGLLifeColoredPFXManager, TGLBaseSpritePFXManager and TGLPointLightPFXManager. <li>23/01/02 - EG - Added ZWrite and BlendingMode to the PFX renderer, minor sort and render optims <li>22/01/02 - EG - Another RenderParticle color lerp fix (GliGli) <li>20/01/02 - EG - Several optimization (35% faster on Volcano bench) <li>18/01/02 - EG - RenderParticle color lerp fix (GliGli) <li>08/09/01 - EG - Creation (GLParticleFX.omm) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLParticle |
Class TGLParticleList |
Class TGLParticleFXManager |
Class TGLParticleFXEffect |
packed record TParticleReference |
record TPFXRegion |
Class TGLParticleFXRenderer |
Class TGLSourcePFXEffect |
Class TGLDynamicPFXManager |
Class TPFXLifeColor |
Class TPFXLifeColors |
Class TGLLifeColoredPFXManager |
Class TGLCustomPFXManager |
Class TGLPolygonPFXManager |
Class TGLBaseSpritePFXManager |
Class TGLCustomSpritePFXManager |
Class TGLPointLightPFXManager |

Functions and Procedures

function GetOrCreateSourcePFX(obj: TGLBaseSceneObject; const name: string = ''): TGLSourcePFXEffect;

Types

TGLParticleClass = class of TGLParticle;
TGLParticleArray = array[0..MaxInt shr 4] of TGLParticle;
PGLParticleArray = ˆTGLParticleArray;
TPFXCreateParticleEvent = procedure(Sender: TObject; aParticle: TGLParticle) of object;
PParticleReference = ˆTParticleReference;
TParticleReferenceArray = packed array[0..MaxInt shr 8-1] of TParticleReference;
PParticleReferenceArray = ˆTParticleReferenceArray;
PFXPointerList = ˆTFXPointerList;
TFXPointerList = array[0..MaxInt shr 8-1] of Pointer;
PPFXRegion = ˆTPFXRegion;
TPFXSortAccuracy = (...);
TGLSourcePFXVelocityMode = (...);
TGLSourcePFXPositionMode = (...);
TGLSourcePFXDispersionMode = (...);
TPFXDirectRenderEvent = procedure(Sender: TObject; aParticle: TGLParticle; var rci: TRenderContextInfo) of object;
TPFXProgressEvent = procedure(Sender: TObject; const progressTime: TProgressTimes; var defaultProgress: Boolean) of object;
TPFXParticleProgress = procedure(Sender: TObject; const progressTime: TProgressTimes; aParticle: TGLParticle; var killParticle: Boolean) of object;
TPFXGetParticleCountEvent = function(Sender: TObject): Integer of object;
TSpriteColorMode = (...);
TSpritesPerTexture = (...);
TPFXPrepareTextureImageEvent = procedure(Sender: TObject; destBmp32: TGLBitmap32; var texFormat: Integer) of object;

Constants

cPFXNbRegions = 128;
cPFXGranularity = 128;

Description

Functions and Procedures

function GetOrCreateSourcePFX(obj: TGLBaseSceneObject; const name: string = ''): TGLSourcePFXEffect;

Returns or creates the TGLBInertia within the given object's behaviours.<p>

Types

TGLParticleClass = class of TGLParticle;
TGLParticleArray = array[0..MaxInt shr 4] of TGLParticle;
PGLParticleArray = ˆTGLParticleArray;
TPFXCreateParticleEvent = procedure(Sender: TObject; aParticle: TGLParticle) of object;
PParticleReference = ˆTParticleReference;
TParticleReferenceArray = packed array[0..MaxInt shr 8-1] of TParticleReference;
PParticleReferenceArray = ˆTParticleReferenceArray;
PFXPointerList = ˆTFXPointerList;
TFXPointerList = array[0..MaxInt shr 8-1] of Pointer;
PPFXRegion = ˆTPFXRegion;
TPFXSortAccuracy = (...);
Values
  • saLow:
  • saOneTenth:
  • saOneThird:
  • saOneHalf:
  • saHigh:
TGLSourcePFXVelocityMode = (...);
Values
  • svmAbsolute:
  • svmRelative:
TGLSourcePFXPositionMode = (...);
Values
  • spmAbsoluteOffset:
  • spmRelative:
TGLSourcePFXDispersionMode = (...);
Values
  • sdmFast:
  • sdmIsotropic:
TPFXDirectRenderEvent = procedure(Sender: TObject; aParticle: TGLParticle; var rci: TRenderContextInfo) of object;
TPFXProgressEvent = procedure(Sender: TObject; const progressTime: TProgressTimes; var defaultProgress: Boolean) of object;
TPFXParticleProgress = procedure(Sender: TObject; const progressTime: TProgressTimes; aParticle: TGLParticle; var killParticle: Boolean) of object;
TPFXGetParticleCountEvent = function(Sender: TObject): Integer of object;
TSpriteColorMode = (...);

Sprite color modes.<p> <ul> <li>scmFade: vertex coloring is used to fade inner-outer <li>scmInner: vertex coloring uses inner color only <li>scmOuter: vertex coloring uses outer color only <li>scmNone: vertex coloring is NOT used (colors are ignored). </ul>

Values
  • scmFade:
  • scmInner:
  • scmOuter:
  • scmNone:
TSpritesPerTexture = (...);

Sprites per sprite texture for the SpritePFX.

Values
  • sptOne:
  • sptFour:
TPFXPrepareTextureImageEvent = procedure(Sender: TObject; destBmp32: TGLBitmap32; var texFormat: Integer) of object;

Constants

cPFXNbRegions = 128;
cPFXGranularity = 128;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLParticleFX: Class TGLParticle

Class TGLParticle

Unit

GLParticleFX

Declaration

type TGLParticle = class(TPersistentObject)

Description

Base class for particles.<p> The class implements properties for position, velocity and time, whatever you need in excess of that will have to be placed in subclasses (this class should remain as compact as possible).

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLParticle

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;

Properties

Public | property CreationTime: Double read FCreationTime write FCreationTime;
Public | property ID: Integer read FID;
Public | property Manager: TGLParticleFXManager read FManager write FManager;
Public | property Position: TAffineVector read FPosition write FPosition;
Public | property PosX : Single index 0 read GetPosition write WritePosition;
Public | property PosY : Single index 1 read GetPosition write WritePosition;
Public | property PosZ : Single index 2 read GetPosition write WritePosition;
Public | property Tag: Integer read FTag write FTag;
Public | property Velocity: TAffineVector read FVelocity write FVelocity;
Public | property VelX : Single index 0 read GetVelocity write WriteVelocity;
Public | property VelY : Single index 1 read GetVelocity write WriteVelocity;
Public | property VelZ : Single index 2 read GetVelocity write WriteVelocity;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure WriteToFiler(writer: TVirtualWriter); override;

Properties

Public property CreationTime: Double read FCreationTime write FCreationTime;

Time at which particle was created

Public property ID: Integer read FID;

Particle's ID, given at birth.<p> ID is a value unique per manager.

Public property Manager: TGLParticleFXManager read FManager write FManager;
Public property Position: TAffineVector read FPosition write FPosition;

Particle's absolute position.<p> Note that this property is read-accessed directly at rendering time in the innards of the depth-sorting code.

Public property PosX : Single index 0 read GetPosition write WritePosition;
Public property PosY : Single index 1 read GetPosition write WritePosition;
Public property PosZ : Single index 2 read GetPosition write WritePosition;
Public property Tag: Integer read FTag write FTag;
Public property Velocity: TAffineVector read FVelocity write FVelocity;

Particle's velocity.<p> This velocity is indicative and is NOT automatically applied to the position during progression events by this class (subclasses may implement that).

Public property VelX : Single index 0 read GetVelocity write WriteVelocity;
Public property VelY : Single index 1 read GetVelocity write WriteVelocity;
Public property VelZ : Single index 2 read GetVelocity write WriteVelocity;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLParticleFX: Class TGLParticleList

Class TGLParticleList

Unit

GLParticleFX

Declaration

type TGLParticleList = class(TPersistentObject)

Description

List of particles.<p> This list is managed with particles and performance in mind, make sure to check methods doc.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLParticleList

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function AddItem(aItem: TGLParticle): Integer;
Public | function IndexOfItem(aItem: TGLParticle): Integer;
Public | function ItemCount: Integer;
Protected | function GetItems(index: Integer): TGLParticle;
Public | procedure Pack;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure RemoveAndFreeItem(aItem: TGLParticle);
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure AfterItemCreated(Sender: TObject);
Protected | procedure SetItems(index: Integer; val: TGLParticle);

Properties

Public | property Items[index: Integer]: TGLParticle read GetItems write SetItems;
Public | property List: PGLParticleArray read FDirectList;
Public | property Owner: TGLParticleFXManager read FOwner write FOwner;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function AddItem(aItem: TGLParticle): Integer;

Adds a particle to the list.<p> Particle owneship is defined blindly, if the particle was previously in another list, it won't be automatically removed from that list.

Public function IndexOfItem(aItem: TGLParticle): Integer;
Public function ItemCount: Integer;
Protected function GetItems(index: Integer): TGLParticle;
Public procedure Pack;

Packs the list by removing all "nil" items.<p> Note: this functions is orders of magnitude faster than the TList version.

Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure RemoveAndFreeItem(aItem: TGLParticle);

Removes and frees a particular item for the list.<p> If the item is not part of the list, nothing is done.<br> If found in the list, the item's "slot" is set to nil and item is freed (after setting its ownership to nil). The nils can be removed with a call to Pack.

Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure AfterItemCreated(Sender: TObject);
Protected procedure SetItems(index: Integer; val: TGLParticle);

Properties

Public property Items[index: Integer]: TGLParticle read GetItems write SetItems;
Public property List: PGLParticleArray read FDirectList;
Public property Owner: TGLParticleFXManager read FOwner write FOwner;

Refers owner manager

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:36


GLScene v.1.1.2: GLParticleFX: Class TGLParticleFXManager

Class TGLParticleFXManager

Unit

GLParticleFX

Declaration

type TGLParticleFXManager = class(TGLCadencedComponent)

Description

Base class for particle FX managers.<p> Managers take care of life and death of particles for a particular particles FX system. You can have multiple scene-wide particle FX managers in a scene, handled by the same ParticleFxRenderer.<p> Before subclassing, make sure you understood how the Initialize/Finalize Rendering, Begin/End Particles and RenderParticles methods (and also understood that rendering of manager's particles may be interwoven).

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager

Overview

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateParticle: TGLParticle; virtual;
Public | function ParticleCount: Integer; virtual;
Public | class function ParticlesClass: TGLParticleClass; virtual;
Protected | function TexturingMode: Cardinal; virtual; abstract;
Public | procedure CreateParticles(nbParticles: Integer);
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure ApplyBlendingMode(var rci: TRenderContextInfo);
Protected | procedure BeginParticles(var rci: TRenderContextInfo); virtual; abstract;
Protected | procedure EndParticles(var rci: TRenderContextInfo); virtual; abstract;
Protected | procedure FinalizeRendering(var rci: TRenderContextInfo); dynamic; abstract;
Protected | procedure InitializeRendering(var rci: TRenderContextInfo); dynamic; abstract;
Protected | procedure registerUser(obj: TGLParticleFXEffect);
Protected | procedure RenderParticle(var rci: TRenderContextInfo; aParticle: TGLParticle); virtual; abstract;
Protected | procedure SetParticles(const aParticles: TGLParticleList);
Protected | procedure SetRenderer(const val: TGLParticleFXRenderer);
Protected | procedure UnapplyBlendingMode(var rci: TRenderContextInfo);
Protected | procedure unregisterUser(obj: TGLParticleFXEffect);

Properties

Public | property AutoFreeWhenEmpty: Boolean read FAutoFreeWhenEmpty write FAutoFreeWhenEmpty;
Protected | property BlendingMode: TBlendingMode read FBlendingMode write FBlendingMode;
Published | property Cadencer;
Protected | property NextID: Integer read FNextID write FNextID;
Published | property OnCreateParticle: TPFXCreateParticleEvent read FOnCreateParticle write FOnCreateParticle;
Public | property Particles: TGLParticleList read FParticles write SetParticles;
Published | property Renderer: TGLParticleFXRenderer read FRenderer write SetRenderer;

Description

Methods

Public constructor Create(aOwner: TComponent); override;
Public destructor Destroy; override;
Public function CreateParticle: TGLParticle; virtual;

Creates a new particle controled by the manager.

Public function ParticleCount: Integer; virtual;

Return the number of particles.<p> Note that subclasses may decide to return a particle count inferior to Particles.ItemCount, and the value returned by this method will be the one honoured at render time.

Public class function ParticlesClass: TGLParticleClass; virtual;

Class of particles created by this manager. }

Protected function TexturingMode: Cardinal; virtual; abstract;

Texturing mode for the particles.<p> Subclasses should return GL_TEXTURE_1D, 2D or 3D depending on their needs, and zero if they don't use texturing. This method is used to reduce the number of texturing activations/deactivations.

Public procedure CreateParticles(nbParticles: Integer);

Create several particles at once.

Public procedure DoProgress(const progressTime: TProgressTimes); override;
Public procedure NotifyChange(Sender: TObject); override;
Protected procedure ApplyBlendingMode(var rci: TRenderContextInfo);

Apply BlendingMode relatively to the renderer's blending mode.

Protected procedure BeginParticles(var rci: TRenderContextInfo); virtual; abstract;

Triggered just before rendering a set of particles.<p> The current OpenGL state should be assumed to be the "base" one as was found during InitializeRendering. Manager-specific states should be established here.<br> Multiple BeginParticles can occur during a render (but all will be between InitializeRendering and Finalizerendering, and at least one particle will be rendered before EndParticles is invoked).

Protected procedure EndParticles(var rci: TRenderContextInfo); virtual; abstract;

Triggered after a set of particles as been rendered.<p> If OpenGL state were altered directly (ie. not through the states caches of GLMisc), it should be restored back to the "base" state.

Protected procedure FinalizeRendering(var rci: TRenderContextInfo); dynamic; abstract;

Invoked when rendering of particles for this manager is done.

Protected procedure InitializeRendering(var rci: TRenderContextInfo); dynamic; abstract;

Invoked when the particles of the manager will be rendered.<p> This method is fired with the "base" OpenGL states and matrices that will be used throughout the whole rendering, per-frame initialization should take place here.<br> OpenGL states/matrices should not be altered in any way here.

Protected procedure registerUser(obj: TGLParticleFXEffect);
Protected procedure RenderParticle(var rci: TRenderContextInfo; aParticle: TGLParticle); virtual; abstract;

Request to render a particular particle.<p> Due to the nature of the rendering, no particular order should be assumed. If possible, no OpenGL state changes should be made in this method, but should be placed in Begin/EndParticles.

Protected procedure SetParticles(const aParticles: TGLParticleList);
Protected procedure SetRenderer(const val: TGLParticleFXRenderer);
Protected procedure UnapplyBlendingMode(var rci: TRenderContextInfo);

Unapply BlendingMode relatively by restoring the renderer's blending mode.

Protected procedure unregisterUser(obj: TGLParticleFXEffect);

Properties

Public property AutoFreeWhenEmpty: Boolean read FAutoFreeWhenEmpty write FAutoFreeWhenEmpty;

If True the manager will free itself when its particle count reaches zero.<p> Check happens in the progression event, use with caution and only if you know what you're doing!

Protected property BlendingMode: TBlendingMode read FBlendingMode write FBlendingMode;

Blending mode for the particles.<p> Protected and unused in the base class.

Published property Cadencer;
Protected property NextID: Integer read FNextID write FNextID;

ID for the next created particle.

Published property OnCreateParticle: TPFXCreateParticleEvent read FOnCreateParticle write FOnCreateParticle;

Event triggered after standard particle creation and initialization.

Public property Particles: TGLParticleList read FParticles write SetParticles;

A TGLParticleList property.

Published property Renderer: TGLParticleFXRenderer read FRenderer write SetRenderer;

References the renderer.<p> The renderer takes care of ordering the particles of the manager (and other managers linked to it) and rendering them all depth-sorted.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticleFX: Class TGLParticleFXEffect

Class TGLParticleFXEffect

Unit

GLParticleFX

Declaration

type TGLParticleFXEffect = class(TGLObjectPostEffect)

Description

Base class for linking scene objects to a particle FX manager.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLObjectEffect
  • TGLObjectPostEffect
  • TGLParticleFXEffect

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Protected | procedure Loaded; override;
Protected | procedure managerNotification(aManager: TGLParticleFXManager; Operation: TOperation);
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure SetManager(val: TGLParticleFXManager);
Protected | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property EffectScale: single read FEffectScale write SetEffectScale;
Published | property Manager: TGLParticleFXManager read FManager write SetManager;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;
Public destructor Destroy; override;
Protected procedure Loaded; override;
Protected procedure managerNotification(aManager: TGLParticleFXManager; Operation: TOperation);
Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure SetManager(val: TGLParticleFXManager);
Protected procedure WriteToFiler(writer: TWriter); override;

Properties

Published property EffectScale: single read FEffectScale write SetEffectScale;
Published property Manager: TGLParticleFXManager read FManager write SetManager;

Reference to the Particle FX manager

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticleFX: packed record TParticleReference

packed record TParticleReference

Unit

GLParticleFX

Declaration

type TParticleReference = packed record

Description

Overview

Fields

particle: TGLParticle;
distance: Integer;

Description

Fields

particle: TGLParticle;
distance: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticleFX: record TPFXRegion

record TPFXRegion

Unit

GLParticleFX

Declaration

type TPFXRegion = record

Description

Overview

Fields

count: Integer;
capacity: Integer;
particleRef: PParticleReferenceArray;
particleOrder: PFXPointerList;

Description

Fields

count: Integer;
capacity: Integer;
particleRef: PParticleReferenceArray;
particleOrder: PFXPointerList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticleFX: Class TGLParticleFXRenderer

Class TGLParticleFXRenderer

Unit

GLParticleFX

Declaration

type TGLParticleFXRenderer = class(TGLBaseSceneObject)

Description

Rendering interface for scene-wide particle FX.<p> A renderer can take care of rendering any number of particle systems, its main task being to depth-sort the particles so that they are blended appropriately.<br> This object will usually be placed at the end of the scene hierarchy, just before the HUD overlays, its position, rotation etc. is of no importance and has no effect on the rendering of the particles.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLParticleFXRenderer

Overview

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function StoreZMaxDistance: Boolean;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure RegisterManager(aManager: TGLParticleFXManager);
Protected | procedure UnRegisterAll;
Protected | procedure UnRegisterManager(aManager: TGLParticleFXManager);

Properties

Published | property BlendingMode: TBlendingMode read FBlendingMode write FBlendingMode default bmAdditive;
Public | property LastParticleCount: Integer read FLastParticleCount;
Public | property LastSortTime: Double read FLastSortTime;
Published | property Visible;
Published | property ZCull: Boolean read FZCull write FZCull default True;
Published | property ZMaxDistance: Single read FZMaxDistance write FZMaxDistance stored StoreZMaxDistance;
Published | property ZSortAccuracy: TPFXSortAccuracy read FZSortAccuracy write FZSortAccuracy default saHigh;
Published | property ZTest: Boolean read FZTest write FZTest default True;
Published | property ZWrite: Boolean read FZWrite write FZWrite default False;

Description

Methods

Public constructor Create(aOwner: TComponent); override;
Public destructor Destroy; override;
Protected function StoreZMaxDistance: Boolean;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure RegisterManager(aManager: TGLParticleFXManager);

Register a manager

Protected procedure UnRegisterAll;
Protected procedure UnRegisterManager(aManager: TGLParticleFXManager);

UnRegister a manager

Properties

Published property BlendingMode: TBlendingMode read FBlendingMode write FBlendingMode default bmAdditive;

Default blending mode for particles.<p> "Additive" blending is the usual mode (increases brightness and saturates), "transparency" may be used for smoke or systems that opacify view, "opaque" is more rarely used.<p> Note: specific PFX managers may override/ignore this setting.

Public property LastParticleCount: Integer read FLastParticleCount;

Amount of particles during the last render.

Public property LastSortTime: Double read FLastSortTime;

Time (in msec) spent sorting the particles for last render.

Published property Visible;
Published property ZCull: Boolean read FZCull write FZCull default True;

If true the renderer will cull particles that are behind the camera.

Published property ZMaxDistance: Single read FZMaxDistance write FZMaxDistance stored StoreZMaxDistance;

Maximum distance for rendering PFX particles.<p> If zero, camera's DepthOfView is used.

Published property ZSortAccuracy: TPFXSortAccuracy read FZSortAccuracy write FZSortAccuracy default saHigh;

If true particles will be accurately sorted back to front.<p> When false, only a rough ordering is used, which can result in visual glitches but may be faster.

Published property ZTest: Boolean read FZTest write FZTest default True;

Specifies if particles should write to test ZBuffer.<p>

Published property ZWrite: Boolean read FZWrite write FZWrite default False;

Specifies if particles should write to ZBuffer.<p> If the PFXRenderer is the last object to be rendered in the scene, it is not necessary to write to the ZBuffer since the particles are depth-sorted. Writing to the ZBuffer has a performance penalty.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticleFX: Class TGLSourcePFXEffect

Class TGLSourcePFXEffect

Unit

GLParticleFX

Declaration

type TGLSourcePFXEffect = class(TGLParticleFXEffect)

Description

Simple Particles Source.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLObjectEffect
  • TGLObjectPostEffect
  • TGLParticleFXEffect
  • TGLSourcePFXEffect

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Protected | function ParticleAbsoluteInitialPos: TAffineVector;
Public | procedure Burst(time: Double; nb: Integer);
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Public | procedure RingExplosion(time: Double; minInitialSpeed, maxInitialSpeed: Single; nbParticles: Integer);
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure SetInitialPosition(const val: TGLCoordinates);
Protected | procedure SetInitialVelocity(const val: TGLCoordinates);
Protected | procedure SetParticleInterval(const val: Single);
Protected | procedure SetPositionDispersionRange(const val: TGLCoordinates);
Protected | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property DisabledIfOwnerInvisible: boolean read FDisabledIfOwnerInvisible write FDisabledIfOwnerInvisible;
Published | property DispersionMode: TGLSourcePFXDispersionMode read FDispersionMode write FDispersionMode default sdmFast;
Published | property Enabled: boolean read FEnabled write FEnabled;
Published | property InitialPosition: TGLCoordinates read FInitialPosition write SetInitialPosition;
Published | property InitialVelocity: TGLCoordinates read FInitialVelocity write SetInitialVelocity;
Published | property ParticleInterval: Single read FParticleInterval write SetParticleInterval;
Published | property PositionDispersion: Single read FPositionDispersion write FPositionDispersion;
Published | property PositionDispersionRange: TGLCoordinates read FPositionDispersionRange write SetPositionDispersionRange;
Published | property PositionMode: TGLSourcePFXPositionMode read FPositionMode write FPositionMode default spmAbsoluteOffset;
Published | property RotationDispersion: Single read FRotationDispersion write FRotationDispersion;
Published | property VelocityDispersion: Single read FVelocityDispersion write FVelocityDispersion;
Published | property VelocityMode: TGLSourcePFXVelocityMode read FVelocityMode write FVelocityMode default svmAbsolute;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Protected function ParticleAbsoluteInitialPos: TAffineVector;
Public procedure Burst(time: Double; nb: Integer);

Instantaneously creates nb particles

Public procedure DoProgress(const progressTime: TProgressTimes); override;
Public procedure RingExplosion(time: Double; minInitialSpeed, maxInitialSpeed: Single; nbParticles: Integer);
Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure SetInitialPosition(const val: TGLCoordinates);
Protected procedure SetInitialVelocity(const val: TGLCoordinates);
Protected procedure SetParticleInterval(const val: Single);
Protected procedure SetPositionDispersionRange(const val: TGLCoordinates);
Protected procedure WriteToFiler(writer: TWriter); override;

Properties

Published property DisabledIfOwnerInvisible: boolean read FDisabledIfOwnerInvisible write FDisabledIfOwnerInvisible;
Published property DispersionMode: TGLSourcePFXDispersionMode read FDispersionMode write FDispersionMode default sdmFast;
Published property Enabled: boolean read FEnabled write FEnabled;
Published property InitialPosition: TGLCoordinates read FInitialPosition write SetInitialPosition;
Published property InitialVelocity: TGLCoordinates read FInitialVelocity write SetInitialVelocity;
Published property ParticleInterval: Single read FParticleInterval write SetParticleInterval;
Published property PositionDispersion: Single read FPositionDispersion write FPositionDispersion;
Published property PositionDispersionRange: TGLCoordinates read FPositionDispersionRange write SetPositionDispersionRange;
Published property PositionMode: TGLSourcePFXPositionMode read FPositionMode write FPositionMode default spmAbsoluteOffset;
Published property RotationDispersion: Single read FRotationDispersion write FRotationDispersion;
Published property VelocityDispersion: Single read FVelocityDispersion write FVelocityDispersion;
Published property VelocityMode: TGLSourcePFXVelocityMode read FVelocityMode write FVelocityMode default svmAbsolute;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticleFX: Class TGLDynamicPFXManager

Class TGLDynamicPFXManager

Unit

GLParticleFX

Declaration

type TGLDynamicPFXManager = class(TGLParticleFXManager)

Description

An abstract PFX manager for simple dynamic particles.<p> Adds properties and progress implementation for handling moving particles (simple velocity and const acceleration integration).

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager

Overview

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function MaxParticleAge: Single; dynamic; abstract;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Protected | procedure SetAcceleration(const val: TGLCoordinates);

Properties

Published | property Acceleration: TGLCoordinates read FAcceleration write SetAcceleration;
Protected | property CurrentTime: Double read FCurrentTime;
Published | property Friction: Single read FFriction write FFriction;

Description

Methods

Public constructor Create(aOwner: TComponent); override;
Public destructor Destroy; override;
Protected function MaxParticleAge: Single; dynamic; abstract;

Returns the maximum age for a particle.<p> Particles older than that will be killed by DoProgress.

Public procedure DoProgress(const progressTime: TProgressTimes); override;
Protected procedure SetAcceleration(const val: TGLCoordinates);

Properties

Published property Acceleration: TGLCoordinates read FAcceleration write SetAcceleration;

Oriented acceleration applied to the particles.

Protected property CurrentTime: Double read FCurrentTime;
Published property Friction: Single read FFriction write FFriction;

Friction applied to the particles.<p> Friction is applied as a speed scaling factor over 1 second, ie. a friction of 0.5 will half speed over 1 second, a friction of 3 will triple speed over 1 second, and a friction of 1 (default value) will have no effect.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticleFX: Class TPFXLifeColor

Class TPFXLifeColor

Unit

GLParticleFX

Declaration

type TPFXLifeColor = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TPFXLifeColor

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure SetColorInner(const val: TGLColor);
Protected | procedure SetColorOuter(const val: TGLColor);
Protected | procedure SetLifeTime(const val: Single);
Protected | procedure SetRotateAngle(const Value: Single);
Protected | procedure SetSizeScale(const val: Single);

Properties

Published | property ColorInner: TGLColor read FColorInner write SetColorInner;
Published | property ColorOuter: TGLColor read FColorOuter write SetColorOuter;
Public | property InvIntervalRatio: Single read FIntervalRatio;
Public | property InvLifeTime: Single read FInvLifeTime;
Published | property LifeTime: Single read FLifeTime write SetLifeTime;
Published | property RotateAngle: Single read FRotateAngle write SetRotateAngle;
Published | property SizeScale: Single read FSizeScale write SetSizeScale;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;
Protected procedure SetColorInner(const val: TGLColor);
Protected procedure SetColorOuter(const val: TGLColor);
Protected procedure SetLifeTime(const val: Single);
Protected procedure SetRotateAngle(const Value: Single);
Protected procedure SetSizeScale(const val: Single);

Properties

Published property ColorInner: TGLColor read FColorInner write SetColorInner;
Published property ColorOuter: TGLColor read FColorOuter write SetColorOuter;
Public property InvIntervalRatio: Single read FIntervalRatio;

Stores 1/(LifeTime[Next]-LifeTime[Self])

Public property InvLifeTime: Single read FInvLifeTime;

Stores 1/LifeTime

Published property LifeTime: Single read FLifeTime write SetLifeTime;
Published property RotateAngle: Single read FRotateAngle write SetRotateAngle;
Published property SizeScale: Single read FSizeScale write SetSizeScale;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticleFX: Class TPFXLifeColors

Class TPFXLifeColors

Unit

GLParticleFX

Declaration

type TPFXLifeColors = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TPFXLifeColors

Overview

Methods

Public | constructor Create(AOwner: TPersistent);
Public | function Add: TPFXLifeColor;
Public | function FindItemID(ID: Integer): TPFXLifeColor;
Public | function MaxLifeTime: Double;
Public | function RotationsDefined: Boolean;
Public | function ScalingDefined: Boolean;
Protected | function GetItems(index: Integer): TPFXLifeColor;
Public | procedure PrepareIntervalRatios;
Protected | procedure SetItems(index: Integer; const val: TPFXLifeColor);

Properties

Public property Items[index: Integer]: TPFXLifeColor read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TPersistent);
Public function Add: TPFXLifeColor;
Public function FindItemID(ID: Integer): TPFXLifeColor;
Public function MaxLifeTime: Double;
Public function RotationsDefined: Boolean;
Public function ScalingDefined: Boolean;
Protected function GetItems(index: Integer): TPFXLifeColor;
Public procedure PrepareIntervalRatios;
Protected procedure SetItems(index: Integer; const val: TPFXLifeColor);

Properties

Public property Items[index: Integer]: TPFXLifeColor read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticleFX: Class TGLLifeColoredPFXManager

Class TGLLifeColoredPFXManager

Unit

GLParticleFX

Declaration

type TGLLifeColoredPFXManager = class(TGLDynamicPFXManager)

Description

Base PFX manager for particles with life colors.<p> Particles have a core and edge color, for subclassing.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager

Overview

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function ComputeRotateAngle(var lifeTime, rotateAngle: Single): Boolean;
Protected | function ComputeSizeScale(var lifeTime: Single; var sizeScale: Single): Boolean;
Protected | function MaxParticleAge: Single; override;
Protected | procedure ComputeColors(var lifeTime: Single; var inner, outer: TColorVector);
Protected | procedure ComputeInnerColor(var lifeTime: Single; var inner: TColorVector);
Protected | procedure ComputeOuterColor(var lifeTime: Single; var outer: TColorVector);
Protected | procedure FinalizeRendering(var rci: TRenderContextInfo); override;
Protected | procedure InitializeRendering(var rci: TRenderContextInfo); override;
Protected | procedure RotateVertexBuf(buf: TAffineVectorList; lifeTime: Single; const axis: TAffineVector; offsetAngle: Single);
Protected | procedure SetColorInner(const val: TGLColor);
Protected | procedure SetColorOuter(const val: TGLColor);
Protected | procedure SetLifeColors(const val: TPFXLifeColors);

Properties

Published | property BlendingMode default bmAdditive;
Public | property ColorInner: TGLColor read FColorInner write SetColorInner;
Public | property ColorOuter: TGLColor read FColorOuter write SetColorOuter;
Public | property LifeColors: TPFXLifeColors read FLifeColors write SetLifeColors;
Public | property ParticleSize: Single read FParticleSize write FParticleSize;

Description

Methods

Public constructor Create(aOwner: TComponent); override;
Public destructor Destroy; override;
Protected function ComputeRotateAngle(var lifeTime, rotateAngle: Single): Boolean;
Protected function ComputeSizeScale(var lifeTime: Single; var sizeScale: Single): Boolean;
Protected function MaxParticleAge: Single; override;
Protected procedure ComputeColors(var lifeTime: Single; var inner, outer: TColorVector);
Protected procedure ComputeInnerColor(var lifeTime: Single; var inner: TColorVector);
Protected procedure ComputeOuterColor(var lifeTime: Single; var outer: TColorVector);
Protected procedure FinalizeRendering(var rci: TRenderContextInfo); override;
Protected procedure InitializeRendering(var rci: TRenderContextInfo); override;
Protected procedure RotateVertexBuf(buf: TAffineVectorList; lifeTime: Single; const axis: TAffineVector; offsetAngle: Single);
Protected procedure SetColorInner(const val: TGLColor);
Protected procedure SetColorOuter(const val: TGLColor);
Protected procedure SetLifeColors(const val: TPFXLifeColors);

Properties

Published property BlendingMode default bmAdditive;
Public property ColorInner: TGLColor read FColorInner write SetColorInner;
Public property ColorOuter: TGLColor read FColorOuter write SetColorOuter;
Public property LifeColors: TPFXLifeColors read FLifeColors write SetLifeColors;
Public property ParticleSize: Single read FParticleSize write FParticleSize;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticleFX: Class TGLCustomPFXManager

Class TGLCustomPFXManager

Unit

GLParticleFX

Declaration

type TGLCustomPFXManager = class(TGLLifeColoredPFXManager)

Description

A particles FX manager offering events for customization/experimentation.<p> This manager essentially surfaces the PFX methods as events, and is best suited when you have specific particles that don't fall into any existing category, or when you want to experiment with particles and later plan to wrap things up in a full-blown manager.<br> If the events aren't handled, nothing will be rendered.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager
  • TGLCustomPFXManager

Overview

Methods

Public | function ParticleCount: Integer; override;
Protected | function TexturingMode: Cardinal; override;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Protected | procedure BeginParticles(var rci: TRenderContextInfo); override;
Protected | procedure EndParticles(var rci: TRenderContextInfo); override;
Protected | procedure FinalizeRendering(var rci: TRenderContextInfo); override;
Protected | procedure InitializeRendering(var rci: TRenderContextInfo); override;
Protected | procedure RenderParticle(var rci: TRenderContextInfo; aParticle: TGLParticle); override;

Properties

Published | property ColorInner;
Published | property ColorOuter;
Published | property LifeColors;
Published | property OnBeginParticles: TDirectRenderEvent read FOnBeginParticles write FOnBeginParticles;
Published | property OnEndParticles: TDirectRenderEvent read FOnEndParticles write FOnEndParticles;
Published | property OnFinalizeRendering: TDirectRenderEvent read FOnFinalizeRendering write FOnFinalizeRendering;
Published | property OnGetParticleCountEvent: TPFXGetParticleCountEvent read FOnGetParticleCountEvent write FOnGetParticleCountEvent;
Published | property OnInitializeRendering: TDirectRenderEvent read FOnInitializeRendering write FOnInitializeRendering;
Published | property OnParticleProgress: TPFXParticleProgress read FOnParticleProgress write FOnParticleProgress;
Published | property OnProgress: TPFXProgressEvent read FOnProgress write FOnProgress;
Published | property OnRenderParticle: TPFXDirectRenderEvent read FOnRenderParticle write FOnRenderParticle;
Published | property ParticleSize;

Description

Methods

Public function ParticleCount: Integer; override;
Protected function TexturingMode: Cardinal; override;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Protected procedure BeginParticles(var rci: TRenderContextInfo); override;
Protected procedure EndParticles(var rci: TRenderContextInfo); override;
Protected procedure FinalizeRendering(var rci: TRenderContextInfo); override;
Protected procedure InitializeRendering(var rci: TRenderContextInfo); override;
Protected procedure RenderParticle(var rci: TRenderContextInfo; aParticle: TGLParticle); override;

Properties

Published property ColorInner;
Published property ColorOuter;
Published property LifeColors;
Published property OnBeginParticles: TDirectRenderEvent read FOnBeginParticles write FOnBeginParticles;
Published property OnEndParticles: TDirectRenderEvent read FOnEndParticles write FOnEndParticles;
Published property OnFinalizeRendering: TDirectRenderEvent read FOnFinalizeRendering write FOnFinalizeRendering;
Published property OnGetParticleCountEvent: TPFXGetParticleCountEvent read FOnGetParticleCountEvent write FOnGetParticleCountEvent;
Published property OnInitializeRendering: TDirectRenderEvent read FOnInitializeRendering write FOnInitializeRendering;
Published property OnParticleProgress: TPFXParticleProgress read FOnParticleProgress write FOnParticleProgress;
Published property OnProgress: TPFXProgressEvent read FOnProgress write FOnProgress;
Published property OnRenderParticle: TPFXDirectRenderEvent read FOnRenderParticle write FOnRenderParticle;
Published property ParticleSize;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticleFX: Class TGLPolygonPFXManager

Class TGLPolygonPFXManager

Unit

GLParticleFX

Declaration

type TGLPolygonPFXManager = class(TGLLifeColoredPFXManager)

Description

Polygonal particles FX manager.<p> The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available.<br> If you render large particles and don't have T&L acceleration, consider using TGLPointLightPFXManager.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager
  • TGLPolygonPFXManager

Overview

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function TexturingMode: Cardinal; override;
Protected | procedure BeginParticles(var rci: TRenderContextInfo); override;
Protected | procedure EndParticles(var rci: TRenderContextInfo); override;
Protected | procedure FinalizeRendering(var rci: TRenderContextInfo); override;
Protected | procedure InitializeRendering(var rci: TRenderContextInfo); override;
Protected | procedure RenderParticle(var rci: TRenderContextInfo; aParticle: TGLParticle); override;
Protected | procedure SetNbSides(const val: Integer);

Properties

Published | property ColorInner;
Published | property ColorOuter;
Published | property LifeColors;
Published | property NbSides: Integer read FNbSides write SetNbSides default 6;
Published | property ParticleSize;

Description

Methods

Public constructor Create(aOwner: TComponent); override;
Public destructor Destroy; override;
Protected function TexturingMode: Cardinal; override;
Protected procedure BeginParticles(var rci: TRenderContextInfo); override;
Protected procedure EndParticles(var rci: TRenderContextInfo); override;
Protected procedure FinalizeRendering(var rci: TRenderContextInfo); override;
Protected procedure InitializeRendering(var rci: TRenderContextInfo); override;
Protected procedure RenderParticle(var rci: TRenderContextInfo; aParticle: TGLParticle); override;
Protected procedure SetNbSides(const val: Integer);

Properties

Published property ColorInner;
Published property ColorOuter;
Published property LifeColors;
Published property NbSides: Integer read FNbSides write SetNbSides default 6;
Published property ParticleSize;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticleFX: Class TGLBaseSpritePFXManager

Class TGLBaseSpritePFXManager

Unit

GLParticleFX

Declaration

type TGLBaseSpritePFXManager = class(TGLLifeColoredPFXManager)

Description

Base class for sprite-based particles FX managers.<p> The particles are made of optionally centered single-textured quads.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager
  • TGLBaseSpritePFXManager

Overview

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function StoreAspectRatio: Boolean;
Protected | function TexturingMode: Cardinal; override;
Protected | procedure BeginParticles(var rci: TRenderContextInfo); override;
Protected | procedure BindTexture(var rci: TRenderContextInfo);
Protected | procedure EndParticles(var rci: TRenderContextInfo); override;
Protected | procedure FinalizeRendering(var rci: TRenderContextInfo); override;
Protected | procedure InitializeRendering(var rci: TRenderContextInfo); override;
Protected | procedure PrepareImage(bmp32: TGLBitmap32; var texFormat: Integer); virtual; abstract;
Protected | procedure RenderParticle(var rci: TRenderContextInfo; aParticle: TGLParticle); override;
Protected | procedure SetAspectRatio(const val: Single);
Protected | procedure SetColorMode(const val: TSpriteColorMode);
Protected | procedure SetRotation(const val: Single);
Protected | procedure SetShareSprites(const val: TGLBaseSpritePFXManager);
Protected | procedure SetSpritesPerTexture(const val: TSpritesPerTexture); virtual;

Properties

Published | property AspectRatio: Single read FAspectRatio write SetAspectRatio stored StoreAspectRatio;
Public | property ColorMode: TSpriteColorMode read FColorMode write SetColorMode;
Published | property Rotation: Single read FRotation write SetRotation;
Published | property ShareSprites: TGLBaseSpritePFXManager read FShareSprites write FShareSprites;
Protected | property SpritesPerTexture: TSpritesPerTexture read FSpritesPerTexture write SetSpritesPerTexture;

Description

Methods

Public constructor Create(aOwner: TComponent); override;
Public destructor Destroy; override;
Protected function StoreAspectRatio: Boolean;
Protected function TexturingMode: Cardinal; override;
Protected procedure BeginParticles(var rci: TRenderContextInfo); override;
Protected procedure BindTexture(var rci: TRenderContextInfo);
Protected procedure EndParticles(var rci: TRenderContextInfo); override;
Protected procedure FinalizeRendering(var rci: TRenderContextInfo); override;
Protected procedure InitializeRendering(var rci: TRenderContextInfo); override;
Protected procedure PrepareImage(bmp32: TGLBitmap32; var texFormat: Integer); virtual; abstract;

Subclasses should draw their stuff in this bmp32.

Protected procedure RenderParticle(var rci: TRenderContextInfo; aParticle: TGLParticle); override;
Protected procedure SetAspectRatio(const val: Single);
Protected procedure SetColorMode(const val: TSpriteColorMode);
Protected procedure SetRotation(const val: Single);
Protected procedure SetShareSprites(const val: TGLBaseSpritePFXManager);
Protected procedure SetSpritesPerTexture(const val: TSpritesPerTexture); virtual;

Properties

Published property AspectRatio: Single read FAspectRatio write SetAspectRatio stored StoreAspectRatio;

Ratio between width and height.<p> An AspectRatio of 1 (default) will result in square sprite particles, values higher than one will result in horizontally stretched sprites, values below one will stretch vertically (assuming no rotation is applied).

Public property ColorMode: TSpriteColorMode read FColorMode write SetColorMode;
Published property Rotation: Single read FRotation write SetRotation;

Particle sprites rotation (in degrees).<p> All particles of the PFX manager share this rotation.

Published property ShareSprites: TGLBaseSpritePFXManager read FShareSprites write FShareSprites;

If specified the manager will reuse the other manager's sprites.<p> Sharing sprites between PFX managers can help at the rendering stage if particles of the managers are mixed by helping reduce the number of texture switches. Note that only the texture is shared, not the colors, sizes or other dynamic parameters.<br>

Protected property SpritesPerTexture: TSpritesPerTexture read FSpritesPerTexture write SetSpritesPerTexture;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticleFX: Class TGLCustomSpritePFXManager

Class TGLCustomSpritePFXManager

Unit

GLParticleFX

Declaration

type TGLCustomSpritePFXManager = class(TGLBaseSpritePFXManager)

Description

A sprite-based particles FX managers using user-specified code to prepare the texture.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager
  • TGLBaseSpritePFXManager
  • TGLCustomSpritePFXManager

Overview

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | procedure PrepareImage(bmp32: TGLBitmap32; var texFormat: Integer); override;

Properties

Published | property ColorInner;
Published | property ColorMode default scmInner;
Published | property ColorOuter;
Published | property LifeColors;
Published | property OnPrepareTextureImage: TPFXPrepareTextureImageEvent read FOnPrepareTextureImage write FOnPrepareTextureImage;
Published | property ParticleSize;
Published | property SpritesPerTexture default sptOne;

Description

Methods

Public constructor Create(aOwner: TComponent); override;
Public destructor Destroy; override;
Protected procedure PrepareImage(bmp32: TGLBitmap32; var texFormat: Integer); override;

Properties

Published property ColorInner;
Published property ColorMode default scmInner;
Published property ColorOuter;
Published property LifeColors;
Published property OnPrepareTextureImage: TPFXPrepareTextureImageEvent read FOnPrepareTextureImage write FOnPrepareTextureImage;

Place your texture rendering code in this event.<p>

Published property ParticleSize;
Published property SpritesPerTexture default sptOne;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticleFX: Class TGLPointLightPFXManager

Class TGLPointLightPFXManager

Unit

GLParticleFX

Declaration

type TGLPointLightPFXManager = class(TGLBaseSpritePFXManager)

Description

A sprite-based particles FX managers using point light maps.<p> The texture map is a round, distance-based transparency map (center "opaque"), you can adjust the quality (size) of the underlying texture map with the TexMapSize property.<p> This PFX manager renders particles similar to what you can get with TGLPolygonPFXManager but stresses fillrate more than T&L rate (and will usually be slower than the PolygonPFX when nbSides is low or T&L acceleration available). Consider this implementation as a sample for your own PFX managers that may use particles with more complex textures.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager
  • TGLBaseSpritePFXManager
  • TGLPointLightPFXManager

Overview

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | procedure PrepareImage(bmp32: TGLBitmap32; var texFormat: Integer); override;
Protected | procedure SetTexMapSize(const val: Integer);

Properties

Published | property ColorInner;
Published | property ColorMode default scmInner;
Published | property ColorOuter;
Published | property LifeColors;
Published | property ParticleSize;
Published | property TexMapSize: Integer read FTexMapSize write SetTexMapSize default 5;

Description

Methods

Public constructor Create(aOwner: TComponent); override;
Public destructor Destroy; override;
Protected procedure PrepareImage(bmp32: TGLBitmap32; var texFormat: Integer); override;
Protected procedure SetTexMapSize(const val: Integer);

Properties

Published property ColorInner;
Published property ColorMode default scmInner;
Published property ColorOuter;
Published property LifeColors;
Published property ParticleSize;
Published property TexMapSize: Integer read FTexMapSize write SetTexMapSize default 5;

Underlying texture map size, as a power of two.<p> Min value is 3 (size=8), max value is 9 (size=512).

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticles

Unit GLParticles

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLParticles<p>

Particle systems for GLScene, based on replication of full-featured scene objects.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>27/07/04 - EG - Added KillParticles <li>18/04/04 - EG - Added Before/After events <li>12/07/01 - EG - Fixed FEdgeColor memory leak <li>18/07/01 - EG - VisibilityCulling compatibility changes <li>17/04/00 - EG - Added Assign, Removed ActivateParticle <li>16/04/00 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLParticles |

Types

TGLParticleEvent = procedure(Sender: TObject; particle: TGLBaseSceneObject) of object;

Description

Types

TGLParticleEvent = procedure(Sender: TObject; particle: TGLBaseSceneObject) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLParticles: Class TGLParticles

Class TGLParticles

Unit

GLParticles

Declaration

type TGLParticles = class(TGLImmaterialSceneObject)

Description

Manager object of a particle system.<p> Particles in a TGLParticles system are described as normal scene objects, however their children are to be :<ul> <li>"particle template" : the first object (index=0), this one will be duplicated to create new particles, it does not receive progression events and is visible at design-time only. <li>"live particle" : the other objects (index>0), this ones are rendered and receive progression events. </ul><br>TGLParticles may also maintain an internal, non-persistent ("freezed") set of objects : the allocated objects pool. Why ? Creating and freeing objects takes cpu-cycles, especially for the TComponent class, and GLScene objects are TComponent. To reduce this load (and at the expense of memory space), the particle systems can move "dead" particles to a pool instead of freeing them, and will pick in the pool instead of creating new objects when new particles are requested. To take advantage of this behaviour, you should set the ParticlePoolSize property to a non-null value and use the KillParticle function instead of "Free" to kill a particle.<br> All direct access to a TGLParticles children should be avoided.<p> For high-performance particle systems of basic particles, you should look into GLParticleFX instead, TGLParticles being rather focused on complex particles.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLParticles

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateParticle: TGLBaseSceneObject;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var ARci: TRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure KillParticle(aParticle: TGLBaseSceneObject);
Public | procedure KillParticles;
Protected | procedure ClearParticlePool;
Protected | procedure SetCubeSize(const val: TGLFloat);
Protected | procedure SetEdgeColor(const val: TGLColor);
Protected | procedure SetParticlePoolSize(val: Integer);
Protected | procedure SetVisibleAtRunTime(const val: Boolean);

Properties

Published | property CubeSize: TGLFloat read FCubeSize write SetCubeSize;
Published | property EdgeColor: TGLColor read FEdgeColor write SetEdgeColor;
Published | property OnActivateParticle: TGLParticleEvent read FOnActivateParticle write FOnActivateParticle;
Published | property OnAfterRenderParticles: TDirectRenderEvent read FOnAfterRenderParticles write FOnAfterRenderParticles;
Published | property OnBeforeRenderParticles: TDirectRenderEvent read FOnBeforeRenderParticles write FOnBeforeRenderParticles;
Published | property OnCreateParticle: TGLParticleEvent read FOnCreateParticle write FOnCreateParticle;
Published | property OnDestroyParticle: TGLParticleEvent read FOnDestroyParticle write FOnDestroyParticle;
Published | property OnKillParticle: TGLParticleEvent read FOnKillParticle write FOnKillParticle;
Published | property ParticlePoolSize: Integer read FParticlePoolSize write SetParticlePoolSize default 0;
Published | property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function CreateParticle: TGLBaseSceneObject;

Request creation of a new particle.<p> Particle will be either created or retrieved from the particlePool.

Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var ARci: TRenderContextInfo); override;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public procedure KillParticle(aParticle: TGLBaseSceneObject);

Kill given particle.<p> If particlePool is not full, particle will be sent to the pool, if not, it will be freed.

Public procedure KillParticles;

Kill all particles.

Protected procedure ClearParticlePool;
Protected procedure SetCubeSize(const val: TGLFloat);
Protected procedure SetEdgeColor(const val: TGLColor);
Protected procedure SetParticlePoolSize(val: Integer);
Protected procedure SetVisibleAtRunTime(const val: Boolean);

Properties

Published property CubeSize: TGLFloat read FCubeSize write SetCubeSize;
Published property EdgeColor: TGLColor read FEdgeColor write SetEdgeColor;
Published property OnActivateParticle: TGLParticleEvent read FOnActivateParticle write FOnActivateParticle;

Fired when a particle will get in the "live" list.<p> The particle has just been "Assigned" with the template, may happen after a creation or a pick from the particle pool.

Published property OnAfterRenderParticles: TDirectRenderEvent read FOnAfterRenderParticles write FOnAfterRenderParticles;

Fired after rendering the last of the particles.

Published property OnBeforeRenderParticles: TDirectRenderEvent read FOnBeforeRenderParticles write FOnBeforeRenderParticles;

Fired before rendering the first of the particles.

Published property OnCreateParticle: TGLParticleEvent read FOnCreateParticle write FOnCreateParticle;

Fired a particle has been created as a template duplicate.<p> When the event is triggered, the particle has yet been added to the scene.

Published property OnDestroyParticle: TGLParticleEvent read FOnDestroyParticle write FOnDestroyParticle;

Triggered just before destroying a particle.<p> The particle can be in the pool (ie. not parented).

Published property OnKillParticle: TGLParticleEvent read FOnKillParticle write FOnKillParticle;

Triggered when a particle is killed.<p> When the event is fired, the particle is still parented, after this event, the particle will either go to the pool or be destroyed if the pool is full.

Published property ParticlePoolSize: Integer read FParticlePoolSize write SetParticlePoolSize default 0;

Size of the particle pool (for storing killed particles).<p> Default size is zero, meaning the particlePool is disabled.

Published property VisibleAtRunTime: Boolean read FVisibleAtRunTime write SetVisibleAtRunTime default False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLPerlin

Unit GLPerlin

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBasePerlinOctav |
Class TGLBasePerlin |
Class TGL1DPerlin |
Class TGL2DPerlinOctav |
Class TGL2DPerlin |
Class TGLPerlinHDS |
Class TGLPerlinHDSThread |

Types

TGLPerlinInterpolation = (...);
TGLPerlinOctav = class of TGLBasePerlinOctav;

Description

Types

TGLPerlinInterpolation = (...);
Values
  • pi_none:
  • pi_simple:
  • pi_linear:
  • pi_Smoothed:
  • pi_Cosine:
  • pi_cubic:
TGLPerlinOctav = class of TGLBasePerlinOctav;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:37


GLScene v.1.1.2: GLPerlin: Class TGLBasePerlinOctav

Class TGLBasePerlinOctav

Unit

GLPerlin

Declaration

type TGLBasePerlinOctav = class(TObject)

Description

Hierarchy

  • TObject
  • TGLBasePerlinOctav

Overview

Methods

Public Procedure Generate; dynamic; abstract;

Properties

Public | property Amplitude: Double read FAmplitude write FAmplitude;
Public | property Interpolation: TGLPerlinInterpolation read FInterpolation write FInterpolation;
Public | property Scale: Double read FScale write FScale;
Public | property Smoothing: TGLPerlinInterpolation read FSmoothing write FSmoothing;

Description

Methods

Public Procedure Generate; dynamic; abstract;

Properties

Public property Amplitude: Double read FAmplitude write FAmplitude;
Public property Interpolation: TGLPerlinInterpolation read FInterpolation write FInterpolation;
Public property Scale: Double read FScale write FScale;
Public property Smoothing: TGLPerlinInterpolation read FSmoothing write FSmoothing;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPerlin: Class TGLBasePerlin

Class TGLBasePerlin

Unit

GLPerlin

Declaration

type TGLBasePerlin = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLBasePerlin

Overview

Methods

Public | Constructor Create(AOwner: TComponent); override;
Protected | function GetOctave(index: Integer): TGLBasePerlinOctav;
Protected | function PerlinNoise_1D(x: Double): Double;
Protected | function PerlinNoise_2D(x, y: Double): Double;
Public | Procedure Generate; dynamic; abstract;
Protected | Procedure SetPersistence(val: Double);
Protected | Procedure Set_Number_Of_Octaves(val: Integer);

Properties

Published | property Interpolation: TGLPerlinInterpolation read FInterpolation write FInterpolation;
Published | property Number_Of_Octaves: Integer read FNumber_Of_Octaves write Set_Number_Of_Octaves;
Public | property Octaves[index: Integer]: TGLBasePerlinOctav read GetOctave;
Published | property Persistence: Double read FPersistence write SetPersistence;
Published | property Smoothing: TGLPerlinInterpolation read FSmoothing write FSmoothing;

Description

Methods

Public Constructor Create(AOwner: TComponent); override;
Protected function GetOctave(index: Integer): TGLBasePerlinOctav;
Protected function PerlinNoise_1D(x: Double): Double;
Protected function PerlinNoise_2D(x, y: Double): Double;
Public Procedure Generate; dynamic; abstract;
Protected Procedure SetPersistence(val: Double);
Protected Procedure Set_Number_Of_Octaves(val: Integer);

Properties

Published property Interpolation: TGLPerlinInterpolation read FInterpolation write FInterpolation;
Published property Number_Of_Octaves: Integer read FNumber_Of_Octaves write Set_Number_Of_Octaves;
Public property Octaves[index: Integer]: TGLBasePerlinOctav read GetOctave;
Published property Persistence: Double read FPersistence write SetPersistence;
Published property Smoothing: TGLPerlinInterpolation read FSmoothing write FSmoothing;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPerlin: Class TGL1DPerlin

Class TGL1DPerlin

Unit

GLPerlin

Declaration

type TGL1DPerlin = class(TGLBasePerlin)

Description

no description available, TGLBasePerlin description follows

Hierarchy

  • TComponent
  • TGLBasePerlin
  • TGL1DPerlin

Overview

Methods

Published Function GetPerlinValue_1D(x: Double): Double;

Description

Methods

Published Function GetPerlinValue_1D(x: Double): Double;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPerlin: Class TGL2DPerlinOctav

Class TGL2DPerlinOctav

Unit

GLPerlin

Declaration

type TGL2DPerlinOctav = class(TGLBasePerlinOctav)

Description

no description available, TGLBasePerlinOctav description follows

Hierarchy

  • TObject
  • TGLBasePerlinOctav
  • TGL2DPerlinOctav

Overview

Fields

Public | Data: T2DPerlinArray;
Public | Width: Integer;
Public | Height: Integer;
Public | XStart: Integer;
Public | YStart: Integer;
Public | XStep: Integer;
Public | YStep: Integer;
Public | YRate: Integer;

Methods

Public | Function GetCosine(x, y: Double): Double;
Public | Function GetCubic(x, y: Double): Double;
Public | Function GetData(x, y: Integer): Double;
Public | Function GetDataSmoothed(x, y: Integer): Double;
Public | Function GetPerling(x, y: Double): Double;
Public | Procedure Generate; override;
Public | Procedure Generate_CubicInterpolate;
Public | Procedure Generate_NonInterpolated;
Public | Procedure Generate_SmoothInterpolate;

Description

Fields

Public Data: T2DPerlinArray;
Public Width: Integer;
Public Height: Integer;
Public XStart: Integer;
Public YStart: Integer;
Public XStep: Integer;
Public YStep: Integer;
Public YRate: Integer;

Methods

Public Function GetCosine(x, y: Double): Double;
Public Function GetCubic(x, y: Double): Double;
Public Function GetData(x, y: Integer): Double;
Public Function GetDataSmoothed(x, y: Integer): Double;
Public Function GetPerling(x, y: Double): Double;
Public Procedure Generate; override;
Public Procedure Generate_CubicInterpolate;
Public Procedure Generate_NonInterpolated;
Public Procedure Generate_SmoothInterpolate;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPerlin: Class TGL2DPerlin

Class TGL2DPerlin

Unit

GLPerlin

Declaration

type TGL2DPerlin = class(TGLBasePerlin)

Description

no description available, TGLBasePerlin description follows

Hierarchy

  • TComponent
  • TGLBasePerlin
  • TGL2DPerlin

Overview

Fields

Public | Width: Integer;
Public | Height: Integer;
Public | XStart: Integer;
Public | YStart: Integer;
Public | XStep: Integer;
Public | YStep: Integer;
Public | MaxValue: Double;
Public | MinValue: Double;

Methods

Public | Constructor Create(AOwner: TComponent); override;
Public | Function GetPerlinValue_2D(x, y: Double): Double;
Public | Procedure Generate; override;
Public | Procedure MakeBitmap(Param: TGLBitmap);
Public | Procedure SetHeightData(heightData: THeightData);

Description

Fields

Public Width: Integer;
Public Height: Integer;
Public XStart: Integer;
Public YStart: Integer;
Public XStep: Integer;
Public YStep: Integer;
Public MaxValue: Double;
Public MinValue: Double;

Methods

Public Constructor Create(AOwner: TComponent); override;
Public Function GetPerlinValue_2D(x, y: Double): Double;
Public Procedure Generate; override;
Public Procedure MakeBitmap(Param: TGLBitmap);
Public Procedure SetHeightData(heightData: THeightData);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPerlin: Class TGLPerlinHDS

Class TGLPerlinHDS

Unit

GLPerlin

Declaration

type TGLPerlinHDS = class(THeightDataSource)

Description

no description available, THeightDataSource description follows

Hierarchy

  • TComponent
  • THeightDataSource
  • TGLPerlinHDS

Overview

Fields

Public | MaxValue: Double;
Public | MinValue: Double;
Public | Stall: Boolean;

Methods

Public | Constructor Create(AOwner: TComponent); override;
Public | procedure StartPreparingData(heightData: THeightData); override;
Public | procedure WaitFor;

Properties

Published | property Interpolation: TGLPerlinInterpolation read FInterpolation write FInterpolation;
Public | property Lines: TStrings read FLines;
Public | property LinesChanged: Boolean read FLinesChanged write FLinesChanged;
Published | property MaxPoolSize;
Published | property Number_Of_Octaves: Integer read FNumber_Of_Octaves write FNumber_Of_Octaves;
Published | property Persistence: Double read FPersistence write FPersistence;
Published | property Smoothing: TGLPerlinInterpolation read FSmoothing write FSmoothing;
Published | property XStart: Integer read FXStart write FXStart;
Published | property YStart: Integer read FYStart write FYStart;

Description

Fields

Public MaxValue: Double;
Public MinValue: Double;
Public Stall: Boolean;

Methods

Public Constructor Create(AOwner: TComponent); override;
Public procedure StartPreparingData(heightData: THeightData); override;
Public procedure WaitFor;

Properties

Published property Interpolation: TGLPerlinInterpolation read FInterpolation write FInterpolation;
Public property Lines: TStrings read FLines;
Public property LinesChanged: Boolean read FLinesChanged write FLinesChanged;
Published property MaxPoolSize;
Published property Number_Of_Octaves: Integer read FNumber_Of_Octaves write FNumber_Of_Octaves;
Published property Persistence: Double read FPersistence write FPersistence;
Published property Smoothing: TGLPerlinInterpolation read FSmoothing write FSmoothing;
Published property XStart: Integer read FXStart write FXStart;
Published property YStart: Integer read FYStart write FYStart;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPerlin: Class TGLPerlinHDSThread

Class TGLPerlinHDSThread

Unit

GLPerlin

Declaration

type TGLPerlinHDSThread = class(THeightDataThread)

Description

no description available, THeightDataThread description follows

Hierarchy

  • TThread
  • THeightDataThread
  • TGLPerlinHDSThread

Overview

Fields

Published | Perlin: TGL2DPerlin;
Published | PerlinSource: TGLPerlinHDS;

Methods

Published | Procedure Execute; override;
Published | Procedure OpdateOutSide;

Description

Fields

Published Perlin: TGL2DPerlin;
Published PerlinSource: TGLPerlinHDS;

Methods

Published Procedure Execute; override;
Published Procedure OpdateOutSide;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPerlinBase

Unit GLPerlinBase

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLScene<p>

Functions for generating perlin noise.<p>

<b>History : </b><font size=-1><ul> <li>20/05/10 - Yar - Fixes for Linux x64 <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Cosmetic fixes for FPC compatibility. <li>29/01/03 - JaJ - Submitted to GLScene. </ul></font>

Overview

Functions and Procedures

function Linear_Interpolate(const a, b, x : Double) : Double;
function Cubic_Interpolate(v0, v1, v2, v3,x : Double) : Double;
Function Cosine_Interpolate(const a, b, x : Double) : Double;
Function Perlin_Random1(X : Integer) : Double;
Function Perlin_Random2(Const X,Y : Integer) : Double;
Procedure Perlin_Random1DStrip(X,Width,Step : Integer; Amp : Double; Res : T1DPerlinArray);
procedure Cubic_Interpolate_Strip(B1,B2,B3,B4,Res : T1DPerlinArray; Width : Integer);
procedure Smooth_Interpolate_Strip(B1,B2,B3,Res : T1DPerlinArray; Width : Integer);
Function ExponateCrap(root, exponant : Integer) : Integer;

Types

T1DPerlinArray = array of Double;
T2DPerlinArray = array of T1DPerlinArray;

Description

Functions and Procedures

function Linear_Interpolate(const a, b, x : Double) : Double;
function Cubic_Interpolate(v0, v1, v2, v3,x : Double) : Double;
Function Cosine_Interpolate(const a, b, x : Double) : Double;
Function Perlin_Random1(X : Integer) : Double;
Function Perlin_Random2(Const X,Y : Integer) : Double;
Procedure Perlin_Random1DStrip(X,Width,Step : Integer; Amp : Double; Res : T1DPerlinArray);
procedure Cubic_Interpolate_Strip(B1,B2,B3,B4,Res : T1DPerlinArray; Width : Integer);
procedure Smooth_Interpolate_Strip(B1,B2,B3,Res : T1DPerlinArray; Width : Integer);
Function ExponateCrap(root, exponant : Integer) : Integer;

Types

T1DPerlinArray = array of Double;
T2DPerlinArray = array of T1DPerlinArray;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPerlinPFX

Unit GLPerlinPFX

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLPerlinPFX<p>

PFX particle effects revolving around the use of Perlin noise.<p>

<b>History : </b><font size=-1><ul> <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/01/10 - Yar - Added bmp32.Blank:=false for memory allocation <li>30/03/07 - DaStr - Added $I GLScene.inc <li>16/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>15/04/04 - Mrqzzz - Fixed range check error suggested by Graham Kennedy <li>15/04/04 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPerlinPFXManager |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPerlinPFX: Class TGLPerlinPFXManager

Class TGLPerlinPFXManager

Unit

GLPerlinPFX

Declaration

type TGLPerlinPFXManager = class(TGLBaseSpritePFXManager)

Description

A sprite-based particles FX manager using perlin-based sprites.<p> This PFX manager is more suited for smoke or fire effects, and with proper tweaking of the texture and perlin parameters, may help render a convincing effect with less particles.<p> The sprite generate by this manager is the composition of a distance-based intensity and a perlin noise.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomCadencedComponent
  • TGLCadencedComponent
  • TGLParticleFXManager
  • TGLDynamicPFXManager
  • TGLLifeColoredPFXManager
  • TGLBaseSpritePFXManager
  • TGLPerlinPFXManager

Overview

Methods

Public | constructor Create(aOwner : TComponent); override;
Public | destructor Destroy; override;
Protected | procedure PrepareImage(bmp32 : TGLBitmap32; var texFormat : Integer); override;
Protected | procedure SetBrightness(const val : Single);
Protected | procedure SetGamma(const val : Single);
Protected | procedure SetNoiseAmplitude(const val : Integer);
Protected | procedure SetNoiseScale(const val : Integer);
Protected | procedure SetNoiseSeed(const val : Integer);
Protected | procedure SetSmoothness(const val : Single);
Protected | procedure SetTexMapSize(const val : Integer);

Properties

Published | property Brightness : Single read FBrightness write SetBrightness;
Published | property ColorInner;
Published | property ColorMode default scmInner;
Published | property ColorOuter;
Published | property Gamma : Single read FGamma write SetGamma;
Published | property LifeColors;
Published | property NoiseAmplitude : Integer read FNoiseAmplitude write SetNoiseAmplitude default 50;
Published | property NoiseScale : Integer read FNoiseScale write SetNoiseScale default 100;
Published | property NoiseSeed : Integer read FNoiseSeed write SetNoiseSeed default 0;
Published | property ParticleSize;
Published | property Smoothness : Single read FSmoothness write SetSmoothness;
Published | property SpritesPerTexture default sptFour;
Published | property TexMapSize : Integer read FTexMapSize write SetTexMapSize default 6;

Description

Methods

Public constructor Create(aOwner : TComponent); override;
Public destructor Destroy; override;
Protected procedure PrepareImage(bmp32 : TGLBitmap32; var texFormat : Integer); override;
Protected procedure SetBrightness(const val : Single);
Protected procedure SetGamma(const val : Single);
Protected procedure SetNoiseAmplitude(const val : Integer);
Protected procedure SetNoiseScale(const val : Integer);
Protected procedure SetNoiseSeed(const val : Integer);
Protected procedure SetSmoothness(const val : Single);
Protected procedure SetTexMapSize(const val : Integer);

Properties

Published property Brightness : Single read FBrightness write SetBrightness;

Brightness factor applied to the perlin texture intensity.<p> Brightness acts as a scaling, non-saturating factor. Examples:<ul> <li>Brightness = 1 : intensities in the [0; 1] range <li>Brightness = 2 : intensities in the [0.5; 1] range <li>Brightness = 0.5 : intensities in the [0; 0.5] range </ul>Brightness is applied to the final texture (and thus affects the distance based intensity).

Published property ColorInner;
Published property ColorMode default scmInner;
Published property ColorOuter;
Published property Gamma : Single read FGamma write SetGamma;
Published property LifeColors;
Published property NoiseAmplitude : Integer read FNoiseAmplitude write SetNoiseAmplitude default 50;

Amplitude applied to the perlin noise (intensity).<p> This value represent the percentage of the sprite luminance affected by the perlin texture.

Published property NoiseScale : Integer read FNoiseScale write SetNoiseScale default 100;

Scale applied to the perlin noise (stretching).

Published property NoiseSeed : Integer read FNoiseSeed write SetNoiseSeed default 0;

Random seed to use for the perlin noise.

Published property ParticleSize;
Published property Smoothness : Single read FSmoothness write SetSmoothness;

Smoothness of the distance-based intensity.<p> This value is the exponent applied to the intensity in the texture, basically with a value of 1 (default) the intensity decreases linearly, with higher values, it will remain 'constant' in the center then fade-off more abruptly, and with values below 1, there will be a sharp spike in the center.

Published property SpritesPerTexture default sptFour;
Published property TexMapSize : Integer read FTexMapSize write SetTexMapSize default 6;

Underlying texture map size, as a power of two.<p> Min value is 3 (size=8), max value is 9 (size=512).

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPhongShader

Unit GLPhongShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLPhongShader<p>

An ARBvp1.0 + ARBfp1.0 shader that implements phong shading.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>28/07/09 - DaStr - Small changes and simplifications <li>24/07/09 - DaStr - TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) <li>20/03/07 - DaStr - Moved some of the stuff from TGLCustomAsmShader back here <li>25/02/07 - DaStr - Completely replaced with a descendant of TGLCustomAsmShader. <li>11/10/04 - SG - Creation. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPhongShader |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPhongShader: Class TGLPhongShader

Class TGLPhongShader

Unit

GLPhongShader

Declaration

type TGLPhongShader = class(TGLCustomAsmShader)

Description

no description available, TGLCustomAsmShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomAsmShader
  • TGLPhongShader

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ShaderSupported: Boolean; override;
Protected | function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected | procedure DoAmbientPass(var rci: TRenderContextInfo); virtual;
Protected | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected | procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure DoLightPass(lightID: Cardinal); virtual;
Protected | procedure UnApplyLights(var rci: TRenderContextInfo); virtual;

Properties

Published property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled default False;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function ShaderSupported: Boolean; override;
Protected function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected procedure DoAmbientPass(var rci: TRenderContextInfo); virtual;
Protected procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure DoLightPass(lightID: Cardinal); virtual;
Protected procedure UnApplyLights(var rci: TRenderContextInfo); virtual;

Properties

Published property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled default False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPipelineTransformation

Unit GLPipelineTransformation

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLPipelineTransformation<p>

<b>History : </b><font size=-1><ul> <li>11/05/11 - Yar - Ranamed TGLPipelineTransformation to TGLTransformation <li>16/11/10 - Yar - Added NormalModelMatrix <li>23/08/10 - Yar - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TTransformationRec |
Class TGLTransformation |

Types

TGLPipelineTransformationState = (...);
TGLPipelineTransformationStates = set of TGLPipelineTransformationState;
PTransformationRec = ˆTTransformationRec;
TOnMatricesPush = procedure() of object;
TGLCall = function(): TGLExtensionsAndEntryPoints;

Constants

MAX_MATRIX_STACK_DEPTH = 128;
cAllStatesChanged = [trsModelViewChanged, trsInvModelViewChanged, trsInvModelChanged, trsViewProjChanged, trsNormalModelChanged, trsFrustum];

Variables

vLocalGL: TGLCall;

Description

Types

TGLPipelineTransformationState = (...);
Values
  • trsModelViewChanged:
  • trsInvModelViewChanged:
  • trsInvModelChanged:
  • trsNormalModelChanged:
  • trsViewProjChanged:
  • trsFrustum:
TGLPipelineTransformationStates = set of TGLPipelineTransformationState;
PTransformationRec = ˆTTransformationRec;
TOnMatricesPush = procedure() of object;
TGLCall = function(): TGLExtensionsAndEntryPoints;

Constants

MAX_MATRIX_STACK_DEPTH = 128;
cAllStatesChanged = [trsModelViewChanged, trsInvModelViewChanged, trsInvModelChanged, trsViewProjChanged, trsNormalModelChanged, trsFrustum];

Variables

vLocalGL: TGLCall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPipelineTransformation: record TTransformationRec

record TTransformationRec

Unit

GLPipelineTransformation

Declaration

type TTransformationRec = record

Description

Overview

Fields

FStates: TGLPipelineTransformationStates;
FModelMatrix: TMatrix;
FViewMatrix: TMatrix;
FProjectionMatrix: TMatrix;
FInvModelMatrix: TMatrix;
FNormalModelMatrix: TAffineMatrix;
FModelViewMatrix: TMatrix;
FInvModelViewMatrix: TMatrix;
FViewProjectionMatrix: TMatrix;
FFrustum: TFrustum;

Description

Fields

FStates: TGLPipelineTransformationStates;
FModelMatrix: TMatrix;
FViewMatrix: TMatrix;
FProjectionMatrix: TMatrix;
FInvModelMatrix: TMatrix;
FNormalModelMatrix: TAffineMatrix;
FModelViewMatrix: TMatrix;
FInvModelViewMatrix: TMatrix;
FViewProjectionMatrix: TMatrix;
FFrustum: TFrustum;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPipelineTransformation: Class TGLTransformation

Class TGLTransformation

Unit

GLPipelineTransformation

Declaration

type TGLTransformation = class(TObject)

Description

Hierarchy

  • TObject
  • TGLTransformation

Overview

Methods

Public | constructor Create;
Public | function StackTop: TTransformationRec;
Public | procedure IdentityAll;
Public | procedure Pop;
Public | procedure Push(AValue: PTransformationRec = nil);
Public | procedure ReplaceFromStack;
Protected | procedure DoMatrcesLoaded; inline;
Protected | procedure LoadModelViewMatrix; inline;
Protected | procedure LoadProjectionMatrix; inline;

Properties

Public | property Frustum: TFrustum read GetFrustum;
Public | property InvModelMatrix: TMatrix read GetInvModelMatrix;
Public | property InvModelViewMatrix: TMatrix read GetInvModelViewMatrix;
Public | property LoadMatricesEnabled: Boolean read FLoadMatricesEnabled write FLoadMatricesEnabled;
Public | property ModelMatrix: TMatrix read GetModelMatrix write SetModelMatrix;
Public | property ModelViewMatrix: TMatrix read GetModelViewMatrix;
Public | property NormalModelMatrix: TAffineMatrix read GetNormalModelMatrix;
Protected | property OnPush: TOnMatricesPush read FOnPush write FOnPush;
Public | property ProjectionMatrix: TMatrix read GetProjectionMatrix write SetProjectionMatrix;
Public | property ViewMatrix: TMatrix read GetViewMatrix write SetViewMatrix;
Public | property ViewProjectionMatrix: TMatrix read GetViewProjectionMatrix;

Description

Methods

Public constructor Create;
Public function StackTop: TTransformationRec;
Public procedure IdentityAll;
Public procedure Pop;
Public procedure Push(AValue: PTransformationRec = nil);
Public procedure ReplaceFromStack;
Protected procedure DoMatrcesLoaded; inline;
Protected procedure LoadModelViewMatrix; inline;
Protected procedure LoadProjectionMatrix; inline;

Properties

Public property Frustum: TFrustum read GetFrustum;
Public property InvModelMatrix: TMatrix read GetInvModelMatrix;
Public property InvModelViewMatrix: TMatrix read GetInvModelViewMatrix;
Public property LoadMatricesEnabled: Boolean read FLoadMatricesEnabled write FLoadMatricesEnabled;
Public property ModelMatrix: TMatrix read GetModelMatrix write SetModelMatrix;
Public property ModelViewMatrix: TMatrix read GetModelViewMatrix;
Public property NormalModelMatrix: TAffineMatrix read GetNormalModelMatrix;
Protected property OnPush: TOnMatricesPush read FOnPush write FOnPush;
Public property ProjectionMatrix: TMatrix read GetProjectionMatrix write SetProjectionMatrix;
Public property ViewMatrix: TMatrix read GetViewMatrix write SetViewMatrix;
Public property ViewProjectionMatrix: TMatrix read GetViewProjectionMatrix;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPolyhedron

Unit GLPolyhedron

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Standard polyhedrons.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses <li>20/01/04 - SG - Added TGLIcosahedron <li>21/07/03 - EG - Creation from GLObjects split </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLDodecahedron |
Class TGLIcosahedron |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPolyhedron: Class TGLDodecahedron

Class TGLDodecahedron

Unit

GLPolyhedron

Declaration

type TGLDodecahedron = class(TGLSceneObject)

Description

A Dodecahedron.<p> The dodecahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLDodecahedron

Overview

Methods

Public procedure BuildList(var rci: TRenderContextInfo); override;

Description

Methods

Public procedure BuildList(var rci: TRenderContextInfo); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPolyhedron: Class TGLIcosahedron

Class TGLIcosahedron

Unit

GLPolyhedron

Declaration

type TGLIcosahedron = class(TGLSceneObject)

Description

A Icosahedron.<p> The icosahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLIcosahedron

Overview

Methods

Public procedure BuildList(var rci: TRenderContextInfo); override;

Description

Methods

Public procedure BuildList(var rci: TRenderContextInfo); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPortal

Unit GLPortal

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLPortal<p>

Portal Rendering support for GLScene.<p>

The portal structures are subclasses of the Mesh structures, with a "sector" being assimilated to a "MeshObject" and sector polygons to facegroups.<p>

<b>Historique : </b><font size=-1><ul> <li>30/03/07 - DaStr - Added $I GLScene.inc <li>30/01/03 - Egg - Completed class registration <li>13/08/00 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TPortalMeshObjectList |
Class TSectorMeshObject |
Class TFGPolygon |
Class TFGPortalPolygon |
Class TGLPortal |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPortal: Class TPortalMeshObjectList

Class TPortalMeshObjectList

Unit

GLPortal

Declaration

type TPortalMeshObjectList = class(TMeshObjectList)

Description

A mesh object list that handles portal rendering.<p> The items are treated as being sectors.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TMeshObjectList
  • TPortalMeshObjectList

Overview

Methods

Public | constructor CreateOwned(AOwner : TGLBaseMesh);
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci : TRenderContextInfo); override;

Description

Methods

Public constructor CreateOwned(AOwner : TGLBaseMesh);
Public destructor Destroy; override;
Public procedure BuildList(var mrci : TRenderContextInfo); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPortal: Class TSectorMeshObject

Class TSectorMeshObject

Unit

GLPortal

Declaration

type TSectorMeshObject = class(TMorphableMeshObject)

Description

A portal renderer sector.<p>

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseMeshObject
  • TMeshObject
  • TMorphableMeshObject
  • TSectorMeshObject

Overview

Methods

Public | constructor CreateOwned(AOwner : TMeshObjectList);
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci : TRenderContextInfo); override;
Public | procedure Prepare; override;

Properties

Public property RenderDone : Boolean read FRenderDone write FRenderDone;

Description

Methods

Public constructor CreateOwned(AOwner : TMeshObjectList);
Public destructor Destroy; override;
Public procedure BuildList(var mrci : TRenderContextInfo); override;
Public procedure Prepare; override;

Properties

Public property RenderDone : Boolean read FRenderDone write FRenderDone;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPortal: Class TFGPolygon

Class TFGPolygon

Unit

GLPortal

Declaration

type TFGPolygon = class(TFGVertexNormalTexIndexList)

Description

A portal polygon.<p> This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TFaceGroup
  • TFGVertexIndexList
  • TFGVertexNormalTexIndexList
  • TFGPolygon

Overview

Methods

Public | constructor CreateOwned(AOwner : TFaceGroups); override;
Public | destructor Destroy; override;
Public | procedure Prepare; override;

Description

Methods

Public constructor CreateOwned(AOwner : TFaceGroups); override;
Public destructor Destroy; override;
Public procedure Prepare; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPortal: Class TFGPortalPolygon

Class TFGPortalPolygon

Unit

GLPortal

Declaration

type TFGPortalPolygon = class(TFGPolygon)

Description

A portal polygon.<p> This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TFaceGroup
  • TFGVertexIndexList
  • TFGVertexNormalTexIndexList
  • TFGPolygon
  • TFGPortalPolygon

Overview

Methods

Public | constructor CreateOwned(AOwner : TFaceGroups); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var mrci : TRenderContextInfo); override;
Public | procedure Prepare; override;

Properties

Public property DestinationSectorIndex : Integer read FDestinationSectorIndex write FDestinationSectorIndex;

Description

Methods

Public constructor CreateOwned(AOwner : TFaceGroups); override;
Public destructor Destroy; override;
Public procedure BuildList(var mrci : TRenderContextInfo); override;
Public procedure Prepare; override;

Properties

Public property DestinationSectorIndex : Integer read FDestinationSectorIndex write FDestinationSectorIndex;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPortal: Class TGLPortal

Class TGLPortal

Unit

GLPortal

Declaration

type TGLPortal = class(TGLBaseMesh)

Description

Portal Renderer class.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLPortal

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;

Properties

Published property MaterialLibrary;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;

Properties

Published property MaterialLibrary;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPostEffects

Unit GLPostEffects

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLPostEffects<p>

A collection of components that generate post effects.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>28/05/08 - DaStr - Fixed AV in TGLPostEffect.MakeDistortEffect() Got rid of all R- hacks <li>10/04/08 - DaStr - Added a Delpi 5 interface bug work-around to TGLPostShaderCollectionItem.SetShader() (BugTracker ID = 1938988) <li>16/08/07 - DaStr - Added pepBlur preset (by Paul van Dinther) <li>25/03/07 - DaStr - Small fix for Delphi5 compatibility <li>23/03/07 - DaStr - Added TGLPostShaderHolder.Assign <li>20/03/07 - DaStr - Fixed TGLPostShaderHolder.DoRender <li>09/03/07 - DaStr - Added pepNightVision preset (thanks Roman Ganz) Changed back all Trunc() calls to Round() <li>07/03/07 - DaStr - Moved "Weird" effect to the demo Added "Distort" effect Modified "RedNoise" to simple monochrome noise (preset renamed to "Noise") Made "Negative" effect really negative, instead swapping R and B channels Changed all Round() calls to Trunc() Removed all TGLPostEffectColor typecasts (All above changes were made by Michail Glukhov) TGLPostEffect and TGLPostShaderHolder are not rendered when DrawState=dsPicking (suggested by Riz) <li>04/03/07 - DaStr - Added TGLPostShaderHolder <li>02/03/07 - DaStr - TGLOnCustomPostEffectEvent now passes rci pepNone preset does not call gl[Read/Draw]Pixels <li>23/02/07 - DaStr - Initial version of TGLPostEffect (based on OldCity demo by FedeX) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLPostShaderHolderException |
Class TGLPostShaderCollectionItem |
Class TGLPostShaderCollection |
Class TGLPostShaderHolder |
record TGLPostEffectColor |
Class TGLPostEffect |

Types

TGLPostEffectBuffer = array of TGLPostEffectColor;
TGLOnCustomPostEffectEvent = procedure(Sender: TObject; var rci : TRenderContextInfo; var Buffer: TGLPostEffectBuffer) of object;
TGLPostEffectPreset = (...);

Description

Types

TGLPostEffectBuffer = array of TGLPostEffectColor;
TGLOnCustomPostEffectEvent = procedure(Sender: TObject; var rci : TRenderContextInfo; var Buffer: TGLPostEffectBuffer) of object;
TGLPostEffectPreset = (...);

Some presets for TGLPostEffect: pepNone - does nothing. pepGray - makes picture gray. pepNegative - inverts all colors. pepDistort - simulates shaky TV image. pepNoise - just adds random niose. pepNightVision - simulates nightvision goggles. pepBlur - blurs the scene. pepCustom - calls the OnCustomEffect event.

Values
  • pepNone:
  • pepGray:
  • pepNegative:
  • pepDistort:
  • pepNoise:
  • pepNightVision:
  • pepBlur:
  • pepCustom:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPostEffects: Class EGLPostShaderHolderException

Class EGLPostShaderHolderException

Unit

GLPostEffects

Declaration

type EGLPostShaderHolderException = class(Exception)

Description

Hierarchy

  • Exception
  • EGLPostShaderHolderException
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPostEffects: Class TGLPostShaderCollectionItem

Class TGLPostShaderCollectionItem

Unit

GLPostEffects

Declaration

type TGLPostShaderCollectionItem = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLPostShaderCollectionItem

Overview

Methods

Protected | function GetDisplayName: string; override;
Protected | function GetRealOwner: TGLPostShaderHolder;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published property Shader: TGLShader read FShader write SetShader;

Description

Methods

Protected function GetDisplayName: string; override;
Protected function GetRealOwner: TGLPostShaderHolder;
Public procedure Assign(Source: TPersistent); override;

Properties

Published property Shader: TGLShader read FShader write SetShader;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPostEffects: Class TGLPostShaderCollection

Class TGLPostShaderCollection

Unit

GLPostEffects

Declaration

type TGLPostShaderCollection = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLPostShaderCollection

Overview

Methods

Public | function Add: TGLPostShaderCollectionItem;
Public | procedure Remove(const Item: TGLShader);

Properties

Public property Items[const Index: Integer]: TGLPostShaderCollectionItem read GetItems write SetItems;

Description

Methods

Public function Add: TGLPostShaderCollectionItem;
Public procedure Remove(const Item: TGLShader);

Properties

Public property Items[const Index: Integer]: TGLPostShaderCollectionItem read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPostEffects: Class TGLPostShaderHolder

Class TGLPostShaderHolder

Unit

GLPostEffects

Declaration

type TGLPostShaderHolder = class(TGLBaseSCeneObject)

Description

A class that allows several post-shaders to be applied to the scene, one after another. It does not provide any optimizations related to multi-shader rendering, just a convenient interface.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLPostShaderHolder

Overview

Methods

Public | constructor Create(Owner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci : TRenderContextInfo; renderSelf, renderChildren : Boolean); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property OnProgress;
Published | property Shaders: TGLPostShaderCollection read FShaders write SetShaders;
Published | property TempTextureTarget: TGLTextureTarget read FTempTextureTarget write FTempTextureTarget default ttTexture2d;
Published | property Visible;

Description

Methods

Public constructor Create(Owner: TComponent); override;
Public destructor Destroy; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoRender(var rci : TRenderContextInfo; renderSelf, renderChildren : Boolean); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published property OnProgress;
Published property Shaders: TGLPostShaderCollection read FShaders write SetShaders;
Published property TempTextureTarget: TGLTextureTarget read FTempTextureTarget write FTempTextureTarget default ttTexture2d;
Published property Visible;

Publish some stuff from TGLBaseSceneObject.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPostEffects: record TGLPostEffectColor

record TGLPostEffectColor

Unit

GLPostEffects

Declaration

type TGLPostEffectColor = record

Description

Overview

Fields

R: TGLubyte;
G: TGLubyte;
B: TGLubyte;
A: TGLubyte;

Description

Fields

R: TGLubyte;
G: TGLubyte;
B: TGLubyte;
A: TGLubyte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLPostEffects: Class TGLPostEffect

Class TGLPostEffect

Unit

GLPostEffects

Declaration

type TGLPostEffect = class(TGLBaseSCeneObject)

Description

Provides a simple way to producing post-effects without shaders.<p> It is slow as hell, but it's worth it in some cases.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLPostEffect

Overview

Methods

Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var rci : TRenderContextInfo; renderSelf, renderChildren : Boolean); override;
Protected | procedure DoOnCustomEffect(var rci : TRenderContextInfo; var Buffer: TGLPostEffectBuffer); virtual;
Protected | procedure MakeBlurEffect(var rci : TRenderContextInfo); virtual;
Protected | procedure MakeDistortEffect; virtual;
Protected | procedure MakeGrayEffect; virtual;
Protected | procedure MakeNegativeEffect; virtual;
Protected | procedure MakeNightVisionEffect; virtual;
Protected | procedure MakeNoiseEffect; virtual;

Properties

Published | property OnCustomEffect: TGLOnCustomPostEffectEvent read FOnCustomEffect write FOnCustomEffect;
Published | property OnProgress;
Published | property Preset: TGLPostEffectPreset read FPreset write FPreset default pepNone;
Published | property Visible;

Description

Methods

Public procedure Assign(Source: TPersistent); override;
Public procedure DoRender(var rci : TRenderContextInfo; renderSelf, renderChildren : Boolean); override;
Protected procedure DoOnCustomEffect(var rci : TRenderContextInfo; var Buffer: TGLPostEffectBuffer); virtual;
Protected procedure MakeBlurEffect(var rci : TRenderContextInfo); virtual;
Protected procedure MakeDistortEffect; virtual;
Protected procedure MakeGrayEffect; virtual;

May be should be private...

Protected procedure MakeNegativeEffect; virtual;
Protected procedure MakeNightVisionEffect; virtual;
Protected procedure MakeNoiseEffect; virtual;

Properties

Published property OnCustomEffect: TGLOnCustomPostEffectEvent read FOnCustomEffect write FOnCustomEffect;

User creates this effect.

Published property OnProgress;
Published property Preset: TGLPostEffectPreset read FPreset write FPreset default pepNone;
Published property Visible;

Publish some stuff from TGLBaseSCeneObject.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLProcTextures

Unit GLProcTextures

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLProcTextures<p>

Procedural textures.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>22/01/10 - Yar - Added bmp32.Blank:=false for memory allocation, Depth dimension, NativeTextureTarget becomes property <li>16/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>01/10/04 - ilh - Added SetPermFromData and SetPermToDefault moved PERM array to protected from inside Noise procedure so it can be changed by SetPermFromData and SetPermToDefault Added FNoiseRandSeed property so a Seed can be set Starts with a random Generated Seed... One must be set to BE Seeded <li>11/12/02 - ??? - Initial, procedural perlin noise texture code by Tobias Peirick </ul></font><p>

I used the following references for my implementation:<p>

http://freespace.virgin.net/hugo.elias/models/m_perlin.htm<br> http://freespace.virgin.net/hugo.elias/models/m_clouds.htm<br> http://www.delphi3d.net<p>

Tobias Peirick

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLProcTextureNoise |

Constants

GRADIENT_TABLE_SIZE = 256;
DAMP_SHIFT = 20;

Description

Constants

GRADIENT_TABLE_SIZE = 256;
DAMP_SHIFT = 20;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLProcTextures: Class TGLProcTextureNoise

Class TGLProcTextureNoise

Unit

GLProcTextures

Declaration

type TGLProcTextureNoise = class(TGLTextureImage)

Description

no description available, TGLTextureImage description follows

Base class for texture image data.<p> Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source).<br> SubClasses should be registered using RegisterGLTextureImageClass to allow proper persistence and editability in the IDE experts.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLProcTextureNoise

Overview

Fields

Protected | FGradients: array[0..GRADIENT_TABLE_SIZE * 3 - 1] of Single;
Protected | PERM: array[0..GRADIENT_TABLE_SIZE - 1] of Byte;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TGLBitmap32; override;
Protected | function GetDepth: Integer; override;
Protected | function GetHeight: Integer; override;
Protected | function GetTextureTarget: TGLTextureTarget; override;
Protected | function GetWidth: Integer; override;
Protected | function Noise(x, y: Single): Single;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure NoiseAnimate(speed: Single);
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;
Public | procedure SetPermFromData(inPERM: array of Byte);
Public | procedure SetPermToDefault;
Protected | procedure SetHeight(const val: Integer);
Protected | procedure SetMinCut(const val: Byte);
Protected | procedure SetNoiseRandSeed(const val: Longint);
Protected | procedure SetNoiseSharpness(const val: Single);
Protected | procedure SetSeamless(const val: Boolean);
Protected | procedure SetWidth(const val: Integer);
Protected | procedure UpdateNoise;

Properties

Published | property Depth: Integer read GetDepth;
Published | property Height: Integer read GetHeight write SetHeight default 128;
Published | property MinCut: Byte read FMinCut write SetMinCut;
Published | property NoiseRandSeed: Longint read FNoiseRandSeed write SetNoiseRandSeed;
Published | property NoiseSharpness: Single read FNoiseSharpness write SetNoiseSharpness;
Published | property Seamless: Boolean read FSeamless write SetSeamless;
Published | property Width: Integer read GetWidth write SetWidth default 128;

Description

Fields

Protected FGradients: array[0..GRADIENT_TABLE_SIZE * 3 - 1] of Single;
Protected PERM: array[0..GRADIENT_TABLE_SIZE - 1] of Byte;

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Public function GetBitmap32: TGLBitmap32; override;
Protected function GetDepth: Integer; override;
Protected function GetHeight: Integer; override;
Protected function GetTextureTarget: TGLTextureTarget; override;
Protected function GetWidth: Integer; override;
Protected function Noise(x, y: Single): Single;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadFromFile(const fileName: string); override;
Public procedure NoiseAnimate(speed: Single);
Public procedure ReleaseBitmap32; override;
Public procedure SaveToFile(const fileName: string); override;
Public procedure SetPermFromData(inPERM: array of Byte);
Public procedure SetPermToDefault;
Protected procedure SetHeight(const val: Integer);
Protected procedure SetMinCut(const val: Byte);
Protected procedure SetNoiseRandSeed(const val: Longint);
Protected procedure SetNoiseSharpness(const val: Single);
Protected procedure SetSeamless(const val: Boolean);
Protected procedure SetWidth(const val: Integer);
Protected procedure UpdateNoise;

Properties

Published property Depth: Integer read GetDepth;
Published property Height: Integer read GetHeight write SetHeight default 128;
Published property MinCut: Byte read FMinCut write SetMinCut;
Published property NoiseRandSeed: Longint read FNoiseRandSeed write SetNoiseRandSeed;
Published property NoiseSharpness: Single read FNoiseSharpness write SetNoiseSharpness;
Published property Seamless: Boolean read FSeamless write SetSeamless;
Published property Width: Integer read GetWidth write SetWidth default 128;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLProjectedTextures

Unit GLProjectedTextures

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLProjectedTextures<p>

Implements projected textures through a GLScene object.

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed const cBase matrix <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>15/06/05 - Mathx - Added the Style property and inverse rendering <li>07/05/05 - Mathx - Support for tmBlend textures (by Ruben Javier) <li>01/10/04 - SG - Initial (by Matheus Degiovani) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTextureEmitter |
Class TGLTextureEmitterItem |
Class TGLTextureEmitters |
Class TGLProjectedTextures |

Types

TGLProjectedTexturesStyle = (...);

Description

Types

TGLProjectedTexturesStyle = (...);

Possible styles of texture projection. Possible values:<ul> <li>ptsOriginal: Original projection method (first pass, is default scene render, second pass is texture projection). <li>ptsInverse: Inverse projection method (first pass is texture projection, sencond pass is regular scene render). This method is useful if you want to simulate lighting only through projected textures (the textures of the scene are "masked" into the white areas of the projection textures). </ul>

Values
  • ptsOriginal:
  • ptsInverse:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLProjectedTextures: Class TGLTextureEmitter

Class TGLTextureEmitter

Unit

GLProjectedTextures

Declaration

type TGLTextureEmitter = class(TGLSceneObject)

Description

A projected texture emmiter.<p> It's material property will be used as the projected texture. Can be places anywhere in the scene.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLTextureEmitter

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Protected | procedure SetupTexMatrix(var ARci: TRenderContextInfo);

Properties

Published | property Aspect: single read FAspect write FAspect;
Published | property FOVy: single read FFOVy write FFOVy;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Protected procedure SetupTexMatrix(var ARci: TRenderContextInfo);

Sets up the base texture matrix for this emitter<p> Should be called whenever a change on its properties is made.

Properties

Published property Aspect: single read FAspect write FAspect;

x/y ratio. For no distortion, this should be set to texture.width/texture.height.

Published property FOVy: single read FFOVy write FFOVy;

Indicates the field-of-view of the projection frustum.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLProjectedTextures: Class TGLTextureEmitterItem

Class TGLTextureEmitterItem

Unit

GLProjectedTextures

Declaration

type TGLTextureEmitterItem = class(TCollectionItem)

Description

Specifies an item on the TGLTextureEmitters collection.

Hierarchy

  • TCollectionItem
  • TGLTextureEmitterItem

Overview

Methods

Public | constructor Create(ACollection: TCollection); override;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure RemoveNotification(aComponent: TComponent);
Protected | procedure SetEmitter(const val: TGLTextureEmitter);

Properties

Published property Emitter: TGLTextureEmitter read FEmitter write SetEmitter;

Description

Methods

Public constructor Create(ACollection: TCollection); override;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;
Protected procedure RemoveNotification(aComponent: TComponent);
Protected procedure SetEmitter(const val: TGLTextureEmitter);

Properties

Published property Emitter: TGLTextureEmitter read FEmitter write SetEmitter;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLProjectedTextures: Class TGLTextureEmitters

Class TGLTextureEmitters

Unit

GLProjectedTextures

Declaration

type TGLTextureEmitters = class(TCollection)

Description

Collection of TGLTextureEmitter.

Hierarchy

  • TCollection
  • TGLTextureEmitters

Overview

Methods

Protected | function GetItems(index: Integer): TGLTextureEmitterItem;
Protected | function GetOwner: TPersistent; override;
Public | procedure AddEmitter(texEmitter: TGLTextureEmitter);
Protected | procedure RemoveNotification(aComponent: TComponent);

Properties

Public property Items[index: Integer]: TGLTextureEmitterItem read GetItems;

Description

Methods

Protected function GetItems(index: Integer): TGLTextureEmitterItem;
Protected function GetOwner: TPersistent; override;
Public procedure AddEmitter(texEmitter: TGLTextureEmitter);
Protected procedure RemoveNotification(aComponent: TComponent);

Properties

Public property Items[index: Integer]: TGLTextureEmitterItem read GetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:38


GLScene v.1.1.2: GLProjectedTextures: Class TGLProjectedTextures

Class TGLProjectedTextures

Unit

GLProjectedTextures

Declaration

type TGLProjectedTextures = class(TGLImmaterialSceneObject)

Description

Projected Textures Manager.<p> Specifies active texture Emitters (whose texture will be projected) and receivers (children of this object).

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLProjectedTextures

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Emitters: TGLTextureEmitters read FEmitters write FEmitters;
Published | property Style: TGLProjectedTexturesStyle read FStyle write FStyle;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published property Emitters: TGLTextureEmitters read FEmitters write FEmitters;

List of texture emitters.

Published property Style: TGLProjectedTexturesStyle read FStyle write FStyle;

Indicates the style of the projected textures.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLProxyObjects

Unit GLProxyObjects

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLProxyObjects<p>

Implements specific proxying classes.<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>25/12/09 - DaStr - Bugfixed TGLActorProxy.RayCastIntersect() in aarMorph mode (thanks Vovik) <li>22/12/09 - DaStr - Added TGLActorProxy.AnimationMode (thanks Vovik) Removed TGLActorProxy.Interval (was not used) <li>18/06/08 - mrqzzz - Don't raise error when setting animation to an ActorProxy and no MasterObject is defined <li>15/03/08 - DaStr - Fixup after previous update: removed all hints and warnings, TGLActorProxy now has two versions of RayCastIntersect() <li>06/02/08 - mrqzzz - Added a "RayCastIntersect" overload for Actorproxy <li>07/11/07 - mrqzzz - Added "OnBeforeRender" event to Actorproxy allowing to apply extra transformations (f.ex: bone rotations) to the referenced Actor in order to have the proxy render these changes. <li>07/11/07 - mrqzzz - Added "StoredBoneNames" property <li>07/11/07 - mrqzzz - Added "BoneMatrix(Boneidndex|boneName)" function and StoreBonesMatrix property for TGLActorProxy (To read each ActorProxy's individual Bone matrices, f.ex to align a weapon in it's hand) <li>06/11/07 - mrqzzz - Added MaterialLibrary and LibMaterialName for TGLActorProxy (allows different materials on proxy actors sharing same master) <li>06/11/07 - mrqzzz - Added public readonly properties for TGLActorProxy (CurrentFrame,StartFrame,Endframe,etc..) <li>05/10/07 - DaStr - Bugfixed TGLMaterialProxy.DoRender (Bugtracker ID = 1808666) <li>04/09/07 - DaStr - Added TGLMaterialProxy Cleaned up this unit a bit <li>10/05/07 - DaStr - Bugfixed TGLColorProxy.DoRender (thanks Paul Robello) (Bugtracker ID = 1716692) <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>25/02/07 - Made TGLActorProxy.SetAnimation a bit safer <li>20/02/07 - DaStr - Redeclared MasterObject of TGLColorProxy and TGLFreeFormProxy Added TGLActorProxy (based on a demo published on the newsgroup by don't know who...) <li>18/12/03 - Dave - Dropped "Object" from "ProxyObject" class names <li>17/12/03 - Dave - Changed class check in Octree code to Assert <li>17/12/03 - Dave+Dan - Added OctreeSphereSweep <li>06/12/03 - EG - Creation from GLScene.pas split </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLProxyException |
Class TGLColorProxy |
Class TGLMaterialProxy |
Class TGLFreeFormProxy |
Class TBoneMatrixObj |
Class TGLActorProxy |

Types

TGLActorProxyAnimationMode = (...);

Description

Types

TGLActorProxyAnimationMode = (...);
Values
  • pamInherited:
  • pamNone:
  • pamPlayOnce:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLProxyObjects: Class EGLProxyException

Class EGLProxyException

Unit

GLProxyObjects

Declaration

type EGLProxyException = class(Exception)

Description

Hierarchy

  • Exception
  • EGLProxyException
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLProxyObjects: Class TGLColorProxy

Class TGLColorProxy

Unit

GLProxyObjects

Declaration

type TGLColorProxy = class(TGLProxyObject)

Description

A proxy object with its own color.<p> This proxy object can have a unique color. Note that multi-material objects (Freeforms linked to a material library f.i.) won't honour the color.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLProxyObject
  • TGLColorProxy

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property FrontColor: TGLFaceProperties read FFrontColor write SetFrontColor;
Published | property MasterObject: TGLCustomSceneObject read GetMasterMaterialObject write SetMasterMaterialObject;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published property FrontColor: TGLFaceProperties read FFrontColor write SetFrontColor;
Published property MasterObject: TGLCustomSceneObject read GetMasterMaterialObject write SetMasterMaterialObject;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLProxyObjects: Class TGLMaterialProxy

Class TGLMaterialProxy

Unit

GLProxyObjects

Declaration

type TGLMaterialProxy = class(TGLProxyObject, IGLMaterialLibrarySupported)

Description

A proxy object with its own material.<p> This proxy object can take a mesh from one master and a materia from a material library.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLProxyObject
  • TGLMaterialProxy

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Public | property MasterLibMaterial: TGLLibMaterial read FMasterLibMaterial write FMasterLibMaterial stored False;
Published | property MasterLibMaterialName: TGLLibMaterialName read GetMasterLibMaterialName write SetMasterLibMaterialName;
Published | property MasterObject: TGLCustomSceneObject read GetMasterMaterialObject write SetMasterMaterialObject;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Public property MasterLibMaterial: TGLLibMaterial read FMasterLibMaterial write FMasterLibMaterial stored False;

Specifies the Material, that current master object will use. Provides a faster way to access FMasterLibMaterial, compared to MasterLibMaterialName

Published property MasterLibMaterialName: TGLLibMaterialName read GetMasterLibMaterialName write SetMasterLibMaterialName;

Specifies the Material, that current master object will use.

Published property MasterObject: TGLCustomSceneObject read GetMasterMaterialObject write SetMasterMaterialObject;

Redeclare as TGLCustomSceneObject.

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLProxyObjects: Class TGLFreeFormProxy

Class TGLFreeFormProxy

Unit

GLProxyObjects

Declaration

type TGLFreeFormProxy = class(TGLProxyObject)

Description

A proxy object specialized for FreeForms.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLProxyObject
  • TGLFreeFormProxy

Overview

Methods

Public | function OctreeRayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean;
Public | function OctreeSphereSweepIntersect(const rayStart, rayVector: TVector; const velocity, radius, modelscale: Single; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean;

Properties

Published property MasterObject: TGLFreeForm read GetMasterFreeFormObject write SetMasterFreeFormObject;

Description

Methods

Public function OctreeRayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean;

If the MasterObject is a FreeForm, you can raycast against the Octree, which is alot faster. You must build the octree before using.

Public function OctreeSphereSweepIntersect(const rayStart, rayVector: TVector; const velocity, radius, modelscale: Single; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean;

WARNING: This function is not yet 100% reliable with scale+rotation.

Properties

Published property MasterObject: TGLFreeForm read GetMasterFreeFormObject write SetMasterFreeFormObject;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLProxyObjects: Class TBoneMatrixObj

Class TBoneMatrixObj

Unit

GLProxyObjects

Declaration

type TBoneMatrixObj = class(TObject)

Description

An object containing the bone matrix for TGLActorProxy.<p>

Hierarchy

  • TObject
  • TBoneMatrixObj

Overview

Fields

Public | Matrix: TMatrix;
Public | BoneName: string;
Public | BoneIndex: integer;

Description

Fields

Public Matrix: TMatrix;
Public BoneName: string;
Public BoneIndex: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLProxyObjects: Class TGLActorProxy

Class TGLActorProxy

Unit

GLProxyObjects

Declaration

type TGLActorProxy = class(TGLProxyObject, IGLMaterialLibrarySupported)

Description

A proxy object specialized for Actors.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLProxyObject
  • TGLActorProxy

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function BoneMatrix(BoneName: string): TMatrix; overload;
Public | function BoneMatrix(BoneIndex: integer): TMatrix; overload;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; override;
Public | function RayCastIntersectEx(RefActor: TGLActor; const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; overload;
Public | procedure BoneMatricesClear;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure DoStoreBonesMatrices;

Properties

Published | property Animation: TActorAnimationName read FAnimation write SetAnimation;
Published | property AnimationMode: TGLActorProxyAnimationMode read FAnimationMode write FAnimationMode default pamInherited;
Public | property CurrentFrame: Integer read FCurrentFrame;
Public | property CurrentFrameDelta: Single read FCurrentFrameDelta;
Public | property CurrentTime: TProgressTimes read FCurrentTime;
Public | property EndFrame: Integer read FEndFrame;
Published | property LibMaterialName: TGLLibMaterialName read GetLibMaterialName write SetLibMaterialName;
Published | property MasterObject: TGLActor read GetMasterActorObject write SetMasterActorObject;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property OnBeforeRender: TGLProgressEvent read FOnBeforeRender write SetOnBeforeRender;
Published | property ProxyOptions default [pooEffects, pooObjects];
Public | property StartFrame: Integer read FStartFrame;
Published | property StoreBonesMatrix: boolean read FStoreBonesMatrix write SetStoreBonesMatrix;
Published | property StoredBoneNames: TStrings read FStoredBoneNames write SetStoredBoneNames;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function BoneMatrix(BoneName: string): TMatrix; overload;
Public function BoneMatrix(BoneIndex: integer): TMatrix; overload;

Gets the Bones Matrix in the current animation frame. (since the masterobject is shared between all proxies, each proxy will have it's bones matrices)

Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; override;

A standard version of the RayCastIntersect function.

Public function RayCastIntersectEx(RefActor: TGLActor; const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; overload;

Raycasts on self, but actually on the "RefActor" Actor. Note that the "RefActor" parameter does not necessarily have to be the same Actor refernced by the MasterObject property: This allows to pass a low-low-low-poly Actor to raycast in the "RefActor" parameter, while using a high-poly Actor in the "MasterObject" property, of course we assume that the two Masterobject Actors have same animations.

Public procedure BoneMatricesClear;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure DoStoreBonesMatrices;

Properties

Published property Animation: TActorAnimationName read FAnimation write SetAnimation;
Published property AnimationMode: TGLActorProxyAnimationMode read FAnimationMode write FAnimationMode default pamInherited;
Public property CurrentFrame: Integer read FCurrentFrame;
Public property CurrentFrameDelta: Single read FCurrentFrameDelta;
Public property CurrentTime: TProgressTimes read FCurrentTime;
Public property EndFrame: Integer read FEndFrame;
Published property LibMaterialName: TGLLibMaterialName read GetLibMaterialName write SetLibMaterialName;

Specifies the Material, that current proxy will use.

Published property MasterObject: TGLActor read GetMasterActorObject write SetMasterActorObject;
Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Specifies the MaterialLibrary, that current proxy will use.

Published property OnBeforeRender: TGLProgressEvent read FOnBeforeRender write SetOnBeforeRender;

Event allowing to apply extra transformations (f.ex: bone rotations) to the referenced Actor on order to have the proxy render these changes.

Published property ProxyOptions default [pooEffects, pooObjects];
Public property StartFrame: Integer read FStartFrame;
Published property StoreBonesMatrix: boolean read FStoreBonesMatrix write SetStoreBonesMatrix;

Specifies if it will store the Bones Matrices, accessible via the BoneMatrix function (since the masterobject is shared between all proxies, each proxy will have it's bones matrices)

Published property StoredBoneNames: TStrings read FStoredBoneNames write SetStoredBoneNames;

Specifies the names of the bones we want the matrices to be stored. If empty, all bones will be stored (since the masterobject is shared between all proxies, each proxy will have it's bones matrices)

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLRagdoll

Unit GLRagdoll

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLRagdoll<p>

Base abstract ragdoll class. Should be extended to use any physics system. <p>

<b>History :</b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to arrays of records <li>23/08/10 - Yar - Added VectorTypes to uses <li>09/11/05 - LucasG - Fixed joint and few small things <li>07/11/05 - LucasG - Fixed bone position and rotation (Align to animation) <li>02/11/05 - LucasG - First version created. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TRagdollJoint |
Class TRagdollBoneList |
Class TRagdollBone |
Class TGLRagdoll |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLRagdoll: Class TRagdollJoint

Class TRagdollJoint

Unit

GLRagdoll

Declaration

type TRagdollJoint = class(TObject)

Description

Hierarchy

  • TObject
  • TRagdollJoint
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLRagdoll: Class TRagdollBoneList

Class TRagdollBoneList

Unit

GLRagdoll

Declaration

type TRagdollBoneList = class(TPersistentObjectList)

Description

no description available, TPersistentObjectList description follows

A persistent Object list.<p> Similar to TList but works on TObject items and has facilities for persistence of contained data. Unlike the VCL's TObjectList, this one does NOT free its objects upon destruction or Clear, use Clean and CleanFree for that, and as such can be used for object referral lists too.<br> But only TPersistentObject items will be streamed appropriately.<p> The list can be used in a stack-like fashion with Push & Pop, and can perform basic boolean set operations.<p> Note: the IndexOf implementation is up to 3 times faster than that of TList

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TRagdollBoneList

Overview

Methods

Public | constructor Create(Ragdoll: TGLRagdoll); reintroduce;
Public | destructor Destroy; override;
Protected | function GetRagdollBone(Index: Integer) : TRagdollBone;
Public | procedure ReadFromFiler(reader : TVirtualReader); override;
Public | procedure WriteToFiler(writer : TVirtualWriter); override;

Properties

Public | property Items[Index: Integer]: TRagdollBone read GetRagdollBone;
Public | property Ragdoll : TGLRagdoll read FRagdoll;

Description

Methods

Public constructor Create(Ragdoll: TGLRagdoll); reintroduce;
Public destructor Destroy; override;
Protected function GetRagdollBone(Index: Integer) : TRagdollBone;
Public procedure ReadFromFiler(reader : TVirtualReader); override;
Public procedure WriteToFiler(writer : TVirtualWriter); override;

Properties

Public property Items[Index: Integer]: TRagdollBone read GetRagdollBone;
Public property Ragdoll : TGLRagdoll read FRagdoll;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLRagdoll: Class TRagdollBone

Class TRagdollBone

Unit

GLRagdoll

Declaration

type TRagdollBone = class(TRagdollBoneList)

Description

no description available, TRagdollBoneList description follows
no description available, TPersistentObjectList description follows

A persistent Object list.<p> Similar to TList but works on TObject items and has facilities for persistence of contained data. Unlike the VCL's TObjectList, this one does NOT free its objects upon destruction or Clear, use Clean and CleanFree for that, and as such can be used for object referral lists too.<br> But only TPersistentObject items will be streamed appropriately.<p> The list can be used in a stack-like fashion with Push & Pop, and can perform basic boolean set operations.<p> Note: the IndexOf implementation is up to 3 times faster than that of TList

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TRagdollBoneList
  • TRagdollBone

Overview

Methods

Public | constructor Create(Ragdoll: TGLRagdoll);
Public | constructor CreateOwned(aOwner : TRagdollBoneList);
Public | destructor Destroy; override;
Protected | function GetRagdollBone(Index: Integer) : TRagdollBone;
Public | procedure ReadFromFiler(reader : TVirtualReader); override;
Public | procedure WriteToFiler(writer : TVirtualWriter); override;
Protected | procedure Align; virtual; abstract;
Protected | procedure Start; virtual; abstract;
Protected | procedure Stop; virtual; abstract;
Protected | procedure Update; virtual; abstract;

Properties

Public | property Anchor : TAffineVector read FAnchor;
Public | property BoneID : Integer read FBoneID write FBoneID;
Public | property BoneMatrix : TMatrix read FBoneMatrix;
Public | property Items[Index: Integer]: TRagdollBone read GetRagdollBone;
Public | property Joint : TRagdollJoint read FJoint write FJoint;
Public | property Name : String read FName write FName;
Public | property Origin : TAffineVector read FOrigin;
Public | property Owner : TRagdollBoneList read FOwner;
Public | property ReferenceMatrix : TMatrix read FReferenceMatrix;
Public | property Size : TAffineVector read FSize;

Description

Methods

Public constructor Create(Ragdoll: TGLRagdoll);
Public constructor CreateOwned(aOwner : TRagdollBoneList);
Public destructor Destroy; override;
Protected function GetRagdollBone(Index: Integer) : TRagdollBone;
Public procedure ReadFromFiler(reader : TVirtualReader); override;
Public procedure WriteToFiler(writer : TVirtualWriter); override;
Protected procedure Align; virtual; abstract;
Protected procedure Start; virtual; abstract;
Protected procedure Stop; virtual; abstract;
Protected procedure Update; virtual; abstract;

Properties

Public property Anchor : TAffineVector read FAnchor;
Public property BoneID : Integer read FBoneID write FBoneID;
Public property BoneMatrix : TMatrix read FBoneMatrix;
Public property Items[Index: Integer]: TRagdollBone read GetRagdollBone;
Public property Joint : TRagdollJoint read FJoint write FJoint;
Public property Name : String read FName write FName;
Public property Origin : TAffineVector read FOrigin;
Public property Owner : TRagdollBoneList read FOwner;
Public property ReferenceMatrix : TMatrix read FReferenceMatrix;
Public property Size : TAffineVector read FSize;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLRagdoll: Class TGLRagdoll

Class TGLRagdoll

Unit

GLRagdoll

Declaration

type TGLRagdoll = class(TPersistentObject)

Description

no description available, TPersistentObject description follows

Base class for persistent objects.<p> The base requirement is implementation of ReadFromFiler & WriteToFiler in sub-classes, the immediate benefits are support of streaming (to stream, file or string), assignment and cloning.<br> The other requirement being the use of a virtual constructor, which allows polymorphic construction (don't forget to register your subclasses).<p> Note that TPersistentObject implements IUnknown, but does *not* implement reference counting.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLRagdoll

Overview

Methods

Public | constructor Create(AOwner : TGLBaseMesh); reintroduce;
Public | destructor Destroy; override;
Public | procedure BuildRagdoll;
Public | procedure ReadFromFiler(reader : TVirtualReader); override;
Public | procedure SetRootBone(RootBone: TRagdollBone);
Public | procedure Start;
Public | procedure Stop;
Public | procedure Update;
Public | procedure WriteToFiler(writer : TVirtualWriter); override;

Properties

Public | property Enabled : Boolean read FEnabled;
Public | property Owner : TGLBaseMesh read FOwner;
Public | property RootBone : TRagdollBone read FRootBone;

Description

Methods

Public constructor Create(AOwner : TGLBaseMesh); reintroduce;
Public destructor Destroy; override;
Public procedure BuildRagdoll;

Create the bounding box and setup the ragdoll do be started later

Public procedure ReadFromFiler(reader : TVirtualReader); override;
Public procedure SetRootBone(RootBone: TRagdollBone);

Must be set before build the ragdoll

Public procedure Start;
Public procedure Stop;
Public procedure Update;
Public procedure WriteToFiler(writer : TVirtualWriter); override;

Properties

Public property Enabled : Boolean read FEnabled;
Public property Owner : TGLBaseMesh read FOwner;
Public property RootBone : TRagdollBone read FRootBone;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLRenderContextInfo

Unit GLRenderContextInfo

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLRenderContextInfo<p>

Stores contextual info useful during rendering methods.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Removed modelViewMatrix, lightDisableCounter. Added PipelineTransformation. <li>22/02/10 - Yar - Added bufferLighting, bufferFog, bufferDepthTest to TRenderContextInfo <li>14/03/09 - DanB - Removed IsVolumeClipped functions, instead replaced with IsVolumeClipped functions in VectorGeometry.pas that use TFrustrum <li>09/10/08 - DanB - Added TRenderContextClippingInfo + IsVolumeClipped functions from VectorGeometry.pas, added nearClippingDistance <li>05/10/08 - DanB - Created from GLTexture.pas split </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TGLSize |
record TRenderContextClippingInfo |
record TRenderContextInfo |

Types

TDrawState = (...);
TGLObjectsSorting = (...);
TGLVisibilityCulling = (...);
PRenderContextInfo = ˆTRenderContextInfo;

Description

Types

TDrawState = (...);
Values
  • dsRendering:
  • dsPicking:
  • dsPrinting:
TGLObjectsSorting = (...);

Determines if objects are sorted, and how.<p> Sorting is done level by level (and not for all entities), values are :<ul> <li>osInherited : use inherited sorting mode, defaults to osRenderFarthestFirst <li>osNone : do not sort objects. <li>osRenderFarthestFirst : render objects whose Position is the farthest from the camera first. <li>osRenderBlendedLast : opaque objects are not sorted and rendered first, blended ones are rendered afterwards and depth sorted. <li>osRenderNearestFirst : render objects whose Position is the nearest to the camera first. </ul>

Values
  • osInherited:
  • osNone:
  • osRenderFarthestFirst:
  • osRenderBlendedLast:
  • osRenderNearestFirst:
TGLVisibilityCulling = (...);

Determines the visibility culling mode. Culling is done level by level, allowed values are:<ul> <li>vcInherited : use inherited culling value, if selected for the root level, defaults to vcNone <li>vcNone : no visibility culling is performed <li>vcObjectBased : culling is done on a per-object basis, each object may or may not be culled base on its own AxisAlignedDimensions, culling has no impact on the visibility of its children <li>vcHierarchical : culling is performed hierarchically, using hierarchical bounding boxes, if a parent is culled, all of its children, whatever their culling options are invisible. <li><br>Depending on the structure of your scene the most efficient culling method will be either vcObjectBased or vcHierarchical. Also note that if you use many objects with "static" geometry and have a T&amp;L graphics board, it may be faster not to cull at all (ie. leave this to the hardware).

Values
  • vcInherited:
  • vcNone:
  • vcObjectBased:
  • vcHierarchical:
PRenderContextInfo = ˆTRenderContextInfo;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLRenderContextInfo: record TGLSize

record TGLSize

Unit

GLRenderContextInfo

Declaration

type TGLSize = record

Description

Overview

Fields

cx: Longint;
cy: Longint;

Description

Fields

cx: Longint;
cy: Longint;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLRenderContextInfo: record TRenderContextClippingInfo

record TRenderContextClippingInfo

Unit

GLRenderContextInfo

Declaration

type TRenderContextClippingInfo = record

Description

Overview

Fields

origin: TVector;
clippingDirection: TVector;
viewPortRadius: Single;
nearClippingDistance: Single;
farClippingDistance: Single;
frustum: TFrustum;

Description

Fields

origin: TVector;
clippingDirection: TVector;
viewPortRadius: Single;
nearClippingDistance: Single;
farClippingDistance: Single;
frustum: TFrustum;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLRenderContextInfo: record TRenderContextInfo

record TRenderContextInfo

Unit

GLRenderContextInfo

Declaration

type TRenderContextInfo = record

Description

Stores contextual info useful during rendering methods.

Overview

Fields

scene: TObject;
buffer: TObject;
cameraPosition: TVector;
cameraDirection: TVector;
cameraUp: TVector;
viewPortSize: TGLSize;
renderDPI: Integer;
materialLibrary: TObject;
lightmapLibrary: TObject;
fogDisabledCounter: Integer;
drawState: TDrawState;
objectsSorting: TGLObjectsSorting;
visibilityCulling: TGLVisibilityCulling;
GLStates: TGLStateCache;
PipelineTransformation: TGLTransformation;
rcci: TRenderContextClippingInfo;
sceneAmbientColor: TColorVector;
bufferFaceCull: Boolean;
bufferLighting: Boolean;
bufferFog: Boolean;
bufferDepthTest: Boolean;
proxySubObject: Boolean;
ignoreMaterials: Boolean;
ignoreBlendingRequests: Boolean;
ignoreDepthRequests: Boolean;
amalgamating: Boolean;
lights: TPersistentObjectList;
afterRenderEffects: TPersistentObjectList;
currentMaterialLevel: TGLMaterialLevel;
primitiveMask: TGLMeshPrimitives;
orderCounter: Integer;

Description

Fields

scene: TObject;
buffer: TObject;
cameraPosition: TVector;
cameraDirection: TVector;
cameraUp: TVector;
viewPortSize: TGLSize;
renderDPI: Integer;
materialLibrary: TObject;
lightmapLibrary: TObject;
fogDisabledCounter: Integer;
drawState: TDrawState;
objectsSorting: TGLObjectsSorting;
visibilityCulling: TGLVisibilityCulling;
GLStates: TGLStateCache;
PipelineTransformation: TGLTransformation;
rcci: TRenderContextClippingInfo;
sceneAmbientColor: TColorVector;
bufferFaceCull: Boolean;
bufferLighting: Boolean;
bufferFog: Boolean;
bufferDepthTest: Boolean;
proxySubObject: Boolean;
ignoreMaterials: Boolean;
ignoreBlendingRequests: Boolean;
ignoreDepthRequests: Boolean;
amalgamating: Boolean;
lights: TPersistentObjectList;
afterRenderEffects: TPersistentObjectList;
currentMaterialLevel: TGLMaterialLevel;
primitiveMask: TGLMeshPrimitives;
orderCounter: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLROAMPatch

Unit GLROAMPatch

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLROAMPatch<p>

Class for managing a ROAM (square) patch.<p>

<b>History : </b><font size=-1><ul> <li>22/08/10 - DaStr - Fixed compiler warning <li>27/07/10 - YP - Safe tesselation operation to avoid AV after a memory shift <li>26/07/10 - YP - Invalid range test when splitting, we need to check space for n and n+1 <li>20/05/10 - Yar - Fixes for Linux x64 <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>30/03/07 - DaStr - Added $I GLScene.inc <li>19/10/06 - LC - Added code to gracefully handle the case when MaxCLODTriangles is reached. It will now increase the buffer instead of not splitting. Bugtracker ID=1574111 <li>09/10/06 - Lin - Added OnMaxCLODTrianglesReached event. <li>09/06/06 - Lin - Bugfix: Stop splitting Triangles when MaxCLODTriangles is reached (prevents Access Violations) <li>10/06/05 - Mathx - Protection against cards that have GL_EXT_compiled_vertex_array but not GL_EXT_draw_range_elements <li>25/04/04 - EG - Occlusion testing support <li>06/02/03 - EG - Adaptative variance computation <li>03/12/02 - EG - Minor ROAM tessel/render optimizations <li>15/06/02 - EG - Fixed patch rendering bug "introduced" by TBaseList fix <li>24/02/02 - EG - Hybrid ROAM-stripifier engine <li>10/09/01 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLROAMException |
packed record TROAMTriangleNode |
packed record TROAMRenderPoint |
Class TGLROAMPatch |

Functions and Procedures

procedure SetROAMTrianglesCapacity(nb: integer);
function GetROAMTrianglesCapacity: integer;

Types

PROAMTriangleNode = ˆTROAMTriangleNode;

Description

Functions and Procedures

procedure SetROAMTrianglesCapacity(nb: integer);

Specifies the maximum number of ROAM triangles that may be allocated.

function GetROAMTrianglesCapacity: integer;

Types

PROAMTriangleNode = ˆTROAMTriangleNode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLROAMPatch: Class EGLROAMException

Class EGLROAMException

Unit

GLROAMPatch

Declaration

type EGLROAMException = class(Exception)

Description

Hierarchy

  • Exception
  • EGLROAMException
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLROAMPatch: packed record TROAMTriangleNode

packed record TROAMTriangleNode

Unit

GLROAMPatch

Declaration

type TROAMTriangleNode = packed record

Description

Overview

Fields

base: PROAMTriangleNode;
left: PROAMTriangleNode;
right: PROAMTriangleNode;
leftChild: PROAMTriangleNode;
rightChild: PROAMTriangleNode;

Description

Fields

base: PROAMTriangleNode;
left: PROAMTriangleNode;
right: PROAMTriangleNode;
leftChild: PROAMTriangleNode;
rightChild: PROAMTriangleNode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLROAMPatch: packed record TROAMRenderPoint

packed record TROAMRenderPoint

Unit

GLROAMPatch

Declaration

type TROAMRenderPoint = packed record

Description

Overview

Fields

X: integer;
Y: integer;
idx: integer;

Description

Fields

X: integer;
Y: integer;
idx: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLROAMPatch: Class TGLROAMPatch

Class TGLROAMPatch

Unit

GLROAMPatch

Declaration

type TGLROAMPatch = class(TObject)

Description

Hierarchy

  • TObject
  • TGLROAMPatch

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function SafeTesselate: boolean;
Protected | function Tesselate: boolean;
Public | procedure ComputeVariance(variance: integer);
Public | procedure ConnectToTheNorth(northPatch: TGLROAMPatch);
Public | procedure ConnectToTheWest(westPatch: TGLROAMPatch);
Public | class procedure FlushAccum(vertices: TAffineVectorList; vertexIndices: TIntegerList; texCoords: TTexPointList);
Public | procedure RenderAccum(vertices: TAffineVectorList; vertexIndices: TIntegerList; texCoords: TTexPointList; autoFlushVertexCount: integer);
Public | procedure RenderHighRes(vertices: TAffineVectorList; vertexIndices: TIntegerList; texCoords: TTexPointList; forceROAM: boolean);
Public | procedure ResetTessellation;
Protected | procedure RenderAsStrips(vertices: TAffineVectorList; vertexIndices: TIntegerList; texCoords: TTexPointList);
Protected | procedure RenderROAM(vertices: TAffineVectorList; vertexIndices: TIntegerList; texCoords: TTexPointList);
Protected | procedure SetHeightData(val: THeightData);
Protected | procedure SetOcclusionSkip(val: integer);

Properties

Public | property HeightData: THeightData read FHeightData write SetHeightData;
Public | property HighRes: boolean read FHighRes write FHighRes;
Public | property ID: integer read FID;
Public | property LastOcclusionTestPassed: boolean read FLastOcclusionTestPassed;
Public | property ObserverPosition: TAffineVector read FObserverPosition write FObserverPosition;
Public | property OcclusionCounter: integer read FOcclusionCounter write FOcclusionCounter;
Public | property OcclusionSkip: integer read FOcclusionSkip write SetOcclusionSkip;
Public | property Tag: integer read FTag write FTag;
Public | property TextureOffset: TAffineVector read FTextureOffset write FTextureOffset;
Public | property TextureScale: TAffineVector read FTextureScale write FTextureScale;
Public | property TriangleCount: integer read FTriangleCount;
Public | property VertexOffset: TAffineVector read FVertexOffset write FVertexOffset;
Public | property VertexScale: TAffineVector read FVertexScale write FVertexScale;

Description

Methods

Public constructor Create;
Public destructor Destroy; override;
Public function SafeTesselate: boolean;

AV free version of Tesselate.<p> When IncreaseTrianglesCapacity is called, all PROAMTriangleNode values in higher function became invalid due to the memory shifting. Recursivity is the main problem, that's why SafeTesselate is calling Tesselate in a try..except .

Protected function Tesselate: boolean;
Public procedure ComputeVariance(variance: integer);
Public procedure ConnectToTheNorth(northPatch: TGLROAMPatch);
Public procedure ConnectToTheWest(westPatch: TGLROAMPatch);
Public class procedure FlushAccum(vertices: TAffineVectorList; vertexIndices: TIntegerList; texCoords: TTexPointList);

Render all vertices accumulated in the arrays and set their count back to zero.

Public procedure RenderAccum(vertices: TAffineVectorList; vertexIndices: TIntegerList; texCoords: TTexPointList; autoFlushVertexCount: integer);

Render the patch by accumulating triangles.<p> The lists are assumed to have enough capacity to allow AddNC calls (additions without capacity check).<br> Once at least autoFlushVertexCount vertices have been accumulated, perform a FlushAccum

Public procedure RenderHighRes(vertices: TAffineVectorList; vertexIndices: TIntegerList; texCoords: TTexPointList; forceROAM: boolean);

Render the patch in high-resolution.<p> The lists are assumed to have enough capacity to allow AddNC calls (additions without capacity check). High-resolution renders use display lists, and are assumed to be made together.

Public procedure ResetTessellation;
Protected procedure RenderAsStrips(vertices: TAffineVectorList; vertexIndices: TIntegerList; texCoords: TTexPointList);
Protected procedure RenderROAM(vertices: TAffineVectorList; vertexIndices: TIntegerList; texCoords: TTexPointList);
Protected procedure SetHeightData(val: THeightData);
Protected procedure SetOcclusionSkip(val: integer);

Properties

Public property HeightData: THeightData read FHeightData write SetHeightData;
Public property HighRes: boolean read FHighRes write FHighRes;
Public property ID: integer read FID;
Public property LastOcclusionTestPassed: boolean read FLastOcclusionTestPassed;

Result for the last occlusion test.<p> Note that this value is updated upon rendering the tile in non-high-res mode only.

Public property ObserverPosition: TAffineVector read FObserverPosition write FObserverPosition;
Public property OcclusionCounter: integer read FOcclusionCounter write FOcclusionCounter;

Number of frames remaining to next occlusion test.

Public property OcclusionSkip: integer read FOcclusionSkip write SetOcclusionSkip;

Number of frames to skip after an occlusion test returned zero pixels.

Public property Tag: integer read FTag write FTag;
Public property TextureOffset: TAffineVector read FTextureOffset write FTextureOffset;
Public property TextureScale: TAffineVector read FTextureScale write FTextureScale;
Public property TriangleCount: integer read FTriangleCount;
Public property VertexOffset: TAffineVector read FVertexOffset write FVertexOffset;
Public property VertexScale: TAffineVector read FVertexScale write FVertexScale;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLSArchiveManager

Unit GLSArchiveManager

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

<b>History : </b><font size=-1><ul> <li>04/06/10 - Yar - Added to GLScene (Created by Rustam Asmandiarov aka Predator) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TBaseArchive |
Class TArchiveFileFormat |
Class TArchiveFileFormatsList |
Class TLibArchive |
Class TLibArchives |
Class TGLSArchiveManager |
Class EInvalidArchiveFile |

Functions and Procedures

function GetArchiveFileFormats: TArchiveFileFormatsList;
procedure RegisterArchiveFormat(const AExtension, ADescription: string; AClass: TBaseArchiveClass);
procedure UnregisterArchiveFormat(AClass: TBaseArchiveClass);
function GetArchiveManager: TGLSArchiveManager;
function ArcCreateFileStream(const fileName: string; mode: word): TStream;
function ArcFileStreamExists(const fileName: string): boolean;

Types

TCompressionLevel = (...);
TBaseArchiveClass = class of TBaseArchive;

Description

Functions and Procedures

function GetArchiveFileFormats: TArchiveFileFormatsList;
procedure RegisterArchiveFormat(const AExtension, ADescription: string; AClass: TBaseArchiveClass);
procedure UnregisterArchiveFormat(AClass: TBaseArchiveClass);
function GetArchiveManager: TGLSArchiveManager;
function ArcCreateFileStream(const fileName: string; mode: word): TStream;
function ArcFileStreamExists(const fileName: string): boolean;

Types

TCompressionLevel = (...);
Values
  • clNone:
  • clFastest:
  • clDefault:
  • clMax:
  • clLevel1:
  • clLevel2:
  • clLevel3:
  • clLevel4:
  • clLevel5:
  • clLevel6:
  • clLevel7:
  • clLevel8:
  • clLevel9:
TBaseArchiveClass = class of TBaseArchive;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLSArchiveManager: Class TBaseArchive

Class TBaseArchive

Unit

GLSArchiveManager

Declaration

type TBaseArchive = class(TDataFile)

Description

no description available, TDataFile description follows

Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TBaseArchive

Overview

Fields

Protected | FFileName: string;
Protected | FContentList: TStrings;
Protected | FCompressionLevel: TCompressionLevel;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function ContentExists(ContentName: string): boolean; virtual; abstract;
Public | function GetContent(ContentName: string): TStream; overload; virtual; abstract;
Public | function GetContent(index: integer): TStream; overload; virtual; abstract;
Public | function GetContent(Stream: TStream; index: integer): TStream; overload; virtual; abstract;
Public | function GetContentSize(index: integer): integer; overload; virtual; abstract;
Public | function GetContentSize(ContentName: string): integer; overload; virtual; abstract;
Public | procedure AddFromFile(FileName, Path: string); virtual; abstract;
Public | procedure AddFromStream(ContentName, Path: string; FS: TStream); virtual; abstract;
Public | procedure Clear; virtual; abstract;
Public | procedure Extract(index: integer; NewName: string); overload; virtual; abstract;
Public | procedure Extract(ContentName, NewName: string); overload; virtual; abstract;
Public | procedure RemoveContent(ContentName: string); overload; virtual; abstract;
Public | procedure RemoveContent(index: integer); overload; virtual; abstract;
Protected | Procedure SetCompressionLevel(aValue: TCompressionLevel); Virtual;

Properties

Public | property CompressionLevel: TCompressionLevel read FCompressionLevel write SetCompressionLevel default clNone;
Public | property ContentList: TStrings read FContentList;

Description

Fields

Protected FFileName: string;
Protected FContentList: TStrings;
Protected FCompressionLevel: TCompressionLevel;

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public function ContentExists(ContentName: string): boolean; virtual; abstract;
Public function GetContent(ContentName: string): TStream; overload; virtual; abstract;
Public function GetContent(index: integer): TStream; overload; virtual; abstract;
Public function GetContent(Stream: TStream; index: integer): TStream; overload; virtual; abstract;
Public function GetContentSize(index: integer): integer; overload; virtual; abstract;
Public function GetContentSize(ContentName: string): integer; overload; virtual; abstract;
Public procedure AddFromFile(FileName, Path: string); virtual; abstract;
Public procedure AddFromStream(ContentName, Path: string; FS: TStream); virtual; abstract;
Public procedure Clear; virtual; abstract;
Public procedure Extract(index: integer; NewName: string); overload; virtual; abstract;
Public procedure Extract(ContentName, NewName: string); overload; virtual; abstract;
Public procedure RemoveContent(ContentName: string); overload; virtual; abstract;
Public procedure RemoveContent(index: integer); overload; virtual; abstract;
Protected Procedure SetCompressionLevel(aValue: TCompressionLevel); Virtual;

Properties

Public property CompressionLevel: TCompressionLevel read FCompressionLevel write SetCompressionLevel default clNone;
Public property ContentList: TStrings read FContentList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLSArchiveManager: Class TArchiveFileFormat

Class TArchiveFileFormat

Unit

GLSArchiveManager

Declaration

type TArchiveFileFormat = class(TObject)

Description

Hierarchy

  • TObject
  • TArchiveFileFormat

Overview

Fields

Public | BaseArchiveClass: TBaseArchiveClass;
Public | Extension: string;
Public | Description: string;
Public | DescResID: Integer;

Description

Fields

Public BaseArchiveClass: TBaseArchiveClass;
Public Extension: string;
Public Description: string;
Public DescResID: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLSArchiveManager: Class TArchiveFileFormatsList

Class TArchiveFileFormatsList

Unit

GLSArchiveManager

Declaration

type TArchiveFileFormatsList = class(TPersistentObjectList)

Description

no description available, TPersistentObjectList description follows

A persistent Object list.<p> Similar to TList but works on TObject items and has facilities for persistence of contained data. Unlike the VCL's TObjectList, this one does NOT free its objects upon destruction or Clear, use Clean and CleanFree for that, and as such can be used for object referral lists too.<br> But only TPersistentObject items will be streamed appropriately.<p> The list can be used in a stack-like fashion with Push & Pop, and can perform basic boolean set operations.<p> Note: the IndexOf implementation is up to 3 times faster than that of TList

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TArchiveFileFormatsList

Overview

Methods

Public | destructor Destroy; override;
Public | function FindExt(ext: string): TBaseArchiveClass;
Public | function FindFromFileName(const fileName: string): TBaseArchiveClass;
Public | procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TBaseArchiveClass);
Public | procedure Remove(AClass: TBaseArchiveClass);

Description

Methods

Public destructor Destroy; override;
Public function FindExt(ext: string): TBaseArchiveClass;
Public function FindFromFileName(const fileName: string): TBaseArchiveClass;
Public procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TBaseArchiveClass);
Public procedure Remove(AClass: TBaseArchiveClass);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLSArchiveManager: Class TLibArchive

Class TLibArchive

Unit

GLSArchiveManager

Declaration

type TLibArchive = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TLibArchive

Overview

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Public | function ContentExists(aContentName: string): boolean;
Public | function GetContent(aindex: integer): TStream; overload;
Public | function GetContent(aContentName: string): TStream; overload;
Public | function GetContentSize(aContentName: string): integer; overload;
Public | function GetContentSize(aindex: integer): integer; overload;
Protected | function GetDisplayName: string; override;
Public | procedure AddFromFile(aFileName: string); overload;
Public | procedure AddFromFile(aFileName, aPath: string); overload;
Public | procedure AddFromStream(aContentName: string; aF: TStream); overload;
Public | procedure AddFromStream(aContentName, aPath: string; aF: TStream); overload;
Public | procedure Clear;
Public | procedure CreateArchive(FileName: string; OverwriteExistingFile: boolean = False);
Public | procedure Extract(aindex: integer; aNewName: string); overload;
Public | procedure Extract(aContentName, aNewName: string); overload;
Public | procedure LoadFromFile(aFileName, aAchiverType: string); overload;
Public | procedure LoadFromFile(aFileName: string); overload;
Public | procedure RemoveContent(aindex: integer); overload;
Public | procedure RemoveContent(aContentName: string); overload;

Properties

Public | property CompressionLevel: TCompressionLevel read GetCompressionLevel write SetCompressionLevel default clNone;
Public | property ContentList: TStrings read GetContentList;
Public | property FileName: string read FFileName;
Published | property Name: string read FName write SetName;

Description

Methods

Public constructor Create(ACollection: TCollection); override;
Public destructor Destroy; override;
Public function ContentExists(aContentName: string): boolean;
Public function GetContent(aindex: integer): TStream; overload;
Public function GetContent(aContentName: string): TStream; overload;
Public function GetContentSize(aContentName: string): integer; overload;
Public function GetContentSize(aindex: integer): integer; overload;
Protected function GetDisplayName: string; override;
Public procedure AddFromFile(aFileName: string); overload;
Public procedure AddFromFile(aFileName, aPath: string); overload;
Public procedure AddFromStream(aContentName: string; aF: TStream); overload;
Public procedure AddFromStream(aContentName, aPath: string; aF: TStream); overload;
Public procedure Clear;
Public procedure CreateArchive(FileName: string; OverwriteExistingFile: boolean = False);
Public procedure Extract(aindex: integer; aNewName: string); overload;
Public procedure Extract(aContentName, aNewName: string); overload;
Public procedure LoadFromFile(aFileName, aAchiverType: string); overload;
Public procedure LoadFromFile(aFileName: string); overload;
Public procedure RemoveContent(aindex: integer); overload;
Public procedure RemoveContent(aContentName: string); overload;

Properties

Public property CompressionLevel: TCompressionLevel read GetCompressionLevel write SetCompressionLevel default clNone;
Public property ContentList: TStrings read GetContentList;
Public property FileName: string read FFileName;
Published property Name: string read FName write SetName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLSArchiveManager: Class TLibArchives

Class TLibArchives

Unit

GLSArchiveManager

Declaration

type TLibArchives = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TLibArchives

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TLibArchive;
Public | function FindItemID(ID: Integer) : TLibArchive;
Public | function GetArchiveByFileName(const AName: string) : TLibArchive;
Public | function GetFileNameOfArchive(aValue: TLibArchive) : string;
Public | function GetLibArchiveByName(const AName: string) : TLibArchive;
Public | function GetNameOfLibArchive(const Archive: TLibArchive) : string;
Public | function IndexOf(const Item: TLibArchive) : Integer;
Public | function MakeUniqueName(const nameRoot: string) : string;
Public | function Owner: TPersistent;
Protected | function GetItems(index: Integer): TLibArchive;
Protected | procedure SetItems(index: Integer; const val: TLibArchive);

Properties

Public property Items[index: Integer]: TLibArchive read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);
Public function Add: TLibArchive;
Public function FindItemID(ID: Integer) : TLibArchive;
Public function GetArchiveByFileName(const AName: string) : TLibArchive;
Public function GetFileNameOfArchive(aValue: TLibArchive) : string;
Public function GetLibArchiveByName(const AName: string) : TLibArchive;
Public function GetNameOfLibArchive(const Archive: TLibArchive) : string;
Public function IndexOf(const Item: TLibArchive) : Integer;
Public function MakeUniqueName(const nameRoot: string) : string;
Public function Owner: TPersistent;
Protected function GetItems(index: Integer): TLibArchive;
Protected procedure SetItems(index: Integer; const val: TLibArchive);

Properties

Public property Items[index: Integer]: TLibArchive read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLSArchiveManager: Class TGLSArchiveManager

Class TGLSArchiveManager

Unit

GLSArchiveManager

Declaration

type TGLSArchiveManager = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLSArchiveManager

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function ContentExists(aContentName: string): boolean;
Public | function GetArchiveByFileName(const aName: string): TLibArchive;
Public | function GetContent(aContentName: string): TStream;
Public | function GetFileNameOfArchive(const aArchive: TLibArchive): string;
Public | function OpenArchive(aFileName, aAchiverType: string): TLibArchive; overload;
Public | function OpenArchive(aFileName: string): TLibArchive; overload;
Public | procedure CloseArchive(aArchive: TLibArchive);

Properties

Published property Archives: TLibArchives read FArchives write SetArchives;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function ContentExists(aContentName: string): boolean;
Public function GetArchiveByFileName(const aName: string): TLibArchive;
Public function GetContent(aContentName: string): TStream;
Public function GetFileNameOfArchive(const aArchive: TLibArchive): string;
Public function OpenArchive(aFileName, aAchiverType: string): TLibArchive; overload;
Public function OpenArchive(aFileName: string): TLibArchive; overload;
Public procedure CloseArchive(aArchive: TLibArchive);

Properties

Published property Archives: TLibArchives read FArchives write SetArchives;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLSArchiveManager: Class EInvalidArchiveFile

Class EInvalidArchiveFile

Unit

GLSArchiveManager

Declaration

type EInvalidArchiveFile = class(Exception)

Description

Hierarchy

  • Exception
  • EInvalidArchiveFile
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:39


GLScene v.1.1.2: GLScene

Unit GLScene

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLScene<p>

Base classes and structures for GLScene.<p>

<b>History : </b><font size=-1><ul> <li>03/02/13 - Yar - Added master's scale transformation to TGLProxyObject (thanks to Dmitriy aka buh) <li>20/11/12 - PW - Added CPP compatibility: changed arrays of vectors to records with arrays <li>15/10/11 - YP - Don't set GLSelection buffer size, it's automatically done in the repeat until loop <li>02/09/11 - Yar - Added csPerspectiveKeepFOV to TGLCamera.CameraStyle (thanks benok1) <li>30/06/11 - DaStr - Bugfixed VisibilityCulling in vcObjectBased mode <li>04/05/11 - Vince - Fix picking problems with Ortho2D Camera <li>21/11/10 - Yar - Added design time navigation <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>25/10/10 - Yar - Bugfixed TGLSceneBuffer.CopyToTexture <li>08/09/10 - Yar - Added gloabal var vCurrentRenderingObject (Thanks Controller) <li>02/09/10 - Yar - Added GLSelection to uses. Improved TGLSceneBuffer.PickObjects for 64-bit OSes <li>29/08/10 - Yar - Bugfixed TGLSceneBuffer.DoStructuralChange when component loading causing excessive context recreation <li>23/08/10 - Yar - Removed all critical deprecated OpenGL function from rendering cycle. Now TGLSceneBuffer can work with forward core context. Pipeline transformation and lighting becomes abststract. <li>18/06/10 - Yar - Replaced OpenGL1x functions to OpenGLAdapter. Changed AddBuffer to improved GLX context sharing. <li>31/05/10 - Yar - Fixes for Linux x64 <li>31/05/10 - Yar - Added roSoftwareMode Buffer.ContextOptions <li>22/04/10 - Yar - Fixes after GLState revision <li>11/04/10 - Yar - Replaced glNewList to GLState.NewList in TGLBaseSceneObject.GetHandle <li>06/04/10 - Yar - Removed double camera freeing in TGLSceneBuffer.Destroy (thanks to Rustam Asmandiarov aka Predator) <li>06/03/10 - Yar - Renamed ModelViewMatrix to ViewMatrix, added ModelMatrix All function working with ModelViewMatrix now deprecated Added roForwardContext to buffer options <li>05/03/10 - DanB - More state added to TGLStateCache <li>22/02/10 - DanB - Moved TGLSceneBuffer.GLStates to TGLContext.GLStates <li>22/02/10 - Yar - Added Push/PopProjectionMatrix to TGLSceneBuffer Optimization of switching states <li>14/03/09 - DanB - Moved RenderScene from TGLScene to TGLSceneBuffer, removed TGLScene.Cameras, place cameras inside scene instead. TGLObjectEffect no longer has "buffer" parameter in render events. <li>24/11/08 - DanB - TGLBaseSceneObject.Assign no longer changes scene of destination object (thanks Alan G.) <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 changed PChar to Pointer where possible <li>12/10/08 - DanB - added nearClippingDistance to RCI <li>09/10/08 - DanB - removed TGLScene.RenderedObject, moved TGLProgressEvent to BaseClasses <li>20/04/08 - DaStr - Added a AABB cauching mechanism to TGLBaseSceneObject TGLDirectOpenGL's dimentions are now all all zeros (all above changes were made by Pascal) <li>15/03/08 - DaStr - Implemented TGLProxyObject.BarycenterAbsolutePosition() <li>16/02/08 - Mrqzzz - Other fix to ResetAndPitchTurnRoll by Pete,Dan Bartlett <li>12/02/08 - Mrqzzz - Dave Gravel fixed ResetAndPitchTurnRoll <li>20/01/08 - DaStr - Bugfixed TGLBaseSceneObject.MoveChild[First/Last]() (thanks "_") (BugTracker ID = 1857974) Converted the TGLBaseSceneObject.AbsoluteMatrix() function into a property (and added a Set method) Added TGLBaseSceneObject.AbsoluteLeft() <li>19/09/07 - DaStr - Made some changes to TGLBaseSceneObject Bounding Box calculations (BugTracker ID = 1797491) <li>17/09/07 - DaStr - Fixed TGLScene.RenderScene (InitializableObjects stuff) (BugTracker ID = 1796358) Moved TGLBaseSceneObject.SetScene to the protected section <li>10/09/07 - DaStr - TGLBaseSceneObject: Added AxisAlignedBoundingBoxAbsolute Bugfixed GetAbsoluteScale <li>08/09/07 - DaStr - Added TGLBaseSceneObject.Absolute[Affine]Scale <li>18/06/07 - DaStr - Fixed bug which caused objects' order to get inverted (BugtrackerID = 1739180) (thanks Burkhard Carstens) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>03/04/07 - DaStr - GLS_DELPHI_5_UP renamed to GLS_DELPHI_4_DOWN for FPC compatibility (thanks Burkhard Carstens) <li>29/03/07 - DaStr - GLS_WANT_DATA removed Added IGLInitializable, TGLInitializableObjectList Added TGLScene.InitializableObjects <li>28/03/07 - DaStr - Added more explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) Fixed TGLBaseSceneObject.Destroy (potential AV) <li>26/03/07 - aidave - Added MoveFirst, MoveLast <li>26/03/07 - aidave - Added MoveChildFirst, MoveChildLast <li>25/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>14/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>10/03/07 - DaStr - TGLSceneBuffer's Events are not stored now (thanks Burkhard Carstens) (BugtrackerID = 1678654) <li>15/02/07 - DaStr - TGLBaseSceneObject.GetChildren bugfixed (subcomponent support) <li>09/02/07 - DaStr - TGLBaseSceneObject.ExchangeChildren(Safe) added (thanks apo_pq) Global $R- removed <li>07/02/07 - DaStr - TGLBaseSceneObject.Remove bugfixed (subcomponent support) TGLBaseSceneObject.HasSubChildren added <li>20/12/06 - DaStr - TGLBaseSceneObject: AbsoluteAffine[Position/Direction/up] added Affine[Right/LeftVector] added OnAddedToParent Event and DoOnAddedToParent() procedure added DistanceTo() and SqrDistanceTo() overloaded Support for GLS_OPTIMIZATIONS added <li>19/10/06 - LC - Fixed TGLSceneBuffer.OrthoScreenToWorld. Bugtracker ID=1537765 (thanks dikoe) <li>19/10/06 - LC - Removed unused assignment in TGLSceneBuffer.SaveAsFloatToFile <li>13/09/06 - NelC - Added TGLSceneBuffer.SaveAsFloatToFile <li>12/09/06 - NelC - Added roNoDepthBufferClear, support for Multiple-Render-Target <li>17/07/06 - PvD - Fixed TGLSceneBuffer.OrthoScreenToWorld sometimes translates screen coordinates incorrectly <li>08/03/06 - ur - added global OptSaveGLStack variable for "arbitrary" deep scene trees <li>06/03/06 - Mathx - Fixed Freeze/Melt (thanks Fig) <li>04/12/04 - MF - Changed FieldOfView to work with degrees (not radians) <li>04/12/04 - MF - Added GLCamera.SetFieldOfView and GLCamera.GetFieldOfView, formula by Ivan Sivak Jr. <li>04/10/04 - NelC - Added support for 64bit and 128bit color depth (float pbuffer) <li>07/07/04 - Mrqzzz - TGLbaseSceneObject.Remove checks if removed object is actually a child (Uffe Hammer) <li>25/02/04 - Mrqzzz - Added TGLSCene.RenderedObject <li>25/02/04 - EG - Children no longer owned <li>13/02/04 - NelC - Added option Modal for ShowInfo <li>04/02/04 - SG - Added roNoSwapBuffers option to TContextOptions (Juergen Abel) <li>09/01/04 - EG - Added TGLCameraInvariantObject <li>06/12/03 - EG - TGLColorProxy moved to new GLProxyObjects unit, GLVectorFileObjects dependency cut. <li>06/12/03 - EG - New FramesPerSecond logic <li>04/12/03 - Dave - Added ProxyObject.OctreeRayCastIntersect <li>26/12/03 - EG - Removed last TList dependencies <li>05/12/03 - Dave - Added GLCamera.PointInFront - Dave - Remade Data property to use Tag <li>05/11/03 - EG - Data pointer made optional (GLS_WANT_DATA define), applications should use VCL's standard (ie. "Tag") <li>04/11/03 - Dave - Added Data pointer to GLSceneBaseObject <li>24/10/03 - NelC - Fixed texture-flipped bug in cubemap generation <li>21/08/03 - EG - Added osRenderNearestFirst <li>28/07/03 - aidave - Added TGLColorProxyObject <li>22/07/03 - EG - LocalMatrix now a PMatrix, FListHandle and FChildren are now autocreating <li>17/07/03 - EG - Removed TTransformationMode and related code <li>16/07/03 - EG - TGLBaseGuiObject moved to GLGui along with RecursiveVisible mechanism <li>19/06/03 - DanB - Added TGLBaseSceneObject.GetOrCreateBehaviour/Effect <li>11/06/03 - Egg - Added CopyToTexture for buffer <li>10/06/03 - Egg - Fixed issue with SetXxxxAngle (Domin) <li>07/06/03 - Egg - Added Buffer.AmbientColor <li>06/06/03 - Egg - Added roNoColorBufferClear <li>21/05/03 - Egg - RenderToBitmap RC setup fixes (Yurik) <li>07/05/03 - Egg - TGLSceneBuffer now invokes BeforeRender and PostRender events even when no camera has been specified <li>13/02/03 - DanB - added unscaled Dimensions and Bounding Box methods <li>03/01/03 - JAJ - Added TGLBaseGuiObject as minimal base GUI class. <li>31/12/02 - JAJ - NotifyHide/NotifyShow implemented. Crucial for the Gui system. <li>14/10/02 - Egg - Camera.TargetObject explicitly registered for notifications <li>07/10/02 - Egg - Fixed Remove/Add/Insert (sublights registration bug) <li>04/09/02 - Egg - BoundingBox computation now based on AABB code, Fixed TGLSceneBuffer.PixelRayToWorld <li>27/08/02 - Egg - Added TGLProxyObject.RayCastIntersect (Matheus Degiovani), Fixed PixelRayToWorld <li>22/08/02 - Egg - Fixed src LocalMatrix computation on Assign <li>12/08/02 - Egg - Fixed Effects persistence 'Assert' issue (David Alcelay), TGLSceneBuffer.PickObjects now preserves ProjMatrix <li>13/07/02 - Egg - Fixed CurrentStates computation <li>01/07/02 - Egg - Fixed XOpenGL picking state <li>03/06/02 - Egg - TGLSceneBuffer.DestroyRC now removes buffer from scene's list <li>30/05/02 - Egg - Fixed light movements not triggering viewer redraw issue, lights no longer 'invisible' (sub objects get rendered) <li>05/04/02 - Egg - Fixed XOpenGL initialization/reinitialization <li>13/03/02 - Egg - Fixed camera-switch loss of "reactivity" <li>08/03/02 - Egg - Fixed InvAbsoluteMatrix/AbsoluteMatrix decoupling <li>05/03/02 - Egg - Added MoveObjectAround <li>04/03/02 - Egg - CoordinateChanged default rightVector based on X, then Y <li>27/02/02 - Egg - Added DepthPrecision and ColorDepth to buffer, ResetAndPitchTurnRoll, ShadeModel (Chris Strahm) <li>26/02/02 - Egg - DestroyHandle/DestroyHandles split, Fixed PickObjects guess count (Steffen Xonna) <li>22/02/02 - Egg - Push/pop ModelView matrix for buffer <li>07/02/02 - Egg - Faster InvAbsoluteMatrix computation <li>06/02/02 - Egg - ValidateTransformations phased out <li>05/02/02 - Egg - Added roNoColorBuffer <li>03/02/02 - Egg - InfoForm registration mechanism, AbsolutePosition promoted to read/write property <li>27/01/02 - Egg - Added TGLCamera.RotateObject, fixed SetMatrix, added RotateAbsolute, ResetRotations <li>21/01/02 - Egg - More graceful recovery for ICDs without pbuffer support <li>10/01/02 - Egg - Fixed init of stCullFace in SetupRenderingContext, MoveAroundTarget/AdjustDistanceToTarget absolute pos fix <li>07/01/02 - Egg - Added some doc, reduced dependencies, RenderToBitmap fixes <li>28/12/01 - Egg - Event persistence change (GliGli / Dephi bug), LoadFromStream fix (noeska) <li>16/12/01 - Egg - Cube maps support (textures and dynamic rendering) <li>15/12/01 - Egg - Added support for AlphaBits <li>12/12/01 - Egg - Introduced TGLNonVisualViewer, TGLSceneViewer moved to GLWin32Viewer <li>07/12/01 - Egg - Added TGLBaseSceneObject.PointTo <li>06/12/01 - Egg - Published OnDblClik and misc. events (Chris S), Some cross-platform cleanups <li>05/12/01 - Egg - MoveAroundTarget fix (Phil Scadden) <li>30/11/01 - Egg - Hardware acceleration detection support, Added Camera.SceneScale (based on code by Chris S) <li>24/09/01 - Egg - TGLProxyObject loop rendering protection <li>14/09/01 - Egg - Use of vFileStreamClass <li>04/09/01 - Egg - Texture binding cache <li>25/08/01 - Egg - Support for WGL_EXT_swap_control (VSync control), Added TGLMemoryViewer <li>24/08/01 - Egg - TGLSceneViewer broken, TGLSceneBuffer born <li>23/08/01 - Lin - Added PixelDepthToDistance function (Rene Lindsay) <li>23/08/01 - Lin - Added ScreenToVector function (Rene Lindsay) <li>23/08/01 - Lin - Fixed PixelRayToWorld no longer requires the camera to have a TargetObject set. (Rene Lindsay) <li>22/08/01 - Egg - Fixed ocStructure not being reset for osDirectDraw objects, Added Absolute-Local conversion helpers, glPopName fix (Puthoon) <li>20/08/01 - Egg - SetParentComponent now accepts 'nil' (Uwe Raabe) <li>19/08/01 - Egg - Default RayCastIntersect is now Sphere <li>16/08/01 - Egg - Dropped Prepare/FinishObject (became obsolete), new CameraStyle (Ortho2D) <li>12/08/01 - Egg - Completely rewritten handles management, Faster camera switching <li>29/07/01 - Egg - Added pooTransformation <li>19/07/01 - Egg - Focal lengths in the ]0; 1[ range are now allowed (beware!) <li>18/07/01 - Egg - Added VisibilityCulling <li>09/07/01 - Egg - Added BoundingBox methods based on code from Jacques Tur <li>08/07/01 - Egg - Fixes from Simon George added in (HDC, contexts and leaks related in TGLSceneViewer), dropped the TCanvas, Added PixelRayToWorld (by Rene Lindsay) <li>06/07/01 - Egg - Fixed Turn/Roll/Pitch Angle Normalization issue <li>04/07/01 - Egg - Minor VectorTypes related changes <li>25/06/01 - Egg - Added osIgnoreDepthBuffer to TObjectStyles <li>20/03/01 - Egg - LoadFromFile & LoadFromStream fixes by Uwe Raabe <li>16/03/01 - Egg - SaveToFile/LoadFromFile additions/fixes by Uwe Raabe <li>14/03/01 - Egg - Streaming fixes by Uwe Raabe <li>03/03/01 - Egg - Added Stencil buffer support <li>02/03/01 - Egg - Added TGLSceneViewer.CreateSnapShot <li>01/03/01 - Egg - Fixed initialization of rci.proxySubObject (broke picking) <li>26/02/01 - Egg - Added support for GL_NV_fog_distance <li>25/02/01 - Egg - Proxy's subobjects are now pushed onto the picking stack <li>22/02/01 - Egg - Changed to InvAbsoluteMatrix code by Uwe Raabe <li>15/02/01 - Egg - Added SubObjects picking code by Alan Ferguson <li>31/01/01 - Egg - Fixed Delphi4 issue in TGLProxyObject.Notification, Invisible objects are no longer depth-sorted <li>21/01/01 - Egg - Simplified TGLBaseSceneObject.SetName <li>17/01/01 - Egg - New TGLCamera.MoveAroundTarget code by Alan Ferguson, Fixed TGLBaseSceneObject.SetName (thx Jacques Tur), Fixed AbsolutePosition/AbsoluteMatrix <li>13/01/01 - Egg - All transformations are now always relative, GlobalMatrix removed/merged with AbsoluteMatrix <li>10/01/01 - Egg - If OpenGL is unavailable, TGLSceneViewer will now work as a regular (blank) WinControl <li>08/01/01 - Egg - Added DoRender for TGLLightSource & TGLCamera <li>04/01/01 - Egg - Fixed Picking (broken by Camera-Sprite fix) <li>22/12/00 - Egg - Fixed error detection in DoDestroyList <li>20/12/00 - Egg - Fixed bug with deleting/freeing a branch with cameras <li>18/12/00 - Egg - Fixed deactivation of Fog (wouldn't deactivate) <li>11/12/00 - Egg - Changed ConstAttenuation default to 0 (VCL persistence bug) <li>05/11/00 - Egg - Completed Screen->World function set, finalized rendering logic change, added orthogonal projection <li>03/11/00 - Egg - Fixed sorting pb with osRenderBlendedLast, Changed camera/world matrix logic, WorldToScreen/WorldToScreen now working <li>30/10/00 - Egg - Fixes for FindChild (thx Steven Cao) <li>12/10/00 - Egg - Added some doc <li>08/10/00 - Egg - Fixed assignment HDC/display list quirk <li>08/10/00 - Egg - Based on work by Roger Cao : Rotation property in TGLBaseSceneObject, Fix in LoadFromfile to avoid name changing and lighting error, Added LoadFromTextFile and SaveToTextFile, Added FindSceneObject <li>25/09/00 - Egg - Added Null checks for SetDirection and SetUp <li>13/08/00 - Egg - Fixed TGLCamera.Apply when camera is not targeting, Added clipping support stuff <li>06/08/00 - Egg - TGLCoordinates moved to GLMisc <li>23/07/00 - Egg - Added GetPixelColor/Depth <li>19/07/00 - Egg - Fixed OpenGL states messup introduces with new logic, Fixed StructureChanged clear flag bug (thanks Roger Cao) <li>15/07/00 - Egg - Altered "Render" logic to allow relative rendering, TProxyObject now renders children too <li>13/07/00 - Egg - Completed (?) memory-leak fixes <li>12/07/00 - Egg - Added 'Hint' property to TGLCustomSceneObject, Completed TGLBaseSceneObject.Assign, Fixed memory loss in TGLBaseSceneObject (Scaling), Many changes to list destruction scheme <li>11/07/00 - Egg - Eased up propagation in Structure/TransformationChanged <li>28/06/00 - Egg - Added ObjectStyle to TGLBaseSceneObject, various changes to the list/handle mechanism <li>22/06/00 - Egg - Added TLightStyle (suggestion by Roger Cao) <li>19/06/00 - Egg - Optimized SetXxxAngle <li>09/06/00 - Egg - First row of Geometry-related upgrades <li>07/06/00 - Egg - Removed dependency to 'Math', RenderToFile <-> Bitmap Overload (Aaron Hochwimmer) <li>28/05/00 - Egg - AxesBuildList now available as a procedure, Un-re-fixed TGLLightSource.DestroyList, Fixed RenderToBitmap <li>26/05/00 - Egg - Slightly changed DrawAxes to avoid a bug in nVidia OpenGL <li>23/05/00 - Egg - Added first set of collision-detection methods <li>22/05/00 - Egg - SetXxxxAngle now properly assigns to FXxxxAngle <li>08/05/00 - Egg - Added Absolute?Vector funcs to TGLBaseSceneObject <li>08/05/00 - RoC - Fixes in TGLScene.LoadFromFile, TGLLightSource.DestroyList <li>26/04/00 - Egg - TagFloat now available in TGLBaseSceneObject, Added TGLProxyObject <li>18/04/00 - Egg - Added TGLObjectEffect structures, TGLCoordinates.CreateInitialized <li>17/04/00 - Egg - Fixed BaseSceneObject.Assign (wasn't duping children), Removed CreateSceneObject, Optimized TGLSceneViewer.Invalidate <li>16/04/00 - Egg - Splitted Render to Render + RenderChildren <li>11/04/00 - Egg - Added TGLBaseSceneObject.SetScene (thanks Uwe) and fixed various funcs accordingly <li>10/04/00 - Egg - Improved persistence logic for behaviours, Added RegisterGLBehaviourNameChangeEvent <li>06/04/00 - Egg - RebuildMatrix should be slightly faster now <li>05/04/00 - Egg - Added TGLBehaviour stuff, Angles are now public stuff in TGLBaseSceneObject <li>26/03/00 - Egg - Added TagFloat to TGLCustomSceneObject, Parent is now longer copied in "Assign" <li>22/03/00 - Egg - TGLStates moved to GLMisc, Removed TGLCamera.FModified stuff, Fixed position bug in TGLScene.SetupLights <li>20/03/00 - Egg - PickObjects now uses "const" and has helper funcs, Dissolved TGLRenderOptions into material and face props (RIP), Joystick stuff moved to a separate unit and component <li>19/03/00 - Egg - Added DoProgress method and event <li>18/03/00 - Egg - Fixed a few "Assign" I forgot to update after adding props, Added bmAdditive blending mode <li>14/03/00 - Egg - Added RegisterGLBaseSceneObjectNameChangeEvent, Added BarycenterXxx and SqrDistance funcs, Fixed (?) AbsolutePosition, Added ResetPerformanceMonitor <li>14/03/00 - Egg - Added SaveToFile, LoadFromFile to GLScene, <li>03/03/00 - Egg - Disabled woTransparent handling <li>12/02/00 - Egg - Added Material Library <li>10/02/00 - Egg - Added Initialize to TGLCoordinates <li>09/02/00 - Egg - All GLScene objects now begin with 'TGL', OpenGL now initialized upon first create of a TGLSceneViewer <li>07/02/00 - Egg - Added ImmaterialSceneObject, Added Camera handling funcs : MoveAroundTarget, AdjustDistanceToTarget, DistanceToTarget, ScreenDeltaToVector, TGLCoordinates.Translate, Deactivated "specials" (ain't working yet), Scaling now a TGLCoordinates <li>06/02/00 - Egg - balanced & secured all context activations, added Assert & try..finally & default galore, OpenGLError renamed to EOpenGLError, ShowErrorXxx funcs renamed to RaiseOpenGLError, fixed CreateSceneObject (was wrongly requiring a TCustomForm), fixed DoJoystickCapture error handling, added TGLUpdateAbleObject <li>05/02/00 - Egg - Javadocisation, fixes and enhancements :<br> TGLSceneViewer.SetContextOptions, TActiveMode -> TJoystickDesignMode, TGLCamera.TargetObject and TGLCamera.AutoLeveling, TGLBaseSceneObject.CoordinateChanged </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Interface IGLInitializable |
Class TGLInitializableObjectList |
Class TGLBaseSceneObject |
Class TGLBaseBehaviour |
Class TGLBehaviour |
Class TGLBehaviours |
Class TGLObjectEffect |
Class TGLObjectPreEffect |
Class TGLObjectPostEffect |
Class TGLObjectAfterEffect |
Class TGLObjectEffects |
Class TGLCustomSceneObject |
Class TGLSceneRootObject |
Class TGLImmaterialSceneObject |
Class TGLCameraInvariantObject |
Class TGLSceneObject |
Class TGLDirectOpenGL |
Class TGLRenderPoint |
Class TGLProxyObject |
Class TGLLightSource |
Class TGLCamera |
Class TGLScene |
Class TGLFogEnvironment |
Class TGLSceneBuffer |
Class TGLNonVisualViewer |
Class TGLMemoryViewer |

Functions and Procedures

procedure RegisterGLBaseSceneObjectNameChangeEvent(notifyEvent: TNotifyEvent);
procedure DeRegisterGLBaseSceneObjectNameChangeEvent(notifyEvent: TNotifyEvent);
procedure RegisterGLBehaviourNameChangeEvent(notifyEvent: TNotifyEvent);
procedure DeRegisterGLBehaviourNameChangeEvent(notifyEvent: TNotifyEvent);
procedure AxesBuildList(var rci: TRenderContextInfo; pattern: Word; AxisLen: Single);
procedure RegisterInfoForm(infoForm: TInvokeInfoForm);
procedure InvokeInfoForm(aSceneBuffer: TGLSceneBuffer; Modal: boolean);
function GetCurrentRenderingObject: TGLBaseSceneObject;

Types

TGLProxyObjectOption = (...);
TGLProxyObjectOptions = set of TGLProxyObjectOption;
TGLCameraInvarianceMode = (...);
TGLSceneViewerMode = (...);
TNormalDirection = (...);
TObjectChange = (...);
TObjectChanges = set of TObjectChange;
TObjectBBChange = (...);
TObjectBBChanges = set of TObjectBBChange;
TSceneOperation = (...);
TContextOption = (...);
TContextOptions = set of TContextOption;
TLimitType = (...);
TGLSceneObjectClass = class of TGLBaseSceneObject;
TGLBehaviourClass = class of TGLBehaviour;
TGLObjectEffectClass = class of TGLObjectEffect;
TGLObjectStyle = (...);
TGLObjectStyles = set of TGLObjectStyle;
TDirectRenderEvent = procedure(Sender: TObject; var rci: TRenderContextInfo) of object;
TGLProxyObjectClass = class of TGLProxyObject;
TLightStyle = (...);
TGLCameraStyle = (...);
TGLCameraKeepFOVMode = (...);
TOnCustomPerspective = procedure(const viewport: TRectangle; width, height: Integer; DPI: Integer; var viewPortRadius: Single) of object;
TFogMode = (...);
TFogDistance = (...);
TGLDepthPrecision = (...);
TGLColorDepth = (...);
TGLShadeModel = (...);
TInvokeInfoForm = procedure(aSceneBuffer: TGLSceneBuffer; Modal: boolean);

Constants

cDefaultProxyOptions = [pooEffects, pooObjects, pooTransformation];
GLSCENE_REVISION = '$Revision: 5600$';
GLSCENE_VERSION = '1.1.0.%s';

Description

Functions and Procedures

procedure RegisterGLBaseSceneObjectNameChangeEvent(notifyEvent: TNotifyEvent);

Register an event handler triggered by any TGLBaseSceneObject Name change.<p> *INCOMPLETE*, currently allows for only 1 (one) event, and is used by GLSceneEdit in the IDE.

procedure DeRegisterGLBaseSceneObjectNameChangeEvent(notifyEvent: TNotifyEvent);

Deregister an event handler triggered by any TGLBaseSceneObject Name change.<p> See RegisterGLBaseSceneObjectNameChangeEvent.

procedure RegisterGLBehaviourNameChangeEvent(notifyEvent: TNotifyEvent);

Register an event handler triggered by any TGLBehaviour Name change.<p> *INCOMPLETE*, currently allows for only 1 (one) event, and is used by FBehavioursEditor in the IDE.

procedure DeRegisterGLBehaviourNameChangeEvent(notifyEvent: TNotifyEvent);

Deregister an event handler triggered by any TGLBaseSceneObject Name change.<p> See RegisterGLBaseSceneObjectNameChangeEvent.

procedure AxesBuildList(var rci: TRenderContextInfo; pattern: Word; AxisLen: Single);

Issues OpenGL calls for drawing X, Y, Z axes in a standard style.

procedure RegisterInfoForm(infoForm: TInvokeInfoForm);

Registers the procedure call used to invoke the info form.

procedure InvokeInfoForm(aSceneBuffer: TGLSceneBuffer; Modal: boolean);
function GetCurrentRenderingObject: TGLBaseSceneObject;

Types

TGLProxyObjectOption = (...);

Defines which features are taken from the master object.

Values
  • pooEffects:
  • pooObjects:
  • pooTransformation:
TGLProxyObjectOptions = set of TGLProxyObjectOption;
TGLCameraInvarianceMode = (...);
Values
  • cimNone:
  • cimPosition:
  • cimOrientation:
TGLSceneViewerMode = (...);
Values
  • svmDisabled:
  • svmDefault:
  • svmNavigation:
  • svmGizmo:
TNormalDirection = (...);
Values
  • ndInside:
  • ndOutside:
TObjectChange = (...);
Values
  • ocTransformation:
  • ocAbsoluteMatrix:
  • ocInvAbsoluteMatrix:
  • ocStructure:
TObjectChanges = set of TObjectChange;
TObjectBBChange = (...);
Values
  • oBBcChild:
  • oBBcStructure:
TObjectBBChanges = set of TObjectBBChange;
TSceneOperation = (...);
Values
  • soAdd:
  • soRemove:
  • soMove:
  • soRename:
  • soSelect:
  • soBeginUpdate:
  • soEndUpdate:
TContextOption = (...);

Options for the rendering context.<p> roSoftwareMode: force software rendering. roDoubleBuffer: enables double-buffering.<br> roRenderToWindows: ignored (legacy).<br> roTwoSideLighting: enables two-side lighting model.<br> roStereo: enables stereo support in the driver (dunno if it works, I don't have a stereo device to test...)<br> roDestinationAlpha: request an Alpha channel for the rendered output<br> roNoColorBuffer: don't request a color buffer (color depth setting ignored)<br> roNoColorBufferClear: do not clear the color buffer automatically, if the whole viewer is fully repainted each frame, this can improve framerate<br> roNoSwapBuffers: don't perform RenderingContext.SwapBuffers after rendering roNoDepthBufferClear: do not clear the depth buffer automatically. Useful for early-z culling.<br> roForwardContext: force OpenGL forward context

Values
  • roSoftwareMode:
  • roDoubleBuffer:
  • roStencilBuffer:
  • roRenderToWindow:
  • roTwoSideLighting:
  • roStereo:
  • roDestinationAlpha:
  • roNoColorBuffer:
  • roNoColorBufferClear:
  • roNoSwapBuffers:
  • roNoDepthBufferClear:
  • roDebugContext:
  • roForwardContext:
  • roOpenGL_ES2_Context:
TContextOptions = set of TContextOption;
TLimitType = (...);
Values
  • limClipPlanes:
  • limEvalOrder:
  • limLights:
  • limListNesting:
  • limModelViewStack:
  • limNameStack:
  • limPixelMapTable:
  • limProjectionStack:
  • limTextureSize:
  • limTextureStack:
  • limViewportDims:
  • limAccumAlphaBits:
  • limAccumBlueBits:
  • limAccumGreenBits:
  • limAccumRedBits:
  • limAlphaBits:
  • limAuxBuffers:
  • limBlueBits:
  • limGreenBits:
  • limRedBits:
  • limIndexBits:
  • limStereo:
  • limDoubleBuffer:
  • limSubpixelBits:
  • limDepthBits:
  • limStencilBits:
  • limNbTextureUnits:
TGLSceneObjectClass = class of TGLBaseSceneObject;
TGLBehaviourClass = class of TGLBehaviour;
TGLObjectEffectClass = class of TGLObjectEffect;
TGLObjectStyle = (...);

Possible styles/options for a GLScene object.<p> Allowed styles are:<ul> <li>osDirectDraw : object shall not make use of compiled call lists, but issue direct calls each time a render should be performed. <li>osIgnoreDepthBuffer : object is rendered with depth test disabled, this is true for its children too. <li>osNoVisibilityCulling : whatever the VisibilityCulling setting, it will be ignored and the object rendered </ul>

Values
  • osDirectDraw:
  • osIgnoreDepthBuffer:
  • osNoVisibilityCulling:
TGLObjectStyles = set of TGLObjectStyle;
TDirectRenderEvent = procedure(Sender: TObject; var rci: TRenderContextInfo) of object;

Event for user-specific rendering in a TGLDirectOpenGL object.

TGLProxyObjectClass = class of TGLProxyObject;
TLightStyle = (...);

Defines the various styles for lightsources.<p> <ul> <li>lsSpot : a spot light, oriented and with a cutoff zone (note that if cutoff is 180, the spot is rendered as an omni source) <li>lsOmni : an omnidirectionnal source, punctual and sending light in all directions uniformously <li>lsParallel : a parallel light, oriented as the light source is (this type of light can help speed up rendering) </ul>

Values
  • lsSpot:
  • lsOmni:
  • lsParallel:
TGLCameraStyle = (...);
Values
  • csPerspective:
  • csOrthogonal:
  • csOrtho2D:
  • csCustom:
  • csInfinitePerspective:
  • csPerspectiveKeepFOV:
TGLCameraKeepFOVMode = (...);
Values
  • ckmHorizontalFOV:
  • ckmVerticalFOV:
TOnCustomPerspective = procedure(const viewport: TRectangle; width, height: Integer; DPI: Integer; var viewPortRadius: Single) of object;
TFogMode = (...);
Values
  • fmLinear:
  • fmExp:
  • fmExp2:
TFogDistance = (...);

Fog distance calculation mode.<p> <ul> <li>fdDefault: let OpenGL use its default formula <li>fdEyeRadial: uses radial "true" distance (best quality) <li>fdEyePlane: uses the distance to the projection plane (same as Z-Buffer, faster) </ul>Requires support of GL_NV_fog_distance extension, otherwise, it is ignored.

Values
  • fdDefault:
  • fdEyeRadial:
  • fdEyePlane:
TGLDepthPrecision = (...);
Values
  • dpDefault:
  • dp16bits:
  • dp24bits:
  • dp32bits:
TGLColorDepth = (...);
Values
  • cdDefault:
  • cd8bits:
  • cd16bits:
  • cd24bits:
  • cdFloat64bits:
  • cdFloat128bits:
TGLShadeModel = (...);
Values
  • smDefault:
  • smSmooth:
  • smFlat:
TInvokeInfoForm = procedure(aSceneBuffer: TGLSceneBuffer; Modal: boolean);

Constants

cDefaultProxyOptions = [pooEffects, pooObjects, pooTransformation];
GLSCENE_REVISION = '$Revision: 5600$';
GLSCENE_VERSION = '1.1.0.%s';
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Interface IGLInitializable

Interface IGLInitializable

Unit

GLScene

Declaration

type IGLInitializable = interface(IInterface)

Description

Interface to objects that need initialization<p>

Hierarchy

  • IInterface
  • IGLInitializable

Overview

Methods

Public procedure InitializeObject(ASender: TObject; const ARci: TRenderContextInfo);

Description

Methods

Public procedure InitializeObject(ASender: TObject; const ARci: TRenderContextInfo);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLInitializableObjectList

Class TGLInitializableObjectList

Unit

GLScene

Declaration

type TGLInitializableObjectList = class(TList)

Description

Just a list of objects that support IGLInitializable.<p>

Hierarchy

  • TList
  • TGLInitializableObjectList

Overview

Methods

Public function Add(const Item: IGLInitializable): Integer;

Properties

Public property Items[const Index: Integer]: IGLInitializable read GetItems write PutItems;

Description

Methods

Public function Add(const Item: IGLInitializable): Integer;

Properties

Public property Items[const Index: Integer]: IGLInitializable read GetItems write PutItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLBaseSceneObject

Class TGLBaseSceneObject

Unit

GLScene

Declaration

type TGLBaseSceneObject = class(TGLCoordinatesUpdateAbleComponent)

Description

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | constructor CreateAsChild(aParentOwner: TGLBaseSceneObject);
Public | destructor Destroy; override;
Public | function AbsoluteLeft: TVector;
Public | function AbsoluteMatrixAsAddress: PMatrix;
Public | function AbsolutePositionAsAddress: PVector;
Public | function AbsoluteRight: TVector;
Public | function AbsoluteToLocal(const v: TAffineVector): TAffineVector; overload;
Public | function AbsoluteToLocal(const v: TVector): TVector; overload;
Public | function AbsoluteXVector: TVector;
Public | function AbsoluteYVector: TVector;
Public | function AbsoluteZVector: TVector;
Public | function AddNewBehaviour(aBehaviour: TGLBehaviourClass): TGLBehaviour;
Public | function AddNewChild(AChild: TGLSceneObjectClass): TGLBaseSceneObject; dynamic;
Public | function AddNewChildFirst(AChild: TGLSceneObjectClass): TGLBaseSceneObject; dynamic;
Public | function AddNewEffect(anEffect: TGLObjectEffectClass): TGLObjectEffect;
Public | function AffineLeftVector: TAffineVector;
Public | function AffineRight: TAffineVector;
Public | function AxisAlignedBoundingBox(const AIncludeChilden: Boolean = True): TAABB;
Public | function AxisAlignedBoundingBoxAbsolute(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): TAABB;
Public | function AxisAlignedBoundingBoxAbsoluteEx: TAABB;
Public | function AxisAlignedBoundingBoxEx: TAABB;
Public | function AxisAlignedBoundingBoxUnscaled(const AIncludeChilden: Boolean = True): TAABB;
Public | function AxisAlignedDimensions: TVector; virtual;
Public | function AxisAlignedDimensionsUnscaled: TVector; virtual;
Public | function BarycenterAbsolutePosition: TVector; virtual;
Public | function BarycenterSqrDistanceTo(const pt: TVector): Single;
Public | function BoundingBox(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;
Public | function BoundingBoxAbsolute(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;
Public | function BoundingBoxIncludingChildrenEx: THmgBoundingBox;
Public | function BoundingBoxOfChildrenEx: THmgBoundingBox;
Public | function BoundingBoxPersonalUnscaledEx: THmgBoundingBox;
Public | function BoundingBoxUnscaled(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;
Public | function BoundingSphereRadius: Single;
Public | function BoundingSphereRadiusUnscaled: Single;
Public | function DistanceTo(anObject: TGLBaseSceneObject): Single; overload;
Public | function DistanceTo(const pt: TAffineVector): Single; overload;
Public | function DistanceTo(const pt: TVector): Single; overload;
Public | function FindChild(const aName: string; ownChildrenOnly: Boolean): TGLBaseSceneObject;
Public | function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; virtual;
Public | function GetHandle(var rci: TRenderContextInfo): Cardinal; virtual;
Public | function GetOrCreateBehaviour(aBehaviour: TGLBehaviourClass): TGLBehaviour;
Public | function GetOrCreateEffect(anEffect: TGLObjectEffectClass): TGLObjectEffect;
Public | function GetParentComponent: TComponent; override;
Public | function HasParent: Boolean; override;
Public | function HasSubChildren: Boolean;
Public | function IndexOfChild(aChild: TGLBaseSceneObject): Integer;
Public | function InvAbsoluteMatrix: TMatrix;
Public | function InvAbsoluteMatrixAsAddress: PMatrix;
Public | function IsUpdating: Boolean;
Public | function LeftVector: TVector;
Public | function ListHandleAllocated: Boolean;
Public | function LocalToAbsolute(const v: TAffineVector): TAffineVector; overload;
Public | function LocalToAbsolute(const v: TVector): TVector; overload;
Public | function MatrixAsAddress: PMatrix;
Public | function PointInObject(const point: TVector): Boolean; virtual;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; virtual;
Public | function Right: TVector;
Public | function SqrDistanceTo(const pt: TAffineVector): Single; overload;
Public | function SqrDistanceTo(const pt: TVector): Single; overload;
Public | function SqrDistanceTo(anObject: TGLBaseSceneObject): Single; overload;
Protected | function Blended: Boolean; virtual;
Protected | function GetAbsoluteAffineDirection: TAffineVector;
Protected | function GetAbsoluteAffinePosition: TAffineVector;
Protected | function GetAbsoluteAffineUp: TAffineVector;
Protected | function GetAbsoluteDirection: TVector;
Protected | function GetAbsolutePosition: TVector;
Protected | function GetAbsoluteUp: TVector;
Protected | function GetPickable: Boolean; virtual;
Protected | function GetVisible: Boolean; virtual;
Public | procedure AddChild(AChild: TGLBaseSceneObject); dynamic;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BeginUpdate; virtual;
Public | procedure BuildList(var rci: TRenderContextInfo); virtual;
Public | procedure ClearStructureChanged;
Public | procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;
Public | procedure DeleteChildren; dynamic;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); virtual;
Public | procedure EndUpdate; virtual;
Public | procedure ExchangeChildren(anIndex1, anIndex2: Integer);
Public | procedure ExchangeChildrenSafe(anIndex1, anIndex2: Integer);
Public | procedure ForceLocalMatrix(const aMatrix: TMatrix);
Public | procedure Insert(AIndex: Integer; AChild: TGLBaseSceneObject); dynamic;
Public | procedure Lift(ADistance: Single);
Public | procedure Move(ADistance: Single);
Public | procedure MoveChildDown(anIndex: Integer);
Public | procedure MoveChildFirst(anIndex: Integer);
Public | procedure MoveChildLast(anIndex: Integer);
Public | procedure MoveChildUp(anIndex: Integer);
Public | procedure MoveDown;
Public | procedure MoveFirst;
Public | procedure MoveLast;
Public | procedure MoveObjectAllAround(anObject: TGLBaseSceneObject; pitchDelta, turnDelta: Single);
Public | procedure MoveObjectAround(anObject: TGLBaseSceneObject; pitchDelta, turnDelta: Single);
Public | procedure MoveTo(newParent: TGLBaseSceneObject); dynamic;
Public | procedure MoveUp;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure Pitch(angle: Single);
Public | procedure PointTo(const AAbsolutePosition, AUpVector: TVector); overload;
Public | procedure PointTo(const ATargetObject: TGLBaseSceneObject; const AUpVector: TVector); overload;
Public | procedure Remove(aChild: TGLBaseSceneObject; keepChildren: Boolean); dynamic;
Public | procedure Render(var ARci: TRenderContextInfo);
Public | procedure RenderChildren(firstChildIndex, lastChildIndex: Integer; var rci: TRenderContextInfo); virtual;
Public | procedure ResetAndPitchTurnRoll(const degX, degY, degZ: Single);
Public | procedure ResetRotations;
Public | procedure Roll(angle: Single);
Public | procedure RotateAbsolute(const rx, ry, rz: Single); overload;
Public | procedure RotateAbsolute(const axis: TAffineVector; angle: Single); overload;
Public | procedure Slide(ADistance: Single);
Public | procedure StructureChanged; dynamic;
Public | procedure TransformationChanged;
Public | procedure Translate(tx, ty, tz: Single);
Public | procedure Turn(angle: Single);
Protected | procedure CalculateBoundingBoxPersonalUnscaled(var ANewBoundingBox: THmgBoundingBox); virtual;
Protected | procedure DefineProperties(Filer: TFiler); override;
Protected | procedure DeleteChildCameras;
Protected | procedure DestroyHandle; dynamic;
Protected | procedure DestroyHandles;
Protected | procedure DoOnAddedToParent; virtual;
Protected | procedure DrawAxes(var rci: TRenderContextInfo; pattern: Word);
Protected | procedure GetChildren(AProc: TGetChildProc; Root: TComponent); override;
Protected | procedure Loaded; override;
Protected | procedure ReadBehaviours(stream: TStream);
Protected | procedure ReadEffects(stream: TStream);
Protected | procedure ReadRotations(stream: TStream);
Protected | procedure RebuildMatrix;
Protected | procedure RecTransformationChanged;
Protected | procedure SetAbsoluteAffineDirection(const v: TAffineVector);
Protected | procedure SetAbsoluteAffinePosition(const Value: TAffineVector);
Protected | procedure SetAbsoluteAffineUp(const v: TAffineVector);
Protected | procedure SetAbsoluteDirection(const v: TVector);
Protected | procedure SetAbsolutePosition(const v: TVector);
Protected | procedure SetAbsoluteUp(const v: TVector);
Protected | procedure SetName(const NewName: TComponentName); override;
Protected | procedure SetParentComponent(Value: TComponent); override;
Protected | procedure SetPickable(aValue: Boolean); virtual;
Protected | procedure SetScene(const Value: TGLScene); virtual;
Protected | procedure SetVisible(aValue: Boolean); virtual;
Protected | procedure WriteBehaviours(stream: TStream);
Protected | procedure WriteEffects(stream: TStream);
Protected | procedure WriteRotations(stream: TStream);

Properties

Public | property AbsoluteAffineDirection: TAffineVector read GetAbsoluteAffineDirection write SetAbsoluteAffineDirection;
Public | property AbsoluteAffinePosition: TAffineVector read GetAbsoluteAffinePosition write SetAbsoluteAffinePosition;
Public | property AbsoluteAffineScale: TAffineVector read GetAbsoluteAffineScale write SetAbsoluteAffineScale;
Public | property AbsoluteAffineUp: TAffineVector read GetAbsoluteAffineUp write SetAbsoluteAffineUp;
Public | property AbsoluteDirection: TVector read GetAbsoluteDirection write SetAbsoluteDirection;
Public | property AbsoluteMatrix: TMatrix read GetAbsoluteMatrix write SetAbsoluteMatrix;
Public | property AbsolutePosition: TVector read GetAbsolutePosition write SetAbsolutePosition;
Public | property AbsoluteScale: TVector read GetAbsoluteScale write SetAbsoluteScale;
Public | property AbsoluteUp: TVector read GetAbsoluteUp write SetAbsoluteUp;
Public | property BBChanges: TObjectBBChanges read fBBChanges write SetBBChanges;
Public | property Behaviours: TGLBehaviours read GetBehaviours write SetBehaviours stored False;
Public | property Changes: TObjectChanges read FChanges;
Public | property Children[Index: Integer]: TGLBaseSceneObject read Get;
Public | property Count: Integer read GetCount;
Public | property DirectAbsoluteMatrix: PMatrix read FAbsoluteMatrix;
Public | property Direction: TGLCoordinates read FDirection write SetDirection;
Public | property Effects: TGLObjectEffects read GetEffects write SetEffects stored False;
Public | property Index: Integer read GetIndex write SetIndex;
Public | property LocalMatrix: PMatrix read FLocalMatrix;
Public | property Matrix: TMatrix read GetMatrix write SetMatrix;
Public | property ObjectsSorting: TGLObjectsSorting read FObjectsSorting write SetObjectsSorting default osInherited;
Public | property ObjectStyle: TGLObjectStyles read FObjectStyle write FObjectStyle;
Public | property OnAddedToParent: TNotifyEvent read FOnAddedToParent write FOnAddedToParent;
Public | property OnPicked: TNotifyEvent read FOnPicked write FOnPicked;
Public | property OnProgress: TGLProgressEvent read FOnProgress write FOnProgress;
Public | property Parent: TGLBaseSceneObject read FParent write SetParent;
Public | property Pickable: Boolean read FPickable write SetPickable default True;
Public | property PitchAngle: Single read GetPitchAngle write SetPitchAngle;
Public | property Position: TGLCoordinates read FPosition write SetPosition;
Public | property RollAngle: Single read GetRollAngle write SetRollAngle;
Public | property Rotation: TGLCoordinates read FRotation write SetRotation;
Public | property Scale: TGLCoordinates read FScaling write SetScaling;
Public | property Scene: TGLScene read FScene;
Public | property ShowAxes: Boolean read FShowAxes write SetShowAxes default False;
Published | property TagFloat: Single read FTagFloat write FTagFloat;
Public | property TagObject: TObject read FTagObject write FTagObject;
Public | property TurnAngle: Single read GetTurnAngle write SetTurnAngle;
Public | property Up: TGLCoordinates read FUp write SetUp;
Public | property VisibilityCulling: TGLVisibilityCulling read FVisibilityCulling write SetVisibilityCulling default vcInherited;
Public | property Visible: Boolean read FVisible write SetVisible default True;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public constructor CreateAsChild(aParentOwner: TGLBaseSceneObject);
Public destructor Destroy; override;
Public function AbsoluteLeft: TVector;

Calculate the left vector in absolute coordinates.

Public function AbsoluteMatrixAsAddress: PMatrix;

See AbsoluteMatrix.

Public function AbsolutePositionAsAddress: PVector;
Public function AbsoluteRight: TVector;

Calculate the right vector in absolute coordinates.

Public function AbsoluteToLocal(const v: TAffineVector): TAffineVector; overload;

Converts a vector from absolute coordinates to local coordinates.<p>

Public function AbsoluteToLocal(const v: TVector): TVector; overload;

Converts a vector/point from absolute coordinates to local coordinates.<p>

Public function AbsoluteXVector: TVector;

Returns the Absolute X Vector expressed in local coordinates.

Public function AbsoluteYVector: TVector;

Returns the Absolute Y Vector expressed in local coordinates.

Public function AbsoluteZVector: TVector;

Returns the Absolute Z Vector expressed in local coordinates.

Public function AddNewBehaviour(aBehaviour: TGLBehaviourClass): TGLBehaviour;
Public function AddNewChild(AChild: TGLSceneObjectClass): TGLBaseSceneObject; dynamic;

Create a new scene object and add it to this object as new child

Public function AddNewChildFirst(AChild: TGLSceneObjectClass): TGLBaseSceneObject; dynamic;

Create a new scene object and add it to this object as first child

Public function AddNewEffect(anEffect: TGLObjectEffectClass): TGLObjectEffect;
Public function AffineLeftVector: TAffineVector;

Returns the Left vector (based on Up and Direction)

Public function AffineRight: TAffineVector;

Returns the Right vector (based on Up and Direction)

Public function AxisAlignedBoundingBox(const AIncludeChilden: Boolean = True): TAABB;

Calculates and return the AABB for the object.<p> The AABB is currently calculated from the BB. There is <b>no</b> caching scheme for them.

Public function AxisAlignedBoundingBoxAbsolute(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): TAABB;
Public function AxisAlignedBoundingBoxAbsoluteEx: TAABB;
Public function AxisAlignedBoundingBoxEx: TAABB;

Advanced AABB functions that use a caching scheme. Also they include children and use BaryCenter.

Public function AxisAlignedBoundingBoxUnscaled(const AIncludeChilden: Boolean = True): TAABB;
Public function AxisAlignedDimensions: TVector; virtual;

Shall returns the object's axis aligned extensions.<p> The dimensions are measured from object center and are expressed <i>with</i> scale accounted for, in the object's coordinates (not in absolute coordinates).<p> Default value is half the object's Scale.<br>

Public function AxisAlignedDimensionsUnscaled: TVector; virtual;
Public function BarycenterAbsolutePosition: TVector; virtual;

Calculates the object's barycenter in absolute coordinates.<p> Default behaviour is to consider Barycenter=AbsolutePosition (whatever the number of children).<br> SubClasses where AbsolutePosition is not the barycenter should override this method as it is used for distance calculation, during rendering for instance, and may lead to visual inconsistencies.

Public function BarycenterSqrDistanceTo(const pt: TVector): Single;

Calculates the object's barycenter distance to a point.<p>

Public function BoundingBox(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;

Calculates and return the Bounding Box for the object.<p> The BB is calculated <b>each</b> time this method is invoked, based on the AxisAlignedDimensions of the object and that of its children. There is <b>no</b> caching scheme for them.

Public function BoundingBoxAbsolute(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;
Public function BoundingBoxIncludingChildrenEx: THmgBoundingBox;
Public function BoundingBoxOfChildrenEx: THmgBoundingBox;
Public function BoundingBoxPersonalUnscaledEx: THmgBoundingBox;

Advanced BB functions that use a caching scheme. Also they include children and use BaryCenter.

Public function BoundingBoxUnscaled(const AIncludeChilden: Boolean = True; const AUseBaryCenter: Boolean = False): THmgBoundingBox;
Public function BoundingSphereRadius: Single;

Max distance of corners of the BoundingBox.

Public function BoundingSphereRadiusUnscaled: Single;
Public function DistanceTo(anObject: TGLBaseSceneObject): Single; overload;

Computes the object's distance to a point/object.<p> Only objects AbsolutePositions are considered.

Public function DistanceTo(const pt: TAffineVector): Single; overload;
Public function DistanceTo(const pt: TVector): Single; overload;
Public function FindChild(const aName: string; ownChildrenOnly: Boolean): TGLBaseSceneObject;
Public function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; virtual;

Request to generate silhouette outlines.<p> Default implementation assumes the objects is a sphere of AxisAlignedDimensionUnscaled size. Subclasses may choose to return nil instead, which will be understood as an empty silhouette.

Public function GetHandle(var rci: TRenderContextInfo): Cardinal; virtual;

Returns the handle to the object's build list.<p> Use with caution! Some objects don't support buildlists!

Public function GetOrCreateBehaviour(aBehaviour: TGLBehaviourClass): TGLBehaviour;
Public function GetOrCreateEffect(anEffect: TGLObjectEffectClass): TGLObjectEffect;
Public function GetParentComponent: TComponent; override;
Public function HasParent: Boolean; override;
Public function HasSubChildren: Boolean;
Public function IndexOfChild(aChild: TGLBaseSceneObject): Integer;
Public function InvAbsoluteMatrix: TMatrix;

Calculates the object's absolute inverse matrix.<p> Multiplying an absolute coordinate with this matrix gives a local coordinate.<p> The current implem uses transposition(AbsoluteMatrix), which is true unless you're using some scaling...

Public function InvAbsoluteMatrixAsAddress: PMatrix;

See InvAbsoluteMatrix.

Public function IsUpdating: Boolean;
Public function LeftVector: TVector;

Returns the Left vector (based on Up and Direction)

Public function ListHandleAllocated: Boolean;
Public function LocalToAbsolute(const v: TAffineVector): TAffineVector; overload;

Converts a vector from local coordinates to absolute coordinates.<p>

Public function LocalToAbsolute(const v: TVector): TVector; overload;

Converts a vector/point from local coordinates to absolute coordinates.<p>

Public function MatrixAsAddress: PMatrix;

See Matrix.

Public function PointInObject(const point: TVector): Boolean; virtual;

Indicates if a point is within an object.<p> Given coordinate is an absolute coordinate.<br> Linear or surfacic objects shall always return False.<p> Default value is based on AxisAlignedDimension and a cube bounding.

Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; virtual;

Request to determine an intersection with a casted ray.<p> Given coordinates & vector are in absolute coordinates, rayVector must be normalized.<br> rayStart may be a point inside the object, allowing retrieval of the multiple intersects of the ray.<p> When intersectXXX parameters are nil (default) implementation should take advantage of this to optimize calculus, if not, and an intersect is found, non nil parameters should be defined.<p> The intersectNormal needs NOT be normalized by the implementations.<p> Default value is based on bounding sphere.

Public function Right: TVector;

Returns the Right vector (based on Up and Direction)

Public function SqrDistanceTo(const pt: TAffineVector): Single; overload;
Public function SqrDistanceTo(const pt: TVector): Single; overload;
Public function SqrDistanceTo(anObject: TGLBaseSceneObject): Single; overload;

Calculates the object's square distance to a point/object.<p> pt is assumed to be in absolute coordinates, AbsolutePosition is considered as being the object position.

Protected function Blended: Boolean; virtual;

Should the object be considered as blended for sorting purposes?

Protected function GetAbsoluteAffineDirection: TAffineVector;
Protected function GetAbsoluteAffinePosition: TAffineVector;
Protected function GetAbsoluteAffineUp: TAffineVector;
Protected function GetAbsoluteDirection: TVector;
Protected function GetAbsolutePosition: TVector;
Protected function GetAbsoluteUp: TVector;
Protected function GetPickable: Boolean; virtual;
Protected function GetVisible: Boolean; virtual;
Public procedure AddChild(AChild: TGLBaseSceneObject); dynamic;
Public procedure Assign(Source: TPersistent); override;
Public procedure BeginUpdate; virtual;
Public procedure BuildList(var rci: TRenderContextInfo); virtual;

Make object-specific geometry description here.<p> Subclasses should MAINTAIN OpenGL states (restore the states if they were altered).

Public procedure ClearStructureChanged;
Public procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;

Recalculate an orthonormal system

Public procedure DeleteChildren; dynamic;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); virtual;
Public procedure EndUpdate; virtual;
Public procedure ExchangeChildren(anIndex1, anIndex2: Integer);

The "regular" version of this procedure does not perform any checks and calls FChildren.Exchange directly. User should/can perform range checks manualy.

Public procedure ExchangeChildrenSafe(anIndex1, anIndex2: Integer);

The "safe" version of this procedure checks if indexes are inside the list. If not, no exception if raised.

Public procedure ForceLocalMatrix(const aMatrix: TMatrix);

Forces the local matrix to the specified value.<p> AbsoluteMatrix, InverseMatrix, etc. will honour that change, but may become invalid if the specified matrix isn't orthonormal (can be used for specific rendering or projection effects).<br> The local matrix will be reset by the next TransformationChanged, position or attitude change.

Public procedure Insert(AIndex: Integer; AChild: TGLBaseSceneObject); dynamic;
Public procedure Lift(ADistance: Single);

Moves the object along the Up vector (move up/down)

Public procedure Move(ADistance: Single);

Moves the object along the direction vector

Public procedure MoveChildDown(anIndex: Integer);
Public procedure MoveChildFirst(anIndex: Integer);
Public procedure MoveChildLast(anIndex: Integer);
Public procedure MoveChildUp(anIndex: Integer);

These procedures are safe.

Public procedure MoveDown;
Public procedure MoveFirst;
Public procedure MoveLast;
Public procedure MoveObjectAllAround(anObject: TGLBaseSceneObject; pitchDelta, turnDelta: Single);
Public procedure MoveObjectAround(anObject: TGLBaseSceneObject; pitchDelta, turnDelta: Single);
Public procedure MoveTo(newParent: TGLBaseSceneObject); dynamic;
Public procedure MoveUp;
Public procedure NotifyChange(Sender: TObject); override;
Public procedure Pitch(angle: Single);
Public procedure PointTo(const AAbsolutePosition, AUpVector: TVector); overload;

Orients the object toward a target absolute position

Public procedure PointTo(const ATargetObject: TGLBaseSceneObject; const AUpVector: TVector); overload;

Orients the object toward a target object

Public procedure Remove(aChild: TGLBaseSceneObject; keepChildren: Boolean); dynamic;

Takes a scene object out of the child list, but doesn't destroy it.<p> If 'KeepChildren' is true its children will be kept as new children in this scene object.

Public procedure Render(var ARci: TRenderContextInfo);
Public procedure RenderChildren(firstChildIndex, lastChildIndex: Integer; var rci: TRenderContextInfo); virtual;
Public procedure ResetAndPitchTurnRoll(const degX, degY, degZ: Single);

Reset rotations and applies them back in the specified order.

Public procedure ResetRotations;

Sets all rotations to zero and restores default Direction/Up.<p> Using this function then applying roll/pitch/turn in the order that suits you, you can give an "absolute" meaning to rotation angles (they are still applied locally though).<br> Scale and Position are not affected.

Public procedure Roll(angle: Single);
Public procedure RotateAbsolute(const rx, ry, rz: Single); overload;

Applies rotations around absolute X, Y and Z axis.<p>

Public procedure RotateAbsolute(const axis: TAffineVector; angle: Single); overload;

Applies rotations around the absolute given vector (angle in degrees).<p>

Public procedure Slide(ADistance: Single);

Moves camera along the right vector (move left and right)

Public procedure StructureChanged; dynamic;
Public procedure TransformationChanged;
Public procedure Translate(tx, ty, tz: Single);

Translates the object

Public procedure Turn(angle: Single);
Protected procedure CalculateBoundingBoxPersonalUnscaled(var ANewBoundingBox: THmgBoundingBox); virtual;

Used to re-calculate BoundingBoxes every time we need it. GetLocalUnscaleBB() must return the local BB, not the axis-aligned one.

By default it is calculated from AxisAlignedBoundingBoxUnscaled and BarycenterAbsolutePosition, but for most objects there is a more efficient method, that's why it is virtual.

Protected procedure DefineProperties(Filer: TFiler); override;
Protected procedure DeleteChildCameras;
Protected procedure DestroyHandle; dynamic;
Protected procedure DestroyHandles;
Protected procedure DoOnAddedToParent; virtual;
Protected procedure DrawAxes(var rci: TRenderContextInfo; pattern: Word);
Protected procedure GetChildren(AProc: TGetChildProc; Root: TComponent); override;
Protected procedure Loaded; override;
Protected procedure ReadBehaviours(stream: TStream);
Protected procedure ReadEffects(stream: TStream);
Protected procedure ReadRotations(stream: TStream);
Protected procedure RebuildMatrix;
Protected procedure RecTransformationChanged;
Protected procedure SetAbsoluteAffineDirection(const v: TAffineVector);
Protected procedure SetAbsoluteAffinePosition(const Value: TAffineVector);
Protected procedure SetAbsoluteAffineUp(const v: TAffineVector);
Protected procedure SetAbsoluteDirection(const v: TVector);
Protected procedure SetAbsolutePosition(const v: TVector);
Protected procedure SetAbsoluteUp(const v: TVector);
Protected procedure SetName(const NewName: TComponentName); override;
Protected procedure SetParentComponent(Value: TComponent); override;
Protected procedure SetPickable(aValue: Boolean); virtual;
Protected procedure SetScene(const Value: TGLScene); virtual;
Protected procedure SetVisible(aValue: Boolean); virtual;
Protected procedure WriteBehaviours(stream: TStream);
Protected procedure WriteEffects(stream: TStream);
Protected procedure WriteRotations(stream: TStream);

Properties

Public property AbsoluteAffineDirection: TAffineVector read GetAbsoluteAffineDirection write SetAbsoluteAffineDirection;
Public property AbsoluteAffinePosition: TAffineVector read GetAbsoluteAffinePosition write SetAbsoluteAffinePosition;
Public property AbsoluteAffineScale: TAffineVector read GetAbsoluteAffineScale write SetAbsoluteAffineScale;
Public property AbsoluteAffineUp: TAffineVector read GetAbsoluteAffineUp write SetAbsoluteAffineUp;
Public property AbsoluteDirection: TVector read GetAbsoluteDirection write SetAbsoluteDirection;

Direction vector in absolute coordinates.

Public property AbsoluteMatrix: TMatrix read GetAbsoluteMatrix write SetAbsoluteMatrix;

The object's absolute matrix by composing all local matrices.<p> Multiplying a local coordinate with this matrix gives an absolute coordinate.

Public property AbsolutePosition: TVector read GetAbsolutePosition write SetAbsolutePosition;

Computes and allows to set the object's absolute coordinates.<p>

Public property AbsoluteScale: TVector read GetAbsoluteScale write SetAbsoluteScale;

Scale vector in absolute coordinates. Warning: SetAbsoluteScale() does not work correctly at the moment.

Public property AbsoluteUp: TVector read GetAbsoluteUp write SetAbsoluteUp;

Up vector in absolute coordinates.

Public property BBChanges: TObjectBBChanges read fBBChanges write SetBBChanges;
Public property Behaviours: TGLBehaviours read GetBehaviours write SetBehaviours stored False;
Public property Changes: TObjectChanges read FChanges;
Public property Children[Index: Integer]: TGLBaseSceneObject read Get;
Public property Count: Integer read GetCount;
Public property DirectAbsoluteMatrix: PMatrix read FAbsoluteMatrix;

Holds the absolute transformation matrix.<p> If you're not *sure* the absolute matrix is up-to-date, use the AbsoluteMatrix property, this one may be nil...

Public property Direction: TGLCoordinates read FDirection write SetDirection;
Public property Effects: TGLObjectEffects read GetEffects write SetEffects stored False;
Public property Index: Integer read GetIndex write SetIndex;
Public property LocalMatrix: PMatrix read FLocalMatrix;

Holds the local transformation (relative to parent).<p> If you're not *sure* the local matrix is up-to-date, use Matrix property.

Public property Matrix: TMatrix read GetMatrix write SetMatrix;

The local transformation (relative to parent).<p> If you're *sure* the local matrix is up-to-date, you may use LocalMatrix for quicker access.

Public property ObjectsSorting: TGLObjectsSorting read FObjectsSorting write SetObjectsSorting default osInherited;
Public property ObjectStyle: TGLObjectStyles read FObjectStyle write FObjectStyle;

Controls and adjusts internal optimizations based on object's style.<p> Advanced user only.

Public property OnAddedToParent: TNotifyEvent read FOnAddedToParent write FOnAddedToParent;
Public property OnPicked: TNotifyEvent read FOnPicked write FOnPicked;
Public property OnProgress: TGLProgressEvent read FOnProgress write FOnProgress;
Public property Parent: TGLBaseSceneObject read FParent write SetParent;
Public property Pickable: Boolean read FPickable write SetPickable default True;
Public property PitchAngle: Single read GetPitchAngle write SetPitchAngle;
Public property Position: TGLCoordinates read FPosition write SetPosition;
Public property RollAngle: Single read GetRollAngle write SetRollAngle;
Public property Rotation: TGLCoordinates read FRotation write SetRotation;
Public property Scale: TGLCoordinates read FScaling write SetScaling;
Public property Scene: TGLScene read FScene;
Public property ShowAxes: Boolean read FShowAxes write SetShowAxes default False;
Published property TagFloat: Single read FTagFloat write FTagFloat;
Public property TagObject: TObject read FTagObject write FTagObject;
Public property TurnAngle: Single read GetTurnAngle write SetTurnAngle;
Public property Up: TGLCoordinates read FUp write SetUp;
Public property VisibilityCulling: TGLVisibilityCulling read FVisibilityCulling write SetVisibilityCulling default vcInherited;
Public property Visible: Boolean read FVisible write SetVisible default True;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLBaseBehaviour

Class TGLBaseBehaviour

Unit

GLScene

Declaration

type TGLBaseBehaviour = class(TXCollectionItem)

Description

Base class for implementing behaviours in TGLScene.<p> Behaviours are regrouped in a collection attached to a TGLBaseSceneObject, and are part of the "Progress" chain of events. Behaviours allows clean application of time-based alterations to objects (movements, shape or texture changes...).<p> Since behaviours are implemented as classes, there are basicly two kinds of strategies for subclasses :<ul> <li>stand-alone : the subclass does it all, and holds all necessary data (covers animation, inertia etc.) <li>proxy : the subclass is an interface to and external, shared operator (like gravity, force-field effects etc.) </ul><br> Some behaviours may be cooperative (like force-fields affects inertia) or unique (e.g. only one inertia behaviour per object).<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function </ul>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Protected | function OwnerBaseSceneObject: TGLBaseSceneObject;
Public | procedure DoProgress(const progressTime: TProgressTimes); virtual;
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure SetName(const val: string); override;
Protected | procedure WriteToFiler(writer: TWriter); override;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;
Public destructor Destroy; override;
Protected function OwnerBaseSceneObject: TGLBaseSceneObject;

Returns the TGLBaseSceneObject on which the behaviour should be applied.<p> Does NOT check for nil owners.

Public procedure DoProgress(const progressTime: TProgressTimes); virtual;
Protected procedure ReadFromFiler(reader: TReader); override;

Override this function to read subclass data.

Protected procedure SetName(const val: string); override;
Protected procedure WriteToFiler(writer: TWriter); override;

Override this function to write subclass data.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLBehaviour

Class TGLBehaviour

Unit

GLScene

Declaration

type TGLBehaviour = class(TGLBaseBehaviour)

Description

Ancestor for non-rendering behaviours.<p> This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLObjectEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLBehaviours

Class TGLBehaviours

Unit

GLScene

Declaration

type TGLBehaviours = class(TXCollection)

Description

Holds a list of TGLBehaviour objects.<p> This object expects itself to be owned by a TGLBaseSceneObject.<p> As a TXCollection (and contrary to a TCollection), this list can contain objects of varying class, the only constraint being that they should all be TGLBehaviour subclasses.

Hierarchy

  • TPersistent
  • TXCollection
  • TGLBehaviours

Overview

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | function CanAdd(aClass: TXCollectionItemClass): Boolean; override;
Public | function GetNamePath: string; override;
Public | class function ItemsClass: TXCollectionItemClass; override;
Protected | function GetBehaviour(index: Integer): TGLBehaviour;
Public | procedure DoProgress(const progressTimes: TProgressTimes);

Properties

Public property Behaviour[index: Integer]: TGLBehaviour read GetBehaviour;

Description

Methods

Public constructor Create(aOwner: TPersistent); override;
Public function CanAdd(aClass: TXCollectionItemClass): Boolean; override;
Public function GetNamePath: string; override;
Public class function ItemsClass: TXCollectionItemClass; override;
Protected function GetBehaviour(index: Integer): TGLBehaviour;
Public procedure DoProgress(const progressTimes: TProgressTimes);

Properties

Public property Behaviour[index: Integer]: TGLBehaviour read GetBehaviour;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLObjectEffect

Class TGLObjectEffect

Unit

GLScene

Declaration

type TGLObjectEffect = class(TGLBaseBehaviour)

Description

no description available, TGLBaseBehaviour description follows

Base class for implementing behaviours in TGLScene.<p> Behaviours are regrouped in a collection attached to a TGLBaseSceneObject, and are part of the "Progress" chain of events. Behaviours allows clean application of time-based alterations to objects (movements, shape or texture changes...).<p> Since behaviours are implemented as classes, there are basicly two kinds of strategies for subclasses :<ul> <li>stand-alone : the subclass does it all, and holds all necessary data (covers animation, inertia etc.) <li>proxy : the subclass is an interface to and external, shared operator (like gravity, force-field effects etc.) </ul><br> Some behaviours may be cooperative (like force-fields affects inertia) or unique (e.g. only one inertia behaviour per object).<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function </ul>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLObjectEffect

Overview

Methods

Public | procedure Render(var rci: TRenderContextInfo); virtual;
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure WriteToFiler(writer: TWriter); override;

Description

Methods

Public procedure Render(var rci: TRenderContextInfo); virtual;
Protected procedure ReadFromFiler(reader: TReader); override;

Override this function to read subclass data.

Protected procedure WriteToFiler(writer: TWriter); override;

Override this function to write subclass data.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLObjectPreEffect

Class TGLObjectPreEffect

Unit

GLScene

Declaration

type TGLObjectPreEffect = class(TGLObjectEffect)

Description

An object effect that gets rendered before owner object's render.<p> The current OpenGL matrices and material are that of the owner object.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLObjectEffect
  • TGLObjectPreEffect
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLObjectPostEffect

Class TGLObjectPostEffect

Unit

GLScene

Declaration

type TGLObjectPostEffect = class(TGLObjectEffect)

Description

An object effect that gets rendered after owner object's render.<p> The current OpenGL matrices and material are that of the owner object.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLObjectEffect
  • TGLObjectPostEffect
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLObjectAfterEffect

Class TGLObjectAfterEffect

Unit

GLScene

Declaration

type TGLObjectAfterEffect = class(TGLObjectEffect)

Description

An object effect that gets rendered at scene's end.<p> No particular OpenGL matrices or material should be assumed.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLObjectEffect
  • TGLObjectAfterEffect
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLObjectEffects

Class TGLObjectEffects

Unit

GLScene

Declaration

type TGLObjectEffects = class(TXCollection)

Description

Holds a list of object effects.<p> This object expects itself to be owned by a TGLBaseSceneObject.<p>

Hierarchy

  • TPersistent
  • TXCollection
  • TGLObjectEffects

Overview

Methods

Public | constructor Create(aOwner: TPersistent); override;
Public | function CanAdd(aClass: TXCollectionItemClass): Boolean; override;
Public | function GetNamePath: string; override;
Public | class function ItemsClass: TXCollectionItemClass; override;
Protected | function GetEffect(index: Integer): TGLObjectEffect;
Public | procedure DoProgress(const progressTime: TProgressTimes);
Public | procedure RenderPostEffects(var rci: TRenderContextInfo);
Public | procedure RenderPreEffects(var rci: TRenderContextInfo);

Properties

Public property ObjectEffect[index: Integer]: TGLObjectEffect read GetEffect;

Description

Methods

Public constructor Create(aOwner: TPersistent); override;
Public function CanAdd(aClass: TXCollectionItemClass): Boolean; override;
Public function GetNamePath: string; override;
Public class function ItemsClass: TXCollectionItemClass; override;
Protected function GetEffect(index: Integer): TGLObjectEffect;
Public procedure DoProgress(const progressTime: TProgressTimes);
Public procedure RenderPostEffects(var rci: TRenderContextInfo);

Also take care of registering after effects with the GLSceneViewer.

Public procedure RenderPreEffects(var rci: TRenderContextInfo);

Properties

Public property ObjectEffect[index: Integer]: TGLObjectEffect read GetEffect;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLCustomSceneObject

Class TGLCustomSceneObject

Unit

GLScene

Declaration

type TGLCustomSceneObject = class(TGLBaseSceneObject)

Description

Extended base scene object class with a material property.<p> The material allows defining a color and texture for the object, see TGLMaterial.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function Blended: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected | procedure DestroyHandle; override;
Protected | procedure Loaded; override;
Protected | procedure SetGLMaterial(AValue: TGLMaterial);

Properties

Public | property Hint: string read FHint write FHint;
Public | property Material: TGLMaterial read FMaterial write SeTGLMaterial;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function Blended: Boolean; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected procedure DestroyHandle; override;
Protected procedure Loaded; override;
Protected procedure SetGLMaterial(AValue: TGLMaterial);

Properties

Public property Hint: string read FHint write FHint;
Public property Material: TGLMaterial read FMaterial write SeTGLMaterial;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLSceneRootObject

Class TGLSceneRootObject

Unit

GLScene

Declaration

type TGLSceneRootObject = class(TGLBaseSceneObject)

Description

This class shall be used only as a hierarchy root.<p> It exists only as a container and shall never be rotated/scaled etc. as the class type is used in parenting optimizations.<p> Shall never implement or add any functionality, the "Create" override only take cares of disabling the build list.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLSceneRootObject

Overview

Methods

Public constructor Create(AOwner: TComponent); override;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLImmaterialSceneObject

Class TGLImmaterialSceneObject

Unit

GLScene

Declaration

type TGLImmaterialSceneObject = class(TGLCustomSceneObject)

Description

Base class for objects that do not have a published "material".<p> Note that the material is available in public properties, but isn't applied automatically before invoking BuildList.<br> Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject

Overview

Methods

Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published | property Behaviours;
Published | property Direction;
Published | property Effects;
Published | property Hint;
Published | property ObjectsSorting;
Published | property OnPicked;
Published | property OnProgress;
Published | property Pickable;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property VisibilityCulling;
Published | property Visible;

Description

Methods

Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Properties

Published property Behaviours;
Published property Direction;
Published property Effects;
Published property Hint;
Published property ObjectsSorting;
Published property OnPicked;
Published property OnProgress;
Published property Pickable;
Published property PitchAngle;
Published property Position;
Published property RollAngle;
Published property Scale;
Published property ShowAxes;
Published property TurnAngle;
Published property Up;
Published property VisibilityCulling;
Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLCameraInvariantObject

Class TGLCameraInvariantObject

Unit

GLScene

Declaration

type TGLCameraInvariantObject = class(TGLImmaterialSceneObject)

Description

Base class for camera invariant objects.<p> Camera invariant objects bypass camera settings, such as camera position (object is always centered on camera) or camera orientation (object always has same orientation as camera).

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLCameraInvariantObject

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected | procedure SetCamInvarianceMode(const val: TGLCameraInvarianceMode);

Properties

Protected property CamInvarianceMode: TGLCameraInvarianceMode read FCamInvarianceMode write SetCamInvarianceMode;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected procedure SetCamInvarianceMode(const val: TGLCameraInvarianceMode);

Properties

Protected property CamInvarianceMode: TGLCameraInvarianceMode read FCamInvarianceMode write SetCamInvarianceMode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLSceneObject

Class TGLSceneObject

Unit

GLScene

Declaration

type TGLSceneObject = class(TGLCustomSceneObject)

Description

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject

Overview

Properties

Published | property Behaviours;
Published | property Direction;
Published | property Effects;
Published | property Hint;
Published | property Material;
Published | property ObjectsSorting;
Published | property OnPicked;
Published | property OnProgress;
Published | property Pickable;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property VisibilityCulling;
Published | property Visible;

Description

Properties

Published property Behaviours;
Published property Direction;
Published property Effects;
Published property Hint;
Published property Material;
Published property ObjectsSorting;
Published property OnPicked;
Published property OnProgress;
Published property Pickable;
Published property PitchAngle;
Published property Position;
Published property RollAngle;
Published property Scale;
Published property ShowAxes;
Published property TurnAngle;
Published property Up;
Published property VisibilityCulling;
Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLDirectOpenGL

Class TGLDirectOpenGL

Unit

GLScene

Declaration

type TGLDirectOpenGL = class(TGLImmaterialSceneObject)

Description

Provides a way to issue direct OpenGL calls during the rendering.<p> You can use this object to do your specific rendering task in its OnRender event. The OpenGL calls shall restore the OpenGL states they found when entering, or exclusively use the GLMisc utility functions to alter the states.<br>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLDirectOpenGL

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Protected | function Blended: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure SetBlend(const val: Boolean);
Protected | procedure SetUseBuildList(const val: Boolean);

Properties

Published | property Blend: Boolean read FBlend write SetBlend;
Published | property OnRender: TDirectRenderEvent read FOnRender write FOnRender;
Published | property UseBuildList: Boolean read FUseBuildList write SetUseBuildList;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Protected function Blended: Boolean; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure SetBlend(const val: Boolean);
Protected procedure SetUseBuildList(const val: Boolean);

Properties

Published property Blend: Boolean read FBlend write SetBlend;

Defines if the object uses blending.<p> This property will allow direct opengl objects to be flagged as blended for object sorting purposes.<br>

Published property OnRender: TDirectRenderEvent read FOnRender write FOnRender;

Place your specific OpenGL code here.<p> The OpenGL calls shall restore the OpenGL states they found when entering, or exclusively use the GLMisc utility functions to alter the states.<br>

Published property UseBuildList: Boolean read FUseBuildList write SetUseBuildList;

Specifies if a build list be made.<p> If True, GLScene will generate a build list (OpenGL-side cache), ie. OnRender will only be invoked once for the first render, or after a StructureChanged call. This is suitable for "static" geometry and will usually speed up rendering of things that don't change.<br> If false, OnRender will be invoked for each render. This is suitable for dynamic geometry (things that change often or constantly).

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLRenderPoint

Class TGLRenderPoint

Unit

GLScene

Declaration

type TGLRenderPoint = class(TGLImmaterialSceneObject)

Description

Scene object that allows other objects to issue rendering at some point.<p> This object is used to specify a render point for which other components have (rendering) tasks to perform. It doesn't render anything itself and is invisible, but other components can register and be notified when the point is reached in the rendering phase.<br> Callbacks must be explicitly unregistered.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLRenderPoint

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure Clear;
Public | procedure RegisterCallBack(renderEvent: TDirectRenderEvent; renderPointFreed: TNotifyEvent);
Public | procedure UnRegisterCallBack(renderEvent: TDirectRenderEvent);

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure Clear;
Public procedure RegisterCallBack(renderEvent: TDirectRenderEvent; renderPointFreed: TNotifyEvent);
Public procedure UnRegisterCallBack(renderEvent: TDirectRenderEvent);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLProxyObject

Class TGLProxyObject

Unit

GLScene

Declaration

type TGLProxyObject = class(TGLBaseSceneObject)

Description

A full proxy object.<p> This object literally uses another object's Render method to do its own rendering, however, it has a coordinate system and a life of its own.<br> Use it for duplicates of an object.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLProxyObject

Overview

Fields

Protected FRendering: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensions: TVector; override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function BarycenterAbsolutePosition: TVector; override;
Public | function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetMasterObject(const val: TGLBaseSceneObject); virtual;
Protected | procedure SetProxyOptions(const val: TGLProxyObjectOptions);

Properties

Published | property Behaviours;
Published | property Direction;
Published | property MasterObject: TGLBaseSceneObject read FMasterObject write SetMasterObject;
Published | property ObjectsSorting;
Published | property OnPicked;
Published | property OnProgress;
Published | property Pickable;
Published | property PitchAngle;
Published | property Position;
Published | property ProxyOptions: TGLProxyObjectOptions read FProxyOptions write SetProxyOptions default cDefaultProxyOptions;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property Visible;

Description

Fields

Protected FRendering: Boolean;

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensions: TVector; override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function BarycenterAbsolutePosition: TVector; override;
Public function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;
Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetMasterObject(const val: TGLBaseSceneObject); virtual;
Protected procedure SetProxyOptions(const val: TGLProxyObjectOptions);

Properties

Published property Behaviours;
Published property Direction;
Published property MasterObject: TGLBaseSceneObject read FMasterObject write SetMasterObject;

Specifies the Master object which will be proxy'ed.

Published property ObjectsSorting;
Published property OnPicked;
Published property OnProgress;
Published property Pickable;
Published property PitchAngle;
Published property Position;
Published property ProxyOptions: TGLProxyObjectOptions read FProxyOptions write SetProxyOptions default cDefaultProxyOptions;

Specifies how and what is proxy'ed.

Published property RollAngle;
Published property Scale;
Published property ShowAxes;
Published property TurnAngle;
Published property Up;
Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:40


GLScene v.1.1.2: GLScene: Class TGLLightSource

Class TGLLightSource

Unit

GLScene

Declaration

type TGLLightSource = class(TGLBaseSceneObject)

Description

Standard light source.<p> The standard GLScene light source covers spotlights, omnidirectionnal and parallel sources (see TLightStyle).<br> Lights are colored, have distance attenuation parameters and are turned on/off through their Shining property.<p> Lightsources are managed in a specific object by the TGLScene for rendering purposes. The maximum number of light source in a scene is limited by the OpenGL implementation (8 lights are supported under most ICDs), though the more light you use, the slower rendering may get. If you want to render many more light/lightsource, you may have to resort to other techniques like lightmapping.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLLightSource

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Attenuated: Boolean;
Public | function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;
Public | function GetHandle(var rci: TRenderContextInfo): Cardinal; override;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; override;
Public | procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected | procedure SetAmbient(AValue: TGLColor);
Protected | procedure SetConstAttenuation(AValue: Single);
Protected | procedure SetDiffuse(AValue: TGLColor);
Protected | procedure SetLightStyle(const val: TLightStyle);
Protected | procedure SetLinearAttenuation(AValue: Single);
Protected | procedure SetQuadraticAttenuation(AValue: Single);
Protected | procedure SetShining(AValue: Boolean);
Protected | procedure SetSpecular(AValue: TGLColor);
Protected | procedure SetSpotCutOff(const val: Single);
Protected | procedure SetSpotDirection(AVector: TGLCoordinates);
Protected | procedure SetSpotExponent(AValue: Single);

Properties

Published | property Ambient: TGLColor read FAmbient write SetAmbient;
Published | property ConstAttenuation: Single read FConstAttenuation write SetConstAttenuation;
Published | property Diffuse: TGLColor read FDiffuse write SetDiffuse;
Public | property LightID: Cardinal read FLightID;
Published | property LightStyle: TLightStyle read FLightStyle write SetLightStyle default lsSpot;
Published | property LinearAttenuation: Single read FLinearAttenuation write SetLinearAttenuation;
Published | property OnProgress;
Published | property Position;
Published | property QuadraticAttenuation: Single read FQuadraticAttenuation write SetQuadraticAttenuation;
Published | property Shining: Boolean read FShining write SetShining default True;
Published | property Specular: TGLColor read FSpecular write SetSpecular;
Published | property SpotCutOff: Single read FSpotCutOff write SetSpotCutOff;
Published | property SpotDirection: TGLCoordinates read FSpotDirection write SetSpotDirection;
Published | property SpotExponent: Single read FSpotExponent write SetSpotExponent;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function Attenuated: Boolean;
Public function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;
Public function GetHandle(var rci: TRenderContextInfo): Cardinal; override;

light sources have different handle types than normal scene objects

Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; override;
Public procedure CoordinateChanged(Sender: TGLCustomCoordinates); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected procedure SetAmbient(AValue: TGLColor);
Protected procedure SetConstAttenuation(AValue: Single);
Protected procedure SetDiffuse(AValue: TGLColor);
Protected procedure SetLightStyle(const val: TLightStyle);
Protected procedure SetLinearAttenuation(AValue: Single);
Protected procedure SetQuadraticAttenuation(AValue: Single);
Protected procedure SetShining(AValue: Boolean);
Protected procedure SetSpecular(AValue: TGLColor);
Protected procedure SetSpotCutOff(const val: Single);
Protected procedure SetSpotDirection(AVector: TGLCoordinates);
Protected procedure SetSpotExponent(AValue: Single);

Properties

Published property Ambient: TGLColor read FAmbient write SetAmbient;
Published property ConstAttenuation: Single read FConstAttenuation write SetConstAttenuation;
Published property Diffuse: TGLColor read FDiffuse write SetDiffuse;
Public property LightID: Cardinal read FLightID;
Published property LightStyle: TLightStyle read FLightStyle write SetLightStyle default lsSpot;
Published property LinearAttenuation: Single read FLinearAttenuation write SetLinearAttenuation;
Published property OnProgress;
Published property Position;
Published property QuadraticAttenuation: Single read FQuadraticAttenuation write SetQuadraticAttenuation;
Published property Shining: Boolean read FShining write SetShining default True;
Published property Specular: TGLColor read FSpecular write SetSpecular;
Published property SpotCutOff: Single read FSpotCutOff write SetSpotCutOff;
Published property SpotDirection: TGLCoordinates read FSpotDirection write SetSpotDirection;
Published property SpotExponent: Single read FSpotExponent write SetSpotExponent;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:41


GLScene v.1.1.2: GLScene: Class TGLCamera

Class TGLCamera

Unit

GLScene

Declaration

type TGLCamera = class(TGLBaseSceneObject)

Description

Camera object.<p> This object is commonly referred by TGLSceneViewer and defines a position, direction, focal length, depth of view... all the properties needed for defining a point of view and optical characteristics.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCamera

Overview

Methods

Public | constructor Create(aOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AbsoluteEyeSpaceVector(forwardDistance, rightDistance, upDistance: Single): TVector;
Public | function AbsoluteRightVectorToTarget: TVector;
Public | function AbsoluteUpVectorToTarget: TVector;
Public | function AbsoluteVectorToTarget: TVector;
Public | function DistanceToTarget: Single;
Public | function GetFieldOfView(const AViewportDimension: single): single;
Public | function PointInFront(const point: TVector): boolean; overload;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; override;
Public | function ScreenDeltaToVector(deltaX, deltaY: Integer; ratio: Single; const planeNormal: TVector): TVector;
Public | function ScreenDeltaToVectorXY(deltaX, deltaY: Integer; ratio: Single): TVector;
Public | function ScreenDeltaToVectorXZ(deltaX, deltaY: Integer; ratio: Single): TVector;
Public | function ScreenDeltaToVectorYZ(deltaX, deltaY: Integer; ratio: Single): TVector;
Protected | function StoreNearPlaneBias: Boolean;
Protected | function StoreSceneScale: Boolean;
Public | procedure AdjustDistanceToTarget(distanceRatio: Single);
Public | procedure Apply;
Public | procedure ApplyPerspective(const AViewport: TRectangle; AWidth, AHeight: Integer; ADPI: Integer);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure AutoLeveling(Factor: Single);
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure MoveAllAroundTarget(pitchDelta, turnDelta :Single);
Public | procedure MoveAroundTarget(pitchDelta, turnDelta: Single);
Public | procedure MoveInEyeSpace(forwardDistance, rightDistance, upDistance: Single);
Public | procedure MoveTargetInEyeSpace(forwardDistance, rightDistance, upDistance: Single);
Public | procedure Reset(aSceneBuffer: TGLSceneBuffer);
Public | procedure RotateObject(obj: TGLBaseSceneObject; pitchDelta, turnDelta: Single; rollDelta: Single = 0);
Public | procedure RotateTarget(pitchDelta, turnDelta: Single; rollDelta: Single = 0);
Public | procedure SetFieldOfView(const AFieldOfView, AViewportDimension: single);
Public | procedure ZoomAll(aSceneBuffer: TGLSceneBuffer);
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetCameraStyle(const val: TGLCameraStyle);
Protected | procedure SetDepthOfView(AValue: Single);
Protected | procedure SetFocalLength(AValue: Single);
Protected | procedure SetKeepFOVMode(const val: TGLCameraKeepFOVMode);
Protected | procedure SetNearPlaneBias(value: Single);
Protected | procedure SetSceneScale(value: Single);
Protected | procedure SetTargetObject(const val: TGLBaseSceneObject);

Properties

Published | property CameraStyle: TGLCameraStyle read FCameraStyle write SetCameraStyle default csPerspective;
Published | property DepthOfView: Single read FDepthOfView write SetDepthOfView;
Published | property Direction;
Published | property FocalLength: Single read FFocalLength write SetFocalLength;
Published | property KeepFOVMode: TGLCameraKeepFOVMode read FKeepFOVMode write SetKeepFOVMode default ckmHorizontalFOV;
Public | property NearPlane: Single read FNearPlane;
Published | property NearPlaneBias: Single read FNearPlaneBias write SetNearPlaneBias stored StoreNearPlaneBias;
Published | property OnCustomPerspective: TOnCustomPerspective read FOnCustomPerspective write FOnCustomPerspective;
Published | property OnProgress;
Published | property Position;
Published | property SceneScale: Single read FSceneScale write SetSceneScale stored StoreSceneScale;
Published | property TargetObject: TGLBaseSceneObject read FTargetObject write SetTargetObject;
Published | property Up;

Description

Methods

Public constructor Create(aOwner: TComponent); override;
Public destructor Destroy; override;
Public function AbsoluteEyeSpaceVector(forwardDistance, rightDistance, upDistance: Single): TVector;

Computes the absolute vector corresponding to the eye-space translations.

Public function AbsoluteRightVectorToTarget: TVector;

Computes the absolute normalized right vector to the camera target.<p> If no target is defined, AbsoluteRight is returned.

Public function AbsoluteUpVectorToTarget: TVector;

Computes the absolute normalized up vector to the camera target.<p> If no target is defined, AbsoluteUpt is returned.

Public function AbsoluteVectorToTarget: TVector;

Computes the absolute normalized vector to the camera target.<p> If no target is defined, AbsoluteDirection is returned.

Public function DistanceToTarget: Single;

Returns the distance from camera to target.<p> If TargetObject is nil, returns 1.

Public function GetFieldOfView(const AViewportDimension: single): single;

Calculates the field of view in degrees, given a viewport dimension (width or height). F.i. you may wish to use the minimum of the two.

Public function PointInFront(const point: TVector): boolean; overload;

Returns true if a point is in front of the camera.

Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; override;
Public function ScreenDeltaToVector(deltaX, deltaY: Integer; ratio: Single; const planeNormal: TVector): TVector;

Calculate an absolute translation vector from a screen vector.<p> Ratio is applied to both screen delta, planeNormal should be the translation plane's normal.

Public function ScreenDeltaToVectorXY(deltaX, deltaY: Integer; ratio: Single): TVector;

Same as ScreenDeltaToVector but optimized for XY plane.

Public function ScreenDeltaToVectorXZ(deltaX, deltaY: Integer; ratio: Single): TVector;

Same as ScreenDeltaToVector but optimized for XZ plane.

Public function ScreenDeltaToVectorYZ(deltaX, deltaY: Integer; ratio: Single): TVector;

Same as ScreenDeltaToVector but optimized for YZ plane.

Protected function StoreNearPlaneBias: Boolean;
Protected function StoreSceneScale: Boolean;
Public procedure AdjustDistanceToTarget(distanceRatio: Single);

Adjusts distance from camera to target by applying a ratio.<p> If TargetObject is nil, nothing happens. This method helps in quickly implementing camera controls. Only the camera's position is changed.

Public procedure Apply;

Apply camera transformation

Public procedure ApplyPerspective(const AViewport: TRectangle; AWidth, AHeight: Integer; ADPI: Integer);
Public procedure Assign(Source: TPersistent); override;
Public procedure AutoLeveling(Factor: Single);
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public procedure MoveAllAroundTarget(pitchDelta, turnDelta :Single);

Change camera's position to make it move all around its target.<p> If TargetObject is nil, nothing happens. This method helps in quickly implementing camera controls. Camera's Up and Direction properties are changed.<br> Angle deltas are in degrees.<p>

Public procedure MoveAroundTarget(pitchDelta, turnDelta: Single);

Change camera's position to make it move around its target.<p> If TargetObject is nil, nothing happens. This method helps in quickly implementing camera controls. Camera's Up and Direction properties are unchanged.<br> Angle deltas are in degrees, camera parent's coordinates should be identity.<p> Tip : make the camera a child of a "target" dummycube and make it a target the dummycube. Now, to pan across the scene, just move the dummycube, to change viewing angle, use this method.

Public procedure MoveInEyeSpace(forwardDistance, rightDistance, upDistance: Single);

Moves the camera in eye space coordinates.

Public procedure MoveTargetInEyeSpace(forwardDistance, rightDistance, upDistance: Single);

Moves the target in eye space coordinates.

Public procedure Reset(aSceneBuffer: TGLSceneBuffer);
Public procedure RotateObject(obj: TGLBaseSceneObject; pitchDelta, turnDelta: Single; rollDelta: Single = 0);
Public procedure RotateTarget(pitchDelta, turnDelta: Single; rollDelta: Single = 0);
Public procedure SetFieldOfView(const AFieldOfView, AViewportDimension: single);

Sets the FocalLength in degrees, given a field of view and a viewport dimension (width or height).

Public procedure ZoomAll(aSceneBuffer: TGLSceneBuffer);

Position the camera so that the whole scene can be seen

Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetCameraStyle(const val: TGLCameraStyle);
Protected procedure SetDepthOfView(AValue: Single);
Protected procedure SetFocalLength(AValue: Single);
Protected procedure SetKeepFOVMode(const val: TGLCameraKeepFOVMode);
Protected procedure SetNearPlaneBias(value: Single);
Protected procedure SetSceneScale(value: Single);
Protected procedure SetTargetObject(const val: TGLBaseSceneObject);

Properties

Published property CameraStyle: TGLCameraStyle read FCameraStyle write SetCameraStyle default csPerspective;

Adjust the camera style.<p> Three styles are available :<ul> <li>csPerspective, the default value for perspective projection <li>csOrthogonal, for orthogonal (or isometric) projection. <li>csOrtho2D, setups orthogonal 2D projection in which 1 unit (in x or y) represents 1 pixel. <li>csInfinitePerspective, for perspective view without depth limit. <li>csKeepCamAnglePerspective, for perspective view with keeping aspect on view resize. <li>csCustom, setup is deferred to the OnCustomPerspective event. </ul>

Published property DepthOfView: Single read FDepthOfView write SetDepthOfView;

Depth of field/view.<p> Adjusts the maximum distance, beyond which objects will be clipped (ie. not visisble).<p> You must adjust this value if you are experiencing disappearing objects (increase the value) of Z-Buffer crawling (decrease the value). Z-Buffer crawling happens when depth of view is too large and the Z-Buffer precision cannot account for all that depth accurately : objects farther overlap closer objects and vice-versa.<p> Note that this value is ignored in cSOrtho2D mode.

Published property Direction;
Published property FocalLength: Single read FFocalLength write SetFocalLength;

Focal Length of the camera.<p> Adjusting this value allows for lens zooming effects (use SceneScale for linear zooming). This property affects near/far planes clipping.

Published property KeepFOVMode: TGLCameraKeepFOVMode read FKeepFOVMode write SetKeepFOVMode default ckmHorizontalFOV;

Keep camera angle mode. <p> When CameraStyle is csKeepCamAnglePerspective, select which camera angle you want to keep. <li>kaHeight, for Keep Height oriented camera angle <li>kaWidth, for Keep Width oriented camera angle

Public property NearPlane: Single read FNearPlane;

Nearest clipping plane for the frustum.<p> This value depends on the FocalLength and DepthOfView fields and is calculated to minimize Z-Buffer crawling as suggested by the OpenGL documentation.

Published property NearPlaneBias: Single read FNearPlaneBias write SetNearPlaneBias stored StoreNearPlaneBias;

Scaling bias applied to near-plane calculation.<p> Values inferior to one will move the nearplane nearer, and also reduce medium/long range Z-Buffer precision, values superior to one will move the nearplane farther, and also improve medium/long range Z-Buffer precision.

Published property OnCustomPerspective: TOnCustomPerspective read FOnCustomPerspective write FOnCustomPerspective;

Custom perspective event.<p> This event allows you to specify your custom perpective, either with a glFrustrum, a glOrtho or whatever method suits you.<br> You must compute viewPortRadius for culling to work.<br> This event is only called if CameraStyle is csCustom.

Published property OnProgress;
Published property Position;
Published property SceneScale: Single read FSceneScale write SetSceneScale stored StoreSceneScale;

Scene scaling for camera point.<p> This is a linear 2D scaling of the camera's output, allows for linear zooming (use FocalLength for lens zooming).

Published property TargetObject: TGLBaseSceneObject read FTargetObject write SetTargetObject;

If set, camera will point to this object.<p> When camera is pointing an object, the Direction vector is ignored and the Up vector is used as an absolute vector to the up.

Published property Up;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:41


GLScene v.1.1.2: GLScene: Class TGLScene

Class TGLScene

Unit

GLScene

Declaration

type TGLScene = class(TGLUpdateAbleComponent)

Description

Scene object.<p> The scene contains the scene description (lights, geometry...), which is basicly a hierarchical scene graph made of TGLBaseSceneObject. It will usually contain one or more TGLCamera object, which can be referred by a Viewer component for rendering purposes.<p> The scene's objects can be accessed directly from Delphi code (as regular components), but those are edited with a specific editor (double-click on the TGLScene component at design-time to invoke it). To add objects at runtime, use the AddNewChild method of TGLBaseSceneObject.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLScene

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function FindSceneObject(const AName: string): TGLBaseSceneObject;
Public | function IsUpdating: Boolean;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): TGLBaseSceneObject; virtual;
Public | procedure AddBuffer(aBuffer: TGLSceneBuffer);
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure LoadFromFile(const fileName: string);
Public | procedure LoadFromStream(aStream: TStream);
Public | procedure LoadFromTextFile(const fileName: string);
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure Progress(const deltaTime, newTime: Double);
Public | procedure RemoveBuffer(aBuffer: TGLSceneBuffer);
Public | procedure SaveToFile(const fileName: string);
Public | procedure SaveToStream(aStream: TStream);
Public | procedure SaveToTextFile(const fileName: string);
Public | procedure SetupLights(maxLights: Integer);
Public | procedure ShutdownAllLights;
Protected | procedure AddLight(aLight: TGLLightSource);
Protected | procedure AddLights(anObj: TGLBaseSceneObject);
Protected | procedure GetChildren(AProc: TGetChildProc; Root: TComponent); override;
Protected | procedure ReadState(Reader: TReader); override;
Protected | procedure RemoveLight(aLight: TGLLightSource);
Protected | procedure RemoveLights(anObj: TGLBaseSceneObject);
Protected | procedure SetChildOrder(AChild: TComponent; Order: Integer); override;
Protected | procedure SetObjectsSorting(const val: TGLObjectsSorting);
Protected | procedure SetVisibilityCulling(const val: TGLVisibilityCulling);

Properties

Public | property CurrentBuffer: TGLSceneBuffer read FCurrentBuffer;
Public | property CurrentDeltaTime: Double read FCurrentDeltaTime;
Public | property CurrentGLCamera: TGLCamera read FCurrentGLCamera;
Public | property InitializableObjects: TGLInitializableObjectList read FInitializableObjects;
Public | property Lights: TPersistentObjectList read FLights;
Public | property Objects: TGLSceneRootObject read FObjects;
Published | property ObjectsSorting: TGLObjectsSorting read FObjectsSorting write SetObjectsSorting default osRenderBlendedLast;
Published | property OnBeforeProgress: TGLProgressEvent read FOnBeforeProgress write FOnBeforeProgress;
Published | property OnProgress: TGLProgressEvent read FOnProgress write FOnProgress;
Published | property VisibilityCulling: TGLVisibilityCulling read FVisibilityCulling write SetVisibilityCulling default vcNone;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function FindSceneObject(const AName: string): TGLBaseSceneObject;
Public function IsUpdating: Boolean;
Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): TGLBaseSceneObject; virtual;

Calculates, finds and returns the first object intercepted by the ray.<p> Returns nil if no intersection was found. This function will be accurate only for objects that overrided their RayCastIntersect method with accurate code, otherwise, bounding sphere intersections will be returned.

Public procedure AddBuffer(aBuffer: TGLSceneBuffer);
Public procedure BeginUpdate;
Public procedure EndUpdate;
Public procedure LoadFromFile(const fileName: string);

Load the scene from a file.<p> Existing objects/lights/cameras are freed, then the file is loaded.<br> Delphi's IDE is not handling this behaviour properly yet, ie. if you load a scene in the IDE, objects will be properly loaded, but no declare will be placed in the code.

Public procedure LoadFromStream(aStream: TStream);
Public procedure LoadFromTextFile(const fileName: string);

Load the scene from a text files.<p> See LoadFromFile for details.

Public procedure NotifyChange(Sender: TObject); override;
Public procedure Progress(const deltaTime, newTime: Double);
Public procedure RemoveBuffer(aBuffer: TGLSceneBuffer);
Public procedure SaveToFile(const fileName: string);

Saves the scene to a file (recommended extension : .GLS)

Public procedure SaveToStream(aStream: TStream);
Public procedure SaveToTextFile(const fileName: string);

Saves the scene to a text file

Public procedure SetupLights(maxLights: Integer);
Public procedure ShutdownAllLights;
Protected procedure AddLight(aLight: TGLLightSource);
Protected procedure AddLights(anObj: TGLBaseSceneObject);

Adds all lights in the subtree (anObj included)

Protected procedure GetChildren(AProc: TGetChildProc; Root: TComponent); override;
Protected procedure ReadState(Reader: TReader); override;
Protected procedure RemoveLight(aLight: TGLLightSource);
Protected procedure RemoveLights(anObj: TGLBaseSceneObject);

Removes all lights in the subtree (anObj included)

Protected procedure SetChildOrder(AChild: TComponent; Order: Integer); override;
Protected procedure SetObjectsSorting(const val: TGLObjectsSorting);
Protected procedure SetVisibilityCulling(const val: TGLVisibilityCulling);

Properties

Public property CurrentBuffer: TGLSceneBuffer read FCurrentBuffer;
Public property CurrentDeltaTime: Double read FCurrentDeltaTime;
Public property CurrentGLCamera: TGLCamera read FCurrentGLCamera;
Public property InitializableObjects: TGLInitializableObjectList read FInitializableObjects;

List of objects that request to be initialized when rendering context is active.<p> They are removed automaticly from this list once initialized.

Public property Lights: TPersistentObjectList read FLights;
Public property Objects: TGLSceneRootObject read FObjects;
Published property ObjectsSorting: TGLObjectsSorting read FObjectsSorting write SetObjectsSorting default osRenderBlendedLast;

Defines default ObjectSorting option for scene objects.

Published property OnBeforeProgress: TGLProgressEvent read FOnBeforeProgress write FOnBeforeProgress;
Published property OnProgress: TGLProgressEvent read FOnProgress write FOnProgress;
Published property VisibilityCulling: TGLVisibilityCulling read FVisibilityCulling write SetVisibilityCulling default vcNone;

Defines default VisibilityCulling option for scene objects.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:41


GLScene v.1.1.2: GLScene: Class TGLFogEnvironment

Class TGLFogEnvironment

Unit

GLScene

Declaration

type TGLFogEnvironment = class(TGLUpdateAbleObject)

Description

Parameters for fog environment in a scene.<p> The fog descibed by this object is a distance-based fog, ie. the "intensity" of the fog is given by a formula depending solely on the distance, this intensity is used for blending to a fixed color.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLFogEnvironment

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function IsAtDefaultValues: Boolean;
Public | procedure ApplyFog;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure SetFogColor(Value: TGLColor);
Protected | procedure SetFogDistance(const val: TFogDistance);
Protected | procedure SetFogEnd(Value: Single);
Protected | procedure SetFogMode(Value: TFogMode);
Protected | procedure SetFogStart(Value: Single);

Properties

Published | property FogColor: TGLColor read FFogColor write SetFogColor;
Published | property FogDistance: TFogDistance read FFogDistance write SetFogDistance default fdDefault;
Published | property FogEnd: Single read FFogEnd write SetFogEnd;
Published | property FogMode: TFogMode read FFogMode write SetFogMode default fmLinear;
Published | property FogStart: Single read FFogStart write SetFogStart;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public function IsAtDefaultValues: Boolean;
Public procedure ApplyFog;
Public procedure Assign(Source: TPersistent); override;
Protected procedure SetFogColor(Value: TGLColor);
Protected procedure SetFogDistance(const val: TFogDistance);
Protected procedure SetFogEnd(Value: Single);
Protected procedure SetFogMode(Value: TFogMode);
Protected procedure SetFogStart(Value: Single);

Properties

Published property FogColor: TGLColor read FFogColor write SetFogColor;

Color of the fog when it is at 100% intensity.

Published property FogDistance: TFogDistance read FFogDistance write SetFogDistance default fdDefault;

Adjusts the formula used for calculating fog distances.<p> This option is honoured if and only if the OpenGL ICD supports the GL_NV_fog_distance extension, otherwise, it is ignored.<ul> <li>fdDefault: let OpenGL use its default formula <li>fdEyeRadial: uses radial "true" distance (best quality) <li>fdEyePlane: uses the distance to the projection plane (same as Z-Buffer, faster) </ul>

Published property FogEnd: Single read FFogEnd write SetFogEnd;

Maximum distance for fog, what is farther is at 100% fog intensity.

Published property FogMode: TFogMode read FFogMode write SetFogMode default fmLinear;

The formula used for converting distance to fog intensity.

Published property FogStart: Single read FFogStart write SetFogStart;

Minimum distance for fog, what is closer is not affected.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:41


GLScene v.1.1.2: GLScene: Class TGLSceneBuffer

Class TGLSceneBuffer

Unit

GLScene

Declaration

type TGLSceneBuffer = class(TGLUpdateAbleObject)

Description

Encapsulates an OpenGL frame/rendering buffer.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLSceneBuffer

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function Acceleration: TGLContextAcceleration;
Public | function CreateSnapShot: TGLImage;
Public | function CreateSnapShotBitmap: TGLBitmap;
Public | function GetPickedObject(x, y: Integer): TGLBaseSceneObject;
Public | function GetPickedObjects(const rect: TGLRect; objectCountGuess: Integer = 64): TGLPickList;
Public | function GetPixelColor(x, y: Integer): TColor;
Public | function GetPixelDepth(x, y: Integer): Single;
Public | function Height: Integer;
Public | function ModelMatrix: TMatrix; deprecated;
Public | function OrthoScreenToWorld(screenX, screenY: Integer): TAffineVector; overload;
Public | function PixelDepthToDistance(aDepth: Single): Single;
Public | function PixelRayToWorld(x, y: Integer): TAffineVector;
Public | function PixelToDistance(x, y: integer): Single;
Public | function ProjectionMatrix: TMatrix; deprecated;
Public | function RCInstantiated: Boolean;
Public | function ScreenToVector(const aPoint: TAffineVector): TAffineVector; overload;
Public | function ScreenToVector(const aPoint: TVector): TVector; overload;
Public | function ScreenToVector(const x, y: Integer): TVector; overload;
Public | function ScreenToWorld(const aPoint: TAffineVector): TAffineVector; overload;
Public | function ScreenToWorld(const aPoint: TVector): TVector; overload;
Public | function ScreenToWorld(screenX, screenY: Integer): TAffineVector; overload;
Public | function ScreenVectorIntersectWithPlane( const aScreenPoint: TVector; const planePoint, planeNormal: TVector; var intersectPoint: TVector): Boolean;
Public | function ScreenVectorIntersectWithPlaneXY( const aScreenPoint: TVector; const z: Single; var intersectPoint: TVector): Boolean;
Public | function ScreenVectorIntersectWithPlaneXZ( const aScreenPoint: TVector; const y: Single; var intersectPoint: TVector): Boolean;
Public | function ScreenVectorIntersectWithPlaneYZ( const aScreenPoint: TVector; const x: Single; var intersectPoint: TVector): Boolean;
Public | function VectorToScreen(const VectToCam: TAffineVector): TAffineVector;
Public | function ViewMatrix: TMatrix; deprecated;
Public | function Width: Integer;
Public | function WorldToScreen(const aPoint: TAffineVector): TAffineVector; overload;
Public | function WorldToScreen(const aPoint: TVector): TVector; overload;
Protected | function GetLimit(Which: TLimitType): Integer;
Protected | function StoreFog: Boolean;
Public | procedure ClearBuffers;
Public | procedure CopyToTexture(aTexture: TGLTexture; xSrc, ySrc, AWidth, AHeight: Integer; xDest, yDest: Integer; glCubeFace: TGLEnum = 0); overload;
Public | procedure CopyToTexture(aTexture: TGLTexture); overload;
Public | procedure CreateRC(AWindowHandle: HWND; memoryContext: Boolean; BufferCount: integer = 1); overload;
Public | procedure DestroyRC;
Public | procedure Freeze;
Public | procedure Melt;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure NotifyMouseMove(Shift: TShiftState; X, Y: Integer);
Public | procedure PickObjects(const rect: TGLRect; pickList: TGLPickList; objectCountGuess: Integer);
Public | procedure PopProjectionMatrix; deprecated;
Public | procedure PopViewMatrix; deprecated;
Public | procedure PushProjectionMatrix(const newMatrix: TMatrix); deprecated;
Public | procedure PushViewMatrix(const newMatrix: TMatrix); deprecated;
Public | procedure Render; overload;
Public | procedure Render(baseObject: TGLBaseSceneObject); overload;
Public | procedure RenderScene(aScene: TGLScene; const viewPortSizeX, viewPortSizeY: Integer; drawState: TDrawState; baseObject: TGLBaseSceneObject);
Public | procedure RenderToBitmap(ABitmap: TGLBitmap; DPI: Integer = 0);
Public | procedure RenderToFile(const AFile: string; DPI: Integer = 0); overload;
Public | procedure RenderToFile(const AFile: string; bmpWidth, bmpHeight: Integer); overload;
Public | procedure ResetPerformanceMonitor;
Public | procedure Resize(newLeft, newTop, newWidth, newHeight: Integer);
Public | procedure SaveAsFloatToFile(const aFilename: string);
Public | procedure SetViewPort(X, Y, W, H: Integer);
Public | procedure ShowInfo(Modal: boolean = false);
Public | procedure WorldToScreen(points: PVector; nbPoints: Integer); overload;
Protected | procedure DoBaseRender(const aViewPort: TRectangle; resolution: Integer; drawState: TDrawState; baseObject: TGLBaseSceneObject);
Protected | procedure DoChange;
Protected | procedure DoStructuralChange;
Protected | procedure PrepareGLContext;
Protected | procedure PrepareRenderingMatrices(const aViewPort: TRectangle; resolution: Integer; pickingRect: PGLRect = nil);
Protected | procedure SetAccumBufferBits(const val: Integer);
Protected | procedure SetAmbientColor(AColor: TGLColor);
Protected | procedure SetAntiAliasing(const val: TGLAntiAliasing);
Protected | procedure SetBackgroundAlpha(alpha: Single);
Protected | procedure SetBackgroundColor(AColor: TColor);
Protected | procedure SetCamera(ACamera: TGLCamera);
Protected | procedure SetColorDepth(const val: TGLColorDepth);
Protected | procedure SetContextOptions(Options: TContextOptions);
Protected | procedure SetDepthPrecision(const val: TGLDepthPrecision);
Protected | procedure SetDepthTest(AValue: Boolean);
Protected | procedure SetFaceCulling(AValue: Boolean);
Protected | procedure SetFogEnable(AValue: Boolean);
Protected | procedure SetGLFogEnvironment(AValue: TGLFogEnvironment);
Protected | procedure SetLighting(AValue: Boolean);
Protected | procedure SetShadeModel(const val: TGLShadeModel);
Protected | procedure SetupRCOptions(context: TGLContext);
Protected | procedure SetupRenderingContext(context: TGLContext);

Properties

Published | property AccumBufferBits: Integer read FAccumBufferBits write SetAccumBufferBits default 0;
Published | property AfterRender: TNotifyEvent read FAfterRender write FAfterRender stored False;
Published | property AmbientColor: TGLColor read FAmbientColor write SetAmbientColor;
Published | property AntiAliasing: TGLAntiAliasing read FAntiAliasing write SetAntiAliasing default aaDefault;
Public | property BackgroundAlpha: Single read FBackgroundAlpha write SetBackgroundAlpha;
Published | property BackgroundColor: TColor read FBackgroundColor write SetBackgroundColor default clBtnFace;
Public | property BaseProjectionMatrix: TMatrix read FBaseProjectionMatrix;
Published | property BeforeRender: TNotifyEvent read FBeforeRender write FBeforeRender stored False;
Public | property Camera: TGLCamera read FCamera write SetCamera;
Published | property ColorDepth: TGLColorDepth read FColorDepth write SetColorDepth default cdDefault;
Published | property ContextOptions: TContextOptions read FContextOptions write SetContextOptions default [roDoubleBuffer, roRenderToWindow, roDebugContext];
Published | property DepthPrecision: TGLDepthPrecision read FDepthPrecision write SetDepthPrecision default dpDefault;
Published | property DepthTest: Boolean read FDepthTest write SetDepthTest default True;
Published | property FaceCulling: Boolean read FFaceCulling write SetFaceCulling default True;
Published | property FogEnable: Boolean read FFogEnable write SetFogEnable default False;
Published | property FogEnvironment: TGLFogEnvironment read FFogEnvironment write SetGLFogEnvironment stored StoreFog;
Public | property FramesPerSecond: Single read FFramesPerSecond;
Public | property Freezed: Boolean read FFreezed;
Published | property InitiateRendering: TDirectRenderEvent read FInitiateRendering write FInitiateRendering stored False;
Public | property LastFrameTime: Single read FLastFrameTime;
Public | property Layer: TGLContextLayer read FLayer write SetLayer default clMainPlane;
Published | property Lighting: Boolean read FLighting write SetLighting default True;
Public | property LimitOf[Which: TLimitType]: Integer read GetLimit;
Published | property OnChange: TNotifyEvent read FOnChange write FOnChange stored False;
Protected | property OnPrepareGLContext: TNotifyEvent read FOnPrepareGLContext write FOnPrepareGLContext;
Published | property OnStructuralChange: TNotifyEvent read FOnStructuralChange write FOnStructuralChange stored False;
Published | property PostRender: TNotifyEvent read FPostRender write FPostRender stored False;
Protected | property RenderDPI: Integer read FRenderDPI;
Public | property Rendering: Boolean read FRendering;
Public | property RenderingContext: TGLContext read FRenderingContext;
Published | property ShadeModel: TGLShadeModel read FShadeModel write SetShadeModel default smDefault;
Public | property ViewerBeforeRender: TNotifyEvent read FViewerBeforeRender write FViewerBeforeRender stored False;
Public | property ViewPort: TRectangle read FViewPort;
Published | property WrapUpRendering: TDirectRenderEvent read FWrapUpRendering write FWrapUpRendering stored False;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public function Acceleration: TGLContextAcceleration;

Indicates hardware acceleration support

Public function CreateSnapShot: TGLImage;

Creates a TGLBitmap32 that is a snapshot of current OpenGL content.<p> When possible, use this function instead of RenderToBitmap, it won't request a redraw and will be significantly faster.<p> The returned TGLBitmap32 should be freed by calling code.

Public function CreateSnapShotBitmap: TGLBitmap;

Creates a VCL bitmap that is a snapshot of current OpenGL content.<p>

Public function GetPickedObject(x, y: Integer): TGLBaseSceneObject;

Returns the nearest object at x, y coordinates or nil if there is none

Public function GetPickedObjects(const rect: TGLRect; objectCountGuess: Integer = 64): TGLPickList;

Returns a PickList with objects in Rect area.<p> Returned list should be freed by caller.<br> Objects are sorted by depth (nearest objects first).

Public function GetPixelColor(x, y: Integer): TColor;

Returns the color of the pixel at x, y in the frame buffer

Public function GetPixelDepth(x, y: Integer): Single;

Returns the raw depth (Z buffer) of the pixel at x, y in the frame buffer.<p> This value does not map to the actual eye-object distance, but to a depth buffer value in the [0; 1] range.

Public function Height: Integer;
Public function ModelMatrix: TMatrix; deprecated;

Warning: this symbol is deprecated.

Public function OrthoScreenToWorld(screenX, screenY: Integer): TAffineVector; overload;

Converts a screen pixel coordinate into 3D coordinates for orthogonal projection.<p> This function accepts standard canvas coordinates, with (0,0) being the top left corner, and returns, when the camera is in orthogonal mode, the corresponding 3D world point that is in the camera's plane.

Public function PixelDepthToDistance(aDepth: Single): Single;

Converts a raw depth (Z buffer value) to frustrum distance. This calculation is only accurate for the pixel at the centre of the viewer, because it does not take into account that the corners of the frustrum are further from the eye than its centre.

Public function PixelRayToWorld(x, y: Integer): TAffineVector;

Calculates a 3D coordinate from screen position and ZBuffer.<p> This function returns a world absolute coordinate from a 2D point in the viewer, the depth being extracted from the ZBuffer data (DepthTesting and ZBuffer must be enabled for this function to work).<br> Note that ZBuffer precision is not linear and can be quite low on some boards (either from compression or resolution approximations).

Public function PixelToDistance(x, y: integer): Single;

Converts a raw depth (Z buffer value) to world distance. It also compensates for the fact that the corners of the frustrum are further from the eye, than its centre.

Public function ProjectionMatrix: TMatrix; deprecated;

Warning: this symbol is deprecated.

Returns the projection matrix in use or used for the last rendering.

Public function RCInstantiated: Boolean;
Public function ScreenToVector(const aPoint: TAffineVector): TAffineVector; overload;

Calculates the 3D vector corresponding to a 2D screen coordinate.<p> The vector originates from the camera's absolute position and is expressed in absolute coordinates.<p> Note that screen coord (0,0) is the lower left corner.

Public function ScreenToVector(const aPoint: TVector): TVector; overload;
Public function ScreenToVector(const x, y: Integer): TVector; overload;
Public function ScreenToWorld(const aPoint: TAffineVector): TAffineVector; overload;

Converts a screen coordinate into world (3D) coordinates.<p> This methods wraps a call to gluUnProject.<p> Note that screen coord (0,0) is the lower left corner.

Public function ScreenToWorld(const aPoint: TVector): TVector; overload;
Public function ScreenToWorld(screenX, screenY: Integer): TAffineVector; overload;

Converts a screen pixel coordinate into 3D world coordinates.<p> This function accepts standard canvas coordinates, with (0,0) being the top left corner.

Public function ScreenVectorIntersectWithPlane( const aScreenPoint: TVector; const planePoint, planeNormal: TVector; var intersectPoint: TVector): Boolean;

Calculates intersection between a plane and screen vector.<p> If an intersection is found, returns True and places result in intersectPoint.

Public function ScreenVectorIntersectWithPlaneXY( const aScreenPoint: TVector; const z: Single; var intersectPoint: TVector): Boolean;

Calculates intersection between plane XY and screen vector.<p> If an intersection is found, returns True and places result in intersectPoint.

Public function ScreenVectorIntersectWithPlaneXZ( const aScreenPoint: TVector; const y: Single; var intersectPoint: TVector): Boolean;

Calculates intersection between plane XZ and screen vector.<p> If an intersection is found, returns True and places result in intersectPoint.

Public function ScreenVectorIntersectWithPlaneYZ( const aScreenPoint: TVector; const x: Single; var intersectPoint: TVector): Boolean;

Calculates intersection between plane YZ and screen vector.<p> If an intersection is found, returns True and places result in intersectPoint.

Public function VectorToScreen(const VectToCam: TAffineVector): TAffineVector;

Calculates the 2D screen coordinate of a vector from the camera's absolute position and is expressed in absolute coordinates.<p> Note that screen coord (0,0) is the lower left corner.

Public function ViewMatrix: TMatrix; deprecated;

Warning: this symbol is deprecated.

Returns the view matrix in use or used for the last rendering.

Public function Width: Integer;
Public function WorldToScreen(const aPoint: TAffineVector): TAffineVector; overload;

Converts an absolute world coordinate into screen coordinate.<p> This methods wraps a call to gluProject.<p> Note that screen coord (0,0) is the lower left corner.

Public function WorldToScreen(const aPoint: TVector): TVector; overload;
Protected function GetLimit(Which: TLimitType): Integer;
Protected function StoreFog: Boolean;
Public procedure ClearBuffers;
Public procedure CopyToTexture(aTexture: TGLTexture; xSrc, ySrc, AWidth, AHeight: Integer; xDest, yDest: Integer; glCubeFace: TGLEnum = 0); overload;
Public procedure CopyToTexture(aTexture: TGLTexture); overload;
Public procedure CreateRC(AWindowHandle: HWND; memoryContext: Boolean; BufferCount: integer = 1); overload;
Public procedure DestroyRC;
Public procedure Freeze;

Freezes rendering leaving the last rendered scene on the buffer. This is usefull in windowed applications for temporarily stoping rendering (when moving the window, for example).

Public procedure Melt;

Restarts rendering after it was freezed.

Public procedure NotifyChange(Sender: TObject); override;
Public procedure NotifyMouseMove(Shift: TShiftState; X, Y: Integer);

Design time notification

Public procedure PickObjects(const rect: TGLRect; pickList: TGLPickList; objectCountGuess: Integer);

Fills the PickList with objects in Rect area

Public procedure PopProjectionMatrix; deprecated;

Warning: this symbol is deprecated.

Public procedure PopViewMatrix; deprecated;

Warning: this symbol is deprecated.

Restore a View matrix previously pushed.

Public procedure PushProjectionMatrix(const newMatrix: TMatrix); deprecated;

Warning: this symbol is deprecated.

Public procedure PushViewMatrix(const newMatrix: TMatrix); deprecated;

Warning: this symbol is deprecated.

Back up current View matrix and replace it with newMatrix.<p> This method has no effect on the OpenGL matrix, only on the Buffer's matrix, and is intended for special effects rendering.

Public procedure Render; overload;
Public procedure Render(baseObject: TGLBaseSceneObject); overload;

Renders the scene on the viewer.<p> You do not need to call this method, unless you explicitly want a render at a specific time. If you just want the control to get refreshed, use Invalidate instead.

Public procedure RenderScene(aScene: TGLScene; const viewPortSizeX, viewPortSizeY: Integer; drawState: TDrawState; baseObject: TGLBaseSceneObject);
Public procedure RenderToBitmap(ABitmap: TGLBitmap; DPI: Integer = 0);

Render the scene to a bitmap at given DPI.<p> DPI = "dots per inch".<p> The "magic" DPI of the screen is 96 under Windows.

Public procedure RenderToFile(const AFile: string; DPI: Integer = 0); overload;

Render the scene to a bitmap at given DPI and saves it to a file.<p> DPI = "dots per inch".<p> The "magic" DPI of the screen is 96 under Windows.

Public procedure RenderToFile(const AFile: string; bmpWidth, bmpHeight: Integer); overload;

Renders to bitmap of given size, then saves it to a file.<p> DPI is adjusted to make the bitmap similar to the viewer.

Public procedure ResetPerformanceMonitor;

Resets the perfomance monitor and begin a new statistics set.<p> See FramesPerSecond.

Public procedure Resize(newLeft, newTop, newWidth, newHeight: Integer);
Public procedure SaveAsFloatToFile(const aFilename: string);

Save as raw float data to a file

Public procedure SetViewPort(X, Y, W, H: Integer);
Public procedure ShowInfo(Modal: boolean = false);

Displays a window with info on current OpenGL ICD and context.

Public procedure WorldToScreen(points: PVector; nbPoints: Integer); overload;

Converts a set of point absolute world coordinates into screen coordinates.<p>

Protected procedure DoBaseRender(const aViewPort: TRectangle; resolution: Integer; drawState: TDrawState; baseObject: TGLBaseSceneObject);
Protected procedure DoChange;
Protected procedure DoStructuralChange;
Protected procedure PrepareGLContext;
Protected procedure PrepareRenderingMatrices(const aViewPort: TRectangle; resolution: Integer; pickingRect: PGLRect = nil);
Protected procedure SetAccumBufferBits(const val: Integer);
Protected procedure SetAmbientColor(AColor: TGLColor);
Protected procedure SetAntiAliasing(const val: TGLAntiAliasing);
Protected procedure SetBackgroundAlpha(alpha: Single);
Protected procedure SetBackgroundColor(AColor: TColor);
Protected procedure SetCamera(ACamera: TGLCamera);
Protected procedure SetColorDepth(const val: TGLColorDepth);
Protected procedure SetContextOptions(Options: TContextOptions);
Protected procedure SetDepthPrecision(const val: TGLDepthPrecision);
Protected procedure SetDepthTest(AValue: Boolean);
Protected procedure SetFaceCulling(AValue: Boolean);
Protected procedure SetFogEnable(AValue: Boolean);
Protected procedure SetGLFogEnvironment(AValue: TGLFogEnvironment);
Protected procedure SetLighting(AValue: Boolean);
Protected procedure SetShadeModel(const val: TGLShadeModel);
Protected procedure SetupRCOptions(context: TGLContext);
Protected procedure SetupRenderingContext(context: TGLContext);

Properties

Published property AccumBufferBits: Integer read FAccumBufferBits write SetAccumBufferBits default 0;

Number of precision bits for the accumulation buffer.

Published property AfterRender: TNotifyEvent read FAfterRender write FAfterRender stored False;

Called after rendering.<p> You cannot issue OpenGL calls in this event, if you want to do your own OpenGL stuff, use the PostRender event.

Published property AmbientColor: TGLColor read FAmbientColor write SetAmbientColor;

Scene ambient color vector.<p> This ambient color is defined independantly from all lightsources, which can have their own ambient components.

Published property AntiAliasing: TGLAntiAliasing read FAntiAliasing write SetAntiAliasing default aaDefault;

AntiAliasing option.<p> Ignored if not hardware supported, currently based on ARB_multisample.

Public property BackgroundAlpha: Single read FBackgroundAlpha write SetBackgroundAlpha;

Adjusts background alpha channel.

Published property BackgroundColor: TColor read FBackgroundColor write SetBackgroundColor default clBtnFace;

Color used for filling the background prior to any rendering.

Public property BaseProjectionMatrix: TMatrix read FBaseProjectionMatrix;

Returns the base projection matrix in use or used for the last rendering.<p> The "base" projection is (as of now) either identity or the pick matrix, ie. it is the matrix on which the perspective or orthogonal matrix gets applied.

Published property BeforeRender: TNotifyEvent read FBeforeRender write FBeforeRender stored False;

Triggered before the scene's objects get rendered.<p> You may use this event to execute your own OpenGL rendering (usually background stuff).

Public property Camera: TGLCamera read FCamera write SetCamera;

The camera from which the scene is rendered.<p> A camera is an object you can add and define in a TGLScene component.

Published property ColorDepth: TGLColorDepth read FColorDepth write SetColorDepth default cdDefault;

Color buffer depth.<p> Default depth buffer is highest available (below and including 24 bits)

Published property ContextOptions: TContextOptions read FContextOptions write SetContextOptions default [roDoubleBuffer, roRenderToWindow, roDebugContext];

Context options allows to setup specifics of the rendering context.<p> Not all contexts support all options.

Published property DepthPrecision: TGLDepthPrecision read FDepthPrecision write SetDepthPrecision default dpDefault;

Depth buffer precision.<p> Default is highest available (below and including 24 bits)

Published property DepthTest: Boolean read FDepthTest write SetDepthTest default True;

DepthTest enabling.<p> When DepthTest is enabled, objects closer to the camera will hide farther ones (via use of Z-Buffering).<br> When DepthTest is disabled, the latest objects drawn/rendered overlap all previous objects, whatever their distance to the camera.<br> Even when DepthTest is enabled, objects may chose to ignore depth testing through the osIgnoreDepthBuffer of their ObjectStyle property.

Published property FaceCulling: Boolean read FFaceCulling write SetFaceCulling default True;

Enable or disable face culling in the renderer.<p> Face culling is used in hidden faces removal algorithms : each face is given a normal or 'outside' direction. When face culling is enabled, only faces whose normal points towards the observer are rendered.

Published property FogEnable: Boolean read FFogEnable write SetFogEnable default False;

Toggle to enable or disable the fog settings.

Published property FogEnvironment: TGLFogEnvironment read FFogEnvironment write SetGLFogEnvironment stored StoreFog;

Fog environment options.<p> See TGLFogEnvironment.

Public property FramesPerSecond: Single read FFramesPerSecond;

Current FramesPerSecond rendering speed.<p> You must keep the renderer busy to get accurate figures from this property.<br> This is an average value, to reset the counter, call ResetPerfomanceMonitor.

Public property Freezed: Boolean read FFreezed;

Indicates if the Viewer is "frozen".

Published property InitiateRendering: TDirectRenderEvent read FInitiateRendering write FInitiateRendering stored False;

Triggered after BeforeRender, before rendering objects.<p> This one is fired after the rci has been initialized and can be used to alter it or perform early renderings that require an rci, the Sender is the buffer.

Public property LastFrameTime: Single read FLastFrameTime;

Time (in second) spent to issue rendering order for the last frame.<p> Be aware that since execution by the hardware isn't synchronous, this value may not be an accurate measurement of the time it took to render the last frame, it's a measurement of only the time it took to issue rendering orders.

Public property Layer: TGLContextLayer read FLayer write SetLayer default clMainPlane;

Specifies the layer plane that the rendering context is bound to.

Published property Lighting: Boolean read FLighting write SetLighting default True;

Toggle to enable or disable lighting calculations.<p> When lighting is enabled, objects will be lit according to lightsources, when lighting is disabled, objects are rendered in their own colors, without any shading.<p> Lighting does NOT generate shadows in OpenGL.

Public property LimitOf[Which: TLimitType]: Integer read GetLimit;

Retrieve one of the OpenGL limits for the current viewer.<p> Limits include max texture size, OpenGL stack depth, etc.

Published property OnChange: TNotifyEvent read FOnChange write FOnChange stored False;

Indicates a change in the scene or buffer options.<p> A simple re-render is enough to take into account the changes.

Protected property OnPrepareGLContext: TNotifyEvent read FOnPrepareGLContext write FOnPrepareGLContext;
Published property OnStructuralChange: TNotifyEvent read FOnStructuralChange write FOnStructuralChange stored False;

Indicates a structural change in the scene or buffer options.<p> A reconstruction of the RC is necessary to take into account the changes (this may lead to a driver switch or lengthy operations).

Published property PostRender: TNotifyEvent read FPostRender write FPostRender stored False;

Triggered just after all the scene's objects have been rendered.<p> The OpenGL context is still active in this event, and you may use it to execute your own OpenGL rendering (usually for HUD, 2D overlays or after effects).<p>

Protected property RenderDPI: Integer read FRenderDPI;

DPI for current/last render

Public property Rendering: Boolean read FRendering;

Currently Rendering?

Public property RenderingContext: TGLContext read FRenderingContext;

Current rendering context.<p> The context is a wrapper around platform-specific contexts (see TGLContext) and takes care of context activation and handle management.

Published property ShadeModel: TGLShadeModel read FShadeModel write SetShadeModel default smDefault;

Shade model.<p> Default is "Smooth".<p>

Public property ViewerBeforeRender: TNotifyEvent read FViewerBeforeRender write FViewerBeforeRender stored False;

Event reserved for viewer-specific uses.<br>

Public property ViewPort: TRectangle read FViewPort;

ViewPort for current/last render

Published property WrapUpRendering: TDirectRenderEvent read FWrapUpRendering write FWrapUpRendering stored False;

Triggered after rendering all scene objects, before PostRender.<p> This is the last point after which the rci becomes unavailable, the Sender is the buffer.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:42


GLScene v.1.1.2: GLScene: Class TGLNonVisualViewer

Class TGLNonVisualViewer

Unit

GLScene

Declaration

type TGLNonVisualViewer = class(TComponent)

Description

Base class for non-visual viewer.<p> Non-visual viewer may actually render visuals, but they are non-visual (ie. non interactive) at design time. Such viewers include memory or full-screen viewers.

Hierarchy

  • TComponent
  • TGLNonVisualViewer

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function GetAfterRender: TNotifyEvent;
Protected | function GetBeforeRender: TNotifyEvent;
Protected | function GetCamera: TGLCamera;
Protected | function GetPostRender: TNotifyEvent;
Public | procedure CopyToTexture(aTexture: TGLTexture); overload; virtual;
Public | procedure CopyToTexture(aTexture: TGLTexture; xSrc, ySrc, width, height: Integer; xDest, yDest: Integer); overload;
Public | procedure CopyToTextureMRT(aTexture: TGLTexture; xSrc, ySrc, width, height: Integer; xDest, yDest: Integer; BufferIndex: integer); overload;
Public | procedure CopyToTextureMRT(aTexture: TGLTexture; BufferIndex: integer); overload; virtual;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure Render(baseObject: TGLBaseSceneObject = nil); virtual; abstract;
Public | procedure RenderCubeMapTextures(cubeMapTexture: TGLTexture; zNear: Single = 0; zFar: Single = 0);
Protected | procedure DoBufferChange(Sender: TObject); virtual;
Protected | procedure DoBufferStructuralChange(Sender: TObject); virtual;
Protected | procedure DoOnPrepareGLContext(Sender: TObject);
Protected | procedure PrepareGLContext; dynamic;
Protected | procedure SetAfterRender(const val: TNotifyEvent);
Protected | procedure SetBeforeRender(const val: TNotifyEvent);
Protected | procedure SetBuffer(const val: TGLSceneBuffer);
Protected | procedure SetCamera(const val: TGLCamera);
Protected | procedure SetHeight(const val: Integer);
Protected | procedure SetPostRender(const val: TNotifyEvent);
Protected | procedure SetupCubeMapCamera(Sender: TObject);
Protected | procedure SetWidth(const val: Integer);

Properties

Published | property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;
Published | property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;
Published | property Buffer: TGLSceneBuffer read FBuffer write SetBuffer;
Published | property Camera: TGLCamera read GetCamera write SetCamera;
Published | property Height: Integer read FHeight write SetHeight default 256;
Published | property PostRender: TNotifyEvent read GetPostRender write SetPostRender;
Published | property Width: Integer read FWidth write SetWidth default 256;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function GetAfterRender: TNotifyEvent;
Protected function GetBeforeRender: TNotifyEvent;
Protected function GetCamera: TGLCamera;
Protected function GetPostRender: TNotifyEvent;
Public procedure CopyToTexture(aTexture: TGLTexture); overload; virtual;
Public procedure CopyToTexture(aTexture: TGLTexture; xSrc, ySrc, width, height: Integer; xDest, yDest: Integer); overload;
Public procedure CopyToTextureMRT(aTexture: TGLTexture; xSrc, ySrc, width, height: Integer; xDest, yDest: Integer; BufferIndex: integer); overload;
Public procedure CopyToTextureMRT(aTexture: TGLTexture; BufferIndex: integer); overload; virtual;

CopyToTexture for Multiple-Render-Target

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure Render(baseObject: TGLBaseSceneObject = nil); virtual; abstract;
Public procedure RenderCubeMapTextures(cubeMapTexture: TGLTexture; zNear: Single = 0; zFar: Single = 0);

Renders the 6 texture maps from a scene.<p> The viewer is used to render the 6 images, one for each face of the cube, from the absolute position of the camera.<p> This does NOT alter the content of the Pictures in the image, and will only change or define the content of textures as registered by OpenGL.

Protected procedure DoBufferChange(Sender: TObject); virtual;
Protected procedure DoBufferStructuralChange(Sender: TObject); virtual;
Protected procedure DoOnPrepareGLContext(Sender: TObject);
Protected procedure PrepareGLContext; dynamic;
Protected procedure SetAfterRender(const val: TNotifyEvent);
Protected procedure SetBeforeRender(const val: TNotifyEvent);
Protected procedure SetBuffer(const val: TGLSceneBuffer);
Protected procedure SetCamera(const val: TGLCamera);
Protected procedure SetHeight(const val: Integer);
Protected procedure SetPostRender(const val: TNotifyEvent);
Protected procedure SetupCubeMapCamera(Sender: TObject);
Protected procedure SetWidth(const val: Integer);

Properties

Published property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;

Called after rendering.<p> You cannot issue OpenGL calls in this event, if you want to do your own OpenGL stuff, use the PostRender event.

Published property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;

Triggered before the scene's objects get rendered.<p> You may use this event to execute your own OpenGL rendering.

Published property Buffer: TGLSceneBuffer read FBuffer write SetBuffer;

Access to buffer properties.

Published property Camera: TGLCamera read GetCamera write SetCamera;

Camera from which the scene is rendered.

Published property Height: Integer read FHeight write SetHeight default 256;
Published property PostRender: TNotifyEvent read GetPostRender write SetPostRender;

Triggered just after all the scene's objects have been rendered.<p> The OpenGL context is still active in this event, and you may use it to execute your own OpenGL rendering.<p>

Published property Width: Integer read FWidth write SetWidth default 256;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:42


GLScene v.1.1.2: GLScene: Class TGLMemoryViewer

Class TGLMemoryViewer

Unit

GLScene

Declaration

type TGLMemoryViewer = class(TGLNonVisualViewer)

Description

Component to render a scene to memory only.<p> This component curently requires that the OpenGL ICD supports the WGL_ARB_pbuffer extension (indirectly).

Hierarchy

  • TComponent
  • TGLNonVisualViewer
  • TGLMemoryViewer

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure InstantiateRenderingContext;
Public | procedure Render(baseObject: TGLBaseSceneObject = nil); override;

Properties

Published property BufferCount: integer read FBufferCount write SetBufferCount default 1;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure InstantiateRenderingContext;
Public procedure Render(baseObject: TGLBaseSceneObject = nil); override;

Properties

Published property BufferCount: integer read FBufferCount write SetBufferCount default 1;

Set BufferCount > 1 for multiple render targets. <p> Users should check if the corresponding extension (GL_ATI_draw_buffers) is supported. Current hardware limit is BufferCount = 4.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:42


GLScene v.1.1.2: GLScene.FMX.Viewer

Unit GLScene.FMX.Viewer

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:42


GLScene v.1.1.2: GLSceneEdit

Unit GLSceneEdit

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSceneEdit<p>

Scene Editor, for adding + removing scene objects within the Delphi IDE.<p>

<b>History : </b><font size=-1><ul> <li>20/01/10 - Yar - TGLSceneEditorForm.IsPastePossible now uses CharInSet <li>20/01/10 - Yar - Added Expand and Collapse buttons (thanks to lolo) <li>14/03/09 - DanB - Removed Cameras node, instead cameras are now placed into scene <li>19/03/08 - mrqzzz - Little change to "stay on top" (references self, not GLSceneEditorForm ) <li>17/03/08 - mrqzzz - By dAlex: Added "stay on top" button <li>12/07/07 - DaStr - Improved cross-platform compatibility (BugTrackerID=1684432) <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>25/03/07 - DaStr - Abstracted IsSubComponent for Delphi5 compatibility <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTrackerID=1681585) <li>07/02/07 - DaStr - TGLSceneEditorForm.ACDeleteObjectExecute bugfixed TGLSceneEditorForm.AddNodes - removed warning (all for proper Subcomponent support) <li>20/01/07 - DaStr - TGLSceneEditorForm.ACCutExecute bugfixed <li>19/12/06 - DaStr - TGLSceneEditorForm.AddNodes bugfixed - SubComponents are no longer displayed in the Editor (BugTraker ID = 1585913) <li>24/06/06 - PvD - Fixed bug with DELETE key when editing name in Treeview <li>03/07/04 - LR - Updated for Linux <li>18/12/04 - PhP - Added support for deleting objects/effects/behaviours by pressing "Delete" <li>03/07/04 - LR - Make change for Linux <li>14/12/03 - EG - Paste fix (Mrqzzz) <li>31/06/03 - EG - Cosmetic changes, form position/state now saved to the registry <li>21/06/03 - DanB - Added behaviours/effects listviews <li>22/01/02 - EG - Fixed controls state after drag/drop (Anton Zhuchkov) <li>06/08/00 - EG - Added basic Clipboard support <li>14/05/00 - EG - Added workaround for VCL DesignInfo bug (thx Nelson Chu) <li>28/04/00 - EG - Fixed new objects not being immediately reco by IDE <li>26/04/00 - EG - Added support for objects categories <li>17/04/00 - EG - Added access to TInfoForm <li>16/04/00 - EG - Fixed occasionnal crash when rebuilding GLScene dpk while GLSceneEdit is visible <li>10/04/00 - EG - Minor Create/Release change <li>24/03/00 - EG - Fixed SetScene not updating enablings <li>13/03/00 - EG - Object names (ie. node text) is now properly adjusted when a GLScene object is renamed, Added Load/Save whole scene <li>07/02/00 - EG - Fixed notification logic <li>06/02/00 - EG - DragDrop now starts after moving the mouse a little, Form is now auto-creating, fixed Notification, Added actionlist and moveUp/moveDown <li>05/02/00 - EG - Fixed DragDrop, added root nodes auto-expansion </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSceneEditorForm |

Functions and Procedures

function GLSceneEditorForm: TGLSceneEditorForm;
procedure ReleaseGLSceneEditorForm;

Types

TSetSubItemsEvent = procedure(Sender: TObject) of object;

Constants

SCENE_SELECTED = 0;
BEHAVIOURS_SELECTED = 1;
EFFECTS_SELECTED = 2;

Description

Functions and Procedures

function GLSceneEditorForm: TGLSceneEditorForm;
procedure ReleaseGLSceneEditorForm;

Types

TSetSubItemsEvent = procedure(Sender: TObject) of object;

Constants

SCENE_SELECTED = 0;
BEHAVIOURS_SELECTED = 1;
EFFECTS_SELECTED = 2;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:42


GLScene v.1.1.2: GLSceneEdit: Class TGLSceneEditorForm

Class TGLSceneEditorForm

Unit

GLSceneEdit

Declaration

type TGLSceneEditorForm = class(TForm)

Description

Hierarchy

  • TForm
  • TGLSceneEditorForm

Overview

Fields

Published | Tree: TTreeView;
Published | PopupMenu: TPopupMenu;
Published | MIAddCamera: TMenuItem;
Published | MIAddObject: TMenuItem;
Published | N1: TMenuItem;
Published | MIDelObject: TMenuItem;
Published | ToolBar: TToolBar;
Published | ActionList: TActionList;
Published | ToolButton1: TToolButton;
Published | TBAddObjects: TToolButton;
Published | ToolButton4: TToolButton;
Published | PMToolBar: TPopupMenu;
Published | ToolButton5: TToolButton;
Published | ToolButton7: TToolButton;
Published | ACAddCamera: TAction;
Published | ACAddObject: TAction;
Published | ImageList: TImageList;
Published | ACDeleteObject: TAction;
Published | ACMoveUp: TAction;
Published | ACMoveDown: TAction;
Published | N2: TMenuItem;
Published | Moveobjectup1: TMenuItem;
Published | Moveobjectdown1: TMenuItem;
Published | ACSaveScene: TAction;
Published | ACLoadScene: TAction;
Published | OpenDialog: TOpenDialog;
Published | SaveDialog: TSaveDialog;
Published | ToolButton8: TToolButton;
Published | ToolButton9: TToolButton;
Published | ACInfo: TAction;
Published | ACCopy: TAction;
Published | ACCut: TAction;
Published | ACPaste: TAction;
Published | Copy1: TMenuItem;
Published | Paste1: TMenuItem;
Published | Cut1: TMenuItem;
Published | ToolButton12: TToolButton;
Published | ToolButton13: TToolButton;
Published | ToolButton14: TToolButton;
Published | PABehaviours: TPanel;
Published | BehavioursListView: TListView;
Published | Splitter3: TSplitter;
Published | EffectsListView: TListView;
Published | Splitter: TSplitter;
Published | PMBehavioursToolbar: TPopupMenu;
Published | ACAddBehaviour: TAction;
Published | MIAddBehaviour: TMenuItem;
Published | MIAddEffect: TMenuItem;
Published | MIBehaviourSeparator: TMenuItem;
Published | ACDeleteBehaviour: TAction;
Published | BehavioursPopupMenu: TPopupMenu;
Published | Delete1: TMenuItem;
Published | MoveUp1: TMenuItem;
Published | MoveDown1: TMenuItem;
Published | N4: TMenuItem;
Published | Label1: TLabel;
Published | Label2: TLabel;
Published | PMEffectsToolbar: TPopupMenu;
Published | ACAddEffect: TAction;
Published | ToolBar1: TToolBar;
Published | TBAddBehaviours: TToolButton;
Published | TBAddEffects: TToolButton;
Published | TBEffectsPanel: TToolButton;
Published | TBStayOnTop: TToolButton;
Published | ACStayOnTop: TAction;
Published | ToolButton10: TToolButton;
Published | ToolButton15: TToolButton;
Published | ToolButton16: TToolButton;
Published | ACExpand: TAction;
Published | ACColapse: TAction;

Methods

Published | procedure ACAddBehaviourExecute(Sender: TObject);
Published | procedure ACAddCameraExecute(Sender: TObject);
Published | procedure ACAddEffectExecute(Sender: TObject);
Published | procedure ACAddObjectExecute(Sender: TObject);
Published | procedure ACColapseExecute(Sender: TObject);
Published | procedure ACCopyExecute(Sender: TObject);
Published | procedure ACCutExecute(Sender: TObject);
Published | procedure ACDeleteObjectExecute(Sender: TObject);
Published | procedure ACExpandExecute(Sender: TObject);
Published | procedure ACInfoExecute(Sender: TObject);
Published | procedure ACLoadSceneExecute(Sender: TObject);
Published | procedure ACMoveDownExecute(Sender: TObject);
Published | procedure ACMoveUpExecute(Sender: TObject);
Published | procedure ACPasteExecute(Sender: TObject);
Published | procedure ACSaveSceneExecute(Sender: TObject);
Published | procedure ACStayOnTopExecute(Sender: TObject);
Published | procedure BehavioursListViewEnter(Sender: TObject);
Published | procedure BehavioursListViewSelectItem(Sender: TObject; Item: TListItem; Selected: Boolean);
Published | procedure DeleteBaseBehaviour(ListView: TListView);
Published | procedure EffectsListViewEnter(Sender: TObject);
Published | procedure FormCreate(Sender: TObject);
Published | procedure FormDestroy(Sender: TObject);
Published | procedure FormKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);
Published | procedure PMBehavioursToolbarPopup(Sender: TObject);
Published | procedure PMEffectsToolbarPopup(Sender: TObject);
Published | procedure PopupMenuPopup(Sender: TObject);
Published | procedure TBEffectsPanelClick(Sender: TObject);
Published | procedure TreeChange(Sender: TObject; Node: TTreeNode);
Published | procedure TreeDragDrop(Sender, Source: TObject; X, Y: Integer);
Published | procedure TreeDragOver(Sender, Source: TObject; X, Y: Integer; State: TDragState; var Accept: Boolean);
Published | procedure TreeEditing(Sender: TObject; Node: TTreeNode; var AllowEdit: Boolean);
Published | procedure TreeEnter(Sender: TObject);
Published | procedure TreeKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);
Published | procedure TreeMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure TreeMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Public | procedure SetScene(Scene: TGLScene; Designer: IFormDesigner);
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Description

Fields

Published Tree: TTreeView;
Published PopupMenu: TPopupMenu;
Published MIAddCamera: TMenuItem;
Published MIAddObject: TMenuItem;
Published N1: TMenuItem;
Published MIDelObject: TMenuItem;
Published ToolBar: TToolBar;
Published ActionList: TActionList;
Published ToolButton1: TToolButton;
Published TBAddObjects: TToolButton;
Published ToolButton4: TToolButton;
Published PMToolBar: TPopupMenu;
Published ToolButton5: TToolButton;
Published ToolButton7: TToolButton;
Published ACAddCamera: TAction;
Published ACAddObject: TAction;
Published ImageList: TImageList;
Published ACDeleteObject: TAction;
Published ACMoveUp: TAction;
Published ACMoveDown: TAction;
Published N2: TMenuItem;
Published Moveobjectup1: TMenuItem;
Published Moveobjectdown1: TMenuItem;
Published ACSaveScene: TAction;
Published ACLoadScene: TAction;
Published OpenDialog: TOpenDialog;
Published SaveDialog: TSaveDialog;
Published ToolButton8: TToolButton;
Published ToolButton9: TToolButton;
Published ACInfo: TAction;
Published ACCopy: TAction;
Published ACCut: TAction;
Published ACPaste: TAction;
Published Copy1: TMenuItem;
Published Paste1: TMenuItem;
Published Cut1: TMenuItem;
Published ToolButton12: TToolButton;
Published ToolButton13: TToolButton;
Published ToolButton14: TToolButton;
Published PABehaviours: TPanel;
Published BehavioursListView: TListView;
Published Splitter3: TSplitter;
Published EffectsListView: TListView;
Published Splitter: TSplitter;
Published PMBehavioursToolbar: TPopupMenu;
Published ACAddBehaviour: TAction;
Published MIAddBehaviour: TMenuItem;
Published MIAddEffect: TMenuItem;
Published MIBehaviourSeparator: TMenuItem;
Published ACDeleteBehaviour: TAction;
Published BehavioursPopupMenu: TPopupMenu;
Published Delete1: TMenuItem;
Published MoveUp1: TMenuItem;
Published MoveDown1: TMenuItem;
Published N4: TMenuItem;
Published Label1: TLabel;
Published Label2: TLabel;
Published PMEffectsToolbar: TPopupMenu;
Published ACAddEffect: TAction;
Published ToolBar1: TToolBar;
Published TBAddBehaviours: TToolButton;
Published TBAddEffects: TToolButton;
Published TBEffectsPanel: TToolButton;
Published TBStayOnTop: TToolButton;
Published ACStayOnTop: TAction;
Published ToolButton10: TToolButton;
Published ToolButton15: TToolButton;
Published ToolButton16: TToolButton;
Published ACExpand: TAction;
Published ACColapse: TAction;

Methods

Published procedure ACAddBehaviourExecute(Sender: TObject);
Published procedure ACAddCameraExecute(Sender: TObject);
Published procedure ACAddEffectExecute(Sender: TObject);
Published procedure ACAddObjectExecute(Sender: TObject);
Published procedure ACColapseExecute(Sender: TObject);
Published procedure ACCopyExecute(Sender: TObject);
Published procedure ACCutExecute(Sender: TObject);
Published procedure ACDeleteObjectExecute(Sender: TObject);
Published procedure ACExpandExecute(Sender: TObject);
Published procedure ACInfoExecute(Sender: TObject);
Published procedure ACLoadSceneExecute(Sender: TObject);
Published procedure ACMoveDownExecute(Sender: TObject);
Published procedure ACMoveUpExecute(Sender: TObject);
Published procedure ACPasteExecute(Sender: TObject);
Published procedure ACSaveSceneExecute(Sender: TObject);
Published procedure ACStayOnTopExecute(Sender: TObject);
Published procedure BehavioursListViewEnter(Sender: TObject);
Published procedure BehavioursListViewSelectItem(Sender: TObject; Item: TListItem; Selected: Boolean);
Published procedure DeleteBaseBehaviour(ListView: TListView);
Published procedure EffectsListViewEnter(Sender: TObject);
Published procedure FormCreate(Sender: TObject);
Published procedure FormDestroy(Sender: TObject);
Published procedure FormKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);
Published procedure PMBehavioursToolbarPopup(Sender: TObject);
Published procedure PMEffectsToolbarPopup(Sender: TObject);
Published procedure PopupMenuPopup(Sender: TObject);
Published procedure TBEffectsPanelClick(Sender: TObject);
Published procedure TreeChange(Sender: TObject; Node: TTreeNode);
Published procedure TreeDragDrop(Sender, Source: TObject; X, Y: Integer);
Published procedure TreeDragOver(Sender, Source: TObject; X, Y: Integer; State: TDragState; var Accept: Boolean);
Published procedure TreeEditing(Sender: TObject; Node: TTreeNode; var AllowEdit: Boolean);
Published procedure TreeEnter(Sender: TObject);
Published procedure TreeKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);
Published procedure TreeMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure TreeMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Public procedure SetScene(Scene: TGLScene; Designer: IFormDesigner);
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:42


GLScene v.1.1.2: GLSceneEditLCL

Unit GLSceneEditLCL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSceneEdit<p>

Scene Editor, for adding + removing scene objects within the Delphi IDE.<p>

<b>History : </b><font size=-1><ul> <li>20/05/10 - Yar - Fixes for Linux x64 <li>18/05/10 - Yar - Fixed for Lazarus-0.9.29-25483 (thanks Predator) <li>26/03/10 - Yar - Added Expand and Collapse buttons, fix for Unix-based systems (thanks to Rustam Asmandiarov aka Predator) <li>14/03/09 - DanB - Removed Cameras node, instead cameras are now placed into scene <li>19/03/08 - mrqzzz - Little change to "stay on top" (references self, not GLSceneEditorForm ) <li>17/03/08 - mrqzzz - By dAlex: Added "stay on top" button <li>12/07/07 - DaStr - Improved cross-platform compatibility (BugTrackerID=1684432) <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>25/03/07 - DaStr - Abstracted IsSubComponent for Delphi5 compatibility <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTrackerID=1681585) <li>07/02/07 - DaStr - TGLSceneEditorForm.ACDeleteObjectExecute bugfixed TGLSceneEditorForm.AddNodes - removed warning (all for proper Subcomponent support) <li>20/01/07 - DaStr - TGLSceneEditorForm.ACCutExecute bugfixed <li>19/12/06 - DaStr - TGLSceneEditorForm.AddNodes bugfixed - SubComponents are no longer displayed in the Editor (BugTraker ID = 1585913) <li>24/06/06 - PvD - Fixed bug with DELETE key when editing name in Treeview <li>03/07/04 - LR - Updated for Linux <li>18/12/04 - PhP - Added support for deleting objects/effects/behaviours by pressing "Delete" <li>03/07/04 - LR - Make change for Linux <li>14/12/03 - EG - Paste fix (Mrqzzz) <li>31/06/03 - EG - Cosmetic changes, form position/state now saved to the registry <li>21/06/03 - DanB - Added behaviours/effects listviews <li>22/01/02 - EG - Fixed controls state after drag/drop (Anton Zhuchkov) <li>06/08/00 - EG - Added basic Clipboard support <li>14/05/00 - EG - Added workaround for VCL DesignInfo bug (thx Nelson Chu) <li>28/04/00 - EG - Fixed new objects not being immediately reco by IDE <li>26/04/00 - EG - Added support for objects categories <li>17/04/00 - EG - Added access to TInfoForm <li>16/04/00 - EG - Fixed occasionnal crash when rebuilding GLScene dpk while GLSceneEdit is visible <li>10/04/00 - EG - Minor Create/Release change <li>24/03/00 - EG - Fixed SetScene not updating enablings <li>13/03/00 - EG - Object names (ie. node text) is now properly adjusted when a GLScene object is renamed, Added Load/Save whole scene <li>07/02/00 - EG - Fixed notification logic <li>06/02/00 - EG - DragDrop now starts after moving the mouse a little, Form is now auto-creating, fixed Notification, Added actionlist and moveUp/moveDown <li>05/02/00 - EG - Fixed DragDrop, added root nodes auto-expansion </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSceneEditorForm |

Functions and Procedures

function GLSceneEditorForm : TGLSceneEditorForm;
procedure ReleaseGLSceneEditorForm;

Types

TSetSubItemsEvent = procedure(Sender:TObject) of object;

Constants

SCENE_SELECTED=0;
BEHAVIOURS_SELECTED=1;
EFFECTS_SELECTED=2;

Description

Functions and Procedures

function GLSceneEditorForm : TGLSceneEditorForm;
procedure ReleaseGLSceneEditorForm;

Types

TSetSubItemsEvent = procedure(Sender:TObject) of object;

Constants

SCENE_SELECTED=0;
BEHAVIOURS_SELECTED=1;
EFFECTS_SELECTED=2;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:42


GLScene v.1.1.2: GLSceneEditLCL: Class TGLSceneEditorForm

Class TGLSceneEditorForm

Unit

GLSceneEditLCL

Declaration

type TGLSceneEditorForm = class(TForm)

Description

Hierarchy

  • TForm
  • TGLSceneEditorForm

Overview

Fields

Published | MenuItem1: TMenuItem;
Published | ToolBar2: TToolBar;
Published | ToolButton10: TToolButton;
Published | ToolButton11: TToolButton;
Published | ToolButton12: TToolButton;
Published | ToolButton13: TToolButton;
Published | ToolButton14: TToolButton;
Published | ToolButton15: TToolButton;
Published | ToolButton2: TToolButton;
Published | ToolButton3: TToolButton;
Published | ToolButton4: TToolButton;
Published | ToolButton5: TToolButton;
Published | ToolButton6: TToolButton;
Published | ToolButton7: TToolButton;
Published | Tree: TTreeView;
Published | PopupMenu: TPopupMenu;
Published | MIAddCamera: TMenuItem;
Published | MIAddObject: TMenuItem;
Published | N1: TMenuItem;
Published | MIDelObject: TMenuItem;
Published | ToolBar: TToolBar;
Published | ActionList: TActionList;
Published | ToolButton1: TToolButton;
Published | TBAddObjects: TToolButton;
Published | PMToolBar: TPopupMenu;
Published | ACAddCamera: TAction;
Published | ACAddObject: TAction;
Published | ImageList: TImageList;
Published | ACDeleteObject: TAction;
Published | ACMoveUp: TAction;
Published | ACMoveDown: TAction;
Published | N2: TMenuItem;
Published | Moveobjectup1: TMenuItem;
Published | Moveobjectdown1: TMenuItem;
Published | ACSaveScene: TAction;
Published | ACLoadScene: TAction;
Published | OpenDialog: TOpenDialog;
Published | SaveDialog: TSaveDialog;
Published | ToolButton8: TToolButton;
Published | ToolButton9: TToolButton;
Published | ACInfo: TAction;
Published | ACCopy: TAction;
Published | ACCut: TAction;
Published | ACPaste: TAction;
Published | Copy1: TMenuItem;
Published | Paste1: TMenuItem;
Published | Cut1: TMenuItem;
Published | PABehaviours: TPanel;
Published | BehavioursListView: TListView;
Published | Splitter3: TSplitter;
Published | EffectsListView: TListView;
Published | Splitter: TSplitter;
Published | PMBehavioursToolbar: TPopupMenu;
Published | ACAddBehaviour: TAction;
Published | MIAddBehaviour: TMenuItem;
Published | MIAddEffect: TMenuItem;
Published | MIBehaviourSeparator: TMenuItem;
Published | ACDeleteBehaviour: TAction;
Published | BehavioursPopupMenu: TPopupMenu;
Published | Delete1: TMenuItem;
Published | MoveUp1: TMenuItem;
Published | MoveDown1: TMenuItem;
Published | N4: TMenuItem;
Published | Label1: TLabel;
Published | Label2: TLabel;
Published | PMEffectsToolbar: TPopupMenu;
Published | ACAddEffect: TAction;
Published | ToolBar1: TToolBar;
Published | TBAddBehaviours: TToolButton;
Published | TBAddEffects: TToolButton;
Published | TBEffectsPanel: TToolButton;
Published | TBStayOnTop: TToolButton;
Published | ACStayOnTop: TAction;

Methods

Published | procedure ACAddBehaviourExecute(Sender: TObject);
Published | procedure ACAddCameraExecute(Sender: TObject);
Published | procedure ACAddEffectExecute(Sender: TObject);
Published | procedure ACAddObjectExecute(Sender: TObject);
Published | procedure ACCopyExecute(Sender: TObject);
Published | procedure ACCutExecute(Sender: TObject);
Published | procedure ACDeleteObjectExecute(Sender: TObject);
Published | procedure ACInfoExecute(Sender: TObject);
Published | procedure ACLoadSceneExecute(Sender: TObject);
Published | procedure ACMoveDownExecute(Sender: TObject);
Published | procedure ACMoveUpExecute(Sender: TObject);
Published | procedure ACPasteExecute(Sender: TObject);
Published | procedure ACSaveSceneExecute(Sender: TObject);
Published | procedure ACStayOnTopExecute(Sender: TObject);
Published | procedure BehavioursListViewClick(Sender: TObject);
Published | procedure BehavioursListViewSelectItem(Sender: TObject; Item: TListItem; Selected: Boolean);
Published | procedure DeleteBaseBehaviour(ListView:TListView);
Published | procedure EffectsListViewClick(Sender: TObject);
Published | procedure FormClose(Sender: TObject; var CloseAction: TCloseAction);
Published | procedure FormCreate(Sender: TObject);
Published | procedure FormDestroy(Sender: TObject);
Published | procedure PMBehavioursToolbarPopup(Sender: TObject);
Published | procedure PMEffectsToolbarPopup(Sender: TObject);
Published | procedure PopupMenuPopup(Sender: TObject);
Published | procedure TBEffectsPanelClick(Sender: TObject);
Published | procedure ToolButton10Click(Sender: TObject);
Published | procedure ToolButton15Click(Sender: TObject);
Published | procedure TreeChange(Sender: TObject; Node: TTreeNode);
Published | procedure TreeDragDrop(Sender, Source: TObject; X, Y: Integer);
Published | procedure TreeDragOver(Sender, Source: TObject; X, Y: Integer; State: TDragState; var Accept: Boolean);
Published | procedure TreeEditing(Sender: TObject; Node: TTreeNode; var AllowEdit: Boolean);
Published | procedure TreeEnter(Sender: TObject);
Published | procedure TreeKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);
Published | procedure TreeMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure TreeMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Public | procedure SetScene(AScene : TGLScene; ADesigner : TComponentEditorDesigner);
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Description

Fields

Published MenuItem1: TMenuItem;
Published ToolBar2: TToolBar;
Published ToolButton10: TToolButton;
Published ToolButton11: TToolButton;
Published ToolButton12: TToolButton;
Published ToolButton13: TToolButton;
Published ToolButton14: TToolButton;
Published ToolButton15: TToolButton;
Published ToolButton2: TToolButton;
Published ToolButton3: TToolButton;
Published ToolButton4: TToolButton;
Published ToolButton5: TToolButton;
Published ToolButton6: TToolButton;
Published ToolButton7: TToolButton;
Published Tree: TTreeView;
Published PopupMenu: TPopupMenu;
Published MIAddCamera: TMenuItem;
Published MIAddObject: TMenuItem;
Published N1: TMenuItem;
Published MIDelObject: TMenuItem;
Published ToolBar: TToolBar;
Published ActionList: TActionList;
Published ToolButton1: TToolButton;
Published TBAddObjects: TToolButton;
Published PMToolBar: TPopupMenu;
Published ACAddCamera: TAction;
Published ACAddObject: TAction;
Published ImageList: TImageList;
Published ACDeleteObject: TAction;
Published ACMoveUp: TAction;
Published ACMoveDown: TAction;
Published N2: TMenuItem;
Published Moveobjectup1: TMenuItem;
Published Moveobjectdown1: TMenuItem;
Published ACSaveScene: TAction;
Published ACLoadScene: TAction;
Published OpenDialog: TOpenDialog;
Published SaveDialog: TSaveDialog;
Published ToolButton8: TToolButton;
Published ToolButton9: TToolButton;
Published ACInfo: TAction;
Published ACCopy: TAction;
Published ACCut: TAction;
Published ACPaste: TAction;
Published Copy1: TMenuItem;
Published Paste1: TMenuItem;
Published Cut1: TMenuItem;
Published PABehaviours: TPanel;
Published BehavioursListView: TListView;
Published Splitter3: TSplitter;
Published EffectsListView: TListView;
Published Splitter: TSplitter;
Published PMBehavioursToolbar: TPopupMenu;
Published ACAddBehaviour: TAction;
Published MIAddBehaviour: TMenuItem;
Published MIAddEffect: TMenuItem;
Published MIBehaviourSeparator: TMenuItem;
Published ACDeleteBehaviour: TAction;
Published BehavioursPopupMenu: TPopupMenu;
Published Delete1: TMenuItem;
Published MoveUp1: TMenuItem;
Published MoveDown1: TMenuItem;
Published N4: TMenuItem;
Published Label1: TLabel;
Published Label2: TLabel;
Published PMEffectsToolbar: TPopupMenu;
Published ACAddEffect: TAction;
Published ToolBar1: TToolBar;
Published TBAddBehaviours: TToolButton;
Published TBAddEffects: TToolButton;
Published TBEffectsPanel: TToolButton;
Published TBStayOnTop: TToolButton;
Published ACStayOnTop: TAction;

Methods

Published procedure ACAddBehaviourExecute(Sender: TObject);
Published procedure ACAddCameraExecute(Sender: TObject);
Published procedure ACAddEffectExecute(Sender: TObject);
Published procedure ACAddObjectExecute(Sender: TObject);
Published procedure ACCopyExecute(Sender: TObject);
Published procedure ACCutExecute(Sender: TObject);
Published procedure ACDeleteObjectExecute(Sender: TObject);
Published procedure ACInfoExecute(Sender: TObject);
Published procedure ACLoadSceneExecute(Sender: TObject);
Published procedure ACMoveDownExecute(Sender: TObject);
Published procedure ACMoveUpExecute(Sender: TObject);
Published procedure ACPasteExecute(Sender: TObject);
Published procedure ACSaveSceneExecute(Sender: TObject);
Published procedure ACStayOnTopExecute(Sender: TObject);
Published procedure BehavioursListViewClick(Sender: TObject);
Published procedure BehavioursListViewSelectItem(Sender: TObject; Item: TListItem; Selected: Boolean);
Published procedure DeleteBaseBehaviour(ListView:TListView);
Published procedure EffectsListViewClick(Sender: TObject);
Published procedure FormClose(Sender: TObject; var CloseAction: TCloseAction);
Published procedure FormCreate(Sender: TObject);
Published procedure FormDestroy(Sender: TObject);
Published procedure PMBehavioursToolbarPopup(Sender: TObject);
Published procedure PMEffectsToolbarPopup(Sender: TObject);
Published procedure PopupMenuPopup(Sender: TObject);
Published procedure TBEffectsPanelClick(Sender: TObject);
Published procedure ToolButton10Click(Sender: TObject);
Published procedure ToolButton15Click(Sender: TObject);
Published procedure TreeChange(Sender: TObject; Node: TTreeNode);
Published procedure TreeDragDrop(Sender, Source: TObject; X, Y: Integer);
Published procedure TreeDragOver(Sender, Source: TObject; X, Y: Integer; State: TDragState; var Accept: Boolean);
Published procedure TreeEditing(Sender: TObject; Node: TTreeNode; var AllowEdit: Boolean);
Published procedure TreeEnter(Sender: TObject);
Published procedure TreeKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);
Published procedure TreeMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure TreeMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Public procedure SetScene(AScene : TGLScene; ADesigner : TComponentEditorDesigner);
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:42


GLScene v.1.1.2: GLSceneForm

Unit GLSceneForm

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLFullScreenVideoMode |
Class TGLSceneForm |
Class TGLSOpenGLForm |

Functions and Procedures

procedure GLRegisterWSComponent(aControl: TComponentClass);

Types

TGLFullScreenResolution = (...);

Description

Functions and Procedures

procedure GLRegisterWSComponent(aControl: TComponentClass);

Types

TGLFullScreenResolution = (...);

Defines how GLSceneForm will handle fullscreen request fcWindowMaximize: Use current resolution (just maximize form and hide OS bars) fcNearestResolution: Change to nearest valid resolution from current window size fcManualResolution: Use FFullScreenVideoMode settings

Values
  • fcUseCurrent:
  • fcNearestResolution:
  • fcManualResolution:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:42


GLScene v.1.1.2: GLSceneForm: Class TGLFullScreenVideoMode

Class TGLFullScreenVideoMode

Unit

GLSceneForm

Declaration

type TGLFullScreenVideoMode = class(TPersistent)

Description

Screen mode settings

Hierarchy

  • TPersistent
  • TGLFullScreenVideoMode

Overview

Methods

Public constructor Create(AOwner: TGLSceneForm);

Properties

Published | property AltTabSupportEnable: Boolean read FAltTabSupportEnable write SetAltTabSupportEnable default False;
Published | property ColorDepth: Integer read FColorDepth write FColorDepth;
Published | property Enabled: Boolean read FEnabled write SetEnabled default False;
Published | property Frequency: Integer read FFrequency write FFrequency;
Published | property Height: Integer read FHeight write FHeight;
Published | property ResolutionMode: TGLFullScreenResolution read FResolutionMode write FResolutionMode default fcUseCurrent;
Published | property Width: Integer read FWidth write FWidth;

Description

Methods

Public constructor Create(AOwner: TGLSceneForm);

Properties

Published property AltTabSupportEnable: Boolean read FAltTabSupportEnable write SetAltTabSupportEnable default False;
Published property ColorDepth: Integer read FColorDepth write FColorDepth;
Published property Enabled: Boolean read FEnabled write SetEnabled default False;
Published property Frequency: Integer read FFrequency write FFrequency;
Published property Height: Integer read FHeight write FHeight;
Published property ResolutionMode: TGLFullScreenResolution read FResolutionMode write FResolutionMode default fcUseCurrent;
Published property Width: Integer read FWidth write FWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneForm: Class TGLSceneForm

Class TGLSceneForm

Unit

GLSceneForm

Declaration

type TGLSceneForm = class(TForm)

Description

Hierarchy

  • TForm
  • TGLSceneForm

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DestroyWnd; override;
Protected | procedure CreateWnd; override;
Protected | procedure DoBeforeRender(Sender: TObject); dynamic;
Protected | procedure DoBufferChange(Sender: TObject); virtual;
Protected | procedure DoBufferStructuralChange(Sender: TObject); dynamic;
Protected | procedure Loaded; override;
Protected | procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;
Published | property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;
Published | property Buffer: TGLSceneBuffer read FBuffer write SetBuffer;
Published | property Camera: TGLCamera read GetCamera write SetCamera;
Published | property FieldOfView: single read GetFieldOfView write SetFieldOfView;
Published | property FullScreenVideoMode: TGLFullScreenVideoMode read FFullScreenVideoMode write SetFullScreenVideoMode;
Public | property IsRenderingContextAvailable: Boolean read GetIsRenderingContextAvailable;
Published | property PostRender: TNotifyEvent read GetPostRender write SetPostRender;
Public | property RenderDC: HDC read FOwnDC;
Published | property VSync: TVSyncMode read FVSync write FVSync default vsmNoSync;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure DestroyWnd; override;
Protected procedure CreateWnd; override;
Protected procedure DoBeforeRender(Sender: TObject); dynamic;
Protected procedure DoBufferChange(Sender: TObject); virtual;
Protected procedure DoBufferStructuralChange(Sender: TObject); dynamic;
Protected procedure Loaded; override;
Protected procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;
Published property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;
Published property Buffer: TGLSceneBuffer read FBuffer write SetBuffer;
Published property Camera: TGLCamera read GetCamera write SetCamera;
Published property FieldOfView: single read GetFieldOfView write SetFieldOfView;
Published property FullScreenVideoMode: TGLFullScreenVideoMode read FFullScreenVideoMode write SetFullScreenVideoMode;
Public property IsRenderingContextAvailable: Boolean read GetIsRenderingContextAvailable;
Published property PostRender: TNotifyEvent read GetPostRender write SetPostRender;
Public property RenderDC: HDC read FOwnDC;
Published property VSync: TVSyncMode read FVSync write FVSync default vsmNoSync;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneForm: Class TGLSOpenGLForm

Class TGLSOpenGLForm

Unit

GLSceneForm

Declaration

type TGLSOpenGLForm = class(TWin32WSForm)

Description

Hierarchy

  • TWin32WSForm
  • TGLSOpenGLForm

Overview

Methods

Published class function CreateHandle(const AWinControl: TWinControl; const AParams: TCreateParams): HWND; override;

Description

Methods

Published class function CreateHandle(const AWinControl: TWinControl; const AParams: TCreateParams): HWND; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneFormDesign

Unit GLSceneFormDesign

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSceneFormDesign<p>

<b>History : </b><font size=-1><ul> <li>03/04/11 - Yar - Added three project wizard for Delphi <li>05/12/10 - PREDATOR - Added three form wizard and three project wizard for Lazarus <li>23/08/10 - Yar - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSceneBaseFormDescriptor |
Class TGLSceneSimpleFormDescriptor |
Class TGLSceneExtendedFormDescriptor |
Class TGLSceneBaseFileDescriptor |
Class TGLSceneSimpleFileDescriptor |
Class TGLSceneExtendedFileDescriptor |

Functions and Procedures

procedure Register;

Constants

rBaseProjectLocalizedName = 'GLScene Base Application';
rBaseProjectLocalizedDescription = 'Template of GLScene Base Application with TGLSceneForm';
rSimpleProjectLocalizedName = 'GLScene Simple Application';
rSimpleProjectLocalizedDescription = 'Template of GLScene Simple Application with TGLSceneForm';
rExtendedProjectLocalizedName = 'GLScene Extended Application';
rExtendedProjectLocalizedDescription = 'Template of GLScene Extended Application with TGLSceneForm';
rBaseFormLocalizedName = 'GLSBaseForm';
rBaseFormLocalizedDescription = 'GLSceneForm - a special form, which combines '+ 'the properties of the viewer and the normal '+ 'form and allows you to render directly into '+ 'the application window';
rSimpleFormLocalizedName = 'GLSSimpleForm';
rSimpleFormLocalizedDescription = 'GLSSimpleForm - a special form, which '+ 'combines the properties viewer and the '+ 'usual form and contains the basic set of '+ 'components to create a simple application.';
rExtendedFormLocalizedName = 'GLSExtendedForm';
rExtendedFormLocalizedDescription = 'GLSExtendedForm - a special form, which '+ 'combines the properties viewer and the '+ 'usual form, and contains an expanded set '+ 'of components needed to create more '+ 'complex applications.';

Description

Functions and Procedures

procedure Register;

Constants

rBaseProjectLocalizedName = 'GLScene Base Application';
rBaseProjectLocalizedDescription = 'Template of GLScene Base Application with TGLSceneForm';
rSimpleProjectLocalizedName = 'GLScene Simple Application';
rSimpleProjectLocalizedDescription = 'Template of GLScene Simple Application with TGLSceneForm';
rExtendedProjectLocalizedName = 'GLScene Extended Application';
rExtendedProjectLocalizedDescription = 'Template of GLScene Extended Application with TGLSceneForm';
rBaseFormLocalizedName = 'GLSBaseForm';
rBaseFormLocalizedDescription = 'GLSceneForm - a special form, which combines '+ 'the properties of the viewer and the normal '+ 'form and allows you to render directly into '+ 'the application window';
rSimpleFormLocalizedName = 'GLSSimpleForm';
rSimpleFormLocalizedDescription = 'GLSSimpleForm - a special form, which '+ 'combines the properties viewer and the '+ 'usual form and contains the basic set of '+ 'components to create a simple application.';
rExtendedFormLocalizedName = 'GLSExtendedForm';
rExtendedFormLocalizedDescription = 'GLSExtendedForm - a special form, which '+ 'combines the properties viewer and the '+ 'usual form, and contains an expanded set '+ 'of components needed to create more '+ 'complex applications.';
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneFormDesign: Class TGLSceneBaseFormDescriptor

Class TGLSceneBaseFormDescriptor

Unit

GLSceneFormDesign

Declaration

type TGLSceneBaseFormDescriptor = class(TProjectDescriptor)

Description

Hierarchy

  • TProjectDescriptor
  • TGLSceneBaseFormDescriptor

Overview

Methods

Public | constructor Create; override;
Public | function CreateStartFiles(AProject: TLazProject): TModalResult; override;
Public | function DoInitDescriptor: TModalResult; override;
Public | function GetLocalizedDescription: string; override;
Public | function GetLocalizedName: string; override;
Public | function InitProject(AProject: TLazProject): TModalResult; override;

Description

Methods

Public constructor Create; override;
Public function CreateStartFiles(AProject: TLazProject): TModalResult; override;
Public function DoInitDescriptor: TModalResult; override;
Public function GetLocalizedDescription: string; override;
Public function GetLocalizedName: string; override;
Public function InitProject(AProject: TLazProject): TModalResult; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneFormDesign: Class TGLSceneSimpleFormDescriptor

Class TGLSceneSimpleFormDescriptor

Unit

GLSceneFormDesign

Declaration

type TGLSceneSimpleFormDescriptor = class(TGLSceneBaseFormDescriptor)

Description

no description available, TGLSceneBaseFormDescriptor description follows

Hierarchy

  • TProjectDescriptor
  • TGLSceneBaseFormDescriptor
  • TGLSceneSimpleFormDescriptor

Overview

Methods

Public | constructor Create; override;
Public | function CreateStartFiles(AProject: TLazProject): TModalResult; override;
Public | function GetLocalizedDescription: string; override;
Public | function GetLocalizedName: string; override;

Description

Methods

Public constructor Create; override;
Public function CreateStartFiles(AProject: TLazProject): TModalResult; override;
Public function GetLocalizedDescription: string; override;
Public function GetLocalizedName: string; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneFormDesign: Class TGLSceneExtendedFormDescriptor

Class TGLSceneExtendedFormDescriptor

Unit

GLSceneFormDesign

Declaration

type TGLSceneExtendedFormDescriptor = class(TGLSceneBaseFormDescriptor)

Description

no description available, TGLSceneBaseFormDescriptor description follows

Hierarchy

  • TProjectDescriptor
  • TGLSceneBaseFormDescriptor
  • TGLSceneExtendedFormDescriptor

Overview

Methods

Public | constructor Create; override;
Public | function CreateStartFiles(AProject: TLazProject): TModalResult; override;
Public | function GetLocalizedDescription: string; override;
Public | function GetLocalizedName: string; override;

Description

Methods

Public constructor Create; override;
Public function CreateStartFiles(AProject: TLazProject): TModalResult; override;
Public function GetLocalizedDescription: string; override;
Public function GetLocalizedName: string; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneFormDesign: Class TGLSceneBaseFileDescriptor

Class TGLSceneBaseFileDescriptor

Unit

GLSceneFormDesign

Declaration

type TGLSceneBaseFileDescriptor = class(TFileDescPascalUnitWithResource)

Description

Hierarchy

  • TFileDescPascalUnitWithResource
  • TGLSceneBaseFileDescriptor

Overview

Methods

Public | constructor Create; override;
Public | function CreateSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public | function GetImplementationSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public | function GetInterfaceSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public | function GetInterfaceUsesSection: string; override;
Public | function GetLocalizedDescription: string; override;
Public | function GetLocalizedName: string; override;
Public | function GetResourceSource(const ResourceName: string): string; override;

Description

Methods

Public constructor Create; override;
Public function CreateSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public function GetImplementationSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public function GetInterfaceSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public function GetInterfaceUsesSection: string; override;
Public function GetLocalizedDescription: string; override;
Public function GetLocalizedName: string; override;
Public function GetResourceSource(const ResourceName: string): string; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneFormDesign: Class TGLSceneSimpleFileDescriptor

Class TGLSceneSimpleFileDescriptor

Unit

GLSceneFormDesign

Declaration

type TGLSceneSimpleFileDescriptor = class(TGLSceneBaseFileDescriptor)

Description

no description available, TGLSceneBaseFileDescriptor description follows

Hierarchy

  • TFileDescPascalUnitWithResource
  • TGLSceneBaseFileDescriptor
  • TGLSceneSimpleFileDescriptor

Overview

Methods

Public | constructor Create; override;
Public | function CreateSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public | function GetImplementationSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public | function GetInterfaceSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public | function GetInterfaceUsesSection: string; override;
Public | function GetLocalizedDescription: string; override;
Public | function GetLocalizedName: string; override;
Public | function GetResourceSource(const ResourceName: string): string; override;

Description

Methods

Public constructor Create; override;
Public function CreateSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public function GetImplementationSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public function GetInterfaceSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public function GetInterfaceUsesSection: string; override;
Public function GetLocalizedDescription: string; override;
Public function GetLocalizedName: string; override;
Public function GetResourceSource(const ResourceName: string): string; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneFormDesign: Class TGLSceneExtendedFileDescriptor

Class TGLSceneExtendedFileDescriptor

Unit

GLSceneFormDesign

Declaration

type TGLSceneExtendedFileDescriptor = class(TGLSceneBaseFileDescriptor)

Description

no description available, TGLSceneBaseFileDescriptor description follows

Hierarchy

  • TFileDescPascalUnitWithResource
  • TGLSceneBaseFileDescriptor
  • TGLSceneExtendedFileDescriptor

Overview

Methods

Public | constructor Create; override;
Public | function CreateSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public | function GetImplementationSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public | function GetInterfaceSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public | function GetInterfaceUsesSection: string; override;
Public | function GetLocalizedDescription: string; override;
Public | function GetLocalizedName: string; override;
Public | function GetResourceSource(const ResourceName: string): string; override;

Description

Methods

Public constructor Create; override;
Public function CreateSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public function GetImplementationSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public function GetInterfaceSource(const Filename : string; const SourceName : string; const ResourceName : string): string; override;
Public function GetInterfaceUsesSection: string; override;
Public function GetLocalizedDescription: string; override;
Public function GetLocalizedName: string; override;
Public function GetResourceSource(const ResourceName: string): string; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister

Unit GLSceneRegister

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSceneRegister<p>

Registration unit for GLScene library components, property editors and IDE experts.<p>

<b>History : </b><font size=-1><ul> <li>15/06/11 - Yar - Improved GetGLSceneVersion (by lolo) <li>04/06/10 - Yar - Added GLSArchiveManager <li>20/04/10 - Yar - Added GLSLanguage <li>08/04/10 - Yar - Added code belonged section GLS_EXPERIMENTAL <li>22/01/10 - Yar - Added GLCompositeImage, GLFileDDS, GLFileO3TC, GLFileHDR to uses <li>07/05/09 - DanB - Added TGLSoundLibrarySelectionEditor, TGLBaseSceneObjectSelectionEditor <li>14/03/09 - DanB - Split TObjectManager to GLObjectManager.pas. Moved property editors to interface section, and made their methods public. <li>08/10/08 - DanB - Added DynamicTexture unit (to allow choosing this at designtime) + register TGLSLPostBlurShader <li>05/10/08 - DanB - Change required due Texture/TextureImageEditor separation + GLMisc split, tidied up some old ifdefs <li>24/03/08 - DaStr - Moved TGLMinFilter and TGLMagFilter from GLUtils.pas to GLGraphics.pas (BugTracker ID = 1923844) <li>21/03/08 - DaStr - Renamed TMMat to TGLTextureSharingShaderMaterial <li>17/03/08 - mrqzzz - Registered TGLTextureSharingShader <li>20/01/08 - DaStr - Registered TGLCapsule (thanks Dave Gravel) Registered TGLGizmo <li>06/11/07 - mrqzzz - Registered material picker for TGLActorProxy <li>18/09/07 - DaStr - Added TGLMaterialProxy, TGLAbsoluteHUDText, TGLResolutionIndependantHUDText <li>12/07/07 - DaStr - Improved Cross-Platform compatibility (Bugtracker ID = 1684432) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>23/03/07 - fig - Added TGLSLProjectedTextures <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTrackerID=1681585) <li>14/03/07 - DaStr - SpriteAnimation now makes use of TGLLibMaterialName's property editor <li>04/03/07 - DaStr - Added TGLPostShaderHolder <li>28/02/07 - LIN - Added GLShadowHDS <li>25/02/07 - DaStr - Added TGLPostEffect Moved all terrain components to a separate tab Moved all shader components registration here <li>23/02/07 - DaStr - Added TGLSLShader, TGLSLDiffuseSpecularShader, TGLSLBumpShader, TGLAsmShader, TGLShaderCombiner TGLSmoothNavigator, TGLSmoothUserInterface Moved TGLLibMaterialNameProperty to the interface section <li>21/02/07 - DaStr - Added TGLActorProxy and TGLMotionBlur <li>16/02/07 - DaStr - Added GLMaterialMultiProxy <li>15/02/07 - DaStr - Added GLConsole and GLAtmosphere <li>13/02/07 - LIN - Added GLAsyncHDS and GLTexturedHDS <li>06/02/07 - DaStr - Added GLSimpleNavigation <li>29/01/07 - DaStr - Added GLEParticleMasksManager, moved registration procedures from other units to this one <li>21/01/07 - DaStr - TGLLibMaterialNameProperty.Edit fixed (to support IGLMaterialLibrarySupported) <li>23/12/04 - PhP - "Animated Sprite" moved to advanced objects category <li>13/10/04 - MRQZZZ - Added GLTrail <li>03/07/04 - LR - Completly review to take account designtime for Linux Note a problem with TGLColorProperty <li>28/06/04 - LR - Changed LoadBitmap to GLLoadBitmapFromInstance <li>12/04/04 - EG - LibMaterialName property editor for SkyBox <li>22/08/02 - EG - RegisterPropertiesInCategory (Robin Gerrets) <li>08/04/02 - EG - Added verb to TGLSceneEditor <li>26/01/02 - EG - Color property drawing in D6 too now <li>22/08/01 - EG - D6 related changes <li>08/07/01 - EG - Register for TGLExtrusionSolid (Uwe Raabe) <li>18/02/01 - EG - Added Terrain/HeightData objects <li>21/01/01 - EG - Enhanced GetAttributes for some property editors <li>09/10/00 - EG - Added registration for TGLMultiPolygon <li>09/06/00 - EG - Added TSoundFileProperty & TSoundNameProperty <li>23/05/00 - EG - Added GLCollision <li>16/05/00 - EG - Delphi 4 Compatibility <li>28/04/00 - EG - Removed ObjectStock in TObjectManager (was useless) <li>26/04/00 - EG - Added Categories in ObjectManager, enhanced GetRegisteredSceneObjects <li>16/04/00 - EG - Objects icons are now loaded from ressources using ClassName (more VCL-like) <li>11/04/00 - EG - Components now install under 'GLScene', Fixed DestroySceneObjectList (thanks Uwe Raabe) <li>06/04/00 - EG - Added TGLBehavioursProperty <li>18/03/00 - EG - Added TGLImageClassProperty <li>13/03/00 - EG - Updated TGLTextureImageProperty <li>14/02/00 - EG - Added MaterialLibrary editor and picker <li>09/02/00 - EG - ObjectManager moved in, ObjectManager is now fully object-oriented and encapsulated <li>06/02/00 - EG - Fixed TGLScenedEditor logic (was causing Delphi IDE crashes on package unload) <li>05/02/00 - EG - Added TGLColorProperty and TGLCoordinatesProperty </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLLibMaterialNameProperty |
Class TGLSceneViewerEditor |
Class TGLSceneEditor |
Class TResolutionProperty |
Class TGLTextureProperty |
Class TGLTextureImageProperty |
Class TGLImageClassProperty |
Class TGLColorProperty |
Class TSoundFileProperty |
Class TSoundNameProperty |
Class TGLCoordinatesProperty |
Class TGLMaterialProperty |
Class TGLGUILayoutEditor |
Class TReuseableDefaultEditor |
Class TGLMaterialLibraryEditor |
Class TGLAnimationNameProperty |
Class TGLSArchiveManagerEditor |
Class TGLMaterialComponentNameProperty |
Class TGLLibTextureNameProperty |
Class TGLLibSamplerNameProperty |
Class TGLLibCombinerNameProperty |
Class TGLLibShaderNameProperty |
Class TGLLibAttachmentNameProperty |
Class TGLLibAsmProgNameProperty |
Class TPictureFileProperty |
Class TShaderFileProperty |
Class TAsmProgFileProperty |
Class TUniformAutoSetProperty |
Class TGLShaderEditorProperty |

Functions and Procedures

procedure Register;
function ObjectManager: TObjectManager;

Constants

sOpenGLCategoryName = 'OpenGL';

Description

Functions and Procedures

procedure Register;
function ObjectManager: TObjectManager;

Auto-create for object manager

Constants

sOpenGLCategoryName = 'OpenGL';
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLLibMaterialNameProperty

Class TGLLibMaterialNameProperty

Unit

GLSceneRegister

Declaration

type TGLLibMaterialNameProperty = class(TStringProperty)

Description

Hierarchy

  • TStringProperty
  • TGLLibMaterialNameProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public procedure Edit; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLSceneViewerEditor

Class TGLSceneViewerEditor

Unit

GLSceneRegister

Declaration

type TGLSceneViewerEditor = class(TComponentEditor)

Description

Hierarchy

  • TComponentEditor
  • TGLSceneViewerEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;
Public function GetVerbCount: Integer; override;
Public procedure ExecuteVerb(Index: Integer); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLSceneEditor

Class TGLSceneEditor

Unit

GLSceneRegister

Declaration

type TGLSceneEditor = class(TComponentEditor)

Description

Hierarchy

  • TComponentEditor
  • TGLSceneEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure Edit; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;
Public function GetVerbCount: Integer; override;
Public procedure Edit; override;
Public procedure ExecuteVerb(Index: Integer); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TResolutionProperty

Class TResolutionProperty

Unit

GLSceneRegister

Declaration

type TResolutionProperty = class(TPropertyEditor)

Description

Hierarchy

  • TPropertyEditor
  • TResolutionProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | function GetValue: string; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure SetValue(const Value: string); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public function GetValue: string; override;
Public procedure GetValues(Proc: TGetStrProc); override;
Public procedure SetValue(const Value: string); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLTextureProperty

Class TGLTextureProperty

Unit

GLSceneRegister

Declaration

type TGLTextureProperty = class(TClassProperty)

Description

Hierarchy

  • TClassProperty
  • TGLTextureProperty

Overview

Methods

Public function GetAttributes: TPropertyAttributes; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLTextureImageProperty

Class TGLTextureImageProperty

Unit

GLSceneRegister

Declaration

type TGLTextureImageProperty = class(TClassProperty)

Description

Hierarchy

  • TClassProperty
  • TGLTextureImageProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public procedure Edit; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLImageClassProperty

Class TGLImageClassProperty

Unit

GLSceneRegister

Declaration

type TGLImageClassProperty = class(TClassProperty)

Description

Hierarchy

  • TClassProperty
  • TGLImageClassProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | function GetValue: string; override;
Public | procedure GetValues(proc: TGetStrProc); override;
Public | procedure SetValue(const value: string); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public function GetValue: string; override;
Public procedure GetValues(proc: TGetStrProc); override;
Public procedure SetValue(const value: string); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLColorProperty

Class TGLColorProperty

Unit

GLSceneRegister

Declaration

type TGLColorProperty = class(TClassProperty, ICustomPropertyDrawing, ICustomPropertyListDrawing)

Description

Hierarchy

  • TClassProperty
  • TGLColorProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | function GetValue: string; override;
Protected | function ColorToBorderColor(aColor: TColorVector; selected: Boolean): TColor;
Public | procedure Edit; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure ListDrawValue(const Value: string; ACanvas: TCanvas; const ARect: TGLRect; ASelected: Boolean);
Public | procedure ListMeasureHeight(const Value: string; ACanvas: TCanvas; var AHeight: Integer);
Public | procedure ListMeasureWidth(const Value: string; ACanvas: TCanvas; var AWidth: Integer);
Public | procedure PropDrawName(ACanvas: TCanvas; const ARect: TGLRect; ASelected: Boolean);
Public | procedure PropDrawValue(ACanvas: TCanvas; const ARect: TGLRect; ASelected: Boolean);
Public | procedure SetValue(const Value: string); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public function GetValue: string; override;
Protected function ColorToBorderColor(aColor: TColorVector; selected: Boolean): TColor;
Public procedure Edit; override;
Public procedure GetValues(Proc: TGetStrProc); override;
Public procedure ListDrawValue(const Value: string; ACanvas: TCanvas; const ARect: TGLRect; ASelected: Boolean);
Public procedure ListMeasureHeight(const Value: string; ACanvas: TCanvas; var AHeight: Integer);
Public procedure ListMeasureWidth(const Value: string; ACanvas: TCanvas; var AWidth: Integer);
Public procedure PropDrawName(ACanvas: TCanvas; const ARect: TGLRect; ASelected: Boolean);
Public procedure PropDrawValue(ACanvas: TCanvas; const ARect: TGLRect; ASelected: Boolean);
Public procedure SetValue(const Value: string); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TSoundFileProperty

Class TSoundFileProperty

Unit

GLSceneRegister

Declaration

type TSoundFileProperty = class(TClassProperty)

Description

Hierarchy

  • TClassProperty
  • TSoundFileProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | function GetValue: string; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public function GetValue: string; override;
Public procedure Edit; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TSoundNameProperty

Class TSoundNameProperty

Unit

GLSceneRegister

Declaration

type TSoundNameProperty = class(TStringProperty)

Description

Hierarchy

  • TStringProperty
  • TSoundNameProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public procedure GetValues(Proc: TGetStrProc); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLCoordinatesProperty

Class TGLCoordinatesProperty

Unit

GLSceneRegister

Declaration

type TGLCoordinatesProperty = class(TClassProperty)

Description

Hierarchy

  • TClassProperty
  • TGLCoordinatesProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public procedure Edit; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLMaterialProperty

Class TGLMaterialProperty

Unit

GLSceneRegister

Declaration

type TGLMaterialProperty = class(TClassProperty)

Description

Hierarchy

  • TClassProperty
  • TGLMaterialProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public procedure Edit; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLGUILayoutEditor

Class TGLGUILayoutEditor

Unit

GLSceneRegister

Declaration

type TGLGUILayoutEditor = class(TComponentEditor)

Description

Hierarchy

  • TComponentEditor
  • TGLGUILayoutEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure Edit; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;
Public function GetVerbCount: Integer; override;
Public procedure Edit; override;
Public procedure ExecuteVerb(Index: Integer); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TReuseableDefaultEditor

Class TReuseableDefaultEditor

Unit

GLSceneRegister

Declaration

type TReuseableDefaultEditor = class(TComponentEditor)

Description

Editor copied from DsgnIntf.<p> Could have been avoided, if only that guy at Borland didn't chose to publish only half of the stuff (and that's not the only class with that problem, most of the subitems handling code in TGLSceneBaseObject is here for the same reason...), the "protected" wasn't meant just to lure programmers into code they can't reuse... Arrr! and he did that again in D6! Grrr...

Hierarchy

  • TComponentEditor
  • TReuseableDefaultEditor

Overview

Fields

Protected | FFirst: TPropertyEditor;
Protected | FBest: TPropertyEditor;
Protected | FContinue: Boolean;

Methods

Public | procedure Edit; override;
Protected | procedure CheckEdit(PropertyEditor: TPropertyEditor);
Protected | procedure EditProperty(PropertyEditor: TPropertyEditor; var Continue, FreeEditor: Boolean); virtual;

Description

Fields

Protected FFirst: TPropertyEditor;
Protected FBest: TPropertyEditor;
Protected FContinue: Boolean;

Methods

Public procedure Edit; override;
Protected procedure CheckEdit(PropertyEditor: TPropertyEditor);
Protected procedure EditProperty(PropertyEditor: TPropertyEditor; var Continue, FreeEditor: Boolean); virtual;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLMaterialLibraryEditor

Class TGLMaterialLibraryEditor

Unit

GLSceneRegister

Declaration

type TGLMaterialLibraryEditor = class(TReuseableDefaultEditor)

Description

Editor for material library.<p>

Hierarchy

  • TComponentEditor
  • TReuseableDefaultEditor
  • TGLMaterialLibraryEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure ExecuteVerb(Index: Integer); override;
Protected | procedure EditProperty(PropertyEditor: TPropertyEditor; var Continue, FreeEditor: Boolean); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;
Public function GetVerbCount: Integer; override;
Public procedure ExecuteVerb(Index: Integer); override;
Protected procedure EditProperty(PropertyEditor: TPropertyEditor; var Continue, FreeEditor: Boolean); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLAnimationNameProperty

Class TGLAnimationNameProperty

Unit

GLSceneRegister

Declaration

type TGLAnimationNameProperty = class(TStringProperty)

Description

Hierarchy

  • TStringProperty
  • TGLAnimationNameProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure GetValues(proc: TGetStrProc); override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public procedure GetValues(proc: TGetStrProc); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLSArchiveManagerEditor

Class TGLSArchiveManagerEditor

Unit

GLSceneRegister

Declaration

type TGLSArchiveManagerEditor = class(TReuseableDefaultEditor)

Description

Editor for GLScene Archive Manager.<p>

Hierarchy

  • TComponentEditor
  • TReuseableDefaultEditor
  • TGLSArchiveManagerEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure ExecuteVerb(Index: Integer); override;
Protected | procedure EditProperty(PropertyEditor: TPropertyEditor; var Continue, FreeEditor: Boolean); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;
Public function GetVerbCount: Integer; override;
Public procedure ExecuteVerb(Index: Integer); override;
Protected procedure EditProperty(PropertyEditor: TPropertyEditor; var Continue, FreeEditor: Boolean); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLMaterialComponentNameProperty

Class TGLMaterialComponentNameProperty

Unit

GLSceneRegister

Declaration

type TGLMaterialComponentNameProperty = class(TStringProperty)

Description

Hierarchy

  • TStringProperty
  • TGLMaterialComponentNameProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public procedure Edit; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLLibTextureNameProperty

Class TGLLibTextureNameProperty

Unit

GLSceneRegister

Declaration

type TGLLibTextureNameProperty = class(TGLMaterialComponentNameProperty)

Description

no description available, TGLMaterialComponentNameProperty description follows

Hierarchy

  • TStringProperty
  • TGLMaterialComponentNameProperty
  • TGLLibTextureNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLLibSamplerNameProperty

Class TGLLibSamplerNameProperty

Unit

GLSceneRegister

Declaration

type TGLLibSamplerNameProperty = class(TGLMaterialComponentNameProperty)

Description

no description available, TGLMaterialComponentNameProperty description follows

Hierarchy

  • TStringProperty
  • TGLMaterialComponentNameProperty
  • TGLLibSamplerNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLLibCombinerNameProperty

Class TGLLibCombinerNameProperty

Unit

GLSceneRegister

Declaration

type TGLLibCombinerNameProperty = class(TGLMaterialComponentNameProperty)

Description

no description available, TGLMaterialComponentNameProperty description follows

Hierarchy

  • TStringProperty
  • TGLMaterialComponentNameProperty
  • TGLLibCombinerNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLLibShaderNameProperty

Class TGLLibShaderNameProperty

Unit

GLSceneRegister

Declaration

type TGLLibShaderNameProperty = class(TGLMaterialComponentNameProperty)

Description

no description available, TGLMaterialComponentNameProperty description follows

Hierarchy

  • TStringProperty
  • TGLMaterialComponentNameProperty
  • TGLLibShaderNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLLibAttachmentNameProperty

Class TGLLibAttachmentNameProperty

Unit

GLSceneRegister

Declaration

type TGLLibAttachmentNameProperty = class(TGLMaterialComponentNameProperty)

Description

no description available, TGLMaterialComponentNameProperty description follows

Hierarchy

  • TStringProperty
  • TGLMaterialComponentNameProperty
  • TGLLibAttachmentNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLLibAsmProgNameProperty

Class TGLLibAsmProgNameProperty

Unit

GLSceneRegister

Declaration

type TGLLibAsmProgNameProperty = class(TGLMaterialComponentNameProperty)

Description

no description available, TGLMaterialComponentNameProperty description follows

Hierarchy

  • TStringProperty
  • TGLMaterialComponentNameProperty
  • TGLLibAsmProgNameProperty

Overview

Methods

Public procedure GetValues(Proc: TGetStrProc); override;

Description

Methods

Public procedure GetValues(Proc: TGetStrProc); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TPictureFileProperty

Class TPictureFileProperty

Unit

GLSceneRegister

Declaration

type TPictureFileProperty = class(TStringProperty)

Description

Hierarchy

  • TStringProperty
  • TPictureFileProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public procedure Edit; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TShaderFileProperty

Class TShaderFileProperty

Unit

GLSceneRegister

Declaration

type TShaderFileProperty = class(TStringProperty)

Description

Hierarchy

  • TStringProperty
  • TShaderFileProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public procedure Edit; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TAsmProgFileProperty

Class TAsmProgFileProperty

Unit

GLSceneRegister

Declaration

type TAsmProgFileProperty = class(TStringProperty)

Description

Hierarchy

  • TStringProperty
  • TAsmProgFileProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public procedure Edit; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TUniformAutoSetProperty

Class TUniformAutoSetProperty

Unit

GLSceneRegister

Declaration

type TUniformAutoSetProperty = class(TPropertyEditor)

Description

Hierarchy

  • TPropertyEditor
  • TUniformAutoSetProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public procedure Edit; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegister: Class TGLShaderEditorProperty

Class TGLShaderEditorProperty

Unit

GLSceneRegister

Declaration

type TGLShaderEditorProperty = class(TClassProperty)

Description

Hierarchy

  • TClassProperty
  • TGLShaderEditorProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Protected | function GetStrings: TStrings;
Public | procedure Edit; override;
Protected | procedure OnShaderCheck(Sender: TObject);
Protected | procedure SetStrings(const Value: TStrings);

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Protected function GetStrings: TStrings;
Public procedure Edit; override;
Protected procedure OnShaderCheck(Sender: TObject);
Protected procedure SetStrings(const Value: TStrings);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegisterLCL

Unit GLSceneRegisterLCL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSceneRegisterLCL<p>

Registration unit for GLScene library components, property editors and IDE experts for Lazarus.<p>

<b>History :</b><font size=-1><ul> <li>04/06/10 - Yar - Added GLSArchiveManager Fixes for Linux x64 <li>20/04/10 - Yar - Added GLSLanguage <li>08/04/10 - Yar - Added code belonged section GLS_EXPERIMENTAL <li>22/01/10 - Yar - Added GLCompositeImage, GLFileDDS, GLFileO3TC, GLFileHDR to uses <li>07/01/10 - DaStr - Added GLLCLFullScreenViewer and improved TResolutionProperty (thanks Predator) <li>24/11/09 - DanB - Removed some more windows only units <li>22/11/09 - DaStr - Improved Unix compatibility (again) <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>24/03/08 - DaStr - Initial version </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLLibMaterialNameProperty |

Functions and Procedures

procedure Register;
function ObjectManager: TObjectManager;

Description

Functions and Procedures

procedure Register;
function ObjectManager: TObjectManager;

Auto-create for object manager

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegisterLCL: Class TGLLibMaterialNameProperty

Class TGLLibMaterialNameProperty

Unit

GLSceneRegisterLCL

Declaration

type TGLLibMaterialNameProperty = class(TStringProperty)

Description

Hierarchy

  • TStringProperty
  • TGLLibMaterialNameProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public procedure Edit; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneRegisterWinOnlyLCL

Unit GLSceneRegisterWinOnlyLCL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSceneRegisterWinOnlyLCL<p>

Contains registration for Design-Time Lazarus Windows-Only units.<p> Because of Lazarus'es limitations, these need to be separated from the main GLSceneRegisterLCL.pas

<b>History :</b><font size=-1><ul> <li>07/01/10 - DaStr - Removed GLLCLFullScreenViewer because it became cross-platform (thanks Predator) <li>24/11/09 - DanB - Added some more windows only units <li>22/11/09 - DaStr - Initial version (by Predator) </ul></font>

Overview

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSceneToolbar

Unit GLSceneToolbar

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSComputingRegister

Unit GLSComputingRegister

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSComputingRegister<p>

Registration unit for GLScene Computing package.<p>

<b>History : </b><font size=-1><ul> <li>05/03/11 - Yar - Added TCUDAConstant, TCUDAFuncParam <li>22/08/10 - Yar - Some improvements for FPC (thanks Predator) <li>09/06/10 - Yar - Added dropdown list ProjectModule for TGLSCUDACompiler <li>19/03/10 - Yar - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSCUDAEditor |
Class TGLSCUDACompilerEditor |
Class TGLSCUDACompilerSourceProperty |
Class TGLSCUDADeviceProperty |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSComputingRegister: Class TGLSCUDAEditor

Class TGLSCUDAEditor

Unit

GLSComputingRegister

Declaration

type TGLSCUDAEditor = class(TComponentEditor)

Description

Hierarchy

  • TComponentEditor
  • TGLSCUDAEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure Edit; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;
Public function GetVerbCount: Integer; override;
Public procedure Edit; override;
Public procedure ExecuteVerb(Index: Integer); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSComputingRegister: Class TGLSCUDACompilerEditor

Class TGLSCUDACompilerEditor

Unit

GLSComputingRegister

Declaration

type TGLSCUDACompilerEditor = class(TComponentEditor)

Description

Hierarchy

  • TComponentEditor
  • TGLSCUDACompilerEditor

Overview

Methods

Public | function GetVerb(Index: Integer): string; override;
Public | function GetVerbCount: Integer; override;
Public | procedure Edit; override;
Public | procedure ExecuteVerb(Index: Integer); override;

Description

Methods

Public function GetVerb(Index: Integer): string; override;
Public function GetVerbCount: Integer; override;
Public procedure Edit; override;
Public procedure ExecuteVerb(Index: Integer); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSComputingRegister: Class TGLSCUDACompilerSourceProperty

Class TGLSCUDACompilerSourceProperty

Unit

GLSComputingRegister

Declaration

type TGLSCUDACompilerSourceProperty = class(TStringProperty)

Description

Hierarchy

  • TStringProperty
  • TGLSCUDACompilerSourceProperty

Overview

Methods

Public | constructor Create(Hook: TPropertyEditorHook; APropCount: Integer); override;
Public | destructor Destroy; override;
Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure SetValue(const Value: String); override;

Description

Methods

Public constructor Create(Hook: TPropertyEditorHook; APropCount: Integer); override;
Public destructor Destroy; override;
Public function GetAttributes: TPropertyAttributes; override;
Public procedure GetValues(Proc: TGetStrProc); override;
Public procedure SetValue(const Value: String); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLSComputingRegister: Class TGLSCUDADeviceProperty

Class TGLSCUDADeviceProperty

Unit

GLSComputingRegister

Declaration

type TGLSCUDADeviceProperty = class(TStringProperty)

Description

Hierarchy

  • TStringProperty
  • TGLSCUDADeviceProperty

Overview

Methods

Public | constructor Create(Hook: TPropertyEditorHook; APropCount: Integer); override;
Public | destructor Destroy; override;
Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure GetValues(Proc: TGetStrProc); override;
Public | procedure SetValue(const Value: String); override;

Description

Methods

Public constructor Create(Hook: TPropertyEditorHook; APropCount: Integer); override;
Public destructor Destroy; override;
Public function GetAttributes: TPropertyAttributes; override;
Public procedure GetValues(Proc: TGetStrProc); override;
Public procedure SetValue(const Value: String); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLScreen

Unit GLScreen

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLScreen<p>

Routines to interact with the screen/desktop.<p>

<b>Historique : </b><font size=-1><ul> <li>04/11/10 - DaStr - Added Delphi5 and Delphi6 compatibility <li>06/06/10 - Yar - Fixed warnings <li>13/04/10 - Yar - Fixed conditional for delphi (thanks mif) <li>07/01/10 - DaStr - Enhanced cross-platform compatibility (thanks Predator) <li>17/12/09 - DaStr - Added screen utility functions from GLCrossPlatform.pas (thanks Predator) <li>07/11/09 - DaStr - Improved FPC compatibility and moved to the /Source/Platform/ directory (BugtrackerID = 2893580) (thanks Predator) <li>23/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>03/07/04 - LR - Suppress CurrentScreenColorDepth because there are in GLCrossPlatform <li>24/07/03 - EG - Video modes now read on request only, removed the non-standard low-res video modes <li>27/09/02 - EG - Added Ability to set display frequency <li>27/07/01 - EG - Removed the "absolute" in RestoreDefaultMode <li>08/02/00 - EG - TLowResMode & TVideoMode packed (wins 5 kb) <li>06/02/00 - EG - Javadocisation, added "default"s to properties </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TDisplayOptions |
packed record TVideoMode |

Functions and Procedures

function GetIndexFromResolution(XRes,YRes,BPP: Integer): TResolution;
procedure ReadVideoModes;
function SetFullscreenMode(modeIndex : TResolution; displayFrequency : Integer = 0) : Boolean;
procedure ReadScreenImage(Dest: HDC; DestLeft, DestTop: Integer; SrcRect: TRectangle);
procedure RestoreDefaultMode;
procedure GLShowCursor(AShow: boolean);
procedure GLSetCursorPos(AScreenX, AScreenY: integer);
procedure GLGetCursorPos(var point: TGLPoint);
function GLGetScreenWidth:integer;
function GLGetScreenHeight:integer;

Types

TResolution = 0..MaxVideoModes;
TWindowAttribute = (...);
TWindowAttributes = set of TWindowAttribute;
TWindowFitting = (...);
PVideoMode = ˆTVideoMode;

Constants

MaxVideoModes = 200;

Variables

vNumberVideoModes: Integer = 0;
vCurrentVideoMode: Integer = 0;
vVideoModes: array of TVideoMode;

Description

Functions and Procedures

function GetIndexFromResolution(XRes,YRes,BPP: Integer): TResolution;
procedure ReadVideoModes;
function SetFullscreenMode(modeIndex : TResolution; displayFrequency : Integer = 0) : Boolean;

Changes to the video mode given by 'Index'

procedure ReadScreenImage(Dest: HDC; DestLeft, DestTop: Integer; SrcRect: TRectangle);
procedure RestoreDefaultMode;
procedure GLShowCursor(AShow: boolean);
procedure GLSetCursorPos(AScreenX, AScreenY: integer);
procedure GLGetCursorPos(var point: TGLPoint);
function GLGetScreenWidth:integer;
function GLGetScreenHeight:integer;

Types

TResolution = 0..MaxVideoModes;
TWindowAttribute = (...);
Values
  • woDesktop:
  • woStayOnTop:
  • woTransparent:
TWindowAttributes = set of TWindowAttribute;
TWindowFitting = (...);
Values
  • wfDefault:
  • wfFitWindowToScreen:
  • wfFitScreenToWindow:
PVideoMode = ˆTVideoMode;

Constants

MaxVideoModes = 200;

Variables

vNumberVideoModes: Integer = 0;
vCurrentVideoMode: Integer = 0;
vVideoModes: array of TVideoMode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLScreen: Class TDisplayOptions

Class TDisplayOptions

Unit

GLScreen

Declaration

type TDisplayOptions = class(TPersistent)

Description

Hierarchy

  • TPersistent
  • TDisplayOptions

Overview

Methods

Public procedure Assign(Source: TPersistent); override;

Properties

Published | property FullScreen: Boolean read FFullScreen write FFullScreen default False;
Published | property ScreenResolution: TResolution read FScreenResolution write FScreenResolution default 0;
Published | property WindowAttributes: TWindowAttributes read FWindowAttributes write FWindowAttributes default [];
Published | property WindowFitting: TWindowFitting read FWindowFitting write FWindowFitting default wfDefault;

Description

Methods

Public procedure Assign(Source: TPersistent); override;

Properties

Published property FullScreen: Boolean read FFullScreen write FFullScreen default False;
Published property ScreenResolution: TResolution read FScreenResolution write FScreenResolution default 0;
Published property WindowAttributes: TWindowAttributes read FWindowAttributes write FWindowAttributes default [];
Published property WindowFitting: TWindowFitting read FWindowFitting write FWindowFitting default wfDefault;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLScreen: packed record TVideoMode

packed record TVideoMode

Unit

GLScreen

Declaration

type TVideoMode = packed record

Description

Overview

Fields

Width: Word;
Height: Word;
ColorDepth: Byte;
MaxFrequency: Byte;
Description: String;

Description

Fields

Width: Word;
Height: Word;
ColorDepth: Byte;
MaxFrequency: Byte;
Description: String;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLScriptBase

Unit GLScriptBase

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

An abstract scripting interface for GLScene<p>

This unit provides the base methods for compiling and executing scripts as well as calling scripted functions. No scripting APIs are implemented here, only abstracted functions.<p>

<b>History : </b><font size=-1><ul> <li>04/11/2004 - SG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLScriptBase |
Class TGLScripts |
Class TGLScriptLibrary |

Types

TGLScriptState = (...);

Description

Types

TGLScriptState = (...);
Values
  • ssUncompiled:
  • ssCompileErrors:
  • ssCompiled:
  • ssRunningErrors:
  • ssRunning:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLScriptBase: Class TGLScriptBase

Class TGLScriptBase

Unit

GLScriptBase

Declaration

type TGLScriptBase = class(TXCollectionItem)

Description

The base script class that defines the abstract functions and properties. Don't use this class directly, use the script classes descended from this base class.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLScriptBase

Overview

Methods

Public | constructor Create(aOwner : TXCollection); override;
Public | destructor Destroy; override;
Public | function Call(aName : String; aParams : array of Variant) : Variant; virtual; abstract;
Protected | function GetState : TGLScriptState; virtual; abstract;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Compile; virtual; abstract;
Public | procedure Execute; virtual; abstract;
Public | procedure Invalidate; virtual; abstract;
Public | procedure Start; virtual; abstract;
Public | procedure Stop; virtual; abstract;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); virtual;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetText(const Value : TStringList);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property Description : String read FDescription write FDescription;
Public | property Errors : TStringList read FErrors;
Public | property State : TGLScriptState read GetState;
Published | property Text : TStringList read FText write SetText;

Description

Methods

Public constructor Create(aOwner : TXCollection); override;
Public destructor Destroy; override;
Public function Call(aName : String; aParams : array of Variant) : Variant; virtual; abstract;
Protected function GetState : TGLScriptState; virtual; abstract;
Public procedure Assign(Source: TPersistent); override;
Public procedure Compile; virtual; abstract;
Public procedure Execute; virtual; abstract;
Public procedure Invalidate; virtual; abstract;
Public procedure Start; virtual; abstract;
Public procedure Stop; virtual; abstract;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); virtual;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetText(const Value : TStringList);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Description : String read FDescription write FDescription;
Public property Errors : TStringList read FErrors;
Public property State : TGLScriptState read GetState;
Published property Text : TStringList read FText write SetText;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLScriptBase: Class TGLScripts

Class TGLScripts

Unit

GLScriptBase

Declaration

type TGLScripts = class(TXCollection)

Description

XCollection descendant for storing and handling scripts.

Hierarchy

  • TPersistent
  • TXCollection
  • TGLScripts

Overview

Methods

Public | function CanAdd(aClass : TXCollectionItemClass) : Boolean; override;
Public | class function ItemsClass : TXCollectionItemClass; override;
Protected | function GetItems(index : Integer) : TGLScriptBase;
Public | procedure Assign(Source: TPersistent); override;

Properties

Public property Items[index : Integer]: TGLScriptBase read GetItems;

Description

Methods

Public function CanAdd(aClass : TXCollectionItemClass) : Boolean; override;
Public class function ItemsClass : TXCollectionItemClass; override;
Protected function GetItems(index : Integer) : TGLScriptBase;
Public procedure Assign(Source: TPersistent); override;

Properties

Public property Items[index : Integer]: TGLScriptBase read GetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLScriptBase: Class TGLScriptLibrary

Class TGLScriptLibrary

Unit

GLScriptBase

Declaration

type TGLScriptLibrary = class(TComponent)

Description

Encapsulation of the scripts XCollection to help with script handling at design-time. Links the scripts to Delphi's persistence model.

Hierarchy

  • TComponent
  • TGLScriptLibrary

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Protected | procedure DefineProperties(Filer : TFiler); override;
Protected | procedure Loaded; override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure ReadScriptsData(Stream : TStream);
Protected | procedure WriteScriptsData(Stream : TStream);

Properties

Published property Scripts : TGLScripts read FScripts;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Protected procedure DefineProperties(Filer : TFiler); override;
Protected procedure Loaded; override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure ReadScriptsData(Stream : TStream);
Protected procedure WriteScriptsData(Stream : TStream);

Properties

Published property Scripts : TGLScripts read FScripts;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLScriptDWS2

Unit GLScriptDWS2

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

DelphiWebScriptII implementation for the GLScene scripting layer.<p>

<b>History : </b><font size=-1><ul> <li>04/11/2004 - SG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLDelphiWebScriptII |
Class TGLScriptDWS2 |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLScriptDWS2: Class TGLDelphiWebScriptII

Class TGLDelphiWebScriptII

Unit

GLScriptDWS2

Declaration

type TGLDelphiWebScriptII = class(TDelphiWebScriptII)

Description

This class only adds manager registration logic to the TDelphiWebScriptII class to enable the XCollection items (ie. TGLScriptDWS2) retain it's assigned compiler from design to run -time.

Hierarchy

  • TDelphiWebScriptII
  • TGLDelphiWebScriptII

Overview

Methods

Public | constructor Create(AOnwer : TComponent); override;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create(AOnwer : TComponent); override;
Public destructor Destroy; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:43


GLScene v.1.1.2: GLScriptDWS2: Class TGLScriptDWS2

Class TGLScriptDWS2

Unit

GLScriptDWS2

Declaration

type TGLScriptDWS2 = class(TGLScriptBase)

Description

Implements DelphiWebScriptII scripting functionality through the abstracted GLScriptBase .

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLScriptBase
  • TGLScriptDWS2

Overview

Methods

Public | destructor Destroy; override;
Public | function Call(aName : String; aParams : array of Variant) : Variant; override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Public | class function ItemCategory : String; override;
Protected | function GetState : TGLScriptState; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Compile; override;
Public | procedure Execute; override;
Public | procedure Invalidate; override;
Public | procedure Start; override;
Public | procedure Stop; override;
Protected | procedure Loaded; override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetCompiler(const Value : TGLDelphiWebScriptII);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published | property Compiler : TGLDelphiWebScriptII read FCompiler write SetCompiler;
Public | property DWS2Program : TProgram read FDWS2Program;

Description

Methods

Public destructor Destroy; override;
Public function Call(aName : String; aParams : array of Variant) : Variant; override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Public class function ItemCategory : String; override;
Protected function GetState : TGLScriptState; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure Compile; override;
Public procedure Execute; override;
Public procedure Invalidate; override;
Public procedure Start; override;
Public procedure Stop; override;
Protected procedure Loaded; override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetCompiler(const Value : TGLDelphiWebScriptII);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Compiler : TGLDelphiWebScriptII read FCompiler write SetCompiler;
Public property DWS2Program : TProgram read FDWS2Program;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLScriptPython

Unit GLScriptPython

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Python implementation for the GLScene scripting layer.<p>

This unit is experimental.<p>

<b>History : </b><font size=-1><ul> <li>11/11/2004 - SG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLPythonEngine |
Class TGLScriptPython |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLScriptPython: Class TGLPythonEngine

Class TGLPythonEngine

Unit

GLScriptPython

Declaration

type TGLPythonEngine = class(TPythonEngine)

Description

This class only adds manager registration logic to the TPythonEngine class to enable the XCollection items (ie. TGLScriptPython) retain it's assigned compiler from design to run -time.

Hierarchy

  • TPythonEngine
  • TGLPythonEngine

Overview

Methods

Public | constructor Create(AOnwer : TComponent); override;
Public | destructor Destroy; override;

Description

Methods

Public constructor Create(AOnwer : TComponent); override;
Public destructor Destroy; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLScriptPython: Class TGLScriptPython

Class TGLScriptPython

Unit

GLScriptPython

Declaration

type TGLScriptPython = class(TGLScriptBase)

Description

Implements Python scripting functionality through the abstracted GLScriptBase.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLScriptBase
  • TGLScriptPython

Overview

Methods

Public | destructor Destroy; override;
Public | function Call(aName : String; aParams : array of Variant) : Variant; override;
Public | class function FriendlyDescription : String; override;
Public | class function FriendlyName : String; override;
Public | class function ItemCategory : String; override;
Protected | function GetState : TGLScriptState; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Compile; override;
Public | procedure Execute; override;
Public | procedure Invalidate; override;
Public | procedure Start; override;
Public | procedure Stop; override;
Protected | procedure Loaded; override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure ReadFromFiler(reader : TReader); override;
Protected | procedure SetEngine(const Value : TGLPythonEngine);
Protected | procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Engine : TGLPythonEngine read FEngine write SetEngine;

Description

Methods

Public destructor Destroy; override;
Public function Call(aName : String; aParams : array of Variant) : Variant; override;
Public class function FriendlyDescription : String; override;
Public class function FriendlyName : String; override;
Public class function ItemCategory : String; override;
Protected function GetState : TGLScriptState; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure Compile; override;
Public procedure Execute; override;
Public procedure Invalidate; override;
Public procedure Start; override;
Public procedure Stop; override;
Protected procedure Loaded; override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure ReadFromFiler(reader : TReader); override;
Protected procedure SetEngine(const Value : TGLPythonEngine);
Protected procedure WriteToFiler(writer : TWriter); override;

Properties

Published property Engine : TGLPythonEngine read FEngine write SetEngine;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCrossXML

Unit GLSCrossXML

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSCrossXML<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Creation </ul></font>

Overview

Functions and Procedures

function GLSNewXMLDocument: GLSXMLDocument;
procedure ReleaseXMLDocument(var ADoc: GLSXMLDocument);
procedure WriteXMLFile(var ADoc: GLSXMLDocument; AStream: TStream); overload;
procedure ReadXMLFile(var ADoc: GLSXMLDocument; AStream: TStream); overload;
procedure WriteXMLFile(var ADoc: GLSXMLDocument; AFileName: string); overload;
procedure ReadXMLFile(var ADoc: GLSXMLDocument; AFileName: string); overload;
function GetXMLAttribute(const XMLNode: GLSXMLNode; const AttrName: string; out Value: string): Boolean; overload;
function GetXMLAttribute(const XMLNode: GLSXMLNode; Idx: Integer): GLSXMLNode; overload;
procedure SetXMLAttribute(const XMLNode: GLSXMLNode; const AttrName: string; const Value: string); overload;
function GetXMLAttributeCount(const XMLNode: GLSXMLNode): Integer;
function FindXMLNode(const ParentNode: GLSXMLNode; const NodeName: string; out ChildNode: GLSXMLNode): Boolean;
function CreateDOMNode(const ParentNode: GLSDOMNode; const NodeName: string): GLSDOMNode;
procedure SetXMLText(const DOMNode: GLSDOMNode; const AText: string);
function GetXMLText(const XMLNode: GLSXMLNode; out AText: string): Boolean;

Types

GLSXMLDocument = TXMLDocument;
GLSXMLNode = TDOMNode;
GLSDOMNode = TDOMNode;

Description

Functions and Procedures

function GLSNewXMLDocument: GLSXMLDocument;
procedure ReleaseXMLDocument(var ADoc: GLSXMLDocument);
procedure WriteXMLFile(var ADoc: GLSXMLDocument; AStream: TStream); overload;
procedure ReadXMLFile(var ADoc: GLSXMLDocument; AStream: TStream); overload;
procedure WriteXMLFile(var ADoc: GLSXMLDocument; AFileName: string); overload;
procedure ReadXMLFile(var ADoc: GLSXMLDocument; AFileName: string); overload;
function GetXMLAttribute(const XMLNode: GLSXMLNode; const AttrName: string; out Value: string): Boolean; overload;
function GetXMLAttribute(const XMLNode: GLSXMLNode; Idx: Integer): GLSXMLNode; overload;
procedure SetXMLAttribute(const XMLNode: GLSXMLNode; const AttrName: string; const Value: string); overload;
function GetXMLAttributeCount(const XMLNode: GLSXMLNode): Integer;
function FindXMLNode(const ParentNode: GLSXMLNode; const NodeName: string; out ChildNode: GLSXMLNode): Boolean;
function CreateDOMNode(const ParentNode: GLSDOMNode; const NodeName: string): GLSDOMNode;
procedure SetXMLText(const DOMNode: GLSDOMNode; const AText: string);
function GetXMLText(const XMLNode: GLSXMLNode; out AText: string): Boolean;

Types

GLSXMLDocument = TXMLDocument;
GLSXMLNode = TDOMNode;
GLSDOMNode = TDOMNode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCUDA

Unit GLSCUDA

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TChannelTypeAndNum |
Class TCUDAComponent |
Class TCUDAModule |
Class TCUDAGraphicResource |
Class TCUDAMemData |
Class TCUDAUniform |
Class TCUDAConstant |
Class TCUDAFuncParam |
Class TCUDAFunction |
Class TCUDATexture |
Class TGLSCUDA |

Functions and Procedures

function GetChannelTypeAndNum(AType: TCUDAType): TChannelTypeAndNum;
procedure RegisterCUDAComponentNameChangeEvent(ANotifyEvent: TNotifyEvent);
procedure DeRegisterCUDAComponentNameChangeEvent;

Types

TCUDAChange = (...);
TCUDAChanges = set of TCUDAChange;
TCuAddresMode = (...);
TCuFilterMode = (...);
TCUDAChannelType = (...);
TCUDAChannelNum = (...);
TCUDAMapping = (...);
TCUDAComponentClass = class of TCUDAComponent;
TGLResourceType = (...);
TCUDAMemType = (...);
TCUDAMemMapFlag = (...);
TCUDAMemMapFlags = set of TCUDAMemMapFlag;

Constants

cudasModuleAbsent = 'Module is absent.';
cudasInvalidParamType = 'Invalid parameter type.';
cudasOnlyHostData = 'Only host data or mapped device or array data can writen/readen';
cudasOutOfRange = 'Indexes out of range';
cudasInvalidValue = 'Invalid value';
cudasWrongParamSetup = 'Function''s parameters must be sutup in OnParameterSetup event';
cudasLaunchFailed = 'Kernel function "%s" launch failed.';
cudasFuncNotConnected = '%s.Launch: Kernel function not connected';
cudasFailMap = 'Unable to map %s - already mapped';
cudasFailUnmap = 'Unable to unmap %s - not mapped.';

Description

Functions and Procedures

function GetChannelTypeAndNum(AType: TCUDAType): TChannelTypeAndNum;
procedure RegisterCUDAComponentNameChangeEvent(ANotifyEvent: TNotifyEvent);
procedure DeRegisterCUDAComponentNameChangeEvent;

Types

TCUDAChange = (...);
Values
  • cuchDevice:
  • cuchContext:
  • cuchSize:
  • cuchAddresMode:
  • cuchFlag:
  • cuchFilterMode:
  • cuchArray:
  • cuchFormat:
  • cuchMapping:
TCUDAChanges = set of TCUDAChange;
TCuAddresMode = (...);
Values
  • amWrap:
  • amClamp:
  • amMirror:
TCuFilterMode = (...);
Values
  • fmPoint:
  • fmLinear:
TCUDAChannelType = (...);
Values
  • ctUndefined:
  • ctUInt8:
  • ctUInt16:
  • ctUInt32:
  • ctInt8:
  • ctInt16:
  • ctInt32:
  • ctHalfFloat:
  • ctFloat:
  • ctDouble:
TCUDAChannelNum = (...);
Values
  • cnOne:
  • cnTwo:
  • cnThree:
  • cnFour:
TCUDAMapping = (...);
Values
  • grmDefault:
  • grmReadOnly:
  • grmWriteDiscard:
TCUDAComponentClass = class of TCUDAComponent;
TGLResourceType = (...);
Values
  • rtTexture:
  • rtBuffer:
TCUDAMemType = (...);
Values
  • mtHost:
  • mtDevice:
  • mtArray:
TCUDAMemMapFlag = (...);
Values
  • mmfPortable:
  • mmfFastWrite:
TCUDAMemMapFlags = set of TCUDAMemMapFlag;

Constants

cudasModuleAbsent = 'Module is absent.';
cudasInvalidParamType = 'Invalid parameter type.';
cudasOnlyHostData = 'Only host data or mapped device or array data can writen/readen';
cudasOutOfRange = 'Indexes out of range';
cudasInvalidValue = 'Invalid value';
cudasWrongParamSetup = 'Function''s parameters must be sutup in OnParameterSetup event';
cudasLaunchFailed = 'Kernel function "%s" launch failed.';
cudasFuncNotConnected = '%s.Launch: Kernel function not connected';
cudasFailMap = 'Unable to map %s - already mapped';
cudasFailUnmap = 'Unable to unmap %s - not mapped.';
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCUDA: record TChannelTypeAndNum

record TChannelTypeAndNum

Unit

GLSCUDA

Declaration

type TChannelTypeAndNum = record

Description

Overview

Fields

F: TCUDAChannelType;
C: TCUDAChannelNum;

Description

Fields

F: TCUDAChannelType;
C: TCUDAChannelNum;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCUDA: Class TCUDAComponent

Class TCUDAComponent

Unit

GLSCUDA

Declaration

type TCUDAComponent = class(TCUDAHandlesMaster)

Description

no description available, TCUDAHandlesMaster description follows

Hierarchy

  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent

Overview

Fields

Protected | FStatus: TCUresult;
Protected | FChanges: TCUDAChanges;

Methods

Public | destructor Destroy; override;
Public | function GetItemByName(const name: string): TCUDAComponent;
Public | function GetParentComponent: TComponent; override;
Public | function HasParent: Boolean; override;
Public | function MakeUniqueName(const BaseName: string): string;
Protected | function GetContext: TCUDAContext; override;
Protected | function GetIsAllocated: Boolean; virtual; abstract;
Public | procedure CuNotifyChange(AChange: TCUDAChange); virtual;
Public | procedure SetParentComponent(Value: TComponent); override;
Protected | procedure AddItem(AItem: TCUDAComponent);
Protected | procedure CollectStatus(AStatus: TCUresult);
Protected | procedure DeleteItems;
Protected | procedure GetChildren(AProc: TGetChildProc; Root: TComponent); override;
Protected | procedure RemoveItem(AItem: TCUDAComponent);
Protected | procedure SetName(const NewName: TComponentName); override;

Properties

Public | property Context: TCUDAContext read GetContext;
Public | property IsAllocated: Boolean read GetIsAllocated;
Public | property Items[const i: Integer]: TCUDAComponent read GetItem;
Public | property ItemsCount: Integer read GetItemsCount;
Public | property Master: TCUDAComponent read FMaster write SetMaster;
Public | property Status: TCUresult read FStatus;

Description

Fields

Protected FStatus: TCUresult;
Protected FChanges: TCUDAChanges;

Methods

Public destructor Destroy; override;
Public function GetItemByName(const name: string): TCUDAComponent;
Public function GetParentComponent: TComponent; override;
Public function HasParent: Boolean; override;
Public function MakeUniqueName(const BaseName: string): string;
Protected function GetContext: TCUDAContext; override;
Protected function GetIsAllocated: Boolean; virtual; abstract;
Public procedure CuNotifyChange(AChange: TCUDAChange); virtual;
Public procedure SetParentComponent(Value: TComponent); override;
Protected procedure AddItem(AItem: TCUDAComponent);
Protected procedure CollectStatus(AStatus: TCUresult);
Protected procedure DeleteItems;
Protected procedure GetChildren(AProc: TGetChildProc; Root: TComponent); override;
Protected procedure RemoveItem(AItem: TCUDAComponent);
Protected procedure SetName(const NewName: TComponentName); override;

Properties

Public property Context: TCUDAContext read GetContext;
Public property IsAllocated: Boolean read GetIsAllocated;

Return true if handle is allocated (i.e. component has device object)

Public property Items[const i: Integer]: TCUDAComponent read GetItem;
Public property ItemsCount: Integer read GetItemsCount;
Public property Master: TCUDAComponent read FMaster write SetMaster;
Public property Status: TCUresult read FStatus;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCUDA: Class TCUDAModule

Class TCUDAModule

Unit

GLSCUDA

Declaration

type TCUDAModule = class(TCUDAComponent)

Description

no description available, TCUDAComponent description follows
no description available, TCUDAHandlesMaster description follows

Hierarchy

  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAModule

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function GetContext: TCUDAContext; override;
Protected | function GetIsAllocated: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadAndCompile;
Public | procedure LoadFromFile(const AFilename: string);
Public | procedure LoadFromSource;
Public | procedure Unload;
Protected | procedure AllocateHandles; override;
Protected | procedure DestroyHandles; override;
Protected | procedure Loaded; override;
Protected | procedure OnChangeCode(Sender: TObject);

Properties

Published | property Code: TStringList read FCode write SetCode;
Public | property CodeType: TGLSCUDACompilerOutput read FCodeType;
Published | property Compiler: TGLSCUDACompiler read FCompiler write SetCompiler;
Public | property Context: TCUDAContext read GetContext;
Public | property KernelConstant[const AName: string]: TCUDAConstant read GetKernelConstant;
Public | property KernelFunction[const AName: string]: TCUDAFunction read GetKernelFunction;
Public | property KernelTexture[const AName: string]: TCUDATexture read GetKernelTexture;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function GetContext: TCUDAContext; override;
Protected function GetIsAllocated: Boolean; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadAndCompile;
Public procedure LoadFromFile(const AFilename: string);
Public procedure LoadFromSource;
Public procedure Unload;
Protected procedure AllocateHandles; override;
Protected procedure DestroyHandles; override;
Protected procedure Loaded; override;
Protected procedure OnChangeCode(Sender: TObject);

Properties

Published property Code: TStringList read FCode write SetCode;
Public property CodeType: TGLSCUDACompilerOutput read FCodeType;
Published property Compiler: TGLSCUDACompiler read FCompiler write SetCompiler;
Public property Context: TCUDAContext read GetContext;
Public property KernelConstant[const AName: string]: TCUDAConstant read GetKernelConstant;
Public property KernelFunction[const AName: string]: TCUDAFunction read GetKernelFunction;
Public property KernelTexture[const AName: string]: TCUDATexture read GetKernelTexture;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCUDA: Class TCUDAGraphicResource

Class TCUDAGraphicResource

Unit

GLSCUDA

Declaration

type TCUDAGraphicResource = class(TCUDAComponent)

Description

no description available, TCUDAComponent description follows
no description available, TCUDAHandlesMaster description follows

Hierarchy

  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAGraphicResource

Overview

Fields

Protected | FHandle: array [0 .. 7] of PCUgraphicsResource;
Protected | FMapping: TCUDAMapping;
Protected | FResourceType: TGLResourceType;
Protected | FGLContextHandle: TGLVirtualHandle;
Protected | FMapCounter: Integer;

Methods

Protected | function GetAttributeArrayAddress(const Attr: string): Pointer; virtual; abstract;
Protected | function GetAttributeArraySize(const Attr: string): LongWord; virtual; abstract;
Protected | function GetElementArrayAddress: Pointer; virtual; abstract;
Protected | function GetElementArrayDataSize: LongWord; virtual; abstract;
Protected | function GetIsAllocated: Boolean; override;
Public | procedure MapResources; virtual; abstract;
Public | procedure UnMapResources; virtual; abstract;
Protected | procedure BindArrayToTexture(var cudaArray: TCUDAMemData; ALeyer, ALevel: LongWord); virtual; abstract;
Protected | procedure OnGLHandleAllocate(Sender: TGLVirtualHandle; var Handle: Cardinal);
Protected | procedure OnGLHandleDestroy(Sender: TGLVirtualHandle; var Handle: Cardinal);
Protected | procedure SetArray(var AArray: TCUDAMemData; AHandle: PCUarray; ForGLTexture, Volume: Boolean);
Protected | procedure SetMapping(const Value: TCUDAMapping); virtual;

Properties

Protected property Mapping: TCUDAMapping read FMapping write SetMapping default grmDefault;

Description

Fields

Protected FHandle: array [0 .. 7] of PCUgraphicsResource;
Protected FMapping: TCUDAMapping;
Protected FResourceType: TGLResourceType;
Protected FGLContextHandle: TGLVirtualHandle;
Protected FMapCounter: Integer;

Methods

Protected function GetAttributeArrayAddress(const Attr: string): Pointer; virtual; abstract;
Protected function GetAttributeArraySize(const Attr: string): LongWord; virtual; abstract;
Protected function GetElementArrayAddress: Pointer; virtual; abstract;
Protected function GetElementArrayDataSize: LongWord; virtual; abstract;
Protected function GetIsAllocated: Boolean; override;
Public procedure MapResources; virtual; abstract;
Public procedure UnMapResources; virtual; abstract;
Protected procedure BindArrayToTexture(var cudaArray: TCUDAMemData; ALeyer, ALevel: LongWord); virtual; abstract;
Protected procedure OnGLHandleAllocate(Sender: TGLVirtualHandle; var Handle: Cardinal);
Protected procedure OnGLHandleDestroy(Sender: TGLVirtualHandle; var Handle: Cardinal);
Protected procedure SetArray(var AArray: TCUDAMemData; AHandle: PCUarray; ForGLTexture, Volume: Boolean);
Protected procedure SetMapping(const Value: TCUDAMapping); virtual;

Properties

Protected property Mapping: TCUDAMapping read FMapping write SetMapping default grmDefault;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCUDA: Class TCUDAMemData

Class TCUDAMemData

Unit

GLSCUDA

Declaration

type TCUDAMemData = class(TCUDAComponent)

Description

no description available, TCUDAComponent description follows
no description available, TCUDAHandlesMaster description follows

Hierarchy

  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAMemData

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Data<EType>(X: Integer): GCUDAHostElementAccess<EType>; overload;
Public | function Data<EType>(X, Y, Z: Integer): GCUDAHostElementAccess<EType>; overload;
Public | function Data<EType>(X, Y: Integer): GCUDAHostElementAccess<EType>; overload;
Protected | function GetIsAllocated: Boolean; override;
Public | procedure CopyFrom(const ASrcMemData: TCUDAMemData); overload;
Public | procedure CopyFrom(const AGLImage: TGLBitmap32); overload;
Public | procedure CopyFrom(const AGLGraphic: TCUDAGraphicResource; aAttr: string = ''); overload;
Public | procedure CopyTo(const AGLImage: TGLImage); overload;
Public | procedure CopyTo(const ADstMemData: TCUDAMemData); overload;
Public | procedure CopyTo(const AGLGraphic: TCUDAGraphicResource; aAttr: string = ''); overload;
Public | procedure CuNotifyChange(AChange: TCUDAChange); override;
Public | procedure FillMem(const Value);
Public | procedure Map(const AFlags: TCUDAMemMapFlags = []);
Public | procedure SubCopyTo(const ADstMemData: TCUDAMemData; ASrcXYZ, ADstXYZ, ASizes: IntElement.TVector3);
Public | procedure UnMap;
Protected | procedure AllocateHandles; override;
Protected | procedure DestroyHandles; override;

Properties

Public | property ArrayHandle: PCUarray read GetArrayHandle;
Published | property ChannelsNum: TCUDAChannelNum read fChannelsNum write SetChannelNum default cnOne;
Published | property ChannelsType: TCUDAChannelType read fChannelsType write SetChannelType default ctInt8;
Public | property DataSize: Integer read FDataSize;
Published | property Depth: Integer read fDepth write SetDepth default 0;
Public | property ElementSize: Integer read FElementSize;
Published | property Height: Integer read fHeight write SetHeight default 0;
Public | property MappedMemoryAddress: TCUdeviceptr read FMappedMemory;
Published | property MemoryType: TCUDAMemType read FMemoryType write SetMemoryType default mtHost;
Public | property Pitch: Cardinal read fPitch;
Public | property RawData: TCUdeviceptr read GetData;
Published | property Width: Integer read fWidth write SetWidth default 256;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function Data<EType>(X: Integer): GCUDAHostElementAccess<EType>; overload;
Public function Data<EType>(X, Y, Z: Integer): GCUDAHostElementAccess<EType>; overload;
Public function Data<EType>(X, Y: Integer): GCUDAHostElementAccess<EType>; overload;
Protected function GetIsAllocated: Boolean; override;
Public procedure CopyFrom(const ASrcMemData: TCUDAMemData); overload;
Public procedure CopyFrom(const AGLImage: TGLBitmap32); overload;
Public procedure CopyFrom(const AGLGraphic: TCUDAGraphicResource; aAttr: string = ''); overload;
Public procedure CopyTo(const AGLImage: TGLImage); overload;
Public procedure CopyTo(const ADstMemData: TCUDAMemData); overload;
Public procedure CopyTo(const AGLGraphic: TCUDAGraphicResource; aAttr: string = ''); overload;
Public procedure CuNotifyChange(AChange: TCUDAChange); override;
Public procedure FillMem(const Value);
Public procedure Map(const AFlags: TCUDAMemMapFlags = []);

Map device and array memory to host or host memory to device. Mapping is necessary for modifying device data. When mapped host memory - it can be accessed in device side via MappedHostAddress.

Public procedure SubCopyTo(const ADstMemData: TCUDAMemData; ASrcXYZ, ADstXYZ, ASizes: IntElement.TVector3);
Public procedure UnMap;

Done mapping operation.

Protected procedure AllocateHandles; override;
Protected procedure DestroyHandles; override;

Properties

Public property ArrayHandle: PCUarray read GetArrayHandle;
Published property ChannelsNum: TCUDAChannelNum read fChannelsNum write SetChannelNum default cnOne;
Published property ChannelsType: TCUDAChannelType read fChannelsType write SetChannelType default ctInt8;
Public property DataSize: Integer read FDataSize;
Published property Depth: Integer read fDepth write SetDepth default 0;
Public property ElementSize: Integer read FElementSize;
Published property Height: Integer read fHeight write SetHeight default 0;
Public property MappedMemoryAddress: TCUdeviceptr read FMappedMemory;
Published property MemoryType: TCUDAMemType read FMemoryType write SetMemoryType default mtHost;
Public property Pitch: Cardinal read fPitch;
Public property RawData: TCUdeviceptr read GetData;
Published property Width: Integer read fWidth write SetWidth default 256;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCUDA: Class TCUDAUniform

Class TCUDAUniform

Unit

GLSCUDA

Declaration

type TCUDAUniform = class(TCUDAComponent)

Description

no description available, TCUDAComponent description follows
no description available, TCUDAHandlesMaster description follows

Hierarchy

  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAUniform

Overview

Fields

Protected | FHandle: TCUdeviceptr;
Protected | FSize: Cardinal;
Protected | FKernelName: string;
Protected | FType: TCUDAType;
Protected | FCustomType: string;
Protected | FRef: Boolean;
Protected | FDefined: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function GetIsAllocated: Boolean; override;
Protected | procedure SetCustomType(const AValue: string);
Protected | procedure SetDefined(AValue: Boolean);
Protected | procedure SetKernelName(const AName: string);
Protected | procedure SetRef(AValue: Boolean);
Protected | procedure SetSize(const AValue: Cardinal);
Protected | procedure SetType(AValue: TCUDAType);

Properties

Protected | property CustomType: string read FCustomType write SetCustomType;
Protected | property DataType: TCUDAType read FType write SetType;
Public | property IsValueDefined: Boolean read FDefined write SetDefined;
Protected | property KernelName: string read FKernelName write SetKernelName;
Protected | property Reference: Boolean read FRef write SetRef;
Protected | property Size: Cardinal read FSize write SetSize;

Description

Fields

Protected FHandle: TCUdeviceptr;
Protected FSize: Cardinal;
Protected FKernelName: string;
Protected FType: TCUDAType;
Protected FCustomType: string;
Protected FRef: Boolean;
Protected FDefined: Boolean;

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function GetIsAllocated: Boolean; override;
Protected procedure SetCustomType(const AValue: string);
Protected procedure SetDefined(AValue: Boolean);
Protected procedure SetKernelName(const AName: string);
Protected procedure SetRef(AValue: Boolean);
Protected procedure SetSize(const AValue: Cardinal);
Protected procedure SetType(AValue: TCUDAType);

Properties

Protected property CustomType: string read FCustomType write SetCustomType;
Protected property DataType: TCUDAType read FType write SetType;
Public property IsValueDefined: Boolean read FDefined write SetDefined;
Protected property KernelName: string read FKernelName write SetKernelName;
Protected property Reference: Boolean read FRef write SetRef;
Protected property Size: Cardinal read FSize write SetSize;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCUDA: Class TCUDAConstant

Class TCUDAConstant

Unit

GLSCUDA

Declaration

type TCUDAConstant = class(TCUDAUniform)

Description

no description available, TCUDAUniform description follows
no description available, TCUDAComponent description follows
no description available, TCUDAHandlesMaster description follows

Hierarchy

  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAUniform
  • TCUDAConstant

Overview

Methods

Protected | function GetDeviceAddress: TCUdeviceptr;
Protected | procedure AllocateHandles; override;
Protected | procedure DestroyHandles; override;

Properties

Published | property CustomType;
Published | property DataType;
Public | property DeviceAddress: TCUdeviceptr read GetDeviceAddress;
Published | property KernelName;
Published | property Reference;
Published | property Size;

Description

Methods

Protected function GetDeviceAddress: TCUdeviceptr;
Protected procedure AllocateHandles; override;
Protected procedure DestroyHandles; override;

Properties

Published property CustomType;
Published property DataType;
Public property DeviceAddress: TCUdeviceptr read GetDeviceAddress;
Published property KernelName;
Published property Reference;
Published property Size;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCUDA: Class TCUDAFuncParam

Class TCUDAFuncParam

Unit

GLSCUDA

Declaration

type TCUDAFuncParam = class(TCUDAUniform)

Description

no description available, TCUDAUniform description follows
no description available, TCUDAComponent description follows
no description available, TCUDAHandlesMaster description follows

Hierarchy

  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAUniform
  • TCUDAFuncParam

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Protected | procedure AllocateHandles; override;
Protected | procedure DestroyHandles; override;

Properties

Published | property CustomType;
Published | property DataType;
Published | property KernelName;
Published | property Reference;
Published | property Size;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Protected procedure AllocateHandles; override;
Protected procedure DestroyHandles; override;

Properties

Published property CustomType;
Published property DataType;
Published property KernelName;
Published property Reference;
Published property Size;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCUDA: Class TCUDAFunction

Class TCUDAFunction

Unit

GLSCUDA

Declaration

type TCUDAFunction = class(TCUDAComponent)

Description

no description available, TCUDAComponent description follows
no description available, TCUDAHandlesMaster description follows

Hierarchy

  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAFunction

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function GetIsAllocated: Boolean; override;
Public | procedure Launch(Grided: Boolean = true);
Public | procedure SetParam(Value: TVector4f); overload;
Public | procedure SetParam(Value: TVector3f); overload;
Public | procedure SetParam(Value: TVector2f); overload;
Public | procedure SetParam(Ptr: Pointer); overload;
Public | procedure SetParam(TexRef: TCUDATexture); overload;
Public | procedure SetParam(MemData: TCUDAMemData); overload;
Public | procedure SetParam(Value: TVector4i); overload;
Public | procedure SetParam(Value: Cardinal); overload;
Public | procedure SetParam(Value: Integer); overload;
Public | procedure SetParam(Value: Single); overload;
Public | procedure SetParam(Value: TVector3i); overload;
Public | procedure SetParam(Value: TVector2i); overload;
Protected | procedure AllocateHandles; override;
Protected | procedure DestroyHandles; override;

Properties

Published | property AutoSync: Boolean read FAutoSync write FAutoSync default true;
Published | property BlockShape: TCUDADimensions read FBlockShape write SetBlockShape;
Public | property ConstMemorySize: Integer read GetConstMemorySize;
Published | property Grid: TCUDADimensions read FGrid write SetGrid;
Public | property Handle: PCUfunction read GetHandle;
Published | property KernelName: string read FKernelName write SetKernelName;
Public | property LocalMemorySize: Integer read GetLocalMemorySize;
Public | property MaxThreadPerBlock: Integer read GetMaxThreadPerBlock;
Public | property NumRegisters: Integer read GetNumRegisters;
Published | property OnParameterSetup: TNotifyEvent read FOnParameterSetup write FOnParameterSetup;
Public | property Parameters[const AName: string]: TCUDAFuncParam read GetParameter;
Public | property SharedMemorySize: Integer read GetSharedMemorySize write SetSharedMemorySize;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function GetIsAllocated: Boolean; override;
Public procedure Launch(Grided: Boolean = true);
Public procedure SetParam(Value: TVector4f); overload;
Public procedure SetParam(Value: TVector3f); overload;
Public procedure SetParam(Value: TVector2f); overload;
Public procedure SetParam(Ptr: Pointer); overload;
Public procedure SetParam(TexRef: TCUDATexture); overload;
Public procedure SetParam(MemData: TCUDAMemData); overload;
Public procedure SetParam(Value: TVector4i); overload;
Public procedure SetParam(Value: Cardinal); overload;
Public procedure SetParam(Value: Integer); overload;
Public procedure SetParam(Value: Single); overload;
Public procedure SetParam(Value: TVector3i); overload;
Public procedure SetParam(Value: TVector2i); overload;
Protected procedure AllocateHandles; override;
Protected procedure DestroyHandles; override;

Properties

Published property AutoSync: Boolean read FAutoSync write FAutoSync default true;
Published property BlockShape: TCUDADimensions read FBlockShape write SetBlockShape;
Public property ConstMemorySize: Integer read GetConstMemorySize;
Published property Grid: TCUDADimensions read FGrid write SetGrid;
Public property Handle: PCUfunction read GetHandle;
Published property KernelName: string read FKernelName write SetKernelName;
Public property LocalMemorySize: Integer read GetLocalMemorySize;
Public property MaxThreadPerBlock: Integer read GetMaxThreadPerBlock;
Public property NumRegisters: Integer read GetNumRegisters;
Published property OnParameterSetup: TNotifyEvent read FOnParameterSetup write FOnParameterSetup;
Public property Parameters[const AName: string]: TCUDAFuncParam read GetParameter;
Public property SharedMemorySize: Integer read GetSharedMemorySize write SetSharedMemorySize;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCUDA: Class TCUDATexture

Class TCUDATexture

Unit

GLSCUDA

Declaration

type TCUDATexture = class(TCUDAComponent)

Description

no description available, TCUDAComponent description follows
no description available, TCUDAHandlesMaster description follows

Hierarchy

  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDATexture

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function GetIsAllocated: Boolean; override;
Protected | procedure AllocateHandles; override;
Protected | procedure DestroyHandles; override;

Properties

Published | property AddressModeR: TCuAddresMode read fAddressModeR write SetAddressModeR default amClamp;
Published | property AddressModeS: TCuAddresMode read fAddressModeS write SetAddressModeS default amClamp;
Published | property AddressModeT: TCuAddresMode read fAddressModeT write SetAddressModeT default amClamp;
Published | property ChannelNum: TCUDAChannelNum read fChannelNum write SetChannelNum;
Published | property FilterMode: TCuFilterMode read fFilterMode write SetFilterMode default fmPoint;
Published | property Format: TCUDAChannelType read fFormat write SetFormat;
Public | property Handle: PCUtexref read GetHandle;
Published | property KernelName: string read FKernelName write SetKernelName;
Published | property MemDataArray: TCUDAMemData read fArray write SetArray;
Published | property NormalizedCoord: Boolean read fNormalizedCoord write SetNormalizedCoord default true;
Published | property ReadAsInteger: Boolean read fReadAsInteger write SetReadAsInteger default false;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function GetIsAllocated: Boolean; override;
Protected procedure AllocateHandles; override;
Protected procedure DestroyHandles; override;

Properties

Published property AddressModeR: TCuAddresMode read fAddressModeR write SetAddressModeR default amClamp;
Published property AddressModeS: TCuAddresMode read fAddressModeS write SetAddressModeS default amClamp;
Published property AddressModeT: TCuAddresMode read fAddressModeT write SetAddressModeT default amClamp;
Published property ChannelNum: TCUDAChannelNum read fChannelNum write SetChannelNum;
Published property FilterMode: TCuFilterMode read fFilterMode write SetFilterMode default fmPoint;
Published property Format: TCUDAChannelType read fFormat write SetFormat;
Public property Handle: PCUtexref read GetHandle;
Published property KernelName: string read FKernelName write SetKernelName;
Published property MemDataArray: TCUDAMemData read fArray write SetArray;
Published property NormalizedCoord: Boolean read fNormalizedCoord write SetNormalizedCoord default true;
Published property ReadAsInteger: Boolean read fReadAsInteger write SetReadAsInteger default false;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCUDA: Class TGLSCUDA

Class TGLSCUDA

Unit

GLSCUDA

Declaration

type TGLSCUDA = class(TCUDAComponent)

Description

no description available, TCUDAComponent description follows
no description available, TCUDAHandlesMaster description follows

Hierarchy

  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TGLSCUDA

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function GetContext: TCUDAContext; override;
Protected | function GetIsAllocated: Boolean; override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property ComputingDevice: TGLSCUDADevice read fDevice write SetDevice;
Public | property Context: TCUDAContext read GetContext;
Public | property Modules[const i: Integer]: TCUDAModule read GetModule;
Published | property OnOpenGLInteropInit: TOnOpenGLInteropInit read FOnOpenGLInteropInit write SetOnOpenGLInteropInit;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function GetContext: TCUDAContext; override;
Protected function GetIsAllocated: Boolean; override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published property ComputingDevice: TGLSCUDADevice read fDevice write SetDevice;
Public property Context: TCUDAContext read GetContext;
Public property Modules[const i: Integer]: TCUDAModule read GetModule;
Published property OnOpenGLInteropInit: TOnOpenGLInteropInit read FOnOpenGLInteropInit write SetOnOpenGLInteropInit;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCUDACompiler

Unit GLSCUDACompiler

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSCUDACompiler |

Types

TGLSCUDACompilerOutput = (...);
TGLSCUDAVirtArch = (...);
TGLSCUDARealArch = (...);
TGLSCUDARealArchs = set of TGLSCUDARealArch;
TFindCuFileFunc = function(var AModuleName: string): Boolean;

Variables

vFindCuFileFunc: TFindCuFileFunc;

Description

Types

TGLSCUDACompilerOutput = (...);
Values
  • codeUndefined:
  • codePtx:
  • codeCubin:
  • codeGpu:
TGLSCUDAVirtArch = (...);

compute_10 Basic features compute_11 + atomic memory operations on global memory compute_12 + atomic memory operations on shared memory + vote instructions compute_13 + double precision floating point support Compute_20 + FERMI support

Values
  • compute_10:
  • compute_11:
  • compute_12:
  • compute_13:
  • compute_20:
TGLSCUDARealArch = (...);

sm_10 ISA_1 Basic features sm_11 + atomic memory operations on global memory sm_12 + atomic memory operations on shared memory + vote instructions sm_13 + double precision floating point support sm_20 + FERMI support. sm_21 + Unknown

Values
  • sm_10:
  • sm_11:
  • sm_12:
  • sm_13:
  • sm_20:
  • sm_21:
TGLSCUDARealArchs = set of TGLSCUDARealArch;
TFindCuFileFunc = function(var AModuleName: string): Boolean;

Variables

vFindCuFileFunc: TFindCuFileFunc;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:44


GLScene v.1.1.2: GLSCUDACompiler: Class TGLSCUDACompiler

Class TGLSCUDACompiler

Unit

GLSCUDACompiler

Declaration

type TGLSCUDACompiler = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLSCUDACompiler

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Compile: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure SetSourceCodeFile(const AFileName: string);
Protected | procedure Loaded; override;

Properties

Public | property ConsoleContent: string read FConsoleContent;
Published | property CppCompilerPath: string read FCppCompilerPath write SetCppCompilerPath;
Published | property MaxRegisterCount: Integer read FMaxRegisterCount write SetMaxRegisterCount default 32;
Public | property ModuleInfo: TCUDAModuleInfo read FModuleInfo;
Published | property NVCCPath: string read FNVCCPath write SetNVCCPath;
Published | property OutputCodeType: TGLSCUDACompilerOutput read FOutputCodeType write setOutputCodeType default codePtx;
Public | property Product: TStringList read FProduct write FProduct;
Published | property ProjectModule: string read FProjectModule write FProjectModule stored StoreProjectModule;
Published | property RealArchitecture: TGLSCUDARealArchs read FRealArch write SetRealArch default [sm_13];
Published | property SourceCodeFile: string read FSourceCodeFile;
Published | property VirtualArchitecture: TGLSCUDAVirtArch read FVirtualArch write FVirtualArch default compute_13;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function Compile: Boolean;
Public procedure Assign(Source: TPersistent); override;
Public procedure SetSourceCodeFile(const AFileName: string);
Protected procedure Loaded; override;

Properties

Public property ConsoleContent: string read FConsoleContent;
Published property CppCompilerPath: string read FCppCompilerPath write SetCppCompilerPath;
Published property MaxRegisterCount: Integer read FMaxRegisterCount write SetMaxRegisterCount default 32;
Public property ModuleInfo: TCUDAModuleInfo read FModuleInfo;
Published property NVCCPath: string read FNVCCPath write SetNVCCPath;
Published property OutputCodeType: TGLSCUDACompilerOutput read FOutputCodeType write setOutputCodeType default codePtx;
Public property Product: TStringList read FProduct write FProduct;
Published property ProjectModule: string read FProjectModule write FProjectModule stored StoreProjectModule;
Published property RealArchitecture: TGLSCUDARealArchs read FRealArch write SetRealArch default [sm_13];
Published property SourceCodeFile: string read FSourceCodeFile;
Published property VirtualArchitecture: TGLSCUDAVirtArch read FVirtualArch write FVirtualArch default compute_13;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAContext

Unit GLSCUDAContext

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCUDADimensions |
Class TCUDADevice |
Class TGLSCUDADevice |
Class TCUDAHandlesMaster |
Class TCUDAContext |
Class CUDAContextManager |

Types

TOnOpenGLInteropInit = procedure(out Context: TGLContext) of object;
TCUDAHandleList = GThreadList<TCUDAHandlesMaster>;
TCUDADeviceList = GList<TCUDADevice>;
TCUDAContextList = GList<TCUDAContext>;

Description

Types

TOnOpenGLInteropInit = procedure(out Context: TGLContext) of object;
TCUDAHandleList = GThreadList<TCUDAHandlesMaster>;
TCUDADeviceList = GList<TCUDADevice>;
TCUDAContextList = GList<TCUDAContext>;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAContext: Class TCUDADimensions

Class TCUDADimensions

Unit

GLSCUDAContext

Declaration

type TCUDADimensions = class(TGLUpdateAbleObject)

Description

no description available, TGLUpdateAbleObject description follows

An abstract class describing the "update" interface.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TCUDADimensions

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Public | property MaxSizeX: Integer index 0 read GetMaxDimComponent write SetMaxDimComponent;
Public | property MaxSizeY: Integer index 1 read GetMaxDimComponent write SetMaxDimComponent;
Public | property MaxSizeZ: Integer index 2 read GetMaxDimComponent write SetMaxDimComponent;
Public | property ReadOnlyValue: Boolean read FReadOnly write FReadOnly;
Published | property SizeX: Integer index 0 read GetDimComponent write SetDimComponent default 1;
Published | property SizeY: Integer index 1 read GetDimComponent write SetDimComponent default 1;
Published | property SizeZ: Integer index 2 read GetDimComponent write SetDimComponent default 1;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public procedure Assign(Source: TPersistent); override;

Properties

Public property MaxSizeX: Integer index 0 read GetMaxDimComponent write SetMaxDimComponent;
Public property MaxSizeY: Integer index 1 read GetMaxDimComponent write SetMaxDimComponent;
Public property MaxSizeZ: Integer index 2 read GetMaxDimComponent write SetMaxDimComponent;
Public property ReadOnlyValue: Boolean read FReadOnly write FReadOnly;
Published property SizeX: Integer index 0 read GetDimComponent write SetDimComponent default 1;
Published property SizeY: Integer index 1 read GetDimComponent write SetDimComponent default 1;
Published property SizeZ: Integer index 2 read GetDimComponent write SetDimComponent default 1;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAContext: Class TCUDADevice

Class TCUDADevice

Unit

GLSCUDAContext

Declaration

type TCUDADevice = class(TPersistent)

Description

Hierarchy

  • TPersistent
  • TCUDADevice

Overview

Methods

Public | constructor Create; reintroduce;
Public | destructor Destroy; override;
Public | function TotalMemory: Cardinal;
Protected | function GetName: string;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property ClockRate: Integer read fDeviceProperties.ClockRate;
Published | property DeviceOverlap: Integer read fDeviceProperties.DeviceOverlap;
Published | property Major: Integer read fDeviceProperties.Major;
Published | property MaxGridSize: TCUDADimensions read fMaxGridSize;
Published | property MaxThreadsDim: TCUDADimensions read fMaxThreadsDim;
Published | property MaxThreadsPerBlock: Integer read fDeviceProperties.MaxThreadsPerBlock;
Published | property MemPitch: TSize_t read fDeviceProperties.MemPitch;
Published | property Minor: Integer read fDeviceProperties.Minor;
Published | property MultiProcessorCount: Integer read fDeviceProperties.MultiProcessorCount;
Published | property Name: string read GetName;
Published | property RegsPerBlock: Integer read fDeviceProperties.RegsPerBlock;
Published | property SharedMemPerBlock: TSize_t read fDeviceProperties.SharedMemPerBlock;
Published | property TextureAlignment: TSize_t read fDeviceProperties.TextureAlignment;
Published | property TotalConstMem: TSize_t read fDeviceProperties.TotalConstMem;
Published | property TotalGlobalMem: TSize_t read fDeviceProperties.TotalGlobalMem;
Published | property WarpSize: Integer read fDeviceProperties.WarpSize;

Description

Methods

Public constructor Create; reintroduce;
Public destructor Destroy; override;
Public function TotalMemory: Cardinal;
Protected function GetName: string;
Public procedure Assign(Source: TPersistent); override;

Properties

Published property ClockRate: Integer read fDeviceProperties.ClockRate;
Published property DeviceOverlap: Integer read fDeviceProperties.DeviceOverlap;
Published property Major: Integer read fDeviceProperties.Major;
Published property MaxGridSize: TCUDADimensions read fMaxGridSize;
Published property MaxThreadsDim: TCUDADimensions read fMaxThreadsDim;
Published property MaxThreadsPerBlock: Integer read fDeviceProperties.MaxThreadsPerBlock;
Published property MemPitch: TSize_t read fDeviceProperties.MemPitch;
Published property Minor: Integer read fDeviceProperties.Minor;
Published property MultiProcessorCount: Integer read fDeviceProperties.MultiProcessorCount;
Published property Name: string read GetName;
Published property RegsPerBlock: Integer read fDeviceProperties.RegsPerBlock;
Published property SharedMemPerBlock: TSize_t read fDeviceProperties.SharedMemPerBlock;
Published property TextureAlignment: TSize_t read fDeviceProperties.TextureAlignment;
Published property TotalConstMem: TSize_t read fDeviceProperties.TotalConstMem;
Published property TotalGlobalMem: TSize_t read fDeviceProperties.TotalGlobalMem;
Published property WarpSize: Integer read fDeviceProperties.WarpSize;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAContext: Class TGLSCUDADevice

Class TGLSCUDADevice

Unit

GLSCUDAContext

Declaration

type TGLSCUDADevice = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLSCUDADevice

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Suitable: Boolean;

Properties

Published | property Device: TCUDADevice read GetDevice write SetDevice;
Published | property SelectDevice: string read FSelectDeviceName write SetDeviceName;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function Suitable: Boolean;

Properties

Published property Device: TCUDADevice read GetDevice write SetDevice;
Published property SelectDevice: string read FSelectDeviceName write SetDeviceName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAContext: Class TCUDAHandlesMaster

Class TCUDAHandlesMaster

Unit

GLSCUDAContext

Declaration

type TCUDAHandlesMaster = class(TComponent)

Description

Hierarchy

  • TComponent
  • TCUDAHandlesMaster

Overview

Methods

Protected | function GetContext: TCUDAContext; virtual; abstract;
Protected | procedure AllocateHandles; virtual;
Protected | procedure DestroyHandles; virtual;

Description

Methods

Protected function GetContext: TCUDAContext; virtual; abstract;
Protected procedure AllocateHandles; virtual;
Protected procedure DestroyHandles; virtual;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAContext: Class TCUDAContext

Class TCUDAContext

Unit

GLSCUDAContext

Declaration

type TCUDAContext = class(TObject)

Description

Hierarchy

  • TObject
  • TCUDAContext

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function IsValid: Boolean; inline;
Public | procedure DestroyAllHandles;
Public | procedure Release;
Public | procedure Requires;

Properties

Public | property Device: TCUDADevice read FDevice write SetDevice;
Public | property OnOpenGLInteropInit: TOnOpenGLInteropInit read FOnOpenGLInteropInit write FOnOpenGLInteropInit;

Description

Methods

Public constructor Create;
Public destructor Destroy; override;
Public function IsValid: Boolean; inline;
Public procedure DestroyAllHandles;
Public procedure Release;
Public procedure Requires;

Properties

Public property Device: TCUDADevice read FDevice write SetDevice;
Public property OnOpenGLInteropInit: TOnOpenGLInteropInit read FOnOpenGLInteropInit write FOnOpenGLInteropInit;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAContext: Class CUDAContextManager

Class CUDAContextManager

Unit

GLSCUDAContext

Declaration

type CUDAContextManager = class(TObject)

Description

Hierarchy

  • TObject
  • CUDAContextManager

Overview

Methods

Public | class function ContextCount: Integer;
Public | class function DeviceCount: Integer;
Public | class function GetCurrentThreadContext: TCUDAContext;
Public | class function GetDeviceByName(const AName: string): TCUDADevice;
Public | class function GetMaxGflopsDevice: TCUDADevice;
Public | class function PopContext: TCUDAContext;
Protected | class function GetContext(i: Integer): TCUDAContext;
Protected | class function GetDevice(i: Integer): TCUDADevice;
Protected | class function GetNextUnusedDevice: TCUDADevice;
Protected | class function GetThreadStack: TCUDAContextList;
Public | class procedure CreateContext(aContext: TCUDAContext);
Public | class procedure CreateContextOf(ADevice: TCUDADevice);
Public | class procedure DestroyContext(aContext: TCUDAContext);
Public | class procedure DestroyContextOf(ADevice: TCUDADevice);
Public | class procedure Done;
Public | class procedure FillUnusedDeviceList(var AList: TStringList);
Public | class procedure Init;
Public | class procedure PushContext(aContext: TCUDAContext);
Protected | class procedure RegisterContext(aContext: TCUDAContext);
Protected | class procedure UnRegisterContext(aContext: TCUDAContext);

Properties

Public | property Contexts[i: Integer]: TCUDAContext read GetContext;
Public | property Devices[i: Integer]: TCUDADevice read GetDevice;

Description

Methods

Public class function ContextCount: Integer;
Public class function DeviceCount: Integer;
Public class function GetCurrentThreadContext: TCUDAContext;
Public class function GetDeviceByName(const AName: string): TCUDADevice;
Public class function GetMaxGflopsDevice: TCUDADevice;
Public class function PopContext: TCUDAContext;
Protected class function GetContext(i: Integer): TCUDAContext;
Protected class function GetDevice(i: Integer): TCUDADevice;
Protected class function GetNextUnusedDevice: TCUDADevice;
Protected class function GetThreadStack: TCUDAContextList;
Public class procedure CreateContext(aContext: TCUDAContext);
Public class procedure CreateContextOf(ADevice: TCUDADevice);
Public class procedure DestroyContext(aContext: TCUDAContext);
Public class procedure DestroyContextOf(ADevice: TCUDADevice);
Public class procedure Done;
Public class procedure FillUnusedDeviceList(var AList: TStringList);
Public class procedure Init;
Public class procedure PushContext(aContext: TCUDAContext);
Protected class procedure RegisterContext(aContext: TCUDAContext);
Protected class procedure UnRegisterContext(aContext: TCUDAContext);

Properties

Public property Contexts[i: Integer]: TCUDAContext read GetContext;
Public property Devices[i: Integer]: TCUDADevice read GetDevice;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAEditor

Unit GLSCUDAEditor

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSCUDAEditor<p>

Editor of TGLSCUDA.<p>

<b>History : </b><font size=-1><ul> <li>22/08/10 - Yar - Some improvements for FPC (thanks Predator) <li>19/03/10 - Yar - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSCUDAEditorForm |

Functions and Procedures

function GLSCUDAEditorForm: TGLSCUDAEditorForm;
procedure ReleaseGLSCUDAEditorForm;

Description

Functions and Procedures

function GLSCUDAEditorForm: TGLSCUDAEditorForm;
procedure ReleaseGLSCUDAEditorForm;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAEditor: Class TGLSCUDAEditorForm

Class TGLSCUDAEditorForm

Unit

GLSCUDAEditor

Declaration

type TGLSCUDAEditorForm = class(TForm)

Description

Hierarchy

  • TForm
  • TGLSCUDAEditorForm

Overview

Fields

Published | ToolBar1: TToolBar;
Published | AddModuleButton: TToolButton;
Published | DeleteButton: TToolButton;
Published | ListBox1: TListBox;
Published | ImageList1: TImageList;
Published | AddMemDataButton: TToolButton;
Published | AddFFTPlanButton: TToolButton;
Published | AddGeometryResButton: TToolButton;
Published | AddImageResButton: TToolButton;

Methods

Published | procedure AddItemButtonClick(Sender: TObject);
Published | procedure DeleteButtonClick(Sender: TObject);
Published | procedure FormCreate(Sender: TObject);
Published | procedure FormDestroy(Sender: TObject);
Published | procedure ListBox1Click(Sender: TObject);
Public | procedure SetCUDAEditorClient(Client: TGLSCUDA; Designer: IDesigner);
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure OnCUDAComponentNameChanged(Sender : TObject);

Description

Fields

Published ToolBar1: TToolBar;
Published AddModuleButton: TToolButton;
Published DeleteButton: TToolButton;
Published ListBox1: TListBox;
Published ImageList1: TImageList;
Published AddMemDataButton: TToolButton;
Published AddFFTPlanButton: TToolButton;
Published AddGeometryResButton: TToolButton;
Published AddImageResButton: TToolButton;

Methods

Published procedure AddItemButtonClick(Sender: TObject);
Published procedure DeleteButtonClick(Sender: TObject);
Published procedure FormCreate(Sender: TObject);
Published procedure FormDestroy(Sender: TObject);
Published procedure ListBox1Click(Sender: TObject);
Public procedure SetCUDAEditorClient(Client: TGLSCUDA; Designer: IDesigner);
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure OnCUDAComponentNameChanged(Sender : TObject);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAFFTPlan

Unit GLSCUDAFFTPlan

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCUDAFFTPlan |

Types

TCUDAFFTransform = (...);
TCUDAFFTdir = (...);

Description

Types

TCUDAFFTransform = (...);
Values
  • fftRealToComplex:
  • fftComplexToReal:
  • fftComplexToComplex:
  • fftDoubleToDoubleComplex:
  • fftDoubleComplexToDouble:
  • fftDoubleComplexToDoubleComplex:
TCUDAFFTdir = (...);
Values
  • fftdForward:
  • fftdInverse:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAFFTPlan: Class TCUDAFFTPlan

Class TCUDAFFTPlan

Unit

GLSCUDAFFTPlan

Declaration

type TCUDAFFTPlan = class(TCUDAComponent)

Description

no description available, TCUDAComponent description follows
no description available, TCUDAHandlesMaster description follows

Hierarchy

  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAFFTPlan

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Execute(ASrc: TCUDAMemData; ADst: TCUDAMemData; const ADir: TCUDAFFTdir = fftdForward);
Protected | procedure AllocateHandles; override;
Protected | class procedure CheckLib;
Protected | procedure DestroyHandles; override;

Properties

Published | property Batch: Integer read FBatch write SetBatch default 1;
Published | property Depth: Integer read FDepth write SetDepth default 0;
Published | property Height: Integer read FHeight write SetHeight default 0;
Published | property Transform: TCUDAFFTransform read FTransform write SetTransform default fftRealToComplex;
Published | property Width: Integer read fWidth write SetWidth default 256;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure Execute(ASrc: TCUDAMemData; ADst: TCUDAMemData; const ADir: TCUDAFFTdir = fftdForward);
Protected procedure AllocateHandles; override;
Protected class procedure CheckLib;
Protected procedure DestroyHandles; override;

Properties

Published property Batch: Integer read FBatch write SetBatch default 1;
Published property Depth: Integer read FDepth write SetDepth default 0;
Published property Height: Integer read FHeight write SetHeight default 0;
Published property Transform: TCUDAFFTransform read FTransform write SetTransform default fftRealToComplex;
Published property Width: Integer read fWidth write SetWidth default 256;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAGraphics

Unit GLSCUDAGraphics

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSCUDAGraphics<p>

<b>History : </b><font size=-1><ul> <li>05/03/11 - Yar - Moved and remake TGLFeedBackMesh from experimental to GLSCUDAGraphics, removed TGLFactory mediator component Added to TGLFeedBackMesh vertex attribute collection <li>01/04/10 - Yar - Creation </ul></font><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLVertexAttribute |
Class TGLVertexAttributes |
Class TGLCustomFeedBackMesh |
Class TGLFeedBackMesh |
Class TCUDAGLImageResource |
Class TCUDAGLGeometryResource |

Types

TOnBeforeKernelLaunch = procedure(Sender: TGLVertexAttribute) of object;
TFeedBackMeshPrimitive = (...);
TFeedBackMeshLaunching = (...);

Description

Types

TOnBeforeKernelLaunch = procedure(Sender: TGLVertexAttribute) of object;
TFeedBackMeshPrimitive = (...);
Values
  • fbmpPoint:
  • fbmpLine:
  • fbmpTriangle:
TFeedBackMeshLaunching = (...);
Values
  • fblCommon:
  • fblOnePerAtttribute:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAGraphics: Class TGLVertexAttribute

Class TGLVertexAttribute

Unit

GLSCUDAGraphics

Declaration

type TGLVertexAttribute = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLVertexAttribute

Overview

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | procedure NotifyChange(Sender: TObject);

Properties

Published | property GLSLType: TGLSLDataType read FType write SetType;
Published | property KernelFunction: TCUDAFunction read FFunc write SetFunc;
Public | property Location: TGLint read GetLocation;
Published | property Name: string read FName write SetName;
Published | property OnBeforeKernelLaunch: TOnBeforeKernelLaunch read FOnBeforeKernelLaunch write FOnBeforeKernelLaunch;

Description

Methods

Public constructor Create(ACollection: TCollection); override;
Public procedure NotifyChange(Sender: TObject);

Properties

Published property GLSLType: TGLSLDataType read FType write SetType;
Published property KernelFunction: TCUDAFunction read FFunc write SetFunc;
Public property Location: TGLint read GetLocation;
Published property Name: string read FName write SetName;
Published property OnBeforeKernelLaunch: TOnBeforeKernelLaunch read FOnBeforeKernelLaunch write FOnBeforeKernelLaunch;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAGraphics: Class TGLVertexAttributes

Class TGLVertexAttributes

Unit

GLSCUDAGraphics

Declaration

type TGLVertexAttributes = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLVertexAttributes

Overview

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLVertexAttribute;
Public | function GetAttributeByName(const AName: string): TGLVertexAttribute;
Public | function MakeUniqueName(const ANameRoot: string): string;
Public | procedure NotifyChange(Sender: TObject);

Properties

Public property Attributes[Index: Integer]: TGLVertexAttribute read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TComponent);
Public function Add: TGLVertexAttribute;
Public function GetAttributeByName(const AName: string): TGLVertexAttribute;
Public function MakeUniqueName(const ANameRoot: string): string;
Public procedure NotifyChange(Sender: TObject);

Properties

Public property Attributes[Index: Integer]: TGLVertexAttribute read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAGraphics: Class TGLCustomFeedBackMesh

Class TGLCustomFeedBackMesh

Unit

GLSCUDAGraphics

Declaration

type TGLCustomFeedBackMesh = class(TGLBaseSceneObject)

Description

no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomFeedBackMesh

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected | procedure AllocateHandles;
Protected | procedure LaunchKernels;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure RefreshAttributes;

Properties

Public | property ArrayBufferHandle: TGLVBOArrayBufferHandle read FVBO;
Protected | property Attributes: TGLVertexAttributes read FAttributes write SetAttributes;
Protected | property Blend: Boolean read FBlend write FBlend default False;
Protected | property CommonKernelFunction: TCUDAFunction read FCommonFunc write SetCommonFunc;
Public | property ElementArrayHandle: TGLVBOElementArrayHandle read FEBO;
Protected | property ElementNumber: Integer read FElementNumber write SetElementNumber default 0;
Protected | property Launching: TFeedBackMeshLaunching read FLaunching write FLaunching default fblCommon;
Protected | property PrimitiveType: TFeedBackMeshPrimitive read FPrimitiveType write SetPrimitiveType default fbmpPoint;
Protected | property Shader: TGLSLShader read FShader write SetShader;
Protected | property VertexNumber: Integer read FVertexNumber write SetVertexNumber default 1;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected procedure AllocateHandles;
Protected procedure LaunchKernels;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure RefreshAttributes;

Properties

Public property ArrayBufferHandle: TGLVBOArrayBufferHandle read FVBO;
Protected property Attributes: TGLVertexAttributes read FAttributes write SetAttributes;
Protected property Blend: Boolean read FBlend write FBlend default False;

Defines if the object uses blending for object sorting purposes.

Protected property CommonKernelFunction: TCUDAFunction read FCommonFunc write SetCommonFunc;

Used for all attributes and elements if Launching = fblCommon otherwise used own attribute function and this for elements.

Public property ElementArrayHandle: TGLVBOElementArrayHandle read FEBO;
Protected property ElementNumber: Integer read FElementNumber write SetElementNumber default 0;
Protected property Launching: TFeedBackMeshLaunching read FLaunching write FLaunching default fblCommon;

Define mode of manufacturer launching: fblCommon - single launch for all, flOnePerAtttribute - one launch per attribute and elements

Protected property PrimitiveType: TFeedBackMeshPrimitive read FPrimitiveType write SetPrimitiveType default fbmpPoint;
Protected property Shader: TGLSLShader read FShader write SetShader;
Protected property VertexNumber: Integer read FVertexNumber write SetVertexNumber default 1;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAGraphics: Class TGLFeedBackMesh

Class TGLFeedBackMesh

Unit

GLSCUDAGraphics

Declaration

type TGLFeedBackMesh = class(TGLCustomFeedBackMesh)

Description

no description available, TGLCustomFeedBackMesh description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomFeedBackMesh
  • TGLFeedBackMesh

Overview

Properties

Published | property Attributes;
Published | property Behaviours;
Published | property Blend;
Published | property CommonKernelFunction;
Published | property Direction;
Published | property Effects;
Published | property ElementNumber;
Published | property Launching;
Published | property ObjectsSorting;
Published | property OnPicked;
Published | property OnProgress;
Published | property Pickable;
Published | property PitchAngle;
Published | property Position;
Published | property PrimitiveType;
Published | property RollAngle;
Published | property Scale;
Published | property Shader;
Published | property ShowAxes;
Published | property TurnAngle;
Published | property Up;
Published | property VertexNumber;
Published | property VisibilityCulling;
Published | property Visible;

Description

Properties

Published property Attributes;
Published property Behaviours;
Published property Blend;
Published property CommonKernelFunction;
Published property Direction;
Published property Effects;
Published property ElementNumber;
Published property Launching;
Published property ObjectsSorting;
Published property OnPicked;
Published property OnProgress;
Published property Pickable;
Published property PitchAngle;
Published property Position;
Published property PrimitiveType;
Published property RollAngle;
Published property Scale;
Published property Shader;
Published property ShowAxes;
Published property TurnAngle;
Published property Up;
Published property VertexNumber;
Published property VisibilityCulling;
Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAGraphics: Class TCUDAGLImageResource

Class TCUDAGLImageResource

Unit

GLSCUDAGraphics

Declaration

type TCUDAGLImageResource = class(TCUDAGraphicResource)

Description

no description available, TCUDAGraphicResource description follows
no description available, TCUDAComponent description follows
no description available, TCUDAHandlesMaster description follows

Hierarchy

  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAGraphicResource
  • TCUDAGLImageResource

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BindArrayToTexture(var cudaArray: TCUDAMemData; ALeyer, ALevel: LOngWord); override;
Public | procedure MapResources; override;
Public | procedure UnMapResources; override;
Protected | procedure AllocateHandles; override;
Protected | procedure DestroyHandles; override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property Mapping;
Published | property MaterialLibrary: TGLMaterialLibrary read fMaterialLibrary write SetMaterialLibrary;
Published | property TextureName: TGLLibMaterialName read fTextureName write SetTextureName;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure BindArrayToTexture(var cudaArray: TCUDAMemData; ALeyer, ALevel: LOngWord); override;
Public procedure MapResources; override;
Public procedure UnMapResources; override;
Protected procedure AllocateHandles; override;
Protected procedure DestroyHandles; override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published property Mapping;
Published property MaterialLibrary: TGLMaterialLibrary read fMaterialLibrary write SetMaterialLibrary;
Published property TextureName: TGLLibMaterialName read fTextureName write SetTextureName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAGraphics: Class TCUDAGLGeometryResource

Class TCUDAGLGeometryResource

Unit

GLSCUDAGraphics

Declaration

type TCUDAGLGeometryResource = class(TCUDAGraphicResource)

Description

no description available, TCUDAGraphicResource description follows
no description available, TCUDAComponent description follows
no description available, TCUDAHandlesMaster description follows

Hierarchy

  • TComponent
  • TCUDAHandlesMaster
  • TCUDAComponent
  • TCUDAGraphicResource
  • TCUDAGLGeometryResource

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function GetAttributeArrayAddress(const AName: string): Pointer; override;
Protected | function GetAttributeArraySize(const AName: string): LongWord; override;
Protected | function GetElementArrayAddress: Pointer; override;
Protected | function GetElementArrayDataSize: LongWord; override;
Public | procedure MapResources; override;
Public | procedure UnMapResources; override;
Protected | procedure AllocateHandles; override;
Protected | procedure DestroyHandles; override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Public | property AttributeDataAddress[const AttribName: string]: Pointer read GetAttributeArrayAddress;
Public | property AttributeDataSize[const AttribName: string]: LongWord read GetAttributeArraySize;
Published | property FeedBackMesh: TGLCustomFeedBackMesh read FFeedBackMesh write SetFeedBackMesh;
Public | property IndexDataAddress: Pointer read GetElementArrayAddress;
Public | property IndexDataSize: LongWord read GetElementArrayDataSize;
Published | property Mapping;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function GetAttributeArrayAddress(const AName: string): Pointer; override;
Protected function GetAttributeArraySize(const AName: string): LongWord; override;
Protected function GetElementArrayAddress: Pointer; override;
Protected function GetElementArrayDataSize: LongWord; override;
Public procedure MapResources; override;
Public procedure UnMapResources; override;
Protected procedure AllocateHandles; override;
Protected procedure DestroyHandles; override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Public property AttributeDataAddress[const AttribName: string]: Pointer read GetAttributeArrayAddress;
Public property AttributeDataSize[const AttribName: string]: LongWord read GetAttributeArraySize;
Published property FeedBackMesh: TGLCustomFeedBackMesh read FFeedBackMesh write SetFeedBackMesh;
Public property IndexDataAddress: Pointer read GetElementArrayAddress;
Public property IndexDataSize: LongWord read GetElementArrayDataSize;
Published property Mapping;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAParser

Unit GLSCUDAParser

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSCUDAParser <p>

Helper unit for parsing CU modules and get information about.<p> kernel's functions, textures, shared and constants memory.<p>

<b>History : </b><font size=-1><ul> <li>13/04/11 - Yar - Added Ptx parsing to get real function's KernelName <li>17/02/11 - Yar - Now parse module instead of compiler product <li>19/03/10 - Yar - Creation </ul></font><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TCUDATexRefInfo |
record TCUDAFuncArgInfo |
record TCUDAFuncInfo |
record TCUDAConstantInfo |
Class TCUDAModuleInfo |

Types

TCUDAType = (...);

Description

Types

TCUDAType = (...);
Values
  • customType:
  • char1:
  • uchar1:
  • char2:
  • uchar2:
  • char3:
  • uchar3:
  • char4:
  • uchar4:
  • short1:
  • ushort1:
  • short2:
  • ushort2:
  • short3:
  • ushort3:
  • short4:
  • ushort4:
  • int1:
  • uint1:
  • int2:
  • uint2:
  • int3:
  • uint3:
  • int4:
  • uint4:
  • long1:
  • ulong1:
  • long2:
  • ulong2:
  • long3:
  • ulong3:
  • long4:
  • ulong4:
  • float1:
  • float2:
  • float3:
  • float4:
  • longlong1:
  • ulonglong1:
  • longlong2:
  • ulonglong2:
  • longlong3:
  • ulonglong3:
  • longlong4:
  • ulonglong4:
  • double1:
  • double2:
  • double3:
  • double4:
  • int8:
  • int16:
  • int32:
  • uint8:
  • uint16:
  • uint32:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAParser: record TCUDATexRefInfo

record TCUDATexRefInfo

Unit

GLSCUDAParser

Declaration

type TCUDATexRefInfo = record

Description

Overview

Fields

Name: string;
DataType: TCUDAType;
Dim: Byte;
ReadMode: TcudaTextureReadMode;

Description

Fields

Name: string;
DataType: TCUDAType;
Dim: Byte;
ReadMode: TcudaTextureReadMode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAParser: record TCUDAFuncArgInfo

record TCUDAFuncArgInfo

Unit

GLSCUDAParser

Declaration

type TCUDAFuncArgInfo = record

Description

Overview

Fields

Name: string;
DataType: TCUDAType;
CustomType: string;
Ref: Boolean;

Description

Fields

Name: string;
DataType: TCUDAType;
CustomType: string;
Ref: Boolean;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAParser: record TCUDAFuncInfo

record TCUDAFuncInfo

Unit

GLSCUDAParser

Declaration

type TCUDAFuncInfo = record

Description

Overview

Fields

Name: string;
KernelName: string;
Args: array of TCUDAFuncArgInfo;

Description

Fields

Name: string;
KernelName: string;
Args: array of TCUDAFuncArgInfo;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAParser: record TCUDAConstantInfo

record TCUDAConstantInfo

Unit

GLSCUDAParser

Declaration

type TCUDAConstantInfo = record

Description

Overview

Fields

Name: string;
DataType: TCUDAType;
CustomType: string;
Ref: Boolean;
DefValue: Boolean;

Description

Fields

Name: string;
DataType: TCUDAType;
CustomType: string;
Ref: Boolean;
DefValue: Boolean;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSCUDAParser: Class TCUDAModuleInfo

Class TCUDAModuleInfo

Unit

GLSCUDAParser

Declaration

type TCUDAModuleInfo = class(TObject)

Description

Hierarchy

  • TObject
  • TCUDAModuleInfo

Overview

Fields

Public | Owner: TComponent;
Public | TexRef: array of TCUDATexRefInfo;
Public | Func: array of TCUDAFuncInfo;
Public | Constant: array of TCUDAConstantInfo;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | procedure ParseModule(ASource, AProduct: TStrings);

Description

Fields

Public Owner: TComponent;
Public TexRef: array of TCUDATexRefInfo;
Public Func: array of TCUDAFuncInfo;
Public Constant: array of TCUDAConstantInfo;

Methods

Public constructor Create;
Public destructor Destroy; override;
Public procedure ParseModule(ASource, AProduct: TStrings);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:45


GLScene v.1.1.2: GLSDL

Unit GLSDL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

SDL<p>

<b>History : </b><font size=-1><ul> <li>22/01/13 - PW - Supplied with CPPB compatibility by suppressing $EXTERNALSYM ... directives <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>07/06/07 - DaStr - Added $I GLScene.inc <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTracekrID=1681585) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record UInt64 |
record SInt64 |
record TArg |
record TSDL_error |
record TStdio |
record TMem |
record TUnknown |
record TSDL_RWops |
record TSDL_TimerID |
record TSDL_AudioSpec |
record TSDL_AudioCVTFilter |
record TSDL_AudioCVT |
record TSDL_CDTrack |
record TSDL_CD |
record TTransAxis |
record TJoystick_hwdata |
record TBallDelta |
record TSDL_Joystick |
record TSDL_version |
record TSDL_KeySym |
record TSDL_ActiveEvent |
record TSDL_KeyboardEvent |
record TSDL_MouseMotionEvent |
record TSDL_MouseButtonEvent |
record TSDL_JoyAxisEvent |
record TSDL_JoyBallEvent |
record TSDL_JoyHatEvent |
record TSDL_JoyButtonEvent |
record TSDL_ResizeEvent |
record TSDL_QuitEvent |
record TSDL_UserEvent |
record TSDL_ExposeEvent |
record TSDL_SysWMmsg |
record TSDL_SysWMEvent |
record TSDL_Event |
record TSDL_Rect |
record TSDL_Color |
record TSDL_Palette |
record TSDL_PixelFormat |
record TSDL_BlitInfo |
record TSDL_Surface |
record TSDL_VideoInfo |
record TSDL_Overlay |
record TSDL_Cursor |
record TSDL_Mutex |
record TSDL_semaphore |
record TSDL_Cond |
record TSDL_Thread |
record TPoint |
record TRect |

Functions and Procedures

function SDL_Init(flags: UInt32): Integer; cdecl; external LibName;
function SDL_InitSubSystem(flags: UInt32): Integer; cdecl; external LibName;
procedure SDL_QuitSubSystem( flags : UInt32 ); cdecl; external LibName;
function SDL_WasInit( flags : UInt32 ): UInt32; cdecl; external LibName;
procedure SDL_Quit; cdecl; external LibName;
function SDL_RegisterApp(name: PAnsiChar; style: UInt32; h_Inst: Pointer): Integer; cdecl; external LibName;
function SDL_TABLESIZE(table: PAnsiChar): Integer;
function SDL_GetError: PAnsiChar; cdecl; external LibName;
procedure SDL_SetError(fmt: PAnsiChar); cdecl; external LibName;
procedure SDL_ClearError; cdecl; external LibName;
procedure SDL_OutOfMemory;
function SDL_RWFromFile(filename, mode: PAnsiChar): PSDL_RWops; cdecl; external LibName;
procedure SDL_FreeRW(area: PSDL_RWops); cdecl; external LibName;
function SDL_RWFromFP(fp: Pointer; autoclose: Integer): PSDL_RWops; cdecl; external LibName;
function SDL_RWFromMem(mem: Pointer; size: Integer): PSDL_RWops; cdecl; external LibName;
function SDL_AllocRW: PSDL_RWops; cdecl; external LibName;
function SDL_RWSeek(context: PSDL_RWops; offset: Integer; whence: Integer) : Integer;
function SDL_RWTell(context: PSDL_RWops): Integer;
function SDL_RWRead(context: PSDL_RWops; ptr: Pointer; size: Integer; n: Integer): Integer;
function SDL_RWWrite(context: PSDL_RWops; ptr: Pointer; size: Integer; n: Integer): Integer;
function SDL_RWClose(context: PSDL_RWops): Integer;
function SDL_GetTicks: UInt32; cdecl; external LibName;
procedure SDL_Delay(msec: UInt32); cdecl; external LibName;
function SDL_AddTimer(interval: UInt32; callback: TSDL_NewTimerCallback; param : Pointer): PSDL_TimerID; cdecl; external LibName;
function SDL_RemoveTimer(t: PSDL_TimerID): TSDL_Bool; cdecl; external LibName;
function SDL_SetTimer(interval: UInt32; callback: TSDL_TimerCallback): Integer; cdecl; external LibName;
function SDL_AudioInit(driver_name: PAnsiChar): Integer; cdecl; external LibName;
procedure SDL_AudioQuit; cdecl; external LibName;
function SDL_AudioDriverName(namebuf: PAnsiChar; maxlen: Integer): PAnsiChar; cdecl; external LibName;
function SDL_OpenAudio(desired, obtained: PSDL_AudioSpec): Integer; cdecl; external LibName;
function SDL_GetAudioStatus: TSDL_Audiostatus; cdecl; external LibName;
procedure SDL_PauseAudio(pause_on: Integer); cdecl; external LibName;
function SDL_LoadWAV_RW(src: PSDL_RWops; freesrc: Integer; spec: PSDL_AudioSpec; audio_buf: PUInt8; audiolen: PUInt32): PSDL_AudioSpec; cdecl; external LibName;
function SDL_LoadWAV(filename: PAnsiChar; spec: PSDL_AudioSpec; audio_buf: PUInt8; audiolen: PUInt32): PSDL_AudioSpec;
procedure SDL_FreeWAV(audio_buf: PUInt8); cdecl; external LibName;
function SDL_BuildAudioCVT(cvt: PSDL_AudioCVT; src_format: UInt16; src_channels: UInt8; src_rate: Integer; dst_format: UInt16; dst_channels: UInt8; dst_rate: Integer): Integer; cdecl; external LibName;
function SDL_ConvertAudio(cvt: PSDL_AudioCVT): Integer; cdecl; external LibName;
procedure SDL_MixAudio(dst, src: PUInt8; len: UInt32; volume: Integer); cdecl; external LibName;
procedure SDL_LockAudio; cdecl; external LibName;
procedure SDL_UnlockAudio; cdecl; external LibName;
procedure SDL_CloseAudio; cdecl; external LibName;
function SDL_CDNumDrives: Integer; cdecl; external LibName;
function SDL_CDName(drive: Integer): PAnsiChar; cdecl; external LibName;
function SDL_CDOpen(drive: Integer): PSDL_CD; cdecl; external LibName;
function SDL_CDStatus(cdrom: PSDL_CD): TSDL_CDStatus; cdecl; external LibName;
function SDL_CDPlayTracks(cdrom: PSDL_CD; start_track: Integer; start_frame: Integer; ntracks: Integer; nframes: Integer): Integer; cdecl; external LibName;
function SDL_CDPlay(cdrom: PSDL_CD; start: Integer; length: Integer): Integer; cdecl; external LibName;
function SDL_CDPause(cdrom: PSDL_CD): Integer; cdecl; external LibName;
function SDL_CDResume(cdrom: PSDL_CD): Integer; cdecl; external LibName;
function SDL_CDStop(cdrom: PSDL_CD): Integer; cdecl; external LibName;
function SDL_CDEject(cdrom: PSDL_CD): Integer; cdecl; external LibName;
procedure SDL_CDClose(cdrom: PSDL_CD); cdecl; external LibName;
function SDL_CDInDrive( status : TSDL_CDStatus ) : LongBool;
procedure FRAMES_TO_MSF(frames: Integer; var M: Integer; var S: Integer; var F: Integer);
function MSF_TO_FRAMES(M: Integer; S: Integer; F: Integer): Integer;
function SDL_NumJoysticks: Integer; cdecl; external LibName;
function SDL_JoystickName(index: Integer): PAnsiChar; cdecl; external LibName;
function SDL_JoystickOpen(index: Integer): PSDL_Joystick; cdecl; external LibName;
function SDL_JoystickOpened(index: Integer): Integer; cdecl; external LibName;
function SDL_JoystickIndex(joystick: PSDL_Joystick): Integer; cdecl; external LibName;
function SDL_JoystickNumAxes(joystick: PSDL_Joystick): Integer; cdecl; external LibName;
function SDL_JoystickNumBalls(joystick: PSDL_Joystick): Integer; cdecl; external LibName;
function SDL_JoystickNumHats(joystick: PSDL_Joystick): Integer; cdecl; external LibName;
function SDL_JoystickNumButtons(joystick: PSDL_Joystick): Integer; cdecl; external LibName;
procedure SDL_JoystickUpdate; cdecl; external LibName;
function SDL_JoystickEventState(state: Integer): Integer; cdecl; external LibName;
function SDL_JoystickGetAxis(joystick: PSDL_Joystick; axis: Integer): SInt16; cdecl; external LibName;
function SDL_JoystickGetHat(joystick: PSDL_Joystick; hat: Integer): UInt8; cdecl; external LibName;
function SDL_JoystickGetBall(joystick: PSDL_Joystick; ball: Integer; var dx: Integer; var dy: Integer): Integer; cdecl; external LibName;
function SDL_JoystickGetButton( joystick: PSDL_Joystick; Button: Integer): UInt8; cdecl; external LibName;
procedure SDL_JoystickClose(joystick: PSDL_Joystick); cdecl; external LibName;
procedure SDL_PumpEvents; cdecl; external LibName;
function SDL_PeepEvents(events: PSDL_Event; numevents: Integer; action: TSDL_eventaction; mask: UInt32): Integer; cdecl; external LibName;
function SDL_PollEvent(event: PSDL_Event): Integer; cdecl; external LibName;
function SDL_WaitEvent(event: PSDL_Event): Integer; cdecl; external LibName;
function SDL_PushEvent( event : PSDL_Event ) : Integer; cdecl; external LibName;
procedure SDL_SetEventFilter( filter : TSDL_EventFilter ); cdecl; external LibName;
function SDL_GetEventFilter: TSDL_EventFilter; cdecl; external LibName;
function SDL_EventState(type_: UInt8; state: Integer): UInt8; cdecl; external LibName;
procedure SDL_VERSION(var X: TSDL_Version);
function SDL_VERSIONNUM(X, Y, Z: Integer): Integer;
function SDL_COMPILEDVERSION: Integer;
function SDL_VERSION_ATLEAST(X: Integer; Y: Integer; Z: Integer): LongBool;
function SDL_Linked_Version: TSDL_version; cdecl; external LibName;
function SDL_VideoInit(driver_name: PAnsiChar; flags: UInt32): Integer; cdecl; external LibName;
procedure SDL_VideoQuit; cdecl; external LibName;
function SDL_VideoDriverName(namebuf: PAnsiChar; maxlen: Integer): PAnsiChar; cdecl; external LibName;
function SDL_GetVideoSurface: PSDL_Surface; cdecl; external LibName;
function SDL_GetVideoInfo: PSDL_VideoInfo; cdecl; external LibName;
function SDL_VideoModeOK(width, height, bpp: Integer; flags: UInt32): Integer; cdecl; external LibName;
function SDL_ListModes(format: PSDL_PixelFormat; flags: UInt32): PPSDL_Rect; cdecl; external LibName;
function SDL_SetVideoMode(width, height, bpp: Integer; flags: UInt32): PSDL_Surface; cdecl; external LibName;
procedure SDL_UpdateRects(screen: PSDL_Surface; numrects: Integer; rects: PSDL_Rect); cdecl; external LibName;
procedure SDL_UpdateRect(screen: PSDL_Surface; x, y: SInt32; w, h: UInt32); cdecl; external LibName;
function SDL_Flip(screen: PSDL_Surface): Integer; cdecl; external LibName;
function SDL_SetGamma(redgamma: single; greengamma: single; bluegamma: single ): Integer; cdecl; external LibName;
function SDL_SetGammaRamp( redtable: PUInt16; greentable: PUInt16; bluetable: PUInt16): Integer; cdecl; external LibName;
function SDL_GetGammaRamp( redtable: PUInt16; greentable: PUInt16; bluetable: PUInt16): Integer; cdecl; external LibName;
function SDL_SetColors(surface: PSDL_Surface; colors: PSDL_Color; firstcolor : Integer; ncolors: Integer): Integer; cdecl; external LibName;
function SDL_SetPalette(surface: PSDL_Surface; flags: Integer; colors: PSDL_Color; firstcolor: Integer; ncolors: Integer): Integer; cdecl; external LibName;
function SDL_MapRGB(format: PSDL_PixelFormat; r: UInt8; g: UInt8; b: UInt8) : UInt32; cdecl; external LibName;
function SDL_MapRGBA(format: PSDL_PixelFormat; r: UInt8; g: UInt8; b: UInt8; a: UInt8): UInt32; cdecl; external LibName;
procedure SDL_GetRGB(pixel: UInt32; fmt: PSDL_PixelFormat; r: PUInt8; g: PUInt8; b: PUInt8); cdecl; external LibName;
procedure SDL_GetRGBA(pixel: UInt32; fmt: PSDL_PixelFormat; r: PUInt8; g: PUInt8; b: PUInt8; a: UInt8); cdecl; external LibName;
function SDL_AllocSurface(flags: UInt32; width, height, depth: Integer; RMask, GMask, BMask, AMask: UInt32): PSDL_Surface;
function SDL_CreateRGBSurface(flags: UInt32; width, height, depth: Integer; RMask, GMask, BMask, AMask: UInt32): PSDL_Surface; cdecl; external LibName;
function SDL_CreateRGBSurfaceFrom(pixels: Pointer; width, height, depth, pitch : Integer; RMask, GMask, BMask, AMask: UInt32): PSDL_Surface; cdecl; external LibName;
procedure SDL_FreeSurface(surface: PSDL_Surface); cdecl; external LibName;
function SDL_MustLock(Surface: PSDL_Surface): Boolean;
function SDL_LockSurface(surface: PSDL_Surface): Integer; cdecl; external LibName;
procedure SDL_UnlockSurface(surface: PSDL_Surface); cdecl; external LibName;
function SDL_LoadBMP_RW(src: PSDL_RWops; freesrc: Integer): PSDL_Surface; cdecl; external LibName;
function SDL_LoadBMP(filename: PAnsiChar): PSDL_Surface;
function SDL_SaveBMP_RW(surface: PSDL_Surface; dst: PSDL_RWops; freedst: Integer): Integer; cdecl; external LibName;
function SDL_SaveBMP(surface: PSDL_Surface; filename: PAnsiChar): Integer;
function SDL_SetColorKey(surface: PSDL_Surface; flag, key: UInt32): Integer; cdecl; external LibName;
function SDL_SetAlpha(surface: PSDL_Surface; flag: UInt32; alpha: UInt8): Integer; cdecl; external LibName;
procedure SDL_SetClipRect(surface: PSDL_Surface; rect: PSDL_Rect); cdecl; external LibName;
procedure SDL_GetClipRect(surface: PSDL_Surface; rect: PSDL_Rect); cdecl; external LibName;
function SDL_ConvertSurface(src: PSDL_Surface; fmt: PSDL_PixelFormat; flags: UInt32): PSDL_Surface; cdecl; external LibName;
function SDL_BlitSurface(src: PSDL_Surface; srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): Integer;
function SDL_UpperBlit(src: PSDL_Surface; srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): Integer; cdecl; external LibName;
function SDL_LowerBlit(src: PSDL_Surface; srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): Integer; cdecl; external LibName;
function SDL_FillRect(dst: PSDL_Surface; dstrect: PSDL_Rect; color: UInt32) : Integer; cdecl; external LibName;
function SDL_DisplayFormat(surface: PSDL_Surface): PSDL_Surface; cdecl; external LibName;
function SDL_DisplayFormatAlpha(surface: PSDL_Surface): PSDL_Surface; cdecl; external LibName;
function SDL_CreateYUVOverlay(width: Integer; height: Integer; format: UInt32; display: PSDL_Surface): PSDL_Overlay; cdecl; external LibName;
function SDL_LockYUVOverlay(Overlay: PSDL_Overlay): Integer; cdecl; external LibName;
procedure SDL_UnlockYUVOverlay(Overlay: PSDL_Overlay); cdecl; external LibName;
function SDL_DisplayYUVOverlay(Overlay: PSDL_Overlay; dstrect: PSDL_Rect): Integer; cdecl; external LibName;
procedure SDL_FreeYUVOverlay(Overlay: PSDL_Overlay); cdecl; external LibName;
function SDL_GL_LoadLibrary(filename: PChar): Integer; cdecl; external LibName;
function SDL_GL_GetProcAddress(procname: PChar) : Pointer; cdecl; external LibName;
function SDL_GL_SetAttribute(attr: TSDL_GLAttr; value: Integer): Integer; cdecl; external LibName;
function SDL_GL_GetAttribute(attr: TSDL_GLAttr; var value: Integer): Integer; cdecl; external LibName;
procedure SDL_GL_SwapBuffers; cdecl; external LibName;
procedure SDL_GL_UpdateRects(numrects: Integer; rects: PSDL_Rect); cdecl; external LibName;
procedure SDL_GL_Lock; cdecl; external LibName;
procedure SDL_GL_Unlock; cdecl; external LibName;
procedure SDL_WM_GetCaption(var title: PAnsiChar; var icon: PAnsiChar); cdecl; external LibName;
procedure SDL_WM_SetCaption(title, icon: PAnsiChar); cdecl; external LibName;
procedure SDL_WM_SetIcon(icon: PSDL_Surface; mask: UInt8); cdecl; external LibName;
function SDL_WM_IconifyWindow: Integer; cdecl; external LibName;
function SDL_WM_ToggleFullScreen(surface: PSDL_Surface): Integer; cdecl; external LibName;
function SDL_WM_GrabInput(mode: TSDL_GrabMode): TSDL_GrabMode; cdecl; external LibName;
function SDL_GetMouseState(var x: Integer; var y: Integer): UInt8; cdecl; external LibName;
function SDL_GetRelativeMouseState(var x: Integer; var y: Integer): UInt8; cdecl; external LibName;
procedure SDL_WarpMouse(x, y: UInt16); cdecl; external LibName;
function SDL_CreateCursor(data, mask: PUInt8; w, h, hot_x, hot_y: Integer): PSDL_Cursor; cdecl; external LibName;
procedure SDL_SetCursor(cursor: PSDL_Cursor); cdecl; external LibName;
function SDL_GetCursor: PSDL_Cursor; cdecl; external LibName;
procedure SDL_FreeCursor(cursor: PSDL_Cursor); cdecl; external LibName;
function SDL_ShowCursor(toggle: Integer): Integer; cdecl; external LibName;
function SDL_BUTTON( Button : Integer ) : Integer;
function SDL_EnableUNICODE(enable: Integer): Integer; cdecl; external LibName;
function SDL_EnableKeyRepeat(delay: Integer; interval: Integer): Integer; cdecl; external LibName;
function SDL_GetKeyState(numkeys: PInt): PUInt8; cdecl; external LibName;
function SDL_GetModState: TSDLMod; cdecl; external LibName;
procedure SDL_SetModState(modstate: TSDLMod); cdecl; external LibName;
function SDL_GetKeyName(key: TSDLKey): PAnsiChar; cdecl; external LibName;
function SDL_GetAppState: UInt8; cdecl; external LibName;
function SDL_CreateMutex: PSDL_Mutex; cdecl; external LibName;
function SDL_mutexP(mutex: PSDL_mutex): Integer; cdecl; external LibName;
function SDL_LockMutex(mutex: PSDL_mutex): Integer;
function SDL_mutexV(mutex: PSDL_mutex): Integer; cdecl; external LibName;
function SDL_UnlockMutex(mutex: PSDL_mutex): Integer;
procedure SDL_DestroyMutex(mutex: PSDL_mutex); cdecl; external LibName;
function SDL_CreateSemaphore(initial_value: UInt32): PSDL_Sem; cdecl; external LibName;
procedure SDL_DestroySemaphore(sem: PSDL_sem); cdecl; external LibName;
function SDL_SemWait(sem: PSDL_sem): Integer; cdecl; external LibName;
function SDL_SemTryWait(sem: PSDL_sem): Integer; cdecl; external LibName;
function SDL_SemWaitTimeout(sem: PSDL_sem; ms: UInt32): Integer; cdecl; external LibName;
function SDL_SemPost(sem: PSDL_sem): Integer; cdecl; external LibName;
function SDL_SemValue(sem: PSDL_sem): UInt32; cdecl; external LibName;
function SDL_CreateCond: PSDL_Cond; cdecl; external LibName;
procedure SDL_DestroyCond(cond: PSDL_Cond); cdecl; external LibName;
function SDL_CondSignal(cond: PSDL_cond): Integer; cdecl; external LibName;
function SDL_CondBroadcast(cond: PSDL_cond): Integer; cdecl; external LibName;
function SDL_CondWait(cond: PSDL_cond; mut: PSDL_mutex): Integer; cdecl; external LibName;
function SDL_CondWaitTimeout(cond: PSDL_cond; mut: PSDL_mutex; ms: UInt32) : Integer; cdecl; external LibName;
function SDL_CreateThread(fn: PInt; data: Pointer): PSDL_Thread; cdecl; external LibName;
function SDL_ThreadID: UInt32; cdecl; external LibName;
function SDL_GetThreadID(thread: PSDL_Thread): UInt32; cdecl; external LibName;
procedure SDL_WaitThread(thread: PSDL_Thread; var status: Integer); cdecl; external LibName;
procedure SDL_KillThread(thread: PSDL_Thread); cdecl; external LibName;
function _putenv( const variable : PAnsiChar ): integer; cdecl;
function SDL_putenv(const variable: PAnsiChar): integer;
function getenv( const name : PAnsiChar ): PAnsiChar; cdecl;
function SDL_getenv(const name: PAnsiChar): PAnsiChar;
function SDL_Swap32(D: Uint32): Uint32;
procedure FreeAndNil(var Obj);

Types

TSDL_Bool = (...);
PUInt8Array = ˆTUInt8Array;
PUInt8 = ˆUInt8;
UInt8 = Byte;
TUInt8Array = array [0..MAXINT shr 1] of UInt8;
PUInt16 = ˆUInt16;
UInt16 = word;
SInt16 = smallint;
PUInt32 = ˆUInt32;
UInt32 = Cardinal;
SInt32 = Integer;
PInt = ˆInteger;
PUInt64 = ˆUInt64;
PSInt64 = ˆSInt64;
TSDL_errorcode = (...);
SDL_errorcode = TSDL_errorcode;
PSDL_error = ˆTSDL_error;
PSDL_RWops = ˆTSDL_RWops;
TSeek = function(context: PSDL_RWops; offset: Integer; whence: Integer): Integer; cdecl;
TRead = function(context: PSDL_RWops; Ptr: Pointer; size: Integer; maxnum : Integer): Integer; cdecl;
TWrite = function(context: PSDL_RWops; Ptr: Pointer; size: Integer; num: Integer): Integer; cdecl;
TClose = function(context: PSDL_RWops): Integer; cdecl;
SDL_RWops = TSDL_RWops;
TSDL_TimerCallback = function(interval: UInt32): UInt32; cdecl;
TSDL_NewTimerCallback = function(interval: UInt32; param: Pointer): UInt32; cdecl;
PSDL_TimerID = ˆTSDL_TimerID;
PSDL_AudioSpec = ˆTSDL_AudioSpec;
PSDL_AudioCVT = ˆTSDL_AudioCVT;
PSDL_AudioCVTFilter = ˆTSDL_AudioCVTFilter;
PSDL_AudioCVTFilterArray = ˆTSDL_AudioCVTFilterArray;
TSDL_AudioCVTFilterArray = array[0..9] of TSDL_AudioCVTFilter;
TSDL_Audiostatus = (...);
TSDL_CDStatus = (...);
PSDL_CDTrack = ˆTSDL_CDTrack;
PSDL_CD = ˆTSDL_CD;
PTransAxis = ˆTTransAxis;
PJoystick_hwdata = ˆTJoystick_hwdata;
PBallDelta = ˆTBallDelta;
PSDL_Joystick = ˆTSDL_Joystick;
PSDL_version = ˆTSDL_version;
TSDLKey = LongWord;
TSDLMod = LongWord;
PSDL_KeySym = ˆTSDL_KeySym;
TSDL_EventAction = (...);
PSDL_QuitEvent = ˆTSDL_QuitEvent;
PSDL_UserEvent = ˆTSDL_UserEvent;
PSDL_ExposeEvent = ˆTSDL_ExposeEvent;
PSDL_SysWMmsg = ˆTSDL_SysWMmsg;
PSDL_SysWMEvent = ˆTSDL_SysWMEvent;
PSDL_Event = ˆTSDL_Event;
TSDL_EventFilter = function(event: PSDL_Event): Integer; cdecl;
PPSDL_Rect = ˆPSDL_Rect;
PSDL_Rect = ˆTSDL_Rect;
SDL_Rect = TSDL_Rect;
PSDL_Color = ˆTSDL_Color;
PSDL_ColorArray = ˆTSDL_ColorArray;
TSDL_ColorArray = array[0..65000] of TSDL_Color;
PSDL_Palette = ˆTSDL_Palette;
PSDL_PixelFormat = ˆTSDL_PixelFormat;
PSDL_BlitInfo = ˆTSDL_BlitInfo;
PSDL_Surface = ˆTSDL_Surface;
TSDL_Blit = function(src: PSDL_Surface; srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): Integer; cdecl;
PSDL_VideoInfo = ˆTSDL_VideoInfo;
PSDL_Overlay = ˆTSDL_Overlay;
TSDL_GLAttr = (...);
TSDL_GrabMode = (...);
PSDL_Cursor = ˆTSDL_Cursor;
PSDL_Mutex = ˆTSDL_Mutex;
PSDL_semaphore = ˆTSDL_semaphore;
PSDL_Sem = ˆTSDL_Sem;
TSDL_Sem = TSDL_Semaphore;
PSDL_Cond = ˆTSDL_Cond;
TSYS_ThreadHandle = THandle;
PSDL_Thread = ˆTSDL_Thread;
PKeyStateArr = ˆTKeyStateArr;
TKeyStateArr = array[0..65000] of UInt8;
PInteger = ˆInteger;
PByte = ˆByte;
PWord = ˆWord;
PLongWord = ˆLongword;
PByteArray = ˆTByteArray;
TByteArray = array[0..32767] of Byte;
PWordArray = ˆTWordArray;
TWordArray = array[0..16383] of Word;
PPoint = ˆTPoint;
PRect = ˆTRect;

Constants

LibName = 'SDL.dll';
SDL_INIT_TIMER = $00000001;
SDL_INIT_AUDIO = $00000010;
SDL_INIT_VIDEO = $00000020;
SDL_INIT_CDROM = $00000100;
SDL_INIT_JOYSTICK = $00000200;
SDL_INIT_NOPARACHUTE = $00100000;
SDL_INIT_EVENTTHREAD = $01000000;
SDL_INIT_EVERYTHING = $0000FFFF;
ERR_MAX_STRLEN = 128;
ERR_MAX_ARGS = 5;
SDL_PRESSED = $01;
SDL_RELEASED = $00;
SDL_TIMESLICE = 10;
TIMER_RESOLUTION = 10;
AUDIO_U8 = $0008;
AUDIO_S8 = $8008;
AUDIO_U16LSB = $0010;
AUDIO_S16LSB = $8010;
AUDIO_U16MSB = $1010;
AUDIO_S16MSB = $9010;
AUDIO_U16 = AUDIO_U16LSB;
AUDIO_S16 = AUDIO_S16LSB;
SDL_MAX_TRACKS = 99;
SDL_AUDIO_TRACK = $00;
SDL_DATA_TRACK = $04;
CD_FPS = 75;
SDL_LIL_ENDIAN = 1234;
SDL_BIG_ENDIAN = 4321;
SDL_BYTEORDER = SDL_LIL_ENDIAN;
AUDIO_U16SYS = AUDIO_U16LSB;
AUDIO_S16SYS = AUDIO_S16LSB;
SDL_MIX_MAXVOLUME = 128;
MAX_JOYSTICKS = 2;
MAX_AXES = 6;
MAX_BUTTONS = 32;
AXIS_MIN = -32768;
AXIS_MAX = 32767;
JOY_AXIS_THRESHOLD = (((AXIS_MAX) - (AXIS_MIN)) / 100);
SDL_HAT_CENTERED = $00;
SDL_HAT_UP = $01;
SDL_HAT_RIGHT = $02;
SDL_HAT_DOWN = $04;
SDL_HAT_LEFT = $08;
SDL_HAT_RIGHTUP = SDL_HAT_RIGHT or SDL_HAT_UP;
SDL_HAT_RIGHTDOWN = SDL_HAT_RIGHT or SDL_HAT_DOWN;
SDL_HAT_LEFTUP = SDL_HAT_LEFT or SDL_HAT_UP;
SDL_HAT_LEFTDOWN = SDL_HAT_LEFT or SDL_HAT_DOWN;
SDL_MAJOR_VERSION = 1;
SDL_MINOR_VERSION = 2;
SDL_PATCHLEVEL = 3;
SDL_NOEVENT = 0;
SDL_ACTIVEEVENT = 1;
SDL_KEYDOWN = 2;
SDL_KEYUP = 3;
SDL_MOUSEMOTION = 4;
SDL_MOUSEBUTTONDOWN = 5;
SDL_MOUSEBUTTONUP = 6;
SDL_JOYAXISMOTION = 7;
SDL_JOYBALLMOTION = 8;
SDL_JOYHATMOTION = 9;
SDL_JOYBUTTONDOWN = 10;
SDL_JOYBUTTONUP = 11;
SDL_QUITEV = 12;
SDL_SYSWMEVENT = 13;
SDL_EVENT_RESERVEDA = 14;
SDL_EVENT_RESERVED = 15;
SDL_VIDEORESIZE = 16;
SDL_VIDEOEXPOSE = 17;
SDL_EVENT_RESERVED2 = 18;
SDL_EVENT_RESERVED3 = 19;
SDL_EVENT_RESERVED4 = 20;
SDL_EVENT_RESERVED5 = 21;
SDL_EVENT_RESERVED6 = 22;
SDL_EVENT_RESERVED7 = 23;
SDL_USEREVENT = 24;
SDL_NUMEVENTS = 32;
SDL_ALLEVENTS = $FFFFFFFF;
SDL_ACTIVEEVENTMASK = 1 shl SDL_ACTIVEEVENT;
SDL_KEYDOWNMASK = 1 shl SDL_KEYDOWN;
SDL_KEYUPMASK = 1 shl SDL_KEYUP;
SDL_MOUSEMOTIONMASK = 1 shl SDL_MOUSEMOTION;
SDL_MOUSEBUTTONDOWNMASK = 1 shl SDL_MOUSEBUTTONDOWN;
SDL_MOUSEBUTTONUPMASK = 1 shl SDL_MOUSEBUTTONUP;
SDL_MOUSEEVENTMASK = 1 shl SDL_MOUSEMOTION or 1 shl SDL_MOUSEBUTTONDOWN or 1 shl SDL_MOUSEBUTTONUP;
SDL_JOYAXISMOTIONMASK = 1 shl SDL_JOYAXISMOTION;
SDL_JOYBALLMOTIONMASK = 1 shl SDL_JOYBALLMOTION;
SDL_JOYHATMOTIONMASK = 1 shl SDL_JOYHATMOTION;
SDL_JOYBUTTONDOWNMASK = 1 shl SDL_JOYBUTTONDOWN;
SDL_JOYBUTTONUPMASK = 1 shl SDL_JOYBUTTONUP;
SDL_JOYEVENTMASK = 1 shl SDL_JOYAXISMOTION or 1 shl SDL_JOYBALLMOTION or 1 shl SDL_JOYHATMOTION or 1 shl SDL_JOYBUTTONDOWN or 1 shl SDL_JOYBUTTONUP;
SDL_VIDEORESIZEMASK = 1 shl SDL_VIDEORESIZE;
SDL_QUITMASK = 1 shl SDL_QUITEV;
SDL_SYSWMEVENTMASK = 1 shl SDL_SYSWMEVENT;
SDL_QUERY = -1;
SDL_IGNORE = 0;
SDL_DISABLE = 0;
SDL_ENABLE = 1;
SDL_ALL_HOTKEYS = $FFFFFFFF;
SDL_DEFAULT_REPEAT_DELAY = 500;
SDL_DEFAULT_REPEAT_INTERVAL = 30;
SDLK_UNKNOWN = 0;
SDLK_FIRST = 0;
SDLK_BACKSPACE = 8;
SDLK_TAB = 9;
SDLK_CLEAR = 12;
SDLK_RETURN = 13;
SDLK_PAUSE = 19;
SDLK_ESCAPE = 27;
SDLK_SPACE = 32;
SDLK_EXCLAIM = 33;
SDLK_QUOTEDBL = 34;
SDLK_HASH = 35;
SDLK_DOLLAR = 36;
SDLK_AMPERSAND = 38;
SDLK_QUOTE = 39;
SDLK_LEFTPAREN = 40;
SDLK_RIGHTPAREN = 41;
SDLK_ASTERISK = 42;
SDLK_PLUS = 43;
SDLK_COMMA = 44;
SDLK_MINUS = 45;
SDLK_PERIOD = 46;
SDLK_SLASH = 47;
SDLK_0 = 48;
SDLK_1 = 49;
SDLK_2 = 50;
SDLK_3 = 51;
SDLK_4 = 52;
SDLK_5 = 53;
SDLK_6 = 54;
SDLK_7 = 55;
SDLK_8 = 56;
SDLK_9 = 57;
SDLK_COLON = 58;
SDLK_SEMICOLON = 59;
SDLK_LESS = 60;
SDLK_EQUALS = 61;
SDLK_GREATER = 62;
SDLK_QUESTION = 63;
SDLK_AT = 64;
SDLK_LEFTBRACKET = 91;
SDLK_BACKSLASH = 92;
SDLK_RIGHTBRACKET = 93;
SDLK_CARET = 94;
SDLK_UNDERSCORE = 95;
SDLK_BACKQUOTE = 96;
SDLK_a = 97;
SDLK_b = 98;
SDLK_c = 99;
SDLK_d = 100;
SDLK_e = 101;
SDLK_f = 102;
SDLK_g = 103;
SDLK_h = 104;
SDLK_i = 105;
SDLK_j = 106;
SDLK_k = 107;
SDLK_l = 108;
SDLK_m = 109;
SDLK_n = 110;
SDLK_o = 111;
SDLK_p = 112;
SDLK_q = 113;
SDLK_r = 114;
SDLK_s = 115;
SDLK_t = 116;
SDLK_u = 117;
SDLK_v = 118;
SDLK_w = 119;
SDLK_x = 120;
SDLK_y = 121;
SDLK_z = 122;
SDLK_DELETE = 127;
SDLK_WORLD_0 = 160;
SDLK_WORLD_1 = 161;
SDLK_WORLD_2 = 162;
SDLK_WORLD_3 = 163;
SDLK_WORLD_4 = 164;
SDLK_WORLD_5 = 165;
SDLK_WORLD_6 = 166;
SDLK_WORLD_7 = 167;
SDLK_WORLD_8 = 168;
SDLK_WORLD_9 = 169;
SDLK_WORLD_10 = 170;
SDLK_WORLD_11 = 171;
SDLK_WORLD_12 = 172;
SDLK_WORLD_13 = 173;
SDLK_WORLD_14 = 174;
SDLK_WORLD_15 = 175;
SDLK_WORLD_16 = 176;
SDLK_WORLD_17 = 177;
SDLK_WORLD_18 = 178;
SDLK_WORLD_19 = 179;
SDLK_WORLD_20 = 180;
SDLK_WORLD_21 = 181;
SDLK_WORLD_22 = 182;
SDLK_WORLD_23 = 183;
SDLK_WORLD_24 = 184;
SDLK_WORLD_25 = 185;
SDLK_WORLD_26 = 186;
SDLK_WORLD_27 = 187;
SDLK_WORLD_28 = 188;
SDLK_WORLD_29 = 189;
SDLK_WORLD_30 = 190;
SDLK_WORLD_31 = 191;
SDLK_WORLD_32 = 192;
SDLK_WORLD_33 = 193;
SDLK_WORLD_34 = 194;
SDLK_WORLD_35 = 195;
SDLK_WORLD_36 = 196;
SDLK_WORLD_37 = 197;
SDLK_WORLD_38 = 198;
SDLK_WORLD_39 = 199;
SDLK_WORLD_40 = 200;
SDLK_WORLD_41 = 201;
SDLK_WORLD_42 = 202;
SDLK_WORLD_43 = 203;
SDLK_WORLD_44 = 204;
SDLK_WORLD_45 = 205;
SDLK_WORLD_46 = 206;
SDLK_WORLD_47 = 207;
SDLK_WORLD_48 = 208;
SDLK_WORLD_49 = 209;
SDLK_WORLD_50 = 210;
SDLK_WORLD_51 = 211;
SDLK_WORLD_52 = 212;
SDLK_WORLD_53 = 213;
SDLK_WORLD_54 = 214;
SDLK_WORLD_55 = 215;
SDLK_WORLD_56 = 216;
SDLK_WORLD_57 = 217;
SDLK_WORLD_58 = 218;
SDLK_WORLD_59 = 219;
SDLK_WORLD_60 = 220;
SDLK_WORLD_61 = 221;
SDLK_WORLD_62 = 222;
SDLK_WORLD_63 = 223;
SDLK_WORLD_64 = 224;
SDLK_WORLD_65 = 225;
SDLK_WORLD_66 = 226;
SDLK_WORLD_67 = 227;
SDLK_WORLD_68 = 228;
SDLK_WORLD_69 = 229;
SDLK_WORLD_70 = 230;
SDLK_WORLD_71 = 231;
SDLK_WORLD_72 = 232;
SDLK_WORLD_73 = 233;
SDLK_WORLD_74 = 234;
SDLK_WORLD_75 = 235;
SDLK_WORLD_76 = 236;
SDLK_WORLD_77 = 237;
SDLK_WORLD_78 = 238;
SDLK_WORLD_79 = 239;
SDLK_WORLD_80 = 240;
SDLK_WORLD_81 = 241;
SDLK_WORLD_82 = 242;
SDLK_WORLD_83 = 243;
SDLK_WORLD_84 = 244;
SDLK_WORLD_85 = 245;
SDLK_WORLD_86 = 246;
SDLK_WORLD_87 = 247;
SDLK_WORLD_88 = 248;
SDLK_WORLD_89 = 249;
SDLK_WORLD_90 = 250;
SDLK_WORLD_91 = 251;
SDLK_WORLD_92 = 252;
SDLK_WORLD_93 = 253;
SDLK_WORLD_94 = 254;
SDLK_WORLD_95 = 255;
SDLK_KP0 = 256;
SDLK_KP1 = 257;
SDLK_KP2 = 258;
SDLK_KP3 = 259;
SDLK_KP4 = 260;
SDLK_KP5 = 261;
SDLK_KP6 = 262;
SDLK_KP7 = 263;
SDLK_KP8 = 264;
SDLK_KP9 = 265;
SDLK_KP_PERIOD = 266;
SDLK_KP_DIVIDE = 267;
SDLK_KP_MULTIPLY = 268;
SDLK_KP_MINUS = 269;
SDLK_KP_PLUS = 270;
SDLK_KP_ENTER = 271;
SDLK_KP_EQUALS = 272;
SDLK_UP = 273;
SDLK_DOWN = 274;
SDLK_RIGHT = 275;
SDLK_LEFT = 276;
SDLK_INSERT = 277;
SDLK_HOME = 278;
SDLK_END = 279;
SDLK_PAGEUP = 280;
SDLK_PAGEDOWN = 281;
SDLK_F1 = 282;
SDLK_F2 = 283;
SDLK_F3 = 284;
SDLK_F4 = 285;
SDLK_F5 = 286;
SDLK_F6 = 287;
SDLK_F7 = 288;
SDLK_F8 = 289;
SDLK_F9 = 290;
SDLK_F10 = 291;
SDLK_F11 = 292;
SDLK_F12 = 293;
SDLK_F13 = 294;
SDLK_F14 = 295;
SDLK_F15 = 296;
SDLK_NUMLOCK = 300;
SDLK_CAPSLOCK = 301;
SDLK_SCROLLOCK = 302;
SDLK_RSHIFT = 303;
SDLK_LSHIFT = 304;
SDLK_RCTRL = 305;
SDLK_LCTRL = 306;
SDLK_RALT = 307;
SDLK_LALT = 308;
SDLK_RMETA = 309;
SDLK_LMETA = 310;
SDLK_LSUPER = 311;
SDLK_RSUPER = 312;
SDLK_MODE = 313;
SDLK_COMPOSE = 314;
SDLK_HELP = 315;
SDLK_PRINT = 316;
SDLK_SYSREQ = 317;
SDLK_BREAK = 318;
SDLK_MENU = 319;
SDLK_POWER = 320;
SDLK_EURO = 321;
KMOD_NONE = $0000;
KMOD_LSHIFT = $0001;
KMOD_RSHIFT = $0002;
KMOD_LCTRL = $0040;
KMOD_RCTRL = $0080;
KMOD_LALT = $0100;
KMOD_RALT = $0200;
KMOD_LMETA = $0400;
KMOD_RMETA = $0800;
KMOD_NUM = $1000;
KMOD_CAPS = $2000;
KMOD_MODE = 44000;
KMOD_RESERVED = $8000;
KMOD_CTRL = (KMOD_LCTRL or KMOD_RCTRL);
KMOD_SHIFT = (KMOD_LSHIFT or KMOD_RSHIFT);
KMOD_ALT = (KMOD_LALT or KMOD_RALT);
KMOD_META = (KMOD_LMETA or KMOD_RMETA);
SDL_ALPHA_OPAQUE = 255;
SDL_ALPHA_TRANSPARENT = 0;
SDL_SWSURFACE = $00000000;
SDL_HWSURFACE = $00000001;
SDL_ASYNCBLIT = $00000004;
SDL_ANYFORMAT = $10000000;
SDL_HWPALETTE = $20000000;
SDL_DOUBLEBUF = $40000000;
SDL_FULLSCREEN = $80000000;
SDL_OPENGL = $00000002;
SDL_OPENGLBLIT = $00000002;
SDL_RESIZABLE = $00000010;
SDL_NOFRAME = $00000020;
SDL_HWACCEL = $00000100;
SDL_SRCCOLORKEY = $00001000;
SDL_RLEACCELOK = $00002000;
SDL_RLEACCEL = $00004000;
SDL_SRCALPHA = $00010000;
SDL_SRCCLIPPING = $00100000;
SDL_PREALLOC = $01000000;
SDL_YV12_OVERLAY = $32315659;
SDL_IYUV_OVERLAY = $56555949;
SDL_YUY2_OVERLAY = $32595559;
SDL_UYVY_OVERLAY = $59565955;
SDL_YVYU_OVERLAY = $55595659;
SDL_LOGPAL = $01;
SDL_PHYSPAL = $02;
SDL_BUTTON_LEFT = 1;
SDL_BUTTON_MIDDLE = 2;
SDL_BUTTON_RIGHT = 3;
SDL_BUTTON_LMASK = SDL_PRESSED shl (SDL_BUTTON_LEFT - 1);
SDL_BUTTON_MMASK = SDL_PRESSED shl (SDL_BUTTON_MIDDLE - 1);
SDL_BUTTON_RMask = SDL_PRESSED shl (SDL_BUTTON_RIGHT - 1);
SDL_APPMOUSEFOCUS = $01;
SDL_APPINPUTFOCUS = $02;
SDL_APPACTIVE = $04;
SDL_MUTEX_TIMEDOUT = 1;
SDL_MUTEX_MAXWAIT = not Cardinal(0);

Description

Functions and Procedures

function SDL_Init(flags: UInt32): Integer; cdecl; external LibName;
function SDL_InitSubSystem(flags: UInt32): Integer; cdecl; external LibName;
procedure SDL_QuitSubSystem( flags : UInt32 ); cdecl; external LibName;
function SDL_WasInit( flags : UInt32 ): UInt32; cdecl; external LibName;
procedure SDL_Quit; cdecl; external LibName;
function SDL_RegisterApp(name: PAnsiChar; style: UInt32; h_Inst: Pointer): Integer; cdecl; external LibName;
function SDL_TABLESIZE(table: PAnsiChar): Integer;
function SDL_GetError: PAnsiChar; cdecl; external LibName;
procedure SDL_SetError(fmt: PAnsiChar); cdecl; external LibName;
procedure SDL_ClearError; cdecl; external LibName;
procedure SDL_OutOfMemory;
function SDL_RWFromFile(filename, mode: PAnsiChar): PSDL_RWops; cdecl; external LibName;
procedure SDL_FreeRW(area: PSDL_RWops); cdecl; external LibName;
function SDL_RWFromFP(fp: Pointer; autoclose: Integer): PSDL_RWops; cdecl; external LibName;
function SDL_RWFromMem(mem: Pointer; size: Integer): PSDL_RWops; cdecl; external LibName;
function SDL_AllocRW: PSDL_RWops; cdecl; external LibName;
function SDL_RWSeek(context: PSDL_RWops; offset: Integer; whence: Integer) : Integer;
function SDL_RWTell(context: PSDL_RWops): Integer;
function SDL_RWRead(context: PSDL_RWops; ptr: Pointer; size: Integer; n: Integer): Integer;
function SDL_RWWrite(context: PSDL_RWops; ptr: Pointer; size: Integer; n: Integer): Integer;
function SDL_RWClose(context: PSDL_RWops): Integer;
function SDL_GetTicks: UInt32; cdecl; external LibName;
procedure SDL_Delay(msec: UInt32); cdecl; external LibName;
function SDL_AddTimer(interval: UInt32; callback: TSDL_NewTimerCallback; param : Pointer): PSDL_TimerID; cdecl; external LibName;
function SDL_RemoveTimer(t: PSDL_TimerID): TSDL_Bool; cdecl; external LibName;
function SDL_SetTimer(interval: UInt32; callback: TSDL_TimerCallback): Integer; cdecl; external LibName;
function SDL_AudioInit(driver_name: PAnsiChar): Integer; cdecl; external LibName;
procedure SDL_AudioQuit; cdecl; external LibName;
function SDL_AudioDriverName(namebuf: PAnsiChar; maxlen: Integer): PAnsiChar; cdecl; external LibName;
function SDL_OpenAudio(desired, obtained: PSDL_AudioSpec): Integer; cdecl; external LibName;
function SDL_GetAudioStatus: TSDL_Audiostatus; cdecl; external LibName;
procedure SDL_PauseAudio(pause_on: Integer); cdecl; external LibName;
function SDL_LoadWAV_RW(src: PSDL_RWops; freesrc: Integer; spec: PSDL_AudioSpec; audio_buf: PUInt8; audiolen: PUInt32): PSDL_AudioSpec; cdecl; external LibName;
function SDL_LoadWAV(filename: PAnsiChar; spec: PSDL_AudioSpec; audio_buf: PUInt8; audiolen: PUInt32): PSDL_AudioSpec;
procedure SDL_FreeWAV(audio_buf: PUInt8); cdecl; external LibName;
function SDL_BuildAudioCVT(cvt: PSDL_AudioCVT; src_format: UInt16; src_channels: UInt8; src_rate: Integer; dst_format: UInt16; dst_channels: UInt8; dst_rate: Integer): Integer; cdecl; external LibName;
function SDL_ConvertAudio(cvt: PSDL_AudioCVT): Integer; cdecl; external LibName;
procedure SDL_MixAudio(dst, src: PUInt8; len: UInt32; volume: Integer); cdecl; external LibName;
procedure SDL_LockAudio; cdecl; external LibName;
procedure SDL_UnlockAudio; cdecl; external LibName;
procedure SDL_CloseAudio; cdecl; external LibName;
function SDL_CDNumDrives: Integer; cdecl; external LibName;
function SDL_CDName(drive: Integer): PAnsiChar; cdecl; external LibName;
function SDL_CDOpen(drive: Integer): PSDL_CD; cdecl; external LibName;
function SDL_CDStatus(cdrom: PSDL_CD): TSDL_CDStatus; cdecl; external LibName;
function SDL_CDPlayTracks(cdrom: PSDL_CD; start_track: Integer; start_frame: Integer; ntracks: Integer; nframes: Integer): Integer; cdecl; external LibName;
function SDL_CDPlay(cdrom: PSDL_CD; start: Integer; length: Integer): Integer; cdecl; external LibName;
function SDL_CDPause(cdrom: PSDL_CD): Integer; cdecl; external LibName;
function SDL_CDResume(cdrom: PSDL_CD): Integer; cdecl; external LibName;
function SDL_CDStop(cdrom: PSDL_CD): Integer; cdecl; external LibName;
function SDL_CDEject(cdrom: PSDL_CD): Integer; cdecl; external LibName;
procedure SDL_CDClose(cdrom: PSDL_CD); cdecl; external LibName;
function SDL_CDInDrive( status : TSDL_CDStatus ) : LongBool;
procedure FRAMES_TO_MSF(frames: Integer; var M: Integer; var S: Integer; var F: Integer);
function MSF_TO_FRAMES(M: Integer; S: Integer; F: Integer): Integer;
function SDL_NumJoysticks: Integer; cdecl; external LibName;
function SDL_JoystickName(index: Integer): PAnsiChar; cdecl; external LibName;
function SDL_JoystickOpen(index: Integer): PSDL_Joystick; cdecl; external LibName;
function SDL_JoystickOpened(index: Integer): Integer; cdecl; external LibName;
function SDL_JoystickIndex(joystick: PSDL_Joystick): Integer; cdecl; external LibName;
function SDL_JoystickNumAxes(joystick: PSDL_Joystick): Integer; cdecl; external LibName;
function SDL_JoystickNumBalls(joystick: PSDL_Joystick): Integer; cdecl; external LibName;
function SDL_JoystickNumHats(joystick: PSDL_Joystick): Integer; cdecl; external LibName;
function SDL_JoystickNumButtons(joystick: PSDL_Joystick): Integer; cdecl; external LibName;
procedure SDL_JoystickUpdate; cdecl; external LibName;
function SDL_JoystickEventState(state: Integer): Integer; cdecl; external LibName;
function SDL_JoystickGetAxis(joystick: PSDL_Joystick; axis: Integer): SInt16; cdecl; external LibName;
function SDL_JoystickGetHat(joystick: PSDL_Joystick; hat: Integer): UInt8; cdecl; external LibName;
function SDL_JoystickGetBall(joystick: PSDL_Joystick; ball: Integer; var dx: Integer; var dy: Integer): Integer; cdecl; external LibName;
function SDL_JoystickGetButton( joystick: PSDL_Joystick; Button: Integer): UInt8; cdecl; external LibName;
procedure SDL_JoystickClose(joystick: PSDL_Joystick); cdecl; external LibName;
procedure SDL_PumpEvents; cdecl; external LibName;
function SDL_PeepEvents(events: PSDL_Event; numevents: Integer; action: TSDL_eventaction; mask: UInt32): Integer; cdecl; external LibName;
function SDL_PollEvent(event: PSDL_Event): Integer; cdecl; external LibName;
function SDL_WaitEvent(event: PSDL_Event): Integer; cdecl; external LibName;
function SDL_PushEvent( event : PSDL_Event ) : Integer; cdecl; external LibName;
procedure SDL_SetEventFilter( filter : TSDL_EventFilter ); cdecl; external LibName;
function SDL_GetEventFilter: TSDL_EventFilter; cdecl; external LibName;
function SDL_EventState(type_: UInt8; state: Integer): UInt8; cdecl; external LibName;
procedure SDL_VERSION(var X: TSDL_Version);
function SDL_VERSIONNUM(X, Y, Z: Integer): Integer;
function SDL_COMPILEDVERSION: Integer;
function SDL_VERSION_ATLEAST(X: Integer; Y: Integer; Z: Integer): LongBool;
function SDL_Linked_Version: TSDL_version; cdecl; external LibName;
function SDL_VideoInit(driver_name: PAnsiChar; flags: UInt32): Integer; cdecl; external LibName;
procedure SDL_VideoQuit; cdecl; external LibName;
function SDL_VideoDriverName(namebuf: PAnsiChar; maxlen: Integer): PAnsiChar; cdecl; external LibName;
function SDL_GetVideoSurface: PSDL_Surface; cdecl; external LibName;
function SDL_GetVideoInfo: PSDL_VideoInfo; cdecl; external LibName;
function SDL_VideoModeOK(width, height, bpp: Integer; flags: UInt32): Integer; cdecl; external LibName;
function SDL_ListModes(format: PSDL_PixelFormat; flags: UInt32): PPSDL_Rect; cdecl; external LibName;
function SDL_SetVideoMode(width, height, bpp: Integer; flags: UInt32): PSDL_Surface; cdecl; external LibName;
procedure SDL_UpdateRects(screen: PSDL_Surface; numrects: Integer; rects: PSDL_Rect); cdecl; external LibName;
procedure SDL_UpdateRect(screen: PSDL_Surface; x, y: SInt32; w, h: UInt32); cdecl; external LibName;
function SDL_Flip(screen: PSDL_Surface): Integer; cdecl; external LibName;
function SDL_SetGamma(redgamma: single; greengamma: single; bluegamma: single ): Integer; cdecl; external LibName;
function SDL_SetGammaRamp( redtable: PUInt16; greentable: PUInt16; bluetable: PUInt16): Integer; cdecl; external LibName;
function SDL_GetGammaRamp( redtable: PUInt16; greentable: PUInt16; bluetable: PUInt16): Integer; cdecl; external LibName;
function SDL_SetColors(surface: PSDL_Surface; colors: PSDL_Color; firstcolor : Integer; ncolors: Integer): Integer; cdecl; external LibName;
function SDL_SetPalette(surface: PSDL_Surface; flags: Integer; colors: PSDL_Color; firstcolor: Integer; ncolors: Integer): Integer; cdecl; external LibName;
function SDL_MapRGB(format: PSDL_PixelFormat; r: UInt8; g: UInt8; b: UInt8) : UInt32; cdecl; external LibName;
function SDL_MapRGBA(format: PSDL_PixelFormat; r: UInt8; g: UInt8; b: UInt8; a: UInt8): UInt32; cdecl; external LibName;
procedure SDL_GetRGB(pixel: UInt32; fmt: PSDL_PixelFormat; r: PUInt8; g: PUInt8; b: PUInt8); cdecl; external LibName;
procedure SDL_GetRGBA(pixel: UInt32; fmt: PSDL_PixelFormat; r: PUInt8; g: PUInt8; b: PUInt8; a: UInt8); cdecl; external LibName;
function SDL_AllocSurface(flags: UInt32; width, height, depth: Integer; RMask, GMask, BMask, AMask: UInt32): PSDL_Surface;
function SDL_CreateRGBSurface(flags: UInt32; width, height, depth: Integer; RMask, GMask, BMask, AMask: UInt32): PSDL_Surface; cdecl; external LibName;
function SDL_CreateRGBSurfaceFrom(pixels: Pointer; width, height, depth, pitch : Integer; RMask, GMask, BMask, AMask: UInt32): PSDL_Surface; cdecl; external LibName;
procedure SDL_FreeSurface(surface: PSDL_Surface); cdecl; external LibName;
function SDL_MustLock(Surface: PSDL_Surface): Boolean;
function SDL_LockSurface(surface: PSDL_Surface): Integer; cdecl; external LibName;
procedure SDL_UnlockSurface(surface: PSDL_Surface); cdecl; external LibName;
function SDL_LoadBMP_RW(src: PSDL_RWops; freesrc: Integer): PSDL_Surface; cdecl; external LibName;
function SDL_LoadBMP(filename: PAnsiChar): PSDL_Surface;
function SDL_SaveBMP_RW(surface: PSDL_Surface; dst: PSDL_RWops; freedst: Integer): Integer; cdecl; external LibName;
function SDL_SaveBMP(surface: PSDL_Surface; filename: PAnsiChar): Integer;
function SDL_SetColorKey(surface: PSDL_Surface; flag, key: UInt32): Integer; cdecl; external LibName;
function SDL_SetAlpha(surface: PSDL_Surface; flag: UInt32; alpha: UInt8): Integer; cdecl; external LibName;
procedure SDL_SetClipRect(surface: PSDL_Surface; rect: PSDL_Rect); cdecl; external LibName;
procedure SDL_GetClipRect(surface: PSDL_Surface; rect: PSDL_Rect); cdecl; external LibName;
function SDL_ConvertSurface(src: PSDL_Surface; fmt: PSDL_PixelFormat; flags: UInt32): PSDL_Surface; cdecl; external LibName;
function SDL_BlitSurface(src: PSDL_Surface; srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): Integer;
function SDL_UpperBlit(src: PSDL_Surface; srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): Integer; cdecl; external LibName;
function SDL_LowerBlit(src: PSDL_Surface; srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): Integer; cdecl; external LibName;
function SDL_FillRect(dst: PSDL_Surface; dstrect: PSDL_Rect; color: UInt32) : Integer; cdecl; external LibName;
function SDL_DisplayFormat(surface: PSDL_Surface): PSDL_Surface; cdecl; external LibName;
function SDL_DisplayFormatAlpha(surface: PSDL_Surface): PSDL_Surface; cdecl; external LibName;
function SDL_CreateYUVOverlay(width: Integer; height: Integer; format: UInt32; display: PSDL_Surface): PSDL_Overlay; cdecl; external LibName;
function SDL_LockYUVOverlay(Overlay: PSDL_Overlay): Integer; cdecl; external LibName;
procedure SDL_UnlockYUVOverlay(Overlay: PSDL_Overlay); cdecl; external LibName;
function SDL_DisplayYUVOverlay(Overlay: PSDL_Overlay; dstrect: PSDL_Rect): Integer; cdecl; external LibName;
procedure SDL_FreeYUVOverlay(Overlay: PSDL_Overlay); cdecl; external LibName;
function SDL_GL_LoadLibrary(filename: PChar): Integer; cdecl; external LibName;
function SDL_GL_GetProcAddress(procname: PChar) : Pointer; cdecl; external LibName;
function SDL_GL_SetAttribute(attr: TSDL_GLAttr; value: Integer): Integer; cdecl; external LibName;
function SDL_GL_GetAttribute(attr: TSDL_GLAttr; var value: Integer): Integer; cdecl; external LibName;
procedure SDL_GL_SwapBuffers; cdecl; external LibName;
procedure SDL_GL_UpdateRects(numrects: Integer; rects: PSDL_Rect); cdecl; external LibName;
procedure SDL_GL_Lock; cdecl; external LibName;
procedure SDL_GL_Unlock; cdecl; external LibName;
procedure SDL_WM_GetCaption(var title: PAnsiChar; var icon: PAnsiChar); cdecl; external LibName;
procedure SDL_WM_SetCaption(title, icon: PAnsiChar); cdecl; external LibName;
procedure SDL_WM_SetIcon(icon: PSDL_Surface; mask: UInt8); cdecl; external LibName;
function SDL_WM_IconifyWindow: Integer; cdecl; external LibName;
function SDL_WM_ToggleFullScreen(surface: PSDL_Surface): Integer; cdecl; external LibName;
function SDL_WM_GrabInput(mode: TSDL_GrabMode): TSDL_GrabMode; cdecl; external LibName;
function SDL_GetMouseState(var x: Integer; var y: Integer): UInt8; cdecl; external LibName;
function SDL_GetRelativeMouseState(var x: Integer; var y: Integer): UInt8; cdecl; external LibName;
procedure SDL_WarpMouse(x, y: UInt16); cdecl; external LibName;
function SDL_CreateCursor(data, mask: PUInt8; w, h, hot_x, hot_y: Integer): PSDL_Cursor; cdecl; external LibName;
procedure SDL_SetCursor(cursor: PSDL_Cursor); cdecl; external LibName;
function SDL_GetCursor: PSDL_Cursor; cdecl; external LibName;
procedure SDL_FreeCursor(cursor: PSDL_Cursor); cdecl; external LibName;
function SDL_ShowCursor(toggle: Integer): Integer; cdecl; external LibName;
function SDL_BUTTON( Button : Integer ) : Integer;
function SDL_EnableUNICODE(enable: Integer): Integer; cdecl; external LibName;
function SDL_EnableKeyRepeat(delay: Integer; interval: Integer): Integer; cdecl; external LibName;
function SDL_GetKeyState(numkeys: PInt): PUInt8; cdecl; external LibName;
function SDL_GetModState: TSDLMod; cdecl; external LibName;
procedure SDL_SetModState(modstate: TSDLMod); cdecl; external LibName;
function SDL_GetKeyName(key: TSDLKey): PAnsiChar; cdecl; external LibName;
function SDL_GetAppState: UInt8; cdecl; external LibName;
function SDL_CreateMutex: PSDL_Mutex; cdecl; external LibName;
function SDL_mutexP(mutex: PSDL_mutex): Integer; cdecl; external LibName;
function SDL_LockMutex(mutex: PSDL_mutex): Integer;
function SDL_mutexV(mutex: PSDL_mutex): Integer; cdecl; external LibName;
function SDL_UnlockMutex(mutex: PSDL_mutex): Integer;
procedure SDL_DestroyMutex(mutex: PSDL_mutex); cdecl; external LibName;
function SDL_CreateSemaphore(initial_value: UInt32): PSDL_Sem; cdecl; external LibName;
procedure SDL_DestroySemaphore(sem: PSDL_sem); cdecl; external LibName;
function SDL_SemWait(sem: PSDL_sem): Integer; cdecl; external LibName;
function SDL_SemTryWait(sem: PSDL_sem): Integer; cdecl; external LibName;
function SDL_SemWaitTimeout(sem: PSDL_sem; ms: UInt32): Integer; cdecl; external LibName;
function SDL_SemPost(sem: PSDL_sem): Integer; cdecl; external LibName;
function SDL_SemValue(sem: PSDL_sem): UInt32; cdecl; external LibName;
function SDL_CreateCond: PSDL_Cond; cdecl; external LibName;
procedure SDL_DestroyCond(cond: PSDL_Cond); cdecl; external LibName;
function SDL_CondSignal(cond: PSDL_cond): Integer; cdecl; external LibName;
function SDL_CondBroadcast(cond: PSDL_cond): Integer; cdecl; external LibName;
function SDL_CondWait(cond: PSDL_cond; mut: PSDL_mutex): Integer; cdecl; external LibName;
function SDL_CondWaitTimeout(cond: PSDL_cond; mut: PSDL_mutex; ms: UInt32) : Integer; cdecl; external LibName;
function SDL_CreateThread(fn: PInt; data: Pointer): PSDL_Thread; cdecl; external LibName;
function SDL_ThreadID: UInt32; cdecl; external LibName;
function SDL_GetThreadID(thread: PSDL_Thread): UInt32; cdecl; external LibName;
procedure SDL_WaitThread(thread: PSDL_Thread; var status: Integer); cdecl; external LibName;
procedure SDL_KillThread(thread: PSDL_Thread); cdecl; external LibName;
function _putenv( const variable : PAnsiChar ): integer; cdecl;
function SDL_putenv(const variable: PAnsiChar): integer;
function getenv( const name : PAnsiChar ): PAnsiChar; cdecl;
function SDL_getenv(const name: PAnsiChar): PAnsiChar;
function SDL_Swap32(D: Uint32): Uint32;
procedure FreeAndNil(var Obj);

Types

TSDL_Bool = (...);
Values
  • SDL_FALSE:
  • SDL_TRUE:
PUInt8Array = ˆTUInt8Array;
PUInt8 = ˆUInt8;
UInt8 = Byte;
TUInt8Array = array [0..MAXINT shr 1] of UInt8;
PUInt16 = ˆUInt16;
UInt16 = word;
SInt16 = smallint;
PUInt32 = ˆUInt32;
UInt32 = Cardinal;
SInt32 = Integer;
PInt = ˆInteger;
PUInt64 = ˆUInt64;
PSInt64 = ˆSInt64;
TSDL_errorcode = (...);
Values
  • SDL_ENOMEM:
  • SDL_EFREAD:
  • SDL_EFWRITE:
  • SDL_EFSEEK:
  • SDL_LASTERROR:
SDL_errorcode = TSDL_errorcode;
PSDL_error = ˆTSDL_error;
PSDL_RWops = ˆTSDL_RWops;
TSeek = function(context: PSDL_RWops; offset: Integer; whence: Integer): Integer; cdecl;
TRead = function(context: PSDL_RWops; Ptr: Pointer; size: Integer; maxnum : Integer): Integer; cdecl;
TWrite = function(context: PSDL_RWops; Ptr: Pointer; size: Integer; num: Integer): Integer; cdecl;
TClose = function(context: PSDL_RWops): Integer; cdecl;
SDL_RWops = TSDL_RWops;
TSDL_TimerCallback = function(interval: UInt32): UInt32; cdecl;
TSDL_NewTimerCallback = function(interval: UInt32; param: Pointer): UInt32; cdecl;
PSDL_TimerID = ˆTSDL_TimerID;
PSDL_AudioSpec = ˆTSDL_AudioSpec;
PSDL_AudioCVT = ˆTSDL_AudioCVT;
PSDL_AudioCVTFilter = ˆTSDL_AudioCVTFilter;
PSDL_AudioCVTFilterArray = ˆTSDL_AudioCVTFilterArray;
TSDL_AudioCVTFilterArray = array[0..9] of TSDL_AudioCVTFilter;
TSDL_Audiostatus = (...);
Values
  • SDL_AUDIO_STOPPED:
  • SDL_AUDIO_PLAYING:
  • SDL_AUDIO_PAUSED:
TSDL_CDStatus = (...);
Values
  • CD_ERROR:
  • CD_TRAYEMPTY:
  • CD_STOPPED:
  • CD_PLAYING:
  • CD_PAUSED:
PSDL_CDTrack = ˆTSDL_CDTrack;
PSDL_CD = ˆTSDL_CD;
PTransAxis = ˆTTransAxis;
PJoystick_hwdata = ˆTJoystick_hwdata;
PBallDelta = ˆTBallDelta;
PSDL_Joystick = ˆTSDL_Joystick;
PSDL_version = ˆTSDL_version;
TSDLKey = LongWord;
TSDLMod = LongWord;
PSDL_KeySym = ˆTSDL_KeySym;
TSDL_EventAction = (...);
Values
  • SDL_ADDEVENT:
  • SDL_PEEKEVENT:
  • SDL_GETEVENT:
PSDL_QuitEvent = ˆTSDL_QuitEvent;
PSDL_UserEvent = ˆTSDL_UserEvent;
PSDL_ExposeEvent = ˆTSDL_ExposeEvent;
PSDL_SysWMmsg = ˆTSDL_SysWMmsg;
PSDL_SysWMEvent = ˆTSDL_SysWMEvent;
PSDL_Event = ˆTSDL_Event;
TSDL_EventFilter = function(event: PSDL_Event): Integer; cdecl;
PPSDL_Rect = ˆPSDL_Rect;
PSDL_Rect = ˆTSDL_Rect;
SDL_Rect = TSDL_Rect;
PSDL_Color = ˆTSDL_Color;
PSDL_ColorArray = ˆTSDL_ColorArray;
TSDL_ColorArray = array[0..65000] of TSDL_Color;
PSDL_Palette = ˆTSDL_Palette;
PSDL_PixelFormat = ˆTSDL_PixelFormat;
PSDL_BlitInfo = ˆTSDL_BlitInfo;
PSDL_Surface = ˆTSDL_Surface;
TSDL_Blit = function(src: PSDL_Surface; srcrect: PSDL_Rect; dst: PSDL_Surface; dstrect: PSDL_Rect): Integer; cdecl;
PSDL_VideoInfo = ˆTSDL_VideoInfo;
PSDL_Overlay = ˆTSDL_Overlay;
TSDL_GLAttr = (...);
Values
  • SDL_GL_RED_SIZE:
  • SDL_GL_GREEN_SIZE:
  • SDL_GL_BLUE_SIZE:
  • SDL_GL_ALPHA_SIZE:
  • SDL_GL_BUFFER_SIZE:
  • SDL_GL_DOUBLEBUFFER:
  • SDL_GL_DEPTH_SIZE:
  • SDL_GL_STENCIL_SIZE:
  • SDL_GL_ACCUM_RED_SIZE:
  • SDL_GL_ACCUM_GREEN_SIZE:
  • SDL_GL_ACCUM_BLUE_SIZE:
  • SDL_GL_ACCUM_ALPHA_SIZE:
TSDL_GrabMode = (...);
Values
  • SDL_GRAB_QUERY:
  • SDL_GRAB_OFF:
  • SDL_GRAB_ON:
PSDL_Cursor = ˆTSDL_Cursor;
PSDL_Mutex = ˆTSDL_Mutex;
PSDL_semaphore = ˆTSDL_semaphore;
PSDL_Sem = ˆTSDL_Sem;
TSDL_Sem = TSDL_Semaphore;
PSDL_Cond = ˆTSDL_Cond;
TSYS_ThreadHandle = THandle;
PSDL_Thread = ˆTSDL_Thread;
PKeyStateArr = ˆTKeyStateArr;
TKeyStateArr = array[0..65000] of UInt8;
PInteger = ˆInteger;
PByte = ˆByte;
PWord = ˆWord;
PLongWord = ˆLongword;
PByteArray = ˆTByteArray;
TByteArray = array[0..32767] of Byte;
PWordArray = ˆTWordArray;
TWordArray = array[0..16383] of Word;
PPoint = ˆTPoint;
PRect = ˆTRect;

Constants

LibName = 'SDL.dll';
SDL_INIT_TIMER = $00000001;
SDL_INIT_AUDIO = $00000010;
SDL_INIT_VIDEO = $00000020;
SDL_INIT_CDROM = $00000100;
SDL_INIT_JOYSTICK = $00000200;
SDL_INIT_NOPARACHUTE = $00100000;
SDL_INIT_EVENTTHREAD = $01000000;
SDL_INIT_EVERYTHING = $0000FFFF;
ERR_MAX_STRLEN = 128;
ERR_MAX_ARGS = 5;
SDL_PRESSED = $01;
SDL_RELEASED = $00;
SDL_TIMESLICE = 10;
TIMER_RESOLUTION = 10;
AUDIO_U8 = $0008;
AUDIO_S8 = $8008;
AUDIO_U16LSB = $0010;
AUDIO_S16LSB = $8010;
AUDIO_U16MSB = $1010;
AUDIO_S16MSB = $9010;
AUDIO_U16 = AUDIO_U16LSB;
AUDIO_S16 = AUDIO_S16LSB;
SDL_MAX_TRACKS = 99;
SDL_AUDIO_TRACK = $00;
SDL_DATA_TRACK = $04;
CD_FPS = 75;
SDL_LIL_ENDIAN = 1234;
SDL_BIG_ENDIAN = 4321;
SDL_BYTEORDER = SDL_LIL_ENDIAN;
AUDIO_U16SYS = AUDIO_U16LSB;
AUDIO_S16SYS = AUDIO_S16LSB;
SDL_MIX_MAXVOLUME = 128;
MAX_JOYSTICKS = 2;
MAX_AXES = 6;
MAX_BUTTONS = 32;
AXIS_MIN = -32768;
AXIS_MAX = 32767;
JOY_AXIS_THRESHOLD = (((AXIS_MAX) - (AXIS_MIN)) / 100);
SDL_HAT_CENTERED = $00;
SDL_HAT_UP = $01;
SDL_HAT_RIGHT = $02;
SDL_HAT_DOWN = $04;
SDL_HAT_LEFT = $08;
SDL_HAT_RIGHTUP = SDL_HAT_RIGHT or SDL_HAT_UP;
SDL_HAT_RIGHTDOWN = SDL_HAT_RIGHT or SDL_HAT_DOWN;
SDL_HAT_LEFTUP = SDL_HAT_LEFT or SDL_HAT_UP;
SDL_HAT_LEFTDOWN = SDL_HAT_LEFT or SDL_HAT_DOWN;
SDL_MAJOR_VERSION = 1;
SDL_MINOR_VERSION = 2;
SDL_PATCHLEVEL = 3;
SDL_NOEVENT = 0;
SDL_ACTIVEEVENT = 1;
SDL_KEYDOWN = 2;
SDL_KEYUP = 3;
SDL_MOUSEMOTION = 4;
SDL_MOUSEBUTTONDOWN = 5;
SDL_MOUSEBUTTONUP = 6;
SDL_JOYAXISMOTION = 7;
SDL_JOYBALLMOTION = 8;
SDL_JOYHATMOTION = 9;
SDL_JOYBUTTONDOWN = 10;
SDL_JOYBUTTONUP = 11;
SDL_QUITEV = 12;
SDL_SYSWMEVENT = 13;
SDL_EVENT_RESERVEDA = 14;
SDL_EVENT_RESERVED = 15;
SDL_VIDEORESIZE = 16;
SDL_VIDEOEXPOSE = 17;
SDL_EVENT_RESERVED2 = 18;
SDL_EVENT_RESERVED3 = 19;
SDL_EVENT_RESERVED4 = 20;
SDL_EVENT_RESERVED5 = 21;
SDL_EVENT_RESERVED6 = 22;
SDL_EVENT_RESERVED7 = 23;
SDL_USEREVENT = 24;
SDL_NUMEVENTS = 32;
SDL_ALLEVENTS = $FFFFFFFF;
SDL_ACTIVEEVENTMASK = 1 shl SDL_ACTIVEEVENT;
SDL_KEYDOWNMASK = 1 shl SDL_KEYDOWN;
SDL_KEYUPMASK = 1 shl SDL_KEYUP;
SDL_MOUSEMOTIONMASK = 1 shl SDL_MOUSEMOTION;
SDL_MOUSEBUTTONDOWNMASK = 1 shl SDL_MOUSEBUTTONDOWN;
SDL_MOUSEBUTTONUPMASK = 1 shl SDL_MOUSEBUTTONUP;
SDL_MOUSEEVENTMASK = 1 shl SDL_MOUSEMOTION or 1 shl SDL_MOUSEBUTTONDOWN or 1 shl SDL_MOUSEBUTTONUP;
SDL_JOYAXISMOTIONMASK = 1 shl SDL_JOYAXISMOTION;
SDL_JOYBALLMOTIONMASK = 1 shl SDL_JOYBALLMOTION;
SDL_JOYHATMOTIONMASK = 1 shl SDL_JOYHATMOTION;
SDL_JOYBUTTONDOWNMASK = 1 shl SDL_JOYBUTTONDOWN;
SDL_JOYBUTTONUPMASK = 1 shl SDL_JOYBUTTONUP;
SDL_JOYEVENTMASK = 1 shl SDL_JOYAXISMOTION or 1 shl SDL_JOYBALLMOTION or 1 shl SDL_JOYHATMOTION or 1 shl SDL_JOYBUTTONDOWN or 1 shl SDL_JOYBUTTONUP;
SDL_VIDEORESIZEMASK = 1 shl SDL_VIDEORESIZE;
SDL_QUITMASK = 1 shl SDL_QUITEV;
SDL_SYSWMEVENTMASK = 1 shl SDL_SYSWMEVENT;
SDL_QUERY = -1;
SDL_IGNORE = 0;
SDL_DISABLE = 0;
SDL_ENABLE = 1;
SDL_ALL_HOTKEYS = $FFFFFFFF;
SDL_DEFAULT_REPEAT_DELAY = 500;
SDL_DEFAULT_REPEAT_INTERVAL = 30;
SDLK_UNKNOWN = 0;
SDLK_FIRST = 0;
SDLK_BACKSPACE = 8;
SDLK_TAB = 9;
SDLK_CLEAR = 12;
SDLK_RETURN = 13;
SDLK_PAUSE = 19;
SDLK_ESCAPE = 27;
SDLK_SPACE = 32;
SDLK_EXCLAIM = 33;
SDLK_QUOTEDBL = 34;
SDLK_HASH = 35;
SDLK_DOLLAR = 36;
SDLK_AMPERSAND = 38;
SDLK_QUOTE = 39;
SDLK_LEFTPAREN = 40;
SDLK_RIGHTPAREN = 41;
SDLK_ASTERISK = 42;
SDLK_PLUS = 43;
SDLK_COMMA = 44;
SDLK_MINUS = 45;
SDLK_PERIOD = 46;
SDLK_SLASH = 47;
SDLK_0 = 48;
SDLK_1 = 49;
SDLK_2 = 50;
SDLK_3 = 51;
SDLK_4 = 52;
SDLK_5 = 53;
SDLK_6 = 54;
SDLK_7 = 55;
SDLK_8 = 56;
SDLK_9 = 57;
SDLK_COLON = 58;
SDLK_SEMICOLON = 59;
SDLK_LESS = 60;
SDLK_EQUALS = 61;
SDLK_GREATER = 62;
SDLK_QUESTION = 63;
SDLK_AT = 64;
SDLK_LEFTBRACKET = 91;
SDLK_BACKSLASH = 92;
SDLK_RIGHTBRACKET = 93;
SDLK_CARET = 94;
SDLK_UNDERSCORE = 95;
SDLK_BACKQUOTE = 96;
SDLK_a = 97;
SDLK_b = 98;
SDLK_c = 99;
SDLK_d = 100;
SDLK_e = 101;
SDLK_f = 102;
SDLK_g = 103;
SDLK_h = 104;
SDLK_i = 105;
SDLK_j = 106;
SDLK_k = 107;
SDLK_l = 108;
SDLK_m = 109;
SDLK_n = 110;
SDLK_o = 111;
SDLK_p = 112;
SDLK_q = 113;
SDLK_r = 114;
SDLK_s = 115;
SDLK_t = 116;
SDLK_u = 117;
SDLK_v = 118;
SDLK_w = 119;
SDLK_x = 120;
SDLK_y = 121;
SDLK_z = 122;
SDLK_DELETE = 127;
SDLK_WORLD_0 = 160;
SDLK_WORLD_1 = 161;
SDLK_WORLD_2 = 162;
SDLK_WORLD_3 = 163;
SDLK_WORLD_4 = 164;
SDLK_WORLD_5 = 165;
SDLK_WORLD_6 = 166;
SDLK_WORLD_7 = 167;
SDLK_WORLD_8 = 168;
SDLK_WORLD_9 = 169;
SDLK_WORLD_10 = 170;
SDLK_WORLD_11 = 171;
SDLK_WORLD_12 = 172;
SDLK_WORLD_13 = 173;
SDLK_WORLD_14 = 174;
SDLK_WORLD_15 = 175;
SDLK_WORLD_16 = 176;
SDLK_WORLD_17 = 177;
SDLK_WORLD_18 = 178;
SDLK_WORLD_19 = 179;
SDLK_WORLD_20 = 180;
SDLK_WORLD_21 = 181;
SDLK_WORLD_22 = 182;
SDLK_WORLD_23 = 183;
SDLK_WORLD_24 = 184;
SDLK_WORLD_25 = 185;
SDLK_WORLD_26 = 186;
SDLK_WORLD_27 = 187;
SDLK_WORLD_28 = 188;
SDLK_WORLD_29 = 189;
SDLK_WORLD_30 = 190;
SDLK_WORLD_31 = 191;
SDLK_WORLD_32 = 192;
SDLK_WORLD_33 = 193;
SDLK_WORLD_34 = 194;
SDLK_WORLD_35 = 195;
SDLK_WORLD_36 = 196;
SDLK_WORLD_37 = 197;
SDLK_WORLD_38 = 198;
SDLK_WORLD_39 = 199;
SDLK_WORLD_40 = 200;
SDLK_WORLD_41 = 201;
SDLK_WORLD_42 = 202;
SDLK_WORLD_43 = 203;
SDLK_WORLD_44 = 204;
SDLK_WORLD_45 = 205;
SDLK_WORLD_46 = 206;
SDLK_WORLD_47 = 207;
SDLK_WORLD_48 = 208;
SDLK_WORLD_49 = 209;
SDLK_WORLD_50 = 210;
SDLK_WORLD_51 = 211;
SDLK_WORLD_52 = 212;
SDLK_WORLD_53 = 213;
SDLK_WORLD_54 = 214;
SDLK_WORLD_55 = 215;
SDLK_WORLD_56 = 216;
SDLK_WORLD_57 = 217;
SDLK_WORLD_58 = 218;
SDLK_WORLD_59 = 219;
SDLK_WORLD_60 = 220;
SDLK_WORLD_61 = 221;
SDLK_WORLD_62 = 222;
SDLK_WORLD_63 = 223;
SDLK_WORLD_64 = 224;
SDLK_WORLD_65 = 225;
SDLK_WORLD_66 = 226;
SDLK_WORLD_67 = 227;
SDLK_WORLD_68 = 228;
SDLK_WORLD_69 = 229;
SDLK_WORLD_70 = 230;
SDLK_WORLD_71 = 231;
SDLK_WORLD_72 = 232;
SDLK_WORLD_73 = 233;
SDLK_WORLD_74 = 234;
SDLK_WORLD_75 = 235;
SDLK_WORLD_76 = 236;
SDLK_WORLD_77 = 237;
SDLK_WORLD_78 = 238;
SDLK_WORLD_79 = 239;
SDLK_WORLD_80 = 240;
SDLK_WORLD_81 = 241;
SDLK_WORLD_82 = 242;
SDLK_WORLD_83 = 243;
SDLK_WORLD_84 = 244;
SDLK_WORLD_85 = 245;
SDLK_WORLD_86 = 246;
SDLK_WORLD_87 = 247;
SDLK_WORLD_88 = 248;
SDLK_WORLD_89 = 249;
SDLK_WORLD_90 = 250;
SDLK_WORLD_91 = 251;
SDLK_WORLD_92 = 252;
SDLK_WORLD_93 = 253;
SDLK_WORLD_94 = 254;
SDLK_WORLD_95 = 255;
SDLK_KP0 = 256;
SDLK_KP1 = 257;
SDLK_KP2 = 258;
SDLK_KP3 = 259;
SDLK_KP4 = 260;
SDLK_KP5 = 261;
SDLK_KP6 = 262;
SDLK_KP7 = 263;
SDLK_KP8 = 264;
SDLK_KP9 = 265;
SDLK_KP_PERIOD = 266;
SDLK_KP_DIVIDE = 267;
SDLK_KP_MULTIPLY = 268;
SDLK_KP_MINUS = 269;
SDLK_KP_PLUS = 270;
SDLK_KP_ENTER = 271;
SDLK_KP_EQUALS = 272;
SDLK_UP = 273;
SDLK_DOWN = 274;
SDLK_RIGHT = 275;
SDLK_LEFT = 276;
SDLK_INSERT = 277;
SDLK_HOME = 278;
SDLK_END = 279;
SDLK_PAGEUP = 280;
SDLK_PAGEDOWN = 281;
SDLK_F1 = 282;
SDLK_F2 = 283;
SDLK_F3 = 284;
SDLK_F4 = 285;
SDLK_F5 = 286;
SDLK_F6 = 287;
SDLK_F7 = 288;
SDLK_F8 = 289;
SDLK_F9 = 290;
SDLK_F10 = 291;
SDLK_F11 = 292;
SDLK_F12 = 293;
SDLK_F13 = 294;
SDLK_F14 = 295;
SDLK_F15 = 296;
SDLK_NUMLOCK = 300;
SDLK_CAPSLOCK = 301;
SDLK_SCROLLOCK = 302;
SDLK_RSHIFT = 303;
SDLK_LSHIFT = 304;
SDLK_RCTRL = 305;
SDLK_LCTRL = 306;
SDLK_RALT = 307;
SDLK_LALT = 308;
SDLK_RMETA = 309;
SDLK_LMETA = 310;
SDLK_LSUPER = 311;
SDLK_RSUPER = 312;
SDLK_MODE = 313;
SDLK_COMPOSE = 314;
SDLK_HELP = 315;
SDLK_PRINT = 316;
SDLK_SYSREQ = 317;
SDLK_BREAK = 318;
SDLK_MENU = 319;
SDLK_POWER = 320;
SDLK_EURO = 321;
KMOD_NONE = $0000;
KMOD_LSHIFT = $0001;
KMOD_RSHIFT = $0002;
KMOD_LCTRL = $0040;
KMOD_RCTRL = $0080;
KMOD_LALT = $0100;
KMOD_RALT = $0200;
KMOD_LMETA = $0400;
KMOD_RMETA = $0800;
KMOD_NUM = $1000;
KMOD_CAPS = $2000;
KMOD_MODE = 44000;
KMOD_RESERVED = $8000;
KMOD_CTRL = (KMOD_LCTRL or KMOD_RCTRL);
KMOD_SHIFT = (KMOD_LSHIFT or KMOD_RSHIFT);
KMOD_ALT = (KMOD_LALT or KMOD_RALT);
KMOD_META = (KMOD_LMETA or KMOD_RMETA);
SDL_ALPHA_OPAQUE = 255;
SDL_ALPHA_TRANSPARENT = 0;
SDL_SWSURFACE = $00000000;
SDL_HWSURFACE = $00000001;
SDL_ASYNCBLIT = $00000004;
SDL_ANYFORMAT = $10000000;
SDL_HWPALETTE = $20000000;
SDL_DOUBLEBUF = $40000000;
SDL_FULLSCREEN = $80000000;
SDL_OPENGL = $00000002;
SDL_OPENGLBLIT = $00000002;
SDL_RESIZABLE = $00000010;
SDL_NOFRAME = $00000020;
SDL_HWACCEL = $00000100;
SDL_SRCCOLORKEY = $00001000;
SDL_RLEACCELOK = $00002000;
SDL_RLEACCEL = $00004000;
SDL_SRCALPHA = $00010000;
SDL_SRCCLIPPING = $00100000;
SDL_PREALLOC = $01000000;
SDL_YV12_OVERLAY = $32315659;
SDL_IYUV_OVERLAY = $56555949;
SDL_YUY2_OVERLAY = $32595559;
SDL_UYVY_OVERLAY = $59565955;
SDL_YVYU_OVERLAY = $55595659;
SDL_LOGPAL = $01;
SDL_PHYSPAL = $02;
SDL_BUTTON_LEFT = 1;
SDL_BUTTON_MIDDLE = 2;
SDL_BUTTON_RIGHT = 3;
SDL_BUTTON_LMASK = SDL_PRESSED shl (SDL_BUTTON_LEFT - 1);
SDL_BUTTON_MMASK = SDL_PRESSED shl (SDL_BUTTON_MIDDLE - 1);
SDL_BUTTON_RMask = SDL_PRESSED shl (SDL_BUTTON_RIGHT - 1);
SDL_APPMOUSEFOCUS = $01;
SDL_APPINPUTFOCUS = $02;
SDL_APPACTIVE = $04;
SDL_MUTEX_TIMEDOUT = 1;
SDL_MUTEX_MAXWAIT = not Cardinal(0);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record UInt64

record UInt64

Unit

GLSDL

Declaration

type UInt64 = record

Description

Overview

Fields

hi: UInt32;
lo: UInt32;

Description

Fields

hi: UInt32;
lo: UInt32;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record SInt64

record SInt64

Unit

GLSDL

Declaration

type SInt64 = record

Description

Overview

Fields

hi: UInt32;
lo: UInt32;

Description

Fields

hi: UInt32;
lo: UInt32;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TArg

record TArg

Unit

GLSDL

Declaration

type TArg = record

Description

Overview

Fields

value_ptr: Pointer
value_i: Integer
value_f: double
buf: array[0..ERR_MAX_STRLEN - 1] of Byte

Description

Fields

value_ptr: Pointer
value_i: Integer
value_f: double
buf: array[0..ERR_MAX_STRLEN - 1] of Byte
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_error

record TSDL_error

Unit

GLSDL

Declaration

type TSDL_error = record

Description

Overview

Fields

error: Integer;
key: array[0..ERR_MAX_STRLEN - 1] of Byte;
argc: Integer;
args: array[0..ERR_MAX_ARGS - 1] of TArg;

Description

Fields

error: Integer;
key: array[0..ERR_MAX_STRLEN - 1] of Byte;
argc: Integer;
args: array[0..ERR_MAX_ARGS - 1] of TArg;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TStdio

record TStdio

Unit

GLSDL

Declaration

type TStdio = record

Description

Overview

Fields

autoclose: Integer;
fp: Pointer;

Description

Fields

autoclose: Integer;
fp: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TMem

record TMem

Unit

GLSDL

Declaration

type TMem = record

Description

Overview

Fields

base: PUInt8;
here: PUInt8;
stop: PUInt8;

Description

Fields

base: PUInt8;
here: PUInt8;
stop: PUInt8;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TUnknown

record TUnknown

Unit

GLSDL

Declaration

type TUnknown = record

Description

Overview

Fields

data1: Pointer;

Description

Fields

data1: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_RWops

record TSDL_RWops

Unit

GLSDL

Declaration

type TSDL_RWops = record

Description

Overview

Fields

seek: TSeek;
read: TRead;
write: TWrite;
close: TClose;
type_: UInt32;
stdio: TStdio
mem: TMem
unknown: TUnknown

Description

Fields

seek: TSeek;
read: TRead;
write: TWrite;
close: TClose;
type_: UInt32;
stdio: TStdio
mem: TMem
unknown: TUnknown
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_TimerID

record TSDL_TimerID

Unit

GLSDL

Declaration

type TSDL_TimerID = record

Description

Overview

Fields

interval: UInt32;
callback: TSDL_NewTimerCallback;
param: Pointer;
last_alarm: UInt32;
next: PSDL_TimerID;

Description

Fields

interval: UInt32;
callback: TSDL_NewTimerCallback;
param: Pointer;
last_alarm: UInt32;
next: PSDL_TimerID;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_AudioSpec

record TSDL_AudioSpec

Unit

GLSDL

Declaration

type TSDL_AudioSpec = record

Description

Overview

Fields

freq: Integer;
format: UInt16;
channels: UInt8;
silence: UInt8;
samples: UInt16;
padding: UInt16;
size: UInt32;
callback: procedure(userdata: Pointer; stream: PUInt8; len: Integer); cdecl;
userdata: Pointer;

Description

Fields

freq: Integer;
format: UInt16;
channels: UInt8;
silence: UInt8;
samples: UInt16;
padding: UInt16;
size: UInt32;
callback: procedure(userdata: Pointer; stream: PUInt8; len: Integer); cdecl;
userdata: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_AudioCVTFilter

record TSDL_AudioCVTFilter

Unit

GLSDL

Declaration

type TSDL_AudioCVTFilter = record

Description

Overview

Fields

cvt: PSDL_AudioCVT;
format: UInt16;

Description

Fields

cvt: PSDL_AudioCVT;
format: UInt16;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_AudioCVT

record TSDL_AudioCVT

Unit

GLSDL

Declaration

type TSDL_AudioCVT = record

Description

Overview

Fields

needed: Integer;
src_format: UInt16;
dst_format: UInt16;
rate_incr: double;
buf: PUInt8;
len: Integer;
len_cvt: Integer;
len_mult: Integer;
len_ratio: double;
filters: PSDL_AudioCVTFilterArray;
filter_index: Integer;

Description

Fields

needed: Integer;
src_format: UInt16;
dst_format: UInt16;
rate_incr: double;
buf: PUInt8;
len: Integer;
len_cvt: Integer;
len_mult: Integer;
len_ratio: double;
filters: PSDL_AudioCVTFilterArray;
filter_index: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_CDTrack

record TSDL_CDTrack

Unit

GLSDL

Declaration

type TSDL_CDTrack = record

Description

Overview

Fields

id: Integer;
type_: UInt8;
unused: UInt16;
length: UInt32;
offset: UInt32;

Description

Fields

id: Integer;
type_: UInt8;
unused: UInt16;
length: UInt32;
offset: UInt32;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_CD

record TSDL_CD

Unit

GLSDL

Declaration

type TSDL_CD = record

Description

Overview

Fields

id: Integer;
status: TSDL_CDStatus;
numtracks: Integer;
cur_track: Integer;
cur_frame: Integer;
track: array[0..SDL_MAX_TRACKS] of TSDL_CDTrack;

Description

Fields

id: Integer;
status: TSDL_CDStatus;
numtracks: Integer;
cur_track: Integer;
cur_frame: Integer;
track: array[0..SDL_MAX_TRACKS] of TSDL_CDTrack;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TTransAxis

record TTransAxis

Unit

GLSDL

Declaration

type TTransAxis = record

Description

Overview

Fields

offset: Integer;
scale: single;

Description

Fields

offset: Integer;
scale: single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TJoystick_hwdata

record TJoystick_hwdata

Unit

GLSDL

Declaration

type TJoystick_hwdata = record

Description

Overview

Fields

id: Integer;
transaxis: array[0..5] of TTransAxis;

Description

Fields

id: Integer;
transaxis: array[0..5] of TTransAxis;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TBallDelta

record TBallDelta

Unit

GLSDL

Declaration

type TBallDelta = record

Description

Overview

Fields

dx: Integer;
dy: Integer;

Description

Fields

dx: Integer;
dy: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_Joystick

record TSDL_Joystick

Unit

GLSDL

Declaration

type TSDL_Joystick = record

Description

Overview

Fields

index: UInt8;
name: PAnsiChar;
naxes: Integer;
axes: PUInt16;
nhats: Integer;
hats: PUInt8;
nballs: Integer;
balls: PBallDelta;
nbuttons: Integer;
buttons: PUInt8;
hwdata: PJoystick_hwdata;
ref_count: Integer;

Description

Fields

index: UInt8;
name: PAnsiChar;
naxes: Integer;
axes: PUInt16;
nhats: Integer;
hats: PUInt8;
nballs: Integer;
balls: PBallDelta;
nbuttons: Integer;
buttons: PUInt8;
hwdata: PJoystick_hwdata;
ref_count: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_version

record TSDL_version

Unit

GLSDL

Declaration

type TSDL_version = record

Description

Overview

Fields

major: UInt8;
minor: UInt8;
patch: UInt8;

Description

Fields

major: UInt8;
minor: UInt8;
patch: UInt8;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_KeySym

record TSDL_KeySym

Unit

GLSDL

Declaration

type TSDL_KeySym = record

Description

Overview

Fields

scancode: UInt8;
sym: TSDLKey;
modifier: TSDLMod;
unicode: UInt16;

Description

Fields

scancode: UInt8;
sym: TSDLKey;
modifier: TSDLMod;
unicode: UInt16;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_ActiveEvent

record TSDL_ActiveEvent

Unit

GLSDL

Declaration

type TSDL_ActiveEvent = record

Description

Overview

Fields

type_: UInt8;
gain: UInt8;
state: UInt8;

Description

Fields

type_: UInt8;
gain: UInt8;
state: UInt8;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_KeyboardEvent

record TSDL_KeyboardEvent

Unit

GLSDL

Declaration

type TSDL_KeyboardEvent = record

Description

Overview

Fields

type_: UInt8;
which: UInt8;
state: UInt8;
keysym: TSDL_KeySym;

Description

Fields

type_: UInt8;
which: UInt8;
state: UInt8;
keysym: TSDL_KeySym;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_MouseMotionEvent

record TSDL_MouseMotionEvent

Unit

GLSDL

Declaration

type TSDL_MouseMotionEvent = record

Description

Overview

Fields

type_: UInt8;
which: UInt8;
state: UInt8;
x: UInt16;
y: UInt16;
xrel: SInt16;
yrel: SInt16;

Description

Fields

type_: UInt8;
which: UInt8;
state: UInt8;
x: UInt16;
y: UInt16;
xrel: SInt16;
yrel: SInt16;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_MouseButtonEvent

record TSDL_MouseButtonEvent

Unit

GLSDL

Declaration

type TSDL_MouseButtonEvent = record

Description

Overview

Fields

type_: UInt8;
which: UInt8;
button: UInt8;
state: UInt8;
x: UInt16;
y: UInt16;

Description

Fields

type_: UInt8;
which: UInt8;
button: UInt8;
state: UInt8;
x: UInt16;
y: UInt16;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_JoyAxisEvent

record TSDL_JoyAxisEvent

Unit

GLSDL

Declaration

type TSDL_JoyAxisEvent = record

Description

Overview

Fields

type_: UInt8;
which: UInt8;
axis: UInt8;
value: SInt16;

Description

Fields

type_: UInt8;
which: UInt8;
axis: UInt8;
value: SInt16;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_JoyBallEvent

record TSDL_JoyBallEvent

Unit

GLSDL

Declaration

type TSDL_JoyBallEvent = record

Description

Overview

Fields

type_: UInt8;
which: UInt8;
ball: UInt8;
xrel: SInt16;
yrel: SInt16;

Description

Fields

type_: UInt8;
which: UInt8;
ball: UInt8;
xrel: SInt16;
yrel: SInt16;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_JoyHatEvent

record TSDL_JoyHatEvent

Unit

GLSDL

Declaration

type TSDL_JoyHatEvent = record

Description

Overview

Fields

type_: UInt8;
which: UInt8;
hat: UInt8;
value: UInt8;

Description

Fields

type_: UInt8;
which: UInt8;
hat: UInt8;
value: UInt8;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_JoyButtonEvent

record TSDL_JoyButtonEvent

Unit

GLSDL

Declaration

type TSDL_JoyButtonEvent = record

Description

Overview

Fields

type_: UInt8;
which: UInt8;
button: UInt8;
state: UInt8;

Description

Fields

type_: UInt8;
which: UInt8;
button: UInt8;
state: UInt8;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_ResizeEvent

record TSDL_ResizeEvent

Unit

GLSDL

Declaration

type TSDL_ResizeEvent = record

Description

Overview

Fields

type_: UInt8;
w: Integer;
h: Integer;

Description

Fields

type_: UInt8;
w: Integer;
h: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_QuitEvent

record TSDL_QuitEvent

Unit

GLSDL

Declaration

type TSDL_QuitEvent = record

Description

Overview

Fields

type_: UInt8;

Description

Fields

type_: UInt8;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_UserEvent

record TSDL_UserEvent

Unit

GLSDL

Declaration

type TSDL_UserEvent = record

Description

Overview

Fields

type_: UInt8;
code: Integer;
data1: Pointer;
data2: Pointer;

Description

Fields

type_: UInt8;
code: Integer;
data1: Pointer;
data2: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_ExposeEvent

record TSDL_ExposeEvent

Unit

GLSDL

Declaration

type TSDL_ExposeEvent = record

Description

Overview

Fields

type_: Uint8;

Description

Fields

type_: Uint8;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_SysWMmsg

record TSDL_SysWMmsg

Unit

GLSDL

Declaration

type TSDL_SysWMmsg = record

Description

Overview

Fields

version: TSDL_version;
h_wnd: HWND;
msg: UInt;
w_Param: WPARAM;
lParam: LPARAM;

Description

Fields

version: TSDL_version;
h_wnd: HWND;
msg: UInt;
w_Param: WPARAM;
lParam: LPARAM;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_SysWMEvent

record TSDL_SysWMEvent

Unit

GLSDL

Declaration

type TSDL_SysWMEvent = record

Description

Overview

Fields

type_: UInt8;
msg: PSDL_SysWMmsg;

Description

Fields

type_: UInt8;
msg: PSDL_SysWMmsg;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_Event

record TSDL_Event

Unit

GLSDL

Declaration

type TSDL_Event = record

Description

Overview

Fields

type_: byte
active: TSDL_ActiveEvent
key: TSDL_KeyboardEvent
motion: TSDL_MouseMotionEvent
button: TSDL_MouseButtonEvent
jaxis: TSDL_JoyAxisEvent
jball: TSDL_JoyBallEvent
jhat: TSDL_JoyHatEvent
jbutton: TSDL_JoyButtonEvent
resize: TSDL_ResizeEvent
quit: TSDL_QuitEvent
user: TSDL_UserEvent
syswm: TSDL_SysWMEvent

Description

Fields

type_: byte
active: TSDL_ActiveEvent
key: TSDL_KeyboardEvent
motion: TSDL_MouseMotionEvent
button: TSDL_MouseButtonEvent
jaxis: TSDL_JoyAxisEvent
jball: TSDL_JoyBallEvent
jhat: TSDL_JoyHatEvent
jbutton: TSDL_JoyButtonEvent
resize: TSDL_ResizeEvent
quit: TSDL_QuitEvent
user: TSDL_UserEvent
syswm: TSDL_SysWMEvent
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_Rect

record TSDL_Rect

Unit

GLSDL

Declaration

type TSDL_Rect = record

Description

Overview

Fields

x: SInt16;
y: SInt16;
w: UInt16;
h: UInt16;

Description

Fields

x: SInt16;
y: SInt16;
w: UInt16;
h: UInt16;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_Color

record TSDL_Color

Unit

GLSDL

Declaration

type TSDL_Color = record

Description

Overview

Fields

r: UInt8;
g: UInt8;
b: UInt8;
unused: UInt8;

Description

Fields

r: UInt8;
g: UInt8;
b: UInt8;
unused: UInt8;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_Palette

record TSDL_Palette

Unit

GLSDL

Declaration

type TSDL_Palette = record

Description

Overview

Fields

ncolors: Integer;
colors: PSDL_ColorArray;

Description

Fields

ncolors: Integer;
colors: PSDL_ColorArray;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_PixelFormat

record TSDL_PixelFormat

Unit

GLSDL

Declaration

type TSDL_PixelFormat = record

Description

Overview

Fields

palette: PSDL_Palette;
BitsPerPixel: UInt8;
BytesPerPixel: UInt8;
Rloss: UInt8;
Gloss: UInt8;
Bloss: UInt8;
Aloss: UInt8;
Rshift: UInt8;
Gshift: UInt8;
Bshift: UInt8;
Ashift: UInt8;
RMask: UInt32;
GMask: UInt32;
BMask: UInt32;
AMask: UInt32;
colorkey: UInt32;
alpha: UInt8;

Description

Fields

palette: PSDL_Palette;
BitsPerPixel: UInt8;
BytesPerPixel: UInt8;
Rloss: UInt8;
Gloss: UInt8;
Bloss: UInt8;
Aloss: UInt8;
Rshift: UInt8;
Gshift: UInt8;
Bshift: UInt8;
Ashift: UInt8;
RMask: UInt32;
GMask: UInt32;
BMask: UInt32;
AMask: UInt32;
colorkey: UInt32;
alpha: UInt8;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_BlitInfo

record TSDL_BlitInfo

Unit

GLSDL

Declaration

type TSDL_BlitInfo = record

Description

Overview

Fields

s_pixels: PUInt8;
s_width: Integer;
s_height: Integer;
s_skip: Integer;
d_pixels: PUInt8;
d_width: Integer;
d_height: Integer;
d_skip: Integer;
aux_data: Pointer;
src: PSDL_PixelFormat;
table: PUInt8;
dst: PSDL_PixelFormat;

Description

Fields

s_pixels: PUInt8;
s_width: Integer;
s_height: Integer;
s_skip: Integer;
d_pixels: PUInt8;
d_width: Integer;
d_height: Integer;
d_skip: Integer;
aux_data: Pointer;
src: PSDL_PixelFormat;
table: PUInt8;
dst: PSDL_PixelFormat;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_Surface

record TSDL_Surface

Unit

GLSDL

Declaration

type TSDL_Surface = record

Description

Overview

Fields

flags: UInt32;
format: PSDL_PixelFormat;
w: Integer;
h: Integer;
pitch: UInt16;
pixels: Pointer;
offset: Integer;
hwdata: Pointer;
clip_rect: TSDL_Rect;
unused1: UInt32;
locked: UInt32;
Blitmap: Pointer;
format_version: Cardinal;
refcount: Integer;

Description

Fields

flags: UInt32;
format: PSDL_PixelFormat;
w: Integer;
h: Integer;
pitch: UInt16;
pixels: Pointer;
offset: Integer;
hwdata: Pointer;
clip_rect: TSDL_Rect;
unused1: UInt32;
locked: UInt32;
Blitmap: Pointer;
format_version: Cardinal;
refcount: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_VideoInfo

record TSDL_VideoInfo

Unit

GLSDL

Declaration

type TSDL_VideoInfo = record

Description

Overview

Fields

hw_available: UInt8;
blit_hw: UInt8;
UnusedBits3: UInt8;
video_mem: UInt32;
vfmt: PSDL_PixelFormat;

Description

Fields

hw_available: UInt8;
blit_hw: UInt8;
UnusedBits3: UInt8;
video_mem: UInt32;
vfmt: PSDL_PixelFormat;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_Overlay

record TSDL_Overlay

Unit

GLSDL

Declaration

type TSDL_Overlay = record

Description

Overview

Fields

format: UInt32;
w: Integer;
h: Integer;
planes: Integer;
pitches: PUInt16;
pixels: PUInt8;
hw_overlay: UInt32;

Description

Fields

format: UInt32;
w: Integer;
h: Integer;
planes: Integer;
pitches: PUInt16;
pixels: PUInt8;
hw_overlay: UInt32;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:46


GLScene v.1.1.2: GLSDL: record TSDL_Cursor

record TSDL_Cursor

Unit

GLSDL

Declaration

type TSDL_Cursor = record

Description

Overview

Fields

area: TSDL_Rect;
hot_x: SInt16;
hot_y: SInt16;
data: PUInt8;
mask: PUInt8;
save: array[1..2] of PUInt8;
wm_cursor: Pointer;

Description

Fields

area: TSDL_Rect;
hot_x: SInt16;
hot_y: SInt16;
data: PUInt8;
mask: PUInt8;
save: array[1..2] of PUInt8;
wm_cursor: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSDL: record TSDL_Mutex

record TSDL_Mutex

Unit

GLSDL

Declaration

type TSDL_Mutex = record

Description

Overview

Fields

id: THANDLE;

Description

Fields

id: THANDLE;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSDL: record TSDL_semaphore

record TSDL_semaphore

Unit

GLSDL

Declaration

type TSDL_semaphore = record

Description

Overview

Fields

id: THANDLE;
count: UInt32;

Description

Fields

id: THANDLE;
count: UInt32;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSDL: record TSDL_Cond

record TSDL_Cond

Unit

GLSDL

Declaration

type TSDL_Cond = record

Description

Overview

Fields

lock: PSDL_mutex;
waiting: Integer;
signals: Integer;
wait_sem: PSDL_Sem;
wait_done: PSDL_Sem;

Description

Fields

lock: PSDL_mutex;
waiting: Integer;
signals: Integer;
wait_sem: PSDL_Sem;
wait_done: PSDL_Sem;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSDL: record TSDL_Thread

record TSDL_Thread

Unit

GLSDL

Declaration

type TSDL_Thread = record

Description

Overview

Fields

threadid: UInt32;
handle: TSYS_ThreadHandle;
status: Integer;
errbuf: TSDL_Error;
data: Pointer;

Description

Fields

threadid: UInt32;
handle: TSYS_ThreadHandle;
status: Integer;
errbuf: TSDL_Error;
data: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSDL: record TPoint

record TPoint

Unit

GLSDL

Declaration

type TPoint = record

Description

Overview

Fields

x: Longint;
y: Longint;

Description

Fields

x: Longint;
y: Longint;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSDL: record TRect

record TRect

Unit

GLSDL

Declaration

type TRect = record

Description

Overview

Fields

Left: Integer
Top: Integer
Right: Integer
Bottom: Integer
TopLeft: TPoint
BottomRight: TPoint

Description

Fields

Left: Integer
Top: Integer
Right: Integer
Bottom: Integer
TopLeft: TPoint
BottomRight: TPoint
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSDLContext

Unit GLSDLContext

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSDLContext<p>

SDL specific Context and Viewer.<p>

NOTA: SDL notifies use of context destruction *after* it happened, this prevents clean release of allocated stuff and requires a temporary switch to "ignore OpenGL errors" mode during destruction, thus potentially leaking memory (depending on hardware drivers willingness to perform automatic releases)<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>06/06/10 - Yar - Make outputDevice HWND type <li>15/02/07 - DaStr - Integer -> Cardinal because $R- was removed in GLScene.pas <li>11/09/06 - NC - Changes for Multiple-Render-Target <li>12/12/01 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSDLViewer |
Class TGLSDLContext |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSDLContext: Class TGLSDLViewer

Class TGLSDLViewer

Unit

GLSDLContext

Declaration

type TGLSDLViewer = class(TGLNonVisualViewer)

Description

A viewer using SDL.<p> Beware: only one at a time, no other viewers allowed!<br> Will also close the application when the window is closed!

Hierarchy

  • TComponent
  • TGLNonVisualViewer
  • TGLSDLViewer

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Active: Boolean;
Public | procedure Render(baseObject: TGLBaseSceneObject = nil); override;
Protected | procedure DoBufferStructuralChange(Sender: TObject); override;
Protected | procedure DoOnClose(sender: TObject);
Protected | procedure DoOnEventPollDone(sender: TObject);
Protected | procedure DoOnOpen(sender: TObject);
Protected | procedure DoOnResize(sender: TObject);
Protected | procedure DoOnSDLEvent(sender: TObject; const event: TSDL_Event);
Protected | procedure PrepareGLContext; override;
Protected | procedure SetCaption(const val: string);

Properties

Published | property Caption: string read FCaption write SetCaption;
Published | property OnEventPollDone: TNotifyEvent read FOnEventPollDone write FOnEventPollDone;
Published | property OnResize: TNotifyEvent read FOnResize write FOnResize;
Published | property OnSDLEvent: TSDLEvent read FOnSDLEvent write FOnSDLEvent;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function Active: Boolean;
Public procedure Render(baseObject: TGLBaseSceneObject = nil); override;
Protected procedure DoBufferStructuralChange(Sender: TObject); override;
Protected procedure DoOnClose(sender: TObject);
Protected procedure DoOnEventPollDone(sender: TObject);
Protected procedure DoOnOpen(sender: TObject);
Protected procedure DoOnResize(sender: TObject);
Protected procedure DoOnSDLEvent(sender: TObject; const event: TSDL_Event);
Protected procedure PrepareGLContext; override;
Protected procedure SetCaption(const val: string);

Properties

Published property Caption: string read FCaption write SetCaption;
Published property OnEventPollDone: TNotifyEvent read FOnEventPollDone write FOnEventPollDone;

Fired whenever an event polling completes with no events left to poll.

Published property OnResize: TNotifyEvent read FOnResize write FOnResize;
Published property OnSDLEvent: TSDLEvent read FOnSDLEvent write FOnSDLEvent;

Fired whenever an SDL Event is polled.<p> SDL_QUITEV and SDL_VIDEORESIZE are not passed to this event handler, they are passed via OnClose and OnResize respectively.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSDLContext: Class TGLSDLContext

Class TGLSDLContext

Unit

GLSDLContext

Declaration

type TGLSDLContext = class(TGLScreenControlingContext)

Description

A context driver for OpenGL via SDL (libsdl.org).<p> Due to limitations of SDL:<ul> <li>you may have only one SDL window opened at any time (you cannot have memory viewers) <li>closing the SDL window will terminate the application </ul>

Hierarchy

  • TObject
  • TGLContext
  • TGLScreenControlingContext
  • TGLSDLContext

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function IsValid: Boolean; override;
Public | function RenderOutputDevice: Pointer; override;
Protected | function DoShareLists(aContext: TGLContext): Boolean; override;
Public | procedure SwapBuffers; override;
Protected | procedure DoActivate; override;
Protected | procedure DoCreateContext(outputDevice: HDC); override;
Protected | procedure DoCreateMemoryContext(outputDevice: HWND; width, height: Integer; BufferCount: integer); override;
Protected | procedure DoDeactivate; override;
Protected | procedure DoDestroyContext; override;

Properties

Public property SDLWindow: TSDLWindow read FSDLWin;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function IsValid: Boolean; override;
Public function RenderOutputDevice: Pointer; override;
Protected function DoShareLists(aContext: TGLContext): Boolean; override;
Public procedure SwapBuffers; override;
Protected procedure DoActivate; override;
Protected procedure DoCreateContext(outputDevice: HDC); override;
Protected procedure DoCreateMemoryContext(outputDevice: HWND; width, height: Integer; BufferCount: integer); override;
Protected procedure DoDeactivate; override;
Protected procedure DoDestroyContext; override;

Properties

Public property SDLWindow: TSDLWindow read FSDLWin;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSDLWindow

Unit GLSDLWindow

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TSDLWindow |
Class ESDLError |

Functions and Procedures

procedure Register;

Types

TSDLWindowPixelDepth = (...);
TSDLWindowOption = (...);
TSDLWindowOptions = set of TSDLWindowOption;
TSDLEvent = procedure(sender: TObject; const event: TSDL_Event) of object;

Constants

cDefaultSDLWindowOptions = [voDoubleBuffer, voHardwareAccel, voOpenGL, voResizable];

Description

Functions and Procedures

procedure Register;

Types

TSDLWindowPixelDepth = (...);
Values
  • vpd16bits:
  • vpd24bits:
TSDLWindowOption = (...);
Values
  • voDoubleBuffer:
  • voHardwareAccel:
  • voOpenGL:
  • voResizable:
  • voFullScreen:
  • voStencilBuffer:
TSDLWindowOptions = set of TSDLWindowOption;
TSDLEvent = procedure(sender: TObject; const event: TSDL_Event) of object;

Constants

cDefaultSDLWindowOptions = [voDoubleBuffer, voHardwareAccel, voOpenGL, voResizable];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSDLWindow: Class TSDLWindow

Class TSDLWindow

Unit

GLSDLWindow

Declaration

type TSDLWindow = class(TComponent)

Description

Hierarchy

  • TComponent
  • TSDLWindow

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function BuildSDLVideoFlags: Cardinal;
Public | procedure Close;
Public | procedure Open;
Public | procedure PollEvents;
Public | procedure SwapBuffers;
Public | procedure UpdateWindow;
Protected | procedure CreateOrRecreateSDLSurface;
Protected | procedure ResizeGLWindow;
Protected | procedure SetActive(const val: Boolean);
Protected | procedure SetCaption(const val: String);
Protected | procedure SetHeight(const val: Integer);
Protected | procedure SetOptions(const val: TSDLWindowOptions);
Protected | procedure SetPixelDepth(const val: TSDLWindowPixelDepth);
Protected | procedure SetSDLGLAttributes;
Protected | procedure SetThreadedEventPolling(const val: Boolean);
Protected | procedure SetThreadPriority(const val: TThreadPriority);
Protected | procedure SetThreadSleepLength(const val: Integer);
Protected | procedure SetupSDLEnvironmentValues;
Protected | procedure SetWidth(const val: Integer);
Protected | procedure StartThread;
Protected | procedure StopThread;

Properties

Public | property Active: Boolean read FActive write SetActive;
Published | property Caption: String read FCaption write SetCaption;
Published | property Height: Integer read FHeight write SetHeight default 480;
Published | property OnClose: TNotifyEvent read FOnClose write FOnClose;
Published | property OnEventPollDone: TNotifyEvent read FOnEventPollDone write FOnEventPollDone;
Published | property OnOpen: TNotifyEvent read FOnOpen write FOnOpen;
Published | property OnResize: TNotifyEvent read FOnResize write FOnResize;
Published | property OnSDLEvent: TSDLEvent read FOnSDLEvent write FOnSDLEvent;
Published | property Options: TSDLWindowOptions read FOptions write SetOptions default cDefaultSDLWindowOptions;
Published | property PixelDepth: TSDLWindowPixelDepth read FPixelDepth write SetPixelDepth default vpd24bits;
Public | property Surface: PSDL_Surface read FSDLSurface;
Published | property ThreadedEventPolling: Boolean read FThreadedEventPolling write SetThreadedEventPolling default True;
Published | property ThreadPriority: TThreadPriority read FThreadPriority write SetThreadPriority default tpLower;
Published | property ThreadSleepLength: Integer read FThreadSleepLength write SetThreadSleepLength default 1;
Published | property Width: Integer read FWidth write SetWidth default 640;
Public | property WindowHandle: Cardinal read FWindowHandle write FWindowHandle;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function BuildSDLVideoFlags: Cardinal;
Public procedure Close;
Public procedure Open;
Public procedure PollEvents;
Public procedure SwapBuffers;
Public procedure UpdateWindow;
Protected procedure CreateOrRecreateSDLSurface;
Protected procedure ResizeGLWindow;
Protected procedure SetActive(const val: Boolean);
Protected procedure SetCaption(const val: String);
Protected procedure SetHeight(const val: Integer);
Protected procedure SetOptions(const val: TSDLWindowOptions);
Protected procedure SetPixelDepth(const val: TSDLWindowPixelDepth);
Protected procedure SetSDLGLAttributes;
Protected procedure SetThreadedEventPolling(const val: Boolean);
Protected procedure SetThreadPriority(const val: TThreadPriority);
Protected procedure SetThreadSleepLength(const val: Integer);
Protected procedure SetupSDLEnvironmentValues;
Protected procedure SetWidth(const val: Integer);
Protected procedure StartThread;
Protected procedure StopThread;

Properties

Public property Active: Boolean read FActive write SetActive;
Published property Caption: String read FCaption write SetCaption;
Published property Height: Integer read FHeight write SetHeight default 480;
Published property OnClose: TNotifyEvent read FOnClose write FOnClose;
Published property OnEventPollDone: TNotifyEvent read FOnEventPollDone write FOnEventPollDone;
Published property OnOpen: TNotifyEvent read FOnOpen write FOnOpen;
Published property OnResize: TNotifyEvent read FOnResize write FOnResize;
Published property OnSDLEvent: TSDLEvent read FOnSDLEvent write FOnSDLEvent;
Published property Options: TSDLWindowOptions read FOptions write SetOptions default cDefaultSDLWindowOptions;
Published property PixelDepth: TSDLWindowPixelDepth read FPixelDepth write SetPixelDepth default vpd24bits;
Public property Surface: PSDL_Surface read FSDLSurface;
Published property ThreadedEventPolling: Boolean read FThreadedEventPolling write SetThreadedEventPolling default True;
Published property ThreadPriority: TThreadPriority read FThreadPriority write SetThreadPriority default tpLower;
Published property ThreadSleepLength: Integer read FThreadSleepLength write SetThreadSleepLength default 1;
Published property Width: Integer read FWidth write SetWidth default 640;
Public property WindowHandle: Cardinal read FWindowHandle write FWindowHandle;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSDLWindow: Class ESDLError

Class ESDLError

Unit

GLSDLWindow

Declaration

type ESDLError = class(Exception)

Description

Hierarchy

  • Exception
  • ESDLError
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSelection

Unit GLSelection

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TPickRecord |
Class TGLPickList |
Class TGLBaseSelectTechnique |
Class TGLSelectRenderModeTechnique |

Functions and Procedures

function GetBestSelectorClass: TGLBaseSelectTechniqueClass;

Types

TPickSubObjects = array of LongInt;
TPickSortType = (...);
TGLBaseSelectTechniqueClass = class of TGLBaseSelectTechnique;

Constants

MAX_OBJECT_STACK_DEPTH = 512;

Description

Functions and Procedures

function GetBestSelectorClass: TGLBaseSelectTechniqueClass;

Types

TPickSubObjects = array of LongInt;
TPickSortType = (...);
Values
  • psDefault:
  • psName:
  • psMinDepth:
  • psMaxDepth:
TGLBaseSelectTechniqueClass = class of TGLBaseSelectTechnique;

Constants

MAX_OBJECT_STACK_DEPTH = 512;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSelection: Class TPickRecord

Class TPickRecord

Unit

GLSelection

Declaration

type TPickRecord = class(TObject)

Description

Hierarchy

  • TObject
  • TPickRecord

Overview

Fields

Public | AObject: TGLUpdateAbleComponent;
Public | SubObjects: TPickSubObjects;
Public | ZMin: Single;
Public | ZMax: Single;

Description

Fields

Public AObject: TGLUpdateAbleComponent;
Public SubObjects: TPickSubObjects;
Public ZMin: Single;
Public ZMax: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSelection: Class TGLPickList

Class TGLPickList

Unit

GLSelection

Declaration

type TGLPickList = class(TPersistentObjectList)

Description

List class for object picking.<p> This list is used to store the results of a PickObjects call.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TGLPickList

Overview

Methods

Public | constructor Create(aSortType: TPickSortType); reintroduce;
Public | function FindObject(AObject: TObject): Integer;
Public | procedure AddHit(obj: TObject; const subObj: TPickSubObjects; zMin, zMax: Single);
Public | procedure Clear; override;

Properties

Public | property FarDistance[Index: Integer]: Single read GetFar;
Public | property Hit[Index: Integer]: TObject read GetHit;
Public | property NearDistance[Index: Integer]: Single read GetNear;
Public | property SubObjects[Index: Integer]: TPickSubObjects read GetSubObjects;

Description

Methods

Public constructor Create(aSortType: TPickSortType); reintroduce;
Public function FindObject(AObject: TObject): Integer;
Public procedure AddHit(obj: TObject; const subObj: TPickSubObjects; zMin, zMax: Single);
Public procedure Clear; override;

Properties

Public property FarDistance[Index: Integer]: Single read GetFar;
Public property Hit[Index: Integer]: TObject read GetHit;
Public property NearDistance[Index: Integer]: Single read GetNear;
Public property SubObjects[Index: Integer]: TPickSubObjects read GetSubObjects;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSelection: Class TGLBaseSelectTechnique

Class TGLBaseSelectTechnique

Unit

GLSelection

Declaration

type TGLBaseSelectTechnique = class(TObject)

Description

Hierarchy

  • TObject
  • TGLBaseSelectTechnique

Overview

Fields

Protected | FObjectStack: array of TObject;
Protected | FNameStack: array[0..255] of TGLuint;
Protected | FCurrentName: TGLuint;
Protected | FStackPosition: Integer;
Protected | FObjectCountGuess: Integer;
Protected | FHits: Integer;

Methods

Public | class function IsSupported: Boolean; virtual; abstract;
Public | function Stop: Boolean; virtual; abstract;
Protected | function GetHits: Integer; virtual; abstract;
Protected | function GetItems(Value: Integer): TObject; virtual; abstract;
Protected | function GetObject: TObject; virtual; abstract;
Public | procedure FillPickingList(var AList: TGLPickList); virtual; abstract;
Public | procedure LoadObject(AName: TObject); virtual; abstract;
Public | procedure PopObject(); virtual; abstract;
Public | procedure PushObject(AName: TObject); virtual; abstract;
Public | procedure Start; virtual; abstract;
Protected | procedure SetHits(Value: Integer); virtual; abstract;
Protected | procedure SetObject(Value: TObject); virtual; abstract;
Protected | procedure SetObjectCountGuess(Value: Integer); virtual; abstract;

Properties

Public | property CurrentObject: TObject read GetObject write SetObject;
Public | property Hits: Integer read GetHits write SetHits;
Public | property ObjectCountGuess: Integer read FObjectCountGuess write SetObjectCountGuess;

Description

Fields

Protected FObjectStack: array of TObject;
Protected FNameStack: array[0..255] of TGLuint;
Protected FCurrentName: TGLuint;
Protected FStackPosition: Integer;
Protected FObjectCountGuess: Integer;
Protected FHits: Integer;

Methods

Public class function IsSupported: Boolean; virtual; abstract;
Public function Stop: Boolean; virtual; abstract;
Protected function GetHits: Integer; virtual; abstract;
Protected function GetItems(Value: Integer): TObject; virtual; abstract;
Protected function GetObject: TObject; virtual; abstract;
Public procedure FillPickingList(var AList: TGLPickList); virtual; abstract;
Public procedure LoadObject(AName: TObject); virtual; abstract;
Public procedure PopObject(); virtual; abstract;
Public procedure PushObject(AName: TObject); virtual; abstract;
Public procedure Start; virtual; abstract;
Protected procedure SetHits(Value: Integer); virtual; abstract;
Protected procedure SetObject(Value: TObject); virtual; abstract;
Protected procedure SetObjectCountGuess(Value: Integer); virtual; abstract;

Properties

Public property CurrentObject: TObject read GetObject write SetObject;
Public property Hits: Integer read GetHits write SetHits;
Public property ObjectCountGuess: Integer read FObjectCountGuess write SetObjectCountGuess;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLSelection: Class TGLSelectRenderModeTechnique

Class TGLSelectRenderModeTechnique

Unit

GLSelection

Declaration

type TGLSelectRenderModeTechnique = class(TGLBaseSelectTechnique)

Description

no description available, TGLBaseSelectTechnique description follows

Hierarchy

  • TObject
  • TGLBaseSelectTechnique
  • TGLSelectRenderModeTechnique

Overview

Methods

Public | class function IsSupported: Boolean; override;
Public | function Stop: Boolean; override;
Protected | function GetHits: Integer; override;
Protected | function GetObject: TObject; override;
Public | procedure FillPickingList(var AList: TGLPickList); override;
Public | procedure Start; override;
Protected | procedure SetHits(Value: Integer); override;
Protected | procedure SetObject(Value: TObject); override;
Protected | procedure SetObjectCountGuess(Value: Integer); override;

Properties

Public | property CurrentObject;
Public | property Hits;
Public | property ObjectCountGuess;

Description

Methods

Public class function IsSupported: Boolean; override;
Public function Stop: Boolean; override;
Protected function GetHits: Integer; override;
Protected function GetObject: TObject; override;
Public procedure FillPickingList(var AList: TGLPickList); override;
Public procedure Start; override;
Protected procedure SetHits(Value: Integer); override;
Protected procedure SetObject(Value: TObject); override;
Protected procedure SetObjectCountGuess(Value: Integer); override;

Properties

Public property CurrentObject;
Public property Hits;
Public property ObjectCountGuess;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLShaderCombiner

Unit GLShaderCombiner

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLShaderCombiner<p>

Allows to combine shaders in different sequences. Note, that can't just take 2 random shaders and combine them, because shaders often override the objects material and vertex data with a total disregard to what existed before it. But in some cases, especially with multipass shaders, this unit does magic and allows to reuse and upgrade previously written shaders.<p>

<b>History : </b><font size=-1><ul> <li>23/02/07 - DaStr - Initial version (contributed to GLScene)

Previous version history: v1.0 02 November '2006 Creation

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCustomShaderCombiner |
Class TGLShaderCombiner |

Types

TGLShaderCombinerType = (...);

Description

Types

TGLShaderCombinerType = (...);

MP - multipass, SP-singlepass, AP - anypass (single or multi) One-Two or Two-One determines the order of how the shaders should be applied For example, sctTwoMPOneSP means that first one will be applied Shader Two, which can be a multipass shader, then Shader One is applied, which should be a singlepass shader.

sctOneMPTwoSP and sctTwoMPOneSP modes are actualy quite Str@nge, because... well look at the code yourself

TODO: Add more modes here, including sctOneAPTwoAP, which should be the default one.

By the way, I admit - the names do look stupid, and if someone gives them proper names, I will be only glad.

Values
  • sctOneSPTwoAP:
  • sctTwoSPOneAP:
  • sctOneMPTwoSP:
  • sctTwoMPOneSP:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLShaderCombiner: Class TGLCustomShaderCombiner

Class TGLCustomShaderCombiner

Unit

GLShaderCombiner

Declaration

type TGLCustomShaderCombiner = class(TGLShader)

Description

no description available, TGLShader description follows

Generic, abstract shader class.<p> Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities.<br> Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShaderCombiner

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function ShaderSupported: Boolean; override;
Protected | function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Protected | property CombinerType: TGLShaderCombinerType read FCombinerType write FCombinerType default sctOneSPTwoAP;
Protected | property CurrentPass : Integer read FCurrentPass stored False;
Protected | property ShaderOne: TGLShader read FShaderOne write SetShaderOne;
Protected | property ShaderTwo: TGLShader read FShaderTwo write SetShaderTwo;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function ShaderSupported: Boolean; override;
Protected function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Public procedure Assign(Source: TPersistent); override;
Protected procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Protected property CombinerType: TGLShaderCombinerType read FCombinerType write FCombinerType default sctOneSPTwoAP;
Protected property CurrentPass : Integer read FCurrentPass stored False;
Protected property ShaderOne: TGLShader read FShaderOne write SetShaderOne;
Protected property ShaderTwo: TGLShader read FShaderTwo write SetShaderTwo;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLShaderCombiner: Class TGLShaderCombiner

Class TGLShaderCombiner

Unit

GLShaderCombiner

Declaration

type TGLShaderCombiner = class(TGLCustomShaderCombiner)

Description

no description available, TGLCustomShaderCombiner description follows
no description available, TGLShader description follows

Generic, abstract shader class.<p> Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities.<br> Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShaderCombiner
  • TGLShaderCombiner

Overview

Properties

Published | property CombinerType;
Published | property ShaderOne;
Published | property ShaderStyle;
Published | property ShaderTwo;

Description

Properties

Published property CombinerType;
Published property ShaderOne;
Published property ShaderStyle;
Published property ShaderTwo;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLShadowHDS

Unit GLShadowHDS

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Implements an HDS that automatically generates a terrain lightmap texture.<p> <b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/01/10 - Yar - Added GLTextureFormat to uses <li>13/11/07 - LIN - Added SkipGenerate flag. Set to true in "OnSourceDataFetched" to generate a blank shadow map. Then load your cached Shadowmap during OnThreadBmp32 event. <li>17/07/07 - LIN - Added OnThreadBmp32 event. This event can be used to modify the lightmap, before it is sent to texture memory. When used with TAsyncHDS, this event runs in the HeightData thread, and NOT in the main thread, so make sure code in this event is thread-safe. <li>22/03/07 - LIN - Thread-safe. (Now works with TGLAsyncHDS) <li>02/03/07 - LIN - Now works with InfiniteWrap terrain <li>14/02/07 - LIN - Creation </ul></font>

Issues:1:Ambient and Diffuse light properties can not be set to 0, to avoid what seems to be a Delphi bug: If a property of type 'Single' is set to 0, Delphi seems to skip the property's set method at startup, and just uses the default value instead. (Does anyone know a better workaround?) 2:Subsampling is not currently supported. 3:If the light vector's y component is not 0 then the shadow edges may be a bit jagged, due to the crude Bresenham line algorythm that was used. You can hide this by increasing SoftRange though. 5:At some light angles, rounding errors cause various artifacts: (Black tile edges / slight mis-alignments /etc.) 6:Applying materials ocasionally causes AV's

PS. The RayCastShadowHeight function returns the height of the shadow at a point on the terrain. This, and the LightVector may come in handy for implementing shadow volumes?

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLShadowHDS |

Types

TNewTilePreparedEvent = procedure (Sender : TGLShadowHDS; heightData : THeightData; ShadowMapMaterial : TGLLibMaterial) of object;
TThreadBmp32 = procedure (Sender : TGLShadowHDS; heightData : THeightData; bmp32:TGLBitmap32) of object;

Description

Types

TNewTilePreparedEvent = procedure (Sender : TGLShadowHDS; heightData : THeightData; ShadowMapMaterial : TGLLibMaterial) of object;
TThreadBmp32 = procedure (Sender : TGLShadowHDS; heightData : THeightData; bmp32:TGLBitmap32) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLShadowHDS: Class TGLShadowHDS

Class TGLShadowHDS

Unit

GLShadowHDS

Declaration

type TGLShadowHDS = class(THeightDataSourceFilter)

Description

An Height Data Source that generates terrain shadow maps automatically.<p> The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where shadowmaps will be placed.

Hierarchy

  • TComponent
  • THeightDataSource
  • THeightDataSourceFilter
  • TGLShadowHDS

Overview

Fields

Public SkipGenerate:boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function RayCastShadowHeight(HD:THeightData;localX,localY:single):single; overload;
Public | function Shade(HeightData:THeightData;x,y:integer;ShadowHeight,TerrainHeight:single):byte;
Protected | function CalcScale:TAffineVector;
Protected | function CalcStep:TAffineVector;
Protected | function FindUnusedMaterial:TGLLibMaterial;
Protected | function WrapDist(Lx,Ly:single):integer;
Public | procedure AfterPreparingData(heightData : THeightData); override;
Public | procedure BeforePreparingData(heightData : THeightData); override;
Public | procedure GenerateShadowMap(heightData:THeightData; ShadowMap:TGLBitmap32; scale:Single);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure PreparingData(heightData : THeightData); override;
Public | procedure RayCastLine(HeightData:THeightData;Lx,Ly:single;ShadowMap:TGLBitmap32);
Public | procedure TrimTextureCache(MaxTextureCount:integer=0);
Protected | procedure LocalToWorld(Lx,Ly:single;HD:THeightData;var Wx:single;var Wy:single);
Protected | procedure SetAmbient(AValue: Single);
Protected | procedure SetDiffuse(AValue: Single);
Protected | procedure SetLightVector(AValue: TGLCoordinates);
Protected | procedure SetScale(AValue: TGLCoordinates);
Protected | procedure SetShadowmapLibrary(const val : TGLMaterialLibrary);
Protected | procedure SetSoftRange(AValue:cardinal);
Protected | procedure Trim(MaxTextureCount:integer);
Protected | procedure WorldToLocal(wx,wy:single;var HD:THeightData;var lx:single; var ly:single);

Properties

Published | property Ambient : single read FAmbient write SetAmbient;
Published | property Diffuse : single read FDiffuse write SetDiffuse;
Published | property LightVector : TGLCoordinates read FLightVector write SetLightVector;
Published | property MaxTextures : integer read FMaxTextures write FMaxTextures;
Published | property OnNewTilePrepared : TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;
Published | property OnSourceDataFetched;
Published | property OnThreadBmp32 : TThreadBmp32 read FOnThreadBmp32 write FOnThreadBmp32;
Published | property Scale : TGLCoordinates read FScale write FScale;
Published | property ScanDistance: integer read FScanDistance write FScanDistance;
Published | property ShadowmapLibrary : TGLMaterialLibrary read FShadowmapLibrary write SetShadowmapLibrary;
Published | property SoftRange : cardinal read FSoftRange write SetSoftRange;

Description

Fields

Public SkipGenerate:boolean;

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function RayCastShadowHeight(HD:THeightData;localX,localY:single):single; overload;
Public function Shade(HeightData:THeightData;x,y:integer;ShadowHeight,TerrainHeight:single):byte;
Protected function CalcScale:TAffineVector;
Protected function CalcStep:TAffineVector;
Protected function FindUnusedMaterial:TGLLibMaterial;
Protected function WrapDist(Lx,Ly:single):integer;
Public procedure AfterPreparingData(heightData : THeightData); override;
Public procedure BeforePreparingData(heightData : THeightData); override;
Public procedure GenerateShadowMap(heightData:THeightData; ShadowMap:TGLBitmap32; scale:Single);
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure PreparingData(heightData : THeightData); override;
Public procedure RayCastLine(HeightData:THeightData;Lx,Ly:single;ShadowMap:TGLBitmap32);
Public procedure TrimTextureCache(MaxTextureCount:integer=0);
Protected procedure LocalToWorld(Lx,Ly:single;HD:THeightData;var Wx:single;var Wy:single);
Protected procedure SetAmbient(AValue: Single);
Protected procedure SetDiffuse(AValue: Single);
Protected procedure SetLightVector(AValue: TGLCoordinates);
Protected procedure SetScale(AValue: TGLCoordinates);
Protected procedure SetShadowmapLibrary(const val : TGLMaterialLibrary);
Protected procedure SetSoftRange(AValue:cardinal);
Protected procedure Trim(MaxTextureCount:integer);
Protected procedure WorldToLocal(wx,wy:single;var HD:THeightData;var lx:single; var ly:single);

Properties

Published property Ambient : single read FAmbient write SetAmbient;
Published property Diffuse : single read FDiffuse write SetDiffuse;
Published property LightVector : TGLCoordinates read FLightVector write SetLightVector;
Published property MaxTextures : integer read FMaxTextures write FMaxTextures;
Published property OnNewTilePrepared : TNewTilePreparedEvent read FOnNewTilePrepared write FOnNewTilePrepared;
Published property OnSourceDataFetched;
Published property OnThreadBmp32 : TThreadBmp32 read FOnThreadBmp32 write FOnThreadBmp32;
Published property Scale : TGLCoordinates read FScale write FScale;
Published property ScanDistance: integer read FScanDistance write FScanDistance;
Published property ShadowmapLibrary : TGLMaterialLibrary read FShadowmapLibrary write SetShadowmapLibrary;
Published property SoftRange : cardinal read FSoftRange write SetSoftRange;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLShadowPlane

Unit GLShadowPlane

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLShadowPlane<p>

Implements a basic shadow plane.<p>

It is strongly recommended to read and understand the explanations in the materials/mirror demo before using this component.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/06/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>22/02/10 - Yar - Optimization of switching states <li>12/03/09 - DanB - Bug-fix for scissor test on recent NVidia drivers <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>02/08/04 - LR, YHC - BCB corrections: use record instead array <li>23/03/04 - EG - Added spoTransparent <li>29/11/03 - EG - Scissors turned of if camera is withing bounding volume <li>30/10/02 - EG - Added OnBegin/EndRenderingShadows <li>25/10/02 - EG - Fixed Stencil cleanup and shadow projection bug <li>02/10/02 - EG - Added spoScissor <li>23/09/02 - EG - Creation (from GLMirror and Mattias FagerLund ShadowPlane.pas) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLShadowPlane |

Types

TShadowPlaneOption = (...);
TShadowPlaneOptions = set of TShadowPlaneOption;

Constants

cDefaultShadowPlaneOptions = [spoUseStencil, spoScissor];

Description

Types

TShadowPlaneOption = (...);
Values
  • spoUseStencil:
  • spoScissor:
  • spoTransparent:
  • spoIgnoreZ:
TShadowPlaneOptions = set of TShadowPlaneOption;

Constants

cDefaultShadowPlaneOptions = [spoUseStencil, spoScissor];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLShadowPlane: Class TGLShadowPlane

Class TGLShadowPlane

Unit

GLShadowPlane

Declaration

type TGLShadowPlane = class(TGLPlane)

Description

A simple shadow plane.<p> This mirror requires a stencil buffer for optimal rendering!<p> The object is a mix between a plane and a proxy object, in that the plane defines where the shadows are cast, while the proxy part is used to reference the objects that should be shadowing (it is legal to self-shadow, but no self-shadow visuals will be rendered).<br> If stenciling isn't used, the shadow will 'paint' the ShadowColor instead of blending it transparently.<p> You can have lower quality shadow geometry: add a dummycube, set it to invisible (so it won't be rendered in the "regular" pass), and under it place another visible dummycube under which you have all your low quality objects, use it as shadowing object. Apply the same movements to the low-quality objects that you apply to the visible, high-quality ones.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLPlane
  • TGLShadowPlane

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetShadowColor(const val: TGLColor);
Protected | procedure SetShadowedLight(const val: TGLLightSource);
Protected | procedure SetShadowingObject(const val: TGLBaseSceneObject);
Protected | procedure SetShadowOptions(const val: TShadowPlaneOptions);

Properties

Published | property OnBeginRenderingShadows: TNotifyEvent read FOnBeginRenderingShadows write FOnBeginRenderingShadows;
Published | property OnEndRenderingShadows: TNotifyEvent read FOnEndRenderingShadows write FOnEndRenderingShadows;
Published | property ShadowColor: TGLColor read FShadowColor write SetShadowColor;
Published | property ShadowedLight: TGLLightSource read FShadowedLight write SetShadowedLight;
Published | property ShadowingObject: TGLBaseSceneObject read FShadowingObject write SetShadowingObject;
Published | property ShadowOptions: TShadowPlaneOptions read FShadowOptions write SetShadowOptions default cDefaultShadowPlaneOptions;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetShadowColor(const val: TGLColor);
Protected procedure SetShadowedLight(const val: TGLLightSource);
Protected procedure SetShadowingObject(const val: TGLBaseSceneObject);
Protected procedure SetShadowOptions(const val: TShadowPlaneOptions);

Properties

Published property OnBeginRenderingShadows: TNotifyEvent read FOnBeginRenderingShadows write FOnBeginRenderingShadows;

Fired before the shadows are rendered.

Published property OnEndRenderingShadows: TNotifyEvent read FOnEndRenderingShadows write FOnEndRenderingShadows;

Fired after the shadows are rendered.

Published property ShadowColor: TGLColor read FShadowColor write SetShadowColor;

The shadow's color.<p> This color is transparently blended to make shadowed area darker.

Published property ShadowedLight: TGLLightSource read FShadowedLight write SetShadowedLight;

The light which casts shadows.<p> The light must be enabled otherwise shadows won't be cast.

Published property ShadowingObject: TGLBaseSceneObject read FShadowingObject write SetShadowingObject;

Selects the object to mirror.<p> If nil, the whole scene is mirrored.

Published property ShadowOptions: TShadowPlaneOptions read FShadowOptions write SetShadowOptions default cDefaultShadowPlaneOptions;

Controls rendering options.<p> <ul> <li>spoUseStencil: plane area is stenciled, prevents shadowing objects to be visible on the sides of the mirror (stencil buffer must be active in the viewer too). It also allows shadows to be partial (blended). <li>spoScissor: plane area is 'scissored', this should improve rendering speed by limiting rendering operations and fill rate, may have adverse effects on old hardware in rare cases <li>spoTransparent: does not render the plane's material, may help improve performance if you're fillrate limited, are using the stencil, and your hardware has optimized stencil-only writes </ul>

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLShadowVolume

Unit GLShadowVolume

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLShadowVolumes<p>

Implements basic shadow volumes support.<p>

Be aware that only objects that support silhouette determination have a chance to cast correct shadows. Transparent/blended/shader objects among the receivers or the casters will be rendered incorrectly.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>31/05/10 - Yar - Fixes forLinux x64 <li>01/05/10 - Yar - Moved ignoreBlendingRequests and ignoreDepthRequests behind RenderChildren <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>31/03/07 - DaStr - Fixed issue with invalid typecasting (thanks Burkhard Carstens) (Bugtracker ID = 1692016) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>08/12/04 - DB - Fixed bug in TGLShadowVolumeCaster.SetCaster <li>02/12/04 - MF - Added some documentation <li>23/03/04 - EG - Added Active property <li>29/11/03 - MF - Removed a "feature" that would draw the shadow of (hierarchially) invisible objects <li>27/11/03 - MF - TGLShadowVolumeCaster now registers with the FCaster for delete notification <li>11/06/03 - EG - Added silhouette cache <li>04/06/03 - EG - Creation (based on code from Mattias Fagerlund) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLShadowVolumeCaster |
Class TGLShadowVolumeOccluder |
Class TGLShadowVolumeLight |
Class TGLShadowVolumeCasters |
Class TGLShadowVolume |

Types

TGLShadowVolumeCapping = (...);
TGLShadowCastingMode = (...);
TGLShadowVolumeOption = (...);
TGLShadowVolumeOptions = set of TGLShadowVolumeOption;
TGLShadowVolumeMode = (...);

Description

Types

TGLShadowVolumeCapping = (...);

Determines when a shadow volume should generate a cap at the beginning and end of the volume. This is ONLY necessary when there's a chance that the camera could end up inside the shadow _or_ between the light source and the camera. If those two situations can't occur then not using capping is the best option.<br> Note that if you use the capping, you must either set the depth of view of your camera to something very large (f.i. 1e9), or you could use the infinite mode (csInfinitePerspective) of your camera. <ul> <li>svcDefault : Default behaviour <li>svcAlways : Always generates caps <li>svcNever : Never generates caps </ul>

Values
  • svcDefault:
  • svcAlways:
  • svcNever:
TGLShadowCastingMode = (...);

Determines when a caster should actually produce a shadow; <ul> <li>scmAlways : Caster always produces a shadow, ignoring visibility <li>scmVisible : Caster casts shadow if the object has visible=true <li>scmRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true <li>scmParentVisible : Caster produces shadow if parent has visible=true <li>scmParentRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true, starting from the parent (ignoring own visible setting) </ul>

Values
  • scmAlways:
  • scmVisible:
  • scmRecursivelyVisible:
  • scmParentVisible:
  • scmParentRecursivelyVisible:
TGLShadowVolumeOption = (...);

Shadow volume rendering options/optimizations.<p> <ul> <li>svoShowVolumes : make the shadow volumes visible <li>svoDesignVisible : the shadow are visible at design-time <li>svoCacheSilhouettes : cache shadow volume silhouettes, beneficial when some objects are static relatively to their light(s) <li>svoScissorClips : use scissor clipping per light, beneficial when lights are attenuated and don't illuminate the whole scene <li>svoWorldScissorClip : use scissor clipping for the world, beneficial when shadow receivers don't cover the whole viewer surface </ul>

Values
  • svoShowVolumes:
  • svoCacheSilhouettes:
  • svoScissorClips:
  • svoWorldScissorClip:
  • svoDesignVisible:
TGLShadowVolumeOptions = set of TGLShadowVolumeOption;
TGLShadowVolumeMode = (...);

Shadow rendering modes.<p> <ul> <li>svmAccurate : will render the scene with ambient lighting only, then for each light will make a diffuse+specular pass <li>svmDarkening : renders the scene with lighting on as usual, then darkens shadowed areas (i.e. inaccurate lighting, but will "shadow" objects that don't honour to diffuse or specular lighting) <li>svmOff : no shadowing will take place </ul>

Values
  • svmAccurate:
  • svmDarkening:
  • svmOff:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLShadowVolume: Class TGLShadowVolumeCaster

Class TGLShadowVolumeCaster

Unit

GLShadowVolume

Declaration

type TGLShadowVolumeCaster = class(TCollectionItem)

Description

Specifies an individual shadow caster.<p> Can be a light or an opaque object.

Hierarchy

  • TCollectionItem
  • TGLShadowVolumeCaster

Overview

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Protected | function GetGLShadowVolume: TGLShadowVolume;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure RemoveNotification(aComponent: TComponent);
Protected | procedure SetCaster(const val: TGLBaseSceneObject);

Properties

Published | property Capping: TGLShadowVolumeCapping read FCapping write FCapping default svcDefault;
Public | property Caster: TGLBaseSceneObject read FCaster write SetCaster;
Published | property CastingMode: TGLShadowCastingMode read FCastingMode write FCastingMode default scmRecursivelyVisible;
Published | property EffectiveRadius: Single read FEffectiveRadius write FEffectiveRadius;
Public | property GLShadowVolume: TGLShadowVolume read GetGLShadowVolume;

Description

Methods

Public constructor Create(ACollection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Protected function GetGLShadowVolume: TGLShadowVolume;
Public procedure Assign(Source: TPersistent); override;
Protected procedure RemoveNotification(aComponent: TComponent);
Protected procedure SetCaster(const val: TGLBaseSceneObject);

Properties

Published property Capping: TGLShadowVolumeCapping read FCapping write FCapping default svcDefault;

Specifies if the shadow volume should be capped.<p> Capping helps solve shadowing artefacts, at the cost of performance.

Public property Caster: TGLBaseSceneObject read FCaster write SetCaster;

Shadow casting object.<p> Can be an opaque object or a lightsource.

Published property CastingMode: TGLShadowCastingMode read FCastingMode write FCastingMode default scmRecursivelyVisible;

Determines when an object should cast a shadow or not. Typically, objects should only cast shadows when recursively visible. But if you're using dummy shadow casters which are less complex than their parent objects, you should use scmParentRecursivelyVisible.

Published property EffectiveRadius: Single read FEffectiveRadius write FEffectiveRadius;

Radius beyond which the caster can be ignored.<p> Zero (default value) means the caster can never be ignored.

Public property GLShadowVolume: TGLShadowVolume read GetGLShadowVolume;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLShadowVolume: Class TGLShadowVolumeOccluder

Class TGLShadowVolumeOccluder

Unit

GLShadowVolume

Declaration

type TGLShadowVolumeOccluder = class(TGLShadowVolumeCaster)

Description

Specifies an individual shadow casting occluder.<p>

Hierarchy

  • TCollectionItem
  • TGLShadowVolumeCaster
  • TGLShadowVolumeOccluder

Overview

Properties

Published property Caster;

Description

Properties

Published property Caster;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLShadowVolume: Class TGLShadowVolumeLight

Class TGLShadowVolumeLight

Unit

GLShadowVolume

Declaration

type TGLShadowVolumeLight = class(TGLShadowVolumeCaster)

Description

Specifies an individual shadow casting light.<p>

Hierarchy

  • TCollectionItem
  • TGLShadowVolumeCaster
  • TGLShadowVolumeLight

Overview

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetCachedSilhouette(AIndex: Integer): TGLSilhouette;
Protected | function GetLightSource: TGLLightSource;
Protected | function SetupScissorRect(worldAABB: PAABB; var rci: TRenderContextInfo): Boolean;
Public | procedure FlushSilhouetteCache;
Protected | procedure SetLightSource(const ls: TGLLightSource);
Protected | procedure StoreCachedSilhouette(AIndex: Integer; ASil: TGLSilhouette);

Properties

Published property LightSource: TGLLightSource read GetLightSource write SetLightSource;

Description

Methods

Public constructor Create(ACollection: TCollection); override;
Public destructor Destroy; override;
Protected function GetCachedSilhouette(AIndex: Integer): TGLSilhouette;
Protected function GetLightSource: TGLLightSource;
Protected function SetupScissorRect(worldAABB: PAABB; var rci: TRenderContextInfo): Boolean;

Compute and setup scissor clipping rect for the light.<p> Returns true if a scissor rect was setup

Public procedure FlushSilhouetteCache;
Protected procedure SetLightSource(const ls: TGLLightSource);
Protected procedure StoreCachedSilhouette(AIndex: Integer; ASil: TGLSilhouette);

Properties

Published property LightSource: TGLLightSource read GetLightSource write SetLightSource;

Shadow casting lightsource.<p>

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLShadowVolume: Class TGLShadowVolumeCasters

Class TGLShadowVolumeCasters

Unit

GLShadowVolume

Declaration

type TGLShadowVolumeCasters = class(TOwnedCollection)

Description

Collection of TGLShadowVolumeCaster.

Hierarchy

  • TOwnedCollection
  • TGLShadowVolumeCasters

Overview

Methods

Public | function AddCaster(obj: TGLBaseSceneObject; effectiveRadius: Single = 0; CastingMode: TGLShadowCastingMode = scmRecursivelyVisible): TGLShadowVolumeCaster;
Public | function IndexOfCaster(obj: TGLBaseSceneObject): Integer;
Protected | function GetItems(index: Integer): TGLShadowVolumeCaster;
Public | procedure RemoveCaster(obj: TGLBaseSceneObject);
Protected | procedure RemoveNotification(aComponent: TComponent);

Properties

Public property Items[index: Integer]: TGLShadowVolumeCaster read GetItems;

Description

Methods

Public function AddCaster(obj: TGLBaseSceneObject; effectiveRadius: Single = 0; CastingMode: TGLShadowCastingMode = scmRecursivelyVisible): TGLShadowVolumeCaster;
Public function IndexOfCaster(obj: TGLBaseSceneObject): Integer;
Protected function GetItems(index: Integer): TGLShadowVolumeCaster;
Public procedure RemoveCaster(obj: TGLBaseSceneObject);
Protected procedure RemoveNotification(aComponent: TComponent);

Properties

Public property Items[index: Integer]: TGLShadowVolumeCaster read GetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:47


GLScene v.1.1.2: GLShadowVolume: Class TGLShadowVolume

Class TGLShadowVolume

Unit

GLShadowVolume

Declaration

type TGLShadowVolume = class(TGLImmaterialSceneObject)

Description

Simple shadow volumes.<p> Shadow receiving objects are the ShadowVolume's children, shadow casters (opaque objects or lights) must be explicitly specified in the Casters collection.<p> Shadow volumes require that the buffer allows stencil buffers, GLSceneViewer.Buffer.ContextOptions contain roStencinBuffer. Without stencil buffers, shadow volumes will not work properly.<p> Another issue to look out for is the fact that shadow volume capping requires that the camera depth of view is either very high (fi 1e9) or that the camera style is csInfinitePerspective.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLShadowVolume

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure FlushSilhouetteCache;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetActive(const val: Boolean);
Protected | procedure SetDarkeningColor(const val: TGLColor);
Protected | procedure SetLights(const val: TGLShadowVolumeCasters);
Protected | procedure SetMode(const val: TGLShadowVolumeMode);
Protected | procedure SetOccluders(const val: TGLShadowVolumeCasters);
Protected | procedure SetOptions(const val: TGLShadowVolumeOptions);

Properties

Published | property Active: Boolean read FActive write SetActive default True;
Published | property Capping: TGLShadowVolumeCapping read FCapping write FCapping default svcAlways;
Published | property DarkeningColor: TGLColor read FDarkeningColor write SetDarkeningColor;
Published | property Lights: TGLShadowVolumeCasters read FLights write SetLights;
Published | property Mode: TGLShadowVolumeMode read FMode write SetMode default svmAccurate;
Published | property Occluders: TGLShadowVolumeCasters read FOccluders write SetOccluders;
Published | property Options: TGLShadowVolumeOptions read FOptions write SetOptions default [svoCacheSilhouettes, svoScissorClips];

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public procedure FlushSilhouetteCache;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetActive(const val: Boolean);
Protected procedure SetDarkeningColor(const val: TGLColor);
Protected procedure SetLights(const val: TGLShadowVolumeCasters);
Protected procedure SetMode(const val: TGLShadowVolumeMode);
Protected procedure SetOccluders(const val: TGLShadowVolumeCasters);
Protected procedure SetOptions(const val: TGLShadowVolumeOptions);

Properties

Published property Active: Boolean read FActive write SetActive default True;

Determines if shadow volume rendering is active.<p> When set to false, children will be rendered without any shadowing or multipass lighting.

Published property Capping: TGLShadowVolumeCapping read FCapping write FCapping default svcAlways;

Specifies if the shadow volume should be capped.<p> Capping helps solve shadowing artefacts, at the cost of performance.

Published property DarkeningColor: TGLColor read FDarkeningColor write SetDarkeningColor;

Darkening color used in svmDarkening mode.

Published property Lights: TGLShadowVolumeCasters read FLights write SetLights;

Lights that cast shadow volumes.

Published property Mode: TGLShadowVolumeMode read FMode write SetMode default svmAccurate;

Shadow rendering mode.

Published property Occluders: TGLShadowVolumeCasters read FOccluders write SetOccluders;

Occluders that cast shadow volumes.

Published property Options: TGLShadowVolumeOptions read FOptions write SetOptions default [svoCacheSilhouettes, svoScissorClips];

Shadow volume rendering options.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSilhouette

Unit GLSilhouette

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSilhouette<p>

Enhanced silhouette classes.<p>

Introduces more evolved/specific silhouette generation and management classes.<p>

CAUTION : both connectivity classes leak memory.<p>

<b>History : </b><font size=-1><ul> <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>16/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>26/09/03 - EG - Improved performance of TConnectivity data construction <li>19/06/03 - MF - Split up Connectivity classes <li>10/06/03 - EG - Creation (based on code from Mattias Fagerlund) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TGLSilhouetteParameters |
Class TGLSilhouette |
Class TBaseConnectivity |
Class TConnectivity |

Types

TGLSilhouetteStyle = (...);

Description

Types

TGLSilhouetteStyle = (...);
Values
  • ssOmni:
  • ssParallel:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSilhouette: packed record TGLSilhouetteParameters

packed record TGLSilhouetteParameters

Unit

GLSilhouette

Declaration

type TGLSilhouetteParameters = packed record

Description

Silouhette generation parameters.<p> SeenFrom and LightDirection are expected in local coordinates.

Overview

Fields

SeenFrom: TAffineVector;
LightDirection: TAffineVector;
Style: TGLSilhouetteStyle;
CappingRequired: Boolean;

Description

Fields

SeenFrom: TAffineVector;
LightDirection: TAffineVector;
Style: TGLSilhouetteStyle;
CappingRequired: Boolean;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSilhouette: Class TGLSilhouette

Class TGLSilhouette

Unit

GLSilhouette

Declaration

type TGLSilhouette = class(TObject)

Description

Base class storing a volume silhouette.<p> Made of a set of indexed vertices defining an outline, and another set of indexed vertices defining a capping volume. Coordinates system is the object's unscaled local coordinates system.<br> This is the base class, you can use the TGLSilhouette subclass if you need some helper methods for generating the indexed sets.

Hierarchy

  • TObject
  • TGLSilhouette

Overview

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | procedure AddCapToSilhouette(const v0, v1, v2 : TAffineVector; tightButSlow : Boolean);
Public | procedure AddEdgeToSilhouette(const v0, v1 : TAffineVector; tightButSlow : Boolean);
Public | procedure AddIndexedCapToSilhouette(const vi0, vi1, vi2 : Integer);
Public | procedure AddIndexedEdgeToSilhouette(const Vi0, Vi1 : integer);
Public | procedure Clear;
Public | procedure ExtrudeVerticesToInfinity(const origin : TAffineVector);
Public | procedure Flush;
Protected | procedure SetCapIndices(const value : TIntegerList);
Protected | procedure SetIndices(const value : TIntegerList);
Protected | procedure SetVertices(const value : TVectorList);

Properties

Public | property CapIndices : TIntegerList read FCapIndices write SetCapIndices;
Public | property Indices : TIntegerList read FIndices write SetIndices;
Public | property Parameters : TGLSilhouetteParameters read FParameters write FParameters;
Public | property Vertices : TVectorList read FVertices write SetVertices;

Description

Methods

Public constructor Create; virtual;
Public destructor Destroy; override;
Public procedure AddCapToSilhouette(const v0, v1, v2 : TAffineVector; tightButSlow : Boolean);

Adds a capping triangle to the silhouette.<p> If TightButSlow is true, no vertices will be doubled in the silhouette list. This should only be used when creating re-usable silhouettes, because it's much slower.

Public procedure AddEdgeToSilhouette(const v0, v1 : TAffineVector; tightButSlow : Boolean);

Adds an edge (two vertices) to the silhouette.<p> If TightButSlow is true, no vertices will be doubled in the silhouette list. This should only be used when creating re-usable silhouettes, because it's much slower.

Public procedure AddIndexedCapToSilhouette(const vi0, vi1, vi2 : Integer);
Public procedure AddIndexedEdgeToSilhouette(const Vi0, Vi1 : integer);
Public procedure Clear;
Public procedure ExtrudeVerticesToInfinity(const origin : TAffineVector);
Public procedure Flush;
Protected procedure SetCapIndices(const value : TIntegerList);
Protected procedure SetIndices(const value : TIntegerList);
Protected procedure SetVertices(const value : TVectorList);

Properties

Public property CapIndices : TIntegerList read FCapIndices write SetCapIndices;
Public property Indices : TIntegerList read FIndices write SetIndices;
Public property Parameters : TGLSilhouetteParameters read FParameters write FParameters;
Public property Vertices : TVectorList read FVertices write SetVertices;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSilhouette: Class TBaseConnectivity

Class TBaseConnectivity

Unit

GLSilhouette

Declaration

type TBaseConnectivity = class(TObject)

Description

Hierarchy

  • TObject
  • TBaseConnectivity

Overview

Fields

Protected FPrecomputeFaceNormal: boolean;

Methods

Public | constructor Create(APrecomputeFaceNormal : boolean); virtual;
Protected | function GetEdgeCount: integer; virtual;
Protected | function GetFaceCount: integer; virtual;
Public | procedure CreateSilhouette(const ASilhouetteParameters : TGLSilhouetteParameters; var ASilhouette : TGLSilhouette; AddToSilhouette : boolean); virtual;

Properties

Public | property EdgeCount : integer read GetEdgeCount;
Public | property FaceCount : integer read GetFaceCount;
Public | property PrecomputeFaceNormal : boolean read FPrecomputeFaceNormal;

Description

Fields

Protected FPrecomputeFaceNormal: boolean;

Methods

Public constructor Create(APrecomputeFaceNormal : boolean); virtual;
Protected function GetEdgeCount: integer; virtual;
Protected function GetFaceCount: integer; virtual;
Public procedure CreateSilhouette(const ASilhouetteParameters : TGLSilhouetteParameters; var ASilhouette : TGLSilhouette; AddToSilhouette : boolean); virtual;

Properties

Public property EdgeCount : integer read GetEdgeCount;
Public property FaceCount : integer read GetFaceCount;
Public property PrecomputeFaceNormal : boolean read FPrecomputeFaceNormal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSilhouette: Class TConnectivity

Class TConnectivity

Unit

GLSilhouette

Declaration

type TConnectivity = class(TBaseConnectivity)

Description

no description available, TBaseConnectivity description follows

Hierarchy

  • TObject
  • TBaseConnectivity
  • TConnectivity

Overview

Fields

Protected | FEdgeVertices: TIntegerList;
Protected | FEdgeFaces: TIntegerList;
Protected | FFaceVisible: TByteList;
Protected | FFaceVertexIndex: TIntegerList;
Protected | FFaceNormal: TAffineVectorList;
Protected | FVertexMemory: TIntegerList;
Protected | FVertices: TAffineVectorList;

Methods

Public | constructor Create(APrecomputeFaceNormal : boolean); override;
Public | destructor Destroy; override;
Public | function AddFace(const vertex0, vertex1, vertex2 : TAffineVector) : integer;
Public | function AddIndexedEdge(vertexIndex0, vertexIndex1 : integer; FaceID: integer) : integer;
Public | function AddIndexedFace(vi0, vi1, vi2 : integer) : integer;
Public | function AddQuad(const vertex0, vertex1, vertex2, vertex3 : TAffineVector) : integer;
Protected | function GetEdgeCount: integer; override;
Protected | function GetFaceCount: integer; override;
Protected | function ReuseOrFindVertexID(const seenFrom : TAffineVector; aSilhouette : TGLSilhouette; index : Integer) : Integer;
Public | procedure Clear; virtual;
Public | procedure CreateSilhouette(const silhouetteParameters : TGLSilhouetteParameters; var aSilhouette : TGLSilhouette; AddToSilhouette : boolean); override;

Properties

Public | property EdgeCount : integer read GetEdgeCount;
Public | property FaceCount : integer read GetFaceCount;

Description

Fields

Protected FEdgeVertices: TIntegerList;
Protected FEdgeFaces: TIntegerList;
Protected FFaceVisible: TByteList;
Protected FFaceVertexIndex: TIntegerList;
Protected FFaceNormal: TAffineVectorList;
Protected FVertexMemory: TIntegerList;
Protected FVertices: TAffineVectorList;

Methods

Public constructor Create(APrecomputeFaceNormal : boolean); override;
Public destructor Destroy; override;
Public function AddFace(const vertex0, vertex1, vertex2 : TAffineVector) : integer;
Public function AddIndexedEdge(vertexIndex0, vertexIndex1 : integer; FaceID: integer) : integer;
Public function AddIndexedFace(vi0, vi1, vi2 : integer) : integer;
Public function AddQuad(const vertex0, vertex1, vertex2, vertex3 : TAffineVector) : integer;
Protected function GetEdgeCount: integer; override;
Protected function GetFaceCount: integer; override;
Protected function ReuseOrFindVertexID(const seenFrom : TAffineVector; aSilhouette : TGLSilhouette; index : Integer) : Integer;
Public procedure Clear; virtual;

Clears out all connectivity information.

Public procedure CreateSilhouette(const silhouetteParameters : TGLSilhouetteParameters; var aSilhouette : TGLSilhouette; AddToSilhouette : boolean); override;

Properties

Public property EdgeCount : integer read GetEdgeCount;
Public property FaceCount : integer read GetFaceCount;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSimpleNavigation

Unit GLSimpleNavigation

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSimpleNavigation<p>

A simple component written by request from someone at the www.glscene.ru forums.<p> Allows to view the FPS and do the usual Zoom and MoveAroundTarget stuff <p> that all demos usually have in themselves. All that is just by dropping <p> this component on the form.<p>

<b>History : </b><font size=-1><ul> <li>14/12/10 - DaStr - Fixed compiler hint <li>12/12/10 - Yar - Adapted to using with TGLSceneForm <li>01/07/10 - Yar - Fixed zooming for FPC (by Rustam Asmandiarov aka Predator) <li>17/06/10 - YP - Fixed Zoom in/out inconsistence (mousewheel up/down inverted) <li>11/06/10 - YP - Fixed wheeldata can be equal to 0 in FormMouseWheel (div by 0 exception) <li>21/01/10 - Yar - Bugfixed zooming in design time (BugtrackerID = 2936266) <li>25/12/09 - DaStr - Added OnMouseMove event (thanks YarUnderoaker) <li>18/10/09 - DaStr - Added snoShowFPS option (thanks YarUnderoaker) Fixed a small bug with FPS string <li>29/09/07 - DaStr - Component now automaticly detects Form Caption <li>24/03/07 - DaStr - Replaced GLWin32Viewer with GLViewer (thanks Burkhard Carstens) (Bugtracker ID = 1684432) Got rid of Types dependancy <li>20/03/07 - DaStr - Improved SceneViewer detection <li>02/03/07 - DaStr - Added default values to all properties Added TGLSimpleNavigationOptions Added TGLSimpleNavigationKeyCombination Some renamings Added TGLSimpleNavigation.Assign MouseWheel is now handled by default <li>06/02/07 - DaStr - Creation (donated to GLScene) </ul></font><p>

Previous version history: v1.0 08 May '2006 Creation v1.1 04 September '2006 FreeNotification fix Automatic Form detection fix v1.2 11 September '2006 Automatic SceneViewer detection FormCaption added v1.3 06 February '2007 FPS is only updated in Run-Time now Donated to GLScene

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSimpleNavigationKeyCombination |
Class TGLSimpleNavigationKeyCombinations |
Class TGLSimpleNavigation |

Types

TPoint = GLCrossPlatform.TGLPoint;
TGLSimpleNavigationOption = (...);
TGLSimpleNavigationOptions = set of TGLSimpleNavigationOption;
TGLSimpleNavigationAction = (...);
TSimpleNavigationCustomActionEvent = procedure(Sender: TGLSimpleNavigationKeyCombination; Shift: TShiftState; X, Y: Integer) of object;

Description

Types

TPoint = GLCrossPlatform.TGLPoint;
TGLSimpleNavigationOption = (...);
Values
  • snoInvertMoveAroundX:
  • snoInvertMoveAroundY:
  • snoInvertZoom:
  • snoInvertMouseWheel:
  • snoInvertRotateX:
  • snoInvertRotateY:
  • snoMouseWheelHandled:
  • snoShowFPS:
TGLSimpleNavigationOptions = set of TGLSimpleNavigationOption;
TGLSimpleNavigationAction = (...);
Values
  • snaNone:
  • snaMoveAroundTarget:
  • snaZoom:
  • snaRotateTarget:
  • snaCustom:
TSimpleNavigationCustomActionEvent = procedure(Sender: TGLSimpleNavigationKeyCombination; Shift: TShiftState; X, Y: Integer) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSimpleNavigation: Class TGLSimpleNavigationKeyCombination

Class TGLSimpleNavigationKeyCombination

Unit

GLSimpleNavigation

Declaration

type TGLSimpleNavigationKeyCombination = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TGLSimpleNavigationKeyCombination

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure DoOnCustomAction(Shift: TShiftState; X, Y: Integer); virtual;

Properties

Published | property Action: TGLSimpleNavigationAction read FAction write FAction default snaNone;
Published | property ExitOnMatch: Boolean read FExitOnMatch write FExitOnMatch default True;
Published | property OnCustomAction: TSimpleNavigationCustomActionEvent read FOnCustomAction write FOnCustomAction;
Published | property ShiftState: TShiftState read FShiftState write FShiftState default [];

Description

Methods

Public constructor Create(Collection: TCollection); override;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;
Protected procedure DoOnCustomAction(Shift: TShiftState; X, Y: Integer); virtual;

Properties

Published property Action: TGLSimpleNavigationAction read FAction write FAction default snaNone;
Published property ExitOnMatch: Boolean read FExitOnMatch write FExitOnMatch default True;
Published property OnCustomAction: TSimpleNavigationCustomActionEvent read FOnCustomAction write FOnCustomAction;
Published property ShiftState: TShiftState read FShiftState write FShiftState default [];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSimpleNavigation: Class TGLSimpleNavigationKeyCombinations

Class TGLSimpleNavigationKeyCombinations

Unit

GLSimpleNavigation

Declaration

type TGLSimpleNavigationKeyCombinations = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLSimpleNavigationKeyCombinations

Overview

Methods

Public | function Add(const AShiftState: TShiftState; const AAction: TGLSimpleNavigationAction; const AExitOnMatch: Boolean = True): TGLSimpleNavigationKeyCombination; overload;
Public | function Add: TGLSimpleNavigationKeyCombination; overload;

Properties

Public property Items[Index: Integer]: TGLSimpleNavigationKeyCombination read GetItems write SetItems;

Description

Methods

Public function Add(const AShiftState: TShiftState; const AAction: TGLSimpleNavigationAction; const AExitOnMatch: Boolean = True): TGLSimpleNavigationKeyCombination; overload;
Public function Add: TGLSimpleNavigationKeyCombination; overload;

Properties

Public property Items[Index: Integer]: TGLSimpleNavigationKeyCombination read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSimpleNavigation: Class TGLSimpleNavigation

Class TGLSimpleNavigation

Unit

GLSimpleNavigation

Declaration

type TGLSimpleNavigation = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLSimpleNavigation

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property Form: TCustomForm read FForm write SetForm;
Published | property FormCaption: string read FFormCaption write FFormCaption stored StoreFormCaption;
Published | property GLSceneViewer: TGLSceneViewer read FGLSceneViewer write SetGLSceneViewer;
Published | property KeyCombinations: TGLSimpleNavigationKeyCombinations read FKeyCombinations write SetKeyCombinations;
Published | property MoveAroundTargetSpeed: Single read FMoveAroundTargetSpeed write FMoveAroundTargetSpeed stored StoreMoveAroundTargetSpeed;
Published | property OnMouseMove: TMouseMoveEvent read FOnMouseMove write FOnMouseMove;
Published | property Options: TGLSimpleNavigationOptions read FOptions write SetOptions default [snoMouseWheelHandled, snoShowFPS];
Published | property RotateTargetSpeed: Single read FRotateTargetSpeed write FRotateTargetSpeed stored StoreRotateTargetSpeed;
Published | property ZoomSpeed: Single read FZoomSpeed write FZoomSpeed stored StoreZoomSpeed;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure Assign(Source: TPersistent); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published property Form: TCustomForm read FForm write SetForm;
Published property FormCaption: string read FFormCaption write FFormCaption stored StoreFormCaption;
Published property GLSceneViewer: TGLSceneViewer read FGLSceneViewer write SetGLSceneViewer;
Published property KeyCombinations: TGLSimpleNavigationKeyCombinations read FKeyCombinations write SetKeyCombinations;
Published property MoveAroundTargetSpeed: Single read FMoveAroundTargetSpeed write FMoveAroundTargetSpeed stored StoreMoveAroundTargetSpeed;
Published property OnMouseMove: TMouseMoveEvent read FOnMouseMove write FOnMouseMove;
Published property Options: TGLSimpleNavigationOptions read FOptions write SetOptions default [snoMouseWheelHandled, snoShowFPS];
Published property RotateTargetSpeed: Single read FRotateTargetSpeed write FRotateTargetSpeed stored StoreRotateTargetSpeed;
Published property ZoomSpeed: Single read FZoomSpeed write FZoomSpeed stored StoreZoomSpeed;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSJPG

Unit GLSJPG

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

JPG<p>

<b>Historique : </b><font size=-1><ul> <li>27/02/10 - Yar - Added to GLScene from Mike Lischke GraphicEx package </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EInvalidGraphic |
Class EInvalidGraphicOperation |
record JQUANT_TBL |
record jpeg_component_info |
record jpeg_marker_reader |
record jpeg_error_mgr |
record jpeg_source_mgr |
record jpeg_memory_mgr |
packed record jpeg_common_struct |
record jpeg_progress_mgr |
packed record jpeg_decompress_struct |
record jpeg_destination_mgr |
packed record jpeg_compress_struct |
record TJPEGContext |

Functions and Procedures

procedure GetJPEGInfo(FileName: String; var Width, Height: Cardinal); overload;
procedure GetJPEGInfo(Stream: TStream; var Width, Height: Cardinal); overload;
procedure JPEGLIBCallback(const cinfo: jpeg_common_struct);
procedure jpeg_CreateDecompress(cinfo: j_decompress_ptr; version : integer; structsize : integer);
procedure jpeg_stdio_src(cinfo: j_decompress_ptr; input_file: TStream);
function jpeg_read_header(cinfo: j_decompress_ptr; RequireImage: LongBool): Integer;
procedure jpeg_calc_output_dimensions(cinfo: j_decompress_ptr);
function jpeg_start_decompress(cinfo: j_decompress_ptr): Longbool;
function jpeg_read_scanlines(cinfo: j_decompress_ptr; scanlines: JSAMPARRAY; max_lines: JDIMENSION): JDIMENSION;
function jpeg_read_raw_data(cinfo: j_decompress_ptr; data: JSAMPIMAGE; max_lines: JDIMENSION): JDIMENSION;
function jpeg_finish_decompress(cinfo: j_decompress_ptr): Longbool;
procedure jpeg_destroy_decompress(cinfo: j_decompress_ptr);
function jpeg_has_multiple_scans(cinfo: j_decompress_ptr): Longbool;
function jpeg_consume_input(cinfo: j_decompress_ptr): Integer;
function jpeg_start_output(cinfo: j_decompress_ptr; scan_number: Integer): Longbool;
function jpeg_finish_output(cinfo: j_decompress_ptr): LongBool;
procedure jpeg_abort(cinfo: j_decompress_ptr);
procedure jpeg_destroy(cinfo: j_decompress_ptr);
procedure jpeg_CreateCompress(cinfo: j_compress_ptr; version : integer; structsize : integer);
procedure jpeg_stdio_dest(cinfo: j_compress_ptr; output_file: TStream);
procedure jpeg_set_defaults(cinfo: j_compress_ptr);
procedure jpeg_set_quality(cinfo: j_compress_ptr; Quality: Integer; Baseline: Longbool);
procedure jpeg_set_colorspace(cinfo: j_compress_ptr; colorspace: J_COLOR_SPACE);
procedure jpeg_simple_progression(cinfo: j_compress_ptr);
procedure jpeg_start_compress(cinfo: j_compress_ptr; WriteAllTables: LongBool);
function jpeg_write_scanlines(cinfo: j_compress_ptr; scanlines: JSAMPARRAY; max_lines: JDIMENSION): JDIMENSION;
procedure jpeg_finish_compress(cinfo: j_compress_ptr);
function jpeg_resync_to_restart(cinfo: j_decompress_ptr; desired: Integer): LongBool;

Types

TJPGColorDepth = (...);
TJPEGPixelFormat = (...);
JSAMPLE = byte;
GETJSAMPLE = integer;
JCOEF = integer;
JCOEF_PTR = ˆJCOEF;
UINT8 = byte;
UINT16 = Word;
UINT32 = Cardinal;
INT16 = SmallInt;
INT32 = Integer;
INT32PTR = ˆINT32;
JDIMENSION = Cardinal;
JOCTET = Byte;
jTOctet = 0..(MaxInt div SizeOf(JOCTET))-1;
JOCTET_FIELD = array[jTOctet] of JOCTET;
JOCTET_FIELD_PTR = ˆJOCTET_FIELD;
JOCTETPTR = ˆJOCTET;
JSAMPLE_PTR = ˆJSAMPLE;
JSAMPROW_PTR = ˆJSAMPROW;
jTSample = 0..(MaxInt div SIZEOF(JSAMPLE))-1;
JSAMPLE_ARRAY = Array[jTSample] of JSAMPLE;
JSAMPROW = ˆJSAMPLE_ARRAY;
jTRow = 0..(MaxInt div SIZEOF(JSAMPROW))-1;
JSAMPROW_ARRAY = Array[jTRow] of JSAMPROW;
JSAMPARRAY = ˆJSAMPROW_ARRAY;
jTArray = 0..(MaxInt div SIZEOF(JSAMPARRAY))-1;
JSAMP_ARRAY = Array[jTArray] of JSAMPARRAY;
JSAMPIMAGE = ˆJSAMP_ARRAY;
J_COLOR_SPACE = (...);
J_DCT_METHOD = (...);
J_DITHER_MODE = (...);
JQUANT_TBL_ptr = ˆJQUANT_TBL;
jpeg_component_info_ptr = ˆjpeg_component_info;
jpeg_error_mgr_ptr = ˆjpeg_error_mgr;
jpeg_progress_mgr_ptr = ˆjpeg_progress_mgr;
j_common_ptr = ˆjpeg_common_struct;
j_decompress_ptr = ˆjpeg_decompress_struct;
jpeg_marker_parser_method = function(cinfo : j_decompress_ptr) : LongBool;
jpeg_marker_reader_ptr = ˆjpeg_marker_reader;
int8array = Array[0..8-1] of Integer;
jpeg_source_mgr_ptr = ˆjpeg_source_mgr;
jpeg_memory_mgr_ptr = ˆjpeg_memory_mgr;
j_compress_ptr = ˆjpeg_compress_struct;
jpeg_destination_mgr_ptr = ˆjpeg_destination_mgr;

Constants

JPEG_SUSPENDED = 0;
JPEG_HEADER_OK = 1;
JPEG_HEADER_TABLES_ONLY = 2;
JPEG_REACHED_SOS = 1;
JPEG_REACHED_EOI = 2;
JPEG_ROW_COMPLETED = 3;
JPEG_SCAN_COMPLETED = 4;
CSTATE_START = 100;
CSTATE_SCANNING = 101;
CSTATE_RAW_OK = 102;
CSTATE_WRCOEFS = 103;
JPEG_LIB_VERSION = 61;
JPEG_RST0 = $D0;
JPEG_EOI = $D9;
JPEG_APP0 = $E0;
JPEG_COM = $FE;
DCTSIZE = 8;
DCTSIZE2 = 64;
NUM_QUANT_TBLS = 4;
NUM_HUFF_TBLS = 4;
NUM_ARITH_TBLS = 16;
MAX_COMPS_IN_SCAN = 4;
MAX_SAMP_FACTOR = 4;
C_MAX_BLOCKS_IN_MCU = 10;
D_MAX_BLOCKS_IN_MCU = 10;
MAX_COMPONENTS = 10;
MAXJSAMPLE = 255;
CENTERJSAMPLE = 128;
DSTATE_START = 200;
DSTATE_INHEADER = 201;
DSTATE_READY = 202;
DSTATE_PRELOAD = 203;
DSTATE_PRESCAN = 204;
DSTATE_SCANNING = 205;
DSTATE_RAW_OK = 206;
DSTATE_BUFIMAGE = 207;
DSTATE_BUFPOST = 208;
DSTATE_RDCOEFS = 209;
DSTATE_STOPPING = 210;
JMSG_LENGTH_MAX = 200;
JMSG_STR_PARM_MAX = 80;
JPOOL_PERMANENT = 0;
JPOOL_IMAGE = 1;

Variables

jpeg_std_error: jpeg_error_mgr = ( error_exit: nil; emit_message: nil; output_message: nil; format_message: nil; reset_error_mgr: nil);

Description

Functions and Procedures

procedure GetJPEGInfo(FileName: String; var Width, Height: Cardinal); overload;
procedure GetJPEGInfo(Stream: TStream; var Width, Height: Cardinal); overload;
procedure JPEGLIBCallback(const cinfo: jpeg_common_struct);
procedure jpeg_CreateDecompress(cinfo: j_decompress_ptr; version : integer; structsize : integer);
procedure jpeg_stdio_src(cinfo: j_decompress_ptr; input_file: TStream);
function jpeg_read_header(cinfo: j_decompress_ptr; RequireImage: LongBool): Integer;
procedure jpeg_calc_output_dimensions(cinfo: j_decompress_ptr);
function jpeg_start_decompress(cinfo: j_decompress_ptr): Longbool;
function jpeg_read_scanlines(cinfo: j_decompress_ptr; scanlines: JSAMPARRAY; max_lines: JDIMENSION): JDIMENSION;
function jpeg_read_raw_data(cinfo: j_decompress_ptr; data: JSAMPIMAGE; max_lines: JDIMENSION): JDIMENSION;
function jpeg_finish_decompress(cinfo: j_decompress_ptr): Longbool;
procedure jpeg_destroy_decompress(cinfo: j_decompress_ptr);
function jpeg_has_multiple_scans(cinfo: j_decompress_ptr): Longbool;
function jpeg_consume_input(cinfo: j_decompress_ptr): Integer;
function jpeg_start_output(cinfo: j_decompress_ptr; scan_number: Integer): Longbool;
function jpeg_finish_output(cinfo: j_decompress_ptr): LongBool;
procedure jpeg_abort(cinfo: j_decompress_ptr);
procedure jpeg_destroy(cinfo: j_decompress_ptr);
procedure jpeg_CreateCompress(cinfo: j_compress_ptr; version : integer; structsize : integer);
procedure jpeg_stdio_dest(cinfo: j_compress_ptr; output_file: TStream);
procedure jpeg_set_defaults(cinfo: j_compress_ptr);
procedure jpeg_set_quality(cinfo: j_compress_ptr; Quality: Integer; Baseline: Longbool);
procedure jpeg_set_colorspace(cinfo: j_compress_ptr; colorspace: J_COLOR_SPACE);
procedure jpeg_simple_progression(cinfo: j_compress_ptr);
procedure jpeg_start_compress(cinfo: j_compress_ptr; WriteAllTables: LongBool);
function jpeg_write_scanlines(cinfo: j_compress_ptr; scanlines: JSAMPARRAY; max_lines: JDIMENSION): JDIMENSION;
procedure jpeg_finish_compress(cinfo: j_compress_ptr);
function jpeg_resync_to_restart(cinfo: j_decompress_ptr; desired: Integer): LongBool;

Types

TJPGColorDepth = (...);
Values
  • jpgAuto:
  • jpgGray:
  • jpg8Bit:
  • jpg24Bit:
TJPEGPixelFormat = (...);
Values
  • jf24Bit:
  • jf8Bit:
JSAMPLE = byte;
GETJSAMPLE = integer;
JCOEF = integer;
JCOEF_PTR = ˆJCOEF;
UINT8 = byte;
UINT16 = Word;
UINT32 = Cardinal;
INT16 = SmallInt;
INT32 = Integer;
INT32PTR = ˆINT32;
JDIMENSION = Cardinal;
JOCTET = Byte;
jTOctet = 0..(MaxInt div SizeOf(JOCTET))-1;
JOCTET_FIELD = array[jTOctet] of JOCTET;
JOCTET_FIELD_PTR = ˆJOCTET_FIELD;
JOCTETPTR = ˆJOCTET;
JSAMPLE_PTR = ˆJSAMPLE;
JSAMPROW_PTR = ˆJSAMPROW;
jTSample = 0..(MaxInt div SIZEOF(JSAMPLE))-1;
JSAMPLE_ARRAY = Array[jTSample] of JSAMPLE;
JSAMPROW = ˆJSAMPLE_ARRAY;
jTRow = 0..(MaxInt div SIZEOF(JSAMPROW))-1;
JSAMPROW_ARRAY = Array[jTRow] of JSAMPROW;
JSAMPARRAY = ˆJSAMPROW_ARRAY;
jTArray = 0..(MaxInt div SIZEOF(JSAMPARRAY))-1;
JSAMP_ARRAY = Array[jTArray] of JSAMPARRAY;
JSAMPIMAGE = ˆJSAMP_ARRAY;
J_COLOR_SPACE = (...);
Values
  • JCS_UNKNOWN:
  • JCS_GRAYSCALE:
  • JCS_RGB:
  • JCS_YCbCr:
  • JCS_CMYK:
  • JCS_YCCK:
J_DCT_METHOD = (...);
Values
  • JDCT_ISLOW:
  • JDCT_IFAST:
  • JDCT_FLOAT:
J_DITHER_MODE = (...);
Values
  • JDITHER_NONE:
  • JDITHER_ORDERED:
  • JDITHER_FS:
JQUANT_TBL_ptr = ˆJQUANT_TBL;
jpeg_component_info_ptr = ˆjpeg_component_info;
jpeg_error_mgr_ptr = ˆjpeg_error_mgr;
jpeg_progress_mgr_ptr = ˆjpeg_progress_mgr;
j_common_ptr = ˆjpeg_common_struct;
j_decompress_ptr = ˆjpeg_decompress_struct;
jpeg_marker_parser_method = function(cinfo : j_decompress_ptr) : LongBool;
jpeg_marker_reader_ptr = ˆjpeg_marker_reader;
int8array = Array[0..8-1] of Integer;
jpeg_source_mgr_ptr = ˆjpeg_source_mgr;
jpeg_memory_mgr_ptr = ˆjpeg_memory_mgr;
j_compress_ptr = ˆjpeg_compress_struct;
jpeg_destination_mgr_ptr = ˆjpeg_destination_mgr;

Constants

JPEG_SUSPENDED = 0;
JPEG_HEADER_OK = 1;
JPEG_HEADER_TABLES_ONLY = 2;
JPEG_REACHED_SOS = 1;
JPEG_REACHED_EOI = 2;
JPEG_ROW_COMPLETED = 3;
JPEG_SCAN_COMPLETED = 4;
CSTATE_START = 100;
CSTATE_SCANNING = 101;
CSTATE_RAW_OK = 102;
CSTATE_WRCOEFS = 103;
JPEG_LIB_VERSION = 61;
JPEG_RST0 = $D0;
JPEG_EOI = $D9;
JPEG_APP0 = $E0;
JPEG_COM = $FE;
DCTSIZE = 8;
DCTSIZE2 = 64;
NUM_QUANT_TBLS = 4;
NUM_HUFF_TBLS = 4;
NUM_ARITH_TBLS = 16;
MAX_COMPS_IN_SCAN = 4;
MAX_SAMP_FACTOR = 4;
C_MAX_BLOCKS_IN_MCU = 10;
D_MAX_BLOCKS_IN_MCU = 10;
MAX_COMPONENTS = 10;
MAXJSAMPLE = 255;
CENTERJSAMPLE = 128;
DSTATE_START = 200;
DSTATE_INHEADER = 201;
DSTATE_READY = 202;
DSTATE_PRELOAD = 203;
DSTATE_PRESCAN = 204;
DSTATE_SCANNING = 205;
DSTATE_RAW_OK = 206;
DSTATE_BUFIMAGE = 207;
DSTATE_BUFPOST = 208;
DSTATE_RDCOEFS = 209;
DSTATE_STOPPING = 210;
JMSG_LENGTH_MAX = 200;
JMSG_STR_PARM_MAX = 80;
JPOOL_PERMANENT = 0;
JPOOL_IMAGE = 1;

Variables

jpeg_std_error: jpeg_error_mgr = ( error_exit: nil; emit_message: nil; output_message: nil; format_message: nil; reset_error_mgr: nil);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSJPG: Class EInvalidGraphic

Class EInvalidGraphic

Unit

GLSJPG

Declaration

type EInvalidGraphic = class(Exception)

Description

Hierarchy

  • Exception
  • EInvalidGraphic
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSJPG: Class EInvalidGraphicOperation

Class EInvalidGraphicOperation

Unit

GLSJPG

Declaration

type EInvalidGraphicOperation = class(Exception)

Description

Hierarchy

  • Exception
  • EInvalidGraphicOperation
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSJPG: record JQUANT_TBL

record JQUANT_TBL

Unit

GLSJPG

Declaration

type JQUANT_TBL = record

Description

Overview

Fields

quantval: array[0..DCTSIZE2 - 1] of Word;
sent_table: LongBool;

Description

Fields

quantval: array[0..DCTSIZE2 - 1] of Word;
sent_table: LongBool;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSJPG: record jpeg_component_info

record jpeg_component_info

Unit

GLSJPG

Declaration

type jpeg_component_info = record

Description

Overview

Fields

component_id: Integer;
component_index: Integer;
h_samp_factor: Integer;
v_samp_factor: Integer;
quant_tbl_no: Integer;
dc_tbl_no: Integer;
ac_tbl_no: Integer;
width_in_blocks: JDIMENSION;
height_in_blocks: JDIMENSION;
DCT_scaled_size: Integer;
downsampled_width: JDIMENSION;
downsampled_height: JDIMENSION;
component_needed: LongBool;
MCU_width: Integer;
MCU_height: Integer;
MCU_blocks: Integer;
MCU_sample_width: Integer;
last_col_width: Integer;
last_row_height: Integer;
quant_table: JQUANT_TBL_ptr;
dct_table: Pointer;

Description

Fields

component_id: Integer;
component_index: Integer;
h_samp_factor: Integer;
v_samp_factor: Integer;
quant_tbl_no: Integer;
dc_tbl_no: Integer;
ac_tbl_no: Integer;
width_in_blocks: JDIMENSION;
height_in_blocks: JDIMENSION;
DCT_scaled_size: Integer;
downsampled_width: JDIMENSION;
downsampled_height: JDIMENSION;
component_needed: LongBool;
MCU_width: Integer;
MCU_height: Integer;
MCU_blocks: Integer;
MCU_sample_width: Integer;
last_col_width: Integer;
last_row_height: Integer;
quant_table: JQUANT_TBL_ptr;
dct_table: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSJPG: record jpeg_marker_reader

record jpeg_marker_reader

Unit

GLSJPG

Declaration

type jpeg_marker_reader = record

Description

Overview

Fields

reset_marker_reader: procedure(cinfo : j_decompress_ptr);
read_markers: function(cinfo : j_decompress_ptr) : Integer;
read_restart_marker: jpeg_marker_parser_method;
process_COM: jpeg_marker_parser_method;
process_APPn: Array[0..16-1] of jpeg_marker_parser_method;
saw_SOI: LongBool;
saw_SOF: LongBool;
next_restart_num: Integer;
discarded_bytes: UINT32;

Description

Fields

reset_marker_reader: procedure(cinfo : j_decompress_ptr);
read_markers: function(cinfo : j_decompress_ptr) : Integer;
read_restart_marker: jpeg_marker_parser_method;
process_COM: jpeg_marker_parser_method;
process_APPn: Array[0..16-1] of jpeg_marker_parser_method;
saw_SOI: LongBool;
saw_SOF: LongBool;
next_restart_num: Integer;
discarded_bytes: UINT32;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSJPG: record jpeg_error_mgr

record jpeg_error_mgr

Unit

GLSJPG

Declaration

type jpeg_error_mgr = record

Description

Overview

Fields

error_exit: procedure(cinfo : j_common_ptr);
emit_message: procedure(cinfo : j_common_ptr; msg_level : Integer);
output_message: procedure(cinfo : j_common_ptr);
format_message: procedure(cinfo : j_common_ptr; buffer: PAnsiChar);
reset_error_mgr: procedure(cinfo : j_common_ptr);
msg_code: Integer;
msg_parm: record
trace_level: Integer;
num_warnings: Integer;

Description

Fields

error_exit: procedure(cinfo : j_common_ptr);
emit_message: procedure(cinfo : j_common_ptr; msg_level : Integer);
output_message: procedure(cinfo : j_common_ptr);
format_message: procedure(cinfo : j_common_ptr; buffer: PAnsiChar);
reset_error_mgr: procedure(cinfo : j_common_ptr);
msg_code: Integer;
msg_parm: record
trace_level: Integer;
num_warnings: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSJPG: record jpeg_source_mgr

record jpeg_source_mgr

Unit

GLSJPG

Declaration

type jpeg_source_mgr = record

Description

Overview

Fields

next_input_byte: JOCTETptr;
bytes_in_buffer: Longint;
init_source: procedure(cinfo : j_decompress_ptr);
fill_input_buffer: function(cinfo : j_decompress_ptr) : LongBool;
skip_input_data: procedure(cinfo : j_decompress_ptr; num_bytes : Longint);
resync_to_restart: function(cinfo : j_decompress_ptr; desired : Integer) : LongBool;
term_source: procedure(cinfo : j_decompress_ptr);

Description

Fields

next_input_byte: JOCTETptr;
bytes_in_buffer: Longint;
init_source: procedure(cinfo : j_decompress_ptr);
fill_input_buffer: function(cinfo : j_decompress_ptr) : LongBool;
skip_input_data: procedure(cinfo : j_decompress_ptr; num_bytes : Longint);
resync_to_restart: function(cinfo : j_decompress_ptr; desired : Integer) : LongBool;
term_source: procedure(cinfo : j_decompress_ptr);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSJPG: record jpeg_memory_mgr

record jpeg_memory_mgr

Unit

GLSJPG

Declaration

type jpeg_memory_mgr = record

Description

Overview

Fields

alloc_small: function(cinfo : j_common_ptr; pool_id, sizeofobject: Integer): pointer;
alloc_large: function(cinfo : j_common_ptr; pool_id, sizeofobject: Integer): pointer;
alloc_sarray: function(cinfo : j_common_ptr; pool_id : Integer; samplesperrow : JDIMENSION; numrows : JDIMENSION) : JSAMPARRAY;
alloc_barray: pointer;
request_virt_sarray: pointer;
request_virt_barray: pointer;
realize_virt_arrays: pointer;
access_virt_sarray: pointer;
access_virt_barray: pointer;
free_pool: pointer;
self_destruct: pointer;
max_memory_to_use: Longint;

Description

Fields

alloc_small: function(cinfo : j_common_ptr; pool_id, sizeofobject: Integer): pointer;
alloc_large: function(cinfo : j_common_ptr; pool_id, sizeofobject: Integer): pointer;
alloc_sarray: function(cinfo : j_common_ptr; pool_id : Integer; samplesperrow : JDIMENSION; numrows : JDIMENSION) : JSAMPARRAY;
alloc_barray: pointer;
request_virt_sarray: pointer;
request_virt_barray: pointer;
realize_virt_arrays: pointer;
access_virt_sarray: pointer;
access_virt_barray: pointer;
free_pool: pointer;
self_destruct: pointer;
max_memory_to_use: Longint;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSJPG: packed record jpeg_common_struct

packed record jpeg_common_struct

Unit

GLSJPG

Declaration

type jpeg_common_struct = packed record

Description

Overview

Fields

err: jpeg_error_mgr_ptr;
mem: jpeg_memory_mgr_ptr;
progress: jpeg_progress_mgr_ptr;
is_decompressor: LongBool;
global_state: Integer;

Description

Fields

err: jpeg_error_mgr_ptr;
mem: jpeg_memory_mgr_ptr;
progress: jpeg_progress_mgr_ptr;
is_decompressor: LongBool;
global_state: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSJPG: record jpeg_progress_mgr

record jpeg_progress_mgr

Unit

GLSJPG

Declaration

type jpeg_progress_mgr = record

Description

Overview

Fields

progress_monitor: procedure(const cinfo : jpeg_common_struct);
pass_counter: Integer;
pass_limit: Integer;
completed_passes: Integer;
total_passes: Integer;
instance: TPersistent;
last_pass: Integer;
last_pct: Integer;
last_time: Integer;
last_scanline: Integer;

Description

Fields

progress_monitor: procedure(const cinfo : jpeg_common_struct);
pass_counter: Integer;
pass_limit: Integer;
completed_passes: Integer;
total_passes: Integer;
instance: TPersistent;
last_pass: Integer;
last_pct: Integer;
last_time: Integer;
last_scanline: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:48


GLScene v.1.1.2: GLSJPG: packed record jpeg_decompress_struct

packed record jpeg_decompress_struct

Unit

GLSJPG

Declaration

type jpeg_decompress_struct = packed record

Description

Overview

Fields

common: jpeg_common_struct;
src: jpeg_source_mgr_ptr;
image_width: JDIMENSION;
image_height: JDIMENSION;
num_components: Integer;
jpeg_color_space: J_COLOR_SPACE;
out_color_space: J_COLOR_SPACE;
scale_num: UINT32 ;
scale_denom: UINT32 ;
output_gamma: double;
buffered_image: LongBool;
raw_data_out: LongBool;
dct_method: J_DCT_METHOD;
do_fancy_upsampling: LongBool;
do_block_smoothing: LongBool;
quantize_colors: LongBool;
dither_mode: J_DITHER_MODE;
two_pass_quantize: LongBool;
desired_number_of_colors: Integer;
enable_1pass_quant: LongBool;
enable_external_quant: LongBool;
enable_2pass_quant: LongBool;
output_width: JDIMENSION;
output_height: JDIMENSION;
out_color_components: Integer;
output_components: Integer;
rec_outbuf_height: Integer;
actual_number_of_colors: Integer;
colormap: JSAMPARRAY;
output_scanline: JDIMENSION;
input_scan_number: Integer;
input_iMCU_row: JDIMENSION;
output_scan_number: Integer;
output_iMCU_row: Integer;
coef_bits: Pointer;
quant_tbl_ptrs: Array[0..NUM_QUANT_TBLS-1] of Pointer;
dc_huff_tbl_ptrs: Array[0..NUM_HUFF_TBLS-1] of Pointer;
ac_huff_tbl_ptrs: Array[0..NUM_HUFF_TBLS-1] of Pointer;
data_precision: Integer;
comp_info: jpeg_component_info_ptr;
progressive_mode: LongBool;
arith_code: LongBool;
arith_dc_L: Array[0..NUM_ARITH_TBLS-1] of UINT8;
arith_dc_U: Array[0..NUM_ARITH_TBLS-1] of UINT8;
arith_ac_K: Array[0..NUM_ARITH_TBLS-1] of UINT8;
restart_interval: UINT32;
saw_JFIF_marker: LongBool;
density_unit: UINT8;
X_density: UINT16;
Y_density: UINT16;
saw_Adobe_marker: LongBool;
Adobe_transform: UINT8;
CCIR601_sampling: LongBool;
max_h_samp_factor: Integer;
max_v_samp_factor: Integer;
min_DCT_scaled_size: Integer;
total_iMCU_rows: JDIMENSION;
sample_range_limit: Pointer;
comps_in_scan: Integer;
cur_comp_info: Array[0..MAX_COMPS_IN_SCAN - 1] of Pointer;
MCUs_per_row: JDIMENSION;
MCU_rows_in_scan: JDIMENSION;
blocks_in_MCU: JDIMENSION;
MCU_membership: Array[0..D_MAX_BLOCKS_IN_MCU - 1] of Integer;
Ss: Integer;
Se: Integer;
Ah: Integer;
Al: Integer;
unread_marker: Integer;
master: Pointer;
main: Pointer;
coef: Pointer;
post: Pointer;
inputctl: Pointer;
marker: Pointer;
entropy: Pointer;
idct: Pointer;
upsample: Pointer;
cconvert: Pointer;
cquantize: Pointer;

Description

Fields

common: jpeg_common_struct;
src: jpeg_source_mgr_ptr;
image_width: JDIMENSION;
image_height: JDIMENSION;
num_components: Integer;
jpeg_color_space: J_COLOR_SPACE;
out_color_space: J_COLOR_SPACE;
scale_num: UINT32 ;
scale_denom: UINT32 ;
output_gamma: double;
buffered_image: LongBool;
raw_data_out: LongBool;
dct_method: J_DCT_METHOD;
do_fancy_upsampling: LongBool;
do_block_smoothing: LongBool;
quantize_colors: LongBool;
dither_mode: J_DITHER_MODE;
two_pass_quantize: LongBool;
desired_number_of_colors: Integer;
enable_1pass_quant: LongBool;
enable_external_quant: LongBool;
enable_2pass_quant: LongBool;
output_width: JDIMENSION;
output_height: JDIMENSION;
out_color_components: Integer;
output_components: Integer;
rec_outbuf_height: Integer;
actual_number_of_colors: Integer;
colormap: JSAMPARRAY;
output_scanline: JDIMENSION;
input_scan_number: Integer;
input_iMCU_row: JDIMENSION;
output_scan_number: Integer;
output_iMCU_row: Integer;
coef_bits: Pointer;
quant_tbl_ptrs: Array[0..NUM_QUANT_TBLS-1] of Pointer;
dc_huff_tbl_ptrs: Array[0..NUM_HUFF_TBLS-1] of Pointer;
ac_huff_tbl_ptrs: Array[0..NUM_HUFF_TBLS-1] of Pointer;
data_precision: Integer;
comp_info: jpeg_component_info_ptr;
progressive_mode: LongBool;
arith_code: LongBool;
arith_dc_L: Array[0..NUM_ARITH_TBLS-1] of UINT8;
arith_dc_U: Array[0..NUM_ARITH_TBLS-1] of UINT8;
arith_ac_K: Array[0..NUM_ARITH_TBLS-1] of UINT8;
restart_interval: UINT32;
saw_JFIF_marker: LongBool;
density_unit: UINT8;
X_density: UINT16;
Y_density: UINT16;
saw_Adobe_marker: LongBool;
Adobe_transform: UINT8;
CCIR601_sampling: LongBool;
max_h_samp_factor: Integer;
max_v_samp_factor: Integer;
min_DCT_scaled_size: Integer;
total_iMCU_rows: JDIMENSION;
sample_range_limit: Pointer;
comps_in_scan: Integer;
cur_comp_info: Array[0..MAX_COMPS_IN_SCAN - 1] of Pointer;
MCUs_per_row: JDIMENSION;
MCU_rows_in_scan: JDIMENSION;
blocks_in_MCU: JDIMENSION;
MCU_membership: Array[0..D_MAX_BLOCKS_IN_MCU - 1] of Integer;
Ss: Integer;
Se: Integer;
Ah: Integer;
Al: Integer;
unread_marker: Integer;
master: Pointer;
main: Pointer;
coef: Pointer;
post: Pointer;
inputctl: Pointer;
marker: Pointer;
entropy: Pointer;
idct: Pointer;
upsample: Pointer;
cconvert: Pointer;
cquantize: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSJPG: record jpeg_destination_mgr

record jpeg_destination_mgr

Unit

GLSJPG

Declaration

type jpeg_destination_mgr = record

Description

Overview

Fields

next_output_byte: JOCTETptr;
free_in_buffer: Longint;
init_destination: procedure(cinfo : j_compress_ptr);
empty_output_buffer: function(cinfo : j_compress_ptr) : LongBool;
term_destination: procedure(cinfo : j_compress_ptr);

Description

Fields

next_output_byte: JOCTETptr;
free_in_buffer: Longint;
init_destination: procedure(cinfo : j_compress_ptr);
empty_output_buffer: function(cinfo : j_compress_ptr) : LongBool;
term_destination: procedure(cinfo : j_compress_ptr);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSJPG: packed record jpeg_compress_struct

packed record jpeg_compress_struct

Unit

GLSJPG

Declaration

type jpeg_compress_struct = packed record

Description

Overview

Fields

common: jpeg_common_struct;
dest: jpeg_destination_mgr_ptr;
image_width: JDIMENSION;
image_height: JDIMENSION;
input_components: Integer;
in_color_space: J_COLOR_SPACE;
input_gamma: double;
data_precision: Integer;
num_components: Integer;
jpeg_color_space: J_COLOR_SPACE;
comp_info: jpeg_component_info_ptr;
quant_tbl_ptrs: Array[0..NUM_QUANT_TBLS-1] of Pointer;
dc_huff_tbl_ptrs: Array[0..NUM_HUFF_TBLS-1] of Pointer;
ac_huff_tbl_ptrs: Array[0..NUM_HUFF_TBLS-1] of Pointer;
arith_dc_L: Array[0..NUM_ARITH_TBLS-1] of UINT8;
arith_dc_U: Array[0..NUM_ARITH_TBLS-1] of UINT8;
arith_ac_K: Array[0..NUM_ARITH_TBLS-1] of UINT8;
num_scans: Integer;
scan_info: Pointer;
raw_data_in: LongBool;
arith_code: LongBool;
optimize_coding: LongBool;
CCIR601_sampling: LongBool;
smoothing_factor: Integer;
dct_method: J_DCT_METHOD;
restart_interval: UINT32;
restart_in_rows: Integer;
write_JFIF_header: LongBool;
density_unit: UINT8;
X_density: UINT16;
Y_density: UINT16;
write_Adobe_marker: LongBool;
next_scanline: JDIMENSION;
progressive_mode: LongBool;
max_h_samp_factor: Integer;
max_v_samp_factor: Integer;
total_iMCU_rows: JDIMENSION;
comps_in_scan: Integer;
cur_comp_info: Array[0..MAX_COMPS_IN_SCAN - 1] of Pointer;
MCUs_per_row: JDIMENSION;
MCU_rows_in_scan: JDIMENSION;
blocks_in_MCU: Integer;
MCU_membership: Array[0..C_MAX_BLOCKS_IN_MCU - 1] of Integer;
Ss: Integer;
Se: Integer;
Ah: Integer;
Al: Integer;
master: Pointer;
main: Pointer;
prep: Pointer;
coef: Pointer;
marker: Pointer;
cconvert: Pointer;
downsample: Pointer;
fdct: Pointer;
entropy: Pointer;

Description

Fields

common: jpeg_common_struct;
dest: jpeg_destination_mgr_ptr;
image_width: JDIMENSION;
image_height: JDIMENSION;
input_components: Integer;
in_color_space: J_COLOR_SPACE;
input_gamma: double;
data_precision: Integer;
num_components: Integer;
jpeg_color_space: J_COLOR_SPACE;
comp_info: jpeg_component_info_ptr;
quant_tbl_ptrs: Array[0..NUM_QUANT_TBLS-1] of Pointer;
dc_huff_tbl_ptrs: Array[0..NUM_HUFF_TBLS-1] of Pointer;
ac_huff_tbl_ptrs: Array[0..NUM_HUFF_TBLS-1] of Pointer;
arith_dc_L: Array[0..NUM_ARITH_TBLS-1] of UINT8;
arith_dc_U: Array[0..NUM_ARITH_TBLS-1] of UINT8;
arith_ac_K: Array[0..NUM_ARITH_TBLS-1] of UINT8;
num_scans: Integer;
scan_info: Pointer;
raw_data_in: LongBool;
arith_code: LongBool;
optimize_coding: LongBool;
CCIR601_sampling: LongBool;
smoothing_factor: Integer;
dct_method: J_DCT_METHOD;
restart_interval: UINT32;
restart_in_rows: Integer;
write_JFIF_header: LongBool;
density_unit: UINT8;
X_density: UINT16;
Y_density: UINT16;
write_Adobe_marker: LongBool;
next_scanline: JDIMENSION;
progressive_mode: LongBool;
max_h_samp_factor: Integer;
max_v_samp_factor: Integer;
total_iMCU_rows: JDIMENSION;
comps_in_scan: Integer;
cur_comp_info: Array[0..MAX_COMPS_IN_SCAN - 1] of Pointer;
MCUs_per_row: JDIMENSION;
MCU_rows_in_scan: JDIMENSION;
blocks_in_MCU: Integer;
MCU_membership: Array[0..C_MAX_BLOCKS_IN_MCU - 1] of Integer;
Ss: Integer;
Se: Integer;
Ah: Integer;
Al: Integer;
master: Pointer;
main: Pointer;
prep: Pointer;
coef: Pointer;
marker: Pointer;
cconvert: Pointer;
downsample: Pointer;
fdct: Pointer;
entropy: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSJPG: record TJPEGContext

record TJPEGContext

Unit

GLSJPG

Declaration

type TJPEGContext = record

Description

Overview

Fields

err: jpeg_error_mgr;
progress: jpeg_progress_mgr;
FinalDCT: J_DCT_METHOD;
FinalTwoPassQuant: Boolean;
FinalDitherMode: J_DITHER_MODE;
common: jpeg_common_struct
d: jpeg_decompress_struct
c: jpeg_compress_struct

Description

Fields

err: jpeg_error_mgr;
progress: jpeg_progress_mgr;
FinalDCT: J_DCT_METHOD;
FinalTwoPassQuant: Boolean;
FinalDitherMode: J_DITHER_MODE;
common: jpeg_common_struct
d: jpeg_decompress_struct
c: jpeg_compress_struct
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSkyBox

Unit GLSkyBox

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSkyBox<p>

A TGLImmaterialSceneObject drawing 6 quads (plus another quad as "Cloud" plane) for use as a skybox always centered on the camera.<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>26/03/09 - DanB - Skybox is now a TGLCameraInvariantObject <li>10/10/08 - DanB - changed Skybox DoRender to use rci instead of Scene.CurrentGLCamera <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>21/01/07 - DaStr - Added IGLMaterialLibrarySupported support <li>12/04/04 - EG - Added Style property, multipass support <li>27/11/03 - EG - Cleanup and fixes <li>09/11/03 - MRQZZZ - mandatory changes suggested by Eric. <li>02/09/03 - MRQZZZ - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSkyBox |

Types

TGLSkyBoxStyle = (...);

Description

Types

TGLSkyBoxStyle = (...);
Values
  • sbsFull:
  • sbsTopHalf:
  • sbsBottomHalf:
  • sbTopTwoThirds:
  • sbsTopHalfClamped:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSkyBox: Class TGLSkyBox

Class TGLSkyBox

Unit

GLSkyBox

Declaration

type TGLSkyBox = class(TGLCameraInvariantObject, IGLMaterialLibrarySupported)

Description

no description available, TGLCameraInvariantObject description follows

Base class for camera invariant objects.<p> Camera invariant objects bypass camera settings, such as camera position (object is always centered on camera) or camera orientation (object always has same orientation as camera).

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLCameraInvariantObject
  • TGLSkyBox

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var ARci: TRenderCOntextInfo); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetCloudsPlaneOffset(const Value: single);
Protected | procedure SetCloudsPlaneSize(const Value: single);
Protected | procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);
Protected | procedure SetMatNameBack(const Value: string);
Protected | procedure SetMatNameBottom(const Value: string);
Protected | procedure SetMatNameClouds(const Value: string);
Protected | procedure SetMatNameFront(const Value: string);
Protected | procedure SetMatNameLeft(const Value: string);
Protected | procedure SetMatNameRight(const Value: string);
Protected | procedure SetMatNameTop(const Value: string);
Protected | procedure SetStyle(const value: TGLSkyBoxStyle);

Properties

Published | property CloudsPlaneOffset: Single read FCloudsPlaneOffset write SetCloudsPlaneOffset;
Published | property CloudsPlaneSize: Single read FCloudsPlaneSize write SetCloudsPlaneSize;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MatNameBack: TGLLibMaterialName read FMatNameBack write SetMatNameBack;
Published | property MatNameBottom: TGLLibMaterialName read FMatNameBottom write SetMatNameBottom;
Published | property MatNameClouds: TGLLibMaterialName read FMatNameClouds write SetMatNameClouds;
Published | property MatNameFront: TGLLibMaterialName read FMatNameFront write SetMatNameFront;
Published | property MatNameLeft: TGLLibMaterialName read FMatNameLeft write SetMatNameLeft;
Published | property MatNameRight: TGLLibMaterialName read FMatNameRight write SetMatNameRight;
Published | property MatNameTop: TGLLibMaterialName read FMatNameTop write SetMatNameTop;
Published | property Style: TGLSkyBoxStyle read FStyle write FStyle default sbsFull;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure BuildList(var ARci: TRenderCOntextInfo); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetCloudsPlaneOffset(const Value: single);
Protected procedure SetCloudsPlaneSize(const Value: single);
Protected procedure SetMaterialLibrary(const Value: TGLMaterialLibrary);
Protected procedure SetMatNameBack(const Value: string);
Protected procedure SetMatNameBottom(const Value: string);
Protected procedure SetMatNameClouds(const Value: string);
Protected procedure SetMatNameFront(const Value: string);
Protected procedure SetMatNameLeft(const Value: string);
Protected procedure SetMatNameRight(const Value: string);
Protected procedure SetMatNameTop(const Value: string);
Protected procedure SetStyle(const value: TGLSkyBoxStyle);

Properties

Published property CloudsPlaneOffset: Single read FCloudsPlaneOffset write SetCloudsPlaneOffset;
Published property CloudsPlaneSize: Single read FCloudsPlaneSize write SetCloudsPlaneSize;
Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published property MatNameBack: TGLLibMaterialName read FMatNameBack write SetMatNameBack;
Published property MatNameBottom: TGLLibMaterialName read FMatNameBottom write SetMatNameBottom;
Published property MatNameClouds: TGLLibMaterialName read FMatNameClouds write SetMatNameClouds;
Published property MatNameFront: TGLLibMaterialName read FMatNameFront write SetMatNameFront;
Published property MatNameLeft: TGLLibMaterialName read FMatNameLeft write SetMatNameLeft;
Published property MatNameRight: TGLLibMaterialName read FMatNameRight write SetMatNameRight;
Published property MatNameTop: TGLLibMaterialName read FMatNameTop write SetMatNameTop;
Published property Style: TGLSkyBoxStyle read FStyle write FStyle default sbsFull;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSkydome

Unit GLSkydome

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSkydome<p>

Skydome object<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>24/03/11 - Yar - Added esoDepthTest to TEarthSkydomeOption (Drawing sky dome latest with depth test reduce pixels overdraw) <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>10/10/08 - DanB - changed Skydome buildlists to use rci instead of Scene.CurrentGLCamera <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>30/03/07 - DaStr - Moved all UNSAFE_TYPE, UNSAFE_CODE checks to GLSCene.inc <li>25/03/07 - DaStr - Fixed compiler directives for Delphi5 compatibility <li>22/03/07 - DaStr - Removed "unsafe type/unsafe code" warnings <li>19/12/06 - DaStr - TSkyDomeStars.AddRandomStars() overloaded <li>29/06/06 - PvD - Fixed small bug to properly deal with polygon fill <li>20/01/05 - Mathx - Added the ExtendedOptions of the EarthSkyDome <li>02/08/04 - LR, YHC - BCB corrections: use record instead array <li>09/01/04 - EG - Now based on TGLCameraInvariantObject <li>04/08/03 - SG - Fixed small bug with random star creation <li>17/06/03 - EG - Fixed PolygonMode (Carlos Ferreira) <li>26/02/02 - EG - Enhanced star support (generation and twinkle), Skydome now 'exports' its coordinate system to children <li>21/01/02 - EG - Skydome position now properly ignored <li>23/09/01 - EG - Fixed and improved TGLEarthSkyDome <li>26/08/01 - EG - Added SkyDomeStars <li>12/08/01 - EG - DepthMask no set to False during rendering <li>18/07/01 - EG - VisibilityCulling compatibility changes <li>12/03/01 - EG - Reversed polar caps orientation <li>28/01/01 - EG - Fixed TSkyDomeBand rendering (vertex coordinates) <li>18/01/01 - EG - First working version of TGLEarthSkyDome <li>14/01/01 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TSkyDomeBand |
Class TSkyDomeBands |
Class TSkyDomeStar |
Class TSkyDomeStars |
Class TGLSkyDome |
Class TGLEarthSkyDome |

Types

TSkyDomeOption = (...);
TSkyDomeOptions = set of TSkyDomeOption;
TEarthSkydomeOption = (...);
TEarthSkydomeOptions = set of TEarthSkydomeOption;

Description

Types

TSkyDomeOption = (...);
Values
  • sdoTwinkle:
TSkyDomeOptions = set of TSkyDomeOption;
TEarthSkydomeOption = (...);
Values
  • esoFadeStarsWithSun:
  • esoRotateOnTwelveHours:
  • esoDepthTest:
TEarthSkydomeOptions = set of TEarthSkydomeOption;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSkydome: Class TSkyDomeBand

Class TSkyDomeBand

Unit

GLSkydome

Declaration

type TSkyDomeBand = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TSkyDomeBand

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo);
Protected | procedure OnColorChange(sender: TObject);
Protected | procedure SetSlices(const val: Integer);
Protected | procedure SetStacks(const val: Integer);
Protected | procedure SetStartAngle(const val: Single);
Protected | procedure SetStartColor(const val: TGLColor);
Protected | procedure SetStopAngle(const val: Single);
Protected | procedure SetStopColor(const val: TGLColor);

Properties

Published | property Slices: Integer read FSlices write SetSlices default 12;
Published | property Stacks: Integer read FStacks write SetStacks default 1;
Published | property StartAngle: Single read FStartAngle write SetStartAngle;
Published | property StartColor: TGLColor read FStartColor write SetStartColor;
Published | property StopAngle: Single read FStopAngle write SetStopAngle;
Published | property StopColor: TGLColor read FStopColor write SetStopColor;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo);
Protected procedure OnColorChange(sender: TObject);
Protected procedure SetSlices(const val: Integer);
Protected procedure SetStacks(const val: Integer);
Protected procedure SetStartAngle(const val: Single);
Protected procedure SetStartColor(const val: TGLColor);
Protected procedure SetStopAngle(const val: Single);
Protected procedure SetStopColor(const val: TGLColor);

Properties

Published property Slices: Integer read FSlices write SetSlices default 12;
Published property Stacks: Integer read FStacks write SetStacks default 1;
Published property StartAngle: Single read FStartAngle write SetStartAngle;
Published property StartColor: TGLColor read FStartColor write SetStartColor;
Published property StopAngle: Single read FStopAngle write SetStopAngle;
Published property StopColor: TGLColor read FStopColor write SetStopColor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSkydome: Class TSkyDomeBands

Class TSkyDomeBands

Unit

GLSkydome

Declaration

type TSkyDomeBands = class(TCollection)

Description

Hierarchy

  • TCollection
  • TSkyDomeBands

Overview

Fields

Protected owner: TComponent;

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TSkyDomeBand;
Public | function FindItemID(ID: Integer): TSkyDomeBand;
Protected | function GetItems(index: Integer): TSkyDomeBand;
Protected | function GetOwner: TPersistent; override;
Public | procedure BuildList(var rci: TRenderContextInfo);
Public | procedure NotifyChange;
Protected | procedure SetItems(index: Integer; const val: TSkyDomeBand);

Properties

Public property Items[index: Integer]: TSkyDomeBand read GetItems write SetItems;

Description

Fields

Protected owner: TComponent;

Methods

Public constructor Create(AOwner: TComponent);
Public function Add: TSkyDomeBand;
Public function FindItemID(ID: Integer): TSkyDomeBand;
Protected function GetItems(index: Integer): TSkyDomeBand;
Protected function GetOwner: TPersistent; override;
Public procedure BuildList(var rci: TRenderContextInfo);
Public procedure NotifyChange;
Protected procedure SetItems(index: Integer; const val: TSkyDomeBand);

Properties

Public property Items[index: Integer]: TSkyDomeBand read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSkydome: Class TSkyDomeStar

Class TSkyDomeStar

Unit

GLSkydome

Declaration

type TSkyDomeStar = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TSkyDomeStar

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Color: TColor read FColor write FColor;
Published | property Dec: Single read FDec write FDec;
Published | property Magnitude: Single read FMagnitude write FMagnitude;
Published | property RA: Single read FRA write FRA;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;

Properties

Published property Color: TColor read FColor write FColor;

Color of the star.

Published property Dec: Single read FDec write FDec;

Declination, in degrees.

Published property Magnitude: Single read FMagnitude write FMagnitude;

Absolute magnitude.

Published property RA: Single read FRA write FRA;

Right Ascension, in degrees.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSkydome: Class TSkyDomeStars

Class TSkyDomeStars

Unit

GLSkydome

Declaration

type TSkyDomeStars = class(TCollection)

Description

Hierarchy

  • TCollection
  • TSkyDomeStars

Overview

Fields

Protected owner: TComponent;

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TSkyDomeStar;
Public | function FindItemID(ID: Integer): TSkyDomeStar;
Protected | function GetItems(index: Integer): TSkyDomeStar;
Protected | function GetOwner: TPersistent; override;
Public | procedure AddRandomStars(const nb: Integer; const color: TColor; const limitToTopDome: Boolean = False); overload;
Public | procedure AddRandomStars(const nb: Integer; const ColorMin, ColorMax: TVector3b; const Magnitude_min, Magnitude_max: Single; const limitToTopDome: Boolean = False); overload;
Public | procedure BuildList(var rci: TRenderContextInfo; twinkle: Boolean);
Public | procedure LoadStarsFile(const starsFileName: string);
Protected | procedure PrecomputeCartesianCoordinates;
Protected | procedure SetItems(index: Integer; const val: TSkyDomeStar);

Properties

Public property Items[index: Integer]: TSkyDomeStar read GetItems write SetItems;

Description

Fields

Protected owner: TComponent;

Methods

Public constructor Create(AOwner: TComponent);
Public function Add: TSkyDomeStar;
Public function FindItemID(ID: Integer): TSkyDomeStar;
Protected function GetItems(index: Integer): TSkyDomeStar;
Protected function GetOwner: TPersistent; override;
Public procedure AddRandomStars(const nb: Integer; const color: TColor; const limitToTopDome: Boolean = False); overload;

Adds nb random stars of the given color.<p> Stars are homogenously scattered on the complete sphere, not only the band defined or visible dome.

Public procedure AddRandomStars(const nb: Integer; const ColorMin, ColorMax: TVector3b; const Magnitude_min, Magnitude_max: Single; const limitToTopDome: Boolean = False); overload;
Public procedure BuildList(var rci: TRenderContextInfo; twinkle: Boolean);
Public procedure LoadStarsFile(const starsFileName: string);

Load a 'stars' file, which is made of TGLStarRecord.<p> Not that '.stars' files should already be sorted by magnitude and color.

Protected procedure PrecomputeCartesianCoordinates;
Protected procedure SetItems(index: Integer; const val: TSkyDomeStar);

Properties

Public property Items[index: Integer]: TSkyDomeStar read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSkydome: Class TGLSkyDome

Class TGLSkyDome

Unit

GLSkydome

Declaration

type TGLSkyDome = class(TGLCameraInvariantObject)

Description

Renders a sky dome always centered on the camera.<p> If you use this object make sure it is rendered *first*, as it ignores depth buffering and overwrites everything. All children of a skydome are rendered in the skydome's coordinate system.<p> The skydome is described by "bands", each "band" is an horizontal cut of a sphere, and you can have as many bands as you wish.<p> Estimated CPU cost (K7-500, GeForce SDR, default bands):<ul> <li>800x600 fullscreen filled: 4.5 ms (220 FPS, worst case) <li>Geometry cost (0% fill): 0.7 ms (1300 FPS, best case) </ul>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLCameraInvariantObject
  • TGLSkyDome

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure SetBands(const val: TSkyDomeBands);
Protected | procedure SetOptions(const val: TSkyDomeOptions);
Protected | procedure SetStars(const val: TSkyDomeStars);

Properties

Published | property Bands: TSkyDomeBands read FBands write SetBands;
Published | property Options: TSkyDomeOptions read FOptions write SetOptions default [];
Published | property Stars: TSkyDomeStars read FStars write SetStars;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure SetBands(const val: TSkyDomeBands);
Protected procedure SetOptions(const val: TSkyDomeOptions);
Protected procedure SetStars(const val: TSkyDomeStars);

Properties

Published property Bands: TSkyDomeBands read FBands write SetBands;
Published property Options: TSkyDomeOptions read FOptions write SetOptions default [];
Published property Stars: TSkyDomeStars read FStars write SetStars;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSkydome: Class TGLEarthSkyDome

Class TGLEarthSkyDome

Unit

GLSkydome

Declaration

type TGLEarthSkyDome = class(TGLSkyDome)

Description

Render a skydome like what can be seen on earth.<p> Color is based on sun position and turbidity, to "mimic" atmospheric Rayleigh and Mie scatterings. The colors can be adjusted to render weird/extra-terrestrial atmospheres too.<p> The default slices/stacks values make for an average quality rendering, for a very clean rendering, use 64/64 (more is overkill in most cases). The complexity is quite high though, making a T&L 3D board a necessity for using TGLEarthSkyDome.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLCameraInvariantObject
  • TGLSkyDome
  • TGLEarthSkyDome

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function CalculateColor(const theta, cosGamma: Single): TColorVector;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure Loaded; override;
Protected | procedure OnColorChanged(Sender: TObject);
Protected | procedure PreCalculate;
Protected | procedure RenderDome;
Protected | procedure SetDeepColor(const val: TGLColor);
Protected | procedure SetHazeColor(const val: TGLColor);
Protected | procedure SetNightColor(const val: TGLColor);
Protected | procedure SetSkyColor(const val: TGLColor);
Protected | procedure SetSlices(const val: Integer);
Protected | procedure SetStacks(const val: Integer);
Protected | procedure SetSunDawnColor(const val: TGLColor);
Protected | procedure SetSunElevation(const val: Single);
Protected | procedure SetSunZenithColor(const val: TGLColor);
Protected | procedure SetTurbidity(const val: Single);

Properties

Published | property DeepColor: TGLColor read FDeepColor write SetDeepColor;
Published | property ExtendedOptions: TEarthSkydomeOptions read FExtendedOptions write FExtendedOptions;
Published | property HazeColor: TGLColor read FHazeColor write SetHazeColor;
Published | property NightColor: TGLColor read FNightColor write SetNightColor;
Published | property SkyColor: TGLColor read FSkyColor write SetSkyColor;
Published | property Slices: Integer read FSlices write SetSlices default 24;
Published | property Stacks: Integer read FStacks write SetStacks default 48;
Published | property SunDawnColor: TGLColor read FSunDawnColor write SetSunDawnColor;
Published | property SunElevation: Single read FSunElevation write SetSunElevation;
Published | property SunZenithColor: TGLColor read FSunZenithColor write SetSunZenithColor;
Published | property Turbidity: Single read FTurbidity write SetTurbidity;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function CalculateColor(const theta, cosGamma: Single): TColorVector;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure Loaded; override;
Protected procedure OnColorChanged(Sender: TObject);
Protected procedure PreCalculate;
Protected procedure RenderDome;
Protected procedure SetDeepColor(const val: TGLColor);
Protected procedure SetHazeColor(const val: TGLColor);
Protected procedure SetNightColor(const val: TGLColor);
Protected procedure SetSkyColor(const val: TGLColor);
Protected procedure SetSlices(const val: Integer);
Protected procedure SetStacks(const val: Integer);
Protected procedure SetSunDawnColor(const val: TGLColor);
Protected procedure SetSunElevation(const val: Single);
Protected procedure SetSunZenithColor(const val: TGLColor);
Protected procedure SetTurbidity(const val: Single);

Properties

Published property DeepColor: TGLColor read FDeepColor write SetDeepColor;
Published property ExtendedOptions: TEarthSkydomeOptions read FExtendedOptions write FExtendedOptions;
Published property HazeColor: TGLColor read FHazeColor write SetHazeColor;
Published property NightColor: TGLColor read FNightColor write SetNightColor;
Published property SkyColor: TGLColor read FSkyColor write SetSkyColor;
Published property Slices: Integer read FSlices write SetSlices default 24;
Published property Stacks: Integer read FStacks write SetStacks default 48;
Published property SunDawnColor: TGLColor read FSunDawnColor write SetSunDawnColor;
Published property SunElevation: Single read FSunElevation write SetSunElevation;

Elevation of the sun, measured in degrees.

Published property SunZenithColor: TGLColor read FSunZenithColor write SetSunZenithColor;
Published property Turbidity: Single read FTurbidity write SetTurbidity;

Expresses the purity of air.<p> Value range is from 1 (pure athmosphere) to 120 (very nebulous)

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSLanguage

Unit GLSLanguage

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Eng Language created to localize your application. In Delphi, the text is encoded using Ansi cp1251 and can not be encoded \ decoding. In Lazarus has the ability to upload text from any encoding. Ru TLanguage ñîçäàí äëÿ ëîêàëèçàöèè âàøåãî ïðèëîæåíèÿ. Â Äåëôè òåêñò èìååò êîäèðîâêó Ansi cp1251 è íå ïîäëåæûò êîäèðîâêå\äåêîäèðîâêå. Â Ëàçàðóñå èìååòñÿ âîçìîæíîñòü çàãðóæàòü òåêñò èç ëþáîé êîäèðîâêè.

<b>History : </b><font size=-1><ul> <li>04/11/10 - DaStr - Added Delphi5 and Delphi6 compatibility <li>20/04/10 - Yar - Added to GLScene (Created by Rustam Asmandiarov aka Predator) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TLanguageEntry |
Class TLanguage |
Class TLanguageExt |
Class TGLSLanguage |

Types

TConvertEncodingList = (...);
TLanguageEntryArray = array of TLanguageEntry;

Description

Types

TConvertEncodingList = (...);
Values
  • celAutomatic:
  • celISO_8859_1ToUTF8:
  • celISO_8859_2ToUTF8:
  • celCP1250ToUTF8:
  • celCP1251ToUTF8:
  • celCP1252ToUTF8:
  • celCP1253ToUTF8:
  • celCP1254ToUTF8:
  • celCP1255ToUTF8:
  • celCP1256ToUTF8:
  • celCP1257ToUTF8:
  • celCP1258ToUTF8:
  • celCP437ToUTF8:
  • celCP850ToUTF8:
  • celCP866ToUTF8:
  • celCP874ToUTF8:
  • celKOI8ToUTF8:
  • celUCS2LEToUTF8:
  • celUCS2BEToUTF8:
TLanguageEntryArray = array of TLanguageEntry;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSLanguage: record TLanguageEntry

record TLanguageEntry

Unit

GLSLanguage

Declaration

type TLanguageEntry = record

Description

Overview

Fields

ID: AnsiString;
Text: UTF8String;

Description

Fields

ID: AnsiString;
Text: UTF8String;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSLanguage: Class TLanguage

Class TLanguage

Unit

GLSLanguage

Declaration

type TLanguage = class(TObject)

Description

Hierarchy

  • TObject
  • TLanguage

Overview

Methods

Public | function FindID(const ID: AnsiString): integer;
Public | function Translate(const ID: AnsiString): UTF8String;
Public | procedure LoadLanguageFromFile(const Language: UTF8String);

Properties

Public | property ConvertEncodingList: TConvertEncodingList read FConvertEncodingList write FConvertEncodingList default celAutomatic;
Public | property CurrentLanguageFile: UTF8String read FCurrentLanguageFile;

Description

Methods

Public function FindID(const ID: AnsiString): integer;
Public function Translate(const ID: AnsiString): UTF8String;
Public procedure LoadLanguageFromFile(const Language: UTF8String);

Properties

Public property ConvertEncodingList: TConvertEncodingList read FConvertEncodingList write FConvertEncodingList default celAutomatic;
Public property CurrentLanguageFile: UTF8String read FCurrentLanguageFile;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSLanguage: Class TLanguageExt

Class TLanguageExt

Unit

GLSLanguage

Declaration

type TLanguageExt = class(TLanguage)

Description

no description available, TLanguage description follows

Hierarchy

  • TObject
  • TLanguage
  • TLanguageExt

Overview

Methods

Public | procedure AddConst(const ID: AnsiString; const Text: UTF8String);
Public | procedure AddConsts(aValues: TStrings);
Public | procedure ChangeConst(const ID: AnsiString; const Text: UTF8String);
Public | procedure SaveLanguageFromFile; overload;
Public | procedure SaveLanguageFromFile(const Language: UTF8String); overload;

Properties

Public | property Count: Integer read GetCount;
Public | property Items[Index: Integer]: TLanguageEntry read GetEntry write SetEntry;

Description

Methods

Public procedure AddConst(const ID: AnsiString; const Text: UTF8String);
Public procedure AddConsts(aValues: TStrings);
Public procedure ChangeConst(const ID: AnsiString; const Text: UTF8String);
Public procedure SaveLanguageFromFile; overload;
Public procedure SaveLanguageFromFile(const Language: UTF8String); overload;

Properties

Public property Count: Integer read GetCount;
Public property Items[Index: Integer]: TLanguageEntry read GetEntry write SetEntry;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSLanguage: Class TGLSLanguage

Class TGLSLanguage

Unit

GLSLanguage

Declaration

type TGLSLanguage = class(TComponent)

Description

Àáñòðàêòíûé êëàññ, äëÿ ïàëèòðû êîìïîíåíòîâ<p>

Hierarchy

  • TComponent
  • TGLSLanguage

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Translate(const ID: AnsiString): UTF8String;
Public | procedure LoadLanguageFromFile(const Language: UTF8String);
Public | procedure SaveLanguageFromFile; overload;
Public | procedure SaveLanguageFromFile(const Language: UTF8String); overload;

Properties

Published | property ConvertEncodingList: TConvertEncodingList read GetEncodingList write SetEncodingList;
Public | property Language: TLanguageExt read FLanguage write SetLanguage;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function Translate(const ID: AnsiString): UTF8String;
Public procedure LoadLanguageFromFile(const Language: UTF8String);
Public procedure SaveLanguageFromFile; overload;
Public procedure SaveLanguageFromFile(const Language: UTF8String); overload;

Properties

Published property ConvertEncodingList: TConvertEncodingList read GetEncodingList write SetEncodingList;
Public property Language: TLanguageExt read FLanguage write SetLanguage;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSLBumpShader

Unit GLSLBumpShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSLBumpShader<p>

A GLSL shader that applies bump mapping.<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>20/10/10 - Yar - Bugfixed memory leak <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>07/01/10 - DaStr - Bugfixed all DoInitialize() calls (thanks YarUnderoaker) <li>24/07/09 - DaStr - TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) Fixed a bug with "fRDotV" clamping, which occured on all GeForce 8x and later graphic cards <li>20/03/07 - DaStr - Made changes related to the new parameter passing model <li>06/03/07 - DaStr - Again replaced DecimalSeparator stuff with a single Str procedure (thanks Uwe Raabe) <li>03/03/07 - DaStr - Made compatible with Delphi6 <li>22/02/07 - DaStr - Initial version (contributed to GLScene)

This is a collection of GLSL Bump shaders, comes in these variaties (to know what these abriviations mean, see GLCustomShader.pas):

- TGLSLBumpShader - TGLSLBumpShaderMT - TGLSLBumpShaderAM

- TGLSLMLBumpShader - TGLSLMLBumpShaderMT

Notes: 1) Alpha is a synthetic property, in real life your should set each color's Alpha individualy 2) TGLSLMLBumpShader takes all Light parameters directly from OpenGL (that includes TGLLightSource's)

TODO: 1) Implement IGLShaderDescription in all shaders.

Previous version history: v1.0 03 September '2006 Creation v1.1 09 September '2006 Camera Positioning bugfix Artefacts on the non-lit side removed v1.2 16 September '2006 Shader made ATI-compatible v1.2.2 02 November '2006 Small optimization if Do(Un)Apply v1.3 27 November '2006 TGLCustomGLSLMLBumpShaderMT added v1.3.2 30 November '2006 LightCompensation added gl_FragColor() calculation optimized a bit v1.4 16 December '2006 All Shaders renamed according to the new naming convention SCS_SHADER_NEEDS_AT_LEAST_ONE_LIGHT_SOURCE moved to GLCustomShader TGLBaseCustomGLSLBumpShader, TGLBaseMatlibGLSLBumpShader(MT) abstracted 7 diferent versions of this shader added All shaders made design-time compatible v1.4.2 18 December '2006 MultiLight versions of this shader bugfixed (the specular light was sometimes "cut") The use of SpecularMap made optional v1.4.6 20 December '2006 TGLBaseMatlibGLSLBumpShader and TGLBaseCustomGLSLBumpShader merged The use of NormalMap is optional MultiLight shaders optimized a bit v1.4.8 06 February '2007 IGLMaterialLibrarySupported renamed to IGLMaterialLibrarySupported v1.5 16 February '2007 Updated to the latest CVS version of GLscene v1.5.2 18 February '2007 Removed the StrangeTextureUtilities dependancy

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLSLBumpShaderException |
Class TGLBaseCustomGLSLBumpShader |
Class TGLBaseCustomGLSLBumpShaderMT |
Class TGLCustomGLSLBumpShaderAM |
Class TGLCustomGLSLBumpShaderMT |
Class TGLCustomGLSLBumpShader |
Class TGLCustomGLSLMLBumpShader |
Class TGLCustomGLSLMLBumpShaderMT |
Class TGLSLBumpShaderMT |
Class TGLSLBumpShader |
Class TGLSLBumpShaderAM |
Class TGLSLMLBumpShader |
Class TGLSLMLBumpShaderMT |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSLBumpShader: Class EGLSLBumpShaderException

Class EGLSLBumpShaderException

Unit

GLSLBumpShader

Declaration

type EGLSLBumpShaderException = class(EGLSLShaderException)

Description

no description available, EGLSLShaderException description follows
no description available, EGLCustomShaderException description follows
no description available, EGLShaderException description follows

Hierarchy

  • Exception
  • EGLShaderException
  • EGLCustomShaderException
  • EGLSLShaderException
  • EGLSLBumpShaderException
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSLBumpShader: Class TGLBaseCustomGLSLBumpShader

Class TGLBaseCustomGLSLBumpShader

Unit

GLSLBumpShader

Declaration

type TGLBaseCustomGLSLBumpShader = class(TGLCustomGLSLShader, IGLMaterialLibrarySupported)

Description

no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Protected | function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected | procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetMaterialLibrary(const Value: TGLMaterialLibrary); virtual;

Properties

Public | property BumpHeight: Single read FBumpHeight write FBumpHeight;
Public | property BumpSmoothness: Integer read FBumpSmoothness write FBumpSmoothness;
Public | property LightPower: Single read FLightPower write FLightPower;
Public | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public | property NormalTexture: TGLTexture read FNormalTexture write SetNormalTexture;
Public | property NormalTextureName: TGLLibMaterialName read GetNormalTextureName write SetNormalTextureName;
Public | property SpecularPower: Single read FSpecularPower write FSpecularPower;
Public | property SpecularSpread: Single read FSpecularSpread write FSpecularSpread;
Public | property SpecularTexture: TGLTexture read FSpecularTexture write SetSpecularTexture;
Public | property SpecularTextureName: TGLLibMaterialName read GetSpecularTextureName write SetSpecularTextureName;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Protected function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetMaterialLibrary(const Value: TGLMaterialLibrary); virtual;

Properties

Public property BumpHeight: Single read FBumpHeight write FBumpHeight;
Public property BumpSmoothness: Integer read FBumpSmoothness write FBumpSmoothness;
Public property LightPower: Single read FLightPower write FLightPower;
Public property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public property NormalTexture: TGLTexture read FNormalTexture write SetNormalTexture;
Public property NormalTextureName: TGLLibMaterialName read GetNormalTextureName write SetNormalTextureName;
Public property SpecularPower: Single read FSpecularPower write FSpecularPower;
Public property SpecularSpread: Single read FSpecularSpread write FSpecularSpread;
Public property SpecularTexture: TGLTexture read FSpecularTexture write SetSpecularTexture;
Public property SpecularTextureName: TGLLibMaterialName read GetSpecularTextureName write SetSpecularTextureName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:49


GLScene v.1.1.2: GLSLBumpShader: Class TGLBaseCustomGLSLBumpShaderMT

Class TGLBaseCustomGLSLBumpShaderMT

Unit

GLSLBumpShader

Declaration

type TGLBaseCustomGLSLBumpShaderMT = class(TGLBaseCustomGLSLBumpShader)

Description

no description available, TGLBaseCustomGLSLBumpShader description follows
no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLBaseCustomGLSLBumpShaderMT

Overview

Methods

Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetMaterialLibrary(const Value: TGLMaterialLibrary); override;

Properties

Public | property MainTexture: TGLTexture read FMainTexture write FMainTexture;
Public | property MainTextureName: TGLLibMaterialName read GetMainTextureName write SetMainTextureName;

Description

Methods

Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetMaterialLibrary(const Value: TGLMaterialLibrary); override;

Properties

Public property MainTexture: TGLTexture read FMainTexture write FMainTexture;
Public property MainTextureName: TGLLibMaterialName read GetMainTextureName write SetMainTextureName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLBumpShader: Class TGLCustomGLSLBumpShaderAM

Class TGLCustomGLSLBumpShaderAM

Unit

GLSLBumpShader

Declaration

type TGLCustomGLSLBumpShaderAM = class(TGLBaseCustomGLSLBumpShaderMT)

Description

no description available, TGLBaseCustomGLSLBumpShaderMT description follows
no description available, TGLBaseCustomGLSLBumpShader description follows
no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLBaseCustomGLSLBumpShaderMT
  • TGLCustomGLSLBumpShaderAM

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Protected | procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;

Properties

Public | property Alpha: Single read GetAlpha write SetAlpha;
Public | property AmbientColor: TGLColor read FAmbientColor;
Public | property DiffuseColor: TGLColor read FDiffuseColor;
Public | property SpecularColor: TGLColor read FSpecularColor;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Protected procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;

Properties

Public property Alpha: Single read GetAlpha write SetAlpha;
Public property AmbientColor: TGLColor read FAmbientColor;
Public property DiffuseColor: TGLColor read FDiffuseColor;
Public property SpecularColor: TGLColor read FSpecularColor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLBumpShader: Class TGLCustomGLSLBumpShaderMT

Class TGLCustomGLSLBumpShaderMT

Unit

GLSLBumpShader

Declaration

type TGLCustomGLSLBumpShaderMT = class(TGLBaseCustomGLSLBumpShaderMT)

Description

no description available, TGLBaseCustomGLSLBumpShaderMT description follows
no description available, TGLBaseCustomGLSLBumpShader description follows
no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLBaseCustomGLSLBumpShaderMT
  • TGLCustomGLSLBumpShaderMT

Overview

Methods

Protected | procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;

Description

Methods

Protected procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLBumpShader: Class TGLCustomGLSLBumpShader

Class TGLCustomGLSLBumpShader

Unit

GLSLBumpShader

Declaration

type TGLCustomGLSLBumpShader = class(TGLBaseCustomGLSLBumpShader, IGLShaderDescription)

Description

no description available, TGLBaseCustomGLSLBumpShader description follows
no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLCustomGLSLBumpShader

Overview

Methods

Protected | procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;

Description

Methods

Protected procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLBumpShader: Class TGLCustomGLSLMLBumpShader

Class TGLCustomGLSLMLBumpShader

Unit

GLSLBumpShader

Declaration

type TGLCustomGLSLMLBumpShader = class(TGLBaseCustomGLSLBumpShader, IGLShaderDescription)

Description

no description available, TGLBaseCustomGLSLBumpShader description follows
no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLCustomGLSLMLBumpShader

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Protected | procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;

Properties

Public | property LightCompensation: Single read FLightCompensation write SetLightCompensation;
Public | property LightSources: TGLLightSourceSet read FLightSources write SetLightSources default [1];

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Protected procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;

Properties

Public property LightCompensation: Single read FLightCompensation write SetLightCompensation;

Setting LightCompensation to a value less than 1 decreeses individual light intensity when using multiple lights

Public property LightSources: TGLLightSourceSet read FLightSources write SetLightSources default [1];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLBumpShader: Class TGLCustomGLSLMLBumpShaderMT

Class TGLCustomGLSLMLBumpShaderMT

Unit

GLSLBumpShader

Declaration

type TGLCustomGLSLMLBumpShaderMT = class(TGLBaseCustomGLSLBumpShaderMT)

Description

no description available, TGLBaseCustomGLSLBumpShaderMT description follows
no description available, TGLBaseCustomGLSLBumpShader description follows
no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLBaseCustomGLSLBumpShaderMT
  • TGLCustomGLSLMLBumpShaderMT

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Protected | procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;

Properties

Public | property LightCompensation: Single read FLightCompensation write SetLightCompensation;
Public | property LightSources: TGLLightSourceSet read FLightSources write SetLightSources default [1];

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Protected procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure DoInitialize(var rci : TRenderContextInfo; Sender : TObject); override;

Properties

Public property LightCompensation: Single read FLightCompensation write SetLightCompensation;

Setting LightCompensation to a value less than 1 decreeses individual light intensity when using multiple lights

Public property LightSources: TGLLightSourceSet read FLightSources write SetLightSources default [1];
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLBumpShader: Class TGLSLBumpShaderMT

Class TGLSLBumpShaderMT

Unit

GLSLBumpShader

Declaration

type TGLSLBumpShaderMT = class(TGLCustomGLSLBumpShaderMT)

Description

no description available, TGLCustomGLSLBumpShaderMT description follows
no description available, TGLBaseCustomGLSLBumpShaderMT description follows
no description available, TGLBaseCustomGLSLBumpShader description follows
no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLBaseCustomGLSLBumpShaderMT
  • TGLCustomGLSLBumpShaderMT
  • TGLSLBumpShaderMT

Overview

Properties

Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property LightPower;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property BumpHeight;
Published property BumpSmoothness;
Published property LightPower;
Published property MainTextureName;
Published property MaterialLibrary;
Published property NormalTextureName;
Published property SpecularPower;
Published property SpecularSpread;
Published property SpecularTextureName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLBumpShader: Class TGLSLBumpShader

Class TGLSLBumpShader

Unit

GLSLBumpShader

Declaration

type TGLSLBumpShader = class(TGLCustomGLSLBumpShader)

Description

no description available, TGLCustomGLSLBumpShader description follows
no description available, TGLBaseCustomGLSLBumpShader description follows
no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLCustomGLSLBumpShader
  • TGLSLBumpShader

Overview

Properties

Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property LightPower;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property BumpHeight;
Published property BumpSmoothness;
Published property LightPower;
Published property MaterialLibrary;
Published property NormalTextureName;
Published property SpecularPower;
Published property SpecularSpread;
Published property SpecularTextureName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLBumpShader: Class TGLSLBumpShaderAM

Class TGLSLBumpShaderAM

Unit

GLSLBumpShader

Declaration

type TGLSLBumpShaderAM = class(TGLCustomGLSLBumpShaderAM)

Description

no description available, TGLCustomGLSLBumpShaderAM description follows
no description available, TGLBaseCustomGLSLBumpShaderMT description follows
no description available, TGLBaseCustomGLSLBumpShader description follows
no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLBaseCustomGLSLBumpShaderMT
  • TGLCustomGLSLBumpShaderAM
  • TGLSLBumpShaderAM

Overview

Properties

Published | property Alpha stored False;
Published | property AmbientColor;
Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property DiffuseColor;
Published | property LightPower;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularColor;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property Alpha stored False;
Published property AmbientColor;
Published property BumpHeight;
Published property BumpSmoothness;
Published property DiffuseColor;
Published property LightPower;
Published property MainTextureName;
Published property MaterialLibrary;
Published property NormalTextureName;
Published property SpecularColor;
Published property SpecularPower;
Published property SpecularSpread;
Published property SpecularTextureName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLBumpShader: Class TGLSLMLBumpShader

Class TGLSLMLBumpShader

Unit

GLSLBumpShader

Declaration

type TGLSLMLBumpShader = class(TGLCustomGLSLMLBumpShader)

Description

no description available, TGLCustomGLSLMLBumpShader description follows
no description available, TGLBaseCustomGLSLBumpShader description follows
no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLCustomGLSLMLBumpShader
  • TGLSLMLBumpShader

Overview

Properties

Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property LightCompensation;
Published | property LightPower;
Published | property LightSources;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property BumpHeight;
Published property BumpSmoothness;
Published property LightCompensation;
Published property LightPower;
Published property LightSources;
Published property MaterialLibrary;
Published property NormalTextureName;
Published property SpecularPower;
Published property SpecularSpread;
Published property SpecularTextureName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLBumpShader: Class TGLSLMLBumpShaderMT

Class TGLSLMLBumpShaderMT

Unit

GLSLBumpShader

Declaration

type TGLSLMLBumpShaderMT = class(TGLCustomGLSLMLBumpShaderMT)

Description

no description available, TGLCustomGLSLMLBumpShaderMT description follows
no description available, TGLBaseCustomGLSLBumpShaderMT description follows
no description available, TGLBaseCustomGLSLBumpShader description follows
no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLBumpShader
  • TGLBaseCustomGLSLBumpShaderMT
  • TGLCustomGLSLMLBumpShaderMT
  • TGLSLMLBumpShaderMT

Overview

Properties

Published | property BumpHeight;
Published | property BumpSmoothness;
Published | property LightCompensation;
Published | property LightPower;
Published | property LightSources;
Published | property MainTextureName;
Published | property MaterialLibrary;
Published | property NormalTextureName;
Published | property SpecularPower;
Published | property SpecularSpread;
Published | property SpecularTextureName;

Description

Properties

Published property BumpHeight;
Published property BumpSmoothness;
Published property LightCompensation;
Published property LightPower;
Published property LightSources;
Published property MainTextureName;
Published property MaterialLibrary;
Published property NormalTextureName;
Published property SpecularPower;
Published property SpecularSpread;
Published property SpecularTextureName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLDiffuseSpecularShader

Unit GLSLDiffuseSpecularShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSLDiffuseSpecularShader<p>

This is a collection of GLSL diffuse-specular shaders.<p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/10/10 - Yar - Bugfixed memory leak <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>07/01/10 - DaStr - Bugfixed all DoInitialize() calls (thanks YarUnderoaker) <li>25/07/09 - DaStr - Fixed a bug with "dot(reflect_vec, LightVector)" clamping which occured on all GeForce 8x and later graphic cards <li>24/07/09 - DaStr - Added Fog support for single-light shaders and fixed a bug with material Alpha (thanks Controller) <li>02/09/07 - LC - Fixed texture bug in TGLSLMLDiffuseSpecularShader. (Bugtracker ID = 1786286) <li>03/04/07 - LC - Shader didn't respect the texture matrix. Changed vertex shader to fix this. (Bugtracker ID = 1693389) <li>20/03/07 - DaStr - Made changes related to the new parameter passing model <li>06/03/07 - DaStr - Again replaced DecimalSeparator stuff with a single Str procedure (thanks Uwe Raabe) <li>03/03/07 - DaStr - Made compatible with Delphi6 Added more stuff to RegisterClasses() <li>21/02/07 - DaStr - Initial version (contributed to GLScene)

This is a collection of GLSL Diffuse Specular shaders, comes in these variaties (to know what these suffixes and prefixes mean see GLCustomShader.pas): - TGLSLDiffuseSpecularShader - TGLSLDiffuseSpecularShaderMT - TGLSLDiffuseSpecularShaderAM

- TGLSLMLDiffuseSpecularShader - TGLSLMLDiffuseSpecularShaderMT

Notes: 1) Alpha is a synthetic property, in real life your should set each color's Alpha individualy 2) TGLSLDiffuseSpecularShader takes all Light parameters directly from OpenGL (that includes TGLLightSource's)

Previous version history: v1.0 01 November '2006 Creation v1.1 19 December '2006 TGLBaseCustomGLSLDiffuseSpecular[MT] abstracted 5 different versions of this shader added v1.1.2 06 February '2007 IGLMaterialLibrarySupported renamed to IGLMaterialLibrarySupported v1.2 16 February '2007 Updated to the latest CVS version of GLScene

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLSLDiffuseSpecularShaderException |
Class TGLBaseCustomGLSLDiffuseSpecular |
Class TGLBaseGLSLDiffuseSpecularShaderMT |
Class TGLCustomGLSLDiffuseSpecularShaderAM |
Class TGLCustomGLSLDiffuseSpecularShader |
Class TGLCustomGLSLDiffuseSpecularShaderMT |
Class TGLCustomGLSLMLDiffuseSpecularShader |
Class TGLCustomGLSLMLDiffuseSpecularShaderMT |
Class TGLSLDiffuseSpecularShaderAM |
Class TGLSLDiffuseSpecularShaderMT |
Class TGLSLDiffuseSpecularShader |
Class TGLSLMLDiffuseSpecularShaderMT |
Class TGLSLMLDiffuseSpecularShader |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLDiffuseSpecularShader: Class EGLSLDiffuseSpecularShaderException

Class EGLSLDiffuseSpecularShaderException

Unit

GLSLDiffuseSpecularShader

Declaration

type EGLSLDiffuseSpecularShaderException = class(EGLSLShaderException)

Description

no description available, EGLSLShaderException description follows
no description available, EGLCustomShaderException description follows
no description available, EGLShaderException description follows

Hierarchy

  • Exception
  • EGLShaderException
  • EGLCustomShaderException
  • EGLSLShaderException
  • EGLSLDiffuseSpecularShaderException
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLDiffuseSpecularShader: Class TGLBaseCustomGLSLDiffuseSpecular

Class TGLBaseCustomGLSLDiffuseSpecular

Unit

GLSLDiffuseSpecularShader

Declaration

type TGLBaseCustomGLSLDiffuseSpecular = class(TGLCustomGLSLShader)

Description

Abstract class.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Protected | function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected | procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;

Properties

Public | property FogSupport: TGLShaderFogSupport read FFogSupport write SetFogSupport default sfsAuto;
Public | property LightPower: Single read FLightPower write FLightPower;
Public | property RealisticSpecular: Boolean read FRealisticSpecular write SetRealisticSpecular;
Public | property SpecularPower: Single read FSpecularPower write FSpecularPower;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Protected function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;

Properties

Public property FogSupport: TGLShaderFogSupport read FFogSupport write SetFogSupport default sfsAuto;

User can disable fog support and save some FPS if he doesn't need it.

Public property LightPower: Single read FLightPower write FLightPower;
Public property RealisticSpecular: Boolean read FRealisticSpecular write SetRealisticSpecular;
Public property SpecularPower: Single read FSpecularPower write FSpecularPower;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLDiffuseSpecularShader: Class TGLBaseGLSLDiffuseSpecularShaderMT

Class TGLBaseGLSLDiffuseSpecularShaderMT

Unit

GLSLDiffuseSpecularShader

Declaration

type TGLBaseGLSLDiffuseSpecularShaderMT = class(TGLBaseCustomGLSLDiffuseSpecular, IGLMaterialLibrarySupported)

Description

Abstract class.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLBaseGLSLDiffuseSpecularShaderMT

Overview

Methods

Protected | procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetMaterialLibrary(const Value: TGLMaterialLibrary); virtual;

Properties

Public | property MainTexture: TGLTexture read FMainTexture write FMainTexture;
Public | property MainTextureName: TGLLibMaterialName read GetMainTextureName write SetMainTextureName;
Public | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Description

Methods

Protected procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetMaterialLibrary(const Value: TGLMaterialLibrary); virtual;

Properties

Public property MainTexture: TGLTexture read FMainTexture write FMainTexture;
Public property MainTextureName: TGLLibMaterialName read GetMainTextureName write SetMainTextureName;
Public property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLDiffuseSpecularShader: Class TGLCustomGLSLDiffuseSpecularShaderAM

Class TGLCustomGLSLDiffuseSpecularShaderAM

Unit

GLSLDiffuseSpecularShader

Declaration

type TGLCustomGLSLDiffuseSpecularShaderAM = class(TGLBaseGLSLDiffuseSpecularShaderMT)

Description

no description available, TGLBaseGLSLDiffuseSpecularShaderMT description follows

Abstract class.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLBaseGLSLDiffuseSpecularShaderMT
  • TGLCustomGLSLDiffuseSpecularShaderAM

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Protected | procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;

Properties

Public | property Alpha: Single read GetAlpha write SetAlpha;
Public | property AmbientColor: TGLColor read FAmbientColor;
Public | property DiffuseColor: TGLColor read FDiffuseColor;
Public | property SpecularColor: TGLColor read FSpecularColor;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Protected procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;

Properties

Public property Alpha: Single read GetAlpha write SetAlpha;
Public property AmbientColor: TGLColor read FAmbientColor;
Public property DiffuseColor: TGLColor read FDiffuseColor;
Public property SpecularColor: TGLColor read FSpecularColor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLDiffuseSpecularShader: Class TGLCustomGLSLDiffuseSpecularShader

Class TGLCustomGLSLDiffuseSpecularShader

Unit

GLSLDiffuseSpecularShader

Declaration

type TGLCustomGLSLDiffuseSpecularShader = class(TGLBaseCustomGLSLDiffuseSpecular)

Description

no description available, TGLBaseCustomGLSLDiffuseSpecular description follows

Abstract class.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLCustomGLSLDiffuseSpecularShader

Overview

Methods

Protected | procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected | procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;

Description

Methods

Protected procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;
Protected procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLDiffuseSpecularShader: Class TGLCustomGLSLDiffuseSpecularShaderMT

Class TGLCustomGLSLDiffuseSpecularShaderMT

Unit

GLSLDiffuseSpecularShader

Declaration

type TGLCustomGLSLDiffuseSpecularShaderMT = class(TGLBaseGLSLDiffuseSpecularShaderMT)

Description

no description available, TGLBaseGLSLDiffuseSpecularShaderMT description follows

Abstract class.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLBaseGLSLDiffuseSpecularShaderMT
  • TGLCustomGLSLDiffuseSpecularShaderMT

Overview

Methods

Protected procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;

Description

Methods

Protected procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLDiffuseSpecularShader: Class TGLCustomGLSLMLDiffuseSpecularShader

Class TGLCustomGLSLMLDiffuseSpecularShader

Unit

GLSLDiffuseSpecularShader

Declaration

type TGLCustomGLSLMLDiffuseSpecularShader = class(TGLBaseCustomGLSLDiffuseSpecular)

Description

Note: probably LightCount should be replaced by LightSources, like in GLSLBumpShader.pas

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLCustomGLSLMLDiffuseSpecularShader

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Protected | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected | procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;

Properties

Public | property LightCompensation: Single read FLightCompensation write SetLightCompensation;
Public | property LightCount: Integer read FLightCount write SetLightCount default 1;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Protected procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;

Properties

Public property LightCompensation: Single read FLightCompensation write SetLightCompensation;

Setting LightCompensation to a value less than 1 decreeses individual light intensity when using multiple lights

Public property LightCount: Integer read FLightCount write SetLightCount default 1;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLDiffuseSpecularShader: Class TGLCustomGLSLMLDiffuseSpecularShaderMT

Class TGLCustomGLSLMLDiffuseSpecularShaderMT

Unit

GLSLDiffuseSpecularShader

Declaration

type TGLCustomGLSLMLDiffuseSpecularShaderMT = class(TGLBaseGLSLDiffuseSpecularShaderMT)

Description

no description available, TGLBaseGLSLDiffuseSpecularShaderMT description follows

Abstract class.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLBaseGLSLDiffuseSpecularShaderMT
  • TGLCustomGLSLMLDiffuseSpecularShaderMT

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Protected | procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;

Properties

Public | property LightCompensation: Single read FLightCompensation write SetLightCompensation;
Public | property LightCount: Integer read FLightCount write SetLightCount default 1;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Protected procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;

Properties

Public property LightCompensation: Single read FLightCompensation write SetLightCompensation;

Setting LightCompensation to a value less than 1 decreeses individual light intensity when using multiple lights

Public property LightCount: Integer read FLightCount write SetLightCount default 1;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLDiffuseSpecularShader: Class TGLSLDiffuseSpecularShaderAM

Class TGLSLDiffuseSpecularShaderAM

Unit

GLSLDiffuseSpecularShader

Declaration

type TGLSLDiffuseSpecularShaderAM = class(TGLCustomGLSLDiffuseSpecularShaderAM)

Description

no description available, TGLCustomGLSLDiffuseSpecularShaderAM description follows
no description available, TGLBaseGLSLDiffuseSpecularShaderMT description follows

Abstract class.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLBaseGLSLDiffuseSpecularShaderMT
  • TGLCustomGLSLDiffuseSpecularShaderAM
  • TGLSLDiffuseSpecularShaderAM

Overview

Properties

Published | property Alpha stored False;
Published | property AmbientColor;
Published | property DiffuseColor;
Published | property FogSupport;
Published | property LightPower;
Published | property MainTexture;
Published | property SpecularColor;
Published | property SpecularPower;

Description

Properties

Published property Alpha stored False;
Published property AmbientColor;
Published property DiffuseColor;
Published property FogSupport;
Published property LightPower;
Published property MainTexture;
Published property SpecularColor;
Published property SpecularPower;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLDiffuseSpecularShader: Class TGLSLDiffuseSpecularShaderMT

Class TGLSLDiffuseSpecularShaderMT

Unit

GLSLDiffuseSpecularShader

Declaration

type TGLSLDiffuseSpecularShaderMT = class(TGLCustomGLSLDiffuseSpecularShaderMT)

Description

no description available, TGLCustomGLSLDiffuseSpecularShaderMT description follows
no description available, TGLBaseGLSLDiffuseSpecularShaderMT description follows

Abstract class.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLBaseGLSLDiffuseSpecularShaderMT
  • TGLCustomGLSLDiffuseSpecularShaderMT
  • TGLSLDiffuseSpecularShaderMT

Overview

Properties

Published | property FogSupport;
Published | property LightPower;
Published | property MainTextureName;
Published | property SpecularPower;

Description

Properties

Published property FogSupport;
Published property LightPower;
Published property MainTextureName;
Published property SpecularPower;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLDiffuseSpecularShader: Class TGLSLDiffuseSpecularShader

Class TGLSLDiffuseSpecularShader

Unit

GLSLDiffuseSpecularShader

Declaration

type TGLSLDiffuseSpecularShader = class(TGLCustomGLSLDiffuseSpecularShader)

Description

no description available, TGLCustomGLSLDiffuseSpecularShader description follows
no description available, TGLBaseCustomGLSLDiffuseSpecular description follows

Abstract class.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLCustomGLSLDiffuseSpecularShader
  • TGLSLDiffuseSpecularShader

Overview

Properties

Published | property FogSupport;
Published | property LightPower;
Published | property SpecularPower;

Description

Properties

Published property FogSupport;
Published property LightPower;
Published property SpecularPower;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLDiffuseSpecularShader: Class TGLSLMLDiffuseSpecularShaderMT

Class TGLSLMLDiffuseSpecularShaderMT

Unit

GLSLDiffuseSpecularShader

Declaration

type TGLSLMLDiffuseSpecularShaderMT = class(TGLCustomGLSLMLDiffuseSpecularShaderMT)

Description

no description available, TGLCustomGLSLMLDiffuseSpecularShaderMT description follows
no description available, TGLBaseGLSLDiffuseSpecularShaderMT description follows

Abstract class.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLBaseGLSLDiffuseSpecularShaderMT
  • TGLCustomGLSLMLDiffuseSpecularShaderMT
  • TGLSLMLDiffuseSpecularShaderMT

Overview

Properties

Published | property FogSupport;
Published | property LightCompensation;
Published | property LightCount;
Published | property LightPower;
Published | property MainTextureName;
Published | property SpecularPower;

Description

Properties

Published property FogSupport;
Published property LightCompensation;
Published property LightCount;
Published property LightPower;
Published property MainTextureName;
Published property SpecularPower;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLDiffuseSpecularShader: Class TGLSLMLDiffuseSpecularShader

Class TGLSLMLDiffuseSpecularShader

Unit

GLSLDiffuseSpecularShader

Declaration

type TGLSLMLDiffuseSpecularShader = class(TGLCustomGLSLMLDiffuseSpecularShader)

Description

no description available, TGLCustomGLSLMLDiffuseSpecularShader description follows

Note: probably LightCount should be replaced by LightSources, like in GLSLBumpShader.pas

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLBaseCustomGLSLDiffuseSpecular
  • TGLCustomGLSLMLDiffuseSpecularShader
  • TGLSLMLDiffuseSpecularShader

Overview

Properties

Published | property FogSupport;
Published | property LightCompensation;
Published | property LightCount;
Published | property LightPower;
Published | property SpecularPower;

Description

Properties

Published property FogSupport;
Published property LightCompensation;
Published property LightCount;
Published property LightPower;
Published property SpecularPower;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLog

Unit GLSLog

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TLogBufferFlushThread |
Class TLogCheckSizeThread |
Class TLogSession |
Class TGLSLogger |

Functions and Procedures

function UserLog: TLogSession;
function SkipBeforeSTR(var TextFile: Text; SkipSTR: string): Boolean;
function ReadLine(var TextFile: Text): string;
function GLSLogger(): TLogSession;
procedure UseCustomGLSLogger(const ALogger: TLogSession);
function ConstArrayToString(const Elements: array of const): String;

Types

TLogLevel = (...);
TLogLevels = set of TLogLevel;
TLogMessageLimitAction = (...);
TLogTimeFormat = (...);
TLogBufferingMode = (...);
CLogSession = class of TLogSession;
TIDELogProc = procedure(const AMsg: string);

Constants

llMax: TLogLevels = [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];
llMedium: TLogLevels = [lkNotice, lkWarning, lkError, lkFatalError];
llMin: TLogLevels = [lkError, lkFatalError];

Variables

llMessageLimit: array [TLogLevel] of Integer = (MaxInt, MaxInt, MaxInt, 500, 100, 10);
lkPrefix: array [TLogLevel] of string = (' (D) ', ' (i) ', ' (M) ', ' (W) ', ' (Er) ', ' (!!) ');
vIDELogProc: TIDELogProc;

Description

Functions and Procedures

function UserLog: TLogSession;
function SkipBeforeSTR(var TextFile: Text; SkipSTR: string): Boolean;
function ReadLine(var TextFile: Text): string;
function GLSLogger(): TLogSession;
procedure UseCustomGLSLogger(const ALogger: TLogSession);
function ConstArrayToString(const Elements: array of const): String;

Types

TLogLevel = (...);
Values
  • lkDebug:
  • lkInfo:
  • lkNotice:
  • lkWarning:
  • lkError:
  • lkFatalError:
TLogLevels = set of TLogLevel;
TLogMessageLimitAction = (...);

What to do when number of messages exceeds message limit.

Values
  • mlaContinue:
  • mlaStopLogging:
  • mlaHalt:
TLogTimeFormat = (...);
Values
  • lfNone:
  • lfDate:
  • lfTime:
  • lfTimeExact:
  • lfDateTime:
  • lfElapsed:
TLogBufferingMode = (...);

How log is buffered.

Values
  • lbmWriteEmidiatly:
  • lbmWritePeriodically:
  • lbmWriteInTheEnd:
CLogSession = class of TLogSession;
TIDELogProc = procedure(const AMsg: string);

Constants

llMax: TLogLevels = [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];
llMedium: TLogLevels = [lkNotice, lkWarning, lkError, lkFatalError];
llMin: TLogLevels = [lkError, lkFatalError];

Variables

llMessageLimit: array [TLogLevel] of Integer = (MaxInt, MaxInt, MaxInt, 500, 100, 10);
lkPrefix: array [TLogLevel] of string = (' (D) ', ' (i) ', ' (M) ', ' (W) ', ' (Er) ', ' (!!) ');
vIDELogProc: TIDELogProc;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLog: Class TLogBufferFlushThread

Class TLogBufferFlushThread

Unit

GLSLog

Declaration

type TLogBufferFlushThread = class(TThread)

Description

Thread that periodically flushes the buffer to disk.

Hierarchy

  • TThread
  • TLogBufferFlushThread

Overview

Methods

Public | constructor Create(const AParent: TLogSession);
Protected | procedure Execute; override;

Description

Methods

Public constructor Create(const AParent: TLogSession);
Protected procedure Execute; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLog: Class TLogCheckSizeThread

Class TLogCheckSizeThread

Unit

GLSLog

Declaration

type TLogCheckSizeThread = class(TThread)

Description

Thread that checks file size and splits the file if nessesary.

Hierarchy

  • TThread
  • TLogCheckSizeThread

Overview

Methods

Public | constructor Create(const AParent: TLogSession);
Protected | procedure Execute; override;

Description

Methods

Public constructor Create(const AParent: TLogSession);
Protected procedure Execute; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLog: Class TLogSession

Class TLogSession

Unit

GLSLog

Declaration

type TLogSession = class(TObject)

Description

Abstract Logger class

Hierarchy

  • TObject
  • TLogSession

Overview

Methods

Public | constructor Init(const AFileName: string; const ATimeFormat: TLogTimeFormat; const ALevels: TLogLevels; const ALogThreadId: Boolean = True; const ABuffered: Boolean = False; const AMaxSize: Integer = 0; const ASaveOldLogs: Boolean = False); virtual;
Public | destructor Destroy; override;
Protected | function AttachLogFile(const AFileName: string; const AResetFile: Boolean = True): Boolean;
Protected | function DoResetLog: Boolean; virtual;
Protected | function DoWriteBufferToLog(): Boolean; virtual;
Protected | function DoWriteToLog(const AString: string): Boolean; virtual;
Public | procedure DisplayLog();
Public | procedure FlushBuffer();
Public | procedure Log(const Desc: string; const Level: TLogLevel = lkInfo);
Public | procedure LogAdv(const args: array of const; const ALevel: TLogLevel = lkError);
Public | procedure LogDebug(const Desc: string);
Public | procedure LogDebugFmt(const Desc: string; const Args: array of const );
Public | procedure LogEmtryLine();
Public | procedure LogError(const Desc: string);
Public | procedure LogErrorFmt(const Desc: string; const Args: array of const );
Public | procedure LogException(const E: Exception; const aFunctionName: string; const args: array of const; const ALevel: TLogLevel = lkError);
Public | procedure LogFatalError(const Desc: string);
Public | procedure LogFatalErrorFmt(const Desc: string; const Args: array of const );
Public | procedure LogInfo(const Desc: string);
Public | procedure LogInfoFmt(const Desc: string; const Args: array of const );
Public | procedure LogNotice(const Desc: string);
Public | procedure LogNoticeFmt(const Desc: string; const Args: array of const );
Public | procedure LogWarning(const Desc: string);
Public | procedure LogWarningFmt(const Desc: string; const Args: array of const );
Protected | procedure AppendLog(const AString: string; const ALevel: TLogLevel; const ALogTime: Boolean = True);
Protected | procedure ClearOldLogs();
Protected | procedure CreateNewLogFileIfNeeded();
Protected | procedure PrintLogLevels();
Protected | procedure PrintLogStatistics();
Protected | procedure SaveOldLogs(const ACurrentLogFileName: string);

Properties

Public | property Buffered: Boolean read FBuffered write SetBuffered default False;
Public | property CheckFileSizePeriod: Integer read FCheckFileSizePeriod write FCheckFileSizePeriod;
Public | property DisplayLogOnExitIfItContains: TLogLevels read FDisplayLogOnExitIfItContains write FDisplayLogOnExitIfItContains;
Public | property Enabled: Boolean read FEnabled write SetEnabled;
Public | property FlushBufferPeriod: Integer read FFlushBufferPeriod write FFlushBufferPeriod;
Public | property LogFileMaxSize: Integer read FLogFileMaxSize write SetLogFileMaxSize;
Public | property LogLevels: TLogLevels read FLogLevels write SetMode;
Public | property LogThreadId: Boolean read FLogThreadId write FLogThreadId;
Public | property MessageLimitAction: TLogMessageLimitAction read FMessageLimitAction write FMessageLimitAction default mlaHalt;

Description

Methods

Public constructor Init(const AFileName: string; const ATimeFormat: TLogTimeFormat; const ALevels: TLogLevels; const ALogThreadId: Boolean = True; const ABuffered: Boolean = False; const AMaxSize: Integer = 0; const ASaveOldLogs: Boolean = False); virtual;
Public destructor Destroy; override;
Protected function AttachLogFile(const AFileName: string; const AResetFile: Boolean = True): Boolean;
Protected function DoResetLog: Boolean; virtual;

Resets log. Returns True if everything went ok.

Protected function DoWriteBufferToLog(): Boolean; virtual;

Writes FBuffer to log. Returns True if everything went ok.

Protected function DoWriteToLog(const AString: string): Boolean; virtual;

Writes string to log. Returns True if everything went ok.

Public procedure DisplayLog();
Public procedure FlushBuffer();
Public procedure Log(const Desc: string; const Level: TLogLevel = lkInfo);
Public procedure LogAdv(const args: array of const; const ALevel: TLogLevel = lkError);
Public procedure LogDebug(const Desc: string);
Public procedure LogDebugFmt(const Desc: string; const Args: array of const );
Public procedure LogEmtryLine();
Public procedure LogError(const Desc: string);
Public procedure LogErrorFmt(const Desc: string; const Args: array of const );
Public procedure LogException(const E: Exception; const aFunctionName: string; const args: array of const; const ALevel: TLogLevel = lkError);
Public procedure LogFatalError(const Desc: string);
Public procedure LogFatalErrorFmt(const Desc: string; const Args: array of const );
Public procedure LogInfo(const Desc: string);
Public procedure LogInfoFmt(const Desc: string; const Args: array of const );
Public procedure LogNotice(const Desc: string);
Public procedure LogNoticeFmt(const Desc: string; const Args: array of const );
Public procedure LogWarning(const Desc: string);
Public procedure LogWarningFmt(const Desc: string; const Args: array of const );
Protected procedure AppendLog(const AString: string; const ALevel: TLogLevel; const ALogTime: Boolean = True);
Protected procedure ClearOldLogs();
Protected procedure CreateNewLogFileIfNeeded();
Protected procedure PrintLogLevels();
Protected procedure PrintLogStatistics();
Protected procedure SaveOldLogs(const ACurrentLogFileName: string);

Properties

Public property Buffered: Boolean read FBuffered write SetBuffered default False;
Public property CheckFileSizePeriod: Integer read FCheckFileSizePeriod write FCheckFileSizePeriod;
Public property DisplayLogOnExitIfItContains: TLogLevels read FDisplayLogOnExitIfItContains write FDisplayLogOnExitIfItContains;

To always display log, put all log types. To never display log, leave this empty.

Public property Enabled: Boolean read FEnabled write SetEnabled;
Public property FlushBufferPeriod: Integer read FFlushBufferPeriod write FFlushBufferPeriod;
Public property LogFileMaxSize: Integer read FLogFileMaxSize write SetLogFileMaxSize;

If LogFileMaxSize is not 0, then: 1) At start, all logs with the same extention will be deleted. 2) All logs wil be periodically cheked for FileSize. New log file will be created when this size exceeds limit.

Public property LogLevels: TLogLevels read FLogLevels write SetMode;
Public property LogThreadId: Boolean read FLogThreadId write FLogThreadId;
Public property MessageLimitAction: TLogMessageLimitAction read FMessageLimitAction write FMessageLimitAction default mlaHalt;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLog: Class TGLSLogger

Class TGLSLogger

Unit

GLSLog

Declaration

type TGLSLogger = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLSLogger

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoPrimary;

Properties

Public | property Log: TLogSession read GetLog;
Published | property LogLevels: TLogLevels read FLogLevels write FLogLevels default [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];
Published | property ReplaceAssertion: Boolean read FReplaceAssertion write SetReplaceAssertion default False;
Published | property TimeFormat: TLogTimeFormat read FTimeFormat write FTimeFormat default lfElapsed;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure DoPrimary;

Properties

Public property Log: TLogSession read GetLog;
Published property LogLevels: TLogLevels read FLogLevels write FLogLevels default [lkDebug, lkInfo, lkNotice, lkWarning, lkError, lkFatalError];
Published property ReplaceAssertion: Boolean read FReplaceAssertion write SetReplaceAssertion default False;
Published property TimeFormat: TLogTimeFormat read FTimeFormat write FTimeFormat default lfElapsed;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLParameter

Unit GLSLParameter

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSLParameter<p>

<b>History : </b><font size=-1><ul> <li>14/03/11 - Yar - Creation </ul>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Interface IShaderParameter |

Functions and Procedures

function GLSLTypeEnum(AType: TGLSLDataType): TGLEnum;
function GLSLTypeComponentCount(AType: TGLSLDataType): Integer;
procedure RegisterUniformAutoSetMethod(AMethodName: string; AType: TGLSLDataType; AMethod: TUniformAutoSetMethod);
procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TGLSLDataType); overload;
procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TGLSLSamplerType); overload;
function GetUniformAutoSetMethod(AMethodName: string): TUniformAutoSetMethod;
function GetUniformAutoSetMethodName(AMethod: TUniformAutoSetMethod): string;

Types

TGLSLDataType = (...);
TGLSLSamplerType = (...);
TGLgsInTypes = (...);
TGLgsOutTypes = (...);
TUniformAutoSetMethod = procedure(Sender: IShaderParameter; var ARci: TRenderContextInfo) of object;

Constants

cGLSLTypeString: array[TGLSLDataType] of AnsiString = ( 'undefined', 'float', 'vec2', 'vec3', 'vec4', 'int', 'ivec2', 'ivec3', 'ivec4', 'uint', 'uivec2', 'uivec3', 'uivec4', 'mat2', 'mat3', 'mat4', 'void');
cGLSLSamplerString: array[TGLSLSamplerType] of AnsiString = ( 'undefined', 'sampler1D', 'sampler2D', 'sampler3D', 'samplerCube', 'sampler1DShadow', 'sampler2DShadow', 'sampler1DArray', 'sampler2DArray', 'sampler1DArrayShadow', 'sampler2DArrayShadow', 'samplerCubeShadow', 'isampler1D', 'isampler2D', 'isampler3D', 'isamplerCube', 'isampler1DArray', 'isampler2DArray', 'usampler1D', 'usampler2D', 'usampler3D', 'usamplerCube', 'usampler1DArray', 'usampler2DArray', 'samplerRect', 'samplerRectShadow', 'samplerBuffer', 'isamplerRect', 'isamplerBuffer', 'usamplerRect', 'usamplerBuffer', 'samplerMS', 'isamplerMS', 'usamplerMS', 'samplerMSArray', 'isamplerMSArray', 'usamplerMSArray');
cGLgsInTypes : array[TGLgsInTypes] of GLenum = (GL_POINTS, GL_LINES, GL_LINES_ADJACENCY_EXT, GL_TRIANGLES, GL_TRIANGLES_ADJACENCY_EXT);
cGLgsOutTypes: array[TGLgsOutTypes] of GLenum = (GL_POINTS, GL_LINE_STRIP, GL_TRIANGLE_STRIP);
rstrNothing = '*nothing*';

Description

Functions and Procedures

function GLSLTypeEnum(AType: TGLSLDataType): TGLEnum;
function GLSLTypeComponentCount(AType: TGLSLDataType): Integer;
procedure RegisterUniformAutoSetMethod(AMethodName: string; AType: TGLSLDataType; AMethod: TUniformAutoSetMethod);
procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TGLSLDataType); overload;
procedure FillUniformAutoSetMethodList(AList: TStrings; TypeFilter: TGLSLSamplerType); overload;
function GetUniformAutoSetMethod(AMethodName: string): TUniformAutoSetMethod;
function GetUniformAutoSetMethodName(AMethod: TUniformAutoSetMethod): string;

Types

TGLSLDataType = (...);
Values
  • GLSLTypeUndefined:
  • GLSLType1F:
  • GLSLType2F:
  • GLSLType3F:
  • GLSLType4F:
  • GLSLType1I:
  • GLSLType2I:
  • GLSLType3I:
  • GLSLType4I:
  • GLSLType1UI:
  • GLSLType2UI:
  • GLSLType3UI:
  • GLSLType4UI:
  • GLSLTypeMat2F:
  • GLSLTypeMat3F:
  • GLSLTypeMat4F:
  • GLSLTypeVoid:
TGLSLSamplerType = (...);
Values
  • GLSLSamplerUndefined:
  • GLSLSampler1D:
  • GLSLSampler2D:
  • GLSLSampler3D:
  • GLSLSamplerCube:
  • GLSLSampler1DShadow:
  • GLSLSampler2DShadow:
  • GLSLSampler1DArray:
  • GLSLSampler2DArray:
  • GLSLSampler1DArrayShadow:
  • GLSLSampler2DArrayShadow:
  • GLSLSamplerCubeShadow:
  • GLSLIntSampler1D:
  • GLSLIntSampler2D:
  • GLSLIntSampler3D:
  • GLSLIntSamplerCube:
  • GLSLIntSampler1DArray:
  • GLSLIntSampler2DArray:
  • GLSLUIntSampler1D:
  • GLSLUIntSampler2D:
  • GLSLUIntSampler3D:
  • GLSLUIntSamplerCube:
  • GLSLUIntSampler1DArray:
  • GLSLUIntSampler2DArray:
  • GLSLSamplerRect:
  • GLSLSamplerRectShadow:
  • GLSLSamplerBuffer:
  • GLSLIntSamplerRect:
  • GLSLIntSamplerBuffer:
  • GLSLUIntSamplerRect:
  • GLSLUIntSamplerBuffer:
  • GLSLSamplerMS:
  • GLSLIntSamplerMS:
  • GLSLUIntSamplerMS:
  • GLSLSamplerMSArray:
  • GLSLIntSamplerMSArray:
  • GLSLUIntSamplerMSArray:
TGLgsInTypes = (...);
Values
  • gsInPoints:
  • gsInLines:
  • gsInAdjLines:
  • gsInTriangles:
  • gsInAdjTriangles:
TGLgsOutTypes = (...);
Values
  • gsOutPoints:
  • gsOutLineStrip:
  • sOutTriangleStrip:
TUniformAutoSetMethod = procedure(Sender: IShaderParameter; var ARci: TRenderContextInfo) of object;

Constants

cGLSLTypeString: array[TGLSLDataType] of AnsiString = ( 'undefined', 'float', 'vec2', 'vec3', 'vec4', 'int', 'ivec2', 'ivec3', 'ivec4', 'uint', 'uivec2', 'uivec3', 'uivec4', 'mat2', 'mat3', 'mat4', 'void');
cGLSLSamplerString: array[TGLSLSamplerType] of AnsiString = ( 'undefined', 'sampler1D', 'sampler2D', 'sampler3D', 'samplerCube', 'sampler1DShadow', 'sampler2DShadow', 'sampler1DArray', 'sampler2DArray', 'sampler1DArrayShadow', 'sampler2DArrayShadow', 'samplerCubeShadow', 'isampler1D', 'isampler2D', 'isampler3D', 'isamplerCube', 'isampler1DArray', 'isampler2DArray', 'usampler1D', 'usampler2D', 'usampler3D', 'usamplerCube', 'usampler1DArray', 'usampler2DArray', 'samplerRect', 'samplerRectShadow', 'samplerBuffer', 'isamplerRect', 'isamplerBuffer', 'usamplerRect', 'usamplerBuffer', 'samplerMS', 'isamplerMS', 'usamplerMS', 'samplerMSArray', 'isamplerMSArray', 'usamplerMSArray');
cGLgsInTypes : array[TGLgsInTypes] of GLenum = (GL_POINTS, GL_LINES, GL_LINES_ADJACENCY_EXT, GL_TRIANGLES, GL_TRIANGLES_ADJACENCY_EXT);
cGLgsOutTypes: array[TGLgsOutTypes] of GLenum = (GL_POINTS, GL_LINE_STRIP, GL_TRIANGLE_STRIP);
rstrNothing = '*nothing*';
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:50


GLScene v.1.1.2: GLSLParameter: Interface IShaderParameter

Interface IShaderParameter

Unit

GLSLParameter

Declaration

type IShaderParameter = interface(IInterface)

Description

Hierarchy

  • IInterface
  • IShaderParameter

Overview

Methods

Public | function GetAutoSetMethod: string;
Public | function GetFloat: Single;
Public | function GetGLSLSamplerType: TGLSLSamplerType;
Public | function GetGLSLType: TGLSLDataType;
Public | function GetInt: TGLint;
Public | function GetIVec2: TVector2i;
Public | function GetIVec3: TVector3i;
Public | function GetIVec4: TVector4i;
Public | function GetMat2: TMatrix2f;
Public | function GetMat3: TMatrix3f;
Public | function GetMat4: TMatrix4f;
Public | function GetName: string;
Public | function GetSamplerName: string;
Public | function GetTextureName: string;
Public | function GetTextureSwizzle: TSwizzleVector;
Public | function GetUInt: TGLuint;
Public | function GetUVec2: TVector2ui;
Public | function GetUVec3: TVector3ui;
Public | function GetUVec4: TVector4ui;
Public | function GetVec2: TVector2f;
Public | function GetVec3: TVector3f;
Public | function GetVec4: TVector4f;
Public | procedure SetAutoSetMethod(const AValue: string);
Public | procedure SetFloat(const Value: TGLFloat);
Public | procedure SetFloatArray(const Values: PGLFloat; Count: Integer);
Public | procedure SetInt(const Value: Integer);
Public | procedure SetIntArray(const Values: PGLInt; Count: Integer);
Public | procedure SetIVec2(const Value: TVector2i);
Public | procedure SetIVec3(const Value: TVector3i);
Public | procedure SetIVec4(const Value: TVector4i);
Public | procedure SetMat2(const Value: TMatrix2f);
Public | procedure SetMat3(const Value: TMatrix3f);
Public | procedure SetMat4(const Value: TMatrix4f);
Public | procedure SetSamplerName(const AValue: string);
Public | procedure SetTextureName(const AValue: string);
Public | procedure SetTextureSwizzle(const AValue: TSwizzleVector);
Public | procedure SetUInt(const Value: GLuint);
Public | procedure SetUIntArray(const Values: PGLUInt; Count: Integer);
Public | procedure SetUVec2(const Value: TVector2ui);
Public | procedure SetUVec3(const Value: TVector3ui);
Public | procedure SetUVec4(const Value: TVector4ui);
Public | procedure SetVec2(const Value: TVector2f);
Public | procedure SetVec3(const Value: TVector3f);
Public | procedure SetVec4(const Value: TVector4f);

Properties

Public | property AutoSetMethod: string read GetAutoSetMethod write SetAutoSetMethod;
Public | property float: TGLFloat read GetFloat write SetFloat;
Public | property GLSLSamplerType: TGLSLSamplerType read GetGLSLSamplerType;
Public | property GLSLType: TGLSLDataType read GetGLSLType;
Public | property int: TGLint read GetInt write SetInt;
Public | property ivec2: TVector2i read GetIVec2 write SetIVec2;
Public | property ivec3: TVector3i read GetIVec3 write SetIVec3;
Public | property ivec4: TVector4i read GetIVec4 write SetIVec4;
Public | property mat2: TMatrix2f read GetMat2 write SetMat2;
Public | property mat3: TMatrix3f read GetMat3 write SetMat3;
Public | property mat4: TMatrix4f read GetMat4 write SetMat4;
Public | property Name: string read GetName;
Public | property SamplerName: string read GetSamplerName write SetSamplerName;
Public | property TextureName: string read GetTextureName write SetTextureName;
Public | property TextureSwizzle: TSwizzleVector read GetTextureSwizzle write SetTextureSwizzle;
Public | property uint: TGLUint read GetUInt write SetUInt;
Public | property uvec2: TVector2ui read GetUVec2 write SetUVec2;
Public | property uvec3: TVector3ui read GetUVec3 write SetUVec3;
Public | property uvec4: TVector4ui read GetUVec4 write SetUVec4;
Public | property vec2: TVector2f read GetVec2 write SetVec2;
Public | property vec3: TVector3f read GetVec3 write SetVec3;
Public | property vec4: TVector4f read GetVec4 write SetVec4;

Description

Methods

Public function GetAutoSetMethod: string;
Public function GetFloat: Single;
Public function GetGLSLSamplerType: TGLSLSamplerType;
Public function GetGLSLType: TGLSLDataType;
Public function GetInt: TGLint;
Public function GetIVec2: TVector2i;
Public function GetIVec3: TVector3i;
Public function GetIVec4: TVector4i;
Public function GetMat2: TMatrix2f;
Public function GetMat3: TMatrix3f;
Public function GetMat4: TMatrix4f;
Public function GetName: string;
Public function GetSamplerName: string;
Public function GetTextureName: string;
Public function GetTextureSwizzle: TSwizzleVector;
Public function GetUInt: TGLuint;
Public function GetUVec2: TVector2ui;
Public function GetUVec3: TVector3ui;
Public function GetUVec4: TVector4ui;
Public function GetVec2: TVector2f;
Public function GetVec3: TVector3f;
Public function GetVec4: TVector4f;
Public procedure SetAutoSetMethod(const AValue: string);
Public procedure SetFloat(const Value: TGLFloat);
Public procedure SetFloatArray(const Values: PGLFloat; Count: Integer);
Public procedure SetInt(const Value: Integer);
Public procedure SetIntArray(const Values: PGLInt; Count: Integer);
Public procedure SetIVec2(const Value: TVector2i);
Public procedure SetIVec3(const Value: TVector3i);
Public procedure SetIVec4(const Value: TVector4i);
Public procedure SetMat2(const Value: TMatrix2f);
Public procedure SetMat3(const Value: TMatrix3f);
Public procedure SetMat4(const Value: TMatrix4f);
Public procedure SetSamplerName(const AValue: string);
Public procedure SetTextureName(const AValue: string);
Public procedure SetTextureSwizzle(const AValue: TSwizzleVector);
Public procedure SetUInt(const Value: GLuint);
Public procedure SetUIntArray(const Values: PGLUInt; Count: Integer);
Public procedure SetUVec2(const Value: TVector2ui);
Public procedure SetUVec3(const Value: TVector3ui);
Public procedure SetUVec4(const Value: TVector4ui);
Public procedure SetVec2(const Value: TVector2f);
Public procedure SetVec3(const Value: TVector3f);
Public procedure SetVec4(const Value: TVector4f);

Properties

Public property AutoSetMethod: string read GetAutoSetMethod write SetAutoSetMethod;

Bindings.<p>

Public property float: TGLFloat read GetFloat write SetFloat;

Scalar types.<p>

Public property GLSLSamplerType: TGLSLSamplerType read GetGLSLSamplerType;
Public property GLSLType: TGLSLDataType read GetGLSLType;
Public property int: TGLint read GetInt write SetInt;
Public property ivec2: TVector2i read GetIVec2 write SetIVec2;

Integer vector types.<p>

Public property ivec3: TVector3i read GetIVec3 write SetIVec3;
Public property ivec4: TVector4i read GetIVec4 write SetIVec4;
Public property mat2: TMatrix2f read GetMat2 write SetMat2;

Matrix Types.<p>

Public property mat3: TMatrix3f read GetMat3 write SetMat3;
Public property mat4: TMatrix4f read GetMat4 write SetMat4;
Public property Name: string read GetName;
Public property SamplerName: string read GetSamplerName write SetSamplerName;
Public property TextureName: string read GetTextureName write SetTextureName;
Public property TextureSwizzle: TSwizzleVector read GetTextureSwizzle write SetTextureSwizzle;
Public property uint: TGLUint read GetUInt write SetUInt;
Public property uvec2: TVector2ui read GetUVec2 write SetUVec2;

Unsigned integer vector types.<p>

Public property uvec3: TVector3ui read GetUVec3 write SetUVec3;
Public property uvec4: TVector4ui read GetUVec4 write SetUVec4;
Public property vec2: TVector2f read GetVec2 write SetVec2;

Float vector types.<p>

Public property vec3: TVector3f read GetVec3 write SetVec3;
Public property vec4: TVector4f read GetVec4 write SetVec4;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSLPostBlurShader

Unit GLSLPostBlurShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSLPostBlurShader <p>

A shader that blurs the entire scene.<p>

<b>History : </b><font size=-1><ul> <li>22/04/10 - Yar - Fixes after GLState revision < Added VectorTypes to uses <li>16/04/07 - DaStr - Shader made ATI compatible <li>05/04/07 - DaStr - Initial version (contributed to GLScene)

Previous version history: v1.0 04 November '2006 Creation (based on RenderMonkey demo) v1.1 04 March '2007 IGLPostShader support added v1.2 30 March '2007 TGLCustomGLSLPostBlurShaderSceneObject removed Shader now supports GL_TEXTURE_RECTANGLE_ARB

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLCustomGLSLPostBlurShader |
Class TGLSLPostBlurShader |
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSLPostBlurShader: Class TGLCustomGLSLPostBlurShader

Class TGLCustomGLSLPostBlurShader

Unit

GLSLPostBlurShader

Declaration

type TGLCustomGLSLPostBlurShader = class(TGLCustomGLSLShader, IGLPostShader)

Description

no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostBlurShader

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Protected | function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;

Properties

Public property Threshold: Single read FThreshold write FThreshold stored StoreThreshold;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Protected function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;

Properties

Public property Threshold: Single read FThreshold write FThreshold stored StoreThreshold;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSLPostBlurShader: Class TGLSLPostBlurShader

Class TGLSLPostBlurShader

Unit

GLSLPostBlurShader

Declaration

type TGLSLPostBlurShader = class(TGLCustomGLSLPostBlurShader)

Description

no description available, TGLCustomGLSLPostBlurShader description follows
no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLCustomGLSLPostBlurShader
  • TGLSLPostBlurShader

Overview

Properties

Published property Threshold;

Description

Properties

Published property Threshold;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSLProjectedTextures

Unit GLSLProjectedTextures

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSLTextureEmitter |
Class TGLSLTextureEmitterItem |
Class TGLSLTextureEmitters |
Class TGLSLProjectedTextures |

Types

TGLSLProjectedTexturesStyle = (...);

Description

Types

TGLSLProjectedTexturesStyle = (...);
Values
  • ptsLight:
  • ptsShadow:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSLProjectedTextures: Class TGLSLTextureEmitter

Class TGLSLTextureEmitter

Unit

GLSLProjectedTextures

Declaration

type TGLSLTextureEmitter = class(TGLBaseSceneObject)

Description

A projected texture emmiter.<p> Can be places anywhere in the scene. Used to generate a modelview and texture matrix for the shader

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLSLTextureEmitter

Overview

Fields

Protected | ProjectedTexturesObject: TGLSLProjectedTextures;
Protected | TexMatrix: TMatrix;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: boolean); override;
Protected | procedure SetAllowReverseProjection(val: boolean);
Protected | procedure SetStyle(val: TGLSLProjectedTexturesStyle);
Protected | procedure SetupTexMatrix;
Protected | procedure SetUseAttenuation(val: boolean);
Protected | procedure SetUseQuadraticAttenuation(val: boolean);

Properties

Published | property AllowReverseProjection: boolean read FAllowReverseProjection write SetAllowReverseProjection;
Published | property Aspect: single read FAspect write FAspect;
Published | property Attenuation: single read FAttenuation write FAttenuation;
Published | property Behaviours;
Published | property Brightness: single read FBrightness write FBrightness;
Published | property Color: TGLColor read FColor write FColor;
Published | property Direction;
Published | property Effects;
Published | property FOV: single read FFOV write FFOV;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property PitchAngle;
Published | property Position;
Published | property RollAngle;
Published | property Scale;
Published | property ShowAxes;
Published | property Style: TGLSLProjectedTexturesStyle read FStyle write SetStyle;
Published | property TurnAngle;
Published | property Up;
Published | property UseAttenuation: boolean read FUseAttenuation write SetUseAttenuation;
Published | property UseQuadraticAttenuation: Boolean read FUseQuadraticAttenuation write SetUseQuadraticAttenuation;
Published | property VisibilityCulling;
Published | property Visible;

Description

Fields

Protected ProjectedTexturesObject: TGLSLProjectedTextures;
Protected TexMatrix: TMatrix;

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: boolean); override;
Protected procedure SetAllowReverseProjection(val: boolean);
Protected procedure SetStyle(val: TGLSLProjectedTexturesStyle);
Protected procedure SetupTexMatrix;
Protected procedure SetUseAttenuation(val: boolean);
Protected procedure SetUseQuadraticAttenuation(val: boolean);

Properties

Published property AllowReverseProjection: boolean read FAllowReverseProjection write SetAllowReverseProjection;
Published property Aspect: single read FAspect write FAspect;

x/y ratio. For no distortion, this should be set to texture.width/texture.height.

Published property Attenuation: single read FAttenuation write FAttenuation;

Fall off/ attenuation of the projected texture

Published property Behaviours;
Published property Brightness: single read FBrightness write FBrightness;
Published property Color: TGLColor read FColor write FColor;
Published property Direction;
Published property Effects;
Published property FOV: single read FFOV write FFOV;

Indicates the field-of-view of the projection frustum.

Published property ObjectsSorting;
Published property OnProgress;
Published property PitchAngle;
Published property Position;
Published property RollAngle;
Published property Scale;
Published property ShowAxes;
Published property Style: TGLSLProjectedTexturesStyle read FStyle write SetStyle;

Indicates the style of the projected textures.

Published property TurnAngle;
Published property Up;
Published property UseAttenuation: boolean read FUseAttenuation write SetUseAttenuation;
Published property UseQuadraticAttenuation: Boolean read FUseQuadraticAttenuation write SetUseQuadraticAttenuation;
Published property VisibilityCulling;
Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSLProjectedTextures: Class TGLSLTextureEmitterItem

Class TGLSLTextureEmitterItem

Unit

GLSLProjectedTextures

Declaration

type TGLSLTextureEmitterItem = class(TCollectionItem)

Description

Specifies an item on the TGLSLTextureEmitters collection.

Hierarchy

  • TCollectionItem
  • TGLSLTextureEmitterItem

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure RemoveNotification(aComponent: TComponent);
Protected | procedure SetEmitter(const val: TGLSLTextureEmitter);

Properties

Published property Emitter: TGLSLTextureEmitter read FEmitter write SetEmitter;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;
Protected procedure RemoveNotification(aComponent: TComponent);
Protected procedure SetEmitter(const val: TGLSLTextureEmitter);

Properties

Published property Emitter: TGLSLTextureEmitter read FEmitter write SetEmitter;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSLProjectedTextures: Class TGLSLTextureEmitters

Class TGLSLTextureEmitters

Unit

GLSLProjectedTextures

Declaration

type TGLSLTextureEmitters = class(TCollection)

Description

Collection of TGLSLTextureEmitter.

Hierarchy

  • TCollection
  • TGLSLTextureEmitters

Overview

Methods

Protected | function GetItems(index: Integer): TGLSLTextureEmitterItem;
Protected | function GetOwner: TPersistent; override;
Public | procedure AddEmitter(texEmitter: TGLSLTextureEmitter);
Protected | procedure RemoveNotification(aComponent: TComponent);

Properties

Public property Items[index: Integer]: TGLSLTextureEmitterItem read GetItems;

Description

Methods

Protected function GetItems(index: Integer): TGLSLTextureEmitterItem;
Protected function GetOwner: TPersistent; override;
Public procedure AddEmitter(texEmitter: TGLSLTextureEmitter);
Protected procedure RemoveNotification(aComponent: TComponent);

Properties

Public property Items[index: Integer]: TGLSLTextureEmitterItem read GetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSLProjectedTextures: Class TGLSLProjectedTextures

Class TGLSLProjectedTextures

Unit

GLSLProjectedTextures

Declaration

type TGLSLProjectedTextures = class(TGLSceneObject)

Description

Projected Texture Manager.<p> Specifies active Emitters and receivers (children of this object). At the moment, only 1 texture can be used.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLSLProjectedTextures

Overview

Fields

Protected ShaderChanged: boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure StructureChanged; override;
Protected | procedure SetUseLightmaps(val: boolean);

Properties

Published | property Ambient: TGLColor read fAmbient write fAmbient;
Published | property Emitters: TGLSLTextureEmitters read FEmitters write FEmitters;
Published | property UseLightmaps: boolean read FUseLightmaps write SetUseLightmaps;

Description

Fields

Protected ShaderChanged: boolean;

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public procedure StructureChanged; override;
Protected procedure SetUseLightmaps(val: boolean);

Properties

Published property Ambient: TGLColor read fAmbient write fAmbient;
Published property Emitters: TGLSLTextureEmitters read FEmitters write FEmitters;

List of emitters.

Published property UseLightmaps: boolean read FUseLightmaps write SetUseLightmaps;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSLShader

Unit GLSLShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSLShader<p>

TGLSLShader is a wrapper for GLS shaders.<p>

<b>History : </b><font size=-1><ul> <li>09/02/13 - Yar - Added OnApplyEx event where is TGLLibMaterial as Sender (thanks to Dmitriy Buharin) <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>18/02/11 - Yar - Fixed transform feedback varyings activation <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>02/06/10 - Yar - Replace OpenGL functions to OpenGLAdapter Added unsigned integer uniforms <li>22/04/10 - Yar - Fixes after GLState revision <li>02/04/10 - Yar - Added GetActiveAttribs to TGLCustomGLSLShader <li>04/11/09 - DaStr - Added default value to TGLCustomGLSLShader.TransformFeedBackMode <li>26/10/09 - DaStr - Updated GeometryShader support (thanks YarUnderoaker) <li>24/08/09 - DaStr - Added GeometryShader support (thanks YarUnderoaker) <li>24/07/09 - DaStr - Added support for TGLCustomShader.DebugMode Fixed spelling mistake in TGLShaderUnAplyEvent TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) Bugfixed TGLCustomGLSLShader.DoInitialize() - now shader cleanes up correctly if failed to initialize <li>15/03/08 - DaStr - Fixups for vIgnoreContextActivationFailures mode (BugTracker ID = 1914782) <li>25/12/07 - DaStr - Fix-up for previous update (BugtrackerID = 1772477) <li>12/08/07 - LC - TGLSLShaderParameter.SetAsCustomTexture now restores the active texture unit (BugtrackerID = 1772477) <li>12/07/07 - DaStr - TGLSLInitializedShaderParameters removed because even if implemented, it could not give a significant performance increase <li>30/03/07 - fig - Changed OnInitialize event to be fired after linking, but before validation. This can now be used to set texture units for different sampler types (1D/2D/3D) before validation, which fixes a bug (or complies to strict validation) with ATI drivers <li>30/03/07 - DaStr - Bugfixed TGLCustomGLSLShader.DoUnApply (Result was not initialized) <li>20/03/07 - DaStr - TGLCustomGLSLShader now generates its own events Added TGLSLShaderParameter Added TGLCustomGLSLShader.DoInitialPass Added TGLCustomGLSLShader.Param[] <li>21/02/07 - DaStr - Initial version (contributed to GLScene)

Previous version history: v1.0 11 March '2006 Creation v1.1 06 August '2006 TGLCustomGLSLShader.DoInitialize bugfixed v1.1.2 24 August '2006 TGLCustomShader.SetParameterTexture[1-3]D added v1.1.4 09 September '2006 Fixed a memory leak which occured when enabling / disabling the shader several times v1.1.6 22 September '2006 DoUnApply fixed (suggested by Nelsol Chu) v1.2 04 November '2006 function GetGLSLProg added (just in case) TGLSLShader has more published properties Bugfix in DoInitialize (when no shader is active) (Get/Set)ParameterTexture[1/2/3]DHandle added (Get/Set)ParameterCustomTextureHandle support added v1.2.4 22 November '2006 TGLProgramHandle.Name is now used Assign() bugfixed Fixed a possible bug in DoInitialize (Handle was freed, but not nil'ed)

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLSLShaderException |
record TGLActiveAttrib |
Class TGLCustomGLSLShader |
Class TGLSLShaderParameter |
Class TGLSLShader |

Types

TGLSLShaderEvent = procedure(Shader: TGLCustomGLSLShader) of object;
TGLSLShaderUnApplyEvent = procedure(Shader: TGLCustomGLSLShader; var ThereAreMorePasses: Boolean) of object;
TGLSLShaderEventEx = procedure(Shader: TGLCustomGLSLShader; Sender: TObject) of object;
TGLActiveAttribArray = array of TGLActiveAttrib;

Description

Types

TGLSLShaderEvent = procedure(Shader: TGLCustomGLSLShader) of object;
TGLSLShaderUnApplyEvent = procedure(Shader: TGLCustomGLSLShader; var ThereAreMorePasses: Boolean) of object;
TGLSLShaderEventEx = procedure(Shader: TGLCustomGLSLShader; Sender: TObject) of object;
TGLActiveAttribArray = array of TGLActiveAttrib;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSLShader: Class EGLSLShaderException

Class EGLSLShaderException

Unit

GLSLShader

Declaration

type EGLSLShaderException = class(EGLCustomShaderException)

Description

no description available, EGLCustomShaderException description follows
no description available, EGLShaderException description follows

Hierarchy

  • Exception
  • EGLShaderException
  • EGLCustomShaderException
  • EGLSLShaderException
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSLShader: record TGLActiveAttrib

record TGLActiveAttrib

Unit

GLSLShader

Declaration

type TGLActiveAttrib = record

Description

Overview

Fields

Name: string;
Size: GLInt;
AType: TGLSLDataType;
Location: Integer;

Description

Fields

Name: string;
Size: GLInt;
AType: TGLSLDataType;
Location: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSLShader: Class TGLCustomGLSLShader

Class TGLCustomGLSLShader

Unit

GLSLShader

Declaration

type TGLCustomGLSLShader = class(TGLCustomShader)

Description

no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function GetActiveAttribs: TGLActiveAttribArray;
Public | function ShaderSupported: Boolean; override;
Protected | function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected | function GetCurrentParam: TGLSLShaderParameter; virtual;
Protected | function GetGLSLProg: TGLProgramHandle; virtual;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected | procedure DoFinalize; override;
Protected | procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;
Protected | procedure DoInitialPass; virtual;
Protected | procedure SetActiveVarying(const Value: TStrings);
Protected | procedure SetTransformFeedBackMode(const Value: TGLTransformFeedBackMode);

Properties

Public | property ActiveVarying: TStrings read FActiveVarying write SetActiveVarying;
Public | property DirectParam[const Index: Cardinal]: TGLSLShaderParameter read GetDirectParam;
Protected | property OnApply: TGLSLShaderEvent read FOnApply write FOnApply;
Protected | property OnApplyEx: TGLSLShaderEventEx read FOnApplyEx write FOnApplyEx;
Protected | property OnInitialize: TGLSLShaderEvent read FOnInitialize write FOnInitialize;
Protected | property OnUnApply: TGLSLShaderUnApplyEvent read FOnUnApply write FOnUnApply;
Public | property Param[const Index: string]: TGLSLShaderParameter read GetParam;
Public | property TransformFeedBackMode: TGLTransformFeedBackMode read FTransformFeedBackMode write SetTransformFeedBackMode default tfbmInterleaved;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function GetActiveAttribs: TGLActiveAttribArray;
Public function ShaderSupported: Boolean; override;
Protected function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected function GetCurrentParam: TGLSLShaderParameter; virtual;
Protected function GetGLSLProg: TGLProgramHandle; virtual;
Public procedure Assign(Source: TPersistent); override;
Protected procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected procedure DoFinalize; override;
Protected procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;
Protected procedure DoInitialPass; virtual;
Protected procedure SetActiveVarying(const Value: TStrings);
Protected procedure SetTransformFeedBackMode(const Value: TGLTransformFeedBackMode);

Properties

Public property ActiveVarying: TStrings read FActiveVarying write SetActiveVarying;
Public property DirectParam[const Index: Cardinal]: TGLSLShaderParameter read GetDirectParam;
Protected property OnApply: TGLSLShaderEvent read FOnApply write FOnApply;
Protected property OnApplyEx: TGLSLShaderEventEx read FOnApplyEx write FOnApplyEx;
Protected property OnInitialize: TGLSLShaderEvent read FOnInitialize write FOnInitialize;
Protected property OnUnApply: TGLSLShaderUnApplyEvent read FOnUnApply write FOnUnApply;
Public property Param[const Index: string]: TGLSLShaderParameter read GetParam;
Public property TransformFeedBackMode: TGLTransformFeedBackMode read FTransformFeedBackMode write SetTransformFeedBackMode default tfbmInterleaved;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSLShader: Class TGLSLShaderParameter

Class TGLSLShaderParameter

Unit

GLSLShader

Declaration

type TGLSLShaderParameter = class(TGLCustomShaderParameter)

Description

Wrapper around a parameter of a GLSL program.

Hierarchy

  • TObject
  • TGLCustomShaderParameter
  • TGLSLShaderParameter

Overview

Methods

Protected | function GetAsCustomTexture(const TextureIndex: Integer; TextureTarget: TGLTextureTarget): Cardinal; override;
Protected | function GetAsMatrix2f: TMatrix2f; override;
Protected | function GetAsMatrix3f: TMatrix3f; override;
Protected | function GetAsMatrix4f: TMatrix4f; override;
Protected | function GetAsUniformBuffer: GLenum; override;
Protected | function GetAsVector1f: Single; override;
Protected | function GetAsVector1i: Integer; override;
Protected | function GetAsVector1ui: GLuint; override;
Protected | function GetAsVector2f: TVector2f; override;
Protected | function GetAsVector2i: TVector2i; override;
Protected | function GetAsVector2ui: TVector2ui; override;
Protected | function GetAsVector3f: TVector3f; override;
Protected | function GetAsVector3i: TVector3i; override;
Protected | function GetAsVector3ui: TVector3ui; override;
Protected | function GetAsVector4f: TVector; override;
Protected | function GetAsVector4i: TVector4i; override;
Protected | function GetAsVector4ui: TVector4ui; override;
Protected | procedure SetAsCustomTexture(const TextureIndex: Integer; TextureTarget: TGLTextureTarget; const Value: Cardinal); override;
Protected | procedure SetAsMatrix2f(const Value: TMatrix2f); override;
Protected | procedure SetAsMatrix3f(const Value: TMatrix3f); override;
Protected | procedure SetAsMatrix4f(const Value: TMatrix4f); override;
Protected | procedure SetAsUniformBuffer( UBO: GLenum); override;
Protected | procedure SetAsVector1f(const Value: Single); override;
Protected | procedure SetAsVector1i(const Value: Integer); override;
Protected | procedure SetAsVector1ui(const Value: GLuint); override;
Protected | procedure SetAsVector2f(const Value: TVector2f); override;
Protected | procedure SetAsVector2i(const Value: TVector2i); override;
Protected | procedure SetAsVector2ui(const Value: TVector2ui); override;
Protected | procedure SetAsVector3f(const Value: TVector3f); override;
Protected | procedure SetAsVector3i(const Value: TVector3i); override;
Protected | procedure SetAsVector3ui(const Value: TVector3ui); override;
Protected | procedure SetAsVector4f(const Value: TVector4f); override;
Protected | procedure SetAsVector4i(const Value: TVector4i); override;
Protected | procedure SetAsVector4ui(const Value: TVector4ui); override;

Description

Methods

Protected function GetAsCustomTexture(const TextureIndex: Integer; TextureTarget: TGLTextureTarget): Cardinal; override;
Protected function GetAsMatrix2f: TMatrix2f; override;
Protected function GetAsMatrix3f: TMatrix3f; override;
Protected function GetAsMatrix4f: TMatrix4f; override;
Protected function GetAsUniformBuffer: GLenum; override;
Protected function GetAsVector1f: Single; override;
Protected function GetAsVector1i: Integer; override;
Protected function GetAsVector1ui: GLuint; override;
Protected function GetAsVector2f: TVector2f; override;
Protected function GetAsVector2i: TVector2i; override;
Protected function GetAsVector2ui: TVector2ui; override;
Protected function GetAsVector3f: TVector3f; override;
Protected function GetAsVector3i: TVector3i; override;
Protected function GetAsVector3ui: TVector3ui; override;
Protected function GetAsVector4f: TVector; override;
Protected function GetAsVector4i: TVector4i; override;
Protected function GetAsVector4ui: TVector4ui; override;
Protected procedure SetAsCustomTexture(const TextureIndex: Integer; TextureTarget: TGLTextureTarget; const Value: Cardinal); override;
Protected procedure SetAsMatrix2f(const Value: TMatrix2f); override;
Protected procedure SetAsMatrix3f(const Value: TMatrix3f); override;
Protected procedure SetAsMatrix4f(const Value: TMatrix4f); override;
Protected procedure SetAsUniformBuffer( UBO: GLenum); override;
Protected procedure SetAsVector1f(const Value: Single); override;
Protected procedure SetAsVector1i(const Value: Integer); override;
Protected procedure SetAsVector1ui(const Value: GLuint); override;
Protected procedure SetAsVector2f(const Value: TVector2f); override;
Protected procedure SetAsVector2i(const Value: TVector2i); override;
Protected procedure SetAsVector2ui(const Value: TVector2ui); override;
Protected procedure SetAsVector3f(const Value: TVector3f); override;
Protected procedure SetAsVector3i(const Value: TVector3i); override;
Protected procedure SetAsVector3ui(const Value: TVector3ui); override;
Protected procedure SetAsVector4f(const Value: TVector4f); override;
Protected procedure SetAsVector4i(const Value: TVector4i); override;
Protected procedure SetAsVector4ui(const Value: TVector4ui); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSLShader: Class TGLSLShader

Class TGLSLShader

Unit

GLSLShader

Declaration

type TGLSLShader = class(TGLCustomGLSLShader)

Description

no description available, TGLCustomGLSLShader description follows
no description available, TGLCustomShader description follows

A pure abstract class, must be overriden.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLCustomShader
  • TGLCustomGLSLShader
  • TGLSLShader

Overview

Properties

Published | property ActiveVarying;
Published | property FailedInitAction;
Published | property FragmentProgram;
Published | property GeometryProgram;
Published | property OnApply;
Published | property OnApplyEx;
Published | property OnInitialize;
Published | property OnUnApply;
Published | property ShaderStyle;
Published | property TransformFeedBackMode;
Published | property VertexProgram;

Description

Properties

Published property ActiveVarying;
Published property FailedInitAction;
Published property FragmentProgram;
Published property GeometryProgram;
Published property OnApply;
Published property OnApplyEx;
Published property OnInitialize;
Published property OnUnApply;
Published property ShaderStyle;
Published property TransformFeedBackMode;
Published property VertexProgram;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSMBASS

Unit GLSMBASS

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSMBASS<p>

BASS based sound-manager (http://www.un4seen.com/music/, free for freeware).<p>

Unsupported feature(s) :<ul> <li>sound source velocity <li>looping (sounds are played either once or forever) <li>source priorities (not relevant, channels are not limited) </ul><p>

<b>History : </b><font size=-1><ul> <li>07/01/10 - DaStr - Fixed a bug with an initial Paused or Muted state of sound source and with sscSample in aSource.Changes <li>07/11/09 - DaStr - Improved FPC compatibility (thanks Predator) (BugtrackerID = 2893580) <li>21/03/08 - DanB - Updated to BASS Version 2.3 <li>15/03/08 - DaStr - Added $I GLScene.inc <li>09/05/04 - GAK - Updated to BASS Version 2.0, and swapped to Dynamic DLL loading <li>24/09/02 - EG - BASS activation errors no longer result in Asserts (ignored) <li>27/02/02 - EG - Added 3D Factors and Environment support <li>05/02/02 - EG - BASS 1.4 compatibility <li>05/02/01 - EG - Fixed TGLSMBASS.CPUUsagePercent <li>13/01/01 - EG - Creation (compat BASS 0.8) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSMBASS |

Functions and Procedures

procedure Register;

Types

TBASS3DAlgorithm = (...);

Description

Functions and Procedures

procedure Register;

Types

TBASS3DAlgorithm = (...);
Values
  • algDefault:
  • algOff:
  • algFull:
  • algLight:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSMBASS: Class TGLSMBASS

Class TGLSMBASS

Unit

GLSMBASS

Declaration

type TGLSMBASS = class(TGLSoundManager)

Description

no description available, TGLSoundManager description follows

Base class for sound manager components.<p> The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this).<p> Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLSoundManager
  • TGLSMBASS

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Public | function CPUUsagePercent : Single; override;
Public | function EAXSupported : Boolean; override;
Protected | function DoActivate : Boolean; override;
Protected | function GetDefaultFrequency(aSource : TGLBaseSoundSource) : Integer;
Public | procedure UpdateSources; override;
Protected | procedure DoDeActivate; override;
Protected | procedure KillSource(aSource : TGLBaseSoundSource); override;
Protected | procedure MuteSource(aSource : TGLBaseSoundSource; muted : Boolean); override;
Protected | procedure Notify3DFactorsChanged; override;
Protected | procedure NotifyEnvironmentChanged; override;
Protected | procedure NotifyMasterVolumeChange; override;
Protected | procedure PauseSource(aSource : TGLBaseSoundSource; paused : Boolean); override;
Protected | procedure UpdateSource(aSource : TGLBaseSoundSource); override;

Properties

Published property Algorithm3D : TBASS3DAlgorithm read FAlgorithm3D write FAlgorithm3D default algDefault;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Public function CPUUsagePercent : Single; override;
Public function EAXSupported : Boolean; override;
Protected function DoActivate : Boolean; override;
Protected function GetDefaultFrequency(aSource : TGLBaseSoundSource) : Integer;
Public procedure UpdateSources; override;
Protected procedure DoDeActivate; override;
Protected procedure KillSource(aSource : TGLBaseSoundSource); override;
Protected procedure MuteSource(aSource : TGLBaseSoundSource; muted : Boolean); override;
Protected procedure Notify3DFactorsChanged; override;
Protected procedure NotifyEnvironmentChanged; override;
Protected procedure NotifyMasterVolumeChange; override;
Protected procedure PauseSource(aSource : TGLBaseSoundSource; paused : Boolean); override;
Protected procedure UpdateSource(aSource : TGLBaseSoundSource); override;

Properties

Published property Algorithm3D : TBASS3DAlgorithm read FAlgorithm3D write FAlgorithm3D default algDefault;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSMemo

Unit GLSMemo

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSMemo<p>

<b>History : </b><font size=-1><ul> <li>30/03/11 - Yar - Initial version (based on kpMemo by Konstantin Polyakov http://kpolyakov.narod.ru/) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TCellSize |
record TCellPos |
record TFullPos |
Class TLineProp |
Class TCharStyle |
Class TStyleList |
Class TGLAbstractMemoObject |
Class TGLSMemoAbstractScrollableObject |
Class TGLSMemoScrollBar |
Class TGLSMemoStrings |
Class TGLSMemoGutter |
Class TGLSMemoUndo |
Class TGLSMemoInsCharUndo |
Class TGLSMemoDelCharUndo |
Class TGLSMEmoDelLineUndo |
Class TGLSMemoSelUndo |
Class TGLSMemoDeleteBufUndo |
Class TGLSMemoPasteUndo |
Class TGLSMemoUndoList |
Class TGLSCustomMemo |
Class TGLSMemo |
Class TGLSMemoStringList |
Class TGLSSynHiMemo |

Functions and Procedures

procedure Border(Canvas: TCanvas; rct: TRect; BorderType: TBorderType);

Types

TBorderType = (...);
TCommand = Integer;
TsbState = (...);
TGutterClickEvent = procedure(Sender: TObject; LineNo: integer) of object;
TGutterDrawEvent = procedure(Sender: TObject; ACanvas: TCanvas; LineNo: integer; rct: TRect) of object;
TGetLineAttrsEvent = procedure(Sender: TObject; LineNo: integer; var Attrs: string) of object;
TUndoChangeEvent = procedure(Sender: TObject; CanUndo, CanRedo: Boolean) of object;
TScrollMode = (...);
TDelimiters = TSysCharSet;
TTokenType = (...);

Description

Functions and Procedures

procedure Border(Canvas: TCanvas; rct: TRect; BorderType: TBorderType);

Types

TBorderType = (...);
Values
  • btRaised:
  • btLowered:
  • btFlatRaised:
  • btFlatLowered:
TCommand = Integer;
TsbState = (...);
Values
  • sbsWait:
  • sbsBack:
  • sbsForward:
  • sbsPageBack:
  • sbsPageForward:
  • sbsDragging:
TGutterClickEvent = procedure(Sender: TObject; LineNo: integer) of object;
TGutterDrawEvent = procedure(Sender: TObject; ACanvas: TCanvas; LineNo: integer; rct: TRect) of object;
TGetLineAttrsEvent = procedure(Sender: TObject; LineNo: integer; var Attrs: string) of object;
TUndoChangeEvent = procedure(Sender: TObject; CanUndo, CanRedo: Boolean) of object;
TScrollMode = (...);
Values
  • smAuto:
  • smStrict:
TDelimiters = TSysCharSet;
TTokenType = (...);
Values
  • ttWord:
  • ttBracket:
  • ttSpecial:
  • ttDelimiter:
  • ttSpace:
  • ttEOL:
  • ttInteger:
  • ttFloat:
  • ttComment:
  • ttOther:
  • ttWrongNumber:
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSMemo: record TCellSize

record TCellSize

Unit

GLSMemo

Declaration

type TCellSize = record

Description

Overview

Fields

W: integer;
H: integer;

Description

Fields

W: integer;
H: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSMemo: record TCellPos

record TCellPos

Unit

GLSMemo

Declaration

type TCellPos = record

Description

Overview

Fields

X: integer;
Y: integer;

Description

Fields

X: integer;
Y: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSMemo: record TFullPos

record TFullPos

Unit

GLSMemo

Declaration

type TFullPos = record

Description

Overview

Fields

LineNo: integer;
Pos: integer;

Description

Fields

LineNo: integer;
Pos: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSMemo: Class TLineProp

Class TLineProp

Unit

GLSMemo

Declaration

type TLineProp = class(TObject)

Description

Hierarchy

  • TObject
  • TLineProp

Overview

Fields

Published | FObject: TObject;
Published | FStyleNo: integer;
Published | FInComment: Boolean;
Published | FInBrackets: integer;
Published | FValidAttrs: Boolean;
Published | FCharAttrs: string;

Description

Fields

Published FObject: TObject;
Published FStyleNo: integer;
Published FInComment: Boolean;
Published FInBrackets: integer;
Published FValidAttrs: Boolean;
Published FCharAttrs: string;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSMemo: Class TCharStyle

Class TCharStyle

Unit

GLSMemo

Declaration

type TCharStyle = class(TPersistent)

Description

Hierarchy

  • TPersistent
  • TCharStyle

Overview

Properties

Published | property BkColor: TColor read FBkColor write FBkColor;
Published | property Style: TFontStyles read FStyle write FStyle;
Published | property TextColor: TColor read FTextColor write FTextColor;

Description

Properties

Published property BkColor: TColor read FBkColor write FBkColor;
Published property Style: TFontStyles read FStyle write FStyle;
Published property TextColor: TColor read FTextColor write FTextColor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSMemo: Class TStyleList

Class TStyleList

Unit

GLSMemo

Declaration

type TStyleList = class(TList)

Description

Hierarchy

  • TList
  • TStyleList

Overview

Methods

Public | destructor Destroy; override;
Public | function Add(ATextColor, ABkCOlor: TColor; AStyle: TFontStyles): Integer;
Public | procedure Change(Index: integer; ATextColor, ABkColor: TColor; AStyle: TFontStyles);
Public | procedure Clear; override;
Public | procedure Delete(Index: Integer);

Properties

Protected | property BkColor[Index: Integer]: TColor read GetBkColor write SetBkColor;
Protected | property Style[Index: Integer]: TFontStyles read GetStyle write SetStyle;
Protected | property TextColor[Index: Integer]: TColor read GetTextColor write SetTextColor;

Description

Methods

Public destructor Destroy; override;
Public function Add(ATextColor, ABkCOlor: TColor; AStyle: TFontStyles): Integer;
Public procedure Change(Index: integer; ATextColor, ABkColor: TColor; AStyle: TFontStyles);
Public procedure Clear; override;
Public procedure Delete(Index: Integer);

Properties

Protected property BkColor[Index: Integer]: TColor read GetBkColor write SetBkColor;
Protected property Style[Index: Integer]: TFontStyles read GetStyle write SetStyle;
Protected property TextColor[Index: Integer]: TColor read GetTextColor write SetTextColor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSMemo: Class TGLAbstractMemoObject

Class TGLAbstractMemoObject

Unit

GLSMemo

Declaration

type TGLAbstractMemoObject = class(TObject)

Description

Hierarchy

  • TObject
  • TGLAbstractMemoObject

Overview

Methods

Public | function MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual; abstract;
Public | function MouseMove(Shift: TShiftState; X, Y: Integer): Boolean; virtual; abstract;
Public | function MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual; abstract;

Description

Methods

Public function MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual; abstract;
Public function MouseMove(Shift: TShiftState; X, Y: Integer): Boolean; virtual; abstract;
Public function MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual; abstract;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSMemo: Class TGLSMemoAbstractScrollableObject

Class TGLSMemoAbstractScrollableObject

Unit

GLSMemo

Declaration

type TGLSMemoAbstractScrollableObject = class(TCustomControl)

Description

Hierarchy

  • TCustomControl
  • TGLSMemoAbstractScrollableObject

Overview

Methods

Protected | procedure DoScroll(Sender: TGLSMemoScrollBar; ByValue: integer); virtual; abstract;
Protected | procedure DoScrollPage(Sender: TGLSMemoScrollBar; ByValue: integer); virtual; abstract;

Description

Methods

Protected procedure DoScroll(Sender: TGLSMemoScrollBar; ByValue: integer); virtual; abstract;
Protected procedure DoScrollPage(Sender: TGLSMemoScrollBar; ByValue: integer); virtual; abstract;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSMemo: Class TGLSMemoScrollBar

Class TGLSMemoScrollBar

Unit

GLSMemo

Declaration

type TGLSMemoScrollBar = class(TGLAbstractMemoObject)

Description

no description available, TGLAbstractMemoObject description follows

Hierarchy

  • TObject
  • TGLAbstractMemoObject
  • TGLSMemoScrollBar

Overview

Methods

Public | constructor Create(AParent: TGLSMemoAbstractScrollableObject; AKind: TScrollBarKind);
Public | function MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | function MouseMove(Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | function MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | function MoveThumbTo(X, Y: Integer): integer;
Public | procedure PaintTo(ACanvas: TCanvas);

Properties

Public | property BackRect: TRect read GetBackRect;
Public | property ForwardRect: TRect read GetForwardRect;
Public | property FullRect: TRect read GetRect;
Public | property Height: integer index 3 read FHeight write SetParams;
Public | property Kind: TScrollBarKind read FKind write FKind;
Public | property Left: integer index 0 read FLeft write SetParams;
Public | property MaxPosition: integer index 5 read FMaxPosition write SetParams;
Public | property MiddleRect: TRect read GetMiddleRect;
Public | property PageBackRect: TRect read GetPgBackRect;
Public | property PageForwardRect: TRect read GetPgForwardRect;
Public | property Parent: TGLSMemoAbstractScrollableObject read FParent;
Public | property Position: integer index 6 read FPosition write SetParams;
Public | property State: TsbState read FState write SetState;
Public | property ThumbRect: TRect read GetThumbRect;
Public | property Top: integer index 1 read FTop write SetParams;
Public | property Total: integer index 4 read FTotal write SetParams;
Public | property Width: integer index 2 read FWidth write SetParams;

Description

Methods

Public constructor Create(AParent: TGLSMemoAbstractScrollableObject; AKind: TScrollBarKind);
Public function MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public function MouseMove(Shift: TShiftState; X, Y: Integer): Boolean; override;
Public function MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public function MoveThumbTo(X, Y: Integer): integer;
Public procedure PaintTo(ACanvas: TCanvas);

Properties

Public property BackRect: TRect read GetBackRect;
Public property ForwardRect: TRect read GetForwardRect;
Public property FullRect: TRect read GetRect;
Public property Height: integer index 3 read FHeight write SetParams;
Public property Kind: TScrollBarKind read FKind write FKind;
Public property Left: integer index 0 read FLeft write SetParams;
Public property MaxPosition: integer index 5 read FMaxPosition write SetParams;
Public property MiddleRect: TRect read GetMiddleRect;
Public property PageBackRect: TRect read GetPgBackRect;
Public property PageForwardRect: TRect read GetPgForwardRect;
Public property Parent: TGLSMemoAbstractScrollableObject read FParent;
Public property Position: integer index 6 read FPosition write SetParams;
Public property State: TsbState read FState write SetState;
Public property ThumbRect: TRect read GetThumbRect;
Public property Top: integer index 1 read FTop write SetParams;
Public property Total: integer index 4 read FTotal write SetParams;
Public property Width: integer index 2 read FWidth write SetParams;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:51


GLScene v.1.1.2: GLSMemo: Class TGLSMemoStrings

Class TGLSMemoStrings

Unit

GLSMemo

Declaration

type TGLSMemoStrings = class(TStringList)

Description

Hierarchy

  • TStringList
  • TGLSMemoStrings

Overview

Methods

Public | destructor Destroy; override;
Public | function Add(const S: string): Integer; override;
Public | function AddObject(const S: string; AObject: TObject): Integer; override;
Public | function DoAdd(const S: string): Integer;
Protected | function CreateProp(Index: integer): TLineProp;
Protected | function GetObject(Index: Integer): TObject; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Clear; override;
Public | procedure Delete(Index: Integer); override;
Public | procedure DoInsert(Index: Integer; const S: string);
Public | procedure Insert(Index: Integer; const S: string); override;
Public | procedure InsertObject(Index: Integer; const S: string; AObject: TObject); override;
Public | procedure LoadFromFile(const FileName: string); override;
Protected | procedure PutObject(Index: Integer; AObject: TObject); override;
Protected | procedure SetUpdateState(Updating: Boolean); override;

Properties

Protected | property CharAttrs[Index: integer]: string read GetCharAttrs write SetCharAttrs;
Protected | property InBrackets[Index: integer]: integer read GetInBrackets write SetInBrackets;
Protected | property InComment[Index: integer]: Boolean read GetInComment write SetInComment;
Protected | property LineProp[Index: integer]: TLineProp read GetLineProp;
Protected | property Style[Index: integer]: integer read GetLineStyle write SetLineStyle;
Protected | property ValidAttrs[Index: integer]: Boolean read GetValidAttrs write SetValidAttrs;

Description

Methods

Public destructor Destroy; override;
Public function Add(const S: string): Integer; override;
Public function AddObject(const S: string; AObject: TObject): Integer; override;
Public function DoAdd(const S: string): Integer;
Protected function CreateProp(Index: integer): TLineProp;
Protected function GetObject(Index: Integer): TObject; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure Clear; override;
Public procedure Delete(Index: Integer); override;
Public procedure DoInsert(Index: Integer; const S: string);
Public procedure Insert(Index: Integer; const S: string); override;
Public procedure InsertObject(Index: Integer; const S: string; AObject: TObject); override;
Public procedure LoadFromFile(const FileName: string); override;
Protected procedure PutObject(Index: Integer; AObject: TObject); override;
Protected procedure SetUpdateState(Updating: Boolean); override;

Properties

Protected property CharAttrs[Index: integer]: string read GetCharAttrs write SetCharAttrs;
Protected property InBrackets[Index: integer]: integer read GetInBrackets write SetInBrackets;
Protected property InComment[Index: integer]: Boolean read GetInComment write SetInComment;
Protected property LineProp[Index: integer]: TLineProp read GetLineProp;
Protected property Style[Index: integer]: integer read GetLineStyle write SetLineStyle;
Protected property ValidAttrs[Index: integer]: Boolean read GetValidAttrs write SetValidAttrs;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:52


GLScene v.1.1.2: GLSMemo: Class TGLSMemoGutter

Class TGLSMemoGutter

Unit

GLSMemo

Declaration

type TGLSMemoGutter = class(TObject)

Description

Hierarchy

  • TObject
  • TGLSMemoGutter

Overview

Methods

Protected | procedure Invalidate;
Protected | procedure PaintTo(ACanvas: TCanvas);

Properties

Public | property FullRect: TRect read GetRect;
Public | property Height: integer index 3 read FHeight write SetParams;
Public | property Left: integer index 0 read FLeft write SetParams;
Public | property Top: integer index 1 read FTop write SetParams;
Public | property Width: integer index 2 read FWidth write SetParams;

Description

Methods

Protected procedure Invalidate;
Protected procedure PaintTo(ACanvas: TCanvas);

Properties

Public property FullRect: TRect read GetRect;
Public property Height: integer index 3 read FHeight write SetParams;
Public property Left: integer index 0 read FLeft write SetParams;
Public property Top: integer index 1 read FTop write SetParams;
Public property Width: integer index 2 read FWidth write SetParams;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:52


GLScene v.1.1.2: GLSMemo: Class TGLSMemoUndo

Class TGLSMemoUndo

Unit

GLSMemo

Declaration

type TGLSMemoUndo = class(TObject)

Description

Hierarchy

  • TObject
  • TGLSMemoUndo

Overview

Methods

Public | constructor Create(ACurX0, ACurY0, ACurX, ACurY: integer; AText: string);
Public | function Append(NewUndo: TGLSMemoUndo): Boolean; virtual;
Public | procedure PerformRedo; virtual; abstract;
Public | procedure PerformUndo; virtual; abstract;
Public | procedure Redo;
Public | procedure Undo;

Properties

Public | property UndoCurX: integer read FUndoCurX write FUndoCurX;
Public | property UndoCurX0: integer read FUndoCurX0 write FUndoCurX0;
Public | property UndoCurY: integer read FUndoCurY write FUndoCurY;
Public | property UndoCurY0: integer read FUndoCurY0 write FUndoCurY0;

Description

Methods

Public constructor Create(ACurX0, ACurY0, ACurX, ACurY: integer; AText: string);
Public function Append(NewUndo: TGLSMemoUndo): Boolean; virtual;
Public procedure PerformRedo; virtual; abstract;
Public procedure PerformUndo; virtual; abstract;
Public procedure Redo;
Public procedure Undo;

Properties

Public property UndoCurX: integer read FUndoCurX write FUndoCurX;
Public property UndoCurX0: integer read FUndoCurX0 write FUndoCurX0;
Public property UndoCurY: integer read FUndoCurY write FUndoCurY;
Public property UndoCurY0: integer read FUndoCurY0 write FUndoCurY0;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:52


GLScene v.1.1.2: GLSMemo: Class TGLSMemoInsCharUndo

Class TGLSMemoInsCharUndo

Unit

GLSMemo

Declaration

type TGLSMemoInsCharUndo = class(TGLSMemoUndo)

Description

no description available, TGLSMemoUndo description follows

Hierarchy

  • TObject
  • TGLSMemoUndo
  • TGLSMemoInsCharUndo

Overview

Methods

Public | function Append(NewUndo: TGLSMemoUndo): Boolean; override;
Public | procedure PerformRedo; override;
Public | procedure PerformUndo; override;

Description

Methods

Public function Append(NewUndo: TGLSMemoUndo): Boolean; override;
Public procedure PerformRedo; override;
Public procedure PerformUndo; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:52


GLScene v.1.1.2: GLSMemo: Class TGLSMemoDelCharUndo

Class TGLSMemoDelCharUndo

Unit

GLSMemo

Declaration

type TGLSMemoDelCharUndo = class(TGLSMemoUndo)

Description

no description available, TGLSMemoUndo description follows

Hierarchy

  • TObject
  • TGLSMemoUndo
  • TGLSMemoDelCharUndo

Overview

Methods

Public | function Append(NewUndo: TGLSMemoUndo): Boolean; override;
Public | procedure PerformRedo; override;
Public | procedure PerformUndo; override;

Properties

Public property IsBackspace: Boolean read FIsBackspace write FIsBackspace;

Description

Methods

Public function Append(NewUndo: TGLSMemoUndo): Boolean; override;
Public procedure PerformRedo; override;
Public procedure PerformUndo; override;

Properties

Public property IsBackspace: Boolean read FIsBackspace write FIsBackspace;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:52


GLScene v.1.1.2: GLSMemo: Class TGLSMEmoDelLineUndo

Class TGLSMEmoDelLineUndo

Unit

GLSMemo

Declaration

type TGLSMEmoDelLineUndo = class(TGLSMemoUndo)

Description

no description available, TGLSMemoUndo description follows

Hierarchy

  • TObject
  • TGLSMemoUndo
  • TGLSMEmoDelLineUndo

Overview

Methods

Public | constructor Create(AIndex, ACurX0, ACurY0, ACurX, ACurY: integer; AText: string);
Public | procedure PerformRedo; override;
Public | procedure PerformUndo; override;

Description

Methods

Public constructor Create(AIndex, ACurX0, ACurY0, ACurX, ACurY: integer; AText: string);
Public procedure PerformRedo; override;
Public procedure PerformUndo; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:52


GLScene v.1.1.2: GLSMemo: Class TGLSMemoSelUndo

Class TGLSMemoSelUndo

Unit

GLSMemo

Declaration

type TGLSMemoSelUndo = class(TGLSMemoUndo)

Description

no description available, TGLSMemoUndo description follows

Hierarchy

  • TObject
  • TGLSMemoUndo
  • TGLSMemoSelUndo

Overview

Properties

Public | property UndoSelEndX: integer read FUndoSelEndX write FUndoSelEndX;
Public | property UndoSelEndY: integer read FUndoSelEndY write FUndoSelEndY;
Public | property UndoSelStartX: integer read FUndoSelStartX write FUndoSelStartX;
Public | property UndoSelStartY: integer read FUndoSelStartY write FUndoSelStartY;

Description

Properties

Public property UndoSelEndX: integer read FUndoSelEndX write FUndoSelEndX;
Public property UndoSelEndY: integer read FUndoSelEndY write FUndoSelEndY;
Public property UndoSelStartX: integer read FUndoSelStartX write FUndoSelStartX;
Public property UndoSelStartY: integer read FUndoSelStartY write FUndoSelStartY;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:52


GLScene v.1.1.2: GLSMemo: Class TGLSMemoDeleteBufUndo

Class TGLSMemoDeleteBufUndo

Unit

GLSMemo

Declaration

type TGLSMemoDeleteBufUndo = class(TGLSMemoSelUndo)

Description

no description available, TGLSMemoSelUndo description follows
no description available, TGLSMemoUndo description follows

Hierarchy

  • TObject
  • TGLSMemoUndo
  • TGLSMemoSelUndo
  • TGLSMemoDeleteBufUndo

Overview

Methods

Public | procedure PerformRedo; override;
Public | procedure PerformUndo; override;

Description

Methods

Public procedure PerformRedo; override;
Public procedure PerformUndo; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:52


GLScene v.1.1.2: GLSMemo: Class TGLSMemoPasteUndo

Class TGLSMemoPasteUndo

Unit

GLSMemo

Declaration

type TGLSMemoPasteUndo = class(TGLSMemoUndo)

Description

no description available, TGLSMemoUndo description follows

Hierarchy

  • TObject
  • TGLSMemoUndo
  • TGLSMemoPasteUndo

Overview

Methods

Public | procedure PerformRedo; override;
Public | procedure PerformUndo; override;

Description

Methods

Public procedure PerformRedo; override;
Public procedure PerformUndo; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:52


GLScene v.1.1.2: GLSMemo: Class TGLSMemoUndoList

Class TGLSMemoUndoList

Unit

GLSMemo

Declaration

type TGLSMemoUndoList = class(TList)

Description

Hierarchy

  • TList
  • TGLSMemoUndoList

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function Add(Item: Pointer): Integer;
Protected | function Get(Index: Integer): TGLSMemoUndo;
Public | procedure Clear; override;
Public | procedure Delete(Index: Integer);
Public | procedure Redo;
Public | procedure Undo;
Protected | procedure SetLimit(Value: integer);

Properties

Public | property IsPerforming: Boolean read FIsPerforming write FIsPerforming;
Public | property Items[Index: Integer]: TGLSMemoUndo read Get;
Public | property Limit: integer read FLimit write SetLimit;
Public | property Memo: TGLSCustomMemo read FMemo write FMemo;
Public | property Pos: integer read FPos write FPos;

Description

Methods

Public constructor Create;
Public destructor Destroy; override;
Public function Add(Item: Pointer): Integer;
Protected function Get(Index: Integer): TGLSMemoUndo;
Public procedure Clear; override;
Public procedure Delete(Index: Integer);
Public procedure Redo;
Public procedure Undo;
Protected procedure SetLimit(Value: integer);

Properties

Public property IsPerforming: Boolean read FIsPerforming write FIsPerforming;
Public property Items[Index: Integer]: TGLSMemoUndo read Get;
Public property Limit: integer read FLimit write SetLimit;
Public property Memo: TGLSCustomMemo read FMemo write FMemo;
Public property Pos: integer read FPos write FPos;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:52


GLScene v.1.1.2: GLSMemo: Class TGLSCustomMemo

Class TGLSCustomMemo

Unit

GLSMemo

Declaration

type TGLSCustomMemo = class(TGLSMemoAbstractScrollableObject)

Description

no description available, TGLSMemoAbstractScrollableObject description follows

Hierarchy

  • TCustomControl
  • TGLSMemoAbstractScrollableObject
  • TGLSCustomMemo

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CanRedo: Boolean;
Public | function CanUndo: Boolean;
Public | function CellFromPos(X, Y: integer): TCellPos;
Public | function CellRect(ACol, ARow: integer): TRect;
Public | function CharFromPos(X, Y: integer): TFullPos;
Public | function CharStyleNo(LineNo, Pos: integer): integer;
Public | function ColRect(ACol: integer): TRect;
Public | function FindText(Text: string; Options: TFindOptions; Select: Boolean): Boolean;
Public | function LineRect(ARow: integer): TRect;
Public | function SelectLine(LineNo, StyleNo: Integer): integer;
Protected | function AddString(S: string): integer;
Protected | function ColRangeRect(FromCol, ToCol: integer): TRect;
Protected | function EditorRect: TRect;
Protected | function IndentCurrLine: string;
Protected | function LineRangeRect(FromLine, ToLine: integer): TRect;
Public | procedure Clear;
Public | procedure ClearSelection;
Public | procedure CopyToClipBoard;
Public | procedure CutToClipBoard;
Public | procedure InsertTemplate(AText: string);
Public | procedure PasteFromClipBoard;
Public | procedure Redo;
Public | procedure SelectAll;
Public | procedure SelectChar(LineNo, Pos, StyleNo: Integer);
Public | procedure SelectLines(StartLine, EndLine: Integer);
Public | procedure SetCursor(ACurX, ACurY: Integer);
Public | procedure Undo;
Public | procedure UnSelectChar;
Protected | procedure AttrChanged(LineNo: integer); virtual;
Protected | procedure BackSpace;
Protected | procedure BackSpaceWord;
Protected | procedure Changed(FromLine, ToLine: integer); virtual;
Protected | procedure ClearUndoList;
Protected | procedure CreateParams(var Params: TCreateParams); override;
Protected | procedure DblClick; override;
Protected | procedure DeleteChar(OldX, OldY: integer);
Protected | procedure DeleteLine(Index, OldX, OldY, NewX, NewY: integer; FixUndo: Boolean);
Protected | procedure DeleteSelection(bRepaint: Boolean);
Protected | procedure DoScroll(Sender: TGLSMemoScrollBar; ByValue: integer); override;
Protected | procedure DoScrollPage(Sender: TGLSMemoScrollBar; ByValue: integer); override;
Protected | procedure DrawGutter;
Protected | procedure DrawMargin;
Protected | procedure DrawScrollBars;
Protected | procedure GoEnd(Shift: TShiftState);
Protected | procedure GoHome(Shift: TShiftState);
Protected | procedure InsertChar(C: Char);
Protected | procedure InsertString(Index: integer; S: string);
Protected | procedure InvalidateLineRange(FromLine, ToLine: integer);
Protected | procedure KeyDown(var Key: Word; Shift: TShiftState); override;
Protected | procedure KeyPress(var Key: Char); override;
Protected | procedure MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Integer); override;
Protected | procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;
Protected | procedure MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer); override;
Protected | procedure NewLine;
Protected | procedure Paint; override;
Protected | procedure SelectionChanged; virtual;
Protected | procedure StatusChanged; virtual;
Protected | procedure UndoChange;
Protected | procedure WndProc(var Message: TMessage); override;

Properties

Protected | property AutoIndent: Boolean read FAutoIndent write FAutoIndent;
Protected | property BkColor: TColor index 0 read FBkColor write SetColor;
Protected | property CharAttrs[Index: integer]: string read GetCharAttrs write SetCharAttrs;
Public | property CurX: integer read FCurX write SetCurX;
Public | property CurY: integer read FCurY write SetCurY;
Public | property DelErase: Boolean read FDelErase write FDelErase;
Protected | property Font: TFont read FFont write SetFont;
Protected | property GutterColor: TColor read GetGutterColor write SetGutterColor;
Protected | property GutterWidth: integer read FGutterWidth write SetGutterWidth;
Protected | property HiddenCaret: Boolean read FHiddenCaret write SetHiddenCaret;
Protected | property HideCursor: Boolean read FHideCursor write FHideCursor;
Protected | property InBrackets[Index: integer]: integer read GetInBrackets write SetInBrackets;
Protected | property InComment[Index: integer]: Boolean read GetInComment write SetInComment;
Protected | property LastVisibleLine: integer index 3 read GetVisible;
Protected | property LastVisiblePos: integer index 2 read GetVisible;
Protected | property Lines: TStrings read FLines write SetLines;
Public | property LineStyle[Index: integer]: integer read GetLineStyle write SetLineStyle;
Protected | property OnAttrChange: TNotifyEvent read FOnAttrChange write FOnAttrChange;
Protected | property OnChange: TNotifyEvent read FOnChange write FOnChange;
Protected | property OnGetLineAttrs: TGetLineAttrsEvent read FOnGetLineAttrs write FOnGetLineAttrs;
Protected | property OnGutterClick: TGutterClickEvent read FOnGutterClick write FOnGutterClick;
Protected | property OnGutterDraw: TGutterDrawEvent read FOnGutterDraw write FOnGutterDraw;
Protected | property OnMoveCursor: TNotifyEvent read FOnMoveCursor write FOnMoveCursor;
Protected | property OnSelectionChange: TNotifyEvent read FOnSelectionChange write FOnSelectionChange;
Protected | property OnStatusChange: TNotifyEvent read FOnStatusChange write FOnStatusChange;
Protected | property OnUndoChange: TUndoChangeEvent read FOnUndoChange write FOnUndoChange;
Protected | property ReadOnly: Boolean read FReadOnly write FReadOnly;
Protected | property ScrollBars: TScrollStyle read FScrollBars write SetScrollBars default ssBoth;
Protected | property ScrollMode: TScrollMode read FScrollMode write FScrollMode default smAuto;
Protected | property SelBkColor: TColor index 2 read FSelBkColor write SetColor;
Protected | property SelColor: TColor index 1 read FSelColor write SetColor;
Public | property Selection: string read GetSelText write SetSelText;
Public | property SelEnd: TPoint read GetSelEnd;
Public | property SelLength: integer read GetSelLength;
Public | property SelStart: TPoint read GetSelStart;
Public | property Styles: TStyleList read FStyles;
Protected | property TabSize: integer read FTabSize write FTabSize;
Protected | property UndoLimit: integer read FUndoLimit write SetUndoLimit;
Public | property UndoList: TGLSMemoUndoList read FUndoList write FUndoList;
Protected | property ValidAttrs[Index: integer]: Boolean read GetValidAttrs write SetValidAttrs;
Protected | property VisibleLineCount: integer index 1 read GetVisible;
Protected | property VisiblePosCount: integer index 0 read GetVisible;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function CanRedo: Boolean;
Public function CanUndo: Boolean;
Public function CellFromPos(X, Y: integer): TCellPos;
Public function CellRect(ACol, ARow: integer): TRect;
Public function CharFromPos(X, Y: integer): TFullPos;
Public function CharStyleNo(LineNo, Pos: integer): integer;
Public function ColRect(ACol: integer): TRect;
Public function FindText(Text: string; Options: TFindOptions; Select: Boolean): Boolean;
Public function LineRect(ARow: integer): TRect;
Public function SelectLine(LineNo, StyleNo: Integer): integer;
Protected function AddString(S: string): integer;
Protected function ColRangeRect(FromCol, ToCol: integer): TRect;
Protected function EditorRect: TRect;
Protected function IndentCurrLine: string;
Protected function LineRangeRect(FromLine, ToLine: integer): TRect;
Public procedure Clear;
Public procedure ClearSelection;
Public procedure CopyToClipBoard;
Public procedure CutToClipBoard;
Public procedure InsertTemplate(AText: string);
Public procedure PasteFromClipBoard;
Public procedure Redo;
Public procedure SelectAll;
Public procedure SelectChar(LineNo, Pos, StyleNo: Integer);
Public procedure SelectLines(StartLine, EndLine: Integer);
Public procedure SetCursor(ACurX, ACurY: Integer);
Public procedure Undo;
Public procedure UnSelectChar;
Protected procedure AttrChanged(LineNo: integer); virtual;
Protected procedure BackSpace;
Protected procedure BackSpaceWord;
Protected procedure Changed(FromLine, ToLine: integer); virtual;
Protected procedure ClearUndoList;
Protected procedure CreateParams(var Params: TCreateParams); override;
Protected procedure DblClick; override;
Protected procedure DeleteChar(OldX, OldY: integer);
Protected procedure DeleteLine(Index, OldX, OldY, NewX, NewY: integer; FixUndo: Boolean);
Protected procedure DeleteSelection(bRepaint: Boolean);
Protected procedure DoScroll(Sender: TGLSMemoScrollBar; ByValue: integer); override;
Protected procedure DoScrollPage(Sender: TGLSMemoScrollBar; ByValue: integer); override;
Protected procedure DrawGutter;
Protected procedure DrawMargin;
Protected procedure DrawScrollBars;
Protected procedure GoEnd(Shift: TShiftState);
Protected procedure GoHome(Shift: TShiftState);
Protected procedure InsertChar(C: Char);
Protected procedure InsertString(Index: integer; S: string);
Protected procedure InvalidateLineRange(FromLine, ToLine: integer);
Protected procedure KeyDown(var Key: Word; Shift: TShiftState); override;
Protected procedure KeyPress(var Key: Char); override;
Protected procedure MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Integer); override;
Protected procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;
Protected procedure MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer); override;
Protected procedure NewLine;
Protected procedure Paint; override;
Protected procedure SelectionChanged; virtual;
Protected procedure StatusChanged; virtual;
Protected procedure UndoChange;
Protected procedure WndProc(var Message: TMessage); override;

Properties

Protected property AutoIndent: Boolean read FAutoIndent write FAutoIndent;
Protected property BkColor: TColor index 0 read FBkColor write SetColor;
Protected property CharAttrs[Index: integer]: string read GetCharAttrs write SetCharAttrs;
Public property CurX: integer read FCurX write SetCurX;
Public property CurY: integer read FCurY write SetCurY;
Public property DelErase: Boolean read FDelErase write FDelErase;
Protected property Font: TFont read FFont write SetFont;
Protected property GutterColor: TColor read GetGutterColor write SetGutterColor;
Protected property GutterWidth: integer read FGutterWidth write SetGutterWidth;
Protected property HiddenCaret: Boolean read FHiddenCaret write SetHiddenCaret;
Protected property HideCursor: Boolean read FHideCursor write FHideCursor;
Protected property InBrackets[Index: integer]: integer read GetInBrackets write SetInBrackets;
Protected property InComment[Index: integer]: Boolean read GetInComment write SetInComment;
Protected property LastVisibleLine: integer index 3 read GetVisible;
Protected property LastVisiblePos: integer index 2 read GetVisible;
Protected property Lines: TStrings read FLines write SetLines;
Public property LineStyle[Index: integer]: integer read GetLineStyle write SetLineStyle;
Protected property OnAttrChange: TNotifyEvent read FOnAttrChange write FOnAttrChange;
Protected property OnChange: TNotifyEvent read FOnChange write FOnChange;
Protected property OnGetLineAttrs: TGetLineAttrsEvent read FOnGetLineAttrs write FOnGetLineAttrs;
Protected property OnGutterClick: TGutterClickEvent read FOnGutterClick write FOnGutterClick;
Protected property OnGutterDraw: TGutterDrawEvent read FOnGutterDraw write FOnGutterDraw;
Protected property OnMoveCursor: TNotifyEvent read FOnMoveCursor write FOnMoveCursor;
Protected property OnSelectionChange: TNotifyEvent read FOnSelectionChange write FOnSelectionChange;
Protected property OnStatusChange: TNotifyEvent read FOnStatusChange write FOnStatusChange;
Protected property OnUndoChange: TUndoChangeEvent read FOnUndoChange write FOnUndoChange;
Protected property ReadOnly: Boolean read FReadOnly write FReadOnly;
Protected property ScrollBars: TScrollStyle read FScrollBars write SetScrollBars default ssBoth;
Protected property ScrollMode: TScrollMode read FScrollMode write FScrollMode default smAuto;
Protected property SelBkColor: TColor index 2 read FSelBkColor write SetColor;
Protected property SelColor: TColor index 1 read FSelColor write SetColor;
Public property Selection: string read GetSelText write SetSelText;
Public property SelEnd: TPoint read GetSelEnd;
Public property SelLength: integer read GetSelLength;
Public property SelStart: TPoint read GetSelStart;
Public property Styles: TStyleList read FStyles;
Protected property TabSize: integer read FTabSize write FTabSize;
Protected property UndoLimit: integer read FUndoLimit write SetUndoLimit;
Public property UndoList: TGLSMemoUndoList read FUndoList write FUndoList;
Protected property ValidAttrs[Index: integer]: Boolean read GetValidAttrs write SetValidAttrs;
Protected property VisibleLineCount: integer index 1 read GetVisible;
Protected property VisiblePosCount: integer index 0 read GetVisible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:52


GLScene v.1.1.2: GLSMemo: Class TGLSMemo

Class TGLSMemo

Unit

GLSMemo

Declaration

type TGLSMemo = class(TGLSCustomMemo)

Description

no description available, TGLSCustomMemo description follows
no description available, TGLSMemoAbstractScrollableObject description follows

Hierarchy

  • TCustomControl
  • TGLSMemoAbstractScrollableObject
  • TGLSCustomMemo
  • TGLSMemo

Overview

Properties

Published | property Align;
Published | property AutoIndent;
Published | property BkColor;
Published | property DelErase;
Published | property Enabled;
Published | property Font;
Published | property GutterColor;
Published | property GutterWidth;
Published | property HiddenCaret;
Published | property Lines;
Published | property OnAttrChange;
Published | property OnChange;
Published | property OnClick;
Published | property OnDblClick;
Published | property OnDragDrop;
Published | property OnDragOver;
Published | property OnEndDrag;
Published | property OnEnter;
Published | property OnExit;
Published | property OnGetLineAttrs;
Published | property OnGutterClick;
Published | property OnGutterDraw;
Published | property OnKeyDown;
Published | property OnKeyPress;
Published | property OnKeyUp;
Published | property OnMouseDown;
Published | property OnMouseMove;
Published | property OnMouseUp;
Published | property OnMoveCursor;
Published | property OnSelectionChange;
Published | property OnStartDrag;
Published | property OnStatusChange;
Published | property OnUndoChange;
Published | property PopupMenu;
Published | property ReadOnly;
Published | property ScrollBars;
Published | property ScrollMode;
Published | property SelBkColor;
Published | property SelColor;
Published | property Selection;
Published | property ShowHint;
Published | property TabOrder;
Published | property TabSize;
Published | property TabStop;
Published | property UndoLimit;
Published | property Visible;

Description

Properties

Published property Align;

TCustomControl

Published property AutoIndent;

TGLSCustomMemo

Published property BkColor;
Published property DelErase;
Published property Enabled;
Published property Font;
Published property GutterColor;
Published property GutterWidth;
Published property HiddenCaret;
Published property Lines;
Published property OnAttrChange;
Published property OnChange;
Published property OnClick;

Inherited events

Published property OnDblClick;
Published property OnDragDrop;
Published property OnDragOver;
Published property OnEndDrag;
Published property OnEnter;
Published property OnExit;
Published property OnGetLineAttrs;
Published property OnGutterClick;
Published property OnGutterDraw;

Events

Published property OnKeyDown;
Published property OnKeyPress;
Published property OnKeyUp;
Published property OnMouseDown;
Published property OnMouseMove;
Published property OnMouseUp;
Published property OnMoveCursor;
Published property OnSelectionChange;
Published property OnStartDrag;
Published property OnStatusChange;
Published property OnUndoChange;
Published property PopupMenu;

TControl

Published property ReadOnly;
Published property ScrollBars;
Published property ScrollMode;
Published property SelBkColor;
Published property SelColor;
Published property Selection;
Published property ShowHint;
Published property TabOrder;
Published property TabSize;
Published property TabStop;
Published property UndoLimit;
Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:52


GLScene v.1.1.2: GLSMemo: Class TGLSMemoStringList

Class TGLSMemoStringList

Unit

GLSMemo

Declaration

type TGLSMemoStringList = class(TStringList)

Description

Hierarchy

  • TStringList
  • TGLSMemoStringList

Overview

Methods

Protected procedure DefineProperties(Filer: TFiler); override;

Description

Methods

Protected procedure DefineProperties(Filer: TFiler); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:52


GLScene v.1.1.2: GLSMemo: Class TGLSSynHiMemo

Class TGLSSynHiMemo

Unit

GLSMemo

Declaration

type TGLSSynHiMemo = class(TGLSCustomMemo)

Description

no description available, TGLSCustomMemo description follows
no description available, TGLSMemoAbstractScrollableObject description follows

Hierarchy

  • TCustomControl
  • TGLSMemoAbstractScrollableObject
  • TGLSCustomMemo
  • TGLSSynHiMemo

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure AddBrackets(StyleNo: integer; ArrS: array of string);
Public | procedure AddSpecial(StyleNo: integer; ArrS: array of string);
Public | procedure AddWord(StyleNo: integer; ArrS: array of string);
Protected | procedure Paint; override;

Properties

Published | property Align;
Published | property AutoIndent;
Published | property BkColor;
Published | property BracketList: TGLSMemoStringList read FBracketList write SetBracketList;
Published | property CaseSensitive: Boolean read FCaseSensitive write SetCaseSensitive;
Published | property CommentStyle: TCharStyle index 1 read FCommentStyle write SetStyle;
Published | property DelErase;
Public | property Delimiters: TDelimiters read FDelimiters write FDelimiters;
Published | property DelimiterStyle: TCharStyle index 0 read FDelimiterStyle write SetStyle;
Published | property Enabled;
Published | property Font;
Published | property GutterColor;
Published | property GutterWidth;
Published | property HiddenCaret;
Published | property LineComment: string read FLineComment write FLineComment;
Published | property Lines;
Published | property MultiCommentLeft: string read FMultiCommentLeft write FMultiCommentLeft;
Published | property MultiCommentRight: string read FMultiCommentRight write FMultiCommentRight;
Published | property NumberStyle: TCharStyle index 2 read FNumberStyle write SetStyle;
Published | property OnChange;
Published | property OnClick;
Published | property OnDblClick;
Published | property OnDragDrop;
Published | property OnDragOver;
Published | property OnEndDrag;
Published | property OnEnter;
Published | property OnExit;
Published | property OnGutterClick;
Published | property OnGutterDraw;
Published | property OnKeyDown;
Published | property OnKeyPress;
Published | property OnKeyUp;
Published | property OnMouseDown;
Published | property OnMouseMove;
Published | property OnMouseUp;
Published | property OnMoveCursor;
Published | property OnSelectionChange;
Published | property OnStartDrag;
Published | property OnStatusChange;
Published | property OnUndoChange;
Published | property PopupMenu;
Published | property ReadOnly;
Published | property ScrollBars;
Published | property ScrollMode;
Published | property SelBkColor;
Published | property SelColor;
Published | property ShowHint;
Published | property SpecialList: TGLSMemoStringList read FSpecialList write SetSpecialList;
Published | property TabOrder;
Published | property TabSize;
Published | property TabStop;
Published | property UndoLimit;
Published | property Visible;
Published | property WordList: TGLSMemoStringList read FWordList write SetWordList;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure AddBrackets(StyleNo: integer; ArrS: array of string);
Public procedure AddSpecial(StyleNo: integer; ArrS: array of string);
Public procedure AddWord(StyleNo: integer; ArrS: array of string);
Protected procedure Paint; override;

Properties

Published property Align;

TCustomControl

Published property AutoIndent;

TGLSCustomMemo

Published property BkColor;
Published property BracketList: TGLSMemoStringList read FBracketList write SetBracketList;
Published property CaseSensitive: Boolean read FCaseSensitive write SetCaseSensitive;
Published property CommentStyle: TCharStyle index 1 read FCommentStyle write SetStyle;
Published property DelErase;
Public property Delimiters: TDelimiters read FDelimiters write FDelimiters;
Published property DelimiterStyle: TCharStyle index 0 read FDelimiterStyle write SetStyle;
Published property Enabled;
Published property Font;
Published property GutterColor;
Published property GutterWidth;
Published property HiddenCaret;
Published property LineComment: string read FLineComment write FLineComment;

TGLSSyntaxMemo

Published property Lines;
Published property MultiCommentLeft: string read FMultiCommentLeft write FMultiCommentLeft;
Published property MultiCommentRight: string read FMultiCommentRight write FMultiCommentRight;
Published property NumberStyle: TCharStyle index 2 read FNumberStyle write SetStyle;
Published property OnChange;
Published property OnClick;

Inherited events

Published property OnDblClick;
Published property OnDragDrop;
Published property OnDragOver;
Published property OnEndDrag;
Published property OnEnter;
Published property OnExit;
Published property OnGutterClick;

Events

Published property OnGutterDraw;
Published property OnKeyDown;
Published property OnKeyPress;
Published property OnKeyUp;
Published property OnMouseDown;
Published property OnMouseMove;
Published property OnMouseUp;
Published property OnMoveCursor;
Published property OnSelectionChange;
Published property OnStartDrag;
Published property OnStatusChange;
Published property OnUndoChange;
Published property PopupMenu;

TControl

Published property ReadOnly;
Published property ScrollBars;
Published property ScrollMode;
Published property SelBkColor;
Published property SelColor;
Published property ShowHint;
Published property SpecialList: TGLSMemoStringList read FSpecialList write SetSpecialList;
Published property TabOrder;
Published property TabSize;
Published property TabStop;
Published property UndoLimit;
Published property Visible;
Published property WordList: TGLSMemoStringList read FWordList write SetWordList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSMFMOD

Unit GLSMFMOD

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSMFMOD<p>

FMOD based sound-manager (http://www.fmod.org/, free for freeware).<p>

Unsupported feature(s) :<ul> <li>sound source velocity <li>looping (sounds are played either once or forever) <li>sound cones </ul><p>

<b>History : </b><font size=-1><ul> <li>07/01/10 - DaStr - Fixed a bug with an initial Paused or Muted state of sound source and with sscSample in aSource.Changes <li>17/03/08 - mrqzzz - Fixed "Consant cannot be pased as var parameter" in NotifyEnvironmentChanged <li>15/03/08 - DaStr - Updated to Fmod v3.7.4 (thanks Chen, Pei) <li>07/06/07 - DaStr - Added $I GLScene.inc <li>18/10/03 - EG - Dynamic support is back <li>18/09/03 - ARH - updated for fmod 3.7 <li>24/09/02 - EG - FMOD activation errors no longer result in Asserts (ignored) <li>28/08/02 - EG - Fixed EAX capability detection <li>27/08/02 - EG - Now uses dynamically linked version by Steve Williams, Added support for EAX environments <li>26/08/02 - EG - Updated to FMOD 3.6 <li>27/02/02 - EG - Updated to FMOD 3.5, added 3D Factors <li>05/02/02 - EG - Updated to FMOD 3.4, now uses DSound by default <li>13/01/01 - EG - Updated for API 3.3 compatibility <li>09/06/00 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSMFMOD |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSMFMOD: Class TGLSMFMOD

Class TGLSMFMOD

Unit

GLSMFMOD

Declaration

type TGLSMFMOD = class(TGLSoundManager)

Description

no description available, TGLSoundManager description follows

Base class for sound manager components.<p> The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this).<p> Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLSoundManager
  • TGLSMFMOD

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Public | function CPUUsagePercent : Single; override;
Public | function EAXSupported : Boolean; override;
Protected | function DoActivate : Boolean; override;
Protected | function GetDefaultFrequency(aSource : TGLBaseSoundSource) : Integer;
Public | procedure UpdateSources; override;
Protected | procedure DoDeActivate; override;
Protected | procedure KillSource(aSource : TGLBaseSoundSource); override;
Protected | procedure MuteSource(aSource : TGLBaseSoundSource; muted : Boolean); override;
Protected | procedure Notify3DFactorsChanged; override;
Protected | procedure NotifyEnvironmentChanged; override;
Protected | procedure NotifyMasterVolumeChange; override;
Protected | procedure PauseSource(aSource : TGLBaseSoundSource; paused : Boolean); override;
Protected | procedure UpdateSource(aSource : TGLBaseSoundSource); override;

Properties

Published property MaxChannels default 32;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Public function CPUUsagePercent : Single; override;
Public function EAXSupported : Boolean; override;
Protected function DoActivate : Boolean; override;
Protected function GetDefaultFrequency(aSource : TGLBaseSoundSource) : Integer;
Public procedure UpdateSources; override;
Protected procedure DoDeActivate; override;
Protected procedure KillSource(aSource : TGLBaseSoundSource); override;
Protected procedure MuteSource(aSource : TGLBaseSoundSource; muted : Boolean); override;
Protected procedure Notify3DFactorsChanged; override;
Protected procedure NotifyEnvironmentChanged; override;
Protected procedure NotifyMasterVolumeChange; override;
Protected procedure PauseSource(aSource : TGLBaseSoundSource; paused : Boolean); override;
Protected procedure UpdateSource(aSource : TGLBaseSoundSource); override;

Properties

Published property MaxChannels default 32;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSModuleLoader

Unit GLSModuleLoader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Functions and Procedures

function LoadModule(var Module: TModuleHandle; FileName: PChar): Boolean; stdcall;
function LoadModuleEx(var Module: TModuleHandle; FileName: PChar; Flags: Cardinal): Boolean; stdcall;
procedure UnloadModule(var Module: TModuleHandle); stdcall;
function GetModuleSymbol(Module: TModuleHandle; SymbolName: PChar): Pointer; stdcall;
function GetModuleSymbolEx(Module: TModuleHandle; SymbolName: PChar; var Accu: Boolean): Pointer; stdcall;
function ReadModuleData(Module: TModuleHandle; SymbolName: PChar; var Buffer; Size: Cardinal): Boolean; stdcall;
function WriteModuleData(Module: TModuleHandle; SymbolName: PChar; var Buffer; Size: Cardinal): Boolean; stdcall;

Types

TModuleHandle = HINST;

Constants

INVALID_MODULEHANDLE_VALUE = TModuleHandle(0);

Description

Functions and Procedures

function LoadModule(var Module: TModuleHandle; FileName: PChar): Boolean; stdcall;
function LoadModuleEx(var Module: TModuleHandle; FileName: PChar; Flags: Cardinal): Boolean; stdcall;
procedure UnloadModule(var Module: TModuleHandle); stdcall;
function GetModuleSymbol(Module: TModuleHandle; SymbolName: PChar): Pointer; stdcall;
function GetModuleSymbolEx(Module: TModuleHandle; SymbolName: PChar; var Accu: Boolean): Pointer; stdcall;
function ReadModuleData(Module: TModuleHandle; SymbolName: PChar; var Buffer; Size: Cardinal): Boolean; stdcall;
function WriteModuleData(Module: TModuleHandle; SymbolName: PChar; var Buffer; Size: Cardinal): Boolean; stdcall;

Types

TModuleHandle = HINST;

Constants

INVALID_MODULEHANDLE_VALUE = TModuleHandle(0);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSmoothNavigator

Unit GLSmoothNavigator

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSmoothNavigator<p>

An extention of TGLNavigator, which allows to move objects with inertia Note: it is not completely FPS-independant. Only Moving code is, but MoveAroundTarget, Turn[Vertical/Horizontal] and AdjustDistanceTo[..] is not.

Don't know why, but when I make their code identical, these function stop working completely. So you probably have to call the AutoScaleParameters procedure once in a while for it to adjust to the current framerate. If someone knows a better way to solve this issue, please contact me via glscene newsgroups.<p>

<b>History : </b><font size=-1><ul> <li>30/06/11 - DaStr - Converted many procedures to functions Bugfixed Assign() in some places Added "Cutoff" property instead of fixed EPS values <li>02/06/11 - DaStr - DeltaTime is now Double, like in Cadencer Added CustomAnimatedItems <li>28/05/11 - DaStr - Added the AdjustDistanceTo[..]Ex procedures <li>25/02/07 - DaStr - Added the AdjustDistanceTo[..] procedures <li>23/02/07 - DaStr - Initial version (contributed to GLScene)

TODO: 1) Scale "Old values" too, when callin the Scale parameter procedure to avoid the temporary "freeze" of controls. 2) AddImpulse procedures.

Previous version history: v1.0 10 December '2005 Creation v1.0.2 11 December '2005 TurnMaxAngle added v1.1 04 March '2006 Inertia became FPS-independant TGLSmoothNavigatorParameters added v1.1.6 18 February '2007 Merged with GLInertedUserInterface.pas All parameters moved into separate classes Added MoveAroudTargetWithInertia v1.2 23 February '2007 Finally made it trully FPS-independant Added default values to every property Contributed to GLScene

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLNavigatorAbstractParameters |
Class TGLNavigatorSmoothChangeItem |
Class TGLNavigatorSmoothChangeSingle |
Class TGLNavigatorSmoothChangeVector |
Class TGLNavigatorSmoothChangeItems |
Class TGLNavigatorAdjustDistanceParameters |
Class TGLNavigatorAdjustDistanceParametersEx |
Class TGLNavigatorInertiaParameters |
Class TGLNavigatorGeneralParameters |
Class TGLNavigatorMoveAroundParameters |
Class TGLSmoothNavigator |
Class TGLSmoothUserInterface |

Types

TGLNavigatorSmoothChangeSingleGetEvent = function(const ASender: TGLNavigatorSmoothChangeSingle): Single of object;
TGLNavigatorSmoothChangeSingleSetEvent = procedure(const ASender: TGLNavigatorSmoothChangeSingle; const AValue: Single) of object;
TGLNavigatorSmoothChangeVectorGetEvent = function(const ASender: TGLNavigatorSmoothChangeVector): TVector of object;
TGLNavigatorSmoothChangeVectorSetEvent = procedure(const ASender: TGLNavigatorSmoothChangeVector; const AValue: TVector) of object;
TGLNavigatorSmoothChangeItemClass = class of TGLNavigatorSmoothChangeItem;

Description

Types

TGLNavigatorSmoothChangeSingleGetEvent = function(const ASender: TGLNavigatorSmoothChangeSingle): Single of object;
TGLNavigatorSmoothChangeSingleSetEvent = procedure(const ASender: TGLNavigatorSmoothChangeSingle; const AValue: Single) of object;
TGLNavigatorSmoothChangeVectorGetEvent = function(const ASender: TGLNavigatorSmoothChangeVector): TVector of object;
TGLNavigatorSmoothChangeVectorSetEvent = procedure(const ASender: TGLNavigatorSmoothChangeVector; const AValue: TVector) of object;
TGLNavigatorSmoothChangeItemClass = class of TGLNavigatorSmoothChangeItem;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSmoothNavigator: Class TGLNavigatorAbstractParameters

Class TGLNavigatorAbstractParameters

Unit

GLSmoothNavigator

Declaration

type TGLNavigatorAbstractParameters = class(TPersistent)

Description

TGLNavigatorAdjustDistanceParameters includes a basic set of parameters that control the smoothness of movement.<p>

Hierarchy

  • TPersistent
  • TGLNavigatorAbstractParameters

Overview

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Protected | function GetOwner: TPersistent; override;
Protected | function StoreInertia: Boolean; virtual;
Protected | function StoreSpeed: Boolean; virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ScaleParameters(const Value: Single); virtual;

Properties

Published | property Cutoff: Single read FCutoff write FCutoff stored StoreCutoff;
Published | property Inertia: Single read FInertia write FInertia stored StoreInertia;
Published | property Speed: Single read FSpeed write FSpeed stored StoreSpeed;

Description

Methods

Public constructor Create(AOwner: TPersistent); virtual;
Protected function GetOwner: TPersistent; override;
Protected function StoreInertia: Boolean; virtual;
Protected function StoreSpeed: Boolean; virtual;
Public procedure Assign(Source: TPersistent); override;
Public procedure ScaleParameters(const Value: Single); virtual;

Properties

Published property Cutoff: Single read FCutoff write FCutoff stored StoreCutoff;
Published property Inertia: Single read FInertia write FInertia stored StoreInertia;
Published property Speed: Single read FSpeed write FSpeed stored StoreSpeed;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSmoothNavigator: Class TGLNavigatorSmoothChangeItem

Class TGLNavigatorSmoothChangeItem

Unit

GLSmoothNavigator

Declaration

type TGLNavigatorSmoothChangeItem = class(TXCollectionItem)

Description

TGLNavigatorSmoothChangeItem includes a basic set of parameters that control the smoothness of movement.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLNavigatorSmoothChangeItem

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | function Proceed(ADeltaTime: Double): Boolean; virtual; abstract;
Protected | function GetNavigator: TGLSmoothNavigator;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ResetTargetValue(); virtual; abstract;
Public | procedure ScaleParameters(const Value: Single); virtual;

Properties

Published | property Cutoff: Double read FCutoff write FCutoff stored StoreCutoff;
Published | property Enabled: Boolean read FEnabled write FEnabled default True;
Published | property Inertia: Single read FInertia write FInertia stored StoreInertia;
Published | property Speed: Single read FSpeed write FSpeed stored StoreSpeed;
Published | property SpeedLimit: Single read FSpeedLimit write FSpeedLimit stored StoreSpeedLimit;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;
Public function Proceed(ADeltaTime: Double): Boolean; virtual; abstract;

Returns False if there was no change.

Protected function GetNavigator: TGLSmoothNavigator;
Public procedure Assign(Source: TPersistent); override;
Public procedure ResetTargetValue(); virtual; abstract;
Public procedure ScaleParameters(const Value: Single); virtual;

Properties

Published property Cutoff: Double read FCutoff write FCutoff stored StoreCutoff;
Published property Enabled: Boolean read FEnabled write FEnabled default True;
Published property Inertia: Single read FInertia write FInertia stored StoreInertia;
Published property Speed: Single read FSpeed write FSpeed stored StoreSpeed;
Published property SpeedLimit: Single read FSpeedLimit write FSpeedLimit stored StoreSpeedLimit;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSmoothNavigator: Class TGLNavigatorSmoothChangeSingle

Class TGLNavigatorSmoothChangeSingle

Unit

GLSmoothNavigator

Declaration

type TGLNavigatorSmoothChangeSingle = class(TGLNavigatorSmoothChangeItem)

Description

Smoothly change any Single value, so it will become TargetValue in the end.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLNavigatorSmoothChangeItem
  • TGLNavigatorSmoothChangeSingle

Overview

Methods

Public | class function FriendlyName: string; override;
Public | function Proceed(ADeltaTime: Double): Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ResetTargetValue(); override;

Properties

Published | property OnGetCurrentValue: TGLNavigatorSmoothChangeSingleGetEvent read FOnGetCurrentValue write FOnGetCurrentValue;
Published | property OnSetCurrentValue: TGLNavigatorSmoothChangeSingleSetEvent read FOnSetCurrentValue write FOnSetCurrentValue;
Published | property TargetValue: Single read FTargetValue write FTargetValue;

Description

Methods

Public class function FriendlyName: string; override;
Public function Proceed(ADeltaTime: Double): Boolean; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure ResetTargetValue(); override;

Properties

Published property OnGetCurrentValue: TGLNavigatorSmoothChangeSingleGetEvent read FOnGetCurrentValue write FOnGetCurrentValue;
Published property OnSetCurrentValue: TGLNavigatorSmoothChangeSingleSetEvent read FOnSetCurrentValue write FOnSetCurrentValue;
Published property TargetValue: Single read FTargetValue write FTargetValue;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSmoothNavigator: Class TGLNavigatorSmoothChangeVector

Class TGLNavigatorSmoothChangeVector

Unit

GLSmoothNavigator

Declaration

type TGLNavigatorSmoothChangeVector = class(TGLNavigatorSmoothChangeItem)

Description

Smoothly change any Vector4f value, so it will become TargetValue in the end.<p>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLNavigatorSmoothChangeItem
  • TGLNavigatorSmoothChangeVector

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyName: string; override;
Public | function Proceed(ADeltaTime: Double): Boolean; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ResetTargetValue(); override;

Properties

Published | property OnGetCurrentValue: TGLNavigatorSmoothChangeVectorGetEvent read FOnGetCurrentValue write FOnGetCurrentValue;
Published | property OnSetCurrentValue: TGLNavigatorSmoothChangeVectorSetEvent read FOnSetCurrentValue write FOnSetCurrentValue;
Published | property TargetValue: TGLCoordinates read FTargetValue write SetTargetValue;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyName: string; override;
Public function Proceed(ADeltaTime: Double): Boolean; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure ResetTargetValue(); override;

Properties

Published property OnGetCurrentValue: TGLNavigatorSmoothChangeVectorGetEvent read FOnGetCurrentValue write FOnGetCurrentValue;
Published property OnSetCurrentValue: TGLNavigatorSmoothChangeVectorSetEvent read FOnSetCurrentValue write FOnSetCurrentValue;
Published property TargetValue: TGLCoordinates read FTargetValue write SetTargetValue;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSmoothNavigator: Class TGLNavigatorSmoothChangeItems

Class TGLNavigatorSmoothChangeItems

Unit

GLSmoothNavigator

Declaration

type TGLNavigatorSmoothChangeItems = class(TXCollection)

Description

XCollection of TGLNavigatorSmoothChangeItem.

Hierarchy

  • TPersistent
  • TXCollection
  • TGLNavigatorSmoothChangeItems

Overview

Methods

Public | function Add(AClass : TGLNavigatorSmoothChangeItemClass): TGLNavigatorSmoothChangeItem;
Public | function CanAdd(AClass: TXCollectionItemClass): Boolean; override;
Public | class function ItemsClass: TXCollectionItemClass; override;
Protected | procedure DoProceed(ADeltaTime: Double);

Properties

Public property Items[const Index : Integer]: TGLNavigatorSmoothChangeItem read GetItems write SetItems;

Description

Methods

Public function Add(AClass : TGLNavigatorSmoothChangeItemClass): TGLNavigatorSmoothChangeItem;
Public function CanAdd(AClass: TXCollectionItemClass): Boolean; override;
Public class function ItemsClass: TXCollectionItemClass; override;
Protected procedure DoProceed(ADeltaTime: Double);

Properties

Public property Items[const Index : Integer]: TGLNavigatorSmoothChangeItem read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSmoothNavigator: Class TGLNavigatorAdjustDistanceParameters

Class TGLNavigatorAdjustDistanceParameters

Unit

GLSmoothNavigator

Declaration

type TGLNavigatorAdjustDistanceParameters = class(TGLNavigatorAbstractParameters)

Description

TGLNavigatorAdjustDistanceParameters is wrapper for all parameters that affect how the AdjustDisanceTo[...] methods work<p>

Hierarchy

  • TPersistent
  • TGLNavigatorAbstractParameters
  • TGLNavigatorAdjustDistanceParameters

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | procedure AddImpulse(const Impulse: Single); virtual;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ScaleParameters(const Value: Single); override;

Properties

Published property ImpulseSpeed: Single read FImpulseSpeed write FImpulseSpeed stored StoreImpulseSpeed;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public procedure AddImpulse(const Impulse: Single); virtual;
Public procedure Assign(Source: TPersistent); override;
Public procedure ScaleParameters(const Value: Single); override;

Properties

Published property ImpulseSpeed: Single read FImpulseSpeed write FImpulseSpeed stored StoreImpulseSpeed;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSmoothNavigator: Class TGLNavigatorAdjustDistanceParametersEx

Class TGLNavigatorAdjustDistanceParametersEx

Unit

GLSmoothNavigator

Declaration

type TGLNavigatorAdjustDistanceParametersEx = class(TGLNavigatorAbstractParameters)

Description

TGLNavigatorAdjustDistanceParameters is wrapper for all parameters that affect how the AdjustDisanceTo[...]Ex methods work<p>

You need to set the TargetObject and desired distance to it, then call AdjustDisanceTo[...]Ex() in your Cadencer.OnProgress code.

Hierarchy

  • TPersistent
  • TGLNavigatorAbstractParameters
  • TGLNavigatorAdjustDistanceParametersEx

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Protected | function StoreInertia: Boolean; override;
Protected | function StoreSpeed: Boolean; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property SpeedLimit: Single read FSpeedLimit write FSpeedLimit stored StoreSpeedLimit;
Published | property TargetDistance: Single read FTargetDistance write FTargetDistance stored StoreTargetDistance;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Protected function StoreInertia: Boolean; override;
Protected function StoreSpeed: Boolean; override;
Public procedure Assign(Source: TPersistent); override;

Properties

Published property SpeedLimit: Single read FSpeedLimit write FSpeedLimit stored StoreSpeedLimit;
Published property TargetDistance: Single read FTargetDistance write FTargetDistance stored StoreTargetDistance;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSmoothNavigator: Class TGLNavigatorInertiaParameters

Class TGLNavigatorInertiaParameters

Unit

GLSmoothNavigator

Declaration

type TGLNavigatorInertiaParameters = class(TPersistent)

Description

TGLNavigatorInertiaParameters is wrapper for all parameters that affect the smoothness of movement<p>

Hierarchy

  • TPersistent
  • TGLNavigatorInertiaParameters

Overview

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Protected | function GetOwner: TPersistent; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ScaleParameters(const Value: Single); virtual;

Properties

Published | property MovementAcceleration: Single read FMovementAcceleration write FMovementAcceleration stored StoreMovementAcceleration;
Published | property MovementInertia: Single read FMovementInertia write FMovementInertia stored StoreMovementInertia;
Published | property MovementSpeed: Single read FMovementSpeed write FMovementSpeed stored StoreMovementSpeed;
Published | property TurnInertia: Single read FTurnInertia write FTurnInertia stored StoreTurnInertia;
Published | property TurnMaxAngle: Single read FTurnMaxAngle write FTurnMaxAngle stored StoreTurnMaxAngle;
Published | property TurnSpeed: Single read FTurnSpeed write FTurnSpeed stored StoreTurnSpeed;

Description

Methods

Public constructor Create(AOwner: TPersistent); virtual;
Protected function GetOwner: TPersistent; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure ScaleParameters(const Value: Single); virtual;

Properties

Published property MovementAcceleration: Single read FMovementAcceleration write FMovementAcceleration stored StoreMovementAcceleration;
Published property MovementInertia: Single read FMovementInertia write FMovementInertia stored StoreMovementInertia;
Published property MovementSpeed: Single read FMovementSpeed write FMovementSpeed stored StoreMovementSpeed;
Published property TurnInertia: Single read FTurnInertia write FTurnInertia stored StoreTurnInertia;
Published property TurnMaxAngle: Single read FTurnMaxAngle write FTurnMaxAngle stored StoreTurnMaxAngle;
Published property TurnSpeed: Single read FTurnSpeed write FTurnSpeed stored StoreTurnSpeed;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSmoothNavigator: Class TGLNavigatorGeneralParameters

Class TGLNavigatorGeneralParameters

Unit

GLSmoothNavigator

Declaration

type TGLNavigatorGeneralParameters = class(TPersistent)

Description

TGLNavigatorGeneralParameters is a wrapper for all general inertia parameters.

These properties mean that if ExpectedMaxFPS is 100, FAutoScaleMin is 0.1, FAutoScaleMax is 0.75 then the "safe range" for it to change is [10..75]. If these bounds are violated, then ExpectedMaxFPS is automaticly increased or decreased by AutoScaleMult.

Hierarchy

  • TPersistent
  • TGLNavigatorGeneralParameters

Overview

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Protected | function GetOwner: TPersistent; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property AutoScaleMax: Single read FAutoScaleMax write FAutoScaleMax stored StoreAutoScaleMax;
Published | property AutoScaleMin: Single read FAutoScaleMin write FAutoScaleMin stored StoreAutoScaleMin;
Published | property AutoScaleMult: Single read FAutoScaleMult write FAutoScaleMult stored StoreAutoScaleMult;

Description

Methods

Public constructor Create(AOwner: TPersistent); virtual;
Protected function GetOwner: TPersistent; override;
Public procedure Assign(Source: TPersistent); override;

Properties

Published property AutoScaleMax: Single read FAutoScaleMax write FAutoScaleMax stored StoreAutoScaleMax;
Published property AutoScaleMin: Single read FAutoScaleMin write FAutoScaleMin stored StoreAutoScaleMin;
Published property AutoScaleMult: Single read FAutoScaleMult write FAutoScaleMult stored StoreAutoScaleMult;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSmoothNavigator: Class TGLNavigatorMoveAroundParameters

Class TGLNavigatorMoveAroundParameters

Unit

GLSmoothNavigator

Declaration

type TGLNavigatorMoveAroundParameters = class(TPersistent)

Description

TGLNavigatorMoveAroundParameters is a wrapper for all parameters that effect how the TGLBaseSceneObject.MoveObjectAround() procedure works

Hierarchy

  • TPersistent
  • TGLNavigatorMoveAroundParameters

Overview

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Protected | function GetOwner: TPersistent; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure ScaleParameters(const Value: Single); virtual;

Properties

Published | property Cutoff: Double read FCutoff write FCutoff stored StoreCutoff;
Published | property Inertia: Single read FInertia write FInertia stored StoreInertia;
Published | property MaxAngle: Single read FMaxAngle write FMaxAngle stored StoreMaxAngle;
Published | property PitchSpeed: Single read FPitchSpeed write FPitchSpeed stored StorePitchSpeed;
Published | property TargetObject: TGLBaseSceneObject read FTargetObject write SetTargetObject;
Published | property TurnSpeed: Single read FTurnSpeed write FTurnSpeed stored StoreTurnSpeed;

Description

Methods

Public constructor Create(AOwner: TPersistent); virtual;
Protected function GetOwner: TPersistent; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure ScaleParameters(const Value: Single); virtual;

Properties

Published property Cutoff: Double read FCutoff write FCutoff stored StoreCutoff;
Published property Inertia: Single read FInertia write FInertia stored StoreInertia;
Published property MaxAngle: Single read FMaxAngle write FMaxAngle stored StoreMaxAngle;
Published property PitchSpeed: Single read FPitchSpeed write FPitchSpeed stored StorePitchSpeed;
Published property TargetObject: TGLBaseSceneObject read FTargetObject write SetTargetObject;
Published property TurnSpeed: Single read FTurnSpeed write FTurnSpeed stored StoreTurnSpeed;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:53


GLScene v.1.1.2: GLSmoothNavigator: Class TGLSmoothNavigator

Class TGLSmoothNavigator

Unit

GLSmoothNavigator

Declaration

type TGLSmoothNavigator = class(TGLNavigator)

Description

TGLSmoothNavigator is the component for moving a TGLBaseSceneObject, and all classes based on it, this includes all the objects from the Scene Editor.<p>

It uses complex smoothing algorithms, most of which are FPS-dependant. Make sure your limit your FPS and set MaxExpectedDeltaTime to a value that is aproximatly 5 times less than your usual deltatime.

Hierarchy

  • TComponent
  • TGLNavigator
  • TGLSmoothNavigator

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AdjustDistanceToPoint(const APoint: TVector; const DistanceRatio : Single; ADeltaTime: Double): Boolean; virtual;
Public | function AdjustDistanceToPointEx(const APoint: TVector; ADeltaTime: Double): Boolean; virtual;
Public | function AdjustDistanceToTarget(const DistanceRatio : Single; const ADeltaTime: Double): Boolean; virtual;
Public | function AdjustDistanceToTargetEx(const ADeltaTime: Double): Boolean; virtual;
Public | function MoveAroundTarget(const PitchDelta, TurnDelta : Single; const ADeltaTime: Double): Boolean; virtual;
Public | function MoveObjectAround(const AObject: TGLBaseSceneObject; PitchDelta, TurnDelta : Single; ADeltaTime: Double): Boolean; virtual;
Public | procedure AnimateCustomItems(const ADeltaTime: Double); virtual;
Public | procedure AutoScaleParameters(const FPS: Single); virtual;
Public | procedure AutoScaleParametersUp(const FPS: Single); virtual;
Public | procedure FlyForward(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public | procedure MoveForward(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public | procedure ScaleParameters(const Value: Single); virtual;
Public | procedure SetObject(Value: TGLBaseSceneObject); override;
Public | procedure StrafeHorizontal(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public | procedure StrafeVertical(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public | procedure TurnHorizontal(Angle: Single; ADeltaTime: Double); virtual;
Public | procedure TurnVertical(Angle: Single; ADeltaTime: Double); virtual;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property AdjustDistanceParams: TGLNavigatorAdjustDistanceParameters read FAdjustDistanceParams write SetAdjustDistanceParams;
Published | property AdjustDistanceParamsEx: TGLNavigatorAdjustDistanceParametersEx read FAdjustDistanceParamsEx write SetAdjustDistanceParamsEx;
Published | property CustomAnimatedItems: TGLNavigatorSmoothChangeItems read FCustomAnimatedItems write SetCustomAnimatedItems;
Published | property GeneralParams: TGLNavigatorGeneralParameters read FGeneralParams write SetGeneralParams;
Published | property InertiaParams: TGLNavigatorInertiaParameters read FInertiaParams write SetInertiaParams;
Published | property MaxExpectedDeltaTime: Double read FMaxExpectedDeltaTime write FMaxExpectedDeltaTime stored StoreMaxExpectedDeltaTime;
Published | property MoveAroundParams: TGLNavigatorMoveAroundParameters read FMoveAroundParams write SetMoveAroundParams;

Description

Methods

Public constructor Create(AOwner: TComponent); override;

Constructors-destructors.

Public destructor Destroy; override;
Public function AdjustDistanceToPoint(const APoint: TVector; const DistanceRatio : Single; ADeltaTime: Double): Boolean; virtual;

Uses AdjustDistanceParams.

Public function AdjustDistanceToPointEx(const APoint: TVector; ADeltaTime: Double): Boolean; virtual;

Uses AdjustDistanceParamsEx.

Public function AdjustDistanceToTarget(const DistanceRatio : Single; const ADeltaTime: Double): Boolean; virtual;
Public function AdjustDistanceToTargetEx(const ADeltaTime: Double): Boolean; virtual;
Public function MoveAroundTarget(const PitchDelta, TurnDelta : Single; const ADeltaTime: Double): Boolean; virtual;

Uses MoveAroundParams. Returns True, if object was actually moved.

Public function MoveObjectAround(const AObject: TGLBaseSceneObject; PitchDelta, TurnDelta : Single; ADeltaTime: Double): Boolean; virtual;
Public procedure AnimateCustomItems(const ADeltaTime: Double); virtual;

Uses CustomAnimatedItems.

Public procedure AutoScaleParameters(const FPS: Single); virtual;
Public procedure AutoScaleParametersUp(const FPS: Single); virtual;
Public procedure FlyForward(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public procedure MoveForward(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public procedure ScaleParameters(const Value: Single); virtual;

In ScaleParameters, Value should be around 1.

Public procedure SetObject(Value: TGLBaseSceneObject); override;

From TGLNavigator. Probably, should not be public.

Public procedure StrafeHorizontal(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public procedure StrafeVertical(const Plus, Minus: Boolean; ADeltaTime: Double; const Accelerate: Boolean = False); virtual;
Public procedure TurnHorizontal(Angle: Single; ADeltaTime: Double); virtual;

Uses InertiaParams.

Public procedure TurnVertical(Angle: Single; ADeltaTime: Double); virtual;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published property AdjustDistanceParams: TGLNavigatorAdjustDistanceParameters read FAdjustDistanceParams write SetAdjustDistanceParams;
Published property AdjustDistanceParamsEx: TGLNavigatorAdjustDistanceParametersEx read FAdjustDistanceParamsEx write SetAdjustDistanceParamsEx;
Published property CustomAnimatedItems: TGLNavigatorSmoothChangeItems read FCustomAnimatedItems write SetCustomAnimatedItems;
Published property GeneralParams: TGLNavigatorGeneralParameters read FGeneralParams write SetGeneralParams;
Published property InertiaParams: TGLNavigatorInertiaParameters read FInertiaParams write SetInertiaParams;
Published property MaxExpectedDeltaTime: Double read FMaxExpectedDeltaTime write FMaxExpectedDeltaTime stored StoreMaxExpectedDeltaTime;
Published property MoveAroundParams: TGLNavigatorMoveAroundParameters read FMoveAroundParams write SetMoveAroundParams;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSmoothNavigator: Class TGLSmoothUserInterface

Class TGLSmoothUserInterface

Unit

GLSmoothNavigator

Declaration

type TGLSmoothUserInterface = class(TComponent)

Description

TGLSmoothUserInterface is the component which reads the userinput and transform it into action.<p> <ul> <li>Mouselook(ADeltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works everywhere!) </ul> The four properties to get you started are: <ul> <li>InvertMouse : Inverts the mouse Y axis. <li>AutoUpdateMouse : If enabled (by defaul), than handles all mouse updates. <li>GLNavigator : The Navigator which receives the user movement. <li>GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras.... </ul>

Hierarchy

  • TComponent
  • TGLSmoothUserInterface

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function MouseLook(const NewXY: TGLPoint; const ADeltaTime: Double): Boolean; overload;
Public | function MouseLook(const ADeltaTime: Double): Boolean; overload;
Public | function MouseLook(const NewX, NewY: Integer; const ADeltaTime: Double): Boolean; overload;
Public | procedure MouseLookActiveToggle; virtual;
Public | procedure TurnHorizontal(const Angle : Single; const ADeltaTime: Double); virtual;
Public | procedure TurnVertical(const Angle : Single; const ADeltaTime: Double); virtual;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property AutoUpdateMouse: Boolean read FAutoUpdateMouse write FAutoUpdateMouse default True;
Published | property InvertMouse: Boolean read FInvertMouse write FInvertMouse default False;
Published | property MouseLookActive: Boolean read FMouseLookActive write SetMouseLookActive default False;
Published | property OriginalMousePos: TGLCoordinates2 read FOriginalMousePos write SetOriginalMousePos;
Published | property SmoothNavigator: TGLSmoothNavigator read FSmoothNavigator write SetSmoothNavigator;
Published | property SmoothVertNavigator: TGLSmoothNavigator read FSmoothVertNavigator write SetSmoothVertNavigator;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function MouseLook(const NewXY: TGLPoint; const ADeltaTime: Double): Boolean; overload;
Public function MouseLook(const ADeltaTime: Double): Boolean; overload;
Public function MouseLook(const NewX, NewY: Integer; const ADeltaTime: Double): Boolean; overload;
Public procedure MouseLookActiveToggle; virtual;
Public procedure TurnHorizontal(const Angle : Single; const ADeltaTime: Double); virtual;
Public procedure TurnVertical(const Angle : Single; const ADeltaTime: Double); virtual;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published property AutoUpdateMouse: Boolean read FAutoUpdateMouse write FAutoUpdateMouse default True;
Published property InvertMouse: Boolean read FInvertMouse write FInvertMouse default False;
Published property MouseLookActive: Boolean read FMouseLookActive write SetMouseLookActive default False;
Published property OriginalMousePos: TGLCoordinates2 read FOriginalMousePos write SetOriginalMousePos;
Published property SmoothNavigator: TGLSmoothNavigator read FSmoothNavigator write SetSmoothNavigator;
Published property SmoothVertNavigator: TGLSmoothNavigator read FSmoothVertNavigator write SetSmoothVertNavigator;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSMOpenAL

Unit GLSMOpenAL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSMOpenAL<p>

OpenAL based sound-manager (http://www.openal.org).<p> OpenAL drivers can be download from the OpenAL site or your soundcard manufacturer's website.<p>

Unsupported feature(s) :<ul> <li>Accepts only simple *uncompressed* WAV files (8/16 bits, mono/stereo) <li>Dynamic loading/unloading <li>Global 3D parameters <li>Environments <li>CPUUsagePercent <li>No system in place to limit number of sources playing simultaneously, can crash if too playing at once. <li>??? </ul><p>

<b>History : </b><font size=-1><ul> <li>11/11/09 - DaStr - Added $I GLScene.inc <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>25/03/08 - DanB - Added design-time support, linked to new OpenAL headers (see OpenAL.pas). <li>??/??/03 - Mrqzz - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSMOpenAL |

Functions and Procedures

procedure Register;

Types

EOpenALError = Exception;

Description

Functions and Procedures

procedure Register;

Types

EOpenALError = Exception;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSMOpenAL: Class TGLSMOpenAL

Class TGLSMOpenAL

Unit

GLSMOpenAL

Declaration

type TGLSMOpenAL = class(TGLSoundManager)

Description

no description available, TGLSoundManager description follows

Base class for sound manager components.<p> The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this).<p> Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLSoundManager
  • TGLSMOpenAL

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Public | function EAXSupported : Boolean; override;
Protected | function DoActivate : Boolean; override;
Protected | function GetALFormat(sampling : TGLSoundSampling) : Integer;
Protected | function GetDefaultFrequency(aSource : TGLBaseSoundSource) : Integer;
Public | procedure UpdateSources; override;
Protected | procedure DoDeActivate; override;
Protected | procedure KillSource(aSource : TGLBaseSoundSource); override;
Protected | procedure MuteSource(aSource : TGLBaseSoundSource; muted : Boolean); override;
Protected | procedure Notify3DFactorsChanged; override;
Protected | procedure NotifyEnvironmentChanged; override;
Protected | procedure NotifyMasterVolumeChange; override;
Protected | procedure PauseSource(aSource : TGLBaseSoundSource; paused : Boolean); override;
Protected | procedure UpdateSource(aSource : TGLBaseSoundSource); override;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Public function EAXSupported : Boolean; override;
Protected function DoActivate : Boolean; override;
Protected function GetALFormat(sampling : TGLSoundSampling) : Integer;
Protected function GetDefaultFrequency(aSource : TGLBaseSoundSource) : Integer;
Public procedure UpdateSources; override;
Protected procedure DoDeActivate; override;
Protected procedure KillSource(aSource : TGLBaseSoundSource); override;
Protected procedure MuteSource(aSource : TGLBaseSoundSource; muted : Boolean); override;
Protected procedure Notify3DFactorsChanged; override;
Protected procedure NotifyEnvironmentChanged; override;
Protected procedure NotifyMasterVolumeChange; override;
Protected procedure PauseSource(aSource : TGLBaseSoundSource; paused : Boolean); override;
Protected procedure UpdateSource(aSource : TGLBaseSoundSource); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSMWaveOut

Unit GLSMWaveOut

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSMWaveOut<p>

Basic sound manager based on WinMM <p>

<b>History : </b><font size=-1><ul> <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>25/07/09 - DaStr - Added $I GLScene.inc <li>30/05/09 - DanB - Fixes for AV when sound finishes, and was repeating the same code more than necessary. <li>24/04/09 - DanB - Creation, split from GLSound.pas, to remove windows dependency </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSMWaveOut |

Functions and Procedures

procedure PlayOnWaveOut(pcmData : Pointer; lengthInBytes : Integer; sampling : TGLSoundSampling); overload;
function PlayOnWaveOut(pcmData : Pointer; lengthInBytes : Integer; waveFormat : TWaveFormatEx) : HWaveOut; overload;

Description

Functions and Procedures

procedure PlayOnWaveOut(pcmData : Pointer; lengthInBytes : Integer; sampling : TGLSoundSampling); overload;
function PlayOnWaveOut(pcmData : Pointer; lengthInBytes : Integer; waveFormat : TWaveFormatEx) : HWaveOut; overload;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSMWaveOut: Class TGLSMWaveOut

Class TGLSMWaveOut

Unit

GLSMWaveOut

Declaration

type TGLSMWaveOut = class(TGLSoundManager)

Description

Basic sound manager based on WinMM <i>waveOut</i> function.<p> This manager has NO 3D miximing capacity, this is merely a default manager that should work on any windows based system, and help showcasing/testing basic GLSS core functionality.<p> Apart from 3D, mute, pause, priority and volume are ignored too, and only sampling conversions supported by the windows ACM driver are supported (ie. no 4bits samples playback etc.).

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLSoundManager
  • TGLSMWaveOut

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Protected | function DoActivate : Boolean; override;
Public | procedure UpdateSources; override;
Protected | procedure DoDeActivate; override;
Protected | procedure KillSource(aSource : TGLBaseSoundSource); override;

Properties

Published property MaxChannels default 4;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Protected function DoActivate : Boolean; override;
Public procedure UpdateSources; override;
Protected procedure DoDeActivate; override;
Protected procedure KillSource(aSource : TGLBaseSoundSource); override;

Properties

Published property MaxChannels default 4;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSound

Unit GLSound

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSound<p>

Base classes and interface for GLScene Sound System<p>

<b>History : </b><font size=-1><ul> <li>24/04/11 - Yar - Bugfixed TGLSoundSample.Assign (thanks to Anonymous) <li>06/06/10 - Yar - Fixed warnings <li>06/05/09 - DanB - Split TGLSMWaveOut to GLSMWaveOut.pas, to remove windows dependancy <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>22/07/02 - EG - SetMute/SetPause fix (Sternas Stefanos) <li>02/07/02 - EG - Persistence fix (MP3 / Sternas Stefanos) <li>05/03/02 - EG - TGLBSoundEmitter.Loaded <li>27/02/02 - EG - Added 3D Factors, special listener-is-camera support <li>13/01/01 - EG - Added CPUUsagePercent <li>09/06/00 - EG - Various enhancements <li>04/06/00 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSoundSample |
Class TGLSoundSamples |
Class TGLSoundLibrary |
Class TGLBaseSoundSource |
Class TGLSoundSource |
Class TGLSoundSources |
Class TGLSoundManager |
Class TGLBSoundEmitter |

Functions and Procedures

function ActiveSoundManager: TGLSoundManager;
function GetSoundLibraryByName(const aName: string): TGLSoundLibrary;
function GetOrCreateSoundEmitter(behaviours: TGLBehaviours): TGLBSoundEmitter; overload;
function GetOrCreateSoundEmitter(obj: TGLBaseSceneObject): TGLBSoundEmitter; overload;

Types

TGLSoundSourceChange = (...);
TGLSoundSourceChanges = set of TGLSoundSourceChange;
TGLSoundEnvironment = (...);

Variables

vVerboseGLSMErrors: Boolean = True;

Description

Functions and Procedures

function ActiveSoundManager: TGLSoundManager;
function GetSoundLibraryByName(const aName: string): TGLSoundLibrary;
function GetOrCreateSoundEmitter(behaviours: TGLBehaviours): TGLBSoundEmitter; overload;
function GetOrCreateSoundEmitter(obj: TGLBaseSceneObject): TGLBSoundEmitter; overload;

Types

TGLSoundSourceChange = (...);
Values
  • sscTransformation:
  • sscSample:
  • sscStatus:
TGLSoundSourceChanges = set of TGLSoundSourceChange;
TGLSoundEnvironment = (...);

EAX standard sound environments.

Values
  • seDefault:
  • sePaddedCell:
  • seRoom:
  • seBathroom:
  • seLivingRoom:
  • seStoneroom:
  • seAuditorium:
  • seConcertHall:
  • seCave:
  • seArena:
  • seHangar:
  • seCarpetedHallway:
  • seHallway:
  • seStoneCorridor:
  • seAlley:
  • seForest:
  • seCity:
  • seMountains:
  • seQuarry:
  • sePlain:
  • seParkingLot:
  • seSewerPipe:
  • seUnderWater:
  • seDrugged:
  • seDizzy:
  • sePsychotic:

Variables

vVerboseGLSMErrors: Boolean = True;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSound: Class TGLSoundSample

Class TGLSoundSample

Unit

GLSound

Declaration

type TGLSoundSample = class(TCollectionItem)

Description

Stores a single PCM coded sound sample.

Hierarchy

  • TCollectionItem
  • TGLSoundSample

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function LengthInBytes: Integer;
Public | function LengthInSamples: Integer;
Public | function LengthInSec: Single;
Public | function Sampling: TGLSoundSampling;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string);
Public | procedure PlayOnWaveOut;
Protected | procedure DefineProperties(Filer: TFiler); override;
Protected | procedure ReadData(Stream: TStream); virtual;
Protected | procedure SetData(const val: TGLSoundFile);
Protected | procedure WriteData(Stream: TStream); virtual;

Properties

Published | property Data: TGLSoundFile read FData write SetData stored False;
Public | property ManagerTag: Integer read FTag write FTag;
Published | property Name: string read FName write FName;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Public function LengthInBytes: Integer;
Public function LengthInSamples: Integer;
Public function LengthInSec: Single;
Public function Sampling: TGLSoundSampling;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadFromFile(const fileName: string);
Public procedure PlayOnWaveOut;
Protected procedure DefineProperties(Filer: TFiler); override;
Protected procedure ReadData(Stream: TStream); virtual;
Protected procedure SetData(const val: TGLSoundFile);
Protected procedure WriteData(Stream: TStream); virtual;

Properties

Published property Data: TGLSoundFile read FData write SetData stored False;
Public property ManagerTag: Integer read FTag write FTag;

This Tag is reserved for sound manager use only

Published property Name: string read FName write FName;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSound: Class TGLSoundSamples

Class TGLSoundSamples

Unit

GLSound

Declaration

type TGLSoundSamples = class(TCollection)

Description

Hierarchy

  • TCollection
  • TGLSoundSamples

Overview

Fields

Protected owner: TComponent;

Methods

Public | constructor Create(AOwner: TComponent);
Public | function Add: TGLSoundSample;
Public | function AddFile(const fileName: string; const sampleName: string = ''): TGLSoundSample;
Public | function FindItemID(ID: Integer): TGLSoundSample;
Public | function GetByName(const aName: string): TGLSoundSample;
Protected | function GetItems(index: Integer): TGLSoundSample;
Protected | function GetOwner: TPersistent; override;
Protected | procedure SetItems(index: Integer; const val: TGLSoundSample);

Properties

Public property Items[index: Integer]: TGLSoundSample read GetItems write SetItems;

Description

Fields

Protected owner: TComponent;

Methods

Public constructor Create(AOwner: TComponent);
Public function Add: TGLSoundSample;
Public function AddFile(const fileName: string; const sampleName: string = ''): TGLSoundSample;
Public function FindItemID(ID: Integer): TGLSoundSample;
Public function GetByName(const aName: string): TGLSoundSample;
Protected function GetItems(index: Integer): TGLSoundSample;
Protected function GetOwner: TPersistent; override;
Protected procedure SetItems(index: Integer; const val: TGLSoundSample);

Properties

Public property Items[index: Integer]: TGLSoundSample read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSound: Class TGLSoundLibrary

Class TGLSoundLibrary

Unit

GLSound

Declaration

type TGLSoundLibrary = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLSoundLibrary

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetSamples(const val: TGLSoundSamples);

Properties

Published property Samples: TGLSoundSamples read FSamples write SetSamples;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetSamples(const val: TGLSoundSamples);

Properties

Published property Samples: TGLSoundSamples read FSamples write SetSamples;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSound: Class TGLBaseSoundSource

Class TGLBaseSoundSource

Unit

GLSound

Declaration

type TGLBaseSoundSource = class(TCollectionItem)

Description

Base class for origin of sound playback.

Hierarchy

  • TCollectionItem
  • TGLBaseSoundSource

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function Sample: TGLSoundSample;
Protected | function GetDisplayName: string; override;
Protected | function GetSoundLibrary: TGLSoundLibrary;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure ReadFromFiler(reader: TReader);
Protected | procedure SetConeOutsideVolume(const val: Single);
Protected | procedure SetFrequency(const val: Integer);
Protected | procedure SetInsideConeAngle(const val: Single);
Protected | procedure SetMaxDistance(const val: Single);
Protected | procedure SetMinDistance(const val: Single);
Protected | procedure SetMute(const val: Boolean);
Protected | procedure SetNbLoops(const val: Integer);
Protected | procedure SetOrigin(const val: TGLBaseSceneObject);
Protected | procedure SetOutsideConeAngle(const val: Single);
Protected | procedure SetPause(const val: Boolean);
Protected | procedure SetPriority(const val: Integer);
Protected | procedure SetSoundLibrary(const val: TGLSoundLibrary);
Protected | procedure SetSoundName(const val: string);
Protected | procedure SetVolume(const val: Single);
Protected | procedure WriteToFiler(writer: TWriter);

Properties

Public | property Changes: TGLSoundSourceChanges read FChanges;
Published | property ConeOutsideVolume: Single read FConeOutsideVolume write SetConeOutsideVolume;
Published | property Frequency: Integer read FFrequency write SetFrequency default -1;
Published | property InsideConeAngle: Single read FInsideConeAngle write SetInsideConeAngle;
Public | property ManagerTag: PtrUInt read FTag write FTag;
Published | property MaxDistance: Single read FMaxDistance write SetMaxDistance;
Published | property MinDistance: Single read FMinDistance write SetMinDistance;
Published | property Mute: Boolean read FMute write SetMute default False;
Published | property NbLoops: Integer read FNbLoops write SetNbLoops default 1;
Public | property Origin: TGLBaseSceneObject read FOrigin write SetOrigin;
Published | property OutsideConeAngle: Single read FOutsideConeAngle write SetOutsideConeAngle;
Published | property Pause: Boolean read FPause write SetPause default False;
Published | property Priority: Integer read FPriority write SetPriority default 0;
Published | property SoundLibrary: TGLSoundLibrary read GetSoundLibrary write SetSoundLibrary;
Published | property SoundName: string read FSoundName write SetSoundName;
Published | property Volume: Single read FVolume write SetVolume;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Public function Sample: TGLSoundSample;
Protected function GetDisplayName: string; override;
Protected function GetSoundLibrary: TGLSoundLibrary;
Public procedure Assign(Source: TPersistent); override;
Protected procedure ReadFromFiler(reader: TReader);
Protected procedure SetConeOutsideVolume(const val: Single);
Protected procedure SetFrequency(const val: Integer);
Protected procedure SetInsideConeAngle(const val: Single);
Protected procedure SetMaxDistance(const val: Single);
Protected procedure SetMinDistance(const val: Single);
Protected procedure SetMute(const val: Boolean);
Protected procedure SetNbLoops(const val: Integer);
Protected procedure SetOrigin(const val: TGLBaseSceneObject);
Protected procedure SetOutsideConeAngle(const val: Single);
Protected procedure SetPause(const val: Boolean);
Protected procedure SetPriority(const val: Integer);
Protected procedure SetSoundLibrary(const val: TGLSoundLibrary);
Protected procedure SetSoundName(const val: string);
Protected procedure SetVolume(const val: Single);
Protected procedure WriteToFiler(writer: TWriter);

Properties

Public property Changes: TGLSoundSourceChanges read FChanges;
Published property ConeOutsideVolume: Single read FConeOutsideVolume write SetConeOutsideVolume;

Cone outside volume, [0.0; 1.0] range.<p> See DirectX SDK for details.

Published property Frequency: Integer read FFrequency write SetFrequency default -1;

Sample custom playback frequency.<p> Values null or negative are interpreted as 'default frequency'.

Published property InsideConeAngle: Single read FInsideConeAngle write SetInsideConeAngle;

Inside cone angle, [0°; 360°].<p> Sound volume is maximal within this cone.<p> See DirectX SDK for details.

Public property ManagerTag: PtrUInt read FTag write FTag;

This Tag is reserved for sound manager use only

Published property MaxDistance: Single read FMaxDistance write SetMaxDistance;

Max distance, if source is further away, it will not be heard.<p> 100.0 by default

Published property MinDistance: Single read FMinDistance write SetMinDistance;

Min distance before spatial attenuation occurs.<p> 1.0 by default

Published property Mute: Boolean read FMute write SetMute default False;
Published property NbLoops: Integer read FNbLoops write SetNbLoops default 1;

Nb of playing loops.

Public property Origin: TGLBaseSceneObject read FOrigin write SetOrigin;

Origin object for the sound sources.<p> Absolute object position/orientation are taken into account, the object's TGLBInertia is considered if any.<p> If origin is nil, the source is assumed to be static at the origin.<p> <b>Note :</b> since TCollectionItem do not support the "Notification" scheme, it is up to the Origin object to take care of updating this property prior to release/destruction.

Published property OutsideConeAngle: Single read FOutsideConeAngle write SetOutsideConeAngle;

Outside cone angle, [0°; 360°].<p> Between inside and outside cone, sound volume decreases between max and cone outside volume.<p> See DirectX SDK for details.

Published property Pause: Boolean read FPause write SetPause default False;
Published property Priority: Integer read FPriority write SetPriority default 0;

Sound source priority, the higher the better.<p> When maximum number of sound sources is reached, only the sources with the highest priority will continue to play, however, even non-playing sources should be tracked by the manager, thus allowing an "unlimited" amount of sources from the application point of view.

Published property SoundLibrary: TGLSoundLibrary read GetSoundLibrary write SetSoundLibrary;
Published property SoundName: string read FSoundName write SetSoundName;
Published property Volume: Single read FVolume write SetVolume;

Volume of the source, [0.0; 1.0] range

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSound: Class TGLSoundSource

Class TGLSoundSource

Unit

GLSound

Declaration

type TGLSoundSource = class(TGLBaseSoundSource)

Description

Origin of sound playback.<p> Just publishes the 'Origin' property.<p> Note that the "orientation" is the the source's Direction, ie. the "Z" vector.

Hierarchy

  • TCollectionItem
  • TGLBaseSoundSource
  • TGLSoundSource

Overview

Methods

Public destructor Destroy; override;

Properties

Published property Origin;

Description

Methods

Public destructor Destroy; override;

Properties

Published property Origin;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSound: Class TGLSoundSources

Class TGLSoundSources

Unit

GLSound

Declaration

type TGLSoundSources = class(TCollection)

Description

Hierarchy

  • TCollection
  • TGLSoundSources

Overview

Fields

Protected owner: TComponent;

Methods

Public | constructor Create(AOwner: TComponent);
Protected | function Add: TGLSoundSource;
Protected | function FindItemID(ID: Integer): TGLSoundSource;
Protected | function GetItems(index: Integer): TGLSoundSource;
Protected | function GetOwner: TPersistent; override;
Protected | procedure SetItems(index: Integer; const val: TGLSoundSource);

Properties

Public property Items[index: Integer]: TGLSoundSource read GetItems write SetItems;

Description

Fields

Protected owner: TComponent;

Methods

Public constructor Create(AOwner: TComponent);
Protected function Add: TGLSoundSource;
Protected function FindItemID(ID: Integer): TGLSoundSource;
Protected function GetItems(index: Integer): TGLSoundSource;
Protected function GetOwner: TPersistent; override;
Protected procedure SetItems(index: Integer; const val: TGLSoundSource);

Properties

Public property Items[index: Integer]: TGLSoundSource read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSound: Class TGLSoundManager

Class TGLSoundManager

Unit

GLSound

Declaration

type TGLSoundManager = class(TGLCadenceAbleComponent)

Description

Base class for sound manager components.<p> The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this).<p> Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLSoundManager

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CPUUsagePercent: Single; virtual;
Public | function EAXSupported: Boolean; dynamic;
Protected | function DoActivate: Boolean; dynamic;
Protected | function DoMute: Boolean; dynamic;
Protected | function DoPause: Boolean; dynamic;
Protected | function StoreDistanceFactor: Boolean;
Protected | function StoreRollOffFactor: Boolean;
Protected | function StoreUpdateFrequency: Boolean;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Public | procedure StopAllSources;
Public | procedure UpdateSources; virtual;
Protected | procedure DefineProperties(Filer: TFiler); override;
Protected | procedure DoDeActivate; dynamic;
Protected | procedure DoUnMute; dynamic;
Protected | procedure DoUnPause; dynamic;
Protected | procedure KillSource(aSource: TGLBaseSoundSource); virtual;
Protected | procedure ListenerCoordinates(var position, velocity, direction, up: TVector);
Protected | procedure Loaded; override;
Protected | procedure MuteSource(aSource: TGLBaseSoundSource; muted: Boolean); virtual;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure Notify3DFactorsChanged; dynamic;
Protected | procedure NotifyEnvironmentChanged; dynamic;
Protected | procedure NotifyMasterVolumeChange; dynamic;
Protected | procedure PauseSource(aSource: TGLBaseSoundSource; paused: Boolean); virtual;
Protected | procedure SetCadencer(const val: TGLCadencer);
Protected | procedure SetDistanceFactor(const val: Single);
Protected | procedure SetDopplerFactor(const val: Single);
Protected | procedure SetListener(const val: TGLBaseSceneObject);
Protected | procedure SetMasterVolume(const val: Single);
Protected | procedure SetMaxChannels(const val: Integer);
Protected | procedure SetOutputFrequency(const val: Integer);
Protected | procedure SetRollOffFactor(const val: Single);
Protected | procedure SetSoundEnvironment(const val: TGLSoundEnvironment);
Protected | procedure SetSources(const val: TGLSoundSources);
Protected | procedure SetUpdateFrequency(const val: Single);
Protected | procedure UpdateSource(aSource: TGLBaseSoundSource); virtual;

Properties

Published | property Active: Boolean read FActive write SetActive default False;
Published | property Cadencer: TGLCadencer read FCadencer write SetCadencer;
Published | property DistanceFactor: Single read FDistanceFactor write SetDistanceFactor stored StoreDistanceFactor;
Published | property DopplerFactor: Single read FDopplerFactor write SetDopplerFactor stored False;
Published | property Environment: TGLSoundEnvironment read FSoundEnvironment write SetSoundEnvironment default seDefault;
Published | property Listener: TGLBaseSceneObject read FListener write SetListener;
Published | property MasterVolume: Single read FMasterVolume write SetMasterVolume;
Published | property MaxChannels: Integer read FMaxChannels write SetMaxChannels default 8;
Published | property Mute: Boolean read FMute write SetMute default False;
Published | property OutputFrequency: Integer read FOutputFrequency write SetOutputFrequency default 44100;
Published | property Pause: Boolean read FPause write SetPause default False;
Published | property RollOffFactor: Single read FRollOffFactor write SetRollOffFactor stored StoreRollOffFactor;
Published | property Sources: TGLSoundSources read FSources write SetSources;
Published | property UpdateFrequency: Single read FUpdateFrequency write SetUpdateFrequency stored StoreUpdateFrequency;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function CPUUsagePercent: Single; virtual;

Sound manager API reported CPU Usage.<p> Returns -1 when unsupported.

Public function EAXSupported: Boolean; dynamic;

True if EAX is supported.

Protected function DoActivate: Boolean; dynamic;
Protected function DoMute: Boolean; dynamic;

Effect mute of all sounds.<p> Default implementation call MuteSource for all non-muted sources with "True" as parameter.

Protected function DoPause: Boolean; dynamic;

Effect pause of all sounds.<p> Default implementation call PauseSource for all non-paused sources with "True" as parameter.

Protected function StoreDistanceFactor: Boolean;
Protected function StoreRollOffFactor: Boolean;
Protected function StoreUpdateFrequency: Boolean;
Public procedure DoProgress(const progressTime: TProgressTimes); override;

Progress notification for time synchronization.<p> This method will call UpdateSources depending on the last time it was performed and the value of the UpdateFrequency property.

Public procedure StopAllSources;

Stop and free all sources.

Public procedure UpdateSources; virtual;

Manual request to update all sources to reflect changes.<p> Default implementation invokes UpdateSource for all known sources.

Protected procedure DefineProperties(Filer: TFiler); override;
Protected procedure DoDeActivate; dynamic;

Invoked AFTER all sources have been stopped

Protected procedure DoUnMute; dynamic;

Effect un-mute of all sounds.<p> Default implementation call MuteSource for all non-muted sources with "False" as parameter.

Protected procedure DoUnPause; dynamic;

Effect un-pause of all sounds.<p> Default implementation call PauseSource for all non-paused sources with "True" as parameter.

Protected procedure KillSource(aSource: TGLBaseSoundSource); virtual;

Called when a source will be freed

Protected procedure ListenerCoordinates(var position, velocity, direction, up: TVector);
Protected procedure Loaded; override;
Protected procedure MuteSource(aSource: TGLBaseSoundSource; muted: Boolean); virtual;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure Notify3DFactorsChanged; dynamic;
Protected procedure NotifyEnvironmentChanged; dynamic;
Protected procedure NotifyMasterVolumeChange; dynamic;
Protected procedure PauseSource(aSource: TGLBaseSoundSource; paused: Boolean); virtual;
Protected procedure SetCadencer(const val: TGLCadencer);
Protected procedure SetDistanceFactor(const val: Single);
Protected procedure SetDopplerFactor(const val: Single);
Protected procedure SetListener(const val: TGLBaseSceneObject);
Protected procedure SetMasterVolume(const val: Single);
Protected procedure SetMaxChannels(const val: Integer);
Protected procedure SetOutputFrequency(const val: Integer);
Protected procedure SetRollOffFactor(const val: Single);
Protected procedure SetSoundEnvironment(const val: TGLSoundEnvironment);
Protected procedure SetSources(const val: TGLSoundSources);
Protected procedure SetUpdateFrequency(const val: Single);
Protected procedure UpdateSource(aSource: TGLBaseSoundSource); virtual;

Request to update source's data in low-level sound API.<p> Default implementation just clears the "Changes" flags.

Properties

Published property Active: Boolean read FActive write SetActive default False;

Activation/deactivation of the low-level sound API

Published property Cadencer: TGLCadencer read FCadencer write SetCadencer;

Cadencer for time-based control.<p>

Published property DistanceFactor: Single read FDistanceFactor write SetDistanceFactor stored StoreDistanceFactor;

Engine relative distance factor, compared to 1.0 meters.<p> Equates to 'how many units per meter' your engine has.

Published property DopplerFactor: Single read FDopplerFactor write SetDopplerFactor stored False;

Engine relative Doppler factor, compared to 1.0 meters.<p> Equates to 'how many units per meter' your engine has.

Published property Environment: TGLSoundEnvironment read FSoundEnvironment write SetSoundEnvironment default seDefault;

Sound environment (requires EAX compatible soundboard).

Published property Listener: TGLBaseSceneObject read FListener write SetListener;

Scene object that materializes the listener.<p> The sceneobject's AbsolutePosition and orientation are used to define the listener coordinates, velocity is automatically calculated (if you're using DoProgress or connected the manager to a cadencer).<p> If this property is nil, the listener is assumed to be static at the NullPoint coordinate, facing Z axis, with up being Y (ie. the default GLScene orientation).

Published property MasterVolume: Single read FMasterVolume write SetMasterVolume;

Master Volume adjustement in the [0.0; 1.0] range.<p> Driver should take care of properly clamping the master volume.

Published property MaxChannels: Integer read FMaxChannels write SetMaxChannels default 8;

Maximum number of sound output channels.<p> While some drivers will just ignore this value, others cannot dynamically adjust the maximum number of channels (you need to de-activate and re-activate the manager for this property to be taken into account).

Published property Mute: Boolean read FMute write SetMute default False;

Request to mute all sounds.<p> All sound requests should be handled as if sound is unmuted though, however drivers should try to take a CPU advantage of mute over MasterVolume=0

Published property OutputFrequency: Integer read FOutputFrequency write SetOutputFrequency default 44100;

Sound output mixing frequency.<p> Commonly used values ar 11025, 22050 and 44100.<p> Note that most driver cannot dynamically adjust the output frequency (you need to de-ativate and re-activate the manager for this property to be taken into account).

Published property Pause: Boolean read FPause write SetPause default False;

Request to pause all sound, sound output should be muted too.<p> When unpausing, all sound should resume at the point they were paused.

Published property RollOffFactor: Single read FRollOffFactor write SetRollOffFactor stored StoreRollOffFactor;

Sets the global attenuation rolloff factor.<p> Normally volume for a sample will scale at 1 / distance. This gives a logarithmic attenuation of volume as the source gets further away (or closer).<br> Setting this value makes the sound drop off faster or slower. The higher the value, the faster volume will fall off.

Published property Sources: TGLSoundSources read FSources write SetSources;

Currently active and playing sound sources.

Published property UpdateFrequency: Single read FUpdateFrequency write SetUpdateFrequency stored StoreUpdateFrequency;

Update frequency for time-based control (DoProgress).<p> Default value is 10 Hz (frequency is clamped in the 1Hz-60Hz range).

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSound: Class TGLBSoundEmitter

Class TGLBSoundEmitter

Unit

GLSound

Declaration

type TGLBSoundEmitter = class(TGLBehaviour)

Description

A sound emitter behaviour, plug it on any object to make it noisy.<p> This behaviour is just an interface to a TGLSoundSource, for editing convenience.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLBehaviour
  • TGLBSoundEmitter

Overview

Methods

Public | constructor Create(aOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | class function UniqueItem: Boolean; override;
Protected | function GetPlaying: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Protected | procedure Loaded; override;
Protected | procedure NotifySourceDestruction(aSource: TGLSoundSource);
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure SetPlaying(const val: Boolean);
Protected | procedure SetSource(const val: TGLBaseSoundSource);
Protected | procedure WriteToFiler(writer: TWriter); override;

Properties

Published | property Playing: Boolean read GetPlaying write SetPlaying default False;
Public | property PlayingSource: TGLSoundSource read FPlayingSource;
Published | property Source: TGLBaseSoundSource read FSource write SetSource;

Description

Methods

Public constructor Create(aOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Public class function UniqueItem: Boolean; override;
Protected function GetPlaying: Boolean;
Public procedure Assign(Source: TPersistent); override;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Protected procedure Loaded; override;
Protected procedure NotifySourceDestruction(aSource: TGLSoundSource);
Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure SetPlaying(const val: Boolean);
Protected procedure SetSource(const val: TGLBaseSoundSource);
Protected procedure WriteToFiler(writer: TWriter); override;

Properties

Published property Playing: Boolean read GetPlaying write SetPlaying default False;
Public property PlayingSource: TGLSoundSource read FPlayingSource;
Published property Source: TGLBaseSoundSource read FSource write SetSource;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSoundFileObjects

Unit GLSoundFileObjects

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSoundFileFormat<p>

Support classes for loading various fileformats.<p> These classes work together like vector file formats or Delphi's TGraphic classes.<p>

<b>Historique : </b><font size=-1><ul> <li>17/11/09 - DaStr - Improved Unix compatibility (thanks Predator) (BugtrackerID = 2893580) <li>13/07/09 - DanB - replaced sAllFilter with glsAllFilter (for FPC) <li>30/05/09 - DanB - TGLSoundSampling.WaveFormat now returns correct nBlockAlign, cbSize. <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>07/06/07 - DaStr - Added $I GLScene.inc <li>26/01/05 - JAJ - Removed leak formed by never freeing vSoundFileFormats. Reported by Dikoe Kenguru. <li>16/03/01 - Egg - TGLWAVFile.Capabilities <li>16/07/00 - Egg - Made use of new TDataFile class <li>09/06/00 - Egg - Added WAVDataSize <li>04/06/00 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSoundSampling |
Class TGLSoundFile |
record TGLSoundFileFormat |
Class TGLSoundFileFormatsList |

Functions and Procedures

function GetGLSoundFileFormats : TGLSoundFileFormatsList;
procedure RegisterSoundFileFormat(const AExtension, ADescription: String; AClass: TGLSoundFileClass);
procedure UnregisterSoundFileClass(AClass: TGLSoundFileClass);

Types

TGLSoundFileClass = class of TGLSoundFile;
PSoundFileFormat = ˆTGLSoundFileFormat;

Description

Functions and Procedures

function GetGLSoundFileFormats : TGLSoundFileFormatsList;
procedure RegisterSoundFileFormat(const AExtension, ADescription: String; AClass: TGLSoundFileClass);
procedure UnregisterSoundFileClass(AClass: TGLSoundFileClass);

Types

TGLSoundFileClass = class of TGLSoundFile;
PSoundFileFormat = ˆTGLSoundFileFormat;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSoundFileObjects: Class TGLSoundSampling

Class TGLSoundSampling

Unit

GLSoundFileObjects

Declaration

type TGLSoundSampling = class(TPersistent)

Description

Defines a sound sampling quality.

Hierarchy

  • TPersistent
  • TGLSoundSampling

Overview

Methods

Public | constructor Create(AOwner: TPersistent);
Public | destructor Destroy; override;
Public | function BytesPerSample : Integer;
Public | function BytesPerSec : Integer;
Public | function WaveFormat : TWaveFormatEx;
Protected | function GetOwner : TPersistent; override;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property BitsPerSample : Integer read FBitsPerSample write FBitsPerSample default 8;
Published | property Frequency : Integer read FFrequency write FFrequency default 22050;
Published | property NbChannels : Integer read FNbChannels write FNbChannels default 1;

Description

Methods

Public constructor Create(AOwner: TPersistent);
Public destructor Destroy; override;
Public function BytesPerSample : Integer;
Public function BytesPerSec : Integer;
Public function WaveFormat : TWaveFormatEx;
Protected function GetOwner : TPersistent; override;
Public procedure Assign(Source: TPersistent); override;

Properties

Published property BitsPerSample : Integer read FBitsPerSample write FBitsPerSample default 8;

Nb of bits per sample.<p> Common values are 8 and 16 bits.

Published property Frequency : Integer read FFrequency write FFrequency default 22050;

Sampling frequency in Hz (= samples per sec)

Published property NbChannels : Integer read FNbChannels write FNbChannels default 1;

Nb of sampling channels.<p> 1 = mono, 2 = stereo, etc.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSoundFileObjects: Class TGLSoundFile

Class TGLSoundFile

Unit

GLSoundFileObjects

Declaration

type TGLSoundFile = class(TDataFile)

Description

Abstract base class for different Sound file formats.<p> The actual implementation for these files (WAV, RAW...) must be done seperately. The concept for TGLSoundFile is very similar to TGraphic (see Delphi Help).<p> Default implementation for LoadFromFile/SaveToFile are to directly call the relevent stream-based methods, ie. you will just have to override the stream methods in most cases.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TGLSoundFile

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function LengthInBytes : Integer; virtual; abstract;
Public | function LengthInSamples : Integer;
Public | function LengthInSec : Single;
Public | function PCMData : Pointer; virtual; abstract;
Public | function WAVData : Pointer; virtual; abstract;
Public | function WAVDataSize : Integer; virtual; abstract;
Public | procedure PlayOnWaveOut; dynamic;
Protected | procedure SetSampling(const val : TGLSoundSampling);

Properties

Public property Sampling : TGLSoundSampling read FSampling write SetSampling;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public function LengthInBytes : Integer; virtual; abstract;

Length of PCM data, in bytes.

Public function LengthInSamples : Integer;

Nb of intensity samples in the sample.

Public function LengthInSec : Single;

Length of play of the sample at nominal speed in seconds.

Public function PCMData : Pointer; virtual; abstract;

Returns a pointer to the sample data viewed as an in-memory PCM buffer.

Public function WAVData : Pointer; virtual; abstract;

Returns a pointer to the sample data viewed as an in-memory WAV File.

Public function WAVDataSize : Integer; virtual; abstract;

Returns the size (in bytes) of the WAVData.

Public procedure PlayOnWaveOut; dynamic;
Protected procedure SetSampling(const val : TGLSoundSampling);

Properties

Public property Sampling : TGLSoundSampling read FSampling write SetSampling;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSoundFileObjects: record TGLSoundFileFormat

record TGLSoundFileFormat

Unit

GLSoundFileObjects

Declaration

type TGLSoundFileFormat = record

Description

Overview

Fields

SoundFileClass: TGLSoundFileClass;
Extension: String;
Description: String;
DescResID: Integer;

Description

Fields

SoundFileClass: TGLSoundFileClass;
Extension: String;
Description: String;
DescResID: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSoundFileObjects: Class TGLSoundFileFormatsList

Class TGLSoundFileFormatsList

Unit

GLSoundFileObjects

Declaration

type TGLSoundFileFormatsList = class(TList)

Description

Hierarchy

  • TList
  • TGLSoundFileFormatsList

Overview

Methods

Public | destructor Destroy; override;
Public | function FindExt(Ext: string): TGLSoundFileClass;
Public | procedure Add(const Ext, Desc: String; DescID: Integer; AClass: TGLSoundFileClass);
Public | procedure BuildFilterStrings(SoundFileClass: TGLSoundFileClass; out Descriptions, Filters: string);
Public | procedure Remove(AClass: TGLSoundFileClass);

Description

Methods

Public destructor Destroy; override;
Public function FindExt(Ext: string): TGLSoundFileClass;
Public procedure Add(const Ext, Desc: String; DescID: Integer; AClass: TGLSoundFileClass);
Public procedure BuildFilterStrings(SoundFileClass: TGLSoundFileClass; out Descriptions, Filters: string);
Public procedure Remove(AClass: TGLSoundFileClass);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSpaceText

Unit GLSpaceText

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTextAdjust |
record TFontEntry |
Class TGLSpaceText |
Class TFontManager |

Functions and Procedures

function FontManager: TFontManager;
procedure ReleaseFontManager;

Types

TSpaceTextCharRange = (...);
TGLTextHorzAdjust = (...);
TGLTextVertAdjust = (...);
PFontEntry = ˆTFontEntry;

Variables

vFontManagerMsgID: Cardinal;

Description

Functions and Procedures

function FontManager: TFontManager;
procedure ReleaseFontManager;

Types

TSpaceTextCharRange = (...);
Values
  • stcrDefault:
  • stcrAlphaNum:
  • stcrNumbers:
  • stcrWide:
TGLTextHorzAdjust = (...);
Values
  • haLeft:
  • haCenter:
  • haRight:
  • haAligned:
  • haCentrically:
  • haFitIn:
TGLTextVertAdjust = (...);
Values
  • vaTop:
  • vaCenter:
  • vaBottom:
  • vaBaseLine:
PFontEntry = ˆTFontEntry;

Variables

vFontManagerMsgID: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:54


GLScene v.1.1.2: GLSpaceText: Class TGLTextAdjust

Class TGLTextAdjust

Unit

GLSpaceText

Declaration

type TGLTextAdjust = class(TPersistent)

Description

Hierarchy

  • TPersistent
  • TGLTextAdjust

Overview

Methods

Public | constructor Create;
Public | procedure Assign(Source: TPersistent); override;

Properties

Published | property Horz: TGLTextHorzAdjust read FHorz write SetHorz default haLeft;
Public | property OnChange: TNotifyEvent read FOnChange write FOnChange;
Published | property Vert: TGLTextVertAdjust read FVert write SetVert default vaBaseLine;

Description

Methods

Public constructor Create;
Public procedure Assign(Source: TPersistent); override;

Properties

Published property Horz: TGLTextHorzAdjust read FHorz write SetHorz default haLeft;
Public property OnChange: TNotifyEvent read FOnChange write FOnChange;
Published property Vert: TGLTextVertAdjust read FVert write SetVert default vaBaseLine;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:55


GLScene v.1.1.2: GLSpaceText: record TFontEntry

record TFontEntry

Unit

GLSpaceText

Declaration

type TFontEntry = record

Description

Overview

Fields

Name: string;
FVirtualHandle: TGLVirtualHandleTransf;
Styles: TFontStyles;
Extrusion: Single;
RefCount: Integer;
allowedDeviation: Single;
firstChar: Integer;
lastChar: Integer;
glyphMetrics: array of TGlyphMetricsFloat;
FClients: TList;

Description

Fields

Name: string;
FVirtualHandle: TGLVirtualHandleTransf;
Styles: TFontStyles;
Extrusion: Single;
RefCount: Integer;
allowedDeviation: Single;
firstChar: Integer;
lastChar: Integer;
glyphMetrics: array of TGlyphMetricsFloat;
FClients: TList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:55


GLScene v.1.1.2: GLSpaceText: Class TGLSpaceText

Class TGLSpaceText

Unit

GLSpaceText

Declaration

type TGLSpaceText = class(TGLSceneObject)

Description

no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLSpaceText

Overview

Fields

Protected | FTextFontEntry: PFontEntry;
Protected | FontChanged: Boolean;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function BarycenterAbsolutePosition: TVector; override;
Public | function TextMaxHeight(const str: WideString = ''): Single;
Public | function TextMaxUnder(const str: WideString = ''): Single;
Public | function TextWidth(const str: WideString = ''): Single;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure DefaultHandler(var Message); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public | procedure NotifyChange(sender: TObject); override;
Public | procedure NotifyFontChanged;
Public | procedure TextMetrics(const str: WideString; out width, maxHeight, maxUnder: Single);
Protected | procedure DestroyHandle; override;
Protected | procedure DoOnLinesChange(sender: TObject); virtual;
Protected | procedure GetFirstAndLastChar(var firstChar, lastChar: Integer);
Protected | procedure OnFontChange(sender: TObject);

Properties

Published | property Adjust: TGLTextAdjust read FAdjust write SetAdjust;
Published | property allowedDeviation: Single read FAllowedDeviation write SetAllowedDeviation;
Published | property AspectRatio: Single read FAspectRatio write SetAspectRatio;
Published | property CharacterRange: TSpaceTextCharRange read FCharacterRange write SetCharacterRange default stcrDefault;
Published | property Extrusion: Single read FExtrusion write SetExtrusion;
Published | property Font: TFont read FFont write SetFont;
Published | property Lines: TStringList read FLines write SetLines;
Published | property Oblique: Single read FOblique write SetOblique;
Published | property Text: WideString read GetText write SetText stored False;
Published | property TextHeight: Single read FTextHeight write SetTextHeight;

Description

Fields

Protected FTextFontEntry: PFontEntry;
Protected FontChanged: Boolean;

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function BarycenterAbsolutePosition: TVector; override;
Public function TextMaxHeight(const str: WideString = ''): Single;
Public function TextMaxUnder(const str: WideString = ''): Single;
Public function TextWidth(const str: WideString = ''): Single;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure DefaultHandler(var Message); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Public procedure NotifyChange(sender: TObject); override;
Public procedure NotifyFontChanged;
Public procedure TextMetrics(const str: WideString; out width, maxHeight, maxUnder: Single);
Protected procedure DestroyHandle; override;
Protected procedure DoOnLinesChange(sender: TObject); virtual;
Protected procedure GetFirstAndLastChar(var firstChar, lastChar: Integer);
Protected procedure OnFontChange(sender: TObject);

Properties

Published property Adjust: TGLTextAdjust read FAdjust write SetAdjust;
Published property allowedDeviation: Single read FAllowedDeviation write SetAllowedDeviation;
Published property AspectRatio: Single read FAspectRatio write SetAspectRatio;
Published property CharacterRange: TSpaceTextCharRange read FCharacterRange write SetCharacterRange default stcrDefault;
Published property Extrusion: Single read FExtrusion write SetExtrusion;
Published property Font: TFont read FFont write SetFont;
Published property Lines: TStringList read FLines write SetLines;
Published property Oblique: Single read FOblique write SetOblique;
Published property Text: WideString read GetText write SetText stored False;
Published property TextHeight: Single read FTextHeight write SetTextHeight;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:55


GLScene v.1.1.2: GLSpaceText: Class TFontManager

Class TFontManager

Unit

GLSpaceText

Declaration

type TFontManager = class(TList)

Description

Hierarchy

  • TList
  • TFontManager

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function FindFont(AName: string; FStyles: TFontStyles; FExtrusion: Single; FAllowedDeviation: Single; FFirstChar, FLastChar: Integer): PFontEntry;
Public | function GetFontBase(AName: string; FStyles: TFontStyles; FExtrusion: Single; allowedDeviation: Single; firstChar, lastChar: Integer; client: TObject): PFontEntry;
Public | procedure Release(entry: PFontEntry; client: TObject);
Protected | procedure NotifyClients(Clients: TList);
Protected | procedure VirtualHandleAlloc(sender: TGLVirtualHandle; var handle: Cardinal);
Protected | procedure VirtualHandleDestroy(sender: TGLVirtualHandle; var handle: Cardinal);

Description

Methods

Public constructor Create;
Public destructor Destroy; override;
Public function FindFont(AName: string; FStyles: TFontStyles; FExtrusion: Single; FAllowedDeviation: Single; FFirstChar, FLastChar: Integer): PFontEntry;
Public function GetFontBase(AName: string; FStyles: TFontStyles; FExtrusion: Single; allowedDeviation: Single; firstChar, lastChar: Integer; client: TObject): PFontEntry;
Public procedure Release(entry: PFontEntry; client: TObject);
Protected procedure NotifyClients(Clients: TList);
Protected procedure VirtualHandleAlloc(sender: TGLVirtualHandle; var handle: Cardinal);
Protected procedure VirtualHandleDestroy(sender: TGLVirtualHandle; var handle: Cardinal);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:55


GLScene v.1.1.2: GLSpatialPartitioning

Unit GLSpatialPartitioning

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLSpatialPartitioning<p>

<p>Spatial partitioning related code that also uses GLScene objects

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>06/06/10 - Yar - Added VectorTypes to uses <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>24/03/07 - DaStr - Replaced GLWin32Viewer with GLViewer (thanks Burkhard Carstens) (Bugtracker ID = 1684432) <li>06/03/07 - DaStr - Removed obsolete FPC IFDEF's <li>19/12/06 - DaStr - Old version of ExtendedFrustumMakeFromSceneViewer function restored as an overloaded version of the new one <li>04/11/05 - Mathx - Corrections related to bug 1335349 (ExtendedFrustumMakeFromSceneViewer supporting more than just regular TGLSceneViewer). <li>03/12/04 - MF - Created </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TSceneObj |

Functions and Procedures

procedure RenderSpatialPartitioning(var rci: TRenderContextInfo; const Space: TSectoredSpacePartition);
function ExtendedFrustumMakeFromSceneViewer(const AFrustum: TFrustum; const vWidth, vHeight: integer; AGLCamera: TGLCamera): TExtendedFrustum; overload;
function ExtendedFrustumMakeFromSceneViewer(const AFrustum: TFrustum; const AGLSceneViewer: TGLSceneViewer): TExtendedFrustum; overload;
procedure RenderAABB(var rci: TRenderContextInfo; AABB: TAABB; w, r, g, b: single); overload;
procedure RenderAABB(var rci: TRenderContextInfo; AABB: TAABB); overload;

Description

Functions and Procedures

procedure RenderSpatialPartitioning(var rci: TRenderContextInfo; const Space: TSectoredSpacePartition);

Render a spacial partitioning descending from TSectoredSpacePartition (octree and quadtree) as a grid - great for debugging and visualisation

function ExtendedFrustumMakeFromSceneViewer(const AFrustum: TFrustum; const vWidth, vHeight: integer; AGLCamera: TGLCamera): TExtendedFrustum; overload;

Create an extended frustum from a GLSceneViewer - this makes the unit specific to the windows platform!

function ExtendedFrustumMakeFromSceneViewer(const AFrustum: TFrustum; const AGLSceneViewer: TGLSceneViewer): TExtendedFrustum; overload;
procedure RenderAABB(var rci: TRenderContextInfo; AABB: TAABB; w, r, g, b: single); overload;

Renders an AABB as a line

procedure RenderAABB(var rci: TRenderContextInfo; AABB: TAABB); overload;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:55


GLScene v.1.1.2: GLSpatialPartitioning: Class TSceneObj

Class TSceneObj

Unit

GLSpatialPartitioning

Declaration

type TSceneObj = class(TSpacePartitionLeaf)

Description

Object for holding glscene objects in a spatial partitioning

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSpacePartitionLeaf
  • TSceneObj

Overview

Fields

Public Obj: TGLBaseSceneObject;

Methods

Public | constructor CreateObj(Owner: TSectoredSpacePartition; aObj: TGLBaseSceneObject);
Public | destructor Destroy; override;
Public | procedure UpdateCachedAABBAndBSphere; override;

Description

Fields

Public Obj: TGLBaseSceneObject;

Methods

Public constructor CreateObj(Owner: TSectoredSpacePartition; aObj: TGLBaseSceneObject);
Public destructor Destroy; override;
Public procedure UpdateCachedAABBAndBSphere; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:55


GLScene v.1.1.2: GLStarRecord

Unit GLStarRecord

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLStarRecord<p>

Unit to interface with simple star records aimed for background skies.<p>

<b>History : </b><font size=-1><ul> <li>05/07/03 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TGLStarRecord |

Functions and Procedures

function StarRecordPositionZUp(const starRecord : TGLStarRecord) : TAffineVector;
function StarRecordPositionYUp(const starRecord : TGLStarRecord) : TAffineVector;
function StarRecordColor(const starRecord : TGLStarRecord; bias : Single) : TVector;

Types

PGLStarRecord = ˆTGLStarRecord;

Description

Functions and Procedures

function StarRecordPositionZUp(const starRecord : TGLStarRecord) : TAffineVector;

Computes position on the unit sphere of a star record (Z=up).

function StarRecordPositionYUp(const starRecord : TGLStarRecord) : TAffineVector;

Computes position on the unit sphere of a star record (Y=up).

function StarRecordColor(const starRecord : TGLStarRecord; bias : Single) : TVector;

Computes star color from BV index (RGB) and magnitude (alpha).

Types

PGLStarRecord = ˆTGLStarRecord;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:55


GLScene v.1.1.2: GLStarRecord: packed record TGLStarRecord

packed record TGLStarRecord

Unit

GLStarRecord

Declaration

type TGLStarRecord = packed record

Description

Overview

Fields

RA: Word;
DEC: SmallInt;
BVColorIndex: Byte;
VMagnitude: Byte;

Description

Fields

RA: Word;
DEC: SmallInt;
BVColorIndex: Byte;
VMagnitude: Byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:55


GLScene v.1.1.2: GLState

Unit GLState

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TLightSourceState |
packed record TShaderLightSourceState |
record TUBOStates |
Class TGLStateCache |
record TStateRecord |

Types

TGLStateType = (...);
TGLStateTypes = set of TGLStateType;
TGLMeshPrimitive = (...);
TGLMeshPrimitives = set of TGLMeshPrimitive;
TGLState = (...);
TGLStates = set of TGLState;
TComparisonFunction = (...);
TStencilFunction = TComparisonFunction;
TDepthFunction = TComparisonFunction;
TBlendFunction = (...);
TDstBlendFunction = bfZero..bfOneMinusConstantAlpha;
TBlendEquation = (...);
TStencilOp = (...);
TLogicOp = (...);
TQueryType = (...);
TFaceWinding = (...);
TPolygonMode = (...);
TCullFaceMode = (...);
TColorComponent = (...);
TColorMask = set of TColorComponent;
THintType = (...);
TOnLightsChanged = procedure(Sender: TObject);
TGLBufferBindingTarget = (...);
TGLMaterialLevel = (...);

Constants

GLS_VERTEX_ATTR_NUM = 16;
cAllAttribBits = [low(TGLStateType)..High(TGLStateType)];
cAllMeshPrimitive = [ mpTRIANGLES, mpTRIANGLE_STRIP, mpTRIANGLE_FAN, mpPOINTS, mpLINES, mpLINE_LOOP, mpLINE_STRIP, mpLINES_ADJACENCY, mpLINE_STRIP_ADJACENCY, mpTRIANGLES_ADJACENCY, mpTRIANGLE_STRIP_ADJACENCY, mpPATCHES];
cAllColorComponents = [ccRed, ccGreen, ccBlue, ccAlpha];
MAX_HARDWARE_LIGHT = 16;
MAX_SHADER_LIGHT = 8;
MAX_HARDWARE_TEXTURE_UNIT = 48;
MAX_HARDWARE_UNIFORM_BUFFER_BINDING = 75;
cGLStateTypeToGLEnum: array[TGLStateType] of TGLenum = ( GL_CURRENT_BIT, GL_POINT_BIT, GL_LINE_BIT, GL_POLYGON_BIT, GL_POLYGON_STIPPLE_BIT, GL_PIXEL_MODE_BIT, GL_LIGHTING_BIT, GL_FOG_BIT, GL_DEPTH_BUFFER_BIT, GL_ACCUM_BUFFER_BIT, GL_STENCIL_BUFFER_BIT, GL_VIEWPORT_BIT, GL_TRANSFORM_BIT, GL_ENABLE_BIT, GL_COLOR_BUFFER_BIT, GL_HINT_BIT, GL_EVAL_BIT, GL_LIST_BIT, GL_TEXTURE_BIT, GL_SCISSOR_BIT, GL_MULTISAMPLE_BIT);
cGLStateToGLEnum: array[TGLState] of TStateRecord = ((GLConst: GL_ALPHA_TEST; GLDeprecated: True), (GLConst: GL_AUTO_NORMAL; GLDeprecated: True), (GLConst: GL_BLEND; GLDeprecated: False), (GLConst: GL_COLOR_MATERIAL; GLDeprecated: True), (GLConst: GL_CULL_FACE; GLDeprecated: False), (GLConst: GL_DEPTH_TEST; GLDeprecated: False), (GLConst: GL_DITHER; GLDeprecated: False), (GLConst: GL_FOG; GLDeprecated: True), (GLConst: GL_LIGHTING; GLDeprecated: True), (GLConst: GL_LINE_SMOOTH; GLDeprecated: True), (GLConst: GL_LINE_STIPPLE; GLDeprecated: True), (GLConst: GL_INDEX_LOGIC_OP; GLDeprecated: True), (GLConst: GL_COLOR_LOGIC_OP; GLDeprecated: False), (GLConst: GL_NORMALIZE; GLDeprecated: True), (GLConst: GL_POINT_SMOOTH; GLDeprecated: True), (GLConst: GL_POINT_SPRITE; GLDeprecated: True), (GLConst: GL_POLYGON_SMOOTH; GLDeprecated: True), (GLConst: GL_POLYGON_STIPPLE; GLDeprecated: True), (GLConst: GL_SCISSOR_TEST; GLDeprecated: False), (GLConst: GL_STENCIL_TEST; GLDeprecated: False), (GLConst: GL_POLYGON_OFFSET_POINT; GLDeprecated: False), (GLConst: GL_POLYGON_OFFSET_LINE; GLDeprecated: False), (GLConst: GL_POLYGON_OFFSET_FILL; GLDeprecated: False), (GLConst: GL_DEPTH_CLAMP; GLDeprecated: False) );
cGLTexTypeToGLEnum: array[TGLTextureTarget] of TGLenum = (0, GL_TEXTURE_1D, GL_TEXTURE_2D, GL_TEXTURE_3D, GL_TEXTURE_1D_ARRAY, GL_TEXTURE_2D_ARRAY, GL_TEXTURE_RECTANGLE, GL_TEXTURE_BUFFER, GL_TEXTURE_CUBE_MAP, GL_TEXTURE_2D_MULTISAMPLE, GL_TEXTURE_2D_MULTISAMPLE_ARRAY, GL_TEXTURE_CUBE_MAP_ARRAY);
cGLQueryTypeToGLEnum: array[TQueryType] of TGLenum = (GL_SAMPLES_PASSED, GL_PRIMITIVES_GENERATED, GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN, GL_TIME_ELAPSED, GL_ANY_SAMPLES_PASSED);
cGLStencilOpToGLEnum: array[TStencilOp] of TGLenum = (GL_KEEP, GL_ZERO, GL_REPLACE, GL_INCR, GL_DECR, GL_INVERT, GL_INCR_WRAP, GL_DECR_WRAP);
cGLLogicOpToGLEnum: array[TLogicOp] of TGLEnum = (GL_CLEAR, GL_AND, GL_AND_REVERSE, GL_COPY, GL_AND_INVERTED, GL_NOOP, GL_XOR, GL_OR, GL_NOR, GL_EQUIV, GL_INVERT, GL_OR_REVERSE, GL_COPY_INVERTED, GL_OR_INVERTED, GL_NAND, GL_SET);
cGLComparisonFunctionToGLEnum: array[TComparisonFunction] of TGLenum = (GL_NEVER, GL_ALWAYS, GL_LESS, GL_LEQUAL, GL_EQUAL, GL_GREATER, GL_NOTEQUAL, GL_GEQUAL);
cGLBlendFunctionToGLEnum: array[TBlendFunction] of TGLenum = (GL_ZERO, GL_ONE, GL_SRC_COLOR, GL_ONE_MINUS_SRC_COLOR, GL_DST_COLOR, GL_ONE_MINUS_DST_COLOR, GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA, GL_DST_ALPHA, GL_ONE_MINUS_DST_ALPHA, GL_CONSTANT_COLOR, GL_ONE_MINUS_CONSTANT_COLOR, GL_CONSTANT_ALPHA, GL_ONE_MINUS_CONSTANT_ALPHA, GL_SRC_ALPHA_SATURATE );
cGLBlendEquationToGLEnum: array[TBlendEquation] of TGLEnum = (GL_FUNC_ADD, GL_FUNC_SUBTRACT, GL_FUNC_REVERSE_SUBTRACT, GL_MIN, GL_MAX);
cGLFaceWindingToGLEnum: array[TFaceWinding] of TGLenum = (GL_CCW, GL_CW);
cGLPolygonModeToGLEnum: array[TPolygonMode] of TGLEnum = (GL_FILL, GL_LINE, GL_POINT);
cGLCullFaceModeToGLEnum: array[TCullFaceMode] of TGLEnum = (GL_FRONT, GL_BACK, GL_FRONT_AND_BACK);
cGLHintToGLEnum: array[THintType] of TGLEnum = (GL_DONT_CARE, GL_FASTEST, GL_NICEST);
cGLBufferBindingTarget: array[TGLBufferBindingTarget] of TGLEnum = (GL_UNIFORM_BUFFER, GL_TRANSFORM_FEEDBACK_BUFFER);

Description

Types

TGLStateType = (...);
Values
  • sttCurrent:
  • sttPoint:
  • sttLine:
  • sttPolygon:
  • sttPolygonStipple:
  • sttPixelMode:
  • sttLighting:
  • sttFog:
  • sttDepthBuffer:
  • sttAccumBuffer:
  • sttStencilBuffer:
  • sttViewport:
  • sttTransform:
  • sttEnable:
  • sttColorBuffer:
  • sttHint:
  • sttEval:
  • sttList:
  • sttTexture:
  • sttScissor:
  • sttMultisample:
TGLStateTypes = set of TGLStateType;
TGLMeshPrimitive = (...);
Values
  • mpNOPRIMITIVE:
  • mpTRIANGLES:
  • mpTRIANGLE_STRIP:
  • mpTRIANGLE_FAN:
  • mpPOINTS:
  • mpLINES:
  • mpLINE_LOOP:
  • mpLINE_STRIP:
  • mpLINES_ADJACENCY:
  • mpLINE_STRIP_ADJACENCY:
  • mpTRIANGLES_ADJACENCY:
  • mpTRIANGLE_STRIP_ADJACENCY:
  • mpPATCHES:
TGLMeshPrimitives = set of TGLMeshPrimitive;
TGLState = (...);

Reflects all relevant (binary) states of OpenGL subsystem

Values
  • stAlphaTest:
  • stAutoNormal:
  • stBlend:
  • stColorMaterial:
  • stCullFace:
  • stDepthTest:
  • stDither:
  • stFog:
  • stLighting:
  • stLineSmooth:
  • stLineStipple:
  • stIndexLogicOp:
  • stColorLogicOp:
  • stNormalize:
  • stPointSmooth:
  • stPointSprite:
  • stPolygonSmooth:
  • stPolygonStipple:
  • stScissorTest:
  • stStencilTest:
  • stPolygonOffsetPoint:
  • stPolygonOffsetLine:
  • stPolygonOffsetFill:
  • stDepthClamp:
TGLStates = set of TGLState;
TComparisonFunction = (...);
Values
  • cfNever:
  • cfAlways:
  • cfLess:
  • cfLEqual:
  • cfEqual:
  • cfGreater:
  • cfNotEqual:
  • cfGEqual:
TStencilFunction = TComparisonFunction;
TDepthFunction = TComparisonFunction;
TBlendFunction = (...);
Values
  • bfZero:
  • bfOne:
  • bfSrcColor:
  • bfOneMinusSrcColor:
  • bfDstColor:
  • bfOneMinusDstColor:
  • bfSrcAlpha:
  • bfOneMinusSrcAlpha:
  • bfDstAlpha:
  • bfOneMinusDstAlpha:
  • bfConstantColor:
  • bfOneMinusConstantColor:
  • bfConstantAlpha:
  • bfOneMinusConstantAlpha:
  • bfSrcAlphaSat:
TDstBlendFunction = bfZero..bfOneMinusConstantAlpha;
TBlendEquation = (...);
Values
  • beAdd:
  • beSubtract:
  • beReverseSubtract:
  • beMin:
  • beMax:
TStencilOp = (...);
Values
  • soKeep:
  • soZero:
  • soReplace:
  • soIncr:
  • soDecr:
  • soInvert:
  • soIncrWrap:
  • soDecrWrap:
TLogicOp = (...);
Values
  • loClear:
  • loAnd:
  • loAndReverse:
  • loCopy:
  • loAndInverted:
  • loNoOp:
  • loXOr:
  • loOr:
  • loNor:
  • loEquiv:
  • loInvert:
  • loOrReverse:
  • loCopyInverted:
  • loOrInverted:
  • loNAnd:
  • loSet:
TQueryType = (...);
Values
  • qrySamplesPassed:
  • qryPrimitivesGenerated:
  • qryTransformFeedbackPrimitivesWritten:
  • qryTimeElapsed:
  • qryAnySamplesPassed:
TFaceWinding = (...);

Describe what kind of winding has a front face

Values
  • fwCounterClockWise:
  • fwClockWise:
TPolygonMode = (...);
Values
  • pmFill:
  • pmLines:
  • pmPoints:
TCullFaceMode = (...);
Values
  • cmFront:
  • cmBack:
  • cmFrontAndBack:
TColorComponent = (...);
Values
  • ccRed:
  • ccGreen:
  • ccBlue:
  • ccAlpha:
TColorMask = set of TColorComponent;
THintType = (...);
Values
  • hintDontCare:
  • hintFastest:
  • hintNicest:
TOnLightsChanged = procedure(Sender: TObject);
TGLBufferBindingTarget = (...);
Values
  • bbtUniform:
  • bbtTransformFeedBack:
TGLMaterialLevel = (...);
Values
  • mlAuto:
  • mlFixedFunction:
  • mlMultitexturing:
  • mlSM3:
  • mlSM4:
  • mlSM5:

Constants

GLS_VERTEX_ATTR_NUM = 16;
cAllAttribBits = [low(TGLStateType)..High(TGLStateType)];
cAllMeshPrimitive = [ mpTRIANGLES, mpTRIANGLE_STRIP, mpTRIANGLE_FAN, mpPOINTS, mpLINES, mpLINE_LOOP, mpLINE_STRIP, mpLINES_ADJACENCY, mpLINE_STRIP_ADJACENCY, mpTRIANGLES_ADJACENCY, mpTRIANGLE_STRIP_ADJACENCY, mpPATCHES];
cAllColorComponents = [ccRed, ccGreen, ccBlue, ccAlpha];
MAX_HARDWARE_LIGHT = 16;
MAX_SHADER_LIGHT = 8;
MAX_HARDWARE_TEXTURE_UNIT = 48;
MAX_HARDWARE_UNIFORM_BUFFER_BINDING = 75;
cGLStateTypeToGLEnum: array[TGLStateType] of TGLenum = ( GL_CURRENT_BIT, GL_POINT_BIT, GL_LINE_BIT, GL_POLYGON_BIT, GL_POLYGON_STIPPLE_BIT, GL_PIXEL_MODE_BIT, GL_LIGHTING_BIT, GL_FOG_BIT, GL_DEPTH_BUFFER_BIT, GL_ACCUM_BUFFER_BIT, GL_STENCIL_BUFFER_BIT, GL_VIEWPORT_BIT, GL_TRANSFORM_BIT, GL_ENABLE_BIT, GL_COLOR_BUFFER_BIT, GL_HINT_BIT, GL_EVAL_BIT, GL_LIST_BIT, GL_TEXTURE_BIT, GL_SCISSOR_BIT, GL_MULTISAMPLE_BIT);
cGLStateToGLEnum: array[TGLState] of TStateRecord = ((GLConst: GL_ALPHA_TEST; GLDeprecated: True), (GLConst: GL_AUTO_NORMAL; GLDeprecated: True), (GLConst: GL_BLEND; GLDeprecated: False), (GLConst: GL_COLOR_MATERIAL; GLDeprecated: True), (GLConst: GL_CULL_FACE; GLDeprecated: False), (GLConst: GL_DEPTH_TEST; GLDeprecated: False), (GLConst: GL_DITHER; GLDeprecated: False), (GLConst: GL_FOG; GLDeprecated: True), (GLConst: GL_LIGHTING; GLDeprecated: True), (GLConst: GL_LINE_SMOOTH; GLDeprecated: True), (GLConst: GL_LINE_STIPPLE; GLDeprecated: True), (GLConst: GL_INDEX_LOGIC_OP; GLDeprecated: True), (GLConst: GL_COLOR_LOGIC_OP; GLDeprecated: False), (GLConst: GL_NORMALIZE; GLDeprecated: True), (GLConst: GL_POINT_SMOOTH; GLDeprecated: True), (GLConst: GL_POINT_SPRITE; GLDeprecated: True), (GLConst: GL_POLYGON_SMOOTH; GLDeprecated: True), (GLConst: GL_POLYGON_STIPPLE; GLDeprecated: True), (GLConst: GL_SCISSOR_TEST; GLDeprecated: False), (GLConst: GL_STENCIL_TEST; GLDeprecated: False), (GLConst: GL_POLYGON_OFFSET_POINT; GLDeprecated: False), (GLConst: GL_POLYGON_OFFSET_LINE; GLDeprecated: False), (GLConst: GL_POLYGON_OFFSET_FILL; GLDeprecated: False), (GLConst: GL_DEPTH_CLAMP; GLDeprecated: False) );
cGLTexTypeToGLEnum: array[TGLTextureTarget] of TGLenum = (0, GL_TEXTURE_1D, GL_TEXTURE_2D, GL_TEXTURE_3D, GL_TEXTURE_1D_ARRAY, GL_TEXTURE_2D_ARRAY, GL_TEXTURE_RECTANGLE, GL_TEXTURE_BUFFER, GL_TEXTURE_CUBE_MAP, GL_TEXTURE_2D_MULTISAMPLE, GL_TEXTURE_2D_MULTISAMPLE_ARRAY, GL_TEXTURE_CUBE_MAP_ARRAY);
cGLQueryTypeToGLEnum: array[TQueryType] of TGLenum = (GL_SAMPLES_PASSED, GL_PRIMITIVES_GENERATED, GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN, GL_TIME_ELAPSED, GL_ANY_SAMPLES_PASSED);
cGLStencilOpToGLEnum: array[TStencilOp] of TGLenum = (GL_KEEP, GL_ZERO, GL_REPLACE, GL_INCR, GL_DECR, GL_INVERT, GL_INCR_WRAP, GL_DECR_WRAP);
cGLLogicOpToGLEnum: array[TLogicOp] of TGLEnum = (GL_CLEAR, GL_AND, GL_AND_REVERSE, GL_COPY, GL_AND_INVERTED, GL_NOOP, GL_XOR, GL_OR, GL_NOR, GL_EQUIV, GL_INVERT, GL_OR_REVERSE, GL_COPY_INVERTED, GL_OR_INVERTED, GL_NAND, GL_SET);
cGLComparisonFunctionToGLEnum: array[TComparisonFunction] of TGLenum = (GL_NEVER, GL_ALWAYS, GL_LESS, GL_LEQUAL, GL_EQUAL, GL_GREATER, GL_NOTEQUAL, GL_GEQUAL);
cGLBlendFunctionToGLEnum: array[TBlendFunction] of TGLenum = (GL_ZERO, GL_ONE, GL_SRC_COLOR, GL_ONE_MINUS_SRC_COLOR, GL_DST_COLOR, GL_ONE_MINUS_DST_COLOR, GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA, GL_DST_ALPHA, GL_ONE_MINUS_DST_ALPHA, GL_CONSTANT_COLOR, GL_ONE_MINUS_CONSTANT_COLOR, GL_CONSTANT_ALPHA, GL_ONE_MINUS_CONSTANT_ALPHA, GL_SRC_ALPHA_SATURATE );
cGLBlendEquationToGLEnum: array[TBlendEquation] of TGLEnum = (GL_FUNC_ADD, GL_FUNC_SUBTRACT, GL_FUNC_REVERSE_SUBTRACT, GL_MIN, GL_MAX);
cGLFaceWindingToGLEnum: array[TFaceWinding] of TGLenum = (GL_CCW, GL_CW);
cGLPolygonModeToGLEnum: array[TPolygonMode] of TGLEnum = (GL_FILL, GL_LINE, GL_POINT);
cGLCullFaceModeToGLEnum: array[TCullFaceMode] of TGLEnum = (GL_FRONT, GL_BACK, GL_FRONT_AND_BACK);
cGLHintToGLEnum: array[THintType] of TGLEnum = (GL_DONT_CARE, GL_FASTEST, GL_NICEST);
cGLBufferBindingTarget: array[TGLBufferBindingTarget] of TGLEnum = (GL_UNIFORM_BUFFER, GL_TRANSFORM_FEEDBACK_BUFFER);
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:55


GLScene v.1.1.2: GLState: packed record TLightSourceState

packed record TLightSourceState

Unit

GLState

Declaration

type TLightSourceState = packed record

Description

Overview

Fields

Position: array[0..MAX_HARDWARE_LIGHT-1] of TVector;
Ambient: array[0..MAX_HARDWARE_LIGHT-1] of TVector;
Diffuse: array[0..MAX_HARDWARE_LIGHT-1] of TVector;
Specular: array[0..MAX_HARDWARE_LIGHT-1] of TVector;
SpotDirection: array[0..MAX_HARDWARE_LIGHT-1] of TVector;
SpotCosCutoffExponent: array[0..MAX_HARDWARE_LIGHT-1] of TVector;
Attenuation: array[0..MAX_HARDWARE_LIGHT-1] of TVector;

Description

Fields

Position: array[0..MAX_HARDWARE_LIGHT-1] of TVector;
Ambient: array[0..MAX_HARDWARE_LIGHT-1] of TVector;
Diffuse: array[0..MAX_HARDWARE_LIGHT-1] of TVector;
Specular: array[0..MAX_HARDWARE_LIGHT-1] of TVector;
SpotDirection: array[0..MAX_HARDWARE_LIGHT-1] of TVector;
SpotCosCutoffExponent: array[0..MAX_HARDWARE_LIGHT-1] of TVector;
Attenuation: array[0..MAX_HARDWARE_LIGHT-1] of TVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:55


GLScene v.1.1.2: GLState: packed record TShaderLightSourceState

packed record TShaderLightSourceState

Unit

GLState

Declaration

type TShaderLightSourceState = packed record

Description

Overview

Fields

Position: array[0..MAX_SHADER_LIGHT-1] of TVector;
Ambient: array[0..MAX_SHADER_LIGHT-1] of TVector;
Diffuse: array[0..MAX_SHADER_LIGHT-1] of TVector;
Specular: array[0..MAX_SHADER_LIGHT-1] of TVector;
SpotDirection: array[0..MAX_SHADER_LIGHT-1] of TVector;
SpotCosCutoffExponent: array[0..MAX_SHADER_LIGHT-1] of TVector;
Attenuation: array[0..MAX_SHADER_LIGHT-1] of TVector;

Description

Fields

Position: array[0..MAX_SHADER_LIGHT-1] of TVector;
Ambient: array[0..MAX_SHADER_LIGHT-1] of TVector;
Diffuse: array[0..MAX_SHADER_LIGHT-1] of TVector;
Specular: array[0..MAX_SHADER_LIGHT-1] of TVector;
SpotDirection: array[0..MAX_SHADER_LIGHT-1] of TVector;
SpotCosCutoffExponent: array[0..MAX_SHADER_LIGHT-1] of TVector;
Attenuation: array[0..MAX_SHADER_LIGHT-1] of TVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:55


GLScene v.1.1.2: GLState: record TUBOStates

record TUBOStates

Unit

GLState

Declaration

type TUBOStates = record

Description

Overview

Fields

FUniformBufferBinding: TGLuint;
FOffset: TGLintptr;
FSize: TGLsizeiptr;

Description

Fields

FUniformBufferBinding: TGLuint;
FOffset: TGLintptr;
FSize: TGLsizeiptr;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:55


GLScene v.1.1.2: GLState: Class TGLStateCache

Class TGLStateCache

Unit

GLState

Declaration

type TGLStateCache = class(TObject)

Description

Manages an application-side cache of OpenGL states and parameters.<p> Purpose of this class is to eliminate redundant state and parameter changes, and there will typically be no more than one state cache per OpenGL context.

Hierarchy

  • TObject
  • TGLStateCache

Overview

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | function GetLightIndicesAsAddress: PGLInt;
Public | function GetLightStateAsAddress: Pointer;
Protected | function GetActiveTextureEnabled(Target: TGLTextureTarget): Boolean;
Protected | function GetArrayBufferBinding: TGLuint;
Protected | function GetColorWriteMask(Index: Integer): TColorMask;
Protected | function GetConstantAtten(I: Integer): Single;
Protected | function GetCurrentQuery(Index: TQueryType): TGLuint;
Protected | function GetCurrentVertexAttrib(Index: Integer): TVector;
Protected | function GetDepthRangeFar:TGLclampd;
Protected | function GetDepthRangeNear:TGLclampd;
Protected | function GetElementBufferBinding: TGLuint;
Protected | function GetEnableBlend(Index: Integer): TGLboolean;
Protected | function GetEnableClipDistance(ClipDistance: Cardinal): TGLboolean;
Protected | function GetEnablePrimitiveRestart: TGLboolean;
Protected | function GetLightAmbient(I: Integer): TVector;
Protected | function GetLightDiffuse(I: Integer): TVector;
Protected | function GetLightEnabling(I: Integer): Boolean;
Protected | function GetLightPosition(I: Integer): TVector;
Protected | function GetLightSpecular(I: Integer): TVector;
Protected | function GetLightSpotDirection(I: Integer): TAffineVector;
Protected | function GetLinearAtten(I: Integer): Single;
Protected | function GetMaterialAmbient(const aFace: TCullFaceMode): TVector;
Protected | function GetMaterialDiffuse(const aFace: TCullFaceMode): TVector;
Protected | function GetMaterialEmission(const aFace: TCullFaceMode): TVector;
Protected | function GetMaterialShininess(const aFace: TCullFaceMode): Integer;
Protected | function GetMaterialSpecular(const aFace: TCullFaceMode): TVector;
Protected | function GetMax3DTextureSize: TGLuint;
Protected | function GetMaxArrayTextureSize: TGLuint;
Protected | function GetMaxCubeTextureSize: TGLuint;
Protected | function GetMaxLights: Integer;
Protected | function GetMaxSamples: TGLuint;
Protected | function GetMaxTextureAnisotropy: TGLuint;
Protected | function GetMaxTextureImageUnits: TGLuint;
Protected | function GetMaxTextureSize: TGLuint;
Protected | function GetMaxTextureUnits: TGLuint;
Protected | function GetPrimitiveRestartIndex: TGLuint;
Protected | function GetQuadAtten(I: Integer): Single;
Protected | function GetSampleMaskValue(Index: Integer): TGLbitfield;
Protected | function GetSamplerBinding(Index: TGLuint): TGLuint;
Protected | function GetSpotCutoff(I: Integer): Single;
Protected | function GetSpotExponent(I: Integer): Single;
Protected | function GetTextureBinding(Index: Integer; target: TGLTextureTarget): TGLuint;
Protected | function GetTextureBindingTime(Index: Integer; target: TGLTextureTarget): Double;
Public | procedure BeginQuery(const Target: TQueryType; const Value: TGLuint);
Public | procedure CallList(list: TGLuint);
Public | procedure Disable(const aState: TGLState);
Public | procedure Enable(const aState: TGLState);
Public | procedure EndList;
Public | procedure EndQuery(const Target: TQueryType);
Public | procedure InvertGLFrontFace;
Public | procedure NewList(list: TGLuint; mode: TGLEnum);
Public | procedure PerformDisable(const aState: TGLState);
Public | procedure PerformEnable(const aState: TGLState);
Public | procedure PopAttrib();
Public | procedure PushAttrib(stateTypes: TGLStateTypes);
Public | procedure ResetAll; deprecated;
Public | procedure ResetAllGLTextureMatrix;
Public | procedure ResetGLCurrentTexture; deprecated;
Public | procedure ResetGLFrontFace; deprecated;
Public | procedure ResetGLMaterialColors; deprecated;
Public | procedure ResetGLPolygonMode; deprecated;
Public | procedure ResetGLTexture(const TextureUnit: Integer); deprecated;
Public | procedure ResetGLTextureMatrix;
Public | procedure SetBlendEquation(const mode: TBlendEquation);
Public | procedure SetBlendEquationSeparate(const modeRGB, modeAlpha: TBlendEquation);
Public | procedure SetBlendFunc(const Src: TBlendFunction; const Dst: TDstBlendFunction);
Public | procedure SetBlendFuncSeparate(const SrcRGB: TBlendFunction; const DstRGB: TDstBlendFunction; const SrcAlpha: TBlendFunction; const DstAlpha: TDstBlendFunction);
Public | procedure SetBufferIndexedBinding(const Value: TGLuint; ATarget: TGLBufferBindingTarget; AIndex: TGLuint; ABufferSize: TGLsizeiptr); overload;
Public | procedure SetBufferIndexedBinding(const Value: TGLuint; ATarget: TGLBufferBindingTarget; AIndex: TGLuint; AOffset: TGLintptr; ARangeSize: TGLsizeiptr); overload;
Public | procedure SetColorMask(mask: TColorMask);
Public | procedure SetDepthRange(const ZNear, ZFar: TGLclampd);
Public | procedure SetFrameBuffer(const Value: TGLuint);
Public | procedure SetGLAlphaFunction(func: TComparisonFunction; ref: TGLclampf);
Public | procedure SetGLColorWriting(flag: Boolean);
Public | procedure SetGLFrontFaceCW; deprecated;
Public | procedure SetGLMaterialAlphaChannel(const aFace: TGLEnum; const alpha: TGLFloat);
Public | procedure SetGLMaterialColors(const aFace: TCullFaceMode; const emission, ambient, diffuse, specular: TVector; const shininess: Integer);
Public | procedure SetGLMaterialDiffuseColor(const aFace: TGLEnum; const diffuse: TVector);
Public | procedure SetGLState(const aState : TGLState); deprecated;
Public | procedure SetGLTextureMatrix(const matrix: TMatrix);
Public | procedure SetPolygonOffset(const factor, units: TGLfloat);
Public | procedure SetSampleCoverage(const Value: TGLfloat; invert: TGLboolean);
Public | procedure SetStencilFunc(const func: TStencilFunction; const ref: TGLint; const mask: TGLuint);
Public | procedure SetStencilFuncSeparate(const face: TCullFaceMode; const func: TStencilFunction; const ref: TGLint; const mask: TGLuint);
Public | procedure SetStencilOp(const fail, zfail, zpass: TStencilOp);
Public | procedure SetStencilOpSeparate(const face: TCullFaceMode; const sfail, dpfail, dppass: TStencilOp);
Public | procedure UnSetGLState(const aState : TGLState); deprecated;
Protected | procedure SetActiveTexture(const Value: TGLint);
Protected | procedure SetActiveTextureEnabled(Target: TGLTextureTarget; const Value: Boolean);
Protected | procedure SetArrayBufferBinding(const Value: TGLuint);
Protected | procedure SetBlendColor(const Value: TVector);
Protected | procedure SetClampReadColor(const Value: TGLenum);
Protected | procedure SetColorClearValue(const Value: TVector);
Protected | procedure SetColorWriteMask(Index: Integer; const Value: TColorMask);
Protected | procedure SetConstantAtten(I: Integer; const Value: Single);
Protected | procedure SetCopyReadBufferBinding(const Value: TGLuint);
Protected | procedure SetCopyWriteBufferBinding(const Value: TGLuint);
Protected | procedure SetCullFaceMode(const Value: TCullFaceMode);
Protected | procedure SetCurrentProgram(const Value: TGLuint);
Protected | procedure SetCurrentVertexAttrib(Index: Integer; const Value: TVector);
Protected | procedure SetDepthClearValue(const Value: TGLfloat);
Protected | procedure SetDepthFunc(const Value: TDepthFunction);
Protected | procedure SetDepthRangeFar(const Value: TGLclampd);
Protected | procedure SetDepthRangeNear(const Value: TGLclampd);
Protected | procedure SetDepthWriteMask(const Value: TGLboolean);
Protected | procedure SetDrawFrameBuffer(const Value: TGLuint);
Protected | procedure SetElementBufferBinding(const Value: TGLuint);
Protected | procedure SetEnableBlend(Index: Integer; const Value: TGLboolean);
Protected | procedure SetEnableClipDistance(Index: Cardinal; const Value: TGLboolean);
Protected | procedure SetEnableColorLogicOp(const Value: TGLboolean);
Protected | procedure SetEnableCullFace(const Value: TGLboolean);
Protected | procedure SetEnableDepthClamp(const enabled: TGLboolean);
Protected | procedure SetEnableDepthTest(const Value: TGLboolean);
Protected | procedure SetEnableDither(const Value: TGLboolean);
Protected | procedure SetEnableFramebufferSRGB(const Value: TGLboolean);
Protected | procedure SetEnableLineSmooth(const Value: TGLboolean);
Protected | procedure SetEnableMultisample(const Value: TGLboolean);
Protected | procedure SetEnablePolygonOffsetFill(const Value: TGLboolean);
Protected | procedure SetEnablePolygonOffsetLine(const Value: TGLboolean);
Protected | procedure SetEnablePolygonOffsetPoint(const Value: TGLboolean);
Protected | procedure SetEnablePolygonSmooth(const Value: TGLboolean);
Protected | procedure SetEnablePrimitiveRestart(const enabled: TGLboolean);
Protected | procedure SetEnableProgramPointSize(const Value: TGLboolean);
Protected | procedure SetEnableSampleAlphaToCoverage(const Value: TGLboolean);
Protected | procedure SetEnableSampleAlphaToOne(const Value: TGLboolean);
Protected | procedure SetEnableSampleCoverage(const Value: TGLboolean);
Protected | procedure SetEnableSampleMask(const Value: TGLboolean);
Protected | procedure SetEnableScissorTest(const Value: TGLboolean);
Protected | procedure SetEnableStencilTest(const Value: TGLboolean);
Protected | procedure SetEnableTextureCubeMapSeamless(const Value: TGLboolean);
Protected | procedure SetFFPLight(Value: Boolean);
Protected | procedure SetForwardContext(Value: Boolean);
Protected | procedure SetFragmentShaderDerivitiveHint(const Value: THintType);
Protected | procedure SetFrontFace(const Value: TFaceWinding);
Protected | procedure SetLightAmbient(I: Integer; const Value: TVector);
Protected | procedure SetLightDiffuse(I: Integer; const Value: TVector);
Protected | procedure SetLightEnabling(I: Integer; Value: Boolean);
Protected | procedure SetLightPosition(I: Integer; const Value: TVector);
Protected | procedure SetLightSpecular(I: Integer; const Value: TVector);
Protected | procedure SetLightSpotDirection(I: Integer; const Value: TAffineVector);
Protected | procedure SetLinearAtten(I: Integer; const Value: Single);
Protected | procedure SetLineSmoothHint(const Value: THintType);
Protected | procedure SetLineStippleFactor(const Value: TGLint);
Protected | procedure SetLineStipplePattern(const Value: TGLushort);
Protected | procedure SetLineWidth(const Value: TGLfloat);
Protected | procedure SetLogicOpMode(const Value: TLogicOp);
Protected | procedure SetMultisampleFilterHint(const Value: THintType);
Protected | procedure SetPackAlignment(const Value: TGLuint);
Protected | procedure SetPackImageHeight(const Value: TGLuint);
Protected | procedure SetPackLSBFirst(const Value: TGLboolean);
Protected | procedure SetPackRowLength(const Value: TGLuint);
Protected | procedure SetPackSkipImages(const Value: TGLuint);
Protected | procedure SetPackSkipPixels(const Value: TGLuint);
Protected | procedure SetPackSkipRows(const Value: TGLuint);
Protected | procedure SetPackSwapBytes(const Value: TGLboolean);
Protected | procedure SetPixelPackBufferBinding(const Value: TGLuint);
Protected | procedure SetPixelUnpackBufferBinding(const Value: TGLuint);
Protected | procedure SetPointFadeThresholdSize(const Value: TGLfloat);
Protected | procedure SetPointSize(const Value: TGLfloat);
Protected | procedure SetPointSpriteCoordOrigin(const Value: TGLenum);
Protected | procedure SetPolygonMode(const Value: TPolygonMode);
Protected | procedure SetPolygonOffsetFactor(const Value: TGLfloat);
Protected | procedure SetPolygonOffsetUnits(const Value: TGLfloat);
Protected | procedure SetPolygonSmoothHint(const Value: THintType);
Protected | procedure SetPrimitiveRestartIndex(const index: TGLuint);
Protected | procedure SetProvokingVertex(const Value: TGLenum);
Protected | procedure SetQuadAtten(I: Integer; const Value: Single);
Protected | procedure SetReadFrameBuffer(const Value: TGLuint);
Protected | procedure SetRenderBuffer(const Value: TGLuint);
Protected | procedure SetSampleCoverageInvert(const Value: TGLboolean);
Protected | procedure SetSampleCoverageValue(const Value: TGLfloat);
Protected | procedure SetSampleMaskValue(Index: Integer; const Value: TGLbitfield);
Protected | procedure SetSamplerBinding(Index: TGLuint; const Value: TGLuint);
Protected | procedure SetScissorBox(const Value: TVector4i);
Protected | procedure SetSpotCutoff(I: Integer; const Value: Single);
Protected | procedure SetSpotExponent(I: Integer; const Value: Single);
Protected | procedure SetStencilBackWriteMask(const Value: TGLuint);
Protected | procedure SetStencilClearValue(const Value: TGLuint);
Protected | procedure SetStencilWriteMask(const Value: TGLuint);
Protected | procedure SetTextureBinding(Index: Integer; target: TGLTextureTarget; const Value: TGLuint);
Protected | procedure SetTextureBufferBinding(const Value: TGLuint);
Protected | procedure SetTextureCompressionHint(const Value: THintType);
Protected | procedure SetTransformFeedbackBufferBinding(const Value: TGLuint);
Protected | procedure SetUniformBufferBinding(const Value: TGLuint);
Protected | procedure SetUnpackAlignment(const Value: TGLuint);
Protected | procedure SetUnpackImageHeight(const Value: TGLuint);
Protected | procedure SetUnpackLSBFirst(const Value: TGLboolean);
Protected | procedure SetUnpackRowLength(const Value: TGLuint);
Protected | procedure SetUnpackSkipImages(const Value: TGLuint);
Protected | procedure SetUnpackSkipPixels(const Value: TGLuint);
Protected | procedure SetUnpackSkipRows(const Value: TGLuint);
Protected | procedure SetUnpackSwapBytes(const Value: TGLboolean);
Protected | procedure SetVertexArrayBinding(const Value: TGLuint);
Protected | procedure SetViewPort(const Value: TVector4i);

Properties

Public | property ActiveTexture: TGLint read FActiveTexture write SetActiveTexture;
Public | property ActiveTextureEnabled[Target: TGLTextureTarget]: Boolean read GetActiveTextureEnabled write SetActiveTextureEnabled;
Public | property ArrayBufferBinding: TGLuint read GetArrayBufferBinding write SetArrayBufferBinding;
Public | property BlendColor: TVector read FBlendColor write SetBlendColor;
Public | property BlendDstAlpha: TDstBlendFunction read FBlendDstAlpha;
Public | property BlendDstRGB: TDstBlendFunction read FBlendDstRGB;
Public | property BlendEquationAlpha: TBlendEquation read FBlendEquationAlpha;
Public | property BlendEquationRGB: TBlendEquation read FBlendEquationRGB;
Public | property BlendSrcAlpha: TBlendFunction read FBlendSrcAlpha;
Public | property BlendSrcRGB: TBlendFunction read FBlendSrcRGB;
Public | property ClampReadColor: TGLenum read FClampReadColor write SetClampReadColor;
Public | property ColorClearValue: TVector read FColorClearValue write SetColorClearValue;
Public | property ColorWriteMask[Index: Integer]: TColorMask read GetColorWriteMask write SetColorWriteMask;
Public | property CopyReadBufferBinding: TGLuint read FCopyReadBufferBinding write SetCopyReadBufferBinding;
Public | property CopyWriteBufferBinding: TGLuint read FCopyWriteBufferBinding write SetCopyWriteBufferBinding;
Public | property CullFaceMode: TCullFaceMode read FCullFaceMode write SetCullFaceMode;
Public | property CurrentProgram: TGLuint read FCurrentProgram write SetCurrentProgram;
Public | property CurrentQuery[Index: TQueryType]: TGLuint read GetCurrentQuery;
Public | property CurrentVertexAttrib[Index: Integer]: TVector read GetCurrentVertexAttrib write SetCurrentVertexAttrib;
Public | property DepthClearValue: TGLfloat read FDepthClearValue write SetDepthClearValue;
Public | property DepthFunc: TDepthFunction read FDepthFunc write SetDepthFunc;
Public | property DepthRangeFar: TGLclampd read GetDepthRangeFar write SetDepthRangeFar;
Public | property DepthRangeNear: TGLclampd read GetDepthRangeNear write SetDepthRangeNear;
Public | property DepthWriteMask: TGLBoolean read FDepthWriteMask write SetDepthWriteMask;
Public | property DrawFrameBuffer: TGLuint read FDrawFrameBuffer write SetDrawFrameBuffer;
Public | property ElementBufferBinding: TGLuint read GetElementBufferBinding write SetElementBufferBinding;
Public | property EnableBlend[Index: Integer]: TGLboolean read GetEnableBlend write SetEnableBlend;
Public | property EnableClipDistance[Index: Cardinal]: TGLboolean read GetEnableClipDistance write SetEnableClipDistance;
Public | property EnableColorLogicOp: TGLboolean read FEnableColorLogicOp write SetEnableColorLogicOp;
Public | property EnableCullFace: TGLboolean read FEnableCullFace write SetEnableCullFace;
Public | property EnableDepthClamp: TGLboolean read FEnableDepthClamp write SetEnableDepthClamp;
Public | property EnableDepthTest: TGLboolean read FEnableDepthTest write SetEnableDepthTest;
Public | property EnableDither: TGLboolean read FEnableDither write SetEnableDither;
Public | property EnableFramebufferSRGB: TGLboolean read FEnableFramebufferSRGB write SetEnableFramebufferSRGB;
Public | property EnableLineSmooth: TGLboolean read FEnableLineSmooth write SetEnableLineSmooth;
Public | property EnableMultisample: TGLboolean read FEnableMultisample write SetEnableMultisample;
Public | property EnablePolygonOffsetFill: TGLboolean read FEnablePolygonOffsetFill write SetEnablePolygonOffsetFill;
Public | property EnablePolygonOffsetLine: TGLboolean read FEnablePolygonOffsetLine write SetEnablePolygonOffsetLine;
Public | property EnablePolygonOffsetPoint: TGLboolean read FEnablePolygonOffsetPoint write SetEnablePolygonOffsetPoint;
Public | property EnablePolygonSmooth: TGLboolean read FEnablePolygonSmooth write SetEnablePolygonSmooth;
Public | property EnablePrimitiveRestart: TGLboolean read GetEnablePrimitiveRestart write SetEnablePrimitiveRestart;
Public | property EnableProgramPointSize: TGLboolean read FEnableProgramPointSize write SetEnableProgramPointSize;
Public | property EnableSampleAlphaToCoverage: TGLboolean read FEnableSampleAlphaToCoverage write SetEnableSampleAlphaToCoverage;
Public | property EnableSampleAlphaToOne: TGLboolean read FEnableSampleAlphaToOne write SetEnableSampleAlphaToOne;
Public | property EnableSampleCoverage: TGLboolean read FEnableSampleCoverage write SetEnableSampleCoverage;
Public | property EnableSampleMask: TGLboolean read FEnableSampleMask write SetEnableSampleMask;
Public | property EnableScissorTest: TGLboolean read FEnableScissorTest write SetEnableScissorTest;
Public | property EnableStencilTest: TGLboolean read FEnableStencilTest write SetEnableStencilTest;
Public | property EnableTextureCubeMapSeamless: TGLboolean read FEnableTextureCubeMapSeamless write SetEnableTextureCubeMapSeamless;
Public | property FixedFunctionPipeLight: Boolean read FFFPLight write SetFFPLight;
Public | property ForwardContext: Boolean read FForwardContext write SetForwardContext;
Public | property FragmentShaderDerivitiveHint: THintType read FFragmentShaderDerivitiveHint write SetFragmentShaderDerivitiveHint;
Public | property FrontFace: TFaceWinding read FFrontFace write SetFrontFace;
Public | property InsideList: Boolean read FInsideList;
Public | property LightAmbient[Index: Integer]: TVector read GetLightAmbient write SetLightAmbient;
Public | property LightConstantAtten[Index: Integer]: Single read GetConstantAtten write SetConstantAtten;
Public | property LightDiffuse[Index: Integer]: TVector read GetLightDiffuse write SetLightDiffuse;
Public | property LightEnabling[Index: Integer]: Boolean read GetLightEnabling write SetLightEnabling;
Public | property LightLinearAtten[Index: Integer]: Single read GetLinearAtten write SetLinearAtten;
Public | property LightNumber: Integer read FLightNumber;
Public | property LightPosition[Index: Integer]: TVector read GetLightPosition write SetLightPosition;
Public | property LightQuadraticAtten[Index: Integer]: Single read GetQuadAtten write SetQuadAtten;
Public | property LightSpecular[Index: Integer]: TVector read GetLightSpecular write SetLightSpecular;
Public | property LightSpotCutoff[Index: Integer]: Single read GetSpotCutoff write SetSpotCutoff;
Public | property LightSpotDirection[Index: Integer]: TAffineVector read GetLightSpotDirection write SetLightSpotDirection;
Public | property LightSpotExponent[Index: Integer]: Single read GetSpotExponent write SetSpotExponent;
Public | property LineSmoothHint: THintType read FLineSmoothHint write SetLineSmoothHint;
Public | property LineStippleFactor: TGLint read FLineStippleFactor write SetLineStippleFactor;
Public | property LineStipplePattern: TGLushort read FLineStipplePattern write SetLineStipplePattern;
Public | property LineWidth: TGLfloat read FLineWidth write SetLineWidth;
Public | property LogicOpMode: TLogicOp read FLogicOpMode write SetLogicOpMode;
Public | property MaterialAmbient[const aFace: TCullFaceMode]: TVector read GetMaterialAmbient;
Public | property MaterialDiffuse[const aFace: TCullFaceMode]: TVector read GetMaterialDiffuse;
Public | property MaterialEmission[const aFace: TCullFaceMode]: TVector read GetMaterialEmission;
Public | property MaterialShininess[const aFace: TCullFaceMode]: Integer read GetMaterialShininess;
Public | property MaterialSpecular[const aFace: TCullFaceMode]: TVector read GetMaterialSpecular;
Public | property Max3DTextureSize: TGLuint read GetMax3DTextureSize;
Public | property MaxArrayTextureSize: TGLuint read GetMaxArrayTextureSize;
Public | property MaxCubeTextureSize: TGLuint read GetMaxCubeTextureSize;
Public | property MaxLights: Integer read GetMaxLights;
Public | property MaxSamples: TGLuint read GetMaxSamples;
Public | property MaxTextureAnisotropy: TGLuint read GetMaxTextureAnisotropy;
Public | property MaxTextureImageUnits: TGLuint read GetMaxTextureImageUnits;
Public | property MaxTextureSize: TGLuint read GetMaxTextureSize;
Public | property MaxTextureUnits: TGLuint read GetMaxTextureUnits;
Public | property MultisampleFilterHint: THintType read FMultisampleFilterHint write SetMultisampleFilterHint;
Public | property OnLightsChanged: TOnLightsChanged read FOnLightsChanged write FOnLightsChanged;
Public | property PackAlignment: TGLuint read FPackAlignment write SetPackAlignment;
Public | property PackImageHeight: TGLuint read FPackImageHeight write SetPackImageHeight;
Public | property PackLSBFirst: TGLboolean read FPackLSBFirst write SetPackLSBFirst;
Public | property PackRowLength: TGLuint read FPackRowLength write SetPackRowLength;
Public | property PackSkipImages: TGLuint read FPackSkipImages write SetPackSkipImages;
Public | property PackSkipPixels: TGLuint read FPackSkipPixels write SetPackSkipPixels;
Public | property PackSkipRows: TGLuint read FPackSkipRows write SetPackSkipRows;
Public | property PackSwapBytes: TGLboolean read FPackSwapBytes write SetPackSwapBytes;
Public | property PixelPackBufferBinding: TGLuint read FPixelPackBufferBinding write SetPixelPackBufferBinding;
Public | property PixelUnpackBufferBinding: TGLuint read FPixelUnpackBufferBinding write SetPixelUnpackBufferBinding;
Public | property PointFadeThresholdSize: TGLfloat read FPointFadeThresholdSize write SetPointFadeThresholdSize;
Public | property PointSize: TGLfloat read FPointSize write SetPointSize;
Public | property PointSpriteCoordOrigin: TGLenum read FPointSpriteCoordOrigin write SetPointSpriteCoordOrigin;
Public | property PolygonMode: TPolygonMode read FPolygonMode write SetPolygonMode;
Public | property PolygonOffsetFactor: TGLfloat read FPolygonOffsetFactor write SetPolygonOffsetFactor;
Public | property PolygonOffsetUnits: TGLfloat read FPolygonOffsetUnits write SetPolygonOffsetUnits;
Public | property PolygonSmoothHint: THintType read FPolygonSmoothHint write SetPolygonSmoothHint;
Public | property PrimitiveRestartIndex: TGLuint read GetPrimitiveRestartIndex write SetPrimitiveRestartIndex;
Public | property ProvokingVertex: TGLenum read FProvokingVertex write SetProvokingVertex;
Public | property ReadFrameBuffer: TGLuint read FReadFrameBuffer write SetReadFrameBuffer;
Public | property RenderBuffer: TGLuint read FRenderBuffer write SetRenderBuffer;
Public | property SampleCoverageInvert: TGLboolean read FSampleCoverageInvert write SetSampleCoverageInvert;
Public | property SampleCoverageValue: TGLfloat read FSampleCoverageValue write SetSampleCoverageValue;
Public | property SampleMaskValue[Index: Integer]: TGLbitfield read GetSampleMaskValue write SetSampleMaskValue;
Public | property SamplerBinding[Index: TGLuint]: TGLuint read GetSamplerBinding write SetSamplerBinding;
Public | property ScissorBox: TVector4i read FScissorBox write SetScissorBox;
Public | property States: TGLStates read FStates;
Public | property StencilBackFail: TStencilOp read FStencilBackFail;
Public | property StencilBackFunc: TStencilFunction read FStencilBackFunc;
Public | property StencilBackPassDepthFail: TStencilOp read FStencilBackPassDepthFail;
Public | property StencilBackPassDepthPass: TStencilOp read FStencilBackPassDepthPass;
Public | property StencilBackRef: TGLuint read FStencilBackRef;
Public | property StencilBackValueMask: TGLuint read FStencilBackValueMask;
Public | property StencilBackWriteMask: TGLuint read FStencilBackWriteMask write SetStencilBackWriteMask;
Public | property StencilClearValue: TGLuint read FStencilClearValue write SetStencilClearValue;
Public | property StencilFail: TStencilOp read FStencilFail;
Public | property StencilFunc: TStencilFunction read FStencilFunc;
Public | property StencilPassDepthFail: TStencilOp read FStencilPassDepthFail;
Public | property StencilPassDepthPass: TStencilOp read FStencilPassDepthPass;
Public | property StencilRef: TGLint read FStencilRef;
Public | property StencilValueMask: TGLuint read FStencilValueMask;
Public | property StencilWriteMask: TGLuint read FStencilWriteMask write SetStencilWriteMask;
Public | property TextureBinding[Index: Integer; target: TGLTextureTarget]: TGLuint read GetTextureBinding write SetTextureBinding;
Public | property TextureBindingTime[Index: Integer; target: TGLTextureTarget]: Double read GetTextureBindingTime;
Public | property TextureBufferBinding: TGLuint read FTextureBufferBinding write SetTextureBufferBinding;
Public | property TextureCompressionHint: THintType read FTextureCompressionHint write SetTextureCompressionHint;
Public | property TransformFeedbackBufferBinding: TGLuint read FTransformFeedbackBufferBinding write SetTransformFeedbackBufferBinding;
Public | property UniformBufferBinding: TGLuint read FUniformBufferBinding write SetUniformBufferBinding;
Public | property UnpackAlignment: TGLuint read FUnpackAlignment write SetUnpackAlignment;
Public | property UnpackImageHeight: TGLuint read FUnpackImageHeight write SetUnpackImageHeight;
Public | property UnpackLSBFirst: TGLboolean read FUnpackLSBFirst write SetUnpackLSBFirst;
Public | property UnpackRowLength: TGLuint read FUnpackRowLength write SetUnpackRowLength;
Public | property UnpackSkipImages: TGLuint read FUnpackSkipImages write SetUnpackSkipImages;
Public | property UnpackSkipPixels: TGLuint read FUnpackSkipPixels write SetUnpackSkipPixels;
Public | property UnpackSkipRows: TGLuint read FUnpackSkipRows write SetUnpackSkipRows;
Public | property UnpackSwapBytes: TGLboolean read FUnpackSwapBytes write SetUnpackSwapBytes;
Public | property VertexArrayBinding: TGLuint read FVertexArrayBinding write SetVertexArrayBinding;
Public | property ViewPort: TVector4i read FViewPort write SetViewPort;

Description

Methods

Public constructor Create; virtual;
Public destructor Destroy; override;
Public function GetLightIndicesAsAddress: PGLInt;
Public function GetLightStateAsAddress: Pointer;
Protected function GetActiveTextureEnabled(Target: TGLTextureTarget): Boolean;
Protected function GetArrayBufferBinding: TGLuint;
Protected function GetColorWriteMask(Index: Integer): TColorMask;
Protected function GetConstantAtten(I: Integer): Single;
Protected function GetCurrentQuery(Index: TQueryType): TGLuint;
Protected function GetCurrentVertexAttrib(Index: Integer): TVector;
Protected function GetDepthRangeFar:TGLclampd;
Protected function GetDepthRangeNear:TGLclampd;
Protected function GetElementBufferBinding: TGLuint;
Protected function GetEnableBlend(Index: Integer): TGLboolean;
Protected function GetEnableClipDistance(ClipDistance: Cardinal): TGLboolean;
Protected function GetEnablePrimitiveRestart: TGLboolean;
Protected function GetLightAmbient(I: Integer): TVector;
Protected function GetLightDiffuse(I: Integer): TVector;
Protected function GetLightEnabling(I: Integer): Boolean;
Protected function GetLightPosition(I: Integer): TVector;
Protected function GetLightSpecular(I: Integer): TVector;
Protected function GetLightSpotDirection(I: Integer): TAffineVector;
Protected function GetLinearAtten(I: Integer): Single;
Protected function GetMaterialAmbient(const aFace: TCullFaceMode): TVector;
Protected function GetMaterialDiffuse(const aFace: TCullFaceMode): TVector;
Protected function GetMaterialEmission(const aFace: TCullFaceMode): TVector;
Protected function GetMaterialShininess(const aFace: TCullFaceMode): Integer;
Protected function GetMaterialSpecular(const aFace: TCullFaceMode): TVector;
Protected function GetMax3DTextureSize: TGLuint;
Protected function GetMaxArrayTextureSize: TGLuint;
Protected function GetMaxCubeTextureSize: TGLuint;
Protected function GetMaxLights: Integer;
Protected function GetMaxSamples: TGLuint;
Protected function GetMaxTextureAnisotropy: TGLuint;
Protected function GetMaxTextureImageUnits: TGLuint;
Protected function GetMaxTextureSize: TGLuint;
Protected function GetMaxTextureUnits: TGLuint;
Protected function GetPrimitiveRestartIndex: TGLuint;
Protected function GetQuadAtten(I: Integer): Single;
Protected function GetSampleMaskValue(Index: Integer): TGLbitfield;
Protected function GetSamplerBinding(Index: TGLuint): TGLuint;
Protected function GetSpotCutoff(I: Integer): Single;
Protected function GetSpotExponent(I: Integer): Single;
Protected function GetTextureBinding(Index: Integer; target: TGLTextureTarget): TGLuint;
Protected function GetTextureBindingTime(Index: Integer; target: TGLTextureTarget): Double;
Public procedure BeginQuery(const Target: TQueryType; const Value: TGLuint);

Begins a query of "Target" type. "Value" must be a valid query object.

Public procedure CallList(list: TGLuint);

Call display list.

Public procedure Disable(const aState: TGLState);
Public procedure Enable(const aState: TGLState);
Public procedure EndList;

End display list.

Public procedure EndQuery(const Target: TQueryType);

Ends current query of type "Target".

Public procedure InvertGLFrontFace;

Inverts front face winding (CCW/CW).

Public procedure NewList(list: TGLuint; mode: TGLEnum);

Begin new display list.

Public procedure PerformDisable(const aState: TGLState);
Public procedure PerformEnable(const aState: TGLState);
Public procedure PopAttrib();
Public procedure PushAttrib(stateTypes: TGLStateTypes);
Public procedure ResetAll; deprecated;

Warning: this symbol is deprecated.

Public procedure ResetAllGLTextureMatrix;
Public procedure ResetGLCurrentTexture; deprecated;

Warning: this symbol is deprecated.

Public procedure ResetGLFrontFace; deprecated;

Warning: this symbol is deprecated.

Public procedure ResetGLMaterialColors; deprecated;

Warning: this symbol is deprecated.

Public procedure ResetGLPolygonMode; deprecated;

Warning: this symbol is deprecated.

Public procedure ResetGLTexture(const TextureUnit: Integer); deprecated;

Warning: this symbol is deprecated.

Public procedure ResetGLTextureMatrix;
Public procedure SetBlendEquation(const mode: TBlendEquation);

Sets the blend equation for RGB + alpha to the same value.

Public procedure SetBlendEquationSeparate(const modeRGB, modeAlpha: TBlendEquation);

Sets the blend equations for RGB + alpha separately.

Public procedure SetBlendFunc(const Src: TBlendFunction; const Dst: TDstBlendFunction);

Sets the weighting factors to be used by the blending equation, for both color + alpha.

Public procedure SetBlendFuncSeparate(const SrcRGB: TBlendFunction; const DstRGB: TDstBlendFunction; const SrcAlpha: TBlendFunction; const DstAlpha: TDstBlendFunction);

Sets the weighting factors to be used by the blending equation, with separate values used for color + alpha components.

Public procedure SetBufferIndexedBinding(const Value: TGLuint; ATarget: TGLBufferBindingTarget; AIndex: TGLuint; ABufferSize: TGLsizeiptr); overload;
Public procedure SetBufferIndexedBinding(const Value: TGLuint; ATarget: TGLBufferBindingTarget; AIndex: TGLuint; AOffset: TGLintptr; ARangeSize: TGLsizeiptr); overload;
Public procedure SetColorMask(mask: TColorMask);

Set the color write mask for all draw buffers.

Public procedure SetDepthRange(const ZNear, ZFar: TGLclampd);

Modifies the near + far clipping planes.

Public procedure SetFrameBuffer(const Value: TGLuint);

set both draw + read framebuffer.

Public procedure SetGLAlphaFunction(func: TComparisonFunction; ref: TGLclampf);

Blending states

Public procedure SetGLColorWriting(flag: Boolean);
Public procedure SetGLFrontFaceCW; deprecated;

Warning: this symbol is deprecated.

Public procedure SetGLMaterialAlphaChannel(const aFace: TGLEnum; const alpha: TGLFloat);

Adjusts material alpha channel for a face.

Public procedure SetGLMaterialColors(const aFace: TCullFaceMode; const emission, ambient, diffuse, specular: TVector; const shininess: Integer);

Adjusts material colors for a face.

Public procedure SetGLMaterialDiffuseColor(const aFace: TGLEnum; const diffuse: TVector);

Adjusts material diffuse color for a face.

Public procedure SetGLState(const aState : TGLState); deprecated;

Warning: this symbol is deprecated.

Public procedure SetGLTextureMatrix(const matrix: TMatrix);

Defines the OpenGL texture matrix.<p> Assumed texture mode is GL_MODELVIEW.

Public procedure SetPolygonOffset(const factor, units: TGLfloat);

Set polygon offset.

Public procedure SetSampleCoverage(const Value: TGLfloat; invert: TGLboolean);

Set sample coverage.

Public procedure SetStencilFunc(const func: TStencilFunction; const ref: TGLint; const mask: TGLuint);

Used to set stencil Function, Reference + Mask values, for both front + back facing primitives.

Public procedure SetStencilFuncSeparate(const face: TCullFaceMode; const func: TStencilFunction; const ref: TGLint; const mask: TGLuint);

Used to set stencil Function, Reference + Mask values for either the front or back facing primitives (or both, which is the same as calling SetStencilFunc).

Public procedure SetStencilOp(const fail, zfail, zpass: TStencilOp);

Used to set the StencilFail, StencilPassDepthFail + StencilPassDepthPass in one go.

Public procedure SetStencilOpSeparate(const face: TCullFaceMode; const sfail, dpfail, dppass: TStencilOp);

Used to set the StencilFail, StencilPassDepthFail + StencilPassDepthPass in one go, for either front or back facing primitives.

Public procedure UnSetGLState(const aState : TGLState); deprecated;

Warning: this symbol is deprecated.

Protected procedure SetActiveTexture(const Value: TGLint);
Protected procedure SetActiveTextureEnabled(Target: TGLTextureTarget; const Value: Boolean);
Protected procedure SetArrayBufferBinding(const Value: TGLuint);
Protected procedure SetBlendColor(const Value: TVector);
Protected procedure SetClampReadColor(const Value: TGLenum);
Protected procedure SetColorClearValue(const Value: TVector);
Protected procedure SetColorWriteMask(Index: Integer; const Value: TColorMask);
Protected procedure SetConstantAtten(I: Integer; const Value: Single);
Protected procedure SetCopyReadBufferBinding(const Value: TGLuint);
Protected procedure SetCopyWriteBufferBinding(const Value: TGLuint);
Protected procedure SetCullFaceMode(const Value: TCullFaceMode);
Protected procedure SetCurrentProgram(const Value: TGLuint);
Protected procedure SetCurrentVertexAttrib(Index: Integer; const Value: TVector);
Protected procedure SetDepthClearValue(const Value: TGLfloat);
Protected procedure SetDepthFunc(const Value: TDepthFunction);
Protected procedure SetDepthRangeFar(const Value: TGLclampd);
Protected procedure SetDepthRangeNear(const Value: TGLclampd);
Protected procedure SetDepthWriteMask(const Value: TGLboolean);
Protected procedure SetDrawFrameBuffer(const Value: TGLuint);
Protected procedure SetElementBufferBinding(const Value: TGLuint);
Protected procedure SetEnableBlend(Index: Integer; const Value: TGLboolean);
Protected procedure SetEnableClipDistance(Index: Cardinal; const Value: TGLboolean);
Protected procedure SetEnableColorLogicOp(const Value: TGLboolean);
Protected procedure SetEnableCullFace(const Value: TGLboolean);
Protected procedure SetEnableDepthClamp(const enabled: TGLboolean);
Protected procedure SetEnableDepthTest(const Value: TGLboolean);
Protected procedure SetEnableDither(const Value: TGLboolean);
Protected procedure SetEnableFramebufferSRGB(const Value: TGLboolean);
Protected procedure SetEnableLineSmooth(const Value: TGLboolean);
Protected procedure SetEnableMultisample(const Value: TGLboolean);
Protected procedure SetEnablePolygonOffsetFill(const Value: TGLboolean);
Protected procedure SetEnablePolygonOffsetLine(const Value: TGLboolean);
Protected procedure SetEnablePolygonOffsetPoint(const Value: TGLboolean);
Protected procedure SetEnablePolygonSmooth(const Value: TGLboolean);
Protected procedure SetEnablePrimitiveRestart(const enabled: TGLboolean);
Protected procedure SetEnableProgramPointSize(const Value: TGLboolean);
Protected procedure SetEnableSampleAlphaToCoverage(const Value: TGLboolean);
Protected procedure SetEnableSampleAlphaToOne(const Value: TGLboolean);
Protected procedure SetEnableSampleCoverage(const Value: TGLboolean);
Protected procedure SetEnableSampleMask(const Value: TGLboolean);
Protected procedure SetEnableScissorTest(const Value: TGLboolean);
Protected procedure SetEnableStencilTest(const Value: TGLboolean);
Protected procedure SetEnableTextureCubeMapSeamless(const Value: TGLboolean);
Protected procedure SetFFPLight(Value: Boolean);
Protected procedure SetForwardContext(Value: Boolean);
Protected procedure SetFragmentShaderDerivitiveHint(const Value: THintType);
Protected procedure SetFrontFace(const Value: TFaceWinding);
Protected procedure SetLightAmbient(I: Integer; const Value: TVector);
Protected procedure SetLightDiffuse(I: Integer; const Value: TVector);
Protected procedure SetLightEnabling(I: Integer; Value: Boolean);
Protected procedure SetLightPosition(I: Integer; const Value: TVector);
Protected procedure SetLightSpecular(I: Integer; const Value: TVector);
Protected procedure SetLightSpotDirection(I: Integer; const Value: TAffineVector);
Protected procedure SetLinearAtten(I: Integer; const Value: Single);
Protected procedure SetLineSmoothHint(const Value: THintType);
Protected procedure SetLineStippleFactor(const Value: TGLint);
Protected procedure SetLineStipplePattern(const Value: TGLushort);
Protected procedure SetLineWidth(const Value: TGLfloat);
Protected procedure SetLogicOpMode(const Value: TLogicOp);
Protected procedure SetMultisampleFilterHint(const Value: THintType);
Protected procedure SetPackAlignment(const Value: TGLuint);
Protected procedure SetPackImageHeight(const Value: TGLuint);
Protected procedure SetPackLSBFirst(const Value: TGLboolean);
Protected procedure SetPackRowLength(const Value: TGLuint);
Protected procedure SetPackSkipImages(const Value: TGLuint);
Protected procedure SetPackSkipPixels(const Value: TGLuint);
Protected procedure SetPackSkipRows(const Value: TGLuint);
Protected procedure SetPackSwapBytes(const Value: TGLboolean);
Protected procedure SetPixelPackBufferBinding(const Value: TGLuint);
Protected procedure SetPixelUnpackBufferBinding(const Value: TGLuint);
Protected procedure SetPointFadeThresholdSize(const Value: TGLfloat);
Protected procedure SetPointSize(const Value: TGLfloat);
Protected procedure SetPointSpriteCoordOrigin(const Value: TGLenum);
Protected procedure SetPolygonMode(const Value: TPolygonMode);
Protected procedure SetPolygonOffsetFactor(const Value: TGLfloat);
Protected procedure SetPolygonOffsetUnits(const Value: TGLfloat);
Protected procedure SetPolygonSmoothHint(const Value: THintType);
Protected procedure SetPrimitiveRestartIndex(const index: TGLuint);
Protected procedure SetProvokingVertex(const Value: TGLenum);
Protected procedure SetQuadAtten(I: Integer; const Value: Single);
Protected procedure SetReadFrameBuffer(const Value: TGLuint);
Protected procedure SetRenderBuffer(const Value: TGLuint);
Protected procedure SetSampleCoverageInvert(const Value: TGLboolean);
Protected procedure SetSampleCoverageValue(const Value: TGLfloat);
Protected procedure SetSampleMaskValue(Index: Integer; const Value: TGLbitfield);
Protected procedure SetSamplerBinding(Index: TGLuint; const Value: TGLuint);
Protected procedure SetScissorBox(const Value: TVector4i);
Protected procedure SetSpotCutoff(I: Integer; const Value: Single);
Protected procedure SetSpotExponent(I: Integer; const Value: Single);
Protected procedure SetStencilBackWriteMask(const Value: TGLuint);
Protected procedure SetStencilClearValue(const Value: TGLuint);
Protected procedure SetStencilWriteMask(const Value: TGLuint);
Protected procedure SetTextureBinding(Index: Integer; target: TGLTextureTarget; const Value: TGLuint);
Protected procedure SetTextureBufferBinding(const Value: TGLuint);
Protected procedure SetTextureCompressionHint(const Value: THintType);
Protected procedure SetTransformFeedbackBufferBinding(const Value: TGLuint);
Protected procedure SetUniformBufferBinding(const Value: TGLuint);
Protected procedure SetUnpackAlignment(const Value: TGLuint);
Protected procedure SetUnpackImageHeight(const Value: TGLuint);
Protected procedure SetUnpackLSBFirst(const Value: TGLboolean);
Protected procedure SetUnpackRowLength(const Value: TGLuint);
Protected procedure SetUnpackSkipImages(const Value: TGLuint);
Protected procedure SetUnpackSkipPixels(const Value: TGLuint);
Protected procedure SetUnpackSkipRows(const Value: TGLuint);
Protected procedure SetUnpackSwapBytes(const Value: TGLboolean);
Protected procedure SetVertexArrayBinding(const Value: TGLuint);
Protected procedure SetViewPort(const Value: TVector4i);

Properties

Public property ActiveTexture: TGLint read FActiveTexture write SetActiveTexture;

The active texture unit. Valid values are 0 .. Max texture units.

Public property ActiveTextureEnabled[Target: TGLTextureTarget]: Boolean read GetActiveTextureEnabled write SetActiveTextureEnabled;
Public property ArrayBufferBinding: TGLuint read GetArrayBufferBinding write SetArrayBufferBinding;

The currently bound vertex buffer object (VAO).

Public property BlendColor: TVector read FBlendColor write SetBlendColor;

A constant blend color, that can be used in the blend equation.

Public property BlendDstAlpha: TDstBlendFunction read FBlendDstAlpha;

The weighting factor used in blending equation, for destination alpha.

Public property BlendDstRGB: TDstBlendFunction read FBlendDstRGB;

The weighting factor used in blending equation, for destination RGB.

Public property BlendEquationAlpha: TBlendEquation read FBlendEquationAlpha;

The blending equation. Determines how the incoming source fragment's alpha values are combined with the destination alpha values.

Public property BlendEquationRGB: TBlendEquation read FBlendEquationRGB;

The blending equation. Determines how the incoming source fragment's RGB are combined with the destination RGB.

Public property BlendSrcAlpha: TBlendFunction read FBlendSrcAlpha;

The weighting factor used in blending equation, for source alpha.

Public property BlendSrcRGB: TBlendFunction read FBlendSrcRGB;

The weighting factor used in blending equation, for source RGB.

Public property ClampReadColor: TGLenum read FClampReadColor write SetClampReadColor;

Controls read color clamping.

Public property ColorClearValue: TVector read FColorClearValue write SetColorClearValue;

The color clear value.

Public property ColorWriteMask[Index: Integer]: TColorMask read GetColorWriteMask write SetColorWriteMask;

The color write mask, for each draw buffer.

Public property CopyReadBufferBinding: TGLuint read FCopyReadBufferBinding write SetCopyReadBufferBinding;

The buffer currently bound to the copy read buffer binding point, this is an extra binding point provided so that you don't need to overwrite other binding points to copy between buffers.

Public property CopyWriteBufferBinding: TGLuint read FCopyWriteBufferBinding write SetCopyWriteBufferBinding;

The buffer currently bound to the copy write buffer binding point, this is an extra binding point provided so that you don't need to overwrite other binding points to copy between buffers.

Public property CullFaceMode: TCullFaceMode read FCullFaceMode write SetCullFaceMode;

Selects which faces to cull: front, back or front+back.

Public property CurrentProgram: TGLuint read FCurrentProgram write SetCurrentProgram;

Currently bound program.

Public property CurrentQuery[Index: TQueryType]: TGLuint read GetCurrentQuery;

Current queries.

Public property CurrentVertexAttrib[Index: Integer]: TVector read GetCurrentVertexAttrib write SetCurrentVertexAttrib;

Default values to be used when a vertex array is not used for that attribute.

Public property DepthClearValue: TGLfloat read FDepthClearValue write SetDepthClearValue;

The depth clear value.

Public property DepthFunc: TDepthFunction read FDepthFunc write SetDepthFunc;

The depth function. Used to determine whether to keep a fragment or discard it, depending on the current value stored in the depth buffer.

Public property DepthRangeFar: TGLclampd read GetDepthRangeFar write SetDepthRangeFar;

The far clipping plane distance.

Public property DepthRangeNear: TGLclampd read GetDepthRangeNear write SetDepthRangeNear;

The near clipping plane distance.

Public property DepthWriteMask: TGLBoolean read FDepthWriteMask write SetDepthWriteMask;

The depth write mask.

Public property DrawFrameBuffer: TGLuint read FDrawFrameBuffer write SetDrawFrameBuffer;

Framebuffer to be used for draw operations, 0 = default framebuffer.

Public property ElementBufferBinding: TGLuint read GetElementBufferBinding write SetElementBufferBinding;

The currently bound element buffer object (EBO).

Public property EnableBlend[Index: Integer]: TGLboolean read GetEnableBlend write SetEnableBlend;

Enables/disables blending for each draw buffer.

Public property EnableClipDistance[Index: Cardinal]: TGLboolean read GetEnableClipDistance write SetEnableClipDistance;

Enables/Disables each of the clip distances, used in shaders.

Public property EnableColorLogicOp: TGLboolean read FEnableColorLogicOp write SetEnableColorLogicOp;

Enables/disables color logic op.

Public property EnableCullFace: TGLboolean read FEnableCullFace write SetEnableCullFace;

Enable/Disable face culling.

Public property EnableDepthClamp: TGLboolean read FEnableDepthClamp write SetEnableDepthClamp;

Enables/Disables depth clamping.

Public property EnableDepthTest: TGLboolean read FEnableDepthTest write SetEnableDepthTest;

Enables/disables depth testing.

Public property EnableDither: TGLboolean read FEnableDither write SetEnableDither;

Enables/disables dithering.

Public property EnableFramebufferSRGB: TGLboolean read FEnableFramebufferSRGB write SetEnableFramebufferSRGB;

Enables/disables framebuffer SRGB.

Public property EnableLineSmooth: TGLboolean read FEnableLineSmooth write SetEnableLineSmooth;

Enable/Disable line smoothing.

Public property EnableMultisample: TGLboolean read FEnableMultisample write SetEnableMultisample;

Enable/Disable multisampling.

Public property EnablePolygonOffsetFill: TGLboolean read FEnablePolygonOffsetFill write SetEnablePolygonOffsetFill;

Enable/Disable polygon offset for polygons in fill mode.

Public property EnablePolygonOffsetLine: TGLboolean read FEnablePolygonOffsetLine write SetEnablePolygonOffsetLine;

Enable/Disable polygon offset for polygons in line mode.

Public property EnablePolygonOffsetPoint: TGLboolean read FEnablePolygonOffsetPoint write SetEnablePolygonOffsetPoint;

Enable/Disable polygon offset for polygons in point mode.

Public property EnablePolygonSmooth: TGLboolean read FEnablePolygonSmooth write SetEnablePolygonSmooth;
Public property EnablePrimitiveRestart: TGLboolean read GetEnablePrimitiveRestart write SetEnablePrimitiveRestart;

Determines whether primitive restart is turned on or off.

Public property EnableProgramPointSize: TGLboolean read FEnableProgramPointSize write SetEnableProgramPointSize;

Enables/disables program point size.

Public property EnableSampleAlphaToCoverage: TGLboolean read FEnableSampleAlphaToCoverage write SetEnableSampleAlphaToCoverage;

Enable/Disable sample alpha to coverage.

Public property EnableSampleAlphaToOne: TGLboolean read FEnableSampleAlphaToOne write SetEnableSampleAlphaToOne;

Enable/Disable sample alpha to one.

Public property EnableSampleCoverage: TGLboolean read FEnableSampleCoverage write SetEnableSampleCoverage;

Enable/Disable sample coverage.

Public property EnableSampleMask: TGLboolean read FEnableSampleMask write SetEnableSampleMask;

Enable/Disable sample mask.

Public property EnableScissorTest: TGLboolean read FEnableScissorTest write SetEnableScissorTest;

Enables/Disables scissor test.

Public property EnableStencilTest: TGLboolean read FEnableStencilTest write SetEnableStencilTest;

Enables/Disables stencil test.

Public property EnableTextureCubeMapSeamless: TGLboolean read FEnableTextureCubeMapSeamless write SetEnableTextureCubeMapSeamless;

Enables/Disables seamless texture cube maps.

Public property FixedFunctionPipeLight: Boolean read FFFPLight write SetFFPLight;

Lighting states

Public property ForwardContext: Boolean read FForwardContext write SetForwardContext;

True for ignore deprecated and removed features in OpenGL 3x

Public property FragmentShaderDerivitiveHint: THintType read FFragmentShaderDerivitiveHint write SetFragmentShaderDerivitiveHint;

Fragment shader derivitive hint.

Public property FrontFace: TFaceWinding read FFrontFace write SetFrontFace;

The winding direction that indicates a front facing primitive.

Public property InsideList: Boolean read FInsideList;

Indicates the current presence within the list.

Public property LightAmbient[Index: Integer]: TVector read GetLightAmbient write SetLightAmbient;
Public property LightConstantAtten[Index: Integer]: Single read GetConstantAtten write SetConstantAtten;
Public property LightDiffuse[Index: Integer]: TVector read GetLightDiffuse write SetLightDiffuse;
Public property LightEnabling[Index: Integer]: Boolean read GetLightEnabling write SetLightEnabling;
Public property LightLinearAtten[Index: Integer]: Single read GetLinearAtten write SetLinearAtten;
Public property LightNumber: Integer read FLightNumber;
Public property LightPosition[Index: Integer]: TVector read GetLightPosition write SetLightPosition;
Public property LightQuadraticAtten[Index: Integer]: Single read GetQuadAtten write SetQuadAtten;
Public property LightSpecular[Index: Integer]: TVector read GetLightSpecular write SetLightSpecular;
Public property LightSpotCutoff[Index: Integer]: Single read GetSpotCutoff write SetSpotCutoff;
Public property LightSpotDirection[Index: Integer]: TAffineVector read GetLightSpotDirection write SetLightSpotDirection;
Public property LightSpotExponent[Index: Integer]: Single read GetSpotExponent write SetSpotExponent;
Public property LineSmoothHint: THintType read FLineSmoothHint write SetLineSmoothHint;

Line smooth hint.

Public property LineStippleFactor: TGLint read FLineStippleFactor write SetLineStippleFactor;

The line stipple.

Public property LineStipplePattern: TGLushort read FLineStipplePattern write SetLineStipplePattern;

The line stipple.

Public property LineWidth: TGLfloat read FLineWidth write SetLineWidth;

The line width.

Public property LogicOpMode: TLogicOp read FLogicOpMode write SetLogicOpMode;

Logic op mode.

Public property MaterialAmbient[const aFace: TCullFaceMode]: TVector read GetMaterialAmbient;
Public property MaterialDiffuse[const aFace: TCullFaceMode]: TVector read GetMaterialDiffuse;
Public property MaterialEmission[const aFace: TCullFaceMode]: TVector read GetMaterialEmission;
Public property MaterialShininess[const aFace: TCullFaceMode]: Integer read GetMaterialShininess;
Public property MaterialSpecular[const aFace: TCullFaceMode]: TVector read GetMaterialSpecular;
Public property Max3DTextureSize: TGLuint read GetMax3DTextureSize;
Public property MaxArrayTextureSize: TGLuint read GetMaxArrayTextureSize;
Public property MaxCubeTextureSize: TGLuint read GetMaxCubeTextureSize;
Public property MaxLights: Integer read GetMaxLights;
Public property MaxSamples: TGLuint read GetMaxSamples;
Public property MaxTextureAnisotropy: TGLuint read GetMaxTextureAnisotropy;
Public property MaxTextureImageUnits: TGLuint read GetMaxTextureImageUnits;
Public property MaxTextureSize: TGLuint read GetMaxTextureSize;
Public property MaxTextureUnits: TGLuint read GetMaxTextureUnits;
Public property MultisampleFilterHint: THintType read FMultisampleFilterHint write SetMultisampleFilterHint;
Public property OnLightsChanged: TOnLightsChanged read FOnLightsChanged write FOnLightsChanged;
Public property PackAlignment: TGLuint read FPackAlignment write SetPackAlignment;

Pack alignment.

Public property PackImageHeight: TGLuint read FPackImageHeight write SetPackImageHeight;

Pack image height.

Public property PackLSBFirst: TGLboolean read FPackLSBFirst write SetPackLSBFirst;

Whether packed data is required with LSB (least significant bit) first.

Public property PackRowLength: TGLuint read FPackRowLength write SetPackRowLength;

Pack row length.

Public property PackSkipImages: TGLuint read FPackSkipImages write SetPackSkipImages;

Pack skip images.

Public property PackSkipPixels: TGLuint read FPackSkipPixels write SetPackSkipPixels;

Pack skip pixels.

Public property PackSkipRows: TGLuint read FPackSkipRows write SetPackSkipRows;

Pack skip rows.

Public property PackSwapBytes: TGLboolean read FPackSwapBytes write SetPackSwapBytes;

Controls whether byte swapping occurs during pixel packing.

Public property PixelPackBufferBinding: TGLuint read FPixelPackBufferBinding write SetPixelPackBufferBinding;

Buffer bound for pixel packing (eg. ReadPixels).

Public property PixelUnpackBufferBinding: TGLuint read FPixelUnpackBufferBinding write SetPixelUnpackBufferBinding;

Buffer bound for pixel unpacking (eg. Tex*Image).

Public property PointFadeThresholdSize: TGLfloat read FPointFadeThresholdSize write SetPointFadeThresholdSize;

If multisampling is enabled, this can control when points are faded out.

Public property PointSize: TGLfloat read FPointSize write SetPointSize;

The default point size, used when EnableProgramPointSize = false.

Public property PointSpriteCoordOrigin: TGLenum read FPointSpriteCoordOrigin write SetPointSpriteCoordOrigin;

The texture coordinate origin of point sprites.

Public property PolygonMode: TPolygonMode read FPolygonMode write SetPolygonMode;

Whether polygons appear filled, lines or points.

Public property PolygonOffsetFactor: TGLfloat read FPolygonOffsetFactor write SetPolygonOffsetFactor;

Scales the maximum depth of the polygon.

Public property PolygonOffsetUnits: TGLfloat read FPolygonOffsetUnits write SetPolygonOffsetUnits;

Scales an implementation-dependent constant that relates to the usable resolution of the depth buffer.

Public property PolygonSmoothHint: THintType read FPolygonSmoothHint write SetPolygonSmoothHint;

Polygon smooth hint.

Public property PrimitiveRestartIndex: TGLuint read GetPrimitiveRestartIndex write SetPrimitiveRestartIndex;

The index Value that causes a primitive restart.

Public property ProvokingVertex: TGLenum read FProvokingVertex write SetProvokingVertex;

The provoking vertex used in flat shading. All the vertices of each primitive will the same value determined by this property.

Public property ReadFrameBuffer: TGLuint read FReadFrameBuffer write SetReadFrameBuffer;

Framebuffer to be used for read operations, 0 = default framebuffer.

Public property RenderBuffer: TGLuint read FRenderBuffer write SetRenderBuffer;

Currently bound render buffer.

Public property SampleCoverageInvert: TGLboolean read FSampleCoverageInvert write SetSampleCoverageInvert;

Inverts sample coverage Value.

Public property SampleCoverageValue: TGLfloat read FSampleCoverageValue write SetSampleCoverageValue;

Sample coverage Value.

Public property SampleMaskValue[Index: Integer]: TGLbitfield read GetSampleMaskValue write SetSampleMaskValue;

Sample mask values.

Public property SamplerBinding[Index: TGLuint]: TGLuint read GetSamplerBinding write SetSamplerBinding;
Public property ScissorBox: TVector4i read FScissorBox write SetScissorBox;

The bounding box used in scissor test.

Public property States: TGLStates read FStates;
Public property StencilBackFail: TStencilOp read FStencilBackFail;

The operation to perform when stencil test fails on back facing primitives.

Public property StencilBackFunc: TStencilFunction read FStencilBackFunc;

The stencil back function. Determines the comparison function to be used when comparing the reference + stored stencil values on back facing primitives.

Public property StencilBackPassDepthFail: TStencilOp read FStencilBackPassDepthFail;

The operation to perform when stencil test passes + depth test fails on back facing primitives.

Public property StencilBackPassDepthPass: TStencilOp read FStencilBackPassDepthPass;

The operation to perform when stencil test passes + depth test passes on back facing primitives.

Public property StencilBackRef: TGLuint read FStencilBackRef;

The stencil back reference value. Clamped to 0..255 with an 8 bit stencil.

Public property StencilBackValueMask: TGLuint read FStencilBackValueMask;

The stencil back value mask. Masks both the reference + stored stencil values.

Public property StencilBackWriteMask: TGLuint read FStencilBackWriteMask write SetStencilBackWriteMask;

The stencil back write mask.

Public property StencilClearValue: TGLuint read FStencilClearValue write SetStencilClearValue;

The stencil clear value.

Public property StencilFail: TStencilOp read FStencilFail;

The operation to perform when stencil test fails.

Public property StencilFunc: TStencilFunction read FStencilFunc;

The stencil function. Determines the comparison function to be used when comparing the reference + stored stencil values.

Public property StencilPassDepthFail: TStencilOp read FStencilPassDepthFail;

The operation to perform when stencil test passes + depth test fails.

Public property StencilPassDepthPass: TStencilOp read FStencilPassDepthPass;

The operation to perform when stencil test passes + depth test passes.

Public property StencilRef: TGLint read FStencilRef;

The stencil reference value. Clamped to 0..255 with an 8 bit stencil.

Public property StencilValueMask: TGLuint read FStencilValueMask;

The stencil value mask. Masks both the reference + stored stencil values.

Public property StencilWriteMask: TGLuint read FStencilWriteMask write SetStencilWriteMask;

The stencil write mask.

Public property TextureBinding[Index: Integer; target: TGLTextureTarget]: TGLuint read GetTextureBinding write SetTextureBinding;

Textures bound to each texture unit + binding point.

Public property TextureBindingTime[Index: Integer; target: TGLTextureTarget]: Double read GetTextureBindingTime;
Public property TextureBufferBinding: TGLuint read FTextureBufferBinding write SetTextureBufferBinding;

The currently bound texture buffer object (TBO).

Public property TextureCompressionHint: THintType read FTextureCompressionHint write SetTextureCompressionHint;

Texture compression hint.

Public property TransformFeedbackBufferBinding: TGLuint read FTransformFeedbackBufferBinding write SetTransformFeedbackBufferBinding;

Currently bound transform feedbac buffer.

Public property UniformBufferBinding: TGLuint read FUniformBufferBinding write SetUniformBufferBinding;

Currently bound uniform buffer.

Public property UnpackAlignment: TGLuint read FUnpackAlignment write SetUnpackAlignment;

Unpack alignment.

Public property UnpackImageHeight: TGLuint read FUnpackImageHeight write SetUnpackImageHeight;

Unpack image height.

Public property UnpackLSBFirst: TGLboolean read FUnpackLSBFirst write SetUnpackLSBFirst;

Whether unpacked data is required with LSB (least significant bit) first.

Public property UnpackRowLength: TGLuint read FUnpackRowLength write SetUnpackRowLength;

Unpack row length.

Public property UnpackSkipImages: TGLuint read FUnpackSkipImages write SetUnpackSkipImages;

Unpack skip images.

Public property UnpackSkipPixels: TGLuint read FUnpackSkipPixels write SetUnpackSkipPixels;

Unpack skip pixels.

Public property UnpackSkipRows: TGLuint read FUnpackSkipRows write SetUnpackSkipRows;

Unpack skip rows.

Public property UnpackSwapBytes: TGLboolean read FUnpackSwapBytes write SetUnpackSwapBytes;

Controls whether byte swapping occurs during pixel unpacking.

Public property VertexArrayBinding: TGLuint read FVertexArrayBinding write SetVertexArrayBinding;

The currently bound array buffer (calling glVertexAttribPointer locks this buffer to the currently bound VBO).

Public property ViewPort: TVector4i read FViewPort write SetViewPort;

The viewport.

Generated by PasDoc 0.11.0 on 2013-02-10 19:37:56


GLScene v.1.1.2: GLState: record TStateRecord

record TStateRecord

Unit

GLState

Declaration

type TStateRecord = record

Description

Overview

Fields

GLConst: TGLEnum;
GLDeprecated: Boolean;

Description

Fields

GLConst: TGLEnum;
GLDeprecated: Boolean;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:56


GLScene v.1.1.2: GLStrings

Unit GLStrings

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLStrings<p>

String constants that are used in many GLScene units<p>

<b>History :</b><font size=-1><ul> <li>16/09/10 - YP - Added glsUnknownParam <li>23/02/07 - DaStr - Added glsDot, glsUnsupportedType, glsUncompatibleTypes, glsUnknownType, glsShaderNeedsAtLeastOneLightSource(Ex), glsCadencerNotDefined(Ex), glsSceneViewerNotDefined <li>16/02/07 - DaStr - Added glsOCProxyObjects, glsError, glsErrorEx, glsMatLibNotDefined, glsMaterialNotFoundInMatlib(Ex) <li>26/08/02 - EG - Added missing header, added glsUnknownExtension </ul></font>

Overview

Constants

glsDot = '.';
glsError = 'Error!';
glsErrorEx = 'Error: ';
glsNoRenderingContext = 'Could not create a rendering context';
glsWrongVersion = 'Need at least OpenGL version 1.1';
glsTooManyLights = 'Too many lights in the scene';
glsDisplayList = 'Failed to create a new display list for object ''%s''';
glsWrongBitmapCanvas = 'Couldn''t create a rendering context for the given bitmap';
glsWrongPrinter = 'Couldn''t render to printer';
glsAlreadyRendering = 'Already rendering';
glsSceneViewerNotDefined = 'SceneViewer not defined!';
glsCadencerNotDefined = 'Cadencer not defined!';
glsCadencerNotDefinedEx = 'Cadencer not defined for the ''%s'' component';
glsShaderNeedsAtLeastOneLightSource = 'This shader needs at least one LightSource!';
glsShaderNeedsAtLeastOneLightSourceEx = 'Shader ''%s'' needs at least one LightSource!';
glsSceneRoot = 'Scene root';
glsObjectRoot = 'Scene objects';
glsCameraRoot = 'Cameras';
glsCamera = 'Camera';
glsImageInvalid = 'Could not load texture, image is invalid';
glsNoNewTexture = 'Could not get new texture name';
glsMatLibNotDefined = 'Material Library not defined!';
glsMaterialNotFoundInMatlib = 'Material not found in current Material Library!';
glsMaterialNotFoundInMatlibEx = 'Material "%s" not found in current Material Library!';
glsSphereTopBottom = 'The top angle must be higher than the bottom angle';
glsSphereStartStop = 'The start angle must be smaller than then stop angle';
glsMaterialNotFound = 'Loading failed: could not find material %s';
glsInterleaveNotSupported = 'Interleaved Array format not supported yet. Sorry.';
glsUnknownArchive = '%s : unknown archive version %d';
glsOutOfMemory = 'Fatal: Out of memory';
glsFileNotFound = 'File %s not found';
glsFailedOpenFile = 'Could not open file: %s';
glsFailedOpenFileFromCurrentDir = 'Could not open file: %s'#13#10'(Current directory is %s)';
glsNoDescriptionAvailable = 'No description available';
glsUnBalancedBeginEndUpdate = 'Unbalanced Begin/EndUpdate';
glsUnknownExtension = 'Unknown file extension (%s), maybe you forgot to add the support ' +'unit to your uses? (%s?)' ;
glsMissingResource = 'Missing application resource: %s: %s';
glsIncompatibleTypes = 'Incompatible types!';
glsUnknownType = 'Unknown type!';
glsUnsupportedType = 'Unsupported type!';
glsOCBasicGeometry = 'Basic geometry';
glsOCAdvancedGeometry = 'Advanced geometry';
glsOCMeshObjects = 'Mesh objects';
glsOCParticleSystems = 'Particle systems';
glsOCEnvironmentObjects = 'Environment objects';
glsOCSpecialObjects = 'Special objects';
glsOCGraphPlottingObjects = 'Graph-plotting objects';
glsOCDoodad = 'Doodad objects';
glsOCHUDObjects = 'HUD objects';
glsOCGuiObjects = 'GUI objects';
glsOCProxyObjects = 'Proxy objects';
glsOCExperimental = 'Experimental objects';
glsUnknownParam = 'Unknown %s "%s" for "%s" or program not in use';

Description

Constants

glsDot = '.';
glsError = 'Error!';
glsErrorEx = 'Error: ';
glsNoRenderingContext = 'Could not create a rendering context';
glsWrongVersion = 'Need at least OpenGL version 1.1';
glsTooManyLights = 'Too many lights in the scene';
glsDisplayList = 'Failed to create a new display list for object ''%s''';
glsWrongBitmapCanvas = 'Couldn''t create a rendering context for the given bitmap';
glsWrongPrinter = 'Couldn''t render to printer';
glsAlreadyRendering = 'Already rendering';
glsSceneViewerNotDefined = 'SceneViewer not defined!';
glsCadencerNotDefined = 'Cadencer not defined!';
glsCadencerNotDefinedEx = 'Cadencer not defined for the ''%s'' component';
glsShaderNeedsAtLeastOneLightSource = 'This shader needs at least one LightSource!';
glsShaderNeedsAtLeastOneLightSourceEx = 'Shader ''%s'' needs at least one LightSource!';
glsSceneRoot = 'Scene root';
glsObjectRoot = 'Scene objects';
glsCameraRoot = 'Cameras';
glsCamera = 'Camera';
glsImageInvalid = 'Could not load texture, image is invalid';
glsNoNewTexture = 'Could not get new texture name';
glsMatLibNotDefined = 'Material Library not defined!';
glsMaterialNotFoundInMatlib = 'Material not found in current Material Library!';
glsMaterialNotFoundInMatlibEx = 'Material "%s" not found in current Material Library!';
glsSphereTopBottom = 'The top angle must be higher than the bottom angle';
glsSphereStartStop = 'The start angle must be smaller than then stop angle';
glsMaterialNotFound = 'Loading failed: could not find material %s';
glsInterleaveNotSupported = 'Interleaved Array format not supported yet. Sorry.';
glsUnknownArchive = '%s : unknown archive version %d';
glsOutOfMemory = 'Fatal: Out of memory';
glsFileNotFound = 'File %s not found';
glsFailedOpenFile = 'Could not open file: %s';
glsFailedOpenFileFromCurrentDir = 'Could not open file: %s'#13#10'(Current directory is %s)';
glsNoDescriptionAvailable = 'No description available';
glsUnBalancedBeginEndUpdate = 'Unbalanced Begin/EndUpdate';
glsUnknownExtension = 'Unknown file extension (%s), maybe you forgot to add the support ' +'unit to your uses? (%s?)' ;
glsMissingResource = 'Missing application resource: %s: %s';
glsIncompatibleTypes = 'Incompatible types!';
glsUnknownType = 'Unknown type!';
glsUnsupportedType = 'Unsupported type!';
glsOCBasicGeometry = 'Basic geometry';
glsOCAdvancedGeometry = 'Advanced geometry';
glsOCMeshObjects = 'Mesh objects';
glsOCParticleSystems = 'Particle systems';
glsOCEnvironmentObjects = 'Environment objects';
glsOCSpecialObjects = 'Special objects';
glsOCGraphPlottingObjects = 'Graph-plotting objects';
glsOCDoodad = 'Doodad objects';
glsOCHUDObjects = 'HUD objects';
glsOCGuiObjects = 'GUI objects';
glsOCProxyObjects = 'Proxy objects';
glsOCExperimental = 'Experimental objects';
glsUnknownParam = 'Unknown %s "%s" for "%s" or program not in use';
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:56


GLScene v.1.1.2: GLSVfw

Unit GLSVfw

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TICOPEN |
packed record TICINFO |
packed record TICCOMPRESS |
packed record TICCOMPRESSFRAMES |
packed record TICSETSTATUSPROC |
packed record TICDECOMPRESS |
packed record TICDECOMPRESSEX |
packed record TICDRAWBEGIN |
packed record TICDRAW |
packed record TICDRAWSUGGEST |
packed record TICPALETTE |
packed record TCOMPVARS |
packed record TDRAWDIBTIME |
packed record TMainAVIHeader |
packed record TAVIStreamHeader |
packed record TAVIINDEXENTRY |
packed record TAVIPALCHANGE |
packed record TAVIStreamInfoW |
packed record TAVIStreamInfoA |
packed record TAVIFileInfoW |
packed record TAVIFileInfoA |
packed record TAVICOMPRESSOPTIONS |
Interface IAVIStream |
Interface IAVIStreaming |
Interface IAVIEditStream |
Interface IAVIFile |
Interface IGetFrame |
record TVIDEOHDR |
record TCHANNEL_CAPS |
record TCAPDRIVERCAPS |
record TCAPSTATUS |
record TCAPTUREPARMS |
record TCAPINFOCHUNK |

Functions and Procedures

function VideoForWindowsVersion: DWORD; pascal;
function MKFOURCC(ch0, ch1, ch2, ch3: AnsiChar): FOURCC;
function mmioFOURCC(ch0, ch1, ch2, ch3: AnsiChar): FOURCC;
function aviTWOCC(ch0, ch1: AnsiChar): TWOCC;
function ICInfo(fccType, fccHandler: DWORD; lpicinfo: PICINFO) : BOOL ; stdcall;
function ICInstall(fccType, fccHandler: DWORD; lParam: LPARAM; szDesc: LPSTR; wFlags: UINT) : BOOL ; stdcall;
function ICRemove(fccType, fccHandler: DWORD; wFlags: UINT) : BOOL ; stdcall;
function ICGetInfo(hic: HIC; picinfo: PICINFO; cb: DWORD) : DWORD ; stdcall;
function ICOpen(fccType, fccHandler: DWORD; wMode: UINT) : HIC ; stdcall;
function ICOpenFunction(fccType, fccHandler: DWORD; wMode: UINT; lpfnHandler: TFarProc) : HIC ; stdcall;
function ICClose(hic: HIC) : DWORD; stdcall;
function ICSendMessage(hic: HIC; msg: UINT; dw1, dw2: DWORD) : DWORD ; stdcall;
function ICQueryAbout(hic: HIC): BOOL;
function ICAbout(hic: HIC; hwnd: HWND): DWORD;
function ICQueryConfigure(hic: HIC): BOOL;
function ICConfigure(hic: HIC; hwnd: HWND): DWORD;
function ICGetState(hic: HIC; pv: PVOID; cb: DWORD): DWORD;
function ICSetState(hic: HIC; pv: PVOID; cb: DWORD): DWORD;
function ICGetStateSize(hic: HIC): DWORD;
function ICGetDefaultQuality(hic: HIC): DWORD;
function ICGetDefaultKeyFrameRate(hic: HIC): DWORD;
function ICDrawWindow(hic: HIC; prc: PRECT): DWORD;
function ICCompress( hic : HIC; dwFlags : DWORD; lpbiOutput : PBITMAPINFOHEADER; lpData : PVOID; lpbiInput : PBITMAPINFOHEADER; lpBits : PVOID; lpckid : PDWORD; lpdwFlags : PDWORD; lFrameNum : DWORD; dwFrameSize : DWORD; dwQuality : DWORD; lpbiPrev : PBITMAPINFOHEADER; lpPrev : PVOID ): DWORD; cdecl;
function ICCompressBegin(hic: HIC; lpbiInput: PBITMAPINFOHEADER; lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICCompressQuery(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICCompressGetFormat(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICCompressGetFormatSize(hic: HIC; lpbi: PBITMAPINFOHEADER): DWORD;
function ICCompressGetSize(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICCompressEnd(hic: HIC): DWORD;
function ICDecompress( hic : HIC; dwFlags : DWORD; lpbiFormat : PBITMAPINFOHEADER; lpData : PVOID; lpbi : PBITMAPINFOHEADER; lpBits : PVOID ): DWORD; cdecl;
function ICDecompressBegin(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICDecompressQuery(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICDecompressGetFormat(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICDecompressGetFormatSize(hic: HIC; lpbi: PBITMAPINFOHEADER): DWORD;
function ICDecompressGetPalette(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICDecompressSetPalette(hic: HIC; lpbiPalette: PBITMAPINFOHEADER): DWORD;
function ICDecompressEnd(hic: HIC): DWORD;
function ICDecompressEx( hic : HIC; dwFlags : DWORD; lpbiSrc : PBITMAPINFOHEADER; lpSrc : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; lpbiDst : PBITMAPINFOHEADER; lpDst : PVOID; xDst : int; yDst : int; dxDst : int; dyDst : int ): DWORD; stdcall;
function ICDecompressExBegin( hic : HIC; dwFlags : DWORD; lpbiSrc : PBITMAPINFOHEADER; lpSrc : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; lpbiDst : PBITMAPINFOHEADER; lpDst : PVOID; xDst : int; yDst : int; dxDst : int; dyDst : int ): DWORD; stdcall;
function ICDecompressExQuery( hic : HIC; dwFlags : DWORD; lpbiSrc : PBITMAPINFOHEADER; lpSrc : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; lpbiDst : PBITMAPINFOHEADER; lpDst : PVOID; xDst : int; yDst : int; dxDst : int; dyDst : int ): DWORD; stdcall;
function ICDecompressExEnd(hic: HIC): DWORD;
function ICDrawBegin( hic : HIC; dwFlags : DWORD; hpal : HPALETTE; hwnd : HWND; hdc : HDC; xDst : int; yDst : int; dxDst : int; dyDst : int; lpbi : PBITMAPINFOHEADER; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; dwRate : DWORD; dwScale : DWORD ): DWORD; cdecl;
function ICDraw( hic : HIC; dwFlags : DWORD; lpFormat : PVOID; lpData : PVOID; cbData : DWORD; lTime : DWORD ): DWORD; cdecl;
function ICDrawSuggestFormat( hic : HIC; lpbiIn : PBITMAPINFOHEADER; lpbiOut : PBITMAPINFOHEADER; dxSrc : int; dySrc : int; dxDst : int; dyDst : int; hicDecomp : HIC ): DWORD; stdcall;
function ICDrawQuery(hic: HIC; lpbiInput: PBITMAPINFOHEADER): DWORD;
function ICDrawChangePalette(hic: HIC; lpbiInput: PBITMAPINFOHEADER): DWORD;
function ICGetBuffersWanted(hic: HIC; lpdwBuffers: PDWORD): DWORD;
function ICDrawEnd(hic: HIC): DWORD;
function ICDrawStart(hic: HIC): DWORD;
function ICDrawStartPlay(hic: HIC; lFrom, lTo: DWORD): DWORD;
function ICDrawStop(hic: HIC): DWORD;
function ICDrawStopPlay(hic: HIC): DWORD;
function ICDrawGetTime(hic: HIC; lplTime: PDWORD): DWORD;
function ICDrawSetTime(hic: HIC; lTime: DWORD): DWORD;
function ICDrawRealize(hic: HIC; hdc: HDC; fBackground: BOOL): DWORD;
function ICDrawFlush(hic: HIC): DWORD;
function ICDrawRenderBuffer(hic: HIC): DWORD;
function ICSetStatusProc( hic : HIC; dwFlags : DWORD; lParam : DWORD; fpfnStatus : TICStatusProc ): DWORD; stdcall;
function ICLocate(fccType, fccHandler: DWORD; lpbiIn, lpbiOut: PBITMAPINFOHEADER; wFlags: WORD): HIC; stdcall;
function ICGetDisplayFormat(hic: HIC; lpbiIn, lpbiOut: PBITMAPINFOHEADER; BitDepth: int; dx, dy: int): HIC; stdcall;
function ICDecompressOpen(fccType, fccHandler: DWORD; lpbiIn, lpbiOut: PBITMAPINFOHEADER): HIC;
function ICDrawOpen(fccType, fccHandler: DWORD; lpbiIn: PBITMAPINFOHEADER): HIC;
function ICImageCompress( hic : HIC; uiFlags : UINT; lpbiIn : PBITMAPINFO; lpBits : PVOID; lpbiOut : PBITMAPINFO; lQuality : LONG; plSize : PDWORD ): THANDLE; stdcall;
function ICImageDecompress( hic : HIC; uiFlags : UINT; lpbiIn : PBITMAPINFO; lpBits : PVOID; lpbiOut : PBITMAPINFO ): THANDLE; stdcall;
function ICCompressorChoose( hwnd : HWND; uiFlags : UINT; pvIn : PVOID; lpData : PVOID; pc : PCOMPVARS; lpszTitle : LPSTR ): BOOL; stdcall;
function ICSeqCompressFrameStart(pc: PCOMPVARS; lpbiIn: PBITMAPINFO): BOOL; stdcall;
procedure ICSeqCompressFrameEnd(pc: PCOMPVARS); stdcall;
function ICSeqCompressFrame( pc : PCOMPVARS; uiFlags : UINT; lpBits : PVOID; pfKey : PBOOL; plSize : PDWORD ): PVOID; stdcall;
procedure ICCompressorFree(pc: PCOMPVARS); stdcall;
function DrawDibOpen: HDRAWDIB; stdcall;
function DrawDibClose(hdd: HDRAWDIB): BOOL; stdcall;
function DrawDibGetBuffer(hdd: HDRAWDIB; lpbi: PBITMAPINFOHEADER; dwSize: DWORD; dwFlags: DWORD): PVOID; stdcall;
function DrawDibGetPalette(hdd: HDRAWDIB): HPALETTE; stdcall;
function DrawDibSetPalette(hdd: HDRAWDIB; hpal: HPALETTE): BOOL; stdcall;
function DrawDibChangePalette(hdd: HDRAWDIB; iStart, iLen: int; lppe: PPALETTEENTRY): BOOL; stdcall;
function DrawDibRealize(hdd: HDRAWDIB; hdc: HDC; fBackground: BOOL): UINT; stdcall;
function DrawDibStart(hdd: HDRAWDIB; rate: DWORD): BOOL; stdcall;
function DrawDibStop(hdd: HDRAWDIB): BOOL; stdcall;
function DrawDibBegin( hdd : HDRAWDIB; hdc : HDC; dxDst : int; dyDst : int; lpbi : PBITMAPINFOHEADER; dxSrc : int; dySrc : int; wFlags : UINT ): BOOL; stdcall;
function DrawDibDraw( hdd : HDRAWDIB; hdc : HDC; xDst : int; yDst : int; dxDst : int; dyDst : int; lpbi : PBITMAPINFOHEADER; lpBits : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; wFlags : UINT ): BOOL; stdcall;
function DrawDibUpdate(hdd: HDRAWDIB; hdc: HDC; x, y: int): BOOL;
function DrawDibEnd(hdd: HDRAWDIB): BOOL; stdcall;
function DrawDibTime(hdd: HDRAWDIB; lpddtime: PDRAWDIBTIME): BOOL; stdcall;
function DrawDibProfileDisplay(lpbi: PBITMAPINFOHEADER): DWORD; stdcall;
function FromHex(n: BYTE): BYTE;
function StreamFromFOURCC(fcc: DWORD): BYTE;
function TWOCCFromFOURCC(fcc: DWORD): WORD;
function ToHex(n: BYTE): BYTE;
function MAKEAVICKID(tcc: WORD; stream: BYTE): DWORD;
procedure AVIFileInit; stdcall;
procedure AVIFileExit; stdcall;
function AVIFileAddRef(pfile: IAVIFile): ULONG; stdcall;
function AVIFileRelease(pfile: IAVIFile): ULONG; stdcall;
function AVIFileOpenA(var ppfile: IAVIFile; szFile: LPCSTR; uMode: UINT; lpHandler: PCLSID): HResult; stdcall;
function AVIFileOpenW(var ppfile: IAVIFile; szFile: LPCWSTR; uMode: UINT; lpHandler: PCLSID): HResult; stdcall;
function AVIFileOpen(var ppfile: IAVIFile; szFile: LPCSTR; uMode: UINT; lpHandler: PCLSID): HResult; stdcall;
function AVIFileInfoW(pfile: IAVIFile; var pfi: TAVIFILEINFOW; lSize: LONG): HResult; stdcall;
function AVIFileInfoA(pfile: IAVIFile; var pfi: TAVIFILEINFOA; lSize: LONG): HResult; stdcall;
function AVIFileInfo(pfile: IAVIFile; var pfi: TAVIFILEINFO; lSize: LONG): HResult; stdcall;
function AVIFileGetStream(pfile: IAVIFile; var ppavi: IAVISTREAM; fccType: DWORD; lParam: LONG): HResult; stdcall;
function AVIFileCreateStreamW(pfile: IAVIFile; var ppavi: IAVISTREAM; var psi: TAVISTREAMINFOW): HResult; stdcall;
function AVIFileCreateStreamA(pfile: IAVIFile; var ppavi: IAVISTREAM; var psi: TAVISTREAMINFOA): HResult; stdcall;
function AVIFileCreateStream(pfile: IAVIFile; var ppavi: IAVISTREAM; var psi: TAVISTREAMINFO): HResult; stdcall;
function AVIFileWriteData(pfile: IAVIFile; ckid: DWORD; lpData: PVOID; cbData: LONG): HResult; stdcall;
function AVIFileReadData(pfile: IAVIFile; ckid: DWORD; lpData: PVOID; var lpcbData: LONG): HResult; stdcall;
function AVIFileEndRecord(pfile: IAVIFile): HResult; stdcall;
function AVIStreamAddRef(pavi: IAVIStream): ULONG; stdcall;
function AVIStreamRelease(pavi: IAVIStream): ULONG; stdcall;
function AVIStreamInfoW (pavi: IAVIStream; var psi: TAVISTREAMINFOW; lSize: LONG): HResult; stdcall;
function AVIStreamInfoA (pavi: IAVIStream; var psi: TAVISTREAMINFOA; lSize: LONG): HResult; stdcall;
function AVIStreamInfo(pavi: IAVIStream; var psi: TAVISTREAMINFO; lSize: LONG): HResult; stdcall;
function AVIStreamFindSample(pavi: IAVIStream; lPos: LONG; lFlags: LONG): LONG; stdcall;
function AVIStreamReadFormat(pavi: IAVIStream; lPos: LONG; lpFormat: PVOID; lpcbFormat: PLONG): HResult; stdcall;
function AVIStreamSetFormat(pavi: IAVIStream; lPos: LONG; lpFormat: PVOID; cbFormat: LONG): HResult; stdcall;
function AVIStreamReadData(pavi: IAVIStream; fcc: DWORD; lp: PVOID; lpcb: PLONG): HResult; stdcall;
function AVIStreamWriteData(pavi: IAVIStream; fcc: DWORD; lp: PVOID; cb: LONG): HResult; stdcall;
function AVIStreamRead( pavi : IAVISTREAM; lStart : LONG; lSamples : LONG; lpBuffer : PVOID; cbBuffer : LONG; plBytes : PLONG; plSamples : PLONG ): HResult; stdcall;
function AVIStreamWrite( pavi : IAVISTREAM; lStart : LONG; lSamples : LONG; lpBuffer : PVOID; cbBuffer : LONG; dwFlags : DWORD; plSampWritten : PLONG; plBytesWritten : PLONG ): HResult; stdcall;
function AVIStreamStart(pavi: IAVIStream): LONG; stdcall;
function AVIStreamLength(pavi: IAVIStream): LONG; stdcall;
function AVIStreamTimeToSample(pavi: IAVIStream; lTime: LONG): LONG; stdcall;
function AVIStreamSampleToTime(pavi: IAVIStream; lSample: LONG): LONG; stdcall;
function AVIStreamBeginStreaming(pavi: IAVIStream; lStart, lEnd: LONG; lRate: LONG): HResult; stdcall;
function AVIStreamEndStreaming(pavi: IAVIStream): HResult; stdcall;
function AVIStreamGetFrameOpen(pavi: IAVIStream; lpbiWanted: PBitmapInfoHeader): IGetFrame; stdcall;
function AVIStreamGetFrame(pg: IGetFrame; lPos: LONG): PBitmapInfoHeader; stdcall;
function AVIStreamGetFrameClose(pg: IGetFrame): HResult; stdcall;
function AVIStreamOpenFromFileA(var ppavi: IAVISTREAM; szFile: LPCSTR; fccType: DWORD; lParam: LONG; mode: UINT; pclsidHandler: PCLSID): HResult; stdcall;
function AVIStreamOpenFromFileW(var ppavi: IAVISTREAM; szFile: LPCWSTR; fccType: DWORD; lParam: LONG; mode: UINT; pclsidHandler: PCLSID): HResult; stdcall;
function AVIStreamOpenFromFile(var ppavi: IAVISTREAM; szFile: LPCSTR; fccType: DWORD; lParam: LONG; mode: UINT; pclsidHandler: PCLSID): HResult; stdcall;
function AVIStreamCreate(var ppavi: IAVISTREAM; lParam1, lParam2: LONG; pclsidHandler: PCLSID): HResult; stdcall;
function AVIStreamFindKeyFrame(var pavi: IAVISTREAM; lPos: LONG; lFlags: LONG): DWORD; stdcall;
function AVIStreamClose(pavi: IAVISTREAM): ULONG; stdcall;
function AVIFileClose(pfile: IAVIFILE): ULONG; stdcall;
procedure AVIStreamInit; stdcall;
procedure AVIStreamExit; stdcall;
function AVIStreamSampleToSample(pavi1, pavi2: IAVISTREAM; l: LONG): LONG;
function AVIStreamNextSample(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamPrevSample(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamNearestSample(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamNextKeyFrame(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamPrevKeyFrame(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamNearestKeyFrame(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamIsKeyFrame(pavi: IAVISTREAM; l: LONG): BOOL;
function AVIStreamPrevSampleTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamNextSampleTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamNearestSampleTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamNextKeyFrameTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamPrevKeyFrameTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamNearestKeyFrameTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamStartTime(pavi: IAVISTREAM): LONG;
function AVIStreamLengthTime(pavi: IAVISTREAM): LONG;
function AVIStreamEnd(pavi: IAVISTREAM): LONG;
function AVIStreamEndTime(pavi: IAVISTREAM): LONG;
function AVIStreamSampleSize(pavi: IAVISTREAM; lPos: LONG; plSize: PLONG): LONG;
function AVIStreamFormatSize(pavi: IAVISTREAM; lPos: LONG; plSize: PLONG): HResult;
function AVIStreamDataSize(pavi: IAVISTREAM; fcc: DWORD; plSize: PLONG): HResult;
function AVIMakeCompressedStream( var ppsCompressed : IAVISTREAM; ppsSource : IAVISTREAM; lpOptions : PAVICOMPRESSOPTIONS; pclsidHandler : PCLSID ): HResult; stdcall;
function AVISaveVA( szFile : LPCSTR; pclsidHandler : PCLSID; lpfnCallback : TAVISAVECALLBACK; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): HResult; stdcall;
function AVISaveVW( szFile : LPCWSTR; pclsidHandler : PCLSID; lpfnCallback : TAVISAVECALLBACK; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): HResult; stdcall;
function AVISaveV( szFile : LPCSTR; pclsidHandler : PCLSID; lpfnCallback : TAVISAVECALLBACK; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): HResult; stdcall;
function AVISaveOptions( hwnd : HWND; uiFlags : UINT; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): BOOL; stdcall;
function AVISaveOptionsFree(nStreams: int; var plpOptions: PAVICOMPRESSOPTIONS): HResult; stdcall;
function AVIBuildFilterW(lpszFilter: LPWSTR; cbFilter: LONG; fSaving: BOOL): HResult; stdcall;
function AVIBuildFilterA(lpszFilter: LPSTR; cbFilter: LONG; fSaving: BOOL): HResult; stdcall;
function AVIBuildFilter(lpszFilter: LPSTR; cbFilter: LONG; fSaving: BOOL): HResult; stdcall;
function AVIMakeFileFromStreams(var ppfile: IAVIFILE; nStreams: int; var papStreams: IAVISTREAM): HResult; stdcall;
function AVIMakeStreamFromClipboard(cfFormat: UINT; hGlobal: THANDLE; var ppstream: IAVISTREAM): HResult; stdcall;
function AVIPutFileOnClipboard(pf: IAVIFILE): HResult; stdcall;
function AVIGetFromClipboard(var lppf: IAVIFILE): HResult; stdcall;
function AVIClearClipboard: HResult; stdcall;
function CreateEditableStream(var ppsEditable: IAVISTREAM; psSource: IAVISTREAM): HResult; stdcall;
function EditStreamCut(pavi: IAVISTREAM; var plStart, plLength: LONG; var ppResult: IAVISTREAM): HResult; stdcall;
function EditStreamCopy(pavi: IAVISTREAM; var plStart, plLength: LONG; var ppResult: IAVISTREAM): HResult; stdcall;
function EditStreamPaste(pavi: IAVISTREAM; var plPos, plLength: LONG; pstream: IAVISTREAM; lStart, lEnd: LONG): HResult; stdcall;
function EditStreamClone(pavi: IAVISTREAM; var ppResult: IAVISTREAM): HResult; stdcall;
function EditStreamSetNameA(pavi: IAVISTREAM; lpszName: LPCSTR): HResult; stdcall;
function EditStreamSetNameW(pavi: IAVISTREAM; lpszName: LPCWSTR): HResult; stdcall;
function EditStreamSetInfoW(pavi: IAVISTREAM; lpInfo: PAVISTREAMINFOW; cbInfo: LONG): HResult; stdcall;
function EditStreamSetInfoA(pavi: IAVISTREAM; lpInfo: PAVISTREAMINFOA; cbInfo: LONG): HResult; stdcall;
function EditStreamSetInfo(pavi: IAVISTREAM; lpInfo: PAVISTREAMINFOA; cbInfo: LONG): HResult; stdcall;
function EditStreamSetName(pavi: IAVISTREAM; lpszName: LPCSTR): HResult; stdcall;
function MCIWndSM(hWnd: HWND; Msg: UINT; wParam: WPARAM; lParam: LPARAM): DWORD;
function MCIWndCreateA(hwndParent: HWND; hInstance: HINST; dwStyle: DWORd; szFile: LPCSTR): HWND; cdecl;
function MCIWndCreateW(hwndParent: HWND; hInstance: HINST; dwStyle: DWORd; szFile: LPCWSTR): HWND; cdecl;
function MCIWndCreate(hwndParent: HWND; hInstance: HINST; dwStyle: DWORd; szFile: LPCSTR): HWND; cdecl;
function MCIWndRegisterClass: BOOL; cdecl;
function MCIWndCanPlay(hwnd: HWND): BOOL;
function MCIWndCanRecord(hwnd: HWND): BOOL;
function MCIWndCanSave(hwnd: HWND): BOOL;
function MCIWndCanWindow(hwnd: HWND): BOOL;
function MCIWndCanEject(hwnd: HWND): BOOL;
function MCIWndCanConfig(hwnd: HWND): BOOL;
function MCIWndPaletteKick(hwnd: HWND): BOOL;
function MCIWndSave(hwnd: HWND; szFile: LPCSTR): DWORD;
function MCIWndSaveDialog(hwnd: HWND): DWORD;
function MCIWndNew(hwnd: HWND; lp: PVOID): DWORD;
function MCIWndRecord(hwnd: HWND): DWORD;
function MCIWndOpen(hwnd: HWND; sz: LPCSTR; f: BOOL): DWORD;
function MCIWndOpenDialog(hwnd: HWND): DWORD;
function MCIWndClose(hwnd: HWND): DWORD;
function MCIWndPlay(hwnd: HWND): DWORD;
function MCIWndStop(hwnd: HWND): DWORD;
function MCIWndPause(hwnd: HWND): DWORD;
function MCIWndResume(hwnd: HWND): DWORD;
function MCIWndSeek(hwnd: HWND; lPos: DWORD): DWORD;
function MCIWndEject(hwnd: HWND): DWORD;
function MCIWndHome(hwnd: HWND): DWORD;
function MCIWndEnd(hwnd: HWND): DWORD;
function MCIWndGetSource(hwnd: HWND; prc: PRECT): DWORD;
function MCIWndPutSource(hwnd: HWND; prc: PRECT): DWORD;
function MCIWndGetDest(hwnd: HWND; prc: PRECT): DWORD;
function MCIWndPutDest(hwnd: HWND; prc: PRECT): DWORD;
function MCIWndPlayReverse(hwnd: HWND): DWORD;
function MCIWndPlayFrom(hwnd: HWND; lPos: DWORD): DWORD;
function MCIWndPlayTo(hwnd: HWND; lPos: DWORD): DWORD;
function MCIWndPlayFromTo(hwnd: HWND; lStart, lEnd: DWORD): DWORD;
function MCIWndGetDeviceID(hwnd: HWND): UINT;
function MCIWndGetAlias(hwnd: HWND): UINT;
function MCIWndGetMode(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetPosition(hwnd: HWND): DWORD;
function MCIWndGetPositionString(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetStart(hwnd: HWND): DWORD;
function MCIWndGetLength(hwnd: HWND): DWORD;
function MCIWndGetEnd(hwnd: HWND): DWORD;
function MCIWndStep(hwnd: HWND; n: DWORD): DWORD;
procedure MCIWndDestroy(hwnd: HWND);
procedure MCIWndSetZoom(hwnd: HWND; iZoom: UINT);
function MCIWndGetZoom(hwnd: HWND): UINT;
function MCIWndSetVolume(hwnd: HWND; iVol: UINT): DWORD;
function MCIWndGetVolume(hwnd: HWND): DWORD;
function MCIWndSetSpeed(hwnd: HWND; iSpeed: UINT): DWORD;
function MCIWndGetSpeed(hwnd: HWND): DWORD;
function MCIWndSetTimeFormat(hwnd: HWND; lp: LPCSTR): DWORD;
function MCIWndGetTimeFormat(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
procedure MCIWndValidateMedia(hwnd: HWND);
procedure MCIWndSetRepeat(hwnd: HWND; f: BOOL);
function MCIWndGetRepeat(hwnd: HWND): BOOL;
function MCIWndUseFrames(hwnd: HWND): DWORD;
function MCIWndUseTime(hwnd: HWND): DWORD;
procedure MCIWndSetActiveTimer(hwnd: HWND; active: UINT);
procedure MCIWndSetInactiveTimer(hwnd: HWND; inactive: UINT);
procedure MCIWndSetTimers(hwnd: HWND; active, inactive: UINT);
function MCIWndGetActiveTimer(hwnd: HWND): UINT;
function MCIWndGetInactiveTimer(hwnd: HWND): UINT;
function MCIWndRealize(hwnd: HWND; fBkgnd: BOOL): DWORD;
function MCIWndSendString(hwnd: HWND; sz: LPCSTR): DWORD;
function MCIWndReturnString(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetError(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetPalette(hwnd: HWND): HPALETTE;
function MCIWndSetPalette(hwnd: HWND; hpal: HPALETTE): DWORD;
function MCIWndGetFileName(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetDevice(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetStyles(hwnd: HWND): UINT;
function MCIWndChangeStyles(hwnd: HWND; mask: UINT; value: DWORD): DWORD;
function MCIWndOpenInterface(hwnd: HWND; pUnk: PUnknown): DWORD;
function MCIWndSetOwner(hwnd: HWND; hwndP: HWND): DWORD;
function AVICapSM(hwnd: HWND; m: UINT; w: WPARAM; l: LPARAM): DWORD;
function capSetCallbackOnError(hwnd: HWND; fpProc: TCAPERRORCALLBACK): BOOL;
function capSetCallbackOnStatus(hwnd: HWND; fpProc: TCAPSTATUSCALLBACK): BOOL;
function capSetCallbackOnYield(hwnd: HWND; fpProc: TCAPYIELDCALLBACK): BOOL;
function capSetCallbackOnFrame(hwnd: HWND; fpProc: TCAPVIDEOCALLBACK): BOOL;
function capSetCallbackOnVideoStream(hwnd: HWND; fpProc: TCAPVIDEOCALLBACK): BOOL;
function capSetCallbackOnWaveStream(hwnd: HWND; fpProc: TCAPWAVECALLBACK): BOOL;
function capSetCallbackOnCapControl(hwnd: HWND; fpProc: TCAPCONTROLCALLBACK): BOOL;
function capSetUserData(hwnd: HWND; lUser: DWORD): BOOL;
function capGetUserData(hwnd: HWND): DWORD;
function capDriverConnect(hwnd: HWND; i: INT): BOOL;
function capDriverDisconnect(hwnd: HWND): BOOL;
function capDriverGetName(hwnd: HWND; szName: LPSTR; wSize: WORD): BOOL;
function capDriverGetVersion(hwnd: HWND; szVer: LPSTR; wSize: WORD): BOOL;
function capDriverGetCaps(hwnd: HWND; s: PCAPDRIVERCAPS; wSize: WORD): BOOL;
function capFileSetCaptureFile(hwnd: HWND; szName: LPCSTR): BOOL;
function capFileGetCaptureFile(hwnd: HWND; szName: LPSTR; wSize: WORD): BOOL;
function capFileAlloc(hwnd: HWND; dwSize: DWORD): BOOL;
function capFileSaveAs(hwnd: HWND; szName: LPCSTR): BOOL;
function capFileSetInfoChunk(hwnd: HWND; lpInfoChunk: PCAPINFOCHUNK): BOOL;
function capFileSaveDIB(hwnd: HWND; szName: LPCSTR): BOOL;
function capEditCopy(hwnd: HWND): BOOL;
function capSetAudioFormat(hwnd: HWND; s: PWAVEFORMATEX; wSize: WORD): BOOL;
function capGetAudioFormat(hwnd: HWND; s: PWAVEFORMATEX; wSize: WORD): DWORD;
function capGetAudioFormatSize(hwnd: HWND): DWORD;
function capDlgVideoFormat(hwnd: HWND): BOOL;
function capDlgVideoSource(hwnd: HWND): BOOL;
function capDlgVideoDisplay(hwnd: HWND): BOOL;
function capDlgVideoCompression(hwnd: HWND): BOOL;
function capGetVideoFormat(hwnd: HWND; s: PVOID; wSize: WORD): DWORD;
function capGetVideoFormatSize(hwnd: HWND): DWORD;
function capSetVideoFormat(hwnd: HWND; s: PVOID; wSize: WORD): BOOL;
function capPreview(hwnd: HWND; f: BOOL): BOOL;
function capPreviewRate(hwnd: HWND; wMS: WORD): BOOL;
function capOverlay(hwnd: HWND; f: BOOL): BOOL;
function capPreviewScale(hwnd: HWND; f: BOOL): BOOL;
function capGetStatus(hwnd: HWND; s: PCAPSTATUS; wSize: WORD): BOOL;
function capSetScrollPos(hwnd: HWND; lpP: PPOINT): BOOL;
function capGrabFrame(hwnd: HWND): BOOL;
function capGrabFrameNoStop(hwnd: HWND): BOOL;
function capCaptureSequence(hwnd: HWND): BOOL;
function capCaptureSequenceNoFile(hwnd: HWND): BOOL;
function capCaptureStop(hwnd: HWND): BOOL;
function capCaptureAbort(hwnd: HWND): BOOL;
function capCaptureSingleFrameOpen(hwnd: HWND): BOOL;
function capCaptureSingleFrameClose(hwnd: HWND): BOOL;
function capCaptureSingleFrame(hwnd: HWND): BOOL;
function capCaptureGetSetup(hwnd: HWND; s: PCAPTUREPARMS; wSize: WORD): BOOL;
function capCaptureSetSetup(hwnd: HWND; s: PCAPTUREPARMS; wSize: WORD): BOOL;
function capSetMCIDeviceName(hwnd: HWND; szName: LPCSTR): BOOL;
function capGetMCIDeviceName(hwnd: HWND; szName: LPSTR; wSize: WORD): BOOL;
function capPaletteOpen(hwnd: HWND; szName: LPCSTR): BOOL;
function capPaletteSave(hwnd: HWND; szName: LPCSTR): BOOL;
function capPalettePaste(hwnd: HWND): BOOL;
function capPaletteAuto(hwnd: HWND; iFrames, iColors: INT): BOOL;
function capPaletteManual(hwnd: HWND; fGrab: BOOL; iColors: INT): BOOL;
function capCreateCaptureWindowA( lpszWindowName : LPCSTR; dwStyle : DWORD; x, y : int; nWidth, nHeight : int; hwndParent : HWND; nID : int ): HWND; stdcall;
function capGetDriverDescriptionA( wDriverIndex : UINT; lpszName : LPSTR; cbName : int; lpszVer : LPSTR; cbVer : int ): BOOL; stdcall;
function capCreateCaptureWindowW( lpszWindowName : LPCWSTR; dwStyle : DWORD; x, y : int; nWidth, nHeight : int; hwndParent : HWND; nID : int ): HWND; stdcall;
function capGetDriverDescriptionW( wDriverIndex : UINT; lpszName : LPWSTR; cbName : int; lpszVer : LPWSTR; cbVer : int ): BOOL; stdcall;
function capCreateCaptureWindow( lpszWindowName : LPCSTR; dwStyle : DWORD; x, y : int; nWidth, nHeight : int; hwndParent : HWND; nID : int ): HWND; stdcall;
function capGetDriverDescription( wDriverIndex : UINT; lpszName : LPSTR; cbName : int; lpszVer : LPSTR; cbVer : int ): BOOL; stdcall;
function GetOpenFileNamePreviewA(lpofn: POPENFILENAMEA): BOOL; stdcall;
function GetSaveFileNamePreviewA(lpofn: POPENFILENAMEA): BOOL; stdcall;
function GetOpenFileNamePreviewW(lpofn: POPENFILENAMEW): BOOL; stdcall;
function GetSaveFileNamePreviewW(lpofn: POPENFILENAMEW): BOOL; stdcall;
function GetOpenFileNamePreview(lpofn: POPENFILENAMEA): BOOL; stdcall;
function GetSaveFileNamePreview(lpofn: POPENFILENAMEA): BOOL; stdcall;

Types

PVOID = pointer;
LONG = longint;
PLONG = ˆLONG;
int = integer;
HIC = THandle;
TWOCC = word;
PICOPEN = ˆTICOPEN;
PICINFO = ˆTICINFO;
PICCOMPRESS = ˆTICCOMPRESS;
TICCompressProc = function(lInputOutput: LPARAM; lFrame: DWORD; lpBits: PVOID; len: LONG): LONG; stdcall;
PICCOMPRESSFRAMES = ˆTICCOMPRESSFRAMES;
TICStatusProc = function(lParam: LPARAM; message: UINT; l: LONG): LONG; stdcall;
PICSETSTATUSPROC = ˆTICSETSTATUSPROC;
PICDECOMPRESS = ˆTICDECOMPRESS;
PICDECOMPRESSEX = ˆTICDECOMPRESSEX;
PICDRAWBEGIN = ˆTICDRAWBEGIN;
PICDRAW = ˆTICDRAW;
PICDRAWSUGGEST = ˆTICDRAWSUGGEST;
PICPALETTE = ˆTICPALETTE;
PCOMPVARS = ˆTCOMPVARS;
HDRAWDIB = THandle;
PDRAWDIBTIME = ˆTDRAWDIBTIME;
PMainAVIHeader = ˆTMainAVIHeader;
PAVIStreamHeader = ˆTAVIStreamHeader;
PAVIINDEXENTRY = ˆTAVIINDEXENTRY;
PAVIPALCHANGE = ˆTAVIPALCHANGE;
PAVIStreamInfoW = ˆTAVIStreamInfoW;
PAVIStreamInfoA = ˆTAVIStreamInfoA;
PAVIStreamInfo = ˆTAVIStreamInfo;
TAVIStreamInfo = TAVIStreamInfoA;
PAVIFileInfoW = ˆTAVIFileInfoW;
PAVIFileInfoA = ˆTAVIFileInfoA;
PAVIFileInfo = ˆTAVIFileInfo;
TAVIFileInfo = TAVIFileInfoA;
TAVISAVECALLBACK = function(i: int): BOOL; pascal;
PAVICOMPRESSOPTIONS = ˆTAVICOMPRESSOPTIONS;
PUnknown = ˆIUnknown;
HVIDEO = THandle;
PHVIDEO = ˆHVIDEO;
PVIDEOHDR = ˆTVIDEOHDR;
PCHANNEL_CAPS = ˆTCHANNEL_CAPS;
TCAPYIELDCALLBACK = function(hWnd: HWND): DWORD; stdcall;
TCAPSTATUSCALLBACKW = function(hWnd: HWND; nID: int; lpsz: LPCWSTR): DWORD; stdcall;
TCAPERRORCALLBACKW = function(hWnd: HWND; nID: int; lpsz: LPCWSTR): DWORD; stdcall;
TCAPSTATUSCALLBACKA = function(hWnd: HWND; nID: int; lpsz: LPCSTR): DWORD; stdcall;
TCAPERRORCALLBACKA = function(hWnd: HWND; nID: int; lpsz: LPCSTR): DWORD; stdcall;
TCAPSTATUSCALLBACK = TCAPSTATUSCALLBACKA;
TCAPERRORCALLBACK = TCAPERRORCALLBACKA;
TCAPVIDEOCALLBACK = function(hWnd: HWND; lpVHdr: PVIDEOHDR): DWORD; stdcall;
TCAPWAVECALLBACK = function(hWnd: HWND; lpWHdr: PWAVEHDR): DWORD; stdcall;
TCAPCONTROLCALLBACK = function(hWnd: HWND; nState: int): DWORD; stdcall;
PCAPDRIVERCAPS = ˆTCAPDRIVERCAPS;
PCAPSTATUS = ˆTCAPSTATUS;
PCAPTUREPARMS = ˆTCAPTUREPARMS;
PCAPINFOCHUNK = ˆTCAPINFOCHUNK;

Constants

ICVERSION = $0104 ;
BI_1632 = $32333631;
ICTYPE_VIDEO = $63646976;
ICTYPE_AUDIO = $63647561;
ICERR_OK = 0 ;
ICERR_DONTDRAW = 1 ;
ICERR_NEWPALETTE = 2 ;
ICERR_GOTOKEYFRAME = 3 ;
ICERR_STOPDRAWING = 4 ;
ICERR_UNSUPPORTED = -1 ;
ICERR_BADFORMAT = -2 ;
ICERR_MEMORY = -3 ;
ICERR_INTERNAL = -4 ;
ICERR_BADFLAGS = -5 ;
ICERR_BADPARAM = -6 ;
ICERR_BADSIZE = -7 ;
ICERR_BADHANDLE = -8 ;
ICERR_CANTUPDATE = -9 ;
ICERR_ABORT = -10 ;
ICERR_ERROR = -100 ;
ICERR_BADBITDEPTH = -200 ;
ICERR_BADIMAGESIZE = -201 ;
ICERR_CUSTOM = -400 ;
ICMODE_COMPRESS = 1 ;
ICMODE_DECOMPRESS = 2 ;
ICMODE_FASTDECOMPRESS = 3 ;
ICMODE_QUERY = 4 ;
ICMODE_FASTCOMPRESS = 5 ;
ICMODE_DRAW = 8 ;
AVIIF_LIST = $00000001 ;
AVIIF_TWOCC = $00000002 ;
AVIIF_KEYFRAME = $00000010 ;
ICQUALITY_LOW = 0 ;
ICQUALITY_HIGH = 10000 ;
ICQUALITY_DEFAULT = -1 ;
ICM_USER = (DRV_USER+$0000) ;
ICM_RESERVED_LOW = (DRV_USER+$1000) ;
ICM_RESERVED_HIGH = (DRV_USER+$2000) ;
ICM_RESERVED = ICM_RESERVED_LOW ;
ICM_GETSTATE = (ICM_RESERVED+0) ;
ICM_SETSTATE = (ICM_RESERVED+1) ;
ICM_GETINFO = (ICM_RESERVED+2) ;
ICM_CONFIGURE = (ICM_RESERVED+10);
ICM_ABOUT = (ICM_RESERVED+11);
ICM_GETDEFAULTQUALITY = (ICM_RESERVED+30);
ICM_GETQUALITY = (ICM_RESERVED+31);
ICM_SETQUALITY = (ICM_RESERVED+32);
ICM_SET = (ICM_RESERVED+40);
ICM_GET = (ICM_RESERVED+41);
ICM_FRAMERATE = $526D7246;
ICM_KEYFRAMERATE = $5279654B;
ICM_COMPRESS_GET_FORMAT = (ICM_USER+4) ;
ICM_COMPRESS_GET_SIZE = (ICM_USER+5) ;
ICM_COMPRESS_QUERY = (ICM_USER+6) ;
ICM_COMPRESS_BEGIN = (ICM_USER+7) ;
ICM_COMPRESS = (ICM_USER+8) ;
ICM_COMPRESS_END = (ICM_USER+9) ;
ICM_DECOMPRESS_GET_FORMAT = (ICM_USER+10) ;
ICM_DECOMPRESS_QUERY = (ICM_USER+11) ;
ICM_DECOMPRESS_BEGIN = (ICM_USER+12) ;
ICM_DECOMPRESS = (ICM_USER+13) ;
ICM_DECOMPRESS_END = (ICM_USER+14) ;
ICM_DECOMPRESS_SET_PALETTE = (ICM_USER+29) ;
ICM_DECOMPRESS_GET_PALETTE = (ICM_USER+30) ;
ICM_DRAW_QUERY = (ICM_USER+31) ;
ICM_DRAW_BEGIN = (ICM_USER+15) ;
ICM_DRAW_GET_PALETTE = (ICM_USER+16) ;
ICM_DRAW_START = (ICM_USER+18) ;
ICM_DRAW_STOP = (ICM_USER+19) ;
ICM_DRAW_END = (ICM_USER+21) ;
ICM_DRAW_GETTIME = (ICM_USER+32) ;
ICM_DRAW = (ICM_USER+33) ;
ICM_DRAW_WINDOW = (ICM_USER+34) ;
ICM_DRAW_SETTIME = (ICM_USER+35) ;
ICM_DRAW_REALIZE = (ICM_USER+36) ;
ICM_DRAW_FLUSH = (ICM_USER+37) ;
ICM_DRAW_RENDERBUFFER = (ICM_USER+38) ;
ICM_DRAW_START_PLAY = (ICM_USER+39) ;
ICM_DRAW_STOP_PLAY = (ICM_USER+40) ;
ICM_DRAW_SUGGESTFORMAT = (ICM_USER+50) ;
ICM_DRAW_CHANGEPALETTE = (ICM_USER+51) ;
ICM_GETBUFFERSWANTED = (ICM_USER+41) ;
ICM_GETDEFAULTKEYFRAMERATE = (ICM_USER+42) ;
ICM_DECOMPRESSEX_BEGIN = (ICM_USER+60) ;
ICM_DECOMPRESSEX_QUERY = (ICM_USER+61) ;
ICM_DECOMPRESSEX = (ICM_USER+62) ;
ICM_DECOMPRESSEX_END = (ICM_USER+63) ;
ICM_COMPRESS_FRAMES_INFO = (ICM_USER+70) ;
ICM_SET_STATUS_PROC = (ICM_USER+72) ;
VIDCF_QUALITY = $0001 ;
VIDCF_CRUNCH = $0002 ;
VIDCF_TEMPORAL = $0004 ;
VIDCF_COMPRESSFRAMES = $0008 ;
VIDCF_DRAW = $0010 ;
VIDCF_FASTTEMPORALC = $0020 ;
VIDCF_FASTTEMPORALD = $0080 ;
ICCOMPRESS_KEYFRAME = $00000001;
ICCOMPRESSFRAMES_PADDING = $00000001 ;
ICSTATUS_START = 0 ;
ICSTATUS_STATUS = 1 ;
ICSTATUS_END = 2 ;
ICSTATUS_ERROR = 3 ;
ICSTATUS_YIELD = 4 ;
ICDECOMPRESS_HURRYUP = $80000000 ;
ICDECOMPRESS_UPDATE = $40000000 ;
ICDECOMPRESS_PREROLL = $20000000 ;
ICDECOMPRESS_NULLFRAME = $10000000 ;
ICDECOMPRESS_NOTKEYFRAME = $08000000 ;
ICDRAW_QUERY = $00000001 ;
ICDRAW_FULLSCREEN = $00000002 ;
ICDRAW_HDC = $00000004 ;
ICDRAW_ANIMATE = $00000008 ;
ICDRAW_CONTINUE = $00000010 ;
ICDRAW_MEMORYDC = $00000020 ;
ICDRAW_UPDATING = $00000040 ;
ICDRAW_RENDER = $00000080 ;
ICDRAW_BUFFER = $00000100 ;
ICDRAW_HURRYUP = $80000000 ;
ICDRAW_UPDATE = $40000000 ;
ICDRAW_PREROLL = $20000000 ;
ICDRAW_NULLFRAME = $10000000 ;
ICDRAW_NOTKEYFRAME = $08000000 ;
ICINSTALL_UNICODE = $8000 ;
ICINSTALL_FUNCTION = $0001 ;
ICINSTALL_DRIVER = $0002 ;
ICINSTALL_HDRV = $0004 ;
ICINSTALL_DRIVERW = $8002 ;
ICMF_CONFIGURE_QUERY = $00000001 ;
ICMF_ABOUT_QUERY = $00000001 ;
ICMF_COMPVARS_VALID = $00000001;
ICMF_CHOOSE_KEYFRAME = $0001;
ICMF_CHOOSE_DATARATE = $0002;
ICMF_CHOOSE_PREVIEW = $0004;
ICMF_CHOOSE_ALLCOMPRESSORS = $0008;
DDF_UPDATE = $0002;
DDF_SAME_HDC = $0004;
DDF_SAME_DRAW = $0008;
DDF_DONTDRAW = $0010;
DDF_ANIMATE = $0020;
DDF_BUFFER = $0040;
DDF_JUSTDRAWIT = $0080;
DDF_FULLSCREEN = $0100;
DDF_BACKGROUNDPAL = $0200;
DDF_NOTKEYFRAME = $0400;
DDF_HURRYUP = $0800;
DDF_HALFTONE = $1000;
DDF_PREROLL = DDF_DONTDRAW;
DDF_SAME_DIB = DDF_SAME_DRAW;
DDF_SAME_SIZE = DDF_SAME_DRAW;
PD_CAN_DRAW_DIB = $0001;
PD_CAN_STRETCHDIB = $0002;
PD_STRETCHDIB_1_1_OK = $0004;
PD_STRETCHDIB_1_2_OK = $0008;
PD_STRETCHDIB_1_N_OK = $0010;
formtypeAVI = $20495641;
listtypeAVIHEADER = $6C726468;
ckidAVIMAINHDR = $68697661;
listtypeSTREAMHEADER = $6C727473;
ckidSTREAMHEADER = $68727473;
ckidSTREAMFORMAT = $66727473;
ckidSTREAMHANDLERDATA = $64727473;
ckidSTREAMNAME = $6E727473;
listtypeAVIMOVIE = $69766F6D;
listtypeAVIRECORD = $20636572;
ckidAVINEWINDEX = $31786469;
streamtypeVIDEO = $73646976;
streamtypeAUDIO = $73647561;
streamtypeMIDI = $7364696D;
streamtypeTEXT = $73747874;
cktypeDIBbits = $6264;
cktypeDIBcompressed = $6364;
cktypePALchange = $6370;
cktypeWAVEbytes = $6277;
ckidAVIPADDING = $4B4E554A;
AVIF_HASINDEX = $00000010;
AVIF_MUSTUSEINDEX = $00000020;
AVIF_ISINTERLEAVED = $00000100;
AVIF_TRUSTCKTYPE = $00000800;
AVIF_WASCAPTUREFILE = $00010000;
AVIF_COPYRIGHTED = $00020000;
AVI_HEADERSIZE = 2048;
AVISF_DISABLED = $00000001;
AVISF_VIDEO_PALCHANGES = $00010000;
AVIIF_NOTIME = $00000100;
AVIIF_COMPUSE = $0FFF0000;
AVIGETFRAMEF_BESTDISPLAYFMT = 1;
AVISTREAMINFO_DISABLED = $00000001;
AVISTREAMINFO_FORMATCHANGES = $00010000;
AVIFILEINFO_HASINDEX = $00000010;
AVIFILEINFO_MUSTUSEINDEX = $00000020;
AVIFILEINFO_ISINTERLEAVED = $00000100;
AVIFILEINFO_WASCAPTUREFILE = $00010000;
AVIFILEINFO_COPYRIGHTED = $00020000;
AVIFILECAPS_CANREAD = $00000001;
AVIFILECAPS_CANWRITE = $00000002;
AVIFILECAPS_ALLKEYFRAMES = $00000010;
AVIFILECAPS_NOCOMPRESSION = $00000020;
AVICOMPRESSF_INTERLEAVE = $00000001;
AVICOMPRESSF_DATARATE = $00000002;
AVICOMPRESSF_KEYFRAMES = $00000004;
AVICOMPRESSF_VALID = $00000008;
IID_IAVIFile : TGUID = (D1: $00020020; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
IID_IAVIStream : TGUID = (D1: $00020021; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
IID_IAVIStreaming : TGUID = (D1: $00020022; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
IID_IGetFrame : TGUID = (D1: $00020023; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
IID_IAVIEditStream: TGUID = (D1: $00020024; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
CLSID_AVISimpleUnMarshal : TGUID = (D1: $00020009; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
CLSID_AVIFile : TGUID = (D1: $00020000; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
AVIFILEHANDLER_CANREAD = $0001;
AVIFILEHANDLER_CANWRITE = $0002;
AVIFILEHANDLER_CANACCEPTNONRGB = $0004;
AVISTREAMREAD_CONVENIENT = -1;
FIND_DIR = $0000000F;
FIND_NEXT = $00000001;
FIND_PREV = $00000004;
FIND_FROM_START = $00000008;
FIND_TYPE = $000000F0;
FIND_KEY = $00000010;
FIND_ANY = $00000020;
FIND_FORMAT = $00000040;
FIND_RET = $0000F000;
FIND_POS = $00000000;
FIND_LENGTH = $00001000;
FIND_OFFSET = $00002000;
FIND_SIZE = $00003000;
FIND_INDEX = $00004000;
SEARCH_NEAREST = FIND_PREV;
SEARCH_BACKWARD = FIND_PREV;
SEARCH_FORWARD = FIND_NEXT;
SEARCH_KEY = FIND_KEY;
SEARCH_ANY = FIND_ANY;
comptypeDIB = $20424944;
AVIERR_OK = 0;
AVIERR_UNSUPPORTED = $80044065;
AVIERR_BADFORMAT = $80044066;
AVIERR_MEMORY = $80044067;
AVIERR_INTERNAL = $80044068;
AVIERR_BADFLAGS = $80044069;
AVIERR_BADPARAM = $8004406A;
AVIERR_BADSIZE = $8004406B;
AVIERR_BADHANDLE = $8004406C;
AVIERR_FILEREAD = $8004406D;
AVIERR_FILEWRITE = $8004406E;
AVIERR_FILEOPEN = $8004406F;
AVIERR_COMPRESSOR = $80044070;
AVIERR_NOCOMPRESSOR = $80044071;
AVIERR_READONLY = $80044072;
AVIERR_NODATA = $80044073;
AVIERR_BUFFERTOOSMALL = $80044074;
AVIERR_CANTCOMPRESS = $80044075;
AVIERR_USERABORT = $800440C6;
AVIERR_ERROR = $800440C7;
MCIWND_WINDOW_CLASS = 'MCIWndClass' ;
MCIWNDOPENF_NEW = $0001;
MCIWNDF_NOAUTOSIZEWINDOW = $0001;
MCIWNDF_NOPLAYBAR = $0002;
MCIWNDF_NOAUTOSIZEMOVIE = $0004;
MCIWNDF_NOMENU = $0008;
MCIWNDF_SHOWNAME = $0010;
MCIWNDF_SHOWPOS = $0020;
MCIWNDF_SHOWMODE = $0040;
MCIWNDF_SHOWALL = $0070;
MCIWNDF_NOTIFYMODE = $0100;
MCIWNDF_NOTIFYPOS = $0200;
MCIWNDF_NOTIFYSIZE = $0400;
MCIWNDF_NOTIFYERROR = $1000;
MCIWNDF_NOTIFYALL = $1F00;
MCIWNDF_NOTIFYANSI = $0080;
MCIWNDF_NOTIFYMEDIAA = $0880;
MCIWNDF_NOTIFYMEDIAW = $0800;
MCIWNDF_NOTIFYMEDIA = MCIWNDF_NOTIFYMEDIAA;
MCIWNDF_RECORD = $2000;
MCIWNDF_NOERRORDLG = $4000;
MCIWNDF_NOOPEN = $8000;
MCIWNDM_GETDEVICEID = WM_USER + 100;
MCIWNDM_GETSTART = WM_USER + 103;
MCIWNDM_GETLENGTH = WM_USER + 104;
MCIWNDM_GETEND = WM_USER + 105;
MCIWNDM_EJECT = WM_USER + 107;
MCIWNDM_SETZOOM = WM_USER + 108;
MCIWNDM_GETZOOM = WM_USER + 109;
MCIWNDM_SETVOLUME = WM_USER + 110;
MCIWNDM_GETVOLUME = WM_USER + 111;
MCIWNDM_SETSPEED = WM_USER + 112;
MCIWNDM_GETSPEED = WM_USER + 113;
MCIWNDM_SETREPEAT = WM_USER + 114;
MCIWNDM_GETREPEAT = WM_USER + 115;
MCIWNDM_REALIZE = WM_USER + 118;
MCIWNDM_VALIDATEMEDIA = WM_USER + 121;
MCIWNDM_PLAYFROM = WM_USER + 122;
MCIWNDM_PLAYTO = WM_USER + 123;
MCIWNDM_GETPALETTE = WM_USER + 126;
MCIWNDM_SETPALETTE = WM_USER + 127;
MCIWNDM_SETTIMERS = WM_USER + 129;
MCIWNDM_SETACTIVETIMER = WM_USER + 130;
MCIWNDM_SETINACTIVETIMER = WM_USER + 131;
MCIWNDM_GETACTIVETIMER = WM_USER + 132;
MCIWNDM_GETINACTIVETIMER = WM_USER + 133;
MCIWNDM_CHANGESTYLES = WM_USER + 135;
MCIWNDM_GETSTYLES = WM_USER + 136;
MCIWNDM_GETALIAS = WM_USER + 137;
MCIWNDM_PLAYREVERSE = WM_USER + 139;
MCIWNDM_GET_SOURCE = WM_USER + 140;
MCIWNDM_PUT_SOURCE = WM_USER + 141;
MCIWNDM_GET_DEST = WM_USER + 142;
MCIWNDM_PUT_DEST = WM_USER + 143;
MCIWNDM_CAN_PLAY = WM_USER + 144;
MCIWNDM_CAN_WINDOW = WM_USER + 145;
MCIWNDM_CAN_RECORD = WM_USER + 146;
MCIWNDM_CAN_SAVE = WM_USER + 147;
MCIWNDM_CAN_EJECT = WM_USER + 148;
MCIWNDM_CAN_CONFIG = WM_USER + 149;
MCIWNDM_PALETTEKICK = WM_USER + 150;
MCIWNDM_OPENINTERFACE = WM_USER + 151;
MCIWNDM_SETOWNER = WM_USER + 152;
MCIWNDM_SENDSTRINGA = WM_USER + 101;
MCIWNDM_GETPOSITIONA = WM_USER + 102;
MCIWNDM_GETMODEA = WM_USER + 106;
MCIWNDM_SETTIMEFORMATA = WM_USER + 119;
MCIWNDM_GETTIMEFORMATA = WM_USER + 120;
MCIWNDM_GETFILENAMEA = WM_USER + 124;
MCIWNDM_GETDEVICEA = WM_USER + 125;
MCIWNDM_GETERRORA = WM_USER + 128;
MCIWNDM_NEWA = WM_USER + 134;
MCIWNDM_RETURNSTRINGA = WM_USER + 138;
MCIWNDM_OPENA = WM_USER + 153;
MCIWNDM_SENDSTRINGW = WM_USER + 201;
MCIWNDM_GETPOSITIONW = WM_USER + 202;
MCIWNDM_GETMODEW = WM_USER + 206;
MCIWNDM_SETTIMEFORMATW = WM_USER + 219;
MCIWNDM_GETTIMEFORMATW = WM_USER + 220;
MCIWNDM_GETFILENAMEW = WM_USER + 224;
MCIWNDM_GETDEVICEW = WM_USER + 225;
MCIWNDM_GETERRORW = WM_USER + 228;
MCIWNDM_NEWW = WM_USER + 234;
MCIWNDM_RETURNSTRINGW = WM_USER + 238;
MCIWNDM_OPENW = WM_USER + 252;
MCIWNDM_SENDSTRING = MCIWNDM_SENDSTRINGA;
MCIWNDM_GETPOSITION = MCIWNDM_GETPOSITIONA;
MCIWNDM_GETMODE = MCIWNDM_GETMODEA;
MCIWNDM_SETTIMEFORMAT = MCIWNDM_SETTIMEFORMATA;
MCIWNDM_GETTIMEFORMAT = MCIWNDM_GETTIMEFORMATA;
MCIWNDM_GETFILENAME = MCIWNDM_GETFILENAMEA;
MCIWNDM_GETDEVICE = MCIWNDM_GETDEVICEA;
MCIWNDM_GETERROR = MCIWNDM_GETERRORA;
MCIWNDM_NEW = MCIWNDM_NEWA;
MCIWNDM_RETURNSTRING = MCIWNDM_RETURNSTRINGA;
MCIWNDM_OPEN = MCIWNDM_OPENA;
MCIWNDM_NOTIFYMODE = WM_USER + 200;
MCIWNDM_NOTIFYPOS = WM_USER + 201;
MCIWNDM_NOTIFYSIZE = WM_USER + 202;
MCIWNDM_NOTIFYMEDIA = WM_USER + 203;
MCIWNDM_NOTIFYERROR = WM_USER + 205;
MCIWND_START = dword(-1) ;
MCIWND_END = dword(-2) ;
DV_ERR_OK = 0;
DV_ERR_BASE = 1;
DV_ERR_NONSPECIFIC = DV_ERR_BASE;
DV_ERR_BADFORMAT = DV_ERR_BASE + 1;
DV_ERR_STILLPLAYING = DV_ERR_BASE + 2;
DV_ERR_UNPREPARED = DV_ERR_BASE + 3;
DV_ERR_SYNC = DV_ERR_BASE + 4;
DV_ERR_TOOMANYCHANNELS = DV_ERR_BASE + 5;
DV_ERR_NOTDETECTED = DV_ERR_BASE + 6;
DV_ERR_BADINSTALL = DV_ERR_BASE + 7;
DV_ERR_CREATEPALETTE = DV_ERR_BASE + 8;
DV_ERR_SIZEFIELD = DV_ERR_BASE + 9;
DV_ERR_PARAM1 = DV_ERR_BASE + 10;
DV_ERR_PARAM2 = DV_ERR_BASE + 11;
DV_ERR_CONFIG1 = DV_ERR_BASE + 12;
DV_ERR_CONFIG2 = DV_ERR_BASE + 13;
DV_ERR_FLAGS = DV_ERR_BASE + 14;
DV_ERR_13 = DV_ERR_BASE + 15;
DV_ERR_NOTSUPPORTED = DV_ERR_BASE + 16;
DV_ERR_NOMEM = DV_ERR_BASE + 17;
DV_ERR_ALLOCATED = DV_ERR_BASE + 18;
DV_ERR_BADDEVICEID = DV_ERR_BASE + 19;
DV_ERR_INVALHANDLE = DV_ERR_BASE + 20;
DV_ERR_BADERRNUM = DV_ERR_BASE + 21;
DV_ERR_NO_BUFFERS = DV_ERR_BASE + 22;
DV_ERR_MEM_CONFLICT = DV_ERR_BASE + 23;
DV_ERR_IO_CONFLICT = DV_ERR_BASE + 24;
DV_ERR_DMA_CONFLICT = DV_ERR_BASE + 25;
DV_ERR_INT_CONFLICT = DV_ERR_BASE + 26;
DV_ERR_PROTECT_ONLY = DV_ERR_BASE + 27;
DV_ERR_LASTERROR = DV_ERR_BASE + 27;
DV_ERR_USER_MSG = DV_ERR_BASE + 1000;
DV_VM_OPEN = MM_DRVM_OPEN;
DV_VM_CLOSE = MM_DRVM_CLOSE;
DV_VM_DATA = MM_DRVM_DATA;
DV_VM_ERROR = MM_DRVM_ERROR;
VHDR_DONE = $00000001;
VHDR_PREPARED = $00000002;
VHDR_INQUEUE = $00000004;
VHDR_KEYFRAME = $00000008;
VCAPS_OVERLAY = $00000001;
VCAPS_SRC_CAN_CLIP = $00000002;
VCAPS_DST_CAN_CLIP = $00000004;
VCAPS_CAN_SCALE = $00000008;
VIDEO_EXTERNALIN = $0001;
VIDEO_EXTERNALOUT = $0002;
VIDEO_IN = $0004;
VIDEO_OUT = $0008;
VIDEO_DLG_QUERY = $0010;
VIDEO_CONFIGURE_QUERY = $8000;
VIDEO_CONFIGURE_SET = $1000;
VIDEO_CONFIGURE_GET = $2000;
VIDEO_CONFIGURE_QUERYSIZE = $0001;
VIDEO_CONFIGURE_CURRENT = $0010;
VIDEO_CONFIGURE_NOMINAL = $0020;
VIDEO_CONFIGURE_MIN = $0040;
VIDEO_CONFIGURE_MAX = $0080;
DVM_USER = $4000;
DVM_CONFIGURE_START = $1000;
DVM_CONFIGURE_END = $1FFF;
DVM_PALETTE = DVM_CONFIGURE_START + 1;
DVM_FORMAT = DVM_CONFIGURE_START + 2;
DVM_PALETTERGB555 = DVM_CONFIGURE_START + 3;
DVM_SRC_RECT = DVM_CONFIGURE_START + 4;
DVM_DST_RECT = DVM_CONFIGURE_START + 5;
WM_CAP_START = WM_USER;
WM_CAP_UNICODE_START = WM_USER + 100;
WM_CAP_GET_CAPSTREAMPTR = WM_CAP_START + 1;
WM_CAP_SET_CALLBACK_ERRORW = WM_CAP_UNICODE_START + 2;
WM_CAP_SET_CALLBACK_STATUSW = WM_CAP_UNICODE_START + 3;
WM_CAP_SET_CALLBACK_ERRORA = WM_CAP_START + 2;
WM_CAP_SET_CALLBACK_STATUSA = WM_CAP_START + 3;
WM_CAP_SET_CALLBACK_ERROR = WM_CAP_SET_CALLBACK_ERRORA;
WM_CAP_SET_CALLBACK_STATUS = WM_CAP_SET_CALLBACK_STATUSA;
WM_CAP_SET_CALLBACK_YIELD = WM_CAP_START + 4;
WM_CAP_SET_CALLBACK_FRAME = WM_CAP_START + 5;
WM_CAP_SET_CALLBACK_VIDEOSTREAM = WM_CAP_START + 6;
WM_CAP_SET_CALLBACK_WAVESTREAM = WM_CAP_START + 7;
WM_CAP_GET_USER_DATA = WM_CAP_START + 8;
WM_CAP_SET_USER_DATA = WM_CAP_START + 9;
WM_CAP_DRIVER_CONNECT = WM_CAP_START + 10;
WM_CAP_DRIVER_DISCONNECT = WM_CAP_START + 11;
WM_CAP_DRIVER_GET_NAMEA = WM_CAP_START + 12;
WM_CAP_DRIVER_GET_VERSIONA = WM_CAP_START + 13;
WM_CAP_DRIVER_GET_NAMEW = WM_CAP_UNICODE_START + 12;
WM_CAP_DRIVER_GET_VERSIONW = WM_CAP_UNICODE_START + 13;
WM_CAP_DRIVER_GET_NAME = WM_CAP_DRIVER_GET_NAMEA;
WM_CAP_DRIVER_GET_VERSION = WM_CAP_DRIVER_GET_VERSIONA;
WM_CAP_DRIVER_GET_CAPS = WM_CAP_START + 14;
WM_CAP_FILE_SET_CAPTURE_FILEA = WM_CAP_START + 20;
WM_CAP_FILE_GET_CAPTURE_FILEA = WM_CAP_START + 21;
WM_CAP_FILE_SAVEASA = WM_CAP_START + 23;
WM_CAP_FILE_SAVEDIBA = WM_CAP_START + 25;
WM_CAP_FILE_SET_CAPTURE_FILEW = WM_CAP_UNICODE_START + 20;
WM_CAP_FILE_GET_CAPTURE_FILEW = WM_CAP_UNICODE_START + 21;
WM_CAP_FILE_SAVEASW = WM_CAP_UNICODE_START + 23;
WM_CAP_FILE_SAVEDIBW = WM_CAP_UNICODE_START + 25;
WM_CAP_FILE_SET_CAPTURE_FILE = WM_CAP_FILE_SET_CAPTURE_FILEA;
WM_CAP_FILE_GET_CAPTURE_FILE = WM_CAP_FILE_GET_CAPTURE_FILEA;
WM_CAP_FILE_SAVEAS = WM_CAP_FILE_SAVEASA;
WM_CAP_FILE_SAVEDIB = WM_CAP_FILE_SAVEDIBA;
WM_CAP_FILE_ALLOCATE = WM_CAP_START + 22;
WM_CAP_FILE_SET_INFOCHUNK = WM_CAP_START + 24;
WM_CAP_EDIT_COPY = WM_CAP_START + 30;
WM_CAP_SET_AUDIOFORMAT = WM_CAP_START + 35;
WM_CAP_GET_AUDIOFORMAT = WM_CAP_START + 36;
WM_CAP_DLG_VIDEOFORMAT = WM_CAP_START + 41;
WM_CAP_DLG_VIDEOSOURCE = WM_CAP_START + 42;
WM_CAP_DLG_VIDEODISPLAY = WM_CAP_START + 43;
WM_CAP_GET_VIDEOFORMAT = WM_CAP_START + 44;
WM_CAP_SET_VIDEOFORMAT = WM_CAP_START + 45;
WM_CAP_DLG_VIDEOCOMPRESSION = WM_CAP_START + 46;
WM_CAP_SET_PREVIEW = WM_CAP_START + 50;
WM_CAP_SET_OVERLAY = WM_CAP_START + 51;
WM_CAP_SET_PREVIEWRATE = WM_CAP_START + 52;
WM_CAP_SET_SCALE = WM_CAP_START + 53;
WM_CAP_GET_STATUS = WM_CAP_START + 54;
WM_CAP_SET_SCROLL = WM_CAP_START + 55;
WM_CAP_GRAB_FRAME = WM_CAP_START + 60;
WM_CAP_GRAB_FRAME_NOSTOP = WM_CAP_START + 61;
WM_CAP_SEQUENCE = WM_CAP_START + 62;
WM_CAP_SEQUENCE_NOFILE = WM_CAP_START + 63;
WM_CAP_SET_SEQUENCE_SETUP = WM_CAP_START + 64;
WM_CAP_GET_SEQUENCE_SETUP = WM_CAP_START + 65;
WM_CAP_SET_MCI_DEVICEA = WM_CAP_START + 66;
WM_CAP_GET_MCI_DEVICEA = WM_CAP_START + 67;
WM_CAP_SET_MCI_DEVICEW = WM_CAP_UNICODE_START + 66;
WM_CAP_GET_MCI_DEVICEW = WM_CAP_UNICODE_START + 67;
WM_CAP_SET_MCI_DEVICE = WM_CAP_SET_MCI_DEVICEA;
WM_CAP_GET_MCI_DEVICE = WM_CAP_GET_MCI_DEVICEA;
WM_CAP_STOP = WM_CAP_START + 68;
WM_CAP_ABORT = WM_CAP_START + 69;
WM_CAP_SINGLE_FRAME_OPEN = WM_CAP_START + 70;
WM_CAP_SINGLE_FRAME_CLOSE = WM_CAP_START + 71;
WM_CAP_SINGLE_FRAME = WM_CAP_START + 72;
WM_CAP_PAL_OPENA = WM_CAP_START + 80;
WM_CAP_PAL_SAVEA = WM_CAP_START + 81;
WM_CAP_PAL_OPENW = WM_CAP_UNICODE_START + 80;
WM_CAP_PAL_SAVEW = WM_CAP_UNICODE_START + 81;
WM_CAP_PAL_OPEN = WM_CAP_PAL_OPENA;
WM_CAP_PAL_SAVE = WM_CAP_PAL_SAVEA;
WM_CAP_PAL_PASTE = WM_CAP_START + 82;
WM_CAP_PAL_AUTOCREATE = WM_CAP_START + 83;
WM_CAP_PAL_MANUALCREATE = WM_CAP_START + 84;
WM_CAP_SET_CALLBACK_CAPCONTROL = WM_CAP_START + 85;
WM_CAP_UNICODE_END = WM_CAP_PAL_SAVEW;
WM_CAP_END = WM_CAP_UNICODE_END;
AVSTREAMMASTER_AUDIO = 0;
AVSTREAMMASTER_NONE = 1;
CONTROLCALLBACK_PREROLL = 1;
CONTROLCALLBACK_CAPTURING = 2;
infotypeDIGITIZATION_TIME = $54494449;
infotypeSMPTE_TIME = $504D5349;
IDS_CAP_BEGIN = 300;
IDS_CAP_END = 301;
IDS_CAP_INFO = 401;
IDS_CAP_OUTOFMEM = 402;
IDS_CAP_FILEEXISTS = 403;
IDS_CAP_ERRORPALOPEN = 404;
IDS_CAP_ERRORPALSAVE = 405;
IDS_CAP_ERRORDIBSAVE = 406;
IDS_CAP_DEFAVIEXT = 407;
IDS_CAP_DEFPALEXT = 408;
IDS_CAP_CANTOPEN = 409;
IDS_CAP_SEQ_MSGSTART = 410;
IDS_CAP_SEQ_MSGSTOP = 411;
IDS_CAP_VIDEDITERR = 412;
IDS_CAP_READONLYFILE = 413;
IDS_CAP_WRITEERROR = 414;
IDS_CAP_NODISKSPACE = 415;
IDS_CAP_SETFILESIZE = 416;
IDS_CAP_SAVEASPERCENT = 417;
IDS_CAP_DRIVER_ERROR = 418;
IDS_CAP_WAVE_OPEN_ERROR = 419;
IDS_CAP_WAVE_ALLOC_ERROR = 420;
IDS_CAP_WAVE_PREPARE_ERROR = 421;
IDS_CAP_WAVE_ADD_ERROR = 422;
IDS_CAP_WAVE_SIZE_ERROR = 423;
IDS_CAP_VIDEO_OPEN_ERROR = 424;
IDS_CAP_VIDEO_ALLOC_ERROR = 425;
IDS_CAP_VIDEO_PREPARE_ERROR = 426;
IDS_CAP_VIDEO_ADD_ERROR = 427;
IDS_CAP_VIDEO_SIZE_ERROR = 428;
IDS_CAP_FILE_OPEN_ERROR = 429;
IDS_CAP_FILE_WRITE_ERROR = 430;
IDS_CAP_RECORDING_ERROR = 431;
IDS_CAP_RECORDING_ERROR2 = 432;
IDS_CAP_AVI_INIT_ERROR = 433;
IDS_CAP_NO_FRAME_CAP_ERROR = 434;
IDS_CAP_NO_PALETTE_WARN = 435;
IDS_CAP_MCI_CONTROL_ERROR = 436;
IDS_CAP_MCI_CANT_STEP_ERROR = 437;
IDS_CAP_NO_AUDIO_CAP_ERROR = 438;
IDS_CAP_AVI_DRAWDIB_ERROR = 439;
IDS_CAP_COMPRESSOR_ERROR = 440;
IDS_CAP_AUDIO_DROP_ERROR = 441;
IDS_CAP_STAT_LIVE_MODE = 500;
IDS_CAP_STAT_OVERLAY_MODE = 501;
IDS_CAP_STAT_CAP_INIT = 502;
IDS_CAP_STAT_CAP_FINI = 503;
IDS_CAP_STAT_PALETTE_BUILD = 504;
IDS_CAP_STAT_OPTPAL_BUILD = 505;
IDS_CAP_STAT_I_FRAMES = 506;
IDS_CAP_STAT_L_FRAMES = 507;
IDS_CAP_STAT_CAP_L_FRAMES = 508;
IDS_CAP_STAT_CAP_AUDIO = 509;
IDS_CAP_STAT_VIDEOCURRENT = 510;
IDS_CAP_STAT_VIDEOAUDIO = 511;
IDS_CAP_STAT_VIDEOONLY = 512;
IDS_CAP_STAT_FRAMESDROPPED = 513;

Description

Functions and Procedures

function VideoForWindowsVersion: DWORD; pascal;
function MKFOURCC(ch0, ch1, ch2, ch3: AnsiChar): FOURCC;
function mmioFOURCC(ch0, ch1, ch2, ch3: AnsiChar): FOURCC;
function aviTWOCC(ch0, ch1: AnsiChar): TWOCC;
function ICInfo(fccType, fccHandler: DWORD; lpicinfo: PICINFO) : BOOL ; stdcall;
function ICInstall(fccType, fccHandler: DWORD; lParam: LPARAM; szDesc: LPSTR; wFlags: UINT) : BOOL ; stdcall;
function ICRemove(fccType, fccHandler: DWORD; wFlags: UINT) : BOOL ; stdcall;
function ICGetInfo(hic: HIC; picinfo: PICINFO; cb: DWORD) : DWORD ; stdcall;
function ICOpen(fccType, fccHandler: DWORD; wMode: UINT) : HIC ; stdcall;
function ICOpenFunction(fccType, fccHandler: DWORD; wMode: UINT; lpfnHandler: TFarProc) : HIC ; stdcall;
function ICClose(hic: HIC) : DWORD; stdcall;
function ICSendMessage(hic: HIC; msg: UINT; dw1, dw2: DWORD) : DWORD ; stdcall;
function ICQueryAbout(hic: HIC): BOOL;
function ICAbout(hic: HIC; hwnd: HWND): DWORD;
function ICQueryConfigure(hic: HIC): BOOL;
function ICConfigure(hic: HIC; hwnd: HWND): DWORD;
function ICGetState(hic: HIC; pv: PVOID; cb: DWORD): DWORD;
function ICSetState(hic: HIC; pv: PVOID; cb: DWORD): DWORD;
function ICGetStateSize(hic: HIC): DWORD;
function ICGetDefaultQuality(hic: HIC): DWORD;
function ICGetDefaultKeyFrameRate(hic: HIC): DWORD;
function ICDrawWindow(hic: HIC; prc: PRECT): DWORD;
function ICCompress( hic : HIC; dwFlags : DWORD; lpbiOutput : PBITMAPINFOHEADER; lpData : PVOID; lpbiInput : PBITMAPINFOHEADER; lpBits : PVOID; lpckid : PDWORD; lpdwFlags : PDWORD; lFrameNum : DWORD; dwFrameSize : DWORD; dwQuality : DWORD; lpbiPrev : PBITMAPINFOHEADER; lpPrev : PVOID ): DWORD; cdecl;
function ICCompressBegin(hic: HIC; lpbiInput: PBITMAPINFOHEADER; lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICCompressQuery(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICCompressGetFormat(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICCompressGetFormatSize(hic: HIC; lpbi: PBITMAPINFOHEADER): DWORD;
function ICCompressGetSize(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICCompressEnd(hic: HIC): DWORD;
function ICDecompress( hic : HIC; dwFlags : DWORD; lpbiFormat : PBITMAPINFOHEADER; lpData : PVOID; lpbi : PBITMAPINFOHEADER; lpBits : PVOID ): DWORD; cdecl;
function ICDecompressBegin(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICDecompressQuery(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICDecompressGetFormat(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICDecompressGetFormatSize(hic: HIC; lpbi: PBITMAPINFOHEADER): DWORD;
function ICDecompressGetPalette(hic: HIC; lpbiInput, lpbiOutput: PBITMAPINFOHEADER): DWORD;
function ICDecompressSetPalette(hic: HIC; lpbiPalette: PBITMAPINFOHEADER): DWORD;
function ICDecompressEnd(hic: HIC): DWORD;
function ICDecompressEx( hic : HIC; dwFlags : DWORD; lpbiSrc : PBITMAPINFOHEADER; lpSrc : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; lpbiDst : PBITMAPINFOHEADER; lpDst : PVOID; xDst : int; yDst : int; dxDst : int; dyDst : int ): DWORD; stdcall;
function ICDecompressExBegin( hic : HIC; dwFlags : DWORD; lpbiSrc : PBITMAPINFOHEADER; lpSrc : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; lpbiDst : PBITMAPINFOHEADER; lpDst : PVOID; xDst : int; yDst : int; dxDst : int; dyDst : int ): DWORD; stdcall;
function ICDecompressExQuery( hic : HIC; dwFlags : DWORD; lpbiSrc : PBITMAPINFOHEADER; lpSrc : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; lpbiDst : PBITMAPINFOHEADER; lpDst : PVOID; xDst : int; yDst : int; dxDst : int; dyDst : int ): DWORD; stdcall;
function ICDecompressExEnd(hic: HIC): DWORD;
function ICDrawBegin( hic : HIC; dwFlags : DWORD; hpal : HPALETTE; hwnd : HWND; hdc : HDC; xDst : int; yDst : int; dxDst : int; dyDst : int; lpbi : PBITMAPINFOHEADER; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; dwRate : DWORD; dwScale : DWORD ): DWORD; cdecl;
function ICDraw( hic : HIC; dwFlags : DWORD; lpFormat : PVOID; lpData : PVOID; cbData : DWORD; lTime : DWORD ): DWORD; cdecl;
function ICDrawSuggestFormat( hic : HIC; lpbiIn : PBITMAPINFOHEADER; lpbiOut : PBITMAPINFOHEADER; dxSrc : int; dySrc : int; dxDst : int; dyDst : int; hicDecomp : HIC ): DWORD; stdcall;
function ICDrawQuery(hic: HIC; lpbiInput: PBITMAPINFOHEADER): DWORD;
function ICDrawChangePalette(hic: HIC; lpbiInput: PBITMAPINFOHEADER): DWORD;
function ICGetBuffersWanted(hic: HIC; lpdwBuffers: PDWORD): DWORD;
function ICDrawEnd(hic: HIC): DWORD;
function ICDrawStart(hic: HIC): DWORD;
function ICDrawStartPlay(hic: HIC; lFrom, lTo: DWORD): DWORD;
function ICDrawStop(hic: HIC): DWORD;
function ICDrawStopPlay(hic: HIC): DWORD;
function ICDrawGetTime(hic: HIC; lplTime: PDWORD): DWORD;
function ICDrawSetTime(hic: HIC; lTime: DWORD): DWORD;
function ICDrawRealize(hic: HIC; hdc: HDC; fBackground: BOOL): DWORD;
function ICDrawFlush(hic: HIC): DWORD;
function ICDrawRenderBuffer(hic: HIC): DWORD;
function ICSetStatusProc( hic : HIC; dwFlags : DWORD; lParam : DWORD; fpfnStatus : TICStatusProc ): DWORD; stdcall;
function ICLocate(fccType, fccHandler: DWORD; lpbiIn, lpbiOut: PBITMAPINFOHEADER; wFlags: WORD): HIC; stdcall;
function ICGetDisplayFormat(hic: HIC; lpbiIn, lpbiOut: PBITMAPINFOHEADER; BitDepth: int; dx, dy: int): HIC; stdcall;
function ICDecompressOpen(fccType, fccHandler: DWORD; lpbiIn, lpbiOut: PBITMAPINFOHEADER): HIC;
function ICDrawOpen(fccType, fccHandler: DWORD; lpbiIn: PBITMAPINFOHEADER): HIC;
function ICImageCompress( hic : HIC; uiFlags : UINT; lpbiIn : PBITMAPINFO; lpBits : PVOID; lpbiOut : PBITMAPINFO; lQuality : LONG; plSize : PDWORD ): THANDLE; stdcall;
function ICImageDecompress( hic : HIC; uiFlags : UINT; lpbiIn : PBITMAPINFO; lpBits : PVOID; lpbiOut : PBITMAPINFO ): THANDLE; stdcall;
function ICCompressorChoose( hwnd : HWND; uiFlags : UINT; pvIn : PVOID; lpData : PVOID; pc : PCOMPVARS; lpszTitle : LPSTR ): BOOL; stdcall;
function ICSeqCompressFrameStart(pc: PCOMPVARS; lpbiIn: PBITMAPINFO): BOOL; stdcall;
procedure ICSeqCompressFrameEnd(pc: PCOMPVARS); stdcall;
function ICSeqCompressFrame( pc : PCOMPVARS; uiFlags : UINT; lpBits : PVOID; pfKey : PBOOL; plSize : PDWORD ): PVOID; stdcall;
procedure ICCompressorFree(pc: PCOMPVARS); stdcall;
function DrawDibOpen: HDRAWDIB; stdcall;
function DrawDibClose(hdd: HDRAWDIB): BOOL; stdcall;
function DrawDibGetBuffer(hdd: HDRAWDIB; lpbi: PBITMAPINFOHEADER; dwSize: DWORD; dwFlags: DWORD): PVOID; stdcall;
function DrawDibGetPalette(hdd: HDRAWDIB): HPALETTE; stdcall;
function DrawDibSetPalette(hdd: HDRAWDIB; hpal: HPALETTE): BOOL; stdcall;
function DrawDibChangePalette(hdd: HDRAWDIB; iStart, iLen: int; lppe: PPALETTEENTRY): BOOL; stdcall;
function DrawDibRealize(hdd: HDRAWDIB; hdc: HDC; fBackground: BOOL): UINT; stdcall;
function DrawDibStart(hdd: HDRAWDIB; rate: DWORD): BOOL; stdcall;
function DrawDibStop(hdd: HDRAWDIB): BOOL; stdcall;
function DrawDibBegin( hdd : HDRAWDIB; hdc : HDC; dxDst : int; dyDst : int; lpbi : PBITMAPINFOHEADER; dxSrc : int; dySrc : int; wFlags : UINT ): BOOL; stdcall;
function DrawDibDraw( hdd : HDRAWDIB; hdc : HDC; xDst : int; yDst : int; dxDst : int; dyDst : int; lpbi : PBITMAPINFOHEADER; lpBits : PVOID; xSrc : int; ySrc : int; dxSrc : int; dySrc : int; wFlags : UINT ): BOOL; stdcall;
function DrawDibUpdate(hdd: HDRAWDIB; hdc: HDC; x, y: int): BOOL;
function DrawDibEnd(hdd: HDRAWDIB): BOOL; stdcall;
function DrawDibTime(hdd: HDRAWDIB; lpddtime: PDRAWDIBTIME): BOOL; stdcall;
function DrawDibProfileDisplay(lpbi: PBITMAPINFOHEADER): DWORD; stdcall;
function FromHex(n: BYTE): BYTE;
function StreamFromFOURCC(fcc: DWORD): BYTE;
function TWOCCFromFOURCC(fcc: DWORD): WORD;
function ToHex(n: BYTE): BYTE;
function MAKEAVICKID(tcc: WORD; stream: BYTE): DWORD;
procedure AVIFileInit; stdcall;
procedure AVIFileExit; stdcall;
function AVIFileAddRef(pfile: IAVIFile): ULONG; stdcall;
function AVIFileRelease(pfile: IAVIFile): ULONG; stdcall;
function AVIFileOpenA(var ppfile: IAVIFile; szFile: LPCSTR; uMode: UINT; lpHandler: PCLSID): HResult; stdcall;
function AVIFileOpenW(var ppfile: IAVIFile; szFile: LPCWSTR; uMode: UINT; lpHandler: PCLSID): HResult; stdcall;
function AVIFileOpen(var ppfile: IAVIFile; szFile: LPCSTR; uMode: UINT; lpHandler: PCLSID): HResult; stdcall;
function AVIFileInfoW(pfile: IAVIFile; var pfi: TAVIFILEINFOW; lSize: LONG): HResult; stdcall;
function AVIFileInfoA(pfile: IAVIFile; var pfi: TAVIFILEINFOA; lSize: LONG): HResult; stdcall;
function AVIFileInfo(pfile: IAVIFile; var pfi: TAVIFILEINFO; lSize: LONG): HResult; stdcall;
function AVIFileGetStream(pfile: IAVIFile; var ppavi: IAVISTREAM; fccType: DWORD; lParam: LONG): HResult; stdcall;
function AVIFileCreateStreamW(pfile: IAVIFile; var ppavi: IAVISTREAM; var psi: TAVISTREAMINFOW): HResult; stdcall;
function AVIFileCreateStreamA(pfile: IAVIFile; var ppavi: IAVISTREAM; var psi: TAVISTREAMINFOA): HResult; stdcall;
function AVIFileCreateStream(pfile: IAVIFile; var ppavi: IAVISTREAM; var psi: TAVISTREAMINFO): HResult; stdcall;
function AVIFileWriteData(pfile: IAVIFile; ckid: DWORD; lpData: PVOID; cbData: LONG): HResult; stdcall;
function AVIFileReadData(pfile: IAVIFile; ckid: DWORD; lpData: PVOID; var lpcbData: LONG): HResult; stdcall;
function AVIFileEndRecord(pfile: IAVIFile): HResult; stdcall;
function AVIStreamAddRef(pavi: IAVIStream): ULONG; stdcall;
function AVIStreamRelease(pavi: IAVIStream): ULONG; stdcall;
function AVIStreamInfoW (pavi: IAVIStream; var psi: TAVISTREAMINFOW; lSize: LONG): HResult; stdcall;
function AVIStreamInfoA (pavi: IAVIStream; var psi: TAVISTREAMINFOA; lSize: LONG): HResult; stdcall;
function AVIStreamInfo(pavi: IAVIStream; var psi: TAVISTREAMINFO; lSize: LONG): HResult; stdcall;
function AVIStreamFindSample(pavi: IAVIStream; lPos: LONG; lFlags: LONG): LONG; stdcall;
function AVIStreamReadFormat(pavi: IAVIStream; lPos: LONG; lpFormat: PVOID; lpcbFormat: PLONG): HResult; stdcall;
function AVIStreamSetFormat(pavi: IAVIStream; lPos: LONG; lpFormat: PVOID; cbFormat: LONG): HResult; stdcall;
function AVIStreamReadData(pavi: IAVIStream; fcc: DWORD; lp: PVOID; lpcb: PLONG): HResult; stdcall;
function AVIStreamWriteData(pavi: IAVIStream; fcc: DWORD; lp: PVOID; cb: LONG): HResult; stdcall;
function AVIStreamRead( pavi : IAVISTREAM; lStart : LONG; lSamples : LONG; lpBuffer : PVOID; cbBuffer : LONG; plBytes : PLONG; plSamples : PLONG ): HResult; stdcall;
function AVIStreamWrite( pavi : IAVISTREAM; lStart : LONG; lSamples : LONG; lpBuffer : PVOID; cbBuffer : LONG; dwFlags : DWORD; plSampWritten : PLONG; plBytesWritten : PLONG ): HResult; stdcall;
function AVIStreamStart(pavi: IAVIStream): LONG; stdcall;
function AVIStreamLength(pavi: IAVIStream): LONG; stdcall;
function AVIStreamTimeToSample(pavi: IAVIStream; lTime: LONG): LONG; stdcall;
function AVIStreamSampleToTime(pavi: IAVIStream; lSample: LONG): LONG; stdcall;
function AVIStreamBeginStreaming(pavi: IAVIStream; lStart, lEnd: LONG; lRate: LONG): HResult; stdcall;
function AVIStreamEndStreaming(pavi: IAVIStream): HResult; stdcall;
function AVIStreamGetFrameOpen(pavi: IAVIStream; lpbiWanted: PBitmapInfoHeader): IGetFrame; stdcall;
function AVIStreamGetFrame(pg: IGetFrame; lPos: LONG): PBitmapInfoHeader; stdcall;
function AVIStreamGetFrameClose(pg: IGetFrame): HResult; stdcall;
function AVIStreamOpenFromFileA(var ppavi: IAVISTREAM; szFile: LPCSTR; fccType: DWORD; lParam: LONG; mode: UINT; pclsidHandler: PCLSID): HResult; stdcall;
function AVIStreamOpenFromFileW(var ppavi: IAVISTREAM; szFile: LPCWSTR; fccType: DWORD; lParam: LONG; mode: UINT; pclsidHandler: PCLSID): HResult; stdcall;
function AVIStreamOpenFromFile(var ppavi: IAVISTREAM; szFile: LPCSTR; fccType: DWORD; lParam: LONG; mode: UINT; pclsidHandler: PCLSID): HResult; stdcall;
function AVIStreamCreate(var ppavi: IAVISTREAM; lParam1, lParam2: LONG; pclsidHandler: PCLSID): HResult; stdcall;
function AVIStreamFindKeyFrame(var pavi: IAVISTREAM; lPos: LONG; lFlags: LONG): DWORD; stdcall;
function AVIStreamClose(pavi: IAVISTREAM): ULONG; stdcall;
function AVIFileClose(pfile: IAVIFILE): ULONG; stdcall;
procedure AVIStreamInit; stdcall;
procedure AVIStreamExit; stdcall;
function AVIStreamSampleToSample(pavi1, pavi2: IAVISTREAM; l: LONG): LONG;
function AVIStreamNextSample(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamPrevSample(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamNearestSample(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamNextKeyFrame(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamPrevKeyFrame(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamNearestKeyFrame(pavi: IAVISTREAM; l: LONG): LONG;
function AVIStreamIsKeyFrame(pavi: IAVISTREAM; l: LONG): BOOL;
function AVIStreamPrevSampleTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamNextSampleTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamNearestSampleTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamNextKeyFrameTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamPrevKeyFrameTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamNearestKeyFrameTime(pavi: IAVISTREAM; t: LONG): LONG;
function AVIStreamStartTime(pavi: IAVISTREAM): LONG;
function AVIStreamLengthTime(pavi: IAVISTREAM): LONG;
function AVIStreamEnd(pavi: IAVISTREAM): LONG;
function AVIStreamEndTime(pavi: IAVISTREAM): LONG;
function AVIStreamSampleSize(pavi: IAVISTREAM; lPos: LONG; plSize: PLONG): LONG;
function AVIStreamFormatSize(pavi: IAVISTREAM; lPos: LONG; plSize: PLONG): HResult;
function AVIStreamDataSize(pavi: IAVISTREAM; fcc: DWORD; plSize: PLONG): HResult;
function AVIMakeCompressedStream( var ppsCompressed : IAVISTREAM; ppsSource : IAVISTREAM; lpOptions : PAVICOMPRESSOPTIONS; pclsidHandler : PCLSID ): HResult; stdcall;
function AVISaveVA( szFile : LPCSTR; pclsidHandler : PCLSID; lpfnCallback : TAVISAVECALLBACK; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): HResult; stdcall;
function AVISaveVW( szFile : LPCWSTR; pclsidHandler : PCLSID; lpfnCallback : TAVISAVECALLBACK; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): HResult; stdcall;
function AVISaveV( szFile : LPCSTR; pclsidHandler : PCLSID; lpfnCallback : TAVISAVECALLBACK; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): HResult; stdcall;
function AVISaveOptions( hwnd : HWND; uiFlags : UINT; nStreams : int; var ppavi : IAVISTREAM; var plpOptions : PAVICOMPRESSOPTIONS ): BOOL; stdcall;
function AVISaveOptionsFree(nStreams: int; var plpOptions: PAVICOMPRESSOPTIONS): HResult; stdcall;
function AVIBuildFilterW(lpszFilter: LPWSTR; cbFilter: LONG; fSaving: BOOL): HResult; stdcall;
function AVIBuildFilterA(lpszFilter: LPSTR; cbFilter: LONG; fSaving: BOOL): HResult; stdcall;
function AVIBuildFilter(lpszFilter: LPSTR; cbFilter: LONG; fSaving: BOOL): HResult; stdcall;
function AVIMakeFileFromStreams(var ppfile: IAVIFILE; nStreams: int; var papStreams: IAVISTREAM): HResult; stdcall;
function AVIMakeStreamFromClipboard(cfFormat: UINT; hGlobal: THANDLE; var ppstream: IAVISTREAM): HResult; stdcall;
function AVIPutFileOnClipboard(pf: IAVIFILE): HResult; stdcall;
function AVIGetFromClipboard(var lppf: IAVIFILE): HResult; stdcall;
function AVIClearClipboard: HResult; stdcall;
function CreateEditableStream(var ppsEditable: IAVISTREAM; psSource: IAVISTREAM): HResult; stdcall;
function EditStreamCut(pavi: IAVISTREAM; var plStart, plLength: LONG; var ppResult: IAVISTREAM): HResult; stdcall;
function EditStreamCopy(pavi: IAVISTREAM; var plStart, plLength: LONG; var ppResult: IAVISTREAM): HResult; stdcall;
function EditStreamPaste(pavi: IAVISTREAM; var plPos, plLength: LONG; pstream: IAVISTREAM; lStart, lEnd: LONG): HResult; stdcall;
function EditStreamClone(pavi: IAVISTREAM; var ppResult: IAVISTREAM): HResult; stdcall;
function EditStreamSetNameA(pavi: IAVISTREAM; lpszName: LPCSTR): HResult; stdcall;
function EditStreamSetNameW(pavi: IAVISTREAM; lpszName: LPCWSTR): HResult; stdcall;
function EditStreamSetInfoW(pavi: IAVISTREAM; lpInfo: PAVISTREAMINFOW; cbInfo: LONG): HResult; stdcall;
function EditStreamSetInfoA(pavi: IAVISTREAM; lpInfo: PAVISTREAMINFOA; cbInfo: LONG): HResult; stdcall;
function EditStreamSetInfo(pavi: IAVISTREAM; lpInfo: PAVISTREAMINFOA; cbInfo: LONG): HResult; stdcall;
function EditStreamSetName(pavi: IAVISTREAM; lpszName: LPCSTR): HResult; stdcall;
function MCIWndSM(hWnd: HWND; Msg: UINT; wParam: WPARAM; lParam: LPARAM): DWORD;
function MCIWndCreateA(hwndParent: HWND; hInstance: HINST; dwStyle: DWORd; szFile: LPCSTR): HWND; cdecl;
function MCIWndCreateW(hwndParent: HWND; hInstance: HINST; dwStyle: DWORd; szFile: LPCWSTR): HWND; cdecl;
function MCIWndCreate(hwndParent: HWND; hInstance: HINST; dwStyle: DWORd; szFile: LPCSTR): HWND; cdecl;
function MCIWndRegisterClass: BOOL; cdecl;
function MCIWndCanPlay(hwnd: HWND): BOOL;
function MCIWndCanRecord(hwnd: HWND): BOOL;
function MCIWndCanSave(hwnd: HWND): BOOL;
function MCIWndCanWindow(hwnd: HWND): BOOL;
function MCIWndCanEject(hwnd: HWND): BOOL;
function MCIWndCanConfig(hwnd: HWND): BOOL;
function MCIWndPaletteKick(hwnd: HWND): BOOL;
function MCIWndSave(hwnd: HWND; szFile: LPCSTR): DWORD;
function MCIWndSaveDialog(hwnd: HWND): DWORD;
function MCIWndNew(hwnd: HWND; lp: PVOID): DWORD;
function MCIWndRecord(hwnd: HWND): DWORD;
function MCIWndOpen(hwnd: HWND; sz: LPCSTR; f: BOOL): DWORD;
function MCIWndOpenDialog(hwnd: HWND): DWORD;
function MCIWndClose(hwnd: HWND): DWORD;
function MCIWndPlay(hwnd: HWND): DWORD;
function MCIWndStop(hwnd: HWND): DWORD;
function MCIWndPause(hwnd: HWND): DWORD;
function MCIWndResume(hwnd: HWND): DWORD;
function MCIWndSeek(hwnd: HWND; lPos: DWORD): DWORD;
function MCIWndEject(hwnd: HWND): DWORD;
function MCIWndHome(hwnd: HWND): DWORD;
function MCIWndEnd(hwnd: HWND): DWORD;
function MCIWndGetSource(hwnd: HWND; prc: PRECT): DWORD;
function MCIWndPutSource(hwnd: HWND; prc: PRECT): DWORD;
function MCIWndGetDest(hwnd: HWND; prc: PRECT): DWORD;
function MCIWndPutDest(hwnd: HWND; prc: PRECT): DWORD;
function MCIWndPlayReverse(hwnd: HWND): DWORD;
function MCIWndPlayFrom(hwnd: HWND; lPos: DWORD): DWORD;
function MCIWndPlayTo(hwnd: HWND; lPos: DWORD): DWORD;
function MCIWndPlayFromTo(hwnd: HWND; lStart, lEnd: DWORD): DWORD;
function MCIWndGetDeviceID(hwnd: HWND): UINT;
function MCIWndGetAlias(hwnd: HWND): UINT;
function MCIWndGetMode(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetPosition(hwnd: HWND): DWORD;
function MCIWndGetPositionString(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetStart(hwnd: HWND): DWORD;
function MCIWndGetLength(hwnd: HWND): DWORD;
function MCIWndGetEnd(hwnd: HWND): DWORD;
function MCIWndStep(hwnd: HWND; n: DWORD): DWORD;
procedure MCIWndDestroy(hwnd: HWND);
procedure MCIWndSetZoom(hwnd: HWND; iZoom: UINT);
function MCIWndGetZoom(hwnd: HWND): UINT;
function MCIWndSetVolume(hwnd: HWND; iVol: UINT): DWORD;
function MCIWndGetVolume(hwnd: HWND): DWORD;
function MCIWndSetSpeed(hwnd: HWND; iSpeed: UINT): DWORD;
function MCIWndGetSpeed(hwnd: HWND): DWORD;
function MCIWndSetTimeFormat(hwnd: HWND; lp: LPCSTR): DWORD;
function MCIWndGetTimeFormat(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
procedure MCIWndValidateMedia(hwnd: HWND);
procedure MCIWndSetRepeat(hwnd: HWND; f: BOOL);
function MCIWndGetRepeat(hwnd: HWND): BOOL;
function MCIWndUseFrames(hwnd: HWND): DWORD;
function MCIWndUseTime(hwnd: HWND): DWORD;
procedure MCIWndSetActiveTimer(hwnd: HWND; active: UINT);
procedure MCIWndSetInactiveTimer(hwnd: HWND; inactive: UINT);
procedure MCIWndSetTimers(hwnd: HWND; active, inactive: UINT);
function MCIWndGetActiveTimer(hwnd: HWND): UINT;
function MCIWndGetInactiveTimer(hwnd: HWND): UINT;
function MCIWndRealize(hwnd: HWND; fBkgnd: BOOL): DWORD;
function MCIWndSendString(hwnd: HWND; sz: LPCSTR): DWORD;
function MCIWndReturnString(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetError(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetPalette(hwnd: HWND): HPALETTE;
function MCIWndSetPalette(hwnd: HWND; hpal: HPALETTE): DWORD;
function MCIWndGetFileName(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetDevice(hwnd: HWND; lp: LPSTR; len: UINT): DWORD;
function MCIWndGetStyles(hwnd: HWND): UINT;
function MCIWndChangeStyles(hwnd: HWND; mask: UINT; value: DWORD): DWORD;
function MCIWndOpenInterface(hwnd: HWND; pUnk: PUnknown): DWORD;
function MCIWndSetOwner(hwnd: HWND; hwndP: HWND): DWORD;
function AVICapSM(hwnd: HWND; m: UINT; w: WPARAM; l: LPARAM): DWORD;
function capSetCallbackOnError(hwnd: HWND; fpProc: TCAPERRORCALLBACK): BOOL;
function capSetCallbackOnStatus(hwnd: HWND; fpProc: TCAPSTATUSCALLBACK): BOOL;
function capSetCallbackOnYield(hwnd: HWND; fpProc: TCAPYIELDCALLBACK): BOOL;
function capSetCallbackOnFrame(hwnd: HWND; fpProc: TCAPVIDEOCALLBACK): BOOL;
function capSetCallbackOnVideoStream(hwnd: HWND; fpProc: TCAPVIDEOCALLBACK): BOOL;
function capSetCallbackOnWaveStream(hwnd: HWND; fpProc: TCAPWAVECALLBACK): BOOL;
function capSetCallbackOnCapControl(hwnd: HWND; fpProc: TCAPCONTROLCALLBACK): BOOL;
function capSetUserData(hwnd: HWND; lUser: DWORD): BOOL;
function capGetUserData(hwnd: HWND): DWORD;
function capDriverConnect(hwnd: HWND; i: INT): BOOL;
function capDriverDisconnect(hwnd: HWND): BOOL;
function capDriverGetName(hwnd: HWND; szName: LPSTR; wSize: WORD): BOOL;
function capDriverGetVersion(hwnd: HWND; szVer: LPSTR; wSize: WORD): BOOL;
function capDriverGetCaps(hwnd: HWND; s: PCAPDRIVERCAPS; wSize: WORD): BOOL;
function capFileSetCaptureFile(hwnd: HWND; szName: LPCSTR): BOOL;
function capFileGetCaptureFile(hwnd: HWND; szName: LPSTR; wSize: WORD): BOOL;
function capFileAlloc(hwnd: HWND; dwSize: DWORD): BOOL;
function capFileSaveAs(hwnd: HWND; szName: LPCSTR): BOOL;
function capFileSetInfoChunk(hwnd: HWND; lpInfoChunk: PCAPINFOCHUNK): BOOL;
function capFileSaveDIB(hwnd: HWND; szName: LPCSTR): BOOL;
function capEditCopy(hwnd: HWND): BOOL;
function capSetAudioFormat(hwnd: HWND; s: PWAVEFORMATEX; wSize: WORD): BOOL;
function capGetAudioFormat(hwnd: HWND; s: PWAVEFORMATEX; wSize: WORD): DWORD;
function capGetAudioFormatSize(hwnd: HWND): DWORD;
function capDlgVideoFormat(hwnd: HWND): BOOL;
function capDlgVideoSource(hwnd: HWND): BOOL;
function capDlgVideoDisplay(hwnd: HWND): BOOL;
function capDlgVideoCompression(hwnd: HWND): BOOL;
function capGetVideoFormat(hwnd: HWND; s: PVOID; wSize: WORD): DWORD;
function capGetVideoFormatSize(hwnd: HWND): DWORD;
function capSetVideoFormat(hwnd: HWND; s: PVOID; wSize: WORD): BOOL;
function capPreview(hwnd: HWND; f: BOOL): BOOL;
function capPreviewRate(hwnd: HWND; wMS: WORD): BOOL;
function capOverlay(hwnd: HWND; f: BOOL): BOOL;
function capPreviewScale(hwnd: HWND; f: BOOL): BOOL;
function capGetStatus(hwnd: HWND; s: PCAPSTATUS; wSize: WORD): BOOL;
function capSetScrollPos(hwnd: HWND; lpP: PPOINT): BOOL;
function capGrabFrame(hwnd: HWND): BOOL;
function capGrabFrameNoStop(hwnd: HWND): BOOL;
function capCaptureSequence(hwnd: HWND): BOOL;
function capCaptureSequenceNoFile(hwnd: HWND): BOOL;
function capCaptureStop(hwnd: HWND): BOOL;
function capCaptureAbort(hwnd: HWND): BOOL;
function capCaptureSingleFrameOpen(hwnd: HWND): BOOL;
function capCaptureSingleFrameClose(hwnd: HWND): BOOL;
function capCaptureSingleFrame(hwnd: HWND): BOOL;
function capCaptureGetSetup(hwnd: HWND; s: PCAPTUREPARMS; wSize: WORD): BOOL;
function capCaptureSetSetup(hwnd: HWND; s: PCAPTUREPARMS; wSize: WORD): BOOL;
function capSetMCIDeviceName(hwnd: HWND; szName: LPCSTR): BOOL;
function capGetMCIDeviceName(hwnd: HWND; szName: LPSTR; wSize: WORD): BOOL;
function capPaletteOpen(hwnd: HWND; szName: LPCSTR): BOOL;
function capPaletteSave(hwnd: HWND; szName: LPCSTR): BOOL;
function capPalettePaste(hwnd: HWND): BOOL;
function capPaletteAuto(hwnd: HWND; iFrames, iColors: INT): BOOL;
function capPaletteManual(hwnd: HWND; fGrab: BOOL; iColors: INT): BOOL;
function capCreateCaptureWindowA( lpszWindowName : LPCSTR; dwStyle : DWORD; x, y : int; nWidth, nHeight : int; hwndParent : HWND; nID : int ): HWND; stdcall;
function capGetDriverDescriptionA( wDriverIndex : UINT; lpszName : LPSTR; cbName : int; lpszVer : LPSTR; cbVer : int ): BOOL; stdcall;
function capCreateCaptureWindowW( lpszWindowName : LPCWSTR; dwStyle : DWORD; x, y : int; nWidth, nHeight : int; hwndParent : HWND; nID : int ): HWND; stdcall;
function capGetDriverDescriptionW( wDriverIndex : UINT; lpszName : LPWSTR; cbName : int; lpszVer : LPWSTR; cbVer : int ): BOOL; stdcall;
function capCreateCaptureWindow( lpszWindowName : LPCSTR; dwStyle : DWORD; x, y : int; nWidth, nHeight : int; hwndParent : HWND; nID : int ): HWND; stdcall;
function capGetDriverDescription( wDriverIndex : UINT; lpszName : LPSTR; cbName : int; lpszVer : LPSTR; cbVer : int ): BOOL; stdcall;
function GetOpenFileNamePreviewA(lpofn: POPENFILENAMEA): BOOL; stdcall;
function GetSaveFileNamePreviewA(lpofn: POPENFILENAMEA): BOOL; stdcall;
function GetOpenFileNamePreviewW(lpofn: POPENFILENAMEW): BOOL; stdcall;
function GetSaveFileNamePreviewW(lpofn: POPENFILENAMEW): BOOL; stdcall;
function GetOpenFileNamePreview(lpofn: POPENFILENAMEA): BOOL; stdcall;
function GetSaveFileNamePreview(lpofn: POPENFILENAMEA): BOOL; stdcall;

Types

PVOID = pointer;
LONG = longint;
PLONG = ˆLONG;
int = integer;
HIC = THandle;
TWOCC = word;
PICOPEN = ˆTICOPEN;
PICINFO = ˆTICINFO;
PICCOMPRESS = ˆTICCOMPRESS;
TICCompressProc = function(lInputOutput: LPARAM; lFrame: DWORD; lpBits: PVOID; len: LONG): LONG; stdcall;
PICCOMPRESSFRAMES = ˆTICCOMPRESSFRAMES;
TICStatusProc = function(lParam: LPARAM; message: UINT; l: LONG): LONG; stdcall;
PICSETSTATUSPROC = ˆTICSETSTATUSPROC;
PICDECOMPRESS = ˆTICDECOMPRESS;
PICDECOMPRESSEX = ˆTICDECOMPRESSEX;
PICDRAWBEGIN = ˆTICDRAWBEGIN;
PICDRAW = ˆTICDRAW;
PICDRAWSUGGEST = ˆTICDRAWSUGGEST;
PICPALETTE = ˆTICPALETTE;
PCOMPVARS = ˆTCOMPVARS;
HDRAWDIB = THandle;
PDRAWDIBTIME = ˆTDRAWDIBTIME;
PMainAVIHeader = ˆTMainAVIHeader;
PAVIStreamHeader = ˆTAVIStreamHeader;
PAVIINDEXENTRY = ˆTAVIINDEXENTRY;
PAVIPALCHANGE = ˆTAVIPALCHANGE;
PAVIStreamInfoW = ˆTAVIStreamInfoW;
PAVIStreamInfoA = ˆTAVIStreamInfoA;
PAVIStreamInfo = ˆTAVIStreamInfo;
TAVIStreamInfo = TAVIStreamInfoA;
PAVIFileInfoW = ˆTAVIFileInfoW;
PAVIFileInfoA = ˆTAVIFileInfoA;
PAVIFileInfo = ˆTAVIFileInfo;
TAVIFileInfo = TAVIFileInfoA;
TAVISAVECALLBACK = function(i: int): BOOL; pascal;
PAVICOMPRESSOPTIONS = ˆTAVICOMPRESSOPTIONS;
PUnknown = ˆIUnknown;
HVIDEO = THandle;
PHVIDEO = ˆHVIDEO;
PVIDEOHDR = ˆTVIDEOHDR;
PCHANNEL_CAPS = ˆTCHANNEL_CAPS;
TCAPYIELDCALLBACK = function(hWnd: HWND): DWORD; stdcall;
TCAPSTATUSCALLBACKW = function(hWnd: HWND; nID: int; lpsz: LPCWSTR): DWORD; stdcall;
TCAPERRORCALLBACKW = function(hWnd: HWND; nID: int; lpsz: LPCWSTR): DWORD; stdcall;
TCAPSTATUSCALLBACKA = function(hWnd: HWND; nID: int; lpsz: LPCSTR): DWORD; stdcall;
TCAPERRORCALLBACKA = function(hWnd: HWND; nID: int; lpsz: LPCSTR): DWORD; stdcall;
TCAPSTATUSCALLBACK = TCAPSTATUSCALLBACKA;
TCAPERRORCALLBACK = TCAPERRORCALLBACKA;
TCAPVIDEOCALLBACK = function(hWnd: HWND; lpVHdr: PVIDEOHDR): DWORD; stdcall;
TCAPWAVECALLBACK = function(hWnd: HWND; lpWHdr: PWAVEHDR): DWORD; stdcall;
TCAPCONTROLCALLBACK = function(hWnd: HWND; nState: int): DWORD; stdcall;
PCAPDRIVERCAPS = ˆTCAPDRIVERCAPS;
PCAPSTATUS = ˆTCAPSTATUS;
PCAPTUREPARMS = ˆTCAPTUREPARMS;
PCAPINFOCHUNK = ˆTCAPINFOCHUNK;

Constants

ICVERSION = $0104 ;
BI_1632 = $32333631;
ICTYPE_VIDEO = $63646976;
ICTYPE_AUDIO = $63647561;
ICERR_OK = 0 ;
ICERR_DONTDRAW = 1 ;
ICERR_NEWPALETTE = 2 ;
ICERR_GOTOKEYFRAME = 3 ;
ICERR_STOPDRAWING = 4 ;
ICERR_UNSUPPORTED = -1 ;
ICERR_BADFORMAT = -2 ;
ICERR_MEMORY = -3 ;
ICERR_INTERNAL = -4 ;
ICERR_BADFLAGS = -5 ;
ICERR_BADPARAM = -6 ;
ICERR_BADSIZE = -7 ;
ICERR_BADHANDLE = -8 ;
ICERR_CANTUPDATE = -9 ;
ICERR_ABORT = -10 ;
ICERR_ERROR = -100 ;
ICERR_BADBITDEPTH = -200 ;
ICERR_BADIMAGESIZE = -201 ;
ICERR_CUSTOM = -400 ;
ICMODE_COMPRESS = 1 ;
ICMODE_DECOMPRESS = 2 ;
ICMODE_FASTDECOMPRESS = 3 ;
ICMODE_QUERY = 4 ;
ICMODE_FASTCOMPRESS = 5 ;
ICMODE_DRAW = 8 ;
AVIIF_LIST = $00000001 ;
AVIIF_TWOCC = $00000002 ;
AVIIF_KEYFRAME = $00000010 ;
ICQUALITY_LOW = 0 ;
ICQUALITY_HIGH = 10000 ;
ICQUALITY_DEFAULT = -1 ;
ICM_USER = (DRV_USER+$0000) ;
ICM_RESERVED_LOW = (DRV_USER+$1000) ;
ICM_RESERVED_HIGH = (DRV_USER+$2000) ;
ICM_RESERVED = ICM_RESERVED_LOW ;
ICM_GETSTATE = (ICM_RESERVED+0) ;
ICM_SETSTATE = (ICM_RESERVED+1) ;
ICM_GETINFO = (ICM_RESERVED+2) ;
ICM_CONFIGURE = (ICM_RESERVED+10);
ICM_ABOUT = (ICM_RESERVED+11);
ICM_GETDEFAULTQUALITY = (ICM_RESERVED+30);
ICM_GETQUALITY = (ICM_RESERVED+31);
ICM_SETQUALITY = (ICM_RESERVED+32);
ICM_SET = (ICM_RESERVED+40);
ICM_GET = (ICM_RESERVED+41);
ICM_FRAMERATE = $526D7246;
ICM_KEYFRAMERATE = $5279654B;
ICM_COMPRESS_GET_FORMAT = (ICM_USER+4) ;
ICM_COMPRESS_GET_SIZE = (ICM_USER+5) ;
ICM_COMPRESS_QUERY = (ICM_USER+6) ;
ICM_COMPRESS_BEGIN = (ICM_USER+7) ;
ICM_COMPRESS = (ICM_USER+8) ;
ICM_COMPRESS_END = (ICM_USER+9) ;
ICM_DECOMPRESS_GET_FORMAT = (ICM_USER+10) ;
ICM_DECOMPRESS_QUERY = (ICM_USER+11) ;
ICM_DECOMPRESS_BEGIN = (ICM_USER+12) ;
ICM_DECOMPRESS = (ICM_USER+13) ;
ICM_DECOMPRESS_END = (ICM_USER+14) ;
ICM_DECOMPRESS_SET_PALETTE = (ICM_USER+29) ;
ICM_DECOMPRESS_GET_PALETTE = (ICM_USER+30) ;
ICM_DRAW_QUERY = (ICM_USER+31) ;
ICM_DRAW_BEGIN = (ICM_USER+15) ;
ICM_DRAW_GET_PALETTE = (ICM_USER+16) ;
ICM_DRAW_START = (ICM_USER+18) ;
ICM_DRAW_STOP = (ICM_USER+19) ;
ICM_DRAW_END = (ICM_USER+21) ;
ICM_DRAW_GETTIME = (ICM_USER+32) ;
ICM_DRAW = (ICM_USER+33) ;
ICM_DRAW_WINDOW = (ICM_USER+34) ;
ICM_DRAW_SETTIME = (ICM_USER+35) ;
ICM_DRAW_REALIZE = (ICM_USER+36) ;
ICM_DRAW_FLUSH = (ICM_USER+37) ;
ICM_DRAW_RENDERBUFFER = (ICM_USER+38) ;
ICM_DRAW_START_PLAY = (ICM_USER+39) ;
ICM_DRAW_STOP_PLAY = (ICM_USER+40) ;
ICM_DRAW_SUGGESTFORMAT = (ICM_USER+50) ;
ICM_DRAW_CHANGEPALETTE = (ICM_USER+51) ;
ICM_GETBUFFERSWANTED = (ICM_USER+41) ;
ICM_GETDEFAULTKEYFRAMERATE = (ICM_USER+42) ;
ICM_DECOMPRESSEX_BEGIN = (ICM_USER+60) ;
ICM_DECOMPRESSEX_QUERY = (ICM_USER+61) ;
ICM_DECOMPRESSEX = (ICM_USER+62) ;
ICM_DECOMPRESSEX_END = (ICM_USER+63) ;
ICM_COMPRESS_FRAMES_INFO = (ICM_USER+70) ;
ICM_SET_STATUS_PROC = (ICM_USER+72) ;
VIDCF_QUALITY = $0001 ;
VIDCF_CRUNCH = $0002 ;
VIDCF_TEMPORAL = $0004 ;
VIDCF_COMPRESSFRAMES = $0008 ;
VIDCF_DRAW = $0010 ;
VIDCF_FASTTEMPORALC = $0020 ;
VIDCF_FASTTEMPORALD = $0080 ;
ICCOMPRESS_KEYFRAME = $00000001;
ICCOMPRESSFRAMES_PADDING = $00000001 ;
ICSTATUS_START = 0 ;
ICSTATUS_STATUS = 1 ;
ICSTATUS_END = 2 ;
ICSTATUS_ERROR = 3 ;
ICSTATUS_YIELD = 4 ;
ICDECOMPRESS_HURRYUP = $80000000 ;
ICDECOMPRESS_UPDATE = $40000000 ;
ICDECOMPRESS_PREROLL = $20000000 ;
ICDECOMPRESS_NULLFRAME = $10000000 ;
ICDECOMPRESS_NOTKEYFRAME = $08000000 ;
ICDRAW_QUERY = $00000001 ;
ICDRAW_FULLSCREEN = $00000002 ;
ICDRAW_HDC = $00000004 ;
ICDRAW_ANIMATE = $00000008 ;
ICDRAW_CONTINUE = $00000010 ;
ICDRAW_MEMORYDC = $00000020 ;
ICDRAW_UPDATING = $00000040 ;
ICDRAW_RENDER = $00000080 ;
ICDRAW_BUFFER = $00000100 ;
ICDRAW_HURRYUP = $80000000 ;
ICDRAW_UPDATE = $40000000 ;
ICDRAW_PREROLL = $20000000 ;
ICDRAW_NULLFRAME = $10000000 ;
ICDRAW_NOTKEYFRAME = $08000000 ;
ICINSTALL_UNICODE = $8000 ;
ICINSTALL_FUNCTION = $0001 ;
ICINSTALL_DRIVER = $0002 ;
ICINSTALL_HDRV = $0004 ;
ICINSTALL_DRIVERW = $8002 ;
ICMF_CONFIGURE_QUERY = $00000001 ;
ICMF_ABOUT_QUERY = $00000001 ;
ICMF_COMPVARS_VALID = $00000001;
ICMF_CHOOSE_KEYFRAME = $0001;
ICMF_CHOOSE_DATARATE = $0002;
ICMF_CHOOSE_PREVIEW = $0004;
ICMF_CHOOSE_ALLCOMPRESSORS = $0008;
DDF_UPDATE = $0002;
DDF_SAME_HDC = $0004;
DDF_SAME_DRAW = $0008;
DDF_DONTDRAW = $0010;
DDF_ANIMATE = $0020;
DDF_BUFFER = $0040;
DDF_JUSTDRAWIT = $0080;
DDF_FULLSCREEN = $0100;
DDF_BACKGROUNDPAL = $0200;
DDF_NOTKEYFRAME = $0400;
DDF_HURRYUP = $0800;
DDF_HALFTONE = $1000;
DDF_PREROLL = DDF_DONTDRAW;
DDF_SAME_DIB = DDF_SAME_DRAW;
DDF_SAME_SIZE = DDF_SAME_DRAW;
PD_CAN_DRAW_DIB = $0001;
PD_CAN_STRETCHDIB = $0002;
PD_STRETCHDIB_1_1_OK = $0004;
PD_STRETCHDIB_1_2_OK = $0008;
PD_STRETCHDIB_1_N_OK = $0010;
formtypeAVI = $20495641;
listtypeAVIHEADER = $6C726468;
ckidAVIMAINHDR = $68697661;
listtypeSTREAMHEADER = $6C727473;
ckidSTREAMHEADER = $68727473;
ckidSTREAMFORMAT = $66727473;
ckidSTREAMHANDLERDATA = $64727473;
ckidSTREAMNAME = $6E727473;
listtypeAVIMOVIE = $69766F6D;
listtypeAVIRECORD = $20636572;
ckidAVINEWINDEX = $31786469;
streamtypeVIDEO = $73646976;
streamtypeAUDIO = $73647561;
streamtypeMIDI = $7364696D;
streamtypeTEXT = $73747874;
cktypeDIBbits = $6264;
cktypeDIBcompressed = $6364;
cktypePALchange = $6370;
cktypeWAVEbytes = $6277;
ckidAVIPADDING = $4B4E554A;
AVIF_HASINDEX = $00000010;
AVIF_MUSTUSEINDEX = $00000020;
AVIF_ISINTERLEAVED = $00000100;
AVIF_TRUSTCKTYPE = $00000800;
AVIF_WASCAPTUREFILE = $00010000;
AVIF_COPYRIGHTED = $00020000;
AVI_HEADERSIZE = 2048;
AVISF_DISABLED = $00000001;
AVISF_VIDEO_PALCHANGES = $00010000;
AVIIF_NOTIME = $00000100;
AVIIF_COMPUSE = $0FFF0000;
AVIGETFRAMEF_BESTDISPLAYFMT = 1;
AVISTREAMINFO_DISABLED = $00000001;
AVISTREAMINFO_FORMATCHANGES = $00010000;
AVIFILEINFO_HASINDEX = $00000010;
AVIFILEINFO_MUSTUSEINDEX = $00000020;
AVIFILEINFO_ISINTERLEAVED = $00000100;
AVIFILEINFO_WASCAPTUREFILE = $00010000;
AVIFILEINFO_COPYRIGHTED = $00020000;
AVIFILECAPS_CANREAD = $00000001;
AVIFILECAPS_CANWRITE = $00000002;
AVIFILECAPS_ALLKEYFRAMES = $00000010;
AVIFILECAPS_NOCOMPRESSION = $00000020;
AVICOMPRESSF_INTERLEAVE = $00000001;
AVICOMPRESSF_DATARATE = $00000002;
AVICOMPRESSF_KEYFRAMES = $00000004;
AVICOMPRESSF_VALID = $00000008;
IID_IAVIFile : TGUID = (D1: $00020020; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
IID_IAVIStream : TGUID = (D1: $00020021; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
IID_IAVIStreaming : TGUID = (D1: $00020022; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
IID_IGetFrame : TGUID = (D1: $00020023; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
IID_IAVIEditStream: TGUID = (D1: $00020024; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
CLSID_AVISimpleUnMarshal : TGUID = (D1: $00020009; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
CLSID_AVIFile : TGUID = (D1: $00020000; D2: $0; D3: $0; D4:($C0,$0,$0,$0,$0,$0,$0,$46));
AVIFILEHANDLER_CANREAD = $0001;
AVIFILEHANDLER_CANWRITE = $0002;
AVIFILEHANDLER_CANACCEPTNONRGB = $0004;
AVISTREAMREAD_CONVENIENT = -1;
FIND_DIR = $0000000F;
FIND_NEXT = $00000001;
FIND_PREV = $00000004;
FIND_FROM_START = $00000008;
FIND_TYPE = $000000F0;
FIND_KEY = $00000010;
FIND_ANY = $00000020;
FIND_FORMAT = $00000040;
FIND_RET = $0000F000;
FIND_POS = $00000000;
FIND_LENGTH = $00001000;
FIND_OFFSET = $00002000;
FIND_SIZE = $00003000;
FIND_INDEX = $00004000;
SEARCH_NEAREST = FIND_PREV;
SEARCH_BACKWARD = FIND_PREV;
SEARCH_FORWARD = FIND_NEXT;
SEARCH_KEY = FIND_KEY;
SEARCH_ANY = FIND_ANY;
comptypeDIB = $20424944;
AVIERR_OK = 0;
AVIERR_UNSUPPORTED = $80044065;
AVIERR_BADFORMAT = $80044066;
AVIERR_MEMORY = $80044067;
AVIERR_INTERNAL = $80044068;
AVIERR_BADFLAGS = $80044069;
AVIERR_BADPARAM = $8004406A;
AVIERR_BADSIZE = $8004406B;
AVIERR_BADHANDLE = $8004406C;
AVIERR_FILEREAD = $8004406D;
AVIERR_FILEWRITE = $8004406E;
AVIERR_FILEOPEN = $8004406F;
AVIERR_COMPRESSOR = $80044070;
AVIERR_NOCOMPRESSOR = $80044071;
AVIERR_READONLY = $80044072;
AVIERR_NODATA = $80044073;
AVIERR_BUFFERTOOSMALL = $80044074;
AVIERR_CANTCOMPRESS = $80044075;
AVIERR_USERABORT = $800440C6;
AVIERR_ERROR = $800440C7;
MCIWND_WINDOW_CLASS = 'MCIWndClass' ;
MCIWNDOPENF_NEW = $0001;
MCIWNDF_NOAUTOSIZEWINDOW = $0001;
MCIWNDF_NOPLAYBAR = $0002;
MCIWNDF_NOAUTOSIZEMOVIE = $0004;
MCIWNDF_NOMENU = $0008;
MCIWNDF_SHOWNAME = $0010;
MCIWNDF_SHOWPOS = $0020;
MCIWNDF_SHOWMODE = $0040;
MCIWNDF_SHOWALL = $0070;
MCIWNDF_NOTIFYMODE = $0100;
MCIWNDF_NOTIFYPOS = $0200;
MCIWNDF_NOTIFYSIZE = $0400;
MCIWNDF_NOTIFYERROR = $1000;
MCIWNDF_NOTIFYALL = $1F00;
MCIWNDF_NOTIFYANSI = $0080;
MCIWNDF_NOTIFYMEDIAA = $0880;
MCIWNDF_NOTIFYMEDIAW = $0800;
MCIWNDF_NOTIFYMEDIA = MCIWNDF_NOTIFYMEDIAA;
MCIWNDF_RECORD = $2000;
MCIWNDF_NOERRORDLG = $4000;
MCIWNDF_NOOPEN = $8000;
MCIWNDM_GETDEVICEID = WM_USER + 100;
MCIWNDM_GETSTART = WM_USER + 103;
MCIWNDM_GETLENGTH = WM_USER + 104;
MCIWNDM_GETEND = WM_USER + 105;
MCIWNDM_EJECT = WM_USER + 107;
MCIWNDM_SETZOOM = WM_USER + 108;
MCIWNDM_GETZOOM = WM_USER + 109;
MCIWNDM_SETVOLUME = WM_USER + 110;
MCIWNDM_GETVOLUME = WM_USER + 111;
MCIWNDM_SETSPEED = WM_USER + 112;
MCIWNDM_GETSPEED = WM_USER + 113;
MCIWNDM_SETREPEAT = WM_USER + 114;
MCIWNDM_GETREPEAT = WM_USER + 115;
MCIWNDM_REALIZE = WM_USER + 118;
MCIWNDM_VALIDATEMEDIA = WM_USER + 121;
MCIWNDM_PLAYFROM = WM_USER + 122;
MCIWNDM_PLAYTO = WM_USER + 123;
MCIWNDM_GETPALETTE = WM_USER + 126;
MCIWNDM_SETPALETTE = WM_USER + 127;
MCIWNDM_SETTIMERS = WM_USER + 129;
MCIWNDM_SETACTIVETIMER = WM_USER + 130;
MCIWNDM_SETINACTIVETIMER = WM_USER + 131;
MCIWNDM_GETACTIVETIMER = WM_USER + 132;
MCIWNDM_GETINACTIVETIMER = WM_USER + 133;
MCIWNDM_CHANGESTYLES = WM_USER + 135;
MCIWNDM_GETSTYLES = WM_USER + 136;
MCIWNDM_GETALIAS = WM_USER + 137;
MCIWNDM_PLAYREVERSE = WM_USER + 139;
MCIWNDM_GET_SOURCE = WM_USER + 140;
MCIWNDM_PUT_SOURCE = WM_USER + 141;
MCIWNDM_GET_DEST = WM_USER + 142;
MCIWNDM_PUT_DEST = WM_USER + 143;
MCIWNDM_CAN_PLAY = WM_USER + 144;
MCIWNDM_CAN_WINDOW = WM_USER + 145;
MCIWNDM_CAN_RECORD = WM_USER + 146;
MCIWNDM_CAN_SAVE = WM_USER + 147;
MCIWNDM_CAN_EJECT = WM_USER + 148;
MCIWNDM_CAN_CONFIG = WM_USER + 149;
MCIWNDM_PALETTEKICK = WM_USER + 150;
MCIWNDM_OPENINTERFACE = WM_USER + 151;
MCIWNDM_SETOWNER = WM_USER + 152;
MCIWNDM_SENDSTRINGA = WM_USER + 101;
MCIWNDM_GETPOSITIONA = WM_USER + 102;
MCIWNDM_GETMODEA = WM_USER + 106;
MCIWNDM_SETTIMEFORMATA = WM_USER + 119;
MCIWNDM_GETTIMEFORMATA = WM_USER + 120;
MCIWNDM_GETFILENAMEA = WM_USER + 124;
MCIWNDM_GETDEVICEA = WM_USER + 125;
MCIWNDM_GETERRORA = WM_USER + 128;
MCIWNDM_NEWA = WM_USER + 134;
MCIWNDM_RETURNSTRINGA = WM_USER + 138;
MCIWNDM_OPENA = WM_USER + 153;
MCIWNDM_SENDSTRINGW = WM_USER + 201;
MCIWNDM_GETPOSITIONW = WM_USER + 202;
MCIWNDM_GETMODEW = WM_USER + 206;
MCIWNDM_SETTIMEFORMATW = WM_USER + 219;
MCIWNDM_GETTIMEFORMATW = WM_USER + 220;
MCIWNDM_GETFILENAMEW = WM_USER + 224;
MCIWNDM_GETDEVICEW = WM_USER + 225;
MCIWNDM_GETERRORW = WM_USER + 228;
MCIWNDM_NEWW = WM_USER + 234;
MCIWNDM_RETURNSTRINGW = WM_USER + 238;
MCIWNDM_OPENW = WM_USER + 252;
MCIWNDM_SENDSTRING = MCIWNDM_SENDSTRINGA;
MCIWNDM_GETPOSITION = MCIWNDM_GETPOSITIONA;
MCIWNDM_GETMODE = MCIWNDM_GETMODEA;
MCIWNDM_SETTIMEFORMAT = MCIWNDM_SETTIMEFORMATA;
MCIWNDM_GETTIMEFORMAT = MCIWNDM_GETTIMEFORMATA;
MCIWNDM_GETFILENAME = MCIWNDM_GETFILENAMEA;
MCIWNDM_GETDEVICE = MCIWNDM_GETDEVICEA;
MCIWNDM_GETERROR = MCIWNDM_GETERRORA;
MCIWNDM_NEW = MCIWNDM_NEWA;
MCIWNDM_RETURNSTRING = MCIWNDM_RETURNSTRINGA;
MCIWNDM_OPEN = MCIWNDM_OPENA;
MCIWNDM_NOTIFYMODE = WM_USER + 200;
MCIWNDM_NOTIFYPOS = WM_USER + 201;
MCIWNDM_NOTIFYSIZE = WM_USER + 202;
MCIWNDM_NOTIFYMEDIA = WM_USER + 203;
MCIWNDM_NOTIFYERROR = WM_USER + 205;
MCIWND_START = dword(-1) ;
MCIWND_END = dword(-2) ;
DV_ERR_OK = 0;
DV_ERR_BASE = 1;
DV_ERR_NONSPECIFIC = DV_ERR_BASE;
DV_ERR_BADFORMAT = DV_ERR_BASE + 1;
DV_ERR_STILLPLAYING = DV_ERR_BASE + 2;
DV_ERR_UNPREPARED = DV_ERR_BASE + 3;
DV_ERR_SYNC = DV_ERR_BASE + 4;
DV_ERR_TOOMANYCHANNELS = DV_ERR_BASE + 5;
DV_ERR_NOTDETECTED = DV_ERR_BASE + 6;
DV_ERR_BADINSTALL = DV_ERR_BASE + 7;
DV_ERR_CREATEPALETTE = DV_ERR_BASE + 8;
DV_ERR_SIZEFIELD = DV_ERR_BASE + 9;
DV_ERR_PARAM1 = DV_ERR_BASE + 10;
DV_ERR_PARAM2 = DV_ERR_BASE + 11;
DV_ERR_CONFIG1 = DV_ERR_BASE + 12;
DV_ERR_CONFIG2 = DV_ERR_BASE + 13;
DV_ERR_FLAGS = DV_ERR_BASE + 14;
DV_ERR_13 = DV_ERR_BASE + 15;
DV_ERR_NOTSUPPORTED = DV_ERR_BASE + 16;
DV_ERR_NOMEM = DV_ERR_BASE + 17;
DV_ERR_ALLOCATED = DV_ERR_BASE + 18;
DV_ERR_BADDEVICEID = DV_ERR_BASE + 19;
DV_ERR_INVALHANDLE = DV_ERR_BASE + 20;
DV_ERR_BADERRNUM = DV_ERR_BASE + 21;
DV_ERR_NO_BUFFERS = DV_ERR_BASE + 22;
DV_ERR_MEM_CONFLICT = DV_ERR_BASE + 23;
DV_ERR_IO_CONFLICT = DV_ERR_BASE + 24;
DV_ERR_DMA_CONFLICT = DV_ERR_BASE + 25;
DV_ERR_INT_CONFLICT = DV_ERR_BASE + 26;
DV_ERR_PROTECT_ONLY = DV_ERR_BASE + 27;
DV_ERR_LASTERROR = DV_ERR_BASE + 27;
DV_ERR_USER_MSG = DV_ERR_BASE + 1000;
DV_VM_OPEN = MM_DRVM_OPEN;
DV_VM_CLOSE = MM_DRVM_CLOSE;
DV_VM_DATA = MM_DRVM_DATA;
DV_VM_ERROR = MM_DRVM_ERROR;
VHDR_DONE = $00000001;
VHDR_PREPARED = $00000002;
VHDR_INQUEUE = $00000004;
VHDR_KEYFRAME = $00000008;
VCAPS_OVERLAY = $00000001;
VCAPS_SRC_CAN_CLIP = $00000002;
VCAPS_DST_CAN_CLIP = $00000004;
VCAPS_CAN_SCALE = $00000008;
VIDEO_EXTERNALIN = $0001;
VIDEO_EXTERNALOUT = $0002;
VIDEO_IN = $0004;
VIDEO_OUT = $0008;
VIDEO_DLG_QUERY = $0010;
VIDEO_CONFIGURE_QUERY = $8000;
VIDEO_CONFIGURE_SET = $1000;
VIDEO_CONFIGURE_GET = $2000;
VIDEO_CONFIGURE_QUERYSIZE = $0001;
VIDEO_CONFIGURE_CURRENT = $0010;
VIDEO_CONFIGURE_NOMINAL = $0020;
VIDEO_CONFIGURE_MIN = $0040;
VIDEO_CONFIGURE_MAX = $0080;
DVM_USER = $4000;
DVM_CONFIGURE_START = $1000;
DVM_CONFIGURE_END = $1FFF;
DVM_PALETTE = DVM_CONFIGURE_START + 1;
DVM_FORMAT = DVM_CONFIGURE_START + 2;
DVM_PALETTERGB555 = DVM_CONFIGURE_START + 3;
DVM_SRC_RECT = DVM_CONFIGURE_START + 4;
DVM_DST_RECT = DVM_CONFIGURE_START + 5;
WM_CAP_START = WM_USER;
WM_CAP_UNICODE_START = WM_USER + 100;
WM_CAP_GET_CAPSTREAMPTR = WM_CAP_START + 1;
WM_CAP_SET_CALLBACK_ERRORW = WM_CAP_UNICODE_START + 2;
WM_CAP_SET_CALLBACK_STATUSW = WM_CAP_UNICODE_START + 3;
WM_CAP_SET_CALLBACK_ERRORA = WM_CAP_START + 2;
WM_CAP_SET_CALLBACK_STATUSA = WM_CAP_START + 3;
WM_CAP_SET_CALLBACK_ERROR = WM_CAP_SET_CALLBACK_ERRORA;
WM_CAP_SET_CALLBACK_STATUS = WM_CAP_SET_CALLBACK_STATUSA;
WM_CAP_SET_CALLBACK_YIELD = WM_CAP_START + 4;
WM_CAP_SET_CALLBACK_FRAME = WM_CAP_START + 5;
WM_CAP_SET_CALLBACK_VIDEOSTREAM = WM_CAP_START + 6;
WM_CAP_SET_CALLBACK_WAVESTREAM = WM_CAP_START + 7;
WM_CAP_GET_USER_DATA = WM_CAP_START + 8;
WM_CAP_SET_USER_DATA = WM_CAP_START + 9;
WM_CAP_DRIVER_CONNECT = WM_CAP_START + 10;
WM_CAP_DRIVER_DISCONNECT = WM_CAP_START + 11;
WM_CAP_DRIVER_GET_NAMEA = WM_CAP_START + 12;
WM_CAP_DRIVER_GET_VERSIONA = WM_CAP_START + 13;
WM_CAP_DRIVER_GET_NAMEW = WM_CAP_UNICODE_START + 12;
WM_CAP_DRIVER_GET_VERSIONW = WM_CAP_UNICODE_START + 13;
WM_CAP_DRIVER_GET_NAME = WM_CAP_DRIVER_GET_NAMEA;
WM_CAP_DRIVER_GET_VERSION = WM_CAP_DRIVER_GET_VERSIONA;
WM_CAP_DRIVER_GET_CAPS = WM_CAP_START + 14;
WM_CAP_FILE_SET_CAPTURE_FILEA = WM_CAP_START + 20;
WM_CAP_FILE_GET_CAPTURE_FILEA = WM_CAP_START + 21;
WM_CAP_FILE_SAVEASA = WM_CAP_START + 23;
WM_CAP_FILE_SAVEDIBA = WM_CAP_START + 25;
WM_CAP_FILE_SET_CAPTURE_FILEW = WM_CAP_UNICODE_START + 20;
WM_CAP_FILE_GET_CAPTURE_FILEW = WM_CAP_UNICODE_START + 21;
WM_CAP_FILE_SAVEASW = WM_CAP_UNICODE_START + 23;
WM_CAP_FILE_SAVEDIBW = WM_CAP_UNICODE_START + 25;
WM_CAP_FILE_SET_CAPTURE_FILE = WM_CAP_FILE_SET_CAPTURE_FILEA;
WM_CAP_FILE_GET_CAPTURE_FILE = WM_CAP_FILE_GET_CAPTURE_FILEA;
WM_CAP_FILE_SAVEAS = WM_CAP_FILE_SAVEASA;
WM_CAP_FILE_SAVEDIB = WM_CAP_FILE_SAVEDIBA;
WM_CAP_FILE_ALLOCATE = WM_CAP_START + 22;
WM_CAP_FILE_SET_INFOCHUNK = WM_CAP_START + 24;
WM_CAP_EDIT_COPY = WM_CAP_START + 30;
WM_CAP_SET_AUDIOFORMAT = WM_CAP_START + 35;
WM_CAP_GET_AUDIOFORMAT = WM_CAP_START + 36;
WM_CAP_DLG_VIDEOFORMAT = WM_CAP_START + 41;
WM_CAP_DLG_VIDEOSOURCE = WM_CAP_START + 42;
WM_CAP_DLG_VIDEODISPLAY = WM_CAP_START + 43;
WM_CAP_GET_VIDEOFORMAT = WM_CAP_START + 44;
WM_CAP_SET_VIDEOFORMAT = WM_CAP_START + 45;
WM_CAP_DLG_VIDEOCOMPRESSION = WM_CAP_START + 46;
WM_CAP_SET_PREVIEW = WM_CAP_START + 50;
WM_CAP_SET_OVERLAY = WM_CAP_START + 51;
WM_CAP_SET_PREVIEWRATE = WM_CAP_START + 52;
WM_CAP_SET_SCALE = WM_CAP_START + 53;
WM_CAP_GET_STATUS = WM_CAP_START + 54;
WM_CAP_SET_SCROLL = WM_CAP_START + 55;
WM_CAP_GRAB_FRAME = WM_CAP_START + 60;
WM_CAP_GRAB_FRAME_NOSTOP = WM_CAP_START + 61;
WM_CAP_SEQUENCE = WM_CAP_START + 62;
WM_CAP_SEQUENCE_NOFILE = WM_CAP_START + 63;
WM_CAP_SET_SEQUENCE_SETUP = WM_CAP_START + 64;
WM_CAP_GET_SEQUENCE_SETUP = WM_CAP_START + 65;
WM_CAP_SET_MCI_DEVICEA = WM_CAP_START + 66;
WM_CAP_GET_MCI_DEVICEA = WM_CAP_START + 67;
WM_CAP_SET_MCI_DEVICEW = WM_CAP_UNICODE_START + 66;
WM_CAP_GET_MCI_DEVICEW = WM_CAP_UNICODE_START + 67;
WM_CAP_SET_MCI_DEVICE = WM_CAP_SET_MCI_DEVICEA;
WM_CAP_GET_MCI_DEVICE = WM_CAP_GET_MCI_DEVICEA;
WM_CAP_STOP = WM_CAP_START + 68;
WM_CAP_ABORT = WM_CAP_START + 69;
WM_CAP_SINGLE_FRAME_OPEN = WM_CAP_START + 70;
WM_CAP_SINGLE_FRAME_CLOSE = WM_CAP_START + 71;
WM_CAP_SINGLE_FRAME = WM_CAP_START + 72;
WM_CAP_PAL_OPENA = WM_CAP_START + 80;
WM_CAP_PAL_SAVEA = WM_CAP_START + 81;
WM_CAP_PAL_OPENW = WM_CAP_UNICODE_START + 80;
WM_CAP_PAL_SAVEW = WM_CAP_UNICODE_START + 81;
WM_CAP_PAL_OPEN = WM_CAP_PAL_OPENA;
WM_CAP_PAL_SAVE = WM_CAP_PAL_SAVEA;
WM_CAP_PAL_PASTE = WM_CAP_START + 82;
WM_CAP_PAL_AUTOCREATE = WM_CAP_START + 83;
WM_CAP_PAL_MANUALCREATE = WM_CAP_START + 84;
WM_CAP_SET_CALLBACK_CAPCONTROL = WM_CAP_START + 85;
WM_CAP_UNICODE_END = WM_CAP_PAL_SAVEW;
WM_CAP_END = WM_CAP_UNICODE_END;
AVSTREAMMASTER_AUDIO = 0;
AVSTREAMMASTER_NONE = 1;
CONTROLCALLBACK_PREROLL = 1;
CONTROLCALLBACK_CAPTURING = 2;
infotypeDIGITIZATION_TIME = $54494449;
infotypeSMPTE_TIME = $504D5349;
IDS_CAP_BEGIN = 300;
IDS_CAP_END = 301;
IDS_CAP_INFO = 401;
IDS_CAP_OUTOFMEM = 402;
IDS_CAP_FILEEXISTS = 403;
IDS_CAP_ERRORPALOPEN = 404;
IDS_CAP_ERRORPALSAVE = 405;
IDS_CAP_ERRORDIBSAVE = 406;
IDS_CAP_DEFAVIEXT = 407;
IDS_CAP_DEFPALEXT = 408;
IDS_CAP_CANTOPEN = 409;
IDS_CAP_SEQ_MSGSTART = 410;
IDS_CAP_SEQ_MSGSTOP = 411;
IDS_CAP_VIDEDITERR = 412;
IDS_CAP_READONLYFILE = 413;
IDS_CAP_WRITEERROR = 414;
IDS_CAP_NODISKSPACE = 415;
IDS_CAP_SETFILESIZE = 416;
IDS_CAP_SAVEASPERCENT = 417;
IDS_CAP_DRIVER_ERROR = 418;
IDS_CAP_WAVE_OPEN_ERROR = 419;
IDS_CAP_WAVE_ALLOC_ERROR = 420;
IDS_CAP_WAVE_PREPARE_ERROR = 421;
IDS_CAP_WAVE_ADD_ERROR = 422;
IDS_CAP_WAVE_SIZE_ERROR = 423;
IDS_CAP_VIDEO_OPEN_ERROR = 424;
IDS_CAP_VIDEO_ALLOC_ERROR = 425;
IDS_CAP_VIDEO_PREPARE_ERROR = 426;
IDS_CAP_VIDEO_ADD_ERROR = 427;
IDS_CAP_VIDEO_SIZE_ERROR = 428;
IDS_CAP_FILE_OPEN_ERROR = 429;
IDS_CAP_FILE_WRITE_ERROR = 430;
IDS_CAP_RECORDING_ERROR = 431;
IDS_CAP_RECORDING_ERROR2 = 432;
IDS_CAP_AVI_INIT_ERROR = 433;
IDS_CAP_NO_FRAME_CAP_ERROR = 434;
IDS_CAP_NO_PALETTE_WARN = 435;
IDS_CAP_MCI_CONTROL_ERROR = 436;
IDS_CAP_MCI_CANT_STEP_ERROR = 437;
IDS_CAP_NO_AUDIO_CAP_ERROR = 438;
IDS_CAP_AVI_DRAWDIB_ERROR = 439;
IDS_CAP_COMPRESSOR_ERROR = 440;
IDS_CAP_AUDIO_DROP_ERROR = 441;
IDS_CAP_STAT_LIVE_MODE = 500;
IDS_CAP_STAT_OVERLAY_MODE = 501;
IDS_CAP_STAT_CAP_INIT = 502;
IDS_CAP_STAT_CAP_FINI = 503;
IDS_CAP_STAT_PALETTE_BUILD = 504;
IDS_CAP_STAT_OPTPAL_BUILD = 505;
IDS_CAP_STAT_I_FRAMES = 506;
IDS_CAP_STAT_L_FRAMES = 507;
IDS_CAP_STAT_CAP_L_FRAMES = 508;
IDS_CAP_STAT_CAP_AUDIO = 509;
IDS_CAP_STAT_VIDEOCURRENT = 510;
IDS_CAP_STAT_VIDEOAUDIO = 511;
IDS_CAP_STAT_VIDEOONLY = 512;
IDS_CAP_STAT_FRAMESDROPPED = 513;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TICOPEN

packed record TICOPEN

Unit

GLSVfw

Declaration

type TICOPEN = packed record

Description

Overview

Fields

dwSize: DWORD ;
fccType: DWORD ;
fccHandler: DWORD ;
dwVersion: DWORD ;
dwFlags: DWORD ;
dwError: DWORD ;
pV1Reserved: PVOID ;
pV2Reserved: PVOID ;
dnDevNode: DWORD ;

Description

Fields

dwSize: DWORD ;
fccType: DWORD ;
fccHandler: DWORD ;
dwVersion: DWORD ;
dwFlags: DWORD ;
dwError: DWORD ;
pV1Reserved: PVOID ;
pV2Reserved: PVOID ;
dnDevNode: DWORD ;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TICINFO

packed record TICINFO

Unit

GLSVfw

Declaration

type TICINFO = packed record

Description

Overview

Fields

dwSize: DWORD;
fccType: DWORD;
fccHandler: DWORD;
dwFlags: DWORD;
dwVersion: DWORD;
dwVersionICM: DWORD;
szName: array[0..15] of WChar ;
szDescription: array[0..127] of WChar ;
szDriver: array[0..127] of WChar ;

Description

Fields

dwSize: DWORD;
fccType: DWORD;
fccHandler: DWORD;
dwFlags: DWORD;
dwVersion: DWORD;
dwVersionICM: DWORD;
szName: array[0..15] of WChar ;
szDescription: array[0..127] of WChar ;
szDriver: array[0..127] of WChar ;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TICCOMPRESS

packed record TICCOMPRESS

Unit

GLSVfw

Declaration

type TICCOMPRESS = packed record

Description

Overview

Fields

dwFlags: DWORD;
lpbiOutput: PBITMAPINFOHEADER ;
lpOutput: PVOID ;
lpbiInput: PBITMAPINFOHEADER ;
lpInput: PVOID ;
lpckid: PDWORD ;
lpdwFlags: PDWORD;
lFrameNum: LONG ;
dwFrameSize: DWORD ;
dwQuality: DWORD ;
lpbiPrev: PBITMAPINFOHEADER ;
lpPrev: PVOID ;

Description

Fields

dwFlags: DWORD;
lpbiOutput: PBITMAPINFOHEADER ;
lpOutput: PVOID ;
lpbiInput: PBITMAPINFOHEADER ;
lpInput: PVOID ;
lpckid: PDWORD ;
lpdwFlags: PDWORD;
lFrameNum: LONG ;
dwFrameSize: DWORD ;
dwQuality: DWORD ;
lpbiPrev: PBITMAPINFOHEADER ;
lpPrev: PVOID ;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TICCOMPRESSFRAMES

packed record TICCOMPRESSFRAMES

Unit

GLSVfw

Declaration

type TICCOMPRESSFRAMES = packed record

Description

Overview

Fields

dwFlags: DWORD ;
lpbiOutput: PBITMAPINFOHEADER ;
lOutput: LPARAM ;
lpbiInput: PBITMAPINFOHEADER ;
lInput: LPARAM ;
lStartFrame: LONG ;
lFrameCount: LONG ;
lQuality: LONG ;
lDataRate: LONG ;
lKeyRate: LONG ;
dwRate: DWORD ;
dwScale: DWORD ;
dwOverheadPerFrame: DWORD ;
dwReserved2: DWORD ;
GetData: TICCompressProc;
PutData: TICCompressProc;

Description

Fields

dwFlags: DWORD ;
lpbiOutput: PBITMAPINFOHEADER ;
lOutput: LPARAM ;
lpbiInput: PBITMAPINFOHEADER ;
lInput: LPARAM ;
lStartFrame: LONG ;
lFrameCount: LONG ;
lQuality: LONG ;
lDataRate: LONG ;
lKeyRate: LONG ;
dwRate: DWORD ;
dwScale: DWORD ;
dwOverheadPerFrame: DWORD ;
dwReserved2: DWORD ;
GetData: TICCompressProc;
PutData: TICCompressProc;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TICSETSTATUSPROC

packed record TICSETSTATUSPROC

Unit

GLSVfw

Declaration

type TICSETSTATUSPROC = packed record

Description

Overview

Fields

dwFlags: DWORD ;
lParam: LPARAM ;
Status: TICStatusProc;

Description

Fields

dwFlags: DWORD ;
lParam: LPARAM ;
Status: TICStatusProc;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TICDECOMPRESS

packed record TICDECOMPRESS

Unit

GLSVfw

Declaration

type TICDECOMPRESS = packed record

Description

Overview

Fields

dwFlags: DWORD ;
lpbiInput: PBITMAPINFOHEADER ;
lpInput: PVOID ;
lpbiOutput: PBITMAPINFOHEADER ;
lpOutput: PVOID ;
ckid: DWORD ;

Description

Fields

dwFlags: DWORD ;
lpbiInput: PBITMAPINFOHEADER ;
lpInput: PVOID ;
lpbiOutput: PBITMAPINFOHEADER ;
lpOutput: PVOID ;
ckid: DWORD ;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TICDECOMPRESSEX

packed record TICDECOMPRESSEX

Unit

GLSVfw

Declaration

type TICDECOMPRESSEX = packed record

Description

Overview

Fields

dwFlags: DWORD;
lpbiSrc: PBITMAPINFOHEADER;
lpSrc: PVOID;
lpbiDst: PBITMAPINFOHEADER;
lpDst: PVOID;
xDst: int;
yDst: int;
dxDst: int;
dyDst: int;
xSrc: int;
ySrc: int;
dxSrc: int;
dySrc: int;

Description

Fields

dwFlags: DWORD;
lpbiSrc: PBITMAPINFOHEADER;
lpSrc: PVOID;
lpbiDst: PBITMAPINFOHEADER;
lpDst: PVOID;
xDst: int;
yDst: int;
dxDst: int;
dyDst: int;
xSrc: int;
ySrc: int;
dxSrc: int;
dySrc: int;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TICDRAWBEGIN

packed record TICDRAWBEGIN

Unit

GLSVfw

Declaration

type TICDRAWBEGIN = packed record

Description

Overview

Fields

dwFlags: DWORD ;
hpal: HPALETTE ;
hwnd: HWND ;
hdc: HDC ;
xDst: int ;
yDst: int ;
dxDst: int ;
dyDst: int ;
lpbi: PBITMAPINFOHEADER ;
xSrc: int ;
ySrc: int ;
dxSrc: int ;
dySrc: int ;
dwRate: DWORD ;
dwScale: DWORD ;

Description

Fields

dwFlags: DWORD ;
hpal: HPALETTE ;
hwnd: HWND ;
hdc: HDC ;
xDst: int ;
yDst: int ;
dxDst: int ;
dyDst: int ;
lpbi: PBITMAPINFOHEADER ;
xSrc: int ;
ySrc: int ;
dxSrc: int ;
dySrc: int ;
dwRate: DWORD ;
dwScale: DWORD ;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TICDRAW

packed record TICDRAW

Unit

GLSVfw

Declaration

type TICDRAW = packed record

Description

Overview

Fields

dwFlags: DWORD ;
lpFormat: PVOID ;
lpData: PVOID ;
cbData: DWORD ;
lTime: LONG ;

Description

Fields

dwFlags: DWORD ;
lpFormat: PVOID ;
lpData: PVOID ;
cbData: DWORD ;
lTime: LONG ;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TICDRAWSUGGEST

packed record TICDRAWSUGGEST

Unit

GLSVfw

Declaration

type TICDRAWSUGGEST = packed record

Description

Overview

Fields

lpbiIn: PBITMAPINFOHEADER ;
lpbiSuggest: PBITMAPINFOHEADER ;
dxSrc: int ;
dySrc: int ;
dxDst: int ;
dyDst: int ;
hicDecompressor: HIC ;

Description

Fields

lpbiIn: PBITMAPINFOHEADER ;
lpbiSuggest: PBITMAPINFOHEADER ;
dxSrc: int ;
dySrc: int ;
dxDst: int ;
dyDst: int ;
hicDecompressor: HIC ;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TICPALETTE

packed record TICPALETTE

Unit

GLSVfw

Declaration

type TICPALETTE = packed record

Description

Overview

Fields

dwFlags: DWORD ;
iStart: int ;
iLen: int ;
lppe: PPALETTEENTRY ;

Description

Fields

dwFlags: DWORD ;
iStart: int ;
iLen: int ;
lppe: PPALETTEENTRY ;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TCOMPVARS

packed record TCOMPVARS

Unit

GLSVfw

Declaration

type TCOMPVARS = packed record

Description

Overview

Fields

cbSize: DWORD;
dwFlags: DWORD;
hic: HIC;
fccType: DWORD;
fccHandler: DWORD;
lpbiIn: PBITMAPINFO;
lpbiOut: PBITMAPINFO;
lpBitsOut: PVOID;
lpBitsPrev: PVOID;
lFrame: LONG;
lKey: LONG;
lDataRate: LONG;
lQ: LONG;
lKeyCount: LONG;
lpState: PVOID;
cbState: LONG;

Description

Fields

cbSize: DWORD;
dwFlags: DWORD;
hic: HIC;
fccType: DWORD;
fccHandler: DWORD;
lpbiIn: PBITMAPINFO;
lpbiOut: PBITMAPINFO;
lpBitsOut: PVOID;
lpBitsPrev: PVOID;
lFrame: LONG;
lKey: LONG;
lDataRate: LONG;
lQ: LONG;
lKeyCount: LONG;
lpState: PVOID;
cbState: LONG;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TDRAWDIBTIME

packed record TDRAWDIBTIME

Unit

GLSVfw

Declaration

type TDRAWDIBTIME = packed record

Description

Overview

Fields

timeCount: LONG;
timeDraw: LONG;
timeDecompress: LONG;
timeDither: LONG;
timeStretch: LONG;
timeBlt: LONG;
timeSetDIBits: LONG;

Description

Fields

timeCount: LONG;
timeDraw: LONG;
timeDecompress: LONG;
timeDither: LONG;
timeStretch: LONG;
timeBlt: LONG;
timeSetDIBits: LONG;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TMainAVIHeader

packed record TMainAVIHeader

Unit

GLSVfw

Declaration

type TMainAVIHeader = packed record

Description

Overview

Fields

dwMicroSecPerFrame: DWORD;
dwMaxBytesPerSec: DWORD;
dwPaddingGranularity: DWORD;
dwFlags: DWORD;
dwTotalFrames: DWORD;
dwInitialFrames: DWORD;
dwStreams: DWORD;
dwSuggestedBufferSize: DWORD;
dwWidth: DWORD;
dwHeight: DWORD;
dwReserved: array[0..3] of DWORD;

Description

Fields

dwMicroSecPerFrame: DWORD;
dwMaxBytesPerSec: DWORD;
dwPaddingGranularity: DWORD;
dwFlags: DWORD;
dwTotalFrames: DWORD;
dwInitialFrames: DWORD;
dwStreams: DWORD;
dwSuggestedBufferSize: DWORD;
dwWidth: DWORD;
dwHeight: DWORD;
dwReserved: array[0..3] of DWORD;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TAVIStreamHeader

packed record TAVIStreamHeader

Unit

GLSVfw

Declaration

type TAVIStreamHeader = packed record

Description

Overview

Fields

fccType: FOURCC;
fccHandler: FOURCC;
dwFlags: DWORD;
wPriority: WORD;
wLanguage: WORD;
dwInitialFrames: DWORD;
dwScale: DWORD;
dwRate: DWORD;
dwStart: DWORD;
dwLength: DWORD;
dwSuggestedBufferSize: DWORD;
dwQuality: DWORD;
dwSampleSize: DWORD;
rcFrame: TRECT;

Description

Fields

fccType: FOURCC;
fccHandler: FOURCC;
dwFlags: DWORD;
wPriority: WORD;
wLanguage: WORD;
dwInitialFrames: DWORD;
dwScale: DWORD;
dwRate: DWORD;
dwStart: DWORD;
dwLength: DWORD;
dwSuggestedBufferSize: DWORD;
dwQuality: DWORD;
dwSampleSize: DWORD;
rcFrame: TRECT;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TAVIINDEXENTRY

packed record TAVIINDEXENTRY

Unit

GLSVfw

Declaration

type TAVIINDEXENTRY = packed record

Description

Overview

Fields

ckid: DWORD;
dwFlags: DWORD;
dwChunkOffset: DWORD;
dwChunkLength: DWORD;

Description

Fields

ckid: DWORD;
dwFlags: DWORD;
dwChunkOffset: DWORD;
dwChunkLength: DWORD;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TAVIPALCHANGE

packed record TAVIPALCHANGE

Unit

GLSVfw

Declaration

type TAVIPALCHANGE = packed record

Description

Overview

Fields

bFirstEntry: BYTE;
bNumEntries: BYTE;
wFlags: WORD;
peNew: array[0..0] of TPALETTEENTRY;

Description

Fields

bFirstEntry: BYTE;
bNumEntries: BYTE;
wFlags: WORD;
peNew: array[0..0] of TPALETTEENTRY;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TAVIStreamInfoW

packed record TAVIStreamInfoW

Unit

GLSVfw

Declaration

type TAVIStreamInfoW = packed record

Description

Overview

Fields

fccType: DWORD;
fccHandler: DWORD;
dwFlags: DWORD;
dwCaps: DWORD;
wPriority: WORD;
wLanguage: WORD;
dwScale: DWORD;
dwRate: DWORD;
dwStart: DWORD;
dwLength: DWORD;
dwInitialFrames: DWORD;
dwSuggestedBufferSize: DWORD;
dwQuality: DWORD;
dwSampleSize: DWORD;
rcFrame: TRECT;
dwEditCount: DWORD;
dwFormatChangeCount: DWORD;
szName: array[0..63] of WideChar;

Description

Fields

fccType: DWORD;
fccHandler: DWORD;
dwFlags: DWORD;
dwCaps: DWORD;
wPriority: WORD;
wLanguage: WORD;
dwScale: DWORD;
dwRate: DWORD;
dwStart: DWORD;
dwLength: DWORD;
dwInitialFrames: DWORD;
dwSuggestedBufferSize: DWORD;
dwQuality: DWORD;
dwSampleSize: DWORD;
rcFrame: TRECT;
dwEditCount: DWORD;
dwFormatChangeCount: DWORD;
szName: array[0..63] of WideChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TAVIStreamInfoA

packed record TAVIStreamInfoA

Unit

GLSVfw

Declaration

type TAVIStreamInfoA = packed record

Description

Overview

Fields

fccType: DWORD;
fccHandler: DWORD;
dwFlags: DWORD;
dwCaps: DWORD;
wPriority: WORD;
wLanguage: WORD;
dwScale: DWORD;
dwRate: DWORD;
dwStart: DWORD;
dwLength: DWORD;
dwInitialFrames: DWORD;
dwSuggestedBufferSize: DWORD;
dwQuality: DWORD;
dwSampleSize: DWORD;
rcFrame: TRECT;
dwEditCount: DWORD;
dwFormatChangeCount: DWORD;
szName: array[0..63] of AnsiChar;

Description

Fields

fccType: DWORD;
fccHandler: DWORD;
dwFlags: DWORD;
dwCaps: DWORD;
wPriority: WORD;
wLanguage: WORD;
dwScale: DWORD;
dwRate: DWORD;
dwStart: DWORD;
dwLength: DWORD;
dwInitialFrames: DWORD;
dwSuggestedBufferSize: DWORD;
dwQuality: DWORD;
dwSampleSize: DWORD;
rcFrame: TRECT;
dwEditCount: DWORD;
dwFormatChangeCount: DWORD;
szName: array[0..63] of AnsiChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TAVIFileInfoW

packed record TAVIFileInfoW

Unit

GLSVfw

Declaration

type TAVIFileInfoW = packed record

Description

Overview

Fields

dwMaxBytesPerSec: DWORD;
dwFlags: DWORD;
dwCaps: DWORD;
dwStreams: DWORD;
dwSuggestedBufferSize: DWORD;
dwWidth: DWORD;
dwHeight: DWORD;
dwScale: DWORD;
dwRate: DWORD;
dwLength: DWORD;
dwEditCount: DWORD;
szFileType: array[0..63] of WideChar;

Description

Fields

dwMaxBytesPerSec: DWORD;
dwFlags: DWORD;
dwCaps: DWORD;
dwStreams: DWORD;
dwSuggestedBufferSize: DWORD;
dwWidth: DWORD;
dwHeight: DWORD;
dwScale: DWORD;
dwRate: DWORD;
dwLength: DWORD;
dwEditCount: DWORD;
szFileType: array[0..63] of WideChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TAVIFileInfoA

packed record TAVIFileInfoA

Unit

GLSVfw

Declaration

type TAVIFileInfoA = packed record

Description

Overview

Fields

dwMaxBytesPerSec: DWORD;
dwFlags: DWORD;
dwCaps: DWORD;
dwStreams: DWORD;
dwSuggestedBufferSize: DWORD;
dwWidth: DWORD;
dwHeight: DWORD;
dwScale: DWORD;
dwRate: DWORD;
dwLength: DWORD;
dwEditCount: DWORD;
szFileType: array[0..63] of AnsiChar;

Description

Fields

dwMaxBytesPerSec: DWORD;
dwFlags: DWORD;
dwCaps: DWORD;
dwStreams: DWORD;
dwSuggestedBufferSize: DWORD;
dwWidth: DWORD;
dwHeight: DWORD;
dwScale: DWORD;
dwRate: DWORD;
dwLength: DWORD;
dwEditCount: DWORD;
szFileType: array[0..63] of AnsiChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: packed record TAVICOMPRESSOPTIONS

packed record TAVICOMPRESSOPTIONS

Unit

GLSVfw

Declaration

type TAVICOMPRESSOPTIONS = packed record

Description

Overview

Fields

fccType: DWORD;
fccHandler: DWORD;
dwKeyFrameEvery: DWORD;
dwQuality: DWORD;
dwBytesPerSecond: DWORD;
dwFlags: DWORD;
lpFormat: PVOID;
cbFormat: DWORD;
lpParms: PVOID;
cbParms: DWORD;
dwInterleaveEvery: DWORD;

Description

Fields

fccType: DWORD;
fccHandler: DWORD;
dwKeyFrameEvery: DWORD;
dwQuality: DWORD;
dwBytesPerSecond: DWORD;
dwFlags: DWORD;
lpFormat: PVOID;
cbFormat: DWORD;
lpParms: PVOID;
cbParms: DWORD;
dwInterleaveEvery: DWORD;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: Interface IAVIStream

Interface IAVIStream

Unit

GLSVfw

Declaration

type IAVIStream = interface(IUnknown)

Description

Hierarchy

  • IUnknown
  • IAVIStream

Overview

Methods

Public | function Create(lParam1, lParam2: LPARAM): HResult; stdcall;
Public | function Delete(lStart: LONG; lSamples: LONG): HResult; stdcall;
Public | function FindSample(lPos: LONG; lFlags: LONG): LONG; stdcall;
Public | function Info(var psi: TAVIStreamInfoW; lSize: LONG): HResult; stdcall;
Public | function Read(lStart: LONG; lSamples: LONG; lpBuffer: PVOID; cbBuffer: LONG; var plBytes, plSamples: LONG): HResult; stdcall;
Public | function ReadData(fcc: DWORD; lp: PVOID; var lpcb: LONG): HResult; stdcall;
Public | function ReadFormat(lPos: LONG; lpFormat: PVOID; var lpcbFormat: LONG): HResult; stdcall;
Public | function SetFormat(lPos: LONG; lpFormat: PVOID; cbFormat: LONG): HResult; stdcall;
Public | function SetInfo(var lpInfo: TAVIStreamInfoW; cbInfo: LONG): HResult; stdcall;
Public | function Write(lStart: LONG; lSamples: LONG; lpBuffer: PVOID; cbBuffer: LONG; dwFlags: DWORD; var plSampWritten, plBytesWritten: LONG): HResult; stdcall;
Public | function WriteData(fcc: DWORD; lp: PVOID; cb: LONG): HResult; stdcall;

Description

Methods

Public function Create(lParam1, lParam2: LPARAM): HResult; stdcall;
Public function Delete(lStart: LONG; lSamples: LONG): HResult; stdcall;
Public function FindSample(lPos: LONG; lFlags: LONG): LONG; stdcall;
Public function Info(var psi: TAVIStreamInfoW; lSize: LONG): HResult; stdcall;
Public function Read(lStart: LONG; lSamples: LONG; lpBuffer: PVOID; cbBuffer: LONG; var plBytes, plSamples: LONG): HResult; stdcall;
Public function ReadData(fcc: DWORD; lp: PVOID; var lpcb: LONG): HResult; stdcall;
Public function ReadFormat(lPos: LONG; lpFormat: PVOID; var lpcbFormat: LONG): HResult; stdcall;
Public function SetFormat(lPos: LONG; lpFormat: PVOID; cbFormat: LONG): HResult; stdcall;
Public function SetInfo(var lpInfo: TAVIStreamInfoW; cbInfo: LONG): HResult; stdcall;
Public function Write(lStart: LONG; lSamples: LONG; lpBuffer: PVOID; cbBuffer: LONG; dwFlags: DWORD; var plSampWritten, plBytesWritten: LONG): HResult; stdcall;
Public function WriteData(fcc: DWORD; lp: PVOID; cb: LONG): HResult; stdcall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: Interface IAVIStreaming

Interface IAVIStreaming

Unit

GLSVfw

Declaration

type IAVIStreaming = interface(IUnknown)

Description

Hierarchy

  • IUnknown
  • IAVIStreaming

Overview

Methods

Public | function _Begin(lStart, lEnd : LONG; lRate : LONG): HResult; stdcall;
Public | function _End: HResult; stdcall;

Description

Methods

Public function _Begin(lStart, lEnd : LONG; lRate : LONG): HResult; stdcall;
Public function _End: HResult; stdcall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: Interface IAVIEditStream

Interface IAVIEditStream

Unit

GLSVfw

Declaration

type IAVIEditStream = interface(IUnknown)

Description

Hierarchy

  • IUnknown
  • IAVIEditStream

Overview

Methods

Public | function Clone(var ppResult: IAVIStream): HResult; stdcall;
Public | function Copy(var plStart, plLength: LONG; var ppResult: IAVIStream): HResult; stdcall;
Public | function Cut(var plStart, plLength: LONG; var ppResult: IAVIStream): HResult; stdcall;
Public | function Paste(var plPos: LONG; var plLength: LONG; pstream: IAVIStream; lStart, lEnd: LONG): HResult; stdcall;
Public | function SetInfo(var lpInfo: TAVIStreamInfoW; cbInfo: LONG): HResult; stdcall;

Description

Methods

Public function Clone(var ppResult: IAVIStream): HResult; stdcall;
Public function Copy(var plStart, plLength: LONG; var ppResult: IAVIStream): HResult; stdcall;
Public function Cut(var plStart, plLength: LONG; var ppResult: IAVIStream): HResult; stdcall;
Public function Paste(var plPos: LONG; var plLength: LONG; pstream: IAVIStream; lStart, lEnd: LONG): HResult; stdcall;
Public function SetInfo(var lpInfo: TAVIStreamInfoW; cbInfo: LONG): HResult; stdcall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: Interface IAVIFile

Interface IAVIFile

Unit

GLSVfw

Declaration

type IAVIFile = interface(IUnknown)

Description

Hierarchy

  • IUnknown
  • IAVIFile

Overview

Methods

Public | function CreateStream(var ppStream: IAVISTREAM; var psi: TAVIStreamInfoW): HResult; stdcall;
Public | function DeleteStream(fccType: DWORD; lParam: LONG): HResult; stdcall;
Public | function EndRecord: HResult; stdcall;
Public | function GetStream(var ppStream: IAVISTREAM; fccType: DWORD; lParam: LONG): HResult; stdcall;
Public | function Info(var pfi: TAVIFileInfoW; iSize: LONG): HResult; stdcall;
Public | function ReadData(ckid: DWORD; lpData: PVOID; lpcbData: PLONG): HResult; stdcall;
Public | function WriteData(ckid: DWORD; lpData: PVOID; cbData: LONG): HResult; stdcall;

Description

Methods

Public function CreateStream(var ppStream: IAVISTREAM; var psi: TAVIStreamInfoW): HResult; stdcall;
Public function DeleteStream(fccType: DWORD; lParam: LONG): HResult; stdcall;
Public function EndRecord: HResult; stdcall;
Public function GetStream(var ppStream: IAVISTREAM; fccType: DWORD; lParam: LONG): HResult; stdcall;
Public function Info(var pfi: TAVIFileInfoW; iSize: LONG): HResult; stdcall;
Public function ReadData(ckid: DWORD; lpData: PVOID; lpcbData: PLONG): HResult; stdcall;
Public function WriteData(ckid: DWORD; lpData: PVOID; cbData: LONG): HResult; stdcall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: Interface IGetFrame

Interface IGetFrame

Unit

GLSVfw

Declaration

type IGetFrame = interface(IUnknown)

Description

Hierarchy

  • IUnknown
  • IGetFrame

Overview

Methods

Public | function BeginExtraction(lStart, lEnd, lRate: LONG): HResult; stdcall;
Public | function EndExtraction: HResult; stdcall;
Public | function GetFrame(lPos: LONG): PBitmapInfoHeader; stdcall;
Public | function SetFormat(var lpbi: TBitmapInfoHeader; lpBits: Pointer; x, y, dx, dy: Integer): HResult; stdcall;

Description

Methods

Public function BeginExtraction(lStart, lEnd, lRate: LONG): HResult; stdcall;
Public function EndExtraction: HResult; stdcall;
Public function GetFrame(lPos: LONG): PBitmapInfoHeader; stdcall;
Public function SetFormat(var lpbi: TBitmapInfoHeader; lpBits: Pointer; x, y, dx, dy: Integer): HResult; stdcall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: record TVIDEOHDR

record TVIDEOHDR

Unit

GLSVfw

Declaration

type TVIDEOHDR = record

Description

Overview

Fields

lpData: PBYTE;
dwBufferLength: DWORD;
dwBytesUsed: DWORD;
dwTimeCaptured: DWORD;
dwUser: DWORD;
dwFlags: DWORD;
dwReserved: array[0..3] of DWORD;

Description

Fields

lpData: PBYTE;
dwBufferLength: DWORD;
dwBytesUsed: DWORD;
dwTimeCaptured: DWORD;
dwUser: DWORD;
dwFlags: DWORD;
dwReserved: array[0..3] of DWORD;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: record TCHANNEL_CAPS

record TCHANNEL_CAPS

Unit

GLSVfw

Declaration

type TCHANNEL_CAPS = record

Description

Overview

Fields

dwFlags: DWORD;
dwSrcRectXMod: DWORD;
dwSrcRectYMod: DWORD;
dwSrcRectWidthMod: DWORD;
dwSrcRectHeightMod: DWORD;
dwDstRectXMod: DWORD;
dwDstRectYMod: DWORD;
dwDstRectWidthMod: DWORD;
dwDstRectHeightMod: DWORD;

Description

Fields

dwFlags: DWORD;
dwSrcRectXMod: DWORD;
dwSrcRectYMod: DWORD;
dwSrcRectWidthMod: DWORD;
dwSrcRectHeightMod: DWORD;
dwDstRectXMod: DWORD;
dwDstRectYMod: DWORD;
dwDstRectWidthMod: DWORD;
dwDstRectHeightMod: DWORD;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: record TCAPDRIVERCAPS

record TCAPDRIVERCAPS

Unit

GLSVfw

Declaration

type TCAPDRIVERCAPS = record

Description

Overview

Fields

wDeviceIndex: UINT;
fHasOverlay: BOOL;
fHasDlgVideoSource: BOOL;
fHasDlgVideoFormat: BOOL;
fHasDlgVideoDisplay: BOOL;
fCaptureInitialized: BOOL;
fDriverSuppliesPalettes: BOOL;
hVideoIn: THANDLE;
hVideoOut: THANDLE;
hVideoExtIn: THANDLE;
hVideoExtOut: THANDLE;

Description

Fields

wDeviceIndex: UINT;
fHasOverlay: BOOL;
fHasDlgVideoSource: BOOL;
fHasDlgVideoFormat: BOOL;
fHasDlgVideoDisplay: BOOL;
fCaptureInitialized: BOOL;
fDriverSuppliesPalettes: BOOL;
hVideoIn: THANDLE;
hVideoOut: THANDLE;
hVideoExtIn: THANDLE;
hVideoExtOut: THANDLE;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: record TCAPSTATUS

record TCAPSTATUS

Unit

GLSVfw

Declaration

type TCAPSTATUS = record

Description

Overview

Fields

uiImageWidth: UINT ;
uiImageHeight: UINT ;
fLiveWindow: BOOL ;
fOverlayWindow: BOOL ;
fScale: BOOL ;
ptScroll: TPOINT ;
fUsingDefaultPalette: BOOL ;
fAudioHardware: BOOL ;
fCapFileExists: BOOL ;
dwCurrentVideoFrame: DWORD ;
dwCurrentVideoFramesDropped: DWORD ;
dwCurrentWaveSamples: DWORD ;
dwCurrentTimeElapsedMS: DWORD ;
hPalCurrent: HPALETTE;
fCapturingNow: BOOL ;
dwReturn: DWORD ;
wNumVideoAllocated: UINT ;
wNumAudioAllocated: UINT ;

Description

Fields

uiImageWidth: UINT ;
uiImageHeight: UINT ;
fLiveWindow: BOOL ;
fOverlayWindow: BOOL ;
fScale: BOOL ;
ptScroll: TPOINT ;
fUsingDefaultPalette: BOOL ;
fAudioHardware: BOOL ;
fCapFileExists: BOOL ;
dwCurrentVideoFrame: DWORD ;
dwCurrentVideoFramesDropped: DWORD ;
dwCurrentWaveSamples: DWORD ;
dwCurrentTimeElapsedMS: DWORD ;
hPalCurrent: HPALETTE;
fCapturingNow: BOOL ;
dwReturn: DWORD ;
wNumVideoAllocated: UINT ;
wNumAudioAllocated: UINT ;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: record TCAPTUREPARMS

record TCAPTUREPARMS

Unit

GLSVfw

Declaration

type TCAPTUREPARMS = record

Description

Overview

Fields

dwRequestMicroSecPerFrame: DWORD ;
fMakeUserHitOKToCapture: BOOL ;
wPercentDropForError: UINT ;
fYield: BOOL ;
dwIndexSize: DWORD ;
wChunkGranularity: UINT ;
fUsingDOSMemory: BOOL ;
wNumVideoRequested: UINT ;
fCaptureAudio: BOOL ;
wNumAudioRequested: UINT ;
vKeyAbort: UINT ;
fAbortLeftMouse: BOOL ;
fAbortRightMouse: BOOL ;
fLimitEnabled: BOOL ;
wTimeLimit: UINT ;
fMCIControl: BOOL ;
fStepMCIDevice: BOOL ;
dwMCIStartTime: DWORD ;
dwMCIStopTime: DWORD ;
fStepCaptureAt2x: BOOL ;
wStepCaptureAverageFrames: UINT ;
dwAudioBufferSize: DWORD ;
fDisableWriteCache: BOOL ;
AVStreamMaster: UINT ;

Description

Fields

dwRequestMicroSecPerFrame: DWORD ;
fMakeUserHitOKToCapture: BOOL ;
wPercentDropForError: UINT ;
fYield: BOOL ;
dwIndexSize: DWORD ;
wChunkGranularity: UINT ;
fUsingDOSMemory: BOOL ;
wNumVideoRequested: UINT ;
fCaptureAudio: BOOL ;
wNumAudioRequested: UINT ;
vKeyAbort: UINT ;
fAbortLeftMouse: BOOL ;
fAbortRightMouse: BOOL ;
fLimitEnabled: BOOL ;
wTimeLimit: UINT ;
fMCIControl: BOOL ;
fStepMCIDevice: BOOL ;
dwMCIStartTime: DWORD ;
dwMCIStopTime: DWORD ;
fStepCaptureAt2x: BOOL ;
wStepCaptureAverageFrames: UINT ;
dwAudioBufferSize: DWORD ;
fDisableWriteCache: BOOL ;
AVStreamMaster: UINT ;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSVfw: record TCAPINFOCHUNK

record TCAPINFOCHUNK

Unit

GLSVfw

Declaration

type TCAPINFOCHUNK = record

Description

Overview

Fields

fccInfoID: FOURCC;
lpData: PVOID;
cbData: DWORD;

Description

Fields

fccInfoID: FOURCC;
lpData: PVOID;
cbData: DWORD;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:58


GLScene v.1.1.2: GLSZLibEx

Unit GLSZLibEx

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

ZLibEx<p>

<b>Historique : </b><font size=-1><ul> <li>07/05/10 - Yar - Fixed for Linux x64 <li>06/05/10 - Yar - Added to GLScene (contributed by oleg matrozov) </ul></font>

{***************************************************************************** * * * copyright (c) 2000-2010 base2 technologies * * copyright (c) 1995-2002 Borland Software Corporation * * * * revision history * * 2010.05.02 added ZDelfateEx and ZInflateEx * * 2010.04.20 added TZ*Buffer classes * * 2010.04.15 moved core zlib routines to separate unit (ZLibExApi.pas) * * added ZDeflate* and ZInflate* * * 2010.04.14 fixed ZInternalCompress loops * * fixed ZInternalDecompress loops * * updated ZInternalCompressStream loops * * updated ZInternalDecompressStream loops * * 2010.01.27 updated for delphi 2010 * * 2009.04.14 added overloaded string routines for AnsiString and * * UnicodeString * * 2009.01.28 updated for delphi 2009 String (UnicodeString) * * 2008.05.15 added TStreamPos type for Stream.Position variants * * added TCustomZStream.Stream* methods * * 2007.08.17 modified TZCompressionStream.Write to use Write instead of * * WriteBuffer * * 2007.03.15 moved gzip routines to separate unit (ZLibExGZ.pas) * * 2006.10.07 fixed EZLibError constructor for c++ builder compatibility * * 2006.03.28 moved Z_DEFLATED to interface section * * added custom compression levels zcLevel1 thru zcLevel9 * * 2006.03.27 added ZCompressStreamWeb * * 2006.03.24 added ZAdler32 and ZCrc32 * * 2005.11.29 changed FStreamPos to Int64 for delphi 6+ * * 2005.03.04 modified ZInternalCompressStream loops * * modified ZInternalDecompressStream loops * * 2005.02.07 fixed ZInternalCompressStream loop conditions * * fixed ZInternalDecompressStream loop conditions * * 2005.01.11 added ZCompressStrWeb * * 2003.04.14 added ZCompress2 and ZDecompress2 * * added ZCompressStr2 and ZDecompressStr2 * * added ZCompressStream2 and ZDecompressStream2 * * added overloaded T*Stream constructors to support * * InflateInit2 and DeflateInit2 * * fixed ZDecompressStream to use ZDecompressCheck instead of * * ZCompressCheck * * 2001.11.27 enhanced TZDecompressionStream.Read to adjust source * * stream position upon end of compression data * * fixed endless loop in TZDecompressionStream.Read when * * destination count was greater than uncompressed data * * 2001.10.26 renamed unit to integrate "nicely" with delphi 6 * * 2000.11.24 added soFromEnd condition to TZDecompressionStream.Seek * * added ZCompressStream and ZDecompressStream * * 2000.06.13 optimized, fixed, rewrote, and enhanced the zlib.pas unit * * included on the delphi cd (zlib version 1.1.3) * * * * acknowledgments * * erik turner * * 2001.10.26 Z*Stream routines * * * * david bennion * * 2001.11.27 finding the nasty little endless loop quirk with the * * TZDecompressionStream.Read method * * * * luigi sandon * * 2005.02.07 pointing out the missing loop condition (Z_STREAM_END) * * in ZInternalCompressStream and * * ZInternalDecompressStream * * * * ferry van genderen * * 2005.03.04 assisting me fine tune and beta test * * ZInternalCompressStream and ZInternalDecompressStream * * * * j. rathlev * * 2005.11.28 pointing out the FStreamPos and TStream.Position type * * inconsistency * * * * anders johansen * * 2006.10.07 pointing out the ELibError constructor incompatibility * * with c++ builder * * * * marcin szafranski * * 2009.01.28 beta testing the delphi 2009 changes * * * * iztok kacin * * 2009.04.14 assisting me design and further improve support for * * delphi 2009 * * * * oleg matrozov * * 2010.04.14 pointing out the missing loop condition (avail_in > 0) * * in ZInternalCompress and ZInternalDecompress * * 2010.04.20 prototyping and assisting with the TZ*Buffer classes * *****************************************************************************

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TZInformation |
Class TCustomZStream |
Class TZCompressionStream |
Class TZDecompressionStream |
Class TZCustomBuffer |
Class TZCompressionBuffer |
Class TZDecompressionBuffer |
Class EZLibError |
Class EZCompressionError |
Class EZDecompressionError |

Functions and Procedures

function ZDeflateInit(var stream: TZStreamRec; level: TZCompressionLevel): Integer; inline;
function ZDeflateInit2(var stream: TZStreamRec; level: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy): Integer; inline;
function ZDeflate(var stream: TZStreamRec; flush: TZFlush): Integer; inline;
function ZDeflateEnd(var stream: TZStreamRec): Integer; inline;
function ZDeflateReset(var stream: TZStreamRec): Integer; inline;
function ZInflateInit(var stream: TZStreamRec): Integer; inline;
function ZInflateInit2(var stream: TZStreamRec; windowBits: Integer): Integer; inline;
function ZInflate(var stream: TZStreamRec; flush: TZFlush): Integer; inline;
function ZInflateEnd(var stream: TZStreamRec): Integer; inline;
function ZInflateReset(var stream: TZStreamRec): Integer; inline;
function ZAdler32(adler: Longint; const buffer; size: Integer): Longint; inline;
function ZCrc32(crc: Longint; const buffer; size: Integer): Longint; inline;
procedure ZDeflateEx(var stream: TZStreamRec; param: Pointer; read: TZReadFunction; write: TZWriteFunction; flush: TZFlush);
procedure ZInflateEx(var stream: TZStreamRec; param: Pointer; read: TZReadFunction; write: TZWriteFunction; flush: TZFlush);
procedure ZCompress(const inBuffer: Pointer; inSize: Integer; out outBuffer: Pointer; out outSize: Integer; level: TZCompressionLevel = zcDefault);
procedure ZCompress2(const inBuffer: Pointer; inSize: Integer; out outBuffer: Pointer; out outSize: Integer; level: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy);
procedure ZDecompress(const inBuffer: Pointer; inSize: Integer; out outBuffer: Pointer; out outSize: Integer; outEstimate: Integer = 0);
procedure ZDecompress2(const inBuffer: Pointer; inSize: Integer; out outBuffer: Pointer; out outSize: Integer; windowBits: Integer; outEstimate: Integer = 0);
function ZCompressStr(const s: AnsiString; level: TZCompressionLevel = zcDefault): RawByteString;
procedure ZCompressString(var result: RawByteString; const s: AnsiString; level: TZCompressionLevel = zcDefault); overload;
procedure ZCompressString(var result: RawByteString; const s: UnicodeString; level: TZCompressionLevel = zcDefault); overload;
function ZCompressStrEx(const s: AnsiString; level: TZCompressionLevel = zcDefault): RawByteString;
procedure ZCompressStringEx(var result: RawByteString; const s: AnsiString; level: TZCompressionLevel = zcDefault); overload;
procedure ZCompressStringEx(var result: RawByteString; const s: UnicodeString; level: TZCompressionLevel = zcDefault); overload;
function ZCompressStr2(const s: AnsiString; level: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy): RawByteString;
procedure ZCompressString2(var result: RawByteString; const s: AnsiString; level: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy); overload;
procedure ZCompressString2(var result: RawByteString; const s: UnicodeString; level: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy); overload;
function ZCompressStrWeb(const s: AnsiString): RawByteString;
procedure ZCompressStringWeb(var result: RawByteString; const s: AnsiString); overload;
procedure ZCompressStringWeb(var result: RawByteString; const s: UnicodeString); overload;
function ZDecompressStr(const s: RawByteString): AnsiString;
procedure ZDecompressString(var result: AnsiString; const s: RawByteString); overload;
procedure ZDecompressString(var result: UnicodeString; const s: RawByteString); overload;
function ZDecompressStrEx(const s: RawByteString): AnsiString;
procedure ZDecompressStringEx(var result: AnsiString; const s: RawByteString); overload;
procedure ZDecompressStringEx(var result: UnicodeString; const s: RawByteString); overload;
function ZDecompressStr2(const s: RawByteString; windowBits: Integer): AnsiString;
procedure ZDecompressString2(var result: AnsiString; const s: RawByteString; windowBits: Integer); overload;
procedure ZDecompressString2(var result: UnicodeString; const s: RawByteString; windowBits: Integer); overload;
procedure ZCompressStream(inStream, outStream: TStream; level: TZCompressionLevel = zcDefault);
procedure ZCompressStream2(inStream, outStream: TStream; level: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy);
procedure ZCompressStreamWeb(inStream, outStream: TStream);
procedure ZDecompressStream(inStream, outStream: TStream);
procedure ZDecompressStream2(inStream, outStream: TStream; windowBits: Integer);

Types

RawByteString = AnsiString;
UnicodeString = WideString;
UnicodeChar = WideChar;
TStreamPos = Longint ;
TZCompressionLevel = (...);
TZStrategy = (...);
TZError = (...);
TZFlush = (...);
TZReadFunction = function (param: Pointer; var buffer; size: Integer): Integer;
TZWriteFunction = function (param: Pointer; const buffer; size: Integer): Integer;
EZLibErrorClass = class of EZlibError;

Constants

ZLevels: Array [TZCompressionLevel] of Integer = ( Z_NO_COMPRESSION, Z_BEST_SPEED, Z_DEFAULT_COMPRESSION, Z_BEST_COMPRESSION, 1, 2, 3, 4, 5, 6, 7, 8, 9 );
ZStrategies: Array [TZStrategy] of Integer = ( Z_DEFAULT_STRATEGY, Z_FILTERED, Z_HUFFMAN_ONLY, Z_RLE, Z_FIXED );
ZErrors: Array [TZError] of Integer = ( Z_ERRNO, Z_STREAM_ERROR, Z_DATA_ERROR, Z_MEM_ERROR, Z_BUF_ERROR, Z_VERSION_ERROR );
ZFlushes: Array [TZFlush] of Integer = ( Z_NO_FLUSH, Z_PARTIAL_FLUSH, Z_SYNC_FLUSH, Z_FULL_FLUSH, Z_FINISH, Z_BLOCK, Z_TREES );

Description

Functions and Procedures

function ZDeflateInit(var stream: TZStreamRec; level: TZCompressionLevel): Integer; inline;
function ZDeflateInit2(var stream: TZStreamRec; level: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy): Integer; inline;
function ZDeflate(var stream: TZStreamRec; flush: TZFlush): Integer; inline;
function ZDeflateEnd(var stream: TZStreamRec): Integer; inline;
function ZDeflateReset(var stream: TZStreamRec): Integer; inline;
function ZInflateInit(var stream: TZStreamRec): Integer; inline;
function ZInflateInit2(var stream: TZStreamRec; windowBits: Integer): Integer; inline;
function ZInflate(var stream: TZStreamRec; flush: TZFlush): Integer; inline;
function ZInflateEnd(var stream: TZStreamRec): Integer; inline;
function ZInflateReset(var stream: TZStreamRec): Integer; inline;
function ZAdler32(adler: Longint; const buffer; size: Integer): Longint; inline;
function ZCrc32(crc: Longint; const buffer; size: Integer): Longint; inline;
procedure ZDeflateEx(var stream: TZStreamRec; param: Pointer; read: TZReadFunction; write: TZWriteFunction; flush: TZFlush);
procedure ZInflateEx(var stream: TZStreamRec; param: Pointer; read: TZReadFunction; write: TZWriteFunction; flush: TZFlush);
procedure ZCompress(const inBuffer: Pointer; inSize: Integer; out outBuffer: Pointer; out outSize: Integer; level: TZCompressionLevel = zcDefault);
procedure ZCompress2(const inBuffer: Pointer; inSize: Integer; out outBuffer: Pointer; out outSize: Integer; level: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy);
procedure ZDecompress(const inBuffer: Pointer; inSize: Integer; out outBuffer: Pointer; out outSize: Integer; outEstimate: Integer = 0);
procedure ZDecompress2(const inBuffer: Pointer; inSize: Integer; out outBuffer: Pointer; out outSize: Integer; windowBits: Integer; outEstimate: Integer = 0);
function ZCompressStr(const s: AnsiString; level: TZCompressionLevel = zcDefault): RawByteString;
procedure ZCompressString(var result: RawByteString; const s: AnsiString; level: TZCompressionLevel = zcDefault); overload;
procedure ZCompressString(var result: RawByteString; const s: UnicodeString; level: TZCompressionLevel = zcDefault); overload;
function ZCompressStrEx(const s: AnsiString; level: TZCompressionLevel = zcDefault): RawByteString;
procedure ZCompressStringEx(var result: RawByteString; const s: AnsiString; level: TZCompressionLevel = zcDefault); overload;
procedure ZCompressStringEx(var result: RawByteString; const s: UnicodeString; level: TZCompressionLevel = zcDefault); overload;
function ZCompressStr2(const s: AnsiString; level: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy): RawByteString;
procedure ZCompressString2(var result: RawByteString; const s: AnsiString; level: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy); overload;
procedure ZCompressString2(var result: RawByteString; const s: UnicodeString; level: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy); overload;
function ZCompressStrWeb(const s: AnsiString): RawByteString;
procedure ZCompressStringWeb(var result: RawByteString; const s: AnsiString); overload;
procedure ZCompressStringWeb(var result: RawByteString; const s: UnicodeString); overload;
function ZDecompressStr(const s: RawByteString): AnsiString;
procedure ZDecompressString(var result: AnsiString; const s: RawByteString); overload;
procedure ZDecompressString(var result: UnicodeString; const s: RawByteString); overload;
function ZDecompressStrEx(const s: RawByteString): AnsiString;
procedure ZDecompressStringEx(var result: AnsiString; const s: RawByteString); overload;
procedure ZDecompressStringEx(var result: UnicodeString; const s: RawByteString); overload;
function ZDecompressStr2(const s: RawByteString; windowBits: Integer): AnsiString;
procedure ZDecompressString2(var result: AnsiString; const s: RawByteString; windowBits: Integer); overload;
procedure ZDecompressString2(var result: UnicodeString; const s: RawByteString; windowBits: Integer); overload;
procedure ZCompressStream(inStream, outStream: TStream; level: TZCompressionLevel = zcDefault);
procedure ZCompressStream2(inStream, outStream: TStream; level: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy);
procedure ZCompressStreamWeb(inStream, outStream: TStream);
procedure ZDecompressStream(inStream, outStream: TStream);
procedure ZDecompressStream2(inStream, outStream: TStream; windowBits: Integer);

Types

RawByteString = AnsiString;
UnicodeString = WideString;
UnicodeChar = WideChar;
TStreamPos = Longint ;
TZCompressionLevel = (...);
Values
  • zcNone:
  • zcFastest:
  • zcDefault:
  • zcMax:
  • zcLevel1:
  • zcLevel2:
  • zcLevel3:
  • zcLevel4:
  • zcLevel5:
  • zcLevel6:
  • zcLevel7:
  • zcLevel8:
  • zcLevel9:
TZStrategy = (...);
Values
  • zsDefault:
  • zsFiltered:
  • zsHuffman:
  • zsRLE:
  • zsFixed:
TZError = (...);
Values
  • zeError:
  • zeStreamError:
  • zeDataError:
  • zeMemoryError:
  • zeBufferError:
  • zeVersionError:
TZFlush = (...);
Values
  • zfNoFlush:
  • zfPartialFlush:
  • zfSyncFlush:
  • zfFullFlush:
  • zfFinish:
  • zfBlock:
  • zfTrees:
TZReadFunction = function (param: Pointer; var buffer; size: Integer): Integer;
TZWriteFunction = function (param: Pointer; const buffer; size: Integer): Integer;
EZLibErrorClass = class of EZlibError;

Constants

ZLevels: Array [TZCompressionLevel] of Integer = ( Z_NO_COMPRESSION, Z_BEST_SPEED, Z_DEFAULT_COMPRESSION, Z_BEST_COMPRESSION, 1, 2, 3, 4, 5, 6, 7, 8, 9 );
ZStrategies: Array [TZStrategy] of Integer = ( Z_DEFAULT_STRATEGY, Z_FILTERED, Z_HUFFMAN_ONLY, Z_RLE, Z_FIXED );
ZErrors: Array [TZError] of Integer = ( Z_ERRNO, Z_STREAM_ERROR, Z_DATA_ERROR, Z_MEM_ERROR, Z_BUF_ERROR, Z_VERSION_ERROR );
ZFlushes: Array [TZFlush] of Integer = ( Z_NO_FLUSH, Z_PARTIAL_FLUSH, Z_SYNC_FLUSH, Z_FULL_FLUSH, Z_FINISH, Z_BLOCK, Z_TREES );
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:59


GLScene v.1.1.2: GLSZLibEx: packed record TZInformation

packed record TZInformation

Unit

GLSZLibEx

Declaration

type TZInformation = packed record

Description

Overview

Fields

CompressedFlags: Longint;
CompressedSize: TStreamPos;
CompressedCrc: Longint;
CompressedAdler: Longint;
UncompressedFlags: Longint;
UncompressedSize: TStreamPos;
UncompressedCrc: Longint;
UncompressedAdler: Longint;

Description

Fields

CompressedFlags: Longint;
CompressedSize: TStreamPos;
CompressedCrc: Longint;
CompressedAdler: Longint;
UncompressedFlags: Longint;
UncompressedSize: TStreamPos;
UncompressedCrc: Longint;
UncompressedAdler: Longint;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:59


GLScene v.1.1.2: GLSZLibEx: Class TCustomZStream

Class TCustomZStream

Unit

GLSZLibEx

Declaration

type TCustomZStream = class(TStream)

Description

Hierarchy

  • TStream
  • TCustomZStream

Overview

Methods

Public | constructor Create(stream: TStream);
Protected | function StreamRead(var buffer; count: Longint): Longint;
Protected | function StreamSeek(offset: Longint; origin: Word): Longint;
Protected | function StreamWrite(const buffer; count: Longint): Longint;
Protected | procedure DoProgress; dynamic;
Protected | procedure StreamReadBuffer(var buffer; count: Longint);
Protected | procedure StreamWriteBuffer(const buffer; count: Longint);

Properties

Protected | property OnProgress: TNotifyEvent read FOnProgress write FOnProgress;
Protected | property StreamPosition: TStreamPos read GetStreamPosition write SetStreamPosition;

Description

Methods

Public constructor Create(stream: TStream);
Protected function StreamRead(var buffer; count: Longint): Longint;
Protected function StreamSeek(offset: Longint; origin: Word): Longint;
Protected function StreamWrite(const buffer; count: Longint): Longint;
Protected procedure DoProgress; dynamic;
Protected procedure StreamReadBuffer(var buffer; count: Longint);
Protected procedure StreamWriteBuffer(const buffer; count: Longint);

Properties

Protected property OnProgress: TNotifyEvent read FOnProgress write FOnProgress;
Protected property StreamPosition: TStreamPos read GetStreamPosition write SetStreamPosition;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:59


GLScene v.1.1.2: GLSZLibEx: Class TZCompressionStream

Class TZCompressionStream

Unit

GLSZLibEx

Declaration

type TZCompressionStream = class(TCustomZStream)

Description

no description available, TCustomZStream description follows

Hierarchy

  • TStream
  • TCustomZStream
  • TZCompressionStream

Overview

Methods

Public | constructor Create(dest: TStream; compressionLevel: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy); overload;
Public | constructor Create(dest: TStream; compressionLevel: TZCompressionLevel = zcDefault); overload;
Public | destructor Destroy; override;
Public | function Read(var buffer; count: Longint): Longint; override;
Public | function Seek(offset: Longint; origin: Word): Longint; override;
Public | function Write(const buffer; count: Longint): Longint; override;

Properties

Public | property CompressionRate: Single read GetCompressionRate;
Public | property OnProgress;

Description

Methods

Public constructor Create(dest: TStream; compressionLevel: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy); overload;
Public constructor Create(dest: TStream; compressionLevel: TZCompressionLevel = zcDefault); overload;
Public destructor Destroy; override;
Public function Read(var buffer; count: Longint): Longint; override;
Public function Seek(offset: Longint; origin: Word): Longint; override;
Public function Write(const buffer; count: Longint): Longint; override;

Properties

Public property CompressionRate: Single read GetCompressionRate;
Public property OnProgress;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:59


GLScene v.1.1.2: GLSZLibEx: Class TZDecompressionStream

Class TZDecompressionStream

Unit

GLSZLibEx

Declaration

type TZDecompressionStream = class(TCustomZStream)

Description

no description available, TCustomZStream description follows

Hierarchy

  • TStream
  • TCustomZStream
  • TZDecompressionStream

Overview

Methods

Public | constructor Create(source: TStream; windowBits: Integer); overload;
Public | constructor Create(source: TStream); overload;
Public | destructor Destroy; override;
Public | function Read(var buffer; count: Longint): Longint; override;
Public | function Seek(offset: Longint; origin: Word): Longint; override;
Public | function Write(const buffer; count: Longint): Longint; override;

Properties

Public property OnProgress;

Description

Methods

Public constructor Create(source: TStream; windowBits: Integer); overload;
Public constructor Create(source: TStream); overload;
Public destructor Destroy; override;
Public function Read(var buffer; count: Longint): Longint; override;
Public function Seek(offset: Longint; origin: Word): Longint; override;
Public function Write(const buffer; count: Longint): Longint; override;

Properties

Public property OnProgress;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:59


GLScene v.1.1.2: GLSZLibEx: Class TZCustomBuffer

Class TZCustomBuffer

Unit

GLSZLibEx

Declaration

type TZCustomBuffer = class(TObject)

Description

Hierarchy

  • TObject
  • TZCustomBuffer

Overview

Fields

Protected FZStream: TZStreamRec;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function Read(var s: AnsiString): Integer; overload;
Public | function Read(var buffer: Pointer; size: Integer): Integer; overload;
Public | function Write(const buffer: Pointer; size: Integer): Integer; overload; virtual; abstract;
Public | function Write(const s: AnsiString): Integer; overload;
Public | procedure Clear; virtual;
Public | procedure Flush(flush: TZFlush); virtual;
Protected | procedure BufferCapacity(capacity: Integer);
Protected | procedure BufferRead(var buffer: Pointer; size: Integer);
Protected | procedure BufferWrite(const buffer: Pointer; size: Integer);

Properties

Protected property BufferSize: Integer read FBufferSize;

Description

Fields

Protected FZStream: TZStreamRec;

Methods

Public constructor Create;
Public destructor Destroy; override;
Public function Read(var s: AnsiString): Integer; overload;
Public function Read(var buffer: Pointer; size: Integer): Integer; overload;
Public function Write(const buffer: Pointer; size: Integer): Integer; overload; virtual; abstract;
Public function Write(const s: AnsiString): Integer; overload;
Public procedure Clear; virtual;
Public procedure Flush(flush: TZFlush); virtual;
Protected procedure BufferCapacity(capacity: Integer);
Protected procedure BufferRead(var buffer: Pointer; size: Integer);
Protected procedure BufferWrite(const buffer: Pointer; size: Integer);

Properties

Protected property BufferSize: Integer read FBufferSize;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:59


GLScene v.1.1.2: GLSZLibEx: Class TZCompressionBuffer

Class TZCompressionBuffer

Unit

GLSZLibEx

Declaration

type TZCompressionBuffer = class(TZCustomBuffer)

Description

no description available, TZCustomBuffer description follows

Hierarchy

  • TObject
  • TZCustomBuffer
  • TZCompressionBuffer

Overview

Methods

Public | constructor Create(level: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy); overload;
Public | constructor Create(level: TZCompressionLevel = zcDefault); overload;
Public | destructor Destroy; override;
Public | function Write(const buffer: Pointer; size: Integer): Integer; override;
Public | procedure Clear; override;
Public | procedure Flush(flush: TZFlush); override;

Description

Methods

Public constructor Create(level: TZCompressionLevel; windowBits, memLevel: Integer; strategy: TZStrategy); overload;
Public constructor Create(level: TZCompressionLevel = zcDefault); overload;
Public destructor Destroy; override;
Public function Write(const buffer: Pointer; size: Integer): Integer; override;
Public procedure Clear; override;
Public procedure Flush(flush: TZFlush); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:59


GLScene v.1.1.2: GLSZLibEx: Class TZDecompressionBuffer

Class TZDecompressionBuffer

Unit

GLSZLibEx

Declaration

type TZDecompressionBuffer = class(TZCustomBuffer)

Description

no description available, TZCustomBuffer description follows

Hierarchy

  • TObject
  • TZCustomBuffer
  • TZDecompressionBuffer

Overview

Methods

Public | constructor Create(windowBits: Integer); overload;
Public | constructor Create; overload;
Public | destructor Destroy; override;
Public | function Write(const buffer: Pointer; size: Integer): Integer; override;
Public | procedure Clear; override;

Description

Methods

Public constructor Create(windowBits: Integer); overload;
Public constructor Create; overload;
Public destructor Destroy; override;
Public function Write(const buffer: Pointer; size: Integer): Integer; override;
Public procedure Clear; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:59


GLScene v.1.1.2: GLSZLibEx: Class EZLibError

Class EZLibError

Unit

GLSZLibEx

Declaration

type EZLibError = class(Exception)

Description

Hierarchy

  • Exception
  • EZLibError

Overview

Methods

Public | constructor Create(error: TZError; const dummy: String = ''); overload;
Public | constructor Create(code: Integer; const dummy: String = ''); overload;

Properties

Public property ErrorCode: Integer read FErrorCode write FErrorCode;

Description

Methods

Public constructor Create(error: TZError; const dummy: String = ''); overload;
Public constructor Create(code: Integer; const dummy: String = ''); overload;

Properties

Public property ErrorCode: Integer read FErrorCode write FErrorCode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:59


GLScene v.1.1.2: GLSZLibEx: Class EZCompressionError

Class EZCompressionError

Unit

GLSZLibEx

Declaration

type EZCompressionError = class(EZLibError)

Description

no description available, EZLibError description follows

Hierarchy

  • Exception
  • EZLibError
  • EZCompressionError
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:59


GLScene v.1.1.2: GLSZLibEx: Class EZDecompressionError

Class EZDecompressionError

Unit

GLSZLibEx

Declaration

type EZDecompressionError = class(EZLibError)

Description

no description available, EZLibError description follows

Hierarchy

  • Exception
  • EZLibError
  • EZDecompressionError
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:59


GLScene v.1.1.2: GLSZLibExApi

Unit GLSZLibExApi

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

ZLibEx<p>

<b>Historique : </b><font size=-1><ul> <li>16/02/11 - PREDATOR - Added support for Mac OS X. Tested on Mac OS X 10.6.5. <li>18/05/10 - Yar - Changed to dynamic library loading for FPC (by Predator) <li>06/05/10 - Yar - Added to GLScene (contributed by oleg matrozov) </ul></font>

****************************************************************************** * ZLibExApi.pas * * * * copyright (c) 2000-2010 base2 technologies * * copyright (c) 1995-2002 Borland Software Corporation * * * * revision history * * 2010.04.20 updated to zlib version 1.2.5 * * 2010.04.15 updated to zlib version 1.2.4 * * 2005.07.25 updated to zlib version 1.2.3 * * 2005.01.11 updated to zlib version 1.2.2 * * 2004.01.06 updated to zlib version 1.2.1 * * 2002.03.15 updated to zlib version 1.1.4 * * * * acknowledgments * * burak kalayci * * 2002.03.15 informing me about the zlib 1.1.4 update * * 2004.01.06 informing me about the zlib 1.2.1 update * * * * vicente sanchez-alarcos * * 2005.01.11 informing me about the zlib 1.2.2 update * * * * mathijs van veluw * * 2005.07.25 informing me about the zlib 1.2.3 update * *****************************************************************************

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TZStreamRec |

Functions and Procedures

function deflateInit(var strm: TZStreamRec; level: Integer): Integer;
function deflateInit2(var strm: TZStreamRec; level, method, windowBits, memLevel, strategy: Integer): Integer;
function inflateInit(var strm: TZStreamRec): Integer;
function inflateInit2(var strm: TZStreamRec; windowBits: Integer): Integer;
function Initzlib : Boolean;
procedure Closezlib;
procedure ReadEntryPoints;
function zlibVersion(): string;
function ZLIB_VERSION(): PChar;
function zGetProcAddress(ProcName: PChar): Pointer;

Types

TZAlloc = function (opaque: Pointer; items, size: Integer): Pointer;
TZFree = procedure (opaque, block: Pointer);

Constants

Z_DEFLATED = 8;
Z_INFO_FLAG_SIZE = $1;
Z_INFO_FLAG_CRC = $2;
Z_INFO_FLAG_ADLER = $4;
Z_INFO_NONE = 0;
Z_INFO_DEFAULT = Z_INFO_FLAG_SIZE or Z_INFO_FLAG_CRC;
Z_NO_FLUSH = 0;
Z_PARTIAL_FLUSH = 1;
Z_SYNC_FLUSH = 2;
Z_FULL_FLUSH = 3;
Z_FINISH = 4;
Z_BLOCK = 5;
Z_TREES = 6;
Z_OK = 0;
Z_STREAM_END = 1;
Z_NEED_DICT = 2;
Z_ERRNO = (-1);
Z_STREAM_ERROR = (-2);
Z_DATA_ERROR = (-3);
Z_MEM_ERROR = (-4);
Z_BUF_ERROR = (-5);
Z_VERSION_ERROR = (-6);
Z_NO_COMPRESSION = 0;
Z_BEST_SPEED = 1;
Z_BEST_COMPRESSION = 9;
Z_DEFAULT_COMPRESSION = (-1);
Z_FILTERED = 1;
Z_HUFFMAN_ONLY = 2;
Z_RLE = 3;
Z_FIXED = 4;
Z_DEFAULT_STRATEGY = 0;
Z_BINARY = 0;
Z_ASCII = 1;
Z_TEXT = Z_ASCII;
Z_UNKNOWN = 2;
_z_errmsg: Array [0..9] of String = ( 'Need dictionary', 'Stream end', 'OK', 'File error', 'Stream error', 'Data error', 'Insufficient memory', 'Buffer error', 'Incompatible version', '' );
libz='zlib1';

Variables

zlibVersionpchar: function(): pchar; cdecl;
zErrorpchar: function(err: integer): pchar; cdecl;
inflateSyncPoint: function(z: TZstreamRec): integer; cdecl;
get_crc_table: function(): pointer; cdecl;
deflateInit_: function(var strm: TZStreamRec; level: Integer; version: PAnsiChar; recsize: Integer): Integer; cdecl;
deflateInit2_: function(var strm: TZStreamRec; level, method, windowBits, memLevel, strategy: Integer; version: PAnsiChar; recsize: Integer): Integer; cdecl;
deflate: function(var strm: TZStreamRec; flush: Integer): Integer; cdecl;
deflateEnd: function(var strm: TZStreamRec): Integer; cdecl;
deflateReset: function(var strm: TZStreamRec): Integer; cdecl;
inflateInit_: function(var strm: TZStreamRec; version: PAnsiChar; recsize: Integer): Integer; cdecl;
inflateInit2_: function(var strm: TZStreamRec; windowBits: Integer; version: PAnsiChar; recsize: Integer): Integer ; cdecl;
inflate: function(var strm: TZStreamRec; flush: Integer): Integer; cdecl;
inflateEnd: function(var strm: TZStreamRec): Integer; cdecl;
inflateReset: function(var strm: TZStreamRec): Integer; cdecl;
adler32: function(adler: Longint; const buf; len: Integer): Longint; cdecl;
crc32: function(crc: Longint; const buf; len: Integer): Longint; cdecl;

Description

Functions and Procedures

function deflateInit(var strm: TZStreamRec; level: Integer): Integer;
function deflateInit2(var strm: TZStreamRec; level, method, windowBits, memLevel, strategy: Integer): Integer;
function inflateInit(var strm: TZStreamRec): Integer;
function inflateInit2(var strm: TZStreamRec; windowBits: Integer): Integer;
function Initzlib : Boolean;
procedure Closezlib;
procedure ReadEntryPoints;
function zlibVersion(): string;
function ZLIB_VERSION(): PChar;
function zGetProcAddress(ProcName: PChar): Pointer;

Types

TZAlloc = function (opaque: Pointer; items, size: Integer): Pointer;
TZFree = procedure (opaque, block: Pointer);

Constants

Z_DEFLATED = 8;
Z_INFO_FLAG_SIZE = $1;
Z_INFO_FLAG_CRC = $2;
Z_INFO_FLAG_ADLER = $4;
Z_INFO_NONE = 0;
Z_INFO_DEFAULT = Z_INFO_FLAG_SIZE or Z_INFO_FLAG_CRC;
Z_NO_FLUSH = 0;
Z_PARTIAL_FLUSH = 1;
Z_SYNC_FLUSH = 2;
Z_FULL_FLUSH = 3;
Z_FINISH = 4;
Z_BLOCK = 5;
Z_TREES = 6;
Z_OK = 0;
Z_STREAM_END = 1;
Z_NEED_DICT = 2;
Z_ERRNO = (-1);
Z_STREAM_ERROR = (-2);
Z_DATA_ERROR = (-3);
Z_MEM_ERROR = (-4);
Z_BUF_ERROR = (-5);
Z_VERSION_ERROR = (-6);
Z_NO_COMPRESSION = 0;
Z_BEST_SPEED = 1;
Z_BEST_COMPRESSION = 9;
Z_DEFAULT_COMPRESSION = (-1);
Z_FILTERED = 1;
Z_HUFFMAN_ONLY = 2;
Z_RLE = 3;
Z_FIXED = 4;
Z_DEFAULT_STRATEGY = 0;
Z_BINARY = 0;
Z_ASCII = 1;
Z_TEXT = Z_ASCII;
Z_UNKNOWN = 2;
_z_errmsg: Array [0..9] of String = ( 'Need dictionary', 'Stream end', 'OK', 'File error', 'Stream error', 'Data error', 'Insufficient memory', 'Buffer error', 'Incompatible version', '' );
libz='zlib1';

Variables

zlibVersionpchar: function(): pchar; cdecl;
zErrorpchar: function(err: integer): pchar; cdecl;
inflateSyncPoint: function(z: TZstreamRec): integer; cdecl;
get_crc_table: function(): pointer; cdecl;
deflateInit_: function(var strm: TZStreamRec; level: Integer; version: PAnsiChar; recsize: Integer): Integer; cdecl;
deflateInit2_: function(var strm: TZStreamRec; level, method, windowBits, memLevel, strategy: Integer; version: PAnsiChar; recsize: Integer): Integer; cdecl;
deflate: function(var strm: TZStreamRec; flush: Integer): Integer; cdecl;
deflateEnd: function(var strm: TZStreamRec): Integer; cdecl;
deflateReset: function(var strm: TZStreamRec): Integer; cdecl;
inflateInit_: function(var strm: TZStreamRec; version: PAnsiChar; recsize: Integer): Integer; cdecl;
inflateInit2_: function(var strm: TZStreamRec; windowBits: Integer; version: PAnsiChar; recsize: Integer): Integer ; cdecl;
inflate: function(var strm: TZStreamRec; flush: Integer): Integer; cdecl;
inflateEnd: function(var strm: TZStreamRec): Integer; cdecl;
inflateReset: function(var strm: TZStreamRec): Integer; cdecl;
adler32: function(adler: Longint; const buf; len: Integer): Longint; cdecl;
crc32: function(crc: Longint; const buf; len: Integer): Longint; cdecl;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:59


GLScene v.1.1.2: GLSZLibExApi: packed record TZStreamRec

packed record TZStreamRec

Unit

GLSZLibExApi

Declaration

type TZStreamRec = packed record

Description

Overview

Fields

next_in: Pointer;
avail_in: Longint;
total_in: Longint;
next_out: Pointer;
avail_out: Longint;
total_out: Longint;
msg: Pointer;
state: Pointer;
zalloc: TZAlloc;
zfree: TZFree;
opaque: Pointer;
data_type: Integer;
adler: Longint;
reserved: Longint;

Description

Fields

next_in: Pointer;
avail_in: Longint;
total_in: Longint;
next_out: Pointer;
avail_out: Longint;
total_out: Longint;
msg: Pointer;
state: Pointer;
zalloc: TZAlloc;
zfree: TZFree;
opaque: Pointer;
data_type: Integer;
adler: Longint;
reserved: Longint;
Generated by PasDoc 0.11.0 on 2013-02-10 19:37:59


GLScene v.1.1.2: GLS_CL

Unit GLS_CL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record T_cl_platform_id |
record T_cl_device_id |
record T_cl_context |
record T_cl_command_queue |
record T_cl_mem |
record T_cl_program |
record T_cl_kernel |
record T_cl_event |
record T_cl_sampler |
record Tcl_image_format |

Functions and Procedures

function InitOpenCL: Boolean;
procedure CloseOpenCL;
function InitOpenCLFromLibrary(const CLName: WideString): Boolean;
function IsOpenCLInitialized: Boolean;

Types

Tcl_platform_id = ˆT_cl_platform_id;
Tcl_device_id = ˆT_cl_device_id;
Tcl_context = ˆT_cl_context;
Tcl_command_queue = ˆT_cl_command_queue;
Tcl_mem = ˆT_cl_mem;
Tcl_program = ˆT_cl_program;
Tcl_kernel = ˆT_cl_kernel;
Tcl_event = ˆT_cl_event;
Tcl_sampler = ˆT_cl_sampler;
Pcl_platform_id = ˆTcl_platform_id;
Pcl_device_id = ˆTcl_device_id;
Pcl_context = ˆTcl_context;
Pcl_command_queue = ˆTcl_command_queue;
Pcl_mem = ˆTcl_mem;
Pcl_program = ˆTcl_program;
Pcl_kernel = ˆTcl_kernel;
Pcl_event = ˆTcl_event;
Pcl_sampler = ˆTcl_sampler;
Tcl_bool = Tcl_uint;
Tcl_bitfield = Tcl_ulong;
Tcl_device_type = Tcl_bitfield;
Tcl_platform_info = Tcl_uint;
Tcl_device_info = Tcl_uint;
Tcl_device_address_info = Tcl_bitfield;
Tcl_device_fp_config = Tcl_bitfield;
Tcl_device_mem_cache_type = Tcl_uint;
Tcl_device_local_mem_type = Tcl_uint;
Tcl_device_exec_capabilities = Tcl_bitfield;
Tcl_command_queue_properties = Tcl_bitfield;
Pcl_bool = ˆTcl_bool;
Pcl_bitfield = ˆTcl_bitfield;
Pcl_device_type = ˆTcl_device_type;
Pcl_platform_info = ˆTcl_platform_info;
Pcl_device_info = ˆTcl_device_info;
Pcl_device_address_info = ˆTcl_device_address_info;
Pcl_device_fp_config = ˆTcl_device_fp_config;
Pcl_device_mem_cache_type = ˆTcl_device_mem_cache_type;
Pcl_device_local_mem_type = ˆTcl_device_local_mem_type;
Pcl_device_exec_capabilities = ˆTcl_device_exec_capabilities;
Pcl_command_queue_properties = ˆTcl_command_queue_properties;
Tcl_context_properties = intptr_t;
Tcl_context_info = Tcl_uint;
Tcl_command_queue_info = Tcl_uint;
Tcl_channel_order = Tcl_uint;
Tcl_channel_type = Tcl_uint;
Tcl_mem_flags = Tcl_bitfield;
Tcl_mem_object_type = Tcl_uint;
Tcl_mem_info = Tcl_uint;
Tcl_image_info = Tcl_uint;
Tcl_addressing_mode = Tcl_uint;
Tcl_filter_mode = Tcl_uint;
Tcl_sampler_info = Tcl_uint;
Tcl_map_flags = Tcl_bitfield;
Tcl_program_info = Tcl_uint;
Tcl_program_build_info = Tcl_uint;
Tcl_build_status = Tcl_int;
Tcl_kernel_info = Tcl_uint;
Tcl_kernel_work_group_info = Tcl_uint;
Tcl_event_info = Tcl_uint;
Tcl_command_type = Tcl_uint;
Tcl_profiling_info = Tcl_uint;
Pcl_context_properties = ˆTcl_context_properties;
Pcl_context_info = ˆTcl_context_info;
Pcl_command_queue_info = ˆTcl_command_queue_info;
Pcl_channel_order = ˆTcl_channel_order;
Pcl_channel_type = ˆTcl_channel_type;
Pcl_mem_flags = ˆTcl_mem_flags;
Pcl_mem_object_type = ˆTcl_mem_object_type;
Pcl_mem_info = ˆTcl_mem_info;
Pcl_image_info = ˆTcl_image_info;
Pcl_addressing_mode = ˆTcl_addressing_mode;
Pcl_filter_mode = ˆTcl_filter_mode;
Pcl_sampler_info = ˆTcl_sampler_info;
Pcl_map_flags = ˆTcl_map_flags;
Pcl_program_info = ˆTcl_program_info;
Pcl_program_build_info = ˆTcl_program_build_info;
Pcl_build_status = ˆTcl_build_status;
Pcl_kernel_info = ˆTcl_kernel_info;
Pcl_kernel_work_group_info = ˆTcl_kernel_work_group_info;
Pcl_event_info = ˆTcl_event_info;
Pcl_command_type = ˆTcl_command_type;
Pcl_profiling_info = ˆTcl_profiling_info;
Pcl_image_format = ˆTcl_image_format;
logging_fn = procedure(errinfo: PAnsiChar; private_info: Pointer; cb: TSize_t; user_data: Pointer); stdcall;
ProgramBuilt_notify_fn = procedure(_program: Tcl_program; user_data: Pointer); stdcall;
EnqueueNativeKernel_user_func = procedure(); stdcall;

Constants

LibOpenCL = 'OpenCL.dll';
CL_SUCCESS = 0;
CL_DEVICE_NOT_FOUND = -1;
CL_DEVICE_NOT_AVAILABLE = -2;
CL_COMPILER_NOT_AVAILABLE = -3;
CL_MEM_OBJECT_ALLOCATION_FAILURE = -4;
CL_OUT_OF_RESOURCES = -5;
CL_OUT_OF_HOST_MEMORY = -6;
CL_PROFILING_INFO_NOT_AVAILABLE = -7;
CL_MEM_COPY_OVERLAP = -8;
CL_IMAGE_FORMAT_MISMATCH = -9;
CL_IMAGE_FORMAT_NOT_SUPPORTED = -10;
CL_BUILD_PROGRAM_FAILURE = -11;
CL_MAP_FAILURE = -12;
CL_INVALID_VALUE = -30;
CL_INVALID_DEVICE_TYPE = -31;
CL_INVALID_PLATFORM = -32;
CL_INVALID_DEVICE = -33;
CL_INVALID_CONTEXT = -34;
CL_INVALID_QUEUE_PROPERTIES = -35;
CL_INVALID_COMMAND_QUEUE = -36;
CL_INVALID_HOST_PTR = -37;
CL_INVALID_MEM_OBJECT = -38;
CL_INVALID_IMAGE_FORMAT_DESCRIPTOR = -39;
CL_INVALID_IMAGE_SIZE = -40;
CL_INVALID_SAMPLER = -41;
CL_INVALID_BINARY = -42;
CL_INVALID_BUILD_OPTIONS = -43;
CL_INVALID_PROGRAM = -44;
CL_INVALID_PROGRAM_EXECUTABLE = -45;
CL_INVALID_KERNEL_NAME = -46;
CL_INVALID_KERNEL_DEFINITION = -47;
CL_INVALID_KERNEL = -48;
CL_INVALID_ARG_INDEX = -49;
CL_INVALID_ARG_VALUE = -50;
CL_INVALID_ARG_SIZE = -51;
CL_INVALID_KERNEL_ARGS = -52;
CL_INVALID_WORK_DIMENSION = -53;
CL_INVALID_WORK_GROUP_SIZE = -54;
CL_INVALID_WORK_ITEM_SIZE = -55;
CL_INVALID_GLOBAL_OFFSET = -56;
CL_INVALID_EVENT_WAIT_LIST = -57;
CL_INVALID_EVENT = -58;
CL_INVALID_OPERATION = -59;
CL_INVALID_GL_OBJECT = -60;
CL_INVALID_BUFFER_SIZE = -61;
CL_INVALID_MIP_LEVEL = -62;
CL_INVALID_GLOBAL_WORK_SIZE = -63;
CL_VERSION_1_0 = 1;
CL_FALSE = 0;
CL_TRUE = 1;
CL_PLATFORM_PROFILE = $0900;
CL_PLATFORM_VERSION = $0901;
CL_PLATFORM_NAME = $0902;
CL_PLATFORM_VENDOR = $0903;
CL_PLATFORM_EXTENSIONS = $0904;
CL_DEVICE_TYPE_DEFAULT = (1 shl 0);
CL_DEVICE_TYPE_CPU = (1 shl 1);
CL_DEVICE_TYPE_GPU = (1 shl 2);
CL_DEVICE_TYPE_ACCELERATOR = (1 shl 3);
CL_DEVICE_TYPE_ALL = $FFFFFFFF;
CL_DEVICE_TYPE = $1000;
CL_DEVICE_VENDOR_ID = $1001;
CL_DEVICE_MAX_COMPUTE_UNITS = $1002;
CL_DEVICE_MAX_WORK_ITEM_DIMENSIONS = $1003;
CL_DEVICE_MAX_WORK_GROUP_SIZE = $1004;
CL_DEVICE_MAX_WORK_ITEM_SIZES = $1005;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_CHAR = $1006;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_SHORT = $1007;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_INT = $1008;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_LONG = $1009;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_FLOAT = $100A;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_DOUBLE = $100B;
CL_DEVICE_MAX_CLOCK_FREQUENCY = $100C;
CL_DEVICE_ADDRESS_BITS = $100D;
CL_DEVICE_MAX_READ_IMAGE_ARGS = $100E;
CL_DEVICE_MAX_WRITE_IMAGE_ARGS = $100F;
CL_DEVICE_MAX_MEM_ALLOC_SIZE = $1010;
CL_DEVICE_IMAGE2D_MAX_WIDTH = $1011;
CL_DEVICE_IMAGE2D_MAX_HEIGHT = $1012;
CL_DEVICE_IMAGE3D_MAX_WIDTH = $1013;
CL_DEVICE_IMAGE3D_MAX_HEIGHT = $1014;
CL_DEVICE_IMAGE3D_MAX_DEPTH = $1015;
CL_DEVICE_IMAGE_SUPPORT = $1016;
CL_DEVICE_MAX_PARAMETER_SIZE = $1017;
CL_DEVICE_MAX_SAMPLERS = $1018;
CL_DEVICE_MEM_BASE_ADDR_ALIGN = $1019;
CL_DEVICE_MIN_DATA_TYPE_ALIGN_SIZE = $101A;
CL_DEVICE_SINGLE_FP_CONFIG = $101B;
CL_DEVICE_GLOBAL_MEM_CACHE_TYPE = $101C;
CL_DEVICE_GLOBAL_MEM_CACHELINE_SIZE = $101D;
CL_DEVICE_GLOBAL_MEM_CACHE_SIZE = $101E;
CL_DEVICE_GLOBAL_MEM_SIZE = $101F;
CL_DEVICE_MAX_CONSTANT_BUFFER_SIZE = $1020;
CL_DEVICE_MAX_CONSTANT_ARGS = $1021;
CL_DEVICE_LOCAL_MEM_TYPE = $1022;
CL_DEVICE_LOCAL_MEM_SIZE = $1023;
CL_DEVICE_ERROR_CORRECTION_SUPPORT = $1024;
CL_DEVICE_PROFILING_TIMER_RESOLUTION = $1025;
CL_DEVICE_ENDIAN_LITTLE = $1026;
CL_DEVICE_AVAILABLE = $1027;
CL_DEVICE_COMPILER_AVAILABLE = $1028;
CL_DEVICE_EXECUTION_CAPABILITIES = $1029;
CL_DEVICE_QUEUE_PROPERTIES = $102A;
CL_DEVICE_NAME = $102B;
CL_DEVICE_VENDOR = $102C;
CL_DRIVER_VERSION = $102D;
CL_DEVICE_PROFILE = $102E;
CL_DEVICE_VERSION = $102F;
CL_DEVICE_EXTENSIONS = $1030;
CL_DEVICE_PLATFORM = $1031;
CL_FP_DENORM = (1 shl 0);
CL_FP_INF_NAN = (1 shl 1);
CL_FP_ROUND_TO_NEAREST = (1 shl 2);
CL_FP_ROUND_TO_ZERO = (1 shl 3);
CL_FP_ROUND_TO_INF = (1 shl 4);
CL_FP_FMA = (1 shl 5);
CL_NONE = $0;
CL_READ_ONLY_CACHE = $1;
CL_READ_WRITE_CACHE = $2;
CL_LOCAL = $1;
CL_GLOBAL = $2;
CL_EXEC_KERNEL = (1 shl 0);
CL_EXEC_NATIVE_KERNEL = (1 shl 1);
CL_QUEUE_OUT_OF_ORDER_EXEC_MODE_ENABLE = (1 shl 0);
CL_QUEUE_PROFILING_ENABLE = (1 shl 1);
CL_CONTEXT_REFERENCE_COUNT = $1080;
CL_CONTEXT_DEVICES = $1081;
CL_CONTEXT_PROPERTIES = $1082;
CL_CONTEXT_PLATFORM = $1084;
CL_QUEUE_CONTEXT = $1090;
CL_QUEUE_DEVICE = $1091;
CL_QUEUE_REFERENCE_COUNT = $1092;
CL_QUEUE_PROPERTIES = $1093;
CL_MEM_READ_WRITE = (1 shl 0);
CL_MEM_WRITE_ONLY = (1 shl 1);
CL_MEM_READ_ONLY = (1 shl 2);
CL_MEM_USE_HOST_PTR = (1 shl 3);
CL_MEM_ALLOC_HOST_PTR = (1 shl 4);
CL_MEM_COPY_HOST_PTR = (1 shl 5);
CL_R = $10B0;
CL_A = $10B1;
CL_RG = $10B2;
CL_RA = $10B3;
CL_RGB = $10B4;
CL_RGBA = $10B5;
CL_BGRA = $10B6;
CL_ARGB = $10B7;
CL_INTENSITY = $10B8;
CL_LUMINANCE = $10B9;
CL_SNORM_INT8 = $10D0;
CL_SNORM_INT16 = $10D1;
CL_UNORM_INT8 = $10D2;
CL_UNORM_INT16 = $10D3;
CL_UNORM_SHORT_565 = $10D4;
CL_UNORM_SHORT_555 = $10D5;
CL_UNORM_INT_101010 = $10D6;
CL_SIGNED_INT8 = $10D7;
CL_SIGNED_INT16 = $10D8;
CL_SIGNED_INT32 = $10D9;
CL_UNSIGNED_INT8 = $10DA;
CL_UNSIGNED_INT16 = $10DB;
CL_UNSIGNED_INT32 = $10DC;
CL_HALF_FLOAT = $10DD;
CL_FLOAT = $10DE;
CL_MEM_OBJECT_BUFFER = $10F0;
CL_MEM_OBJECT_IMAGE2D = $10F1;
CL_MEM_OBJECT_IMAGE3D = $10F2;
CL_MEM_TYPE = $1100;
CL_MEM_FLAGS = $1101;
CL_MEM_SIZE = $1102;
CL_MEM_HOST_PTR = $1103;
CL_MEM_MAP_COUNT = $1104;
CL_MEM_REFERENCE_COUNT = $1105;
CL_MEM_CONTEXT = $1106;
CL_IMAGE_FORMAT = $1110;
CL_IMAGE_ELEMENT_SIZE = $1111;
CL_IMAGE_ROW_PITCH = $1112;
CL_IMAGE_SLICE_PITCH = $1113;
CL_IMAGE_WIDTH = $1114;
CL_IMAGE_HEIGHT = $1115;
CL_IMAGE_DEPTH = $1116;
CL_ADDRESS_NONE = $1130;
CL_ADDRESS_CLAMP_TO_EDGE = $1131;
CL_ADDRESS_CLAMP = $1132;
CL_ADDRESS_REPEAT = $1133;
CL_FILTER_NEAREST = $1140;
CL_FILTER_LINEAR = $1141;
CL_SAMPLER_REFERENCE_COUNT = $1150;
CL_SAMPLER_CONTEXT = $1151;
CL_SAMPLER_NORMALIZED_COORDS = $1152;
CL_SAMPLER_ADDRESSING_MODE = $1153;
CL_SAMPLER_FILTER_MODE = $1154;
CL_MAP_READ = (1 shl 0);
CL_MAP_WRITE = (1 shl 1);
CL_PROGRAM_REFERENCE_COUNT = $1160;
CL_PROGRAM_CONTEXT = $1161;
CL_PROGRAM_NUM_DEVICES = $1162;
CL_PROGRAM_DEVICES = $1163;
CL_PROGRAM_SOURCE = $1164;
CL_PROGRAM_BINARY_SIZES = $1165;
CL_PROGRAM_BINARIES = $1166;
CL_PROGRAM_BUILD_STATUS = $1181;
CL_PROGRAM_BUILD_OPTIONS = $1182;
CL_PROGRAM_BUILD_LOG = $1183;
CL_BUILD_SUCCESS = 0;
CL_BUILD_NONE = -1;
CL_BUILD_ERROR = -2;
CL_BUILD_IN_PROGRESS = -3;
CL_KERNEL_FUNCTION_NAME = $1190;
CL_KERNEL_NUM_ARGS = $1191;
CL_KERNEL_REFERENCE_COUNT = $1192;
CL_KERNEL_CONTEXT = $1193;
CL_KERNEL_PROGRAM = $1194;
CL_KERNEL_WORK_GROUP_SIZE = $11B0;
CL_KERNEL_COMPILE_WORK_GROUP_SIZE = $11B1;
CL_KERNEL_LOCAL_MEM_SIZE = $11B2;
CL_EVENT_COMMAND_QUEUE = $11D0;
CL_EVENT_COMMAND_TYPE = $11D1;
CL_EVENT_REFERENCE_COUNT = $11D2;
CL_EVENT_COMMAND_EXECUTION_STATUS = $11D3;
CL_COMMAND_NDRANGE_KERNEL = $11F0;
CL_COMMAND_TASK = $11F1;
CL_COMMAND_NATIVE_KERNEL = $11F2;
CL_COMMAND_READ_BUFFER = $11F3;
CL_COMMAND_WRITE_BUFFER = $11F4;
CL_COMMAND_COPY_BUFFER = $11F5;
CL_COMMAND_READ_IMAGE = $11F6;
CL_COMMAND_WRITE_IMAGE = $11F7;
CL_COMMAND_COPY_IMAGE = $11F8;
CL_COMMAND_COPY_IMAGE_TO_BUFFER = $11F9;
CL_COMMAND_COPY_BUFFER_TO_IMAGE = $11FA;
CL_COMMAND_MAP_BUFFER = $11FB;
CL_COMMAND_MAP_IMAGE = $11FC;
CL_COMMAND_UNMAP_MEM_OBJECT = $11FD;
CL_COMMAND_MARKER = $11FE;
CL_COMMAND_ACQUIRE_GL_OBJECTS = $11FF;
CL_COMMAND_RELEASE_GL_OBJECTS = $1200;
CL_COMPLETE = $0;
CL_RUNNING = $1;
CL_SUBMITTED = $2;
CL_QUEUED = $3;
CL_PROFILING_COMMAND_QUEUED = $1280;
CL_PROFILING_COMMAND_SUBMIT = $1281;
CL_PROFILING_COMMAND_START = $1282;
CL_PROFILING_COMMAND_END = $1283;

Variables

clGetPlatformIDs: function(num_entries: Tcl_uint; platforms: Pcl_platform_id; num_platforms: Pcl_uint): Tcl_int; stdcall;
clGetPlatformInfo: function(_platform: Tcl_platform_id; param_name: Tcl_platform_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clGetDeviceIDs: function(_platform: Tcl_platform_id; device_type: Tcl_device_type; num_entries: Tcl_uint; devices: Pcl_device_id; num_devices: Pcl_uint): Tcl_int; stdcall;
clGetDeviceInfo: function(device: Tcl_device_id; param_name: Tcl_device_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clCreateContext: function(properties: Pcl_context_properties; num_devices: Tcl_uint; devices: Pcl_device_id; pfn_notify: logging_fn; user_data: Pointer; errcode_ret: Pcl_int): Tcl_context; stdcall;
clCreateContextFromType: function(properties: Pcl_context_properties; device_type: Tcl_device_type; pfn_notify: logging_fn; user_data: Pointer; errcode_ret: Pcl_int): Tcl_context; stdcall;
clRetainContext: function(context: Tcl_context): Tcl_int; stdcall;
clReleaseContext: function(context: Tcl_context): Tcl_int; stdcall;
clGetContextInfo: function(context: Tcl_context; param_name: Tcl_context_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clCreateCommandQueue: function(context: Tcl_context; device: Tcl_device_id; properties: Tcl_command_queue_properties; errcode_ret: Pcl_int): Tcl_command_queue; stdcall;
clRetainCommandQueue: function(command_queue: Tcl_command_queue): Tcl_int; stdcall;
clReleaseCommandQueue: function(command_queue: Tcl_command_queue): Tcl_int; stdcall;
clGetCommandQueueInfo: function(command_queue: Tcl_command_queue; param_name: Tcl_command_queue_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clSetCommandQueueProperty: function(command_queue: Tcl_command_queue; properties: Tcl_command_queue_properties; enable: Tcl_bool; old_properties: Pcl_command_queue_properties): Tcl_int; stdcall;
clCreateBuffer: function(context: Tcl_context; flags: Tcl_mem_flags; size: TSize_t; host_ptr: Pointer; errcode_ret: Pcl_int): Tcl_mem; stdcall;
clCreateImage2D: function(context: Tcl_context; flags: Tcl_mem_flags; image_format: Pcl_image_format; image_width: TSize_t; image_height: TSize_t; image_row_pitch: TSize_t; host_ptr: Pointer; errcode_ret: Pcl_int): Tcl_mem; stdcall;
clCreateImage3D: function(context: Tcl_context; flags: Tcl_mem_flags; image_format: Pcl_image_format; image_width: TSize_t; image_height: TSize_t; image_depth: TSize_t; image_row_pitch: TSize_t; image_slice_pitch: TSize_t; host_ptr: Pointer; errcode_ret: Pcl_int): Tcl_mem; stdcall;
clRetainMemObject: function(memobj: Tcl_mem): Tcl_int; stdcall;
clReleaseMemObject: function(memobj: Tcl_mem): Tcl_int; stdcall;
clGetSupportedImageFormats: function(context: Tcl_context; flags: Tcl_mem_flags; image_type: Tcl_mem_object_type; num_entries: Tcl_uint; image_formats: Pcl_image_format; num_image_formats: Pcl_uint): Tcl_int; stdcall;
clGetMemObjectInfo: function(memobj: Tcl_mem; param_name: Tcl_mem_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clGetImageInfo: function(image: Tcl_mem; param_name: Tcl_image_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clCreateSampler: function(context: Tcl_context; normalized_coords: Tcl_bool; addressing_mode: Tcl_addressing_mode; filter_mode: Tcl_filter_mode; errcode_ret: Pcl_int): Tcl_sampler; stdcall;
clRetainSampler: function(sampler: Tcl_sampler): Tcl_int; stdcall;
clReleaseSampler: function(sampler: Tcl_sampler): Tcl_int; stdcall;
clGetSamplerInfo: function(sampler: Tcl_sampler; param_name: Tcl_sampler_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clCreateProgramWithSource: function(context: Tcl_context; count: Tcl_uint; strings: PPAnsiChar; lengths: PSize_t; errcode_ret: Pcl_int): Tcl_program; stdcall;
clCreateProgramWithBinary: function(context: Tcl_context; num_devices: Tcl_uint; device_list: Pcl_device_id; lengths: PSize_t; binaries: PPointer; binary_status: Pcl_int; errcode_ret: Pcl_int): Tcl_program; stdcall;
clRetainProgram: function(_program: Tcl_program): Tcl_int; stdcall;
clReleaseProgram: function(_program: Tcl_program): Tcl_int; stdcall;
clBuildProgram: function(_program: Tcl_program; num_devices: Tcl_uint; device_list: Pcl_device_id; options: PAnsiChar; pfn_notify: ProgramBuilt_notify_fn; user_data: Pointer): Tcl_int; stdcall;
clUnloadCompiler: function: Tcl_int; stdcall;
clGetProgramInfo: function(_program: Tcl_program; param_name: Tcl_program_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clGetProgramBuildInfo: function(_program: Tcl_program; device: Tcl_device_id; param_name: Tcl_program_build_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clCreateKernel: function(_program: Tcl_program; kernel_name: PAnsiChar; errcode_ret: Pcl_int): Tcl_kernel; stdcall;
clCreateKernelsInProgram: function(_program: Tcl_program; num_kernels: Tcl_uint; kernels: Pcl_kernel; num_kernels_ret: Pcl_uint): Tcl_int; stdcall;
clRetainKernel: function(kernel: Tcl_kernel): Tcl_int; stdcall;
clReleaseKernel: function(kernel: Tcl_kernel): Tcl_int; stdcall;
clSetKernelArg: function(kernel: Tcl_kernel; arg_index: Tcl_uint; arg_size: TSize_t; arg_value: Pointer): Tcl_int; stdcall;
clGetKernelInfo: function(kernel: Tcl_kernel; param_name: Tcl_kernel_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clGetKernelWorkGroupInfo: function(kernel: Tcl_kernel; device: Tcl_device_id; param_name: Tcl_kernel_work_group_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clWaitForEvents: function(num_events: Tcl_uint; event_list: Pcl_event): Tcl_int; stdcall;
clGetEventInfo: function(event: Tcl_event; param_name: Tcl_event_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clRetainEvent: function(event: Tcl_event): Tcl_int; stdcall;
clReleaseEvent: function(event: Tcl_event): Tcl_int; stdcall;
clGetEventProfilingInfo: function(event: Tcl_event; param_name: Tcl_profiling_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clFlush: function(command_queue: Tcl_command_queue): Tcl_int; stdcall;
clFinish: function(command_queue: Tcl_command_queue): Tcl_int; stdcall;
clEnqueueReadBuffer: function(command_queue: Tcl_command_queue; buffer: Tcl_mem; blocking_read: Tcl_bool; offset: TSize_t; cb: TSize_t; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueWriteBuffer: function(command_queue: Tcl_command_queue; buffer: Tcl_mem; blocking_write: Tcl_bool; offset: TSize_t; cb: TSize_t; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueCopyBuffer: function(command_queue: Tcl_command_queue; src_buffer: Tcl_mem; dst_buffer: Tcl_mem; src_offset: TSize_t; dst_offset: TSize_t; cb: TSize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueReadImage: function(command_queue: Tcl_command_queue; image: Tcl_mem; blocking_read: Tcl_bool; origin: PSize_t; region: PSize_t; row_pitch: TSize_t; slice_pitch: TSize_t; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueWriteImage: function(command_queue: Tcl_command_queue; image: Tcl_mem; blocking_write: Tcl_bool; origin: PSize_t; region: PSize_t; input_row_pitch: TSize_t; input_slice_pitch: TSize_t; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueCopyImage: function(command_queue: Tcl_command_queue; src_image: Tcl_mem; dst_image: Tcl_mem; src_origin: PSize_t; dst_origin: PSize_t; region: PSize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueCopyImageToBuffer: function(command_queue: Tcl_command_queue; src_image: Tcl_mem; dst_buffer: Tcl_mem; src_origin: PSize_t; region: PSize_t; dst_offset: TSize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueCopyBufferToImage: function(command_queue: Tcl_command_queue; src_buffer: Tcl_mem; dst_image: Tcl_mem; src_offset: TSize_t; dst_origin: PSize_t; region: PSize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueMapBuffer: function(command_queue: Tcl_command_queue; buffer: Tcl_mem; blocking_map: Tcl_bool; map_flags: Tcl_map_flags; offset: TSize_t; cb: TSize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event; errcode_ret: Pcl_int): Pointer; stdcall;
clEnqueueMapImage: function(command_queue: Tcl_command_queue; image: Tcl_mem; blocking_map: Tcl_bool; map_flags: Tcl_map_flags; origin: PSize_t; region: PSize_t; image_row_pitch: PSize_t; image_slice_pitch: PSize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event; errcode_ret: Pcl_int): Pointer; stdcall;
clEnqueueUnmapMemObject: function(command_queue: Tcl_command_queue; memobj: Tcl_mem; mapped_ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueNDRangeKernel: function(command_queue: Tcl_command_queue; kernel: Tcl_kernel; work_dim: Tcl_uint; global_work_offset: PSize_t; global_work_size: PSize_t; local_work_size: PSize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueTask: function(command_queue: Tcl_command_queue; kernel: Tcl_kernel; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueNativeKernel: function(command_queue: Tcl_command_queue; user_func: EnqueueNativeKernel_user_func; args: Pointer; cb_args: TSize_t; num_mem_objects: Tcl_uint; mem_list: Pcl_mem; args_mem_loc: PPointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueMarker: function(command_queue: Tcl_command_queue; event: Pcl_event): Tcl_int; stdcall;
clEnqueueWaitForEvents: function(command_queue: Tcl_command_queue; num_events: Tcl_uint; event_list: Pcl_event): Tcl_int; stdcall;
clEnqueueBarrier: function(command_queue: Tcl_command_queue): Tcl_int; stdcall;
clGetExtensionFunctionAddress: function(func_name: PAnsiChar): Pointer; stdcall;

Description

Functions and Procedures

function InitOpenCL: Boolean;
procedure CloseOpenCL;
function InitOpenCLFromLibrary(const CLName: WideString): Boolean;
function IsOpenCLInitialized: Boolean;

Types

Tcl_platform_id = ˆT_cl_platform_id;
Tcl_device_id = ˆT_cl_device_id;
Tcl_context = ˆT_cl_context;
Tcl_command_queue = ˆT_cl_command_queue;
Tcl_mem = ˆT_cl_mem;
Tcl_program = ˆT_cl_program;
Tcl_kernel = ˆT_cl_kernel;
Tcl_event = ˆT_cl_event;
Tcl_sampler = ˆT_cl_sampler;
Pcl_platform_id = ˆTcl_platform_id;
Pcl_device_id = ˆTcl_device_id;
Pcl_context = ˆTcl_context;
Pcl_command_queue = ˆTcl_command_queue;
Pcl_mem = ˆTcl_mem;
Pcl_program = ˆTcl_program;
Pcl_kernel = ˆTcl_kernel;
Pcl_event = ˆTcl_event;
Pcl_sampler = ˆTcl_sampler;
Tcl_bool = Tcl_uint;
Tcl_bitfield = Tcl_ulong;
Tcl_device_type = Tcl_bitfield;
Tcl_platform_info = Tcl_uint;
Tcl_device_info = Tcl_uint;
Tcl_device_address_info = Tcl_bitfield;
Tcl_device_fp_config = Tcl_bitfield;
Tcl_device_mem_cache_type = Tcl_uint;
Tcl_device_local_mem_type = Tcl_uint;
Tcl_device_exec_capabilities = Tcl_bitfield;
Tcl_command_queue_properties = Tcl_bitfield;
Pcl_bool = ˆTcl_bool;
Pcl_bitfield = ˆTcl_bitfield;
Pcl_device_type = ˆTcl_device_type;
Pcl_platform_info = ˆTcl_platform_info;
Pcl_device_info = ˆTcl_device_info;
Pcl_device_address_info = ˆTcl_device_address_info;
Pcl_device_fp_config = ˆTcl_device_fp_config;
Pcl_device_mem_cache_type = ˆTcl_device_mem_cache_type;
Pcl_device_local_mem_type = ˆTcl_device_local_mem_type;
Pcl_device_exec_capabilities = ˆTcl_device_exec_capabilities;
Pcl_command_queue_properties = ˆTcl_command_queue_properties;
Tcl_context_properties = intptr_t;
Tcl_context_info = Tcl_uint;
Tcl_command_queue_info = Tcl_uint;
Tcl_channel_order = Tcl_uint;
Tcl_channel_type = Tcl_uint;
Tcl_mem_flags = Tcl_bitfield;
Tcl_mem_object_type = Tcl_uint;
Tcl_mem_info = Tcl_uint;
Tcl_image_info = Tcl_uint;
Tcl_addressing_mode = Tcl_uint;
Tcl_filter_mode = Tcl_uint;
Tcl_sampler_info = Tcl_uint;
Tcl_map_flags = Tcl_bitfield;
Tcl_program_info = Tcl_uint;
Tcl_program_build_info = Tcl_uint;
Tcl_build_status = Tcl_int;
Tcl_kernel_info = Tcl_uint;
Tcl_kernel_work_group_info = Tcl_uint;
Tcl_event_info = Tcl_uint;
Tcl_command_type = Tcl_uint;
Tcl_profiling_info = Tcl_uint;
Pcl_context_properties = ˆTcl_context_properties;
Pcl_context_info = ˆTcl_context_info;
Pcl_command_queue_info = ˆTcl_command_queue_info;
Pcl_channel_order = ˆTcl_channel_order;
Pcl_channel_type = ˆTcl_channel_type;
Pcl_mem_flags = ˆTcl_mem_flags;
Pcl_mem_object_type = ˆTcl_mem_object_type;
Pcl_mem_info = ˆTcl_mem_info;
Pcl_image_info = ˆTcl_image_info;
Pcl_addressing_mode = ˆTcl_addressing_mode;
Pcl_filter_mode = ˆTcl_filter_mode;
Pcl_sampler_info = ˆTcl_sampler_info;
Pcl_map_flags = ˆTcl_map_flags;
Pcl_program_info = ˆTcl_program_info;
Pcl_program_build_info = ˆTcl_program_build_info;
Pcl_build_status = ˆTcl_build_status;
Pcl_kernel_info = ˆTcl_kernel_info;
Pcl_kernel_work_group_info = ˆTcl_kernel_work_group_info;
Pcl_event_info = ˆTcl_event_info;
Pcl_command_type = ˆTcl_command_type;
Pcl_profiling_info = ˆTcl_profiling_info;
Pcl_image_format = ˆTcl_image_format;
logging_fn = procedure(errinfo: PAnsiChar; private_info: Pointer; cb: TSize_t; user_data: Pointer); stdcall;
ProgramBuilt_notify_fn = procedure(_program: Tcl_program; user_data: Pointer); stdcall;
EnqueueNativeKernel_user_func = procedure(); stdcall;

Constants

LibOpenCL = 'OpenCL.dll';
CL_SUCCESS = 0;
CL_DEVICE_NOT_FOUND = -1;
CL_DEVICE_NOT_AVAILABLE = -2;
CL_COMPILER_NOT_AVAILABLE = -3;
CL_MEM_OBJECT_ALLOCATION_FAILURE = -4;
CL_OUT_OF_RESOURCES = -5;
CL_OUT_OF_HOST_MEMORY = -6;
CL_PROFILING_INFO_NOT_AVAILABLE = -7;
CL_MEM_COPY_OVERLAP = -8;
CL_IMAGE_FORMAT_MISMATCH = -9;
CL_IMAGE_FORMAT_NOT_SUPPORTED = -10;
CL_BUILD_PROGRAM_FAILURE = -11;
CL_MAP_FAILURE = -12;
CL_INVALID_VALUE = -30;
CL_INVALID_DEVICE_TYPE = -31;
CL_INVALID_PLATFORM = -32;
CL_INVALID_DEVICE = -33;
CL_INVALID_CONTEXT = -34;
CL_INVALID_QUEUE_PROPERTIES = -35;
CL_INVALID_COMMAND_QUEUE = -36;
CL_INVALID_HOST_PTR = -37;
CL_INVALID_MEM_OBJECT = -38;
CL_INVALID_IMAGE_FORMAT_DESCRIPTOR = -39;
CL_INVALID_IMAGE_SIZE = -40;
CL_INVALID_SAMPLER = -41;
CL_INVALID_BINARY = -42;
CL_INVALID_BUILD_OPTIONS = -43;
CL_INVALID_PROGRAM = -44;
CL_INVALID_PROGRAM_EXECUTABLE = -45;
CL_INVALID_KERNEL_NAME = -46;
CL_INVALID_KERNEL_DEFINITION = -47;
CL_INVALID_KERNEL = -48;
CL_INVALID_ARG_INDEX = -49;
CL_INVALID_ARG_VALUE = -50;
CL_INVALID_ARG_SIZE = -51;
CL_INVALID_KERNEL_ARGS = -52;
CL_INVALID_WORK_DIMENSION = -53;
CL_INVALID_WORK_GROUP_SIZE = -54;
CL_INVALID_WORK_ITEM_SIZE = -55;
CL_INVALID_GLOBAL_OFFSET = -56;
CL_INVALID_EVENT_WAIT_LIST = -57;
CL_INVALID_EVENT = -58;
CL_INVALID_OPERATION = -59;
CL_INVALID_GL_OBJECT = -60;
CL_INVALID_BUFFER_SIZE = -61;
CL_INVALID_MIP_LEVEL = -62;
CL_INVALID_GLOBAL_WORK_SIZE = -63;
CL_VERSION_1_0 = 1;
CL_FALSE = 0;
CL_TRUE = 1;
CL_PLATFORM_PROFILE = $0900;
CL_PLATFORM_VERSION = $0901;
CL_PLATFORM_NAME = $0902;
CL_PLATFORM_VENDOR = $0903;
CL_PLATFORM_EXTENSIONS = $0904;
CL_DEVICE_TYPE_DEFAULT = (1 shl 0);
CL_DEVICE_TYPE_CPU = (1 shl 1);
CL_DEVICE_TYPE_GPU = (1 shl 2);
CL_DEVICE_TYPE_ACCELERATOR = (1 shl 3);
CL_DEVICE_TYPE_ALL = $FFFFFFFF;
CL_DEVICE_TYPE = $1000;
CL_DEVICE_VENDOR_ID = $1001;
CL_DEVICE_MAX_COMPUTE_UNITS = $1002;
CL_DEVICE_MAX_WORK_ITEM_DIMENSIONS = $1003;
CL_DEVICE_MAX_WORK_GROUP_SIZE = $1004;
CL_DEVICE_MAX_WORK_ITEM_SIZES = $1005;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_CHAR = $1006;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_SHORT = $1007;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_INT = $1008;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_LONG = $1009;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_FLOAT = $100A;
CL_DEVICE_PREFERRED_VECTOR_WIDTH_DOUBLE = $100B;
CL_DEVICE_MAX_CLOCK_FREQUENCY = $100C;
CL_DEVICE_ADDRESS_BITS = $100D;
CL_DEVICE_MAX_READ_IMAGE_ARGS = $100E;
CL_DEVICE_MAX_WRITE_IMAGE_ARGS = $100F;
CL_DEVICE_MAX_MEM_ALLOC_SIZE = $1010;
CL_DEVICE_IMAGE2D_MAX_WIDTH = $1011;
CL_DEVICE_IMAGE2D_MAX_HEIGHT = $1012;
CL_DEVICE_IMAGE3D_MAX_WIDTH = $1013;
CL_DEVICE_IMAGE3D_MAX_HEIGHT = $1014;
CL_DEVICE_IMAGE3D_MAX_DEPTH = $1015;
CL_DEVICE_IMAGE_SUPPORT = $1016;
CL_DEVICE_MAX_PARAMETER_SIZE = $1017;
CL_DEVICE_MAX_SAMPLERS = $1018;
CL_DEVICE_MEM_BASE_ADDR_ALIGN = $1019;
CL_DEVICE_MIN_DATA_TYPE_ALIGN_SIZE = $101A;
CL_DEVICE_SINGLE_FP_CONFIG = $101B;
CL_DEVICE_GLOBAL_MEM_CACHE_TYPE = $101C;
CL_DEVICE_GLOBAL_MEM_CACHELINE_SIZE = $101D;
CL_DEVICE_GLOBAL_MEM_CACHE_SIZE = $101E;
CL_DEVICE_GLOBAL_MEM_SIZE = $101F;
CL_DEVICE_MAX_CONSTANT_BUFFER_SIZE = $1020;
CL_DEVICE_MAX_CONSTANT_ARGS = $1021;
CL_DEVICE_LOCAL_MEM_TYPE = $1022;
CL_DEVICE_LOCAL_MEM_SIZE = $1023;
CL_DEVICE_ERROR_CORRECTION_SUPPORT = $1024;
CL_DEVICE_PROFILING_TIMER_RESOLUTION = $1025;
CL_DEVICE_ENDIAN_LITTLE = $1026;
CL_DEVICE_AVAILABLE = $1027;
CL_DEVICE_COMPILER_AVAILABLE = $1028;
CL_DEVICE_EXECUTION_CAPABILITIES = $1029;
CL_DEVICE_QUEUE_PROPERTIES = $102A;
CL_DEVICE_NAME = $102B;
CL_DEVICE_VENDOR = $102C;
CL_DRIVER_VERSION = $102D;
CL_DEVICE_PROFILE = $102E;
CL_DEVICE_VERSION = $102F;
CL_DEVICE_EXTENSIONS = $1030;
CL_DEVICE_PLATFORM = $1031;
CL_FP_DENORM = (1 shl 0);
CL_FP_INF_NAN = (1 shl 1);
CL_FP_ROUND_TO_NEAREST = (1 shl 2);
CL_FP_ROUND_TO_ZERO = (1 shl 3);
CL_FP_ROUND_TO_INF = (1 shl 4);
CL_FP_FMA = (1 shl 5);
CL_NONE = $0;
CL_READ_ONLY_CACHE = $1;
CL_READ_WRITE_CACHE = $2;
CL_LOCAL = $1;
CL_GLOBAL = $2;
CL_EXEC_KERNEL = (1 shl 0);
CL_EXEC_NATIVE_KERNEL = (1 shl 1);
CL_QUEUE_OUT_OF_ORDER_EXEC_MODE_ENABLE = (1 shl 0);
CL_QUEUE_PROFILING_ENABLE = (1 shl 1);
CL_CONTEXT_REFERENCE_COUNT = $1080;
CL_CONTEXT_DEVICES = $1081;
CL_CONTEXT_PROPERTIES = $1082;
CL_CONTEXT_PLATFORM = $1084;
CL_QUEUE_CONTEXT = $1090;
CL_QUEUE_DEVICE = $1091;
CL_QUEUE_REFERENCE_COUNT = $1092;
CL_QUEUE_PROPERTIES = $1093;
CL_MEM_READ_WRITE = (1 shl 0);
CL_MEM_WRITE_ONLY = (1 shl 1);
CL_MEM_READ_ONLY = (1 shl 2);
CL_MEM_USE_HOST_PTR = (1 shl 3);
CL_MEM_ALLOC_HOST_PTR = (1 shl 4);
CL_MEM_COPY_HOST_PTR = (1 shl 5);
CL_R = $10B0;
CL_A = $10B1;
CL_RG = $10B2;
CL_RA = $10B3;
CL_RGB = $10B4;
CL_RGBA = $10B5;
CL_BGRA = $10B6;
CL_ARGB = $10B7;
CL_INTENSITY = $10B8;
CL_LUMINANCE = $10B9;
CL_SNORM_INT8 = $10D0;
CL_SNORM_INT16 = $10D1;
CL_UNORM_INT8 = $10D2;
CL_UNORM_INT16 = $10D3;
CL_UNORM_SHORT_565 = $10D4;
CL_UNORM_SHORT_555 = $10D5;
CL_UNORM_INT_101010 = $10D6;
CL_SIGNED_INT8 = $10D7;
CL_SIGNED_INT16 = $10D8;
CL_SIGNED_INT32 = $10D9;
CL_UNSIGNED_INT8 = $10DA;
CL_UNSIGNED_INT16 = $10DB;
CL_UNSIGNED_INT32 = $10DC;
CL_HALF_FLOAT = $10DD;
CL_FLOAT = $10DE;
CL_MEM_OBJECT_BUFFER = $10F0;
CL_MEM_OBJECT_IMAGE2D = $10F1;
CL_MEM_OBJECT_IMAGE3D = $10F2;
CL_MEM_TYPE = $1100;
CL_MEM_FLAGS = $1101;
CL_MEM_SIZE = $1102;
CL_MEM_HOST_PTR = $1103;
CL_MEM_MAP_COUNT = $1104;
CL_MEM_REFERENCE_COUNT = $1105;
CL_MEM_CONTEXT = $1106;
CL_IMAGE_FORMAT = $1110;
CL_IMAGE_ELEMENT_SIZE = $1111;
CL_IMAGE_ROW_PITCH = $1112;
CL_IMAGE_SLICE_PITCH = $1113;
CL_IMAGE_WIDTH = $1114;
CL_IMAGE_HEIGHT = $1115;
CL_IMAGE_DEPTH = $1116;
CL_ADDRESS_NONE = $1130;
CL_ADDRESS_CLAMP_TO_EDGE = $1131;
CL_ADDRESS_CLAMP = $1132;
CL_ADDRESS_REPEAT = $1133;
CL_FILTER_NEAREST = $1140;
CL_FILTER_LINEAR = $1141;
CL_SAMPLER_REFERENCE_COUNT = $1150;
CL_SAMPLER_CONTEXT = $1151;
CL_SAMPLER_NORMALIZED_COORDS = $1152;
CL_SAMPLER_ADDRESSING_MODE = $1153;
CL_SAMPLER_FILTER_MODE = $1154;
CL_MAP_READ = (1 shl 0);
CL_MAP_WRITE = (1 shl 1);
CL_PROGRAM_REFERENCE_COUNT = $1160;
CL_PROGRAM_CONTEXT = $1161;
CL_PROGRAM_NUM_DEVICES = $1162;
CL_PROGRAM_DEVICES = $1163;
CL_PROGRAM_SOURCE = $1164;
CL_PROGRAM_BINARY_SIZES = $1165;
CL_PROGRAM_BINARIES = $1166;
CL_PROGRAM_BUILD_STATUS = $1181;
CL_PROGRAM_BUILD_OPTIONS = $1182;
CL_PROGRAM_BUILD_LOG = $1183;
CL_BUILD_SUCCESS = 0;
CL_BUILD_NONE = -1;
CL_BUILD_ERROR = -2;
CL_BUILD_IN_PROGRESS = -3;
CL_KERNEL_FUNCTION_NAME = $1190;
CL_KERNEL_NUM_ARGS = $1191;
CL_KERNEL_REFERENCE_COUNT = $1192;
CL_KERNEL_CONTEXT = $1193;
CL_KERNEL_PROGRAM = $1194;
CL_KERNEL_WORK_GROUP_SIZE = $11B0;
CL_KERNEL_COMPILE_WORK_GROUP_SIZE = $11B1;
CL_KERNEL_LOCAL_MEM_SIZE = $11B2;
CL_EVENT_COMMAND_QUEUE = $11D0;
CL_EVENT_COMMAND_TYPE = $11D1;
CL_EVENT_REFERENCE_COUNT = $11D2;
CL_EVENT_COMMAND_EXECUTION_STATUS = $11D3;
CL_COMMAND_NDRANGE_KERNEL = $11F0;
CL_COMMAND_TASK = $11F1;
CL_COMMAND_NATIVE_KERNEL = $11F2;
CL_COMMAND_READ_BUFFER = $11F3;
CL_COMMAND_WRITE_BUFFER = $11F4;
CL_COMMAND_COPY_BUFFER = $11F5;
CL_COMMAND_READ_IMAGE = $11F6;
CL_COMMAND_WRITE_IMAGE = $11F7;
CL_COMMAND_COPY_IMAGE = $11F8;
CL_COMMAND_COPY_IMAGE_TO_BUFFER = $11F9;
CL_COMMAND_COPY_BUFFER_TO_IMAGE = $11FA;
CL_COMMAND_MAP_BUFFER = $11FB;
CL_COMMAND_MAP_IMAGE = $11FC;
CL_COMMAND_UNMAP_MEM_OBJECT = $11FD;
CL_COMMAND_MARKER = $11FE;
CL_COMMAND_ACQUIRE_GL_OBJECTS = $11FF;
CL_COMMAND_RELEASE_GL_OBJECTS = $1200;
CL_COMPLETE = $0;
CL_RUNNING = $1;
CL_SUBMITTED = $2;
CL_QUEUED = $3;
CL_PROFILING_COMMAND_QUEUED = $1280;
CL_PROFILING_COMMAND_SUBMIT = $1281;
CL_PROFILING_COMMAND_START = $1282;
CL_PROFILING_COMMAND_END = $1283;

Variables

clGetPlatformIDs: function(num_entries: Tcl_uint; platforms: Pcl_platform_id; num_platforms: Pcl_uint): Tcl_int; stdcall;
clGetPlatformInfo: function(_platform: Tcl_platform_id; param_name: Tcl_platform_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clGetDeviceIDs: function(_platform: Tcl_platform_id; device_type: Tcl_device_type; num_entries: Tcl_uint; devices: Pcl_device_id; num_devices: Pcl_uint): Tcl_int; stdcall;
clGetDeviceInfo: function(device: Tcl_device_id; param_name: Tcl_device_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clCreateContext: function(properties: Pcl_context_properties; num_devices: Tcl_uint; devices: Pcl_device_id; pfn_notify: logging_fn; user_data: Pointer; errcode_ret: Pcl_int): Tcl_context; stdcall;
clCreateContextFromType: function(properties: Pcl_context_properties; device_type: Tcl_device_type; pfn_notify: logging_fn; user_data: Pointer; errcode_ret: Pcl_int): Tcl_context; stdcall;
clRetainContext: function(context: Tcl_context): Tcl_int; stdcall;
clReleaseContext: function(context: Tcl_context): Tcl_int; stdcall;
clGetContextInfo: function(context: Tcl_context; param_name: Tcl_context_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clCreateCommandQueue: function(context: Tcl_context; device: Tcl_device_id; properties: Tcl_command_queue_properties; errcode_ret: Pcl_int): Tcl_command_queue; stdcall;
clRetainCommandQueue: function(command_queue: Tcl_command_queue): Tcl_int; stdcall;
clReleaseCommandQueue: function(command_queue: Tcl_command_queue): Tcl_int; stdcall;
clGetCommandQueueInfo: function(command_queue: Tcl_command_queue; param_name: Tcl_command_queue_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clSetCommandQueueProperty: function(command_queue: Tcl_command_queue; properties: Tcl_command_queue_properties; enable: Tcl_bool; old_properties: Pcl_command_queue_properties): Tcl_int; stdcall;
clCreateBuffer: function(context: Tcl_context; flags: Tcl_mem_flags; size: TSize_t; host_ptr: Pointer; errcode_ret: Pcl_int): Tcl_mem; stdcall;
clCreateImage2D: function(context: Tcl_context; flags: Tcl_mem_flags; image_format: Pcl_image_format; image_width: TSize_t; image_height: TSize_t; image_row_pitch: TSize_t; host_ptr: Pointer; errcode_ret: Pcl_int): Tcl_mem; stdcall;
clCreateImage3D: function(context: Tcl_context; flags: Tcl_mem_flags; image_format: Pcl_image_format; image_width: TSize_t; image_height: TSize_t; image_depth: TSize_t; image_row_pitch: TSize_t; image_slice_pitch: TSize_t; host_ptr: Pointer; errcode_ret: Pcl_int): Tcl_mem; stdcall;
clRetainMemObject: function(memobj: Tcl_mem): Tcl_int; stdcall;
clReleaseMemObject: function(memobj: Tcl_mem): Tcl_int; stdcall;
clGetSupportedImageFormats: function(context: Tcl_context; flags: Tcl_mem_flags; image_type: Tcl_mem_object_type; num_entries: Tcl_uint; image_formats: Pcl_image_format; num_image_formats: Pcl_uint): Tcl_int; stdcall;
clGetMemObjectInfo: function(memobj: Tcl_mem; param_name: Tcl_mem_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clGetImageInfo: function(image: Tcl_mem; param_name: Tcl_image_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clCreateSampler: function(context: Tcl_context; normalized_coords: Tcl_bool; addressing_mode: Tcl_addressing_mode; filter_mode: Tcl_filter_mode; errcode_ret: Pcl_int): Tcl_sampler; stdcall;
clRetainSampler: function(sampler: Tcl_sampler): Tcl_int; stdcall;
clReleaseSampler: function(sampler: Tcl_sampler): Tcl_int; stdcall;
clGetSamplerInfo: function(sampler: Tcl_sampler; param_name: Tcl_sampler_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clCreateProgramWithSource: function(context: Tcl_context; count: Tcl_uint; strings: PPAnsiChar; lengths: PSize_t; errcode_ret: Pcl_int): Tcl_program; stdcall;
clCreateProgramWithBinary: function(context: Tcl_context; num_devices: Tcl_uint; device_list: Pcl_device_id; lengths: PSize_t; binaries: PPointer; binary_status: Pcl_int; errcode_ret: Pcl_int): Tcl_program; stdcall;
clRetainProgram: function(_program: Tcl_program): Tcl_int; stdcall;
clReleaseProgram: function(_program: Tcl_program): Tcl_int; stdcall;
clBuildProgram: function(_program: Tcl_program; num_devices: Tcl_uint; device_list: Pcl_device_id; options: PAnsiChar; pfn_notify: ProgramBuilt_notify_fn; user_data: Pointer): Tcl_int; stdcall;
clUnloadCompiler: function: Tcl_int; stdcall;
clGetProgramInfo: function(_program: Tcl_program; param_name: Tcl_program_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clGetProgramBuildInfo: function(_program: Tcl_program; device: Tcl_device_id; param_name: Tcl_program_build_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clCreateKernel: function(_program: Tcl_program; kernel_name: PAnsiChar; errcode_ret: Pcl_int): Tcl_kernel; stdcall;
clCreateKernelsInProgram: function(_program: Tcl_program; num_kernels: Tcl_uint; kernels: Pcl_kernel; num_kernels_ret: Pcl_uint): Tcl_int; stdcall;
clRetainKernel: function(kernel: Tcl_kernel): Tcl_int; stdcall;
clReleaseKernel: function(kernel: Tcl_kernel): Tcl_int; stdcall;
clSetKernelArg: function(kernel: Tcl_kernel; arg_index: Tcl_uint; arg_size: TSize_t; arg_value: Pointer): Tcl_int; stdcall;
clGetKernelInfo: function(kernel: Tcl_kernel; param_name: Tcl_kernel_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clGetKernelWorkGroupInfo: function(kernel: Tcl_kernel; device: Tcl_device_id; param_name: Tcl_kernel_work_group_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clWaitForEvents: function(num_events: Tcl_uint; event_list: Pcl_event): Tcl_int; stdcall;
clGetEventInfo: function(event: Tcl_event; param_name: Tcl_event_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clRetainEvent: function(event: Tcl_event): Tcl_int; stdcall;
clReleaseEvent: function(event: Tcl_event): Tcl_int; stdcall;
clGetEventProfilingInfo: function(event: Tcl_event; param_name: Tcl_profiling_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall;
clFlush: function(command_queue: Tcl_command_queue): Tcl_int; stdcall;
clFinish: function(command_queue: Tcl_command_queue): Tcl_int; stdcall;
clEnqueueReadBuffer: function(command_queue: Tcl_command_queue; buffer: Tcl_mem; blocking_read: Tcl_bool; offset: TSize_t; cb: TSize_t; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueWriteBuffer: function(command_queue: Tcl_command_queue; buffer: Tcl_mem; blocking_write: Tcl_bool; offset: TSize_t; cb: TSize_t; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueCopyBuffer: function(command_queue: Tcl_command_queue; src_buffer: Tcl_mem; dst_buffer: Tcl_mem; src_offset: TSize_t; dst_offset: TSize_t; cb: TSize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueReadImage: function(command_queue: Tcl_command_queue; image: Tcl_mem; blocking_read: Tcl_bool; origin: PSize_t; region: PSize_t; row_pitch: TSize_t; slice_pitch: TSize_t; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueWriteImage: function(command_queue: Tcl_command_queue; image: Tcl_mem; blocking_write: Tcl_bool; origin: PSize_t; region: PSize_t; input_row_pitch: TSize_t; input_slice_pitch: TSize_t; ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueCopyImage: function(command_queue: Tcl_command_queue; src_image: Tcl_mem; dst_image: Tcl_mem; src_origin: PSize_t; dst_origin: PSize_t; region: PSize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueCopyImageToBuffer: function(command_queue: Tcl_command_queue; src_image: Tcl_mem; dst_buffer: Tcl_mem; src_origin: PSize_t; region: PSize_t; dst_offset: TSize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueCopyBufferToImage: function(command_queue: Tcl_command_queue; src_buffer: Tcl_mem; dst_image: Tcl_mem; src_offset: TSize_t; dst_origin: PSize_t; region: PSize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueMapBuffer: function(command_queue: Tcl_command_queue; buffer: Tcl_mem; blocking_map: Tcl_bool; map_flags: Tcl_map_flags; offset: TSize_t; cb: TSize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event; errcode_ret: Pcl_int): Pointer; stdcall;
clEnqueueMapImage: function(command_queue: Tcl_command_queue; image: Tcl_mem; blocking_map: Tcl_bool; map_flags: Tcl_map_flags; origin: PSize_t; region: PSize_t; image_row_pitch: PSize_t; image_slice_pitch: PSize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event; errcode_ret: Pcl_int): Pointer; stdcall;
clEnqueueUnmapMemObject: function(command_queue: Tcl_command_queue; memobj: Tcl_mem; mapped_ptr: Pointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueNDRangeKernel: function(command_queue: Tcl_command_queue; kernel: Tcl_kernel; work_dim: Tcl_uint; global_work_offset: PSize_t; global_work_size: PSize_t; local_work_size: PSize_t; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueTask: function(command_queue: Tcl_command_queue; kernel: Tcl_kernel; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueNativeKernel: function(command_queue: Tcl_command_queue; user_func: EnqueueNativeKernel_user_func; args: Pointer; cb_args: TSize_t; num_mem_objects: Tcl_uint; mem_list: Pcl_mem; args_mem_loc: PPointer; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall;
clEnqueueMarker: function(command_queue: Tcl_command_queue; event: Pcl_event): Tcl_int; stdcall;
clEnqueueWaitForEvents: function(command_queue: Tcl_command_queue; num_events: Tcl_uint; event_list: Pcl_event): Tcl_int; stdcall;
clEnqueueBarrier: function(command_queue: Tcl_command_queue): Tcl_int; stdcall;
clGetExtensionFunctionAddress: function(func_name: PAnsiChar): Pointer; stdcall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:00


GLScene v.1.1.2: GLS_CL: record T_cl_platform_id

record T_cl_platform_id

Unit

GLS_CL

Declaration

type T_cl_platform_id = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:00


GLScene v.1.1.2: GLS_CL: record T_cl_device_id

record T_cl_device_id

Unit

GLS_CL

Declaration

type T_cl_device_id = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:00


GLScene v.1.1.2: GLS_CL: record T_cl_context

record T_cl_context

Unit

GLS_CL

Declaration

type T_cl_context = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:00


GLScene v.1.1.2: GLS_CL: record T_cl_command_queue

record T_cl_command_queue

Unit

GLS_CL

Declaration

type T_cl_command_queue = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:00


GLScene v.1.1.2: GLS_CL: record T_cl_mem

record T_cl_mem

Unit

GLS_CL

Declaration

type T_cl_mem = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:00


GLScene v.1.1.2: GLS_CL: record T_cl_program

record T_cl_program

Unit

GLS_CL

Declaration

type T_cl_program = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:00


GLScene v.1.1.2: GLS_CL: record T_cl_kernel

record T_cl_kernel

Unit

GLS_CL

Declaration

type T_cl_kernel = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:00


GLScene v.1.1.2: GLS_CL: record T_cl_event

record T_cl_event

Unit

GLS_CL

Declaration

type T_cl_event = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:00


GLScene v.1.1.2: GLS_CL: record T_cl_sampler

record T_cl_sampler

Unit

GLS_CL

Declaration

type T_cl_sampler = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:00


GLScene v.1.1.2: GLS_CL: record Tcl_image_format

record Tcl_image_format

Unit

GLS_CL

Declaration

type Tcl_image_format = record

Description

Overview

Fields

image_channel_order: Tcl_channel_order;
image_channel_data_type: Tcl_channel_type;

Description

Fields

image_channel_order: Tcl_channel_order;
image_channel_data_type: Tcl_channel_type;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:00


GLScene v.1.1.2: GLS_CL_GL

Unit GLS_CL_GL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Functions and Procedures

function clCreateFromGLBuffer(context: Tcl_context; flags: Tcl_mem_flags; bufobj: GLuint; errcode_ret: Pcl_int): Tcl_mem; stdcall; external LibOpenCL;
function clCreateFromGLTexture2D(context: Tcl_context; flags: Tcl_mem_flags; target: GLenum; miplevel: GLint; texture: GLuint; errcode_ret: Pcl_int): Tcl_mem; stdcall; external LibOpenCL;
function clCreateFromGLTexture3D(context: Tcl_context; flags: Tcl_mem_flags; target: GLenum; miplevel: GLint; texture: GLuint; errcode_ret: Pcl_int): Tcl_mem; stdcall; external LibOpenCL;
function clCreateFromGLRenderbuffer(context: Tcl_context; flags: Tcl_mem_flags; renderbuffer: GLuint; errcode_ret: Pcl_int): Tcl_mem; stdcall; external LibOpenCL;
function clGetGLObjectInfo(memobj: Tcl_mem; gl_object_type: Pcl_gl_object_type; gl_object_name: PGLuint): Tcl_int; stdcall; external LibOpenCL;
function clGetGLTextureInfo(memobj: Tcl_mem; param_name: Tcl_gl_texture_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueAcquireGLObjects(command_queue: Tcl_command_queue; num_objects: Tcl_uint; mem_objects: Pcl_mem; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueReleaseGLObjects(command_queue: Tcl_command_queue; num_objects: Tcl_uint; mem_objects: Pcl_mem; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

Types

Tcl_gl_object_type = Tcl_uint;
Pcl_gl_object_type = ˆTcl_gl_object_type;
Tcl_gl_texture_info = Tcl_uint;
Pcl_gl_texture_info = ˆTcl_gl_texture_info;
Tcl_gl_platform_info = Tcl_uint;
Pcl_gl_platform_info = ˆTcl_gl_platform_info;

Constants

CL_GL_OBJECT_BUFFER = $2000;
CL_GL_OBJECT_TEXTURE2D = $2001;
CL_GL_OBJECT_TEXTURE3D = $2002;
CL_GL_OBJECT_RENDERBUFFER = $2003;
CL_GL_TEXTURE_TARGET = $2004;
CL_GL_MIPMAP_LEVEL = $2005;

Description

Functions and Procedures

function clCreateFromGLBuffer(context: Tcl_context; flags: Tcl_mem_flags; bufobj: GLuint; errcode_ret: Pcl_int): Tcl_mem; stdcall; external LibOpenCL;
function clCreateFromGLTexture2D(context: Tcl_context; flags: Tcl_mem_flags; target: GLenum; miplevel: GLint; texture: GLuint; errcode_ret: Pcl_int): Tcl_mem; stdcall; external LibOpenCL;
function clCreateFromGLTexture3D(context: Tcl_context; flags: Tcl_mem_flags; target: GLenum; miplevel: GLint; texture: GLuint; errcode_ret: Pcl_int): Tcl_mem; stdcall; external LibOpenCL;
function clCreateFromGLRenderbuffer(context: Tcl_context; flags: Tcl_mem_flags; renderbuffer: GLuint; errcode_ret: Pcl_int): Tcl_mem; stdcall; external LibOpenCL;
function clGetGLObjectInfo(memobj: Tcl_mem; gl_object_type: Pcl_gl_object_type; gl_object_name: PGLuint): Tcl_int; stdcall; external LibOpenCL;
function clGetGLTextureInfo(memobj: Tcl_mem; param_name: Tcl_gl_texture_info; param_value_size: TSize_t; param_value: Pointer; param_value_size_ret: PSize_t): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueAcquireGLObjects(command_queue: Tcl_command_queue; num_objects: Tcl_uint; mem_objects: Pcl_mem; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;
function clEnqueueReleaseGLObjects(command_queue: Tcl_command_queue; num_objects: Tcl_uint; mem_objects: Pcl_mem; num_events_in_wait_list: Tcl_uint; event_wait_list: Pcl_event; event: Pcl_event): Tcl_int; stdcall; external LibOpenCL;

Types

Tcl_gl_object_type = Tcl_uint;
Pcl_gl_object_type = ˆTcl_gl_object_type;
Tcl_gl_texture_info = Tcl_uint;
Pcl_gl_texture_info = ˆTcl_gl_texture_info;
Tcl_gl_platform_info = Tcl_uint;
Pcl_gl_platform_info = ˆTcl_gl_platform_info;

Constants

CL_GL_OBJECT_BUFFER = $2000;
CL_GL_OBJECT_TEXTURE2D = $2001;
CL_GL_OBJECT_TEXTURE3D = $2002;
CL_GL_OBJECT_RENDERBUFFER = $2003;
CL_GL_TEXTURE_TARGET = $2004;
CL_GL_MIPMAP_LEVEL = $2005;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:00


GLScene v.1.1.2: GLS_CL_Platform

Unit GLS_CL_Platform

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Types

TSize_T = SizeInt;
Psize_t = PSizeInt;
intptr_t = PtrInt;
Tcl_char = ShortInt;
Tcl_uchar = Byte;
Tcl_short = SmallInt;
Tcl_ushort = Word;
Tcl_int = LongInt;
Tcl_uint = LongWord;
Tcl_long = Int64;
Tcl_ulong = UInt64;
Tcl_half = Word;
Tcl_float = Single;
Tcl_double = Double;
Pcl_char = ˆTcl_char;
Pcl_uchar = ˆTcl_uchar;
Pcl_short = ˆTcl_short;
Pcl_ushort = ˆTcl_ushort;
Pcl_int = ˆTcl_int;
Pcl_uint = ˆTcl_uint;
Pcl_long = ˆTcl_long;
Pcl_ulong = ˆTcl_ulong;
Pcl_half = ˆTcl_half;
Pcl_float = ˆTcl_float;
Pcl_double = ˆTcl_double;
Tcl_char2 = array [0 .. 1] of Tcl_char;
Tcl_char4 = array [0 .. 3] of Tcl_char;
Tcl_char8 = array [0 .. 7] of Tcl_char;
Tcl_char16 = array [0 .. 15] of Tcl_char;
Tcl_uchar2 = array [0 .. 1] of Tcl_uchar;
Tcl_uchar4 = array [0 .. 3] of Tcl_uchar;
Tcl_uchar8 = array [0 .. 7] of Tcl_uchar;
Tcl_uchar16 = array [0 .. 15] of Tcl_uchar;
Tcl_short2 = array [0 .. 1] of Tcl_short;
Tcl_short4 = array [0 .. 3] of Tcl_short;
Tcl_short8 = array [0 .. 7] of Tcl_short;
Tcl_short16 = array [0 .. 15] of Tcl_short;
Tcl_ushort2 = array [0 .. 1] of Tcl_ushort;
Tcl_ushort4 = array [0 .. 3] of Tcl_ushort;
Tcl_ushort8 = array [0 .. 7] of Tcl_ushort;
Tcl_ushort16 = array [0 .. 15] of Tcl_ushort;
Tcl_int2 = array [0 .. 1] of Tcl_int;
Tcl_int4 = array [0 .. 3] of Tcl_int;
Tcl_int8 = array [0 .. 7] of Tcl_int;
Tcl_int16 = array [0 .. 15] of Tcl_int;
Tcl_uint2 = array [0 .. 1] of Tcl_uint;
Tcl_uint4 = array [0 .. 3] of Tcl_uint;
Tcl_uint8 = array [0 .. 7] of Tcl_uint;
Tcl_uint16 = array [0 .. 15] of Tcl_uint;
Tcl_long2 = array [0 .. 1] of Tcl_long;
Tcl_long4 = array [0 .. 3] of Tcl_long;
Tcl_long8 = array [0 .. 7] of Tcl_long;
Tcl_long16 = array [0 .. 15] of Tcl_long;
Tcl_ulong2 = array [0 .. 1] of Tcl_ulong;
Tcl_ulong4 = array [0 .. 3] of Tcl_ulong;
Tcl_ulong8 = array [0 .. 7] of Tcl_ulong;
Tcl_ulong16 = array [0 .. 15] of Tcl_ulong;
Tcl_float2 = array [0 .. 1] of Tcl_float;
Tcl_float4 = array [0 .. 3] of Tcl_float;
Tcl_float8 = array [0 .. 7] of Tcl_float;
Tcl_float16 = array [0 .. 15] of Tcl_float;
Tcl_double2 = array [0 .. 1] of Tcl_double;
Tcl_double4 = array [0 .. 3] of Tcl_double;
Tcl_double8 = array [0 .. 7] of Tcl_double;
Tcl_double16 = array [0 .. 15] of Tcl_double;

Constants

CL_CHAR_BIT = 8;
CL_SCHAR_MAX = 127;
CL_SCHAR_MIN = (-127 - 1);
CL_CHAR_MAX = CL_SCHAR_MAX;
CL_CHAR_MIN = CL_SCHAR_MIN;
CL_UCHAR_MAX = 255;
CL_SHRT_MAX = 32767;
CL_SHRT_MIN = (-32767 - 1);
CL_USHRT_MAX = 65535;
CL_INT_MAX = 2147483647;
CL_INT_MIN = (-2147483647 - 1);
CL_UINT_MAX = $FFFFFFFF;
CL_LONG_MAX = $7FFFFFFFFFFFFFFF;
CL_LONG_MIN = -$7FFFFFFFFFFFFFFF - 1;
CL_ULONG_MAX = $FFFFFFFFFFFFFFFF;
CL_FLT_DIG = 6;
CL_FLT_MANT_DIG = 24;
CL_FLT_MAX_10_EXP = +38;
CL_FLT_MAX_EXP = +128;
CL_FLT_MIN_10_EXP = -37;
CL_FLT_MIN_EXP = -125;
CL_FLT_RADIX = 2;
CL_FLT_MAX = 1.7E38;
CL_FLT_MIN = 1.17E-38;
CL_FLT_EPSILON = 1.0E-7;
CL_DBL_DIG = 15;
CL_DBL_MANT_DIG = 53;
CL_DBL_MAX_10_EXP = +308;
CL_DBL_MAX_EXP = +1024;
CL_DBL_MIN_10_EXP = -307;
CL_DBL_MIN_EXP = -1021;
CL_DBL_RADIX = 2;
CL_DBL_MAX = 8.98E307;
CL_DBL_MIN = 2.2E-308;
CL_DBL_EPSILON = 2.2E-26;

Description

Types

TSize_T = SizeInt;
Psize_t = PSizeInt;
intptr_t = PtrInt;
Tcl_char = ShortInt;
Tcl_uchar = Byte;
Tcl_short = SmallInt;
Tcl_ushort = Word;
Tcl_int = LongInt;
Tcl_uint = LongWord;
Tcl_long = Int64;
Tcl_ulong = UInt64;
Tcl_half = Word;
Tcl_float = Single;
Tcl_double = Double;
Pcl_char = ˆTcl_char;
Pcl_uchar = ˆTcl_uchar;
Pcl_short = ˆTcl_short;
Pcl_ushort = ˆTcl_ushort;
Pcl_int = ˆTcl_int;
Pcl_uint = ˆTcl_uint;
Pcl_long = ˆTcl_long;
Pcl_ulong = ˆTcl_ulong;
Pcl_half = ˆTcl_half;
Pcl_float = ˆTcl_float;
Pcl_double = ˆTcl_double;
Tcl_char2 = array [0 .. 1] of Tcl_char;
Tcl_char4 = array [0 .. 3] of Tcl_char;
Tcl_char8 = array [0 .. 7] of Tcl_char;
Tcl_char16 = array [0 .. 15] of Tcl_char;
Tcl_uchar2 = array [0 .. 1] of Tcl_uchar;
Tcl_uchar4 = array [0 .. 3] of Tcl_uchar;
Tcl_uchar8 = array [0 .. 7] of Tcl_uchar;
Tcl_uchar16 = array [0 .. 15] of Tcl_uchar;
Tcl_short2 = array [0 .. 1] of Tcl_short;
Tcl_short4 = array [0 .. 3] of Tcl_short;
Tcl_short8 = array [0 .. 7] of Tcl_short;
Tcl_short16 = array [0 .. 15] of Tcl_short;
Tcl_ushort2 = array [0 .. 1] of Tcl_ushort;
Tcl_ushort4 = array [0 .. 3] of Tcl_ushort;
Tcl_ushort8 = array [0 .. 7] of Tcl_ushort;
Tcl_ushort16 = array [0 .. 15] of Tcl_ushort;
Tcl_int2 = array [0 .. 1] of Tcl_int;
Tcl_int4 = array [0 .. 3] of Tcl_int;
Tcl_int8 = array [0 .. 7] of Tcl_int;
Tcl_int16 = array [0 .. 15] of Tcl_int;
Tcl_uint2 = array [0 .. 1] of Tcl_uint;
Tcl_uint4 = array [0 .. 3] of Tcl_uint;
Tcl_uint8 = array [0 .. 7] of Tcl_uint;
Tcl_uint16 = array [0 .. 15] of Tcl_uint;
Tcl_long2 = array [0 .. 1] of Tcl_long;
Tcl_long4 = array [0 .. 3] of Tcl_long;
Tcl_long8 = array [0 .. 7] of Tcl_long;
Tcl_long16 = array [0 .. 15] of Tcl_long;
Tcl_ulong2 = array [0 .. 1] of Tcl_ulong;
Tcl_ulong4 = array [0 .. 3] of Tcl_ulong;
Tcl_ulong8 = array [0 .. 7] of Tcl_ulong;
Tcl_ulong16 = array [0 .. 15] of Tcl_ulong;
Tcl_float2 = array [0 .. 1] of Tcl_float;
Tcl_float4 = array [0 .. 3] of Tcl_float;
Tcl_float8 = array [0 .. 7] of Tcl_float;
Tcl_float16 = array [0 .. 15] of Tcl_float;
Tcl_double2 = array [0 .. 1] of Tcl_double;
Tcl_double4 = array [0 .. 3] of Tcl_double;
Tcl_double8 = array [0 .. 7] of Tcl_double;
Tcl_double16 = array [0 .. 15] of Tcl_double;

Constants

CL_CHAR_BIT = 8;
CL_SCHAR_MAX = 127;
CL_SCHAR_MIN = (-127 - 1);
CL_CHAR_MAX = CL_SCHAR_MAX;
CL_CHAR_MIN = CL_SCHAR_MIN;
CL_UCHAR_MAX = 255;
CL_SHRT_MAX = 32767;
CL_SHRT_MIN = (-32767 - 1);
CL_USHRT_MAX = 65535;
CL_INT_MAX = 2147483647;
CL_INT_MIN = (-2147483647 - 1);
CL_UINT_MAX = $FFFFFFFF;
CL_LONG_MAX = $7FFFFFFFFFFFFFFF;
CL_LONG_MIN = -$7FFFFFFFFFFFFFFF - 1;
CL_ULONG_MAX = $FFFFFFFFFFFFFFFF;
CL_FLT_DIG = 6;
CL_FLT_MANT_DIG = 24;
CL_FLT_MAX_10_EXP = +38;
CL_FLT_MAX_EXP = +128;
CL_FLT_MIN_10_EXP = -37;
CL_FLT_MIN_EXP = -125;
CL_FLT_RADIX = 2;
CL_FLT_MAX = 1.7E38;
CL_FLT_MIN = 1.17E-38;
CL_FLT_EPSILON = 1.0E-7;
CL_DBL_DIG = 15;
CL_DBL_MANT_DIG = 53;
CL_DBL_MAX_10_EXP = +308;
CL_DBL_MAX_EXP = +1024;
CL_DBL_MIN_10_EXP = -307;
CL_DBL_MIN_EXP = -1021;
CL_DBL_RADIX = 2;
CL_DBL_MAX = 8.98E307;
CL_DBL_MIN = 2.2E-308;
CL_DBL_EPSILON = 2.2E-26;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:00


GLScene v.1.1.2: GLS_CUDA_API

Unit GLS_CUDA_API

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TCUcontext |
record TCUmodule |
record TCUfunction |
record TCUarray |
record TCUtexref |
record TCUevent |
record TCUstream |
record TCUgraphicsResource |
record TCUdevprop |
record TcudaFuncAttributes |
record TCUDA_MEMCPY2D |
record TCUDA_MEMCPY3D |
record TCUDA_ARRAY_DESCRIPTOR |
record TCUDA_ARRAY3D_DESCRIPTOR |

Functions and Procedures

function InitCUDA: Boolean;
procedure CloseCUDA;
function InitCUDAFromLibrary(const LibName: WideString): Boolean;
function IsCUDAInitialized: Boolean;
function Get_CUDA_API_Error_String(AError: TCUresult): string;

Types

TCUdeviceptr = Pointer;
TCUdevice = Integer;
PCUcontext = ˆTCUcontext;
PCUmodule = ˆTCUmodule;
PCUfunction = ˆTCUfunction;
PCUarray = ˆTCUarray;
PCUtexref = ˆTCUtexref;
PCUevent = ˆTCUevent;
PCUstream = ˆTCUstream;
PPCUgraphicsResource = ˆPCUgraphicsResource;
PCUgraphicsResource = ˆTCUgraphicsResource;
TCUctx_flags = (...);
TCUevent_flags = (...);
TCUarray_format = (...);
TCUaddress_mode = (...);
TCUfilter_mode = (...);
TCUdevice_attribute = (...);
TcudaLimit = (...);
TCUfunction_attribute = (...);
TCUmemorytype = (...);
TCUcomputemode = (...);
TCUjit_option = (...);
TCUjit_target = (...);
TCUjit_fallback = (...);
TCUgraphicsRegisterFlags = (...);
TCUgraphicsMapResourceFlags = (...);
TCUarray_cubemap_face = (...);
TcudaFuncCache = (...);
TCUresult = type Cardinal;
PCUDA_MEMCPY2D = ˆTCUDA_MEMCPY2D;
PCUDA_ARRAY_DESCRIPTOR = ˆTCUDA_ARRAY_DESCRIPTOR;
TCUGLmap_flags = (...);
TDim3 = array [0 .. 2] of LongWord;
HGPUNV = Pointer;
TcuInit = function(Flags: Cardinal): TCUresult; stdcall;
TcuDriverGetVersion = function(out driverVersion: Integer): TCUresult; stdcall;
TcuDeviceGet = function(var device: TCUdevice; ordinal: Integer): TCUresult; stdcall;
TcuDeviceGetCount = function(var count: Integer): TCUresult; stdcall;
TcuDeviceGetName = function(name: PAnsiChar; len: Integer; dev: TCUdevice) : TCUresult; stdcall;
TcuDeviceComputeCapability = function(var major: Integer; var minor: Integer; dev: TCUdevice): TCUresult; stdcall;
TcuDeviceTotalMem = function(bytes: PSize_t; dev: TCUdevice): TCUresult; stdcall;
TcuDeviceGetProperties = function(var prop: TCUdevprop; dev: TCUdevice) : TCUresult; stdcall;
TcuDeviceGetAttribute = function(pi: PSize_t; attrib: TCUdevice_attribute; dev: TCUdevice): TCUresult; stdcall;
TcuCtxCreate = function(var pctx: PCUcontext; Flags: Cardinal; dev: TCUdevice) : TCUresult; stdcall;
TcuCtxDestroy = function(ctx: PCUcontext): TCUresult; stdcall;
TcuCtxAttach = function(var pctx: PCUcontext; Flags: Cardinal): TCUresult; stdcall;
TcuCtxDetach = function(ctx: PCUcontext): TCUresult; stdcall;
TcuCtxPushCurrent = function(ctx: PCUcontext): TCUresult; stdcall;
TcuCtxPopCurrent = function(var pctx: PCUcontext): TCUresult; stdcall;
TcuCtxGetDevice = function(var device: TCUdevice): TCUresult; stdcall;
TcuCtxSynchronize = function: TCUresult; stdcall;
TcuModuleLoad = function(var module: PCUmodule; const fname: PAnsiChar) : TCUresult; stdcall;
TcuModuleLoadData = function(var module: PCUmodule; const image: PAnsiChar) : TCUresult; stdcall;
TcuModuleLoadDataEx = function(var module: PCUmodule; var image; numOptions: Cardinal; var options: TCUjit_option; var optionValues) : TCUresult; stdcall;
TcuModuleLoadFatBinary = function(var module: PCUmodule; var fatCubin) : TCUresult; stdcall;
TcuModuleUnload = function(hmod: PCUmodule): TCUresult; stdcall;
TcuModuleGetFunction = function(out hfunc: PCUfunction; hmod: PCUmodule; const name: PAnsiChar): TCUresult; stdcall;
TcuModuleGetGlobal = function(out dptr: TCUdeviceptr; var bytes: Cardinal; hmod: PCUmodule; const name: PAnsiChar): TCUresult; stdcall;
TcuModuleGetTexRef = function(out pTexRef: PCUtexref; hmod: PCUmodule; const name: PAnsiChar): TCUresult; stdcall;
TcuMemGetInfo = function(var free: Cardinal; var total: Cardinal): TCUresult; stdcall;
TcuMemAlloc = function(var dptr: TCUdeviceptr; bytesize: Cardinal): TCUresult; stdcall;
TcuMemAllocPitch = function(var dptr: TCUdeviceptr; var pPitch: Cardinal; WidthInBytes: Cardinal; Height: Cardinal; ElementSizeBytes: Cardinal) : TCUresult; stdcall;
TcuMemFree = function(dptr: TCUdeviceptr): TCUresult; stdcall;
TcuMemGetAddressRange = function(var pbase: TCUdeviceptr; var psize: Cardinal; dptr: TCUdeviceptr): TCUresult; stdcall;
TcuMemAllocHost = function(var pp; bytesize: Cardinal): TCUresult; stdcall;
TcuMemFreeHost = function(p: Pointer): TCUresult; stdcall;
TcuMemHostAlloc = function(var pp: Pointer; bytesize: Cardinal; Flags: Cardinal) : TCUresult; stdcall;
TcuMemHostGetDevicePointer = function(var pdptr: TCUdeviceptr; p: Pointer; Flags: Cardinal): TCUresult; stdcall;
TcuMemHostGetFlags = function(var pFlags: Cardinal; var p): TCUresult; stdcall;
TcuMemcpyHtoD = function(dstDevice: TCUdeviceptr; const srcHost: Pointer; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyDtoH = function(const dstHost: Pointer; srcDevice: TCUdeviceptr; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyDtoD = function(dstDevice: TCUdeviceptr; srcDevice: TCUdeviceptr; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyDtoDAsync = function(dstDevice: TCUdeviceptr; srcDevice: TCUdeviceptr; ByteCount: Cardinal; hStream: PCUstream) : TCUresult; stdcall;
TcuMemcpyDtoA = function(dstArray: PCUarray; dstIndex: Cardinal; srcDevice: TCUdeviceptr; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyAtoD = function(dstDevice: TCUdeviceptr; hSrc: PCUarray; SrcIndex: Cardinal; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyHtoA = function(dstArray: PCUarray; dstIndex: Cardinal; pSrc: Pointer; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyAtoH = function(dstHost: Pointer; srcArray: PCUarray; SrcIndex: Cardinal; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyAtoA = function(dstArray: PCUarray; dstIndex: Cardinal; srcArray: PCUarray; SrcIndex: Cardinal; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpy2D = function(const pCopy: PCUDA_MEMCPY2D): TCUresult; stdcall;
TcuMemcpy2DUnaligned = function(var pCopy: TCUDA_MEMCPY2D): TCUresult; stdcall;
TcuMemcpy3D = function(var pCopy: TCUDA_MEMCPY3D): TCUresult; stdcall;
TcuMemcpyHtoDAsync = function(dstDevice: TCUdeviceptr; var srcHost; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuMemcpyDtoHAsync = function(var dstHost; srcDevice: TCUdeviceptr; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuMemcpyHtoAAsync = function(dstArray: PCUarray; dstIndex: Cardinal; var pSrc; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuMemcpyAtoHAsync = function(var dstHost; srcArray: PCUstream; SrcIndex: Cardinal; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuMemcpy2DAsync = function(var pCopy: TCUDA_MEMCPY2D; hStream: PCUstream) : TCUresult; stdcall;
TcuMemcpy3DAsync = function(var pCopy: TCUDA_MEMCPY3D; hStream: PCUstream) : TCUresult; stdcall;
TcuMemsetD8 = function(dstDevice: TCUdeviceptr; ub: Byte; N: Cardinal) : TCUresult; stdcall;
TcuMemsetD16 = function(dstDevice: TCUdeviceptr; uw: Word; N: Cardinal) : TCUresult; stdcall;
TcuMemsetD32 = function(dstDevice: TCUdeviceptr; ui: Cardinal; N: Cardinal) : TCUresult; stdcall;
TcuMemsetD2D8 = function(dstDevice: TCUdeviceptr; dstPitch: Cardinal; ub: Byte; Width: Cardinal; Height: Cardinal): TCUresult; stdcall;
TcuMemsetD2D16 = function(dstDevice: TCUdeviceptr; dstPitch: Cardinal; uw: Word; Width: Cardinal; Height: Cardinal): TCUresult; stdcall;
TcuMemsetD2D32 = function(dstDevice: TCUdeviceptr; dstPitch: Cardinal; ui: Cardinal; Width: Cardinal; Height: Cardinal): TCUresult; stdcall;
TcuFuncSetBlockShape = function(hfunc: PCUfunction; x: Integer; y: Integer; z: Integer): TCUresult; stdcall;
TcuFuncSetSharedSize = function(hfunc: PCUfunction; bytes: Cardinal) : TCUresult; stdcall;
TcuFuncGetAttribute = function(var pi: Integer; attrib: TCUfunction_attribute; hfunc: PCUfunction): TCUresult; stdcall;
TcuArrayCreate = function(var pHandle: PCUarray; var pAllocateArray: TCUDA_ARRAY_DESCRIPTOR): TCUresult; stdcall;
TcuArrayGetDescriptor = function(var pArrayDescriptor: TCUDA_ARRAY_DESCRIPTOR; hArray: PCUarray): TCUresult; stdcall;
TcuArrayDestroy = function(hArray: PCUarray): TCUresult; stdcall;
TcuArray3DCreate = function(var pHandle: PCUarray; var pAllocateArray: TCUDA_ARRAY3D_DESCRIPTOR): TCUresult; stdcall;
TcuArray3DGetDescriptor = function(var pArrayDescriptor : TCUDA_ARRAY3D_DESCRIPTOR; hArray: PCUarray): TCUresult; stdcall;
TcuTexRefCreate = function(var pTexRef: PCUtexref): TCUresult; stdcall;
TcuTexRefDestroy = function(hTexRef: PCUtexref): TCUresult; stdcall;
TcuTexRefSetArray = function(hTexRef: PCUtexref; hArray: PCUarray; Flags: Cardinal): TCUresult; stdcall;
TcuTexRefSetAddress = function(var ByteOffset: Cardinal; hTexRef: PCUtexref; dptr: TCUdeviceptr; bytes: Cardinal): TCUresult; stdcall;
TcuTexRefSetAddress2D = function(hTexRef: PCUtexref; var desc: TCUDA_ARRAY_DESCRIPTOR; dptr: TCUdeviceptr; Pitch: Cardinal) : TCUresult; stdcall;
TcuTexRefSetFormat = function(hTexRef: PCUtexref; fmt: TCUarray_format; NumPackedComponents: Integer): TCUresult; stdcall;
TcuTexRefSetAddressMode = function(hTexRef: PCUtexref; dim: Integer; am: TCUaddress_mode): TCUresult; stdcall;
TcuTexRefSetFilterMode = function(hTexRef: PCUtexref; fm: TCUfilter_mode) : TCUresult; stdcall;
TcuTexRefSetFlags = function(hTexRef: PCUtexref; Flags: Cardinal): TCUresult; stdcall;
TcuTexRefGetAddress = function(var pdptr: TCUdeviceptr; hTexRef: PCUtexref) : TCUresult; stdcall;
TcuTexRefGetArray = function(var phArray: PCUarray; hTexRef: PCUtexref) : TCUresult; stdcall;
TcuTexRefGetAddressMode = function(var pam: TCUaddress_mode; hTexRef: PCUtexref; dim: Integer): TCUresult; stdcall;
TcuTexRefGetFilterMode = function(var pfm: TCUfilter_mode; hTexRef: PCUtexref) : TCUresult; stdcall;
TcuTexRefGetFormat = function(var pFormat: TCUarray_format; var pNumChannels: Integer; hTexRef: PCUtexref): TCUresult; stdcall;
TcuTexRefGetFlags = function(var pFlags: Cardinal; hTexRef: PCUtexref) : TCUresult; stdcall;
TcuParamSetSize = function(hfunc: PCUfunction; numbytes: Cardinal): TCUresult; stdcall;
TcuParamSeti = function(hfunc: PCUfunction; offset: Integer; value: Cardinal) : TCUresult; stdcall;
TcuParamSetf = function(hfunc: PCUfunction; offset: Integer; value: Single) : TCUresult; stdcall;
TcuParamSetv = function(hfunc: PCUfunction; offset: Integer; var ptr; numbytes: Cardinal): TCUresult; stdcall;
TcuParamSetTexRef = function(hfunc: PCUfunction; texunit: Integer; hTexRef: PCUtexref): TCUresult; stdcall;
TcuLaunch = function(f: PCUfunction): TCUresult; stdcall;
TcuLaunchGrid = function(f: PCUfunction; grid_width: Integer; grid_height: Integer): TCUresult; stdcall;
TcuLaunchGridAsync = function(f: PCUfunction; grid_width: Integer; grid_height: Integer; hStream: PCUstream): TCUresult; stdcall;
TcuEventCreate = function(var phEvent: PCUevent; Flags: Cardinal): TCUresult; stdcall;
TcuEventRecord = function(hEvent: PCUevent; hStream: PCUstream): TCUresult; stdcall;
TcuEventQuery = function(hEvent: PCUevent): TCUresult; stdcall;
TcuEventSynchronize = function(hEvent: PCUevent): TCUresult; stdcall;
TcuEventDestroy = function(hEvent: PCUevent): TCUresult; stdcall;
TcuEventElapsedTime = function(var pMilliseconds: Single; hStart: PCUevent; hEnd: PCUevent): TCUresult; stdcall;
TcuStreamCreate = function(var phStream: PCUstream; Flags: Cardinal) : TCUresult; stdcall;
TcuStreamQuery = function(hStream: PCUstream): TCUresult; stdcall;
TcuStreamSynchronize = function(hStream: PCUstream): TCUresult; stdcall;
TcuStreamDestroy = function(hStream: PCUstream): TCUresult; stdcall;
TcuGLCtxCreate = function(var pctx: PCUcontext; Flags: Cardinal; device: TCUdevice): TCUresult; stdcall;
TcuGraphicsGLRegisterBuffer = function(var pCudaResource: PCUgraphicsResource; buffer: Cardinal; Flags: TCUgraphicsMapResourceFlags): TCUresult; stdcall;
TcuGraphicsGLRegisterImage = function(var pCudaResource: PCUgraphicsResource; image, target: Cardinal; Flags: TCUgraphicsMapResourceFlags): TCUresult; stdcall;
TcuWGLGetDevice = function(var pDevice: TCUdevice; hGpu: HGPUNV): TCUresult; stdcall;
TcuGraphicsUnregisterResource = function(resource: PCUgraphicsResource) : TCUresult; stdcall;
TcuGraphicsSubResourceGetMappedArray = function(var pArray: PCUarray; resource: PCUgraphicsResource; arrayIndex: Cardinal; mipLevel: Cardinal) : TCUresult; stdcall;
TcuGraphicsResourceGetMappedPointer = function(var pDevPtr: TCUdeviceptr; out psize: Cardinal; resource: PCUgraphicsResource): TCUresult; stdcall;
TcuGraphicsResourceSetMapFlags = function(resource: PCUgraphicsResource; Flags: Cardinal): TCUresult; stdcall;
TcuGraphicsMapResources = function(count: Cardinal; resources: PPCUgraphicsResource; hStream: PCUstream): TCUresult; stdcall;
TcuGraphicsUnmapResources = function(count: Cardinal; resources: PPCUgraphicsResource; hStream: PCUstream): TCUresult; stdcall;
TcuGLInit = procedure(); stdcall;
TcuGLRegisterBufferObject = function(buffer: Cardinal): TCUresult; stdcall;
TcuGLMapBufferObject = function(var dptr: TCUdeviceptr; var size: Cardinal; buffer: Cardinal): TCUresult; stdcall;
TcuGLUnmapBufferObject = function(buffer: Cardinal): TCUresult; stdcall;
TcuGLUnregisterBufferObject = function(buffer: Cardinal): TCUresult; stdcall;
TcuGLSetBufferObjectMapFlags = function(buffer: Cardinal; Flags: Cardinal) : TCUresult; stdcall;
TcuGLMapBufferObjectAsync = function(var dptr: TCUdeviceptr; var size: Cardinal; buffer: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuGLUnmapBufferObjectAsync = function(buffer: Cardinal; hStream: PCUstream) : TCUresult; stdcall;

Constants

CUDAAPIDLL = 'nvcuda.dll';
CUDA_SUCCESS: TCUresult = 0;
CUDA_ERROR_INVALID_VALUE = 1;
CUDA_ERROR_OUT_OF_MEMORY = 2;
CUDA_ERROR_NOT_INITIALIZED = 3;
CUDA_ERROR_DEINITIALIZED = 4;
CUDA_ERROR_NO_DEVICE = 100;
CUDA_ERROR_INVALID_DEVICE = 101;
CUDA_ERROR_INVALID_IMAGE = 200;
CUDA_ERROR_INVALID_CONTEXT = 201;
CUDA_ERROR_CONTEXT_ALREADY_CURRENT = 202;
CUDA_ERROR_MAP_FAILED = 205;
CUDA_ERROR_UNMAP_FAILED = 206;
CUDA_ERROR_ARRAY_IS_MAPPED = 207;
CUDA_ERROR_ALREADY_MAPPED = 208;
CUDA_ERROR_NO_BINARY_FOR_GPU = 209;
CUDA_ERROR_ALREADY_ACQUIRED = 210;
CUDA_ERROR_NOT_MAPPED = 211;
CUDA_ERROR_NOT_MAPPED_AS_ARRAY = 212;
CUDA_ERROR_NOT_MAPPED_AS_POINTER = 213;
CUDA_ERROR_INVALID_SOURCE = 300;
CUDA_ERROR_FILE_NOT_FOUND = 301;
CUDA_ERROR_INVALID_HANDLE = 400;
CUDA_ERROR_NOT_FOUND = 500;
CUDA_ERROR_NOT_READY = 600;
CUDA_ERROR_LAUNCH_FAILED = 700;
CUDA_ERROR_LAUNCH_OUT_OF_RESOURCES = 701;
CUDA_ERROR_LAUNCH_TIMEOUT = 702;
CUDA_ERROR_LAUNCH_INCOMPATIBLE_TEXTURING = 703;
CUDA_ERROR_POINTER_IS_64BIT = 800;
CUDA_ERROR_SIZE_IS_64BIT = 801;
CUDA_ERROR_UNKNOWN = 999;
CU_MEMHOSTALLOC_PORTABLE = $01;
CU_MEMHOSTALLOC_DEVICEMAP = $02;
CU_MEMHOSTALLOC_WRITECOMBINED = $04;
CU_TRSA_OVERRIDE_FORMAT = $01;
CU_TRSF_READ_AS_INTEGER = $01;
CU_TRSF_NORMALIZED_COORDINATES = $02;
CU_PARAM_TR_DEFAULT = -1;

Variables

cuInit: TcuInit;
cuDriverGetVersion: TcuDriverGetVersion;
cuDeviceGet: TcuDeviceGet;
cuDeviceGetCount: TcuDeviceGetCount;
cuDeviceGetName: TcuDeviceGetName;
cuDeviceComputeCapability: TcuDeviceComputeCapability;
cuDeviceTotalMem: TcuDeviceTotalMem;
cuDeviceGetProperties: TcuDeviceGetProperties;
cuDeviceGetAttribute: TcuDeviceGetAttribute;
cuCtxCreate: TcuCtxCreate;
cuCtxDestroy: TcuCtxDestroy;
cuCtxAttach: TcuCtxAttach;
cuCtxDetach: TcuCtxDetach;
cuCtxPushCurrent: TcuCtxPushCurrent;
cuCtxPopCurrent: TcuCtxPopCurrent;
cuCtxGetDevice: TcuCtxGetDevice;
cuCtxSynchronize: TcuCtxSynchronize;
cuModuleLoad: TcuModuleLoad;
cuModuleLoadData: TcuModuleLoadData;
cuModuleLoadDataEx: TcuModuleLoadDataEx;
cuModuleLoadFatBinary: TcuModuleLoadFatBinary;
cuModuleUnload: TcuModuleUnload;
cuModuleGetFunction: TcuModuleGetFunction;
cuModuleGetGlobal: TcuModuleGetGlobal;
cuModuleGetTexRef: TcuModuleGetTexRef;
cuMemGetInfo: TcuMemGetInfo;
cuMemAlloc: TcuMemAlloc;
cuMemAllocPitch: TcuMemAllocPitch;
cuMemFree: TcuMemFree;
cuMemGetAddressRange: TcuMemGetAddressRange;
cuMemAllocHost: TcuMemAllocHost;
cuMemFreeHost: TcuMemFreeHost;
cuMemHostAlloc: TcuMemHostAlloc;
cuMemHostGetDevicePointer: TcuMemHostGetDevicePointer;
cuMemHostGetFlags: TcuMemHostGetFlags;
cuMemcpyHtoD: TcuMemcpyHtoD;
cuMemcpyDtoH: TcuMemcpyDtoH;
cuMemcpyDtoD: TcuMemcpyDtoD;
cuMemcpyDtoDAsync: TcuMemcpyDtoDAsync;
cuMemcpyDtoA: TcuMemcpyDtoA;
cuMemcpyAtoD: TcuMemcpyAtoD;
cuMemcpyHtoA: TcuMemcpyHtoA;
cuMemcpyAtoH: TcuMemcpyAtoH;
cuMemcpyAtoA: TcuMemcpyAtoA;
cuMemcpy2D: TcuMemcpy2D;
cuMemcpy2DUnaligned: TcuMemcpy2DUnaligned;
cuMemcpy3D: TcuMemcpy3D;
cuMemcpyHtoDAsync: TcuMemcpyHtoDAsync;
cuMemcpyDtoHAsync: TcuMemcpyDtoHAsync;
cuMemcpyHtoAAsync: TcuMemcpyHtoAAsync;
cuMemcpyAtoHAsync: TcuMemcpyAtoHAsync;
cuMemcpy2DAsync: TcuMemcpy2DAsync;
cuMemcpy3DAsync: TcuMemcpy3DAsync;
cuMemsetD8: TcuMemsetD8;
cuMemsetD16: TcuMemsetD16;
cuMemsetD32: TcuMemsetD32;
cuMemsetD2D8: TcuMemsetD2D8;
cuMemsetD2D16: TcuMemsetD2D16;
cuMemsetD2D32: TcuMemsetD2D32;
cuFuncSetBlockShape: TcuFuncSetBlockShape;
cuFuncSetSharedSize: TcuFuncSetSharedSize;
cuFuncGetAttribute: TcuFuncGetAttribute;
cuArrayCreate: TcuArrayCreate;
cuArrayGetDescriptor: TcuArrayGetDescriptor;
cuArrayDestroy: TcuArrayDestroy;
cuArray3DCreate: TcuArray3DCreate;
cuArray3DGetDescriptor: TcuArray3DGetDescriptor;
cuTexRefCreate: TcuTexRefCreate;
cuTexRefDestroy: TcuTexRefDestroy;
cuTexRefSetArray: TcuTexRefSetArray;
cuTexRefSetAddress: TcuTexRefSetAddress;
cuTexRefSetAddress2D: TcuTexRefSetAddress2D;
cuTexRefSetFormat: TcuTexRefSetFormat;
cuTexRefSetAddressMode: TcuTexRefSetAddressMode;
cuTexRefSetFilterMode: TcuTexRefSetFilterMode;
cuTexRefSetFlags: TcuTexRefSetFlags;
cuTexRefGetAddress: TcuTexRefGetAddress;
cuTexRefGetArray: TcuTexRefGetArray;
cuTexRefGetAddressMode: TcuTexRefGetAddressMode;
cuTexRefGetFilterMode: TcuTexRefGetFilterMode;
cuTexRefGetFormat: TcuTexRefGetFormat;
cuTexRefGetFlags: TcuTexRefGetFlags;
cuParamSetSize: TcuParamSetSize;
cuParamSeti: TcuParamSeti;
cuParamSetf: TcuParamSetf;
cuParamSetv: TcuParamSetv;
cuParamSetTexRef: TcuParamSetTexRef;
cuLaunch: TcuLaunch;
cuLaunchGrid: TcuLaunchGrid;
cuLaunchGridAsync: TcuLaunchGridAsync;
cuEventCreate: TcuEventCreate;
cuEventRecord: TcuEventRecord;
cuEventQuery: TcuEventQuery;
cuEventSynchronize: TcuEventSynchronize;
cuEventDestroy: TcuEventDestroy;
cuEventElapsedTime: TcuEventElapsedTime;
cuStreamCreate: TcuStreamCreate;
cuStreamQuery: TcuStreamQuery;
cuStreamSynchronize: TcuStreamSynchronize;
cuStreamDestroy: TcuStreamDestroy;
cuGLInit: TcuGLInit;
cuGLCtxCreate: TcuGLCtxCreate;
cuGraphicsGLRegisterBuffer: TcuGraphicsGLRegisterBuffer;
cuGraphicsGLRegisterImage: TcuGraphicsGLRegisterImage;
cuWGLGetDevice: TcuWGLGetDevice;
cuGraphicsUnregisterResource: TcuGraphicsUnregisterResource;
cuGraphicsSubResourceGetMappedArray: TcuGraphicsSubResourceGetMappedArray;
cuGraphicsResourceGetMappedPointer: TcuGraphicsResourceGetMappedPointer;
cuGraphicsResourceSetMapFlags: TcuGraphicsResourceSetMapFlags;
cuGraphicsMapResources: TcuGraphicsMapResources;
cuGraphicsUnmapResources: TcuGraphicsUnmapResources;
cuGLRegisterBufferObject: TcuGLRegisterBufferObject;
cuGLMapBufferObject: TcuGLMapBufferObject;
cuGLUnmapBufferObject: TcuGLUnmapBufferObject;
cuGLUnregisterBufferObject: TcuGLUnregisterBufferObject;
cuGLSetBufferObjectMapFlags: TcuGLSetBufferObjectMapFlags;
cuGLMapBufferObjectAsync: TcuGLMapBufferObjectAsync;
cuGLUnmapBufferObjectAsync: TcuGLUnmapBufferObjectAsync;

Description

Functions and Procedures

function InitCUDA: Boolean;
procedure CloseCUDA;
function InitCUDAFromLibrary(const LibName: WideString): Boolean;
function IsCUDAInitialized: Boolean;
function Get_CUDA_API_Error_String(AError: TCUresult): string;

Types

TCUdeviceptr = Pointer;
TCUdevice = Integer;
PCUcontext = ˆTCUcontext;
PCUmodule = ˆTCUmodule;
PCUfunction = ˆTCUfunction;
PCUarray = ˆTCUarray;
PCUtexref = ˆTCUtexref;
PCUevent = ˆTCUevent;
PCUstream = ˆTCUstream;
PPCUgraphicsResource = ˆPCUgraphicsResource;
PCUgraphicsResource = ˆTCUgraphicsResource;
TCUctx_flags = (...);
Values
  • CU_CTX_SCHED_AUTO = 0:
  • CU_CTX_SCHED_SPIN = 1:
  • CU_CTX_SCHED_YIELD = 2:
  • CU_CTX_SCHED_MASK = 3:
  • CU_CTX_BLOCKING_SYNC = 4:
  • CU_CTX_MAP_HOST = 8:
  • CU_CTX_FLAGS_MASK = 15:
TCUevent_flags = (...);
Values
  • CU_EVENT_DEFAULT = 0:
  • CU_EVENT_BLOCKING_SYNC = 1:
TCUarray_format = (...);
Values
  • CU_AD_FORMAT_UNSIGNED_INT8 = $01:
  • CU_AD_FORMAT_UNSIGNED_INT16 = $02:
  • CU_AD_FORMAT_UNSIGNED_INT32 = $03:
  • CU_AD_FORMAT_SIGNED_INT8 = $08:
  • CU_AD_FORMAT_SIGNED_INT16 = $09:
  • CU_AD_FORMAT_SIGNED_INT32 = $0A:
  • CU_AD_FORMAT_HALF = $10:
  • CU_AD_FORMAT_FLOAT = $20:
TCUaddress_mode = (...);
Values
  • CU_TR_ADDRESS_MODE_WRAP = 0:
  • CU_TR_ADDRESS_MODE_CLAMP = 1:
  • CU_TR_ADDRESS_MODE_MIRROR = 2:
TCUfilter_mode = (...);
Values
  • CU_TR_FILTER_MODE_POINT = 0:
  • CU_TR_FILTER_MODE_LINEAR = 1:
TCUdevice_attribute = (...);
Values
  • CU_DEVICE_ATTRIBUTE_MAX_THREADS_PER_BLOCK = 1:
  • CU_DEVICE_ATTRIBUTE_MAX_BLOCK_DIM_X = 2:
  • CU_DEVICE_ATTRIBUTE_MAX_BLOCK_DIM_Y = 3:
  • CU_DEVICE_ATTRIBUTE_MAX_BLOCK_DIM_Z = 4:
  • CU_DEVICE_ATTRIBUTE_MAX_GRID_DIM_X = 5:
  • CU_DEVICE_ATTRIBUTE_MAX_GRID_DIM_Y = 6:
  • CU_DEVICE_ATTRIBUTE_MAX_GRID_DIM_Z = 7:
  • CU_DEVICE_ATTRIBUTE_MAX_SHARED_MEMORY_PER_BLOCK = 8:
  • CU_DEVICE_ATTRIBUTE_SHARED_MEMORY_PER_BLOCK = 8:
  • CU_DEVICE_ATTRIBUTE_TOTAL_CONSTANT_MEMORY = 9:
  • CU_DEVICE_ATTRIBUTE_WARP_SIZE = 10:
  • CU_DEVICE_ATTRIBUTE_MAX_PITCH = 11:
  • CU_DEVICE_ATTRIBUTE_MAX_REGISTERS_PER_BLOCK = 12:
  • CU_DEVICE_ATTRIBUTE_REGISTERS_PER_BLOCK = 12:
  • CU_DEVICE_ATTRIBUTE_CLOCK_RATE = 13:
  • CU_DEVICE_ATTRIBUTE_TEXTURE_ALIGNMENT = 14:
  • CU_DEVICE_ATTRIBUTE_GPU_OVERLAP = 15:
  • CU_DEVICE_ATTRIBUTE_MULTIPROCESSOR_COUNT = 16:
  • CU_DEVICE_ATTRIBUTE_KERNEL_EXEC_TIMEOUT = 17:
  • CU_DEVICE_ATTRIBUTE_INTEGRATED = 18:
  • CU_DEVICE_ATTRIBUTE_CAN_MAP_HOST_MEMORY = 19:
  • CU_DEVICE_ATTRIBUTE_COMPUTE_MODE = 20:
TcudaLimit = (...);
Values
  • cudaLimitStackSize = $00:
  • cudaLimitPrintfFifoSize = $01:
TCUfunction_attribute = (...);
Values
  • CU_FUNC_ATTRIBUTE_MAX_THREADS_PER_BLOCK = 0:
  • CU_FUNC_ATTRIBUTE_SHARED_SIZE_BYTES = 1:
  • CU_FUNC_ATTRIBUTE_CONST_SIZE_BYTES = 2:
  • CU_FUNC_ATTRIBUTE_LOCAL_SIZE_BYTES = 3:
  • CU_FUNC_ATTRIBUTE_NUM_REGS = 4:
  • CU_FUNC_ATTRIBUTE_MAX:
TCUmemorytype = (...);
Values
  • CU_MEMORYTYPE_HOST = $01:
  • CU_MEMORYTYPE_DEVICE = $02:
  • CU_MEMORYTYPE_ARRAY = $03:
TCUcomputemode = (...);
Values
  • CU_COMPUTEMODE_DEFAULT = 0:
  • CU_COMPUTEMODE_EXCLUSIVE = 1:
  • CU_COMPUTEMODE_PROHIBITED = 2:
TCUjit_option = (...);
Values
  • CU_JIT_MAX_REGISTERS = 0:
  • CU_JIT_THREADS_PER_BLOCK:
  • CU_JIT_WALL_TIME:
  • CU_JIT_INFO_LOG_BUFFER:
  • CU_JIT_INFO_LOG_BUFFER_SIZE_BYTES:
  • CU_JIT_ERROR_LOG_BUFFER:
  • CU_JIT_ERROR_LOG_BUFFER_SIZE_BYTES:
  • CU_JIT_OPTIMIZATION_LEVEL:
  • CU_JIT_TARGET_FROM_CUCONTEXT:
  • CU_JIT_TARGET:
  • CU_JIT_FALLBACK_STRATEGY:
TCUjit_target = (...);
Values
  • CU_TARGET_COMPUTE_10 = 0:
  • CU_TARGET_COMPUTE_11:
  • CU_TARGET_COMPUTE_12:
  • CU_TARGET_COMPUTE_13:
TCUjit_fallback = (...);
Values
  • CU_PREFER_PTX = 0:
  • CU_PREFER_BINARY:
TCUgraphicsRegisterFlags = (...);
Values
  • CU_GRAPHICS_REGISTER_FLAGS_NONE = $00000000:
TCUgraphicsMapResourceFlags = (...);
Values
  • CU_GRAPHICS_MAP_RESOURCE_FLAGS_NONE = $00000000:
  • CU_GRAPHICS_MAP_RESOURCE_FLAGS_READ_ONLY = $00000001:
  • CU_GRAPHICS_MAP_RESOURCE_FLAGS_WRITE_DISCARD = $00000002:
TCUarray_cubemap_face = (...);
Values
  • CU_CUBEMAP_FACE_POSITIVE_X = $00000000:
  • CU_CUBEMAP_FACE_NEGATIVE_X = $00000001:
  • CU_CUBEMAP_FACE_POSITIVE_Y = $00000002:
  • CU_CUBEMAP_FACE_NEGATIVE_Y = $00000003:
  • CU_CUBEMAP_FACE_POSITIVE_Z = $00000004:
  • CU_CUBEMAP_FACE_NEGATIVE_Z = $00000005:
TcudaFuncCache = (...);
Values
  • cudaFuncCachePreferNone = 0:
  • cudaFuncCachePreferShared = 1:
  • cudaFuncCachePreferL1 = 2:
TCUresult = type Cardinal;
PCUDA_MEMCPY2D = ˆTCUDA_MEMCPY2D;
PCUDA_ARRAY_DESCRIPTOR = ˆTCUDA_ARRAY_DESCRIPTOR;
TCUGLmap_flags = (...);
Values
  • CU_GL_MAP_RESOURCE_FLAGS_NONE:
  • CU_GL_MAP_RESOURCE_FLAGS_READ_ONLY:
  • CU_GL_MAP_RESOURCE_FLAGS_WRITE_DISCARD:
TDim3 = array [0 .. 2] of LongWord;
HGPUNV = Pointer;
TcuInit = function(Flags: Cardinal): TCUresult; stdcall;
TcuDriverGetVersion = function(out driverVersion: Integer): TCUresult; stdcall;
TcuDeviceGet = function(var device: TCUdevice; ordinal: Integer): TCUresult; stdcall;
TcuDeviceGetCount = function(var count: Integer): TCUresult; stdcall;
TcuDeviceGetName = function(name: PAnsiChar; len: Integer; dev: TCUdevice) : TCUresult; stdcall;
TcuDeviceComputeCapability = function(var major: Integer; var minor: Integer; dev: TCUdevice): TCUresult; stdcall;
TcuDeviceTotalMem = function(bytes: PSize_t; dev: TCUdevice): TCUresult; stdcall;
TcuDeviceGetProperties = function(var prop: TCUdevprop; dev: TCUdevice) : TCUresult; stdcall;
TcuDeviceGetAttribute = function(pi: PSize_t; attrib: TCUdevice_attribute; dev: TCUdevice): TCUresult; stdcall;
TcuCtxCreate = function(var pctx: PCUcontext; Flags: Cardinal; dev: TCUdevice) : TCUresult; stdcall;
TcuCtxDestroy = function(ctx: PCUcontext): TCUresult; stdcall;
TcuCtxAttach = function(var pctx: PCUcontext; Flags: Cardinal): TCUresult; stdcall;
TcuCtxDetach = function(ctx: PCUcontext): TCUresult; stdcall;
TcuCtxPushCurrent = function(ctx: PCUcontext): TCUresult; stdcall;
TcuCtxPopCurrent = function(var pctx: PCUcontext): TCUresult; stdcall;
TcuCtxGetDevice = function(var device: TCUdevice): TCUresult; stdcall;
TcuCtxSynchronize = function: TCUresult; stdcall;
TcuModuleLoad = function(var module: PCUmodule; const fname: PAnsiChar) : TCUresult; stdcall;
TcuModuleLoadData = function(var module: PCUmodule; const image: PAnsiChar) : TCUresult; stdcall;
TcuModuleLoadDataEx = function(var module: PCUmodule; var image; numOptions: Cardinal; var options: TCUjit_option; var optionValues) : TCUresult; stdcall;
TcuModuleLoadFatBinary = function(var module: PCUmodule; var fatCubin) : TCUresult; stdcall;
TcuModuleUnload = function(hmod: PCUmodule): TCUresult; stdcall;
TcuModuleGetFunction = function(out hfunc: PCUfunction; hmod: PCUmodule; const name: PAnsiChar): TCUresult; stdcall;
TcuModuleGetGlobal = function(out dptr: TCUdeviceptr; var bytes: Cardinal; hmod: PCUmodule; const name: PAnsiChar): TCUresult; stdcall;
TcuModuleGetTexRef = function(out pTexRef: PCUtexref; hmod: PCUmodule; const name: PAnsiChar): TCUresult; stdcall;
TcuMemGetInfo = function(var free: Cardinal; var total: Cardinal): TCUresult; stdcall;
TcuMemAlloc = function(var dptr: TCUdeviceptr; bytesize: Cardinal): TCUresult; stdcall;
TcuMemAllocPitch = function(var dptr: TCUdeviceptr; var pPitch: Cardinal; WidthInBytes: Cardinal; Height: Cardinal; ElementSizeBytes: Cardinal) : TCUresult; stdcall;
TcuMemFree = function(dptr: TCUdeviceptr): TCUresult; stdcall;
TcuMemGetAddressRange = function(var pbase: TCUdeviceptr; var psize: Cardinal; dptr: TCUdeviceptr): TCUresult; stdcall;
TcuMemAllocHost = function(var pp; bytesize: Cardinal): TCUresult; stdcall;
TcuMemFreeHost = function(p: Pointer): TCUresult; stdcall;
TcuMemHostAlloc = function(var pp: Pointer; bytesize: Cardinal; Flags: Cardinal) : TCUresult; stdcall;
TcuMemHostGetDevicePointer = function(var pdptr: TCUdeviceptr; p: Pointer; Flags: Cardinal): TCUresult; stdcall;
TcuMemHostGetFlags = function(var pFlags: Cardinal; var p): TCUresult; stdcall;
TcuMemcpyHtoD = function(dstDevice: TCUdeviceptr; const srcHost: Pointer; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyDtoH = function(const dstHost: Pointer; srcDevice: TCUdeviceptr; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyDtoD = function(dstDevice: TCUdeviceptr; srcDevice: TCUdeviceptr; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyDtoDAsync = function(dstDevice: TCUdeviceptr; srcDevice: TCUdeviceptr; ByteCount: Cardinal; hStream: PCUstream) : TCUresult; stdcall;
TcuMemcpyDtoA = function(dstArray: PCUarray; dstIndex: Cardinal; srcDevice: TCUdeviceptr; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyAtoD = function(dstDevice: TCUdeviceptr; hSrc: PCUarray; SrcIndex: Cardinal; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyHtoA = function(dstArray: PCUarray; dstIndex: Cardinal; pSrc: Pointer; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyAtoH = function(dstHost: Pointer; srcArray: PCUarray; SrcIndex: Cardinal; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpyAtoA = function(dstArray: PCUarray; dstIndex: Cardinal; srcArray: PCUarray; SrcIndex: Cardinal; ByteCount: Cardinal): TCUresult; stdcall;
TcuMemcpy2D = function(const pCopy: PCUDA_MEMCPY2D): TCUresult; stdcall;
TcuMemcpy2DUnaligned = function(var pCopy: TCUDA_MEMCPY2D): TCUresult; stdcall;
TcuMemcpy3D = function(var pCopy: TCUDA_MEMCPY3D): TCUresult; stdcall;
TcuMemcpyHtoDAsync = function(dstDevice: TCUdeviceptr; var srcHost; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuMemcpyDtoHAsync = function(var dstHost; srcDevice: TCUdeviceptr; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuMemcpyHtoAAsync = function(dstArray: PCUarray; dstIndex: Cardinal; var pSrc; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuMemcpyAtoHAsync = function(var dstHost; srcArray: PCUstream; SrcIndex: Cardinal; ByteCount: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuMemcpy2DAsync = function(var pCopy: TCUDA_MEMCPY2D; hStream: PCUstream) : TCUresult; stdcall;
TcuMemcpy3DAsync = function(var pCopy: TCUDA_MEMCPY3D; hStream: PCUstream) : TCUresult; stdcall;
TcuMemsetD8 = function(dstDevice: TCUdeviceptr; ub: Byte; N: Cardinal) : TCUresult; stdcall;
TcuMemsetD16 = function(dstDevice: TCUdeviceptr; uw: Word; N: Cardinal) : TCUresult; stdcall;
TcuMemsetD32 = function(dstDevice: TCUdeviceptr; ui: Cardinal; N: Cardinal) : TCUresult; stdcall;
TcuMemsetD2D8 = function(dstDevice: TCUdeviceptr; dstPitch: Cardinal; ub: Byte; Width: Cardinal; Height: Cardinal): TCUresult; stdcall;
TcuMemsetD2D16 = function(dstDevice: TCUdeviceptr; dstPitch: Cardinal; uw: Word; Width: Cardinal; Height: Cardinal): TCUresult; stdcall;
TcuMemsetD2D32 = function(dstDevice: TCUdeviceptr; dstPitch: Cardinal; ui: Cardinal; Width: Cardinal; Height: Cardinal): TCUresult; stdcall;
TcuFuncSetBlockShape = function(hfunc: PCUfunction; x: Integer; y: Integer; z: Integer): TCUresult; stdcall;
TcuFuncSetSharedSize = function(hfunc: PCUfunction; bytes: Cardinal) : TCUresult; stdcall;
TcuFuncGetAttribute = function(var pi: Integer; attrib: TCUfunction_attribute; hfunc: PCUfunction): TCUresult; stdcall;
TcuArrayCreate = function(var pHandle: PCUarray; var pAllocateArray: TCUDA_ARRAY_DESCRIPTOR): TCUresult; stdcall;
TcuArrayGetDescriptor = function(var pArrayDescriptor: TCUDA_ARRAY_DESCRIPTOR; hArray: PCUarray): TCUresult; stdcall;
TcuArrayDestroy = function(hArray: PCUarray): TCUresult; stdcall;
TcuArray3DCreate = function(var pHandle: PCUarray; var pAllocateArray: TCUDA_ARRAY3D_DESCRIPTOR): TCUresult; stdcall;
TcuArray3DGetDescriptor = function(var pArrayDescriptor : TCUDA_ARRAY3D_DESCRIPTOR; hArray: PCUarray): TCUresult; stdcall;
TcuTexRefCreate = function(var pTexRef: PCUtexref): TCUresult; stdcall;
TcuTexRefDestroy = function(hTexRef: PCUtexref): TCUresult; stdcall;
TcuTexRefSetArray = function(hTexRef: PCUtexref; hArray: PCUarray; Flags: Cardinal): TCUresult; stdcall;
TcuTexRefSetAddress = function(var ByteOffset: Cardinal; hTexRef: PCUtexref; dptr: TCUdeviceptr; bytes: Cardinal): TCUresult; stdcall;
TcuTexRefSetAddress2D = function(hTexRef: PCUtexref; var desc: TCUDA_ARRAY_DESCRIPTOR; dptr: TCUdeviceptr; Pitch: Cardinal) : TCUresult; stdcall;
TcuTexRefSetFormat = function(hTexRef: PCUtexref; fmt: TCUarray_format; NumPackedComponents: Integer): TCUresult; stdcall;
TcuTexRefSetAddressMode = function(hTexRef: PCUtexref; dim: Integer; am: TCUaddress_mode): TCUresult; stdcall;
TcuTexRefSetFilterMode = function(hTexRef: PCUtexref; fm: TCUfilter_mode) : TCUresult; stdcall;
TcuTexRefSetFlags = function(hTexRef: PCUtexref; Flags: Cardinal): TCUresult; stdcall;
TcuTexRefGetAddress = function(var pdptr: TCUdeviceptr; hTexRef: PCUtexref) : TCUresult; stdcall;
TcuTexRefGetArray = function(var phArray: PCUarray; hTexRef: PCUtexref) : TCUresult; stdcall;
TcuTexRefGetAddressMode = function(var pam: TCUaddress_mode; hTexRef: PCUtexref; dim: Integer): TCUresult; stdcall;
TcuTexRefGetFilterMode = function(var pfm: TCUfilter_mode; hTexRef: PCUtexref) : TCUresult; stdcall;
TcuTexRefGetFormat = function(var pFormat: TCUarray_format; var pNumChannels: Integer; hTexRef: PCUtexref): TCUresult; stdcall;
TcuTexRefGetFlags = function(var pFlags: Cardinal; hTexRef: PCUtexref) : TCUresult; stdcall;
TcuParamSetSize = function(hfunc: PCUfunction; numbytes: Cardinal): TCUresult; stdcall;
TcuParamSeti = function(hfunc: PCUfunction; offset: Integer; value: Cardinal) : TCUresult; stdcall;
TcuParamSetf = function(hfunc: PCUfunction; offset: Integer; value: Single) : TCUresult; stdcall;
TcuParamSetv = function(hfunc: PCUfunction; offset: Integer; var ptr; numbytes: Cardinal): TCUresult; stdcall;
TcuParamSetTexRef = function(hfunc: PCUfunction; texunit: Integer; hTexRef: PCUtexref): TCUresult; stdcall;
TcuLaunch = function(f: PCUfunction): TCUresult; stdcall;
TcuLaunchGrid = function(f: PCUfunction; grid_width: Integer; grid_height: Integer): TCUresult; stdcall;
TcuLaunchGridAsync = function(f: PCUfunction; grid_width: Integer; grid_height: Integer; hStream: PCUstream): TCUresult; stdcall;
TcuEventCreate = function(var phEvent: PCUevent; Flags: Cardinal): TCUresult; stdcall;
TcuEventRecord = function(hEvent: PCUevent; hStream: PCUstream): TCUresult; stdcall;
TcuEventQuery = function(hEvent: PCUevent): TCUresult; stdcall;
TcuEventSynchronize = function(hEvent: PCUevent): TCUresult; stdcall;
TcuEventDestroy = function(hEvent: PCUevent): TCUresult; stdcall;
TcuEventElapsedTime = function(var pMilliseconds: Single; hStart: PCUevent; hEnd: PCUevent): TCUresult; stdcall;
TcuStreamCreate = function(var phStream: PCUstream; Flags: Cardinal) : TCUresult; stdcall;
TcuStreamQuery = function(hStream: PCUstream): TCUresult; stdcall;
TcuStreamSynchronize = function(hStream: PCUstream): TCUresult; stdcall;
TcuStreamDestroy = function(hStream: PCUstream): TCUresult; stdcall;
TcuGLCtxCreate = function(var pctx: PCUcontext; Flags: Cardinal; device: TCUdevice): TCUresult; stdcall;
TcuGraphicsGLRegisterBuffer = function(var pCudaResource: PCUgraphicsResource; buffer: Cardinal; Flags: TCUgraphicsMapResourceFlags): TCUresult; stdcall;
TcuGraphicsGLRegisterImage = function(var pCudaResource: PCUgraphicsResource; image, target: Cardinal; Flags: TCUgraphicsMapResourceFlags): TCUresult; stdcall;
TcuWGLGetDevice = function(var pDevice: TCUdevice; hGpu: HGPUNV): TCUresult; stdcall;
TcuGraphicsUnregisterResource = function(resource: PCUgraphicsResource) : TCUresult; stdcall;
TcuGraphicsSubResourceGetMappedArray = function(var pArray: PCUarray; resource: PCUgraphicsResource; arrayIndex: Cardinal; mipLevel: Cardinal) : TCUresult; stdcall;
TcuGraphicsResourceGetMappedPointer = function(var pDevPtr: TCUdeviceptr; out psize: Cardinal; resource: PCUgraphicsResource): TCUresult; stdcall;
TcuGraphicsResourceSetMapFlags = function(resource: PCUgraphicsResource; Flags: Cardinal): TCUresult; stdcall;
TcuGraphicsMapResources = function(count: Cardinal; resources: PPCUgraphicsResource; hStream: PCUstream): TCUresult; stdcall;
TcuGraphicsUnmapResources = function(count: Cardinal; resources: PPCUgraphicsResource; hStream: PCUstream): TCUresult; stdcall;
TcuGLInit = procedure(); stdcall;
TcuGLRegisterBufferObject = function(buffer: Cardinal): TCUresult; stdcall;
TcuGLMapBufferObject = function(var dptr: TCUdeviceptr; var size: Cardinal; buffer: Cardinal): TCUresult; stdcall;
TcuGLUnmapBufferObject = function(buffer: Cardinal): TCUresult; stdcall;
TcuGLUnregisterBufferObject = function(buffer: Cardinal): TCUresult; stdcall;
TcuGLSetBufferObjectMapFlags = function(buffer: Cardinal; Flags: Cardinal) : TCUresult; stdcall;
TcuGLMapBufferObjectAsync = function(var dptr: TCUdeviceptr; var size: Cardinal; buffer: Cardinal; hStream: PCUstream): TCUresult; stdcall;
TcuGLUnmapBufferObjectAsync = function(buffer: Cardinal; hStream: PCUstream) : TCUresult; stdcall;

Constants

CUDAAPIDLL = 'nvcuda.dll';
CUDA_SUCCESS: TCUresult = 0;
CUDA_ERROR_INVALID_VALUE = 1;
CUDA_ERROR_OUT_OF_MEMORY = 2;
CUDA_ERROR_NOT_INITIALIZED = 3;
CUDA_ERROR_DEINITIALIZED = 4;
CUDA_ERROR_NO_DEVICE = 100;
CUDA_ERROR_INVALID_DEVICE = 101;
CUDA_ERROR_INVALID_IMAGE = 200;
CUDA_ERROR_INVALID_CONTEXT = 201;
CUDA_ERROR_CONTEXT_ALREADY_CURRENT = 202;
CUDA_ERROR_MAP_FAILED = 205;
CUDA_ERROR_UNMAP_FAILED = 206;
CUDA_ERROR_ARRAY_IS_MAPPED = 207;
CUDA_ERROR_ALREADY_MAPPED = 208;
CUDA_ERROR_NO_BINARY_FOR_GPU = 209;
CUDA_ERROR_ALREADY_ACQUIRED = 210;
CUDA_ERROR_NOT_MAPPED = 211;
CUDA_ERROR_NOT_MAPPED_AS_ARRAY = 212;
CUDA_ERROR_NOT_MAPPED_AS_POINTER = 213;
CUDA_ERROR_INVALID_SOURCE = 300;
CUDA_ERROR_FILE_NOT_FOUND = 301;
CUDA_ERROR_INVALID_HANDLE = 400;
CUDA_ERROR_NOT_FOUND = 500;
CUDA_ERROR_NOT_READY = 600;
CUDA_ERROR_LAUNCH_FAILED = 700;
CUDA_ERROR_LAUNCH_OUT_OF_RESOURCES = 701;
CUDA_ERROR_LAUNCH_TIMEOUT = 702;
CUDA_ERROR_LAUNCH_INCOMPATIBLE_TEXTURING = 703;
CUDA_ERROR_POINTER_IS_64BIT = 800;
CUDA_ERROR_SIZE_IS_64BIT = 801;
CUDA_ERROR_UNKNOWN = 999;
CU_MEMHOSTALLOC_PORTABLE = $01;
CU_MEMHOSTALLOC_DEVICEMAP = $02;
CU_MEMHOSTALLOC_WRITECOMBINED = $04;
CU_TRSA_OVERRIDE_FORMAT = $01;
CU_TRSF_READ_AS_INTEGER = $01;
CU_TRSF_NORMALIZED_COORDINATES = $02;
CU_PARAM_TR_DEFAULT = -1;

Variables

cuInit: TcuInit;
cuDriverGetVersion: TcuDriverGetVersion;
cuDeviceGet: TcuDeviceGet;
cuDeviceGetCount: TcuDeviceGetCount;
cuDeviceGetName: TcuDeviceGetName;
cuDeviceComputeCapability: TcuDeviceComputeCapability;
cuDeviceTotalMem: TcuDeviceTotalMem;
cuDeviceGetProperties: TcuDeviceGetProperties;
cuDeviceGetAttribute: TcuDeviceGetAttribute;
cuCtxCreate: TcuCtxCreate;
cuCtxDestroy: TcuCtxDestroy;
cuCtxAttach: TcuCtxAttach;
cuCtxDetach: TcuCtxDetach;
cuCtxPushCurrent: TcuCtxPushCurrent;
cuCtxPopCurrent: TcuCtxPopCurrent;
cuCtxGetDevice: TcuCtxGetDevice;
cuCtxSynchronize: TcuCtxSynchronize;
cuModuleLoad: TcuModuleLoad;
cuModuleLoadData: TcuModuleLoadData;
cuModuleLoadDataEx: TcuModuleLoadDataEx;
cuModuleLoadFatBinary: TcuModuleLoadFatBinary;
cuModuleUnload: TcuModuleUnload;
cuModuleGetFunction: TcuModuleGetFunction;
cuModuleGetGlobal: TcuModuleGetGlobal;
cuModuleGetTexRef: TcuModuleGetTexRef;
cuMemGetInfo: TcuMemGetInfo;
cuMemAlloc: TcuMemAlloc;
cuMemAllocPitch: TcuMemAllocPitch;
cuMemFree: TcuMemFree;
cuMemGetAddressRange: TcuMemGetAddressRange;
cuMemAllocHost: TcuMemAllocHost;
cuMemFreeHost: TcuMemFreeHost;
cuMemHostAlloc: TcuMemHostAlloc;
cuMemHostGetDevicePointer: TcuMemHostGetDevicePointer;
cuMemHostGetFlags: TcuMemHostGetFlags;
cuMemcpyHtoD: TcuMemcpyHtoD;
cuMemcpyDtoH: TcuMemcpyDtoH;
cuMemcpyDtoD: TcuMemcpyDtoD;
cuMemcpyDtoDAsync: TcuMemcpyDtoDAsync;
cuMemcpyDtoA: TcuMemcpyDtoA;
cuMemcpyAtoD: TcuMemcpyAtoD;
cuMemcpyHtoA: TcuMemcpyHtoA;
cuMemcpyAtoH: TcuMemcpyAtoH;
cuMemcpyAtoA: TcuMemcpyAtoA;
cuMemcpy2D: TcuMemcpy2D;
cuMemcpy2DUnaligned: TcuMemcpy2DUnaligned;
cuMemcpy3D: TcuMemcpy3D;
cuMemcpyHtoDAsync: TcuMemcpyHtoDAsync;
cuMemcpyDtoHAsync: TcuMemcpyDtoHAsync;
cuMemcpyHtoAAsync: TcuMemcpyHtoAAsync;
cuMemcpyAtoHAsync: TcuMemcpyAtoHAsync;
cuMemcpy2DAsync: TcuMemcpy2DAsync;
cuMemcpy3DAsync: TcuMemcpy3DAsync;
cuMemsetD8: TcuMemsetD8;
cuMemsetD16: TcuMemsetD16;
cuMemsetD32: TcuMemsetD32;
cuMemsetD2D8: TcuMemsetD2D8;
cuMemsetD2D16: TcuMemsetD2D16;
cuMemsetD2D32: TcuMemsetD2D32;
cuFuncSetBlockShape: TcuFuncSetBlockShape;
cuFuncSetSharedSize: TcuFuncSetSharedSize;
cuFuncGetAttribute: TcuFuncGetAttribute;
cuArrayCreate: TcuArrayCreate;
cuArrayGetDescriptor: TcuArrayGetDescriptor;
cuArrayDestroy: TcuArrayDestroy;
cuArray3DCreate: TcuArray3DCreate;
cuArray3DGetDescriptor: TcuArray3DGetDescriptor;
cuTexRefCreate: TcuTexRefCreate;
cuTexRefDestroy: TcuTexRefDestroy;
cuTexRefSetArray: TcuTexRefSetArray;
cuTexRefSetAddress: TcuTexRefSetAddress;
cuTexRefSetAddress2D: TcuTexRefSetAddress2D;
cuTexRefSetFormat: TcuTexRefSetFormat;
cuTexRefSetAddressMode: TcuTexRefSetAddressMode;
cuTexRefSetFilterMode: TcuTexRefSetFilterMode;
cuTexRefSetFlags: TcuTexRefSetFlags;
cuTexRefGetAddress: TcuTexRefGetAddress;
cuTexRefGetArray: TcuTexRefGetArray;
cuTexRefGetAddressMode: TcuTexRefGetAddressMode;
cuTexRefGetFilterMode: TcuTexRefGetFilterMode;
cuTexRefGetFormat: TcuTexRefGetFormat;
cuTexRefGetFlags: TcuTexRefGetFlags;
cuParamSetSize: TcuParamSetSize;
cuParamSeti: TcuParamSeti;
cuParamSetf: TcuParamSetf;
cuParamSetv: TcuParamSetv;
cuParamSetTexRef: TcuParamSetTexRef;
cuLaunch: TcuLaunch;
cuLaunchGrid: TcuLaunchGrid;
cuLaunchGridAsync: TcuLaunchGridAsync;
cuEventCreate: TcuEventCreate;
cuEventRecord: TcuEventRecord;
cuEventQuery: TcuEventQuery;
cuEventSynchronize: TcuEventSynchronize;
cuEventDestroy: TcuEventDestroy;
cuEventElapsedTime: TcuEventElapsedTime;
cuStreamCreate: TcuStreamCreate;
cuStreamQuery: TcuStreamQuery;
cuStreamSynchronize: TcuStreamSynchronize;
cuStreamDestroy: TcuStreamDestroy;
cuGLInit: TcuGLInit;
cuGLCtxCreate: TcuGLCtxCreate;
cuGraphicsGLRegisterBuffer: TcuGraphicsGLRegisterBuffer;
cuGraphicsGLRegisterImage: TcuGraphicsGLRegisterImage;
cuWGLGetDevice: TcuWGLGetDevice;
cuGraphicsUnregisterResource: TcuGraphicsUnregisterResource;
cuGraphicsSubResourceGetMappedArray: TcuGraphicsSubResourceGetMappedArray;
cuGraphicsResourceGetMappedPointer: TcuGraphicsResourceGetMappedPointer;
cuGraphicsResourceSetMapFlags: TcuGraphicsResourceSetMapFlags;
cuGraphicsMapResources: TcuGraphicsMapResources;
cuGraphicsUnmapResources: TcuGraphicsUnmapResources;
cuGLRegisterBufferObject: TcuGLRegisterBufferObject;
cuGLMapBufferObject: TcuGLMapBufferObject;
cuGLUnmapBufferObject: TcuGLUnmapBufferObject;
cuGLUnregisterBufferObject: TcuGLUnregisterBufferObject;
cuGLSetBufferObjectMapFlags: TcuGLSetBufferObjectMapFlags;
cuGLMapBufferObjectAsync: TcuGLMapBufferObjectAsync;
cuGLUnmapBufferObjectAsync: TcuGLUnmapBufferObjectAsync;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_API: record TCUcontext

record TCUcontext

Unit

GLS_CUDA_API

Declaration

type TCUcontext = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_API: record TCUmodule

record TCUmodule

Unit

GLS_CUDA_API

Declaration

type TCUmodule = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_API: record TCUfunction

record TCUfunction

Unit

GLS_CUDA_API

Declaration

type TCUfunction = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_API: record TCUarray

record TCUarray

Unit

GLS_CUDA_API

Declaration

type TCUarray = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_API: record TCUtexref

record TCUtexref

Unit

GLS_CUDA_API

Declaration

type TCUtexref = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_API: record TCUevent

record TCUevent

Unit

GLS_CUDA_API

Declaration

type TCUevent = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_API: record TCUstream

record TCUstream

Unit

GLS_CUDA_API

Declaration

type TCUstream = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_API: record TCUgraphicsResource

record TCUgraphicsResource

Unit

GLS_CUDA_API

Declaration

type TCUgraphicsResource = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_API: record TCUdevprop

record TCUdevprop

Unit

GLS_CUDA_API

Declaration

type TCUdevprop = record

Description

Overview

Fields

maxThreadsPerBlock: Integer;
maxThreadsDim: array [0 .. 2] of Integer;
maxGridSize: array [0 .. 2] of Integer;
sharedMemPerBlock: Integer;
totalConstantMemory: Integer;
SIMDWidth: Integer;
memPitch: Integer;
regsPerBlock: Integer;
clockRate: Integer;
textureAlign: Integer;

Description

Fields

maxThreadsPerBlock: Integer;
maxThreadsDim: array [0 .. 2] of Integer;
maxGridSize: array [0 .. 2] of Integer;
sharedMemPerBlock: Integer;
totalConstantMemory: Integer;
SIMDWidth: Integer;
memPitch: Integer;
regsPerBlock: Integer;
clockRate: Integer;
textureAlign: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_API: record TcudaFuncAttributes

record TcudaFuncAttributes

Unit

GLS_CUDA_API

Declaration

type TcudaFuncAttributes = record

Description

Overview

Fields

sharedSizeBytes: TSize_t;
constSizeBytes: TSize_t;
localSizeBytes: TSize_t;
maxThreadsPerBlock: Integer;
numRegs: Integer;
ptxVersion: Integer;
binaryVersion: Integer;
__cudaReserved: array [0 .. 5] of Integer;

Description

Fields

sharedSizeBytes: TSize_t;
constSizeBytes: TSize_t;
localSizeBytes: TSize_t;
maxThreadsPerBlock: Integer;
numRegs: Integer;
ptxVersion: Integer;
binaryVersion: Integer;
__cudaReserved: array [0 .. 5] of Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_API: record TCUDA_MEMCPY2D

record TCUDA_MEMCPY2D

Unit

GLS_CUDA_API

Declaration

type TCUDA_MEMCPY2D = record

Description

Overview

Fields

srcXInBytes: Cardinal;
srcY: Cardinal;
srcMemoryType: TCUmemorytype;
srcHost: Pointer;
srcDevice: TCUdeviceptr;
srcArray: PCUarray;
srcPitch: Cardinal;
dstXInBytes: Cardinal;
dstY: Cardinal;
dstMemoryType: TCUmemorytype;
dstHost: Pointer;
dstDevice: TCUdeviceptr;
dstArray: PCUarray;
dstPitch: Cardinal;
WidthInBytes: Cardinal;
Height: Cardinal;

Description

Fields

srcXInBytes: Cardinal;
srcY: Cardinal;
srcMemoryType: TCUmemorytype;
srcHost: Pointer;
srcDevice: TCUdeviceptr;
srcArray: PCUarray;
srcPitch: Cardinal;
dstXInBytes: Cardinal;
dstY: Cardinal;
dstMemoryType: TCUmemorytype;
dstHost: Pointer;
dstDevice: TCUdeviceptr;
dstArray: PCUarray;
dstPitch: Cardinal;
WidthInBytes: Cardinal;
Height: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_API: record TCUDA_MEMCPY3D

record TCUDA_MEMCPY3D

Unit

GLS_CUDA_API

Declaration

type TCUDA_MEMCPY3D = record

Description

Overview

Fields

srcXInBytes: Cardinal;
srcY: Cardinal;
srcZ: Cardinal;
srcLOD: Cardinal;
srcMemoryType: TCUmemorytype;
srcHost: Pointer;
srcDevice: TCUdeviceptr;
srcArray: PCUarray;
reserved0: Pointer;
srcPitch: Cardinal;
srcHeight: Cardinal;
dstXInBytes: Cardinal;
dstY: Cardinal;
dstZ: Cardinal;
dstLOD: Cardinal;
dstMemoryType: TCUmemorytype;
dstHost: Pointer;
dstDevice: TCUdeviceptr;
dstArray: PCUarray;
reserved1: Pointer;
dstPitch: Cardinal;
dstHeight: Cardinal;
WidthInBytes: Cardinal;
Height: Cardinal;
Depth: Cardinal;

Description

Fields

srcXInBytes: Cardinal;
srcY: Cardinal;
srcZ: Cardinal;
srcLOD: Cardinal;
srcMemoryType: TCUmemorytype;
srcHost: Pointer;
srcDevice: TCUdeviceptr;
srcArray: PCUarray;
reserved0: Pointer;
srcPitch: Cardinal;
srcHeight: Cardinal;
dstXInBytes: Cardinal;
dstY: Cardinal;
dstZ: Cardinal;
dstLOD: Cardinal;
dstMemoryType: TCUmemorytype;
dstHost: Pointer;
dstDevice: TCUdeviceptr;
dstArray: PCUarray;
reserved1: Pointer;
dstPitch: Cardinal;
dstHeight: Cardinal;
WidthInBytes: Cardinal;
Height: Cardinal;
Depth: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_API: record TCUDA_ARRAY_DESCRIPTOR

record TCUDA_ARRAY_DESCRIPTOR

Unit

GLS_CUDA_API

Declaration

type TCUDA_ARRAY_DESCRIPTOR = record

Description

Overview

Fields

Width: Cardinal;
Height: Cardinal;
Format: TCUarray_format;
NumChannels: Cardinal;

Description

Fields

Width: Cardinal;
Height: Cardinal;
Format: TCUarray_format;
NumChannels: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_API: record TCUDA_ARRAY3D_DESCRIPTOR

record TCUDA_ARRAY3D_DESCRIPTOR

Unit

GLS_CUDA_API

Declaration

type TCUDA_ARRAY3D_DESCRIPTOR = record

Description

Overview

Fields

Width: Cardinal;
Height: Cardinal;
Depth: Cardinal;
Format: TCUarray_format;
NumChannels: Cardinal;
Flags: Cardinal;

Description

Fields

Width: Cardinal;
Height: Cardinal;
Depth: Cardinal;
Format: TCUarray_format;
NumChannels: Cardinal;
Flags: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_FourierTransform

Unit GLS_CUDA_FourierTransform

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Functions and Procedures

function InitCUFFT: Boolean;
procedure CloseCUFFT;
function InitCUFFTFromLibrary(const LibName: WideString): Boolean;
function IsCUFFTInitialized: Boolean;
function Get_CUDA_FFT_Error_String(AError: TcufftResult): string;

Types

TcufftHandle = type Cardinal;
TcufftReal = Single;
PcufftReal = ˆTcufftReal;
TcufftRealfloat = Single;
PcufftDoubleReal = ˆTcufftDoubleReal;
TcufftDoubleReal = Double;
PcufftDoubleComplex = ˆTcufftDoubleComplex;
TcufftDoubleComplex = TVector2d;
PcufftComplex = ˆTcufftComplex;
TcufftComplex = TVector2f;
TcufftResult = type Byte;
TcufftType = type Cardinal;
TcudaRoundMode = (...);
TcufftCompatibility = type Cardinal;
TcufftPlan1d = function(out plan: TcufftHandle; nx: Integer; atype: TcufftType; batch: Integer): TcufftResult; stdcall;
TcufftPlan2d = function(out plan: TcufftHandle; nx: Integer; ny: Integer; atype: TcufftType): TcufftResult; stdcall;
TcufftPlan3d = function(out plan: TcufftHandle; nx: Integer; ny: Integer; nz: Integer; atype: TcufftType): TcufftResult; stdcall;
TcufftDestroy = function(plan: TcufftHandle): TcufftResult; stdcall;
TcufftPlanMany = function(out plan: TcufftHandle; rank: Integer; var n: Integer; var inembed: Integer; istride, idist: Integer; var onembed: Integer; ostride, odist: Integer; ctype: TcufftType; batch: Integer): TcufftResult; stdcall;
TcufftExecC2C = function(plan: TcufftHandle; idata: PcufftComplex; odata: PcufftComplex; direction: Integer): TcufftResult; stdcall;
TcufftExecR2C = function(plan: TcufftHandle; idata: PcufftReal; odata: PcufftComplex): TcufftResult; stdcall;
TcufftExecC2R = function(plan: TcufftHandle; idata: PcufftComplex; odata: PcufftReal): TcufftResult; stdcall;
TcufftExecZ2Z = function(plan: TcufftHandle; idata: PcufftDoubleComplex; odata: PcufftDoubleComplex; direction: Integer): TcufftResult; stdcall;
TcufftExecD2Z = function(plan: TcufftHandle; idata: PcufftDoubleReal; odata: PcufftDoubleComplex): TcufftResult; stdcall;
TcufftExecZ2D = function(plan: TcufftHandle; idata: PcufftDoubleComplex; odata: PcufftDoubleReal): TcufftResult; stdcall;
TcufftSetStream = function(p: TcufftHandle; stream: Integer): TcufftResult; stdcall;
TcufftSetCompatibilityMode = function(plan: TcufftHandle; mode: TcufftCompatibility): TcufftResult; stdcall;

Constants

CUFFTDLLNAMES: array [0 .. 9] of string = ( 'cufft32_42_9', 'cufft32_41_28', 'cufft32_40_10', 'cufft32_32_16', 'cufft32_31_4', 'cufft32_30_14', 'cufft32_30_9', 'cufft32_30_8', 'cufft32', 'cufft');
INVALID_CUFFT_HANDLE = $FFFFFFFF;
CUFFT_SUCCESS: TcufftResult = $00;
CUFFT_INVALID_PLAN: TcufftResult = $01;
CUFFT_ALLOC_FAILED: TcufftResult = $02;
CUFFT_INVALID_TYPE: TcufftResult = $03;
CUFFT_INVALID_VALUE: TcufftResult = $04;
CUFFT_INTERNAL_ERROR: TcufftResult = $05;
CUFFT_EXEC_FAILED: TcufftResult = $06;
CUFFT_SETUP_FAILED: TcufftResult = $07;
CUFFT_INVALID_SIZE: TcufftResult = $08;
CUFFT_FORWARD = -1;
CUFFT_INVERSE = 1;
CUFFT_R2C: TcufftType = $2A;
CUFFT_C2R: TcufftType = $2C;
CUFFT_C2C: TcufftType = $29;
CUFFT_D2Z: TcufftType = $6A;
CUFFT_Z2D: TcufftType = $6C;
CUFFT_Z2Z: TcufftType = $69;
CUFFT_COMPATIBILITY_NORMAL: TcufftCompatibility = $00;
CUFFT_COMPATIBILITY_FFTW_PADDING: TcufftCompatibility = $01;
CUFFT_COMPATIBILITY_FFTW_C2R_ASYMMETRIC: TcufftCompatibility = $02;
CUFFT_COMPATIBILITY_FFTW: TcufftCompatibility = $03;

Variables

cufftPlan1d: TcufftPlan1d;
cufftPlan2d: TcufftPlan2d;
cufftPlan3d: TcufftPlan3d;
cufftDestroy: TcufftDestroy;
cufftPlanMany: TcufftPlanMany;
cufftExecC2C: TcufftExecC2C;
cufftExecR2C: TcufftExecR2C;
cufftExecC2R: TcufftExecC2R;
cufftExecZ2Z: TcufftExecZ2Z;
cufftExecD2Z: TcufftExecD2Z;
cufftExecZ2D: TcufftExecZ2D;
cufftSetStream: TcufftSetStream;
cufftSetCompatibilityMode: TcufftSetCompatibilityMode;

Description

Functions and Procedures

function InitCUFFT: Boolean;
procedure CloseCUFFT;
function InitCUFFTFromLibrary(const LibName: WideString): Boolean;
function IsCUFFTInitialized: Boolean;
function Get_CUDA_FFT_Error_String(AError: TcufftResult): string;

Types

TcufftHandle = type Cardinal;
TcufftReal = Single;
PcufftReal = ˆTcufftReal;
TcufftRealfloat = Single;
PcufftDoubleReal = ˆTcufftDoubleReal;
TcufftDoubleReal = Double;
PcufftDoubleComplex = ˆTcufftDoubleComplex;
TcufftDoubleComplex = TVector2d;
PcufftComplex = ˆTcufftComplex;
TcufftComplex = TVector2f;
TcufftResult = type Byte;
TcufftType = type Cardinal;
TcudaRoundMode = (...);
Values
  • cudaRoundNearest:
  • cudaRoundZero:
  • cudaRoundPosInf:
  • cudaRoundMinInf:
TcufftCompatibility = type Cardinal;
TcufftPlan1d = function(out plan: TcufftHandle; nx: Integer; atype: TcufftType; batch: Integer): TcufftResult; stdcall;
TcufftPlan2d = function(out plan: TcufftHandle; nx: Integer; ny: Integer; atype: TcufftType): TcufftResult; stdcall;
TcufftPlan3d = function(out plan: TcufftHandle; nx: Integer; ny: Integer; nz: Integer; atype: TcufftType): TcufftResult; stdcall;
TcufftDestroy = function(plan: TcufftHandle): TcufftResult; stdcall;
TcufftPlanMany = function(out plan: TcufftHandle; rank: Integer; var n: Integer; var inembed: Integer; istride, idist: Integer; var onembed: Integer; ostride, odist: Integer; ctype: TcufftType; batch: Integer): TcufftResult; stdcall;
TcufftExecC2C = function(plan: TcufftHandle; idata: PcufftComplex; odata: PcufftComplex; direction: Integer): TcufftResult; stdcall;
TcufftExecR2C = function(plan: TcufftHandle; idata: PcufftReal; odata: PcufftComplex): TcufftResult; stdcall;
TcufftExecC2R = function(plan: TcufftHandle; idata: PcufftComplex; odata: PcufftReal): TcufftResult; stdcall;
TcufftExecZ2Z = function(plan: TcufftHandle; idata: PcufftDoubleComplex; odata: PcufftDoubleComplex; direction: Integer): TcufftResult; stdcall;
TcufftExecD2Z = function(plan: TcufftHandle; idata: PcufftDoubleReal; odata: PcufftDoubleComplex): TcufftResult; stdcall;
TcufftExecZ2D = function(plan: TcufftHandle; idata: PcufftDoubleComplex; odata: PcufftDoubleReal): TcufftResult; stdcall;
TcufftSetStream = function(p: TcufftHandle; stream: Integer): TcufftResult; stdcall;
TcufftSetCompatibilityMode = function(plan: TcufftHandle; mode: TcufftCompatibility): TcufftResult; stdcall;

Constants

CUFFTDLLNAMES: array [0 .. 9] of string = ( 'cufft32_42_9', 'cufft32_41_28', 'cufft32_40_10', 'cufft32_32_16', 'cufft32_31_4', 'cufft32_30_14', 'cufft32_30_9', 'cufft32_30_8', 'cufft32', 'cufft');
INVALID_CUFFT_HANDLE = $FFFFFFFF;
CUFFT_SUCCESS: TcufftResult = $00;
CUFFT_INVALID_PLAN: TcufftResult = $01;
CUFFT_ALLOC_FAILED: TcufftResult = $02;
CUFFT_INVALID_TYPE: TcufftResult = $03;
CUFFT_INVALID_VALUE: TcufftResult = $04;
CUFFT_INTERNAL_ERROR: TcufftResult = $05;
CUFFT_EXEC_FAILED: TcufftResult = $06;
CUFFT_SETUP_FAILED: TcufftResult = $07;
CUFFT_INVALID_SIZE: TcufftResult = $08;
CUFFT_FORWARD = -1;
CUFFT_INVERSE = 1;
CUFFT_R2C: TcufftType = $2A;
CUFFT_C2R: TcufftType = $2C;
CUFFT_C2C: TcufftType = $29;
CUFFT_D2Z: TcufftType = $6A;
CUFFT_Z2D: TcufftType = $6C;
CUFFT_Z2Z: TcufftType = $69;
CUFFT_COMPATIBILITY_NORMAL: TcufftCompatibility = $00;
CUFFT_COMPATIBILITY_FFTW_PADDING: TcufftCompatibility = $01;
CUFFT_COMPATIBILITY_FFTW_C2R_ASYMMETRIC: TcufftCompatibility = $02;
CUFFT_COMPATIBILITY_FFTW: TcufftCompatibility = $03;

Variables

cufftPlan1d: TcufftPlan1d;
cufftPlan2d: TcufftPlan2d;
cufftPlan3d: TcufftPlan3d;
cufftDestroy: TcufftDestroy;
cufftPlanMany: TcufftPlanMany;
cufftExecC2C: TcufftExecC2C;
cufftExecR2C: TcufftExecR2C;
cufftExecC2R: TcufftExecC2R;
cufftExecZ2Z: TcufftExecZ2Z;
cufftExecD2Z: TcufftExecD2Z;
cufftExecZ2D: TcufftExecZ2D;
cufftSetStream: TcufftSetStream;
cufftSetCompatibilityMode: TcufftSetCompatibilityMode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_ParallelPrimitives

Unit GLS_CUDA_ParallelPrimitives

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TCUDPPConfiguration |

Functions and Procedures

function cudppPlan(var planHandle: TCUDPPHandle; config: TCUDPPConfiguration; n: size_t; rows: size_t; rowPitch: size_t): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppDestroyPlan(plan: TCUDPPHandle): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppScan(planHandle: TCUDPPHandle; var d_out; var d_in, numElements: size_t): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppMultiScan(planHandle: TCUDPPHandle; var d_out; var d_in; numElements: size_t; numRows: size_t): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppSegmentedScan(planHandle: TCUDPPHandle; var d_out; var d_idata; const d_iflags: PCardinal; numElements: size_t): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppCompact(planHandle: TCUDPPHandle; var d_out; var d_numValidElements: size_t; var d_in; const d_isValid: PCardinal; numElements: size_t): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppSort(planHandle: TCUDPPHandle; var d_keys; var d_values; keybits: Integer; numElements: size_t): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppSparseMatrix(var sparseMatrixHandle: TCUDPPHandle; config: TCUDPPConfiguration; n: size_t; rows: size_t; var A; const h_rowIndices: PCardinal; const h_indices: PCardinal): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppDestroySparseMatrix(sparseMatrixHandle: TCUDPPHandle): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppSparseMatrixVectorMultiply(sparseMatrixHandle: TCUDPPHandle; var d_y; var d_x): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppRand(planHandle: TCUDPPHandle; var d_out; numElements: size_t): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppRandSeed(const planHandle: TCUDPPHandle; seed: Cardinal): TCUDPPResult; stdcall; external CUDPPDLL;

Types

TCUDPPResult = (...);
TCUDPPOption = (...);
TCUDPPDatatype = (...);
TCUDPPOperator = (...);
TCUDPPAlgorithm = (...);
TCUDPPHandle = size_t;

Constants

CUDPPDLL = 'cudpp32.dll';
CUDPP_INVALID_HANDLE = $C0DABAD1;

Description

Functions and Procedures

function cudppPlan(var planHandle: TCUDPPHandle; config: TCUDPPConfiguration; n: size_t; rows: size_t; rowPitch: size_t): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppDestroyPlan(plan: TCUDPPHandle): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppScan(planHandle: TCUDPPHandle; var d_out; var d_in, numElements: size_t): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppMultiScan(planHandle: TCUDPPHandle; var d_out; var d_in; numElements: size_t; numRows: size_t): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppSegmentedScan(planHandle: TCUDPPHandle; var d_out; var d_idata; const d_iflags: PCardinal; numElements: size_t): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppCompact(planHandle: TCUDPPHandle; var d_out; var d_numValidElements: size_t; var d_in; const d_isValid: PCardinal; numElements: size_t): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppSort(planHandle: TCUDPPHandle; var d_keys; var d_values; keybits: Integer; numElements: size_t): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppSparseMatrix(var sparseMatrixHandle: TCUDPPHandle; config: TCUDPPConfiguration; n: size_t; rows: size_t; var A; const h_rowIndices: PCardinal; const h_indices: PCardinal): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppDestroySparseMatrix(sparseMatrixHandle: TCUDPPHandle): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppSparseMatrixVectorMultiply(sparseMatrixHandle: TCUDPPHandle; var d_y; var d_x): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppRand(planHandle: TCUDPPHandle; var d_out; numElements: size_t): TCUDPPResult; stdcall; external CUDPPDLL;
function cudppRandSeed(const planHandle: TCUDPPHandle; seed: Cardinal): TCUDPPResult; stdcall; external CUDPPDLL;

Types

TCUDPPResult = (...);
Values
  • CUDPP_SUCCESS:
  • CUDPP_ERROR_INVALID_HANDLE:
  • CUDPP_ERROR_ILLEGAL_CONFIGURATION:
  • CUDPP_ERROR_UNKNOWN:
TCUDPPOption = (...);
Values
  • CUDPP_OPTION_FORWARD:
  • CUDPP_OPTION_BACKWARD:
  • CUDPP_OPTION_EXCLUSIVE:
  • CUDPP_OPTION_INCLUSIVE:
  • CUDPP_OPTION_CTA_LOCAL:
  • CUDPP_OPTION_KEYS_ONLY:
  • CUDPP_OPTION_KEY_VALUE_PAIRS:
TCUDPPDatatype = (...);
Values
  • CUDPP_CHAR:
  • CUDPP_UCHAR:
  • CUDPP_INT:
  • CUDPP_UINT:
  • CUDPP_FLOAT:
TCUDPPOperator = (...);
Values
  • CUDPP_ADD:
  • CUDPP_MULTIPLY:
  • CUDPP_MIN:
  • CUDPP_MAX:
TCUDPPAlgorithm = (...);
Values
  • CUDPP_SCAN:
  • CUDPP_SEGMENTED_SCAN:
  • CUDPP_COMPACT:
  • CUDPP_REDUCE:
  • CUDPP_SORT_RADIX:
  • CUDPP_SPMVMULT:
  • CUDPP_RAND_MD5:
  • CUDPP_ALGORITHM_INVALID:
TCUDPPHandle = size_t;

Constants

CUDPPDLL = 'cudpp32.dll';
CUDPP_INVALID_HANDLE = $C0DABAD1;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_ParallelPrimitives: record TCUDPPConfiguration

record TCUDPPConfiguration

Unit

GLS_CUDA_ParallelPrimitives

Declaration

type TCUDPPConfiguration = record

Description

Overview

Fields

algorithm: TCUDPPAlgorithm;
op: TCUDPPOperator;
datatype: TCUDPPDatatype;
options: TCUDPPoption;

Description

Fields

algorithm: TCUDPPAlgorithm;
op: TCUDPPOperator;
datatype: TCUDPPDatatype;
options: TCUDPPoption;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:01


GLScene v.1.1.2: GLS_CUDA_Runtime

Unit GLS_CUDA_Runtime

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TCudaChannelFormatDesc |
record TcudaArray |
record TcudaPitchedPtr |
record TcudaExtent |
record TcudaPos |
record TcudaMemcpy3DParms |
record TCudaDeviceProp |
record TTextureReference |

Functions and Procedures

function cudaGetLastErrorString: string;
function InitCUDART: Boolean;
procedure CloseCUDART;
function InitCUDARTFromLibrary(const LibName: WideString): Boolean;
function IsCUDARTInitialized: Boolean;

Types

TcudaError = (...);
TCudaChannelFormatKind = (...);
TCudaGLMapFlags = (...);
PcudaChannelFormatDesc = ˆTCudaChannelFormatDesc;
TcudaMemcpyKind = (...);
PCudaDeviceProp = ˆTCudaDeviceProp;
TcudaTextureAddressMode = (...);
TcudaTextureFilterMode = (...);
TcudaTextureReadMode = (...);
PTextureReference = ˆTTextureReference;
PcudaArray = ˆTcudaArray;
cudaError_t = TcudaError;
cudaStream_t = Integer;
cudaEvent_t = Integer;

Constants

CUDARTDLLNAMES: array [0 .. 9] of string = ( 'cudart32_42_9', 'cudart32_41_28', 'cudart32_40_10', 'cudart32_32_16', 'cudart32_31_4', 'cudart32_30_14', 'cudart32_30_9', 'cudart32_30_8', 'cudart32', 'cudart');
CUDART_INF_F: Single = $7F800000;
CUDART_NAN_F: Single = $7FFFFFFF;
CUDART_MIN_DENORM_F: Single = $00000001;
CUDART_MAX_NORMAL_F: Single = $7F7FFFFF;
CUDART_NEG_ZERO_F: Single = $80000000;
CUDART_ZERO_F = 0.0;
CUDART_ONE_F = 1.0;
CUDART_SQRT_HALF_F = 0.707106781;
CUDART_SQRT_TWO_F = 1.414213562;
CUDART_THIRD_F = 0.333333333;
CUDART_PIO4_F = 0.785398163;
CUDART_PIO2_F = 1.570796327;
CUDART_3PIO4_F = 2.356194490;
CUDART_2_OVER_PI_F = 0.636619772;
CUDART_PI_F = 3.141592654;
CUDART_L2E_F = 1.442695041;
CUDART_L2T_F = 3.321928094;
CUDART_LG2_F = 0.301029996;
CUDART_LGE_F = 0.434294482;
CUDART_LN2_F = 0.693147181;
CUDART_LNT_F = 2.302585093;
CUDART_LNPI_F = 1.144729886;
CUDART_TWO_TO_M126_F = 1.175494351E-38;
CUDART_TWO_TO_126_F = 8.507059173E37;
CUDART_NORM_HUGE_F = 3.402823466E38;
CUDART_TWO_TO_23_F = 8388608.0;
CUDART_TWO_TO_24_F = 16777216.0;
CUDART_TWO_TO_31_F = 2147483648.0;
CUDART_TWO_TO_32_F = 4294967296.0;
CUDART_REMQUO_BITS_F = 3;
CUDART_REMQUO_MASK_F = CUDART_REMQUO_BITS_F;
CUDART_TRIG_PLOSS_F = 48039.0;
CUDART_INF: Double = $7FF0000000000000;
CUDART_NAN: Double = $FFF8000000000000;
CUDART_NEG_ZERO: Double = $8000000000000000;
CUDART_MIN_DENORM: Double = $0000000000000001;
CUDART_ZERO = 0.0;
CUDART_ONE = 1.0;
CUDART_SQRT_TWO = 1.4142135623730951E+0;
CUDART_SQRT_HALF = 7.0710678118654757E-1;
CUDART_THIRD = 3.3333333333333333E-1;
CUDART_TWOTHIRD = 6.6666666666666667E-1;
CUDART_PIO4 = 7.8539816339744828E-1;
CUDART_PIO4_HI = 7.8539816339744828E-1;
CUDART_PIO4_LO = 3.0616169978683830E-17;
CUDART_PIO2 = 1.5707963267948966E+0;
CUDART_PIO2_HI = 1.5707963267948966E+0;
CUDART_PIO2_LO = 6.1232339957367660E-17;
CUDART_3PIO4 = 2.3561944901923448E+0;
CUDART_2_OVER_PI = 6.3661977236758138E-1;
CUDART_PI = 3.1415926535897931E+0;
CUDART_PI_HI = 3.1415926535897931E+0;
CUDART_PI_LO = 1.2246467991473532E-16;
CUDART_SQRT_2PI_HI = 2.5066282746310007E+0;
CUDART_SQRT_2PI_LO = -1.8328579980459167E-16;
CUDART_SQRT_PIO2_HI = 1.2533141373155003E+0;
CUDART_SQRT_PIO2_LO = -9.1642899902295834E-17;
CUDART_L2E = 1.4426950408889634E+0;
CUDART_L2E_HI = 1.4426950408889634E+0;
CUDART_L2E_LO = 2.0355273740931033E-17;
CUDART_L2T = 3.3219280948873622E+0;
CUDART_LG2 = 3.0102999566398120E-1;
CUDART_LG2_HI = 3.0102999566398120E-1;
CUDART_LG2_LO = -2.8037281277851704E-18;
CUDART_LGE = 4.3429448190325182E-1;
CUDART_LGE_HI = 4.3429448190325182E-1;
CUDART_LGE_LO = 1.09831965021676510E-17;
CUDART_LN2 = 6.9314718055994529E-1;
CUDART_LN2_HI = 6.9314718055994529E-1;
CUDART_LN2_LO = 2.3190468138462996E-17;
CUDART_LNT = 2.3025850929940459E+0;
CUDART_LNT_HI = 2.3025850929940459E+0;
CUDART_LNT_LO = -2.1707562233822494E-16;
CUDART_LNPI = 1.1447298858494002E+0;
CUDART_LN2_X_1024 = 7.0978271289338397E+2;
CUDART_LN2_X_1025 = 7.1047586007394398E+2;
CUDART_LN2_X_1075 = 7.4513321910194122E+2;
CUDART_LG2_X_1024 = 3.0825471555991675E+2;
CUDART_LG2_X_1075 = 3.2360724533877976E+2;
CUDART_TWO_TO_23 = 8388608.0;
CUDART_TWO_TO_52 = 4503599627370496.0;
CUDART_TWO_TO_54 = 18014398509481984.0;
CUDART_TWO_TO_M54 = 5.5511151231257827E-17;
CUDART_TWO_TO_M1022 = 2.22507385850720140E-308;
CUDART_TRIG_PLOSS = 2147483648.0;

Variables

cudaBindTexture: function(var offset: TSize_t; const texref: PTextureReference; var devPtr: Pointer; var desc: TCudaChannelFormatDesc; size: TSize_t) : cudaError_t; stdcall;
cudaBindTexture2D: function(var offset: TSize_t; const texref: PTextureReference; const devPtr: Pointer; var desc: TCudaChannelFormatDesc; width, height, pitch: TSize_t) : cudaError_t; stdcall;
cudaBindTextureToArray: function(const texref: PTextureReference; const cudaArray: PcudaArray): cudaError_t; stdcall;
cudaUnbindTexture: function(const texref: PTextureReference): cudaError_t; stdcall;
cudaGetTextureAlignmentOffset: function(offset: TSize_t; const texref: PTextureReference): cudaError_t; stdcall;
cudaGetTextureReference: function(const texref: PTextureReference; const symbol: PAnsiChar): cudaError_t; stdcall;
cudaGetChannelDesc: function(var desc: TCudaChannelFormatDesc; const array_: Pointer): cudaError_t; stdcall;
cudaCreateChannelDesc: function(x, y, z, w: Integer; f: TCudaChannelFormatKind): TCudaChannelFormatDesc; stdcall;
cudaMalloc3D: function(var pitchedDevPtr: TcudaPitchedPtr; extent: TcudaExtent): cudaError_t; stdcall;
cudaMalloc3DArray: function(var arrayPtr: PcudaArray; const desc: TCudaChannelFormatDesc; extent: TcudaExtent; flags: Cardinal) : cudaError_t; stdcall;
cudaMemset3D: function(pitchedDevPtr: TcudaPitchedPtr; value: Integer; extent: TcudaExtent): cudaError_t; stdcall;
cudaMemcpy3D: function(const p: TcudaMemcpy3DParms): cudaError_t; stdcall;
cudaMemcpy3DAsync: function(const p: TcudaMemcpy3DParms; stream: cudaStream_t) : cudaError_t; stdcall;
cudaMalloc: function(var devPtr; size: TSize_t): cudaError_t; stdcall;
cudaMallocHost: function(var ptr: Pointer; size: TSize_t): cudaError_t; stdcall;
cudaMallocPitch: function(var devPtr; var pitch: TSize_t; width: TSize_t; height: TSize_t): cudaError_t; stdcall;
cudaMallocArray: function(var aarray: Pointer; var desc: TCudaChannelFormatDesc; width: TSize_t; height: TSize_t) : cudaError_t; stdcall;
cudaFree: function(devPtr: Pointer): cudaError_t; stdcall;
cudaFreeHost: function(ptr: Pointer): cudaError_t; stdcall;
cudaFreeArray: function(const aarray: Pointer): cudaError_t; stdcall;
cudaHostAlloc: function(var pHost: Pointer; bytes: TSize_t; flags: Cardinal) : cudaError_t; stdcall;
cudaHostGetDevicePointer: function(var pDevice: Pointer; pHost: Pointer; flags: Cardinal): cudaError_t; stdcall;
cudaHostGetFlags: function(var pFlags: Cardinal; pHost: Pointer): cudaError_t; stdcall;
cudaMemGetInfo: function(var free: TSize_t; var total: TSize_t): cudaError_t; stdcall;
cudaMemcpy: function(dst: Pointer; src: Pointer; count: TSize_t; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpyToArray: function(var dst: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; var src; count: TSize_t; kind: TcudaMemcpyKind) : cudaError_t; stdcall;
cudaMemcpyFromArray: function(var dst; const src: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; count: TSize_t; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpyArrayToArray: function(dst: PcudaArray; wOffsetDst: TSize_t; hOffsetDst: TSize_t; const src: PcudaArray; wOffsetSrc: TSize_t; hOffsetSrc: TSize_t; count: TSize_t; const kind: TcudaMemcpyKind = cudaMemcpyDeviceToDevice): cudaError_t; stdcall;
cudaMemcpy2D: function(var dst; dpitch: TSize_t; var src; spitch: TSize_t; width: TSize_t; height: TSize_t; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpy2DToArray: function(dst: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; var src; spitch: TSize_t; width: TSize_t; height: TSize_t; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpy2DFromArray: function(var dst; dpitch: TSize_t; src: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; width: TSize_t; height: TSize_t; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpy2DArrayToArray: function(dst: PcudaArray; wOffsetDst: TSize_t; hOffsetDst: TSize_t; src: PcudaArray; wOffsetSrc: TSize_t; hOffsetSrc: TSize_t; width: TSize_t; height: TSize_t; const kind: TcudaMemcpyKind = cudaMemcpyDeviceToDevice): cudaError_t; stdcall;
cudaMemcpyToSymbol: function(symbol: PAnsiChar; var src; count: TSize_t; const offset: TSize_t = 0; const kind: TcudaMemcpyKind = cudaMemcpyHostToDevice): cudaError_t; stdcall;
cudaMemcpyFromSymbol: function(var dst; symbol: PAnsiChar; count: TSize_t; const offset: TSize_t = 0; const kind: TcudaMemcpyKind = cudaMemcpyDeviceToHost): cudaError_t; stdcall;
cudaMemcpyAsync: function(var dst; const src; count: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpyToArrayAsync: function(dst: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; const src; count: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpyFromArrayAsync: function(var dst; const src: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; count: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpy2DAsync: function(var dst; dpitch: TSize_t; const src; spitch: TSize_t; width: TSize_t; height: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpy2DToArrayAsync: function(dst: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; const src; spitch: TSize_t; width: TSize_t; height: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpy2DFromArrayAsync: function(var dst; dpitch: TSize_t; const src: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; width: TSize_t; height: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpyToSymbolAsync: function(const symbol: PAnsiChar; const src; count: TSize_t; offset: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t) : cudaError_t; stdcall;
cudaMemcpyFromSymbolAsync: function(var dst; const symbol: PAnsiChar; count: TSize_t; offset: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t) : cudaError_t; stdcall;
cudaMemset: function(var devPtr; value: Integer; count: TSize_t): cudaError_t; stdcall;
cudaMemset2D: function(var devPtr; pitch: TSize_t; value: Integer; width: TSize_t; height: TSize_t): cudaError_t; stdcall;
cudaGetSymbolAddress: function(var devPtr: Pointer; const symbol: PAnsiChar) : cudaError_t; stdcall;
cudaGetSymbolSize: function(var size: TSize_t; const symbol: PAnsiChar) : cudaError_t; stdcall;
cudaGetDeviceCount: function(var count: Integer): cudaError_t; stdcall;
cudaGetDeviceProperties: function(var prop: TCudaDeviceProp; device: Integer) : cudaError_t; stdcall;
cudaChooseDevice: function(var device: Integer; const prop: PCudaDeviceProp) : cudaError_t; stdcall;
cudaSetDevice: function(device: Integer): cudaError_t; stdcall;
cudaGetDevice: function(var device: Integer): cudaError_t; stdcall;
cudaSetDeviceFlags: function(flags: Integer): cudaError_t; stdcall;
cudaSetValidDevices: function(device_arr: PInteger; len: Integer) : cudaError_t; stdcall;
cudaConfigureCall: function(gridDim, blockDim: TDim3; sharedMem: TSize_t; stream: cudaStream_t): cudaError_t; stdcall;
cudaSetupArgument: function(const arg: Pointer; size: TSize_t; offset: TSize_t) : cudaError_t; stdcall;
cudaFuncSetCacheConfig: function(const func: PAnsiChar; cacheConfig: TcudaFuncCache): cudaError_t; stdcall;
cudaLaunch: function(const entry: PAnsiChar): cudaError_t; stdcall;
cudaFuncGetAttributes: function(var attr: TcudaFuncAttributes; const func: PAnsiChar): cudaError_t; stdcall;
cudaGetLastError: function: cudaError_t; stdcall;
cudaGLSetGLDevice: function(device: Integer): cudaError_t; stdcall;
cudaGLRegisterBufferObject: function(bufObj: GLuint): cudaError_t; stdcall;
cudaGraphicsGLRegisterImage: function(const resource: PCUgraphicsResource; image: GLuint; target: GLenum; flags: Cardinal): cudaError_t; stdcall;
cudaGraphicsGLRegisterBuffer: function(const resource: PCUgraphicsResource; buffer: GLuint; flags: Cardinal): cudaError_t; stdcall;
cudaGLMapBufferObject: function(devPtr: Pointer; bufObj: GLuint): cudaError_t; stdcall;
cudaGLUnmapBufferObject: function(bufObj: GLuint): cudaError_t; stdcall;
cudaGLUnregisterBufferObject: function(bufObj: GLuint): cudaError_t; stdcall;
cudaGLSetBufferObjectMapFlags: function(bufObj: GLuint; flags: TCudaGLMapFlags): cudaError_t; stdcall;
cudaGLMapBufferObjectAsync: function(var devPtr: Pointer; bufObj: GLuint; stream: cudaStream_t): cudaError_t; stdcall;
cudaGLUnmapBufferObjectAsync: function(bufObj: GLuint; stream: cudaStream_t) : cudaError_t; stdcall;
cudaGraphicsUnregisterResource: function(resource: PCUgraphicsResource) : cudaError_t; stdcall;
cudaGraphicsResourceSetMapFlags: function(resource: PCUgraphicsResource; flags: Cardinal): cudaError_t; stdcall;
cudaGraphicsMapResources: function(count: Integer; const resources: PCUgraphicsResource; stream: cudaStream_t): cudaError_t; stdcall;
cudaGraphicsUnmapResources: function(count: Integer; const resources: PCUgraphicsResource; stream: cudaStream_t): cudaError_t; stdcall;
cudaGraphicsResourceGetMappedPointer: function(var pDevPtr: TCUdeviceptr; var pSize: Cardinal; resource: PCUgraphicsResource): cudaError_t; stdcall;
cudaGraphicsSubResourceGetMappedArray: function(var pArray: PCUarray; resource: PCUgraphicsResource; arrayIndex: Cardinal; mipLevel: Cardinal) : cudaError_t; stdcall;
cudaGetErrorString: function(error: cudaError_t): PAnsiChar; stdcall;
cudaDriverGetVersion: function(out driverVersion: Integer): cudaError_t; stdcall;
cudaRuntimeGetVersion: function(out runtimeVersion: Integer): cudaError_t; stdcall;
cudaSetDoubleForDevice: function(var d: Double): cudaError_t; stdcall;
cudaSetDoubleForHost: function(var d: Double): cudaError_t; stdcall;
cudaStreamCreate: function(var pStream: cudaStream_t): cudaError_t; stdcall;
cudaStreamDestroy: function(stream: cudaStream_t): cudaError_t; stdcall;
cudaStreamSynchronize: function(stream: cudaStream_t): cudaError_t; stdcall;
cudaStreamQuery: function(stream: cudaStream_t): cudaError_t; stdcall;
cudaEventCreate: function(var event: cudaEvent_t): cudaError_t; stdcall;
cudaEventCreateWithFlags: function(var event: cudaEvent_t; flags: Integer) : cudaError_t; stdcall;
cudaEventRecord: function(event: cudaEvent_t; stream: cudaStream_t) : cudaError_t; stdcall;
cudaEventQuery: function(event: cudaEvent_t): cudaError_t; stdcall;
cudaEventSynchronize: function(event: cudaEvent_t): cudaError_t; stdcall;
cudaEventDestroy: function(event: cudaEvent_t): cudaError_t; stdcall;
cudaEventElapsedTime: function(var ms: Single; start: cudaEvent_t; ending: cudaEvent_t): cudaError_t; stdcall;
cudaWGLGetDevice: function(var device: Integer; hGpu: HGPUNV): cudaError_t; stdcall;
cudaThreadExit: function(): cudaError_t; stdcall;
cudaThreadSynchronize: function(): cudaError_t; stdcall;
cudaThreadSetLimit: function(limit: TcudaLimit; value: TSize_t): cudaError_t; stdcall;
cudaThreadGetLimit: function(var value: TSize_t; limit: TcudaLimit) : cudaError_t; stdcall;

Description

Functions and Procedures

function cudaGetLastErrorString: string;
function InitCUDART: Boolean;
procedure CloseCUDART;
function InitCUDARTFromLibrary(const LibName: WideString): Boolean;
function IsCUDARTInitialized: Boolean;

Types

TcudaError = (...);
Values
  • cudaSuccess:
  • cudaErrorMissingConfiguration:
  • cudaErrorMemoryAllocation:
  • cudaErrorInitializationError:
  • cudaErrorLaunchFailure:
  • cudaErrorPriorLaunchFailure:
  • cudaErrorLaunchTimeout:
  • cudaErrorLaunchOutOfResources:
  • cudaErrorInvalidDeviceFunction:
  • cudaErrorInvalidConfiguration:
  • cudaErrorInvalidDevice:
  • cudaErrorInvalidValue:
  • cudaErrorInvalidPitchValue:
  • cudaErrorInvalidSymbol:
  • cudaErrorMapBufferObjectFailed:
  • cudaErrorUnmapBufferObjectFailed:
  • cudaErrorInvalidHostPointer:
  • cudaErrorInvalidDevicePointer:
  • cudaErrorInvalidTexture:
  • cudaErrorInvalidTextureBinding:
  • cudaErrorInvalidChannelDescriptor:
  • cudaErrorInvalidMemcpyDirection:
  • cudaErrorAddressOfConstant:
  • cudaErrorTextureFetchFailed:
  • cudaErrorTextureNotBound:
  • cudaErrorSynchronizationError:
  • cudaErrorInvalidFilterSetting:
  • cudaErrorInvalidNormSetting:
  • cudaErrorMixedDeviceExecution:
  • cudaErrorCudartUnloading:
  • cudaErrorUnknown:
  • cudaErrorNotYetImplemented:
  • cudaErrorMemoryValueTooLarge:
  • cudaErrorInvalidResourceHandle:
  • cudaErrorNotReady:
  • cudaErrorStartupFailure:
  • cudaErrorApiFailureBase:
TCudaChannelFormatKind = (...);
Values
  • cudaChannelFormatKindSigned:
  • cudaChannelFormatKindUnsigned:
  • cudaChannelFormatKindFloat:
TCudaGLMapFlags = (...);
Values
  • cudaGLMapFlagsNone:
  • cudaGLMapFlagsReadOnly:
  • cudaGLMapFlagsWriteDiscard:
PcudaChannelFormatDesc = ˆTCudaChannelFormatDesc;
TcudaMemcpyKind = (...);
Values
  • cudaMemcpyHostToHost:
  • cudaMemcpyHostToDevice:
  • cudaMemcpyDeviceToHost:
  • cudaMemcpyDeviceToDevice:
PCudaDeviceProp = ˆTCudaDeviceProp;
TcudaTextureAddressMode = (...);
Values
  • cudaAddressModeWrap:
  • cudaAddressModeClamp:
  • cudaAddressModeMirror:
TcudaTextureFilterMode = (...);
Values
  • cudaFilterModePoint:
  • cudaFilterModeLinear:
TcudaTextureReadMode = (...);
Values
  • cudaReadModeElementType:
  • cudaReadModeNormalizedFloat:
PTextureReference = ˆTTextureReference;
PcudaArray = ˆTcudaArray;
cudaError_t = TcudaError;
cudaStream_t = Integer;
cudaEvent_t = Integer;

Constants

CUDARTDLLNAMES: array [0 .. 9] of string = ( 'cudart32_42_9', 'cudart32_41_28', 'cudart32_40_10', 'cudart32_32_16', 'cudart32_31_4', 'cudart32_30_14', 'cudart32_30_9', 'cudart32_30_8', 'cudart32', 'cudart');
CUDART_INF_F: Single = $7F800000;
CUDART_NAN_F: Single = $7FFFFFFF;
CUDART_MIN_DENORM_F: Single = $00000001;
CUDART_MAX_NORMAL_F: Single = $7F7FFFFF;
CUDART_NEG_ZERO_F: Single = $80000000;
CUDART_ZERO_F = 0.0;
CUDART_ONE_F = 1.0;
CUDART_SQRT_HALF_F = 0.707106781;
CUDART_SQRT_TWO_F = 1.414213562;
CUDART_THIRD_F = 0.333333333;
CUDART_PIO4_F = 0.785398163;
CUDART_PIO2_F = 1.570796327;
CUDART_3PIO4_F = 2.356194490;
CUDART_2_OVER_PI_F = 0.636619772;
CUDART_PI_F = 3.141592654;
CUDART_L2E_F = 1.442695041;
CUDART_L2T_F = 3.321928094;
CUDART_LG2_F = 0.301029996;
CUDART_LGE_F = 0.434294482;
CUDART_LN2_F = 0.693147181;
CUDART_LNT_F = 2.302585093;
CUDART_LNPI_F = 1.144729886;
CUDART_TWO_TO_M126_F = 1.175494351E-38;
CUDART_TWO_TO_126_F = 8.507059173E37;
CUDART_NORM_HUGE_F = 3.402823466E38;
CUDART_TWO_TO_23_F = 8388608.0;
CUDART_TWO_TO_24_F = 16777216.0;
CUDART_TWO_TO_31_F = 2147483648.0;
CUDART_TWO_TO_32_F = 4294967296.0;
CUDART_REMQUO_BITS_F = 3;
CUDART_REMQUO_MASK_F = CUDART_REMQUO_BITS_F;
CUDART_TRIG_PLOSS_F = 48039.0;
CUDART_INF: Double = $7FF0000000000000;
CUDART_NAN: Double = $FFF8000000000000;
CUDART_NEG_ZERO: Double = $8000000000000000;
CUDART_MIN_DENORM: Double = $0000000000000001;
CUDART_ZERO = 0.0;
CUDART_ONE = 1.0;
CUDART_SQRT_TWO = 1.4142135623730951E+0;
CUDART_SQRT_HALF = 7.0710678118654757E-1;
CUDART_THIRD = 3.3333333333333333E-1;
CUDART_TWOTHIRD = 6.6666666666666667E-1;
CUDART_PIO4 = 7.8539816339744828E-1;
CUDART_PIO4_HI = 7.8539816339744828E-1;
CUDART_PIO4_LO = 3.0616169978683830E-17;
CUDART_PIO2 = 1.5707963267948966E+0;
CUDART_PIO2_HI = 1.5707963267948966E+0;
CUDART_PIO2_LO = 6.1232339957367660E-17;
CUDART_3PIO4 = 2.3561944901923448E+0;
CUDART_2_OVER_PI = 6.3661977236758138E-1;
CUDART_PI = 3.1415926535897931E+0;
CUDART_PI_HI = 3.1415926535897931E+0;
CUDART_PI_LO = 1.2246467991473532E-16;
CUDART_SQRT_2PI_HI = 2.5066282746310007E+0;
CUDART_SQRT_2PI_LO = -1.8328579980459167E-16;
CUDART_SQRT_PIO2_HI = 1.2533141373155003E+0;
CUDART_SQRT_PIO2_LO = -9.1642899902295834E-17;
CUDART_L2E = 1.4426950408889634E+0;
CUDART_L2E_HI = 1.4426950408889634E+0;
CUDART_L2E_LO = 2.0355273740931033E-17;
CUDART_L2T = 3.3219280948873622E+0;
CUDART_LG2 = 3.0102999566398120E-1;
CUDART_LG2_HI = 3.0102999566398120E-1;
CUDART_LG2_LO = -2.8037281277851704E-18;
CUDART_LGE = 4.3429448190325182E-1;
CUDART_LGE_HI = 4.3429448190325182E-1;
CUDART_LGE_LO = 1.09831965021676510E-17;
CUDART_LN2 = 6.9314718055994529E-1;
CUDART_LN2_HI = 6.9314718055994529E-1;
CUDART_LN2_LO = 2.3190468138462996E-17;
CUDART_LNT = 2.3025850929940459E+0;
CUDART_LNT_HI = 2.3025850929940459E+0;
CUDART_LNT_LO = -2.1707562233822494E-16;
CUDART_LNPI = 1.1447298858494002E+0;
CUDART_LN2_X_1024 = 7.0978271289338397E+2;
CUDART_LN2_X_1025 = 7.1047586007394398E+2;
CUDART_LN2_X_1075 = 7.4513321910194122E+2;
CUDART_LG2_X_1024 = 3.0825471555991675E+2;
CUDART_LG2_X_1075 = 3.2360724533877976E+2;
CUDART_TWO_TO_23 = 8388608.0;
CUDART_TWO_TO_52 = 4503599627370496.0;
CUDART_TWO_TO_54 = 18014398509481984.0;
CUDART_TWO_TO_M54 = 5.5511151231257827E-17;
CUDART_TWO_TO_M1022 = 2.22507385850720140E-308;
CUDART_TRIG_PLOSS = 2147483648.0;

Variables

cudaBindTexture: function(var offset: TSize_t; const texref: PTextureReference; var devPtr: Pointer; var desc: TCudaChannelFormatDesc; size: TSize_t) : cudaError_t; stdcall;
cudaBindTexture2D: function(var offset: TSize_t; const texref: PTextureReference; const devPtr: Pointer; var desc: TCudaChannelFormatDesc; width, height, pitch: TSize_t) : cudaError_t; stdcall;
cudaBindTextureToArray: function(const texref: PTextureReference; const cudaArray: PcudaArray): cudaError_t; stdcall;
cudaUnbindTexture: function(const texref: PTextureReference): cudaError_t; stdcall;
cudaGetTextureAlignmentOffset: function(offset: TSize_t; const texref: PTextureReference): cudaError_t; stdcall;
cudaGetTextureReference: function(const texref: PTextureReference; const symbol: PAnsiChar): cudaError_t; stdcall;
cudaGetChannelDesc: function(var desc: TCudaChannelFormatDesc; const array_: Pointer): cudaError_t; stdcall;
cudaCreateChannelDesc: function(x, y, z, w: Integer; f: TCudaChannelFormatKind): TCudaChannelFormatDesc; stdcall;
cudaMalloc3D: function(var pitchedDevPtr: TcudaPitchedPtr; extent: TcudaExtent): cudaError_t; stdcall;
cudaMalloc3DArray: function(var arrayPtr: PcudaArray; const desc: TCudaChannelFormatDesc; extent: TcudaExtent; flags: Cardinal) : cudaError_t; stdcall;
cudaMemset3D: function(pitchedDevPtr: TcudaPitchedPtr; value: Integer; extent: TcudaExtent): cudaError_t; stdcall;
cudaMemcpy3D: function(const p: TcudaMemcpy3DParms): cudaError_t; stdcall;
cudaMemcpy3DAsync: function(const p: TcudaMemcpy3DParms; stream: cudaStream_t) : cudaError_t; stdcall;
cudaMalloc: function(var devPtr; size: TSize_t): cudaError_t; stdcall;
cudaMallocHost: function(var ptr: Pointer; size: TSize_t): cudaError_t; stdcall;
cudaMallocPitch: function(var devPtr; var pitch: TSize_t; width: TSize_t; height: TSize_t): cudaError_t; stdcall;
cudaMallocArray: function(var aarray: Pointer; var desc: TCudaChannelFormatDesc; width: TSize_t; height: TSize_t) : cudaError_t; stdcall;
cudaFree: function(devPtr: Pointer): cudaError_t; stdcall;
cudaFreeHost: function(ptr: Pointer): cudaError_t; stdcall;
cudaFreeArray: function(const aarray: Pointer): cudaError_t; stdcall;
cudaHostAlloc: function(var pHost: Pointer; bytes: TSize_t; flags: Cardinal) : cudaError_t; stdcall;
cudaHostGetDevicePointer: function(var pDevice: Pointer; pHost: Pointer; flags: Cardinal): cudaError_t; stdcall;
cudaHostGetFlags: function(var pFlags: Cardinal; pHost: Pointer): cudaError_t; stdcall;
cudaMemGetInfo: function(var free: TSize_t; var total: TSize_t): cudaError_t; stdcall;
cudaMemcpy: function(dst: Pointer; src: Pointer; count: TSize_t; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpyToArray: function(var dst: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; var src; count: TSize_t; kind: TcudaMemcpyKind) : cudaError_t; stdcall;
cudaMemcpyFromArray: function(var dst; const src: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; count: TSize_t; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpyArrayToArray: function(dst: PcudaArray; wOffsetDst: TSize_t; hOffsetDst: TSize_t; const src: PcudaArray; wOffsetSrc: TSize_t; hOffsetSrc: TSize_t; count: TSize_t; const kind: TcudaMemcpyKind = cudaMemcpyDeviceToDevice): cudaError_t; stdcall;
cudaMemcpy2D: function(var dst; dpitch: TSize_t; var src; spitch: TSize_t; width: TSize_t; height: TSize_t; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpy2DToArray: function(dst: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; var src; spitch: TSize_t; width: TSize_t; height: TSize_t; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpy2DFromArray: function(var dst; dpitch: TSize_t; src: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; width: TSize_t; height: TSize_t; kind: TcudaMemcpyKind): cudaError_t; stdcall;
cudaMemcpy2DArrayToArray: function(dst: PcudaArray; wOffsetDst: TSize_t; hOffsetDst: TSize_t; src: PcudaArray; wOffsetSrc: TSize_t; hOffsetSrc: TSize_t; width: TSize_t; height: TSize_t; const kind: TcudaMemcpyKind = cudaMemcpyDeviceToDevice): cudaError_t; stdcall;
cudaMemcpyToSymbol: function(symbol: PAnsiChar; var src; count: TSize_t; const offset: TSize_t = 0; const kind: TcudaMemcpyKind = cudaMemcpyHostToDevice): cudaError_t; stdcall;
cudaMemcpyFromSymbol: function(var dst; symbol: PAnsiChar; count: TSize_t; const offset: TSize_t = 0; const kind: TcudaMemcpyKind = cudaMemcpyDeviceToHost): cudaError_t; stdcall;
cudaMemcpyAsync: function(var dst; const src; count: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpyToArrayAsync: function(dst: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; const src; count: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpyFromArrayAsync: function(var dst; const src: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; count: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpy2DAsync: function(var dst; dpitch: TSize_t; const src; spitch: TSize_t; width: TSize_t; height: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpy2DToArrayAsync: function(dst: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; const src; spitch: TSize_t; width: TSize_t; height: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpy2DFromArrayAsync: function(var dst; dpitch: TSize_t; const src: PcudaArray; wOffset: TSize_t; hOffset: TSize_t; width: TSize_t; height: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t): cudaError_t; stdcall;
cudaMemcpyToSymbolAsync: function(const symbol: PAnsiChar; const src; count: TSize_t; offset: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t) : cudaError_t; stdcall;
cudaMemcpyFromSymbolAsync: function(var dst; const symbol: PAnsiChar; count: TSize_t; offset: TSize_t; kind: TcudaMemcpyKind; stream: cudaStream_t) : cudaError_t; stdcall;
cudaMemset: function(var devPtr; value: Integer; count: TSize_t): cudaError_t; stdcall;
cudaMemset2D: function(var devPtr; pitch: TSize_t; value: Integer; width: TSize_t; height: TSize_t): cudaError_t; stdcall;
cudaGetSymbolAddress: function(var devPtr: Pointer; const symbol: PAnsiChar) : cudaError_t; stdcall;
cudaGetSymbolSize: function(var size: TSize_t; const symbol: PAnsiChar) : cudaError_t; stdcall;
cudaGetDeviceCount: function(var count: Integer): cudaError_t; stdcall;
cudaGetDeviceProperties: function(var prop: TCudaDeviceProp; device: Integer) : cudaError_t; stdcall;
cudaChooseDevice: function(var device: Integer; const prop: PCudaDeviceProp) : cudaError_t; stdcall;
cudaSetDevice: function(device: Integer): cudaError_t; stdcall;
cudaGetDevice: function(var device: Integer): cudaError_t; stdcall;
cudaSetDeviceFlags: function(flags: Integer): cudaError_t; stdcall;
cudaSetValidDevices: function(device_arr: PInteger; len: Integer) : cudaError_t; stdcall;
cudaConfigureCall: function(gridDim, blockDim: TDim3; sharedMem: TSize_t; stream: cudaStream_t): cudaError_t; stdcall;
cudaSetupArgument: function(const arg: Pointer; size: TSize_t; offset: TSize_t) : cudaError_t; stdcall;
cudaFuncSetCacheConfig: function(const func: PAnsiChar; cacheConfig: TcudaFuncCache): cudaError_t; stdcall;
cudaLaunch: function(const entry: PAnsiChar): cudaError_t; stdcall;
cudaFuncGetAttributes: function(var attr: TcudaFuncAttributes; const func: PAnsiChar): cudaError_t; stdcall;
cudaGetLastError: function: cudaError_t; stdcall;
cudaGLSetGLDevice: function(device: Integer): cudaError_t; stdcall;
cudaGLRegisterBufferObject: function(bufObj: GLuint): cudaError_t; stdcall;
cudaGraphicsGLRegisterImage: function(const resource: PCUgraphicsResource; image: GLuint; target: GLenum; flags: Cardinal): cudaError_t; stdcall;
cudaGraphicsGLRegisterBuffer: function(const resource: PCUgraphicsResource; buffer: GLuint; flags: Cardinal): cudaError_t; stdcall;
cudaGLMapBufferObject: function(devPtr: Pointer; bufObj: GLuint): cudaError_t; stdcall;
cudaGLUnmapBufferObject: function(bufObj: GLuint): cudaError_t; stdcall;
cudaGLUnregisterBufferObject: function(bufObj: GLuint): cudaError_t; stdcall;
cudaGLSetBufferObjectMapFlags: function(bufObj: GLuint; flags: TCudaGLMapFlags): cudaError_t; stdcall;
cudaGLMapBufferObjectAsync: function(var devPtr: Pointer; bufObj: GLuint; stream: cudaStream_t): cudaError_t; stdcall;
cudaGLUnmapBufferObjectAsync: function(bufObj: GLuint; stream: cudaStream_t) : cudaError_t; stdcall;
cudaGraphicsUnregisterResource: function(resource: PCUgraphicsResource) : cudaError_t; stdcall;
cudaGraphicsResourceSetMapFlags: function(resource: PCUgraphicsResource; flags: Cardinal): cudaError_t; stdcall;
cudaGraphicsMapResources: function(count: Integer; const resources: PCUgraphicsResource; stream: cudaStream_t): cudaError_t; stdcall;
cudaGraphicsUnmapResources: function(count: Integer; const resources: PCUgraphicsResource; stream: cudaStream_t): cudaError_t; stdcall;
cudaGraphicsResourceGetMappedPointer: function(var pDevPtr: TCUdeviceptr; var pSize: Cardinal; resource: PCUgraphicsResource): cudaError_t; stdcall;
cudaGraphicsSubResourceGetMappedArray: function(var pArray: PCUarray; resource: PCUgraphicsResource; arrayIndex: Cardinal; mipLevel: Cardinal) : cudaError_t; stdcall;
cudaGetErrorString: function(error: cudaError_t): PAnsiChar; stdcall;
cudaDriverGetVersion: function(out driverVersion: Integer): cudaError_t; stdcall;
cudaRuntimeGetVersion: function(out runtimeVersion: Integer): cudaError_t; stdcall;
cudaSetDoubleForDevice: function(var d: Double): cudaError_t; stdcall;
cudaSetDoubleForHost: function(var d: Double): cudaError_t; stdcall;
cudaStreamCreate: function(var pStream: cudaStream_t): cudaError_t; stdcall;
cudaStreamDestroy: function(stream: cudaStream_t): cudaError_t; stdcall;
cudaStreamSynchronize: function(stream: cudaStream_t): cudaError_t; stdcall;
cudaStreamQuery: function(stream: cudaStream_t): cudaError_t; stdcall;
cudaEventCreate: function(var event: cudaEvent_t): cudaError_t; stdcall;
cudaEventCreateWithFlags: function(var event: cudaEvent_t; flags: Integer) : cudaError_t; stdcall;
cudaEventRecord: function(event: cudaEvent_t; stream: cudaStream_t) : cudaError_t; stdcall;
cudaEventQuery: function(event: cudaEvent_t): cudaError_t; stdcall;
cudaEventSynchronize: function(event: cudaEvent_t): cudaError_t; stdcall;
cudaEventDestroy: function(event: cudaEvent_t): cudaError_t; stdcall;
cudaEventElapsedTime: function(var ms: Single; start: cudaEvent_t; ending: cudaEvent_t): cudaError_t; stdcall;
cudaWGLGetDevice: function(var device: Integer; hGpu: HGPUNV): cudaError_t; stdcall;
cudaThreadExit: function(): cudaError_t; stdcall;
cudaThreadSynchronize: function(): cudaError_t; stdcall;
cudaThreadSetLimit: function(limit: TcudaLimit; value: TSize_t): cudaError_t; stdcall;
cudaThreadGetLimit: function(var value: TSize_t; limit: TcudaLimit) : cudaError_t; stdcall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:02


GLScene v.1.1.2: GLS_CUDA_Runtime: record TCudaChannelFormatDesc

record TCudaChannelFormatDesc

Unit

GLS_CUDA_Runtime

Declaration

type TCudaChannelFormatDesc = record

Description

Overview

Fields

x: Integer;
y: Integer;
z: Integer;
w: Integer;
f: TCudaChannelFormatKind;

Description

Fields

x: Integer;
y: Integer;
z: Integer;
w: Integer;
f: TCudaChannelFormatKind;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:02


GLScene v.1.1.2: GLS_CUDA_Runtime: record TcudaArray

record TcudaArray

Unit

GLS_CUDA_Runtime

Declaration

type TcudaArray = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:02


GLScene v.1.1.2: GLS_CUDA_Runtime: record TcudaPitchedPtr

record TcudaPitchedPtr

Unit

GLS_CUDA_Runtime

Declaration

type TcudaPitchedPtr = record

Description

Overview

Fields

ptr: Pointer;
pitch: TSize_t;
xsize: TSize_t;
ysize: TSize_t;

Description

Fields

ptr: Pointer;
pitch: TSize_t;
xsize: TSize_t;
ysize: TSize_t;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:02


GLScene v.1.1.2: GLS_CUDA_Runtime: record TcudaExtent

record TcudaExtent

Unit

GLS_CUDA_Runtime

Declaration

type TcudaExtent = record

Description

Overview

Fields

width: TSize_t;
height: TSize_t;
depth: TSize_t;

Description

Fields

width: TSize_t;
height: TSize_t;
depth: TSize_t;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:02


GLScene v.1.1.2: GLS_CUDA_Runtime: record TcudaPos

record TcudaPos

Unit

GLS_CUDA_Runtime

Declaration

type TcudaPos = record

Description

Overview

Fields

x: TSize_t;
y: TSize_t;
z: TSize_t;

Description

Fields

x: TSize_t;
y: TSize_t;
z: TSize_t;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:02


GLScene v.1.1.2: GLS_CUDA_Runtime: record TcudaMemcpy3DParms

record TcudaMemcpy3DParms

Unit

GLS_CUDA_Runtime

Declaration

type TcudaMemcpy3DParms = record

Description

Overview

Fields

srcArray: Pointer;
srcPos: TcudaPos;
srcPtr: TcudaPitchedPtr;
dstArray: Pointer;
dstPos: TcudaPos;
dstPtr: TcudaPitchedPtr;
extent: TcudaExtent;
kind: TcudaMemcpyKind;

Description

Fields

srcArray: Pointer;
srcPos: TcudaPos;
srcPtr: TcudaPitchedPtr;
dstArray: Pointer;
dstPos: TcudaPos;
dstPtr: TcudaPitchedPtr;
extent: TcudaExtent;
kind: TcudaMemcpyKind;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:02


GLScene v.1.1.2: GLS_CUDA_Runtime: record TCudaDeviceProp

record TCudaDeviceProp

Unit

GLS_CUDA_Runtime

Declaration

type TCudaDeviceProp = record

Description

Overview

Fields

name: array [0 .. 256 - 1] of AnsiChar;
totalGlobalMem: TSize_t;
sharedMemPerBlock: TSize_t;
regsPerBlock: Integer;
warpSize: Integer;
memPitch: TSize_t;
maxThreadsPerBlock: Integer;
maxThreadsDim: array [0 .. 3 - 1] of Integer;
maxGridSize: array [0 .. 3 - 1] of Integer;
clockRate: Integer;
totalConstMem: TSize_t;
major: Integer;
minor: Integer;
textureAlignment: TSize_t;
deviceOverlap: Integer;
multiProcessorCount: Integer;
kernelExecTimeoutEnabled: Integer;
egrated: Integer;
canMapHostMemory: Integer;
computeMode: Integer;
maxTexture1D: Integer;
maxTexture2D: array[0..1] of Integer;
maxTexture3D: array[0..2] of Integer;
maxTexture2DArray: array[0..2] of Integer;
surfaceAlignment: TSize_t;
concurrentKernels: Integer;
ECCEnabled: Integer;
pciBusID: Integer;
pciDeviceID: Integer;
tccDriver: Integer;
__cudaReserved: array [0 .. 20] of Integer;

Description

Fields

name: array [0 .. 256 - 1] of AnsiChar;
totalGlobalMem: TSize_t;
sharedMemPerBlock: TSize_t;
regsPerBlock: Integer;
warpSize: Integer;
memPitch: TSize_t;
maxThreadsPerBlock: Integer;
maxThreadsDim: array [0 .. 3 - 1] of Integer;
maxGridSize: array [0 .. 3 - 1] of Integer;
clockRate: Integer;
totalConstMem: TSize_t;
major: Integer;
minor: Integer;
textureAlignment: TSize_t;
deviceOverlap: Integer;
multiProcessorCount: Integer;
kernelExecTimeoutEnabled: Integer;
egrated: Integer;
canMapHostMemory: Integer;
computeMode: Integer;
maxTexture1D: Integer;
maxTexture2D: array[0..1] of Integer;
maxTexture3D: array[0..2] of Integer;
maxTexture2DArray: array[0..2] of Integer;
surfaceAlignment: TSize_t;
concurrentKernels: Integer;
ECCEnabled: Integer;
pciBusID: Integer;
pciDeviceID: Integer;
tccDriver: Integer;
__cudaReserved: array [0 .. 20] of Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:02


GLScene v.1.1.2: GLS_CUDA_Runtime: record TTextureReference

record TTextureReference

Unit

GLS_CUDA_Runtime

Declaration

type TTextureReference = record

Description

Overview

Fields

normalized: Integer;
filterMode: TcudaTextureFilterMode;
addressMode: array [0 .. 2] of TcudaTextureAddressMode;
channelDesc: TCudaChannelFormatDesc;
__cudaReserved: array [0 .. 15] of Integer;

Description

Fields

normalized: Integer;
filterMode: TcudaTextureFilterMode;
addressMode: array [0 .. 2] of TcudaTextureAddressMode;
channelDesc: TCudaChannelFormatDesc;
__cudaReserved: array [0 .. 15] of Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:02


GLScene v.1.1.2: GLS_CUDA_Utility

Unit GLS_CUDA_Utility

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLS_CUDA_Utility<p>

Wraper of cutil.<p>

<b>History : </b><font size=-1><ul> <li>02/03/10 - Yar - Creation </ul></font>

Overview

Functions and Procedures

function InitCUTIL: Boolean;
procedure CloseCUTIL;
function InitCUTILFromLibrary(const LibName: WideString): Boolean;
function IsCUTILInitialized: Boolean;

Constants

CUTILDLL = 'cutil32.dll';

Variables

cutFindFilePath: function(const filename: PAnsiChar; const executablePath: PAnsiChar): PAnsiChar; stdcall;
cutLoadPGMf: function(const filename: PAnsiChar; var data: System.PSingle; var w: Integer; var h: Integer): Boolean; stdcall;
cutSavePGMf: function(const filename: PAnsiChar; data: System.PSingle; w: Integer; h: Integer): Boolean; stdcall;
cutLoadPGMub: function(const filename: PAnsiChar; var data: PByte; var w: Integer; var h: Integer): Boolean; stdcall;
cutLoadPPMub: function(const filename: PAnsiChar; var data: PByte; var w: Integer; var h: Integer): Boolean; stdcall;
cutLoadPPM4ub: function(const filename: PAnsiChar; var data: PByte; var w: Integer; var h: Integer): Boolean; stdcall;
cutLoadPGMi: function(const filename: PAnsiChar; var data: PInteger; var w: Integer; var h: Integer): Boolean; stdcall;
cutLoadPGMs: function(const filename: PAnsiChar; var data: PWord; var w: Integer; var h: Integer): Boolean; stdcall;
cutSavePGMub: function(const filename: PAnsiChar; data: PByte; w: Integer; h: Integer): Boolean; stdcall;
cutSavePPMub: function(const filename: PAnsiChar; data: PByte; w: Integer; h: Integer): Boolean; stdcall;
cutSavePPM4ub: function(const filename: PAnsiChar; data: PByte; w: Integer; h: Integer): Boolean; stdcall;
cutSavePGMi: function(const filename: PAnsiChar; data: PInteger; w: Integer; h: Integer): Boolean; stdcall;
cutSavePGMs: function(const filename: PAnsiChar; data: PWord; w: Integer; h: Integer): Boolean; stdcall;
cutComparef: function(const reference: PSingle; const data: PSingle; const len: Cardinal): Boolean; stdcall;
cutComparei: function(const reference: PInteger; const data: PInteger; const len: Cardinal): Boolean; stdcall;
cutCompareuit: function( const reference: PInteger; const data: PInteger; const len: Cardinal; const epsilon: Single; const threshold: Single ): Boolean; stdcall;
cutCompareub: function(const reference: PByte; const data: PByte; const len: Cardinal): Boolean; stdcall;
cutCompareubt: function( const reference: PByte; const data: PByte; const len: Cardinal; const epsilon: Single; const threshold: Single ): Boolean; stdcall;
cutCompareube: function( const reference: PByte; const data: PByte; const len: Cardinal; const epsilon: Single): Boolean; stdcall;
cutComparefe: function( const reference: PSingle; const data: PSingle; const len: Cardinal; const epsilon: Single): Boolean; stdcall;
cutComparefet: function( const reference: PSingle; const data: PSingle; const len: Cardinal; const epsilon: Single; const threshold: Single ): Boolean; stdcall;
cutCompareL2fe: function( const reference: PSingle; const data: PSingle; const len: Cardinal; const epsilon: Single): Boolean; stdcall;
cutCreateTimer: function(var name: Cardinal): Boolean; stdcall;
cutStartTimer: function(const name: Cardinal): Boolean; stdcall;
cutStopTimer: function(const name: Cardinal): Boolean; stdcall;
cutResetTimer: function(const name: Cardinal): Boolean; stdcall;
cutDeleteTimer: function(const name: Cardinal): Boolean; stdcall;
cutGetTimerValue: function(const name: Cardinal): Single; stdcall;
cutGetAverageTimerValue: function(const name: Cardinal): Single; stdcall;
cutFree: procedure(ptr: Pointer); stdcall;

Description

Functions and Procedures

function InitCUTIL: Boolean;
procedure CloseCUTIL;
function InitCUTILFromLibrary(const LibName: WideString): Boolean;
function IsCUTILInitialized: Boolean;

Constants

CUTILDLL = 'cutil32.dll';

Variables

cutFindFilePath: function(const filename: PAnsiChar; const executablePath: PAnsiChar): PAnsiChar; stdcall;
cutLoadPGMf: function(const filename: PAnsiChar; var data: System.PSingle; var w: Integer; var h: Integer): Boolean; stdcall;
cutSavePGMf: function(const filename: PAnsiChar; data: System.PSingle; w: Integer; h: Integer): Boolean; stdcall;
cutLoadPGMub: function(const filename: PAnsiChar; var data: PByte; var w: Integer; var h: Integer): Boolean; stdcall;
cutLoadPPMub: function(const filename: PAnsiChar; var data: PByte; var w: Integer; var h: Integer): Boolean; stdcall;
cutLoadPPM4ub: function(const filename: PAnsiChar; var data: PByte; var w: Integer; var h: Integer): Boolean; stdcall;
cutLoadPGMi: function(const filename: PAnsiChar; var data: PInteger; var w: Integer; var h: Integer): Boolean; stdcall;
cutLoadPGMs: function(const filename: PAnsiChar; var data: PWord; var w: Integer; var h: Integer): Boolean; stdcall;
cutSavePGMub: function(const filename: PAnsiChar; data: PByte; w: Integer; h: Integer): Boolean; stdcall;
cutSavePPMub: function(const filename: PAnsiChar; data: PByte; w: Integer; h: Integer): Boolean; stdcall;
cutSavePPM4ub: function(const filename: PAnsiChar; data: PByte; w: Integer; h: Integer): Boolean; stdcall;
cutSavePGMi: function(const filename: PAnsiChar; data: PInteger; w: Integer; h: Integer): Boolean; stdcall;
cutSavePGMs: function(const filename: PAnsiChar; data: PWord; w: Integer; h: Integer): Boolean; stdcall;
cutComparef: function(const reference: PSingle; const data: PSingle; const len: Cardinal): Boolean; stdcall;
cutComparei: function(const reference: PInteger; const data: PInteger; const len: Cardinal): Boolean; stdcall;
cutCompareuit: function( const reference: PInteger; const data: PInteger; const len: Cardinal; const epsilon: Single; const threshold: Single ): Boolean; stdcall;
cutCompareub: function(const reference: PByte; const data: PByte; const len: Cardinal): Boolean; stdcall;
cutCompareubt: function( const reference: PByte; const data: PByte; const len: Cardinal; const epsilon: Single; const threshold: Single ): Boolean; stdcall;
cutCompareube: function( const reference: PByte; const data: PByte; const len: Cardinal; const epsilon: Single): Boolean; stdcall;
cutComparefe: function( const reference: PSingle; const data: PSingle; const len: Cardinal; const epsilon: Single): Boolean; stdcall;
cutComparefet: function( const reference: PSingle; const data: PSingle; const len: Cardinal; const epsilon: Single; const threshold: Single ): Boolean; stdcall;
cutCompareL2fe: function( const reference: PSingle; const data: PSingle; const len: Cardinal; const epsilon: Single): Boolean; stdcall;
cutCreateTimer: function(var name: Cardinal): Boolean; stdcall;
cutStartTimer: function(const name: Cardinal): Boolean; stdcall;
cutStopTimer: function(const name: Cardinal): Boolean; stdcall;
cutResetTimer: function(const name: Cardinal): Boolean; stdcall;
cutDeleteTimer: function(const name: Cardinal): Boolean; stdcall;
cutGetTimerValue: function(const name: Cardinal): Single; stdcall;
cutGetAverageTimerValue: function(const name: Cardinal): Single; stdcall;
cutFree: procedure(ptr: Pointer); stdcall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:03


GLScene v.1.1.2: GLS_VDPAU_API

Unit GLS_VDPAU_API

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TVdpPoint |
record TVdpRect |
record TVdpColor |
record TVdpProcamp |
record TVdpOutputSurfaceRenderBlendState |
record TVdpBitstreamBuffer |
record TVdpPictureInfoMPEG1Or2 |
record TVdpReferenceFrameH264 |
record TVdpPictureInfoH264 |
record TVdpPictureInfoVC1 |
record TVdpPictureInfoMPEG4Part2 |
record TVdpLayer |

Types

PVdpBool = ˆTVdpBool;
TVdpBool = longint;
PVdpChromaType = ˆTVdpChromaType;
TVdpChromaType = Tuint32_t;
PVdpYCbCrFormat = ˆTVdpYCbCrFormat;
TVdpYCbCrFormat = Tuint32_t;
PVdpRGBAFormat = ˆTVdpRGBAFormat;
TVdpRGBAFormat = Tuint32_t;
PVdpIndexedFormat = ˆTVdpIndexedFormat;
TVdpIndexedFormat = Tuint32_t;
PVdpPoint = ˆTVdpPoint;
PVdpRect = ˆTVdpRect;
PVdpColor = ˆTVdpColor;
PVdpStatus = ˆTVdpStatus;
TVdpStatus = (...);
PVdpGetErrorString = ˆTVdpGetErrorString;
TVdpGetErrorString = function(status: TVdpStatus): Pchar; cdecl;
TVdpGetApiVersion = function(api_version: Puint32_t): TVdpStatus; cdecl;
TVdpGetInformationString = function(information_string: PPchar): TVdpStatus; cdecl;
PVdpDevice = ˆTVdpDevice;
TVdpDevice = Tuint32_t;
TVdpDeviceDestroy = function(device: TVdpDevice): TVdpStatus; cdecl;
PVdpCSCMatrix = ˆTVdpCSCMatrix;
TVdpCSCMatrix = array [0 .. 2] of array [0 .. 3] of single;
PVdpProcamp = ˆTVdpProcamp;
PVdpColorStandard = ˆTVdpColorStandard;
TVdpColorStandard = Tuint32_t;
TVdpGenerateCSCMatrix = function(procamp: PVdpProcamp; standard: TVdpColorStandard; csc_matrix: PVdpCSCMatrix): TVdpStatus; cdecl;
TVdpVideoSurfaceQueryCapabilities = function(device: TVdpDevice; surface_chroma_type: TVdpChromaType; is_supported: PVdpBool; max_width: Puint32_t; max_height: Puint32_t): TVdpStatus; cdecl;
TVdpVideoSurfaceQueryGetPutBitsYCbCrCapabilities = function(device: TVdpDevice; surface_chroma_type: TVdpChromaType; bits_ycbcr_format: TVdpYCbCrFormat; is_supported: PVdpBool): TVdpStatus; cdecl;
PVdpVideoSurface = ˆTVdpVideoSurface;
TVdpVideoSurface = Tuint32_t;
TVdpVideoSurfaceCreate = function(device: TVdpDevice; chroma_type: TVdpChromaType; width: Tuint32_t; height: Tuint32_t; surface: PVdpVideoSurface): TVdpStatus; cdecl;
TVdpVideoSurfaceDestroy = function(surface: TVdpVideoSurface): TVdpStatus; cdecl;
TVdpVideoSurfaceGetParameters = function(surface: TVdpVideoSurface; chroma_type: PVdpChromaType; width: Puint32_t; height: Puint32_t): TVdpStatus; cdecl;
TVdpVideoSurfaceGetBitsYCbCr = function(surface: TVdpVideoSurface; destination_ycbcr_format: TVdpYCbCrFormat; destination_data: Ppointer; destination_pitches: Puint32_t): TVdpStatus; cdecl;
TVdpVideoSurfacePutBitsYCbCr = function(surface: TVdpVideoSurface; source_ycbcr_format: TVdpYCbCrFormat; source_data: Ppointer; source_pitches: Puint32_t): TVdpStatus; cdecl;
PVdpColorTableFormat = ˆTVdpColorTableFormat;
TVdpColorTableFormat = Tuint32_t;
TVdpOutputSurfaceQueryCapabilities = function(device: TVdpDevice; surface_rgba_format: TVdpRGBAFormat; is_supported: PVdpBool; max_width: Puint32_t; max_height: Puint32_t): TVdpStatus; cdecl;
TVdpOutputSurfaceQueryGetPutBitsNativeCapabilities = function(device: TVdpDevice; surface_rgba_format: TVdpRGBAFormat; is_supported: PVdpBool): TVdpStatus; cdecl;
TVdpOutputSurfaceQueryPutBitsIndexedCapabilities = function(device: TVdpDevice; surface_rgba_format: TVdpRGBAFormat; bits_indexed_format: TVdpIndexedFormat; color_table_format: TVdpColorTableFormat; is_supported: PVdpBool): TVdpStatus; cdecl;
TVdpOutputSurfaceQueryPutBitsYCbCrCapabilities = function(device: TVdpDevice; surface_rgba_format: TVdpRGBAFormat; bits_ycbcr_format: TVdpYCbCrFormat; is_supported: PVdpBool): TVdpStatus; cdecl;
PVdpOutputSurface = ˆTVdpOutputSurface;
TVdpOutputSurface = Tuint32_t;
TVdpOutputSurfaceCreate = function(device: TVdpDevice; rgba_format: TVdpRGBAFormat; width: Tuint32_t; height: Tuint32_t; surface: PVdpOutputSurface): TVdpStatus; cdecl;
TVdpOutputSurfaceDestroy = function(surface: TVdpOutputSurface): TVdpStatus; cdecl;
TVdpOutputSurfaceGetParameters = function(surface: TVdpOutputSurface; rgba_format: PVdpRGBAFormat; width: Puint32_t; height: Puint32_t): TVdpStatus; cdecl;
TVdpOutputSurfaceGetBitsNative = function(surface: TVdpOutputSurface; source_rect: PVdpRect; destination_data: Ppointer; destination_pitches: Puint32_t): TVdpStatus; cdecl;
TVdpOutputSurfacePutBitsNative = function(surface: TVdpOutputSurface; source_data: Ppointer; source_pitches: Puint32_t; destination_rect: PVdpRect): TVdpStatus; cdecl;
TVdpOutputSurfacePutBitsIndexed = function(surface: TVdpOutputSurface; source_indexed_format: TVdpIndexedFormat; source_data: Ppointer; source_pitch: Puint32_t; destination_rect: PVdpRect; color_table_format: TVdpColorTableFormat; color_table: pointer): TVdpStatus; cdecl;
TVdpOutputSurfacePutBitsYCbCr = function(surface: TVdpOutputSurface; source_ycbcr_format: TVdpYCbCrFormat; source_data: Ppointer; source_pitches: Puint32_t; destination_rect: PVdpRect; csc_matrix: PVdpCSCMatrix): TVdpStatus; cdecl;
TVdpBitmapSurfaceQueryCapabilities = function(device: TVdpDevice; surface_rgba_format: TVdpRGBAFormat; is_supported: PVdpBool; max_width: Puint32_t; max_height: Puint32_t): TVdpStatus; cdecl;
PVdpBitmapSurface = ˆTVdpBitmapSurface;
TVdpBitmapSurface = Tuint32_t;
TVdpBitmapSurfaceCreate = function(device: TVdpDevice; rgba_format: TVdpRGBAFormat; width: Tuint32_t; height: Tuint32_t; frequently_accessed: TVdpBool; surface: PVdpBitmapSurface): TVdpStatus; cdecl;
TVdpBitmapSurfaceDestroy = function(surface: TVdpBitmapSurface): TVdpStatus; cdecl;
TVdpBitmapSurfaceGetParameters = function(surface: TVdpBitmapSurface; rgba_format: PVdpRGBAFormat; width: Puint32_t; height: Puint32_t; frequently_accessed: PVdpBool): TVdpStatus; cdecl;
TVdpBitmapSurfacePutBitsNative = function(surface: TVdpBitmapSurface; source_data: Ppointer; source_pitches: Puint32_t; destination_rect: PVdpRect): TVdpStatus; cdecl;
PVdpOutputSurfaceRenderBlendFactor = ˆTVdpOutputSurfaceRenderBlendFactor;
TVdpOutputSurfaceRenderBlendFactor = (...);
PVdpOutputSurfaceRenderBlendEquation = ˆTVdpOutputSurfaceRenderBlendEquation;
TVdpOutputSurfaceRenderBlendEquation = (...);
PVdpOutputSurfaceRenderBlendState = ˆTVdpOutputSurfaceRenderBlendState;
TVdpOutputSurfaceRenderOutputSurface = function(destination_surface: TVdpOutputSurface; destination_rect: PVdpRect; source_surface: TVdpOutputSurface; source_rect: PVdpRect; colors: PVdpColor; blend_state: PVdpOutputSurfaceRenderBlendState; flags: Tuint32_t): TVdpStatus; cdecl;
TVdpOutputSurfaceRenderBitmapSurface = function(destination_surface: TVdpOutputSurface; destination_rect: PVdpRect; source_surface: TVdpBitmapSurface; source_rect: PVdpRect; colors: PVdpColor; blend_state: PVdpOutputSurfaceRenderBlendState; flags: Tuint32_t): TVdpStatus; cdecl;
PVdpDecoderProfile = ˆTVdpDecoderProfile;
TVdpDecoderProfile = Tuint32_t;
TVdpDecoderQueryCapabilities = function(device: TVdpDevice; profile: TVdpDecoderProfile; is_supported: PVdpBool; max_level: Puint32_t; max_macroblocks: Puint32_t; max_width: Puint32_t; max_height: Puint32_t): TVdpStatus; cdecl;
PVdpDecoder = ˆTVdpDecoder;
TVdpDecoder = Tuint32_t;
TVdpDecoderCreate = function(device: TVdpDevice; profile: TVdpDecoderProfile; width: Tuint32_t; height: Tuint32_t; max_references: Tuint32_t; decoder: PVdpDecoder): TVdpStatus; cdecl;
TVdpDecoderDestroy = function(decoder: TVdpDecoder): TVdpStatus; cdecl;
TVdpDecoderGetParameters = function(decoder: TVdpDecoder; profile: PVdpDecoderProfile; width: Puint32_t; height: Puint32_t): TVdpStatus; cdecl;
PVdpBitstreamBuffer = ˆTVdpBitstreamBuffer;
PVdpPictureInfo = ˆTVdpPictureInfo;
TVdpPictureInfo = pointer;
PVdpPictureInfoMPEG1Or2 = ˆTVdpPictureInfoMPEG1Or2;
PVdpReferenceFrameH264 = ˆTVdpReferenceFrameH264;
PVdpPictureInfoH264 = ˆTVdpPictureInfoH264;
PVdpPictureInfoVC1 = ˆTVdpPictureInfoVC1;
PVdpPictureInfoMPEG4Part2 = ˆTVdpPictureInfoMPEG4Part2;
PVdpPictureInfoDivX4 = ˆTVdpPictureInfoDivX4;
TVdpPictureInfoDivX4 = TVdpPictureInfoMPEG4Part2;
PVdpPictureInfoDivX5 = ˆTVdpPictureInfoDivX5;
TVdpPictureInfoDivX5 = TVdpPictureInfoMPEG4Part2;
TVdpDecoderRender = function(decoder: TVdpDecoder; target: TVdpVideoSurface; picture_info: PVdpPictureInfo; bitstream_buffer_count: Tuint32_t; bitstream_buffers: PVdpBitstreamBuffer): TVdpStatus; cdecl;
PVdpVideoMixerFeature = ˆTVdpVideoMixerFeature;
TVdpVideoMixerFeature = Tuint32_t;
PVdpVideoMixerParameter = ˆTVdpVideoMixerParameter;
TVdpVideoMixerParameter = Tuint32_t;
PVdpVideoMixerAttribute = ˆTVdpVideoMixerAttribute;
TVdpVideoMixerAttribute = Tuint32_t;
TVdpVideoMixerQueryFeatureSupport = function(device: TVdpDevice; feature: TVdpVideoMixerFeature; is_supported: PVdpBool): TVdpStatus; cdecl;
TVdpVideoMixerQueryParameterSupport = function(device: TVdpDevice; parameter: TVdpVideoMixerParameter; is_supported: PVdpBool): TVdpStatus; cdecl;
TVdpVideoMixerQueryAttributeSupport = function(device: TVdpDevice; attribute: TVdpVideoMixerAttribute; is_supported: PVdpBool): TVdpStatus; cdecl;
TVdpVideoMixerQueryParameterValueRange = function(device: TVdpDevice; parameter: TVdpVideoMixerParameter; min_value: pointer; max_value: pointer): TVdpStatus; cdecl;
TVdpVideoMixerQueryAttributeValueRange = function(device: TVdpDevice; attribute: TVdpVideoMixerAttribute; min_value: pointer; max_value: pointer): TVdpStatus; cdecl;
PVdpVideoMixer = ˆTVdpVideoMixer;
TVdpVideoMixer = Tuint32_t;
TVdpVideoMixerCreate = function(device: TVdpDevice; feature_count: Tuint32_t; features: PVdpVideoMixerFeature; parameter_count: Tuint32_t; parameters: PVdpVideoMixerParameter; parameter_values: Ppointer; mixer: PVdpVideoMixer): TVdpStatus; cdecl;
TVdpVideoMixerSetFeatureEnables = function(mixer: TVdpVideoMixer; feature_count: Tuint32_t; features: PVdpVideoMixerFeature; feature_enables: PVdpBool): TVdpStatus; cdecl;
TVdpVideoMixerSetAttributeValues = function(mixer: TVdpVideoMixer; attribute_count: Tuint32_t; attributes: PVdpVideoMixerAttribute; attribute_values: Ppointer): TVdpStatus; cdecl;
TVdpVideoMixerGetFeatureSupport = function(mixer: TVdpVideoMixer; feature_count: Tuint32_t; features: PVdpVideoMixerFeature; feature_supports: PVdpBool): TVdpStatus; cdecl;
TVdpVideoMixerGetFeatureEnables = function(mixer: TVdpVideoMixer; feature_count: Tuint32_t; features: PVdpVideoMixerFeature; feature_enables: PVdpBool): TVdpStatus; cdecl;
TVdpVideoMixerGetParameterValues = function(mixer: TVdpVideoMixer; parameter_count: Tuint32_t; parameters: PVdpVideoMixerParameter; parameter_values: Ppointer): TVdpStatus; cdecl;
TVdpVideoMixerGetAttributeValues = function(mixer: TVdpVideoMixer; attribute_count: Tuint32_t; attributes: PVdpVideoMixerAttribute; attribute_values: Ppointer): TVdpStatus; cdecl;
TVdpVideoMixerDestroy = function(mixer: TVdpVideoMixer): TVdpStatus; cdecl;
PVdpVideoMixerPictureStructure = ˆTVdpVideoMixerPictureStructure;
TVdpVideoMixerPictureStructure = (...);
PVdpLayer = ˆTVdpLayer;
TVdpVideoMixerRender = function(mixer: TVdpVideoMixer; background_surface: TVdpOutputSurface; background_source_rect: PVdpRect; current_picture_structure: TVdpVideoMixerPictureStructure; video_surface_past_count: Tuint32_t; video_surface_past: PVdpVideoSurface; video_surface_current: TVdpVideoSurface; video_surface_future_count: Tuint32_t; video_surface_future: PVdpVideoSurface; video_source_rect: PVdpRect; destination_surface: TVdpOutputSurface; destination_rect: PVdpRect; destination_video_rect: PVdpRect; layer_count: Tuint32_t; layers: PVdpLayer): TVdpStatus; cdecl;
PVdpTime = ˆTVdpTime;
TVdpTime = Tuint64_t;
PVdpPresentationQueueTarget = ˆTVdpPresentationQueueTarget;
TVdpPresentationQueueTarget = Tuint32_t;
TVdpPresentationQueueTargetDestroy = function(presentation_queue_target: TVdpPresentationQueueTarget): TVdpStatus; cdecl;
PVdpPresentationQueue = ˆTVdpPresentationQueue;
TVdpPresentationQueue = Tuint32_t;
TVdpPresentationQueueCreate = function(device: TVdpDevice; presentation_queue_target: TVdpPresentationQueueTarget; presentation_queue: PVdpPresentationQueue): TVdpStatus; cdecl;
TVdpPresentationQueueDestroy = function(presentation_queue: TVdpPresentationQueue): TVdpStatus; cdecl;
TVdpPresentationQueueSetBackgroundColor = function(presentation_queue: TVdpPresentationQueue; background_color: PVdpColor): TVdpStatus; cdecl;
TVdpPresentationQueueGetBackgroundColor = function(presentation_queue: TVdpPresentationQueue; background_color: PVdpColor): TVdpStatus; cdecl;
TVdpPresentationQueueGetTime = function(presentation_queue: TVdpPresentationQueue; current_time: PVdpTime): TVdpStatus; cdecl;
TVdpPresentationQueueDisplay = function(presentation_queue: TVdpPresentationQueue; surface: TVdpOutputSurface; clip_width: Tuint32_t; clip_height: Tuint32_t; earliest_presentation_time: TVdpTime): TVdpStatus; cdecl;
TVdpPresentationQueueBlockUntilSurfaceIdle = function(presentation_queue: TVdpPresentationQueue; surface: TVdpOutputSurface; first_presentation_time: PVdpTime): TVdpStatus; cdecl;
PVdpPresentationQueueStatus = ˆTVdpPresentationQueueStatus;
TVdpPresentationQueueStatus = (...);
TVdpPresentationQueueQuerySurfaceStatus = function(presentation_queue: TVdpPresentationQueue; surface: TVdpOutputSurface; status: PVdpPresentationQueueStatus; first_presentation_time: PVdpTime): TVdpStatus; cdecl;
TVdpPreemptionCallback = procedure(device: TVdpDevice; context: pointer); cdecl;
TVdpPreemptionCallbackRegister = function(device: TVdpDevice; callback: TVdpPreemptionCallback; context: pointer): TVdpStatus; cdecl;
PVdpFuncId = ˆTVdpFuncId;
TVdpFuncId = Tuint32_t;
TVdpGetProcAddress = function(device: TVdpDevice; function_id: TVdpFuncId; function_pointer: Ppointer): TVdpStatus; cdecl;

Constants

VDP_TRUE = 1;
VDP_FALSE = 0;
VDP_INVALID_HANDLE = $FFFFFFFF;
VDP_CHROMA_TYPE_420 = TVdpChromaType(0);
VDP_CHROMA_TYPE_422 = TVdpChromaType(1);
VDP_CHROMA_TYPE_444 = TVdpChromaType(2);
VDP_YCBCR_FORMAT_NV12 = TVdpYCbCrFormat(0);
VDP_YCBCR_FORMAT_YV12 = TVdpYCbCrFormat(1);
VDP_YCBCR_FORMAT_UYVY = TVdpYCbCrFormat(2);
VDP_YCBCR_FORMAT_YUYV = TVdpYCbCrFormat(3);
VDP_YCBCR_FORMAT_Y8U8V8A8 = TVdpYCbCrFormat(4);
VDP_YCBCR_FORMAT_V8U8Y8A8 = TVdpYCbCrFormat(5);
VDP_RGBA_FORMAT_B8G8R8A8 = TVdpRGBAFormat(0);
VDP_RGBA_FORMAT_R8G8B8A8 = TVdpRGBAFormat(1);
VDP_RGBA_FORMAT_R10G10B10A2 = TVdpRGBAFormat(2);
VDP_RGBA_FORMAT_B10G10R10A2 = TVdpRGBAFormat(3);
VDP_RGBA_FORMAT_A8 = TVdpRGBAFormat(4);
VDP_INDEXED_FORMAT_A4I4 = TVdpIndexedFormat(0);
VDP_INDEXED_FORMAT_I4A4 = TVdpIndexedFormat(1);
VDP_INDEXED_FORMAT_A8I8 = TVdpIndexedFormat(2);
VDP_INDEXED_FORMAT_I8A8 = TVdpIndexedFormat(3);
VDP_COLOR_STANDARD_ITUR_BT_601 = TVdpColorStandard(0);
VDP_COLOR_STANDARD_ITUR_BT_709 = TVdpColorStandard(1);
VDP_COLOR_STANDARD_SMPTE_240M = TVdpColorStandard(2);
VDP_COLOR_TABLE_FORMAT_B8G8R8X8 = TVdpColorTableFormat(0);
VDP_DECODER_PROFILE_MPEG1 = TVdpDecoderProfile(0);
VDP_DECODER_PROFILE_MPEG2_SIMPLE = TVdpDecoderProfile(1);
VDP_DECODER_PROFILE_MPEG2_MAIN = TVdpDecoderProfile(2);
VDP_DECODER_PROFILE_H264_BASELINE = TVdpDecoderProfile(6);
VDP_DECODER_PROFILE_H264_MAIN = TVdpDecoderProfile(7);
VDP_DECODER_PROFILE_H264_HIGH = TVdpDecoderProfile(8);
VDP_DECODER_PROFILE_VC1_SIMPLE = TVdpDecoderProfile(9);
VDP_DECODER_PROFILE_VC1_MAIN = TVdpDecoderProfile(10);
VDP_DECODER_PROFILE_VC1_ADVANCED = TVdpDecoderProfile(11);
VDP_DECODER_PROFILE_MPEG4_PART2_SP = TVdpDecoderProfile(12);
VDP_DECODER_PROFILE_MPEG4_PART2_ASP = TVdpDecoderProfile(13);
VDP_DECODER_PROFILE_DIVX4_QMOBILE = TVdpDecoderProfile(14);
VDP_DECODER_PROFILE_DIVX4_MOBILE = TVdpDecoderProfile(15);
VDP_DECODER_PROFILE_DIVX4_HOME_THEATER = TVdpDecoderProfile(16);
VDP_DECODER_PROFILE_DIVX4_HD_1080P = TVdpDecoderProfile(17);
VDP_DECODER_PROFILE_DIVX5_QMOBILE = TVdpDecoderProfile(18);
VDP_DECODER_PROFILE_DIVX5_MOBILE = TVdpDecoderProfile(19);
VDP_DECODER_PROFILE_DIVX5_HOME_THEATER = TVdpDecoderProfile(20);
VDP_DECODER_PROFILE_DIVX5_HD_1080P = TVdpDecoderProfile(21);
VDP_VIDEO_MIXER_FEATURE_DEINTERLACE_TEMPORAL = TVdpVideoMixerFeature(0);
VDP_VIDEO_MIXER_FEATURE_DEINTERLACE_TEMPORAL_SPATIAL = TVdpVideoMixerFeature(1);
VDP_VIDEO_MIXER_FEATURE_INVERSE_TELECINE = TVdpVideoMixerFeature(2);
VDP_VIDEO_MIXER_FEATURE_NOISE_REDUCTION = TVdpVideoMixerFeature(3);
VDP_VIDEO_MIXER_FEATURE_SHARPNESS = TVdpVideoMixerFeature(4);
VDP_VIDEO_MIXER_FEATURE_LUMA_KEY = TVdpVideoMixerFeature(5);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L1 = TVdpVideoMixerFeature(11);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L2 = TVdpVideoMixerFeature(12);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L3 = TVdpVideoMixerFeature(13);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L4 = TVdpVideoMixerFeature(14);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L5 = TVdpVideoMixerFeature(15);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L6 = TVdpVideoMixerFeature(16);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L7 = TVdpVideoMixerFeature(17);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L8 = TVdpVideoMixerFeature(18);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L9 = TVdpVideoMixerFeature(19);
VDP_VIDEO_MIXER_PARAMETER_VIDEO_SURFACE_WIDTH = TVdpVideoMixerParameter(0);
VDP_VIDEO_MIXER_PARAMETER_VIDEO_SURFACE_HEIGHT = TVdpVideoMixerParameter(1);
VDP_VIDEO_MIXER_PARAMETER_CHROMA_TYPE = TVdpVideoMixerParameter(2);
VDP_VIDEO_MIXER_PARAMETER_LAYERS = TVdpVideoMixerParameter(3);
VDP_VIDEO_MIXER_ATTRIBUTE_BACKGROUND_COLOR = TVdpVideoMixerAttribute(0);
VDP_VIDEO_MIXER_ATTRIBUTE_CSC_MATRIX = TVdpVideoMixerAttribute(1);
VDP_VIDEO_MIXER_ATTRIBUTE_NOISE_REDUCTION_LEVEL = TVdpVideoMixerAttribute(2);
VDP_VIDEO_MIXER_ATTRIBUTE_SHARPNESS_LEVEL = TVdpVideoMixerAttribute(3);
VDP_VIDEO_MIXER_ATTRIBUTE_LUMA_KEY_MIN_LUMA = TVdpVideoMixerAttribute(4);
VDP_VIDEO_MIXER_ATTRIBUTE_LUMA_KEY_MAX_LUMA = TVdpVideoMixerAttribute(5);
VDP_VIDEO_MIXER_ATTRIBUTE_SKIP_CHROMA_DEINTERLACE = TVdpVideoMixerAttribute(6);
VDP_FUNC_ID_GET_ERROR_STRING = TVdpFuncId(0);
VDP_FUNC_ID_GET_PROC_ADDRESS = TVdpFuncId(1);
VDP_FUNC_ID_GET_API_VERSION = TVdpFuncId(2);
VDP_FUNC_ID_GET_INFORMATION_STRING = TVdpFuncId(4);
VDP_FUNC_ID_DEVICE_DESTROY = TVdpFuncId(5);
VDP_FUNC_ID_GENERATE_CSC_MATRIX = TVdpFuncId(6);
VDP_FUNC_ID_VIDEO_SURFACE_QUERY_CAPABILITIES = TVdpFuncId(7);
VDP_FUNC_ID_VIDEO_SURFACE_QUERY_GET_PUT_BITS_Y_CB_CR_CAPABILITIES = TVdpFuncId(8);
VDP_FUNC_ID_VIDEO_SURFACE_CREATE = TVdpFuncId(9);
VDP_FUNC_ID_VIDEO_SURFACE_DESTROY = TVdpFuncId(10);
VDP_FUNC_ID_VIDEO_SURFACE_GET_PARAMETERS = TVdpFuncId(11);
VDP_FUNC_ID_VIDEO_SURFACE_GET_BITS_Y_CB_CR = TVdpFuncId(12);
VDP_FUNC_ID_VIDEO_SURFACE_PUT_BITS_Y_CB_CR = TVdpFuncId(13);
VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_CAPABILITIES = TVdpFuncId(14);
VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_GET_PUT_BITS_NATIVE_CAPABILITIES = TVdpFuncId(15);
VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_PUT_BITS_INDEXED_CAPABILITIES = TVdpFuncId(16);
VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_PUT_BITS_Y_CB_CR_CAPABILITIES = TVdpFuncId(17);
VDP_FUNC_ID_OUTPUT_SURFACE_CREATE = TVdpFuncId(18);
VDP_FUNC_ID_OUTPUT_SURFACE_DESTROY = TVdpFuncId(19);
VDP_FUNC_ID_OUTPUT_SURFACE_GET_PARAMETERS = TVdpFuncId(20);
VDP_FUNC_ID_OUTPUT_SURFACE_GET_BITS_NATIVE = TVdpFuncId(21);
VDP_FUNC_ID_OUTPUT_SURFACE_PUT_BITS_NATIVE = TVdpFuncId(22);
VDP_FUNC_ID_OUTPUT_SURFACE_PUT_BITS_INDEXED = TVdpFuncId(23);
VDP_FUNC_ID_OUTPUT_SURFACE_PUT_BITS_Y_CB_CR = TVdpFuncId(24);
VDP_FUNC_ID_BITMAP_SURFACE_QUERY_CAPABILITIES = TVdpFuncId(25);
VDP_FUNC_ID_BITMAP_SURFACE_CREATE = TVdpFuncId(26);
VDP_FUNC_ID_BITMAP_SURFACE_DESTROY = TVdpFuncId(27);
VDP_FUNC_ID_BITMAP_SURFACE_GET_PARAMETERS = TVdpFuncId(28);
VDP_FUNC_ID_BITMAP_SURFACE_PUT_BITS_NATIVE = TVdpFuncId(29);
VDP_FUNC_ID_OUTPUT_SURFACE_RENDER_OUTPUT_SURFACE = TVdpFuncId(33);
VDP_FUNC_ID_OUTPUT_SURFACE_RENDER_BITMAP_SURFACE = TVdpFuncId(34);
VDP_FUNC_ID_OUTPUT_SURFACE_RENDER_VIDEO_SURFACE_LUMA = TVdpFuncId(35);
VDP_FUNC_ID_DECODER_QUERY_CAPABILITIES = TVdpFuncId(36);
VDP_FUNC_ID_DECODER_CREATE = TVdpFuncId(37);
VDP_FUNC_ID_DECODER_DESTROY = TVdpFuncId(38);
VDP_FUNC_ID_DECODER_GET_PARAMETERS = TVdpFuncId(39);
VDP_FUNC_ID_DECODER_RENDER = TVdpFuncId(40);
VDP_FUNC_ID_VIDEO_MIXER_QUERY_FEATURE_SUPPORT = TVdpFuncId(41);
VDP_FUNC_ID_VIDEO_MIXER_QUERY_PARAMETER_SUPPORT = TVdpFuncId(42);
VDP_FUNC_ID_VIDEO_MIXER_QUERY_ATTRIBUTE_SUPPORT = TVdpFuncId(43);
VDP_FUNC_ID_VIDEO_MIXER_QUERY_PARAMETER_VALUE_RANGE = TVdpFuncId(44);
VDP_FUNC_ID_VIDEO_MIXER_QUERY_ATTRIBUTE_VALUE_RANGE = TVdpFuncId(45);
VDP_FUNC_ID_VIDEO_MIXER_CREATE = TVdpFuncId(46);
VDP_FUNC_ID_VIDEO_MIXER_SET_FEATURE_ENABLES = TVdpFuncId(47);
VDP_FUNC_ID_VIDEO_MIXER_SET_ATTRIBUTE_VALUES = TVdpFuncId(48);
VDP_FUNC_ID_VIDEO_MIXER_GET_FEATURE_SUPPORT = TVdpFuncId(49);
VDP_FUNC_ID_VIDEO_MIXER_GET_FEATURE_ENABLES = TVdpFuncId(50);
VDP_FUNC_ID_VIDEO_MIXER_GET_PARAMETER_VALUES = TVdpFuncId(51);
VDP_FUNC_ID_VIDEO_MIXER_GET_ATTRIBUTE_VALUES = TVdpFuncId(52);
VDP_FUNC_ID_VIDEO_MIXER_DESTROY = TVdpFuncId(53);
VDP_FUNC_ID_VIDEO_MIXER_RENDER = TVdpFuncId(54);
VDP_FUNC_ID_PRESENTATION_QUEUE_TARGET_DESTROY = TVdpFuncId(55);
VDP_FUNC_ID_PRESENTATION_QUEUE_CREATE = TVdpFuncId(56);
VDP_FUNC_ID_PRESENTATION_QUEUE_DESTROY = TVdpFuncId(57);
VDP_FUNC_ID_PRESENTATION_QUEUE_SET_BACKGROUND_COLOR = TVdpFuncId(58);
VDP_FUNC_ID_PRESENTATION_QUEUE_GET_BACKGROUND_COLOR = TVdpFuncId(59);
VDP_FUNC_ID_PRESENTATION_QUEUE_GET_TIME = TVdpFuncId(62);
VDP_FUNC_ID_PRESENTATION_QUEUE_DISPLAY = TVdpFuncId(63);
VDP_FUNC_ID_PRESENTATION_QUEUE_BLOCK_UNTIL_SURFACE_IDLE = TVdpFuncId(64);
VDP_FUNC_ID_PRESENTATION_QUEUE_QUERY_SURFACE_STATUS = TVdpFuncId(65);
VDP_FUNC_ID_PREEMPTION_CALLBACK_REGISTER = TVdpFuncId(66);
VDPAU_INTERFACE_VERSION = 1;
VDPAU_VERSION = 1;
VDP_PROCAMP_VERSION = 0;
VDP_OUTPUT_SURFACE_RENDER_BLEND_STATE_VERSION = 0;
VDP_OUTPUT_SURFACE_RENDER_ROTATE_0 = 0;
VDP_OUTPUT_SURFACE_RENDER_ROTATE_90 = 1;
VDP_OUTPUT_SURFACE_RENDER_ROTATE_180 = 2;
VDP_OUTPUT_SURFACE_RENDER_ROTATE_270 = 3;
VDP_OUTPUT_SURFACE_RENDER_COLOR_PER_VERTEX = 1 shl 2;
VDP_DECODER_LEVEL_MPEG1_NA = 0;
VDP_DECODER_LEVEL_MPEG2_LL = 0;
VDP_DECODER_LEVEL_MPEG2_ML = 1;
VDP_DECODER_LEVEL_MPEG2_HL14 = 2;
VDP_DECODER_LEVEL_MPEG2_HL = 3;
VDP_DECODER_LEVEL_H264_1 = 10;
VDP_DECODER_LEVEL_H264_1b = 9;
VDP_DECODER_LEVEL_H264_1_1 = 11;
VDP_DECODER_LEVEL_H264_1_2 = 12;
VDP_DECODER_LEVEL_H264_1_3 = 13;
VDP_DECODER_LEVEL_H264_2 = 20;
VDP_DECODER_LEVEL_H264_2_1 = 21;
VDP_DECODER_LEVEL_H264_2_2 = 22;
VDP_DECODER_LEVEL_H264_3 = 30;
VDP_DECODER_LEVEL_H264_3_1 = 31;
VDP_DECODER_LEVEL_H264_3_2 = 32;
VDP_DECODER_LEVEL_H264_4 = 40;
VDP_DECODER_LEVEL_H264_4_1 = 41;
VDP_DECODER_LEVEL_H264_4_2 = 42;
VDP_DECODER_LEVEL_H264_5 = 50;
VDP_DECODER_LEVEL_H264_5_1 = 51;
VDP_DECODER_LEVEL_VC1_SIMPLE_LOW = 0;
VDP_DECODER_LEVEL_VC1_SIMPLE_MEDIUM = 1;
VDP_DECODER_LEVEL_VC1_MAIN_LOW = 0;
VDP_DECODER_LEVEL_VC1_MAIN_MEDIUM = 1;
VDP_DECODER_LEVEL_VC1_MAIN_HIGH = 2;
VDP_DECODER_LEVEL_VC1_ADVANCED_L0 = 0;
VDP_DECODER_LEVEL_VC1_ADVANCED_L1 = 1;
VDP_DECODER_LEVEL_VC1_ADVANCED_L2 = 2;
VDP_DECODER_LEVEL_VC1_ADVANCED_L3 = 3;
VDP_DECODER_LEVEL_VC1_ADVANCED_L4 = 4;
VDP_DECODER_LEVEL_MPEG4_PART2_SP_L0 = 0;
VDP_DECODER_LEVEL_MPEG4_PART2_SP_L1 = 1;
VDP_DECODER_LEVEL_MPEG4_PART2_SP_L2 = 2;
VDP_DECODER_LEVEL_MPEG4_PART2_SP_L3 = 3;
VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L0 = 0;
VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L1 = 1;
VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L2 = 2;
VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L3 = 3;
VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L4 = 4;
VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L5 = 5;
VDP_DECODER_LEVEL_DIVX_NA = 0;
VDP_BITSTREAM_BUFFER_VERSION = 0;
VDP_LAYER_VERSION = 0;
VDP_FUNC_ID_BASE_WINSYS = $1000;

Description

Types

PVdpBool = ˆTVdpBool;
TVdpBool = longint;
PVdpChromaType = ˆTVdpChromaType;
TVdpChromaType = Tuint32_t;
PVdpYCbCrFormat = ˆTVdpYCbCrFormat;
TVdpYCbCrFormat = Tuint32_t;
PVdpRGBAFormat = ˆTVdpRGBAFormat;
TVdpRGBAFormat = Tuint32_t;
PVdpIndexedFormat = ˆTVdpIndexedFormat;
TVdpIndexedFormat = Tuint32_t;
PVdpPoint = ˆTVdpPoint;
PVdpRect = ˆTVdpRect;
PVdpColor = ˆTVdpColor;
PVdpStatus = ˆTVdpStatus;
TVdpStatus = (...);
Values
  • VDP_STATUS_OK = 0:
  • VDP_STATUS_NO_IMPLEMENTATION:
  • VDP_STATUS_DISPLAY_PREEMPTED:
  • VDP_STATUS_INVALID_HANDLE:
  • VDP_STATUS_INVALID_POINTER:
  • VDP_STATUS_INVALID_CHROMA_TYPE:
  • VDP_STATUS_INVALID_Y_CB_CR_FORMAT:
  • VDP_STATUS_INVALID_RGBA_FORMAT:
  • VDP_STATUS_INVALID_INDEXED_FORMAT:
  • VDP_STATUS_INVALID_COLOR_STANDARD:
  • VDP_STATUS_INVALID_COLOR_TABLE_FORMAT:
  • VDP_STATUS_INVALID_BLEND_FACTOR:
  • VDP_STATUS_INVALID_BLEND_EQUATION:
  • VDP_STATUS_INVALID_FLAG:
  • VDP_STATUS_INVALID_DECODER_PROFILE:
  • VDP_STATUS_INVALID_VIDEO_MIXER_FEATURE:
  • VDP_STATUS_INVALID_VIDEO_MIXER_PARAMETER:
  • VDP_STATUS_INVALID_VIDEO_MIXER_ATTRIBUTE:
  • VDP_STATUS_INVALID_VIDEO_MIXER_PICTURE_STRUCTURE:
  • VDP_STATUS_INVALID_FUNC_ID:
  • VDP_STATUS_INVALID_SIZE:
  • VDP_STATUS_INVALID_VALUE:
  • VDP_STATUS_INVALID_STRUCT_VERSION:
  • VDP_STATUS_RESOURCES:
  • VDP_STATUS_HANDLE_DEVICE_MISMATCH:
  • VDP_STATUS_ERROR:
PVdpGetErrorString = ˆTVdpGetErrorString;
TVdpGetErrorString = function(status: TVdpStatus): Pchar; cdecl;
TVdpGetApiVersion = function(api_version: Puint32_t): TVdpStatus; cdecl;
TVdpGetInformationString = function(information_string: PPchar): TVdpStatus; cdecl;
PVdpDevice = ˆTVdpDevice;
TVdpDevice = Tuint32_t;
TVdpDeviceDestroy = function(device: TVdpDevice): TVdpStatus; cdecl;
PVdpCSCMatrix = ˆTVdpCSCMatrix;
TVdpCSCMatrix = array [0 .. 2] of array [0 .. 3] of single;
PVdpProcamp = ˆTVdpProcamp;
PVdpColorStandard = ˆTVdpColorStandard;
TVdpColorStandard = Tuint32_t;
TVdpGenerateCSCMatrix = function(procamp: PVdpProcamp; standard: TVdpColorStandard; csc_matrix: PVdpCSCMatrix): TVdpStatus; cdecl;
TVdpVideoSurfaceQueryCapabilities = function(device: TVdpDevice; surface_chroma_type: TVdpChromaType; is_supported: PVdpBool; max_width: Puint32_t; max_height: Puint32_t): TVdpStatus; cdecl;
TVdpVideoSurfaceQueryGetPutBitsYCbCrCapabilities = function(device: TVdpDevice; surface_chroma_type: TVdpChromaType; bits_ycbcr_format: TVdpYCbCrFormat; is_supported: PVdpBool): TVdpStatus; cdecl;
PVdpVideoSurface = ˆTVdpVideoSurface;
TVdpVideoSurface = Tuint32_t;
TVdpVideoSurfaceCreate = function(device: TVdpDevice; chroma_type: TVdpChromaType; width: Tuint32_t; height: Tuint32_t; surface: PVdpVideoSurface): TVdpStatus; cdecl;
TVdpVideoSurfaceDestroy = function(surface: TVdpVideoSurface): TVdpStatus; cdecl;
TVdpVideoSurfaceGetParameters = function(surface: TVdpVideoSurface; chroma_type: PVdpChromaType; width: Puint32_t; height: Puint32_t): TVdpStatus; cdecl;
TVdpVideoSurfaceGetBitsYCbCr = function(surface: TVdpVideoSurface; destination_ycbcr_format: TVdpYCbCrFormat; destination_data: Ppointer; destination_pitches: Puint32_t): TVdpStatus; cdecl;
TVdpVideoSurfacePutBitsYCbCr = function(surface: TVdpVideoSurface; source_ycbcr_format: TVdpYCbCrFormat; source_data: Ppointer; source_pitches: Puint32_t): TVdpStatus; cdecl;
PVdpColorTableFormat = ˆTVdpColorTableFormat;
TVdpColorTableFormat = Tuint32_t;
TVdpOutputSurfaceQueryCapabilities = function(device: TVdpDevice; surface_rgba_format: TVdpRGBAFormat; is_supported: PVdpBool; max_width: Puint32_t; max_height: Puint32_t): TVdpStatus; cdecl;
TVdpOutputSurfaceQueryGetPutBitsNativeCapabilities = function(device: TVdpDevice; surface_rgba_format: TVdpRGBAFormat; is_supported: PVdpBool): TVdpStatus; cdecl;
TVdpOutputSurfaceQueryPutBitsIndexedCapabilities = function(device: TVdpDevice; surface_rgba_format: TVdpRGBAFormat; bits_indexed_format: TVdpIndexedFormat; color_table_format: TVdpColorTableFormat; is_supported: PVdpBool): TVdpStatus; cdecl;
TVdpOutputSurfaceQueryPutBitsYCbCrCapabilities = function(device: TVdpDevice; surface_rgba_format: TVdpRGBAFormat; bits_ycbcr_format: TVdpYCbCrFormat; is_supported: PVdpBool): TVdpStatus; cdecl;
PVdpOutputSurface = ˆTVdpOutputSurface;
TVdpOutputSurface = Tuint32_t;
TVdpOutputSurfaceCreate = function(device: TVdpDevice; rgba_format: TVdpRGBAFormat; width: Tuint32_t; height: Tuint32_t; surface: PVdpOutputSurface): TVdpStatus; cdecl;
TVdpOutputSurfaceDestroy = function(surface: TVdpOutputSurface): TVdpStatus; cdecl;
TVdpOutputSurfaceGetParameters = function(surface: TVdpOutputSurface; rgba_format: PVdpRGBAFormat; width: Puint32_t; height: Puint32_t): TVdpStatus; cdecl;
TVdpOutputSurfaceGetBitsNative = function(surface: TVdpOutputSurface; source_rect: PVdpRect; destination_data: Ppointer; destination_pitches: Puint32_t): TVdpStatus; cdecl;
TVdpOutputSurfacePutBitsNative = function(surface: TVdpOutputSurface; source_data: Ppointer; source_pitches: Puint32_t; destination_rect: PVdpRect): TVdpStatus; cdecl;
TVdpOutputSurfacePutBitsIndexed = function(surface: TVdpOutputSurface; source_indexed_format: TVdpIndexedFormat; source_data: Ppointer; source_pitch: Puint32_t; destination_rect: PVdpRect; color_table_format: TVdpColorTableFormat; color_table: pointer): TVdpStatus; cdecl;
TVdpOutputSurfacePutBitsYCbCr = function(surface: TVdpOutputSurface; source_ycbcr_format: TVdpYCbCrFormat; source_data: Ppointer; source_pitches: Puint32_t; destination_rect: PVdpRect; csc_matrix: PVdpCSCMatrix): TVdpStatus; cdecl;
TVdpBitmapSurfaceQueryCapabilities = function(device: TVdpDevice; surface_rgba_format: TVdpRGBAFormat; is_supported: PVdpBool; max_width: Puint32_t; max_height: Puint32_t): TVdpStatus; cdecl;
PVdpBitmapSurface = ˆTVdpBitmapSurface;
TVdpBitmapSurface = Tuint32_t;
TVdpBitmapSurfaceCreate = function(device: TVdpDevice; rgba_format: TVdpRGBAFormat; width: Tuint32_t; height: Tuint32_t; frequently_accessed: TVdpBool; surface: PVdpBitmapSurface): TVdpStatus; cdecl;
TVdpBitmapSurfaceDestroy = function(surface: TVdpBitmapSurface): TVdpStatus; cdecl;
TVdpBitmapSurfaceGetParameters = function(surface: TVdpBitmapSurface; rgba_format: PVdpRGBAFormat; width: Puint32_t; height: Puint32_t; frequently_accessed: PVdpBool): TVdpStatus; cdecl;
TVdpBitmapSurfacePutBitsNative = function(surface: TVdpBitmapSurface; source_data: Ppointer; source_pitches: Puint32_t; destination_rect: PVdpRect): TVdpStatus; cdecl;
PVdpOutputSurfaceRenderBlendFactor = ˆTVdpOutputSurfaceRenderBlendFactor;
TVdpOutputSurfaceRenderBlendFactor = (...);
Values
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_ZERO = 0:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_ONE = 1:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_SRC_COLOR = 2:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_ONE_MINUS_SRC_COLOR = 3:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_SRC_ALPHA = 4:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_ONE_MINUS_SRC_ALPHA = 5:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_DST_ALPHA = 6:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_ONE_MINUS_DST_ALPHA = 7:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_DST_COLOR = 8:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_ONE_MINUS_DST_COLOR = 9:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_SRC_ALPHA_SATURATE = 10:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_CONSTANT_COLOR = 11:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_ONE_MINUS_CONSTANT_COLOR = 12:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_CONSTANT_ALPHA = 13:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_FACTOR_ONE_MINUS_CONSTANT_ALPHA = 14:
PVdpOutputSurfaceRenderBlendEquation = ˆTVdpOutputSurfaceRenderBlendEquation;
TVdpOutputSurfaceRenderBlendEquation = (...);
Values
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_EQUATION_SUBTRACT = 0:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_EQUATION_REVERSE_SUBTRACT = 1:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_EQUATION_ADD = 2:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_EQUATION_MIN = 3:
  • VDP_OUTPUT_SURFACE_RENDER_BLEND_EQUATION_MAX = 4:
PVdpOutputSurfaceRenderBlendState = ˆTVdpOutputSurfaceRenderBlendState;
TVdpOutputSurfaceRenderOutputSurface = function(destination_surface: TVdpOutputSurface; destination_rect: PVdpRect; source_surface: TVdpOutputSurface; source_rect: PVdpRect; colors: PVdpColor; blend_state: PVdpOutputSurfaceRenderBlendState; flags: Tuint32_t): TVdpStatus; cdecl;
TVdpOutputSurfaceRenderBitmapSurface = function(destination_surface: TVdpOutputSurface; destination_rect: PVdpRect; source_surface: TVdpBitmapSurface; source_rect: PVdpRect; colors: PVdpColor; blend_state: PVdpOutputSurfaceRenderBlendState; flags: Tuint32_t): TVdpStatus; cdecl;
PVdpDecoderProfile = ˆTVdpDecoderProfile;
TVdpDecoderProfile = Tuint32_t;
TVdpDecoderQueryCapabilities = function(device: TVdpDevice; profile: TVdpDecoderProfile; is_supported: PVdpBool; max_level: Puint32_t; max_macroblocks: Puint32_t; max_width: Puint32_t; max_height: Puint32_t): TVdpStatus; cdecl;
PVdpDecoder = ˆTVdpDecoder;
TVdpDecoder = Tuint32_t;
TVdpDecoderCreate = function(device: TVdpDevice; profile: TVdpDecoderProfile; width: Tuint32_t; height: Tuint32_t; max_references: Tuint32_t; decoder: PVdpDecoder): TVdpStatus; cdecl;
TVdpDecoderDestroy = function(decoder: TVdpDecoder): TVdpStatus; cdecl;
TVdpDecoderGetParameters = function(decoder: TVdpDecoder; profile: PVdpDecoderProfile; width: Puint32_t; height: Puint32_t): TVdpStatus; cdecl;
PVdpBitstreamBuffer = ˆTVdpBitstreamBuffer;
PVdpPictureInfo = ˆTVdpPictureInfo;
TVdpPictureInfo = pointer;
PVdpPictureInfoMPEG1Or2 = ˆTVdpPictureInfoMPEG1Or2;
PVdpReferenceFrameH264 = ˆTVdpReferenceFrameH264;
PVdpPictureInfoH264 = ˆTVdpPictureInfoH264;
PVdpPictureInfoVC1 = ˆTVdpPictureInfoVC1;
PVdpPictureInfoMPEG4Part2 = ˆTVdpPictureInfoMPEG4Part2;
PVdpPictureInfoDivX4 = ˆTVdpPictureInfoDivX4;
TVdpPictureInfoDivX4 = TVdpPictureInfoMPEG4Part2;
PVdpPictureInfoDivX5 = ˆTVdpPictureInfoDivX5;
TVdpPictureInfoDivX5 = TVdpPictureInfoMPEG4Part2;
TVdpDecoderRender = function(decoder: TVdpDecoder; target: TVdpVideoSurface; picture_info: PVdpPictureInfo; bitstream_buffer_count: Tuint32_t; bitstream_buffers: PVdpBitstreamBuffer): TVdpStatus; cdecl;
PVdpVideoMixerFeature = ˆTVdpVideoMixerFeature;
TVdpVideoMixerFeature = Tuint32_t;
PVdpVideoMixerParameter = ˆTVdpVideoMixerParameter;
TVdpVideoMixerParameter = Tuint32_t;
PVdpVideoMixerAttribute = ˆTVdpVideoMixerAttribute;
TVdpVideoMixerAttribute = Tuint32_t;
TVdpVideoMixerQueryFeatureSupport = function(device: TVdpDevice; feature: TVdpVideoMixerFeature; is_supported: PVdpBool): TVdpStatus; cdecl;
TVdpVideoMixerQueryParameterSupport = function(device: TVdpDevice; parameter: TVdpVideoMixerParameter; is_supported: PVdpBool): TVdpStatus; cdecl;
TVdpVideoMixerQueryAttributeSupport = function(device: TVdpDevice; attribute: TVdpVideoMixerAttribute; is_supported: PVdpBool): TVdpStatus; cdecl;
TVdpVideoMixerQueryParameterValueRange = function(device: TVdpDevice; parameter: TVdpVideoMixerParameter; min_value: pointer; max_value: pointer): TVdpStatus; cdecl;
TVdpVideoMixerQueryAttributeValueRange = function(device: TVdpDevice; attribute: TVdpVideoMixerAttribute; min_value: pointer; max_value: pointer): TVdpStatus; cdecl;
PVdpVideoMixer = ˆTVdpVideoMixer;
TVdpVideoMixer = Tuint32_t;
TVdpVideoMixerCreate = function(device: TVdpDevice; feature_count: Tuint32_t; features: PVdpVideoMixerFeature; parameter_count: Tuint32_t; parameters: PVdpVideoMixerParameter; parameter_values: Ppointer; mixer: PVdpVideoMixer): TVdpStatus; cdecl;
TVdpVideoMixerSetFeatureEnables = function(mixer: TVdpVideoMixer; feature_count: Tuint32_t; features: PVdpVideoMixerFeature; feature_enables: PVdpBool): TVdpStatus; cdecl;
TVdpVideoMixerSetAttributeValues = function(mixer: TVdpVideoMixer; attribute_count: Tuint32_t; attributes: PVdpVideoMixerAttribute; attribute_values: Ppointer): TVdpStatus; cdecl;
TVdpVideoMixerGetFeatureSupport = function(mixer: TVdpVideoMixer; feature_count: Tuint32_t; features: PVdpVideoMixerFeature; feature_supports: PVdpBool): TVdpStatus; cdecl;
TVdpVideoMixerGetFeatureEnables = function(mixer: TVdpVideoMixer; feature_count: Tuint32_t; features: PVdpVideoMixerFeature; feature_enables: PVdpBool): TVdpStatus; cdecl;
TVdpVideoMixerGetParameterValues = function(mixer: TVdpVideoMixer; parameter_count: Tuint32_t; parameters: PVdpVideoMixerParameter; parameter_values: Ppointer): TVdpStatus; cdecl;
TVdpVideoMixerGetAttributeValues = function(mixer: TVdpVideoMixer; attribute_count: Tuint32_t; attributes: PVdpVideoMixerAttribute; attribute_values: Ppointer): TVdpStatus; cdecl;
TVdpVideoMixerDestroy = function(mixer: TVdpVideoMixer): TVdpStatus; cdecl;
PVdpVideoMixerPictureStructure = ˆTVdpVideoMixerPictureStructure;
TVdpVideoMixerPictureStructure = (...);
Values
  • VDP_VIDEO_MIXER_PICTURE_STRUCTURE_TOP_FIELD:
  • VDP_VIDEO_MIXER_PICTURE_STRUCTURE_BOTTOM_FIELD:
  • VDP_VIDEO_MIXER_PICTURE_STRUCTURE_FRAME:
PVdpLayer = ˆTVdpLayer;
TVdpVideoMixerRender = function(mixer: TVdpVideoMixer; background_surface: TVdpOutputSurface; background_source_rect: PVdpRect; current_picture_structure: TVdpVideoMixerPictureStructure; video_surface_past_count: Tuint32_t; video_surface_past: PVdpVideoSurface; video_surface_current: TVdpVideoSurface; video_surface_future_count: Tuint32_t; video_surface_future: PVdpVideoSurface; video_source_rect: PVdpRect; destination_surface: TVdpOutputSurface; destination_rect: PVdpRect; destination_video_rect: PVdpRect; layer_count: Tuint32_t; layers: PVdpLayer): TVdpStatus; cdecl;
PVdpTime = ˆTVdpTime;
TVdpTime = Tuint64_t;
PVdpPresentationQueueTarget = ˆTVdpPresentationQueueTarget;
TVdpPresentationQueueTarget = Tuint32_t;
TVdpPresentationQueueTargetDestroy = function(presentation_queue_target: TVdpPresentationQueueTarget): TVdpStatus; cdecl;
PVdpPresentationQueue = ˆTVdpPresentationQueue;
TVdpPresentationQueue = Tuint32_t;
TVdpPresentationQueueCreate = function(device: TVdpDevice; presentation_queue_target: TVdpPresentationQueueTarget; presentation_queue: PVdpPresentationQueue): TVdpStatus; cdecl;
TVdpPresentationQueueDestroy = function(presentation_queue: TVdpPresentationQueue): TVdpStatus; cdecl;
TVdpPresentationQueueSetBackgroundColor = function(presentation_queue: TVdpPresentationQueue; background_color: PVdpColor): TVdpStatus; cdecl;
TVdpPresentationQueueGetBackgroundColor = function(presentation_queue: TVdpPresentationQueue; background_color: PVdpColor): TVdpStatus; cdecl;
TVdpPresentationQueueGetTime = function(presentation_queue: TVdpPresentationQueue; current_time: PVdpTime): TVdpStatus; cdecl;
TVdpPresentationQueueDisplay = function(presentation_queue: TVdpPresentationQueue; surface: TVdpOutputSurface; clip_width: Tuint32_t; clip_height: Tuint32_t; earliest_presentation_time: TVdpTime): TVdpStatus; cdecl;
TVdpPresentationQueueBlockUntilSurfaceIdle = function(presentation_queue: TVdpPresentationQueue; surface: TVdpOutputSurface; first_presentation_time: PVdpTime): TVdpStatus; cdecl;
PVdpPresentationQueueStatus = ˆTVdpPresentationQueueStatus;
TVdpPresentationQueueStatus = (...);
Values
  • VDP_PRESENTATION_QUEUE_STATUS_IDLE:
  • VDP_PRESENTATION_QUEUE_STATUS_QUEUED:
  • VDP_PRESENTATION_QUEUE_STATUS_VISIBLE:
TVdpPresentationQueueQuerySurfaceStatus = function(presentation_queue: TVdpPresentationQueue; surface: TVdpOutputSurface; status: PVdpPresentationQueueStatus; first_presentation_time: PVdpTime): TVdpStatus; cdecl;
TVdpPreemptionCallback = procedure(device: TVdpDevice; context: pointer); cdecl;
TVdpPreemptionCallbackRegister = function(device: TVdpDevice; callback: TVdpPreemptionCallback; context: pointer): TVdpStatus; cdecl;
PVdpFuncId = ˆTVdpFuncId;
TVdpFuncId = Tuint32_t;
TVdpGetProcAddress = function(device: TVdpDevice; function_id: TVdpFuncId; function_pointer: Ppointer): TVdpStatus; cdecl;

Constants

VDP_TRUE = 1;
VDP_FALSE = 0;
VDP_INVALID_HANDLE = $FFFFFFFF;
VDP_CHROMA_TYPE_420 = TVdpChromaType(0);
VDP_CHROMA_TYPE_422 = TVdpChromaType(1);
VDP_CHROMA_TYPE_444 = TVdpChromaType(2);
VDP_YCBCR_FORMAT_NV12 = TVdpYCbCrFormat(0);
VDP_YCBCR_FORMAT_YV12 = TVdpYCbCrFormat(1);
VDP_YCBCR_FORMAT_UYVY = TVdpYCbCrFormat(2);
VDP_YCBCR_FORMAT_YUYV = TVdpYCbCrFormat(3);
VDP_YCBCR_FORMAT_Y8U8V8A8 = TVdpYCbCrFormat(4);
VDP_YCBCR_FORMAT_V8U8Y8A8 = TVdpYCbCrFormat(5);
VDP_RGBA_FORMAT_B8G8R8A8 = TVdpRGBAFormat(0);
VDP_RGBA_FORMAT_R8G8B8A8 = TVdpRGBAFormat(1);
VDP_RGBA_FORMAT_R10G10B10A2 = TVdpRGBAFormat(2);
VDP_RGBA_FORMAT_B10G10R10A2 = TVdpRGBAFormat(3);
VDP_RGBA_FORMAT_A8 = TVdpRGBAFormat(4);
VDP_INDEXED_FORMAT_A4I4 = TVdpIndexedFormat(0);
VDP_INDEXED_FORMAT_I4A4 = TVdpIndexedFormat(1);
VDP_INDEXED_FORMAT_A8I8 = TVdpIndexedFormat(2);
VDP_INDEXED_FORMAT_I8A8 = TVdpIndexedFormat(3);
VDP_COLOR_STANDARD_ITUR_BT_601 = TVdpColorStandard(0);
VDP_COLOR_STANDARD_ITUR_BT_709 = TVdpColorStandard(1);
VDP_COLOR_STANDARD_SMPTE_240M = TVdpColorStandard(2);
VDP_COLOR_TABLE_FORMAT_B8G8R8X8 = TVdpColorTableFormat(0);
VDP_DECODER_PROFILE_MPEG1 = TVdpDecoderProfile(0);
VDP_DECODER_PROFILE_MPEG2_SIMPLE = TVdpDecoderProfile(1);
VDP_DECODER_PROFILE_MPEG2_MAIN = TVdpDecoderProfile(2);
VDP_DECODER_PROFILE_H264_BASELINE = TVdpDecoderProfile(6);
VDP_DECODER_PROFILE_H264_MAIN = TVdpDecoderProfile(7);
VDP_DECODER_PROFILE_H264_HIGH = TVdpDecoderProfile(8);
VDP_DECODER_PROFILE_VC1_SIMPLE = TVdpDecoderProfile(9);
VDP_DECODER_PROFILE_VC1_MAIN = TVdpDecoderProfile(10);
VDP_DECODER_PROFILE_VC1_ADVANCED = TVdpDecoderProfile(11);
VDP_DECODER_PROFILE_MPEG4_PART2_SP = TVdpDecoderProfile(12);
VDP_DECODER_PROFILE_MPEG4_PART2_ASP = TVdpDecoderProfile(13);
VDP_DECODER_PROFILE_DIVX4_QMOBILE = TVdpDecoderProfile(14);
VDP_DECODER_PROFILE_DIVX4_MOBILE = TVdpDecoderProfile(15);
VDP_DECODER_PROFILE_DIVX4_HOME_THEATER = TVdpDecoderProfile(16);
VDP_DECODER_PROFILE_DIVX4_HD_1080P = TVdpDecoderProfile(17);
VDP_DECODER_PROFILE_DIVX5_QMOBILE = TVdpDecoderProfile(18);
VDP_DECODER_PROFILE_DIVX5_MOBILE = TVdpDecoderProfile(19);
VDP_DECODER_PROFILE_DIVX5_HOME_THEATER = TVdpDecoderProfile(20);
VDP_DECODER_PROFILE_DIVX5_HD_1080P = TVdpDecoderProfile(21);
VDP_VIDEO_MIXER_FEATURE_DEINTERLACE_TEMPORAL = TVdpVideoMixerFeature(0);
VDP_VIDEO_MIXER_FEATURE_DEINTERLACE_TEMPORAL_SPATIAL = TVdpVideoMixerFeature(1);
VDP_VIDEO_MIXER_FEATURE_INVERSE_TELECINE = TVdpVideoMixerFeature(2);
VDP_VIDEO_MIXER_FEATURE_NOISE_REDUCTION = TVdpVideoMixerFeature(3);
VDP_VIDEO_MIXER_FEATURE_SHARPNESS = TVdpVideoMixerFeature(4);
VDP_VIDEO_MIXER_FEATURE_LUMA_KEY = TVdpVideoMixerFeature(5);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L1 = TVdpVideoMixerFeature(11);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L2 = TVdpVideoMixerFeature(12);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L3 = TVdpVideoMixerFeature(13);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L4 = TVdpVideoMixerFeature(14);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L5 = TVdpVideoMixerFeature(15);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L6 = TVdpVideoMixerFeature(16);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L7 = TVdpVideoMixerFeature(17);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L8 = TVdpVideoMixerFeature(18);
VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L9 = TVdpVideoMixerFeature(19);
VDP_VIDEO_MIXER_PARAMETER_VIDEO_SURFACE_WIDTH = TVdpVideoMixerParameter(0);
VDP_VIDEO_MIXER_PARAMETER_VIDEO_SURFACE_HEIGHT = TVdpVideoMixerParameter(1);
VDP_VIDEO_MIXER_PARAMETER_CHROMA_TYPE = TVdpVideoMixerParameter(2);
VDP_VIDEO_MIXER_PARAMETER_LAYERS = TVdpVideoMixerParameter(3);
VDP_VIDEO_MIXER_ATTRIBUTE_BACKGROUND_COLOR = TVdpVideoMixerAttribute(0);
VDP_VIDEO_MIXER_ATTRIBUTE_CSC_MATRIX = TVdpVideoMixerAttribute(1);
VDP_VIDEO_MIXER_ATTRIBUTE_NOISE_REDUCTION_LEVEL = TVdpVideoMixerAttribute(2);
VDP_VIDEO_MIXER_ATTRIBUTE_SHARPNESS_LEVEL = TVdpVideoMixerAttribute(3);
VDP_VIDEO_MIXER_ATTRIBUTE_LUMA_KEY_MIN_LUMA = TVdpVideoMixerAttribute(4);
VDP_VIDEO_MIXER_ATTRIBUTE_LUMA_KEY_MAX_LUMA = TVdpVideoMixerAttribute(5);
VDP_VIDEO_MIXER_ATTRIBUTE_SKIP_CHROMA_DEINTERLACE = TVdpVideoMixerAttribute(6);
VDP_FUNC_ID_GET_ERROR_STRING = TVdpFuncId(0);
VDP_FUNC_ID_GET_PROC_ADDRESS = TVdpFuncId(1);
VDP_FUNC_ID_GET_API_VERSION = TVdpFuncId(2);
VDP_FUNC_ID_GET_INFORMATION_STRING = TVdpFuncId(4);
VDP_FUNC_ID_DEVICE_DESTROY = TVdpFuncId(5);
VDP_FUNC_ID_GENERATE_CSC_MATRIX = TVdpFuncId(6);
VDP_FUNC_ID_VIDEO_SURFACE_QUERY_CAPABILITIES = TVdpFuncId(7);
VDP_FUNC_ID_VIDEO_SURFACE_QUERY_GET_PUT_BITS_Y_CB_CR_CAPABILITIES = TVdpFuncId(8);
VDP_FUNC_ID_VIDEO_SURFACE_CREATE = TVdpFuncId(9);
VDP_FUNC_ID_VIDEO_SURFACE_DESTROY = TVdpFuncId(10);
VDP_FUNC_ID_VIDEO_SURFACE_GET_PARAMETERS = TVdpFuncId(11);
VDP_FUNC_ID_VIDEO_SURFACE_GET_BITS_Y_CB_CR = TVdpFuncId(12);
VDP_FUNC_ID_VIDEO_SURFACE_PUT_BITS_Y_CB_CR = TVdpFuncId(13);
VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_CAPABILITIES = TVdpFuncId(14);
VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_GET_PUT_BITS_NATIVE_CAPABILITIES = TVdpFuncId(15);
VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_PUT_BITS_INDEXED_CAPABILITIES = TVdpFuncId(16);
VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_PUT_BITS_Y_CB_CR_CAPABILITIES = TVdpFuncId(17);
VDP_FUNC_ID_OUTPUT_SURFACE_CREATE = TVdpFuncId(18);
VDP_FUNC_ID_OUTPUT_SURFACE_DESTROY = TVdpFuncId(19);
VDP_FUNC_ID_OUTPUT_SURFACE_GET_PARAMETERS = TVdpFuncId(20);
VDP_FUNC_ID_OUTPUT_SURFACE_GET_BITS_NATIVE = TVdpFuncId(21);
VDP_FUNC_ID_OUTPUT_SURFACE_PUT_BITS_NATIVE = TVdpFuncId(22);
VDP_FUNC_ID_OUTPUT_SURFACE_PUT_BITS_INDEXED = TVdpFuncId(23);
VDP_FUNC_ID_OUTPUT_SURFACE_PUT_BITS_Y_CB_CR = TVdpFuncId(24);
VDP_FUNC_ID_BITMAP_SURFACE_QUERY_CAPABILITIES = TVdpFuncId(25);
VDP_FUNC_ID_BITMAP_SURFACE_CREATE = TVdpFuncId(26);
VDP_FUNC_ID_BITMAP_SURFACE_DESTROY = TVdpFuncId(27);
VDP_FUNC_ID_BITMAP_SURFACE_GET_PARAMETERS = TVdpFuncId(28);
VDP_FUNC_ID_BITMAP_SURFACE_PUT_BITS_NATIVE = TVdpFuncId(29);
VDP_FUNC_ID_OUTPUT_SURFACE_RENDER_OUTPUT_SURFACE = TVdpFuncId(33);
VDP_FUNC_ID_OUTPUT_SURFACE_RENDER_BITMAP_SURFACE = TVdpFuncId(34);
VDP_FUNC_ID_OUTPUT_SURFACE_RENDER_VIDEO_SURFACE_LUMA = TVdpFuncId(35);
VDP_FUNC_ID_DECODER_QUERY_CAPABILITIES = TVdpFuncId(36);
VDP_FUNC_ID_DECODER_CREATE = TVdpFuncId(37);
VDP_FUNC_ID_DECODER_DESTROY = TVdpFuncId(38);
VDP_FUNC_ID_DECODER_GET_PARAMETERS = TVdpFuncId(39);
VDP_FUNC_ID_DECODER_RENDER = TVdpFuncId(40);
VDP_FUNC_ID_VIDEO_MIXER_QUERY_FEATURE_SUPPORT = TVdpFuncId(41);
VDP_FUNC_ID_VIDEO_MIXER_QUERY_PARAMETER_SUPPORT = TVdpFuncId(42);
VDP_FUNC_ID_VIDEO_MIXER_QUERY_ATTRIBUTE_SUPPORT = TVdpFuncId(43);
VDP_FUNC_ID_VIDEO_MIXER_QUERY_PARAMETER_VALUE_RANGE = TVdpFuncId(44);
VDP_FUNC_ID_VIDEO_MIXER_QUERY_ATTRIBUTE_VALUE_RANGE = TVdpFuncId(45);
VDP_FUNC_ID_VIDEO_MIXER_CREATE = TVdpFuncId(46);
VDP_FUNC_ID_VIDEO_MIXER_SET_FEATURE_ENABLES = TVdpFuncId(47);
VDP_FUNC_ID_VIDEO_MIXER_SET_ATTRIBUTE_VALUES = TVdpFuncId(48);
VDP_FUNC_ID_VIDEO_MIXER_GET_FEATURE_SUPPORT = TVdpFuncId(49);
VDP_FUNC_ID_VIDEO_MIXER_GET_FEATURE_ENABLES = TVdpFuncId(50);
VDP_FUNC_ID_VIDEO_MIXER_GET_PARAMETER_VALUES = TVdpFuncId(51);
VDP_FUNC_ID_VIDEO_MIXER_GET_ATTRIBUTE_VALUES = TVdpFuncId(52);
VDP_FUNC_ID_VIDEO_MIXER_DESTROY = TVdpFuncId(53);
VDP_FUNC_ID_VIDEO_MIXER_RENDER = TVdpFuncId(54);
VDP_FUNC_ID_PRESENTATION_QUEUE_TARGET_DESTROY = TVdpFuncId(55);
VDP_FUNC_ID_PRESENTATION_QUEUE_CREATE = TVdpFuncId(56);
VDP_FUNC_ID_PRESENTATION_QUEUE_DESTROY = TVdpFuncId(57);
VDP_FUNC_ID_PRESENTATION_QUEUE_SET_BACKGROUND_COLOR = TVdpFuncId(58);
VDP_FUNC_ID_PRESENTATION_QUEUE_GET_BACKGROUND_COLOR = TVdpFuncId(59);
VDP_FUNC_ID_PRESENTATION_QUEUE_GET_TIME = TVdpFuncId(62);
VDP_FUNC_ID_PRESENTATION_QUEUE_DISPLAY = TVdpFuncId(63);
VDP_FUNC_ID_PRESENTATION_QUEUE_BLOCK_UNTIL_SURFACE_IDLE = TVdpFuncId(64);
VDP_FUNC_ID_PRESENTATION_QUEUE_QUERY_SURFACE_STATUS = TVdpFuncId(65);
VDP_FUNC_ID_PREEMPTION_CALLBACK_REGISTER = TVdpFuncId(66);
VDPAU_INTERFACE_VERSION = 1;
VDPAU_VERSION = 1;
VDP_PROCAMP_VERSION = 0;
VDP_OUTPUT_SURFACE_RENDER_BLEND_STATE_VERSION = 0;
VDP_OUTPUT_SURFACE_RENDER_ROTATE_0 = 0;
VDP_OUTPUT_SURFACE_RENDER_ROTATE_90 = 1;
VDP_OUTPUT_SURFACE_RENDER_ROTATE_180 = 2;
VDP_OUTPUT_SURFACE_RENDER_ROTATE_270 = 3;
VDP_OUTPUT_SURFACE_RENDER_COLOR_PER_VERTEX = 1 shl 2;
VDP_DECODER_LEVEL_MPEG1_NA = 0;
VDP_DECODER_LEVEL_MPEG2_LL = 0;
VDP_DECODER_LEVEL_MPEG2_ML = 1;
VDP_DECODER_LEVEL_MPEG2_HL14 = 2;
VDP_DECODER_LEVEL_MPEG2_HL = 3;
VDP_DECODER_LEVEL_H264_1 = 10;
VDP_DECODER_LEVEL_H264_1b = 9;
VDP_DECODER_LEVEL_H264_1_1 = 11;
VDP_DECODER_LEVEL_H264_1_2 = 12;
VDP_DECODER_LEVEL_H264_1_3 = 13;
VDP_DECODER_LEVEL_H264_2 = 20;
VDP_DECODER_LEVEL_H264_2_1 = 21;
VDP_DECODER_LEVEL_H264_2_2 = 22;
VDP_DECODER_LEVEL_H264_3 = 30;
VDP_DECODER_LEVEL_H264_3_1 = 31;
VDP_DECODER_LEVEL_H264_3_2 = 32;
VDP_DECODER_LEVEL_H264_4 = 40;
VDP_DECODER_LEVEL_H264_4_1 = 41;
VDP_DECODER_LEVEL_H264_4_2 = 42;
VDP_DECODER_LEVEL_H264_5 = 50;
VDP_DECODER_LEVEL_H264_5_1 = 51;
VDP_DECODER_LEVEL_VC1_SIMPLE_LOW = 0;
VDP_DECODER_LEVEL_VC1_SIMPLE_MEDIUM = 1;
VDP_DECODER_LEVEL_VC1_MAIN_LOW = 0;
VDP_DECODER_LEVEL_VC1_MAIN_MEDIUM = 1;
VDP_DECODER_LEVEL_VC1_MAIN_HIGH = 2;
VDP_DECODER_LEVEL_VC1_ADVANCED_L0 = 0;
VDP_DECODER_LEVEL_VC1_ADVANCED_L1 = 1;
VDP_DECODER_LEVEL_VC1_ADVANCED_L2 = 2;
VDP_DECODER_LEVEL_VC1_ADVANCED_L3 = 3;
VDP_DECODER_LEVEL_VC1_ADVANCED_L4 = 4;
VDP_DECODER_LEVEL_MPEG4_PART2_SP_L0 = 0;
VDP_DECODER_LEVEL_MPEG4_PART2_SP_L1 = 1;
VDP_DECODER_LEVEL_MPEG4_PART2_SP_L2 = 2;
VDP_DECODER_LEVEL_MPEG4_PART2_SP_L3 = 3;
VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L0 = 0;
VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L1 = 1;
VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L2 = 2;
VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L3 = 3;
VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L4 = 4;
VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L5 = 5;
VDP_DECODER_LEVEL_DIVX_NA = 0;
VDP_BITSTREAM_BUFFER_VERSION = 0;
VDP_LAYER_VERSION = 0;
VDP_FUNC_ID_BASE_WINSYS = $1000;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLS_VDPAU_API: record TVdpPoint

record TVdpPoint

Unit

GLS_VDPAU_API

Declaration

type TVdpPoint = record

Description

Overview

Fields

x: Tuint32_t;
y: Tuint32_t;

Description

Fields

x: Tuint32_t;
y: Tuint32_t;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLS_VDPAU_API: record TVdpRect

record TVdpRect

Unit

GLS_VDPAU_API

Declaration

type TVdpRect = record

Description

Overview

Fields

x0: Tuint32_t;
y0: Tuint32_t;
x1: Tuint32_t;
y1: Tuint32_t;

Description

Fields

x0: Tuint32_t;
y0: Tuint32_t;
x1: Tuint32_t;
y1: Tuint32_t;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLS_VDPAU_API: record TVdpColor

record TVdpColor

Unit

GLS_VDPAU_API

Declaration

type TVdpColor = record

Description

Overview

Fields

red: single;
green: single;
blue: single;
alpha: single;

Description

Fields

red: single;
green: single;
blue: single;
alpha: single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLS_VDPAU_API: record TVdpProcamp

record TVdpProcamp

Unit

GLS_VDPAU_API

Declaration

type TVdpProcamp = record

Description

Overview

Fields

struct_version: Tuint32_t;
brightness: single;
contrast: single;
saturation: single;
hue: single;

Description

Fields

struct_version: Tuint32_t;
brightness: single;
contrast: single;
saturation: single;
hue: single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLS_VDPAU_API: record TVdpOutputSurfaceRenderBlendState

record TVdpOutputSurfaceRenderBlendState

Unit

GLS_VDPAU_API

Declaration

type TVdpOutputSurfaceRenderBlendState = record

Description

Overview

Fields

struct_version: Tuint32_t;
blend_factor_source_color: TVdpOutputSurfaceRenderBlendFactor;
blend_factor_destination_color: TVdpOutputSurfaceRenderBlendFactor;
blend_factor_source_alpha: TVdpOutputSurfaceRenderBlendFactor;
blend_factor_destination_alpha: TVdpOutputSurfaceRenderBlendFactor;
blend_equation_color: TVdpOutputSurfaceRenderBlendEquation;
blend_equation_alpha: TVdpOutputSurfaceRenderBlendEquation;
blend_constant: TVdpColor;

Description

Fields

struct_version: Tuint32_t;
blend_factor_source_color: TVdpOutputSurfaceRenderBlendFactor;
blend_factor_destination_color: TVdpOutputSurfaceRenderBlendFactor;
blend_factor_source_alpha: TVdpOutputSurfaceRenderBlendFactor;
blend_factor_destination_alpha: TVdpOutputSurfaceRenderBlendFactor;
blend_equation_color: TVdpOutputSurfaceRenderBlendEquation;
blend_equation_alpha: TVdpOutputSurfaceRenderBlendEquation;
blend_constant: TVdpColor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLS_VDPAU_API: record TVdpBitstreamBuffer

record TVdpBitstreamBuffer

Unit

GLS_VDPAU_API

Declaration

type TVdpBitstreamBuffer = record

Description

Overview

Fields

struct_version: Tuint32_t;
bitstream: pointer;
bitstream_bytes: Tuint32_t;

Description

Fields

struct_version: Tuint32_t;
bitstream: pointer;
bitstream_bytes: Tuint32_t;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLS_VDPAU_API: record TVdpPictureInfoMPEG1Or2

record TVdpPictureInfoMPEG1Or2

Unit

GLS_VDPAU_API

Declaration

type TVdpPictureInfoMPEG1Or2 = record

Description

Overview

Fields

forward_reference: TVdpVideoSurface;
backward_reference: TVdpVideoSurface;
slice_count: Tuint32_t;
picture_structure: Tuint8_t;
picture_coding_type: Tuint8_t;
intra_dc_precision: Tuint8_t;
frame_pred_frame_dct: Tuint8_t;
concealment_motion_vectors: Tuint8_t;
intra_vlc_format: Tuint8_t;
alternate_scan: Tuint8_t;
q_scale_type: Tuint8_t;
top_field_first: Tuint8_t;
full_pel_forward_vector: Tuint8_t;
full_pel_backward_vector: Tuint8_t;
f_code: array [0 .. 1] of array [0 .. 1] of Tuint8_t;
intra_quantizer_matrix: array [0 .. 63] of Tuint8_t;
non_intra_quantizer_matrix: array [0 .. 63] of Tuint8_t;

Description

Fields

forward_reference: TVdpVideoSurface;
backward_reference: TVdpVideoSurface;
slice_count: Tuint32_t;
picture_structure: Tuint8_t;
picture_coding_type: Tuint8_t;
intra_dc_precision: Tuint8_t;
frame_pred_frame_dct: Tuint8_t;
concealment_motion_vectors: Tuint8_t;
intra_vlc_format: Tuint8_t;
alternate_scan: Tuint8_t;
q_scale_type: Tuint8_t;
top_field_first: Tuint8_t;
full_pel_forward_vector: Tuint8_t;
full_pel_backward_vector: Tuint8_t;
f_code: array [0 .. 1] of array [0 .. 1] of Tuint8_t;
intra_quantizer_matrix: array [0 .. 63] of Tuint8_t;
non_intra_quantizer_matrix: array [0 .. 63] of Tuint8_t;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLS_VDPAU_API: record TVdpReferenceFrameH264

record TVdpReferenceFrameH264

Unit

GLS_VDPAU_API

Declaration

type TVdpReferenceFrameH264 = record

Description

Overview

Fields

surface: TVdpVideoSurface;
is_long_term: TVdpBool;
top_is_reference: TVdpBool;
bottom_is_reference: TVdpBool;
field_order_cnt: array [0 .. 1] of Tint32_t;
frame_idx: Tuint16_t;

Description

Fields

surface: TVdpVideoSurface;
is_long_term: TVdpBool;
top_is_reference: TVdpBool;
bottom_is_reference: TVdpBool;
field_order_cnt: array [0 .. 1] of Tint32_t;
frame_idx: Tuint16_t;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLS_VDPAU_API: record TVdpPictureInfoH264

record TVdpPictureInfoH264

Unit

GLS_VDPAU_API

Declaration

type TVdpPictureInfoH264 = record

Description

Overview

Fields

slice_count: Tuint32_t;
field_order_cnt: array [0 .. 1] of Tint32_t;
is_reference: TVdpBool;
frame_num: Tuint16_t;
field_pic_flag: Tuint8_t;
bottom_field_flag: Tuint8_t;
num_ref_frames: Tuint8_t;
mb_adaptive_frame_field_flag: Tuint8_t;
constrained_intra_pred_flag: Tuint8_t;
weighted_pred_flag: Tuint8_t;
weighted_bipred_idc: Tuint8_t;
frame_mbs_only_flag: Tuint8_t;
transform_8x8_mode_flag: Tuint8_t;
chroma_qp_index_offset: Tint8_t;
second_chroma_qp_index_offset: Tint8_t;
pic_init_qp_minus26: Tint8_t;
num_ref_idx_l0_active_minus1: Tuint8_t;
num_ref_idx_l1_active_minus1: Tuint8_t;
log2_max_frame_num_minus4: Tuint8_t;
pic_order_cnt_type: Tuint8_t;
log2_max_pic_order_cnt_lsb_minus4: Tuint8_t;
delta_pic_order_always_zero_flag: Tuint8_t;
direct_8x8_inference_flag: Tuint8_t;
entropy_coding_mode_flag: Tuint8_t;
pic_order_present_flag: Tuint8_t;
deblocking_filter_control_present_flag: Tuint8_t;
redundant_pic_cnt_present_flag: Tuint8_t;
scaling_lists_4x4: array [0 .. 5] of array [0 .. 15] of Tuint8_t;
scaling_lists_8x8: array [0 .. 1] of array [0 .. 63] of Tuint8_t;
referenceFrames: array [0 .. 15] of TVdpReferenceFrameH264;

Description

Fields

slice_count: Tuint32_t;
field_order_cnt: array [0 .. 1] of Tint32_t;
is_reference: TVdpBool;
frame_num: Tuint16_t;
field_pic_flag: Tuint8_t;
bottom_field_flag: Tuint8_t;
num_ref_frames: Tuint8_t;
mb_adaptive_frame_field_flag: Tuint8_t;
constrained_intra_pred_flag: Tuint8_t;
weighted_pred_flag: Tuint8_t;
weighted_bipred_idc: Tuint8_t;
frame_mbs_only_flag: Tuint8_t;
transform_8x8_mode_flag: Tuint8_t;
chroma_qp_index_offset: Tint8_t;
second_chroma_qp_index_offset: Tint8_t;
pic_init_qp_minus26: Tint8_t;
num_ref_idx_l0_active_minus1: Tuint8_t;
num_ref_idx_l1_active_minus1: Tuint8_t;
log2_max_frame_num_minus4: Tuint8_t;
pic_order_cnt_type: Tuint8_t;
log2_max_pic_order_cnt_lsb_minus4: Tuint8_t;
delta_pic_order_always_zero_flag: Tuint8_t;
direct_8x8_inference_flag: Tuint8_t;
entropy_coding_mode_flag: Tuint8_t;
pic_order_present_flag: Tuint8_t;
deblocking_filter_control_present_flag: Tuint8_t;
redundant_pic_cnt_present_flag: Tuint8_t;
scaling_lists_4x4: array [0 .. 5] of array [0 .. 15] of Tuint8_t;
scaling_lists_8x8: array [0 .. 1] of array [0 .. 63] of Tuint8_t;
referenceFrames: array [0 .. 15] of TVdpReferenceFrameH264;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLS_VDPAU_API: record TVdpPictureInfoVC1

record TVdpPictureInfoVC1

Unit

GLS_VDPAU_API

Declaration

type TVdpPictureInfoVC1 = record

Description

Overview

Fields

forward_reference: TVdpVideoSurface;
backward_reference: TVdpVideoSurface;
slice_count: Tuint32_t;
picture_type: Tuint8_t;
frame_coding_mode: Tuint8_t;
postprocflag: Tuint8_t;
pulldown: Tuint8_t;
interlace: Tuint8_t;
tfcntrflag: Tuint8_t;
finterpflag: Tuint8_t;
psf: Tuint8_t;
dquant: Tuint8_t;
panscan_flag: Tuint8_t;
refdist_flag: Tuint8_t;
quantizer: Tuint8_t;
extended_mv: Tuint8_t;
extended_dmv: Tuint8_t;
overlap: Tuint8_t;
vstransform: Tuint8_t;
loopfilter: Tuint8_t;
fastuvmc: Tuint8_t;
range_mapy_flag: Tuint8_t;
range_mapy: Tuint8_t;
range_mapuv_flag: Tuint8_t;
range_mapuv: Tuint8_t;
multires: Tuint8_t;
syncmarker: Tuint8_t;
rangered: Tuint8_t;
maxbframes: Tuint8_t;
deblockEnable: Tuint8_t;
pquant: Tuint8_t;

Description

Fields

forward_reference: TVdpVideoSurface;
backward_reference: TVdpVideoSurface;
slice_count: Tuint32_t;
picture_type: Tuint8_t;
frame_coding_mode: Tuint8_t;
postprocflag: Tuint8_t;
pulldown: Tuint8_t;
interlace: Tuint8_t;
tfcntrflag: Tuint8_t;
finterpflag: Tuint8_t;
psf: Tuint8_t;
dquant: Tuint8_t;
panscan_flag: Tuint8_t;
refdist_flag: Tuint8_t;
quantizer: Tuint8_t;
extended_mv: Tuint8_t;
extended_dmv: Tuint8_t;
overlap: Tuint8_t;
vstransform: Tuint8_t;
loopfilter: Tuint8_t;
fastuvmc: Tuint8_t;
range_mapy_flag: Tuint8_t;
range_mapy: Tuint8_t;
range_mapuv_flag: Tuint8_t;
range_mapuv: Tuint8_t;
multires: Tuint8_t;
syncmarker: Tuint8_t;
rangered: Tuint8_t;
maxbframes: Tuint8_t;
deblockEnable: Tuint8_t;
pquant: Tuint8_t;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLS_VDPAU_API: record TVdpPictureInfoMPEG4Part2

record TVdpPictureInfoMPEG4Part2

Unit

GLS_VDPAU_API

Declaration

type TVdpPictureInfoMPEG4Part2 = record

Description

Overview

Fields

forward_reference: TVdpVideoSurface;
backward_reference: TVdpVideoSurface;
trd: array [0 .. 1] of Tint32_t;
trb: array [0 .. 1] of Tint32_t;
vop_time_increment_resolution: Tuint16_t;
vop_coding_type: Tuint8_t;
vop_fcode_forward: Tuint8_t;
vop_fcode_backward: Tuint8_t;
resync_marker_disable: Tuint8_t;
interlaced: Tuint8_t;
quant_type: Tuint8_t;
quarter_sample: Tuint8_t;
short_video_header: Tuint8_t;
rounding_control: Tuint8_t;
alternate_vertical_scan_flag: Tuint8_t;
top_field_first: Tuint8_t;
intra_quantizer_matrix: array [0 .. 63] of Tuint8_t;
non_intra_quantizer_matrix: array [0 .. 63] of Tuint8_t;

Description

Fields

forward_reference: TVdpVideoSurface;
backward_reference: TVdpVideoSurface;
trd: array [0 .. 1] of Tint32_t;
trb: array [0 .. 1] of Tint32_t;
vop_time_increment_resolution: Tuint16_t;
vop_coding_type: Tuint8_t;
vop_fcode_forward: Tuint8_t;
vop_fcode_backward: Tuint8_t;
resync_marker_disable: Tuint8_t;
interlaced: Tuint8_t;
quant_type: Tuint8_t;
quarter_sample: Tuint8_t;
short_video_header: Tuint8_t;
rounding_control: Tuint8_t;
alternate_vertical_scan_flag: Tuint8_t;
top_field_first: Tuint8_t;
intra_quantizer_matrix: array [0 .. 63] of Tuint8_t;
non_intra_quantizer_matrix: array [0 .. 63] of Tuint8_t;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLS_VDPAU_API: record TVdpLayer

record TVdpLayer

Unit

GLS_VDPAU_API

Declaration

type TVdpLayer = record

Description

Overview

Fields

struct_version: Tuint32_t;
source_surface: TVdpOutputSurface;
source_rect: PVdpRect;
destination_rect: PVdpRect;

Description

Fields

struct_version: Tuint32_t;
source_surface: TVdpOutputSurface;
source_rect: PVdpRect;
destination_rect: PVdpRect;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLS_VDPAU_X11

Unit GLS_VDPAU_X11

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Types

PDisplay = ˆDisplay;
PVdpDevice = ˆVdpDevice;
PVdpGetProcAddress = ˆVdpGetProcAddress;
PVdpPresentationQueueTarget = ˆVdpPresentationQueueTarget;
TVdpDeviceCreateX11 = function(Display: PDisplay; screen: longint; device: PVdpDevice; get_proc_address: PPVdpGetProcAddress): TVdpStatus; cdecl;
TVdpPresentationQueueTargetCreateX11 = function(device: TVdpDevice; drawable: TDrawable; target: PVdpPresentationQueueTarget): TVdpStatus; cdecl;

Variables

vdp_device_create_x11: TVdpDeviceCreateX11;

Description

Types

PDisplay = ˆDisplay;
PVdpDevice = ˆVdpDevice;
PVdpGetProcAddress = ˆVdpGetProcAddress;
PVdpPresentationQueueTarget = ˆVdpPresentationQueueTarget;
TVdpDeviceCreateX11 = function(Display: PDisplay; screen: longint; device: PVdpDevice; get_proc_address: PPVdpGetProcAddress): TVdpStatus; cdecl;
TVdpPresentationQueueTargetCreateX11 = function(device: TVdpDevice; drawable: TDrawable; target: PVdpPresentationQueueTarget): TVdpStatus; cdecl;

Variables

vdp_device_create_x11: TVdpDeviceCreateX11;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLTeapot

Unit GLTeapot

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLTeapot<p>

Implements the standard Teapot, build from evaluators.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>30/03/07 - DaStr - Added $I GLScene.inc <li>21/07/03 - EG - Creation from GLObjects split </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTeapot |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLTeapot: Class TGLTeapot

Class TGLTeapot

Unit

GLTeapot

Declaration

type TGLTeapot = class(TGLSceneObject)

Description

The classic teapot.<p> The only use of this object is as placeholder for testing...

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLTeapot

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLTerrainRenderer

Unit GLTerrainRenderer

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLTerrainRenderer<p>

GLScene's brute-force terrain renderer.<p>

<b>History : </b><font size=-1><ul> <li>10/01/13 - PW - Added CPP compatibility: considered sensitivity to upper case characters in identifiers <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>15/08/10 - Yar - Return missing part of code in BuildList <li>20/05/10 - Yar - Fixes for Linux x64 <li>20/07/07 - LC - Fixed a problem when camera is far away from the terrain bounds. (Bugtracker ID = 1757733) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Cosmetic fixes for FPC compatibility <li>27/03/07 - Lin- Added TileManagement flags. - Helps prevent tile cache fushes. <li>19/03/07 - Lin- Added IgnoredByRenderer flag to THeightData. Helps manage duplicate tiles, when a dirty tile is being replaced. <li>16/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>08/02/07 - Lin- Ignore tiles that are not hdsReady (Prevents crashes when threading) <li>30/01/07 - Lin- Added HashedTileCount - Counts the tiles in the buffer <li>19/10/06 - LC - Changed the behaviour of OnMaxCLODTrianglesReached <li>09/10/06 - Lin- Added OnMaxCLODTrianglesReached event.(Rene Lindsay) <li>01/09/04 - SG - Fix for RayCastIntersect (Alan Rose) <li>02/08/04 - LR, YHC - BCB corrections: use record instead array <li>25/04/04 - EG - Occlusion testing support <li>13/01/04 - EG - Leak fix (Phil Scadden) <li>05/11/03 - SG - Fixed minuscule bug in RayCastIntersect (thanks Michael) <li>06/02/03 - EG - Fixed speculative range computation, better hashkey <li>14/01/03 - EG - RayCastIntersect normals fix (Stuart Gooding) <li>24/09/02 - EG - Added RayCastIntersect (Stuart Gooding) <li>28/08/02 - EG - Now longer wrongly requests hdtByte (Phil Scadden), Terrain bounds limiting event (Erazem Polutnik) <li>10/07/02 - EG - Added support for "holes" in the elevation data <li>16/06/02 - EG - Added support for multi-material terrains <li>24/02/02 - EG - Hybrid ROAM-stripifier engine <li>18/12/01 - EG - Vertex-cache aware stripifier (+10% on GeForce) <li>12/08/01 - EG - Completely rewritten handles management <li>21/07/01 - EG - Added Notication registration in SetHeightDataSource <li>04/03/01 - EG - Completed for first release <li>12/02/01 - EG - Creation </ul></font><p>

NOTA : multi-materials terrain support is not yet optimized to minimize texture switches (in case of resued tile textures).

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTerrainRenderer |

Types

TGetTerrainBoundsEvent = procedure(var l, t, r, b: single) of object;
TPatchPostRenderEvent = procedure(var rci: TRenderContextInfo; const patches: TList) of object;
THeightDataPostRenderEvent = procedure(var rci: TRenderContextInfo; var HeightDatas: TList) of object;
TMaxCLODTrianglesReachedEvent = procedure(var rci: TRenderContextInfo) of object;
TTerrainHighResStyle = (...);
TTerrainOcclusionTesselate = (...);
TTileManagementFlag = (...);
TTileManagementFlags = set of TTileManagementFlag;

Constants

cTilesHashSize = 255;

Description

Types

TGetTerrainBoundsEvent = procedure(var l, t, r, b: single) of object;
TPatchPostRenderEvent = procedure(var rci: TRenderContextInfo; const patches: TList) of object;
THeightDataPostRenderEvent = procedure(var rci: TRenderContextInfo; var HeightDatas: TList) of object;
TMaxCLODTrianglesReachedEvent = procedure(var rci: TRenderContextInfo) of object;
TTerrainHighResStyle = (...);
Values
  • hrsFullGeometry:
  • hrsTesselated:
TTerrainOcclusionTesselate = (...);
Values
  • totTesselateAlways:
  • totTesselateIfVisible:
TTileManagementFlag = (...);
Values
  • tmClearUsedFlags:
  • tmMarkUsedTiles:
  • tmReleaseUnusedTiles:
  • tmAllocateNewTiles:
  • tmWaitForPreparing:
TTileManagementFlags = set of TTileManagementFlag;

Constants

cTilesHashSize = 255;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLTerrainRenderer: Class TGLTerrainRenderer

Class TGLTerrainRenderer

Unit

GLTerrainRenderer

Declaration

type TGLTerrainRenderer = class(TGLSceneObject)

Description

no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLTerrainRenderer

Overview

Fields

Protected | FTilesHash: packed [0..cTilesHashSize] of TList;
Public | TileManagement: TTileManagementFlags;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function HashedTileCount: integer;
Public | function InterpolatedHeight(const p: TAffineVector): single; overload;
Public | function InterpolatedHeight(const p: TVector): single; overload; virtual;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): boolean; override;
Protected | function GetPreparedPatch(const tilePos, eyePos: TAffineVector; texFactor: single; hdList: TList): TGLROAMPatch;
Protected | function HashedTile(const tilePos: TAffineVector; canAllocate: boolean = True): THeightData; overload;
Protected | function HashedTile(const xLeft, yTop: Integer; canAllocate: boolean = True): THeightData; overload;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Protected | procedure DestroyHandle; override;
Protected | procedure MarkAllTilesAsUnused;
Protected | procedure MarkHashedTileAsUsed(const tilePos: TAffineVector);
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure OnTileDestroyed(Sender: TObject); virtual;
Protected | procedure ReleaseAllTiles; dynamic;
Protected | procedure ReleaseAllUnusedTiles;
Protected | procedure SetCLODPrecision(const val: Integer);
Protected | procedure SetHeightDataSource(const val: THeightDataSource);
Protected | procedure SetMaterialLibrary(const val: TGLMaterialLibrary);
Protected | procedure SetOcclusionFrameSkip(val: Integer);
Protected | procedure SetQualityStyle(const val: TTerrainHighResStyle);
Protected | procedure SetTileSize(const val: integer);
Protected | procedure SetTilesPerTexture(const val: Single);

Properties

Published | property CLODPrecision: integer read FCLODPrecision write SetCLODPrecision default 100;
Published | property HeightDataSource: THeightDataSource read FHeightDataSource write SetHeightDataSource;
Public | property LastTriangleCount: integer read FLastTriangleCount;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property MaxCLODTriangles: integer read FMaxCLODTriangles write FMaxCLODTriangles default 65536;
Published | property OcclusionFrameSkip: integer read FOcclusionFrameSkip write SetOcclusionFrameSkip default 0;
Published | property OcclusionTesselate: TTerrainOcclusionTesselate read FOcclusionTesselate write FOcclusionTesselate default totTesselateIfVisible;
Published | property OnGetTerrainBounds: TGetTerrainBoundsEvent read FOnGetTerrainBounds write FOnGetTerrainBounds;
Published | property OnHeightDataPostRender: THeightDataPostRenderEvent read FOnHeightDataPostRender write FOnHeightDataPostRender;
Published | property OnMaxCLODTrianglesReached: TMaxCLODTrianglesReachedEvent read FOnMaxCLODTrianglesReached write FOnMaxCLODTrianglesReached;
Published | property OnPatchPostRender: TPatchPostRenderEvent read FOnPatchPostRender write FOnPatchPostRender;
Published | property QualityDistance: single read FQualityDistance write FQualityDistance;
Published | property QualityStyle: TTerrainHighResStyle read FQualityStyle write SetQualityStyle default hrsFullGeometry;
Published | property TileSize: integer read FTileSize write SetTileSize default 16;
Published | property TilesPerTexture: single read FTilesPerTexture write SetTilesPerTexture;

Description

Fields

Protected FTilesHash: packed [0..cTilesHashSize] of TList;
Public TileManagement: TTileManagementFlags;

TileManagement flags can be used to turn off various Tile cache management features. This helps to prevent unnecessary tile cache flushes, when rendering from multiple cameras.

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function HashedTileCount: integer;
Public function InterpolatedHeight(const p: TAffineVector): single; overload;
Public function InterpolatedHeight(const p: TVector): single; overload; virtual;

Interpolates height for the given point.<p> Expects a point expressed in absolute coordinates.

Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): boolean; override;
Protected function GetPreparedPatch(const tilePos, eyePos: TAffineVector; texFactor: single; hdList: TList): TGLROAMPatch;
Protected function HashedTile(const tilePos: TAffineVector; canAllocate: boolean = True): THeightData; overload;
Protected function HashedTile(const xLeft, yTop: Integer; canAllocate: boolean = True): THeightData; overload;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Protected procedure DestroyHandle; override;
Protected procedure MarkAllTilesAsUnused;
Protected procedure MarkHashedTileAsUsed(const tilePos: TAffineVector);
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure OnTileDestroyed(Sender: TObject); virtual;
Protected procedure ReleaseAllTiles; dynamic;
Protected procedure ReleaseAllUnusedTiles;
Protected procedure SetCLODPrecision(const val: Integer);
Protected procedure SetHeightDataSource(const val: THeightDataSource);
Protected procedure SetMaterialLibrary(const val: TGLMaterialLibrary);
Protected procedure SetOcclusionFrameSkip(val: Integer);
Protected procedure SetQualityStyle(const val: TTerrainHighResStyle);
Protected procedure SetTileSize(const val: integer);
Protected procedure SetTilesPerTexture(const val: Single);

Properties

Published property CLODPrecision: integer read FCLODPrecision write SetCLODPrecision default 100;

Precision of CLOD tiles.<p> The lower the value, the higher the precision and triangle count. Large values will result in coarse terrain.<br> high-resolution tiles (closer than QualityDistance) ignore this setting.

Published property HeightDataSource: THeightDataSource read FHeightDataSource write SetHeightDataSource;

Specifies the HeightData provider component.

Public property LastTriangleCount: integer read FLastTriangleCount;

Triangle count for the last render.

Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Link to the material library holding terrain materials.<p> If unspecified, and for all terrain tiles with unspecified material, the terrain renderer's material is used.

Published property MaxCLODTriangles: integer read FMaxCLODTriangles write FMaxCLODTriangles default 65536;

Maximum number of CLOD triangles per scene.<p> Triangles in high-resolution tiles (closer than QualityDistance) do not count toward this limit.

Published property OcclusionFrameSkip: integer read FOcclusionFrameSkip write SetOcclusionFrameSkip default 0;

Numbers of frames to skip for a tile when occlusion testing found it invisible.<p> Occlusion testing can help reduce CPU, T&L and fillrate requirements when tiles are occluded, either by the terrain itself (tiles behind a mountain or a cliff) or by geometry that was rendered before the terrain (large buildings). If there is little occlusion in your scene (such as in top down or high-altitude view), turning occlusion on may have a slightly negative effect on framerate.<br> It works by turning off rendering of tiles for the specified number of frames if it has been found invisible, after FrameSkip number of frames have been skipped, it will be rendered again, and a new occlusion testing made. This makes occlusion-testing a frame-to-frame coherency optimization, and as such, shouldn't be used for static rendering (ie. leave value to its default of zero).<br> This optimization requires the hardware to support GL_NV_occlusion_query.

Published property OcclusionTesselate: TTerrainOcclusionTesselate read FOcclusionTesselate write FOcclusionTesselate default totTesselateIfVisible;

Determines if and how occlusion testing affects tesselation.<p> Turning off tesselation of tiles determined invisible can improve performance, however, it may result in glitches since the tesselation of an ivisible tile can have a slight effect on the tesselation of its adjacent tiles (by forcing higher resolution at the border for instance). This negative effect can be lessened by increasing the QualityDistance, so that glitches will apear farther away (this will mean increasing your triangle count though, so you'll trade CPU power against T&L power).

Published property OnGetTerrainBounds: TGetTerrainBoundsEvent read FOnGetTerrainBounds write FOnGetTerrainBounds;

Allows to specify terrain bounds.<p> Default rendering bounds will reach depth of view in all direction, with this event you can chose to specify a smaller rendered terrain area.

Published property OnHeightDataPostRender: THeightDataPostRenderEvent read FOnHeightDataPostRender write FOnHeightDataPostRender;

Invoked for each heightData not culled out by the terrain renderer.<p> The list holds THeightData objects and allows per-patch post-processings, like waters, trees... It is invoked *after* OnPatchPostRender.

Published property OnMaxCLODTrianglesReached: TMaxCLODTrianglesReachedEvent read FOnMaxCLODTrianglesReached write FOnMaxCLODTrianglesReached;

Invoked whenever the MaxCLODTriangles limit was reached during last rendering.<p> This forced the terrain renderer to resize the buffer, which affects performance. If this event is fired frequently, one should increase MaxCLODTriangles.

Published property OnPatchPostRender: TPatchPostRenderEvent read FOnPatchPostRender write FOnPatchPostRender;

Invoked for each rendered patch after terrain render has completed.<p> The list holds TGLROAMPatch objects and allows per-patch post-processings, like waters, trees... It is invoked *before* OnHeightDataPostRender.

Published property QualityDistance: single read FQualityDistance write FQualityDistance;

Quality distance hint.<p> This parameter gives an hint to the terrain renderer at which distance the terrain quality can be degraded to favor speed. The distance is expressed in absolute coordinates units.<p> All tiles closer than this distance are rendered according to QualityStyle and with a static resolution.

Published property QualityStyle: TTerrainHighResStyle read FQualityStyle write SetQualityStyle default hrsFullGeometry;

Determines how high-res tiles (closer than QualityDistance) are rendered.<p> hrsFullGeometry (default value) means that the high-res tiles are rendered with full-geometry, and no LOD of any kind, while hrsTesselated means the tiles will be tesselated once, with the best output for the CLODPrecision, and the result of that tesselation will be reused in further frames without any adpative tesselation.

Published property TileSize: integer read FTileSize write SetTileSize default 16;

Size of the terrain tiles.<p> Must be a power of two.

Published property TilesPerTexture: single read FTilesPerTexture write SetTilesPerTexture;

Number of tiles required for a full texture map.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLTexCombineShader

Unit GLTexCombineShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLTexCombineShader<p>

A shader that allows texture combiner setup.<p>

<b>History : </b><font size=-1><ul> <li>05/03/11 - Yar - Added combiner's commands cache <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>24/07/09 - DaStr - TGLShader.DoInitialize() now passes rci (BugTracker ID = 2826217) <li>03/04/07 - DaStr - Added $I GLScene.inc <li>25/02/07 - DaStr - Moved registration to GLSceneRegister.pas <li>23/05/03 - EG - Added support for binding two extra texture units <li>16/05/03 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTexCombineShader |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLTexCombineShader: Class TGLTexCombineShader

Class TGLTexCombineShader

Unit

GLTexCombineShader

Declaration

type TGLTexCombineShader = class(TGLShader)

Description

A shader that can setup the texture combiner.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLTexCombineShader

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected | procedure DoFinalize; override;
Protected | procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;
Protected | procedure NotifyLibMaterial3Destruction;
Protected | procedure NotifyLibMaterial4Destruction;
Protected | procedure SetCombiners(const val: TStringList);
Protected | procedure SetDesignTimeEnabled(const val: Boolean);
Protected | procedure SetLibMaterial3Name(const val: TGLLibMaterialName);
Protected | procedure SetLibMaterial4Name(const val: TGLLibMaterialName);
Protected | procedure SetMaterialLibrary(const val: TGLMaterialLibrary);

Properties

Published | property Combiners: TStringList read FCombiners write SetCombiners;
Published | property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled;
Published | property LibMaterial3Name: TGLLibMaterialName read FLibMaterial3Name write SetLibMaterial3Name;
Published | property LibMaterial4Name: TGLLibMaterialName read FLibMaterial4Name write SetLibMaterial4Name;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure NotifyChange(Sender: TObject); override;
Protected procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected procedure DoFinalize; override;
Protected procedure DoInitialize(var rci: TRenderContextInfo; Sender: TObject); override;
Protected procedure NotifyLibMaterial3Destruction;
Protected procedure NotifyLibMaterial4Destruction;
Protected procedure SetCombiners(const val: TStringList);
Protected procedure SetDesignTimeEnabled(const val: Boolean);
Protected procedure SetLibMaterial3Name(const val: TGLLibMaterialName);
Protected procedure SetLibMaterial4Name(const val: TGLLibMaterialName);
Protected procedure SetMaterialLibrary(const val: TGLMaterialLibrary);

Properties

Published property Combiners: TStringList read FCombiners write SetCombiners;
Published property DesignTimeEnabled: Boolean read FDesignTimeEnabled write SetDesignTimeEnabled;
Published property LibMaterial3Name: TGLLibMaterialName read FLibMaterial3Name write SetLibMaterial3Name;
Published property LibMaterial4Name: TGLLibMaterialName read FLibMaterial4Name write SetLibMaterial4Name;
Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLTexLensFlare

Unit GLTexLensFlare

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLTexLensFlare<p>

Texture-based Lens flare object.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>30/03/07 - DaStr - Added $I GLScene.inc <li>23/03/07 - DaStr - Added missing parameters in procedure's implementation (thanks Burkhard Carstens) (Bugtracker ID = 1681409) <li>25/09/03 - EG - Creation from GLLensFlare split </ul></font><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTextureLensFlare |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLTexLensFlare: Class TGLTextureLensFlare

Class TGLTextureLensFlare

Unit

GLTexLensFlare

Declaration

type TGLTextureLensFlare = class(TGLBaseSceneObject)

Description

no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLTextureLensFlare

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Protected | procedure SetAutoZTest(aValue: boolean);
Protected | procedure SetNumSecs(aValue: integer);
Protected | procedure SetSize(aValue: integer);

Properties

Published | property AutoZTest: boolean read FAutoZTest write SetAutoZTest default True;
Published | property Behaviours;
Published | property Effects;
Published | property ImgGlow: TGLTexture read FImgGlow write SetImgGlow;
Published | property ImgRays: TGLTexture read FImgRays write SetImgRays;
Published | property ImgRing: TGLTexture read FImgRing write SetImgRing;
Published | property ImgSecondaries: TGLTexture read FImgSecondaries write SetImgSecondaries;
Published | property NumSecs: integer read FNumSecs write SetNumSecs default 8;
Published | property ObjectsSorting;
Published | property OnProgress;
Published | property Position;
Published | property Seed: Integer read FSeed write SetSeed;
Published | property Size: integer read FSize write SetSize default 50;
Published | property Visible;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Protected procedure SetAutoZTest(aValue: boolean);
Protected procedure SetNumSecs(aValue: integer);
Protected procedure SetSize(aValue: integer);

Properties

Published property AutoZTest: boolean read FAutoZTest write SetAutoZTest default True;

Number of segments used when rendering circles.

Published property Behaviours;
Published property Effects;
Published property ImgGlow: TGLTexture read FImgGlow write SetImgGlow;
Published property ImgRays: TGLTexture read FImgRays write SetImgRays;
Published property ImgRing: TGLTexture read FImgRing write SetImgRing;
Published property ImgSecondaries: TGLTexture read FImgSecondaries write SetImgSecondaries;
Published property NumSecs: integer read FNumSecs write SetNumSecs default 8;

Number of secondary flares.

Published property ObjectsSorting;
Published property OnProgress;
Published property Position;
Published property Seed: Integer read FSeed write SetSeed;

Random seed

Published property Size: integer read FSize write SetSize default 50;

MaxRadius of the flare.

Published property Visible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLTexture

Unit GLTexture

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLTexture<p>

Handles all the color and texture stuff.<p>

<b>History : </b><font size=-1><ul> <li>04/01/13 - PW - Moved cubic map texture consts CmtPX..CmtNZ from GLColor unit to here <li>10/11/12 - PW - Added CPPB compatibility: used dummy instead abstract methods, restored definition of TGLCubeMapTarget as integer type <li>12/05/11 - Yar - Added KeepImageAfterTransfer for TGLTexture <li>04/10/10 - Yar - Improved multycontext features for TGLTexture <li>23/08/10 - Yar - Added OpenGLTokens to uses <li>21/05/10 - Yar - Removed TGLFloatDataImage, replace OpenGL1x functions to OpenGLAdapter <li>16/05/10 - Yar - Added protected method IsSelfLoading and LoadTexture to TGLTextureImage <li>14/05/10 - Yar - Fixed UnpackAlignment in PrepareParams <li>09/05/10 - Yar - Fixed texture compression (thanks Hacker) <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - Removed disabling Texture Rect/CubeMap/3D, since disabling will cause errors on hardware that doesn't support them <li>05/03/10 - DanB - More state added to TGLStateCache <li>23/01/10 - Yar - Added TextureFormatEx to TGLTexture and tfExtended to TGLTextureFormat (thanks mif for idea) <li>22/01/10 - Yar - Added GLTextureFormat to uses, 1D, 3D, array, cube map array target support, texture error indication, TGLTextureImage ResorceName property, Depth property, NativeTextureTarget becomes property <li>07/01/10 - DaStr - Added tmAdd TextureMode and enhanced documentation (thanks DungeonLords) Removed IncludeTrailingBackslash function <li>10/11/09 - DaStr - Added more texture formats (thanks YarUnderoaker) <li>04/06/09 - DanB - Delphi 5 fix <li>17/10/08 - DanB - changed some NotifyChange(Sender) calls to NotifyChange(Self) <li>08/10/08 - DanB - split materials related stuff into GLMaterial.pas <li>06/10/08 - DanB - added Assert check for trying to create texture images <li>05/10/08 - DanB - separated texture image editor from texture unit moved color related stuff to GLColor.pas moved TRenderContextInfo into separate unit <li>12/04/08 - DaStr - Bugfixed TGLTextureExItem.Create() (thanks dAlex) (BugTracker ID = 1940451) <li>10/04/08 - DaStr - Added a Delpi 5 interface bug work-around to TGLMaterial (BugTracker ID = 1938988) <li>08/02/08 - Mrqzzz - Added tiaBottomRightPointColorTransparent <li>29/07/07 - LC - Modified how tmmEyeLinear is applied, see Bugtracker ID = 1762966. <li>06/06/07 - DaStr - Moved all color types, constants and functions to GLColor.pas (Bugtracker ID = 1732211) <li>31/03/07 - DaStr - Bugfixed TGLTexture.Assign (missed some properties) (Bugtracker ID = 1692012) (thanks Zapology) <li>28/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>23/03/07 - DaStr - Added missing parameters in procedure's implementation (thanks Burkhard Carstens) (Bugtracker ID = 1681409) <li>06/03/07 - DaStr - Removed obsolete FPC IFDEF's (thanks Burkhard Carstens) (Bugtracker ID = 1678642) <li>14/03/07 - DaStr - TGLPicFileImage now provides correct Width and Height (BugtrackerID = 1680742) <li>09/03/07 - DaStr - Added TGLMaterial.GetActualPrimaryMaterial, GetLibMaterial Bugfixed TGLColor.Initialize and TGLColor.Destroy (thanks Burkhard Carstens) (BugtrackerID = 1678650) <li>04/03/07 - DaStr - Added TGLTextureTarget, [Encode/Decode]GLTextureTarget <li>23/02/07 - DaStr - Added TGLShaderClass, TGLShaderFailedInitAction, EGLShaderException Added TGLShader.HandleFailedInitialization, ShaderSupported, GetStardardNotSupportedMessage, FailedInitAction Added default value for TGLShader.ShaderStyle Fixed TGLShader.InitializeShader Fixed TGLTextureExItem.Create (TGLCoordinatesStyle stuff) <li>16/02/07 - DaStr - Global $Q- removed Added TGLLibMaterials.GetTextureIndex, GetMaterialIndex, GetNameOfTexture, GetNameOfLibMaterial Added TGLMaterialLibrary.TextureByName, GetNameOfTexture, GetNameOfLibMaterial <li>01/02/07 - LIN - Added TGLLibMaterial.IsUsed : true if texture has registered users <li>23/01/07 - LIN - Added TGLTextureImage.AssignToBitmap : Converts the TextureImage to a TBitmap <li>23/01/07 - LIN - Added TGLTextureImage.AsBitmap : Returns the TextureImage as a TBitmap <li>22/01/07 - DaStr - IGLMaterialLibrarySupported abstracted TGLLibMaterial.TextureOffset/TextureScale.FStyle bugfxed (thanks Ian Mac) <li>20/12/06 - DaStr - TGLColorManager.Enumcolors overloaded TGLShader.Apply bugfixed, TGLShader.Assign added <li>19/10/06 - LC - Fixed TGLLibMaterial.UnApply so it doesn't unapply a 2nd texture that was never applied. Bugtracker ID=1234085 <li>19/10/06 - LC - Fixed TGLLibMaterial.Assign. Bugtracker ID=1549843 (thanks Zapology) <li>15/09/06 - NC - TGLShader.handle as Integer -> Cardinal <li>12/09/06 - NC - Added GetFloatTexImage and SetFloatTexImage <li>06/03/05 - EG - FTextureEx now autocreated (like FTexture) <li>30/11/04 - EG - No longer stores TextureEx if empty <li>06/10/04 - NC - Corrected filtering param. setting for float texture, Now keep using GL_TEXTURE_RECTANGLE_NV for TGLFloatDataImage <li>05/10/04 - SG - Added Material.TextureEx (texture extension) <li>04/10/04 - NC - Added TGLFloatDataImage <li>02/08/04 - LR, YHC - BCB corrections: Added dummy method for the abstract problem Changed type of TGLCubeMapTarget to integer <li>03/07/04 - LR - Move InitWinColors to GLCrossPlatform Replace TGraphics, TBitmap by TGLGraphics, TGLBitmap <li>29/06/04 - SG - Added bmModulate blending mode <li>08/04/04 - EG - Added AddMaterialsFromXxxx logic <li>04/09/03 - EG - Added TGLShader.Enabled <li>02/09/03 - EG - Added TGLColor.HSVA <li>28/07/03 - aidave - Added TGLColor.RandomColor <li>24/07/03 - EG - Introduced TGLTextureImageEditor mechanism <li>04/07/03 - EG - Material.Texture now autocreating, added per-texture brightness and gamma correction <li>13/06/03 - EG - cubemap images can now be saved/restored as a whole <li>05/06/03 - EG - Assign fixes (Andrzej Kaluza) <li>23/05/03 - EG - More generic libmaterial registration <li>08/12/02 - EG - Added tiaInverseLuminance <li>13/11/02 - EG - Added tmmCubeMapLight0 <li>18/10/02 - EG - CubeMap texture matrix now setup for 2nd texture unit too <li>24/07/02 - EG - Added TGLLibMaterials.DeleteUnusedMaterials <li>13/07/02 - EG - Improved materials when lighting is off <li>10/07/02 - EG - Added basic protection against cyclic material refs <li>08/07/02 - EG - Multipass support <li>18/06/02 - EG - Added TGLShader <li>26/01/02 - EG - Makes use of new xglBegin/EndUpdate mechanism <li>24/01/02 - EG - Added vUseDefaultSets mechanism, TGLPictureImage no longer systematically creates a TPicture <li>21/01/02 - EG - Fixed OnTextureNeeded calls (Leonel) <li>20/01/02 - EG - Fixed texture memory use report error <li>10/01/02 - EG - Added Material.FaceCulling, default texture filters are now Linear/MipMap <li>07/01/02 - EG - Added renderDPI to rci <li>16/12/01 - EG - Added support for cube maps (texture and mappings) <li>30/11/01 - EG - Texture-compression related errors now ignored (unsupported formats) <li>14/09/01 - EG - Use of vFileStreamClass <li>06/09/01 - EG - No longers depends on 'Windows' <li>04/09/01 - EG - Texture binding cache <li>31/08/01 - EG - tiaDefault wasn't honoured (Rene Lindsay) <li>25/08/01 - EG - Added TGLBlankImage <li>16/08/01 - EG - drawState now part of TRenderContextInfo <li>15/08/01 - EG - TexGen support (object_linear, eye_linear and sphere_map) <li>13/08/01 - EG - Fixed OnTextureNeeded handling (paths for mat lib) <li>12/08/01 - EG - Completely rewritten handles management <li>27/07/01 - EG - TGLLibMaterials now a TOwnedCollection <li>19/07/01 - EG - Added "Enabled" to TGLTexture <li>28/06/01 - EG - Added AddTextureMaterial TGraphic variant <li>14/03/01 - EG - Streaming fixes by Uwe Raabe <li>08/03/01 - EG - TGLPicFileImage.GetBitmap32 now resets filename if not found <li>01/03/01 - EG - Fixed TGLMaterial.DestroyHandle, Added Texture2 notifications and material cacheing <li>26/02/01 - EG - Added support for GL_EXT_texture_filter_anisotropic <li>23/02/01 - EG - Fixed texture matrix messup (second was using first) <li>21/02/01 - EG - Minor fix for TextureImageRequiredMemory, TexGen calls now based on XOpenGL <li>14/02/01 - EG - Added support for texture format & texture compression <li>31/01/01 - EG - Added Multitexture support <li>28/01/01 - EG - Added MaterialOptions <li>15/01/01 - EG - Enhanced TGLPicFileImage.LoadFromFile <li>13/01/01 - EG - New helper functions for TGLMaterialLibrary <li>08/01/01 - EG - Not-so-clean fix for TGLTexture.Destroy... better fix will require awareness of rendering contexts... <li>06/12/00 - EG - Added PrepareBuildList mechanism <li>16/10/00 - EG - Fix in TGLPictureImage.Assign <li>25/09/00 - EG - New texture management implemented <li>13/08/00 - EG - Added AddTextureMaterial <li>06/08/00 - EG - File not found error now happens only once per texture, also added some more doc and texture transforms support to TGLLibMaterial <li>27/07/00 - EG - TGLPictureImage.Assign now accepts TGraphic & TPicture, Added max texture size clamping <li>15/07/00 - EG - Upgrade for new list/handle destruction scheme <li>05/07/00 - EG - Added tiaTopLeftPointColorTransparent <li>28/06/00 - EG - Added asserts for missing texture files <li>01/06/00 - EG - Added ReloadTexture (support for texture library), Fixed persistence of material names in a texture library <li>28/05/00 - EG - TGLColor now has NotifyChange support for TGLBaseSceneObject <li>23/04/00 - EG - Fixed bugs with TGLPicFileImage & TGLPersistentImage, Added tiaOpaque <li>17/04/00 - EG - Added Assign to DummyCube and Sprite <li>16/04/00 - EG - Added TGLPicFileImage.Assign <li>26/03/00 - EG - Finally fixed nasty bug in TGLMaterial.Free <li>22/03/00 - EG - Added BeginUpdate/EndUpdate to TGLPictureImage, Made use of [Un]SetGLState in TGLMaterial (gain = 7-10% on T&L intensive rendering), TGLTexBaseClass is no more (RIP) <li>21/03/00 - EG - TGLMaterial props are now longer stored when it is linked to a material library entry, Added TGLPictureImage (split from TGLPersistentImage), TGLPicFileImage has been updated and reactivated, ColorManager is now autocreated and non longer force-linked. <li>19/03/00 - EG - Added SaveToXxxx & LoadFromXxxx to TGLMaterialLibrary <li>18/03/00 - EG - Added GetGLTextureImageClassesAsStrings, Added FindGLTextureImageClassByFriendlyName, FChanges states now ignored in TGLTexture.GetHandle, Added SaveToFile/LoadFromFile to TextureImage <li>17/03/00 - EG - Added tiaLuminance <li>14/03/00 - EG - Added RegisterGLTextureImageClass stuff, Added ImageAlpha <li>13/03/00 - EG - Changed TGLTextureImage image persistence again, Added "Edit" method for texture image classes, TMagFilter/TMinFilter -> TGLMagFilter/TGLMinFilter <li>03/03/00 - EG - Removed TImagePath, Started major rework of the whole TGLTextureImage stuff, Fixed and optimized TGLTexture.PrepareImage <li>12/02/00 - EG - Added Material Library <li>10/02/00 - EG - Fixed crash when texture is empty <li>08/02/00 - EG - Added AsWinColor & DeclareCurrentAsDefault to TGLColor, fixed notification on material property setXxx methods, Objects now begin with 'TGL' <li>07/02/00 - EG - "Update"s renamed to "NotifyChange"s <li>06/02/00 - EG - RoundUpToPowerOf2, RoundDownToPowerOf2 and IsPowerOf2 moved to GLMisc, added TGLPersistentImage.Assign, fixed TGLMaterial.Assign, disable inheritance stuff in TGLFaceProperties.Apply (needs fixing), Diffuse & ambient color now default to openGL values <li>05/02/00 - EG - Javadocisation, fixes and enhancements :<br> TGLColor.Update, ConvertWinColor, TPicImage, TGLMaterial.Apply </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Interface IGLTextureNotifyAble |
Class TGLTextureImage |
Class TGLBlankImage |
Class TGLPictureImage |
Class TGLPersistentImage |
Class TGLPicFileImage |
Class TGLCubeMapImage |
Class TGLTexture |
Class TGLTextureExItem |
Class TGLTextureEx |
Class ETexture |
Class EGLShaderException |

Functions and Procedures

procedure RegisterGLTextureImageClass(textureImageClass: TGLTextureImageClass);
function FindGLTextureImageClass(const className: string): TGLTextureImageClass;
function FindGLTextureImageClassByFriendlyName(const friendlyName: string): TGLTextureImageClass;
procedure SetGLTextureImageClassesToStrings(aStrings: TStrings);
function GetGLTextureImageClassesAsStrings: TStrings;
procedure RegisterTGraphicClassFileExtension(const extension: string; const aClass: TGraphicClass);
function CreateGraphicFromFile(const fileName: string): TGLGraphic;

Types

TGLMinFilter = (...);
TGLMagFilter = (...);
TGLTextureMode = (...);
TGLTextureWrap = (...);
TGLDepthTextureMode = (...);
TGLDepthCompareFunc = TDepthFunction;
TGLTextureFormat = (...);
TGLTextureCompression = TGLInternalCompression;
TTextureNeededEvent = procedure(Sender: TObject; var textureFileName: string) of object;
TGLTextureChange = (...);
TGLTextureChanges = set of TGLTextureChange;
TGLTextureImageAlpha = (...);
TGLTextureImageClass = class of TGLTextureImage;
TGLCubeMapTarget = Integer;
TGLTextureMappingMode = (...);

Constants

cDefaultNormalMapScale = 0.125;
CmtPX = 0;
CmtNX = 1;
CmtPY = 2;
CmtNY = 3;
CmtPZ = 4;
CmtNZ = 5;

Description

Functions and Procedures

procedure RegisterGLTextureImageClass(textureImageClass: TGLTextureImageClass);

Register a TGLTextureImageClass (used for persistence and IDE purposes)

function FindGLTextureImageClass(const className: string): TGLTextureImageClass;

Finds a registerer TGLTextureImageClass using its classname

function FindGLTextureImageClassByFriendlyName(const friendlyName: string): TGLTextureImageClass;

Finds a registerer TGLTextureImageClass using its FriendlyName

procedure SetGLTextureImageClassesToStrings(aStrings: TStrings);

Defines a TStrings with the list of registered TGLTextureImageClass.

function GetGLTextureImageClassesAsStrings: TStrings;

Creates a TStrings with the list of registered TGLTextureImageClass.<p> To be freed by caller.

procedure RegisterTGraphicClassFileExtension(const extension: string; const aClass: TGraphicClass);
function CreateGraphicFromFile(const fileName: string): TGLGraphic;

Types

TGLMinFilter = (...);
Values
  • miNearest:
  • miLinear:
  • miNearestMipmapNearest:
  • miLinearMipmapNearest:
  • miNearestMipmapLinear:
  • miLinearMipmapLinear:
TGLMagFilter = (...);
Values
  • maNearest:
  • maLinear:
TGLTextureMode = (...);
Values
  • tmDecal:
  • tmModulate:
  • tmBlend:
  • tmReplace:
  • tmAdd:
TGLTextureWrap = (...);
Values
  • twBoth:
  • twNone:
  • twVertical:
  • twHorizontal:
  • twSeparate:
TGLDepthTextureMode = (...);
Values
  • dtmLuminance:
  • dtmIntensity:
  • dtmAlpha:
TGLDepthCompareFunc = TDepthFunction;
TGLTextureFormat = (...);

Texture format for OpenGL (rendering) use.<p> Internally, GLScene handles all "base" images as 32 Bits RGBA, but you can specify a generic format to reduce OpenGL texture memory use:<ul>

Values
  • tfDefault:
  • tfRGB:
  • tfRGBA:
  • tfRGB16:
  • tfRGBA16:
  • tfAlpha:
  • tfLuminance:
  • tfLuminanceAlpha:
  • tfIntensity:
  • tfNormalMap:
  • tfRGBAFloat16:
  • tfRGBAFloat32:
  • tfExtended:
TGLTextureCompression = TGLInternalCompression;
TTextureNeededEvent = procedure(Sender: TObject; var textureFileName: string) of object;
TGLTextureChange = (...);
Values
  • tcImage:
  • tcParams:
TGLTextureChanges = set of TGLTextureChange;
TGLTextureImageAlpha = (...);

Defines how and if Alpha channel is defined for a texture image.<ul> <li>tiaDefault : uses the alpha channel in the image if any <li>tiaAlphaFromIntensity : the alpha channel value is deduced from other RGB components intensity (the brighter, the more opaque) <li>tiaSuperBlackTransparent : pixels with a RGB color of (0, 0, 0) are completely transparent, others are completely opaque <li>tiaLuminance : the luminance value is calculated for each pixel and used for RGB and Alpha values <li>tiaLuminanceSqrt : same as tiaLuminance but with an Sqrt(Luminance) <li>tiaOpaque : alpha channel is uniformously set to 1.0 <li>tiaTopLeftPointColorTransparent : points of the same color as the top left point of the bitmap are transparent, others are opaque. </ul>

Values
  • tiaDefault:
  • tiaAlphaFromIntensity:
  • tiaSuperBlackTransparent:
  • tiaLuminance:
  • tiaLuminanceSqrt:
  • tiaOpaque:
  • tiaTopLeftPointColorTransparent:
  • tiaInverseLuminance:
  • tiaInverseLuminanceSqrt:
  • tiaBottomRightPointColorTransparent:
TGLTextureImageClass = class of TGLTextureImage;
TGLCubeMapTarget = Integer;
TGLTextureMappingMode = (...);
Values
  • tmmUser:
  • tmmObjectLinear:
  • tmmEyeLinear:
  • tmmSphere:
  • tmmCubeMapReflection:
  • tmmCubeMapNormal:
  • tmmCubeMapLight0:
  • tmmCubeMapCamera:

Constants

cDefaultNormalMapScale = 0.125;
CmtPX = 0;
CmtNX = 1;
CmtPY = 2;
CmtNY = 3;
CmtPZ = 4;
CmtNZ = 5;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLTexture: Interface IGLTextureNotifyAble

Interface IGLTextureNotifyAble

Unit

GLTexture

Declaration

type IGLTextureNotifyAble = interface(IGLNotifyAble)

Description

no description available, IGLNotifyAble description follows

Hierarchy

  • IInterface
  • IGLNotifyAble
  • IGLTextureNotifyAble

Overview

Methods

Public procedure NotifyTexMapChange(Sender: TObject);

Description

Methods

Public procedure NotifyTexMapChange(Sender: TObject);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:04


GLScene v.1.1.2: GLTexture: Class TGLTextureImage

Class TGLTextureImage

Unit

GLTexture

Declaration

type TGLTextureImage = class(TGLUpdateAbleObject)

Description

Base class for texture image data.<p> Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source).<br> SubClasses should be registered using RegisterGLTextureImageClass to allow proper persistence and editability in the IDE experts.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLTextureImage

Overview

Fields

Protected | FOwnerTexture: TGLTexture;
Protected | FOnTextureNeeded: TTextureNeededEvent;
Protected | FResourceFile: string;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function AsBitmap: TGLBitmap;
Public | class function FriendlyDescription: string; virtual;
Public | class function FriendlyName: string; virtual; abstract;
Public | function GetBitmap32: TGLImage; virtual; abstract;
Protected | function GetDepth: Integer; virtual; abstract;
Protected | function GetHeight: Integer; virtual; abstract;
Protected | function GetTextureTarget: TGLTextureTarget; virtual; abstract;
Protected | function GetWidth: Integer; virtual; abstract;
Protected | class function IsSelfLoading: Boolean; virtual;
Public | procedure AssignToBitmap(aBitmap: TGLBitmap);
Public | procedure Invalidate; dynamic;
Public | procedure LoadFromFile(const fileName: string); dynamic;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure ReleaseBitmap32; virtual;
Public | procedure SaveToFile(const fileName: string); dynamic; abstract;
Protected | procedure LoadTexture(AInternalFormat: TGLInternalFormat); virtual;

Properties

Public | property Depth: Integer read GetDepth;
Public | property Height: Integer read GetHeight;
Public | property NativeTextureTarget: TGLTextureTarget read GetTextureTarget;
Protected | property OnTextureNeeded: TTextureNeededEvent read FOnTextureNeeded write FOnTextureNeeded;
Public | property OwnerTexture: TGLTexture read FOwnerTexture write FOwnerTexture;
Public | property ResourceName: string read GetResourceName;
Public | property Width: Integer read GetWidth;

Description

Fields

Protected FOwnerTexture: TGLTexture;
Protected FOnTextureNeeded: TTextureNeededEvent;
Protected FResourceFile: string;

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public function AsBitmap: TGLBitmap;
Public class function FriendlyDescription: string; virtual;

Returns a user-friendly description for the class.<p> This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: string; virtual; abstract;

Returns a user-friendly denomination for the class.<p> This denomination is used for picking a texture image class in the IDE expert.

Public function GetBitmap32: TGLImage; virtual; abstract;

Returns image's bitmap handle.<p> If the actual image is not a windows bitmap (BMP), descendants should take care of properly converting to bitmap.

Protected function GetDepth: Integer; virtual; abstract;
Protected function GetHeight: Integer; virtual; abstract;
Protected function GetTextureTarget: TGLTextureTarget; virtual; abstract;
Protected function GetWidth: Integer; virtual; abstract;
Protected class function IsSelfLoading: Boolean; virtual;
Public procedure AssignToBitmap(aBitmap: TGLBitmap);
Public procedure Invalidate; dynamic;

Request reload/refresh of data upon next use.

Public procedure LoadFromFile(const fileName: string); dynamic;

Load textureImage from a file.<p> This may not load a picture, but for instance, parameters, if the textureImage is a procedural texture.<br> Subclasses should invoke inherited which will take care of the "OnTextureNeeded" stuff.

Public procedure NotifyChange(Sender: TObject); override;
Public procedure ReleaseBitmap32; virtual;

Request for unloading bitmapData, to free some memory.<p> This one is invoked when GLScene no longer needs the Bitmap data it got through a call to GetHBitmap.<br> Subclasses may ignore this call if the HBitmap was obtained at no particular memory cost.

Public procedure SaveToFile(const fileName: string); dynamic; abstract;

Save textureImage to file.<p> This may not save a picture, but for instance, parameters, if the textureImage is a procedural texture.

Protected procedure LoadTexture(AInternalFormat: TGLInternalFormat); virtual;

Properties

Public property Depth: Integer read GetDepth;
Public property Height: Integer read GetHeight;
Public property NativeTextureTarget: TGLTextureTarget read GetTextureTarget;

Native opengl texture target.<p>

Protected property OnTextureNeeded: TTextureNeededEvent read FOnTextureNeeded write FOnTextureNeeded;
Public property OwnerTexture: TGLTexture read FOwnerTexture write FOwnerTexture;
Public property ResourceName: string read GetResourceName;
Public property Width: Integer read GetWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTexture: Class TGLBlankImage

Class TGLBlankImage

Unit

GLTexture

Declaration

type TGLBlankImage = class(TGLTextureImage)

Description

A texture image with no specified content, only a size.<p> This texture image type is of use if the context of your texture is calculated at run-time (with a TGLMemoryViewer for instance).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLBlankImage

Overview

Fields

Protected | fBitmap: TGLImage;
Protected | fWidth: Integer;
Protected | fHeight: Integer;
Protected | fDepth: Integer;
Protected | fColorFormat: GLenum;
Protected | fCubeMap: Boolean;
Protected | fArray: Boolean;

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TGLImage; override;
Protected | function GetDepth: Integer; override;
Protected | function GetHeight: Integer; override;
Protected | function GetTextureTarget: TGLTextureTarget; override;
Protected | function GetWidth: Integer; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;

Properties

Published | property ColorFormat: GLenum read fColorFormat write fColorFormat;
Published | property CubeMap: Boolean read fCubeMap write SetCubeMap default false;
Published | property Depth: Integer read GetDepth write SetDepth default 0;
Published | property Height: Integer read GetHeight write SetHeight default 256;
Published | property TextureArray: Boolean read fArray write SetArray default false;
Published | property Width: Integer read GetWidth write SetWidth default 256;

Description

Fields

Protected fBitmap: TGLImage;
Protected fWidth: Integer;
Protected fHeight: Integer;
Protected fDepth: Integer;
Protected fColorFormat: GLenum;

Store a icolor format, because fBitmap is not always defined

Protected fCubeMap: Boolean;

Blank Cube Map

Protected fArray: Boolean;

Flag to interparate depth as layer

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Public function GetBitmap32: TGLImage; override;
Protected function GetDepth: Integer; override;
Protected function GetHeight: Integer; override;
Protected function GetTextureTarget: TGLTextureTarget; override;
Protected function GetWidth: Integer; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure LoadFromFile(const fileName: string); override;
Public procedure ReleaseBitmap32; override;
Public procedure SaveToFile(const fileName: string); override;

Properties

Published property ColorFormat: GLenum read fColorFormat write fColorFormat;
Published property CubeMap: Boolean read fCubeMap write SetCubeMap default false;
Published property Depth: Integer read GetDepth write SetDepth default 0;
Published property Height: Integer read GetHeight write SetHeight default 256;
Published property TextureArray: Boolean read fArray write SetArray default false;
Published property Width: Integer read GetWidth write SetWidth default 256;

Width, heigth and depth of the blank image (for memory allocation).

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTexture: Class TGLPictureImage

Class TGLPictureImage

Unit

GLTexture

Declaration

type TGLPictureImage = class(TGLTextureImage)

Description

Base class for image data classes internally based on a TPicture.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLPictureImage

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function GetBitmap32: TGLImage; override;
Protected | function GetDepth: Integer; override;
Protected | function GetHeight: Integer; override;
Protected | function GetPicture: TGLPicture;
Protected | function GetTextureTarget: TGLTextureTarget; override;
Protected | function GetWidth: Integer; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure ReleaseBitmap32; override;
Protected | procedure PictureChanged(Sender: TObject);
Protected | procedure SetPicture(const aPicture: TGLPicture);

Properties

Public property Picture: TGLPicture read GetPicture write SetPicture;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public function GetBitmap32: TGLImage; override;
Protected function GetDepth: Integer; override;
Protected function GetHeight: Integer; override;
Protected function GetPicture: TGLPicture;
Protected function GetTextureTarget: TGLTextureTarget; override;
Protected function GetWidth: Integer; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BeginUpdate;

Use this function if you are going to modify the Picture directly.<p> Each invokation MUST be balanced by a call to EndUpdate.

Public procedure EndUpdate;

Ends a direct picture modification session.<p> Follows a BeginUpdate.

Public procedure ReleaseBitmap32; override;
Protected procedure PictureChanged(Sender: TObject);
Protected procedure SetPicture(const aPicture: TGLPicture);

Properties

Public property Picture: TGLPicture read GetPicture write SetPicture;

Holds the image content.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTexture: Class TGLPersistentImage

Class TGLPersistentImage

Unit

GLTexture

Declaration

type TGLPersistentImage = class(TGLPictureImage)

Description

Stores any image compatible with Delphi's TPicture mechanism.<p> The picture's data is actually stored into the DFM, the original picture name or path is not remembered. It is similar in behaviour to Delphi's TImage.<p> Note that if original image is for instance JPEG format, only the JPEG data will be stored in the DFM (compact)

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLPictureImage
  • TGLPersistentImage

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure SaveToFile(const fileName: string); override;

Properties

Public | property NativeTextureTarget;
Published | property Picture;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Public procedure LoadFromFile(const fileName: string); override;
Public procedure SaveToFile(const fileName: string); override;

Properties

Public property NativeTextureTarget;
Published property Picture;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTexture: Class TGLPicFileImage

Class TGLPicFileImage

Unit

GLTexture

Declaration

type TGLPicFileImage = class(TGLPictureImage)

Description

Uses a picture whose data is found in a file (only filename is stored).<p> The image is unloaded after upload to OpenGL.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLPictureImage
  • TGLPicFileImage

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TGLImage; override;
Protected | function GetDepth: Integer; override;
Protected | function GetHeight: Integer; override;
Protected | function GetWidth: Integer; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Invalidate; override;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure SaveToFile(const fileName: string); override;
Protected | procedure SetPictureFileName(const val: string);

Properties

Public | property NativeTextureTarget;
Published | property PictureFileName: string read FPictureFileName write SetPictureFileName;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Public function GetBitmap32: TGLImage; override;
Protected function GetDepth: Integer; override;
Protected function GetHeight: Integer; override;
Protected function GetWidth: Integer; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure Invalidate; override;
Public procedure LoadFromFile(const fileName: string); override;

Load picture file name or use fileName as picture filename.<p> The autodetection is based on the filelength and presence of zeros.

Public procedure SaveToFile(const fileName: string); override;

Only picture file name is saved

Protected procedure SetPictureFileName(const val: string);

Properties

Public property NativeTextureTarget;
Published property PictureFileName: string read FPictureFileName write SetPictureFileName;

Filename of the picture to use.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTexture: Class TGLCubeMapImage

Class TGLCubeMapImage

Unit

GLTexture

Declaration

type TGLCubeMapImage = class(TGLTextureImage)

Description

A texture image used for specifying and stroing a cube map.<p> Not unlike TGLPictureImage, but storing 6 of them instead of just one.<br> Saving & loading as a whole currently not supported.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLTextureImage
  • TGLCubeMapImage

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: string; override;
Public | class function FriendlyName: string; override;
Public | function GetBitmap32: TGLImage; override;
Protected | function GetDepth: Integer; override;
Protected | function GetHeight: Integer; override;
Protected | function GetPicture(index: TGLCubeMapTarget): TGLPicture;
Protected | function GetTextureTarget: TGLTextureTarget; override;
Protected | function GetWidth: Integer; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure LoadFromFile(const fileName: string); override;
Public | procedure ReleaseBitmap32; override;
Public | procedure SaveToFile(const fileName: string); override;
Protected | procedure PictureChanged(Sender: TObject);
Protected | procedure SetPicture(index: TGLCubeMapTarget; const val: TGLPicture);

Properties

Public | property NativeTextureTarget;
Public | property Picture[index: TGLCubeMapTarget]: TGLPicture read GetPicture write SetPicture;
Published | property PictureNX: TGLPicture index cmtNX read GetPicture write SetPicture;
Published | property PictureNY: TGLPicture index cmtNY read GetPicture write SetPicture;
Published | property PictureNZ: TGLPicture index cmtNZ read GetPicture write SetPicture;
Published | property PicturePX: TGLPicture index cmtPX read GetPicture write SetPicture;
Published | property PicturePY: TGLPicture index cmtPY read GetPicture write SetPicture;
Published | property PicturePZ: TGLPicture index cmtPZ read GetPicture write SetPicture;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public class function FriendlyDescription: string; override;
Public class function FriendlyName: string; override;
Public function GetBitmap32: TGLImage; override;
Protected function GetDepth: Integer; override;
Protected function GetHeight: Integer; override;
Protected function GetPicture(index: TGLCubeMapTarget): TGLPicture;
Protected function GetTextureTarget: TGLTextureTarget; override;
Protected function GetWidth: Integer; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BeginUpdate;

Use this function if you are going to modify the Picture directly.<p> Each invokation MUST be balanced by a call to EndUpdate.

Public procedure EndUpdate;
Public procedure LoadFromFile(const fileName: string); override;
Public procedure ReleaseBitmap32; override;
Public procedure SaveToFile(const fileName: string); override;
Protected procedure PictureChanged(Sender: TObject);
Protected procedure SetPicture(index: TGLCubeMapTarget; const val: TGLPicture);

Properties

Public property NativeTextureTarget;
Public property Picture[index: TGLCubeMapTarget]: TGLPicture read GetPicture write SetPicture;

Indexed access to the cube map's sub pictures.

Published property PictureNX: TGLPicture index cmtNX read GetPicture write SetPicture;
Published property PictureNY: TGLPicture index cmtNY read GetPicture write SetPicture;
Published property PictureNZ: TGLPicture index cmtNZ read GetPicture write SetPicture;
Published property PicturePX: TGLPicture index cmtPX read GetPicture write SetPicture;
Published property PicturePY: TGLPicture index cmtPY read GetPicture write SetPicture;
Published property PicturePZ: TGLPicture index cmtPZ read GetPicture write SetPicture;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTexture: Class TGLTexture

Class TGLTexture

Unit

GLTexture

Declaration

type TGLTexture = class(TGLUpdateAbleObject)

Description

Defines basic texturing properties.<p> You can control texture wrapping, smoothing/filtering and of course define the texture map (note that texturing is disabled by default).<p> A built-in mechanism (through ImageAlpha) allows auto-generation of an Alpha channel for all bitmaps (see TGLTextureImageAlpha).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TGLTexture

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | destructor Destroy; override;
Public | function AllocateHandle: TGLuint;
Public | function GetImageClassName: string;
Public | function IsFloatType: Boolean;
Public | function IsHandleAllocated: Boolean;
Public | function OpenGLTextureFormat: Integer;
Public | function TextureImageRequiredMemory: Integer;
Protected | function GetEnabled: Boolean;
Protected | function GetHandle: TGLuint; virtual;
Protected | function GetMappingQCoordinates: TGLCoordinates4;
Protected | function GetMappingRCoordinates: TGLCoordinates4;
Protected | function GetMappingSCoordinates: TGLCoordinates4;
Protected | function GetMappingTCoordinates: TGLCoordinates4;
Protected | function GetTextureFormat: TGLTextureFormat;
Protected | function StoreBrightness: Boolean;
Protected | function StoreGamma: Boolean;
Protected | function StoreImageClassName: Boolean;
Protected | function StoreMappingQCoordinates: Boolean;
Protected | function StoreMappingRCoordinates: Boolean;
Protected | function StoreMappingSCoordinates: Boolean;
Protected | function StoreMappingTCoordinates: Boolean;
Protected | function StoreNormalMapScale: Boolean;
Protected | function StoreTextureFormatEx: Boolean;
Public | procedure Apply(var rci: TRenderContextInfo);
Public | procedure ApplyAsTexture2(var rci: TRenderContextInfo; textureMatrix: PMatrix = nil);
Public | procedure ApplyAsTextureN(n: Integer; var rci: TRenderContextInfo; textureMatrix: PMatrix = nil);
Public | procedure ApplyMappingMode;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure DestroyHandles;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure NotifyImageChange;
Public | procedure NotifyParamsChange;
Public | procedure PrepareBuildList;
Public | procedure SetImageClassName(const val: string);
Public | procedure UnApply(var rci: TRenderContextInfo);
Public | procedure UnApplyAsTexture2(var rci: TRenderContextInfo; reloadIdentityTextureMatrix: boolean);
Public | procedure UnApplyAsTextureN(n: Integer; var rci: TRenderContextInfo; reloadIdentityTextureMatrix: boolean);
Public | procedure UnApplyMappingMode;
Protected | procedure DoOnTextureNeeded(Sender: TObject; var textureFileName: string);
Protected | procedure OnSamplerAllocate(Sender: TGLVirtualHandle; var Handle: Cardinal);
Protected | procedure OnSamplerDestroy(Sender: TGLVirtualHandle; var Handle: Cardinal);
Protected | procedure PrepareImage(target: TGLUInt); virtual;
Protected | procedure PrepareParams(target: TGLUInt); virtual;
Protected | procedure SetBorderColor(const val: TGLColor);
Protected | procedure SetCompression(const val: TGLTextureCompression);
Protected | procedure SetDepthTextureMode(const val: TGLDepthTextureMode);
Protected | procedure SetDisabled(AValue: Boolean);
Protected | procedure SetEnabled(const val: Boolean);
Protected | procedure SetEnvColor(const val: TGLColor);
Protected | procedure SetFilteringQuality(const val: TGLTextureFilteringQuality);
Protected | procedure SetImage(AValue: TGLTextureImage);
Protected | procedure SetImageAlpha(const val: TGLTextureImageAlpha);
Protected | procedure SetImageBrightness(const val: Single);
Protected | procedure SetImageGamma(const val: Single);
Protected | procedure SetMagFilter(AValue: TGLMagFilter);
Protected | procedure SetMappingMode(const val: TGLTextureMappingMode);
Protected | procedure SetMappingQCoordinates(const val: TGLCoordinates4);
Protected | procedure SetMappingRCoordinates(const val: TGLCoordinates4);
Protected | procedure SetMappingSCoordinates(const val: TGLCoordinates4);
Protected | procedure SetMappingTCoordinates(const val: TGLCoordinates4);
Protected | procedure SetMinFilter(AValue: TGLMinFilter);
Protected | procedure SetNormalMapScale(const val: Single);
Protected | procedure SetTextureCompareFunc(const val: TGLDepthCompareFunc);
Protected | procedure SetTextureCompareMode(const val: TGLTextureCompareMode);
Protected | procedure SetTextureErrorImage;
Protected | procedure SetTextureFormat(const val: TGLTextureFormat);
Protected | procedure SetTextureFormatEx(const val: TGLInternalFormat);
Protected | procedure SetTextureMode(AValue: TGLTextureMode);
Protected | procedure SetTextureWrap(AValue: TGLTextureWrap);
Protected | procedure SetTextureWrapR(AValue: TGLSeparateTextureWrap);
Protected | procedure SetTextureWrapS(AValue: TGLSeparateTextureWrap);
Protected | procedure SetTextureWrapT(AValue: TGLSeparateTextureWrap);

Properties

Published | property BorderColor: TGLColor read FBorderColor write SetBorderColor;
Published | property Compression: TGLTextureCompression read FCompression write SetCompression default tcDefault;
Published | property DepthTextureMode: TGLDepthTextureMode read fDepthTextureMode write SetDepthTextureMode default dtmLuminance;
Published | property Disabled: Boolean read FDisabled write SetDisabled default True;
Public | property Enabled: Boolean read GetEnabled write SetEnabled;
Published | property EnvColor: TGLColor read FEnvColor write SetEnvColor;
Published | property FilteringQuality: TGLTextureFilteringQuality read FFilteringQuality write SetFilteringQuality default tfIsotropic;
Public | property Handle: TGLuint read GetHandle;
Published | property Image: TGLTextureImage read FImage write SetImage;
Published | property ImageAlpha: TGLTextureImageAlpha read FImageAlpha write SetImageAlpha default tiaDefault;
Published | property ImageBrightness: Single read FImageBrightness write SetImageBrightness stored StoreBrightness;
Published | property ImageClassName: string read GetImageClassName write SetImageClassName stored StoreImageClassName;
Published | property ImageGamma: Single read FImageGamma write SetImageGamma stored StoreGamma;
Published | property KeepImageAfterTransfer: Boolean read FKeepImageAfterTransfer write FKeepImageAfterTransfer default False;
Published | property MagFilter: TGLMagFilter read FMagFilter write SetMagFilter default maLinear;
Published | property MappingMode: TGLTextureMappingMode read FMappingMode write SetMappingMode default tmmUser;
Published | property MappingQCoordinates: TGLCoordinates4 read GetMappingQCoordinates write SetMappingQCoordinates stored StoreMappingQCoordinates;
Published | property MappingRCoordinates: TGLCoordinates4 read GetMappingRCoordinates write SetMappingRCoordinates stored StoreMappingRCoordinates;
Published | property MappingSCoordinates: TGLCoordinates4 read GetMappingSCoordinates write SetMappingSCoordinates stored StoreMappingSCoordinates;
Published | property MappingTCoordinates: TGLCoordinates4 read GetMappingTCoordinates write SetMappingTCoordinates stored StoreMappingTCoordinates;
Published | property MinFilter: TGLMinFilter read FMinFilter write SetMinFilter default miLinearMipMapLinear;
Published | property NormalMapScale: Single read FNormalMapScale write SetNormalMapScale stored StoreNormalMapScale;
Public | property OnTextureNeeded: TTextureNeededEvent read FOnTextureNeeded write FOnTextureNeeded;
Public | property TexDepth: Integer read FTexDepth;
Public | property TexHeight: Integer read FTexHeight;
Published | property TextureCompareFunc: TGLDepthCompareFunc read fTextureCompareFunc write SetTextureCompareFunc default cfLequal;
Published | property TextureCompareMode: TGLTextureCompareMode read fTextureCompareMode write SetTextureCompareMode default tcmNone;
Published | property TextureFormat: TGLTextureFormat read GetTextureFormat write SetTextureFormat default tfDefault;
Published | property TextureFormatEx: TGLInternalFormat read FTextureFormat write SetTextureFormatEx stored StoreTextureFormatEx;
Public | property TextureHandle: TGLTextureHandle read FTextureHandle;
Published | property TextureMode: TGLTextureMode read FTextureMode write SetTextureMode default tmDecal;
Published | property TextureWrap: TGLTextureWrap read FTextureWrap write SetTextureWrap default twBoth;
Published | property TextureWrapR: TGLSeparateTextureWrap read FTextureWrapR write SetTextureWrapR default twRepeat;
Published | property TextureWrapS: TGLSeparateTextureWrap read FTextureWrapS write SetTextureWrapS default twRepeat;
Published | property TextureWrapT: TGLSeparateTextureWrap read FTextureWrapT write SetTextureWrapT default twRepeat;
Public | property TexWidth: Integer read FTexWidth;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public destructor Destroy; override;
Public function AllocateHandle: TGLuint;

Allocates the texture handle if not already allocated.<p> The texture is binded and parameters are setup, but no image data is initialized by this call - for expert use only.

Public function GetImageClassName: string;
Public function IsFloatType: Boolean;

Returns if of float data type

Public function IsHandleAllocated: Boolean;
Public function OpenGLTextureFormat: Integer;

Returns OpenGL texture format corresponding to current options.

Public function TextureImageRequiredMemory: Integer;

Returns the OpenGL memory used by the texture.<p> The compressed size is returned if, and only if texture compression if active and possible, and the texture has been allocated (Handle is defined), otherwise the estimated size (from TextureFormat specification) is returned.

Protected function GetEnabled: Boolean;
Protected function GetHandle: TGLuint; virtual;
Protected function GetMappingQCoordinates: TGLCoordinates4;
Protected function GetMappingRCoordinates: TGLCoordinates4;
Protected function GetMappingSCoordinates: TGLCoordinates4;
Protected function GetMappingTCoordinates: TGLCoordinates4;
Protected function GetTextureFormat: TGLTextureFormat;
Protected function StoreBrightness: Boolean;
Protected function StoreGamma: Boolean;
Protected function StoreImageClassName: Boolean;
Protected function StoreMappingQCoordinates: Boolean;
Protected function StoreMappingRCoordinates: Boolean;
Protected function StoreMappingSCoordinates: Boolean;
Protected function StoreMappingTCoordinates: Boolean;
Protected function StoreNormalMapScale: Boolean;
Protected function StoreTextureFormatEx: Boolean;
Public procedure Apply(var rci: TRenderContextInfo);
Public procedure ApplyAsTexture2(var rci: TRenderContextInfo; textureMatrix: PMatrix = nil);

Applies to TEXTURE1

Public procedure ApplyAsTextureN(n: Integer; var rci: TRenderContextInfo; textureMatrix: PMatrix = nil);

N=1 for TEXTURE0, N=2 for TEXTURE1, etc.

Public procedure ApplyMappingMode;
Public procedure Assign(Source: TPersistent); override;
Public procedure DestroyHandles;
Public procedure NotifyChange(Sender: TObject); override;
Public procedure NotifyImageChange;
Public procedure NotifyParamsChange;
Public procedure PrepareBuildList;
Public procedure SetImageClassName(const val: string);
Public procedure UnApply(var rci: TRenderContextInfo);
Public procedure UnApplyAsTexture2(var rci: TRenderContextInfo; reloadIdentityTextureMatrix: boolean);
Public procedure UnApplyAsTextureN(n: Integer; var rci: TRenderContextInfo; reloadIdentityTextureMatrix: boolean);
Public procedure UnApplyMappingMode;
Protected procedure DoOnTextureNeeded(Sender: TObject; var textureFileName: string);
Protected procedure OnSamplerAllocate(Sender: TGLVirtualHandle; var Handle: Cardinal);
Protected procedure OnSamplerDestroy(Sender: TGLVirtualHandle; var Handle: Cardinal);
Protected procedure PrepareImage(target: TGLUInt); virtual;

Load texture to OpenGL subsystem

Protected procedure PrepareParams(target: TGLUInt); virtual;

Setup OpenGL texture parameters

Protected procedure SetBorderColor(const val: TGLColor);
Protected procedure SetCompression(const val: TGLTextureCompression);
Protected procedure SetDepthTextureMode(const val: TGLDepthTextureMode);
Protected procedure SetDisabled(AValue: Boolean);
Protected procedure SetEnabled(const val: Boolean);
Protected procedure SetEnvColor(const val: TGLColor);
Protected procedure SetFilteringQuality(const val: TGLTextureFilteringQuality);
Protected procedure SetImage(AValue: TGLTextureImage);
Protected procedure SetImageAlpha(const val: TGLTextureImageAlpha);
Protected procedure SetImageBrightness(const val: Single);
Protected procedure SetImageGamma(const val: Single);
Protected procedure SetMagFilter(AValue: TGLMagFilter);
Protected procedure SetMappingMode(const val: TGLTextureMappingMode);
Protected procedure SetMappingQCoordinates(const val: TGLCoordinates4);
Protected procedure SetMappingRCoordinates(const val: TGLCoordinates4);
Protected procedure SetMappingSCoordinates(const val: TGLCoordinates4);
Protected procedure SetMappingTCoordinates(const val: TGLCoordinates4);
Protected procedure SetMinFilter(AValue: TGLMinFilter);
Protected procedure SetNormalMapScale(const val: Single);
Protected procedure SetTextureCompareFunc(const val: TGLDepthCompareFunc);
Protected procedure SetTextureCompareMode(const val: TGLTextureCompareMode);
Protected procedure SetTextureErrorImage;

Shows a special image that indicates an error

Protected procedure SetTextureFormat(const val: TGLTextureFormat);
Protected procedure SetTextureFormatEx(const val: TGLInternalFormat);
Protected procedure SetTextureMode(AValue: TGLTextureMode);
Protected procedure SetTextureWrap(AValue: TGLTextureWrap);
Protected procedure SetTextureWrapR(AValue: TGLSeparateTextureWrap);
Protected procedure SetTextureWrapS(AValue: TGLSeparateTextureWrap);
Protected procedure SetTextureWrapT(AValue: TGLSeparateTextureWrap);

Properties

Published property BorderColor: TGLColor read FBorderColor write SetBorderColor;

Texture Border color.

Published property Compression: TGLTextureCompression read FCompression write SetCompression default tcDefault;

Texture compression control.<p> If True the compressed TextureFormat variant (the OpenGL ICD must support GL_ARB_texture_compression, or this option is ignored).

Published property DepthTextureMode: TGLDepthTextureMode read fDepthTextureMode write SetDepthTextureMode default dtmLuminance;
Published property Disabled: Boolean read FDisabled write SetDisabled default True;

If true, the texture is disabled (not used).

Public property Enabled: Boolean read GetEnabled write SetEnabled;

Is the texture enabled?.<p> Always equals to 'not Disabled'.

Published property EnvColor: TGLColor read FEnvColor write SetEnvColor;

Texture Environment color.

Published property FilteringQuality: TGLTextureFilteringQuality read FFilteringQuality write SetFilteringQuality default tfIsotropic;

Specifies texture filtering quality.<p> You can choose between bilinear and trilinear filetring (anisotropic).<p> The OpenGL ICD must support GL_EXT_texture_filter_anisotropic or this property is ignored.

Public property Handle: TGLuint read GetHandle;

Handle to the OpenGL texture object.<p> If the handle hasn't already been allocated, it will be allocated by this call (ie. do not use if no OpenGL context is active!)

Published property Image: TGLTextureImage read FImage write SetImage;

Image data for the texture.<p>

Published property ImageAlpha: TGLTextureImageAlpha read FImageAlpha write SetImageAlpha default tiaDefault;

Automatic Image Alpha setting.<p> Allows to control how and if the image's Alpha channel (transparency) is computed.

Published property ImageBrightness: Single read FImageBrightness write SetImageBrightness stored StoreBrightness;

Texture brightness correction.<p> This correction is applied upon loading a TGLTextureImage, it's a simple saturating scaling applied to the RGB components of the 32 bits image, before it is passed to OpenGL, and before gamma correction (if any).

Published property ImageClassName: string read GetImageClassName write SetImageClassName stored StoreImageClassName;

Image ClassName for enabling True polymorphism.<p> This is ugly, but since the default streaming mechanism does a really bad job at storing polymorphic owned-object properties, and neither TFiler nor TPicture allow proper use of the built-in streaming, that's the only way I found to allow a user-extensible mechanism.

Published property ImageGamma: Single read FImageGamma write SetImageGamma stored StoreGamma;

Texture gamma correction.<p> The gamma correction is applied upon loading a TGLTextureImage, applied to the RGB components of the 32 bits image, before it is passed to OpenGL, after brightness correction (if any).

Published property KeepImageAfterTransfer: Boolean read FKeepImageAfterTransfer write FKeepImageAfterTransfer default False;

Disable image release after transfering it to VGA.

Published property MagFilter: TGLMagFilter read FMagFilter write SetMagFilter default maLinear;

Texture magnification filter.

Published property MappingMode: TGLTextureMappingMode read FMappingMode write SetMappingMode default tmmUser;

Texture coordinates mapping mode.<p> This property controls automatic texture coordinates generation.

Published property MappingQCoordinates: TGLCoordinates4 read GetMappingQCoordinates write SetMappingQCoordinates stored StoreMappingQCoordinates;
Published property MappingRCoordinates: TGLCoordinates4 read GetMappingRCoordinates write SetMappingRCoordinates stored StoreMappingRCoordinates;
Published property MappingSCoordinates: TGLCoordinates4 read GetMappingSCoordinates write SetMappingSCoordinates stored StoreMappingSCoordinates;

Texture mapping coordinates mode for S, T, R and Q axis.<p> This property stores the coordinates for automatic texture coordinates generation.

Published property MappingTCoordinates: TGLCoordinates4 read GetMappingTCoordinates write SetMappingTCoordinates stored StoreMappingTCoordinates;
Published property MinFilter: TGLMinFilter read FMinFilter write SetMinFilter default miLinearMipMapLinear;

Texture minification filter.

Published property NormalMapScale: Single read FNormalMapScale write SetNormalMapScale stored StoreNormalMapScale;

Normal Map scaling.<p> Only applies when TextureFormat is tfNormalMap, this property defines the scaling that is applied during normal map generation (ie. controls the intensity of the bumps).

Public property OnTextureNeeded: TTextureNeededEvent read FOnTextureNeeded write FOnTextureNeeded;
Public property TexDepth: Integer read FTexDepth;
Public property TexHeight: Integer read FTexHeight;
Published property TextureCompareFunc: TGLDepthCompareFunc read fTextureCompareFunc write SetTextureCompareFunc default cfLequal;
Published property TextureCompareMode: TGLTextureCompareMode read fTextureCompareMode write SetTextureCompareMode default tcmNone;
Published property TextureFormat: TGLTextureFormat read GetTextureFormat write SetTextureFormat default tfDefault;

Texture format for use by the renderer.<p> See TGLTextureFormat for details.

Published property TextureFormatEx: TGLInternalFormat read FTextureFormat write SetTextureFormatEx stored StoreTextureFormatEx;
Public property TextureHandle: TGLTextureHandle read FTextureHandle;
Published property TextureMode: TGLTextureMode read FTextureMode write SetTextureMode default tmDecal;

Texture application mode.

Published property TextureWrap: TGLTextureWrap read FTextureWrap write SetTextureWrap default twBoth;

Wrapping mode for the texture.

Published property TextureWrapR: TGLSeparateTextureWrap read FTextureWrapR write SetTextureWrapR default twRepeat;
Published property TextureWrapS: TGLSeparateTextureWrap read FTextureWrapS write SetTextureWrapS default twRepeat;

Wrapping mode for the texture when TextureWrap=twSeparate.

Published property TextureWrapT: TGLSeparateTextureWrap read FTextureWrapT write SetTextureWrapT default twRepeat;
Public property TexWidth: Integer read FTexWidth;

Actual width, height and depth used for last texture specification binding.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTexture: Class TGLTextureExItem

Class TGLTextureExItem

Unit

GLTexture

Declaration

type TGLTextureExItem = class(TCollectionItem, IGLTextureNotifyAble)

Description

Hierarchy

  • TCollectionItem
  • TGLTextureExItem

Overview

Methods

Public | constructor Create(ACollection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Protected | function GetOwner: TPersistent; override;
Public | procedure Apply(var rci: TRenderContextInfo);
Public | procedure Assign(Source: TPersistent); override;
Public | procedure NotifyChange(Sender: TObject);
Public | procedure UnApply(var rci: TRenderContextInfo);
Protected | procedure CalculateTextureMatrix;
Protected | procedure NotifyTexMapChange(Sender: TObject);
Protected | procedure OnNotifyChange(Sender: TObject);
Protected | procedure SetTexture(const Value: TGLTexture);
Protected | procedure SetTextureIndex(const Value: Integer);
Protected | procedure SetTextureOffset(const Value: TGLCoordinates);
Protected | procedure SetTextureScale(const Value: TGLCoordinates);

Properties

Published | property Texture: TGLTexture read FTexture write SetTexture;
Published | property TextureIndex: Integer read FTextureIndex write SetTextureIndex;
Published | property TextureOffset: TGLCoordinates read FTextureOffset write SetTextureOffset;
Published | property TextureScale: TGLCoordinates read FTextureScale write SetTextureScale;

Description

Methods

Public constructor Create(ACollection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Protected function GetOwner: TPersistent; override;
Public procedure Apply(var rci: TRenderContextInfo);
Public procedure Assign(Source: TPersistent); override;
Public procedure NotifyChange(Sender: TObject);
Public procedure UnApply(var rci: TRenderContextInfo);
Protected procedure CalculateTextureMatrix;
Protected procedure NotifyTexMapChange(Sender: TObject);
Protected procedure OnNotifyChange(Sender: TObject);
Protected procedure SetTexture(const Value: TGLTexture);
Protected procedure SetTextureIndex(const Value: Integer);
Protected procedure SetTextureOffset(const Value: TGLCoordinates);
Protected procedure SetTextureScale(const Value: TGLCoordinates);

Properties

Published property Texture: TGLTexture read FTexture write SetTexture;
Published property TextureIndex: Integer read FTextureIndex write SetTextureIndex;
Published property TextureOffset: TGLCoordinates read FTextureOffset write SetTextureOffset;
Published property TextureScale: TGLCoordinates read FTextureScale write SetTextureScale;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTexture: Class TGLTextureEx

Class TGLTextureEx

Unit

GLTexture

Declaration

type TGLTextureEx = class(TCollection)

Description

Hierarchy

  • TCollection
  • TGLTextureEx

Overview

Methods

Public | constructor Create(AOwner: TGLUpdateAbleObject);
Public | function Add: TGLTextureExItem;
Public | function IsTextureEnabled(Index: Integer): Boolean;
Protected | function GetItems(index: Integer): TGLTextureExItem;
Protected | function GetOwner: TPersistent; override;
Public | procedure Apply(var rci: TRenderContextInfo);
Public | procedure Loaded;
Public | procedure NotifyChange(Sender: TObject);
Public | procedure UnApply(var rci: TRenderContextInfo);
Protected | procedure SetItems(index: Integer; const Value: TGLTextureExItem);

Properties

Public property Items[index: Integer]: TGLTextureExItem read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TGLUpdateAbleObject);
Public function Add: TGLTextureExItem;
Public function IsTextureEnabled(Index: Integer): Boolean;
Protected function GetItems(index: Integer): TGLTextureExItem;
Protected function GetOwner: TPersistent; override;
Public procedure Apply(var rci: TRenderContextInfo);
Public procedure Loaded;
Public procedure NotifyChange(Sender: TObject);
Public procedure UnApply(var rci: TRenderContextInfo);
Protected procedure SetItems(index: Integer; const Value: TGLTextureExItem);

Properties

Public property Items[index: Integer]: TGLTextureExItem read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTexture: Class ETexture

Class ETexture

Unit

GLTexture

Declaration

type ETexture = class(Exception)

Description

Hierarchy

  • Exception
  • ETexture
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTexture: Class EGLShaderException

Class EGLShaderException

Unit

GLTexture

Declaration

type EGLShaderException = class(Exception)

Description

Hierarchy

  • Exception
  • EGLShaderException
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTextureCombiners

Unit GLTextureCombiners

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLTextureCombiners<p>

Texture combiners setup utility functions.<p>

<b>History : </b><font size=-1><ul> <li>05/03/11 - Yar - Added combiner's commands cache <li>23/08/10 - Yar - Added OpenGLTokens to uses <li>18/06/10 - Yar - Replaced OpenGL functions to OpenGLAdapter <li>02/04/07 - DaStr - Added $I GLScene.inc <li>17/12/03 - EG - Alpha and RGB channels separate combination now supported <li>23/05/03 - EG - All tex units now accepted as target <li>22/05/03 - EG - Fixed GL_ADD_SIGNED_ARB parsing, better error reporting <li>16/05/03 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TCombinerCommand |
Class ETextureCombinerError |

Functions and Procedures

function GetTextureCombiners(const tcCode: TStringList): TCombinerCache;

Types

TCombinerCache = array of TCombinerCommand;

Description

Functions and Procedures

function GetTextureCombiners(const tcCode: TStringList): TCombinerCache;

Parses a TC text description and setups combiners accordingly.<p> *experimental*<br> Knowledge of texture combiners is a requirement<br> Syntax: pascal-like, one instruction per line, use '//' for comment.<p>

Examples:<ul> <li>Tex1:=Tex0; // replace texture 1 with texture 0 <li>Tex1:=Tex0+Tex1; // additive blending between textures 0 and 1 <li>Tex1:=Tex0-Tex1; // subtractive blending between textures 0 and 1 <li>Tex1:=Tex0*Tex1; // modulation between textures 0 and 1 <li>Tex1:=Tex0+Tex1-0.5; // signed additive blending between textures 0 and 1 <li>Tex1:=Interpolate(Tex0, Tex1, PrimaryColor); // interpolation between textures 0 and 1 using primary color as factor <li>Tex1:=Dot3(Tex0, Tex1); // dot3 product between textures 0 and 1 </ul><p>

Accepted tokens:<ul> <li>Tex0, Tex1, etc. : texture unit <li>PrimaryColor, Col : the primary color <li>ConstantColor, EnvCol : texture environment constant color </ul><br> Tokens can be qualified with '.a' or '.alpha' to specify the alpha channel explicitly, and '.rgb' to specify color channels (default). You cannot mix alpha and rgb tokens in the same line.

Types

TCombinerCache = array of TCombinerCommand;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTextureCombiners: record TCombinerCommand

record TCombinerCommand

Unit

GLTextureCombiners

Declaration

type TCombinerCommand = record

Description

Overview

Fields

ActiveUnit: Integer;
Arg1: Integer;
Arg2: Integer;

Description

Fields

ActiveUnit: Integer;
Arg1: Integer;
Arg2: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTextureCombiners: Class ETextureCombinerError

Class ETextureCombinerError

Unit

GLTextureCombiners

Declaration

type ETextureCombinerError = class(Exception)

Description

Hierarchy

  • Exception
  • ETextureCombinerError
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTexturedHDS

Unit GLTexturedHDS

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Implements a HDS, which automatically maps textures onto a parent HDS .<p> This HDS links to and extracts its height data from a parent HDS. (like TGLHeightTileFile)

The HDS also links to a TGLMaterial Library, and maps ALL textures from the selected Material Library onto the terrain, WITHOUT using Multitexturing. The position and scale of each texture is determined by the material's own TextureOffset and TextureScale properties. This makes it easy to tile many textures onto a single, continuous TGLTerrainRenderer.

If two or more textures in the library overlap, the top texture is used.( ie.the later one in the list)

WARNING: Only one base texture is mapped onto each terrain tile, so, make sure your texture edges are alligned to height tile edges, or gaps will show. (Of course you can still multitexture in a detail texture too.)

<b>History : </b><font size=-1><ul> <li>22/01/07 - LIN - Added 'TileSize' and 'TilesPerTexture' properties Removed 'Active' property Now works with both TGLHeightTileFileHDS AND TGLBitmapHDS <li>19/01/07 - LIN - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTexturedHDS |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTexturedHDS: Class TGLTexturedHDS

Class TGLTexturedHDS

Unit

GLTexturedHDS

Declaration

type TGLTexturedHDS = class(THeightDataSource)

Description

no description available, THeightDataSource description follows

Hierarchy

  • TComponent
  • THeightDataSource
  • TGLTexturedHDS

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure MarkDirty(const area : TGLRect); override;
Public | procedure StartPreparingData(heightData : THeightData); override;
Protected | procedure SetHeightDataSource(val:THeightDataSource);

Properties

Published | property HeightDataSource : THeightDataSource read FHeightDataSource write SetHeightDataSource;
Published | property MaterialLibrary : TGLMaterialLibrary read FMaterialLibrary write FMaterialLibrary;
Published | property MaxPoolSize;
Published | property OnMarkDirtyEvent : TMarkDirtyEvent read FOnMarkDirty write FOnMarkDirty;
Published | property OnStartPreparingData : TStartPreparingDataEvent read FOnStartPreparingData write FOnStartPreparingData;
Published | property TileSize : integer read FTileSize write FTileSize;
Published | property TilesPerTexture : Integer read FTilesPerTexture write FTilesPerTexture;
Published | property WholeTilesOnly : Boolean read FWholeTilesOnly write FWholeTilesOnly;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure MarkDirty(const area : TGLRect); override;
Public procedure StartPreparingData(heightData : THeightData); override;
Protected procedure SetHeightDataSource(val:THeightDataSource);

Properties

Published property HeightDataSource : THeightDataSource read FHeightDataSource write SetHeightDataSource;
Published property MaterialLibrary : TGLMaterialLibrary read FMaterialLibrary write FMaterialLibrary;
Published property MaxPoolSize;
Published property OnMarkDirtyEvent : TMarkDirtyEvent read FOnMarkDirty write FOnMarkDirty;
Published property OnStartPreparingData : TStartPreparingDataEvent read FOnStartPreparingData write FOnStartPreparingData;
Published property TileSize : integer read FTileSize write FTileSize;
Published property TilesPerTexture : Integer read FTilesPerTexture write FTilesPerTexture;
Published property WholeTilesOnly : Boolean read FWholeTilesOnly write FWholeTilesOnly;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:05


GLScene v.1.1.2: GLTextureFormat

Unit GLTextureFormat

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLTextureFormat<p>

<b>History : </b><font size=-1><ul> <li>10/05/12 - Yar - Fixed extension checking for float texture (thnaks Nelson Chu) <li>03/08/10 - Yar - Added SNORM texture format <li>15/06/10 - Yar - Replace OpenGL1x extensions to OpenGLAdapter <li>22/04/10 - Yar - Moved TGLTextureTarget <li>23/01/10 - Yar - Separated GLTextureFormat and GLInternalFormat GLTextureFormat moved to GLTexture <li>21/01/10 - Yar - Creation </ul><p>

Overview

Functions and Procedures

function InternalFormatToOpenGLFormat(intFormat: TGLInternalFormat): TGLEnum;
function OpenGLFormatToInternalFormat(glFormat: TGLEnum): TGLInternalFormat;
function GetTextureElementSize(intFormat: TGLInternalFormat): Integer; overload;
function GetTextureElementSize(colorFormat: TGLEnum; dataType: TGLEnum): Integer; overload;
procedure FindCompatibleDataFormat(intFormat: TGLInternalFormat; out dFormat: GLenum; out dType: GLenum);
function CompressedInternalFormatToOpenGL(intFormat: TGLInternalFormat): Integer;
function IsTargetSupported(glTarget: TGLEnum): Boolean; overload;
function IsTargetSupported(target: TGLTextureTarget): Boolean; overload;
function IsFormatSupported(intFormat: TGLInternalFormat): Boolean;
function IsFloatFormat(intFormat: TGLInternalFormat): Boolean; overload;
function IsFloatFormat(glFormat: TGLEnum): Boolean; overload;
function IsDepthFormat(intFormat: TGLInternalFormat): boolean; overload;
function IsDepthFormat(glFormat: TGLEnum): Boolean; overload;
function IsCompressedFormat(intFormat: TGLInternalFormat): Boolean; overload;
function IsCompressedFormat(glFormat: TGLEnum): Boolean; overload;
function GetGenericCompressedFormat(const intFormat: TGLInternalFormat; const colorFormat: TGLEnum; out internalFormat: TGLEnum): Boolean;
function GetUncompressedFormat(const intFormat: TGLInternalFormat; out internalFormat: TGLInternalFormat; out colorFormat: TGLEnum): Boolean;
function DecodeGLTextureTarget(const TextureTarget: TGLTextureTarget): TGLEnum;
function EncodeGLTextureTarget(const glTarget: TGLEnum): TGLTextureTarget;
function IsTargetSupportMipmap(const TextureTarget: TGLTextureTarget): Boolean; overload;
function IsTargetSupportMipmap(const glTarget: TGLEnum): Boolean; overload;

Types

TGLSeparateTextureWrap = (...);
TGLTextureCompareMode = (...);
TGLTextureFilteringQuality = (...);
TGLTextureTarget = (...);
TGLTextureSwizzle = (...);
TSwizzleVector = array[0..3] of TGLTextureSwizzle;
TGLInternalFormat = (...);
TGLInternalCompression = (...);

Constants

cDefaultSwizzleVector: TSwizzleVector = (tswRed, tswGreen, tswBlue, tswAlpha);

Variables

vDefaultTextureFormat: TGLInternalFormat = tfRGBA8;
vDefaultTextureCompression: TGLInternalCompression = tcNone;

Description

Functions and Procedures

function InternalFormatToOpenGLFormat(intFormat: TGLInternalFormat): TGLEnum;

Give a openGL texture format from GLScene texture format.

function OpenGLFormatToInternalFormat(glFormat: TGLEnum): TGLInternalFormat;

Give a GLScene texture format from openGL texture format.

function GetTextureElementSize(intFormat: TGLInternalFormat): Integer; overload;

Give a pixel size in bytes from texture format or data format.

function GetTextureElementSize(colorFormat: TGLEnum; dataType: TGLEnum): Integer; overload;
procedure FindCompatibleDataFormat(intFormat: TGLInternalFormat; out dFormat: GLenum; out dType: GLenum);

Give compatible openGL image format and data type.

function CompressedInternalFormatToOpenGL(intFormat: TGLInternalFormat): Integer;

Give a compressed openGL texture format from GLScene texture format if format is have not compression than return same openGL format.

function IsTargetSupported(glTarget: TGLEnum): Boolean; overload;

True if texture target supported.

function IsTargetSupported(target: TGLTextureTarget): Boolean; overload;
function IsFormatSupported(intFormat: TGLInternalFormat): Boolean;

True if texture format is supported by hardware or software.

function IsFloatFormat(intFormat: TGLInternalFormat): Boolean; overload;

True if texture format is float.

function IsFloatFormat(glFormat: TGLEnum): Boolean; overload;
function IsDepthFormat(intFormat: TGLInternalFormat): boolean; overload;

True if depth texture.

function IsDepthFormat(glFormat: TGLEnum): Boolean; overload;
function IsCompressedFormat(intFormat: TGLInternalFormat): Boolean; overload;

True if texture compressed.

function IsCompressedFormat(glFormat: TGLEnum): Boolean; overload;
function GetGenericCompressedFormat(const intFormat: TGLInternalFormat; const colorFormat: TGLEnum; out internalFormat: TGLEnum): Boolean;

Give generic compressed OpenGL texture format.

function GetUncompressedFormat(const intFormat: TGLInternalFormat; out internalFormat: TGLInternalFormat; out colorFormat: TGLEnum): Boolean;

Give uncompressed texture format and OpenGL color format.

function DecodeGLTextureTarget(const TextureTarget: TGLTextureTarget): TGLEnum;
function EncodeGLTextureTarget(const glTarget: TGLEnum): TGLTextureTarget;
function IsTargetSupportMipmap(const TextureTarget: TGLTextureTarget): Boolean; overload;
function IsTargetSupportMipmap(const glTarget: TGLEnum): Boolean; overload;

Types

TGLSeparateTextureWrap = (...);
Values
  • twRepeat:
  • twClampToEdge:
  • twClampToBorder:
  • twMirrorRepeat:
  • twMirrorClampToEdge:
  • twMirrorClampToBorder:
TGLTextureCompareMode = (...);
Values
  • tcmNone:
  • tcmCompareRtoTexture:
TGLTextureFilteringQuality = (...);
Values
  • tfIsotropic:
  • tfAnisotropic:
TGLTextureTarget = (...);
Values
  • ttNoShape:
  • ttTexture1D:
  • ttTexture2D:
  • ttTexture3D:
  • ttTexture1DArray:
  • ttTexture2DArray:
  • ttTextureRect:
  • ttTextureBuffer:
  • ttTextureCube:
  • ttTexture2DMultisample:
  • ttTexture2DMultisampleArray:
  • ttTextureCubeArray:
TGLTextureSwizzle = (...);
Values
  • tswRed:
  • tswGreen:
  • tswBlue:
  • tswAlpha:
  • tswZero:
  • tswOne:
TSwizzleVector = array[0..3] of TGLTextureSwizzle;
TGLInternalFormat = (...);
Values
  • tfALPHA4:
  • tfALPHA8:
  • tfALPHA12:
  • tfALPHA16:
  • tfDEPTH_COMPONENT16:
  • tfDEPTH_COMPONENT24:
  • tfDEPTH_COMPONENT32:
  • tfLUMINANCE4:
  • tfLUMINANCE8:
  • tfLUMINANCE12:
  • tfLUMINANCE16:
  • tfLUMINANCE4_ALPHA4:
  • tfLUMINANCE6_ALPHA2:
  • tfLUMINANCE8_ALPHA8:
  • tfLUMINANCE12_ALPHA4:
  • tfLUMINANCE12_ALPHA12:
  • tfLUMINANCE16_ALPHA16:
  • tfINTENSITY4:
  • tfINTENSITY8:
  • tfINTENSITY12:
  • tfINTENSITY16:
  • tfR3_G3_B2:
  • tfRGB4:
  • tfRGB5:
  • tfRGB8:
  • tfRGB10:
  • tfRGB12:
  • tfR16G16B16:
  • tfRGBA2:
  • tfRGBA4:
  • tfRGB5_A1:
  • tfRGBA8:
  • tfRGB10_A2:
  • tfRGBA12:
  • tfR16G16B16A16:
  • tfCOMPRESSED_RGB_S3TC_DXT1:
  • tfCOMPRESSED_RGBA_S3TC_DXT1:
  • tfCOMPRESSED_RGBA_S3TC_DXT3:
  • tfCOMPRESSED_RGBA_S3TC_DXT5:
  • tfSIGNED_LUMINANCE8:
  • tfSIGNED_LUMINANCE8_ALPHA8:
  • tfSIGNED_RGB8:
  • tfSIGNED_RGBA8:
  • tfSIGNED_RGB8_UNSIGNED_ALPHA8:
  • tfSIGNED_ALPHA8:
  • tfSIGNED_INTENSITY8:
  • tfHILO16:
  • tfSIGNED_HILO16:
  • tfDSDT8:
  • tfDSDT8_MAG8:
  • tfDSDT8_MAG8_INTENSITY8:
  • tfHILO8:
  • tfSIGNED_HILO8:
  • tfFLOAT_R16:
  • tfFLOAT_R32:
  • tfFLOAT_RG16:
  • tfFLOAT_RGB16:
  • tfFLOAT_RGBA16:
  • tfFLOAT_RG32:
  • tfFLOAT_RGB32:
  • tfFLOAT_RGBA32:
  • tfRGBA_FLOAT32:
  • tfRGB_FLOAT32:
  • tfALPHA_FLOAT32:
  • tfINTENSITY_FLOAT32:
  • tfLUMINANCE_FLOAT32:
  • tfLUMINANCE_ALPHA_FLOAT32:
  • tfRGBA_FLOAT16:
  • tfRGB_FLOAT16:
  • tfALPHA_FLOAT16:
  • tfINTENSITY_FLOAT16:
  • tfLUMINANCE_FLOAT16:
  • tfLUMINANCE_ALPHA_FLOAT16:
  • tfDEPTH24_STENCIL8:
  • tfDEPTH_COMPONENT32F:
  • tfDEPTH32F_STENCIL8:
  • tfSRGB8:
  • tfSRGB8_ALPHA8:
  • tfSLUMINANCE8:
  • tfSLUMINANCE8_ALPHA8:
  • tfCOMPRESSED_SRGB_S3TC_DXT1:
  • tfCOMPRESSED_SRGB_ALPHA_S3TC_DXT1:
  • tfCOMPRESSED_SRGB_ALPHA_S3TC_DXT3:
  • tfCOMPRESSED_SRGB_ALPHA_S3TC_DXT5:
  • tfRGB9_E5:
  • tfR11F_G11F_B10F:
  • tfCOMPRESSED_LUMINANCE_LATC1:
  • tfCOMPRESSED_SIGNED_LUMINANCE_LATC1:
  • tfCOMPRESSED_LUMINANCE_ALPHA_LATC2:
  • tfCOMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2:
  • tfCOMPRESSED_LUMINANCE_ALPHA_3DC:
  • tfRGBA32UI:
  • tfRGB32UI:
  • tfALPHA32UI:
  • tfINTENSITY32UI:
  • tfLUMINANCE32UI:
  • tfLUMINANCE_ALPHA32UI:
  • tfRGBA16UI:
  • tfRGB16UI:
  • tfALPHA16UI:
  • tfINTENSITY16UI:
  • tfLUMINANCE16UI:
  • tfLUMINANCE_ALPHA16UI:
  • tfRGBA8UI:
  • tfRGB8UI:
  • tfALPHA8UI:
  • tfINTENSITY8UI:
  • tfLUMINANCE8UI:
  • tfLUMINANCE_ALPHA8UI:
  • tfRGBA32I:
  • tfRGB32I:
  • tfALPHA32I:
  • tfINTENSITY32I:
  • tfLUMINANCE32I:
  • tfLUMINANCE_ALPHA32I:
  • tfRGBA16I:
  • tfRGB16I:
  • tfALPHA16I:
  • tfINTENSITY16I:
  • tfLUMINANCE16I:
  • tfLUMINANCE_ALPHA16I:
  • tfRGBA8I:
  • tfRGB8I:
  • tfALPHA8I:
  • tfINTENSITY8I:
  • tfLUMINANCE8I:
  • tfLUMINANCE_ALPHA8I:
  • tfRG32UI:
  • tfR32UI:
  • tfRG16UI:
  • tfR16UI:
  • tfRG8UI:
  • tfR8UI:
  • tfRG32I:
  • tfR32I:
  • tfRG16I:
  • tfR16I:
  • tfRG8I:
  • tfR8I:
  • tfRG8:
  • tfR8:
  • tfRG16:
  • tfR16:
  • tfRG16F:
  • tfR16F:
  • tfRG32F:
  • tfR32F:
  • tfCOMPRESSED_RED_RGTC1:
  • tfCOMPRESSED_SIGNED_RED_RGTC1:
  • tfCOMPRESSED_RG_RGTC2:
  • tfCOMPRESSED_SIGNED_RG_RGTC2:
  • tfR8_SNORM:
  • tfRG8_SNORM:
  • tfRGB8_SNORM:
  • tfRGBA8_SNORM:
  • tfR16_SNORM:
  • tfRG16_SNORM:
  • tfRGB16_SNORM:
  • tfRGBA16_SNORM:
TGLInternalCompression = (...);

Texture compression option.<p> If OpenGL supports it, this will activate a compressed texture format:<ul> <li>tcDefault : uses global default compression option <li>tcNone : do not use compression <li>tcStandard : use standard compression, average quality, average rate <li>tcHighQuality : choose a high-quality, low-speed compression <li>tcHighSpeed : choose a high-speed, low-quality compression </ul>.

Values
  • tcDefault:
  • tcNone:
  • tcStandard:
  • tcHighQuality:
  • tcHighSpeed:

Constants

cDefaultSwizzleVector: TSwizzleVector = (tswRed, tswGreen, tswBlue, tswAlpha);

Variables

vDefaultTextureFormat: TGLInternalFormat = tfRGBA8;
vDefaultTextureCompression: TGLInternalCompression = tcNone;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTextureImageEditors

Unit GLTextureImageEditors

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLTextureImageEditors<p>

Standard texture image editors for standard texture image classes.<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPPB compatibility: used dummy method instead abstract class function Edit for GLS_CPPB <li>22/01/10 - Yar - Added to TGLBlankImage property editor ability to set the depth <li>03/07/04 - LR - Make change for Linux <li>24/07/03 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTextureImageEditor |
Class TGLBlankTIE |
Class TGLPersistentTIE |
Class TGLPicFileTIE |
Class TGLProcTextureNoiseTIE |

Functions and Procedures

function EditGLTextureImage(aTexImage : TGLTextureImage) : Boolean;
procedure RegisterGLTextureImageEditor(aTexImageClass : TGLTextureImageClass; texImageEditor : TGLTextureImageEditorClass);
procedure UnRegisterGLTextureImageEditor(texImageEditor : TGLTextureImageEditorClass);

Types

TGLTextureImageEditorClass = class of TGLTextureImageEditor;

Description

Functions and Procedures

function EditGLTextureImage(aTexImage : TGLTextureImage) : Boolean;

Invokes the editor for the given TGLTextureImage

procedure RegisterGLTextureImageEditor(aTexImageClass : TGLTextureImageClass; texImageEditor : TGLTextureImageEditorClass);
procedure UnRegisterGLTextureImageEditor(texImageEditor : TGLTextureImageEditorClass);

Types

TGLTextureImageEditorClass = class of TGLTextureImageEditor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTextureImageEditors: Class TGLTextureImageEditor

Class TGLTextureImageEditor

Unit

GLTextureImageEditors

Declaration

type TGLTextureImageEditor = class(TObject)

Description

Hierarchy

  • TObject
  • TGLTextureImageEditor

Overview

Methods

Public class function Edit(aTexImage : TGLTextureImage) : Boolean; virtual; abstract;

Description

Methods

Public class function Edit(aTexImage : TGLTextureImage) : Boolean; virtual; abstract;

Request to edit a textureImage.<p> Returns True if changes have been made.<br> This method may be invoked from the IDE or at run-time.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTextureImageEditors: Class TGLBlankTIE

Class TGLBlankTIE

Unit

GLTextureImageEditors

Declaration

type TGLBlankTIE = class(TGLTextureImageEditor)

Description

no description available, TGLTextureImageEditor description follows

Hierarchy

  • TObject
  • TGLTextureImageEditor
  • TGLBlankTIE

Overview

Methods

Public class function Edit(aTexImage : TGLTextureImage) : Boolean; override;

Description

Methods

Public class function Edit(aTexImage : TGLTextureImage) : Boolean; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTextureImageEditors: Class TGLPersistentTIE

Class TGLPersistentTIE

Unit

GLTextureImageEditors

Declaration

type TGLPersistentTIE = class(TGLTextureImageEditor)

Description

no description available, TGLTextureImageEditor description follows

Hierarchy

  • TObject
  • TGLTextureImageEditor
  • TGLPersistentTIE

Overview

Methods

Public class function Edit(aTexImage : TGLTextureImage) : Boolean; override;

Description

Methods

Public class function Edit(aTexImage : TGLTextureImage) : Boolean; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTextureImageEditors: Class TGLPicFileTIE

Class TGLPicFileTIE

Unit

GLTextureImageEditors

Declaration

type TGLPicFileTIE = class(TGLTextureImageEditor)

Description

no description available, TGLTextureImageEditor description follows

Hierarchy

  • TObject
  • TGLTextureImageEditor
  • TGLPicFileTIE

Overview

Methods

Public class function Edit(aTexImage : TGLTextureImage) : Boolean; override;

Description

Methods

Public class function Edit(aTexImage : TGLTextureImage) : Boolean; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTextureImageEditors: Class TGLProcTextureNoiseTIE

Class TGLProcTextureNoiseTIE

Unit

GLTextureImageEditors

Declaration

type TGLProcTextureNoiseTIE = class(TGLTextureImageEditor)

Description

no description available, TGLTextureImageEditor description follows

Hierarchy

  • TObject
  • TGLTextureImageEditor
  • TGLProcTextureNoiseTIE

Overview

Methods

Public class function Edit(aTexImage : TGLTextureImage) : Boolean; override;

Description

Methods

Public class function Edit(aTexImage : TGLTextureImage) : Boolean; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTextureSharingShader

Unit GLTextureSharingShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLTextureSharingShader (originally GlProxMultiMatShader)<p> <p> This shader allows to apply multiple textures, gathering them from existing materials. This allows saving resources, since you can reference the textures of any material in any materialLibrary. Note that actually the component references a Material (not a texture) but it uses that material's texture. The referenced material settings will be ignored, but the texture's settings (like TextureMode, ImageGamma, ImageBrightness) will be used. Instead the local material settings (listed in the collection) will be used. </p>

<b>History : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/08/10 - Yar - Fixed light state changes <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>10/04/08 - DaStr - Added a Delpi 5 interface bug work-around (BugTracker ID = 1938988). TGLTextureSharingShaderMaterial.GetTextureSharingShader() is now more safe <li>24/03/08 - DaStr - Small fixups with setting LibMaterial and for Delphi 5 compatibility (thanks Pascal) <li>21/03/08 - DaStr - Reformated according to VCL standard, made some renamings <li>17/03/08 - mrqzzz - Added IGLMaterialLibrarySupported, moved registration <li>14/03/08 - Pascal - Initial version (contributed to GLScene)

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTextureSharingShaderMaterial |
Class TGLTextureSharingShaderMaterials |
Class TGLTextureSharingShader |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTextureSharingShader: Class TGLTextureSharingShaderMaterial

Class TGLTextureSharingShaderMaterial

Unit

GLTextureSharingShader

Declaration

type TGLTextureSharingShaderMaterial = class(TGLInterfacedCollectionItem, IGLMaterialLibrarySupported)

Description

no description available, TGLInterfacedCollectionItem description follows

TCollectionItem thet inplements IInterface.

Hierarchy

  • TCollectionItem
  • TGLInterfacedCollectionItem
  • TGLTextureSharingShaderMaterial

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName: string; override;
Protected | function GetMaterialLibrary: TGLAbstractMaterialLibrary; virtual;
Protected | function GetTextureSharingShader: TGLTextureSharingShader;
Public | procedure Apply(var rci: TRenderContextInfo);
Public | procedure UnApply(var rci: TRenderContextInfo);
Protected | procedure coordNotifychange(Sender: TObject);
Protected | procedure OtherNotifychange(Sender: TObject);

Properties

Published | property Ambient: TGLColor read FAmbient write SetAmbient;
Published | property BlendingMode: TBlendingMode read FBlendingMode write SetBlendingMode;
Published | property Diffuse: TGLColor read FDiffuse write SetDiffuse;
Published | property Emission: TGLColor read FEmission write SetEmission;
Public | property LibMaterial: TGLLibMaterial read FLibMaterial write SetLibMaterial;
Published | property LibMaterialName: TGLLibMaterialName read FLibMaterialName write SetLibMaterialName;
Published | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property Shininess: TShininess read FShininess write SetShininess;
Published | property Specular: TGLColor read FSpecular write SetSpecular;
Published | property TexOffset: TGLCoordinates2 read FTexOffset write SetTexOffset;
Published | property TexScale: TGLCoordinates2 read FTexScale write SetTexScale;
Public | property TextureMatrix: TMatrix read GetTextureMatrix;
Public | property TextureMatrixIsUnitary: Boolean read GetTextureMatrixIsUnitary;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName: string; override;
Protected function GetMaterialLibrary: TGLAbstractMaterialLibrary; virtual;
Protected function GetTextureSharingShader: TGLTextureSharingShader;
Public procedure Apply(var rci: TRenderContextInfo);
Public procedure UnApply(var rci: TRenderContextInfo);
Protected procedure coordNotifychange(Sender: TObject);
Protected procedure OtherNotifychange(Sender: TObject);

Properties

Published property Ambient: TGLColor read FAmbient write SetAmbient;
Published property BlendingMode: TBlendingMode read FBlendingMode write SetBlendingMode;
Published property Diffuse: TGLColor read FDiffuse write SetDiffuse;
Published property Emission: TGLColor read FEmission write SetEmission;
Public property LibMaterial: TGLLibMaterial read FLibMaterial write SetLibMaterial;
Published property LibMaterialName: TGLLibMaterialName read FLibMaterialName write SetLibMaterialName;
Published property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published property Shininess: TShininess read FShininess write SetShininess;
Published property Specular: TGLColor read FSpecular write SetSpecular;
Published property TexOffset: TGLCoordinates2 read FTexOffset write SetTexOffset;
Published property TexScale: TGLCoordinates2 read FTexScale write SetTexScale;
Public property TextureMatrix: TMatrix read GetTextureMatrix;
Public property TextureMatrixIsUnitary: Boolean read GetTextureMatrixIsUnitary;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTextureSharingShader: Class TGLTextureSharingShaderMaterials

Class TGLTextureSharingShaderMaterials

Unit

GLTextureSharingShader

Declaration

type TGLTextureSharingShaderMaterials = class(TOwnedCollection)

Description

Hierarchy

  • TOwnedCollection
  • TGLTextureSharingShaderMaterials

Overview

Methods

Public | constructor Create(AOwner: TGLTextureSharingShader);
Public | function Add: TGLTextureSharingShaderMaterial;
Protected | function GetItems(const AIndex: Integer): TGLTextureSharingShaderMaterial;
Protected | function GetParent: TGLTextureSharingShader;
Protected | procedure SetItems(const AIndex: Integer; const Value: TGLTextureSharingShaderMaterial);

Properties

Public property Items[const AIndex: Integer]: TGLTextureSharingShaderMaterial read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TGLTextureSharingShader);
Public function Add: TGLTextureSharingShaderMaterial;
Protected function GetItems(const AIndex: Integer): TGLTextureSharingShaderMaterial;
Protected function GetParent: TGLTextureSharingShader;
Protected procedure SetItems(const AIndex: Integer; const Value: TGLTextureSharingShaderMaterial);

Properties

Public property Items[const AIndex: Integer]: TGLTextureSharingShaderMaterial read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTextureSharingShader: Class TGLTextureSharingShader

Class TGLTextureSharingShader

Unit

GLTextureSharingShader

Declaration

type TGLTextureSharingShader = class(TGLShader)

Description

no description available, TGLShader description follows

Generic, abstract shader class.<p> Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities.<br> Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLTextureSharingShader

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AddLibMaterial(const ALibMaterial: TGLLibMaterial): TGLTextureSharingShaderMaterial;
Public | function FindLibMaterial(const ALibMaterial: TGLLibMaterial): TGLTextureSharingShaderMaterial;
Protected | function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected | procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published property Materials: TGLTextureSharingShaderMaterials read FMaterials write SetMaterials;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AddLibMaterial(const ALibMaterial: TGLLibMaterial): TGLTextureSharingShaderMaterial;
Public function FindLibMaterial(const ALibMaterial: TGLLibMaterial): TGLTextureSharingShaderMaterial;
Protected function DoUnApply(var rci: TRenderContextInfo): Boolean; override;
Protected procedure DoApply(var rci: TRenderContextInfo; Sender: TObject); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published property Materials: TGLTextureSharingShaderMaterials read FMaterials write SetMaterials;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLThorFX

Unit GLThorFX

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TThorpoint |
Class TGLThorFXManager |
Class TGLBThorFX |

Functions and Procedures

function GetOrCreateThorFX(obj: TGLBaseSceneObject; const name: String = '') : TGLBThorFX;

Types

PThorpoint = ˆTThorpoint;
PThorpointArray = ˆTThorpointArray;
TThorpointArray = array [0 .. MAXINT shr 6] of TThorpoint;
TCalcPointEvent = procedure(Sender: TObject; PointNo: integer; var x: single; var y: single; var z: single) of object;

Description

Functions and Procedures

function GetOrCreateThorFX(obj: TGLBaseSceneObject; const name: String = '') : TGLBThorFX;

Types

PThorpoint = ˆTThorpoint;
PThorpointArray = ˆTThorpointArray;
TThorpointArray = array [0 .. MAXINT shr 6] of TThorpoint;
TCalcPointEvent = procedure(Sender: TObject; PointNo: integer; var x: single; var y: single; var z: single) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLThorFX: record TThorpoint

record TThorpoint

Unit

GLThorFX

Declaration

type TThorpoint = record

Description

Overview

Fields

Position: TVector;
Size: single;

Description

Fields

Position: TVector;
Size: single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLThorFX: Class TGLThorFXManager

Class TGLThorFXManager

Unit

GLThorFX

Declaration

type TGLThorFXManager = class(TGLCadenceAbleComponent)

Description

no description available, TGLCadenceAbleComponent description follows

A base class describing the "cadenceing" interface.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLThorFXManager

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function StoreGlowSize: boolean;
Protected | function StoreVibrate: boolean;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Protected | procedure CalcFrac(left, right: integer; lh, rh: single; xyz: integer);
Protected | procedure CalcThor;
Protected | procedure DeRegisterAllClients;
Protected | procedure DeRegisterClient(aClient: TGLBThorFX);
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure RegisterClient(aClient: TGLBThorFX);
Protected | procedure SetCadencer(const val: TGLCadencer);
Protected | procedure SetCoreColor(const val: TGLColor);
Protected | procedure SetInnerColor(const val: TGLColor);
Protected | procedure SetMaxpoints(const val: integer);
Protected | procedure SetOuterColor(const val: TGLColor);
Protected | procedure SetTarget(const val: TGLCoordinates);
Protected | procedure ThorInit;

Properties

Published | property Cadencer: TGLCadencer read FCadencer write SetCadencer;
Published | property Core: boolean read FCore write FCore;
Published | property CoreColor: TGLColor read FCoreColor write SetCoreColor;
Published | property Disabled: boolean read FDisabled write FDisabled;
Published | property Glow: boolean read FGlow write FGlow;
Published | property GlowSize: single read FGlowSize write FGlowSize stored StoreGlowSize;
Published | property InnerColor: TGLColor read FInnerColor write SetInnerColor;
Published | property Maxpoints: integer read FMaxpoints write SetMaxpoints default 256;
Published | property OnCalcPoint: TCalcPointEvent read FOnCalcPoint write FOnCalcPoint;
Published | property OuterColor: TGLColor read FOuterColor write SetOuterColor;
Published | property Target: TGLCoordinates read FTarget write SetTarget;
Published | property Vibrate: single read FVibrate write FVibrate stored StoreVibrate;
Published | property Wildness: single read FWildness write FWildness;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function StoreGlowSize: boolean;
Protected function StoreVibrate: boolean;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Protected procedure CalcFrac(left, right: integer; lh, rh: single; xyz: integer);
Protected procedure CalcThor;
Protected procedure DeRegisterAllClients;
Protected procedure DeRegisterClient(aClient: TGLBThorFX);
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure RegisterClient(aClient: TGLBThorFX);
Protected procedure SetCadencer(const val: TGLCadencer);
Protected procedure SetCoreColor(const val: TGLColor);
Protected procedure SetInnerColor(const val: TGLColor);
Protected procedure SetMaxpoints(const val: integer);
Protected procedure SetOuterColor(const val: TGLColor);
Protected procedure SetTarget(const val: TGLCoordinates);
Protected procedure ThorInit;

Properties

Published property Cadencer: TGLCadencer read FCadencer write SetCadencer;
Published property Core: boolean read FCore write FCore;
Published property CoreColor: TGLColor read FCoreColor write SetCoreColor;
Published property Disabled: boolean read FDisabled write FDisabled;
Published property Glow: boolean read FGlow write FGlow;
Published property GlowSize: single read FGlowSize write FGlowSize stored StoreGlowSize;
Published property InnerColor: TGLColor read FInnerColor write SetInnerColor;
Published property Maxpoints: integer read FMaxpoints write SetMaxpoints default 256;
Published property OnCalcPoint: TCalcPointEvent read FOnCalcPoint write FOnCalcPoint;
Published property OuterColor: TGLColor read FOuterColor write SetOuterColor;
Published property Target: TGLCoordinates read FTarget write SetTarget;
Published property Vibrate: single read FVibrate write FVibrate stored StoreVibrate;
Published property Wildness: single read FWildness write FWildness;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLThorFX: Class TGLBThorFX

Class TGLBThorFX

Unit

GLThorFX

Declaration

type TGLBThorFX = class(TGLObjectPostEffect)

Description

no description available, TGLObjectPostEffect description follows

An object effect that gets rendered after owner object's render.<p> The current OpenGL matrices and material are that of the owner object.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem
  • TGLBaseBehaviour
  • TGLObjectEffect
  • TGLObjectPostEffect
  • TGLBThorFX

Overview

Methods

Public | constructor Create(AOwner: TXCollection); override;
Public | destructor Destroy; override;
Public | class function FriendlyDescription: String; override;
Public | class function FriendlyName: String; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Render(var rci: TRenderContextInfo); override;
Protected | procedure Loaded; override;
Protected | procedure ReadFromFiler(reader: TReader); override;
Protected | procedure SetManager(const val: TGLThorFXManager);
Protected | procedure SetTarget(const val: TGLCoordinates);
Protected | procedure WriteToFiler(writer: TWriter); override;

Properties

Published property Manager: TGLThorFXManager read FManager write SetManager;

Description

Methods

Public constructor Create(AOwner: TXCollection); override;
Public destructor Destroy; override;
Public class function FriendlyDescription: String; override;
Public class function FriendlyName: String; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure Render(var rci: TRenderContextInfo); override;
Protected procedure Loaded; override;
Protected procedure ReadFromFiler(reader: TReader); override;
Protected procedure SetManager(const val: TGLThorFXManager);
Protected procedure SetTarget(const val: TGLCoordinates);
Protected procedure WriteToFiler(writer: TWriter); override;

Properties

Published property Manager: TGLThorFXManager read FManager write SetManager;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTilePlane

Unit GLTilePlane

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLTilePlane<p>

Implements a tiled texture plane.<p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>23/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>19/08/05 - Mathx - Made index of materials start from 0 not from 1 (thanks to uhfath) <li>23/03/04 - EG - Added NoZWrite <li>09/01/04 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTiledAreaRow |
Class TGLTiledArea |
Class TGLTilePlane |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTilePlane: Class TGLTiledAreaRow

Class TGLTiledAreaRow

Unit

GLTilePlane

Declaration

type TGLTiledAreaRow = class(TPersistentObject)

Description

Stores row information for a tiled area.<p>

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLTiledAreaRow

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function Empty : Boolean;
Protected | function GetCell(col : Integer) : Integer;
Public | procedure Pack;
Public | procedure ReadFromFiler(reader : TVirtualReader); override;
Public | procedure RemapTiles(remapList : TIntegerList);
Public | procedure WriteToFiler(writer : TVirtualWriter); override;
Protected | procedure SetCell(col, val : Integer);
Protected | procedure SetColMax(const val : Integer);
Protected | procedure SetColMin(const val : Integer);

Properties

Public | property Cell[col : Integer]: Integer read GetCell write SetCell;
Public | property ColMax : Integer read FColMax write SetColMax;
Public | property ColMin : Integer read FColMin write SetColMin;
Public | property Data : TIntegerList read FData;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function Empty : Boolean;
Protected function GetCell(col : Integer) : Integer;
Public procedure Pack;
Public procedure ReadFromFiler(reader : TVirtualReader); override;
Public procedure RemapTiles(remapList : TIntegerList);
Public procedure WriteToFiler(writer : TVirtualWriter); override;
Protected procedure SetCell(col, val : Integer);
Protected procedure SetColMax(const val : Integer);
Protected procedure SetColMin(const val : Integer);

Properties

Public property Cell[col : Integer]: Integer read GetCell write SetCell;
Public property ColMax : Integer read FColMax write SetColMax;
Public property ColMin : Integer read FColMin write SetColMin;
Public property Data : TIntegerList read FData;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTilePlane: Class TGLTiledArea

Class TGLTiledArea

Unit

GLTilePlane

Declaration

type TGLTiledArea = class(TPersistentObject)

Description

Stores tile information in a tiled area.<p> Each tile stores an integer value with zero the default value, assumed as "empty".

Hierarchy

  • TPersistent
  • TPersistentObject
  • TGLTiledArea

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function Empty : Boolean;
Protected | function GetRow(index : Integer) : TGLTiledAreaRow;
Protected | function GetTile(col, row : Integer) : Integer;
Public | procedure Clear;
Public | procedure Pack;
Public | procedure ReadFromFiler(reader : TVirtualReader); override;
Public | procedure RemapTiles(remapList : TIntegerList);
Public | procedure WriteToFiler(writer : TVirtualWriter); override;
Protected | procedure SetRowMax(const val : Integer);
Protected | procedure SetRowMin(const val : Integer);
Protected | procedure SetTile(col, row, val : Integer);

Properties

Public | property Row[index : Integer]: TGLTiledAreaRow read GetRow;
Public | property RowMax : Integer read FRowMax write SetRowMax;
Public | property RowMin : Integer read FRowMin write SetRowMin;
Public | property Tile[col, row : Integer]: Integer read GetTile write SetTile;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function Empty : Boolean;
Protected function GetRow(index : Integer) : TGLTiledAreaRow;
Protected function GetTile(col, row : Integer) : Integer;
Public procedure Clear;
Public procedure Pack;
Public procedure ReadFromFiler(reader : TVirtualReader); override;
Public procedure RemapTiles(remapList : TIntegerList);
Public procedure WriteToFiler(writer : TVirtualWriter); override;
Protected procedure SetRowMax(const val : Integer);
Protected procedure SetRowMin(const val : Integer);
Protected procedure SetTile(col, row, val : Integer);

Properties

Public property Row[index : Integer]: TGLTiledAreaRow read GetRow;
Public property RowMax : Integer read FRowMax write SetRowMax;
Public property RowMin : Integer read FRowMin write SetRowMin;
Public property Tile[col, row : Integer]: Integer read GetTile write SetTile;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTilePlane: Class TGLTilePlane

Class TGLTilePlane

Unit

GLTilePlane

Declaration

type TGLTilePlane = class(TGLImmaterialSceneObject)

Description

A tiled textured plane.<p> This plane object stores and displays texture tiles that composes it, and is optimized to minimize texture switches when rendering.<br> Its bounding dimensions are determined by its painted tile.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLTilePlane

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure BuildList(var rci : TRenderContextInfo); override;
Public | procedure DoRender(var ARci : TRenderContextInfo; ARenderSelf, ARenderChildren : Boolean); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetMaterialLibrary(const val : TGLMaterialLibrary);
Protected | procedure SetNoZWrite(const val : Boolean);
Protected | procedure SetSortByMaterials(const val : Boolean);
Protected | procedure SetTiles(const val : TGLTiledArea);

Properties

Published | property MaterialLibrary : TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Published | property NoZWrite : Boolean read FNoZWrite write SetNoZWrite;
Public | property SortByMaterials : Boolean read FSortByMaterials write SetSortByMaterials;
Public | property Tiles : TGLTiledArea read FTiles write SetTiles;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure BuildList(var rci : TRenderContextInfo); override;
Public procedure DoRender(var ARci : TRenderContextInfo; ARenderSelf, ARenderChildren : Boolean); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetMaterialLibrary(const val : TGLMaterialLibrary);
Protected procedure SetNoZWrite(const val : Boolean);
Protected procedure SetSortByMaterials(const val : Boolean);
Protected procedure SetTiles(const val : TGLTiledArea);

Properties

Published property MaterialLibrary : TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Material library where tiles materials will be stored/retrieved.<p> The lower 16 bits of the tile integer value is understood as being the index of the tile's material in the library (material of index zero is thus unused).

Published property NoZWrite : Boolean read FNoZWrite write SetNoZWrite;

If True the tiles are rendered without writing to the ZBuffer.

Public property SortByMaterials : Boolean read FSortByMaterials write SetSortByMaterials;

Controls the sorting of tiles by material.<p> This property should ideally be left always at its default, True, except for debugging and performance measurement, which is why it's only public and not published.

Public property Tiles : TGLTiledArea read FTiles write SetTiles;

Access to the TiledArea data

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTimeEventsMgr

Unit GLTimeEventsMgr

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLTimeEventsMgr<p> by GliGli

Time based events mannager using the Cadencer<p> can be useful to make animations with GlScene<p>

<b>History : </b><font size=-1><ul> <li>07/01/10 - DaStr - Added TGLTimeEventsMGR.Reset() Fixed code formating <li>25/11/09 - DanB - Changed TTimeEvent.Name from ShortString to String <li>11/10/07 - DaStr - TTimeEvent.SetEnabled now updates StartTime to Cadencers's current time. (Thanks Lukasz Sokol) (BugTracker ID = 1811141) <li>28/03/07 - DaStr - Cosmetic fix for FPC compatibility <li>29/01/07 - DaStr - Moved registration to GLSceneRegister.pas <li>07/02/02 - EG - Added Notification, DoEvent, ElapsedTime and changed Event type

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTimeEventsMGR |
Class TTimeEvents |
Class TTimeEvent |

Types

TTimeEventType = (...);
TTimeEventProc = procedure (event : TTimeEvent) of object;

Description

Types

TTimeEventType = (...);
Values
  • etOneShot:
  • etContinuous:
  • etPeriodic:
TTimeEventProc = procedure (event : TTimeEvent) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTimeEventsMgr: Class TGLTimeEventsMGR

Class TGLTimeEventsMGR

Unit

GLTimeEventsMgr

Declaration

type TGLTimeEventsMGR = class(TGLUpdateAbleComponent)

Description

no description available, TGLUpdateAbleComponent description follows

A base class describing the "update" interface.<p>

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLTimeEventsMGR

Overview

Methods

Public | constructor Create(aOwner : TComponent); override;
Public | destructor Destroy; override;
Public | procedure DoProgress(const progressTime : TProgressTimes); override;
Public | procedure Reset();
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetCadencer(const val : TGLCadencer);
Protected | procedure SetEvents(const val : TTimeEvents);

Properties

Published | property Cadencer : TGLCadencer read FCadencer write SetCadencer;
Published | property Enabled : boolean read FEnabled write FEnabled default True;
Published | property Events : TTimeEvents read FEvents write SetEvents;
Published | property FreeEventOnEnd : boolean read FFreeEventOnEnd write FFreeEventOnEnd default False;

Description

Methods

Public constructor Create(aOwner : TComponent); override;
Public destructor Destroy; override;
Public procedure DoProgress(const progressTime : TProgressTimes); override;
Public procedure Reset();
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetCadencer(const val : TGLCadencer);
Protected procedure SetEvents(const val : TTimeEvents);

Properties

Published property Cadencer : TGLCadencer read FCadencer write SetCadencer;
Published property Enabled : boolean read FEnabled write FEnabled default True;
Published property Events : TTimeEvents read FEvents write SetEvents;
Published property FreeEventOnEnd : boolean read FFreeEventOnEnd write FFreeEventOnEnd default False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTimeEventsMgr: Class TTimeEvents

Class TTimeEvents

Unit

GLTimeEventsMgr

Declaration

type TTimeEvents = class(TCollection)

Description

Hierarchy

  • TCollection
  • TTimeEvents

Overview

Fields

Protected Owner: TComponent;

Methods

Public | constructor Create(AOwner : TComponent);
Public | function Add: TTimeEvent;
Public | function EventByName(name:String): TTimeEvent;
Public | function FindItemID(ID: Integer): TTimeEvent;
Protected | function GetItems(index : Integer) : TTimeEvent;
Protected | function GetOwner: TPersistent; override;
Protected | procedure SetItems(index : Integer; const val : TTimeEvent);

Properties

Public property Items[index : Integer]: TTimeEvent read GetItems write SetItems;

Description

Fields

Protected Owner: TComponent;

Methods

Public constructor Create(AOwner : TComponent);
Public function Add: TTimeEvent;
Public function EventByName(name:String): TTimeEvent;
Public function FindItemID(ID: Integer): TTimeEvent;
Protected function GetItems(index : Integer) : TTimeEvent;
Protected function GetOwner: TPersistent; override;
Protected procedure SetItems(index : Integer; const val : TTimeEvent);

Properties

Public property Items[index : Integer]: TTimeEvent read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTimeEventsMgr: Class TTimeEvent

Class TTimeEvent

Unit

GLTimeEventsMgr

Declaration

type TTimeEvent = class(TCollectionItem)

Description

Hierarchy

  • TCollectionItem
  • TTimeEvent

Overview

Methods

Public | constructor Create(Collection : TCollection); override;
Public | destructor Destroy; override;
Protected | function GetDisplayName : String; override;
Protected | procedure DoEvent(const curTime : Double);
Protected | procedure SetName(val : String);

Properties

Public | property ElapsedTime : Double read FElapsedTime;
Published | property Enabled : Boolean read FEnabled write SetEnabled default True;
Published | property EndTime : Double read FEndTime write FEndTime;
Published | property EventType : TTimeEventType read FEventType write FEventType default etOneShot;
Published | property Name : String read FName write SetName;
Published | property OnEvent : TTimeEventProc read FOnEvent write FOnEvent;
Published | property Period : Double read FPeriod write FPeriod;
Published | property StartTime : Double read FStartTime write FStartTime;
Public | property TickCount : Cardinal read FTickCount;

Description

Methods

Public constructor Create(Collection : TCollection); override;
Public destructor Destroy; override;
Protected function GetDisplayName : String; override;
Protected procedure DoEvent(const curTime : Double);
Protected procedure SetName(val : String);

Properties

Public property ElapsedTime : Double read FElapsedTime;

Elapsed time since the event was activated

Published property Enabled : Boolean read FEnabled write SetEnabled default True;
Published property EndTime : Double read FEndTime write FEndTime;
Published property EventType : TTimeEventType read FEventType write FEventType default etOneShot;
Published property Name : String read FName write SetName;
Published property OnEvent : TTimeEventProc read FOnEvent write FOnEvent;
Published property Period : Double read FPeriod write FPeriod;
Published property StartTime : Double read FStartTime write FStartTime;
Public property TickCount : Cardinal read FTickCount;

Number of times the event was triggered since activation

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTrail

Unit GLTrail

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLTrail<p>

Creates a trail-like mesh. Based on Jason Lanford's demo. <p>

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>03/04/07 - DaStr - Added default values to some properties Added TGLTrail.AntiZFightOffset Subscribed for Notification in TGLTrail.SetTrailObject <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>19/12/06 - DaS - msRight (TMarkStyle) support added <li>09/12/04 - LR - Suppress windows uses <li>12/10/04 - Mrqzzz - Creation (Based on Jason Lanford's demo - june 2003) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTrail |

Types

TMarkStyle = (...);

Constants

cMaxVerts = 2000;

Description

Types

TMarkStyle = (...);
Values
  • msUp:
  • msDirection:
  • msFaceCamera:
  • msRight:

Constants

cMaxVerts = 2000;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:06


GLScene v.1.1.2: GLTrail: Class TGLTrail

Class TGLTrail

Unit

GLTrail

Declaration

type TGLTrail = class(TGlMesh)

Description

no description available, TGlMesh description follows
no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLMesh
  • TGLTrail

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateMark(p1,p2: TVector3f;CurrentTime : Double):boolean; overload;
Public | procedure ClearMarks;
Public | procedure CreateMark(APos,ADir,AUp: TVector3f; AWidth: single;ACurrentTime : Double); overload;
Public | procedure CreateMark(obj: TGlBaseSceneObject; width: single;CurrentTime : Double); overload;
Public | procedure DoProgress(const progressTime : TProgressTimes); override;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published | property Alpha: single read FAlpha write SetAlpha;
Published | property AlphaFade: Boolean read FAlphaFade write SetAlphaFade default True;
Published | property AntiZFightOffset: Single read FAntiZFightOffset write FAntiZFightOffset stored StoreAntiZFightOffset;
Published | property Enabled : boolean read FEnabled write SetEnabled default True;
Published | property MarkStyle : TMarkStyle read FMarkStyle write SetMarkStyle default msFaceCamera;
Published | property MarkWidth : single read FMarkWidth write SetMarkWidth;
Published | property MinDistance: single read FMinDistance write SetMinDistance;
Published | property TimeLimit: single read FTimeLimit write SetTimeLimit;
Published | property TrailObject : TGLBaseSceneObject read FTrailObject write SetTrailObject default nil;
Published | property UVScale: single read FUVScale write SetUVScale;
Published | property VertLimit: integer read FVertLimit write SetVertLimit default 150;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function CreateMark(p1,p2: TVector3f;CurrentTime : Double):boolean; overload;
Public procedure ClearMarks;
Public procedure CreateMark(APos,ADir,AUp: TVector3f; AWidth: single;ACurrentTime : Double); overload;
Public procedure CreateMark(obj: TGlBaseSceneObject; width: single;CurrentTime : Double); overload;
Public procedure DoProgress(const progressTime : TProgressTimes); override;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Properties

Published property Alpha: single read FAlpha write SetAlpha;
Published property AlphaFade: Boolean read FAlphaFade write SetAlphaFade default True;
Published property AntiZFightOffset: Single read FAntiZFightOffset write FAntiZFightOffset stored StoreAntiZFightOffset;

Add a tiny bit of offset to help prevent z-fighting.. Need a better solution here as this will get out of whack on really long trails and is dependant on scene scale.

Published property Enabled : boolean read FEnabled write SetEnabled default True;
Published property MarkStyle : TMarkStyle read FMarkStyle write SetMarkStyle default msFaceCamera;
Published property MarkWidth : single read FMarkWidth write SetMarkWidth;
Published property MinDistance: single read FMinDistance write SetMinDistance;

Don't create mark unless moved at least this distance.

Published property TimeLimit: single read FTimeLimit write SetTimeLimit;
Published property TrailObject : TGLBaseSceneObject read FTrailObject write SetTrailObject default nil;
Published property UVScale: single read FUVScale write SetUVScale;
Published property VertLimit: integer read FVertLimit write SetVertLimit default 150;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTree

Unit GLTree

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLTree<p>

Dynamic tree generation in GLScene<p>

This code was adapted from the nVidia Tree Demo: http://developer.nvidia.com/object/Procedural_Tree.html<p>

History:<ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>13/01/07 - DaStr - Added changes proposed by Tim "Sivael" Kapuœciñski [sivael@gensys.pl] Modified the code to create much more realistic trees - added third branch for every node and modified constants to make the tree look more "alive". Also removed the "fractal effect" that ocurred, when rendering with the older engine - the leaves and branches were much more "in order". Added Center* declarations, CenterBranchConstant, Added AutoRebuild flag. <li>02/08/04 - LR, YHC - BCB corrections: use record instead array <li>14/04/04 - SG - Added AutoCenter property. <li>03/03/04 - SG - Added GetExtents and AxisAlignedDimensionsUnscaled. <li>24/11/03 - SG - Creation. </ul>

Some info: <ul>CenterBranchConstant</ul> - Defines, how big the central branch is. When around 50% it makes a small branch inside the tree, for higher values much more branches and leaves are created, so either use it with low depth, or set it to zero, and have two-branched tree. Default : 0.5 <ul>"AutoRebuild" flag</ul> - Rebuild tree after property change. Default: True

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLTreeLeaves |
Class TGLTreeBranch |
Class TGLTreeBranches |
Class TGLTreeBranchNoise |
Class TGLTree |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTree: Class TGLTreeLeaves

Class TGLTreeLeaves

Unit

GLTree

Declaration

type TGLTreeLeaves = class(TObject)

Description

Hierarchy

  • TObject
  • TGLTreeLeaves

Overview

Methods

Public | constructor Create(AOwner : TGLTree);
Public | destructor Destroy; override;
Public | procedure AddNew(matrix : TMatrix);
Public | procedure BuildList(var rci : TRenderContextInfo);
Public | procedure Clear;

Properties

Public | property Count : Integer read FCount;
Public | property Normals : TAffineVectorList read FNormals;
Public | property Owner : TGLTree read FOwner;
Public | property TexCoords : TAffineVectorList read FTexCoords;
Public | property Vertices : TAffineVectorList read FVertices;

Description

Methods

Public constructor Create(AOwner : TGLTree);
Public destructor Destroy; override;
Public procedure AddNew(matrix : TMatrix);
Public procedure BuildList(var rci : TRenderContextInfo);
Public procedure Clear;

Properties

Public property Count : Integer read FCount;
Public property Normals : TAffineVectorList read FNormals;
Public property Owner : TGLTree read FOwner;
Public property TexCoords : TAffineVectorList read FTexCoords;
Public property Vertices : TAffineVectorList read FVertices;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTree: Class TGLTreeBranch

Class TGLTreeBranch

Unit

GLTree

Declaration

type TGLTreeBranch = class(TObject)

Description

Hierarchy

  • TObject
  • TGLTreeBranch

Overview

Methods

Public | constructor Create(AOwner : TGLTreeBranches; AParent : TGLTreeBranch);
Public | destructor Destroy; override;

Properties

Public | property Center : TGLTreeBranch read FCenter;
Public | property Left : TGLTreeBranch read FLeft;
Public | property Lower : TIntegerList read FLower;
Public | property Matrix : TMatrix read FMatrix;
Public | property Owner : TGLTreeBranches read FOwner;
Public | property Parent : TGLTreeBranch read FParent;
Public | property Right : TGLTreeBranch read FRight;
Public | property Upper : TIntegerList read FUpper;

Description

Methods

Public constructor Create(AOwner : TGLTreeBranches; AParent : TGLTreeBranch);
Public destructor Destroy; override;

Properties

Public property Center : TGLTreeBranch read FCenter;
Public property Left : TGLTreeBranch read FLeft;
Public property Lower : TIntegerList read FLower;
Public property Matrix : TMatrix read FMatrix;
Public property Owner : TGLTreeBranches read FOwner;
Public property Parent : TGLTreeBranch read FParent;
Public property Right : TGLTreeBranch read FRight;
Public property Upper : TIntegerList read FUpper;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTree: Class TGLTreeBranches

Class TGLTreeBranches

Unit

GLTree

Declaration

type TGLTreeBranches = class(TObject)

Description

Hierarchy

  • TObject
  • TGLTreeBranches

Overview

Methods

Public | constructor Create(AOwner : TGLTree);
Public | destructor Destroy; override;
Public | procedure BuildList(var rci : TRenderContextInfo);
Public | procedure Clear;

Properties

Public | property CosList : TSingleList read FCosList;
Public | property Count : Integer read FCount;
Public | property Normals : TAffineVectorList read FNormals;
Public | property Owner : TGLTree read FOwner;
Public | property SinList : TSingleList read FSinList;
Public | property TexCoords : TAffineVectorList read FTexCoords;
Public | property Vertices : TAffineVectorList read FVertices;

Description

Methods

Public constructor Create(AOwner : TGLTree);
Public destructor Destroy; override;
Public procedure BuildList(var rci : TRenderContextInfo);
Public procedure Clear;

Properties

Public property CosList : TSingleList read FCosList;
Public property Count : Integer read FCount;
Public property Normals : TAffineVectorList read FNormals;
Public property Owner : TGLTree read FOwner;
Public property SinList : TSingleList read FSinList;
Public property TexCoords : TAffineVectorList read FTexCoords;
Public property Vertices : TAffineVectorList read FVertices;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTree: Class TGLTreeBranchNoise

Class TGLTreeBranchNoise

Unit

GLTree

Declaration

type TGLTreeBranchNoise = class(TObject)

Description

Hierarchy

  • TObject
  • TGLTreeBranchNoise

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Properties

Public | property BranchNoise : Single read FBranchNoise;
Public | property Center : TGLTreeBranchNoise read GetCenter;
Public | property Left : TGLTreeBranchNoise read GetLeft;
Public | property Right : TGLTreeBranchNoise read GetRight;

Description

Methods

Public constructor Create;
Public destructor Destroy; override;

Properties

Public property BranchNoise : Single read FBranchNoise;
Public property Center : TGLTreeBranchNoise read GetCenter;
Public property Left : TGLTreeBranchNoise read GetLeft;
Public property Right : TGLTreeBranchNoise read GetRight;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTree: Class TGLTree

Class TGLTree

Unit

GLTree

Declaration

type TGLTree = class(TGLImmaterialSceneObject)

Description

no description available, TGLImmaterialSceneObject description follows

Base class for objects that do not have a published "material".<p> Note that the material is available in public properties, but isn't applied automatically before invoking BuildList.<br> Subclassing should be reserved to structural objects and objects that have no material of their own.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLImmaterialSceneObject
  • TGLTree

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled : TVector; override;
Public | procedure BuildList(var rci : TRenderContextInfo); override;
Public | procedure BuildMesh(GLBaseMesh : TGLBaseMesh);
Public | procedure Clear;
Public | procedure DoRender(var ARci : TRenderContextInfo; ARenderSelf, ARenderChildren : Boolean); override;
Public | procedure ForceTotalRebuild;
Public | procedure GetExtents(var min, max : TAffineVector);
Public | procedure LoadFromFile(aFileName : String);
Public | procedure LoadFromStream(aStream : TStream);
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure RebuildTree;
Public | procedure SaveToFile(aFileName : String);
Public | procedure SaveToStream(aStream : TStream);
Public | procedure StructureChanged; override;
Protected | procedure Loaded; override;
Protected | procedure SetAutoCenter(const Value : Boolean);
Protected | procedure SetAutoRebuild(const Value : Boolean);
Protected | procedure SetBranchAngle(const Value : Single);
Protected | procedure SetBranchAngleBias(const Value : Single);
Protected | procedure SetBranchFacets(const Value : Integer);
Protected | procedure SetBranchMaterialName(const Value : TGLLibMaterialName);
Protected | procedure SetBranchNoise(const Value : Single);
Protected | procedure SetBranchRadius(const Value : Single);
Protected | procedure SetBranchSize(const Value : Single);
Protected | procedure SetBranchTwist(const Value : Single);
Protected | procedure SetCenterBranchConstant(const Value : Single);
Protected | procedure SetCentralLeader(const Value : Boolean);
Protected | procedure SetCentralLeaderBias(const Value : Single);
Protected | procedure SetDepth(const Value : Integer);
Protected | procedure SetLeafBackMaterialName(const Value : TGLLibMaterialName);
Protected | procedure SetLeafMaterialName(const Value : TGLLibMaterialName);
Protected | procedure SetLeafSize(const Value : Single);
Protected | procedure SetLeafThreshold(const Value : Single);
Protected | procedure SetMaterialLibrary(const Value : TGLMaterialLibrary);
Protected | procedure SetSeed(const Value : Integer);

Properties

Published | property AutoCenter : Boolean read FAutoCenter write SetAutoCenter;
Published | property AutoRebuild : Boolean read FAutoRebuild write SetAutoRebuild;
Published | property BranchAngle : Single read FBranchAngle write SetBranchAngle;
Published | property BranchAngleBias : Single read FBranchAngleBias write SetBranchAngleBias;
Public | property Branches : TGLTreeBranches read FBranches;
Published | property BranchFacets : Integer read FBranchFacets write SetBranchFacets;
Published | property BranchMaterialName : TGLLibMaterialName read FBranchMaterialName write SetBranchMaterialName;
Published | property BranchNoise : Single read FBranchNoise write SetBranchNoise;
Published | property BranchRadius : Single read FBranchRadius write SetBranchRadius;
Published | property BranchSize : Single read FBranchSize write SetBranchSize;
Published | property BranchTwist : Single read FBranchTwist write SetBranchTwist;
Published | property CenterBranchConstant : Single read FCenterBranchConstant write SetCenterBranchConstant;
Published | property CentralLeader : Boolean read FCentralLeader write SetCentralLeader;
Published | property CentralLeaderBias : Single read FCentralLeaderBias write SetCentralLeaderBias;
Published | property Depth : Integer read FDepth write SetDepth;
Published | property LeafBackMaterialName : TGLLibMaterialName read FLeafBackMaterialName write SetLeafBackMaterialName;
Published | property LeafMaterialName : TGLLibMaterialName read FLeafMaterialName write SetLeafMaterialName;
Published | property LeafSize : Single read FLeafSize write SetLeafSize;
Published | property LeafThreshold : Single read FLeafThreshold write SetLeafThreshold;
Public | property Leaves : TGLTreeLeaves read FLeaves;
Published | property MaterialLibrary : TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public | property Noise : TGLTreeBranchNoise read FNoise;
Published | property Seed : Integer read FSeed write SetSeed;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensionsUnscaled : TVector; override;
Public procedure BuildList(var rci : TRenderContextInfo); override;
Public procedure BuildMesh(GLBaseMesh : TGLBaseMesh);
Public procedure Clear;
Public procedure DoRender(var ARci : TRenderContextInfo; ARenderSelf, ARenderChildren : Boolean); override;
Public procedure ForceTotalRebuild;
Public procedure GetExtents(var min, max : TAffineVector);
Public procedure LoadFromFile(aFileName : String);
Public procedure LoadFromStream(aStream : TStream);
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure RebuildTree;
Public procedure SaveToFile(aFileName : String);
Public procedure SaveToStream(aStream : TStream);
Public procedure StructureChanged; override;
Protected procedure Loaded; override;
Protected procedure SetAutoCenter(const Value : Boolean);
Protected procedure SetAutoRebuild(const Value : Boolean);
Protected procedure SetBranchAngle(const Value : Single);
Protected procedure SetBranchAngleBias(const Value : Single);
Protected procedure SetBranchFacets(const Value : Integer);
Protected procedure SetBranchMaterialName(const Value : TGLLibMaterialName);
Protected procedure SetBranchNoise(const Value : Single);
Protected procedure SetBranchRadius(const Value : Single);
Protected procedure SetBranchSize(const Value : Single);
Protected procedure SetBranchTwist(const Value : Single);
Protected procedure SetCenterBranchConstant(const Value : Single);
Protected procedure SetCentralLeader(const Value : Boolean);
Protected procedure SetCentralLeaderBias(const Value : Single);
Protected procedure SetDepth(const Value : Integer);
Protected procedure SetLeafBackMaterialName(const Value : TGLLibMaterialName);
Protected procedure SetLeafMaterialName(const Value : TGLLibMaterialName);
Protected procedure SetLeafSize(const Value : Single);
Protected procedure SetLeafThreshold(const Value : Single);
Protected procedure SetMaterialLibrary(const Value : TGLMaterialLibrary);
Protected procedure SetSeed(const Value : Integer);

Properties

Published property AutoCenter : Boolean read FAutoCenter write SetAutoCenter;

Automatically center the tree's vertices after building them.

Published property AutoRebuild : Boolean read FAutoRebuild write SetAutoRebuild;

Automatically rebuild the tree after changing the settings

Published property BranchAngle : Single read FBranchAngle write SetBranchAngle;

Effects the balance of the tree.

Published property BranchAngleBias : Single read FBranchAngleBias write SetBranchAngleBias;

Effects the habit of the tree. Values from 0 to 1 refer to Upright to Spreading respectively.

Public property Branches : TGLTreeBranches read FBranches;
Published property BranchFacets : Integer read FBranchFacets write SetBranchFacets;

The number of facets for each branch in the tree.

Published property BranchMaterialName : TGLLibMaterialName read FBranchMaterialName write SetBranchMaterialName;
Published property BranchNoise : Single read FBranchNoise write SetBranchNoise;

Overall branch noise influence. Relates to the 'fullness' of the tree.

Published property BranchRadius : Single read FBranchRadius write SetBranchRadius;

Effects the thickness of the branches.

Published property BranchSize : Single read FBranchSize write SetBranchSize;

Branch length modifier.

Published property BranchTwist : Single read FBranchTwist write SetBranchTwist;

Effects the rotation of each sub branch in recursion.

Published property CenterBranchConstant : Single read FCenterBranchConstant write SetCenterBranchConstant;

Central branch can be thinner(lower values)/thicker(->1) depending on this constant. The effect also depends on the BranchAngle variable.

Published property CentralLeader : Boolean read FCentralLeader write SetCentralLeader;

Does this tree have a central leader?

Published property CentralLeaderBias : Single read FCentralLeaderBias write SetCentralLeaderBias;

Determines how BranchAngle effects the central leader (CentralLeader must = True).

Published property Depth : Integer read FDepth write SetDepth;

The depth of tree branch recursion.

Published property LeafBackMaterialName : TGLLibMaterialName read FLeafBackMaterialName write SetLeafBackMaterialName;
Published property LeafMaterialName : TGLLibMaterialName read FLeafMaterialName write SetLeafMaterialName;
Published property LeafSize : Single read FLeafSize write SetLeafSize;

Leaf size modifier. Leaf size is also influenced by branch recursion scale.

Published property LeafThreshold : Single read FLeafThreshold write SetLeafThreshold;

Determines how thin a branch can get before a leaf is substituted.

Public property Leaves : TGLTreeLeaves read FLeaves;
Published property MaterialLibrary : TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public property Noise : TGLTreeBranchNoise read FNoise;
Published property Seed : Integer read FSeed write SetSeed;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTypes

Unit GLTypes

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLTypes<p> Defines vector types for geometry only aiming to imply compatibility of GLScene for Delphi with C+Builder. Do not include any other units in uses clause <p>

<b>History : </b><font size=-1><ul> <li>12/12/12 - PW - Added TGLVector's and TGLMatrix's types <li>11/11/11 - PW - Creation. Defined TGLPoint, TGLPolygon and TGLPolyhedron types </ul>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TGLBox |
record TGLPoint2D |
record TGLPoint3D |
record TGLVector2D |
record TGLVector3D |
record TGLMatrix2D |
record TGLMatrix3D |
packed record TGLMesh2DVertex |
packed record TGLMesh3DVertex |
record TGLQuaternion3D |

Types

PGLPoint2D = ˆTGLPoint2D;
PGLPoint3D = ˆTGLPoint3D;
TGLPoint2DArray = array of TGLPoint2D;
TGLPoint3DArray = array of TGLPoint3D;
TGLPolygon2D = TGLPoint2DArray;
TGLPolygon3D = TGLPoint3DArray;
TGLPolyhedron = array of TGLPolygon3D;
TGLVector2DType = array [0..1] of Single;
TGLVector3DType = array [0..2] of Single;
TGLMatrix2DType = array[0..3] of TGLVector2D;
TGLMatrix3DType = array[0..3] of TGLVector3D;
TGLMatrix2DArray = array of TGLMatrix2D;
TGLMatrix3DArray = array of TGLMatrix3D;
TGLMesh2D = array of TGLMesh2DVertex;
TGLMesh3D = array of TGLMesh3DVertex;

Constants

ClosedPolygon2D: TGLPoint2D = (X: $FFFF; Y: $FFFF);
ClosedPolygon3D: TGLPoint3D = (X: $FFFF; Y: $FFFF; Z: $FFFF);

Description

Types

PGLPoint2D = ˆTGLPoint2D;
PGLPoint3D = ˆTGLPoint3D;
TGLPoint2DArray = array of TGLPoint2D;
TGLPoint3DArray = array of TGLPoint3D;
TGLPolygon2D = TGLPoint2DArray;
TGLPolygon3D = TGLPoint3DArray;
TGLPolyhedron = array of TGLPolygon3D;
TGLVector2DType = array [0..1] of Single;
TGLVector3DType = array [0..2] of Single;
TGLMatrix2DType = array[0..3] of TGLVector2D;
TGLMatrix3DType = array[0..3] of TGLVector3D;
TGLMatrix2DArray = array of TGLMatrix2D;
TGLMatrix3DArray = array of TGLMatrix3D;
TGLMesh2D = array of TGLMesh2DVertex;
TGLMesh3D = array of TGLMesh3DVertex;

Constants

ClosedPolygon2D: TGLPoint2D = (X: $FFFF; Y: $FFFF);
ClosedPolygon3D: TGLPoint3D = (X: $FFFF; Y: $FFFF; Z: $FFFF);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTypes: record TGLBox

record TGLBox

Unit

GLTypes

Declaration

type TGLBox = record

Description

Overview

Fields

ALeft: Single;
ATop: Single;
ANear: Single;
ARight: Single;
ABottom: Single;
AFar: Single;

Description

Fields

ALeft: Single;
ATop: Single;
ANear: Single;
ARight: Single;
ABottom: Single;
AFar: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTypes: record TGLPoint2D

record TGLPoint2D

Unit

GLTypes

Declaration

type TGLPoint2D = record

Description

Overview

Fields

X: Single;
Y: Single;

Methods

constructor Create(X, Y : Single);
function Add(const APoint2D: TGLPoint2D): TGLPoint2D;
function Distance(const APoint2D : TGLPoint2D) : Single;
function Length: Single;
procedure Offset(const ADeltaX, ADeltaY : Single);
procedure SetPosition(const X, Y : Single);

Description

Fields

X: Single;
Y: Single;

Methods

constructor Create(X, Y : Single);
function Add(const APoint2D: TGLPoint2D): TGLPoint2D;
function Distance(const APoint2D : TGLPoint2D) : Single;
function Length: Single;
procedure Offset(const ADeltaX, ADeltaY : Single);
procedure SetPosition(const X, Y : Single);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTypes: record TGLPoint3D

record TGLPoint3D

Unit

GLTypes

Declaration

type TGLPoint3D = record

Description

Overview

Fields

X: Single;
Y: Single;
Z: Single;

Methods

constructor Create(X, Y, Z: Single);
function Add(const AGLPoint3D: TGLPoint3D): TGLPoint3D;
function Distance(const APoint3D : TGLPoint3D) : Single;
function Length: Single;
procedure Offset(const ADeltaX, ADeltaY, ADeltaZ : Single);
procedure SetPosition(const X, Y, Z : Single);

Description

Fields

X: Single;
Y: Single;
Z: Single;

Methods

constructor Create(X, Y, Z: Single);
function Add(const AGLPoint3D: TGLPoint3D): TGLPoint3D;
function Distance(const APoint3D : TGLPoint3D) : Single;
function Length: Single;
procedure Offset(const ADeltaX, ADeltaY, ADeltaZ : Single);
procedure SetPosition(const X, Y, Z : Single);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTypes: record TGLVector2D

record TGLVector2D

Unit

GLTypes

Declaration

type TGLVector2D = record

Description

Overview

Fields

V: TGLVector2DType;
X: Single;
Y: Single;
W: Single;

Methods

constructor Create(const AX, AY, AW : Single);
function Length: Single;

Description

Fields

V: TGLVector2DType;
X: Single;
Y: Single;
W: Single;

Methods

constructor Create(const AX, AY, AW : Single);
function Length: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTypes: record TGLVector3D

record TGLVector3D

Unit

GLTypes

Declaration

type TGLVector3D = record

Description

Overview

Fields

V: TGLVector3DType;
X: Single;
Y: Single;
Z: Single;
W: Single;

Methods

constructor Create(const AX, AY, AZ, AW : Single);
function Length: Single;

Description

Fields

V: TGLVector3DType;
X: Single;
Y: Single;
Z: Single;
W: Single;

Methods

constructor Create(const AX, AY, AZ, AW : Single);
function Length: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTypes: record TGLMatrix2D

record TGLMatrix2D

Unit

GLTypes

Declaration

type TGLMatrix2D = record

Description

Overview

Fields

M: TGLMatrix2DType;
e11: Single;
e12: Single;
e13: Single;
e21: Single;
e22: Single;
e23: Single;
e31: Single
e32: Single
e33: Single

Description

Fields

M: TGLMatrix2DType;
e11: Single;
e12: Single;
e13: Single;
e21: Single;
e22: Single;
e23: Single;
e31: Single
e32: Single
e33: Single
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTypes: record TGLMatrix3D

record TGLMatrix3D

Unit

GLTypes

Declaration

type TGLMatrix3D = record

Description

Overview

Fields

M: TGLMatrix3DType;
e11: Single;
e12: Single;
e13: Single;
e14: Single;
e21: Single;
e22: Single;
e23: Single;
e24: Single;
e31: Single;
e32: Single;
e33: Single;
e34: Single;
e41: Single
e42: Single
e43: Single
e44: Single

Description

Fields

M: TGLMatrix3DType;
e11: Single;
e12: Single;
e13: Single;
e14: Single;
e21: Single;
e22: Single;
e23: Single;
e24: Single;
e31: Single;
e32: Single;
e33: Single;
e34: Single;
e41: Single
e42: Single
e43: Single
e44: Single
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTypes: packed record TGLMesh2DVertex

packed record TGLMesh2DVertex

Unit

GLTypes

Declaration

type TGLMesh2DVertex = packed record

Description

Overview

Fields

X: Single;
Y: Single;
NX: Single;
NY: Single;
tU: Single;
tV: Single;

Description

Fields

X: Single;
Y: Single;
NX: Single;
NY: Single;
tU: Single;
tV: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTypes: packed record TGLMesh3DVertex

packed record TGLMesh3DVertex

Unit

GLTypes

Declaration

type TGLMesh3DVertex = packed record

Description

Overview

Fields

X: Single;
Y: Single;
Z: Single;
NX: Single;
NY: Single;
NZ: Single;
tU: Single;
tV: Single;

Description

Fields

X: Single;
Y: Single;
Z: Single;
NX: Single;
NY: Single;
NZ: Single;
tU: Single;
tV: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLTypes: record TGLQuaternion3D

record TGLQuaternion3D

Unit

GLTypes

Declaration

type TGLQuaternion3D = record

Description

Overview

Fields

ImPart: TGLVector3D;
RePart: Single;

Description

Fields

ImPart: TGLVector3D;
RePart: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLUserShader

Unit GLUserShader

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLUserShader<p>

A shader that passes control of the DoApply and DoUnApply methods through published events. This component is designed to make it a little easier to implement a customized shader. Be sure to keep the shader balanced by returning the OpenGL state to how you found it.<p>

<b>History : </b><font size=-1><ul> <li>25/02/07 - DaStr - Moved registration to GLSceneRegister.pas <li>05/08/03 - SG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLUserShader |

Types

TOnDoApplyEvent = procedure (Sender : TObject; var rci : TRenderContextInfo) of Object;
TOnDoUnApplyEvent = procedure (Sender : TObject; Pass:Integer; var rci : TRenderContextInfo; var Continue : Boolean) of Object;

Description

Types

TOnDoApplyEvent = procedure (Sender : TObject; var rci : TRenderContextInfo) of Object;
TOnDoUnApplyEvent = procedure (Sender : TObject; Pass:Integer; var rci : TRenderContextInfo; var Continue : Boolean) of Object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLUserShader: Class TGLUserShader

Class TGLUserShader

Unit

GLUserShader

Declaration

type TGLUserShader = class(TGLShader)

Description

no description available, TGLShader description follows

Generic, abstract shader class.<p> Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities.<br> Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLShader
  • TGLUserShader

Overview

Methods

Protected | function DoUnApply(var rci : TRenderContextInfo) : Boolean; override;
Protected | procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;

Properties

Published | property OnDoApply : TOnDoApplyEvent read FOnDoApply write FOnDoApply;
Published | property OnDoUnApply : TOnDoUnApplyEvent read FOnDoUnApply write FOnDoUnApply;
Published | property ShaderStyle;

Description

Methods

Protected function DoUnApply(var rci : TRenderContextInfo) : Boolean; override;
Protected procedure DoApply(var rci : TRenderContextInfo; Sender : TObject); override;

Properties

Published property OnDoApply : TOnDoApplyEvent read FOnDoApply write FOnDoApply;
Published property OnDoUnApply : TOnDoUnApplyEvent read FOnDoUnApply write FOnDoUnApply;
Published property ShaderStyle;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLUtils

Unit GLUtils

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLUtils<p>

Miscellaneous support utilities & classes.<p>

<b>History : </b><font size=-1><ul> <li>02/01/13 - Yar - Added SetGLSceneMediaDir <li>07/01/11 - Yar - Added SaveModelDialog, OpenModelDialog <li>04/03/10 - DanB - Now uses CharInSet <li>27/05/09 - DanB - re-added TryStrToFloat, since it ignores user's locale. <li>24/03/09 - DanB - removed TryStrToFloat (exists in SysUtils or GLCrossPlatform already) changed StrToFloatDef to accept only 1 param + now overloaded <li>24/03/09 - DanB - Moved Dialog utilities here from GLCrossPlatform, because they work on all platforms (with FPC) <li>16/10/08 - UweR - corrected typo in TryStringToColorAdvanced parameter <li>16/10/08 - DanB - renamed Save/LoadStringFromFile to Save/LoadAnsiStringFromFile <li>24/03/08 - DaStr - Removed OpenGL1x dependancy Moved TGLMinFilter and TGLMagFilter from GLUtils.pas to GLGraphics.pas (BugTracker ID = 1923844) <li>25/03/07 - DaStr - Replaced StrUtils with GLCrossPlatform <li>23/03/07 - DaStr - Removed compiler warnings caused by SaveComponentToFile and LoadComponentFromFile <li>22/03/07 - DaStr - Added SaveComponentToFile, LoadComponentFromFile <li>07/02/07 - DaStr - Added StringToColorAdvanced() functions <li>05/09/03 - EG - Creation from GLMisc split </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EGLUtilsException |

Functions and Procedures

procedure WordToIntegerArray(Source: PWordArray; Dest: PIntegerArray; Count: Cardinal);
function RoundUpToPowerOf2(value: Integer): Integer;
function RoundDownToPowerOf2(value: Integer): Integer;
function IsPowerOf2(value: Integer): Boolean;
function ReadCRLFString(aStream: TStream): AnsiString;
procedure WriteCRLFString(aStream: TStream; const aString: AnsiString);
function TryStrToFloat(const strValue: string; var val: Extended): Boolean;
function StrToFloatDef(const strValue: string; defValue: Extended = 0): Extended;
function StringToColorAdvancedSafe(const Str: string; const Default: TColor): TColor;
function TryStringToColorAdvanced(const Str: string; var OutColor: TColor): Boolean;
function StringToColorAdvanced(const Str: string): TColor;
function ParseInteger(var p: PChar): Integer;
function ParseFloat(var p: PChar): Extended;
procedure SaveAnsiStringToFile(const fileName: string; const data: AnsiString);
function LoadAnsiStringFromFile(const fileName: string): AnsiString;
procedure SaveComponentToFile(const Component: TComponent; const FileName: string; const AsText: Boolean = True);
procedure LoadComponentFromFile(const Component: TComponent; const FileName: string; const AsText: Boolean = True);
function SizeOfFile(const fileName: string): Int64;
function GetSqrt255Array: PSqrt255Array;
procedure InformationDlg(const msg: string);
function QuestionDlg(const msg: string): Boolean;
function InputDlg(const aCaption, aPrompt, aDefault: string): string;
function SavePictureDialog(var aFileName: string; const aTitle: string = ''): Boolean;
function OpenPictureDialog(var aFileName: string; const aTitle: string = ''): Boolean;
procedure SetGLSceneMediaDir();

Types

TSqrt255Array = array[0..255] of Byte;
PSqrt255Array = ˆTSqrt255Array;

Description

Functions and Procedures

procedure WordToIntegerArray(Source: PWordArray; Dest: PIntegerArray; Count: Cardinal);

Copies the values of Source to Dest (converting word values to integer values)

function RoundUpToPowerOf2(value: Integer): Integer;

Round ups to the nearest power of two, value must be positive

function RoundDownToPowerOf2(value: Integer): Integer;

Round down to the nearest power of two, value must be strictly positive

function IsPowerOf2(value: Integer): Boolean;

Returns True if value is a true power of two

function ReadCRLFString(aStream: TStream): AnsiString;

Read a CRLF terminated string from a stream.<p> The CRLF is NOT in the returned string.

procedure WriteCRLFString(aStream: TStream; const aString: AnsiString);

Write the string and a CRLF in the stream

function TryStrToFloat(const strValue: string; var val: Extended): Boolean;

Similar to SysUtils.TryStrToFloat, but ignores user's locale

function StrToFloatDef(const strValue: string; defValue: Extended = 0): Extended;

Similar to SysUtils.StrToFloatDef, but ignores user's locale

function StringToColorAdvancedSafe(const Str: string; const Default: TColor): TColor;

Converts a string into color

function TryStringToColorAdvanced(const Str: string; var OutColor: TColor): Boolean;

Converts a string into color

function StringToColorAdvanced(const Str: string): TColor;

Converts a string into color

function ParseInteger(var p: PChar): Integer;

Parses the next integer in the string.<p> Initial non-numeric characters are skipper, p is altered, returns 0 if none found. '+' and '-' are acknowledged.

function ParseFloat(var p: PChar): Extended;

Parses the next integer in the string.<p> Initial non-numeric characters are skipper, p is altered, returns 0 if none found. Both '.' and ',' are accepted as decimal separators.

procedure SaveAnsiStringToFile(const fileName: string; const data: AnsiString);

Saves "data" to "filename".

function LoadAnsiStringFromFile(const fileName: string): AnsiString;

Returns the content of "filename".

procedure SaveComponentToFile(const Component: TComponent; const FileName: string; const AsText: Boolean = True);

Saves component to a file.

procedure LoadComponentFromFile(const Component: TComponent; const FileName: string; const AsText: Boolean = True);

Loads component from a file.

function SizeOfFile(const fileName: string): Int64;

Returns the size of "filename".<p> Returns 0 (zero) is file does not exists.

function GetSqrt255Array: PSqrt255Array;

Returns a pointer to an array containing the results of "255*sqrt(i/255)".

procedure InformationDlg(const msg: string);

Pops up a simple dialog with msg and an Ok button.

function QuestionDlg(const msg: string): Boolean;

Pops up a simple question dialog with msg and yes/no buttons.<p> Returns True if answer was "yes".

function InputDlg(const aCaption, aPrompt, aDefault: string): string;

Posp a simple dialog with a string input.

function SavePictureDialog(var aFileName: string; const aTitle: string = ''): Boolean;

Pops up a simple save picture dialog.

function OpenPictureDialog(var aFileName: string; const aTitle: string = ''): Boolean;

Pops up a simple open picture dialog.

procedure SetGLSceneMediaDir();

Types

TSqrt255Array = array[0..255] of Byte;
PSqrt255Array = ˆTSqrt255Array;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLUtils: Class EGLUtilsException

Class EGLUtilsException

Unit

GLUtils

Declaration

type EGLUtilsException = class(Exception)

Description

Hierarchy

  • Exception
  • EGLUtilsException
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLVectorFileObjects

Unit GLVectorFileObjects

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLVectorFileObjects<p>

Vector File related objects for GLScene<p>

<b>History :</b><font size=-1><ul>

<li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>11/07/12 - YP - Added BarycenterPosition and BarycenterOffset New centering option macRestorePosition <li>02/07/11 - DaStr - Replaced TAABB.Revision with TMeshObject.FExtentCacheRevision <li>30/06/11 - DaStr - TGLBaseMesh.BarycenterAbsolutePosition() now uses caching <li>23/02/11 - Yar - Added extent caching to TMeshObject <li>03/12/10 - Yar - Added mesh visibility checking in TMeshObjectList.ExtractTriangles (thnaks to Sandor Domokos) <li>23/08/10 - Yar - Added OpenGLTokens to uses <li>23/07/10 - Yar - Bugfixed TSkeleton.WriteToFiler (thanks E-Cone) <li>11/06/10 - Yar - Bugfixed binary reading TGLMeshObject for FPC Replace OpenGL1x functions to OpenGLAdapter. Fixes for Linux x64 <li>22/04/10 - Yar - Fixes after GLState revision <li>11/04/10 - Yar - Replaced function InsideList to GLState.InsideList <li>05/03/10 - DanB - More state added to TGLStateCache <li>25/12/09 - DaStr - Separated TGLActor.DoAnimate() from TGLActor.BuildList() <li>16/01/09 - DanB - re-disable VBOs in display list to prevent AV on ATI cards <li>27/11/08 - DanB - fix to TFGVertexIndexList.BuildList <li>05/10/08 - DaStr - Added GLSM format backward compatibility after MeshObject.LightMapTexCoords update (thanks Uwe Raabe) (Bugtracker ID = 2140994) <li>03/10/08 - DanB - Added Delphi 2009 (Unicode) support <li>22/06/08 - DaStr - TMeshObject.LightMapTexCoords converted to TAffineVectorList (thanks Ast) (Bugtracker ID = 2000089) <li>07/06/08 - DaStr - Implemented TBaseMeshObject.Assign(), TMeshObject.Assign() <li>20/05/08 - Mrqzzz - Fixed memory leak in TSkeletonMeshObject.Destroy (thanks Dave Gravel) <li>17/05/08 - DaStr - Added TSkeleton.MorphInvisibleParts (thanks andron13 and Veon (BugtrackerID = 1966020) Added vGLVectorFileObjectsEnableVBOByDefault <li>01/05/08 - DaStr - Implemented TGLBaseMesh.BarycenterAbsolutePosition() Bugfixed TGLBaseMesh.AxisAlignedDimensionsUnscaled() <li>06/04/08 - DaStr - TMeshObjectList.MorphTo() and Lerp() are now virtual <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>16/05/07 - PvD - Applied fixes to skeletonmesh to fix problems with physics engines. (Bugtracker ID = 1719652) <li>15/05/07 - LC - Added workaround for ATI bug in TFGVertexIndexList. (Bugtracker ID = 1719611) <li>13/05/07 - LC - Fixed AV bug in TMeshObject.BufferArrays (Bugtracker ID = 1718033) <li>03/04/07 - LC - Added VBO support for TextureEx (Bugtracker ID = 1693378) <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>25/03/07 - LC - Added VBO support to TFGVertexIndexList, depends on MeshObject owner's UseVBO status <li>25/03/07 - LC - Fixed VBO bug. Bugtracker ID=1687665 <li>16/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>21/02/07 - DaStr - Added TMeshObjectList.BuildTangentSpace, UseVBO Added TGLActor.SetCurrentFrameDirect <li>19/02/07 - LC - Added some VBO support <li>19/10/06 - LC - Fixed bug in TGLActor.SetCurrentFrame. Bugtracker ID=1580511 <li>04/10/06 - PhP - fixed TGLActor.SetCurrentFrame (thanks dikoe) <li>05/12/05 - PhP - fixed TFGIndexTexCoordList.BuildList (thanks fig) <li>10/11/05 - Mathx - Added LastLoadedFilename to TGLBaseMesh (RFE 955083). <li>09/11/05 - Mathx - Added isSwitchingAnimation to TGLActor. <li>05/09/05 - Mathx - Fixed TSkeletonMeshObject read/write filer (thanks to Zapology) <li>04/07/05 - Mathx - Protection against picking mode texture mapping errors <li>27/01/05 - Mathx - BuildOctree can now specify an (optional) TreeDepth. <li>11/01/05 - SG - Another fix for TGLBaseMesh.Assign (dikoe Kenguru) <li>11/01/05 - SG - Fix for TGLBaseMesh.Assign when assigning actors <li>26/11/04 - MRQZZZ - by Uwe Raabe : fixed TBaseMeshObject.BuildNormals <li>26/11/04 - MRQZZZ - Added "Rendered" property to TGLBaseMesh in order to prevent rendering of the GLBaseMesh but allowing the rendering of it's children <li>25/11/04 - SG - Fixed memory leak in TMeshObject (dikoe Kenguru) <li>24/11/04 - MF - Added OctreePointInMesh <li>03/10/04 - MRQZZZ - Fixed memory leak (FAutoScaling.Free) in TGLBaseMesh.Destroy; (thanks Jan Zizka) <li>24/09/04 - SG - Added GetTriangleData/SetTriangleData functions, Added TexCoordsEx, Binormals, Tangents, Added BuildTangentSpace function (experimental). <li>23/07/04 - SG - Added fgmmQuad case for TFGVertexIndexList.TraingleCount (Thanks fig). <li>02/08/04 - LR, YHC - BCB corrections: use record instead array moved TBlendedLerpInfo to top of declaration <li>18/07/04 - LR - Suppress Consts in uses <li>20/06/04 - MRQZZZ - Added AutoScaling property to GLBaseMesh to scale a mesh after loading (like Autocentering) <li>30/03/04 - EG - Added TSkeletonBoneList.BoneCount <li>23/03/04 - SG - External positions added to skeleton blended lerps. AutoUpdate flag added to skeleton collider list. <li>09/03/04 - SG - TFGIndexTexCoordList.BuildList can now use per vertex color <li>29/01/04 - SG - Fix for ApplyCurrentSkeletonFrame with multiple bones per vertex. Mesh reassembles correctly now (tested up to 4 bones per vertex). <li>03/12/03 - SG - Added TSkeletonCollider and TSkeletonColliderList Added Colliders (TSkeletonColliderList) to TSkeleton <li>24/10/03 - SG - Various fixes for multiple bones per vertex <li>21/09/03 - MRQZZZ - Added "aamLoopBackward" to AnimationMode property <li>19/09/03 - EG - "Lighmap" -&gt; "LightMap" <li>01/09/03 - SG - Added skeleton frame conversion methods to convert between Rotations and Quaternions. <li>27/08/03 - SG - Fixed AddWeightedBone for multiple bones per vertex <li>13/08/03 - SG - Added quaternion transforms for skeletal animation <li>12/08/03 - SG - Fixed a tiny bug in TSkeleton.MorphMesh <li>08/07/03 - EG - Fixed puny bug in skeletal normals transformation <li>05/06/03 - SG - Split SMD, MD2, 3DS, PLY, TIN and GTS code into separate units, FileFormats\GLFile???.pas <li>16/05/03 - SG - Fixed OpenGL error caused by glColorMaterial in TMeshObject.BuildList <li>08/05/03 - DanB - added OctreeAABBIntersect (Matheus Degiovani) <li>07/05/03 - SG - Added TGLSMDVectorFile.SaveToFile method and [read,write] capabilities <li>17/04/03 - SG - Added TMeshObjectList.FindMeshByName method <li>01/04/03 - SG - Fixed TGLBaseMesh.Assign <li>13/02/03 - DanB - added AxisAlignedDimensionsUnscaled <li>03/02/03 - EG - Faster PrepareBuildList logic <li>31/01/03 - EG - Added MaterialCache logic <li>30/01/03 - EG - Fixed color array enable/disable (Nelson Chu), Normals extraction and extraction standardization <li>27/01/03 - EG - Assign support, fixed MorphableMeshObjects persistence <li>16/01/03 - EG - Updated multiples Bones per vertex transformation code, now makes use of CVAs <li>14/01/03 - EG - Added DisableOpenGLArrays <li>09/01/03 - EG - Added Clear methods for MeshObjects <li>25/11/02 - EG - Colors and TexCoords lists now disabled if ignoreMaterials is true <li>23/10/02 - EG - Faster .GTS and .PLY imports (parsing) <li>22/10/02 - EG - Added actor options, fixed skeleton normals transform (thx Marcus) <li>21/10/02 - EG - Read support for .GTS (GNU Triangulated Surface library) <li>18/10/02 - EG - FindExtByIndex (Adem) <li>17/10/02 - EG - TGLSTLVectorFile moved to new GLFileSTL unit <li>04/09/02 - EG - Fixed TGLBaseMesh.AxisAlignedDimensions <li>23/08/02 - EG - Added TGLBaseMesh.Visible <li>23/07/02 - EG - TGLBaseMesh.LoadFromStream fix (D. Angilella) <li>13/07/02 - EG - AutoCenter on barycenter <li>22/03/02 - EG - TGLAnimationControler basics now functional <li>13/03/02 - EG - Octree support (experimental) <li>18/02/02 - EG - Fixed persistence of skeletal meshes <li>04/01/02 - EG - Added basic RayCastIntersect implementation <li>17/12/01 - EG - Upgraded TGLActor.Synchronize (smooth transitions support) <li>30/11/01 - EG - Added smooth transitions (based on Mrqzzz code) <li>14/09/01 - EG - Use of vFileStreamClass <li>18/08/01 - EG - Added TriangleCount methods, STL export, PLY import <li>15/08/01 - EG - FaceGroups can now be rendered by material group (activate with RenderingOption "moroGroupByMaterial") <li>14/08/01 - EG - Added TSkeletonBoneList and support for skeleton with multiple root bones, updated SMD loader <li>13/08/01 - EG - Improved/fixed SMD loader <li>12/08/01 - EG - Completely rewritten handles management, Fixed TActorAnimation.Assign, Fixed persistence <li>08/08/01 - EG - Added TGLBaseMesh.AxisAlignedDimensions <li>19/07/01 - EG - AutoCentering is now a property of TGLBaseMesh, 3DS loader no longer auto-centers, Added ExtractTriangles and related methods <li>18/07/01 - EG - VisibilityCulling compatibility changes <li>19/06/01 - EG - StrToFloat outlawed and replaced by StrToFloatDef <li>25/03/01 - EG - Added TGLAnimationControler <li>18/03/01 - EG - Added basic Skeleton structures & SMD importer <li>16/03/01 - EG - Introduced new PersistentClasses <li>15/03/01 - EG - Fix in TActorAnimation.SetEndFrame (thx David Costa) <li>08/03/01 - EG - TGL3DSVectorFile now loads materials for TGLBaseMesh <li>26/02/01 - EG - Added TBaseMeshObject & BuildNormals, MD2 normals auto-builded <li>21/02/01 - EG - Now XOpenGL based (multitexture) <li>15/01/01 - EG - Added Translate methods <li>10/01/01 - EG - Fixed in TGLBaseMesh.DoRender for RenderChildren states <li>08/01/01 - EG - Fixed TGLBaseMesh.BuildList messup of attrib states <li>22/12/00 - EG - Fixed non-interpolated TGLActor animation (was freezing), Fixed TGLBaseMesh.DoRender messup of attrib states <li>18/12/00 - EG - TFGIndexTexCoordList now supports normals (automatically), NormalsOrientation code moved to TGLBaseMesh <li>11/12/00 - EG - Fix for NormalOrientation (3DS importer) <li>06/12/00 - EG - Added PrepareBuildList mechanism <li>08/10/00 - EG - Removed TGLOBJVectorFile, use GLFileOBJ instead <li>13/08/00 - EG - Enhancements for Portal Rendering support, Added utility methods & triangle fans <li>10/08/00 - EG - Added CurrentAnimation, fixed TMeshObject.GetExtents <li>21/07/00 - EG - Vastly improved memory use and mechanisms for MD2/TGLActor <li>19/07/00 - EG - Introduced enhanced mesh structure <li>16/07/00 - EG - Made use of new TDataFile class <li>15/07/00 - EG - FreeForm can now handle 3DS files with multiple textures, Added TGLBaseMesh.GetExtents <li>28/06/00 - EG - Support for "ObjectStyle" <li>23/06/00 - EG - Reversed "t" texture coord for MD2, TActorAnimations can now load/save <li>21/06/00 - EG - Added frame change events to TGLActor, Added TActorAnimations collection <li>19/06/00 - EG - Completed smooth movement interpolation for TGLActor <li>07/06/00 - EG - TVectorFile now longers assumes a TGLFreeForm as Owner, Added generic TVectorFile.LoadFromFile <li>26/05/00 - EG - Removed dependency to GLObjects, TGLFreeForm now may use InterleavedArrays instead of IndexedArrays (better BuildList compatibility) <li>22/04/00 - EG - Fixed Material handlings in TGLFreeForm, inverted CCW/CW convention for 3DS Release3 <li>11/04/00 - EG - Removed unnecessary code in finalization (thanks Uwe) <li>09/02/00 - EG - Creation from split of GLObjects, fixed class registrations and formats unregistration </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TBaseMeshObject |
Class TSkeletonFrame |
Class TSkeletonFrameList |
Class TSkeletonBoneList |
Class TSkeletonRootBoneList |
Class TSkeletonBone |
Class TSkeletonCollider |
Class TSkeletonColliderList |
record TBlendedLerpInfo |
Class TSkeleton |
Class TMeshObject |
Class TMeshObjectList |
Class TMeshMorphTarget |
Class TMeshMorphTargetList |
Class TMorphableMeshObject |
packed record TVertexBoneWeight |
Class TSkeletonMeshObject |
Class TFaceGroup |
Class TFGVertexIndexList |
Class TFGVertexNormalTexIndexList |
Class TFGIndexTexCoordList |
Class TFaceGroups |
Class TVectorFile |
Class TGLGLSMVectorFile |
Class TGLBaseMesh |
Class TGLFreeForm |
Class TActorAnimation |
Class TActorAnimations |
Class TGLBaseAnimationControler |
Class TGLAnimationControler |
Class TGLActor |
Class TVectorFileFormat |
Class TVectorFileFormatsList |
Class EInvalidVectorFile |

Functions and Procedures

function GetVectorFileFormats: TVectorFileFormatsList;
function VectorFileFormatsFilter: string;
function VectorFileFormatsSaveFilter: string;
function VectorFileFormatExtensionByIndex(index: Integer): string;
procedure RegisterVectorFileFormat(const aExtension, aDescription: string; aClass: TVectorFileClass);
procedure UnregisterVectorFileClass(aClass: TVectorFileClass);

Types

TMeshAutoCentering = (...);
TMeshAutoCenterings = set of TMeshAutoCentering;
TMeshObjectMode = (...);
TSkeletonFrameTransform = (...);
TMeshObjectRenderingOption = (...);
TMeshObjectRenderingOptions = set of TMeshObjectRenderingOption;
TVBOBuffer = (...);
TVBOBuffers = set of TVBOBuffer;
TMeshObjectListClass = class of TMeshObjectList;
TVertexBoneWeightArray = array[0..MaxInt div (2*SizeOf(TVertexBoneWeight))] of TVertexBoneWeight;
PVertexBoneWeightArray = ˆTVertexBoneWeightArray;
TVerticesBoneWeights = array[0..MaxInt div (2*SizeOf(PVertexBoneWeightArray))] of PVertexBoneWeightArray;
PVerticesBoneWeights = ˆTVerticesBoneWeights;
TVertexBoneWeightDynArray = array of TVertexBoneWeight;
TFaceGroupMeshMode = (...);
TMeshNormalsOrientation = (...);
TVectorFileClass = class of TVectorFile;
TGLActorOption = (...);
TGLActorOptions = set of TGLActorOption;
TActorAnimationReference = (...);
TActorAnimationName = string;
TActorFrameInterpolation = (...);
TActorAnimationMode = (...);

Constants

cDefaultGLActorOptions = [aoSkeletonNormalizeNormals];

Variables

vGLVectorFileObjectsAllocateMaterials: Boolean = True;
vGLVectorFileObjectsEnableVBOByDefault: Boolean = True;

Description

Functions and Procedures

function GetVectorFileFormats: TVectorFileFormatsList;

Read access to the list of registered vector file formats

function VectorFileFormatsFilter: string;

A file extension filter suitable for dialog's 'Filter' property

function VectorFileFormatsSaveFilter: string;

A file extension filter suitable for a savedialog's 'Filter' property

function VectorFileFormatExtensionByIndex(index: Integer): string;

Returns an extension by its index in the vector files dialogs filter.<p> Use VectorFileFormatsFilter to obtain the filter.

procedure RegisterVectorFileFormat(const aExtension, aDescription: string; aClass: TVectorFileClass);
procedure UnregisterVectorFileClass(aClass: TVectorFileClass);

Types

TMeshAutoCentering = (...);
Values
  • macCenterX:
  • macCenterY:
  • macCenterZ:
  • macUseBarycenter:
  • macRestorePosition:
TMeshAutoCenterings = set of TMeshAutoCentering;
TMeshObjectMode = (...);
Values
  • momTriangles:
  • momTriangleStrip:
  • momFaceGroups:
TSkeletonFrameTransform = (...);
Values
  • sftRotation:
  • sftQuaternion:
TMeshObjectRenderingOption = (...);

Rendering options per TMeshObject.<p> <ul> <li>moroGroupByMaterial : if set, the facegroups will be rendered by material in batchs, this will optimize rendering by reducing material switches, but also implies that facegroups will not be rendered in the order they are in the list. </ul>

Values
  • moroGroupByMaterial:
TMeshObjectRenderingOptions = set of TMeshObjectRenderingOption;
TVBOBuffer = (...);
Values
  • vbVertices:
  • vbNormals:
  • vbColors:
  • vbTexCoords:
  • vbLightMapTexCoords:
  • vbTexCoordsEx:
TVBOBuffers = set of TVBOBuffer;
TMeshObjectListClass = class of TMeshObjectList;
TVertexBoneWeightArray = array[0..MaxInt div (2*SizeOf(TVertexBoneWeight))] of TVertexBoneWeight;
PVertexBoneWeightArray = ˆTVertexBoneWeightArray;
TVerticesBoneWeights = array[0..MaxInt div (2*SizeOf(PVertexBoneWeightArray))] of PVertexBoneWeightArray;
PVerticesBoneWeights = ˆTVerticesBoneWeights;
TVertexBoneWeightDynArray = array of TVertexBoneWeight;
TFaceGroupMeshMode = (...);

Known descriptions for face group mesh modes.<p> - fgmmTriangles : issue all vertices with GL_TRIANGLES.<br> - fgmmTriangleStrip : issue all vertices with GL_TRIANGLE_STRIP.<br> - fgmmFlatTriangles : same as fgmmTriangles, but take advantage of having the same normal for all vertices of a triangle.<br> - fgmmTriangleFan : issue all vertices with GL_TRIANGLE_FAN.<br> - fgmmQuads : issue all vertices with GL_QUADS.

Values
  • fgmmTriangles:
  • fgmmTriangleStrip:
  • fgmmFlatTriangles:
  • fgmmTriangleFan:
  • fgmmQuads:
TMeshNormalsOrientation = (...);

Determines how normals orientation is defined in a mesh.<p> - mnoDefault : uses default orientation<br> - mnoInvert : inverse of default orientation<br> - mnoAutoSolid : autocalculate to make the mesh globally solid<br> - mnoAutoHollow : autocalculate to make the mesh globally hollow<br>

Values
  • mnoDefault:
  • mnoInvert:
TVectorFileClass = class of TVectorFile;
TGLActorOption = (...);

Miscellanious actor options.<p> <ul> <li>aoSkeletonNormalizeNormals : if set the normals of a skeleton-animated mesh will be normalized, this is not required if no normals-based texture coordinates generation occurs, and thus may be unset to improve performance. </ul>

Values
  • aoSkeletonNormalizeNormals:
TGLActorOptions = set of TGLActorOption;
TActorAnimationReference = (...);
Values
  • aarMorph:
  • aarSkeleton:
  • aarNone:
TActorAnimationName = string;
TActorFrameInterpolation = (...);

Actor frame-interpolation mode.<p> - afpNone : no interpolation, display CurrentFrame only<br> - afpLinear : perform linear interpolation between current and next frame

Values
  • afpNone:
  • afpLinear:
TActorAnimationMode = (...);

Defines how an actor plays between its StartFrame and EndFrame.<p> <ul> <li>aamNone : no animation is performed <li>aamPlayOnce : play from current frame to EndFrame, once end frame has been reached, switches to aamNone <li>aamLoop : play from current frame to EndFrame, once end frame has been reached, sets CurrentFrame to StartFrame <li>aamBounceForward : play from current frame to EndFrame, once end frame has been reached, switches to aamBounceBackward <li>aamBounceBackward : play from current frame to StartFrame, once start frame has been reached, switches to aamBounceForward <li>aamExternal : Allows for external animation control </ul>

Values
  • aamNone:
  • aamPlayOnce:
  • aamLoop:
  • aamBounceForward:
  • aamBounceBackward:
  • aamLoopBackward:
  • aamExternal:

Constants

cDefaultGLActorOptions = [aoSkeletonNormalizeNormals];

Variables

vGLVectorFileObjectsAllocateMaterials: Boolean = True;
vGLVectorFileObjectsEnableVBOByDefault: Boolean = True;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:07


GLScene v.1.1.2: GLVectorFileObjects: Class TBaseMeshObject

Class TBaseMeshObject

Unit

GLVectorFileObjects

Declaration

type TBaseMeshObject = class(TPersistentObject)

Description

A base class for mesh objects.<p> The class introduces a set of vertices and normals for the object but does no rendering of its own.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseMeshObject

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function ExtractTriangles(texCoords: TAffineVectorList = nil; normals: TAffineVectorList = nil): TAffineVectorList; dynamic;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildNormals(vertexIndices: TIntegerList; mode: TMeshObjectMode; normalIndices: TIntegerList = nil);
Public | procedure Clear; dynamic;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure Translate(const delta: TAffineVector); dynamic;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure ContributeToBarycenter(var currentSum: TAffineVector; var nb: Integer); dynamic;
Protected | procedure SetNormals(const val: TAffineVectorList);
Protected | procedure SetVertices(const val: TAffineVectorList);

Properties

Public | property Name: string read FName write FName;
Public | property Normals: TAffineVectorList read FNormals write SetNormals;
Public | property Vertices: TAffineVectorList read FVertices write SetVertices;
Public | property Visible: Boolean read FVisible write FVisible;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function ExtractTriangles(texCoords: TAffineVectorList = nil; normals: TAffineVectorList = nil): TAffineVectorList; dynamic;

Extracts all mesh triangles as a triangles list.<p> The resulting list size is a multiple of 3, each group of 3 vertices making up and independant triangle.<br> The returned list can be used independantly from the mesh object (all data is duplicated) and should be freed by caller.<p> If texCoords is specified, per vertex texture coordinates will be placed there, when available.

Public procedure Assign(Source: TPersistent); override;
Public procedure BuildNormals(vertexIndices: TIntegerList; mode: TMeshObjectMode; normalIndices: TIntegerList = nil);

Builds (smoothed) normals for the vertex list.<p> If normalIndices is nil, the method assumes a bijection between vertices and normals sets, and when performed, Normals and Vertices list will have the same number of items (whatever previously was in the Normals list is ignored/removed).<p> If normalIndices is defined, normals will be added to the list and their indices will be added to normalIndices. Already defined normals and indices are preserved.<p> The only valid modes are currently momTriangles and momTriangleStrip (ie. momFaceGroups not supported).

Public procedure Clear; dynamic;

Clears all mesh object data, submeshes, facegroups, etc.

Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure Translate(const delta: TAffineVector); dynamic;

Translates all the vertices by the given delta.

Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure ContributeToBarycenter(var currentSum: TAffineVector; var nb: Integer); dynamic;
Protected procedure SetNormals(const val: TAffineVectorList);
Protected procedure SetVertices(const val: TAffineVectorList);

Properties

Public property Name: string read FName write FName;
Public property Normals: TAffineVectorList read FNormals write SetNormals;
Public property Vertices: TAffineVectorList read FVertices write SetVertices;
Public property Visible: Boolean read FVisible write FVisible;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TSkeletonFrame

Class TSkeletonFrame

Unit

GLVectorFileObjects

Declaration

type TSkeletonFrame = class(TPersistentObject)

Description

Stores position and rotation for skeleton joints.<p> If you directly alter some values, make sure to call FlushLocalMatrixList so that the local matrices will be recalculated (the call to Flush does not recalculate the matrices, but marks the current ones as dirty).

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSkeletonFrame

Overview

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(aOwner: TSkeletonFrameList);
Public | destructor Destroy; override;
Public | function LocalMatrixList: PMatrixArray;
Public | procedure ConvertQuaternionsToRotations(KeepQuaternions: Boolean = True);
Public | procedure ConvertRotationsToQuaternions(KeepRotations: Boolean = True);
Public | procedure FlushLocalMatrixList;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure SetPosition(const val: TAffineVectorList);
Protected | procedure SetQuaternion(const val: TQuaternionList);
Protected | procedure SetRotation(const val: TAffineVectorList);

Properties

Public | property Name: string read FName write FName;
Public | property Owner: TSkeletonFrameList read FOwner;
Public | property Position: TAffineVectorList read FPosition write SetPosition;
Public | property Quaternion: TQuaternionList read FQuaternion write SetQuaternion;
Public | property Rotation: TAffineVectorList read FRotation write SetRotation;
Public | property TransformMode: TSkeletonFrameTransform read FTransformMode write FTransformMode;

Description

Methods

Public constructor Create; override;
Public constructor CreateOwned(aOwner: TSkeletonFrameList);
Public destructor Destroy; override;
Public function LocalMatrixList: PMatrixArray;

Calculate or retrieves an array of local bone matrices.<p> This array is calculated on the first call after creation, and the first call following a FlushLocalMatrixList. Subsequent calls return the same arrays.

Public procedure ConvertQuaternionsToRotations(KeepQuaternions: Boolean = True);

As the name states; Convert Quaternions to Rotations or vice-versa.

Public procedure ConvertRotationsToQuaternions(KeepRotations: Boolean = True);
Public procedure FlushLocalMatrixList;

Flushes (frees) then LocalMatrixList data.<p> Call this function to allow a recalculation of local matrices.

Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure SetPosition(const val: TAffineVectorList);
Protected procedure SetQuaternion(const val: TQuaternionList);
Protected procedure SetRotation(const val: TAffineVectorList);

Properties

Public property Name: string read FName write FName;
Public property Owner: TSkeletonFrameList read FOwner;
Public property Position: TAffineVectorList read FPosition write SetPosition;

Position values for the joints.

Public property Quaternion: TQuaternionList read FQuaternion write SetQuaternion;

Quaternions are an alternative to Euler rotations to build the global matrices for the skeleton bones.

Public property Rotation: TAffineVectorList read FRotation write SetRotation;

Rotation values for the joints.

Public property TransformMode: TSkeletonFrameTransform read FTransformMode write FTransformMode;

TransformMode indicates whether to use Rotation or Quaternion to build the local transform matrices.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TSkeletonFrameList

Class TSkeletonFrameList

Unit

GLVectorFileObjects

Declaration

type TSkeletonFrameList = class(TPersistentObjectList)

Description

A list of TSkeletonFrame objects.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TSkeletonFrameList

Overview

Methods

Public | constructor CreateOwned(AOwner: TPersistent);
Public | destructor Destroy; override;
Protected | function GetSkeletonFrame(Index: Integer): TSkeletonFrame;
Public | procedure Clear; override;
Public | procedure ConvertQuaternionsToRotations( KeepQuaternions: Boolean = True; SetTransformMode: Boolean = True);
Public | procedure ConvertRotationsToQuaternions( KeepRotations: Boolean = True; SetTransformMode: Boolean = True);
Public | procedure ReadFromFiler(reader: TVirtualReader); override;

Properties

Public | property Items[Index: Integer]: TSkeletonFrame read GetSkeletonFrame;
Public | property Owner: TPersistent read FOwner;

Description

Methods

Public constructor CreateOwned(AOwner: TPersistent);
Public destructor Destroy; override;
Protected function GetSkeletonFrame(Index: Integer): TSkeletonFrame;
Public procedure Clear; override;
Public procedure ConvertQuaternionsToRotations( KeepQuaternions: Boolean = True; SetTransformMode: Boolean = True);

As the name states; Convert Quaternions to Rotations or vice-versa.

Public procedure ConvertRotationsToQuaternions( KeepRotations: Boolean = True; SetTransformMode: Boolean = True);
Public procedure ReadFromFiler(reader: TVirtualReader); override;

Properties

Public property Items[Index: Integer]: TSkeletonFrame read GetSkeletonFrame;
Public property Owner: TPersistent read FOwner;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TSkeletonBoneList

Class TSkeletonBoneList

Unit

GLVectorFileObjects

Declaration

type TSkeletonBoneList = class(TPersistentObjectList)

Description

A list of skeleton bones.<p>

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TSkeletonBoneList

Overview

Fields

Protected FGlobalMatrix: TMatrix;

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(aOwner: TSkeleton);
Public | destructor Destroy; override;
Public | function BoneByID(anID: Integer): TSkeletonBone; virtual;
Public | function BoneByName(const aName: string): TSkeletonBone; virtual;
Public | function BoneCount: Integer;
Protected | function GetSkeletonBone(Index: Integer): TSkeletonBone;
Public | procedure BuildList(var mrci: TRenderContextInfo); virtual; abstract;
Public | procedure PrepareGlobalMatrices; virtual;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure AfterObjectCreatedByReader(Sender: TObject); override;

Properties

Public | property Items[Index: Integer]: TSkeletonBone read GetSkeletonBone;
Public | property Skeleton: TSkeleton read FSkeleton;

Description

Fields

Protected FGlobalMatrix: TMatrix;

Methods

Public constructor Create; override;
Public constructor CreateOwned(aOwner: TSkeleton);
Public destructor Destroy; override;
Public function BoneByID(anID: Integer): TSkeletonBone; virtual;

Returns a bone by its BoneID, nil if not found.

Public function BoneByName(const aName: string): TSkeletonBone; virtual;

Returns a bone by its Name, nil if not found.

Public function BoneCount: Integer;

Number of bones (including all children and self).

Protected function GetSkeletonBone(Index: Integer): TSkeletonBone;
Public procedure BuildList(var mrci: TRenderContextInfo); virtual; abstract;

Render skeleton wireframe

Public procedure PrepareGlobalMatrices; virtual;
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure AfterObjectCreatedByReader(Sender: TObject); override;

Properties

Public property Items[Index: Integer]: TSkeletonBone read GetSkeletonBone;
Public property Skeleton: TSkeleton read FSkeleton;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TSkeletonRootBoneList

Class TSkeletonRootBoneList

Unit

GLVectorFileObjects

Declaration

type TSkeletonRootBoneList = class(TSkeletonBoneList)

Description

This list store skeleton root bones exclusively.<p>

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TSkeletonBoneList
  • TSkeletonRootBoneList

Overview

Methods

Public | procedure BuildList(var mrci: TRenderContextInfo); override;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;

Properties

Public property GlobalMatrix: TMatrix read FGlobalMatrix write FGlobalMatrix;

Description

Methods

Public procedure BuildList(var mrci: TRenderContextInfo); override;

Render skeleton wireframe

Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure WriteToFiler(writer: TVirtualWriter); override;

Properties

Public property GlobalMatrix: TMatrix read FGlobalMatrix write FGlobalMatrix;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TSkeletonBone

Class TSkeletonBone

Unit

GLVectorFileObjects

Declaration

type TSkeletonBone = class(TSkeletonBoneList)

Description

A skeleton bone or node and its children.<p> This class is the base item of the bones hierarchy in a skeletal model. The joint values are stored in a TSkeletonFrame, but the calculated bone matrices are stored here.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TSkeletonBoneList
  • TSkeletonBone

Overview

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(aOwner: TSkeletonBoneList);
Public | destructor Destroy; override;
Public | function BoneByID(anID: Integer): TSkeletonBone; override;
Public | function BoneByName(const aName: string): TSkeletonBone; override;
Protected | function GetSkeletonBone(Index: Integer): TSkeletonBone;
Public | procedure BuildList(var mrci: TRenderContextInfo); override;
Public | procedure Clean; override;
Public | procedure PrepareGlobalMatrices; override;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure SetGlobalMatrix(Matrix: TMatrix);
Public | procedure SetGlobalMatrixForRagDoll(RagDollMatrix: TMatrix);
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure SetColor(const val: Cardinal);

Properties

Public | property BoneID: Integer read FBoneID write FBoneID;
Public | property Color: Cardinal read FColor write SetColor;
Public | property GlobalMatrix: TMatrix read FGlobalMatrix;
Public | property Items[Index: Integer]: TSkeletonBone read GetSkeletonBone;
Public | property Name: string read FName write FName;
Public | property Owner: TSkeletonBoneList read FOwner;

Description

Methods

Public constructor Create; override;
Public constructor CreateOwned(aOwner: TSkeletonBoneList);
Public destructor Destroy; override;
Public function BoneByID(anID: Integer): TSkeletonBone; override;

Returns a bone by its BoneID, nil if not found.

Public function BoneByName(const aName: string): TSkeletonBone; override;
Protected function GetSkeletonBone(Index: Integer): TSkeletonBone;
Public procedure BuildList(var mrci: TRenderContextInfo); override;

Render skeleton wireframe

Public procedure Clean; override;

Free all sub bones and reset BoneID and Name.

Public procedure PrepareGlobalMatrices; override;

Calculates the global matrix for the bone and its sub-bone.<p> Call this function directly only the RootBone.

Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure SetGlobalMatrix(Matrix: TMatrix);

Set the bone's matrix. Becareful using this.

Public procedure SetGlobalMatrixForRagDoll(RagDollMatrix: TMatrix);

Set the bone's GlobalMatrix. Used for Ragdoll.

Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure SetColor(const val: Cardinal);

Properties

Public property BoneID: Integer read FBoneID write FBoneID;
Public property Color: Cardinal read FColor write SetColor;
Public property GlobalMatrix: TMatrix read FGlobalMatrix;

Global Matrix for the bone in the current frame.<p> Global matrices must be prepared by invoking PrepareGlobalMatrices on the root bone.

Public property Items[Index: Integer]: TSkeletonBone read GetSkeletonBone;
Public property Name: string read FName write FName;
Public property Owner: TSkeletonBoneList read FOwner;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TSkeletonCollider

Class TSkeletonCollider

Unit

GLVectorFileObjects

Declaration

type TSkeletonCollider = class(TPersistentObject)

Description

A general class storing the base level info required for skeleton based collision methods. This class is meant to be inherited from to create skeleton driven Verlet Constraints, ODE Geoms, etc. Overriden classes should be named as TSCxxxxx.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSkeletonCollider

Overview

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(AOwner: TSkeletonColliderList);
Public | procedure AlignCollider; virtual;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure SetBone(const val: TSkeletonBone);
Protected | procedure SetLocalMatrix(const val: TMatrix);

Properties

Public | property AutoUpdate: Boolean read FAutoUpdate write FAutoUpdate;
Public | property Bone: TSkeletonBone read FBone write SetBone;
Public | property GlobalMatrix: TMatrix read FGlobalMatrix;
Public | property LocalMatrix: TMatrix read FLocalMatrix write SetLocalMatrix;
Public | property Owner: TSkeletonColliderList read FOwner;

Description

Methods

Public constructor Create; override;
Public constructor CreateOwned(AOwner: TSkeletonColliderList);
Public procedure AlignCollider; virtual;

This method is used to align the colliders and their derived objects to their associated skeleton bone. Override to set up descendant class alignment properties.

Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure SetBone(const val: TSkeletonBone);
Protected procedure SetLocalMatrix(const val: TMatrix);

Properties

Public property AutoUpdate: Boolean read FAutoUpdate write FAutoUpdate;
Public property Bone: TSkeletonBone read FBone write SetBone;

The bone that this collider associates with.

Public property GlobalMatrix: TMatrix read FGlobalMatrix;

Global offset and orientation of the collider. This gets set in the AlignCollider method.

Public property LocalMatrix: TMatrix read FLocalMatrix write SetLocalMatrix;

Offset and orientation of the collider in the associated bone's space.

Public property Owner: TSkeletonColliderList read FOwner;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TSkeletonColliderList

Class TSkeletonColliderList

Unit

GLVectorFileObjects

Declaration

type TSkeletonColliderList = class(TPersistentObjectList)

Description

List class for storing TSkeletonCollider objects.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TSkeletonColliderList

Overview

Methods

Public | constructor CreateOwned(AOwner: TPersistent);
Public | destructor Destroy; override;
Protected | function GetSkeletonCollider(index: Integer): TSkeletonCollider;
Public | procedure AlignColliders;
Public | procedure Clear; override;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;

Properties

Public | property Items[Index: Integer]: TSkeletonCollider read GetSkeletonCollider;
Public | property Owner: TPersistent read FOwner;

Description

Methods

Public constructor CreateOwned(AOwner: TPersistent);
Public destructor Destroy; override;
Protected function GetSkeletonCollider(index: Integer): TSkeletonCollider;
Public procedure AlignColliders;

Calls AlignCollider for each collider in the list.

Public procedure Clear; override;
Public procedure ReadFromFiler(reader: TVirtualReader); override;

Properties

Public property Items[Index: Integer]: TSkeletonCollider read GetSkeletonCollider;
Public property Owner: TPersistent read FOwner;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: record TBlendedLerpInfo

record TBlendedLerpInfo

Unit

GLVectorFileObjects

Declaration

type TBlendedLerpInfo = record

Description

Small structure to store a weighted lerp for use in blending.

Overview

Fields

frameIndex1: Integer;
frameIndex2: Integer;
lerpFactor: Single;
weight: Single;
externalPositions: TAffineVectorList;
externalRotations: TAffineVectorList;
externalQuaternions: TQuaternionList;

Description

Fields

frameIndex1: Integer;
frameIndex2: Integer;
lerpFactor: Single;
weight: Single;
externalPositions: TAffineVectorList;
externalRotations: TAffineVectorList;
externalQuaternions: TQuaternionList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TSkeleton

Class TSkeleton

Unit

GLVectorFileObjects

Declaration

type TSkeleton = class(TPersistentObject)

Description

Main skeleton object.<p> This class stores the bones hierarchy and animation frames.<br> It is also responsible for maintaining the "CurrentFrame" and allowing various frame blending operations.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSkeleton

Overview

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(AOwner: TGLBaseMesh);
Public | destructor Destroy; override;
Public | function BoneByID(anID: Integer): TSkeletonBone;
Public | function BoneByName(const aName: string): TSkeletonBone;
Public | function BoneCount: Integer;
Protected | function GetCurrentFrame: TSkeletonFrame;
Public | procedure BlendedLerps(const lerpInfos: array of TBlendedLerpInfo);
Public | procedure Clear;
Public | procedure FlushBoneByIDCache;
Public | procedure Lerp(frameIndex1, frameIndex2: Integer; lerpFactor: Single);
Public | procedure MakeSkeletalRotationDelta(startFrame, endFrame: Integer);
Public | procedure MakeSkeletalTranslationStatic(startFrame, endFrame: Integer);
Public | procedure MorphMesh(normalize: Boolean);
Public | procedure MorphTo(frame: TSkeletonFrame); overload;
Public | procedure MorphTo(frameIndex: Integer); overload;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure StartRagdoll;
Public | procedure StopRagdoll;
Public | procedure Synchronize(reference: TSkeleton);
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure SetColliders(const val: TSkeletonColliderList);
Protected | procedure SetCurrentFrame(val: TSkeletonFrame);
Protected | procedure SetFrames(const val: TSkeletonFrameList);
Protected | procedure SetRootBones(const val: TSkeletonRootBoneList);

Properties

Public | property Colliders: TSkeletonColliderList read FColliders write SetColliders;
Public | property CurrentFrame: TSkeletonFrame read GetCurrentFrame write SetCurrentFrame;
Public | property Frames: TSkeletonFrameList read FFrames write SetFrames;
Public | property MorphInvisibleParts: Boolean read FMorphInvisibleParts write FMorphInvisibleParts;
Public | property Owner: TGLBaseMesh read FOwner;
Public | property RootBones: TSkeletonRootBoneList read FRootBones write SetRootBones;

Description

Methods

Public constructor Create; override;
Public constructor CreateOwned(AOwner: TGLBaseMesh);
Public destructor Destroy; override;
Public function BoneByID(anID: Integer): TSkeletonBone;
Public function BoneByName(const aName: string): TSkeletonBone;
Public function BoneCount: Integer;
Protected function GetCurrentFrame: TSkeletonFrame;
Public procedure BlendedLerps(const lerpInfos: array of TBlendedLerpInfo);
Public procedure Clear;

Release bones and frames info.

Public procedure FlushBoneByIDCache;
Public procedure Lerp(frameIndex1, frameIndex2: Integer; lerpFactor: Single);
Public procedure MakeSkeletalRotationDelta(startFrame, endFrame: Integer);

Removes the absolute rotation component of the skeletal frames.<p> Some formats will store frames with absolute rotation information, if this correct if the animation is the "main" animation.<br> This function removes that absolute information, making the animation frames suitable for blending purposes.

Public procedure MakeSkeletalTranslationStatic(startFrame, endFrame: Integer);

Linearly removes the translation component between skeletal frames.<p> This function will compute the translation of the first bone (index 0) and linearly subtract this translation in all frames between startFrame and endFrame. Its purpose is essentially to remove the 'slide' that exists in some animation formats (f.i. SMD).

Public procedure MorphMesh(normalize: Boolean);

Applies current frame to morph all mesh objects.

Public procedure MorphTo(frame: TSkeletonFrame); overload;
Public procedure MorphTo(frameIndex: Integer); overload;
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure StartRagdoll;

Backup and prepare the BoneMatrixInvertedMeshes to use with ragdolls

Public procedure StopRagdoll;

Restore the BoneMatrixInvertedMeshes to stop the ragdoll

Public procedure Synchronize(reference: TSkeleton);

Copy bone rotations from reference skeleton.

Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure SetColliders(const val: TSkeletonColliderList);
Protected procedure SetCurrentFrame(val: TSkeletonFrame);
Protected procedure SetFrames(const val: TSkeletonFrameList);
Protected procedure SetRootBones(const val: TSkeletonRootBoneList);

Properties

Public property Colliders: TSkeletonColliderList read FColliders write SetColliders;
Public property CurrentFrame: TSkeletonFrame read GetCurrentFrame write SetCurrentFrame;
Public property Frames: TSkeletonFrameList read FFrames write SetFrames;
Public property MorphInvisibleParts: Boolean read FMorphInvisibleParts write FMorphInvisibleParts;

Turning this option off (by default) alows to increase FPS, but may break backwards-compatibility, because some may choose to attach other objects to invisible parts.

Public property Owner: TGLBaseMesh read FOwner;
Public property RootBones: TSkeletonRootBoneList read FRootBones write SetRootBones;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TMeshObject

Class TMeshObject

Unit

GLVectorFileObjects

Declaration

type TMeshObject = class(TBaseMeshObject)

Description

Base mesh class.<p> Introduces base methods and properties for mesh objects.<p> Subclasses are named "TMOxxx".

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseMeshObject
  • TMeshObject

Overview

Methods

Public | constructor Create; override;
Public | constructor CreateOwned(AOwner: TMeshObjectList);
Public | destructor Destroy; override;
Public | function ExtractTriangles(texCoords: TAffineVectorList = nil; normals: TAffineVectorList = nil): TAffineVectorList; override;
Public | function GetBarycenter: TVector;
Public | function PointInObject(const aPoint: TAffineVector): Boolean; virtual;
Public | function TriangleCount: Integer; dynamic;
Protected | function GetBinormals: TVectorList;
Protected | function GetTangents: TVectorList;
Protected | function GetTexCoordsEx(index: Integer): TVectorList;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var mrci: TRenderContextInfo); virtual;
Public | procedure BuildTangentSpace( buildBinormals: Boolean = True; buildTangents: Boolean = True);
Public | procedure Clear; override;
Public | procedure DropMaterialLibraryCache;
Public | procedure GetExtents(out min, max: TAffineVector); overload; virtual;
Public | procedure GetExtents(out aabb: TAABB); overload; virtual;
Public | procedure GetTriangleData(tri: Integer; list: TAffineVectorList; var v0, v1, v2: TAffineVector); overload;
Public | procedure GetTriangleData(tri: Integer; list: TVectorList; var v0, v1, v2: TVector); overload;
Public | procedure Prepare; dynamic;
Public | procedure PrepareBuildList(var mrci: TRenderContextInfo); virtual;
Public | procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure SetTriangleData(tri: Integer; list: TAffineVectorList; const v0, v1, v2: TAffineVector); overload;
Public | procedure SetTriangleData(tri: Integer; list: TVectorList; const v0, v1, v2: TVector); overload;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure BufferArrays;
Protected | procedure DeclareArraysToOpenGL(var mrci: TRenderContextInfo; evenIfAlreadyDeclared: Boolean = False);
Protected | procedure DisableLightMapArray(var mrci: TRenderContextInfo);
Protected | procedure DisableOpenGLArrays(var mrci: TRenderContextInfo);
Protected | procedure EnableLightMapArray(var mrci: TRenderContextInfo);
Protected | procedure SetBinormals(const val: TVectorList);
Protected | procedure SetBinormalsTexCoordIndex(const val: Integer);
Protected | procedure SetColors(const val: TVectorList);
Protected | procedure SetLightmapTexCoords(const val: TAffineVectorList);
Protected | procedure SetTangents(const val: TVectorList);
Protected | procedure SetTangentsTexCoordIndex(const val: Integer);
Protected | procedure SetTexCoords(const val: TAffineVectorList);
Protected | procedure SetTexCoordsEx(index: Integer; const val: TVectorList);

Properties

Public | property Binormals: TVectorList read GetBinormals write SetBinormals;
Public | property BinormalsTexCoordIndex: Integer read FBinormalsTexCoordIndex write SetBinormalsTexCoordIndex;
Public | property Colors: TVectorList read FColors write SetColors;
Public | property FaceGroups: TFaceGroups read FFaceGroups;
Public | property LightMapTexCoords: TAffineVectorList read FLightMapTexCoords write SetLightMapTexCoords;
Public | property Mode: TMeshObjectMode read FMode write FMode;
Public | property Owner: TMeshObjectList read FOwner;
Public | property RenderingOptions: TMeshObjectRenderingOptions read FRenderingOptions write FRenderingOptions;
Public | property Tangents: TVectorList read GetTangents write SetTangents;
Public | property TangentsTexCoordIndex: Integer read FTangentsTexCoordIndex write SetTangentsTexCoordIndex;
Public | property TexCoords: TAffineVectorList read FTexCoords write SetTexCoords;
Public | property TexCoordsEx[index: Integer]: TVectorList read GetTexCoordsEx write SetTexCoordsEx;
Public | property UseVBO: boolean read FUseVBO write SetUseVBO;
Protected | property ValidBuffers: TVBOBuffers read FValidBuffers write SetValidBuffers;

Description

Methods

Public constructor Create; override;
Public constructor CreateOwned(AOwner: TMeshObjectList);

Creates, assigns Owner and adds to list.

Public destructor Destroy; override;
Public function ExtractTriangles(texCoords: TAffineVectorList = nil; normals: TAffineVectorList = nil): TAffineVectorList; override;
Public function GetBarycenter: TVector;

Barycenter from vertices data

Public function PointInObject(const aPoint: TAffineVector): Boolean; virtual;
Public function TriangleCount: Integer; dynamic;

Returns number of triangles in the mesh object.

Protected function GetBinormals: TVectorList;
Protected function GetTangents: TVectorList;
Protected function GetTexCoordsEx(index: Integer): TVectorList;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var mrci: TRenderContextInfo); virtual;

Similar to regular scene object's BuildList method

Public procedure BuildTangentSpace( buildBinormals: Boolean = True; buildTangents: Boolean = True);

Build the tangent space from the mesh object's vertex, normal and texcoord data, filling the binormals and tangents where specified.

Public procedure Clear; override;
Public procedure DropMaterialLibraryCache;
Public procedure GetExtents(out min, max: TAffineVector); overload; virtual;

The extents of the object (min and max coordinates)

Public procedure GetExtents(out aabb: TAABB); overload; virtual;
Public procedure GetTriangleData(tri: Integer; list: TAffineVectorList; var v0, v1, v2: TAffineVector); overload;

Returns the triangle data for a given triangle

Public procedure GetTriangleData(tri: Integer; list: TVectorList; var v0, v1, v2: TVector); overload;
Public procedure Prepare; dynamic;

Precalculate whatever is needed for rendering, called once

Public procedure PrepareBuildList(var mrci: TRenderContextInfo); virtual;

Prepare the texture and materials before rendering.<p> Invoked once, before building the list and NOT while building the list.

Public procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure SetTriangleData(tri: Integer; list: TAffineVectorList; const v0, v1, v2: TAffineVector); overload;

Sets the triangle data of a given triangle

Public procedure SetTriangleData(tri: Integer; list: TVectorList; const v0, v1, v2: TVector); overload;
Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure BufferArrays;
Protected procedure DeclareArraysToOpenGL(var mrci: TRenderContextInfo; evenIfAlreadyDeclared: Boolean = False);
Protected procedure DisableLightMapArray(var mrci: TRenderContextInfo);
Protected procedure DisableOpenGLArrays(var mrci: TRenderContextInfo);
Protected procedure EnableLightMapArray(var mrci: TRenderContextInfo);
Protected procedure SetBinormals(const val: TVectorList);
Protected procedure SetBinormalsTexCoordIndex(const val: Integer);
Protected procedure SetColors(const val: TVectorList);
Protected procedure SetLightmapTexCoords(const val: TAffineVectorList);
Protected procedure SetTangents(const val: TVectorList);
Protected procedure SetTangentsTexCoordIndex(const val: Integer);
Protected procedure SetTexCoords(const val: TAffineVectorList);
Protected procedure SetTexCoordsEx(index: Integer; const val: TVectorList);

Properties

Public property Binormals: TVectorList read GetBinormals write SetBinormals;

A TexCoordsEx list wrapper for binormals usage, returns TexCoordsEx[BinormalsTexCoordIndex].

Public property BinormalsTexCoordIndex: Integer read FBinormalsTexCoordIndex write SetBinormalsTexCoordIndex;

Specify the texcoord extension index for binormals (default = 2)

Public property Colors: TVectorList read FColors write SetColors;
Public property FaceGroups: TFaceGroups read FFaceGroups;
Public property LightMapTexCoords: TAffineVectorList read FLightMapTexCoords write SetLightMapTexCoords;
Public property Mode: TMeshObjectMode read FMode write FMode;
Public property Owner: TMeshObjectList read FOwner;
Public property RenderingOptions: TMeshObjectRenderingOptions read FRenderingOptions write FRenderingOptions;
Public property Tangents: TVectorList read GetTangents write SetTangents;

A TexCoordsEx list wrapper for tangents usage, returns TexCoordsEx[BinormalsTexCoordIndex].

Public property TangentsTexCoordIndex: Integer read FTangentsTexCoordIndex write SetTangentsTexCoordIndex;

Specify the texcoord extension index for tangents (default = 3)

Public property TexCoords: TAffineVectorList read FTexCoords write SetTexCoords;
Public property TexCoordsEx[index: Integer]: TVectorList read GetTexCoordsEx write SetTexCoordsEx;

The TexCoords Extension is a list of vector lists that are used to extend the vertex data applied during rendering.<p>

The lists are applied to the GL_TEXTURE0_ARB + index texture environment. This means that if TexCoordsEx 0 or 1 have data it will override the TexCoords or LightMapTexCoords repectively. Lists are created on demand, meaning that if you request TexCoordsEx[4] it will create the list up to and including 4. The extensions are only applied to the texture environment if they contain data.

Public property UseVBO: boolean read FUseVBO write SetUseVBO;

If set, rendering will use VBO's instead of vertex arrays.

Protected property ValidBuffers: TVBOBuffers read FValidBuffers write SetValidBuffers;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TMeshObjectList

Class TMeshObjectList

Unit

GLVectorFileObjects

Declaration

type TMeshObjectList = class(TPersistentObjectList)

Description

A list of TMeshObject objects.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TMeshObjectList

Overview

Methods

Public | constructor CreateOwned(aOwner: TGLBaseMesh);
Public | destructor Destroy; override;
Public | function ExtractTriangles(texCoords: TAffineVectorList = nil; normals: TAffineVectorList = nil): TAffineVectorList;
Public | function FindMeshByName(MeshName: string): TMeshObject;
Public | function MorphTargetCount: Integer;
Public | function TriangleCount: Integer;
Protected | function GetMeshObject(Index: Integer): TMeshObject;
Public | procedure BuildList(var mrci: TRenderContextInfo); virtual;
Public | procedure BuildTangentSpace( buildBinormals: Boolean = True; buildTangents: Boolean = True);
Public | procedure Clear; override;
Public | procedure DropMaterialLibraryCache;
Public | procedure GetExtents(out min, max: TAffineVector);
Public | procedure Lerp(morphTargetIndex1, morphTargetIndex2: Integer; lerpFactor: Single);
Public | procedure MorphTo(morphTargetIndex: Integer);
Public | procedure Prepare; dynamic;
Public | procedure PrepareBuildList(var mrci: TRenderContextInfo); virtual;
Public | procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure Translate(const delta: TAffineVector);

Properties

Public | property Items[Index: Integer]: TMeshObject read GetMeshObject;
Public | property Owner: TGLBaseMesh read FOwner;
Public | property UseVBO: Boolean read GetUseVBO write SetUseVBO;

Description

Methods

Public constructor CreateOwned(aOwner: TGLBaseMesh);
Public destructor Destroy; override;
Public function ExtractTriangles(texCoords: TAffineVectorList = nil; normals: TAffineVectorList = nil): TAffineVectorList;
Public function FindMeshByName(MeshName: string): TMeshObject;
Public function MorphTargetCount: Integer;
Public function TriangleCount: Integer;

Returns number of triangles in the meshes of the list.

Protected function GetMeshObject(Index: Integer): TMeshObject;
Public procedure BuildList(var mrci: TRenderContextInfo); virtual;

Similar to regular scene object's BuildList method

Public procedure BuildTangentSpace( buildBinormals: Boolean = True; buildTangents: Boolean = True);

Build the tangent space from the mesh object's vertex, normal and texcoord data, filling the binormals and tangents where specified.

Public procedure Clear; override;
Public procedure DropMaterialLibraryCache;
Public procedure GetExtents(out min, max: TAffineVector);
Public procedure Lerp(morphTargetIndex1, morphTargetIndex2: Integer; lerpFactor: Single);
Public procedure MorphTo(morphTargetIndex: Integer);
Public procedure Prepare; dynamic;

Precalculate whatever is needed for rendering, called once

Public procedure PrepareBuildList(var mrci: TRenderContextInfo); virtual;

Prepare the texture and materials before rendering.<p> Invoked once, before building the list and NOT while building the list.

Public procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure Translate(const delta: TAffineVector);

Properties

Public property Items[Index: Integer]: TMeshObject read GetMeshObject;
Public property Owner: TGLBaseMesh read FOwner;
Public property UseVBO: Boolean read GetUseVBO write SetUseVBO;

If set, rendering will use VBO's instead of vertex arrays. Resturns True if all its MeshObjects use VBOs.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TMeshMorphTarget

Class TMeshMorphTarget

Unit

GLVectorFileObjects

Declaration

type TMeshMorphTarget = class(TBaseMeshObject)

Description

A morph target, stores alternate lists of vertices and normals.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseMeshObject
  • TMeshMorphTarget

Overview

Methods

Public | constructor CreateOwned(AOwner: TMeshMorphTargetList);
Public | destructor Destroy; override;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;

Properties

Public property Owner: TMeshMorphTargetList read FOwner;

Description

Methods

Public constructor CreateOwned(AOwner: TMeshMorphTargetList);
Public destructor Destroy; override;
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure WriteToFiler(writer: TVirtualWriter); override;

Properties

Public property Owner: TMeshMorphTargetList read FOwner;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TMeshMorphTargetList

Class TMeshMorphTargetList

Unit

GLVectorFileObjects

Declaration

type TMeshMorphTargetList = class(TPersistentObjectList)

Description

A list of TMeshMorphTarget objects.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TMeshMorphTargetList

Overview

Methods

Public | constructor CreateOwned(AOwner: TPersistent);
Public | destructor Destroy; override;
Protected | function GetMeshMorphTarget(Index: Integer): TMeshMorphTarget;
Public | procedure Clear; override;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure Translate(const delta: TAffineVector);

Properties

Public | property Items[Index: Integer]: TMeshMorphTarget read GetMeshMorphTarget;
Public | property Owner: TPersistent read FOwner;

Description

Methods

Public constructor CreateOwned(AOwner: TPersistent);
Public destructor Destroy; override;
Protected function GetMeshMorphTarget(Index: Integer): TMeshMorphTarget;
Public procedure Clear; override;
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure Translate(const delta: TAffineVector);

Properties

Public property Items[Index: Integer]: TMeshMorphTarget read GetMeshMorphTarget;
Public property Owner: TPersistent read FOwner;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TMorphableMeshObject

Class TMorphableMeshObject

Unit

GLVectorFileObjects

Declaration

type TMorphableMeshObject = class(TMeshObject)

Description

Mesh object with support for morph targets.<p> The morph targets allow to change vertices and normals according to pre- existing "morph targets".

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseMeshObject
  • TMeshObject
  • TMorphableMeshObject

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure Clear; override;
Public | procedure Lerp(morphTargetIndex1, morphTargetIndex2: Integer; lerpFactor: Single); virtual;
Public | procedure MorphTo(morphTargetIndex: Integer); virtual;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure Translate(const delta: TAffineVector); override;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;

Properties

Public property MorphTargets: TMeshMorphTargetList read FMorphTargets;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public procedure Clear; override;
Public procedure Lerp(morphTargetIndex1, morphTargetIndex2: Integer; lerpFactor: Single); virtual;
Public procedure MorphTo(morphTargetIndex: Integer); virtual;
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure Translate(const delta: TAffineVector); override;
Public procedure WriteToFiler(writer: TVirtualWriter); override;

Properties

Public property MorphTargets: TMeshMorphTargetList read FMorphTargets;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: packed record TVertexBoneWeight

packed record TVertexBoneWeight

Unit

GLVectorFileObjects

Declaration

type TVertexBoneWeight = packed record

Description

Overview

Fields

BoneID: Integer;
Weight: Single;

Description

Fields

BoneID: Integer;
Weight: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TSkeletonMeshObject

Class TSkeletonMeshObject

Unit

GLVectorFileObjects

Declaration

type TSkeletonMeshObject = class(TMorphableMeshObject)

Description

A mesh object with vertice bone attachments.<p> The class adds per vertex bone weights to the standard morphable mesh.<br> The TVertexBoneWeight structures are accessed via VerticesBonesWeights, they must be initialized by adjusting the BonesPerVertex and VerticeBoneWeightCount properties, you can also add vertex by vertex by using the AddWeightedBone method.<p> When BonesPerVertex is 1, the weight is ignored (set to 1.0).

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseMeshObject
  • TMeshObject
  • TMorphableMeshObject
  • TSkeletonMeshObject

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function FindOrAdd(const boneIDs: TVertexBoneWeightDynArray; const vertex, normal: TAffineVector): Integer; overload;
Public | function FindOrAdd(boneID: Integer; const vertex, normal: TAffineVector): Integer; overload;
Public | procedure AddWeightedBone(aBoneID: Integer; aWeight: Single);
Public | procedure AddWeightedBones(const boneIDs: TVertexBoneWeightDynArray);
Public | procedure ApplyCurrentSkeletonFrame(normalize: Boolean);
Public | procedure Clear; override;
Public | procedure PrepareBoneMatrixInvertedMeshes;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure ResizeVerticesBonesWeights;
Protected | procedure SetBonesPerVertex(const val: Integer);
Protected | procedure SetVerticeBoneWeightCapacity(const val: Integer);
Protected | procedure SetVerticeBoneWeightCount(const val: Integer);

Properties

Public | property BonesPerVertex: Integer read FBonesPerVertex write SetBonesPerVertex;
Public | property VerticeBoneWeightCapacity: Integer read FVerticeBoneWeightCapacity write SetVerticeBoneWeightCapacity;
Public | property VerticeBoneWeightCount: Integer read FVerticeBoneWeightCount write SetVerticeBoneWeightCount;
Public | property VerticesBonesWeights: PVerticesBoneWeights read FVerticesBonesWeights;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function FindOrAdd(const boneIDs: TVertexBoneWeightDynArray; const vertex, normal: TAffineVector): Integer; overload;
Public function FindOrAdd(boneID: Integer; const vertex, normal: TAffineVector): Integer; overload;
Public procedure AddWeightedBone(aBoneID: Integer; aWeight: Single);
Public procedure AddWeightedBones(const boneIDs: TVertexBoneWeightDynArray);
Public procedure ApplyCurrentSkeletonFrame(normalize: Boolean);
Public procedure Clear; override;
Public procedure PrepareBoneMatrixInvertedMeshes;
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure ResizeVerticesBonesWeights;
Protected procedure SetBonesPerVertex(const val: Integer);
Protected procedure SetVerticeBoneWeightCapacity(const val: Integer);
Protected procedure SetVerticeBoneWeightCount(const val: Integer);

Properties

Public property BonesPerVertex: Integer read FBonesPerVertex write SetBonesPerVertex;
Public property VerticeBoneWeightCapacity: Integer read FVerticeBoneWeightCapacity write SetVerticeBoneWeightCapacity;
Public property VerticeBoneWeightCount: Integer read FVerticeBoneWeightCount write SetVerticeBoneWeightCount;
Public property VerticesBonesWeights: PVerticesBoneWeights read FVerticesBonesWeights;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TFaceGroup

Class TFaceGroup

Unit

GLVectorFileObjects

Declaration

type TFaceGroup = class(TPersistentObject)

Description

Describes a face group of a TMeshObject.<p> Face groups should be understood as "a way to use mesh data to render a part or the whole mesh object".<p> Subclasses implement the actual behaviours, and should have at least one "Add" method, taking in parameters all that is required to describe a single base facegroup element.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TFaceGroup

Overview

Methods

Public | constructor CreateOwned(AOwner: TFaceGroups); virtual;
Public | destructor Destroy; override;
Public | function TriangleCount: Integer; dynamic; abstract;
Public | procedure AddToTriangles(aList: TAffineVectorList; aTexCoords: TAffineVectorList = nil; aNormals: TAffineVectorList = nil); dynamic;
Public | procedure BuildList(var mrci: TRenderContextInfo); virtual; abstract;
Public | procedure DropMaterialLibraryCache;
Public | procedure Prepare; dynamic;
Public | procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure Reverse; dynamic;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure AttachLightmap(lightMap: TGLTexture; var mrci: TRenderContextInfo);
Protected | procedure AttachOrDetachLightmap(var mrci: TRenderContextInfo);

Properties

Public | property LightMapIndex: Integer read FLightMapIndex write FLightMapIndex;
Public | property MaterialCache: TGLLibMaterial read FMaterialCache;
Public | property MaterialName: string read FMaterialName write FMaterialName;
Public | property Owner: TFaceGroups read FOwner write FOwner;

Description

Methods

Public constructor CreateOwned(AOwner: TFaceGroups); virtual;
Public destructor Destroy; override;
Public function TriangleCount: Integer; dynamic; abstract;

Returns number of triangles in the facegroup.

Public procedure AddToTriangles(aList: TAffineVectorList; aTexCoords: TAffineVectorList = nil; aNormals: TAffineVectorList = nil); dynamic;

Add to the list the triangles corresponding to the facegroup.<p> This function is used by TMeshObjects ExtractTriangles to retrieve all the triangles in a mesh.

Public procedure BuildList(var mrci: TRenderContextInfo); virtual; abstract;
Public procedure DropMaterialLibraryCache;
Public procedure Prepare; dynamic;

Precalculate whatever is needed for rendering, called once

Public procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure Reverse; dynamic;

Reverses the rendering order of faces.<p> Default implementation does nothing

Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure AttachLightmap(lightMap: TGLTexture; var mrci: TRenderContextInfo);
Protected procedure AttachOrDetachLightmap(var mrci: TRenderContextInfo);

Properties

Public property LightMapIndex: Integer read FLightMapIndex write FLightMapIndex;

Index of lightmap in the lightmap library.

Public property MaterialCache: TGLLibMaterial read FMaterialCache;
Public property MaterialName: string read FMaterialName write FMaterialName;
Public property Owner: TFaceGroups read FOwner write FOwner;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TFGVertexIndexList

Class TFGVertexIndexList

Unit

GLVectorFileObjects

Declaration

type TFGVertexIndexList = class(TFaceGroup)

Description

A face group based on an indexlist.<p> The index list refers to items in the mesh object (vertices, normals, etc.), that are all considered in sync, the render is obtained issueing the items in the order given by the vertices.<p>

Hierarchy

  • TPersistent
  • TPersistentObject
  • TFaceGroup
  • TFGVertexIndexList

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function GetNormal: TAffineVector;
Public | function TriangleCount: Integer; override;
Public | procedure Add(idx: Integer);
Public | procedure AddToTriangles(aList: TAffineVectorList; aTexCoords: TAffineVectorList = nil; aNormals: TAffineVectorList = nil); override;
Public | procedure BuildList(var mrci: TRenderContextInfo); override;
Public | procedure ConvertToList;
Public | procedure GetExtents(var min, max: TAffineVector);
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure Reverse; override;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure AddToList(source, destination: TAffineVectorList; indices: TIntegerList);
Protected | procedure SetVertexIndices(const val: TIntegerList);

Properties

Public | property Mode: TFaceGroupMeshMode read FMode write FMode;
Public | property VertexIndices: TIntegerList read FVertexIndices write SetVertexIndices;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function GetNormal: TAffineVector;

Return the normal from the 1st three points in the facegroup

Public function TriangleCount: Integer; override;
Public procedure Add(idx: Integer);
Public procedure AddToTriangles(aList: TAffineVectorList; aTexCoords: TAffineVectorList = nil; aNormals: TAffineVectorList = nil); override;
Public procedure BuildList(var mrci: TRenderContextInfo); override;
Public procedure ConvertToList;

If mode is strip or fan, convert the indices to triangle list indices.

Public procedure GetExtents(var min, max: TAffineVector);
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure Reverse; override;
Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure AddToList(source, destination: TAffineVectorList; indices: TIntegerList);
Protected procedure SetVertexIndices(const val: TIntegerList);

Properties

Public property Mode: TFaceGroupMeshMode read FMode write FMode;
Public property VertexIndices: TIntegerList read FVertexIndices write SetVertexIndices;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TFGVertexNormalTexIndexList

Class TFGVertexNormalTexIndexList

Unit

GLVectorFileObjects

Declaration

type TFGVertexNormalTexIndexList = class(TFGVertexIndexList)

Description

Adds normals and texcoords indices.<p> Allows very compact description of a mesh. The Normals ad TexCoords indices are optionnal, if missing (empty), VertexIndices will be used.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TFaceGroup
  • TFGVertexIndexList
  • TFGVertexNormalTexIndexList

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure Add(vertexIdx, normalIdx, texCoordIdx: Integer);
Public | procedure AddToTriangles(aList: TAffineVectorList; aTexCoords: TAffineVectorList = nil; aNormals: TAffineVectorList = nil); override;
Public | procedure BuildList(var mrci: TRenderContextInfo); override;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure SetNormalIndices(const val: TIntegerList);
Protected | procedure SetTexCoordIndices(const val: TIntegerList);

Properties

Public | property NormalIndices: TIntegerList read FNormalIndices write SetNormalIndices;
Public | property TexCoordIndices: TIntegerList read FTexCoordIndices write SetTexCoordIndices;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public procedure Add(vertexIdx, normalIdx, texCoordIdx: Integer);
Public procedure AddToTriangles(aList: TAffineVectorList; aTexCoords: TAffineVectorList = nil; aNormals: TAffineVectorList = nil); override;
Public procedure BuildList(var mrci: TRenderContextInfo); override;
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure SetNormalIndices(const val: TIntegerList);
Protected procedure SetTexCoordIndices(const val: TIntegerList);

Properties

Public property NormalIndices: TIntegerList read FNormalIndices write SetNormalIndices;
Public property TexCoordIndices: TIntegerList read FTexCoordIndices write SetTexCoordIndices;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TFGIndexTexCoordList

Class TFGIndexTexCoordList

Unit

GLVectorFileObjects

Declaration

type TFGIndexTexCoordList = class(TFGVertexIndexList)

Description

Adds per index texture coordinates to its ancestor.<p> Per index texture coordinates allows having different texture coordinates per triangle, depending on the face it is used in.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TFaceGroup
  • TFGVertexIndexList
  • TFGIndexTexCoordList

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure Add(idx: Integer; const texCoord: TAffineVector); overload;
Public | procedure Add(idx: Integer; const s, t: Single); overload;
Public | procedure AddToTriangles(aList: TAffineVectorList; aTexCoords: TAffineVectorList = nil; aNormals: TAffineVectorList = nil); override;
Public | procedure BuildList(var mrci: TRenderContextInfo); override;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure SetTexCoords(const val: TAffineVectorList);

Properties

Public property TexCoords: TAffineVectorList read FTexCoords write SetTexCoords;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public procedure Add(idx: Integer; const texCoord: TAffineVector); overload;
Public procedure Add(idx: Integer; const s, t: Single); overload;
Public procedure AddToTriangles(aList: TAffineVectorList; aTexCoords: TAffineVectorList = nil; aNormals: TAffineVectorList = nil); override;
Public procedure BuildList(var mrci: TRenderContextInfo); override;
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure SetTexCoords(const val: TAffineVectorList);

Properties

Public property TexCoords: TAffineVectorList read FTexCoords write SetTexCoords;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TFaceGroups

Class TFaceGroups

Unit

GLVectorFileObjects

Declaration

type TFaceGroups = class(TPersistentObjectList)

Description

A list of TFaceGroup objects.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TFaceGroups

Overview

Methods

Public | constructor CreateOwned(AOwner: TMeshObject);
Public | destructor Destroy; override;
Public | function MaterialLibrary: TGLMaterialLibrary;
Protected | function GetFaceGroup(Index: Integer): TFaceGroup;
Public | procedure AddToTriangles(aList: TAffineVectorList; aTexCoords: TAffineVectorList = nil; aNormals: TAffineVectorList = nil);
Public | procedure Clear; override;
Public | procedure DropMaterialLibraryCache;
Public | procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure SortByMaterial;

Properties

Public | property Items[Index: Integer]: TFaceGroup read GetFaceGroup;
Public | property Owner: TMeshObject read FOwner;

Description

Methods

Public constructor CreateOwned(AOwner: TMeshObject);
Public destructor Destroy; override;
Public function MaterialLibrary: TGLMaterialLibrary;

Material Library of the owner TGLBaseMesh.

Protected function GetFaceGroup(Index: Integer): TFaceGroup;
Public procedure AddToTriangles(aList: TAffineVectorList; aTexCoords: TAffineVectorList = nil; aNormals: TAffineVectorList = nil);
Public procedure Clear; override;
Public procedure DropMaterialLibraryCache;
Public procedure PrepareMaterialLibraryCache(matLib: TGLMaterialLibrary);
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure SortByMaterial;

Sort faces by material.<p> Those without material first in list, followed by opaque materials, then transparent materials.

Properties

Public property Items[Index: Integer]: TFaceGroup read GetFaceGroup;
Public property Owner: TMeshObject read FOwner;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TVectorFile

Class TVectorFile

Unit

GLVectorFileObjects

Declaration

type TVectorFile = class(TDataFile)

Description

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile

Overview

Methods

Public | constructor Create(AOwner: TPersistent); override;
Public | function Owner: TGLBaseMesh;
Protected | procedure SetNormalsOrientation(const val: TMeshNormalsOrientation); virtual;

Properties

Public property NormalsOrientation: TMeshNormalsOrientation read FNormalsOrientation write SetNormalsOrientation;

Description

Methods

Public constructor Create(AOwner: TPersistent); override;
Public function Owner: TGLBaseMesh;
Protected procedure SetNormalsOrientation(const val: TMeshNormalsOrientation); virtual;

Properties

Public property NormalsOrientation: TMeshNormalsOrientation read FNormalsOrientation write SetNormalsOrientation;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TGLGLSMVectorFile

Class TGLGLSMVectorFile

Unit

GLVectorFileObjects

Declaration

type TGLGLSMVectorFile = class(TVectorFile)

Description

GLSM (GLScene Mesh) vector file.<p> This corresponds to the 'native' GLScene format, and object persistence stream, which should be the 'fastest' of all formats to load, and supports all of GLScene features.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TGLUpdateAbleObject
  • TDataFile
  • TVectorFile
  • TGLGLSMVectorFile

Overview

Methods

Public | class function Capabilities: TDataFileCapabilities; override;
Public | procedure LoadFromStream(aStream: TStream); override;
Public | procedure SaveToStream(aStream: TStream); override;

Description

Methods

Public class function Capabilities: TDataFileCapabilities; override;
Public procedure LoadFromStream(aStream: TStream); override;
Public procedure SaveToStream(aStream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:08


GLScene v.1.1.2: GLVectorFileObjects: Class TGLBaseMesh

Class TGLBaseMesh

Unit

GLVectorFileObjects

Declaration

type TGLBaseMesh = class(TGLSceneObject)

Description

Base class for mesh objects.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh

Overview

Fields

Protected | FMeshObjects: TMeshObjectList;
Protected | FSkeleton: TSkeleton;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled: TVector; override;
Public | function BarycenterAbsolutePosition: TVector; override;
Public | function BarycenterOffset: TVector;
Public | function BarycenterPosition: TVector;
Public | function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;
Public | function GetBarycenter: TAffineVector;
Public | function LastLoadedFilename: string;
Public | function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; override;
Public | procedure AddDataFromFile(const filename: string); dynamic;
Public | procedure AddDataFromStream(const filename: string; aStream: TStream); dynamic;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure BuildSilhouetteConnectivityData;
Public | procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure GetExtents(out min, max: TAffineVector);
Public | procedure LoadFromFile(const filename: string); dynamic;
Public | procedure LoadFromStream(const filename: string; aStream: TStream); dynamic;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure PerformAutoCentering; dynamic;
Public | procedure PerformAutoScaling; dynamic;
Public | procedure SaveToFile(const fileName: string); dynamic;
Public | procedure SaveToStream(const fileName: string; aStream: TStream); dynamic;
Public | procedure StructureChanged; override;
Public | procedure StructureChangedNoPrepare;
Protected | procedure DestroyHandle; override;
Protected | procedure DropMaterialLibraryCache;
Protected | procedure PrepareBuildList(var mrci: TRenderContextInfo); dynamic;
Protected | procedure PrepareMaterialLibraryCache;
Protected | procedure PrepareMesh; dynamic;
Protected | procedure PrepareVectorFile(aFile: TVectorFile); dynamic;
Protected | procedure SetAutoScaling(const Value: TGLCoordinates);
Protected | procedure SetLightmapLibrary(const val: TGLMaterialLibrary);
Protected | procedure SetMaterialLibrary(const val: TGLMaterialLibrary);
Protected | procedure SetNormalsOrientation(const val: TMeshNormalsOrientation);
Protected | procedure SetOverlaySkeleton(const val: Boolean);
Protected | procedure SetUseMeshMaterials(const val: Boolean);

Properties

Public | property AutoCentering: TMeshAutoCenterings read FAutoCentering write FAutoCentering default [];
Public | property AutoScaling: TGLCoordinates read FAutoScaling write FAutoScaling;
Public | property IgnoreMissingTextures: Boolean read FIgnoreMissingTextures write FIgnoreMissingTextures default False;
Public | property LightmapLibrary: TGLMaterialLibrary read FLightmapLibrary write SetLightmapLibrary;
Public | property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;
Public | property MeshObjects: TMeshObjectList read FMeshObjects;
Public | property NormalsOrientation: TMeshNormalsOrientation read FNormalsOrientation write SetNormalsOrientation default mnoDefault;
Public | property OverlaySkeleton: Boolean read FOverlaySkeleton write SetOverlaySkeleton default False;
Public | property Skeleton: TSkeleton read FSkeleton;
Public | property UseMeshMaterials: Boolean read FUseMeshMaterials write SetUseMeshMaterials default True;

Description

Fields

Protected FMeshObjects: TMeshObjectList;
Protected FSkeleton: TSkeleton;

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensionsUnscaled: TVector; override;
Public function BarycenterAbsolutePosition: TVector; override;
Public function BarycenterOffset: TVector;
Public function BarycenterPosition: TVector;
Public function GenerateSilhouette(const silhouetteParameters: TGLSilhouetteParameters): TGLSilhouette; override;
Public function GetBarycenter: TAffineVector;

Computes the barycenter of the mesh.<p>

Public function LastLoadedFilename: string;

Returns the filename of the last loaded file, or a blank string if not file was loaded (or if the mesh was dinamically built). This does not take into account the data added to the mesh (through AddDataFromFile) or saved files.

Public function RayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean; override;

BEWARE! Utterly inefficient implementation!

Public procedure AddDataFromFile(const filename: string); dynamic;

Loads additionnal data from a file.<p> Additionnal data could be more animation frames or morph target.<br> The VectorFile importer must be able to handle addition of data flawlessly.

Public procedure AddDataFromStream(const filename: string; aStream: TStream); dynamic;

Loads additionnal data from stream.<p> See AddDataFromFile.

Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure BuildSilhouetteConnectivityData;

This method allows fast shadow volumes for GLActors.<p> If your actor/mesh doesn't change, you don't need to call this. It basically caches the connectivity data.

Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public procedure GetExtents(out min, max: TAffineVector);

Computes the extents of the mesh.<p>

Public procedure LoadFromFile(const filename: string); dynamic;

Loads a vector file.<p> A vector files (for instance a ".3DS") stores the definition of a mesh as well as materials property.<p> Loading a file replaces the current one (if any).

Public procedure LoadFromStream(const filename: string; aStream: TStream); dynamic;

Loads a vector file from a stream.<p> See LoadFromFile.<br> The filename attribute is required to identify the type data you're streaming (3DS, OBJ, etc.)

Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure PerformAutoCentering; dynamic;

Invoked after a mesh has been loaded.<p> Should auto-center according to the AutoCentering property.

Public procedure PerformAutoScaling; dynamic;

Invoked after a mesh has been loaded.<p> Should auto-scale the vertices of the meshobjects to AutoScaling the property.

Public procedure SaveToFile(const fileName: string); dynamic;

Saves to a vector file.<p> Note that only some of the vector files formats can be written to by GLScene.

Public procedure SaveToStream(const fileName: string; aStream: TStream); dynamic;

Saves to a vector file in a stream.<p> Note that only some of the vector files formats can be written to by GLScene.

Public procedure StructureChanged; override;
Public procedure StructureChangedNoPrepare;

Notifies that geometry data changed, but no re-preparation is needed.<p> Using this method will usually be faster, but may result in incorrect rendering, reduced performance and/or invalid bounding box data (ie. invalid collision detection). Use with caution.

Protected procedure DestroyHandle; override;
Protected procedure DropMaterialLibraryCache;

Recursively propagated to mesh object and facegroups.<p> Notifies that they all should forget their material library caches.

Protected procedure PrepareBuildList(var mrci: TRenderContextInfo); dynamic;

Prepare the texture and materials before rendering.<p> Invoked once, before building the list and NOT while building the list, MaterialLibraryCache can be assumed to having been prepared if materials are active. Default behaviour is to prepare build lists for the meshobjects.

Protected procedure PrepareMaterialLibraryCache;

Recursively propagated to mesh object and facegroups.<p> Notifies that they all can establish their material library caches.

Protected procedure PrepareMesh; dynamic;

Invoked after a mesh has been loaded/added.<p> Triggered by LoadFromFile/Stream and AddDataFromFile/Stream.<br> Allows to adjust/transfer subclass-specific features.

Protected procedure PrepareVectorFile(aFile: TVectorFile); dynamic;

Invoked after creating a TVectorFile and before loading.<p> Triggered by LoadFromFile/Stream and AddDataFromFile/Stream.<br> Allows to adjust/transfer subclass-specific features.

Protected procedure SetAutoScaling(const Value: TGLCoordinates);
Protected procedure SetLightmapLibrary(const val: TGLMaterialLibrary);
Protected procedure SetMaterialLibrary(const val: TGLMaterialLibrary);
Protected procedure SetNormalsOrientation(const val: TMeshNormalsOrientation);
Protected procedure SetOverlaySkeleton(const val: Boolean);
Protected procedure SetUseMeshMaterials(const val: Boolean);

Properties

Public property AutoCentering: TMeshAutoCenterings read FAutoCentering write FAutoCentering default [];

Determines if a mesh should be centered and how.<p> AutoCentering is performed <b>only</b> after loading a mesh, it has no effect on already loaded mesh data or when adding from a file/stream.<br> If you want to alter mesh data, use direct manipulation methods (on the TMeshObjects).

Public property AutoScaling: TGLCoordinates read FAutoScaling write FAutoScaling;

Scales vertices to a AutoScaling.<p> AutoScaling is performed <b>only</b> after loading a mesh, it has no effect on already loaded mesh data or when adding from a file/stream.<br> If you want to alter mesh data, use direct manipulation methods (on the TMeshObjects).

Public property IgnoreMissingTextures: Boolean read FIgnoreMissingTextures write FIgnoreMissingTextures default False;

If True, exceptions about missing textures will be ignored.<p> Implementation is up to the file loader class (ie. this property may be ignored by some loaders)

Public property LightmapLibrary: TGLMaterialLibrary read FLightmapLibrary write SetLightmapLibrary;

LightMap library where lightmaps will be stored/retrieved.<p> If this property is not defined, lightmaps won't be used. Lightmaps currently *always* use the second texture unit (unit 1), and may interfere with multi-texture materials.

Public property MaterialLibrary: TGLMaterialLibrary read FMaterialLibrary write SetMaterialLibrary;

Material library where mesh materials will be stored/retrieved.<p> If this property is not defined or if UseMeshMaterials is false, only the FreeForm's material will be used (and the mesh's materials will be ignored.

Public property MeshObjects: TMeshObjectList read FMeshObjects;
Public property NormalsOrientation: TMeshNormalsOrientation read FNormalsOrientation write SetNormalsOrientation default mnoDefault;

Normals orientation for owned mesh.<p>

Public property OverlaySkeleton: Boolean read FOverlaySkeleton write SetOverlaySkeleton default False;

Request rendering of skeleton bones over the mesh.

Public property Skeleton: TSkeleton read FSkeleton;
Public property UseMeshMaterials: Boolean read FUseMeshMaterials write SetUseMeshMaterials default True;

Defines wether materials declared in the vector file mesh are used.<p> You must also define the MaterialLibrary property.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVectorFileObjects: Class TGLFreeForm

Class TGLFreeForm

Unit

GLVectorFileObjects

Declaration

type TGLFreeForm = class(TGLBaseMesh)

Description

Container objects for a vector file mesh.<p> FreeForms allows loading and rendering vector files (like 3DStudio ".3DS" file) in GLScene. Meshes can be loaded with the LoadFromFile method.<p> A FreeForm may contain more than one mesh, but they will all be handled as a single object in a scene.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLFreeForm

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function OctreeAABBIntersect(const AABB: TAABB; objMatrix, invObjMatrix: TMatrix; triangles: TAffineVectorList = nil): boolean;
Public | function OctreePointInMesh(const Point: TVector): boolean;
Public | function OctreeRayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean;
Public | function OctreeSphereSweepIntersect(const rayStart, rayVector: TVector; const velocity, radius: Single; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean;
Public | function OctreeTriangleIntersect(const v1, v2, v3: TAffineVector): boolean;
Protected | function GetOctree: TOctree;
Public | procedure BuildOctree(TreeDepth: integer = 3);

Properties

Published | property AutoCentering;
Published | property AutoScaling;
Published | property LightmapLibrary;
Published | property MaterialLibrary;
Published | property NormalsOrientation;
Public | property Octree: TOctree read GetOctree;
Published | property UseMeshMaterials;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function OctreeAABBIntersect(const AABB: TAABB; objMatrix, invObjMatrix: TMatrix; triangles: TAffineVectorList = nil): boolean;
Public function OctreePointInMesh(const Point: TVector): boolean;

Returns true if Point is inside the free form - this will only work properly on closed meshes. Requires that Octree has been prepared.

Public function OctreeRayCastIntersect(const rayStart, rayVector: TVector; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean;
Public function OctreeSphereSweepIntersect(const rayStart, rayVector: TVector; const velocity, radius: Single; intersectPoint: PVector = nil; intersectNormal: PVector = nil): Boolean;
Public function OctreeTriangleIntersect(const v1, v2, v3: TAffineVector): boolean;
Protected function GetOctree: TOctree;
Public procedure BuildOctree(TreeDepth: integer = 3);

Properties

Published property AutoCentering;
Published property AutoScaling;
Published property LightmapLibrary;
Published property MaterialLibrary;
Published property NormalsOrientation;
Public property Octree: TOctree read GetOctree;

Octree support *experimental*.<p> Use only if you understand what you're doing!

Published property UseMeshMaterials;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVectorFileObjects: Class TActorAnimation

Class TActorAnimation

Unit

GLVectorFileObjects

Declaration

type TActorAnimation = class(TCollectionItem)

Description

An actor animation sequence.<p> An animation sequence is a named set of contiguous frames that can be used for animating an actor. The referred frames can be either morph or skeletal frames (choose which via the Reference property).<p> An animation can be directly "played" by the actor by selecting it with SwitchAnimation, and can also be "blended" via a TGLAnimationControler.

Hierarchy

  • TCollectionItem
  • TActorAnimation

Overview

Methods

Public | constructor Create(Collection: TCollection); override;
Public | destructor Destroy; override;
Public | function OwnerActor: TGLActor;
Protected | function FrameCount: Integer;
Protected | function GetAsString: string;
Protected | function GetDisplayName: string; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure MakeSkeletalRotationDelta;
Public | procedure MakeSkeletalTranslationStatic;
Protected | procedure SetAsString(const val: string);
Protected | procedure SetEndFrame(const val: Integer);
Protected | procedure SetReference(val: TActorAnimationReference);
Protected | procedure SetStartFrame(const val: Integer);

Properties

Public | property AsString: string read GetAsString write SetAsString;
Published | property EndFrame: Integer read FEndFrame write SetEndFrame;
Published | property Name: string read FName write FName;
Published | property Reference: TActorAnimationReference read FReference write SetReference default aarMorph;
Published | property StartFrame: Integer read FStartFrame write SetStartFrame;

Description

Methods

Public constructor Create(Collection: TCollection); override;
Public destructor Destroy; override;
Public function OwnerActor: TGLActor;
Protected function FrameCount: Integer;
Protected function GetAsString: string;
Protected function GetDisplayName: string; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure MakeSkeletalRotationDelta;

Removes the absolute rotation component of the skeletal frames.<p> Some formats will store frames with absolute rotation information, if this correct if the animation is the "main" animation.<br> This function removes that absolute information, making the animation frames suitable for blending purposes.

Public procedure MakeSkeletalTranslationStatic;

Linearly removes the translation component between skeletal frames.<p> This function will compute the translation of the first bone (index 0) and linearly subtract this translation in all frames between startFrame and endFrame. Its purpose is essentially to remove the 'slide' that exists in some animation formats (f.i. SMD).

Protected procedure SetAsString(const val: string);
Protected procedure SetEndFrame(const val: Integer);
Protected procedure SetReference(val: TActorAnimationReference);
Protected procedure SetStartFrame(const val: Integer);

Properties

Public property AsString: string read GetAsString write SetAsString;
Published property EndFrame: Integer read FEndFrame write SetEndFrame;

Index of the final frame of the animation.

Published property Name: string read FName write FName;
Published property Reference: TActorAnimationReference read FReference write SetReference default aarMorph;

Indicates if this is a skeletal or a morph-based animation.

Published property StartFrame: Integer read FStartFrame write SetStartFrame;

Index of the initial frame of the animation.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVectorFileObjects: Class TActorAnimations

Class TActorAnimations

Unit

GLVectorFileObjects

Declaration

type TActorAnimations = class(TCollection)

Description

Collection of actor animations sequences.

Hierarchy

  • TCollection
  • TActorAnimations

Overview

Methods

Public | constructor Create(AOwner: TGLActor);
Public | function Add: TActorAnimation;
Public | function FindFrame(aFrame: Integer; aReference: TActorAnimationReference): TActorAnimation;
Public | function FindItemID(ID: Integer): TActorAnimation;
Public | function FindName(const aName: string): TActorAnimation;
Public | function Last: TActorAnimation;
Protected | function GetItems(index: Integer): TActorAnimation;
Protected | function GetOwner: TPersistent; override;
Public | procedure LoadFromFile(const fileName: string);
Public | procedure LoadFromStream(aStream: TStream);
Public | procedure SaveToFile(const fileName: string);
Public | procedure SaveToStream(aStream: TStream);
Public | procedure SetToStrings(aStrings: TStrings);
Protected | procedure SetItems(index: Integer; const val: TActorAnimation);

Properties

Public property Items[index: Integer]: TActorAnimation read GetItems write SetItems;

Description

Methods

Public constructor Create(AOwner: TGLActor);
Public function Add: TActorAnimation;
Public function FindFrame(aFrame: Integer; aReference: TActorAnimationReference): TActorAnimation;
Public function FindItemID(ID: Integer): TActorAnimation;
Public function FindName(const aName: string): TActorAnimation;
Public function Last: TActorAnimation;
Protected function GetItems(index: Integer): TActorAnimation;
Protected function GetOwner: TPersistent; override;
Public procedure LoadFromFile(const fileName: string);
Public procedure LoadFromStream(aStream: TStream);
Public procedure SaveToFile(const fileName: string);
Public procedure SaveToStream(aStream: TStream);
Public procedure SetToStrings(aStrings: TStrings);
Protected procedure SetItems(index: Integer; const val: TActorAnimation);

Properties

Public property Items[index: Integer]: TActorAnimation read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVectorFileObjects: Class TGLBaseAnimationControler

Class TGLBaseAnimationControler

Unit

GLVectorFileObjects

Declaration

type TGLBaseAnimationControler = class(TComponent)

Description

Base class for skeletal animation control.<p>

Hierarchy

  • TComponent
  • TGLBaseAnimationControler

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function Apply(var lerpInfo: TBlendedLerpInfo): Boolean; virtual;
Protected | procedure DoChange; virtual;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetActor(const val: TGLActor);
Protected | procedure SetEnabled(const val: Boolean);

Properties

Published | property Actor: TGLActor read FActor write SetActor;
Published | property Enabled: Boolean read FEnabled write SetEnabled default True;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function Apply(var lerpInfo: TBlendedLerpInfo): Boolean; virtual;
Protected procedure DoChange; virtual;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetActor(const val: TGLActor);
Protected procedure SetEnabled(const val: Boolean);

Properties

Published property Actor: TGLActor read FActor write SetActor;
Published property Enabled: Boolean read FEnabled write SetEnabled default True;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVectorFileObjects: Class TGLAnimationControler

Class TGLAnimationControler

Unit

GLVectorFileObjects

Declaration

type TGLAnimationControler = class(TGLBaseAnimationControler)

Description

Controls the blending of an additionnal skeletal animation into an actor.<p> The animation controler allows animating an actor with several animations at a time, for instance, you could use a "run" animation as base animation (in TGLActor), blend an animation that makes the arms move differently depending on what the actor is carrying, along with an animation that will make the head turn toward a target.

Hierarchy

  • TComponent
  • TGLBaseAnimationControler
  • TGLAnimationControler

Overview

Methods

Protected | function Apply(var lerpInfo: TBlendedLerpInfo): Boolean; override;
Protected | procedure DoChange; override;
Protected | procedure SetAnimationName(const val: TActorAnimationName);
Protected | procedure SetRatio(const val: Single);

Properties

Published | property AnimationName: string read FAnimationName write SetAnimationName;
Published | property Ratio: Single read FRatio write SetRatio;

Description

Methods

Protected function Apply(var lerpInfo: TBlendedLerpInfo): Boolean; override;
Protected procedure DoChange; override;
Protected procedure SetAnimationName(const val: TActorAnimationName);
Protected procedure SetRatio(const val: Single);

Properties

Published property AnimationName: string read FAnimationName write SetAnimationName;
Published property Ratio: Single read FRatio write SetRatio;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVectorFileObjects: Class TGLActor

Class TGLActor

Unit

GLVectorFileObjects

Declaration

type TGLActor = class(TGLBaseMesh)

Description

Mesh class specialized in animated meshes.<p> The TGLActor provides a quick interface to animated meshes based on morph or skeleton frames, it is capable of performing frame interpolation and animation blending (via TGLAnimationControler components).

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLBaseMesh
  • TGLActor

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CurrentAnimation: string;
Public | function FrameCount: Integer;
Public | function isSwitchingAnimation: boolean;
Public | function NextFrameIndex: Integer;
Protected | function StoreAnimations: Boolean;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci: TRenderContextInfo); override;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Public | procedure LoadFromStream(const filename: string; aStream: TStream); override;
Public | procedure NextFrame(nbSteps: Integer = 1);
Public | procedure PrevFrame(nbSteps: Integer = 1);
Public | procedure SetCurrentFrameDirect(const Value: Integer);
Public | procedure SwitchToAnimation(animationIndex: Integer; smooth: Boolean = False); overload;
Public | procedure SwitchToAnimation(const animationName: string; smooth: Boolean = False); overload;
Public | procedure SwitchToAnimation(anAnimation: TActorAnimation; smooth: Boolean = False); overload;
Public | procedure Synchronize(referenceActor: TGLActor);
Protected | procedure DoAnimate; virtual;
Protected | procedure PrepareBuildList(var mrci: TRenderContextInfo); override;
Protected | procedure PrepareMesh; override;
Protected | procedure RegisterControler(aControler: TGLBaseAnimationControler);
Protected | procedure SetAnimations(const val: TActorAnimations);
Protected | procedure SetCurrentFrame(val: Integer);
Protected | procedure SetEndFrame(val: Integer);
Protected | procedure SetOptions(const val: TGLActorOptions);
Protected | procedure SetReference(val: TActorAnimationReference);
Protected | procedure SetStartFrame(val: Integer);
Protected | procedure UnRegisterControler(aControler: TGLBaseAnimationControler);

Properties

Published | property AnimationMode: TActorAnimationMode read FAnimationMode write FAnimationMode default aamNone;
Published | property Animations: TActorAnimations read FAnimations write SetAnimations stored StoreAnimations;
Published | property AutoCentering;
Published | property CurrentFrame: Integer read FCurrentFrame write SetCurrentFrame default 0;
Published | property CurrentFrameDelta: Single read FCurrentFrameDelta write FCurrentFrameDelta;
Published | property EndFrame: Integer read FEndFrame write SetEndFrame default 0;
Published | property FrameInterpolation: TActorFrameInterpolation read FFrameInterpolation write FFrameInterpolation default afpLinear;
Published | property Interval: Integer read FInterval write FInterval;
Published | property LightmapLibrary;
Published | property MaterialLibrary;
Published | property NormalsOrientation;
Published | property OnEndFrameReached: TNotifyEvent read FOnEndFrameReached write FOnEndFrameReached;
Published | property OnFrameChanged: TNotifyEvent read FOnFrameChanged write FOnFrameChanged;
Published | property OnStartFrameReached: TNotifyEvent read FOnStartFrameReached write FOnStartFrameReached;
Published | property Options: TGLActorOptions read FOptions write SetOptions default cDefaultGLActorOptions;
Published | property OverlaySkeleton;
Published | property Reference: TActorAnimationReference read FReference write FReference default aarMorph;
Published | property StartFrame: Integer read FStartFrame write SetStartFrame default 0;
Published | property UseMeshMaterials;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function CurrentAnimation: string;
Public function FrameCount: Integer;
Public function isSwitchingAnimation: boolean;

Indicates whether the actor is currently swithing animations (with smooth interpolation).

Public function NextFrameIndex: Integer;
Protected function StoreAnimations: Boolean;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci: TRenderContextInfo); override;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Public procedure LoadFromStream(const filename: string; aStream: TStream); override;
Public procedure NextFrame(nbSteps: Integer = 1);
Public procedure PrevFrame(nbSteps: Integer = 1);
Public procedure SetCurrentFrameDirect(const Value: Integer);

Provides a direct access to FCurrentFrame without any checks. Used in TGLActorProxy.

Public procedure SwitchToAnimation(animationIndex: Integer; smooth: Boolean = False); overload;
Public procedure SwitchToAnimation(const animationName: string; smooth: Boolean = False); overload;
Public procedure SwitchToAnimation(anAnimation: TActorAnimation; smooth: Boolean = False); overload;
Public procedure Synchronize(referenceActor: TGLActor);

Synchronize self animation with an other actor.<p> Copies Start/Current/End Frame values, CurrentFrameDelta, AnimationMode and FrameInterpolation.

Protected procedure DoAnimate; virtual;
Protected procedure PrepareBuildList(var mrci: TRenderContextInfo); override;
Protected procedure PrepareMesh; override;
Protected procedure RegisterControler(aControler: TGLBaseAnimationControler);
Protected procedure SetAnimations(const val: TActorAnimations);
Protected procedure SetCurrentFrame(val: Integer);
Protected procedure SetEndFrame(val: Integer);
Protected procedure SetOptions(const val: TGLActorOptions);
Protected procedure SetReference(val: TActorAnimationReference);
Protected procedure SetStartFrame(val: Integer);
Protected procedure UnRegisterControler(aControler: TGLBaseAnimationControler);

Properties

Published property AnimationMode: TActorAnimationMode read FAnimationMode write FAnimationMode default aamNone;

See TActorAnimationMode.<p>

Published property Animations: TActorAnimations read FAnimations write SetAnimations stored StoreAnimations;

Collection of animations sequences.

Published property AutoCentering;
Published property CurrentFrame: Integer read FCurrentFrame write SetCurrentFrame default 0;

Current animation frame.

Published property CurrentFrameDelta: Single read FCurrentFrameDelta write FCurrentFrameDelta;

Value in the [0; 1] range expressing the delta to the next frame.<p>

Published property EndFrame: Integer read FEndFrame write SetEndFrame default 0;
Published property FrameInterpolation: TActorFrameInterpolation read FFrameInterpolation write FFrameInterpolation default afpLinear;

Frame interpolation mode (afpNone/afpLinear).

Published property Interval: Integer read FInterval write FInterval;

Interval between frames, in milliseconds.

Published property LightmapLibrary;
Published property MaterialLibrary;
Published property NormalsOrientation;
Published property OnEndFrameReached: TNotifyEvent read FOnEndFrameReached write FOnEndFrameReached;

Triggered after EndFrame has been reached by progression or "nextframe"

Published property OnFrameChanged: TNotifyEvent read FOnFrameChanged write FOnFrameChanged;

Triggered after each CurrentFrame change.

Published property OnStartFrameReached: TNotifyEvent read FOnStartFrameReached write FOnStartFrameReached;

Triggered after StartFrame has been reached by progression or "nextframe"

Published property Options: TGLActorOptions read FOptions write SetOptions default cDefaultGLActorOptions;

Actor and animation miscellanious options.

Published property OverlaySkeleton;
Published property Reference: TActorAnimationReference read FReference write FReference default aarMorph;

Reference Frame Animation mode.<p> Allows specifying if the model is primarily morph or skeleton based.

Published property StartFrame: Integer read FStartFrame write SetStartFrame default 0;
Published property UseMeshMaterials;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVectorFileObjects: Class TVectorFileFormat

Class TVectorFileFormat

Unit

GLVectorFileObjects

Declaration

type TVectorFileFormat = class(TObject)

Description

Hierarchy

  • TObject
  • TVectorFileFormat

Overview

Fields

Public | VectorFileClass: TVectorFileClass;
Public | Extension: string;
Public | Description: string;
Public | DescResID: Integer;

Description

Fields

Public VectorFileClass: TVectorFileClass;
Public Extension: string;
Public Description: string;
Public DescResID: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVectorFileObjects: Class TVectorFileFormatsList

Class TVectorFileFormatsList

Unit

GLVectorFileObjects

Declaration

type TVectorFileFormatsList = class(TPersistentObjectList)

Description

Stores registered vector file formats.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TVectorFileFormatsList

Overview

Methods

Public | destructor Destroy; override;
Public | function FindExt(ext: string): TVectorFileClass;
Public | function FindExtByIndex(index: Integer; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False): string;
Public | function FindFromFileName(const fileName: string): TVectorFileClass;
Public | procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TVectorFileClass);
Public | procedure BuildFilterStrings(vectorFileClass: TVectorFileClass; out descriptions, filters: string; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False);
Public | procedure Remove(AClass: TVectorFileClass);

Description

Methods

Public destructor Destroy; override;
Public function FindExt(ext: string): TVectorFileClass;
Public function FindExtByIndex(index: Integer; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False): string;
Public function FindFromFileName(const fileName: string): TVectorFileClass;
Public procedure Add(const Ext, Desc: string; DescID: Integer; AClass: TVectorFileClass);
Public procedure BuildFilterStrings(vectorFileClass: TVectorFileClass; out descriptions, filters: string; formatsThatCanBeOpened: Boolean = True; formatsThatCanBeSaved: Boolean = False);
Public procedure Remove(AClass: TVectorFileClass);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVectorFileObjects: Class EInvalidVectorFile

Class EInvalidVectorFile

Unit

GLVectorFileObjects

Declaration

type EInvalidVectorFile = class(Exception)

Description

Hierarchy

  • Exception
  • EInvalidVectorFile
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVerletClasses

Unit GLVerletClasses

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLVerletClasses<p>

Classes and functions that make integration between verlets and glscene objects easy.

<b>History : </b><font size=-1><ul> <li>23/08/10 - Yar - Added VectorTypes to uses <li>13/04/04 - MF - Verlet call now uses TVerletProgressTimes <li>06/03/04 - MF - Creation </ul>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLVerletNode |

Functions and Procedures

function CreateVCPlaneFromGLPlane(Plane : TGLPlane; VerletWorld : TVerletWorld; Offset : single) : TVCFloor;

Description

Functions and Procedures

function CreateVCPlaneFromGLPlane(Plane : TGLPlane; VerletWorld : TVerletWorld; Offset : single) : TVCFloor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVerletClasses: Class TGLVerletNode

Class TGLVerletNode

Unit

GLVerletClasses

Declaration

type TGLVerletNode = class(TVerletNode)

Description

Specialized verlet node that can be anchored to a GLScene object. If it's anchored and has the property "NailedDown" set, it will remain in the same relative position to the GLScene object.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSpacePartitionLeaf
  • TVerletNode
  • TGLVerletNode

Overview

Methods

Public | procedure Verlet(const vpt : TVerletProgressTimes); override;
Protected | procedure SetLocation(const Value: TAffineVector); override;

Properties

Public | property GLBaseSceneObject : TGLBaseSceneObject read FGLBaseSceneObject write SetGLBaseSceneObject;
Public | property RelativePosition : TAffineVector read FRelativePosition write FRelativePosition;

Description

Methods

Public procedure Verlet(const vpt : TVerletProgressTimes); override;
Protected procedure SetLocation(const Value: TAffineVector); override;

Properties

Public property GLBaseSceneObject : TGLBaseSceneObject read FGLBaseSceneObject write SetGLBaseSceneObject;
Public property RelativePosition : TAffineVector read FRelativePosition write FRelativePosition;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVerletClothify

Unit GLVerletClothify

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLVerletClothify<p>

Methods for turning a TGLBaseMesh into a Verlet cloth / jelly<p>

<b>History : </b><font size=-1><ul> <li>16/09/10 - YP - Created public NodeList property of TFaceExtractor, it allow us to nail some vertex <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>06/06/10 - Yar - Fixed warnings <li>05/03/10 - DanB - More state added to TGLStateCache <li>22/02/10 - Yar - Optimization of switching states <li>30/03/07 - DaStr - Added $I GLScene.inc <li>28/03/07 - DaStr - Added explicit pointer dereferencing (even more) <li>16/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>27/05/04 - MF - Added some length information to edges <li>24/06/03 - MF - Removed several embarrassing warnings <li>17/06/03 - MF - Creation </ul>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TFace |
Class TFaceList |
Class TFaceExtractor |
Class TEdge |
Class TEdgeList |
Class TEdgeDetector |
Class TMeshObjectVerletNode |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVerletClothify: Class TFace

Class TFace

Unit

GLVerletClothify

Declaration

type TFace = class(TObject)

Description

Class that represents a face. This structure is not used for rendering, but for extracting info from meshes

Hierarchy

  • TObject
  • TFace

Overview

Fields

Public | Vertices: array[0..2] of integer;
Public | Normal: TAffineVector;
Public | MeshObject: TMeshObject;
Public | Active: boolean;

Methods

Public | constructor Create(aMeshObject : TMeshObject);
Public | procedure UpdateNormal;

Description

Fields

Public Vertices: array[0..2] of integer;
Public Normal: TAffineVector;
Public MeshObject: TMeshObject;
Public Active: boolean;

Methods

Public constructor Create(aMeshObject : TMeshObject);
Public procedure UpdateNormal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVerletClothify: Class TFaceList

Class TFaceList

Unit

GLVerletClothify

Declaration

type TFaceList = class(TList)

Description

List of faces

Hierarchy

  • TList
  • TFaceList

Overview

Properties

Public property Items[i : integer]: TFace read GetItems write SetItems;

Description

Properties

Public property Items[i : integer]: TFace read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVerletClothify: Class TFaceExtractor

Class TFaceExtractor

Unit

GLVerletClothify

Declaration

type TFaceExtractor = class(TObject)

Description

Class that extracts faces from a GLBaseMesh

Hierarchy

  • TObject
  • TFaceExtractor

Overview

Methods

Public | constructor Create(const aGLBaseMesh : TGLBaseMesh); virtual;
Public | destructor Destroy; override;
Public | function AddFace(const Vi0, Vi1, Vi2 : integer; const MeshObject : TMeshObject) : TFace; virtual;
Public | procedure Clear; virtual;
Public | procedure ExtractFacesFromVertexIndexList( const FaceGroup : TFGVertexIndexList; const MeshObject : TMeshObject);
Public | procedure ProcessMesh; virtual;
Protected | procedure ProcessMeshObject(const MeshObject : TMeshObject); virtual;

Properties

Public | property EdgeDoublesSkipped : integer read FEdgeDoublesSkipped;
Public | property FaceList : TFaceList read FFaceList;
Public | property GLBaseMesh : TGLBaseMesh read FGLBaseMesh;
Public | property NodeList : TVerletNodeList read FNodeList;
Public | property WeldDistance : single read FWeldDistance write SetWeldDistance;

Description

Methods

Public constructor Create(const aGLBaseMesh : TGLBaseMesh); virtual;
Public destructor Destroy; override;
Public function AddFace(const Vi0, Vi1, Vi2 : integer; const MeshObject : TMeshObject) : TFace; virtual;
Public procedure Clear; virtual;
Public procedure ExtractFacesFromVertexIndexList( const FaceGroup : TFGVertexIndexList; const MeshObject : TMeshObject);
Public procedure ProcessMesh; virtual;
Protected procedure ProcessMeshObject(const MeshObject : TMeshObject); virtual;

Properties

Public property EdgeDoublesSkipped : integer read FEdgeDoublesSkipped;
Public property FaceList : TFaceList read FFaceList;
Public property GLBaseMesh : TGLBaseMesh read FGLBaseMesh;
Public property NodeList : TVerletNodeList read FNodeList;
Public property WeldDistance : single read FWeldDistance write SetWeldDistance;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVerletClothify: Class TEdge

Class TEdge

Unit

GLVerletClothify

Declaration

type TEdge = class(TObject)

Description

Hierarchy

  • TObject
  • TEdge

Overview

Fields

Public | Vertices: array[0..1] of integer;
Public | Faces: array[0..1] of TFace;

Methods

Public | constructor Create(const AOwner: TEdgeDetector; AVi0, AVi1 : integer; AFace0, AFace1 : TFace; AMeshObject : TMeshObject; ASolid : boolean);
Public | procedure Contract;
Public | procedure UpdateEdgeLength;

Properties

Public | property Length : single read FLength write FLength;
Public | property MeshObject : TMeshObject read FMeshObject write FMeshObject;
Public | property Owner : TEdgeDetector read FOwner;
Public | property Solid : boolean read FSolid write FSolid;

Description

Fields

Public Vertices: array[0..1] of integer;
Public Faces: array[0..1] of TFace;

Methods

Public constructor Create(const AOwner: TEdgeDetector; AVi0, AVi1 : integer; AFace0, AFace1 : TFace; AMeshObject : TMeshObject; ASolid : boolean);
Public procedure Contract;
Public procedure UpdateEdgeLength;

Properties

Public property Length : single read FLength write FLength;
Public property MeshObject : TMeshObject read FMeshObject write FMeshObject;
Public property Owner : TEdgeDetector read FOwner;
Public property Solid : boolean read FSolid write FSolid;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVerletClothify: Class TEdgeList

Class TEdgeList

Unit

GLVerletClothify

Declaration

type TEdgeList = class(TList)

Description

Hierarchy

  • TList
  • TEdgeList

Overview

Methods

Public | function InsertSorted(AEdge : TEdge) : integer;
Public | procedure SortByLength;

Properties

Public property Items[i : integer]: TEdge read GetItems write SetItems;

Description

Methods

Public function InsertSorted(AEdge : TEdge) : integer;
Public procedure SortByLength;

Properties

Public property Items[i : integer]: TEdge read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVerletClothify: Class TEdgeDetector

Class TEdgeDetector

Unit

GLVerletClothify

Declaration

type TEdgeDetector = class(TFaceExtractor)

Description

no description available, TFaceExtractor description follows

Class that extracts faces from a GLBaseMesh

Hierarchy

  • TObject
  • TFaceExtractor
  • TEdgeDetector

Overview

Fields

Protected FCalcEdgeLength: boolean;

Methods

Public | constructor Create(const aGLBaseMesh : TGLBaseMesh); override;
Public | destructor Destroy; override;
Public | function AddEdge(const Vi0, Vi1 : integer; const Face : TFace; const AMeshObject : TMeshObject) : TEdge;
Public | function AddFace(const Vi0, Vi1, Vi2 : integer; const MeshObject : TMeshObject) : TFace; override;
Public | function AddNode(const VerletWorld : TVerletWorld; const MeshObject : TMeshObject; const VertexIndex : integer) : TVerletNode; virtual;
Public | procedure AddEdgesAsSolidEdges(const VerletWorld : TVerletWorld);
Public | procedure AddEdgesAsSprings(const VerletWorld : TVerletWorld; const Strength, Damping, Slack : single);
Public | procedure AddEdgesAsSticks(const VerletWorld : TVerletWorld; const Slack : single);
Public | procedure AddNodes(const VerletWorld : TVerletWorld);
Public | procedure AddOuterEdgesAsSolidEdges(const VerletWorld : TVerletWorld);
Public | procedure Clear; override;
Public | procedure ProcessMesh; override;
Public | procedure RenderEdges(var rci : TRenderContextInfo);
Public | procedure ReplaceVertexIndex(const ViRemove, ViReplaceWith : integer);

Properties

Public | property CurrentNodeOffset : integer read FCurrentNodeOffset;
Public | property EdgeList : TEdgeList read FEdgeList;
Public | property NodesAdded : boolean read FNodesAdded;

Description

Fields

Protected FCalcEdgeLength: boolean;

Methods

Public constructor Create(const aGLBaseMesh : TGLBaseMesh); override;
Public destructor Destroy; override;
Public function AddEdge(const Vi0, Vi1 : integer; const Face : TFace; const AMeshObject : TMeshObject) : TEdge;
Public function AddFace(const Vi0, Vi1, Vi2 : integer; const MeshObject : TMeshObject) : TFace; override;
Public function AddNode(const VerletWorld : TVerletWorld; const MeshObject : TMeshObject; const VertexIndex : integer) : TVerletNode; virtual;
Public procedure AddEdgesAsSolidEdges(const VerletWorld : TVerletWorld);
Public procedure AddEdgesAsSprings(const VerletWorld : TVerletWorld; const Strength, Damping, Slack : single);
Public procedure AddEdgesAsSticks(const VerletWorld : TVerletWorld; const Slack : single);
Public procedure AddNodes(const VerletWorld : TVerletWorld);
Public procedure AddOuterEdgesAsSolidEdges(const VerletWorld : TVerletWorld);
Public procedure Clear; override;
Public procedure ProcessMesh; override;
Public procedure RenderEdges(var rci : TRenderContextInfo);
Public procedure ReplaceVertexIndex(const ViRemove, ViReplaceWith : integer);

Properties

Public property CurrentNodeOffset : integer read FCurrentNodeOffset;
Public property EdgeList : TEdgeList read FEdgeList;
Public property NodesAdded : boolean read FNodesAdded;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVerletClothify: Class TMeshObjectVerletNode

Class TMeshObjectVerletNode

Unit

GLVerletClothify

Declaration

type TMeshObjectVerletNode = class(TVerletNode)

Description

no description available, TVerletNode description follows

Basic verlet node

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSpacePartitionLeaf
  • TVerletNode
  • TMeshObjectVerletNode

Overview

Methods

Public | constructor CreateOwned(const aOwner : TVerletWorld); override;
Public | destructor Destroy; override;
Public | procedure AfterProgress; override;

Description

Methods

Public constructor CreateOwned(const aOwner : TVerletWorld); override;
Public destructor Destroy; override;
Public procedure AfterProgress; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVerletSkeletonColliders

Unit GLVerletSkeletonColliders

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLVerletSkeletonColliders<p>

Skeleton colliders for defining and controlling verlet constraints.<p>

<b>History :</b><font size=-1><ul> <li>11/12/03 - SG - Now uses AddToVerletWorld to build the constraints. <li>08/10/03 - SG - Creation. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TSCVerletBase |
Class TSCVerletSphere |
Class TSCVerletCapsule |

Functions and Procedures

procedure AddSCVerletConstriantsToVerletWorld( colliders : TSkeletonColliderList; world : TVerletWorld);

Description

Functions and Procedures

procedure AddSCVerletConstriantsToVerletWorld( colliders : TSkeletonColliderList; world : TVerletWorld);

After loading call this function to add all the constraints in a skeleton collider list to a given verlet world.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVerletSkeletonColliders: Class TSCVerletBase

Class TSCVerletBase

Unit

GLVerletSkeletonColliders

Declaration

type TSCVerletBase = class(TSkeletonCollider)

Description

Base verlet skeleton collider class.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSkeletonCollider
  • TSCVerletBase

Overview

Methods

Public | procedure AddToVerletWorld(VerletWorld : TVerletWorld); virtual;
Public | procedure ReadFromFiler(reader : TVirtualReader); override;
Public | procedure WriteToFiler(writer : TVirtualWriter); override;

Properties

Public property VerletConstraint : TVerletConstraint read FVerletConstraint;

Description

Methods

Public procedure AddToVerletWorld(VerletWorld : TVerletWorld); virtual;
Public procedure ReadFromFiler(reader : TVirtualReader); override;
Public procedure WriteToFiler(writer : TVirtualWriter); override;

Properties

Public property VerletConstraint : TVerletConstraint read FVerletConstraint;

The verlet constraint is created through the AddToVerletWorld procedure.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVerletSkeletonColliders: Class TSCVerletSphere

Class TSCVerletSphere

Unit

GLVerletSkeletonColliders

Declaration

type TSCVerletSphere = class(TSCVerletBase)

Description

Sphere shaped verlet constraint in a skeleton collider.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSkeletonCollider
  • TSCVerletBase
  • TSCVerletSphere

Overview

Methods

Public | constructor Create; override;
Public | procedure AddToVerletWorld(VerletWorld : TVerletWorld); override;
Public | procedure AlignCollider; override;
Public | procedure ReadFromFiler(reader : TVirtualReader); override;
Public | procedure WriteToFiler(writer : TVirtualWriter); override;
Protected | procedure SetRadius(const val : Single);

Properties

Public property Radius : Single read FRadius write SetRadius;

Description

Methods

Public constructor Create; override;
Public procedure AddToVerletWorld(VerletWorld : TVerletWorld); override;
Public procedure AlignCollider; override;
Public procedure ReadFromFiler(reader : TVirtualReader); override;
Public procedure WriteToFiler(writer : TVirtualWriter); override;
Protected procedure SetRadius(const val : Single);

Properties

Public property Radius : Single read FRadius write SetRadius;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVerletSkeletonColliders: Class TSCVerletCapsule

Class TSCVerletCapsule

Unit

GLVerletSkeletonColliders

Declaration

type TSCVerletCapsule = class(TSCVerletBase)

Description

Capsule shaped verlet constraint in a skeleton collider.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSkeletonCollider
  • TSCVerletBase
  • TSCVerletCapsule

Overview

Methods

Public | constructor Create; override;
Public | procedure AddToVerletWorld(VerletWorld : TVerletWorld); override;
Public | procedure AlignCollider; override;
Public | procedure ReadFromFiler(reader : TVirtualReader); override;
Public | procedure WriteToFiler(writer : TVirtualWriter); override;
Protected | procedure SetLength(const val : Single);
Protected | procedure SetRadius(const val : Single);

Properties

Public | property Length : Single read FLength write SetLength;
Public | property Radius : Single read FRadius write SetRadius;

Description

Methods

Public constructor Create; override;
Public procedure AddToVerletWorld(VerletWorld : TVerletWorld); override;
Public procedure AlignCollider; override;
Public procedure ReadFromFiler(reader : TVirtualReader); override;
Public procedure WriteToFiler(writer : TVirtualWriter); override;
Protected procedure SetLength(const val : Single);
Protected procedure SetRadius(const val : Single);

Properties

Public property Length : Single read FLength write SetLength;
Public property Radius : Single read FRadius write SetRadius;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVfsPAK

Unit GLVfsPAK

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLVfsPAK<p>

Support-code for loading files from Quake II PAK Files.<p> When instance is created all LoadFromFile methods using ApplicationFileIO mechanism will be pointed into PAK file.<p> You can change current PAK file by ActivePak variable.<p>

<b>History :</b><font size=-1><ul> <li>16/10/2008 - UweR - Compatibility fix for Delphi 2009 <li>31/03/2007 - DaStr - Added $I GLScene.inc <li>29/01/2007 - DaStr - Moved registration to GLSceneRegister.pas <li>26/10/2006 - LC - Fixed memory leak in TGLVfsPAK.LoadFromFile. Bugtracker ID=1585215 (thanks Da Stranger) <li>18/10/2004 - Orchestraman - PAKCreateFileStream, Fixed an error when trying to load an image file in material editor during design time. It Loads the file from the Hard Disk. <li>14/10/2004 - Orchestraman - PAKCreateFileStream, PAKFileStreamExists procedures redirect the streaming to hard disk if pack file does not exist. <li>04/10/2004 - Orchestraman - Fixed bug in LoadFromFile. The compressor object is created when the file is signed as compressed. <li>04/10/2004 - Orchestraman - Fixed bug in Constructor. The inherited constructor of TComponent didn't run when the component was created by the component pallete. <li>03/08/2004 - Orchestraman - Add LZRW1 compression. <li>19/04/04 - PSz - Creation </ul></font>

<b>Notes on Compression feature :</b><font size=-1><ul>

</ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TPakHeader |
record TFileSection |
Class TGLVfsPAK |

Functions and Procedures

function PAKCreateFileStream(const fileName: string; mode: word): TStream;
function PAKFileStreamExists(const fileName: string): boolean;

Types

TZCompressedMode = (...);

Constants

SIGN = 'PACK';
SIGN_COMPRESSED = 'PACZ';

Variables

ActiveVfsPAK: TGLVfsPak;

Description

Functions and Procedures

function PAKCreateFileStream(const fileName: string; mode: word): TStream;
function PAKFileStreamExists(const fileName: string): boolean;

Types

TZCompressedMode = (...);
Values
  • Good:
  • Fast:
  • Auto:
  • None:

Constants

SIGN = 'PACK';
SIGN_COMPRESSED = 'PACZ';

Variables

ActiveVfsPAK: TGLVfsPak;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVfsPAK: record TPakHeader

record TPakHeader

Unit

GLVfsPAK

Declaration

type TPakHeader = record

Description

Overview

Fields

Signature: array[0..3] of AnsiChar;
DirOffset: integer;
DirLength: integer;

Description

Fields

Signature: array[0..3] of AnsiChar;
DirOffset: integer;
DirLength: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVfsPAK: record TFileSection

record TFileSection

Unit

GLVfsPAK

Declaration

type TFileSection = record

Description

Overview

Fields

FileName: array[0..119] of AnsiChar;
FilePos: integer;
FileLength: integer;

Description

Fields

FileName: array[0..119] of AnsiChar;
FilePos: integer;
FileLength: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLVfsPAK: Class TGLVfsPAK

Class TGLVfsPAK

Unit

GLVfsPAK

Declaration

type TGLVfsPAK = class(TComponent)

Description

Hierarchy

  • TComponent
  • TGLVfsPAK

Overview

Methods

Public | constructor Create(AOwner : TComponent; const CbrMode: TZCompressedMode); reintroduce; overload;
Public | constructor Create(AOwner : TComponent); overload; override;
Public | destructor Destroy; override;
Public | function FileExists(FileName: string): boolean;
Public | function GetFile(index: integer): TStream; overload;
Public | function GetFile(FileName: string): TStream; overload;
Public | function GetFileSize(FileName: string): integer; overload;
Public | function GetFileSize(index: integer): integer; overload;
Public | procedure AddEmptyFile(FileName, Path: string);
Public | procedure AddFromFile(FileName, Path: string);
Public | procedure AddFromStream(FileName, Path: string; F: TStream);
Public | procedure ClearPakFiles;
Public | procedure Extract(index: integer; NewName: string); overload;
Public | procedure Extract(FileName, NewName: string); overload;
Public | procedure LoadFromFile(FileName: string; Mode: word);
Public | procedure RemoveFile(index: integer); overload;
Public | procedure RemoveFile(FileName: string); overload;

Properties

Public | property ActivePakNum: integer read GetStreamNumber write SetStreamNumber;
Public | property Compressed: Boolean read FCompressed;
Public | property CompressionLevel: TZCompressedMode read FCompressionLevel;
Public | property FileCount: integer Read GetFileCount;
Public | property Files: TStrings read FFiles;
Public | property PakFileName: string Read FFileName;
Public | property PakFiles: TStringList read FPakFiles;

Description

Methods

Public constructor Create(AOwner : TComponent; const CbrMode: TZCompressedMode); reintroduce; overload;
Public constructor Create(AOwner : TComponent); overload; override;
Public destructor Destroy; override;
Public function FileExists(FileName: string): boolean;
Public function GetFile(index: integer): TStream; overload;
Public function GetFile(FileName: string): TStream; overload;
Public function GetFileSize(FileName: string): integer; overload;
Public function GetFileSize(index: integer): integer; overload;
Public procedure AddEmptyFile(FileName, Path: string);
Public procedure AddFromFile(FileName, Path: string);
Public procedure AddFromStream(FileName, Path: string; F: TStream);
Public procedure ClearPakFiles;
Public procedure Extract(index: integer; NewName: string); overload;
Public procedure Extract(FileName, NewName: string); overload;
Public procedure LoadFromFile(FileName: string; Mode: word);
Public procedure RemoveFile(index: integer); overload;
Public procedure RemoveFile(FileName: string); overload;

Properties

Public property ActivePakNum: integer read GetStreamNumber write SetStreamNumber;
Public property Compressed: Boolean read FCompressed;
Public property CompressionLevel: TZCompressedMode read FCompressionLevel;
Public property FileCount: integer Read GetFileCount;
Public property Files: TStrings read FFiles;
Public property PakFileName: string Read FFileName;
Public property PakFiles: TStringList read FPakFiles;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:09


GLScene v.1.1.2: GLViewer

Unit GLViewer

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLViewer<p>

Platform independant viewer.<p>

History: <li>13/06/12 - Yar - Bugfix synchronization control for Mac OS (thanks to pchev) <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens <li>30/04/10 - Yar - Added vertical synchronization cntrol for Linux (by Rustam Asmandiarov aka Predato) <li>17/09/07 - DaStr - Replaced $IFNDEF KYLIX to $IFDEF MSWINDOWS in SetupVSync() because wgl* functions are Windows-specific <li>12/09/07 - DaStr - Fixed SetupVSync() function (Bugtracker ID = 1786279) Made cross-platform code easier to read <li>12/07/07 - DaStr - Added SetupVSync <li>30/03/07 - DaStr - Another update after the previous fix (removed class()) Added TVSyncMode type and constants. <li>24/03/07 - DaStr - Update for Windows after the previous fix <li>21/03/07 - DaStr - Improved Cross-Platform compatibility (thanks Burkhard Carstens) (Bugtracker ID = 1684432) <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTrackerID=1681585) <li>24/01/02 - EG - Initial version

Overview

Functions and Procedures

procedure SetupVSync(const AVSyncMode : TVSyncMode);

Types

TGLSceneViewer = GLLCLViewer.TGLSceneViewer;

Description

Functions and Procedures

procedure SetupVSync(const AVSyncMode : TVSyncMode);

Types

TGLSceneViewer = GLLCLViewer.TGLSceneViewer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWaterPlane

Unit GLWaterPlane

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLWaterPlane<p>

A plane simulating animated water<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>30/03/07 - DaStr - Added $I GLScene.inc <li>22/09/04 - R.Cao - Added AxisAlignedDimensionsUnscaled to fix visibility culling <li>02/04/03 - EG - More optimizations, mask support <li>01/04/03 - EG - Cleanup and optimizations <li>14/11/03 - Mrqzzz - Tried "CreateRippleAtWorldPos" to work at any position/rotation, but need expert's help.. :( <li>13/11/03 - Mrqzzz - Tried to add timing indipendence (quite not precise yet) <li>12/11/03 - Mrqzzz - Added some properties & small optims added <li>01/01/03 - Sternas Stefanos - Original code </ul></font>

<p>The Original Code is part of Cosmos4D<br> http://users.hol.gr/˜sternas/<br> Sternas Stefanos 2003

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLWaterPlane |

Types

TGLWaterPlaneOption = (...);
TGLWaterPlaneOptions = set of TGLWaterPlaneOption;

Constants

cDefaultWaterPlaneOptions = [wpoTextured];

Description

Types

TGLWaterPlaneOption = (...);
Values
  • wpoTextured:
TGLWaterPlaneOptions = set of TGLWaterPlaneOption;

Constants

cDefaultWaterPlaneOptions = [wpoTextured];
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWaterPlane: Class TGLWaterPlane

Class TGLWaterPlane

Unit

GLWaterPlane

Declaration

type TGLWaterPlane = class(TGLSceneObject)

Description

no description available, TGLSceneObject description follows

Base class for standard scene objects.<p> Publishes the Material property.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLCustomSceneObject
  • TGLSceneObject
  • TGLWaterPlane

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Public | function AxisAlignedDimensionsUnscaled : TVector; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure BuildList(var rci : TRenderContextInfo); override;
Public | procedure CreateRippleAtGridPos(X,Y:integer);
Public | procedure CreateRippleAtWorldPos(const x, y, z : Single); overload;
Public | procedure CreateRippleAtWorldPos(const pos : TVector); overload;
Public | procedure CreateRippleRandom;
Public | procedure DoProgress(const progressTime : TProgressTimes); override;
Public | procedure Reset;
Protected | procedure DoMaskChanged(Sender : TObject);
Protected | procedure InitResolution;
Protected | procedure Iterate;
Protected | procedure IterComputeNormals;
Protected | procedure IterComputePositions;
Protected | procedure IterComputeVelocity;
Protected | procedure SetElastic(const value : Single);
Protected | procedure SetMask(val : TGLPicture);
Protected | procedure SetOptions(const val : TGLWaterPlaneOptions);
Protected | procedure SetRainForce(const val : Single);
Protected | procedure SetRainTimeInterval(const val : Integer);
Protected | procedure SetResolution(const value : Integer);
Protected | procedure SetSimulationFrequency(const val : Single);
Protected | procedure SetViscosity(const val : Single);

Properties

Published | property Active : Boolean read FActive write FActive default True;
Published | property Elastic : Single read FElastic write SetElastic;
Public | property LastIterationStepTime : Single read FLastIterationStepTime;
Published | property Mask : TGLPicture read FMask write SetMask;
Published | property MaximumCatchupIterations : Integer read FMaximumCatchupIterations write FMaximumCatchupIterations default 1;
Published | property Options : TGLWaterPlaneOptions read FOptions write SetOptions default cDefaultWaterPlaneOptions;
Published | property RainForce : Single read FRainForce write SetRainForce;
Published | property RainTimeInterval : Integer read FRainTimeInterval write SetRainTimeInterval default 500;
Published | property Resolution : Integer read FResolution write SetResolution default 64;
Published | property SimulationFrequency : Single read FSimulationFrequency write SetSimulationFrequency;
Published | property Viscosity : Single read FViscosity write SetViscosity ;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Public function AxisAlignedDimensionsUnscaled : TVector; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure BuildList(var rci : TRenderContextInfo); override;
Public procedure CreateRippleAtGridPos(X,Y:integer);
Public procedure CreateRippleAtWorldPos(const x, y, z : Single); overload;
Public procedure CreateRippleAtWorldPos(const pos : TVector); overload;
Public procedure CreateRippleRandom;
Public procedure DoProgress(const progressTime : TProgressTimes); override;
Public procedure Reset;
Protected procedure DoMaskChanged(Sender : TObject);
Protected procedure InitResolution;
Protected procedure Iterate;
Protected procedure IterComputeNormals;
Protected procedure IterComputePositions;
Protected procedure IterComputeVelocity;
Protected procedure SetElastic(const value : Single);
Protected procedure SetMask(val : TGLPicture);
Protected procedure SetOptions(const val : TGLWaterPlaneOptions);
Protected procedure SetRainForce(const val : Single);
Protected procedure SetRainTimeInterval(const val : Integer);
Protected procedure SetResolution(const value : Integer);
Protected procedure SetSimulationFrequency(const val : Single);
Protected procedure SetViscosity(const val : Single);

Properties

Published property Active : Boolean read FActive write FActive default True;
Published property Elastic : Single read FElastic write SetElastic;
Public property LastIterationStepTime : Single read FLastIterationStepTime;

CPU time (in seconds) taken by the last iteration step.

Published property Mask : TGLPicture read FMask write SetMask;

A picture whose pixels determine what part of the waterplane is active.<p> Pixels with a green/gray component beyond 128 are active, the others are not (in short, white = active, black = inactive).<p> The picture will automatically be stretched to match the resolution.

Published property MaximumCatchupIterations : Integer read FMaximumCatchupIterations write FMaximumCatchupIterations default 1;

Maximum number of simulation iterations during catchups.<p> Catchups happen when for a reason or another, the DoProgress doesn't happen as fast SimulationFrequency.

Published property Options : TGLWaterPlaneOptions read FOptions write SetOptions default cDefaultWaterPlaneOptions;
Published property RainForce : Single read FRainForce write SetRainForce;
Published property RainTimeInterval : Integer read FRainTimeInterval write SetRainTimeInterval default 500;

Delay between raindrops in milliseconds (0 = no rain)

Published property Resolution : Integer read FResolution write SetResolution default 64;
Published property SimulationFrequency : Single read FSimulationFrequency write SetSimulationFrequency;

Maximum frequency (in Hz) at which simulation iterations happen.

Published property Viscosity : Single read FViscosity write SetViscosity ;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWidgetContext

Unit GLWidgetContext

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLWidgetContext<p>

Widget specific Context.<p> GLWidgetContext replaces old GLLinGTKContext.<p>

<b>History : </b><font size=-1><ul> <li>11/06/10 - Yar - Fixed uses section after lazarus-0.9.29.26033 release <li>02/05/10 - Yar - Fixes for Linux x64 <li>21/04/10 - Yar - Fixed conditions (by Rustam Asmandiarov aka Predator) <li>06/04/10 - Yar - Added to GLScene (Created by Rustam Asmandiarov aka Predator) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLWidgetContext |
Class TGLSOpenGLControl |

Functions and Procedures

procedure GLRegisterWSComponent(aControl: TComponentClass);

Description

Functions and Procedures

procedure GLRegisterWSComponent(aControl: TComponentClass);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWidgetContext: Class TGLWidgetContext

Class TGLWidgetContext

Unit

GLWidgetContext

Declaration

type TGLWidgetContext = class(TGLWin32Context)

Description

no description available, TGLWin32Context description follows

A context driver for standard Windows OpenGL (via MS OpenGL).

Hierarchy

  • TObject
  • TGLContext
  • TGLWin32Context
  • TGLWidgetContext

Overview

Methods

Protected procedure DoGetHandles(outputDevice: HWND; out XWin: HWND); override;

Description

Methods

Protected procedure DoGetHandles(outputDevice: HWND; out XWin: HWND); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWidgetContext: Class TGLSOpenGLControl

Class TGLSOpenGLControl

Unit

GLWidgetContext

Declaration

type TGLSOpenGLControl = class(TWin32WSWinControl)

Description

Hierarchy

  • TWin32WSWinControl
  • TGLSOpenGLControl

Overview

Methods

Published class function CreateHandle(const AWinControl: TWinControl; const AParams: TCreateParams): HWND; override;

Description

Methods

Published class function CreateHandle(const AWinControl: TWinControl; const AParams: TCreateParams): HWND; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWin32Context

Unit GLWin32Context

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLWin32Context<p>

Win32 specific Context.<p>

<b>History : </b><font size=-1><ul> <li>11/09/11 - Yar - Added layers support (not tested because need Quadro or FireFX VGA) <li>18/07/11 - Yar - Added ability of creating OpenGL ES 2.0 profile context <li>03/12/10 - Yar - Fixed window tracking (thanks to Gabriel Corneanu) <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>23/08/10 - Yar - Replaced OpenGL1x to OpenGLTokens. Improved context creation. <li>18/06/10 - Yar - Changed context sharing method for similarity to GLX <li>06/06/10 - Yar - Moved forward context creation to DoCreateContext make outputDevice HWND type <li>19/05/10 - Yar - Added choice between hardware and software acceleration <li>06/05/10 - Yar - Added vLastVendor clearing when multithreading is enabled <li>06/04/10 - Yar - Added DoGetHandles to TGLWin32Context (thanks Rustam Asmandiarov aka Predator) <li>28/03/10 - Yar - Added 3.3 forward context creation and eliminate memory leaks when multithreading <li>06/03/10 - Yar - Added forward context creation in TGLWin32Context.DoActivate <li>20/02/10 - DanB - Allow double-buffered memory viewers, if you want single buffered, or no swapping, then change buffer options instead. Some changes from Cardinal to the appropriate HDC /HGLRC type. <li>15/01/10 - DaStr - Bugfixed TGLWin32Context.ChooseWGLFormat() (BugtrackerID = 2933081) (thanks YarUndeoaker) <li>08/01/10 - DaStr - Added more AntiAliasing modes (thanks YarUndeoaker) <li>13/12/09 - DaStr - Modified for multithread support (thanks Controller) <li>30/08/09 - DanB - vIgnoreContextActivationFailures renamed to vContextActivationFailureOccurred + check removed. <li>06/11/07 - mrqzzz - Ignore ContextActivation failure if GLContext.vIgnoreContextActivationFailures=true <li>15/02/07 - DaStr - Integer -> Cardinal because $R- was removed in GLScene.pas <li>11/09/06 - NC - Added support for Multiple-Render-Target <li>03/10/04 - NC - Added float texture support <li>03/07/02 - EG - ChooseWGLFormat Kyro fix (Patrick Chevalley) <li>13/03/02 - EG - aaDefault now prefers non-AA when possible <li>03/03/02 - EG - Fixed aaNone mode (AA specifically off) <li>01/03/02 - EG - Fixed CurrentPixelFormatIsHardwareAccelerated <li>22/02/02 - EG - Unified ChooseWGLFormat for visual & non-visual <li>21/02/02 - EG - AntiAliasing support *experimental* (Chris N. Strahm) <li>05/02/02 - EG - Fixed UnTrackWindow <li>03/02/02 - EG - Added experimental Hook-based window tracking <li>29/01/02 - EG - Improved recovery for ICDs without pbuffer support <li>21/01/02 - EG - More graceful recovery for ICDs without pbuffer support <li>07/01/02 - EG - DoCreateMemoryContext now retrieved topDC when needed <li>15/12/01 - EG - Added support for AlphaBits <li>30/11/01 - EG - Hardware acceleration support now detected <li>20/11/01 - EG - New temp HWnd code for memory contexts (improved compat.) <li>04/09/01 - EG - Added ChangeIAttrib, support for 16bits depth buffer <li>25/08/01 - EG - Added pbuffer support and CreateMemoryContext interface <li>24/08/01 - EG - Fixed PropagateSharedContext <li>12/08/01 - EG - Handles management completed <li>22/07/01 - EG - Creation (glcontext.omm) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLWin32Context |

Functions and Procedures

function CreateTempWnd: HWND;

Constants

WGL_SWAP_MAIN_PLANE = $00000001;
WGL_SWAP_OVERLAY1 = $00000002;
WGL_SWAP_OVERLAY2 = $00000004;
WGL_SWAP_OVERLAY3 = $00000008;
WGL_SWAP_OVERLAY4 = $00000010;
WGL_SWAP_OVERLAY5 = $00000020;
WGL_SWAP_OVERLAY6 = $00000040;
WGL_SWAP_OVERLAY7 = $00000080;
WGL_SWAP_OVERLAY8 = $00000100;
WGL_SWAP_OVERLAY9 = $00000200;
WGL_SWAP_OVERLAY10 = $00000400;
WGL_SWAP_OVERLAY11 = $00000800;
WGL_SWAP_OVERLAY12 = $00001000;
WGL_SWAP_OVERLAY13 = $00002000;
WGL_SWAP_OVERLAY14 = $00004000;
WGL_SWAP_OVERLAY15 = $00008000;
WGL_SWAP_UNDERLAY1 = $00010000;
WGL_SWAP_UNDERLAY2 = $00020000;
WGL_SWAP_UNDERLAY3 = $00040000;
WGL_SWAP_UNDERLAY4 = $00080000;
WGL_SWAP_UNDERLAY5 = $00100000;
WGL_SWAP_UNDERLAY6 = $00200000;
WGL_SWAP_UNDERLAY7 = $00400000;
WGL_SWAP_UNDERLAY8 = $00800000;
WGL_SWAP_UNDERLAY9 = $01000000;
WGL_SWAP_UNDERLAY10 = $02000000;
WGL_SWAP_UNDERLAY11 = $04000000;
WGL_SWAP_UNDERLAY12 = $08000000;
WGL_SWAP_UNDERLAY13 = $10000000;
WGL_SWAP_UNDERLAY14 = $20000000;
WGL_SWAP_UNDERLAY15 = $40000000;
cForwardContextFailed = 'Can not create forward compatible context: #%X, %s';
cBackwardContextFailed = 'Can not create backward compatible context: #%X, %s';
cFailHWRC = 'Unable to create rendering context with hardware acceleration - down to software';
glsTmpRC_Created = 'Temporary rendering context created';
glsDriverNotSupportFRC = 'Driver not support creating of forward context';
glsDriverNotSupportOESRC = 'Driver not support creating of OpenGL ES 2.0 context';
glsDriverNotSupportDebugRC = 'Driver not support creating of debug context';
glsOESvsForwardRC = 'OpenGL ES 2.0 context incompatible with Forward context - flag ignored';
glsFRC_created = 'Forward core context seccussfuly created';
glsOESRC_created = 'OpenGL ES 2.0 context seccussfuly created';
glsPBufferRC_created = 'Backward compatible core PBuffer context successfully created';

Variables

vUseWindowTrackingHook: Boolean = True;

Description

Functions and Procedures

function CreateTempWnd: HWND;

Constants

WGL_SWAP_MAIN_PLANE = $00000001;
WGL_SWAP_OVERLAY1 = $00000002;
WGL_SWAP_OVERLAY2 = $00000004;
WGL_SWAP_OVERLAY3 = $00000008;
WGL_SWAP_OVERLAY4 = $00000010;
WGL_SWAP_OVERLAY5 = $00000020;
WGL_SWAP_OVERLAY6 = $00000040;
WGL_SWAP_OVERLAY7 = $00000080;
WGL_SWAP_OVERLAY8 = $00000100;
WGL_SWAP_OVERLAY9 = $00000200;
WGL_SWAP_OVERLAY10 = $00000400;
WGL_SWAP_OVERLAY11 = $00000800;
WGL_SWAP_OVERLAY12 = $00001000;
WGL_SWAP_OVERLAY13 = $00002000;
WGL_SWAP_OVERLAY14 = $00004000;
WGL_SWAP_OVERLAY15 = $00008000;
WGL_SWAP_UNDERLAY1 = $00010000;
WGL_SWAP_UNDERLAY2 = $00020000;
WGL_SWAP_UNDERLAY3 = $00040000;
WGL_SWAP_UNDERLAY4 = $00080000;
WGL_SWAP_UNDERLAY5 = $00100000;
WGL_SWAP_UNDERLAY6 = $00200000;
WGL_SWAP_UNDERLAY7 = $00400000;
WGL_SWAP_UNDERLAY8 = $00800000;
WGL_SWAP_UNDERLAY9 = $01000000;
WGL_SWAP_UNDERLAY10 = $02000000;
WGL_SWAP_UNDERLAY11 = $04000000;
WGL_SWAP_UNDERLAY12 = $08000000;
WGL_SWAP_UNDERLAY13 = $10000000;
WGL_SWAP_UNDERLAY14 = $20000000;
WGL_SWAP_UNDERLAY15 = $40000000;
cForwardContextFailed = 'Can not create forward compatible context: #%X, %s';
cBackwardContextFailed = 'Can not create backward compatible context: #%X, %s';
cFailHWRC = 'Unable to create rendering context with hardware acceleration - down to software';
glsTmpRC_Created = 'Temporary rendering context created';
glsDriverNotSupportFRC = 'Driver not support creating of forward context';
glsDriverNotSupportOESRC = 'Driver not support creating of OpenGL ES 2.0 context';
glsDriverNotSupportDebugRC = 'Driver not support creating of debug context';
glsOESvsForwardRC = 'OpenGL ES 2.0 context incompatible with Forward context - flag ignored';
glsFRC_created = 'Forward core context seccussfuly created';
glsOESRC_created = 'OpenGL ES 2.0 context seccussfuly created';
glsPBufferRC_created = 'Backward compatible core PBuffer context successfully created';

Variables

vUseWindowTrackingHook: Boolean = True;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWin32Context: Class TGLWin32Context

Class TGLWin32Context

Unit

GLWin32Context

Declaration

type TGLWin32Context = class(TGLContext)

Description

A context driver for standard Windows OpenGL (via MS OpenGL).

Hierarchy

  • TObject
  • TGLContext
  • TGLWin32Context

Overview

Fields

Protected | FDC: HDC;
Protected | FRC: HGLRC;
Protected | FShareContext: TGLWin32Context;
Protected | FHPBUFFER: Integer;
Protected | FiAttribs: packed of Integer;
Protected | FfAttribs: packed of Single;
Protected | FLegacyContextsOnly: Boolean;
Protected | FSwapBufferSupported: Boolean;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function IsValid: Boolean; override;
Public | function RenderOutputDevice: Pointer; override;
Protected | function DoShareLists(aContext: TGLContext): Boolean; override;
Public | procedure SwapBuffers; override;
Protected | procedure AddFAttrib(attrib, value: Single);
Protected | procedure AddIAttrib(attrib, value: Integer);
Protected | procedure ChangeIAttrib(attrib, newValue: Integer);
Protected | procedure ChooseWGLFormat(DC: HDC; nMaxFormats: Cardinal; piFormats: PInteger; var nNumFormats: Integer; BufferCount: integer = 1);
Protected | procedure ClearFAttribs;
Protected | procedure ClearIAttribs;
Protected | procedure CreateNewContext(aDC: HDC); dynamic;
Protected | procedure CreateOldContext(aDC: HDC); dynamic;
Protected | procedure DestructionEarlyWarning(sender: TObject);
Protected | procedure DoActivate; override;
Protected | procedure DoCreateContext(ADeviceHandle: HDC); override;
Protected | procedure DoCreateMemoryContext(outputDevice: HWND; width, height: Integer; BufferCount: integer); override;
Protected | procedure DoDeactivate; override;
Protected | procedure DoDestroyContext; override;
Protected | procedure DoGetHandles(outputDevice: HWND; out XWin: HDC); virtual; abstract;
Protected | procedure DropIAttrib(attrib: Integer);
Protected | procedure SpawnLegacyContext(aDC: HDC);

Properties

Public | property DC: HDC read FDC;
Public | property RC: HGLRC read FRC;

Description

Fields

Protected FDC: HDC;
Protected FRC: HGLRC;
Protected FShareContext: TGLWin32Context;
Protected FHPBUFFER: Integer;
Protected FiAttribs: packed of Integer;
Protected FfAttribs: packed of Single;
Protected FLegacyContextsOnly: Boolean;
Protected FSwapBufferSupported: Boolean;

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function IsValid: Boolean; override;
Public function RenderOutputDevice: Pointer; override;
Protected function DoShareLists(aContext: TGLContext): Boolean; override;
Public procedure SwapBuffers; override;
Protected procedure AddFAttrib(attrib, value: Single);
Protected procedure AddIAttrib(attrib, value: Integer);
Protected procedure ChangeIAttrib(attrib, newValue: Integer);
Protected procedure ChooseWGLFormat(DC: HDC; nMaxFormats: Cardinal; piFormats: PInteger; var nNumFormats: Integer; BufferCount: integer = 1);
Protected procedure ClearFAttribs;
Protected procedure ClearIAttribs;
Protected procedure CreateNewContext(aDC: HDC); dynamic;
Protected procedure CreateOldContext(aDC: HDC); dynamic;
Protected procedure DestructionEarlyWarning(sender: TObject);
Protected procedure DoActivate; override;
Protected procedure DoCreateContext(ADeviceHandle: HDC); override;
Protected procedure DoCreateMemoryContext(outputDevice: HWND; width, height: Integer; BufferCount: integer); override;
Protected procedure DoDeactivate; override;
Protected procedure DoDestroyContext; override;
Protected procedure DoGetHandles(outputDevice: HWND; out XWin: HDC); virtual; abstract;

DoGetHandles must be implemented in child classes, and return the display + window

Protected procedure DropIAttrib(attrib: Integer);
Protected procedure SpawnLegacyContext(aDC: HDC);

Properties

Public property DC: HDC read FDC;
Public property RC: HGLRC read FRC;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWin32Viewer

Unit GLWin32Viewer

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLWin32Viewer<p>

Win32 specific Scene viewer.<p>

<b>History : </b><font size=-1><ul> <li>03/02/13 - Yar - Added Touch Events (thanks to nelsonchu) <li>28/09/11 - YP - Added support for keyboard arrows via WM_GETDLGCODE <li>23/08/10 - Yar - Moved TVSyncMode to GLContext <li>22/12/09 - DaStr - Published TabStop, TabOrder, OnEnter, OnExit properties (thanks Yury Plashenkov) <li>10/11/09 - DaStr - Added Delphi 2010 OnGesture and Touch support <li>13/03/09 - DanB - Removed OpenGL dependencies <li>10/04/08 - DaStr - Bugfixed TGLSceneViewer.Notification() (thanks z80maniac) (Bugtracker ID = 1936108) <li>12/09/07 - DaStr - Removed old IFDEFs. Moved SetupVSync() to GLViewer.pas (Bugtracker ID = 1786279) <li>04/12/04 - DaStr - OnMouseWheel, OnMouseWheelDown, OnMouseWheelUp are now published in TGLSceneViewer <li>04/12/04 - MF - Added FieldOfView, formula by Ivan Sivak Jr. <li>24/07/03 - EG - FullScreen Viewer moved to GLWin32FullScreenViewer <li>11/06/03 - EG - Now uses ViewerBeforeChange to adjust VSync <li>29/10/02 - EG - Added MouseEnter/Leave/InControl <li>27/09/02 - EG - Added Ability to set display frequency <li>22/08/02 - EG - Added TGLSceneViewer.RecreateWnd <li>19/08/02 - EG - Added GetHandle <li>14/03/02 - EG - No longer invalidates while rendering <li>11/02/02 - EG - Fixed BeforeRender <li>29/01/02 - EG - New StayOnTop/Maximize logic (Richard Smuts) <li>22/01/02 - EG - Added TGLFullScreenViewer <li>28/12/01 - EG - Event persistence change (GliGli / Dephi bug) <li>12/12/01 - EG - Creation (split from GLScene.pas) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLSceneViewer |

Types

TTouchEvent = procedure(X, Y, TouchWidth, TouchHeight : integer; TouchID : Cardinal; MultiTouch : boolean) of object;

Description

Types

TTouchEvent = procedure(X, Y, TouchWidth, TouchHeight : integer; TouchID : Cardinal; MultiTouch : boolean) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWin32Viewer: Class TGLSceneViewer

Class TGLSceneViewer

Unit

GLWin32Viewer

Declaration

type TGLSceneViewer = class(TWinControl)

Description

Component where the GLScene objects get rendered.<p> This component delimits the area where OpenGL renders the scene, it represents the 3D scene viewed from a camera (specified in the camera property). This component can also render to a file or to a bitmap.<p> It is primarily a windowed component, but it can handle full-screen operations : simply make this component fit the whole screen (use a borderless form).<p> This viewer also allows to define rendering options such a fog, face culling, depth testing, etc. and can take care of framerate calculation.<p>

Hierarchy

  • TWinControl
  • TGLSceneViewer

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function CreateSnapShotBitmap: TBitmap;
Public | function FramesPerSecond: Single;
Public | function FramesPerSecondText(decimals: Integer = 1): string;
Public | function LastFrameTime: Single;
Protected | function GetAfterRender: TNotifyEvent;
Protected | function GetBeforeRender: TNotifyEvent;
Protected | function GetCamera: TGLCamera;
Protected | function GetPostRender: TNotifyEvent;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure RecreateWnd;
Public | procedure RegisterTouch;
Public | procedure ResetPerformanceMonitor;
Public | procedure UnregisterTouch;
Protected | procedure CreateParams(var Params: TCreateParams); override;
Protected | procedure CreateWnd; override;
Protected | procedure DestroyWnd; override;
Protected | procedure DoBeforeRender(Sender: TObject); dynamic;
Protected | procedure DoBufferChange(Sender: TObject); virtual;
Protected | procedure DoBufferStructuralChange(Sender: TObject); dynamic;
Protected | procedure Loaded; override;
Protected | procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;
Protected | procedure SetAfterRender(const val: TNotifyEvent);
Protected | procedure SetBeforeRender(const val: TNotifyEvent);
Protected | procedure SetBuffer(const val: TGLSceneBuffer);
Protected | procedure SetCamera(const val: TGLCamera);
Protected | procedure SetPostRender(const val: TNotifyEvent);

Properties

Published | property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;
Published | property Align;
Published | property Anchors;
Published | property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;
Published | property Buffer: TGLSceneBuffer read FBuffer write SetBuffer;
Published | property Camera: TGLCamera read GetCamera write SetCamera;
Published | property DragCursor;
Published | property DragMode;
Published | property Enabled;
Published | property FieldOfView: single read GetFieldOfView write SetFieldOfView;
Published | property HelpContext;
Published | property Hint;
Public | property IsRenderingContextAvailable: Boolean read GetIsRenderingContextAvailable;
Public | property MouseInControl: Boolean read FMouseInControl;
Published | property OnClick;
Published | property OnContextPopup;
Published | property OnDblClick;
Published | property OnDragDrop;
Published | property OnDragOver;
Published | property OnEndDrag;
Published | property OnEnter;
Published | property OnExit;
Published | property OnKeyDown;
Published | property OnKeyUp;
Published | property OnMouseDown;
Published | property OnMouseEnter: TNotifyEvent read FOnMouseEnter write FOnMouseEnter;
Published | property OnMouseLeave: TNotifyEvent read FOnMouseLeave write FOnMouseLeave;
Published | property OnMouseMove;
Published | property OnMouseUp;
Published | property OnMouseWheel;
Published | property OnMouseWheelDown;
Published | property OnMouseWheelUp;
Published | property OnStartDrag;
Published | property OnTouchDown: TTouchEvent read FOnTouchDown write FOnTouchDown;
Published | property OnTouchMove: TTouchEvent read FOnTouchMove write FOnTouchMove;
Published | property OnTouchUp: TTouchEvent read FOnTouchUp write FOnTouchUp;
Published | property PopupMenu;
Published | property PostRender: TNotifyEvent read GetPostRender write SetPostRender;
Public | property RenderDC: HDC read FOwnDC;
Published | property TabOrder;
Published | property TabStop;
Published | property Visible;
Published | property VSync: TVSyncMode read FVSync write FVSync default vsmNoSync;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function CreateSnapShotBitmap: TBitmap;
Public function FramesPerSecond: Single;
Public function FramesPerSecondText(decimals: Integer = 1): string;
Public function LastFrameTime: Single;
Protected function GetAfterRender: TNotifyEvent;
Protected function GetBeforeRender: TNotifyEvent;
Protected function GetCamera: TGLCamera;
Protected function GetPostRender: TNotifyEvent;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure RecreateWnd;

Makes TWinControl's RecreateWnd public.<p> This procedure allows to work around limitations in some OpenGL drivers (like MS Software OpenGL) that are not able to share lists between RCs that already have display lists.

Public procedure RegisterTouch;
Public procedure ResetPerformanceMonitor;
Public procedure UnregisterTouch;
Protected procedure CreateParams(var Params: TCreateParams); override;
Protected procedure CreateWnd; override;
Protected procedure DestroyWnd; override;
Protected procedure DoBeforeRender(Sender: TObject); dynamic;
Protected procedure DoBufferChange(Sender: TObject); virtual;
Protected procedure DoBufferStructuralChange(Sender: TObject); dynamic;
Protected procedure Loaded; override;
Protected procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;
Protected procedure SetAfterRender(const val: TNotifyEvent);
Protected procedure SetBeforeRender(const val: TNotifyEvent);
Protected procedure SetBuffer(const val: TGLSceneBuffer);
Protected procedure SetCamera(const val: TGLCamera);
Protected procedure SetPostRender(const val: TNotifyEvent);

Properties

Published property AfterRender: TNotifyEvent read GetAfterRender write SetAfterRender;

Called after rendering.<p> You cannot issue OpenGL calls in this event, if you want to do your own OpenGL stuff, use the PostRender event.

Published property Align;
Published property Anchors;
Published property BeforeRender: TNotifyEvent read GetBeforeRender write SetBeforeRender;

Triggered before the scene's objects get rendered.<p> You may use this event to execute your own OpenGL rendering.

Published property Buffer: TGLSceneBuffer read FBuffer write SetBuffer;

Access to buffer properties.

Published property Camera: TGLCamera read GetCamera write SetCamera;

Camera from which the scene is rendered.

Published property DragCursor;
Published property DragMode;
Published property Enabled;
Published property FieldOfView: single read GetFieldOfView write SetFieldOfView;

Returns or sets the field of view for the viewer, in degrees.<p> This value depends on the camera and the width and height of the scene. The value isn't persisted, if the width/height or camera.focallength is changed, FieldOfView is changed also.

Published property HelpContext;
Published property Hint;
Public property IsRenderingContextAvailable: Boolean read GetIsRenderingContextAvailable;
Public property MouseInControl: Boolean read FMouseInControl;
Published property OnClick;
Published property OnContextPopup;
Published property OnDblClick;
Published property OnDragDrop;
Published property OnDragOver;
Published property OnEndDrag;
Published property OnEnter;
Published property OnExit;
Published property OnKeyDown;
Published property OnKeyUp;
Published property OnMouseDown;
Published property OnMouseEnter: TNotifyEvent read FOnMouseEnter write FOnMouseEnter;
Published property OnMouseLeave: TNotifyEvent read FOnMouseLeave write FOnMouseLeave;
Published property OnMouseMove;
Published property OnMouseUp;
Published property OnMouseWheel;
Published property OnMouseWheelDown;
Published property OnMouseWheelUp;
Published property OnStartDrag;
Published property OnTouchDown: TTouchEvent read FOnTouchDown write FOnTouchDown;
Published property OnTouchMove: TTouchEvent read FOnTouchMove write FOnTouchMove;
Published property OnTouchUp: TTouchEvent read FOnTouchUp write FOnTouchUp;
Published property PopupMenu;
Published property PostRender: TNotifyEvent read GetPostRender write SetPostRender;

Triggered just after all the scene's objects have been rendered.<p> The OpenGL context is still active in this event, and you may use it to execute your own OpenGL rendering.<p>

Public property RenderDC: HDC read FOwnDC;
Published property TabOrder;
Published property TabStop;
Published property Visible;
Published property VSync: TVSyncMode read FVSync write FVSync default vsmNoSync;

Specifies if the refresh should be synchronized with the VSync signal.<p> If the underlying OpenGL ICD does not support the WGL_EXT_swap_control extension, this property is ignored.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWindows

Unit GLWindows

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLWindows<p>

OpenGL windows management classes and structures<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records, renamed lowercase sender and accept to uppercase Sender and Accept <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>11/06/10 - YP - Link GUI elements to their parent <li>22/04/10 - Yar - Fixes after GLState revision <li>05/03/10 - DanB - More state added to TGLStateCache <li>17/10/08 - DanB - reversed order of vertices in TGLCustomControl.InternalRender, which fixes the GUIPaint demo <li>27/04/08 - DaStr - Fixed bug in TGLButton.InternalRender() (thanks Nicoara Adrian) (BugtrackerID = 1952711) <li>06/06/07 - DaStr - Added GLColor to uses (BugtrackerID = 1732211) <li>20/12/06 - DaStr - Added: TGLEdit.ReadOnly, TGLScrollbar.Locked, TGLStringGrid.ColSelect <li>10/11/05 - Mathx - Fixed TGLPopupMenu stack overflow on method internalRender. Related to bug 1193909. <li>24/05/02 - JAJ - Base Unit built on basis of Jan Horn's demo at (http://www.sulaco.co.za/opengl/windows.zip) <li>01/06/02 - JAJ - After not having received Jan Horn's blessing, the system have been revised all parts have been rewritten. <li>01/01/03 - JAJ - Updated so that focused controls pass focus on hide... <li>05/01/03 - JAJ - Cleaned up the DesignTime AccessViolations... <li>07/01/03 - JAJ - Jeremy Darling modified the TGLEdit's Render, more updates on TGLEdit expected... <li>18/01/03 - JAJ - Added TGLStringList, TGLScrollbar, TGLPopupMenu... <li>08/08/03 - PS - Added Horizontal to GLScrollbar... <li>14/08/03 - SG - Fixed TGLBaseComponent.SetGuiLayout (Joen Joensen) <li>08/08/03 - JAJ - Merged PS's and SG's update... Added TitleOffset... <li>03/07/04 - LR - Added constant for Keyboard (glKey_TAB, ...) Added function GLOKMessageBox to avoid the uses of Forms Replace TColor, TBitmap, TMouseEvent, TKeyEvent, ... by TGLColor, TGLBitmap, TGLMouseEvent, TGLKeyEvent, ... <li>25/01/05 - AX - Corrected AlphaChannel default value, must be 1 TGLButton, TGLForm - AlphaChannel behaviour text. Added events OnMouseEnter/OnMouseLeave for all controls <li>05/02/05 - AX - TGLLabel correct layout depending on Aligment and TextLayout. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLBaseComponent |
Class TGLBaseControl |
Class TGLBaseFontControl |
Class TGLBaseTextControl |
Class TGLFocusControl |
Class TGLCustomControl |
Class TGLPopupMenu |
Class TGLForm |
Class TGLPanel |
Class TGLCheckBox |
Class TGLButton |
Class TGLEdit |
Class TGLLabel |
Class TGLAdvancedLabel |
Class TGLScrollbar |
Class TGLStringGrid |

Functions and Procedures

function UnpressGroup(CurrentObject: TGLBaseSceneObject; AGroupID: Integer): Boolean;

Types

TGLMouseAction = (...);
TGLAcceptMouseQuery = procedure(Sender: TGLBaseControl; Shift: TShiftState; Action: TGLMouseAction; Button: TGLMouseButton; X, Y: Integer; var Accept: boolean) of object;
TGLCustomRenderEvent = procedure(Sender: TGLCustomControl; Bitmap: TGLBitmap) of object;
TGLPopupMenuClick = procedure(Sender: TGLPopupMenu; index: Integer; const MenuItemText: string) of object;
TGLFormCanRequest = procedure(Sender: TGLForm; var Can: Boolean) of object;
TGLFormCloseOptions = (...);
TGLFormCanClose = procedure(Sender: TGLForm; var CanClose: TGLFormCloseOptions) of object;
TGLFormNotify = procedure(Sender: TGLForm) of object;
TGLFormMove = procedure(Sender: TGLForm; var Left, Top: Single) of object;

Description

Functions and Procedures

function UnpressGroup(CurrentObject: TGLBaseSceneObject; AGroupID: Integer): Boolean;

Types

TGLMouseAction = (...);
Values
  • ma_mouseup:
  • ma_mousedown:
  • ma_mousemove:
TGLAcceptMouseQuery = procedure(Sender: TGLBaseControl; Shift: TShiftState; Action: TGLMouseAction; Button: TGLMouseButton; X, Y: Integer; var Accept: boolean) of object;
TGLCustomRenderEvent = procedure(Sender: TGLCustomControl; Bitmap: TGLBitmap) of object;
TGLPopupMenuClick = procedure(Sender: TGLPopupMenu; index: Integer; const MenuItemText: string) of object;
TGLFormCanRequest = procedure(Sender: TGLForm; var Can: Boolean) of object;
TGLFormCloseOptions = (...);
Values
  • co_Hide:
  • co_Ignore:
  • co_Destroy:
TGLFormCanClose = procedure(Sender: TGLForm; var CanClose: TGLFormCloseOptions) of object;
TGLFormNotify = procedure(Sender: TGLForm) of object;
TGLFormMove = procedure(Sender: TGLForm; var Left, Top: Single) of object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWindows: Class TGLBaseComponent

Class TGLBaseComponent

Unit

GLWindows

Declaration

type TGLBaseComponent = class(TGLBaseGuiObject)

Description

no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function StoreAlphaChannel: Boolean;
Public | procedure BlockRender;
Public | procedure DoChanges; virtual;
Public | procedure DoProgress(const progressTime: TProgressTimes); override;
Public | procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); virtual;
Public | procedure MoveGUI(XRel, YRel: Single);
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure PlaceGUI(XPos, YPos: Single);
Public | procedure UnBlockRender;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure RenderFooter(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean);
Protected | procedure RenderHeader(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean);
Protected | procedure SetAlphaChannel(const val: Single);
Protected | procedure SetGuiLayout(NewGui: TGLGuiLayout); virtual;
Protected | procedure SetGuiLayoutName(NewName: TGLGuiComponentName);
Protected | procedure SetNoZWrite(const val: Boolean);
Protected | procedure SetRotation(const val: TGLFloat);

Properties

Published | property AlphaChannel: Single read FAlphaChannel write SetAlphaChannel stored StoreAlphaChannel;
Published | property Autosize: Boolean read FAutosize write SetAutosize;
Published | property DoChangesOnProgress: Boolean read FDoChangesOnProgress write SetDoChangesOnProgress;
Published | property GuiLayout: TGLGuiLayout read FGuiLayout write SetGuiLayout;
Published | property GuiLayoutName: TGLGuiComponentName read FGuiLayoutName write SetGuiLayoutName;
Public | property GUIRedraw: Boolean read FGUIRedraw write SetGUIRedraw;
Published | property Height;
Published | property Left;
Published | property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;
Published | property Position;
Public | property ReBuildGui: Boolean read FReBuildGui write FReBuildGui;
Published | property RedrawAtOnce: Boolean read FRedrawAtOnce write FRedrawAtOnce;
Published | property Rotation: TGLFloat read FRotation write SetRotation;
Published | property Top;
Published | property Visible;
Published | property Width;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function StoreAlphaChannel: Boolean;
Public procedure BlockRender;
Public procedure DoChanges; virtual;
Public procedure DoProgress(const progressTime: TProgressTimes); override;
Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); virtual;
Public procedure MoveGUI(XRel, YRel: Single);
Public procedure NotifyChange(Sender: TObject); override;
Public procedure PlaceGUI(XPos, YPos: Single);
Public procedure UnBlockRender;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure RenderFooter(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean);
Protected procedure RenderHeader(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean);
Protected procedure SetAlphaChannel(const val: Single);
Protected procedure SetGuiLayout(NewGui: TGLGuiLayout); virtual;
Protected procedure SetGuiLayoutName(NewName: TGLGuiComponentName);
Protected procedure SetNoZWrite(const val: Boolean);
Protected procedure SetRotation(const val: TGLFloat);

Properties

Published property AlphaChannel: Single read FAlphaChannel write SetAlphaChannel stored StoreAlphaChannel;

If different from 1, this value will replace that of Diffuse.Alpha

Published property Autosize: Boolean read FAutosize write SetAutosize;
Published property DoChangesOnProgress: Boolean read FDoChangesOnProgress write SetDoChangesOnProgress;
Published property GuiLayout: TGLGuiLayout read FGuiLayout write SetGuiLayout;
Published property GuiLayoutName: TGLGuiComponentName read FGuiLayoutName write SetGuiLayoutName;
Public property GUIRedraw: Boolean read FGUIRedraw write SetGUIRedraw;
Published property Height;
Published property Left;
Published property NoZWrite: Boolean read FNoZWrite write SetNoZWrite;

If True, GuiComponent will not write to Z-Buffer.<p> GuiComponent will STILL be maskable by ZBuffer test.

Published property Position;
Public property ReBuildGui: Boolean read FReBuildGui write FReBuildGui;
Published property RedrawAtOnce: Boolean read FRedrawAtOnce write FRedrawAtOnce;
Published property Rotation: TGLFloat read FRotation write SetRotation;

This the ON-SCREEN rotation of the GuiComponent.<p> Rotatation=0 is handled faster.

Published property Top;
Published property Visible;
Published property Width;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWindows: Class TGLBaseControl

Class TGLBaseControl

Unit

GLWindows

Declaration

type TGLBaseControl = class(TGLBaseComponent)

Description

no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl

Overview

Methods

Public | function MouseDown(Sender: TObject; Button: TGLMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual;
Public | function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; virtual;
Public | function MouseUp(Sender: TObject; Button: TGLMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual;
Protected | function FindFirstGui: TGLBaseControl;
Public | procedure KeyDown(Sender: TObject; var Key: Word; Shift: TShiftState); virtual;
Public | procedure KeyPress(Sender: TObject; var Key: Char); virtual;
Public | procedure KeyUp(Sender: TObject; var Key: Word; Shift: TShiftState); virtual;
Protected | procedure DoMouseEnter;
Protected | procedure DoMouseLeave;
Protected | procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); virtual;
Protected | procedure InternalMouseMove(Shift: TShiftState; X, Y: Integer); virtual;
Protected | procedure InternalMouseUp(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); virtual;
Protected | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetActiveControl(NewControl: TGLBaseControl);
Protected | procedure SetFocusedControl(NewControl: TGLFocusControl);

Properties

Public | property ActiveControl: TGLBaseControl read FActiveControl write SetActiveControl;
Published | property FocusedControl: TGLFocusControl read FFocusedControl write SetFocusedControl;
Public | property KeepMouseEvents: Boolean read FKeepMouseEvents write FKeepMouseEvents default false;
Published | property OnAcceptMouseQuery: TGLAcceptMouseQuery read FOnAcceptMouseQuery write FOnAcceptMouseQuery;
Published | property OnMouseDown: TGLMouseEvent read FOnMouseDown write FOnMouseDown;
Published | property OnMouseEnter: TNotifyEvent read FOnMouseEnter write FOnMouseEnter;
Published | property OnMouseLeave: TNotifyEvent read FOnMouseLeave write FOnMouseLeave;
Published | property OnMouseMove: TGLMouseMoveEvent read FOnMouseMove write FOnMouseMove;
Published | property OnMouseUp: TGLMouseEvent read FOnMouseUp write FOnMouseUp;

Description

Methods

Public function MouseDown(Sender: TObject; Button: TGLMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual;
Public function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; virtual;
Public function MouseUp(Sender: TObject; Button: TGLMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; virtual;
Protected function FindFirstGui: TGLBaseControl;
Public procedure KeyDown(Sender: TObject; var Key: Word; Shift: TShiftState); virtual;
Public procedure KeyPress(Sender: TObject; var Key: Char); virtual;
Public procedure KeyUp(Sender: TObject; var Key: Word; Shift: TShiftState); virtual;
Protected procedure DoMouseEnter;
Protected procedure DoMouseLeave;
Protected procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); virtual;
Protected procedure InternalMouseMove(Shift: TShiftState; X, Y: Integer); virtual;
Protected procedure InternalMouseUp(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); virtual;
Protected procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetActiveControl(NewControl: TGLBaseControl);
Protected procedure SetFocusedControl(NewControl: TGLFocusControl);

Properties

Public property ActiveControl: TGLBaseControl read FActiveControl write SetActiveControl;
Published property FocusedControl: TGLFocusControl read FFocusedControl write SetFocusedControl;
Public property KeepMouseEvents: Boolean read FKeepMouseEvents write FKeepMouseEvents default false;
Published property OnAcceptMouseQuery: TGLAcceptMouseQuery read FOnAcceptMouseQuery write FOnAcceptMouseQuery;
Published property OnMouseDown: TGLMouseEvent read FOnMouseDown write FOnMouseDown;
Published property OnMouseEnter: TNotifyEvent read FOnMouseEnter write FOnMouseEnter;
Published property OnMouseLeave: TNotifyEvent read FOnMouseLeave write FOnMouseLeave;
Published property OnMouseMove: TGLMouseMoveEvent read FOnMouseMove write FOnMouseMove;
Published property OnMouseUp: TGLMouseEvent read FOnMouseUp write FOnMouseUp;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWindows: Class TGLBaseFontControl

Class TGLBaseFontControl

Unit

GLWindows

Declaration

type TGLBaseFontControl = class(TGLBaseControl)

Description

no description available, TGLBaseControl description follows
no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Protected | function GetBitmapFont: TGLCustomBitmapFont;
Protected | function GetDefaultColor: TDelphiColor;
Protected | function GetFontHeight: Integer;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected | procedure SetBitmapFont(NewFont: TGLCustomBitmapFont);
Protected | procedure SetDefaultColor(value: TDelphiColor);
Protected | procedure WriteTextAt(var rci: TRenderContextInfo; const X, Y: TGLFloat; const Data: UnicodeString; const Color: TColorVector); overload;
Protected | procedure WriteTextAt(var rci: TRenderContextInfo; const X1, Y1, X2, Y2: TGLFloat; const Data: UnicodeString; const Color: TColorVector); overload;

Properties

Published | property BitmapFont: TGLCustomBitmapFont read GetBitmapFont write SetBitmapFont;
Published | property DefaultColor: TDelphiColor read GetDefaultColor write SetDefaultColor;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Protected function GetBitmapFont: TGLCustomBitmapFont;
Protected function GetDefaultColor: TDelphiColor;
Protected function GetFontHeight: Integer;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Protected procedure SetBitmapFont(NewFont: TGLCustomBitmapFont);
Protected procedure SetDefaultColor(value: TDelphiColor);
Protected procedure WriteTextAt(var rci: TRenderContextInfo; const X, Y: TGLFloat; const Data: UnicodeString; const Color: TColorVector); overload;
Protected procedure WriteTextAt(var rci: TRenderContextInfo; const X1, Y1, X2, Y2: TGLFloat; const Data: UnicodeString; const Color: TColorVector); overload;

Properties

Published property BitmapFont: TGLCustomBitmapFont read GetBitmapFont write SetBitmapFont;
Published property DefaultColor: TDelphiColor read GetDefaultColor write SetDefaultColor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWindows: Class TGLBaseTextControl

Class TGLBaseTextControl

Unit

GLWindows

Declaration

type TGLBaseTextControl = class(TGLBaseFontControl)

Description

no description available, TGLBaseFontControl description follows
no description available, TGLBaseControl description follows
no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl

Overview

Methods

Protected procedure SetCaption(const NewCaption: UnicodeString);

Properties

Published property Caption: UnicodeString read FCaption write SetCaption;

Description

Methods

Protected procedure SetCaption(const NewCaption: UnicodeString);

Properties

Published property Caption: UnicodeString read FCaption write SetCaption;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:10


GLScene v.1.1.2: GLWindows: Class TGLFocusControl

Class TGLFocusControl

Unit

GLWindows

Declaration

type TGLFocusControl = class(TGLBaseTextControl)

Description

no description available, TGLBaseTextControl description follows
no description available, TGLBaseFontControl description follows
no description available, TGLBaseControl description follows
no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl

Overview

Methods

Public | destructor Destroy; override;
Protected | function GetFocusedColor: TDelphiColor;
Protected | function GetRootControl: TGLBaseControl;
Public | procedure KeyDown(Sender: TObject; var Key: Word; Shift: TShiftState); override;
Public | procedure KeyPress(Sender: TObject; var Key: Char); override;
Public | procedure KeyUp(Sender: TObject; var Key: Word; Shift: TShiftState); override;
Public | procedure MoveTo(newParent: TGLBaseSceneObject); override;
Public | procedure NextControl;
Public | procedure NotifyHide; override;
Public | procedure PrevControl;
Public | procedure ReGetRootControl;
Public | procedure SetFocus;
Protected | procedure InternalKeyDown(var Key: Word; Shift: TShiftState); virtual;
Protected | procedure InternalKeyPress(var Key: Char); virtual;
Protected | procedure InternalKeyUp(var Key: Word; Shift: TShiftState); virtual;
Protected | procedure SetFocused(Value: Boolean); virtual;
Protected | procedure SetFocusedColor(const Val: TDelphiColor);

Properties

Published | property Focused: Boolean read FFocused write SetFocused;
Published | property FocusedColor: TDelphiColor read GetFocusedColor write SetFocusedColor;
Published | property OnKeyDown: TGLKeyEvent read FOnKeyDown write FOnKeyDown;
Published | property OnKeyPress: TGLKeyPressEvent read FOnKeyPress write FOnKeyPress;
Published | property OnKeyUp: TGLKeyEvent read FOnKeyUp write FOnKeyUp;
Published | property RootControl: TGLBaseControl read GetRootControl;

Description

Methods

Public destructor Destroy; override;
Protected function GetFocusedColor: TDelphiColor;
Protected function GetRootControl: TGLBaseControl;
Public procedure KeyDown(Sender: TObject; var Key: Word; Shift: TShiftState); override;
Public procedure KeyPress(Sender: TObject; var Key: Char); override;
Public procedure KeyUp(Sender: TObject; var Key: Word; Shift: TShiftState); override;
Public procedure MoveTo(newParent: TGLBaseSceneObject); override;
Public procedure NextControl;
Public procedure NotifyHide; override;
Public procedure PrevControl;
Public procedure ReGetRootControl;
Public procedure SetFocus;
Protected procedure InternalKeyDown(var Key: Word; Shift: TShiftState); virtual;
Protected procedure InternalKeyPress(var Key: Char); virtual;
Protected procedure InternalKeyUp(var Key: Word; Shift: TShiftState); virtual;
Protected procedure SetFocused(Value: Boolean); virtual;
Protected procedure SetFocusedColor(const Val: TDelphiColor);

Properties

Published property Focused: Boolean read FFocused write SetFocused;
Published property FocusedColor: TDelphiColor read GetFocusedColor write SetFocusedColor;
Published property OnKeyDown: TGLKeyEvent read FOnKeyDown write FOnKeyDown;
Published property OnKeyPress: TGLKeyPressEvent read FOnKeyPress write FOnKeyPress;
Published property OnKeyUp: TGLKeyEvent read FOnKeyUp write FOnKeyUp;
Published property RootControl: TGLBaseControl read GetRootControl;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:11


GLScene v.1.1.2: GLWindows: Class TGLCustomControl

Class TGLCustomControl

Unit

GLWindows

Declaration

type TGLCustomControl = class(TGLFocusControl)

Description

no description available, TGLFocusControl description follows
no description available, TGLBaseTextControl description follows
no description available, TGLBaseFontControl description follows
no description available, TGLBaseControl description follows
no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl
  • TGLCustomControl

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure SetMaterial(AMaterial: TGLMaterial);
Protected | procedure OnBitmapChanged(Sender: TObject);
Protected | procedure SetBitmap(ABitmap: TGLBitmap);

Properties

Published | property Bitmap: TGLBitmap read FBitmap write SetBitmap;
Published | property Centered: Boolean read FCentered write SetCentered;
Public | property CustomData: Pointer read FCustomData write FCustomData;
Public | property CustomObject: TObject read FCustomObject write FCustomObject;
Published | property Material: TGLMaterial read FMaterial write SetMaterial;
Published | property MaxInvalidRenderCount: Integer read FMaxInvalidRenderCount write FMaxInvalidRenderCount;
Published | property OnRender: TGLCustomRenderEvent read FOnRender write FOnRender;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public procedure SetMaterial(AMaterial: TGLMaterial);
Protected procedure OnBitmapChanged(Sender: TObject);
Protected procedure SetBitmap(ABitmap: TGLBitmap);

Properties

Published property Bitmap: TGLBitmap read FBitmap write SetBitmap;
Published property Centered: Boolean read FCentered write SetCentered;
Public property CustomData: Pointer read FCustomData write FCustomData;
Public property CustomObject: TObject read FCustomObject write FCustomObject;
Published property Material: TGLMaterial read FMaterial write SetMaterial;
Published property MaxInvalidRenderCount: Integer read FMaxInvalidRenderCount write FMaxInvalidRenderCount;
Published property OnRender: TGLCustomRenderEvent read FOnRender write FOnRender;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:11


GLScene v.1.1.2: GLWindows: Class TGLPopupMenu

Class TGLPopupMenu

Unit

GLWindows

Declaration

type TGLPopupMenu = class(TGLFocusControl)

Description

no description available, TGLFocusControl description follows
no description available, TGLBaseTextControl description follows
no description available, TGLBaseFontControl description follows
no description available, TGLBaseControl description follows
no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl
  • TGLPopupMenu

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function MouseDown(Sender: TObject; Button: TGLMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure PopUp(Px, Py: Integer);
Protected | procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected | procedure InternalMouseMove(Shift: TShiftState; X, Y: Integer); override;
Protected | procedure OnStringListChange(Sender: TObject);
Protected | procedure SetFocused(Value: Boolean); override;
Protected | procedure SetMarginSize(const val: Single);
Protected | procedure SetMenuItems(Value: TStrings);
Protected | procedure SetSelIndex(const val: Integer);

Properties

Published | property MarginSize: Single read FMarginSize write SetMarginSize;
Published | property MenuItems: TStrings read FMenuItems write SetMenuItems;
Published | property OnClick: TGLPopupMenuClick read FOnClick write FOnClick;
Published | property SelIndex: Integer read FSelIndex write SetSelIndex;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function MouseDown(Sender: TObject; Button: TGLMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public procedure DoRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public procedure PopUp(Px, Py: Integer);
Protected procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected procedure InternalMouseMove(Shift: TShiftState; X, Y: Integer); override;
Protected procedure OnStringListChange(Sender: TObject);
Protected procedure SetFocused(Value: Boolean); override;
Protected procedure SetMarginSize(const val: Single);
Protected procedure SetMenuItems(Value: TStrings);
Protected procedure SetSelIndex(const val: Integer);

Properties

Published property MarginSize: Single read FMarginSize write SetMarginSize;
Published property MenuItems: TStrings read FMenuItems write SetMenuItems;
Published property OnClick: TGLPopupMenuClick read FOnClick write FOnClick;
Published property SelIndex: Integer read FSelIndex write SetSelIndex;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:11


GLScene v.1.1.2: GLWindows: Class TGLForm

Class TGLForm

Unit

GLWindows

Declaration

type TGLForm = class(TGLBaseTextControl)

Description

no description available, TGLBaseTextControl description follows
no description available, TGLBaseFontControl description follows
no description available, TGLBaseControl description follows
no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLForm

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | function MouseUp(Sender: TObject; Button: TGLMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Protected | function GetTitleColor: TDelphiColor;
Public | procedure Close;
Public | procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure NotifyHide; override;
Public | procedure NotifyShow; override;
Protected | procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected | procedure InternalMouseMove(Shift: TShiftState; X, Y: Integer); override;
Protected | procedure InternalMouseUp(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected | procedure SetTitleColor(value: TDelphiColor);

Properties

Published | property OnCanClose: TGLFormCanClose read FOnCanClose write FOnCanClose;
Published | property OnCanMove: TGLFormCanRequest read FOnCanMove write FOnCanMove;
Published | property OnCanResize: TGLFormCanRequest read FOnCanResize write FOnCanResize;
Published | property OnHide: TGLFormNotify read FOnHide write FOnHide;
Published | property OnMoving: TGLFormMove read FOnMoving write FOnMoving;
Published | property OnShow: TGLFormNotify read FOnShow write FOnShow;
Published | property TitleColor: TDelphiColor read GetTitleColor write SetTitleColor;
Published | property TitleOffset: Single read FTitleOffset write FTitleOffset;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public function MouseUp(Sender: TObject; Button: TGLMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Protected function GetTitleColor: TDelphiColor;
Public procedure Close;
Public procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public procedure NotifyHide; override;
Public procedure NotifyShow; override;
Protected procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected procedure InternalMouseMove(Shift: TShiftState; X, Y: Integer); override;
Protected procedure InternalMouseUp(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected procedure SetTitleColor(value: TDelphiColor);

Properties

Published property OnCanClose: TGLFormCanClose read FOnCanClose write FOnCanClose;
Published property OnCanMove: TGLFormCanRequest read FOnCanMove write FOnCanMove;
Published property OnCanResize: TGLFormCanRequest read FOnCanResize write FOnCanResize;
Published property OnHide: TGLFormNotify read FOnHide write FOnHide;
Published property OnMoving: TGLFormMove read FOnMoving write FOnMoving;
Published property OnShow: TGLFormNotify read FOnShow write FOnShow;
Published property TitleColor: TDelphiColor read GetTitleColor write SetTitleColor;
Published property TitleOffset: Single read FTitleOffset write FTitleOffset;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:11


GLScene v.1.1.2: GLWindows: Class TGLPanel

Class TGLPanel

Unit

GLWindows

Declaration

type TGLPanel = class(TGLBaseControl)

Description

no description available, TGLBaseControl description follows
no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLPanel
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:11


GLScene v.1.1.2: GLWindows: Class TGLCheckBox

Class TGLCheckBox

Unit

GLWindows

Declaration

type TGLCheckBox = class(TGLBaseControl)

Description

no description available, TGLBaseControl description follows
no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLCheckBox

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected | procedure InternalMouseUp(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected | procedure SetChecked(NewChecked: Boolean);
Protected | procedure SetGroup(const val: Integer);
Protected | procedure SetGuiLayout(NewGui: TGLGuiLayout); override;
Protected | procedure SetGuiLayoutNameChecked(newName: TGLGuiComponentName);

Properties

Published | property Checked: Boolean read FChecked write SetChecked;
Published | property Group: Integer read FGroup write SetGroup;
Published | property GuiLayoutNameChecked: TGLGuiComponentName read FGuiLayoutNameChecked write SetGuiLayoutNameChecked;
Published | property OnChange: TNotifyEvent read FOnChange write FOnChange;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public procedure NotifyChange(Sender: TObject); override;
Protected procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected procedure InternalMouseUp(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected procedure SetChecked(NewChecked: Boolean);
Protected procedure SetGroup(const val: Integer);
Protected procedure SetGuiLayout(NewGui: TGLGuiLayout); override;
Protected procedure SetGuiLayoutNameChecked(newName: TGLGuiComponentName);

Properties

Published property Checked: Boolean read FChecked write SetChecked;
Published property Group: Integer read FGroup write SetGroup;
Published property GuiLayoutNameChecked: TGLGuiComponentName read FGuiLayoutNameChecked write SetGuiLayoutNameChecked;
Published property OnChange: TNotifyEvent read FOnChange write FOnChange;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:11


GLScene v.1.1.2: GLWindows: Class TGLButton

Class TGLButton

Unit

GLWindows

Declaration

type TGLButton = class(TGLFocusControl)

Description

no description available, TGLFocusControl description follows
no description available, TGLBaseTextControl description follows
no description available, TGLBaseFontControl description follows
no description available, TGLBaseControl description follows
no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl
  • TGLButton

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Protected | procedure DestroyHandle; override;
Protected | procedure InternalKeyDown(var Key: Word; Shift: TShiftState); override;
Protected | procedure InternalKeyUp(var Key: Word; Shift: TShiftState); override;
Protected | procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected | procedure InternalMouseUp(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected | procedure SetBitBtn(AValue: TGLMaterial);
Protected | procedure SetFocused(Value: Boolean); override;
Protected | procedure SetGroup(const val: Integer);
Protected | procedure SetGuiLayout(NewGui: TGLGuiLayout); override;
Protected | procedure SetGuiLayoutNamePressed(newName: TGLGuiComponentName);
Protected | procedure SetLogicHeight(const val: single);
Protected | procedure SetLogicWidth(const val: single);
Protected | procedure SetPressed(NewPressed: Boolean);
Protected | procedure SetXOffset(const val: single);
Protected | procedure SetYOffset(const val: single);

Properties

Published | property AllowUp: Boolean read FAllowUp write FAllowUp;
Published | property BitBtn: TGLMaterial read FBitBtn write SetBitBtn;
Published | property Group: Integer read FGroup write SetGroup;
Published | property GuiLayoutNamePressed: TGLGuiComponentName read FGuiLayoutNamePressed write SetGuiLayoutNamePressed;
Published | property LogicHeight: Single read FLogicHeight write SetLogicHeight;
Published | property LogicWidth: Single read FLogicWidth write SetLogicWidth;
Published | property OnButtonClick: TNotifyEvent read FOnButtonClick write FOnButtonClick;
Published | property Pressed: Boolean read FPressed write SetPressed;
Published | property XOffset: Single read FXOffset write SetXOffset;
Published | property YOffset: Single read FYOffset write SetYOffset;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Protected procedure DestroyHandle; override;
Protected procedure InternalKeyDown(var Key: Word; Shift: TShiftState); override;
Protected procedure InternalKeyUp(var Key: Word; Shift: TShiftState); override;
Protected procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected procedure InternalMouseUp(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected procedure SetBitBtn(AValue: TGLMaterial);
Protected procedure SetFocused(Value: Boolean); override;
Protected procedure SetGroup(const val: Integer);
Protected procedure SetGuiLayout(NewGui: TGLGuiLayout); override;
Protected procedure SetGuiLayoutNamePressed(newName: TGLGuiComponentName);
Protected procedure SetLogicHeight(const val: single);
Protected procedure SetLogicWidth(const val: single);
Protected procedure SetPressed(NewPressed: Boolean);
Protected procedure SetXOffset(const val: single);
Protected procedure SetYOffset(const val: single);

Properties

Published property AllowUp: Boolean read FAllowUp write FAllowUp;
Published property BitBtn: TGLMaterial read FBitBtn write SetBitBtn;
Published property Group: Integer read FGroup write SetGroup;
Published property GuiLayoutNamePressed: TGLGuiComponentName read FGuiLayoutNamePressed write SetGuiLayoutNamePressed;
Published property LogicHeight: Single read FLogicHeight write SetLogicHeight;
Published property LogicWidth: Single read FLogicWidth write SetLogicWidth;
Published property OnButtonClick: TNotifyEvent read FOnButtonClick write FOnButtonClick;
Published property Pressed: Boolean read FPressed write SetPressed;
Published property XOffset: Single read FXOffset write SetXOffset;
Published property YOffset: Single read FYOffset write SetYOffset;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:11


GLScene v.1.1.2: GLWindows: Class TGLEdit

Class TGLEdit

Unit

GLWindows

Declaration

type TGLEdit = class(TGLFocusControl)

Description

no description available, TGLFocusControl description follows
no description available, TGLBaseTextControl description follows
no description available, TGLBaseFontControl description follows
no description available, TGLBaseControl description follows
no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl
  • TGLEdit

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Protected | procedure InternalKeyDown(var Key: Word; Shift: TShiftState); override;
Protected | procedure InternalKeyPress(var Key: Char); override;
Protected | procedure InternalKeyUp(var Key: Word; Shift: TShiftState); override;
Protected | procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected | procedure SetEditChar(const Value: string);
Protected | procedure SetFocused(Value: Boolean); override;
Protected | procedure SetSelStart(const Value: Integer);

Properties

Published | property EditChar: string read FEditChar write SetEditChar;
Published | property OnChange: TNotifyEvent read FOnChange write FOnChange;
Published | property ReadOnly: Boolean read FReadOnly write FReadOnly default False;
Published | property SelStart: Integer read FSelStart write SetSelStart;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Protected procedure InternalKeyDown(var Key: Word; Shift: TShiftState); override;
Protected procedure InternalKeyPress(var Key: Char); override;
Protected procedure InternalKeyUp(var Key: Word; Shift: TShiftState); override;
Protected procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected procedure SetEditChar(const Value: string);
Protected procedure SetFocused(Value: Boolean); override;
Protected procedure SetSelStart(const Value: Integer);

Properties

Published property EditChar: string read FEditChar write SetEditChar;
Published property OnChange: TNotifyEvent read FOnChange write FOnChange;
Published property ReadOnly: Boolean read FReadOnly write FReadOnly default False;
Published property SelStart: Integer read FSelStart write SetSelStart;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:11


GLScene v.1.1.2: GLWindows: Class TGLLabel

Class TGLLabel

Unit

GLWindows

Declaration

type TGLLabel = class(TGLBaseTextControl)

Description

no description available, TGLBaseTextControl description follows
no description available, TGLBaseFontControl description follows
no description available, TGLBaseControl description follows
no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLLabel

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published | property Alignment: TAlignment read FAlignment write SetAlignment;
Published | property TextLayout: TGLTextLayout read FTextLayout write SetTextLayout;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Properties

Published property Alignment: TAlignment read FAlignment write SetAlignment;
Published property TextLayout: TGLTextLayout read FTextLayout write SetTextLayout;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:11


GLScene v.1.1.2: GLWindows: Class TGLAdvancedLabel

Class TGLAdvancedLabel

Unit

GLWindows

Declaration

type TGLAdvancedLabel = class(TGLFocusControl)

Description

no description available, TGLFocusControl description follows
no description available, TGLBaseTextControl description follows
no description available, TGLBaseFontControl description follows
no description available, TGLBaseControl description follows
no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl
  • TGLAdvancedLabel

Overview

Methods

Public procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;

Description

Methods

Public procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:11


GLScene v.1.1.2: GLWindows: Class TGLScrollbar

Class TGLScrollbar

Unit

GLWindows

Declaration

type TGLScrollbar = class(TGLFocusControl)

Description

no description available, TGLFocusControl description follows
no description available, TGLBaseTextControl description follows
no description available, TGLBaseFontControl description follows
no description available, TGLBaseControl description follows
no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl
  • TGLScrollbar

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public | function MouseUp(Sender: TObject; Button: TGLMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Protected | function GetScrollPosX(ScrollPos: Single): Single;
Protected | function GetScrollPosY(ScrollPos: Single): Single;
Protected | function GetXScrollPos(X: Single): Single;
Protected | function GetYScrollPos(Y: Single): Single;
Public | procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure PageDown;
Public | procedure PageUp;
Public | procedure StepDown;
Public | procedure StepUp;
Protected | procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected | procedure InternalMouseMove(Shift: TShiftState; X, Y: Integer); override;
Protected | procedure InternalMouseUp(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected | procedure SetGuiLayout(NewGui: TGLGuiLayout); override;
Protected | procedure SetGuiLayoutKnobName(newName: TGLGuiComponentName);
Protected | procedure SetHorizontal(const val: Boolean);
Protected | procedure SetMax(const val: Single);
Protected | procedure SetMin(const val: Single);
Protected | procedure SetPageSize(const val: Single);
Protected | procedure SetPos(const val: Single);

Properties

Published | property GuiLayoutKnobName: TGLGuiComponentName read FGuiLayoutKnobName write SetGuiLayoutKnobName;
Published | property Horizontal: Boolean read FHorizontal write SetHorizontal;
Published | property Locked: Boolean read FLocked write FLocked default False;
Published | property Max: Single read FMax write SetMax;
Published | property Min: Single read FMin write SetMin;
Published | property OnChange: TNotifyEvent read FOnChange write FOnChange;
Published | property PageSize: Single read FPageSize write SetPageSize;
Published | property Pos: Single read FPos write SetPos;
Published | property Step: Single read FStep write FStep;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public function MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer): Boolean; override;
Public function MouseUp(Sender: TObject; Button: TGLMouseButton; Shift: TShiftState; X, Y: Integer): Boolean; override;
Protected function GetScrollPosX(ScrollPos: Single): Single;
Protected function GetScrollPosY(ScrollPos: Single): Single;
Protected function GetXScrollPos(X: Single): Single;
Protected function GetYScrollPos(Y: Single): Single;
Public procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public procedure PageDown;
Public procedure PageUp;
Public procedure StepDown;
Public procedure StepUp;
Protected procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected procedure InternalMouseMove(Shift: TShiftState; X, Y: Integer); override;
Protected procedure InternalMouseUp(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected procedure SetGuiLayout(NewGui: TGLGuiLayout); override;
Protected procedure SetGuiLayoutKnobName(newName: TGLGuiComponentName);
Protected procedure SetHorizontal(const val: Boolean);
Protected procedure SetMax(const val: Single);
Protected procedure SetMin(const val: Single);
Protected procedure SetPageSize(const val: Single);
Protected procedure SetPos(const val: Single);

Properties

Published property GuiLayoutKnobName: TGLGuiComponentName read FGuiLayoutKnobName write SetGuiLayoutKnobName;
Published property Horizontal: Boolean read FHorizontal write SetHorizontal;
Published property Locked: Boolean read FLocked write FLocked default False;
Published property Max: Single read FMax write SetMax;
Published property Min: Single read FMin write SetMin;
Published property OnChange: TNotifyEvent read FOnChange write FOnChange;
Published property PageSize: Single read FPageSize write SetPageSize;
Published property Pos: Single read FPos write SetPos;
Published property Step: Single read FStep write FStep;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:11


GLScene v.1.1.2: GLWindows: Class TGLStringGrid

Class TGLStringGrid

Unit

GLWindows

Declaration

type TGLStringGrid = class(TGLFocusControl)

Description

no description available, TGLFocusControl description follows
no description available, TGLBaseTextControl description follows
no description available, TGLBaseFontControl description follows
no description available, TGLBaseControl description follows
no description available, TGLBaseComponent description follows
no description available, TGLBaseGuiObject description follows
no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLBaseGuiObject
  • TGLBaseComponent
  • TGLBaseControl
  • TGLBaseFontControl
  • TGLBaseTextControl
  • TGLFocusControl
  • TGLStringGrid

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function Add(Data: array of string): Integer; overload;
Public | function Add(const Data: string): Integer; overload;
Protected | function GetCell(X, Y: Integer; out oCol, oRow: Integer): Boolean;
Protected | function GetHeaderColor: TDelphiColor;
Protected | function GetRow(index: Integer): TStringList;
Protected | function GetRowCount: Integer;
Public | procedure Clear;
Public | procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public | procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public | procedure NotifyChange(Sender: TObject); override;
Public | procedure OnStringListChange(Sender: TObject);
Public | procedure SetText(Data: string);
Protected | procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected | procedure SetColSelect(const val: Boolean);
Protected | procedure SetColumns(const val: TStrings);
Protected | procedure SetColumnSize(const val: Integer);
Protected | procedure SetDrawHeader(const val: Boolean);
Protected | procedure SetGuiLayout(NewGui: TGLGuiLayout); override;
Protected | procedure SetHeaderColor(const val: TDelphiColor);
Protected | procedure SetMarginSize(const val: Integer);
Protected | procedure SetRow(index: Integer; const val: TStringList);
Protected | procedure SetRowCount(const val: Integer);
Protected | procedure SetRowHeight(const val: Integer);
Protected | procedure SetRowSelect(const val: Boolean);
Protected | procedure SetScrollbar(const val: TGLScrollbar);
Protected | procedure SetSelCol(const val: Integer);
Protected | procedure SetSelRow(const val: Integer);

Properties

Published | property ColSelect: Boolean read FColSelect write SetColSelect;
Published | property Columns: TStrings read FColumns write SetColumns;
Published | property ColumnSize: Integer read FColumnSize write SetColumnSize;
Published | property DrawHeader: Boolean read FDrawHeader write SetDrawHeader;
Published | property HeaderColor: TDelphiColor read GetHeaderColor write SetHeaderColor;
Published | property MarginSize: Integer read FMarginSize write SetMarginSize;
Public | property Row[index: Integer]: TStringList read GetRow write SetRow;
Published | property RowCount: Integer read GetRowCount write SetRowCount;
Published | property RowHeight: Integer read FRowHeight write SetRowHeight;
Published | property RowSelect: Boolean read FRowSelect write SetRowSelect;
Published | property Scrollbar: TGLScrollbar read FScrollbar write SetScrollbar;
Published | property SelCol: Integer read FSelCol write SetSelCol;
Published | property SelRow: Integer read FSelRow write SetSelRow;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function Add(Data: array of string): Integer; overload;
Public function Add(const Data: string): Integer; overload;
Protected function GetCell(X, Y: Integer; out oCol, oRow: Integer): Boolean;
Protected function GetHeaderColor: TDelphiColor;
Protected function GetRow(index: Integer): TStringList;
Protected function GetRowCount: Integer;
Public procedure Clear;
Public procedure InternalRender(var rci: TRenderContextInfo; renderSelf, renderChildren: Boolean); override;
Public procedure Notification(AComponent: TComponent; Operation: TOperation); override;
Public procedure NotifyChange(Sender: TObject); override;
Public procedure OnStringListChange(Sender: TObject);
Public procedure SetText(Data: string);
Protected procedure InternalMouseDown(Shift: TShiftState; Button: TGLMouseButton; X, Y: Integer); override;
Protected procedure SetColSelect(const val: Boolean);
Protected procedure SetColumns(const val: TStrings);
Protected procedure SetColumnSize(const val: Integer);
Protected procedure SetDrawHeader(const val: Boolean);
Protected procedure SetGuiLayout(NewGui: TGLGuiLayout); override;
Protected procedure SetHeaderColor(const val: TDelphiColor);
Protected procedure SetMarginSize(const val: Integer);
Protected procedure SetRow(index: Integer; const val: TStringList);
Protected procedure SetRowCount(const val: Integer);
Protected procedure SetRowHeight(const val: Integer);
Protected procedure SetRowSelect(const val: Boolean);
Protected procedure SetScrollbar(const val: TGLScrollbar);
Protected procedure SetSelCol(const val: Integer);
Protected procedure SetSelRow(const val: Integer);

Properties

Published property ColSelect: Boolean read FColSelect write SetColSelect;
Published property Columns: TStrings read FColumns write SetColumns;
Published property ColumnSize: Integer read FColumnSize write SetColumnSize;
Published property DrawHeader: Boolean read FDrawHeader write SetDrawHeader;
Published property HeaderColor: TDelphiColor read GetHeaderColor write SetHeaderColor;
Published property MarginSize: Integer read FMarginSize write SetMarginSize;
Public property Row[index: Integer]: TStringList read GetRow write SetRow;
Published property RowCount: Integer read GetRowCount write SetRowCount;
Published property RowHeight: Integer read FRowHeight write SetRowHeight;
Published property RowSelect: Boolean read FRowSelect write SetRowSelect;
Published property Scrollbar: TGLScrollbar read FScrollbar write SetScrollbar;
Published property SelCol: Integer read FSelCol write SetSelCol;
Published property SelRow: Integer read FSelRow write SetSelRow;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:12


GLScene v.1.1.2: GLWindowsFont

Unit GLWindowsFont

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GLWindowsFont<p>

TFont Import into a BitmapFont using variable width...<p>

<b>History : </b><font size=-1><ul> <li>29/05/11 - Yar - Unicode support for Unix OSes (by Gabriel Corneanu) <li>16/05/11 - Yar - Redesign to use multiple textures (by Gabriel Corneanu) <li>13/05/11 - Yar - Adapted to unicode (by Gabriel Corneanu) <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>06/06/10 - Yar - Added VectorTypes to uses <li>25/01/10 - Yar - Bugfix in LoadWindowsFont with zero width of char (thanks olkondr) Replace Char to AnsiChar <li>11/11/09 - DaStr - Added Delphi 2009 compatibility (thanks mal) <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTracekrID=1681585) <li>12/15/04 - Eugene Kryukov - Added TGLStoredBitmapFont <li>03/07/04 - LR - Added ifdef for Graphics uses <li>29/09/02 - EG - Fixed transparency, style fixes, prop defaults fixed, dropped interface dependency, texture size auto computed, fixed italics spacing, uses LUM+ALPHA texture <li>06/09/02 - JAJ - Fixed alot of bugs... Expecially designtime updating bugs.. <li>12/08/02 - JAJ - Made into a standalone unit... </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLWindowsBitmapFont |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:12


GLScene v.1.1.2: GLWindowsFont: Class TGLWindowsBitmapFont

Class TGLWindowsBitmapFont

Unit

GLWindowsFont

Declaration

type TGLWindowsBitmapFont = class(TGLCustomBitmapFont)

Description

A bitmap font automatically built from a TFont.<p> It works like a TGLBitmapfont, you set ranges and which chars are assigned to which indexes, however here you also set the Font property to any TFont available to the system and it renders in GLScene as close to that font as posible, on some font types this is 100% on some a slight difference in spacing can occur at most 1 pixel per char on some char combinations.<p> Ranges must be sorted in ascending ASCII order and should not overlap. As the font texture is automatically layed out, the Ranges StartGlyphIdx property is ignored and replaced appropriately.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCustomBitmapFont
  • TGLWindowsBitmapFont

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function FontTextureHeight: Integer;
Public | function FontTextureWidth: Integer;
Protected | function StoreRanges: Boolean;
Protected | function TextureFormat: Integer; override;
Public | procedure EnsureChars(const AStart, AEnd: widechar);
Public | procedure EnsureString(const s : UnicodeString); overload;
Public | procedure NotifyChange(Sender: TObject); override;
Protected | procedure LoadWindowsFont; virtual;
Protected | procedure PrepareImage(var ARci: TRenderContextInfo); override;
Protected | procedure SetFont(value: TFont);
Protected | procedure StreamlineRanges;

Properties

Published | property Font: TFont read FFont write SetFont;
Public | property Glyphs;
Published | property HSpace;
Published | property MagFilter;
Published | property MinFilter;
Published | property Ranges stored StoreRanges;
Published | property VSpace;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function FontTextureHeight: Integer;
Public function FontTextureWidth: Integer;
Protected function StoreRanges: Boolean;
Protected function TextureFormat: Integer; override;
Public procedure EnsureChars(const AStart, AEnd: widechar);
Public procedure EnsureString(const s : UnicodeString); overload;
Public procedure NotifyChange(Sender: TObject); override;
Protected procedure LoadWindowsFont; virtual;
Protected procedure PrepareImage(var ARci: TRenderContextInfo); override;
Protected procedure SetFont(value: TFont);
Protected procedure StreamlineRanges;

Properties

Published property Font: TFont read FFont write SetFont;

The font used to prepare the texture.<p> Note: the font color is ignored.

Public property Glyphs;
Published property HSpace;
Published property MagFilter;
Published property MinFilter;
Published property Ranges stored StoreRanges;
Published property VSpace;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:12


GLScene v.1.1.2: GLzBuffer

Unit GLzBuffer

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EZBufferException |
Class TGLzBuffer |
Class TGLZShadows |

Types

TZArray = array[0..MaxInt shr 3] of Single;
PZArray = ˆTZArray;
TZArrayIdx = array of PZArray;
TAArray = array[0..MaxInt shr 3] of Byte;
PAArray = ˆTAArray;
TAArrayIdx = array of PAArray;
TOptimise = (...);

Description

Types

TZArray = array[0..MaxInt shr 3] of Single;
PZArray = ˆTZArray;
TZArrayIdx = array of PZArray;
TAArray = array[0..MaxInt shr 3] of Byte;
PAArray = ˆTAArray;
TAArrayIdx = array of PAArray;
TOptimise = (...);
Values
  • opNone:
  • op4in1:
  • op9in1:
  • op16in1:
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:12


GLScene v.1.1.2: GLzBuffer: Class EZBufferException

Class EZBufferException

Unit

GLzBuffer

Declaration

type EZBufferException = class(Exception)

Description

Hierarchy

  • Exception
  • EZBufferException
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:12


GLScene v.1.1.2: GLzBuffer: Class TGLzBuffer

Class TGLzBuffer

Unit

GLzBuffer

Declaration

type TGLzBuffer = class(TPersistent)

Description

Hierarchy

  • TPersistent
  • TGLzBuffer

Overview

Fields

Public | SceneViewer: TGLSceneViewer;
Public | MemoryViewer: TGLMemoryViewer;
Public | Buffer: TGLSceneBuffer;
Public | Normal: TAffineVector;

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function FastScreenToVector(x, y: Integer): TAffineVector;
Public | function FastVectorToScreen(vec: TAffineVector): TAffineVector;
Public | function GetDepthBuffer(CalcVectors: Boolean; ContextIsActive: boolean): PZArray;
Public | function GetPixelzDepth(x, y: integer): Single;
Public | function OrthWorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: single; out pixZ: single): boolean;
Public | function PixelToDistance(x, y: integer): Single;
Public | function PixelToDistance_OLD(x, y: integer): Single;
Public | function PixelToWorld(const x, y: Integer): TAffineVector;
Public | function WorldToPixel(const aPoint: TAffineVector; out pixX, pixY: integer; out pixZ: single): boolean;
Public | function WorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: integer; out pixZ: single): boolean; overload;
Public | function WorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: single; out pixZ: single): boolean; overload;
Public | procedure LinkToViewer(viewer: TGLMemoryViewer); overload;
Public | procedure LinkToViewer(viewer: TGLSceneViewer); overload;
Public | procedure Refresh;
Protected | procedure PrepareBufferMemory;
Protected | procedure SetHeight(const val: Integer);
Protected | procedure SetWidth(val: Integer);

Properties

Public | property Data: PZArray read FData;
Public | property DataIdx: TZArrayIdx read FDataIdx;
Public | property DataInvIdx: TZArrayIdx read FDataIdx;
Public | property DataSize: Integer read FDataSize;
Public | property Height: Integer read FHeight write SetHeight;
Public | property Width: Integer read FWidth write SetWidth;

Description

Fields

Public SceneViewer: TGLSceneViewer;
Public MemoryViewer: TGLMemoryViewer;
Public Buffer: TGLSceneBuffer;
Public Normal: TAffineVector;

Methods

Public constructor Create;
Public destructor Destroy; override;
Public function FastScreenToVector(x, y: Integer): TAffineVector;
Public function FastVectorToScreen(vec: TAffineVector): TAffineVector;
Public function GetDepthBuffer(CalcVectors: Boolean; ContextIsActive: boolean): PZArray;
Public function GetPixelzDepth(x, y: integer): Single;
Public function OrthWorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: single; out pixZ: single): boolean;
Public function PixelToDistance(x, y: integer): Single;
Public function PixelToDistance_OLD(x, y: integer): Single;
Public function PixelToWorld(const x, y: Integer): TAffineVector;
Public function WorldToPixel(const aPoint: TAffineVector; out pixX, pixY: integer; out pixZ: single): boolean;
Public function WorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: integer; out pixZ: single): boolean; overload;
Public function WorldToPixelZ(const aPoint: TAffineVector; out pixX, pixY: single; out pixZ: single): boolean; overload;
Public procedure LinkToViewer(viewer: TGLMemoryViewer); overload;
Public procedure LinkToViewer(viewer: TGLSceneViewer); overload;
Public procedure Refresh;
Protected procedure PrepareBufferMemory;
Protected procedure SetHeight(const val: Integer);
Protected procedure SetWidth(val: Integer);

Properties

Public property Data: PZArray read FData;
Public property DataIdx: TZArrayIdx read FDataIdx;
Public property DataInvIdx: TZArrayIdx read FDataIdx;
Public property DataSize: Integer read FDataSize;
Public property Height: Integer read FHeight write SetHeight;
Public property Width: Integer read FWidth write SetWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:12


GLScene v.1.1.2: GLzBuffer: Class TGLZShadows

Class TGLZShadows

Unit

GLzBuffer

Declaration

type TGLZShadows = class(TGLBaseSceneObject)

Description

no description available, TGLBaseSceneObject description follows

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

Hierarchy

  • TComponent
  • TGLComponent
  • TGLCadenceAbleComponent
  • TGLUpdateAbleComponent
  • TGLCoordinatesUpdateAbleComponent
  • TGLBaseSceneObject
  • TGLZShadows

Overview

Fields

Public | ViewerZBuf: TGLzBuffer;
Public | CasterZBuf: TGLzBuffer;

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Published | function CastShadow: boolean;
Protected | function GetCaster: TGLMemoryViewer;
Protected | function GetViewer: TGLSceneViewer;
Protected | function HardSet(const x, y: integer): Byte;
Protected | function SoftTest(const x, y: integer): Byte;
Public | procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected | procedure BindTexture;
Protected | procedure CalcShadowTexture(var rci: TRenderContextInfo);
Protected | procedure PrepareAlphaMemory;
Protected | procedure SetCaster(const val: TGLMemoryViewer);
Protected | procedure SetHeight(const val: integer);
Protected | procedure SetSoft(const val: boolean);
Protected | procedure SetViewer(const val: TGLSceneViewer);
Protected | procedure SetWidth(const val: integer);
Protected | procedure SetXRes(const val: integer);
Protected | procedure SetYRes(const val: integer);

Properties

Published | property Caster: TGLMemoryViewer read GetCaster write SetCaster;
Published | property Color: TGLColor read FColor write FColor;
Published | property DepthFade: Boolean read FDepthFade write FDepthFade;
Published | property FrustShadow: Boolean read FFrustShadow write FFrustShadow;
Published | property Height: integer read FHeight write SetHeight;
Published | property ObjectsSorting;
Published | property Optimise: TOptimise read FOptimise write FOptimise;
Published | property SkyShadow: Boolean read FSkyShadow write FSkyShadow;
Published | property Soft: Boolean read Fsoft write SetSoft;
Published | property Tolerance: single read FTolerance write FTolerance;
Published | property Viewer: TGLSceneViewer read GetViewer write SetViewer;
Published | property Visible;
Published | property Width: integer read FWidth write SetWidth;

Description

Fields

Public ViewerZBuf: TGLzBuffer;
Public CasterZBuf: TGLzBuffer;

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Published function CastShadow: boolean;
Protected function GetCaster: TGLMemoryViewer;
Protected function GetViewer: TGLSceneViewer;
Protected function HardSet(const x, y: integer): Byte;
Protected function SoftTest(const x, y: integer): Byte;
Public procedure DoRender(var ARci: TRenderContextInfo; ARenderSelf, ARenderChildren: Boolean); override;
Protected procedure BindTexture;
Protected procedure CalcShadowTexture(var rci: TRenderContextInfo);
Protected procedure PrepareAlphaMemory;
Protected procedure SetCaster(const val: TGLMemoryViewer);
Protected procedure SetHeight(const val: integer);
Protected procedure SetSoft(const val: boolean);
Protected procedure SetViewer(const val: TGLSceneViewer);
Protected procedure SetWidth(const val: integer);
Protected procedure SetXRes(const val: integer);
Protected procedure SetYRes(const val: integer);

Properties

Published property Caster: TGLMemoryViewer read GetCaster write SetCaster;
Published property Color: TGLColor read FColor write FColor;
Published property DepthFade: Boolean read FDepthFade write FDepthFade;
Published property FrustShadow: Boolean read FFrustShadow write FFrustShadow;
Published property Height: integer read FHeight write SetHeight;
Published property ObjectsSorting;
Published property Optimise: TOptimise read FOptimise write FOptimise;
Published property SkyShadow: Boolean read FSkyShadow write FSkyShadow;
Published property Soft: Boolean read Fsoft write SetSoft;
Published property Tolerance: single read FTolerance write FTolerance;
Published property Viewer: TGLSceneViewer read GetViewer write SetViewer;
Published property Visible;
Published property Width: integer read FWidth write SetWidth;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:12


GLScene v.1.1.2: GuiSkinEditorFormUnit

Unit GuiSkinEditorFormUnit

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GuiSkinEditorFormUnit<p>

Editor for Gui skin.<p>

<b>Historique : </b><font size=-1><ul> <li>16/03/11 - Yar - Fixes after emergence of GLMaterialEx <li>04/03/10 - DanB - Now uses CharInSet <li>05/10/08 - DanB - removed Kylix support, changed uses clause <li>07/06/08 - DaStr - Updated TGUISkinEditor.AddElement() to use SetPoint2D() (thanks Nicoara Adrian) <li>29/03/07 - DaStr - Renamed LINUX to KYLIX (BugTrackerID=1681585) <li>18/02/07 - DaStr - Fixed range check error. <li>22/02/05 - Mathx - Fixed Delphi 5 support. <li>16/12/05 - aidave - moved GUIComponentDialog in from GLGui.pas<br> <li>03/10/05 - adirex - XP styles and panels problem<br> <li>24/01/05 - adirex - Focus rect for selection<br> Huge editor enchancements. Too many to write them all :) <li>03/07/04 - LR - Make change for Linux <li>?/?/? - - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGUISkinEditor |

Functions and Procedures

function GUIComponentDialog(GuiComponent: TGLGuiElementList): Boolean;

Variables

GUISkinEditor: TGUISkinEditor;

Description

Functions and Procedures

function GUIComponentDialog(GuiComponent: TGLGuiElementList): Boolean;

Variables

GUISkinEditor: TGUISkinEditor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:12


GLScene v.1.1.2: GuiSkinEditorFormUnit: Class TGUISkinEditor

Class TGUISkinEditor

Unit

GuiSkinEditorFormUnit

Declaration

type TGUISkinEditor = class(TForm)

Description

Hierarchy

  • TForm
  • TGUISkinEditor

Overview

Fields

Published | GLScene1: TGLScene;
Published | GLCamera1: TGLCamera;
Published | GLPanel1: TGLPanel;
Published | HUDSprite1: TGLHUDSprite;
Published | GLMemoryViewer1: TGLMemoryViewer;
Published | GLLightSource1: TGLLightSource;
Published | StatusBar: TStatusBar;
Published | panBottom: TPanel;
Published | panZoomImage: TPanel;
Published | imgFull: TImage;
Published | sbarHorizontal: TScrollBar;
Published | sbarVertical: TScrollBar;
Published | Button5: TButton;
Published | Button6: TButton;
Published | panImageProperties: TPanel;
Published | Label5: TLabel;
Published | Label6: TLabel;
Published | Panel2: TPanel;
Published | imgPreview: TImage;
Published | Panel3: TPanel;
Published | Label2: TLabel;
Published | Label1: TLabel;
Published | Button3: TButton;
Published | Button4: TButton;
Published | CheckBox1: TCheckBox;
Published | WidthEdit: TEdit;
Published | HeightEdit: TEdit;
Published | panElements: TPanel;
Published | Bevel2: TBevel;
Published | Bevel1: TBevel;
Published | Label3: TLabel;
Published | Label4: TLabel;
Published | Label11: TLabel;
Published | Label12: TLabel;
Published | Label13: TLabel;
Published | Label9: TLabel;
Published | Label10: TLabel;
Published | Label14: TLabel;
Published | lbElements: TListBox;
Published | btnAdd: TButton;
Published | btnDelete: TButton;
Published | ComboBox1: TComboBox;
Published | LeftEdit: TEdit;
Published | TopEdit: TEdit;
Published | RightEdit: TEdit;
Published | BottomEdit: TEdit;
Published | ScaleXEdit: TEdit;
Published | ScaleYEdit: TEdit;
Published | popElements: TPopupMenu;
Published | mnuTopLeft: TMenuItem;
Published | mnuTop: TMenuItem;
Published | mnuTopRight: TMenuItem;
Published | mnuLeft: TMenuItem;
Published | mnuCenter: TMenuItem;
Published | mnuRight: TMenuItem;
Published | mnuBottomLeft: TMenuItem;
Published | mnuBottom: TMenuItem;
Published | mnuBottomRight: TMenuItem;
Published | N1: TMenuItem;
Published | mnuAddAll: TMenuItem;
Published | N2: TMenuItem;
Published | mnuAllTop: TMenuItem;
Published | mnuAllMiddle: TMenuItem;
Published | mnuAllBottom: TMenuItem;
Public | TheGuiComponent: TGLGuiElementList;
Public | SelectedElement: TGLGUIElement;
Public | Tex: TGLTexture;
Public | Zoom: Single;
Public | Width: Integer;
Public | Height: Integer;

Methods

Public | function Edit(GuiComponent: TGLGuiElementList): Boolean;
Published | procedure BottomEditChange(Sender: TObject);
Published | procedure btnAddClick(Sender: TObject);
Published | procedure btnDeleteClick(Sender: TObject);
Published | procedure Button3Click(Sender: TObject);
Published | procedure Button4Click(Sender: TObject);
Published | procedure CheckBox1Click(Sender: TObject);
Published | procedure ComboBox1Change(Sender: TObject);
Published | procedure EditKeyPress(Sender: TObject; var Key: Char);
Published | procedure FormCreate(Sender: TObject);
Published | procedure FormDestroy(Sender: TObject);
Published | procedure FormResize(Sender: TObject);
Published | procedure HeightEditChange(Sender: TObject);
Published | procedure imgFullMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure imgFullMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published | procedure imgFullMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure imgPreviewMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure imgPreviewMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published | procedure lbElementsClick(Sender: TObject);
Published | procedure lbElementsKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);
Published | procedure LeftEditChange(Sender: TObject);
Published | procedure MenuItemClick(Sender: TObject);
Published | procedure mnuAddAllClick(Sender: TObject);
Published | procedure mnuAllBottomClick(Sender: TObject);
Published | procedure mnuAllMiddleClick(Sender: TObject);
Published | procedure mnuAllTopClick(Sender: TObject);
Published | procedure RightEditChange(Sender: TObject);
Published | procedure ScaleXEditChange(Sender: TObject);
Published | procedure ScaleYEditChange(Sender: TObject);
Published | procedure ScrollbarChange(Sender: TObject);
Published | procedure ScrollBarScroll(Sender: TObject; ScrollCode: TScrollCode; var ScrollPos: Integer);
Published | procedure TopEditChange(Sender: TObject);
Published | procedure WidthEditChange(Sender: TObject);
Public | procedure Render;
Public | procedure SetMax(Scrollbar: TScrollbar; Val: Integer);

Description

Fields

Published GLScene1: TGLScene;
Published GLCamera1: TGLCamera;
Published GLPanel1: TGLPanel;
Published HUDSprite1: TGLHUDSprite;
Published GLMemoryViewer1: TGLMemoryViewer;
Published GLLightSource1: TGLLightSource;
Published StatusBar: TStatusBar;
Published panBottom: TPanel;
Published panZoomImage: TPanel;
Published imgFull: TImage;
Published sbarHorizontal: TScrollBar;
Published sbarVertical: TScrollBar;
Published Button5: TButton;
Published Button6: TButton;
Published panImageProperties: TPanel;
Published Label5: TLabel;
Published Label6: TLabel;
Published Panel2: TPanel;
Published imgPreview: TImage;
Published Panel3: TPanel;
Published Label2: TLabel;
Published Label1: TLabel;
Published Button3: TButton;
Published Button4: TButton;
Published CheckBox1: TCheckBox;
Published WidthEdit: TEdit;
Published HeightEdit: TEdit;
Published panElements: TPanel;
Published Bevel2: TBevel;
Published Bevel1: TBevel;
Published Label3: TLabel;
Published Label4: TLabel;
Published Label11: TLabel;
Published Label12: TLabel;
Published Label13: TLabel;
Published Label9: TLabel;
Published Label10: TLabel;
Published Label14: TLabel;
Published lbElements: TListBox;
Published btnAdd: TButton;
Published btnDelete: TButton;
Published ComboBox1: TComboBox;
Published LeftEdit: TEdit;
Published TopEdit: TEdit;
Published RightEdit: TEdit;
Published BottomEdit: TEdit;
Published ScaleXEdit: TEdit;
Published ScaleYEdit: TEdit;
Published popElements: TPopupMenu;
Published mnuTopLeft: TMenuItem;
Published mnuTop: TMenuItem;
Published mnuTopRight: TMenuItem;
Published mnuLeft: TMenuItem;
Published mnuCenter: TMenuItem;
Published mnuRight: TMenuItem;
Published mnuBottomLeft: TMenuItem;
Published mnuBottom: TMenuItem;
Published mnuBottomRight: TMenuItem;
Published N1: TMenuItem;
Published mnuAddAll: TMenuItem;
Published N2: TMenuItem;
Published mnuAllTop: TMenuItem;
Published mnuAllMiddle: TMenuItem;
Published mnuAllBottom: TMenuItem;
Public TheGuiComponent: TGLGuiElementList;
Public SelectedElement: TGLGUIElement;
Public Tex: TGLTexture;
Public Zoom: Single;
Public Width: Integer;
Public Height: Integer;

Methods

Public function Edit(GuiComponent: TGLGuiElementList): Boolean;
Published procedure BottomEditChange(Sender: TObject);
Published procedure btnAddClick(Sender: TObject);
Published procedure btnDeleteClick(Sender: TObject);
Published procedure Button3Click(Sender: TObject);
Published procedure Button4Click(Sender: TObject);
Published procedure CheckBox1Click(Sender: TObject);
Published procedure ComboBox1Change(Sender: TObject);
Published procedure EditKeyPress(Sender: TObject; var Key: Char);
Published procedure FormCreate(Sender: TObject);
Published procedure FormDestroy(Sender: TObject);
Published procedure FormResize(Sender: TObject);
Published procedure HeightEditChange(Sender: TObject);
Published procedure imgFullMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure imgFullMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published procedure imgFullMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure imgPreviewMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure imgPreviewMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published procedure lbElementsClick(Sender: TObject);
Published procedure lbElementsKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);
Published procedure LeftEditChange(Sender: TObject);
Published procedure MenuItemClick(Sender: TObject);
Published procedure mnuAddAllClick(Sender: TObject);
Published procedure mnuAllBottomClick(Sender: TObject);
Published procedure mnuAllMiddleClick(Sender: TObject);
Published procedure mnuAllTopClick(Sender: TObject);
Published procedure RightEditChange(Sender: TObject);
Published procedure ScaleXEditChange(Sender: TObject);
Published procedure ScaleYEditChange(Sender: TObject);
Published procedure ScrollbarChange(Sender: TObject);
Published procedure ScrollBarScroll(Sender: TObject; ScrollCode: TScrollCode; var ScrollPos: Integer);
Published procedure TopEditChange(Sender: TObject);
Published procedure WidthEditChange(Sender: TObject);
Public procedure Render;
Public procedure SetMax(Scrollbar: TScrollbar; Val: Integer);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:12


GLScene v.1.1.2: GuiSkinEditorFormUnitLCL

Unit GuiSkinEditorFormUnitLCL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

GuiSkinEditorFormUnit<p>

Editor for Gui skin.<p>

<b>Historique : </b><font size=-1><ul> <li>26/08/10 - Yar - Fixed ImageWndProc (thnaks Predator) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGUISkinEditor |

Functions and Procedures

Function GUIComponentDialog(GuiComponent : TGLGuiElementList) : Boolean;

Variables

GUISkinEditor: TGUISkinEditor;

Description

Functions and Procedures

Function GUIComponentDialog(GuiComponent : TGLGuiElementList) : Boolean;

Variables

GUISkinEditor: TGUISkinEditor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:12


GLScene v.1.1.2: GuiSkinEditorFormUnitLCL: Class TGUISkinEditor

Class TGUISkinEditor

Unit

GuiSkinEditorFormUnitLCL

Declaration

type TGUISkinEditor = class(TForm)

Description

Hierarchy

  • TForm
  • TGUISkinEditor

Overview

Fields

Published | GLScene1: TGLScene;
Published | GLCamera1: TGLCamera;
Published | GLPanel1: TGLPanel;
Published | HUDSprite1: TGLHUDSprite;
Published | GLMemoryViewer1: TGLMemoryViewer;
Published | GLLightSource1: TGLLightSource;
Published | StatusBar: TStatusBar;
Published | panBottom: TPanel;
Published | panZoomImage: TPanel;
Published | imgFull: TImage;
Published | sbarHorizontal: TScrollBar;
Published | sbarVertical: TScrollBar;
Published | Button5: TButton;
Published | Button6: TButton;
Published | panImageProperties: TPanel;
Published | Label5: TLabel;
Published | Label6: TLabel;
Published | Panel2: TPanel;
Published | imgPreview: TImage;
Published | Panel3: TPanel;
Published | Label2: TLabel;
Published | Label1: TLabel;
Published | Button3: TButton;
Published | Button4: TButton;
Published | CheckBox1: TCheckBox;
Published | WidthEdit: TEdit;
Published | HeightEdit: TEdit;
Published | panElements: TPanel;
Published | Bevel2: TBevel;
Published | Bevel1: TBevel;
Published | Label3: TLabel;
Published | Label4: TLabel;
Published | Label11: TLabel;
Published | Label12: TLabel;
Published | Label13: TLabel;
Published | Label9: TLabel;
Published | Label10: TLabel;
Published | Label14: TLabel;
Published | lbElements: TListBox;
Published | btnAdd: TButton;
Published | btnDelete: TButton;
Published | ComboBox1: TComboBox;
Published | LeftEdit: TEdit;
Published | TopEdit: TEdit;
Published | RightEdit: TEdit;
Published | BottomEdit: TEdit;
Published | ScaleXEdit: TEdit;
Published | ScaleYEdit: TEdit;
Published | popElements: TPopupMenu;
Published | mnuTopLeft: TMenuItem;
Published | mnuTop: TMenuItem;
Published | mnuTopRight: TMenuItem;
Published | mnuLeft: TMenuItem;
Published | mnuCenter: TMenuItem;
Published | mnuRight: TMenuItem;
Published | mnuBottomLeft: TMenuItem;
Published | mnuBottom: TMenuItem;
Published | mnuBottomRight: TMenuItem;
Published | N1: TMenuItem;
Published | mnuAddAll: TMenuItem;
Published | N2: TMenuItem;
Published | mnuAllTop: TMenuItem;
Published | mnuAllMiddle: TMenuItem;
Published | mnuAllBottom: TMenuItem;
Public | TheGuiComponent: TGLGuiElementList;
Public | SelectedElement: TGLGUIElement;
Public | Tex: TGLTexture;
Public | Zoom: Single;
Public | Width: Integer;
Public | Height: Integer;

Methods

Public | Function Edit(GuiComponent : TGLGuiElementList) : Boolean;
Published | procedure BottomEditChange(Sender: TObject);
Published | procedure btnAddClick(Sender: TObject);
Published | procedure btnDeleteClick(Sender: TObject);
Published | procedure Button3Click(Sender: TObject);
Published | procedure Button4Click(Sender: TObject);
Published | procedure CheckBox1Click(Sender: TObject);
Published | procedure ComboBox1Change(Sender: TObject);
Published | procedure EditKeyPress(Sender: TObject; var Key: Char);
Published | procedure FormCreate(Sender: TObject);
Published | procedure FormDestroy(Sender: TObject);
Published | procedure FormResize(Sender: TObject);
Published | procedure HeightEditChange(Sender: TObject);
Published | procedure imgFullMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure imgFullMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published | procedure imgFullMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure imgPreviewMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published | procedure imgPreviewMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published | procedure lbElementsClick(Sender: TObject);
Published | procedure lbElementsKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);
Published | procedure LeftEditChange(Sender: TObject);
Published | procedure MenuItemClick(Sender: TObject);
Published | procedure mnuAddAllClick(Sender: TObject);
Published | procedure mnuAllBottomClick(Sender: TObject);
Published | procedure mnuAllMiddleClick(Sender: TObject);
Published | procedure mnuAllTopClick(Sender: TObject);
Published | procedure RightEditChange(Sender: TObject);
Published | procedure ScaleXEditChange(Sender: TObject);
Published | procedure ScaleYEditChange(Sender: TObject);
Published | procedure ScrollbarChange(Sender: TObject);
Published | procedure ScrollBarScroll(Sender: TObject; ScrollCode: TScrollCode; var ScrollPos: Integer);
Published | procedure TopEditChange(Sender: TObject);
Published | procedure WidthEditChange(Sender: TObject);
Public | Procedure Render;
Public | Procedure SetMax(Scrollbar : TScrollbar; Val : Integer);

Description

Fields

Published GLScene1: TGLScene;
Published GLCamera1: TGLCamera;
Published GLPanel1: TGLPanel;
Published HUDSprite1: TGLHUDSprite;
Published GLMemoryViewer1: TGLMemoryViewer;
Published GLLightSource1: TGLLightSource;
Published StatusBar: TStatusBar;
Published panBottom: TPanel;
Published panZoomImage: TPanel;
Published imgFull: TImage;
Published sbarHorizontal: TScrollBar;
Published sbarVertical: TScrollBar;
Published Button5: TButton;
Published Button6: TButton;
Published panImageProperties: TPanel;
Published Label5: TLabel;
Published Label6: TLabel;
Published Panel2: TPanel;
Published imgPreview: TImage;
Published Panel3: TPanel;
Published Label2: TLabel;
Published Label1: TLabel;
Published Button3: TButton;
Published Button4: TButton;
Published CheckBox1: TCheckBox;
Published WidthEdit: TEdit;
Published HeightEdit: TEdit;
Published panElements: TPanel;
Published Bevel2: TBevel;
Published Bevel1: TBevel;
Published Label3: TLabel;
Published Label4: TLabel;
Published Label11: TLabel;
Published Label12: TLabel;
Published Label13: TLabel;
Published Label9: TLabel;
Published Label10: TLabel;
Published Label14: TLabel;
Published lbElements: TListBox;
Published btnAdd: TButton;
Published btnDelete: TButton;
Published ComboBox1: TComboBox;
Published LeftEdit: TEdit;
Published TopEdit: TEdit;
Published RightEdit: TEdit;
Published BottomEdit: TEdit;
Published ScaleXEdit: TEdit;
Published ScaleYEdit: TEdit;
Published popElements: TPopupMenu;
Published mnuTopLeft: TMenuItem;
Published mnuTop: TMenuItem;
Published mnuTopRight: TMenuItem;
Published mnuLeft: TMenuItem;
Published mnuCenter: TMenuItem;
Published mnuRight: TMenuItem;
Published mnuBottomLeft: TMenuItem;
Published mnuBottom: TMenuItem;
Published mnuBottomRight: TMenuItem;
Published N1: TMenuItem;
Published mnuAddAll: TMenuItem;
Published N2: TMenuItem;
Published mnuAllTop: TMenuItem;
Published mnuAllMiddle: TMenuItem;
Published mnuAllBottom: TMenuItem;
Public TheGuiComponent: TGLGuiElementList;
Public SelectedElement: TGLGUIElement;
Public Tex: TGLTexture;
Public Zoom: Single;
Public Width: Integer;
Public Height: Integer;

Methods

Public Function Edit(GuiComponent : TGLGuiElementList) : Boolean;
Published procedure BottomEditChange(Sender: TObject);
Published procedure btnAddClick(Sender: TObject);
Published procedure btnDeleteClick(Sender: TObject);
Published procedure Button3Click(Sender: TObject);
Published procedure Button4Click(Sender: TObject);
Published procedure CheckBox1Click(Sender: TObject);
Published procedure ComboBox1Change(Sender: TObject);
Published procedure EditKeyPress(Sender: TObject; var Key: Char);
Published procedure FormCreate(Sender: TObject);
Published procedure FormDestroy(Sender: TObject);
Published procedure FormResize(Sender: TObject);
Published procedure HeightEditChange(Sender: TObject);
Published procedure imgFullMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure imgFullMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published procedure imgFullMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure imgPreviewMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
Published procedure imgPreviewMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Published procedure lbElementsClick(Sender: TObject);
Published procedure lbElementsKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);
Published procedure LeftEditChange(Sender: TObject);
Published procedure MenuItemClick(Sender: TObject);
Published procedure mnuAddAllClick(Sender: TObject);
Published procedure mnuAllBottomClick(Sender: TObject);
Published procedure mnuAllMiddleClick(Sender: TObject);
Published procedure mnuAllTopClick(Sender: TObject);
Published procedure RightEditChange(Sender: TObject);
Published procedure ScaleXEditChange(Sender: TObject);
Published procedure ScaleYEditChange(Sender: TObject);
Published procedure ScrollbarChange(Sender: TObject);
Published procedure ScrollBarScroll(Sender: TObject; ScrollCode: TScrollCode; var ScrollPos: Integer);
Published procedure TopEditChange(Sender: TObject);
Published procedure WidthEditChange(Sender: TObject);
Public Procedure Render;
Public Procedure SetMax(Scrollbar : TScrollbar; Val : Integer);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: HDRImage

Unit HDRImage

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

HDRImage<p> Good for preview picture in OpenDialog, so you may include both HDRImage (preview) and GLFileHDR (loading)

<li>23/10/10 - Yar - Removed PBuffer <li>23/08/10 - Yar - Changes after PBuffer upgrade <li>21/03/10 - Yar - Added Linux support (thanks to Rustam Asmandiarov aka Predator) <li>24/01/10 - Yar - Improved FPC compatibility <li>21/01/10 - Yar - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class THDRImage |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: HDRImage: Class THDRImage

Class THDRImage

Unit

HDRImage

Declaration

type THDRImage = class(TGLBitmap)

Description

no description available, TGLBitmap description follows

Hierarchy

  • THDRImage

Overview

Methods

Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public procedure LoadFromStream(stream: TStream); override;
Public procedure SaveToStream(stream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: HeightTileFile

Unit HeightTileFile

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

HeightTileFile<p>

Access to large tiled height data files.<p>

Performance vs Raw file accesses (for perfect tile match):<ul> <li>Cached data:<ul> <li>"Smooth" terrain 1:2 to 1:10 <li>Random terrain 1:1 </ul> <li>Non-cached data:<ul> <li>"Smooth" terrain 1:100 to 1:1000 <li>Random terrain 1:100 </ul> </ul><p>

<b>Historique : </b><font size=-1><ul> <li>20/05/10 - Yar - Fixes for Linux x64 <li>30/03/07 - DaStr - Added $I GLScene.inc <li>21/12/01 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record THeightTileInfo |
packed record THeightTile |
packed record THTFHeader |
Class THeightTileFile |

Types

PByte = ˆByte;
TIntegerArray = array [0..MaxInt shr 3] of Integer;
PIntegerArray = ˆTIntegerArray;
PInteger = ˆInteger;
TSmallIntArray = array [0..MaxInt shr 2] of SmallInt;
PSmallIntArray = ˆTSmallIntArray;
PSmallInt = ˆSmallInt;
TShortIntArray = array [0..MaxInt shr 2] of ShortInt;
PShortIntArray = ˆTShortIntArray;
PShortInt = ˆShortInt;
PHeightTileInfo = ˆTHeightTileInfo;
PPHeightTileInfo = ˆPHeightTileInfo;
PHeightTile = ˆTHeightTile;

Constants

cHTFHashTableSize = 1023;
cHTFQuadTableSize = 31;

Description

Types

PByte = ˆByte;
TIntegerArray = array [0..MaxInt shr 3] of Integer;
PIntegerArray = ˆTIntegerArray;
PInteger = ˆInteger;
TSmallIntArray = array [0..MaxInt shr 2] of SmallInt;
PSmallIntArray = ˆTSmallIntArray;
PSmallInt = ˆSmallInt;
TShortIntArray = array [0..MaxInt shr 2] of ShortInt;
PShortIntArray = ˆTShortIntArray;
PShortInt = ˆShortInt;
PHeightTileInfo = ˆTHeightTileInfo;
PPHeightTileInfo = ˆPHeightTileInfo;
PHeightTile = ˆTHeightTile;

Constants

cHTFHashTableSize = 1023;
cHTFQuadTableSize = 31;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: HeightTileFile: packed record THeightTileInfo

packed record THeightTileInfo

Unit

HeightTileFile

Declaration

type THeightTileInfo = packed record

Description

Overview

Fields

left: Integer;
top: Integer;
width: Integer;
height: Integer;
min: SmallInt;
max: SmallInt;
average: SmallInt;
fileOffset: Int64;

Description

Fields

left: Integer;
top: Integer;
width: Integer;
height: Integer;
min: SmallInt;
max: SmallInt;
average: SmallInt;
fileOffset: Int64;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: HeightTileFile: packed record THeightTile

packed record THeightTile

Unit

HeightTileFile

Declaration

type THeightTile = packed record

Description

Overview

Fields

info: THeightTileInfo;
data: array of SmallInt;

Description

Fields

info: THeightTileInfo;
data: array of SmallInt;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: HeightTileFile: packed record THTFHeader

packed record THTFHeader

Unit

HeightTileFile

Declaration

type THTFHeader = packed record

Description

Overview

Fields

FileVersion: array [0..5] of AnsiChar;
TileIndexOffset: Int64;
SizeX: Integer;
SizeY: Integer;
TileSize: Integer;
DefaultZ: SmallInt;

Description

Fields

FileVersion: array [0..5] of AnsiChar;
TileIndexOffset: Int64;
SizeX: Integer;
SizeY: Integer;
TileSize: Integer;
DefaultZ: SmallInt;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: HeightTileFile: Class THeightTileFile

Class THeightTileFile

Unit

HeightTileFile

Declaration

type THeightTileFile = class(TObject)

Description

Interfaces a Tiled file

Hierarchy

  • TObject
  • THeightTileFile

Overview

Methods

Public | constructor Create(const fileName : String);
Public | constructor CreateNew(const fileName : String; aSizeX, aSizeY, aTileSize : Integer);
Public | destructor Destroy; override;
Public | function GetTile(aLeft, aTop : Integer; pTileInfo : PPHeightTileInfo = nil) : PHeightTile;
Public | function GetTileIndex(aLeft, aTop : Integer) : Integer;
Public | function IndexOfTile(aTile : PHeightTileInfo) : Integer;
Public | function TileCompressedSize(tileIndex : Integer) : Integer;
Public | function TileCount : Integer;
Public | function XYHeight(anX, anY : Integer) : SmallInt;
Public | function XYTileInfo(anX, anY : Integer) : PHeightTileInfo;
Protected | function GetTiles(index : Integer) : PHeightTileInfo;
Protected | function QuadTableX(x : Integer) : Integer;
Protected | function QuadTableY(y : Integer) : Integer;
Public | procedure CompressTile(aLeft, aTop, aWidth, aHeight : Integer; aData : PSmallIntArray);
Public | procedure ExtractRow(x, y, len : Integer; dest : PSmallIntArray);
Public | procedure TilesInRect(aLeft, aTop, aRight, aBottom : Integer; destList : TList);
Protected | procedure PackTile(aWidth, aHeight : Integer; src : PSmallIntArray);
Protected | procedure UnPackTile(source : PShortIntArray);

Properties

Public | property DefaultZ : SmallInt read FHeader.DefaultZ write FHeader.DefaultZ;
Public | property SizeX : Integer read FHeader.SizeX;
Public | property SizeY : Integer read FHeader.SizeY;
Protected | property TileIndexOffset : Int64 read FHeader.TileIndexOffset write FHeader.TileIndexOffset;
Public | property Tiles[index : Integer]: PHeightTileInfo read GetTiles;
Public | property TileSize : Integer read FHeader.TileSize;

Description

Methods

Public constructor Create(const fileName : String);
Public constructor CreateNew(const fileName : String; aSizeX, aSizeY, aTileSize : Integer);

Creates a new HTF file.<p> Read and data access methods are not available when creating.

Public destructor Destroy; override;
Public function GetTile(aLeft, aTop : Integer; pTileInfo : PPHeightTileInfo = nil) : PHeightTile;

Returns tile of corresponding left/top.<p>

Public function GetTileIndex(aLeft, aTop : Integer) : Integer;

Returns tile index for corresponding left/top.

Public function IndexOfTile(aTile : PHeightTileInfo) : Integer;
Public function TileCompressedSize(tileIndex : Integer) : Integer;
Public function TileCount : Integer;
Public function XYHeight(anX, anY : Integer) : SmallInt;

Returns the height at given coordinates.<p> This is definetely NOT the fastest way to access HTF data and should only be used as utility function.

Public function XYTileInfo(anX, anY : Integer) : PHeightTileInfo;

Returns the tile that contains x and y.

Protected function GetTiles(index : Integer) : PHeightTileInfo;
Protected function QuadTableX(x : Integer) : Integer;
Protected function QuadTableY(y : Integer) : Integer;
Public procedure CompressTile(aLeft, aTop, aWidth, aHeight : Integer; aData : PSmallIntArray);

Stores and compresses give tile data.<p> aLeft and top MUST be a multiple of TileSize, aWidth and aHeight MUST be lower or equal to TileSize.

Public procedure ExtractRow(x, y, len : Integer; dest : PSmallIntArray);

Extract a single row from the HTF file.<p> This is NOT the fastest way to access HTF data.<br> All of the row must be contained in the world, otherwise result is undefined.

Public procedure TilesInRect(aLeft, aTop, aRight, aBottom : Integer; destList : TList);

Clears the list then add all tiles that overlap the rectangular area.

Protected procedure PackTile(aWidth, aHeight : Integer; src : PSmallIntArray);
Protected procedure UnPackTile(source : PShortIntArray);

Properties

Public property DefaultZ : SmallInt read FHeader.DefaultZ write FHeader.DefaultZ;
Public property SizeX : Integer read FHeader.SizeX;
Public property SizeY : Integer read FHeader.SizeY;
Protected property TileIndexOffset : Int64 read FHeader.TileIndexOffset write FHeader.TileIndexOffset;
Public property Tiles[index : Integer]: PHeightTileInfo read GetTiles;
Public property TileSize : Integer read FHeader.TileSize;

Maximum width and height for a tile.<p> Actual tiles may not be square, can assume random layouts, and may overlap.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: ImageUtils

Unit ImageUtils

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TIntermediateFormat |
Class EGLImageUtils |

Functions and Procedures

function ImageBoxFilter(Value: Single): Single;
function ImageTriangleFilter(Value: Single): Single;
function ImageHermiteFilter(Value: Single): Single;
function ImageBellFilter(Value: Single): Single;
function ImageSplineFilter(Value: Single): Single;
function ImageLanczos3Filter(Value: Single): Single;
function ImageMitchellFilter(Value: Single): Single;
procedure ImageAlphaFromIntensity(var AColor: TIntermediateFormat);
procedure ImageAlphaSuperBlackTransparent(var AColor: TIntermediateFormat);
procedure ImageAlphaLuminance(var AColor: TIntermediateFormat);
procedure ImageAlphaLuminanceSqrt(var AColor: TIntermediateFormat);
procedure ImageAlphaOpaque(var AColor: TIntermediateFormat);
procedure ImageAlphaTopLeftPointColorTransparent(var AColor: TIntermediateFormat);
procedure ImageAlphaInverseLuminance(var AColor: TIntermediateFormat);
procedure ImageAlphaInverseLuminanceSqrt(var AColor: TIntermediateFormat);
procedure ImageAlphaBottomRightPointColorTransparent(var AColor: TIntermediateFormat);
procedure ConvertImage(const ASrc: Pointer; const ADst: Pointer; ASrcColorFormat, ADstColorFormat: TGLEnum; ASrcDataType, ADstDataType: TGLEnum; AWidth, AHeight: Integer);
procedure RescaleImage(const ASrc: Pointer; const ADst: Pointer; AColorFormat: TGLEnum; ADataType: TGLEnum; AFilter: TImageFilterFunction; ASrcWidth, ASrcHeight, ADstWidth, ADstHeight: Integer);
procedure Build2DMipmap(const ASrc: Pointer; const ADst: TPointerArray; AColorFormat: TGLEnum; ADataType: TGLEnum; AFilter: TImageFilterFunction; ASrcWidth, ASrcHeight: Integer);
procedure AlphaGammaBrightCorrection(const ASrc: Pointer; AColorFormat: TGLEnum; ADataType: TGLEnum; ASrcWidth, ASrcHeight: Integer; anAlphaProc: TImageAlphaProc; ABrightness: Single; AGamma: Single);

Types

TPointerArray = array of Pointer;
PRGBA32F = ˆTIntermediateFormat;
TIntermediateFormatArray = array [0 .. MaxInt div (2 * SizeOf(TIntermediateFormat))] of TIntermediateFormat;
PIntermediateFormatArray = ˆTIntermediateFormatArray;
TU48BitBlock = array [0 .. 3, 0 .. 3] of Byte;
T48BitBlock = array [0 .. 3, 0 .. 3] of SmallInt;
TImageFilterFunction = function(Value: Single): Single;
TImageAlphaProc = procedure(var AColor: TIntermediateFormat);

Variables

vImageScaleFilterWidth: Integer = 5;

Description

Functions and Procedures

function ImageBoxFilter(Value: Single): Single;
function ImageTriangleFilter(Value: Single): Single;
function ImageHermiteFilter(Value: Single): Single;
function ImageBellFilter(Value: Single): Single;
function ImageSplineFilter(Value: Single): Single;
function ImageLanczos3Filter(Value: Single): Single;
function ImageMitchellFilter(Value: Single): Single;
procedure ImageAlphaFromIntensity(var AColor: TIntermediateFormat);
procedure ImageAlphaSuperBlackTransparent(var AColor: TIntermediateFormat);
procedure ImageAlphaLuminance(var AColor: TIntermediateFormat);
procedure ImageAlphaLuminanceSqrt(var AColor: TIntermediateFormat);
procedure ImageAlphaOpaque(var AColor: TIntermediateFormat);
procedure ImageAlphaTopLeftPointColorTransparent(var AColor: TIntermediateFormat);
procedure ImageAlphaInverseLuminance(var AColor: TIntermediateFormat);
procedure ImageAlphaInverseLuminanceSqrt(var AColor: TIntermediateFormat);
procedure ImageAlphaBottomRightPointColorTransparent(var AColor: TIntermediateFormat);
procedure ConvertImage(const ASrc: Pointer; const ADst: Pointer; ASrcColorFormat, ADstColorFormat: TGLEnum; ASrcDataType, ADstDataType: TGLEnum; AWidth, AHeight: Integer);
procedure RescaleImage(const ASrc: Pointer; const ADst: Pointer; AColorFormat: TGLEnum; ADataType: TGLEnum; AFilter: TImageFilterFunction; ASrcWidth, ASrcHeight, ADstWidth, ADstHeight: Integer);
procedure Build2DMipmap(const ASrc: Pointer; const ADst: TPointerArray; AColorFormat: TGLEnum; ADataType: TGLEnum; AFilter: TImageFilterFunction; ASrcWidth, ASrcHeight: Integer);
procedure AlphaGammaBrightCorrection(const ASrc: Pointer; AColorFormat: TGLEnum; ADataType: TGLEnum; ASrcWidth, ASrcHeight: Integer; anAlphaProc: TImageAlphaProc; ABrightness: Single; AGamma: Single);

Types

TPointerArray = array of Pointer;
PRGBA32F = ˆTIntermediateFormat;
TIntermediateFormatArray = array [0 .. MaxInt div (2 * SizeOf(TIntermediateFormat))] of TIntermediateFormat;
PIntermediateFormatArray = ˆTIntermediateFormatArray;
TU48BitBlock = array [0 .. 3, 0 .. 3] of Byte;
T48BitBlock = array [0 .. 3, 0 .. 3] of SmallInt;
TImageFilterFunction = function(Value: Single): Single;
TImageAlphaProc = procedure(var AColor: TIntermediateFormat);

Variables

vImageScaleFilterWidth: Integer = 5;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: ImageUtils: record TIntermediateFormat

record TIntermediateFormat

Unit

ImageUtils

Declaration

type TIntermediateFormat = record

Description

Overview

Fields

R: Single;
G: Single;
B: Single;
A: Single;

Description

Fields

R: Single;
G: Single;
B: Single;
A: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: ImageUtils: Class EGLImageUtils

Class EGLImageUtils

Unit

ImageUtils

Declaration

type EGLImageUtils = class(Exception)

Description

Hierarchy

  • Exception
  • EGLImageUtils
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: Info

Unit Info

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TInfoForm |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: Info: Class TInfoForm

Class TInfoForm

Unit

Info

Declaration

type TInfoForm = class(TForm)

Description

Hierarchy

  • TForm
  • TInfoForm

Overview

Fields

Published | AccLabel: TLabel;
Published | AccumLabel: TLabel;
Published | AuxLabel: TLabel;
Published | ClipLabel: TLabel;
Published | ColorLabel: TLabel;
Published | CopyLabel: TLabel;
Published | DepthLabel: TLabel;
Published | DoubleLabel: TLabel;
Published | EvalLabel: TLabel;
Published | Image1: TImage;
Published | Label1: TLabel;
Published | Label10: TLabel;
Published | Label11: TLabel;
Published | Label12: TLabel;
Published | Label13: TLabel;
Published | Label14: TLabel;
Published | Label15: TLabel;
Published | Label16: TLabel;
Published | Label17: TLabel;
Published | Label18: TLabel;
Published | Label2: TLabel;
Published | Label20: TLabel;
Published | Label23: TLabel;
Published | Label25: TLabel;
Published | Label26: TLabel;
Published | Label27: TLabel;
Published | Label28: TLabel;
Published | Label29: TLabel;
Published | Label3: TLabel;
Published | Label30: TLabel;
Published | Label31: TLabel;
Published | Label32: TLabel;
Published | Label33: TLabel;
Published | Label34: TLabel;
Published | Label35: TLabel;
Published | Label37: TLabel;
Published | Label4: TLabel;
Published | Label5: TLabel;
Published | Label6: TLabel;
Published | Label7: TLabel;
Published | Label8: TLabel;
Published | Label9: TLabel;
Published | LightLabel: TLabel;
Published | ListLabel: TLabel;
Published | Memo1: TMemo;
Published | Contributors: TMemo;
Published | ModelLabel: TLabel;
Published | NameLabel: TLabel;
Published | OverlayLabel: TLabel;
Published | PageControl: TPageControl;
Published | PixelLabel: TLabel;
Published | ProjLabel: TLabel;
Published | RendererLabel: TLabel;
Published | ScrollBox1: TScrollBox;
Published | TabSheet4: TTabSheet;
Published | StencilLabel: TLabel;
Published | StereoLabel: TLabel;
Published | SubLabel: TLabel;
Published | TabSheet2: TTabSheet;
Published | TabSheet3: TTabSheet;
Published | TexSizeLabel: TLabel;
Published | TexStackLabel: TLabel;
Published | TexUnitsLabel: TLabel;
Published | UnderlayLabel: TLabel;
Published | VendorLabel: TLabel;
Published | VersionLabel: TLabel;
Published | TabSheet5: TTabSheet;
Published | Extensions: TListBox;
Published | PMWebLink: TPopupMenu;
Published | MIRegistryLink: TMenuItem;
Published | MIDelphi3D: TMenuItem;
Published | TabSheet1: TTabSheet;
Published | CloseButton: TButton;
Published | VersionLbl: TLabel;
Published | ViewLabel: TLabel;
Published | WebsiteLbl: TLabel;

Methods

Protected | function GetSceneVersion: string;
Published | procedure CloseButtonClick(Sender: TObject);
Published | procedure ExtensionsClick(Sender: TObject);
Published | procedure ExtensionsDblClick(Sender: TObject);
Published | procedure ExtensionsKeyPress(Sender: TObject; var Key: Char);
Published | procedure FormClose(Sender: TObject; var Action: TCloseAction);
Published | procedure FormCreate(Sender: TObject);
Published | procedure FormKeyPress(Sender: TObject; var Key: Char);
Published | procedure FormShow(Sender: TObject);
Published | procedure MIDelphi3DClick(Sender: TObject);
Published | procedure WebsiteLblClick(Sender: TObject);
Public | procedure GetInfoFrom(aSceneBuffer: TGLSceneBuffer);
Protected | procedure LoadContributors;

Description

Fields

Published AccLabel: TLabel;
Published AccumLabel: TLabel;
Published AuxLabel: TLabel;
Published ClipLabel: TLabel;
Published ColorLabel: TLabel;
Published CopyLabel: TLabel;
Published DepthLabel: TLabel;
Published DoubleLabel: TLabel;
Published EvalLabel: TLabel;
Published Image1: TImage;
Published Label1: TLabel;
Published Label10: TLabel;
Published Label11: TLabel;
Published Label12: TLabel;
Published Label13: TLabel;
Published Label14: TLabel;
Published Label15: TLabel;
Published Label16: TLabel;
Published Label17: TLabel;
Published Label18: TLabel;
Published Label2: TLabel;
Published Label20: TLabel;
Published Label23: TLabel;
Published Label25: TLabel;
Published Label26: TLabel;
Published Label27: TLabel;
Published Label28: TLabel;
Published Label29: TLabel;
Published Label3: TLabel;
Published Label30: TLabel;
Published Label31: TLabel;
Published Label32: TLabel;
Published Label33: TLabel;
Published Label34: TLabel;
Published Label35: TLabel;
Published Label37: TLabel;
Published Label4: TLabel;
Published Label5: TLabel;
Published Label6: TLabel;
Published Label7: TLabel;
Published Label8: TLabel;
Published Label9: TLabel;
Published LightLabel: TLabel;
Published ListLabel: TLabel;
Published Memo1: TMemo;
Published Contributors: TMemo;
Published ModelLabel: TLabel;
Published NameLabel: TLabel;
Published OverlayLabel: TLabel;
Published PageControl: TPageControl;
Published PixelLabel: TLabel;
Published ProjLabel: TLabel;
Published RendererLabel: TLabel;
Published ScrollBox1: TScrollBox;
Published TabSheet4: TTabSheet;
Published StencilLabel: TLabel;
Published StereoLabel: TLabel;
Published SubLabel: TLabel;
Published TabSheet2: TTabSheet;
Published TabSheet3: TTabSheet;
Published TexSizeLabel: TLabel;
Published TexStackLabel: TLabel;
Published TexUnitsLabel: TLabel;
Published UnderlayLabel: TLabel;
Published VendorLabel: TLabel;
Published VersionLabel: TLabel;
Published TabSheet5: TTabSheet;
Published Extensions: TListBox;
Published PMWebLink: TPopupMenu;
Published MIRegistryLink: TMenuItem;
Published MIDelphi3D: TMenuItem;
Published TabSheet1: TTabSheet;
Published CloseButton: TButton;
Published VersionLbl: TLabel;
Published ViewLabel: TLabel;
Published WebsiteLbl: TLabel;

Methods

Protected function GetSceneVersion: string;
Published procedure CloseButtonClick(Sender: TObject);
Published procedure ExtensionsClick(Sender: TObject);
Published procedure ExtensionsDblClick(Sender: TObject);
Published procedure ExtensionsKeyPress(Sender: TObject; var Key: Char);
Published procedure FormClose(Sender: TObject; var Action: TCloseAction);
Published procedure FormCreate(Sender: TObject);
Published procedure FormKeyPress(Sender: TObject; var Key: Char);
Published procedure FormShow(Sender: TObject);
Published procedure MIDelphi3DClick(Sender: TObject);
Published procedure WebsiteLblClick(Sender: TObject);
Public procedure GetInfoFrom(aSceneBuffer: TGLSceneBuffer);
Protected procedure LoadContributors;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: InfoLCL

Unit InfoLCL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Informations on OpenGL driver.<p>

<b>History : </b><font size=-1><ul> <li>04/05/10 - Yar - Redecoration (thanks Conferno and Predator) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TInfoForm |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: InfoLCL: Class TInfoForm

Class TInfoForm

Unit

InfoLCL

Declaration

type TInfoForm = class(TForm)

Description

Hierarchy

  • TForm
  • TInfoForm

Overview

Fields

Published | AccLabel: TLabel;
Published | AccumLabel: TLabel;
Published | AuxLabel: TLabel;
Published | ClipLabel: TLabel;
Published | ColorLabel: TLabel;
Published | CopyLabel: TLabel;
Published | DepthLabel: TLabel;
Published | DoubleLabel: TLabel;
Published | EvalLabel: TLabel;
Published | Image1: TImage;
Published | Label1: TLabel;
Published | Label10: TLabel;
Published | Label11: TLabel;
Published | Label12: TLabel;
Published | Label13: TLabel;
Published | Label14: TLabel;
Published | Label15: TLabel;
Published | Label16: TLabel;
Published | Label17: TLabel;
Published | Label18: TLabel;
Published | Label2: TLabel;
Published | Label20: TLabel;
Published | Label23: TLabel;
Published | Label25: TLabel;
Published | Label26: TLabel;
Published | Label27: TLabel;
Published | Label28: TLabel;
Published | Label29: TLabel;
Published | Label3: TLabel;
Published | Label30: TLabel;
Published | Label31: TLabel;
Published | Label32: TLabel;
Published | Label33: TLabel;
Published | Label34: TLabel;
Published | Label35: TLabel;
Published | Label37: TLabel;
Published | Label4: TLabel;
Published | Label5: TLabel;
Published | Label6: TLabel;
Published | Label7: TLabel;
Published | Label8: TLabel;
Published | Label9: TLabel;
Published | LightLabel: TLabel;
Published | ListLabel: TLabel;
Published | Memo1: TMemo;
Published | Contributors: TMemo;
Published | ModelLabel: TLabel;
Published | NameLabel: TLabel;
Published | OverlayLabel: TLabel;
Published | PageControl: TPageControl;
Published | PixelLabel: TLabel;
Published | ProjLabel: TLabel;
Published | RendererLabel: TLabel;
Published | ScrollBox1: TScrollBox;
Published | TabSheet4: TTabSheet;
Published | StencilLabel: TLabel;
Published | StereoLabel: TLabel;
Published | SubLabel: TLabel;
Published | TabSheet2: TTabSheet;
Published | TabSheet3: TTabSheet;
Published | TexSizeLabel: TLabel;
Published | TexStackLabel: TLabel;
Published | TexUnitsLabel: TLabel;
Published | UnderlayLabel: TLabel;
Published | VendorLabel: TLabel;
Published | VersionLabel: TLabel;
Published | TabSheet5: TTabSheet;
Published | Extensions: TListBox;
Published | PMWebLink: TPopupMenu;
Published | MIRegistryLink: TMenuItem;
Published | MIDelphi3D: TMenuItem;
Published | TabSheet1: TTabSheet;
Published | CloseButton: TButton;
Published | VersionLbl: TLabel;
Published | ViewLabel: TLabel;
Published | WebsiteLbl: TLabel;

Methods

Published | procedure CloseButtonClick(Sender: TObject);
Published | procedure ExtensionsClick(Sender: TObject);
Published | procedure ExtensionsDblClick(Sender: TObject);
Published | procedure ExtensionsKeyPress(Sender: TObject; var Key: Char);
Published | procedure FormClose(Sender: TObject; var Action: TCloseAction);
Published | procedure FormKeyPress(Sender: TObject; var Key: Char);
Published | procedure FormShow(Sender: TObject);
Published | procedure MIDelphi3DClick(Sender: TObject);
Published | procedure WebsiteLblClick(Sender: TObject);
Public | procedure GetInfoFrom(aSceneBuffer : TGLSceneBuffer);

Description

Fields

Published AccLabel: TLabel;
Published AccumLabel: TLabel;
Published AuxLabel: TLabel;
Published ClipLabel: TLabel;
Published ColorLabel: TLabel;
Published CopyLabel: TLabel;
Published DepthLabel: TLabel;
Published DoubleLabel: TLabel;
Published EvalLabel: TLabel;
Published Image1: TImage;
Published Label1: TLabel;
Published Label10: TLabel;
Published Label11: TLabel;
Published Label12: TLabel;
Published Label13: TLabel;
Published Label14: TLabel;
Published Label15: TLabel;
Published Label16: TLabel;
Published Label17: TLabel;
Published Label18: TLabel;
Published Label2: TLabel;
Published Label20: TLabel;
Published Label23: TLabel;
Published Label25: TLabel;
Published Label26: TLabel;
Published Label27: TLabel;
Published Label28: TLabel;
Published Label29: TLabel;
Published Label3: TLabel;
Published Label30: TLabel;
Published Label31: TLabel;
Published Label32: TLabel;
Published Label33: TLabel;
Published Label34: TLabel;
Published Label35: TLabel;
Published Label37: TLabel;
Published Label4: TLabel;
Published Label5: TLabel;
Published Label6: TLabel;
Published Label7: TLabel;
Published Label8: TLabel;
Published Label9: TLabel;
Published LightLabel: TLabel;
Published ListLabel: TLabel;
Published Memo1: TMemo;
Published Contributors: TMemo;
Published ModelLabel: TLabel;
Published NameLabel: TLabel;
Published OverlayLabel: TLabel;
Published PageControl: TPageControl;
Published PixelLabel: TLabel;
Published ProjLabel: TLabel;
Published RendererLabel: TLabel;
Published ScrollBox1: TScrollBox;
Published TabSheet4: TTabSheet;
Published StencilLabel: TLabel;
Published StereoLabel: TLabel;
Published SubLabel: TLabel;
Published TabSheet2: TTabSheet;
Published TabSheet3: TTabSheet;
Published TexSizeLabel: TLabel;
Published TexStackLabel: TLabel;
Published TexUnitsLabel: TLabel;
Published UnderlayLabel: TLabel;
Published VendorLabel: TLabel;
Published VersionLabel: TLabel;
Published TabSheet5: TTabSheet;
Published Extensions: TListBox;
Published PMWebLink: TPopupMenu;
Published MIRegistryLink: TMenuItem;
Published MIDelphi3D: TMenuItem;
Published TabSheet1: TTabSheet;
Published CloseButton: TButton;
Published VersionLbl: TLabel;
Published ViewLabel: TLabel;
Published WebsiteLbl: TLabel;

Methods

Published procedure CloseButtonClick(Sender: TObject);
Published procedure ExtensionsClick(Sender: TObject);
Published procedure ExtensionsDblClick(Sender: TObject);
Published procedure ExtensionsKeyPress(Sender: TObject; var Key: Char);
Published procedure FormClose(Sender: TObject; var Action: TCloseAction);
Published procedure FormKeyPress(Sender: TObject; var Key: Char);
Published procedure FormShow(Sender: TObject);
Published procedure MIDelphi3DClick(Sender: TObject);
Published procedure WebsiteLblClick(Sender: TObject);
Public procedure GetInfoFrom(aSceneBuffer : TGLSceneBuffer);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: Joystick

Unit Joystick

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Joystick<p>

Component for handling joystick messages<p>

<b>Historique : </b><font size=-1><ul> <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTracekrID=1681585) <li>29/01/02 - Egg - Added NoCaptureErrors <li>18/12/00 - Egg - Fix for supporting 2 joysticks simultaneously <li>14/04/00 - Egg - Various minor to major fixes, the component should now work properly for the 4 first buttons and XY axis <li>20/03/00 - Egg - Creation from GLScene's TGLJoystick </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TJoystick |

Types

TJoystickButton = (...);
TJoystickButtons = set of TJoystickButton;
TJoystickID = (...);
TJoystickDesignMode = (...);
TJoyPos = (...);
TJoyAxis = (...);
TJoystickEvent = procedure(Sender: TObject; JoyID: TJoystickID; Buttons: TJoystickButtons; XDeflection, YDeflection: Integer) of Object;

Description

Types

TJoystickButton = (...);
Values
  • jbButton1:
  • jbButton2:
  • jbButton3:
  • jbButton4:
TJoystickButtons = set of TJoystickButton;
TJoystickID = (...);
Values
  • jidNoJoystick:
  • jidJoystick1:
  • jidJoystick2:
TJoystickDesignMode = (...);
Values
  • jdmInactive:
  • jdmActive:
TJoyPos = (...);
Values
  • jpMin:
  • jpCenter:
  • jpMax:
TJoyAxis = (...);
Values
  • jaX:
  • jaY:
  • jaZ:
  • jaR:
  • jaU:
  • jaV:
TJoystickEvent = procedure(Sender: TObject; JoyID: TJoystickID; Buttons: TJoystickButtons; XDeflection, YDeflection: Integer) of Object;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: Joystick: Class TJoystick

Class TJoystick

Unit

Joystick

Declaration

type TJoystick = class(TComponent)

Description

A component interfacing the Joystick via the (regular) windows API.

Hierarchy

  • TComponent
  • TJoystick

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Protected | function MakeJoyButtons(Param: UINT): TJoystickButtons;
Public | procedure Assign(Source: TPersistent); override;
Protected | procedure DoJoystickCapture(AHandle: HWND; AJoystick: TJoystickID);
Protected | procedure DoJoystickRelease(AJoystick: TJoystickID);
Protected | procedure DoXYMove(Buttons: Word; XPos, YPos: Integer);
Protected | procedure DoZMove(Buttons: Word; ZPos: Integer);
Protected | procedure Loaded; override;
Protected | procedure ReapplyCapture(AJoystick: TJoystickID);
Protected | procedure WndProc(var Msg: TMessage);

Properties

Published | property Capture : Boolean read FCapture write SetCapture default False;
Published | property Interval : Cardinal read FInterval write SetInterval default 100;
Public | property JoyButtons : TJoystickButtons read FJoyButtons;
Published | property JoystickID: TJoystickID read FJoystickID write SetJoystickID default jidNoJoystick;
Published | property NoCaptureErrors : Boolean read FNoCaptureErrors write FNoCaptureErrors default True;
Published | property OnJoystickButtonChange: TJoystickEvent read FOnJoystickButtonChange write FOnJoystickButtonChange;
Published | property OnJoystickMove: TJoystickEvent read FOnJoystickMove write FOnJoystickMove;
Published | property Threshold: Cardinal read FThreshold write SetThreshold default 1000;
Public | property XPosition : Integer read FXPosition;
Public | property YPosition : Integer read FYPosition;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Protected function MakeJoyButtons(Param: UINT): TJoystickButtons;
Public procedure Assign(Source: TPersistent); override;
Protected procedure DoJoystickCapture(AHandle: HWND; AJoystick: TJoystickID);
Protected procedure DoJoystickRelease(AJoystick: TJoystickID);
Protected procedure DoXYMove(Buttons: Word; XPos, YPos: Integer);
Protected procedure DoZMove(Buttons: Word; ZPos: Integer);
Protected procedure Loaded; override;
Protected procedure ReapplyCapture(AJoystick: TJoystickID);
Protected procedure WndProc(var Msg: TMessage);

Properties

Published property Capture : Boolean read FCapture write SetCapture default False;

When set to True, the component attempts to capture the joystick.<p> If capture is successfull, retrieving joystick status is possible, if not, an error message is triggered.

Published property Interval : Cardinal read FInterval write SetInterval default 100;

Polling frequency (milliseconds)

Public property JoyButtons : TJoystickButtons read FJoyButtons;
Published property JoystickID: TJoystickID read FJoystickID write SetJoystickID default jidNoJoystick;
Published property NoCaptureErrors : Boolean read FNoCaptureErrors write FNoCaptureErrors default True;

If true joystick capture errors do not result in exceptions.

Published property OnJoystickButtonChange: TJoystickEvent read FOnJoystickButtonChange write FOnJoystickButtonChange;
Published property OnJoystickMove: TJoystickEvent read FOnJoystickMove write FOnJoystickMove;
Published property Threshold: Cardinal read FThreshold write SetThreshold default 1000;
Public property XPosition : Integer read FXPosition;
Public property YPosition : Integer read FYPosition;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:13


GLScene v.1.1.2: LIBFREETYPE

Unit LIBFREETYPE

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

LIBFREETYPE<p>

<b>Historique : </b><font size=-1><ul> <li>21/01/11 - Yar - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record FT_Matrix |
record FT_LibraryRec_ |
record FT_Subglyph |
packed record FT_Bitmap_Size |
packed record FT_Generic |
packed record FT_BBox |
packed record FT_Vector |
packed record FT_Bitmap |
packed record FT_OutlineRec_ |
packed record FT_Glyph_Metrics |
packed record FT_GlyphSlotRec_ |
record FT_Size_Metrics |
record FT_SizeRec_ |
packed record FT_FaceRec_ |
packed record FT_CharmapRec_ |
record FTC_CMapCacheRec_ |
record FTC_ManagerRec_ |
record FTC_ImageCacheRec_ |
packed record FTC_ImageTypeRec_ |
record FT_GlyphRec_ |
record FTC_NodeRec_ |
packed record FTC_ScalerRec_ |
record FTC_SBitCacheRec_ |
packed record FTC_SBitRec_ |
record FT_ModuleRec_ |
packed record FT_MM_Axis |
packed record FT_Multi_Master |
packed record PS_FontInfoRec_ |
packed record PS_PrivateRec_ |
packed record FT_Glyph_ClassRec_ |
packed record FT_RasterRec_ |
packed record FT_Raster_Funcs |
packed record FT_Renderer_Class |
packed record FT_RendererRec_ |
packed record FT_MemoryRec_ |
packed record FT_SfntName |
packed record FT_WinFNT_HeaderRec |
packed record FT_StrokerRec_ |
packed record FT_ListNodeRec_ |
packed record FT_ListRec_ |
packed record FT_Span |
packed record FT_Raster_Params |
packed record FT_Size_RequestRec_ |
packed record FT_StreamDesc |
packed record FT_StreamRec_ |
packed record FT_Parameter |
packed record FT_Open_Args |
packed record FT_Var_Axis |
packed record FT_Var_Named_Style |
packed record FT_MM_Var |
packed record FT_Outline_Funcs |

Functions and Procedures

function FT_Curve_Tag(flag: char): char;
function FT_Is_Scalable(face: FT_Face): boolean;
function FT_Has_Kerning(face: FT_Face): boolean;
function InitFreetype: Boolean;
procedure CloseFreetype;
function InitFreetypeFromLibrary(const FTName: WideString): Boolean;
function IsFreetypeInitialized: Boolean;

Types

FT_Encoding = array[0..3] of char;
FT_Pointer = pointer;
FT_Byte = byte;
FT_Byte_array = array[0..MaxInt div (2*SizeOf(FT_Byte))-1] of FT_Byte;
FT_Bytes = ˆFT_Byte_array;
FT_Short = smallint;
FT_UShort = word;
FT_Int = longint;
FT_UInt = longword;
FT_Int32 = longint;
FT_UInt32 = cardinal;
FT_Long = longint;
FT_ULong = longword;
FT_Fixed = longint;
FT_Bool = bytebool;
FT_Char = ShortInt;
FT_Pos = longint;
FT_Error = longint;
FT_F26Dot6 = longint;
FT_String = AnsiChar;
FT_Byte_ptr = ˆFT_Byte;
FT_Short_array = array[0..MaxInt div (2*SizeOf(FT_Short))-1] of FT_Short;
FT_Short_ptr = ˆFT_Short_array;
FT_Long_ptr = ˆFT_Long;
FT_Fixed_ptr = ˆFT_Fixed;
FT_UInt_ptr = ˆFT_UInt;
FT_Render_Mode = FT_Int;
FT_Library = ˆFT_LibraryRec_;
FT_Library_array = array[0..MaxInt div 16 - 1] of FT_Library;
FT_Library_ptr = ˆFT_Library_array;
FT_Subglyph_ptr = ˆFT_Subglyph;
AFT_Bitmap_Size = array[0..1023] of FT_Bitmap_Size;
FT_Bitmap_Size_ptr = ˆAFT_Bitmap_Size;
FT_Generic_Finalizer = procedure(AnObject: pointer); cdecl;
FT_BBox_ptr = ˆFT_BBox;
FT_Vector_ptr = ˆFT_Vector_array;
FT_Vector_array = array[0..MaxInt div (2*SizeOf(FT_Vector)) - 1] of FT_Vector;
FT_Bitmap_ptr = ˆFT_Bitmap;
FT_Outline = ˆFT_OutlineRec_;
FT_Face = ˆFT_FaceRec_;
FT_Face_array = array[0..MaxInt div 16 - 1] of FT_Face;
FT_Face_ptr = ˆFT_Face_array;
FT_GlyphSlot = ˆFT_GlyphSlotRec_;
FT_Size = ˆFT_SizeRec_;
FT_Charmap = ˆFT_CharmapRec_;
FT_Charmap_ptr = ˆFT_Charmap_array;
FT_Charmap_array = array[0..MaxInt div 16 - 1] of FT_Charmap;
FTC_CMapCache = ˆFTC_CMapCacheRec_;
FTC_FaceID = FT_Pointer;
FTC_Manager = ˆFTC_ManagerRec_;
FTC_ImageCache = ˆFTC_ImageCacheRec_;
FTC_ImageType = ˆFTC_ImageTypeRec_;
FT_Glyph = ˆFT_GlyphRec_;
FTC_Node = ˆFTC_NodeRec_;
FTC_Scaler = ˆFTC_ScalerRec_;
FT_Angle = FT_Fixed;
FTC_Face_Requester = function(face_id: FTC_FaceID; Alibrary: FT_Library; request_data: FT_Pointer; var aface: FT_Face): FT_Error; cdecl;
FTC_SBitCache = ˆFTC_SBitCacheRec_;
FTC_SBit = ˆFTC_SBitRec_;
FT_Module_Class = FT_Pointer;
FT_Module = ˆFT_ModuleRec_;
PS_FontInfo = ˆPS_FontInfoRec_;
PS_Private = ˆPS_PrivateRec_;
FT_Glyph_Format = (...);
FT_Glyph_Class = ˆFT_Glyph_ClassRec_;
FT_Raster = ˆFT_RasterRec_;
pFT_Raster_Params = ˆFT_Raster_Params;
FT_Raster_Render_Func = function(raster: FT_Raster; params: pFT_Raster_Params): Integer; cdecl;
FT_Renderer = ˆFT_RendererRec_;
FT_Renderer_RenderFunc = function(renderer: FT_Renderer; slot: FT_GlyphSlot; mode: FT_UInt; const origin: FT_Vector): FT_Error; cdecl;
FT_Renderer_TransformFunc = function(renderer: FT_Renderer; slot: FT_GlyphSlot; const matrix: FT_Matrix; const delta: FT_Vector): FT_Error; cdecl;
FT_Renderer_GetCBoxFunc = procedure(renderer: FT_Renderer; slot: FT_GlyphSlot; var cbox: FT_BBox); cdecl;
FT_Renderer_SetModeFunc = function(renderer: FT_Renderer; mode_tag: FT_ULong; mode_ptr: FT_Pointer): FT_Error; cdecl;
FT_Raster_NewFunc = function(memory: Pointer; var raster: FT_Raster): Integer; cdecl;
FT_Raster_ResetFunc = procedure(raster: FT_Raster; pool_base: PAnsiChar; pool_size: PtrUint); cdecl;
FT_Raster_SetModeFunc = function(raster: FT_Raster; mode: PtrUint; args: Pointer): Integer; cdecl;
FT_Raster_RenderFunc = function(raster: FT_Raster; params: pFT_Raster_Params): Integer; cdecl;
FT_Raster_DoneFunc = procedure(raster: FT_Raster); cdecl;
FT_Memory = ˆFT_MemoryRec_;
FT_Alloc_Func = function(memory: FT_Memory; size: LongInt): Pointer;
FT_Free_Func = procedure(memory: FT_Memory; block: Pointer); cdecl;
FT_Realloc_Func = function(memory: FT_Memory; cur_size: LongInt; new_size: LongInt; block: Pointer): Pointer; cdecl;
FT_Sfnt_Tag = (...);
FT_TrueTypeEngineType = (...);
FT_Stroker = ˆFT_StrokerRec_;
FT_ListNode = ˆFT_ListNodeRec_;
FT_List = ˆFT_ListRec_;
FT_List_Destructor = procedure(memory: FT_Memory; data: Pointer; user: Pointer); cdecl;
FT_List_Iterator = function(node: FT_ListNode; user: Pointer): FT_Error; cdecl;
FT_StrokerBorder = (...);
FT_Orientation = (...);
FT_SpanFunc = procedure(y: Integer; count: Integer; var spans: FT_Span; user: Pointer); cdecl;
FT_Raster_BitTest_Func = function(y: Integer; x: Integer; user: Pointer): Integer; cdecl;
FT_Raster_BitSet_Func = procedure(y: Integer; x: Integer; user: Pointer); cdecl;
FT_Size_Request_Type = (...);
FT_Size_Request = ˆFT_Size_RequestRec_;
FT_DebugHook_Func = procedure(arg: Pointer); cdecl;
FT_Stream = ˆFT_StreamRec_;
FT_Stream_IoFunc = function(stream: FT_Stream; offset: PtrUint; buffer: PAnsiChar; count: PtrUint): PtrUint; cdecl;
FT_Stream_CloseFunc = procedure(stream: FT_Stream); cdecl;
FT_Stroker_LineCap = (...);
FT_Stroker_LineJoin = (...);
FT_Outline_MoveToFunc = function(const ato: FT_Vector; user: Pointer): Integer; cdecl;
FT_Outline_LineToFunc = function(const ato: FT_Vector; user: Pointer): Integer; cdecl;
FT_Outline_ConicToFunc = function(const control: FT_Vector; const ato: FT_Vector; user: Pointer): Integer; cdecl;
FT_Outline_CubicToFunc = function(const control1: FT_Vector; const control2: FT_Vector; const ato: FT_Vector; user: Pointer): Integer; cdecl;
FT_Tables = array[0..FT_VALIDATE_GX_LENGTH - 1] of FT_Bytes;

Constants

FTLIBNAME = 'freetype.dll';
FT_CURVE_TAG_ON = 1;
FT_CURVE_TAG_CONIC = 0;
FT_CURVE_TAG_CUBIC = 2;
FT_FACE_FLAG_SCALABLE = 1 shl 0;
FT_FACE_FLAG_KERNING = 1 shl 6;
FT_ENCODING_NONE: FT_Encoding = (#0, #0, #0, #0);
FT_LOAD_DEFAULT = $0000;
FT_LOAD_NO_HINTING = $0002;
FT_LOAD_FORCE_AUTOHINT = $0020;
FT_RENDER_MODE_NORMAL = 0;
FT_RENDER_MODE_LIGHT = FT_RENDER_MODE_NORMAL + 1;
FT_RENDER_MODE_MONO = FT_RENDER_MODE_LIGHT + 1;
FT_RENDER_MODE_LCD = FT_RENDER_MODE_MONO + 1;
FT_RENDER_MODE_LCD_V = FT_RENDER_MODE_LCD + 1;
FT_RENDER_MODE_MAX = FT_RENDER_MODE_LCD_V + 1;
FT_KERNING_DEFAULT = 0;
FT_KERNING_UNFITTED = 1;
FT_KERNING_UNSCALED = 2;
FT_STYLE_FLAG_ITALIC = 1 shl 0;
FT_STYLE_FLAG_BOLD = 1 shl 1;
T1_MAX_MM_AXIS = 4;
FT_VALIDATE_feat_INDEX = 0;
FT_VALIDATE_mort_INDEX = 1;
FT_VALIDATE_morx_INDEX = 2;
FT_VALIDATE_bsln_INDEX = 3;
FT_VALIDATE_just_INDEX = 4;
FT_VALIDATE_kern_INDEX = 5;
FT_VALIDATE_opbd_INDEX = 6;
FT_VALIDATE_trak_INDEX = 7;
FT_VALIDATE_prop_INDEX = 8;
FT_VALIDATE_lcar_INDEX = 9;
FT_VALIDATE_GX_LAST_INDEX = FT_VALIDATE_lcar_INDEX;
FT_VALIDATE_GX_LENGTH = FT_VALIDATE_GX_LAST_INDEX + 1;
FT_OPEN_MEMORY = $1;
FT_OPEN_STREAM = $2;
FT_OPEN_PATHNAME = $4;
FT_OPEN_DRIVER = $8;
FT_OPEN_PARAMS = $10;
FT_OUTLINE_NONE = $0;
FT_OUTLINE_OWNER = $1;
FT_OUTLINE_EVEN_ODD_FILL = $2;
FT_OUTLINE_REVERSE_FILL = $4;
FT_OUTLINE_IGNORE_DROPOUTS = $8;
FT_OUTLINE_HIGH_PRECISION = $100;
FT_OUTLINE_SINGLE_PASS = $200;

Variables

FTC_CMapCache_Lookup: function(cache: FTC_CMapCache; face_id: FTC_FaceID; cmap_index: FT_Int; char_code: FT_UInt32): FT_UInt; cdecl;
FTC_CMapCache_New: function(manager: FTC_Manager; var acache: FTC_ImageCache): FT_Error; cdecl;
FTC_ImageCache_Lookup: function(cache: FTC_ImageCache; Atype: FTC_ImageType; gindex: FT_UInt; var aglyph: FT_Glyph; var anode: FTC_Node): FT_Error; cdecl;
FTC_ImageCache_LookupScaler: function(cache: FTC_ImageCache; scaler: FTC_Scaler; load_flags: FT_ULong; gindex: FT_UInt; var aglyph: FT_Glyph; var anode: FTC_Node): FT_Error; cdecl;
FTC_ImageCache_New: function(manager: FTC_Manager; var acache: FTC_ImageCache): FT_Error; cdecl;
FTC_Manager_Done: procedure(manager: FTC_Manager); cdecl;
FTC_Manager_LookupFace: function(manager: FTC_Manager; face_id: FTC_FaceID; var aface: FT_Face): FT_Error; cdecl;
FTC_Manager_LookupSize: function(manager: FTC_Manager; scaler: FTC_Scaler; var asize: FT_Size): FT_Error; cdecl;
FTC_Manager_New: function(Alibrary: FT_Library; max_faces: FT_UInt; max_sizes: FT_UInt; max_bytes: FT_ULong; requester: FTC_Face_Requester; req_data: FT_Pointer; var amanager: FTC_Manager): FT_Error; cdecl;
FTC_Manager_RemoveFaceID: procedure(manager: FTC_Manager; face_id: FTC_FaceID); cdecl;
FTC_Manager_Reset: procedure(manager: FTC_Manager); cdecl;
FTC_Node_Unref: procedure(node: FTC_Node; manage: FTC_Manager); cdecl;
FTC_SBitCache_Lookup: function(cache: FTC_SBitCache; Atype: FTC_ImageType; gindex: FT_UInt; var sbit: FTC_SBit; var anode: FTC_Node): FT_Error; cdecl;
FTC_SBitCache_LookupScaler: function(cache: FTC_SBitCache; scaler: FTC_Scaler; load_flags: FT_ULong; gindex: FT_UInt; var sbit: FTC_SBit; var anode: FTC_Node): FT_Error; cdecl;
FTC_SBitCache_New: function(manager: FTC_Manager; var acache: FTC_SBitCache): FT_Error; cdecl;
FT_Activate_Size: function(size: FT_Size): FT_Error; cdecl;
FT_Add_Default_Modules: function(Alibrary: FT_Library): FT_Error; cdecl;
FT_Add_Module: function(Alibrary: FT_Library; const clazz: FT_Module_Class): FT_Error; cdecl;
FT_Angle_Diff: function(angle1: FT_Angle; angle2: FT_Angle): FT_Angle; cdecl;
FT_Atan2: function(x: FT_Fixed; y: FT_Fixed): FT_Angle; cdecl;
FT_Attach_File: function(face: FT_Face; filepathname: PAnsiChar): FT_Error; cdecl;
FT_Attach_Stream: function(face: FT_Face; const parameters: FT_Open_Args): FT_Error; cdecl;
FT_Bitmap_Convert: function(Alibrary: FT_Library; const source: FT_Bitmap; var target: FT_Bitmap; alignment: FT_Int): FT_Error; cdecl;
FT_Bitmap_Copy: function(Alibrary: FT_Library; const source: FT_Bitmap; var target: FT_Bitmap): FT_Error; cdecl;
FT_Bitmap_Done: function(Alibrary: FT_Library; var bitmap: FT_Bitmap): FT_Error; cdecl;
FT_Bitmap_Embolden: function(Alibrary: FT_Library; var bitmap: FT_Bitmap; xStrength: FT_Pos; yStrength: FT_Pos): FT_Error; cdecl;
FT_Bitmap_New: procedure(var abitmap: FT_Bitmap); cdecl;
FT_CeilFix: function(a: FT_Fixed): FT_Fixed; cdecl;
FT_ClassicKern_Free: procedure(face: FT_Face; table: FT_Bytes); cdecl;
FT_ClassicKern_Validate: function(face: FT_Face; validation_flags: FT_UInt; var ckern_table: FT_Bytes): FT_Error; cdecl;
FT_Cos: function(angle: FT_Angle): FT_Fixed; cdecl;
FT_DivFix: function(a: FT_Long; b: FT_Long): FT_Long; cdecl;
FT_Done_Face: function(face: FT_Face): FT_Error; cdecl;
FT_Done_FreeType: function(alibrary: FT_Library): FT_Error; cdecl;
FT_Done_Glyph: procedure(glyph: FT_Glyph); cdecl;
FT_Done_Library: function(Alibrary: FT_Library): FT_Error; cdecl;
FT_Done_Size: function(size: FT_Size): FT_Error; cdecl;
FT_Face_CheckTrueTypePatents: function(face: FT_Face): FT_Bool; cdecl;
FT_Face_SetUnpatentedHinting: function(face: FT_Face; value: FT_Bool): FT_Bool; cdecl;
FT_FloorFix: function(a: FT_Fixed): FT_Fixed; cdecl;
FT_Get_CMap_Format: function(charmap: FT_CharMap): FT_Long; cdecl;
FT_Get_CMap_Language_ID: function(charmap: FT_CharMap): FT_ULong; cdecl;
FT_Get_Char_Index: function(face: FT_Face; charcode: FT_ULong): FT_UInt; cdecl;
FT_Get_Charmap_Index: function(charmap: FT_CharMap): FT_Int; cdecl;
FT_Get_First_Char: function(face: FT_Face; var agindex: FT_UInt): FT_ULong; cdecl;
FT_Get_Glyph: function(slot: FT_GlyphSlot; var aglyph: FT_Glyph): FT_Error; cdecl;
FT_Get_Glyph_Name: function(face: FT_Face; glyph_index: FT_UInt; buffer: FT_Pointer; buffer_max: FT_UInt): FT_Error; cdecl;
FT_Get_Kerning: function( face: FT_Face; left_glyph, right_glyph, kern_mode: FT_UInt; var akerning: FT_Vector): FT_Error; cdecl;
FT_Get_MM_Var: function(face: FT_Face; var amaster: FT_MM_Var): FT_Error; cdecl;
FT_Get_Module: function(Alibrary: FT_Library; module_name: PAnsiChar): FT_Module; cdecl;
FT_Get_Multi_Master: function(face: FT_Face; var amaster: FT_Multi_Master): FT_Error; cdecl;
FT_Get_Name_Index: function(face: FT_Face; var glyph_name: FT_String): FT_UInt; cdecl;
FT_Get_Next_Char: function(face: FT_Face; char_code: FT_ULong; var agindex: FT_UInt): FT_ULong; cdecl;
FT_Get_PFR_Advance: function(face: FT_Face; gindex: FT_UInt; var aadvance: FT_Pos): FT_Error; cdecl;
FT_Get_PFR_Kerning: function(face: FT_Face; left: FT_UInt; right: FT_UInt; var avector: FT_Vector): FT_Error; cdecl;
FT_Get_PFR_Metrics: function(face: FT_Face; var aoutline_resolution: FT_UInt; var ametrics_resolution: FT_UInt; ametrics_x_scale: FT_Fixed; ametrics_y_scale: FT_Fixed): FT_Error; cdecl;
FT_Get_PS_Font_Info: function(face: FT_Face; afont_info: PS_FontInfo): FT_Error; cdecl;
FT_Get_PS_Font_Private: function(face: FT_Face; afont_private: PS_Private): FT_Error; cdecl;
FT_Get_Postscript_Name: function(face: FT_Face): PAnsiChar; cdecl;
FT_Get_Renderer: function(Alibrary: FT_Library; format: FT_Glyph_Format): FT_Renderer; cdecl;
FT_Get_Sfnt_Name: function(face: FT_Face; idx: FT_UInt; var aname: FT_SfntName): FT_Error; cdecl;
FT_Get_Sfnt_Name_Count: function(face: FT_Face): FT_UInt; cdecl;
FT_Get_Sfnt_Table: function(face: FT_Face; tag: FT_Sfnt_Tag): Pointer; cdecl;
FT_Get_SubGlyph_Info: function(glyph: FT_GlyphSlot; sub_index: FT_UInt; var p_index: FT_Int; var p_flags: FT_UInt; var p_arg1: FT_Int; var p_arg2: FT_Int; var p_transform: FT_Matrix): FT_Error; cdecl;
FT_Get_Track_Kerning: function(face: FT_Face; point_size: FT_Fixed; degree: FT_Int; var akerning: FT_Fixed): FT_Error; cdecl;
FT_Get_TrueType_Engine_Type: function(Alibrary: FT_Library): FT_TrueTypeEngineType; cdecl;
FT_Get_WinFNT_Header: function(face: FT_Face; var aheader: FT_WinFNT_HeaderRec): FT_Error; cdecl;
FT_GlyphSlot_Embolden: procedure(slot: FT_GlyphSlot); cdecl;
FT_GlyphSlot_Oblique: procedure(slot: FT_GlyphSlot); cdecl;
FT_GlyphSlot_Own_Bitmap: function(slot: FT_GlyphSlot): FT_Error; cdecl;
FT_Glyph_Copy: function(source: FT_Glyph; var target: FT_Glyph): FT_Error; cdecl;
FT_Glyph_Get_CBox: procedure(glyph: FT_Glyph; bbox_mode: FT_UInt; var acbo: FT_BBox); cdecl;
FT_Glyph_Stroke: function(var pglyph: FT_Glyph; stroker: FT_Stroker; destroy: FT_Bool): FT_Error; cdecl;
FT_Glyph_StrokeBorder: function(var pglyph: FT_Glyph; stroker: FT_Stroker; inside: FT_Bool; destroy: FT_Bool): FT_Error; cdecl;
FT_Glyph_To_Bitmap: function(var the_glyph: FT_Glyph; render_mode: FT_Render_Mode; var origin: FT_Vector; destroy: FT_Bool): FT_Error; cdecl;
FT_Glyph_Transform: function(glyph: FT_Glyph; var matrix: FT_Matrix; var delta: FT_Vector): FT_Error; cdecl;
FT_Has_PS_Glyph_Names: function(face: FT_Face): FT_Int; cdecl;
FT_Init_FreeType: function(alibrary: FT_Library): FT_Error; cdecl;
FT_Library_Version: procedure(Alibrary: FT_Library; var amajor: FT_Int; var aminor: FT_Int; var apatch: FT_Int); cdecl;
FT_List_Add: procedure(list: FT_List; node: FT_ListNode); cdecl;
FT_List_Finalize: procedure(list: FT_List; destroy: FT_List_Destructor; memory: FT_Memory; user: Pointer); cdecl;
FT_List_Find: function(list: FT_List; data: Pointer): FT_ListNode; cdecl;
FT_List_Insert: procedure(list: FT_List; node: FT_ListNode); cdecl;
FT_List_Iterate: function(list: FT_List; iterator: FT_List_Iterator; user: Pointer): FT_Error; cdecl;
FT_List_Remove: procedure(list: FT_List; node: FT_ListNode); cdecl;
FT_List_Up: procedure(list: FT_List; node: FT_ListNode); cdecl;
FT_Load_Char: function(face: FT_Face; char_code: FT_ULong; load_flags: FT_Int32): FT_Error; cdecl;
FT_Load_Glyph: function( face: FT_Face; glyph_index: FT_UInt; load_flags: FT_Int32): FT_Error; cdecl;
FT_Load_Sfnt_Table: function(face: FT_Face; tag: FT_ULong; offset: FT_Long; var buffer: FT_Byte; var length: FT_ULong): FT_Error; cdecl;
FT_Matrix_Invert: function(var matrix: FT_Matrix): FT_Error; cdecl;
FT_Matrix_Multiply: procedure(var a: FT_Matrix; var b: FT_Matrix); cdecl;
FT_MulDiv: function(a: FT_Long; b: FT_Long; c: FT_Long): FT_Long; cdecl;
FT_MulFix: function(a: FT_Long; b: FT_Long): FT_Long; cdecl;
FT_New_Face: function( library_: FT_Library; filepathname: PAnsiChar; face_index: FT_Long; var aface: FT_Face): FT_Error; cdecl;
FT_New_Library: function(memory: FT_Memory; var alibrary: FT_Library): FT_Error; cdecl;
FT_New_Memory_Face: function( library_: FT_Library; file_base: FT_Byte_ptr; file_size, face_index: FT_Long; var aface: FT_Face): FT_Error; cdecl;
FT_New_Size: function(face: FT_Face; var size: FT_Size): FT_Error; cdecl;
FT_OpenType_Free: procedure(face: FT_Face; table: FT_Bytes); cdecl;
FT_OpenType_Validate: function(face: FT_Face; validation_flags: FT_UInt; var BASE_table: FT_Bytes; var GDEF_table: FT_Bytes; var GPOS_table: FT_Bytes; var GSUB_table: FT_Bytes; var JSTF_table: FT_Bytes): FT_Error; cdecl;
FT_Open_Face: function(Alibrary: FT_Library; const args: FT_Open_Args; face_index: FT_Long; var aface: FT_Face): FT_Error; cdecl;
FT_Outline_Check: function(var outline: FT_Outline): FT_Error; cdecl;
FT_Outline_Copy: function(const source: FT_Outline; var target: FT_Outline): FT_Error; cdecl;
FT_Outline_Decompose: function(var outline: FT_Outline; const func_interface: FT_Outline_Funcs; use: Pointer): FT_Error; cdecl;
FT_Outline_Done: function(Alibrary: FT_Library; var outline: FT_Outline): FT_Error; cdecl;
FT_Outline_Done_Internal: function(memory: FT_Memory; var outline: FT_Outline): FT_Error; cdecl;
FT_Outline_Embolden: function(var outline: FT_Outline; strength: FT_Pos): FT_Error; cdecl;
FT_Outline_GetInsideBorder: function(const outline: FT_Outline): FT_StrokerBorder; cdecl;
FT_Outline_GetOutsideBorder: function(const outline: FT_Outline): FT_StrokerBorder; cdecl;
FT_Outline_Get_BBox: function(const outline: FT_Outline; var abbox: FT_BBox): FT_Error; cdecl;
FT_Outline_Get_Bitmap: function(Alibrary: FT_Library; const outline: FT_Outline; var abitmap: FT_Bitmap): FT_Error; cdecl;
FT_Outline_Get_CBox: procedure(const outline: FT_Outline; out acbo: FT_BBox); cdecl;
FT_Outline_Get_Orientation: function(const outline: FT_Outline): FT_Orientation; cdecl;
FT_Outline_New: function(Alibrary: FT_Library; numPoints: FT_UInt; numContours: FT_Int; var anoutline: FT_Outline): FT_Error; cdecl;
FT_Outline_New_Internal: function(memory: FT_Memory; numPoints: FT_UInt; numContours: FT_Int; var anoutline: FT_Outline): FT_Error; cdecl;
FT_Outline_Render: function(Alibrary: FT_Library; var outline: FT_Outline; const params: FT_Raster_Params): FT_Error; cdecl;
FT_Outline_Reverse: procedure(const outline: FT_Outline); cdecl;
FT_Outline_Transform: procedure(var outline: FT_Outline; const matrix: FT_Matrix); cdecl;
FT_Outline_Translate: procedure(var outline: FT_Outline; xOffset: FT_Pos; yOffset: FT_Pos); cdecl;
FT_Remove_Module: function(Alibrary: FT_Library; module: FT_Module): FT_Error; cdecl;
FT_Render_Glyph: function(slot: FT_GlyphSlot; render_mode: FT_Render_Mode): FT_Error; cdecl;
FT_Request_Size: function(face: FT_Face; req: FT_Size_Request): FT_Error; cdecl;
FT_RoundFix: function(a: FT_Fixed): FT_Fixed; cdecl;
FT_Select_Charmap: function(face: FT_Face; encoding: FT_Encoding): FT_Error; cdecl;
FT_Select_Size: function(face: FT_Face; strike_index: FT_Int): FT_Error; cdecl;
FT_Set_Char_Size: function( face: FT_Face_ptr; char_width, char_height: FT_F26dot6; horz_res, vert_res: FT_UInt): FT_Error; cdecl;
FT_Set_Charmap: function(face: FT_Face; charmap: FT_CharMap): FT_Error; cdecl;
FT_Set_Debug_Hook: procedure(Alibrary: FT_Library; hook_index: FT_UInt; debug_hook: FT_DebugHook_Func); cdecl;
FT_Set_MM_Blend_Coordinates: function(face: FT_Face; num_coords: FT_UInt; var coords: FT_Fixed): FT_Error; cdecl;
FT_Set_MM_Design_Coordinates: function(face: FT_Face; num_coords: FT_UInt; coords: FT_Long_ptr): FT_Error; cdecl;
FT_Set_Pixel_Sizes: function( face: FT_Face_ptr; pixel_width, pixel_height: FT_UInt): FT_Error; cdecl;
FT_Set_Renderer: function(Alibrary: FT_Library; renderer: FT_Renderer; num_params: FT_UInt; const parameters: FT_Parameter): FT_Error; cdecl;
FT_Set_Transform: procedure(face: FT_Face; var matrix: FT_Matrix; var delta: FT_Vector); cdecl;
FT_Set_Var_Blend_Coordinates: function(face: FT_Face; num_coords: FT_UInt; coords: FT_Fixed_ptr): FT_Error; cdecl;
FT_Set_Var_Design_Coordinates: function(face: FT_Face; num_coords: FT_UInt; coords: FT_Fixed_ptr): FT_Error; cdecl;
FT_Sfnt_Table_Info: function(face: FT_Face; table_index: FT_UInt; var tag: FT_ULong; var length: FT_ULong): FT_Error; cdecl;
FT_Sin: function(angle: FT_Angle): FT_Fixed; cdecl;
FT_Stream_OpenGzip: function(stream: FT_Stream; sourc: FT_Stream): FT_Error; cdecl;
FT_Stream_OpenLZW: function(stream: FT_Stream; sourc: FT_Stream): FT_Error; cdecl;
FT_Stroker_BeginSubPath: function(stroker: FT_Stroker; const ato: FT_Vector; open: FT_Bool): FT_Error; cdecl;
FT_Stroker_ConicTo: function(stroker: FT_Stroker; const control: FT_Vector; var t: FT_Vector): FT_Error; cdecl;
FT_Stroker_CubicTo: function(stroker: FT_Stroker; const control1: FT_Vector; const control2: FT_Vector; var ato: FT_Vector): FT_Error; cdecl;
FT_Stroker_Done: procedure(stroker: FT_Stroker); cdecl;
FT_Stroker_EndSubPath: function(stroker: FT_Stroker): FT_Error; cdecl;
FT_Stroker_Export: procedure(stroker: FT_Stroker; var outline: FT_Outline); cdecl;
FT_Stroker_ExportBorder: procedure(stroker: FT_Stroker; border: FT_StrokerBorder; var outline: FT_Outline); cdecl;
FT_Stroker_GetBorderCounts: function(stroker: FT_Stroker; border: FT_StrokerBorder; anum_points: FT_UInt_ptr; anum_contours: FT_UInt_ptr): FT_Error; cdecl;
FT_Stroker_GetCounts: function(stroker: FT_Stroker; anum_points: FT_UInt_ptr; anum_contours: FT_UInt_ptr): FT_Error; cdecl;
FT_Stroker_LineTo: function(stroker: FT_Stroker; var ato: FT_Vector): FT_Error; cdecl;
FT_Stroker_New: function(Alibrary: FT_Library; var astroker: FT_Stroker): FT_Error; cdecl;
FT_Stroker_ParseOutline: function(stroker: FT_Stroker; const outline: FT_Outline; opened: FT_Bool): FT_Error; cdecl;
FT_Stroker_Rewind: procedure(stroker: FT_Stroker); cdecl;
FT_Stroker_Set: procedure(stroker: FT_Stroker; radius: FT_Fixed; line_cap: FT_Stroker_LineCap; line_join: FT_Stroker_LineJoin; miter_limit: FT_Fixed); cdecl;
FT_Tan: function(angle: FT_Angle): FT_Fixed; cdecl;
FT_TrueTypeGX_Free: procedure(face: FT_Face; table: FT_Bytes); cdecl;
FT_TrueTypeGX_Validate: function(face: FT_Face; validation_flags: FT_UInt; const tables: FT_Tables; table_length: FT_UInt): FT_Error; cdecl;
FT_Vector_From_Polar: procedure(var vec: FT_Vector; length: FT_Fixed; angle: FT_Angle); cdecl;
FT_Vector_Length: function(var vec: FT_Vector): FT_Fixed; cdecl;
FT_Vector_Polarize: procedure(const vec: FT_Vector; var length: FT_Fixed; var angl: FT_Angle); cdecl;
FT_Vector_Rotate: procedure(var vec: FT_Vector; angle: FT_Angle); cdecl;
FT_Vector_Transform: procedure(var vec: FT_Vector; const matrix: FT_Matrix); cdecl;
FT_Vector_Unit: procedure(var vec: FT_Vector; angle: FT_Angle); cdecl;

Description

Functions and Procedures

function FT_Curve_Tag(flag: char): char;
function FT_Is_Scalable(face: FT_Face): boolean;
function FT_Has_Kerning(face: FT_Face): boolean;
function InitFreetype: Boolean;
procedure CloseFreetype;
function InitFreetypeFromLibrary(const FTName: WideString): Boolean;
function IsFreetypeInitialized: Boolean;

Types

FT_Encoding = array[0..3] of char;
FT_Pointer = pointer;
FT_Byte = byte;
FT_Byte_array = array[0..MaxInt div (2*SizeOf(FT_Byte))-1] of FT_Byte;
FT_Bytes = ˆFT_Byte_array;
FT_Short = smallint;
FT_UShort = word;
FT_Int = longint;
FT_UInt = longword;
FT_Int32 = longint;
FT_UInt32 = cardinal;
FT_Long = longint;
FT_ULong = longword;
FT_Fixed = longint;
FT_Bool = bytebool;
FT_Char = ShortInt;
FT_Pos = longint;
FT_Error = longint;
FT_F26Dot6 = longint;
FT_String = AnsiChar;
FT_Byte_ptr = ˆFT_Byte;
FT_Short_array = array[0..MaxInt div (2*SizeOf(FT_Short))-1] of FT_Short;
FT_Short_ptr = ˆFT_Short_array;
FT_Long_ptr = ˆFT_Long;
FT_Fixed_ptr = ˆFT_Fixed;
FT_UInt_ptr = ˆFT_UInt;
FT_Render_Mode = FT_Int;
FT_Library = ˆFT_LibraryRec_;
FT_Library_array = array[0..MaxInt div 16 - 1] of FT_Library;
FT_Library_ptr = ˆFT_Library_array;
FT_Subglyph_ptr = ˆFT_Subglyph;
AFT_Bitmap_Size = array[0..1023] of FT_Bitmap_Size;
FT_Bitmap_Size_ptr = ˆAFT_Bitmap_Size;
FT_Generic_Finalizer = procedure(AnObject: pointer); cdecl;
FT_BBox_ptr = ˆFT_BBox;
FT_Vector_ptr = ˆFT_Vector_array;
FT_Vector_array = array[0..MaxInt div (2*SizeOf(FT_Vector)) - 1] of FT_Vector;
FT_Bitmap_ptr = ˆFT_Bitmap;
FT_Outline = ˆFT_OutlineRec_;
FT_Face = ˆFT_FaceRec_;
FT_Face_array = array[0..MaxInt div 16 - 1] of FT_Face;
FT_Face_ptr = ˆFT_Face_array;
FT_GlyphSlot = ˆFT_GlyphSlotRec_;
FT_Size = ˆFT_SizeRec_;
FT_Charmap = ˆFT_CharmapRec_;
FT_Charmap_ptr = ˆFT_Charmap_array;
FT_Charmap_array = array[0..MaxInt div 16 - 1] of FT_Charmap;
FTC_CMapCache = ˆFTC_CMapCacheRec_;
FTC_FaceID = FT_Pointer;
FTC_Manager = ˆFTC_ManagerRec_;
FTC_ImageCache = ˆFTC_ImageCacheRec_;
FTC_ImageType = ˆFTC_ImageTypeRec_;
FT_Glyph = ˆFT_GlyphRec_;
FTC_Node = ˆFTC_NodeRec_;
FTC_Scaler = ˆFTC_ScalerRec_;
FT_Angle = FT_Fixed;
FTC_Face_Requester = function(face_id: FTC_FaceID; Alibrary: FT_Library; request_data: FT_Pointer; var aface: FT_Face): FT_Error; cdecl;
FTC_SBitCache = ˆFTC_SBitCacheRec_;
FTC_SBit = ˆFTC_SBitRec_;
FT_Module_Class = FT_Pointer;
FT_Module = ˆFT_ModuleRec_;
PS_FontInfo = ˆPS_FontInfoRec_;
PS_Private = ˆPS_PrivateRec_;
FT_Glyph_Format = (...);
Values
  • FT_GLYPH_FORMAT_NONE = $00000000:
  • FT_GLYPH_FORMAT_COMPOSITE = $706D6F63:
  • FT_GLYPH_FORMAT_BITMAP = $73746962:
  • FT_GLYPH_FORMAT_OUTLINE = $6C74756F:
  • FT_GLYPH_FORMAT_PLOTTER = $746F6C70:
FT_Glyph_Class = ˆFT_Glyph_ClassRec_;
FT_Raster = ˆFT_RasterRec_;
pFT_Raster_Params = ˆFT_Raster_Params;
FT_Raster_Render_Func = function(raster: FT_Raster; params: pFT_Raster_Params): Integer; cdecl;
FT_Renderer = ˆFT_RendererRec_;
FT_Renderer_RenderFunc = function(renderer: FT_Renderer; slot: FT_GlyphSlot; mode: FT_UInt; const origin: FT_Vector): FT_Error; cdecl;
FT_Renderer_TransformFunc = function(renderer: FT_Renderer; slot: FT_GlyphSlot; const matrix: FT_Matrix; const delta: FT_Vector): FT_Error; cdecl;
FT_Renderer_GetCBoxFunc = procedure(renderer: FT_Renderer; slot: FT_GlyphSlot; var cbox: FT_BBox); cdecl;
FT_Renderer_SetModeFunc = function(renderer: FT_Renderer; mode_tag: FT_ULong; mode_ptr: FT_Pointer): FT_Error; cdecl;
FT_Raster_NewFunc = function(memory: Pointer; var raster: FT_Raster): Integer; cdecl;
FT_Raster_ResetFunc = procedure(raster: FT_Raster; pool_base: PAnsiChar; pool_size: PtrUint); cdecl;
FT_Raster_SetModeFunc = function(raster: FT_Raster; mode: PtrUint; args: Pointer): Integer; cdecl;
FT_Raster_RenderFunc = function(raster: FT_Raster; params: pFT_Raster_Params): Integer; cdecl;
FT_Raster_DoneFunc = procedure(raster: FT_Raster); cdecl;
FT_Memory = ˆFT_MemoryRec_;
FT_Alloc_Func = function(memory: FT_Memory; size: LongInt): Pointer;
FT_Free_Func = procedure(memory: FT_Memory; block: Pointer); cdecl;
FT_Realloc_Func = function(memory: FT_Memory; cur_size: LongInt; new_size: LongInt; block: Pointer): Pointer; cdecl;
FT_Sfnt_Tag = (...);
Values
  • ft_sfnt_head = 0:
  • ft_sfnt_maxp = 1:
  • ft_sfnt_os2 = 2:
  • ft_sfnt_hhea = 3:
  • ft_sfnt_vhea = 4:
  • ft_sfnt_post = 5:
  • ft_sfnt_pclt = 6:
FT_TrueTypeEngineType = (...);
Values
  • FT_TRUETYPE_ENGINE_TYPE_NONE:
  • FT_TRUETYPE_ENGINE_TYPE_UNPATENTED:
  • FT_TRUETYPE_ENGINE_TYPE_PATENTE:
FT_Stroker = ˆFT_StrokerRec_;
FT_ListNode = ˆFT_ListNodeRec_;
FT_List = ˆFT_ListRec_;
FT_List_Destructor = procedure(memory: FT_Memory; data: Pointer; user: Pointer); cdecl;
FT_List_Iterator = function(node: FT_ListNode; user: Pointer): FT_Error; cdecl;
FT_StrokerBorder = (...);
Values
  • FT_STROKER_BORDER_LEFT:
  • FT_STROKER_BORDER_RIGHT:
FT_Orientation = (...);
Values
  • FT_ORIENTATION_TRUETYPE = 0:
  • FT_ORIENTATION_POSTSCRIPT = 1:
  • FT_ORIENTATION_FILL_RIGHT = FT_ORIENTATION_TRUETYPE:
  • FT_ORIENTATION_FILL_LEFT = FT_ORIENTATION_POSTSCRIPT:
  • FT_ORIENTATION_NONE = 3:
FT_SpanFunc = procedure(y: Integer; count: Integer; var spans: FT_Span; user: Pointer); cdecl;
FT_Raster_BitTest_Func = function(y: Integer; x: Integer; user: Pointer): Integer; cdecl;
FT_Raster_BitSet_Func = procedure(y: Integer; x: Integer; user: Pointer); cdecl;
FT_Size_Request_Type = (...);
Values
  • FT_SIZE_REQUEST_TYPE_NOMINAL:
  • FT_SIZE_REQUEST_TYPE_REAL_DIM:
  • FT_SIZE_REQUEST_TYPE_BBOX:
  • FT_SIZE_REQUEST_TYPE_CELL:
  • FT_SIZE_REQUEST_TYPE_SCALES:
  • FT_SIZE_REQUEST_TYPE_MAX:
FT_Size_Request = ˆFT_Size_RequestRec_;
FT_DebugHook_Func = procedure(arg: Pointer); cdecl;
FT_Stream = ˆFT_StreamRec_;
FT_Stream_IoFunc = function(stream: FT_Stream; offset: PtrUint; buffer: PAnsiChar; count: PtrUint): PtrUint; cdecl;
FT_Stream_CloseFunc = procedure(stream: FT_Stream); cdecl;
FT_Stroker_LineCap = (...);
Values
  • FT_STROKER_LINECAP_BUTT:
  • FT_STROKER_LINECAP_ROUND:
  • FT_STROKER_LINECAP_SQUARE:
FT_Stroker_LineJoin = (...);
Values
  • FT_STROKER_LINEJOIN_ROUND:
  • FT_STROKER_LINEJOIN_BEVEL:
  • FT_STROKER_LINEJOIN_MITE:
FT_Outline_MoveToFunc = function(const ato: FT_Vector; user: Pointer): Integer; cdecl;
FT_Outline_LineToFunc = function(const ato: FT_Vector; user: Pointer): Integer; cdecl;
FT_Outline_ConicToFunc = function(const control: FT_Vector; const ato: FT_Vector; user: Pointer): Integer; cdecl;
FT_Outline_CubicToFunc = function(const control1: FT_Vector; const control2: FT_Vector; const ato: FT_Vector; user: Pointer): Integer; cdecl;
FT_Tables = array[0..FT_VALIDATE_GX_LENGTH - 1] of FT_Bytes;

Constants

FTLIBNAME = 'freetype.dll';
FT_CURVE_TAG_ON = 1;
FT_CURVE_TAG_CONIC = 0;
FT_CURVE_TAG_CUBIC = 2;
FT_FACE_FLAG_SCALABLE = 1 shl 0;
FT_FACE_FLAG_KERNING = 1 shl 6;
FT_ENCODING_NONE: FT_Encoding = (#0, #0, #0, #0);
FT_LOAD_DEFAULT = $0000;
FT_LOAD_NO_HINTING = $0002;
FT_LOAD_FORCE_AUTOHINT = $0020;
FT_RENDER_MODE_NORMAL = 0;
FT_RENDER_MODE_LIGHT = FT_RENDER_MODE_NORMAL + 1;
FT_RENDER_MODE_MONO = FT_RENDER_MODE_LIGHT + 1;
FT_RENDER_MODE_LCD = FT_RENDER_MODE_MONO + 1;
FT_RENDER_MODE_LCD_V = FT_RENDER_MODE_LCD + 1;
FT_RENDER_MODE_MAX = FT_RENDER_MODE_LCD_V + 1;
FT_KERNING_DEFAULT = 0;
FT_KERNING_UNFITTED = 1;
FT_KERNING_UNSCALED = 2;
FT_STYLE_FLAG_ITALIC = 1 shl 0;
FT_STYLE_FLAG_BOLD = 1 shl 1;
T1_MAX_MM_AXIS = 4;
FT_VALIDATE_feat_INDEX = 0;
FT_VALIDATE_mort_INDEX = 1;
FT_VALIDATE_morx_INDEX = 2;
FT_VALIDATE_bsln_INDEX = 3;
FT_VALIDATE_just_INDEX = 4;
FT_VALIDATE_kern_INDEX = 5;
FT_VALIDATE_opbd_INDEX = 6;
FT_VALIDATE_trak_INDEX = 7;
FT_VALIDATE_prop_INDEX = 8;
FT_VALIDATE_lcar_INDEX = 9;
FT_VALIDATE_GX_LAST_INDEX = FT_VALIDATE_lcar_INDEX;
FT_VALIDATE_GX_LENGTH = FT_VALIDATE_GX_LAST_INDEX + 1;
FT_OPEN_MEMORY = $1;
FT_OPEN_STREAM = $2;
FT_OPEN_PATHNAME = $4;
FT_OPEN_DRIVER = $8;
FT_OPEN_PARAMS = $10;
FT_OUTLINE_NONE = $0;
FT_OUTLINE_OWNER = $1;
FT_OUTLINE_EVEN_ODD_FILL = $2;
FT_OUTLINE_REVERSE_FILL = $4;
FT_OUTLINE_IGNORE_DROPOUTS = $8;
FT_OUTLINE_HIGH_PRECISION = $100;
FT_OUTLINE_SINGLE_PASS = $200;

Variables

FTC_CMapCache_Lookup: function(cache: FTC_CMapCache; face_id: FTC_FaceID; cmap_index: FT_Int; char_code: FT_UInt32): FT_UInt; cdecl;
FTC_CMapCache_New: function(manager: FTC_Manager; var acache: FTC_ImageCache): FT_Error; cdecl;
FTC_ImageCache_Lookup: function(cache: FTC_ImageCache; Atype: FTC_ImageType; gindex: FT_UInt; var aglyph: FT_Glyph; var anode: FTC_Node): FT_Error; cdecl;
FTC_ImageCache_LookupScaler: function(cache: FTC_ImageCache; scaler: FTC_Scaler; load_flags: FT_ULong; gindex: FT_UInt; var aglyph: FT_Glyph; var anode: FTC_Node): FT_Error; cdecl;
FTC_ImageCache_New: function(manager: FTC_Manager; var acache: FTC_ImageCache): FT_Error; cdecl;
FTC_Manager_Done: procedure(manager: FTC_Manager); cdecl;
FTC_Manager_LookupFace: function(manager: FTC_Manager; face_id: FTC_FaceID; var aface: FT_Face): FT_Error; cdecl;
FTC_Manager_LookupSize: function(manager: FTC_Manager; scaler: FTC_Scaler; var asize: FT_Size): FT_Error; cdecl;
FTC_Manager_New: function(Alibrary: FT_Library; max_faces: FT_UInt; max_sizes: FT_UInt; max_bytes: FT_ULong; requester: FTC_Face_Requester; req_data: FT_Pointer; var amanager: FTC_Manager): FT_Error; cdecl;
FTC_Manager_RemoveFaceID: procedure(manager: FTC_Manager; face_id: FTC_FaceID); cdecl;
FTC_Manager_Reset: procedure(manager: FTC_Manager); cdecl;
FTC_Node_Unref: procedure(node: FTC_Node; manage: FTC_Manager); cdecl;
FTC_SBitCache_Lookup: function(cache: FTC_SBitCache; Atype: FTC_ImageType; gindex: FT_UInt; var sbit: FTC_SBit; var anode: FTC_Node): FT_Error; cdecl;
FTC_SBitCache_LookupScaler: function(cache: FTC_SBitCache; scaler: FTC_Scaler; load_flags: FT_ULong; gindex: FT_UInt; var sbit: FTC_SBit; var anode: FTC_Node): FT_Error; cdecl;
FTC_SBitCache_New: function(manager: FTC_Manager; var acache: FTC_SBitCache): FT_Error; cdecl;
FT_Activate_Size: function(size: FT_Size): FT_Error; cdecl;
FT_Add_Default_Modules: function(Alibrary: FT_Library): FT_Error; cdecl;
FT_Add_Module: function(Alibrary: FT_Library; const clazz: FT_Module_Class): FT_Error; cdecl;
FT_Angle_Diff: function(angle1: FT_Angle; angle2: FT_Angle): FT_Angle; cdecl;
FT_Atan2: function(x: FT_Fixed; y: FT_Fixed): FT_Angle; cdecl;
FT_Attach_File: function(face: FT_Face; filepathname: PAnsiChar): FT_Error; cdecl;
FT_Attach_Stream: function(face: FT_Face; const parameters: FT_Open_Args): FT_Error; cdecl;
FT_Bitmap_Convert: function(Alibrary: FT_Library; const source: FT_Bitmap; var target: FT_Bitmap; alignment: FT_Int): FT_Error; cdecl;
FT_Bitmap_Copy: function(Alibrary: FT_Library; const source: FT_Bitmap; var target: FT_Bitmap): FT_Error; cdecl;
FT_Bitmap_Done: function(Alibrary: FT_Library; var bitmap: FT_Bitmap): FT_Error; cdecl;
FT_Bitmap_Embolden: function(Alibrary: FT_Library; var bitmap: FT_Bitmap; xStrength: FT_Pos; yStrength: FT_Pos): FT_Error; cdecl;
FT_Bitmap_New: procedure(var abitmap: FT_Bitmap); cdecl;
FT_CeilFix: function(a: FT_Fixed): FT_Fixed; cdecl;
FT_ClassicKern_Free: procedure(face: FT_Face; table: FT_Bytes); cdecl;
FT_ClassicKern_Validate: function(face: FT_Face; validation_flags: FT_UInt; var ckern_table: FT_Bytes): FT_Error; cdecl;
FT_Cos: function(angle: FT_Angle): FT_Fixed; cdecl;
FT_DivFix: function(a: FT_Long; b: FT_Long): FT_Long; cdecl;
FT_Done_Face: function(face: FT_Face): FT_Error; cdecl;
FT_Done_FreeType: function(alibrary: FT_Library): FT_Error; cdecl;
FT_Done_Glyph: procedure(glyph: FT_Glyph); cdecl;
FT_Done_Library: function(Alibrary: FT_Library): FT_Error; cdecl;
FT_Done_Size: function(size: FT_Size): FT_Error; cdecl;
FT_Face_CheckTrueTypePatents: function(face: FT_Face): FT_Bool; cdecl;
FT_Face_SetUnpatentedHinting: function(face: FT_Face; value: FT_Bool): FT_Bool; cdecl;
FT_FloorFix: function(a: FT_Fixed): FT_Fixed; cdecl;
FT_Get_CMap_Format: function(charmap: FT_CharMap): FT_Long; cdecl;
FT_Get_CMap_Language_ID: function(charmap: FT_CharMap): FT_ULong; cdecl;
FT_Get_Char_Index: function(face: FT_Face; charcode: FT_ULong): FT_UInt; cdecl;
FT_Get_Charmap_Index: function(charmap: FT_CharMap): FT_Int; cdecl;
FT_Get_First_Char: function(face: FT_Face; var agindex: FT_UInt): FT_ULong; cdecl;
FT_Get_Glyph: function(slot: FT_GlyphSlot; var aglyph: FT_Glyph): FT_Error; cdecl;
FT_Get_Glyph_Name: function(face: FT_Face; glyph_index: FT_UInt; buffer: FT_Pointer; buffer_max: FT_UInt): FT_Error; cdecl;
FT_Get_Kerning: function( face: FT_Face; left_glyph, right_glyph, kern_mode: FT_UInt; var akerning: FT_Vector): FT_Error; cdecl;
FT_Get_MM_Var: function(face: FT_Face; var amaster: FT_MM_Var): FT_Error; cdecl;
FT_Get_Module: function(Alibrary: FT_Library; module_name: PAnsiChar): FT_Module; cdecl;
FT_Get_Multi_Master: function(face: FT_Face; var amaster: FT_Multi_Master): FT_Error; cdecl;
FT_Get_Name_Index: function(face: FT_Face; var glyph_name: FT_String): FT_UInt; cdecl;
FT_Get_Next_Char: function(face: FT_Face; char_code: FT_ULong; var agindex: FT_UInt): FT_ULong; cdecl;
FT_Get_PFR_Advance: function(face: FT_Face; gindex: FT_UInt; var aadvance: FT_Pos): FT_Error; cdecl;
FT_Get_PFR_Kerning: function(face: FT_Face; left: FT_UInt; right: FT_UInt; var avector: FT_Vector): FT_Error; cdecl;
FT_Get_PFR_Metrics: function(face: FT_Face; var aoutline_resolution: FT_UInt; var ametrics_resolution: FT_UInt; ametrics_x_scale: FT_Fixed; ametrics_y_scale: FT_Fixed): FT_Error; cdecl;
FT_Get_PS_Font_Info: function(face: FT_Face; afont_info: PS_FontInfo): FT_Error; cdecl;
FT_Get_PS_Font_Private: function(face: FT_Face; afont_private: PS_Private): FT_Error; cdecl;
FT_Get_Postscript_Name: function(face: FT_Face): PAnsiChar; cdecl;
FT_Get_Renderer: function(Alibrary: FT_Library; format: FT_Glyph_Format): FT_Renderer; cdecl;
FT_Get_Sfnt_Name: function(face: FT_Face; idx: FT_UInt; var aname: FT_SfntName): FT_Error; cdecl;
FT_Get_Sfnt_Name_Count: function(face: FT_Face): FT_UInt; cdecl;
FT_Get_Sfnt_Table: function(face: FT_Face; tag: FT_Sfnt_Tag): Pointer; cdecl;
FT_Get_SubGlyph_Info: function(glyph: FT_GlyphSlot; sub_index: FT_UInt; var p_index: FT_Int; var p_flags: FT_UInt; var p_arg1: FT_Int; var p_arg2: FT_Int; var p_transform: FT_Matrix): FT_Error; cdecl;
FT_Get_Track_Kerning: function(face: FT_Face; point_size: FT_Fixed; degree: FT_Int; var akerning: FT_Fixed): FT_Error; cdecl;
FT_Get_TrueType_Engine_Type: function(Alibrary: FT_Library): FT_TrueTypeEngineType; cdecl;
FT_Get_WinFNT_Header: function(face: FT_Face; var aheader: FT_WinFNT_HeaderRec): FT_Error; cdecl;
FT_GlyphSlot_Embolden: procedure(slot: FT_GlyphSlot); cdecl;
FT_GlyphSlot_Oblique: procedure(slot: FT_GlyphSlot); cdecl;
FT_GlyphSlot_Own_Bitmap: function(slot: FT_GlyphSlot): FT_Error; cdecl;
FT_Glyph_Copy: function(source: FT_Glyph; var target: FT_Glyph): FT_Error; cdecl;
FT_Glyph_Get_CBox: procedure(glyph: FT_Glyph; bbox_mode: FT_UInt; var acbo: FT_BBox); cdecl;
FT_Glyph_Stroke: function(var pglyph: FT_Glyph; stroker: FT_Stroker; destroy: FT_Bool): FT_Error; cdecl;
FT_Glyph_StrokeBorder: function(var pglyph: FT_Glyph; stroker: FT_Stroker; inside: FT_Bool; destroy: FT_Bool): FT_Error; cdecl;
FT_Glyph_To_Bitmap: function(var the_glyph: FT_Glyph; render_mode: FT_Render_Mode; var origin: FT_Vector; destroy: FT_Bool): FT_Error; cdecl;
FT_Glyph_Transform: function(glyph: FT_Glyph; var matrix: FT_Matrix; var delta: FT_Vector): FT_Error; cdecl;
FT_Has_PS_Glyph_Names: function(face: FT_Face): FT_Int; cdecl;
FT_Init_FreeType: function(alibrary: FT_Library): FT_Error; cdecl;
FT_Library_Version: procedure(Alibrary: FT_Library; var amajor: FT_Int; var aminor: FT_Int; var apatch: FT_Int); cdecl;
FT_List_Add: procedure(list: FT_List; node: FT_ListNode); cdecl;
FT_List_Finalize: procedure(list: FT_List; destroy: FT_List_Destructor; memory: FT_Memory; user: Pointer); cdecl;
FT_List_Find: function(list: FT_List; data: Pointer): FT_ListNode; cdecl;
FT_List_Insert: procedure(list: FT_List; node: FT_ListNode); cdecl;
FT_List_Iterate: function(list: FT_List; iterator: FT_List_Iterator; user: Pointer): FT_Error; cdecl;
FT_List_Remove: procedure(list: FT_List; node: FT_ListNode); cdecl;
FT_List_Up: procedure(list: FT_List; node: FT_ListNode); cdecl;
FT_Load_Char: function(face: FT_Face; char_code: FT_ULong; load_flags: FT_Int32): FT_Error; cdecl;
FT_Load_Glyph: function( face: FT_Face; glyph_index: FT_UInt; load_flags: FT_Int32): FT_Error; cdecl;
FT_Load_Sfnt_Table: function(face: FT_Face; tag: FT_ULong; offset: FT_Long; var buffer: FT_Byte; var length: FT_ULong): FT_Error; cdecl;
FT_Matrix_Invert: function(var matrix: FT_Matrix): FT_Error; cdecl;
FT_Matrix_Multiply: procedure(var a: FT_Matrix; var b: FT_Matrix); cdecl;
FT_MulDiv: function(a: FT_Long; b: FT_Long; c: FT_Long): FT_Long; cdecl;
FT_MulFix: function(a: FT_Long; b: FT_Long): FT_Long; cdecl;
FT_New_Face: function( library_: FT_Library; filepathname: PAnsiChar; face_index: FT_Long; var aface: FT_Face): FT_Error; cdecl;
FT_New_Library: function(memory: FT_Memory; var alibrary: FT_Library): FT_Error; cdecl;
FT_New_Memory_Face: function( library_: FT_Library; file_base: FT_Byte_ptr; file_size, face_index: FT_Long; var aface: FT_Face): FT_Error; cdecl;
FT_New_Size: function(face: FT_Face; var size: FT_Size): FT_Error; cdecl;
FT_OpenType_Free: procedure(face: FT_Face; table: FT_Bytes); cdecl;
FT_OpenType_Validate: function(face: FT_Face; validation_flags: FT_UInt; var BASE_table: FT_Bytes; var GDEF_table: FT_Bytes; var GPOS_table: FT_Bytes; var GSUB_table: FT_Bytes; var JSTF_table: FT_Bytes): FT_Error; cdecl;
FT_Open_Face: function(Alibrary: FT_Library; const args: FT_Open_Args; face_index: FT_Long; var aface: FT_Face): FT_Error; cdecl;
FT_Outline_Check: function(var outline: FT_Outline): FT_Error; cdecl;
FT_Outline_Copy: function(const source: FT_Outline; var target: FT_Outline): FT_Error; cdecl;
FT_Outline_Decompose: function(var outline: FT_Outline; const func_interface: FT_Outline_Funcs; use: Pointer): FT_Error; cdecl;
FT_Outline_Done: function(Alibrary: FT_Library; var outline: FT_Outline): FT_Error; cdecl;
FT_Outline_Done_Internal: function(memory: FT_Memory; var outline: FT_Outline): FT_Error; cdecl;
FT_Outline_Embolden: function(var outline: FT_Outline; strength: FT_Pos): FT_Error; cdecl;
FT_Outline_GetInsideBorder: function(const outline: FT_Outline): FT_StrokerBorder; cdecl;
FT_Outline_GetOutsideBorder: function(const outline: FT_Outline): FT_StrokerBorder; cdecl;
FT_Outline_Get_BBox: function(const outline: FT_Outline; var abbox: FT_BBox): FT_Error; cdecl;
FT_Outline_Get_Bitmap: function(Alibrary: FT_Library; const outline: FT_Outline; var abitmap: FT_Bitmap): FT_Error; cdecl;
FT_Outline_Get_CBox: procedure(const outline: FT_Outline; out acbo: FT_BBox); cdecl;
FT_Outline_Get_Orientation: function(const outline: FT_Outline): FT_Orientation; cdecl;
FT_Outline_New: function(Alibrary: FT_Library; numPoints: FT_UInt; numContours: FT_Int; var anoutline: FT_Outline): FT_Error; cdecl;
FT_Outline_New_Internal: function(memory: FT_Memory; numPoints: FT_UInt; numContours: FT_Int; var anoutline: FT_Outline): FT_Error; cdecl;
FT_Outline_Render: function(Alibrary: FT_Library; var outline: FT_Outline; const params: FT_Raster_Params): FT_Error; cdecl;
FT_Outline_Reverse: procedure(const outline: FT_Outline); cdecl;
FT_Outline_Transform: procedure(var outline: FT_Outline; const matrix: FT_Matrix); cdecl;
FT_Outline_Translate: procedure(var outline: FT_Outline; xOffset: FT_Pos; yOffset: FT_Pos); cdecl;
FT_Remove_Module: function(Alibrary: FT_Library; module: FT_Module): FT_Error; cdecl;
FT_Render_Glyph: function(slot: FT_GlyphSlot; render_mode: FT_Render_Mode): FT_Error; cdecl;
FT_Request_Size: function(face: FT_Face; req: FT_Size_Request): FT_Error; cdecl;
FT_RoundFix: function(a: FT_Fixed): FT_Fixed; cdecl;
FT_Select_Charmap: function(face: FT_Face; encoding: FT_Encoding): FT_Error; cdecl;
FT_Select_Size: function(face: FT_Face; strike_index: FT_Int): FT_Error; cdecl;
FT_Set_Char_Size: function( face: FT_Face_ptr; char_width, char_height: FT_F26dot6; horz_res, vert_res: FT_UInt): FT_Error; cdecl;
FT_Set_Charmap: function(face: FT_Face; charmap: FT_CharMap): FT_Error; cdecl;
FT_Set_Debug_Hook: procedure(Alibrary: FT_Library; hook_index: FT_UInt; debug_hook: FT_DebugHook_Func); cdecl;
FT_Set_MM_Blend_Coordinates: function(face: FT_Face; num_coords: FT_UInt; var coords: FT_Fixed): FT_Error; cdecl;
FT_Set_MM_Design_Coordinates: function(face: FT_Face; num_coords: FT_UInt; coords: FT_Long_ptr): FT_Error; cdecl;
FT_Set_Pixel_Sizes: function( face: FT_Face_ptr; pixel_width, pixel_height: FT_UInt): FT_Error; cdecl;
FT_Set_Renderer: function(Alibrary: FT_Library; renderer: FT_Renderer; num_params: FT_UInt; const parameters: FT_Parameter): FT_Error; cdecl;
FT_Set_Transform: procedure(face: FT_Face; var matrix: FT_Matrix; var delta: FT_Vector); cdecl;
FT_Set_Var_Blend_Coordinates: function(face: FT_Face; num_coords: FT_UInt; coords: FT_Fixed_ptr): FT_Error; cdecl;
FT_Set_Var_Design_Coordinates: function(face: FT_Face; num_coords: FT_UInt; coords: FT_Fixed_ptr): FT_Error; cdecl;
FT_Sfnt_Table_Info: function(face: FT_Face; table_index: FT_UInt; var tag: FT_ULong; var length: FT_ULong): FT_Error; cdecl;
FT_Sin: function(angle: FT_Angle): FT_Fixed; cdecl;
FT_Stream_OpenGzip: function(stream: FT_Stream; sourc: FT_Stream): FT_Error; cdecl;
FT_Stream_OpenLZW: function(stream: FT_Stream; sourc: FT_Stream): FT_Error; cdecl;
FT_Stroker_BeginSubPath: function(stroker: FT_Stroker; const ato: FT_Vector; open: FT_Bool): FT_Error; cdecl;
FT_Stroker_ConicTo: function(stroker: FT_Stroker; const control: FT_Vector; var t: FT_Vector): FT_Error; cdecl;
FT_Stroker_CubicTo: function(stroker: FT_Stroker; const control1: FT_Vector; const control2: FT_Vector; var ato: FT_Vector): FT_Error; cdecl;
FT_Stroker_Done: procedure(stroker: FT_Stroker); cdecl;
FT_Stroker_EndSubPath: function(stroker: FT_Stroker): FT_Error; cdecl;
FT_Stroker_Export: procedure(stroker: FT_Stroker; var outline: FT_Outline); cdecl;
FT_Stroker_ExportBorder: procedure(stroker: FT_Stroker; border: FT_StrokerBorder; var outline: FT_Outline); cdecl;
FT_Stroker_GetBorderCounts: function(stroker: FT_Stroker; border: FT_StrokerBorder; anum_points: FT_UInt_ptr; anum_contours: FT_UInt_ptr): FT_Error; cdecl;
FT_Stroker_GetCounts: function(stroker: FT_Stroker; anum_points: FT_UInt_ptr; anum_contours: FT_UInt_ptr): FT_Error; cdecl;
FT_Stroker_LineTo: function(stroker: FT_Stroker; var ato: FT_Vector): FT_Error; cdecl;
FT_Stroker_New: function(Alibrary: FT_Library; var astroker: FT_Stroker): FT_Error; cdecl;
FT_Stroker_ParseOutline: function(stroker: FT_Stroker; const outline: FT_Outline; opened: FT_Bool): FT_Error; cdecl;
FT_Stroker_Rewind: procedure(stroker: FT_Stroker); cdecl;
FT_Stroker_Set: procedure(stroker: FT_Stroker; radius: FT_Fixed; line_cap: FT_Stroker_LineCap; line_join: FT_Stroker_LineJoin; miter_limit: FT_Fixed); cdecl;
FT_Tan: function(angle: FT_Angle): FT_Fixed; cdecl;
FT_TrueTypeGX_Free: procedure(face: FT_Face; table: FT_Bytes); cdecl;
FT_TrueTypeGX_Validate: function(face: FT_Face; validation_flags: FT_UInt; const tables: FT_Tables; table_length: FT_UInt): FT_Error; cdecl;
FT_Vector_From_Polar: procedure(var vec: FT_Vector; length: FT_Fixed; angle: FT_Angle); cdecl;
FT_Vector_Length: function(var vec: FT_Vector): FT_Fixed; cdecl;
FT_Vector_Polarize: procedure(const vec: FT_Vector; var length: FT_Fixed; var angl: FT_Angle); cdecl;
FT_Vector_Rotate: procedure(var vec: FT_Vector; angle: FT_Angle); cdecl;
FT_Vector_Transform: procedure(var vec: FT_Vector; const matrix: FT_Matrix); cdecl;
FT_Vector_Unit: procedure(var vec: FT_Vector; angle: FT_Angle); cdecl;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Matrix

packed record FT_Matrix

Unit

LIBFREETYPE

Declaration

type FT_Matrix = packed record

Description

Overview

Fields

xx: FT_Fixed;
xy: FT_Fixed;
yx: FT_Fixed;
yy: FT_Fixed;

Description

Fields

xx: FT_Fixed;
xy: FT_Fixed;
yx: FT_Fixed;
yy: FT_Fixed;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: record FT_LibraryRec_

record FT_LibraryRec_

Unit

LIBFREETYPE

Declaration

type FT_LibraryRec_ = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: record FT_Subglyph

record FT_Subglyph

Unit

LIBFREETYPE

Declaration

type FT_Subglyph = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Bitmap_Size

packed record FT_Bitmap_Size

Unit

LIBFREETYPE

Declaration

type FT_Bitmap_Size = packed record

Description

Overview

Fields

height: FT_Short;
width: FT_Short;

Description

Fields

height: FT_Short;
width: FT_Short;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Generic

packed record FT_Generic

Unit

LIBFREETYPE

Declaration

type FT_Generic = packed record

Description

Overview

Fields

data: pointer;
finalizer: FT_Generic_Finalizer;

Description

Fields

data: pointer;
finalizer: FT_Generic_Finalizer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_BBox

packed record FT_BBox

Unit

LIBFREETYPE

Declaration

type FT_BBox = packed record

Description

Overview

Fields

xMin: FT_Pos;
yMin: FT_Pos;
xMax: FT_Pos;
yMax: FT_Pos;

Description

Fields

xMin: FT_Pos;
yMin: FT_Pos;
xMax: FT_Pos;
yMax: FT_Pos;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Vector

packed record FT_Vector

Unit

LIBFREETYPE

Declaration

type FT_Vector = packed record

Description

Overview

Fields

x: FT_Pos;
y: FT_Pos;

Description

Fields

x: FT_Pos;
y: FT_Pos;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Bitmap

packed record FT_Bitmap

Unit

LIBFREETYPE

Declaration

type FT_Bitmap = packed record

Description

Overview

Fields

rows: FT_Int;
width: FT_Int;
pitch: FT_Int;
buffer: pointer;
num_grays: FT_Short;
pixel_mode: char;
palette_mode: char;
palette: pointer;

Description

Fields

rows: FT_Int;
width: FT_Int;
pitch: FT_Int;
buffer: pointer;
num_grays: FT_Short;
pixel_mode: char;
palette_mode: char;
palette: pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_OutlineRec_

packed record FT_OutlineRec_

Unit

LIBFREETYPE

Declaration

type FT_OutlineRec_ = packed record

Description

Overview

Fields

n_contours: FT_Short;
n_points: FT_Short;
points: FT_Vector_ptr;
tags: PChar;
contours: FT_Short_ptr;
flags: FT_Int;

Description

Fields

n_contours: FT_Short;
n_points: FT_Short;
points: FT_Vector_ptr;
tags: PChar;
contours: FT_Short_ptr;
flags: FT_Int;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Glyph_Metrics

packed record FT_Glyph_Metrics

Unit

LIBFREETYPE

Declaration

type FT_Glyph_Metrics = packed record

Description

Overview

Fields

width: FT_Pos;
height: FT_Pos;
horiBearingX: FT_Pos;
horiBearingY: FT_Pos;
horiAdvance: FT_Pos;
vertBearingX: FT_Pos;
vertBearingY: FT_Pos;
vertAdvance: FT_Pos;

Description

Fields

width: FT_Pos;
height: FT_Pos;
horiBearingX: FT_Pos;
horiBearingY: FT_Pos;
horiAdvance: FT_Pos;
vertBearingX: FT_Pos;
vertBearingY: FT_Pos;
vertAdvance: FT_Pos;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_GlyphSlotRec_

packed record FT_GlyphSlotRec_

Unit

LIBFREETYPE

Declaration

type FT_GlyphSlotRec_ = packed record

Description

Overview

Fields

alibrary: FT_Library_ptr;
face: FT_Face_ptr;
next: FT_GlyphSlot;
flags: FT_UInt;
generic: FT_Generic;
metrics: FT_Glyph_Metrics;
linearHoriAdvance: FT_Fixed;
linearVertAdvance: FT_Fixed;
advance: FT_Vector;
format: longword;
bitmap: FT_Bitmap;
bitmap_left: FT_Int;
bitmap_top: FT_Int;
outline: FT_Outline;
num_subglyphs: FT_UInt;
subglyphs: FT_SubGlyph_ptr;
control_data: pointer;
control_len: longint;
other: pointer;

Description

Fields

alibrary: FT_Library_ptr;
face: FT_Face_ptr;
next: FT_GlyphSlot;
flags: FT_UInt;
generic: FT_Generic;
metrics: FT_Glyph_Metrics;
linearHoriAdvance: FT_Fixed;
linearVertAdvance: FT_Fixed;
advance: FT_Vector;
format: longword;
bitmap: FT_Bitmap;
bitmap_left: FT_Int;
bitmap_top: FT_Int;
outline: FT_Outline;
num_subglyphs: FT_UInt;
subglyphs: FT_SubGlyph_ptr;
control_data: pointer;
control_len: longint;
other: pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: record FT_Size_Metrics

record FT_Size_Metrics

Unit

LIBFREETYPE

Declaration

type FT_Size_Metrics = record

Description

Overview

Fields

x_ppem: FT_UShort;
y_ppem: FT_UShort;
x_scale: FT_Fixed;
y_scale: FT_Fixed;
ascender: FT_Pos;
descender: FT_Pos;
height: FT_Pos;
max_advance: FT_Pos;

Description

Fields

x_ppem: FT_UShort;
y_ppem: FT_UShort;
x_scale: FT_Fixed;
y_scale: FT_Fixed;
ascender: FT_Pos;
descender: FT_Pos;
height: FT_Pos;
max_advance: FT_Pos;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: record FT_SizeRec_

record FT_SizeRec_

Unit

LIBFREETYPE

Declaration

type FT_SizeRec_ = record

Description

Overview

Fields

face: FT_Face_ptr;
generic: FT_Generic;
metrics: FT_Size_Metrics;

Description

Fields

face: FT_Face_ptr;
generic: FT_Generic;
metrics: FT_Size_Metrics;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_FaceRec_

packed record FT_FaceRec_

Unit

LIBFREETYPE

Declaration

type FT_FaceRec_ = packed record

Description

Overview

Fields

num_faces: FT_Long;
face_index: FT_Long;
face_flags: FT_Long;
style_flags: FT_Long;
num_glyphs: FT_Long;
family_name: PChar;
style_name: PChar;
num_fixed_sizes: FT_Int;
available_sizes: FT_Bitmap_Size_ptr;
num_charmaps: FT_Int;
charmaps: FT_CharMap_ptr;
generic: FT_Generic;
bbox: FT_BBox;
units_per_EM: FT_UShort;
ascender: FT_Short;
descender: FT_Short;
height: FT_Short;
max_advance_width: FT_Short;
max_advance_height: FT_Short;
underline_position: FT_Short;
underline_thickness: FT_Short;
glyph: FT_GlyphSlot;
size: FT_Size;
charmap: FT_CharMap;

Description

Fields

num_faces: FT_Long;
face_index: FT_Long;
face_flags: FT_Long;
style_flags: FT_Long;
num_glyphs: FT_Long;
family_name: PChar;
style_name: PChar;
num_fixed_sizes: FT_Int;
available_sizes: FT_Bitmap_Size_ptr;
num_charmaps: FT_Int;
charmaps: FT_CharMap_ptr;
generic: FT_Generic;
bbox: FT_BBox;
units_per_EM: FT_UShort;
ascender: FT_Short;
descender: FT_Short;
height: FT_Short;
max_advance_width: FT_Short;
max_advance_height: FT_Short;
underline_position: FT_Short;
underline_thickness: FT_Short;
glyph: FT_GlyphSlot;
size: FT_Size;
charmap: FT_CharMap;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_CharmapRec_

packed record FT_CharmapRec_

Unit

LIBFREETYPE

Declaration

type FT_CharmapRec_ = packed record

Description

Overview

Fields

face: FT_Face_ptr;
encoding: FT_Encoding;
platform_id: FT_UShort;
encoding_id: FT_UShort;

Description

Fields

face: FT_Face_ptr;
encoding: FT_Encoding;
platform_id: FT_UShort;
encoding_id: FT_UShort;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: record FTC_CMapCacheRec_

record FTC_CMapCacheRec_

Unit

LIBFREETYPE

Declaration

type FTC_CMapCacheRec_ = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: record FTC_ManagerRec_

record FTC_ManagerRec_

Unit

LIBFREETYPE

Declaration

type FTC_ManagerRec_ = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: record FTC_ImageCacheRec_

record FTC_ImageCacheRec_

Unit

LIBFREETYPE

Declaration

type FTC_ImageCacheRec_ = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FTC_ImageTypeRec_

packed record FTC_ImageTypeRec_

Unit

LIBFREETYPE

Declaration

type FTC_ImageTypeRec_ = packed record

Description

Overview

Fields

face_id: FTC_FaceID;
width: FT_Int;
height: FT_Int;
flags: FT_Int32;

Description

Fields

face_id: FTC_FaceID;
width: FT_Int;
height: FT_Int;
flags: FT_Int32;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: record FT_GlyphRec_

record FT_GlyphRec_

Unit

LIBFREETYPE

Declaration

type FT_GlyphRec_ = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: record FTC_NodeRec_

record FTC_NodeRec_

Unit

LIBFREETYPE

Declaration

type FTC_NodeRec_ = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FTC_ScalerRec_

packed record FTC_ScalerRec_

Unit

LIBFREETYPE

Declaration

type FTC_ScalerRec_ = packed record

Description

Overview

Fields

face_id: FTC_FaceID;
width: FT_UInt;
height: FT_UInt;
pixel: FT_Int;
x_res: FT_UInt;
y_res: FT_UInt;

Description

Fields

face_id: FTC_FaceID;
width: FT_UInt;
height: FT_UInt;
pixel: FT_Int;
x_res: FT_UInt;
y_res: FT_UInt;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: record FTC_SBitCacheRec_

record FTC_SBitCacheRec_

Unit

LIBFREETYPE

Declaration

type FTC_SBitCacheRec_ = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FTC_SBitRec_

packed record FTC_SBitRec_

Unit

LIBFREETYPE

Declaration

type FTC_SBitRec_ = packed record

Description

Overview

Fields

width: FT_Byte;
height: FT_Byte;
left: FT_Char;
top: FT_Char;
format: FT_Byte;
max_grays: FT_Byte;
pitch: FT_Short;
xadvance: FT_Char;
yadvance: FT_Char;
buffer: ˆFT_Byte;

Description

Fields

width: FT_Byte;
height: FT_Byte;
left: FT_Char;
top: FT_Char;
format: FT_Byte;
max_grays: FT_Byte;
pitch: FT_Short;
xadvance: FT_Char;
yadvance: FT_Char;
buffer: ˆFT_Byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: record FT_ModuleRec_

record FT_ModuleRec_

Unit

LIBFREETYPE

Declaration

type FT_ModuleRec_ = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_MM_Axis

packed record FT_MM_Axis

Unit

LIBFREETYPE

Declaration

type FT_MM_Axis = packed record

Description

Overview

Fields

name: ˆFT_String;
minimum: FT_Long;
maximum: FT_Long;

Description

Fields

name: ˆFT_String;
minimum: FT_Long;
maximum: FT_Long;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Multi_Master

packed record FT_Multi_Master

Unit

LIBFREETYPE

Declaration

type FT_Multi_Master = packed record

Description

Overview

Fields

num_axis: FT_UInt;
num_designs: FT_UInt;
axis: array[0..T1_MAX_MM_AXIS - 1] of FT_MM_Axis;

Description

Fields

num_axis: FT_UInt;
num_designs: FT_UInt;
axis: array[0..T1_MAX_MM_AXIS - 1] of FT_MM_Axis;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record PS_FontInfoRec_

packed record PS_FontInfoRec_

Unit

LIBFREETYPE

Declaration

type PS_FontInfoRec_ = packed record

Description

Overview

Fields

version: ˆFT_String;
notice: ˆFT_String;
full_name: ˆFT_String;
family_name: ˆFT_String;
weight: ˆFT_String;
italic_angle: FT_Long;
is_fixed_pitch: FT_Bool;
underline_position: FT_Short;
underline_thickness: FT_UShort;

Description

Fields

version: ˆFT_String;
notice: ˆFT_String;
full_name: ˆFT_String;
family_name: ˆFT_String;
weight: ˆFT_String;
italic_angle: FT_Long;
is_fixed_pitch: FT_Bool;
underline_position: FT_Short;
underline_thickness: FT_UShort;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record PS_PrivateRec_

packed record PS_PrivateRec_

Unit

LIBFREETYPE

Declaration

type PS_PrivateRec_ = packed record

Description

Overview

Fields

unique_id: FT_Int;
lenIV: FT_Int;
num_blue_values: FT_Byte;
num_other_blues: FT_Byte;
num_family_blues: FT_Byte;
num_family_other_blues: FT_Byte;
blue_values: array[0..13] of FT_Short;
other_blues: array[0..9] of FT_Short;
family_blues: array[0..13] of FT_Short;
family_other_blues: array[0..9] of FT_Short;
blue_scale: FT_Fixed;
blue_shift: FT_Int;
blue_fuzz: FT_Int;
standard_width: array[0..1] of FT_UShort;
standard_height: array[0..1] of FT_UShort;
num_snap_widths: FT_Byte;
num_snap_heights: FT_Byte;
force_bold: FT_Byte;
round_stem_up: FT_Byte;
snap_widths: array[0..13] of FT_Short;
snap_heights: array[0..13] of FT_Short;
expansion_factor: FT_Fixed;
language_group: FT_Long;
password: FT_Long;
min_feature: array[0..1] of FT_Short;

Description

Fields

unique_id: FT_Int;
lenIV: FT_Int;
num_blue_values: FT_Byte;
num_other_blues: FT_Byte;
num_family_blues: FT_Byte;
num_family_other_blues: FT_Byte;
blue_values: array[0..13] of FT_Short;
other_blues: array[0..9] of FT_Short;
family_blues: array[0..13] of FT_Short;
family_other_blues: array[0..9] of FT_Short;
blue_scale: FT_Fixed;
blue_shift: FT_Int;
blue_fuzz: FT_Int;
standard_width: array[0..1] of FT_UShort;
standard_height: array[0..1] of FT_UShort;
num_snap_widths: FT_Byte;
num_snap_heights: FT_Byte;
force_bold: FT_Byte;
round_stem_up: FT_Byte;
snap_widths: array[0..13] of FT_Short;
snap_heights: array[0..13] of FT_Short;
expansion_factor: FT_Fixed;
language_group: FT_Long;
password: FT_Long;
min_feature: array[0..1] of FT_Short;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Glyph_ClassRec_

packed record FT_Glyph_ClassRec_

Unit

LIBFREETYPE

Declaration

type FT_Glyph_ClassRec_ = packed record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_RasterRec_

packed record FT_RasterRec_

Unit

LIBFREETYPE

Declaration

type FT_RasterRec_ = packed record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Raster_Funcs

packed record FT_Raster_Funcs

Unit

LIBFREETYPE

Declaration

type FT_Raster_Funcs = packed record

Description

Overview

Fields

glyph_format: FT_Glyph_Format;
raster_new: FT_Raster_NewFunc;
raster_reset: FT_Raster_ResetFunc;
raster_set_mode: FT_Raster_SetModeFunc;
raster_render: FT_Raster_RenderFunc;
raster_done: FT_Raster_DoneFunc;

Description

Fields

glyph_format: FT_Glyph_Format;
raster_new: FT_Raster_NewFunc;
raster_reset: FT_Raster_ResetFunc;
raster_set_mode: FT_Raster_SetModeFunc;
raster_render: FT_Raster_RenderFunc;
raster_done: FT_Raster_DoneFunc;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Renderer_Class

packed record FT_Renderer_Class

Unit

LIBFREETYPE

Declaration

type FT_Renderer_Class = packed record

Description

Overview

Fields

root: FT_Module_Class;
glyph_format: FT_Glyph_Format;
render_glyph: FT_Renderer_RenderFunc;
transform_glyph: FT_Renderer_TransformFunc;
get_glyph_cbox: FT_Renderer_GetCBoxFunc;
set_mode: FT_Renderer_SetModeFunc;
raster_class: ˆFT_Raster_Funcs;

Description

Fields

root: FT_Module_Class;
glyph_format: FT_Glyph_Format;
render_glyph: FT_Renderer_RenderFunc;
transform_glyph: FT_Renderer_TransformFunc;
get_glyph_cbox: FT_Renderer_GetCBoxFunc;
set_mode: FT_Renderer_SetModeFunc;
raster_class: ˆFT_Raster_Funcs;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_RendererRec_

packed record FT_RendererRec_

Unit

LIBFREETYPE

Declaration

type FT_RendererRec_ = packed record

Description

Overview

Fields

root: FT_ModuleRec_;
clazz: ˆFT_Renderer_Class;
glyph_format: FT_Glyph_Format;
glyph_class: FT_Glyph_Class;
raster: FT_Raster;
raster_render: FT_Raster_Render_Func;
render: FT_Renderer_RenderFunc;

Description

Fields

root: FT_ModuleRec_;
clazz: ˆFT_Renderer_Class;
glyph_format: FT_Glyph_Format;
glyph_class: FT_Glyph_Class;
raster: FT_Raster;
raster_render: FT_Raster_Render_Func;
render: FT_Renderer_RenderFunc;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_MemoryRec_

packed record FT_MemoryRec_

Unit

LIBFREETYPE

Declaration

type FT_MemoryRec_ = packed record

Description

Overview

Fields

user: Pointer;
alloc: FT_Alloc_Func;
free: FT_Free_Func;
realloc: FT_Realloc_Func;

Description

Fields

user: Pointer;
alloc: FT_Alloc_Func;
free: FT_Free_Func;
realloc: FT_Realloc_Func;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_SfntName

packed record FT_SfntName

Unit

LIBFREETYPE

Declaration

type FT_SfntName = packed record

Description

Overview

Fields

platform_id: FT_UShort;
encoding_id: FT_UShort;
language_id: FT_UShort;
name_id: FT_UShort;
AString: ˆFT_Byte;
string_len: FT_UInt;

Description

Fields

platform_id: FT_UShort;
encoding_id: FT_UShort;
language_id: FT_UShort;
name_id: FT_UShort;
AString: ˆFT_Byte;
string_len: FT_UInt;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_WinFNT_HeaderRec

packed record FT_WinFNT_HeaderRec

Unit

LIBFREETYPE

Declaration

type FT_WinFNT_HeaderRec = packed record

Description

Overview

Fields

version: FT_UShort;
file_size: FT_ULong;
copyright: array[0..59] of FT_Byte;
file_type: FT_UShort;
nominal_point_size: FT_UShort;
vertical_resolution: FT_UShort;
horizontal_resolution: FT_UShort;
ascent: FT_UShort;
internal_leading: FT_UShort;
external_leading: FT_UShort;
italic: FT_Byte;
underline: FT_Byte;
strike_out: FT_Byte;
weight: FT_UShort;
charset: FT_Byte;
pixel_width: FT_UShort;
pixel_height: FT_UShort;
pitch_and_family: FT_Byte;
avg_width: FT_UShort;
max_width: FT_UShort;
first_char: FT_Byte;
last_char: FT_Byte;
default_char: FT_Byte;
break_char: FT_Byte;
bytes_per_row: FT_UShort;
device_offset: FT_ULong;
face_name_offset: FT_ULong;
bits_pointer: FT_ULong;
bits_offset: FT_ULong;
reserved: FT_Byte;
flags: FT_ULong;
A_space: FT_UShort;
B_space: FT_UShort;
C_space: FT_UShort;
color_table_offset: FT_UShort;
reserved1: array[0..3] of FT_ULong;

Description

Fields

version: FT_UShort;
file_size: FT_ULong;
copyright: array[0..59] of FT_Byte;
file_type: FT_UShort;
nominal_point_size: FT_UShort;
vertical_resolution: FT_UShort;
horizontal_resolution: FT_UShort;
ascent: FT_UShort;
internal_leading: FT_UShort;
external_leading: FT_UShort;
italic: FT_Byte;
underline: FT_Byte;
strike_out: FT_Byte;
weight: FT_UShort;
charset: FT_Byte;
pixel_width: FT_UShort;
pixel_height: FT_UShort;
pitch_and_family: FT_Byte;
avg_width: FT_UShort;
max_width: FT_UShort;
first_char: FT_Byte;
last_char: FT_Byte;
default_char: FT_Byte;
break_char: FT_Byte;
bytes_per_row: FT_UShort;
device_offset: FT_ULong;
face_name_offset: FT_ULong;
bits_pointer: FT_ULong;
bits_offset: FT_ULong;
reserved: FT_Byte;
flags: FT_ULong;
A_space: FT_UShort;
B_space: FT_UShort;
C_space: FT_UShort;
color_table_offset: FT_UShort;
reserved1: array[0..3] of FT_ULong;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_StrokerRec_

packed record FT_StrokerRec_

Unit

LIBFREETYPE

Declaration

type FT_StrokerRec_ = packed record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_ListNodeRec_

packed record FT_ListNodeRec_

Unit

LIBFREETYPE

Declaration

type FT_ListNodeRec_ = packed record

Description

Overview

Fields

prev: FT_ListNode;
next: FT_ListNode;
data: Pointer;

Description

Fields

prev: FT_ListNode;
next: FT_ListNode;
data: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_ListRec_

packed record FT_ListRec_

Unit

LIBFREETYPE

Declaration

type FT_ListRec_ = packed record

Description

Overview

Fields

head: FT_ListNode;
tail: FT_ListNode;

Description

Fields

head: FT_ListNode;
tail: FT_ListNode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Span

packed record FT_Span

Unit

LIBFREETYPE

Declaration

type FT_Span = packed record

Description

Overview

Fields

x: SmallInt;
len: Word;
coverage: Byte;

Description

Fields

x: SmallInt;
len: Word;
coverage: Byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Raster_Params

packed record FT_Raster_Params

Unit

LIBFREETYPE

Declaration

type FT_Raster_Params = packed record

Description

Overview

Fields

target: ˆFT_Bitmap;
source: Pointer;
flags: Integer;
gray_spans: FT_SpanFunc;
black_spans: FT_SpanFunc;
bit_test: FT_Raster_BitTest_Func;
bit_set: FT_Raster_BitSet_Func;
user: Pointer;
clip_box: FT_BBox;

Description

Fields

target: ˆFT_Bitmap;
source: Pointer;
flags: Integer;
gray_spans: FT_SpanFunc;
black_spans: FT_SpanFunc;
bit_test: FT_Raster_BitTest_Func;
bit_set: FT_Raster_BitSet_Func;
user: Pointer;
clip_box: FT_BBox;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Size_RequestRec_

packed record FT_Size_RequestRec_

Unit

LIBFREETYPE

Declaration

type FT_Size_RequestRec_ = packed record

Description

Overview

Fields

atype: FT_Size_Request_Type;
width: FT_Long;
height: FT_Long;
horiResolution: FT_UInt;
vertResolution: FT_UInt;

Description

Fields

atype: FT_Size_Request_Type;
width: FT_Long;
height: FT_Long;
horiResolution: FT_UInt;
vertResolution: FT_UInt;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_StreamDesc

packed record FT_StreamDesc

Unit

LIBFREETYPE

Declaration

type FT_StreamDesc = packed record

Description

Overview

Fields

Val: record
Ptr: record

Description

Fields

Val: record
Ptr: record
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_StreamRec_

packed record FT_StreamRec_

Unit

LIBFREETYPE

Declaration

type FT_StreamRec_ = packed record

Description

Overview

Fields

base: PAnsiChar;
size: PtrUint;
pos: PtrUint;
descriptor: FT_StreamDesc;
pathname: FT_StreamDesc;
read: FT_Stream_IoFunc;
close: FT_Stream_CloseFunc;
memory: FT_Memory;
cursor: PAnsiChar;
limit: PAnsiChar;

Description

Fields

base: PAnsiChar;
size: PtrUint;
pos: PtrUint;
descriptor: FT_StreamDesc;
pathname: FT_StreamDesc;
read: FT_Stream_IoFunc;
close: FT_Stream_CloseFunc;
memory: FT_Memory;
cursor: PAnsiChar;
limit: PAnsiChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Parameter

packed record FT_Parameter

Unit

LIBFREETYPE

Declaration

type FT_Parameter = packed record

Description

Overview

Fields

tag: FT_ULong;
data: FT_Pointer;

Description

Fields

tag: FT_ULong;
data: FT_Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Open_Args

packed record FT_Open_Args

Unit

LIBFREETYPE

Declaration

type FT_Open_Args = packed record

Description

Overview

Fields

flags: FT_UInt;
memory_base: FT_Byte_ptr;
memory_size: FT_Long;
pathname: ˆFT_String;
stream: FT_Stream;
driver: FT_Module;
num_params: FT_Int;
params: ˆFT_Parameter;

Description

Fields

flags: FT_UInt;
memory_base: FT_Byte_ptr;
memory_size: FT_Long;
pathname: ˆFT_String;
stream: FT_Stream;
driver: FT_Module;
num_params: FT_Int;
params: ˆFT_Parameter;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Var_Axis

packed record FT_Var_Axis

Unit

LIBFREETYPE

Declaration

type FT_Var_Axis = packed record

Description

Overview

Fields

name: ˆFT_String;
minimum: FT_Fixed;
def: FT_Fixed;
maximum: FT_Fixed;
tag: FT_ULong;
strid: FT_UInt;

Description

Fields

name: ˆFT_String;
minimum: FT_Fixed;
def: FT_Fixed;
maximum: FT_Fixed;
tag: FT_ULong;
strid: FT_UInt;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Var_Named_Style

packed record FT_Var_Named_Style

Unit

LIBFREETYPE

Declaration

type FT_Var_Named_Style = packed record

Description

Overview

Fields

coords: ˆFT_Fixed;
strid: FT_UInt;

Description

Fields

coords: ˆFT_Fixed;
strid: FT_UInt;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_MM_Var

packed record FT_MM_Var

Unit

LIBFREETYPE

Declaration

type FT_MM_Var = packed record

Description

Overview

Fields

num_axis: FT_UInt;
num_designs: FT_UInt;
num_namedstyles: FT_UInt;
axis: ˆFT_Var_Axis;
namedstyle: ˆFT_Var_Named_Style;

Description

Fields

num_axis: FT_UInt;
num_designs: FT_UInt;
num_namedstyles: FT_UInt;
axis: ˆFT_Var_Axis;
namedstyle: ˆFT_Var_Named_Style;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBFREETYPE: packed record FT_Outline_Funcs

packed record FT_Outline_Funcs

Unit

LIBFREETYPE

Declaration

type FT_Outline_Funcs = packed record

Description

Overview

Fields

move_to: FT_Outline_MoveToFunc;
line_to: FT_Outline_LineToFunc;
conic_to: FT_Outline_ConicToFunc;
cubic_to: FT_Outline_CubicToFunc;
shift: Integer;
delta: FT_Pos;

Description

Fields

move_to: FT_Outline_MoveToFunc;
line_to: FT_Outline_LineToFunc;
conic_to: FT_Outline_ConicToFunc;
cubic_to: FT_Outline_CubicToFunc;
shift: Integer;
delta: FT_Pos;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:15


GLScene v.1.1.2: LIBPNG

Unit LIBPNG

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

LIBPNG<p>

<b>Historique : </b><font size=-1><ul> <li>30/06/11 - DaStr - Fixed compiler crash for Delphi7 <li>16/02/11 - PREDATOR - Added support for Mac OS X. Tested on Mac OS X 10.6.5. <li>01/04/10 - Yar - Bugfix when Delphi not use optimization (thanks Lampogolovii) <li>15/03/10 - Yar - Fixed memory leak (thanks Lampogolovii) <li>05/03/10 - Yar - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record jmp_buf |
record png_color |
record png_color_8 |
record png_color_16 |
record png_unknown_chunk |
record png_text |
record png_time |
record png_sPLT_entry |
record png_sPLT_t |
record png_info |
record png_row_info |
packed record TZStreamRec |
record png_struct |

Functions and Procedures

procedure pngReadFn(png_ptr: png_structp; Data: png_bytep; length: png_size_t); cdecl;
procedure pngWriteFn(png_ptr: png_structp; Data: png_bytep; length: png_size_t); cdecl;
procedure pngErrorFn(struct: png_structp; str: png_const_charp); cdecl;
procedure pngWarnFn(struct: png_structp; str: png_const_charp); cdecl;

Types

time_t = longint;
int = longint;
png_uint_32 = dword;
png_int_32 = longint;
png_uint_16 = word;
png_int_16 = smallint;
png_byte = byte;
ppng_uint_32 = ˆpng_uint_32;
ppng_int_32 = ˆpng_int_32;
ppng_uint_16 = ˆpng_uint_16;
ppng_int_16 = ˆpng_int_16;
ppng_byte = ˆpng_byte;
pppng_uint_32 = ˆppng_uint_32;
pppng_int_32 = ˆppng_int_32;
pppng_uint_16 = ˆppng_uint_16;
ppng_uint_16p = ˆpng_uint_16p;
pppng_int_16 = ˆppng_int_16;
pppng_byte = ˆppng_byte;
png_size_t = ptruint;
png_fixed_point = png_int_32;
ppng_fixed_point = ˆpng_fixed_point;
pppng_fixed_point = ˆppng_fixed_point;
png_voidp = pointer;
ppng_bytep = ˆpng_bytep;
png_const_charp = PChar;
png_charp = PChar;
ppng_charp = ˆpng_charp;
png_fixed_point_p = Ppng_fixed_point;
TFile = Pointer;
png_FILE_p = ˆfile;
png_doublep = Pdouble;
png_byte_array = array[0..MaxInt div 2 - 1] of png_byte;
png_bytep = ˆpng_byte_array;
png_bytep_array = array[0..MaxInt div (2 * SizeOf(png_bytep))] of png_bytep;
png_bytep_arrayp = ˆpng_bytep_array;
png_bytepp = ˆpng_bytep;
png_uint_32p = ˆpng_uint_32;
png_int_32p = PInteger;
png_uint_16p = ˆpng_uint_16;
png_uint_16pp = ˆpng_uint_16p;
png_int_16p = PShortInt;
png_charp_array = array[0..MaxInt div (2 * SizeOf(png_charp))] of png_charp;
png_charp_arrayp = ˆpng_charp_array;
png_charpp = ˆpng_charp;
ppng_charpp = ˆpng_charpp;
jmp_bufp = ˆjmp_buf;
png_color_array = array[0..MaxInt div (2 * SizeOf(png_color))] of png_color;
png_colorp = ˆpng_color_array;
png_colorpp = ˆpng_colorp;
png_color_8p = ˆpng_color_8;
png_color_8pp = ˆpng_color_8p;
ppng_color_8p = ˆpng_color_8p;
ppng_colorp = ˆpng_colorp;
png_color_16p = ˆpng_color_16;
png_color_16pp = ˆpng_color_16p;
ppng_color_16p = ˆpng_color_16p;
png_unknown_chunk_array = array[0..MaxInt div (2 * SizeOf(png_unknown_chunk))] of png_unknown_chunk;
png_unknown_chunk_arrayp = ˆpng_unknown_chunk_array;
png_unknown_chunkp = ˆpng_unknown_chunk;
png_unknown_chunkpp = ˆpng_unknown_chunkp;
png_text_array = array[0..MaxInt div (2 * SizeOf(png_text))] of png_text;
png_text_arrayp = ˆpng_text_array;
png_textp = ˆpng_text;
png_textpp = ˆpng_textp;
ppng_textp = ˆpng_textp;
png_timep = ˆpng_time;
png_timepp = ˆpng_timep;
ppng_timep = ˆpng_timep;
png_sPLT_entryp = ˆpng_sPLT_entry;
png_sPLT_entrypp = ˆpng_sPLT_entryp;
png_sPLT_tp_array = array[0..MaxInt div (2 * SizeOf(png_sPLT_t))] of png_sPLT_t;
png_sPLT_tp_arrayp = ˆpng_sPLT_tp_array;
png_sPLT_tp = ˆpng_sPLT_t;
png_sPLT_tpp = ˆpng_sPLT_tp;
png_structp = ˆpng_struct;
png_structpp = ˆpng_structp;
png_infop = ˆpng_info;
png_infopp = ˆpng_infop;
png_row_infop = ˆpng_row_info;
TAlloc = function(AppData: Pointer; Items, Size: integer): Pointer; cdecl;
TFree = procedure(AppData, Block: Pointer); cdecl;
TInFunc = function(opaque: Pointer; var buf: PByte): integer; cdecl;
TOutFunc = function(opaque: Pointer; buf: PByte; size: integer): integer;
png_error_ptr = procedure(struct: png_structp; str: png_const_charp); cdecl;
png_rw_ptr = procedure(struct: png_structp; Data: png_bytep; size: png_size_t); cdecl;
png_longjmp_ptr = procedure(jb: jmp_buf; i: integer); cdecl;
png_user_transform_ptr = procedure(struct: png_structp; row_info: png_row_infop; b: png_bytep); cdecl;
png_flush_ptr = procedure(struct: png_structp); cdecl;
png_read_status_ptr = procedure(struct: png_structp; ui: png_uint_32; i: integer); cdecl;
png_write_status_ptr = procedure(struct: png_structp; ui: png_uint_32; i: integer); cdecl;
png_progressive_info_ptr = procedure(struct: png_structp; info: png_infop); cdecl;
png_progressive_end_ptr = procedure(struct: png_structp; info: png_infop); cdecl;
png_progressive_row_ptr = procedure(struct: png_structp; bp: png_bytep; ui: png_uint_32; i: integer); cdecl;
png_malloc_ptr = function(struct: png_structp; size: png_size_t): png_voidp;
png_free_ptr = procedure(struct: png_structp; ptr: png_voidp);
png_user_chunk_ptr = function(struct: png_structp; chunk: png_unknown_chunkp): integer;

Constants

LibPng13 = 'libpng13';
ZLIB_VERSION = '1.2.3';
LIBPNG_VERSION = '1.4.0';
PNG_FLAG_ZLIB_CUSTOM_STRATEGY = $0001;
PNG_FLAG_ZLIB_CUSTOM_LEVEL = $0002;
PNG_FLAG_ZLIB_CUSTOM_MEM_LEVEL = $0004;
PNG_FLAG_ZLIB_CUSTOM_WINDOW_BITS = $0008;
PNG_FLAG_ZLIB_CUSTOM_METHOD = $0010;
PNG_FLAG_ZLIB_FINISHED = $0020;
PNG_FLAG_ROW_INIT = $0040;
PNG_FLAG_FILLER_AFTER = $0080;
PNG_FLAG_CRC_ANCILLARY_USE = $0100;
PNG_FLAG_CRC_ANCILLARY_NOWARN = $0200;
PNG_FLAG_CRC_CRITICAL_USE = $0400;
PNG_FLAG_CRC_CRITICAL_IGNORE = $0800;
PNG_FLAG_KEEP_UNKNOWN_CHUNKS = $8000;
PNG_FLAG_KEEP_UNSAFE_CHUNKS = $10000;
PNG_FLAG_LIBRARY_MISMATCH = $20000;
PNG_FLAG_STRIP_ERROR_NUMBERS = $40000;
PNG_FLAG_STRIP_ERROR_TEXT = $80000;
PNG_FLAG_MALLOC_NULL_MEM_OK = $100000;
PNG_FLAG_ADD_ALPHA = $200000;
PNG_FLAG_STRIP_ALPHA = $400000;
PNG_FLAG_BENIGN_ERRORS_WARN = $800000;
PNG_FLAG_CRC_ANCILLARY_MASK = PNG_FLAG_CRC_ANCILLARY_USE or PNG_FLAG_CRC_ANCILLARY_NOWARN;
PNG_FLAG_CRC_CRITICAL_MASK = PNG_FLAG_CRC_CRITICAL_USE or PNG_FLAG_CRC_CRITICAL_IGNORE;
PNG_FLAG_CRC_MASK = PNG_FLAG_CRC_ANCILLARY_MASK or PNG_FLAG_CRC_CRITICAL_MASK;
PNG_USER_WIDTH_MAX = 1000000;
PNG_USER_HEIGHT_MAX = 1000000;
PNG_UINT_31_MAX = $7FFFFFFF;
PNG_UINT_32_MAX = $FFFFFFFF;
PNG_COLOR_MASK_PALETTE = 1;
PNG_COLOR_MASK_COLOR = 2;
PNG_COLOR_MASK_ALPHA = 4;
PNG_COLOR_TYPE_GRAY = 0;
PNG_COLOR_TYPE_PALETTE = PNG_COLOR_MASK_COLOR or PNG_COLOR_MASK_PALETTE;
PNG_COLOR_TYPE_RGB = PNG_COLOR_MASK_COLOR;
PNG_COLOR_TYPE_RGB_ALPHA = PNG_COLOR_MASK_COLOR or PNG_COLOR_MASK_ALPHA;
PNG_COLOR_TYPE_GRAY_ALPHA = PNG_COLOR_MASK_ALPHA;
PNG_INTERLACE_NONE = 0;
PNG_INTERLACE_ADAM7 = 1;
PNG_INTERLACE_LAST = 2;
PNG_COMPRESSION_TYPE_BASE = 0;
PNG_HAVE_IHDR = $01;
PNG_HAVE_PLTE = $02;
PNG_HAVE_IDAT = $04;
PNG_AFTER_IDAT = $08;
PNG_HAVE_IEND = $10;
PNG_HAVE_gAMA = $20;
PNG_HAVE_cHRM = $40;
PNG_HAVE_sRGB = $80;
PNG_HAVE_CHUNK_HEADER = $0100;
PNG_WROTE_tIME = $0200;
PNG_WROTE_INFO_BEFORE_PLTE = $0400;
PNG_BACKGROUND_IS_GRAY = $0800;
PNG_HAVE_PNG_SIGNATURE = $1000;
PNG_HAVE_CHUNK_AFTER_IDAT = $2000;
PNG_INFO_gAMA = $0001;
PNG_INFO_sBIT = $0002;
PNG_INFO_cHRM = $0004;
PNG_INFO_PLTE = $0008;
PNG_INFO_tRNS = $0010;
PNG_INFO_bKGD = $0020;
PNG_INFO_hIST = $0040;
PNG_INFO_pHYs = $0080;
PNG_INFO_oFFs = $0100;
PNG_INFO_tIME = $0200;
PNG_INFO_pCAL = $0400;
PNG_INFO_sRGB = $0800;
PNG_INFO_iCCP = $1000;
PNG_INFO_sPLT = $2000;
PNG_INFO_sCAL = $4000;
PNG_INFO_IDAT = $8000;
PNG_FILTER_TYPE_BASE = 0;
PNG_INTRAPIXEL_DIFFERENCING = 64;
PNG_FLAG_MNG_EMPTY_PLTE = $01;
PNG_FLAG_MNG_FILTER_64 = $04;
PNG_ALL_MNG_FEATURES = $05;
PNG_BGR = $0001;
PNG_INTERLACE = $0002;
PNG_PACK = $0004;
PNG_SHIFT = $0008;
PNG_SWAP_BYTES = $0010;
PNG_INVERT_MONO = $0020;
PNG_DITHER = $0040;
PNG_BACKGROUND = $0080;
PNG_BACKGROUND_EXPAND = $0100;
PNG_16_TO_8 = $0400;
PNG_RGBA = $0800;
PNG_EXPAND = $1000;
PNG_GAMMA = $2000;
PNG_GRAY_TO_RGB = $4000;
PNG_FILLER = $8000;
PNG_PACKSWAP = $10000;
PNG_SWAP_ALPHA = $20000;
PNG_STRIP_ALPHA = $40000;
PNG_INVERT_ALPHA = $80000;
PNG_USER_TRANSFORM = $100000;
PNG_RGB_TO_GRAY_ERR = $200000;
PNG_RGB_TO_GRAY_WARN = $400000;
PNG_RGB_TO_GRAY = $600000;
PNG_ADD_ALPHA = $1000000;
PNG_EXPAND_tRNS = $2000000;
PNG_GAMMA_THRESHOLD = 0.05;
PNG_BACKGROUND_GAMMA_UNKNOWN = 0;
PNG_BACKGROUND_GAMMA_SCREEN = 1;
PNG_BACKGROUND_GAMMA_FILE = 2;
PNG_BACKGROUND_GAMMA_UNIQUE = 3;
PNG_FREE_HIST = $0008;
PNG_FREE_ICCP = $0010;
PNG_FREE_SPLT = $0020;
PNG_FREE_ROWS = $0040;
PNG_FREE_PCAL = $0080;
PNG_FREE_SCAL = $0100;
PNG_FREE_UNKN = $0200;
PNG_FREE_LIST = $0400;
PNG_FREE_PLTE = $1000;
PNG_FREE_TRNS = $2000;
PNG_FREE_TEXT = $4000;
PNG_FREE_ALL = $7FFF;
PNG_FREE_MUL = $4220;
PNG_COMPRESSION_TYPE_DEFAULT = PNG_COMPRESSION_TYPE_BASE;
PNG_FILTER_TYPE_DEFAULT = PNG_FILTER_TYPE_BASE;

Variables

_png_access_version_number: function(): png_uint_32; cdecl;
_png_set_sig_bytes: procedure(png_ptr: png_structp; num_bytes: longint); cdecl;
_png_sig_cmp: function(sig: png_bytep; start: png_size_t; num_to_check: png_size_t): longint; cdecl;
_png_check_sig: function(sig: png_bytep; num: longint): longint; cdecl;
_png_create_read_struct: function(user_png_ver: png_const_charp; error_ptr: png_voidp; error_fn: png_error_ptr; warn_fn: png_error_ptr): png_structp; cdecl;
_png_create_write_struct: function(user_png_ver: png_const_charp; error_ptr: png_voidp; error_fn: png_error_ptr; warn_fn: png_error_ptr): png_structp; cdecl;
_png_get_compression_buffer_size: function(png_ptr: png_structp): png_uint_32; cdecl;
_png_set_compression_buffer_size: procedure(png_ptr: png_structp; size: png_uint_32); cdecl;
_png_reset_zstream: function(png_ptr: png_structp): longint; cdecl;
_png_write_chunk: procedure(png_ptr: png_structp; chunk_name: png_bytep; Data: png_bytep; length: png_size_t); cdecl;
_png_write_chunk_start: procedure(png_ptr: png_structp; chunk_name: png_bytep; length: png_uint_32); cdecl;
_png_write_chunk_data: procedure(png_ptr: png_structp; Data: png_bytep; length: png_size_t); cdecl;
_png_write_chunk_end: procedure(png_ptr: png_structp); cdecl;
_png_create_info_struct: function(png_ptr: png_structp): png_infop; cdecl;
_png_info_init: procedure(info_ptr: png_infop); cdecl;
_png_write_info_before_PLTE: procedure(png_ptr: png_structp; info_ptr: png_infop); cdecl;
_png_write_info: procedure(png_ptr: png_structp; info_ptr: png_infop); cdecl;
_png_read_info: procedure(png_ptr: png_structp; info_ptr: png_infop); cdecl;
_png_convert_to_rfc1123: function(png_ptr: png_structp; ptime: png_timep): png_charp; cdecl;
_png_convert_from_struct_tm: procedure(ptime: png_timep; ttime: Pointer); cdecl;
_png_convert_from_time_t: procedure(ptime: png_timep; ttime: time_t); cdecl;
_png_set_expand: procedure(png_ptr: png_structp); cdecl;
_png_set_gray_1_2_4_to_8: procedure(png_ptr: png_structp); cdecl;
_png_set_palette_to_rgb: procedure(png_ptr: png_structp); cdecl;
_png_set_tRNS_to_alpha: procedure(png_ptr: png_structp); cdecl;
_png_set_bgr: procedure(png_ptr: png_structp); cdecl;
_png_set_gray_to_rgb: procedure(png_ptr: png_structp); cdecl;
_png_set_rgb_to_gray: procedure(png_ptr: png_structp; error_action: longint; red: double; green: double); cdecl;
_png_set_rgb_to_gray_fixed: procedure(png_ptr: png_structp; error_action: longint; red: png_fixed_point; green: png_fixed_point); cdecl;
_png_get_rgb_to_gray_status: function(png_ptr: png_structp): png_byte; cdecl;
_png_build_grayscale_palette: procedure(bit_depth: longint; palette: png_colorp); cdecl;
_png_set_strip_alpha: procedure(png_ptr: png_structp); cdecl;
_png_set_swap_alpha: procedure(png_ptr: png_structp); cdecl;
_png_set_invert_alpha: procedure(png_ptr: png_structp); cdecl;
_png_set_filler: procedure(png_ptr: png_structp; filler: png_uint_32; flags: longint); cdecl;
_png_set_swap: procedure(png_ptr: png_structp); cdecl;
_png_set_packing: procedure(png_ptr: png_structp); cdecl;
_png_set_packswap: procedure(png_ptr: png_structp); cdecl;
_png_set_shift: procedure(png_ptr: png_structp; true_bits: png_color_8p); cdecl;
_png_set_interlace_handling: function(png_ptr: png_structp): longint; cdecl;
_png_set_invert_mono: procedure(png_ptr: png_structp); cdecl;
_png_set_background: procedure(png_ptr: png_structp; background_color: png_color_16p; background_gamma_code: longint; need_expand: longint; background_gamma: double); cdecl;
_png_set_strip_16: procedure(png_ptr: png_structp); cdecl;
_png_set_dither: procedure(png_ptr: png_structp; palette: png_colorp; num_palette: longint; maximum_colors: longint; histogram: png_uint_16p; full_dither: longint); cdecl;
_png_set_gamma: procedure(png_ptr: png_structp; screen_gamma: double; default_file_gamma: double); cdecl;
_png_permit_empty_plte: procedure(png_ptr: png_structp; empty_plte_permitted: longint); cdecl;
_png_set_flush: procedure(png_ptr: png_structp; nrows: longint); cdecl;
_png_write_flush: procedure(png_ptr: png_structp); cdecl;
_png_start_read_image: procedure(png_ptr: png_structp); cdecl;
_png_read_update_info: procedure(png_ptr: png_structp; info_ptr: png_infop); cdecl;
_png_read_rows: procedure(png_ptr: png_structp; row: png_bytepp; display_row: png_bytepp; num_rows: png_uint_32); cdecl;
_png_read_row: procedure(png_ptr: png_structp; row: png_bytep; display_row: png_bytep); cdecl;
_png_read_image: procedure(png_ptr: png_structp; image: png_bytepp); cdecl;
_png_write_row: procedure(png_ptr: png_structp; row: png_bytep); cdecl;
_png_write_rows: procedure(png_ptr: png_structp; row: png_bytepp; num_rows: png_uint_32); cdecl;
_png_write_image: procedure(png_ptr: png_structp; image: png_bytepp); cdecl;
_png_write_end: procedure(png_ptr: png_structp; info_ptr: png_infop); cdecl;
_png_read_end: procedure(png_ptr: png_structp; info_ptr: png_infop); cdecl;
_png_destroy_info_struct: procedure(png_ptr: png_structp; info_ptr_ptr: png_infopp); cdecl;
_png_destroy_read_struct: procedure(png_ptr_ptr: png_structpp; info_ptr_ptr: png_infopp; end_info_ptr_ptr: png_infopp); cdecl;
_png_read_destroy: procedure(png_ptr: png_structp; info_ptr: png_infop; end_info_ptr: png_infop); cdecl;
_png_destroy_write_struct: procedure(png_ptr_ptr: png_structpp; info_ptr_ptr: png_infopp); cdecl;
_png_write_destroy_info: procedure(info_ptr: png_infop); cdecl;
_png_write_destroy: procedure(png_ptr: png_structp); cdecl;
_png_set_crc_action: procedure(png_ptr: png_structp; crit_action: longint; ancil_action: longint); cdecl;
_png_set_filter: procedure(png_ptr: png_structp; method: longint; filters: longint); cdecl;
_png_set_filter_heuristics: procedure(png_ptr: png_structp; heuristic_method: longint; num_weights: longint; filter_weights: png_doublep; filter_costs: png_doublep); cdecl;
_png_set_compression_level: procedure(png_ptr: png_structp; level: longint); cdecl;
_png_set_compression_mem_level: procedure(png_ptr: png_structp; mem_level: longint); cdecl;
_png_set_compression_strategy: procedure(png_ptr: png_structp; strategy: longint); cdecl;
_png_set_compression_window_bits: procedure(png_ptr: png_structp; window_bits: longint); cdecl;
_png_set_compression_method: procedure(png_ptr: png_structp; method: longint); cdecl;
_png_init_io: procedure(png_ptr: png_structp; fp: png_FILE_p); cdecl;
_png_set_error_fn: procedure(png_ptr: png_structp; error_ptr: png_voidp; error_fn: png_error_ptr; warning_fn: png_error_ptr); cdecl;
_png_get_error_ptr: function(png_ptr: png_structp): png_voidp; cdecl;
_png_set_write_fn: procedure(png_ptr: png_structp; io_ptr: png_voidp; write_data_fn: png_rw_ptr; output_flush_fn: png_flush_ptr); cdecl;
_png_set_read_fn: procedure(png_ptr: png_structp; io_ptr: png_voidp; read_data_fn: png_rw_ptr); cdecl;
_png_get_io_ptr: function(png_ptr: png_structp): png_voidp; cdecl;
_png_set_read_status_fn: procedure(png_ptr: png_structp; read_row_fn: png_read_status_ptr); cdecl;
_png_set_write_status_fn: procedure(png_ptr: png_structp; write_row_fn: png_write_status_ptr); cdecl;
_png_set_read_user_transform_fn: procedure(png_ptr: png_structp; read_user_transform_fn: png_user_transform_ptr); cdecl;
_png_set_write_user_transform_fn: procedure(png_ptr: png_structp; write_user_transform_fn: png_user_transform_ptr); cdecl;
_png_set_user_transform_info: procedure(png_ptr: png_structp; user_transform_ptr: png_voidp; user_transform_depth: longint; user_transform_channels: longint); cdecl;
_png_get_user_transform_ptr: function(png_ptr: png_structp): png_voidp; cdecl;
_png_set_read_user_chunk_fn: procedure(png_ptr: png_structp; user_chunk_ptr: png_voidp; read_user_chunk_fn: png_user_chunk_ptr); cdecl;
_png_get_user_chunk_ptr: function(png_ptr: png_structp): png_voidp; cdecl;
_png_set_progressive_read_fn: procedure(png_ptr: png_structp; progressive_ptr: png_voidp; info_fn: png_progressive_info_ptr; row_fn: png_progressive_row_ptr; end_fn: png_progressive_end_ptr); cdecl;
_png_get_progressive_ptr: function(png_ptr: png_structp): png_voidp; cdecl;
_png_process_data: procedure(png_ptr: png_structp; info_ptr: png_infop; buffer: png_bytep; buffer_size: png_size_t); cdecl;
_png_progressive_combine_row: procedure(png_ptr: png_structp; old_row: png_bytep; new_row: png_bytep); cdecl;
_png_malloc: function(png_ptr: png_structp; size: png_uint_32): png_voidp; cdecl;
_png_free: procedure(png_ptr: png_structp; ptr: png_voidp); cdecl;
_png_free_data: procedure(png_ptr: png_structp; info_ptr: png_infop; free_me: png_uint_32; num: longint); cdecl;
_png_data_freer: procedure(png_ptr: png_structp; info_ptr: png_infop; freer: longint; mask: png_uint_32); cdecl;
_png_memcpy_check: function(png_ptr: png_structp; s1: png_voidp; s2: png_voidp; size: png_uint_32): png_voidp; cdecl;
_png_memset_check: function(png_ptr: png_structp; s1: png_voidp; Value: longint; size: png_uint_32): png_voidp; cdecl;
_png_error: procedure(png_ptr: png_structp; error: png_const_charp); cdecl;
_png_chunk_error: procedure(png_ptr: png_structp; error: png_const_charp); cdecl;
_png_warning: procedure(png_ptr: png_structp; message: png_const_charp); cdecl;
_png_chunk_warning: procedure(png_ptr: png_structp; message: png_const_charp); cdecl;
_png_get_valid: function(png_ptr: png_structp; info_ptr: png_infop; flag: png_uint_32): png_uint_32; cdecl;
_png_get_rowbytes: function(png_ptr: png_structp; info_ptr: png_infop): png_uint_32; cdecl;
_png_get_rows: function(png_ptr: png_structp; info_ptr: png_infop): png_bytepp; cdecl;
_png_set_rows: procedure(png_ptr: png_structp; info_ptr: png_infop; row_pointers: png_bytepp); cdecl;
_png_get_channels: function(png_ptr: png_structp; info_ptr: png_infop): png_byte; cdecl;
_png_get_image_width: function(png_ptr: png_structp; info_ptr: png_infop): png_uint_32; cdecl;
_png_get_image_height: function(png_ptr: png_structp; info_ptr: png_infop): png_uint_32; cdecl;
_png_get_bit_depth: function(png_ptr: png_structp; info_ptr: png_infop): png_byte; cdecl;
_png_get_color_type: function(png_ptr: png_structp; info_ptr: png_infop): png_byte; cdecl;
_png_get_filter_type: function(png_ptr: png_structp; info_ptr: png_infop): png_byte; cdecl;
_png_get_interlace_type: function(png_ptr: png_structp; info_ptr: png_infop): png_byte; cdecl;
_png_get_compression_type: function(png_ptr: png_structp; info_ptr: png_infop): png_byte; cdecl;
_png_get_pixels_per_meter: function(png_ptr: png_structp; info_ptr: png_infop): png_uint_32; cdecl;
_png_get_x_pixels_per_meter: function(png_ptr: png_structp; info_ptr: png_infop): png_uint_32; cdecl;
_png_get_y_pixels_per_meter: function(png_ptr: png_structp; info_ptr: png_infop): png_uint_32; cdecl;
_png_get_pixel_aspect_ratio: function(png_ptr: png_structp; info_ptr: png_infop): double; cdecl;
_png_get_x_offset_pixels: function(png_ptr: png_structp; info_ptr: png_infop): png_int_32; cdecl;
_png_get_y_offset_pixels: function(png_ptr: png_structp; info_ptr: png_infop): png_int_32; cdecl;
_png_get_x_offset_microns: function(png_ptr: png_structp; info_ptr: png_infop): png_int_32; cdecl;
_png_get_y_offset_microns: function(png_ptr: png_structp; info_ptr: png_infop): png_int_32; cdecl;
_png_get_signature: function(png_ptr: png_structp; info_ptr: png_infop): png_bytep; cdecl;
_png_get_bKGD: function(png_ptr: png_structp; info_ptr: png_infop; background: Ppng_color_16p): png_uint_32; cdecl;
_png_set_bKGD: procedure(png_ptr: png_structp; info_ptr: png_infop; background: png_color_16p); cdecl;
_png_get_cHRM: function(png_ptr: png_structp; info_ptr: png_infop; white_x: Pdouble; white_y: Pdouble; red_x: Pdouble; red_y: Pdouble; green_x: Pdouble; green_y: Pdouble; blue_x: Pdouble; blue_y: Pdouble): png_uint_32; cdecl;
_png_get_cHRM_fixed: function(png_ptr: png_structp; info_ptr: png_infop; int_white_x: Ppng_fixed_point; int_white_y: Ppng_fixed_point; int_red_x: Ppng_fixed_point; int_red_y: Ppng_fixed_point; int_green_x: Ppng_fixed_point; int_green_y: Ppng_fixed_point; int_blue_x: Ppng_fixed_point; int_blue_y: Ppng_fixed_point): png_uint_32; cdecl;
_png_set_cHRM: procedure(png_ptr: png_structp; info_ptr: png_infop; white_x: double; white_y: double; red_x: double; red_y: double; green_x: double; green_y: double; blue_x: double; blue_y: double); cdecl;
_png_set_cHRM_fixed: procedure(png_ptr: png_structp; info_ptr: png_infop; int_white_x: png_fixed_point; int_white_y: png_fixed_point; int_red_x: png_fixed_point; int_red_y: png_fixed_point; int_green_x: png_fixed_point; int_green_y: png_fixed_point; int_blue_x: png_fixed_point; int_blue_y: png_fixed_point); cdecl;
_png_get_gAMA: function(png_ptr: png_structp; info_ptr: png_infop; file_gamma: Pdouble): png_uint_32; cdecl;
_png_get_gAMA_fixed: function(png_ptr: png_structp; info_ptr: png_infop; int_file_gamma: Ppng_fixed_point): png_uint_32; cdecl;
_png_set_gAMA: procedure(png_ptr: png_structp; info_ptr: png_infop; file_gamma: double); cdecl;
_png_set_gAMA_fixed: procedure(png_ptr: png_structp; info_ptr: png_infop; int_file_gamma: png_fixed_point); cdecl;
_png_get_hIST: function(png_ptr: png_structp; info_ptr: png_infop; hist: Ppng_uint_16p): png_uint_32; cdecl;
_png_set_hIST: procedure(png_ptr: png_structp; info_ptr: png_infop; hist: png_uint_16p); cdecl;
_png_get_IHDR: function(png_ptr: png_structp; info_ptr: png_infop; Width: Ppng_uint_32; Height: Ppng_uint_32; bit_depth: Plongint; color_type: Plongint; interlace_type: Plongint; compression_type: Plongint; filter_type: Plongint): png_uint_32; cdecl;
_png_set_IHDR: procedure(png_ptr: png_structp; info_ptr: png_infop; Width: png_uint_32; Height: png_uint_32; bit_depth: longint; color_type: longint; interlace_type: longint; compression_type: longint; filter_type: longint); cdecl;
_png_get_oFFs: function(png_ptr: png_structp; info_ptr: png_infop; offset_x: Ppng_int_32; offset_y: Ppng_int_32; unit_type: Plongint): png_uint_32; cdecl;
_png_set_oFFs: procedure(png_ptr: png_structp; info_ptr: png_infop; offset_x: png_int_32; offset_y: png_int_32; unit_type: longint); cdecl;
_png_get_pCAL: function(png_ptr: png_structp; info_ptr: png_infop; purpose: Ppng_charp; X0: Ppng_int_32; X1: Ppng_int_32; atype: Plongint; nparams: Plongint; units: Ppng_charp; params: Ppng_charpp): png_uint_32; cdecl;
_png_set_pCAL: procedure(png_ptr: png_structp; info_ptr: png_infop; purpose: png_charp; X0: png_int_32; X1: png_int_32; atype: longint; nparams: longint; units: png_charp; params: png_charpp); cdecl;
_png_get_pHYs: function(png_ptr: png_structp; info_ptr: png_infop; res_x: Ppng_uint_32; res_y: Ppng_uint_32; unit_type: Plongint): png_uint_32; cdecl;
_png_set_pHYs: procedure(png_ptr: png_structp; info_ptr: png_infop; res_x: png_uint_32; res_y: png_uint_32; unit_type: longint); cdecl;
_png_get_PLTE: function(png_ptr: png_structp; info_ptr: png_infop; palette: Ppng_colorp; num_palette: Plongint): png_uint_32; cdecl;
_png_set_PLTE: procedure(png_ptr: png_structp; info_ptr: png_infop; palette: png_colorp; num_palette: longint); cdecl;
_png_get_sBIT: function(png_ptr: png_structp; info_ptr: png_infop; sig_bit: Ppng_color_8p): png_uint_32; cdecl;
_png_set_sBIT: procedure(png_ptr: png_structp; info_ptr: png_infop; sig_bit: png_color_8p); cdecl;
_png_get_sRGB: function(png_ptr: png_structp; info_ptr: png_infop; intent: Plongint): png_uint_32; cdecl;
_png_set_sRGB: procedure(png_ptr: png_structp; info_ptr: png_infop; intent: longint); cdecl;
_png_set_sRGB_gAMA_and_cHRM: procedure(png_ptr: png_structp; info_ptr: png_infop; intent: longint); cdecl;
_png_get_iCCP: function(png_ptr: png_structp; info_ptr: png_infop; Name: png_charpp; compression_type: Plongint; profile: png_charpp; proflen: Ppng_uint_32): png_uint_32; cdecl;
_png_set_iCCP: procedure(png_ptr: png_structp; info_ptr: png_infop; Name: png_charp; compression_type: longint; profile: png_charp; proflen: png_uint_32); cdecl;
_png_get_sPLT: function(png_ptr: png_structp; info_ptr: png_infop; entries: png_sPLT_tpp): png_uint_32; cdecl;
_png_set_sPLT: procedure(png_ptr: png_structp; info_ptr: png_infop; entries: png_sPLT_tp; nentries: longint); cdecl;
_png_get_text: function(png_ptr: png_structp; info_ptr: png_infop; text_ptr: Ppng_textp; num_text: Plongint): png_uint_32; cdecl;
_png_set_text: procedure(png_ptr: png_structp; info_ptr: png_infop; text_ptr: png_textp; num_text: longint); cdecl;
_png_get_tIME: function(png_ptr: png_structp; info_ptr: png_infop; mod_time: Ppng_timep): png_uint_32; cdecl;
_png_set_tIME: procedure(png_ptr: png_structp; info_ptr: png_infop; mod_time: png_timep); cdecl;
_png_get_tRNS: function(png_ptr: png_structp; info_ptr: png_infop; trans: Ppng_bytep; num_trans: Plongint; trans_values: Ppng_color_16p): png_uint_32; cdecl;
_png_set_tRNS: procedure(png_ptr: png_structp; info_ptr: png_infop; trans: png_bytep; num_trans: longint; trans_values: png_color_16p); cdecl;
_png_get_sCAL: function(png_ptr: png_structp; info_ptr: png_infop; aunit: Plongint; Width: Pdouble; Height: Pdouble): png_uint_32; cdecl;
_png_set_sCAL: procedure(png_ptr: png_structp; info_ptr: png_infop; aunit: longint; Width: double; Height: double); cdecl;
_png_set_sCAL_s: procedure(png_ptr: png_structp; info_ptr: png_infop; aunit: longint; swidth: png_charp; sheight: png_charp); cdecl;
_png_set_keep_unknown_chunks: procedure(png_ptr: png_structp; keep: longint; chunk_list: png_bytep; num_chunks: longint); cdecl;
_png_set_unknown_chunks: procedure(png_ptr: png_structp; info_ptr: png_infop; unknowns: png_unknown_chunkp; num_unknowns: longint); cdecl;
_png_set_unknown_chunk_location: procedure(png_ptr: png_structp; info_ptr: png_infop; chunk: longint; location: longint); cdecl;
_png_get_unknown_chunks: function(png_ptr: png_structp; info_ptr: png_infop; entries: png_unknown_chunkpp): png_uint_32; cdecl;
_png_set_invalid: procedure(png_ptr: png_structp; info_ptr: png_infop; mask: longint); cdecl;
_png_read_png: procedure(png_ptr: png_structp; info_ptr: png_infop; transforms: longint; params: Pointer); cdecl;
_png_write_png: procedure(png_ptr: png_structp; info_ptr: png_infop; transforms: longint; params: Pointer); cdecl;
_png_get_header_ver: function(png_ptr: png_structp): png_charp; cdecl;
_png_get_header_version: function(png_ptr: png_structp): png_charp; cdecl;
_png_get_libpng_ver: function(png_ptr: png_structp): png_charp; cdecl;

Description

Functions and Procedures

procedure pngReadFn(png_ptr: png_structp; Data: png_bytep; length: png_size_t); cdecl;
procedure pngWriteFn(png_ptr: png_structp; Data: png_bytep; length: png_size_t); cdecl;
procedure pngErrorFn(struct: png_structp; str: png_const_charp); cdecl;
procedure pngWarnFn(struct: png_structp; str: png_const_charp); cdecl;

Types

time_t = longint;
int = longint;
png_uint_32 = dword;
png_int_32 = longint;
png_uint_16 = word;
png_int_16 = smallint;
png_byte = byte;
ppng_uint_32 = ˆpng_uint_32;
ppng_int_32 = ˆpng_int_32;
ppng_uint_16 = ˆpng_uint_16;
ppng_int_16 = ˆpng_int_16;
ppng_byte = ˆpng_byte;
pppng_uint_32 = ˆppng_uint_32;
pppng_int_32 = ˆppng_int_32;
pppng_uint_16 = ˆppng_uint_16;
ppng_uint_16p = ˆpng_uint_16p;
pppng_int_16 = ˆppng_int_16;
pppng_byte = ˆppng_byte;
png_size_t = ptruint;
png_fixed_point = png_int_32;
ppng_fixed_point = ˆpng_fixed_point;
pppng_fixed_point = ˆppng_fixed_point;
png_voidp = pointer;
ppng_bytep = ˆpng_bytep;
png_const_charp = PChar;
png_charp = PChar;
ppng_charp = ˆpng_charp;
png_fixed_point_p = Ppng_fixed_point;
TFile = Pointer;
png_FILE_p = ˆfile;
png_doublep = Pdouble;
png_byte_array = array[0..MaxInt div 2 - 1] of png_byte;
png_bytep = ˆpng_byte_array;
png_bytep_array = array[0..MaxInt div (2 * SizeOf(png_bytep))] of png_bytep;
png_bytep_arrayp = ˆpng_bytep_array;
png_bytepp = ˆpng_bytep;
png_uint_32p = ˆpng_uint_32;
png_int_32p = PInteger;
png_uint_16p = ˆpng_uint_16;
png_uint_16pp = ˆpng_uint_16p;
png_int_16p = PShortInt;
png_charp_array = array[0..MaxInt div (2 * SizeOf(png_charp))] of png_charp;
png_charp_arrayp = ˆpng_charp_array;
png_charpp = ˆpng_charp;
ppng_charpp = ˆpng_charpp;
jmp_bufp = ˆjmp_buf;
png_color_array = array[0..MaxInt div (2 * SizeOf(png_color))] of png_color;
png_colorp = ˆpng_color_array;
png_colorpp = ˆpng_colorp;
png_color_8p = ˆpng_color_8;
png_color_8pp = ˆpng_color_8p;
ppng_color_8p = ˆpng_color_8p;
ppng_colorp = ˆpng_colorp;
png_color_16p = ˆpng_color_16;
png_color_16pp = ˆpng_color_16p;
ppng_color_16p = ˆpng_color_16p;
png_unknown_chunk_array = array[0..MaxInt div (2 * SizeOf(png_unknown_chunk))] of png_unknown_chunk;

libpng-using applications should NOT directly modify this byte. png_byte location; mode of operation at read time

png_unknown_chunk_arrayp = ˆpng_unknown_chunk_array;
png_unknown_chunkp = ˆpng_unknown_chunk;
png_unknown_chunkpp = ˆpng_unknown_chunkp;
png_text_array = array[0..MaxInt div (2 * SizeOf(png_text))] of png_text;
png_text_arrayp = ˆpng_text_array;
png_textp = ˆpng_text;
png_textpp = ˆpng_textp;
ppng_textp = ˆpng_textp;
png_timep = ˆpng_time;

second of minute, 0 - 60 (for leap seconds)

png_timepp = ˆpng_timep;
ppng_timep = ˆpng_timep;
png_sPLT_entryp = ˆpng_sPLT_entry;
png_sPLT_entrypp = ˆpng_sPLT_entryp;
png_sPLT_tp_array = array[0..MaxInt div (2 * SizeOf(png_sPLT_t))] of png_sPLT_t;

number of palette entries

png_sPLT_tp_arrayp = ˆpng_sPLT_tp_array;
png_sPLT_tp = ˆpng_sPLT_t;
png_sPLT_tpp = ˆpng_sPLT_tp;
png_structp = ˆpng_struct;
png_structpp = ˆpng_structp;
png_infop = ˆpng_info;
png_infopp = ˆpng_infop;
png_row_infop = ˆpng_row_info;
TAlloc = function(AppData: Pointer; Items, Size: integer): Pointer; cdecl;
TFree = procedure(AppData, Block: Pointer); cdecl;
TInFunc = function(opaque: Pointer; var buf: PByte): integer; cdecl;
TOutFunc = function(opaque: Pointer; buf: PByte; size: integer): integer;
png_error_ptr = procedure(struct: png_structp; str: png_const_charp); cdecl;
png_rw_ptr = procedure(struct: png_structp; Data: png_bytep; size: png_size_t); cdecl;
png_longjmp_ptr = procedure(jb: jmp_buf; i: integer); cdecl;
png_user_transform_ptr = procedure(struct: png_structp; row_info: png_row_infop; b: png_bytep); cdecl;
png_flush_ptr = procedure(struct: png_structp); cdecl;
png_read_status_ptr = procedure(struct: png_structp; ui: png_uint_32; i: integer); cdecl;
png_write_status_ptr = procedure(struct: png_structp; ui: png_uint_32; i: integer); cdecl;
png_progressive_info_ptr = procedure(struct: png_structp; info: png_infop); cdecl;
png_progressive_end_ptr = procedure(struct: png_structp; info: png_infop); cdecl;
png_progressive_row_ptr = procedure(struct: png_structp; bp: png_bytep; ui: png_uint_32; i: integer); cdecl;
png_malloc_ptr = function(struct: png_structp; size: png_size_t): png_voidp;
png_free_ptr = procedure(struct: png_structp; ptr: png_voidp);
png_user_chunk_ptr = function(struct: png_structp; chunk: png_unknown_chunkp): integer;

Constants

LibPng13 = 'libpng13';
ZLIB_VERSION = '1.2.3';
LIBPNG_VERSION = '1.4.0';
PNG_FLAG_ZLIB_CUSTOM_STRATEGY = $0001;
PNG_FLAG_ZLIB_CUSTOM_LEVEL = $0002;
PNG_FLAG_ZLIB_CUSTOM_MEM_LEVEL = $0004;
PNG_FLAG_ZLIB_CUSTOM_WINDOW_BITS = $0008;
PNG_FLAG_ZLIB_CUSTOM_METHOD = $0010;
PNG_FLAG_ZLIB_FINISHED = $0020;
PNG_FLAG_ROW_INIT = $0040;
PNG_FLAG_FILLER_AFTER = $0080;
PNG_FLAG_CRC_ANCILLARY_USE = $0100;
PNG_FLAG_CRC_ANCILLARY_NOWARN = $0200;
PNG_FLAG_CRC_CRITICAL_USE = $0400;
PNG_FLAG_CRC_CRITICAL_IGNORE = $0800;
PNG_FLAG_KEEP_UNKNOWN_CHUNKS = $8000;
PNG_FLAG_KEEP_UNSAFE_CHUNKS = $10000;
PNG_FLAG_LIBRARY_MISMATCH = $20000;
PNG_FLAG_STRIP_ERROR_NUMBERS = $40000;
PNG_FLAG_STRIP_ERROR_TEXT = $80000;
PNG_FLAG_MALLOC_NULL_MEM_OK = $100000;
PNG_FLAG_ADD_ALPHA = $200000;
PNG_FLAG_STRIP_ALPHA = $400000;
PNG_FLAG_BENIGN_ERRORS_WARN = $800000;
PNG_FLAG_CRC_ANCILLARY_MASK = PNG_FLAG_CRC_ANCILLARY_USE or PNG_FLAG_CRC_ANCILLARY_NOWARN;
PNG_FLAG_CRC_CRITICAL_MASK = PNG_FLAG_CRC_CRITICAL_USE or PNG_FLAG_CRC_CRITICAL_IGNORE;
PNG_FLAG_CRC_MASK = PNG_FLAG_CRC_ANCILLARY_MASK or PNG_FLAG_CRC_CRITICAL_MASK;
PNG_USER_WIDTH_MAX = 1000000;
PNG_USER_HEIGHT_MAX = 1000000;
PNG_UINT_31_MAX = $7FFFFFFF;
PNG_UINT_32_MAX = $FFFFFFFF;
PNG_COLOR_MASK_PALETTE = 1;
PNG_COLOR_MASK_COLOR = 2;
PNG_COLOR_MASK_ALPHA = 4;
PNG_COLOR_TYPE_GRAY = 0;
PNG_COLOR_TYPE_PALETTE = PNG_COLOR_MASK_COLOR or PNG_COLOR_MASK_PALETTE;
PNG_COLOR_TYPE_RGB = PNG_COLOR_MASK_COLOR;
PNG_COLOR_TYPE_RGB_ALPHA = PNG_COLOR_MASK_COLOR or PNG_COLOR_MASK_ALPHA;
PNG_COLOR_TYPE_GRAY_ALPHA = PNG_COLOR_MASK_ALPHA;
PNG_INTERLACE_NONE = 0;
PNG_INTERLACE_ADAM7 = 1;
PNG_INTERLACE_LAST = 2;
PNG_COMPRESSION_TYPE_BASE = 0;
PNG_HAVE_IHDR = $01;
PNG_HAVE_PLTE = $02;
PNG_HAVE_IDAT = $04;
PNG_AFTER_IDAT = $08;
PNG_HAVE_IEND = $10;
PNG_HAVE_gAMA = $20;
PNG_HAVE_cHRM = $40;
PNG_HAVE_sRGB = $80;
PNG_HAVE_CHUNK_HEADER = $0100;
PNG_WROTE_tIME = $0200;
PNG_WROTE_INFO_BEFORE_PLTE = $0400;
PNG_BACKGROUND_IS_GRAY = $0800;
PNG_HAVE_PNG_SIGNATURE = $1000;
PNG_HAVE_CHUNK_AFTER_IDAT = $2000;
PNG_INFO_gAMA = $0001;
PNG_INFO_sBIT = $0002;
PNG_INFO_cHRM = $0004;
PNG_INFO_PLTE = $0008;
PNG_INFO_tRNS = $0010;
PNG_INFO_bKGD = $0020;
PNG_INFO_hIST = $0040;
PNG_INFO_pHYs = $0080;
PNG_INFO_oFFs = $0100;
PNG_INFO_tIME = $0200;
PNG_INFO_pCAL = $0400;
PNG_INFO_sRGB = $0800;
PNG_INFO_iCCP = $1000;
PNG_INFO_sPLT = $2000;
PNG_INFO_sCAL = $4000;
PNG_INFO_IDAT = $8000;
PNG_FILTER_TYPE_BASE = 0;
PNG_INTRAPIXEL_DIFFERENCING = 64;
PNG_FLAG_MNG_EMPTY_PLTE = $01;
PNG_FLAG_MNG_FILTER_64 = $04;
PNG_ALL_MNG_FEATURES = $05;
PNG_BGR = $0001;
PNG_INTERLACE = $0002;
PNG_PACK = $0004;
PNG_SHIFT = $0008;
PNG_SWAP_BYTES = $0010;
PNG_INVERT_MONO = $0020;
PNG_DITHER = $0040;
PNG_BACKGROUND = $0080;
PNG_BACKGROUND_EXPAND = $0100;
PNG_16_TO_8 = $0400;
PNG_RGBA = $0800;
PNG_EXPAND = $1000;
PNG_GAMMA = $2000;
PNG_GRAY_TO_RGB = $4000;
PNG_FILLER = $8000;
PNG_PACKSWAP = $10000;
PNG_SWAP_ALPHA = $20000;
PNG_STRIP_ALPHA = $40000;
PNG_INVERT_ALPHA = $80000;
PNG_USER_TRANSFORM = $100000;
PNG_RGB_TO_GRAY_ERR = $200000;
PNG_RGB_TO_GRAY_WARN = $400000;
PNG_RGB_TO_GRAY = $600000;
PNG_ADD_ALPHA = $1000000;
PNG_EXPAND_tRNS = $2000000;
PNG_GAMMA_THRESHOLD = 0.05;
PNG_BACKGROUND_GAMMA_UNKNOWN = 0;
PNG_BACKGROUND_GAMMA_SCREEN = 1;
PNG_BACKGROUND_GAMMA_FILE = 2;
PNG_BACKGROUND_GAMMA_UNIQUE = 3;
PNG_FREE_HIST = $0008;
PNG_FREE_ICCP = $0010;
PNG_FREE_SPLT = $0020;
PNG_FREE_ROWS = $0040;
PNG_FREE_PCAL = $0080;
PNG_FREE_SCAL = $0100;
PNG_FREE_UNKN = $0200;
PNG_FREE_LIST = $0400;
PNG_FREE_PLTE = $1000;
PNG_FREE_TRNS = $2000;
PNG_FREE_TEXT = $4000;
PNG_FREE_ALL = $7FFF;
PNG_FREE_MUL = $4220;
PNG_COMPRESSION_TYPE_DEFAULT = PNG_COMPRESSION_TYPE_BASE;
PNG_FILTER_TYPE_DEFAULT = PNG_FILTER_TYPE_BASE;

Variables

_png_access_version_number: function(): png_uint_32; cdecl;
_png_set_sig_bytes: procedure(png_ptr: png_structp; num_bytes: longint); cdecl;
_png_sig_cmp: function(sig: png_bytep; start: png_size_t; num_to_check: png_size_t): longint; cdecl;
_png_check_sig: function(sig: png_bytep; num: longint): longint; cdecl;
_png_create_read_struct: function(user_png_ver: png_const_charp; error_ptr: png_voidp; error_fn: png_error_ptr; warn_fn: png_error_ptr): png_structp; cdecl;
_png_create_write_struct: function(user_png_ver: png_const_charp; error_ptr: png_voidp; error_fn: png_error_ptr; warn_fn: png_error_ptr): png_structp; cdecl;
_png_get_compression_buffer_size: function(png_ptr: png_structp): png_uint_32; cdecl;
_png_set_compression_buffer_size: procedure(png_ptr: png_structp; size: png_uint_32); cdecl;
_png_reset_zstream: function(png_ptr: png_structp): longint; cdecl;
_png_write_chunk: procedure(png_ptr: png_structp; chunk_name: png_bytep; Data: png_bytep; length: png_size_t); cdecl;
_png_write_chunk_start: procedure(png_ptr: png_structp; chunk_name: png_bytep; length: png_uint_32); cdecl;
_png_write_chunk_data: procedure(png_ptr: png_structp; Data: png_bytep; length: png_size_t); cdecl;
_png_write_chunk_end: procedure(png_ptr: png_structp); cdecl;
_png_create_info_struct: function(png_ptr: png_structp): png_infop; cdecl;
_png_info_init: procedure(info_ptr: png_infop); cdecl;
_png_write_info_before_PLTE: procedure(png_ptr: png_structp; info_ptr: png_infop); cdecl;
_png_write_info: procedure(png_ptr: png_structp; info_ptr: png_infop); cdecl;
_png_read_info: procedure(png_ptr: png_structp; info_ptr: png_infop); cdecl;
_png_convert_to_rfc1123: function(png_ptr: png_structp; ptime: png_timep): png_charp; cdecl;
_png_convert_from_struct_tm: procedure(ptime: png_timep; ttime: Pointer); cdecl;
_png_convert_from_time_t: procedure(ptime: png_timep; ttime: time_t); cdecl;
_png_set_expand: procedure(png_ptr: png_structp); cdecl;
_png_set_gray_1_2_4_to_8: procedure(png_ptr: png_structp); cdecl;
_png_set_palette_to_rgb: procedure(png_ptr: png_structp); cdecl;
_png_set_tRNS_to_alpha: procedure(png_ptr: png_structp); cdecl;
_png_set_bgr: procedure(png_ptr: png_structp); cdecl;
_png_set_gray_to_rgb: procedure(png_ptr: png_structp); cdecl;
_png_set_rgb_to_gray: procedure(png_ptr: png_structp; error_action: longint; red: double; green: double); cdecl;
_png_set_rgb_to_gray_fixed: procedure(png_ptr: png_structp; error_action: longint; red: png_fixed_point; green: png_fixed_point); cdecl;
_png_get_rgb_to_gray_status: function(png_ptr: png_structp): png_byte; cdecl;
_png_build_grayscale_palette: procedure(bit_depth: longint; palette: png_colorp); cdecl;
_png_set_strip_alpha: procedure(png_ptr: png_structp); cdecl;
_png_set_swap_alpha: procedure(png_ptr: png_structp); cdecl;
_png_set_invert_alpha: procedure(png_ptr: png_structp); cdecl;
_png_set_filler: procedure(png_ptr: png_structp; filler: png_uint_32; flags: longint); cdecl;
_png_set_swap: procedure(png_ptr: png_structp); cdecl;
_png_set_packing: procedure(png_ptr: png_structp); cdecl;
_png_set_packswap: procedure(png_ptr: png_structp); cdecl;
_png_set_shift: procedure(png_ptr: png_structp; true_bits: png_color_8p); cdecl;
_png_set_interlace_handling: function(png_ptr: png_structp): longint; cdecl;
_png_set_invert_mono: procedure(png_ptr: png_structp); cdecl;
_png_set_background: procedure(png_ptr: png_structp; background_color: png_color_16p; background_gamma_code: longint; need_expand: longint; background_gamma: double); cdecl;
_png_set_strip_16: procedure(png_ptr: png_structp); cdecl;
_png_set_dither: procedure(png_ptr: png_structp; palette: png_colorp; num_palette: longint; maximum_colors: longint; histogram: png_uint_16p; full_dither: longint); cdecl;
_png_set_gamma: procedure(png_ptr: png_structp; screen_gamma: double; default_file_gamma: double); cdecl;
_png_permit_empty_plte: procedure(png_ptr: png_structp; empty_plte_permitted: longint); cdecl;
_png_set_flush: procedure(png_ptr: png_structp; nrows: longint); cdecl;
_png_write_flush: procedure(png_ptr: png_structp); cdecl;
_png_start_read_image: procedure(png_ptr: png_structp); cdecl;
_png_read_update_info: procedure(png_ptr: png_structp; info_ptr: png_infop); cdecl;
_png_read_rows: procedure(png_ptr: png_structp; row: png_bytepp; display_row: png_bytepp; num_rows: png_uint_32); cdecl;
_png_read_row: procedure(png_ptr: png_structp; row: png_bytep; display_row: png_bytep); cdecl;
_png_read_image: procedure(png_ptr: png_structp; image: png_bytepp); cdecl;
_png_write_row: procedure(png_ptr: png_structp; row: png_bytep); cdecl;
_png_write_rows: procedure(png_ptr: png_structp; row: png_bytepp; num_rows: png_uint_32); cdecl;
_png_write_image: procedure(png_ptr: png_structp; image: png_bytepp); cdecl;
_png_write_end: procedure(png_ptr: png_structp; info_ptr: png_infop); cdecl;
_png_read_end: procedure(png_ptr: png_structp; info_ptr: png_infop); cdecl;
_png_destroy_info_struct: procedure(png_ptr: png_structp; info_ptr_ptr: png_infopp); cdecl;
_png_destroy_read_struct: procedure(png_ptr_ptr: png_structpp; info_ptr_ptr: png_infopp; end_info_ptr_ptr: png_infopp); cdecl;
_png_read_destroy: procedure(png_ptr: png_structp; info_ptr: png_infop; end_info_ptr: png_infop); cdecl;
_png_destroy_write_struct: procedure(png_ptr_ptr: png_structpp; info_ptr_ptr: png_infopp); cdecl;
_png_write_destroy_info: procedure(info_ptr: png_infop); cdecl;
_png_write_destroy: procedure(png_ptr: png_structp); cdecl;
_png_set_crc_action: procedure(png_ptr: png_structp; crit_action: longint; ancil_action: longint); cdecl;
_png_set_filter: procedure(png_ptr: png_structp; method: longint; filters: longint); cdecl;
_png_set_filter_heuristics: procedure(png_ptr: png_structp; heuristic_method: longint; num_weights: longint; filter_weights: png_doublep; filter_costs: png_doublep); cdecl;
_png_set_compression_level: procedure(png_ptr: png_structp; level: longint); cdecl;
_png_set_compression_mem_level: procedure(png_ptr: png_structp; mem_level: longint); cdecl;
_png_set_compression_strategy: procedure(png_ptr: png_structp; strategy: longint); cdecl;
_png_set_compression_window_bits: procedure(png_ptr: png_structp; window_bits: longint); cdecl;
_png_set_compression_method: procedure(png_ptr: png_structp; method: longint); cdecl;
_png_init_io: procedure(png_ptr: png_structp; fp: png_FILE_p); cdecl;
_png_set_error_fn: procedure(png_ptr: png_structp; error_ptr: png_voidp; error_fn: png_error_ptr; warning_fn: png_error_ptr); cdecl;
_png_get_error_ptr: function(png_ptr: png_structp): png_voidp; cdecl;
_png_set_write_fn: procedure(png_ptr: png_structp; io_ptr: png_voidp; write_data_fn: png_rw_ptr; output_flush_fn: png_flush_ptr); cdecl;
_png_set_read_fn: procedure(png_ptr: png_structp; io_ptr: png_voidp; read_data_fn: png_rw_ptr); cdecl;
_png_get_io_ptr: function(png_ptr: png_structp): png_voidp; cdecl;
_png_set_read_status_fn: procedure(png_ptr: png_structp; read_row_fn: png_read_status_ptr); cdecl;
_png_set_write_status_fn: procedure(png_ptr: png_structp; write_row_fn: png_write_status_ptr); cdecl;
_png_set_read_user_transform_fn: procedure(png_ptr: png_structp; read_user_transform_fn: png_user_transform_ptr); cdecl;
_png_set_write_user_transform_fn: procedure(png_ptr: png_structp; write_user_transform_fn: png_user_transform_ptr); cdecl;
_png_set_user_transform_info: procedure(png_ptr: png_structp; user_transform_ptr: png_voidp; user_transform_depth: longint; user_transform_channels: longint); cdecl;
_png_get_user_transform_ptr: function(png_ptr: png_structp): png_voidp; cdecl;
_png_set_read_user_chunk_fn: procedure(png_ptr: png_structp; user_chunk_ptr: png_voidp; read_user_chunk_fn: png_user_chunk_ptr); cdecl;
_png_get_user_chunk_ptr: function(png_ptr: png_structp): png_voidp; cdecl;
_png_set_progressive_read_fn: procedure(png_ptr: png_structp; progressive_ptr: png_voidp; info_fn: png_progressive_info_ptr; row_fn: png_progressive_row_ptr; end_fn: png_progressive_end_ptr); cdecl;
_png_get_progressive_ptr: function(png_ptr: png_structp): png_voidp; cdecl;
_png_process_data: procedure(png_ptr: png_structp; info_ptr: png_infop; buffer: png_bytep; buffer_size: png_size_t); cdecl;
_png_progressive_combine_row: procedure(png_ptr: png_structp; old_row: png_bytep; new_row: png_bytep); cdecl;
_png_malloc: function(png_ptr: png_structp; size: png_uint_32): png_voidp; cdecl;
_png_free: procedure(png_ptr: png_structp; ptr: png_voidp); cdecl;
_png_free_data: procedure(png_ptr: png_structp; info_ptr: png_infop; free_me: png_uint_32; num: longint); cdecl;
_png_data_freer: procedure(png_ptr: png_structp; info_ptr: png_infop; freer: longint; mask: png_uint_32); cdecl;
_png_memcpy_check: function(png_ptr: png_structp; s1: png_voidp; s2: png_voidp; size: png_uint_32): png_voidp; cdecl;
_png_memset_check: function(png_ptr: png_structp; s1: png_voidp; Value: longint; size: png_uint_32): png_voidp; cdecl;
_png_error: procedure(png_ptr: png_structp; error: png_const_charp); cdecl;
_png_chunk_error: procedure(png_ptr: png_structp; error: png_const_charp); cdecl;
_png_warning: procedure(png_ptr: png_structp; message: png_const_charp); cdecl;
_png_chunk_warning: procedure(png_ptr: png_structp; message: png_const_charp); cdecl;
_png_get_valid: function(png_ptr: png_structp; info_ptr: png_infop; flag: png_uint_32): png_uint_32; cdecl;
_png_get_rowbytes: function(png_ptr: png_structp; info_ptr: png_infop): png_uint_32; cdecl;
_png_get_rows: function(png_ptr: png_structp; info_ptr: png_infop): png_bytepp; cdecl;
_png_set_rows: procedure(png_ptr: png_structp; info_ptr: png_infop; row_pointers: png_bytepp); cdecl;
_png_get_channels: function(png_ptr: png_structp; info_ptr: png_infop): png_byte; cdecl;
_png_get_image_width: function(png_ptr: png_structp; info_ptr: png_infop): png_uint_32; cdecl;
_png_get_image_height: function(png_ptr: png_structp; info_ptr: png_infop): png_uint_32; cdecl;
_png_get_bit_depth: function(png_ptr: png_structp; info_ptr: png_infop): png_byte; cdecl;
_png_get_color_type: function(png_ptr: png_structp; info_ptr: png_infop): png_byte; cdecl;
_png_get_filter_type: function(png_ptr: png_structp; info_ptr: png_infop): png_byte; cdecl;
_png_get_interlace_type: function(png_ptr: png_structp; info_ptr: png_infop): png_byte; cdecl;
_png_get_compression_type: function(png_ptr: png_structp; info_ptr: png_infop): png_byte; cdecl;
_png_get_pixels_per_meter: function(png_ptr: png_structp; info_ptr: png_infop): png_uint_32; cdecl;
_png_get_x_pixels_per_meter: function(png_ptr: png_structp; info_ptr: png_infop): png_uint_32; cdecl;
_png_get_y_pixels_per_meter: function(png_ptr: png_structp; info_ptr: png_infop): png_uint_32; cdecl;
_png_get_pixel_aspect_ratio: function(png_ptr: png_structp; info_ptr: png_infop): double; cdecl;
_png_get_x_offset_pixels: function(png_ptr: png_structp; info_ptr: png_infop): png_int_32; cdecl;
_png_get_y_offset_pixels: function(png_ptr: png_structp; info_ptr: png_infop): png_int_32; cdecl;
_png_get_x_offset_microns: function(png_ptr: png_structp; info_ptr: png_infop): png_int_32; cdecl;
_png_get_y_offset_microns: function(png_ptr: png_structp; info_ptr: png_infop): png_int_32; cdecl;
_png_get_signature: function(png_ptr: png_structp; info_ptr: png_infop): png_bytep; cdecl;
_png_get_bKGD: function(png_ptr: png_structp; info_ptr: png_infop; background: Ppng_color_16p): png_uint_32; cdecl;
_png_set_bKGD: procedure(png_ptr: png_structp; info_ptr: png_infop; background: png_color_16p); cdecl;
_png_get_cHRM: function(png_ptr: png_structp; info_ptr: png_infop; white_x: Pdouble; white_y: Pdouble; red_x: Pdouble; red_y: Pdouble; green_x: Pdouble; green_y: Pdouble; blue_x: Pdouble; blue_y: Pdouble): png_uint_32; cdecl;
_png_get_cHRM_fixed: function(png_ptr: png_structp; info_ptr: png_infop; int_white_x: Ppng_fixed_point; int_white_y: Ppng_fixed_point; int_red_x: Ppng_fixed_point; int_red_y: Ppng_fixed_point; int_green_x: Ppng_fixed_point; int_green_y: Ppng_fixed_point; int_blue_x: Ppng_fixed_point; int_blue_y: Ppng_fixed_point): png_uint_32; cdecl;
_png_set_cHRM: procedure(png_ptr: png_structp; info_ptr: png_infop; white_x: double; white_y: double; red_x: double; red_y: double; green_x: double; green_y: double; blue_x: double; blue_y: double); cdecl;
_png_set_cHRM_fixed: procedure(png_ptr: png_structp; info_ptr: png_infop; int_white_x: png_fixed_point; int_white_y: png_fixed_point; int_red_x: png_fixed_point; int_red_y: png_fixed_point; int_green_x: png_fixed_point; int_green_y: png_fixed_point; int_blue_x: png_fixed_point; int_blue_y: png_fixed_point); cdecl;
_png_get_gAMA: function(png_ptr: png_structp; info_ptr: png_infop; file_gamma: Pdouble): png_uint_32; cdecl;
_png_get_gAMA_fixed: function(png_ptr: png_structp; info_ptr: png_infop; int_file_gamma: Ppng_fixed_point): png_uint_32; cdecl;
_png_set_gAMA: procedure(png_ptr: png_structp; info_ptr: png_infop; file_gamma: double); cdecl;
_png_set_gAMA_fixed: procedure(png_ptr: png_structp; info_ptr: png_infop; int_file_gamma: png_fixed_point); cdecl;
_png_get_hIST: function(png_ptr: png_structp; info_ptr: png_infop; hist: Ppng_uint_16p): png_uint_32; cdecl;
_png_set_hIST: procedure(png_ptr: png_structp; info_ptr: png_infop; hist: png_uint_16p); cdecl;
_png_get_IHDR: function(png_ptr: png_structp; info_ptr: png_infop; Width: Ppng_uint_32; Height: Ppng_uint_32; bit_depth: Plongint; color_type: Plongint; interlace_type: Plongint; compression_type: Plongint; filter_type: Plongint): png_uint_32; cdecl;
_png_set_IHDR: procedure(png_ptr: png_structp; info_ptr: png_infop; Width: png_uint_32; Height: png_uint_32; bit_depth: longint; color_type: longint; interlace_type: longint; compression_type: longint; filter_type: longint); cdecl;
_png_get_oFFs: function(png_ptr: png_structp; info_ptr: png_infop; offset_x: Ppng_int_32; offset_y: Ppng_int_32; unit_type: Plongint): png_uint_32; cdecl;
_png_set_oFFs: procedure(png_ptr: png_structp; info_ptr: png_infop; offset_x: png_int_32; offset_y: png_int_32; unit_type: longint); cdecl;
_png_get_pCAL: function(png_ptr: png_structp; info_ptr: png_infop; purpose: Ppng_charp; X0: Ppng_int_32; X1: Ppng_int_32; atype: Plongint; nparams: Plongint; units: Ppng_charp; params: Ppng_charpp): png_uint_32; cdecl;
_png_set_pCAL: procedure(png_ptr: png_structp; info_ptr: png_infop; purpose: png_charp; X0: png_int_32; X1: png_int_32; atype: longint; nparams: longint; units: png_charp; params: png_charpp); cdecl;
_png_get_pHYs: function(png_ptr: png_structp; info_ptr: png_infop; res_x: Ppng_uint_32; res_y: Ppng_uint_32; unit_type: Plongint): png_uint_32; cdecl;
_png_set_pHYs: procedure(png_ptr: png_structp; info_ptr: png_infop; res_x: png_uint_32; res_y: png_uint_32; unit_type: longint); cdecl;
_png_get_PLTE: function(png_ptr: png_structp; info_ptr: png_infop; palette: Ppng_colorp; num_palette: Plongint): png_uint_32; cdecl;
_png_set_PLTE: procedure(png_ptr: png_structp; info_ptr: png_infop; palette: png_colorp; num_palette: longint); cdecl;
_png_get_sBIT: function(png_ptr: png_structp; info_ptr: png_infop; sig_bit: Ppng_color_8p): png_uint_32; cdecl;
_png_set_sBIT: procedure(png_ptr: png_structp; info_ptr: png_infop; sig_bit: png_color_8p); cdecl;
_png_get_sRGB: function(png_ptr: png_structp; info_ptr: png_infop; intent: Plongint): png_uint_32; cdecl;
_png_set_sRGB: procedure(png_ptr: png_structp; info_ptr: png_infop; intent: longint); cdecl;
_png_set_sRGB_gAMA_and_cHRM: procedure(png_ptr: png_structp; info_ptr: png_infop; intent: longint); cdecl;
_png_get_iCCP: function(png_ptr: png_structp; info_ptr: png_infop; Name: png_charpp; compression_type: Plongint; profile: png_charpp; proflen: Ppng_uint_32): png_uint_32; cdecl;
_png_set_iCCP: procedure(png_ptr: png_structp; info_ptr: png_infop; Name: png_charp; compression_type: longint; profile: png_charp; proflen: png_uint_32); cdecl;
_png_get_sPLT: function(png_ptr: png_structp; info_ptr: png_infop; entries: png_sPLT_tpp): png_uint_32; cdecl;
_png_set_sPLT: procedure(png_ptr: png_structp; info_ptr: png_infop; entries: png_sPLT_tp; nentries: longint); cdecl;
_png_get_text: function(png_ptr: png_structp; info_ptr: png_infop; text_ptr: Ppng_textp; num_text: Plongint): png_uint_32; cdecl;
_png_set_text: procedure(png_ptr: png_structp; info_ptr: png_infop; text_ptr: png_textp; num_text: longint); cdecl;
_png_get_tIME: function(png_ptr: png_structp; info_ptr: png_infop; mod_time: Ppng_timep): png_uint_32; cdecl;
_png_set_tIME: procedure(png_ptr: png_structp; info_ptr: png_infop; mod_time: png_timep); cdecl;
_png_get_tRNS: function(png_ptr: png_structp; info_ptr: png_infop; trans: Ppng_bytep; num_trans: Plongint; trans_values: Ppng_color_16p): png_uint_32; cdecl;
_png_set_tRNS: procedure(png_ptr: png_structp; info_ptr: png_infop; trans: png_bytep; num_trans: longint; trans_values: png_color_16p); cdecl;
_png_get_sCAL: function(png_ptr: png_structp; info_ptr: png_infop; aunit: Plongint; Width: Pdouble; Height: Pdouble): png_uint_32; cdecl;
_png_set_sCAL: procedure(png_ptr: png_structp; info_ptr: png_infop; aunit: longint; Width: double; Height: double); cdecl;
_png_set_sCAL_s: procedure(png_ptr: png_structp; info_ptr: png_infop; aunit: longint; swidth: png_charp; sheight: png_charp); cdecl;
_png_set_keep_unknown_chunks: procedure(png_ptr: png_structp; keep: longint; chunk_list: png_bytep; num_chunks: longint); cdecl;
_png_set_unknown_chunks: procedure(png_ptr: png_structp; info_ptr: png_infop; unknowns: png_unknown_chunkp; num_unknowns: longint); cdecl;
_png_set_unknown_chunk_location: procedure(png_ptr: png_structp; info_ptr: png_infop; chunk: longint; location: longint); cdecl;
_png_get_unknown_chunks: function(png_ptr: png_structp; info_ptr: png_infop; entries: png_unknown_chunkpp): png_uint_32; cdecl;
_png_set_invalid: procedure(png_ptr: png_structp; info_ptr: png_infop; mask: longint); cdecl;
_png_read_png: procedure(png_ptr: png_structp; info_ptr: png_infop; transforms: longint; params: Pointer); cdecl;
_png_write_png: procedure(png_ptr: png_structp; info_ptr: png_infop; transforms: longint; params: Pointer); cdecl;
_png_get_header_ver: function(png_ptr: png_structp): png_charp; cdecl;
_png_get_header_version: function(png_ptr: png_structp): png_charp; cdecl;
_png_get_libpng_ver: function(png_ptr: png_structp): png_charp; cdecl;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:16


GLScene v.1.1.2: LIBPNG: record jmp_buf

record jmp_buf

Unit

LIBPNG

Declaration

type jmp_buf = record

Description

Overview

Fields

j_ebp: cardinal;
j_ebx: cardinal;
j_edi: cardinal;
j_esi: cardinal;
j_esp: cardinal;
j_ret: cardinal;
j_excep: cardinal;
j_context: cardinal;

Description

Fields

j_ebp: cardinal;
j_ebx: cardinal;
j_edi: cardinal;
j_esi: cardinal;
j_esp: cardinal;
j_ret: cardinal;
j_excep: cardinal;
j_context: cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:16


GLScene v.1.1.2: LIBPNG: record png_color

record png_color

Unit

LIBPNG

Declaration

type png_color = record

Description

Three color definitions. The order of the red, green, and blue, (and the exact size) is not important, although the size of the fields need to be png_byte or png_uint_16 (as defined below).

Overview

Fields

red: png_byte;
green: png_byte;
blue: png_byte;

Description

Fields

red: png_byte;
green: png_byte;
blue: png_byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:16


GLScene v.1.1.2: LIBPNG: record png_color_8

record png_color_8

Unit

LIBPNG

Declaration

type png_color_8 = record

Description

Overview

Fields

red: png_byte;
green: png_byte;
blue: png_byte;
gray: png_byte;
alpha: png_byte;

Description

Fields

red: png_byte;
green: png_byte;
blue: png_byte;
gray: png_byte;
alpha: png_byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:16


GLScene v.1.1.2: LIBPNG: record png_color_16

record png_color_16

Unit

LIBPNG

Declaration

type png_color_16 = record

Description

Overview

Fields

index: png_byte;
red: png_uint_16;
green: png_uint_16;
blue: png_uint_16;
gray: png_uint_16;

Description

Fields

index: png_byte;
red: png_uint_16;
green: png_uint_16;
blue: png_uint_16;
gray: png_uint_16;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:16


GLScene v.1.1.2: LIBPNG: record png_unknown_chunk

record png_unknown_chunk

Unit

LIBPNG

Declaration

type png_unknown_chunk = record

Description

png_unknown_chunk is a structure to hold queued chunks for which there is no specific support. The idea is that we can use this to queue up private chunks for output even though the library doesn't actually know about their semantics.

Overview

Fields

Name: array[0..4] of png_byte;
Data: png_bytep;
size: png_size_t;

Description

Fields

Name: array[0..4] of png_byte;
Data: png_bytep;
size: png_size_t;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:16


GLScene v.1.1.2: LIBPNG: record png_text

record png_text

Unit

LIBPNG

Declaration

type png_text = record

Description

Overview

Fields

compression: integer;
key: png_charp;
Text: png_charp;
text_length: png_size_t;
itxt_length: png_size_t;
lang: png_charp;
lang_key: png_charp;

Description

Fields

compression: integer;

compression value: -1: tEXt, none 0: zTXt, deflate 1: iTXt, none 2: iTXt, deflate

key: png_charp;

keyword, 1-79 character description of "text"

Text: png_charp;

comment, may be an empty string (ie "") or a NULL pointer

text_length: png_size_t;

length of the text string

itxt_length: png_size_t;

length of the itxt string

lang: png_charp;

language code, 0-79 characters or a NULL pointer

lang_key: png_charp;

keyword translated UTF-8 string, 0 or more chars or a NULL pointer

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:16


GLScene v.1.1.2: LIBPNG: record png_time

record png_time

Unit

LIBPNG

Declaration

type png_time = record

Description

Overview

Fields

year: png_uint_16;
month: png_byte;
day: png_byte;
hour: png_byte;
minute: png_byte;
second: png_byte;

Description

Fields

year: png_uint_16;
month: png_byte;

full year, as in, 1995

day: png_byte;

month of year, 1 - 12

hour: png_byte;

day of month, 1 - 31

minute: png_byte;

hour of day, 0 - 23

second: png_byte;

minute of hour, 0 - 59

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:16


GLScene v.1.1.2: LIBPNG: record png_sPLT_entry

record png_sPLT_entry

Unit

LIBPNG

Declaration

type png_sPLT_entry = record

Description

Overview

Fields

red: png_uint_16;
green: png_uint_16;
blue: png_uint_16;
alpha: png_uint_16;
frequency: png_uint_16;

Description

Fields

red: png_uint_16;
green: png_uint_16;
blue: png_uint_16;
alpha: png_uint_16;
frequency: png_uint_16;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:16


GLScene v.1.1.2: LIBPNG: record png_sPLT_t

record png_sPLT_t

Unit

LIBPNG

Declaration

type png_sPLT_t = record

Description

Overview

Fields

Name: png_charp;
depth: png_byte;
entries: png_sPLT_entryp;
nentries: png_int_32;

Description

Fields

Name: png_charp;
depth: png_byte;

palette name

entries: png_sPLT_entryp;

depth of palette samples

nentries: png_int_32;

palette entries

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:16


GLScene v.1.1.2: LIBPNG: record png_info

record png_info

Unit

LIBPNG

Declaration

type png_info = record

Description

Overview

Fields

Width: png_uint_32;
Height: png_uint_32;
valid: png_uint_32;
rowbytes: png_size_t;
palette: png_colorp;
num_palette: png_uint_16;
num_trans: png_uint_16;
bit_depth: png_byte;
color_type: png_byte;
compression_type: png_byte;
filter_type: png_byte;
interlace_type: png_byte;
channels: png_byte;
pixel_depth: png_byte;
spare_byte: png_byte;
signature: array[0..7] of png_byte;
gamma: single;
srgb_intent: png_byte;
num_text: integer;
max_text: integer;
Text: png_textp;
mod_time: png_time;
sig_bit: png_color_8;
trans_alpha: png_bytep;
trans_color: png_color_16;
background: png_color_16;
x_offset: png_int_32;
y_offset: png_int_32;
offset_unit_type: png_byte;
x_pixels_per_unit: png_uint_32;
y_pixels_per_unit: png_uint_32;
phys_unit_type: png_byte;
hist: png_uint_16p;
x_white: single;
y_white: single;
x_red: single;
y_red: single;
x_green: single;
y_green: single;
x_blue: single;
y_blue: single;
pcal_purpose: png_charp;
pcal_X0: png_int_32;
pcal_X1: png_int_32;
pcal_units: png_charp;
pcal_params: png_charpp;
pcal_type: png_byte;
pcal_nparams: png_byte;
free_me: png_uint_32;
unknown_chunks: png_unknown_chunkp;
unknown_chunks_num: png_size_t;
iccp_name: png_charp;
iccp_profile: png_charp;
iccp_proflen: png_uint_32;
iccp_compression: png_byte;
splt_palettes: png_sPLT_tp;
splt_palettes_num: png_uint_32;
scal_unit: png_byte;
scal_pixel_width: double;
scal_pixel_height: double;
scal_s_width: png_charp;
scal_s_height: png_charp;
row_pointers: png_bytepp;
int_gamma: png_fixed_point;
int_x_white: png_fixed_point;
int_y_white: png_fixed_point;
int_x_red: png_fixed_point;
int_y_red: png_fixed_point;
int_x_green: png_fixed_point;
int_y_green: png_fixed_point;
int_x_blue: png_fixed_point;
int_y_blue: png_fixed_point;

Description

Fields

Width: png_uint_32;
Height: png_uint_32;

width of image in pixels (from IHDR)

valid: png_uint_32;

height of image in pixels (from IHDR)

rowbytes: png_size_t;

valid chunk data (see PNG_INFO_ below)

palette: png_colorp;

bytes needed to hold an untransformed row

num_palette: png_uint_16;

array of color values (valid & PNG_INFO_PLTE)

num_trans: png_uint_16;

number of color entries in "palette" (PLTE)

bit_depth: png_byte;

number of transparent palette color (tRNS)

color_type: png_byte;

1, 2, 4, 8, or 16 bits/channel (from IHDR)

compression_type: png_byte;

see PNG_COLOR_TYPE_ below (from IHDR)

filter_type: png_byte;

must be PNG_COMPRESSION_TYPE_BASE (IHDR)

interlace_type: png_byte;

must be PNG_FILTER_TYPE_BASE (from IHDR)

channels: png_byte;

One of PNG_INTERLACE_NONE, PNG_INTERLACE_ADAM7

pixel_depth: png_byte;

number of data channels per pixel (1, 2, 3, 4)

spare_byte: png_byte;

number of bits per pixel

signature: array[0..7] of png_byte;

to align the data, and for future use

gamma: single;

magic bytes read by libpng from start of file

srgb_intent: png_byte;

gamma value of image, if (valid & PNG_INFO_gAMA)

num_text: integer;

sRGB rendering intent [0, 1, 2, or 3]

max_text: integer;

number of comments read/to write

Text: png_textp;

current size of text array

mod_time: png_time;

array of comments read/to write

sig_bit: png_color_8;
trans_alpha: png_bytep;

significant bits in color channels

trans_color: png_color_16;

alpha values for paletted image

background: png_color_16;

transparent color for non-palette image

x_offset: png_int_32;
y_offset: png_int_32;

x offset on page

offset_unit_type: png_byte;

y offset on page

x_pixels_per_unit: png_uint_32;

offset units type

y_pixels_per_unit: png_uint_32;

horizontal pixel density

phys_unit_type: png_byte;

vertical pixel density

hist: png_uint_16p;

resolution type (see PNG_RESOLUTION_ below)

x_white: single;
y_white: single;
x_red: single;
y_red: single;
x_green: single;
y_green: single;
x_blue: single;
y_blue: single;
pcal_purpose: png_charp;
pcal_X0: png_int_32;

pCAL chunk description string

pcal_X1: png_int_32;

minimum value

pcal_units: png_charp;

maximum value

pcal_params: png_charpp;

Latin-1 string giving physical units

pcal_type: png_byte;

ASCII strings containing parameter values

pcal_nparams: png_byte;

equation type (see PNG_EQUATION_ below)

free_me: png_uint_32;

number of parameters given in pcal_params

unknown_chunks: png_unknown_chunkp;

flags items libpng is responsible for freeing

unknown_chunks_num: png_size_t;
iccp_name: png_charp;
iccp_profile: png_charp;

profile name

iccp_proflen: png_uint_32;

Note to maintainer: should be png_bytep

iccp_compression: png_byte;

ICC profile data length

splt_palettes: png_sPLT_tp;

Always zero

splt_palettes_num: png_uint_32;
scal_unit: png_byte;
scal_pixel_width: double;

unit of physical scale

scal_pixel_height: double;

width of one pixel

scal_s_width: png_charp;

height of one pixel

scal_s_height: png_charp;

string containing height

row_pointers: png_bytepp;

string containing width

int_gamma: png_fixed_point;

the image bits

int_x_white: png_fixed_point;

gamma of image, if (valid & PNG_INFO_gAMA)

int_y_white: png_fixed_point;
int_x_red: png_fixed_point;
int_y_red: png_fixed_point;
int_x_green: png_fixed_point;
int_y_green: png_fixed_point;
int_x_blue: png_fixed_point;
int_y_blue: png_fixed_point;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:16


GLScene v.1.1.2: LIBPNG: record png_row_info

record png_row_info

Unit

LIBPNG

Declaration

type png_row_info = record

Description

Overview

Fields

Width: png_uint_32;
rowbytes: png_uint_32;
color_type: png_byte;
bit_depth: png_byte;
channels: png_byte;
pixel_depth: png_byte;

Description

Fields

Width: png_uint_32;
rowbytes: png_uint_32;
color_type: png_byte;
bit_depth: png_byte;
channels: png_byte;
pixel_depth: png_byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:16


GLScene v.1.1.2: LIBPNG: packed record TZStreamRec

packed record TZStreamRec

Unit

LIBPNG

Declaration

type TZStreamRec = packed record

Description

Overview

Fields

next_in: PAnsiChar;
avail_in: integer;
total_in: integer;
next_out: PAnsiChar;
avail_out: integer;
total_out: integer;
msg: PAnsiChar;
internal: Pointer;
zalloc: TAlloc;
zfree: TFree;
AppData: Pointer;
data_type: integer;
adler: integer;
reserved: integer;

Description

Fields

next_in: PAnsiChar;
avail_in: integer;
total_in: integer;
next_out: PAnsiChar;
avail_out: integer;
total_out: integer;
msg: PAnsiChar;
internal: Pointer;
zalloc: TAlloc;
zfree: TFree;
AppData: Pointer;
data_type: integer;
adler: integer;
reserved: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LIBPNG: record png_struct

record png_struct

Unit

LIBPNG

Declaration

type png_struct = record

Description

Overview

Fields

jmpbuf: jmp_buf;
longjmp_fn: png_longjmp_ptr;
error_fn: png_error_ptr;
warning_fn: png_error_ptr;
error_ptr: png_voidp;
write_data_fn: png_rw_ptr;
read_data_fn: png_rw_ptr;
io_ptr: png_voidp;
read_user_transform_fn: png_user_transform_ptr;
write_user_transform_fn: png_user_transform_ptr;
user_transform_ptr: png_voidp;
user_transform_depth: png_byte;
user_transform_channels: png_byte;
mode: png_uint_32;
flags: png_uint_32;
transformations: png_uint_32;
zstream: TZStreamRec;
zbuf: png_bytep;
zbuf_size: png_size_t;
zlib_level: integer;
zlib_method: integer;
zlib_window_bits: integer;
zlib_mem_level: integer;
zlib_strategy: integer;
Width: png_uint_32;
Height: png_uint_32;
num_rows: png_uint_32;
usr_width: png_uint_32;
rowbytes: png_uint_32;
irowbytes: png_uint_32;
iwidth: png_uint_32;
row_number: png_uint_32;
prev_row: png_bytep;
row_buf: png_bytep;
sub_row: png_bytep;
up_row: png_bytep;
avg_row: png_bytep;
paeth_row: png_bytep;
row_info: png_row_info;
idat_size: png_uint_32;
crc: png_uint_32;
palette: png_colorp;
num_palette: png_uint_16;
num_trans: png_uint_16;
chunk_name: array[0..4] of png_byte;
compression: png_byte;
filter: png_byte;
interlaced: png_byte;
pass: png_byte;
do_filter: png_byte;
color_type: png_byte;
bit_depth: png_byte;
usr_bit_depth: png_byte;
pixel_depth: png_byte;
channels: png_byte;
usr_channels: png_byte;
sig_bytes: png_byte;
filler: png_uint_16;
background_gamma_type: png_byte;
background_gamma: single;
background: png_color_16;
background_1: png_color_16;
output_flush_fn: png_flush_ptr;
flush_dist: png_uint_32;
flush_rows: png_uint_32;
gamma_shift: integer;
gamma: single;
screen_gamma: single;
gamma_table: png_bytep;
gamma_from_1: png_bytep;
gamma_to_1: png_bytep;
gamma_16_table: png_uint_16pp;
gamma_16_from_1: png_uint_16pp;
gamma_16_to_1: png_uint_16pp;
sig_bit: png_color_8;
shift: png_color_8;
trans: png_bytep;
trans_values: png_color_16;
trans_alpha: png_bytep;
trans_color: png_color_16;
read_row_fn: png_read_status_ptr;
write_row_fn: png_write_status_ptr;
info_fn: png_progressive_info_ptr;
row_fn: png_progressive_row_ptr;
end_fn: png_progressive_end_ptr;
save_buffer_ptr: png_bytep;
save_buffer: png_bytep;
current_buffer_ptr: png_bytep;
current_buffer: png_bytep;
push_length: png_uint_32;
skip_length: png_uint_32;
save_buffer_size: png_size_t;
save_buffer_max: png_size_t;
buffer_size: png_size_t;
current_buffer_size: png_size_t;
process_mode: integer;
cur_palette: integer;
current_text_size: png_size_t;
current_text_left: png_size_t;
current_text: png_charp;
current_text_ptr: png_charp;
hist: png_uint_16p;
heuristic_method: png_byte;
num_prev_filters: png_byte;
prev_filters: png_bytep;
filter_weights: png_uint_16p;
inv_filter_weights: png_uint_16p;
filter_costs: png_uint_16p;
inv_filter_costs: png_uint_16p;
time_buffer: png_charp;
free_me: png_uint_32;
user_chunk_ptr: png_voidp;
read_user_chunk_fn: png_user_chunk_ptr;
num_chunk_list: integer;
chunk_list: png_bytep;
rgb_to_gray_status: png_byte;
rgb_to_gray_red_coeff: png_uint_16;
rgb_to_gray_green_coeff: png_uint_16;
rgb_to_gray_blue_coeff: png_uint_16;
mng_features_permitted: png_uint_32;
int_gamma: png_fixed_point;
filter_type: png_byte;
mem_ptr: png_voidp;
malloc_fn: png_malloc_ptr;
free_fn: png_free_ptr;
big_row_buf: png_bytep;
compression_type: png_byte;
unknown_chunk: png_unknown_chunk;
old_big_row_buf_size: png_uint_32;
old_prev_row_size: png_uint_32;
chunkdata: png_charp;
io_state: png_uint_32;

Description

Fields

jmpbuf: jmp_buf;
longjmp_fn: png_longjmp_ptr;
error_fn: png_error_ptr;
warning_fn: png_error_ptr;
error_ptr: png_voidp;
write_data_fn: png_rw_ptr;
read_data_fn: png_rw_ptr;
io_ptr: png_voidp;
read_user_transform_fn: png_user_transform_ptr;
write_user_transform_fn: png_user_transform_ptr;
user_transform_ptr: png_voidp;
user_transform_depth: png_byte;
user_transform_channels: png_byte;
mode: png_uint_32;
flags: png_uint_32;
transformations: png_uint_32;
zstream: TZStreamRec;
zbuf: png_bytep;
zbuf_size: png_size_t;
zlib_level: integer;
zlib_method: integer;
zlib_window_bits: integer;
zlib_mem_level: integer;
zlib_strategy: integer;
Width: png_uint_32;
Height: png_uint_32;
num_rows: png_uint_32;
usr_width: png_uint_32;
rowbytes: png_uint_32;
irowbytes: png_uint_32;
iwidth: png_uint_32;
row_number: png_uint_32;
prev_row: png_bytep;
row_buf: png_bytep;
sub_row: png_bytep;
up_row: png_bytep;
avg_row: png_bytep;
paeth_row: png_bytep;
row_info: png_row_info;
idat_size: png_uint_32;
crc: png_uint_32;
palette: png_colorp;
num_palette: png_uint_16;
num_trans: png_uint_16;
chunk_name: array[0..4] of png_byte;
compression: png_byte;
filter: png_byte;
interlaced: png_byte;
pass: png_byte;
do_filter: png_byte;
color_type: png_byte;
bit_depth: png_byte;
usr_bit_depth: png_byte;
pixel_depth: png_byte;
channels: png_byte;
usr_channels: png_byte;
sig_bytes: png_byte;
filler: png_uint_16;
background_gamma_type: png_byte;
background_gamma: single;
background: png_color_16;
background_1: png_color_16;
output_flush_fn: png_flush_ptr;
flush_dist: png_uint_32;
flush_rows: png_uint_32;
gamma_shift: integer;
gamma: single;
screen_gamma: single;
gamma_table: png_bytep;
gamma_from_1: png_bytep;
gamma_to_1: png_bytep;
gamma_16_table: png_uint_16pp;
gamma_16_from_1: png_uint_16pp;
gamma_16_to_1: png_uint_16pp;
sig_bit: png_color_8;
shift: png_color_8;
trans: png_bytep;
trans_values: png_color_16;
trans_alpha: png_bytep;
trans_color: png_color_16;
read_row_fn: png_read_status_ptr;
write_row_fn: png_write_status_ptr;
info_fn: png_progressive_info_ptr;
row_fn: png_progressive_row_ptr;
end_fn: png_progressive_end_ptr;
save_buffer_ptr: png_bytep;
save_buffer: png_bytep;
current_buffer_ptr: png_bytep;
current_buffer: png_bytep;
push_length: png_uint_32;
skip_length: png_uint_32;
save_buffer_size: png_size_t;
save_buffer_max: png_size_t;
buffer_size: png_size_t;
current_buffer_size: png_size_t;
process_mode: integer;
cur_palette: integer;
current_text_size: png_size_t;
current_text_left: png_size_t;
current_text: png_charp;
current_text_ptr: png_charp;
hist: png_uint_16p;
heuristic_method: png_byte;
num_prev_filters: png_byte;
prev_filters: png_bytep;
filter_weights: png_uint_16p;
inv_filter_weights: png_uint_16p;
filter_costs: png_uint_16p;
inv_filter_costs: png_uint_16p;
time_buffer: png_charp;
free_me: png_uint_32;
user_chunk_ptr: png_voidp;
read_user_chunk_fn: png_user_chunk_ptr;
num_chunk_list: integer;
chunk_list: png_bytep;
rgb_to_gray_status: png_byte;
rgb_to_gray_red_coeff: png_uint_16;
rgb_to_gray_green_coeff: png_uint_16;
rgb_to_gray_blue_coeff: png_uint_16;
mng_features_permitted: png_uint_32;
int_gamma: png_fixed_point;
filter_type: png_byte;
mem_ptr: png_voidp;
malloc_fn: png_malloc_ptr;
free_fn: png_free_ptr;
big_row_buf: png_bytep;
compression_type: png_byte;
unknown_chunk: png_unknown_chunk;
old_big_row_buf_size: png_uint_32;
old_prev_row_size: png_uint_32;
chunkdata: png_charp;
io_state: png_uint_32;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects

Unit LWObjects

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TLWChunkRec |
record TLWSubChunkRec |
record TLWPolsInfo |
record TLWPntsInfo |
record TLWPolyTagMap |
record TLWVertexMap |
Class TLWChunk |
Class TLWSubChunk |
Class TLWChunkList |
Class TLWParentChunk |
Class TLWPnts |
Class TLWPols |
Class TLWVMap |
Class TLWTags |
Class TLWSurf |
Class TLWLayr |
Class TLWPTag |
Class TLWObjectFile |
Class TLWClip |
Class TLWContentDir |

Functions and Procedures

procedure RegisterChunkClass(ChunkClass: TLWChunkClass);
function LoadLW0FromStream(Stream: TStream; ReadCallback: TLWOReadCallback; UserData: Pointer): LongWord; cdecl;
function LoadLWOFromFile(const AFilename: string; ReadCallback: TLWOReadCallback; UserData: Pointer): LongWord;
procedure ReadMotorolaNumber(Stream: TStream; Data: Pointer; ElementSize: Integer; Count: Integer = 1);
function WriteMotorolaNumber(Stream: TStream; Data: Pointer; ElementSize: Integer; Count: Integer = 1): Integer;
function ReadS0(Stream: TStream; out Str: string): Integer;
procedure WriteS0(Stream: TStream; Data: string);
procedure WriteU4AsVX(Stream:TStream; Data: Pointer; Count: Integer);
function ReadVXAsU4(Stream: TStream; Data: Pointer; Count: Integer = 1): Integer;
procedure ReverseByteOrder(ValueIn: Pointer; Size: Integer; Count: Integer = 1);
function ToDosPath(const Path: string): string;
function ToUnixPath(const Path: string): string;
function ID4ToInt(const Id: TID4): Integer;
procedure FindChunkById(AChunk: TLWChunk; Data: Pointer; var Found: boolean);
procedure FindSurfaceByName(AChunk: TLWChunk; AName: Pointer; var Found: boolean);
procedure FindSurfaceByTag(AChunk: TLWChunk; ATag: Pointer; var Found: boolean);
procedure FindVMapByName(AChunk: TLWChunk; AName: Pointer; var Found: boolean);
procedure FindClipByClipIndex(AChunk: TLWChunk; AIndex: Pointer; var Found: boolean);
function GetContentDir: TLWContentDir;

Types

TID4 = array[0..3] of AnsiChar;
PID4 = ˆTID4;
TID4DynArray = array of TID4;
TI1 = ShortInt;
PI1 = ˆTI1;
TI2 = SmallInt;
PI2 = ˆTI2;
TI4 = LongInt;
PI4 = ˆTI4;
TU1 = Byte;
PU1 = ˆTU1;
TU1DynArray = array of TU1;
TU2 = Word;
PU2 = ˆTU2;
TU2Array = array [0..65534] of TU2;
PU2Array = ˆTU2Array;
TU2DynArray = array of TU2;
TU4 = LongWord;
PU4 = ˆTU4;
TU4Array = array [0..65534] of TU4;
PU4Array = ˆTU4Array;
TU4DynArray = array of TU4;
TF4 = Single;
PF4 = ˆTF4;
TF4Array = array [0..65534] of TF4;
PF4Array = ˆTF4Array;
TF4DynArray = array of TF4;
TANG4 = TF4;
PANG4 = ˆTANG4;
TVec12 = array[0..2] of TF4;
PVec12 = ˆTVec12;
TVec12Array = array [0..65534] of TVec12;
PVec12Array = ˆTVec12Array;
TVec12DynArray = array of TVec12;
TColr12 = TVec12;
PColr12 = ˆTColr12;
TColr12DynArray = array of TColr12;
TColr4 = array[0..3] of TU1;
PColr4 = ˆTColr4;
PLWChunkRec = ˆTLWChunkRec;
PLWSubChunkRec = ˆTLWSubChunkRec;
TLWPolsInfoDynArray = array of TLWPolsInfo;
TLWPntsInfoDynArray = array of TLWPntsInfo;
TLWPolsDynArray = TU2DynArray;
TLWPolyTagMapDynArray = TU2DynArray;
PLWPolyTagMap = ˆTLWPolyTagMap;
TLWVertexMapDynArray = array of TLWVertexMap;
TLWChunkClass = class of TLWChunk;
TLWChunkFind = procedure(AChunk: TLWChunk; Criteria: Pointer; var Found: boolean);
TLWContentNotify = procedure(Sender: TObject; var Content: string) of object;
TLWOReadCallback = procedure(Chunk: TLWChunkRec; Data: Pointer); cdecl;

Constants

ID_NULL = '#0#0#0#0';
ID_LWSC: TID4 = 'LWSC';
ID_FORM: TID4 = 'FORM';
ID_LWOB: TID4 = 'LWOB';
ID_LWLO: TID4 = 'LWLO';
ID_LAYR: TID4 = 'LAYR';
ID_PNTS: TID4 = 'PNTS';
ID_SRFS: TID4 = 'SRFS';
ID_POLS: TID4 = 'POLS';
ID_CRVS: TID4 = 'CRVS';
ID_PCHS: TID4 = 'PCHS';
ID_SURF: TID4 = 'SURF';
ID_COLR: TID4 = 'COLR';
ID_FLAG: TID4 = 'FLAG';
ID_LUMI: TID4 = 'LUMI';
ID_DIFF: TID4 = 'DIFF';
ID_SPEC: TID4 = 'SPEC';
ID_REFL: TID4 = 'REFL';
ID_TRAN: TID4 = 'TRAN';
ID_VLUM: TID4 = 'VLUM';
ID_VDIF: TID4 = 'VDIF';
ID_VSPC: TID4 = 'VSPC';
ID_VRFL: TID4 = 'VRFL';
ID_VTRN: TID4 = 'VTRN';
ID_GLOS: TID4 = 'GLOS';
ID_SIDE: TID4 = 'SIDE';
ID_RFLT: TID4 = 'RFLT';
ID_RFOP: TID4 = 'RFOP';
ID_RIMG: TID4 = 'RIMG';
ID_RSAN: TID4 = 'RSAN';
ID_RIND: TID4 = 'RIND';
ID_EDGE: TID4 = 'EDGE';
ID_SMAN: TID4 = 'SMAN';
ID_ALPH: TID4 = 'ALPH';
ID_CTEX: TID4 = 'CTEX';
ID_DTEX: TID4 = 'DTEX';
ID_STEX: TID4 = 'STEX';
ID_RTEX: TID4 = 'RTEX';
ID_TTEX: TID4 = 'TTEX';
ID_LTEX: TID4 = 'LTEX';
ID_BTEX: TID4 = 'BTEX';
ID_TFLG: TID4 = 'TFLG';
ID_TSIZ: TID4 = 'TSIZ';
ID_TCTR: TID4 = 'TCTR';
ID_TFAL: TID4 = 'TFAL';
ID_TVEL: TID4 = 'TVAL';
ID_TREF: TID4 = 'TREF';
ID_TCLR: TID4 = 'TCLR';
ID_TVAL: TID4 = 'TVAL';
ID_TAMP: TID4 = 'TAMP';
ID_TFP0: TID4 = 'TFP0';
ID_TFP1: TID4 = 'TFP1';
ID_TFP2: TID4 = 'TFP2';
ID_TIP0: TID4 = 'TIP0';
ID_TIP1: TID4 = 'TIP1';
ID_TIP2: TID4 = 'TIP2';
ID_TSP0: TID4 = 'TSP0';
ID_TSP1: TID4 = 'TSP1';
ID_TSP2: TID4 = 'TSP2';
ID_TFRQ: TID4 = 'TFRQ';
ID_TIMG: TID4 = 'TIMG';
ID_TALP: TID4 = 'TALP';
ID_TWRP: TID4 = 'TWRP';
ID_TAAS: TID4 = 'TAAS';
ID_TOPC: TID4 = 'TOPC';
ID_SHDR: TID4 = 'SHDR';
ID_SDAT: TID4 = 'SDAT';
ID_IMSQ: TID4 = 'IMSQ';
ID_FLYR: TID4 = 'FLYR';
ID_IMCC: TID4 = 'IMCC';
SURF_FLAG_LUMINOUS = 1;
SURF_FLAG_OUTLINE = 2;
SURF_FLAG_SMOOTHING = 4;
SURF_FLAG_COLORHIGHLIGHTS = 8;
SURF_FLAG_COLORFILTER = 16;
SURF_FLAG_OPAQUEEDGE = 32;
SURF_FLAG_TRANSPARENTEDGE = 64;
SURF_FLAG_SHARPTERMINATOR = 128;
SURF_FLAG_DOUBLESIDED = 256;
SURF_FLAG_ADDITIVE = 512;
SURF_FLAG_SHADOWALPHA = 1024;
CURV_CONTINUITY_FIRST = 1;
CURV_CONTINUITY_LAST = 2;
IMSQ_FLAG_LOOP = 1;
IMSQ_FLAG_INTERLACE = 2;
ID_LWO2: TID4 = 'LWO2';
ID_VMAP: TID4 = 'VMAP';
ID_TAGS: TID4 = 'TAGS';
ID_PTAG: TID4 = 'PTAG';
ID_VMAD: TID4 = 'VMAD';
ID_ENVL: TID4 = 'ENVL';
ID_CLIP: TID4 = 'CLIP';
ID_BBOX: TID4 = 'BBOX';
ID_DESC: TID4 = 'DESC';
ID_TEXT: TID4 = 'TEXT';
ID_ICON: TID4 = 'ICON';
ENVL_PRE: TID4 = 'PRE'#0;
ENVL_POST: TID4 = 'POST';
ENVL_KEY: TID4 = 'KEY'#0;
ENVL_SPAN: TID4 = 'SPAN';
ENVL_CHAN: TID4 = 'CHAN';
ENVL_NAME: TID4 = 'NAME';
ID_STIL: TID4 = 'STIL';
ID_ISEQ: TID4 = 'ISEQ';
ID_ANIM: TID4 = 'ANIM';
ID_STCC: TID4 = 'STCC';
ID_CONT: TID4 = 'CONT';
ID_BRIT: TID4 = 'BRIT';
ID_SATR: TID4 = 'SATR';
ID_HUE: TID4 = 'HUE'#0;
ID_GAMMA: TID4 = 'GAMM';
ID_NEGA: TID4 = 'NEGA';
ID_IFLT: TID4 = 'IFLT';
ID_PFLT: TID4 = 'PFLT';
POLS_TYPE_FACE: TID4 = 'FACE';
POLS_TYPE_CURV: TID4 = 'CURV';
POLS_TYPE_PTCH: TID4 = 'PTCH';
POLS_TYPE_MBAL: TID4 = 'MBAL';
POLS_TYPE_BONE: TID4 = 'BONE';
VMAP_TYPE_PICK: TID4 = 'PICK';
VMAP_TYPE_WGHT: TID4 = 'WGHT';
VMAP_TYPE_MNVW: TID4 = 'MNVW';
VMAP_TYPE_TXUV: TID4 = 'TXUV';
VMAP_TYPE_RGB: TID4 = 'RGB'#0;
VMAP_TYPE_RGBA: TID4 = 'RGBA';
VMAP_TYPE_MORF: TID4 = 'MORF';
VMAP_TYPE_SPOT: TID4 = 'SPOT';
PTAG_TYPE_SURF: TID4 = 'SURF';
PTAG_TYPE_PART: TID4 = 'PART';
PTAG_TYPE_SMGP: TID4 = 'SMGP';
PRE_POST_RESET = 0;
PRE_POST_CONSTANT = 1;
PRE_POST_REPEAT = 2;
PRE_POST_OSCILLATE = 3;
PRE_POST_OFFSET = 4;
PRE_POST_LINEAR = 5;
POLS_VCOUNT_MASK = $3FF;
POLS_FLAGS_MASK = $FC00;
SIDE_FRONT = 1;
SIDE_BACK = 2;
SIDE_FRONT_AND_BACK = SIDE_FRONT and SIDE_BACK;
RFOP_BACKDROP = 0;
RFOP_RAYTRACEANDBACKDROP = 1;
RFOP_SPHERICALMAP = 2;
RFOP_RAYTRACEANDSPHERICALMAP = 3;

Description

Functions and Procedures

procedure RegisterChunkClass(ChunkClass: TLWChunkClass);
function LoadLW0FromStream(Stream: TStream; ReadCallback: TLWOReadCallback; UserData: Pointer): LongWord; cdecl;
function LoadLWOFromFile(const AFilename: string; ReadCallback: TLWOReadCallback; UserData: Pointer): LongWord;
procedure ReadMotorolaNumber(Stream: TStream; Data: Pointer; ElementSize: Integer; Count: Integer = 1);
function WriteMotorolaNumber(Stream: TStream; Data: Pointer; ElementSize: Integer; Count: Integer = 1): Integer;
function ReadS0(Stream: TStream; out Str: string): Integer;
procedure WriteS0(Stream: TStream; Data: string);
procedure WriteU4AsVX(Stream:TStream; Data: Pointer; Count: Integer);
function ReadVXAsU4(Stream: TStream; Data: Pointer; Count: Integer = 1): Integer;
procedure ReverseByteOrder(ValueIn: Pointer; Size: Integer; Count: Integer = 1);
function ToDosPath(const Path: string): string;
function ToUnixPath(const Path: string): string;
function ID4ToInt(const Id: TID4): Integer;
procedure FindChunkById(AChunk: TLWChunk; Data: Pointer; var Found: boolean);
procedure FindSurfaceByName(AChunk: TLWChunk; AName: Pointer; var Found: boolean);
procedure FindSurfaceByTag(AChunk: TLWChunk; ATag: Pointer; var Found: boolean);
procedure FindVMapByName(AChunk: TLWChunk; AName: Pointer; var Found: boolean);
procedure FindClipByClipIndex(AChunk: TLWChunk; AIndex: Pointer; var Found: boolean);
function GetContentDir: TLWContentDir;

Types

TID4 = array[0..3] of AnsiChar;
PID4 = ˆTID4;
TID4DynArray = array of TID4;
TI1 = ShortInt;
PI1 = ˆTI1;
TI2 = SmallInt;
PI2 = ˆTI2;
TI4 = LongInt;
PI4 = ˆTI4;
TU1 = Byte;
PU1 = ˆTU1;
TU1DynArray = array of TU1;
TU2 = Word;
PU2 = ˆTU2;
TU2Array = array [0..65534] of TU2;
PU2Array = ˆTU2Array;
TU2DynArray = array of TU2;
TU4 = LongWord;
PU4 = ˆTU4;
TU4Array = array [0..65534] of TU4;
PU4Array = ˆTU4Array;
TU4DynArray = array of TU4;
TF4 = Single;
PF4 = ˆTF4;
TF4Array = array [0..65534] of TF4;
PF4Array = ˆTF4Array;
TF4DynArray = array of TF4;
TANG4 = TF4;
PANG4 = ˆTANG4;
TVec12 = array[0..2] of TF4;
PVec12 = ˆTVec12;
TVec12Array = array [0..65534] of TVec12;
PVec12Array = ˆTVec12Array;
TVec12DynArray = array of TVec12;
TColr12 = TVec12;
PColr12 = ˆTColr12;
TColr12DynArray = array of TColr12;
TColr4 = array[0..3] of TU1;
PColr4 = ˆTColr4;
PLWChunkRec = ˆTLWChunkRec;
PLWSubChunkRec = ˆTLWSubChunkRec;
TLWPolsInfoDynArray = array of TLWPolsInfo;
TLWPntsInfoDynArray = array of TLWPntsInfo;
TLWPolsDynArray = TU2DynArray;
TLWPolyTagMapDynArray = TU2DynArray;
PLWPolyTagMap = ˆTLWPolyTagMap;
TLWVertexMapDynArray = array of TLWVertexMap;
TLWChunkClass = class of TLWChunk;
TLWChunkFind = procedure(AChunk: TLWChunk; Criteria: Pointer; var Found: boolean);
TLWContentNotify = procedure(Sender: TObject; var Content: string) of object;
TLWOReadCallback = procedure(Chunk: TLWChunkRec; Data: Pointer); cdecl;

Constants

ID_NULL = '#0#0#0#0';
ID_LWSC: TID4 = 'LWSC';
ID_FORM: TID4 = 'FORM';
ID_LWOB: TID4 = 'LWOB';
ID_LWLO: TID4 = 'LWLO';
ID_LAYR: TID4 = 'LAYR';
ID_PNTS: TID4 = 'PNTS';
ID_SRFS: TID4 = 'SRFS';
ID_POLS: TID4 = 'POLS';
ID_CRVS: TID4 = 'CRVS';
ID_PCHS: TID4 = 'PCHS';
ID_SURF: TID4 = 'SURF';
ID_COLR: TID4 = 'COLR';
ID_FLAG: TID4 = 'FLAG';
ID_LUMI: TID4 = 'LUMI';
ID_DIFF: TID4 = 'DIFF';
ID_SPEC: TID4 = 'SPEC';
ID_REFL: TID4 = 'REFL';
ID_TRAN: TID4 = 'TRAN';
ID_VLUM: TID4 = 'VLUM';
ID_VDIF: TID4 = 'VDIF';
ID_VSPC: TID4 = 'VSPC';
ID_VRFL: TID4 = 'VRFL';
ID_VTRN: TID4 = 'VTRN';
ID_GLOS: TID4 = 'GLOS';
ID_SIDE: TID4 = 'SIDE';
ID_RFLT: TID4 = 'RFLT';
ID_RFOP: TID4 = 'RFOP';
ID_RIMG: TID4 = 'RIMG';
ID_RSAN: TID4 = 'RSAN';
ID_RIND: TID4 = 'RIND';
ID_EDGE: TID4 = 'EDGE';
ID_SMAN: TID4 = 'SMAN';
ID_ALPH: TID4 = 'ALPH';
ID_CTEX: TID4 = 'CTEX';
ID_DTEX: TID4 = 'DTEX';
ID_STEX: TID4 = 'STEX';
ID_RTEX: TID4 = 'RTEX';
ID_TTEX: TID4 = 'TTEX';
ID_LTEX: TID4 = 'LTEX';
ID_BTEX: TID4 = 'BTEX';
ID_TFLG: TID4 = 'TFLG';
ID_TSIZ: TID4 = 'TSIZ';
ID_TCTR: TID4 = 'TCTR';
ID_TFAL: TID4 = 'TFAL';
ID_TVEL: TID4 = 'TVAL';
ID_TREF: TID4 = 'TREF';
ID_TCLR: TID4 = 'TCLR';
ID_TVAL: TID4 = 'TVAL';
ID_TAMP: TID4 = 'TAMP';
ID_TFP0: TID4 = 'TFP0';
ID_TFP1: TID4 = 'TFP1';
ID_TFP2: TID4 = 'TFP2';
ID_TIP0: TID4 = 'TIP0';
ID_TIP1: TID4 = 'TIP1';
ID_TIP2: TID4 = 'TIP2';
ID_TSP0: TID4 = 'TSP0';
ID_TSP1: TID4 = 'TSP1';
ID_TSP2: TID4 = 'TSP2';
ID_TFRQ: TID4 = 'TFRQ';
ID_TIMG: TID4 = 'TIMG';
ID_TALP: TID4 = 'TALP';
ID_TWRP: TID4 = 'TWRP';
ID_TAAS: TID4 = 'TAAS';
ID_TOPC: TID4 = 'TOPC';
ID_SHDR: TID4 = 'SHDR';
ID_SDAT: TID4 = 'SDAT';
ID_IMSQ: TID4 = 'IMSQ';
ID_FLYR: TID4 = 'FLYR';
ID_IMCC: TID4 = 'IMCC';
SURF_FLAG_LUMINOUS = 1;
SURF_FLAG_OUTLINE = 2;
SURF_FLAG_SMOOTHING = 4;
SURF_FLAG_COLORHIGHLIGHTS = 8;
SURF_FLAG_COLORFILTER = 16;
SURF_FLAG_OPAQUEEDGE = 32;
SURF_FLAG_TRANSPARENTEDGE = 64;
SURF_FLAG_SHARPTERMINATOR = 128;
SURF_FLAG_DOUBLESIDED = 256;
SURF_FLAG_ADDITIVE = 512;
SURF_FLAG_SHADOWALPHA = 1024;
CURV_CONTINUITY_FIRST = 1;
CURV_CONTINUITY_LAST = 2;
IMSQ_FLAG_LOOP = 1;
IMSQ_FLAG_INTERLACE = 2;
ID_LWO2: TID4 = 'LWO2';
ID_VMAP: TID4 = 'VMAP';
ID_TAGS: TID4 = 'TAGS';
ID_PTAG: TID4 = 'PTAG';
ID_VMAD: TID4 = 'VMAD';
ID_ENVL: TID4 = 'ENVL';
ID_CLIP: TID4 = 'CLIP';
ID_BBOX: TID4 = 'BBOX';
ID_DESC: TID4 = 'DESC';
ID_TEXT: TID4 = 'TEXT';
ID_ICON: TID4 = 'ICON';
ENVL_PRE: TID4 = 'PRE'#0;
ENVL_POST: TID4 = 'POST';
ENVL_KEY: TID4 = 'KEY'#0;
ENVL_SPAN: TID4 = 'SPAN';
ENVL_CHAN: TID4 = 'CHAN';
ENVL_NAME: TID4 = 'NAME';
ID_STIL: TID4 = 'STIL';
ID_ISEQ: TID4 = 'ISEQ';
ID_ANIM: TID4 = 'ANIM';
ID_STCC: TID4 = 'STCC';
ID_CONT: TID4 = 'CONT';
ID_BRIT: TID4 = 'BRIT';
ID_SATR: TID4 = 'SATR';
ID_HUE: TID4 = 'HUE'#0;
ID_GAMMA: TID4 = 'GAMM';
ID_NEGA: TID4 = 'NEGA';
ID_IFLT: TID4 = 'IFLT';
ID_PFLT: TID4 = 'PFLT';
POLS_TYPE_FACE: TID4 = 'FACE';
POLS_TYPE_CURV: TID4 = 'CURV';
POLS_TYPE_PTCH: TID4 = 'PTCH';
POLS_TYPE_MBAL: TID4 = 'MBAL';
POLS_TYPE_BONE: TID4 = 'BONE';
VMAP_TYPE_PICK: TID4 = 'PICK';
VMAP_TYPE_WGHT: TID4 = 'WGHT';
VMAP_TYPE_MNVW: TID4 = 'MNVW';
VMAP_TYPE_TXUV: TID4 = 'TXUV';
VMAP_TYPE_RGB: TID4 = 'RGB'#0;
VMAP_TYPE_RGBA: TID4 = 'RGBA';
VMAP_TYPE_MORF: TID4 = 'MORF';
VMAP_TYPE_SPOT: TID4 = 'SPOT';
PTAG_TYPE_SURF: TID4 = 'SURF';
PTAG_TYPE_PART: TID4 = 'PART';
PTAG_TYPE_SMGP: TID4 = 'SMGP';
PRE_POST_RESET = 0;
PRE_POST_CONSTANT = 1;
PRE_POST_REPEAT = 2;
PRE_POST_OSCILLATE = 3;
PRE_POST_OFFSET = 4;
PRE_POST_LINEAR = 5;
POLS_VCOUNT_MASK = $3FF;
POLS_FLAGS_MASK = $FC00;
SIDE_FRONT = 1;
SIDE_BACK = 2;
SIDE_FRONT_AND_BACK = SIDE_FRONT and SIDE_BACK;
RFOP_BACKDROP = 0;
RFOP_RAYTRACEANDBACKDROP = 1;
RFOP_SPHERICALMAP = 2;
RFOP_RAYTRACEANDSPHERICALMAP = 3;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: record TLWChunkRec

record TLWChunkRec

Unit

LWObjects

Declaration

type TLWChunkRec = record

Description

Overview

Fields

id: TID4;
size: TU4;
data: Pointer;

Description

Fields

id: TID4;
size: TU4;
data: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: record TLWSubChunkRec

record TLWSubChunkRec

Unit

LWObjects

Declaration

type TLWSubChunkRec = record

Description

Overview

Fields

id: TID4;
size: TU2;
data: Pointer;

Description

Fields

id: TID4;
size: TU2;
data: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: record TLWPolsInfo

record TLWPolsInfo

Unit

LWObjects

Declaration

type TLWPolsInfo = record

Description

Overview

Fields

norm: TVec12;
vnorms: TVec12DynArray;
surfid: TU2;

Description

Fields

norm: TVec12;
vnorms: TVec12DynArray;
surfid: TU2;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: record TLWPntsInfo

record TLWPntsInfo

Unit

LWObjects

Declaration

type TLWPntsInfo = record

Description

Overview

Fields

npols: TU2;
pols: TU2DynArray;

Description

Fields

npols: TU2;
pols: TU2DynArray;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: record TLWPolyTagMap

record TLWPolyTagMap

Unit

LWObjects

Declaration

type TLWPolyTagMap = record

Description

Overview

Fields

poly: TU2;
tag: TU2;

Description

Fields

poly: TU2;
tag: TU2;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: record TLWVertexMap

record TLWVertexMap

Unit

LWObjects

Declaration

type TLWVertexMap = record

Description

Overview

Fields

vert: TU2;
values: TF4DynArray;

Description

Fields

vert: TU2;
values: TF4DynArray;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: Class TLWChunk

Class TLWChunk

Unit

LWObjects

Declaration

type TLWChunk = class(TPersistent)

Description

Hierarchy

  • TPersistent
  • TLWChunk

Overview

Methods

Public | destructor Destroy; override;
Public | class function GetID: TID4; virtual;
Public | procedure LoadFromStream(AStream: TStream); virtual;
Protected | procedure Clear; virtual;
Protected | procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); virtual;
Protected | procedure Loaded; virtual;

Properties

Public | property Data: Pointer read FData;
Public | property ID: TID4 read FID;
Public | property Index: Integer read GetIndex;
Public | property Owner: TLWChunkList read FOwner;
Public | property ParentChunk: TLWParentChunk read FParentChunk;
Public | property RootChunks: TLWChunkList read GetRootChunks;
Public | property Size: TU4 read FSize;

Description

Methods

Public destructor Destroy; override;
Public class function GetID: TID4; virtual;
Public procedure LoadFromStream(AStream: TStream); virtual;
Protected procedure Clear; virtual;
Protected procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); virtual;
Protected procedure Loaded; virtual;

Properties

Public property Data: Pointer read FData;
Public property ID: TID4 read FID;
Public property Index: Integer read GetIndex;
Public property Owner: TLWChunkList read FOwner;
Public property ParentChunk: TLWParentChunk read FParentChunk;
Public property RootChunks: TLWChunkList read GetRootChunks;
Public property Size: TU4 read FSize;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: Class TLWSubChunk

Class TLWSubChunk

Unit

LWObjects

Declaration

type TLWSubChunk = class(TLWChunk)

Description

no description available, TLWChunk description follows

Hierarchy

  • TPersistent
  • TLWChunk
  • TLWSubChunk

Overview

Methods

Public procedure LoadFromStream(AStream: TStream); override;

Description

Methods

Public procedure LoadFromStream(AStream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: Class TLWChunkList

Class TLWChunkList

Unit

LWObjects

Declaration

type TLWChunkList = class(TList)

Description

Hierarchy

  • TList
  • TLWChunkList

Overview

Methods

Public | constructor Create(AOwnsItems: boolean; AOwner: TObject);
Public | destructor Destroy; override;
Public | function Add(AChunk: TLWChunk): Integer;
Public | function FindChunk(ChunkFind: TLWChunkFind; Criteria: Pointer; StartIndex: Integer = 0): Integer;
Public | procedure Clear; override;
Public | procedure Delete(Index: Integer);
Protected | procedure Loaded; virtual;

Properties

Public | property Items[Index: Integer]: TLWChunk read GetItem;
Public | property Owner: TObject read FOwner;
Public | property OwnsItems: Boolean read FOwnsItems;

Description

Methods

Public constructor Create(AOwnsItems: boolean; AOwner: TObject);
Public destructor Destroy; override;
Public function Add(AChunk: TLWChunk): Integer;
Public function FindChunk(ChunkFind: TLWChunkFind; Criteria: Pointer; StartIndex: Integer = 0): Integer;
Public procedure Clear; override;
Public procedure Delete(Index: Integer);
Protected procedure Loaded; virtual;

Properties

Public property Items[Index: Integer]: TLWChunk read GetItem;
Public property Owner: TObject read FOwner;
Public property OwnsItems: Boolean read FOwnsItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: Class TLWParentChunk

Class TLWParentChunk

Unit

LWObjects

Declaration

type TLWParentChunk = class(TLWChunk)

Description

no description available, TLWChunk description follows

Hierarchy

  • TPersistent
  • TLWChunk
  • TLWParentChunk

Overview

Methods

Protected | function GetParamAddr(Param: TID4): Pointer; virtual;
Protected | procedure Clear; override;
Protected | procedure Loaded; override;

Properties

Public | property FloatParam[Param: TID4]: Single read GetFloatParam;
Public | property Items: TLWChunkList read GetItems;
Public | property LongParam[Param: TID4]: LongWord read GetLongParam;
Public | property ParamAddr[Param: TID4]: Pointer read GetParamAddr;
Public | property Vec3Param[Param: TID4]: TVec12 read GetVec3Param;
Public | property VXParam[Param: TID4]: Word read GetVXParam;
Public | property WordParam[Param: TID4]: Word read GetWordParam;

Description

Methods

Protected function GetParamAddr(Param: TID4): Pointer; virtual;
Protected procedure Clear; override;
Protected procedure Loaded; override;

Properties

Public property FloatParam[Param: TID4]: Single read GetFloatParam;
Public property Items: TLWChunkList read GetItems;
Public property LongParam[Param: TID4]: LongWord read GetLongParam;
Public property ParamAddr[Param: TID4]: Pointer read GetParamAddr;
Public property Vec3Param[Param: TID4]: TVec12 read GetVec3Param;
Public property VXParam[Param: TID4]: Word read GetVXParam;
Public property WordParam[Param: TID4]: Word read GetWordParam;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: Class TLWPnts

Class TLWPnts

Unit

LWObjects

Declaration

type TLWPnts = class(TLWParentChunk)

Description

no description available, TLWParentChunk description follows
no description available, TLWChunk description follows

Hierarchy

  • TPersistent
  • TLWChunk
  • TLWParentChunk
  • TLWPnts

Overview

Methods

Public | class function GetID: TID4; override;
Public | function GetVMap(VMapID: TID4; out VMap: TLWVMap): Boolean;
Protected | procedure Clear; override;
Protected | procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;

Properties

Public | property Pnts: TVEC12DynArray read FPnts;
Public | property PntsCount: LongWord read GetPntsCount;
Public | property PntsInfo: TLWPntsInfoDynArray read FPntsInfo;

Description

Methods

Public class function GetID: TID4; override;
Public function GetVMap(VMapID: TID4; out VMap: TLWVMap): Boolean;
Protected procedure Clear; override;
Protected procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;

Properties

Public property Pnts: TVEC12DynArray read FPnts;
Public property PntsCount: LongWord read GetPntsCount;
Public property PntsInfo: TLWPntsInfoDynArray read FPntsInfo;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: Class TLWPols

Class TLWPols

Unit

LWObjects

Declaration

type TLWPols = class(TLWParentChunk)

Description

no description available, TLWParentChunk description follows
no description available, TLWChunk description follows

Hierarchy

  • TPersistent
  • TLWChunk
  • TLWParentChunk
  • TLWPols

Overview

Methods

Public | class function GetID: TID4; override;
Public | function GetPolsByPntIdx(VertIdx: TU2; var VertPolys: TU2DynArray): Integer;
Protected | procedure Clear; override;
Protected | procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;
Protected | procedure Loaded; override;

Properties

Public | property IndiceCount: TU4 read GetIndiceCount;
Public | property Indices[AIndex: Integer]: TU2 read GetIndice;
Public | property PolsByIndex[AIndex: TU2]: Integer read GetPolsByIndex;
Public | property PolsCount: Integer read GetPolsCount;
Public | property PolsInfo: TLWPolsInfoDynArray read FPolsInfo;
Public | property PolsType: TID4 read FPolsType;

Description

Methods

Public class function GetID: TID4; override;
Public function GetPolsByPntIdx(VertIdx: TU2; var VertPolys: TU2DynArray): Integer;
Protected procedure Clear; override;
Protected procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;
Protected procedure Loaded; override;

Properties

Public property IndiceCount: TU4 read GetIndiceCount;
Public property Indices[AIndex: Integer]: TU2 read GetIndice;
Public property PolsByIndex[AIndex: TU2]: Integer read GetPolsByIndex;
Public property PolsCount: Integer read GetPolsCount;
Public property PolsInfo: TLWPolsInfoDynArray read FPolsInfo;
Public property PolsType: TID4 read FPolsType;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: Class TLWVMap

Class TLWVMap

Unit

LWObjects

Declaration

type TLWVMap = class(TLWChunk)

Description

no description available, TLWChunk description follows

Hierarchy

  • TPersistent
  • TLWChunk
  • TLWVMap

Overview

Methods

Public | class function GetID: TID4; override;
Protected | procedure Clear; override;
Protected | procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;

Properties

Public | property Dimensions: TU2 read FDimensions;
Public | property Name: string read FName;
Public | property Value[AIndex: TU2]: TLWVertexMap read GetValue;
Public | property ValueCount: Integer read GetValueCount;
Public | property VMapType: TID4 read FVMapType;

Description

Methods

Public class function GetID: TID4; override;
Protected procedure Clear; override;
Protected procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;

Properties

Public property Dimensions: TU2 read FDimensions;
Public property Name: string read FName;
Public property Value[AIndex: TU2]: TLWVertexMap read GetValue;
Public property ValueCount: Integer read GetValueCount;
Public property VMapType: TID4 read FVMapType;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: Class TLWTags

Class TLWTags

Unit

LWObjects

Declaration

type TLWTags = class(TLWChunk)

Description

no description available, TLWChunk description follows

Hierarchy

  • TPersistent
  • TLWChunk
  • TLWTags

Overview

Methods

Public | destructor Destroy; override;
Public | class function GetID: TID4; override;
Public | function TagToName(Tag: TU2): string;
Protected | procedure Clear; override;
Protected | procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;

Properties

Public property Tags: TStrings read GetTags;

Description

Methods

Public destructor Destroy; override;
Public class function GetID: TID4; override;
Public function TagToName(Tag: TU2): string;
Protected procedure Clear; override;
Protected procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;

Properties

Public property Tags: TStrings read GetTags;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: Class TLWSurf

Class TLWSurf

Unit

LWObjects

Declaration

type TLWSurf = class(TLWParentChunk)

Description

no description available, TLWParentChunk description follows
no description available, TLWChunk description follows

Hierarchy

  • TPersistent
  • TLWChunk
  • TLWParentChunk
  • TLWSurf

Overview

Methods

Public | destructor Destroy; override;
Public | class function GetID: TID4; override;
Protected | function GetParamAddr(Param: TID4): Pointer; override;
Protected | procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;

Properties

Public | property Name: string read FName;
Public | property Source: string read FSource;
Public | property SurfId: Integer read GetSurfId;

Description

Methods

Public destructor Destroy; override;
Public class function GetID: TID4; override;
Protected function GetParamAddr(Param: TID4): Pointer; override;
Protected procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;

Properties

Public property Name: string read FName;
Public property Source: string read FSource;
Public property SurfId: Integer read GetSurfId;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: Class TLWLayr

Class TLWLayr

Unit

LWObjects

Declaration

type TLWLayr = class(TLWParentChunk)

Description

no description available, TLWParentChunk description follows
no description available, TLWChunk description follows

Hierarchy

  • TPersistent
  • TLWChunk
  • TLWParentChunk
  • TLWLayr

Overview

Methods

Public | destructor Destroy; override;
Public | class function GetID: TID4; override;
Protected | procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;

Properties

Public | property Flags: TU2 read FFlags;
Public | property Name: string read FName;
Public | property Number: TU2 read FNumber;
Public | property Parent: TU2 read FParent;
Public | property Pivot: TVec12 read FPivot;

Description

Methods

Public destructor Destroy; override;
Public class function GetID: TID4; override;
Protected procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;

Properties

Public property Flags: TU2 read FFlags;
Public property Name: string read FName;
Public property Number: TU2 read FNumber;
Public property Parent: TU2 read FParent;
Public property Pivot: TVec12 read FPivot;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: Class TLWPTag

Class TLWPTag

Unit

LWObjects

Declaration

type TLWPTag = class(TLWChunk)

Description

no description available, TLWChunk description follows

Hierarchy

  • TPersistent
  • TLWChunk
  • TLWPTag

Overview

Methods

Public | constructor Create;
Public | class function GetID: TID4; override;
Public | function GetPolsByTag(Tag: TU2; var PolyIndices: TU2DynArray): Integer;
Protected | procedure Clear; override;
Protected | procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;

Properties

Public | property MapType: TID4 read FMapType;
Public | property TagCount: Integer read GetTagCount;
Public | property TagMapCount: Integer read GetTagMapCount;
Public | property TagMaps[AIndex: Integer]: TLWPolyTagMap read GetTagMaps;
Public | property Tags[AIndex: Integer]: TU2 read GetTag;

Description

Methods

Public constructor Create;
Public class function GetID: TID4; override;
Public function GetPolsByTag(Tag: TU2; var PolyIndices: TU2DynArray): Integer;
Protected procedure Clear; override;
Protected procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;

Properties

Public property MapType: TID4 read FMapType;
Public property TagCount: Integer read GetTagCount;
Public property TagMapCount: Integer read GetTagMapCount;
Public property TagMaps[AIndex: Integer]: TLWPolyTagMap read GetTagMaps;
Public property Tags[AIndex: Integer]: TU2 read GetTag;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: Class TLWObjectFile

Class TLWObjectFile

Unit

LWObjects

Declaration

type TLWObjectFile = class(TObject)

Description

Hierarchy

  • TObject
  • TLWObjectFile

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Public | function TagToName(Tag: TU2): string;
Public | procedure LoadFromFile(const AFilename: string);
Public | procedure LoadFromStream(AStream: TStream);

Properties

Public | property ChunkCount: Integer read GetCount;
Public | property Chunks: TLWChunkList read GetChunks;
Public | property FileName: string read FFileName;
Public | property SurfaceByName[Index: string]: TLWSurf read GetSurfaceByName;
Public | property SurfaceByTag[Index: TU2]: TLWSurf read GetSurfaceByTag;

Description

Methods

Public constructor Create;
Public destructor Destroy; override;
Public function TagToName(Tag: TU2): string;
Public procedure LoadFromFile(const AFilename: string);
Public procedure LoadFromStream(AStream: TStream);

Properties

Public property ChunkCount: Integer read GetCount;
Public property Chunks: TLWChunkList read GetChunks;
Public property FileName: string read FFileName;
Public property SurfaceByName[Index: string]: TLWSurf read GetSurfaceByName;
Public property SurfaceByTag[Index: TU2]: TLWSurf read GetSurfaceByTag;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: Class TLWClip

Class TLWClip

Unit

LWObjects

Declaration

type TLWClip = class(TLWParentChunk)

Description

no description available, TLWParentChunk description follows
no description available, TLWChunk description follows

Hierarchy

  • TPersistent
  • TLWChunk
  • TLWParentChunk
  • TLWClip

Overview

Methods

Public | class function GetID: TID4; override;
Protected | procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;

Properties

Public property ClipIndex: TU4 read FClipIndex;

Description

Methods

Public class function GetID: TID4; override;
Protected procedure LoadData(AStream: TStream; DataStart, DataSize: LongWord); override;

Properties

Public property ClipIndex: TU4 read FClipIndex;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: LWObjects: Class TLWContentDir

Class TLWContentDir

Unit

LWObjects

Declaration

type TLWContentDir = class(TObject)

Description

Hierarchy

  • TObject
  • TLWContentDir

Overview

Methods

Public | destructor Destroy; override;
Public | function FindContent(AFilename: string): string;

Properties

Public | property Root: string read FRoot write SetRoot;
Public | property SubDirs: TStrings read GetSubDirs write SetSubDirs;

Description

Methods

Public destructor Destroy; override;
Public function FindContent(AFilename: string): string;

Properties

Public property Root: string read FRoot write SetRoot;
Public property SubDirs: TStrings read GetSubDirs write SetSubDirs;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: MeshUtils

Unit MeshUtils

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

MeshUtils.<p>

General utilities for mesh manipulations.<p>

<b>History : </b><font size=-1><ul> <li>20/05/10 - Yar - Fixes for Linux x64 <li>26/02/10 - Yar - Added functions to work with adjacent triangles <li>30/03/07 - DaStr - Added $I GLScene.inc <li>29/07/03 - PVD - Fixed bug in RemapReferences limiting lists to 32768 items <li>29/07/03 - SG - Fixed small bug in ConvertStripToList (indexed vectors variant) <li>05/03/03 - EG - Added RemapIndicesToIndicesMap <li>20/01/03 - EG - Added UnifyTrianglesWinding <li>15/01/03 - EG - Added ConvertStripToList, ConvertIndexedListToList <li>13/01/03 - EG - Added InvertTrianglesWinding, BuildNonOrientedEdgesList, SubdivideTriangles <li>10/03/02 - EG - Added WeldVertices, RemapTrianglesIndices and IncreaseCoherency <li>04/11/01 - EG - Optimized RemapAndCleanupReferences and BuildNormals <li>02/11/01 - EG - BuildVectorCountOptimizedIndices three times faster, StripifyMesh slightly faster <li>18/08/01 - EG - Creation </ul></font>

Overview

Functions and Procedures

procedure ConvertStripToList(const strip : TAffineVectorList; list : TAffineVectorList); overload;
procedure ConvertStripToList(const strip : TIntegerList; list : TIntegerList); overload;
procedure ConvertStripToList(const strip : TAffineVectorList; const indices : TIntegerList; list : TAffineVectorList); overload;
function ConvertStripToList( const AindicesList: PLongWordArray; Count: LongWord; RestartIndex: LongWord): TLongWordList; overload;
function ConvertFansToList( const AindicesList: PLongWordArray; Count: LongWord; RestartIndex: LongWord): TLongWordList;
procedure ConvertIndexedListToList(const data : TAffineVectorList; const indices : TIntegerList; list : TAffineVectorList);
function BuildVectorCountOptimizedIndices(const vertices : TAffineVectorList; const normals : TAffineVectorList = nil; const texCoords : TAffineVectorList = nil) : TIntegerList;
procedure RemapReferences(reference : TAffineVectorList; const indices : TIntegerList); overload;
procedure RemapReferences(reference : TIntegerList; const indices : TIntegerList); overload;
procedure RemapAndCleanupReferences(reference : TAffineVectorList; indices : TIntegerList);
function RemapIndicesToIndicesMap(remapIndices : TIntegerList) : TIntegerList;
procedure RemapTrianglesIndices(indices, indicesMap : TIntegerList);
procedure RemapIndices(indices, indicesMap : TIntegerList);
procedure UnifyTrianglesWinding(indices : TIntegerList);
procedure InvertTrianglesWinding(indices : TIntegerList);
function BuildNormals(reference : TAffineVectorList; indices : TIntegerList) : TAffineVectorList;
function BuildNonOrientedEdgesList(triangleIndices : TIntegerList; triangleEdges : TIntegerList = nil; edgesTriangles : TIntegerList = nil) : TIntegerList;
procedure WeldVertices(vertices : TAffineVectorList; indicesMap : TIntegerList; weldRadius : Single);
function StripifyMesh(indices : TIntegerList; maxVertexIndex : Integer; agglomerateLoneTriangles : Boolean = False) : TPersistentObjectList;
procedure IncreaseCoherency(indices : TIntegerList; cacheSize : Integer);
procedure SubdivideTriangles(smoothFactor : Single; vertices : TAffineVectorList; triangleIndices : TIntegerList; normals : TAffineVectorList = nil; onSubdivideEdge : TSubdivideEdgeEvent = nil);
function MakeTriangleAdjacencyList( const AindicesList: PLongWordArray; Count: LongWord; const AVerticesList: PAffineVectorArray): TLongWordList;

Types

TSubdivideEdgeEvent = procedure (const idxA, idxB, newIdx : Integer); register;

Variables

vImprovedFixingOpenTriangleEdge: Boolean = False;
vEdgeInfoReserveSize: LongWord = 64;

Description

Functions and Procedures

procedure ConvertStripToList(const strip : TAffineVectorList; list : TAffineVectorList); overload;

Converts a triangle strips into a triangle list.<p> Vertices are added to list, based on the content of strip. Both non-indexed and indexed variants are available, the output is *always* non indexed.

procedure ConvertStripToList(const strip : TIntegerList; list : TIntegerList); overload;
procedure ConvertStripToList(const strip : TAffineVectorList; const indices : TIntegerList; list : TAffineVectorList); overload;
function ConvertStripToList( const AindicesList: PLongWordArray; Count: LongWord; RestartIndex: LongWord): TLongWordList; overload;
function ConvertFansToList( const AindicesList: PLongWordArray; Count: LongWord; RestartIndex: LongWord): TLongWordList;
procedure ConvertIndexedListToList(const data : TAffineVectorList; const indices : TIntegerList; list : TAffineVectorList);

Expands an indexed structure into a non-indexed structure.

function BuildVectorCountOptimizedIndices(const vertices : TAffineVectorList; const normals : TAffineVectorList = nil; const texCoords : TAffineVectorList = nil) : TIntegerList;

Builds a vector-count optimized indices list.<p> The returned list (to be freed by caller) contains an "optimized" indices list in which duplicates coordinates in the original vertices list are used only once (the first available duplicate in the list is used).<br> The vertices list is left untouched, to remap/cleanup, you may use the RemapAndCleanupReferences function.

procedure RemapReferences(reference : TAffineVectorList; const indices : TIntegerList); overload;

Alters a reference array and removes unused reference values.<p> This functions scans the reference list and removes all values that aren't referred in the indices list, the indices list is *not* remapped.

procedure RemapReferences(reference : TIntegerList; const indices : TIntegerList); overload;
procedure RemapAndCleanupReferences(reference : TAffineVectorList; indices : TIntegerList);

Alters a reference/indice pair and removes unused reference values.<p> This functions scans the reference list and removes all values that aren't referred in the indices list, and the indices list is remapped so as to remain coherent.

function RemapIndicesToIndicesMap(remapIndices : TIntegerList) : TIntegerList;

Creates an indices map from a remap list.<p> The remap list is what BuildVectorCountOptimizedIndices, a list of indices to distinct/unique items, the indices map contains the indices of these items after a remap and cleanup of the set referred by remapIndices... Clear?<br> In short it takes the output of BuildVectorCountOptimizedIndices and can change it to something suitable for RemapTrianglesIndices.<br> Any simpler documentation of this function welcome ;)

procedure RemapTrianglesIndices(indices, indicesMap : TIntegerList);

Remaps a list of triangles vertex indices and remove degenerate triangles.<p> The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]

procedure RemapIndices(indices, indicesMap : TIntegerList);

Remaps a list of indices.<p> The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]

procedure UnifyTrianglesWinding(indices : TIntegerList);

Attempts to unify triangle winding.<p> Depending on topology, this may or may not be successful (some topologies can't be unified, f.i. those that have duplicate triangles, those that have edges shared by more than two triangles, those that have unconnected submeshes etc.)

procedure InvertTrianglesWinding(indices : TIntegerList);

Inverts the triangles winding (vertex order).

function BuildNormals(reference : TAffineVectorList; indices : TIntegerList) : TAffineVectorList;

Builds normals for a triangles list.<p> Builds one normal per reference vertex (may be NullVector is reference isn't used), which is the averaged for normals of all adjacent triangles.<p> Returned list must be freed by caller.

function BuildNonOrientedEdgesList(triangleIndices : TIntegerList; triangleEdges : TIntegerList = nil; edgesTriangles : TIntegerList = nil) : TIntegerList;

Builds a list of non-oriented (non duplicated) edges list.<p> Each edge is represented by the two integers of its vertices, sorted in ascending order.<br> If not nil, triangleEdges is filled with the 3 indices of the 3 edges of the triangle, the edges ordering respecting the original triangle orientation.

procedure WeldVertices(vertices : TAffineVectorList; indicesMap : TIntegerList; weldRadius : Single);

Welds all vertices separated by a distance inferior to weldRadius.<p> Any two vertices whose distance is inferior to weldRadius will be merged (ie. one of them will be removed, and the other replaced by the barycenter).<p> The indicesMap is constructed to allow remapping of indices lists with the simple rule: newVertexIndex:=indicesMap[oldVertexIndex].<p> The logic is protected from chain welding, and only vertices that were initially closer than weldRadius will be welded in the same resulting vertex.<p> This procedure can be used for mesh simplification, but preferably at design-time for it is not optimized for speed. This is more a "fixing" utility for meshes exported from high-polycount CAD tools (to remove duplicate vertices, quantification errors, etc.)

function StripifyMesh(indices : TIntegerList; maxVertexIndex : Integer; agglomerateLoneTriangles : Boolean = False) : TPersistentObjectList;

Attempts to create as few as possible triangle strips to cover the mesh.<p> The indices parameters define a set of triangles as a set of indices to vertices in a vertex pool, free of duplicate vertices (or resulting stripification will be of lower quality).<br> The function returns a list of TIntegerList, each of these lists hosting a triangle strip, returned objects must be freed by caller.<br> If agglomerateLoneTriangles is True, the first of the lists actually contains the agglomerated list of the triangles that couldn't be stripified.

procedure IncreaseCoherency(indices : TIntegerList; cacheSize : Integer);

Increases indices coherency wrt vertex caches.<p> The indices parameters is understood as vertex indices of a triangles set, the triangles are reordered to maximize coherency (vertex reuse) over the cacheSize latest indices. This allows higher rendering performance from hardware renderers that implement vertex cache (nVidia GeForce family f.i.), allowing reuse of T&amp;L performance (similar to stripification without the normals issues of strips).<p> This procedure performs a coherency optimization via a greedy hill-climber algorithm (ie. not optimal but fast).

procedure SubdivideTriangles(smoothFactor : Single; vertices : TAffineVectorList; triangleIndices : TIntegerList; normals : TAffineVectorList = nil; onSubdivideEdge : TSubdivideEdgeEvent = nil);

Subdivides mesh triangles.<p> Splits along edges, each triangle becomes four. The smoothFactor can be used to control subdivision smoothing, zero means no smoothing (tesselation only), while 1 means "sphere" subdivision (a low res sphere will be subdivided in a higher-res sphere), values outside of the [0..1] range are for, er, artistic purposes.<p> The procedure is not intended for real-time use.

function MakeTriangleAdjacencyList( const AindicesList: PLongWordArray; Count: LongWord; const AVerticesList: PAffineVectorArray): TLongWordList;

Create list of indices of triangles with adjacency from triangle list

Types

TSubdivideEdgeEvent = procedure (const idxA, idxB, newIdx : Integer); register;

Variables

vImprovedFixingOpenTriangleEdge: Boolean = False;
vEdgeInfoReserveSize: LongWord = 64;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:17


GLScene v.1.1.2: NewtonImport

Unit NewtonImport

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TNewtonBoxParam |
packed record TNewtonSphereParam |
packed record TNewtonCylinderParam |
packed record TNewtonCapsuleParam |
packed record TNewtonConeParam |
packed record TNewtonChamferCylinderParam |
packed record TNewtonConvexHullParam |
packed record TNewtonConvexHullModifierParam |
packed record TNewtonCompoundCollisionParam |
packed record TNewtonCollisionTreeParam |
packed record TNewtonHeightFieldCollisionParam |
packed record TNewtonSceneCollisionParam |
packed record TNewtonCollisionNullParam |
packed record TNewtonCollisionInfoRecord |
record NewtonJointRecord |
record NewtonUserMeshCollisionCollideDesc |
record NewtonWorldConvexCastReturnInfo |
record NewtonUserMeshCollisionRayHitDesc |
record NewtonHingeSliderUpdateDesc |

Functions and Procedures

function NewtonWorldGetVersion( const newtonWorld : PNewtonWorld) : int; cdecl; external NewtonDLL;
function NewtonWorldFloatSize( const newtonWorld : PNewtonWorld) : int; cdecl; external NewtonDLL;
function NewtonCreate( malloc : NewtonAllocMemory; mfree : NewtonFreeMemory ) : PNewtonWorld; cdecl; external NewtonDLL;
procedure NewtonDestroy( const newtonWorld : PNewtonWorld ); cdecl; external NewtonDLL;
procedure NewtonDestroyAllBodies( const newtonWorld : PNewtonWorld ); cdecl; external NewtonDLL;
function NewtonGetMemoryUsed() : int; cdecl; external NewtonDLL;
procedure NewtonSetMemorySystem( malloc : NewtonAllocMemory; mfree : NewtonFreeMemory ); cdecl; external NewtonDLL;
procedure NewtonUpdate( const newtonWorld : PNewtonWorld; timestep : float ); cdecl; external NewtonDLL;
procedure NewtonInvalidateCache( const newtonWorld : PNewtonWorld); cdecl; external NewtonDLL;
procedure NewtonCollisionUpdate( const newtonWorld : PNewtonWorld); cdecl; external NewtonDLL;
procedure NewtonSetSolverModel(const NewtonWorld : PNewtonWorld; Model : Int); cdecl; external NewtonDLL;
procedure NewtonSetPlatformArchitecture (const newtonWorld : PNewtonWorld; mode : Int); cdecl; external NewtonDLL;
function NewtonGetPlatformArchitecture (const newtonWorld : PNewtonWorld; description : PCharArray) : int; cdecl; external NewtonDLL;
procedure NewtonSetMultiThreadSolverOnSingleIsland (const newtonWorld : PNewtonWorld; mode : Int); cdecl; external NewtonDLL;
function NewtonGetMultiThreadSolverOnSingleIsland (const newtonWorld : PNewtonWorld) : int; cdecl; external NewtonDLL;
procedure NewtonSetPerformanceClock (const newtonWorld : PNewtonWorld; NewtonGetTicksCountCallback : PNewtonGetTicksCountCallback); cdecl; external NewtonDLL;
function NewtonReadPerformanceTicks (const newtonWorld : PNewtonWorld; performanceEntry : cardinal) : cardinal; cdecl; external NewtonDLL;
function NewtonReadThreadPerformanceTicks (const NewtonWorld : PNewtonWorld; ThreadIndex: Cardinal) : Cardinal; cdecl; external NewtonDLL;
procedure NewtonWorldCriticalSectionLock (const newtonWorld : PNewtonWorld); cdecl; external NewtonDLL;
procedure NewtonWorldCriticalSectionUnlock (const newtonWorld : PNewtonWorld); cdecl; external NewtonDLL;
procedure NewtonSetThreadsCount (const newtonWorld : PNewtonWorld; threads : int); cdecl; external NewtonDLL;
function NewtonGetThreadsCount (const newtonWorld : PNewtonWorld) : int; cdecl; external NewtonDLL;
function NewtonGetMaxThreadsCount (const NewtonWorld : PNewtonWorld) : int; cdecl; external NewtonDLL;
procedure NewtonSetFrictionModel(const NewtonWorld : PNewtonWorld; Model : Int); cdecl; external NewtonDLL;
procedure NewtonSetMinimumFrameRate( const newtonWorld : PNewtonWorld; frameRate : float ); cdecl; external NewtonDLL;
procedure NewtonSetBodyLeaveWorldEvent( const newtonWorld : PNewtonWorld; callback : PNewtonBodyLeaveWorld ); cdecl; external NewtonDLL;
procedure NewtonSetWorldSize( const newtonWorld : PNewtonWorld; const minPoint : PFloat; const maxPoint : PFloat ); cdecl; external NewtonDLL;
procedure NewtonSetIslandUpdateEvent( const newtonWorld : PNewtonWorld; NewtonIslandUpdate : PNewtonIslandUpdate ); cdecl; external NewtonDLL;
procedure NewtonSetCollisionDestructor( const newtonWorld : PNewtonWorld; callback : PNewtonCollisionDestructor ); cdecl; external NewtonDLL;
procedure NewtonSetDestroyBodyByExeciveForce( const newtonWorld : PNewtonWorld; callback : PNewtonDestroyBodyByExeciveForce ); cdecl; external NewtonDLL;
procedure NewtonWorldForEachJointDo (const newtonWorld : PNewtonWorld; callback : PNewtonJointIterator; userData : Pointer); cdecl; external NewtonDLL;
procedure NewtonWorldForEachBodyInAABBDo (const newtonWorld : PNewtonWorld; const p0 : PFloat; const p1 : PFloat; callback : PNewtonBodyIterator; userData : Pointer); cdecl; external NewtonDLL;
procedure NewtonWorldSetUserData( const newtonWorld : PNewtonWorld; userData : Pointer); cdecl; external NewtonDLL;
function NewtonWorldGetUserData( const newtonWorld : PNewtonWorld) : Pointer; cdecl; external NewtonDLL;
procedure NewtonWorldSetDestructorCallBack( const newtonWorld : PNewtonWorld; NewtonDestroyWorld : PNewtonDestroyWorld); cdecl; external NewtonDLL;
function NewtonWorldGetDestructorCallBack( const newtonWorld : PNewtonWorld) : PNewtonDestroyWorld; cdecl; external NewtonDLL;
procedure NewtonWorldRayCast( const newtonWorld : PNewtonWorld; const p0 : PFloat; const p1 : PFloat; filter : PNewtonWorldRayFilterCallback; userData: Pointer; prefilter : NewtonWorldRayPrefilterCallback); cdecl; external NewtonDLL;
function NewtonWorldConvexCast( const newtonWorld : PNewtonWorld; const matrix : PFloat; const target : PFloat; const shape : PNewtonCollision; hitParam : PFloat; userData: Pointer; prefilter : NewtonWorldRayPrefilterCallback; info : PNewtonWorldConvexCastReturnInfo; maxContactsCount : int; threadIndex : int) : Int; cdecl; external NewtonDLL;
function NewtonWorldGetBodyCount( const newtonWorld : PNewtonWorld) : int; cdecl; external NewtonDLL;
function NewtonWorldGetConstraintCount( const newtonWorld : PNewtonWorld) : int; cdecl; external NewtonDLL;
function NewtonIslandGetBody( const island : Pointer; bodyIndex : int) : PNewtonBody; cdecl; external NewtonDLL;
procedure NewtonIslandGetBodyAABB( const island : Pointer; bodyIndex : int; p0 : PFloat; p1 : PFloat); cdecl; external NewtonDLL;
function NewtonMaterialCreateGroupID( const newtonWorld : PNewtonWorld ) : int; cdecl; external NewtonDLL;
function NewtonMaterialGetDefaultGroupID( const newtonWorld : PNewtonWorld ) : int; cdecl; external NewtonDLL;
procedure NewtonMaterialDestroyAllGroupID( const newtonWorld : PNewtonWorld ); cdecl; external NewtonDLL;
function NewtonMaterialGetUserData( const NewtonWorld: PNewtonWorld; id0: int; id1: int): Pointer; cdecl; external NewtonDLL;
procedure NewtonMaterialSetSurfaceThickness( const newtonWorld : PNewtonWorld; id0 : int; id1 : int; thickness : Float); cdecl; external NewtonDLL;
procedure NewtonMaterialSetContinuousCollisionMode (const newtonWorld : PNewtonWOrld; id0, id1, state : int); cdecl; external NewtonDLL;
procedure NewtonMaterialSetCollisionCallback( const newtonWorld : PNewtonWorld; id0 : int; id1 : int; userData : Pointer; AABBOverlap : PNewtonOnAABBOverlap; process : PNewtonContactsProcess ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetDefaultSoftness( const newtonWorld : PNewtonWorld; id0 : int; id1 : int; value : float ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetDefaultElasticity( const newtonWorld : PNewtonWorld; id0 : int; id1 : int; elasticCoef : float ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetDefaultCollidable( const newtonWorld : PNewtonWorld; id0 : int; id1 : int; state : int ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetDefaultFriction( const newtonWorld : PNewtonWorld; id0 : int; id1 : int; staticFriction : float; kineticFriction : float ); cdecl; external NewtonDLL;
function NewtonWorldGetFirstMaterial( const NewtonWorld: PNewtonWorld): PNewtonMaterial; cdecl; external NewtonDLL;
function NewtonWorldGetNextMaterial( const NewtonWorld: PNewtonWorld; const material : PNewtonMaterial): PNewtonMaterial; cdecl; external NewtonDLL;
function NewtonWorldGetFirstBody( const NewtonWorld: PNewtonWorld): PNewtonBody; cdecl; external NewtonDLL;
function NewtonWorldGetNextBody( const NewtonWorld: PNewtonWorld; const curBody : PNewtonBody): PNewtonBody; cdecl; external NewtonDLL;
function NewtonMaterialGetMaterialPairUserData( const material : PNewtonMaterial) : Pointer; cdecl; external NewtonDLL;
function NewtonMaterialGetContactFaceAttribute( const material : PNewtonMaterial) : Unsigned_int; cdecl; external NewtonDLL;
function NewtonMaterialGetBodyCollisionID( const material : PNewtonMaterial; body : PNewtonBody) : Unsigned_int; cdecl; external NewtonDLL;
function NewtonMaterialGetContactNormalSpeed( const material : PNewtonMaterial ) : float; cdecl; external NewtonDLL;
procedure NewtonMaterialGetContactForce(const Material : PNewtonMaterial; const Body : PNEwtonBody; Force : PFloat); cdecl; external NewtonDLL;
procedure NewtonMaterialGetContactPositionAndNormal(const Material : PNewtonMaterial; const Body : PNewtonBody; const Posit, Normal : PFloat); cdecl; external NewtonDLL;
procedure NewtonMaterialGetContactTangentDirections(const Material : PNewtonMaterial; const Body : PNewtonBody; const Dir0, Dir1 : PFloat); cdecl; external NewtonDLL;
function NewtonMaterialGetContactTangentSpeed( const material : PNewtonMaterial; index : int ) : float; cdecl; external NewtonDLL;
procedure NewtonMaterialSetContactSoftness( const material : PNewtonMaterial; softness : float ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetContactElasticity( const material : PNewtonMaterial; restitution : float ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetContactFrictionState( const material : PNewtonMaterial; state : int; index : int ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetContactFrictionCoef( const material : PNewtonMaterial; staticFrictionCoef,kineticFrictionCoef : float; index : int ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetContactNormalAcceleration (const material : PNewtonMaterial; accel : float); cdecl; external NewtonDLL;
procedure NewtonMaterialSetContactNormalDirection(const material : PNewtonMaterial; directionVector : PFloat); cdecl; external NewtonDLL;
procedure NewtonMaterialSetContactTangentAcceleration( const material : PNewtonMaterial; accel : float; index : int ); cdecl; external NewtonDLL;
procedure NewtonMaterialContactRotateTangentDirections( const material : PNewtonMaterial; const directionVector : PFloat ); cdecl; external NewtonDLL;
function NewtonCreateNull( const newtonWorld : PNewtonWorld) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateSphere( const newtonWorld : PNewtonWorld; radiusX, radiusY, radiusZ : float; shapeID : int; const offsetMatrix : PFloat ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateBox( const newtonWorld : PNewtonWorld; dx : float; dy : float; dz : float; shapeID : int; const offsetMatrix : PFloat ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateCone( const newtonWorld : PNewtonWorld; radius : Float; height : Float; shapeID : int; const offsetMatrix : PFloat) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateCapsule( const newtonWorld : PNewtonWorld; radius : Float; height : Float; shapeID : int; const offsetMatrix : PFloat) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateCylinder( const newtonWorld : PNewtonWorld; radius : Float; height : Float; shapeID : int; const offsetMatrix : PFloat) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateChamferCylinder( const newtonWorld : PNewtonWorld; raduis : Float; height : Float; shapeID : int; const offsetMatrix : PFloat) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateConvexHull( const newtonWorld : PNewtonWorld; count : int; const vertexCloud : PFloat; strideInBytes : int; tolerance : float; shapeID : int; const offsetMatrix : PFloat) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateConvexHullFromMesh( const newtonWorld : PNewtonWorld; mesh : PNewtonMesh; tolerance : Float; shapeID : int ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateConvexHullModifier( const newtonWorld : PNewtonWorld; const convexHullCollision : PNewtonCollision; shapeID : int): PNewtonCollision; cdecl; external NewtonDLL;
procedure NewtonConvexHullModifierGetMatrix(const convexHullCollision : PNewtonCollision; matrix : PFloat); cdecl; external NewtonDLL;
procedure NewtonConvexHullModifierSetMatrix(const convexHullCollision : PNewtonCollision; const matrix : PFloat); cdecl; external NewtonDLL;
function NewtonCollisionIsTriggerVolume( const convexCollision : PNewtonCollision): int; cdecl; external NewtonDLL;
procedure NewtonCollisionSetAsTriggerVolume( const convexCollision : PNewtonCollision; trigger : int ); cdecl; external NewtonDLL;
procedure NewtonCollisionSetMaxBreakImpactImpulse( const convexHullCollision : PNewtonCollision; maxImpactImpulse : Float ); cdecl; external NewtonDLL;
function NewtonCollisionGetMaxBreakImpactImpulse( const convexHullCollision : PNewtonCollision) : Float; cdecl; external NewtonDLL;
procedure NewtonCollisionSetUserID( const convexCollision : PNewtonCollision; id : unsigned_int ); cdecl; external NewtonDLL;
function NewtonCollisionGetUserID( const convexCollision : PNewtonCollision) : unsigned_int; cdecl; external NewtonDLL;
function NewtonConvexHullGetFaceIndices( const convexHullCollision : PNewtonCollision; face : int; faceIndices : PInt) : int; cdecl; external NewtonDLL;
function NewtonConvexCollisionCalculateVolume(const convexCollision : PNewtonCollision) : Float; cdecl; external NewtonDLL;
procedure NewtonConvexCollisionCalculateInertialMatrix (const convexCollision : PNewtonCollision; inertia, origin : PFloat); cdecl; external NewtonDLL;
procedure NewtonCollisionMakeUnique (const newtonWorld : PNewtonWorld; const collision : PNewtonCollision); cdecl; external NewtonDLL;
procedure NewtonReleaseCollision( const newtonWorld : PNewtonWorld; const collision : PNewtonCollision ); cdecl; external NewtonDLL;
function NewtonAddCollisionReference( const Collision : PNewtonCollision): int; cdecl; external NewtonDLL;
function NewtonCreateCompoundCollision( const newtonWorld : PNewtonWorld; count : int; const collisionPrimitiveArray : TcollisionPrimitiveArray; shapeID : Int ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateCompoundCollisionFromMesh( const newtonWorld : PNewtonWorld; const mesh : PNewtonMesh; maxSubShapesCount : int; shapeID : Int; subShapeID : int ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateUserMeshCollision( const newtonWorld : PNewtonWorld; const minBox : PFloat; const maxBox : PFloat; userData : Pointer; collideCallback : NewtonUserMeshCollisionCollideCallback; rayHitCallback : NewtonUserMeshCollisionRayHitCallback; destroyCallback : NewtonUserMeshCollisionDestroyCallback; getInfoCallback : NewtonUserMeshCollisionGetCollisionInfo; facesInAABBCallback : NewtonUserMeshCollisionGetFacesInAABB; shapeID : Int ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateTreeCollisionFromMesh (const NewtonWorld : PNewtonWorld; const Mesh : PNewtonMesh; ShapeID : Int) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateSceneCollision( const newtonWorld : PNewtonWorld; shapeID : Int ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonSceneCollisionCreateProxy( scene : PNewtonCollision; collision : PNewtonCollision ) : PNewtonSceneProxy; cdecl; external NewtonDLL;
procedure NewtonSceneCollisionDestroyProxy( scene : PNewtonCollision; Proxy : PNewtonSceneProxy ); cdecl; external NewtonDLL;
procedure NewtonSceneProxySetMatrix( Proxy : PNewtonSceneProxy; const Matrix : PFloat ); cdecl; external NewtonDLL;
procedure NewtonSceneProxyGetMatrix( Proxy : PNewtonSceneProxy; Matrix : PFloat ); cdecl; external NewtonDLL;
procedure NewtonSceneSetProxyUserData(const Proxy : PNewtonSceneProxy; UserData : Pointer); cdecl; external NewtonDLL;
function NewtonSceneGetProxyUserData(const Proxy : PNewtonSceneProxy) : Pointer; cdecl; external NewtonDLL;
function NewtonSceneGetFirstProxy(const Scene : PNewtonCollision ) : PNewtonSceneProxy; cdecl; external NewtonDLL;
function NewtonSceneGetNextProxy(const Scene : PNewtonCollision; const Proxy : PNewtonSceneProxy ) : PNewtonSceneProxy; cdecl; external NewtonDLL;
procedure NewtonSceneCollisionOptimize( scene : PNewtonCollision ); cdecl; external NewtonDLL;
function NewtonCreateCompoundBreakable( const NewtonWorld : PNewtonWorld; meshCount : int; const SolidsArray : PNewtonMesh; const ShapeIDArray : PInt; Densities : PFloat; internalFaceMaterial : PInt; ShapeID : Int; debrisID : Int; DebrisSeparationGap : Float ) : PNewtonCollision; cdecl; external NewtonDLL;
procedure NewtonCompoundBreakableResetAnchoredPieces( const compoundBreakable : PNewtonCollision ); cdecl; external NewtonDLL;
procedure NewtonCompoundBreakableSetAnchoredPieces( const compoundBreakable : PNewtonCollision; fixshapesCount : Int; matrixPallete : PFloat; fixedShapesArray : PNewtonCollision ); cdecl; external NewtonDLL;
function NewtonCompoundBreakableGetVertexCount( const compoundBreakable : PNewtonCollision ) : Int; cdecl; external NewtonDLL;
procedure NewtonCompoundBreakableGetVertexStreams( const compoundBreakable : PNewtonCollision; vertexStrideInByte : Int; Vertex : PFloat; normalStrideInByte : Int; normal : PFloat; uvStrideInByte : Int; uv : PFloat ); cdecl; external NewtonDLL;
function NewtonBreakableGetMainMesh( const compoundBreakable : PNewtonCollision ) : PNewtonBreakableComponentMesh; cdecl; external NewtonDLL;
function NewtonBreakableGetFirstComponent( const compoundBreakable : PNewtonCollision ) : PNewtonBreakableComponentMesh; cdecl; external NewtonDLL;
function NewtonBreakableGetNextComponent( const component : PNewtonBreakableComponentMesh ) : PNewtonBreakableComponentMesh; cdecl; external NewtonDLL;
procedure NewtonBreakableBeginDelete( const compoundBreakable : PNewtonCollision ); cdecl; external NewtonDLL;
function NewtonBreakableCreateDebrieBody( const compoundBreakable : PNewtonCollision; const component : PNewtonBreakableComponentMesh ) : PNewtonBody; cdecl; external NewtonDLL;
procedure NewtonBreakableDeleteComponent( const compoundBreakable : PNewtonCollision; const component : PNewtonBreakableComponentMesh ); cdecl; external NewtonDLL;
procedure NewtonBreakableEndDelete( const compoundBreakable : PNewtonCollision ); cdecl; external NewtonDLL;
function NewtonBreakableGetComponentsInRadius( const compoundBreakable : PNewtonCollision; const position : PFloat; radius : Float; Segments : PNewtonBreakableComponentMesh; maxCount : Int ) : Int; cdecl; external NewtonDLL;
function NewtonBreakableGetFirstSegment( const BreakableComponent : PNewtonBreakableComponentMesh ) : Pointer; cdecl; external NewtonDLL;
function NewtonBreakableGetNextSegment( const Segment : Pointer ) : Pointer; cdecl; external NewtonDLL;
function NewtonBreakableSegmentGetMaterial( const Segment : Pointer ) : Int; cdecl; external NewtonDLL;
function NewtonBreakableSegmentGetIndexCount( const Segment : Pointer ) : Int; cdecl; external NewtonDLL;
function NewtonBreakableSegmentGetIndexStream( CompoundBreakable : PNewtonCollision; const MeshOwner : PNewtonBreakableComponentMesh; const Segment : Pointer; Index : PInt ) : Int; cdecl; external NewtonDLL;
function NewtonBreakableSegmentGetIndexStreamShort( CompoundBreakable : PNewtonCollision; const MeshOwner : PNewtonBreakableComponentMesh; const Segment : Pointer; Index : PShort ) : Int; cdecl; external NewtonDLL;
function NewtonCreateCollisionFromSerialization( const newtonWorld : PNewtonWorld; deserializeFunction : PNewtonDeserialize; serializeHandle : Pointer ) : PNewtonCollision; cdecl; external NewtonDLL;
procedure NewtonCollisionSerialize( const newtonWorld : PNewtonWorld; const collision : PNewtonCollision; serializeFunction : PNewtonSerialize; serializeHandle : Pointer ); cdecl; external NewtonDLL;
procedure NewtonCollisionGetInfo( const collision : PNewtonCollision; collisionInfo : PNewtonCollisionInfoRecord); cdecl; external NewtonDLL;
function NewtonCreateHeightFieldCollision( const newtonWorld : PNewtonWorld; width, height, gridDiagonals : int; elevationMap : PUnsigned_short; attributeMap : P2Char; horizontalScale,verticalScale : Float; shapeID : Int) : PNewtonCollision; cdecl; external NewtonDLL;
procedure NewtonHeightFieldSetUserRayCastCallback (const TreeCollision : PNewtonCollision; RayHitCallBack : PNewtonHeightFieldRayCastCallback); cdecl; external NewtonDLL;
function NewtonCreateTreeCollision( const newtonWorld : PNewtonWorld; shapeID : Int ) : PNewtonCollision; cdecl; external NewtonDLL;
procedure NewtonTreeCollisionSetUserRayCastCallback( const treeCollision : PNewtonCollision; rayHitCallback : PNewtonCollisionTreeRayCastCallback ); cdecl; external NewtonDLL;
procedure NewtonTreeCollisionBeginBuild( const treeCollision : PNewtonCollision ); cdecl; external NewtonDLL;
procedure NewtonTreeCollisionAddFace( const treeCollision : PNewtonCollision; vertexCount : int; const vertexPtr : PFloat; strideInBytes : int; faceAttribute : int ); cdecl; external NewtonDLL;
procedure NewtonTreeCollisionEndBuild( const treeCollision : PNewtonCollision; optimize : int ); cdecl; external NewtonDLL;
function NewtonTreeCollisionGetFaceAtribute( const treeCollision : PNewtonCollision; const faceIndexArray : Pint ) : int; cdecl; external NewtonDLL;
procedure NewtonTreeCollisionSetFaceAtribute( const treeCollision : PNewtonCollision; const faceIndexArray : Pint; attribute : int ); cdecl; external NewtonDLL;
function NewtonTreeCollisionGetVertexListIndexListInAABB( const treeCollision : PNewtonCollision; const p0, p1 : PFloat; const vertexArray : PFloat; vertexCount,vertexStrideInBytes : PInt; const indexList : PInt; maxIndexCount : Int; const faceAttribute : PInt ) : int; cdecl; external NewtonDLL;
procedure NewtonStaticCollisionSetDebugCallback( const staticCollision : PNewtonCollision; userCallback : PNewtonTreeCollisionCallback ); cdecl; external NewtonDLL;
function NewtonCollisionPointDistance (const newtonWorld : PNewtonWorld; const point : PFloat; const collision : PNewtonCollision; const matrix : PFloat; contact : PFloat; normal : PFloat; threadIndex : int) : Int; cdecl; external NewtonDLL;
function NewtonCollisionClosestPoint (const newtonWorld : PNewtonWorld; const collsionA : PNewtonCollision; const matrixA : PFloat; const collisionB : PNewtonCollision; const matrixB : PFloat; contactA, contactB, normalAB : PFloat; threadIndex : int) : Int; cdecl; external NewtonDLL;
function NewtonCollisionCollide (const newtonWorld : PNewtonWorld; maxSize : Int; const collsionA : PNewtonCollision; const matrixA : PFloat; const collisionB : PNewtonCollision; const matrixB : PFloat; contacts, normals, penetration : PFloat; threadIndex : int) : Int; cdecl; external NewtonDLL;
function NewtonCollisionCollideContinue(const newtonWorld : PNewtonWorld; maxSize : Int; const timestep : Float; const collsionA : PNewtonCollision; const matrixA : PFloat; const velocA : PFloat; const omegaA : Float; const collsionB : PNewtonCollision; const matrixB : PFloat; const velocB : PFloat; const omegaB : Float; timeOfImpact : PFloat; contacts : PFloat; normals : PFloat; penetration : PFloat; threadIndex : int) : Int; cdecl; external NewtonDLL;
procedure NewtonCollisionSupportVertex( const collision : PNewtonCollision; const dir : PFloat; vertex : PFloat); cdecl; external NewtonDLL;
function NewtonCollisionRayCast(const collision : PNewtonCollision; const p0: PFloat; const p1: PFloat; normals: PFloat; attribute: pint): float; cdecl; external NewtonDLL;
procedure NewtonCollisionCalculateAABB( const collision : PNewtonCollision; const matrix : PFloat; p0 : PFloat; p1 : PFloat ); cdecl; external NewtonDLL;
procedure NewtonCollisionForEachPolygonDo (const collision : PNewtonCollision; const matrix : PFloat; callback : NewtonCollisionIterator; UserData : Pointer); cdecl; external NewtonDLL;
procedure NewtonGetEulerAngle( const matrix : PFloat; eulersAngles : PFloat ); cdecl; external NewtonDLL;
procedure NewtonSetEulerAngle( const eulersAngles : PFloat; matrix : PFloat ); cdecl; external NewtonDLL;
function NewtonCalculateSpringDamperAcceleration(dt, ks, x, kd, s : Float): float; cdecl; external NewtonDLL;
function NewtonCreateBody( const newtonWorld : PNewtonWorld; const collision : PNewtonCollision; const Matrix : PFloat) : PNewtonBody; cdecl; external NewtonDLL;
procedure NewtonDestroyBody( const newtonWorld : PNewtonWorld; const body : PNewtonBody ); cdecl; external NewtonDLL;
procedure NewtonBodyAddForce( const body : PNewtonBody; const force : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyAddTorque( const body : PNewtonBody; const torque : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyCalculateInverseDynamicsForce(const body : PNewtonBody; timestep : Float; const desiredVeloc : PFloat; forceOut : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetMatrix( const body : PNewtonBody; const matrix : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetMatrixRecursive( const body : PNewtonBody; const matrix : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetMassMatrix( const body : PNewtonBody; mass : float; Ixx : float; Iyy : float; Izz : float ); cdecl; external NewtonDLL;
procedure NewtonBodySetMaterialGroupID( const body : PNewtonBody; id : int ); cdecl; external NewtonDLL;
procedure NewtonBodySetContinuousCollisionMode(const body : PNewtonbody; state : int); cdecl; external NewtonDLL;
procedure NewtonBodySetJointRecursiveCollision( const body : PNewtonBody; state : unsigned_int ); cdecl; external NewtonDLL;
procedure NewtonBodySetOmega( const body : PNewtonBody; const omega : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetVelocity( const body : PNewtonBody; const velocity : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetForce( const body : PNewtonBody; const force : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetTorque( const body : PNewtonBody; const torque : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetCentreOfMass(const body : PNewtonBody; const com : PFloat); cdecl; external NewtonDLL;
procedure NewtonBodySetLinearDamping( const body : PNewtonBody; linearDamp : float ); cdecl; external NewtonDLL;
procedure NewtonBodySetAngularDamping( const body : PNewtonBody; const angularDamp : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetUserData( const body : PNewtonBody; userData : Pointer ); cdecl; external NewtonDLL;
procedure NewtonBodySetCollision( const body : PNewtonBody; const collision : PNewtonCollision ); cdecl; external NewtonDLL;
function NewtonBodyGetSleepState( const body : PNewtonBody) : Int; cdecl; external NewtonDLL;
function NewtonBodyGetAutoSleep( const body : PNewtonBody) : Int; cdecl; external NewtonDLL;
procedure NewtonBodySetAutoSleep( const body : PNewtonBody; state : int ); cdecl; external NewtonDLL;
function NewtonBodyGetFreezeState( const body : PNewtonBody) : Int; cdecl; external NewtonDLL;
procedure NewtonBodySetFreezeState( const body : PNewtonBody; state : int ); cdecl; external NewtonDLL;
procedure NewtonBodySetDestructorCallback( const body : PNewtonBody; callback : NewtonBodyDestructor ); cdecl; external NewtonDLL;
procedure NewtonBodySetTransformCallback( const body : PNewtonBody; callback : NewtonSetTransform ); cdecl; external NewtonDLL;
function NewtonBodyGetTransformCallback( const body : PNewtonBody ): NewtonSetTransform; cdecl; external NewtonDLL;
procedure NewtonBodySetForceAndTorqueCallback( const body : PNewtonBody; callback : NewtonApplyForceAndTorque ); cdecl; external NewtonDLL;
function NewtonBodyGetForceAndTorqueCallback( const body : PNewtonBody ): NewtonApplyForceAndTorque; cdecl; external NewtonDLL;
function NewtonBodyGetUserData( const body : PNewtonBody ) : Pointer; cdecl; external NewtonDLL;
function NewtonBodyGetWorld( const body : PNewtonBody) : PNewtonWorld; cdecl; external NewtonDLL;
function NewtonBodyGetCollision( const body : PNewtonBody ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonBodyGetMaterialGroupID( const body : PNewtonBody ) : Int; cdecl; external NewtonDLL;
function NewtonBodyGetContinuousCollisionMode( const body : PNewtonBody ) : Int; cdecl; external NewtonDLL;
function NewtonBodyGetJointRecursiveCollision( const body : PNewtonBody ) : Int; cdecl; external NewtonDLL;
procedure NewtonBodyGetMatrix( const body : PNewtonBody; matrix : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetRotation( const body : PNewtonBody; rotation : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetMassMatrix( const body : PNewtonBody; mass : PFloat; Ixx : PFloat; Iyy : PFloat; Izz : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetInvMass( const body : PNewtonBody; invMass : PFloat; invIxx : PFloat; invIyy : PFloat; invIzz : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetOmega( const body : PNewtonBody; vector : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetVelocity( const body : PNewtonBody; vector : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetForce( const body : PNewtonBody; vector : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetTorque( const body : PNewtonBody; vector : PFloat); cdecl; external NewtonDLL;
procedure NewtonBodyGetForceAcc( const body : PNewtonBody; vector : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetTorqueAcc( const body : PNewtonBody; vector : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetCentreOfMass(const body : PNewtonBody; com : PFloat); cdecl; external NewtonDLL;
function NewtonBodyGetLinearDamping( const body : PNewtonBody ) : float; cdecl; external NewtonDLL;
procedure NewtonBodyGetAngularDamping( const body : PNewtonBody; vector : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetAABB( const body : PNewtonBody; p0 : PFloat; p1 : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetFreezeTreshold( const body : PNewtonBody; freezeSpeed2 : PFloat; freezeOmega2 : PFloat ); cdecl; external NewtonDLL;
function NewtonBodyGetFirstJoint( const body : PNewtonBody ) : PNewtonJoint; cdecl; external NewtonDLL;
function NewtonBodyGetNextJoint( const body : PNewtonBody; const joint : PNewtonJoint ) : PNewtonJoint; cdecl; external NewtonDLL;
function NewtonBodyGetFirstContactJoint( const body : PNewtonBody ) : PNewtonJoint; cdecl; external NewtonDLL;
function NewtonBodyGetNextContactJoint( const body : PNewtonBody; const contactJoint : PNewtonJoint ) : PNewtonJoint; cdecl; external NewtonDLL;
function NewtonContactJointGetFirstContact( const contactJoint : PNewtonJoint ) : Pointer; cdecl; external NewtonDLL;
function NewtonContactJointGetNextContact( const contactJoint : PNewtonJoint; contact : Pointer ) : Pointer; cdecl; external NewtonDLL;
function NewtonContactJointGetContactCount( const contactJoint : PNewtonJoint ) : int; cdecl; external NewtonDLL;
procedure NewtonContactJointRemoveContact( const contactJoint : PNewtonJoint; contact : Pointer ); cdecl; external NewtonDLL;
function NewtonContactGetMaterial( const contact : Pointer ) : PNewtonMaterial; cdecl; external NewtonDLL;
procedure NewtonBodyAddBuoyancyForce( const body : PNewtonBody; fluidDensity : float; fluidLinearViscosity, fluidAngularViscosity : float; const gravityVector : PFloat; buoyancyPlane : NewtonGetBuoyancyPlane; context : Pointer ); cdecl; external NewtonDLL;
procedure NewtonBodyAddImpulse(const body : PNewtonBody; const pointDeltaVeloc : PFloat; const pointPosit : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyApplyImpulseArray (const Body : PNewtonBody; ImpuleCount : Int; StrideInByte : Int; const impulseArray : PFloat; const pointArray : PFloat); cdecl; external NewtonDLL;
function NewtonJointGetUserData( const joint : PNewtonJoint ) : Pointer; cdecl; external NewtonDLL;
procedure NewtonJointSetUserData( const joint : PNewtonJoint; userData : Pointer ); cdecl; external NewtonDLL;
function NewtonJointGetBody0( const joint : PNewtonJoint ) : PNewtonBody; cdecl; external NewtonDLL;
function NewtonJointGetBody1( const joint : PNewtonJoint ) : PNewtonBody; cdecl; external NewtonDLL;
procedure NewtonJointGetInfo( const joint : PNewtonJoint; info : PNewtonJointRecord ); cdecl; external NewtonDLL;
function NewtonJointGetCollisionState( const joint : PNewtonJoint ) : int; cdecl; external NewtonDLL;
procedure NewtonJointSetCollisionState( const joint : PNewtonJoint; state : int ); cdecl; external NewtonDLL;
function NewtonJointGetStiffness( const joint : PNewtonJoint): float; cdecl; external NewtonDLL;
procedure NewtonJointSetStiffness( const joint: PNewtonJoint; state: float); cdecl; external NewtonDLL;
procedure NewtonDestroyJoint( const newtonWorld : PNewtonWorld; const joint : PNewtonJoint ); cdecl; external NewtonDLL;
procedure NewtonJointSetDestructor( const joint : PNewtonJoint; _destructor : NewtonConstraintDestructor ); cdecl; external NewtonDLL;
function NewtonConstraintCreateBall( const newtonWorld : PNewtonWorld; const pivotPoint : PFloat; const childBody : PNewtonBody; const parentBody : PNewtonBody ) : PNewtonJoint; cdecl; external NewtonDLL;
procedure NewtonBallSetUserCallback( const ball : PNewtonJoint; callback : NewtonBallCallBack ); cdecl; external NewtonDLL;
procedure NewtonBallGetJointAngle( const ball : PNewtonJoint; angle : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBallGetJointOmega( const ball : PNewtonJoint; omega : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBallGetJointForce( const ball : PNewtonJoint; force : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBallSetConeLimits( const ball : PNewtonJoint; const pin : PFloat; maxConeAngle : float; maxTwistAngle : float ); cdecl; external NewtonDLL;
function NewtonConstraintCreateHinge( const newtonWorld : PNewtonWorld; const pivotPoint : PFloat; const pinDir : PFloat; const childBody : PNewtonBody; const parentBody : PNewtonBody ) : PNewtonJoint; cdecl; external NewtonDLL;
procedure NewtonHingeSetUserCallback( const hinge : PNewtonJoint; callback : NewtonHingeCallBack ); cdecl; external NewtonDLL;
function NewtonHingeGetJointAngle( const hinge : PNewtonJoint ) : float; cdecl; external NewtonDLL;
function NewtonHingeGetJointOmega( const hinge : PNewtonJoint ) : float; cdecl; external NewtonDLL;
procedure NewtonHingeGetJointForce( const hinge : PNewtonJoint; force : PFloat ); cdecl; external NewtonDLL;
function NewtonHingeCalculateStopAlpha( const hinge : PNewtonJoint; const desc : PNewtonHingeSliderUpdateDesc; angle : float ) : float; cdecl; external NewtonDLL;
function NewtonConstraintCreateSlider( const newtonWorld : PNewtonWorld; const pivotPoint : PFloat; const pinDir : PFloat; const childBody : PNewtonBody; const parentBody : PNewtonBody ) : PNewtonJoint; cdecl; external NewtonDLL;
procedure NewtonSliderSetUserCallback( const slider : PNewtonJoint; callback : NewtonSliderCallBack ); cdecl; external NewtonDLL;
function NewtonSliderGetJointPosit( const slider : PNewtonJoint ) : float; cdecl; external NewtonDLL;
function NewtonSliderGetJointVeloc( const slider : PNewtonJoint ) : float; cdecl; external NewtonDLL;
procedure NewtonSliderGetJointForce( const slider : PNewtonJoint; force : PFloat ); cdecl; external NewtonDLL;
function NewtonSliderCalculateStopAccel( const slider : PNewtonJoint; const desc : PNewtonHingeSliderUpdateDesc; position : float ) : float; cdecl; external NewtonDLL;
function NewtonConstraintCreateCorkscrew( const newtonWorld : PNewtonWorld; const pivotPoint : PFloat; const pinDir : PFloat; const childBody : PNewtonBody; const parentBody : PNewtonBody ) : PNewtonJoint; cdecl; external NewtonDLL;
procedure NewtonCorkscrewSetUserCallback( const corkscrew : PNewtonJoint; callback : NewtonCorkscrewCallBack ); cdecl; external NewtonDLL;
function NewtonCorkscrewGetJointPosit( const corkscrew : PNewtonJoint ) : float; cdecl; external NewtonDLL;
function NewtonCorkscrewGetJointAngle( const corkscrew : PNewtonJoint ) : float; cdecl; external NewtonDLL;
function NewtonCorkscrewGetJointVeloc( const corkscrew : PNewtonJoint ) : float; cdecl; external NewtonDLL;
function NewtonCorkscrewGetJointOmega( const corkscrew : PNewtonJoint ) : float; cdecl; external NewtonDLL;
procedure NewtonCorkscrewGetJointForce( const corkscrew : PNewtonJoint; force : PFloat ); cdecl; external NewtonDLL;
function NewtonCorkscrewCalculateStopAlpha(const corkscrew : PNewtonJoint;const desc : PNewtonHingeSliderUpdateDesc;angle : float) : float; cdecl; external NewtonDLL;
function NewtonCorkscrewCalculateStopAccel(const corkscrew : PNewtonJoint;const desc : PNewtonHingeSliderUpdateDesc;position : float) : float; cdecl; external NewtonDLL;
function NewtonConstraintCreateUniversal( const newtonWorld: PNewtonWorld; const pivotPoint: PFloat; const pinDir0: PFloat; const pinDir1: PFloat; const childBody: PNewtonBody; const parentBody: PNewtonBody): PNewtonJoint; cdecl; external NewtonDLL;
procedure NewtonUniversalSetUserCallback(const universal: PNewtonJoint; callback: NewtonUniversalCallback); cdecl; external NewtonDLL;
function NewtonUniversalGetJointAngle0(const universal: PNewtonJoint):float; cdecl; external NewtonDLL;
function NewtonUniversalGetJointAngle1(const universal: PNewtonJoint):float; cdecl; external NewtonDLL;
function NewtonUniversalGetJointOmega0(const universal: PNewtonJoint):float; cdecl; external NewtonDLL;
function NewtonUniversalGetJointOmega1(const universal: PNewtonJoint):float; cdecl; external NewtonDLL;
procedure NewtonUniversalGetJointForce(const universal: PNewtonJoint; force: PFloat); cdecl; external NewtonDLL;
function NewtonUniversalCalculateStopAlpha0(const universal : PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; angle: float): float; cdecl; external NewtonDLL;
function NewtonUniversalCalculateStopAlpha1(const universal : PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; angle: float): float; cdecl; external NewtonDLL;
function NewtonConstraintCreateUpVector( const newtonWorld : PNewtonWorld; const pinDir : PFloat; const body : PNewtonBody ) : PNewtonJoint; cdecl; external NewtonDLL;
procedure NewtonUpVectorGetPin( const upVector : PNewtonJoint; pin : PFloat ); cdecl; external NewtonDLL;
procedure NewtonUpVectorSetPin( const upVector : PNewtonJoint; const pin : PFloat ); cdecl; external NewtonDLL;
function NewtonConstraintCreateUserJoint(const NewtonWorld : PNewtonWorld; MaxDOF : Integer; Callback : PNewtonUserBilateralCallBack; GetInfo : PNewtonUserBilateralGetInfoCallBack; const ChildBody: PNewtonBody; const parentBody: PNewtonBody): PNewtonJoint; cdecl; external NewtonDLL;
procedure NewtonUserJointSetFeedbackCollectorCallback(const Joint : PNewtonJoint; GetFeedback : PNewtonUserBilateralCallBack); cdecl; external NewtonDLL;
procedure NewtonUserJointAddLinearRow(const Joint : PNewtonJoint; const pivot0 : PFloat; const pivot1 : PFloat; const Dir : PFloat); cdecl; external NewtonDLL;
procedure NewtonUserJointAddAngularRow(const Joint : PNewtonJoint; RelativeAngle : Float; const Dir : PFloat); cdecl; external NewtonDLL;
procedure NewtonUserJointAddGeneralRow(const Joint : PNewtonJoint; const Jacobian0 : PFloat; const Jacobian1 : PFloat); cdecl; external NewtonDLL;
procedure NewtonUserJointSetRowMinimumFriction(const Joint : PNewtonJoint; Friction : Float); cdecl; external NewtonDLL;
procedure NewtonUserJointSetRowMaximumFriction(const Joint : PNewtonJoint; Friction : Float); cdecl; external NewtonDLL;
procedure NewtonUserJointSetRowAcceleration(const Joint : PNewtonJoint; Acceleration : Float); cdecl; external NewtonDLL;
procedure NewtonUserJointSetRowSpringDamperAcceleration(const joint : PNewtonJoint; springK : Float; springD : Float); cdecl; external NewtonDLL;
procedure NewtonUserJointSetRowStiffness(const Joint : PNewtonJoint; Stiffness : Float); cdecl; external NewtonDLL;
function NewtonUserJointGetRowForce (const Joint : PNewtonJoint; Row : Int) : Float; cdecl; external NewtonDLL;
function NewtonMeshCreate (const World : PNewtonWorld) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshCreateFromMesh(const Mesh : PNewtonMesh) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshCreateFromCollision (const collision : PNewtonCollision) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshConvexHull (const NewtonWorld : PNewtonWorld; count : int; const vertexCloud : PFloat; strideInBytes : int; tolerance : float) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshCreatePlane (const World : PNewtonWorld; const locationMatrix : PFloat; width : Float; breadth : Float; material : Int; const textureMatrix0 : PFloat; const textureMatrix1) : PNewtonMesh; cdecl; external NewtonDLL;
procedure NewtonMeshDestroy(const mesh : PNewtonMesh); cdecl; external NewtonDLL;
procedure NewtonMeshCalculateOOBB(const mesh : PNewtonMesh; const matrix : PFloat; x : PFloat; y : PFloat; z : PFloat); cdecl; external NewtonDLL;
procedure NewtonMesApplyTransform (const Mesh : PNewtonMesh; const Matrix : PFloat); cdecl; external NewtonDLL;
procedure NewtonMeshCalculateVertexNormals(const mesh : PNewtonMesh; angleInRadians : Float); cdecl; external NewtonDLL;
procedure NewtonMeshApplySphericalMapping(const mesh : PNewtonMesh; material : int); cdecl; external NewtonDLL;
procedure NewtonMeshApplyBoxMapping(const mesh : PNewtonMesh; front,side,top : int); cdecl; external NewtonDLL;
procedure NewtonMeshApplyCylindricalMapping(const mesh : PNewtonMesh; cylinderMaterial,capMaterial : int); cdecl; external NewtonDLL;
function NewtonMeshIsOpenMesh (const mesh : PNewtonMesh) : Int; cdecl; external NewtonDLL;
procedure NewtonMeshFixTJoints (const mesh : PNewtonMesh); cdecl; external NewtonDLL;
procedure NewtonMeshPolygonize (const mesh : PNewtonMesh); cdecl; external NewtonDLL;
procedure NewtonMeshTriangulate (const mesh : PNewtonMesh); cdecl; external NewtonDLL;
function NewtonMeshUnion (const mesh : PNewtonMesh; clipper : PNewtonMesh; clipperMatrix : PFloat) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshDifference (const mesh : PNewtonMesh; clipper : PNewtonMesh; clipperMatrix : PFloat) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshIntersection (const mesh : PNewtonMesh; clipper : PNewtonMesh; clipperMatrix : PFloat) : PNewtonMesh; cdecl; external NewtonDLL;
procedure NewtonMeshClip (const mesh : PNewtonMesh; const clipper : PNewtonMesh; const clippermatrix : PFloat; const topMesh : PNewtonMesh; const bottomMesh : PNewtonMesh); cdecl; external NewtonDLL;
procedure NewtonMeshPlaneClip (const Mesh : PNewtonMesh; const planeMatrix : PFloat; const PlaneTextureMatrix : PFloat; PlaneMaterial : Int; const topMesh : PNewtonMesh; const bottomMesh : PNewtonMesh); cdecl; external NewtonDLL;
function NewtonMeshConvexDecomposition (const Mesh : PNewtonMesh; MaxCount : Int) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshVoronoiDecomposition (const Mesh : PNewtonMesh; PointCount, PointStrideInBytes : Int; const PointCloud : PFloat; InternalMaterial : Int; const TextureMatrix : PFloat) : PNewtonMesh; cdecl; external NewtonDLL;
procedure NewtonRemoveUnusedVertices(const mesh : PNewtonMesh; vertexRemapTable : PInt); cdecl; external NewtonDLL;
procedure NewtonMeshBeginFace(const mesh : PNewtonMesh); cdecl; external NewtonDLL;
procedure NewtonMeshAddFace(const mesh : PNewtonMesh; vertexCount : int; const vertex : PFloat; strideInBytes,materialIndex : int ); cdecl; external NewtonDLL;
procedure NewtonMeshEndFace(const mesh : PNewtonMesh); cdecl; external NewtonDLL;
procedure NewtonMeshBuildFromVertexListIndexList(const Mesh : PNewtonMesh; FaceCount : Int; const faceIndexCount : PInt; const faceMaterialIndex : PInt; const vertex : PFloat; vertexStrideInBytes : Int; const vertexIndex : PInt; const normal : PFloat; normalStrideInBytes : Int; const normalIndex : PInt; const uv0 : PFloat; uv0StrideInBytes : Int; const uv0Index : PInt; const uv1 : PFloat; uv1StrideInBytes : Int; const uv1Index : PInt); cdecl; external NewtonDLL;
procedure NewtonMeshGetVertexStreams(const Mesh : PNewtonMesh; vertexStrideInByte : Int; Vertex : PFloat; normalStrideInByte : int; Normal : PFloat; uvStrideInByte0 : Int; uv0 : PFloat; uvStrideInByte1 : Int; uv1 : PFloat); cdecl; external NewtonDLL;
procedure NewtonMeshGetIndirectVertexStreams(const mesh : PNewtonMesh; vertexStrideInByte : int; vertex : PFloat; vertexIndices : PInt; vertexCount : PInt; normalStrideInByte : int; normal : PFloat; normalIndices : PInt; normalCount : PInt; uvStrideInByte0 : int; uv0 : PFloat; uvIndices0 : PInt; uvCount0 : PInt; uvStrideInByte1 : int; uv1 : PFloat; uvIndices1 : PInt; uvCount1 : PInt); cdecl; external NewtonDLL;
function NewtonMeshBeginHandle (const mesh : PNewtonMesh) : Pointer; cdecl; external NewtonDLL;
procedure NewtonMeshEndHandle (const mesh : PNewtonMesh; Handle : Pointer); cdecl; external NewtonDLL;
function NewtonMeshFirstMaterial (const mesh : PNewtonMesh; Handle : Pointer) : int; cdecl; external NewtonDLL;
function NewtonMeshNextMaterial (const mesh : PNewtonMesh; Handle : Pointer; materialID : int) : int; cdecl; external NewtonDLL;
function NewtonMeshMaterialGetMaterial (const mesh : PNewtonMesh; Handle : Pointer; materialID : int) : int; cdecl; external NewtonDLL;
function NewtonMeshMaterialGetIndexCount (const mesh : PNewtonMesh; Handle : Pointer; materialID : int) : int; cdecl; external NewtonDLL;
procedure NewtonMeshMaterialGetIndexStream(const mesh : PNewtonMesh; Handle : Pointer; materialID : int; index : PInt); cdecl; external NewtonDLL;
procedure NewtonMeshMaterialGetIndexStreamShort(const mesh : PNewtonMesh; Handle : Pointer; materialID : int; index : PShort); cdecl; external NewtonDLL;
function NewtonMeshCreateFirstSingleSegment (const mesh : PNewtonMesh) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshCreateNextSingleSegment (const mesh : PNewtonMesh; Segment : PNewtonMesh) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshCreateFirstLayer(const Mesh : PNewtonMesh) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshCreateNextLayer(const Mesh : PNewtonMesh; const Segment : PNewtonMesh) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshGetTotalFaceCount (const mesh : PNewtonMesh) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetTotalIndexCount (const mesh : PNewtonMesh) : Int; cdecl; external NewtonDLL;
procedure NewtonMeshGetFaces (const mesh : PNewtonMesh; const faceIndexCount : PInt; faceMaterial : PInt; faceIndices : PInt); cdecl; external NewtonDLL;
function NewtonMeshGetPointCount (const Mesh : PNewtonMesh) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetPointStrideInByte (const Mesh : PNewtonMesh) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetPointArray (const Mesh : PNewtonMesh): PFloat; cdecl; external NewtonDLL;
function NewtonMeshGetNormalArray (const Mesh : PNewtonMesh) : PFloat; cdecl; external NewtonDLL;
function NewtonMeshGetUV0Array (const Mesh : PNewtonMesh) : PFloat; cdecl; external NewtonDLL;
function NewtonMeshGetUV1Array (const Mesh : PNewtonMesh) : PFloat; cdecl; external NewtonDLL;
function NewtonMeshGetVertexCount (const Mesh : PNewtonMesh) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetVertexStrideInByte (const Mesh : PNewtonMesh) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetVertexArray (const Mesh : PNewtonMesh) : PFloat; cdecl; external NewtonDLL;
function NewtonMeshGetFirstVertex (const Mesh : PNewtonMesh) : Pointer; cdecl; external NewtonDLL;
function NewtonMeshGetNextVertex (const Mesh : PNewtonMesh; const Vertex : Pointer) : Pointer; cdecl; external NewtonDLL;
function NewtonMeshGetVertexIndex (const Mesh : PNewtonMesh; const Vertex : Pointer) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetFirstPoint (const Mesh : PNewtonMesh) : Pointer; cdecl; external NewtonDLL;
function NewtonMeshGetNextPoint (const Mesh : PNewtonMesh; const point : Pointer) : Pointer; cdecl; external NewtonDLL;
function NewtonMeshGetPointIndex (const Mesh : PNewtonMesh; const point : Pointer) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetVertexIndexFromPoint (const Mesh : PNewtonMesh; const point : Pointer) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetFirstEdge (const Mesh : PNewtonMesh) : Pointer; cdecl; external NewtonDLL;
function NewtonMeshGetNextEdge (const Mesh : PNewtonMesh; const Edge : Pointer) : Pointer; cdecl; external NewtonDLL;
procedure NewtonMeshGetEdgeIndices (const Mesh : PNewtonMesh; const Edge : Pointer; v0 : PInt; v1 : PInt); cdecl; external NewtonDLL;
function NewtonMeshGetFirstFace (const Mesh : PNewtonMesh) : Pointer; cdecl; external NewtonDLL;
function NewtonMeshGetNextFace (const Mesh : PNewtonMesh; const Face : Pointer) : Pointer; cdecl; external NewtonDLL;
function NewtonMeshIsFaceOpen (const Mesh : PNewtonMesh; const Face : Pointer) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetFaceMaterial (const Mesh : PNewtonMesh; const Face : Pointer) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetFaceIndexCount (const Mesh : PNewtonMesh; const Face : Pointer) : Int; cdecl; external NewtonDLL;
procedure NewtonMeshGetFaceIndices (const Mesh : PNewtonMesh; const Face : Pointer; Indices : PInt); cdecl; external NewtonDLL;
procedure NewtonMeshGetFacePointIndices (const Mesh : PNewtonMesh; const Face : Pointer; Indices : PInt); cdecl; external NewtonDLL;

Types

Float = Single;
Long_double = Extended;
Int = Integer;
__int8 = ShortInt;
__int16 = SmallInt;
__int32 = LongInt;
__int64 = Int64;
NChar = ShortInt;
Unsigned_char = Byte;
Short = SmallInt;
Unsigned_short = Word;
Long = LongInt;
Unsigned_long = LongWord;
Unsigned_int = Cardinal;
size_t = Cardinal;
CharArray = Array [0..255] of Char;
PInt = ˆInt;
P__int8 = ˆ__int8;
P__int16 = ˆ__int16;
P__int32 = ˆ__int32;
P__int64 = ˆ__int64;
P2Char = ˆNChar;
PUnsigned_char = ˆUnsigned_char;
PShort = ˆShort;
PUnsigned_short = ˆUnsigned_short;
PLong = ˆLong;
PUnsigned_long = ˆUnsigned_long;
PUnsigned_int = ˆUnsigned_int;
Psize_t = ˆsize_t;
PFloat = ˆFloat;
PLong_double = ˆLong_double;
PCharArray = ˆCharArray;
Bool = Boolean;
Pvoid = Pointer;
PBool = ˆBool;
PNewtonMesh = ˆPointer;
PNewtonBody = ˆPointer;
PNewtonWorld = ˆPointer;
PNewtonJoint = ˆPointer;
PNewtonContact = ˆPointer;
PNewtonMaterial = ˆPointer;
PNewtonCollision = ˆPointer;
PNewtonSceneProxy = ˆPointer;
PNewtonBreakableComponentMesh = ˆPointer;
PNewtonMeshVertex = ˆPointer;
PNewtonMeshEdge = ˆPointer;
PNewtonMeshFace = ˆPointer;
PNewtonMeshPoint= ˆPointer;
PNewtonUserJoint = ˆPointer;
PNewtonCollisionInfoRecord = ˆTNewtonCollisionInfoRecord;
PNewtonJointRecord = ˆNewtonJointRecord;
PNewtonUserMeshCollisionCollideDesc = ˆNewtonUserMeshCollisionCollideDesc;
PNewtonWorldConvexCastReturnInfo = ˆNewtonWorldConvexCastReturnInfo;
PNewtonUserMeshCollisionRayHitDesc = ˆNewtonUserMeshCollisionRayHitDesc;
PNewtonHingeSliderUpdateDesc = ˆNewtonHingeSliderUpdateDesc;
PNewtonAllocMemory = ˆNewtonAllocMemory;
NewtonAllocMemory = function( sizeInBytes : int ) : Pointer; cdecl;
PNewtonFreeMemory = ˆNewtonFreeMemory;
NewtonFreeMemory = procedure( ptr : Pointer; sizeInBytes : int ); cdecl;
PNewtonDestroyWorld = ˆNewtonDestroyWorld;
NewtonDestroyWorld = procedure( const NewtonWorld : PNewtonWorld ); cdecl;
PNewtonGetTicksCountCallback = ˆNewtonGetTicksCountCallback;
NewtonGetTicksCountCallback = function () : cardinal; cdecl;
PNewtonSerialize = ˆNewtonSerialize;
NewtonSerialize = procedure( serializeHandle : Pointer; const buffer : Pointer; size : size_t ); cdecl;
PNewtonDeserialize = ˆNewtonDeserialize;
NewtonDeserialize = procedure( serializeHandle : Pointer; buffer : Pointer; size : size_t ); cdecl;
PNewtonUserMeshCollisionDestroyCallback = ˆNewtonUserMeshCollisionDestroyCallback;
NewtonUserMeshCollisionDestroyCallback = procedure( descData : Pointer ); cdecl;
PNewtonUserMeshCollisionCollideCallback = ˆNewtonUserMeshCollisionCollideCallback;
NewtonUserMeshCollisionCollideCallback = procedure( NewtonUserMeshCollisionCollideDesc : PNewtonUserMeshCollisionCollideDesc ); cdecl;
PNewtonUserMeshCollisionRayHitCallback = ˆNewtonUserMeshCollisionRayHitCallback;
NewtonUserMeshCollisionRayHitCallback = function( NewtonUserMeshCollisionRayHitDesc : PNewtonUserMeshCollisionRayHitDesc ) : int; cdecl;
PNewtonUserMeshCollisionGetCollisionInfo = ˆNewtonUserMeshCollisionGetCollisionInfo;
NewtonUserMeshCollisionGetCollisionInfo = procedure( userData : Pointer; infoRecord : PNewtonCollisionInfoRecord ); cdecl;
PNewtonUserMeshCollisionGetFacesInAABB = ˆNewtonUserMeshCollisionGetFacesInAABB;
NewtonUserMeshCollisionGetFacesInAABB = function( userData : Pointer; const p0 : PFloat; const p1 : PFloat; const vertexArray : PFloat; vertexCount : pint; vertexStrideInBytes : pint; const indexList : pint; maxIndexCount : int; const userDataList : pint ) : int; cdecl;
PNewtonCollisionTreeRayCastCallback = ˆNewtonCollisionTreeRayCastCallback;
NewtonCollisionTreeRayCastCallback = function(const Body : PNewtonBody; const TreeCollision : PNewtonCollision; interception : Float; normal : PFloat; faceId : int; usedData : Pointer) : Float; cdecl;
PNewtonHeightFieldRayCastCallback = ˆNewtonHeightFieldRayCastCallback;
NewtonHeightFieldRayCastCallback = function(const Body : PNewtonBody; const HeightFieldCollision : PNewtonCollision; Interception : Float; Row, Col : Int; Normal : PFloat; FaceID : Int; UsedData : Pointer) : Float; cdecl;
PNewtonTreeCollisionCallback = ˆNewtonTreeCollisionCallback;
NewtonTreeCollisionCallback = procedure( const bodyWithTreeCollision : PNewtonBody; const body : PNewtonBody; faceID : int; const vertex : PFloat; vertexstrideInBytes : int); cdecl;
PNewtonBodyDestructor = ˆNewtonBodyDestructor;
NewtonBodyDestructor = procedure( const body : PNewtonBody ); cdecl;
PNewtonApplyForceAndTorque = ˆNewtonApplyForceAndTorque;
NewtonApplyForceAndTorque = procedure( const body : PNewtonBody; timestep : Float; threadIndex : int ); cdecl;
PNewtonSetTransform = ˆNewtonSetTransform;
NewtonSetTransform = procedure( const body : PNewtonBody; const matrix : PFloat; threadIndex : int ); cdecl;
PNewtonIslandUpdate = ˆNewtonIslandUpdate;
NewtonIslandUpdate = function(const World : PNewtonWorld; islandHandle : Pointer; bodyCount : int) : int; cdecl;
PNewtonBodyLeaveWorld = ˆNewtonBodyLeaveWorld;
NewtonBodyLeaveWorld = procedure( const body : PNewtonBody; threadIndex : int ); cdecl;
PNewtonDestroyBodyByExeciveForce = ˆNewtonDestroyBodyByExeciveForce;
NewtonDestroyBodyByExeciveForce = procedure( const body : PNewtonBody; const contact : PNewtonJoint ); cdecl;
PNewtonCollisionDestructor = ˆNewtonCollisionDestructor;
NewtonCollisionDestructor = procedure (const World : PNewtonWorld; const collision : PNewtonCollision); cdecl;
PNewtonCollisionCompoundBreakableCallback = ˆNewtonCollisionCompoundBreakableCallback;
NewtonCollisionCompoundBreakableCallback = function(const Mesh : PNewtonMesh; userData : Pointer; planeMatrixOut : PFloat) : Int; cdecl;
PNewtonGetBuoyancyPlane = ˆNewtonGetBuoyancyPlane;
NewtonGetBuoyancyPlane = function(const collisionID : Int; context : Pointer; const globalSpaceMatrix : PFloat; globalSpacePlane : PFloat ) : Int; cdecl;
PNewtonWorldRayPrefilterCallback = ˆNewtonWorldRayPrefilterCallback;
NewtonWorldRayPrefilterCallback = function (const body : PNewtonBody; const collision : PNewtonCollision; userData : Pointer) : cardinal; cdecl;
PNewtonWorldRayFilterCallback = ˆNewtonWorldRayFilterCallback;
NewtonWorldRayFilterCallback = function( const body : PNewtonBody; const hitNormal: PFloat; collisionID : Int; userData: Pointer; intersetParam: Float ) : Float; cdecl;
PNewtonOnAABBOverlap = ˆNewtonOnAABBOverlap;
NewtonOnAABBOverlap = function( const material : PNewtonMaterial; const body0 : PNewtonBody; const body1 : PNewtonBody; threadIndex : int ) : int; cdecl;
PNewtonContactsProcess = ˆNewtonContactsProcess;
NewtonContactsProcess = procedure( const contact : PNewtonJoint; timestep : Float; threadIndex : int ); cdecl;
PNewtonBodyIterator = ˆNewtonBodyIterator;
NewtonBodyIterator = procedure( const body : PNewtonBody; userData : Pointer ); cdecl;
PNewtonJointIterator = ˆNewtonJointIterator;
NewtonJointIterator = procedure( const joint : PNewtonJoint; userData : Pointer ); cdecl;
PNewtonCollisionIterator = ˆNewtonCollisionIterator;
NewtonCollisionIterator = procedure( userData : Pointer; vertexCount : int; const FaceArray : PFloat; faceId : int ); cdecl;
PNewtonBallCallBack = ˆNewtonBallCallBack;
NewtonBallCallBack = procedure( const ball : PNewtonJoint; timestep : Float ); cdecl;
PNewtonHingeCallBack = ˆNewtonHingeCallBack;
NewtonHingeCallBack = function( const hinge : PNewtonJoint; desc : PNewtonHingeSliderUpdateDesc ) : Unsigned_int; cdecl;
PNewtonSliderCallBack = ˆNewtonSliderCallBack;
NewtonSliderCallBack = function( const slider : PNewtonJoint; desc : PNewtonHingeSliderUpdateDesc ) : Unsigned_int; cdecl;
PNewtonUniversalCallBack = ˆNewtonUniversalCallBack;
NewtonUniversalCallBack = function( const universal : PNewtonJoint; desc : PNewtonHingeSliderUpdateDesc ) : Unsigned_int; cdecl;
PNewtonCorkscrewCallBack = ˆNewtonCorkscrewCallBack;
NewtonCorkscrewCallBack = function( const corkscrew : PNewtonJoint; desc : PNewtonHingeSliderUpdateDesc ) : Unsigned_int; cdecl;
PNewtonUserBilateralCallBack = ˆNewtonUserBilateralCallBack;
NewtonUserBilateralCallBack = procedure( const userJoint: PNewtonJoint; timestep : Float; threadIndex : int); cdecl;
PNewtonUserBilateralGetInfoCallBack = ˆNewtonUserBilateralGetInfoCallBack;
NewtonUserBilateralGetInfoCallBack = procedure( const userJoint : PNewtonJoint; info : PNewtonJointRecord ); cdecl;
PNewtonConstraintDestructor = ˆNewtonConstraintDestructor;
NewtonConstraintDestructor = procedure( const me : PNewtonJoint ); cdecl;
TCollisionPrimitiveArray = array of PNewtonCollision;

Constants

NewtonDLL = 'Newton.dll';
NEWTON_MAJOR_VERSION = 2;
NEWTON_MINOR_VERSION = 35;
NEWTON_PROFILER_WORLD_UPDATE = 0;
NEWTON_PROFILER_COLLISION_UPDATE = 1;
NEWTON_PROFILER_COLLISION_UPDATE_BROAD_PHASE = 2;
NEWTON_PROFILER_COLLISION_UPDATE_NARROW_PHASE = 3;
NEWTON_PROFILER_DYNAMICS_UPDATE = 4;
NEWTON_PROFILER_DYNAMICS_CONSTRAINT_GRAPH = 5;
NEWTON_PROFILER_FORCE_CALLBACK_UPDATE = 6;
NEWTON_PROFILER_DYNAMICS_SOLVE_CONSTRAINT_GRAPH = 7;
SERIALIZE_ID_BOX = 0;
SERIALIZE_ID_CONE = 1;
SERIALIZE_ID_SPHERE = 2;
SERIALIZE_ID_CAPSULE = 3;
SERIALIZE_ID_CYLINDER = 4;
SERIALIZE_ID_COMPOUND = 5;
SERIALIZE_ID_CONVEXHULL = 6;
SERIALIZE_ID_CONVEXMODIFIER = 7;
SERIALIZE_ID_CHAMFERCYLINDER = 8;
SERIALIZE_ID_TREE = 9;
SERIALIZE_ID_NULL = 10;
SERIALIZE_ID_HEIGHTFIELD = 11;
SERIALIZE_ID_USERMESH = 12;
SERIALIZE_ID_SCENE = 13;
SERIALIZE_ID_COMPOUND_BREAKABLE = 14;

Description

Functions and Procedures

function NewtonWorldGetVersion( const newtonWorld : PNewtonWorld) : int; cdecl; external NewtonDLL;
function NewtonWorldFloatSize( const newtonWorld : PNewtonWorld) : int; cdecl; external NewtonDLL;
function NewtonCreate( malloc : NewtonAllocMemory; mfree : NewtonFreeMemory ) : PNewtonWorld; cdecl; external NewtonDLL;
procedure NewtonDestroy( const newtonWorld : PNewtonWorld ); cdecl; external NewtonDLL;
procedure NewtonDestroyAllBodies( const newtonWorld : PNewtonWorld ); cdecl; external NewtonDLL;
function NewtonGetMemoryUsed() : int; cdecl; external NewtonDLL;
procedure NewtonSetMemorySystem( malloc : NewtonAllocMemory; mfree : NewtonFreeMemory ); cdecl; external NewtonDLL;
procedure NewtonUpdate( const newtonWorld : PNewtonWorld; timestep : float ); cdecl; external NewtonDLL;
procedure NewtonInvalidateCache( const newtonWorld : PNewtonWorld); cdecl; external NewtonDLL;
procedure NewtonCollisionUpdate( const newtonWorld : PNewtonWorld); cdecl; external NewtonDLL;
procedure NewtonSetSolverModel(const NewtonWorld : PNewtonWorld; Model : Int); cdecl; external NewtonDLL;
procedure NewtonSetPlatformArchitecture (const newtonWorld : PNewtonWorld; mode : Int); cdecl; external NewtonDLL;
function NewtonGetPlatformArchitecture (const newtonWorld : PNewtonWorld; description : PCharArray) : int; cdecl; external NewtonDLL;
procedure NewtonSetMultiThreadSolverOnSingleIsland (const newtonWorld : PNewtonWorld; mode : Int); cdecl; external NewtonDLL;
function NewtonGetMultiThreadSolverOnSingleIsland (const newtonWorld : PNewtonWorld) : int; cdecl; external NewtonDLL;
procedure NewtonSetPerformanceClock (const newtonWorld : PNewtonWorld; NewtonGetTicksCountCallback : PNewtonGetTicksCountCallback); cdecl; external NewtonDLL;
function NewtonReadPerformanceTicks (const newtonWorld : PNewtonWorld; performanceEntry : cardinal) : cardinal; cdecl; external NewtonDLL;
function NewtonReadThreadPerformanceTicks (const NewtonWorld : PNewtonWorld; ThreadIndex: Cardinal) : Cardinal; cdecl; external NewtonDLL;
procedure NewtonWorldCriticalSectionLock (const newtonWorld : PNewtonWorld); cdecl; external NewtonDLL;
procedure NewtonWorldCriticalSectionUnlock (const newtonWorld : PNewtonWorld); cdecl; external NewtonDLL;
procedure NewtonSetThreadsCount (const newtonWorld : PNewtonWorld; threads : int); cdecl; external NewtonDLL;
function NewtonGetThreadsCount (const newtonWorld : PNewtonWorld) : int; cdecl; external NewtonDLL;
function NewtonGetMaxThreadsCount (const NewtonWorld : PNewtonWorld) : int; cdecl; external NewtonDLL;
procedure NewtonSetFrictionModel(const NewtonWorld : PNewtonWorld; Model : Int); cdecl; external NewtonDLL;
procedure NewtonSetMinimumFrameRate( const newtonWorld : PNewtonWorld; frameRate : float ); cdecl; external NewtonDLL;
procedure NewtonSetBodyLeaveWorldEvent( const newtonWorld : PNewtonWorld; callback : PNewtonBodyLeaveWorld ); cdecl; external NewtonDLL;
procedure NewtonSetWorldSize( const newtonWorld : PNewtonWorld; const minPoint : PFloat; const maxPoint : PFloat ); cdecl; external NewtonDLL;
procedure NewtonSetIslandUpdateEvent( const newtonWorld : PNewtonWorld; NewtonIslandUpdate : PNewtonIslandUpdate ); cdecl; external NewtonDLL;
procedure NewtonSetCollisionDestructor( const newtonWorld : PNewtonWorld; callback : PNewtonCollisionDestructor ); cdecl; external NewtonDLL;
procedure NewtonSetDestroyBodyByExeciveForce( const newtonWorld : PNewtonWorld; callback : PNewtonDestroyBodyByExeciveForce ); cdecl; external NewtonDLL;
procedure NewtonWorldForEachJointDo (const newtonWorld : PNewtonWorld; callback : PNewtonJointIterator; userData : Pointer); cdecl; external NewtonDLL;
procedure NewtonWorldForEachBodyInAABBDo (const newtonWorld : PNewtonWorld; const p0 : PFloat; const p1 : PFloat; callback : PNewtonBodyIterator; userData : Pointer); cdecl; external NewtonDLL;
procedure NewtonWorldSetUserData( const newtonWorld : PNewtonWorld; userData : Pointer); cdecl; external NewtonDLL;
function NewtonWorldGetUserData( const newtonWorld : PNewtonWorld) : Pointer; cdecl; external NewtonDLL;
procedure NewtonWorldSetDestructorCallBack( const newtonWorld : PNewtonWorld; NewtonDestroyWorld : PNewtonDestroyWorld); cdecl; external NewtonDLL;
function NewtonWorldGetDestructorCallBack( const newtonWorld : PNewtonWorld) : PNewtonDestroyWorld; cdecl; external NewtonDLL;
procedure NewtonWorldRayCast( const newtonWorld : PNewtonWorld; const p0 : PFloat; const p1 : PFloat; filter : PNewtonWorldRayFilterCallback; userData: Pointer; prefilter : NewtonWorldRayPrefilterCallback); cdecl; external NewtonDLL;
function NewtonWorldConvexCast( const newtonWorld : PNewtonWorld; const matrix : PFloat; const target : PFloat; const shape : PNewtonCollision; hitParam : PFloat; userData: Pointer; prefilter : NewtonWorldRayPrefilterCallback; info : PNewtonWorldConvexCastReturnInfo; maxContactsCount : int; threadIndex : int) : Int; cdecl; external NewtonDLL;
function NewtonWorldGetBodyCount( const newtonWorld : PNewtonWorld) : int; cdecl; external NewtonDLL;
function NewtonWorldGetConstraintCount( const newtonWorld : PNewtonWorld) : int; cdecl; external NewtonDLL;
function NewtonIslandGetBody( const island : Pointer; bodyIndex : int) : PNewtonBody; cdecl; external NewtonDLL;
procedure NewtonIslandGetBodyAABB( const island : Pointer; bodyIndex : int; p0 : PFloat; p1 : PFloat); cdecl; external NewtonDLL;
function NewtonMaterialCreateGroupID( const newtonWorld : PNewtonWorld ) : int; cdecl; external NewtonDLL;
function NewtonMaterialGetDefaultGroupID( const newtonWorld : PNewtonWorld ) : int; cdecl; external NewtonDLL;
procedure NewtonMaterialDestroyAllGroupID( const newtonWorld : PNewtonWorld ); cdecl; external NewtonDLL;
function NewtonMaterialGetUserData( const NewtonWorld: PNewtonWorld; id0: int; id1: int): Pointer; cdecl; external NewtonDLL;
procedure NewtonMaterialSetSurfaceThickness( const newtonWorld : PNewtonWorld; id0 : int; id1 : int; thickness : Float); cdecl; external NewtonDLL;
procedure NewtonMaterialSetContinuousCollisionMode (const newtonWorld : PNewtonWOrld; id0, id1, state : int); cdecl; external NewtonDLL;
procedure NewtonMaterialSetCollisionCallback( const newtonWorld : PNewtonWorld; id0 : int; id1 : int; userData : Pointer; AABBOverlap : PNewtonOnAABBOverlap; process : PNewtonContactsProcess ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetDefaultSoftness( const newtonWorld : PNewtonWorld; id0 : int; id1 : int; value : float ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetDefaultElasticity( const newtonWorld : PNewtonWorld; id0 : int; id1 : int; elasticCoef : float ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetDefaultCollidable( const newtonWorld : PNewtonWorld; id0 : int; id1 : int; state : int ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetDefaultFriction( const newtonWorld : PNewtonWorld; id0 : int; id1 : int; staticFriction : float; kineticFriction : float ); cdecl; external NewtonDLL;
function NewtonWorldGetFirstMaterial( const NewtonWorld: PNewtonWorld): PNewtonMaterial; cdecl; external NewtonDLL;
function NewtonWorldGetNextMaterial( const NewtonWorld: PNewtonWorld; const material : PNewtonMaterial): PNewtonMaterial; cdecl; external NewtonDLL;
function NewtonWorldGetFirstBody( const NewtonWorld: PNewtonWorld): PNewtonBody; cdecl; external NewtonDLL;
function NewtonWorldGetNextBody( const NewtonWorld: PNewtonWorld; const curBody : PNewtonBody): PNewtonBody; cdecl; external NewtonDLL;
function NewtonMaterialGetMaterialPairUserData( const material : PNewtonMaterial) : Pointer; cdecl; external NewtonDLL;
function NewtonMaterialGetContactFaceAttribute( const material : PNewtonMaterial) : Unsigned_int; cdecl; external NewtonDLL;
function NewtonMaterialGetBodyCollisionID( const material : PNewtonMaterial; body : PNewtonBody) : Unsigned_int; cdecl; external NewtonDLL;
function NewtonMaterialGetContactNormalSpeed( const material : PNewtonMaterial ) : float; cdecl; external NewtonDLL;
procedure NewtonMaterialGetContactForce(const Material : PNewtonMaterial; const Body : PNEwtonBody; Force : PFloat); cdecl; external NewtonDLL;
procedure NewtonMaterialGetContactPositionAndNormal(const Material : PNewtonMaterial; const Body : PNewtonBody; const Posit, Normal : PFloat); cdecl; external NewtonDLL;
procedure NewtonMaterialGetContactTangentDirections(const Material : PNewtonMaterial; const Body : PNewtonBody; const Dir0, Dir1 : PFloat); cdecl; external NewtonDLL;
function NewtonMaterialGetContactTangentSpeed( const material : PNewtonMaterial; index : int ) : float; cdecl; external NewtonDLL;
procedure NewtonMaterialSetContactSoftness( const material : PNewtonMaterial; softness : float ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetContactElasticity( const material : PNewtonMaterial; restitution : float ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetContactFrictionState( const material : PNewtonMaterial; state : int; index : int ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetContactFrictionCoef( const material : PNewtonMaterial; staticFrictionCoef,kineticFrictionCoef : float; index : int ); cdecl; external NewtonDLL;
procedure NewtonMaterialSetContactNormalAcceleration (const material : PNewtonMaterial; accel : float); cdecl; external NewtonDLL;
procedure NewtonMaterialSetContactNormalDirection(const material : PNewtonMaterial; directionVector : PFloat); cdecl; external NewtonDLL;
procedure NewtonMaterialSetContactTangentAcceleration( const material : PNewtonMaterial; accel : float; index : int ); cdecl; external NewtonDLL;
procedure NewtonMaterialContactRotateTangentDirections( const material : PNewtonMaterial; const directionVector : PFloat ); cdecl; external NewtonDLL;
function NewtonCreateNull( const newtonWorld : PNewtonWorld) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateSphere( const newtonWorld : PNewtonWorld; radiusX, radiusY, radiusZ : float; shapeID : int; const offsetMatrix : PFloat ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateBox( const newtonWorld : PNewtonWorld; dx : float; dy : float; dz : float; shapeID : int; const offsetMatrix : PFloat ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateCone( const newtonWorld : PNewtonWorld; radius : Float; height : Float; shapeID : int; const offsetMatrix : PFloat) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateCapsule( const newtonWorld : PNewtonWorld; radius : Float; height : Float; shapeID : int; const offsetMatrix : PFloat) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateCylinder( const newtonWorld : PNewtonWorld; radius : Float; height : Float; shapeID : int; const offsetMatrix : PFloat) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateChamferCylinder( const newtonWorld : PNewtonWorld; raduis : Float; height : Float; shapeID : int; const offsetMatrix : PFloat) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateConvexHull( const newtonWorld : PNewtonWorld; count : int; const vertexCloud : PFloat; strideInBytes : int; tolerance : float; shapeID : int; const offsetMatrix : PFloat) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateConvexHullFromMesh( const newtonWorld : PNewtonWorld; mesh : PNewtonMesh; tolerance : Float; shapeID : int ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateConvexHullModifier( const newtonWorld : PNewtonWorld; const convexHullCollision : PNewtonCollision; shapeID : int): PNewtonCollision; cdecl; external NewtonDLL;
procedure NewtonConvexHullModifierGetMatrix(const convexHullCollision : PNewtonCollision; matrix : PFloat); cdecl; external NewtonDLL;
procedure NewtonConvexHullModifierSetMatrix(const convexHullCollision : PNewtonCollision; const matrix : PFloat); cdecl; external NewtonDLL;
function NewtonCollisionIsTriggerVolume( const convexCollision : PNewtonCollision): int; cdecl; external NewtonDLL;
procedure NewtonCollisionSetAsTriggerVolume( const convexCollision : PNewtonCollision; trigger : int ); cdecl; external NewtonDLL;
procedure NewtonCollisionSetMaxBreakImpactImpulse( const convexHullCollision : PNewtonCollision; maxImpactImpulse : Float ); cdecl; external NewtonDLL;
function NewtonCollisionGetMaxBreakImpactImpulse( const convexHullCollision : PNewtonCollision) : Float; cdecl; external NewtonDLL;
procedure NewtonCollisionSetUserID( const convexCollision : PNewtonCollision; id : unsigned_int ); cdecl; external NewtonDLL;
function NewtonCollisionGetUserID( const convexCollision : PNewtonCollision) : unsigned_int; cdecl; external NewtonDLL;
function NewtonConvexHullGetFaceIndices( const convexHullCollision : PNewtonCollision; face : int; faceIndices : PInt) : int; cdecl; external NewtonDLL;
function NewtonConvexCollisionCalculateVolume(const convexCollision : PNewtonCollision) : Float; cdecl; external NewtonDLL;
procedure NewtonConvexCollisionCalculateInertialMatrix (const convexCollision : PNewtonCollision; inertia, origin : PFloat); cdecl; external NewtonDLL;
procedure NewtonCollisionMakeUnique (const newtonWorld : PNewtonWorld; const collision : PNewtonCollision); cdecl; external NewtonDLL;
procedure NewtonReleaseCollision( const newtonWorld : PNewtonWorld; const collision : PNewtonCollision ); cdecl; external NewtonDLL;
function NewtonAddCollisionReference( const Collision : PNewtonCollision): int; cdecl; external NewtonDLL;
function NewtonCreateCompoundCollision( const newtonWorld : PNewtonWorld; count : int; const collisionPrimitiveArray : TcollisionPrimitiveArray; shapeID : Int ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateCompoundCollisionFromMesh( const newtonWorld : PNewtonWorld; const mesh : PNewtonMesh; maxSubShapesCount : int; shapeID : Int; subShapeID : int ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateUserMeshCollision( const newtonWorld : PNewtonWorld; const minBox : PFloat; const maxBox : PFloat; userData : Pointer; collideCallback : NewtonUserMeshCollisionCollideCallback; rayHitCallback : NewtonUserMeshCollisionRayHitCallback; destroyCallback : NewtonUserMeshCollisionDestroyCallback; getInfoCallback : NewtonUserMeshCollisionGetCollisionInfo; facesInAABBCallback : NewtonUserMeshCollisionGetFacesInAABB; shapeID : Int ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateTreeCollisionFromMesh (const NewtonWorld : PNewtonWorld; const Mesh : PNewtonMesh; ShapeID : Int) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonCreateSceneCollision( const newtonWorld : PNewtonWorld; shapeID : Int ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonSceneCollisionCreateProxy( scene : PNewtonCollision; collision : PNewtonCollision ) : PNewtonSceneProxy; cdecl; external NewtonDLL;
procedure NewtonSceneCollisionDestroyProxy( scene : PNewtonCollision; Proxy : PNewtonSceneProxy ); cdecl; external NewtonDLL;
procedure NewtonSceneProxySetMatrix( Proxy : PNewtonSceneProxy; const Matrix : PFloat ); cdecl; external NewtonDLL;
procedure NewtonSceneProxyGetMatrix( Proxy : PNewtonSceneProxy; Matrix : PFloat ); cdecl; external NewtonDLL;
procedure NewtonSceneSetProxyUserData(const Proxy : PNewtonSceneProxy; UserData : Pointer); cdecl; external NewtonDLL;
function NewtonSceneGetProxyUserData(const Proxy : PNewtonSceneProxy) : Pointer; cdecl; external NewtonDLL;
function NewtonSceneGetFirstProxy(const Scene : PNewtonCollision ) : PNewtonSceneProxy; cdecl; external NewtonDLL;
function NewtonSceneGetNextProxy(const Scene : PNewtonCollision; const Proxy : PNewtonSceneProxy ) : PNewtonSceneProxy; cdecl; external NewtonDLL;
procedure NewtonSceneCollisionOptimize( scene : PNewtonCollision ); cdecl; external NewtonDLL;
function NewtonCreateCompoundBreakable( const NewtonWorld : PNewtonWorld; meshCount : int; const SolidsArray : PNewtonMesh; const ShapeIDArray : PInt; Densities : PFloat; internalFaceMaterial : PInt; ShapeID : Int; debrisID : Int; DebrisSeparationGap : Float ) : PNewtonCollision; cdecl; external NewtonDLL;
procedure NewtonCompoundBreakableResetAnchoredPieces( const compoundBreakable : PNewtonCollision ); cdecl; external NewtonDLL;
procedure NewtonCompoundBreakableSetAnchoredPieces( const compoundBreakable : PNewtonCollision; fixshapesCount : Int; matrixPallete : PFloat; fixedShapesArray : PNewtonCollision ); cdecl; external NewtonDLL;
function NewtonCompoundBreakableGetVertexCount( const compoundBreakable : PNewtonCollision ) : Int; cdecl; external NewtonDLL;
procedure NewtonCompoundBreakableGetVertexStreams( const compoundBreakable : PNewtonCollision; vertexStrideInByte : Int; Vertex : PFloat; normalStrideInByte : Int; normal : PFloat; uvStrideInByte : Int; uv : PFloat ); cdecl; external NewtonDLL;
function NewtonBreakableGetMainMesh( const compoundBreakable : PNewtonCollision ) : PNewtonBreakableComponentMesh; cdecl; external NewtonDLL;
function NewtonBreakableGetFirstComponent( const compoundBreakable : PNewtonCollision ) : PNewtonBreakableComponentMesh; cdecl; external NewtonDLL;
function NewtonBreakableGetNextComponent( const component : PNewtonBreakableComponentMesh ) : PNewtonBreakableComponentMesh; cdecl; external NewtonDLL;
procedure NewtonBreakableBeginDelete( const compoundBreakable : PNewtonCollision ); cdecl; external NewtonDLL;
function NewtonBreakableCreateDebrieBody( const compoundBreakable : PNewtonCollision; const component : PNewtonBreakableComponentMesh ) : PNewtonBody; cdecl; external NewtonDLL;
procedure NewtonBreakableDeleteComponent( const compoundBreakable : PNewtonCollision; const component : PNewtonBreakableComponentMesh ); cdecl; external NewtonDLL;
procedure NewtonBreakableEndDelete( const compoundBreakable : PNewtonCollision ); cdecl; external NewtonDLL;
function NewtonBreakableGetComponentsInRadius( const compoundBreakable : PNewtonCollision; const position : PFloat; radius : Float; Segments : PNewtonBreakableComponentMesh; maxCount : Int ) : Int; cdecl; external NewtonDLL;
function NewtonBreakableGetFirstSegment( const BreakableComponent : PNewtonBreakableComponentMesh ) : Pointer; cdecl; external NewtonDLL;
function NewtonBreakableGetNextSegment( const Segment : Pointer ) : Pointer; cdecl; external NewtonDLL;
function NewtonBreakableSegmentGetMaterial( const Segment : Pointer ) : Int; cdecl; external NewtonDLL;
function NewtonBreakableSegmentGetIndexCount( const Segment : Pointer ) : Int; cdecl; external NewtonDLL;
function NewtonBreakableSegmentGetIndexStream( CompoundBreakable : PNewtonCollision; const MeshOwner : PNewtonBreakableComponentMesh; const Segment : Pointer; Index : PInt ) : Int; cdecl; external NewtonDLL;
function NewtonBreakableSegmentGetIndexStreamShort( CompoundBreakable : PNewtonCollision; const MeshOwner : PNewtonBreakableComponentMesh; const Segment : Pointer; Index : PShort ) : Int; cdecl; external NewtonDLL;
function NewtonCreateCollisionFromSerialization( const newtonWorld : PNewtonWorld; deserializeFunction : PNewtonDeserialize; serializeHandle : Pointer ) : PNewtonCollision; cdecl; external NewtonDLL;
procedure NewtonCollisionSerialize( const newtonWorld : PNewtonWorld; const collision : PNewtonCollision; serializeFunction : PNewtonSerialize; serializeHandle : Pointer ); cdecl; external NewtonDLL;
procedure NewtonCollisionGetInfo( const collision : PNewtonCollision; collisionInfo : PNewtonCollisionInfoRecord); cdecl; external NewtonDLL;
function NewtonCreateHeightFieldCollision( const newtonWorld : PNewtonWorld; width, height, gridDiagonals : int; elevationMap : PUnsigned_short; attributeMap : P2Char; horizontalScale,verticalScale : Float; shapeID : Int) : PNewtonCollision; cdecl; external NewtonDLL;
procedure NewtonHeightFieldSetUserRayCastCallback (const TreeCollision : PNewtonCollision; RayHitCallBack : PNewtonHeightFieldRayCastCallback); cdecl; external NewtonDLL;
function NewtonCreateTreeCollision( const newtonWorld : PNewtonWorld; shapeID : Int ) : PNewtonCollision; cdecl; external NewtonDLL;
procedure NewtonTreeCollisionSetUserRayCastCallback( const treeCollision : PNewtonCollision; rayHitCallback : PNewtonCollisionTreeRayCastCallback ); cdecl; external NewtonDLL;
procedure NewtonTreeCollisionBeginBuild( const treeCollision : PNewtonCollision ); cdecl; external NewtonDLL;
procedure NewtonTreeCollisionAddFace( const treeCollision : PNewtonCollision; vertexCount : int; const vertexPtr : PFloat; strideInBytes : int; faceAttribute : int ); cdecl; external NewtonDLL;
procedure NewtonTreeCollisionEndBuild( const treeCollision : PNewtonCollision; optimize : int ); cdecl; external NewtonDLL;
function NewtonTreeCollisionGetFaceAtribute( const treeCollision : PNewtonCollision; const faceIndexArray : Pint ) : int; cdecl; external NewtonDLL;
procedure NewtonTreeCollisionSetFaceAtribute( const treeCollision : PNewtonCollision; const faceIndexArray : Pint; attribute : int ); cdecl; external NewtonDLL;
function NewtonTreeCollisionGetVertexListIndexListInAABB( const treeCollision : PNewtonCollision; const p0, p1 : PFloat; const vertexArray : PFloat; vertexCount,vertexStrideInBytes : PInt; const indexList : PInt; maxIndexCount : Int; const faceAttribute : PInt ) : int; cdecl; external NewtonDLL;
procedure NewtonStaticCollisionSetDebugCallback( const staticCollision : PNewtonCollision; userCallback : PNewtonTreeCollisionCallback ); cdecl; external NewtonDLL;
function NewtonCollisionPointDistance (const newtonWorld : PNewtonWorld; const point : PFloat; const collision : PNewtonCollision; const matrix : PFloat; contact : PFloat; normal : PFloat; threadIndex : int) : Int; cdecl; external NewtonDLL;
function NewtonCollisionClosestPoint (const newtonWorld : PNewtonWorld; const collsionA : PNewtonCollision; const matrixA : PFloat; const collisionB : PNewtonCollision; const matrixB : PFloat; contactA, contactB, normalAB : PFloat; threadIndex : int) : Int; cdecl; external NewtonDLL;
function NewtonCollisionCollide (const newtonWorld : PNewtonWorld; maxSize : Int; const collsionA : PNewtonCollision; const matrixA : PFloat; const collisionB : PNewtonCollision; const matrixB : PFloat; contacts, normals, penetration : PFloat; threadIndex : int) : Int; cdecl; external NewtonDLL;
function NewtonCollisionCollideContinue(const newtonWorld : PNewtonWorld; maxSize : Int; const timestep : Float; const collsionA : PNewtonCollision; const matrixA : PFloat; const velocA : PFloat; const omegaA : Float; const collsionB : PNewtonCollision; const matrixB : PFloat; const velocB : PFloat; const omegaB : Float; timeOfImpact : PFloat; contacts : PFloat; normals : PFloat; penetration : PFloat; threadIndex : int) : Int; cdecl; external NewtonDLL;
procedure NewtonCollisionSupportVertex( const collision : PNewtonCollision; const dir : PFloat; vertex : PFloat); cdecl; external NewtonDLL;
function NewtonCollisionRayCast(const collision : PNewtonCollision; const p0: PFloat; const p1: PFloat; normals: PFloat; attribute: pint): float; cdecl; external NewtonDLL;
procedure NewtonCollisionCalculateAABB( const collision : PNewtonCollision; const matrix : PFloat; p0 : PFloat; p1 : PFloat ); cdecl; external NewtonDLL;
procedure NewtonCollisionForEachPolygonDo (const collision : PNewtonCollision; const matrix : PFloat; callback : NewtonCollisionIterator; UserData : Pointer); cdecl; external NewtonDLL;
procedure NewtonGetEulerAngle( const matrix : PFloat; eulersAngles : PFloat ); cdecl; external NewtonDLL;
procedure NewtonSetEulerAngle( const eulersAngles : PFloat; matrix : PFloat ); cdecl; external NewtonDLL;
function NewtonCalculateSpringDamperAcceleration(dt, ks, x, kd, s : Float): float; cdecl; external NewtonDLL;
function NewtonCreateBody( const newtonWorld : PNewtonWorld; const collision : PNewtonCollision; const Matrix : PFloat) : PNewtonBody; cdecl; external NewtonDLL;
procedure NewtonDestroyBody( const newtonWorld : PNewtonWorld; const body : PNewtonBody ); cdecl; external NewtonDLL;
procedure NewtonBodyAddForce( const body : PNewtonBody; const force : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyAddTorque( const body : PNewtonBody; const torque : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyCalculateInverseDynamicsForce(const body : PNewtonBody; timestep : Float; const desiredVeloc : PFloat; forceOut : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetMatrix( const body : PNewtonBody; const matrix : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetMatrixRecursive( const body : PNewtonBody; const matrix : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetMassMatrix( const body : PNewtonBody; mass : float; Ixx : float; Iyy : float; Izz : float ); cdecl; external NewtonDLL;
procedure NewtonBodySetMaterialGroupID( const body : PNewtonBody; id : int ); cdecl; external NewtonDLL;
procedure NewtonBodySetContinuousCollisionMode(const body : PNewtonbody; state : int); cdecl; external NewtonDLL;
procedure NewtonBodySetJointRecursiveCollision( const body : PNewtonBody; state : unsigned_int ); cdecl; external NewtonDLL;
procedure NewtonBodySetOmega( const body : PNewtonBody; const omega : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetVelocity( const body : PNewtonBody; const velocity : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetForce( const body : PNewtonBody; const force : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetTorque( const body : PNewtonBody; const torque : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetCentreOfMass(const body : PNewtonBody; const com : PFloat); cdecl; external NewtonDLL;
procedure NewtonBodySetLinearDamping( const body : PNewtonBody; linearDamp : float ); cdecl; external NewtonDLL;
procedure NewtonBodySetAngularDamping( const body : PNewtonBody; const angularDamp : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodySetUserData( const body : PNewtonBody; userData : Pointer ); cdecl; external NewtonDLL;
procedure NewtonBodySetCollision( const body : PNewtonBody; const collision : PNewtonCollision ); cdecl; external NewtonDLL;
function NewtonBodyGetSleepState( const body : PNewtonBody) : Int; cdecl; external NewtonDLL;
function NewtonBodyGetAutoSleep( const body : PNewtonBody) : Int; cdecl; external NewtonDLL;
procedure NewtonBodySetAutoSleep( const body : PNewtonBody; state : int ); cdecl; external NewtonDLL;
function NewtonBodyGetFreezeState( const body : PNewtonBody) : Int; cdecl; external NewtonDLL;
procedure NewtonBodySetFreezeState( const body : PNewtonBody; state : int ); cdecl; external NewtonDLL;
procedure NewtonBodySetDestructorCallback( const body : PNewtonBody; callback : NewtonBodyDestructor ); cdecl; external NewtonDLL;
procedure NewtonBodySetTransformCallback( const body : PNewtonBody; callback : NewtonSetTransform ); cdecl; external NewtonDLL;
function NewtonBodyGetTransformCallback( const body : PNewtonBody ): NewtonSetTransform; cdecl; external NewtonDLL;
procedure NewtonBodySetForceAndTorqueCallback( const body : PNewtonBody; callback : NewtonApplyForceAndTorque ); cdecl; external NewtonDLL;
function NewtonBodyGetForceAndTorqueCallback( const body : PNewtonBody ): NewtonApplyForceAndTorque; cdecl; external NewtonDLL;
function NewtonBodyGetUserData( const body : PNewtonBody ) : Pointer; cdecl; external NewtonDLL;
function NewtonBodyGetWorld( const body : PNewtonBody) : PNewtonWorld; cdecl; external NewtonDLL;
function NewtonBodyGetCollision( const body : PNewtonBody ) : PNewtonCollision; cdecl; external NewtonDLL;
function NewtonBodyGetMaterialGroupID( const body : PNewtonBody ) : Int; cdecl; external NewtonDLL;
function NewtonBodyGetContinuousCollisionMode( const body : PNewtonBody ) : Int; cdecl; external NewtonDLL;
function NewtonBodyGetJointRecursiveCollision( const body : PNewtonBody ) : Int; cdecl; external NewtonDLL;
procedure NewtonBodyGetMatrix( const body : PNewtonBody; matrix : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetRotation( const body : PNewtonBody; rotation : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetMassMatrix( const body : PNewtonBody; mass : PFloat; Ixx : PFloat; Iyy : PFloat; Izz : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetInvMass( const body : PNewtonBody; invMass : PFloat; invIxx : PFloat; invIyy : PFloat; invIzz : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetOmega( const body : PNewtonBody; vector : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetVelocity( const body : PNewtonBody; vector : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetForce( const body : PNewtonBody; vector : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetTorque( const body : PNewtonBody; vector : PFloat); cdecl; external NewtonDLL;
procedure NewtonBodyGetForceAcc( const body : PNewtonBody; vector : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetTorqueAcc( const body : PNewtonBody; vector : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetCentreOfMass(const body : PNewtonBody; com : PFloat); cdecl; external NewtonDLL;
function NewtonBodyGetLinearDamping( const body : PNewtonBody ) : float; cdecl; external NewtonDLL;
procedure NewtonBodyGetAngularDamping( const body : PNewtonBody; vector : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetAABB( const body : PNewtonBody; p0 : PFloat; p1 : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyGetFreezeTreshold( const body : PNewtonBody; freezeSpeed2 : PFloat; freezeOmega2 : PFloat ); cdecl; external NewtonDLL;
function NewtonBodyGetFirstJoint( const body : PNewtonBody ) : PNewtonJoint; cdecl; external NewtonDLL;
function NewtonBodyGetNextJoint( const body : PNewtonBody; const joint : PNewtonJoint ) : PNewtonJoint; cdecl; external NewtonDLL;
function NewtonBodyGetFirstContactJoint( const body : PNewtonBody ) : PNewtonJoint; cdecl; external NewtonDLL;
function NewtonBodyGetNextContactJoint( const body : PNewtonBody; const contactJoint : PNewtonJoint ) : PNewtonJoint; cdecl; external NewtonDLL;
function NewtonContactJointGetFirstContact( const contactJoint : PNewtonJoint ) : Pointer; cdecl; external NewtonDLL;
function NewtonContactJointGetNextContact( const contactJoint : PNewtonJoint; contact : Pointer ) : Pointer; cdecl; external NewtonDLL;
function NewtonContactJointGetContactCount( const contactJoint : PNewtonJoint ) : int; cdecl; external NewtonDLL;
procedure NewtonContactJointRemoveContact( const contactJoint : PNewtonJoint; contact : Pointer ); cdecl; external NewtonDLL;
function NewtonContactGetMaterial( const contact : Pointer ) : PNewtonMaterial; cdecl; external NewtonDLL;
procedure NewtonBodyAddBuoyancyForce( const body : PNewtonBody; fluidDensity : float; fluidLinearViscosity, fluidAngularViscosity : float; const gravityVector : PFloat; buoyancyPlane : NewtonGetBuoyancyPlane; context : Pointer ); cdecl; external NewtonDLL;
procedure NewtonBodyAddImpulse(const body : PNewtonBody; const pointDeltaVeloc : PFloat; const pointPosit : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBodyApplyImpulseArray (const Body : PNewtonBody; ImpuleCount : Int; StrideInByte : Int; const impulseArray : PFloat; const pointArray : PFloat); cdecl; external NewtonDLL;
function NewtonJointGetUserData( const joint : PNewtonJoint ) : Pointer; cdecl; external NewtonDLL;
procedure NewtonJointSetUserData( const joint : PNewtonJoint; userData : Pointer ); cdecl; external NewtonDLL;
function NewtonJointGetBody0( const joint : PNewtonJoint ) : PNewtonBody; cdecl; external NewtonDLL;
function NewtonJointGetBody1( const joint : PNewtonJoint ) : PNewtonBody; cdecl; external NewtonDLL;
procedure NewtonJointGetInfo( const joint : PNewtonJoint; info : PNewtonJointRecord ); cdecl; external NewtonDLL;
function NewtonJointGetCollisionState( const joint : PNewtonJoint ) : int; cdecl; external NewtonDLL;
procedure NewtonJointSetCollisionState( const joint : PNewtonJoint; state : int ); cdecl; external NewtonDLL;
function NewtonJointGetStiffness( const joint : PNewtonJoint): float; cdecl; external NewtonDLL;
procedure NewtonJointSetStiffness( const joint: PNewtonJoint; state: float); cdecl; external NewtonDLL;
procedure NewtonDestroyJoint( const newtonWorld : PNewtonWorld; const joint : PNewtonJoint ); cdecl; external NewtonDLL;
procedure NewtonJointSetDestructor( const joint : PNewtonJoint; _destructor : NewtonConstraintDestructor ); cdecl; external NewtonDLL;
function NewtonConstraintCreateBall( const newtonWorld : PNewtonWorld; const pivotPoint : PFloat; const childBody : PNewtonBody; const parentBody : PNewtonBody ) : PNewtonJoint; cdecl; external NewtonDLL;
procedure NewtonBallSetUserCallback( const ball : PNewtonJoint; callback : NewtonBallCallBack ); cdecl; external NewtonDLL;
procedure NewtonBallGetJointAngle( const ball : PNewtonJoint; angle : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBallGetJointOmega( const ball : PNewtonJoint; omega : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBallGetJointForce( const ball : PNewtonJoint; force : PFloat ); cdecl; external NewtonDLL;
procedure NewtonBallSetConeLimits( const ball : PNewtonJoint; const pin : PFloat; maxConeAngle : float; maxTwistAngle : float ); cdecl; external NewtonDLL;
function NewtonConstraintCreateHinge( const newtonWorld : PNewtonWorld; const pivotPoint : PFloat; const pinDir : PFloat; const childBody : PNewtonBody; const parentBody : PNewtonBody ) : PNewtonJoint; cdecl; external NewtonDLL;
procedure NewtonHingeSetUserCallback( const hinge : PNewtonJoint; callback : NewtonHingeCallBack ); cdecl; external NewtonDLL;
function NewtonHingeGetJointAngle( const hinge : PNewtonJoint ) : float; cdecl; external NewtonDLL;
function NewtonHingeGetJointOmega( const hinge : PNewtonJoint ) : float; cdecl; external NewtonDLL;
procedure NewtonHingeGetJointForce( const hinge : PNewtonJoint; force : PFloat ); cdecl; external NewtonDLL;
function NewtonHingeCalculateStopAlpha( const hinge : PNewtonJoint; const desc : PNewtonHingeSliderUpdateDesc; angle : float ) : float; cdecl; external NewtonDLL;
function NewtonConstraintCreateSlider( const newtonWorld : PNewtonWorld; const pivotPoint : PFloat; const pinDir : PFloat; const childBody : PNewtonBody; const parentBody : PNewtonBody ) : PNewtonJoint; cdecl; external NewtonDLL;
procedure NewtonSliderSetUserCallback( const slider : PNewtonJoint; callback : NewtonSliderCallBack ); cdecl; external NewtonDLL;
function NewtonSliderGetJointPosit( const slider : PNewtonJoint ) : float; cdecl; external NewtonDLL;
function NewtonSliderGetJointVeloc( const slider : PNewtonJoint ) : float; cdecl; external NewtonDLL;
procedure NewtonSliderGetJointForce( const slider : PNewtonJoint; force : PFloat ); cdecl; external NewtonDLL;
function NewtonSliderCalculateStopAccel( const slider : PNewtonJoint; const desc : PNewtonHingeSliderUpdateDesc; position : float ) : float; cdecl; external NewtonDLL;
function NewtonConstraintCreateCorkscrew( const newtonWorld : PNewtonWorld; const pivotPoint : PFloat; const pinDir : PFloat; const childBody : PNewtonBody; const parentBody : PNewtonBody ) : PNewtonJoint; cdecl; external NewtonDLL;
procedure NewtonCorkscrewSetUserCallback( const corkscrew : PNewtonJoint; callback : NewtonCorkscrewCallBack ); cdecl; external NewtonDLL;
function NewtonCorkscrewGetJointPosit( const corkscrew : PNewtonJoint ) : float; cdecl; external NewtonDLL;
function NewtonCorkscrewGetJointAngle( const corkscrew : PNewtonJoint ) : float; cdecl; external NewtonDLL;
function NewtonCorkscrewGetJointVeloc( const corkscrew : PNewtonJoint ) : float; cdecl; external NewtonDLL;
function NewtonCorkscrewGetJointOmega( const corkscrew : PNewtonJoint ) : float; cdecl; external NewtonDLL;
procedure NewtonCorkscrewGetJointForce( const corkscrew : PNewtonJoint; force : PFloat ); cdecl; external NewtonDLL;
function NewtonCorkscrewCalculateStopAlpha(const corkscrew : PNewtonJoint;const desc : PNewtonHingeSliderUpdateDesc;angle : float) : float; cdecl; external NewtonDLL;
function NewtonCorkscrewCalculateStopAccel(const corkscrew : PNewtonJoint;const desc : PNewtonHingeSliderUpdateDesc;position : float) : float; cdecl; external NewtonDLL;
function NewtonConstraintCreateUniversal( const newtonWorld: PNewtonWorld; const pivotPoint: PFloat; const pinDir0: PFloat; const pinDir1: PFloat; const childBody: PNewtonBody; const parentBody: PNewtonBody): PNewtonJoint; cdecl; external NewtonDLL;
procedure NewtonUniversalSetUserCallback(const universal: PNewtonJoint; callback: NewtonUniversalCallback); cdecl; external NewtonDLL;
function NewtonUniversalGetJointAngle0(const universal: PNewtonJoint):float; cdecl; external NewtonDLL;
function NewtonUniversalGetJointAngle1(const universal: PNewtonJoint):float; cdecl; external NewtonDLL;
function NewtonUniversalGetJointOmega0(const universal: PNewtonJoint):float; cdecl; external NewtonDLL;
function NewtonUniversalGetJointOmega1(const universal: PNewtonJoint):float; cdecl; external NewtonDLL;
procedure NewtonUniversalGetJointForce(const universal: PNewtonJoint; force: PFloat); cdecl; external NewtonDLL;
function NewtonUniversalCalculateStopAlpha0(const universal : PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; angle: float): float; cdecl; external NewtonDLL;
function NewtonUniversalCalculateStopAlpha1(const universal : PNewtonJoint; const desc: PNewtonHingeSliderUpdateDesc; angle: float): float; cdecl; external NewtonDLL;
function NewtonConstraintCreateUpVector( const newtonWorld : PNewtonWorld; const pinDir : PFloat; const body : PNewtonBody ) : PNewtonJoint; cdecl; external NewtonDLL;
procedure NewtonUpVectorGetPin( const upVector : PNewtonJoint; pin : PFloat ); cdecl; external NewtonDLL;
procedure NewtonUpVectorSetPin( const upVector : PNewtonJoint; const pin : PFloat ); cdecl; external NewtonDLL;
function NewtonConstraintCreateUserJoint(const NewtonWorld : PNewtonWorld; MaxDOF : Integer; Callback : PNewtonUserBilateralCallBack; GetInfo : PNewtonUserBilateralGetInfoCallBack; const ChildBody: PNewtonBody; const parentBody: PNewtonBody): PNewtonJoint; cdecl; external NewtonDLL;
procedure NewtonUserJointSetFeedbackCollectorCallback(const Joint : PNewtonJoint; GetFeedback : PNewtonUserBilateralCallBack); cdecl; external NewtonDLL;
procedure NewtonUserJointAddLinearRow(const Joint : PNewtonJoint; const pivot0 : PFloat; const pivot1 : PFloat; const Dir : PFloat); cdecl; external NewtonDLL;
procedure NewtonUserJointAddAngularRow(const Joint : PNewtonJoint; RelativeAngle : Float; const Dir : PFloat); cdecl; external NewtonDLL;
procedure NewtonUserJointAddGeneralRow(const Joint : PNewtonJoint; const Jacobian0 : PFloat; const Jacobian1 : PFloat); cdecl; external NewtonDLL;
procedure NewtonUserJointSetRowMinimumFriction(const Joint : PNewtonJoint; Friction : Float); cdecl; external NewtonDLL;
procedure NewtonUserJointSetRowMaximumFriction(const Joint : PNewtonJoint; Friction : Float); cdecl; external NewtonDLL;
procedure NewtonUserJointSetRowAcceleration(const Joint : PNewtonJoint; Acceleration : Float); cdecl; external NewtonDLL;
procedure NewtonUserJointSetRowSpringDamperAcceleration(const joint : PNewtonJoint; springK : Float; springD : Float); cdecl; external NewtonDLL;
procedure NewtonUserJointSetRowStiffness(const Joint : PNewtonJoint; Stiffness : Float); cdecl; external NewtonDLL;
function NewtonUserJointGetRowForce (const Joint : PNewtonJoint; Row : Int) : Float; cdecl; external NewtonDLL;
function NewtonMeshCreate (const World : PNewtonWorld) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshCreateFromMesh(const Mesh : PNewtonMesh) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshCreateFromCollision (const collision : PNewtonCollision) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshConvexHull (const NewtonWorld : PNewtonWorld; count : int; const vertexCloud : PFloat; strideInBytes : int; tolerance : float) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshCreatePlane (const World : PNewtonWorld; const locationMatrix : PFloat; width : Float; breadth : Float; material : Int; const textureMatrix0 : PFloat; const textureMatrix1) : PNewtonMesh; cdecl; external NewtonDLL;
procedure NewtonMeshDestroy(const mesh : PNewtonMesh); cdecl; external NewtonDLL;
procedure NewtonMeshCalculateOOBB(const mesh : PNewtonMesh; const matrix : PFloat; x : PFloat; y : PFloat; z : PFloat); cdecl; external NewtonDLL;
procedure NewtonMesApplyTransform (const Mesh : PNewtonMesh; const Matrix : PFloat); cdecl; external NewtonDLL;
procedure NewtonMeshCalculateVertexNormals(const mesh : PNewtonMesh; angleInRadians : Float); cdecl; external NewtonDLL;
procedure NewtonMeshApplySphericalMapping(const mesh : PNewtonMesh; material : int); cdecl; external NewtonDLL;
procedure NewtonMeshApplyBoxMapping(const mesh : PNewtonMesh; front,side,top : int); cdecl; external NewtonDLL;
procedure NewtonMeshApplyCylindricalMapping(const mesh : PNewtonMesh; cylinderMaterial,capMaterial : int); cdecl; external NewtonDLL;
function NewtonMeshIsOpenMesh (const mesh : PNewtonMesh) : Int; cdecl; external NewtonDLL;
procedure NewtonMeshFixTJoints (const mesh : PNewtonMesh); cdecl; external NewtonDLL;
procedure NewtonMeshPolygonize (const mesh : PNewtonMesh); cdecl; external NewtonDLL;
procedure NewtonMeshTriangulate (const mesh : PNewtonMesh); cdecl; external NewtonDLL;
function NewtonMeshUnion (const mesh : PNewtonMesh; clipper : PNewtonMesh; clipperMatrix : PFloat) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshDifference (const mesh : PNewtonMesh; clipper : PNewtonMesh; clipperMatrix : PFloat) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshIntersection (const mesh : PNewtonMesh; clipper : PNewtonMesh; clipperMatrix : PFloat) : PNewtonMesh; cdecl; external NewtonDLL;
procedure NewtonMeshClip (const mesh : PNewtonMesh; const clipper : PNewtonMesh; const clippermatrix : PFloat; const topMesh : PNewtonMesh; const bottomMesh : PNewtonMesh); cdecl; external NewtonDLL;
procedure NewtonMeshPlaneClip (const Mesh : PNewtonMesh; const planeMatrix : PFloat; const PlaneTextureMatrix : PFloat; PlaneMaterial : Int; const topMesh : PNewtonMesh; const bottomMesh : PNewtonMesh); cdecl; external NewtonDLL;
function NewtonMeshConvexDecomposition (const Mesh : PNewtonMesh; MaxCount : Int) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshVoronoiDecomposition (const Mesh : PNewtonMesh; PointCount, PointStrideInBytes : Int; const PointCloud : PFloat; InternalMaterial : Int; const TextureMatrix : PFloat) : PNewtonMesh; cdecl; external NewtonDLL;
procedure NewtonRemoveUnusedVertices(const mesh : PNewtonMesh; vertexRemapTable : PInt); cdecl; external NewtonDLL;
procedure NewtonMeshBeginFace(const mesh : PNewtonMesh); cdecl; external NewtonDLL;
procedure NewtonMeshAddFace(const mesh : PNewtonMesh; vertexCount : int; const vertex : PFloat; strideInBytes,materialIndex : int ); cdecl; external NewtonDLL;
procedure NewtonMeshEndFace(const mesh : PNewtonMesh); cdecl; external NewtonDLL;
procedure NewtonMeshBuildFromVertexListIndexList(const Mesh : PNewtonMesh; FaceCount : Int; const faceIndexCount : PInt; const faceMaterialIndex : PInt; const vertex : PFloat; vertexStrideInBytes : Int; const vertexIndex : PInt; const normal : PFloat; normalStrideInBytes : Int; const normalIndex : PInt; const uv0 : PFloat; uv0StrideInBytes : Int; const uv0Index : PInt; const uv1 : PFloat; uv1StrideInBytes : Int; const uv1Index : PInt); cdecl; external NewtonDLL;
procedure NewtonMeshGetVertexStreams(const Mesh : PNewtonMesh; vertexStrideInByte : Int; Vertex : PFloat; normalStrideInByte : int; Normal : PFloat; uvStrideInByte0 : Int; uv0 : PFloat; uvStrideInByte1 : Int; uv1 : PFloat); cdecl; external NewtonDLL;
procedure NewtonMeshGetIndirectVertexStreams(const mesh : PNewtonMesh; vertexStrideInByte : int; vertex : PFloat; vertexIndices : PInt; vertexCount : PInt; normalStrideInByte : int; normal : PFloat; normalIndices : PInt; normalCount : PInt; uvStrideInByte0 : int; uv0 : PFloat; uvIndices0 : PInt; uvCount0 : PInt; uvStrideInByte1 : int; uv1 : PFloat; uvIndices1 : PInt; uvCount1 : PInt); cdecl; external NewtonDLL;
function NewtonMeshBeginHandle (const mesh : PNewtonMesh) : Pointer; cdecl; external NewtonDLL;
procedure NewtonMeshEndHandle (const mesh : PNewtonMesh; Handle : Pointer); cdecl; external NewtonDLL;
function NewtonMeshFirstMaterial (const mesh : PNewtonMesh; Handle : Pointer) : int; cdecl; external NewtonDLL;
function NewtonMeshNextMaterial (const mesh : PNewtonMesh; Handle : Pointer; materialID : int) : int; cdecl; external NewtonDLL;
function NewtonMeshMaterialGetMaterial (const mesh : PNewtonMesh; Handle : Pointer; materialID : int) : int; cdecl; external NewtonDLL;
function NewtonMeshMaterialGetIndexCount (const mesh : PNewtonMesh; Handle : Pointer; materialID : int) : int; cdecl; external NewtonDLL;
procedure NewtonMeshMaterialGetIndexStream(const mesh : PNewtonMesh; Handle : Pointer; materialID : int; index : PInt); cdecl; external NewtonDLL;
procedure NewtonMeshMaterialGetIndexStreamShort(const mesh : PNewtonMesh; Handle : Pointer; materialID : int; index : PShort); cdecl; external NewtonDLL;
function NewtonMeshCreateFirstSingleSegment (const mesh : PNewtonMesh) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshCreateNextSingleSegment (const mesh : PNewtonMesh; Segment : PNewtonMesh) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshCreateFirstLayer(const Mesh : PNewtonMesh) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshCreateNextLayer(const Mesh : PNewtonMesh; const Segment : PNewtonMesh) : PNewtonMesh; cdecl; external NewtonDLL;
function NewtonMeshGetTotalFaceCount (const mesh : PNewtonMesh) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetTotalIndexCount (const mesh : PNewtonMesh) : Int; cdecl; external NewtonDLL;
procedure NewtonMeshGetFaces (const mesh : PNewtonMesh; const faceIndexCount : PInt; faceMaterial : PInt; faceIndices : PInt); cdecl; external NewtonDLL;
function NewtonMeshGetPointCount (const Mesh : PNewtonMesh) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetPointStrideInByte (const Mesh : PNewtonMesh) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetPointArray (const Mesh : PNewtonMesh): PFloat; cdecl; external NewtonDLL;
function NewtonMeshGetNormalArray (const Mesh : PNewtonMesh) : PFloat; cdecl; external NewtonDLL;
function NewtonMeshGetUV0Array (const Mesh : PNewtonMesh) : PFloat; cdecl; external NewtonDLL;
function NewtonMeshGetUV1Array (const Mesh : PNewtonMesh) : PFloat; cdecl; external NewtonDLL;
function NewtonMeshGetVertexCount (const Mesh : PNewtonMesh) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetVertexStrideInByte (const Mesh : PNewtonMesh) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetVertexArray (const Mesh : PNewtonMesh) : PFloat; cdecl; external NewtonDLL;
function NewtonMeshGetFirstVertex (const Mesh : PNewtonMesh) : Pointer; cdecl; external NewtonDLL;
function NewtonMeshGetNextVertex (const Mesh : PNewtonMesh; const Vertex : Pointer) : Pointer; cdecl; external NewtonDLL;
function NewtonMeshGetVertexIndex (const Mesh : PNewtonMesh; const Vertex : Pointer) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetFirstPoint (const Mesh : PNewtonMesh) : Pointer; cdecl; external NewtonDLL;
function NewtonMeshGetNextPoint (const Mesh : PNewtonMesh; const point : Pointer) : Pointer; cdecl; external NewtonDLL;
function NewtonMeshGetPointIndex (const Mesh : PNewtonMesh; const point : Pointer) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetVertexIndexFromPoint (const Mesh : PNewtonMesh; const point : Pointer) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetFirstEdge (const Mesh : PNewtonMesh) : Pointer; cdecl; external NewtonDLL;
function NewtonMeshGetNextEdge (const Mesh : PNewtonMesh; const Edge : Pointer) : Pointer; cdecl; external NewtonDLL;
procedure NewtonMeshGetEdgeIndices (const Mesh : PNewtonMesh; const Edge : Pointer; v0 : PInt; v1 : PInt); cdecl; external NewtonDLL;
function NewtonMeshGetFirstFace (const Mesh : PNewtonMesh) : Pointer; cdecl; external NewtonDLL;
function NewtonMeshGetNextFace (const Mesh : PNewtonMesh; const Face : Pointer) : Pointer; cdecl; external NewtonDLL;
function NewtonMeshIsFaceOpen (const Mesh : PNewtonMesh; const Face : Pointer) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetFaceMaterial (const Mesh : PNewtonMesh; const Face : Pointer) : Int; cdecl; external NewtonDLL;
function NewtonMeshGetFaceIndexCount (const Mesh : PNewtonMesh; const Face : Pointer) : Int; cdecl; external NewtonDLL;
procedure NewtonMeshGetFaceIndices (const Mesh : PNewtonMesh; const Face : Pointer; Indices : PInt); cdecl; external NewtonDLL;
procedure NewtonMeshGetFacePointIndices (const Mesh : PNewtonMesh; const Face : Pointer; Indices : PInt); cdecl; external NewtonDLL;

Types

Float = Single;
Long_double = Extended;
Int = Integer;
__int8 = ShortInt;
__int16 = SmallInt;
__int32 = LongInt;
__int64 = Int64;
NChar = ShortInt;
Unsigned_char = Byte;
Short = SmallInt;
Unsigned_short = Word;
Long = LongInt;
Unsigned_long = LongWord;
Unsigned_int = Cardinal;
size_t = Cardinal;
CharArray = Array [0..255] of Char;
PInt = ˆInt;
P__int8 = ˆ__int8;
P__int16 = ˆ__int16;
P__int32 = ˆ__int32;
P__int64 = ˆ__int64;
P2Char = ˆNChar;
PUnsigned_char = ˆUnsigned_char;
PShort = ˆShort;
PUnsigned_short = ˆUnsigned_short;
PLong = ˆLong;
PUnsigned_long = ˆUnsigned_long;
PUnsigned_int = ˆUnsigned_int;
Psize_t = ˆsize_t;
PFloat = ˆFloat;
PLong_double = ˆLong_double;
PCharArray = ˆCharArray;
Bool = Boolean;
Pvoid = Pointer;
PBool = ˆBool;
PNewtonMesh = ˆPointer;
PNewtonBody = ˆPointer;
PNewtonWorld = ˆPointer;
PNewtonJoint = ˆPointer;
PNewtonContact = ˆPointer;
PNewtonMaterial = ˆPointer;
PNewtonCollision = ˆPointer;
PNewtonSceneProxy = ˆPointer;
PNewtonBreakableComponentMesh = ˆPointer;
PNewtonMeshVertex = ˆPointer;
PNewtonMeshEdge = ˆPointer;
PNewtonMeshFace = ˆPointer;
PNewtonMeshPoint= ˆPointer;
PNewtonUserJoint = ˆPointer;
PNewtonCollisionInfoRecord = ˆTNewtonCollisionInfoRecord;
PNewtonJointRecord = ˆNewtonJointRecord;
PNewtonUserMeshCollisionCollideDesc = ˆNewtonUserMeshCollisionCollideDesc;
PNewtonWorldConvexCastReturnInfo = ˆNewtonWorldConvexCastReturnInfo;
PNewtonUserMeshCollisionRayHitDesc = ˆNewtonUserMeshCollisionRayHitDesc;
PNewtonHingeSliderUpdateDesc = ˆNewtonHingeSliderUpdateDesc;
PNewtonAllocMemory = ˆNewtonAllocMemory;
NewtonAllocMemory = function( sizeInBytes : int ) : Pointer; cdecl;
PNewtonFreeMemory = ˆNewtonFreeMemory;
NewtonFreeMemory = procedure( ptr : Pointer; sizeInBytes : int ); cdecl;
PNewtonDestroyWorld = ˆNewtonDestroyWorld;
NewtonDestroyWorld = procedure( const NewtonWorld : PNewtonWorld ); cdecl;
PNewtonGetTicksCountCallback = ˆNewtonGetTicksCountCallback;
NewtonGetTicksCountCallback = function () : cardinal; cdecl;
PNewtonSerialize = ˆNewtonSerialize;
NewtonSerialize = procedure( serializeHandle : Pointer; const buffer : Pointer; size : size_t ); cdecl;
PNewtonDeserialize = ˆNewtonDeserialize;
NewtonDeserialize = procedure( serializeHandle : Pointer; buffer : Pointer; size : size_t ); cdecl;
PNewtonUserMeshCollisionDestroyCallback = ˆNewtonUserMeshCollisionDestroyCallback;
NewtonUserMeshCollisionDestroyCallback = procedure( descData : Pointer ); cdecl;
PNewtonUserMeshCollisionCollideCallback = ˆNewtonUserMeshCollisionCollideCallback;
NewtonUserMeshCollisionCollideCallback = procedure( NewtonUserMeshCollisionCollideDesc : PNewtonUserMeshCollisionCollideDesc ); cdecl;
PNewtonUserMeshCollisionRayHitCallback = ˆNewtonUserMeshCollisionRayHitCallback;
NewtonUserMeshCollisionRayHitCallback = function( NewtonUserMeshCollisionRayHitDesc : PNewtonUserMeshCollisionRayHitDesc ) : int; cdecl;
PNewtonUserMeshCollisionGetCollisionInfo = ˆNewtonUserMeshCollisionGetCollisionInfo;
NewtonUserMeshCollisionGetCollisionInfo = procedure( userData : Pointer; infoRecord : PNewtonCollisionInfoRecord ); cdecl;
PNewtonUserMeshCollisionGetFacesInAABB = ˆNewtonUserMeshCollisionGetFacesInAABB;
NewtonUserMeshCollisionGetFacesInAABB = function( userData : Pointer; const p0 : PFloat; const p1 : PFloat; const vertexArray : PFloat; vertexCount : pint; vertexStrideInBytes : pint; const indexList : pint; maxIndexCount : int; const userDataList : pint ) : int; cdecl;
PNewtonCollisionTreeRayCastCallback = ˆNewtonCollisionTreeRayCastCallback;
NewtonCollisionTreeRayCastCallback = function(const Body : PNewtonBody; const TreeCollision : PNewtonCollision; interception : Float; normal : PFloat; faceId : int; usedData : Pointer) : Float; cdecl;
PNewtonHeightFieldRayCastCallback = ˆNewtonHeightFieldRayCastCallback;
NewtonHeightFieldRayCastCallback = function(const Body : PNewtonBody; const HeightFieldCollision : PNewtonCollision; Interception : Float; Row, Col : Int; Normal : PFloat; FaceID : Int; UsedData : Pointer) : Float; cdecl;
PNewtonTreeCollisionCallback = ˆNewtonTreeCollisionCallback;
NewtonTreeCollisionCallback = procedure( const bodyWithTreeCollision : PNewtonBody; const body : PNewtonBody; faceID : int; const vertex : PFloat; vertexstrideInBytes : int); cdecl;
PNewtonBodyDestructor = ˆNewtonBodyDestructor;
NewtonBodyDestructor = procedure( const body : PNewtonBody ); cdecl;
PNewtonApplyForceAndTorque = ˆNewtonApplyForceAndTorque;
NewtonApplyForceAndTorque = procedure( const body : PNewtonBody; timestep : Float; threadIndex : int ); cdecl;
PNewtonSetTransform = ˆNewtonSetTransform;
NewtonSetTransform = procedure( const body : PNewtonBody; const matrix : PFloat; threadIndex : int ); cdecl;
PNewtonIslandUpdate = ˆNewtonIslandUpdate;
NewtonIslandUpdate = function(const World : PNewtonWorld; islandHandle : Pointer; bodyCount : int) : int; cdecl;
PNewtonBodyLeaveWorld = ˆNewtonBodyLeaveWorld;
NewtonBodyLeaveWorld = procedure( const body : PNewtonBody; threadIndex : int ); cdecl;
PNewtonDestroyBodyByExeciveForce = ˆNewtonDestroyBodyByExeciveForce;
NewtonDestroyBodyByExeciveForce = procedure( const body : PNewtonBody; const contact : PNewtonJoint ); cdecl;
PNewtonCollisionDestructor = ˆNewtonCollisionDestructor;
NewtonCollisionDestructor = procedure (const World : PNewtonWorld; const collision : PNewtonCollision); cdecl;
PNewtonCollisionCompoundBreakableCallback = ˆNewtonCollisionCompoundBreakableCallback;
NewtonCollisionCompoundBreakableCallback = function(const Mesh : PNewtonMesh; userData : Pointer; planeMatrixOut : PFloat) : Int; cdecl;
PNewtonGetBuoyancyPlane = ˆNewtonGetBuoyancyPlane;
NewtonGetBuoyancyPlane = function(const collisionID : Int; context : Pointer; const globalSpaceMatrix : PFloat; globalSpacePlane : PFloat ) : Int; cdecl;
PNewtonWorldRayPrefilterCallback = ˆNewtonWorldRayPrefilterCallback;
NewtonWorldRayPrefilterCallback = function (const body : PNewtonBody; const collision : PNewtonCollision; userData : Pointer) : cardinal; cdecl;
PNewtonWorldRayFilterCallback = ˆNewtonWorldRayFilterCallback;
NewtonWorldRayFilterCallback = function( const body : PNewtonBody; const hitNormal: PFloat; collisionID : Int; userData: Pointer; intersetParam: Float ) : Float; cdecl;
PNewtonOnAABBOverlap = ˆNewtonOnAABBOverlap;
NewtonOnAABBOverlap = function( const material : PNewtonMaterial; const body0 : PNewtonBody; const body1 : PNewtonBody; threadIndex : int ) : int; cdecl;
PNewtonContactsProcess = ˆNewtonContactsProcess;
NewtonContactsProcess = procedure( const contact : PNewtonJoint; timestep : Float; threadIndex : int ); cdecl;
PNewtonBodyIterator = ˆNewtonBodyIterator;
NewtonBodyIterator = procedure( const body : PNewtonBody; userData : Pointer ); cdecl;
PNewtonJointIterator = ˆNewtonJointIterator;
NewtonJointIterator = procedure( const joint : PNewtonJoint; userData : Pointer ); cdecl;
PNewtonCollisionIterator = ˆNewtonCollisionIterator;
NewtonCollisionIterator = procedure( userData : Pointer; vertexCount : int; const FaceArray : PFloat; faceId : int ); cdecl;
PNewtonBallCallBack = ˆNewtonBallCallBack;
NewtonBallCallBack = procedure( const ball : PNewtonJoint; timestep : Float ); cdecl;
PNewtonHingeCallBack = ˆNewtonHingeCallBack;
NewtonHingeCallBack = function( const hinge : PNewtonJoint; desc : PNewtonHingeSliderUpdateDesc ) : Unsigned_int; cdecl;
PNewtonSliderCallBack = ˆNewtonSliderCallBack;
NewtonSliderCallBack = function( const slider : PNewtonJoint; desc : PNewtonHingeSliderUpdateDesc ) : Unsigned_int; cdecl;
PNewtonUniversalCallBack = ˆNewtonUniversalCallBack;
NewtonUniversalCallBack = function( const universal : PNewtonJoint; desc : PNewtonHingeSliderUpdateDesc ) : Unsigned_int; cdecl;
PNewtonCorkscrewCallBack = ˆNewtonCorkscrewCallBack;
NewtonCorkscrewCallBack = function( const corkscrew : PNewtonJoint; desc : PNewtonHingeSliderUpdateDesc ) : Unsigned_int; cdecl;
PNewtonUserBilateralCallBack = ˆNewtonUserBilateralCallBack;
NewtonUserBilateralCallBack = procedure( const userJoint: PNewtonJoint; timestep : Float; threadIndex : int); cdecl;
PNewtonUserBilateralGetInfoCallBack = ˆNewtonUserBilateralGetInfoCallBack;
NewtonUserBilateralGetInfoCallBack = procedure( const userJoint : PNewtonJoint; info : PNewtonJointRecord ); cdecl;
PNewtonConstraintDestructor = ˆNewtonConstraintDestructor;
NewtonConstraintDestructor = procedure( const me : PNewtonJoint ); cdecl;
TCollisionPrimitiveArray = array of PNewtonCollision;

Constants

NewtonDLL = 'Newton.dll';
NEWTON_MAJOR_VERSION = 2;
NEWTON_MINOR_VERSION = 35;
NEWTON_PROFILER_WORLD_UPDATE = 0;
NEWTON_PROFILER_COLLISION_UPDATE = 1;
NEWTON_PROFILER_COLLISION_UPDATE_BROAD_PHASE = 2;
NEWTON_PROFILER_COLLISION_UPDATE_NARROW_PHASE = 3;
NEWTON_PROFILER_DYNAMICS_UPDATE = 4;
NEWTON_PROFILER_DYNAMICS_CONSTRAINT_GRAPH = 5;
NEWTON_PROFILER_FORCE_CALLBACK_UPDATE = 6;
NEWTON_PROFILER_DYNAMICS_SOLVE_CONSTRAINT_GRAPH = 7;
SERIALIZE_ID_BOX = 0;
SERIALIZE_ID_CONE = 1;
SERIALIZE_ID_SPHERE = 2;
SERIALIZE_ID_CAPSULE = 3;
SERIALIZE_ID_CYLINDER = 4;
SERIALIZE_ID_COMPOUND = 5;
SERIALIZE_ID_CONVEXHULL = 6;
SERIALIZE_ID_CONVEXMODIFIER = 7;
SERIALIZE_ID_CHAMFERCYLINDER = 8;
SERIALIZE_ID_TREE = 9;
SERIALIZE_ID_NULL = 10;
SERIALIZE_ID_HEIGHTFIELD = 11;
SERIALIZE_ID_USERMESH = 12;
SERIALIZE_ID_SCENE = 13;
SERIALIZE_ID_COMPOUND_BREAKABLE = 14;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: packed record TNewtonBoxParam

packed record TNewtonBoxParam

Unit

NewtonImport

Declaration

type TNewtonBoxParam = packed record

Description

Overview

Fields

m_x: float;
m_y: float;
m_z: float;

Description

Fields

m_x: float;
m_y: float;
m_z: float;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: packed record TNewtonSphereParam

packed record TNewtonSphereParam

Unit

NewtonImport

Declaration

type TNewtonSphereParam = packed record

Description

Overview

Fields

m_r0: float;
m_r1: float;
m_r2: float;

Description

Fields

m_r0: float;
m_r1: float;
m_r2: float;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: packed record TNewtonCylinderParam

packed record TNewtonCylinderParam

Unit

NewtonImport

Declaration

type TNewtonCylinderParam = packed record

Description

Overview

Fields

m_r0: float;
m_r1: float;
m_height: float;

Description

Fields

m_r0: float;
m_r1: float;
m_height: float;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: packed record TNewtonCapsuleParam

packed record TNewtonCapsuleParam

Unit

NewtonImport

Declaration

type TNewtonCapsuleParam = packed record

Description

Overview

Fields

m_r0: float;
m_r1: float;
m_height: float;

Description

Fields

m_r0: float;
m_r1: float;
m_height: float;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: packed record TNewtonConeParam

packed record TNewtonConeParam

Unit

NewtonImport

Declaration

type TNewtonConeParam = packed record

Description

Overview

Fields

m_r: float;
m_height: float;

Description

Fields

m_r: float;
m_height: float;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: packed record TNewtonChamferCylinderParam

packed record TNewtonChamferCylinderParam

Unit

NewtonImport

Declaration

type TNewtonChamferCylinderParam = packed record

Description

Overview

Fields

m_r: float;
m_height: float;

Description

Fields

m_r: float;
m_height: float;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: packed record TNewtonConvexHullParam

packed record TNewtonConvexHullParam

Unit

NewtonImport

Declaration

type TNewtonConvexHullParam = packed record

Description

Overview

Fields

m_vertexCount: Integer;
m_vertexStrideInBytes: Integer;
m_faceCount: Integer;
m_vertex: PFloat;

Description

Fields

m_vertexCount: Integer;
m_vertexStrideInBytes: Integer;
m_faceCount: Integer;
m_vertex: PFloat;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: packed record TNewtonConvexHullModifierParam

packed record TNewtonConvexHullModifierParam

Unit

NewtonImport

Declaration

type TNewtonConvexHullModifierParam = packed record

Description

Overview

Fields

m_chidren: PNewtonCollision;

Description

Fields

m_chidren: PNewtonCollision;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: packed record TNewtonCompoundCollisionParam

packed record TNewtonCompoundCollisionParam

Unit

NewtonImport

Declaration

type TNewtonCompoundCollisionParam = packed record

Description

Overview

Fields

m_chidrenCount: integer;
m_chidren: pointer;

Description

Fields

m_chidrenCount: integer;
m_chidren: pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: packed record TNewtonCollisionTreeParam

packed record TNewtonCollisionTreeParam

Unit

NewtonImport

Declaration

type TNewtonCollisionTreeParam = packed record

Description

Overview

Fields

m_vertexCount: Integer;
m_indexCount: Integer;

Description

Fields

m_vertexCount: Integer;
m_indexCount: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: packed record TNewtonHeightFieldCollisionParam

packed record TNewtonHeightFieldCollisionParam

Unit

NewtonImport

Declaration

type TNewtonHeightFieldCollisionParam = packed record

Description

Overview

Fields

m_width: integer;
m_height: integer;
m_gridsDiagonals: integer;
m_horizonalScale: float;
m_verticalScale: float;
m_elevation: pointer;
m_atributes: pchar;

Description

Fields

m_width: integer;
m_height: integer;
m_gridsDiagonals: integer;
m_horizonalScale: float;
m_verticalScale: float;
m_elevation: pointer;
m_atributes: pchar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: packed record TNewtonSceneCollisionParam

packed record TNewtonSceneCollisionParam

Unit

NewtonImport

Declaration

type TNewtonSceneCollisionParam = packed record

Description

Overview

Fields

m_childrenProxyCount: integer;

Description

Fields

m_childrenProxyCount: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: packed record TNewtonCollisionNullParam

packed record TNewtonCollisionNullParam

Unit

NewtonImport

Declaration

type TNewtonCollisionNullParam = packed record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: packed record TNewtonCollisionInfoRecord

packed record TNewtonCollisionInfoRecord

Unit

NewtonImport

Declaration

type TNewtonCollisionInfoRecord = packed record

Description

Overview

Fields

m_offsetMatrix: array[0..3,0..3] of float;
m_collisionType: integer;
m_referenceCount: integer;
m_collisionUserID: integer;
shapedatabox: TNewtonBoxParam
shapedata: TNewtonConeParam
shapedatasphere: TNewtonSphereParam
shapedatacapsule: TNewtonCapsuleParam
shapedatacylinder: TNewtonCylinderParam
shapedatacompound: TNewtonCompoundCollisionParam
shapedataconvexhull: TNewtonConvexHullParam
shapedataxonvexhull: TNewtonConvexHullModifierParam
shapedatachamfercylinder: TNewtonChamferCylinderParam
shapedatatree: TNewtonCollisionTreeParam
shapedatanull: TNewtonCollisionNullParam
shapedataheightfield: TNewtonHeightFieldCollisionParam
m_paramArray: array[0..63] of float
shapedatascenecollision: TNewtonSceneCollisionParam

Description

Fields

m_offsetMatrix: array[0..3,0..3] of float;
m_collisionType: integer;
m_referenceCount: integer;
m_collisionUserID: integer;
shapedatabox: TNewtonBoxParam
shapedata: TNewtonConeParam
shapedatasphere: TNewtonSphereParam
shapedatacapsule: TNewtonCapsuleParam
shapedatacylinder: TNewtonCylinderParam
shapedatacompound: TNewtonCompoundCollisionParam
shapedataconvexhull: TNewtonConvexHullParam
shapedataxonvexhull: TNewtonConvexHullModifierParam
shapedatachamfercylinder: TNewtonChamferCylinderParam
shapedatatree: TNewtonCollisionTreeParam
shapedatanull: TNewtonCollisionNullParam
shapedataheightfield: TNewtonHeightFieldCollisionParam
m_paramArray: array[0..63] of float
shapedatascenecollision: TNewtonSceneCollisionParam
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: record NewtonJointRecord

record NewtonJointRecord

Unit

NewtonImport

Declaration

type NewtonJointRecord = record

Description

Overview

Fields

m_attachmenMatrix_0: array[ 0..3,0..3 ] of float;
m_attachmenMatrix_1: array[ 0..3,0..3 ] of float;
m_minLinearDof: array[ 0..2 ] of float;
m_maxLinearDof: array[ 0..2 ] of float;
m_minAngularDof: array[ 0..2 ] of float;
m_maxAngularDof: array[ 0..2 ] of float;
m_attachBody_0: PNewtonBody;
m_attachBody_1: PNewtonBody;
m_extraParameters: array[ 0..15 ] of float;
m_bodiesCollisionOn: int;
m_descriptionType: array[ 0..31 ] of NChar;

Description

Fields

m_attachmenMatrix_0: array[ 0..3,0..3 ] of float;
m_attachmenMatrix_1: array[ 0..3,0..3 ] of float;
m_minLinearDof: array[ 0..2 ] of float;
m_maxLinearDof: array[ 0..2 ] of float;
m_minAngularDof: array[ 0..2 ] of float;
m_maxAngularDof: array[ 0..2 ] of float;
m_attachBody_0: PNewtonBody;
m_attachBody_1: PNewtonBody;
m_extraParameters: array[ 0..15 ] of float;
m_bodiesCollisionOn: int;
m_descriptionType: array[ 0..31 ] of NChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: record NewtonUserMeshCollisionCollideDesc

record NewtonUserMeshCollisionCollideDesc

Unit

NewtonImport

Declaration

type NewtonUserMeshCollisionCollideDesc = record

Description

Overview

Fields

m_boxP0: array[ 0..3 ] of float;
m_boxP1: array[ 0..3 ] of float;
m_threadNumber: int;
m_faceCount: int;
m_vertexStrideInBytes: int;
m_userData: Pointer;
m_vertex: ˆfloat;
m_userAttribute: ˆint;
m_faceIndexCount: ˆint;
m_faceVertexIndex: ˆint;
m_objBody: PNewtonBody;
m_polySoupBody: PNewtonBody;

Description

Fields

m_boxP0: array[ 0..3 ] of float;
m_boxP1: array[ 0..3 ] of float;
m_threadNumber: int;
m_faceCount: int;
m_vertexStrideInBytes: int;
m_userData: Pointer;
m_vertex: ˆfloat;
m_userAttribute: ˆint;
m_faceIndexCount: ˆint;
m_faceVertexIndex: ˆint;
m_objBody: PNewtonBody;
m_polySoupBody: PNewtonBody;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: record NewtonWorldConvexCastReturnInfo

record NewtonWorldConvexCastReturnInfo

Unit

NewtonImport

Declaration

type NewtonWorldConvexCastReturnInfo = record

Description

Overview

Fields

m_point: array[ 0..3 ] of float;
m_normal: array[ 0..3 ] of float;
m_normalOnHitPoint: array[ 0..3 ] of float;
m_penetration: float;
m_contactID: int;
m_hitBody: PNewtonBody;

Description

Fields

m_point: array[ 0..3 ] of float;
m_normal: array[ 0..3 ] of float;
m_normalOnHitPoint: array[ 0..3 ] of float;
m_penetration: float;
m_contactID: int;
m_hitBody: PNewtonBody;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: record NewtonUserMeshCollisionRayHitDesc

record NewtonUserMeshCollisionRayHitDesc

Unit

NewtonImport

Declaration

type NewtonUserMeshCollisionRayHitDesc = record

Description

Overview

Fields

m_p0: array[ 0..3 ] of float;
m_p1: array[ 0..3 ] of float;
m_normalOut: array[ 0..3 ] of float;
m_userIdOut: int;
m_userData: Pointer;

Description

Fields

m_p0: array[ 0..3 ] of float;
m_p1: array[ 0..3 ] of float;
m_normalOut: array[ 0..3 ] of float;
m_userIdOut: int;
m_userData: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport: record NewtonHingeSliderUpdateDesc

record NewtonHingeSliderUpdateDesc

Unit

NewtonImport

Declaration

type NewtonHingeSliderUpdateDesc = record

Description

Overview

Fields

m_accel: float;
m_minFriction: float;
m_maxFriction: float;
m_timestep: float;

Description

Fields

m_accel: float;
m_minFriction: float;
m_maxFriction: float;
m_timestep: float;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: NewtonImport_JointLibrary

Unit NewtonImport_JointLibrary

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Functions and Procedures

procedure CustomDestroyJoint( const joint : PNewtonUserJoint ); cdecl; external JointLibraryDLL;
function CustomGetNewtonJoint( const joint : PNewtonUserJoint ) : PNewtonJoint; cdecl; external JointLibraryDLL;
function CustomGetJointID( const joint : PNewtonUserJoint ) : int; cdecl; external JointLibraryDLL;
procedure CustomSetJointID( const joint : PNewtonUserJoint; rttI : int ); cdecl; external JointLibraryDLL;
function CustomGetBody0( const joint : PNewtonUserJoint ) : PNewtonBody; cdecl; external JointLibraryDLL;
function CustomGetBody1( const joint : PNewtonUserJoint ) : PNewtonBody; cdecl; external JointLibraryDLL;
function CustomGetBodiesCollisionState( const joint : PNewtonUserJoint ) : int; cdecl; external JointLibraryDLL;
procedure CustomSetBodiesCollisionState( const joint : PNewtonUserJoint; state : int ); cdecl; external JointLibraryDLL;
function CustomGetUserData( const joint : PNewtonUserJoint ) : Pointer; cdecl; external JointLibraryDLL;
procedure CustomSetUserData( const joint : PNewtonUserJoint; userData : Pointer ); cdecl; external JointLibraryDLL;
procedure CustomSetDestructorCallback( const joint : PNewtonUserJoint; callback : NewtonUserJointDestructorCallback ); cdecl; external JointLibraryDLL;
procedure CustomSetSubmitContraintCallback( const joint : PNewtonUserJoint; callback : NewtonUserJointSubmitConstraintCallback ); cdecl; external JointLibraryDLL;
function CustomCreateBlankJoint( maxDof : int; const body0 : PNewtonBody; const body1 : PNewtonBody; info : BlankJointGetInfo) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
function CreateCustomKinematicController( const targetBody : PNewtonBody; attachmentPointInGlobalSpace : PFloat ) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
procedure CustomKinematicControllerSetPickMode( const pick : PNewtonUserJoint; mode : int); cdecl; external JointLibraryDLL;
procedure CustomKinematicControllerSetMaxLinearFriction( const pick : PNewtonUserJoint; accel : Float ); cdecl; external JointLibraryDLL;
procedure CustomKinematicControllerSetMaxAngularFriction( const pick : PNewtonUserJoint; alpha : Float ); cdecl; external JointLibraryDLL;
procedure CustomKinematicControllerSetTargetPosit( const pick : PNewtonUserJoint; posit : PFloat ); cdecl; external JointLibraryDLL;
procedure CustomKinematicControllerSetTargetRotation( const pick : PNewtonUserJoint; rotation : PFloat ); cdecl; external JointLibraryDLL;
procedure CustomKinematicControllerSetTargetMatrix( const pick : PNewtonUserJoint; matrix : PFloat ); cdecl; external JointLibraryDLL;
procedure CustomKinematicControllerGetTargetMatrix( const pick : PNewtonUserJoint; matrix : PFloat ); cdecl; external JointLibraryDLL;
function CreateCustomJoint6DOF( const pinsAndPivotChildFrame : PFloat; const pinsAndPivotParentFrame : PFloat; const child : PNewtonBody; const parent : PNewtonBody ) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
procedure CustomJoint6DOF_SetLinearLimits( customJoint6DOF : PNewtonUserJoint; const minLinearLimits : PFloat; const maxLinearLimits : PFloat ); cdecl; external JointLibraryDLL;
procedure CustomJoint6DOF_SetAngularLimits( customJoint6DOF : PNewtonUserJoint; const minAngularLimits : PFloat; const maxAngularLimits : PFloat ); cdecl; external JointLibraryDLL;
procedure CustomJoint6DOF_GetLinearLimits( customJoint6DOF : PNewtonUserJoint; minLinearLimits, maxLinearLimits : PFloat ); cdecl; external JointLibraryDLL;
procedure CustomJoint6DOF_GetAngularLimits( customJoint6DOF : PNewtonUserJoint; minAngularLimits, maxAngularLimits : PFloat ); cdecl; external JointLibraryDLL;
procedure CustomJoint6DOF_SetReverseUniversal( customJoint6DOF : PNewtonUserJoint; order : int ); cdecl; external JointLibraryDLL;
function CreateCustomBallAndSocket( const pinsAndPivotChildFrame : PFloat; const child : PNewtonBody; const parent : PNewtonBody) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
procedure BallAndSocketSetConeAngle( ballJoint : PNewtonUserJoint; angle : Float ); cdecl; external JointLibraryDLL;
procedure BallAndSocketSetTwistAngle( ballJoint : PNewtonUserJoint; minAngle, maxAngle : Float ); cdecl; external JointLibraryDLL;
function CreateCustomHinge( const pinsAndPivotChildFrame : PFloat; const child : PNewtonBody; const parent : PNewtonBody ) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
procedure HingeEnableLimits( hingeJoint : PNewtonUserJoint; state : int ); cdecl; external JointLibraryDLL;
procedure HingeSetLimits( hingeJoint : PNewtonUserJoint; minAngle, maxAngle : Float ); cdecl; external JointLibraryDLL;
function HingeGetJointAngle (const hingeJoint : PNewtonUserJoint) : Float; cdecl; external JointLibraryDLL;
procedure HingeGetPinAxis (const hingeJoint : PNewtonUserJoint; Pin : PFloat); cdecl; external JointLibraryDLL;
function HingeCalculateJointOmega (const hingeJoint : PNewtonUserJoint) : Float; cdecl; external JointLibraryDLL;
function CreateCustomSlider( const pinsAndPivotChildFrame : PFloat; const child : PNewtonBody; const parent : PNewtonBody ) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
procedure SliderEnableLimits( sliderJoint : PNewtonUserJoint; state : int ); cdecl; external JointLibraryDLL;
procedure SliderSetLimits( sliderJoint : PNewtonUserJoint; mindist, maxdist : Float ); cdecl; external JointLibraryDLL;
function CreateCustomPlayerController( const pins : PFloat; const player : PNewtonBody; maxStairStepFactor, cushion : Float ) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
procedure CustomPlayerControllerSetVelocity( const playerController : PNewtonUserJoint; forwardSpeed, sideSpeed, heading : Float ); cdecl; external JointLibraryDLL;
procedure CustomPlayerControllerGetVisualMaTrix( const playerController : PNewtonUserJoint; matrix : PFloat ); cdecl; external JointLibraryDLL;
function CustomPlayerControllerGetMaxSlope( const playerController : PNewtonUserJoint ) : Float; cdecl; external JointLibraryDLL;
procedure CustomPlayerControllerSetMaxSlope( const playerController : PNewtonUserJoint; maxSlopeAngleIndRadian : Float ); cdecl; external JointLibraryDLL;
function CustomPlayerControllerGetSensorShape( const playerController : PNewtonUserJoint ) : PNewtonCollision; cdecl; external JointLibraryDLL;
function DGRaycastVehicleCreate( maxTireCount : int; const cordenateSytemInLocalSpace : PFloat; carBody : PNewtonBody ) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
procedure DGRaycastVehicleAddTire( car : PNewtonUserJoint; userData : Pointer; const localPosition : PFloat; mass, radius, width, friction, suspensionLength, springConst, springDamper : Float; castMode : int ); cdecl; external JointLibraryDLL;
procedure DGRaycastVehicleSetTireTransformCallback( car : PNewtonUserJoint; callback : DGRaycastVehicleTireTransformCallback ); cdecl; external JointLibraryDLL;
function DGRaycastVehicleGetTiresCount( car : PNewtonUserJoint ) : int; cdecl; external JointLibraryDLL;
function DGRaycastVehicleGetTiresUserData( car : PNewtonUserJoint; tireIndex : int ) : Pointer; cdecl; external JointLibraryDLL;
procedure DGRaycastVehicleGetTireMatrix( car : PNewtonUserJoint; tireIndex : int; tireMatrix : PFloat ); cdecl; external JointLibraryDLL;
procedure DGRaycastVehicleInitNormalizeTireLateralForce( car : PNewtonUserJoint; pointsCount : int; piceSizeStepAxis : PFloat; normalizedForceValue : PFloat ); cdecl; external JointLibraryDLL;
procedure DGRaycastVehicleInitNormalizeTireLongitudinalForce( car : PNewtonUserJoint; pointsCount : int; piceSizeStepAxis : PFloat; normalizedForceValue : PFloat ); cdecl; external JointLibraryDLL;

Types

NewtonUserJointDestructorCallback = procedure( const me : PNewtonUserJoint ); cdecl;
PNewtonUserJointDestructorCallback = ˆNewtonUserJointDestructorCallback;
NewtonUserJointSubmitConstraintCallback = procedure( const me : PNewtonUserJoint; timestep : Float; threadIndex : int ); cdecl;
PNewtonUserJointSubmitConstraintCallback = ˆNewtonUserJointSubmitConstraintCallback;
BlankJointGetInfo = procedure( const me : PNewtonUserJoint; info : PNewtonJointRecord ); cdecl;
PBlankJointGetInfo = ˆBlankJointGetInfo;
DGRaycastVehicleTireTransformCallback = procedure( car : PNewtonUserJoint ); cdecl;
PDGRaycastVehicleTireTransformCallback = ˆDGRaycastVehicleTireTransformCallback;

Constants

JointLibraryDLL = 'dJointLibrary.dll';

Description

Functions and Procedures

procedure CustomDestroyJoint( const joint : PNewtonUserJoint ); cdecl; external JointLibraryDLL;
function CustomGetNewtonJoint( const joint : PNewtonUserJoint ) : PNewtonJoint; cdecl; external JointLibraryDLL;
function CustomGetJointID( const joint : PNewtonUserJoint ) : int; cdecl; external JointLibraryDLL;
procedure CustomSetJointID( const joint : PNewtonUserJoint; rttI : int ); cdecl; external JointLibraryDLL;
function CustomGetBody0( const joint : PNewtonUserJoint ) : PNewtonBody; cdecl; external JointLibraryDLL;
function CustomGetBody1( const joint : PNewtonUserJoint ) : PNewtonBody; cdecl; external JointLibraryDLL;
function CustomGetBodiesCollisionState( const joint : PNewtonUserJoint ) : int; cdecl; external JointLibraryDLL;
procedure CustomSetBodiesCollisionState( const joint : PNewtonUserJoint; state : int ); cdecl; external JointLibraryDLL;
function CustomGetUserData( const joint : PNewtonUserJoint ) : Pointer; cdecl; external JointLibraryDLL;
procedure CustomSetUserData( const joint : PNewtonUserJoint; userData : Pointer ); cdecl; external JointLibraryDLL;
procedure CustomSetDestructorCallback( const joint : PNewtonUserJoint; callback : NewtonUserJointDestructorCallback ); cdecl; external JointLibraryDLL;
procedure CustomSetSubmitContraintCallback( const joint : PNewtonUserJoint; callback : NewtonUserJointSubmitConstraintCallback ); cdecl; external JointLibraryDLL;
function CustomCreateBlankJoint( maxDof : int; const body0 : PNewtonBody; const body1 : PNewtonBody; info : BlankJointGetInfo) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
function CreateCustomKinematicController( const targetBody : PNewtonBody; attachmentPointInGlobalSpace : PFloat ) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
procedure CustomKinematicControllerSetPickMode( const pick : PNewtonUserJoint; mode : int); cdecl; external JointLibraryDLL;
procedure CustomKinematicControllerSetMaxLinearFriction( const pick : PNewtonUserJoint; accel : Float ); cdecl; external JointLibraryDLL;
procedure CustomKinematicControllerSetMaxAngularFriction( const pick : PNewtonUserJoint; alpha : Float ); cdecl; external JointLibraryDLL;
procedure CustomKinematicControllerSetTargetPosit( const pick : PNewtonUserJoint; posit : PFloat ); cdecl; external JointLibraryDLL;
procedure CustomKinematicControllerSetTargetRotation( const pick : PNewtonUserJoint; rotation : PFloat ); cdecl; external JointLibraryDLL;
procedure CustomKinematicControllerSetTargetMatrix( const pick : PNewtonUserJoint; matrix : PFloat ); cdecl; external JointLibraryDLL;
procedure CustomKinematicControllerGetTargetMatrix( const pick : PNewtonUserJoint; matrix : PFloat ); cdecl; external JointLibraryDLL;
function CreateCustomJoint6DOF( const pinsAndPivotChildFrame : PFloat; const pinsAndPivotParentFrame : PFloat; const child : PNewtonBody; const parent : PNewtonBody ) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
procedure CustomJoint6DOF_SetLinearLimits( customJoint6DOF : PNewtonUserJoint; const minLinearLimits : PFloat; const maxLinearLimits : PFloat ); cdecl; external JointLibraryDLL;
procedure CustomJoint6DOF_SetAngularLimits( customJoint6DOF : PNewtonUserJoint; const minAngularLimits : PFloat; const maxAngularLimits : PFloat ); cdecl; external JointLibraryDLL;
procedure CustomJoint6DOF_GetLinearLimits( customJoint6DOF : PNewtonUserJoint; minLinearLimits, maxLinearLimits : PFloat ); cdecl; external JointLibraryDLL;
procedure CustomJoint6DOF_GetAngularLimits( customJoint6DOF : PNewtonUserJoint; minAngularLimits, maxAngularLimits : PFloat ); cdecl; external JointLibraryDLL;
procedure CustomJoint6DOF_SetReverseUniversal( customJoint6DOF : PNewtonUserJoint; order : int ); cdecl; external JointLibraryDLL;
function CreateCustomBallAndSocket( const pinsAndPivotChildFrame : PFloat; const child : PNewtonBody; const parent : PNewtonBody) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
procedure BallAndSocketSetConeAngle( ballJoint : PNewtonUserJoint; angle : Float ); cdecl; external JointLibraryDLL;
procedure BallAndSocketSetTwistAngle( ballJoint : PNewtonUserJoint; minAngle, maxAngle : Float ); cdecl; external JointLibraryDLL;
function CreateCustomHinge( const pinsAndPivotChildFrame : PFloat; const child : PNewtonBody; const parent : PNewtonBody ) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
procedure HingeEnableLimits( hingeJoint : PNewtonUserJoint; state : int ); cdecl; external JointLibraryDLL;
procedure HingeSetLimits( hingeJoint : PNewtonUserJoint; minAngle, maxAngle : Float ); cdecl; external JointLibraryDLL;
function HingeGetJointAngle (const hingeJoint : PNewtonUserJoint) : Float; cdecl; external JointLibraryDLL;
procedure HingeGetPinAxis (const hingeJoint : PNewtonUserJoint; Pin : PFloat); cdecl; external JointLibraryDLL;
function HingeCalculateJointOmega (const hingeJoint : PNewtonUserJoint) : Float; cdecl; external JointLibraryDLL;
function CreateCustomSlider( const pinsAndPivotChildFrame : PFloat; const child : PNewtonBody; const parent : PNewtonBody ) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
procedure SliderEnableLimits( sliderJoint : PNewtonUserJoint; state : int ); cdecl; external JointLibraryDLL;
procedure SliderSetLimits( sliderJoint : PNewtonUserJoint; mindist, maxdist : Float ); cdecl; external JointLibraryDLL;
function CreateCustomPlayerController( const pins : PFloat; const player : PNewtonBody; maxStairStepFactor, cushion : Float ) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
procedure CustomPlayerControllerSetVelocity( const playerController : PNewtonUserJoint; forwardSpeed, sideSpeed, heading : Float ); cdecl; external JointLibraryDLL;
procedure CustomPlayerControllerGetVisualMaTrix( const playerController : PNewtonUserJoint; matrix : PFloat ); cdecl; external JointLibraryDLL;
function CustomPlayerControllerGetMaxSlope( const playerController : PNewtonUserJoint ) : Float; cdecl; external JointLibraryDLL;
procedure CustomPlayerControllerSetMaxSlope( const playerController : PNewtonUserJoint; maxSlopeAngleIndRadian : Float ); cdecl; external JointLibraryDLL;
function CustomPlayerControllerGetSensorShape( const playerController : PNewtonUserJoint ) : PNewtonCollision; cdecl; external JointLibraryDLL;
function DGRaycastVehicleCreate( maxTireCount : int; const cordenateSytemInLocalSpace : PFloat; carBody : PNewtonBody ) : PNewtonUserJoint; cdecl; external JointLibraryDLL;
procedure DGRaycastVehicleAddTire( car : PNewtonUserJoint; userData : Pointer; const localPosition : PFloat; mass, radius, width, friction, suspensionLength, springConst, springDamper : Float; castMode : int ); cdecl; external JointLibraryDLL;
procedure DGRaycastVehicleSetTireTransformCallback( car : PNewtonUserJoint; callback : DGRaycastVehicleTireTransformCallback ); cdecl; external JointLibraryDLL;
function DGRaycastVehicleGetTiresCount( car : PNewtonUserJoint ) : int; cdecl; external JointLibraryDLL;
function DGRaycastVehicleGetTiresUserData( car : PNewtonUserJoint; tireIndex : int ) : Pointer; cdecl; external JointLibraryDLL;
procedure DGRaycastVehicleGetTireMatrix( car : PNewtonUserJoint; tireIndex : int; tireMatrix : PFloat ); cdecl; external JointLibraryDLL;
procedure DGRaycastVehicleInitNormalizeTireLateralForce( car : PNewtonUserJoint; pointsCount : int; piceSizeStepAxis : PFloat; normalizedForceValue : PFloat ); cdecl; external JointLibraryDLL;
procedure DGRaycastVehicleInitNormalizeTireLongitudinalForce( car : PNewtonUserJoint; pointsCount : int; piceSizeStepAxis : PFloat; normalizedForceValue : PFloat ); cdecl; external JointLibraryDLL;

Types

NewtonUserJointDestructorCallback = procedure( const me : PNewtonUserJoint ); cdecl;
PNewtonUserJointDestructorCallback = ˆNewtonUserJointDestructorCallback;
NewtonUserJointSubmitConstraintCallback = procedure( const me : PNewtonUserJoint; timestep : Float; threadIndex : int ); cdecl;
PNewtonUserJointSubmitConstraintCallback = ˆNewtonUserJointSubmitConstraintCallback;
BlankJointGetInfo = procedure( const me : PNewtonUserJoint; info : PNewtonJointRecord ); cdecl;
PBlankJointGetInfo = ˆBlankJointGetInfo;
DGRaycastVehicleTireTransformCallback = procedure( car : PNewtonUserJoint ); cdecl;
PDGRaycastVehicleTireTransformCallback = ˆDGRaycastVehicleTireTransformCallback;

Constants

JointLibraryDLL = 'dJointLibrary.dll';
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: O3TCImage

Unit O3TCImage

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

O3TCImage<p> Good for preview picture in OpenDialog, so you may include both O3TCImage (preview) and GLFileO3TC (loading)

<li>23/10/10 - Yar - Removed PBuffer <li>23/08/10 - Yar - Changes after PBuffer upgrade <li>21/03/10 - Yar - Added Linux support (thanks to Rustam Asmandiarov aka Predator) <li>24/01/10 - Yar - Improved FPC compatibility <li>21/01/10 - Yar - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TO3TCImage |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: O3TCImage: Class TO3TCImage

Class TO3TCImage

Unit

O3TCImage

Declaration

type TO3TCImage = class(TGLBitmap)

Description

no description available, TGLBitmap description follows

Hierarchy

  • TO3TCImage

Overview

Methods

Public | procedure LoadFromStream(stream: TStream); override;
Public | procedure SaveToStream(stream: TStream); override;

Description

Methods

Public procedure LoadFromStream(stream: TStream); override;
Public procedure SaveToStream(stream: TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: Octree

Unit Octree

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TOctreeTriangleInfo |
record TOctreeNode |
Class TOctree |

Types

TProcInt = procedure(I: Integer) of object;
TProcAffineAffineAffine = procedure(V1, V2, V3: TAffineFLTVector) of object;
POctreeTriangleInfo = ˆTOctreeTriangleInfo;
POctreeNode = ˆTOctreeNode;

Description

Types

TProcInt = procedure(I: Integer) of object;
TProcAffineAffineAffine = procedure(V1, V2, V3: TAffineFLTVector) of object;
POctreeTriangleInfo = ˆTOctreeTriangleInfo;
POctreeNode = ˆTOctreeNode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: Octree: record TOctreeTriangleInfo

record TOctreeTriangleInfo

Unit

Octree

Declaration

type TOctreeTriangleInfo = record

Description

Overview

Fields

Index: Integer;
Vertex: array [0 .. 2] of TAffineVector;

Description

Fields

Index: Integer;
Vertex: array [0 .. 2] of TAffineVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: Octree: record TOctreeNode

record TOctreeNode

Unit

Octree

Declaration

type TOctreeNode = record

Description

Overview

Fields

MinExtent: TAffineFLTVector;
MaxExtent: TAffineFLTVector;
TriArray: array of Integer;
ChildArray: array [0 .. 7] of POctreeNode;

Description

Fields

MinExtent: TAffineFLTVector;
MaxExtent: TAffineFLTVector;
TriArray: array of Integer;
ChildArray: array [0 .. 7] of POctreeNode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: Octree: Class TOctree

Class TOctree

Unit

Octree

Declaration

type TOctree = class(TObject)

Description

Hierarchy

  • TObject
  • TOctree

Overview

Fields

Public | WorldMinExtent: TAffineFLTVector;
Public | WorldMaxExtent: TAffineFLTVector;
Public | RootNode: POctreeNode;
Public | MaxOlevel: Integer;
Public | NodeCount: Integer;
Public | TriCountMesh: Integer;
Public | TriCountOctree: Integer;
Public | MeshCount: Integer;
Public | ResultArray: array of POctreeNode;
Public | TriangleFiler: TAffineVectorList;

Methods

Public | destructor Destroy; override;
Public | function AABBIntersect(const AABB: TAABB; M1to2, M2to1: TMatrix; Triangles: TAffineVectorList = nil): Boolean;
Public | function GetTrianglesFromNodesIntersectingAABB(const ObjAABB: TAABB) : TAffineVectorList;
Public | function GetTrianglesFromNodesIntersectingCube(const ObjAABB: TAABB; const ObjToSelf, SelfToObj: TMatrix): TAffineVectorList;
Public | function RayCastIntersect(const RayStart, RayVector: TVector; IntersectPoint: PVector = nil; IntersectNormal: PVector = nil; TriangleInfo: POctreeTriangleInfo = nil): Boolean;
Public | function SphereSweepIntersect(const RayStart, RayVector: TVector; const Velocity, Radius: Single; IntersectPoint: PVector = nil; IntersectNormal: PVector = nil): Boolean;
Public | function TriangleIntersect(const V1, V2, V3: TAffineVector): Boolean;
Protected | function GetExtent(const Flags: array of Byte; ParentNode: POctreeNode) : TAffineFLTVector;
Protected | function GetMidPoint(Min, Max: Single): Single;
Protected | function PointInNode(const Min, Max, APoint: TAffineFLTVector): Boolean;
Protected | function SphereInNode(const MinExtent, MaxExtent: TAffineVector; const C: TVector; Radius: Single): Boolean;
Protected | function TriIntersectNode(const MinExtent, MaxExtent, V1, V2, V3: TAffineFLTVector): BOOLEAN;
Public | procedure DisposeTree;
Public | procedure InitializeTree(const AWorldMinExtent, AWorldMaxExtent : TAffineVector; const ATriangles: TAffineVectorList; const ATreeDepth: Integer);
Public | procedure WalkSphereToLeaf(Onode: POctreeNode; const P: TVector; Radius: Single);
Protected | procedure ConvertR4(ONode: POctreeNode; const Scale: TAffineFLTVector);
Protected | procedure CreateTree(Depth: Integer);
Protected | procedure CutMesh;
Protected | procedure Refine(ParentNode: POctreeNode; Level: Integer);
Protected | procedure WalkPointToLeaf(ONode: POctreeNode; const P: TAffineVector);
Protected | procedure WalkPointToLeafx(ONode: POctreeNode; const P: TAffineVector);
Protected | procedure WalkRayToLeaf(Onode: POctreeNode; const P, V: TVector);
Protected | procedure WalkRayToLeafx(Onode: POctreeNode; const P, V: TVector);
Protected | procedure WalkSphereToLeafx(Onode: POctreeNode; const P: TVector; Radius: Single);
Protected | procedure WalkTriToLeaf(Onode: POctreeNode; const V1, V2, V3: TAffineVector);
Protected | procedure WalkTriToLeafx(Onode: POctreeNode; const V1, V2, V3: TAffineFLTVector);

Description

Fields

Public WorldMinExtent: TAffineFLTVector;
Public WorldMaxExtent: TAffineFLTVector;
Public RootNode: POctreeNode;
Public MaxOlevel: Integer;
Public NodeCount: Integer;
Public TriCountMesh: Integer;
Public TriCountOctree: Integer;
Public MeshCount: Integer;
Public ResultArray: array of POctreeNode;
Public TriangleFiler: TAffineVectorList;

Methods

Public destructor Destroy; override;
Public function AABBIntersect(const AABB: TAABB; M1to2, M2to1: TMatrix; Triangles: TAffineVectorList = nil): Boolean;
Public function GetTrianglesFromNodesIntersectingAABB(const ObjAABB: TAABB) : TAffineVectorList;
Public function GetTrianglesFromNodesIntersectingCube(const ObjAABB: TAABB; const ObjToSelf, SelfToObj: TMatrix): TAffineVectorList;
Public function RayCastIntersect(const RayStart, RayVector: TVector; IntersectPoint: PVector = nil; IntersectNormal: PVector = nil; TriangleInfo: POctreeTriangleInfo = nil): Boolean;
Public function SphereSweepIntersect(const RayStart, RayVector: TVector; const Velocity, Radius: Single; IntersectPoint: PVector = nil; IntersectNormal: PVector = nil): Boolean;
Public function TriangleIntersect(const V1, V2, V3: TAffineVector): Boolean;
Protected function GetExtent(const Flags: array of Byte; ParentNode: POctreeNode) : TAffineFLTVector;
Protected function GetMidPoint(Min, Max: Single): Single;
Protected function PointInNode(const Min, Max, APoint: TAffineFLTVector): Boolean;
Protected function SphereInNode(const MinExtent, MaxExtent: TAffineVector; const C: TVector; Radius: Single): Boolean;
Protected function TriIntersectNode(const MinExtent, MaxExtent, V1, V2, V3: TAffineFLTVector): BOOLEAN;
Public procedure DisposeTree;
Public procedure InitializeTree(const AWorldMinExtent, AWorldMaxExtent : TAffineVector; const ATriangles: TAffineVectorList; const ATreeDepth: Integer);
Public procedure WalkSphereToLeaf(Onode: POctreeNode; const P: TVector; Radius: Single);
Protected procedure ConvertR4(ONode: POctreeNode; const Scale: TAffineFLTVector);
Protected procedure CreateTree(Depth: Integer);
Protected procedure CutMesh;
Protected procedure Refine(ParentNode: POctreeNode; Level: Integer);
Protected procedure WalkPointToLeaf(ONode: POctreeNode; const P: TAffineVector);
Protected procedure WalkPointToLeafx(ONode: POctreeNode; const P: TAffineVector);
Protected procedure WalkRayToLeaf(Onode: POctreeNode; const P, V: TVector);
Protected procedure WalkRayToLeafx(Onode: POctreeNode; const P, V: TVector);
Protected procedure WalkSphereToLeafx(Onode: POctreeNode; const P: TVector; Radius: Single);
Protected procedure WalkTriToLeaf(Onode: POctreeNode; const V1, V2, V3: TAffineVector);
Protected procedure WalkTriToLeafx(Onode: POctreeNode; const V1, V2, V3: TAffineFLTVector);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:18


GLScene v.1.1.2: ODEGL

Unit ODEGL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Functions and Procedures

procedure DrawBox(Sides: TdVector3);
procedure setTransform(pos: TdVector3; R: TdMatrix3);
procedure dsDrawBox(pos: PdVector3; R: PdMatrix3; Sides: TdVector3); overload;
procedure dsDrawBox(pos: TdVector3; R: TdMatrix3; Sides: TdVector3); overload;
procedure ODERToGLSceneMatrix(var m: TMatrix; R: TdMatrix3; pos: TdVector3); overload;
procedure ODERToGLSceneMatrix(var m: TMatrix; R: PdMatrix3; pos: PdVector3); overload;
procedure ODERToGLSceneMatrix(var m: TMatrix; R: TdMatrix3_As3x4; pos: TdVector3); overload;
function GLSceneMatrixToODER(m: TMatrix): TdMatrix3;
function ConvertdVector3ToVector3f(R: TdVector3): TVector3f; overload;
function ConvertdVector3ToVector3f(R: PdVector3): TVector3f; overload;
function ConvertdVector3ToVector4f(R: TdVector3): TVector4f; overload;
function ConvertdVector3ToVector4f(R: PdVector3): TVector4f; overload;
function ConvertdVector3ToAffineVector(R: PdVector3): TAffineVector; overload;
function ConvertdVector3ToAffineVector(R: TdVector3): TAffineVector; overload;
function GetBodyPositionAsAffineVector(Body: PdxBody): TAffineVector;
function ConvertVector3fTodVector3(R: TVector3f): TdVector3;
function ConvertVector3fToPdVector3(R: TVector3f): PdVector3;
function ConvertVector4fTodVector3(R: TVector4f): TdVector3;
function ConvertVector4fToPdVector3(R: TVector4f): PdVector3;
function dVector3Length(R: TdVector3): single; overload;
function dVector3Length(R: PdVector3): single; overload;
function dBodyToBodyDistance(Body1, Body2: PdxBody): TdReal;
procedure CopyPosFromGeomToGL(Geom: PdxGeom; GLBaseSceneObject: TGLBaseSceneObject);
procedure PositionSceneObject(GLBaseSceneObject: TGLBaseSceneObject; Geom: PdxGeom);
procedure PositionSceneObjectForGeom(Geom: PdxGeom);
procedure CopyCubeSizeFromBox(Cube: TGLCube; Geom: PdxGeom);
procedure CopyBodyFromCube(Body: PdxBody; var Geom: PdxGeom; Cube: TGLCube; Space: PdxSpace);
function CreateGeomFromCube(Cube: TGLCube; Space: PdxSpace): PdxGeom;
function CreateBodyFromCube(var Geom: PdxGeom; Cube: TGLCube; World: PdxWorld; Space: PdxSpace): PdxBody;
function CreateTriMeshFromBaseMesh( GLBaseMesh: TGLBaseMesh; Space: PdxSpace; var Vertices: PdVector3Array; var Indices: PdIntegerArray): PdxGeom;
function GLMatrixFromGeom(Geom: PdxGeom): TMatrix;
function GLDirectionFromGeom(Geom: PdxGeom): TVector;
function CreateODEPlaneFromGLPlane(Plane: TGLPlane; Space: PdxSpace): PdxGeom;
procedure RenderGeomList(GeomList: TGeomList);
function RandomColorVector: TVector;

Description

Functions and Procedures

procedure DrawBox(Sides: TdVector3);
procedure setTransform(pos: TdVector3; R: TdMatrix3);
procedure dsDrawBox(pos: PdVector3; R: PdMatrix3; Sides: TdVector3); overload;
procedure dsDrawBox(pos: TdVector3; R: TdMatrix3; Sides: TdVector3); overload;
procedure ODERToGLSceneMatrix(var m: TMatrix; R: TdMatrix3; pos: TdVector3); overload;
procedure ODERToGLSceneMatrix(var m: TMatrix; R: PdMatrix3; pos: PdVector3); overload;
procedure ODERToGLSceneMatrix(var m: TMatrix; R: TdMatrix3_As3x4; pos: TdVector3); overload;
function GLSceneMatrixToODER(m: TMatrix): TdMatrix3;
function ConvertdVector3ToVector3f(R: TdVector3): TVector3f; overload;
function ConvertdVector3ToVector3f(R: PdVector3): TVector3f; overload;
function ConvertdVector3ToVector4f(R: TdVector3): TVector4f; overload;
function ConvertdVector3ToVector4f(R: PdVector3): TVector4f; overload;
function ConvertdVector3ToAffineVector(R: PdVector3): TAffineVector; overload;
function ConvertdVector3ToAffineVector(R: TdVector3): TAffineVector; overload;
function GetBodyPositionAsAffineVector(Body: PdxBody): TAffineVector;
function ConvertVector3fTodVector3(R: TVector3f): TdVector3;
function ConvertVector3fToPdVector3(R: TVector3f): PdVector3;
function ConvertVector4fTodVector3(R: TVector4f): TdVector3;
function ConvertVector4fToPdVector3(R: TVector4f): PdVector3;
function dVector3Length(R: TdVector3): single; overload;
function dVector3Length(R: PdVector3): single; overload;
function dBodyToBodyDistance(Body1, Body2: PdxBody): TdReal;
procedure CopyPosFromGeomToGL(Geom: PdxGeom; GLBaseSceneObject: TGLBaseSceneObject);
procedure PositionSceneObject(GLBaseSceneObject: TGLBaseSceneObject; Geom: PdxGeom);
procedure PositionSceneObjectForGeom(Geom: PdxGeom);
procedure CopyCubeSizeFromBox(Cube: TGLCube; Geom: PdxGeom);
procedure CopyBodyFromCube(Body: PdxBody; var Geom: PdxGeom; Cube: TGLCube; Space: PdxSpace);
function CreateGeomFromCube(Cube: TGLCube; Space: PdxSpace): PdxGeom;
function CreateBodyFromCube(var Geom: PdxGeom; Cube: TGLCube; World: PdxWorld; Space: PdxSpace): PdxBody;
function CreateTriMeshFromBaseMesh( GLBaseMesh: TGLBaseMesh; Space: PdxSpace; var Vertices: PdVector3Array; var Indices: PdIntegerArray): PdxGeom;

Note that this method requires you to manually deallocate vertices and indices when you're done with the trimesh

function GLMatrixFromGeom(Geom: PdxGeom): TMatrix;
function GLDirectionFromGeom(Geom: PdxGeom): TVector;
function CreateODEPlaneFromGLPlane(Plane: TGLPlane; Space: PdxSpace): PdxGeom;
procedure RenderGeomList(GeomList: TGeomList);
function RandomColorVector: TVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport

Unit ODEImport

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TdxJointGroup |
record TdxJointLimitMotor |
record TdMass |
record TdxAutoDisable |
record TdxDampingParameters |
record TdxContactParameters |
record TdxQuickStepParameters |
record TdObject |
record TdxJointNode |
record TJointInfo1 |
record TJointInfo2 |
record TdxJoint |
record TdxJointBall |
record TdxJointHinge |
record TdxJointUniversial |
record TdxJointPR |
record TdxJointPiston |
record TdxJointSlider |
record TdxJointHinge2 |
record TdxJointAMotor |
record TdxJointLMotor |
record TdxJointPlane2D |
record TdxJointFixed |
record TdxPosR |
record TdxBody |
Class TBodyList |
record TdxWorld |
record TdJointFeedback |
record TdSurfaceParameters |
record TdContactGeom |
record TdContact |
record TdGeomClass |
record TdxTriMeshData |
record TdxHeightfieldData |
record TdGeomSpaceData |
record TdxGeom |
Class TGeomList |
record TdxSpace |
record TdxHashSpace |
record TdxQuadTreeSpace |

Functions and Procedures

procedure dInitODE; cdecl; external ODEDLL;
function dInitODE2(uiInitFlags : longword) : integer; cdecl; external ODEDLL;
procedure dCloseODE; cdecl; external ODEDLL;
function dWorldCreate: PdxWorld; cdecl; external ODEDLL;
procedure dWorldDestroy(const World: PdxWorld); cdecl; external ODEDLL;
function dWorldGetCFM(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
function dWorldGetERP(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldGetGravity(const World: PdxWorld; var gravity: TdVector3); cdecl; external ODEDLL;
procedure dWorldSetGravity(const World: PdxWorld; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dWorldImpulseToForce(const World: PdxWorld; const stepsize, ix, iy, iz: TdReal; var force: TdVector3); cdecl; external ODEDLL;
procedure dWorldSetCFM(const World: PdxWorld; cfm: TdReal); cdecl; external ODEDLL;
procedure dWorldSetERP(const World: PdxWorld; erp: TdReal); cdecl; external ODEDLL;
procedure dWorldSetContactMaxCorrectingVel(const World: PdxWorld; const vel: TdReal); cdecl; external ODEDLL;
function dWorldGetContactMaxCorrectingVel(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetContactSurfaceLayer(const World: PdxWorld; const depth: TdReal); cdecl; external ODEDLL;
function dWorldGetContactSurfaceLayer(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldExportDIF(const World: PdxWorld; fileHandle: cardinal; const world_name:PAnsiChar); cdecl; external ODEDLL;
function dWorldGetLinearDampingThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetLinearDampingThreshold(const World: PdxWorld; const threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAngularDampingThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAngularDampingThreshold(const World: PdxWorld; const threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetLinearDamping(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetLinearDamping(const World: PdxWorld; const scale: TdReal); cdecl; external ODEDLL;
function dWorldGetAngularDamping(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAngularDamping(const World: PdxWorld; const scale: TdReal); cdecl; external ODEDLL;
procedure dWorldSetDamping(const World: PdxWorld; const linear_scale,angular_scale: TdReal); cdecl; external ODEDLL;
function dWorldGetMaxAngularSpeed(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetMaxAngularSpeed(const World: PdxWorld; const max_speed: TdReal); cdecl; external ODEDLL;
procedure dWorldStep(const World: PdxWorld; const stepsize: TdReal); cdecl; external ODEDLL;
procedure dWorldQuickStep(const World: PdxWorld; const stepsize: TdReal); cdecl; external ODEDLL;
procedure dWorldSetQuickStepNumIterations(const World: PdxWorld; const num: integer); cdecl; external ODEDLL;
function dWorldGetQuickStepNumIterations(const World: PdxWorld): integer; cdecl; external ODEDLL;
procedure dWorldSetQuickStepW(const World: PdxWorld; const param: TdReal); cdecl; external ODEDLL;
function dWorldGetQuickStepW(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldStepFast1(const World: PdxWorld; const stepsize: TdReal; const iterations: Integer); cdecl; external ODEDLL;
procedure dWorldSetAutoEnableDepthSF1(const World: PdxWorld; autodepth: Integer); cdecl; external ODEDLL;
function dWorldGetAutoEnableDepthSF1(const World: PdxWorld): Integer; cdecl; external ODEDLL;
function dWorldGetAutoDisableLinearAverageThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableLinearAverageThreshold(const World: PdxWorld; linear_average_threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableAngularAverageThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableAngularAverageThreshold(const World: PdxWorld; linear_average_threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableAverageSamplesCount(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableAverageSamplesCount(const World: PdxWorld; linear_average_threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableLinearThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableLinearThreshold(const World: PdxWorld; linThreshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableAngularThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableAngularThreshold(const World: PdxWorld; angThreshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableSteps(const World: PdxWorld): Integer; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableSteps(const World: PdxWorld; steps: Integer); cdecl; external ODEDLL;
function dWorldGetAutoDisableTime(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableTime(const World: PdxWorld; time: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableFlag(const World: PdxWorld): Integer; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableFlag(const World: PdxWorld; do_auto_disable: Integer); cdecl; external ODEDLL;
procedure dBodyAddForce(const Body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddForceAtPos(const Body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddForceAtRelPos(const Body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddRelForce(const Body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddRelForceAtPos(const Body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddRelForceAtRelPos(const Body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddRelTorque(const Body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddTorque(const Body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;
function dBodyCreate(const World: PdxWorld): PdxBody; cdecl; external ODEDLL;
procedure dBodyDestroy(const Body: PdxBody); cdecl; external ODEDLL;
procedure dBodyDisable(const Body: PdxBody); cdecl; external ODEDLL;
procedure dBodyEnable(const Body: PdxBody); cdecl; external ODEDLL;
function dBodyGetAngularVel(const Body: PdxBody): PdVector3; cdecl; external ODEDLL;
procedure dBodyGetFiniteRotationAxis(const Body: PdxBody; var result: TdVector3); cdecl; external ODEDLL;
function dBodyGetFiniteRotationMode(const Body: PdxBody): Integer; cdecl; external ODEDLL;
function dBodyGetForce(const Body: PdxBody): PdVector3; cdecl; external ODEDLL;
function dBodyGetGravityMode(const Body: PdxBody): Integer; cdecl; external ODEDLL;
function dBodyGetJoint(const Body: PdxBody; const index: Integer): TdJointID; cdecl; external ODEDLL;
function dBodyGetLinearVel(const Body: PdxBody): PdVector3; cdecl; external ODEDLL;
procedure dBodyGetMass(const Body: PdxBody; var mass: TdMass); cdecl; external ODEDLL;
function dBodyGetNumJoints(const Body: PdxBody): Integer; cdecl; external ODEDLL;
procedure dBodyGetPointVel(const Body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
procedure dBodyGetPosRelPoint(const Body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
function dBodyGetPosition(const Body: PdxBody): PdVector3; cdecl; external ODEDLL;
function dBodyGetQuaternion(const Body: PdxBody): PdQuaternion; cdecl; external ODEDLL;
procedure dBodyGetRelPointPos(const Body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
procedure dBodyGetRelPointVel(const Body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
function dBodyGetRotation(const Body: PdxBody): PdMatrix3; cdecl; external ODEDLL;
function dBodyGetTorque(const Body: PdxBody): PdVector3; cdecl; external ODEDLL;
function dBodyIsEnabled(const Body: PdxBody): Integer; cdecl; external ODEDLL;
procedure dBodySetAngularVel(const Body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetFiniteRotationAxis(const Body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetFiniteRotationMode(const Body: PdxBody; const mode: Integer); cdecl; external ODEDLL;
procedure dBodySetForce(const Body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetGravityMode(const Body: PdxBody; const mode: Integer); cdecl; external ODEDLL;
procedure dBodySetLinearVel(const Body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetMass( const Body: PdxBody; const mass: PdMass); cdecl; external ODEDLL;
procedure dBodySetPosition(const Body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetQuaternion(const Body: PdxBody; const q: TdQuaternion); cdecl; external ODEDLL;
procedure dBodySetRotation(const Body: PdxBody; const R: TdMatrix3); cdecl; external ODEDLL;
procedure dBodySetTorque(const Body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodyVectorFromWorld(const Body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
procedure dBodyVectorToWorld(const Body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
procedure dBodySetData (const Body: PdxBody; data : pointer); cdecl; external ODEDLL;
function dBodyGetData (const Body: PdxBody) : pointer; cdecl; external ODEDLL;
procedure dBodySetMovedCallback (const Body: PdxBody; Callback : TdMovedCallback); cdecl; external ODEDLL;
procedure dBodyCopyPosition(const Body: PdxBody; const pos: TdVector3); cdecl; external ODEDLL;
procedure dBodyCopyRotation(const Body: PdxBody; const R: TdMatrix3); cdecl; external ODEDLL;
procedure dBodyCopyQuaternion(const Body: PdxBody; const quat: TdQuaternion); cdecl; external ODEDLL;
procedure dBodySetLinearDamping (const Body: PdxBody; scale : TdReal); cdecl; external ODEDLL;
function dBodyGetLinearDamping (const Body: PdxBody) : TdReal; cdecl; external ODEDLL;
procedure dBodySetAngularDamping(const Body: PdxBody; scale : TdReal); cdecl; external ODEDLL;
function dBodyGetAngularDamping(const Body: PdxBody) : TdReal; cdecl; external ODEDLL;
procedure dBodySetDamping(const Body: PdxBody; linear_scale, angular_scale : TdReal); cdecl; external ODEDLL;
function dBodyGetLinearDampingThreshold(const Body: PdxBody) : TdReal; cdecl; external ODEDLL;
procedure dBodySetLinearDampingThreshold(const Body: PdxBody; threshold : TdReal); cdecl; external ODEDLL;
function dBodyGetAngularDampingThreshold(const Body: PdxBody) : TdReal; cdecl; external ODEDLL;
procedure dBodySetAngularDampingThreshold(const Body: PdxBody; threshold : TdReal); cdecl; external ODEDLL;
procedure dBodySetDampingDefaults(const Body: PdxBody; threshold : TdReal); cdecl; external ODEDLL;
procedure dBodySetMaxAngularSpeed(const Body: PdxBody; max_speed : TdReal); cdecl; external ODEDLL;
function dBodyGetMaxAngularSpeed(const Body: PdxBody) : TdReal; cdecl; external ODEDLL;
function dBodyGetAutoDisableLinearThreshold(const Body: PdxBody): TdReal; cdecl; external ODEDLL;
procedure dBodySetAutoDisableLinearThreshold(const Body: PdxBody; linThreshold: TdReal); cdecl; external ODEDLL;
function dBodyGetAutoDisableAngularThreshold(const Body: PdxBody): TdReal; cdecl; external ODEDLL;
procedure dBodySetAutoDisableAngularThreshold(const Body: PdxBody; angThreshold: TdReal); cdecl; external ODEDLL;
function dBodyGetAutoDisableSteps(const Body: PdxBody): Integer; cdecl; external ODEDLL;
procedure dBodySetAutoDisableSteps(const Body: PdxBody; steps: Integer); cdecl; external ODEDLL;
function dBodyGetAutoDisableTime(const Body: PdxBody): TdReal; cdecl; external ODEDLL;
procedure dBodySetAutoDisableTime(const Body: PdxBody; time: TdReal); cdecl; external ODEDLL;
function dBodyGetAutoDisableFlag(const Body: PdxBody): Integer; cdecl; external ODEDLL;
procedure dBodySetAutoDisableFlag(const Body: PdxBody; do_auto_disable: Integer); cdecl; external ODEDLL;
procedure dBodySetAutoDisableDefaults(const Body: PdxBody); cdecl; external ODEDLL;
procedure dBodySetAutoDisableAverageSamplesCount(const Body: PdxBody; average_samples_count : longword); cdecl; external ODEDLL;
procedure dJointGroupDestroy(const dJointGroupID : TdJointGroupID); cdecl; external ODEDLL;
function dJointGroupCreate(const max_size: Integer): TdJointGroupID; cdecl; external ODEDLL;
procedure dJointGroupEmpty(const dJointGroupID : TdJointGroupID); cdecl; external ODEDLL;
procedure dJointAttach(const dJointID : TdJointID; const body1, body2: PdxBody); cdecl; external ODEDLL;
procedure dJointDestroy(const dJointID : TdJointID); cdecl; external ODEDLL;
function dJointGetData (const dJointID : TdJointID) : pointer; cdecl; external ODEDLL;
procedure dJointSetData (const dJointID : TdJointID; data : Pointer); cdecl; external ODEDLL;
procedure dJointSetFeedback (const dJointID : TdJointID; Feedback : PTdJointFeedback); cdecl; external ODEDLL;
function dJointGetFeedback (const dJointID : TdJointID) : PTdJointFeedback; cdecl; external ODEDLL;
function dJointGetType(const dJointID : TdJointID): Integer; cdecl; external ODEDLL;
function dJointGetBody(const dJointID : TdJointID; const index: Integer): PdxBody; cdecl; external ODEDLL;
function dJointCreateContact(const World : PdxWorld; dJointGroupID : TdJointGroupID; const dContact: PdContact): TdJointID; cdecl; external ODEDLL;
function dJointCreateAMotor(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetAMotorAngle(const dJointID : TdJointID; const anum: Integer; const angle: TdReal); cdecl; external ODEDLL;
function dJointGetAMotorAngle(const dJointID : TdJointID; const anum: Integer): TdReal; cdecl; external ODEDLL;
procedure dJointSetAMotorAxis(const dJointID : TdJointID; const anum, rel: Integer; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetAMotorAxis(const dJointID : TdJointID; const anum: Integer; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetAMotorNumAxes(const dJointID : TdJointID; const num: Integer); cdecl; external ODEDLL;
function dJointGetAMotorNumAxes(const dJointID : TdJointID): Integer; cdecl; external ODEDLL;
procedure dJointSetAMotorParam(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetAMotorParam(const dJointID : TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
procedure dJointSetAMotorMode(const dJointID : TdJointID; const mode: TdAngularMotorModeNumbers); cdecl; external ODEDLL;
function dJointGetAMotorMode(const dJointID : TdJointID): Integer; cdecl; external ODEDLL;
procedure dJointAddAMotorTorques (const dJointID : TdJointID; torque1, torque2, torque3: TdReal); cdecl; external ODEDLL;
function dJointGetAMotorAngleRate(const dJointID : TdJointID; const anum: Integer): TdReal; cdecl; external ODEDLL;
function dJointGetAMotorAxisRel(const dJointID : TdJointID; const anum: Integer): Integer; cdecl; external ODEDLL;
function dJointCreateLMotor(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetLMotorAxis(const dJointID : TdJointID; const anum, rel: Integer; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetLMotorAxis(const dJointID : TdJointID; const anum: Integer; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetLMotorNumAxes(const dJointID : TdJointID; const num: Integer); cdecl; external ODEDLL;
function dJointGetLMotorNumAxes(const dJointID : TdJointID): Integer; cdecl; external ODEDLL;
procedure dJointSetLMotorParam(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetLMotorParam(const dJointID : TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointCreateBall(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetBallAnchor(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetBallAnchor(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetBallAnchor2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
function dJointCreateHinge(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetHingeAnchor(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHingeAnchor(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetHingeAnchor2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHingeAxis(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHingeAxis(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHingeParam(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetHingeParam(const dJointID : TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointGetHingeAngle(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetHingeAngleRate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
procedure dJointAddHingeTorque (const dJointID : TdJointID; torque: TdReal); cdecl; external ODEDLL;
function dJointCreateHinge2(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetHinge2Anchor(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHinge2Anchor(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetHinge2Anchor2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHinge2Axis1(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHinge2Axis1(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHinge2Axis2(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHinge2Axis2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHinge2Param(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetHinge2Param(const dJointID : TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointGetHinge2Angle1(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetHinge2Angle1Rate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetHinge2Angle2Rate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
procedure dJointAddHinge2Torques (const dJointID : TdJointID; torque1, torque2: TdReal); cdecl; external ODEDLL;
procedure dJointCorrectHinge2(const dJointID : TdJointID); cdecl; external ODEDLL;
function dJointCreateSlider(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetSliderAxis(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetSliderAxis(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetSliderParam(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetSliderParam(const dJointID : TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointGetSliderPosition(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetSliderPositionRate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
procedure dJointAddSliderForce (const dJointID : TdJointID; force: TdReal); cdecl; external ODEDLL;
function dJointCreateUniversal(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointGetUniversalAnchor(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetUniversalAnchor2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetUniversalAxis1(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetUniversalAxis1(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetUniversalAxis2(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetUniversalAxis2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetUniversalParam(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetUniversalParam(const dJointID : TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointGetUniversalAngle1(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetUniversalAngle2(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetUniversalAngle1Rate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetUniversalAngle2Rate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
procedure dJointSetUniversalAnchor(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointAddUniversalTorques (const dJointID : TdJointID; torque1, torque2: TdReal); cdecl; external ODEDLL;
function dJointCreateFixed(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetFixed(const dJointID : TdJointID); cdecl; external ODEDLL;
function dJointCreatePlane2D(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetPlane2DXParam(const dJointID : TdJointID; const parameter: Integer; const value: TdReal); cdecl; external ODEDLL;
procedure dJointSetPlane2DYParam(const dJointID : TdJointID; const parameter: Integer; const value: TdReal); cdecl; external ODEDLL;
procedure dJointSetPlane2DAngleParam(const dJointID : TdJointID; const parameter: Integer; const value: TdReal); cdecl; external ODEDLL;
function dJointCreatePR(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetPRAnchor(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointSetPRAxis1(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetPRAxis1(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetPRAxis2(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetPRAxis2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetPRParam(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetPRParam(const dJointID : TdJointID; parameter: integer): TdReal; cdecl; external ODEDLL;
procedure dJointAddPRTorque (const dJointID : TdJointID; torque: TdReal); cdecl; external ODEDLL;
function dJointCreatePiston(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetPistonAnchor(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetPistonAnchor(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetPistonAnchor2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetPistonAxis(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetPistonAxis(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetPistonParam(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetPistonParam(const dJointID : TdJointID; parameter : integer): TdReal; cdecl; external ODEDLL;
procedure dJointSetPistonAxisDelta(const dJointID : TdJointID; const x, y, z, ax, ay, az: TdReal); cdecl; external ODEDLL;
procedure dJointAddPistonForce (const dJointID : TdJointID; force: TdReal); cdecl; external ODEDLL;
function dJointGetPistonPosition(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetPistonAngle(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetPistonAngleRate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetPistonRate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dCreateGeom (classnum : Integer) : PdxGeom; cdecl; external ODEDLL;
procedure dGeomDestroy(const Geom : PdxGeom); cdecl; external ODEDLL;
function dCreateGeomClass(const classptr : TdGeomClass) : Integer; cdecl; external ODEDLL;
function dGeomGetClass(const Geom : PdxGeom): Integer; cdecl; external ODEDLL;
function dGeomGetClassData(o : PdxGeom) : Pointer; cdecl; external ODEDLL;
function dGeomGetSpace(const Geom : PdxGeom): PdxSpace; cdecl; external ODEDLL;
function dGeomIsSpace (const Geom : PdxGeom) : integer; cdecl; external ODEDLL;
procedure dGeomSetBody(const Geom : PdxGeom; Body: PdxBody); cdecl; external ODEDLL;
function dGeomGetBody(const Geom : PdxGeom): PdxBody; cdecl; external ODEDLL;
procedure dGeomSetPosition(const Geom : PdxGeom; const x, y, z: TdReal); cdecl; external ODEDLL;
function dGeomGetPosition(const Geom : PdxGeom): PdVector3; cdecl; external ODEDLL;
procedure dGeomSetRotation(const Geom : PdxGeom; const R: TdMatrix3); cdecl; external ODEDLL;
function dGeomGetRotation(const Geom : PdxGeom): PdMatrix3; cdecl; external ODEDLL;
procedure dGeomSetQuaternion(const Geom : PdxGeom; const TdQuaternion); cdecl; external ODEDLL;
procedure dGeomGetQuaternion(const Geom : PdxGeom; var result: TdQuaternion); cdecl; external ODEDLL;
procedure dGeomCopyPosition(const Geom : PdxGeom; const pos: TdVector3); cdecl; external ODEDLL;
procedure dGeomCopyRotation(const Geom : PdxGeom; const R: TdMatrix3); cdecl; external ODEDLL;
procedure dGeomCopyQuaternion(const Geom : PdxGeom; const quat: TdQuaternion); cdecl; external ODEDLL;
procedure dGeomSetData (const Geom : PdxGeom; data : pointer); cdecl; external ODEDLL;
function dGeomGetData (const Geom : PdxGeom) : pointer; cdecl; external ODEDLL;
procedure dGeomEnable (const Geom : PdxGeom); cdecl; external ODEDLL;
procedure dGeomDisable (const Geom : PdxGeom); cdecl; external ODEDLL;
function dGeomIsEnabled (const Geom : PdxGeom) : integer; cdecl; external ODEDLL;
procedure dGeomGetAABB(const Geom : PdxGeom; var aabb: TdAABB); cdecl; external ODEDLL;
procedure dGeomSetCategoryBits (const Geom : PdxGeom; bits : Cardinal); cdecl; external ODEDLL;
function dGeomGetCategoryBits (const Geom : PdxGeom) : cardinal; cdecl; external ODEDLL;
procedure dGeomSetCollideBits (const Geom : PdxGeom; bits : Cardinal); cdecl; external ODEDLL;
function dGeomGetCollideBits (const Geom : PdxGeom) : cardinal; cdecl; external ODEDLL;
procedure dGeomSetOffsetPosition (const Geom : PdxGeom; x,y,z:TdReal); cdecl; external ODEDLL;
function dGeomGetOffsetPosition(const Geom : PdxGeom): PdVector3; cdecl; external ODEDLL;
procedure dGeomSetOffsetRotation (const Geom : PdxGeom; R:TdMatrix3); cdecl; external ODEDLL;
function dGeomGetOffsetRotation(const Geom : PdxGeom): PdVector3; cdecl; external ODEDLL;
procedure dGeomSetOffsetQuaternion (const Geom : PdxGeom; const Q:TdQuaternion); cdecl; external ODEDLL;
procedure dGeomGetOffsetQuaternion (const Geom : PdxGeom; var Q:TdQuaternion); cdecl; external ODEDLL;
procedure dGeomClearOffset (const Geom : PdxGeom); cdecl; external ODEDLL;
procedure dGeomSetOffsetWorldPosition (const Geom : PdxGeom; x,y,z:TdReal); cdecl; external ODEDLL;
procedure dGeomSetOffsetWorldRotation (const Geom : PdxGeom; R:TdMatrix3); cdecl; external ODEDLL;
procedure dGeomSetOffsetWorldQuaternion (const Geom : PdxGeom; const Q:TdQuaternion); cdecl; external ODEDLL;
procedure dGeomCopyOffsetPosition(const Geom : PdxGeom; var pos: TdVector3); cdecl; external ODEDLL;
procedure dGeomCopyOffsetRotation(const Geom : PdxGeom; var R: TdMatrix3); cdecl; external ODEDLL;
procedure dGeomIsOffset (const Geom : PdxGeom); cdecl; external ODEDLL;
function dCreateGeomTransform(const Space : PdxSpace): PdxGeom; cdecl; external ODEDLL name 'dCreateGeomTransform';
procedure dGeomTransformSetGeom(const Geom, obj: PdxGeom); cdecl; external ODEDLL;
function dGeomTransformGetGeom(const Geom : PdxGeom): PdxGeom; cdecl; external ODEDLL;
procedure dGeomTransformSetInfo (const Geom : PdxGeom; mode : integer); cdecl; external ODEDLL;
function dGeomTransformGetInfo (const Geom : PdxGeom) : integer; cdecl; external ODEDLL;
procedure dGeomTransformSetCleanup(const Geom : PdxGeom; const mode: Integer); cdecl; external ODEDLL;
function dGeomTransformGetCleanup(const Geom : PdxGeom): Integer; cdecl; external ODEDLL;
function dCreateBox(const Space : PdxSpace; const lx, ly, lz: TdReal): PdxGeom; cdecl; external ODEDLL name 'dCreateBox';
procedure dGeomBoxGetLengths(const Geom : PdxGeom; var result: TdVector3); cdecl; external ODEDLL;
procedure dGeomBoxSetLengths(const Geom : PdxGeom; const lx, ly, lz: TdReal); cdecl; external ODEDLL;
function dGeomBoxPointDepth (const Geom : PdxGeom; const x,y,z : TdReal) : TdReal; cdecl; external ODEDLL;
function dCreateCylinder(const Space : PdxSpace; r, lz : TdReal) : PdxGeom; cdecl; external ODEDLL name 'dCreateCylinder';
procedure dGeomCylinderSetParams (const Geom : PdxGeom; radius, length : TdReal); cdecl; external ODEDLL;
procedure dGeomCylinderGetParams (const Geom : PdxGeom; var radius, length : TdReal); cdecl; external ODEDLL;
function dCreateCapsule(const Space : PdxSpace; const radius, length: TdReal): PdxGeom; cdecl; external ODEDLL name 'dCreateCapsule';
procedure dGeomCapsuleSetParams(const Geom : PdxGeom; const radius, length: TdReal); cdecl; external ODEDLL;
procedure dGeomCapsuleGetParams(const Geom : PdxGeom; var radius, length: TdReal); cdecl; external ODEDLL;
function dGeomCapsulePointDepth (const Geom : PdxGeom; const x,y,z : TdReal) : TdReal; cdecl; external ODEDLL;
function dCreatePlane(const Space : PdxSpace; const a, b, c, d: TdReal): PdxGeom; cdecl; external ODEDLL name 'dCreatePlane';
procedure dGeomPlaneSetParams (const Geom : PdxGeom; const a, b, c, d: TdReal); cdecl; external ODEDLL;
procedure dGeomPlaneGetParams(const Geom : PdxGeom; var result: TdVector4); cdecl; external ODEDLL;
function dGeomPlanePointDepth (const Geom : PdxGeom; const x,y,z : TdReal) : TdReal; cdecl; external ODEDLL;
function dCreateSphere(const Space : PdxSpace; const radius: TdReal): PdxGeom; cdecl; external ODEDLL name 'dCreateSphere';
procedure dGeomSphereSetRadius(const Geom : PdxGeom; const radius: TdReal); cdecl; external ODEDLL;
function dGeomSphereGetRadius(const Geom : PdxGeom): TdReal; cdecl; external ODEDLL;
function dGeomSpherePointDepth (const Geom : PdxGeom; const x,y,z : TdReal) : TdReal; cdecl; external ODEDLL;
function dCreateConvex(const Space : PdxSpace; _planes: PdReal; _planecount: longword; _points : PdReal; _pointcount: longword; const _polygons:longword): PdxGeom; cdecl; external ODEDLL;
procedure dGeomSetConvex(const Geom: PdxGeom; _planes: PdReal; _planecount: longword; _points : PdReal; _pointcount: longword; const _polygons:longword); cdecl; external ODEDLL;
function dCreateHeightfield(const Space : PdxSpace; Data: PdxHeightfieldData; bPlaceable:Integer): PdxGeom; cdecl; external ODEDLL;
function dGeomHeightfieldDataCreate: PdxHeightfieldData; cdecl; external ODEDLL;
procedure dGeomHeightfieldDataDestroy(Data: PdxHeightfieldData); cdecl; external ODEDLL;
procedure dGeomHeightfieldSetHeightfieldData(const Geom : PdxGeom; Data: PdxHeightfieldData); cdecl; external ODEDLL;
function dGeomHeightfieldGetHeightfieldData(const Geom : PdxGeom):PdxHeightfieldData; cdecl; external ODEDLL;
function dGeomHeightfieldDataSetBounds (Data: PdxHeightfieldData; minHeight, MaxHeight : TdReal) : TdReal; cdecl; external ODEDLL;
function dCreateRay(const Space : PdxSpace; length : TdReal) : PdxGeom; cdecl; external ODEDLL name 'dCreateRay';
procedure dGeomRaySet(const Geom : PdxGeom; px, py, pz, dx, dy, dz: TdReal); cdecl; external ODEDLL;
procedure dGeomRayGet(const Geom : PdxGeom; var start, dir: TdVector3); cdecl; external ODEDLL;
procedure dGeomRaySetLength(const Geom : PdxGeom; length: TdReal); cdecl; external ODEDLL;
function dGeomRayGetLength(const Geom : PdxGeom) : TdReal; cdecl; external ODEDLL;
procedure dGeomRaySetParams(const Geom : PdxGeom; FirstContact, BackfacCull: integer); cdecl; external ODEDLL;
procedure dGeomRayGetParams(const Geom : PdxGeom; var FirstContact, BackfacCull: integer); cdecl; external ODEDLL;
procedure dGeomRaySetClosestHit(const Geom : PdxGeom; closestHit: Integer); cdecl; external ODEDLL;
function dGeomRayGetClosestHit(const Geom : PdxGeom) : Integer; cdecl; external ODEDLL;
function dCreateTriMesh(const Space : PdxSpace; Data: PdxTriMeshData; Callback:TdTriCallback; ArrayCallback:TdTriArrayCallback; RayCallback: TdTriRayCallback): PdxGeom; cdecl; external ODEDLL;
procedure dGeomTriMeshSetData(g: PdxGeom; Data: PdxTriMeshData); cdecl; external ODEDLL;
function dGeomTriMeshGetData(g: PdxGeom):PdxTriMeshData; cdecl; external ODEDLL;
function dGeomTriMeshGetTriMeshDataID(g: PdxGeom) : PdxTriMeshData; cdecl; external ODEDLL;
procedure dGeomTriMeshDataUpdate(g: PdxTriMeshData); cdecl; external ODEDLL;
function dGeomTriMeshIsTCEnabled(g: PdxGeom; geomClass: Integer): Integer; cdecl; external ODEDLL;
procedure dGeomTriMeshEnableTC(g: PdxGeom; geomClass, enable: Integer); cdecl; external ODEDLL;
procedure dGeomTriMeshClearTCCache(g: PdxGeom); cdecl; external ODEDLL;
function dGeomTriMeshGetTriangleCount(g: PdxGeom) : integer; cdecl; external ODEDLL;
procedure dGeomTriMeshGetTriangle(g: PdxGeom; Index: Integer; v0, v1, v2: PdVector3); cdecl; external ODEDLL;
procedure dGeomTriMeshGetPoint(g: PdxGeom; Index: Integer; u, v: TdReal; result: TdVector3); cdecl; external ODEDLL;
function dGeomTriMeshGetArrayCallback(g: PdxGeom): Pointer; cdecl; external ODEDLL;
function dGeomTriMeshGetRayCallback(g: PdxGeom): Pointer; cdecl; external ODEDLL;
procedure dGeomTriMeshSetArrayCallback(g: PdxGeom; ArrayCallback: Pointer); cdecl; external ODEDLL;
procedure dGeomTriMeshSetRayCallback(g: PdxGeom; RayCallback: Pointer); cdecl; external ODEDLL;
procedure dGeomTriMeshSetCallback(g: PdxGeom; Callback: Pointer); cdecl; external ODEDLL;
function dGeomTriMeshGetCallback(g: PdxGeom): Pointer; cdecl; external ODEDLL;
procedure dGeomTriMeshDataDestroy(g: PdxTriMeshData); cdecl; external ODEDLL;
function dGeomTriMeshDataCreate: PdxTriMeshData; cdecl; external ODEDLL;
procedure dGeomTriMeshDataSet(g: PdxTriMeshData; data_id: Integer; data: Pointer); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildSimple(g: PdxTriMeshData; Vertices: PdVector3Array; VertexCount: Integer; Indices: PdIntegerArray; IndexCount: Integer); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildSimple1(g: PdxTriMeshData; Vertices: PdVector3Array; VertexCount: Integer; Indices: PdIntegerArray; IndexCount: Integer; Normals: PdVector3Array); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildDouble(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildDouble1(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer; Normals: PdVector3Array); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildSingle(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildSingle1(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer; Normals: PdVector3Array); cdecl; external ODEDLL;
procedure dInfiniteAABB(geom : PdxGeom; var aabb : TdAABB); cdecl; external ODEDLL;
procedure dSpaceDestroy(const Space: PdxSpace); cdecl; external ODEDLL;
function dSimpleSpaceCreate(Space : PdxSpace): PdxSpace; cdecl; external ODEDLL;
function dHashSpaceCreate(Space : PdxSpace): PdxSpace; cdecl; external ODEDLL;
function dQuadTreeSpaceCreate(const Space : PdxSpace; const Center, Extents : TdVector3; const Depth : Integer): PdxSpace; cdecl; external ODEDLL;
procedure dSpaceAdd(const Space : PdxSpace; const Geom : PdxGeom); cdecl; external ODEDLL;
procedure dSpaceRemove(const Space : PdxSpace; const Geom : PdxGeom); cdecl; external ODEDLL;
procedure dSpaceClean (const Space : PdxSpace); cdecl; external ODEDLL;
function dSpaceQuery (const Space : PdxSpace; const Geom : PdxGeom): Integer; cdecl; external ODEDLL;
function dSpaceGetNumGeoms (const Space: PdxSpace) : integer; cdecl; external ODEDLL;
function dSpaceGetGeom (const Space: PdxSpace; const i: Integer) : PdxGeom; cdecl; external ODEDLL;
procedure dHashSpaceSetLevels(const Space: PdxSpace; const minlevel, maxlevel: Integer); cdecl; external ODEDLL;
procedure dHashSpaceGetLevels(const Space: PdxSpace; var minlevel, maxlevel: Integer); cdecl; external ODEDLL;
procedure dSpaceSetCleanup (space : PdxSpace; const mode : integer); cdecl; external ODEDLL;
function dSpaceGetCleanup(Space : PdxSpace): integer; cdecl; external ODEDLL;
function dCollide (o1, o2 : PdxGeom; flags : integer; var Contact : TdContactGeom; Skip : integer) : integer; cdecl; external ODEDLL;
procedure dSpaceCollide (const Space : PdxSpace; data : pointer; callback : TdNearCallback); cdecl; external ODEDLL;
procedure dSpaceCollide2 (o1, o2 : PdxGeom; data : pointer; callback : TdNearCallback); cdecl; external ODEDLL;
procedure dMassSetParameters(var m: TdMass; themass, cgx, cgy, cgz, I11, I22, I33, I12, I13, I23: TdReal); cdecl; external ODEDLL;
procedure dMassAdd(var a,b : TdMass); cdecl; external ODEDLL;
procedure dMassAdjust(var m: TdMass; newmass: TdReal); cdecl; external ODEDLL;
procedure dMassTranslate(var m: TdMass; x, y, z: TdReal); cdecl; external ODEDLL;
procedure dMassRotate(var m: TdMass; var R: TdMatrix3); cdecl; external ODEDLL;
procedure dMassSetZero(var m: TdMass); cdecl; external ODEDLL;
procedure dMassSetBox(var m: TdMass; density, lx, ly, lz: TdReal); cdecl; external ODEDLL;
procedure dMassSetBoxTotal(var m: TdMass; total_mass, lx, ly, lz: TdReal); cdecl; external ODEDLL;
procedure dMassSetCylinder(var m: TdMass; density: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;
procedure dMassSetCylinderTotal(var m: TdMass; total_mass: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;
procedure dMassSetCapsule(var m: TdMass; density: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;
procedure dMassSetCapsuleTotal(var m: TdMass; total_mass: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;
procedure dMassSetSphere(var m: TdMass; density, radius: TdReal); cdecl; external ODEDLL;
procedure dMassSetSphereTotal(var m: TdMass; total_mass, radius: TdReal); cdecl; external ODEDLL;
procedure dMassSetTrimesh(var m: TdMass; density: TdReal; trimesh:PdxGeom); cdecl; external ODEDLL;
procedure dMassSetTrimeshTotal(var m: TdMass; total_mass: TdReal; trimesh:PdxGeom); cdecl; external ODEDLL;
procedure dQFromAxisAndAngle (var q : TdQuaternion; const ax, ay ,az, angle : TdReal); cdecl; external ODEDLL;
procedure dRFromAxisAndAngle (var R : TdMatrix3; const ax, ay ,az, angle : TdReal); cdecl; external ODEDLL;
procedure dRSetIdentity (var R : TdMatrix3); cdecl; external ODEDLL;
procedure dQSetIdentity (var Q : TdQuaternion); cdecl; external ODEDLL;
procedure dRFromEulerAngles (var R : TdMatrix3; const phi, theta, psi : TdReal); cdecl; external ODEDLL;
procedure dRFrom2Axes (var R: TdMatrix3; const ax, ay, az, bx, by, bz : TdReal); cdecl; external ODEDLL;
procedure dRFromZAxis (var R: TdMatrix3; const ax, ay, az : TdReal); cdecl; external ODEDLL;
procedure dMultiply0 (const A : PdReal; const B, C : PdReal; p, q, r : integer); cdecl; external ODEDLL;
procedure dMultiply1 (const A : PdReal; const B, C : PdReal; p, q, r : integer); cdecl; external ODEDLL;
procedure dMultiply2 (const A : PdReal; const B, C : PdReal; p, q, r : integer); cdecl; external ODEDLL;
procedure dQMultiply0 (var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;
procedure dQMultiply1 (var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;
procedure dQMultiply2 (var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;
procedure dQMultiply3 (var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;
procedure dRfromQ (var R : TdMatrix3; const q : TdQuaternion); cdecl; external ODEDLL;
procedure dQfromR (var q : TdQuaternion; const R : TdMatrix3); cdecl; external ODEDLL;
procedure dDQfromW (var dq : TdVector4; const w : TdVector3; const q: TdQuaternion); cdecl; external ODEDLL;
procedure dNormalize3 (var a : TdVector3); cdecl; external ODEDLL;
procedure dNormalize4 (var a : TdVector4); cdecl; external ODEDLL;
procedure dClosestLineSegmentPoints (const a1, a2, b1, b2 : TdVector3; var cp1, cp2 : TdVector3); cdecl; external ODEDLL;
function dBoxTouchesBox (const _p1 : TdVector3; const R1 : TdMatrix3; const side1 : TdVector3; const _p2 : TdVector3; const R2 : TdMatrix3; const side2 : TdVector3) : integer; cdecl; external ODEDLL;
function dMaxDifference (A, B : PdReal; n, m : integer) : TdReal; cdecl; external ODEDLL;
procedure dMakeRandomVector(var n1 : TdVector3; a : integer; f : TdReal); cdecl; external ODEDLL;
function dAreConnected (a, b : PdxBody) : integer; cdecl; external ODEDLL;
function dAreConnectedExcluding (a, b : PdxBody; joint_type : TdJointTypeNumbers) : integer; cdecl; external ODEDLL;
procedure dMakeRandomMatrix (A : PdRealArray; n, m : integer; range : TdReal); cdecl; external ODEDLL;
procedure dClearUpperTriangle (A : PdRealArray; n : integer); cdecl; external ODEDLL;
function dRandGetSeed: Cardinal; cdecl; external ODEDLL;
procedure dRandSetSeed (const s: Cardinal); cdecl; external ODEDLL;
function dRandInt (const n: Integer): Integer; cdecl; external ODEDLL;
function dRandReal: TdReal; cdecl; external ODEDLL;
function dTestRand: Integer; cdecl; external ODEDLL;
procedure dTestMatrixComparison; cdecl; external ODEDLL;
procedure dTestSolveLCP; cdecl; external ODEDLL;
function dDot (const a, b : TdVector3) : TdReal; overload;
function dDot (const a, b : PdVector3) : TdReal; overload;
function dDOT14(const a,b : TdRealArray) : TdReal; overload;
function dDOT14(const a,b : PdRealArray) : TdReal; overload;
procedure dMULTIPLY0_333(var A : TdMatrix3; const B,C : TdMatrix3);
procedure dMULTIPLY0_331(var A : TdVector3; const B : TdMatrix3; const C : TdVector3);
function Vector3ScalarMul(const a : TdVector3; const Scalar : TdReal) : TdVector3;
function Vector3ADD(const a, b : TdVector3) : TdVector3;
function Vector3SUB(const a, b : TdVector3) : TdVector3;
function Vector3Length(const a : TdVector3) : TdReal;
function Vector3Cross(const V1, V2 : TdVector3) : TdVector3;
function Vector3Make(const x,y,z : TdReal) : TdVector3;
procedure VerifyDelphiODE(Body : PdxBody; Geom : PdxGeom);
function InitODE(ADllName : PChar) : boolean;
procedure CloseODE;

Types

TJointFlag = Integer;
TdContactType = Integer;
TBodyFlags = Integer;
TdReal = single;
PdReal = ˆTdReal;
PdxJointGroup = ˆTdxJointGroup;
TdJointGroupID = PdxJointGroup;
PdxJointLimitMotor = ˆTdxJointLimitMotor;
TdRealArray = array[0..15] of TdReal;
PdRealArray = ˆTdRealArray;
TdVector3 = array[0..3] of TdReal;
PdVector3 = ˆTdVector3;
Pd3Axis = ˆTd3Axis;
Td3Axis = array[0..2] of TdVector3;
PdInteger3 = ˆTdInteger3;
TdInteger3 = array[0..2] of integer;
PdxJointLimitMotor3 = ˆTdxJointLimitMotor3;
TdxJointLimitMotor3 = array[0..2] of TdxJointLimitMotor;
TdVector4 = array[0..3] of TdReal;
PdVector4 = ˆTdVector4;
TdMatrix3 = array[0..4*3-1] of TdReal;
PdMatrix3 = ˆTdMatrix3;
TdMatrix3_As3x4 = array[0..2, 0..3] of TdReal;
PdMatrix3_As3x4 = ˆTdMatrix3_As3x4;
TdMatrix4 = array[0..4*4-1] of TdReal;
PdMatrix4 = ˆTdMatrix4;
TdMatrix6 = array[0..8*6-1] of TdReal;
PdMatrix6 = ˆTdMatrix6;
TdQuaternion = TdVector4;
PdQuaternion = ˆTdQuaternion;
TdAABB = array[0..5] of TdReal;
PdMass = ˆTdMass;
PdxGeom = ˆTdxGeom;
PPdxGeom = ˆPdxGeom;
TdMovedCallback = procedure(o1: PdxGeom); cdecl;
TdTriCallback = function(TriMesh,RefObject : PdxGeom; TriangleIndex : integer) : integer;
TdTriArrayCallback = procedure(TriMesh,RefObject : PdxGeom; TriIndices:PIntegerArray; TriCount : integer);
TdTriRayCallback = function(TriMesh,Ray : PdxGeom; TriangleIndex : integer; u,v:TdReal) : integer;
PdxWorld = ˆTdxWorld;
PdObject = ˆTdObject;
PPdObject = ˆPdObject;
PdxBody = ˆTdxBody;
PdxJoint= ˆTdxJoint;
TdJointID = PdxJoint;
PdxJointNode = ˆTdxJointNode;
TdxJointNull = TdxJoint;
PdxJointBall = ˆTdxJointBall;
PdxJointHinge = ˆTdxJointHinge;
PdxJointUniversial = ˆTdxJointUniversial;
PdxJointPR = ˆTdxJointPR;
PdxJointPiston = ˆTdxJointPiston;
PdxJointSlider = ˆTdxJointSlider;
PdxJointHinge2 = ˆTdxJointHinge2;
PdxPosR = ˆTdxPosR;
PTdJointFeedback = ˆTdJointFeedback;
TdErrorType = (...);
TdJointTypeNumbers = (...);
TdAngularMotorModeNumbers = (...);
PdContactGeom = ˆTdContactGeom;
PdContact = ˆTdContact;
TdNearCallback = procedure(data : pointer; o1, o2 : PdxGeom); cdecl;
TdColliderFn = function(o1, o2 : PdxGeom; flags : Integer; contact : PdContactGeom; skip : Integer) : Integer; cdecl;
TdGetColliderFnFn = function(num : Integer) : TdColliderFn; cdecl;
TdGetAABBFn = procedure(g : PdxGeom; var aabb : TdAABB); cdecl;
TdGeomDtorFn = procedure(o : PdxGeom); cdecl;
TdAABBTestFn = function(o1, o2 : PdxGeom; const aabb2 : TdAABB) : Integer; cdecl;
PdGeomClass = ˆTdGeomClass;
PdxSpace = ˆTdxSpace;
TdRealHugeArray = array[0..65535] of TdReal;
PdRealHugeArray = ˆTdRealHugeArray;
TdIntegerArray = array[0..65535] of Integer;
PdIntegerArray = ˆTdIntegerArray;
TdVector3Array = array[0..65535] of TdVector3;
PdVector3Array = ˆTdVector3Array;
PdxTriMeshData = ˆTdxTriMeshData;
PdxHeightfieldData = ˆTdxHeightfieldData;
PdxSimpleSpace = ˆTdxSimpleSpace;
PdxHashSpace = ˆTdxHashSpace;
TdxSimpleSpace = TdxSpace;
TJointParams = Integer;

Constants

ODEDLL = 'ode_single.dll';
TRIMESH_FACE_NORMALS = 0;
TRIMESH_LAST_TRANSFORMATION = 1;
CONTACTS_UNIMPORTANT = $80000000;
dJOINT_INGROUP: TJointFlag = 1;
dJOINT_REVERSE: TJointFlag = 2;
dJOINT_TWOBODIES: TJointFlag = 4;
dContactMu2: TdContactType = $0001;
dContactFDir1: TdContactType = $0002;
dContactBounce: TdContactType = $0004;
dContactSoftERP: TdContactType = $0008;
dContactSoftCFM: TdContactType = $0010;
dContactMotion1: TdContactType = $0020;
dContactMotion2: TdContactType = $0040;
dContactMotionN: TdContactType = $0080;
dContactSlip1: TdContactType = $0100;
dContactSlip2: TdContactType = $0200;
dContactApprox0: TdContactType = $0000;
dContactApprox1_1: TdContactType = $1000;
dContactApprox1_2: TdContactType = $2000;
dContactApprox1: TdContactType = $3000;
dxBodyFlagFiniteRotation: TBodyFlags = 1;
dxBodyFlagFiniteRotationAxis: TBodyFlags = 2;
dxBodyDisabled: TBodyFlags = 4;
dxBodyNoGravity: TBodyFlags = 8;
_priv_dParamLoStop = $000;
_priv_dParamLoStop2 = $100;
_priv_dParamLoStop3 = $200;
dParamLoStop: TJointParams = _priv_dParamLoStop;
dParamHiStop: TJointParams = _priv_dParamLoStop + 1;
dParamVel: TJointParams = _priv_dParamLoStop + 2;
dParamFMax: TJointParams = _priv_dParamLoStop + 3;
dParamFudgeFactor: TJointParams = _priv_dParamLoStop + 4;
dParamBounce: TJointParams = _priv_dParamLoStop + 5;
dParamCFM: TJointParams = _priv_dParamLoStop + 6;
dParamStopERP: TJointParams = _priv_dParamLoStop + 7;
dParamStopCFM: TJointParams = _priv_dParamLoStop + 8;
dParamSuspensionERP: TJointParams = _priv_dParamLoStop + 9;
dParamSuspensionCFM: TJointParams = _priv_dParamLoStop + 10;
dParamERP: TJointParams = _priv_dParamLoStop + 11;
dParamGroup1: TJointParams = $000;
dParamLoStop1: TJointParams = _priv_dParamLoStop;
dParamHiStop1: TJointParams = _priv_dParamLoStop + 1;
dParamVel1: TJointParams = _priv_dParamLoStop + 2;
dParamFMax1: TJointParams = _priv_dParamLoStop + 3;
dParamFudgeFactor1: TJointParams = _priv_dParamLoStop + 4;
dParamBounce1: TJointParams = _priv_dParamLoStop + 5;
dParamCFM1: TJointParams = _priv_dParamLoStop + 6;
dParamStopERP1: TJointParams = _priv_dParamLoStop + 7;
dParamStopCFM1: TJointParams = _priv_dParamLoStop + 8;
dParamSuspensionERP1: TJointParams = _priv_dParamLoStop + 9;
dParamSuspensionCFM1: TJointParams = _priv_dParamLoStop + 10;
dParamERP1: TJointParams = _priv_dParamLoStop + 11;
dParamGroup2: TJointParams = $100;
dParamLoStop2: TJointParams = _priv_dParamLoStop2;
dParamHiStop2: TJointParams = _priv_dParamLoStop2 + 1;
dParamVel2: TJointParams = _priv_dParamLoStop2 + 2;
dParamFMax2: TJointParams = _priv_dParamLoStop2 + 3;
dParamFudgeFactor2: TJointParams = _priv_dParamLoStop2 + 4;
dParamBounce2: TJointParams = _priv_dParamLoStop2 + 5;
dParamCFM2: TJointParams = _priv_dParamLoStop2 + 6;
dParamStopERP2: TJointParams = _priv_dParamLoStop2 + 7;
dParamStopCFM2: TJointParams = _priv_dParamLoStop2 + 8;
dParamSuspensionERP2: TJointParams = _priv_dParamLoStop2 + 9;
dParamSuspensionCFM2: TJointParams = _priv_dParamLoStop2 + 10;
dParamERP2: TJointParams = _priv_dParamLoStop2 + 11;
dParamGroup3: TJointParams = $200;
dParamLoStop3: TJointParams = _priv_dParamLoStop3;
dParamHiStop3: TJointParams = _priv_dParamLoStop3 + 1;
dParamVel3: TJointParams = _priv_dParamLoStop3 + 2;
dParamFMax3: TJointParams = _priv_dParamLoStop3 + 3;
dParamFudgeFactor3: TJointParams = _priv_dParamLoStop3 + 4;
dParamBounce3: TJointParams = _priv_dParamLoStop3 + 5;
dParamCFM3: TJointParams = _priv_dParamLoStop3 + 6;
dParamStopERP3: TJointParams = _priv_dParamLoStop3 + 7;
dParamStopCFM3: TJointParams = _priv_dParamLoStop3 + 8;
dParamSuspensionERP3: TJointParams = _priv_dParamLoStop3 + 9;
dParamSuspensionCFM3: TJointParams = _priv_dParamLoStop3 + 10;
dParamERP3: TJointParams = _priv_dParamLoStop3 + 11;
dParamGroup: TJointParams = $100;
MaxUserClasses = 4;

Variables

dSphereClass: integer=0;
dBoxClass: integer=1;
dCapsuleClass: integer=2;
dCylinderClass: integer=3;
dPlaneClass: integer=4;
dRayClass: integer=5;
dConvexClass: integer=6;
dGeomTransformClass: integer=7;
dTriMeshClass: integer=8;
dHeightFieldClass: integer=9;
dFirstSpaceClass: integer = 10;
dSimpleSpaceClass: integer = 10;
dHashSpaceClass: integer = 11;
dSweepAndPruneSpaceClass: integer = 12;
dQuadTreeSpaceClass: integer = 13;
dLastSpaceClass: integer = 13;
dFirstUserClass: integer = 14;
dLastUserClass: integer = 17;
dGeomNumClasses: integer = 18;
IsODEInitialized: boolean = False;
DisabledDebugGeom: boolean = False;
DisabledDebugCollision: boolean = False;

Description

Functions and Procedures

procedure dInitODE; cdecl; external ODEDLL;
function dInitODE2(uiInitFlags : longword) : integer; cdecl; external ODEDLL;
procedure dCloseODE; cdecl; external ODEDLL;
function dWorldCreate: PdxWorld; cdecl; external ODEDLL;
procedure dWorldDestroy(const World: PdxWorld); cdecl; external ODEDLL;
function dWorldGetCFM(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
function dWorldGetERP(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldGetGravity(const World: PdxWorld; var gravity: TdVector3); cdecl; external ODEDLL;
procedure dWorldSetGravity(const World: PdxWorld; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dWorldImpulseToForce(const World: PdxWorld; const stepsize, ix, iy, iz: TdReal; var force: TdVector3); cdecl; external ODEDLL;
procedure dWorldSetCFM(const World: PdxWorld; cfm: TdReal); cdecl; external ODEDLL;
procedure dWorldSetERP(const World: PdxWorld; erp: TdReal); cdecl; external ODEDLL;
procedure dWorldSetContactMaxCorrectingVel(const World: PdxWorld; const vel: TdReal); cdecl; external ODEDLL;
function dWorldGetContactMaxCorrectingVel(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetContactSurfaceLayer(const World: PdxWorld; const depth: TdReal); cdecl; external ODEDLL;
function dWorldGetContactSurfaceLayer(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldExportDIF(const World: PdxWorld; fileHandle: cardinal; const world_name:PAnsiChar); cdecl; external ODEDLL;
function dWorldGetLinearDampingThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetLinearDampingThreshold(const World: PdxWorld; const threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAngularDampingThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAngularDampingThreshold(const World: PdxWorld; const threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetLinearDamping(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetLinearDamping(const World: PdxWorld; const scale: TdReal); cdecl; external ODEDLL;
function dWorldGetAngularDamping(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAngularDamping(const World: PdxWorld; const scale: TdReal); cdecl; external ODEDLL;
procedure dWorldSetDamping(const World: PdxWorld; const linear_scale,angular_scale: TdReal); cdecl; external ODEDLL;
function dWorldGetMaxAngularSpeed(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetMaxAngularSpeed(const World: PdxWorld; const max_speed: TdReal); cdecl; external ODEDLL;
procedure dWorldStep(const World: PdxWorld; const stepsize: TdReal); cdecl; external ODEDLL;
procedure dWorldQuickStep(const World: PdxWorld; const stepsize: TdReal); cdecl; external ODEDLL;
procedure dWorldSetQuickStepNumIterations(const World: PdxWorld; const num: integer); cdecl; external ODEDLL;
function dWorldGetQuickStepNumIterations(const World: PdxWorld): integer; cdecl; external ODEDLL;
procedure dWorldSetQuickStepW(const World: PdxWorld; const param: TdReal); cdecl; external ODEDLL;
function dWorldGetQuickStepW(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldStepFast1(const World: PdxWorld; const stepsize: TdReal; const iterations: Integer); cdecl; external ODEDLL;
procedure dWorldSetAutoEnableDepthSF1(const World: PdxWorld; autodepth: Integer); cdecl; external ODEDLL;
function dWorldGetAutoEnableDepthSF1(const World: PdxWorld): Integer; cdecl; external ODEDLL;
function dWorldGetAutoDisableLinearAverageThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableLinearAverageThreshold(const World: PdxWorld; linear_average_threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableAngularAverageThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableAngularAverageThreshold(const World: PdxWorld; linear_average_threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableAverageSamplesCount(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableAverageSamplesCount(const World: PdxWorld; linear_average_threshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableLinearThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableLinearThreshold(const World: PdxWorld; linThreshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableAngularThreshold(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableAngularThreshold(const World: PdxWorld; angThreshold: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableSteps(const World: PdxWorld): Integer; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableSteps(const World: PdxWorld; steps: Integer); cdecl; external ODEDLL;
function dWorldGetAutoDisableTime(const World: PdxWorld): TdReal; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableTime(const World: PdxWorld; time: TdReal); cdecl; external ODEDLL;
function dWorldGetAutoDisableFlag(const World: PdxWorld): Integer; cdecl; external ODEDLL;
procedure dWorldSetAutoDisableFlag(const World: PdxWorld; do_auto_disable: Integer); cdecl; external ODEDLL;
procedure dBodyAddForce(const Body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddForceAtPos(const Body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddForceAtRelPos(const Body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddRelForce(const Body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddRelForceAtPos(const Body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddRelForceAtRelPos(const Body: PdxBody; const fx, fy, fz, px, py, pz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddRelTorque(const Body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;
procedure dBodyAddTorque(const Body: PdxBody; const fx, fy, fz: TdReal); cdecl; external ODEDLL;
function dBodyCreate(const World: PdxWorld): PdxBody; cdecl; external ODEDLL;
procedure dBodyDestroy(const Body: PdxBody); cdecl; external ODEDLL;
procedure dBodyDisable(const Body: PdxBody); cdecl; external ODEDLL;
procedure dBodyEnable(const Body: PdxBody); cdecl; external ODEDLL;
function dBodyGetAngularVel(const Body: PdxBody): PdVector3; cdecl; external ODEDLL;
procedure dBodyGetFiniteRotationAxis(const Body: PdxBody; var result: TdVector3); cdecl; external ODEDLL;
function dBodyGetFiniteRotationMode(const Body: PdxBody): Integer; cdecl; external ODEDLL;
function dBodyGetForce(const Body: PdxBody): PdVector3; cdecl; external ODEDLL;
function dBodyGetGravityMode(const Body: PdxBody): Integer; cdecl; external ODEDLL;
function dBodyGetJoint(const Body: PdxBody; const index: Integer): TdJointID; cdecl; external ODEDLL;
function dBodyGetLinearVel(const Body: PdxBody): PdVector3; cdecl; external ODEDLL;
procedure dBodyGetMass(const Body: PdxBody; var mass: TdMass); cdecl; external ODEDLL;
function dBodyGetNumJoints(const Body: PdxBody): Integer; cdecl; external ODEDLL;
procedure dBodyGetPointVel(const Body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
procedure dBodyGetPosRelPoint(const Body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
function dBodyGetPosition(const Body: PdxBody): PdVector3; cdecl; external ODEDLL;
function dBodyGetQuaternion(const Body: PdxBody): PdQuaternion; cdecl; external ODEDLL;
procedure dBodyGetRelPointPos(const Body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
procedure dBodyGetRelPointVel(const Body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
function dBodyGetRotation(const Body: PdxBody): PdMatrix3; cdecl; external ODEDLL;
function dBodyGetTorque(const Body: PdxBody): PdVector3; cdecl; external ODEDLL;
function dBodyIsEnabled(const Body: PdxBody): Integer; cdecl; external ODEDLL;
procedure dBodySetAngularVel(const Body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetFiniteRotationAxis(const Body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetFiniteRotationMode(const Body: PdxBody; const mode: Integer); cdecl; external ODEDLL;
procedure dBodySetForce(const Body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetGravityMode(const Body: PdxBody; const mode: Integer); cdecl; external ODEDLL;
procedure dBodySetLinearVel(const Body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetMass( const Body: PdxBody; const mass: PdMass); cdecl; external ODEDLL;
procedure dBodySetPosition(const Body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodySetQuaternion(const Body: PdxBody; const q: TdQuaternion); cdecl; external ODEDLL;
procedure dBodySetRotation(const Body: PdxBody; const R: TdMatrix3); cdecl; external ODEDLL;
procedure dBodySetTorque(const Body: PdxBody; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dBodyVectorFromWorld(const Body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
procedure dBodyVectorToWorld(const Body: PdxBody; const px, py, pz: TdReal; var result: TdVector3); cdecl; external ODEDLL;
procedure dBodySetData (const Body: PdxBody; data : pointer); cdecl; external ODEDLL;
function dBodyGetData (const Body: PdxBody) : pointer; cdecl; external ODEDLL;
procedure dBodySetMovedCallback (const Body: PdxBody; Callback : TdMovedCallback); cdecl; external ODEDLL;
procedure dBodyCopyPosition(const Body: PdxBody; const pos: TdVector3); cdecl; external ODEDLL;
procedure dBodyCopyRotation(const Body: PdxBody; const R: TdMatrix3); cdecl; external ODEDLL;
procedure dBodyCopyQuaternion(const Body: PdxBody; const quat: TdQuaternion); cdecl; external ODEDLL;
procedure dBodySetLinearDamping (const Body: PdxBody; scale : TdReal); cdecl; external ODEDLL;
function dBodyGetLinearDamping (const Body: PdxBody) : TdReal; cdecl; external ODEDLL;
procedure dBodySetAngularDamping(const Body: PdxBody; scale : TdReal); cdecl; external ODEDLL;
function dBodyGetAngularDamping(const Body: PdxBody) : TdReal; cdecl; external ODEDLL;
procedure dBodySetDamping(const Body: PdxBody; linear_scale, angular_scale : TdReal); cdecl; external ODEDLL;
function dBodyGetLinearDampingThreshold(const Body: PdxBody) : TdReal; cdecl; external ODEDLL;
procedure dBodySetLinearDampingThreshold(const Body: PdxBody; threshold : TdReal); cdecl; external ODEDLL;
function dBodyGetAngularDampingThreshold(const Body: PdxBody) : TdReal; cdecl; external ODEDLL;
procedure dBodySetAngularDampingThreshold(const Body: PdxBody; threshold : TdReal); cdecl; external ODEDLL;
procedure dBodySetDampingDefaults(const Body: PdxBody; threshold : TdReal); cdecl; external ODEDLL;
procedure dBodySetMaxAngularSpeed(const Body: PdxBody; max_speed : TdReal); cdecl; external ODEDLL;
function dBodyGetMaxAngularSpeed(const Body: PdxBody) : TdReal; cdecl; external ODEDLL;
function dBodyGetAutoDisableLinearThreshold(const Body: PdxBody): TdReal; cdecl; external ODEDLL;
procedure dBodySetAutoDisableLinearThreshold(const Body: PdxBody; linThreshold: TdReal); cdecl; external ODEDLL;
function dBodyGetAutoDisableAngularThreshold(const Body: PdxBody): TdReal; cdecl; external ODEDLL;
procedure dBodySetAutoDisableAngularThreshold(const Body: PdxBody; angThreshold: TdReal); cdecl; external ODEDLL;
function dBodyGetAutoDisableSteps(const Body: PdxBody): Integer; cdecl; external ODEDLL;
procedure dBodySetAutoDisableSteps(const Body: PdxBody; steps: Integer); cdecl; external ODEDLL;
function dBodyGetAutoDisableTime(const Body: PdxBody): TdReal; cdecl; external ODEDLL;
procedure dBodySetAutoDisableTime(const Body: PdxBody; time: TdReal); cdecl; external ODEDLL;
function dBodyGetAutoDisableFlag(const Body: PdxBody): Integer; cdecl; external ODEDLL;
procedure dBodySetAutoDisableFlag(const Body: PdxBody; do_auto_disable: Integer); cdecl; external ODEDLL;
procedure dBodySetAutoDisableDefaults(const Body: PdxBody); cdecl; external ODEDLL;
procedure dBodySetAutoDisableAverageSamplesCount(const Body: PdxBody; average_samples_count : longword); cdecl; external ODEDLL;
procedure dJointGroupDestroy(const dJointGroupID : TdJointGroupID); cdecl; external ODEDLL;
function dJointGroupCreate(const max_size: Integer): TdJointGroupID; cdecl; external ODEDLL;
procedure dJointGroupEmpty(const dJointGroupID : TdJointGroupID); cdecl; external ODEDLL;
procedure dJointAttach(const dJointID : TdJointID; const body1, body2: PdxBody); cdecl; external ODEDLL;
procedure dJointDestroy(const dJointID : TdJointID); cdecl; external ODEDLL;
function dJointGetData (const dJointID : TdJointID) : pointer; cdecl; external ODEDLL;
procedure dJointSetData (const dJointID : TdJointID; data : Pointer); cdecl; external ODEDLL;
procedure dJointSetFeedback (const dJointID : TdJointID; Feedback : PTdJointFeedback); cdecl; external ODEDLL;
function dJointGetFeedback (const dJointID : TdJointID) : PTdJointFeedback; cdecl; external ODEDLL;
function dJointGetType(const dJointID : TdJointID): Integer; cdecl; external ODEDLL;
function dJointGetBody(const dJointID : TdJointID; const index: Integer): PdxBody; cdecl; external ODEDLL;
function dJointCreateContact(const World : PdxWorld; dJointGroupID : TdJointGroupID; const dContact: PdContact): TdJointID; cdecl; external ODEDLL;
function dJointCreateAMotor(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetAMotorAngle(const dJointID : TdJointID; const anum: Integer; const angle: TdReal); cdecl; external ODEDLL;
function dJointGetAMotorAngle(const dJointID : TdJointID; const anum: Integer): TdReal; cdecl; external ODEDLL;
procedure dJointSetAMotorAxis(const dJointID : TdJointID; const anum, rel: Integer; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetAMotorAxis(const dJointID : TdJointID; const anum: Integer; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetAMotorNumAxes(const dJointID : TdJointID; const num: Integer); cdecl; external ODEDLL;
function dJointGetAMotorNumAxes(const dJointID : TdJointID): Integer; cdecl; external ODEDLL;
procedure dJointSetAMotorParam(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetAMotorParam(const dJointID : TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
procedure dJointSetAMotorMode(const dJointID : TdJointID; const mode: TdAngularMotorModeNumbers); cdecl; external ODEDLL;
function dJointGetAMotorMode(const dJointID : TdJointID): Integer; cdecl; external ODEDLL;
procedure dJointAddAMotorTorques (const dJointID : TdJointID; torque1, torque2, torque3: TdReal); cdecl; external ODEDLL;
function dJointGetAMotorAngleRate(const dJointID : TdJointID; const anum: Integer): TdReal; cdecl; external ODEDLL;
function dJointGetAMotorAxisRel(const dJointID : TdJointID; const anum: Integer): Integer; cdecl; external ODEDLL;
function dJointCreateLMotor(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetLMotorAxis(const dJointID : TdJointID; const anum, rel: Integer; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetLMotorAxis(const dJointID : TdJointID; const anum: Integer; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetLMotorNumAxes(const dJointID : TdJointID; const num: Integer); cdecl; external ODEDLL;
function dJointGetLMotorNumAxes(const dJointID : TdJointID): Integer; cdecl; external ODEDLL;
procedure dJointSetLMotorParam(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetLMotorParam(const dJointID : TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointCreateBall(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetBallAnchor(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetBallAnchor(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetBallAnchor2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
function dJointCreateHinge(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetHingeAnchor(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHingeAnchor(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetHingeAnchor2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHingeAxis(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHingeAxis(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHingeParam(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetHingeParam(const dJointID : TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointGetHingeAngle(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetHingeAngleRate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
procedure dJointAddHingeTorque (const dJointID : TdJointID; torque: TdReal); cdecl; external ODEDLL;
function dJointCreateHinge2(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetHinge2Anchor(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHinge2Anchor(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetHinge2Anchor2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHinge2Axis1(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHinge2Axis1(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHinge2Axis2(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetHinge2Axis2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetHinge2Param(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetHinge2Param(const dJointID : TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointGetHinge2Angle1(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetHinge2Angle1Rate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetHinge2Angle2Rate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
procedure dJointAddHinge2Torques (const dJointID : TdJointID; torque1, torque2: TdReal); cdecl; external ODEDLL;
procedure dJointCorrectHinge2(const dJointID : TdJointID); cdecl; external ODEDLL;
function dJointCreateSlider(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetSliderAxis(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetSliderAxis(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetSliderParam(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetSliderParam(const dJointID : TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointGetSliderPosition(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetSliderPositionRate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
procedure dJointAddSliderForce (const dJointID : TdJointID; force: TdReal); cdecl; external ODEDLL;
function dJointCreateUniversal(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointGetUniversalAnchor(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetUniversalAnchor2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetUniversalAxis1(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetUniversalAxis1(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetUniversalAxis2(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetUniversalAxis2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetUniversalParam(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetUniversalParam(const dJointID : TdJointID; const parameter: TJointParams): TdReal; cdecl; external ODEDLL;
function dJointGetUniversalAngle1(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetUniversalAngle2(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetUniversalAngle1Rate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetUniversalAngle2Rate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
procedure dJointSetUniversalAnchor(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointAddUniversalTorques (const dJointID : TdJointID; torque1, torque2: TdReal); cdecl; external ODEDLL;
function dJointCreateFixed(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetFixed(const dJointID : TdJointID); cdecl; external ODEDLL;
function dJointCreatePlane2D(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetPlane2DXParam(const dJointID : TdJointID; const parameter: Integer; const value: TdReal); cdecl; external ODEDLL;
procedure dJointSetPlane2DYParam(const dJointID : TdJointID; const parameter: Integer; const value: TdReal); cdecl; external ODEDLL;
procedure dJointSetPlane2DAngleParam(const dJointID : TdJointID; const parameter: Integer; const value: TdReal); cdecl; external ODEDLL;
function dJointCreatePR(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetPRAnchor(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointSetPRAxis1(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetPRAxis1(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetPRAxis2(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetPRAxis2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetPRParam(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetPRParam(const dJointID : TdJointID; parameter: integer): TdReal; cdecl; external ODEDLL;
procedure dJointAddPRTorque (const dJointID : TdJointID; torque: TdReal); cdecl; external ODEDLL;
function dJointCreatePiston(const World : PdxWorld; dJointGroupID : TdJointGroupID): TdJointID; cdecl; external ODEDLL;
procedure dJointSetPistonAnchor(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetPistonAnchor(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointGetPistonAnchor2(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetPistonAxis(const dJointID : TdJointID; const x, y, z: TdReal); cdecl; external ODEDLL;
procedure dJointGetPistonAxis(const dJointID : TdJointID; var result: TdVector3); cdecl; external ODEDLL;
procedure dJointSetPistonParam(const dJointID : TdJointID; const parameter: TJointParams; const value: TdReal); cdecl; external ODEDLL;
function dJointGetPistonParam(const dJointID : TdJointID; parameter : integer): TdReal; cdecl; external ODEDLL;
procedure dJointSetPistonAxisDelta(const dJointID : TdJointID; const x, y, z, ax, ay, az: TdReal); cdecl; external ODEDLL;
procedure dJointAddPistonForce (const dJointID : TdJointID; force: TdReal); cdecl; external ODEDLL;
function dJointGetPistonPosition(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetPistonAngle(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetPistonAngleRate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dJointGetPistonRate(const dJointID : TdJointID): TdReal; cdecl; external ODEDLL;
function dCreateGeom (classnum : Integer) : PdxGeom; cdecl; external ODEDLL;
procedure dGeomDestroy(const Geom : PdxGeom); cdecl; external ODEDLL;
function dCreateGeomClass(const classptr : TdGeomClass) : Integer; cdecl; external ODEDLL;
function dGeomGetClass(const Geom : PdxGeom): Integer; cdecl; external ODEDLL;
function dGeomGetClassData(o : PdxGeom) : Pointer; cdecl; external ODEDLL;
function dGeomGetSpace(const Geom : PdxGeom): PdxSpace; cdecl; external ODEDLL;
function dGeomIsSpace (const Geom : PdxGeom) : integer; cdecl; external ODEDLL;
procedure dGeomSetBody(const Geom : PdxGeom; Body: PdxBody); cdecl; external ODEDLL;
function dGeomGetBody(const Geom : PdxGeom): PdxBody; cdecl; external ODEDLL;
procedure dGeomSetPosition(const Geom : PdxGeom; const x, y, z: TdReal); cdecl; external ODEDLL;
function dGeomGetPosition(const Geom : PdxGeom): PdVector3; cdecl; external ODEDLL;
procedure dGeomSetRotation(const Geom : PdxGeom; const R: TdMatrix3); cdecl; external ODEDLL;
function dGeomGetRotation(const Geom : PdxGeom): PdMatrix3; cdecl; external ODEDLL;
procedure dGeomSetQuaternion(const Geom : PdxGeom; const TdQuaternion); cdecl; external ODEDLL;
procedure dGeomGetQuaternion(const Geom : PdxGeom; var result: TdQuaternion); cdecl; external ODEDLL;
procedure dGeomCopyPosition(const Geom : PdxGeom; const pos: TdVector3); cdecl; external ODEDLL;
procedure dGeomCopyRotation(const Geom : PdxGeom; const R: TdMatrix3); cdecl; external ODEDLL;
procedure dGeomCopyQuaternion(const Geom : PdxGeom; const quat: TdQuaternion); cdecl; external ODEDLL;
procedure dGeomSetData (const Geom : PdxGeom; data : pointer); cdecl; external ODEDLL;
function dGeomGetData (const Geom : PdxGeom) : pointer; cdecl; external ODEDLL;
procedure dGeomEnable (const Geom : PdxGeom); cdecl; external ODEDLL;
procedure dGeomDisable (const Geom : PdxGeom); cdecl; external ODEDLL;
function dGeomIsEnabled (const Geom : PdxGeom) : integer; cdecl; external ODEDLL;
procedure dGeomGetAABB(const Geom : PdxGeom; var aabb: TdAABB); cdecl; external ODEDLL;
procedure dGeomSetCategoryBits (const Geom : PdxGeom; bits : Cardinal); cdecl; external ODEDLL;
function dGeomGetCategoryBits (const Geom : PdxGeom) : cardinal; cdecl; external ODEDLL;
procedure dGeomSetCollideBits (const Geom : PdxGeom; bits : Cardinal); cdecl; external ODEDLL;
function dGeomGetCollideBits (const Geom : PdxGeom) : cardinal; cdecl; external ODEDLL;
procedure dGeomSetOffsetPosition (const Geom : PdxGeom; x,y,z:TdReal); cdecl; external ODEDLL;
function dGeomGetOffsetPosition(const Geom : PdxGeom): PdVector3; cdecl; external ODEDLL;
procedure dGeomSetOffsetRotation (const Geom : PdxGeom; R:TdMatrix3); cdecl; external ODEDLL;
function dGeomGetOffsetRotation(const Geom : PdxGeom): PdVector3; cdecl; external ODEDLL;
procedure dGeomSetOffsetQuaternion (const Geom : PdxGeom; const Q:TdQuaternion); cdecl; external ODEDLL;
procedure dGeomGetOffsetQuaternion (const Geom : PdxGeom; var Q:TdQuaternion); cdecl; external ODEDLL;
procedure dGeomClearOffset (const Geom : PdxGeom); cdecl; external ODEDLL;
procedure dGeomSetOffsetWorldPosition (const Geom : PdxGeom; x,y,z:TdReal); cdecl; external ODEDLL;
procedure dGeomSetOffsetWorldRotation (const Geom : PdxGeom; R:TdMatrix3); cdecl; external ODEDLL;
procedure dGeomSetOffsetWorldQuaternion (const Geom : PdxGeom; const Q:TdQuaternion); cdecl; external ODEDLL;
procedure dGeomCopyOffsetPosition(const Geom : PdxGeom; var pos: TdVector3); cdecl; external ODEDLL;
procedure dGeomCopyOffsetRotation(const Geom : PdxGeom; var R: TdMatrix3); cdecl; external ODEDLL;
procedure dGeomIsOffset (const Geom : PdxGeom); cdecl; external ODEDLL;
function dCreateGeomTransform(const Space : PdxSpace): PdxGeom; cdecl; external ODEDLL name 'dCreateGeomTransform';
procedure dGeomTransformSetGeom(const Geom, obj: PdxGeom); cdecl; external ODEDLL;
function dGeomTransformGetGeom(const Geom : PdxGeom): PdxGeom; cdecl; external ODEDLL;
procedure dGeomTransformSetInfo (const Geom : PdxGeom; mode : integer); cdecl; external ODEDLL;
function dGeomTransformGetInfo (const Geom : PdxGeom) : integer; cdecl; external ODEDLL;
procedure dGeomTransformSetCleanup(const Geom : PdxGeom; const mode: Integer); cdecl; external ODEDLL;
function dGeomTransformGetCleanup(const Geom : PdxGeom): Integer; cdecl; external ODEDLL;
function dCreateBox(const Space : PdxSpace; const lx, ly, lz: TdReal): PdxGeom; cdecl; external ODEDLL name 'dCreateBox';
procedure dGeomBoxGetLengths(const Geom : PdxGeom; var result: TdVector3); cdecl; external ODEDLL;
procedure dGeomBoxSetLengths(const Geom : PdxGeom; const lx, ly, lz: TdReal); cdecl; external ODEDLL;
function dGeomBoxPointDepth (const Geom : PdxGeom; const x,y,z : TdReal) : TdReal; cdecl; external ODEDLL;
function dCreateCylinder(const Space : PdxSpace; r, lz : TdReal) : PdxGeom; cdecl; external ODEDLL name 'dCreateCylinder';
procedure dGeomCylinderSetParams (const Geom : PdxGeom; radius, length : TdReal); cdecl; external ODEDLL;
procedure dGeomCylinderGetParams (const Geom : PdxGeom; var radius, length : TdReal); cdecl; external ODEDLL;
function dCreateCapsule(const Space : PdxSpace; const radius, length: TdReal): PdxGeom; cdecl; external ODEDLL name 'dCreateCapsule';
procedure dGeomCapsuleSetParams(const Geom : PdxGeom; const radius, length: TdReal); cdecl; external ODEDLL;
procedure dGeomCapsuleGetParams(const Geom : PdxGeom; var radius, length: TdReal); cdecl; external ODEDLL;
function dGeomCapsulePointDepth (const Geom : PdxGeom; const x,y,z : TdReal) : TdReal; cdecl; external ODEDLL;
function dCreatePlane(const Space : PdxSpace; const a, b, c, d: TdReal): PdxGeom; cdecl; external ODEDLL name 'dCreatePlane';
procedure dGeomPlaneSetParams (const Geom : PdxGeom; const a, b, c, d: TdReal); cdecl; external ODEDLL;
procedure dGeomPlaneGetParams(const Geom : PdxGeom; var result: TdVector4); cdecl; external ODEDLL;
function dGeomPlanePointDepth (const Geom : PdxGeom; const x,y,z : TdReal) : TdReal; cdecl; external ODEDLL;
function dCreateSphere(const Space : PdxSpace; const radius: TdReal): PdxGeom; cdecl; external ODEDLL name 'dCreateSphere';
procedure dGeomSphereSetRadius(const Geom : PdxGeom; const radius: TdReal); cdecl; external ODEDLL;
function dGeomSphereGetRadius(const Geom : PdxGeom): TdReal; cdecl; external ODEDLL;
function dGeomSpherePointDepth (const Geom : PdxGeom; const x,y,z : TdReal) : TdReal; cdecl; external ODEDLL;
function dCreateConvex(const Space : PdxSpace; _planes: PdReal; _planecount: longword; _points : PdReal; _pointcount: longword; const _polygons:longword): PdxGeom; cdecl; external ODEDLL;
procedure dGeomSetConvex(const Geom: PdxGeom; _planes: PdReal; _planecount: longword; _points : PdReal; _pointcount: longword; const _polygons:longword); cdecl; external ODEDLL;
function dCreateHeightfield(const Space : PdxSpace; Data: PdxHeightfieldData; bPlaceable:Integer): PdxGeom; cdecl; external ODEDLL;
function dGeomHeightfieldDataCreate: PdxHeightfieldData; cdecl; external ODEDLL;
procedure dGeomHeightfieldDataDestroy(Data: PdxHeightfieldData); cdecl; external ODEDLL;
procedure dGeomHeightfieldSetHeightfieldData(const Geom : PdxGeom; Data: PdxHeightfieldData); cdecl; external ODEDLL;
function dGeomHeightfieldGetHeightfieldData(const Geom : PdxGeom):PdxHeightfieldData; cdecl; external ODEDLL;
function dGeomHeightfieldDataSetBounds (Data: PdxHeightfieldData; minHeight, MaxHeight : TdReal) : TdReal; cdecl; external ODEDLL;
function dCreateRay(const Space : PdxSpace; length : TdReal) : PdxGeom; cdecl; external ODEDLL name 'dCreateRay';
procedure dGeomRaySet(const Geom : PdxGeom; px, py, pz, dx, dy, dz: TdReal); cdecl; external ODEDLL;
procedure dGeomRayGet(const Geom : PdxGeom; var start, dir: TdVector3); cdecl; external ODEDLL;
procedure dGeomRaySetLength(const Geom : PdxGeom; length: TdReal); cdecl; external ODEDLL;
function dGeomRayGetLength(const Geom : PdxGeom) : TdReal; cdecl; external ODEDLL;
procedure dGeomRaySetParams(const Geom : PdxGeom; FirstContact, BackfacCull: integer); cdecl; external ODEDLL;
procedure dGeomRayGetParams(const Geom : PdxGeom; var FirstContact, BackfacCull: integer); cdecl; external ODEDLL;
procedure dGeomRaySetClosestHit(const Geom : PdxGeom; closestHit: Integer); cdecl; external ODEDLL;
function dGeomRayGetClosestHit(const Geom : PdxGeom) : Integer; cdecl; external ODEDLL;
function dCreateTriMesh(const Space : PdxSpace; Data: PdxTriMeshData; Callback:TdTriCallback; ArrayCallback:TdTriArrayCallback; RayCallback: TdTriRayCallback): PdxGeom; cdecl; external ODEDLL;
procedure dGeomTriMeshSetData(g: PdxGeom; Data: PdxTriMeshData); cdecl; external ODEDLL;
function dGeomTriMeshGetData(g: PdxGeom):PdxTriMeshData; cdecl; external ODEDLL;
function dGeomTriMeshGetTriMeshDataID(g: PdxGeom) : PdxTriMeshData; cdecl; external ODEDLL;
procedure dGeomTriMeshDataUpdate(g: PdxTriMeshData); cdecl; external ODEDLL;
function dGeomTriMeshIsTCEnabled(g: PdxGeom; geomClass: Integer): Integer; cdecl; external ODEDLL;
procedure dGeomTriMeshEnableTC(g: PdxGeom; geomClass, enable: Integer); cdecl; external ODEDLL;
procedure dGeomTriMeshClearTCCache(g: PdxGeom); cdecl; external ODEDLL;
function dGeomTriMeshGetTriangleCount(g: PdxGeom) : integer; cdecl; external ODEDLL;
procedure dGeomTriMeshGetTriangle(g: PdxGeom; Index: Integer; v0, v1, v2: PdVector3); cdecl; external ODEDLL;
procedure dGeomTriMeshGetPoint(g: PdxGeom; Index: Integer; u, v: TdReal; result: TdVector3); cdecl; external ODEDLL;
function dGeomTriMeshGetArrayCallback(g: PdxGeom): Pointer; cdecl; external ODEDLL;
function dGeomTriMeshGetRayCallback(g: PdxGeom): Pointer; cdecl; external ODEDLL;
procedure dGeomTriMeshSetArrayCallback(g: PdxGeom; ArrayCallback: Pointer); cdecl; external ODEDLL;
procedure dGeomTriMeshSetRayCallback(g: PdxGeom; RayCallback: Pointer); cdecl; external ODEDLL;
procedure dGeomTriMeshSetCallback(g: PdxGeom; Callback: Pointer); cdecl; external ODEDLL;
function dGeomTriMeshGetCallback(g: PdxGeom): Pointer; cdecl; external ODEDLL;
procedure dGeomTriMeshDataDestroy(g: PdxTriMeshData); cdecl; external ODEDLL;
function dGeomTriMeshDataCreate: PdxTriMeshData; cdecl; external ODEDLL;
procedure dGeomTriMeshDataSet(g: PdxTriMeshData; data_id: Integer; data: Pointer); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildSimple(g: PdxTriMeshData; Vertices: PdVector3Array; VertexCount: Integer; Indices: PdIntegerArray; IndexCount: Integer); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildSimple1(g: PdxTriMeshData; Vertices: PdVector3Array; VertexCount: Integer; Indices: PdIntegerArray; IndexCount: Integer; Normals: PdVector3Array); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildDouble(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildDouble1(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer; Normals: PdVector3Array); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildSingle(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer); cdecl; external ODEDLL;
procedure dGeomTriMeshDataBuildSingle1(g: PdxTriMeshData; Vertices: PdVector3Array; VertexStride, VertexCount: Integer; Indices: PdIntegerArray; IndexCount, TriStride: Integer; Normals: PdVector3Array); cdecl; external ODEDLL;
procedure dInfiniteAABB(geom : PdxGeom; var aabb : TdAABB); cdecl; external ODEDLL;
procedure dSpaceDestroy(const Space: PdxSpace); cdecl; external ODEDLL;
function dSimpleSpaceCreate(Space : PdxSpace): PdxSpace; cdecl; external ODEDLL;
function dHashSpaceCreate(Space : PdxSpace): PdxSpace; cdecl; external ODEDLL;
function dQuadTreeSpaceCreate(const Space : PdxSpace; const Center, Extents : TdVector3; const Depth : Integer): PdxSpace; cdecl; external ODEDLL;
procedure dSpaceAdd(const Space : PdxSpace; const Geom : PdxGeom); cdecl; external ODEDLL;
procedure dSpaceRemove(const Space : PdxSpace; const Geom : PdxGeom); cdecl; external ODEDLL;
procedure dSpaceClean (const Space : PdxSpace); cdecl; external ODEDLL;
function dSpaceQuery (const Space : PdxSpace; const Geom : PdxGeom): Integer; cdecl; external ODEDLL;
function dSpaceGetNumGeoms (const Space: PdxSpace) : integer; cdecl; external ODEDLL;
function dSpaceGetGeom (const Space: PdxSpace; const i: Integer) : PdxGeom; cdecl; external ODEDLL;
procedure dHashSpaceSetLevels(const Space: PdxSpace; const minlevel, maxlevel: Integer); cdecl; external ODEDLL;
procedure dHashSpaceGetLevels(const Space: PdxSpace; var minlevel, maxlevel: Integer); cdecl; external ODEDLL;
procedure dSpaceSetCleanup (space : PdxSpace; const mode : integer); cdecl; external ODEDLL;
function dSpaceGetCleanup(Space : PdxSpace): integer; cdecl; external ODEDLL;
function dCollide (o1, o2 : PdxGeom; flags : integer; var Contact : TdContactGeom; Skip : integer) : integer; cdecl; external ODEDLL;
procedure dSpaceCollide (const Space : PdxSpace; data : pointer; callback : TdNearCallback); cdecl; external ODEDLL;
procedure dSpaceCollide2 (o1, o2 : PdxGeom; data : pointer; callback : TdNearCallback); cdecl; external ODEDLL;
procedure dMassSetParameters(var m: TdMass; themass, cgx, cgy, cgz, I11, I22, I33, I12, I13, I23: TdReal); cdecl; external ODEDLL;
procedure dMassAdd(var a,b : TdMass); cdecl; external ODEDLL;
procedure dMassAdjust(var m: TdMass; newmass: TdReal); cdecl; external ODEDLL;
procedure dMassTranslate(var m: TdMass; x, y, z: TdReal); cdecl; external ODEDLL;
procedure dMassRotate(var m: TdMass; var R: TdMatrix3); cdecl; external ODEDLL;
procedure dMassSetZero(var m: TdMass); cdecl; external ODEDLL;
procedure dMassSetBox(var m: TdMass; density, lx, ly, lz: TdReal); cdecl; external ODEDLL;
procedure dMassSetBoxTotal(var m: TdMass; total_mass, lx, ly, lz: TdReal); cdecl; external ODEDLL;
procedure dMassSetCylinder(var m: TdMass; density: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;
procedure dMassSetCylinderTotal(var m: TdMass; total_mass: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;
procedure dMassSetCapsule(var m: TdMass; density: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;
procedure dMassSetCapsuleTotal(var m: TdMass; total_mass: TdReal; direction: Integer; radius, length: TdReal); cdecl; external ODEDLL;
procedure dMassSetSphere(var m: TdMass; density, radius: TdReal); cdecl; external ODEDLL;
procedure dMassSetSphereTotal(var m: TdMass; total_mass, radius: TdReal); cdecl; external ODEDLL;
procedure dMassSetTrimesh(var m: TdMass; density: TdReal; trimesh:PdxGeom); cdecl; external ODEDLL;
procedure dMassSetTrimeshTotal(var m: TdMass; total_mass: TdReal; trimesh:PdxGeom); cdecl; external ODEDLL;
procedure dQFromAxisAndAngle (var q : TdQuaternion; const ax, ay ,az, angle : TdReal); cdecl; external ODEDLL;
procedure dRFromAxisAndAngle (var R : TdMatrix3; const ax, ay ,az, angle : TdReal); cdecl; external ODEDLL;
procedure dRSetIdentity (var R : TdMatrix3); cdecl; external ODEDLL;
procedure dQSetIdentity (var Q : TdQuaternion); cdecl; external ODEDLL;
procedure dRFromEulerAngles (var R : TdMatrix3; const phi, theta, psi : TdReal); cdecl; external ODEDLL;
procedure dRFrom2Axes (var R: TdMatrix3; const ax, ay, az, bx, by, bz : TdReal); cdecl; external ODEDLL;
procedure dRFromZAxis (var R: TdMatrix3; const ax, ay, az : TdReal); cdecl; external ODEDLL;
procedure dMultiply0 (const A : PdReal; const B, C : PdReal; p, q, r : integer); cdecl; external ODEDLL;
procedure dMultiply1 (const A : PdReal; const B, C : PdReal; p, q, r : integer); cdecl; external ODEDLL;
procedure dMultiply2 (const A : PdReal; const B, C : PdReal; p, q, r : integer); cdecl; external ODEDLL;
procedure dQMultiply0 (var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;
procedure dQMultiply1 (var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;
procedure dQMultiply2 (var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;
procedure dQMultiply3 (var qa: TdQuaternion; const qb, qc: TdQuaternion); cdecl; external ODEDLL;
procedure dRfromQ (var R : TdMatrix3; const q : TdQuaternion); cdecl; external ODEDLL;
procedure dQfromR (var q : TdQuaternion; const R : TdMatrix3); cdecl; external ODEDLL;
procedure dDQfromW (var dq : TdVector4; const w : TdVector3; const q: TdQuaternion); cdecl; external ODEDLL;
procedure dNormalize3 (var a : TdVector3); cdecl; external ODEDLL;
procedure dNormalize4 (var a : TdVector4); cdecl; external ODEDLL;
procedure dClosestLineSegmentPoints (const a1, a2, b1, b2 : TdVector3; var cp1, cp2 : TdVector3); cdecl; external ODEDLL;
function dBoxTouchesBox (const _p1 : TdVector3; const R1 : TdMatrix3; const side1 : TdVector3; const _p2 : TdVector3; const R2 : TdMatrix3; const side2 : TdVector3) : integer; cdecl; external ODEDLL;
function dMaxDifference (A, B : PdReal; n, m : integer) : TdReal; cdecl; external ODEDLL;
procedure dMakeRandomVector(var n1 : TdVector3; a : integer; f : TdReal); cdecl; external ODEDLL;
function dAreConnected (a, b : PdxBody) : integer; cdecl; external ODEDLL;
function dAreConnectedExcluding (a, b : PdxBody; joint_type : TdJointTypeNumbers) : integer; cdecl; external ODEDLL;
procedure dMakeRandomMatrix (A : PdRealArray; n, m : integer; range : TdReal); cdecl; external ODEDLL;
procedure dClearUpperTriangle (A : PdRealArray; n : integer); cdecl; external ODEDLL;
function dRandGetSeed: Cardinal; cdecl; external ODEDLL;
procedure dRandSetSeed (const s: Cardinal); cdecl; external ODEDLL;
function dRandInt (const n: Integer): Integer; cdecl; external ODEDLL;
function dRandReal: TdReal; cdecl; external ODEDLL;
function dTestRand: Integer; cdecl; external ODEDLL;
procedure dTestMatrixComparison; cdecl; external ODEDLL;
procedure dTestSolveLCP; cdecl; external ODEDLL;
function dDot (const a, b : TdVector3) : TdReal; overload;
function dDot (const a, b : PdVector3) : TdReal; overload;
function dDOT14(const a,b : TdRealArray) : TdReal; overload;
function dDOT14(const a,b : PdRealArray) : TdReal; overload;
procedure dMULTIPLY0_333(var A : TdMatrix3; const B,C : TdMatrix3);
procedure dMULTIPLY0_331(var A : TdVector3; const B : TdMatrix3; const C : TdVector3);
function Vector3ScalarMul(const a : TdVector3; const Scalar : TdReal) : TdVector3;
function Vector3ADD(const a, b : TdVector3) : TdVector3;
function Vector3SUB(const a, b : TdVector3) : TdVector3;
function Vector3Length(const a : TdVector3) : TdReal;
function Vector3Cross(const V1, V2 : TdVector3) : TdVector3;
function Vector3Make(const x,y,z : TdReal) : TdVector3;
procedure VerifyDelphiODE(Body : PdxBody; Geom : PdxGeom);
function InitODE(ADllName : PChar) : boolean;
procedure CloseODE;

Types

TJointFlag = Integer;
TdContactType = Integer;
TBodyFlags = Integer;
TdReal = single;
PdReal = ˆTdReal;
PdxJointGroup = ˆTdxJointGroup;
TdJointGroupID = PdxJointGroup;
PdxJointLimitMotor = ˆTdxJointLimitMotor;
TdRealArray = array[0..15] of TdReal;
PdRealArray = ˆTdRealArray;
TdVector3 = array[0..3] of TdReal;
PdVector3 = ˆTdVector3;
Pd3Axis = ˆTd3Axis;
Td3Axis = array[0..2] of TdVector3;
PdInteger3 = ˆTdInteger3;
TdInteger3 = array[0..2] of integer;
PdxJointLimitMotor3 = ˆTdxJointLimitMotor3;
TdxJointLimitMotor3 = array[0..2] of TdxJointLimitMotor;
TdVector4 = array[0..3] of TdReal;
PdVector4 = ˆTdVector4;
TdMatrix3 = array[0..4*3-1] of TdReal;
PdMatrix3 = ˆTdMatrix3;
TdMatrix3_As3x4 = array[0..2, 0..3] of TdReal;
PdMatrix3_As3x4 = ˆTdMatrix3_As3x4;
TdMatrix4 = array[0..4*4-1] of TdReal;
PdMatrix4 = ˆTdMatrix4;
TdMatrix6 = array[0..8*6-1] of TdReal;
PdMatrix6 = ˆTdMatrix6;
TdQuaternion = TdVector4;
PdQuaternion = ˆTdQuaternion;
TdAABB = array[0..5] of TdReal;
PdMass = ˆTdMass;
PdxGeom = ˆTdxGeom;
PPdxGeom = ˆPdxGeom;
TdMovedCallback = procedure(o1: PdxGeom); cdecl;
TdTriCallback = function(TriMesh,RefObject : PdxGeom; TriangleIndex : integer) : integer;
TdTriArrayCallback = procedure(TriMesh,RefObject : PdxGeom; TriIndices:PIntegerArray; TriCount : integer);
TdTriRayCallback = function(TriMesh,Ray : PdxGeom; TriangleIndex : integer; u,v:TdReal) : integer;
PdxWorld = ˆTdxWorld;
PdObject = ˆTdObject;
PPdObject = ˆPdObject;
PdxBody = ˆTdxBody;
PdxJoint= ˆTdxJoint;
TdJointID = PdxJoint;
PdxJointNode = ˆTdxJointNode;
TdxJointNull = TdxJoint;
PdxJointBall = ˆTdxJointBall;
PdxJointHinge = ˆTdxJointHinge;
PdxJointUniversial = ˆTdxJointUniversial;
PdxJointPR = ˆTdxJointPR;
PdxJointPiston = ˆTdxJointPiston;
PdxJointSlider = ˆTdxJointSlider;
PdxJointHinge2 = ˆTdxJointHinge2;
PdxPosR = ˆTdxPosR;
PTdJointFeedback = ˆTdJointFeedback;
TdErrorType = (...);
Values
  • d_ERR_UNKNOWN:
  • d_ERR_IASSERT:
  • d_ERR_UASSERT:
  • d_ERR_LCP:
TdJointTypeNumbers = (...);
Values
  • dJointTypeNone:
  • dJointTypeBall:
  • dJointTypeHinge:
  • dJointTypeSlider:
  • dJointTypeContact:
  • dJointTypeUniversal:
  • dJointTypeHinge2:
  • dJointTypeFixed:
  • dJointTypeNull:
  • dJointTypeAMotor:
  • dJointTypeLMotor:
  • dJointTypePlane2D:
  • dJointTypePR:
  • dJointTypePU:
  • dJointTypePiston:
TdAngularMotorModeNumbers = (...);
Values
  • dAMotorUser:
  • dAMotorEuler:
PdContactGeom = ˆTdContactGeom;
PdContact = ˆTdContact;
TdNearCallback = procedure(data : pointer; o1, o2 : PdxGeom); cdecl;
TdColliderFn = function(o1, o2 : PdxGeom; flags : Integer; contact : PdContactGeom; skip : Integer) : Integer; cdecl;
TdGetColliderFnFn = function(num : Integer) : TdColliderFn; cdecl;
TdGetAABBFn = procedure(g : PdxGeom; var aabb : TdAABB); cdecl;
TdGeomDtorFn = procedure(o : PdxGeom); cdecl;
TdAABBTestFn = function(o1, o2 : PdxGeom; const aabb2 : TdAABB) : Integer; cdecl;
PdGeomClass = ˆTdGeomClass;
PdxSpace = ˆTdxSpace;
TdRealHugeArray = array[0..65535] of TdReal;
PdRealHugeArray = ˆTdRealHugeArray;
TdIntegerArray = array[0..65535] of Integer;
PdIntegerArray = ˆTdIntegerArray;
TdVector3Array = array[0..65535] of TdVector3;
PdVector3Array = ˆTdVector3Array;
PdxTriMeshData = ˆTdxTriMeshData;
PdxHeightfieldData = ˆTdxHeightfieldData;
PdxSimpleSpace = ˆTdxSimpleSpace;
PdxHashSpace = ˆTdxHashSpace;
TdxSimpleSpace = TdxSpace;
TJointParams = Integer;

Constants

ODEDLL = 'ode_single.dll';
TRIMESH_FACE_NORMALS = 0;
TRIMESH_LAST_TRANSFORMATION = 1;
CONTACTS_UNIMPORTANT = $80000000;
dJOINT_INGROUP: TJointFlag = 1;
dJOINT_REVERSE: TJointFlag = 2;
dJOINT_TWOBODIES: TJointFlag = 4;
dContactMu2: TdContactType = $0001;
dContactFDir1: TdContactType = $0002;
dContactBounce: TdContactType = $0004;
dContactSoftERP: TdContactType = $0008;
dContactSoftCFM: TdContactType = $0010;
dContactMotion1: TdContactType = $0020;
dContactMotion2: TdContactType = $0040;
dContactMotionN: TdContactType = $0080;
dContactSlip1: TdContactType = $0100;
dContactSlip2: TdContactType = $0200;
dContactApprox0: TdContactType = $0000;
dContactApprox1_1: TdContactType = $1000;
dContactApprox1_2: TdContactType = $2000;
dContactApprox1: TdContactType = $3000;
dxBodyFlagFiniteRotation: TBodyFlags = 1;
dxBodyFlagFiniteRotationAxis: TBodyFlags = 2;
dxBodyDisabled: TBodyFlags = 4;
dxBodyNoGravity: TBodyFlags = 8;
_priv_dParamLoStop = $000;
_priv_dParamLoStop2 = $100;
_priv_dParamLoStop3 = $200;
dParamLoStop: TJointParams = _priv_dParamLoStop;
dParamHiStop: TJointParams = _priv_dParamLoStop + 1;
dParamVel: TJointParams = _priv_dParamLoStop + 2;
dParamFMax: TJointParams = _priv_dParamLoStop + 3;
dParamFudgeFactor: TJointParams = _priv_dParamLoStop + 4;
dParamBounce: TJointParams = _priv_dParamLoStop + 5;
dParamCFM: TJointParams = _priv_dParamLoStop + 6;
dParamStopERP: TJointParams = _priv_dParamLoStop + 7;
dParamStopCFM: TJointParams = _priv_dParamLoStop + 8;
dParamSuspensionERP: TJointParams = _priv_dParamLoStop + 9;
dParamSuspensionCFM: TJointParams = _priv_dParamLoStop + 10;
dParamERP: TJointParams = _priv_dParamLoStop + 11;
dParamGroup1: TJointParams = $000;
dParamLoStop1: TJointParams = _priv_dParamLoStop;
dParamHiStop1: TJointParams = _priv_dParamLoStop + 1;
dParamVel1: TJointParams = _priv_dParamLoStop + 2;
dParamFMax1: TJointParams = _priv_dParamLoStop + 3;
dParamFudgeFactor1: TJointParams = _priv_dParamLoStop + 4;
dParamBounce1: TJointParams = _priv_dParamLoStop + 5;
dParamCFM1: TJointParams = _priv_dParamLoStop + 6;
dParamStopERP1: TJointParams = _priv_dParamLoStop + 7;
dParamStopCFM1: TJointParams = _priv_dParamLoStop + 8;
dParamSuspensionERP1: TJointParams = _priv_dParamLoStop + 9;
dParamSuspensionCFM1: TJointParams = _priv_dParamLoStop + 10;
dParamERP1: TJointParams = _priv_dParamLoStop + 11;
dParamGroup2: TJointParams = $100;
dParamLoStop2: TJointParams = _priv_dParamLoStop2;
dParamHiStop2: TJointParams = _priv_dParamLoStop2 + 1;
dParamVel2: TJointParams = _priv_dParamLoStop2 + 2;
dParamFMax2: TJointParams = _priv_dParamLoStop2 + 3;
dParamFudgeFactor2: TJointParams = _priv_dParamLoStop2 + 4;
dParamBounce2: TJointParams = _priv_dParamLoStop2 + 5;
dParamCFM2: TJointParams = _priv_dParamLoStop2 + 6;
dParamStopERP2: TJointParams = _priv_dParamLoStop2 + 7;
dParamStopCFM2: TJointParams = _priv_dParamLoStop2 + 8;
dParamSuspensionERP2: TJointParams = _priv_dParamLoStop2 + 9;
dParamSuspensionCFM2: TJointParams = _priv_dParamLoStop2 + 10;
dParamERP2: TJointParams = _priv_dParamLoStop2 + 11;
dParamGroup3: TJointParams = $200;
dParamLoStop3: TJointParams = _priv_dParamLoStop3;
dParamHiStop3: TJointParams = _priv_dParamLoStop3 + 1;
dParamVel3: TJointParams = _priv_dParamLoStop3 + 2;
dParamFMax3: TJointParams = _priv_dParamLoStop3 + 3;
dParamFudgeFactor3: TJointParams = _priv_dParamLoStop3 + 4;
dParamBounce3: TJointParams = _priv_dParamLoStop3 + 5;
dParamCFM3: TJointParams = _priv_dParamLoStop3 + 6;
dParamStopERP3: TJointParams = _priv_dParamLoStop3 + 7;
dParamStopCFM3: TJointParams = _priv_dParamLoStop3 + 8;
dParamSuspensionERP3: TJointParams = _priv_dParamLoStop3 + 9;
dParamSuspensionCFM3: TJointParams = _priv_dParamLoStop3 + 10;
dParamERP3: TJointParams = _priv_dParamLoStop3 + 11;
dParamGroup: TJointParams = $100;
MaxUserClasses = 4;

Variables

dSphereClass: integer=0;
dBoxClass: integer=1;
dCapsuleClass: integer=2;
dCylinderClass: integer=3;
dPlaneClass: integer=4;
dRayClass: integer=5;
dConvexClass: integer=6;
dGeomTransformClass: integer=7;
dTriMeshClass: integer=8;
dHeightFieldClass: integer=9;
dFirstSpaceClass: integer = 10;
dSimpleSpaceClass: integer = 10;
dHashSpaceClass: integer = 11;
dSweepAndPruneSpaceClass: integer = 12;
dQuadTreeSpaceClass: integer = 13;
dLastSpaceClass: integer = 13;
dFirstUserClass: integer = 14;
dLastUserClass: integer = 17;
dGeomNumClasses: integer = 18;
IsODEInitialized: boolean = False;
DisabledDebugGeom: boolean = False;
DisabledDebugCollision: boolean = False;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJointGroup

record TdxJointGroup

Unit

ODEImport

Declaration

type TdxJointGroup = record

Description

Overview

Fields

num: integer;
stack: pointer;

Description

Fields

num: integer;
stack: pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJointLimitMotor

record TdxJointLimitMotor

Unit

ODEImport

Declaration

type TdxJointLimitMotor = record

Description

Overview

Fields

vel: TdReal;
fmax: TdReal;
lostop: TdReal;
histop: TdReal;
fudge_factor: TdReal;
normal_cfm: TdReal;
stop_erp: TdReal;
stop_sfm: TdReal;
bounce: TdReal;
limit: integer;
limit_err: TdReal;

Description

Fields

vel: TdReal;
fmax: TdReal;
lostop: TdReal;
histop: TdReal;
fudge_factor: TdReal;
normal_cfm: TdReal;
stop_erp: TdReal;
stop_sfm: TdReal;
bounce: TdReal;
limit: integer;
limit_err: TdReal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdMass

record TdMass

Unit

ODEImport

Declaration

type TdMass = record

Description

Overview

Fields

mass: TdReal;
c: TdVector4;
I: TdMatrix3;

Description

Fields

mass: TdReal;
c: TdVector4;
I: TdMatrix3;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxAutoDisable

record TdxAutoDisable

Unit

ODEImport

Declaration

type TdxAutoDisable = record

Description

Overview

Fields

idle_time: TdReal;
idle_steps: integer;
linear_average_threashold: TdReal;
angular_average_threashold: TdReal;
average_samples: longword;

Description

Fields

idle_time: TdReal;
idle_steps: integer;
linear_average_threashold: TdReal;
angular_average_threashold: TdReal;
average_samples: longword;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxDampingParameters

record TdxDampingParameters

Unit

ODEImport

Declaration

type TdxDampingParameters = record

Description

Overview

Fields

linear_scale: TdReal;
angular_scale: TdReal;
linear_threahold: TdReal;
angular_threashold: TdReal;

Description

Fields

linear_scale: TdReal;
angular_scale: TdReal;
linear_threahold: TdReal;
angular_threashold: TdReal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxContactParameters

record TdxContactParameters

Unit

ODEImport

Declaration

type TdxContactParameters = record

Description

Overview

Fields

max_vel: TdReal;
min_depth: TdReal;

Description

Fields

max_vel: TdReal;
min_depth: TdReal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxQuickStepParameters

record TdxQuickStepParameters

Unit

ODEImport

Declaration

type TdxQuickStepParameters = record

Description

Overview

Fields

num_iterations: integer;
w: TdReal;

Description

Fields

num_iterations: integer;
w: TdReal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdObject

record TdObject

Unit

ODEImport

Declaration

type TdObject = record

Description

Overview

Fields

World: PdxWorld;
next: PdObject;
tome: PPdObject;
userdata: pointer;
tag: integer;

Description

Fields

World: PdxWorld;
next: PdObject;
tome: PPdObject;
userdata: pointer;
tag: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJointNode

record TdxJointNode

Unit

ODEImport

Declaration

type TdxJointNode = record

Description

Overview

Fields

joint: PdxJoint;
body: PdxBody;
next: PdxJointNode;

Description

Fields

joint: PdxJoint;
body: PdxBody;
next: PdxJointNode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TJointInfo1

record TJointInfo1

Unit

ODEImport

Declaration

type TJointInfo1 = record

Description

Overview

Fields

m: integer;
nub: integer;

Description

Fields

m: integer;
nub: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TJointInfo2

record TJointInfo2

Unit

ODEImport

Declaration

type TJointInfo2 = record

Description

Overview

Fields

fps: TdReal;
erp: TdReal;
J1l: pdReal;
J1a: pdReal;
J2l: pdReal;
J2a: pdReal;
rowskip: integer;
c: pdReal;
cfm: pdReal;
lo: pdReal;
hi: pdReal;
findex: pinteger;

Description

Fields

fps: TdReal;
erp: TdReal;
J1l: pdReal;
J1a: pdReal;
J2l: pdReal;
J2a: pdReal;
rowskip: integer;
c: pdReal;
cfm: pdReal;
lo: pdReal;
hi: pdReal;
findex: pinteger;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJoint

record TdxJoint

Unit

ODEImport

Declaration

type TdxJoint = record

Description

Overview

Fields

baseObject: TdObject;
Info1: TJointInfo1;
Info2: TJointInfo2;

Description

Fields

baseObject: TdObject;
Info1: TJointInfo1;
Info2: TJointInfo2;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJointBall

record TdxJointBall

Unit

ODEImport

Declaration

type TdxJointBall = record

Description

Overview

Fields

BaseJoint: TdxJoint;
anchor1: TdVector3;
anchor2: TdVector3;
erp: TdReal;
cfm: TdReal;

Description

Fields

BaseJoint: TdxJoint;
anchor1: TdVector3;
anchor2: TdVector3;
erp: TdReal;
cfm: TdReal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJointHinge

record TdxJointHinge

Unit

ODEImport

Declaration

type TdxJointHinge = record

Description

Overview

Fields

BaseJoint: TdxJoint;
anchor1: TdVector3;
anchor2: TdVector3;
axis1: TdVector3;
axis2: TdVector3;
qrel: tdQuaternion;
limot: TdxJointLimitMotor;

Description

Fields

BaseJoint: TdxJoint;
anchor1: TdVector3;
anchor2: TdVector3;
axis1: TdVector3;
axis2: TdVector3;
qrel: tdQuaternion;
limot: TdxJointLimitMotor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJointUniversial

record TdxJointUniversial

Unit

ODEImport

Declaration

type TdxJointUniversial = record

Description

Overview

Fields

BaseJoint: TdxJoint;
anchor1: TdVector3;
anchor2: TdVector3;
axis1: TdVector3;
axis2: TdVector3;
qrel1: tdQuaternion;
qrel2: tdQuaternion;
limot1: TdxJointLimitMotor;
limot2: TdxJointLimitMotor;

Description

Fields

BaseJoint: TdxJoint;
anchor1: TdVector3;
anchor2: TdVector3;
axis1: TdVector3;
axis2: TdVector3;
qrel1: tdQuaternion;
qrel2: tdQuaternion;
limot1: TdxJointLimitMotor;
limot2: TdxJointLimitMotor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJointPR

record TdxJointPR

Unit

ODEImport

Declaration

type TdxJointPR = record

Description

Overview

Fields

BaseJoint: TdxJoint;
anchor2:TdVector3;
axisR1:TdVector3 ;
axisR2:TdVector3 ;
axisP1:TdVector3;
qrel:TdQuaternion;
offset:TdVector3;
limotR:TdxJointLimitMotor;
limotP:TdxJointLimitMotor;

Description

Fields

BaseJoint: TdxJoint;
anchor2:TdVector3;
axisR1:TdVector3 ;
axisR2:TdVector3 ;
axisP1:TdVector3;
qrel:TdQuaternion;
offset:TdVector3;
limotR:TdxJointLimitMotor;
limotP:TdxJointLimitMotor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJointPiston

record TdxJointPiston

Unit

ODEImport

Declaration

type TdxJointPiston = record

Description

Overview

Fields

BaseJoint: TdxJoint;
axis1:TdVector3;
axis2:TdVector3;
qrel:TdQuaternion;
anchor1:TdVector3;
anchor2:TdVector3;
limotP:TdxJointLimitMotor;
limotR:TdxJointLimitMotor;

Description

Fields

BaseJoint: TdxJoint;
axis1:TdVector3;
axis2:TdVector3;
qrel:TdQuaternion;
anchor1:TdVector3;
anchor2:TdVector3;
limotP:TdxJointLimitMotor;
limotR:TdxJointLimitMotor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJointSlider

record TdxJointSlider

Unit

ODEImport

Declaration

type TdxJointSlider = record

Description

Overview

Fields

BaseJoint: TdxJoint;
axis1:TdVector3;
qrel:TdQuaternion;
offset:TdVector3;
limot:TdxJointLimitMotor;

Description

Fields

BaseJoint: TdxJoint;
axis1:TdVector3;
qrel:TdQuaternion;
offset:TdVector3;
limot:TdxJointLimitMotor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJointHinge2

record TdxJointHinge2

Unit

ODEImport

Declaration

type TdxJointHinge2 = record

Description

Overview

Fields

BaseJoint: TdxJoint;
anchor1:TdVector3 ;
anchor2:TdVector3 ;
axis1:TdVector3;
axis2:TdVector3;
c0:TdReal;
s0:TdReal;
v1:TdVector3;
v2:TdVector3;
limot1:TdxJointLimitMotor;
limot2:TdxJointLimitMotor;
susp_erp:TdReal;
susp_cfm:TdReal;

Description

Fields

BaseJoint: TdxJoint;
anchor1:TdVector3 ;
anchor2:TdVector3 ;
axis1:TdVector3;
axis2:TdVector3;
c0:TdReal;
s0:TdReal;
v1:TdVector3;
v2:TdVector3;
limot1:TdxJointLimitMotor;
limot2:TdxJointLimitMotor;
susp_erp:TdReal;
susp_cfm:TdReal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJointAMotor

record TdxJointAMotor

Unit

ODEImport

Declaration

type TdxJointAMotor = record

Description

Overview

Fields

BaseJoint: TdxJoint;
num:integer;
mode:integer;
rel:TdInteger3;
axis:Td3Axis;
limot:TdxJointLimitMotor3;
angle:TdVector3;
reference1:TdVector3;
reference2:TdVector3;

Description

Fields

BaseJoint: TdxJoint;
num:integer;
mode:integer;
rel:TdInteger3;
axis:Td3Axis;
limot:TdxJointLimitMotor3;
angle:TdVector3;
reference1:TdVector3;
reference2:TdVector3;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJointLMotor

record TdxJointLMotor

Unit

ODEImport

Declaration

type TdxJointLMotor = record

Description

Overview

Fields

BaseJoint: TdxJoint;
num: integer;
rel:TdInteger3;
axis:Td3Axis;
limot:TdxJointLimitMotor3;

Description

Fields

BaseJoint: TdxJoint;
num: integer;
rel:TdInteger3;
axis:Td3Axis;
limot:TdxJointLimitMotor3;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJointPlane2D

record TdxJointPlane2D

Unit

ODEImport

Declaration

type TdxJointPlane2D = record

Description

Overview

Fields

BaseJoint: TdxJoint;
row_motor_x:integer;
row_motor_y:integer;
row_motor_angle:integer;
motor_x:TdxJointLimitMotor;
motor_y:TdxJointLimitMotor;
motor_angle:TdxJointLimitMotor;

Description

Fields

BaseJoint: TdxJoint;
row_motor_x:integer;
row_motor_y:integer;
row_motor_angle:integer;
motor_x:TdxJointLimitMotor;
motor_y:TdxJointLimitMotor;
motor_angle:TdxJointLimitMotor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxJointFixed

record TdxJointFixed

Unit

ODEImport

Declaration

type TdxJointFixed = record

Description

Overview

Fields

BaseJoint: TdxJoint;
qrel:TdQuaternion;
offset:TdVector3;
erp:TdReal;
cfm:TdReal;

Description

Fields

BaseJoint: TdxJoint;
qrel:TdQuaternion;
offset:TdVector3;
erp:TdReal;
cfm:TdReal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxPosR

record TdxPosR

Unit

ODEImport

Declaration

type TdxPosR = record

Description

Overview

Fields

pos: TdVector3;
R: TdMatrix3;

Description

Fields

pos: TdVector3;
R: TdMatrix3;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxBody

record TdxBody

Unit

ODEImport

Declaration

type TdxBody = record

Description

Overview

Fields

BaseObject: TdObject;
Padding: byte;
firstjoint: TdJointID;
flags: integer;
geom: PdxGeom;
mass: TdMass;
invI: TdMatrix3 ;
invMass: TdReal;
posr: TdxPosR;
q: TdQuaternion;
lvel: TdVector3;
avel: TdVector3;
facc: TdVector3 ;
tacc: TdVector3 ;
finite_rot_axis: TdVector3 ;
adis: TdxAutoDisable;
adis_timeleft: TdReal;
adis_stepsleft: integer;
average_lvel_buffer: pdVector3;
average_avel_buffer: pdVector3;
average_counter: longword;
average_ready: integer;
moved_callback: TdMovedCallback;
dampingp: TdxDampingParameters;
max_angular_speed: TdReal;

Description

Fields

BaseObject: TdObject;
Padding: byte;
firstjoint: TdJointID;
flags: integer;
geom: PdxGeom;
mass: TdMass;
invI: TdMatrix3 ;
invMass: TdReal;
posr: TdxPosR;
q: TdQuaternion;
lvel: TdVector3;
avel: TdVector3;
facc: TdVector3 ;
tacc: TdVector3 ;
finite_rot_axis: TdVector3 ;
adis: TdxAutoDisable;
adis_timeleft: TdReal;
adis_stepsleft: integer;
average_lvel_buffer: pdVector3;
average_avel_buffer: pdVector3;
average_counter: longword;
average_ready: integer;
moved_callback: TdMovedCallback;
dampingp: TdxDampingParameters;
max_angular_speed: TdReal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: Class TBodyList

Class TBodyList

Unit

ODEImport

Declaration

type TBodyList = class(TList)

Description

Hierarchy

  • TList
  • TBodyList

Overview

Methods

Public procedure DeleteAllBodies;

Properties

Public property Items[i : integer]: PdxBody read GetItems write SetItems;

Description

Methods

Public procedure DeleteAllBodies;

Properties

Public property Items[i : integer]: PdxBody read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxWorld

record TdxWorld

Unit

ODEImport

Declaration

type TdxWorld = record

Description

Overview

Fields

firstbody: PdxBody;
firstjoint: PdxJoint;
nb: integer;
nj: integer;
gravity: TdVector3;
global_erp: TdReal;
global_cfm: TdReal;
adis: TdxAutoDisable;
body_flags: integer;
qs: TdxQuickStepParameters;
contactp: TdxContactParameters;
dampingp: TdxDampingParameters;
max_angular_speed: TdReal;

Description

Fields

firstbody: PdxBody;
firstjoint: PdxJoint;
nb: integer;
nj: integer;
gravity: TdVector3;
global_erp: TdReal;
global_cfm: TdReal;
adis: TdxAutoDisable;
body_flags: integer;
qs: TdxQuickStepParameters;
contactp: TdxContactParameters;
dampingp: TdxDampingParameters;
max_angular_speed: TdReal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdJointFeedback

record TdJointFeedback

Unit

ODEImport

Declaration

type TdJointFeedback = record

Description

Overview

Fields

f1: TdVector3;
t1: TdVector3;
f2: TdVector3;
t2: TdVector3;

Description

Fields

f1: TdVector3;
t1: TdVector3;
f2: TdVector3;
t2: TdVector3;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdSurfaceParameters

record TdSurfaceParameters

Unit

ODEImport

Declaration

type TdSurfaceParameters = record

Description

Overview

Fields

mode: integer;
mu: TdReal;
mu2: TdReal
bounce: TdReal
bounce_vel: TdReal
soft_erp: TdReal
soft_cfm: TdReal
motion1: TdReal
motion2: TdReal
motionN: TdReal
slip1: TdReal
slip2: TdReal

Description

Fields

mode: integer;
mu: TdReal;
mu2: TdReal
bounce: TdReal
bounce_vel: TdReal
soft_erp: TdReal
soft_cfm: TdReal
motion1: TdReal
motion2: TdReal
motionN: TdReal
slip1: TdReal
slip2: TdReal
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdContactGeom

record TdContactGeom

Unit

ODEImport

Declaration

type TdContactGeom = record

Description

Overview

Fields

pos: TdVector3;
normal: TdVector3;
depth: TdReal;
g1: PdxGeom;
g2: PdxGeom;
side1: integer;
side2: integer;

Description

Fields

pos: TdVector3;
normal: TdVector3;
depth: TdReal;
g1: PdxGeom;
g2: PdxGeom;
side1: integer;
side2: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdContact

record TdContact

Unit

ODEImport

Declaration

type TdContact = record

Description

Overview

Fields

surface: TdSurfaceParameters;
geom: TdContactGeom;
fdir1: TdVector3;

Description

Fields

surface: TdSurfaceParameters;
geom: TdContactGeom;
fdir1: TdVector3;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdGeomClass

record TdGeomClass

Unit

ODEImport

Declaration

type TdGeomClass = record

Description

Overview

Fields

bytes: integer;
collider: TdGetColliderFnFn;
aabb: TdGetAABBFn;
aabb_test: TdAABBTestFn;
dtor: TdGeomDtorFn;

Description

Fields

bytes: integer;
collider: TdGetColliderFnFn;
aabb: TdGetAABBFn;
aabb_test: TdAABBTestFn;
dtor: TdGeomDtorFn;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxTriMeshData

record TdxTriMeshData

Unit

ODEImport

Declaration

type TdxTriMeshData = record

Description

Overview

Fields

unknown: byte;

Description

Fields

unknown: byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxHeightfieldData

record TdxHeightfieldData

Unit

ODEImport

Declaration

type TdxHeightfieldData = record

Description

Overview

Fields

m_fWidth: TdReal;
m_fDepth: TdReal;
m_fSampleWidth: TdReal;
m_fSampleDepth: TdReal;
m_fInvSampleWidth: TdReal;
m_fInvSampleDepth: TdReal;
m_fHalfWidth: TdReal;
m_fHalfDepth: TdReal;
m_fMinHeight: TdReal;
m_fMaxHeight: TdReal;
m_fThickness: TdReal;
m_fScale: TdReal;
m_fOffset: TdReal;
m_nWidthSamples: integer;
m_nDepthSamples: integer;
m_bCopyHeightData: integer;
m_bWrapMode: integer;
m_nGetHeightMode: integer;
m_pHeightData: pointer;
m_pUserData: pointer;
m_contacts: PdContactGeom;

Description

Fields

m_fWidth: TdReal;
m_fDepth: TdReal;
m_fSampleWidth: TdReal;
m_fSampleDepth: TdReal;
m_fInvSampleWidth: TdReal;
m_fInvSampleDepth: TdReal;
m_fHalfWidth: TdReal;
m_fHalfDepth: TdReal;
m_fMinHeight: TdReal;
m_fMaxHeight: TdReal;
m_fThickness: TdReal;
m_fScale: TdReal;
m_fOffset: TdReal;
m_nWidthSamples: integer;
m_nDepthSamples: integer;
m_bCopyHeightData: integer;
m_bWrapMode: integer;
m_nGetHeightMode: integer;
m_pHeightData: pointer;
m_pUserData: pointer;
m_contacts: PdContactGeom;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdGeomSpaceData

record TdGeomSpaceData

Unit

ODEImport

Declaration

type TdGeomSpaceData = record

Description

Overview

Fields

next: PdxGeom;

Description

Fields

next: PdxGeom;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: record TdxGeom

record TdxGeom

Unit

ODEImport

Declaration

type TdxGeom = record

Description

Overview

Fields

_type: integer;
Padding: byte;
gflags: integer;
data: pointer;
Body: PdxBody ;
body_next: PdxGeom;
final_posr: PdxPosR;
offset_posr: PdxPosR;
next: PdxGeom;
tome: PPdxGeom;
parent_space: Pdxspace;
aabb: TdAABB;
category_bits: longword;
collide_bits: longword;

Description

Fields

_type: integer;
Padding: byte;
gflags: integer;
data: pointer;
Body: PdxBody ;
body_next: PdxGeom;
final_posr: PdxPosR;
offset_posr: PdxPosR;
next: PdxGeom;
tome: PPdxGeom;
parent_space: Pdxspace;
aabb: TdAABB;
category_bits: longword;
collide_bits: longword;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:19


GLScene v.1.1.2: ODEImport: Class TGeomList

Class TGeomList

Unit

ODEImport

Declaration

type TGeomList = class(TList)

Description

Hierarchy

  • TList
  • TGeomList

Overview

Methods

Public procedure DeleteAllGeoms(DeleteDataAsObject : boolean=false);

Properties

Public property Items[i : integer]: PdxGeom read GetItems write SetItems;

Description

Methods

Public procedure DeleteAllGeoms(DeleteDataAsObject : boolean=false);

Properties

Public property Items[i : integer]: PdxGeom read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:20


GLScene v.1.1.2: ODEImport: record TdxSpace

record TdxSpace

Unit

ODEImport

Declaration

type TdxSpace = record

Description

Overview

Fields

baseGeom: TdxGeom;
count: integer;
first: PdxGeom;
cleanup: integer;
current_index: integer;
current_geom: PdxGeom;
lock_count: integer;

Description

Fields

baseGeom: TdxGeom;
count: integer;
first: PdxGeom;
cleanup: integer;
current_index: integer;
current_geom: PdxGeom;
lock_count: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:20


GLScene v.1.1.2: ODEImport: record TdxHashSpace

record TdxHashSpace

Unit

ODEImport

Declaration

type TdxHashSpace = record

Description

Overview

Fields

BaseSpace: TdxSpace;
global_minlevel: integer;
global_maxlevel: integer;

Description

Fields

BaseSpace: TdxSpace;
global_minlevel: integer;
global_maxlevel: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:20


GLScene v.1.1.2: ODEImport: record TdxQuadTreeSpace

record TdxQuadTreeSpace

Unit

ODEImport

Declaration

type TdxQuadTreeSpace = record

Description

Overview

Fields

BaseSpace: TdxSpace;
Blocks: pointer;
DirtyList: pointer;

Description

Fields

BaseSpace: TdxSpace;
Blocks: pointer;
DirtyList: pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:20


GLScene v.1.1.2: openal

Unit openal

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TEaxListenerProperties |
packed record TEaxBufferProperties |
packed record _EFXEAXREVERBPROPERTIES |
packed record _EFXLOWPASSFILTER |

Functions and Procedures

procedure alutInit(argc: PALint; argv: array of PALbyte);
procedure alutExit;
procedure alutLoadWAVFile(fname: string; var format: TALenum; var data: TALvoid; var size: TALsizei; var freq: TALsizei; var loop: TALint);
procedure alutLoadWAVMemory(memory: PALbyte; var format: TALenum; var data: TALvoid; var size: TALsizei; var freq: TALsizei; var loop: TALint);
procedure alutUnloadWAV(format: TALenum; data: TALvoid; size: TALsizei; freq: TALsizei);
function InitOpenAL(LibName: String = callibname): Boolean;
procedure ReadOpenALExtensions;

Types

TALboolean = Boolean;
PALboolean = ˆTALboolean;
TALchar = char;
PALchar = PAnsiChar;
TALbyte = ShortInt;
PALbyte = ˆTALbyte;
TALuByte = Char;
PALuByte = PAnsiChar;
TALshort = SmallInt;
PALshort = ˆTALshort;
TALushort = Word;
PALushort = ˆTALushort;
TALuint = Cardinal;
PALuint = ˆTALuint;
TALint = Integer;
PALint = ˆTALint;
TALfloat = Single;
PALfloat = ˆTALfloat;
TALdouble = Double;
PALdouble = ˆTALdouble;
TALsizei = Cardinal;
PALsizei = ˆTALsizei;
TALvoid = Pointer;
PALvoid = ˆTALvoid;
PPALvoid = ˆPALvoid;
TALenum = Integer;
PALenum = ˆTALenum;
TALbitfield = Cardinal;
PALbitfield = ˆTALbitfield;
TALclampf = TALfloat;
PALclampf = ˆTALclampf;
TALclampd = TALdouble;
PALclampd = ˆTALclampd;
TALCenum = integer;
PALCenum = ˆTALCenum;
TALCboolean = boolean;
PALCboolean = ˆTALCboolean;
TALCchar = char;
PALCchar = PAnsiChar;
TALCbyte = ShortInt;
PALCbyte = ˆTALCbyte;
TALCubyte = Char;
PALCubyte = PAnsiChar;
TALCshort = smallint;
PALCshort = ˆTALCshort;
TALCushort = Word;
PALCushort = ˆTALCushort;
TALCuint = Cardinal;
PALCuint = ˆTALCuint;
TALCint = integer;
PALCint = ˆTALCint;
TALCfloat = single;
PALCfloat = ˆTALCfloat;
TALCdouble = double;
PALCdouble = ˆTALCdouble;
TALCsizei = integer;
PALCsizei = ˆTALCsizei;
TALCvoid = Pointer;
PALCvoid = ˆTALCvoid;
TALCdevice = TALCvoid;
PALCdevice = ˆTALCdevice;
TALCcontext = TALCvoid;
PALCcontext = ˆTALCcontext;
DSPROPERTY_EAX_LISTENERPROPERTY = LongWORD;
DSPROPERTY_EAX_BUFFERPROPERTY = LongWORD;
PEaxListenerProperties = ˆTEaxListenerProperties;
PEaxBufferProperties = ˆTEaxBufferProperties;
EFXEAXREVERBPROPERTIES = _EFXEAXREVERBPROPERTIES;
PEFXEAXREVERBPROPERTIES = ˆ_EFXEAXREVERBPROPERTIES;
EFXLOWPASSFILTER = _EFXLOWPASSFILTER;
PEFXLOWPASSFILTER = ˆ_EFXLOWPASSFILTER;
HMODULE = THandle;

Constants

callibname='OpenAL32.dll';
calutlibname='Alut.dll';
AL_INVALID = -1;
AL_NONE = 0;
AL_FALSE = 0;
AL_TRUE = 1;
AL_SOURCE_ABSOLUTE = $201;
AL_SOURCE_RELATIVE = $202;
AL_CONE_INNER_ANGLE = $1001;
AL_CONE_OUTER_ANGLE = $1002;
AL_PITCH =$1003;
AL_POSITION =$1004;
AL_DIRECTION =$1005;
AL_VELOCITY =$1006;
AL_LOOPING =$1007;
AL_BUFFER =$1009;
AL_GAIN =$100A;
AL_MIN_GAIN =$100D;
AL_MAX_GAIN =$100E;
AL_ORIENTATION =$100F;
AL_CHANNEL_MASK =$3000;
AL_SOURCE_STATE =$1010;
AL_INITIAL =$1011;
AL_PLAYING =$1012;
AL_PAUSED =$1013;
AL_STOPPED =$1014;
AL_BUFFERS_QUEUED =$1015;
AL_BUFFERS_PROCESSED =$1016;
AL_SEC_OFFSET = $1024;
AL_SAMPLE_OFFSET = $1025;
AL_BYTE_OFFSET = $1026;
AL_SOURCE_TYPE = $1027;
AL_STATIC = $1028;
AL_STREAMING = $1029;
AL_UNDETERMINED = $1030;
AL_FORMAT_MONO8 =$1100;
AL_FORMAT_MONO16 =$1101;
AL_FORMAT_STEREO8 =$1102;
AL_FORMAT_STEREO16 =$1103;
AL_REFERENCE_DISTANCE =$1020;
AL_ROLLOFF_FACTOR =$1021;
AL_CONE_OUTER_GAIN =$1022;
AL_MAX_DISTANCE =$1023;
AL_FREQUENCY =$2001;
AL_BITS =$2002;
AL_CHANNELS =$2003;
AL_SIZE =$2004;
AL_UNUSED =$2010;
AL_PENDING =$2011;
AL_PROCESSED =$2012;
AL_NO_ERROR =AL_FALSE;
AL_INVALID_NAME =$A001;
AL_ILLEGAL_ENUM =$A002;
AL_INVALID_ENUM =$A002;
AL_INVALID_VALUE =$A003;
AL_ILLEGAL_COMMAND =$A004;
AL_INVALID_OPERATION =$A004;
AL_OUT_OF_MEMORY =$A005;
AL_VENDOR =$B001;
AL_VERSION =$B002;
AL_RENDERER =$B003;
AL_EXTENSIONS =$B004;
AL_DOPPLER_FACTOR =$C000;
AL_DOPPLER_VELOCITY =$C001;
AL_SPEED_OF_SOUND = $C003;
AL_DISTANCE_MODEL =$D000;
AL_INVERSE_DISTANCE =$D001;
AL_INVERSE_DISTANCE_CLAMPED =$D002;
AL_LINEAR_DISTANCE =$D003;
AL_LINEAR_DISTANCE_CLAMPED =$D004;
AL_EXPONENT_DISTANCE =$D005;
AL_EXPONENT_DISTANCE_CLAMPED =$D006;
ALC_INVALID =0;
ALC_FALSE =0;
ALC_TRUE =1;
ALC_FREQUENCY =$1007;
ALC_REFRESH =$1008;
ALC_SYNC =$1009;
ALC_MONO_SOURCES =$1010;
ALC_STEREO_SOURCES =$1011;
ALC_NO_ERROR =ALC_FALSE;
ALC_INVALID_DEVICE =$A001;
ALC_INVALID_CONTEXT =$A002;
ALC_INVALID_ENUM =$A003;
ALC_INVALID_VALUE =$A004;
ALC_OUT_OF_MEMORY =$A005;
ALC_DEFAULT_DEVICE_SPECIFIER =$1004;
ALC_DEVICE_SPECIFIER =$1005;
ALC_EXTENSIONS =$1006;
ALC_MAJOR_VERSION =$1000;
ALC_MINOR_VERSION =$1001;
ALC_ATTRIBUTES_SIZE =$1002;
ALC_ALL_ATTRIBUTES =$1003;
ALC_DEFAULT_ALL_DEVICES_SPECIFIER =$1012;
ALC_ALL_DEVICES_SPECIFIER =$1013;
ALC_CAPTURE_DEVICE_SPECIFIER =$310;
ALC_CAPTURE_DEFAULT_DEVICE_SPECIFIER =$311;
ALC_CAPTURE_SAMPLES =$312;
ALC_EXT_EFX_NAME ='ALC_EXT_EFX';
ALC_EFX_MAJOR_VERSION =$20001;
ALC_EFX_MINOR_VERSION =$20002;
ALC_MAX_AUXILIARY_SENDS =$20003;
AL_METERS_PER_UNIT =$20004;
AL_DIRECT_FILTER =$20005;
AL_AUXILIARY_SEND_FILTER =$20006;
AL_AIR_ABSORPTION_FACTOR =$20007;
AL_ROOM_ROLLOFF_FACTOR =$20008;
AL_CONE_OUTER_GAINHF =$20009;
AL_DIRECT_FILTER_GAINHF_AUTO =$2000A;
AL_AUXILIARY_SEND_FILTER_GAIN_AUTO =$2000B;
AL_AUXILIARY_SEND_FILTER_GAINHF_AUTO =$2000C;
AL_REVERB_DENSITY =$0001;
AL_REVERB_DIFFUSION =$0002;
AL_REVERB_GAIN =$0003;
AL_REVERB_GAINHF =$0004;
AL_REVERB_DECAY_TIME =$0005;
AL_REVERB_DECAY_HFRATIO =$0006;
AL_REVERB_REFLECTIONS_GAIN =$0007;
AL_REVERB_REFLECTIONS_DELAY =$0008;
AL_REVERB_LATE_REVERB_GAIN =$0009;
AL_REVERB_LATE_REVERB_DELAY =$000A;
AL_REVERB_AIR_ABSORPTION_GAINHF =$000B;
AL_REVERB_ROOM_ROLLOFF_FACTOR =$000C;
AL_REVERB_DECAY_HFLIMIT =$000D;
AL_CHORUS_WAVEFORM =$0001;
AL_CHORUS_PHASE =$0002;
AL_CHORUS_RATE =$0003;
AL_CHORUS_DEPTH =$0004;
AL_CHORUS_FEEDBACK =$0005;
AL_CHORUS_DELAY =$0006;
AL_DISTORTION_EDGE =$0001;
AL_DISTORTION_GAIN =$0002;
AL_DISTORTION_LOWPASS_CUTOFF =$0003;
AL_DISTORTION_EQCENTER =$0004;
AL_DISTORTION_EQBANDWIDTH =$0005;
AL_ECHO_DELAY =$0001;
AL_ECHO_LRDELAY =$0002;
AL_ECHO_DAMPING =$0003;
AL_ECHO_FEEDBACK =$0004;
AL_ECHO_SPREAD =$0005;
AL_FLANGER_WAVEFORM =$0001;
AL_FLANGER_PHASE =$0002;
AL_FLANGER_RATE =$0003;
AL_FLANGER_DEPTH =$0004;
AL_FLANGER_FEEDBACK =$0005;
AL_FLANGER_DELAY =$0006;
AL_FREQUENCY_SHIFTER_FREQUENCY =$0001;
AL_FREQUENCY_SHIFTER_LEFT_DIRECTION =$0002;
AL_FREQUENCY_SHIFTER_RIGHT_DIRECTION =$0003;
AL_VOCAL_MORPHER_PHONEMEA =$0001;
AL_VOCAL_MORPHER_PHONEMEA_COARSE_TUNING =$0002;
AL_VOCAL_MORPHER_PHONEMEB =$0003;
AL_VOCAL_MORPHER_PHONEMEB_COARSE_TUNING =$0004;
AL_VOCAL_MORPHER_WAVEFORM =$0005;
AL_VOCAL_MORPHER_RATE =$0006;
AL_PITCH_SHIFTER_COARSE_TUNE =$0001;
AL_PITCH_SHIFTER_FINE_TUNE =$0002;
AL_RING_MODULATOR_FREQUENCY =$0001;
AL_RING_MODULATOR_HIGHPASS_CUTOFF =$0002;
AL_RING_MODULATOR_WAVEFORM =$0003;
AL_AUTOWAH_ATTACK_TIME =$0001;
AL_AUTOWAH_RELEASE_TIME =$0002;
AL_AUTOWAH_RESONANCE =$0003;
AL_AUTOWAH_PEAK_GAIN =$0004;
AL_COMPRESSOR_ONOFF =$0001;
AL_EQUALIZER_LOW_GAIN =$0001;
AL_EQUALIZER_LOW_CUTOFF =$0002;
AL_EQUALIZER_MID1_GAIN =$0003;
AL_EQUALIZER_MID1_CENTER =$0004;
AL_EQUALIZER_MID1_WIDTH =$0005;
AL_EQUALIZER_MID2_GAIN =$0006;
AL_EQUALIZER_MID2_CENTER =$0007;
AL_EQUALIZER_MID2_WIDTH =$0008;
AL_EQUALIZER_HIGH_GAIN =$0009;
AL_EQUALIZER_HIGH_CUTOFF =$000A;
AL_EFFECT_FIRST_PARAMETER =$0000;
AL_EFFECT_LAST_PARAMETER =$8000;
AL_EFFECT_TYPE =$8001;
AL_EFFECT_NULL =$0000;
AL_EFFECT_REVERB =$0001;
AL_EFFECT_CHORUS =$0002;
AL_EFFECT_DISTORTION =$0003;
AL_EFFECT_ECHO =$0004;
AL_EFFECT_FLANGER =$0005;
AL_EFFECT_FREQUENCY_SHIFTER =$0006;
AL_EFFECT_VOCAL_MORPHER =$0007;
AL_EFFECT_PITCH_SHIFTER =$0008;
AL_EFFECT_RING_MODULATOR =$0009;
AL_EFFECT_AUTOWAH =$000A;
AL_EFFECT_COMPRESSOR =$000B;
AL_EFFECT_EQUALIZER =$000C;
AL_EFFECTSLOT_EFFECT =$0001;
AL_EFFECTSLOT_GAIN =$0002;
AL_EFFECTSLOT_AUXILIARY_SEND_AUTO =$0003;
AL_EFFECTSLOT_NULL =$0000;
AL_LOWPASS_GAIN =$0001;
AL_LOWPASS_GAINHF =$0002;
AL_HIGHPASS_GAIN =$0001;
AL_HIGHPASS_GAINLF =$0002;
AL_BANDPASS_GAIN =$0001;
AL_BANDPASS_GAINLF =$0002;
AL_BANDPASS_GAINHF =$0003;
AL_FILTER_FIRST_PARAMETER =$0000;
AL_FILTER_LAST_PARAMETER =$8000;
AL_FILTER_TYPE =$8001;
AL_FILTER_NULL =$0000;
AL_FILTER_LOWPASS =$0001;
AL_FILTER_HIGHPASS =$0002;
AL_FILTER_BANDPASS =$0003;
LOWPASS_MIN_GAIN =0.0;
LOWPASS_MAX_GAIN =1.0;
LOWPASS_DEFAULT_GAIN =1.0;
LOWPASS_MIN_GAINHF =0.0;
LOWPASS_MAX_GAINHF =1.0;
LOWPASS_DEFAULT_GAINHF =1.0;
HIGHPASS_MIN_GAIN =0.0;
HIGHPASS_MAX_GAIN =1.0;
HIGHPASS_DEFAULT_GAIN =1.0;
HIGHPASS_MIN_GAINLF =0.0;
HIGHPASS_MAX_GAINLF =1.0;
HIGHPASS_DEFAULT_GAINLF =1.0;
BANDPASS_MIN_GAIN =0.0;
BANDPASS_MAX_GAIN =1.0;
BANDPASS_DEFAULT_GAIN =1.0;
BANDPASS_MIN_GAINHF =0.0;
BANDPASS_MAX_GAINHF =1.0;
BANDPASS_DEFAULT_GAINHF =1.0;
BANDPASS_MIN_GAINLF =0.0;
BANDPASS_MAX_GAINLF =1.0;
BANDPASS_DEFAULT_GAINLF =1.0;
AL_REVERB_MIN_DENSITY =0.0;
AL_REVERB_MAX_DENSITY =1.0;
AL_REVERB_DEFAULT_DENSITY =1.0;
AL_REVERB_MIN_DIFFUSION =0.0;
AL_REVERB_MAX_DIFFUSION =1.0;
AL_REVERB_DEFAULT_DIFFUSION =1.0;
AL_REVERB_MIN_GAIN =0.0;
AL_REVERB_MAX_GAIN =1.0;
AL_REVERB_DEFAULT_GAIN =0.32;
AL_REVERB_MIN_GAINHF =0.0;
AL_REVERB_MAX_GAINHF =1.0;
AL_REVERB_DEFAULT_GAINHF =0.89;
AL_REVERB_MIN_DECAY_TIME =0.1;
AL_REVERB_MAX_DECAY_TIME =20.0;
AL_REVERB_DEFAULT_DECAY_TIME =1.49;
AL_REVERB_MIN_DECAY_HFRATIO =0.1;
AL_REVERB_MAX_DECAY_HFRATIO =2.0;
AL_REVERB_DEFAULT_DECAY_HFRATIO =0.83;
AL_REVERB_MIN_REFLECTIONS_GAIN =0.0;
AL_REVERB_MAX_REFLECTIONS_GAIN =3.16;
AL_REVERB_DEFAULT_REFLECTIONS_GAIN =0.05;
AL_REVERB_MIN_REFLECTIONS_DELAY =0.0;
AL_REVERB_MAX_REFLECTIONS_DELAY =0.3;
AL_REVERB_DEFAULT_REFLECTIONS_DELAY =0.007;
AL_REVERB_MIN_LATE_REVERB_GAIN =0.0;
AL_REVERB_MAX_LATE_REVERB_GAIN =10.0;
AL_REVERB_DEFAULT_LATE_REVERB_GAIN =1.26;
AL_REVERB_MIN_LATE_REVERB_DELAY =0.0;
AL_REVERB_MAX_LATE_REVERB_DELAY =0.1;
AL_REVERB_DEFAULT_LATE_REVERB_DELAY =0.011;
AL_REVERB_MIN_AIR_ABSORPTION_GAINHF =0.892;
AL_REVERB_MAX_AIR_ABSORPTION_GAINHF =1.0;
AL_REVERB_DEFAULT_AIR_ABSORPTION_GAINHF =0.994;
AL_REVERB_MIN_ROOM_ROLLOFF_FACTOR =0.0;
AL_REVERB_MAX_ROOM_ROLLOFF_FACTOR =10.0;
AL_REVERB_DEFAULT_ROOM_ROLLOFF_FACTOR =0.0;
AL_REVERB_MIN_DECAY_HFLIMIT =AL_FALSE;
AL_REVERB_MAX_DECAY_HFLIMIT =AL_TRUE;
AL_REVERB_DEFAULT_DECAY_HFLIMIT =AL_TRUE;
AL_CHORUS_MIN_WAVEFORM =0;
AL_CHORUS_MAX_WAVEFORM =1;
AL_CHORUS_DEFAULT_WAVEFORM =1;
AL_CHORUS_WAVEFORM_SINUSOID =0;
AL_CHORUS_WAVEFORM_TRIANGLE =1;
AL_CHORUS_MIN_PHASE =-180;
AL_CHORUS_MAX_PHASE =180;
AL_CHORUS_DEFAULT_PHASE =90;
AL_CHORUS_MIN_RATE =0.0;
AL_CHORUS_MAX_RATE =10.0;
AL_CHORUS_DEFAULT_RATE =1.1;
AL_CHORUS_MIN_DEPTH =0.0;
AL_CHORUS_MAX_DEPTH =1.0;
AL_CHORUS_DEFAULT_DEPTH =0.1;
AL_CHORUS_MIN_FEEDBACK =-1.0;
AL_CHORUS_MAX_FEEDBACK =1.0;
AL_CHORUS_DEFAULT_FEEDBACK =0.25;
AL_CHORUS_MIN_DELAY =0.0;
AL_CHORUS_MAX_DELAY =0.016;
AL_CHORUS_DEFAULT_DELAY =0.016;
AL_DISTORTION_MIN_EDGE =0.0;
AL_DISTORTION_MAX_EDGE =1.0;
AL_DISTORTION_DEFAULT_EDGE =0.2;
AL_DISTORTION_MIN_GAIN =0.01;
AL_DISTORTION_MAX_GAIN =1.0;
AL_DISTORTION_DEFAULT_GAIN =0.05;
AL_DISTORTION_MIN_LOWPASS_CUTOFF =80.0;
AL_DISTORTION_MAX_LOWPASS_CUTOFF =24000.0;
AL_DISTORTION_DEFAULT_LOWPASS_CUTOFF =8000.0;
AL_DISTORTION_MIN_EQCENTER =80.0;
AL_DISTORTION_MAX_EQCENTER =24000.0;
AL_DISTORTION_DEFAULT_EQCENTER =3600.0;
AL_DISTORTION_MIN_EQBANDWIDTH =80.0;
AL_DISTORTION_MAX_EQBANDWIDTH =24000.0;
AL_DISTORTION_DEFAULT_EQBANDWIDTH =3600.0;
AL_ECHO_MIN_DELAY =0.0;
AL_ECHO_MAX_DELAY =0.207;
AL_ECHO_DEFAULT_DELAY =0.1;
AL_ECHO_MIN_LRDELAY =0.0;
AL_ECHO_MAX_LRDELAY =0.404;
AL_ECHO_DEFAULT_LRDELAY =0.1;
AL_ECHO_MIN_DAMPING =0.0;
AL_ECHO_MAX_DAMPING =0.99;
AL_ECHO_DEFAULT_DAMPING =0.5;
AL_ECHO_MIN_FEEDBACK =0.0;
AL_ECHO_MAX_FEEDBACK =1.0;
AL_ECHO_DEFAULT_FEEDBACK =0.5;
AL_ECHO_MIN_SPREAD =-1.0;
AL_ECHO_MAX_SPREAD =1.0;
AL_ECHO_DEFAULT_SPREAD =-1.0;
AL_FLANGER_MIN_WAVEFORM =0;
AL_FLANGER_MAX_WAVEFORM =1;
AL_FLANGER_DEFAULT_WAVEFORM =1;
AL_FLANGER_WAVEFORM_SINUSOID =0;
AL_FLANGER_WAVEFORM_TRIANGLE =1;
AL_FLANGER_MIN_PHASE =-180;
AL_FLANGER_MAX_PHASE =180;
AL_FLANGER_DEFAULT_PHASE =0;
AL_FLANGER_MIN_RATE =0.0;
AL_FLANGER_MAX_RATE =10.0;
AL_FLANGER_DEFAULT_RATE =0.27;
AL_FLANGER_MIN_DEPTH =0.0;
AL_FLANGER_MAX_DEPTH =1.0;
AL_FLANGER_DEFAULT_DEPTH =1.0;
AL_FLANGER_MIN_FEEDBACK =-1.0;
AL_FLANGER_MAX_FEEDBACK =1.0;
AL_FLANGER_DEFAULT_FEEDBACK =-0.5;
AL_FLANGER_MIN_DELAY =0.0;
AL_FLANGER_MAX_DELAY =0.004;
AL_FLANGER_DEFAULT_DELAY =0.002;
AL_FREQUENCY_SHIFTER_MIN_FREQUENCY =0.0;
AL_FREQUENCY_SHIFTER_MAX_FREQUENCY =24000.0;
AL_FREQUENCY_SHIFTER_DEFAULT_FREQUENCY =0.0;
AL_FREQUENCY_SHIFTER_MIN_LEFT_DIRECTION =0;
AL_FREQUENCY_SHIFTER_MAX_LEFT_DIRECTION =2;
AL_FREQUENCY_SHIFTER_DEFAULT_LEFT_DIRECTION =0;
AL_FREQUENCY_SHIFTER_MIN_RIGHT_DIRECTION =0;
AL_FREQUENCY_SHIFTER_MAX_RIGHT_DIRECTION =2;
AL_FREQUENCY_SHIFTER_DEFAULT_RIGHT_DIRECTION =0;
AL_FREQUENCY_SHIFTER_DIRECTION_DOWN =0;
AL_FREQUENCY_SHIFTER_DIRECTION_UP =1;
AL_FREQUENCY_SHIFTER_DIRECTION_OFF =2;
AL_VOCAL_MORPHER_MIN_PHONEMEA =0;
AL_VOCAL_MORPHER_MAX_PHONEMEA =29;
AL_VOCAL_MORPHER_DEFAULT_PHONEMEA =0;
AL_VOCAL_MORPHER_MIN_PHONEMEA_COARSE_TUNING =-24;
AL_VOCAL_MORPHER_MAX_PHONEMEA_COARSE_TUNING =24;
AL_VOCAL_MORPHER_DEFAULT_PHONEMEA_COARSE_TUNING =0;
AL_VOCAL_MORPHER_MIN_PHONEMEB =0;
AL_VOCAL_MORPHER_MAX_PHONEMEB =29;
AL_VOCAL_MORPHER_DEFAULT_PHONEMEB =10;
AL_VOCAL_MORPHER_PHONEME_A =0;
AL_VOCAL_MORPHER_PHONEME_E =1;
AL_VOCAL_MORPHER_PHONEME_I =2;
AL_VOCAL_MORPHER_PHONEME_O =3;
AL_VOCAL_MORPHER_PHONEME_U =4;
AL_VOCAL_MORPHER_PHONEME_AA =5;
AL_VOCAL_MORPHER_PHONEME_AE =6;
AL_VOCAL_MORPHER_PHONEME_AH =7;
AL_VOCAL_MORPHER_PHONEME_AO =8;
AL_VOCAL_MORPHER_PHONEME_EH =9;
AL_VOCAL_MORPHER_PHONEME_ER =10;
AL_VOCAL_MORPHER_PHONEME_IH =11;
AL_VOCAL_MORPHER_PHONEME_IY =12;
AL_VOCAL_MORPHER_PHONEME_UH =13;
AL_VOCAL_MORPHER_PHONEME_UW =14;
AL_VOCAL_MORPHER_PHONEME_B =15;
AL_VOCAL_MORPHER_PHONEME_D =16;
AL_VOCAL_MORPHER_PHONEME_F =17;
AL_VOCAL_MORPHER_PHONEME_G =18;
AL_VOCAL_MORPHER_PHONEME_J =19;
AL_VOCAL_MORPHER_PHONEME_K =20;
AL_VOCAL_MORPHER_PHONEME_L =21;
AL_VOCAL_MORPHER_PHONEME_M =22;
AL_VOCAL_MORPHER_PHONEME_N =23;
AL_VOCAL_MORPHER_PHONEME_P =24;
AL_VOCAL_MORPHER_PHONEME_R =25;
AL_VOCAL_MORPHER_PHONEME_S =26;
AL_VOCAL_MORPHER_PHONEME_T =27;
AL_VOCAL_MORPHER_PHONEME_V =28;
AL_VOCAL_MORPHER_PHONEME_Z =29;
AL_VOCAL_MORPHER_MIN_PHONEMEB_COARSE_TUNING =-24;
AL_VOCAL_MORPHER_MAX_PHONEMEB_COARSE_TUNING =24;
AL_VOCAL_MORPHER_DEFAULT_PHONEMEB_COARSE_TUNING =0;
AL_VOCAL_MORPHER_MIN_WAVEFORM =0;
AL_VOCAL_MORPHER_MAX_WAVEFORM =2;
AL_VOCAL_MORPHER_DEFAULT_WAVEFORM =0;
AL_VOCAL_MORPHER_WAVEFORM_SINUSOID =0;
AL_VOCAL_MORPHER_WAVEFORM_TRIANGLE =1;
AL_VOCAL_MORPHER_WAVEFORM_SAWTOOTH =2;
AL_VOCAL_MORPHER_MIN_RATE =0.0;
AL_VOCAL_MORPHER_MAX_RATE =10.0;
AL_VOCAL_MORPHER_DEFAULT_RATE =1.41;
AL_PITCH_SHIFTER_MIN_COARSE_TUNE =-12;
AL_PITCH_SHIFTER_MAX_COARSE_TUNE =12;
AL_PITCH_SHIFTER_DEFAULT_COARSE_TUNE =12;
AL_PITCH_SHIFTER_MIN_FINE_TUNE =-50;
AL_PITCH_SHIFTER_MAX_FINE_TUNE =50;
AL_PITCH_SHIFTER_DEFAULT_FINE_TUNE =0;
AL_RING_MODULATOR_MIN_FREQUENCY =0.0;
AL_RING_MODULATOR_MAX_FREQUENCY =8000.0;
AL_RING_MODULATOR_DEFAULT_FREQUENCY =440.0;
AL_RING_MODULATOR_MIN_HIGHPASS_CUTOFF =0.0;
AL_RING_MODULATOR_MAX_HIGHPASS_CUTOFF =24000.0;
AL_RING_MODULATOR_DEFAULT_HIGHPASS_CUTOFF =800.0;
AL_RING_MODULATOR_MIN_WAVEFORM =0;
AL_RING_MODULATOR_MAX_WAVEFORM =2;
AL_RING_MODULATOR_DEFAULT_WAVEFORM =0;
AL_RING_MODULATOR_SINUSOID =0;
AL_RING_MODULATOR_SAWTOOTH =1;
AL_RING_MODULATOR_SQUARE =2;
AL_AUTOWAH_MIN_ATTACK_TIME =0.0001;
AL_AUTOWAH_MAX_ATTACK_TIME =1.0;
AL_AUTOWAH_DEFAULT_ATTACK_TIME =0.06;
AL_AUTOWAH_MIN_RELEASE_TIME =0.0001;
AL_AUTOWAH_MAX_RELEASE_TIME =1.0;
AL_AUTOWAH_DEFAULT_RELEASE_TIME =0.06;
AL_AUTOWAH_MIN_RESONANCE =2.0;
AL_AUTOWAH_MAX_RESONANCE =1000.0;
AL_AUTOWAH_DEFAULT_RESONANCE =1000.0;
AL_AUTOWAH_MIN_PEAK_GAIN =0.00003;
AL_AUTOWAH_MAX_PEAK_GAIN =31621.0;
AL_AUTOWAH_DEFAULT_PEAK_GAIN =11.22;
AL_COMPRESSOR_MIN_ONOFF =0;
AL_COMPRESSOR_MAX_ONOFF =1;
AL_COMPRESSOR_DEFAULT_ONOFF =1;
AL_EQUALIZER_MIN_LOW_GAIN =0.126;
AL_EQUALIZER_MAX_LOW_GAIN =7.943;
AL_EQUALIZER_DEFAULT_LOW_GAIN =1.0;
AL_EQUALIZER_MIN_LOW_CUTOFF =50.0;
AL_EQUALIZER_MAX_LOW_CUTOFF =800.0;
AL_EQUALIZER_DEFAULT_LOW_CUTOFF =200.0;
AL_EQUALIZER_MIN_MID1_GAIN =0.126;
AL_EQUALIZER_MAX_MID1_GAIN =7.943;
AL_EQUALIZER_DEFAULT_MID1_GAIN =1.0;
AL_EQUALIZER_MIN_MID1_CENTER =200.0;
AL_EQUALIZER_MAX_MID1_CENTER =3000.0;
AL_EQUALIZER_DEFAULT_MID1_CENTER =500.0;
AL_EQUALIZER_MIN_MID1_WIDTH =0.01;
AL_EQUALIZER_MAX_MID1_WIDTH =1.0;
AL_EQUALIZER_DEFAULT_MID1_WIDTH =1.0;
AL_EQUALIZER_MIN_MID2_GAIN =0.126;
AL_EQUALIZER_MAX_MID2_GAIN =7.943;
AL_EQUALIZER_DEFAULT_MID2_GAIN =1.0;
AL_EQUALIZER_MIN_MID2_CENTER =1000.0;
AL_EQUALIZER_MAX_MID2_CENTER =8000.0;
AL_EQUALIZER_DEFAULT_MID2_CENTER =3000.0;
AL_EQUALIZER_MIN_MID2_WIDTH =0.01;
AL_EQUALIZER_MAX_MID2_WIDTH =1.0;
AL_EQUALIZER_DEFAULT_MID2_WIDTH =1.0;
AL_EQUALIZER_MIN_HIGH_GAIN =0.126;
AL_EQUALIZER_MAX_HIGH_GAIN =7.943;
AL_EQUALIZER_DEFAULT_HIGH_GAIN =1.0;
AL_EQUALIZER_MIN_HIGH_CUTOFF =4000.0;
AL_EQUALIZER_MAX_HIGH_CUTOFF =16000.0;
AL_EQUALIZER_DEFAULT_HIGH_CUTOFF =6000.0;
AL_MIN_AIR_ABSORPTION_FACTOR =0.0;
AL_MAX_AIR_ABSORPTION_FACTOR =10.0;
AL_DEFAULT_AIR_ABSORPTION_FACTOR =0.0;
AL_MIN_ROOM_ROLLOFF_FACTOR =0.0;
AL_MAX_ROOM_ROLLOFF_FACTOR =10.0;
AL_DEFAULT_ROOM_ROLLOFF_FACTOR =0.0;
AL_MIN_CONE_OUTER_GAINHF =0.0;
AL_MAX_CONE_OUTER_GAINHF =1.0;
AL_DEFAULT_CONE_OUTER_GAINHF =1.0;
AL_MIN_DIRECT_FILTER_GAINHF_AUTO =AL_FALSE;
AL_MAX_DIRECT_FILTER_GAINHF_AUTO =AL_TRUE;
AL_DEFAULT_DIRECT_FILTER_GAINHF_AUTO =AL_TRUE;
AL_MIN_AUXILIARY_SEND_FILTER_GAIN_AUTO =AL_FALSE;
AL_MAX_AUXILIARY_SEND_FILTER_GAIN_AUTO =AL_TRUE;
AL_DEFAULT_AUXILIARY_SEND_FILTER_GAIN_AUTO =AL_TRUE;
AL_MIN_AUXILIARY_SEND_FILTER_GAINHF_AUTO =AL_FALSE;
AL_MAX_AUXILIARY_SEND_FILTER_GAINHF_AUTO =AL_TRUE;
AL_DEFAULT_AUXILIARY_SEND_FILTER_GAINHF_AUTO =AL_TRUE;
AL_DEFAULT_METERS_PER_UNIT =1.0;
AL_EAXREVERB_DENSITY =$0001;
AL_EAXREVERB_DIFFUSION =$0002;
AL_EAXREVERB_GAIN =$0003;
AL_EAXREVERB_GAINHF =$0004;
AL_EAXREVERB_GAINLF =$0005;
AL_EAXREVERB_DECAY_TIME =$0006;
AL_EAXREVERB_DECAY_HFRATIO =$0007;
AL_EAXREVERB_DECAY_LFRATIO =$0008;
AL_EAXREVERB_REFLECTIONS_GAIN =$0009;
AL_EAXREVERB_REFLECTIONS_DELAY =$000A;
AL_EAXREVERB_REFLECTIONS_PAN =$000B;
AL_EAXREVERB_LATE_REVERB_GAIN =$000C;
AL_EAXREVERB_LATE_REVERB_DELAY =$000D;
AL_EAXREVERB_LATE_REVERB_PAN =$000E;
AL_EAXREVERB_ECHO_TIME =$000F;
AL_EAXREVERB_ECHO_DEPTH =$0010;
AL_EAXREVERB_MODULATION_TIME =$0011;
AL_EAXREVERB_MODULATION_DEPTH =$0012;
AL_EAXREVERB_AIR_ABSORPTION_GAINHF =$0013;
AL_EAXREVERB_HFREFERENCE =$0014;
AL_EAXREVERB_LFREFERENCE =$0015;
AL_EAXREVERB_ROOM_ROLLOFF_FACTOR =$0016;
AL_EAXREVERB_DECAY_HFLIMIT =$0017;
AL_EFFECT_EAXREVERB =$8000;
AL_EAXREVERB_MIN_DENSITY =0.0;
AL_EAXREVERB_MAX_DENSITY =1.0;
AL_EAXREVERB_DEFAULT_DENSITY =1.0;
AL_EAXREVERB_MIN_DIFFUSION =0.0;
AL_EAXREVERB_MAX_DIFFUSION =1.0;
AL_EAXREVERB_DEFAULT_DIFFUSION =1.0;
AL_EAXREVERB_MIN_GAIN =0.0;
AL_EAXREVERB_MAX_GAIN =1.0;
AL_EAXREVERB_DEFAULT_GAIN =0.32;
AL_EAXREVERB_MIN_GAINHF =0.0;
AL_EAXREVERB_MAX_GAINHF =1.0;
AL_EAXREVERB_DEFAULT_GAINHF =0.89;
AL_EAXREVERB_MIN_GAINLF =0.0;
AL_EAXREVERB_MAX_GAINLF =1.0;
AL_EAXREVERB_DEFAULT_GAINLF =1.0;
AL_EAXREVERB_MIN_DECAY_TIME =0.1;
AL_EAXREVERB_MAX_DECAY_TIME =20.0;
AL_EAXREVERB_DEFAULT_DECAY_TIME =1.49;
AL_EAXREVERB_MIN_DECAY_HFRATIO =0.1;
AL_EAXREVERB_MAX_DECAY_HFRATIO =2.0;
AL_EAXREVERB_DEFAULT_DECAY_HFRATIO =0.83;
AL_EAXREVERB_MIN_DECAY_LFRATIO =0.1;
AL_EAXREVERB_MAX_DECAY_LFRATIO =2.0;
AL_EAXREVERB_DEFAULT_DECAY_LFRATIO =1.0;
AL_EAXREVERB_MIN_REFLECTIONS_GAIN =0.0;
AL_EAXREVERB_MAX_REFLECTIONS_GAIN =3.16;
AL_EAXREVERB_DEFAULT_REFLECTIONS_GAIN =0.05;
AL_EAXREVERB_MIN_REFLECTIONS_DELAY =0.0;
AL_EAXREVERB_MAX_REFLECTIONS_DELAY =0.3;
AL_EAXREVERB_DEFAULT_REFLECTIONS_DELAY =0.007;
AL_EAXREVERB_DEFAULT_REFLECTIONS_PAN: array[0..2] of TALFloat = (0.0, 0.0, 0.0);
AL_EAXREVERB_MIN_LATE_REVERB_GAIN =0.0;
AL_EAXREVERB_MAX_LATE_REVERB_GAIN =10.0;
AL_EAXREVERB_DEFAULT_LATE_REVERB_GAIN =1.26;
AL_EAXREVERB_MIN_LATE_REVERB_DELAY =0.0;
AL_EAXREVERB_MAX_LATE_REVERB_DELAY =0.1;
AL_EAXREVERB_DEFAULT_LATE_REVERB_DELAY =0.011;
AL_EAXREVERB_DEFAULT_LATE_REVERB_PAN: array[0..2] of TALFloat = (0.0, 0.0, 0.0);
AL_EAXREVERB_MIN_ECHO_TIME =0.075;
AL_EAXREVERB_MAX_ECHO_TIME =0.25;
AL_EAXREVERB_DEFAULT_ECHO_TIME =0.25;
AL_EAXREVERB_MIN_ECHO_DEPTH =0.0;
AL_EAXREVERB_MAX_ECHO_DEPTH =1.0;
AL_EAXREVERB_DEFAULT_ECHO_DEPTH =0.0;
AL_EAXREVERB_MIN_MODULATION_TIME =0.04;
AL_EAXREVERB_MAX_MODULATION_TIME =4.0;
AL_EAXREVERB_DEFAULT_MODULATION_TIME =0.25;
AL_EAXREVERB_MIN_MODULATION_DEPTH =0.0;
AL_EAXREVERB_MAX_MODULATION_DEPTH =1.0;
AL_EAXREVERB_DEFAULT_MODULATION_DEPTH =0.0;
AL_EAXREVERB_MIN_AIR_ABSORPTION_GAINHF =0.892;
AL_EAXREVERB_MAX_AIR_ABSORPTION_GAINHF =1.0;
AL_EAXREVERB_DEFAULT_AIR_ABSORPTION_GAINHF =0.994;
AL_EAXREVERB_MIN_HFREFERENCE =1000.0;
AL_EAXREVERB_MAX_HFREFERENCE =20000.0;
AL_EAXREVERB_DEFAULT_HFREFERENCE =5000.0;
AL_EAXREVERB_MIN_LFREFERENCE =20.0;
AL_EAXREVERB_MAX_LFREFERENCE =1000.0;
AL_EAXREVERB_DEFAULT_LFREFERENCE =250.0;
AL_EAXREVERB_MIN_ROOM_ROLLOFF_FACTOR =0.0;
AL_EAXREVERB_MAX_ROOM_ROLLOFF_FACTOR =10.0;
AL_EAXREVERB_DEFAULT_ROOM_ROLLOFF_FACTOR =0.0;
AL_EAXREVERB_MIN_DECAY_HFLIMIT = AL_FALSE;
AL_EAXREVERB_MAX_DECAY_HFLIMIT = AL_TRUE;
AL_EAXREVERB_DEFAULT_DECAY_HFLIMIT = AL_TRUE;
DSPROPSETID_EAX20_ListenerProperties : TGuid = '{0306A6A8-B224-11d2-99E5-0000E8D8C722}';
DSPROPSETID_EAX20_BufferProperties : TGuid = '{0306A6A7-B224-11d2-99E5-0000E8D8C722}';
DSPROPERTY_EAXLISTENER_NONE = 0;
DSPROPERTY_EAXLISTENER_ALLPARAMETERS = 1;
DSPROPERTY_EAXLISTENER_ROOM = 2;
DSPROPERTY_EAXLISTENER_ROOMHF = 3;
DSPROPERTY_EAXLISTENER_ROOMROLLOFFFACTOR = 4;
DSPROPERTY_EAXLISTENER_DECAYTIME = 5;
DSPROPERTY_EAXLISTENER_DECAYHFRATIO = 6;
DSPROPERTY_EAXLISTENER_REFLECTIONS = 7;
DSPROPERTY_EAXLISTENER_REFLECTIONSDELAY = 8;
DSPROPERTY_EAXLISTENER_REVERB = 9;
DSPROPERTY_EAXLISTENER_REVERBDELAY = 10;
DSPROPERTY_EAXLISTENER_ENVIRONMENT = 11;
DSPROPERTY_EAXLISTENER_ENVIRONMENTSIZE = 12;
DSPROPERTY_EAXLISTENER_ENVIRONMENTDIFFUSION = 13;
DSPROPERTY_EAXLISTENER_AIRABSORPTIONHF = 14;
DSPROPERTY_EAXLISTENER_FLAGS = 15;
DSPROPERTY_EAXLISTENER_IMMEDIATE = $00000000;
DSPROPERTY_EAXLISTENER_DEFERRED = LongWORD($80000000);
DSPROPERTY_EAXLISTENER_COMMITDEFERREDSETTINGS = (DSPROPERTY_EAXLISTENER_NONE or DSPROPERTY_EAXLISTENER_IMMEDIATE);
EAX_ENVIRONMENT_GENERIC = 0;
EAX_ENVIRONMENT_PADDEDCELL = 1;
EAX_ENVIRONMENT_ROOM = 2;
EAX_ENVIRONMENT_BATHROOM = 3;
EAX_ENVIRONMENT_LIVINGROOM = 4;
EAX_ENVIRONMENT_STONEROOM = 5;
EAX_ENVIRONMENT_AUDITORIUM = 6;
EAX_ENVIRONMENT_CONCERTHALL = 7;
EAX_ENVIRONMENT_CAVE = 8;
EAX_ENVIRONMENT_ARENA = 9;
EAX_ENVIRONMENT_HANGAR = 10;
EAX_ENVIRONMENT_CARPETEDHALLWAY = 11;
EAX_ENVIRONMENT_HALLWAY = 12;
EAX_ENVIRONMENT_STONECORRIDOR = 13;
EAX_ENVIRONMENT_ALLEY = 14;
EAX_ENVIRONMENT_FOREST = 15;
EAX_ENVIRONMENT_CITY = 16;
EAX_ENVIRONMENT_MOUNTAINS = 17;
EAX_ENVIRONMENT_QUARRY = 18;
EAX_ENVIRONMENT_PLAIN = 19;
EAX_ENVIRONMENT_PARKINGLOT = 20;
EAX_ENVIRONMENT_SEWERPIPE = 21;
EAX_ENVIRONMENT_UNDERWATER = 22;
EAX_ENVIRONMENT_DRUGGED = 23;
EAX_ENVIRONMENT_DIZZY = 24;
EAX_ENVIRONMENT_PSYCHOTIC = 25;
EAX_ENVIRONMENT_COUNT = 26;
EAXLISTENERFLAGS_DECAYTIMESCALE = $00000001;
EAXLISTENERFLAGS_REFLECTIONSSCALE = $00000002;
EAXLISTENERFLAGS_REFLECTIONSDELAYSCALE = $00000004;
EAXLISTENERFLAGS_REVERBSCALE = $00000008;
EAXLISTENERFLAGS_REVERBDELAYSCALE = $00000010;
EAXLISTENERFLAGS_DECAYHFLIMIT = $00000020;
EAXLISTENERFLAGS_RESERVED = $FFFFFFC0;
EAXLISTENER_MINROOM = -10000;
EAXLISTENER_MAXROOM = 0;
EAXLISTENER_DEFAULTROOM = -1000;
EAXLISTENER_MINROOMHF = -10000;
EAXLISTENER_MAXROOMHF = 0;
EAXLISTENER_DEFAULTROOMHF = -100;
EAXLISTENER_MINROOMROLLOFFFACTOR = 0.0;
EAXLISTENER_MAXROOMROLLOFFFACTOR = 10.0;
EAXLISTENER_DEFAULTROOMROLLOFFFACTOR = 0.0;
EAXLISTENER_MINDECAYTIME = 0.1;
EAXLISTENER_MAXDECAYTIME = 20.0;
EAXLISTENER_DEFAULTDECAYTIME = 1.49;
EAXLISTENER_MINDECAYHFRATIO = 0.1;
EAXLISTENER_MAXDECAYHFRATIO = 2.0;
EAXLISTENER_DEFAULTDECAYHFRATIO = 0.83;
EAXLISTENER_MINREFLECTIONS = -10000;
EAXLISTENER_MAXREFLECTIONS = 1000;
EAXLISTENER_DEFAULTREFLECTIONS = -2602;
EAXLISTENER_MINREFLECTIONSDELAY = 0.0;
EAXLISTENER_MAXREFLECTIONSDELAY = 0.3;
EAXLISTENER_DEFAULTREFLECTIONSDELAY = 0.007;
EAXLISTENER_MINREVERB = -10000;
EAXLISTENER_MAXREVERB = 2000;
EAXLISTENER_DEFAULTREVERB = 200;
EAXLISTENER_MINREVERBDELAY = 0.0;
EAXLISTENER_MAXREVERBDELAY = 0.1;
EAXLISTENER_DEFAULTREVERBDELAY = 0.011;
EAXLISTENER_MINENVIRONMENT = 0;
EAXLISTENER_MAXENVIRONMENT = EAX_ENVIRONMENT_COUNT - 1;
EAXLISTENER_DEFAULTENVIRONMENT = EAX_ENVIRONMENT_GENERIC;
EAXLISTENER_MINENVIRONMENTSIZE = 1.0;
EAXLISTENER_MAXENVIRONMENTSIZE = 100.0;
EAXLISTENER_DEFAULTENVIRONMENTSIZE = 7.5;
EAXLISTENER_MINENVIRONMENTDIFFUSION = 0.0;
EAXLISTENER_MAXENVIRONMENTDIFFUSION = 1.0;
EAXLISTENER_DEFAULTENVIRONMENTDIFFUSION = 1.0;
EAXLISTENER_MINAIRABSORPTIONHF = -100.0;
EAXLISTENER_MAXAIRABSORPTIONHF = 0.0;
EAXLISTENER_DEFAULTAIRABSORPTIONHF = -5.0;
EAXLISTENER_DEFAULTFLAGS = EAXLISTENERFLAGS_DECAYTIMESCALE or EAXLISTENERFLAGS_REFLECTIONSSCALE or EAXLISTENERFLAGS_REFLECTIONSDELAYSCALE or EAXLISTENERFLAGS_REVERBSCALE or EAXLISTENERFLAGS_REVERBDELAYSCALE or EAXLISTENERFLAGS_DECAYHFLIMIT;
DSPROPERTY_EAXBUFFER_NONE = 0;
DSPROPERTY_EAXBUFFER_ALLPARAMETERS = 1;
DSPROPERTY_EAXBUFFER_DIRECT = 2;
DSPROPERTY_EAXBUFFER_DIRECTHF = 3;
DSPROPERTY_EAXBUFFER_ROOM = 4;
DSPROPERTY_EAXBUFFER_ROOMHF = 5;
DSPROPERTY_EAXBUFFER_ROOMROLLOFFFACTOR = 6;
DSPROPERTY_EAXBUFFER_OBSTRUCTION = 7;
DSPROPERTY_EAXBUFFER_OBSTRUCTIONLFRATIO = 8;
DSPROPERTY_EAXBUFFER_OCCLUSION = 9;
DSPROPERTY_EAXBUFFER_OCCLUSIONLFRATIO = 10;
DSPROPERTY_EAXBUFFER_OCCLUSIONROOMRATIO = 11;
DSPROPERTY_EAXBUFFER_OUTSIDEVOLUMEHF = 12;
DSPROPERTY_EAXBUFFER_AIRABSORPTIONFACTOR = 13;
DSPROPERTY_EAXBUFFER_FLAG = 14;
DSPROPERTY_EAXBUFFER_IMMEDIATE = $00000000;
DSPROPERTY_EAXBUFFER_DEFERRED = LongWORD($80000000);
DSPROPERTY_EAXBUFFER_COMMITDEFERREDSETTINGS = DSPROPERTY_EAXBUFFER_NONE or DSPROPERTY_EAXBUFFER_IMMEDIATE;
EAXBUFFERFLAGS_DIRECTHFAUTO = $00000001;
EAXBUFFERFLAGS_ROOMAUTO = $00000002;
EAXBUFFERFLAGS_ROOMHFAUTO = $00000004;
EAXBUFFERFLAGS_RESERVED = $FFFFFFF8;
EAXBUFFER_MINDIRECT = -10000;
EAXBUFFER_MAXDIRECT = 1000;
EAXBUFFER_DEFAULTDIRECT = 0;
EAXBUFFER_MINDIRECTHF = -10000;
EAXBUFFER_MAXDIRECTHF = 0;
EAXBUFFER_DEFAULTDIRECTHF = 0;
EAXBUFFER_MINROOM = -10000;
EAXBUFFER_MAXROOM = 1000;
EAXBUFFER_DEFAULTROOM = 0;
EAXBUFFER_MINROOMHF = -10000;
EAXBUFFER_MAXROOMHF = 0;
EAXBUFFER_DEFAULTROOMHF = 0;
EAXBUFFER_MINROOMROLLOFFFACTOR = 0.0;
EAXBUFFER_MAXROOMROLLOFFFACTOR = 10.;
EAXBUFFER_DEFAULTROOMROLLOFFFACTOR = 0.0;
EAXBUFFER_MINOBSTRUCTION = -10000;
EAXBUFFER_MAXOBSTRUCTION = 0;
EAXBUFFER_DEFAULTOBSTRUCTION = 0;
EAXBUFFER_MINOBSTRUCTIONLFRATIO = 0.0;
EAXBUFFER_MAXOBSTRUCTIONLFRATIO = 1.0;
EAXBUFFER_DEFAULTOBSTRUCTIONLFRATIO = 0.0;
EAXBUFFER_MINOCCLUSION = -10000;
EAXBUFFER_MAXOCCLUSION = 0;
EAXBUFFER_DEFAULTOCCLUSION = 0;
EAXBUFFER_MINOCCLUSIONLFRATIO = 0.0;
EAXBUFFER_MAXOCCLUSIONLFRATIO = 1.0;
EAXBUFFER_DEFAULTOCCLUSIONLFRATIO = 0.25;
EAXBUFFER_MINOCCLUSIONROOMRATIO = 0.0;
EAXBUFFER_MAXOCCLUSIONROOMRATIO = 10.0;
EAXBUFFER_DEFAULTOCCLUSIONROOMRATIO = 0.5;
EAXBUFFER_MINOUTSIDEVOLUMEHF = -10000;
EAXBUFFER_MAXOUTSIDEVOLUMEHF = 0;
EAXBUFFER_DEFAULTOUTSIDEVOLUMEHF = 0;
EAXBUFFER_MINAIRABSORPTIONFACTOR = 0.0;
EAXBUFFER_MAXAIRABSORPTIONFACTOR = 10.0;
EAXBUFFER_DEFAULTAIRABSORPTIONFACTOR = 1.0;
EAXBUFFER_DEFAULTFLAGS = EAXBUFFERFLAGS_DIRECTHFAUTO or EAXBUFFERFLAGS_ROOMAUTO or EAXBUFFERFLAGS_ROOMHFAUTO;
EAX_MATERIAL_SINGLEWINDOW = -2800;
EAX_MATERIAL_SINGLEWINDOWLF = 0.71;
EAX_MATERIAL_SINGLEWINDOWROOMRATIO = 0.43;
EAX_MATERIAL_DOUBLEWINDOW = -5000;
EAX_MATERIAL_DOUBLEWINDOWHF = 0.40;
EAX_MATERIAL_DOUBLEWINDOWROOMRATIO = 0.24;
EAX_MATERIAL_THINDOOR = -1800;
EAX_MATERIAL_THINDOORLF = 0.66;
EAX_MATERIAL_THINDOORROOMRATIO = 0.66;
EAX_MATERIAL_THICKDOOR = -4400;
EAX_MATERIAL_THICKDOORLF = 0.64;
EAX_MATERIAL_THICKDOORROOMRTATION = 0.27;
EAX_MATERIAL_WOODWALL = -4000;
EAX_MATERIAL_WOODWALLLF = 0.50;
EAX_MATERIAL_WOODWALLROOMRATIO = 0.30;
EAX_MATERIAL_BRICKWALL = -5000;
EAX_MATERIAL_BRICKWALLLF = 0.60;
EAX_MATERIAL_BRICKWALLROOMRATIO = 0.24;
EAX_MATERIAL_STONEWALL = -6000;
EAX_MATERIAL_STONEWALLLF = 0.68;
EAX_MATERIAL_STONEWALLROOMRATIO = 0.20;
EAX_MATERIAL_CURTAIN = -1200;
EAX_MATERIAL_CURTAINLF = 0.15;
EAX_MATERIAL_CURTAINROOMRATIO = 1.00;

Variables

alEnable: procedure(capability: TALenum); cdecl;
alDisable: procedure(capability: TALenum); cdecl;
alIsEnabled: function(capability: TALenum): TALboolean; cdecl;
alHint: procedure(target, mode: TALenum); cdecl;
alGetBooleanv: procedure(param: TALenum; data: PALboolean); cdecl;
alGetIntegerv: procedure(param: TALenum; data: PALint); cdecl;
alGetFloatv: procedure(param: TALenum; data: PALfloat); cdecl;
alGetDoublev: procedure(param: TALenum; data: PALdouble); cdecl;
alGetString: function(param: TALenum): PALubyte; cdecl;
alGetBoolean: function(param: TALenum): TALboolean; cdecl;
alGetInteger: function(param: TALenum): TALint; cdecl;
alGetFloat: function(param: TALenum): TALfloat; cdecl;
alGetDouble: function(param: TALenum): TALdouble; cdecl;
alGetError: function: TALenum; cdecl;
alIsExtensionPresent: function(fname: PAnsiChar): TALboolean; cdecl;
alGetProcAddress: function(fname: PALuByte): Pointer; cdecl;
alGetEnumValue: function(ename: PALuByte): TALenum; cdecl;
alListenerf: procedure(param: TALenum; value: TALfloat); cdecl;
alListener3f: procedure(param: TALenum; f1: TALfloat; f2: TALfloat; f3: TALfloat); cdecl;
alListenerfv: procedure(param: TALenum; values: PALfloat); cdecl;
alListeneri: procedure(param: TAlenum; value: TALint); cdecl;
alListener3i: procedure(param: TALenum; value1: TALint; value2: TALint; value3: TALint );
alListeneriv: procedure(param: TALenum; const values: PALint );
alGetListeneriv: procedure(param: TALenum; values: PALint); cdecl;
alGetListenerfv: procedure(param: TALenum; values: PALfloat); cdecl;
alGenSources: procedure(n: TALsizei; sources: PALuint); cdecl;
alDeleteSources: procedure(n: TALsizei; sources: PALuint); cdecl;
alIsSource: function(id: TALuint): TALboolean; cdecl;
alSourcei: procedure(source: TALuint; param: TALenum; value: TALint); cdecl;
alSource3i: procedure(source: TALuint; param: TALenum; v1: TALint; v2: TALint; v3: TALint); cdecl;
alSourceiv: procedure(source: TALuint; param: TALenum; values: PALint); cdecl;
alSourcef: procedure(source: TALuint; param: TALenum; value: TALfloat); cdecl;
alSource3f: procedure(source: TALuint; param: TALenum; v1: TALfloat; v2: TALfloat; v3: TALfloat); cdecl;
alSourcefv: procedure(source: TALuint; param: TALenum; values: PALfloat); cdecl;
alGetSourcei: procedure(source: TALuint; param: TALenum; value: PALint); cdecl;
alGetSource3i: procedure(source: TALuint; param: TALenum; v1: PALint; v2: PALint; v3: PALint); cdecl;
alGetSourceiv: procedure(source: TALuint; param: TALenum; values: PALint); cdecl;
alGetSourcef: procedure(source: TALuint; param: TALenum; value: PALfloat); cdecl;
alGetSource3f: procedure(source: TALuint; param: TALenum; v1: PALfloat; v2: PALfloat; v3: PALfloat); cdecl;
alGetSourcefv: procedure(source: TALuint; param: TALenum; values: PALfloat); cdecl;
alSourcePlay: procedure(source: TALuint); cdecl;
alSourcePause: procedure(source: TALuint); cdecl;
alSourceStop: procedure(source: TALuint); cdecl;
alSourceRewind: procedure(source: TALuint); cdecl;
alSourcePlayv: procedure(n: TALsizei; sources: PALuint); cdecl;
alSourceStopv: procedure(n: TALsizei; sources: PALuint); cdecl;
alSourceRewindv: procedure(n: TALsizei; sources: PALuint); cdecl;
alSourcePausev: procedure(n: TALsizei; sources: PALuint); cdecl;
alSourceQueueBuffers: procedure(source: TALuint; n: TALsizei; buffers: PALuint); cdecl;
alSourceUnqueueBuffers: procedure(source: TALuint; n: TALsizei; buffers: PALuint); cdecl;
alGenBuffers: procedure(n: TALsizei; buffers: PALuint); cdecl;
alDeleteBuffers: procedure(n: TALsizei; buffers: PALuint); cdecl;
alIsBuffer: function(buffer: TALuint): TALboolean; cdecl;
alBufferData: procedure(buffer: TALuint; format: TALenum; data: Pointer; size, freq: TALsizei); cdecl;
alBufferi: procedure(buffer: TALuint; param: TALenum; value: TALint); cdecl;
alBuffer3i: procedure(buffer: TALuint; param: TALenum; v1: TALint; v2: TALint; v3: TALint); cdecl;
alBufferiv: procedure(buffer: TALuint; param: TALenum; values: PALint); cdecl;
alBufferf: procedure(buffer: TALuint; param: TALenum; value: TALfloat); cdecl;
alBuffer3f: procedure(buffer: TALuint; param: TALenum; v1: TALfloat; v2: TALfloat; v3: TALfloat); cdecl;
alBufferfv: procedure(buffer: TALuint; param: TALenum; values: PALfloat); cdecl;
alGetBufferi: procedure(buffer: TALuint; param: TALenum; value: PALint); cdecl;
alGetBuffer3i: procedure(buffer: TALuint; param: TALenum; v1: PALint; v2: PALint; v3: PALint); cdecl;
alGetBufferiv: procedure(buffer: TALuint; param: TALenum; values: PALint); cdecl;
alGetBufferf: procedure(buffer: TALuint; param: TALenum; value: PALfloat); cdecl;
alGetBuffer3f: procedure(buffer: TALuint; param: TALenum; v1: PALfloat; v2: PALfloat; v3: PALfloat); cdecl;
alGetBufferfv: procedure(buffer: TALuint; param: TALenum; values: PALfloat); cdecl;
alDistanceModel: procedure(value: TALenum); cdecl;
alDopplerFactor: procedure(value: TALfloat); cdecl;
alDopplerVelocity: procedure(value: TALfloat); cdecl;
alSpeedOfSound: procedure( value: TALfloat ); cdecl;
alcCreateContext: function(device: TALCdevice; attrlist: PALCint): TALCcontext; cdecl;
alcMakeContextCurrent: function(context: TALCcontext): TALCenum; cdecl;
alcProcessContext: procedure(context: TALCcontext); cdecl;
alcSuspendContext: procedure(context: TALCcontext); cdecl;
alcDestroyContext: procedure(context: TALCcontext); cdecl;
alcGetCurrentContext: function: TALCcontext; cdecl;
alcGetContextsDevice: function(context: TALCcontext): TALCdevice; cdecl;
alcOpenDevice: function(deviceName: PALCuByte): TALCdevice; cdecl;
alcCloseDevice: procedure(device: TALCdevice); cdecl;
alcGetError: function(device: TALCdevice): TALCenum; cdecl;
alcIsExtensionPresent: function(device: TALCdevice; extName: PALuByte): TALCboolean; cdecl;
alcGetProcAddress: function(device: TALCdevice; funcName: PALuByte): TALCvoid; cdecl;
alcGetEnumValue: function(device: TALCdevice; enumName: PALuByte): TALCenum; cdecl;
alcGetString: function(device: TALCdevice; param: TALCenum): PALCubyte; cdecl;
alcGetIntegerv: procedure(device: TALCdevice; param: TALCenum; size: TALCsizei; data: PALCint); cdecl;
alcCaptureOpenDevice: function( const devicename: PALCchar; frequency: TALCuint; format: TALCenum; buffersize: TALCsizei): PALCdevice; cdecl;
alcCaptureCloseDevice: function( device: PALCdevice ): TALCboolean; cdecl;
alcCaptureStart: procedure( device: PALCdevice ); cdecl;
alcCaptureStop: procedure( device: PALCdevice ); cdecl;
alcCaptureSamples: procedure( device: PALCdevice; buffer: TALCvoid; samples: TALCsizei ); cdecl;
EAXSet: Function(const Guid: TGUID; ALuint1: TALuint; ALuint2: TALuint; point: Pointer; ALuint3: TALuint): TALenum; cdecl;
EAXGet: Function(const Guid: TGUID; ALuint1: TALuint; ALuint2: TALuint; point: Pointer; ALuint3: TALuint): TALenum; cdecl;
AL_EAX_RAM_SIZE: TALEnum;
AL_EAX_RAM_FREE: TALEnum;
AL_STORAGE_AUTOMATIC: TALEnum;
AL_STORAGE_HARDWARE: TALEnum;
AL_STORAGE_ACCESSIBLE: TALEnum;
EAXSetBufferMode: function(n: TALsizei;buffers: PALuint; value: TALint ): TALboolean; cdecl;
EAXGetBufferMode: function(buffer: TALuint; value: PALint ): TALenum; cdecl;
ALGENEFFECTS: procedure( n: TALsizei; effects: PALuint ); cdecl;
ALDELETEEFFECTS: procedure( n: TALsizei; effects: PALuint ); cdecl;
ALISEFFECT: function( eid: TALuint ): TALboolean; cdecl;
ALEFFECTI: procedure( eid: TALuint; param: TALCenum; value: TALint); cdecl;
ALEFFECTIV: procedure( eid: TALuint; param: TALenum; values: PALint ); cdecl;
ALEFFECTF: procedure( eid: TALuint; param: TALenum; value: TALfloat); cdecl;
ALEFFECTFV: procedure( eid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGETEFFECTI: procedure( eid: TALuint; param: TALenum; value: PALint ); cdecl;
ALGETEFFECTIV: procedure( eid: TALuint; param: TALenum; values: PALint ); cdecl;
ALGETEFFECTF: procedure( eid: TALuint; param: TALenum; value: PALfloat ); cdecl;
ALGETEFFECTFV: procedure( eid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGENFILTERS: procedure( n: TALsizei; filters: PALuint ); cdecl;
ALDELETEFILTERS: procedure( n: TALsizei; filters: PALuint ); cdecl;
ALISFILTER: function( fid: TALuint ): TALboolean; cdecl;
ALFILTERI: procedure( fid: TALuint; param: TALenum; value: TALint ); cdecl;
ALFILTERIV: procedure( fid: TALuint; param: TALenum; values: PALint ); cdecl;
ALFILTERF: procedure( fid: TALuint; param: TALenum; value: TALfloat); cdecl;
ALFILTERFV: procedure( fid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGETFILTERI: procedure( fid: TALuint; param: TALenum; value: PALint ); cdecl;
ALGETFILTERIV: procedure( fid: TALuint; param: TALenum; values: PALint ); cdecl;
ALGETFILTERF: procedure( fid: TALuint; param: TALenum; value: PALfloat ); cdecl;
ALGETFILTERFV: procedure( fid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGENAUXILIARYEFFECTSLOTS: procedure( n: TALsizei; slots: PALuint ); cdecl;
ALDELETEAUXILIARYEFFECTSLOTS: procedure( n: TALsizei; slots: PALuint ); cdecl;
ALISAUXILIARYEFFECTSLOT: function( slot: TALuint ): TALboolean; cdecl;
ALAUXILIARYEFFECTSLOTI: procedure( asid: TALuint; param: TALenum; value: TALint ); cdecl;
ALAUXILIARYEFFECTSLOTIV: procedure( asid: TALuint; param: TALenum; values: PALint ); cdecl;
ALAUXILIARYEFFECTSLOTF: procedure( asid: TALuint; param: TALenum; value: TALfloat ); cdecl;
ALAUXILIARYEFFECTSLOTFV: procedure( asid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGETAUXILIARYEFFECTSLOTI: procedure( asid: TALuint; param: TALenum; value: PALint ); cdecl;
ALGETAUXILIARYEFFECTSLOTIV: procedure( asid: TALuint; param: TALenum; values: PALint ); cdecl;
ALGETAUXILIARYEFFECTSLOTF: procedure( asid: TALuint; param: TALenum; value: PALfloat ); cdecl;
ALGETAUXILIARYEFFECTSLOTFV: procedure( asid: TALuint; param: TALenum; values: PALfloat ); cdecl;
LibHandle: THandle = 0;
EFXUtilLibHandle: THandle = 0;

Description

Functions and Procedures

procedure alutInit(argc: PALint; argv: array of PALbyte);
procedure alutExit;
procedure alutLoadWAVFile(fname: string; var format: TALenum; var data: TALvoid; var size: TALsizei; var freq: TALsizei; var loop: TALint);
procedure alutLoadWAVMemory(memory: PALbyte; var format: TALenum; var data: TALvoid; var size: TALsizei; var freq: TALsizei; var loop: TALint);
procedure alutUnloadWAV(format: TALenum; data: TALvoid; size: TALsizei; freq: TALsizei);
function InitOpenAL(LibName: String = callibname): Boolean;
procedure ReadOpenALExtensions;

Types

TALboolean = Boolean;
PALboolean = ˆTALboolean;
TALchar = char;
PALchar = PAnsiChar;
TALbyte = ShortInt;
PALbyte = ˆTALbyte;
TALuByte = Char;
PALuByte = PAnsiChar;
TALshort = SmallInt;
PALshort = ˆTALshort;
TALushort = Word;
PALushort = ˆTALushort;
TALuint = Cardinal;
PALuint = ˆTALuint;
TALint = Integer;
PALint = ˆTALint;
TALfloat = Single;
PALfloat = ˆTALfloat;
TALdouble = Double;
PALdouble = ˆTALdouble;
TALsizei = Cardinal;
PALsizei = ˆTALsizei;
TALvoid = Pointer;
PALvoid = ˆTALvoid;
PPALvoid = ˆPALvoid;
TALenum = Integer;
PALenum = ˆTALenum;
TALbitfield = Cardinal;
PALbitfield = ˆTALbitfield;
TALclampf = TALfloat;
PALclampf = ˆTALclampf;
TALclampd = TALdouble;
PALclampd = ˆTALclampd;
TALCenum = integer;
PALCenum = ˆTALCenum;
TALCboolean = boolean;
PALCboolean = ˆTALCboolean;
TALCchar = char;
PALCchar = PAnsiChar;
TALCbyte = ShortInt;
PALCbyte = ˆTALCbyte;
TALCubyte = Char;
PALCubyte = PAnsiChar;
TALCshort = smallint;
PALCshort = ˆTALCshort;
TALCushort = Word;
PALCushort = ˆTALCushort;
TALCuint = Cardinal;
PALCuint = ˆTALCuint;
TALCint = integer;
PALCint = ˆTALCint;
TALCfloat = single;
PALCfloat = ˆTALCfloat;
TALCdouble = double;
PALCdouble = ˆTALCdouble;
TALCsizei = integer;
PALCsizei = ˆTALCsizei;
TALCvoid = Pointer;
PALCvoid = ˆTALCvoid;
TALCdevice = TALCvoid;
PALCdevice = ˆTALCdevice;
TALCcontext = TALCvoid;
PALCcontext = ˆTALCcontext;
DSPROPERTY_EAX_LISTENERPROPERTY = LongWORD;
DSPROPERTY_EAX_BUFFERPROPERTY = LongWORD;
PEaxListenerProperties = ˆTEaxListenerProperties;
PEaxBufferProperties = ˆTEaxBufferProperties;
EFXEAXREVERBPROPERTIES = _EFXEAXREVERBPROPERTIES;
PEFXEAXREVERBPROPERTIES = ˆ_EFXEAXREVERBPROPERTIES;
EFXLOWPASSFILTER = _EFXLOWPASSFILTER;
PEFXLOWPASSFILTER = ˆ_EFXLOWPASSFILTER;
HMODULE = THandle;

Constants

callibname='OpenAL32.dll';
calutlibname='Alut.dll';
AL_INVALID = -1;
AL_NONE = 0;
AL_FALSE = 0;
AL_TRUE = 1;
AL_SOURCE_ABSOLUTE = $201;
AL_SOURCE_RELATIVE = $202;
AL_CONE_INNER_ANGLE = $1001;
AL_CONE_OUTER_ANGLE = $1002;
AL_PITCH =$1003;
AL_POSITION =$1004;
AL_DIRECTION =$1005;
AL_VELOCITY =$1006;
AL_LOOPING =$1007;
AL_BUFFER =$1009;
AL_GAIN =$100A;
AL_MIN_GAIN =$100D;
AL_MAX_GAIN =$100E;
AL_ORIENTATION =$100F;
AL_CHANNEL_MASK =$3000;
AL_SOURCE_STATE =$1010;
AL_INITIAL =$1011;
AL_PLAYING =$1012;
AL_PAUSED =$1013;
AL_STOPPED =$1014;
AL_BUFFERS_QUEUED =$1015;
AL_BUFFERS_PROCESSED =$1016;
AL_SEC_OFFSET = $1024;
AL_SAMPLE_OFFSET = $1025;
AL_BYTE_OFFSET = $1026;
AL_SOURCE_TYPE = $1027;
AL_STATIC = $1028;
AL_STREAMING = $1029;
AL_UNDETERMINED = $1030;
AL_FORMAT_MONO8 =$1100;
AL_FORMAT_MONO16 =$1101;
AL_FORMAT_STEREO8 =$1102;
AL_FORMAT_STEREO16 =$1103;
AL_REFERENCE_DISTANCE =$1020;
AL_ROLLOFF_FACTOR =$1021;
AL_CONE_OUTER_GAIN =$1022;
AL_MAX_DISTANCE =$1023;
AL_FREQUENCY =$2001;
AL_BITS =$2002;
AL_CHANNELS =$2003;
AL_SIZE =$2004;
AL_UNUSED =$2010;
AL_PENDING =$2011;
AL_PROCESSED =$2012;
AL_NO_ERROR =AL_FALSE;
AL_INVALID_NAME =$A001;
AL_ILLEGAL_ENUM =$A002;
AL_INVALID_ENUM =$A002;
AL_INVALID_VALUE =$A003;
AL_ILLEGAL_COMMAND =$A004;
AL_INVALID_OPERATION =$A004;
AL_OUT_OF_MEMORY =$A005;
AL_VENDOR =$B001;
AL_VERSION =$B002;
AL_RENDERER =$B003;
AL_EXTENSIONS =$B004;
AL_DOPPLER_FACTOR =$C000;
AL_DOPPLER_VELOCITY =$C001;
AL_SPEED_OF_SOUND = $C003;
AL_DISTANCE_MODEL =$D000;
AL_INVERSE_DISTANCE =$D001;
AL_INVERSE_DISTANCE_CLAMPED =$D002;
AL_LINEAR_DISTANCE =$D003;
AL_LINEAR_DISTANCE_CLAMPED =$D004;
AL_EXPONENT_DISTANCE =$D005;
AL_EXPONENT_DISTANCE_CLAMPED =$D006;
ALC_INVALID =0;
ALC_FALSE =0;
ALC_TRUE =1;
ALC_FREQUENCY =$1007;
ALC_REFRESH =$1008;
ALC_SYNC =$1009;
ALC_MONO_SOURCES =$1010;
ALC_STEREO_SOURCES =$1011;
ALC_NO_ERROR =ALC_FALSE;
ALC_INVALID_DEVICE =$A001;
ALC_INVALID_CONTEXT =$A002;
ALC_INVALID_ENUM =$A003;
ALC_INVALID_VALUE =$A004;
ALC_OUT_OF_MEMORY =$A005;
ALC_DEFAULT_DEVICE_SPECIFIER =$1004;
ALC_DEVICE_SPECIFIER =$1005;
ALC_EXTENSIONS =$1006;
ALC_MAJOR_VERSION =$1000;
ALC_MINOR_VERSION =$1001;
ALC_ATTRIBUTES_SIZE =$1002;
ALC_ALL_ATTRIBUTES =$1003;
ALC_DEFAULT_ALL_DEVICES_SPECIFIER =$1012;
ALC_ALL_DEVICES_SPECIFIER =$1013;
ALC_CAPTURE_DEVICE_SPECIFIER =$310;
ALC_CAPTURE_DEFAULT_DEVICE_SPECIFIER =$311;
ALC_CAPTURE_SAMPLES =$312;
ALC_EXT_EFX_NAME ='ALC_EXT_EFX';
ALC_EFX_MAJOR_VERSION =$20001;
ALC_EFX_MINOR_VERSION =$20002;
ALC_MAX_AUXILIARY_SENDS =$20003;
AL_METERS_PER_UNIT =$20004;
AL_DIRECT_FILTER =$20005;
AL_AUXILIARY_SEND_FILTER =$20006;
AL_AIR_ABSORPTION_FACTOR =$20007;
AL_ROOM_ROLLOFF_FACTOR =$20008;
AL_CONE_OUTER_GAINHF =$20009;
AL_DIRECT_FILTER_GAINHF_AUTO =$2000A;
AL_AUXILIARY_SEND_FILTER_GAIN_AUTO =$2000B;
AL_AUXILIARY_SEND_FILTER_GAINHF_AUTO =$2000C;
AL_REVERB_DENSITY =$0001;
AL_REVERB_DIFFUSION =$0002;
AL_REVERB_GAIN =$0003;
AL_REVERB_GAINHF =$0004;
AL_REVERB_DECAY_TIME =$0005;
AL_REVERB_DECAY_HFRATIO =$0006;
AL_REVERB_REFLECTIONS_GAIN =$0007;
AL_REVERB_REFLECTIONS_DELAY =$0008;
AL_REVERB_LATE_REVERB_GAIN =$0009;
AL_REVERB_LATE_REVERB_DELAY =$000A;
AL_REVERB_AIR_ABSORPTION_GAINHF =$000B;
AL_REVERB_ROOM_ROLLOFF_FACTOR =$000C;
AL_REVERB_DECAY_HFLIMIT =$000D;
AL_CHORUS_WAVEFORM =$0001;
AL_CHORUS_PHASE =$0002;
AL_CHORUS_RATE =$0003;
AL_CHORUS_DEPTH =$0004;
AL_CHORUS_FEEDBACK =$0005;
AL_CHORUS_DELAY =$0006;
AL_DISTORTION_EDGE =$0001;
AL_DISTORTION_GAIN =$0002;
AL_DISTORTION_LOWPASS_CUTOFF =$0003;
AL_DISTORTION_EQCENTER =$0004;
AL_DISTORTION_EQBANDWIDTH =$0005;
AL_ECHO_DELAY =$0001;
AL_ECHO_LRDELAY =$0002;
AL_ECHO_DAMPING =$0003;
AL_ECHO_FEEDBACK =$0004;
AL_ECHO_SPREAD =$0005;
AL_FLANGER_WAVEFORM =$0001;
AL_FLANGER_PHASE =$0002;
AL_FLANGER_RATE =$0003;
AL_FLANGER_DEPTH =$0004;
AL_FLANGER_FEEDBACK =$0005;
AL_FLANGER_DELAY =$0006;
AL_FREQUENCY_SHIFTER_FREQUENCY =$0001;
AL_FREQUENCY_SHIFTER_LEFT_DIRECTION =$0002;
AL_FREQUENCY_SHIFTER_RIGHT_DIRECTION =$0003;
AL_VOCAL_MORPHER_PHONEMEA =$0001;
AL_VOCAL_MORPHER_PHONEMEA_COARSE_TUNING =$0002;
AL_VOCAL_MORPHER_PHONEMEB =$0003;
AL_VOCAL_MORPHER_PHONEMEB_COARSE_TUNING =$0004;
AL_VOCAL_MORPHER_WAVEFORM =$0005;
AL_VOCAL_MORPHER_RATE =$0006;
AL_PITCH_SHIFTER_COARSE_TUNE =$0001;
AL_PITCH_SHIFTER_FINE_TUNE =$0002;
AL_RING_MODULATOR_FREQUENCY =$0001;
AL_RING_MODULATOR_HIGHPASS_CUTOFF =$0002;
AL_RING_MODULATOR_WAVEFORM =$0003;
AL_AUTOWAH_ATTACK_TIME =$0001;
AL_AUTOWAH_RELEASE_TIME =$0002;
AL_AUTOWAH_RESONANCE =$0003;
AL_AUTOWAH_PEAK_GAIN =$0004;
AL_COMPRESSOR_ONOFF =$0001;
AL_EQUALIZER_LOW_GAIN =$0001;
AL_EQUALIZER_LOW_CUTOFF =$0002;
AL_EQUALIZER_MID1_GAIN =$0003;
AL_EQUALIZER_MID1_CENTER =$0004;
AL_EQUALIZER_MID1_WIDTH =$0005;
AL_EQUALIZER_MID2_GAIN =$0006;
AL_EQUALIZER_MID2_CENTER =$0007;
AL_EQUALIZER_MID2_WIDTH =$0008;
AL_EQUALIZER_HIGH_GAIN =$0009;
AL_EQUALIZER_HIGH_CUTOFF =$000A;
AL_EFFECT_FIRST_PARAMETER =$0000;
AL_EFFECT_LAST_PARAMETER =$8000;
AL_EFFECT_TYPE =$8001;
AL_EFFECT_NULL =$0000;
AL_EFFECT_REVERB =$0001;
AL_EFFECT_CHORUS =$0002;
AL_EFFECT_DISTORTION =$0003;
AL_EFFECT_ECHO =$0004;
AL_EFFECT_FLANGER =$0005;
AL_EFFECT_FREQUENCY_SHIFTER =$0006;
AL_EFFECT_VOCAL_MORPHER =$0007;
AL_EFFECT_PITCH_SHIFTER =$0008;
AL_EFFECT_RING_MODULATOR =$0009;
AL_EFFECT_AUTOWAH =$000A;
AL_EFFECT_COMPRESSOR =$000B;
AL_EFFECT_EQUALIZER =$000C;
AL_EFFECTSLOT_EFFECT =$0001;
AL_EFFECTSLOT_GAIN =$0002;
AL_EFFECTSLOT_AUXILIARY_SEND_AUTO =$0003;
AL_EFFECTSLOT_NULL =$0000;
AL_LOWPASS_GAIN =$0001;
AL_LOWPASS_GAINHF =$0002;
AL_HIGHPASS_GAIN =$0001;
AL_HIGHPASS_GAINLF =$0002;
AL_BANDPASS_GAIN =$0001;
AL_BANDPASS_GAINLF =$0002;
AL_BANDPASS_GAINHF =$0003;
AL_FILTER_FIRST_PARAMETER =$0000;
AL_FILTER_LAST_PARAMETER =$8000;
AL_FILTER_TYPE =$8001;
AL_FILTER_NULL =$0000;
AL_FILTER_LOWPASS =$0001;
AL_FILTER_HIGHPASS =$0002;
AL_FILTER_BANDPASS =$0003;
LOWPASS_MIN_GAIN =0.0;
LOWPASS_MAX_GAIN =1.0;
LOWPASS_DEFAULT_GAIN =1.0;
LOWPASS_MIN_GAINHF =0.0;
LOWPASS_MAX_GAINHF =1.0;
LOWPASS_DEFAULT_GAINHF =1.0;
HIGHPASS_MIN_GAIN =0.0;
HIGHPASS_MAX_GAIN =1.0;
HIGHPASS_DEFAULT_GAIN =1.0;
HIGHPASS_MIN_GAINLF =0.0;
HIGHPASS_MAX_GAINLF =1.0;
HIGHPASS_DEFAULT_GAINLF =1.0;
BANDPASS_MIN_GAIN =0.0;
BANDPASS_MAX_GAIN =1.0;
BANDPASS_DEFAULT_GAIN =1.0;
BANDPASS_MIN_GAINHF =0.0;
BANDPASS_MAX_GAINHF =1.0;
BANDPASS_DEFAULT_GAINHF =1.0;
BANDPASS_MIN_GAINLF =0.0;
BANDPASS_MAX_GAINLF =1.0;
BANDPASS_DEFAULT_GAINLF =1.0;
AL_REVERB_MIN_DENSITY =0.0;
AL_REVERB_MAX_DENSITY =1.0;
AL_REVERB_DEFAULT_DENSITY =1.0;
AL_REVERB_MIN_DIFFUSION =0.0;
AL_REVERB_MAX_DIFFUSION =1.0;
AL_REVERB_DEFAULT_DIFFUSION =1.0;
AL_REVERB_MIN_GAIN =0.0;
AL_REVERB_MAX_GAIN =1.0;
AL_REVERB_DEFAULT_GAIN =0.32;
AL_REVERB_MIN_GAINHF =0.0;
AL_REVERB_MAX_GAINHF =1.0;
AL_REVERB_DEFAULT_GAINHF =0.89;
AL_REVERB_MIN_DECAY_TIME =0.1;
AL_REVERB_MAX_DECAY_TIME =20.0;
AL_REVERB_DEFAULT_DECAY_TIME =1.49;
AL_REVERB_MIN_DECAY_HFRATIO =0.1;
AL_REVERB_MAX_DECAY_HFRATIO =2.0;
AL_REVERB_DEFAULT_DECAY_HFRATIO =0.83;
AL_REVERB_MIN_REFLECTIONS_GAIN =0.0;
AL_REVERB_MAX_REFLECTIONS_GAIN =3.16;
AL_REVERB_DEFAULT_REFLECTIONS_GAIN =0.05;
AL_REVERB_MIN_REFLECTIONS_DELAY =0.0;
AL_REVERB_MAX_REFLECTIONS_DELAY =0.3;
AL_REVERB_DEFAULT_REFLECTIONS_DELAY =0.007;
AL_REVERB_MIN_LATE_REVERB_GAIN =0.0;
AL_REVERB_MAX_LATE_REVERB_GAIN =10.0;
AL_REVERB_DEFAULT_LATE_REVERB_GAIN =1.26;
AL_REVERB_MIN_LATE_REVERB_DELAY =0.0;
AL_REVERB_MAX_LATE_REVERB_DELAY =0.1;
AL_REVERB_DEFAULT_LATE_REVERB_DELAY =0.011;
AL_REVERB_MIN_AIR_ABSORPTION_GAINHF =0.892;
AL_REVERB_MAX_AIR_ABSORPTION_GAINHF =1.0;
AL_REVERB_DEFAULT_AIR_ABSORPTION_GAINHF =0.994;
AL_REVERB_MIN_ROOM_ROLLOFF_FACTOR =0.0;
AL_REVERB_MAX_ROOM_ROLLOFF_FACTOR =10.0;
AL_REVERB_DEFAULT_ROOM_ROLLOFF_FACTOR =0.0;
AL_REVERB_MIN_DECAY_HFLIMIT =AL_FALSE;
AL_REVERB_MAX_DECAY_HFLIMIT =AL_TRUE;
AL_REVERB_DEFAULT_DECAY_HFLIMIT =AL_TRUE;
AL_CHORUS_MIN_WAVEFORM =0;
AL_CHORUS_MAX_WAVEFORM =1;
AL_CHORUS_DEFAULT_WAVEFORM =1;
AL_CHORUS_WAVEFORM_SINUSOID =0;
AL_CHORUS_WAVEFORM_TRIANGLE =1;
AL_CHORUS_MIN_PHASE =-180;
AL_CHORUS_MAX_PHASE =180;
AL_CHORUS_DEFAULT_PHASE =90;
AL_CHORUS_MIN_RATE =0.0;
AL_CHORUS_MAX_RATE =10.0;
AL_CHORUS_DEFAULT_RATE =1.1;
AL_CHORUS_MIN_DEPTH =0.0;
AL_CHORUS_MAX_DEPTH =1.0;
AL_CHORUS_DEFAULT_DEPTH =0.1;
AL_CHORUS_MIN_FEEDBACK =-1.0;
AL_CHORUS_MAX_FEEDBACK =1.0;
AL_CHORUS_DEFAULT_FEEDBACK =0.25;
AL_CHORUS_MIN_DELAY =0.0;
AL_CHORUS_MAX_DELAY =0.016;
AL_CHORUS_DEFAULT_DELAY =0.016;
AL_DISTORTION_MIN_EDGE =0.0;
AL_DISTORTION_MAX_EDGE =1.0;
AL_DISTORTION_DEFAULT_EDGE =0.2;
AL_DISTORTION_MIN_GAIN =0.01;
AL_DISTORTION_MAX_GAIN =1.0;
AL_DISTORTION_DEFAULT_GAIN =0.05;
AL_DISTORTION_MIN_LOWPASS_CUTOFF =80.0;
AL_DISTORTION_MAX_LOWPASS_CUTOFF =24000.0;
AL_DISTORTION_DEFAULT_LOWPASS_CUTOFF =8000.0;
AL_DISTORTION_MIN_EQCENTER =80.0;
AL_DISTORTION_MAX_EQCENTER =24000.0;
AL_DISTORTION_DEFAULT_EQCENTER =3600.0;
AL_DISTORTION_MIN_EQBANDWIDTH =80.0;
AL_DISTORTION_MAX_EQBANDWIDTH =24000.0;
AL_DISTORTION_DEFAULT_EQBANDWIDTH =3600.0;
AL_ECHO_MIN_DELAY =0.0;
AL_ECHO_MAX_DELAY =0.207;
AL_ECHO_DEFAULT_DELAY =0.1;
AL_ECHO_MIN_LRDELAY =0.0;
AL_ECHO_MAX_LRDELAY =0.404;
AL_ECHO_DEFAULT_LRDELAY =0.1;
AL_ECHO_MIN_DAMPING =0.0;
AL_ECHO_MAX_DAMPING =0.99;
AL_ECHO_DEFAULT_DAMPING =0.5;
AL_ECHO_MIN_FEEDBACK =0.0;
AL_ECHO_MAX_FEEDBACK =1.0;
AL_ECHO_DEFAULT_FEEDBACK =0.5;
AL_ECHO_MIN_SPREAD =-1.0;
AL_ECHO_MAX_SPREAD =1.0;
AL_ECHO_DEFAULT_SPREAD =-1.0;
AL_FLANGER_MIN_WAVEFORM =0;
AL_FLANGER_MAX_WAVEFORM =1;
AL_FLANGER_DEFAULT_WAVEFORM =1;
AL_FLANGER_WAVEFORM_SINUSOID =0;
AL_FLANGER_WAVEFORM_TRIANGLE =1;
AL_FLANGER_MIN_PHASE =-180;
AL_FLANGER_MAX_PHASE =180;
AL_FLANGER_DEFAULT_PHASE =0;
AL_FLANGER_MIN_RATE =0.0;
AL_FLANGER_MAX_RATE =10.0;
AL_FLANGER_DEFAULT_RATE =0.27;
AL_FLANGER_MIN_DEPTH =0.0;
AL_FLANGER_MAX_DEPTH =1.0;
AL_FLANGER_DEFAULT_DEPTH =1.0;
AL_FLANGER_MIN_FEEDBACK =-1.0;
AL_FLANGER_MAX_FEEDBACK =1.0;
AL_FLANGER_DEFAULT_FEEDBACK =-0.5;
AL_FLANGER_MIN_DELAY =0.0;
AL_FLANGER_MAX_DELAY =0.004;
AL_FLANGER_DEFAULT_DELAY =0.002;
AL_FREQUENCY_SHIFTER_MIN_FREQUENCY =0.0;
AL_FREQUENCY_SHIFTER_MAX_FREQUENCY =24000.0;
AL_FREQUENCY_SHIFTER_DEFAULT_FREQUENCY =0.0;
AL_FREQUENCY_SHIFTER_MIN_LEFT_DIRECTION =0;
AL_FREQUENCY_SHIFTER_MAX_LEFT_DIRECTION =2;
AL_FREQUENCY_SHIFTER_DEFAULT_LEFT_DIRECTION =0;
AL_FREQUENCY_SHIFTER_MIN_RIGHT_DIRECTION =0;
AL_FREQUENCY_SHIFTER_MAX_RIGHT_DIRECTION =2;
AL_FREQUENCY_SHIFTER_DEFAULT_RIGHT_DIRECTION =0;
AL_FREQUENCY_SHIFTER_DIRECTION_DOWN =0;
AL_FREQUENCY_SHIFTER_DIRECTION_UP =1;
AL_FREQUENCY_SHIFTER_DIRECTION_OFF =2;
AL_VOCAL_MORPHER_MIN_PHONEMEA =0;
AL_VOCAL_MORPHER_MAX_PHONEMEA =29;
AL_VOCAL_MORPHER_DEFAULT_PHONEMEA =0;
AL_VOCAL_MORPHER_MIN_PHONEMEA_COARSE_TUNING =-24;
AL_VOCAL_MORPHER_MAX_PHONEMEA_COARSE_TUNING =24;
AL_VOCAL_MORPHER_DEFAULT_PHONEMEA_COARSE_TUNING =0;
AL_VOCAL_MORPHER_MIN_PHONEMEB =0;
AL_VOCAL_MORPHER_MAX_PHONEMEB =29;
AL_VOCAL_MORPHER_DEFAULT_PHONEMEB =10;
AL_VOCAL_MORPHER_PHONEME_A =0;
AL_VOCAL_MORPHER_PHONEME_E =1;
AL_VOCAL_MORPHER_PHONEME_I =2;
AL_VOCAL_MORPHER_PHONEME_O =3;
AL_VOCAL_MORPHER_PHONEME_U =4;
AL_VOCAL_MORPHER_PHONEME_AA =5;
AL_VOCAL_MORPHER_PHONEME_AE =6;
AL_VOCAL_MORPHER_PHONEME_AH =7;
AL_VOCAL_MORPHER_PHONEME_AO =8;
AL_VOCAL_MORPHER_PHONEME_EH =9;
AL_VOCAL_MORPHER_PHONEME_ER =10;
AL_VOCAL_MORPHER_PHONEME_IH =11;
AL_VOCAL_MORPHER_PHONEME_IY =12;
AL_VOCAL_MORPHER_PHONEME_UH =13;
AL_VOCAL_MORPHER_PHONEME_UW =14;
AL_VOCAL_MORPHER_PHONEME_B =15;
AL_VOCAL_MORPHER_PHONEME_D =16;
AL_VOCAL_MORPHER_PHONEME_F =17;
AL_VOCAL_MORPHER_PHONEME_G =18;
AL_VOCAL_MORPHER_PHONEME_J =19;
AL_VOCAL_MORPHER_PHONEME_K =20;
AL_VOCAL_MORPHER_PHONEME_L =21;
AL_VOCAL_MORPHER_PHONEME_M =22;
AL_VOCAL_MORPHER_PHONEME_N =23;
AL_VOCAL_MORPHER_PHONEME_P =24;
AL_VOCAL_MORPHER_PHONEME_R =25;
AL_VOCAL_MORPHER_PHONEME_S =26;
AL_VOCAL_MORPHER_PHONEME_T =27;
AL_VOCAL_MORPHER_PHONEME_V =28;
AL_VOCAL_MORPHER_PHONEME_Z =29;
AL_VOCAL_MORPHER_MIN_PHONEMEB_COARSE_TUNING =-24;
AL_VOCAL_MORPHER_MAX_PHONEMEB_COARSE_TUNING =24;
AL_VOCAL_MORPHER_DEFAULT_PHONEMEB_COARSE_TUNING =0;
AL_VOCAL_MORPHER_MIN_WAVEFORM =0;
AL_VOCAL_MORPHER_MAX_WAVEFORM =2;
AL_VOCAL_MORPHER_DEFAULT_WAVEFORM =0;
AL_VOCAL_MORPHER_WAVEFORM_SINUSOID =0;
AL_VOCAL_MORPHER_WAVEFORM_TRIANGLE =1;
AL_VOCAL_MORPHER_WAVEFORM_SAWTOOTH =2;
AL_VOCAL_MORPHER_MIN_RATE =0.0;
AL_VOCAL_MORPHER_MAX_RATE =10.0;
AL_VOCAL_MORPHER_DEFAULT_RATE =1.41;
AL_PITCH_SHIFTER_MIN_COARSE_TUNE =-12;
AL_PITCH_SHIFTER_MAX_COARSE_TUNE =12;
AL_PITCH_SHIFTER_DEFAULT_COARSE_TUNE =12;
AL_PITCH_SHIFTER_MIN_FINE_TUNE =-50;
AL_PITCH_SHIFTER_MAX_FINE_TUNE =50;
AL_PITCH_SHIFTER_DEFAULT_FINE_TUNE =0;
AL_RING_MODULATOR_MIN_FREQUENCY =0.0;
AL_RING_MODULATOR_MAX_FREQUENCY =8000.0;
AL_RING_MODULATOR_DEFAULT_FREQUENCY =440.0;
AL_RING_MODULATOR_MIN_HIGHPASS_CUTOFF =0.0;
AL_RING_MODULATOR_MAX_HIGHPASS_CUTOFF =24000.0;
AL_RING_MODULATOR_DEFAULT_HIGHPASS_CUTOFF =800.0;
AL_RING_MODULATOR_MIN_WAVEFORM =0;
AL_RING_MODULATOR_MAX_WAVEFORM =2;
AL_RING_MODULATOR_DEFAULT_WAVEFORM =0;
AL_RING_MODULATOR_SINUSOID =0;
AL_RING_MODULATOR_SAWTOOTH =1;
AL_RING_MODULATOR_SQUARE =2;
AL_AUTOWAH_MIN_ATTACK_TIME =0.0001;
AL_AUTOWAH_MAX_ATTACK_TIME =1.0;
AL_AUTOWAH_DEFAULT_ATTACK_TIME =0.06;
AL_AUTOWAH_MIN_RELEASE_TIME =0.0001;
AL_AUTOWAH_MAX_RELEASE_TIME =1.0;
AL_AUTOWAH_DEFAULT_RELEASE_TIME =0.06;
AL_AUTOWAH_MIN_RESONANCE =2.0;
AL_AUTOWAH_MAX_RESONANCE =1000.0;
AL_AUTOWAH_DEFAULT_RESONANCE =1000.0;
AL_AUTOWAH_MIN_PEAK_GAIN =0.00003;
AL_AUTOWAH_MAX_PEAK_GAIN =31621.0;
AL_AUTOWAH_DEFAULT_PEAK_GAIN =11.22;
AL_COMPRESSOR_MIN_ONOFF =0;
AL_COMPRESSOR_MAX_ONOFF =1;
AL_COMPRESSOR_DEFAULT_ONOFF =1;
AL_EQUALIZER_MIN_LOW_GAIN =0.126;
AL_EQUALIZER_MAX_LOW_GAIN =7.943;
AL_EQUALIZER_DEFAULT_LOW_GAIN =1.0;
AL_EQUALIZER_MIN_LOW_CUTOFF =50.0;
AL_EQUALIZER_MAX_LOW_CUTOFF =800.0;
AL_EQUALIZER_DEFAULT_LOW_CUTOFF =200.0;
AL_EQUALIZER_MIN_MID1_GAIN =0.126;
AL_EQUALIZER_MAX_MID1_GAIN =7.943;
AL_EQUALIZER_DEFAULT_MID1_GAIN =1.0;
AL_EQUALIZER_MIN_MID1_CENTER =200.0;
AL_EQUALIZER_MAX_MID1_CENTER =3000.0;
AL_EQUALIZER_DEFAULT_MID1_CENTER =500.0;
AL_EQUALIZER_MIN_MID1_WIDTH =0.01;
AL_EQUALIZER_MAX_MID1_WIDTH =1.0;
AL_EQUALIZER_DEFAULT_MID1_WIDTH =1.0;
AL_EQUALIZER_MIN_MID2_GAIN =0.126;
AL_EQUALIZER_MAX_MID2_GAIN =7.943;
AL_EQUALIZER_DEFAULT_MID2_GAIN =1.0;
AL_EQUALIZER_MIN_MID2_CENTER =1000.0;
AL_EQUALIZER_MAX_MID2_CENTER =8000.0;
AL_EQUALIZER_DEFAULT_MID2_CENTER =3000.0;
AL_EQUALIZER_MIN_MID2_WIDTH =0.01;
AL_EQUALIZER_MAX_MID2_WIDTH =1.0;
AL_EQUALIZER_DEFAULT_MID2_WIDTH =1.0;
AL_EQUALIZER_MIN_HIGH_GAIN =0.126;
AL_EQUALIZER_MAX_HIGH_GAIN =7.943;
AL_EQUALIZER_DEFAULT_HIGH_GAIN =1.0;
AL_EQUALIZER_MIN_HIGH_CUTOFF =4000.0;
AL_EQUALIZER_MAX_HIGH_CUTOFF =16000.0;
AL_EQUALIZER_DEFAULT_HIGH_CUTOFF =6000.0;
AL_MIN_AIR_ABSORPTION_FACTOR =0.0;
AL_MAX_AIR_ABSORPTION_FACTOR =10.0;
AL_DEFAULT_AIR_ABSORPTION_FACTOR =0.0;
AL_MIN_ROOM_ROLLOFF_FACTOR =0.0;
AL_MAX_ROOM_ROLLOFF_FACTOR =10.0;
AL_DEFAULT_ROOM_ROLLOFF_FACTOR =0.0;
AL_MIN_CONE_OUTER_GAINHF =0.0;
AL_MAX_CONE_OUTER_GAINHF =1.0;
AL_DEFAULT_CONE_OUTER_GAINHF =1.0;
AL_MIN_DIRECT_FILTER_GAINHF_AUTO =AL_FALSE;
AL_MAX_DIRECT_FILTER_GAINHF_AUTO =AL_TRUE;
AL_DEFAULT_DIRECT_FILTER_GAINHF_AUTO =AL_TRUE;
AL_MIN_AUXILIARY_SEND_FILTER_GAIN_AUTO =AL_FALSE;
AL_MAX_AUXILIARY_SEND_FILTER_GAIN_AUTO =AL_TRUE;
AL_DEFAULT_AUXILIARY_SEND_FILTER_GAIN_AUTO =AL_TRUE;
AL_MIN_AUXILIARY_SEND_FILTER_GAINHF_AUTO =AL_FALSE;
AL_MAX_AUXILIARY_SEND_FILTER_GAINHF_AUTO =AL_TRUE;
AL_DEFAULT_AUXILIARY_SEND_FILTER_GAINHF_AUTO =AL_TRUE;
AL_DEFAULT_METERS_PER_UNIT =1.0;
AL_EAXREVERB_DENSITY =$0001;
AL_EAXREVERB_DIFFUSION =$0002;
AL_EAXREVERB_GAIN =$0003;
AL_EAXREVERB_GAINHF =$0004;
AL_EAXREVERB_GAINLF =$0005;
AL_EAXREVERB_DECAY_TIME =$0006;
AL_EAXREVERB_DECAY_HFRATIO =$0007;
AL_EAXREVERB_DECAY_LFRATIO =$0008;
AL_EAXREVERB_REFLECTIONS_GAIN =$0009;
AL_EAXREVERB_REFLECTIONS_DELAY =$000A;
AL_EAXREVERB_REFLECTIONS_PAN =$000B;
AL_EAXREVERB_LATE_REVERB_GAIN =$000C;
AL_EAXREVERB_LATE_REVERB_DELAY =$000D;
AL_EAXREVERB_LATE_REVERB_PAN =$000E;
AL_EAXREVERB_ECHO_TIME =$000F;
AL_EAXREVERB_ECHO_DEPTH =$0010;
AL_EAXREVERB_MODULATION_TIME =$0011;
AL_EAXREVERB_MODULATION_DEPTH =$0012;
AL_EAXREVERB_AIR_ABSORPTION_GAINHF =$0013;
AL_EAXREVERB_HFREFERENCE =$0014;
AL_EAXREVERB_LFREFERENCE =$0015;
AL_EAXREVERB_ROOM_ROLLOFF_FACTOR =$0016;
AL_EAXREVERB_DECAY_HFLIMIT =$0017;
AL_EFFECT_EAXREVERB =$8000;
AL_EAXREVERB_MIN_DENSITY =0.0;
AL_EAXREVERB_MAX_DENSITY =1.0;
AL_EAXREVERB_DEFAULT_DENSITY =1.0;
AL_EAXREVERB_MIN_DIFFUSION =0.0;
AL_EAXREVERB_MAX_DIFFUSION =1.0;
AL_EAXREVERB_DEFAULT_DIFFUSION =1.0;
AL_EAXREVERB_MIN_GAIN =0.0;
AL_EAXREVERB_MAX_GAIN =1.0;
AL_EAXREVERB_DEFAULT_GAIN =0.32;
AL_EAXREVERB_MIN_GAINHF =0.0;
AL_EAXREVERB_MAX_GAINHF =1.0;
AL_EAXREVERB_DEFAULT_GAINHF =0.89;
AL_EAXREVERB_MIN_GAINLF =0.0;
AL_EAXREVERB_MAX_GAINLF =1.0;
AL_EAXREVERB_DEFAULT_GAINLF =1.0;
AL_EAXREVERB_MIN_DECAY_TIME =0.1;
AL_EAXREVERB_MAX_DECAY_TIME =20.0;
AL_EAXREVERB_DEFAULT_DECAY_TIME =1.49;
AL_EAXREVERB_MIN_DECAY_HFRATIO =0.1;
AL_EAXREVERB_MAX_DECAY_HFRATIO =2.0;
AL_EAXREVERB_DEFAULT_DECAY_HFRATIO =0.83;
AL_EAXREVERB_MIN_DECAY_LFRATIO =0.1;
AL_EAXREVERB_MAX_DECAY_LFRATIO =2.0;
AL_EAXREVERB_DEFAULT_DECAY_LFRATIO =1.0;
AL_EAXREVERB_MIN_REFLECTIONS_GAIN =0.0;
AL_EAXREVERB_MAX_REFLECTIONS_GAIN =3.16;
AL_EAXREVERB_DEFAULT_REFLECTIONS_GAIN =0.05;
AL_EAXREVERB_MIN_REFLECTIONS_DELAY =0.0;
AL_EAXREVERB_MAX_REFLECTIONS_DELAY =0.3;
AL_EAXREVERB_DEFAULT_REFLECTIONS_DELAY =0.007;
AL_EAXREVERB_DEFAULT_REFLECTIONS_PAN: array[0..2] of TALFloat = (0.0, 0.0, 0.0);
AL_EAXREVERB_MIN_LATE_REVERB_GAIN =0.0;
AL_EAXREVERB_MAX_LATE_REVERB_GAIN =10.0;
AL_EAXREVERB_DEFAULT_LATE_REVERB_GAIN =1.26;
AL_EAXREVERB_MIN_LATE_REVERB_DELAY =0.0;
AL_EAXREVERB_MAX_LATE_REVERB_DELAY =0.1;
AL_EAXREVERB_DEFAULT_LATE_REVERB_DELAY =0.011;
AL_EAXREVERB_DEFAULT_LATE_REVERB_PAN: array[0..2] of TALFloat = (0.0, 0.0, 0.0);
AL_EAXREVERB_MIN_ECHO_TIME =0.075;
AL_EAXREVERB_MAX_ECHO_TIME =0.25;
AL_EAXREVERB_DEFAULT_ECHO_TIME =0.25;
AL_EAXREVERB_MIN_ECHO_DEPTH =0.0;
AL_EAXREVERB_MAX_ECHO_DEPTH =1.0;
AL_EAXREVERB_DEFAULT_ECHO_DEPTH =0.0;
AL_EAXREVERB_MIN_MODULATION_TIME =0.04;
AL_EAXREVERB_MAX_MODULATION_TIME =4.0;
AL_EAXREVERB_DEFAULT_MODULATION_TIME =0.25;
AL_EAXREVERB_MIN_MODULATION_DEPTH =0.0;
AL_EAXREVERB_MAX_MODULATION_DEPTH =1.0;
AL_EAXREVERB_DEFAULT_MODULATION_DEPTH =0.0;
AL_EAXREVERB_MIN_AIR_ABSORPTION_GAINHF =0.892;
AL_EAXREVERB_MAX_AIR_ABSORPTION_GAINHF =1.0;
AL_EAXREVERB_DEFAULT_AIR_ABSORPTION_GAINHF =0.994;
AL_EAXREVERB_MIN_HFREFERENCE =1000.0;
AL_EAXREVERB_MAX_HFREFERENCE =20000.0;
AL_EAXREVERB_DEFAULT_HFREFERENCE =5000.0;
AL_EAXREVERB_MIN_LFREFERENCE =20.0;
AL_EAXREVERB_MAX_LFREFERENCE =1000.0;
AL_EAXREVERB_DEFAULT_LFREFERENCE =250.0;
AL_EAXREVERB_MIN_ROOM_ROLLOFF_FACTOR =0.0;
AL_EAXREVERB_MAX_ROOM_ROLLOFF_FACTOR =10.0;
AL_EAXREVERB_DEFAULT_ROOM_ROLLOFF_FACTOR =0.0;
AL_EAXREVERB_MIN_DECAY_HFLIMIT = AL_FALSE;
AL_EAXREVERB_MAX_DECAY_HFLIMIT = AL_TRUE;
AL_EAXREVERB_DEFAULT_DECAY_HFLIMIT = AL_TRUE;
DSPROPSETID_EAX20_ListenerProperties : TGuid = '{0306A6A8-B224-11d2-99E5-0000E8D8C722}';
DSPROPSETID_EAX20_BufferProperties : TGuid = '{0306A6A7-B224-11d2-99E5-0000E8D8C722}';
DSPROPERTY_EAXLISTENER_NONE = 0;
DSPROPERTY_EAXLISTENER_ALLPARAMETERS = 1;
DSPROPERTY_EAXLISTENER_ROOM = 2;
DSPROPERTY_EAXLISTENER_ROOMHF = 3;
DSPROPERTY_EAXLISTENER_ROOMROLLOFFFACTOR = 4;
DSPROPERTY_EAXLISTENER_DECAYTIME = 5;
DSPROPERTY_EAXLISTENER_DECAYHFRATIO = 6;
DSPROPERTY_EAXLISTENER_REFLECTIONS = 7;
DSPROPERTY_EAXLISTENER_REFLECTIONSDELAY = 8;
DSPROPERTY_EAXLISTENER_REVERB = 9;
DSPROPERTY_EAXLISTENER_REVERBDELAY = 10;
DSPROPERTY_EAXLISTENER_ENVIRONMENT = 11;
DSPROPERTY_EAXLISTENER_ENVIRONMENTSIZE = 12;
DSPROPERTY_EAXLISTENER_ENVIRONMENTDIFFUSION = 13;
DSPROPERTY_EAXLISTENER_AIRABSORPTIONHF = 14;
DSPROPERTY_EAXLISTENER_FLAGS = 15;
DSPROPERTY_EAXLISTENER_IMMEDIATE = $00000000;
DSPROPERTY_EAXLISTENER_DEFERRED = LongWORD($80000000);
DSPROPERTY_EAXLISTENER_COMMITDEFERREDSETTINGS = (DSPROPERTY_EAXLISTENER_NONE or DSPROPERTY_EAXLISTENER_IMMEDIATE);
EAX_ENVIRONMENT_GENERIC = 0;
EAX_ENVIRONMENT_PADDEDCELL = 1;
EAX_ENVIRONMENT_ROOM = 2;
EAX_ENVIRONMENT_BATHROOM = 3;
EAX_ENVIRONMENT_LIVINGROOM = 4;
EAX_ENVIRONMENT_STONEROOM = 5;
EAX_ENVIRONMENT_AUDITORIUM = 6;
EAX_ENVIRONMENT_CONCERTHALL = 7;
EAX_ENVIRONMENT_CAVE = 8;
EAX_ENVIRONMENT_ARENA = 9;
EAX_ENVIRONMENT_HANGAR = 10;
EAX_ENVIRONMENT_CARPETEDHALLWAY = 11;
EAX_ENVIRONMENT_HALLWAY = 12;
EAX_ENVIRONMENT_STONECORRIDOR = 13;
EAX_ENVIRONMENT_ALLEY = 14;
EAX_ENVIRONMENT_FOREST = 15;
EAX_ENVIRONMENT_CITY = 16;
EAX_ENVIRONMENT_MOUNTAINS = 17;
EAX_ENVIRONMENT_QUARRY = 18;
EAX_ENVIRONMENT_PLAIN = 19;
EAX_ENVIRONMENT_PARKINGLOT = 20;
EAX_ENVIRONMENT_SEWERPIPE = 21;
EAX_ENVIRONMENT_UNDERWATER = 22;
EAX_ENVIRONMENT_DRUGGED = 23;
EAX_ENVIRONMENT_DIZZY = 24;
EAX_ENVIRONMENT_PSYCHOTIC = 25;
EAX_ENVIRONMENT_COUNT = 26;
EAXLISTENERFLAGS_DECAYTIMESCALE = $00000001;
EAXLISTENERFLAGS_REFLECTIONSSCALE = $00000002;
EAXLISTENERFLAGS_REFLECTIONSDELAYSCALE = $00000004;
EAXLISTENERFLAGS_REVERBSCALE = $00000008;
EAXLISTENERFLAGS_REVERBDELAYSCALE = $00000010;
EAXLISTENERFLAGS_DECAYHFLIMIT = $00000020;
EAXLISTENERFLAGS_RESERVED = $FFFFFFC0;
EAXLISTENER_MINROOM = -10000;
EAXLISTENER_MAXROOM = 0;
EAXLISTENER_DEFAULTROOM = -1000;
EAXLISTENER_MINROOMHF = -10000;
EAXLISTENER_MAXROOMHF = 0;
EAXLISTENER_DEFAULTROOMHF = -100;
EAXLISTENER_MINROOMROLLOFFFACTOR = 0.0;
EAXLISTENER_MAXROOMROLLOFFFACTOR = 10.0;
EAXLISTENER_DEFAULTROOMROLLOFFFACTOR = 0.0;
EAXLISTENER_MINDECAYTIME = 0.1;
EAXLISTENER_MAXDECAYTIME = 20.0;
EAXLISTENER_DEFAULTDECAYTIME = 1.49;
EAXLISTENER_MINDECAYHFRATIO = 0.1;
EAXLISTENER_MAXDECAYHFRATIO = 2.0;
EAXLISTENER_DEFAULTDECAYHFRATIO = 0.83;
EAXLISTENER_MINREFLECTIONS = -10000;
EAXLISTENER_MAXREFLECTIONS = 1000;
EAXLISTENER_DEFAULTREFLECTIONS = -2602;
EAXLISTENER_MINREFLECTIONSDELAY = 0.0;
EAXLISTENER_MAXREFLECTIONSDELAY = 0.3;
EAXLISTENER_DEFAULTREFLECTIONSDELAY = 0.007;
EAXLISTENER_MINREVERB = -10000;
EAXLISTENER_MAXREVERB = 2000;
EAXLISTENER_DEFAULTREVERB = 200;
EAXLISTENER_MINREVERBDELAY = 0.0;
EAXLISTENER_MAXREVERBDELAY = 0.1;
EAXLISTENER_DEFAULTREVERBDELAY = 0.011;
EAXLISTENER_MINENVIRONMENT = 0;
EAXLISTENER_MAXENVIRONMENT = EAX_ENVIRONMENT_COUNT - 1;
EAXLISTENER_DEFAULTENVIRONMENT = EAX_ENVIRONMENT_GENERIC;
EAXLISTENER_MINENVIRONMENTSIZE = 1.0;
EAXLISTENER_MAXENVIRONMENTSIZE = 100.0;
EAXLISTENER_DEFAULTENVIRONMENTSIZE = 7.5;
EAXLISTENER_MINENVIRONMENTDIFFUSION = 0.0;
EAXLISTENER_MAXENVIRONMENTDIFFUSION = 1.0;
EAXLISTENER_DEFAULTENVIRONMENTDIFFUSION = 1.0;
EAXLISTENER_MINAIRABSORPTIONHF = -100.0;
EAXLISTENER_MAXAIRABSORPTIONHF = 0.0;
EAXLISTENER_DEFAULTAIRABSORPTIONHF = -5.0;
EAXLISTENER_DEFAULTFLAGS = EAXLISTENERFLAGS_DECAYTIMESCALE or EAXLISTENERFLAGS_REFLECTIONSSCALE or EAXLISTENERFLAGS_REFLECTIONSDELAYSCALE or EAXLISTENERFLAGS_REVERBSCALE or EAXLISTENERFLAGS_REVERBDELAYSCALE or EAXLISTENERFLAGS_DECAYHFLIMIT;
DSPROPERTY_EAXBUFFER_NONE = 0;
DSPROPERTY_EAXBUFFER_ALLPARAMETERS = 1;
DSPROPERTY_EAXBUFFER_DIRECT = 2;
DSPROPERTY_EAXBUFFER_DIRECTHF = 3;
DSPROPERTY_EAXBUFFER_ROOM = 4;
DSPROPERTY_EAXBUFFER_ROOMHF = 5;
DSPROPERTY_EAXBUFFER_ROOMROLLOFFFACTOR = 6;
DSPROPERTY_EAXBUFFER_OBSTRUCTION = 7;
DSPROPERTY_EAXBUFFER_OBSTRUCTIONLFRATIO = 8;
DSPROPERTY_EAXBUFFER_OCCLUSION = 9;
DSPROPERTY_EAXBUFFER_OCCLUSIONLFRATIO = 10;
DSPROPERTY_EAXBUFFER_OCCLUSIONROOMRATIO = 11;
DSPROPERTY_EAXBUFFER_OUTSIDEVOLUMEHF = 12;
DSPROPERTY_EAXBUFFER_AIRABSORPTIONFACTOR = 13;
DSPROPERTY_EAXBUFFER_FLAG = 14;
DSPROPERTY_EAXBUFFER_IMMEDIATE = $00000000;
DSPROPERTY_EAXBUFFER_DEFERRED = LongWORD($80000000);
DSPROPERTY_EAXBUFFER_COMMITDEFERREDSETTINGS = DSPROPERTY_EAXBUFFER_NONE or DSPROPERTY_EAXBUFFER_IMMEDIATE;
EAXBUFFERFLAGS_DIRECTHFAUTO = $00000001;
EAXBUFFERFLAGS_ROOMAUTO = $00000002;
EAXBUFFERFLAGS_ROOMHFAUTO = $00000004;
EAXBUFFERFLAGS_RESERVED = $FFFFFFF8;
EAXBUFFER_MINDIRECT = -10000;
EAXBUFFER_MAXDIRECT = 1000;
EAXBUFFER_DEFAULTDIRECT = 0;
EAXBUFFER_MINDIRECTHF = -10000;
EAXBUFFER_MAXDIRECTHF = 0;
EAXBUFFER_DEFAULTDIRECTHF = 0;
EAXBUFFER_MINROOM = -10000;
EAXBUFFER_MAXROOM = 1000;
EAXBUFFER_DEFAULTROOM = 0;
EAXBUFFER_MINROOMHF = -10000;
EAXBUFFER_MAXROOMHF = 0;
EAXBUFFER_DEFAULTROOMHF = 0;
EAXBUFFER_MINROOMROLLOFFFACTOR = 0.0;
EAXBUFFER_MAXROOMROLLOFFFACTOR = 10.;
EAXBUFFER_DEFAULTROOMROLLOFFFACTOR = 0.0;
EAXBUFFER_MINOBSTRUCTION = -10000;
EAXBUFFER_MAXOBSTRUCTION = 0;
EAXBUFFER_DEFAULTOBSTRUCTION = 0;
EAXBUFFER_MINOBSTRUCTIONLFRATIO = 0.0;
EAXBUFFER_MAXOBSTRUCTIONLFRATIO = 1.0;
EAXBUFFER_DEFAULTOBSTRUCTIONLFRATIO = 0.0;
EAXBUFFER_MINOCCLUSION = -10000;
EAXBUFFER_MAXOCCLUSION = 0;
EAXBUFFER_DEFAULTOCCLUSION = 0;
EAXBUFFER_MINOCCLUSIONLFRATIO = 0.0;
EAXBUFFER_MAXOCCLUSIONLFRATIO = 1.0;
EAXBUFFER_DEFAULTOCCLUSIONLFRATIO = 0.25;
EAXBUFFER_MINOCCLUSIONROOMRATIO = 0.0;
EAXBUFFER_MAXOCCLUSIONROOMRATIO = 10.0;
EAXBUFFER_DEFAULTOCCLUSIONROOMRATIO = 0.5;
EAXBUFFER_MINOUTSIDEVOLUMEHF = -10000;
EAXBUFFER_MAXOUTSIDEVOLUMEHF = 0;
EAXBUFFER_DEFAULTOUTSIDEVOLUMEHF = 0;
EAXBUFFER_MINAIRABSORPTIONFACTOR = 0.0;
EAXBUFFER_MAXAIRABSORPTIONFACTOR = 10.0;
EAXBUFFER_DEFAULTAIRABSORPTIONFACTOR = 1.0;
EAXBUFFER_DEFAULTFLAGS = EAXBUFFERFLAGS_DIRECTHFAUTO or EAXBUFFERFLAGS_ROOMAUTO or EAXBUFFERFLAGS_ROOMHFAUTO;
EAX_MATERIAL_SINGLEWINDOW = -2800;
EAX_MATERIAL_SINGLEWINDOWLF = 0.71;
EAX_MATERIAL_SINGLEWINDOWROOMRATIO = 0.43;
EAX_MATERIAL_DOUBLEWINDOW = -5000;
EAX_MATERIAL_DOUBLEWINDOWHF = 0.40;
EAX_MATERIAL_DOUBLEWINDOWROOMRATIO = 0.24;
EAX_MATERIAL_THINDOOR = -1800;
EAX_MATERIAL_THINDOORLF = 0.66;
EAX_MATERIAL_THINDOORROOMRATIO = 0.66;
EAX_MATERIAL_THICKDOOR = -4400;
EAX_MATERIAL_THICKDOORLF = 0.64;
EAX_MATERIAL_THICKDOORROOMRTATION = 0.27;
EAX_MATERIAL_WOODWALL = -4000;
EAX_MATERIAL_WOODWALLLF = 0.50;
EAX_MATERIAL_WOODWALLROOMRATIO = 0.30;
EAX_MATERIAL_BRICKWALL = -5000;
EAX_MATERIAL_BRICKWALLLF = 0.60;
EAX_MATERIAL_BRICKWALLROOMRATIO = 0.24;
EAX_MATERIAL_STONEWALL = -6000;
EAX_MATERIAL_STONEWALLLF = 0.68;
EAX_MATERIAL_STONEWALLROOMRATIO = 0.20;
EAX_MATERIAL_CURTAIN = -1200;
EAX_MATERIAL_CURTAINLF = 0.15;
EAX_MATERIAL_CURTAINROOMRATIO = 1.00;

Variables

alEnable: procedure(capability: TALenum); cdecl;
alDisable: procedure(capability: TALenum); cdecl;
alIsEnabled: function(capability: TALenum): TALboolean; cdecl;
alHint: procedure(target, mode: TALenum); cdecl;
alGetBooleanv: procedure(param: TALenum; data: PALboolean); cdecl;
alGetIntegerv: procedure(param: TALenum; data: PALint); cdecl;
alGetFloatv: procedure(param: TALenum; data: PALfloat); cdecl;
alGetDoublev: procedure(param: TALenum; data: PALdouble); cdecl;
alGetString: function(param: TALenum): PALubyte; cdecl;
alGetBoolean: function(param: TALenum): TALboolean; cdecl;
alGetInteger: function(param: TALenum): TALint; cdecl;
alGetFloat: function(param: TALenum): TALfloat; cdecl;
alGetDouble: function(param: TALenum): TALdouble; cdecl;
alGetError: function: TALenum; cdecl;
alIsExtensionPresent: function(fname: PAnsiChar): TALboolean; cdecl;
alGetProcAddress: function(fname: PALuByte): Pointer; cdecl;
alGetEnumValue: function(ename: PALuByte): TALenum; cdecl;
alListenerf: procedure(param: TALenum; value: TALfloat); cdecl;
alListener3f: procedure(param: TALenum; f1: TALfloat; f2: TALfloat; f3: TALfloat); cdecl;
alListenerfv: procedure(param: TALenum; values: PALfloat); cdecl;
alListeneri: procedure(param: TAlenum; value: TALint); cdecl;
alListener3i: procedure(param: TALenum; value1: TALint; value2: TALint; value3: TALint );
alListeneriv: procedure(param: TALenum; const values: PALint );
alGetListeneriv: procedure(param: TALenum; values: PALint); cdecl;
alGetListenerfv: procedure(param: TALenum; values: PALfloat); cdecl;
alGenSources: procedure(n: TALsizei; sources: PALuint); cdecl;
alDeleteSources: procedure(n: TALsizei; sources: PALuint); cdecl;
alIsSource: function(id: TALuint): TALboolean; cdecl;
alSourcei: procedure(source: TALuint; param: TALenum; value: TALint); cdecl;
alSource3i: procedure(source: TALuint; param: TALenum; v1: TALint; v2: TALint; v3: TALint); cdecl;
alSourceiv: procedure(source: TALuint; param: TALenum; values: PALint); cdecl;
alSourcef: procedure(source: TALuint; param: TALenum; value: TALfloat); cdecl;
alSource3f: procedure(source: TALuint; param: TALenum; v1: TALfloat; v2: TALfloat; v3: TALfloat); cdecl;
alSourcefv: procedure(source: TALuint; param: TALenum; values: PALfloat); cdecl;
alGetSourcei: procedure(source: TALuint; param: TALenum; value: PALint); cdecl;
alGetSource3i: procedure(source: TALuint; param: TALenum; v1: PALint; v2: PALint; v3: PALint); cdecl;
alGetSourceiv: procedure(source: TALuint; param: TALenum; values: PALint); cdecl;
alGetSourcef: procedure(source: TALuint; param: TALenum; value: PALfloat); cdecl;
alGetSource3f: procedure(source: TALuint; param: TALenum; v1: PALfloat; v2: PALfloat; v3: PALfloat); cdecl;
alGetSourcefv: procedure(source: TALuint; param: TALenum; values: PALfloat); cdecl;
alSourcePlay: procedure(source: TALuint); cdecl;
alSourcePause: procedure(source: TALuint); cdecl;
alSourceStop: procedure(source: TALuint); cdecl;
alSourceRewind: procedure(source: TALuint); cdecl;
alSourcePlayv: procedure(n: TALsizei; sources: PALuint); cdecl;
alSourceStopv: procedure(n: TALsizei; sources: PALuint); cdecl;
alSourceRewindv: procedure(n: TALsizei; sources: PALuint); cdecl;
alSourcePausev: procedure(n: TALsizei; sources: PALuint); cdecl;
alSourceQueueBuffers: procedure(source: TALuint; n: TALsizei; buffers: PALuint); cdecl;
alSourceUnqueueBuffers: procedure(source: TALuint; n: TALsizei; buffers: PALuint); cdecl;
alGenBuffers: procedure(n: TALsizei; buffers: PALuint); cdecl;
alDeleteBuffers: procedure(n: TALsizei; buffers: PALuint); cdecl;
alIsBuffer: function(buffer: TALuint): TALboolean; cdecl;
alBufferData: procedure(buffer: TALuint; format: TALenum; data: Pointer; size, freq: TALsizei); cdecl;
alBufferi: procedure(buffer: TALuint; param: TALenum; value: TALint); cdecl;
alBuffer3i: procedure(buffer: TALuint; param: TALenum; v1: TALint; v2: TALint; v3: TALint); cdecl;
alBufferiv: procedure(buffer: TALuint; param: TALenum; values: PALint); cdecl;
alBufferf: procedure(buffer: TALuint; param: TALenum; value: TALfloat); cdecl;
alBuffer3f: procedure(buffer: TALuint; param: TALenum; v1: TALfloat; v2: TALfloat; v3: TALfloat); cdecl;
alBufferfv: procedure(buffer: TALuint; param: TALenum; values: PALfloat); cdecl;
alGetBufferi: procedure(buffer: TALuint; param: TALenum; value: PALint); cdecl;
alGetBuffer3i: procedure(buffer: TALuint; param: TALenum; v1: PALint; v2: PALint; v3: PALint); cdecl;
alGetBufferiv: procedure(buffer: TALuint; param: TALenum; values: PALint); cdecl;
alGetBufferf: procedure(buffer: TALuint; param: TALenum; value: PALfloat); cdecl;
alGetBuffer3f: procedure(buffer: TALuint; param: TALenum; v1: PALfloat; v2: PALfloat; v3: PALfloat); cdecl;
alGetBufferfv: procedure(buffer: TALuint; param: TALenum; values: PALfloat); cdecl;
alDistanceModel: procedure(value: TALenum); cdecl;
alDopplerFactor: procedure(value: TALfloat); cdecl;
alDopplerVelocity: procedure(value: TALfloat); cdecl;
alSpeedOfSound: procedure( value: TALfloat ); cdecl;
alcCreateContext: function(device: TALCdevice; attrlist: PALCint): TALCcontext; cdecl;
alcMakeContextCurrent: function(context: TALCcontext): TALCenum; cdecl;
alcProcessContext: procedure(context: TALCcontext); cdecl;
alcSuspendContext: procedure(context: TALCcontext); cdecl;
alcDestroyContext: procedure(context: TALCcontext); cdecl;
alcGetCurrentContext: function: TALCcontext; cdecl;
alcGetContextsDevice: function(context: TALCcontext): TALCdevice; cdecl;
alcOpenDevice: function(deviceName: PALCuByte): TALCdevice; cdecl;
alcCloseDevice: procedure(device: TALCdevice); cdecl;
alcGetError: function(device: TALCdevice): TALCenum; cdecl;
alcIsExtensionPresent: function(device: TALCdevice; extName: PALuByte): TALCboolean; cdecl;
alcGetProcAddress: function(device: TALCdevice; funcName: PALuByte): TALCvoid; cdecl;
alcGetEnumValue: function(device: TALCdevice; enumName: PALuByte): TALCenum; cdecl;
alcGetString: function(device: TALCdevice; param: TALCenum): PALCubyte; cdecl;
alcGetIntegerv: procedure(device: TALCdevice; param: TALCenum; size: TALCsizei; data: PALCint); cdecl;
alcCaptureOpenDevice: function( const devicename: PALCchar; frequency: TALCuint; format: TALCenum; buffersize: TALCsizei): PALCdevice; cdecl;
alcCaptureCloseDevice: function( device: PALCdevice ): TALCboolean; cdecl;
alcCaptureStart: procedure( device: PALCdevice ); cdecl;
alcCaptureStop: procedure( device: PALCdevice ); cdecl;
alcCaptureSamples: procedure( device: PALCdevice; buffer: TALCvoid; samples: TALCsizei ); cdecl;
EAXSet: Function(const Guid: TGUID; ALuint1: TALuint; ALuint2: TALuint; point: Pointer; ALuint3: TALuint): TALenum; cdecl;
EAXGet: Function(const Guid: TGUID; ALuint1: TALuint; ALuint2: TALuint; point: Pointer; ALuint3: TALuint): TALenum; cdecl;
AL_EAX_RAM_SIZE: TALEnum;
AL_EAX_RAM_FREE: TALEnum;
AL_STORAGE_AUTOMATIC: TALEnum;
AL_STORAGE_HARDWARE: TALEnum;
AL_STORAGE_ACCESSIBLE: TALEnum;
EAXSetBufferMode: function(n: TALsizei;buffers: PALuint; value: TALint ): TALboolean; cdecl;
EAXGetBufferMode: function(buffer: TALuint; value: PALint ): TALenum; cdecl;
ALGENEFFECTS: procedure( n: TALsizei; effects: PALuint ); cdecl;
ALDELETEEFFECTS: procedure( n: TALsizei; effects: PALuint ); cdecl;
ALISEFFECT: function( eid: TALuint ): TALboolean; cdecl;
ALEFFECTI: procedure( eid: TALuint; param: TALCenum; value: TALint); cdecl;
ALEFFECTIV: procedure( eid: TALuint; param: TALenum; values: PALint ); cdecl;
ALEFFECTF: procedure( eid: TALuint; param: TALenum; value: TALfloat); cdecl;
ALEFFECTFV: procedure( eid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGETEFFECTI: procedure( eid: TALuint; param: TALenum; value: PALint ); cdecl;
ALGETEFFECTIV: procedure( eid: TALuint; param: TALenum; values: PALint ); cdecl;
ALGETEFFECTF: procedure( eid: TALuint; param: TALenum; value: PALfloat ); cdecl;
ALGETEFFECTFV: procedure( eid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGENFILTERS: procedure( n: TALsizei; filters: PALuint ); cdecl;
ALDELETEFILTERS: procedure( n: TALsizei; filters: PALuint ); cdecl;
ALISFILTER: function( fid: TALuint ): TALboolean; cdecl;
ALFILTERI: procedure( fid: TALuint; param: TALenum; value: TALint ); cdecl;
ALFILTERIV: procedure( fid: TALuint; param: TALenum; values: PALint ); cdecl;
ALFILTERF: procedure( fid: TALuint; param: TALenum; value: TALfloat); cdecl;
ALFILTERFV: procedure( fid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGETFILTERI: procedure( fid: TALuint; param: TALenum; value: PALint ); cdecl;
ALGETFILTERIV: procedure( fid: TALuint; param: TALenum; values: PALint ); cdecl;
ALGETFILTERF: procedure( fid: TALuint; param: TALenum; value: PALfloat ); cdecl;
ALGETFILTERFV: procedure( fid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGENAUXILIARYEFFECTSLOTS: procedure( n: TALsizei; slots: PALuint ); cdecl;
ALDELETEAUXILIARYEFFECTSLOTS: procedure( n: TALsizei; slots: PALuint ); cdecl;
ALISAUXILIARYEFFECTSLOT: function( slot: TALuint ): TALboolean; cdecl;
ALAUXILIARYEFFECTSLOTI: procedure( asid: TALuint; param: TALenum; value: TALint ); cdecl;
ALAUXILIARYEFFECTSLOTIV: procedure( asid: TALuint; param: TALenum; values: PALint ); cdecl;
ALAUXILIARYEFFECTSLOTF: procedure( asid: TALuint; param: TALenum; value: TALfloat ); cdecl;
ALAUXILIARYEFFECTSLOTFV: procedure( asid: TALuint; param: TALenum; values: PALfloat ); cdecl;
ALGETAUXILIARYEFFECTSLOTI: procedure( asid: TALuint; param: TALenum; value: PALint ); cdecl;
ALGETAUXILIARYEFFECTSLOTIV: procedure( asid: TALuint; param: TALenum; values: PALint ); cdecl;
ALGETAUXILIARYEFFECTSLOTF: procedure( asid: TALuint; param: TALenum; value: PALfloat ); cdecl;
ALGETAUXILIARYEFFECTSLOTFV: procedure( asid: TALuint; param: TALenum; values: PALfloat ); cdecl;
LibHandle: THandle = 0;
EFXUtilLibHandle: THandle = 0;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:21


GLScene v.1.1.2: openal: packed record TEaxListenerProperties

packed record TEaxListenerProperties

Unit

openal

Declaration

type TEaxListenerProperties = packed record

Description

Overview

Fields

lRoom: integer;
lRoomHF: integer;
flRoomRolloffFactor: double;
flDecayTime: double;
flDecayHFRatio: double;
lReflections: integer;
flReflectionsDelay: double;
lReverb: integer;
flReverbDelay: double;
dwEnvironment: cardinal;
flEnvironmentSize: double;
flEnvironmentDiffusion: double;
flAirAbsorptionHF: double;
dwFlags: cardinal;

Description

Fields

lRoom: integer;
lRoomHF: integer;
flRoomRolloffFactor: double;
flDecayTime: double;
flDecayHFRatio: double;
lReflections: integer;
flReflectionsDelay: double;
lReverb: integer;
flReverbDelay: double;
dwEnvironment: cardinal;
flEnvironmentSize: double;
flEnvironmentDiffusion: double;
flAirAbsorptionHF: double;
dwFlags: cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:21


GLScene v.1.1.2: openal: packed record TEaxBufferProperties

packed record TEaxBufferProperties

Unit

openal

Declaration

type TEaxBufferProperties = packed record

Description

Overview

Fields

lDirect: integer;
lDirectHF: integer;
lRoom: integer;
lRoomHF: integer;
flRoomRolloffFactor: double;
lObstruction: integer;
flObstructionLFRatio: double;
lOcclusion: integer;
flOcclusionLFRatio: double;
flOcclusionRoomRatio: double;
lOutsideVolumeHF: integer;
flAirAbsorptionFactor: double;
dwFlags: Cardinal;

Description

Fields

lDirect: integer;
lDirectHF: integer;
lRoom: integer;
lRoomHF: integer;
flRoomRolloffFactor: double;
lObstruction: integer;
flObstructionLFRatio: double;
lOcclusion: integer;
flOcclusionLFRatio: double;
flOcclusionRoomRatio: double;
lOutsideVolumeHF: integer;
flAirAbsorptionFactor: double;
dwFlags: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:21


GLScene v.1.1.2: openal: packed record _EFXEAXREVERBPROPERTIES

packed record _EFXEAXREVERBPROPERTIES

Unit

openal

Declaration

type _EFXEAXREVERBPROPERTIES = packed record

Description

Overview

Fields

flDensity: single;
flDiffusion: single;
flGain: single;
flGainHF: single;
flGainLF: single;
flDecayTime: single;
flDecayHFRatio: single;
flDecayLFRatio: single;
flReflectionsGain: single;
flReflectionsDelay: single;
flReflectionsPan: packed[0..2] of single;
flLateReverbGain: single;
flLateReverbDelay: single;
flLateReverbPan: packed[0..2] of single;
flEchoTime: single;
flEchoDepth: single;
flModulationTime: single;
flModulationDepth: single;
flAirAbsorptionGainHF: single;
flHFReference: single;
flLFReference: single;
flRoomRolloffFactor: single;
iDecayHFLimit: integer;

Description

Fields

flDensity: single;
flDiffusion: single;
flGain: single;
flGainHF: single;
flGainLF: single;
flDecayTime: single;
flDecayHFRatio: single;
flDecayLFRatio: single;
flReflectionsGain: single;
flReflectionsDelay: single;
flReflectionsPan: packed[0..2] of single;
flLateReverbGain: single;
flLateReverbDelay: single;
flLateReverbPan: packed[0..2] of single;
flEchoTime: single;
flEchoDepth: single;
flModulationTime: single;
flModulationDepth: single;
flAirAbsorptionGainHF: single;
flHFReference: single;
flLFReference: single;
flRoomRolloffFactor: single;
iDecayHFLimit: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:21


GLScene v.1.1.2: openal: packed record _EFXLOWPASSFILTER

packed record _EFXLOWPASSFILTER

Unit

openal

Declaration

type _EFXLOWPASSFILTER = packed record

Description

Overview

Fields

flGain: single;
flGainHF: single;

Description

Fields

flGain: single;
flGainHF: single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:21


GLScene v.1.1.2: OpenGL1x

Unit OpenGL1x

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

OpenGL1x<p>

OpenGL 1.x import unit for GLScene. Unit remains "general purpose", but with a more "pragmatic" approach :)<p>

This unit is based on OpenGL12.pas orginally written by Mike Lischke, please refer to OpenGL12.pas header.<p>

<b>History : </b><font size=-1><ul> <li>23/01/11 - DanB - Entry points now use procedural types from OpenGLTokens.pas Added OpenGL 4.1 + ARB extensions Switched to use GLS_REGIONS define <li>23/08/10 - Yar - Moved tokens part to OpenGLTokens.pas <li>22/07/10 - Yar - Added GL_ARB_debug_output constant <li>01/06/10 - Yar - Fixes for Linux x64 <li>31/05/10 - Yar - Added WGL_NV_gpu_affinity <li>12/05/10 - Yar - Added GL_ARB_texture_compression_bptc <li>04/05/10 - Yar - Added GL_S3_s3tc extension (thanks to Rustam Asmandiarov aka Predator) <li>01/05/10 - DanB - Fixed glGetTransformFeedbackVarying params <li>16/04/10 - Yar - Added Graphics Remedy's Extensions <li>28/03/10 - DanB - Added missing OpenGL 3.1/3.2 function lookups + added bindless graphics extensions <li>18/03/10 - Yar - Added more GLX extensions (thanks to Rustam Asmandiarov aka Predator) <li>12/03/10 - DanB - OpenGL 3.3/4.0 support (new ARB extensions), removed _ARB suffix from functions/procedures in GL_ARB_draw_buffers_blend + GL_ARB_sample_shading <li>04/03/10 - DanB - Organised core into relevant + deprecated sections, fixed a couple of function params + misc changes. <li>12/02/10 - Yar - Added GL_AMD_vertex_shader_tessellator <li>07/02/10 - Yar - Added GL_NV_primitive_restart <li>21/01/10 - DaStr - Bugfixed wglChoosePixelFormatARB() and wglCreatePbufferARB() parameters <li>07/01/10 - DaStr - Added WGL_COLOR_SAMPLES_NV (thanks YarUndeoaker) <li>25/12/09 - DaStr - Added GL_NV_copy_image, GL_LUMINANCE_INTEGER, GL_LUMINANCE_ALPHA_INTEGER extentions and constants Re-added $region declarations (thanks YarUndeoaker) <li>13/12/09 - DaStr - Added missing stdcall/cdecl modifiers <li>25/10/09 - DaStr - Added some texture compression extensions and updated glTransformFeedbackVaryings()(thanks YarUndeoaker) <li>28/09/09 - DaStr - Added some NVidia-specific extensions (thanks YarUndeoaker) <li>30/08/09 - DanB - GLsync changed to NativeInt, fixes to glBindBufferRange calls <li>14/08/09 - DanB - Added missing GL_ARB_framebuffer_object extension check + fixed typo <li>04/08/09 - DanB - OpenGL 3.1/3.2 support + new ARB extensions added <li>28/07/09 - DaStr - Added GL_GEOMETRY_PROGRAM_NV and related extensions <li>20/01/08 - DanB - Fix due to Delphi6 not containing UInt64 <li>05/10/08 - DanB - Moved error handling code here from GLContext.pas OpenGL 3.0 support, new core features + ARB extensions <li>23/03/08 - DanB - Added more Vendor/EXT extensions <li>17/03/08 - mrqzzz - uncommented some constants "GL_NORMAL_MAP_EXT,..." to keep compatibility with dws2OpenGL1x. <li>16/03/08 - DanB - Major rewrite of unit, including: OpenGL 1.3, 1.4, 1.5, 2.0, 2.1 support. removed TRCOptions (not used). moved MRT_BUFFERS constant to GLContext.pas (isn't core openGL). several new ARB extensions added. several new Vendor/EXT exensions added. new function IsOpenGLVersionMet added. restructured unit so extensions are in numerical order. <li>17/06/07 - LC - Added GL_ARB_pixel_buffer_object, GL_EXT_pixel_buffer_object <li>22/03/07 - DaStr - Removed GetTextureRectangle (had many useless checks) <li>16/03/07 - DaStr - Dropped Kylix support in favor of FPC (thanks Burkhard Carstens) (BugTracekrID=1681585) <li>09/03/07 - DaStr - Added GL_ARB_draw_buffers (thanks riz) <li>03/03/07 - DaStr - Added GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT <li>02/03/07 - DaStr - Added GL_[ARB/EXT]_texture_rectangle Added GetTextureRectangle <li>10/01/07 - LC - Added GL_EXT_framebuffer_object <li>11/09/06 - NC - Added GL_ARB_texture_float, GL_ARB_texture_non_power_of_two <li>13/10/04 - NC - Added GL_ATI_draw_buffers <li>08/10/04 - LR - Added const in the prototype of the following function for compatibility : TGLUTessCombineProc, TGLUTessCombineDataProc, gluPickMatrix gluProject, gluUnProject, gluTessVertex, gluLoadSamplingMatrices <li>04/10/04 - NC - Added GL_ATI_texture_float, WGL_ATI_pixel_format_float, WGL_NV_float_buffer, GL_NV_float_buffer <li>08/07/04 - LR - Change case for Linux <li>05/07/04 - LR - Corrections for Linux. Now glX function are directly load by external action (like for Windows). So i suppress the function LoadLinuxOpenGL. <li>28/06/04 - LR - Removed ..\ from the GLScene.inc <li>24/06/04 - SG - Added GL_ARB_fragment_program <li>17/05/04 - EG - Dropped EXT_vertex_array (assumed as standard) <li>06/04/04 - EG - Added GL_ARB_shader_objects, GL_ARB_vertex_shader and GL_ARB_fragment_shader, dropped a few oldies <li>13/02/04 - EG - Added GL_NV_texture_rectangle <li>18/11/03 - EG - Fixed binding of core extensions, added GL_ARB_depth_texture and GL_ARB_shadow support <li>20/09/03 - EG - Added GL_NV_occlusion_query, dropped some more oldies <li>09/09/03 - EG - Added GL_ARB_vertex_buffer_object, dropped some oldies <li>04/09/03 - EG - Added GL_ARB_vertex_program <li>23/07/03 - EG - Creation from OpenGL12.pas "morph": classic OpenGL calls made static, obsolete/rare extensions support dropped </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EOpenGLError |

Functions and Procedures

procedure glBindTexture(target: TGLEnum; texture: TGLuint); stdcall; external opengl32;
procedure glBlendFunc(sfactor: TGLEnum; dfactor: TGLEnum); stdcall; external opengl32;
procedure glClear(mask: TGLbitfield); stdcall; external opengl32;
procedure glClearColor(red, green, blue, alpha: TGLclampf); stdcall; external opengl32;
procedure glClearDepth(depth: TGLclampd); stdcall; external opengl32;
procedure glClearStencil(s: TGLint ); stdcall; external opengl32;
procedure glColorMask(red, green, blue, alpha: TGLboolean); stdcall; external opengl32;
procedure glCopyTexImage1D(target: TGLEnum; level: TGLint; internalFormat: TGLEnum; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall; external opengl32;
procedure glCopyTexImage2D(target: TGLEnum; level: TGLint; internalFormat: TGLEnum; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall; external opengl32;
procedure glCopyTexSubImage1D(target: TGLEnum; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall; external opengl32;
procedure glCopyTexSubImage2D(target: TGLEnum; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;
procedure glCullFace(mode: TGLEnum); stdcall; external opengl32;
procedure glDeleteTextures(n: TGLsizei; textures: PGLuint); stdcall; external opengl32;
procedure glDepthFunc(func: TGLEnum); stdcall; external opengl32;
procedure glDepthMask(flag: TGLboolean); stdcall; external opengl32;
procedure glDepthRange(zNear, zFar: TGLclampd); stdcall; external opengl32;
procedure glDisable(cap: TGLEnum); stdcall; external opengl32;
procedure glDrawArrays(mode: TGLEnum; first: TGLint; count: TGLsizei); stdcall; external opengl32;
procedure glDrawBuffer(mode: TGLEnum); stdcall; external opengl32;
procedure glDrawElements(mode: TGLEnum; count: TGLsizei; atype: TGLEnum; indices: Pointer); stdcall; external opengl32;
procedure glEnable(cap: TGLEnum); stdcall; external opengl32;
procedure glFinish; stdcall; external opengl32;
procedure glFlush; stdcall; external opengl32;
procedure glFrontFace(mode: TGLEnum); stdcall; external opengl32;
procedure glGenTextures(n: TGLsizei; textures: PGLuint); stdcall; external opengl32;
procedure glGetBooleanv(pname: TGLEnum; params: PGLboolean); stdcall; external opengl32;
procedure glGetDoublev(pname: TGLEnum; params: PGLdouble); stdcall; external opengl32;
function glGetError: TGLuint; stdcall; external opengl32;
procedure glGetFloatv(pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glGetIntegerv(pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glGetPointerv(pname: TGLEnum; var params); stdcall; external opengl32;
function glGetString(name: TGLEnum): PGLChar; stdcall; external opengl32;
procedure glGetTexImage(target: TGLEnum; level: TGLint; format, atype: TGLEnum; pixels: Pointer); stdcall; external opengl32;
procedure glGetTexLevelParameterfv(target: TGLEnum; level: TGLint; pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glGetTexLevelParameteriv(target: TGLEnum; level: TGLint; pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glGetTexParameterfv(target, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glGetTexParameteriv(target, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glHint(target, mode: TGLEnum); stdcall; external opengl32;
function glIsEnabled(cap: TGLEnum): TGLboolean; stdcall; external opengl32;
function glIsTexture(texture: TGLuint): TGLboolean; stdcall; external opengl32;
procedure glLineWidth(width: TGLfloat); stdcall; external opengl32;
procedure glLogicOp(opcode: TGLEnum); stdcall; external opengl32;
procedure glPixelStoref(pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glPixelStorei(pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glPointSize(size: TGLfloat); stdcall; external opengl32;
procedure glPolygonMode(face, mode: TGLEnum); stdcall; external opengl32;
procedure glPolygonOffset(factor, units: TGLfloat); stdcall; external opengl32;
procedure glReadBuffer(mode: TGLEnum); stdcall; external opengl32;
procedure glReadPixels(x, y: TGLint; width, height: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall; external opengl32;
procedure glScissor(x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;
procedure glStencilFunc(func: TGLEnum; ref: TGLint; mask: TGLuint); stdcall; external opengl32;
procedure glStencilMask(mask: TGLuint); stdcall; external opengl32;
procedure glStencilOp(fail, zfail, zpass: TGLEnum); stdcall; external opengl32;
procedure glTexImage1D(target: TGLEnum; level, internalformat: TGLint; width: TGLsizei; border: TGLint; format, atype: TGLEnum; pixels: Pointer); stdcall; external opengl32;
procedure glTexImage2D(target: TGLEnum; level, internalformat: TGLint; width, height: TGLsizei; border: TGLint; format, atype: TGLEnum; Pixels:Pointer); stdcall; external opengl32;
procedure glTexParameterf(target, pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glTexParameterfv(target, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glTexParameteri(target, pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glTexParameteriv(target, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glTexSubImage1D(target: TGLEnum; level, xoffset: TGLint; width: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall; external opengl32;
procedure glTexSubImage2D(target: TGLEnum; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall; external opengl32;
procedure glViewport(x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;
procedure glAccum(op: TGLuint; value: TGLfloat); stdcall; external opengl32;
procedure glAlphaFunc(func: TGLEnum; ref: TGLclampf); stdcall; external opengl32;
function glAreTexturesResident(n: TGLsizei; Textures: PGLuint; residences: PGLboolean): TGLboolean; stdcall; external opengl32;
procedure glArrayElement(i: TGLint); stdcall; external opengl32;
procedure glBegin(mode: TGLEnum); stdcall; external opengl32;
procedure glBitmap(width: TGLsizei; height: TGLsizei; xorig, yorig: TGLfloat; xmove: TGLfloat; ymove: TGLfloat; bitmap: Pointer); stdcall; external opengl32;
procedure glCallList(list: TGLuint); stdcall; external opengl32;
procedure glCallLists(n: TGLsizei; atype: TGLEnum; lists: Pointer); stdcall; external opengl32;
procedure glClearAccum(red, green, blue, alpha: TGLfloat); stdcall; external opengl32;
procedure glClearIndex(c: TGLfloat); stdcall; external opengl32;
procedure glClipPlane(plane: TGLEnum; equation: PGLdouble); stdcall; external opengl32;
procedure glColor3b(red, green, blue: TGLbyte); stdcall; external opengl32;
procedure glColor3bv(v: PGLbyte); stdcall; external opengl32;
procedure glColor3d(red, green, blue: TGLdouble); stdcall; external opengl32;
procedure glColor3dv(v: PGLdouble); stdcall; external opengl32;
procedure glColor3f(red, green, blue: TGLfloat); stdcall; external opengl32;
procedure glColor3fv(v: PGLfloat); stdcall; external opengl32;
procedure glColor3i(red, green, blue: TGLint); stdcall; external opengl32;
procedure glColor3iv(v: PGLint); stdcall; external opengl32;
procedure glColor3s(red, green, blue: TGLshort); stdcall; external opengl32;
procedure glColor3sv(v: PGLshort); stdcall; external opengl32;
procedure glColor3ub(red, green, blue: TGLubyte); stdcall; external opengl32;
procedure glColor3ubv(v: PGLubyte); stdcall; external opengl32;
procedure glColor3ui(red, green, blue: TGLuint); stdcall; external opengl32;
procedure glColor3uiv(v: PGLuint); stdcall; external opengl32;
procedure glColor3us(red, green, blue: TGLushort); stdcall; external opengl32;
procedure glColor3usv(v: PGLushort); stdcall; external opengl32;
procedure glColor4b(red, green, blue, alpha: TGLbyte); stdcall; external opengl32;
procedure glColor4bv(v: PGLbyte); stdcall; external opengl32;
procedure glColor4d(red, green, blue, alpha: TGLdouble ); stdcall; external opengl32;
procedure glColor4dv(v: PGLdouble); stdcall; external opengl32;
procedure glColor4f(red, green, blue, alpha: TGLfloat); stdcall; external opengl32;
procedure glColor4fv(v: PGLfloat); stdcall; external opengl32;
procedure glColor4i(red, green, blue, alpha: TGLint); stdcall; external opengl32;
procedure glColor4iv(v: PGLint); stdcall; external opengl32;
procedure glColor4s(red, green, blue, alpha: TGLshort); stdcall; external opengl32;
procedure glColor4sv(v: TGLshort); stdcall; external opengl32;
procedure glColor4ub(red, green, blue, alpha: TGLubyte); stdcall; external opengl32;
procedure glColor4ubv(v: PGLubyte); stdcall; external opengl32;
procedure glColor4ui(red, green, blue, alpha: TGLuint); stdcall; external opengl32;
procedure glColor4uiv(v: PGLuint); stdcall; external opengl32;
procedure glColor4us(red, green, blue, alpha: TGLushort); stdcall; external opengl32;
procedure glColor4usv(v: PGLushort); stdcall; external opengl32;
procedure glColorMaterial(face: TGLEnum; mode: TGLEnum); stdcall; external opengl32;
procedure glColorPointer(size: TGLint; atype: TGLEnum; stride: TGLsizei; data: pointer); stdcall; external opengl32;
procedure glCopyPixels(x, y: TGLint; width, height: TGLsizei; atype: TGLEnum); stdcall; external opengl32;
procedure glDeleteLists(list: TGLuint; range: TGLsizei); stdcall; external opengl32;
procedure glDisableClientState(aarray: TGLEnum); stdcall; external opengl32;
procedure glDrawPixels(width, height: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall; external opengl32;
procedure glEdgeFlag(flag: TGLboolean); stdcall; external opengl32;
procedure glEdgeFlagPointer(stride: TGLsizei; data: pointer); stdcall; external opengl32;
procedure glEdgeFlagv(flag: PGLboolean); stdcall; external opengl32;
procedure glEnableClientState(aarray: TGLEnum); stdcall; external opengl32;
procedure glEnd; stdcall; external opengl32;
procedure glEndList; stdcall; external opengl32;
procedure glEvalCoord1d(u: TGLdouble); stdcall; external opengl32;
procedure glEvalCoord1dv(u: PGLdouble); stdcall; external opengl32;
procedure glEvalCoord1f(u: TGLfloat); stdcall; external opengl32;
procedure glEvalCoord1fv(u: PGLfloat); stdcall; external opengl32;
procedure glEvalCoord2d(u: TGLdouble; v: TGLdouble); stdcall; external opengl32;
procedure glEvalCoord2dv(u: PGLdouble); stdcall; external opengl32;
procedure glEvalCoord2f(u, v: TGLfloat); stdcall; external opengl32;
procedure glEvalCoord2fv(u: PGLfloat); stdcall; external opengl32;
procedure glEvalMesh1(mode: TGLEnum; i1, i2: TGLint); stdcall; external opengl32;
procedure glEvalMesh2(mode: TGLEnum; i1, i2, j1, j2: TGLint); stdcall; external opengl32;
procedure glEvalPoint1(i: TGLint); stdcall; external opengl32;
procedure glEvalPoint2(i, j: TGLint); stdcall; external opengl32;
procedure glFeedbackBuffer(size: TGLsizei; atype: TGLEnum; buffer: PGLfloat); stdcall; external opengl32;
procedure glFogf(pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glFogfv(pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glFogi(pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glFogiv(pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glFrustum(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall; external opengl32;
function glGenLists(range: TGLsizei): TGLuint; stdcall; external opengl32;
procedure glGetClipPlane(plane: TGLEnum; equation: PGLdouble); stdcall; external opengl32;
procedure glGetLightfv(light, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glGetLightiv(light, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glGetMapdv(target, query: TGLEnum; v: PGLdouble); stdcall; external opengl32;
procedure glGetMapfv(target, query: TGLEnum; v: PGLfloat); stdcall; external opengl32;
procedure glGetMapiv(target, query: TGLEnum; v: PGLint); stdcall; external opengl32;
procedure glGetMaterialfv(face, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glGetMaterialiv(face, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glGetPixelMapfv(map: TGLEnum; values: PGLfloat); stdcall; external opengl32;
procedure glGetPixelMapuiv(map: TGLEnum; values: PGLuint); stdcall; external opengl32;
procedure glGetPixelMapusv(map: TGLEnum; values: PGLushort); stdcall; external opengl32;
procedure glGetPolygonStipple(mask: PGLubyte); stdcall; external opengl32;
procedure glGetTexEnvfv(target, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glGetTexEnviv(target, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glGetTexGendv(coord, pname: TGLEnum; params: PGLdouble); stdcall; external opengl32;
procedure glGetTexGenfv(coord, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glGetTexGeniv(coord, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glIndexMask(mask: TGLuint); stdcall; external opengl32;
procedure glIndexPointer(atype: TGLEnum; stride: TGLsizei; data: pointer); stdcall; external opengl32;
procedure glIndexd(c: TGLdouble); stdcall; external opengl32;
procedure glIndexdv(c: PGLdouble); stdcall; external opengl32;
procedure glIndexf(c: TGLfloat); stdcall; external opengl32;
procedure glIndexfv(c: PGLfloat); stdcall; external opengl32;
procedure glIndexi(c: TGLint); stdcall; external opengl32;
procedure glIndexiv(c: PGLint); stdcall; external opengl32;
procedure glIndexs(c: TGLshort); stdcall; external opengl32;
procedure glIndexsv(c: PGLshort); stdcall; external opengl32;
procedure glIndexub(c: TGLubyte); stdcall; external opengl32;
procedure glIndexubv(c: PGLubyte); stdcall; external opengl32;
procedure glInitNames; stdcall; external opengl32;
procedure glInterleavedArrays(format: TGLEnum; stride: TGLsizei; data: pointer); stdcall; external opengl32;
function glIsList(list: TGLuint): TGLboolean; stdcall; external opengl32;
procedure glLightModelf(pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glLightModelfv(pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glLightModeli(pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glLightModeliv(pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glLightf(light, pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glLightfv(light, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glLighti(light, pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glLightiv(light, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glLineStipple(factor: TGLint; pattern: TGLushort); stdcall; external opengl32;
procedure glListBase(base: TGLuint); stdcall; external opengl32;
procedure glLoadIdentity; stdcall; external opengl32;
procedure glLoadMatrixd(m: PGLdouble); stdcall; external opengl32;
procedure glLoadMatrixf(m: PGLfloat); stdcall; external opengl32;
procedure glLoadName(name: TGLuint); stdcall; external opengl32;
procedure glMap1d(target: TGLEnum; u1, u2: TGLdouble; stride, order: TGLint; points: PGLdouble); stdcall; external opengl32;
procedure glMap1f(target: TGLEnum; u1, u2: TGLfloat; stride, order: TGLint; points: PGLfloat); stdcall; external opengl32;
procedure glMap2d(target: TGLEnum; u1, u2: TGLdouble; ustride, uorder: TGLint; v1, v2: TGLdouble; vstride, vorder: TGLint; points: PGLdouble); stdcall; external opengl32;
procedure glMap2f(target: TGLEnum; u1, u2: TGLfloat; ustride, uorder: TGLint; v1, v2: TGLfloat; vstride, vorder: TGLint; points: PGLfloat); stdcall; external opengl32;
procedure glMapGrid1d(un: TGLint; u1, u2: TGLdouble); stdcall; external opengl32;
procedure glMapGrid1f(un: TGLint; u1, u2: TGLfloat); stdcall; external opengl32;
procedure glMapGrid2d(un: TGLint; u1, u2: TGLdouble; vn: TGLint; v1, v2: TGLdouble); stdcall; external opengl32;
procedure glMapGrid2f(un: TGLint; u1, u2: TGLfloat; vn: TGLint; v1, v2: TGLfloat); stdcall; external opengl32;
procedure glMaterialf(face, pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glMaterialfv(face, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glMateriali(face, pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glMaterialiv(face, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glMatrixMode(mode: TGLEnum); stdcall; external opengl32;
procedure glMultMatrixd(m: PGLdouble); stdcall; external opengl32;
procedure glMultMatrixf(m: PGLfloat); stdcall; external opengl32;
procedure glNewList(list: TGLuint; mode: TGLEnum); stdcall; external opengl32;
procedure glNormal3b(nx, ny, nz: TGLbyte); stdcall; external opengl32;
procedure glNormal3bv(v: PGLbyte); stdcall; external opengl32;
procedure glNormal3d(nx, ny, nz: TGLdouble); stdcall; external opengl32;
procedure glNormal3dv(v: PGLdouble); stdcall; external opengl32;
procedure glNormal3f(nx, ny, nz: TGLfloat); stdcall; external opengl32;
procedure glNormal3fv(v: PGLfloat); stdcall; external opengl32;
procedure glNormal3i(nx, ny, nz: TGLint); stdcall; external opengl32;
procedure glNormal3iv(v: PGLint); stdcall; external opengl32;
procedure glNormal3s(nx, ny, nz: TGLshort); stdcall; external opengl32;
procedure glNormal3sv(v: PGLshort); stdcall; external opengl32;
procedure glNormalPointer(atype: TGLEnum; stride: TGLsizei; data: pointer); stdcall; external opengl32;
procedure glOrtho(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall; external opengl32;
procedure glPassThrough(token: TGLfloat); stdcall; external opengl32;
procedure glPixelMapfv(map: TGLEnum; mapsize: TGLsizei; values: PGLfloat); stdcall; external opengl32;
procedure glPixelMapuiv(map: TGLEnum; mapsize: TGLsizei; values: PGLuint); stdcall; external opengl32;
procedure glPixelMapusv(map: TGLEnum; mapsize: TGLsizei; values: PGLushort); stdcall; external opengl32;
procedure glPixelTransferf(pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glPixelTransferi(pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glPixelZoom(xfactor, yfactor: TGLfloat); stdcall; external opengl32;
procedure glPolygonStipple(mask: PGLubyte); stdcall; external opengl32;
procedure glPopAttrib; stdcall; external opengl32;
procedure glPopClientAttrib; stdcall; external opengl32;
procedure glPopMatrix; stdcall; external opengl32;
procedure glPopName; stdcall; external opengl32;
procedure glPrioritizeTextures(n: TGLsizei; textures: PGLuint; priorities: PGLclampf); stdcall; external opengl32;
procedure glPushAttrib(mask: TGLbitfield); stdcall; external opengl32;
procedure glPushClientAttrib(mask: TGLbitfield); stdcall; external opengl32;
procedure glPushMatrix; stdcall; external opengl32;
procedure glPushName(name: TGLuint); stdcall; external opengl32;
procedure glRasterPos2d(x, y: TGLdouble); stdcall; external opengl32;
procedure glRasterPos2dv(v: PGLdouble); stdcall; external opengl32;
procedure glRasterPos2f(x, y: TGLfloat); stdcall; external opengl32;
procedure glRasterPos2fv(v: PGLfloat); stdcall; external opengl32;
procedure glRasterPos2i(x, y: TGLint); stdcall; external opengl32;
procedure glRasterPos2iv(v: PGLint); stdcall; external opengl32;
procedure glRasterPos2s(x, y: PGLshort); stdcall; external opengl32;
procedure glRasterPos2sv(v: PGLshort); stdcall; external opengl32;
procedure glRasterPos3d(x, y, z: TGLdouble); stdcall; external opengl32;
procedure glRasterPos3dv(v: PGLdouble); stdcall; external opengl32;
procedure glRasterPos3f(x, y, z: TGLfloat); stdcall; external opengl32;
procedure glRasterPos3fv(v: PGLfloat); stdcall; external opengl32;
procedure glRasterPos3i(x, y, z: TGLint); stdcall; external opengl32;
procedure glRasterPos3iv(v: PGLint); stdcall; external opengl32;
procedure glRasterPos3s(x, y, z: TGLshort); stdcall; external opengl32;
procedure glRasterPos3sv(v: PGLshort); stdcall; external opengl32;
procedure glRasterPos4d(x, y, z, w: TGLdouble); stdcall; external opengl32;
procedure glRasterPos4dv(v: PGLdouble); stdcall; external opengl32;
procedure glRasterPos4f(x, y, z, w: TGLfloat); stdcall; external opengl32;
procedure glRasterPos4fv(v: PGLfloat); stdcall; external opengl32;
procedure glRasterPos4i(x, y, z, w: TGLint); stdcall; external opengl32;
procedure glRasterPos4iv(v: PGLint); stdcall; external opengl32;
procedure glRasterPos4s(x, y, z, w: TGLshort); stdcall; external opengl32;
procedure glRasterPos4sv(v: PGLshort); stdcall; external opengl32;
procedure glRectd(x1, y1, x2, y2: TGLdouble); stdcall; external opengl32;
procedure glRectdv(v1, v2: PGLdouble); stdcall; external opengl32;
procedure glRectf(x1, y1, x2, y2: TGLfloat); stdcall; external opengl32;
procedure glRectfv(v1, v2: PGLfloat); stdcall; external opengl32;
procedure glRecti(x1, y1, x2, y2: TGLint); stdcall; external opengl32;
procedure glRectiv(v1, v2: PGLint); stdcall; external opengl32;
procedure glRects(x1, y1, x2, y2: TGLshort); stdcall; external opengl32;
procedure glRectsv(v1, v2: PGLshort); stdcall; external opengl32;
function glRenderMode(mode: TGLEnum): TGLint; stdcall; external opengl32;
procedure glRotated(angle, x, y, z: TGLdouble); stdcall; external opengl32;
procedure glRotatef(angle, x, y, z: TGLfloat); stdcall; external opengl32;
procedure glScaled(x, y, z: TGLdouble); stdcall; external opengl32;
procedure glScalef(x, y, z: TGLfloat); stdcall; external opengl32;
procedure glSelectBuffer(size: TGLsizei; buffer: PGLuint); stdcall; external opengl32;
procedure glShadeModel(mode: TGLEnum); stdcall; external opengl32;
procedure glTexCoord1d(s: TGLdouble); stdcall; external opengl32;
procedure glTexCoord1dv(v: PGLdouble); stdcall; external opengl32;
procedure glTexCoord1f(s: TGLfloat); stdcall; external opengl32;
procedure glTexCoord1fv(v: PGLfloat); stdcall; external opengl32;
procedure glTexCoord1i(s: TGLint); stdcall; external opengl32;
procedure glTexCoord1iv(v: PGLint); stdcall; external opengl32;
procedure glTexCoord1s(s: TGLshort); stdcall; external opengl32;
procedure glTexCoord1sv(v: PGLshort); stdcall; external opengl32;
procedure glTexCoord2d(s, t: TGLdouble); stdcall; external opengl32;
procedure glTexCoord2dv(v: PGLdouble); stdcall; external opengl32;
procedure glTexCoord2f(s, t: TGLfloat); stdcall; external opengl32;
procedure glTexCoord2fv(v: PGLfloat); stdcall; external opengl32;
procedure glTexCoord2i(s, t: TGLint); stdcall; external opengl32;
procedure glTexCoord2iv(v: PGLint); stdcall; external opengl32;
procedure glTexCoord2s(s, t: TGLshort); stdcall; external opengl32;
procedure glTexCoord2sv(v: PGLshort); stdcall; external opengl32;
procedure glTexCoord3d(s, t, r: TGLdouble); stdcall; external opengl32;
procedure glTexCoord3dv(v: PGLdouble); stdcall; external opengl32;
procedure glTexCoord3f(s, t, r: TGLfloat); stdcall; external opengl32;
procedure glTexCoord3fv(v: PGLfloat); stdcall; external opengl32;
procedure glTexCoord3i(s, t, r: TGLint); stdcall; external opengl32;
procedure glTexCoord3iv(v: PGLint); stdcall; external opengl32;
procedure glTexCoord3s(s, t, r: TGLshort); stdcall; external opengl32;
procedure glTexCoord3sv(v: PGLshort); stdcall; external opengl32;
procedure glTexCoord4d(s, t, r, q: TGLdouble); stdcall; external opengl32;
procedure glTexCoord4dv(v: PGLdouble); stdcall; external opengl32;
procedure glTexCoord4f(s, t, r, q: TGLfloat); stdcall; external opengl32;
procedure glTexCoord4fv(v: PGLfloat); stdcall; external opengl32;
procedure glTexCoord4i(s, t, r, q: TGLint); stdcall; external opengl32;
procedure glTexCoord4iv(v: PGLint); stdcall; external opengl32;
procedure glTexCoord4s(s, t, r, q: TGLshort); stdcall; external opengl32;
procedure glTexCoord4sv(v: PGLshort); stdcall; external opengl32;
procedure glTexCoordPointer(size: TGLint; atype: TGLEnum; stride: TGLsizei; data: pointer); stdcall; external opengl32;
procedure glTexEnvf(target, pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glTexEnvfv(target, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glTexEnvi(target, pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glTexEnviv(target, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glTexGend(coord, pname: TGLEnum; param: TGLdouble); stdcall; external opengl32;
procedure glTexGendv(coord, pname: TGLEnum; params: PGLdouble); stdcall; external opengl32;
procedure glTexGenf(coord, pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glTexGenfv(coord, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glTexGeni(coord, pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glTexGeniv(coord, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glTranslated(x, y, z: TGLdouble); stdcall; external opengl32;
procedure glTranslatef(x, y, z: TGLfloat); stdcall; external opengl32;
procedure glVertex2d(x, y: TGLdouble); stdcall; external opengl32;
procedure glVertex2dv(v: PGLdouble); stdcall; external opengl32;
procedure glVertex2f(x, y: TGLfloat); stdcall; external opengl32;
procedure glVertex2fv(v: PGLfloat); stdcall; external opengl32;
procedure glVertex2i(x, y: TGLint); stdcall; external opengl32;
procedure glVertex2iv(v: PGLint); stdcall; external opengl32;
procedure glVertex2s(x, y: TGLshort); stdcall; external opengl32;
procedure glVertex2sv(v: PGLshort); stdcall; external opengl32;
procedure glVertex3d(x, y, z: TGLdouble); stdcall; external opengl32;
procedure glVertex3dv(v: PGLdouble); stdcall; external opengl32;
procedure glVertex3f(x, y, z: TGLfloat); stdcall; external opengl32;
procedure glVertex3fv(v: PGLfloat); stdcall; external opengl32;
procedure glVertex3i(x, y, z: TGLint); stdcall; external opengl32;
procedure glVertex3iv(v: PGLint); stdcall; external opengl32;
procedure glVertex3s(x, y, z: TGLshort); stdcall; external opengl32;
procedure glVertex3sv(v: PGLshort); stdcall; external opengl32;
procedure glVertex4d(x, y, z, w: TGLdouble); stdcall; external opengl32;
procedure glVertex4dv(v: PGLdouble); stdcall; external opengl32;
procedure glVertex4f(x, y, z, w: TGLfloat); stdcall; external opengl32;
procedure glVertex4fv(v: PGLfloat); stdcall; external opengl32;
procedure glVertex4i(x, y, z, w: TGLint); stdcall; external opengl32;
procedure glVertex4iv(v: PGLint); stdcall; external opengl32;
procedure glVertex4s(x, y, z, w: TGLshort); stdcall; external opengl32;
procedure glVertex4sv(v: PGLshort); stdcall; external opengl32;
procedure glVertexPointer(size: TGLint; atype: TGLEnum; stride: TGLsizei; data: pointer); stdcall; external opengl32;
function gluErrorString(errCode: TGLEnum): PGLChar; stdcall; external glu32;
function gluGetString(name: TGLEnum): PGLChar; stdcall; external glu32;
procedure gluOrtho2D(left, right, bottom, top: TGLdouble); stdcall; external glu32;
procedure gluPerspective(fovy, aspect, zNear, zFar: TGLdouble); stdcall; external glu32;
procedure gluPickMatrix(x, y, width, height: TGLdouble; const viewport: TVector4i); stdcall; external glu32;
procedure gluLookAt(eyex, eyey, eyez, centerx, centery, centerz, upx, upy, upz: TGLdouble); stdcall; external glu32;
function gluProject(objx, objy, objz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const viewport: TVector4i; winx, winy, winz: PGLdouble): TGLint; stdcall; external glu32;
function gluUnProject(winx, winy, winz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const viewport: TVector4i; objx, objy, objz: PGLdouble): TGLint; stdcall; external glu32;
function gluScaleImage(format: TGLEnum; widthin, heightin: TGLint; typein: TGLEnum; datain: Pointer; widthout, heightout: TGLint; typeout: TGLEnum; dataout: Pointer): TGLint; stdcall; external glu32;
function gluBuild1DMipmaps(target: TGLEnum; components, width: TGLint; format, atype: TGLEnum; data: Pointer): TGLint; stdcall; external glu32;
function gluBuild2DMipmaps(target: TGLEnum; components, width, height: TGLint; format, atype: TGLEnum; data: Pointer): TGLint; stdcall; external glu32;
function gluNewQuadric: PGLUquadric; stdcall; external glu32;
procedure gluDeleteQuadric(state: PGLUquadric); stdcall; external glu32;
procedure gluQuadricNormals(quadObject: PGLUquadric; normals: TGLEnum); stdcall; external glu32;
procedure gluQuadricTexture(quadObject: PGLUquadric; textureCoords: TGLboolean); stdcall; external glu32;
procedure gluQuadricOrientation(quadObject: PGLUquadric; orientation: TGLEnum); stdcall; external glu32;
procedure gluQuadricDrawStyle(quadObject: PGLUquadric; drawStyle: TGLEnum); stdcall; external glu32;
procedure gluCylinder(quadObject: PGLUquadric; baseRadius, topRadius, height: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;
procedure gluDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint); stdcall; external glu32;
procedure gluPartialDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint; startAngle, sweepAngle: TGLdouble); stdcall; external glu32;
procedure gluSphere(quadObject: PGLUquadric; radius: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;
procedure gluQuadricCallback(quadObject: PGLUquadric; which: TGLEnum; fn: TGLUQuadricErrorProc); stdcall; external glu32;
function gluNewTess: PGLUtesselator; stdcall; external glu32;
procedure gluDeleteTess(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessBeginPolygon(tess: PGLUtesselator; polygon_data: Pointer); stdcall; external glu32;
procedure gluTessBeginContour(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessVertex(tess: PGLUtesselator; const coords: TVector3d; data: Pointer); stdcall; external glu32;
procedure gluTessEndContour(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessEndPolygon(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessProperty(tess: PGLUtesselator; which: TGLEnum; value: TGLdouble); stdcall; external glu32;
procedure gluTessNormal(tess: PGLUtesselator; x, y, z: TGLdouble); stdcall; external glu32;
procedure gluTessCallback(tess: PGLUtesselator; which: TGLEnum; fn: Pointer); stdcall; external glu32;
procedure gluGetTessProperty(tess: PGLUtesselator; which: TGLEnum; value: PGLdouble); stdcall; external glu32;
function gluNewNurbsRenderer: PGLUnurbs; stdcall; external glu32;
procedure gluDeleteNurbsRenderer(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginSurface(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginCurve(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndCurve(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndSurface(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginTrim(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndTrim(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluPwlCurve(nobj: PGLUnurbs; count: TGLint; points: PGLfloat; stride: TGLint; atype: TGLEnum); stdcall; external glu32;
procedure gluNurbsCurve(nobj: PGLUnurbs; nknots: TGLint; knot: PGLfloat; stride: TGLint; ctlarray: PGLfloat; order: TGLint; atype: TGLEnum); stdcall; external glu32;
procedure gluNurbsSurface(nobj: PGLUnurbs; sknot_count: TGLint; sknot: PGLfloat; tknot_count: TGLint; tknot: PGLfloat; s_stride, t_stride: TGLint; ctlarray: PGLfloat; sorder, torder: TGLint; atype: TGLEnum); stdcall; external glu32;
procedure gluLoadSamplingMatrices(nobj: PGLUnurbs; const modelMatrix: TMatrix4f; const projMatrix: TMatrix4f; const viewport: TVector4i); stdcall; external glu32;
procedure gluNurbsProperty(nobj: PGLUnurbs; aproperty: TGLEnum; value: TGLfloat); stdcall; external glu32;
procedure gluGetNurbsProperty(nobj: PGLUnurbs; aproperty: TGLEnum; value: PGLfloat); stdcall; external glu32;
procedure gluNurbsCallback(nobj: PGLUnurbs; which: TGLEnum; fn: TGLUNurbsErrorProc); stdcall; external glu32;
procedure gluBeginPolygon(tess: PGLUtesselator); stdcall; external glu32;
procedure gluNextContour(tess: PGLUtesselator; atype: TGLEnum); stdcall; external glu32;
procedure gluEndPolygon(tess: PGLUtesselator); stdcall; external glu32;
function wglGetProcAddress(ProcName: PGLChar): Pointer; stdcall; external opengl32;
function wglCopyContext(p1: HGLRC; p2: HGLRC; p3: Cardinal): BOOL; stdcall; external opengl32;
function wglCreateContext(DC: HDC): HGLRC; stdcall; external opengl32;
function wglCreateLayerContext(p1: HDC; p2: Integer): HGLRC; stdcall; external opengl32;
function wglDeleteContext(p1: HGLRC): BOOL; stdcall; external opengl32;
function wglDescribeLayerPlane(p1: HDC; p2, p3: Integer; p4: Cardinal; var p5: TLayerPlaneDescriptor): BOOL; stdcall; external opengl32;
function wglGetCurrentContext: HGLRC; stdcall; external opengl32;
function wglGetCurrentDC: HDC; stdcall; external opengl32;
function wglGetLayerPaletteEntries(p1: HDC; p2, p3, p4: Integer; var pcr): Integer; stdcall; external opengl32;
function wglMakeCurrent(DC: HDC; p2: HGLRC): BOOL; stdcall; external opengl32;
function wglRealizeLayerPalette(p1: HDC; p2: Integer; p3: BOOL): BOOL; stdcall; external opengl32;
function wglSetLayerPaletteEntries(p1: HDC; p2, p3, p4: Integer; var pcr): Integer; stdcall; external opengl32;
function wglShareLists(p1, p2: HGLRC): BOOL; stdcall; external opengl32;
function wglSwapLayerBuffers(p1: HDC; p2: Cardinal): BOOL; stdcall; external opengl32;
function wglSwapMultipleBuffers(p1: UINT; const p2: PWGLSwap): DWORD; stdcall; external opengl32;
function wglUseFontBitmapsA(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;
function wglUseFontOutlinesA (p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;
function wglUseFontBitmapsW(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;
function wglUseFontOutlinesW (p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;
function wglUseFontBitmaps(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32 name 'wglUseFontBitmapsA';
function wglUseFontOutlines(p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32 name 'wglUseFontOutlinesA';
function GLLibGetProcAddress(ProcName: PGLChar): Pointer;
function GLGetProcAddress(ProcName: PGLChar): Pointer;
procedure ReadExtensions;
procedure ReadImplementationProperties;
procedure ReadWGLExtensions;
procedure ReadWGLImplementationProperties;
procedure CloseOpenGL;
function InitOpenGL : Boolean;
function InitOpenGLFromLibrary(const GLName, GLUName : String) : Boolean;
function IsOpenGLInitialized: Boolean;
procedure UnloadOpenGL;
function LoadOpenGL : Boolean;
function LoadOpenGLFromLibrary(GLName, GLUName: String): Boolean;
function IsOpenGLLoaded : Boolean;
function IsMesaGL : Boolean;
procedure TrimAndSplitVersionString(Buffer: String; var Max, Min: Integer);
function IsVersionMet(MajorVersion,MinorVersion, actualMajorVersion, actualMinorVersion:Integer): boolean;
function IsOpenGLVersionMet(MajorVersion,MinorVersion: Integer): boolean;
procedure CheckOpenGLError;
procedure ClearGLError;
procedure RaiseOpenGLError(const msg : String);

Variables

GL_VERSION_1_0: Boolean;
GL_VERSION_1_1: Boolean;
GL_VERSION_1_2: Boolean;
GL_VERSION_1_3: Boolean;
GL_VERSION_1_4: Boolean;
GL_VERSION_1_5: Boolean;
GL_VERSION_2_0: Boolean;
GL_VERSION_2_1: Boolean;
GL_VERSION_3_0: Boolean;
GL_VERSION_3_1: Boolean;
GL_VERSION_3_2: Boolean;
GL_VERSION_3_3: Boolean;
GL_VERSION_4_0: Boolean;
GL_VERSION_4_1: Boolean;
GLU_VERSION_1_1: Boolean;
GLU_VERSION_1_2: Boolean;
GLU_VERSION_1_3: Boolean;
GL_ARB_blend_func_extended: Boolean;
GL_ARB_color_buffer_float: Boolean;
GL_ARB_compatibility: Boolean;
GL_ARB_copy_buffer: Boolean;
GL_ARB_debug_output: Boolean;
GL_ARB_depth_buffer_float: Boolean;
GL_ARB_depth_clamp: Boolean;
GL_ARB_depth_texture: Boolean;
GL_ARB_draw_buffers: Boolean;
GL_ARB_draw_buffers_blend: Boolean;
GL_ARB_draw_elements_base_vertex: Boolean;
GL_ARB_draw_indirect: Boolean;
GL_ARB_draw_instanced: Boolean;
GL_ARB_ES2_compatibility: Boolean;
GL_ARB_explicit_attrib_location: Boolean;
GL_ARB_fragment_coord_conventions: Boolean;
GL_ARB_fragment_program: Boolean;
GL_ARB_fragment_program_shadow: Boolean;
GL_ARB_fragment_shader: Boolean;
GL_ARB_framebuffer_object: Boolean;
GL_ARB_framebuffer_sRGB: Boolean;
GL_ARB_geometry_shader4: Boolean;
GL_ARB_get_program_binary: Boolean;
GL_ARB_gpu_shader_fp64: Boolean;
GL_ARB_gpu_shader5: Boolean;
GL_ARB_half_float_pixel: Boolean;
GL_ARB_half_float_vertex: Boolean;
GL_ARB_imaging: Boolean;
GL_ARB_instanced_arrays: Boolean;
GL_ARB_map_buffer_range: Boolean;
GL_ARB_matrix_palette: Boolean;
GL_ARB_multisample: Boolean;
GL_ARB_multitexture: Boolean;
GL_ARB_occlusion_query: Boolean;
GL_ARB_occlusion_query2: Boolean;
GL_ARB_pixel_buffer_object: Boolean;
GL_ARB_point_parameters: Boolean;
GL_ARB_point_sprite: Boolean;
GL_ARB_provoking_vertex: Boolean;
GL_ARB_robustness: Boolean;
GL_ARB_sample_shading: Boolean;
GL_ARB_sampler_objects: Boolean;
GL_ARB_seamless_cube_map: Boolean;
GL_ARB_separate_shader_objects: Boolean;
GL_ARB_shader_bit_encoding: Boolean;
GL_ARB_shader_precision: Boolean;
GL_ARB_shader_stencil_export: Boolean;
GL_ARB_shader_subroutine: Boolean;
GL_ARB_shader_texture_lod: Boolean;
GL_ARB_shading_language_100: Boolean;
GL_ARB_shadow: Boolean;
GL_ARB_shadow_ambient: Boolean;
GL_ARB_shader_objects: Boolean;
GL_ARB_sync: Boolean;
GL_ARB_tessellation_shader: Boolean;
GL_ARB_texture_border_clamp: Boolean;
GL_ARB_texture_buffer_object: Boolean;
GL_ARB_texture_buffer_object_rgb32: Boolean;
GL_ARB_texture_compression: Boolean;
GL_ARB_texture_compression_rgtc: Boolean;
GL_ARB_texture_cube_map: Boolean;
GL_ARB_texture_cube_map_array: Boolean;
GL_ARB_texture_env_add: Boolean;
GL_ARB_texture_env_combine: Boolean;
GL_ARB_texture_env_crossbar: Boolean;
GL_ARB_texture_env_dot3: Boolean;
GL_ARB_texture_float: Boolean;
GL_ARB_texture_gather: Boolean;
GL_ARB_texture_mirrored_repeat: Boolean;
GL_ARB_texture_multisample: Boolean;
GL_ARB_texture_non_power_of_two: Boolean;
GL_ARB_texture_query_lod: Boolean;
GL_ARB_texture_rectangle: Boolean;
GL_ARB_texture_rg: Boolean;
GL_ARB_texture_rgb10_a2ui: Boolean;
GL_ARB_texture_swizzle: Boolean;
GL_ARB_timer_query: Boolean;
GL_ARB_transform_feedback2: Boolean;
GL_ARB_transform_feedback3: Boolean;
GL_ARB_transpose_matrix: Boolean;
GL_ARB_uniform_buffer_object: Boolean;
GL_ARB_vertex_array_bgra: Boolean;
GL_ARB_vertex_array_object: Boolean;
GL_ARB_vertex_attrib_64bit: Boolean;
GL_ARB_vertex_blend: Boolean;
GL_ARB_vertex_buffer_object: Boolean;
GL_ARB_vertex_program: Boolean;
GL_ARB_vertex_shader: Boolean;
GL_ARB_vertex_type_2_10_10_10_rev: Boolean;
GL_ARB_viewport_array: Boolean;
GL_ARB_window_pos: Boolean;
GL_ARB_texture_compression_bptc: Boolean;
GL_3DFX_multisample: Boolean;
GL_3DFX_tbuffer: Boolean;
GL_3DFX_texture_compression_FXT1: Boolean;
GL_ATI_draw_buffers: Boolean;
GL_ATI_texture_compression_3dc: Boolean;
GL_ATI_texture_float: Boolean;
GL_ATI_texture_mirror_once: Boolean;
GL_S3_s3tc: Boolean;
GL_EXT_abgr: Boolean;
GL_EXT_bgra: Boolean;
GL_EXT_bindable_uniform: Boolean;
GL_EXT_blend_color: Boolean;
GL_EXT_blend_equation_separate: Boolean;
GL_EXT_blend_func_separate: Boolean;
GL_EXT_blend_logic_op: Boolean;
GL_EXT_blend_minmax: Boolean;
GL_EXT_blend_subtract: Boolean;
GL_EXT_Cg_shader: Boolean;
GL_EXT_clip_volume_hint: Boolean;
GL_EXT_compiled_vertex_array: Boolean;
GL_EXT_copy_texture: Boolean;
GL_EXT_depth_bounds_test: Boolean;
GL_EXT_draw_buffers2: Boolean;
GL_EXT_draw_instanced: Boolean;
GL_EXT_draw_range_elements: Boolean;
GL_EXT_fog_coord: Boolean;
GL_EXT_framebuffer_blit: Boolean;
GL_EXT_framebuffer_multisample: Boolean;
GL_EXT_framebuffer_object: Boolean;
GL_EXT_framebuffer_sRGB: Boolean;
GL_EXT_geometry_shader4: Boolean;
GL_EXT_gpu_program_parameters: Boolean;
GL_EXT_gpu_shader4: Boolean;
GL_EXT_multi_draw_arrays: Boolean;
GL_EXT_multisample: Boolean;
GL_EXT_packed_depth_stencil: Boolean;
GL_EXT_packed_float: Boolean;
GL_EXT_packed_pixels: Boolean;
GL_EXT_paletted_texture: Boolean;
GL_EXT_pixel_buffer_object: Boolean;
GL_EXT_polygon_offset: Boolean;
GL_EXT_rescale_normal: Boolean;
GL_EXT_secondary_color: Boolean;
GL_EXT_separate_specular_color: Boolean;
GL_EXT_shadow_funcs: Boolean;
GL_EXT_shared_texture_palette: Boolean;
GL_EXT_stencil_clear_tag: Boolean;
GL_EXT_stencil_two_side: Boolean;
GL_EXT_stencil_wrap: Boolean;
GL_EXT_texture3D: Boolean;
GL_EXT_texture_array: Boolean;
GL_EXT_texture_buffer_object: Boolean;
GL_EXT_texture_compression_latc: Boolean;
GL_EXT_texture_compression_rgtc: Boolean;
GL_EXT_texture_compression_s3tc: Boolean;
GL_EXT_texture_cube_map: Boolean;
GL_EXT_texture_edge_clamp: Boolean;
GL_EXT_texture_env_add: Boolean;
GL_EXT_texture_env_combine: Boolean;
GL_EXT_texture_env_dot3: Boolean;
GL_EXT_texture_filter_anisotropic: Boolean;
GL_EXT_texture_integer: Boolean;
GL_EXT_texture_lod: Boolean;
GL_EXT_texture_lod_bias: Boolean;
GL_EXT_texture_mirror_clamp: Boolean;
GL_EXT_texture_object: Boolean;
GL_EXT_texture_rectangle: Boolean;
GL_EXT_texture_sRGB: Boolean;
GL_EXT_texture_shared_exponent: Boolean;
GL_EXT_timer_query: Boolean;
GL_EXT_transform_feedback: Boolean;
GL_EXT_vertex_array: Boolean;
GL_HP_occlusion_test: Boolean;
GL_IBM_rasterpos_clip: Boolean;
GL_KTX_buffer_region: Boolean;
GL_MESA_resize_buffers: Boolean;
GL_NV_blend_square: Boolean;
GL_NV_conditional_render: Boolean;
GL_NV_copy_image: Boolean;
GL_NV_depth_buffer_float: Boolean;
GL_NV_fence: Boolean;
GL_NV_float_buffer: Boolean;
GL_NV_fog_distance: Boolean;
GL_NV_geometry_program4: Boolean;
GL_NV_light_max_exponent: Boolean;
GL_NV_multisample_filter_hint: Boolean;
GL_NV_occlusion_query: Boolean;
GL_NV_point_sprite: Boolean;
GL_NV_primitive_restart: Boolean;
GL_NV_register_combiners: Boolean;
GL_NV_shader_buffer_load: Boolean;
GL_NV_texgen_reflection: Boolean;
GL_NV_texture_compression_vtc: Boolean;
GL_NV_texture_env_combine4: Boolean;
GL_NV_texture_rectangle: Boolean;
GL_NV_texture_shader: Boolean;
GL_NV_texture_shader2: Boolean;
GL_NV_texture_shader3: Boolean;
GL_NV_transform_feedback: Boolean;
GL_NV_vertex_array_range: Boolean;
GL_NV_vertex_array_range2: Boolean;
GL_NV_vertex_buffer_unified_memory: Boolean;
GL_NV_vertex_program: Boolean;
GL_SGI_color_matrix: Boolean;
GL_SGIS_generate_mipmap: Boolean;
GL_SGIS_multisample: Boolean;
GL_SGIS_texture_border_clamp: Boolean;
GL_SGIS_texture_color_mask: Boolean;
GL_SGIS_texture_edge_clamp: Boolean;
GL_SGIS_texture_lod: Boolean;
GL_SGIX_depth_texture: Boolean;
GL_SGIX_shadow: Boolean;
GL_SGIX_shadow_ambient: Boolean;
GL_AMD_vertex_shader_tessellator: Boolean;
GL_WIN_swap_hint: Boolean;
WGL_ARB_buffer_region: Boolean;
WGL_ARB_create_context: Boolean;
WGL_ARB_create_context_profile: Boolean;
WGL_ARB_extensions_string: Boolean;
WGL_ARB_framebuffer_sRGB: Boolean;
WGL_ARB_make_current_read: Boolean;
WGL_ARB_multisample: Boolean;
WGL_ARB_pbuffer: Boolean;
WGL_ARB_pixel_format: Boolean;
WGL_ARB_pixel_format_float: Boolean;
WGL_ARB_render_texture: Boolean;
WGL_ATI_pixel_format_float: Boolean;
WGL_EXT_framebuffer_sRGB: Boolean;
WGL_EXT_pixel_format_packed_float: Boolean;
WGL_EXT_swap_control: Boolean;
WGL_NV_gpu_affinity: Boolean;
GLX_VERSION_1_1: Boolean;
GLX_VERSION_1_2: Boolean;
GLX_VERSION_1_3: Boolean;
GLX_VERSION_1_4: Boolean;
GLX_ARB_create_context: Boolean;
GLX_ARB_create_context_profile: Boolean;
GLX_ARB_framebuffer_sRGB: Boolean;
GLX_ARB_multisample: Boolean;
GLX_EXT_framebuffer_sRGB: Boolean;
GLX_EXT_fbconfig_packed_float: Boolean;
GLX_SGIS_multisample: Boolean;
GLX_EXT_visual_info: Boolean;
GLX_SGI_swap_control: Boolean;
GLX_SGI_video_sync: Boolean;
GLX_SGI_make_current_read: Boolean;
GLX_SGIX_video_source: Boolean;
GLX_EXT_visual_rating: Boolean;
GLX_EXT_import_context: Boolean;
GLX_SGIX_fbconfig: Boolean;
GLX_SGIX_pbuffer: Boolean;
GLX_SGI_cushion: Boolean;
GLX_SGIX_video_resize: Boolean;
GLX_SGIX_dmbuffer: Boolean;
GLX_SGIX_swap_group: Boolean;
GLX_SGIX_swap_barrier: Boolean;
GLX_SGIS_blended_overlay: Boolean;
GLX_SGIS_shared_multisample: Boolean;
GLX_SUN_get_transparent_index: Boolean;
GLX_3DFX_multisample: Boolean;
GLX_MESA_copy_sub_buffer: Boolean;
GLX_MESA_pixmap_colormap: Boolean;
GLX_MESA_release_buffers: Boolean;
GLX_MESA_set_3dfx_mode: Boolean;
GLX_SGIX_visual_select_group: Boolean;
GLX_SGIX_hyperpipe: Boolean;
GL_GREMEDY_frame_terminator: Boolean;
GL_GREMEDY_string_marker: Boolean;
GLU_EXT_object_space_tess: Boolean;
GLU_EXT_nurbs_tessellator: Boolean;
GLU_EXT_Texture: Boolean;
glBlendColor: PFNGLBLENDCOLORPROC;
glBlendEquation: PFNGLBLENDEQUATIONPROC;
glDrawRangeElements: PFNGLDRAWRANGEELEMENTSPROC;
glTexImage3D: PFNGLTEXIMAGE3DPROC;
glTexSubImage3D: PFNGLTEXSUBIMAGE3DPROC;
glCopyTexSubImage3D: PFNGLCOPYTEXSUBIMAGE3DPROC;
glColorTable: PFNGLCOLORTABLEPROC;
glColorTableParameterfv: PFNGLCOLORTABLEPARAMETERFVPROC;
glColorTableParameteriv: PFNGLCOLORTABLEPARAMETERIVPROC;
glCopyColorTable: PFNGLCOPYCOLORTABLEPROC;
glGetColorTable: PFNGLGETCOLORTABLEPROC;
glGetColorTableParameterfv: PFNGLGETCOLORTABLEPARAMETERFVPROC;
glGetColorTableParameteriv: PFNGLGETCOLORTABLEPARAMETERIVPROC;
glColorSubTable: PFNGLCOLORSUBTABLEPROC;
glCopyColorSubTable: PFNGLCOPYCOLORSUBTABLEPROC;
glConvolutionFilter1D: PFNGLCONVOLUTIONFILTER1DPROC;
glConvolutionFilter2D: PFNGLCONVOLUTIONFILTER2DPROC;
glConvolutionParameterf: PFNGLCONVOLUTIONPARAMETERFPROC;
glConvolutionParameterfv: PFNGLCONVOLUTIONPARAMETERFVPROC;
glConvolutionParameteri: PFNGLCONVOLUTIONPARAMETERIPROC;
glConvolutionParameteriv: PFNGLCONVOLUTIONPARAMETERIVPROC;
glCopyConvolutionFilter1D: PFNGLCOPYCONVOLUTIONFILTER1DPROC;
glCopyConvolutionFilter2D: PFNGLCOPYCONVOLUTIONFILTER2DPROC;
glGetConvolutionFilter: PFNGLGETCONVOLUTIONFILTERPROC;
glGetConvolutionParameterfv: PFNGLGETCONVOLUTIONPARAMETERFVPROC;
glGetConvolutionParameteriv: PFNGLGETCONVOLUTIONPARAMETERIVPROC;
glGetSeparableFilter: PFNGLGETSEPARABLEFILTERPROC;
glSeparableFilter2D: PFNGLSEPARABLEFILTER2DPROC;
glGetHistogram: PFNGLGETHISTOGRAMPROC;
glGetHistogramParameterfv: PFNGLGETHISTOGRAMPARAMETERFVPROC;
glGetHistogramParameteriv: PFNGLGETHISTOGRAMPARAMETERIVPROC;
glGetMinmax: PFNGLGETMINMAXPROC;
glGetMinmaxParameterfv: PFNGLGETMINMAXPARAMETERFVPROC;
glGetMinmaxParameteriv: PFNGLGETMINMAXPARAMETERIVPROC;
glHistogram: PFNGLHISTOGRAMPROC;
glMinmax: PFNGLMINMAXPROC;
glResetHistogram: PFNGLRESETHISTOGRAMPROC;
glResetMinmax: PFNGLRESETMINMAXPROC;
glActiveTexture: PFNGLACTIVETEXTUREPROC;
glSampleCoverage: PFNGLSAMPLECOVERAGEPROC;
glCompressedTexImage3D: PFNGLCOMPRESSEDTEXIMAGE3DPROC;
glCompressedTexImage2D: PFNGLCOMPRESSEDTEXIMAGE2DPROC;
glCompressedTexImage1D: PFNGLCOMPRESSEDTEXIMAGE1DPROC;
glCompressedTexSubImage3D: PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC;
glCompressedTexSubImage2D: PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC;
glCompressedTexSubImage1D: PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC;
glGetCompressedTexImage: PFNGLGETCOMPRESSEDTEXIMAGEPROC;
glClientActiveTexture: PFNGLCLIENTACTIVETEXTUREPROC;
glMultiTexCoord1d: PFNGLMULTITEXCOORD1DPROC;
glMultiTexCoord1dV: PFNGLMULTITEXCOORD1DVPROC;
glMultiTexCoord1f: PFNGLMULTITEXCOORD1FPROC;
glMultiTexCoord1fV: PFNGLMULTITEXCOORD1FVPROC;
glMultiTexCoord1i: PFNGLMULTITEXCOORD1IPROC;
glMultiTexCoord1iV: PFNGLMULTITEXCOORD1IVPROC;
glMultiTexCoord1s: PFNGLMULTITEXCOORD1SPROC;
glMultiTexCoord1sV: PFNGLMULTITEXCOORD1SVPROC;
glMultiTexCoord2d: PFNGLMULTITEXCOORD2DPROC;
glMultiTexCoord2dv: PFNGLMULTITEXCOORD2DVPROC;
glMultiTexCoord2f: PFNGLMULTITEXCOORD2FPROC;
glMultiTexCoord2fv: PFNGLMULTITEXCOORD2FVPROC;
glMultiTexCoord2i: PFNGLMULTITEXCOORD2IPROC;
glMultiTexCoord2iv: PFNGLMULTITEXCOORD2IVPROC;
glMultiTexCoord2s: PFNGLMULTITEXCOORD2SPROC;
glMultiTexCoord2sv: PFNGLMULTITEXCOORD2SVPROC;
glMultiTexCoord3d: PFNGLMULTITEXCOORD3DPROC;
glMultiTexCoord3dv: PFNGLMULTITEXCOORD3DVPROC;
glMultiTexCoord3f: PFNGLMULTITEXCOORD3FPROC;
glMultiTexCoord3fv: PFNGLMULTITEXCOORD3FVPROC;
glMultiTexCoord3i: PFNGLMULTITEXCOORD3IPROC;
glMultiTexCoord3iv: PFNGLMULTITEXCOORD3IVPROC;
glMultiTexCoord3s: PFNGLMULTITEXCOORD3SPROC;
glMultiTexCoord3sv: PFNGLMULTITEXCOORD3SVPROC;
glMultiTexCoord4d: PFNGLMULTITEXCOORD4DPROC;
glMultiTexCoord4dv: PFNGLMULTITEXCOORD4DVPROC;
glMultiTexCoord4f: PFNGLMULTITEXCOORD4FPROC;
glMultiTexCoord4fv: PFNGLMULTITEXCOORD4FVPROC;
glMultiTexCoord4i: PFNGLMULTITEXCOORD4IPROC;
glMultiTexCoord4iv: PFNGLMULTITEXCOORD4IVPROC;
glMultiTexCoord4s: PFNGLMULTITEXCOORD4SPROC;
glMultiTexCoord4sv: PFNGLMULTITEXCOORD4SVPROC;
glLoadTransposeMatrixf: PFNGLLOADTRANSPOSEMATRIXFPROC;
glLoadTransposeMatrixd: PFNGLLOADTRANSPOSEMATRIXDPROC;
glMultTransposeMatrixf: PFNGLMULTTRANSPOSEMATRIXFPROC;
glMultTransposeMatrixd: PFNGLMULTTRANSPOSEMATRIXDPROC;
glBlendFuncSeparate: PFNGLBLENDFUNCSEPARATEPROC;
glMultiDrawArrays: PFNGLMULTIDRAWARRAYSPROC;
glMultiDrawElements: PFNGLMULTIDRAWELEMENTSPROC;
glPointParameterf: PFNGLPOINTPARAMETERFPROC;
glPointParameterfv: PFNGLPOINTPARAMETERFVPROC;
glPointParameteri: PFNGLPOINTPARAMETERIPROC;
glPointParameteriv: PFNGLPOINTPARAMETERIVPROC;
glFogCoordf: PFNGLFOGCOORDFPROC;
glFogCoordfv: PFNGLFOGCOORDFVPROC;
glFogCoordd: PFNGLFOGCOORDDPROC;
glFogCoorddv: PFNGLFOGCOORDDVPROC;
glFogCoordPointer: PFNGLFOGCOORDPOINTERPROC;
glSecondaryColor3b: PFNGLSECONDARYCOLOR3BPROC;
glSecondaryColor3bv: PFNGLSECONDARYCOLOR3BVPROC;
glSecondaryColor3d: PFNGLSECONDARYCOLOR3DPROC;
glSecondaryColor3dv: PFNGLSECONDARYCOLOR3DVPROC;
glSecondaryColor3f: PFNGLSECONDARYCOLOR3FPROC;
glSecondaryColor3fv: PFNGLSECONDARYCOLOR3FVPROC;
glSecondaryColor3i: PFNGLSECONDARYCOLOR3IPROC;
glSecondaryColor3iv: PFNGLSECONDARYCOLOR3IVPROC;
glSecondaryColor3s: PFNGLSECONDARYCOLOR3SPROC;
glSecondaryColor3sv: PFNGLSECONDARYCOLOR3SVPROC;
glSecondaryColor3ub: PFNGLSECONDARYCOLOR3UBPROC;
glSecondaryColor3ubv: PFNGLSECONDARYCOLOR3UBVPROC;
glSecondaryColor3ui: PFNGLSECONDARYCOLOR3UIPROC;
glSecondaryColor3uiv: PFNGLSECONDARYCOLOR3UIVPROC;
glSecondaryColor3us: PFNGLSECONDARYCOLOR3USPROC;
glSecondaryColor3usv: PFNGLSECONDARYCOLOR3USVPROC;
glSecondaryColorPointer: PFNGLSECONDARYCOLORPOINTERPROC;
glWindowPos2d: PFNGLWINDOWPOS2DPROC;
glWindowPos2dv: PFNGLWINDOWPOS2DVPROC;
glWindowPos2f: PFNGLWINDOWPOS2FPROC;
glWindowPos2fv: PFNGLWINDOWPOS2FVPROC;
glWindowPos2i: PFNGLWINDOWPOS2IPROC;
glWindowPos2iv: PFNGLWINDOWPOS2IVPROC;
glWindowPos2s: PFNGLWINDOWPOS2SPROC;
glWindowPos2sv: PFNGLWINDOWPOS2SVPROC;
glWindowPos3d: PFNGLWINDOWPOS3DPROC;
glWindowPos3dv: PFNGLWINDOWPOS3DVPROC;
glWindowPos3f: PFNGLWINDOWPOS3FPROC;
glWindowPos3fv: PFNGLWINDOWPOS3FVPROC;
glWindowPos3i: PFNGLWINDOWPOS3IPROC;
glWindowPos3iv: PFNGLWINDOWPOS3IVPROC;
glWindowPos3s: PFNGLWINDOWPOS3SPROC;
glWindowPos3sv: PFNGLWINDOWPOS3SVPROC;
glGenQueries: PFNGLGENQUERIESPROC;
glDeleteQueries: PFNGLDELETEQUERIESPROC;
glIsQuery: PFNGLISQUERYPROC;
glBeginQuery: PFNGLBEGINQUERYPROC;
glEndQuery: PFNGLENDQUERYPROC;
glGetQueryiv: PFNGLGETQUERYIVPROC;
glGetQueryObjectiv: PFNGLGETQUERYOBJECTIVPROC;
glGetQueryObjectuiv: PFNGLGETQUERYOBJECTUIVPROC;
glBindBuffer: PFNGLBINDBUFFERPROC;
glDeleteBuffers: PFNGLDELETEBUFFERSPROC;
glGenBuffers: PFNGLGENBUFFERSPROC;
glIsBuffer: PFNGLISBUFFERPROC;
glBufferData: PFNGLBUFFERDATAPROC;
glBufferSubData: PFNGLBUFFERSUBDATAPROC;
glGetBufferSubData: PFNGLGETBUFFERSUBDATAPROC;
glMapBuffer: PFNGLMAPBUFFERPROC;
glUnmapBuffer: PFNGLUNMAPBUFFERPROC;
glGetBufferParameteriv: PFNGLGETBUFFERPARAMETERIVPROC;
glGetBufferPointerv: PFNGLGETBUFFERPOINTERVPROC;
glBlendEquationSeparate: PFNGLBLENDEQUATIONSEPARATEPROC;
glDrawBuffers: PFNGLDRAWBUFFERSPROC;
glStencilOpSeparate: PFNGLSTENCILOPSEPARATEPROC;
glStencilFuncSeparate: PFNGLSTENCILFUNCSEPARATEPROC;
glStencilMaskSeparate: PFNGLSTENCILMASKSEPARATEPROC;
glAttachShader: PFNGLATTACHSHADERPROC;
glBindAttribLocation: PFNGLBINDATTRIBLOCATIONPROC;
glCompileShader: PFNGLCOMPILESHADERPROC;
glCreateProgram: PFNGLCREATEPROGRAMPROC;
glCreateShader: PFNGLCREATESHADERPROC;
glDeleteProgram: PFNGLDELETEPROGRAMPROC;
glDeleteShader: PFNGLDELETESHADERPROC;
glDetachShader: PFNGLDETACHSHADERPROC;
glDisableVertexAttribArray: PFNGLDISABLEVERTEXATTRIBARRAYPROC;
glEnableVertexAttribArray: PFNGLENABLEVERTEXATTRIBARRAYPROC;
glGetActiveAttrib: PFNGLGETACTIVEATTRIBPROC;
glGetActiveUniform: PFNGLGETACTIVEUNIFORMPROC;
glGetAttachedShaders: PFNGLGETATTACHEDSHADERSPROC;
glGetAttribLocation: PFNGLGETATTRIBLOCATIONPROC;
glGetProgramiv: PFNGLGETPROGRAMIVPROC;
glGetProgramInfoLog: PFNGLGETPROGRAMINFOLOGPROC;
glGetShaderiv: PFNGLGETSHADERIVPROC;
glGetShaderInfoLog: PFNGLGETSHADERINFOLOGPROC;
glGetShaderSource: PFNGLGETSHADERSOURCEPROC;
glGetUniformLocation: PFNGLGETUNIFORMLOCATIONPROC;
glGetUniformfv: PFNGLGETUNIFORMFVPROC;
glGetUniformiv: PFNGLGETUNIFORMIVPROC;
glGetVertexAttribdv: PFNGLGETVERTEXATTRIBDVPROC;
glGetVertexAttribfv: PFNGLGETVERTEXATTRIBFVPROC;
glGetVertexAttribiv: PFNGLGETVERTEXATTRIBIVPROC;
glGetVertexAttribPointerv: PFNGLGETVERTEXATTRIBPOINTERVPROC;
glIsProgram: PFNGLISPROGRAMPROC;
glIsShader: PFNGLISSHADERPROC;
glLinkProgram: PFNGLLINKPROGRAMPROC;
glShaderSource: PFNGLSHADERSOURCEPROC;
glUseProgram: PFNGLUSEPROGRAMPROC;
glUniform1f: PFNGLUNIFORM1FPROC;
glUniform2f: PFNGLUNIFORM2FPROC;
glUniform3f: PFNGLUNIFORM3FPROC;
glUniform4f: PFNGLUNIFORM4FPROC;
glUniform1i: PFNGLUNIFORM1IPROC;
glUniform2i: PFNGLUNIFORM2IPROC;
glUniform3i: PFNGLUNIFORM3IPROC;
glUniform4i: PFNGLUNIFORM4IPROC;
glUniform1fv: PFNGLUNIFORM1FVPROC;
glUniform2fv: PFNGLUNIFORM2FVPROC;
glUniform3fv: PFNGLUNIFORM3FVPROC;
glUniform4fv: PFNGLUNIFORM4FVPROC;
glUniform1iv: PFNGLUNIFORM1IVPROC;
glUniform2iv: PFNGLUNIFORM2IVPROC;
glUniform3iv: PFNGLUNIFORM3IVPROC;
glUniform4iv: PFNGLUNIFORM4IVPROC;
glUniformMatrix2fv: PFNGLUNIFORMMATRIX2FVPROC;
glUniformMatrix3fv: PFNGLUNIFORMMATRIX3FVPROC;
glUniformMatrix4fv: PFNGLUNIFORMMATRIX4FVPROC;
glValidateProgram: PFNGLVALIDATEPROGRAMPROC;
glVertexAttrib1d: PFNGLVERTEXATTRIB1DPROC;
glVertexAttrib1dv: PFNGLVERTEXATTRIB1DVPROC;
glVertexAttrib1f: PFNGLVERTEXATTRIB1FPROC;
glVertexAttrib1fv: PFNGLVERTEXATTRIB1FVPROC;
glVertexAttrib1s: PFNGLVERTEXATTRIB1SPROC;
glVertexAttrib1sv: PFNGLVERTEXATTRIB1SVPROC;
glVertexAttrib2d: PFNGLVERTEXATTRIB2DPROC;
glVertexAttrib2dv: PFNGLVERTEXATTRIB2DVPROC;
glVertexAttrib2f: PFNGLVERTEXATTRIB2FPROC;
glVertexAttrib2fv: PFNGLVERTEXATTRIB2FVPROC;
glVertexAttrib2s: PFNGLVERTEXATTRIB2SPROC;
glVertexAttrib2sv: PFNGLVERTEXATTRIB2SVPROC;
glVertexAttrib3d: PFNGLVERTEXATTRIB3DPROC;
glVertexAttrib3dv: PFNGLVERTEXATTRIB3DVPROC;
glVertexAttrib3f: PFNGLVERTEXATTRIB3FPROC;
glVertexAttrib3fv: PFNGLVERTEXATTRIB3FVPROC;
glVertexAttrib3s: PFNGLVERTEXATTRIB3SPROC;
glVertexAttrib3sv: PFNGLVERTEXATTRIB3SVPROC;
glVertexAttrib4Nbv: PFNGLVERTEXATTRIB4NBVPROC;
glVertexAttrib4Niv: PFNGLVERTEXATTRIB4NIVPROC;
glVertexAttrib4Nsv: PFNGLVERTEXATTRIB4NSVPROC;
glVertexAttrib4Nub: PFNGLVERTEXATTRIB4NUBPROC;
glVertexAttrib4Nubv: PFNGLVERTEXATTRIB4NUBVPROC;
glVertexAttrib4Nuiv: PFNGLVERTEXATTRIB4NUIVPROC;
glVertexAttrib4Nusv: PFNGLVERTEXATTRIB4NUSVPROC;
glVertexAttrib4bv: PFNGLVERTEXATTRIB4BVPROC;
glVertexAttrib4d: PFNGLVERTEXATTRIB4DPROC;
glVertexAttrib4dv: PFNGLVERTEXATTRIB4DVPROC;
glVertexAttrib4f: PFNGLVERTEXATTRIB4FPROC;
glVertexAttrib4fv: PFNGLVERTEXATTRIB4FVPROC;
glVertexAttrib4iv: PFNGLVERTEXATTRIB4IVPROC;
glVertexAttrib4s: PFNGLVERTEXATTRIB4SPROC;
glVertexAttrib4sv: PFNGLVERTEXATTRIB4SVPROC;
glVertexAttrib4ubv: PFNGLVERTEXATTRIB4UBVPROC;
glVertexAttrib4uiv: PFNGLVERTEXATTRIB4UIVPROC;
glVertexAttrib4usv: PFNGLVERTEXATTRIB4USVPROC;
glVertexAttribPointer: PFNGLVERTEXATTRIBPOINTERPROC;
glUniformMatrix2x3fv: PFNGLUNIFORMMATRIX2X3FVPROC;
glUniformMatrix3x2fv: PFNGLUNIFORMMATRIX3X2FVPROC;
glUniformMatrix2x4fv: PFNGLUNIFORMMATRIX2X4FVPROC;
glUniformMatrix4x2fv: PFNGLUNIFORMMATRIX4X2FVPROC;
glUniformMatrix3x4fv: PFNGLUNIFORMMATRIX3X4FVPROC;
glUniformMatrix4x3fv: PFNGLUNIFORMMATRIX4X3FVPROC;
glVertexAttribI1i: PFNGLVERTEXATTRIBI1IPROC;
glVertexAttribI2i: PFNGLVERTEXATTRIBI2IPROC;
glVertexAttribI3i: PFNGLVERTEXATTRIBI3IPROC;
glVertexAttribI4i: PFNGLVERTEXATTRIBI4IPROC;
glVertexAttribI1ui: PFNGLVERTEXATTRIBI1UIPROC;
glVertexAttribI2ui: PFNGLVERTEXATTRIBI2UIPROC;
glVertexAttribI3ui: PFNGLVERTEXATTRIBI3UIPROC;
glVertexAttribI4ui: PFNGLVERTEXATTRIBI4UIPROC;
glVertexAttribI1iv: PFNGLVERTEXATTRIBI1IVPROC;
glVertexAttribI2iv: PFNGLVERTEXATTRIBI2IVPROC;
glVertexAttribI3iv: PFNGLVERTEXATTRIBI3IVPROC;
glVertexAttribI4iv: PFNGLVERTEXATTRIBI4IVPROC;
glVertexAttribI1uiv: PFNGLVERTEXATTRIBI1UIVPROC;
glVertexAttribI2uiv: PFNGLVERTEXATTRIBI2UIVPROC;
glVertexAttribI3uiv: PFNGLVERTEXATTRIBI3UIVPROC;
glVertexAttribI4uiv: PFNGLVERTEXATTRIBI4UIVPROC;
glVertexAttribI4bv: PFNGLVERTEXATTRIBI4BVPROC;
glVertexAttribI4sv: PFNGLVERTEXATTRIBI4SVPROC;
glVertexAttribI4ubv: PFNGLVERTEXATTRIBI4UBVPROC;
glVertexAttribI4usv: PFNGLVERTEXATTRIBI4USVPROC;
glVertexAttribIPointer: PFNGLVERTEXATTRIBIPOINTERPROC;
glGetVertexAttribIiv: PFNGLGETVERTEXATTRIBIIVPROC;
glGetVertexAttribIuiv: PFNGLGETVERTEXATTRIBIUIVPROC;
glUniform1ui: PFNGLUNIFORM1UIPROC;
glUniform2ui: PFNGLUNIFORM2UIPROC;
glUniform3ui: PFNGLUNIFORM3UIPROC;
glUniform4ui: PFNGLUNIFORM4UIPROC;
glUniform1uiv: PFNGLUNIFORM1UIVPROC;
glUniform2uiv: PFNGLUNIFORM2UIVPROC;
glUniform3uiv: PFNGLUNIFORM3UIVPROC;
glUniform4uiv: PFNGLUNIFORM4UIVPROC;
glGetUniformuiv: PFNGLGETUNIFORMUIVPROC;
glBindFragDataLocation: PFNGLBINDFRAGDATALOCATIONPROC;
glGetFragDataLocation: PFNGLGETFRAGDATALOCATIONPROC;
glBeginConditionalRender: PFNGLBEGINCONDITIONALRENDERPROC;
glEndConditionalRender: PFNGLENDCONDITIONALRENDERPROC;
glClampColor: PFNGLCLAMPCOLORPROC;
glTexParameterIiv: PFNGLTEXPARAMETERIIVPROC;
glTexParameterIuiv: PFNGLTEXPARAMETERIUIVPROC;
glGetTexParameterIiv: PFNGLGETTEXPARAMETERIIVPROC;
glGetTexParameterIuiv: PFNGLGETTEXPARAMETERIUIVPROC;
glColorMaski: PFNGLCOLORMASKIPROC;
glGetBooleani_v: PFNGLGETBOOLEANI_VPROC;
glGetIntegeri_v: PFNGLGETINTEGERI_VPROC;
glEnablei: PFNGLENABLEIPROC;
glDisablei: PFNGLDISABLEIPROC;
glIsEnabledi: PFNGLISENABLEDIPROC;
glBindBufferRange: PFNGLBINDBUFFERRANGEPROC;
glBindBufferBase: PFNGLBINDBUFFERBASEPROC;
glBeginTransformFeedback: PFNGLBEGINTRANSFORMFEEDBACKPROC;
glEndTransformFeedback: PFNGLENDTRANSFORMFEEDBACKPROC;
glTransformFeedbackVaryings: PFNGLTRANSFORMFEEDBACKVARYINGSPROC;
glGetTransformFeedbackVarying: PFNGLGETTRANSFORMFEEDBACKVARYINGPROC;
glClearBufferiv: PFNGLCLEARBUFFERIVPROC;
glClearBufferuiv: PFNGLCLEARBUFFERUIVPROC;
glClearBufferfv: PFNGLCLEARBUFFERFVPROC;
glClearBufferfi: PFNGLCLEARBUFFERFIPROC;
glGetStringi: PFNGLGETSTRINGIPROC;
glDrawArraysInstanced: PFNGLDRAWARRAYSINSTANCEDPROC;
glDrawElementsInstanced: PFNGLDRAWELEMENTSINSTANCEDPROC;
glTexBuffer: PFNGLTEXBUFFERPROC;
glPrimitiveRestartIndex: PFNGLPRIMITIVERESTARTINDEXPROC;
glGetInteger64i_v: PFNGLGETINTEGER64I_VPROC;
glGetBufferParameteri64v: PFNGLGETBUFFERPARAMETERI64VPROC;
glFramebufferTexture: PFNGLFRAMEBUFFERTEXTUREPROC;
glVertexAttribDivisor: PFNGLVERTEXATTRIBDIVISORPROC;
glMinSampleShading: PFNGLMINSAMPLESHADINGPROC;
glBlendEquationi: PFNGLBLENDEQUATIONIPROC;
glBlendEquationSeparatei: PFNGLBLENDEQUATIONSEPARATEIPROC;
glBlendFunci: PFNGLBLENDFUNCIPROC;
glBlendFuncSeparatei: PFNGLBLENDFUNCSEPARATEIPROC;
gluNurbsCallbackDataEXT: PFNGLUNURBSCALLBACKDATAEXTPROC;
gluNewNurbsTessellatorEXT: PFNGLUNEWNURBSTESSELLATOREXTPROC;
gluDeleteNurbsTessellatorEXT: PFNGLUDELETENURBSTESSELLATOREXTPROC;
wglCreateBufferRegionARB: PFNWGLCREATEBUFFERREGIONARBPROC;
wglDeleteBufferRegionARB: PFNWGLDELETEBUFFERREGIONARBPROC;
wglSaveBufferRegionARB: PFNWGLSAVEBUFFERREGIONARBPROC;
wglRestoreBufferRegionARB: PFNWGLRESTOREBUFFERREGIONARBPROC;
wglGetExtensionsStringARB: PFNWGLGETEXTENSIONSSTRINGARBPROC;
wglGetPixelFormatAttribivARB: PFNWGLGETPIXELFORMATATTRIBIVARBPROC;
wglGetPixelFormatAttribfvARB: PFNWGLGETPIXELFORMATATTRIBFVARBPROC;
wglChoosePixelFormatARB: PFNWGLCHOOSEPIXELFORMATARBPROC;
wglMakeContextCurrentARB: PFNWGLMAKECONTEXTCURRENTARBPROC;
wglGetCurrentReadDCARB: PFNWGLGETCURRENTREADDCARBPROC;
wglCreatePbufferARB: PFNWGLCREATEPBUFFERARBPROC;
wglGetPbufferDCARB: PFNWGLGETPBUFFERDCARBPROC;
wglReleasePbufferDCARB: PFNWGLRELEASEPBUFFERDCARBPROC;
wglDestroyPbufferARB: PFNWGLDESTROYPBUFFERARBPROC;
wglQueryPbufferARB: PFNWGLQUERYPBUFFERARBPROC;
wglBindTexImageARB: PFNWGLBINDTEXIMAGEARBPROC;
wglReleaseTexImageARB: PFNWGLRELEASETEXIMAGEARBPROC;
wglSetPbufferAttribARB: PFNWGLSETPBUFFERATTRIBARBPROC;
wglCreateContextAttribsARB: PFNWGLCREATECONTEXTATTRIBSARBPROC;
wglEnumGpusNV: PFNWGLENUMGPUSNVPROC;
wglEnumGpuDevicesNV: PFNWGLENUMGPUDEVICESNVPROC;
wglCreateAffinityDCNV: PFNWGLCREATEAFFINITYDCNVPROC;
wglEnumGpusFromAffinityDCNV: PFNWGLENUMGPUSFROMAFFINITYDCNVPROC;
wglDeleteDCNV: PFNWGLDELETEDCNVPROC;
wglSwapIntervalEXT: PFNWGLSWAPINTERVALEXTPROC;
wglGetSwapIntervalEXT: PFNWGLGETSWAPINTERVALEXTPROC;
glSamplePassARB: PFNGLSAMPLEPASSARBPROC;
glActiveTextureARB: PFNGLACTIVETEXTUREARBPROC;
glClientActiveTextureARB: PFNGLCLIENTACTIVETEXTUREARBPROC;
glMultiTexCoord1dARB: PFNGLMULTITEXCOORD1DARBPROC;
glMultiTexCoord1dVARB: PFNGLMULTITEXCOORD1DVARBPROC;
glMultiTexCoord1fARB: PFNGLMULTITEXCOORD1FARBPROC;
glMultiTexCoord1fVARB: PFNGLMULTITEXCOORD1FVARBPROC;
glMultiTexCoord1iARB: PFNGLMULTITEXCOORD1IARBPROC;
glMultiTexCoord1iVARB: PFNGLMULTITEXCOORD1IVARBPROC;
glMultiTexCoord1sARB: PFNGLMULTITEXCOORD1SARBPROC;
glMultiTexCoord1sVARB: PFNGLMULTITEXCOORD1SVARBPROC;
glMultiTexCoord2dARB: PFNGLMULTITEXCOORD2DARBPROC;
glMultiTexCoord2dvARB: PFNGLMULTITEXCOORD2DVARBPROC;
glMultiTexCoord2fARB: PFNGLMULTITEXCOORD2FARBPROC;
glMultiTexCoord2fvARB: PFNGLMULTITEXCOORD2FVARBPROC;
glMultiTexCoord2iARB: PFNGLMULTITEXCOORD2IARBPROC;
glMultiTexCoord2ivARB: PFNGLMULTITEXCOORD2IVARBPROC;
glMultiTexCoord2sARB: PFNGLMULTITEXCOORD2SARBPROC;
glMultiTexCoord2svARB: PFNGLMULTITEXCOORD2SVARBPROC;
glMultiTexCoord3dARB: PFNGLMULTITEXCOORD3DARBPROC;
glMultiTexCoord3dvARB: PFNGLMULTITEXCOORD3DVARBPROC;
glMultiTexCoord3fARB: PFNGLMULTITEXCOORD3FARBPROC;
glMultiTexCoord3fvARB: PFNGLMULTITEXCOORD3FVARBPROC;
glMultiTexCoord3iARB: PFNGLMULTITEXCOORD3IARBPROC;
glMultiTexCoord3ivARB: PFNGLMULTITEXCOORD3IVARBPROC;
glMultiTexCoord3sARB: PFNGLMULTITEXCOORD3SARBPROC;
glMultiTexCoord3svARB: PFNGLMULTITEXCOORD3SVARBPROC;
glMultiTexCoord4dARB: PFNGLMULTITEXCOORD4DARBPROC;
glMultiTexCoord4dvARB: PFNGLMULTITEXCOORD4DVARBPROC;
glMultiTexCoord4fARB: PFNGLMULTITEXCOORD4FARBPROC;
glMultiTexCoord4fvARB: PFNGLMULTITEXCOORD4FVARBPROC;
glMultiTexCoord4iARB: PFNGLMULTITEXCOORD4IARBPROC;
glMultiTexCoord4ivARB: PFNGLMULTITEXCOORD4IVARBPROC;
glMultiTexCoord4sARB: PFNGLMULTITEXCOORD4SARBPROC;
glMultiTexCoord4svARB: PFNGLMULTITEXCOORD4SVARBPROC;
glLoadTransposeMatrixfARB: PFNGLLOADTRANSPOSEMATRIXFARBPROC;
glLoadTransposeMatrixdARB: PFNGLLOADTRANSPOSEMATRIXDARBPROC;
glMultTransposeMatrixfARB: PFNGLMULTTRANSPOSEMATRIXFARBPROC;
glMultTransposeMatrixdARB: PFNGLMULTTRANSPOSEMATRIXDARBPROC;
glSampleCoverageARB: PFNGLSAMPLECOVERAGEARBPROC;
glCompressedTexImage3DARB: PFNGLCOMPRESSEDTEXIMAGE3DARBPROC;
glCompressedTexImage2DARB: PFNGLCOMPRESSEDTEXIMAGE2DARBPROC;
glCompressedTexImage1DARB: PFNGLCOMPRESSEDTEXIMAGE1DARBPROC;
glCompressedTexSubImage3DARB: PFNGLCOMPRESSEDTEXSUBIMAGE3DARBPROC;
glCompressedTexSubImage2DARB: PFNGLCOMPRESSEDTEXSUBIMAGE2DARBPROC;
glCompressedTexSubImage1DARB: PFNGLCOMPRESSEDTEXSUBIMAGE1DARBPROC;
glGetCompressedTexImageARB: PFNGLGETCOMPRESSEDTEXIMAGEARBPROC;
glPointParameterfARB: PFNGLPOINTPARAMETERFARBPROC;
glPointParameterfvARB: PFNGLPOINTPARAMETERFVARBPROC;
glWeightbvARB: PFNGLWEIGHTBVARBPROC;
glWeightsvARB: PFNGLWEIGHTSVARBPROC;
glWeightivARB: PFNGLWEIGHTIVARBPROC;
glWeightfvARB: PFNGLWEIGHTFVARBPROC;
glWeightdvARB: PFNGLWEIGHTDVARBPROC;
glWeightubvARB: PFNGLWEIGHTUBVARBPROC;
glWeightusvARB: PFNGLWEIGHTUSVARBPROC;
glWeightuivARB: PFNGLWEIGHTUIVARBPROC;
glWeightPointerARB: PFNGLWEIGHTPOINTERARBPROC;
glVertexBlendARB: PFNGLVERTEXBLENDARBPROC;
glCurrentPaletteMatrixARB: PFNGLCURRENTPALETTEMATRIXARBPROC;
glMatrixIndexubvARB: PFNGLMATRIXINDEXUBVARBPROC;
glMatrixIndexusvARB: PFNGLMATRIXINDEXUSVARBPROC;
glMatrixIndexuivARB: PFNGLMATRIXINDEXUIVARBPROC;
glMatrixIndexPointerARB: PFNGLMATRIXINDEXPOINTERARBPROC;
glWindowPos2dARB: PFNGLWINDOWPOS2DARBPROC;
glWindowPos2dvARB: PFNGLWINDOWPOS2DVARBPROC;
glWindowPos2fARB: PFNGLWINDOWPOS2FARBPROC;
glWindowPos2fvARB: PFNGLWINDOWPOS2FVARBPROC;
glWindowPos2iARB: PFNGLWINDOWPOS2IARBPROC;
glWindowPos2ivARB: PFNGLWINDOWPOS2IVARBPROC;
glWindowPos2sARB: PFNGLWINDOWPOS2SARBPROC;
glWindowPos2svARB: PFNGLWINDOWPOS2SVARBPROC;
glWindowPos3dARB: PFNGLWINDOWPOS3DARBPROC;
glWindowPos3dvARB: PFNGLWINDOWPOS3DVARBPROC;
glWindowPos3fARB: PFNGLWINDOWPOS3FARBPROC;
glWindowPos3fvARB: PFNGLWINDOWPOS3FVARBPROC;
glWindowPos3iARB: PFNGLWINDOWPOS3IARBPROC;
glWindowPos3ivARB: PFNGLWINDOWPOS3IVARBPROC;
glWindowPos3sARB: PFNGLWINDOWPOS3SARBPROC;
glWindowPos3svARB: PFNGLWINDOWPOS3SVARBPROC;
glVertexAttrib1dARB: PFNGLVERTEXATTRIB1DARBPROC;
glVertexAttrib1dvARB: PFNGLVERTEXATTRIB1DVARBPROC;
glVertexAttrib1fARB: PFNGLVERTEXATTRIB1FARBPROC;
glVertexAttrib1fvARB: PFNGLVERTEXATTRIB1FVARBPROC;
glVertexAttrib1sARB: PFNGLVERTEXATTRIB1SARBPROC;
glVertexAttrib1svARB: PFNGLVERTEXATTRIB1SVARBPROC;
glVertexAttrib2dARB: PFNGLVERTEXATTRIB2DARBPROC;
glVertexAttrib2dvARB: PFNGLVERTEXATTRIB2DVARBPROC;
glVertexAttrib2fARB: PFNGLVERTEXATTRIB2FARBPROC;
glVertexAttrib2fvARB: PFNGLVERTEXATTRIB2FVARBPROC;
glVertexAttrib2sARB: PFNGLVERTEXATTRIB2SARBPROC;
glVertexAttrib2svARB: PFNGLVERTEXATTRIB2SVARBPROC;
glVertexAttrib3dARB: PFNGLVERTEXATTRIB3DARBPROC;
glVertexAttrib3dvARB: PFNGLVERTEXATTRIB3DVARBPROC;
glVertexAttrib3fARB: PFNGLVERTEXATTRIB3FARBPROC;
glVertexAttrib3fvARB: PFNGLVERTEXATTRIB3FVARBPROC;
glVertexAttrib3sARB: PFNGLVERTEXATTRIB3SARBPROC;
glVertexAttrib3svARB: PFNGLVERTEXATTRIB3SVARBPROC;
glVertexAttrib4NbvARB: PFNGLVERTEXATTRIB4NBVARBPROC;
glVertexAttrib4NivARB: PFNGLVERTEXATTRIB4NIVARBPROC;
glVertexAttrib4NsvARB: PFNGLVERTEXATTRIB4NSVARBPROC;
glVertexAttrib4NubARB: PFNGLVERTEXATTRIB4NUBARBPROC;
glVertexAttrib4NubvARB: PFNGLVERTEXATTRIB4NUBVARBPROC;
glVertexAttrib4NuivARB: PFNGLVERTEXATTRIB4NUIVARBPROC;
glVertexAttrib4NusvARB: PFNGLVERTEXATTRIB4NUSVARBPROC;
glVertexAttrib4bvARB: PFNGLVERTEXATTRIB4BVARBPROC;
glVertexAttrib4dARB: PFNGLVERTEXATTRIB4DARBPROC;
glVertexAttrib4dvARB: PFNGLVERTEXATTRIB4DVARBPROC;
glVertexAttrib4fARB: PFNGLVERTEXATTRIB4FARBPROC;
glVertexAttrib4fvARB: PFNGLVERTEXATTRIB4FVARBPROC;
glVertexAttrib4ivARB: PFNGLVERTEXATTRIB4IVARBPROC;
glVertexAttrib4sARB: PFNGLVERTEXATTRIB4SARBPROC;
glVertexAttrib4svARB: PFNGLVERTEXATTRIB4SVARBPROC;
glVertexAttrib4ubvARB: PFNGLVERTEXATTRIB4UBVARBPROC;
glVertexAttrib4uivARB: PFNGLVERTEXATTRIB4UIVARBPROC;
glVertexAttrib4usvARB: PFNGLVERTEXATTRIB4USVARBPROC;
glVertexAttribPointerARB: PFNGLVERTEXATTRIBPOINTERARBPROC;
glEnableVertexAttribArrayARB: PFNGLENABLEVERTEXATTRIBARRAYARBPROC;
glDisableVertexAttribArrayARB: PFNGLDISABLEVERTEXATTRIBARRAYARBPROC;
glProgramStringARB: PFNGLPROGRAMSTRINGARBPROC;
glBindProgramARB: PFNGLBINDPROGRAMARBPROC;
glDeleteProgramsARB: PFNGLDELETEPROGRAMSARBPROC;
glGenProgramsARB: PFNGLGENPROGRAMSARBPROC;
glProgramEnvParameter4dARB: PFNGLPROGRAMENVPARAMETER4DARBPROC;
glProgramEnvParameter4dvARB: PFNGLPROGRAMENVPARAMETER4DVARBPROC;
glProgramEnvParameter4fARB: PFNGLPROGRAMENVPARAMETER4FARBPROC;
glProgramEnvParameter4fvARB: PFNGLPROGRAMENVPARAMETER4FVARBPROC;
glProgramLocalParameter4dARB: PFNGLPROGRAMLOCALPARAMETER4DARBPROC;
glProgramLocalParameter4dvARB: PFNGLPROGRAMLOCALPARAMETER4DVARBPROC;
glProgramLocalParameter4fARB: PFNGLPROGRAMLOCALPARAMETER4FARBPROC;
glProgramLocalParameter4fvARB: PFNGLPROGRAMLOCALPARAMETER4FVARBPROC;
glGetProgramEnvParameterdvARB: PFNGLGETPROGRAMENVPARAMETERDVARBPROC;
glGetProgramEnvParameterfvARB: PFNGLGETPROGRAMENVPARAMETERFVARBPROC;
glGetProgramLocalParameterdvARB: PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC;
glGetProgramLocalParameterfvARB: PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC;
glGetProgramivARB: PFNGLGETPROGRAMIVARBPROC;
glGetProgramStringARB: PFNGLGETPROGRAMSTRINGARBPROC;
glGetVertexAttribdvARB: PFNGLGETVERTEXATTRIBDVARBPROC;
glGetVertexAttribfvARB: PFNGLGETVERTEXATTRIBFVARBPROC;
glGetVertexAttribivARB: PFNGLGETVERTEXATTRIBIVARBPROC;
glGetVertexAttribPointervARB: PFNGLGETVERTEXATTRIBPOINTERVARBPROC;
glIsProgramARB: PFNGLISPROGRAMARBPROC;
glBindBufferARB: PFNGLBINDBUFFERARBPROC;
glDeleteBuffersARB: PFNGLDELETEBUFFERSARBPROC;
glGenBuffersARB: PFNGLGENBUFFERSARBPROC;
glIsBufferARB: PFNGLISBUFFERARBPROC;
glBufferDataARB: PFNGLBUFFERDATAARBPROC;
glBufferSubDataARB: PFNGLBUFFERSUBDATAARBPROC;
glGetBufferSubDataARB: PFNGLGETBUFFERSUBDATAARBPROC;
glMapBufferARB: PFNGLMAPBUFFERARBPROC;
glUnmapBufferARB: PFNGLUNMAPBUFFERARBPROC;
glGetBufferParameterivARB: PFNGLGETBUFFERPARAMETERIVARBPROC;
glGetBufferPointervARB: PFNGLGETBUFFERPOINTERVARBPROC;
glGenQueriesARB: PFNGLGENQUERIESARBPROC;
glDeleteQueriesARB: PFNGLDELETEQUERIESARBPROC;
glIsQueryARB: PFNGLISQUERYARBPROC;
glBeginQueryARB: PFNGLBEGINQUERYARBPROC;
glEndQueryARB: PFNGLENDQUERYARBPROC;
glGetQueryivARB: PFNGLGETQUERYIVARBPROC;
glGetQueryObjectivARB: PFNGLGETQUERYOBJECTIVARBPROC;
glGetQueryObjectuivARB: PFNGLGETQUERYOBJECTUIVARBPROC;
glDeleteObjectARB: PFNGLDELETEOBJECTARBPROC;
glGetHandleARB: PFNGLGETHANDLEARBPROC;
glDetachObjectARB: PFNGLDETACHOBJECTARBPROC;
glCreateShaderObjectARB: PFNGLCREATESHADEROBJECTARBPROC;
glShaderSourceARB: PFNGLSHADERSOURCEARBPROC;
glCompileShaderARB: PFNGLCOMPILESHADERARBPROC;
glCreateProgramObjectARB: PFNGLCREATEPROGRAMOBJECTARBPROC;
glAttachObjectARB: PFNGLATTACHOBJECTARBPROC;
glLinkProgramARB: PFNGLLINKPROGRAMARBPROC;
glUseProgramObjectARB: PFNGLUSEPROGRAMOBJECTARBPROC;
glValidateProgramARB: PFNGLVALIDATEPROGRAMARBPROC;
glUniform1fARB: PFNGLUNIFORM1FARBPROC;
glUniform2fARB: PFNGLUNIFORM2FARBPROC;
glUniform3fARB: PFNGLUNIFORM3FARBPROC;
glUniform4fARB: PFNGLUNIFORM4FARBPROC;
glUniform1iARB: PFNGLUNIFORM1IARBPROC;
glUniform2iARB: PFNGLUNIFORM2IARBPROC;
glUniform3iARB: PFNGLUNIFORM3IARBPROC;
glUniform4iARB: PFNGLUNIFORM4IARBPROC;
glUniform1fvARB: PFNGLUNIFORM1FVARBPROC;
glUniform2fvARB: PFNGLUNIFORM2FVARBPROC;
glUniform3fvARB: PFNGLUNIFORM3FVARBPROC;
glUniform4fvARB: PFNGLUNIFORM4FVARBPROC;
glUniform1ivARB: PFNGLUNIFORM1IVARBPROC;
glUniform2ivARB: PFNGLUNIFORM2IVARBPROC;
glUniform3ivARB: PFNGLUNIFORM3IVARBPROC;
glUniform4ivARB: PFNGLUNIFORM4IVARBPROC;
glUniformMatrix2fvARB: PFNGLUNIFORMMATRIX2FVARBPROC;
glUniformMatrix3fvARB: PFNGLUNIFORMMATRIX3FVARBPROC;
glUniformMatrix4fvARB: PFNGLUNIFORMMATRIX4FVARBPROC;
glGetObjectParameterfvARB: PFNGLGETOBJECTPARAMETERFVARBPROC;
glGetObjectParameterivARB: PFNGLGETOBJECTPARAMETERIVARBPROC;
glGetInfoLogARB: PFNGLGETINFOLOGARBPROC;
glGetAttachedObjectsARB: PFNGLGETATTACHEDOBJECTSARBPROC;
glGetUniformLocationARB: PFNGLGETUNIFORMLOCATIONARBPROC;
glGetActiveUniformARB: PFNGLGETACTIVEUNIFORMARBPROC;
glGetUniformfvARB: PFNGLGETUNIFORMFVARBPROC;
glGetUniformivARB: PFNGLGETUNIFORMIVARBPROC;
glGetShaderSourceARB: PFNGLGETSHADERSOURCEARBPROC;
glBindAttribLocationARB: PFNGLBINDATTRIBLOCATIONARBPROC;
glGetActiveAttribARB: PFNGLGETACTIVEATTRIBARBPROC;
glGetAttribLocationARB: PFNGLGETATTRIBLOCATIONARBPROC;
glDrawBuffersARB: PFNGLDRAWBUFFERSARBPROC;
glClampColorARB: PFNGLCLAMPCOLORARBPROC;
glDrawArraysInstancedARB: PFNGLDRAWARRAYSINSTANCEDARBPROC;
glDrawElementsInstancedARB: PFNGLDRAWELEMENTSINSTANCEDARBPROC;
glIsRenderbuffer: PFNGLISRENDERBUFFERPROC;
glBindRenderbuffer: PFNGLBINDRENDERBUFFERPROC;
glDeleteRenderbuffers: PFNGLDELETERENDERBUFFERSPROC;
glGenRenderbuffers: PFNGLGENRENDERBUFFERSPROC;
glRenderbufferStorage: PFNGLRENDERBUFFERSTORAGEPROC;
glRenderbufferStorageMultisample: PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC;
glGetRenderbufferParameteriv: PFNGLGETRENDERBUFFERPARAMETERIVPROC;
glIsFramebuffer: PFNGLISFRAMEBUFFERPROC;
glBindFramebuffer: PFNGLBINDFRAMEBUFFERPROC;
glDeleteFramebuffers: PFNGLDELETEFRAMEBUFFERSPROC;
glGenFramebuffers: PFNGLGENFRAMEBUFFERSPROC;
glCheckFramebufferStatus: PFNGLCHECKFRAMEBUFFERSTATUSPROC;
glFramebufferTexture1D: PFNGLFRAMEBUFFERTEXTURE1DPROC;
glFramebufferTexture2D: PFNGLFRAMEBUFFERTEXTURE2DPROC;
glFramebufferTexture3D: PFNGLFRAMEBUFFERTEXTURE3DPROC;
glFramebufferTextureLayer: PFNGLFRAMEBUFFERTEXTURELAYERPROC;
glFramebufferRenderbuffer: PFNGLFRAMEBUFFERRENDERBUFFERPROC;
glGetFramebufferAttachmentParameteriv: PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC;
glBlitFramebuffer: PFNGLBLITFRAMEBUFFERPROC;
glGenerateMipmap: PFNGLGENERATEMIPMAPPROC;
glProgramParameteriARB: PFNGLPROGRAMPARAMETERIARBPROC;
glFramebufferTextureARB: PFNGLFRAMEBUFFERTEXTUREARBPROC;
glFramebufferTextureLayerARB: PFNGLFRAMEBUFFERTEXTURELAYERARBPROC;
glFramebufferTextureFaceARB: PFNGLFRAMEBUFFERTEXTUREFACEARBPROC;
glVertexAttribDivisorARB: PFNGLVERTEXATTRIBDIVISORARBPROC;
glMapBufferRange: PFNGLMAPBUFFERRANGEPROC;
glFlushMappedBufferRange: PFNGLFLUSHMAPPEDBUFFERRANGEPROC;
glTexBufferARB: PFNGLTEXBUFFERARBPROC;
glBindVertexArray: PFNGLBINDVERTEXARRAYPROC;
glDeleteVertexArrays: PFNGLDELETEVERTEXARRAYSPROC;
glGenVertexArrays: PFNGLGENVERTEXARRAYSPROC;
glIsVertexArray: PFNGLISVERTEXARRAYPROC;
glGetUniformIndices: PFNGLGETUNIFORMINDICESPROC;
glGetActiveUniformsiv: PFNGLGETACTIVEUNIFORMSIVPROC;
glGetActiveUniformName: PFNGLGETACTIVEUNIFORMNAMEPROC;
glGetUniformBlockIndex: PFNGLGETUNIFORMBLOCKINDEXPROC;
glGetActiveUniformBlockiv: PFNGLGETACTIVEUNIFORMBLOCKIVPROC;
glGetActiveUniformBlockName: PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC;
glUniformBlockBinding: PFNGLUNIFORMBLOCKBINDINGPROC;
glCopyBufferSubData: PFNGLCOPYBUFFERSUBDATAPROC;
glDrawElementsBaseVertex: PFNGLDRAWELEMENTSBASEVERTEXPROC;
glDrawRangeElementsBaseVertex: PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC;
glDrawElementsInstancedBaseVertex: PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC;
glMultiDrawElementsBaseVertex: PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC;
glProvokingVertex: PFNGLPROVOKINGVERTEXPROC;
glFenceSync: PFNGLFENCESYNCPROC;
glIsSync: PFNGLISSYNCPROC;
glDeleteSync: PFNGLDELETESYNCPROC;
glClientWaitSync: PFNGLCLIENTWAITSYNCPROC;
glWaitSync: PFNGLWAITSYNCPROC;
glGetInteger64v: PFNGLGETINTEGER64VPROC;
glGetSynciv: PFNGLGETSYNCIVPROC;
glTexImage2DMultisample: PFNGLTEXIMAGE2DMULTISAMPLEPROC;
glTexImage3DMultisample: PFNGLTEXIMAGE3DMULTISAMPLEPROC;
glGetMultisamplefv: PFNGLGETMULTISAMPLEFVPROC;
glSampleMaski: PFNGLSAMPLEMASKIPROC;
glBlendEquationiARB: PFNGLBLENDEQUATIONIARBPROC;
glBlendEquationSeparateiARB: PFNGLBLENDEQUATIONSEPARATEIARBPROC;
glBlendFunciARB: PFNGLBLENDFUNCIARBPROC;
glBlendFuncSeparateiARB: PFNGLBLENDFUNCSEPARATEIARBPROC;
glMinSampleShadingARB: PFNGLMINSAMPLESHADINGARBPROC;
glBindFragDataLocationIndexed: PFNGLBINDFRAGDATALOCATIONINDEXEDPROC;
glGetFragDataIndex: PFNGLGETFRAGDATAINDEXPROC;
glGenSamplers: PFNGLGENSAMPLERSPROC;
glDeleteSamplers: PFNGLDELETESAMPLERSPROC;
glIsSampler: PFNGLISSAMPLERPROC;
glBindSampler: PFNGLBINDSAMPLERPROC;
glSamplerParameteri: PFNGLSAMPLERPARAMETERIPROC;
glSamplerParameteriv: PFNGLSAMPLERPARAMETERIVPROC;
glSamplerParameterf: PFNGLSAMPLERPARAMETERFPROC;
glSamplerParameterfv: PFNGLSAMPLERPARAMETERFVPROC;
glSamplerParameterIiv: PFNGLSAMPLERPARAMETERIIVPROC;
glSamplerParameterIuiv: PFNGLSAMPLERPARAMETERIUIVPROC;
glGetSamplerParameteriv: PFNGLGETSAMPLERPARAMETERIVPROC;
glGetSamplerParameterIiv: PFNGLGETSAMPLERPARAMETERIIVPROC;
glGetSamplerParameterfv: PFNGLGETSAMPLERPARAMETERFVPROC;
glGetSamplerParameterIfv: PFNGLGETSAMPLERPARAMETERIFVPROC;
glQueryCounter: PFNGLQUERYCOUNTERPROC;
glGetQueryObjecti64v: PFNGLGETQUERYOBJECTI64VPROC;
glGetQueryObjectui64v: PFNGLGETQUERYOBJECTUI64VPROC;
glVertexP2ui: PFNGLVERTEXP2UIPROC;
glVertexP2uiv: PFNGLVERTEXP2UIVPROC;
glVertexP3ui: PFNGLVERTEXP3UIPROC;
glVertexP3uiv: PFNGLVERTEXP3UIVPROC;
glVertexP4ui: PFNGLVERTEXP4UIPROC;
glVertexP4uiv: PFNGLVERTEXP4UIVPROC;
glTexCoordP1ui: PFNGLTEXCOORDP1UIPROC;
glTexCoordP1uiv: PFNGLTEXCOORDP1UIVPROC;
glTexCoordP2ui: PFNGLTEXCOORDP2UIPROC;
glTexCoordP2uiv: PFNGLTEXCOORDP2UIVPROC;
glTexCoordP3ui: PFNGLTEXCOORDP3UIPROC;
glTexCoordP3uiv: PFNGLTEXCOORDP3UIVPROC;
glTexCoordP4ui: PFNGLTEXCOORDP4UIPROC;
glTexCoordP4uiv: PFNGLTEXCOORDP4UIVPROC;
glMultiTexCoordP1ui: PFNGLMULTITEXCOORDP1UIPROC;
glMultiTexCoordP1uiv: PFNGLMULTITEXCOORDP1UIVPROC;
glMultiTexCoordP2ui: PFNGLMULTITEXCOORDP2UIPROC;
glMultiTexCoordP2uiv: PFNGLMULTITEXCOORDP2UIVPROC;
glMultiTexCoordP3ui: PFNGLMULTITEXCOORDP3UIPROC;
glMultiTexCoordP3uiv: PFNGLMULTITEXCOORDP3UIVPROC;
glMultiTexCoordP4ui: PFNGLMULTITEXCOORDP4UIPROC;
glMultiTexCoordP4uiv: PFNGLMULTITEXCOORDP4UIVPROC;
glNormalP3ui: PFNGLNORMALP3UIPROC;
glNormalP3uiv: PFNGLNORMALP3UIVPROC;
glColorP3ui: PFNGLCOLORP3UIPROC;
glColorP3uiv: PFNGLCOLORP3UIVPROC;
glColorP4ui: PFNGLCOLORP4UIPROC;
glColorP4uiv: PFNGLCOLORP4UIVPROC;
glSecondaryColorP3ui: PFNGLSECONDARYCOLORP3UIPROC;
glSecondaryColorP3uiv: PFNGLSECONDARYCOLORP3UIVPROC;
glVertexAttribP1ui: PFNGLVERTEXATTRIBP1UIPROC;
glVertexAttribP1uiv: PFNGLVERTEXATTRIBP1UIVPROC;
glVertexAttribP2ui: PFNGLVERTEXATTRIBP2UIPROC;
glVertexAttribP2uiv: PFNGLVERTEXATTRIBP2UIVPROC;
glVertexAttribP3ui: PFNGLVERTEXATTRIBP3UIPROC;
glVertexAttribP3uiv: PFNGLVERTEXATTRIBP3UIVPROC;
glVertexAttribP4ui: PFNGLVERTEXATTRIBP4UIPROC;
glVertexAttribP4uiv: PFNGLVERTEXATTRIBP4UIVPROC;
glDrawArraysIndirect: PFNGLDRAWARRAYSINDIRECTPROC;
glDrawElementsIndirect: PFNGLDRAWELEMENTSINDIRECTPROC;
glUniform1d: PFNGLUNIFORM1DPROC;
glUniform2d: PFNGLUNIFORM2DPROC;
glUniform3d: PFNGLUNIFORM3DPROC;
glUniform4d: PFNGLUNIFORM4DPROC;
glUniform1dv: PFNGLUNIFORM1DVPROC;
glUniform2dv: PFNGLUNIFORM2DVPROC;
glUniform3dv: PFNGLUNIFORM3DVPROC;
glUniform4dv: PFNGLUNIFORM4DVPROC;
glUniformMatrix2dv: PFNGLUNIFORMMATRIX2DVPROC;
glUniformMatrix3dv: PFNGLUNIFORMMATRIX3DVPROC;
glUniformMatrix4dv: PFNGLUNIFORMMATRIX4DVPROC;
glUniformMatrix2x3dv: PFNGLUNIFORMMATRIX2X3DVPROC;
glUniformMatrix2x4dv: PFNGLUNIFORMMATRIX2X4DVPROC;
glUniformMatrix3x2dv: PFNGLUNIFORMMATRIX3X2DVPROC;
glUniformMatrix3x4dv: PFNGLUNIFORMMATRIX3X4DVPROC;
glUniformMatrix4x2dv: PFNGLUNIFORMMATRIX4X2DVPROC;
glUniformMatrix4x3dv: PFNGLUNIFORMMATRIX4X3DVPROC;
glGetUniformdv: PFNGLGETUNIFORMDVPROC;
glProgramUniform1dEXT: PFNGLPROGRAMUNIFORM1DEXTPROC;
glProgramUniform2dEXT: PFNGLPROGRAMUNIFORM2DEXTPROC;
glProgramUniform3dEXT: PFNGLPROGRAMUNIFORM3DEXTPROC;
glProgramUniform4dEXT: PFNGLPROGRAMUNIFORM4DEXTPROC;
glProgramUniform1dvEXT: PFNGLPROGRAMUNIFORM1DVEXTPROC;
glProgramUniform2dvEXT: PFNGLPROGRAMUNIFORM2DVEXTPROC;
glProgramUniform3dvEXT: PFNGLPROGRAMUNIFORM3DVEXTPROC;
glProgramUniform4dvEXT: PFNGLPROGRAMUNIFORM4DVEXTPROC;
glProgramUniformMatrix2dvEXT: PFNGLPROGRAMUNIFORMMATRIX2DVEXTPROC;
glProgramUniformMatrix3dvEXT: PFNGLPROGRAMUNIFORMMATRIX3DVEXTPROC;
glProgramUniformMatrix4dvEXT: PFNGLPROGRAMUNIFORMMATRIX4DVEXTPROC;
glProgramUniformMatrix2x3dvEXT: PFNGLPROGRAMUNIFORMMATRIX2X3DVEXTPROC;
glProgramUniformMatrix2x4dvEXT: PFNGLPROGRAMUNIFORMMATRIX2X4DVEXTPROC;
glProgramUniformMatrix3x2dvEXT: PFNGLPROGRAMUNIFORMMATRIX3X2DVEXTPROC;
glProgramUniformMatrix3x4dvEXT: PFNGLPROGRAMUNIFORMMATRIX3X4DVEXTPROC;
glProgramUniformMatrix4x2dvEXT: PFNGLPROGRAMUNIFORMMATRIX4X2DVEXTPROC;
glProgramUniformMatrix4x3dvEXT: PFNGLPROGRAMUNIFORMMATRIX4X3DVEXTPROC;
glGetSubroutineUniformLocation: PFNGLGETSUBROUTINEUNIFORMLOCATIONPROC;
glGetSubroutineIndex: PFNGLGETSUBROUTINEINDEXPROC;
glGetActiveSubroutineUniformiv: PFNGLGETACTIVESUBROUTINEUNIFORMIVPROC;
glGetActiveSubroutineUniformName: PFNGLGETACTIVESUBROUTINEUNIFORMNAMEPROC;
glGetActiveSubroutineName: PFNGLGETACTIVESUBROUTINENAMEPROC;
glUniformSubroutinesuiv: PFNGLUNIFORMSUBROUTINESUIVPROC;
glGetUniformSubroutineuiv: PFNGLGETUNIFORMSUBROUTINEUIVPROC;
glGetProgramStageiv: PFNGLGETPROGRAMSTAGEIVPROC;
glPatchParameteri: PFNGLPATCHPARAMETERIPROC;
glPatchParameterfv: PFNGLPATCHPARAMETERFVPROC;
glBindTransformFeedback: PFNGLBINDTRANSFORMFEEDBACKPROC;
glDeleteTransformFeedbacks: PFNGLDELETETRANSFORMFEEDBACKSPROC;
glGenTransformFeedbacks: PFNGLGENTRANSFORMFEEDBACKSPROC;
glIsTransformFeedback: PFNGLISTRANSFORMFEEDBACKPROC;
glPauseTransformFeedback: PFNGLPAUSETRANSFORMFEEDBACKPROC;
glResumeTransformFeedback: PFNGLRESUMETRANSFORMFEEDBACKPROC;
glDrawTransformFeedback: PFNGLDRAWTRANSFORMFEEDBACKPROC;
glDrawTransformFeedbackStream: PFNGLDRAWTRANSFORMFEEDBACKSTREAMPROC;
glBeginQueryIndexed: PFNGLBEGINQUERYINDEXEDPROC;
glEndQueryIndexed: PFNGLENDQUERYINDEXEDPROC;
glGetQueryIndexediv: PFNGLGETQUERYINDEXEDIVPROC;
glReleaseShaderCompiler: PFNGLRELEASESHADERCOMPILERPROC;
glShaderBinary: PFNGLSHADERBINARYPROC;
glGetShaderPrecisionFormat: PFNGLGETSHADERPRECISIONFORMATPROC;
glDepthRangef: PFNGLDEPTHRANGEFPROC;
glClearDepthf: PFNGLCLEARDEPTHFPROC;
glGetProgramBinary: PFNGLGetProgramBinaryPROC;
glProgramBinary: PFNGLProgramBinaryPROC;
glProgramParameteri: PFNGLProgramParameteriPROC;
glUseProgramStages: PFNGLUSEPROGRAMSTAGESPROC;
glActiveShaderProgram: PFNGLACTIVESHADERPROGRAMPROC;
glCreateShaderProgramv: PFNGLCREATESHADERPROGRAMVPROC;
glBindProgramPipeline: PFNGLBINDPROGRAMPIPELINEPROC;
glDeleteProgramPipelines: PFNGLDELETEPROGRAMPIPELINESPROC;
glGenProgramPipelines: PFNGLGENPROGRAMPIPELINESPROC;
glIsProgramPipeline: PFNGLISPROGRAMPIPELINEPROC;
glGetProgramPipelineiv: PFNGLGETPROGRAMPIPELINEIVPROC;
glProgramUniform1i: PFNGLPROGRAMUNIFORM1IPROC;
glProgramUniform1iv: PFNGLPROGRAMUNIFORM1IVPROC;
glProgramUniform1f: PFNGLPROGRAMUNIFORM1FPROC;
glProgramUniform1fv: PFNGLPROGRAMUNIFORM1FVPROC;
glProgramUniform1d: PFNGLPROGRAMUNIFORM1DPROC;
glProgramUniform1dv: PFNGLPROGRAMUNIFORM1DVPROC;
glProgramUniform1ui: PFNGLPROGRAMUNIFORM1UIPROC;
glProgramUniform1uiv: PFNGLPROGRAMUNIFORM1UIVPROC;
glProgramUniform2i: PFNGLPROGRAMUNIFORM2IPROC;
glProgramUniform2iv: PFNGLPROGRAMUNIFORM2IVPROC;
glProgramUniform2f: PFNGLPROGRAMUNIFORM2FPROC;
glProgramUniform2fv: PFNGLPROGRAMUNIFORM2FVPROC;
glProgramUniform2d: PFNGLPROGRAMUNIFORM2DPROC;
glProgramUniform2dv: PFNGLPROGRAMUNIFORM2DVPROC;
glProgramUniform2ui: PFNGLPROGRAMUNIFORM2UIPROC;
glProgramUniform2uiv: PFNGLPROGRAMUNIFORM2UIVPROC;
glProgramUniform3i: PFNGLPROGRAMUNIFORM3IPROC;
glProgramUniform3iv: PFNGLPROGRAMUNIFORM3IVPROC;
glProgramUniform3f: PFNGLPROGRAMUNIFORM3FPROC;
glProgramUniform3fv: PFNGLPROGRAMUNIFORM3FVPROC;
glProgramUniform3d: PFNGLPROGRAMUNIFORM3DPROC;
glProgramUniform3dv: PFNGLPROGRAMUNIFORM3DVPROC;
glProgramUniform3ui: PFNGLPROGRAMUNIFORM3UIPROC;
glProgramUniform3uiv: PFNGLPROGRAMUNIFORM3UIVPROC;
glProgramUniform4i: PFNGLPROGRAMUNIFORM4IPROC;
glProgramUniform4iv: PFNGLPROGRAMUNIFORM4IVPROC;
glProgramUniform4f: PFNGLPROGRAMUNIFORM4FPROC;
glProgramUniform4fv: PFNGLPROGRAMUNIFORM4FVPROC;
glProgramUniform4d: PFNGLPROGRAMUNIFORM4DPROC;
glProgramUniform4dv: PFNGLPROGRAMUNIFORM4DVPROC;
glProgramUniform4ui: PFNGLPROGRAMUNIFORM4UIPROC;
glProgramUniform4uiv: PFNGLPROGRAMUNIFORM4UIVPROC;
glProgramUniformMatrix2fv: PFNGLPROGRAMUNIFORMMATRIX2FVPROC;
glProgramUniformMatrix3fv: PFNGLPROGRAMUNIFORMMATRIX3FVPROC;
glProgramUniformMatrix4fv: PFNGLPROGRAMUNIFORMMATRIX4FVPROC;
glProgramUniformMatrix2dv: PFNGLPROGRAMUNIFORMMATRIX2DVPROC;
glProgramUniformMatrix3dv: PFNGLPROGRAMUNIFORMMATRIX3DVPROC;
glProgramUniformMatrix4dv: PFNGLPROGRAMUNIFORMMATRIX4DVPROC;
glProgramUniformMatrix2x3fv: PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC;
glProgramUniformMatrix3x2fv: PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC;
glProgramUniformMatrix2x4fv: PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC;
glProgramUniformMatrix4x2fv: PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC;
glProgramUniformMatrix3x4fv: PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC;
glProgramUniformMatrix4x3fv: PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC;
glProgramUniformMatrix2x3dv: PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC;
glProgramUniformMatrix3x2dv: PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC;
glProgramUniformMatrix2x4dv: PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC;
glProgramUniformMatrix4x2dv: PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC;
glProgramUniformMatrix3x4dv: PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC;
glProgramUniformMatrix4x3dv: PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC;
glValidateProgramPipeline: PFNGLVALIDATEPROGRAMPIPELINEPROC;
glGetProgramPipelineInfoLog: PFNGLGETPROGRAMPIPELINEINFOLOGPROC;
glVertexAttribL1d: PFNGLVERTEXATTRIBL1DPROC;
glVertexAttribL2d: PFNGLVERTEXATTRIBL2DPROC;
glVertexAttribL3d: PFNGLVERTEXATTRIBL3DPROC;
glVertexAttribL4d: PFNGLVERTEXATTRIBL4DPROC;
glVertexAttribL1dv: PFNGLVERTEXATTRIBL1DVPROC;
glVertexAttribL2dv: PFNGLVERTEXATTRIBL2DVPROC;
glVertexAttribL3dv: PFNGLVERTEXATTRIBL3DVPROC;
glVertexAttribL4dv: PFNGLVERTEXATTRIBL4DVPROC;
glVertexAttribLPointer: PFNGLVERTEXATTRIBLPOINTERPROC;
glGetVertexAttribLdv: PFNGLGETVERTEXATTRIBLDVPROC;
glVertexArrayVertexAttribLOffsetEXT: PFNGLVERTEXARRAYVERTEXATTRIBLOFFSETEXTPROC;
glViewportArrayv: PFNGLVIEWPORTARRAYVPROC;
glViewportIndexedf: PFNGLVIEWPORTINDEXEDFPROC;
glViewportIndexedfv: PFNGLVIEWPORTINDEXEDFVPROC;
glScissorArrayv: PFNGLSCISSORARRAYVPROC;
glScissorIndexed: PFNGLSCISSORINDEXEDPROC;
glScissorIndexedv: PFNGLSCISSORINDEXEDVPROC;
glDepthRangeArrayv: PFNGLDEPTHRANGEARRAYVPROC;
glDepthRangeIndexed: PFNGLDEPTHRANGEINDEXEDPROC;
glGetFloati_v: PFNGLGETFLOATI_VPROC;
glGetDoublei_v: PFNGLGETDOUBLEI_VPROC;
glDebugMessageControlARB: PFNGLDEBUGMESSAGECONTROLARBPROC;
glDebugMessageInsertARB: PFNGLDEBUGMESSAGEINSERTARBPROC;
glDebugMessageCallbackARB: PFNGLDEBUGMESSAGECALLBACKARBPROC;
glGetDebugMessageLogARB: PFNGLGETDEBUGMESSAGELOGARBPROC;
glGetGraphicsResetStatusARB: PFNGLGETGRAPHICSRESETSTATUSARBPROC;
glGetnMapdvARB: PFNGLGETNMAPDVARBPROC;
glGetnMapfvARB: PFNGLGETNMAPFVARBPROC;
glGetnMapivARB: PFNGLGETNMAPIVARBPROC;
glGetnPixelMapfvARB: PFNGLGETNPIXELMAPFVARBPROC;
glGetnPixelMapuivARB: PFNGLGETNPIXELMAPUIVARBPROC;
glGetnPixelMapusvARB: PFNGLGETNPIXELMAPUSVARBPROC;
glGetnPolygonStippleARB: PFNGLGETNPOLYGONSTIPPLEARBPROC;
glGetnColorTableARB: PFNGLGETNCOLORTABLEARBPROC;
glGetnConvolutionFilterARB: PFNGLGETNCONVOLUTIONFILTERARBPROC;
glGetnSeparableFilterARB: PFNGLGETNSEPARABLEFILTERARBPROC;
glGetnHistogramARB: PFNGLGETNHISTOGRAMARBPROC;
glGetnMinmaxARB: PFNGLGETNMINMAXARBPROC;
glGetnTexImageARB: PFNGLGETNTEXIMAGEARBPROC;
glReadnPixelsARB: PFNGLREADNPIXELSARBPROC;
glGetnCompressedTexImageARB: PFNGLGETNCOMPRESSEDTEXIMAGEARBPROC;
glGetnUniformfvARB: PFNGLGETNUNIFORMFVARBPROC;
glGetnUniformivARB: PFNGLGETNUNIFORMIVARBPROC;
glGetnUniformuivARB: PFNGLGETNUNIFORMUIVARBPROC;
glGetnUniformdvARB: PFNGLGETNUNIFORMDVARBPROC;
glArrayElementArrayEXT: PFNGLARRAYELEMENTARRAYEXTPROC;
glAddSwapHintRectWIN: PFNGLADDSWAPHINTRECTWINPROC;
glBlendColorEXT: PFNGLBLENDCOLOREXTPROC;
glPolygonOffsetEXT: PFNGLPOLYGONOFFSETEXTPROC;
glTexImage3DEXT: PFNGLTEXIMAGE3DEXTPROC;
glTexSubImage1DEXT: PFNGLTEXSUBIMAGE1DEXTPROC;
glTexSubImage2DEXT: PFNGLTEXSUBIMAGE2DEXTPROC;
glTexSubImage3DEXT: PFNGLTEXSUBIMAGE3DEXTPROC;
glCopyTexImage1DEXT: PFNGLCOPYTEXIMAGE1DEXTPROC;
glCopyTexImage2DEXT: PFNGLCOPYTEXIMAGE2DEXTPROC;
glCopyTexSubImage1DEXT: PFNGLCOPYTEXSUBIMAGE1DEXTPROC;
glCopyTexSubImage2DEXT: PFNGLCOPYTEXSUBIMAGE2DEXTPROC;
glCopyTexSubImage3DEXT: PFNGLCOPYTEXSUBIMAGE3DEXTPROC;
glGenTexturesEXT: PFNGLGENTEXTURESEXTPROC;
glDeleteTexturesEXT: PFNGLDELETETEXTURESEXTPROC;
glBindTextureEXT: PFNGLBINDTEXTUREEXTPROC;
glPrioritizeTexturesEXT: PFNGLPRIORITIZETEXTURESEXTPROC;
glAreTexturesResidentEXT: PFNGLARETEXTURESRESIDENTEXTPROC;
glIsTextureEXT: PFNGLISTEXTUREEXTPROC;
glSampleMaskSGIS: PFNGLSAMPLEMASKSGISPROC;
glSamplePatternSGIS: PFNGLSAMPLEPATTERNSGISPROC;
glBlendEquationEXT: PFNGLBLENDEQUATIONEXTPROC;
glColorTableEXT: PFNGLCOLORTABLEEXTPROC;
glColorSubTableExt: PFNGLCOLORSUBTABLEEXTPROC;
glGetColorTableEXT: PFNGLGETCOLORTABLEEXTPROC;
glGetColorTableParameterfvEXT: PFNGLGETCOLORTABLEPARAMETERFVEXTPROC;
glGetColorTableParameterivEXT: PFNGLGETCOLORTABLEPARAMETERIVEXTPROC;
glIndexMaterialEXT: PFNGLINDEXMATERIALEXTPROC;
glIndexFuncEXT: PFNGLINDEXFUNCEXTPROC;
glLockArraysEXT: PFNGLLOCKARRAYSEXTPROC;
glUnlockArraysEXT: PFNGLUNLOCKARRAYSEXTPROC;
glDrawRangeElementsEXT: PFNGLDRAWRANGEELEMENTSEXTPROC;
glBeginSceneEXT: PFNGLBEGINSCENEEXTPROC;
glEndSceneEXT: PFNGLENDSCENEEXTPROC;
glSecondaryColor3bEXT: PFNGLSECONDARYCOLOR3BEXTPROC;
glSecondaryColor3bvEXT: PFNGLSECONDARYCOLOR3BVEXTPROC;
glSecondaryColor3dEXT: PFNGLSECONDARYCOLOR3DEXTPROC;
glSecondaryColor3dvEXT: PFNGLSECONDARYCOLOR3DVEXTPROC;
glSecondaryColor3fEXT: PFNGLSECONDARYCOLOR3FEXTPROC;
glSecondaryColor3fvEXT: PFNGLSECONDARYCOLOR3FVEXTPROC;
glSecondaryColor3iEXT: PFNGLSECONDARYCOLOR3IEXTPROC;
glSecondaryColor3ivEXT: PFNGLSECONDARYCOLOR3IVEXTPROC;
glSecondaryColor3sEXT: PFNGLSECONDARYCOLOR3SEXTPROC;
glSecondaryColor3svEXT: PFNGLSECONDARYCOLOR3SVEXTPROC;
glSecondaryColor3ubEXT: PFNGLSECONDARYCOLOR3UBEXTPROC;
glSecondaryColor3ubvEXT: PFNGLSECONDARYCOLOR3UBVEXTPROC;
glSecondaryColor3uiEXT: PFNGLSECONDARYCOLOR3UIEXTPROC;
glSecondaryColor3uivEXT: PFNGLSECONDARYCOLOR3UIVEXTPROC;
glSecondaryColor3usEXT: PFNGLSECONDARYCOLOR3USEXTPROC;
glSecondaryColor3usvEXT: PFNGLSECONDARYCOLOR3USVEXTPROC;
glSecondaryColorPointerEXT: PFNGLSECONDARYCOLORPOINTEREXTPROC;
glMultiDrawArraysEXT: PFNGLMULTIDRAWARRAYSEXTPROC;
glMultiDrawElementsEXT: PFNGLMULTIDRAWELEMENTSEXTPROC;
glFogCoordfEXT: PFNGLFOGCOORDFEXTPROC;
glFogCoordfvEXT: PFNGLFOGCOORDFVEXTPROC;
glFogCoorddEXT: PFNGLFOGCOORDDEXTPROC;
glFogCoorddvEXT: PFNGLFOGCOORDDVEXTPROC;
glFogCoordPointerEXT: PFNGLFOGCOORDPOINTEREXTPROC;
glBlendFuncSeparateEXT: PFNGLBLENDFUNCSEPARATEEXTPROC;
glFlushVertexArrayRangeNV: PFNGLFLUSHVERTEXARRAYRANGENVPROC;
glVertexArrayRangeNV: PFNGLVERTEXARRAYRANGENVPROC;
wglAllocateMemoryNV: PFNWGLALLOCATEMEMORYNVPROC;
wglFreeMemoryNV: PFNWGLFREEMEMORYNVPROC;
glCombinerParameterfvNV: PFNGLCOMBINERPARAMETERFVNVPROC;
glCombinerParameterfNV: PFNGLCOMBINERPARAMETERFNVPROC;
glCombinerParameterivNV: PFNGLCOMBINERPARAMETERIVNVPROC;
glCombinerParameteriNV: PFNGLCOMBINERPARAMETERINVPROC;
glCombinerInputNV: PFNGLCOMBINERINPUTNVPROC;
glCombinerOutputNV: PFNGLCOMBINEROUTPUTNVPROC;
glFinalCombinerInputNV: PFNGLFINALCOMBINERINPUTNVPROC;
glGetCombinerInputParameterfvNV: PFNGLGETCOMBINERINPUTPARAMETERFVNVPROC;
glGetCombinerInputParameterivNV: PFNGLGETCOMBINERINPUTPARAMETERIVNVPROC;
glGetCombinerOutputParameterfvNV: PFNGLGETCOMBINEROUTPUTPARAMETERFVNVPROC;
glGetCombinerOutputParameterivNV: PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC;
glGetFinalCombinerInputParameterfvNV: PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC;
glGetFinalCombinerInputParameterivNV: PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC;
glResizeBuffersMESA: PFNGLRESIZEBUFFERSMESAPROC;
glTbufferMask3DFX: PFNGLTBUFFERMASK3DFXPROC;
glSampleMaskEXT: PFNGLSAMPLEMASKEXTPROC;
glSamplePatternEXT: PFNGLSAMPLEPATTERNEXTPROC;
glTextureColorMaskSGIS: PFNGLTEXTURECOLORMASKSGISPROC;
glGenFencesNV: PFNGLGENFENCESNVPROC;
glDeleteFencesNV: PFNGLDELETEFENCESNVPROC;
glSetFenceNV: PFNGLSETFENCENVPROC;
glTestFenceNV: PFNGLTESTFENCENVPROC;
glFinishFenceNV: PFNGLFINISHFENCENVPROC;
glIsFenceNV: PFNGLISFENCENVPROC;
glGetFenceivNV: PFNGLGETFENCEIVNVPROC;
glAreProgramsResidentNV: PFNGLAREPROGRAMSRESIDENTNVPROC;
glBindProgramNV: PFNGLBINDPROGRAMNVPROC;
glDeleteProgramsNV: PFNGLDELETEPROGRAMSNVPROC;
glExecuteProgramNV: PFNGLEXECUTEPROGRAMNVPROC;
glGenProgramsNV: PFNGLGENPROGRAMSNVPROC;
glGetProgramParameterdvNV: PFNGLGETPROGRAMPARAMETERDVNVPROC;
glGetProgramParameterfvNV: PFNGLGETPROGRAMPARAMETERFVNVPROC;
glGetProgramivNV: PFNGLGETPROGRAMIVNVPROC;
glGetProgramStringNV: PFNGLGETPROGRAMSTRINGNVPROC;
glGetTrackMatrixivNV: PFNGLGETTRACKMATRIXIVNVPROC;
glGetVertexAttribdvNV: PFNGLGETVERTEXATTRIBDVNVPROC;
glGetVertexAttribfvNV: PFNGLGETVERTEXATTRIBFVNVPROC;
glGetVertexAttribivNV: PFNGLGETVERTEXATTRIBIVNVPROC;
glGetVertexAttribPointervNV: PFNGLGETVERTEXATTRIBPOINTERVNVPROC;
glIsProgramNV: PFNGLISPROGRAMNVPROC;
glLoadProgramNV: PFNGLLOADPROGRAMNVPROC;
glProgramParameter4dNV: PFNGLPROGRAMPARAMETER4DNVPROC;
glProgramParameter4dvNV: PFNGLPROGRAMPARAMETER4DVNVPROC;
glProgramParameter4fNV: PFNGLPROGRAMPARAMETER4FNVPROC;
glProgramParameter4fvNV: PFNGLPROGRAMPARAMETER4FVNVPROC;
glProgramParameters4dvNV: PFNGLPROGRAMPARAMETERS4DVNVPROC;
glProgramParameters4fvNV: PFNGLPROGRAMPARAMETERS4FVNVPROC;
glRequestResidentProgramsNV: PFNGLREQUESTRESIDENTPROGRAMSNVPROC;
glTrackMatrixNV: PFNGLTRACKMATRIXNVPROC;
glVertexAttribPointerNV: PFNGLVERTEXATTRIBPOINTERNVPROC;
glVertexAttrib1dNV: PFNGLVERTEXATTRIB1DNVPROC;
glVertexAttrib1dvNV: PFNGLVERTEXATTRIB1DVNVPROC;
glVertexAttrib1fNV: PFNGLVERTEXATTRIB1FNVPROC;
glVertexAttrib1fvNV: PFNGLVERTEXATTRIB1FVNVPROC;
glVertexAttrib1sNV: PFNGLVERTEXATTRIB1SNVPROC;
glVertexAttrib1svNV: PFNGLVERTEXATTRIB1SVNVPROC;
glVertexAttrib2dNV: PFNGLVERTEXATTRIB2DNVPROC;
glVertexAttrib2dvNV: PFNGLVERTEXATTRIB2DVNVPROC;
glVertexAttrib2fNV: PFNGLVERTEXATTRIB2FNVPROC;
glVertexAttrib2fvNV: PFNGLVERTEXATTRIB2FVNVPROC;
glVertexAttrib2sNV: PFNGLVERTEXATTRIB2SNVPROC;
glVertexAttrib2svNV: PFNGLVERTEXATTRIB2SVNVPROC;
glVertexAttrib3dNV: PFNGLVERTEXATTRIB3DNVPROC;
glVertexAttrib3dvNV: PFNGLVERTEXATTRIB3DVNVPROC;
glVertexAttrib3fNV: PFNGLVERTEXATTRIB3FNVPROC;
glVertexAttrib3fvNV: PFNGLVERTEXATTRIB3FVNVPROC;
glVertexAttrib3sNV: PFNGLVERTEXATTRIB3SNVPROC;
glVertexAttrib3svNV: PFNGLVERTEXATTRIB3SVNVPROC;
glVertexAttrib4dNV: PFNGLVERTEXATTRIB4DNVPROC;
glVertexAttrib4dvNV: PFNGLVERTEXATTRIB4DVNVPROC;
glVertexAttrib4fNV: PFNGLVERTEXATTRIB4FNVPROC;
glVertexAttrib4fvNV: PFNGLVERTEXATTRIB4FVNVPROC;
glVertexAttrib4sNV: PFNGLVERTEXATTRIB4SNVPROC;
glVertexAttrib4svNV: PFNGLVERTEXATTRIB4SVNVPROC;
glVertexAttrib4ubvNV: PFNGLVERTEXATTRIB4UBVNVPROC;
glVertexAttribs1dvNV: PFNGLVERTEXATTRIBS1DVNVPROC;
glVertexAttribs1fvNV: PFNGLVERTEXATTRIBS1FVNVPROC;
glVertexAttribs1svNV: PFNGLVERTEXATTRIBS1SVNVPROC;
glVertexAttribs2dvNV: PFNGLVERTEXATTRIBS2DVNVPROC;
glVertexAttribs2fvNV: PFNGLVERTEXATTRIBS2FVNVPROC;
glVertexAttribs2svNV: PFNGLVERTEXATTRIBS2SVNVPROC;
glVertexAttribs3dvNV: PFNGLVERTEXATTRIBS3DVNVPROC;
glVertexAttribs3fvNV: PFNGLVERTEXATTRIBS3FVNVPROC;
glVertexAttribs3svNV: PFNGLVERTEXATTRIBS3SVNVPROC;
glVertexAttribs4dvNV: PFNGLVERTEXATTRIBS4DVNVPROC;
glVertexAttribs4fvNV: PFNGLVERTEXATTRIBS4FVNVPROC;
glVertexAttribs4svNV: PFNGLVERTEXATTRIBS4SVNVPROC;
glVertexAttribs4ubvNV: PFNGLVERTEXATTRIBS4UBVNVPROC;
glGenOcclusionQueriesNV: PFNGLGENOCCLUSIONQUERIESNVPROC;
glDeleteOcclusionQueriesNV: PFNGLDELETEOCCLUSIONQUERIESNVPROC;
glIsOcclusionQueryNV: PFNGLISOCCLUSIONQUERYNVPROC;
glBeginOcclusionQueryNV: PFNGLBEGINOCCLUSIONQUERYNVPROC;
glEndOcclusionQueryNV: PFNGLENDOCCLUSIONQUERYNVPROC;
glGetOcclusionQueryivNV: PFNGLGETOCCLUSIONQUERYIVNVPROC;
glGetOcclusionQueryuivNV: PFNGLGETOCCLUSIONQUERYUIVNVPROC;
glPointParameteriNV: PFNGLPOINTPARAMETERINVPROC;
glPointParameterivNV: PFNGLPOINTPARAMETERIVNVPROC;
glActiveStencilFaceEXT: PFNGLACTIVESTENCILFACEEXTPROC;
glDrawBuffersATI: PFNGLDRAWBUFFERSATIPROC;
glPrimitiveRestartNV: PFNGLPRIMITIVERESTARTNVPROC;
glPrimitiveRestartIndexNV: PFNGLPRIMITIVERESTARTINDEXNVPROC;
glDepthBoundsEXT: PFNGLDEPTHBOUNDSEXTPROC;
glBlendEquationSeparateEXT: PFNGLBLENDEQUATIONSEPARATEEXTPROC;
glIsRenderbufferEXT: PFNGLISRENDERBUFFEREXTPROC;
glBindRenderbufferEXT: PFNGLBINDRENDERBUFFEREXTPROC;
glDeleteRenderbuffersEXT: PFNGLDELETERENDERBUFFERSEXTPROC;
glGenRenderbuffersEXT: PFNGLGENRENDERBUFFERSEXTPROC;
glRenderbufferStorageEXT: PFNGLRENDERBUFFERSTORAGEEXTPROC;
glGetRenderbufferParameterivEXT: PFNGLGETRENDERBUFFERPARAMETERIVEXTPROC;
glIsFramebufferEXT: PFNGLISFRAMEBUFFEREXTPROC;
glBindFramebufferEXT: PFNGLBINDFRAMEBUFFEREXTPROC;
glDeleteFramebuffersEXT: PFNGLDELETEFRAMEBUFFERSEXTPROC;
glGenFramebuffersEXT: PFNGLGENFRAMEBUFFERSEXTPROC;
glCheckFramebufferStatusEXT: PFNGLCHECKFRAMEBUFFERSTATUSEXTPROC;
glFramebufferTexture1DEXT: PFNGLFRAMEBUFFERTEXTURE1DEXTPROC;
glFramebufferTexture2DEXT: PFNGLFRAMEBUFFERTEXTURE2DEXTPROC;
glFramebufferTexture3DEXT: PFNGLFRAMEBUFFERTEXTURE3DEXTPROC;
glFramebufferRenderbufferEXT: PFNGLFRAMEBUFFERRENDERBUFFEREXTPROC;
glGetFramebufferAttachmentParameterivEXT: PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC;
glGenerateMipmapEXT: PFNGLGENERATEMIPMAPEXTPROC;
glStringMarkerGREMEDY: PFNGLSTRINGMARKERGREMEDYPROC;
glStencilClearTagEXT: PFNGLSTENCILCLEARTAGEXTPROC;
glBlitFramebufferEXT: PFNGLBLITFRAMEBUFFEREXTPROC;
glRenderbufferStorageMultisampleEXT: PFNGLRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC;
glGetQueryObjecti64vEXT: PFNGLGETQUERYOBJECTI64VEXTPROC;
glGetQueryObjectui64vEXT: PFNGLGETQUERYOBJECTUI64VEXTPROC;
glProgramEnvParameters4fvEXT: PFNGLPROGRAMENVPARAMETERS4FVEXTPROC;
glProgramLocalParameters4fvEXT: PFNGLPROGRAMLOCALPARAMETERS4FVEXTPROC;
glProgramVertexLimitNV: PFNGLPROGRAMVERTEXLIMITNVPROC;
glProgramParameteriEXT: PFNGLPROGRAMPARAMETERIEXTPROC;
glFramebufferTextureEXT: PFNGLFRAMEBUFFERTEXTUREEXTPROC;
glFramebufferTextureLayerEXT: PFNGLFRAMEBUFFERTEXTURELAYEREXTPROC;
glFramebufferTextureFaceEXT: PFNGLFRAMEBUFFERTEXTUREFACEEXTPROC;
glVertexAttribI1iEXT: PFNGLVERTEXATTRIBI1IEXTPROC;
glVertexAttribI2iEXT: PFNGLVERTEXATTRIBI2IEXTPROC;
glVertexAttribI3iEXT: PFNGLVERTEXATTRIBI3IEXTPROC;
glVertexAttribI4iEXT: PFNGLVERTEXATTRIBI4IEXTPROC;
glVertexAttribI1uiEXT: PFNGLVERTEXATTRIBI1UIEXTPROC;
glVertexAttribI2uiEXT: PFNGLVERTEXATTRIBI2UIEXTPROC;
glVertexAttribI3uiEXT: PFNGLVERTEXATTRIBI3UIEXTPROC;
glVertexAttribI4uiEXT: PFNGLVERTEXATTRIBI4UIEXTPROC;
glVertexAttribI1ivEXT: PFNGLVERTEXATTRIBI1IVEXTPROC;
glVertexAttribI2ivEXT: PFNGLVERTEXATTRIBI2IVEXTPROC;
glVertexAttribI3ivEXT: PFNGLVERTEXATTRIBI3IVEXTPROC;
glVertexAttribI4ivEXT: PFNGLVERTEXATTRIBI4IVEXTPROC;
glVertexAttribI1uivEXT: PFNGLVERTEXATTRIBI1UIVEXTPROC;
glVertexAttribI2uivEXT: PFNGLVERTEXATTRIBI2UIVEXTPROC;
glVertexAttribI3uivEXT: PFNGLVERTEXATTRIBI3UIVEXTPROC;
glVertexAttribI4uivEXT: PFNGLVERTEXATTRIBI4UIVEXTPROC;
glVertexAttribI4bvEXT: PFNGLVERTEXATTRIBI4BVEXTPROC;
glVertexAttribI4svEXT: PFNGLVERTEXATTRIBI4SVEXTPROC;
glVertexAttribI4ubvEXT: PFNGLVERTEXATTRIBI4UBVEXTPROC;
glVertexAttribI4usvEXT: PFNGLVERTEXATTRIBI4USVEXTPROC;
glVertexAttribIPointerEXT: PFNGLVERTEXATTRIBIPOINTEREXTPROC;
glGetVertexAttribIivEXT: PFNGLGETVERTEXATTRIBIIVEXTPROC;
glGetVertexAttribIuivEXT: PFNGLGETVERTEXATTRIBIUIVEXTPROC;
glUniform1uiEXT: PFNGLUNIFORM1UIEXTPROC;
glUniform2uiEXT: PFNGLUNIFORM2UIEXTPROC;
glUniform3uiEXT: PFNGLUNIFORM3UIEXTPROC;
glUniform4uiEXT: PFNGLUNIFORM4UIEXTPROC;
glUniform1uivEXT: PFNGLUNIFORM1UIVEXTPROC;
glUniform2uivEXT: PFNGLUNIFORM2UIVEXTPROC;
glUniform3uivEXT: PFNGLUNIFORM3UIVEXTPROC;
glUniform4uivEXT: PFNGLUNIFORM4UIVEXTPROC;
glGetUniformuivEXT: PFNGLGETUNIFORMUIVEXTPROC;
glBindFragDataLocationEXT: PFNGLBINDFRAGDATALOCATIONEXTPROC;
glGetFragDataLocationEXT: PFNGLGETFRAGDATALOCATIONEXTPROC;
glDrawArraysInstancedEXT: PFNGLDRAWARRAYSINSTANCEDEXTPROC;
glDrawElementsInstancedEXT: PFNGLDRAWELEMENTSINSTANCEDEXTPROC;
glTexBufferEXT: PFNGLTEXBUFFEREXTPROC;
glColorMaskIndexedEXT: PFNGLCOLORMASKINDEXEDEXTPROC;
glGetBooleanIndexedvEXT: PFNGLGETBOOLEANINDEXEDVEXTPROC;
glGetIntegerIndexedvEXT: PFNGLGETINTEGERINDEXEDVEXTPROC;
glEnableIndexedEXT: PFNGLENABLEINDEXEDEXTPROC;
glDisableIndexedEXT: PFNGLDISABLEINDEXEDEXTPROC;
glIsEnabledIndexedEXT: PFNGLISENABLEDINDEXEDEXTPROC;
glBindBufferRangeNV: PFNGLBINDBUFFERRANGENVPROC;
glBindBufferOffsetNV: PFNGLBINDBUFFEROFFSETNVPROC;
glBindBufferBaseNV: PFNGLBINDBUFFERBASENVPROC;
glTransformFeedbackAttribsNV: PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC;
glTransformFeedbackVaryingsNV: PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC;
glBeginTransformFeedbackNV: PFNGLBEGINTRANSFORMFEEDBACKNVPROC;
glEndTransformFeedbackNV: PFNGLENDTRANSFORMFEEDBACKNVPROC;
glGetVaryingLocationNV: PFNGLGETVARYINGLOCATIONNVPROC;
glGetActiveVaryingNV: PFNGLGETACTIVEVARYINGNVPROC;
glActiveVaryingNV: PFNGLACTIVEVARYINGNVPROC;
glGetTransformFeedbackVaryingNV: PFNGLGETTRANSFORMFEEDBACKVARYINGNVPROC;
glUniformBufferEXT: PFNGLUNIFORMBUFFEREXTPROC;
glGetUniformBufferSizeEXT: PFNGLGETUNIFORMBUFFERSIZEEXTPROC;
glGetUniformOffsetEXT: PFNGLGETUNIFORMOFFSETEXTPROC;
glClearColorIiEXT: PFNGLCLEARCOLORIIEXTPROC;
glClearColorIuiEXT: PFNGLCLEARCOLORIUIEXTPROC;
glTexParameterIivEXT: PFNGLTEXPARAMETERIIVEXTPROC;
glTexParameterIuivEXT: PFNGLTEXPARAMETERIUIVEXTPROC;
glGetTexParameterIivEXT: PFNGLGETTEXPARAMETERIIVEXTPROC;
glGetTexParameterIuivEXT: PFNGLGETTEXPARAMETERIUIVEXTPROC;
glFrameTerminatorGREMEDY: PFNGLFRAMETERMINATORGREMEDYPROC;
glBeginConditionalRenderNV: PFNGLBEGINCONDITIONALRENDERNVPROC;
glEndConditionalRenderNV: PFNGLENDCONDITIONALRENDERNVPROC;
glBindBufferRangeEXT: PFNGLBINDBUFFERRANGEEXTPROC;
glBindBufferOffsetEXT: PFNGLBINDBUFFEROFFSETEXTPROC;
glBindBufferBaseEXT: PFNGLBINDBUFFERBASEEXTPROC;
glBeginTransformFeedbackEXT: PFNGLBEGINTRANSFORMFEEDBACKEXTPROC;
glEndTransformFeedbackEXT: PFNGLENDTRANSFORMFEEDBACKEXTPROC;
glTransformFeedbackVaryingsEXT: PFNGLTRANSFORMFEEDBACKVARYINGSEXTPROC;
glGetTransformFeedbackVaryingEXT: PFNGLGETTRANSFORMFEEDBACKVARYINGEXTPROC;
glTessellationFactorAMD: PFNGLTESSELLATIONFACTORAMDPROC;
glTessellationModeAMD: PFNGLTESSELLATIONMODEAMDPROC;
glCopyImageSubDataNV: PFNGLCOPYIMAGESUBDATANVPROC;
glMakeBufferResidentNV: PFNGLMAKEBUFFERRESIDENTNVPROC;
glMakeBufferNonResidentNV: PFNGLMAKEBUFFERNONRESIDENTNVPROC;
glIsBufferResidentNV: PFNGLISBUFFERRESIDENTNVPROC;
glMakeNamedBufferResidentNV: PFNGLMAKENAMEDBUFFERRESIDENTNVPROC;
glMakeNamedBufferNonResidentNV: PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC;
glIsNamedBufferResidentNV: PFNGLISNAMEDBUFFERRESIDENTNVPROC;
glGetBufferParameterui64vNV: PFNGLGETBUFFERPARAMETERUI64VNVPROC;
glGetNamedBufferParameterui64vNV: PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC;
glGetIntegerui64vNV: PFNGLGETINTEGERUI64VNVPROC;
glUniformui64NV: PFNGLUNIFORMUI64NVPROC;
glUniformui64vNV: PFNGLUNIFORMUI64VNVPROC;
glGetUniformui64vNV: PFNGLGETUNIFORMUI64VNVPROC;
glProgramUniformui64NV: PFNGLPROGRAMUNIFORMUI64NVPROC;
glProgramUniformui64vNV: PFNGLPROGRAMUNIFORMUI64VNVPROC;
glBufferAddressRangeNV: PFNGLBUFFERADDRESSRANGENVPROC;
glVertexFormatNV: PFNGLVERTEXFORMATNVPROC;
glNormalFormatNV: PFNGLNORMALFORMATNVPROC;
glColorFormatNV: PFNGLCOLORFORMATNVPROC;
glIndexFormatNV: PFNGLINDEXFORMATNVPROC;
glTexCoordFormatNV: PFNGLTEXCOORDFORMATNVPROC;
glEdgeFlagFormatNV: PFNGLEDGEFLAGFORMATNVPROC;
glSecondaryColorFormatNV: PFNGLSECONDARYCOLORFORMATNVPROC;
glFogCoordFormatNV: PFNGLFOGCOORDFORMATNVPROC;
glVertexAttribFormatNV: PFNGLVERTEXATTRIBFORMATNVPROC;
glVertexAttribIFormatNV: PFNGLVERTEXATTRIBIFORMATNVPROC;
glGetIntegerui64i_vNV: PFNGLGETINTEGERUI64I_VNVPROC;
vIgnoreOpenGLErrors: Boolean = false;

Description

Functions and Procedures

procedure glBindTexture(target: TGLEnum; texture: TGLuint); stdcall; external opengl32;
procedure glBlendFunc(sfactor: TGLEnum; dfactor: TGLEnum); stdcall; external opengl32;
procedure glClear(mask: TGLbitfield); stdcall; external opengl32;
procedure glClearColor(red, green, blue, alpha: TGLclampf); stdcall; external opengl32;
procedure glClearDepth(depth: TGLclampd); stdcall; external opengl32;
procedure glClearStencil(s: TGLint ); stdcall; external opengl32;
procedure glColorMask(red, green, blue, alpha: TGLboolean); stdcall; external opengl32;
procedure glCopyTexImage1D(target: TGLEnum; level: TGLint; internalFormat: TGLEnum; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall; external opengl32;
procedure glCopyTexImage2D(target: TGLEnum; level: TGLint; internalFormat: TGLEnum; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall; external opengl32;
procedure glCopyTexSubImage1D(target: TGLEnum; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall; external opengl32;
procedure glCopyTexSubImage2D(target: TGLEnum; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;
procedure glCullFace(mode: TGLEnum); stdcall; external opengl32;
procedure glDeleteTextures(n: TGLsizei; textures: PGLuint); stdcall; external opengl32;
procedure glDepthFunc(func: TGLEnum); stdcall; external opengl32;
procedure glDepthMask(flag: TGLboolean); stdcall; external opengl32;
procedure glDepthRange(zNear, zFar: TGLclampd); stdcall; external opengl32;
procedure glDisable(cap: TGLEnum); stdcall; external opengl32;
procedure glDrawArrays(mode: TGLEnum; first: TGLint; count: TGLsizei); stdcall; external opengl32;
procedure glDrawBuffer(mode: TGLEnum); stdcall; external opengl32;
procedure glDrawElements(mode: TGLEnum; count: TGLsizei; atype: TGLEnum; indices: Pointer); stdcall; external opengl32;
procedure glEnable(cap: TGLEnum); stdcall; external opengl32;
procedure glFinish; stdcall; external opengl32;
procedure glFlush; stdcall; external opengl32;
procedure glFrontFace(mode: TGLEnum); stdcall; external opengl32;
procedure glGenTextures(n: TGLsizei; textures: PGLuint); stdcall; external opengl32;
procedure glGetBooleanv(pname: TGLEnum; params: PGLboolean); stdcall; external opengl32;
procedure glGetDoublev(pname: TGLEnum; params: PGLdouble); stdcall; external opengl32;
function glGetError: TGLuint; stdcall; external opengl32;
procedure glGetFloatv(pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glGetIntegerv(pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glGetPointerv(pname: TGLEnum; var params); stdcall; external opengl32;
function glGetString(name: TGLEnum): PGLChar; stdcall; external opengl32;
procedure glGetTexImage(target: TGLEnum; level: TGLint; format, atype: TGLEnum; pixels: Pointer); stdcall; external opengl32;
procedure glGetTexLevelParameterfv(target: TGLEnum; level: TGLint; pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glGetTexLevelParameteriv(target: TGLEnum; level: TGLint; pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glGetTexParameterfv(target, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glGetTexParameteriv(target, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glHint(target, mode: TGLEnum); stdcall; external opengl32;
function glIsEnabled(cap: TGLEnum): TGLboolean; stdcall; external opengl32;
function glIsTexture(texture: TGLuint): TGLboolean; stdcall; external opengl32;
procedure glLineWidth(width: TGLfloat); stdcall; external opengl32;
procedure glLogicOp(opcode: TGLEnum); stdcall; external opengl32;
procedure glPixelStoref(pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glPixelStorei(pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glPointSize(size: TGLfloat); stdcall; external opengl32;
procedure glPolygonMode(face, mode: TGLEnum); stdcall; external opengl32;
procedure glPolygonOffset(factor, units: TGLfloat); stdcall; external opengl32;
procedure glReadBuffer(mode: TGLEnum); stdcall; external opengl32;
procedure glReadPixels(x, y: TGLint; width, height: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall; external opengl32;
procedure glScissor(x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;
procedure glStencilFunc(func: TGLEnum; ref: TGLint; mask: TGLuint); stdcall; external opengl32;
procedure glStencilMask(mask: TGLuint); stdcall; external opengl32;
procedure glStencilOp(fail, zfail, zpass: TGLEnum); stdcall; external opengl32;
procedure glTexImage1D(target: TGLEnum; level, internalformat: TGLint; width: TGLsizei; border: TGLint; format, atype: TGLEnum; pixels: Pointer); stdcall; external opengl32;
procedure glTexImage2D(target: TGLEnum; level, internalformat: TGLint; width, height: TGLsizei; border: TGLint; format, atype: TGLEnum; Pixels:Pointer); stdcall; external opengl32;
procedure glTexParameterf(target, pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glTexParameterfv(target, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glTexParameteri(target, pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glTexParameteriv(target, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glTexSubImage1D(target: TGLEnum; level, xoffset: TGLint; width: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall; external opengl32;
procedure glTexSubImage2D(target: TGLEnum; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall; external opengl32;
procedure glViewport(x, y: TGLint; width, height: TGLsizei); stdcall; external opengl32;
procedure glAccum(op: TGLuint; value: TGLfloat); stdcall; external opengl32;
procedure glAlphaFunc(func: TGLEnum; ref: TGLclampf); stdcall; external opengl32;
function glAreTexturesResident(n: TGLsizei; Textures: PGLuint; residences: PGLboolean): TGLboolean; stdcall; external opengl32;
procedure glArrayElement(i: TGLint); stdcall; external opengl32;
procedure glBegin(mode: TGLEnum); stdcall; external opengl32;
procedure glBitmap(width: TGLsizei; height: TGLsizei; xorig, yorig: TGLfloat; xmove: TGLfloat; ymove: TGLfloat; bitmap: Pointer); stdcall; external opengl32;
procedure glCallList(list: TGLuint); stdcall; external opengl32;
procedure glCallLists(n: TGLsizei; atype: TGLEnum; lists: Pointer); stdcall; external opengl32;
procedure glClearAccum(red, green, blue, alpha: TGLfloat); stdcall; external opengl32;
procedure glClearIndex(c: TGLfloat); stdcall; external opengl32;
procedure glClipPlane(plane: TGLEnum; equation: PGLdouble); stdcall; external opengl32;
procedure glColor3b(red, green, blue: TGLbyte); stdcall; external opengl32;
procedure glColor3bv(v: PGLbyte); stdcall; external opengl32;
procedure glColor3d(red, green, blue: TGLdouble); stdcall; external opengl32;
procedure glColor3dv(v: PGLdouble); stdcall; external opengl32;
procedure glColor3f(red, green, blue: TGLfloat); stdcall; external opengl32;
procedure glColor3fv(v: PGLfloat); stdcall; external opengl32;
procedure glColor3i(red, green, blue: TGLint); stdcall; external opengl32;
procedure glColor3iv(v: PGLint); stdcall; external opengl32;
procedure glColor3s(red, green, blue: TGLshort); stdcall; external opengl32;
procedure glColor3sv(v: PGLshort); stdcall; external opengl32;
procedure glColor3ub(red, green, blue: TGLubyte); stdcall; external opengl32;
procedure glColor3ubv(v: PGLubyte); stdcall; external opengl32;
procedure glColor3ui(red, green, blue: TGLuint); stdcall; external opengl32;
procedure glColor3uiv(v: PGLuint); stdcall; external opengl32;
procedure glColor3us(red, green, blue: TGLushort); stdcall; external opengl32;
procedure glColor3usv(v: PGLushort); stdcall; external opengl32;
procedure glColor4b(red, green, blue, alpha: TGLbyte); stdcall; external opengl32;
procedure glColor4bv(v: PGLbyte); stdcall; external opengl32;
procedure glColor4d(red, green, blue, alpha: TGLdouble ); stdcall; external opengl32;
procedure glColor4dv(v: PGLdouble); stdcall; external opengl32;
procedure glColor4f(red, green, blue, alpha: TGLfloat); stdcall; external opengl32;
procedure glColor4fv(v: PGLfloat); stdcall; external opengl32;
procedure glColor4i(red, green, blue, alpha: TGLint); stdcall; external opengl32;
procedure glColor4iv(v: PGLint); stdcall; external opengl32;
procedure glColor4s(red, green, blue, alpha: TGLshort); stdcall; external opengl32;
procedure glColor4sv(v: TGLshort); stdcall; external opengl32;
procedure glColor4ub(red, green, blue, alpha: TGLubyte); stdcall; external opengl32;
procedure glColor4ubv(v: PGLubyte); stdcall; external opengl32;
procedure glColor4ui(red, green, blue, alpha: TGLuint); stdcall; external opengl32;
procedure glColor4uiv(v: PGLuint); stdcall; external opengl32;
procedure glColor4us(red, green, blue, alpha: TGLushort); stdcall; external opengl32;
procedure glColor4usv(v: PGLushort); stdcall; external opengl32;
procedure glColorMaterial(face: TGLEnum; mode: TGLEnum); stdcall; external opengl32;
procedure glColorPointer(size: TGLint; atype: TGLEnum; stride: TGLsizei; data: pointer); stdcall; external opengl32;
procedure glCopyPixels(x, y: TGLint; width, height: TGLsizei; atype: TGLEnum); stdcall; external opengl32;
procedure glDeleteLists(list: TGLuint; range: TGLsizei); stdcall; external opengl32;
procedure glDisableClientState(aarray: TGLEnum); stdcall; external opengl32;
procedure glDrawPixels(width, height: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall; external opengl32;
procedure glEdgeFlag(flag: TGLboolean); stdcall; external opengl32;
procedure glEdgeFlagPointer(stride: TGLsizei; data: pointer); stdcall; external opengl32;
procedure glEdgeFlagv(flag: PGLboolean); stdcall; external opengl32;
procedure glEnableClientState(aarray: TGLEnum); stdcall; external opengl32;
procedure glEnd; stdcall; external opengl32;
procedure glEndList; stdcall; external opengl32;
procedure glEvalCoord1d(u: TGLdouble); stdcall; external opengl32;
procedure glEvalCoord1dv(u: PGLdouble); stdcall; external opengl32;
procedure glEvalCoord1f(u: TGLfloat); stdcall; external opengl32;
procedure glEvalCoord1fv(u: PGLfloat); stdcall; external opengl32;
procedure glEvalCoord2d(u: TGLdouble; v: TGLdouble); stdcall; external opengl32;
procedure glEvalCoord2dv(u: PGLdouble); stdcall; external opengl32;
procedure glEvalCoord2f(u, v: TGLfloat); stdcall; external opengl32;
procedure glEvalCoord2fv(u: PGLfloat); stdcall; external opengl32;
procedure glEvalMesh1(mode: TGLEnum; i1, i2: TGLint); stdcall; external opengl32;
procedure glEvalMesh2(mode: TGLEnum; i1, i2, j1, j2: TGLint); stdcall; external opengl32;
procedure glEvalPoint1(i: TGLint); stdcall; external opengl32;
procedure glEvalPoint2(i, j: TGLint); stdcall; external opengl32;
procedure glFeedbackBuffer(size: TGLsizei; atype: TGLEnum; buffer: PGLfloat); stdcall; external opengl32;
procedure glFogf(pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glFogfv(pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glFogi(pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glFogiv(pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glFrustum(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall; external opengl32;
function glGenLists(range: TGLsizei): TGLuint; stdcall; external opengl32;
procedure glGetClipPlane(plane: TGLEnum; equation: PGLdouble); stdcall; external opengl32;
procedure glGetLightfv(light, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glGetLightiv(light, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glGetMapdv(target, query: TGLEnum; v: PGLdouble); stdcall; external opengl32;
procedure glGetMapfv(target, query: TGLEnum; v: PGLfloat); stdcall; external opengl32;
procedure glGetMapiv(target, query: TGLEnum; v: PGLint); stdcall; external opengl32;
procedure glGetMaterialfv(face, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glGetMaterialiv(face, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glGetPixelMapfv(map: TGLEnum; values: PGLfloat); stdcall; external opengl32;
procedure glGetPixelMapuiv(map: TGLEnum; values: PGLuint); stdcall; external opengl32;
procedure glGetPixelMapusv(map: TGLEnum; values: PGLushort); stdcall; external opengl32;
procedure glGetPolygonStipple(mask: PGLubyte); stdcall; external opengl32;
procedure glGetTexEnvfv(target, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glGetTexEnviv(target, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glGetTexGendv(coord, pname: TGLEnum; params: PGLdouble); stdcall; external opengl32;
procedure glGetTexGenfv(coord, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glGetTexGeniv(coord, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glIndexMask(mask: TGLuint); stdcall; external opengl32;
procedure glIndexPointer(atype: TGLEnum; stride: TGLsizei; data: pointer); stdcall; external opengl32;
procedure glIndexd(c: TGLdouble); stdcall; external opengl32;
procedure glIndexdv(c: PGLdouble); stdcall; external opengl32;
procedure glIndexf(c: TGLfloat); stdcall; external opengl32;
procedure glIndexfv(c: PGLfloat); stdcall; external opengl32;
procedure glIndexi(c: TGLint); stdcall; external opengl32;
procedure glIndexiv(c: PGLint); stdcall; external opengl32;
procedure glIndexs(c: TGLshort); stdcall; external opengl32;
procedure glIndexsv(c: PGLshort); stdcall; external opengl32;
procedure glIndexub(c: TGLubyte); stdcall; external opengl32;
procedure glIndexubv(c: PGLubyte); stdcall; external opengl32;
procedure glInitNames; stdcall; external opengl32;
procedure glInterleavedArrays(format: TGLEnum; stride: TGLsizei; data: pointer); stdcall; external opengl32;
function glIsList(list: TGLuint): TGLboolean; stdcall; external opengl32;
procedure glLightModelf(pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glLightModelfv(pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glLightModeli(pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glLightModeliv(pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glLightf(light, pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glLightfv(light, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glLighti(light, pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glLightiv(light, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glLineStipple(factor: TGLint; pattern: TGLushort); stdcall; external opengl32;
procedure glListBase(base: TGLuint); stdcall; external opengl32;
procedure glLoadIdentity; stdcall; external opengl32;
procedure glLoadMatrixd(m: PGLdouble); stdcall; external opengl32;
procedure glLoadMatrixf(m: PGLfloat); stdcall; external opengl32;
procedure glLoadName(name: TGLuint); stdcall; external opengl32;
procedure glMap1d(target: TGLEnum; u1, u2: TGLdouble; stride, order: TGLint; points: PGLdouble); stdcall; external opengl32;
procedure glMap1f(target: TGLEnum; u1, u2: TGLfloat; stride, order: TGLint; points: PGLfloat); stdcall; external opengl32;
procedure glMap2d(target: TGLEnum; u1, u2: TGLdouble; ustride, uorder: TGLint; v1, v2: TGLdouble; vstride, vorder: TGLint; points: PGLdouble); stdcall; external opengl32;
procedure glMap2f(target: TGLEnum; u1, u2: TGLfloat; ustride, uorder: TGLint; v1, v2: TGLfloat; vstride, vorder: TGLint; points: PGLfloat); stdcall; external opengl32;
procedure glMapGrid1d(un: TGLint; u1, u2: TGLdouble); stdcall; external opengl32;
procedure glMapGrid1f(un: TGLint; u1, u2: TGLfloat); stdcall; external opengl32;
procedure glMapGrid2d(un: TGLint; u1, u2: TGLdouble; vn: TGLint; v1, v2: TGLdouble); stdcall; external opengl32;
procedure glMapGrid2f(un: TGLint; u1, u2: TGLfloat; vn: TGLint; v1, v2: TGLfloat); stdcall; external opengl32;
procedure glMaterialf(face, pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glMaterialfv(face, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glMateriali(face, pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glMaterialiv(face, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glMatrixMode(mode: TGLEnum); stdcall; external opengl32;
procedure glMultMatrixd(m: PGLdouble); stdcall; external opengl32;
procedure glMultMatrixf(m: PGLfloat); stdcall; external opengl32;
procedure glNewList(list: TGLuint; mode: TGLEnum); stdcall; external opengl32;
procedure glNormal3b(nx, ny, nz: TGLbyte); stdcall; external opengl32;
procedure glNormal3bv(v: PGLbyte); stdcall; external opengl32;
procedure glNormal3d(nx, ny, nz: TGLdouble); stdcall; external opengl32;
procedure glNormal3dv(v: PGLdouble); stdcall; external opengl32;
procedure glNormal3f(nx, ny, nz: TGLfloat); stdcall; external opengl32;
procedure glNormal3fv(v: PGLfloat); stdcall; external opengl32;
procedure glNormal3i(nx, ny, nz: TGLint); stdcall; external opengl32;
procedure glNormal3iv(v: PGLint); stdcall; external opengl32;
procedure glNormal3s(nx, ny, nz: TGLshort); stdcall; external opengl32;
procedure glNormal3sv(v: PGLshort); stdcall; external opengl32;
procedure glNormalPointer(atype: TGLEnum; stride: TGLsizei; data: pointer); stdcall; external opengl32;
procedure glOrtho(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall; external opengl32;
procedure glPassThrough(token: TGLfloat); stdcall; external opengl32;
procedure glPixelMapfv(map: TGLEnum; mapsize: TGLsizei; values: PGLfloat); stdcall; external opengl32;
procedure glPixelMapuiv(map: TGLEnum; mapsize: TGLsizei; values: PGLuint); stdcall; external opengl32;
procedure glPixelMapusv(map: TGLEnum; mapsize: TGLsizei; values: PGLushort); stdcall; external opengl32;
procedure glPixelTransferf(pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glPixelTransferi(pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glPixelZoom(xfactor, yfactor: TGLfloat); stdcall; external opengl32;
procedure glPolygonStipple(mask: PGLubyte); stdcall; external opengl32;
procedure glPopAttrib; stdcall; external opengl32;
procedure glPopClientAttrib; stdcall; external opengl32;
procedure glPopMatrix; stdcall; external opengl32;
procedure glPopName; stdcall; external opengl32;
procedure glPrioritizeTextures(n: TGLsizei; textures: PGLuint; priorities: PGLclampf); stdcall; external opengl32;
procedure glPushAttrib(mask: TGLbitfield); stdcall; external opengl32;
procedure glPushClientAttrib(mask: TGLbitfield); stdcall; external opengl32;
procedure glPushMatrix; stdcall; external opengl32;
procedure glPushName(name: TGLuint); stdcall; external opengl32;
procedure glRasterPos2d(x, y: TGLdouble); stdcall; external opengl32;
procedure glRasterPos2dv(v: PGLdouble); stdcall; external opengl32;
procedure glRasterPos2f(x, y: TGLfloat); stdcall; external opengl32;
procedure glRasterPos2fv(v: PGLfloat); stdcall; external opengl32;
procedure glRasterPos2i(x, y: TGLint); stdcall; external opengl32;
procedure glRasterPos2iv(v: PGLint); stdcall; external opengl32;
procedure glRasterPos2s(x, y: PGLshort); stdcall; external opengl32;
procedure glRasterPos2sv(v: PGLshort); stdcall; external opengl32;
procedure glRasterPos3d(x, y, z: TGLdouble); stdcall; external opengl32;
procedure glRasterPos3dv(v: PGLdouble); stdcall; external opengl32;
procedure glRasterPos3f(x, y, z: TGLfloat); stdcall; external opengl32;
procedure glRasterPos3fv(v: PGLfloat); stdcall; external opengl32;
procedure glRasterPos3i(x, y, z: TGLint); stdcall; external opengl32;
procedure glRasterPos3iv(v: PGLint); stdcall; external opengl32;
procedure glRasterPos3s(x, y, z: TGLshort); stdcall; external opengl32;
procedure glRasterPos3sv(v: PGLshort); stdcall; external opengl32;
procedure glRasterPos4d(x, y, z, w: TGLdouble); stdcall; external opengl32;
procedure glRasterPos4dv(v: PGLdouble); stdcall; external opengl32;
procedure glRasterPos4f(x, y, z, w: TGLfloat); stdcall; external opengl32;
procedure glRasterPos4fv(v: PGLfloat); stdcall; external opengl32;
procedure glRasterPos4i(x, y, z, w: TGLint); stdcall; external opengl32;
procedure glRasterPos4iv(v: PGLint); stdcall; external opengl32;
procedure glRasterPos4s(x, y, z, w: TGLshort); stdcall; external opengl32;
procedure glRasterPos4sv(v: PGLshort); stdcall; external opengl32;
procedure glRectd(x1, y1, x2, y2: TGLdouble); stdcall; external opengl32;
procedure glRectdv(v1, v2: PGLdouble); stdcall; external opengl32;
procedure glRectf(x1, y1, x2, y2: TGLfloat); stdcall; external opengl32;
procedure glRectfv(v1, v2: PGLfloat); stdcall; external opengl32;
procedure glRecti(x1, y1, x2, y2: TGLint); stdcall; external opengl32;
procedure glRectiv(v1, v2: PGLint); stdcall; external opengl32;
procedure glRects(x1, y1, x2, y2: TGLshort); stdcall; external opengl32;
procedure glRectsv(v1, v2: PGLshort); stdcall; external opengl32;
function glRenderMode(mode: TGLEnum): TGLint; stdcall; external opengl32;
procedure glRotated(angle, x, y, z: TGLdouble); stdcall; external opengl32;
procedure glRotatef(angle, x, y, z: TGLfloat); stdcall; external opengl32;
procedure glScaled(x, y, z: TGLdouble); stdcall; external opengl32;
procedure glScalef(x, y, z: TGLfloat); stdcall; external opengl32;
procedure glSelectBuffer(size: TGLsizei; buffer: PGLuint); stdcall; external opengl32;
procedure glShadeModel(mode: TGLEnum); stdcall; external opengl32;
procedure glTexCoord1d(s: TGLdouble); stdcall; external opengl32;
procedure glTexCoord1dv(v: PGLdouble); stdcall; external opengl32;
procedure glTexCoord1f(s: TGLfloat); stdcall; external opengl32;
procedure glTexCoord1fv(v: PGLfloat); stdcall; external opengl32;
procedure glTexCoord1i(s: TGLint); stdcall; external opengl32;
procedure glTexCoord1iv(v: PGLint); stdcall; external opengl32;
procedure glTexCoord1s(s: TGLshort); stdcall; external opengl32;
procedure glTexCoord1sv(v: PGLshort); stdcall; external opengl32;
procedure glTexCoord2d(s, t: TGLdouble); stdcall; external opengl32;
procedure glTexCoord2dv(v: PGLdouble); stdcall; external opengl32;
procedure glTexCoord2f(s, t: TGLfloat); stdcall; external opengl32;
procedure glTexCoord2fv(v: PGLfloat); stdcall; external opengl32;
procedure glTexCoord2i(s, t: TGLint); stdcall; external opengl32;
procedure glTexCoord2iv(v: PGLint); stdcall; external opengl32;
procedure glTexCoord2s(s, t: TGLshort); stdcall; external opengl32;
procedure glTexCoord2sv(v: PGLshort); stdcall; external opengl32;
procedure glTexCoord3d(s, t, r: TGLdouble); stdcall; external opengl32;
procedure glTexCoord3dv(v: PGLdouble); stdcall; external opengl32;
procedure glTexCoord3f(s, t, r: TGLfloat); stdcall; external opengl32;
procedure glTexCoord3fv(v: PGLfloat); stdcall; external opengl32;
procedure glTexCoord3i(s, t, r: TGLint); stdcall; external opengl32;
procedure glTexCoord3iv(v: PGLint); stdcall; external opengl32;
procedure glTexCoord3s(s, t, r: TGLshort); stdcall; external opengl32;
procedure glTexCoord3sv(v: PGLshort); stdcall; external opengl32;
procedure glTexCoord4d(s, t, r, q: TGLdouble); stdcall; external opengl32;
procedure glTexCoord4dv(v: PGLdouble); stdcall; external opengl32;
procedure glTexCoord4f(s, t, r, q: TGLfloat); stdcall; external opengl32;
procedure glTexCoord4fv(v: PGLfloat); stdcall; external opengl32;
procedure glTexCoord4i(s, t, r, q: TGLint); stdcall; external opengl32;
procedure glTexCoord4iv(v: PGLint); stdcall; external opengl32;
procedure glTexCoord4s(s, t, r, q: TGLshort); stdcall; external opengl32;
procedure glTexCoord4sv(v: PGLshort); stdcall; external opengl32;
procedure glTexCoordPointer(size: TGLint; atype: TGLEnum; stride: TGLsizei; data: pointer); stdcall; external opengl32;
procedure glTexEnvf(target, pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glTexEnvfv(target, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glTexEnvi(target, pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glTexEnviv(target, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glTexGend(coord, pname: TGLEnum; param: TGLdouble); stdcall; external opengl32;
procedure glTexGendv(coord, pname: TGLEnum; params: PGLdouble); stdcall; external opengl32;
procedure glTexGenf(coord, pname: TGLEnum; param: TGLfloat); stdcall; external opengl32;
procedure glTexGenfv(coord, pname: TGLEnum; params: PGLfloat); stdcall; external opengl32;
procedure glTexGeni(coord, pname: TGLEnum; param: TGLint); stdcall; external opengl32;
procedure glTexGeniv(coord, pname: TGLEnum; params: PGLint); stdcall; external opengl32;
procedure glTranslated(x, y, z: TGLdouble); stdcall; external opengl32;
procedure glTranslatef(x, y, z: TGLfloat); stdcall; external opengl32;
procedure glVertex2d(x, y: TGLdouble); stdcall; external opengl32;
procedure glVertex2dv(v: PGLdouble); stdcall; external opengl32;
procedure glVertex2f(x, y: TGLfloat); stdcall; external opengl32;
procedure glVertex2fv(v: PGLfloat); stdcall; external opengl32;
procedure glVertex2i(x, y: TGLint); stdcall; external opengl32;
procedure glVertex2iv(v: PGLint); stdcall; external opengl32;
procedure glVertex2s(x, y: TGLshort); stdcall; external opengl32;
procedure glVertex2sv(v: PGLshort); stdcall; external opengl32;
procedure glVertex3d(x, y, z: TGLdouble); stdcall; external opengl32;
procedure glVertex3dv(v: PGLdouble); stdcall; external opengl32;
procedure glVertex3f(x, y, z: TGLfloat); stdcall; external opengl32;
procedure glVertex3fv(v: PGLfloat); stdcall; external opengl32;
procedure glVertex3i(x, y, z: TGLint); stdcall; external opengl32;
procedure glVertex3iv(v: PGLint); stdcall; external opengl32;
procedure glVertex3s(x, y, z: TGLshort); stdcall; external opengl32;
procedure glVertex3sv(v: PGLshort); stdcall; external opengl32;
procedure glVertex4d(x, y, z, w: TGLdouble); stdcall; external opengl32;
procedure glVertex4dv(v: PGLdouble); stdcall; external opengl32;
procedure glVertex4f(x, y, z, w: TGLfloat); stdcall; external opengl32;
procedure glVertex4fv(v: PGLfloat); stdcall; external opengl32;
procedure glVertex4i(x, y, z, w: TGLint); stdcall; external opengl32;
procedure glVertex4iv(v: PGLint); stdcall; external opengl32;
procedure glVertex4s(x, y, z, w: TGLshort); stdcall; external opengl32;
procedure glVertex4sv(v: PGLshort); stdcall; external opengl32;
procedure glVertexPointer(size: TGLint; atype: TGLEnum; stride: TGLsizei; data: pointer); stdcall; external opengl32;
function gluErrorString(errCode: TGLEnum): PGLChar; stdcall; external glu32;
function gluGetString(name: TGLEnum): PGLChar; stdcall; external glu32;
procedure gluOrtho2D(left, right, bottom, top: TGLdouble); stdcall; external glu32;
procedure gluPerspective(fovy, aspect, zNear, zFar: TGLdouble); stdcall; external glu32;
procedure gluPickMatrix(x, y, width, height: TGLdouble; const viewport: TVector4i); stdcall; external glu32;
procedure gluLookAt(eyex, eyey, eyez, centerx, centery, centerz, upx, upy, upz: TGLdouble); stdcall; external glu32;
function gluProject(objx, objy, objz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const viewport: TVector4i; winx, winy, winz: PGLdouble): TGLint; stdcall; external glu32;
function gluUnProject(winx, winy, winz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const viewport: TVector4i; objx, objy, objz: PGLdouble): TGLint; stdcall; external glu32;
function gluScaleImage(format: TGLEnum; widthin, heightin: TGLint; typein: TGLEnum; datain: Pointer; widthout, heightout: TGLint; typeout: TGLEnum; dataout: Pointer): TGLint; stdcall; external glu32;
function gluBuild1DMipmaps(target: TGLEnum; components, width: TGLint; format, atype: TGLEnum; data: Pointer): TGLint; stdcall; external glu32;
function gluBuild2DMipmaps(target: TGLEnum; components, width, height: TGLint; format, atype: TGLEnum; data: Pointer): TGLint; stdcall; external glu32;
function gluNewQuadric: PGLUquadric; stdcall; external glu32;
procedure gluDeleteQuadric(state: PGLUquadric); stdcall; external glu32;
procedure gluQuadricNormals(quadObject: PGLUquadric; normals: TGLEnum); stdcall; external glu32;
procedure gluQuadricTexture(quadObject: PGLUquadric; textureCoords: TGLboolean); stdcall; external glu32;
procedure gluQuadricOrientation(quadObject: PGLUquadric; orientation: TGLEnum); stdcall; external glu32;
procedure gluQuadricDrawStyle(quadObject: PGLUquadric; drawStyle: TGLEnum); stdcall; external glu32;
procedure gluCylinder(quadObject: PGLUquadric; baseRadius, topRadius, height: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;
procedure gluDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint); stdcall; external glu32;
procedure gluPartialDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint; startAngle, sweepAngle: TGLdouble); stdcall; external glu32;
procedure gluSphere(quadObject: PGLUquadric; radius: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;
procedure gluQuadricCallback(quadObject: PGLUquadric; which: TGLEnum; fn: TGLUQuadricErrorProc); stdcall; external glu32;
function gluNewTess: PGLUtesselator; stdcall; external glu32;
procedure gluDeleteTess(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessBeginPolygon(tess: PGLUtesselator; polygon_data: Pointer); stdcall; external glu32;
procedure gluTessBeginContour(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessVertex(tess: PGLUtesselator; const coords: TVector3d; data: Pointer); stdcall; external glu32;
procedure gluTessEndContour(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessEndPolygon(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessProperty(tess: PGLUtesselator; which: TGLEnum; value: TGLdouble); stdcall; external glu32;
procedure gluTessNormal(tess: PGLUtesselator; x, y, z: TGLdouble); stdcall; external glu32;
procedure gluTessCallback(tess: PGLUtesselator; which: TGLEnum; fn: Pointer); stdcall; external glu32;
procedure gluGetTessProperty(tess: PGLUtesselator; which: TGLEnum; value: PGLdouble); stdcall; external glu32;
function gluNewNurbsRenderer: PGLUnurbs; stdcall; external glu32;
procedure gluDeleteNurbsRenderer(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginSurface(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginCurve(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndCurve(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndSurface(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginTrim(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndTrim(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluPwlCurve(nobj: PGLUnurbs; count: TGLint; points: PGLfloat; stride: TGLint; atype: TGLEnum); stdcall; external glu32;
procedure gluNurbsCurve(nobj: PGLUnurbs; nknots: TGLint; knot: PGLfloat; stride: TGLint; ctlarray: PGLfloat; order: TGLint; atype: TGLEnum); stdcall; external glu32;
procedure gluNurbsSurface(nobj: PGLUnurbs; sknot_count: TGLint; sknot: PGLfloat; tknot_count: TGLint; tknot: PGLfloat; s_stride, t_stride: TGLint; ctlarray: PGLfloat; sorder, torder: TGLint; atype: TGLEnum); stdcall; external glu32;
procedure gluLoadSamplingMatrices(nobj: PGLUnurbs; const modelMatrix: TMatrix4f; const projMatrix: TMatrix4f; const viewport: TVector4i); stdcall; external glu32;
procedure gluNurbsProperty(nobj: PGLUnurbs; aproperty: TGLEnum; value: TGLfloat); stdcall; external glu32;
procedure gluGetNurbsProperty(nobj: PGLUnurbs; aproperty: TGLEnum; value: PGLfloat); stdcall; external glu32;
procedure gluNurbsCallback(nobj: PGLUnurbs; which: TGLEnum; fn: TGLUNurbsErrorProc); stdcall; external glu32;
procedure gluBeginPolygon(tess: PGLUtesselator); stdcall; external glu32;
procedure gluNextContour(tess: PGLUtesselator; atype: TGLEnum); stdcall; external glu32;
procedure gluEndPolygon(tess: PGLUtesselator); stdcall; external glu32;
function wglGetProcAddress(ProcName: PGLChar): Pointer; stdcall; external opengl32;
function wglCopyContext(p1: HGLRC; p2: HGLRC; p3: Cardinal): BOOL; stdcall; external opengl32;
function wglCreateContext(DC: HDC): HGLRC; stdcall; external opengl32;
function wglCreateLayerContext(p1: HDC; p2: Integer): HGLRC; stdcall; external opengl32;
function wglDeleteContext(p1: HGLRC): BOOL; stdcall; external opengl32;
function wglDescribeLayerPlane(p1: HDC; p2, p3: Integer; p4: Cardinal; var p5: TLayerPlaneDescriptor): BOOL; stdcall; external opengl32;
function wglGetCurrentContext: HGLRC; stdcall; external opengl32;
function wglGetCurrentDC: HDC; stdcall; external opengl32;
function wglGetLayerPaletteEntries(p1: HDC; p2, p3, p4: Integer; var pcr): Integer; stdcall; external opengl32;
function wglMakeCurrent(DC: HDC; p2: HGLRC): BOOL; stdcall; external opengl32;
function wglRealizeLayerPalette(p1: HDC; p2: Integer; p3: BOOL): BOOL; stdcall; external opengl32;
function wglSetLayerPaletteEntries(p1: HDC; p2, p3, p4: Integer; var pcr): Integer; stdcall; external opengl32;
function wglShareLists(p1, p2: HGLRC): BOOL; stdcall; external opengl32;
function wglSwapLayerBuffers(p1: HDC; p2: Cardinal): BOOL; stdcall; external opengl32;
function wglSwapMultipleBuffers(p1: UINT; const p2: PWGLSwap): DWORD; stdcall; external opengl32;
function wglUseFontBitmapsA(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;
function wglUseFontOutlinesA (p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;
function wglUseFontBitmapsW(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;
function wglUseFontOutlinesW (p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;
function wglUseFontBitmaps(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32 name 'wglUseFontBitmapsA';
function wglUseFontOutlines(p1: HDC; p2, p3, p4: DWORD; p5, p6: Single; p7: Integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32 name 'wglUseFontOutlinesA';
function GLLibGetProcAddress(ProcName: PGLChar): Pointer;
function GLGetProcAddress(ProcName: PGLChar): Pointer;
procedure ReadExtensions;
procedure ReadImplementationProperties;
procedure ReadWGLExtensions;
procedure ReadWGLImplementationProperties;
procedure CloseOpenGL;
function InitOpenGL : Boolean;
function InitOpenGLFromLibrary(const GLName, GLUName : String) : Boolean;
function IsOpenGLInitialized: Boolean;
procedure UnloadOpenGL;
function LoadOpenGL : Boolean;
function LoadOpenGLFromLibrary(GLName, GLUName: String): Boolean;
function IsOpenGLLoaded : Boolean;
function IsMesaGL : Boolean;
procedure TrimAndSplitVersionString(Buffer: String; var Max, Min: Integer);
function IsVersionMet(MajorVersion,MinorVersion, actualMajorVersion, actualMinorVersion:Integer): boolean;
function IsOpenGLVersionMet(MajorVersion,MinorVersion: Integer): boolean;
procedure CheckOpenGLError;

Gets the oldest error from OpenGL engine and tries to clear the error queue.<p>

procedure ClearGLError;

Clears all pending OpenGL errors.

procedure RaiseOpenGLError(const msg : String);

Raises an EOpenGLError with 'msg' error string.

Variables

GL_VERSION_1_0: Boolean;
GL_VERSION_1_1: Boolean;
GL_VERSION_1_2: Boolean;
GL_VERSION_1_3: Boolean;
GL_VERSION_1_4: Boolean;
GL_VERSION_1_5: Boolean;
GL_VERSION_2_0: Boolean;
GL_VERSION_2_1: Boolean;
GL_VERSION_3_0: Boolean;
GL_VERSION_3_1: Boolean;
GL_VERSION_3_2: Boolean;
GL_VERSION_3_3: Boolean;
GL_VERSION_4_0: Boolean;
GL_VERSION_4_1: Boolean;
GLU_VERSION_1_1: Boolean;
GLU_VERSION_1_2: Boolean;
GLU_VERSION_1_3: Boolean;
GL_ARB_blend_func_extended: Boolean;
GL_ARB_color_buffer_float: Boolean;
GL_ARB_compatibility: Boolean;
GL_ARB_copy_buffer: Boolean;
GL_ARB_debug_output: Boolean;
GL_ARB_depth_buffer_float: Boolean;
GL_ARB_depth_clamp: Boolean;
GL_ARB_depth_texture: Boolean;
GL_ARB_draw_buffers: Boolean;
GL_ARB_draw_buffers_blend: Boolean;
GL_ARB_draw_elements_base_vertex: Boolean;
GL_ARB_draw_indirect: Boolean;
GL_ARB_draw_instanced: Boolean;
GL_ARB_ES2_compatibility: Boolean;
GL_ARB_explicit_attrib_location: Boolean;
GL_ARB_fragment_coord_conventions: Boolean;
GL_ARB_fragment_program: Boolean;
GL_ARB_fragment_program_shadow: Boolean;
GL_ARB_fragment_shader: Boolean;
GL_ARB_framebuffer_object: Boolean;
GL_ARB_framebuffer_sRGB: Boolean;
GL_ARB_geometry_shader4: Boolean;
GL_ARB_get_program_binary: Boolean;
GL_ARB_gpu_shader_fp64: Boolean;
GL_ARB_gpu_shader5: Boolean;
GL_ARB_half_float_pixel: Boolean;
GL_ARB_half_float_vertex: Boolean;
GL_ARB_imaging: Boolean;
GL_ARB_instanced_arrays: Boolean;
GL_ARB_map_buffer_range: Boolean;
GL_ARB_matrix_palette: Boolean;
GL_ARB_multisample: Boolean;
GL_ARB_multitexture: Boolean;
GL_ARB_occlusion_query: Boolean;
GL_ARB_occlusion_query2: Boolean;
GL_ARB_pixel_buffer_object: Boolean;
GL_ARB_point_parameters: Boolean;
GL_ARB_point_sprite: Boolean;
GL_ARB_provoking_vertex: Boolean;
GL_ARB_robustness: Boolean;
GL_ARB_sample_shading: Boolean;
GL_ARB_sampler_objects: Boolean;
GL_ARB_seamless_cube_map: Boolean;
GL_ARB_separate_shader_objects: Boolean;
GL_ARB_shader_bit_encoding: Boolean;
GL_ARB_shader_precision: Boolean;
GL_ARB_shader_stencil_export: Boolean;
GL_ARB_shader_subroutine: Boolean;
GL_ARB_shader_texture_lod: Boolean;
GL_ARB_shading_language_100: Boolean;
GL_ARB_shadow: Boolean;
GL_ARB_shadow_ambient: Boolean;
GL_ARB_shader_objects: Boolean;
GL_ARB_sync: Boolean;
GL_ARB_tessellation_shader: Boolean;
GL_ARB_texture_border_clamp: Boolean;
GL_ARB_texture_buffer_object: Boolean;
GL_ARB_texture_buffer_object_rgb32: Boolean;
GL_ARB_texture_compression: Boolean;
GL_ARB_texture_compression_rgtc: Boolean;
GL_ARB_texture_cube_map: Boolean;
GL_ARB_texture_cube_map_array: Boolean;
GL_ARB_texture_env_add: Boolean;
GL_ARB_texture_env_combine: Boolean;
GL_ARB_texture_env_crossbar: Boolean;
GL_ARB_texture_env_dot3: Boolean;
GL_ARB_texture_float: Boolean;
GL_ARB_texture_gather: Boolean;
GL_ARB_texture_mirrored_repeat: Boolean;
GL_ARB_texture_multisample: Boolean;
GL_ARB_texture_non_power_of_two: Boolean;
GL_ARB_texture_query_lod: Boolean;
GL_ARB_texture_rectangle: Boolean;
GL_ARB_texture_rg: Boolean;
GL_ARB_texture_rgb10_a2ui: Boolean;
GL_ARB_texture_swizzle: Boolean;
GL_ARB_timer_query: Boolean;
GL_ARB_transform_feedback2: Boolean;
GL_ARB_transform_feedback3: Boolean;
GL_ARB_transpose_matrix: Boolean;
GL_ARB_uniform_buffer_object: Boolean;
GL_ARB_vertex_array_bgra: Boolean;
GL_ARB_vertex_array_object: Boolean;
GL_ARB_vertex_attrib_64bit: Boolean;
GL_ARB_vertex_blend: Boolean;
GL_ARB_vertex_buffer_object: Boolean;
GL_ARB_vertex_program: Boolean;
GL_ARB_vertex_shader: Boolean;
GL_ARB_vertex_type_2_10_10_10_rev: Boolean;
GL_ARB_viewport_array: Boolean;
GL_ARB_window_pos: Boolean;
GL_ARB_texture_compression_bptc: Boolean;
GL_3DFX_multisample: Boolean;
GL_3DFX_tbuffer: Boolean;
GL_3DFX_texture_compression_FXT1: Boolean;
GL_ATI_draw_buffers: Boolean;
GL_ATI_texture_compression_3dc: Boolean;
GL_ATI_texture_float: Boolean;
GL_ATI_texture_mirror_once: Boolean;
GL_S3_s3tc: Boolean;
GL_EXT_abgr: Boolean;
GL_EXT_bgra: Boolean;
GL_EXT_bindable_uniform: Boolean;
GL_EXT_blend_color: Boolean;
GL_EXT_blend_equation_separate: Boolean;
GL_EXT_blend_func_separate: Boolean;
GL_EXT_blend_logic_op: Boolean;
GL_EXT_blend_minmax: Boolean;
GL_EXT_blend_subtract: Boolean;
GL_EXT_Cg_shader: Boolean;
GL_EXT_clip_volume_hint: Boolean;
GL_EXT_compiled_vertex_array: Boolean;
GL_EXT_copy_texture: Boolean;
GL_EXT_depth_bounds_test: Boolean;
GL_EXT_draw_buffers2: Boolean;
GL_EXT_draw_instanced: Boolean;
GL_EXT_draw_range_elements: Boolean;
GL_EXT_fog_coord: Boolean;
GL_EXT_framebuffer_blit: Boolean;
GL_EXT_framebuffer_multisample: Boolean;
GL_EXT_framebuffer_object: Boolean;
GL_EXT_framebuffer_sRGB: Boolean;
GL_EXT_geometry_shader4: Boolean;
GL_EXT_gpu_program_parameters: Boolean;
GL_EXT_gpu_shader4: Boolean;
GL_EXT_multi_draw_arrays: Boolean;
GL_EXT_multisample: Boolean;
GL_EXT_packed_depth_stencil: Boolean;
GL_EXT_packed_float: Boolean;
GL_EXT_packed_pixels: Boolean;
GL_EXT_paletted_texture: Boolean;
GL_EXT_pixel_buffer_object: Boolean;
GL_EXT_polygon_offset: Boolean;
GL_EXT_rescale_normal: Boolean;
GL_EXT_secondary_color: Boolean;
GL_EXT_separate_specular_color: Boolean;
GL_EXT_shadow_funcs: Boolean;
GL_EXT_shared_texture_palette: Boolean;
GL_EXT_stencil_clear_tag: Boolean;
GL_EXT_stencil_two_side: Boolean;
GL_EXT_stencil_wrap: Boolean;
GL_EXT_texture3D: Boolean;
GL_EXT_texture_array: Boolean;
GL_EXT_texture_buffer_object: Boolean;
GL_EXT_texture_compression_latc: Boolean;
GL_EXT_texture_compression_rgtc: Boolean;
GL_EXT_texture_compression_s3tc: Boolean;
GL_EXT_texture_cube_map: Boolean;
GL_EXT_texture_edge_clamp: Boolean;
GL_EXT_texture_env_add: Boolean;
GL_EXT_texture_env_combine: Boolean;
GL_EXT_texture_env_dot3: Boolean;
GL_EXT_texture_filter_anisotropic: Boolean;
GL_EXT_texture_integer: Boolean;
GL_EXT_texture_lod: Boolean;
GL_EXT_texture_lod_bias: Boolean;
GL_EXT_texture_mirror_clamp: Boolean;
GL_EXT_texture_object: Boolean;
GL_EXT_texture_rectangle: Boolean;
GL_EXT_texture_sRGB: Boolean;
GL_EXT_texture_shared_exponent: Boolean;
GL_EXT_timer_query: Boolean;
GL_EXT_transform_feedback: Boolean;
GL_EXT_vertex_array: Boolean;
GL_HP_occlusion_test: Boolean;
GL_IBM_rasterpos_clip: Boolean;
GL_KTX_buffer_region: Boolean;
GL_MESA_resize_buffers: Boolean;
GL_NV_blend_square: Boolean;
GL_NV_conditional_render: Boolean;
GL_NV_copy_image: Boolean;
GL_NV_depth_buffer_float: Boolean;
GL_NV_fence: Boolean;
GL_NV_float_buffer: Boolean;
GL_NV_fog_distance: Boolean;
GL_NV_geometry_program4: Boolean;
GL_NV_light_max_exponent: Boolean;
GL_NV_multisample_filter_hint: Boolean;
GL_NV_occlusion_query: Boolean;
GL_NV_point_sprite: Boolean;
GL_NV_primitive_restart: Boolean;
GL_NV_register_combiners: Boolean;
GL_NV_shader_buffer_load: Boolean;
GL_NV_texgen_reflection: Boolean;
GL_NV_texture_compression_vtc: Boolean;
GL_NV_texture_env_combine4: Boolean;
GL_NV_texture_rectangle: Boolean;
GL_NV_texture_shader: Boolean;
GL_NV_texture_shader2: Boolean;
GL_NV_texture_shader3: Boolean;
GL_NV_transform_feedback: Boolean;
GL_NV_vertex_array_range: Boolean;
GL_NV_vertex_array_range2: Boolean;
GL_NV_vertex_buffer_unified_memory: Boolean;
GL_NV_vertex_program: Boolean;
GL_SGI_color_matrix: Boolean;
GL_SGIS_generate_mipmap: Boolean;
GL_SGIS_multisample: Boolean;
GL_SGIS_texture_border_clamp: Boolean;
GL_SGIS_texture_color_mask: Boolean;
GL_SGIS_texture_edge_clamp: Boolean;
GL_SGIS_texture_lod: Boolean;
GL_SGIX_depth_texture: Boolean;
GL_SGIX_shadow: Boolean;
GL_SGIX_shadow_ambient: Boolean;
GL_AMD_vertex_shader_tessellator: Boolean;
GL_WIN_swap_hint: Boolean;
WGL_ARB_buffer_region: Boolean;
WGL_ARB_create_context: Boolean;
WGL_ARB_create_context_profile: Boolean;
WGL_ARB_extensions_string: Boolean;
WGL_ARB_framebuffer_sRGB: Boolean;
WGL_ARB_make_current_read: Boolean;
WGL_ARB_multisample: Boolean;
WGL_ARB_pbuffer: Boolean;
WGL_ARB_pixel_format: Boolean;
WGL_ARB_pixel_format_float: Boolean;
WGL_ARB_render_texture: Boolean;
WGL_ATI_pixel_format_float: Boolean;
WGL_EXT_framebuffer_sRGB: Boolean;
WGL_EXT_pixel_format_packed_float: Boolean;
WGL_EXT_swap_control: Boolean;
WGL_NV_gpu_affinity: Boolean;
GLX_VERSION_1_1: Boolean;
GLX_VERSION_1_2: Boolean;
GLX_VERSION_1_3: Boolean;
GLX_VERSION_1_4: Boolean;
GLX_ARB_create_context: Boolean;
GLX_ARB_create_context_profile: Boolean;
GLX_ARB_framebuffer_sRGB: Boolean;
GLX_ARB_multisample: Boolean;
GLX_EXT_framebuffer_sRGB: Boolean;
GLX_EXT_fbconfig_packed_float: Boolean;
GLX_SGIS_multisample: Boolean;
GLX_EXT_visual_info: Boolean;
GLX_SGI_swap_control: Boolean;
GLX_SGI_video_sync: Boolean;
GLX_SGI_make_current_read: Boolean;
GLX_SGIX_video_source: Boolean;
GLX_EXT_visual_rating: Boolean;
GLX_EXT_import_context: Boolean;
GLX_SGIX_fbconfig: Boolean;
GLX_SGIX_pbuffer: Boolean;
GLX_SGI_cushion: Boolean;
GLX_SGIX_video_resize: Boolean;
GLX_SGIX_dmbuffer: Boolean;
GLX_SGIX_swap_group: Boolean;
GLX_SGIX_swap_barrier: Boolean;
GLX_SGIS_blended_overlay: Boolean;
GLX_SGIS_shared_multisample: Boolean;
GLX_SUN_get_transparent_index: Boolean;
GLX_3DFX_multisample: Boolean;
GLX_MESA_copy_sub_buffer: Boolean;
GLX_MESA_pixmap_colormap: Boolean;
GLX_MESA_release_buffers: Boolean;
GLX_MESA_set_3dfx_mode: Boolean;
GLX_SGIX_visual_select_group: Boolean;
GLX_SGIX_hyperpipe: Boolean;
GL_GREMEDY_frame_terminator: Boolean;
GL_GREMEDY_string_marker: Boolean;
GLU_EXT_object_space_tess: Boolean;
GLU_EXT_nurbs_tessellator: Boolean;
GLU_EXT_Texture: Boolean;
glBlendColor: PFNGLBLENDCOLORPROC;
glBlendEquation: PFNGLBLENDEQUATIONPROC;
glDrawRangeElements: PFNGLDRAWRANGEELEMENTSPROC;
glTexImage3D: PFNGLTEXIMAGE3DPROC;
glTexSubImage3D: PFNGLTEXSUBIMAGE3DPROC;
glCopyTexSubImage3D: PFNGLCOPYTEXSUBIMAGE3DPROC;
glColorTable: PFNGLCOLORTABLEPROC;
glColorTableParameterfv: PFNGLCOLORTABLEPARAMETERFVPROC;
glColorTableParameteriv: PFNGLCOLORTABLEPARAMETERIVPROC;
glCopyColorTable: PFNGLCOPYCOLORTABLEPROC;
glGetColorTable: PFNGLGETCOLORTABLEPROC;
glGetColorTableParameterfv: PFNGLGETCOLORTABLEPARAMETERFVPROC;
glGetColorTableParameteriv: PFNGLGETCOLORTABLEPARAMETERIVPROC;
glColorSubTable: PFNGLCOLORSUBTABLEPROC;
glCopyColorSubTable: PFNGLCOPYCOLORSUBTABLEPROC;
glConvolutionFilter1D: PFNGLCONVOLUTIONFILTER1DPROC;
glConvolutionFilter2D: PFNGLCONVOLUTIONFILTER2DPROC;
glConvolutionParameterf: PFNGLCONVOLUTIONPARAMETERFPROC;
glConvolutionParameterfv: PFNGLCONVOLUTIONPARAMETERFVPROC;
glConvolutionParameteri: PFNGLCONVOLUTIONPARAMETERIPROC;
glConvolutionParameteriv: PFNGLCONVOLUTIONPARAMETERIVPROC;
glCopyConvolutionFilter1D: PFNGLCOPYCONVOLUTIONFILTER1DPROC;
glCopyConvolutionFilter2D: PFNGLCOPYCONVOLUTIONFILTER2DPROC;
glGetConvolutionFilter: PFNGLGETCONVOLUTIONFILTERPROC;
glGetConvolutionParameterfv: PFNGLGETCONVOLUTIONPARAMETERFVPROC;
glGetConvolutionParameteriv: PFNGLGETCONVOLUTIONPARAMETERIVPROC;
glGetSeparableFilter: PFNGLGETSEPARABLEFILTERPROC;
glSeparableFilter2D: PFNGLSEPARABLEFILTER2DPROC;
glGetHistogram: PFNGLGETHISTOGRAMPROC;
glGetHistogramParameterfv: PFNGLGETHISTOGRAMPARAMETERFVPROC;
glGetHistogramParameteriv: PFNGLGETHISTOGRAMPARAMETERIVPROC;
glGetMinmax: PFNGLGETMINMAXPROC;
glGetMinmaxParameterfv: PFNGLGETMINMAXPARAMETERFVPROC;
glGetMinmaxParameteriv: PFNGLGETMINMAXPARAMETERIVPROC;
glHistogram: PFNGLHISTOGRAMPROC;
glMinmax: PFNGLMINMAXPROC;
glResetHistogram: PFNGLRESETHISTOGRAMPROC;
glResetMinmax: PFNGLRESETMINMAXPROC;
glActiveTexture: PFNGLACTIVETEXTUREPROC;
glSampleCoverage: PFNGLSAMPLECOVERAGEPROC;
glCompressedTexImage3D: PFNGLCOMPRESSEDTEXIMAGE3DPROC;
glCompressedTexImage2D: PFNGLCOMPRESSEDTEXIMAGE2DPROC;
glCompressedTexImage1D: PFNGLCOMPRESSEDTEXIMAGE1DPROC;
glCompressedTexSubImage3D: PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC;
glCompressedTexSubImage2D: PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC;
glCompressedTexSubImage1D: PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC;
glGetCompressedTexImage: PFNGLGETCOMPRESSEDTEXIMAGEPROC;
glClientActiveTexture: PFNGLCLIENTACTIVETEXTUREPROC;
glMultiTexCoord1d: PFNGLMULTITEXCOORD1DPROC;
glMultiTexCoord1dV: PFNGLMULTITEXCOORD1DVPROC;
glMultiTexCoord1f: PFNGLMULTITEXCOORD1FPROC;
glMultiTexCoord1fV: PFNGLMULTITEXCOORD1FVPROC;
glMultiTexCoord1i: PFNGLMULTITEXCOORD1IPROC;
glMultiTexCoord1iV: PFNGLMULTITEXCOORD1IVPROC;
glMultiTexCoord1s: PFNGLMULTITEXCOORD1SPROC;
glMultiTexCoord1sV: PFNGLMULTITEXCOORD1SVPROC;
glMultiTexCoord2d: PFNGLMULTITEXCOORD2DPROC;
glMultiTexCoord2dv: PFNGLMULTITEXCOORD2DVPROC;
glMultiTexCoord2f: PFNGLMULTITEXCOORD2FPROC;
glMultiTexCoord2fv: PFNGLMULTITEXCOORD2FVPROC;
glMultiTexCoord2i: PFNGLMULTITEXCOORD2IPROC;
glMultiTexCoord2iv: PFNGLMULTITEXCOORD2IVPROC;
glMultiTexCoord2s: PFNGLMULTITEXCOORD2SPROC;
glMultiTexCoord2sv: PFNGLMULTITEXCOORD2SVPROC;
glMultiTexCoord3d: PFNGLMULTITEXCOORD3DPROC;
glMultiTexCoord3dv: PFNGLMULTITEXCOORD3DVPROC;
glMultiTexCoord3f: PFNGLMULTITEXCOORD3FPROC;
glMultiTexCoord3fv: PFNGLMULTITEXCOORD3FVPROC;
glMultiTexCoord3i: PFNGLMULTITEXCOORD3IPROC;
glMultiTexCoord3iv: PFNGLMULTITEXCOORD3IVPROC;
glMultiTexCoord3s: PFNGLMULTITEXCOORD3SPROC;
glMultiTexCoord3sv: PFNGLMULTITEXCOORD3SVPROC;
glMultiTexCoord4d: PFNGLMULTITEXCOORD4DPROC;
glMultiTexCoord4dv: PFNGLMULTITEXCOORD4DVPROC;
glMultiTexCoord4f: PFNGLMULTITEXCOORD4FPROC;
glMultiTexCoord4fv: PFNGLMULTITEXCOORD4FVPROC;
glMultiTexCoord4i: PFNGLMULTITEXCOORD4IPROC;
glMultiTexCoord4iv: PFNGLMULTITEXCOORD4IVPROC;
glMultiTexCoord4s: PFNGLMULTITEXCOORD4SPROC;
glMultiTexCoord4sv: PFNGLMULTITEXCOORD4SVPROC;
glLoadTransposeMatrixf: PFNGLLOADTRANSPOSEMATRIXFPROC;
glLoadTransposeMatrixd: PFNGLLOADTRANSPOSEMATRIXDPROC;
glMultTransposeMatrixf: PFNGLMULTTRANSPOSEMATRIXFPROC;
glMultTransposeMatrixd: PFNGLMULTTRANSPOSEMATRIXDPROC;
glBlendFuncSeparate: PFNGLBLENDFUNCSEPARATEPROC;
glMultiDrawArrays: PFNGLMULTIDRAWARRAYSPROC;
glMultiDrawElements: PFNGLMULTIDRAWELEMENTSPROC;
glPointParameterf: PFNGLPOINTPARAMETERFPROC;
glPointParameterfv: PFNGLPOINTPARAMETERFVPROC;
glPointParameteri: PFNGLPOINTPARAMETERIPROC;
glPointParameteriv: PFNGLPOINTPARAMETERIVPROC;
glFogCoordf: PFNGLFOGCOORDFPROC;
glFogCoordfv: PFNGLFOGCOORDFVPROC;
glFogCoordd: PFNGLFOGCOORDDPROC;
glFogCoorddv: PFNGLFOGCOORDDVPROC;
glFogCoordPointer: PFNGLFOGCOORDPOINTERPROC;
glSecondaryColor3b: PFNGLSECONDARYCOLOR3BPROC;
glSecondaryColor3bv: PFNGLSECONDARYCOLOR3BVPROC;
glSecondaryColor3d: PFNGLSECONDARYCOLOR3DPROC;
glSecondaryColor3dv: PFNGLSECONDARYCOLOR3DVPROC;
glSecondaryColor3f: PFNGLSECONDARYCOLOR3FPROC;
glSecondaryColor3fv: PFNGLSECONDARYCOLOR3FVPROC;
glSecondaryColor3i: PFNGLSECONDARYCOLOR3IPROC;
glSecondaryColor3iv: PFNGLSECONDARYCOLOR3IVPROC;
glSecondaryColor3s: PFNGLSECONDARYCOLOR3SPROC;
glSecondaryColor3sv: PFNGLSECONDARYCOLOR3SVPROC;
glSecondaryColor3ub: PFNGLSECONDARYCOLOR3UBPROC;
glSecondaryColor3ubv: PFNGLSECONDARYCOLOR3UBVPROC;
glSecondaryColor3ui: PFNGLSECONDARYCOLOR3UIPROC;
glSecondaryColor3uiv: PFNGLSECONDARYCOLOR3UIVPROC;
glSecondaryColor3us: PFNGLSECONDARYCOLOR3USPROC;
glSecondaryColor3usv: PFNGLSECONDARYCOLOR3USVPROC;
glSecondaryColorPointer: PFNGLSECONDARYCOLORPOINTERPROC;
glWindowPos2d: PFNGLWINDOWPOS2DPROC;
glWindowPos2dv: PFNGLWINDOWPOS2DVPROC;
glWindowPos2f: PFNGLWINDOWPOS2FPROC;
glWindowPos2fv: PFNGLWINDOWPOS2FVPROC;
glWindowPos2i: PFNGLWINDOWPOS2IPROC;
glWindowPos2iv: PFNGLWINDOWPOS2IVPROC;
glWindowPos2s: PFNGLWINDOWPOS2SPROC;
glWindowPos2sv: PFNGLWINDOWPOS2SVPROC;
glWindowPos3d: PFNGLWINDOWPOS3DPROC;
glWindowPos3dv: PFNGLWINDOWPOS3DVPROC;
glWindowPos3f: PFNGLWINDOWPOS3FPROC;
glWindowPos3fv: PFNGLWINDOWPOS3FVPROC;
glWindowPos3i: PFNGLWINDOWPOS3IPROC;
glWindowPos3iv: PFNGLWINDOWPOS3IVPROC;
glWindowPos3s: PFNGLWINDOWPOS3SPROC;
glWindowPos3sv: PFNGLWINDOWPOS3SVPROC;
glGenQueries: PFNGLGENQUERIESPROC;
glDeleteQueries: PFNGLDELETEQUERIESPROC;
glIsQuery: PFNGLISQUERYPROC;
glBeginQuery: PFNGLBEGINQUERYPROC;
glEndQuery: PFNGLENDQUERYPROC;
glGetQueryiv: PFNGLGETQUERYIVPROC;
glGetQueryObjectiv: PFNGLGETQUERYOBJECTIVPROC;
glGetQueryObjectuiv: PFNGLGETQUERYOBJECTUIVPROC;
glBindBuffer: PFNGLBINDBUFFERPROC;
glDeleteBuffers: PFNGLDELETEBUFFERSPROC;
glGenBuffers: PFNGLGENBUFFERSPROC;
glIsBuffer: PFNGLISBUFFERPROC;
glBufferData: PFNGLBUFFERDATAPROC;
glBufferSubData: PFNGLBUFFERSUBDATAPROC;
glGetBufferSubData: PFNGLGETBUFFERSUBDATAPROC;
glMapBuffer: PFNGLMAPBUFFERPROC;
glUnmapBuffer: PFNGLUNMAPBUFFERPROC;
glGetBufferParameteriv: PFNGLGETBUFFERPARAMETERIVPROC;
glGetBufferPointerv: PFNGLGETBUFFERPOINTERVPROC;
glBlendEquationSeparate: PFNGLBLENDEQUATIONSEPARATEPROC;
glDrawBuffers: PFNGLDRAWBUFFERSPROC;
glStencilOpSeparate: PFNGLSTENCILOPSEPARATEPROC;
glStencilFuncSeparate: PFNGLSTENCILFUNCSEPARATEPROC;
glStencilMaskSeparate: PFNGLSTENCILMASKSEPARATEPROC;
glAttachShader: PFNGLATTACHSHADERPROC;
glBindAttribLocation: PFNGLBINDATTRIBLOCATIONPROC;
glCompileShader: PFNGLCOMPILESHADERPROC;
glCreateProgram: PFNGLCREATEPROGRAMPROC;
glCreateShader: PFNGLCREATESHADERPROC;
glDeleteProgram: PFNGLDELETEPROGRAMPROC;
glDeleteShader: PFNGLDELETESHADERPROC;
glDetachShader: PFNGLDETACHSHADERPROC;
glDisableVertexAttribArray: PFNGLDISABLEVERTEXATTRIBARRAYPROC;
glEnableVertexAttribArray: PFNGLENABLEVERTEXATTRIBARRAYPROC;
glGetActiveAttrib: PFNGLGETACTIVEATTRIBPROC;
glGetActiveUniform: PFNGLGETACTIVEUNIFORMPROC;
glGetAttachedShaders: PFNGLGETATTACHEDSHADERSPROC;
glGetAttribLocation: PFNGLGETATTRIBLOCATIONPROC;
glGetProgramiv: PFNGLGETPROGRAMIVPROC;
glGetProgramInfoLog: PFNGLGETPROGRAMINFOLOGPROC;
glGetShaderiv: PFNGLGETSHADERIVPROC;
glGetShaderInfoLog: PFNGLGETSHADERINFOLOGPROC;
glGetShaderSource: PFNGLGETSHADERSOURCEPROC;
glGetUniformLocation: PFNGLGETUNIFORMLOCATIONPROC;
glGetUniformfv: PFNGLGETUNIFORMFVPROC;
glGetUniformiv: PFNGLGETUNIFORMIVPROC;
glGetVertexAttribdv: PFNGLGETVERTEXATTRIBDVPROC;
glGetVertexAttribfv: PFNGLGETVERTEXATTRIBFVPROC;
glGetVertexAttribiv: PFNGLGETVERTEXATTRIBIVPROC;
glGetVertexAttribPointerv: PFNGLGETVERTEXATTRIBPOINTERVPROC;
glIsProgram: PFNGLISPROGRAMPROC;
glIsShader: PFNGLISSHADERPROC;
glLinkProgram: PFNGLLINKPROGRAMPROC;
glShaderSource: PFNGLSHADERSOURCEPROC;
glUseProgram: PFNGLUSEPROGRAMPROC;
glUniform1f: PFNGLUNIFORM1FPROC;
glUniform2f: PFNGLUNIFORM2FPROC;
glUniform3f: PFNGLUNIFORM3FPROC;
glUniform4f: PFNGLUNIFORM4FPROC;
glUniform1i: PFNGLUNIFORM1IPROC;
glUniform2i: PFNGLUNIFORM2IPROC;
glUniform3i: PFNGLUNIFORM3IPROC;
glUniform4i: PFNGLUNIFORM4IPROC;
glUniform1fv: PFNGLUNIFORM1FVPROC;
glUniform2fv: PFNGLUNIFORM2FVPROC;
glUniform3fv: PFNGLUNIFORM3FVPROC;
glUniform4fv: PFNGLUNIFORM4FVPROC;
glUniform1iv: PFNGLUNIFORM1IVPROC;
glUniform2iv: PFNGLUNIFORM2IVPROC;
glUniform3iv: PFNGLUNIFORM3IVPROC;
glUniform4iv: PFNGLUNIFORM4IVPROC;
glUniformMatrix2fv: PFNGLUNIFORMMATRIX2FVPROC;
glUniformMatrix3fv: PFNGLUNIFORMMATRIX3FVPROC;
glUniformMatrix4fv: PFNGLUNIFORMMATRIX4FVPROC;
glValidateProgram: PFNGLVALIDATEPROGRAMPROC;
glVertexAttrib1d: PFNGLVERTEXATTRIB1DPROC;
glVertexAttrib1dv: PFNGLVERTEXATTRIB1DVPROC;
glVertexAttrib1f: PFNGLVERTEXATTRIB1FPROC;
glVertexAttrib1fv: PFNGLVERTEXATTRIB1FVPROC;
glVertexAttrib1s: PFNGLVERTEXATTRIB1SPROC;
glVertexAttrib1sv: PFNGLVERTEXATTRIB1SVPROC;
glVertexAttrib2d: PFNGLVERTEXATTRIB2DPROC;
glVertexAttrib2dv: PFNGLVERTEXATTRIB2DVPROC;
glVertexAttrib2f: PFNGLVERTEXATTRIB2FPROC;
glVertexAttrib2fv: PFNGLVERTEXATTRIB2FVPROC;
glVertexAttrib2s: PFNGLVERTEXATTRIB2SPROC;
glVertexAttrib2sv: PFNGLVERTEXATTRIB2SVPROC;
glVertexAttrib3d: PFNGLVERTEXATTRIB3DPROC;
glVertexAttrib3dv: PFNGLVERTEXATTRIB3DVPROC;
glVertexAttrib3f: PFNGLVERTEXATTRIB3FPROC;
glVertexAttrib3fv: PFNGLVERTEXATTRIB3FVPROC;
glVertexAttrib3s: PFNGLVERTEXATTRIB3SPROC;
glVertexAttrib3sv: PFNGLVERTEXATTRIB3SVPROC;
glVertexAttrib4Nbv: PFNGLVERTEXATTRIB4NBVPROC;
glVertexAttrib4Niv: PFNGLVERTEXATTRIB4NIVPROC;
glVertexAttrib4Nsv: PFNGLVERTEXATTRIB4NSVPROC;
glVertexAttrib4Nub: PFNGLVERTEXATTRIB4NUBPROC;
glVertexAttrib4Nubv: PFNGLVERTEXATTRIB4NUBVPROC;
glVertexAttrib4Nuiv: PFNGLVERTEXATTRIB4NUIVPROC;
glVertexAttrib4Nusv: PFNGLVERTEXATTRIB4NUSVPROC;
glVertexAttrib4bv: PFNGLVERTEXATTRIB4BVPROC;
glVertexAttrib4d: PFNGLVERTEXATTRIB4DPROC;
glVertexAttrib4dv: PFNGLVERTEXATTRIB4DVPROC;
glVertexAttrib4f: PFNGLVERTEXATTRIB4FPROC;
glVertexAttrib4fv: PFNGLVERTEXATTRIB4FVPROC;
glVertexAttrib4iv: PFNGLVERTEXATTRIB4IVPROC;
glVertexAttrib4s: PFNGLVERTEXATTRIB4SPROC;
glVertexAttrib4sv: PFNGLVERTEXATTRIB4SVPROC;
glVertexAttrib4ubv: PFNGLVERTEXATTRIB4UBVPROC;
glVertexAttrib4uiv: PFNGLVERTEXATTRIB4UIVPROC;
glVertexAttrib4usv: PFNGLVERTEXATTRIB4USVPROC;
glVertexAttribPointer: PFNGLVERTEXATTRIBPOINTERPROC;
glUniformMatrix2x3fv: PFNGLUNIFORMMATRIX2X3FVPROC;
glUniformMatrix3x2fv: PFNGLUNIFORMMATRIX3X2FVPROC;
glUniformMatrix2x4fv: PFNGLUNIFORMMATRIX2X4FVPROC;
glUniformMatrix4x2fv: PFNGLUNIFORMMATRIX4X2FVPROC;
glUniformMatrix3x4fv: PFNGLUNIFORMMATRIX3X4FVPROC;
glUniformMatrix4x3fv: PFNGLUNIFORMMATRIX4X3FVPROC;
glVertexAttribI1i: PFNGLVERTEXATTRIBI1IPROC;
glVertexAttribI2i: PFNGLVERTEXATTRIBI2IPROC;
glVertexAttribI3i: PFNGLVERTEXATTRIBI3IPROC;
glVertexAttribI4i: PFNGLVERTEXATTRIBI4IPROC;
glVertexAttribI1ui: PFNGLVERTEXATTRIBI1UIPROC;
glVertexAttribI2ui: PFNGLVERTEXATTRIBI2UIPROC;
glVertexAttribI3ui: PFNGLVERTEXATTRIBI3UIPROC;
glVertexAttribI4ui: PFNGLVERTEXATTRIBI4UIPROC;
glVertexAttribI1iv: PFNGLVERTEXATTRIBI1IVPROC;
glVertexAttribI2iv: PFNGLVERTEXATTRIBI2IVPROC;
glVertexAttribI3iv: PFNGLVERTEXATTRIBI3IVPROC;
glVertexAttribI4iv: PFNGLVERTEXATTRIBI4IVPROC;
glVertexAttribI1uiv: PFNGLVERTEXATTRIBI1UIVPROC;
glVertexAttribI2uiv: PFNGLVERTEXATTRIBI2UIVPROC;
glVertexAttribI3uiv: PFNGLVERTEXATTRIBI3UIVPROC;
glVertexAttribI4uiv: PFNGLVERTEXATTRIBI4UIVPROC;
glVertexAttribI4bv: PFNGLVERTEXATTRIBI4BVPROC;
glVertexAttribI4sv: PFNGLVERTEXATTRIBI4SVPROC;
glVertexAttribI4ubv: PFNGLVERTEXATTRIBI4UBVPROC;
glVertexAttribI4usv: PFNGLVERTEXATTRIBI4USVPROC;
glVertexAttribIPointer: PFNGLVERTEXATTRIBIPOINTERPROC;
glGetVertexAttribIiv: PFNGLGETVERTEXATTRIBIIVPROC;
glGetVertexAttribIuiv: PFNGLGETVERTEXATTRIBIUIVPROC;
glUniform1ui: PFNGLUNIFORM1UIPROC;
glUniform2ui: PFNGLUNIFORM2UIPROC;
glUniform3ui: PFNGLUNIFORM3UIPROC;
glUniform4ui: PFNGLUNIFORM4UIPROC;
glUniform1uiv: PFNGLUNIFORM1UIVPROC;
glUniform2uiv: PFNGLUNIFORM2UIVPROC;
glUniform3uiv: PFNGLUNIFORM3UIVPROC;
glUniform4uiv: PFNGLUNIFORM4UIVPROC;
glGetUniformuiv: PFNGLGETUNIFORMUIVPROC;
glBindFragDataLocation: PFNGLBINDFRAGDATALOCATIONPROC;
glGetFragDataLocation: PFNGLGETFRAGDATALOCATIONPROC;
glBeginConditionalRender: PFNGLBEGINCONDITIONALRENDERPROC;
glEndConditionalRender: PFNGLENDCONDITIONALRENDERPROC;
glClampColor: PFNGLCLAMPCOLORPROC;
glTexParameterIiv: PFNGLTEXPARAMETERIIVPROC;
glTexParameterIuiv: PFNGLTEXPARAMETERIUIVPROC;
glGetTexParameterIiv: PFNGLGETTEXPARAMETERIIVPROC;
glGetTexParameterIuiv: PFNGLGETTEXPARAMETERIUIVPROC;
glColorMaski: PFNGLCOLORMASKIPROC;
glGetBooleani_v: PFNGLGETBOOLEANI_VPROC;
glGetIntegeri_v: PFNGLGETINTEGERI_VPROC;
glEnablei: PFNGLENABLEIPROC;
glDisablei: PFNGLDISABLEIPROC;
glIsEnabledi: PFNGLISENABLEDIPROC;
glBindBufferRange: PFNGLBINDBUFFERRANGEPROC;
glBindBufferBase: PFNGLBINDBUFFERBASEPROC;
glBeginTransformFeedback: PFNGLBEGINTRANSFORMFEEDBACKPROC;
glEndTransformFeedback: PFNGLENDTRANSFORMFEEDBACKPROC;
glTransformFeedbackVaryings: PFNGLTRANSFORMFEEDBACKVARYINGSPROC;
glGetTransformFeedbackVarying: PFNGLGETTRANSFORMFEEDBACKVARYINGPROC;
glClearBufferiv: PFNGLCLEARBUFFERIVPROC;
glClearBufferuiv: PFNGLCLEARBUFFERUIVPROC;
glClearBufferfv: PFNGLCLEARBUFFERFVPROC;
glClearBufferfi: PFNGLCLEARBUFFERFIPROC;
glGetStringi: PFNGLGETSTRINGIPROC;
glDrawArraysInstanced: PFNGLDRAWARRAYSINSTANCEDPROC;
glDrawElementsInstanced: PFNGLDRAWELEMENTSINSTANCEDPROC;
glTexBuffer: PFNGLTEXBUFFERPROC;
glPrimitiveRestartIndex: PFNGLPRIMITIVERESTARTINDEXPROC;
glGetInteger64i_v: PFNGLGETINTEGER64I_VPROC;
glGetBufferParameteri64v: PFNGLGETBUFFERPARAMETERI64VPROC;
glFramebufferTexture: PFNGLFRAMEBUFFERTEXTUREPROC;
glVertexAttribDivisor: PFNGLVERTEXATTRIBDIVISORPROC;
glMinSampleShading: PFNGLMINSAMPLESHADINGPROC;
glBlendEquationi: PFNGLBLENDEQUATIONIPROC;
glBlendEquationSeparatei: PFNGLBLENDEQUATIONSEPARATEIPROC;
glBlendFunci: PFNGLBLENDFUNCIPROC;
glBlendFuncSeparatei: PFNGLBLENDFUNCSEPARATEIPROC;
gluNurbsCallbackDataEXT: PFNGLUNURBSCALLBACKDATAEXTPROC;
gluNewNurbsTessellatorEXT: PFNGLUNEWNURBSTESSELLATOREXTPROC;
gluDeleteNurbsTessellatorEXT: PFNGLUDELETENURBSTESSELLATOREXTPROC;
wglCreateBufferRegionARB: PFNWGLCREATEBUFFERREGIONARBPROC;
wglDeleteBufferRegionARB: PFNWGLDELETEBUFFERREGIONARBPROC;
wglSaveBufferRegionARB: PFNWGLSAVEBUFFERREGIONARBPROC;
wglRestoreBufferRegionARB: PFNWGLRESTOREBUFFERREGIONARBPROC;
wglGetExtensionsStringARB: PFNWGLGETEXTENSIONSSTRINGARBPROC;
wglGetPixelFormatAttribivARB: PFNWGLGETPIXELFORMATATTRIBIVARBPROC;
wglGetPixelFormatAttribfvARB: PFNWGLGETPIXELFORMATATTRIBFVARBPROC;
wglChoosePixelFormatARB: PFNWGLCHOOSEPIXELFORMATARBPROC;
wglMakeContextCurrentARB: PFNWGLMAKECONTEXTCURRENTARBPROC;
wglGetCurrentReadDCARB: PFNWGLGETCURRENTREADDCARBPROC;
wglCreatePbufferARB: PFNWGLCREATEPBUFFERARBPROC;
wglGetPbufferDCARB: PFNWGLGETPBUFFERDCARBPROC;
wglReleasePbufferDCARB: PFNWGLRELEASEPBUFFERDCARBPROC;
wglDestroyPbufferARB: PFNWGLDESTROYPBUFFERARBPROC;
wglQueryPbufferARB: PFNWGLQUERYPBUFFERARBPROC;
wglBindTexImageARB: PFNWGLBINDTEXIMAGEARBPROC;
wglReleaseTexImageARB: PFNWGLRELEASETEXIMAGEARBPROC;
wglSetPbufferAttribARB: PFNWGLSETPBUFFERATTRIBARBPROC;
wglCreateContextAttribsARB: PFNWGLCREATECONTEXTATTRIBSARBPROC;
wglEnumGpusNV: PFNWGLENUMGPUSNVPROC;
wglEnumGpuDevicesNV: PFNWGLENUMGPUDEVICESNVPROC;
wglCreateAffinityDCNV: PFNWGLCREATEAFFINITYDCNVPROC;
wglEnumGpusFromAffinityDCNV: PFNWGLENUMGPUSFROMAFFINITYDCNVPROC;
wglDeleteDCNV: PFNWGLDELETEDCNVPROC;
wglSwapIntervalEXT: PFNWGLSWAPINTERVALEXTPROC;
wglGetSwapIntervalEXT: PFNWGLGETSWAPINTERVALEXTPROC;
glSamplePassARB: PFNGLSAMPLEPASSARBPROC;
glActiveTextureARB: PFNGLACTIVETEXTUREARBPROC;
glClientActiveTextureARB: PFNGLCLIENTACTIVETEXTUREARBPROC;
glMultiTexCoord1dARB: PFNGLMULTITEXCOORD1DARBPROC;
glMultiTexCoord1dVARB: PFNGLMULTITEXCOORD1DVARBPROC;
glMultiTexCoord1fARB: PFNGLMULTITEXCOORD1FARBPROC;
glMultiTexCoord1fVARB: PFNGLMULTITEXCOORD1FVARBPROC;
glMultiTexCoord1iARB: PFNGLMULTITEXCOORD1IARBPROC;
glMultiTexCoord1iVARB: PFNGLMULTITEXCOORD1IVARBPROC;
glMultiTexCoord1sARB: PFNGLMULTITEXCOORD1SARBPROC;
glMultiTexCoord1sVARB: PFNGLMULTITEXCOORD1SVARBPROC;
glMultiTexCoord2dARB: PFNGLMULTITEXCOORD2DARBPROC;
glMultiTexCoord2dvARB: PFNGLMULTITEXCOORD2DVARBPROC;
glMultiTexCoord2fARB: PFNGLMULTITEXCOORD2FARBPROC;
glMultiTexCoord2fvARB: PFNGLMULTITEXCOORD2FVARBPROC;
glMultiTexCoord2iARB: PFNGLMULTITEXCOORD2IARBPROC;
glMultiTexCoord2ivARB: PFNGLMULTITEXCOORD2IVARBPROC;
glMultiTexCoord2sARB: PFNGLMULTITEXCOORD2SARBPROC;
glMultiTexCoord2svARB: PFNGLMULTITEXCOORD2SVARBPROC;
glMultiTexCoord3dARB: PFNGLMULTITEXCOORD3DARBPROC;
glMultiTexCoord3dvARB: PFNGLMULTITEXCOORD3DVARBPROC;
glMultiTexCoord3fARB: PFNGLMULTITEXCOORD3FARBPROC;
glMultiTexCoord3fvARB: PFNGLMULTITEXCOORD3FVARBPROC;
glMultiTexCoord3iARB: PFNGLMULTITEXCOORD3IARBPROC;
glMultiTexCoord3ivARB: PFNGLMULTITEXCOORD3IVARBPROC;
glMultiTexCoord3sARB: PFNGLMULTITEXCOORD3SARBPROC;
glMultiTexCoord3svARB: PFNGLMULTITEXCOORD3SVARBPROC;
glMultiTexCoord4dARB: PFNGLMULTITEXCOORD4DARBPROC;
glMultiTexCoord4dvARB: PFNGLMULTITEXCOORD4DVARBPROC;
glMultiTexCoord4fARB: PFNGLMULTITEXCOORD4FARBPROC;
glMultiTexCoord4fvARB: PFNGLMULTITEXCOORD4FVARBPROC;
glMultiTexCoord4iARB: PFNGLMULTITEXCOORD4IARBPROC;
glMultiTexCoord4ivARB: PFNGLMULTITEXCOORD4IVARBPROC;
glMultiTexCoord4sARB: PFNGLMULTITEXCOORD4SARBPROC;
glMultiTexCoord4svARB: PFNGLMULTITEXCOORD4SVARBPROC;
glLoadTransposeMatrixfARB: PFNGLLOADTRANSPOSEMATRIXFARBPROC;
glLoadTransposeMatrixdARB: PFNGLLOADTRANSPOSEMATRIXDARBPROC;
glMultTransposeMatrixfARB: PFNGLMULTTRANSPOSEMATRIXFARBPROC;
glMultTransposeMatrixdARB: PFNGLMULTTRANSPOSEMATRIXDARBPROC;
glSampleCoverageARB: PFNGLSAMPLECOVERAGEARBPROC;
glCompressedTexImage3DARB: PFNGLCOMPRESSEDTEXIMAGE3DARBPROC;
glCompressedTexImage2DARB: PFNGLCOMPRESSEDTEXIMAGE2DARBPROC;
glCompressedTexImage1DARB: PFNGLCOMPRESSEDTEXIMAGE1DARBPROC;
glCompressedTexSubImage3DARB: PFNGLCOMPRESSEDTEXSUBIMAGE3DARBPROC;
glCompressedTexSubImage2DARB: PFNGLCOMPRESSEDTEXSUBIMAGE2DARBPROC;
glCompressedTexSubImage1DARB: PFNGLCOMPRESSEDTEXSUBIMAGE1DARBPROC;
glGetCompressedTexImageARB: PFNGLGETCOMPRESSEDTEXIMAGEARBPROC;
glPointParameterfARB: PFNGLPOINTPARAMETERFARBPROC;
glPointParameterfvARB: PFNGLPOINTPARAMETERFVARBPROC;
glWeightbvARB: PFNGLWEIGHTBVARBPROC;
glWeightsvARB: PFNGLWEIGHTSVARBPROC;
glWeightivARB: PFNGLWEIGHTIVARBPROC;
glWeightfvARB: PFNGLWEIGHTFVARBPROC;
glWeightdvARB: PFNGLWEIGHTDVARBPROC;
glWeightubvARB: PFNGLWEIGHTUBVARBPROC;
glWeightusvARB: PFNGLWEIGHTUSVARBPROC;
glWeightuivARB: PFNGLWEIGHTUIVARBPROC;
glWeightPointerARB: PFNGLWEIGHTPOINTERARBPROC;
glVertexBlendARB: PFNGLVERTEXBLENDARBPROC;
glCurrentPaletteMatrixARB: PFNGLCURRENTPALETTEMATRIXARBPROC;
glMatrixIndexubvARB: PFNGLMATRIXINDEXUBVARBPROC;
glMatrixIndexusvARB: PFNGLMATRIXINDEXUSVARBPROC;
glMatrixIndexuivARB: PFNGLMATRIXINDEXUIVARBPROC;
glMatrixIndexPointerARB: PFNGLMATRIXINDEXPOINTERARBPROC;
glWindowPos2dARB: PFNGLWINDOWPOS2DARBPROC;
glWindowPos2dvARB: PFNGLWINDOWPOS2DVARBPROC;
glWindowPos2fARB: PFNGLWINDOWPOS2FARBPROC;
glWindowPos2fvARB: PFNGLWINDOWPOS2FVARBPROC;
glWindowPos2iARB: PFNGLWINDOWPOS2IARBPROC;
glWindowPos2ivARB: PFNGLWINDOWPOS2IVARBPROC;
glWindowPos2sARB: PFNGLWINDOWPOS2SARBPROC;
glWindowPos2svARB: PFNGLWINDOWPOS2SVARBPROC;
glWindowPos3dARB: PFNGLWINDOWPOS3DARBPROC;
glWindowPos3dvARB: PFNGLWINDOWPOS3DVARBPROC;
glWindowPos3fARB: PFNGLWINDOWPOS3FARBPROC;
glWindowPos3fvARB: PFNGLWINDOWPOS3FVARBPROC;
glWindowPos3iARB: PFNGLWINDOWPOS3IARBPROC;
glWindowPos3ivARB: PFNGLWINDOWPOS3IVARBPROC;
glWindowPos3sARB: PFNGLWINDOWPOS3SARBPROC;
glWindowPos3svARB: PFNGLWINDOWPOS3SVARBPROC;
glVertexAttrib1dARB: PFNGLVERTEXATTRIB1DARBPROC;
glVertexAttrib1dvARB: PFNGLVERTEXATTRIB1DVARBPROC;
glVertexAttrib1fARB: PFNGLVERTEXATTRIB1FARBPROC;
glVertexAttrib1fvARB: PFNGLVERTEXATTRIB1FVARBPROC;
glVertexAttrib1sARB: PFNGLVERTEXATTRIB1SARBPROC;
glVertexAttrib1svARB: PFNGLVERTEXATTRIB1SVARBPROC;
glVertexAttrib2dARB: PFNGLVERTEXATTRIB2DARBPROC;
glVertexAttrib2dvARB: PFNGLVERTEXATTRIB2DVARBPROC;
glVertexAttrib2fARB: PFNGLVERTEXATTRIB2FARBPROC;
glVertexAttrib2fvARB: PFNGLVERTEXATTRIB2FVARBPROC;
glVertexAttrib2sARB: PFNGLVERTEXATTRIB2SARBPROC;
glVertexAttrib2svARB: PFNGLVERTEXATTRIB2SVARBPROC;
glVertexAttrib3dARB: PFNGLVERTEXATTRIB3DARBPROC;
glVertexAttrib3dvARB: PFNGLVERTEXATTRIB3DVARBPROC;
glVertexAttrib3fARB: PFNGLVERTEXATTRIB3FARBPROC;
glVertexAttrib3fvARB: PFNGLVERTEXATTRIB3FVARBPROC;
glVertexAttrib3sARB: PFNGLVERTEXATTRIB3SARBPROC;
glVertexAttrib3svARB: PFNGLVERTEXATTRIB3SVARBPROC;
glVertexAttrib4NbvARB: PFNGLVERTEXATTRIB4NBVARBPROC;
glVertexAttrib4NivARB: PFNGLVERTEXATTRIB4NIVARBPROC;
glVertexAttrib4NsvARB: PFNGLVERTEXATTRIB4NSVARBPROC;
glVertexAttrib4NubARB: PFNGLVERTEXATTRIB4NUBARBPROC;
glVertexAttrib4NubvARB: PFNGLVERTEXATTRIB4NUBVARBPROC;
glVertexAttrib4NuivARB: PFNGLVERTEXATTRIB4NUIVARBPROC;
glVertexAttrib4NusvARB: PFNGLVERTEXATTRIB4NUSVARBPROC;
glVertexAttrib4bvARB: PFNGLVERTEXATTRIB4BVARBPROC;
glVertexAttrib4dARB: PFNGLVERTEXATTRIB4DARBPROC;
glVertexAttrib4dvARB: PFNGLVERTEXATTRIB4DVARBPROC;
glVertexAttrib4fARB: PFNGLVERTEXATTRIB4FARBPROC;
glVertexAttrib4fvARB: PFNGLVERTEXATTRIB4FVARBPROC;
glVertexAttrib4ivARB: PFNGLVERTEXATTRIB4IVARBPROC;
glVertexAttrib4sARB: PFNGLVERTEXATTRIB4SARBPROC;
glVertexAttrib4svARB: PFNGLVERTEXATTRIB4SVARBPROC;
glVertexAttrib4ubvARB: PFNGLVERTEXATTRIB4UBVARBPROC;
glVertexAttrib4uivARB: PFNGLVERTEXATTRIB4UIVARBPROC;
glVertexAttrib4usvARB: PFNGLVERTEXATTRIB4USVARBPROC;
glVertexAttribPointerARB: PFNGLVERTEXATTRIBPOINTERARBPROC;
glEnableVertexAttribArrayARB: PFNGLENABLEVERTEXATTRIBARRAYARBPROC;
glDisableVertexAttribArrayARB: PFNGLDISABLEVERTEXATTRIBARRAYARBPROC;
glProgramStringARB: PFNGLPROGRAMSTRINGARBPROC;
glBindProgramARB: PFNGLBINDPROGRAMARBPROC;
glDeleteProgramsARB: PFNGLDELETEPROGRAMSARBPROC;
glGenProgramsARB: PFNGLGENPROGRAMSARBPROC;
glProgramEnvParameter4dARB: PFNGLPROGRAMENVPARAMETER4DARBPROC;
glProgramEnvParameter4dvARB: PFNGLPROGRAMENVPARAMETER4DVARBPROC;
glProgramEnvParameter4fARB: PFNGLPROGRAMENVPARAMETER4FARBPROC;
glProgramEnvParameter4fvARB: PFNGLPROGRAMENVPARAMETER4FVARBPROC;
glProgramLocalParameter4dARB: PFNGLPROGRAMLOCALPARAMETER4DARBPROC;
glProgramLocalParameter4dvARB: PFNGLPROGRAMLOCALPARAMETER4DVARBPROC;
glProgramLocalParameter4fARB: PFNGLPROGRAMLOCALPARAMETER4FARBPROC;
glProgramLocalParameter4fvARB: PFNGLPROGRAMLOCALPARAMETER4FVARBPROC;
glGetProgramEnvParameterdvARB: PFNGLGETPROGRAMENVPARAMETERDVARBPROC;
glGetProgramEnvParameterfvARB: PFNGLGETPROGRAMENVPARAMETERFVARBPROC;
glGetProgramLocalParameterdvARB: PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC;
glGetProgramLocalParameterfvARB: PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC;
glGetProgramivARB: PFNGLGETPROGRAMIVARBPROC;
glGetProgramStringARB: PFNGLGETPROGRAMSTRINGARBPROC;
glGetVertexAttribdvARB: PFNGLGETVERTEXATTRIBDVARBPROC;
glGetVertexAttribfvARB: PFNGLGETVERTEXATTRIBFVARBPROC;
glGetVertexAttribivARB: PFNGLGETVERTEXATTRIBIVARBPROC;
glGetVertexAttribPointervARB: PFNGLGETVERTEXATTRIBPOINTERVARBPROC;
glIsProgramARB: PFNGLISPROGRAMARBPROC;
glBindBufferARB: PFNGLBINDBUFFERARBPROC;
glDeleteBuffersARB: PFNGLDELETEBUFFERSARBPROC;
glGenBuffersARB: PFNGLGENBUFFERSARBPROC;
glIsBufferARB: PFNGLISBUFFERARBPROC;
glBufferDataARB: PFNGLBUFFERDATAARBPROC;
glBufferSubDataARB: PFNGLBUFFERSUBDATAARBPROC;
glGetBufferSubDataARB: PFNGLGETBUFFERSUBDATAARBPROC;
glMapBufferARB: PFNGLMAPBUFFERARBPROC;
glUnmapBufferARB: PFNGLUNMAPBUFFERARBPROC;
glGetBufferParameterivARB: PFNGLGETBUFFERPARAMETERIVARBPROC;
glGetBufferPointervARB: PFNGLGETBUFFERPOINTERVARBPROC;
glGenQueriesARB: PFNGLGENQUERIESARBPROC;
glDeleteQueriesARB: PFNGLDELETEQUERIESARBPROC;
glIsQueryARB: PFNGLISQUERYARBPROC;
glBeginQueryARB: PFNGLBEGINQUERYARBPROC;
glEndQueryARB: PFNGLENDQUERYARBPROC;
glGetQueryivARB: PFNGLGETQUERYIVARBPROC;
glGetQueryObjectivARB: PFNGLGETQUERYOBJECTIVARBPROC;
glGetQueryObjectuivARB: PFNGLGETQUERYOBJECTUIVARBPROC;
glDeleteObjectARB: PFNGLDELETEOBJECTARBPROC;
glGetHandleARB: PFNGLGETHANDLEARBPROC;
glDetachObjectARB: PFNGLDETACHOBJECTARBPROC;
glCreateShaderObjectARB: PFNGLCREATESHADEROBJECTARBPROC;
glShaderSourceARB: PFNGLSHADERSOURCEARBPROC;
glCompileShaderARB: PFNGLCOMPILESHADERARBPROC;
glCreateProgramObjectARB: PFNGLCREATEPROGRAMOBJECTARBPROC;
glAttachObjectARB: PFNGLATTACHOBJECTARBPROC;
glLinkProgramARB: PFNGLLINKPROGRAMARBPROC;
glUseProgramObjectARB: PFNGLUSEPROGRAMOBJECTARBPROC;
glValidateProgramARB: PFNGLVALIDATEPROGRAMARBPROC;
glUniform1fARB: PFNGLUNIFORM1FARBPROC;
glUniform2fARB: PFNGLUNIFORM2FARBPROC;
glUniform3fARB: PFNGLUNIFORM3FARBPROC;
glUniform4fARB: PFNGLUNIFORM4FARBPROC;
glUniform1iARB: PFNGLUNIFORM1IARBPROC;
glUniform2iARB: PFNGLUNIFORM2IARBPROC;
glUniform3iARB: PFNGLUNIFORM3IARBPROC;
glUniform4iARB: PFNGLUNIFORM4IARBPROC;
glUniform1fvARB: PFNGLUNIFORM1FVARBPROC;
glUniform2fvARB: PFNGLUNIFORM2FVARBPROC;
glUniform3fvARB: PFNGLUNIFORM3FVARBPROC;
glUniform4fvARB: PFNGLUNIFORM4FVARBPROC;
glUniform1ivARB: PFNGLUNIFORM1IVARBPROC;
glUniform2ivARB: PFNGLUNIFORM2IVARBPROC;
glUniform3ivARB: PFNGLUNIFORM3IVARBPROC;
glUniform4ivARB: PFNGLUNIFORM4IVARBPROC;
glUniformMatrix2fvARB: PFNGLUNIFORMMATRIX2FVARBPROC;
glUniformMatrix3fvARB: PFNGLUNIFORMMATRIX3FVARBPROC;
glUniformMatrix4fvARB: PFNGLUNIFORMMATRIX4FVARBPROC;
glGetObjectParameterfvARB: PFNGLGETOBJECTPARAMETERFVARBPROC;
glGetObjectParameterivARB: PFNGLGETOBJECTPARAMETERIVARBPROC;
glGetInfoLogARB: PFNGLGETINFOLOGARBPROC;
glGetAttachedObjectsARB: PFNGLGETATTACHEDOBJECTSARBPROC;
glGetUniformLocationARB: PFNGLGETUNIFORMLOCATIONARBPROC;
glGetActiveUniformARB: PFNGLGETACTIVEUNIFORMARBPROC;
glGetUniformfvARB: PFNGLGETUNIFORMFVARBPROC;
glGetUniformivARB: PFNGLGETUNIFORMIVARBPROC;
glGetShaderSourceARB: PFNGLGETSHADERSOURCEARBPROC;
glBindAttribLocationARB: PFNGLBINDATTRIBLOCATIONARBPROC;
glGetActiveAttribARB: PFNGLGETACTIVEATTRIBARBPROC;
glGetAttribLocationARB: PFNGLGETATTRIBLOCATIONARBPROC;
glDrawBuffersARB: PFNGLDRAWBUFFERSARBPROC;
glClampColorARB: PFNGLCLAMPCOLORARBPROC;
glDrawArraysInstancedARB: PFNGLDRAWARRAYSINSTANCEDARBPROC;
glDrawElementsInstancedARB: PFNGLDRAWELEMENTSINSTANCEDARBPROC;
glIsRenderbuffer: PFNGLISRENDERBUFFERPROC;
glBindRenderbuffer: PFNGLBINDRENDERBUFFERPROC;
glDeleteRenderbuffers: PFNGLDELETERENDERBUFFERSPROC;
glGenRenderbuffers: PFNGLGENRENDERBUFFERSPROC;
glRenderbufferStorage: PFNGLRENDERBUFFERSTORAGEPROC;
glRenderbufferStorageMultisample: PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC;
glGetRenderbufferParameteriv: PFNGLGETRENDERBUFFERPARAMETERIVPROC;
glIsFramebuffer: PFNGLISFRAMEBUFFERPROC;
glBindFramebuffer: PFNGLBINDFRAMEBUFFERPROC;
glDeleteFramebuffers: PFNGLDELETEFRAMEBUFFERSPROC;
glGenFramebuffers: PFNGLGENFRAMEBUFFERSPROC;
glCheckFramebufferStatus: PFNGLCHECKFRAMEBUFFERSTATUSPROC;
glFramebufferTexture1D: PFNGLFRAMEBUFFERTEXTURE1DPROC;
glFramebufferTexture2D: PFNGLFRAMEBUFFERTEXTURE2DPROC;
glFramebufferTexture3D: PFNGLFRAMEBUFFERTEXTURE3DPROC;
glFramebufferTextureLayer: PFNGLFRAMEBUFFERTEXTURELAYERPROC;
glFramebufferRenderbuffer: PFNGLFRAMEBUFFERRENDERBUFFERPROC;
glGetFramebufferAttachmentParameteriv: PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC;
glBlitFramebuffer: PFNGLBLITFRAMEBUFFERPROC;
glGenerateMipmap: PFNGLGENERATEMIPMAPPROC;
glProgramParameteriARB: PFNGLPROGRAMPARAMETERIARBPROC;
glFramebufferTextureARB: PFNGLFRAMEBUFFERTEXTUREARBPROC;
glFramebufferTextureLayerARB: PFNGLFRAMEBUFFERTEXTURELAYERARBPROC;
glFramebufferTextureFaceARB: PFNGLFRAMEBUFFERTEXTUREFACEARBPROC;
glVertexAttribDivisorARB: PFNGLVERTEXATTRIBDIVISORARBPROC;
glMapBufferRange: PFNGLMAPBUFFERRANGEPROC;
glFlushMappedBufferRange: PFNGLFLUSHMAPPEDBUFFERRANGEPROC;
glTexBufferARB: PFNGLTEXBUFFERARBPROC;
glBindVertexArray: PFNGLBINDVERTEXARRAYPROC;
glDeleteVertexArrays: PFNGLDELETEVERTEXARRAYSPROC;
glGenVertexArrays: PFNGLGENVERTEXARRAYSPROC;
glIsVertexArray: PFNGLISVERTEXARRAYPROC;
glGetUniformIndices: PFNGLGETUNIFORMINDICESPROC;
glGetActiveUniformsiv: PFNGLGETACTIVEUNIFORMSIVPROC;
glGetActiveUniformName: PFNGLGETACTIVEUNIFORMNAMEPROC;
glGetUniformBlockIndex: PFNGLGETUNIFORMBLOCKINDEXPROC;
glGetActiveUniformBlockiv: PFNGLGETACTIVEUNIFORMBLOCKIVPROC;
glGetActiveUniformBlockName: PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC;
glUniformBlockBinding: PFNGLUNIFORMBLOCKBINDINGPROC;
glCopyBufferSubData: PFNGLCOPYBUFFERSUBDATAPROC;
glDrawElementsBaseVertex: PFNGLDRAWELEMENTSBASEVERTEXPROC;
glDrawRangeElementsBaseVertex: PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC;
glDrawElementsInstancedBaseVertex: PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC;
glMultiDrawElementsBaseVertex: PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC;
glProvokingVertex: PFNGLPROVOKINGVERTEXPROC;
glFenceSync: PFNGLFENCESYNCPROC;
glIsSync: PFNGLISSYNCPROC;
glDeleteSync: PFNGLDELETESYNCPROC;
glClientWaitSync: PFNGLCLIENTWAITSYNCPROC;
glWaitSync: PFNGLWAITSYNCPROC;
glGetInteger64v: PFNGLGETINTEGER64VPROC;
glGetSynciv: PFNGLGETSYNCIVPROC;
glTexImage2DMultisample: PFNGLTEXIMAGE2DMULTISAMPLEPROC;
glTexImage3DMultisample: PFNGLTEXIMAGE3DMULTISAMPLEPROC;
glGetMultisamplefv: PFNGLGETMULTISAMPLEFVPROC;
glSampleMaski: PFNGLSAMPLEMASKIPROC;
glBlendEquationiARB: PFNGLBLENDEQUATIONIARBPROC;
glBlendEquationSeparateiARB: PFNGLBLENDEQUATIONSEPARATEIARBPROC;
glBlendFunciARB: PFNGLBLENDFUNCIARBPROC;
glBlendFuncSeparateiARB: PFNGLBLENDFUNCSEPARATEIARBPROC;
glMinSampleShadingARB: PFNGLMINSAMPLESHADINGARBPROC;
glBindFragDataLocationIndexed: PFNGLBINDFRAGDATALOCATIONINDEXEDPROC;
glGetFragDataIndex: PFNGLGETFRAGDATAINDEXPROC;
glGenSamplers: PFNGLGENSAMPLERSPROC;
glDeleteSamplers: PFNGLDELETESAMPLERSPROC;
glIsSampler: PFNGLISSAMPLERPROC;
glBindSampler: PFNGLBINDSAMPLERPROC;
glSamplerParameteri: PFNGLSAMPLERPARAMETERIPROC;
glSamplerParameteriv: PFNGLSAMPLERPARAMETERIVPROC;
glSamplerParameterf: PFNGLSAMPLERPARAMETERFPROC;
glSamplerParameterfv: PFNGLSAMPLERPARAMETERFVPROC;
glSamplerParameterIiv: PFNGLSAMPLERPARAMETERIIVPROC;
glSamplerParameterIuiv: PFNGLSAMPLERPARAMETERIUIVPROC;
glGetSamplerParameteriv: PFNGLGETSAMPLERPARAMETERIVPROC;
glGetSamplerParameterIiv: PFNGLGETSAMPLERPARAMETERIIVPROC;
glGetSamplerParameterfv: PFNGLGETSAMPLERPARAMETERFVPROC;
glGetSamplerParameterIfv: PFNGLGETSAMPLERPARAMETERIFVPROC;
glQueryCounter: PFNGLQUERYCOUNTERPROC;
glGetQueryObjecti64v: PFNGLGETQUERYOBJECTI64VPROC;
glGetQueryObjectui64v: PFNGLGETQUERYOBJECTUI64VPROC;
glVertexP2ui: PFNGLVERTEXP2UIPROC;
glVertexP2uiv: PFNGLVERTEXP2UIVPROC;
glVertexP3ui: PFNGLVERTEXP3UIPROC;
glVertexP3uiv: PFNGLVERTEXP3UIVPROC;
glVertexP4ui: PFNGLVERTEXP4UIPROC;
glVertexP4uiv: PFNGLVERTEXP4UIVPROC;
glTexCoordP1ui: PFNGLTEXCOORDP1UIPROC;
glTexCoordP1uiv: PFNGLTEXCOORDP1UIVPROC;
glTexCoordP2ui: PFNGLTEXCOORDP2UIPROC;
glTexCoordP2uiv: PFNGLTEXCOORDP2UIVPROC;
glTexCoordP3ui: PFNGLTEXCOORDP3UIPROC;
glTexCoordP3uiv: PFNGLTEXCOORDP3UIVPROC;
glTexCoordP4ui: PFNGLTEXCOORDP4UIPROC;
glTexCoordP4uiv: PFNGLTEXCOORDP4UIVPROC;
glMultiTexCoordP1ui: PFNGLMULTITEXCOORDP1UIPROC;
glMultiTexCoordP1uiv: PFNGLMULTITEXCOORDP1UIVPROC;
glMultiTexCoordP2ui: PFNGLMULTITEXCOORDP2UIPROC;
glMultiTexCoordP2uiv: PFNGLMULTITEXCOORDP2UIVPROC;
glMultiTexCoordP3ui: PFNGLMULTITEXCOORDP3UIPROC;
glMultiTexCoordP3uiv: PFNGLMULTITEXCOORDP3UIVPROC;
glMultiTexCoordP4ui: PFNGLMULTITEXCOORDP4UIPROC;
glMultiTexCoordP4uiv: PFNGLMULTITEXCOORDP4UIVPROC;
glNormalP3ui: PFNGLNORMALP3UIPROC;
glNormalP3uiv: PFNGLNORMALP3UIVPROC;
glColorP3ui: PFNGLCOLORP3UIPROC;
glColorP3uiv: PFNGLCOLORP3UIVPROC;
glColorP4ui: PFNGLCOLORP4UIPROC;
glColorP4uiv: PFNGLCOLORP4UIVPROC;
glSecondaryColorP3ui: PFNGLSECONDARYCOLORP3UIPROC;
glSecondaryColorP3uiv: PFNGLSECONDARYCOLORP3UIVPROC;
glVertexAttribP1ui: PFNGLVERTEXATTRIBP1UIPROC;
glVertexAttribP1uiv: PFNGLVERTEXATTRIBP1UIVPROC;
glVertexAttribP2ui: PFNGLVERTEXATTRIBP2UIPROC;
glVertexAttribP2uiv: PFNGLVERTEXATTRIBP2UIVPROC;
glVertexAttribP3ui: PFNGLVERTEXATTRIBP3UIPROC;
glVertexAttribP3uiv: PFNGLVERTEXATTRIBP3UIVPROC;
glVertexAttribP4ui: PFNGLVERTEXATTRIBP4UIPROC;
glVertexAttribP4uiv: PFNGLVERTEXATTRIBP4UIVPROC;
glDrawArraysIndirect: PFNGLDRAWARRAYSINDIRECTPROC;
glDrawElementsIndirect: PFNGLDRAWELEMENTSINDIRECTPROC;
glUniform1d: PFNGLUNIFORM1DPROC;
glUniform2d: PFNGLUNIFORM2DPROC;
glUniform3d: PFNGLUNIFORM3DPROC;
glUniform4d: PFNGLUNIFORM4DPROC;
glUniform1dv: PFNGLUNIFORM1DVPROC;
glUniform2dv: PFNGLUNIFORM2DVPROC;
glUniform3dv: PFNGLUNIFORM3DVPROC;
glUniform4dv: PFNGLUNIFORM4DVPROC;
glUniformMatrix2dv: PFNGLUNIFORMMATRIX2DVPROC;
glUniformMatrix3dv: PFNGLUNIFORMMATRIX3DVPROC;
glUniformMatrix4dv: PFNGLUNIFORMMATRIX4DVPROC;
glUniformMatrix2x3dv: PFNGLUNIFORMMATRIX2X3DVPROC;
glUniformMatrix2x4dv: PFNGLUNIFORMMATRIX2X4DVPROC;
glUniformMatrix3x2dv: PFNGLUNIFORMMATRIX3X2DVPROC;
glUniformMatrix3x4dv: PFNGLUNIFORMMATRIX3X4DVPROC;
glUniformMatrix4x2dv: PFNGLUNIFORMMATRIX4X2DVPROC;
glUniformMatrix4x3dv: PFNGLUNIFORMMATRIX4X3DVPROC;
glGetUniformdv: PFNGLGETUNIFORMDVPROC;
glProgramUniform1dEXT: PFNGLPROGRAMUNIFORM1DEXTPROC;
glProgramUniform2dEXT: PFNGLPROGRAMUNIFORM2DEXTPROC;
glProgramUniform3dEXT: PFNGLPROGRAMUNIFORM3DEXTPROC;
glProgramUniform4dEXT: PFNGLPROGRAMUNIFORM4DEXTPROC;
glProgramUniform1dvEXT: PFNGLPROGRAMUNIFORM1DVEXTPROC;
glProgramUniform2dvEXT: PFNGLPROGRAMUNIFORM2DVEXTPROC;
glProgramUniform3dvEXT: PFNGLPROGRAMUNIFORM3DVEXTPROC;
glProgramUniform4dvEXT: PFNGLPROGRAMUNIFORM4DVEXTPROC;
glProgramUniformMatrix2dvEXT: PFNGLPROGRAMUNIFORMMATRIX2DVEXTPROC;
glProgramUniformMatrix3dvEXT: PFNGLPROGRAMUNIFORMMATRIX3DVEXTPROC;
glProgramUniformMatrix4dvEXT: PFNGLPROGRAMUNIFORMMATRIX4DVEXTPROC;
glProgramUniformMatrix2x3dvEXT: PFNGLPROGRAMUNIFORMMATRIX2X3DVEXTPROC;
glProgramUniformMatrix2x4dvEXT: PFNGLPROGRAMUNIFORMMATRIX2X4DVEXTPROC;
glProgramUniformMatrix3x2dvEXT: PFNGLPROGRAMUNIFORMMATRIX3X2DVEXTPROC;
glProgramUniformMatrix3x4dvEXT: PFNGLPROGRAMUNIFORMMATRIX3X4DVEXTPROC;
glProgramUniformMatrix4x2dvEXT: PFNGLPROGRAMUNIFORMMATRIX4X2DVEXTPROC;
glProgramUniformMatrix4x3dvEXT: PFNGLPROGRAMUNIFORMMATRIX4X3DVEXTPROC;
glGetSubroutineUniformLocation: PFNGLGETSUBROUTINEUNIFORMLOCATIONPROC;
glGetSubroutineIndex: PFNGLGETSUBROUTINEINDEXPROC;
glGetActiveSubroutineUniformiv: PFNGLGETACTIVESUBROUTINEUNIFORMIVPROC;
glGetActiveSubroutineUniformName: PFNGLGETACTIVESUBROUTINEUNIFORMNAMEPROC;
glGetActiveSubroutineName: PFNGLGETACTIVESUBROUTINENAMEPROC;
glUniformSubroutinesuiv: PFNGLUNIFORMSUBROUTINESUIVPROC;
glGetUniformSubroutineuiv: PFNGLGETUNIFORMSUBROUTINEUIVPROC;
glGetProgramStageiv: PFNGLGETPROGRAMSTAGEIVPROC;
glPatchParameteri: PFNGLPATCHPARAMETERIPROC;
glPatchParameterfv: PFNGLPATCHPARAMETERFVPROC;
glBindTransformFeedback: PFNGLBINDTRANSFORMFEEDBACKPROC;
glDeleteTransformFeedbacks: PFNGLDELETETRANSFORMFEEDBACKSPROC;
glGenTransformFeedbacks: PFNGLGENTRANSFORMFEEDBACKSPROC;
glIsTransformFeedback: PFNGLISTRANSFORMFEEDBACKPROC;
glPauseTransformFeedback: PFNGLPAUSETRANSFORMFEEDBACKPROC;
glResumeTransformFeedback: PFNGLRESUMETRANSFORMFEEDBACKPROC;
glDrawTransformFeedback: PFNGLDRAWTRANSFORMFEEDBACKPROC;
glDrawTransformFeedbackStream: PFNGLDRAWTRANSFORMFEEDBACKSTREAMPROC;
glBeginQueryIndexed: PFNGLBEGINQUERYINDEXEDPROC;
glEndQueryIndexed: PFNGLENDQUERYINDEXEDPROC;
glGetQueryIndexediv: PFNGLGETQUERYINDEXEDIVPROC;
glReleaseShaderCompiler: PFNGLRELEASESHADERCOMPILERPROC;
glShaderBinary: PFNGLSHADERBINARYPROC;
glGetShaderPrecisionFormat: PFNGLGETSHADERPRECISIONFORMATPROC;
glDepthRangef: PFNGLDEPTHRANGEFPROC;
glClearDepthf: PFNGLCLEARDEPTHFPROC;
glGetProgramBinary: PFNGLGetProgramBinaryPROC;
glProgramBinary: PFNGLProgramBinaryPROC;
glProgramParameteri: PFNGLProgramParameteriPROC;
glUseProgramStages: PFNGLUSEPROGRAMSTAGESPROC;
glActiveShaderProgram: PFNGLACTIVESHADERPROGRAMPROC;
glCreateShaderProgramv: PFNGLCREATESHADERPROGRAMVPROC;
glBindProgramPipeline: PFNGLBINDPROGRAMPIPELINEPROC;
glDeleteProgramPipelines: PFNGLDELETEPROGRAMPIPELINESPROC;
glGenProgramPipelines: PFNGLGENPROGRAMPIPELINESPROC;
glIsProgramPipeline: PFNGLISPROGRAMPIPELINEPROC;
glGetProgramPipelineiv: PFNGLGETPROGRAMPIPELINEIVPROC;
glProgramUniform1i: PFNGLPROGRAMUNIFORM1IPROC;
glProgramUniform1iv: PFNGLPROGRAMUNIFORM1IVPROC;
glProgramUniform1f: PFNGLPROGRAMUNIFORM1FPROC;
glProgramUniform1fv: PFNGLPROGRAMUNIFORM1FVPROC;
glProgramUniform1d: PFNGLPROGRAMUNIFORM1DPROC;
glProgramUniform1dv: PFNGLPROGRAMUNIFORM1DVPROC;
glProgramUniform1ui: PFNGLPROGRAMUNIFORM1UIPROC;
glProgramUniform1uiv: PFNGLPROGRAMUNIFORM1UIVPROC;
glProgramUniform2i: PFNGLPROGRAMUNIFORM2IPROC;
glProgramUniform2iv: PFNGLPROGRAMUNIFORM2IVPROC;
glProgramUniform2f: PFNGLPROGRAMUNIFORM2FPROC;
glProgramUniform2fv: PFNGLPROGRAMUNIFORM2FVPROC;
glProgramUniform2d: PFNGLPROGRAMUNIFORM2DPROC;
glProgramUniform2dv: PFNGLPROGRAMUNIFORM2DVPROC;
glProgramUniform2ui: PFNGLPROGRAMUNIFORM2UIPROC;
glProgramUniform2uiv: PFNGLPROGRAMUNIFORM2UIVPROC;
glProgramUniform3i: PFNGLPROGRAMUNIFORM3IPROC;
glProgramUniform3iv: PFNGLPROGRAMUNIFORM3IVPROC;
glProgramUniform3f: PFNGLPROGRAMUNIFORM3FPROC;
glProgramUniform3fv: PFNGLPROGRAMUNIFORM3FVPROC;
glProgramUniform3d: PFNGLPROGRAMUNIFORM3DPROC;
glProgramUniform3dv: PFNGLPROGRAMUNIFORM3DVPROC;
glProgramUniform3ui: PFNGLPROGRAMUNIFORM3UIPROC;
glProgramUniform3uiv: PFNGLPROGRAMUNIFORM3UIVPROC;
glProgramUniform4i: PFNGLPROGRAMUNIFORM4IPROC;
glProgramUniform4iv: PFNGLPROGRAMUNIFORM4IVPROC;
glProgramUniform4f: PFNGLPROGRAMUNIFORM4FPROC;
glProgramUniform4fv: PFNGLPROGRAMUNIFORM4FVPROC;
glProgramUniform4d: PFNGLPROGRAMUNIFORM4DPROC;
glProgramUniform4dv: PFNGLPROGRAMUNIFORM4DVPROC;
glProgramUniform4ui: PFNGLPROGRAMUNIFORM4UIPROC;
glProgramUniform4uiv: PFNGLPROGRAMUNIFORM4UIVPROC;
glProgramUniformMatrix2fv: PFNGLPROGRAMUNIFORMMATRIX2FVPROC;
glProgramUniformMatrix3fv: PFNGLPROGRAMUNIFORMMATRIX3FVPROC;
glProgramUniformMatrix4fv: PFNGLPROGRAMUNIFORMMATRIX4FVPROC;
glProgramUniformMatrix2dv: PFNGLPROGRAMUNIFORMMATRIX2DVPROC;
glProgramUniformMatrix3dv: PFNGLPROGRAMUNIFORMMATRIX3DVPROC;
glProgramUniformMatrix4dv: PFNGLPROGRAMUNIFORMMATRIX4DVPROC;
glProgramUniformMatrix2x3fv: PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC;
glProgramUniformMatrix3x2fv: PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC;
glProgramUniformMatrix2x4fv: PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC;
glProgramUniformMatrix4x2fv: PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC;
glProgramUniformMatrix3x4fv: PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC;
glProgramUniformMatrix4x3fv: PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC;
glProgramUniformMatrix2x3dv: PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC;
glProgramUniformMatrix3x2dv: PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC;
glProgramUniformMatrix2x4dv: PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC;
glProgramUniformMatrix4x2dv: PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC;
glProgramUniformMatrix3x4dv: PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC;
glProgramUniformMatrix4x3dv: PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC;
glValidateProgramPipeline: PFNGLVALIDATEPROGRAMPIPELINEPROC;
glGetProgramPipelineInfoLog: PFNGLGETPROGRAMPIPELINEINFOLOGPROC;
glVertexAttribL1d: PFNGLVERTEXATTRIBL1DPROC;
glVertexAttribL2d: PFNGLVERTEXATTRIBL2DPROC;
glVertexAttribL3d: PFNGLVERTEXATTRIBL3DPROC;
glVertexAttribL4d: PFNGLVERTEXATTRIBL4DPROC;
glVertexAttribL1dv: PFNGLVERTEXATTRIBL1DVPROC;
glVertexAttribL2dv: PFNGLVERTEXATTRIBL2DVPROC;
glVertexAttribL3dv: PFNGLVERTEXATTRIBL3DVPROC;
glVertexAttribL4dv: PFNGLVERTEXATTRIBL4DVPROC;
glVertexAttribLPointer: PFNGLVERTEXATTRIBLPOINTERPROC;
glGetVertexAttribLdv: PFNGLGETVERTEXATTRIBLDVPROC;
glVertexArrayVertexAttribLOffsetEXT: PFNGLVERTEXARRAYVERTEXATTRIBLOFFSETEXTPROC;
glViewportArrayv: PFNGLVIEWPORTARRAYVPROC;
glViewportIndexedf: PFNGLVIEWPORTINDEXEDFPROC;
glViewportIndexedfv: PFNGLVIEWPORTINDEXEDFVPROC;
glScissorArrayv: PFNGLSCISSORARRAYVPROC;
glScissorIndexed: PFNGLSCISSORINDEXEDPROC;
glScissorIndexedv: PFNGLSCISSORINDEXEDVPROC;
glDepthRangeArrayv: PFNGLDEPTHRANGEARRAYVPROC;
glDepthRangeIndexed: PFNGLDEPTHRANGEINDEXEDPROC;
glGetFloati_v: PFNGLGETFLOATI_VPROC;
glGetDoublei_v: PFNGLGETDOUBLEI_VPROC;
glDebugMessageControlARB: PFNGLDEBUGMESSAGECONTROLARBPROC;
glDebugMessageInsertARB: PFNGLDEBUGMESSAGEINSERTARBPROC;
glDebugMessageCallbackARB: PFNGLDEBUGMESSAGECALLBACKARBPROC;
glGetDebugMessageLogARB: PFNGLGETDEBUGMESSAGELOGARBPROC;
glGetGraphicsResetStatusARB: PFNGLGETGRAPHICSRESETSTATUSARBPROC;
glGetnMapdvARB: PFNGLGETNMAPDVARBPROC;
glGetnMapfvARB: PFNGLGETNMAPFVARBPROC;
glGetnMapivARB: PFNGLGETNMAPIVARBPROC;
glGetnPixelMapfvARB: PFNGLGETNPIXELMAPFVARBPROC;
glGetnPixelMapuivARB: PFNGLGETNPIXELMAPUIVARBPROC;
glGetnPixelMapusvARB: PFNGLGETNPIXELMAPUSVARBPROC;
glGetnPolygonStippleARB: PFNGLGETNPOLYGONSTIPPLEARBPROC;
glGetnColorTableARB: PFNGLGETNCOLORTABLEARBPROC;
glGetnConvolutionFilterARB: PFNGLGETNCONVOLUTIONFILTERARBPROC;
glGetnSeparableFilterARB: PFNGLGETNSEPARABLEFILTERARBPROC;
glGetnHistogramARB: PFNGLGETNHISTOGRAMARBPROC;
glGetnMinmaxARB: PFNGLGETNMINMAXARBPROC;
glGetnTexImageARB: PFNGLGETNTEXIMAGEARBPROC;
glReadnPixelsARB: PFNGLREADNPIXELSARBPROC;
glGetnCompressedTexImageARB: PFNGLGETNCOMPRESSEDTEXIMAGEARBPROC;
glGetnUniformfvARB: PFNGLGETNUNIFORMFVARBPROC;
glGetnUniformivARB: PFNGLGETNUNIFORMIVARBPROC;
glGetnUniformuivARB: PFNGLGETNUNIFORMUIVARBPROC;
glGetnUniformdvARB: PFNGLGETNUNIFORMDVARBPROC;
glArrayElementArrayEXT: PFNGLARRAYELEMENTARRAYEXTPROC;
glAddSwapHintRectWIN: PFNGLADDSWAPHINTRECTWINPROC;
glBlendColorEXT: PFNGLBLENDCOLOREXTPROC;
glPolygonOffsetEXT: PFNGLPOLYGONOFFSETEXTPROC;
glTexImage3DEXT: PFNGLTEXIMAGE3DEXTPROC;
glTexSubImage1DEXT: PFNGLTEXSUBIMAGE1DEXTPROC;
glTexSubImage2DEXT: PFNGLTEXSUBIMAGE2DEXTPROC;
glTexSubImage3DEXT: PFNGLTEXSUBIMAGE3DEXTPROC;
glCopyTexImage1DEXT: PFNGLCOPYTEXIMAGE1DEXTPROC;
glCopyTexImage2DEXT: PFNGLCOPYTEXIMAGE2DEXTPROC;
glCopyTexSubImage1DEXT: PFNGLCOPYTEXSUBIMAGE1DEXTPROC;
glCopyTexSubImage2DEXT: PFNGLCOPYTEXSUBIMAGE2DEXTPROC;
glCopyTexSubImage3DEXT: PFNGLCOPYTEXSUBIMAGE3DEXTPROC;
glGenTexturesEXT: PFNGLGENTEXTURESEXTPROC;
glDeleteTexturesEXT: PFNGLDELETETEXTURESEXTPROC;
glBindTextureEXT: PFNGLBINDTEXTUREEXTPROC;
glPrioritizeTexturesEXT: PFNGLPRIORITIZETEXTURESEXTPROC;
glAreTexturesResidentEXT: PFNGLARETEXTURESRESIDENTEXTPROC;
glIsTextureEXT: PFNGLISTEXTUREEXTPROC;
glSampleMaskSGIS: PFNGLSAMPLEMASKSGISPROC;
glSamplePatternSGIS: PFNGLSAMPLEPATTERNSGISPROC;
glBlendEquationEXT: PFNGLBLENDEQUATIONEXTPROC;
glColorTableEXT: PFNGLCOLORTABLEEXTPROC;
glColorSubTableExt: PFNGLCOLORSUBTABLEEXTPROC;
glGetColorTableEXT: PFNGLGETCOLORTABLEEXTPROC;
glGetColorTableParameterfvEXT: PFNGLGETCOLORTABLEPARAMETERFVEXTPROC;
glGetColorTableParameterivEXT: PFNGLGETCOLORTABLEPARAMETERIVEXTPROC;
glIndexMaterialEXT: PFNGLINDEXMATERIALEXTPROC;
glIndexFuncEXT: PFNGLINDEXFUNCEXTPROC;
glLockArraysEXT: PFNGLLOCKARRAYSEXTPROC;
glUnlockArraysEXT: PFNGLUNLOCKARRAYSEXTPROC;
glDrawRangeElementsEXT: PFNGLDRAWRANGEELEMENTSEXTPROC;
glBeginSceneEXT: PFNGLBEGINSCENEEXTPROC;
glEndSceneEXT: PFNGLENDSCENEEXTPROC;
glSecondaryColor3bEXT: PFNGLSECONDARYCOLOR3BEXTPROC;
glSecondaryColor3bvEXT: PFNGLSECONDARYCOLOR3BVEXTPROC;
glSecondaryColor3dEXT: PFNGLSECONDARYCOLOR3DEXTPROC;
glSecondaryColor3dvEXT: PFNGLSECONDARYCOLOR3DVEXTPROC;
glSecondaryColor3fEXT: PFNGLSECONDARYCOLOR3FEXTPROC;
glSecondaryColor3fvEXT: PFNGLSECONDARYCOLOR3FVEXTPROC;
glSecondaryColor3iEXT: PFNGLSECONDARYCOLOR3IEXTPROC;
glSecondaryColor3ivEXT: PFNGLSECONDARYCOLOR3IVEXTPROC;
glSecondaryColor3sEXT: PFNGLSECONDARYCOLOR3SEXTPROC;
glSecondaryColor3svEXT: PFNGLSECONDARYCOLOR3SVEXTPROC;
glSecondaryColor3ubEXT: PFNGLSECONDARYCOLOR3UBEXTPROC;
glSecondaryColor3ubvEXT: PFNGLSECONDARYCOLOR3UBVEXTPROC;
glSecondaryColor3uiEXT: PFNGLSECONDARYCOLOR3UIEXTPROC;
glSecondaryColor3uivEXT: PFNGLSECONDARYCOLOR3UIVEXTPROC;
glSecondaryColor3usEXT: PFNGLSECONDARYCOLOR3USEXTPROC;
glSecondaryColor3usvEXT: PFNGLSECONDARYCOLOR3USVEXTPROC;
glSecondaryColorPointerEXT: PFNGLSECONDARYCOLORPOINTEREXTPROC;
glMultiDrawArraysEXT: PFNGLMULTIDRAWARRAYSEXTPROC;
glMultiDrawElementsEXT: PFNGLMULTIDRAWELEMENTSEXTPROC;
glFogCoordfEXT: PFNGLFOGCOORDFEXTPROC;
glFogCoordfvEXT: PFNGLFOGCOORDFVEXTPROC;
glFogCoorddEXT: PFNGLFOGCOORDDEXTPROC;
glFogCoorddvEXT: PFNGLFOGCOORDDVEXTPROC;
glFogCoordPointerEXT: PFNGLFOGCOORDPOINTEREXTPROC;
glBlendFuncSeparateEXT: PFNGLBLENDFUNCSEPARATEEXTPROC;
glFlushVertexArrayRangeNV: PFNGLFLUSHVERTEXARRAYRANGENVPROC;
glVertexArrayRangeNV: PFNGLVERTEXARRAYRANGENVPROC;
wglAllocateMemoryNV: PFNWGLALLOCATEMEMORYNVPROC;
wglFreeMemoryNV: PFNWGLFREEMEMORYNVPROC;
glCombinerParameterfvNV: PFNGLCOMBINERPARAMETERFVNVPROC;
glCombinerParameterfNV: PFNGLCOMBINERPARAMETERFNVPROC;
glCombinerParameterivNV: PFNGLCOMBINERPARAMETERIVNVPROC;
glCombinerParameteriNV: PFNGLCOMBINERPARAMETERINVPROC;
glCombinerInputNV: PFNGLCOMBINERINPUTNVPROC;
glCombinerOutputNV: PFNGLCOMBINEROUTPUTNVPROC;
glFinalCombinerInputNV: PFNGLFINALCOMBINERINPUTNVPROC;
glGetCombinerInputParameterfvNV: PFNGLGETCOMBINERINPUTPARAMETERFVNVPROC;
glGetCombinerInputParameterivNV: PFNGLGETCOMBINERINPUTPARAMETERIVNVPROC;
glGetCombinerOutputParameterfvNV: PFNGLGETCOMBINEROUTPUTPARAMETERFVNVPROC;
glGetCombinerOutputParameterivNV: PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC;
glGetFinalCombinerInputParameterfvNV: PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC;
glGetFinalCombinerInputParameterivNV: PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC;
glResizeBuffersMESA: PFNGLRESIZEBUFFERSMESAPROC;
glTbufferMask3DFX: PFNGLTBUFFERMASK3DFXPROC;
glSampleMaskEXT: PFNGLSAMPLEMASKEXTPROC;
glSamplePatternEXT: PFNGLSAMPLEPATTERNEXTPROC;
glTextureColorMaskSGIS: PFNGLTEXTURECOLORMASKSGISPROC;
glGenFencesNV: PFNGLGENFENCESNVPROC;
glDeleteFencesNV: PFNGLDELETEFENCESNVPROC;
glSetFenceNV: PFNGLSETFENCENVPROC;
glTestFenceNV: PFNGLTESTFENCENVPROC;
glFinishFenceNV: PFNGLFINISHFENCENVPROC;
glIsFenceNV: PFNGLISFENCENVPROC;
glGetFenceivNV: PFNGLGETFENCEIVNVPROC;
glAreProgramsResidentNV: PFNGLAREPROGRAMSRESIDENTNVPROC;
glBindProgramNV: PFNGLBINDPROGRAMNVPROC;
glDeleteProgramsNV: PFNGLDELETEPROGRAMSNVPROC;
glExecuteProgramNV: PFNGLEXECUTEPROGRAMNVPROC;
glGenProgramsNV: PFNGLGENPROGRAMSNVPROC;
glGetProgramParameterdvNV: PFNGLGETPROGRAMPARAMETERDVNVPROC;
glGetProgramParameterfvNV: PFNGLGETPROGRAMPARAMETERFVNVPROC;
glGetProgramivNV: PFNGLGETPROGRAMIVNVPROC;
glGetProgramStringNV: PFNGLGETPROGRAMSTRINGNVPROC;
glGetTrackMatrixivNV: PFNGLGETTRACKMATRIXIVNVPROC;
glGetVertexAttribdvNV: PFNGLGETVERTEXATTRIBDVNVPROC;
glGetVertexAttribfvNV: PFNGLGETVERTEXATTRIBFVNVPROC;
glGetVertexAttribivNV: PFNGLGETVERTEXATTRIBIVNVPROC;
glGetVertexAttribPointervNV: PFNGLGETVERTEXATTRIBPOINTERVNVPROC;
glIsProgramNV: PFNGLISPROGRAMNVPROC;
glLoadProgramNV: PFNGLLOADPROGRAMNVPROC;
glProgramParameter4dNV: PFNGLPROGRAMPARAMETER4DNVPROC;
glProgramParameter4dvNV: PFNGLPROGRAMPARAMETER4DVNVPROC;
glProgramParameter4fNV: PFNGLPROGRAMPARAMETER4FNVPROC;
glProgramParameter4fvNV: PFNGLPROGRAMPARAMETER4FVNVPROC;
glProgramParameters4dvNV: PFNGLPROGRAMPARAMETERS4DVNVPROC;
glProgramParameters4fvNV: PFNGLPROGRAMPARAMETERS4FVNVPROC;
glRequestResidentProgramsNV: PFNGLREQUESTRESIDENTPROGRAMSNVPROC;
glTrackMatrixNV: PFNGLTRACKMATRIXNVPROC;
glVertexAttribPointerNV: PFNGLVERTEXATTRIBPOINTERNVPROC;
glVertexAttrib1dNV: PFNGLVERTEXATTRIB1DNVPROC;
glVertexAttrib1dvNV: PFNGLVERTEXATTRIB1DVNVPROC;
glVertexAttrib1fNV: PFNGLVERTEXATTRIB1FNVPROC;
glVertexAttrib1fvNV: PFNGLVERTEXATTRIB1FVNVPROC;
glVertexAttrib1sNV: PFNGLVERTEXATTRIB1SNVPROC;
glVertexAttrib1svNV: PFNGLVERTEXATTRIB1SVNVPROC;
glVertexAttrib2dNV: PFNGLVERTEXATTRIB2DNVPROC;
glVertexAttrib2dvNV: PFNGLVERTEXATTRIB2DVNVPROC;
glVertexAttrib2fNV: PFNGLVERTEXATTRIB2FNVPROC;
glVertexAttrib2fvNV: PFNGLVERTEXATTRIB2FVNVPROC;
glVertexAttrib2sNV: PFNGLVERTEXATTRIB2SNVPROC;
glVertexAttrib2svNV: PFNGLVERTEXATTRIB2SVNVPROC;
glVertexAttrib3dNV: PFNGLVERTEXATTRIB3DNVPROC;
glVertexAttrib3dvNV: PFNGLVERTEXATTRIB3DVNVPROC;
glVertexAttrib3fNV: PFNGLVERTEXATTRIB3FNVPROC;
glVertexAttrib3fvNV: PFNGLVERTEXATTRIB3FVNVPROC;
glVertexAttrib3sNV: PFNGLVERTEXATTRIB3SNVPROC;
glVertexAttrib3svNV: PFNGLVERTEXATTRIB3SVNVPROC;
glVertexAttrib4dNV: PFNGLVERTEXATTRIB4DNVPROC;
glVertexAttrib4dvNV: PFNGLVERTEXATTRIB4DVNVPROC;
glVertexAttrib4fNV: PFNGLVERTEXATTRIB4FNVPROC;
glVertexAttrib4fvNV: PFNGLVERTEXATTRIB4FVNVPROC;
glVertexAttrib4sNV: PFNGLVERTEXATTRIB4SNVPROC;
glVertexAttrib4svNV: PFNGLVERTEXATTRIB4SVNVPROC;
glVertexAttrib4ubvNV: PFNGLVERTEXATTRIB4UBVNVPROC;
glVertexAttribs1dvNV: PFNGLVERTEXATTRIBS1DVNVPROC;
glVertexAttribs1fvNV: PFNGLVERTEXATTRIBS1FVNVPROC;
glVertexAttribs1svNV: PFNGLVERTEXATTRIBS1SVNVPROC;
glVertexAttribs2dvNV: PFNGLVERTEXATTRIBS2DVNVPROC;
glVertexAttribs2fvNV: PFNGLVERTEXATTRIBS2FVNVPROC;
glVertexAttribs2svNV: PFNGLVERTEXATTRIBS2SVNVPROC;
glVertexAttribs3dvNV: PFNGLVERTEXATTRIBS3DVNVPROC;
glVertexAttribs3fvNV: PFNGLVERTEXATTRIBS3FVNVPROC;
glVertexAttribs3svNV: PFNGLVERTEXATTRIBS3SVNVPROC;
glVertexAttribs4dvNV: PFNGLVERTEXATTRIBS4DVNVPROC;
glVertexAttribs4fvNV: PFNGLVERTEXATTRIBS4FVNVPROC;
glVertexAttribs4svNV: PFNGLVERTEXATTRIBS4SVNVPROC;
glVertexAttribs4ubvNV: PFNGLVERTEXATTRIBS4UBVNVPROC;
glGenOcclusionQueriesNV: PFNGLGENOCCLUSIONQUERIESNVPROC;
glDeleteOcclusionQueriesNV: PFNGLDELETEOCCLUSIONQUERIESNVPROC;
glIsOcclusionQueryNV: PFNGLISOCCLUSIONQUERYNVPROC;
glBeginOcclusionQueryNV: PFNGLBEGINOCCLUSIONQUERYNVPROC;
glEndOcclusionQueryNV: PFNGLENDOCCLUSIONQUERYNVPROC;
glGetOcclusionQueryivNV: PFNGLGETOCCLUSIONQUERYIVNVPROC;
glGetOcclusionQueryuivNV: PFNGLGETOCCLUSIONQUERYUIVNVPROC;
glPointParameteriNV: PFNGLPOINTPARAMETERINVPROC;
glPointParameterivNV: PFNGLPOINTPARAMETERIVNVPROC;
glActiveStencilFaceEXT: PFNGLACTIVESTENCILFACEEXTPROC;
glDrawBuffersATI: PFNGLDRAWBUFFERSATIPROC;
glPrimitiveRestartNV: PFNGLPRIMITIVERESTARTNVPROC;
glPrimitiveRestartIndexNV: PFNGLPRIMITIVERESTARTINDEXNVPROC;
glDepthBoundsEXT: PFNGLDEPTHBOUNDSEXTPROC;
glBlendEquationSeparateEXT: PFNGLBLENDEQUATIONSEPARATEEXTPROC;
glIsRenderbufferEXT: PFNGLISRENDERBUFFEREXTPROC;
glBindRenderbufferEXT: PFNGLBINDRENDERBUFFEREXTPROC;
glDeleteRenderbuffersEXT: PFNGLDELETERENDERBUFFERSEXTPROC;
glGenRenderbuffersEXT: PFNGLGENRENDERBUFFERSEXTPROC;
glRenderbufferStorageEXT: PFNGLRENDERBUFFERSTORAGEEXTPROC;
glGetRenderbufferParameterivEXT: PFNGLGETRENDERBUFFERPARAMETERIVEXTPROC;
glIsFramebufferEXT: PFNGLISFRAMEBUFFEREXTPROC;
glBindFramebufferEXT: PFNGLBINDFRAMEBUFFEREXTPROC;
glDeleteFramebuffersEXT: PFNGLDELETEFRAMEBUFFERSEXTPROC;
glGenFramebuffersEXT: PFNGLGENFRAMEBUFFERSEXTPROC;
glCheckFramebufferStatusEXT: PFNGLCHECKFRAMEBUFFERSTATUSEXTPROC;
glFramebufferTexture1DEXT: PFNGLFRAMEBUFFERTEXTURE1DEXTPROC;
glFramebufferTexture2DEXT: PFNGLFRAMEBUFFERTEXTURE2DEXTPROC;
glFramebufferTexture3DEXT: PFNGLFRAMEBUFFERTEXTURE3DEXTPROC;
glFramebufferRenderbufferEXT: PFNGLFRAMEBUFFERRENDERBUFFEREXTPROC;
glGetFramebufferAttachmentParameterivEXT: PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC;
glGenerateMipmapEXT: PFNGLGENERATEMIPMAPEXTPROC;
glStringMarkerGREMEDY: PFNGLSTRINGMARKERGREMEDYPROC;
glStencilClearTagEXT: PFNGLSTENCILCLEARTAGEXTPROC;
glBlitFramebufferEXT: PFNGLBLITFRAMEBUFFEREXTPROC;
glRenderbufferStorageMultisampleEXT: PFNGLRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC;
glGetQueryObjecti64vEXT: PFNGLGETQUERYOBJECTI64VEXTPROC;
glGetQueryObjectui64vEXT: PFNGLGETQUERYOBJECTUI64VEXTPROC;
glProgramEnvParameters4fvEXT: PFNGLPROGRAMENVPARAMETERS4FVEXTPROC;
glProgramLocalParameters4fvEXT: PFNGLPROGRAMLOCALPARAMETERS4FVEXTPROC;
glProgramVertexLimitNV: PFNGLPROGRAMVERTEXLIMITNVPROC;
glProgramParameteriEXT: PFNGLPROGRAMPARAMETERIEXTPROC;
glFramebufferTextureEXT: PFNGLFRAMEBUFFERTEXTUREEXTPROC;
glFramebufferTextureLayerEXT: PFNGLFRAMEBUFFERTEXTURELAYEREXTPROC;
glFramebufferTextureFaceEXT: PFNGLFRAMEBUFFERTEXTUREFACEEXTPROC;
glVertexAttribI1iEXT: PFNGLVERTEXATTRIBI1IEXTPROC;
glVertexAttribI2iEXT: PFNGLVERTEXATTRIBI2IEXTPROC;
glVertexAttribI3iEXT: PFNGLVERTEXATTRIBI3IEXTPROC;
glVertexAttribI4iEXT: PFNGLVERTEXATTRIBI4IEXTPROC;
glVertexAttribI1uiEXT: PFNGLVERTEXATTRIBI1UIEXTPROC;
glVertexAttribI2uiEXT: PFNGLVERTEXATTRIBI2UIEXTPROC;
glVertexAttribI3uiEXT: PFNGLVERTEXATTRIBI3UIEXTPROC;
glVertexAttribI4uiEXT: PFNGLVERTEXATTRIBI4UIEXTPROC;
glVertexAttribI1ivEXT: PFNGLVERTEXATTRIBI1IVEXTPROC;
glVertexAttribI2ivEXT: PFNGLVERTEXATTRIBI2IVEXTPROC;
glVertexAttribI3ivEXT: PFNGLVERTEXATTRIBI3IVEXTPROC;
glVertexAttribI4ivEXT: PFNGLVERTEXATTRIBI4IVEXTPROC;
glVertexAttribI1uivEXT: PFNGLVERTEXATTRIBI1UIVEXTPROC;
glVertexAttribI2uivEXT: PFNGLVERTEXATTRIBI2UIVEXTPROC;
glVertexAttribI3uivEXT: PFNGLVERTEXATTRIBI3UIVEXTPROC;
glVertexAttribI4uivEXT: PFNGLVERTEXATTRIBI4UIVEXTPROC;
glVertexAttribI4bvEXT: PFNGLVERTEXATTRIBI4BVEXTPROC;
glVertexAttribI4svEXT: PFNGLVERTEXATTRIBI4SVEXTPROC;
glVertexAttribI4ubvEXT: PFNGLVERTEXATTRIBI4UBVEXTPROC;
glVertexAttribI4usvEXT: PFNGLVERTEXATTRIBI4USVEXTPROC;
glVertexAttribIPointerEXT: PFNGLVERTEXATTRIBIPOINTEREXTPROC;
glGetVertexAttribIivEXT: PFNGLGETVERTEXATTRIBIIVEXTPROC;
glGetVertexAttribIuivEXT: PFNGLGETVERTEXATTRIBIUIVEXTPROC;
glUniform1uiEXT: PFNGLUNIFORM1UIEXTPROC;
glUniform2uiEXT: PFNGLUNIFORM2UIEXTPROC;
glUniform3uiEXT: PFNGLUNIFORM3UIEXTPROC;
glUniform4uiEXT: PFNGLUNIFORM4UIEXTPROC;
glUniform1uivEXT: PFNGLUNIFORM1UIVEXTPROC;
glUniform2uivEXT: PFNGLUNIFORM2UIVEXTPROC;
glUniform3uivEXT: PFNGLUNIFORM3UIVEXTPROC;
glUniform4uivEXT: PFNGLUNIFORM4UIVEXTPROC;
glGetUniformuivEXT: PFNGLGETUNIFORMUIVEXTPROC;
glBindFragDataLocationEXT: PFNGLBINDFRAGDATALOCATIONEXTPROC;
glGetFragDataLocationEXT: PFNGLGETFRAGDATALOCATIONEXTPROC;
glDrawArraysInstancedEXT: PFNGLDRAWARRAYSINSTANCEDEXTPROC;
glDrawElementsInstancedEXT: PFNGLDRAWELEMENTSINSTANCEDEXTPROC;
glTexBufferEXT: PFNGLTEXBUFFEREXTPROC;
glColorMaskIndexedEXT: PFNGLCOLORMASKINDEXEDEXTPROC;
glGetBooleanIndexedvEXT: PFNGLGETBOOLEANINDEXEDVEXTPROC;
glGetIntegerIndexedvEXT: PFNGLGETINTEGERINDEXEDVEXTPROC;
glEnableIndexedEXT: PFNGLENABLEINDEXEDEXTPROC;
glDisableIndexedEXT: PFNGLDISABLEINDEXEDEXTPROC;
glIsEnabledIndexedEXT: PFNGLISENABLEDINDEXEDEXTPROC;
glBindBufferRangeNV: PFNGLBINDBUFFERRANGENVPROC;
glBindBufferOffsetNV: PFNGLBINDBUFFEROFFSETNVPROC;
glBindBufferBaseNV: PFNGLBINDBUFFERBASENVPROC;
glTransformFeedbackAttribsNV: PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC;
glTransformFeedbackVaryingsNV: PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC;
glBeginTransformFeedbackNV: PFNGLBEGINTRANSFORMFEEDBACKNVPROC;
glEndTransformFeedbackNV: PFNGLENDTRANSFORMFEEDBACKNVPROC;
glGetVaryingLocationNV: PFNGLGETVARYINGLOCATIONNVPROC;
glGetActiveVaryingNV: PFNGLGETACTIVEVARYINGNVPROC;
glActiveVaryingNV: PFNGLACTIVEVARYINGNVPROC;
glGetTransformFeedbackVaryingNV: PFNGLGETTRANSFORMFEEDBACKVARYINGNVPROC;
glUniformBufferEXT: PFNGLUNIFORMBUFFEREXTPROC;
glGetUniformBufferSizeEXT: PFNGLGETUNIFORMBUFFERSIZEEXTPROC;
glGetUniformOffsetEXT: PFNGLGETUNIFORMOFFSETEXTPROC;
glClearColorIiEXT: PFNGLCLEARCOLORIIEXTPROC;
glClearColorIuiEXT: PFNGLCLEARCOLORIUIEXTPROC;
glTexParameterIivEXT: PFNGLTEXPARAMETERIIVEXTPROC;
glTexParameterIuivEXT: PFNGLTEXPARAMETERIUIVEXTPROC;
glGetTexParameterIivEXT: PFNGLGETTEXPARAMETERIIVEXTPROC;
glGetTexParameterIuivEXT: PFNGLGETTEXPARAMETERIUIVEXTPROC;
glFrameTerminatorGREMEDY: PFNGLFRAMETERMINATORGREMEDYPROC;
glBeginConditionalRenderNV: PFNGLBEGINCONDITIONALRENDERNVPROC;
glEndConditionalRenderNV: PFNGLENDCONDITIONALRENDERNVPROC;
glBindBufferRangeEXT: PFNGLBINDBUFFERRANGEEXTPROC;
glBindBufferOffsetEXT: PFNGLBINDBUFFEROFFSETEXTPROC;
glBindBufferBaseEXT: PFNGLBINDBUFFERBASEEXTPROC;
glBeginTransformFeedbackEXT: PFNGLBEGINTRANSFORMFEEDBACKEXTPROC;
glEndTransformFeedbackEXT: PFNGLENDTRANSFORMFEEDBACKEXTPROC;
glTransformFeedbackVaryingsEXT: PFNGLTRANSFORMFEEDBACKVARYINGSEXTPROC;
glGetTransformFeedbackVaryingEXT: PFNGLGETTRANSFORMFEEDBACKVARYINGEXTPROC;
glTessellationFactorAMD: PFNGLTESSELLATIONFACTORAMDPROC;
glTessellationModeAMD: PFNGLTESSELLATIONMODEAMDPROC;
glCopyImageSubDataNV: PFNGLCOPYIMAGESUBDATANVPROC;
glMakeBufferResidentNV: PFNGLMAKEBUFFERRESIDENTNVPROC;
glMakeBufferNonResidentNV: PFNGLMAKEBUFFERNONRESIDENTNVPROC;
glIsBufferResidentNV: PFNGLISBUFFERRESIDENTNVPROC;
glMakeNamedBufferResidentNV: PFNGLMAKENAMEDBUFFERRESIDENTNVPROC;
glMakeNamedBufferNonResidentNV: PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC;
glIsNamedBufferResidentNV: PFNGLISNAMEDBUFFERRESIDENTNVPROC;
glGetBufferParameterui64vNV: PFNGLGETBUFFERPARAMETERUI64VNVPROC;
glGetNamedBufferParameterui64vNV: PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC;
glGetIntegerui64vNV: PFNGLGETINTEGERUI64VNVPROC;
glUniformui64NV: PFNGLUNIFORMUI64NVPROC;
glUniformui64vNV: PFNGLUNIFORMUI64VNVPROC;
glGetUniformui64vNV: PFNGLGETUNIFORMUI64VNVPROC;
glProgramUniformui64NV: PFNGLPROGRAMUNIFORMUI64NVPROC;
glProgramUniformui64vNV: PFNGLPROGRAMUNIFORMUI64VNVPROC;
glBufferAddressRangeNV: PFNGLBUFFERADDRESSRANGENVPROC;
glVertexFormatNV: PFNGLVERTEXFORMATNVPROC;
glNormalFormatNV: PFNGLNORMALFORMATNVPROC;
glColorFormatNV: PFNGLCOLORFORMATNVPROC;
glIndexFormatNV: PFNGLINDEXFORMATNVPROC;
glTexCoordFormatNV: PFNGLTEXCOORDFORMATNVPROC;
glEdgeFlagFormatNV: PFNGLEDGEFLAGFORMATNVPROC;
glSecondaryColorFormatNV: PFNGLSECONDARYCOLORFORMATNVPROC;
glFogCoordFormatNV: PFNGLFOGCOORDFORMATNVPROC;
glVertexAttribFormatNV: PFNGLVERTEXATTRIBFORMATNVPROC;
glVertexAttribIFormatNV: PFNGLVERTEXATTRIBIFORMATNVPROC;
glGetIntegerui64i_vNV: PFNGLGETINTEGERUI64I_VNVPROC;
vIgnoreOpenGLErrors: Boolean = false;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:22


GLScene v.1.1.2: OpenGL1x: Class EOpenGLError

Class EOpenGLError

Unit

OpenGL1x

Declaration

type EOpenGLError = class(Exception)

Description

Hierarchy

  • Exception
  • EOpenGLError
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:22


GLScene v.1.1.2: OpenGLAdapter

Unit OpenGLAdapter

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EOpenGLError |
Class TGLExtensionsAndEntryPoints |

Functions and Procedures

function wglGetProcAddress(ProcName: PGLChar): Pointer; stdcall; external opengl32;
function wglCopyContext(p1: HGLRC; p2: HGLRC; p3: cardinal): BOOL; stdcall; external opengl32;
function wglCreateContext(DC: HDC): HGLRC; stdcall; external opengl32;
function wglCreateLayerContext(p1: HDC; p2: integer): HGLRC; stdcall; external opengl32;
function wglDeleteContext(p1: HGLRC): BOOL; stdcall; external opengl32;
function wglDescribeLayerPlane(p1: HDC; p2, p3: integer; p4: cardinal; var p5: TLayerPlaneDescriptor): BOOL; stdcall; external opengl32;
function wglGetCurrentContext: HGLRC; stdcall; external opengl32;
function wglGetCurrentDC: HDC; stdcall; external opengl32;
function wglGetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;
function wglMakeCurrent(DC: HDC; p2: HGLRC): BOOL; stdcall; external opengl32;
function wglRealizeLayerPalette(p1: HDC; p2: integer; p3: BOOL): BOOL; stdcall; external opengl32;
function wglSetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;
function wglShareLists(p1, p2: HGLRC): BOOL; stdcall; external opengl32;
function wglSwapLayerBuffers(p1: HDC; p2: cardinal): BOOL; stdcall; external opengl32;
function wglSwapMultipleBuffers(p1: UINT; const p2: PWGLSwap): DWORD; stdcall; external opengl32;
function wglUseFontBitmapsA(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;
function wglUseFontOutlinesA(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;
function wglUseFontBitmapsW(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;
function wglUseFontOutlinesW(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;
function wglUseFontBitmaps(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32 Name 'wglUseFontBitmapsA';
function wglUseFontOutlines(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32 Name 'wglUseFontOutlinesA';
function gluErrorString(errCode: TGLEnum): PGLChar; stdcall; external glu32;
function gluGetString(Name: TGLEnum): PGLChar; stdcall; external glu32;
procedure gluOrtho2D(left, right, bottom, top: TGLdouble); stdcall; external glu32;
procedure gluPerspective(fovy, aspect, zNear, zFar: TGLdouble); stdcall; external glu32;
procedure gluPickMatrix(X, y, Width, Height: TGLdouble; const Viewport: TVector4i); stdcall; external glu32;
procedure gluLookAt(eyex, eyey, eyez, centerx, centery, centerz, upx, upy, upz: TGLdouble); stdcall; external glu32;
function gluProject(objx, objy, objz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const Viewport: TVector4i; winx, winy, winz: PGLdouble): TGLint; stdcall; external glu32;
function gluUnProject(winx, winy, winz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const Viewport: TVector4i; objx, objy, objz: PGLdouble): TGLint; stdcall; external glu32;
function gluScaleImage(format: TGLEnum; widthin, heightin: TGLint; typein: TGLEnum; datain: Pointer; widthout, heightout: TGLint; typeout: TGLEnum; dataout: Pointer): TGLint; stdcall; external glu32;
function gluBuild1DMipmaps(target: TGLEnum; Components, Width: TGLint; format, atype: TGLEnum; Data: Pointer): TGLint; stdcall; external glu32;
function gluBuild2DMipmaps(target: TGLEnum; Components, Width, Height: TGLint; format, atype: TGLEnum; Data: Pointer): TGLint; stdcall; external glu32;
function gluNewQuadric: PGLUquadric; stdcall; external glu32;
procedure gluDeleteQuadric(state: PGLUquadric); stdcall; external glu32;
procedure gluQuadricNormals(quadObject: PGLUquadric; normals: TGLEnum); stdcall; external glu32;
procedure gluQuadricTexture(quadObject: PGLUquadric; textureCoords: TGLboolean); stdcall; external glu32;
procedure gluQuadricOrientation(quadObject: PGLUquadric; orientation: TGLEnum); stdcall; external glu32;
procedure gluQuadricDrawStyle(quadObject: PGLUquadric; drawStyle: TGLEnum); stdcall; external glu32;
procedure gluCylinder(quadObject: PGLUquadric; baseRadius, topRadius, Height: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;
procedure gluDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint); stdcall; external glu32;
procedure gluPartialDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint; startAngle, sweepAngle: TGLdouble); stdcall; external glu32;
procedure gluSphere(quadObject: PGLUquadric; radius: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;
procedure gluQuadricCallback(quadObject: PGLUquadric; which: TGLEnum; fn: TGLUQuadricErrorProc); stdcall; external glu32;
function gluNewTess: PGLUtesselator; stdcall; external glu32;
procedure gluDeleteTess(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessBeginPolygon(tess: PGLUtesselator; polygon_data: Pointer); stdcall; external glu32;
procedure gluTessBeginContour(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessVertex(tess: PGLUtesselator; const coords: TVector3d; Data: Pointer); stdcall; external glu32;
procedure gluTessEndContour(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessEndPolygon(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessProperty(tess: PGLUtesselator; which: TGLEnum; Value: TGLdouble); stdcall; external glu32;
procedure gluTessNormal(tess: PGLUtesselator; X, y, z: TGLdouble); stdcall; external glu32;
procedure gluTessCallback(tess: PGLUtesselator; which: TGLEnum; fn: Pointer); stdcall; external glu32;
procedure gluGetTessProperty(tess: PGLUtesselator; which: TGLEnum; Value: PGLdouble); stdcall; external glu32;
function gluNewNurbsRenderer: PGLUnurbs; stdcall; external glu32;
procedure gluDeleteNurbsRenderer(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginSurface(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginCurve(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndCurve(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndSurface(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginTrim(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndTrim(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluPwlCurve(nobj: PGLUnurbs; Count: TGLint; points: PGLfloat; stride: TGLint; atype: TGLEnum); stdcall; external glu32;
procedure gluNurbsCurve(nobj: PGLUnurbs; nknots: TGLint; knot: PGLfloat; stride: TGLint; ctlarray: PGLfloat; order: TGLint; atype: TGLEnum); stdcall; external glu32;
procedure gluNurbsSurface(nobj: PGLUnurbs; sknot_count: TGLint; sknot: PGLfloat; tknot_count: TGLint; tknot: PGLfloat; s_stride, t_stride: TGLint; ctlarray: PGLfloat; sorder, torder: TGLint; atype: TGLEnum); stdcall; external glu32;
procedure gluLoadSamplingMatrices(nobj: PGLUnurbs; const modelMatrix: TMatrix4f; const projMatrix: TMatrix4f; const Viewport: TVector4i); stdcall; external glu32;
procedure gluNurbsProperty(nobj: PGLUnurbs; aproperty: TGLEnum; Value: TGLfloat); stdcall; external glu32;
procedure gluGetNurbsProperty(nobj: PGLUnurbs; aproperty: TGLEnum; Value: PGLfloat); stdcall; external glu32;
procedure gluNurbsCallback(nobj: PGLUnurbs; which: TGLEnum; fn: TGLUNurbsErrorProc); stdcall; external glu32;
procedure gluBeginPolygon(tess: PGLUtesselator); stdcall; external glu32;
procedure gluNextContour(tess: PGLUtesselator; atype: TGLEnum); stdcall; external glu32;
procedure gluEndPolygon(tess: PGLUtesselator); stdcall; external glu32;
function GLLibGetProcAddress(ProcName: PGLChar): Pointer;
function GLGetProcAddress(ProcName: PGLChar): Pointer;
procedure CloseOpenGL;
function InitOpenGL: boolean;
function InitOpenGLFromLibrary(const GLName, GLUName: string): boolean;
function IsOpenGLInitialized: boolean;
procedure UnloadOpenGL;
function LoadOpenGL: boolean;
function LoadOpenGLFromLibrary(GLName, GLUName: string): boolean;
function IsOpenGLLoaded: boolean;
function IsMesaGL: boolean;
procedure TrimAndSplitVersionString(buffer: string; var max, min: integer);
function IsVersionMet(MajorVersion, MinorVersion, actualMajorVersion, actualMinorVersion: integer): boolean;

Description

Functions and Procedures

function wglGetProcAddress(ProcName: PGLChar): Pointer; stdcall; external opengl32;
function wglCopyContext(p1: HGLRC; p2: HGLRC; p3: cardinal): BOOL; stdcall; external opengl32;
function wglCreateContext(DC: HDC): HGLRC; stdcall; external opengl32;
function wglCreateLayerContext(p1: HDC; p2: integer): HGLRC; stdcall; external opengl32;
function wglDeleteContext(p1: HGLRC): BOOL; stdcall; external opengl32;
function wglDescribeLayerPlane(p1: HDC; p2, p3: integer; p4: cardinal; var p5: TLayerPlaneDescriptor): BOOL; stdcall; external opengl32;
function wglGetCurrentContext: HGLRC; stdcall; external opengl32;
function wglGetCurrentDC: HDC; stdcall; external opengl32;
function wglGetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;
function wglMakeCurrent(DC: HDC; p2: HGLRC): BOOL; stdcall; external opengl32;
function wglRealizeLayerPalette(p1: HDC; p2: integer; p3: BOOL): BOOL; stdcall; external opengl32;
function wglSetLayerPaletteEntries(p1: HDC; p2, p3, p4: integer; var pcr): integer; stdcall; external opengl32;
function wglShareLists(p1, p2: HGLRC): BOOL; stdcall; external opengl32;
function wglSwapLayerBuffers(p1: HDC; p2: cardinal): BOOL; stdcall; external opengl32;
function wglSwapMultipleBuffers(p1: UINT; const p2: PWGLSwap): DWORD; stdcall; external opengl32;
function wglUseFontBitmapsA(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;
function wglUseFontOutlinesA(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;
function wglUseFontBitmapsW(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32;
function wglUseFontOutlinesW(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32;
function wglUseFontBitmaps(DC: HDC; p2, p3, p4: DWORD): BOOL; stdcall; external opengl32 Name 'wglUseFontBitmapsA';
function wglUseFontOutlines(p1: HDC; p2, p3, p4: DWORD; p5, p6: single; p7: integer; p8: PGlyphMetricsFloat): BOOL; stdcall; external opengl32 Name 'wglUseFontOutlinesA';
function gluErrorString(errCode: TGLEnum): PGLChar; stdcall; external glu32;
function gluGetString(Name: TGLEnum): PGLChar; stdcall; external glu32;
procedure gluOrtho2D(left, right, bottom, top: TGLdouble); stdcall; external glu32;
procedure gluPerspective(fovy, aspect, zNear, zFar: TGLdouble); stdcall; external glu32;
procedure gluPickMatrix(X, y, Width, Height: TGLdouble; const Viewport: TVector4i); stdcall; external glu32;
procedure gluLookAt(eyex, eyey, eyez, centerx, centery, centerz, upx, upy, upz: TGLdouble); stdcall; external glu32;
function gluProject(objx, objy, objz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const Viewport: TVector4i; winx, winy, winz: PGLdouble): TGLint; stdcall; external glu32;
function gluUnProject(winx, winy, winz: TGLdouble; const modelMatrix: TMatrix4d; const projMatrix: TMatrix4d; const Viewport: TVector4i; objx, objy, objz: PGLdouble): TGLint; stdcall; external glu32;
function gluScaleImage(format: TGLEnum; widthin, heightin: TGLint; typein: TGLEnum; datain: Pointer; widthout, heightout: TGLint; typeout: TGLEnum; dataout: Pointer): TGLint; stdcall; external glu32;
function gluBuild1DMipmaps(target: TGLEnum; Components, Width: TGLint; format, atype: TGLEnum; Data: Pointer): TGLint; stdcall; external glu32;
function gluBuild2DMipmaps(target: TGLEnum; Components, Width, Height: TGLint; format, atype: TGLEnum; Data: Pointer): TGLint; stdcall; external glu32;
function gluNewQuadric: PGLUquadric; stdcall; external glu32;
procedure gluDeleteQuadric(state: PGLUquadric); stdcall; external glu32;
procedure gluQuadricNormals(quadObject: PGLUquadric; normals: TGLEnum); stdcall; external glu32;
procedure gluQuadricTexture(quadObject: PGLUquadric; textureCoords: TGLboolean); stdcall; external glu32;
procedure gluQuadricOrientation(quadObject: PGLUquadric; orientation: TGLEnum); stdcall; external glu32;
procedure gluQuadricDrawStyle(quadObject: PGLUquadric; drawStyle: TGLEnum); stdcall; external glu32;
procedure gluCylinder(quadObject: PGLUquadric; baseRadius, topRadius, Height: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;
procedure gluDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint); stdcall; external glu32;
procedure gluPartialDisk(quadObject: PGLUquadric; innerRadius, outerRadius: TGLdouble; slices, loops: TGLint; startAngle, sweepAngle: TGLdouble); stdcall; external glu32;
procedure gluSphere(quadObject: PGLUquadric; radius: TGLdouble; slices, stacks: TGLint); stdcall; external glu32;
procedure gluQuadricCallback(quadObject: PGLUquadric; which: TGLEnum; fn: TGLUQuadricErrorProc); stdcall; external glu32;
function gluNewTess: PGLUtesselator; stdcall; external glu32;
procedure gluDeleteTess(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessBeginPolygon(tess: PGLUtesselator; polygon_data: Pointer); stdcall; external glu32;
procedure gluTessBeginContour(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessVertex(tess: PGLUtesselator; const coords: TVector3d; Data: Pointer); stdcall; external glu32;
procedure gluTessEndContour(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessEndPolygon(tess: PGLUtesselator); stdcall; external glu32;
procedure gluTessProperty(tess: PGLUtesselator; which: TGLEnum; Value: TGLdouble); stdcall; external glu32;
procedure gluTessNormal(tess: PGLUtesselator; X, y, z: TGLdouble); stdcall; external glu32;
procedure gluTessCallback(tess: PGLUtesselator; which: TGLEnum; fn: Pointer); stdcall; external glu32;
procedure gluGetTessProperty(tess: PGLUtesselator; which: TGLEnum; Value: PGLdouble); stdcall; external glu32;
function gluNewNurbsRenderer: PGLUnurbs; stdcall; external glu32;
procedure gluDeleteNurbsRenderer(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginSurface(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginCurve(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndCurve(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndSurface(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluBeginTrim(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluEndTrim(nobj: PGLUnurbs); stdcall; external glu32;
procedure gluPwlCurve(nobj: PGLUnurbs; Count: TGLint; points: PGLfloat; stride: TGLint; atype: TGLEnum); stdcall; external glu32;
procedure gluNurbsCurve(nobj: PGLUnurbs; nknots: TGLint; knot: PGLfloat; stride: TGLint; ctlarray: PGLfloat; order: TGLint; atype: TGLEnum); stdcall; external glu32;
procedure gluNurbsSurface(nobj: PGLUnurbs; sknot_count: TGLint; sknot: PGLfloat; tknot_count: TGLint; tknot: PGLfloat; s_stride, t_stride: TGLint; ctlarray: PGLfloat; sorder, torder: TGLint; atype: TGLEnum); stdcall; external glu32;
procedure gluLoadSamplingMatrices(nobj: PGLUnurbs; const modelMatrix: TMatrix4f; const projMatrix: TMatrix4f; const Viewport: TVector4i); stdcall; external glu32;
procedure gluNurbsProperty(nobj: PGLUnurbs; aproperty: TGLEnum; Value: TGLfloat); stdcall; external glu32;
procedure gluGetNurbsProperty(nobj: PGLUnurbs; aproperty: TGLEnum; Value: PGLfloat); stdcall; external glu32;
procedure gluNurbsCallback(nobj: PGLUnurbs; which: TGLEnum; fn: TGLUNurbsErrorProc); stdcall; external glu32;
procedure gluBeginPolygon(tess: PGLUtesselator); stdcall; external glu32;
procedure gluNextContour(tess: PGLUtesselator; atype: TGLEnum); stdcall; external glu32;
procedure gluEndPolygon(tess: PGLUtesselator); stdcall; external glu32;
function GLLibGetProcAddress(ProcName: PGLChar): Pointer;
function GLGetProcAddress(ProcName: PGLChar): Pointer;
procedure CloseOpenGL;
function InitOpenGL: boolean;
function InitOpenGLFromLibrary(const GLName, GLUName: string): boolean;
function IsOpenGLInitialized: boolean;
procedure UnloadOpenGL;
function LoadOpenGL: boolean;
function LoadOpenGLFromLibrary(GLName, GLUName: string): boolean;
function IsOpenGLLoaded: boolean;
function IsMesaGL: boolean;
procedure TrimAndSplitVersionString(buffer: string; var max, min: integer);
function IsVersionMet(MajorVersion, MinorVersion, actualMajorVersion, actualMinorVersion: integer): boolean;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:22


GLScene v.1.1.2: OpenGLAdapter: Class EOpenGLError

Class EOpenGLError

Unit

OpenGLAdapter

Declaration

type EOpenGLError = class(Exception)

Description

Hierarchy

  • Exception
  • EOpenGLError
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:22


GLScene v.1.1.2: OpenGLAdapter: Class TGLExtensionsAndEntryPoints

Class TGLExtensionsAndEntryPoints

Unit

OpenGLAdapter

Declaration

type TGLExtensionsAndEntryPoints = class(TObject)

Description

Hierarchy

  • TObject
  • TGLExtensionsAndEntryPoints

Overview

Fields

Public | VERSION_1_0: boolean;
Public | VERSION_1_1: boolean;
Public | VERSION_1_2: boolean;
Public | VERSION_1_3: boolean;
Public | VERSION_1_4: boolean;
Public | VERSION_1_5: boolean;
Public | VERSION_2_0: boolean;
Public | VERSION_2_1: boolean;
Public | VERSION_3_0: boolean;
Public | VERSION_3_1: boolean;
Public | VERSION_3_2: boolean;
Public | VERSION_3_3: boolean;
Public | VERSION_4_0: boolean;
Public | VERSION_4_1: boolean;
Public | VERSION_4_2: boolean;
Public | ARB_blend_func_extended: boolean;
Public | ARB_color_buffer_float: boolean;
Public | ARB_compatibility: boolean;
Public | ARB_copy_buffer: boolean;
Public | ARB_depth_buffer_float: boolean;
Public | ARB_depth_clamp: boolean;
Public | ARB_depth_texture: boolean;
Public | ARB_draw_buffers: boolean;
Public | ARB_draw_buffers_blend: boolean;
Public | ARB_draw_elements_base_vertex: boolean;
Public | ARB_draw_indirect: boolean;
Public | ARB_draw_instanced: boolean;
Public | ARB_explicit_attrib_location: boolean;
Public | ARB_fragment_coord_conventions: boolean;
Public | ARB_fragment_program: boolean;
Public | ARB_fragment_program_shadow: boolean;
Public | ARB_fragment_shader: boolean;
Public | ARB_framebuffer_object: boolean;
Public | ARB_framebuffer_sRGB: boolean;
Public | ARB_geometry_shader4: boolean;
Public | ARB_gpu_shader_fp64: boolean;
Public | ARB_gpu_shader5: boolean;
Public | ARB_half_float_pixel: boolean;
Public | ARB_half_float_vertex: boolean;
Public | ARB_imaging: boolean;
Public | ARB_instanced_arrays: boolean;
Public | ARB_map_buffer_range: boolean;
Public | ARB_matrix_palette: boolean;
Public | ARB_multisample: boolean;
Public | ARB_multitexture: boolean;
Public | ARB_occlusion_query: boolean;
Public | ARB_occlusion_query2: boolean;
Public | ARB_pixel_buffer_object: boolean;
Public | ARB_point_parameters: boolean;
Public | ARB_point_sprite: boolean;
Public | ARB_provoking_vertex: boolean;
Public | ARB_sample_shading: boolean;
Public | ARB_sampler_objects: boolean;
Public | ARB_seamless_cube_map: boolean;
Public | ARB_shader_bit_encoding: boolean;
Public | ARB_shader_subroutine: boolean;
Public | ARB_shader_texture_lod: boolean;
Public | ARB_shading_language_100: boolean;
Public | ARB_shadow: boolean;
Public | ARB_shadow_ambient: boolean;
Public | ARB_shader_objects: boolean;
Public | ARB_sync: boolean;
Public | ARB_tessellation_shader: boolean;
Public | ARB_texture_border_clamp: boolean;
Public | ARB_texture_buffer_object: boolean;
Public | ARB_texture_buffer_object_rgb32: boolean;
Public | ARB_texture_compression: boolean;
Public | ARB_texture_compression_rgtc: boolean;
Public | ARB_texture_cube_map: boolean;
Public | ARB_texture_cube_map_array: boolean;
Public | ARB_texture_env_add: boolean;
Public | ARB_texture_env_combine: boolean;
Public | ARB_texture_env_crossbar: boolean;
Public | ARB_texture_env_dot3: boolean;
Public | ARB_texture_float: boolean;
Public | ARB_texture_gather: boolean;
Public | ARB_texture_mirrored_repeat: boolean;
Public | ARB_texture_multisample: boolean;
Public | ARB_texture_non_power_of_two: boolean;
Public | ARB_texture_query_lod: boolean;
Public | ARB_texture_rectangle: boolean;
Public | ARB_texture_rg: boolean;
Public | ARB_texture_rgb10_a2ui: boolean;
Public | ARB_texture_swizzle: boolean;
Public | ARB_timer_query: boolean;
Public | ARB_transform_feedback2: boolean;
Public | ARB_transform_feedback3: boolean;
Public | ARB_transpose_matrix: boolean;
Public | ARB_uniform_buffer_object: boolean;
Public | ARB_vertex_array_bgra: boolean;
Public | ARB_vertex_array_object: boolean;
Public | ARB_vertex_blend: boolean;
Public | ARB_vertex_buffer_object: boolean;
Public | ARB_vertex_program: boolean;
Public | ARB_vertex_shader: boolean;
Public | ARB_vertex_type_2_10_10_10_rev: boolean;
Public | ARB_window_pos: boolean;
Public | ARB_texture_compression_bptc: boolean;
Public | ARB_get_program_binary: boolean;
Public | ARB_separate_shader_objects: boolean;
Public | _3DFX_multisample: boolean;
Public | _3DFX_tbuffer: boolean;
Public | _3DFX_texture_compression_FXT1: boolean;
Public | ATI_draw_buffers: boolean;
Public | ATI_texture_compression_3dc: boolean;
Public | ATI_texture_float: boolean;
Public | ATI_texture_mirror_once: boolean;
Public | S3_s3tc: boolean;
Public | EXT_abgr: boolean;
Public | EXT_bgra: boolean;
Public | EXT_bindable_uniform: boolean;
Public | EXT_blend_color: boolean;
Public | EXT_blend_equation_separate: boolean;
Public | EXT_blend_func_separate: boolean;
Public | EXT_blend_logic_op: boolean;
Public | EXT_blend_minmax: boolean;
Public | EXT_blend_subtract: boolean;
Public | EXT_Cg_shader: boolean;
Public | EXT_clip_volume_hint: boolean;
Public | EXT_compiled_vertex_array: boolean;
Public | EXT_copy_texture: boolean;
Public | EXT_depth_bounds_test: boolean;
Public | EXT_draw_buffers2: boolean;
Public | EXT_draw_instanced: boolean;
Public | EXT_draw_range_elements: boolean;
Public | EXT_fog_coord: boolean;
Public | EXT_framebuffer_blit: boolean;
Public | EXT_framebuffer_multisample: boolean;
Public | EXT_framebuffer_object: boolean;
Public | EXT_framebuffer_sRGB: boolean;
Public | EXT_geometry_shader4: boolean;
Public | EXT_gpu_program_parameters: boolean;
Public | EXT_gpu_shader4: boolean;
Public | EXT_multi_draw_arrays: boolean;
Public | EXT_multisample: boolean;
Public | EXT_packed_depth_stencil: boolean;
Public | EXT_packed_float: boolean;
Public | EXT_packed_pixels: boolean;
Public | EXT_paletted_texture: boolean;
Public | EXT_pixel_buffer_object: boolean;
Public | EXT_polygon_offset: boolean;
Public | EXT_rescale_normal: boolean;
Public | EXT_secondary_color: boolean;
Public | EXT_separate_specular_color: boolean;
Public | EXT_shadow_funcs: boolean;
Public | EXT_shared_texture_palette: boolean;
Public | EXT_stencil_clear_tag: boolean;
Public | EXT_stencil_two_side: boolean;
Public | EXT_stencil_wrap: boolean;
Public | EXT_texture3D: boolean;
Public | EXT_texture_array: boolean;
Public | EXT_texture_buffer_object: boolean;
Public | EXT_texture_compression_latc: boolean;
Public | EXT_texture_compression_rgtc: boolean;
Public | EXT_texture_compression_s3tc: boolean;
Public | EXT_texture_cube_map: boolean;
Public | EXT_texture_edge_clamp: boolean;
Public | EXT_texture_env_add: boolean;
Public | EXT_texture_env_combine: boolean;
Public | EXT_texture_env_dot3: boolean;
Public | EXT_texture_filter_anisotropic: boolean;
Public | EXT_texture_integer: boolean;
Public | EXT_texture_lod: boolean;
Public | EXT_texture_lod_bias: boolean;
Public | EXT_texture_mirror_clamp: boolean;
Public | EXT_texture_object: boolean;
Public | EXT_texture_rectangle: boolean;
Public | EXT_texture_sRGB: boolean;
Public | EXT_texture_shared_exponent: boolean;
Public | EXT_timer_query: boolean;
Public | EXT_transform_feedback: boolean;
Public | EXT_vertex_array: boolean;
Public | EXT_texture_sRGB_decode: boolean;
Public | EXT_direct_state_access: boolean;
Public | EXT_texture_swizzle: boolean;
Public | HP_occlusion_test: boolean;
Public | IBM_rasterpos_clip: boolean;
Public | KTX_buffer_region: boolean;
Public | MESA_resize_buffers: boolean;
Public | NV_blend_square: boolean;
Public | NV_conditional_render: boolean;
Public | NV_copy_image: boolean;
Public | NV_depth_buffer_float: boolean;
Public | NV_fence: boolean;
Public | NV_float_buffer: boolean;
Public | NV_fog_distance: boolean;
Public | NV_geometry_program4: boolean;
Public | NV_light_max_exponent: boolean;
Public | NV_multisample_filter_hint: boolean;
Public | NV_occlusion_query: boolean;
Public | NV_point_sprite: boolean;
Public | NV_primitive_restart: boolean;
Public | NV_register_combiners: boolean;
Public | NV_shader_buffer_load: boolean;
Public | NV_texgen_reflection: boolean;
Public | NV_texture_compression_vtc: boolean;
Public | NV_texture_env_combine4: boolean;
Public | NV_texture_rectangle: boolean;
Public | NV_texture_shader: boolean;
Public | NV_texture_shader2: boolean;
Public | NV_texture_shader3: boolean;
Public | NV_transform_feedback: boolean;
Public | NV_vertex_array_range: boolean;
Public | NV_vertex_array_range2: boolean;
Public | NV_vertex_buffer_unified_memory: boolean;
Public | NV_vertex_program: boolean;
Public | SGI_color_matrix: boolean;
Public | SGIS_generate_mipmap: boolean;
Public | SGIS_multisample: boolean;
Public | SGIS_texture_border_clamp: boolean;
Public | SGIS_texture_color_mask: boolean;
Public | SGIS_texture_edge_clamp: boolean;
Public | SGIS_texture_lod: boolean;
Public | SGIX_depth_texture: boolean;
Public | SGIX_shadow: boolean;
Public | SGIX_shadow_ambient: boolean;
Public | AMD_vertex_shader_tessellator: boolean;
Public | WIN_swap_hint: boolean;
Public | ATI_meminfo: boolean;
Public | NVX_gpu_memory_info: boolean;
Public | NV_vdpau_interop: boolean;
Public | NV_path_rendering: boolean;
Public | GREMEDY_frame_terminator: boolean;
Public | GREMEDY_string_marker: boolean;
Public | AMDX_debug_output: boolean;
Public | ARB_debug_output: boolean;
Public | BindTexture: procedure(target: TGLEnum; texture: TGLuint); stdcall;
Public | BlendFunc: procedure(sfactor: TGLEnum; dfactor: TGLEnum); stdcall;
Public | Clear: procedure(mask: TGLbitfield); stdcall;
Public | ClearColor: procedure(red, green, blue, alpha: TGLclampf); stdcall;
Public | ClearDepth: procedure(depth: TGLclampd); stdcall;
Public | ClearStencil: procedure(s: TGLint); stdcall;
Public | ColorMask: procedure(red, green, blue, alpha: TGLboolean); stdcall;
Public | CopyTexImage1D: procedure(target: TGLEnum; level: TGLint; internalFormat: TGLEnum; X, y: TGLint; Width: TGLsizei; border: TGLint); stdcall;
Public | CopyTexImage2D: procedure(target: TGLEnum; level: TGLint; internalFormat: TGLEnum; X, y: TGLint; Width, Height: TGLsizei; border: TGLint); stdcall;
Public | CopyTexSubImage1D: procedure(target: TGLEnum; level, xoffset, X, y: TGLint; Width: TGLsizei); stdcall;
Public | CopyTexSubImage2D: procedure(target: TGLEnum; level, xoffset, yoffset, X, y: TGLint; Width, Height: TGLsizei); stdcall;
Public | CullFace: procedure(mode: TGLEnum); stdcall;
Public | DeleteTextures: procedure(n: TGLsizei; textures: PGLuint); stdcall;
Public | DepthFunc: procedure(func: TGLEnum); stdcall;
Public | DepthMask: procedure(flag: TGLboolean); stdcall;
Public | DepthRange: procedure(zNear, zFar: TGLclampd); stdcall;
Public | Disable: procedure(cap: TGLEnum); stdcall;
Public | DrawArrays: procedure(mode: TGLEnum; First: TGLint; Count: TGLsizei); stdcall;
Public | DrawBuffer: procedure(mode: TGLEnum); stdcall;
Public | DrawElements: procedure(mode: TGLEnum; Count: TGLsizei; atype: TGLEnum; indices: Pointer); stdcall;
Public | Enable: procedure(cap: TGLEnum); stdcall;
Public | Finish: procedure(); stdcall;
Public | Flush: procedure(); stdcall;
Public | FrontFace: procedure(mode: TGLEnum); stdcall;
Public | GenTextures: procedure(n: TGLsizei; textures: PGLuint); stdcall;
Public | GetBooleanv: procedure(pname: TGLEnum; params: PGLboolean); stdcall;
Public | GetDoublev: procedure(pname: TGLEnum; params: PGLdouble); stdcall;
Public | GetError: function: TGLuint; stdcall;
Public | GetFloatv: procedure(pname: TGLEnum; params: PGLfloat); stdcall;
Public | GetIntegerv: procedure(pname: TGLEnum; params: PGLint); stdcall;
Public | GetPointerv: procedure(pname: TGLEnum; var params); stdcall;
Public | GetString: function(Name: TGLEnum): PGLChar; stdcall;
Public | GetTexImage: procedure(target: TGLEnum; level: TGLint; format, atype: TGLEnum; pixels: Pointer); stdcall;
Public | GetTexLevelParameterfv: procedure(target: TGLEnum; level: TGLint; pname: TGLEnum; params: PGLfloat); stdcall;
Public | GetTexLevelParameteriv: procedure(target: TGLEnum; level: TGLint; pname: TGLEnum; params: PGLint); stdcall;
Public | GetTexParameterfv: procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;
Public | GetTexParameteriv: procedure(target, pname: TGLEnum; params: PGLint); stdcall;
Public | Hint: procedure(target, mode: TGLEnum); stdcall;
Public | IsEnabled: function(cap: TGLEnum): TGLboolean; stdcall;
Public | IsTexture: function(texture: TGLuint): TGLboolean; stdcall;
Public | LineWidth: procedure(Width: TGLfloat); stdcall;
Public | LogicOp: procedure(opcode: TGLEnum); stdcall;
Public | PixelStoref: procedure(pname: TGLEnum; param: TGLfloat); stdcall;
Public | PixelStorei: procedure(pname: TGLEnum; param: TGLint); stdcall;
Public | PointSize: procedure(size: TGLfloat); stdcall;
Public | PolygonMode: procedure(face, mode: TGLEnum); stdcall;
Public | PolygonOffset: procedure(factor, units: TGLfloat); stdcall;
Public | ReadBuffer: procedure(mode: TGLEnum); stdcall;
Public | ReadPixels: procedure(X, y: TGLint; Width, Height: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall;
Public | Scissor: procedure(X, y: TGLint; Width, Height: TGLsizei); stdcall;
Public | StencilFunc: procedure(func: TGLEnum; ref: TGLint; mask: TGLuint); stdcall;
Public | StencilMask: procedure(mask: TGLuint); stdcall;
Public | StencilOp: procedure(fail, zfail, zpass: TGLEnum); stdcall;
Public | TexImage1D: procedure(target: TGLEnum; level, internalFormat: TGLint; Width: TGLsizei; border: TGLint; format, atype: TGLEnum; pixels: Pointer); stdcall;
Public | TexImage2D: procedure(target: TGLEnum; level, internalFormat: TGLint; Width, Height: TGLsizei; border: TGLint; format, atype: TGLEnum; pixels: Pointer); stdcall;
Public | TexParameterf: procedure(target, pname: TGLEnum; param: TGLfloat); stdcall;
Public | TexParameterfv: procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;
Public | TexParameteri: procedure(target, pname: TGLEnum; param: TGLint); stdcall;
Public | TexParameteriv: procedure(target, pname: TGLEnum; params: PGLint); stdcall;
Public | TexSubImage1D: procedure(target: TGLEnum; level, xoffset: TGLint; Width: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall;
Public | TexSubImage2D: procedure(target: TGLEnum; level, xoffset, yoffset: TGLint; Width, Height: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall;
Public | Viewport: procedure(X, y: TGLint; Width, Height: TGLsizei); stdcall;
Public | Accum: procedure(op: TGLuint; Value: TGLfloat); stdcall;
Public | AlphaFunc: procedure(func: TGLEnum; ref: TGLclampf); stdcall;
Public | AreTexturesResident: function(n: TGLsizei; textures: PGLuint; residences: PGLboolean): TGLboolean; stdcall;
Public | ArrayElement: procedure(i: TGLint); stdcall;
Public | Begin_: procedure(mode: TGLEnum); stdcall;
Public | Bitmap: procedure(Width: TGLsizei; Height: TGLsizei; xorig, yorig: TGLfloat; xmove: TGLfloat; ymove: TGLfloat; Bitmap: Pointer); stdcall;
Public | CallList: procedure(list: TGLuint); stdcall;
Public | CallLists: procedure(n: TGLsizei; atype: TGLEnum; lists: Pointer); stdcall;
Public | ClearAccum: procedure(red, green, blue, alpha: TGLfloat); stdcall;
Public | ClearIndex: procedure(c: TGLfloat); stdcall;
Public | ClipPlane: procedure(plane: TGLEnum; equation: PGLdouble); stdcall;
Public | Color3b: procedure(red, green, blue: TGLbyte); stdcall;
Public | Color3bv: procedure(v: PGLbyte); stdcall;
Public | Color3d: procedure(red, green, blue: TGLdouble); stdcall;
Public | Color3dv: procedure(v: PGLdouble); stdcall;
Public | Color3f: procedure(red, green, blue: TGLfloat); stdcall;
Public | Color3fv: procedure(v: PGLfloat); stdcall;
Public | Color3i: procedure(red, green, blue: TGLint); stdcall;
Public | Color3iv: procedure(v: PGLint); stdcall;
Public | Color3s: procedure(red, green, blue: TGLshort); stdcall;
Public | Color3sv: procedure(v: PGLshort); stdcall;
Public | Color3ub: procedure(red, green, blue: TGLubyte); stdcall;
Public | Color3ubv: procedure(v: PGLubyte); stdcall;
Public | Color3ui: procedure(red, green, blue: TGLuint); stdcall;
Public | Color3uiv: procedure(v: PGLuint); stdcall;
Public | Color3us: procedure(red, green, blue: TGLushort); stdcall;
Public | Color3usv: procedure(v: PGLushort); stdcall;
Public | Color4b: procedure(red, green, blue, alpha: TGLbyte); stdcall;
Public | Color4bv: procedure(v: PGLbyte); stdcall;
Public | Color4d: procedure(red, green, blue, alpha: TGLdouble); stdcall;
Public | Color4dv: procedure(v: PGLdouble); stdcall;
Public | Color4f: procedure(red, green, blue, alpha: TGLfloat); stdcall;
Public | Color4fv: procedure(v: PGLfloat); stdcall;
Public | Color4i: procedure(red, green, blue, alpha: TGLint); stdcall;
Public | Color4iv: procedure(v: PGLint); stdcall;
Public | Color4s: procedure(red, green, blue, alpha: TGLshort); stdcall;
Public | Color4sv: procedure(v: TGLshort); stdcall;
Public | Color4ub: procedure(red, green, blue, alpha: TGLubyte); stdcall;
Public | Color4ubv: procedure(v: PGLubyte); stdcall;
Public | Color4ui: procedure(red, green, blue, alpha: TGLuint); stdcall;
Public | Color4uiv: procedure(v: PGLuint); stdcall;
Public | Color4us: procedure(red, green, blue, alpha: TGLushort); stdcall;
Public | Color4usv: procedure(v: PGLushort); stdcall;
Public | ColorMaterial: procedure(face: TGLEnum; mode: TGLEnum); stdcall;
Public | ColorPointer: procedure(size: TGLint; atype: TGLEnum; stride: TGLsizei; Data: Pointer); stdcall;
Public | CopyPixels: procedure(X, y: TGLint; Width, Height: TGLsizei; atype: TGLEnum); stdcall;
Public | DeleteLists: procedure(list: TGLuint; range: TGLsizei); stdcall;
Public | DisableClientState: procedure(aarray: TGLEnum); stdcall;
Public | DrawPixels: procedure(Width, Height: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall;
Public | EdgeFlag: procedure(flag: TGLboolean); stdcall;
Public | EdgeFlagPointer: procedure(stride: TGLsizei; Data: Pointer); stdcall;
Public | EdgeFlagv: procedure(flag: PGLboolean); stdcall;
Public | EnableClientState: procedure(aarray: TGLEnum); stdcall;
Public | End_: procedure(); stdcall;
Public | EndList: procedure(); stdcall;
Public | EvalCoord1d: procedure(u: TGLdouble); stdcall;
Public | EvalCoord1dv: procedure(u: PGLdouble); stdcall;
Public | EvalCoord1f: procedure(u: TGLfloat); stdcall;
Public | EvalCoord1fv: procedure(u: PGLfloat); stdcall;
Public | EvalCoord2d: procedure(u: TGLdouble; v: TGLdouble); stdcall;
Public | EvalCoord2dv: procedure(u: PGLdouble); stdcall;
Public | EvalCoord2f: procedure(u, v: TGLfloat); stdcall;
Public | EvalCoord2fv: procedure(u: PGLfloat); stdcall;
Public | EvalMesh1: procedure(mode: TGLEnum; i1, i2: TGLint); stdcall;
Public | EvalMesh2: procedure(mode: TGLEnum; i1, i2, j1, j2: TGLint); stdcall;
Public | EvalPoint1: procedure(i: TGLint); stdcall;
Public | EvalPoint2: procedure(i, j: TGLint); stdcall;
Public | FeedbackBuffer: procedure(size: TGLsizei; atype: TGLEnum; buffer: PGLfloat); stdcall;
Public | Fogf: procedure(pname: TGLEnum; param: TGLfloat); stdcall;
Public | Fogfv: procedure(pname: TGLEnum; params: PGLfloat); stdcall;
Public | Fogi: procedure(pname: TGLEnum; param: TGLint); stdcall;
Public | Fogiv: procedure(pname: TGLEnum; params: PGLint); stdcall;
Public | Frustum: procedure(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall;
Public | GenLists: function(range: TGLsizei): TGLuint; stdcall;
Public | GetClipPlane: procedure(plane: TGLEnum; equation: PGLdouble); stdcall;
Public | GetLightfv: procedure(light, pname: TGLEnum; params: PGLfloat); stdcall;
Public | GetLightiv: procedure(light, pname: TGLEnum; params: PGLint); stdcall;
Public | GetMapdv: procedure(target, query: TGLEnum; v: PGLdouble); stdcall;
Public | GetMapfv: procedure(target, query: TGLEnum; v: PGLfloat); stdcall;
Public | GetMapiv: procedure(target, query: TGLEnum; v: PGLint); stdcall;
Public | GetMaterialfv: procedure(face, pname: TGLEnum; params: PGLfloat); stdcall;
Public | GetMaterialiv: procedure(face, pname: TGLEnum; params: PGLint); stdcall;
Public | GetPixelMapfv: procedure(map: TGLEnum; values: PGLfloat); stdcall;
Public | GetPixelMapuiv: procedure(map: TGLEnum; values: PGLuint); stdcall;
Public | GetPixelMapusv: procedure(map: TGLEnum; values: PGLushort); stdcall;
Public | GetPolygonStipple: procedure(mask: PGLubyte); stdcall;
Public | GetTexEnvfv: procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;
Public | GetTexEnviv: procedure(target, pname: TGLEnum; params: PGLint); stdcall;
Public | GetTexGendv: procedure(coord, pname: TGLEnum; params: PGLdouble); stdcall;
Public | GetTexGenfv: procedure(coord, pname: TGLEnum; params: PGLfloat); stdcall;
Public | GetTexGeniv: procedure(coord, pname: TGLEnum; params: PGLint); stdcall;
Public | IndexMask: procedure(mask: TGLuint); stdcall;
Public | IndexPointer: procedure(atype: TGLEnum; stride: TGLsizei; Data: Pointer); stdcall;
Public | Indexd: procedure(c: TGLdouble); stdcall;
Public | Indexdv: procedure(c: PGLdouble); stdcall;
Public | Indexf: procedure(c: TGLfloat); stdcall;
Public | Indexfv: procedure(c: PGLfloat); stdcall;
Public | Indexi: procedure(c: TGLint); stdcall;
Public | Indexiv: procedure(c: PGLint); stdcall;
Public | Indexs: procedure(c: TGLshort); stdcall;
Public | Indexsv: procedure(c: PGLshort); stdcall;
Public | Indexub: procedure(c: TGLubyte); stdcall;
Public | Indexubv: procedure(c: PGLubyte); stdcall;
Public | InitNames: procedure(); stdcall;
Public | InterleavedArrays: procedure(format: TGLEnum; stride: TGLsizei; Data: Pointer); stdcall;
Public | IsList: function(list: TGLuint): TGLboolean; stdcall;
Public | LightModelf: procedure(pname: TGLEnum; param: TGLfloat); stdcall;
Public | LightModelfv: procedure(pname: TGLEnum; params: PGLfloat); stdcall;
Public | LightModeli: procedure(pname: TGLEnum; param: TGLint); stdcall;
Public | LightModeliv: procedure(pname: TGLEnum; params: PGLint); stdcall;
Public | Lightf: procedure(light, pname: TGLEnum; param: TGLfloat); stdcall;
Public | Lightfv: procedure(light, pname: TGLEnum; params: PGLfloat); stdcall;
Public | Lighti: procedure(light, pname: TGLEnum; param: TGLint); stdcall;
Public | Lightiv: procedure(light, pname: TGLEnum; params: PGLint); stdcall;
Public | LineStipple: procedure(factor: TGLint; pattern: TGLushort); stdcall;
Public | ListBase: procedure(base: TGLuint); stdcall;
Public | LoadIdentity: procedure(); stdcall;
Public | LoadMatrixd: procedure(m: PGLdouble); stdcall;
Public | LoadMatrixf: procedure(m: PGLfloat); stdcall;
Public | LoadName: procedure(Name: TGLuint); stdcall;
Public | Map1d: procedure(target: TGLEnum; u1, u2: TGLdouble; stride, order: TGLint; points: PGLdouble); stdcall;
Public | Map1f: procedure(target: TGLEnum; u1, u2: TGLfloat; stride, order: TGLint; points: PGLfloat); stdcall;
Public | Map2d: procedure(target: TGLEnum; u1, u2: TGLdouble; ustride, uorder: TGLint; v1, v2: TGLdouble; vstride, vorder: TGLint; points: PGLdouble); stdcall;
Public | Map2f: procedure(target: TGLEnum; u1, u2: TGLfloat; ustride, uorder: TGLint; v1, v2: TGLfloat; vstride, vorder: TGLint; points: PGLfloat); stdcall;
Public | MapGrid1d: procedure(un: TGLint; u1, u2: TGLdouble); stdcall;
Public | MapGrid1f: procedure(un: TGLint; u1, u2: TGLfloat); stdcall;
Public | MapGrid2d: procedure(un: TGLint; u1, u2: TGLdouble; vn: TGLint; v1, v2: TGLdouble); stdcall;
Public | MapGrid2f: procedure(un: TGLint; u1, u2: TGLfloat; vn: TGLint; v1, v2: TGLfloat); stdcall;
Public | Materialf: procedure(face, pname: TGLEnum; param: TGLfloat); stdcall;
Public | Materialfv: procedure(face, pname: TGLEnum; params: PGLfloat); stdcall;
Public | Materiali: procedure(face, pname: TGLEnum; param: TGLint); stdcall;
Public | Materialiv: procedure(face, pname: TGLEnum; params: PGLint); stdcall;
Public | MatrixMode: procedure(mode: TGLEnum); stdcall;
Public | MultMatrixd: procedure(m: PGLdouble); stdcall;
Public | MultMatrixf: procedure(m: PGLfloat); stdcall;
Public | NewList: procedure(list: TGLuint; mode: TGLEnum); stdcall;
Public | Normal3b: procedure(nx, ny, nz: TGLbyte); stdcall;
Public | Normal3bv: procedure(v: PGLbyte); stdcall;
Public | Normal3d: procedure(nx, ny, nz: TGLdouble); stdcall;
Public | Normal3dv: procedure(v: PGLdouble); stdcall;
Public | Normal3f: procedure(nx, ny, nz: TGLfloat); stdcall;
Public | Normal3fv: procedure(v: PGLfloat); stdcall;
Public | Normal3i: procedure(nx, ny, nz: TGLint); stdcall;
Public | Normal3iv: procedure(v: PGLint); stdcall;
Public | Normal3s: procedure(nx, ny, nz: TGLshort); stdcall;
Public | Normal3sv: procedure(v: PGLshort); stdcall;
Public | NormalPointer: procedure(atype: TGLEnum; stride: TGLsizei; Data: Pointer); stdcall;
Public | Ortho: procedure(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall;
Public | PassThrough: procedure(token: TGLfloat); stdcall;
Public | PixelMapfv: procedure(map: TGLEnum; mapsize: TGLsizei; values: PGLfloat); stdcall;
Public | PixelMapuiv: procedure(map: TGLEnum; mapsize: TGLsizei; values: PGLuint); stdcall;
Public | PixelMapusv: procedure(map: TGLEnum; mapsize: TGLsizei; values: PGLushort); stdcall;
Public | PixelTransferf: procedure(pname: TGLEnum; param: TGLfloat); stdcall;
Public | PixelTransferi: procedure(pname: TGLEnum; param: TGLint); stdcall;
Public | PixelZoom: procedure(xfactor, yfactor: TGLfloat); stdcall;
Public | PolygonStipple: procedure(mask: PGLubyte); stdcall;
Public | PopAttrib: procedure(); stdcall;
Public | PopClientAttrib: procedure(); stdcall;
Public | PopMatrix: procedure(); stdcall;
Public | PopName: procedure(); stdcall;
Public | PrioritizeTextures: procedure(n: TGLsizei; textures: PGLuint; priorities: PGLclampf); stdcall;
Public | PushAttrib: procedure(mask: TGLbitfield); stdcall;
Public | PushClientAttrib: procedure(mask: TGLbitfield); stdcall;
Public | PushMatrix: procedure(); stdcall;
Public | PushName: procedure(Name: TGLuint); stdcall;
Public | RasterPos2d: procedure(X, y: TGLdouble); stdcall;
Public | RasterPos2dv: procedure(v: PGLdouble); stdcall;
Public | RasterPos2f: procedure(X, y: TGLfloat); stdcall;
Public | RasterPos2fv: procedure(v: PGLfloat); stdcall;
Public | RasterPos2i: procedure(X, y: TGLint); stdcall;
Public | RasterPos2iv: procedure(v: PGLint); stdcall;
Public | RasterPos2s: procedure(X, y: PGLshort); stdcall;
Public | RasterPos2sv: procedure(v: PGLshort); stdcall;
Public | RasterPos3d: procedure(X, y, z: TGLdouble); stdcall;
Public | RasterPos3dv: procedure(v: PGLdouble); stdcall;
Public | RasterPos3f: procedure(X, y, z: TGLfloat); stdcall;
Public | RasterPos3fv: procedure(v: PGLfloat); stdcall;
Public | RasterPos3i: procedure(X, y, z: TGLint); stdcall;
Public | RasterPos3iv: procedure(v: PGLint); stdcall;
Public | RasterPos3s: procedure(X, y, z: TGLshort); stdcall;
Public | RasterPos3sv: procedure(v: PGLshort); stdcall;
Public | RasterPos4d: procedure(X, y, z, w: TGLdouble); stdcall;
Public | RasterPos4dv: procedure(v: PGLdouble); stdcall;
Public | RasterPos4f: procedure(X, y, z, w: TGLfloat); stdcall;
Public | RasterPos4fv: procedure(v: PGLfloat); stdcall;
Public | RasterPos4i: procedure(X, y, z, w: TGLint); stdcall;
Public | RasterPos4iv: procedure(v: PGLint); stdcall;
Public | RasterPos4s: procedure(X, y, z, w: TGLshort); stdcall;
Public | RasterPos4sv: procedure(v: PGLshort); stdcall;
Public | Rectd: procedure(x1, y1, x2, y2: TGLdouble); stdcall;
Public | Rectdv: procedure(v1, v2: PGLdouble); stdcall;
Public | Rectf: procedure(x1, y1, x2, y2: TGLfloat); stdcall;
Public | Rectfv: procedure(v1, v2: PGLfloat); stdcall;
Public | Recti: procedure(x1, y1, x2, y2: TGLint); stdcall;
Public | Rectiv: procedure(v1, v2: PGLint); stdcall;
Public | Rects: procedure(x1, y1, x2, y2: TGLshort); stdcall;
Public | Rectsv: procedure(v1, v2: PGLshort); stdcall;
Public | RenderMode: function(mode: TGLEnum): TGLint; stdcall;
Public | Rotated: procedure(ane, X, y, z: TGLdouble); stdcall;
Public | Rotatef: procedure(ane, X, y, z: TGLfloat); stdcall;
Public | Scaled: procedure(X, y, z: TGLdouble); stdcall;
Public | Scalef: procedure(X, y, z: TGLfloat); stdcall;
Public | SelectBuffer: procedure(size: TGLsizei; buffer: PGLuint); stdcall;
Public | ShadeModel: procedure(mode: TGLEnum); stdcall;
Public | TexCoord1d: procedure(s: TGLdouble); stdcall;
Public | TexCoord1dv: procedure(v: PGLdouble); stdcall;
Public | TexCoord1f: procedure(s: TGLfloat); stdcall;
Public | TexCoord1fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord1i: procedure(s: TGLint); stdcall;
Public | TexCoord1iv: procedure(v: PGLint); stdcall;
Public | TexCoord1s: procedure(s: TGLshort); stdcall;
Public | TexCoord1sv: procedure(v: PGLshort); stdcall;
Public | TexCoord2d: procedure(s, t: TGLdouble); stdcall;
Public | TexCoord2dv: procedure(v: PGLdouble); stdcall;
Public | TexCoord2f: procedure(s, t: TGLfloat); stdcall;
Public | TexCoord2fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord2i: procedure(s, t: TGLint); stdcall;
Public | TexCoord2iv: procedure(v: PGLint); stdcall;
Public | TexCoord2s: procedure(s, t: TGLshort); stdcall;
Public | TexCoord2sv: procedure(v: PGLshort); stdcall;
Public | TexCoord3d: procedure(s, t, r: TGLdouble); stdcall;
Public | TexCoord3dv: procedure(v: PGLdouble); stdcall;
Public | TexCoord3f: procedure(s, t, r: TGLfloat); stdcall;
Public | TexCoord3fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord3i: procedure(s, t, r: TGLint); stdcall;
Public | TexCoord3iv: procedure(v: PGLint); stdcall;
Public | TexCoord3s: procedure(s, t, r: TGLshort); stdcall;
Public | TexCoord3sv: procedure(v: PGLshort); stdcall;
Public | TexCoord4d: procedure(s, t, r, q: TGLdouble); stdcall;
Public | TexCoord4dv: procedure(v: PGLdouble); stdcall;
Public | TexCoord4f: procedure(s, t, r, q: TGLfloat); stdcall;
Public | TexCoord4fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord4i: procedure(s, t, r, q: TGLint); stdcall;
Public | TexCoord4iv: procedure(v: PGLint); stdcall;
Public | TexCoord4s: procedure(s, t, r, q: TGLshort); stdcall;
Public | TexCoord4sv: procedure(v: PGLshort); stdcall;
Public | TexCoordPointer: procedure(size: TGLint; atype: TGLEnum; stride: TGLsizei; Data: Pointer); stdcall;
Public | TexEnvf: procedure(target, pname: TGLEnum; param: TGLfloat); stdcall;
Public | TexEnvfv: procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;
Public | TexEnvi: procedure(target, pname: TGLEnum; param: TGLint); stdcall;
Public | TexEnviv: procedure(target, pname: TGLEnum; params: PGLint); stdcall;
Public | TexGend: procedure(coord, pname: TGLEnum; param: TGLdouble); stdcall;
Public | TexGendv: procedure(coord, pname: TGLEnum; params: PGLdouble); stdcall;
Public | TexGenf: procedure(coord, pname: TGLEnum; param: TGLfloat); stdcall;
Public | TexGenfv: procedure(coord, pname: TGLEnum; params: PGLfloat); stdcall;
Public | TexGeni: procedure(coord, pname: TGLEnum; param: TGLint); stdcall;
Public | TexGeniv: procedure(coord, pname: TGLEnum; params: PGLint); stdcall;
Public | Translated: procedure(X, y, z: TGLdouble); stdcall;
Public | Translatef: procedure(X, y, z: TGLfloat); stdcall;
Public | Vertex2d: procedure(X, y: TGLdouble); stdcall;
Public | Vertex2dv: procedure(v: PGLdouble); stdcall;
Public | Vertex2f: procedure(X, y: TGLfloat); stdcall;
Public | Vertex2fv: procedure(v: PGLfloat); stdcall;
Public | Vertex2i: procedure(X, y: TGLint); stdcall;
Public | Vertex2iv: procedure(v: PGLint); stdcall;
Public | Vertex2s: procedure(X, y: TGLshort); stdcall;
Public | Vertex2sv: procedure(v: PGLshort); stdcall;
Public | Vertex3d: procedure(X, y, z: TGLdouble); stdcall;
Public | Vertex3dv: procedure(v: PGLdouble); stdcall;
Public | Vertex3f: procedure(X, y, z: TGLfloat); stdcall;
Public | Vertex3fv: procedure(v: PGLfloat); stdcall;
Public | Vertex3i: procedure(X, y, z: TGLint); stdcall;
Public | Vertex3iv: procedure(v: PGLint); stdcall;
Public | Vertex3s: procedure(X, y, z: TGLshort); stdcall;
Public | Vertex3sv: procedure(v: PGLshort); stdcall;
Public | Vertex4d: procedure(X, y, z, w: TGLdouble); stdcall;
Public | Vertex4dv: procedure(v: PGLdouble); stdcall;
Public | Vertex4f: procedure(X, y, z, w: TGLfloat); stdcall;
Public | Vertex4fv: procedure(v: PGLfloat); stdcall;
Public | Vertex4i: procedure(X, y, z, w: TGLint); stdcall;
Public | Vertex4iv: procedure(v: PGLint); stdcall;
Public | Vertex4s: procedure(X, y, z, w: TGLshort); stdcall;
Public | Vertex4sv: procedure(v: PGLshort); stdcall;
Public | VertexPointer: procedure(size: TGLint; atype: TGLEnum; stride: TGLsizei; Data: Pointer); stdcall;
Public | BlendColor: PFNGLBLENDCOLORPROC;
Public | BlendEquation: PFNGLBLENDEQUATIONPROC;
Public | DrawRangeElements: PFNGLDRAWRANGEELEMENTSPROC;
Public | TexImage3D: PFNGLTEXIMAGE3DPROC;
Public | TexSubImage3D: PFNGLTEXSUBIMAGE3DPROC;
Public | CopyTexSubImage3D: PFNGLCOPYTEXSUBIMAGE3DPROC;
Public | BlendFuncSeparate: PFNGLBLENDFUNCSEPARATEPROC;
Public | MultiDrawArrays: PFNGLMULTIDRAWARRAYSPROC;
Public | MultiDrawElements: PFNGLMULTIDRAWELEMENTSPROC;
Public | PointParameterf: PFNGLPOINTPARAMETERFPROC;
Public | PointParameterfv: PFNGLPOINTPARAMETERFVPROC;
Public | PointParameteri: PFNGLPOINTPARAMETERIPROC;
Public | PointParameteriv: PFNGLPOINTPARAMETERIVPROC;
Public | BlendEquationSeparate: PFNGLBLENDEQUATIONSEPARATEPROC;
Public | DrawBuffers: PFNGLDRAWBUFFERSPROC;
Public | StencilOpSeparate: PFNGLSTENCILOPSEPARATEPROC;
Public | StencilFuncSeparate: PFNGLSTENCILFUNCSEPARATEPROC;
Public | StencilMaskSeparate: PFNGLSTENCILMASKSEPARATEPROC;
Public | LockArrays: PFNGLLOCKARRAYSEXTPROC;
Public | UnlockArrays: PFNGLUNLOCKARRAYSEXTPROC;
Public | BindBuffer: PFNGLBINDBUFFERPROC;
Public | DeleteBuffers: PFNGLDELETEBUFFERSPROC;
Public | GenBuffers: PFNGLGENBUFFERSPROC;
Public | IsBuffer: PFNGLISBUFFERPROC;
Public | BufferData: PFNGLBUFFERDATAPROC;
Public | BufferSubData: PFNGLBUFFERSUBDATAPROC;
Public | GetBufferSubData: PFNGLGETBUFFERSUBDATAPROC;
Public | MapBuffer: PFNGLMAPBUFFERPROC;
Public | UnmapBuffer: PFNGLUNMAPBUFFERPROC;
Public | GetBufferParameteriv: PFNGLGETBUFFERPARAMETERIVPROC;
Public | GetBufferPointerv: PFNGLGETBUFFERPOINTERVPROC;
Public | MapBufferRange: PFNGLMAPBUFFERRANGEPROC;
Public | FlushMappedBufferRange: PFNGLFLUSHMAPPEDBUFFERRANGEPROC;
Public | BindBufferRange: PFNGLBINDBUFFERRANGEPROC;
Public | BindBufferOffset: PFNGLBINDBUFFEROFFSETEXTPROC;
Public | BindBufferBase: PFNGLBINDBUFFERBASEPROC;
Public | TransformFeedbackAttribs: PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC;
Public | TransformFeedbackVaryingsNV: PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC;
Public | TransformFeedbackVaryings: PFNGLTRANSFORMFEEDBACKVARYINGSPROC;
Public | GetTransformFeedbackVarying: PFNGLGETTRANSFORMFEEDBACKVARYINGPROC;
Public | BeginTransformFeedback: PFNGLBEGINTRANSFORMFEEDBACKPROC;
Public | EndTransformFeedback: PFNGLENDTRANSFORMFEEDBACKPROC;
Public | TexBuffer: PFNGLTEXBUFFERPROC;
Public | ClearBufferiv: PFNGLCLEARBUFFERIVPROC;
Public | ClearBufferuiv: PFNGLCLEARBUFFERUIVPROC;
Public | ClearBufferfv: PFNGLCLEARBUFFERFVPROC;
Public | ClearBufferfi: PFNGLCLEARBUFFERFIPROC;
Public | GetStringi: PFNGLGETSTRINGIPROC;
Public | BindVertexArray: PFNGLBINDVERTEXARRAYPROC;
Public | DeleteVertexArrays: PFNGLDELETEVERTEXARRAYSPROC;
Public | GenVertexArrays: PFNGLGENVERTEXARRAYSPROC;
Public | IsVertexArray: PFNGLISVERTEXARRAYPROC;
Public | FlushVertexArrayRangeNV: PFNGLFLUSHVERTEXARRAYRANGENVPROC;
Public | VertexArrayRangeNV: PFNGLVERTEXARRAYRANGENVPROC;
Public | GetUniformIndices: PFNGLGETUNIFORMINDICESPROC;
Public | GetActiveUniformsiv: PFNGLGETACTIVEUNIFORMSIVPROC;
Public | GetActiveUniformName: PFNGLGETACTIVEUNIFORMNAMEPROC;
Public | GetUniformBlockIndex: PFNGLGETUNIFORMBLOCKINDEXPROC;
Public | GetActiveUniformBlockiv: PFNGLGETACTIVEUNIFORMBLOCKIVPROC;
Public | GetActiveUniformBlockName: PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC;
Public | UniformBlockBinding: PFNGLUNIFORMBLOCKBINDINGPROC;
Public | CopyBufferSubData: PFNGLCOPYBUFFERSUBDATAPROC;
Public | UniformBuffer: PFNGLUNIFORMBUFFEREXTPROC;
Public | GetUniformBufferSize: PFNGLGETUNIFORMBUFFERSIZEEXTPROC;
Public | GetUniformOffset: PFNGLGETUNIFORMOFFSETEXTPROC;
Public | PrimitiveRestartIndex: PFNGLPRIMITIVERESTARTINDEXPROC;
Public | DrawElementsBaseVertex: PFNGLDRAWELEMENTSBASEVERTEXPROC;
Public | DrawRangeElementsBaseVertex: PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC;
Public | DrawElementsInstancedBaseVertex: PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC;
Public | MultiDrawElementsBaseVertex: PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC;
Public | DrawArraysInstanced: PFNGLDRAWARRAYSINSTANCEDPROC;
Public | DrawElementsInstanced: PFNGLDRAWELEMENTSINSTANCEDPROC;
Public | VertexAttrib1d: PFNGLVERTEXATTRIB1DPROC;
Public | VertexAttrib1dv: PFNGLVERTEXATTRIB1DVPROC;
Public | VertexAttrib1f: PFNGLVERTEXATTRIB1FPROC;
Public | VertexAttrib1fv: PFNGLVERTEXATTRIB1FVPROC;
Public | VertexAttrib1s: PFNGLVERTEXATTRIB1SPROC;
Public | VertexAttrib1sv: PFNGLVERTEXATTRIB1SVPROC;
Public | VertexAttrib2d: PFNGLVERTEXATTRIB2DPROC;
Public | VertexAttrib2dv: PFNGLVERTEXATTRIB2DVPROC;
Public | VertexAttrib2f: PFNGLVERTEXATTRIB2FPROC;
Public | VertexAttrib2fv: PFNGLVERTEXATTRIB2FVPROC;
Public | VertexAttrib2s: PFNGLVERTEXATTRIB2SPROC;
Public | VertexAttrib2sv: PFNGLVERTEXATTRIB2SVPROC;
Public | VertexAttrib3d: PFNGLVERTEXATTRIB3DPROC;
Public | VertexAttrib3dv: PFNGLVERTEXATTRIB3DVPROC;
Public | VertexAttrib3f: PFNGLVERTEXATTRIB3FPROC;
Public | VertexAttrib3fv: PFNGLVERTEXATTRIB3FVPROC;
Public | VertexAttrib3s: PFNGLVERTEXATTRIB3SPROC;
Public | VertexAttrib3sv: PFNGLVERTEXATTRIB3SVPROC;
Public | VertexAttrib4Nbv: PFNGLVERTEXATTRIB4NBVPROC;
Public | VertexAttrib4Niv: PFNGLVERTEXATTRIB4NIVPROC;
Public | VertexAttrib4Nsv: PFNGLVERTEXATTRIB4NSVPROC;
Public | VertexAttrib4Nub: PFNGLVERTEXATTRIB4NUBPROC;
Public | VertexAttrib4Nubv: PFNGLVERTEXATTRIB4NUBVPROC;
Public | VertexAttrib4Nuiv: PFNGLVERTEXATTRIB4NUIVPROC;
Public | VertexAttrib4Nusv: PFNGLVERTEXATTRIB4NUSVPROC;
Public | VertexAttrib4bv: PFNGLVERTEXATTRIB4BVPROC;
Public | VertexAttrib4d: PFNGLVERTEXATTRIB4DPROC;
Public | VertexAttrib4dv: PFNGLVERTEXATTRIB4DVPROC;
Public | VertexAttrib4f: PFNGLVERTEXATTRIB4FPROC;
Public | VertexAttrib4fv: PFNGLVERTEXATTRIB4FVPROC;
Public | VertexAttrib4iv: PFNGLVERTEXATTRIB4IVPROC;
Public | VertexAttrib4s: PFNGLVERTEXATTRIB4SPROC;
Public | VertexAttrib4sv: PFNGLVERTEXATTRIB4SVPROC;
Public | VertexAttrib4ubv: PFNGLVERTEXATTRIB4UBVPROC;
Public | VertexAttrib4uiv: PFNGLVERTEXATTRIB4UIVPROC;
Public | VertexAttrib4usv: PFNGLVERTEXATTRIB4USVPROC;
Public | VertexAttribPointer: PFNGLVERTEXATTRIBPOINTERPROC;
Public | VertexAttribI1i: PFNGLVERTEXATTRIBI1IPROC;
Public | VertexAttribI2i: PFNGLVERTEXATTRIBI2IPROC;
Public | VertexAttribI3i: PFNGLVERTEXATTRIBI3IPROC;
Public | VertexAttribI4i: PFNGLVERTEXATTRIBI4IPROC;
Public | VertexAttribI1ui: PFNGLVERTEXATTRIBI1UIPROC;
Public | VertexAttribI2ui: PFNGLVERTEXATTRIBI2UIPROC;
Public | VertexAttribI3ui: PFNGLVERTEXATTRIBI3UIPROC;
Public | VertexAttribI4ui: PFNGLVERTEXATTRIBI4UIPROC;
Public | VertexAttribI1iv: PFNGLVERTEXATTRIBI1IVPROC;
Public | VertexAttribI2iv: PFNGLVERTEXATTRIBI2IVPROC;
Public | VertexAttribI3iv: PFNGLVERTEXATTRIBI3IVPROC;
Public | VertexAttribI4iv: PFNGLVERTEXATTRIBI4IVPROC;
Public | VertexAttribI1uiv: PFNGLVERTEXATTRIBI1UIVPROC;
Public | VertexAttribI2uiv: PFNGLVERTEXATTRIBI2UIVPROC;
Public | VertexAttribI3uiv: PFNGLVERTEXATTRIBI3UIVPROC;
Public | VertexAttribI4uiv: PFNGLVERTEXATTRIBI4UIVPROC;
Public | VertexAttribI4bv: PFNGLVERTEXATTRIBI4BVPROC;
Public | VertexAttribI4sv: PFNGLVERTEXATTRIBI4SVPROC;
Public | VertexAttribI4ubv: PFNGLVERTEXATTRIBI4UBVPROC;
Public | VertexAttribI4usv: PFNGLVERTEXATTRIBI4USVPROC;
Public | VertexAttribIPointer: PFNGLVERTEXATTRIBIPOINTERPROC;
Public | GetVertexAttribIiv: PFNGLGETVERTEXATTRIBIIVPROC;
Public | GetVertexAttribIuiv: PFNGLGETVERTEXATTRIBIUIVPROC;
Public | Uniform1ui: PFNGLUNIFORM1UIPROC;
Public | Uniform2ui: PFNGLUNIFORM2UIPROC;
Public | Uniform3ui: PFNGLUNIFORM3UIPROC;
Public | Uniform4ui: PFNGLUNIFORM4UIPROC;
Public | Uniform1uiv: PFNGLUNIFORM1UIVPROC;
Public | Uniform2uiv: PFNGLUNIFORM2UIVPROC;
Public | Uniform3uiv: PFNGLUNIFORM3UIVPROC;
Public | Uniform4uiv: PFNGLUNIFORM4UIVPROC;
Public | GetUniformuiv: PFNGLGETUNIFORMUIVPROC;
Public | BindFragDataLocation: PFNGLBINDFRAGDATALOCATIONPROC;
Public | GetFragDataLocation: PFNGLGETFRAGDATALOCATIONPROC;
Public | ClampColor: PFNGLCLAMPCOLORPROC;
Public | ColorMaski: PFNGLCOLORMASKIPROC;
Public | GetBooleani_v: PFNGLGETBOOLEANI_VPROC;
Public | GetIntegeri_v: PFNGLGETINTEGERI_VPROC;
Public | Enablei: PFNGLENABLEIPROC;
Public | Disablei: PFNGLDISABLEIPROC;
Public | IsEnabledi: PFNGLISENABLEDIPROC;
Public | EnableVertexAttribArray: PFNGLENABLEVERTEXATTRIBARRAYPROC;
Public | DisableVertexAttribArray: PFNGLDISABLEVERTEXATTRIBARRAYPROC;
Public | VertexAttribDivisor: PFNGLVERTEXATTRIBDIVISORPROC;
Public | ClearColorIi: PFNGLCLEARCOLORIIEXTPROC;
Public | ClearColorIui: PFNGLCLEARCOLORIUIEXTPROC;
Public | TexParameterIiv: PFNGLTEXPARAMETERIIVPROC;
Public | TexParameterIuiv: PFNGLTEXPARAMETERIUIVPROC;
Public | GetTexParameterIiv: PFNGLGETTEXPARAMETERIIVPROC;
Public | GetTexParameterIuiv: PFNGLGETTEXPARAMETERIUIVPROC;
Public | PatchParameteri: PFNGLPATCHPARAMETERIPROC;
Public | PatchParameterfv: PFNGLPATCHPARAMETERFVPROC;
Public | BufferAddressRangeNV: PFNGLBUFFERADDRESSRANGENVPROC;
Public | VertexFormatNV: PFNGLVERTEXFORMATNVPROC;
Public | NormalFormatNV: PFNGLNORMALFORMATNVPROC;
Public | ColorFormatNV: PFNGLCOLORFORMATNVPROC;
Public | IndexFormatNV: PFNGLINDEXFORMATNVPROC;
Public | TexCoordFormatNV: PFNGLTEXCOORDFORMATNVPROC;
Public | EdgeFlagFormatNV: PFNGLEDGEFLAGFORMATNVPROC;
Public | SecondaryColorFormatNV: PFNGLSECONDARYCOLORFORMATNVPROC;
Public | FogCoordFormatNV: PFNGLFOGCOORDFORMATNVPROC;
Public | VertexAttribFormatNV: PFNGLVERTEXATTRIBFORMATNVPROC;
Public | VertexAttribIFormatNV: PFNGLVERTEXATTRIBIFORMATNVPROC;
Public | GetIntegerui64i_vNV: PFNGLGETINTEGERUI64I_VNVPROC;
Public | GetBufferParameterui64vNV: PGNGLGETBUFFERPARAMETERUI64VNV;
Public | MakeBufferResidentNV: PFNGLMAKEBUFFERRESIDENTNVPROC;
Public | MakeBufferNonResidentNV: PFNGLMAKEBUFFERNONRESIDENTNVPROC;
Public | IsBufferResidentNV: PFNGLISBUFFERRESIDENTNVPROC;
Public | MakeNamedBufferResidentNV: PFNGLMAKENAMEDBUFFERRESIDENTNVPROC;
Public | MakeNamedBufferNonResidentNV: PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC;
Public | IsNamedBufferResidentNV: PFNGLISNAMEDBUFFERRESIDENTNVPROC;
Public | GetNamedBufferParameterui64vNV: PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC;
Public | GetIntegerui64vNV: PFNGLGETINTEGERUI64VNVPROC;
Public | Uniformui64NV: PFNGLUNIFORMUI64NVPROC;
Public | Uniformui64vNV: PFNGLUNIFORMUI64VNVPROC;
Public | GetUniformui64vNV: PFNGLGETUNIFORMUI64VNVPROC;
Public | ProgramUniformui64NV: PFNGLPROGRAMUNIFORMUI64NVPROC;
Public | ProgramUniformui64vNV: PFNGLPROGRAMUNIFORMUI64VNVPROC;
Public | DeleteObject: PFNGLDELETEOBJECTARBPROC;
Public | GetHandle: PFNGLGETHANDLEARBPROC;
Public | DetachShader: PFNGLDETACHSHADERPROC;
Public | CreateShader: PFNGLCREATESHADERPROC;
Public | ShaderSource: PFNGLSHADERSOURCEPROC;
Public | CompileShader: PFNGLCOMPILESHADERPROC;
Public | CreateProgram: PFNGLCREATEPROGRAMPROC;
Public | AttachShader: PFNGLATTACHSHADERPROC;
Public | LinkProgram: PFNGLLINKPROGRAMPROC;
Public | UseProgram: PFNGLUSEPROGRAMPROC;
Public | ValidateProgram: PFNGLVALIDATEPROGRAMPROC;
Public | Uniform1f: PFNGLUNIFORM1FPROC;
Public | Uniform2f: PFNGLUNIFORM2FPROC;
Public | Uniform3f: PFNGLUNIFORM3FPROC;
Public | Uniform4f: PFNGLUNIFORM4FPROC;
Public | Uniform1i: PFNGLUNIFORM1IPROC;
Public | Uniform2i: PFNGLUNIFORM2IPROC;
Public | Uniform3i: PFNGLUNIFORM3IPROC;
Public | Uniform4i: PFNGLUNIFORM4IPROC;
Public | Uniform1fv: PFNGLUNIFORM1FVPROC;
Public | Uniform2fv: PFNGLUNIFORM2FVPROC;
Public | Uniform3fv: PFNGLUNIFORM3FVPROC;
Public | Uniform4fv: PFNGLUNIFORM4FVPROC;
Public | Uniform1iv: PFNGLUNIFORM1IVPROC;
Public | Uniform2iv: PFNGLUNIFORM2IVPROC;
Public | Uniform3iv: PFNGLUNIFORM3IVPROC;
Public | Uniform4iv: PFNGLUNIFORM4IVPROC;
Public | UniformMatrix2fv: PFNGLUNIFORMMATRIX2FVPROC;
Public | UniformMatrix3fv: PFNGLUNIFORMMATRIX3FVPROC;
Public | UniformMatrix4fv: PFNGLUNIFORMMATRIX4FVPROC;
Public | GetObjectParameterfv: PFNGLGETOBJECTPARAMETERFVARBPROC;
Public | GetObjectParameteriv: PFNGLGETOBJECTPARAMETERIVARBPROC;
Public | GetInfoLog: PFNGLGETINFOLOGARBPROC;
Public | GetAttachedObjects: PFNGLGETATTACHEDOBJECTSARBPROC;
Public | GetActiveAttrib: PFNGLGETACTIVEATTRIBPROC;
Public | GetActiveUniform: PFNGLGETACTIVEUNIFORMPROC;
Public | GetAttachedShaders: PFNGLGETATTACHEDSHADERSPROC;
Public | GetAttribLocation: PFNGLGETATTRIBLOCATIONPROC;
Public | GetProgramiv: PFNGLGETPROGRAMIVPROC;
Public | GetProgramInfoLog: PFNGLGETPROGRAMINFOLOGPROC;
Public | GetShaderiv: PFNGLGETSHADERIVPROC;
Public | GetShaderInfoLog: PFNGLGETSHADERINFOLOGPROC;
Public | GetShaderSource: PFNGLGETSHADERSOURCEPROC;
Public | GetUniformLocation: PFNGLGETUNIFORMLOCATIONPROC;
Public | GetUniformfv: PFNGLGETUNIFORMFVPROC;
Public | GetUniformiv: PFNGLGETUNIFORMIVPROC;
Public | GetVertexAttribdv: PFNGLGETVERTEXATTRIBDVPROC;
Public | GetVertexAttribfv: PFNGLGETVERTEXATTRIBFVPROC;
Public | GetVertexAttribiv: PFNGLGETVERTEXATTRIBIVPROC;
Public | GetVertexAttribPointerv: PFNGLGETVERTEXATTRIBPOINTERVPROC;
Public | IsProgram: PFNGLISPROGRAMPROC;
Public | IsShader: PFNGLISSHADERPROC;
Public | BindAttribLocation: PFNGLBINDATTRIBLOCATIONPROC;
Public | BindFragDataLocationIndexed: PFNGLBINDFRAGDATALOCATIONINDEXEDPROC;
Public | GetFragDataIndex: PFNGLGETFRAGDATAINDEXPROC;
Public | GetVaryingLocation: PFNGLGETVARYINGLOCATIONNVPROC;
Public | GetActiveVarying: PFNGLGETACTIVEVARYINGNVPROC;
Public | ActiveVarying: PFNGLACTIVEVARYINGNVPROC;
Public | GetProgramBinary: PFNGLGETPROGRAMBINARYPROC;
Public | ProgramBinary: PFNGLPROGRAMBINARYPROC;
Public | UseProgramStages: PFNGLUSEPROGRAMSTAGESPROC;
Public | ActiveShaderProgram: PFNGLACTIVESHADERPROGRAMPROC;
Public | CreateShaderProgramv: PFNGLCREATESHADERPROGRAMVPROC;
Public | BindProgramPipeline: PFNGLBINDPROGRAMPIPELINEPROC;
Public | DeleteProgramPipelines: PFNGLDELETEPROGRAMPIPELINESPROC;
Public | GenProgramPipelines: PFNGLGENPROGRAMPIPELINESPROC;
Public | IsProgramPipeline: PFNGLISPROGRAMPIPELINEPROC;
Public | GetProgramPipelineiv: PFNGLGETPROGRAMPIPELINEIVPROC;
Public | ProgramUniform1i: PFNGLPROGRAMUNIFORM1IPROC;
Public | ProgramUniform1iv: PFNGLPROGRAMUNIFORM1IVPROC;
Public | ProgramUniform1f: PFNGLPROGRAMUNIFORM1FPROC;
Public | ProgramUniform1fv: PFNGLPROGRAMUNIFORM1FVPROC;
Public | ProgramUniform1d: PFNGLPROGRAMUNIFORM1DPROC;
Public | ProgramUniform1dv: PFNGLPROGRAMUNIFORM1DVPROC;
Public | ProgramUniform1ui: PFNGLPROGRAMUNIFORM1UIPROC;
Public | ProgramUniform1uiv: PFNGLPROGRAMUNIFORM1UIVPROC;
Public | ProgramUniform2i: PFNGLPROGRAMUNIFORM2IPROC;
Public | ProgramUniform2iv: PFNGLPROGRAMUNIFORM2IVPROC;
Public | ProgramUniform2f: PFNGLPROGRAMUNIFORM2FPROC;
Public | ProgramUniform2fv: PFNGLPROGRAMUNIFORM2FVPROC;
Public | ProgramUniform2d: PFNGLPROGRAMUNIFORM2DPROC;
Public | ProgramUniform2dv: PFNGLPROGRAMUNIFORM2DVPROC;
Public | ProgramUniform2ui: PFNGLPROGRAMUNIFORM2UIPROC;
Public | ProgramUniform2uiv: PFNGLPROGRAMUNIFORM2UIVPROC;
Public | ProgramUniform3i: PFNGLPROGRAMUNIFORM3IPROC;
Public | ProgramUniform3iv: PFNGLPROGRAMUNIFORM3IVPROC;
Public | ProgramUniform3f: PFNGLPROGRAMUNIFORM3FPROC;
Public | ProgramUniform3fv: PFNGLPROGRAMUNIFORM3FVPROC;
Public | ProgramUniform3d: PFNGLPROGRAMUNIFORM3DPROC;
Public | ProgramUniform3dv: PFNGLPROGRAMUNIFORM3DVPROC;
Public | ProgramUniform3ui: PFNGLPROGRAMUNIFORM3UIPROC;
Public | ProgramUniform3uiv: PFNGLPROGRAMUNIFORM3UIVPROC;
Public | ProgramUniform4i: PFNGLPROGRAMUNIFORM4IPROC;
Public | ProgramUniform4iv: PFNGLPROGRAMUNIFORM4IVPROC;
Public | ProgramUniform4f: PFNGLPROGRAMUNIFORM4FPROC;
Public | ProgramUniform4fv: PFNGLPROGRAMUNIFORM4FVPROC;
Public | ProgramUniform4d: PFNGLPROGRAMUNIFORM4DPROC;
Public | ProgramUniform4dv: PFNGLPROGRAMUNIFORM4DVPROC;
Public | ProgramUniform4ui: PFNGLPROGRAMUNIFORM4UIPROC;
Public | ProgramUniform4uiv: PFNGLPROGRAMUNIFORM4UIVPROC;
Public | ProgramUniformMatrix2fv: PFNGLPROGRAMUNIFORMMATRIX2FVPROC;
Public | ProgramUniformMatrix3fv: PFNGLPROGRAMUNIFORMMATRIX3FVPROC;
Public | ProgramUniformMatrix4fv: PFNGLPROGRAMUNIFORMMATRIX4FVPROC;
Public | ProgramUniformMatrix2dv: PFNGLPROGRAMUNIFORMMATRIX2DVPROC;
Public | ProgramUniformMatrix3dv: PFNGLPROGRAMUNIFORMMATRIX3DVPROC;
Public | ProgramUniformMatrix4dv: PFNGLPROGRAMUNIFORMMATRIX4DVPROC;
Public | ProgramUniformMatrix2x3fv: PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC;
Public | ProgramUniformMatrix3x2fv: PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC;
Public | ProgramUniformMatrix2x4fv: PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC;
Public | ProgramUniformMatrix4x2fv: PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC;
Public | ProgramUniformMatrix3x4fv: PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC;
Public | ProgramUniformMatrix4x3fv: PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC;
Public | ProgramUniformMatrix2x3dv: PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC;
Public | ProgramUniformMatrix3x2dv: PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC;
Public | ProgramUniformMatrix2x4dv: PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC;
Public | ProgramUniformMatrix4x2dv: PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC;
Public | ProgramUniformMatrix3x4dv: PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC;
Public | ProgramUniformMatrix4x3dv: PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC;
Public | ValidateProgramPipeline: PFNGLVALIDATEPROGRAMPIPELINEPROC;
Public | GetProgramPipelineInfoLog: PFNGLGETPROGRAMPIPELINEINFOLOGPROC;
Public | IsRenderbuffer: PFNGLISRENDERBUFFERPROC;
Public | BindRenderbuffer: PFNGLBINDRENDERBUFFERPROC;
Public | DeleteRenderbuffers: PFNGLDELETERENDERBUFFERSPROC;
Public | GenRenderbuffers: PFNGLGENRENDERBUFFERSPROC;
Public | RenderbufferStorage: PFNGLRENDERBUFFERSTORAGEPROC;
Public | RenderbufferStorageMultisample: PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC;
Public | GetRenderbufferParameteriv: PFNGLGETRENDERBUFFERPARAMETERIVPROC;
Public | IsFramebuffer: PFNGLISFRAMEBUFFERPROC;
Public | BindFramebuffer: PFNGLBINDFRAMEBUFFERPROC;
Public | DeleteFramebuffers: PFNGLDELETEFRAMEBUFFERSPROC;
Public | GenFramebuffers: PFNGLGENFRAMEBUFFERSPROC;
Public | CheckFramebufferStatus: PFNGLCHECKFRAMEBUFFERSTATUSPROC;
Public | FramebufferTexture: PFNGLFRAMEBUFFERTEXTUREPROC;
Public | FramebufferTexture1D: PFNGLFRAMEBUFFERTEXTURE1DPROC;
Public | FramebufferTexture2D: PFNGLFRAMEBUFFERTEXTURE2DPROC;
Public | FramebufferTexture3D: PFNGLFRAMEBUFFERTEXTURE3DPROC;
Public | FramebufferTextureLayer: PFNGLFRAMEBUFFERTEXTURELAYERPROC;
Public | FramebufferTextureFace: PFNGLFRAMEBUFFERTEXTUREFACEARBPROC;
Public | FramebufferRenderbuffer: PFNGLFRAMEBUFFERRENDERBUFFERPROC;
Public | GetFramebufferAttachmentParameteriv: PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC;
Public | BlitFramebuffer: PFNGLBLITFRAMEBUFFERPROC;
Public | GenerateMipmap: PFNGLGENERATEMIPMAPPROC;
Public | GenQueries: PFNGLGENQUERIESPROC;
Public | DeleteQueries: PFNGLDELETEQUERIESPROC;
Public | IsQuery: PFNGLISQUERYPROC;
Public | BeginQuery: PFNGLBEGINQUERYPROC;
Public | EndQuery: PFNGLENDQUERYPROC;
Public | GetQueryiv: PFNGLGETQUERYIVPROC;
Public | GetQueryObjectiv: PFNGLGETQUERYOBJECTIVPROC;
Public | GetQueryObjectuiv: PFNGLGETQUERYOBJECTUIVPROC;
Public | QueryCounter: PFNGLQUERYCOUNTERPROC;
Public | GetQueryObjecti64v: PFNGLGETQUERYOBJECTI64VPROC;
Public | GetQueryObjectui64v: PFNGLGETQUERYOBJECTUI64VPROC;
Public | ActiveTexture: PFNGLACTIVETEXTUREPROC;
Public | SampleCoverage: PFNGLSAMPLECOVERAGEPROC;
Public | CompressedTexImage3D: PFNGLCOMPRESSEDTEXIMAGE3DPROC;
Public | CompressedTexImage2D: PFNGLCOMPRESSEDTEXIMAGE2DPROC;
Public | CompressedTexImage1D: PFNGLCOMPRESSEDTEXIMAGE1DPROC;
Public | CompressedTexSubImage3D: PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC;
Public | CompressedTexSubImage2D: PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC;
Public | CompressedTexSubImage1D: PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC;
Public | GetCompressedTexImage: PFNGLGETCOMPRESSEDTEXIMAGEPROC;
Public | ClientActiveTexture: PFNGLCLIENTACTIVETEXTUREPROC;
Public | MultiTexCoord1d: PFNGLMULTITEXCOORD1DPROC;
Public | MultiTexCoord1dV: PFNGLMULTITEXCOORD1DVPROC;
Public | MultiTexCoord1f: PFNGLMULTITEXCOORD1FPROC;
Public | MultiTexCoord1fv: PFNGLMULTITEXCOORD1FVPROC;
Public | MultiTexCoord1i: PFNGLMULTITEXCOORD1IPROC;
Public | MultiTexCoord1iv: PFNGLMULTITEXCOORD1IVPROC;
Public | MultiTexCoord1s: PFNGLMULTITEXCOORD1SPROC;
Public | MultiTexCoord1sv: PFNGLMULTITEXCOORD1SVPROC;
Public | MultiTexCoord2d: PFNGLMULTITEXCOORD2DPROC;
Public | MultiTexCoord2dv: PFNGLMULTITEXCOORD2DVPROC;
Public | MultiTexCoord2f: PFNGLMULTITEXCOORD2FPROC;
Public | MultiTexCoord2fv: PFNGLMULTITEXCOORD2FVPROC;
Public | MultiTexCoord2i: PFNGLMULTITEXCOORD2IPROC;
Public | MultiTexCoord2iv: PFNGLMULTITEXCOORD2IVPROC;
Public | MultiTexCoord2s: PFNGLMULTITEXCOORD2SPROC;
Public | MultiTexCoord2sv: PFNGLMULTITEXCOORD2SVPROC;
Public | MultiTexCoord3d: PFNGLMULTITEXCOORD3DPROC;
Public | MultiTexCoord3dv: PFNGLMULTITEXCOORD3DVPROC;
Public | MultiTexCoord3f: PFNGLMULTITEXCOORD3FPROC;
Public | MultiTexCoord3fv: PFNGLMULTITEXCOORD3FVPROC;
Public | MultiTexCoord3i: PFNGLMULTITEXCOORD3IPROC;
Public | MultiTexCoord3iv: PFNGLMULTITEXCOORD3IVPROC;
Public | MultiTexCoord3s: PFNGLMULTITEXCOORD3SPROC;
Public | MultiTexCoord3sv: PFNGLMULTITEXCOORD3SVPROC;
Public | MultiTexCoord4d: PFNGLMULTITEXCOORD4DPROC;
Public | MultiTexCoord4dv: PFNGLMULTITEXCOORD4DVPROC;
Public | MultiTexCoord4f: PFNGLMULTITEXCOORD4FPROC;
Public | MultiTexCoord4fv: PFNGLMULTITEXCOORD4FVPROC;
Public | MultiTexCoord4i: PFNGLMULTITEXCOORD4IPROC;
Public | MultiTexCoord4iv: PFNGLMULTITEXCOORD4IVPROC;
Public | MultiTexCoord4s: PFNGLMULTITEXCOORD4SPROC;
Public | MultiTexCoord4sv: PFNGLMULTITEXCOORD4SVPROC;
Public | GetInteger64i_v: PFNGLGETINTEGER64I_VPROC;
Public | GetBufferParameteri64v: PFNGLGETBUFFERPARAMETERI64VPROC;
Public | ProgramParameteri: PFNGLPROGRAMPARAMETERIPROC;
Public | ProgramString: PFNGLPROGRAMSTRINGARBPROC;
Public | BindProgram: PFNGLBINDPROGRAMARBPROC;
Public | DeletePrograms: PFNGLDELETEPROGRAMSARBPROC;
Public | GenPrograms: PFNGLGENPROGRAMSARBPROC;
Public | ProgramEnvParameter4d: PFNGLPROGRAMENVPARAMETER4DARBPROC;
Public | ProgramEnvParameter4dv: PFNGLPROGRAMENVPARAMETER4DVARBPROC;
Public | ProgramEnvParameter4f: PFNGLPROGRAMENVPARAMETER4FARBPROC;
Public | ProgramEnvParameter4fv: PFNGLPROGRAMENVPARAMETER4FVARBPROC;
Public | ProgramLocalParameter4d: PFNGLPROGRAMLOCALPARAMETER4DARBPROC;
Public | ProgramLocalParameter4dv: PFNGLPROGRAMLOCALPARAMETER4DVARBPROC;
Public | ProgramLocalParameter4f: PFNGLPROGRAMLOCALPARAMETER4FARBPROC;
Public | ProgramLocalParameter4fv: PFNGLPROGRAMLOCALPARAMETER4FVARBPROC;
Public | GetProgramEnvParameterdv: PFNGLGETPROGRAMENVPARAMETERDVARBPROC;
Public | GetProgramEnvParameterfv: PFNGLGETPROGRAMENVPARAMETERFVARBPROC;
Public | GetProgramLocalParameterdv: PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC;
Public | GetProgramLocalParameterfv: PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC;
Public | TexImage2DMultisample: PFNGLTEXIMAGE2DMULTISAMPLEPROC;
Public | TexImage3DMultisample: PFNGLTEXIMAGE3DMULTISAMPLEPROC;
Public | GetMultisamplefv: PFNGLGETMULTISAMPLEFVPROC;
Public | SampleMaski: PFNGLSAMPLEMASKIPROC;
Public | ProvokingVertex: PFNGLPROVOKINGVERTEXPROC;
Public | FenceSync: PFNGLFENCESYNCPROC;
Public | IsSync: PFNGLISSYNCPROC;
Public | DeleteSync: PFNGLDELETESYNCPROC;
Public | ClientWaitSync: PFNGLCLIENTWAITSYNCPROC;
Public | WaitSync: PFNGLWAITSYNCPROC;
Public | GetInteger64v: PFNGLGETINTEGER64VPROC;
Public | GetSynciv: PFNGLGETSYNCIVPROC;
Public | BlendEquationi: PFNGLBLENDEQUATIONIPROC;
Public | BlendEquationSeparatei: PFNGLBLENDEQUATIONSEPARATEIPROC;
Public | BlendFunci: PFNGLBLENDFUNCIPROC;
Public | BlendFuncSeparatei: PFNGLBLENDFUNCSEPARATEIPROC;
Public | MinSampleShading: PFNGLMINSAMPLESHADINGPROC;
Public | GenSamplers: PFNGLGENSAMPLERSPROC;
Public | DeleteSamplers: PFNGLDELETESAMPLERSPROC;
Public | IsSampler: PFNGLISSAMPLERPROC;
Public | BindSampler: PFNGLBINDSAMPLERPROC;
Public | SamplerParameteri: PFNGLSAMPLERPARAMETERIPROC;
Public | SamplerParameteriv: PFNGLSAMPLERPARAMETERIVPROC;
Public | SamplerParameterf: PFNGLSAMPLERPARAMETERFPROC;
Public | SamplerParameterfv: PFNGLSAMPLERPARAMETERFVPROC;
Public | SamplerParameterIiv: PFNGLSAMPLERPARAMETERIIVPROC;
Public | SamplerParameterIuiv: PFNGLSAMPLERPARAMETERIUIVPROC;
Public | GetSamplerParameteriv: PFNGLGETSAMPLERPARAMETERIVPROC;
Public | GetSamplerParameterIiv: PFNGLGETSAMPLERPARAMETERIIVPROC;
Public | GetSamplerParameterfv: PFNGLGETSAMPLERPARAMETERFVPROC;
Public | GetSamplerParameterIfv: PFNGLGETSAMPLERPARAMETERIFVPROC;
Public | ClientAttribDefault: PFNGLCLIENTATTRIBDEFAULTEXTPROC;
Public | PushClientAttribDefault: PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC;
Public | MatrixLoadf: PFNGLMATRIXLOADFEXTPROC;
Public | MatrixLoadd: PFNGLMATRIXLOADDEXTPROC;
Public | MatrixMultf: PFNGLMATRIXMULTFEXTPROC;
Public | MatrixMultd: PFNGLMATRIXMULTDEXTPROC;
Public | MatrixLoadIdentity: PFNGLMATRIXLOADIDENTITYEXTPROC;
Public | MatrixRotatef: PFNGLMATRIXROTATEFEXTPROC;
Public | MatrixRotated: PFNGLMATRIXROTATEDEXTPROC;
Public | MatrixScalef: PFNGLMATRIXSCALEFEXTPROC;
Public | MatrixScaled: PFNGLMATRIXSCALEDEXTPROC;
Public | MatrixTranslatef: PFNGLMATRIXTRANSLATEFEXTPROC;
Public | MatrixTranslated: PFNGLMATRIXTRANSLATEDEXTPROC;
Public | MatrixFrustum: PFNGLMATRIXFRUSTUMEXTPROC;
Public | MatrixOrtho: PFNGLMATRIXORTHOEXTPROC;
Public | MatrixPop: PFNGLMATRIXPOPEXTPROC;
Public | MatrixPush: PFNGLMATRIXPUSHEXTPROC;
Public | MatrixLoadTransposef: PFNGLMATRIXLOADTRANSPOSEFEXTPROC;
Public | MatrixLoadTransposed: PFNGLMATRIXLOADTRANSPOSEDEXTPROC;
Public | MatrixMultTransposef: PFNGLMATRIXMULTTRANSPOSEFEXTPROC;
Public | MatrixMultTransposed: PFNGLMATRIXMULTTRANSPOSEDEXTPROC;
Public | TextureParameterf: PFNGLTEXTUREPARAMETERFEXTPROC;
Public | TextureParameterfv: PFNGLTEXTUREPARAMETERFVEXTPROC;
Public | TextureParameteri: PFNGLTEXTUREPARAMETERIEXTPROC;
Public | TextureParameteriv: PFNGLTEXTUREPARAMETERIVEXTPROC;
Public | TextureImage1D: PFNGLTEXTUREIMAGE1DEXTPROC;
Public | TextureImage2D: PFNGLTEXTUREIMAGE2DEXTPROC;
Public | TextureSubImage1D: PFNGLTEXTURESUBIMAGE1DEXTPROC;
Public | TextureSubImage2D: PFNGLTEXTURESUBIMAGE2DEXTPROC;
Public | CopyTextureImage1D: PFNGLCOPYTEXTUREIMAGE1DEXTPROC;
Public | CopyTextureImage2D: PFNGLCOPYTEXTUREIMAGE2DEXTPROC;
Public | CopyTextureSubImage1D: PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC;
Public | CopyTextureSubImage2D: PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC;
Public | GetTextureImage: PFNGLGETTEXTUREIMAGEEXTPROC;
Public | GetTextureParameterfv: PFNGLGETTEXTUREPARAMETERFVEXTPROC;
Public | GetTextureParameteriv: PFNGLGETTEXTUREPARAMETERIVEXTPROC;
Public | GetTextureLevelParameterfv: PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC;
Public | GetTextureLevelParameteriv: PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC;
Public | TextureImage3D: PFNGLTEXTUREIMAGE3DEXTPROC;
Public | TextureSubImage3D: PFNGLTEXTURESUBIMAGE3DEXTPROC;
Public | CopyTextureSubImage3D: PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC;
Public | MultiTexParameterf: PFNGLMULTITEXPARAMETERFEXTPROC;
Public | MultiTexParameterfv: PFNGLMULTITEXPARAMETERFVEXTPROC;
Public | MultiTexParameteri: PFNGLMULTITEXPARAMETERIEXTPROC;
Public | MultiTexParameteriv: PFNGLMULTITEXPARAMETERIVEXTPROC;
Public | MultiTexImage1D: PFNGLMULTITEXIMAGE1DEXTPROC;
Public | MultiTexImage2D: PFNGLMULTITEXIMAGE2DEXTPROC;
Public | MultiTexSubImage1D: PFNGLMULTITEXSUBIMAGE1DEXTPROC;
Public | MultiTexSubImage2D: PFNGLMULTITEXSUBIMAGE2DEXTPROC;
Public | CopyMultiTexImage1D: PFNGLCOPYMULTITEXIMAGE1DEXTPROC;
Public | CopyMultiTexImage2D: PFNGLCOPYMULTITEXIMAGE2DEXTPROC;
Public | CopyMultiTexSubImage1D: PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC;
Public | CopyMultiTexSubImage2D: PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC;
Public | GetMultiTexImage: PFNGLGETMULTITEXIMAGEEXTPROC;
Public | GetMultiTexParameterfv: PFNGLGETMULTITEXPARAMETERFVEXTPROC;
Public | GetMultiTexParameteriv: PFNGLGETMULTITEXPARAMETERIVEXTPROC;
Public | GetMultiTexLevelParameterfv: PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC;
Public | GetMultiTexLevelParameteriv: PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC;
Public | MultiTexImage3D: PFNGLMULTITEXIMAGE3DEXTPROC;
Public | MultiTexSubImage3D: PFNGLMULTITEXSUBIMAGE3DEXTPROC;
Public | CopyMultiTexSubImage3D: PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC;
Public | BindMultiTexture: PFNGLBINDMULTITEXTUREEXTPROC;
Public | EnableClientStateIndexed: PFNGLENABLECLIENTSTATEINDEXEDEXTPROC;
Public | DisableClientStateIndexed: PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC;
Public | MultiTexCoordPointer: PFNGLMULTITEXCOORDPOINTEREXTPROC;
Public | MultiTexEnvf: PFNGLMULTITEXENVFEXTPROC;
Public | MultiTexEnvfv: PFNGLMULTITEXENVFVEXTPROC;
Public | MultiTexEnvi: PFNGLMULTITEXENVIEXTPROC;
Public | MultiTexEnviv: PFNGLMULTITEXENVIVEXTPROC;
Public | MultiTexGend: PFNGLMULTITEXGENDEXTPROC;
Public | MultiTexGendv: PFNGLMULTITEXGENDVEXTPROC;
Public | MultiTexGenf: PFNGLMULTITEXGENFEXTPROC;
Public | MultiTexGenfv: PFNGLMULTITEXGENFVEXTPROC;
Public | MultiTexGeni: PFNGLMULTITEXGENIEXTPROC;
Public | MultiTexGeniv: PFNGLMULTITEXGENIVEXTPROC;
Public | GetMultiTexEnvfv: PFNGLGETMULTITEXENVFVEXTPROC;
Public | GetMultiTexEnviv: PFNGLGETMULTITEXENVIVEXTPROC;
Public | GetMultiTexGendv: PFNGLGETMULTITEXGENDVEXTPROC;
Public | GetMultiTexGenfv: PFNGLGETMULTITEXGENFVEXTPROC;
Public | GetMultiTexGeniv: PFNGLGETMULTITEXGENIVEXTPROC;
Public | GetFloatIndexedv: PFNGLGETFLOATINDEXEDVEXTPROC;
Public | GetDoubleIndexedv: PFNGLGETDOUBLEINDEXEDVEXTPROC;
Public | GetPointerIndexedv: PFNGLGETPOINTERINDEXEDVEXTPROC;
Public | CompressedTextureImage3D: PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC;
Public | CompressedTextureImage2D: PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC;
Public | CompressedTextureImage1D: PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC;
Public | CompressedTextureSubImage3D: PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC;
Public | CompressedTextureSubImage2D: PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC;
Public | CompressedTextureSubImage1D: PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC;
Public | GetCompressedTextureImage: PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC;
Public | CompressedMultiTexImage3D: PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC;
Public | CompressedMultiTexImage2D: PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC;
Public | CompressedMultiTexImage1D: PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC;
Public | CompressedMultiTexSubImage3D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC;
Public | CompressedMultiTexSubImage2D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC;
Public | CompressedMultiTexSubImage1D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC;
Public | GetCompressedMultiTexImage: PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC;
Public | NamedProgramString: PFNGLNAMEDPROGRAMSTRINGEXTPROC;
Public | NamedProgramLocalParameter4d: PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC;
Public | NamedProgramLocalParameter4dv: PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC;
Public | NamedProgramLocalParameter4f: PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC;
Public | NamedProgramLocalParameter4fv: PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC;
Public | GetNamedProgramLocalParameterdv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC;
Public | GetNamedProgramLocalParameterfv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC;
Public | GetNamedProgramiv: PFNGLGETNAMEDPROGRAMIVEXTPROC;
Public | GetNamedProgramString: PFNGLGETNAMEDPROGRAMSTRINGEXTPROC;
Public | NamedProgramLocalParameters4fv: PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC;
Public | NamedProgramLocalParameterI4i: PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC;
Public | NamedProgramLocalParameterI4iv: PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC;
Public | NamedProgramLocalParametersI4iv: PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC;
Public | NamedProgramLocalParameterI4ui: PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC;
Public | NamedProgramLocalParameterI4uiv: PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC;
Public | NamedProgramLocalParametersI4uiv: PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC;
Public | GetNamedProgramLocalParameterIiv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC;
Public | GetNamedProgramLocalParameterIuiv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC;
Public | TextureParameterIiv: PFNGLTEXTUREPARAMETERIIVEXTPROC;
Public | TextureParameterIuiv: PFNGLTEXTUREPARAMETERIUIVEXTPROC;
Public | GetTextureParameterIiv: PFNGLGETTEXTUREPARAMETERIIVEXTPROC;
Public | GetTextureParameterIuiv: PFNGLGETTEXTUREPARAMETERIUIVEXTPROC;
Public | MultiTexParameterIiv: PFNGLMULTITEXPARAMETERIIVEXTPROC;
Public | MultiTexParameterIuiv: PFNGLMULTITEXPARAMETERIUIVEXTPROC;
Public | GetMultiTexParameterIiv: PFNGLGETMULTITEXPARAMETERIIVEXTPROC;
Public | GetMultiTexParameterIuiv: PFNGLGETMULTITEXPARAMETERIUIVEXTPROC;
Public | NamedBufferData: PFNGLNAMEDBUFFERDATAEXTPROC;
Public | NamedBufferSubData: PFNGLNAMEDBUFFERSUBDATAEXTPROC;
Public | MapNamedBuffer: PFNGLMAPNAMEDBUFFEREXTPROC;
Public | UnmapNamedBuffer: PFNGLUNMAPNAMEDBUFFEREXTPROC;
Public | MapNamedBufferRange: PFNGLMAPNAMEDBUFFERRANGEEXTPROC;
Public | FlushMappedNamedBufferRange: PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC;
Public | NamedCopyBufferSubData: PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC;
Public | GetNamedBufferParameteriv: PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC;
Public | GetNamedBufferPointerv: PFNGLGETNAMEDBUFFERPOINTERVEXTPROC;
Public | GetNamedBufferSubData: PFNGLGETNAMEDBUFFERSUBDATAEXTPROC;
Public | TextureBuffer: PFNGLTEXTUREBUFFEREXTPROC;
Public | MultiTexBuffer: PFNGLMULTITEXBUFFEREXTPROC;
Public | NamedRenderbufferStorage: PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC;
Public | GetNamedRenderbufferParameteriv: PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC;
Public | CheckNamedFramebufferStatus: PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC;
Public | NamedFramebufferTexture1D: PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC;
Public | NamedFramebufferTexture2D: PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC;
Public | NamedFramebufferTexture3D: PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC;
Public | NamedFramebufferRenderbuffer: PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC;
Public | GetNamedFramebufferAttachmentParameteriv: PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC;
Public | GenerateTextureMipmap: PFNGLGENERATETEXTUREMIPMAPEXTPROC;
Public | GenerateMultiTexMipmap: PFNGLGENERATEMULTITEXMIPMAPEXTPROC;
Public | FramebufferDrawBuffer: PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC;
Public | FramebufferDrawBuffers: PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC;
Public | FramebufferReadBuffer: PFNGLFRAMEBUFFERREADBUFFEREXTPROC;
Public | GetFramebufferParameteriv: PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC;
Public | NamedRenderbufferStorageMultisample: PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC;
Public | NamedRenderbufferStorageMultisampleCoverage: PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC;
Public | NamedFramebufferTexture: PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC;
Public | NamedFramebufferTextureLayer: PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC;
Public | NamedFramebufferTextureFace: PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC;
Public | TextureRenderbuffer: PFNGLTEXTURERENDERBUFFEREXTPROC;
Public | MultiTexRenderbuffer: PFNGLMULTITEXRENDERBUFFEREXTPROC;
Public | FrameTerminatorGREMEDY: PFNGLFRAMETERMINATORGREMEDYPROC;
Public | StringMarkerGREMEDY: PFNGLSTRINGMARKERGREMEDYPROC;
Public | DebugMessageEnableAMDX: procedure(category: GLenum; severity: GLenum; Count: GLSizei; var ids: GLuint; Enabled: boolean); stdcall;
Public | DebugMessageCallbackAMDX: procedure(callback: TDebugProcAMD; userParam: Pointer); stdcall;
Public | DebugMessageControl: procedure(type_: GLenum; Source: GLenum; severity: GLenum; Count: GLSizei; var ids: GLuint; Enabled: boolean); stdcall;
Public | DebugMessageInsert: procedure(Source: GLenum; severity: GLenum; id: GLuint; length: GLSizei; const buf: PGLChar); stdcall;
Public | DebugMessageCallback: procedure(callback: TDebugProc; userParam: Pointer); stdcall;
Public | GetDebugMessageLog: function(Count: GLuint; bufSize: GLSizei; var severity: GLenum; var severities: GLuint; var ids: GLuint; var lengths: GLSizei; messageLog: PGLChar): GLuint; stdcall;
Public | GenPathsNV: PFNGLGENPATHSNVPROC;
Public | DeletePathsNV: PFNGLDELETEPATHSNVPROC;
Public | IsPathNV: PFNGLISPATHNVPROC;
Public | PathCommandsNV: PFNGLPATHCOMMANDSNVPROC;
Public | PathCoordsNV: PFNGLPATHCOORDSNVPROC;
Public | PathSubCommandsNV: PFNGLPATHSUBCOMMANDSNVPROC;
Public | PathSubCoordsNV: PFNGLPATHSUBCOORDSNVPROC;
Public | PathStringNV: PFNGLPATHSTRINGNVPROC;
Public | PathGlyphsNV: PFNGLPATHGLYPHSNVPROC;
Public | PathGlyphRangeNV: PFNGLPATHGLYPHRANGENVPROC;
Public | WeightPathsNV: PFNGLWEIGHTPATHSNVPROC;
Public | CopyPathNV: PFNGLCOPYPATHNVPROC;
Public | InterpolatePathsNV: PFNGLINTERPOLATEPATHSNVPROC;
Public | PathParameterivNV: PFNGLPATHPARAMETERIVNVPROC;
Public | PathParameteriNV: PFNGLPATHPARAMETERINVPROC;
Public | PathParameterfvNV: PFNGLPATHPARAMETERFVNVPROC;
Public | PathParameterfNV: PFNGLPATHPARAMETERFNVPROC;
Public | PathDashArrayNV: PFNGLPATHDASHARRAYNVPROC;
Public | PathStencilFuncNV: PFNGLPATHSTENCILFUNCNVPROC;
Public | StencilFillPathNV: PFNGLSTENCILFILLPATHNVPROC;
Public | StencilStrokePathNV: PFNGLSTENCILSTROKEPATHNVPROC;
Public | StencilFillPathInstancedNV: PFNGLSTENCILFILLPATHINSTANCEDNVPROC;
Public | StencilStrokePathInstancedNV: PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC;
Public | PathColorGenNV: PFNGLPATHCOLORGENNVPROC;
Public | PathTexGenNV: PFNGLPATHTEXGENNVPROC;
Public | PathFogGenNV: PFNGLPATHFOGGENNVPROC;
Public | CoverFillPathNV: PFNGLCOVERFILLPATHNVPROC;
Public | CoverStrokePathNV: PFNGLCOVERSTROKEPATHNVPROC;
Public | CoverFillPathInstancedNV: PFNGLCOVERFILLPATHINSTANCEDNVPROC;
Public | CoverStrokePathInstancedNV: PFNGLCOVERSTROKEPATHINSTANCEDNVPROC;
Public | GetPathParameterivNV: PFNGLGETPATHPARAMETERIVNVPROC;
Public | GetPathParameterfvNV: PFNGLGETPATHPARAMETERFVNVPROC;
Public | GetPathCommandsNV: PFNGLGETPATHCOMMANDSNVPROC;
Public | GetPathCoordsNV: PFNGLGETPATHCOORDSNVPROC;
Public | GetPathDashArrayNV: PFNGLGETPATHDASHARRAYNVPROC;
Public | GetPathMetricsNV: PFNGLGETPATHMETRICSNVPROC;
Public | GetPathMetricRangeNV: PFNGLGETPATHMETRICRANGENVPROC;
Public | GetPathSpacingNV: PFNGLGETPATHSPACINGNVPROC;
Public | GetPathColorGenivNV: PFNGLGETPATHCOLORGENIVNVPROC;
Public | GetPathColorGenfvNV: PFNGLGETPATHCOLORGENFVNVPROC;
Public | GetPathTexGenivNV: PFNGLGETPATHTEXGENIVNVPROC;
Public | GetPathTexGenfvNV: PFNGLGETPATHTEXGENFVNVPROC;
Public | IsPointInFillPathNV: PFNGLISPOINTINFILLPATHNVPROC;
Public | IsPointInStrokePathNV: PFNGLISPOINTINSTROKEPATHNVPROC;
Public | GetPathLengthNV: PFNGLGETPATHLENGTHNVPROC;
Public | PointAlongPathNV: PFNGLPOINTALONGPATHNVPROC;
Public | PathStencilDepthOffsetNV: PFNGLPATHSTENCILDEPTHOFFSETNVPROC;
Public | PathCoverDepthFuncNV: PFNGLPATHCOVERDEPTHFUNCNVPROC;
Public | W_ARB_buffer_region: boolean;
Public | W_ARB_create_context: boolean;
Public | W_ARB_create_context_profile: boolean;
Public | W_ARB_extensions_string: boolean;
Public | W_ARB_framebuffer_sRGB: boolean;
Public | W_ARB_make_current_read: boolean;
Public | W_ARB_multisample: boolean;
Public | W_ARB_pbuffer: boolean;
Public | W_ARB_pixel_format: boolean;
Public | W_ARB_pixel_format_float: boolean;
Public | W_ARB_render_texture: boolean;
Public | W_ATI_pixel_format_float: boolean;
Public | W_EXT_framebuffer_sRGB: boolean;
Public | W_EXT_pixel_format_packed_float: boolean;
Public | W_EXT_swap_control: boolean;
Public | W_NV_gpu_affinity: boolean;
Public | W_EXT_create_context_es2_profile: boolean;
Public | W_NV_DX_interop: boolean;
Public | W_NV_DX_interop2: boolean;
Public | WCreateBufferRegionARB: PFNWGLCREATEBUFFERREGIONARBPROC;
Public | WDeleteBufferRegionARB: PFNWGLDELETEBUFFERREGIONARBPROC;
Public | WSaveBufferRegionARB: PFNWGLSAVEBUFFERREGIONARBPROC;
Public | WRestoreBufferRegionARB: PFNWGLRESTOREBUFFERREGIONARBPROC;
Public | WGetExtensionsStringARB: PFNWGLGETEXTENSIONSSTRINGARBPROC;
Public | WGetPixelFormatAttribivARB: PFNWGLGETPIXELFORMATATTRIBIVARBPROC;
Public | WGetPixelFormatAttribfvARB: PFNWGLGETPIXELFORMATATTRIBFVARBPROC;
Public | WChoosePixelFormatARB: PFNWGLCHOOSEPIXELFORMATARBPROC;
Public | WMakeContextCurrentARB: PFNWGLMAKECONTEXTCURRENTARBPROC;
Public | WGetCurrentReadDCARB: PFNWGLGETCURRENTREADDCARBPROC;
Public | WCreatePbufferARB: PFNWGLCREATEPBUFFERARBPROC;
Public | WGetPbufferDCARB: PFNWGLGETPBUFFERDCARBPROC;
Public | WReleasePbufferDCARB: PFNWGLRELEASEPBUFFERDCARBPROC;
Public | WDestroyPbufferARB: PFNWGLDESTROYPBUFFERARBPROC;
Public | WQueryPbufferARB: PFNWGLQUERYPBUFFERARBPROC;
Public | WBindTexImageARB: PFNWGLBINDTEXIMAGEARBPROC;
Public | WReleaseTexImageARB: PFNWGLRELEASETEXIMAGEARBPROC;
Public | WSetPbufferAttribARB: PFNWGLSETPBUFFERATTRIBARBPROC;
Public | WCreateContextAttribsARB: PFNWGLCREATECONTEXTATTRIBSARBPROC;
Public | WEnumGpusNV: PFNWGLENUMGPUSNVPROC;
Public | WEnumGpuDevicesNV: PFNWGLENUMGPUDEVICESNVPROC;
Public | WCreateAffinityDCNV: PFNWGLCREATEAFFINITYDCNVPROC;
Public | WEnumGpusFromAffinityDCNV: PFNWGLENUMGPUSFROMAFFINITYDCNVPROC;
Public | WDeleteDCNV: PFNWGLDELETEDCNVPROC;
Public | WDXSetResourceShareHandleNV: PFNWGLDXSETRESOURCESHAREHANDLEPROC;
Public | WDXOpenDeviceNV: PFNWGLDXOPENDEVICEPROC;
Public | WDXCloseDeviceNV: PFNWGLDXCLOSEDEVICEPROC;
Public | WDXRegisterObjectNV: PFNWGLDXREGISTEROBJECTPROC;
Public | WDXUnregisterObjectNV: PFNWGLDXUNREGISTEROBJECTPROC;
Public | WDXObjectAccessNV: PFNWGLDXOBJECTACCESSPROC;
Public | WDXLockObjectsNV: PFNWGLDXLOCKOBJECTSPROC;
Public | WDXUnlockObjectsNV: PFNWGLDXUNLOCKOBJECTSNVPROC;
Public | WSwapIntervalEXT: PFNWGLSWAPINTERVALEXTPROC;
Public | WGetSwapIntervalEXT: PFNWGLGETSWAPINTERVALEXTPROC;
Public | WAllocateMemoryNV: PFNWGLALLOCATEMEMORYNVPROC;
Public | WFreeMemoryNV: PFNWGLFREEMEMORYNVPROC;
Public | UNurbsCallbackDataEXT: procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;
Public | UNewNurbsTessellatorEXT: function: PGLUnurbs; stdcall;
Public | UDeleteNurbsTessellatorEXT: procedure(nurb: PGLUnurbs); stdcall;

Methods

Public | constructor Create;
Public | procedure CheckError;
Public | procedure ClearError;
Public | procedure Close;
Public | procedure Initialize(ATemporary: boolean = False);

Properties

Public | property DebugMode: boolean read FDebug write FDebug;
Public | property IsInitialized: boolean read FInitialized;

Description

Fields

Public VERSION_1_0: boolean;
Public VERSION_1_1: boolean;
Public VERSION_1_2: boolean;
Public VERSION_1_3: boolean;
Public VERSION_1_4: boolean;
Public VERSION_1_5: boolean;
Public VERSION_2_0: boolean;
Public VERSION_2_1: boolean;
Public VERSION_3_0: boolean;
Public VERSION_3_1: boolean;
Public VERSION_3_2: boolean;
Public VERSION_3_3: boolean;
Public VERSION_4_0: boolean;
Public VERSION_4_1: boolean;
Public VERSION_4_2: boolean;
Public ARB_blend_func_extended: boolean;
Public ARB_color_buffer_float: boolean;
Public ARB_compatibility: boolean;
Public ARB_copy_buffer: boolean;
Public ARB_depth_buffer_float: boolean;
Public ARB_depth_clamp: boolean;
Public ARB_depth_texture: boolean;
Public ARB_draw_buffers: boolean;
Public ARB_draw_buffers_blend: boolean;
Public ARB_draw_elements_base_vertex: boolean;
Public ARB_draw_indirect: boolean;
Public ARB_draw_instanced: boolean;
Public ARB_explicit_attrib_location: boolean;
Public ARB_fragment_coord_conventions: boolean;
Public ARB_fragment_program: boolean;
Public ARB_fragment_program_shadow: boolean;
Public ARB_fragment_shader: boolean;
Public ARB_framebuffer_object: boolean;
Public ARB_framebuffer_sRGB: boolean;
Public ARB_geometry_shader4: boolean;
Public ARB_gpu_shader_fp64: boolean;
Public ARB_gpu_shader5: boolean;
Public ARB_half_float_pixel: boolean;
Public ARB_half_float_vertex: boolean;
Public ARB_imaging: boolean;
Public ARB_instanced_arrays: boolean;
Public ARB_map_buffer_range: boolean;
Public ARB_matrix_palette: boolean;
Public ARB_multisample: boolean;
Public ARB_multitexture: boolean;
Public ARB_occlusion_query: boolean;
Public ARB_occlusion_query2: boolean;
Public ARB_pixel_buffer_object: boolean;
Public ARB_point_parameters: boolean;
Public ARB_point_sprite: boolean;
Public ARB_provoking_vertex: boolean;
Public ARB_sample_shading: boolean;
Public ARB_sampler_objects: boolean;
Public ARB_seamless_cube_map: boolean;
Public ARB_shader_bit_encoding: boolean;
Public ARB_shader_subroutine: boolean;
Public ARB_shader_texture_lod: boolean;
Public ARB_shading_language_100: boolean;
Public ARB_shadow: boolean;
Public ARB_shadow_ambient: boolean;
Public ARB_shader_objects: boolean;
Public ARB_sync: boolean;
Public ARB_tessellation_shader: boolean;
Public ARB_texture_border_clamp: boolean;
Public ARB_texture_buffer_object: boolean;
Public ARB_texture_buffer_object_rgb32: boolean;
Public ARB_texture_compression: boolean;
Public ARB_texture_compression_rgtc: boolean;
Public ARB_texture_cube_map: boolean;
Public ARB_texture_cube_map_array: boolean;
Public ARB_texture_env_add: boolean;
Public ARB_texture_env_combine: boolean;
Public ARB_texture_env_crossbar: boolean;
Public ARB_texture_env_dot3: boolean;
Public ARB_texture_float: boolean;
Public ARB_texture_gather: boolean;
Public ARB_texture_mirrored_repeat: boolean;
Public ARB_texture_multisample: boolean;
Public ARB_texture_non_power_of_two: boolean;
Public ARB_texture_query_lod: boolean;
Public ARB_texture_rectangle: boolean;
Public ARB_texture_rg: boolean;
Public ARB_texture_rgb10_a2ui: boolean;
Public ARB_texture_swizzle: boolean;
Public ARB_timer_query: boolean;
Public ARB_transform_feedback2: boolean;
Public ARB_transform_feedback3: boolean;
Public ARB_transpose_matrix: boolean;
Public ARB_uniform_buffer_object: boolean;
Public ARB_vertex_array_bgra: boolean;
Public ARB_vertex_array_object: boolean;
Public ARB_vertex_blend: boolean;
Public ARB_vertex_buffer_object: boolean;
Public ARB_vertex_program: boolean;
Public ARB_vertex_shader: boolean;
Public ARB_vertex_type_2_10_10_10_rev: boolean;
Public ARB_window_pos: boolean;
Public ARB_texture_compression_bptc: boolean;
Public ARB_get_program_binary: boolean;
Public ARB_separate_shader_objects: boolean;
Public _3DFX_multisample: boolean;
Public _3DFX_tbuffer: boolean;
Public _3DFX_texture_compression_FXT1: boolean;
Public ATI_draw_buffers: boolean;
Public ATI_texture_compression_3dc: boolean;
Public ATI_texture_float: boolean;
Public ATI_texture_mirror_once: boolean;
Public S3_s3tc: boolean;
Public EXT_abgr: boolean;
Public EXT_bgra: boolean;
Public EXT_bindable_uniform: boolean;
Public EXT_blend_color: boolean;
Public EXT_blend_equation_separate: boolean;
Public EXT_blend_func_separate: boolean;
Public EXT_blend_logic_op: boolean;
Public EXT_blend_minmax: boolean;
Public EXT_blend_subtract: boolean;
Public EXT_Cg_shader: boolean;
Public EXT_clip_volume_hint: boolean;
Public EXT_compiled_vertex_array: boolean;
Public EXT_copy_texture: boolean;
Public EXT_depth_bounds_test: boolean;
Public EXT_draw_buffers2: boolean;
Public EXT_draw_instanced: boolean;
Public EXT_draw_range_elements: boolean;
Public EXT_fog_coord: boolean;
Public EXT_framebuffer_blit: boolean;
Public EXT_framebuffer_multisample: boolean;
Public EXT_framebuffer_object: boolean;
Public EXT_framebuffer_sRGB: boolean;
Public EXT_geometry_shader4: boolean;
Public EXT_gpu_program_parameters: boolean;
Public EXT_gpu_shader4: boolean;
Public EXT_multi_draw_arrays: boolean;
Public EXT_multisample: boolean;
Public EXT_packed_depth_stencil: boolean;
Public EXT_packed_float: boolean;
Public EXT_packed_pixels: boolean;
Public EXT_paletted_texture: boolean;
Public EXT_pixel_buffer_object: boolean;
Public EXT_polygon_offset: boolean;
Public EXT_rescale_normal: boolean;
Public EXT_secondary_color: boolean;
Public EXT_separate_specular_color: boolean;
Public EXT_shadow_funcs: boolean;
Public EXT_shared_texture_palette: boolean;
Public EXT_stencil_clear_tag: boolean;
Public EXT_stencil_two_side: boolean;
Public EXT_stencil_wrap: boolean;
Public EXT_texture3D: boolean;
Public EXT_texture_array: boolean;
Public EXT_texture_buffer_object: boolean;
Public EXT_texture_compression_latc: boolean;
Public EXT_texture_compression_rgtc: boolean;
Public EXT_texture_compression_s3tc: boolean;
Public EXT_texture_cube_map: boolean;
Public EXT_texture_edge_clamp: boolean;
Public EXT_texture_env_add: boolean;
Public EXT_texture_env_combine: boolean;
Public EXT_texture_env_dot3: boolean;
Public EXT_texture_filter_anisotropic: boolean;
Public EXT_texture_integer: boolean;
Public EXT_texture_lod: boolean;
Public EXT_texture_lod_bias: boolean;
Public EXT_texture_mirror_clamp: boolean;
Public EXT_texture_object: boolean;
Public EXT_texture_rectangle: boolean;
Public EXT_texture_sRGB: boolean;
Public EXT_texture_shared_exponent: boolean;
Public EXT_timer_query: boolean;
Public EXT_transform_feedback: boolean;
Public EXT_vertex_array: boolean;
Public EXT_texture_sRGB_decode: boolean;
Public EXT_direct_state_access: boolean;
Public EXT_texture_swizzle: boolean;
Public HP_occlusion_test: boolean;
Public IBM_rasterpos_clip: boolean;
Public KTX_buffer_region: boolean;
Public MESA_resize_buffers: boolean;
Public NV_blend_square: boolean;
Public NV_conditional_render: boolean;
Public NV_copy_image: boolean;
Public NV_depth_buffer_float: boolean;
Public NV_fence: boolean;
Public NV_float_buffer: boolean;
Public NV_fog_distance: boolean;
Public NV_geometry_program4: boolean;
Public NV_light_max_exponent: boolean;
Public NV_multisample_filter_hint: boolean;
Public NV_occlusion_query: boolean;
Public NV_point_sprite: boolean;
Public NV_primitive_restart: boolean;
Public NV_register_combiners: boolean;
Public NV_shader_buffer_load: boolean;
Public NV_texgen_reflection: boolean;
Public NV_texture_compression_vtc: boolean;
Public NV_texture_env_combine4: boolean;
Public NV_texture_rectangle: boolean;
Public NV_texture_shader: boolean;
Public NV_texture_shader2: boolean;
Public NV_texture_shader3: boolean;
Public NV_transform_feedback: boolean;
Public NV_vertex_array_range: boolean;
Public NV_vertex_array_range2: boolean;
Public NV_vertex_buffer_unified_memory: boolean;
Public NV_vertex_program: boolean;
Public SGI_color_matrix: boolean;
Public SGIS_generate_mipmap: boolean;
Public SGIS_multisample: boolean;
Public SGIS_texture_border_clamp: boolean;
Public SGIS_texture_color_mask: boolean;
Public SGIS_texture_edge_clamp: boolean;
Public SGIS_texture_lod: boolean;
Public SGIX_depth_texture: boolean;
Public SGIX_shadow: boolean;
Public SGIX_shadow_ambient: boolean;
Public AMD_vertex_shader_tessellator: boolean;
Public WIN_swap_hint: boolean;
Public ATI_meminfo: boolean;
Public NVX_gpu_memory_info: boolean;
Public NV_vdpau_interop: boolean;
Public NV_path_rendering: boolean;
Public GREMEDY_frame_terminator: boolean;
Public GREMEDY_string_marker: boolean;
Public AMDX_debug_output: boolean;
Public ARB_debug_output: boolean;
Public BindTexture: procedure(target: TGLEnum; texture: TGLuint); stdcall;
Public BlendFunc: procedure(sfactor: TGLEnum; dfactor: TGLEnum); stdcall;
Public Clear: procedure(mask: TGLbitfield); stdcall;
Public ClearColor: procedure(red, green, blue, alpha: TGLclampf); stdcall;
Public ClearDepth: procedure(depth: TGLclampd); stdcall;
Public ClearStencil: procedure(s: TGLint); stdcall;
Public ColorMask: procedure(red, green, blue, alpha: TGLboolean); stdcall;
Public CopyTexImage1D: procedure(target: TGLEnum; level: TGLint; internalFormat: TGLEnum; X, y: TGLint; Width: TGLsizei; border: TGLint); stdcall;
Public CopyTexImage2D: procedure(target: TGLEnum; level: TGLint; internalFormat: TGLEnum; X, y: TGLint; Width, Height: TGLsizei; border: TGLint); stdcall;
Public CopyTexSubImage1D: procedure(target: TGLEnum; level, xoffset, X, y: TGLint; Width: TGLsizei); stdcall;
Public CopyTexSubImage2D: procedure(target: TGLEnum; level, xoffset, yoffset, X, y: TGLint; Width, Height: TGLsizei); stdcall;
Public CullFace: procedure(mode: TGLEnum); stdcall;
Public DeleteTextures: procedure(n: TGLsizei; textures: PGLuint); stdcall;
Public DepthFunc: procedure(func: TGLEnum); stdcall;
Public DepthMask: procedure(flag: TGLboolean); stdcall;
Public DepthRange: procedure(zNear, zFar: TGLclampd); stdcall;
Public Disable: procedure(cap: TGLEnum); stdcall;
Public DrawArrays: procedure(mode: TGLEnum; First: TGLint; Count: TGLsizei); stdcall;
Public DrawBuffer: procedure(mode: TGLEnum); stdcall;
Public DrawElements: procedure(mode: TGLEnum; Count: TGLsizei; atype: TGLEnum; indices: Pointer); stdcall;
Public Enable: procedure(cap: TGLEnum); stdcall;
Public Finish: procedure(); stdcall;
Public Flush: procedure(); stdcall;
Public FrontFace: procedure(mode: TGLEnum); stdcall;
Public GenTextures: procedure(n: TGLsizei; textures: PGLuint); stdcall;
Public GetBooleanv: procedure(pname: TGLEnum; params: PGLboolean); stdcall;
Public GetDoublev: procedure(pname: TGLEnum; params: PGLdouble); stdcall;
Public GetError: function: TGLuint; stdcall;
Public GetFloatv: procedure(pname: TGLEnum; params: PGLfloat); stdcall;
Public GetIntegerv: procedure(pname: TGLEnum; params: PGLint); stdcall;
Public GetPointerv: procedure(pname: TGLEnum; var params); stdcall;
Public GetString: function(Name: TGLEnum): PGLChar; stdcall;
Public GetTexImage: procedure(target: TGLEnum; level: TGLint; format, atype: TGLEnum; pixels: Pointer); stdcall;
Public GetTexLevelParameterfv: procedure(target: TGLEnum; level: TGLint; pname: TGLEnum; params: PGLfloat); stdcall;
Public GetTexLevelParameteriv: procedure(target: TGLEnum; level: TGLint; pname: TGLEnum; params: PGLint); stdcall;
Public GetTexParameterfv: procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;
Public GetTexParameteriv: procedure(target, pname: TGLEnum; params: PGLint); stdcall;
Public Hint: procedure(target, mode: TGLEnum); stdcall;
Public IsEnabled: function(cap: TGLEnum): TGLboolean; stdcall;
Public IsTexture: function(texture: TGLuint): TGLboolean; stdcall;
Public LineWidth: procedure(Width: TGLfloat); stdcall;
Public LogicOp: procedure(opcode: TGLEnum); stdcall;
Public PixelStoref: procedure(pname: TGLEnum; param: TGLfloat); stdcall;
Public PixelStorei: procedure(pname: TGLEnum; param: TGLint); stdcall;
Public PointSize: procedure(size: TGLfloat); stdcall;
Public PolygonMode: procedure(face, mode: TGLEnum); stdcall;
Public PolygonOffset: procedure(factor, units: TGLfloat); stdcall;
Public ReadBuffer: procedure(mode: TGLEnum); stdcall;
Public ReadPixels: procedure(X, y: TGLint; Width, Height: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall;
Public Scissor: procedure(X, y: TGLint; Width, Height: TGLsizei); stdcall;
Public StencilFunc: procedure(func: TGLEnum; ref: TGLint; mask: TGLuint); stdcall;
Public StencilMask: procedure(mask: TGLuint); stdcall;
Public StencilOp: procedure(fail, zfail, zpass: TGLEnum); stdcall;
Public TexImage1D: procedure(target: TGLEnum; level, internalFormat: TGLint; Width: TGLsizei; border: TGLint; format, atype: TGLEnum; pixels: Pointer); stdcall;
Public TexImage2D: procedure(target: TGLEnum; level, internalFormat: TGLint; Width, Height: TGLsizei; border: TGLint; format, atype: TGLEnum; pixels: Pointer); stdcall;
Public TexParameterf: procedure(target, pname: TGLEnum; param: TGLfloat); stdcall;
Public TexParameterfv: procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;
Public TexParameteri: procedure(target, pname: TGLEnum; param: TGLint); stdcall;
Public TexParameteriv: procedure(target, pname: TGLEnum; params: PGLint); stdcall;
Public TexSubImage1D: procedure(target: TGLEnum; level, xoffset: TGLint; Width: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall;
Public TexSubImage2D: procedure(target: TGLEnum; level, xoffset, yoffset: TGLint; Width, Height: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall;
Public Viewport: procedure(X, y: TGLint; Width, Height: TGLsizei); stdcall;
Public Accum: procedure(op: TGLuint; Value: TGLfloat); stdcall;
Public AlphaFunc: procedure(func: TGLEnum; ref: TGLclampf); stdcall;
Public AreTexturesResident: function(n: TGLsizei; textures: PGLuint; residences: PGLboolean): TGLboolean; stdcall;
Public ArrayElement: procedure(i: TGLint); stdcall;
Public Begin_: procedure(mode: TGLEnum); stdcall;
Public Bitmap: procedure(Width: TGLsizei; Height: TGLsizei; xorig, yorig: TGLfloat; xmove: TGLfloat; ymove: TGLfloat; Bitmap: Pointer); stdcall;
Public CallList: procedure(list: TGLuint); stdcall;
Public CallLists: procedure(n: TGLsizei; atype: TGLEnum; lists: Pointer); stdcall;
Public ClearAccum: procedure(red, green, blue, alpha: TGLfloat); stdcall;
Public ClearIndex: procedure(c: TGLfloat); stdcall;
Public ClipPlane: procedure(plane: TGLEnum; equation: PGLdouble); stdcall;
Public Color3b: procedure(red, green, blue: TGLbyte); stdcall;
Public Color3bv: procedure(v: PGLbyte); stdcall;
Public Color3d: procedure(red, green, blue: TGLdouble); stdcall;
Public Color3dv: procedure(v: PGLdouble); stdcall;
Public Color3f: procedure(red, green, blue: TGLfloat); stdcall;
Public Color3fv: procedure(v: PGLfloat); stdcall;
Public Color3i: procedure(red, green, blue: TGLint); stdcall;
Public Color3iv: procedure(v: PGLint); stdcall;
Public Color3s: procedure(red, green, blue: TGLshort); stdcall;
Public Color3sv: procedure(v: PGLshort); stdcall;
Public Color3ub: procedure(red, green, blue: TGLubyte); stdcall;
Public Color3ubv: procedure(v: PGLubyte); stdcall;
Public Color3ui: procedure(red, green, blue: TGLuint); stdcall;
Public Color3uiv: procedure(v: PGLuint); stdcall;
Public Color3us: procedure(red, green, blue: TGLushort); stdcall;
Public Color3usv: procedure(v: PGLushort); stdcall;
Public Color4b: procedure(red, green, blue, alpha: TGLbyte); stdcall;
Public Color4bv: procedure(v: PGLbyte); stdcall;
Public Color4d: procedure(red, green, blue, alpha: TGLdouble); stdcall;
Public Color4dv: procedure(v: PGLdouble); stdcall;
Public Color4f: procedure(red, green, blue, alpha: TGLfloat); stdcall;
Public Color4fv: procedure(v: PGLfloat); stdcall;
Public Color4i: procedure(red, green, blue, alpha: TGLint); stdcall;
Public Color4iv: procedure(v: PGLint); stdcall;
Public Color4s: procedure(red, green, blue, alpha: TGLshort); stdcall;
Public Color4sv: procedure(v: TGLshort); stdcall;
Public Color4ub: procedure(red, green, blue, alpha: TGLubyte); stdcall;
Public Color4ubv: procedure(v: PGLubyte); stdcall;
Public Color4ui: procedure(red, green, blue, alpha: TGLuint); stdcall;
Public Color4uiv: procedure(v: PGLuint); stdcall;
Public Color4us: procedure(red, green, blue, alpha: TGLushort); stdcall;
Public Color4usv: procedure(v: PGLushort); stdcall;
Public ColorMaterial: procedure(face: TGLEnum; mode: TGLEnum); stdcall;
Public ColorPointer: procedure(size: TGLint; atype: TGLEnum; stride: TGLsizei; Data: Pointer); stdcall;
Public CopyPixels: procedure(X, y: TGLint; Width, Height: TGLsizei; atype: TGLEnum); stdcall;
Public DeleteLists: procedure(list: TGLuint; range: TGLsizei); stdcall;
Public DisableClientState: procedure(aarray: TGLEnum); stdcall;
Public DrawPixels: procedure(Width, Height: TGLsizei; format, atype: TGLEnum; pixels: Pointer); stdcall;
Public EdgeFlag: procedure(flag: TGLboolean); stdcall;
Public EdgeFlagPointer: procedure(stride: TGLsizei; Data: Pointer); stdcall;
Public EdgeFlagv: procedure(flag: PGLboolean); stdcall;
Public EnableClientState: procedure(aarray: TGLEnum); stdcall;
Public End_: procedure(); stdcall;
Public EndList: procedure(); stdcall;
Public EvalCoord1d: procedure(u: TGLdouble); stdcall;
Public EvalCoord1dv: procedure(u: PGLdouble); stdcall;
Public EvalCoord1f: procedure(u: TGLfloat); stdcall;
Public EvalCoord1fv: procedure(u: PGLfloat); stdcall;
Public EvalCoord2d: procedure(u: TGLdouble; v: TGLdouble); stdcall;
Public EvalCoord2dv: procedure(u: PGLdouble); stdcall;
Public EvalCoord2f: procedure(u, v: TGLfloat); stdcall;
Public EvalCoord2fv: procedure(u: PGLfloat); stdcall;
Public EvalMesh1: procedure(mode: TGLEnum; i1, i2: TGLint); stdcall;
Public EvalMesh2: procedure(mode: TGLEnum; i1, i2, j1, j2: TGLint); stdcall;
Public EvalPoint1: procedure(i: TGLint); stdcall;
Public EvalPoint2: procedure(i, j: TGLint); stdcall;
Public FeedbackBuffer: procedure(size: TGLsizei; atype: TGLEnum; buffer: PGLfloat); stdcall;
Public Fogf: procedure(pname: TGLEnum; param: TGLfloat); stdcall;
Public Fogfv: procedure(pname: TGLEnum; params: PGLfloat); stdcall;
Public Fogi: procedure(pname: TGLEnum; param: TGLint); stdcall;
Public Fogiv: procedure(pname: TGLEnum; params: PGLint); stdcall;
Public Frustum: procedure(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall;
Public GenLists: function(range: TGLsizei): TGLuint; stdcall;
Public GetClipPlane: procedure(plane: TGLEnum; equation: PGLdouble); stdcall;
Public GetLightfv: procedure(light, pname: TGLEnum; params: PGLfloat); stdcall;
Public GetLightiv: procedure(light, pname: TGLEnum; params: PGLint); stdcall;
Public GetMapdv: procedure(target, query: TGLEnum; v: PGLdouble); stdcall;
Public GetMapfv: procedure(target, query: TGLEnum; v: PGLfloat); stdcall;
Public GetMapiv: procedure(target, query: TGLEnum; v: PGLint); stdcall;
Public GetMaterialfv: procedure(face, pname: TGLEnum; params: PGLfloat); stdcall;
Public GetMaterialiv: procedure(face, pname: TGLEnum; params: PGLint); stdcall;
Public GetPixelMapfv: procedure(map: TGLEnum; values: PGLfloat); stdcall;
Public GetPixelMapuiv: procedure(map: TGLEnum; values: PGLuint); stdcall;
Public GetPixelMapusv: procedure(map: TGLEnum; values: PGLushort); stdcall;
Public GetPolygonStipple: procedure(mask: PGLubyte); stdcall;
Public GetTexEnvfv: procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;
Public GetTexEnviv: procedure(target, pname: TGLEnum; params: PGLint); stdcall;
Public GetTexGendv: procedure(coord, pname: TGLEnum; params: PGLdouble); stdcall;
Public GetTexGenfv: procedure(coord, pname: TGLEnum; params: PGLfloat); stdcall;
Public GetTexGeniv: procedure(coord, pname: TGLEnum; params: PGLint); stdcall;
Public IndexMask: procedure(mask: TGLuint); stdcall;
Public IndexPointer: procedure(atype: TGLEnum; stride: TGLsizei; Data: Pointer); stdcall;
Public Indexd: procedure(c: TGLdouble); stdcall;
Public Indexdv: procedure(c: PGLdouble); stdcall;
Public Indexf: procedure(c: TGLfloat); stdcall;
Public Indexfv: procedure(c: PGLfloat); stdcall;
Public Indexi: procedure(c: TGLint); stdcall;
Public Indexiv: procedure(c: PGLint); stdcall;
Public Indexs: procedure(c: TGLshort); stdcall;
Public Indexsv: procedure(c: PGLshort); stdcall;
Public Indexub: procedure(c: TGLubyte); stdcall;
Public Indexubv: procedure(c: PGLubyte); stdcall;
Public InitNames: procedure(); stdcall;
Public InterleavedArrays: procedure(format: TGLEnum; stride: TGLsizei; Data: Pointer); stdcall;
Public IsList: function(list: TGLuint): TGLboolean; stdcall;
Public LightModelf: procedure(pname: TGLEnum; param: TGLfloat); stdcall;
Public LightModelfv: procedure(pname: TGLEnum; params: PGLfloat); stdcall;
Public LightModeli: procedure(pname: TGLEnum; param: TGLint); stdcall;
Public LightModeliv: procedure(pname: TGLEnum; params: PGLint); stdcall;
Public Lightf: procedure(light, pname: TGLEnum; param: TGLfloat); stdcall;
Public Lightfv: procedure(light, pname: TGLEnum; params: PGLfloat); stdcall;
Public Lighti: procedure(light, pname: TGLEnum; param: TGLint); stdcall;
Public Lightiv: procedure(light, pname: TGLEnum; params: PGLint); stdcall;
Public LineStipple: procedure(factor: TGLint; pattern: TGLushort); stdcall;
Public ListBase: procedure(base: TGLuint); stdcall;
Public LoadIdentity: procedure(); stdcall;
Public LoadMatrixd: procedure(m: PGLdouble); stdcall;
Public LoadMatrixf: procedure(m: PGLfloat); stdcall;
Public LoadName: procedure(Name: TGLuint); stdcall;
Public Map1d: procedure(target: TGLEnum; u1, u2: TGLdouble; stride, order: TGLint; points: PGLdouble); stdcall;
Public Map1f: procedure(target: TGLEnum; u1, u2: TGLfloat; stride, order: TGLint; points: PGLfloat); stdcall;
Public Map2d: procedure(target: TGLEnum; u1, u2: TGLdouble; ustride, uorder: TGLint; v1, v2: TGLdouble; vstride, vorder: TGLint; points: PGLdouble); stdcall;
Public Map2f: procedure(target: TGLEnum; u1, u2: TGLfloat; ustride, uorder: TGLint; v1, v2: TGLfloat; vstride, vorder: TGLint; points: PGLfloat); stdcall;
Public MapGrid1d: procedure(un: TGLint; u1, u2: TGLdouble); stdcall;
Public MapGrid1f: procedure(un: TGLint; u1, u2: TGLfloat); stdcall;
Public MapGrid2d: procedure(un: TGLint; u1, u2: TGLdouble; vn: TGLint; v1, v2: TGLdouble); stdcall;
Public MapGrid2f: procedure(un: TGLint; u1, u2: TGLfloat; vn: TGLint; v1, v2: TGLfloat); stdcall;
Public Materialf: procedure(face, pname: TGLEnum; param: TGLfloat); stdcall;
Public Materialfv: procedure(face, pname: TGLEnum; params: PGLfloat); stdcall;
Public Materiali: procedure(face, pname: TGLEnum; param: TGLint); stdcall;
Public Materialiv: procedure(face, pname: TGLEnum; params: PGLint); stdcall;
Public MatrixMode: procedure(mode: TGLEnum); stdcall;
Public MultMatrixd: procedure(m: PGLdouble); stdcall;
Public MultMatrixf: procedure(m: PGLfloat); stdcall;
Public NewList: procedure(list: TGLuint; mode: TGLEnum); stdcall;
Public Normal3b: procedure(nx, ny, nz: TGLbyte); stdcall;
Public Normal3bv: procedure(v: PGLbyte); stdcall;
Public Normal3d: procedure(nx, ny, nz: TGLdouble); stdcall;
Public Normal3dv: procedure(v: PGLdouble); stdcall;
Public Normal3f: procedure(nx, ny, nz: TGLfloat); stdcall;
Public Normal3fv: procedure(v: PGLfloat); stdcall;
Public Normal3i: procedure(nx, ny, nz: TGLint); stdcall;
Public Normal3iv: procedure(v: PGLint); stdcall;
Public Normal3s: procedure(nx, ny, nz: TGLshort); stdcall;
Public Normal3sv: procedure(v: PGLshort); stdcall;
Public NormalPointer: procedure(atype: TGLEnum; stride: TGLsizei; Data: Pointer); stdcall;
Public Ortho: procedure(left, right, bottom, top, zNear, zFar: TGLdouble); stdcall;
Public PassThrough: procedure(token: TGLfloat); stdcall;
Public PixelMapfv: procedure(map: TGLEnum; mapsize: TGLsizei; values: PGLfloat); stdcall;
Public PixelMapuiv: procedure(map: TGLEnum; mapsize: TGLsizei; values: PGLuint); stdcall;
Public PixelMapusv: procedure(map: TGLEnum; mapsize: TGLsizei; values: PGLushort); stdcall;
Public PixelTransferf: procedure(pname: TGLEnum; param: TGLfloat); stdcall;
Public PixelTransferi: procedure(pname: TGLEnum; param: TGLint); stdcall;
Public PixelZoom: procedure(xfactor, yfactor: TGLfloat); stdcall;
Public PolygonStipple: procedure(mask: PGLubyte); stdcall;
Public PopAttrib: procedure(); stdcall;
Public PopClientAttrib: procedure(); stdcall;
Public PopMatrix: procedure(); stdcall;
Public PopName: procedure(); stdcall;
Public PrioritizeTextures: procedure(n: TGLsizei; textures: PGLuint; priorities: PGLclampf); stdcall;
Public PushAttrib: procedure(mask: TGLbitfield); stdcall;
Public PushClientAttrib: procedure(mask: TGLbitfield); stdcall;
Public PushMatrix: procedure(); stdcall;
Public PushName: procedure(Name: TGLuint); stdcall;
Public RasterPos2d: procedure(X, y: TGLdouble); stdcall;
Public RasterPos2dv: procedure(v: PGLdouble); stdcall;
Public RasterPos2f: procedure(X, y: TGLfloat); stdcall;
Public RasterPos2fv: procedure(v: PGLfloat); stdcall;
Public RasterPos2i: procedure(X, y: TGLint); stdcall;
Public RasterPos2iv: procedure(v: PGLint); stdcall;
Public RasterPos2s: procedure(X, y: PGLshort); stdcall;
Public RasterPos2sv: procedure(v: PGLshort); stdcall;
Public RasterPos3d: procedure(X, y, z: TGLdouble); stdcall;
Public RasterPos3dv: procedure(v: PGLdouble); stdcall;
Public RasterPos3f: procedure(X, y, z: TGLfloat); stdcall;
Public RasterPos3fv: procedure(v: PGLfloat); stdcall;
Public RasterPos3i: procedure(X, y, z: TGLint); stdcall;
Public RasterPos3iv: procedure(v: PGLint); stdcall;
Public RasterPos3s: procedure(X, y, z: TGLshort); stdcall;
Public RasterPos3sv: procedure(v: PGLshort); stdcall;
Public RasterPos4d: procedure(X, y, z, w: TGLdouble); stdcall;
Public RasterPos4dv: procedure(v: PGLdouble); stdcall;
Public RasterPos4f: procedure(X, y, z, w: TGLfloat); stdcall;
Public RasterPos4fv: procedure(v: PGLfloat); stdcall;
Public RasterPos4i: procedure(X, y, z, w: TGLint); stdcall;
Public RasterPos4iv: procedure(v: PGLint); stdcall;
Public RasterPos4s: procedure(X, y, z, w: TGLshort); stdcall;
Public RasterPos4sv: procedure(v: PGLshort); stdcall;
Public Rectd: procedure(x1, y1, x2, y2: TGLdouble); stdcall;
Public Rectdv: procedure(v1, v2: PGLdouble); stdcall;
Public Rectf: procedure(x1, y1, x2, y2: TGLfloat); stdcall;
Public Rectfv: procedure(v1, v2: PGLfloat); stdcall;
Public Recti: procedure(x1, y1, x2, y2: TGLint); stdcall;
Public Rectiv: procedure(v1, v2: PGLint); stdcall;
Public Rects: procedure(x1, y1, x2, y2: TGLshort); stdcall;
Public Rectsv: procedure(v1, v2: PGLshort); stdcall;
Public RenderMode: function(mode: TGLEnum): TGLint; stdcall;
Public Rotated: procedure(ane, X, y, z: TGLdouble); stdcall;
Public Rotatef: procedure(ane, X, y, z: TGLfloat); stdcall;
Public Scaled: procedure(X, y, z: TGLdouble); stdcall;
Public Scalef: procedure(X, y, z: TGLfloat); stdcall;
Public SelectBuffer: procedure(size: TGLsizei; buffer: PGLuint); stdcall;
Public ShadeModel: procedure(mode: TGLEnum); stdcall;
Public TexCoord1d: procedure(s: TGLdouble); stdcall;
Public TexCoord1dv: procedure(v: PGLdouble); stdcall;
Public TexCoord1f: procedure(s: TGLfloat); stdcall;
Public TexCoord1fv: procedure(v: PGLfloat); stdcall;
Public TexCoord1i: procedure(s: TGLint); stdcall;
Public TexCoord1iv: procedure(v: PGLint); stdcall;
Public TexCoord1s: procedure(s: TGLshort); stdcall;
Public TexCoord1sv: procedure(v: PGLshort); stdcall;
Public TexCoord2d: procedure(s, t: TGLdouble); stdcall;
Public TexCoord2dv: procedure(v: PGLdouble); stdcall;
Public TexCoord2f: procedure(s, t: TGLfloat); stdcall;
Public TexCoord2fv: procedure(v: PGLfloat); stdcall;
Public TexCoord2i: procedure(s, t: TGLint); stdcall;
Public TexCoord2iv: procedure(v: PGLint); stdcall;
Public TexCoord2s: procedure(s, t: TGLshort); stdcall;
Public TexCoord2sv: procedure(v: PGLshort); stdcall;
Public TexCoord3d: procedure(s, t, r: TGLdouble); stdcall;
Public TexCoord3dv: procedure(v: PGLdouble); stdcall;
Public TexCoord3f: procedure(s, t, r: TGLfloat); stdcall;
Public TexCoord3fv: procedure(v: PGLfloat); stdcall;
Public TexCoord3i: procedure(s, t, r: TGLint); stdcall;
Public TexCoord3iv: procedure(v: PGLint); stdcall;
Public TexCoord3s: procedure(s, t, r: TGLshort); stdcall;
Public TexCoord3sv: procedure(v: PGLshort); stdcall;
Public TexCoord4d: procedure(s, t, r, q: TGLdouble); stdcall;
Public TexCoord4dv: procedure(v: PGLdouble); stdcall;
Public TexCoord4f: procedure(s, t, r, q: TGLfloat); stdcall;
Public TexCoord4fv: procedure(v: PGLfloat); stdcall;
Public TexCoord4i: procedure(s, t, r, q: TGLint); stdcall;
Public TexCoord4iv: procedure(v: PGLint); stdcall;
Public TexCoord4s: procedure(s, t, r, q: TGLshort); stdcall;
Public TexCoord4sv: procedure(v: PGLshort); stdcall;
Public TexCoordPointer: procedure(size: TGLint; atype: TGLEnum; stride: TGLsizei; Data: Pointer); stdcall;
Public TexEnvf: procedure(target, pname: TGLEnum; param: TGLfloat); stdcall;
Public TexEnvfv: procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;
Public TexEnvi: procedure(target, pname: TGLEnum; param: TGLint); stdcall;
Public TexEnviv: procedure(target, pname: TGLEnum; params: PGLint); stdcall;
Public TexGend: procedure(coord, pname: TGLEnum; param: TGLdouble); stdcall;
Public TexGendv: procedure(coord, pname: TGLEnum; params: PGLdouble); stdcall;
Public TexGenf: procedure(coord, pname: TGLEnum; param: TGLfloat); stdcall;
Public TexGenfv: procedure(coord, pname: TGLEnum; params: PGLfloat); stdcall;
Public TexGeni: procedure(coord, pname: TGLEnum; param: TGLint); stdcall;
Public TexGeniv: procedure(coord, pname: TGLEnum; params: PGLint); stdcall;
Public Translated: procedure(X, y, z: TGLdouble); stdcall;
Public Translatef: procedure(X, y, z: TGLfloat); stdcall;
Public Vertex2d: procedure(X, y: TGLdouble); stdcall;
Public Vertex2dv: procedure(v: PGLdouble); stdcall;
Public Vertex2f: procedure(X, y: TGLfloat); stdcall;
Public Vertex2fv: procedure(v: PGLfloat); stdcall;
Public Vertex2i: procedure(X, y: TGLint); stdcall;
Public Vertex2iv: procedure(v: PGLint); stdcall;
Public Vertex2s: procedure(X, y: TGLshort); stdcall;
Public Vertex2sv: procedure(v: PGLshort); stdcall;
Public Vertex3d: procedure(X, y, z: TGLdouble); stdcall;
Public Vertex3dv: procedure(v: PGLdouble); stdcall;
Public Vertex3f: procedure(X, y, z: TGLfloat); stdcall;
Public Vertex3fv: procedure(v: PGLfloat); stdcall;
Public Vertex3i: procedure(X, y, z: TGLint); stdcall;
Public Vertex3iv: procedure(v: PGLint); stdcall;
Public Vertex3s: procedure(X, y, z: TGLshort); stdcall;
Public Vertex3sv: procedure(v: PGLshort); stdcall;
Public Vertex4d: procedure(X, y, z, w: TGLdouble); stdcall;
Public Vertex4dv: procedure(v: PGLdouble); stdcall;
Public Vertex4f: procedure(X, y, z, w: TGLfloat); stdcall;
Public Vertex4fv: procedure(v: PGLfloat); stdcall;
Public Vertex4i: procedure(X, y, z, w: TGLint); stdcall;
Public Vertex4iv: procedure(v: PGLint); stdcall;
Public Vertex4s: procedure(X, y, z, w: TGLshort); stdcall;
Public Vertex4sv: procedure(v: PGLshort); stdcall;
Public VertexPointer: procedure(size: TGLint; atype: TGLEnum; stride: TGLsizei; Data: Pointer); stdcall;
Public BlendColor: PFNGLBLENDCOLORPROC;
Public BlendEquation: PFNGLBLENDEQUATIONPROC;
Public DrawRangeElements: PFNGLDRAWRANGEELEMENTSPROC;
Public TexImage3D: PFNGLTEXIMAGE3DPROC;
Public TexSubImage3D: PFNGLTEXSUBIMAGE3DPROC;
Public CopyTexSubImage3D: PFNGLCOPYTEXSUBIMAGE3DPROC;
Public BlendFuncSeparate: PFNGLBLENDFUNCSEPARATEPROC;
Public MultiDrawArrays: PFNGLMULTIDRAWARRAYSPROC;
Public MultiDrawElements: PFNGLMULTIDRAWELEMENTSPROC;
Public PointParameterf: PFNGLPOINTPARAMETERFPROC;
Public PointParameterfv: PFNGLPOINTPARAMETERFVPROC;
Public PointParameteri: PFNGLPOINTPARAMETERIPROC;
Public PointParameteriv: PFNGLPOINTPARAMETERIVPROC;
Public BlendEquationSeparate: PFNGLBLENDEQUATIONSEPARATEPROC;
Public DrawBuffers: PFNGLDRAWBUFFERSPROC;
Public StencilOpSeparate: PFNGLSTENCILOPSEPARATEPROC;
Public StencilFuncSeparate: PFNGLSTENCILFUNCSEPARATEPROC;
Public StencilMaskSeparate: PFNGLSTENCILMASKSEPARATEPROC;
Public LockArrays: PFNGLLOCKARRAYSEXTPROC;
Public UnlockArrays: PFNGLUNLOCKARRAYSEXTPROC;
Public BindBuffer: PFNGLBINDBUFFERPROC;
Public DeleteBuffers: PFNGLDELETEBUFFERSPROC;
Public GenBuffers: PFNGLGENBUFFERSPROC;
Public IsBuffer: PFNGLISBUFFERPROC;
Public BufferData: PFNGLBUFFERDATAPROC;
Public BufferSubData: PFNGLBUFFERSUBDATAPROC;
Public GetBufferSubData: PFNGLGETBUFFERSUBDATAPROC;
Public MapBuffer: PFNGLMAPBUFFERPROC;
Public UnmapBuffer: PFNGLUNMAPBUFFERPROC;
Public GetBufferParameteriv: PFNGLGETBUFFERPARAMETERIVPROC;
Public GetBufferPointerv: PFNGLGETBUFFERPOINTERVPROC;
Public MapBufferRange: PFNGLMAPBUFFERRANGEPROC;
Public FlushMappedBufferRange: PFNGLFLUSHMAPPEDBUFFERRANGEPROC;
Public BindBufferRange: PFNGLBINDBUFFERRANGEPROC;
Public BindBufferOffset: PFNGLBINDBUFFEROFFSETEXTPROC;
Public BindBufferBase: PFNGLBINDBUFFERBASEPROC;
Public TransformFeedbackAttribs: PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC;
Public TransformFeedbackVaryingsNV: PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC;
Public TransformFeedbackVaryings: PFNGLTRANSFORMFEEDBACKVARYINGSPROC;
Public GetTransformFeedbackVarying: PFNGLGETTRANSFORMFEEDBACKVARYINGPROC;
Public BeginTransformFeedback: PFNGLBEGINTRANSFORMFEEDBACKPROC;
Public EndTransformFeedback: PFNGLENDTRANSFORMFEEDBACKPROC;
Public TexBuffer: PFNGLTEXBUFFERPROC;
Public ClearBufferiv: PFNGLCLEARBUFFERIVPROC;
Public ClearBufferuiv: PFNGLCLEARBUFFERUIVPROC;
Public ClearBufferfv: PFNGLCLEARBUFFERFVPROC;
Public ClearBufferfi: PFNGLCLEARBUFFERFIPROC;
Public GetStringi: PFNGLGETSTRINGIPROC;
Public BindVertexArray: PFNGLBINDVERTEXARRAYPROC;
Public DeleteVertexArrays: PFNGLDELETEVERTEXARRAYSPROC;
Public GenVertexArrays: PFNGLGENVERTEXARRAYSPROC;
Public IsVertexArray: PFNGLISVERTEXARRAYPROC;
Public FlushVertexArrayRangeNV: PFNGLFLUSHVERTEXARRAYRANGENVPROC;
Public VertexArrayRangeNV: PFNGLVERTEXARRAYRANGENVPROC;
Public GetUniformIndices: PFNGLGETUNIFORMINDICESPROC;
Public GetActiveUniformsiv: PFNGLGETACTIVEUNIFORMSIVPROC;
Public GetActiveUniformName: PFNGLGETACTIVEUNIFORMNAMEPROC;
Public GetUniformBlockIndex: PFNGLGETUNIFORMBLOCKINDEXPROC;
Public GetActiveUniformBlockiv: PFNGLGETACTIVEUNIFORMBLOCKIVPROC;
Public GetActiveUniformBlockName: PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC;
Public UniformBlockBinding: PFNGLUNIFORMBLOCKBINDINGPROC;
Public CopyBufferSubData: PFNGLCOPYBUFFERSUBDATAPROC;
Public UniformBuffer: PFNGLUNIFORMBUFFEREXTPROC;
Public GetUniformBufferSize: PFNGLGETUNIFORMBUFFERSIZEEXTPROC;
Public GetUniformOffset: PFNGLGETUNIFORMOFFSETEXTPROC;
Public PrimitiveRestartIndex: PFNGLPRIMITIVERESTARTINDEXPROC;
Public DrawElementsBaseVertex: PFNGLDRAWELEMENTSBASEVERTEXPROC;
Public DrawRangeElementsBaseVertex: PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC;
Public DrawElementsInstancedBaseVertex: PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC;
Public MultiDrawElementsBaseVertex: PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC;
Public DrawArraysInstanced: PFNGLDRAWARRAYSINSTANCEDPROC;
Public DrawElementsInstanced: PFNGLDRAWELEMENTSINSTANCEDPROC;
Public VertexAttrib1d: PFNGLVERTEXATTRIB1DPROC;
Public VertexAttrib1dv: PFNGLVERTEXATTRIB1DVPROC;
Public VertexAttrib1f: PFNGLVERTEXATTRIB1FPROC;
Public VertexAttrib1fv: PFNGLVERTEXATTRIB1FVPROC;
Public VertexAttrib1s: PFNGLVERTEXATTRIB1SPROC;
Public VertexAttrib1sv: PFNGLVERTEXATTRIB1SVPROC;
Public VertexAttrib2d: PFNGLVERTEXATTRIB2DPROC;
Public VertexAttrib2dv: PFNGLVERTEXATTRIB2DVPROC;
Public VertexAttrib2f: PFNGLVERTEXATTRIB2FPROC;
Public VertexAttrib2fv: PFNGLVERTEXATTRIB2FVPROC;
Public VertexAttrib2s: PFNGLVERTEXATTRIB2SPROC;
Public VertexAttrib2sv: PFNGLVERTEXATTRIB2SVPROC;
Public VertexAttrib3d: PFNGLVERTEXATTRIB3DPROC;
Public VertexAttrib3dv: PFNGLVERTEXATTRIB3DVPROC;
Public VertexAttrib3f: PFNGLVERTEXATTRIB3FPROC;
Public VertexAttrib3fv: PFNGLVERTEXATTRIB3FVPROC;
Public VertexAttrib3s: PFNGLVERTEXATTRIB3SPROC;
Public VertexAttrib3sv: PFNGLVERTEXATTRIB3SVPROC;
Public VertexAttrib4Nbv: PFNGLVERTEXATTRIB4NBVPROC;
Public VertexAttrib4Niv: PFNGLVERTEXATTRIB4NIVPROC;
Public VertexAttrib4Nsv: PFNGLVERTEXATTRIB4NSVPROC;
Public VertexAttrib4Nub: PFNGLVERTEXATTRIB4NUBPROC;
Public VertexAttrib4Nubv: PFNGLVERTEXATTRIB4NUBVPROC;
Public VertexAttrib4Nuiv: PFNGLVERTEXATTRIB4NUIVPROC;
Public VertexAttrib4Nusv: PFNGLVERTEXATTRIB4NUSVPROC;
Public VertexAttrib4bv: PFNGLVERTEXATTRIB4BVPROC;
Public VertexAttrib4d: PFNGLVERTEXATTRIB4DPROC;
Public VertexAttrib4dv: PFNGLVERTEXATTRIB4DVPROC;
Public VertexAttrib4f: PFNGLVERTEXATTRIB4FPROC;
Public VertexAttrib4fv: PFNGLVERTEXATTRIB4FVPROC;
Public VertexAttrib4iv: PFNGLVERTEXATTRIB4IVPROC;
Public VertexAttrib4s: PFNGLVERTEXATTRIB4SPROC;
Public VertexAttrib4sv: PFNGLVERTEXATTRIB4SVPROC;
Public VertexAttrib4ubv: PFNGLVERTEXATTRIB4UBVPROC;
Public VertexAttrib4uiv: PFNGLVERTEXATTRIB4UIVPROC;
Public VertexAttrib4usv: PFNGLVERTEXATTRIB4USVPROC;
Public VertexAttribPointer: PFNGLVERTEXATTRIBPOINTERPROC;
Public VertexAttribI1i: PFNGLVERTEXATTRIBI1IPROC;
Public VertexAttribI2i: PFNGLVERTEXATTRIBI2IPROC;
Public VertexAttribI3i: PFNGLVERTEXATTRIBI3IPROC;
Public VertexAttribI4i: PFNGLVERTEXATTRIBI4IPROC;
Public VertexAttribI1ui: PFNGLVERTEXATTRIBI1UIPROC;
Public VertexAttribI2ui: PFNGLVERTEXATTRIBI2UIPROC;
Public VertexAttribI3ui: PFNGLVERTEXATTRIBI3UIPROC;
Public VertexAttribI4ui: PFNGLVERTEXATTRIBI4UIPROC;
Public VertexAttribI1iv: PFNGLVERTEXATTRIBI1IVPROC;
Public VertexAttribI2iv: PFNGLVERTEXATTRIBI2IVPROC;
Public VertexAttribI3iv: PFNGLVERTEXATTRIBI3IVPROC;
Public VertexAttribI4iv: PFNGLVERTEXATTRIBI4IVPROC;
Public VertexAttribI1uiv: PFNGLVERTEXATTRIBI1UIVPROC;
Public VertexAttribI2uiv: PFNGLVERTEXATTRIBI2UIVPROC;
Public VertexAttribI3uiv: PFNGLVERTEXATTRIBI3UIVPROC;
Public VertexAttribI4uiv: PFNGLVERTEXATTRIBI4UIVPROC;
Public VertexAttribI4bv: PFNGLVERTEXATTRIBI4BVPROC;
Public VertexAttribI4sv: PFNGLVERTEXATTRIBI4SVPROC;
Public VertexAttribI4ubv: PFNGLVERTEXATTRIBI4UBVPROC;
Public VertexAttribI4usv: PFNGLVERTEXATTRIBI4USVPROC;
Public VertexAttribIPointer: PFNGLVERTEXATTRIBIPOINTERPROC;
Public GetVertexAttribIiv: PFNGLGETVERTEXATTRIBIIVPROC;
Public GetVertexAttribIuiv: PFNGLGETVERTEXATTRIBIUIVPROC;
Public Uniform1ui: PFNGLUNIFORM1UIPROC;
Public Uniform2ui: PFNGLUNIFORM2UIPROC;
Public Uniform3ui: PFNGLUNIFORM3UIPROC;
Public Uniform4ui: PFNGLUNIFORM4UIPROC;
Public Uniform1uiv: PFNGLUNIFORM1UIVPROC;
Public Uniform2uiv: PFNGLUNIFORM2UIVPROC;
Public Uniform3uiv: PFNGLUNIFORM3UIVPROC;
Public Uniform4uiv: PFNGLUNIFORM4UIVPROC;
Public GetUniformuiv: PFNGLGETUNIFORMUIVPROC;
Public BindFragDataLocation: PFNGLBINDFRAGDATALOCATIONPROC;
Public GetFragDataLocation: PFNGLGETFRAGDATALOCATIONPROC;
Public ClampColor: PFNGLCLAMPCOLORPROC;
Public ColorMaski: PFNGLCOLORMASKIPROC;
Public GetBooleani_v: PFNGLGETBOOLEANI_VPROC;
Public GetIntegeri_v: PFNGLGETINTEGERI_VPROC;
Public Enablei: PFNGLENABLEIPROC;
Public Disablei: PFNGLDISABLEIPROC;
Public IsEnabledi: PFNGLISENABLEDIPROC;
Public EnableVertexAttribArray: PFNGLENABLEVERTEXATTRIBARRAYPROC;
Public DisableVertexAttribArray: PFNGLDISABLEVERTEXATTRIBARRAYPROC;
Public VertexAttribDivisor: PFNGLVERTEXATTRIBDIVISORPROC;
Public ClearColorIi: PFNGLCLEARCOLORIIEXTPROC;
Public ClearColorIui: PFNGLCLEARCOLORIUIEXTPROC;
Public TexParameterIiv: PFNGLTEXPARAMETERIIVPROC;
Public TexParameterIuiv: PFNGLTEXPARAMETERIUIVPROC;
Public GetTexParameterIiv: PFNGLGETTEXPARAMETERIIVPROC;
Public GetTexParameterIuiv: PFNGLGETTEXPARAMETERIUIVPROC;
Public PatchParameteri: PFNGLPATCHPARAMETERIPROC;
Public PatchParameterfv: PFNGLPATCHPARAMETERFVPROC;
Public BufferAddressRangeNV: PFNGLBUFFERADDRESSRANGENVPROC;
Public VertexFormatNV: PFNGLVERTEXFORMATNVPROC;
Public NormalFormatNV: PFNGLNORMALFORMATNVPROC;
Public ColorFormatNV: PFNGLCOLORFORMATNVPROC;
Public IndexFormatNV: PFNGLINDEXFORMATNVPROC;
Public TexCoordFormatNV: PFNGLTEXCOORDFORMATNVPROC;
Public EdgeFlagFormatNV: PFNGLEDGEFLAGFORMATNVPROC;
Public SecondaryColorFormatNV: PFNGLSECONDARYCOLORFORMATNVPROC;
Public FogCoordFormatNV: PFNGLFOGCOORDFORMATNVPROC;
Public VertexAttribFormatNV: PFNGLVERTEXATTRIBFORMATNVPROC;
Public VertexAttribIFormatNV: PFNGLVERTEXATTRIBIFORMATNVPROC;
Public GetIntegerui64i_vNV: PFNGLGETINTEGERUI64I_VNVPROC;
Public GetBufferParameterui64vNV: PGNGLGETBUFFERPARAMETERUI64VNV;
Public MakeBufferResidentNV: PFNGLMAKEBUFFERRESIDENTNVPROC;
Public MakeBufferNonResidentNV: PFNGLMAKEBUFFERNONRESIDENTNVPROC;
Public IsBufferResidentNV: PFNGLISBUFFERRESIDENTNVPROC;
Public MakeNamedBufferResidentNV: PFNGLMAKENAMEDBUFFERRESIDENTNVPROC;
Public MakeNamedBufferNonResidentNV: PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC;
Public IsNamedBufferResidentNV: PFNGLISNAMEDBUFFERRESIDENTNVPROC;
Public GetNamedBufferParameterui64vNV: PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC;
Public GetIntegerui64vNV: PFNGLGETINTEGERUI64VNVPROC;
Public Uniformui64NV: PFNGLUNIFORMUI64NVPROC;
Public Uniformui64vNV: PFNGLUNIFORMUI64VNVPROC;
Public GetUniformui64vNV: PFNGLGETUNIFORMUI64VNVPROC;
Public ProgramUniformui64NV: PFNGLPROGRAMUNIFORMUI64NVPROC;
Public ProgramUniformui64vNV: PFNGLPROGRAMUNIFORMUI64VNVPROC;
Public DeleteObject: PFNGLDELETEOBJECTARBPROC;
Public GetHandle: PFNGLGETHANDLEARBPROC;
Public DetachShader: PFNGLDETACHSHADERPROC;
Public CreateShader: PFNGLCREATESHADERPROC;
Public ShaderSource: PFNGLSHADERSOURCEPROC;
Public CompileShader: PFNGLCOMPILESHADERPROC;
Public CreateProgram: PFNGLCREATEPROGRAMPROC;
Public AttachShader: PFNGLATTACHSHADERPROC;
Public LinkProgram: PFNGLLINKPROGRAMPROC;
Public UseProgram: PFNGLUSEPROGRAMPROC;
Public ValidateProgram: PFNGLVALIDATEPROGRAMPROC;
Public Uniform1f: PFNGLUNIFORM1FPROC;
Public Uniform2f: PFNGLUNIFORM2FPROC;
Public Uniform3f: PFNGLUNIFORM3FPROC;
Public Uniform4f: PFNGLUNIFORM4FPROC;
Public Uniform1i: PFNGLUNIFORM1IPROC;
Public Uniform2i: PFNGLUNIFORM2IPROC;
Public Uniform3i: PFNGLUNIFORM3IPROC;
Public Uniform4i: PFNGLUNIFORM4IPROC;
Public Uniform1fv: PFNGLUNIFORM1FVPROC;
Public Uniform2fv: PFNGLUNIFORM2FVPROC;
Public Uniform3fv: PFNGLUNIFORM3FVPROC;
Public Uniform4fv: PFNGLUNIFORM4FVPROC;
Public Uniform1iv: PFNGLUNIFORM1IVPROC;
Public Uniform2iv: PFNGLUNIFORM2IVPROC;
Public Uniform3iv: PFNGLUNIFORM3IVPROC;
Public Uniform4iv: PFNGLUNIFORM4IVPROC;
Public UniformMatrix2fv: PFNGLUNIFORMMATRIX2FVPROC;
Public UniformMatrix3fv: PFNGLUNIFORMMATRIX3FVPROC;
Public UniformMatrix4fv: PFNGLUNIFORMMATRIX4FVPROC;
Public GetObjectParameterfv: PFNGLGETOBJECTPARAMETERFVARBPROC;
Public GetObjectParameteriv: PFNGLGETOBJECTPARAMETERIVARBPROC;
Public GetInfoLog: PFNGLGETINFOLOGARBPROC;
Public GetAttachedObjects: PFNGLGETATTACHEDOBJECTSARBPROC;
Public GetActiveAttrib: PFNGLGETACTIVEATTRIBPROC;
Public GetActiveUniform: PFNGLGETACTIVEUNIFORMPROC;
Public GetAttachedShaders: PFNGLGETATTACHEDSHADERSPROC;
Public GetAttribLocation: PFNGLGETATTRIBLOCATIONPROC;
Public GetProgramiv: PFNGLGETPROGRAMIVPROC;
Public GetProgramInfoLog: PFNGLGETPROGRAMINFOLOGPROC;
Public GetShaderiv: PFNGLGETSHADERIVPROC;
Public GetShaderInfoLog: PFNGLGETSHADERINFOLOGPROC;
Public GetShaderSource: PFNGLGETSHADERSOURCEPROC;
Public GetUniformLocation: PFNGLGETUNIFORMLOCATIONPROC;
Public GetUniformfv: PFNGLGETUNIFORMFVPROC;
Public GetUniformiv: PFNGLGETUNIFORMIVPROC;
Public GetVertexAttribdv: PFNGLGETVERTEXATTRIBDVPROC;
Public GetVertexAttribfv: PFNGLGETVERTEXATTRIBFVPROC;
Public GetVertexAttribiv: PFNGLGETVERTEXATTRIBIVPROC;
Public GetVertexAttribPointerv: PFNGLGETVERTEXATTRIBPOINTERVPROC;
Public IsProgram: PFNGLISPROGRAMPROC;
Public IsShader: PFNGLISSHADERPROC;
Public BindAttribLocation: PFNGLBINDATTRIBLOCATIONPROC;
Public BindFragDataLocationIndexed: PFNGLBINDFRAGDATALOCATIONINDEXEDPROC;
Public GetFragDataIndex: PFNGLGETFRAGDATAINDEXPROC;
Public GetVaryingLocation: PFNGLGETVARYINGLOCATIONNVPROC;
Public GetActiveVarying: PFNGLGETACTIVEVARYINGNVPROC;
Public ActiveVarying: PFNGLACTIVEVARYINGNVPROC;
Public GetProgramBinary: PFNGLGETPROGRAMBINARYPROC;
Public ProgramBinary: PFNGLPROGRAMBINARYPROC;
Public UseProgramStages: PFNGLUSEPROGRAMSTAGESPROC;
Public ActiveShaderProgram: PFNGLACTIVESHADERPROGRAMPROC;
Public CreateShaderProgramv: PFNGLCREATESHADERPROGRAMVPROC;
Public BindProgramPipeline: PFNGLBINDPROGRAMPIPELINEPROC;
Public DeleteProgramPipelines: PFNGLDELETEPROGRAMPIPELINESPROC;
Public GenProgramPipelines: PFNGLGENPROGRAMPIPELINESPROC;
Public IsProgramPipeline: PFNGLISPROGRAMPIPELINEPROC;
Public GetProgramPipelineiv: PFNGLGETPROGRAMPIPELINEIVPROC;
Public ProgramUniform1i: PFNGLPROGRAMUNIFORM1IPROC;
Public ProgramUniform1iv: PFNGLPROGRAMUNIFORM1IVPROC;
Public ProgramUniform1f: PFNGLPROGRAMUNIFORM1FPROC;
Public ProgramUniform1fv: PFNGLPROGRAMUNIFORM1FVPROC;
Public ProgramUniform1d: PFNGLPROGRAMUNIFORM1DPROC;
Public ProgramUniform1dv: PFNGLPROGRAMUNIFORM1DVPROC;
Public ProgramUniform1ui: PFNGLPROGRAMUNIFORM1UIPROC;
Public ProgramUniform1uiv: PFNGLPROGRAMUNIFORM1UIVPROC;
Public ProgramUniform2i: PFNGLPROGRAMUNIFORM2IPROC;
Public ProgramUniform2iv: PFNGLPROGRAMUNIFORM2IVPROC;
Public ProgramUniform2f: PFNGLPROGRAMUNIFORM2FPROC;
Public ProgramUniform2fv: PFNGLPROGRAMUNIFORM2FVPROC;
Public ProgramUniform2d: PFNGLPROGRAMUNIFORM2DPROC;
Public ProgramUniform2dv: PFNGLPROGRAMUNIFORM2DVPROC;
Public ProgramUniform2ui: PFNGLPROGRAMUNIFORM2UIPROC;
Public ProgramUniform2uiv: PFNGLPROGRAMUNIFORM2UIVPROC;
Public ProgramUniform3i: PFNGLPROGRAMUNIFORM3IPROC;
Public ProgramUniform3iv: PFNGLPROGRAMUNIFORM3IVPROC;
Public ProgramUniform3f: PFNGLPROGRAMUNIFORM3FPROC;
Public ProgramUniform3fv: PFNGLPROGRAMUNIFORM3FVPROC;
Public ProgramUniform3d: PFNGLPROGRAMUNIFORM3DPROC;
Public ProgramUniform3dv: PFNGLPROGRAMUNIFORM3DVPROC;
Public ProgramUniform3ui: PFNGLPROGRAMUNIFORM3UIPROC;
Public ProgramUniform3uiv: PFNGLPROGRAMUNIFORM3UIVPROC;
Public ProgramUniform4i: PFNGLPROGRAMUNIFORM4IPROC;
Public ProgramUniform4iv: PFNGLPROGRAMUNIFORM4IVPROC;
Public ProgramUniform4f: PFNGLPROGRAMUNIFORM4FPROC;
Public ProgramUniform4fv: PFNGLPROGRAMUNIFORM4FVPROC;
Public ProgramUniform4d: PFNGLPROGRAMUNIFORM4DPROC;
Public ProgramUniform4dv: PFNGLPROGRAMUNIFORM4DVPROC;
Public ProgramUniform4ui: PFNGLPROGRAMUNIFORM4UIPROC;
Public ProgramUniform4uiv: PFNGLPROGRAMUNIFORM4UIVPROC;
Public ProgramUniformMatrix2fv: PFNGLPROGRAMUNIFORMMATRIX2FVPROC;
Public ProgramUniformMatrix3fv: PFNGLPROGRAMUNIFORMMATRIX3FVPROC;
Public ProgramUniformMatrix4fv: PFNGLPROGRAMUNIFORMMATRIX4FVPROC;
Public ProgramUniformMatrix2dv: PFNGLPROGRAMUNIFORMMATRIX2DVPROC;
Public ProgramUniformMatrix3dv: PFNGLPROGRAMUNIFORMMATRIX3DVPROC;
Public ProgramUniformMatrix4dv: PFNGLPROGRAMUNIFORMMATRIX4DVPROC;
Public ProgramUniformMatrix2x3fv: PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC;
Public ProgramUniformMatrix3x2fv: PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC;
Public ProgramUniformMatrix2x4fv: PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC;
Public ProgramUniformMatrix4x2fv: PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC;
Public ProgramUniformMatrix3x4fv: PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC;
Public ProgramUniformMatrix4x3fv: PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC;
Public ProgramUniformMatrix2x3dv: PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC;
Public ProgramUniformMatrix3x2dv: PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC;
Public ProgramUniformMatrix2x4dv: PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC;
Public ProgramUniformMatrix4x2dv: PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC;
Public ProgramUniformMatrix3x4dv: PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC;
Public ProgramUniformMatrix4x3dv: PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC;
Public ValidateProgramPipeline: PFNGLVALIDATEPROGRAMPIPELINEPROC;
Public GetProgramPipelineInfoLog: PFNGLGETPROGRAMPIPELINEINFOLOGPROC;
Public IsRenderbuffer: PFNGLISRENDERBUFFERPROC;
Public BindRenderbuffer: PFNGLBINDRENDERBUFFERPROC;
Public DeleteRenderbuffers: PFNGLDELETERENDERBUFFERSPROC;
Public GenRenderbuffers: PFNGLGENRENDERBUFFERSPROC;
Public RenderbufferStorage: PFNGLRENDERBUFFERSTORAGEPROC;
Public RenderbufferStorageMultisample: PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC;
Public GetRenderbufferParameteriv: PFNGLGETRENDERBUFFERPARAMETERIVPROC;
Public IsFramebuffer: PFNGLISFRAMEBUFFERPROC;
Public BindFramebuffer: PFNGLBINDFRAMEBUFFERPROC;
Public DeleteFramebuffers: PFNGLDELETEFRAMEBUFFERSPROC;
Public GenFramebuffers: PFNGLGENFRAMEBUFFERSPROC;
Public CheckFramebufferStatus: PFNGLCHECKFRAMEBUFFERSTATUSPROC;
Public FramebufferTexture: PFNGLFRAMEBUFFERTEXTUREPROC;
Public FramebufferTexture1D: PFNGLFRAMEBUFFERTEXTURE1DPROC;
Public FramebufferTexture2D: PFNGLFRAMEBUFFERTEXTURE2DPROC;
Public FramebufferTexture3D: PFNGLFRAMEBUFFERTEXTURE3DPROC;
Public FramebufferTextureLayer: PFNGLFRAMEBUFFERTEXTURELAYERPROC;
Public FramebufferTextureFace: PFNGLFRAMEBUFFERTEXTUREFACEARBPROC;
Public FramebufferRenderbuffer: PFNGLFRAMEBUFFERRENDERBUFFERPROC;
Public GetFramebufferAttachmentParameteriv: PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC;
Public BlitFramebuffer: PFNGLBLITFRAMEBUFFERPROC;
Public GenerateMipmap: PFNGLGENERATEMIPMAPPROC;
Public GenQueries: PFNGLGENQUERIESPROC;
Public DeleteQueries: PFNGLDELETEQUERIESPROC;
Public IsQuery: PFNGLISQUERYPROC;
Public BeginQuery: PFNGLBEGINQUERYPROC;
Public EndQuery: PFNGLENDQUERYPROC;
Public GetQueryiv: PFNGLGETQUERYIVPROC;
Public GetQueryObjectiv: PFNGLGETQUERYOBJECTIVPROC;
Public GetQueryObjectuiv: PFNGLGETQUERYOBJECTUIVPROC;
Public QueryCounter: PFNGLQUERYCOUNTERPROC;
Public GetQueryObjecti64v: PFNGLGETQUERYOBJECTI64VPROC;
Public GetQueryObjectui64v: PFNGLGETQUERYOBJECTUI64VPROC;
Public ActiveTexture: PFNGLACTIVETEXTUREPROC;
Public SampleCoverage: PFNGLSAMPLECOVERAGEPROC;
Public CompressedTexImage3D: PFNGLCOMPRESSEDTEXIMAGE3DPROC;
Public CompressedTexImage2D: PFNGLCOMPRESSEDTEXIMAGE2DPROC;
Public CompressedTexImage1D: PFNGLCOMPRESSEDTEXIMAGE1DPROC;
Public CompressedTexSubImage3D: PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC;
Public CompressedTexSubImage2D: PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC;
Public CompressedTexSubImage1D: PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC;
Public GetCompressedTexImage: PFNGLGETCOMPRESSEDTEXIMAGEPROC;
Public ClientActiveTexture: PFNGLCLIENTACTIVETEXTUREPROC;
Public MultiTexCoord1d: PFNGLMULTITEXCOORD1DPROC;
Public MultiTexCoord1dV: PFNGLMULTITEXCOORD1DVPROC;
Public MultiTexCoord1f: PFNGLMULTITEXCOORD1FPROC;
Public MultiTexCoord1fv: PFNGLMULTITEXCOORD1FVPROC;
Public MultiTexCoord1i: PFNGLMULTITEXCOORD1IPROC;
Public MultiTexCoord1iv: PFNGLMULTITEXCOORD1IVPROC;
Public MultiTexCoord1s: PFNGLMULTITEXCOORD1SPROC;
Public MultiTexCoord1sv: PFNGLMULTITEXCOORD1SVPROC;
Public MultiTexCoord2d: PFNGLMULTITEXCOORD2DPROC;
Public MultiTexCoord2dv: PFNGLMULTITEXCOORD2DVPROC;
Public MultiTexCoord2f: PFNGLMULTITEXCOORD2FPROC;
Public MultiTexCoord2fv: PFNGLMULTITEXCOORD2FVPROC;
Public MultiTexCoord2i: PFNGLMULTITEXCOORD2IPROC;
Public MultiTexCoord2iv: PFNGLMULTITEXCOORD2IVPROC;
Public MultiTexCoord2s: PFNGLMULTITEXCOORD2SPROC;
Public MultiTexCoord2sv: PFNGLMULTITEXCOORD2SVPROC;
Public MultiTexCoord3d: PFNGLMULTITEXCOORD3DPROC;
Public MultiTexCoord3dv: PFNGLMULTITEXCOORD3DVPROC;
Public MultiTexCoord3f: PFNGLMULTITEXCOORD3FPROC;
Public MultiTexCoord3fv: PFNGLMULTITEXCOORD3FVPROC;
Public MultiTexCoord3i: PFNGLMULTITEXCOORD3IPROC;
Public MultiTexCoord3iv: PFNGLMULTITEXCOORD3IVPROC;
Public MultiTexCoord3s: PFNGLMULTITEXCOORD3SPROC;
Public MultiTexCoord3sv: PFNGLMULTITEXCOORD3SVPROC;
Public MultiTexCoord4d: PFNGLMULTITEXCOORD4DPROC;
Public MultiTexCoord4dv: PFNGLMULTITEXCOORD4DVPROC;
Public MultiTexCoord4f: PFNGLMULTITEXCOORD4FPROC;
Public MultiTexCoord4fv: PFNGLMULTITEXCOORD4FVPROC;
Public MultiTexCoord4i: PFNGLMULTITEXCOORD4IPROC;
Public MultiTexCoord4iv: PFNGLMULTITEXCOORD4IVPROC;
Public MultiTexCoord4s: PFNGLMULTITEXCOORD4SPROC;
Public MultiTexCoord4sv: PFNGLMULTITEXCOORD4SVPROC;
Public GetInteger64i_v: PFNGLGETINTEGER64I_VPROC;
Public GetBufferParameteri64v: PFNGLGETBUFFERPARAMETERI64VPROC;
Public ProgramParameteri: PFNGLPROGRAMPARAMETERIPROC;
Public ProgramString: PFNGLPROGRAMSTRINGARBPROC;
Public BindProgram: PFNGLBINDPROGRAMARBPROC;
Public DeletePrograms: PFNGLDELETEPROGRAMSARBPROC;
Public GenPrograms: PFNGLGENPROGRAMSARBPROC;
Public ProgramEnvParameter4d: PFNGLPROGRAMENVPARAMETER4DARBPROC;
Public ProgramEnvParameter4dv: PFNGLPROGRAMENVPARAMETER4DVARBPROC;
Public ProgramEnvParameter4f: PFNGLPROGRAMENVPARAMETER4FARBPROC;
Public ProgramEnvParameter4fv: PFNGLPROGRAMENVPARAMETER4FVARBPROC;
Public ProgramLocalParameter4d: PFNGLPROGRAMLOCALPARAMETER4DARBPROC;
Public ProgramLocalParameter4dv: PFNGLPROGRAMLOCALPARAMETER4DVARBPROC;
Public ProgramLocalParameter4f: PFNGLPROGRAMLOCALPARAMETER4FARBPROC;
Public ProgramLocalParameter4fv: PFNGLPROGRAMLOCALPARAMETER4FVARBPROC;
Public GetProgramEnvParameterdv: PFNGLGETPROGRAMENVPARAMETERDVARBPROC;
Public GetProgramEnvParameterfv: PFNGLGETPROGRAMENVPARAMETERFVARBPROC;
Public GetProgramLocalParameterdv: PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC;
Public GetProgramLocalParameterfv: PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC;
Public TexImage2DMultisample: PFNGLTEXIMAGE2DMULTISAMPLEPROC;
Public TexImage3DMultisample: PFNGLTEXIMAGE3DMULTISAMPLEPROC;
Public GetMultisamplefv: PFNGLGETMULTISAMPLEFVPROC;
Public SampleMaski: PFNGLSAMPLEMASKIPROC;
Public ProvokingVertex: PFNGLPROVOKINGVERTEXPROC;
Public FenceSync: PFNGLFENCESYNCPROC;
Public IsSync: PFNGLISSYNCPROC;
Public DeleteSync: PFNGLDELETESYNCPROC;
Public ClientWaitSync: PFNGLCLIENTWAITSYNCPROC;
Public WaitSync: PFNGLWAITSYNCPROC;
Public GetInteger64v: PFNGLGETINTEGER64VPROC;
Public GetSynciv: PFNGLGETSYNCIVPROC;
Public BlendEquationi: PFNGLBLENDEQUATIONIPROC;
Public BlendEquationSeparatei: PFNGLBLENDEQUATIONSEPARATEIPROC;
Public BlendFunci: PFNGLBLENDFUNCIPROC;
Public BlendFuncSeparatei: PFNGLBLENDFUNCSEPARATEIPROC;
Public MinSampleShading: PFNGLMINSAMPLESHADINGPROC;
Public GenSamplers: PFNGLGENSAMPLERSPROC;
Public DeleteSamplers: PFNGLDELETESAMPLERSPROC;
Public IsSampler: PFNGLISSAMPLERPROC;
Public BindSampler: PFNGLBINDSAMPLERPROC;
Public SamplerParameteri: PFNGLSAMPLERPARAMETERIPROC;
Public SamplerParameteriv: PFNGLSAMPLERPARAMETERIVPROC;
Public SamplerParameterf: PFNGLSAMPLERPARAMETERFPROC;
Public SamplerParameterfv: PFNGLSAMPLERPARAMETERFVPROC;
Public SamplerParameterIiv: PFNGLSAMPLERPARAMETERIIVPROC;
Public SamplerParameterIuiv: PFNGLSAMPLERPARAMETERIUIVPROC;
Public GetSamplerParameteriv: PFNGLGETSAMPLERPARAMETERIVPROC;
Public GetSamplerParameterIiv: PFNGLGETSAMPLERPARAMETERIIVPROC;
Public GetSamplerParameterfv: PFNGLGETSAMPLERPARAMETERFVPROC;
Public GetSamplerParameterIfv: PFNGLGETSAMPLERPARAMETERIFVPROC;
Public ClientAttribDefault: PFNGLCLIENTATTRIBDEFAULTEXTPROC;
Public PushClientAttribDefault: PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC;
Public MatrixLoadf: PFNGLMATRIXLOADFEXTPROC;
Public MatrixLoadd: PFNGLMATRIXLOADDEXTPROC;
Public MatrixMultf: PFNGLMATRIXMULTFEXTPROC;
Public MatrixMultd: PFNGLMATRIXMULTDEXTPROC;
Public MatrixLoadIdentity: PFNGLMATRIXLOADIDENTITYEXTPROC;
Public MatrixRotatef: PFNGLMATRIXROTATEFEXTPROC;
Public MatrixRotated: PFNGLMATRIXROTATEDEXTPROC;
Public MatrixScalef: PFNGLMATRIXSCALEFEXTPROC;
Public MatrixScaled: PFNGLMATRIXSCALEDEXTPROC;
Public MatrixTranslatef: PFNGLMATRIXTRANSLATEFEXTPROC;
Public MatrixTranslated: PFNGLMATRIXTRANSLATEDEXTPROC;
Public MatrixFrustum: PFNGLMATRIXFRUSTUMEXTPROC;
Public MatrixOrtho: PFNGLMATRIXORTHOEXTPROC;
Public MatrixPop: PFNGLMATRIXPOPEXTPROC;
Public MatrixPush: PFNGLMATRIXPUSHEXTPROC;
Public MatrixLoadTransposef: PFNGLMATRIXLOADTRANSPOSEFEXTPROC;
Public MatrixLoadTransposed: PFNGLMATRIXLOADTRANSPOSEDEXTPROC;
Public MatrixMultTransposef: PFNGLMATRIXMULTTRANSPOSEFEXTPROC;
Public MatrixMultTransposed: PFNGLMATRIXMULTTRANSPOSEDEXTPROC;
Public TextureParameterf: PFNGLTEXTUREPARAMETERFEXTPROC;
Public TextureParameterfv: PFNGLTEXTUREPARAMETERFVEXTPROC;
Public TextureParameteri: PFNGLTEXTUREPARAMETERIEXTPROC;
Public TextureParameteriv: PFNGLTEXTUREPARAMETERIVEXTPROC;
Public TextureImage1D: PFNGLTEXTUREIMAGE1DEXTPROC;
Public TextureImage2D: PFNGLTEXTUREIMAGE2DEXTPROC;
Public TextureSubImage1D: PFNGLTEXTURESUBIMAGE1DEXTPROC;
Public TextureSubImage2D: PFNGLTEXTURESUBIMAGE2DEXTPROC;
Public CopyTextureImage1D: PFNGLCOPYTEXTUREIMAGE1DEXTPROC;
Public CopyTextureImage2D: PFNGLCOPYTEXTUREIMAGE2DEXTPROC;
Public CopyTextureSubImage1D: PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC;
Public CopyTextureSubImage2D: PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC;
Public GetTextureImage: PFNGLGETTEXTUREIMAGEEXTPROC;
Public GetTextureParameterfv: PFNGLGETTEXTUREPARAMETERFVEXTPROC;
Public GetTextureParameteriv: PFNGLGETTEXTUREPARAMETERIVEXTPROC;
Public GetTextureLevelParameterfv: PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC;
Public GetTextureLevelParameteriv: PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC;
Public TextureImage3D: PFNGLTEXTUREIMAGE3DEXTPROC;
Public TextureSubImage3D: PFNGLTEXTURESUBIMAGE3DEXTPROC;
Public CopyTextureSubImage3D: PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC;
Public MultiTexParameterf: PFNGLMULTITEXPARAMETERFEXTPROC;
Public MultiTexParameterfv: PFNGLMULTITEXPARAMETERFVEXTPROC;
Public MultiTexParameteri: PFNGLMULTITEXPARAMETERIEXTPROC;
Public MultiTexParameteriv: PFNGLMULTITEXPARAMETERIVEXTPROC;
Public MultiTexImage1D: PFNGLMULTITEXIMAGE1DEXTPROC;
Public MultiTexImage2D: PFNGLMULTITEXIMAGE2DEXTPROC;
Public MultiTexSubImage1D: PFNGLMULTITEXSUBIMAGE1DEXTPROC;
Public MultiTexSubImage2D: PFNGLMULTITEXSUBIMAGE2DEXTPROC;
Public CopyMultiTexImage1D: PFNGLCOPYMULTITEXIMAGE1DEXTPROC;
Public CopyMultiTexImage2D: PFNGLCOPYMULTITEXIMAGE2DEXTPROC;
Public CopyMultiTexSubImage1D: PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC;
Public CopyMultiTexSubImage2D: PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC;
Public GetMultiTexImage: PFNGLGETMULTITEXIMAGEEXTPROC;
Public GetMultiTexParameterfv: PFNGLGETMULTITEXPARAMETERFVEXTPROC;
Public GetMultiTexParameteriv: PFNGLGETMULTITEXPARAMETERIVEXTPROC;
Public GetMultiTexLevelParameterfv: PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC;
Public GetMultiTexLevelParameteriv: PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC;
Public MultiTexImage3D: PFNGLMULTITEXIMAGE3DEXTPROC;
Public MultiTexSubImage3D: PFNGLMULTITEXSUBIMAGE3DEXTPROC;
Public CopyMultiTexSubImage3D: PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC;
Public BindMultiTexture: PFNGLBINDMULTITEXTUREEXTPROC;
Public EnableClientStateIndexed: PFNGLENABLECLIENTSTATEINDEXEDEXTPROC;
Public DisableClientStateIndexed: PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC;
Public MultiTexCoordPointer: PFNGLMULTITEXCOORDPOINTEREXTPROC;
Public MultiTexEnvf: PFNGLMULTITEXENVFEXTPROC;
Public MultiTexEnvfv: PFNGLMULTITEXENVFVEXTPROC;
Public MultiTexEnvi: PFNGLMULTITEXENVIEXTPROC;
Public MultiTexEnviv: PFNGLMULTITEXENVIVEXTPROC;
Public MultiTexGend: PFNGLMULTITEXGENDEXTPROC;
Public MultiTexGendv: PFNGLMULTITEXGENDVEXTPROC;
Public MultiTexGenf: PFNGLMULTITEXGENFEXTPROC;
Public MultiTexGenfv: PFNGLMULTITEXGENFVEXTPROC;
Public MultiTexGeni: PFNGLMULTITEXGENIEXTPROC;
Public MultiTexGeniv: PFNGLMULTITEXGENIVEXTPROC;
Public GetMultiTexEnvfv: PFNGLGETMULTITEXENVFVEXTPROC;
Public GetMultiTexEnviv: PFNGLGETMULTITEXENVIVEXTPROC;
Public GetMultiTexGendv: PFNGLGETMULTITEXGENDVEXTPROC;
Public GetMultiTexGenfv: PFNGLGETMULTITEXGENFVEXTPROC;
Public GetMultiTexGeniv: PFNGLGETMULTITEXGENIVEXTPROC;
Public GetFloatIndexedv: PFNGLGETFLOATINDEXEDVEXTPROC;
Public GetDoubleIndexedv: PFNGLGETDOUBLEINDEXEDVEXTPROC;
Public GetPointerIndexedv: PFNGLGETPOINTERINDEXEDVEXTPROC;
Public CompressedTextureImage3D: PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC;
Public CompressedTextureImage2D: PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC;
Public CompressedTextureImage1D: PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC;
Public CompressedTextureSubImage3D: PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC;
Public CompressedTextureSubImage2D: PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC;
Public CompressedTextureSubImage1D: PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC;
Public GetCompressedTextureImage: PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC;
Public CompressedMultiTexImage3D: PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC;
Public CompressedMultiTexImage2D: PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC;
Public CompressedMultiTexImage1D: PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC;
Public CompressedMultiTexSubImage3D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC;
Public CompressedMultiTexSubImage2D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC;
Public CompressedMultiTexSubImage1D: PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC;
Public GetCompressedMultiTexImage: PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC;
Public NamedProgramString: PFNGLNAMEDPROGRAMSTRINGEXTPROC;
Public NamedProgramLocalParameter4d: PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC;
Public NamedProgramLocalParameter4dv: PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC;
Public NamedProgramLocalParameter4f: PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC;
Public NamedProgramLocalParameter4fv: PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC;
Public GetNamedProgramLocalParameterdv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC;
Public GetNamedProgramLocalParameterfv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC;
Public GetNamedProgramiv: PFNGLGETNAMEDPROGRAMIVEXTPROC;
Public GetNamedProgramString: PFNGLGETNAMEDPROGRAMSTRINGEXTPROC;
Public NamedProgramLocalParameters4fv: PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC;
Public NamedProgramLocalParameterI4i: PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC;
Public NamedProgramLocalParameterI4iv: PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC;
Public NamedProgramLocalParametersI4iv: PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC;
Public NamedProgramLocalParameterI4ui: PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC;
Public NamedProgramLocalParameterI4uiv: PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC;
Public NamedProgramLocalParametersI4uiv: PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC;
Public GetNamedProgramLocalParameterIiv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC;
Public GetNamedProgramLocalParameterIuiv: PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC;
Public TextureParameterIiv: PFNGLTEXTUREPARAMETERIIVEXTPROC;
Public TextureParameterIuiv: PFNGLTEXTUREPARAMETERIUIVEXTPROC;
Public GetTextureParameterIiv: PFNGLGETTEXTUREPARAMETERIIVEXTPROC;
Public GetTextureParameterIuiv: PFNGLGETTEXTUREPARAMETERIUIVEXTPROC;
Public MultiTexParameterIiv: PFNGLMULTITEXPARAMETERIIVEXTPROC;
Public MultiTexParameterIuiv: PFNGLMULTITEXPARAMETERIUIVEXTPROC;
Public GetMultiTexParameterIiv: PFNGLGETMULTITEXPARAMETERIIVEXTPROC;
Public GetMultiTexParameterIuiv: PFNGLGETMULTITEXPARAMETERIUIVEXTPROC;
Public NamedBufferData: PFNGLNAMEDBUFFERDATAEXTPROC;
Public NamedBufferSubData: PFNGLNAMEDBUFFERSUBDATAEXTPROC;
Public MapNamedBuffer: PFNGLMAPNAMEDBUFFEREXTPROC;
Public UnmapNamedBuffer: PFNGLUNMAPNAMEDBUFFEREXTPROC;
Public MapNamedBufferRange: PFNGLMAPNAMEDBUFFERRANGEEXTPROC;
Public FlushMappedNamedBufferRange: PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC;
Public NamedCopyBufferSubData: PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC;
Public GetNamedBufferParameteriv: PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC;
Public GetNamedBufferPointerv: PFNGLGETNAMEDBUFFERPOINTERVEXTPROC;
Public GetNamedBufferSubData: PFNGLGETNAMEDBUFFERSUBDATAEXTPROC;
Public TextureBuffer: PFNGLTEXTUREBUFFEREXTPROC;
Public MultiTexBuffer: PFNGLMULTITEXBUFFEREXTPROC;
Public NamedRenderbufferStorage: PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC;
Public GetNamedRenderbufferParameteriv: PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC;
Public CheckNamedFramebufferStatus: PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC;
Public NamedFramebufferTexture1D: PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC;
Public NamedFramebufferTexture2D: PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC;
Public NamedFramebufferTexture3D: PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC;
Public NamedFramebufferRenderbuffer: PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC;
Public GetNamedFramebufferAttachmentParameteriv: PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC;
Public GenerateTextureMipmap: PFNGLGENERATETEXTUREMIPMAPEXTPROC;
Public GenerateMultiTexMipmap: PFNGLGENERATEMULTITEXMIPMAPEXTPROC;
Public FramebufferDrawBuffer: PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC;
Public FramebufferDrawBuffers: PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC;
Public FramebufferReadBuffer: PFNGLFRAMEBUFFERREADBUFFEREXTPROC;
Public GetFramebufferParameteriv: PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC;
Public NamedRenderbufferStorageMultisample: PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC;
Public NamedRenderbufferStorageMultisampleCoverage: PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC;
Public NamedFramebufferTexture: PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC;
Public NamedFramebufferTextureLayer: PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC;
Public NamedFramebufferTextureFace: PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC;
Public TextureRenderbuffer: PFNGLTEXTURERENDERBUFFEREXTPROC;
Public MultiTexRenderbuffer: PFNGLMULTITEXRENDERBUFFEREXTPROC;
Public FrameTerminatorGREMEDY: PFNGLFRAMETERMINATORGREMEDYPROC;
Public StringMarkerGREMEDY: PFNGLSTRINGMARKERGREMEDYPROC;
Public DebugMessageEnableAMDX: procedure(category: GLenum; severity: GLenum; Count: GLSizei; var ids: GLuint; Enabled: boolean); stdcall;
Public DebugMessageCallbackAMDX: procedure(callback: TDebugProcAMD; userParam: Pointer); stdcall;
Public DebugMessageControl: procedure(type_: GLenum; Source: GLenum; severity: GLenum; Count: GLSizei; var ids: GLuint; Enabled: boolean); stdcall;
Public DebugMessageInsert: procedure(Source: GLenum; severity: GLenum; id: GLuint; length: GLSizei; const buf: PGLChar); stdcall;
Public DebugMessageCallback: procedure(callback: TDebugProc; userParam: Pointer); stdcall;
Public GetDebugMessageLog: function(Count: GLuint; bufSize: GLSizei; var severity: GLenum; var severities: GLuint; var ids: GLuint; var lengths: GLSizei; messageLog: PGLChar): GLuint; stdcall;
Public GenPathsNV: PFNGLGENPATHSNVPROC;
Public DeletePathsNV: PFNGLDELETEPATHSNVPROC;
Public IsPathNV: PFNGLISPATHNVPROC;
Public PathCommandsNV: PFNGLPATHCOMMANDSNVPROC;
Public PathCoordsNV: PFNGLPATHCOORDSNVPROC;
Public PathSubCommandsNV: PFNGLPATHSUBCOMMANDSNVPROC;
Public PathSubCoordsNV: PFNGLPATHSUBCOORDSNVPROC;
Public PathStringNV: PFNGLPATHSTRINGNVPROC;
Public PathGlyphsNV: PFNGLPATHGLYPHSNVPROC;
Public PathGlyphRangeNV: PFNGLPATHGLYPHRANGENVPROC;
Public WeightPathsNV: PFNGLWEIGHTPATHSNVPROC;
Public CopyPathNV: PFNGLCOPYPATHNVPROC;
Public InterpolatePathsNV: PFNGLINTERPOLATEPATHSNVPROC;
Public PathParameterivNV: PFNGLPATHPARAMETERIVNVPROC;
Public PathParameteriNV: PFNGLPATHPARAMETERINVPROC;
Public PathParameterfvNV: PFNGLPATHPARAMETERFVNVPROC;
Public PathParameterfNV: PFNGLPATHPARAMETERFNVPROC;
Public PathDashArrayNV: PFNGLPATHDASHARRAYNVPROC;
Public PathStencilFuncNV: PFNGLPATHSTENCILFUNCNVPROC;
Public StencilFillPathNV: PFNGLSTENCILFILLPATHNVPROC;
Public StencilStrokePathNV: PFNGLSTENCILSTROKEPATHNVPROC;
Public StencilFillPathInstancedNV: PFNGLSTENCILFILLPATHINSTANCEDNVPROC;
Public StencilStrokePathInstancedNV: PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC;
Public PathColorGenNV: PFNGLPATHCOLORGENNVPROC;
Public PathTexGenNV: PFNGLPATHTEXGENNVPROC;
Public PathFogGenNV: PFNGLPATHFOGGENNVPROC;
Public CoverFillPathNV: PFNGLCOVERFILLPATHNVPROC;
Public CoverStrokePathNV: PFNGLCOVERSTROKEPATHNVPROC;
Public CoverFillPathInstancedNV: PFNGLCOVERFILLPATHINSTANCEDNVPROC;
Public CoverStrokePathInstancedNV: PFNGLCOVERSTROKEPATHINSTANCEDNVPROC;
Public GetPathParameterivNV: PFNGLGETPATHPARAMETERIVNVPROC;
Public GetPathParameterfvNV: PFNGLGETPATHPARAMETERFVNVPROC;
Public GetPathCommandsNV: PFNGLGETPATHCOMMANDSNVPROC;
Public GetPathCoordsNV: PFNGLGETPATHCOORDSNVPROC;
Public GetPathDashArrayNV: PFNGLGETPATHDASHARRAYNVPROC;
Public GetPathMetricsNV: PFNGLGETPATHMETRICSNVPROC;
Public GetPathMetricRangeNV: PFNGLGETPATHMETRICRANGENVPROC;
Public GetPathSpacingNV: PFNGLGETPATHSPACINGNVPROC;
Public GetPathColorGenivNV: PFNGLGETPATHCOLORGENIVNVPROC;
Public GetPathColorGenfvNV: PFNGLGETPATHCOLORGENFVNVPROC;
Public GetPathTexGenivNV: PFNGLGETPATHTEXGENIVNVPROC;
Public GetPathTexGenfvNV: PFNGLGETPATHTEXGENFVNVPROC;
Public IsPointInFillPathNV: PFNGLISPOINTINFILLPATHNVPROC;
Public IsPointInStrokePathNV: PFNGLISPOINTINSTROKEPATHNVPROC;
Public GetPathLengthNV: PFNGLGETPATHLENGTHNVPROC;
Public PointAlongPathNV: PFNGLPOINTALONGPATHNVPROC;
Public PathStencilDepthOffsetNV: PFNGLPATHSTENCILDEPTHOFFSETNVPROC;
Public PathCoverDepthFuncNV: PFNGLPATHCOVERDEPTHFUNCNVPROC;
Public W_ARB_buffer_region: boolean;
Public W_ARB_create_context: boolean;
Public W_ARB_create_context_profile: boolean;
Public W_ARB_extensions_string: boolean;
Public W_ARB_framebuffer_sRGB: boolean;
Public W_ARB_make_current_read: boolean;
Public W_ARB_multisample: boolean;
Public W_ARB_pbuffer: boolean;
Public W_ARB_pixel_format: boolean;
Public W_ARB_pixel_format_float: boolean;
Public W_ARB_render_texture: boolean;
Public W_ATI_pixel_format_float: boolean;
Public W_EXT_framebuffer_sRGB: boolean;
Public W_EXT_pixel_format_packed_float: boolean;
Public W_EXT_swap_control: boolean;
Public W_NV_gpu_affinity: boolean;
Public W_EXT_create_context_es2_profile: boolean;
Public W_NV_DX_interop: boolean;
Public W_NV_DX_interop2: boolean;
Public WCreateBufferRegionARB: PFNWGLCREATEBUFFERREGIONARBPROC;
Public WDeleteBufferRegionARB: PFNWGLDELETEBUFFERREGIONARBPROC;
Public WSaveBufferRegionARB: PFNWGLSAVEBUFFERREGIONARBPROC;
Public WRestoreBufferRegionARB: PFNWGLRESTOREBUFFERREGIONARBPROC;
Public WGetExtensionsStringARB: PFNWGLGETEXTENSIONSSTRINGARBPROC;
Public WGetPixelFormatAttribivARB: PFNWGLGETPIXELFORMATATTRIBIVARBPROC;
Public WGetPixelFormatAttribfvARB: PFNWGLGETPIXELFORMATATTRIBFVARBPROC;
Public WChoosePixelFormatARB: PFNWGLCHOOSEPIXELFORMATARBPROC;
Public WMakeContextCurrentARB: PFNWGLMAKECONTEXTCURRENTARBPROC;
Public WGetCurrentReadDCARB: PFNWGLGETCURRENTREADDCARBPROC;
Public WCreatePbufferARB: PFNWGLCREATEPBUFFERARBPROC;
Public WGetPbufferDCARB: PFNWGLGETPBUFFERDCARBPROC;
Public WReleasePbufferDCARB: PFNWGLRELEASEPBUFFERDCARBPROC;
Public WDestroyPbufferARB: PFNWGLDESTROYPBUFFERARBPROC;
Public WQueryPbufferARB: PFNWGLQUERYPBUFFERARBPROC;
Public WBindTexImageARB: PFNWGLBINDTEXIMAGEARBPROC;
Public WReleaseTexImageARB: PFNWGLRELEASETEXIMAGEARBPROC;
Public WSetPbufferAttribARB: PFNWGLSETPBUFFERATTRIBARBPROC;
Public WCreateContextAttribsARB: PFNWGLCREATECONTEXTATTRIBSARBPROC;
Public WEnumGpusNV: PFNWGLENUMGPUSNVPROC;
Public WEnumGpuDevicesNV: PFNWGLENUMGPUDEVICESNVPROC;
Public WCreateAffinityDCNV: PFNWGLCREATEAFFINITYDCNVPROC;
Public WEnumGpusFromAffinityDCNV: PFNWGLENUMGPUSFROMAFFINITYDCNVPROC;
Public WDeleteDCNV: PFNWGLDELETEDCNVPROC;
Public WDXSetResourceShareHandleNV: PFNWGLDXSETRESOURCESHAREHANDLEPROC;
Public WDXOpenDeviceNV: PFNWGLDXOPENDEVICEPROC;
Public WDXCloseDeviceNV: PFNWGLDXCLOSEDEVICEPROC;
Public WDXRegisterObjectNV: PFNWGLDXREGISTEROBJECTPROC;
Public WDXUnregisterObjectNV: PFNWGLDXUNREGISTEROBJECTPROC;
Public WDXObjectAccessNV: PFNWGLDXOBJECTACCESSPROC;
Public WDXLockObjectsNV: PFNWGLDXLOCKOBJECTSPROC;
Public WDXUnlockObjectsNV: PFNWGLDXUNLOCKOBJECTSNVPROC;
Public WSwapIntervalEXT: PFNWGLSWAPINTERVALEXTPROC;
Public WGetSwapIntervalEXT: PFNWGLGETSWAPINTERVALEXTPROC;
Public WAllocateMemoryNV: PFNWGLALLOCATEMEMORYNVPROC;
Public WFreeMemoryNV: PFNWGLFREEMEMORYNVPROC;
Public UNurbsCallbackDataEXT: procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;
Public UNewNurbsTessellatorEXT: function: PGLUnurbs; stdcall;
Public UDeleteNurbsTessellatorEXT: procedure(nurb: PGLUnurbs); stdcall;

Methods

Public constructor Create;
Public procedure CheckError;
Public procedure ClearError;
Public procedure Close;
Public procedure Initialize(ATemporary: boolean = False);

Properties

Public property DebugMode: boolean read FDebug write FDebug;
Public property IsInitialized: boolean read FInitialized;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:25


GLScene v.1.1.2: OpenGLTokens

Unit OpenGLTokens

Description

uses

Classes, Interfaces, Objects and Records

Functions and Procedures

Types

Constants

Variables

Description

OpenGLTokens<p>
<b>History : </b><font size=-1><ul> <li>17/12/12 - PW - Added CPP compatibility: changed PWGLSwap to PWGLswap to exclude ambiquity with 'Winapi::Windows::PWGLSwap' <li>21/08/11 - Yar - Added OpenGL ES <li>31/07/11 - Yar - Added types and constants for GL_NV_Path_rendering <li>23/01/11 - DanB - Added OpenGL procedural types, OpenGL 4.1 + ARB extensions <li>14/10/10 - Yar - Moved GLU types and constants from OpenGL1x <li>03/08/10 - Yar - Moved from OpenGL1x types and constants </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name

Description

packed record _WGLSWAP

record TGPUDevice

record TGLUNurbs

record TGLUQuadric

record TGLUTesselator

Types

PGLChar = PAnsiChar;

TGLString = AnsiString;

GLenum = UINT;

TGLenum = UINT;

PGLenum = ˆTGLenum;

GLboolean = BYTEBOOL;

TGLboolean = BYTEBOOL;

PGLboolean = ˆTGLboolean;

GLbitfield = UINT;

TGLbitfield = UINT;

PGLbitfield = ˆTGLbitfield;

GLbyte = ShortInt;

TGLbyte = ShortInt;

PGLbyte = ˆTGLbyte;

GLshort = SmallInt;

TGLshort = SmallInt;

PGLshort = ˆTGLshort;

GLint = Integer;

TGLint = Integer;

PGLint = ˆInteger;

GLsizei = Integer;

TGLsizei = Integer;

PGLsizei = ˆTGLsizei;

GLint64 = Int64;

TGLint64 = Int64;

PGLint64 = ˆTGLInt64;

GLint64EXT = Int64;

TGLint64EXT = Int64;

PGLint64EXT = ˆTGLint64EXT;

GLuint64 = UInt64;

TGLuint64 = UInt64;

PGLuint64 = ˆTGLuint64;

GLuint64EXT = UInt64;

TGLuint64EXT = UInt64;

PGLuint64EXT = ˆTGLuint64EXT;

GLubyte = Byte;

TGLubyte = Byte;

PGLubyte = System.PByte;

GLushort = Word;

TGLushort = Word;

PGLushort = System.PWord;

GLuint = UINT;

TGLuint = UINT;

PGLuint = ˆTGLuint;

GLfloat = Single;

TGLfloat = Single;

PGLfloat = System.PSingle;

GLclampf = Single;

TGLclampf = Single;

PGLclampf = ˆTGLclampf;

GLdouble = Double;

TGLdouble = Double;

PGLdouble = System.PDouble;

GLclampd = Double;

TGLclampd = Double;

PGLclampd = ˆTGLclampd;

GLhandleARB = Cardinal;

PGLhandleARB = ˆGLhandleARB;

PGLPCharArray = ˆPGLChar;

PGLvoid = Pointer;

PGLPointer = ˆPointer;

GLintptr = PtrInt;

TGLintptr = PtrInt;

GLsizeiptr = SizeInt;

TGLsizeiptr = SizeInt;

GLsync = PtrInt;

TGLsync = PtrInt;

PWGLswap = ˆTWGLswap;

TWGLswap = _WGLSWAP;

WGLSWAP = _WGLSWAP;

HPBUFFERARB = Integer;

PHGPUNV = ˆHGPUNV;

HGPUNV = THandle;

PGPUDevice = ˆTGPUDevice;

TDebugProc = procedure( source: GLenum; type_: GLenum; id: GLuint; severity: GLenum; length: GLsizei; const message: PGLchar; userParam: Pointer); stdcall;

TGLDEBUGPROCARB = TDebugProc;

TDebugProcAMD = procedure( id: GLuint; category: GLenum; severity: GLenum; length: GLsizei; message: PGLchar; userParam: Pointer); stdcall;

TGLvdpauSurfaceNV = GLintptr;

PGLvdpauSurfaceNV = ˆTGLvdpauSurfaceNV;

PGLUNurbs = ˆTGLUNurbs;

PGLUQuadric = ˆTGLUQuadric;

PGLUTesselator= ˆTGLUTesselator;

TGLUNurbsObj = TGLUNurbs;

TGLUQuadricObj = TGLUQuadric;

TGLUTesselatorObj = TGLUTesselator;

TGLUTriangulatorObj = TGLUTesselator;

PGLUNurbsObj = PGLUNurbs;

PGLUQuadricObj = PGLUQuadric;

PGLUTesselatorObj = PGLUTesselator;

PGLUTriangulatorObj = PGLUTesselator;

TGLUQuadricErrorProc = procedure(errorCode: TGLEnum); stdcall;

TGLUTessBeginProc = procedure(AType: TGLEnum); stdcall;

TGLUTessEdgeFlagProc = procedure(Flag: TGLboolean); stdcall;

TGLUTessVertexProc = procedure(VertexData: Pointer); stdcall;

TGLUTessEndProc = procedure; stdcall;

TGLUTessErrorProc = procedure(ErrNo: TGLEnum); stdcall;

TGLUTessCombineProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer); stdcall;

TGLUTessBeginDataProc = procedure(AType: TGLEnum; UserData: Pointer); stdcall;

TGLUTessEdgeFlagDataProc = procedure(Flag: TGLboolean; UserData: Pointer); stdcall;

TGLUTessVertexDataProc = procedure(VertexData: Pointer; UserData: Pointer); stdcall;

TGLUTessEndDataProc = procedure(UserData: Pointer); stdcall;

TGLUTessErrorDataProc = procedure(ErrNo: TGLEnum; UserData: Pointer); stdcall;

TGLUTessCombineDataProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer; UserData: Pointer); stdcall;

TGLUNurbsErrorProc = procedure(ErrorCode: TGLEnum); stdcall;

PFNGLBLENDCOLORPROC = procedure(red, green, blue, alpha: TGLclampf); stdcall;

PFNGLBLENDEQUATIONPROC = procedure(mode: TGLEnum); stdcall;

PFNGLDRAWRANGEELEMENTSPROC = procedure(mode: TGLEnum; Astart, Aend: TGLuint; count: TGLsizei; Atype: TGLEnum; indices: Pointer); stdcall;

PFNGLTEXIMAGE3DPROC = procedure(target: TGLEnum; level: TGLint; internalformat: TGLEnum; width, height, depth: TGLsizei; border: TGLint; format: TGLEnum; Atype: TGLEnum; pixels: Pointer); stdcall;

PFNGLTEXSUBIMAGE3DPROC = procedure(target: TGLEnum; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format: TGLEnum; Atype: TGLEnum; pixels: Pointer); stdcall;

PFNGLCOPYTEXSUBIMAGE3DPROC = procedure(target: TGLEnum; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

PFNGLCOLORTABLEPROC = procedure(target, internalformat: TGLEnum; width: TGLsizei; format, Atype: TGLEnum; table: Pointer); stdcall;

PFNGLCOLORTABLEPARAMETERFVPROC = procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;

PFNGLCOLORTABLEPARAMETERIVPROC = procedure(target, pname: TGLEnum; params: PGLint); stdcall;

PFNGLCOPYCOLORTABLEPROC = procedure(target, internalformat: TGLEnum; x, y: TGLint; width: TGLsizei); stdcall;

PFNGLGETCOLORTABLEPROC = procedure(target, format, Atype: TGLEnum; table: Pointer); stdcall;

PFNGLGETCOLORTABLEPARAMETERFVPROC = procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;

PFNGLGETCOLORTABLEPARAMETERIVPROC = procedure(target, pname: TGLEnum; params: PGLint); stdcall;

PFNGLCOLORSUBTABLEPROC = procedure(target: TGLEnum; start, count: TGLsizei; format, Atype: TGLEnum; data: Pointer); stdcall;

PFNGLCOPYCOLORSUBTABLEPROC = procedure(target: TGLEnum; start: TGLsizei; x, y: TGLint; width: TGLsizei); stdcall;

PFNGLCONVOLUTIONFILTER1DPROC = procedure(target, internalformat: TGLEnum; width: TGLsizei; format, Atype: TGLEnum; image: Pointer); stdcall;

PFNGLCONVOLUTIONFILTER2DPROC = procedure(target, internalformat: TGLEnum; width, height: TGLsizei; format, Atype: TGLEnum; image: Pointer); stdcall;

PFNGLCONVOLUTIONPARAMETERFPROC = procedure(target, pname: TGLEnum; param: TGLfloat); stdcall;

PFNGLCONVOLUTIONPARAMETERFVPROC = procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;

PFNGLCONVOLUTIONPARAMETERIPROC = procedure(target, pname: TGLEnum; param: TGLint); stdcall;

PFNGLCONVOLUTIONPARAMETERIVPROC = procedure(target, pname: TGLEnum; params: PGLint); stdcall;

PFNGLCOPYCONVOLUTIONFILTER1DPROC = procedure(target, internalformat: TGLEnum; x, y: TGLint; width: TGLsizei); stdcall;

PFNGLCOPYCONVOLUTIONFILTER2DPROC = procedure(target, internalformat: TGLEnum; x, y: TGLint; width, height: TGLsizei); stdcall;

PFNGLGETCONVOLUTIONFILTERPROC = procedure(target, internalformat, Atype: TGLEnum; image: Pointer); stdcall;

PFNGLGETCONVOLUTIONPARAMETERFVPROC = procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;

PFNGLGETCONVOLUTIONPARAMETERIVPROC = procedure(target, pname: TGLEnum; params: PGLint); stdcall;

PFNGLGETSEPARABLEFILTERPROC = procedure(target, format, Atype: TGLEnum; row, column, span: Pointer); stdcall;

PFNGLSEPARABLEFILTER2DPROC = procedure(target, internalformat: TGLEnum; width, height: TGLsizei; format, Atype: TGLEnum; row, column: Pointer); stdcall;

PFNGLGETHISTOGRAMPROC = procedure(target: TGLEnum; reset: TGLboolean; format, Atype: TGLEnum; values: Pointer); stdcall;

PFNGLGETHISTOGRAMPARAMETERFVPROC = procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;

PFNGLGETHISTOGRAMPARAMETERIVPROC = procedure(target, pname: TGLEnum; params: PGLint); stdcall;

PFNGLGETMINMAXPROC = procedure(target: TGLEnum; reset: TGLboolean; format, Atype: TGLEnum; values: Pointer); stdcall;

PFNGLGETMINMAXPARAMETERFVPROC = procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;

PFNGLGETMINMAXPARAMETERIVPROC = procedure(target, pname: TGLEnum; params: PGLint); stdcall;

PFNGLHISTOGRAMPROC = procedure(target: TGLEnum; width: TGLsizei; internalformat: TGLEnum; sink: TGLboolean); stdcall;

PFNGLMINMAXPROC = procedure(target, internalformat: TGLEnum; sink: TGLboolean); stdcall;

PFNGLRESETHISTOGRAMPROC = procedure(target: TGLEnum); stdcall;

PFNGLRESETMINMAXPROC = procedure(target: TGLEnum); stdcall;

PFNGLACTIVETEXTUREPROC = procedure(texture: TGLenum); stdcall;

PFNGLSAMPLECOVERAGEPROC = procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

PFNGLCOMPRESSEDTEXIMAGE3DPROC = procedure(target: TGLenum; level: TGLint; internalformat: TGLenum; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXIMAGE2DPROC = procedure(target: TGLenum; level: TGLint; internalformat: TGLenum; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXIMAGE1DPROC = procedure(target: TGLenum; level: TGLint; internalformat: TGLenum; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC = procedure(target: TGLenum; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: TGLenum; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC = procedure(target: TGLenum; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: TGLenum; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC = procedure(target: TGLenum; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: TGLenum; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLGETCOMPRESSEDTEXIMAGEPROC = procedure(target: TGLenum; level: TGLint; img: pointer); stdcall;

PFNGLCLIENTACTIVETEXTUREPROC = procedure(texture: TGLenum); stdcall;

PFNGLMULTITEXCOORD1DPROC = procedure(target: TGLenum; s: TGLdouble); stdcall;

PFNGLMULTITEXCOORD1DVPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD1FPROC = procedure(target: TGLenum; s: TGLfloat); stdcall;

PFNGLMULTITEXCOORD1FVPROC = procedure(target: TGLenum; v: TGLfloat); stdcall;

PFNGLMULTITEXCOORD1IPROC = procedure(target: TGLenum; s: TGLint); stdcall;

PFNGLMULTITEXCOORD1IVPROC = procedure(target: TGLenum; v: PGLInt); stdcall;

PFNGLMULTITEXCOORD1SPROC = procedure(target: TGLenum; s: TGLshort); stdcall;

PFNGLMULTITEXCOORD1SVPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLMULTITEXCOORD2DPROC = procedure(target: TGLenum; s, t: TGLdouble); stdcall;

PFNGLMULTITEXCOORD2DVPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD2FPROC = procedure(target: TGLenum; s, t: TGLfloat); stdcall;

PFNGLMULTITEXCOORD2FVPROC = procedure(target: TGLenum; v: PGLfloat); stdcall;

PFNGLMULTITEXCOORD2IPROC = procedure(target: TGLenum; s, t: TGLint); stdcall;

PFNGLMULTITEXCOORD2IVPROC = procedure(target: TGLenum; v: PGLint); stdcall;

PFNGLMULTITEXCOORD2SPROC = procedure(target: TGLenum; s, t: TGLshort); stdcall;

PFNGLMULTITEXCOORD2SVPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLMULTITEXCOORD3DPROC = procedure(target: TGLenum; s, t, r: TGLdouble); stdcall;

PFNGLMULTITEXCOORD3DVPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD3FPROC = procedure(target: TGLenum; s, t, r: TGLfloat); stdcall;

PFNGLMULTITEXCOORD3FVPROC = procedure(target: TGLenum; v: PGLfloat); stdcall;

PFNGLMULTITEXCOORD3IPROC = procedure(target: TGLenum; s, t, r: TGLint); stdcall;

PFNGLMULTITEXCOORD3IVPROC = procedure(target: TGLenum; v: PGLint); stdcall;

PFNGLMULTITEXCOORD3SPROC = procedure(target: TGLenum; s, t, r: TGLshort); stdcall;

PFNGLMULTITEXCOORD3SVPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLMULTITEXCOORD4DPROC = procedure(target: TGLenum; s, t, r, q: TGLdouble); stdcall;

PFNGLMULTITEXCOORD4DVPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD4FPROC = procedure(target: TGLenum; s, t, r, q: TGLfloat); stdcall;

PFNGLMULTITEXCOORD4FVPROC = procedure(target: TGLenum; v: PGLfloat); stdcall;

PFNGLMULTITEXCOORD4IPROC = procedure(target: TGLenum; s, t, r, q: TGLint); stdcall;

PFNGLMULTITEXCOORD4IVPROC = procedure(target: TGLenum; v: PGLint); stdcall;

PFNGLMULTITEXCOORD4SPROC = procedure(target: TGLenum; s, t, r, q: TGLshort); stdcall;

PFNGLMULTITEXCOORD4SVPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLLOADTRANSPOSEMATRIXFPROC = procedure(m: PGLfloat); stdcall;

PFNGLLOADTRANSPOSEMATRIXDPROC = procedure(m: PGLdouble); stdcall;

PFNGLMULTTRANSPOSEMATRIXFPROC = procedure(m: PGLfloat); stdcall;

PFNGLMULTTRANSPOSEMATRIXDPROC = procedure(m: PGLdouble); stdcall;

PFNGLBLENDFUNCSEPARATEPROC = procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: TGLenum); stdcall;

PFNGLMULTIDRAWARRAYSPROC = procedure(mode: TGLenum; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

PFNGLMULTIDRAWELEMENTSPROC = procedure(mode: TGLenum; Count: PGLsizei; AType: TGLenum; var indices; primcount: TGLsizei); stdcall;

PFNGLPOINTPARAMETERFPROC = procedure(pname: TGLenum; param: TGLfloat); stdcall;

PFNGLPOINTPARAMETERFVPROC = procedure(pname: TGLenum; params: PGLfloat); stdcall;

PFNGLPOINTPARAMETERIPROC = procedure(pname: TGLenum; param: TGLint); stdcall;

PFNGLPOINTPARAMETERIVPROC = procedure(pname: TGLenum; params: PGLint); stdcall;

PFNGLFOGCOORDFPROC = procedure(coord: TGLfloat); stdcall;

PFNGLFOGCOORDFVPROC = procedure(coord: PGLfloat); stdcall;

PFNGLFOGCOORDDPROC = procedure(coord: TGLdouble); stdcall;

PFNGLFOGCOORDDVPROC = procedure(coord: PGLdouble); stdcall;

PFNGLFOGCOORDPOINTERPROC = procedure(AType: TGLenum; stride: TGLsizei; p: Pointer); stdcall;

PFNGLSECONDARYCOLOR3BPROC = procedure(red, green, blue: TGLbyte); stdcall;

PFNGLSECONDARYCOLOR3BVPROC = procedure(v: PGLbyte); stdcall;

PFNGLSECONDARYCOLOR3DPROC = procedure(red, green, blue: TGLdouble); stdcall;

PFNGLSECONDARYCOLOR3DVPROC = procedure(v: PGLdouble); stdcall;

PFNGLSECONDARYCOLOR3FPROC = procedure(red, green, blue: TGLfloat); stdcall;

PFNGLSECONDARYCOLOR3FVPROC = procedure(v: PGLfloat); stdcall;

PFNGLSECONDARYCOLOR3IPROC = procedure(red, green, blue: TGLint); stdcall;

PFNGLSECONDARYCOLOR3IVPROC = procedure(v: PGLint); stdcall;

PFNGLSECONDARYCOLOR3SPROC = procedure(red, green, blue: TGLshort); stdcall;

PFNGLSECONDARYCOLOR3SVPROC = procedure(v: PGLshort); stdcall;

PFNGLSECONDARYCOLOR3UBPROC = procedure(red, green, blue: TGLubyte); stdcall;

PFNGLSECONDARYCOLOR3UBVPROC = procedure(v: PGLubyte); stdcall;

PFNGLSECONDARYCOLOR3UIPROC = procedure(red, green, blue: TGLuint); stdcall;

PFNGLSECONDARYCOLOR3UIVPROC = procedure(v: PGLuint); stdcall;

PFNGLSECONDARYCOLOR3USPROC = procedure(red, green, blue: TGLushort); stdcall;

PFNGLSECONDARYCOLOR3USVPROC = procedure(v: PGLushort); stdcall;

PFNGLSECONDARYCOLORPOINTERPROC = procedure(Size: TGLint; Atype: TGLenum; stride: TGLsizei; p: pointer); stdcall;

PFNGLWINDOWPOS2DPROC = procedure(x,y : TGLdouble); stdcall;

PFNGLWINDOWPOS2DVPROC = procedure(v : PGLdouble); stdcall;

PFNGLWINDOWPOS2FPROC = procedure(x,y : TGLfloat); stdcall;

PFNGLWINDOWPOS2FVPROC = procedure(v : PGLfloat); stdcall;

PFNGLWINDOWPOS2IPROC = procedure(x,y : TGLint); stdcall;

PFNGLWINDOWPOS2IVPROC = procedure(v : PGLint); stdcall;

PFNGLWINDOWPOS2SPROC = procedure(x,y : TGLshort); stdcall;

PFNGLWINDOWPOS2SVPROC = procedure(v : PGLshort); stdcall;

PFNGLWINDOWPOS3DPROC = procedure(x,y,z : TGLdouble); stdcall;

PFNGLWINDOWPOS3DVPROC = procedure(v : PGLdouble); stdcall;

PFNGLWINDOWPOS3FPROC = procedure(x,y,z : TGLfloat); stdcall;

PFNGLWINDOWPOS3FVPROC = procedure(v : PGLfloat); stdcall;

PFNGLWINDOWPOS3IPROC = procedure(x,y,z : TGLint); stdcall;

PFNGLWINDOWPOS3IVPROC = procedure(v : PGLint); stdcall;

PFNGLWINDOWPOS3SPROC = procedure(x,y,z : TGLshort); stdcall;

PFNGLWINDOWPOS3SVPROC = procedure(v : PGLshort); stdcall;

PFNGLGENQUERIESPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

PFNGLDELETEQUERIESPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

PFNGLISQUERYPROC = function(id: TGLuint): TGLboolean; stdcall;

PFNGLBEGINQUERYPROC = procedure(target: TGLenum; id: TGLuint); stdcall;

PFNGLENDQUERYPROC = procedure(target: TGLenum); stdcall;

PFNGLGETQUERYIVPROC = procedure(target: TGLEnum; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETQUERYOBJECTIVPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETQUERYOBJECTUIVPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLuint); stdcall;

PFNGLBINDBUFFERPROC = procedure(target: GLenum; buffer: GLuint); stdcall;

PFNGLDELETEBUFFERSPROC = procedure(n: GLsizei; const buffers: PGLuint); stdcall;

PFNGLGENBUFFERSPROC = procedure(n: GLsizei; buffers: PGLuint); stdcall;

PFNGLISBUFFERPROC = function(buffer: GLuint): GLboolean; stdcall;

PFNGLBUFFERDATAPROC = procedure(target: GLenum; size: GLsizei; const data: Pointer; usage: GLenum); stdcall;

PFNGLBUFFERSUBDATAPROC = procedure(target: GLenum; offset: GLuint; size: GLsizei; const data: Pointer); stdcall;

PFNGLGETBUFFERSUBDATAPROC = procedure(target: GLenum; offset: GLuint; size: GLsizei; data: Pointer); stdcall;

PFNGLMAPBUFFERPROC = function(target: GLenum; access: GLenum): Pointer; stdcall;

PFNGLUNMAPBUFFERPROC = function(target: GLenum): GLboolean; stdcall;

PFNGLGETBUFFERPARAMETERIVPROC = procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETBUFFERPOINTERVPROC = procedure(target: GLenum; pname: GLenum; params: Pointer); stdcall;

PFNGLBLENDEQUATIONSEPARATEPROC = procedure(modeRGB: TGLenum; modeAlpha: TGLenum); stdcall;

PFNGLDRAWBUFFERSPROC = procedure(n: GLSizei; const bufs: PGLenum); stdcall;

PFNGLSTENCILOPSEPARATEPROC = procedure(face, sfail, dpfail, dppass: TGLenum); stdcall;

PFNGLSTENCILFUNCSEPARATEPROC = procedure(face, func: TGLenum; ref: TGLint; mask: TGLuint); stdcall;

PFNGLSTENCILMASKSEPARATEPROC = procedure(face: TGLenum; mask: TGLuint); stdcall;

PFNGLATTACHSHADERPROC = procedure(_program: TGLuint; shader: TGLuint); stdcall;

PFNGLBINDATTRIBLOCATIONPROC = procedure(_program: TGLuint; index: TGLuint; const name: PGLChar); stdcall;

PFNGLCOMPILESHADERPROC = procedure(shader: TGLuint); stdcall;

PFNGLCREATEPROGRAMPROC = function(): TGLuint; stdcall;

PFNGLCREATESHADERPROC = function(_type: TGLenum): TGLuint; stdcall;

PFNGLDELETEPROGRAMPROC = procedure(_program: TGLuint); stdcall;

PFNGLDELETESHADERPROC = procedure(shader: TGLuint); stdcall;

PFNGLDETACHSHADERPROC = procedure(_program: TGLuint; shader: TGLuint); stdcall;

PFNGLDISABLEVERTEXATTRIBARRAYPROC = procedure(index: TGLuint); stdcall;

PFNGLENABLEVERTEXATTRIBARRAYPROC = procedure(index: TGLuint); stdcall;

PFNGLGETACTIVEATTRIBPROC = procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

PFNGLGETACTIVEUNIFORMPROC = procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

PFNGLGETATTACHEDSHADERSPROC = procedure(_program: TGLuint; maxCount: TGLsizei; count: PGLSizei; obj: PGLuint); stdcall;

PFNGLGETATTRIBLOCATIONPROC = function(_program: TGLuint; const name: PGLChar): TGLint; stdcall;

PFNGLGETPROGRAMIVPROC = procedure(_program: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETPROGRAMINFOLOGPROC = procedure(_program: TGLuint; bufSize: TGLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

PFNGLGETSHADERIVPROC = procedure(shader: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETSHADERINFOLOGPROC = procedure(shader: TGLuint; bufSize: TGLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

PFNGLGETSHADERSOURCEPROC = procedure(shader:TGLuint; bufSize: TGLsizei; length: PGLsizei; source: PGLChar); stdcall;

PFNGLGETUNIFORMLOCATIONPROC = function(_program: TGLuint; const name: PGLChar): TGLint; stdcall;

PFNGLGETUNIFORMFVPROC = procedure(_program: TGLuint; location: TGLint; params: PGLfloat); stdcall;

PFNGLGETUNIFORMIVPROC = procedure(_program: TGLuint; location: TGLint; params: PGLint); stdcall;

PFNGLGETVERTEXATTRIBDVPROC = procedure(index:TGLuint; pname: TGLenum; params: PGLdouble); stdcall;

PFNGLGETVERTEXATTRIBFVPROC = procedure(index: TGLuint; pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETVERTEXATTRIBIVPROC = procedure(index: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETVERTEXATTRIBPOINTERVPROC = procedure(index: TGLuint; pname: TGLenum; _pointer:pointer); stdcall;

PFNGLISPROGRAMPROC = function(_program: TGLuint):TGLboolean; stdcall;

PFNGLISSHADERPROC = function(shader: TGLuint): TGLboolean; stdcall;

PFNGLLINKPROGRAMPROC = procedure(_program: TGLuint); stdcall;

PFNGLSHADERSOURCEPROC = procedure(shader: TGLuint; count: TGLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

PFNGLUSEPROGRAMPROC = procedure(_program: TGLuint); stdcall;

PFNGLUNIFORM1FPROC = procedure(location: GLint; v0: GLfloat); stdcall;

PFNGLUNIFORM2FPROC = procedure(location: GLint; v0: GLfloat; v1: GLfloat); stdcall;

PFNGLUNIFORM3FPROC = procedure(location: GLint; v0: GLfloat; v1: GLfloat; v2: GLfloat); stdcall;

PFNGLUNIFORM4FPROC = procedure(location: GLint; v0: GLfloat; v1: GLfloat; v2: GLfloat; v3: GLfloat); stdcall;

PFNGLUNIFORM1IPROC = procedure(location: GLint; v0: GLint); stdcall;

PFNGLUNIFORM2IPROC = procedure(location: GLint; v0: GLint; v1: GLint); stdcall;

PFNGLUNIFORM3IPROC = procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint); stdcall;

PFNGLUNIFORM4IPROC = procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint; v3: GLint); stdcall;

PFNGLUNIFORM1FVPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM2FVPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM3FVPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM4FVPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM1IVPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORM2IVPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORM3IVPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORM4IVPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORMMATRIX2FVPROC = procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX3FVPROC = procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX4FVPROC = procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

PFNGLVALIDATEPROGRAMPROC = procedure(_program: TGLuint); stdcall;

PFNGLVERTEXATTRIB1DPROC = procedure(index:TGLuint; x: TGLdouble); stdcall;

PFNGLVERTEXATTRIB1DVPROC = procedure(index:TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB1FPROC = procedure(index:TGLuint; x: TGLfloat); stdcall;

PFNGLVERTEXATTRIB1FVPROC = procedure(index:TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB1SPROC = procedure(index:TGLuint; x: TGLshort); stdcall;

PFNGLVERTEXATTRIB1SVPROC = procedure(index:TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB2DPROC = procedure(index:TGLuint; x,y: TGLdouble); stdcall;

PFNGLVERTEXATTRIB2DVPROC = procedure(index:TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB2FPROC = procedure(index:TGLuint; x,y: TGLfloat); stdcall;

PFNGLVERTEXATTRIB2FVPROC = procedure(index:TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB2SPROC = procedure(index:TGLuint; x,y: TGLshort); stdcall;

PFNGLVERTEXATTRIB2SVPROC = procedure(index:TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB3DPROC = procedure(index:TGLuint; x,y,z: TGLdouble); stdcall;

PFNGLVERTEXATTRIB3DVPROC = procedure(index:TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB3FPROC = procedure(index:TGLuint; x,y,z: TGLfloat); stdcall;

PFNGLVERTEXATTRIB3FVPROC = procedure(index:TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB3SPROC = procedure(index:TGLuint; x,y,z: TGLshort); stdcall;

PFNGLVERTEXATTRIB3SVPROC = procedure(index:TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4NBVPROC = procedure(index:TGLuint; v: PGLbyte); stdcall;

PFNGLVERTEXATTRIB4NIVPROC = procedure(index:TGLuint; v: PGLint); stdcall;

PFNGLVERTEXATTRIB4NSVPROC = procedure(index:TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4NUBPROC = procedure(index:TGLuint; x,y,z,w: TGLubyte); stdcall;

PFNGLVERTEXATTRIB4NUBVPROC = procedure(index:TGLuint; v: PGLubyte); stdcall;

PFNGLVERTEXATTRIB4NUIVPROC = procedure(index:TGLuint; v: PGLuint); stdcall;

PFNGLVERTEXATTRIB4NUSVPROC = procedure(index:TGLuint; v: PGLushort); stdcall;

PFNGLVERTEXATTRIB4BVPROC = procedure(index:TGLuint; v: PGLbyte); stdcall;

PFNGLVERTEXATTRIB4DPROC = procedure(index:TGLuint; x,y,z,w: TGLdouble); stdcall;

PFNGLVERTEXATTRIB4DVPROC = procedure(index:TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB4FPROC = procedure(index:TGLuint; x,y,z,w: TGLfloat); stdcall;

PFNGLVERTEXATTRIB4FVPROC = procedure(index:TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB4IVPROC = procedure(index:TGLuint; v: PGLint); stdcall;

PFNGLVERTEXATTRIB4SPROC = procedure(index:TGLuint; x,y,z,w: TGLshort); stdcall;

PFNGLVERTEXATTRIB4SVPROC = procedure(index:TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4UBVPROC = procedure(index:TGLuint; v: PGLubyte); stdcall;

PFNGLVERTEXATTRIB4UIVPROC = procedure(index:TGLuint; v: PGLuint); stdcall;

PFNGLVERTEXATTRIB4USVPROC = procedure(index:TGLuint; v: PGLushort); stdcall;

PFNGLVERTEXATTRIBPOINTERPROC = procedure(index:TGLuint; size: TGLint; _type: TGLenum; normalized: TGLboolean; stride:TGLsizei; _pointer:pointer); stdcall;

PFNGLUNIFORMMATRIX2X3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX3X2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX2X4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX4X2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX3X4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX4X3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

PFNGLVERTEXATTRIBI1IPROC = procedure(index: TGLuint; x: TGLint); stdcall;

PFNGLVERTEXATTRIBI2IPROC = procedure(index: TGLuint; x: TGLint; y: TGLint); stdcall;

PFNGLVERTEXATTRIBI3IPROC = procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint); stdcall;

PFNGLVERTEXATTRIBI4IPROC = procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

PFNGLVERTEXATTRIBI1UIPROC = procedure(index: TGLuint; x: TGLuint); stdcall;

PFNGLVERTEXATTRIBI2UIPROC = procedure(index: TGLuint; x: TGLuint; y: TGLuint); stdcall;

PFNGLVERTEXATTRIBI3UIPROC = procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint); stdcall;

PFNGLVERTEXATTRIBI4UIPROC = procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint; w: TGLuint); stdcall;

PFNGLVERTEXATTRIBI1IVPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI2IVPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI3IVPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI4IVPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI1UIVPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI2UIVPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI3UIVPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI4UIVPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI4BVPROC = procedure(index: TGLuint; v:PGLbyte); stdcall;

PFNGLVERTEXATTRIBI4SVPROC = procedure(index: TGLuint; v:PGLshort); stdcall;

PFNGLVERTEXATTRIBI4UBVPROC = procedure(index: TGLuint; v: PGLUbyte); stdcall;

PFNGLVERTEXATTRIBI4USVPROC = procedure(index: TGLuint; v: PGLushort); stdcall;

PFNGLVERTEXATTRIBIPOINTERPROC = procedure(index: TGLuint; size: TGLint; _type: TGLenum; stride: TGLsizei; _pointer: pointer); stdcall;

PFNGLGETVERTEXATTRIBIIVPROC = procedure(index: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETVERTEXATTRIBIUIVPROC = procedure(index: TGLuint; pname: TGLenum; params: PGLuint); stdcall;

PFNGLUNIFORM1UIPROC = procedure(location: TGLInt; v0: TGLuint); stdcall;

PFNGLUNIFORM2UIPROC = procedure(location: TGLInt; v0: TGLuint; v1: TGLuint); stdcall;

PFNGLUNIFORM3UIPROC = procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint); stdcall;

PFNGLUNIFORM4UIPROC = procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint; v3: TGLuint); stdcall;

PFNGLUNIFORM1UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLUNIFORM2UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLUNIFORM3UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLUNIFORM4UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLGETUNIFORMUIVPROC = procedure(_program: TGLuint; location: TGLint; params: PGLuint); stdcall;

PFNGLBINDFRAGDATALOCATIONPROC = procedure(_program: TGLuint; colorNumber: TGLuint; name: PGLChar); stdcall;

PFNGLGETFRAGDATALOCATIONPROC = function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

PFNGLBEGINCONDITIONALRENDERPROC = procedure(id: TGLuint; mode: TGLenum); stdcall;

PFNGLENDCONDITIONALRENDERPROC = procedure(); stdcall;

PFNGLCLAMPCOLORPROC = procedure (target: TGLenum; clamp: TGLenum); stdcall;

PFNGLTEXPARAMETERIIVPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLTEXPARAMETERIUIVPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLuint); stdcall;

PFNGLGETTEXPARAMETERIIVPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETTEXPARAMETERIUIVPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLuint); stdcall;

PFNGLCOLORMASKIPROC = procedure(index: TGLuint; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

PFNGLGETBOOLEANI_VPROC = procedure(target: TGLenum; index: TGLuint; data: PGLboolean); stdcall;

PFNGLGETINTEGERI_VPROC = procedure(target: TGLenum; index: TGLuint; data: PGLint); stdcall;

PFNGLENABLEIPROC = procedure(target: TGLenum; index: TGLuint); stdcall;

PFNGLDISABLEIPROC = procedure(target: TGLenum; index: TGLuint); stdcall;

PFNGLISENABLEDIPROC = function(target: TGLenum; index: TGLuint): TGLboolean; stdcall;

PFNGLBINDBUFFERRANGEPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint; offset:TGLintptr; size: TGLsizeiptr); stdcall;

PFNGLBINDBUFFERBASEPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint); stdcall;

PFNGLBEGINTRANSFORMFEEDBACKPROC = procedure(primitiveMode: TGLenum); stdcall;

PFNGLENDTRANSFORMFEEDBACKPROC = procedure(); stdcall;

PFNGLTRANSFORMFEEDBACKVARYINGSPROC = procedure(_program: TGLuint; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: TGLenum); stdcall;

PFNGLGETTRANSFORMFEEDBACKVARYINGPROC = procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PGLenum; name: PGLChar); stdcall;

PFNGLCLEARBUFFERIVPROC = procedure(buffer: TGLenum; drawbuffer: TGLint; value: PGLint); stdcall;

PFNGLCLEARBUFFERUIVPROC = procedure(buffer: TGLenum; drawbuffer: TGLint; value: PGLuint); stdcall;

PFNGLCLEARBUFFERFVPROC = procedure(buffer: TGLenum; drawbuffer: TGLint; value: PGLfloat); stdcall;

PFNGLCLEARBUFFERFIPROC = procedure(buffer: TGLenum; drawbuffer: TGLint; depth: TGLfloat; stencil: TGLint); stdcall;

PFNGLGETSTRINGIPROC = function(name: TGLenum; index: TGLuint): PGLChar; stdcall;

PFNGLDRAWARRAYSINSTANCEDPROC = procedure(mode: TGLenum; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

PFNGLDRAWELEMENTSINSTANCEDPROC = procedure(mode: TGLenum; count: TGLsizei; _type: TGLenum; indices: PGLvoid; primcount: TGLsizei); stdcall;

PFNGLTEXBUFFERPROC = procedure(target: TGLenum; internalformat: TGLenum; buffer: TGLuint); stdcall;

PFNGLPRIMITIVERESTARTINDEXPROC = procedure(index: TGLuint); stdcall;

PFNGLGETINTEGER64I_VPROC = procedure(target: TGLenum; index: TGLuint; data: PGLint64); stdcall;

PFNGLGETBUFFERPARAMETERI64VPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLint64); stdcall;

PFNGLFRAMEBUFFERTEXTUREPROC = procedure(target: TGLenum; attachment: TGLenum; texture: TGLuint; level: TGLint); stdcall;

PFNGLVERTEXATTRIBDIVISORPROC = procedure(index: TGLuint; divisor: TGLuint); stdcall;

PFNGLBLENDEQUATIONIPROC = procedure(buf: TGLuint; mode: TGLenum); stdcall;

PFNGLBLENDEQUATIONSEPARATEIPROC = procedure(buf: TGLuint; modeRGB: TGLenum; modeAlpha: TGLenum); stdcall;

PFNGLBLENDFUNCIPROC = procedure(buf: TGLuint; src: TGLenum; dst: TGLenum); stdcall;

PFNGLBLENDFUNCSEPARATEIPROC = procedure(buf: TGLuint; srcRGB: TGLenum; dstRGB: TGLenum; srcAlpha: TGLenum; dstAlpha: TGLenum); stdcall;

PFNGLMINSAMPLESHADINGPROC = procedure(value: TGLclampf); stdcall;

PFNGLUNURBSCALLBACKDATAEXTPROC = procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;

PFNGLUNEWNURBSTESSELLATOREXTPROC = function: PGLUnurbs; stdcall;

PFNGLUDELETENURBSTESSELLATOREXTPROC = procedure(nurb: PGLUnurbs); stdcall;

PFNWGLCREATEBUFFERREGIONARBPROC = function(DC: HDC; iLayerPlane: Integer; uType: TGLenum) : Integer; stdcall;

PFNWGLDELETEBUFFERREGIONARBPROC = procedure(hRegion: Integer); stdcall;

PFNWGLSAVEBUFFERREGIONARBPROC = function(hRegion: Integer; x, y, width, height: Integer): BOOL; stdcall;

PFNWGLRESTOREBUFFERREGIONARBPROC = function(hRegion: Integer; x, y, width, height: Integer; xSrc, ySrc: Integer): BOOL; stdcall;

PFNWGLGETEXTENSIONSSTRINGARBPROC = function(DC: HDC): PGLChar; stdcall;

PFNWGLGETPIXELFORMATATTRIBIVARBPROC = function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: TGLenum; const piAttributes: PGLint; piValues : PGLint) : BOOL; stdcall;

PFNWGLGETPIXELFORMATATTRIBFVARBPROC = function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: TGLenum; const piAttributes: PGLint; piValues: PGLFloat) : BOOL; stdcall;

PFNWGLCHOOSEPIXELFORMATARBPROC = function(DC: HDC; const piAttribIList: PGLint; const pfAttribFList: PGLFloat; nMaxFormats: GLuint; piFormats: PGLint; nNumFormats: PGLenum) : BOOL; stdcall;

PFNWGLMAKECONTEXTCURRENTARBPROC = function(hDrawDC: HDC; hReadDC: HDC; _hglrc: HGLRC): BOOL; stdcall;

PFNWGLGETCURRENTREADDCARBPROC = function(): HDC; stdcall;

PFNWGLCREATEPBUFFERARBPROC = function(DC: HDC; iPixelFormat: GLInt; iWidth, iHeight : GLInt; const piAttribList: PGLint) : HPBUFFERARB; stdcall;

PFNWGLGETPBUFFERDCARBPROC = function(hPbuffer: HPBUFFERARB) : HDC; stdcall;

PFNWGLRELEASEPBUFFERDCARBPROC = function(hPbuffer: HPBUFFERARB; DC: HDC) : Integer; stdcall;

PFNWGLDESTROYPBUFFERARBPROC = function(hPbuffer: HPBUFFERARB): BOOL; stdcall;

PFNWGLQUERYPBUFFERARBPROC = function(hPbuffer: HPBUFFERARB; iAttribute : Integer; piValue: PGLint) : BOOL; stdcall;

PFNWGLBINDTEXIMAGEARBPROC = function(hPbuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

PFNWGLRELEASETEXIMAGEARBPROC = function(hpBuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

PFNWGLSETPBUFFERATTRIBARBPROC = function(hpBuffer: HPBUFFERARB; const piAttribList: PGLint): BOOL; stdcall;

PFNWGLCREATECONTEXTATTRIBSARBPROC = function(DC: HDC; hShareContext: HGLRC; attribList: PGLint):HGLRC; stdcall;

PFNWGLSWAPINTERVALEXTPROC = function(interval : Integer) : BOOL; stdcall;

PFNWGLGETSWAPINTERVALEXTPROC = function : Integer; stdcall;

PFNWGLENUMGPUSNVPROC = function(iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean; stdcall;

PFNWGLENUMGPUDEVICESNVPROC = function(hGpu: HGPUNV; iDeviceIndex: Cardinal; lpGpuDevice: PGPUDevice): Boolean; stdcall;

PFNWGLCREATEAFFINITYDCNVPROC = function(hGpuList: PHGPUNV): HDC; stdcall;

PFNWGLENUMGPUSFROMAFFINITYDCNVPROC = function(hAffinityDC: HDC; iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean; stdcall;

PFNWGLDELETEDCNVPROC = function(hdc: HDC): Boolean; stdcall;

PFNWGLDXSETRESOURCESHAREHANDLEPROC = function (dxObject: Pointer; shareHandle: THandle): BOOL; stdcall;

PFNWGLDXOPENDEVICEPROC = function(dxDevice: Pointer): THandle; stdcall;

PFNWGLDXCLOSEDEVICEPROC = function(hDevice: THandle): BOOL; stdcall;

PFNWGLDXREGISTEROBJECTPROC = function(hDevice: THandle; dxObject: Pointer; name: GLuint; atype: GLuint; access: GLuint): THandle; stdcall;

PFNWGLDXUNREGISTEROBJECTPROC = function(hDevice: THandle; hObject: THandle): BOOL; stdcall;

PFNWGLDXOBJECTACCESSPROC = function(hObject: THandle; access: GLenum): BOOL; stdcall;

PFNWGLDXLOCKOBJECTSPROC = function(hDevice: THandle; count: GLint; hObjects: PHandle): BOOL; stdcall;

PFNWGLDXUNLOCKOBJECTSNVPROC = function (hDevice: THandle; count: GLint; hObjects: PHandle): BOOL; stdcall;

PFNGLSAMPLEPASSARBPROC = procedure(pass: TGLenum); stdcall;

PFNGLACTIVETEXTUREARBPROC = procedure(target: TGLenum); stdcall;

PFNGLCLIENTACTIVETEXTUREARBPROC = procedure(target: TGLenum); stdcall;

PFNGLMULTITEXCOORD1DARBPROC = procedure(target: TGLenum; s: TGLdouble); stdcall;

PFNGLMULTITEXCOORD1DVARBPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD1FARBPROC = procedure(target: TGLenum; s: TGLfloat); stdcall;

PFNGLMULTITEXCOORD1FVARBPROC = procedure(target: TGLenum; v: TGLfloat); stdcall;

PFNGLMULTITEXCOORD1IARBPROC = procedure(target: TGLenum; s: TGLint); stdcall;

PFNGLMULTITEXCOORD1IVARBPROC = procedure(target: TGLenum; v: PGLInt); stdcall;

PFNGLMULTITEXCOORD1SARBPROC = procedure(target: TGLenum; s: TGLshort); stdcall;

PFNGLMULTITEXCOORD1SVARBPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLMULTITEXCOORD2DARBPROC = procedure(target: TGLenum; s, t: TGLdouble); stdcall;

PFNGLMULTITEXCOORD2DVARBPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD2FARBPROC = procedure(target: TGLenum; s, t: TGLfloat); stdcall;

PFNGLMULTITEXCOORD2FVARBPROC = procedure(target: TGLenum; v: PGLfloat); stdcall;

PFNGLMULTITEXCOORD2IARBPROC = procedure(target: TGLenum; s, t: TGLint); stdcall;

PFNGLMULTITEXCOORD2IVARBPROC = procedure(target: TGLenum; v: PGLint); stdcall;

PFNGLMULTITEXCOORD2SARBPROC = procedure(target: TGLenum; s, t: TGLshort); stdcall;

PFNGLMULTITEXCOORD2SVARBPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLMULTITEXCOORD3DARBPROC = procedure(target: TGLenum; s, t, r: TGLdouble); stdcall;

PFNGLMULTITEXCOORD3DVARBPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD3FARBPROC = procedure(target: TGLenum; s, t, r: TGLfloat); stdcall;

PFNGLMULTITEXCOORD3FVARBPROC = procedure(target: TGLenum; v: PGLfloat); stdcall;

PFNGLMULTITEXCOORD3IARBPROC = procedure(target: TGLenum; s, t, r: TGLint); stdcall;

PFNGLMULTITEXCOORD3IVARBPROC = procedure(target: TGLenum; v: PGLint); stdcall;

PFNGLMULTITEXCOORD3SARBPROC = procedure(target: TGLenum; s, t, r: TGLshort); stdcall;

PFNGLMULTITEXCOORD3SVARBPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLMULTITEXCOORD4DARBPROC = procedure(target: TGLenum; s, t, r, q: TGLdouble); stdcall;

PFNGLMULTITEXCOORD4DVARBPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD4FARBPROC = procedure(target: TGLenum; s, t, r, q: TGLfloat); stdcall;

PFNGLMULTITEXCOORD4FVARBPROC = procedure(target: TGLenum; v: PGLfloat); stdcall;

PFNGLMULTITEXCOORD4IARBPROC = procedure(target: TGLenum; s, t, r, q: TGLint); stdcall;

PFNGLMULTITEXCOORD4IVARBPROC = procedure(target: TGLenum; v: PGLint); stdcall;

PFNGLMULTITEXCOORD4SARBPROC = procedure(target: TGLenum; s, t, r, q: TGLshort); stdcall;

PFNGLMULTITEXCOORD4SVARBPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLLOADTRANSPOSEMATRIXFARBPROC = procedure(m: PGLfloat); stdcall;

PFNGLLOADTRANSPOSEMATRIXDARBPROC = procedure(m: PGLdouble); stdcall;

PFNGLMULTTRANSPOSEMATRIXFARBPROC = procedure(m: PGLfloat); stdcall;

PFNGLMULTTRANSPOSEMATRIXDARBPROC = procedure(m: PGLdouble); stdcall;

PFNGLSAMPLECOVERAGEARBPROC = procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

PFNGLCOMPRESSEDTEXIMAGE3DARBPROC = procedure(target: TGLenum; level: TGLint; internalformat: TGLenum; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXIMAGE2DARBPROC = procedure(target: TGLenum; level: TGLint; internalformat: TGLenum; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXIMAGE1DARBPROC = procedure(target: TGLenum; level: TGLint; internalformat: TGLenum; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXSUBIMAGE3DARBPROC = procedure(target: TGLenum; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: TGLenum; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXSUBIMAGE2DARBPROC = procedure(target: TGLenum; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: TGLenum; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXSUBIMAGE1DARBPROC = procedure(target: TGLenum; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: TGLenum; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLGETCOMPRESSEDTEXIMAGEARBPROC = procedure(target: TGLenum; level: TGLint; img: pointer); stdcall;

PFNGLPOINTPARAMETERFARBPROC = procedure(pname: TGLenum; param: TGLfloat); stdcall;

PFNGLPOINTPARAMETERFVARBPROC = procedure(pname: TGLenum; params: PGLfloat); stdcall;

PFNGLWEIGHTBVARBPROC = procedure(size: TGLint; weights: PGLbyte); stdcall;

PFNGLWEIGHTSVARBPROC = procedure(size: TGLint; weights: PGLshort); stdcall;

PFNGLWEIGHTIVARBPROC = procedure(size: TGLint; weights: PGLint); stdcall;

PFNGLWEIGHTFVARBPROC = procedure(size: TGLint; weights: PGLfloat); stdcall;

PFNGLWEIGHTDVARBPROC = procedure(size: TGLint; weights: PGLdouble); stdcall;

PFNGLWEIGHTUBVARBPROC = procedure(size: TGLint; weights: PGLubyte); stdcall;

PFNGLWEIGHTUSVARBPROC = procedure(size: TGLint; weights: PGLushort); stdcall;

PFNGLWEIGHTUIVARBPROC = procedure(size: TGLint; weights: PGLuint); stdcall;

PFNGLWEIGHTPOINTERARBPROC = procedure(size: TGLint; _type: TGLenum; stride:TGLsizei; _pointer:pointer); stdcall;

PFNGLVERTEXBLENDARBPROC = procedure(count: TGLint); stdcall;

PFNGLCURRENTPALETTEMATRIXARBPROC = procedure(index: TGLint); stdcall;

PFNGLMATRIXINDEXUBVARBPROC = procedure(size: TGLint; indices: PGLubyte); stdcall;

PFNGLMATRIXINDEXUSVARBPROC = procedure(size: TGLint; indices: PGLushort); stdcall;

PFNGLMATRIXINDEXUIVARBPROC = procedure(size: TGLint; indices: PGLuint); stdcall;

PFNGLMATRIXINDEXPOINTERARBPROC = procedure(size: TGLint; _type: TGLenum; stride: TGLsizei; _pointer:pointer); stdcall;

PFNGLWINDOWPOS2DARBPROC = procedure(x,y : TGLdouble); stdcall;

PFNGLWINDOWPOS2DVARBPROC = procedure(v : PGLdouble); stdcall;

PFNGLWINDOWPOS2FARBPROC = procedure(x,y : TGLfloat); stdcall;

PFNGLWINDOWPOS2FVARBPROC = procedure(v : PGLfloat); stdcall;

PFNGLWINDOWPOS2IARBPROC = procedure(x,y : TGLint); stdcall;

PFNGLWINDOWPOS2IVARBPROC = procedure(v : PGLint); stdcall;

PFNGLWINDOWPOS2SARBPROC = procedure(x,y : TGLshort); stdcall;

PFNGLWINDOWPOS2SVARBPROC = procedure(v : PGLshort); stdcall;

PFNGLWINDOWPOS3DARBPROC = procedure(x,y,z : TGLdouble); stdcall;

PFNGLWINDOWPOS3DVARBPROC = procedure(v : PGLdouble); stdcall;

PFNGLWINDOWPOS3FARBPROC = procedure(x,y,z : TGLfloat); stdcall;

PFNGLWINDOWPOS3FVARBPROC = procedure(v : PGLfloat); stdcall;

PFNGLWINDOWPOS3IARBPROC = procedure(x,y,z : TGLint); stdcall;

PFNGLWINDOWPOS3IVARBPROC = procedure(v : PGLint); stdcall;

PFNGLWINDOWPOS3SARBPROC = procedure(x,y,z : TGLshort); stdcall;

PFNGLWINDOWPOS3SVARBPROC = procedure(v : PGLshort); stdcall;

PFNGLVERTEXATTRIB1DARBPROC = procedure(index: GLuint; x: GLdouble); stdcall;

PFNGLVERTEXATTRIB1DVARBPROC = procedure(index: GLuint; const v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB1FARBPROC = procedure(index: GLuint; x: GLfloat); stdcall;

PFNGLVERTEXATTRIB1FVARBPROC = procedure(index: GLuint; const v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB1SARBPROC = procedure(index: GLuint; x: GLshort); stdcall;

PFNGLVERTEXATTRIB1SVARBPROC = procedure(index: GLuint; const v: PGLshort); stdcall;

PFNGLVERTEXATTRIB2DARBPROC = procedure(index: GLuint; x: GLdouble; y: GLdouble); stdcall;

PFNGLVERTEXATTRIB2DVARBPROC = procedure(index: GLuint; const v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB2FARBPROC = procedure(index: GLuint; x: GLfloat; y: GLfloat); stdcall;

PFNGLVERTEXATTRIB2FVARBPROC = procedure(index: GLuint; const v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB2SARBPROC = procedure(index: GLuint; x: GLshort; y: GLshort); stdcall;

PFNGLVERTEXATTRIB2SVARBPROC = procedure(index: GLuint; const v: PGLshort); stdcall;

PFNGLVERTEXATTRIB3DARBPROC = procedure(index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble); stdcall;

PFNGLVERTEXATTRIB3DVARBPROC = procedure(index: GLuint; const v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB3FARBPROC = procedure(index: GLuint; x: GLfloat; y: GLfloat; z: GLfloat); stdcall;

PFNGLVERTEXATTRIB3FVARBPROC = procedure(index: GLuint; const v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB3SARBPROC = procedure(index: GLuint; x: GLshort; y: GLshort; z: GLshort); stdcall;

PFNGLVERTEXATTRIB3SVARBPROC = procedure(index: GLuint; const v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4NBVARBPROC = procedure(index: GLuint; const v: PGLbyte); stdcall;

PFNGLVERTEXATTRIB4NIVARBPROC = procedure(index: GLuint; const v: PGLint); stdcall;

PFNGLVERTEXATTRIB4NSVARBPROC = procedure(index: GLuint; const v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4NUBARBPROC = procedure(index: GLuint; x: GLubyte; y: GLubyte; z: GLubyte; w: GLubyte); stdcall;

PFNGLVERTEXATTRIB4NUBVARBPROC = procedure(index: GLuint; const v: PGLubyte); stdcall;

PFNGLVERTEXATTRIB4NUIVARBPROC = procedure(index: GLuint; const v: PGLuint); stdcall;

PFNGLVERTEXATTRIB4NUSVARBPROC = procedure(index: GLuint; const v: PGLushort); stdcall;

PFNGLVERTEXATTRIB4BVARBPROC = procedure(index: GLuint; const v: PGLbyte); stdcall;

PFNGLVERTEXATTRIB4DARBPROC = procedure(index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

PFNGLVERTEXATTRIB4DVARBPROC = procedure(index: GLuint; const v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB4FARBPROC = procedure(index: GLuint; x: GLfloat; y: GLfloat; z: GLfloat; w: GLfloat); stdcall;

PFNGLVERTEXATTRIB4FVARBPROC = procedure(index: GLuint; const v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB4IVARBPROC = procedure(index: GLuint; const v: PGLint); stdcall;

PFNGLVERTEXATTRIB4SARBPROC = procedure(index: GLuint; x: GLshort; y: GLshort; z: GLshort; w: GLshort); stdcall;

PFNGLVERTEXATTRIB4SVARBPROC = procedure(index: GLuint; const v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4UBVARBPROC = procedure(index: GLuint; const v: PGLubyte); stdcall;

PFNGLVERTEXATTRIB4UIVARBPROC = procedure(index: GLuint; const v: PGLuint); stdcall;

PFNGLVERTEXATTRIB4USVARBPROC = procedure(index: GLuint; const v: PGLushort); stdcall;

PFNGLVERTEXATTRIBPOINTERARBPROC = procedure(index: GLuint; size: GLint; _type: GLenum; normalized: GLboolean; stride: GLsizei; const _pointer: pointer); stdcall;

PFNGLENABLEVERTEXATTRIBARRAYARBPROC = procedure(index: GLuint); stdcall;

PFNGLDISABLEVERTEXATTRIBARRAYARBPROC = procedure(index: GLuint); stdcall;

PFNGLPROGRAMSTRINGARBPROC = procedure(target: GLenum; format: GLenum; len: GLsizei; const _string: pointer); stdcall;

PFNGLBINDPROGRAMARBPROC = procedure(target: GLenum; _program: GLuint); stdcall;

PFNGLDELETEPROGRAMSARBPROC = procedure(n: GLsizei; const programs: PGLuint); stdcall;

PFNGLGENPROGRAMSARBPROC = procedure(n: GLsizei; programs: PGLuint); stdcall;

PFNGLPROGRAMENVPARAMETER4DARBPROC = procedure(target: GLenum; index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

PFNGLPROGRAMENVPARAMETER4DVARBPROC = procedure(target: GLenum; index: GLuint; const params: PGLdouble); stdcall;

PFNGLPROGRAMENVPARAMETER4FARBPROC = procedure(target: GLenum; index: GLuint; x: GLfloat; y: GLfloat; z: GLfloat; w: GLfloat); stdcall;

PFNGLPROGRAMENVPARAMETER4FVARBPROC = procedure(target: GLenum; index: GLuint; const params: PGLfloat); stdcall;

PFNGLPROGRAMLOCALPARAMETER4DARBPROC = procedure(target: GLenum; index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

PFNGLPROGRAMLOCALPARAMETER4DVARBPROC = procedure(target: GLenum; index: GLuint; const params: PGLdouble); stdcall;

PFNGLPROGRAMLOCALPARAMETER4FARBPROC = procedure(target: GLenum; index: GLuint; x: GLfloat; y: GLfloat; z: GLfloat; w: GLfloat); stdcall;

PFNGLPROGRAMLOCALPARAMETER4FVARBPROC = procedure(target: GLenum; index: GLuint; const params: PGLfloat); stdcall;

PFNGLGETPROGRAMENVPARAMETERDVARBPROC = procedure(target: GLenum; index: GLuint; params: PGLdouble); stdcall;

PFNGLGETPROGRAMENVPARAMETERFVARBPROC = procedure(target: GLenum; index: GLuint; params: PGLfloat); stdcall;

PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC = procedure(target: GLenum; index: GLuint; params: PGLdouble); stdcall;

PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC = procedure(target: GLenum; index: GLuint; params: PGLfloat); stdcall;

PFNGLGETPROGRAMIVARBPROC = procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETPROGRAMSTRINGARBPROC = procedure(target: GLenum; pname: GLenum; _string: pointer); stdcall;

PFNGLGETVERTEXATTRIBDVARBPROC = procedure(index: GLuint; pname: GLenum; params: PGLdouble); stdcall;

PFNGLGETVERTEXATTRIBFVARBPROC = procedure(index: GLuint; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETVERTEXATTRIBIVARBPROC = procedure(index: GLuint; pname: GLenum; params: PGLint); stdcall;

PFNGLGETVERTEXATTRIBPOINTERVARBPROC = procedure(index: GLuint; pname: GLenum; _pointer: pointer); stdcall;

PFNGLISPROGRAMARBPROC = function(_program: GLuint): GLboolean; stdcall;

PFNGLBINDBUFFERARBPROC = procedure(target: GLenum; buffer: GLuint); stdcall;

PFNGLDELETEBUFFERSARBPROC = procedure(n: GLsizei; const buffers: PGLuint); stdcall;

PFNGLGENBUFFERSARBPROC = procedure(n: GLsizei; buffers: PGLuint); stdcall;

PFNGLISBUFFERARBPROC = function(buffer: GLuint): GLboolean; stdcall;

PFNGLBUFFERDATAARBPROC = procedure(target: GLenum; size: GLsizei; const data: Pointer; usage: GLenum); stdcall;

PFNGLBUFFERSUBDATAARBPROC = procedure(target: GLenum; offset: GLuint; size: GLsizei; const data: Pointer); stdcall;

PFNGLGETBUFFERSUBDATAARBPROC = procedure(target: GLenum; offset: GLuint; size: GLsizei; data: Pointer); stdcall;

PFNGLMAPBUFFERARBPROC = function(target: GLenum; access: GLenum): Pointer; stdcall;

PFNGLUNMAPBUFFERARBPROC = function(target: GLenum): GLboolean; stdcall;

PFNGLGETBUFFERPARAMETERIVARBPROC = procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETBUFFERPOINTERVARBPROC = procedure(target: GLenum; pname: GLenum; params: Pointer); stdcall;

PFNGLGENQUERIESARBPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

PFNGLDELETEQUERIESARBPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

PFNGLISQUERYARBPROC = function(id: TGLuint): TGLboolean; stdcall;

PFNGLBEGINQUERYARBPROC = procedure(target: TGLenum; id: TGLuint); stdcall;

PFNGLENDQUERYARBPROC = procedure(target: TGLenum); stdcall;

PFNGLGETQUERYIVARBPROC = procedure(target: TGLEnum; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETQUERYOBJECTIVARBPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETQUERYOBJECTUIVARBPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLuint); stdcall;

PFNGLDELETEOBJECTARBPROC = procedure(obj: GLhandleARB); stdcall;

PFNGLGETHANDLEARBPROC = function(pname: GLenum): GLhandleARB; stdcall;

PFNGLDETACHOBJECTARBPROC = procedure(containerObj: GLhandleARB; attachedObj: GLhandleARB); stdcall;

PFNGLCREATESHADEROBJECTARBPROC = function(shaderType: GLenum): GLhandleARB; stdcall;

PFNGLSHADERSOURCEARBPROC = procedure(shaderObj: GLhandleARB; count: GLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

PFNGLCOMPILESHADERARBPROC = procedure(shaderObj: GLhandleARB); stdcall;

PFNGLCREATEPROGRAMOBJECTARBPROC = function(): GLhandleARB; stdcall;

PFNGLATTACHOBJECTARBPROC = procedure(containerObj: GLhandleARB; obj: GLhandleARB); stdcall;

PFNGLLINKPROGRAMARBPROC = procedure(programObj: GLhandleARB); stdcall;

PFNGLUSEPROGRAMOBJECTARBPROC = procedure(programObj: GLhandleARB); stdcall;

PFNGLVALIDATEPROGRAMARBPROC = procedure(programObj: GLhandleARB); stdcall;

PFNGLUNIFORM1FARBPROC = procedure(location: GLint; v0: GLfloat); stdcall;

PFNGLUNIFORM2FARBPROC = procedure(location: GLint; v0: GLfloat; v1: GLfloat); stdcall;

PFNGLUNIFORM3FARBPROC = procedure(location: GLint; v0: GLfloat; v1: GLfloat; v2: GLfloat); stdcall;

PFNGLUNIFORM4FARBPROC = procedure(location: GLint; v0: GLfloat; v1: GLfloat; v2: GLfloat; v3: GLfloat); stdcall;

PFNGLUNIFORM1IARBPROC = procedure(location: GLint; v0: GLint); stdcall;

PFNGLUNIFORM2IARBPROC = procedure(location: GLint; v0: GLint; v1: GLint); stdcall;

PFNGLUNIFORM3IARBPROC = procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint); stdcall;

PFNGLUNIFORM4IARBPROC = procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint; v3: GLint); stdcall;

PFNGLUNIFORM1FVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM2FVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM3FVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM4FVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM1IVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORM2IVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORM3IVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORM4IVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORMMATRIX2FVARBPROC = procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX3FVARBPROC = procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX4FVARBPROC = procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

PFNGLGETOBJECTPARAMETERFVARBPROC = procedure(obj: GLhandleARB; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETOBJECTPARAMETERIVARBPROC = procedure(obj: GLhandleARB; pname: GLenum; params: PGLint); stdcall;

PFNGLGETINFOLOGARBPROC = procedure(obj: GLhandleARB; maxLength: GLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

PFNGLGETATTACHEDOBJECTSARBPROC = procedure(containerObj: GLhandleARB; maxCount: GLsizei; count: PGLsizei; obj: PGLhandleARB); stdcall;

PFNGLGETUNIFORMLOCATIONARBPROC = function(programObj: GLhandleARB; const name: PGLChar): GLint; stdcall;

PFNGLGETACTIVEUNIFORMARBPROC = procedure(programObj: GLhandleARB; index: GLuint; maxLength: GLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

PFNGLGETUNIFORMFVARBPROC = procedure(programObj: GLhandleARB; location: GLint; params: PGLfloat); stdcall;

PFNGLGETUNIFORMIVARBPROC = procedure(programObj: GLhandleARB; location: GLint; params: PGLint); stdcall;

PFNGLGETSHADERSOURCEARBPROC = procedure(obj: GLhandleARB; maxLength: GLsizei; length: PGLsizei; source: PGLChar); stdcall;

PFNGLBINDATTRIBLOCATIONARBPROC = procedure(programObj: GLhandleARB; index: GLuint; const name: PGLChar); stdcall;

PFNGLGETACTIVEATTRIBARBPROC = procedure(programObj: GLhandleARB; index: GLuint; maxLength: GLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

PFNGLGETATTRIBLOCATIONARBPROC = function(programObj: GLhandleARB; const name: PGLChar): GLint; stdcall;

PFNGLDRAWBUFFERSARBPROC = procedure (n: GLSizei; const bufs: PGLenum); stdcall;

PFNGLCLAMPCOLORARBPROC = procedure (target: TGLenum; clamp: TGLenum); stdcall;

PFNGLDRAWARRAYSINSTANCEDARBPROC = procedure(mode: TGLenum; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

PFNGLDRAWELEMENTSINSTANCEDARBPROC = procedure(mode: TGLenum; count: TGLSizei; _type: TGLenum; indices: PGLvoid; primcount: TGLsizei); stdcall;

PFNGLISRENDERBUFFERPROC = function(renderbuffer: TGLuint): TGLBoolean; stdcall;

PFNGLBINDRENDERBUFFERPROC = procedure(target: TGLenum; renderbuffer: TGLuint); stdcall;

PFNGLDELETERENDERBUFFERSPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

PFNGLGENRENDERBUFFERSPROC = procedure(n: TGLSizei; renderbuffers: PGLuint); stdcall;

PFNGLRENDERBUFFERSTORAGEPROC = procedure(target: TGLenum; internalformat: TGLenum; width: TGLsizei; height: TGLsizei); stdcall;

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC = procedure(target: TGLenum; samples: TGLsizei; internalformat: TGLenum; width: TGLsizei; height: TGLsizei); stdcall;

PFNGLGETRENDERBUFFERPARAMETERIVPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLISFRAMEBUFFERPROC = function(framebuffer: TGLuint): TGLboolean; stdcall;

PFNGLBINDFRAMEBUFFERPROC = procedure(target: TGLenum; framebuffer: TGLuint); stdcall;

PFNGLDELETEFRAMEBUFFERSPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

PFNGLGENFRAMEBUFFERSPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

PFNGLCHECKFRAMEBUFFERSTATUSPROC = function(target: TGLenum): TGLenum; stdcall;

PFNGLFRAMEBUFFERTEXTURE1DPROC = procedure(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTURE2DPROC = procedure(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTURE3DPROC = procedure(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint; layer: TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTURELAYERPROC = procedure(target: TGLenum; attachment: TGLenum; texture: TGLuint; level: TGLint; layer: TGLint); stdcall;

PFNGLFRAMEBUFFERRENDERBUFFERPROC = procedure(target: TGLenum; attachment: TGLenum; renderbuffertarget: TGLenum; renderbuffer: TGLuint); stdcall;

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC = procedure(target: TGLenum; attachment: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLBLITFRAMEBUFFERPROC = procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: TGLenum); stdcall;

PFNGLGENERATEMIPMAPPROC = procedure(target: TGLenum); stdcall;

PFNGLPROGRAMPARAMETERIARBPROC = procedure ( _program:TGLuint; pname:TGLenum; value: TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTUREARBPROC = procedure ( target:TGLenum; attachment:TGLenum; texture:TGLuint; level:TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTURELAYERARBPROC = procedure ( target:TGLenum; attachment:TGLenum; texture:TGLuint; level:TGLint; layer:TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTUREFACEARBPROC = procedure ( target:TGLenum; attachment:TGLenum; texture:TGLuint; level:TGLint; face:TGLenum); stdcall;

PFNGLVERTEXATTRIBDIVISORARBPROC = procedure(index: TGLuint; divisor: TGLuint); stdcall;

PFNGLMAPBUFFERRANGEPROC = function(target: TGLenum; offset: TGLint; length: TGLsizei; access: TGLbitfield ): Pointer; stdcall;

PFNGLFLUSHMAPPEDBUFFERRANGEPROC = procedure( target: TGLenum; offset: TGLint; length: TGLsizei ); stdcall;

PFNGLTEXBUFFERARBPROC = procedure(target: TGLenum; internalformat: TGLEnum; buffer: TGLuint); stdcall;

PFNGLBINDVERTEXARRAYPROC = procedure(_array: TGLuint); stdcall;

PFNGLDELETEVERTEXARRAYSPROC = procedure(n: TGLsizei; arrays: PGLuint); stdcall;

PFNGLGENVERTEXARRAYSPROC = procedure(n: TGLsizei; arrays: PGLuint); stdcall;

PFNGLISVERTEXARRAYPROC = function(_array: TGLuint): TGLboolean; stdcall;

PFNGLGETUNIFORMINDICESPROC = procedure(_program: TGLuint; uniformCount: TGLsizei; uniformNames: PGLPCharArray; uniformIndices: PGLuint); stdcall;

PFNGLGETACTIVEUNIFORMSIVPROC = procedure(_program: TGLuint; uniformCount: TGLsizei; uniformIndices: PGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETACTIVEUNIFORMNAMEPROC = procedure(_program: TGLuint; uniformIndex: TGLuint; bufSize: TGLsizei; length: PGLsizei; uniformName: PGLchar); stdcall;

PFNGLGETUNIFORMBLOCKINDEXPROC = function(_program: TGLuint; uniformBlockName: PGLchar): TGLuint; stdcall;

PFNGLGETACTIVEUNIFORMBLOCKIVPROC = procedure(_program: TGLuint; uniformBlockIndex: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC = procedure(_program: TGLuint; uniformBlockIndex: TGLuint; bufSize: TGLsizei; length: PGLsizei; uniformBlockName: PGLchar); stdcall;

PFNGLUNIFORMBLOCKBINDINGPROC = procedure(_program: TGLuint; uniformBlockIndex: TGLuint; uniformBlockBinding: TGLuint); stdcall;

PFNGLCOPYBUFFERSUBDATAPROC = procedure(readTarget: TGLenum; writeTarget: TGLenum; readOffset: TGLintptr; writeOffset: TGLintptr; size: TGLsizeiptr); stdcall;

PFNGLDRAWELEMENTSBASEVERTEXPROC = procedure(mode: TGLenum; count: TGLsizei; _type: TGLenum; indices: PGLvoid; basevertex: TGLint); stdcall;

PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC = procedure(mode: TGLenum; start: TGLuint; _end: TGLuint; count: TGLsizei; _type: TGLenum; indices: PGLvoid; basevertex: TGLint); stdcall;

PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC = procedure(mode: TGLenum; count: TGLsizei; _type: TGLenum; indices: PGLvoid; primcount: TGLsizei; basevertex: TGLint); stdcall;

PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC = procedure(mode: TGLenum; count: PGLsizei; _type: TGLenum; var indices; primcount: TGLsizei; basevertex: PGLint); stdcall;

PFNGLPROVOKINGVERTEXPROC = procedure(mode: TGLenum); stdcall;

PFNGLFENCESYNCPROC = function(condition: TGLenum; flags: TGLbitfield): TGLsync; stdcall;

PFNGLISSYNCPROC = function(sync: TGLsync): TGLboolean; stdcall;

PFNGLDELETESYNCPROC = procedure(sync: TGLsync); stdcall;

PFNGLCLIENTWAITSYNCPROC = function(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64): TGLenum; stdcall;

PFNGLWAITSYNCPROC = procedure(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64); stdcall;

PFNGLGETINTEGER64VPROC = procedure(pname: TGLenum; params: PGLint64); stdcall;

PFNGLGETSYNCIVPROC = procedure(sync: TGLsync; pname: TGLenum; bufSize: TGLsizei; length: PGLsizei; values: PGLint); stdcall;

PFNGLTEXIMAGE2DMULTISAMPLEPROC = procedure(target: TGLenum; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

PFNGLTEXIMAGE3DMULTISAMPLEPROC = procedure(target: TGLenum; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

PFNGLGETMULTISAMPLEFVPROC = procedure(pname: TGLenum; index: TGLuint; val: PGLfloat); stdcall;

PFNGLSAMPLEMASKIPROC = procedure(index: TGLuint; mask: TGLbitfield); stdcall;

PFNGLBLENDEQUATIONIARBPROC = procedure(buf: TGLuint; mode: TGLenum); stdcall;

PFNGLBLENDEQUATIONSEPARATEIARBPROC = procedure(buf: TGLuint; modeRGB: TGLenum; modeAlpha: TGLenum); stdcall;

PFNGLBLENDFUNCIARBPROC = procedure(buf: TGLuint; src: TGLenum; dst: TGLenum); stdcall;

PFNGLBLENDFUNCSEPARATEIARBPROC = procedure(buf: TGLuint; srcRGB: TGLenum; dstRGB: TGLenum; srcAlpha: TGLenum; dstAlpha: TGLenum); stdcall;

PFNGLMINSAMPLESHADINGARBPROC = procedure(value: TGLclampf); stdcall;

PFNGLBINDFRAGDATALOCATIONINDEXEDPROC = procedure (_program: TGLuint; colorNumber: TGLuint; index: TGLuint; const name: PGLchar); stdcall;

PFNGLGETFRAGDATAINDEXPROC = function (_program: TGLuint; const name: PGLchar): TGLint; stdcall;

PFNGLGENSAMPLERSPROC = procedure(count: TGLsizei; samplers: PGLuint); stdcall;

PFNGLDELETESAMPLERSPROC = procedure(count: TGLsizei; const samplers: PGLuint); stdcall;

PFNGLISSAMPLERPROC = function(sampler: TGLuint): TGLboolean; stdcall;

PFNGLBINDSAMPLERPROC = procedure(_unit: TGLuint; sampler: TGLuint); stdcall;

PFNGLSAMPLERPARAMETERIPROC = procedure(sampler: TGLuint; pname: TGLenum; param: TGLint); stdcall;

PFNGLSAMPLERPARAMETERIVPROC = procedure(sampler: TGLuint; pname: TGLenum; const params: PGLint); stdcall;

PFNGLSAMPLERPARAMETERFPROC = procedure(sampler: TGLuint; pname: TGLenum; param: TGLfloat); stdcall;

PFNGLSAMPLERPARAMETERFVPROC = procedure(sampler: TGLuint; pname: TGLenum; const params: PGLfloat); stdcall;

PFNGLSAMPLERPARAMETERIIVPROC = procedure(sampler: TGLuint; pname: TGLenum; const params: PGLint); stdcall;

PFNGLSAMPLERPARAMETERIUIVPROC = procedure(sampler: TGLuint; pname: TGLenum; const params: PGLuint); stdcall;

PFNGLGETSAMPLERPARAMETERIVPROC = procedure(sampler: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETSAMPLERPARAMETERIIVPROC = procedure(sampler: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETSAMPLERPARAMETERFVPROC = procedure(sampler: TGLuint; pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETSAMPLERPARAMETERIFVPROC = procedure(sampler: TGLuint; pname: TGLenum; params: PGLfloat); stdcall;

PFNGLQUERYCOUNTERPROC = procedure(id: TGLuint; target: TGLenum); stdcall;

PFNGLGETQUERYOBJECTI64VPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLint64); stdcall;

PFNGLGETQUERYOBJECTUI64VPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLuint64); stdcall;

PFNGLVERTEXP2UIPROC = procedure(_type: TGLenum; value: TGLuint); stdcall;

PFNGLVERTEXP2UIVPROC = procedure(_type: TGLenum; const value: PGLuint ); stdcall;

PFNGLVERTEXP3UIPROC = procedure(_type: TGLenum; value: TGLuint); stdcall;

PFNGLVERTEXP3UIVPROC = procedure(_type: TGLenum; const value: PGLuint); stdcall;

PFNGLVERTEXP4UIPROC = procedure(_type: TGLenum; value: TGLuint); stdcall;

PFNGLVERTEXP4UIVPROC = procedure(_type: TGLenum; const value: PGLuint); stdcall;

PFNGLTEXCOORDP1UIPROC = procedure(_type: TGLenum; coords: TGLuint); stdcall;

PFNGLTEXCOORDP1UIVPROC = procedure(_type: TGLenum; const coords: PGLuint); stdcall;

PFNGLTEXCOORDP2UIPROC = procedure(_type: TGLenum; coords: TGLuint); stdcall;

PFNGLTEXCOORDP2UIVPROC = procedure(_type: TGLenum; const coords: PGLuint); stdcall;

PFNGLTEXCOORDP3UIPROC = procedure(_type: TGLenum; coords: TGLuint); stdcall;

PFNGLTEXCOORDP3UIVPROC = procedure(_type: TGLenum; const coords: PGLuint); stdcall;

PFNGLTEXCOORDP4UIPROC = procedure(_type: TGLenum; coords: TGLuint); stdcall;

PFNGLTEXCOORDP4UIVPROC = procedure(_type: TGLenum; const coords: PGLuint); stdcall;

PFNGLMULTITEXCOORDP1UIPROC = procedure(texture: TGLenum; _type: GLenum; coords: TGLuint); stdcall;

PFNGLMULTITEXCOORDP1UIVPROC = procedure(texture: TGLenum; _type: GLenum; const coords: PGLuint); stdcall;

PFNGLMULTITEXCOORDP2UIPROC = procedure(texture: TGLenum; _type: GLenum; coords: TGLuint); stdcall;

PFNGLMULTITEXCOORDP2UIVPROC = procedure(texture: TGLenum; _type: GLenum; const coords: PGLuint); stdcall;

PFNGLMULTITEXCOORDP3UIPROC = procedure(texture: TGLenum; _type: GLenum; coords: TGLuint); stdcall;

PFNGLMULTITEXCOORDP3UIVPROC = procedure(texture: TGLenum; _type: GLenum; const coords: PGLuint); stdcall;

PFNGLMULTITEXCOORDP4UIPROC = procedure(texture: TGLenum; _type: GLenum; coords: TGLuint); stdcall;

PFNGLMULTITEXCOORDP4UIVPROC = procedure(texture: TGLenum; _type: GLenum; const coords: PGLuint); stdcall;

PFNGLNORMALP3UIPROC = procedure(_type: TGLenum; coords: TGLuint); stdcall;

PFNGLNORMALP3UIVPROC = procedure(_type: TGLenum; const coords: PGLuint); stdcall;

PFNGLCOLORP3UIPROC = procedure(_type: TGLenum; color: TGLuint); stdcall;

PFNGLCOLORP3UIVPROC = procedure(_type: TGLenum; const color: PGLuint); stdcall;

PFNGLCOLORP4UIPROC = procedure(_type: TGLenum; color: TGLuint); stdcall;

PFNGLCOLORP4UIVPROC = procedure(_type: TGLenum; const color: PGLuint); stdcall;

PFNGLSECONDARYCOLORP3UIPROC = procedure(_type: TGLenum; color: TGLuint); stdcall;

PFNGLSECONDARYCOLORP3UIVPROC = procedure(_type: TGLenum; const color: PGLuint); stdcall;

PFNGLVERTEXATTRIBP1UIPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; value: TGLuint); stdcall;

PFNGLVERTEXATTRIBP1UIVPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; const value: PGLuint); stdcall;

PFNGLVERTEXATTRIBP2UIPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; value: TGLuint); stdcall;

PFNGLVERTEXATTRIBP2UIVPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; const value: PGLuint); stdcall;

PFNGLVERTEXATTRIBP3UIPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; value: TGLuint); stdcall;

PFNGLVERTEXATTRIBP3UIVPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; const value: PGLuint); stdcall;

PFNGLVERTEXATTRIBP4UIPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; value: TGLuint); stdcall;

PFNGLVERTEXATTRIBP4UIVPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; const value: PGLuint); stdcall;

PFNGLDRAWARRAYSINDIRECTPROC = procedure(mode: TGLenum; const indirect: PGLvoid); stdcall;

PFNGLDRAWELEMENTSINDIRECTPROC = procedure(mode: TGLenum; _type: TGLenum; const indirect: PGLvoid); stdcall;

PFNGLUNIFORM1DPROC = procedure(location: TGLint; x: TGLdouble); stdcall;

PFNGLUNIFORM2DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

PFNGLUNIFORM3DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

PFNGLUNIFORM4DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

PFNGLUNIFORM1DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLUNIFORM2DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLUNIFORM3DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLUNIFORM4DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX2X3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX2X4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX3X2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX3X4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX4X2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX4X3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLGETUNIFORMDVPROC = procedure(_program: TGLuint; location: TGLint; params : PGLdouble); stdcall;

PFNGLCLIENTATTRIBDEFAULTEXTPROC = procedure(mask: GLbitfield); stdcall;

PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC = procedure(mask: GLbitfield); stdcall;

PFNGLMATRIXLOADFEXTPROC = procedure(mode: GLenum; const m: PGLfloat); stdcall;

PFNGLMATRIXLOADDEXTPROC = procedure(mode: GLenum; const m: PGLdouble); stdcall;

PFNGLMATRIXMULTFEXTPROC = procedure(mode: GLenum; const m: PGLfloat); stdcall;

PFNGLMATRIXMULTDEXTPROC = procedure(mode: GLenum; const m: PGLdouble); stdcall;

PFNGLMATRIXLOADIDENTITYEXTPROC = procedure(mode: GLenum); stdcall;

PFNGLMATRIXROTATEFEXTPROC = procedure(mode: GLenum; angle: GLfloat; x: GLfloat; y: GLfloat; z: GLfloat); stdcall;

PFNGLMATRIXROTATEDEXTPROC = procedure(mode: GLenum; angle: GLdouble; x: GLdouble; y: GLdouble; z: GLdouble); stdcall;

PFNGLMATRIXSCALEFEXTPROC = procedure(mode: GLenum; x: GLfloat; y: GLfloat; z: GLfloat); stdcall;

PFNGLMATRIXSCALEDEXTPROC = procedure(mode: GLenum; x: GLdouble; y: GLdouble; z: GLdouble); stdcall;

PFNGLMATRIXTRANSLATEFEXTPROC = procedure(mode: GLenum; x: GLfloat; y: GLfloat; z: GLfloat); stdcall;

PFNGLMATRIXTRANSLATEDEXTPROC = procedure(mode: GLenum; x: GLdouble; y: GLdouble; z: GLdouble); stdcall;

PFNGLMATRIXFRUSTUMEXTPROC = procedure(mode: GLenum; left: GLdouble; right: GLdouble; bottom: GLdouble; top: GLdouble; zNear: GLdouble; zFar: GLdouble); stdcall;

PFNGLMATRIXORTHOEXTPROC = procedure(mode: GLenum; left: GLdouble; right: GLdouble; bottom: GLdouble; top: GLdouble; zNear: GLdouble; zFar: GLdouble); stdcall;

PFNGLMATRIXPOPEXTPROC = procedure(mode: GLenum); stdcall;

PFNGLMATRIXPUSHEXTPROC = procedure(mode: GLenum); stdcall;

PFNGLMATRIXLOADTRANSPOSEFEXTPROC = procedure(mode: GLenum; const m: PGLfloat); stdcall;

PFNGLMATRIXLOADTRANSPOSEDEXTPROC = procedure(mode: GLenum; const m: PGLdouble); stdcall;

PFNGLMATRIXMULTTRANSPOSEFEXTPROC = procedure(mode: GLenum; const m: PGLfloat); stdcall;

PFNGLMATRIXMULTTRANSPOSEDEXTPROC = procedure(mode: GLenum; const m: PGLdouble); stdcall;

PFNGLTEXTUREPARAMETERFEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; param: GLfloat); stdcall;

PFNGLTEXTUREPARAMETERFVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; const params: PGLfloat); stdcall;

PFNGLTEXTUREPARAMETERIEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; param: GLint); stdcall;

PFNGLTEXTUREPARAMETERIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; const params: PGLint); stdcall;

PFNGLTEXTUREIMAGE1DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; border: GLint; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLTEXTUREIMAGE2DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; border: GLint; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLTEXTURESUBIMAGE1DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; width: GLsizei; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLTEXTURESUBIMAGE2DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; width: GLsizei; height: GLsizei; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLCOPYTEXTUREIMAGE1DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; x: GLint; y: GLint; width: GLsizei; border: GLint); stdcall;

PFNGLCOPYTEXTUREIMAGE2DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; x: GLint; y: GLint; width: GLsizei; height: GLsizei; border: GLint); stdcall;

PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; x: GLint; y: GLint; width: GLsizei); stdcall;

PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; x: GLint; y: GLint; width: GLsizei; height: GLsizei); stdcall;

PFNGLGETTEXTUREIMAGEEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; format: GLenum; type_: GLenum; pixels: PGLvoid); stdcall;

PFNGLGETTEXTUREPARAMETERFVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETTEXTUREPARAMETERIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; pname: GLenum; params: GLint); stdcall;

PFNGLTEXTUREIMAGE3DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; depth: GLsizei; border: GLint; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLTEXTURESUBIMAGE3DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; zoffset: GLint; width: GLsizei; height: GLsizei; depth: GLsizei; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; zoffset: GLint; x: GLint; y: GLint; width: GLsizei; height: GLsizei); stdcall;

PFNGLMULTITEXPARAMETERFEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; param: GLfloat); stdcall;

PFNGLMULTITEXPARAMETERFVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; const params: PGLfloat); stdcall;

PFNGLMULTITEXPARAMETERIEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; param: GLint); stdcall;

PFNGLMULTITEXPARAMETERIVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; const params: PGLint); stdcall;

PFNGLMULTITEXIMAGE1DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; border: GLint; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLMULTITEXIMAGE2DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; border: GLint; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; width: GLsizei; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; width: GLsizei; height: GLsizei; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLCOPYMULTITEXIMAGE1DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; x: GLint; y: GLint; width: GLsizei; border: GLint); stdcall;

PFNGLCOPYMULTITEXIMAGE2DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; x: GLint; y: GLint; width: GLsizei; height: GLsizei; border: GLint); stdcall;

PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; x: GLint; y: GLint; width: GLsizei); stdcall;

PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; x: GLint; y: GLint; width: GLsizei; height: GLsizei); stdcall;

PFNGLGETMULTITEXIMAGEEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; format: GLenum; type_: GLenum; pixels: PGLvoid); stdcall;

PFNGLGETMULTITEXPARAMETERFVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETMULTITEXPARAMETERIVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; pname: GLenum; params: PGLint); stdcall;

PFNGLMULTITEXIMAGE3DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; depth: GLsizei; border: GLint; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; zoffset: GLint; width: GLsizei; height: GLsizei; depth: GLsizei; format: GLenum; type_: GLenum; const pixels:PGLvoid); stdcall;

PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; zoffset: GLint; x: GLint; y: GLint; width: GLsizei; height: GLsizei); stdcall;

PFNGLBINDMULTITEXTUREEXTPROC = procedure(texunit: GLenum; target: GLenum; texture: GLuint); stdcall;

PFNGLENABLECLIENTSTATEINDEXEDEXTPROC = procedure(array_: GLenum; index_: GLuint); stdcall;

PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC = procedure(array_: GLenum; index_: GLuint); stdcall;

PFNGLMULTITEXCOORDPOINTEREXTPROC = procedure(texunit: GLenum; size: GLint; type_: GLenum; stride: GLsizei; const pointer: PGLvoid); stdcall;

PFNGLMULTITEXENVFEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; param: GLfloat); stdcall;

PFNGLMULTITEXENVFVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; const params: PGLfloat); stdcall;

PFNGLMULTITEXENVIEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; param: GLint); stdcall;

PFNGLMULTITEXENVIVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; const params: PGLint); stdcall;

PFNGLMULTITEXGENDEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; param: GLdouble); stdcall;

PFNGLMULTITEXGENDVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; const params: PGLdouble); stdcall;

PFNGLMULTITEXGENFEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; param: GLfloat); stdcall;

PFNGLMULTITEXGENFVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; const params: PGLfloat); stdcall;

PFNGLMULTITEXGENIEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; param: GLint); stdcall;

PFNGLMULTITEXGENIVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; const params: PGLint); stdcall;

PFNGLGETMULTITEXENVFVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETMULTITEXENVIVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETMULTITEXGENDVEXTPROC = procedure(texunit: GLenum; coord: GLenum; pname: GLenum; params: PGLdouble); stdcall;

PFNGLGETMULTITEXGENFVEXTPROC = procedure(texunit: GLenum; coord: GLenum; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETMULTITEXGENIVEXTPROC = procedure(texunit: GLenum; coord: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETFLOATINDEXEDVEXTPROC = procedure(target: GLenum; index_: GLuint; data: PGLfloat); stdcall;

PFNGLGETDOUBLEINDEXEDVEXTPROC = procedure(target: GLenum; index_: GLuint; data: PGLdouble); stdcall;

PFNGLGETPOINTERINDEXEDVEXTPROC = procedure(target: GLenum; index_: GLuint; data: PGLvoid); stdcall;

PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; depth: GLsizei; border: GLint; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; border: GLint; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; border: GLint; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; zoffset: GLint; width: GLsizei; height: GLsizei; depth: GLsizei; format: GLenum; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; width: GLsizei; height: GLsizei; format: GLenum; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; width: GLsizei; format: GLenum; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC = procedure(texture: GLuint; target: GLenum; lod: GLint; img: PGLvoid); stdcall;

PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; depth: GLsizei; border: GLint; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; border: GLint; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; border: GLint; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; zoffset: GLint; width: GLsizei; height: GLsizei; depth: GLsizei; format: GLenum; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; width: GLsizei; height: GLsizei; format: GLenum; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; width: GLsizei; format: GLenum; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC = procedure(texunit: GLenum; target: GLenum; lod: GLint; img: PGLvoid); stdcall;

PFNGLNAMEDPROGRAMSTRINGEXTPROC = procedure(program_: GLuint; target: GLenum; format: GLenum; len: GLsizei; const string_: PGLvoid); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; const params: PGLdouble); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; x: GLfloat; y: GLfloat; z: GLfloat; w: GLfloat); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; const params: PGLfloat); stdcall;

PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; params: PGLdouble); stdcall;

PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; params: PGLfloat); stdcall;

PFNGLGETNAMEDPROGRAMIVEXTPROC = procedure(program_: GLuint; target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETNAMEDPROGRAMSTRINGEXTPROC = procedure(program_: GLuint; target: GLenum; pname: GLenum; string_: PGLvoid); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; count: GLsizei; const params: PGLfloat); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; x: GLint; y: GLint; z: GLint; w: GLint); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; const params: PGLint); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; count: GLsizei; const params: PGLint); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; x: GLuint; y: GLuint; z: GLuint; w: GLuint); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; const params: PGLuint); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; count: GLsizei; const params: PGLuint); stdcall;

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; params: PGLint); stdcall;

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; params: PGLuint); stdcall;

PFNGLTEXTUREPARAMETERIIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; const params: PGLint); stdcall;

PFNGLTEXTUREPARAMETERIUIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; const params: PGLuint); stdcall;

PFNGLGETTEXTUREPARAMETERIIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETTEXTUREPARAMETERIUIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; params: PGLuint); stdcall;

PFNGLMULTITEXPARAMETERIIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; const params: PGLint); stdcall;

PFNGLMULTITEXPARAMETERIUIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; const params: PGLuint); stdcall;

PFNGLGETMULTITEXPARAMETERIIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETMULTITEXPARAMETERIUIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; params: PGLuint); stdcall;

PFNGLNAMEDBUFFERDATAEXTPROC = procedure(buffer: GLuint; size: GLsizei; const data: PGLvoid; usage: GLenum); stdcall;

PFNGLNAMEDBUFFERSUBDATAEXTPROC = procedure(buffer: GLuint; offset: GLintptr; size: GLsizeiptr; const data: PGLvoid); stdcall;

PFNGLMAPNAMEDBUFFEREXTPROC = function(buffer: GLuint; access: GLenum): PGLvoid; stdcall;

PFNGLUNMAPNAMEDBUFFEREXTPROC = function(buffer: GLuint): GLboolean; stdcall;

PFNGLMAPNAMEDBUFFERRANGEEXTPROC = function(buffer: GLuint; offset: GLintptr; length: GLsizeiptr; access: GLbitfield): PGLvoid; stdcall;

PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC = procedure(buffer: GLuint; offset: GLintptr; length: GLsizeiptr); stdcall;

PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC = procedure(readBuffer: GLuint; writeBuffer: GLuint; readOffset: GLintptr; writeOffset: GLintptr; size: GLsizeiptr); stdcall;

PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC = procedure(buffer: GLuint; pname: GLenum; params: PGLint); stdcall;

PFNGLGETNAMEDBUFFERPOINTERVEXTPROC = procedure(buffer: GLuint; pname: GLenum; params: PGLvoid); stdcall;

PFNGLGETNAMEDBUFFERSUBDATAEXTPROC = procedure(buffer: GLuint; offset: GLintptr; size: GLsizeiptr; data: PGLvoid); stdcall;

PFNGLTEXTUREBUFFEREXTPROC = procedure(texture: GLuint; target: GLenum; internalformat: GLenum; buffer: GLuint); stdcall;

PFNGLMULTITEXBUFFEREXTPROC = procedure(texunit: GLenum; target: GLenum; interformat: GLenum; buffer: GLuint); stdcall;

PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC = procedure(renderbuffer: GLuint; interformat: GLenum; width: GLsizei; height: GLsizei); stdcall;

PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC = procedure(renderbuffer: GLuint; pname: GLenum; params: PGLint); stdcall;

PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC = function(framebuffer: GLuint; target: GLenum): GLenum; stdcall;

PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; textarget: GLenum; texture: GLuint; level: GLint); stdcall;

PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; textarget: GLenum; texture: GLuint; level: GLint); stdcall;

PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; textarget: GLenum; texture: GLuint; level: GLint; zoffset: GLint); stdcall;

PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; renderbuffertarget: GLenum; renderbuffer: GLuint); stdcall;

PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGENERATETEXTUREMIPMAPEXTPROC = procedure(texture: GLuint; target: GLenum); stdcall;

PFNGLGENERATEMULTITEXMIPMAPEXTPROC = procedure(texunit: GLenum; target: GLenum); stdcall;

PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC = procedure(framebuffer: GLuint; mode: GLenum); stdcall;

PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC = procedure(framebuffer: GLuint; n: GLsizei; const bufs: PGLenum); stdcall;

PFNGLFRAMEBUFFERREADBUFFEREXTPROC = procedure(framebuffer: GLuint; mode: GLenum); stdcall;

PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC = procedure(framebuffer: GLuint; pname: GLenum; params: PGLint); stdcall;

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC = procedure(renderbuffer: GLuint; samples: GLsizei; internalformat: GLenum; width: GLsizei; height: GLsizei); stdcall;

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC = procedure(renderbuffer: GLuint; coverageSamples: GLsizei; colorSamples: GLsizei; internalformat: GLenum; width: GLsizei; height: GLsizei); stdcall;

PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; texture: GLuint; level: GLint); stdcall;

PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; texture: GLuint; level: GLint; layer: GLint); stdcall;

PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; texture: GLuint; level: GLint; face: GLenum); stdcall;

PFNGLTEXTURERENDERBUFFEREXTPROC = procedure(texture: GLuint; target: GLenum; renderbuffer: GLuint); stdcall;

PFNGLMULTITEXRENDERBUFFEREXTPROC = procedure(texunit: GLenum; target: GLenum; renderbuffer: GLuint); stdcall;

PFNGLPROGRAMUNIFORM1DEXTPROC = procedure(_program: TGLuint; location: TGLint; x: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM2DEXTPROC = procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM3DEXTPROC = procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM4DEXTPROC = procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM1DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORM2DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORM3DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORM4DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2X3DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2X4DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3X2DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3X4DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4X2DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4X3DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLGETSUBROUTINEUNIFORMLOCATIONPROC = function(_program: TGLuint; shadertype: TGLenum; const name: PGLchar): TGLint; stdcall;

PFNGLGETSUBROUTINEINDEXPROC = function(_program: TGLuint; shadertype: TGLenum; const name: PGLchar): TGLuint; stdcall;

PFNGLGETACTIVESUBROUTINEUNIFORMIVPROC = procedure(_program: TGLuint; shadertype: TGLenum; index: TGLuint; pname: TGLenum; values: PGLint); stdcall;

PFNGLGETACTIVESUBROUTINEUNIFORMNAMEPROC = procedure(_program: TGLuint; shadertype: TGLenum; index: TGLuint; bufsize: TGLsizei; length: PGLsizei; name: PGLchar); stdcall;

PFNGLGETACTIVESUBROUTINENAMEPROC = procedure(_program: TGLuint; shadertype: TGLenum; index: TGLuint; bufsize: TGLsizei; length: PGLsizei; name: PGLchar); stdcall;

PFNGLUNIFORMSUBROUTINESUIVPROC = procedure(shadertype: TGLenum; count: TGLsizei; const indices: PGLuint); stdcall;

PFNGLGETUNIFORMSUBROUTINEUIVPROC = procedure(shadertype: TGLenum; location: TGLint; params: PGLuint); stdcall;

PFNGLGETPROGRAMSTAGEIVPROC = procedure(_program: TGLuint; shadertype: TGLenum; pname: TGLenum; values: PGLint); stdcall;

PFNGLPATCHPARAMETERIPROC = procedure(pname: TGLenum; value: TGLint); stdcall;

PFNGLPATCHPARAMETERFVPROC = procedure(pname: TGLenum; const values: PGLfloat); stdcall;

PFNGLBINDTRANSFORMFEEDBACKPROC = procedure(target: TGLenum; id: TGLuint); stdcall;

PFNGLDELETETRANSFORMFEEDBACKSPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

PFNGLGENTRANSFORMFEEDBACKSPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

PFNGLISTRANSFORMFEEDBACKPROC = function(id: TGLuint): TGLboolean; stdcall;

PFNGLPAUSETRANSFORMFEEDBACKPROC = procedure(); stdcall;

PFNGLRESUMETRANSFORMFEEDBACKPROC = procedure(); stdcall;

PFNGLDRAWTRANSFORMFEEDBACKPROC = procedure(mode: TGLenum; id: TGLuint); stdcall;

PFNGLDRAWTRANSFORMFEEDBACKSTREAMPROC = procedure(mode: TGLenum; id: TGLuint; stream: TGLuint); stdcall;

PFNGLBEGINQUERYINDEXEDPROC = procedure(target: TGLenum; index: TGLuint; id: TGLuint); stdcall;

PFNGLENDQUERYINDEXEDPROC = procedure(target: TGLenum; index: TGLuint); stdcall;

PFNGLGETQUERYINDEXEDIVPROC = procedure(target: TGLenum; index: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLRELEASESHADERCOMPILERPROC = procedure(); stdcall;

PFNGLSHADERBINARYPROC = procedure(count: TGLsizei; shaders: PGLuint; binaryformat: TGLenum; binary: Pointer; length: TGLsizei); stdcall;

PFNGLGETSHADERPRECISIONFORMATPROC = procedure(shadertype: TGLenum; precisiontype: TGLenum; range: PGLint; precision: PGLint); stdcall;

PFNGLDEPTHRANGEFPROC = procedure(n: TGLclampf; f: TGLclampf); stdcall;

PFNGLCLEARDEPTHFPROC = procedure(d: TGLclampf); stdcall;

PFNGLGETPROGRAMBINARYPROC = procedure(_program: TGLuint; bufSize: TGLsizei; length: PGLsizei; binaryFormat: PGLenum; binary: Pointer); stdcall;

PFNGLPROGRAMBINARYPROC = procedure(_program: TGLuint; binaryFormat: TGLEnum; binary: Pointer; length: TGLsizei); stdcall;

PFNGLPROGRAMPARAMETERIPROC = procedure(_program: TGLuint; pname: TGLenum; value: TGLint); stdcall;

PFNGLUSEPROGRAMSTAGESPROC = procedure(pipeline: TGLuint; stages: TGLbitfield; _program: TGLuint); stdcall;

PFNGLACTIVESHADERPROGRAMPROC = procedure(pipeline: TGLuint; _program: TGLuint); stdcall;

PFNGLCREATESHADERPROGRAMVPROC = function(_type: TGLenum; count: TGLsizei; const strings: PGLPCharArray): TGLuint; stdcall;

PFNGLBINDPROGRAMPIPELINEPROC = procedure(pipeline: TGLuint); stdcall;

PFNGLDELETEPROGRAMPIPELINESPROC = procedure(n: TGLsizei; pipelines: PGLuint); stdcall;

PFNGLGENPROGRAMPIPELINESPROC = procedure(n: TGLsizei; pipelines: PGLuint); stdcall;

PFNGLISPROGRAMPIPELINEPROC = function(pipeline: TGLuint): TGLboolean; stdcall;

PFNGLGETPROGRAMPIPELINEIVPROC = procedure(pipeline: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLPROGRAMUNIFORM1IPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLint); stdcall;

PFNGLPROGRAMUNIFORM1IVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

PFNGLPROGRAMUNIFORM1FPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLfloat); stdcall;

PFNGLPROGRAMUNIFORM1FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORM1DPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM1DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORM1UIPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLuint); stdcall;

PFNGLPROGRAMUNIFORM1UIVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

PFNGLPROGRAMUNIFORM2IPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLint; v1: TGLint); stdcall;

PFNGLPROGRAMUNIFORM2IVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

PFNGLPROGRAMUNIFORM2FPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLfloat; v1: TGLfloat); stdcall;

PFNGLPROGRAMUNIFORM2FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORM2DPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLdouble; v1: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM2DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORM2UIPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLuint; v1: TGLuint); stdcall;

PFNGLPROGRAMUNIFORM2UIVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

PFNGLPROGRAMUNIFORM3IPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint); stdcall;

PFNGLPROGRAMUNIFORM3IVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

PFNGLPROGRAMUNIFORM3FPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat); stdcall;

PFNGLPROGRAMUNIFORM3FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORM3DPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLdouble; v1: TGLdouble; v2: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM3DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORM3UIPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLuint; v1: TGLuint; v2: TGLuint); stdcall;

PFNGLPROGRAMUNIFORM3UIVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

PFNGLPROGRAMUNIFORM4IPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint; v3: TGLint); stdcall;

PFNGLPROGRAMUNIFORM4IVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

PFNGLPROGRAMUNIFORM4FPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat; v3: TGLfloat); stdcall;

PFNGLPROGRAMUNIFORM4FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORM4DPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLdouble; v1: TGLdouble; v2: TGLdouble; v3: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM4DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORM4UIPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLuint; v1: TGLuint; v2: TGLuint; v3: TGLuint); stdcall;

PFNGLPROGRAMUNIFORM4UIVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLVALIDATEPROGRAMPIPELINEPROC = procedure(pipeline: TGLuint); stdcall;

PFNGLGETPROGRAMPIPELINEINFOLOGPROC = procedure(pipeline: TGLuint; bufSize: TGLsizei; length: PGLsizei; infoLog: PGLchar); stdcall;

PFNGLVERTEXATTRIBL1DPROC = procedure(index: TGLuint; x: TGLdouble); stdcall;

PFNGLVERTEXATTRIBL2DPROC = procedure(index: TGLuint; x: TGLdouble; y: TGLdouble); stdcall;

PFNGLVERTEXATTRIBL3DPROC = procedure(index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

PFNGLVERTEXATTRIBL4DPROC = procedure(index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

PFNGLVERTEXATTRIBL1DVPROC = procedure(index: TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIBL2DVPROC = procedure(index: TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIBL3DVPROC = procedure(index: TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIBL4DVPROC = procedure(index: TGLuint; v :PGLdouble); stdcall;

PFNGLVERTEXATTRIBLPOINTERPROC = procedure(index: TGLuint; size: TGLint; _type: TGLenum; stride: TGLsizei; ptr: Pointer); stdcall;

PFNGLGETVERTEXATTRIBLDVPROC = procedure(index: TGLuint; pname: TGLenum; params: PGLdouble); stdcall;

PFNGLVERTEXARRAYVERTEXATTRIBLOFFSETEXTPROC = procedure (vaobj: TGLuint; buffer: TGLuint; index: TGLuint; size: TGLint; _type: TGLenum; stride: TGLsizei; offset: TGLintptr); stdcall;

PFNGLVIEWPORTARRAYVPROC = procedure(first: TGLuint; count: TGLsizei; v: PGLfloat); stdcall;

PFNGLVIEWPORTINDEXEDFPROC = procedure(index: TGLuint; x: TGLfloat; y: TGLfloat; w: TGLfloat; h: TGLfloat); stdcall;

PFNGLVIEWPORTINDEXEDFVPROC = procedure(index: TGLuint; v: PGLfloat); stdcall;

PFNGLSCISSORARRAYVPROC = procedure(first: TGLuint; count: TGLsizei; v: PGLint); stdcall;

PFNGLSCISSORINDEXEDPROC = procedure(index: TGLuint; left: TGLint; bottom: TGLint; width: TGLsizei; height: TGLsizei); stdcall;

PFNGLSCISSORINDEXEDVPROC = procedure(index: TGLuint; v: PGLint); stdcall;

PFNGLDEPTHRANGEARRAYVPROC = procedure(first: TGLuint; count: TGLsizei; v: PGLclampd); stdcall;

PFNGLDEPTHRANGEINDEXEDPROC = procedure(index: TGLuint; n: TGLclampd; f: TGLclampd); stdcall;

PFNGLGETFLOATI_VPROC = procedure(target: TGLenum; index: TGLuint; data: PGLfloat); stdcall;

PFNGLGETDOUBLEI_VPROC = procedure(target: TGLenum; index: TGLuint; data: PGLdouble); stdcall;

PFNGLDEBUGMESSAGECONTROLARBPROC = procedure(source: TGLenum; _type: TGLenum; severity: TGLenum; count: TGLsizei; ids: PGLuint; enabled: TGLboolean); stdcall;

PFNGLDEBUGMESSAGEINSERTARBPROC = procedure(source: TGLenum; _type: TGLenum; id: TGLuint; severity: TGLenum; length: TGLsizei; buf: PGLchar); stdcall;

PFNGLDEBUGMESSAGECALLBACKARBPROC = procedure(callback: TGLDEBUGPROCARB; userParam: Pointer); stdcall;

PFNGLGETDEBUGMESSAGELOGARBPROC = function(count: TGLuint; bufsize: TGLsizei; sources: PGLenum; types: PGLenum; ids: PGLuint; severities: PGLenum; lengths: PGLsizei; messageLog: PGLchar): TGLuint; stdcall;

PFNGLGETGRAPHICSRESETSTATUSARBPROC = function(): TGLenum; stdcall;

PFNGLGETNMAPDVARBPROC = procedure(target: TGLenum; query: TGLenum; bufSize: TGLsizei; v: PGLdouble); stdcall;

PFNGLGETNMAPFVARBPROC = procedure(target: TGLenum; query: TGLenum; bufSize: TGLsizei; v: PGLfloat); stdcall;

PFNGLGETNMAPIVARBPROC = procedure(target: TGLenum; query: TGLenum; bufSize: TGLsizei; v: PGLint); stdcall;

PFNGLGETNPIXELMAPFVARBPROC = procedure(map: TGLenum; bufSize: TGLsizei; values: PGLfloat); stdcall;

PFNGLGETNPIXELMAPUIVARBPROC = procedure(map: TGLenum; bufSize: TGLsizei; values: PGLuint); stdcall;

PFNGLGETNPIXELMAPUSVARBPROC = procedure(map: TGLenum; bufSize: TGLsizei; values: PGLushort); stdcall;

PFNGLGETNPOLYGONSTIPPLEARBPROC = procedure(bufSize: TGLsizei; pattern: PGLubyte); stdcall;

PFNGLGETNCOLORTABLEARBPROC = procedure(target: TGLenum; format: TGLenum; _type: TGLenum; bufSize: TGLsizei; table: Pointer); stdcall;

PFNGLGETNCONVOLUTIONFILTERARBPROC = procedure(target: TGLenum; format: TGLenum; _type: TGLenum; bufSize: TGLsizei; image: Pointer); stdcall;

PFNGLGETNSEPARABLEFILTERARBPROC = procedure(target: TGLenum; format: TGLenum; _type: TGLenum; rowBufSize: TGLsizei; row: Pointer; columnBufSize: TGLsizei; column: Pointer; span: Pointer); stdcall;

PFNGLGETNHISTOGRAMARBPROC = procedure(target: TGLenum; reset: TGLboolean; format: TGLenum; _type: TGLenum; bufSize: TGLsizei; values: Pointer); stdcall;

PFNGLGETNMINMAXARBPROC = procedure(target: TGLenum; reset: TGLboolean; format: TGLenum; _type: TGLenum; bufSize: TGLsizei; values: Pointer); stdcall;

PFNGLGETNTEXIMAGEARBPROC = procedure(target: TGLenum; level: TGLint; format: TGLenum; _type: TGLenum; bufSize: TGLsizei; img: Pointer); stdcall;

PFNGLREADNPIXELSARBPROC = procedure(x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei; format: TGLenum; _type: TGLenum; bufSize: TGLsizei; data: Pointer); stdcall;

PFNGLGETNCOMPRESSEDTEXIMAGEARBPROC = procedure(target: TGLenum; lod: TGLint; bufSize: TGLsizei; img: Pointer); stdcall;

PFNGLGETNUNIFORMFVARBPROC = procedure(_program: TGLuint; location: TGLint; bufSize: TGLsizei; params: PGLfloat); stdcall;

PFNGLGETNUNIFORMIVARBPROC = procedure(_program: TGLuint; location: TGLint; bufSize: TGLsizei; params: PGLint); stdcall;

PFNGLGETNUNIFORMUIVARBPROC = procedure(_program: TGLuint; location: TGLint; bufSize: TGLsizei; params: PGLuint); stdcall;

PFNGLGETNUNIFORMDVARBPROC = procedure(_program: TGLuint; location: TGLint; bufSize: TGLsizei; params: PGLdouble); stdcall;

PFNGLARRAYELEMENTARRAYEXTPROC = procedure(mode: TGLEnum; count: TGLsizei; pi: Pointer); stdcall;

PFNGLADDSWAPHINTRECTWINPROC = procedure(x, y: TGLint; width, height: TGLsizei); stdcall;

PFNGLBLENDCOLOREXTPROC = procedure(red, green, blue: TGLclampf; alpha: TGLclampf); stdcall;

PFNGLPOLYGONOFFSETEXTPROC = procedure(factor, bias: TGLfloat); stdcall;

PFNGLTEXIMAGE3DEXTPROC = procedure(target: TGLenum; level: TGLint; internalformat: TGLenum; width, height, depth: TGLsizei; border: TGLint; Format, AType: TGLenum; pixels: Pointer); stdcall;

PFNGLTEXSUBIMAGE1DEXTPROC = procedure(target: TGLEnum; level, xoffset: TGLint; width: TGLsizei; format, Atype: TGLEnum; pixels: Pointer); stdcall;

PFNGLTEXSUBIMAGE2DEXTPROC = procedure(target: TGLEnum; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, Atype: TGLEnum; pixels: Pointer); stdcall;

PFNGLTEXSUBIMAGE3DEXTPROC = procedure(target: TGLEnum; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format, Atype: TGLEnum; pixels: Pointer); stdcall;

PFNGLCOPYTEXIMAGE1DEXTPROC = procedure(target: TGLEnum; level: TGLint; internalFormat: TGLEnum; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall;

PFNGLCOPYTEXIMAGE2DEXTPROC = procedure(target: TGLEnum; level: TGLint; internalFormat: TGLEnum; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall;

PFNGLCOPYTEXSUBIMAGE1DEXTPROC = procedure(target: TGLEnum; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall;

PFNGLCOPYTEXSUBIMAGE2DEXTPROC = procedure(target: TGLEnum; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

PFNGLCOPYTEXSUBIMAGE3DEXTPROC = procedure(target: TGLEnum; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

PFNGLGENTEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint); stdcall;

PFNGLDELETETEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint); stdcall;

PFNGLBINDTEXTUREEXTPROC = procedure(target: TGLEnum; texture: TGLuint); stdcall;

PFNGLPRIORITIZETEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint; priorities: PGLclampf); stdcall;

PFNGLARETEXTURESRESIDENTEXTPROC = function(n: TGLsizei; textures: PGLuint; residences: PGLBoolean): TGLboolean; stdcall;

PFNGLISTEXTUREEXTPROC = function(texture: TGLuint): TGLboolean; stdcall;

PFNGLSAMPLEMASKSGISPROC = procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

PFNGLSAMPLEPATTERNSGISPROC = procedure(pattern: TGLenum); stdcall;

PFNGLBLENDEQUATIONEXTPROC = procedure(mode: TGLenum); stdcall;

PFNGLCOLORTABLEEXTPROC = procedure(target, internalFormat: TGLEnum; width: TGLsizei; format, atype: TGLEnum; data: Pointer); stdcall;

PFNGLCOLORSUBTABLEEXTPROC = procedure(target: TGLEnum; start, count: TGLsizei; format, atype: TGLEnum; data: Pointer); stdcall;

PFNGLGETCOLORTABLEEXTPROC = procedure(target, format, atype: TGLEnum; data: Pointer); stdcall;

PFNGLGETCOLORTABLEPARAMETERFVEXTPROC = procedure(target, pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETCOLORTABLEPARAMETERIVEXTPROC = procedure(target, pname: TGLenum; params: PGLint); stdcall;

PFNGLINDEXMATERIALEXTPROC = procedure(face: TGLEnum; mode: TGLEnum); stdcall;

PFNGLINDEXFUNCEXTPROC = procedure(func: TGLEnum; ref: TGLfloat); stdcall;

PFNGLLOCKARRAYSEXTPROC = procedure(first: TGLint; count: TGLsizei); stdcall;

PFNGLUNLOCKARRAYSEXTPROC = procedure; stdcall;

PFNGLDRAWRANGEELEMENTSEXTPROC = procedure(mode: TGLenum; start, Aend: TGLuint; Count: TGLsizei; Atype: TGLenum; indices: Pointer); stdcall;

PFNGLBEGINSCENEEXTPROC = procedure; stdcall;

PFNGLENDSCENEEXTPROC = procedure; stdcall;

PFNGLSECONDARYCOLOR3BEXTPROC = procedure(red, green, blue: TGLbyte); stdcall;

PFNGLSECONDARYCOLOR3BVEXTPROC = procedure(v: PGLbyte); stdcall;

PFNGLSECONDARYCOLOR3DEXTPROC = procedure(red, green, blue: TGLdouble); stdcall;

PFNGLSECONDARYCOLOR3DVEXTPROC = procedure(v: PGLdouble); stdcall;

PFNGLSECONDARYCOLOR3FEXTPROC = procedure(red, green, blue: TGLfloat); stdcall;

PFNGLSECONDARYCOLOR3FVEXTPROC = procedure(v: PGLfloat); stdcall;

PFNGLSECONDARYCOLOR3IEXTPROC = procedure(red, green, blue: TGLint); stdcall;

PFNGLSECONDARYCOLOR3IVEXTPROC = procedure(v: PGLint); stdcall;

PFNGLSECONDARYCOLOR3SEXTPROC = procedure(red, green, blue: TGLshort); stdcall;

PFNGLSECONDARYCOLOR3SVEXTPROC = procedure(v: PGLshort); stdcall;

PFNGLSECONDARYCOLOR3UBEXTPROC = procedure(red, green, blue: TGLubyte); stdcall;

PFNGLSECONDARYCOLOR3UBVEXTPROC = procedure(v: PGLubyte); stdcall;

PFNGLSECONDARYCOLOR3UIEXTPROC = procedure(red, green, blue: TGLuint); stdcall;

PFNGLSECONDARYCOLOR3UIVEXTPROC = procedure(v: PGLuint); stdcall;

PFNGLSECONDARYCOLOR3USEXTPROC = procedure(red, green, blue: TGLushort); stdcall;

PFNGLSECONDARYCOLOR3USVEXTPROC = procedure(v: PGLushort); stdcall;

PFNGLSECONDARYCOLORPOINTEREXTPROC = procedure(Size: TGLint; Atype: TGLenum; stride: TGLsizei; p: pointer); stdcall;

PFNGLMULTIDRAWARRAYSEXTPROC = procedure(mode: TGLenum; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

PFNGLMULTIDRAWELEMENTSEXTPROC = procedure(mode: TGLenum; Count: PGLsizei; AType: TGLenum; var indices; primcount: TGLsizei); stdcall;

PFNGLFOGCOORDFEXTPROC = procedure(coord: TGLfloat); stdcall;

PFNGLFOGCOORDFVEXTPROC = procedure(coord: PGLfloat); stdcall;

PFNGLFOGCOORDDEXTPROC = procedure(coord: TGLdouble); stdcall;

PFNGLFOGCOORDDVEXTPROC = procedure(coord: PGLdouble); stdcall;

PFNGLFOGCOORDPOINTEREXTPROC = procedure(AType: TGLenum; stride: TGLsizei; p: Pointer); stdcall;

PFNGLBLENDFUNCSEPARATEEXTPROC = procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: TGLenum); stdcall;

PFNGLFLUSHVERTEXARRAYRANGENVPROC = procedure; stdcall;

PFNGLVERTEXARRAYRANGENVPROC = procedure(Size: TGLsizei; p: pointer); stdcall;

PFNWGLALLOCATEMEMORYNVPROC = function(size: TGLsizei; readFrequency, writeFrequency, priority: Single): Pointer; stdcall;

PFNWGLFREEMEMORYNVPROC = procedure(ptr: Pointer); stdcall;

PFNGLCOMBINERPARAMETERFVNVPROC = procedure(pname: TGLenum; params: PGLfloat); stdcall;

PFNGLCOMBINERPARAMETERFNVPROC = procedure(pname: TGLenum; param: TGLfloat); stdcall;

PFNGLCOMBINERPARAMETERIVNVPROC = procedure(pname: TGLenum; params: PGLint); stdcall;

PFNGLCOMBINERPARAMETERINVPROC = procedure(pname: TGLenum; param: TGLint); stdcall;

PFNGLCOMBINERINPUTNVPROC = procedure(stage, portion, variable, input, mapping, componentUsage: TGLenum); stdcall;

PFNGLCOMBINEROUTPUTNVPROC = procedure(stage, portion, abOutput, cdOutput, sumOutput, scale, bias: TGLenum; abDotProduct, cdDotProduct, muxSum: TGLboolean); stdcall;

PFNGLFINALCOMBINERINPUTNVPROC = procedure(variable, input, mapping, componentUsage: TGLenum); stdcall;

PFNGLGETCOMBINERINPUTPARAMETERFVNVPROC = procedure(stage, portion, variable, pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETCOMBINERINPUTPARAMETERIVNVPROC = procedure(stage, portion, variable, pname: TGLenum; params: PGLint); stdcall;

PFNGLGETCOMBINEROUTPUTPARAMETERFVNVPROC = procedure(stage, portion, pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC = procedure(stage, portion, pname: TGLenum; params: PGLint); stdcall;

PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC = procedure(variable, pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC = procedure(variable, pname: TGLenum; params: PGLint); stdcall;

PFNGLRESIZEBUFFERSMESAPROC = procedure; stdcall;

PFNGLTBUFFERMASK3DFXPROC = procedure(mask: TGLuint); stdcall;

PFNGLSAMPLEMASKEXTPROC = procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

PFNGLSAMPLEPATTERNEXTPROC = procedure(pattern: TGLenum); stdcall;

PFNGLTEXTURECOLORMASKSGISPROC = procedure(red, green, blue, alpha: TGLboolean); stdcall;

PFNGLGENFENCESNVPROC = procedure(n: TGLsizei; fences: PGLuint); stdcall;

PFNGLDELETEFENCESNVPROC = procedure(n: TGLsizei; fences: PGLuint); stdcall;

PFNGLSETFENCENVPROC = procedure(fence: TGLuint; condition: TGLenum); stdcall;

PFNGLTESTFENCENVPROC = function(fence: TGLuint): TGLboolean; stdcall;

PFNGLFINISHFENCENVPROC = procedure(fence: TGLuint); stdcall;

PFNGLISFENCENVPROC = function(fence: TGLuint): TGLboolean; stdcall;

PFNGLGETFENCEIVNVPROC = procedure(fence: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLAREPROGRAMSRESIDENTNVPROC = procedure(n: TGLSizei; programs: PGLuint; residences: PGLboolean); stdcall;

PFNGLBINDPROGRAMNVPROC = procedure(target: TGLenum; id: TGLuint); stdcall;

PFNGLDELETEPROGRAMSNVPROC = procedure(n: TGLSizei; programs: PGLuint); stdcall;

PFNGLEXECUTEPROGRAMNVPROC = procedure(target: TGLenum; id: TGLuint; params: PGLfloat); stdcall;

PFNGLGENPROGRAMSNVPROC = procedure(n: TGLSizei; programs: PGLuint); stdcall;

PFNGLGETPROGRAMPARAMETERDVNVPROC = procedure (target: TGLenum; index: TGLuint; pname: TGLenum; params: PGLdouble); stdcall;

PFNGLGETPROGRAMPARAMETERFVNVPROC = procedure (target: TGLenum; index: TGLuint; pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETPROGRAMIVNVPROC = procedure (id: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETPROGRAMSTRINGNVPROC = procedure (id: TGLuint; pname: TGLenum; programIdx: PGLubyte); stdcall;

PFNGLGETTRACKMATRIXIVNVPROC = procedure (target: TGLenum; address: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETVERTEXATTRIBDVNVPROC = procedure (index: TGLuint; pname: TGLenum; params: PGLdouble); stdcall;

PFNGLGETVERTEXATTRIBFVNVPROC = procedure (index: TGLuint; pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETVERTEXATTRIBIVNVPROC = procedure (index: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETVERTEXATTRIBPOINTERVNVPROC = procedure (index: TGLuint; pname: TGLenum; pointer: PGLPointer); stdcall;

PFNGLISPROGRAMNVPROC = function (id: TGLuint): TGLboolean; stdcall;

PFNGLLOADPROGRAMNVPROC = procedure (target: TGLenum; id: TGLuint; len: TGLSizei; programIdx: PGLubyte); stdcall;

PFNGLPROGRAMPARAMETER4DNVPROC = procedure (target: TGLenum; index: TGLuint; x, y, z, w: TGLdouble); stdcall;

PFNGLPROGRAMPARAMETER4DVNVPROC = procedure (target: TGLenum; index: TGLuint; v: PGLdouble ); stdcall;

PFNGLPROGRAMPARAMETER4FNVPROC = procedure (target: TGLenum; index: TGLuint; x, y, z, w: TGLfloat); stdcall;

PFNGLPROGRAMPARAMETER4FVNVPROC = procedure (target: TGLenum; index: TGLuint; v: PGLfloat); stdcall;

PFNGLPROGRAMPARAMETERS4DVNVPROC = procedure (target: TGLenum; index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

PFNGLPROGRAMPARAMETERS4FVNVPROC = procedure (target: TGLenum; index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

PFNGLREQUESTRESIDENTPROGRAMSNVPROC = procedure (n: TGLSizei; programs: PGLuint); stdcall;

PFNGLTRACKMATRIXNVPROC = procedure (target: TGLenum; address: TGLuint; matrix: TGLenum; transform: TGLenum); stdcall;

PFNGLVERTEXATTRIBPOINTERNVPROC = procedure (index: TGLuint; fsize: TGLint; vertextype: TGLenum; stride: TGLSizei; pointer: Pointer); stdcall;

PFNGLVERTEXATTRIB1DNVPROC = procedure (index: TGLuint; x: TGLdouble); stdcall;

PFNGLVERTEXATTRIB1DVNVPROC = procedure (index: TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB1FNVPROC = procedure (index: TGLuint; x: TGLfloat); stdcall;

PFNGLVERTEXATTRIB1FVNVPROC = procedure (index: TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB1SNVPROC = procedure (index: TGLuint; x: TGLshort); stdcall;

PFNGLVERTEXATTRIB1SVNVPROC = procedure (index: TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB2DNVPROC = procedure (index: TGLuint; x: TGLdouble; y: TGLdouble); stdcall;

PFNGLVERTEXATTRIB2DVNVPROC = procedure (index: TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB2FNVPROC = procedure (index: TGLuint; x: TGLfloat; y: TGLfloat); stdcall;

PFNGLVERTEXATTRIB2FVNVPROC = procedure (index: TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB2SNVPROC = procedure (index: TGLuint; x: TGLshort; y: TGLshort); stdcall;

PFNGLVERTEXATTRIB2SVNVPROC = procedure (index: TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB3DNVPROC = procedure (index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

PFNGLVERTEXATTRIB3DVNVPROC = procedure (index: TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB3FNVPROC = procedure (index: TGLuint; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;

PFNGLVERTEXATTRIB3FVNVPROC = procedure (index: TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB3SNVPROC = procedure (index: TGLuint; x: TGLshort; y: TGLshort; z: TGLshort); stdcall;

PFNGLVERTEXATTRIB3SVNVPROC = procedure (index: TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4DNVPROC = procedure (index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

PFNGLVERTEXATTRIB4DVNVPROC = procedure (index: TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB4FNVPROC = procedure(index: TGLuint; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;

PFNGLVERTEXATTRIB4FVNVPROC = procedure(index: TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB4SNVPROC = procedure (index: TGLuint; x: TGLshort; y: TGLshort; z: TGLdouble; w: TGLshort); stdcall;

PFNGLVERTEXATTRIB4SVNVPROC = procedure (index: TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4UBVNVPROC = procedure (index: TGLuint; v: PGLubyte); stdcall;

PFNGLVERTEXATTRIBS1DVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIBS1FVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIBS1SVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

PFNGLVERTEXATTRIBS2DVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIBS2FVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIBS2SVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

PFNGLVERTEXATTRIBS3DVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIBS3FVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIBS3SVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

PFNGLVERTEXATTRIBS4DVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIBS4FVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIBS4SVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

PFNGLVERTEXATTRIBS4UBVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLubyte); stdcall;

PFNGLGENOCCLUSIONQUERIESNVPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

PFNGLDELETEOCCLUSIONQUERIESNVPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

PFNGLISOCCLUSIONQUERYNVPROC = function(id: TGLuint): TGLboolean; stdcall;

PFNGLBEGINOCCLUSIONQUERYNVPROC = procedure(id: TGLuint); stdcall;

PFNGLENDOCCLUSIONQUERYNVPROC = procedure; stdcall;

PFNGLGETOCCLUSIONQUERYIVNVPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETOCCLUSIONQUERYUIVNVPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLuint); stdcall;

PFNGLPOINTPARAMETERINVPROC = procedure(pname: TGLenum; param: TGLint); stdcall;

PFNGLPOINTPARAMETERIVNVPROC = procedure(pname: TGLenum; params: PGLint); stdcall;

PFNGLACTIVESTENCILFACEEXTPROC = procedure(face: TGLenum); stdcall;

PFNGLDRAWBUFFERSATIPROC = procedure(n: GLsizei; const bufs: PGLenum); stdcall;

PFNGLPRIMITIVERESTARTNVPROC = procedure(); stdcall;

PFNGLPRIMITIVERESTARTINDEXNVPROC = procedure(index: TGLuint); stdcall;

PFNGLDEPTHBOUNDSEXTPROC = procedure(zmin: TGLclampd; zmax: TGLclampd); stdcall;

PFNGLBLENDEQUATIONSEPARATEEXTPROC = procedure(modeRGB: TGLenum; modeAlpha: TGLenum); stdcall;

PFNGLISRENDERBUFFEREXTPROC = function(renderbuffer: TGLuint): TGLboolean; stdcall;

PFNGLBINDRENDERBUFFEREXTPROC = procedure(target: TGLenum; renderbuffer: TGLuint); stdcall;

PFNGLDELETERENDERBUFFERSEXTPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

PFNGLGENRENDERBUFFERSEXTPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

PFNGLRENDERBUFFERSTORAGEEXTPROC = procedure(target: TGLenum; internalformat: TGLenum; width: TGLsizei; height: TGLsizei); stdcall;

PFNGLGETRENDERBUFFERPARAMETERIVEXTPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLISFRAMEBUFFEREXTPROC = function(framebuffer: TGLuint): TGLboolean; stdcall;

PFNGLBINDFRAMEBUFFEREXTPROC = procedure(target: TGLenum; framebuffer: TGLuint); stdcall;

PFNGLDELETEFRAMEBUFFERSEXTPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

PFNGLGENFRAMEBUFFERSEXTPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

PFNGLCHECKFRAMEBUFFERSTATUSEXTPROC = function(target: TGLenum): TGLenum; stdcall;

PFNGLFRAMEBUFFERTEXTURE1DEXTPROC = procedure(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTURE2DEXTPROC = procedure(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTURE3DEXTPROC = procedure(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint; zoffset: TGLint); stdcall;

PFNGLFRAMEBUFFERRENDERBUFFEREXTPROC = procedure(target: TGLenum; attachment: TGLenum; renderbuffertarget: TGLenum; renderbuffer: TGLuint); stdcall;

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC = procedure(target: TGLenum; attachment: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLGENERATEMIPMAPEXTPROC = procedure(target: TGLenum); stdcall;

PFNGLSTRINGMARKERGREMEDYPROC = procedure(len: GLsizei; str: PGLChar); stdcall;

PFNGLSTENCILCLEARTAGEXTPROC = procedure(stencilTagBits: TGLsizei; stencilClearTag: TGLuint); stdcall;

PFNGLBLITFRAMEBUFFEREXTPROC = procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: TGLenum); stdcall;

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC = procedure(target: TGLenum; samples: TGLsizei; internalformat: TGLenum; width: TGLsizei; height: TGLsizei); stdcall;

PFNGLGETQUERYOBJECTI64VEXTPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLint64EXT); stdcall;

PFNGLGETQUERYOBJECTUI64VEXTPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLuint64EXT); stdcall;

PFNGLPROGRAMENVPARAMETERS4FVEXTPROC = procedure(target:TGLenum; index:TGLuint; count:TGLsizei; const params:PGLfloat); stdcall;

PFNGLPROGRAMLOCALPARAMETERS4FVEXTPROC = procedure(target:TGLenum; index:TGLuint; count:TGLsizei; const params:PGLFloat); stdcall;

PFNGLPROGRAMVERTEXLIMITNVPROC = procedure (target: TGLenum; limit: TGLint); stdcall;

PFNGLPROGRAMPARAMETERIEXTPROC = procedure ( _program:TGLuint; pname:TGLenum; value: TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTUREEXTPROC = procedure ( target:TGLenum; attachment:TGLenum; texture:TGLuint; level:TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTURELAYEREXTPROC = procedure ( target:TGLenum; attachment:TGLenum; texture:TGLuint; level:TGLint; layer:TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTUREFACEEXTPROC = procedure ( target:TGLenum; attachment:TGLenum; texture:TGLuint; level:TGLint; face:TGLenum); stdcall;

PFNGLVERTEXATTRIBI1IEXTPROC = procedure(index: TGLuint; x: TGLint); stdcall;

PFNGLVERTEXATTRIBI2IEXTPROC = procedure(index: TGLuint; x: TGLint; y: TGLint); stdcall;

PFNGLVERTEXATTRIBI3IEXTPROC = procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint); stdcall;

PFNGLVERTEXATTRIBI4IEXTPROC = procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

PFNGLVERTEXATTRIBI1UIEXTPROC = procedure(index: TGLuint; x: TGLuint); stdcall;

PFNGLVERTEXATTRIBI2UIEXTPROC = procedure(index: TGLuint; x: TGLuint; y: TGLuint); stdcall;

PFNGLVERTEXATTRIBI3UIEXTPROC = procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint); stdcall;

PFNGLVERTEXATTRIBI4UIEXTPROC = procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint; w: TGLuint); stdcall;

PFNGLVERTEXATTRIBI1IVEXTPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI2IVEXTPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI3IVEXTPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI4IVEXTPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI1UIVEXTPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI2UIVEXTPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI3UIVEXTPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI4UIVEXTPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI4BVEXTPROC = procedure(index: TGLuint; v:PGLbyte); stdcall;

PFNGLVERTEXATTRIBI4SVEXTPROC = procedure(index: TGLuint; v:PGLshort); stdcall;

PFNGLVERTEXATTRIBI4UBVEXTPROC = procedure(index: TGLuint; v: PGLUbyte); stdcall;

PFNGLVERTEXATTRIBI4USVEXTPROC = procedure(index: TGLuint; v: PGLushort); stdcall;

PFNGLVERTEXATTRIBIPOINTEREXTPROC = procedure(index: TGLuint; size: TGLint; _type: TGLenum; stride: TGLsizei; _pointer: pointer); stdcall;

PFNGLGETVERTEXATTRIBIIVEXTPROC = procedure(index: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETVERTEXATTRIBIUIVEXTPROC = procedure(index: TGLuint; pname: TGLenum; params: PGLuint); stdcall;

PFNGLUNIFORM1UIEXTPROC = procedure(location: TGLInt; v0: TGLuint); stdcall;

PFNGLUNIFORM2UIEXTPROC = procedure(location: TGLInt; v0: TGLuint; v1: TGLuint); stdcall;

PFNGLUNIFORM3UIEXTPROC = procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint); stdcall;

PFNGLUNIFORM4UIEXTPROC = procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint; v3: TGLuint); stdcall;

PFNGLUNIFORM1UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLUNIFORM2UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLUNIFORM3UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLUNIFORM4UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLGETUNIFORMUIVEXTPROC = procedure(_program: TGLuint; location: TGLint; params: PGLuint); stdcall;

PFNGLBINDFRAGDATALOCATIONEXTPROC = procedure(_program: TGLuint; colorNumber: TGLuint; name: PGLChar); stdcall;

PFNGLGETFRAGDATALOCATIONEXTPROC = function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

PFNGLDRAWARRAYSINSTANCEDEXTPROC = procedure(mode: TGLenum; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

PFNGLDRAWELEMENTSINSTANCEDEXTPROC = procedure(mode: TGLenum; count: TGLSizei; _type: TGLenum; indices: PGLvoid; primcount: TGLsizei); stdcall;

PFNGLTEXBUFFEREXTPROC = procedure(target: TGLenum; internalformat: TGLenum; buffer: TGLuint); stdcall;

PFNGLCOLORMASKINDEXEDEXTPROC = procedure(buf: TGLuint; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

PFNGLGETBOOLEANINDEXEDVEXTPROC = procedure(value: TGLenum; index: TGLuint; data: PGLboolean); stdcall;

PFNGLGETINTEGERINDEXEDVEXTPROC = procedure(value: TGLenum; index: TGLuint; data: PGLint); stdcall;

PFNGLENABLEINDEXEDEXTPROC = procedure(target: TGLenum; index: TGLuint); stdcall;

PFNGLDISABLEINDEXEDEXTPROC = procedure(target: TGLenum; index: TGLuint); stdcall;

PFNGLISENABLEDINDEXEDEXTPROC = function(target: TGLenum; index: TGLuint): TGLboolean; stdcall;

PFNGLBINDBUFFERRANGENVPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint; offset: TGLintptr; size: TGLsizeiptr); stdcall;

PFNGLBINDBUFFEROFFSETNVPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint; offset: TGLintptr); stdcall;

PFNGLBINDBUFFERBASENVPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint); stdcall;

PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC = procedure(count: TGLsizei; attribs: PGLint; bufferMode: TGLenum); stdcall;

PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC = procedure(_program: TGLuint; count: TGLsizei; locations: PGLint; bufferMode: TGLenum); stdcall;

PFNGLBEGINTRANSFORMFEEDBACKNVPROC = procedure(primitiveMode: TGLenum); stdcall;

PFNGLENDTRANSFORMFEEDBACKNVPROC = procedure(); stdcall;

PFNGLGETVARYINGLOCATIONNVPROC = function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

PFNGLGETACTIVEVARYINGNVPROC = procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: TGLenum; name: PGLChar); stdcall;

PFNGLACTIVEVARYINGNVPROC = procedure(_program: TGLuint; name: PGLChar); stdcall;

PFNGLGETTRANSFORMFEEDBACKVARYINGNVPROC = procedure(_program: TGLuint; index: TGLuint; location: PGLint); stdcall;

PFNGLUNIFORMBUFFEREXTPROC = procedure(_program: TGLUint; location: TGLint; buffer: TGLuint); stdcall;

PFNGLGETUNIFORMBUFFERSIZEEXTPROC = function(_program: TGLuint; location: TGLint): TGLint; stdcall;

PFNGLGETUNIFORMOFFSETEXTPROC = function(_program: TGLuint; location: TGLint): PGLint; stdcall;

PFNGLCLEARCOLORIIEXTPROC = procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint); stdcall;

PFNGLCLEARCOLORIUIEXTPROC = procedure(r: TGLuint; g: TGLuint; b: TGLuint; a: TGLuint); stdcall;

PFNGLTEXPARAMETERIIVEXTPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLTEXPARAMETERIUIVEXTPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLuint); stdcall;

PFNGLGETTEXPARAMETERIIVEXTPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETTEXPARAMETERIUIVEXTPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLuint); stdcall;

PFNGLFRAMETERMINATORGREMEDYPROC = procedure(); stdcall;

PFNGLBEGINCONDITIONALRENDERNVPROC = procedure(id: TGLuint; mode: TGLenum); stdcall;

PFNGLENDCONDITIONALRENDERNVPROC = procedure(); stdcall;

PFNGLBINDBUFFERRANGEEXTPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint; offset:TGLintptr; size: TGLsizeiptr); stdcall;

PFNGLBINDBUFFEROFFSETEXTPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint; offset:TGLintptr); stdcall;

PFNGLBINDBUFFERBASEEXTPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint); stdcall;

PFNGLBEGINTRANSFORMFEEDBACKEXTPROC = procedure(primitiveMode: TGLenum); stdcall;

PFNGLENDTRANSFORMFEEDBACKEXTPROC = procedure(); stdcall;

PFNGLTRANSFORMFEEDBACKVARYINGSEXTPROC = procedure(_program: TGLuint; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: TGLenum); stdcall;

PFNGLGETTRANSFORMFEEDBACKVARYINGEXTPROC = procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PGLenum; name: PGLChar); stdcall;

PFNGLTESSELLATIONFACTORAMDPROC = procedure(factor: GLfloat); stdcall;

PFNGLTESSELLATIONMODEAMDPROC = procedure(mode: TGLenum); stdcall;

PFNGLCOPYIMAGESUBDATANVPROC = procedure( srcName: GLuint; srcTarget: GLenum; srcLevel: GLint; srcX: GLint; srcY: GLint; srcZ: GLint; dstName: GLuint; dstTarget: GLenum; dstLevel: GLint; dstX: GLint; dstY: GLint; dstZ: GLint; width: GLsizei; height: GLsizei; depth: GLsizei); stdcall;

PFNGLMAKEBUFFERRESIDENTNVPROC = procedure(target: TGLenum; access: TGLenum); stdcall;

PFNGLMAKEBUFFERNONRESIDENTNVPROC = procedure(target: TGLenum); stdcall;

PFNGLISBUFFERRESIDENTNVPROC = function(target: TGLenum): TGLboolean; stdcall;

PFNGLMAKENAMEDBUFFERRESIDENTNVPROC = procedure(buffer: TGLuint; access: TGLenum); stdcall;

PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC = procedure(buffer: TGLuint); stdcall;

PFNGLISNAMEDBUFFERRESIDENTNVPROC = function (buffer: TGLuint): TGLboolean; stdcall;

PFNGLGETBUFFERPARAMETERUI64VNVPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLuint64EXT ); stdcall;

PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC = procedure(buffer: TGLuint; pname: TGLenum; params: PGLuint64EXT); stdcall;

PFNGLGETINTEGERUI64VNVPROC = procedure(value: TGLenum; result: PGLuint64EXT); stdcall;

PFNGLUNIFORMUI64NVPROC = procedure(location: TGLint; value: TGLuint64EXT); stdcall;

PFNGLUNIFORMUI64VNVPROC = procedure(location: GLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

PFNGLGETUNIFORMUI64VNVPROC = procedure(_program: TGLuint; location: TGLint; params: PGLuint64EXT); stdcall;

PFNGLPROGRAMUNIFORMUI64NVPROC = procedure(_program: TGLuint; location: TGLint; value: TGLuint64EXT); stdcall;

PFNGLPROGRAMUNIFORMUI64VNVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

PFNGLBUFFERADDRESSRANGENVPROC = procedure(pname: TGLenum; index: TGLuint; address: TGLuint64EXT; length: TGLsizeiptr); stdcall;

PFNGLVERTEXFORMATNVPROC = procedure(size: TGLint; _type: TGLenum; stride: TGLsizei); stdcall;

PFNGLNORMALFORMATNVPROC = procedure(_type: TGLenum; stride: TGLsizei); stdcall;

PFNGLCOLORFORMATNVPROC = procedure(size: TGLint; _type: TGLenum; stride: TGLsizei); stdcall;

PFNGLINDEXFORMATNVPROC = procedure(_type: TGLenum; stride: TGLsizei); stdcall;

PFNGLTEXCOORDFORMATNVPROC = procedure(size: TGLint; _type: TGLenum; stride: TGLsizei); stdcall;

PFNGLEDGEFLAGFORMATNVPROC = procedure(stride: TGLsizei); stdcall;

PFNGLSECONDARYCOLORFORMATNVPROC = procedure(size: TGLint; _type: TGLenum; stride: TGLsizei); stdcall;

PFNGLFOGCOORDFORMATNVPROC = procedure(_type: TGLenum; stride: TGLsizei); stdcall;

PFNGLVERTEXATTRIBFORMATNVPROC = procedure(index: TGLuint; size: TGLint; _type: TGLenum; normalized: TGLboolean; stride: TGLsizei); stdcall;

PFNGLVERTEXATTRIBIFORMATNVPROC = procedure(index: TGLuint; size: TGLint; _type: TGLenum; stride: TGLsizei); stdcall;

PFNGLGETINTEGERUI64I_VNVPROC = procedure(value: TGLenum; index: TGLuint; result: PGLuint64EXT); stdcall;

PGNGLGETBUFFERPARAMETERUI64VNV = procedure(value: TGLenum; index: TGLuint; result: PGLuint64EXT); stdcall;

PFNGLGENPATHSNVPROC = function (range: GLsizei): GLuint; stdcall;

PFNGLDELETEPATHSNVPROC = procedure(path: GLuint; range: GLsizei); stdcall;

PFNGLISPATHNVPROC = function(path: GLuint): GLboolean; stdcall;

PFNGLPATHCOMMANDSNVPROC = procedure(path: GLuint; numCommands: GLsizei; commands: PGLubyte; numCoords: GLsizei; coordType: GLenum; coords: PGLvoid); stdcall;

PFNGLPATHCOORDSNVPROC = procedure(path: GLuint; numCoords: GLsizei; coordType: GLenum; coords: PGLvoid); stdcall;

PFNGLPATHSUBCOMMANDSNVPROC = procedure(path: GLuint; commandStart: GLsizei; commandsToDelete: GLsizei; numCommands: GLsizei; commands: PGLubyte; numCoords: GLsizei; coordType: GLenum; coords: PGLvoid); stdcall;

PFNGLPATHSUBCOORDSNVPROC = procedure(path: GLuint; coordStart: GLsizei; numCoords: GLsizei; coordType: GLenum; coords: PGLvoid); stdcall;

PFNGLPATHSTRINGNVPROC = procedure(path: GLuint; format: GLenum; length: GLsizei; pathString: PGLvoid); stdcall;

PFNGLPATHGLYPHSNVPROC = procedure(firstPathName: GLuint; fontTarget: GLenum; fontName: PGLvoid; fontStyle: GLbitfield; numGlyphs: GLsizei; _type: GLenum; charcodes: PGLvoid; handleMissingGlyphs: GLenum; pathParameterTemplate: GLuint; emScale: GLfloat); stdcall;

PFNGLPATHGLYPHRANGENVPROC = procedure(firstPathName: GLuint; fontTarget: GLenum; fontName: PGLChar; fontStyle: GLbitfield; firstGlyph: GLuint; numGlyphs: GLsizei; handleMissingGlyphs: GLenum; pathParameterTemplate: GLuint; emScale: GLfloat); stdcall;

PFNGLWEIGHTPATHSNVPROC = procedure (resultPath: GLuint; numPaths: GLsizei; paths: PGLuint; weights: PGLfloat); stdcall;

PFNGLCOPYPATHNVPROC = procedure (resultPath: GLuint; srcPath: GLuint); stdcall;

PFNGLINTERPOLATEPATHSNVPROC = procedure (resultPath: GLuint; pathA: GLuint; pathB: GLuint; weight: GLfloat); stdcall;

PFNGLTRANSFORMPATHNVPROC = procedure ( resultPath: GLuint; srcPath: GLuint; transformType: GLenum; transformValues: PGLfloat); stdcall;

PFNGLPATHPARAMETERIVNVPROC = procedure (path: GLuint; pname: GLenum; value: PGLint); stdcall;

PFNGLPATHPARAMETERINVPROC = procedure (path: GLuint; pname: GLenum; value: GLint); stdcall;

PFNGLPATHPARAMETERFVNVPROC = procedure (path: GLuint; pname: GLenum; value: PGLfloat); stdcall;

PFNGLPATHPARAMETERFNVPROC = procedure (path: GLuint; pname: GLenum; value: GLfloat); stdcall;

PFNGLPATHDASHARRAYNVPROC = procedure (path: GLuint; dashCount: GLsizei; dashArray: PGLfloat); stdcall;

PFNGLPATHSTENCILFUNCNVPROC = procedure (func: GLenum; ref: GLint; mask: GLuint); stdcall;

PFNGLPATHSTENCILDEPTHOFFSETNVPROC = procedure (factor: GLfloat; units: GLfloat); stdcall;

PFNGLSTENCILFILLPATHNVPROC = procedure (path: GLuint; fillMode: GLenum; mask: GLuint); stdcall;

PFNGLSTENCILSTROKEPATHNVPROC = procedure(path: GLuint; reference: GLint; mask: GLuint); stdcall;

PFNGLSTENCILFILLPATHINSTANCEDNVPROC = procedure (numPaths: GLsizei; pathNameType: GLenum; paths: PGLvoid; pathBase: GLuint; fillMode: GLenum; mask: GLuint; transformType: GLenum; transformValues: PGLfloat); stdcall;

PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC = procedure (numPaths: GLsizei; pathNameType: GLenum; paths: PGLvoid; pathBase: GLuint; reference: GLint; mask: GLuint; transformType: GLenum; transformValues: PGLfloat); stdcall;

PFNGLPATHCOVERDEPTHFUNCNVPROC = procedure (func: GLenum); stdcall;

PFNGLPATHCOLORGENNVPROC = procedure (color: GLenum; genMode: GLenum; colorFormat: GLenum; coeffs: PGLfloat); stdcall;

PFNGLPATHTEXGENNVPROC = procedure (texCoordSet: GLenum; genMode: GLenum; components: GLint; coeffs: PGLfloat); stdcall;

PFNGLPATHFOGGENNVPROC = procedure (genMode: GLenum); stdcall;

PFNGLCOVERFILLPATHNVPROC = procedure (path: GLuint; coverMode: GLenum); stdcall;

PFNGLCOVERSTROKEPATHNVPROC = procedure (path: GLuint; coverMode: GLenum); stdcall;

PFNGLCOVERFILLPATHINSTANCEDNVPROC = procedure (numPaths: GLsizei; pathNameType: GLenum; paths: PGLvoid; pathBase: GLuint; coverMode: GLenum; transformType: GLenum; transformValues: PGLfloat); stdcall;

PFNGLCOVERSTROKEPATHINSTANCEDNVPROC = procedure (numPaths: GLsizei; pathNameType: GLenum; paths: PGLvoid; pathBase: GLuint; coverMode: GLenum; transformType: GLenum; transformValues: PGLfloat); stdcall;

PFNGLGETPATHPARAMETERIVNVPROC = procedure (path: GLuint; pname: GLenum; value: PGLint); stdcall;

PFNGLGETPATHPARAMETERFVNVPROC = procedure (path: GLuint; pname: GLenum; value: PGLfloat); stdcall;

PFNGLGETPATHCOMMANDSNVPROC = procedure (path: GLuint; commands: PGLubyte); stdcall;

PFNGLGETPATHCOORDSNVPROC = procedure (path: GLuint; coords: PGLfloat); stdcall;

PFNGLGETPATHDASHARRAYNVPROC = procedure (path: GLuint; dashArray: PGLfloat); stdcall;

PFNGLGETPATHMETRICSNVPROC = procedure (metricQueryMask: GLbitfield; numPaths: GLsizei; pathNameType: GLenum; paths: PGLvoid; pathBase: GLuint; stride: GLsizei; metrics: PGLfloat); stdcall;

PFNGLGETPATHMETRICRANGENVPROC = procedure (metricQueryMask: GLbitfield; firstPathName: GLuint; numPaths: GLsizei; stride: GLsizei; metrics: PGLfloat); stdcall;

PFNGLGETPATHSPACINGNVPROC = procedure (pathListMode: GLenum; numPaths: GLsizei; pathNameType: GLenum; paths: PGLvoid; pathBase: GLuint; advanceScale: GLfloat; kerningScale: GLfloat; transformType: GLenum; returnedSpacing: PGLfloat); stdcall;

PFNGLGETPATHCOLORGENIVNVPROC = procedure (color: GLenum; pname: GLenum; value: PGLint); stdcall;

PFNGLGETPATHCOLORGENFVNVPROC = procedure (color: GLenum; pname: GLenum; value: PGLfloat); stdcall;

PFNGLGETPATHTEXGENIVNVPROC = procedure (texCoordSet: GLenum; pname: GLenum; value: PGLint); stdcall;

PFNGLGETPATHTEXGENFVNVPROC = procedure (texCoordSet: GLenum; pname: GLenum; value: PGLfloat); stdcall;

PFNGLISPOINTINFILLPATHNVPROC = function (path: GLuint; mask: GLuint; x: GLfloat; y: GLfloat): GLboolean; stdcall;

PFNGLISPOINTINSTROKEPATHNVPROC = function (path: GLuint; x: GLfloat; y: GLfloat): GLboolean; stdcall;

PFNGLGETPATHLENGTHNVPROC = function (path: GLuint; startSegment: GLsizei; numSegments: GLsizei): GLfloat; stdcall;

PFNGLPOINTALONGPATHNVPROC = function (path: GLuint; startSegment: GLsizei; numSegments: GLsizei; distance: GLfloat; x: PGLfloat; y: PGLfloat; tangentX: PGLfloat; tangentY: PGLfloat): GLboolean; stdcall;

Constants

opengl32 = 'OpenGL32.dll';

glu32 = 'GLU32.dll';

libEGL = 'libEGL.dll';

libGLES2 = 'libGLESv2.dll';

GL_DEPTH_BUFFER_BIT = $00000100;

GL_STENCIL_BUFFER_BIT = $00000400;

GL_COLOR_BUFFER_BIT = $00004000;

GL_FALSE = 0;

GL_TRUE = 1;

GL_POINTS = $0000;

GL_LINES = $0001;

GL_LINE_LOOP = $0002;

GL_LINE_STRIP = $0003;

GL_TRIANGLES = $0004;

GL_TRIANGLE_STRIP = $0005;

GL_TRIANGLE_FAN = $0006;

GL_NEVER = $0200;

GL_LESS = $0201;

GL_EQUAL = $0202;

GL_LEQUAL = $0203;

GL_GREATER = $0204;

GL_NOTEQUAL = $0205;

GL_GEQUAL = $0206;

GL_ALWAYS = $0207;

GL_ZERO = 0;

GL_ONE = 1;

GL_SRC_COLOR = $0300;

GL_ONE_MINUS_SRC_COLOR = $0301;

GL_SRC_ALPHA = $0302;

GL_ONE_MINUS_SRC_ALPHA = $0303;

GL_DST_ALPHA = $0304;

GL_ONE_MINUS_DST_ALPHA = $0305;

GL_DST_COLOR = $0306;

GL_ONE_MINUS_DST_COLOR = $0307;

GL_SRC_ALPHA_SATURATE = $0308;

GL_NONE = 0;

GL_FRONT_LEFT = $0400;

GL_FRONT_RIGHT = $0401;

GL_BACK_LEFT = $0402;

GL_BACK_RIGHT = $0403;

GL_FRONT = $0404;

GL_BACK = $0405;

GL_LEFT = $0406;

GL_RIGHT = $0407;

GL_FRONT_AND_BACK = $0408;

GL_NO_ERROR = 0;

GL_INVALID_ENUM = $0500;

GL_INVALID_VALUE = $0501;

GL_INVALID_OPERATION = $0502;

GL_OUT_OF_MEMORY = $0505;

GL_CW = $0900;

GL_CCW = $0901;

GL_POINT_SIZE = $0B11;

GL_POINT_SIZE_RANGE = $0B12;

GL_POINT_SIZE_GRANULARITY = $0B13;

GL_LINE_SMOOTH = $0B20;

GL_LINE_WIDTH = $0B21;

GL_LINE_WIDTH_RANGE = $0B22;

GL_LINE_WIDTH_GRANULARITY = $0B23;

GL_POLYGON_SMOOTH = $0B41;

GL_CULL_FACE = $0B44;

GL_CULL_FACE_MODE = $0B45;

GL_FRONT_FACE = $0B46;

GL_DEPTH_RANGE = $0B70;

GL_DEPTH_TEST = $0B71;

GL_DEPTH_WRITEMASK = $0B72;

GL_DEPTH_CLEAR_VALUE = $0B73;

GL_DEPTH_FUNC = $0B74;

GL_STENCIL_TEST = $0B90;

GL_STENCIL_CLEAR_VALUE = $0B91;

GL_STENCIL_FUNC = $0B92;

GL_STENCIL_VALUE_MASK = $0B93;

GL_STENCIL_FAIL = $0B94;

GL_STENCIL_PASS_DEPTH_FAIL = $0B95;

GL_STENCIL_PASS_DEPTH_PASS = $0B96;

GL_STENCIL_REF = $0B97;

GL_STENCIL_WRITEMASK = $0B98;

GL_MATRIX_MODE = $0BA0;

GL_VIEWPORT = $0BA2;

GL_DITHER = $0BD0;

GL_BLEND_DST = $0BE0;

GL_BLEND_SRC = $0BE1;

GL_BLEND = $0BE2;

GL_LOGIC_OP_MODE = $0BF0;

GL_COLOR_LOGIC_OP = $0BF2;

GL_DRAW_BUFFER = $0C01;

GL_READ_BUFFER = $0C02;

GL_SCISSOR_BOX = $0C10;

GL_SCISSOR_TEST = $0C11;

GL_COLOR_CLEAR_VALUE = $0C22;

GL_COLOR_WRITEMASK = $0C23;

GL_DOUBLEBUFFER = $0C32;

GL_STEREO = $0C33;

GL_LINE_SMOOTH_HINT = $0C52;

GL_POLYGON_SMOOTH_HINT = $0C53;

GL_UNPACK_SWAP_BYTES = $0CF0;

GL_UNPACK_LSB_FIRST = $0CF1;

GL_UNPACK_ROW_LENGTH = $0CF2;

GL_UNPACK_SKIP_ROWS = $0CF3;

GL_UNPACK_SKIP_PIXELS = $0CF4;

GL_UNPACK_ALIGNMENT = $0CF5;

GL_PACK_SWAP_BYTES = $0D00;

GL_PACK_LSB_FIRST = $0D01;

GL_PACK_ROW_LENGTH = $0D02;

GL_PACK_SKIP_ROWS = $0D03;

GL_PACK_SKIP_PIXELS = $0D04;

GL_PACK_ALIGNMENT = $0D05;

GL_MAX_TEXTURE_SIZE = $0D33;

GL_MAX_VIEWPORT_DIMS = $0D3A;

GL_SUBPIXEL_BITS = $0D50;

GL_TEXTURE_1D = $0DE0;

GL_TEXTURE_2D = $0DE1;

GL_POLYGON_OFFSET_UNITS = $2A00;

GL_POLYGON_OFFSET_POINT = $2A01;

GL_POLYGON_OFFSET_LINE = $2A02;

GL_POLYGON_OFFSET_FILL = $8037;

GL_POLYGON_OFFSET_FACTOR = $8038;

GL_TEXTURE_BINDING_1D = $8068;

GL_TEXTURE_BINDING_2D = $8069;

GL_TEXTURE_WIDTH = $1000;

GL_TEXTURE_HEIGHT = $1001;

GL_TEXTURE_INTERNAL_FORMAT = $1003;

GL_TEXTURE_BORDER_COLOR = $1004;

GL_TEXTURE_BORDER = $1005;

GL_TEXTURE_RED_SIZE = $805C;

GL_TEXTURE_GREEN_SIZE = $805D;

GL_TEXTURE_BLUE_SIZE = $805E;

GL_TEXTURE_ALPHA_SIZE = $805F;

GL_DONT_CARE = $1100;

GL_FASTEST = $1101;

GL_NICEST = $1102;

GL_BYTE = $1400;

GL_UNSIGNED_BYTE = $1401;

GL_SHORT = $1402;

GL_UNSIGNED_SHORT = $1403;

GL_INT = $1404;

GL_UNSIGNED_INT = $1405;

GL_FLOAT = $1406;

GL_DOUBLE = $140A;

GL_CLEAR = $1500;

GL_AND = $1501;

GL_AND_REVERSE = $1502;

GL_COPY = $1503;

GL_AND_INVERTED = $1504;

GL_NOOP = $1505;

GL_XOR = $1506;

GL_OR = $1507;

GL_NOR = $1508;

GL_EQUIV = $1509;

GL_INVERT = $150A;

GL_OR_REVERSE = $150B;

GL_COPY_INVERTED = $150C;

GL_OR_INVERTED = $150D;

GL_NAND = $150E;

GL_SET = $150F;

GL_TEXTURE = $1702;

GL_COLOR = $1800;

GL_DEPTH = $1801;

GL_STENCIL = $1802;

GL_STENCIL_INDEX = $1901;

GL_DEPTH_COMPONENT = $1902;

GL_RED = $1903;

GL_GREEN = $1904;

GL_BLUE = $1905;

GL_ALPHA = $1906;

GL_RGB = $1907;

GL_RGBA = $1908;

GL_POINT = $1B00;

GL_LINE = $1B01;

GL_FILL = $1B02;

GL_KEEP = $1E00;

GL_REPLACE = $1E01;

GL_INCR = $1E02;

GL_DECR = $1E03;

GL_VENDOR = $1F00;

GL_RENDERER = $1F01;

GL_VERSION = $1F02;

GL_EXTENSIONS = $1F03;

GL_NEAREST = $2600;

GL_LINEAR = $2601;

GL_NEAREST_MIPMAP_NEAREST = $2700;

GL_LINEAR_MIPMAP_NEAREST = $2701;

GL_NEAREST_MIPMAP_LINEAR = $2702;

GL_LINEAR_MIPMAP_LINEAR = $2703;

GL_TEXTURE_MAG_FILTER = $2800;

GL_TEXTURE_MIN_FILTER = $2801;

GL_TEXTURE_WRAP_S = $2802;

GL_TEXTURE_WRAP_T = $2803;

GL_PROXY_TEXTURE_1D = $8063;

GL_PROXY_TEXTURE_2D = $8064;

GL_REPEAT = $2901;

GL_R3_G3_B2 = $2A10;

GL_RGB4 = $804F;

GL_RGB5 = $8050;

GL_RGB8 = $8051;

GL_RGB10 = $8052;

GL_RGB12 = $8053;

GL_RGB16 = $8054;

GL_RGBA2 = $8055;

GL_RGBA4 = $8056;

GL_RGB5_A1 = $8057;

GL_RGBA8 = $8058;

GL_RGB10_A2 = $8059;

GL_RGBA12 = $805A;

GL_RGBA16 = $805B;

GL_CURRENT_BIT = $00000001 ;

GL_POINT_BIT = $00000002 ;

GL_LINE_BIT = $00000004 ;

GL_POLYGON_BIT = $00000008 ;

GL_POLYGON_STIPPLE_BIT = $00000010 ;

GL_PIXEL_MODE_BIT = $00000020 ;

GL_LIGHTING_BIT = $00000040 ;

GL_FOG_BIT = $00000080 ;

GL_ACCUM_BUFFER_BIT = $00000200 ;

GL_VIEWPORT_BIT = $00000800 ;

GL_TRANSFORM_BIT = $00001000 ;

GL_ENABLE_BIT = $00002000 ;

GL_HINT_BIT = $00008000 ;

GL_EVAL_BIT = $00010000 ;

GL_LIST_BIT = $00020000 ;

GL_TEXTURE_BIT = $00040000 ;

GL_SCISSOR_BIT = $00080000 ;

GL_ALL_ATTRIB_BITS = $FFFFFFFF ;

GL_CLIENT_PIXEL_STORE_BIT = $00000001 ;

GL_CLIENT_VERTEX_ARRAY_BIT = $00000002 ;

GL_CLIENT_ALL_ATTRIB_BITS = $FFFFFFFF ;

GL_QUADS = $0007 ;

GL_QUAD_STRIP = $0008 ;

GL_POLYGON = $0009 ;

GL_ACCUM = $0100 ;

GL_LOAD = $0101 ;

GL_RETURN = $0102 ;

GL_MULT = $0103 ;

GL_ADD = $0104 ;

GL_AUX0 = $0409 ;

GL_AUX1 = $040A ;

GL_AUX2 = $040B ;

GL_AUX3 = $040C ;

GL_STACK_OVERFLOW = $0503 ;

GL_STACK_UNDERFLOW = $0504 ;

GL_2D = $0600 ;

GL_3D = $0601 ;

GL_3D_COLOR = $0602 ;

GL_3D_COLOR_TEXTURE = $0603 ;

GL_4D_COLOR_TEXTURE = $0604 ;

GL_PASS_THROUGH_TOKEN = $0700 ;

GL_POINT_TOKEN = $0701 ;

GL_LINE_TOKEN = $0702 ;

GL_POLYGON_TOKEN = $0703 ;

GL_BITMAP_TOKEN = $0704 ;

GL_DRAW_PIXEL_TOKEN = $0705 ;

GL_COPY_PIXEL_TOKEN = $0706 ;

GL_LINE_RESET_TOKEN = $0707 ;

GL_EXP = $0800 ;

GL_EXP2 = $0801 ;

GL_COEFF = $0A00 ;

GL_ORDER = $0A01 ;

GL_DOMAIN = $0A02 ;

GL_CURRENT_COLOR = $0B00 ;

GL_CURRENT_INDEX = $0B01 ;

GL_CURRENT_NORMAL = $0B02 ;

GL_CURRENT_TEXTURE_COORDS = $0B03 ;

GL_CURRENT_RASTER_COLOR = $0B04 ;

GL_CURRENT_RASTER_INDEX = $0B05 ;

GL_CURRENT_RASTER_TEXTURE_COORDS = $0B06 ;

GL_CURRENT_RASTER_POSITION = $0B07 ;

GL_CURRENT_RASTER_POSITION_VALID = $0B08 ;

GL_CURRENT_RASTER_DISTANCE = $0B09 ;

GL_POINT_SMOOTH = $0B10 ;

GL_LINE_STIPPLE = $0B24 ;

GL_LINE_STIPPLE_PATTERN = $0B25 ;

GL_LINE_STIPPLE_REPEAT = $0B26 ;

GL_LIST_MODE = $0B30 ;

GL_MAX_LIST_NESTING = $0B31 ;

GL_LIST_BASE = $0B32 ;

GL_LIST_INDEX = $0B33 ;

GL_POLYGON_MODE = $0B40 ;

GL_POLYGON_STIPPLE = $0B42 ;

GL_EDGE_FLAG = $0B43 ;

GL_LIGHTING = $0B50 ;

GL_LIGHT_MODEL_LOCAL_VIEWER = $0B51 ;

GL_LIGHT_MODEL_TWO_SIDE = $0B52 ;

GL_LIGHT_MODEL_AMBIENT = $0B53 ;

GL_SHADE_MODEL = $0B54 ;

GL_COLOR_MATERIAL_FACE = $0B55 ;

GL_COLOR_MATERIAL_PARAMETER = $0B56 ;

GL_COLOR_MATERIAL = $0B57 ;

GL_FOG = $0B60 ;

GL_FOG_INDEX = $0B61 ;

GL_FOG_DENSITY = $0B62 ;

GL_FOG_START = $0B63 ;

GL_FOG_END = $0B64 ;

GL_FOG_MODE = $0B65 ;

GL_FOG_COLOR = $0B66 ;

GL_ACCUM_CLEAR_VALUE = $0B80 ;

GL_NORMALIZE = $0BA1 ;

GL_MODELVIEW_STACK_DEPTH = $0BA3 ;

GL_PROJECTION_STACK_DEPTH = $0BA4 ;

GL_TEXTURE_STACK_DEPTH = $0BA5 ;

GL_MODELVIEW_MATRIX = $0BA6 ;

GL_PROJECTION_MATRIX = $0BA7 ;

GL_TEXTURE_MATRIX = $0BA8 ;

GL_ATTRIB_STACK_DEPTH = $0BB0 ;

GL_CLIENT_ATTRIB_STACK_DEPTH = $0BB1 ;

GL_ALPHA_TEST = $0BC0 ;

GL_ALPHA_TEST_FUNC = $0BC1 ;

GL_ALPHA_TEST_REF = $0BC2 ;

GL_INDEX_LOGIC_OP = $0BF1 ;

GL_LOGIC_OP = $0BF1 ;

GL_AUX_BUFFERS = $0C00 ;

GL_INDEX_CLEAR_VALUE = $0C20 ;

GL_INDEX_WRITEMASK = $0C21 ;

GL_INDEX_MODE = $0C30 ;

GL_RGBA_MODE = $0C31 ;

GL_RENDER_MODE = $0C40 ;

GL_PERSPECTIVE_CORRECTION_HINT = $0C50 ;

GL_POINT_SMOOTH_HINT = $0C51 ;

GL_FOG_HINT = $0C54 ;

GL_TEXTURE_GEN_S = $0C60 ;

GL_TEXTURE_GEN_T = $0C61 ;

GL_TEXTURE_GEN_R = $0C62 ;

GL_TEXTURE_GEN_Q = $0C63 ;

GL_PIXEL_MAP_I_TO_I = $0C70 ;

GL_PIXEL_MAP_S_TO_S = $0C71 ;

GL_PIXEL_MAP_I_TO_R = $0C72 ;

GL_PIXEL_MAP_I_TO_G = $0C73 ;

GL_PIXEL_MAP_I_TO_B = $0C74 ;

GL_PIXEL_MAP_I_TO_A = $0C75 ;

GL_PIXEL_MAP_R_TO_R = $0C76 ;

GL_PIXEL_MAP_G_TO_G = $0C77 ;

GL_PIXEL_MAP_B_TO_B = $0C78 ;

GL_PIXEL_MAP_A_TO_A = $0C79 ;

GL_PIXEL_MAP_I_TO_I_SIZE = $0CB0 ;

GL_PIXEL_MAP_S_TO_S_SIZE = $0CB1 ;

GL_PIXEL_MAP_I_TO_R_SIZE = $0CB2 ;

GL_PIXEL_MAP_I_TO_G_SIZE = $0CB3 ;

GL_PIXEL_MAP_I_TO_B_SIZE = $0CB4 ;

GL_PIXEL_MAP_I_TO_A_SIZE = $0CB5 ;

GL_PIXEL_MAP_R_TO_R_SIZE = $0CB6 ;

GL_PIXEL_MAP_G_TO_G_SIZE = $0CB7 ;

GL_PIXEL_MAP_B_TO_B_SIZE = $0CB8 ;

GL_PIXEL_MAP_A_TO_A_SIZE = $0CB9 ;

GL_MAP_COLOR = $0D10 ;

GL_MAP_STENCIL = $0D11 ;

GL_INDEX_SHIFT = $0D12 ;

GL_INDEX_OFFSET = $0D13 ;

GL_RED_SCALE = $0D14 ;

GL_RED_BIAS = $0D15 ;

GL_ZOOM_X = $0D16 ;

GL_ZOOM_Y = $0D17 ;

GL_GREEN_SCALE = $0D18 ;

GL_GREEN_BIAS = $0D19 ;

GL_BLUE_SCALE = $0D1A ;

GL_BLUE_BIAS = $0D1B ;

GL_ALPHA_SCALE = $0D1C ;

GL_ALPHA_BIAS = $0D1D ;

GL_DEPTH_SCALE = $0D1E ;

GL_DEPTH_BIAS = $0D1F ;

GL_MAX_EVAL_ORDER = $0D30 ;

GL_MAX_LIGHTS = $0D31 ;

GL_MAX_CLIP_PLANES = $0D32 ;

GL_MAX_PIXEL_MAP_TABLE = $0D34 ;

GL_MAX_ATTRIB_STACK_DEPTH = $0D35 ;

GL_MAX_MODELVIEW_STACK_DEPTH = $0D36 ;

GL_MAX_NAME_STACK_DEPTH = $0D37 ;

GL_MAX_PROJECTION_STACK_DEPTH = $0D38 ;

GL_MAX_TEXTURE_STACK_DEPTH = $0D39 ;

GL_MAX_CLIENT_ATTRIB_STACK_DEPTH = $0D3B ;

GL_INDEX_BITS = $0D51 ;

GL_RED_BITS = $0D52 ;

GL_GREEN_BITS = $0D53 ;

GL_BLUE_BITS = $0D54 ;

GL_ALPHA_BITS = $0D55 ;

GL_DEPTH_BITS = $0D56 ;

GL_STENCIL_BITS = $0D57 ;

GL_ACCUM_RED_BITS = $0D58 ;

GL_ACCUM_GREEN_BITS = $0D59 ;

GL_ACCUM_BLUE_BITS = $0D5A ;

GL_ACCUM_ALPHA_BITS = $0D5B ;

GL_NAME_STACK_DEPTH = $0D70 ;

GL_AUTO_NORMAL = $0D80 ;

GL_MAP1_COLOR_4 = $0D90 ;

GL_MAP1_INDEX = $0D91 ;

GL_MAP1_NORMAL = $0D92 ;

GL_MAP1_TEXTURE_COORD_1 = $0D93 ;

GL_MAP1_TEXTURE_COORD_2 = $0D94 ;

GL_MAP1_TEXTURE_COORD_3 = $0D95 ;

GL_MAP1_TEXTURE_COORD_4 = $0D96 ;

GL_MAP1_VERTEX_3 = $0D97 ;

GL_MAP1_VERTEX_4 = $0D98 ;

GL_MAP2_COLOR_4 = $0DB0 ;

GL_MAP2_INDEX = $0DB1 ;

GL_MAP2_NORMAL = $0DB2 ;

GL_MAP2_TEXTURE_COORD_1 = $0DB3 ;

GL_MAP2_TEXTURE_COORD_2 = $0DB4 ;

GL_MAP2_TEXTURE_COORD_3 = $0DB5 ;

GL_MAP2_TEXTURE_COORD_4 = $0DB6 ;

GL_MAP2_VERTEX_3 = $0DB7 ;

GL_MAP2_VERTEX_4 = $0DB8 ;

GL_MAP1_GRID_DOMAIN = $0DD0 ;

GL_MAP1_GRID_SEGMENTS = $0DD1 ;

GL_MAP2_GRID_DOMAIN = $0DD2 ;

GL_MAP2_GRID_SEGMENTS = $0DD3 ;

GL_FEEDBACK_BUFFER_POINTER = $0DF0 ;

GL_FEEDBACK_BUFFER_SIZE = $0DF1 ;

GL_FEEDBACK_BUFFER_TYPE = $0DF2 ;

GL_SELECTION_BUFFER_POINTER = $0DF3 ;

GL_SELECTION_BUFFER_SIZE = $0DF4 ;

GL_TEXTURE_COMPONENTS = $1003 ;

GL_TEXTURE_LUMINANCE_SIZE = $8060 ;

GL_TEXTURE_INTENSITY_SIZE = $8061 ;

GL_TEXTURE_PRIORITY = $8066 ;

GL_TEXTURE_RESIDENT = $8067 ;

GL_AMBIENT = $1200 ;

GL_DIFFUSE = $1201 ;

GL_SPECULAR = $1202 ;

GL_POSITION = $1203 ;

GL_SPOT_DIRECTION = $1204 ;

GL_SPOT_EXPONENT = $1205 ;

GL_SPOT_CUTOFF = $1206 ;

GL_CONSTANT_ATTENUATION = $1207 ;

GL_LINEAR_ATTENUATION = $1208 ;

GL_QUADRATIC_ATTENUATION = $1209 ;

GL_COMPILE = $1300 ;

GL_COMPILE_AND_EXECUTE = $1301 ;

GL_2_BYTES = $1407 ;

GL_3_BYTES = $1408 ;

GL_4_BYTES = $1409 ;

GL_DOUBLE_EXT = $140A ;

GL_EMISSION = $1600 ;

GL_SHININESS = $1601 ;

GL_AMBIENT_AND_DIFFUSE = $1602 ;

GL_COLOR_INDEXES = $1603 ;

GL_MODELVIEW = $1700 ;

GL_PROJECTION = $1701 ;

GL_COLOR_INDEX = $1900 ;

GL_LUMINANCE = $1909 ;

GL_LUMINANCE_ALPHA = $190A ;

GL_BITMAP = $1A00 ;

GL_RENDER = $1C00 ;

GL_FEEDBACK = $1C01 ;

GL_SELECT = $1C02 ;

GL_FLAT = $1D00 ;

GL_SMOOTH = $1D01 ;

GL_S = $2000 ;

GL_T = $2001 ;

GL_R = $2002 ;

GL_Q = $2003 ;

GL_MODULATE = $2100 ;

GL_DECAL = $2101 ;

GL_TEXTURE_ENV_MODE = $2200 ;

GL_TEXTURE_ENV_COLOR = $2201 ;

GL_TEXTURE_ENV = $2300 ;

GL_EYE_LINEAR = $2400 ;

GL_OBJECT_LINEAR = $2401 ;

GL_SPHERE_MAP = $2402 ;

GL_TEXTURE_GEN_MODE = $2500 ;

GL_OBJECT_PLANE = $2501 ;

GL_EYE_PLANE = $2502 ;

GL_CLAMP = $2900 ;

GL_ALPHA4 = $803B ;

GL_ALPHA8 = $803C ;

GL_ALPHA12 = $803D ;

GL_ALPHA16 = $803E ;

GL_LUMINANCE4 = $803F ;

GL_LUMINANCE8 = $8040 ;

GL_LUMINANCE12 = $8041 ;

GL_LUMINANCE16 = $8042 ;

GL_LUMINANCE4_ALPHA4 = $8043 ;

GL_LUMINANCE6_ALPHA2 = $8044 ;

GL_LUMINANCE8_ALPHA8 = $8045 ;

GL_LUMINANCE12_ALPHA4 = $8046 ;

GL_LUMINANCE12_ALPHA12 = $8047 ;

GL_LUMINANCE16_ALPHA16 = $8048 ;

GL_INTENSITY = $8049 ;

GL_INTENSITY4 = $804A ;

GL_INTENSITY8 = $804B ;

GL_INTENSITY12 = $804C ;

GL_INTENSITY16 = $804D ;

GL_VERTEX_ARRAY = $8074 ;

GL_NORMAL_ARRAY = $8075 ;

GL_COLOR_ARRAY = $8076 ;

GL_INDEX_ARRAY = $8077 ;

GL_TEXTURE_COORD_ARRAY = $8078 ;

GL_EDGE_FLAG_ARRAY = $8079 ;

GL_VERTEX_ARRAY_SIZE = $807A ;

GL_VERTEX_ARRAY_TYPE = $807B ;

GL_VERTEX_ARRAY_STRIDE = $807C ;

GL_NORMAL_ARRAY_TYPE = $807E ;

GL_NORMAL_ARRAY_STRIDE = $807F ;

GL_COLOR_ARRAY_SIZE = $8081 ;

GL_COLOR_ARRAY_TYPE = $8082 ;

GL_COLOR_ARRAY_STRIDE = $8083 ;

GL_INDEX_ARRAY_TYPE = $8085 ;

GL_INDEX_ARRAY_STRIDE = $8086 ;

GL_TEXTURE_COORD_ARRAY_SIZE = $8088 ;

GL_TEXTURE_COORD_ARRAY_TYPE = $8089 ;

GL_TEXTURE_COORD_ARRAY_STRIDE = $808A ;

GL_EDGE_FLAG_ARRAY_STRIDE = $808C ;

GL_VERTEX_ARRAY_POINTER = $808E ;

GL_NORMAL_ARRAY_POINTER = $808F ;

GL_COLOR_ARRAY_POINTER = $8090 ;

GL_INDEX_ARRAY_POINTER = $8091 ;

GL_TEXTURE_COORD_ARRAY_POINTER = $8092 ;

GL_EDGE_FLAG_ARRAY_POINTER = $8093 ;

GL_V2F = $2A20 ;

GL_V3F = $2A21 ;

GL_C4UB_V2F = $2A22 ;

GL_C4UB_V3F = $2A23 ;

GL_C3F_V3F = $2A24 ;

GL_N3F_V3F = $2A25 ;

GL_C4F_N3F_V3F = $2A26 ;

GL_T2F_V3F = $2A27 ;

GL_T4F_V4F = $2A28 ;

GL_T2F_C4UB_V3F = $2A29 ;

GL_T2F_C3F_V3F = $2A2A ;

GL_T2F_N3F_V3F = $2A2B ;

GL_T2F_C4F_N3F_V3F = $2A2C ;

GL_T4F_C4F_N3F_V4F = $2A2D ;

GL_CLIP_PLANE0 = $3000 ;

GL_CLIP_PLANE1 = $3001 ;

GL_CLIP_PLANE2 = $3002 ;

GL_CLIP_PLANE3 = $3003 ;

GL_CLIP_PLANE4 = $3004 ;

GL_CLIP_PLANE5 = $3005 ;

GL_LIGHT0 = $4000 ;

GL_LIGHT1 = $4001 ;

GL_LIGHT2 = $4002 ;

GL_LIGHT3 = $4003 ;

GL_LIGHT4 = $4004 ;

GL_LIGHT5 = $4005 ;

GL_LIGHT6 = $4006 ;

GL_LIGHT7 = $4007 ;

GL_UNSIGNED_BYTE_3_3_2 = $8032;

GL_UNSIGNED_SHORT_4_4_4_4 = $8033;

GL_UNSIGNED_SHORT_5_5_5_1 = $8034;

GL_UNSIGNED_INT_8_8_8_8 = $8035;

GL_UNSIGNED_INT_10_10_10_2 = $8036;

GL_PACK_SKIP_IMAGES = $806B;

GL_PACK_IMAGE_HEIGHT = $806C;

GL_UNPACK_SKIP_IMAGES = $806D;

GL_UNPACK_IMAGE_HEIGHT = $806E;

GL_TEXTURE_3D = $806F;

GL_TEXTURE_BINDING_3D = $806A;

GL_PROXY_TEXTURE_3D = $8070;

GL_TEXTURE_DEPTH = $8071;

GL_TEXTURE_WRAP_R = $8072;

GL_MAX_3D_TEXTURE_SIZE = $8073;

GL_UNSIGNED_BYTE_2_3_3_REV = $8362;

GL_UNSIGNED_SHORT_5_6_5 = $8363;

GL_UNSIGNED_SHORT_5_6_5_REV = $8364;

GL_UNSIGNED_SHORT_4_4_4_4_REV = $8365;

GL_UNSIGNED_SHORT_1_5_5_5_REV = $8366;

GL_UNSIGNED_INT_8_8_8_8_REV = $8367;

GL_UNSIGNED_INT_2_10_10_10_REV = $8368;

GL_BGR = $80E0;

GL_BGRA = $80E1;

GL_MAX_ELEMENTS_VERTICES = $80E8;

GL_MAX_ELEMENTS_INDICES = $80E9;

GL_CLAMP_TO_EDGE = $812F;

GL_TEXTURE_MIN_LOD = $813A;

GL_TEXTURE_MAX_LOD = $813B;

GL_TEXTURE_BASE_LEVEL = $813C;

GL_TEXTURE_MAX_LEVEL = $813D;

GL_SMOOTH_POINT_SIZE_RANGE = $0B12;

GL_SMOOTH_POINT_SIZE_GRANULARITY = $0B13;

GL_SMOOTH_LINE_WIDTH_RANGE = $0B22;

GL_SMOOTH_LINE_WIDTH_GRANULARITY = $0B23;

GL_ALIASED_LINE_WIDTH_RANGE = $846E;

GL_CONSTANT_COLOR = $8001;

GL_ONE_MINUS_CONSTANT_COLOR = $8002;

GL_CONSTANT_ALPHA = $8003;

GL_ONE_MINUS_CONSTANT_ALPHA = $8004;

GL_BLEND_COLOR = $8005;

GL_FUNC_ADD = $8006;

GL_MIN = $8007;

GL_MAX = $8008;

GL_BLEND_EQUATION = $8009;

GL_FUNC_SUBTRACT = $800A;

GL_FUNC_REVERSE_SUBTRACT = $800B;

GL_RESCALE_NORMAL = $803A ;

GL_LIGHT_MODEL_COLOR_CONTROL = $81F8 ;

GL_SINGLE_COLOR = $81F9 ;

GL_SEPARATE_SPECULAR_COLOR = $81FA ;

GL_ALIASED_POINT_SIZE_RANGE = $846D ;

GL_CONVOLUTION_1D = $8010 ;

GL_CONVOLUTION_2D = $8011 ;

GL_SEPARABLE_2D = $8012 ;

GL_CONVOLUTION_BORDER_MODE = $8013 ;

GL_CONVOLUTION_FILTER_SCALE = $8014 ;

GL_CONVOLUTION_FILTER_BIAS = $8015 ;

GL_REDUCE = $8016 ;

GL_CONVOLUTION_FORMAT = $8017 ;

GL_CONVOLUTION_WIDTH = $8018 ;

GL_CONVOLUTION_HEIGHT = $8019 ;

GL_MAX_CONVOLUTION_WIDTH = $801A ;

GL_MAX_CONVOLUTION_HEIGHT = $801B ;

GL_POST_CONVOLUTION_RED_SCALE = $801C ;

GL_POST_CONVOLUTION_GREEN_SCALE = $801D ;

GL_POST_CONVOLUTION_BLUE_SCALE = $801E ;

GL_POST_CONVOLUTION_ALPHA_SCALE = $801F ;

GL_POST_CONVOLUTION_RED_BIAS = $8020 ;

GL_POST_CONVOLUTION_GREEN_BIAS = $8021 ;

GL_POST_CONVOLUTION_BLUE_BIAS = $8022 ;

GL_POST_CONVOLUTION_ALPHA_BIAS = $8023 ;

GL_HISTOGRAM = $8024 ;

GL_PROXY_HISTOGRAM = $8025 ;

GL_HISTOGRAM_WIDTH = $8026 ;

GL_HISTOGRAM_FORMAT = $8027 ;

GL_HISTOGRAM_RED_SIZE = $8028 ;

GL_HISTOGRAM_GREEN_SIZE = $8029 ;

GL_HISTOGRAM_BLUE_SIZE = $802A ;

GL_HISTOGRAM_ALPHA_SIZE = $802B ;

GL_HISTOGRAM_LUMINANCE_SIZE = $802C ;

GL_HISTOGRAM_SINK = $802D ;

GL_MINMAX = $802E ;

GL_MINMAX_FORMAT = $802F ;

GL_MINMAX_SINK = $8030 ;

GL_TABLE_TOO_LARGE = $8031 ;

GL_COLOR_MATRIX = $80B1 ;

GL_COLOR_MATRIX_STACK_DEPTH = $80B2 ;

GL_MAX_COLOR_MATRIX_STACK_DEPTH = $80B3 ;

GL_POST_COLOR_MATRIX_RED_SCALE = $80B4 ;

GL_POST_COLOR_MATRIX_GREEN_SCALE = $80B5 ;

GL_POST_COLOR_MATRIX_BLUE_SCALE = $80B6 ;

GL_POST_COLOR_MATRIX_ALPHA_SCALE = $80B7 ;

GL_POST_COLOR_MATRIX_RED_BIAS = $80B8 ;

GL_POST_COLOR_MATRIX_GREEN_BIAS = $80B9 ;

GL_POST_COLOR_MATRIX_BLUE_BIAS = $80BA ;

GL_POST_COLOR_MATRIX_ALPHA_BIAS = $80BB ;

GL_COLOR_TABLE = $80D0 ;

GL_POST_CONVOLUTION_COLOR_TABLE = $80D1 ;

GL_POST_COLOR_MATRIX_COLOR_TABLE = $80D2 ;

GL_PROXY_COLOR_TABLE = $80D3 ;

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE = $80D4 ;

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE = $80D5 ;

GL_COLOR_TABLE_SCALE = $80D6 ;

GL_COLOR_TABLE_BIAS = $80D7 ;

GL_COLOR_TABLE_FORMAT = $80D8 ;

GL_COLOR_TABLE_WIDTH = $80D9 ;

GL_COLOR_TABLE_RED_SIZE = $80DA ;

GL_COLOR_TABLE_GREEN_SIZE = $80DB ;

GL_COLOR_TABLE_BLUE_SIZE = $80DC ;

GL_COLOR_TABLE_ALPHA_SIZE = $80DD ;

GL_COLOR_TABLE_LUMINANCE_SIZE = $80DE ;

GL_COLOR_TABLE_INTENSITY_SIZE = $80DF ;

GL_CONSTANT_BORDER = $8151 ;

GL_REPLICATE_BORDER = $8153 ;

GL_CONVOLUTION_BORDER_COLOR = $8154 ;

GL_TEXTURE0 = $84C0;

GL_TEXTURE1 = $84C1;

GL_TEXTURE2 = $84C2;

GL_TEXTURE3 = $84C3;

GL_TEXTURE4 = $84C4;

GL_TEXTURE5 = $84C5;

GL_TEXTURE6 = $84C6;

GL_TEXTURE7 = $84C7;

GL_TEXTURE8 = $84C8;

GL_TEXTURE9 = $84C9;

GL_TEXTURE10 = $84CA;

GL_TEXTURE11 = $84CB;

GL_TEXTURE12 = $84CC;

GL_TEXTURE13 = $84CD;

GL_TEXTURE14 = $84CE;

GL_TEXTURE15 = $84CF;

GL_TEXTURE16 = $84D0;

GL_TEXTURE17 = $84D1;

GL_TEXTURE18 = $84D2;

GL_TEXTURE19 = $84D3;

GL_TEXTURE20 = $84D4;

GL_TEXTURE21 = $84D5;

GL_TEXTURE22 = $84D6;

GL_TEXTURE23 = $84D7;

GL_TEXTURE24 = $84D8;

GL_TEXTURE25 = $84D9;

GL_TEXTURE26 = $84DA;

GL_TEXTURE27 = $84DB;

GL_TEXTURE28 = $84DC;

GL_TEXTURE29 = $84DD;

GL_TEXTURE30 = $84DE;

GL_TEXTURE31 = $84DF;

GL_ACTIVE_TEXTURE = $84E0;

GL_MULTISAMPLE = $809D;

GL_SAMPLE_ALPHA_TO_COVERAGE = $809E;

GL_SAMPLE_ALPHA_TO_ONE = $809F;

GL_SAMPLE_COVERAGE = $80A0;

GL_SAMPLE_BUFFERS = $80A8;

GL_SAMPLES = $80A9;

GL_SAMPLE_COVERAGE_VALUE = $80AA;

GL_SAMPLE_COVERAGE_INVERT = $80AB;

GL_TEXTURE_CUBE_MAP = $8513;

GL_TEXTURE_BINDING_CUBE_MAP = $8514;

GL_TEXTURE_CUBE_MAP_POSITIVE_X = $8515;

GL_TEXTURE_CUBE_MAP_NEGATIVE_X = $8516;

GL_TEXTURE_CUBE_MAP_POSITIVE_Y = $8517;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y = $8518;

GL_TEXTURE_CUBE_MAP_POSITIVE_Z = $8519;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z = $851A;

GL_PROXY_TEXTURE_CUBE_MAP = $851B;

GL_MAX_CUBE_MAP_TEXTURE_SIZE = $851C;

GL_COMPRESSED_RGB = $84ED;

GL_COMPRESSED_RGBA = $84EE;

GL_TEXTURE_COMPRESSION_HINT = $84EF;

GL_TEXTURE_COMPRESSED_IMAGE_SIZE = $86A0;

GL_TEXTURE_COMPRESSED = $86A1;

GL_NUM_COMPRESSED_TEXTURE_FORMATS = $86A2;

GL_COMPRESSED_TEXTURE_FORMATS = $86A3;

GL_CLAMP_TO_BORDER = $812D;

GL_CLIENT_ACTIVE_TEXTURE = $84E1 ;

GL_MAX_TEXTURE_UNITS = $84E2 ;

GL_TRANSPOSE_MODELVIEW_MATRIX = $84E3 ;

GL_TRANSPOSE_PROJECTION_MATRIX = $84E4 ;

GL_TRANSPOSE_TEXTURE_MATRIX = $84E5 ;

GL_TRANSPOSE_COLOR_MATRIX = $84E6 ;

GL_MULTISAMPLE_BIT = $20000000 ;

GL_NORMAL_MAP = $8511 ;

GL_REFLECTION_MAP = $8512 ;

GL_COMPRESSED_ALPHA = $84E9 ;

GL_COMPRESSED_LUMINANCE = $84EA ;

GL_COMPRESSED_LUMINANCE_ALPHA = $84EB ;

GL_COMPRESSED_INTENSITY = $84EC ;

GL_COMBINE = $8570 ;

GL_COMBINE_RGB = $8571 ;

GL_COMBINE_ALPHA = $8572 ;

GL_SOURCE0_RGB = $8580 ;

GL_SOURCE1_RGB = $8581 ;

GL_SOURCE2_RGB = $8582 ;

GL_SOURCE0_ALPHA = $8588 ;

GL_SOURCE1_ALPHA = $8589 ;

GL_SOURCE2_ALPHA = $858A ;

GL_OPERAND0_RGB = $8590 ;

GL_OPERAND1_RGB = $8591 ;

GL_OPERAND2_RGB = $8592 ;

GL_OPERAND0_ALPHA = $8598 ;

GL_OPERAND1_ALPHA = $8599 ;

GL_OPERAND2_ALPHA = $859A ;

GL_RGB_SCALE = $8573 ;

GL_ADD_SIGNED = $8574 ;

GL_INTERPOLATE = $8575 ;

GL_SUBTRACT = $84E7 ;

GL_CONSTANT = $8576 ;

GL_PRIMARY_COLOR = $8577 ;

GL_PREVIOUS = $8578 ;

GL_DOT3_RGB = $86AE ;

GL_DOT3_RGBA = $86AF ;

GL_BLEND_DST_RGB = $80C8;

GL_BLEND_SRC_RGB = $80C9;

GL_BLEND_DST_ALPHA = $80CA;

GL_BLEND_SRC_ALPHA = $80CB;

GL_POINT_FADE_THRESHOLD_SIZE = $8128;

GL_DEPTH_COMPONENT16 = $81A5;

GL_DEPTH_COMPONENT24 = $81A6;

GL_DEPTH_COMPONENT32 = $81A7;

GL_MIRRORED_REPEAT = $8370;

GL_MAX_TEXTURE_LOD_BIAS = $84FD;

GL_TEXTURE_LOD_BIAS = $8501;

GL_INCR_WRAP = $8507;

GL_DECR_WRAP = $8508;

GL_TEXTURE_DEPTH_SIZE = $884A;

GL_TEXTURE_COMPARE_MODE = $884C;

GL_TEXTURE_COMPARE_FUNC = $884D;

GL_POINT_SIZE_MIN = $8126 ;

GL_POINT_SIZE_MAX = $8127 ;

GL_POINT_DISTANCE_ATTENUATION = $8129 ;

GL_GENERATE_MIPMAP = $8191 ;

GL_GENERATE_MIPMAP_HINT = $8192 ;

GL_FOG_COORDINATE_SOURCE = $8450 ;

GL_FOG_COORDINATE = $8451 ;

GL_FRAGMENT_DEPTH = $8452 ;

GL_CURRENT_FOG_COORDINATE = $8453 ;

GL_FOG_COORDINATE_ARRAY_TYPE = $8454 ;

GL_FOG_COORDINATE_ARRAY_STRIDE = $8455 ;

GL_FOG_COORDINATE_ARRAY_POINTER = $8456 ;

GL_FOG_COORDINATE_ARRAY = $8457 ;

GL_COLOR_SUM = $8458 ;

GL_CURRENT_SECONDARY_COLOR = $8459 ;

GL_SECONDARY_COLOR_ARRAY_SIZE = $845A ;

GL_SECONDARY_COLOR_ARRAY_TYPE = $845B ;

GL_SECONDARY_COLOR_ARRAY_STRIDE = $845C ;

GL_SECONDARY_COLOR_ARRAY_POINTER = $845D ;

GL_SECONDARY_COLOR_ARRAY = $845E ;

GL_TEXTURE_FILTER_CONTROL = $8500 ;

GL_DEPTH_TEXTURE_MODE = $884B ;

GL_COMPARE_R_TO_TEXTURE = $884E ;

GL_BUFFER_SIZE = $8764;

GL_BUFFER_USAGE = $8765;

GL_QUERY_COUNTER_BITS = $8864;

GL_CURRENT_QUERY = $8865;

GL_QUERY_RESULT = $8866;

GL_QUERY_RESULT_AVAILABLE = $8867;

GL_ARRAY_BUFFER = $8892;

GL_ELEMENT_ARRAY_BUFFER = $8893;

GL_ARRAY_BUFFER_BINDING = $8894;

GL_ELEMENT_ARRAY_BUFFER_BINDING = $8895;

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING = $889F;

GL_READ_ONLY = $88B8;

GL_WRITE_ONLY = $88B9;

GL_READ_WRITE = $88BA;

GL_BUFFER_ACCESS = $88BB;

GL_BUFFER_MAPPED = $88BC;

GL_BUFFER_MAP_POINTER = $88BD;

GL_STREAM_DRAW = $88E0;

GL_STREAM_READ = $88E1;

GL_STREAM_COPY = $88E2;

GL_STATIC_DRAW = $88E4;

GL_STATIC_READ = $88E5;

GL_STATIC_COPY = $88E6;

GL_DYNAMIC_DRAW = $88E8;

GL_DYNAMIC_READ = $88E9;

GL_DYNAMIC_COPY = $88EA;

GL_SAMPLES_PASSED = $8914;

GL_SRC1_ALPHA = GL_SOURCE1_ALPHA;

GL_VERTEX_ARRAY_BUFFER_BINDING = $8896 ;

GL_NORMAL_ARRAY_BUFFER_BINDING = $8897 ;

GL_COLOR_ARRAY_BUFFER_BINDING = $8898 ;

GL_INDEX_ARRAY_BUFFER_BINDING = $8899 ;

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING = $889A ;

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING = $889B ;

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING = $889C ;

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING = $889D ;

GL_WEIGHT_ARRAY_BUFFER_BINDING = $889E ;

GL_FOG_COORD_SRC = GL_FOG_COORDINATE_SOURCE ;

GL_FOG_COORD = GL_FOG_COORDINATE ;

GL_CURRENT_FOG_COORD = GL_CURRENT_FOG_COORDINATE ;

GL_FOG_COORD_ARRAY_TYPE = GL_FOG_COORDINATE_ARRAY_TYPE ;

GL_FOG_COORD_ARRAY_STRIDE = GL_FOG_COORDINATE_ARRAY_STRIDE ;

GL_FOG_COORD_ARRAY_POINTER = GL_FOG_COORDINATE_ARRAY_POINTER ;

GL_FOG_COORD_ARRAY = GL_FOG_COORDINATE_ARRAY ;

GL_FOG_COORD_ARRAY_BUFFER_BINDING = GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING ;

GL_SRC0_RGB = GL_SOURCE0_RGB ;

GL_SRC1_RGB = GL_SOURCE1_RGB ;

GL_SRC2_RGB = GL_SOURCE2_RGB ;

GL_SRC0_ALPHA = GL_SOURCE0_ALPHA ;

GL_SRC2_ALPHA = GL_SOURCE2_ALPHA ;

GL_BLEND_EQUATION_RGB = GL_BLEND_EQUATION;

GL_VERTEX_ATTRIB_ARRAY_ENABLED = $8622;

GL_VERTEX_ATTRIB_ARRAY_SIZE = $8623;

GL_VERTEX_ATTRIB_ARRAY_STRIDE = $8624;

GL_VERTEX_ATTRIB_ARRAY_TYPE = $8625;

GL_CURRENT_VERTEX_ATTRIB = $8626;

GL_VERTEX_PROGRAM_POINT_SIZE = $8642;

GL_VERTEX_ATTRIB_ARRAY_POINTER = $8645;

GL_STENCIL_BACK_FUNC = $8800;

GL_STENCIL_BACK_FAIL = $8801;

GL_STENCIL_BACK_PASS_DEPTH_FAIL = $8802;

GL_STENCIL_BACK_PASS_DEPTH_PASS = $8803;

GL_MAX_DRAW_BUFFERS = $8824;

GL_DRAW_BUFFER0 = $8825;

GL_DRAW_BUFFER1 = $8826;

GL_DRAW_BUFFER2 = $8827;

GL_DRAW_BUFFER3 = $8828;

GL_DRAW_BUFFER4 = $8829;

GL_DRAW_BUFFER5 = $882A;

GL_DRAW_BUFFER6 = $882B;

GL_DRAW_BUFFER7 = $882C;

GL_DRAW_BUFFER8 = $882D;

GL_DRAW_BUFFER9 = $882E;

GL_DRAW_BUFFER10 = $882F;

GL_DRAW_BUFFER11 = $8830;

GL_DRAW_BUFFER12 = $8831;

GL_DRAW_BUFFER13 = $8832;

GL_DRAW_BUFFER14 = $8833;

GL_DRAW_BUFFER15 = $8834;

GL_BLEND_EQUATION_ALPHA = $883D;

GL_MAX_VERTEX_ATTRIBS = $8869;

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED = $886A;

GL_MAX_TEXTURE_IMAGE_UNITS = $8872;

GL_FRAGMENT_SHADER = $8B30;

GL_VERTEX_SHADER = $8B31;

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS = $8B49;

GL_MAX_VERTEX_UNIFORM_COMPONENTS = $8B4A;

GL_MAX_VARYING_FLOATS = $8B4B ;

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS = $8B4C;

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS = $8B4D;

GL_SHADER_TYPE = $8B4F;

GL_FLOAT_VEC2 = $8B50;

GL_FLOAT_VEC3 = $8B51;

GL_FLOAT_VEC4 = $8B52;

GL_INT_VEC2 = $8B53;

GL_INT_VEC3 = $8B54;

GL_INT_VEC4 = $8B55;

GL_BOOL = $8B56;

GL_BOOL_VEC2 = $8B57;

GL_BOOL_VEC3 = $8B58;

GL_BOOL_VEC4 = $8B59;

GL_FLOAT_MAT2 = $8B5A;

GL_FLOAT_MAT3 = $8B5B;

GL_FLOAT_MAT4 = $8B5C;

GL_SAMPLER_1D = $8B5D;

GL_SAMPLER_2D = $8B5E;

GL_SAMPLER_3D = $8B5F;

GL_SAMPLER_CUBE = $8B60;

GL_SAMPLER_1D_SHADOW = $8B61;

GL_SAMPLER_2D_SHADOW = $8B62;

GL_DELETE_STATUS = $8B80;

GL_COMPILE_STATUS = $8B81;

GL_LINK_STATUS = $8B82;

GL_VALIDATE_STATUS = $8B83;

GL_INFO_LOG_LENGTH = $8B84;

GL_ATTACHED_SHADERS = $8B85;

GL_ACTIVE_UNIFORMS = $8B86;

GL_ACTIVE_UNIFORM_MAX_LENGTH = $8B87;

GL_SHADER_SOURCE_LENGTH = $8B88;

GL_ACTIVE_ATTRIBUTES = $8B89;

GL_ACTIVE_ATTRIBUTE_MAX_LENGTH = $8B8A;

GL_FRAGMENT_SHADER_DERIVATIVE_HINT = $8B8B;

GL_SHADING_LANGUAGE_VERSION = $8B8C;

GL_CURRENT_PROGRAM = $8B8D;

GL_POINT_SPRITE_COORD_ORIGIN = $8CA0;

GL_LOWER_LEFT = $8CA1;

GL_UPPER_LEFT = $8CA2;

GL_STENCIL_BACK_REF = $8CA3;

GL_STENCIL_BACK_VALUE_MASK = $8CA4;

GL_STENCIL_BACK_WRITEMASK = $8CA5;

GL_VERTEX_PROGRAM_TWO_SIDE = $8643 ;

GL_POINT_SPRITE = $8861 ;

GL_COORD_REPLACE = $8862 ;

GL_MAX_TEXTURE_COORDS = $8871 ;

GL_PIXEL_PACK_BUFFER = $88EB;

GL_PIXEL_UNPACK_BUFFER = $88EC;

GL_PIXEL_PACK_BUFFER_BINDING = $88ED;

GL_PIXEL_UNPACK_BUFFER_BINDING = $88EF;

GL_FLOAT_MAT2x3 = $8B65;

GL_FLOAT_MAT2x4 = $8B66;

GL_FLOAT_MAT3x2 = $8B67;

GL_FLOAT_MAT3x4 = $8B68;

GL_FLOAT_MAT4x2 = $8B69;

GL_FLOAT_MAT4x3 = $8B6A;

GL_SRGB = $8C40;

GL_SRGB8 = $8C41;

GL_SRGB_ALPHA = $8C42;

GL_SRGB8_ALPHA8 = $8C43;

GL_COMPRESSED_SRGB = $8C48;

GL_COMPRESSED_SRGB_ALPHA = $8C49;

GL_CURRENT_RASTER_SECONDARY_COLOR = $845F ;

GL_SLUMINANCE_ALPHA = $8C44 ;

GL_SLUMINANCE8_ALPHA8 = $8C45 ;

GL_SLUMINANCE = $8C46 ;

GL_SLUMINANCE8 = $8C47 ;

GL_COMPRESSED_SLUMINANCE = $8C4A ;

GL_COMPRESSED_SLUMINANCE_ALPHA = $8C4B ;

GL_COMPARE_REF_TO_TEXTURE = $884E;

GL_CLIP_DISTANCE0 = $3000;

GL_CLIP_DISTANCE1 = $3001;

GL_CLIP_DISTANCE2 = $3002;

GL_CLIP_DISTANCE3 = $3003;

GL_CLIP_DISTANCE4 = $3004;

GL_CLIP_DISTANCE5 = $3005;

GL_CLIP_DISTANCE6 = $3006;

GL_CLIP_DISTANCE7 = $3007;

GL_MAX_CLIP_DISTANCES = $0D32;

GL_MAJOR_VERSION = $821B;

GL_MINOR_VERSION = $821C;

GL_NUM_EXTENSIONS = $821D;

GL_CONTEXT_FLAGS = $821E;

GL_DEPTH_BUFFER = $8223;

GL_STENCIL_BUFFER = $8224;

GL_COMPRESSED_RED = $8225;

GL_COMPRESSED_RG = $8226;

GL_CONTEXT_FLAG_FORWARD_COMPATIBLE_BIT = $0001;

GL_RGBA32F = $8814;

GL_RGB32F = $8815;

GL_RGBA16F = $881A;

GL_RGB16F = $881B;

GL_VERTEX_ATTRIB_ARRAY_INTEGER = $88FD;

GL_MAX_ARRAY_TEXTURE_LAYERS = $88FF;

GL_MIN_PROGRAM_TEXEL_OFFSET = $8904;

GL_MAX_PROGRAM_TEXEL_OFFSET = $8905;

GL_CLAMP_VERTEX_COLOR = $891A;

GL_CLAMP_FRAGMENT_COLOR = $891B;

GL_CLAMP_READ_COLOR = $891C;

GL_FIXED_ONLY = $891D;

GL_MAX_VARYING_COMPONENTS = GL_MAX_VARYING_FLOATS ;

GL_TEXTURE_1D_ARRAY = $8C18;

GL_PROXY_TEXTURE_1D_ARRAY = $8C19;

GL_TEXTURE_2D_ARRAY = $8C1A;

GL_PROXY_TEXTURE_2D_ARRAY = $8C1B;

GL_TEXTURE_BINDING_1D_ARRAY = $8C1C;

GL_TEXTURE_BINDING_2D_ARRAY = $8C1D;

GL_R11F_G11F_B10F = $8C3A;

GL_UNSIGNED_INT_10F_11F_11F_REV = $8C3B;

GL_RGB9_E5 = $8C3D;

GL_UNSIGNED_INT_5_9_9_9_REV = $8C3E;

GL_TEXTURE_SHARED_SIZE = $8C3F;

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH = $8C76;

GL_TRANSFORM_FEEDBACK_BUFFER_MODE = $8C7F;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS = $8C80;

GL_TRANSFORM_FEEDBACK_VARYINGS = $8C83;

GL_TRANSFORM_FEEDBACK_BUFFER_START = $8C84;

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE = $8C85;

GL_PRIMITIVES_GENERATED = $8C87;

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN = $8C88;

GL_RASTERIZER_DISCARD = $8C89;

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS = $8C8A;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS = $8C8B;

GL_INTERLEAVED_ATTRIBS = $8C8C;

GL_SEPARATE_ATTRIBS = $8C8D;

GL_TRANSFORM_FEEDBACK_BUFFER = $8C8E;

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING = $8C8F;

GL_RGBA32UI = $8D70;

GL_RGB32UI = $8D71;

GL_RGBA16UI = $8D76;

GL_RGB16UI = $8D77;

GL_RGBA8UI = $8D7C;

GL_RGB8UI = $8D7D;

GL_RGBA32I = $8D82;

GL_RGB32I = $8D83;

GL_RGBA16I = $8D88;

GL_RGB16I = $8D89;

GL_RGBA8I = $8D8E;

GL_RGB8I = $8D8F;

GL_RED_INTEGER = $8D94;

GL_GREEN_INTEGER = $8D95;

GL_BLUE_INTEGER = $8D96;

GL_ALPHA_INTEGER = $8D97;

GL_RGB_INTEGER = $8D98;

GL_RGBA_INTEGER = $8D99;

GL_BGR_INTEGER = $8D9A;

GL_BGRA_INTEGER = $8D9B;

GL_SAMPLER_1D_ARRAY = $8DC0;

GL_SAMPLER_2D_ARRAY = $8DC1;

GL_SAMPLER_1D_ARRAY_SHADOW = $8DC3;

GL_SAMPLER_2D_ARRAY_SHADOW = $8DC4;

GL_SAMPLER_CUBE_SHADOW = $8DC5;

GL_UNSIGNED_INT_VEC2 = $8DC6;

GL_UNSIGNED_INT_VEC3 = $8DC7;

GL_UNSIGNED_INT_VEC4 = $8DC8;

GL_INT_SAMPLER_1D = $8DC9;

GL_INT_SAMPLER_2D = $8DCA;

GL_INT_SAMPLER_3D = $8DCB;

GL_INT_SAMPLER_CUBE = $8DCC;

GL_INT_SAMPLER_1D_ARRAY = $8DCE;

GL_INT_SAMPLER_2D_ARRAY = $8DCF;

GL_UNSIGNED_INT_SAMPLER_1D = $8DD1;

GL_UNSIGNED_INT_SAMPLER_2D = $8DD2;

GL_UNSIGNED_INT_SAMPLER_3D = $8DD3;

GL_UNSIGNED_INT_SAMPLER_CUBE = $8DD4;

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY = $8DD6;

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY = $8DD7;

GL_QUERY_WAIT = $8E13;

GL_QUERY_NO_WAIT = $8E14;

GL_QUERY_BY_REGION_WAIT = $8E15;

GL_QUERY_BY_REGION_NO_WAIT = $8E16;

GL_BUFFER_ACCESS_FLAGS = $911F;

GL_BUFFER_MAP_LENGTH = $9120;

GL_BUFFER_MAP_OFFSET = $9121;

GL_SAMPLER_2D_RECT = $8B63;

GL_SAMPLER_2D_RECT_SHADOW = $8B64;

GL_SAMPLER_BUFFER = $8DC2;

GL_INT_SAMPLER_2D_RECT = $8DCD;

GL_INT_SAMPLER_BUFFER = $8DD0;

GL_UNSIGNED_INT_SAMPLER_2D_RECT = $8DD5;

GL_UNSIGNED_INT_SAMPLER_BUFFER = $8DD8;

GL_TEXTURE_BUFFER = $8C2A;

GL_MAX_TEXTURE_BUFFER_SIZE = $8C2B;

GL_TEXTURE_BINDING_BUFFER = $8C2C;

GL_TEXTURE_BUFFER_DATA_STORE_BINDING = $8C2D;

GL_TEXTURE_BUFFER_FORMAT = $8C2E;

GL_TEXTURE_RECTANGLE = $84F5;

GL_TEXTURE_BINDING_RECTANGLE = $84F6;

GL_PROXY_TEXTURE_RECTANGLE = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE = $84F8;

GL_RED_SNORM = $8F90;

GL_RG_SNORM = $8F91;

GL_RGB_SNORM = $8F92;

GL_RGBA_SNORM = $8F93;

GL_R8_SNORM = $8F94;

GL_RG8_SNORM = $8F95;

GL_RGB8_SNORM = $8F96;

GL_RGBA8_SNORM = $8F97;

GL_R16_SNORM = $8F98;

GL_RG16_SNORM = $8F99;

GL_RGB16_SNORM = $8F9A;

GL_RGBA16_SNORM = $8F9B;

GL_SIGNED_NORMALIZED = $8F9C;

GL_PRIMITIVE_RESTART = $8F9D;

GL_PRIMITIVE_RESTART_INDEX = $8F9E;

GL_COMPRESSED_RGBA_BPTC_UNORM_ARB = $8E8C;

GL_COMPRESSED_SRGB_ALPHA_BPTC_UNORM_ARB = $8E8D;

GL_COMPRESSED_RGB_BPTC_SIGNED_FLOAT_ARB = $8E8E;

GL_COMPRESSED_RGB_BPTC_UNSIGNED_FLOAT_ARB = $8E8F;

GL_CONTEXT_CORE_PROFILE_BIT = $00000001;

GL_CONTEXT_COMPATIBILITY_PROFILE_BIT = $00000002;

GL_LINES_ADJACENCY = $000A;

GL_LINE_STRIP_ADJACENCY = $000B;

GL_TRIANGLES_ADJACENCY = $000C;

GL_TRIANGLE_STRIP_ADJACENCY = $000D;

GL_PROGRAM_POINT_SIZE = $8642;

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS = $8C29;

GL_FRAMEBUFFER_ATTACHMENT_LAYERED = $8DA7;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS = $8DA8;

GL_GEOMETRY_SHADER = $8DD9;

GL_GEOMETRY_VERTICES_OUT = $8916;

GL_GEOMETRY_INPUT_TYPE = $8917;

GL_GEOMETRY_OUTPUT_TYPE = $8918;

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS = $8DDF;

GL_MAX_GEOMETRY_OUTPUT_VERTICES = $8DE0;

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS = $8DE1;

GL_MAX_VERTEX_OUTPUT_COMPONENTS = $9122;

GL_MAX_GEOMETRY_INPUT_COMPONENTS = $9123;

GL_MAX_GEOMETRY_OUTPUT_COMPONENTS = $9124;

GL_MAX_FRAGMENT_INPUT_COMPONENTS = $9125;

GL_CONTEXT_PROFILE_MASK = $9126;

GL_VERTEX_ATTRIB_ARRAY_DIVISOR = $88FE;

GL_SAMPLE_SHADING = $8C36;

GL_MIN_SAMPLE_SHADING_VALUE = $8C37;

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET = $8E5E;

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET = $8E5F;

GL_TEXTURE_CUBE_MAP_ARRAY = $9009;

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY = $900A;

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY = $900B;

GL_SAMPLER_CUBE_MAP_ARRAY = $900C;

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW = $900D;

GL_INT_SAMPLER_CUBE_MAP_ARRAY = $900E;

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY = $900F;

GL_ACTIVE_TEXTURE_ARB = $84E0;

GL_CLIENT_ACTIVE_TEXTURE_ARB = $84E1;

GL_MAX_TEXTURE_UNITS_ARB = $84E2;

GL_TEXTURE0_ARB = $84C0;

GL_TEXTURE1_ARB = $84C1;

GL_TEXTURE2_ARB = $84C2;

GL_TEXTURE3_ARB = $84C3;

GL_TEXTURE4_ARB = $84C4;

GL_TEXTURE5_ARB = $84C5;

GL_TEXTURE6_ARB = $84C6;

GL_TEXTURE7_ARB = $84C7;

GL_TEXTURE8_ARB = $84C8;

GL_TEXTURE9_ARB = $84C9;

GL_TEXTURE10_ARB = $84CA;

GL_TEXTURE11_ARB = $84CB;

GL_TEXTURE12_ARB = $84CC;

GL_TEXTURE13_ARB = $84CD;

GL_TEXTURE14_ARB = $84CE;

GL_TEXTURE15_ARB = $84CF;

GL_TEXTURE16_ARB = $84D0;

GL_TEXTURE17_ARB = $84D1;

GL_TEXTURE18_ARB = $84D2;

GL_TEXTURE19_ARB = $84D3;

GL_TEXTURE20_ARB = $84D4;

GL_TEXTURE21_ARB = $84D5;

GL_TEXTURE22_ARB = $84D6;

GL_TEXTURE23_ARB = $84D7;

GL_TEXTURE24_ARB = $84D8;

GL_TEXTURE25_ARB = $84D9;

GL_TEXTURE26_ARB = $84DA;

GL_TEXTURE27_ARB = $84DB;

GL_TEXTURE28_ARB = $84DC;

GL_TEXTURE29_ARB = $84DD;

GL_TEXTURE30_ARB = $84DE;

GL_TEXTURE31_ARB = $84DF;

GL_TRANSPOSE_MODELVIEW_MATRIX_ARB = $84E3;

GL_TRANSPOSE_PROJECTION_MATRIX_ARB = $84E4;

GL_TRANSPOSE_TEXTURE_MATRIX_ARB = $84E5;

GL_TRANSPOSE_COLOR_MATRIX_ARB = $84E6;

WGL_FRONT_COLOR_BUFFER_BIT_ARB = $00000001;

WGL_BACK_COLOR_BUFFER_BIT_ARB = $00000002;

WGL_DEPTH_BUFFER_BIT_ARB = $00000004;

WGL_STENCIL_BUFFER_BIT_ARB = $00000008;

GL_MULTISAMPLE_ARB = $809D;

GL_SAMPLE_ALPHA_TO_COVERAGE_ARB = $809E;

GL_SAMPLE_ALPHA_TO_ONE_ARB = $809F;

GL_SAMPLE_COVERAGE_ARB = $80A0;

GL_SAMPLE_BUFFERS_ARB = $80A8;

GL_SAMPLES_ARB = $80A9;

GL_SAMPLE_COVERAGE_VALUE_ARB = $80AA;

GL_SAMPLE_COVERAGE_INVERT_ARB = $80AB;

GL_MULTISAMPLE_BIT_ARB = $20000000;

GLX_SAMPLE_BUFFERS_ARB = 100000;

GLX_SAMPLES_ARB = 100001;

WGL_SAMPLE_BUFFERS_ARB = $2041;

WGL_SAMPLES_ARB = $2042;

GLX_SAMPLE_BUFFERS_SGIS = $100000;

GLX_SAMPLES_SGIS = $100001;

GLX_SAMPLE_BUFFERS = $100000;

GLX_SAMPLES = $100001;

GL_NORMAL_MAP_ARB = $8511;

GL_REFLECTION_MAP_ARB = $8512;

GL_TEXTURE_CUBE_MAP_ARB = $8513;

GL_TEXTURE_BINDING_CUBE_MAP_ARB = $8514;

GL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $8515;

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $8516;

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $8517;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $8518;

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $8519;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $851A;

GL_PROXY_TEXTURE_CUBE_MAP_ARB = $851B;

GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB = $851C;

WGL_NUMBER_PIXEL_FORMATS_ARB = $2000;

WGL_DRAW_TO_WINDOW_ARB = $2001;

WGL_DRAW_TO_BITMAP_ARB = $2002;

WGL_ACCELERATION_ARB = $2003;

WGL_NEED_PALETTE_ARB = $2004;

WGL_NEED_SYSTEM_PALETTE_ARB = $2005;

WGL_SWAP_LAYER_BUFFERS_ARB = $2006;

WGL_SWAP_METHOD_ARB = $2007;

WGL_NUMBER_OVERLAYS_ARB = $2008;

WGL_NUMBER_UNDERLAYS_ARB = $2009;

WGL_TRANSPARENT_ARB = $200A;

WGL_TRANSPARENT_RED_VALUE_ARB = $2037;

WGL_TRANSPARENT_GREEN_VALUE_ARB = $2038;

WGL_TRANSPARENT_BLUE_VALUE_ARB = $2039;

WGL_TRANSPARENT_ALPHA_VALUE_ARB = $203A;

WGL_TRANSPARENT_INDEX_VALUE_ARB = $203B;

WGL_SHARE_DEPTH_ARB = $200C;

WGL_SHARE_STENCIL_ARB = $200D;

WGL_SHARE_ACCUM_ARB = $200E;

WGL_SUPPORT_GDI_ARB = $200F;

WGL_SUPPORT_OPENGL_ARB = $2010;

WGL_DOUBLE_BUFFER_ARB = $2011;

WGL_STEREO_ARB = $2012;

WGL_PIXEL_TYPE_ARB = $2013;

WGL_COLOR_BITS_ARB = $2014;

WGL_RED_BITS_ARB = $2015;

WGL_RED_SHIFT_ARB = $2016;

WGL_GREEN_BITS_ARB = $2017;

WGL_GREEN_SHIFT_ARB = $2018;

WGL_BLUE_BITS_ARB = $2019;

WGL_BLUE_SHIFT_ARB = $201A;

WGL_ALPHA_BITS_ARB = $201B;

WGL_ALPHA_SHIFT_ARB = $201C;

WGL_ACCUM_BITS_ARB = $201D;

WGL_ACCUM_RED_BITS_ARB = $201E;

WGL_ACCUM_GREEN_BITS_ARB = $201F;

WGL_ACCUM_BLUE_BITS_ARB = $2020;

WGL_ACCUM_ALPHA_BITS_ARB = $2021;

WGL_DEPTH_BITS_ARB = $2022;

WGL_STENCIL_BITS_ARB = $2023;

WGL_AUX_BUFFERS_ARB = $2024;

WGL_NO_ACCELERATION_ARB = $2025;

WGL_GENERIC_ACCELERATION_ARB = $2026;

WGL_FULL_ACCELERATION_ARB = $2027;

WGL_SWAP_EXCHANGE_ARB = $2028;

WGL_SWAP_COPY_ARB = $2029;

WGL_SWAP_UNDEFINED_ARB = $202A;

WGL_TYPE_RGBA_ARB = $202B;

WGL_TYPE_COLORINDEX_ARB = $202C;

ERROR_INVALID_PIXEL_TYPE_ARB = $2043;

ERROR_INCOMPATIBLE_DEVICE_CONTEXTS_ARB = $2054;

WGL_DRAW_TO_PBUFFER_ARB = $202D;

WGL_MAX_PBUFFER_PIXELS_ARB = $202E;

WGL_MAX_PBUFFER_WIDTH_ARB = $202F;

WGL_MAX_PBUFFER_HEIGHT_ARB = $2030;

WGL_PBUFFER_LARGEST_ARB = $2033;

WGL_PBUFFER_WIDTH_ARB = $2034;

WGL_PBUFFER_HEIGHT_ARB = $2035;

WGL_PBUFFER_LOST_ARB = $2036;

GL_COMPRESSED_ALPHA_ARB = $84E9;

GL_COMPRESSED_LUMINANCE_ARB = $84EA;

GL_COMPRESSED_LUMINANCE_ALPHA_ARB = $84EB;

GL_COMPRESSED_INTENSITY_ARB = $84EC;

GL_COMPRESSED_RGB_ARB = $84ED;

GL_COMPRESSED_RGBA_ARB = $84EE;

GL_TEXTURE_COMPRESSION_HINT_ARB = $84EF;

GL_TEXTURE_COMPRESSED_IMAGE_SIZE_ARB = $86A0;

GL_TEXTURE_COMPRESSED_ARB = $86A1;

GL_NUM_COMPRESSED_TEXTURE_FORMATS_ARB = $86A2;

GL_COMPRESSED_TEXTURE_FORMATS_ARB = $86A3;

GL_CLAMP_TO_BORDER_ARB = $812D;

GL_POINT_SIZE_MIN_ARB = $8126;

GL_POINT_SIZE_MAX_ARB = $8127;

GL_POINT_FADE_THRESHOLD_SIZE_ARB = $8128;

GL_DISTANCE_ATTENUATION_ARB = $8129;

GL_MAX_VERTEX_UNITS_ARB = $86A4;

GL_ACTIVE_VERTEX_UNITS_ARB = $86A5;

GL_WEIGHT_SUM_UNITY_ARB = $86A6;

GL_VERTEX_BLEND_ARB = $86A7;

GL_CURRENT_WEIGHT_ARB = $86A8;

GL_WEIGHT_ARRAY_TYPE_ARB = $86A9;

GL_WEIGHT_ARRAY_STRIDE_ARB = $86AA;

GL_WEIGHT_ARRAY_SIZE_ARB = $86AB;

GL_WEIGHT_ARRAY_POINTER_ARB = $86AC;

GL_WEIGHT_ARRAY_ARB = $86AD;

GL_MODELVIEW0_ARB = $1700;

GL_MODELVIEW1_ARB = $850A;

GL_MODELVIEW2_ARB = $8722;

GL_MODELVIEW3_ARB = $8723;

GL_MODELVIEW4_ARB = $8724;

GL_MODELVIEW5_ARB = $8725;

GL_MODELVIEW6_ARB = $8726;

GL_MODELVIEW7_ARB = $8727;

GL_MODELVIEW8_ARB = $8728;

GL_MODELVIEW9_ARB = $8729;

GL_MODELVIEW10_ARB = $872A;

GL_MODELVIEW11_ARB = $872B;

GL_MODELVIEW12_ARB = $872C;

GL_MODELVIEW13_ARB = $872D;

GL_MODELVIEW14_ARB = $872E;

GL_MODELVIEW15_ARB = $872F;

GL_MODELVIEW16_ARB = $8730;

GL_MODELVIEW17_ARB = $8731;

GL_MODELVIEW18_ARB = $8732;

GL_MODELVIEW19_ARB = $8733;

GL_MODELVIEW20_ARB = $8734;

GL_MODELVIEW21_ARB = $8735;

GL_MODELVIEW22_ARB = $8736;

GL_MODELVIEW23_ARB = $8737;

GL_MODELVIEW24_ARB = $8738;

GL_MODELVIEW25_ARB = $8739;

GL_MODELVIEW26_ARB = $873A;

GL_MODELVIEW27_ARB = $873B;

GL_MODELVIEW28_ARB = $873C;

GL_MODELVIEW29_ARB = $873D;

GL_MODELVIEW30_ARB = $873E;

GL_MODELVIEW31_ARB = $873F;

GL_MATRIX_PALETTE_ARB = $8840;

GL_MAX_MATRIX_PALETTE_STACK_DEPTH_ARB = $8841;

GL_MAX_PALETTE_MATRICES_ARB = $8842;

GL_CURRENT_PALETTE_MATRIX_ARB = $8843;

GL_MATRIX_INDEX_ARRAY_ARB = $8844;

GL_CURRENT_MATRIX_INDEX_ARB = $8845;

GL_MATRIX_INDEX_ARRAY_SIZE_ARB = $8846;

GL_MATRIX_INDEX_ARRAY_TYPE_ARB = $8847;

GL_MATRIX_INDEX_ARRAY_STRIDE_ARB = $8848;

GL_MATRIX_INDEX_ARRAY_POINTER_ARB = $8849;

GL_COMBINE_ARB = $8570;

GL_COMBINE_RGB_ARB = $8571;

GL_COMBINE_ALPHA_ARB = $8572;

GL_RGB_SCALE_ARB = $8573;

GL_ADD_SIGNED_ARB = $8574;

GL_INTERPOLATE_ARB = $8575;

GL_CONSTANT_ARB = $8576;

GL_CONSTANT_COLOR_ARB = $8576;

GL_PRIMARY_COLOR_ARB = $8577;

GL_PREVIOUS_ARB = $8578;

GL_SOURCE0_RGB_ARB = $8580;

GL_SOURCE1_RGB_ARB = $8581;

GL_SOURCE2_RGB_ARB = $8582;

GL_SOURCE0_ALPHA_ARB = $8588;

GL_SOURCE1_ALPHA_ARB = $8589;

GL_SOURCE2_ALPHA_ARB = $858A;

GL_OPERAND0_RGB_ARB = $8590;

GL_OPERAND1_RGB_ARB = $8591;

GL_OPERAND2_RGB_ARB = $8592;

GL_OPERAND0_ALPHA_ARB = $8598;

GL_OPERAND1_ALPHA_ARB = $8599;

GL_OPERAND2_ALPHA_ARB = $859A;

GL_SUBTRACT_ARB = $84E7;

GL_DOT3_RGB_ARB = $86AE;

GL_DOT3_RGBA_ARB = $86AF;

WGL_BIND_TO_TEXTURE_RGB_ARB = $2070;

WGL_BIND_TO_TEXTURE_RGBA_ARB = $2071;

WGL_TEXTURE_FORMAT_ARB = $2072;

WGL_TEXTURE_TARGET_ARB = $2073;

WGL_MIPMAP_TEXTURE_ARB = $2074;

WGL_TEXTURE_RGB_ARB = $2075;

WGL_TEXTURE_RGBA_ARB = $2076;

WGL_NO_TEXTURE_ARB = $2077;

WGL_TEXTURE_CUBE_MAP_ARB = $2078;

WGL_TEXTURE_1D_ARB = $2079;

WGL_TEXTURE_2D_ARB = $207A;

WGL_MIPMAP_LEVEL_ARB = $207B;

WGL_CUBE_MAP_FACE_ARB = $207C;

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $207D;

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $207E;

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $207F;

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $2080;

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $2081;

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $2082;

WGL_FRONT_LEFT_ARB = $2083;

WGL_FRONT_RIGHT_ARB = $2084;

WGL_BACK_LEFT_ARB = $2085;

WGL_BACK_RIGHT_ARB = $2086;

WGL_AUX0_ARB = $2087;

WGL_AUX1_ARB = $2088;

WGL_AUX2_ARB = $2089;

WGL_AUX3_ARB = $208A;

WGL_AUX4_ARB = $208B;

WGL_AUX5_ARB = $208C;

WGL_AUX6_ARB = $208D;

WGL_AUX7_ARB = $208E;

WGL_AUX8_ARB = $208F;

WGL_AUX9_ARB = $2090;

GL_MIRRORED_REPEAT_ARB = $8370;

GL_DEPTH_COMPONENT16_ARB = $81A5;

GL_DEPTH_COMPONENT24_ARB = $81A6;

GL_DEPTH_COMPONENT32_ARB = $81A7;

GL_TEXTURE_DEPTH_SIZE_ARB = $884A;

GL_DEPTH_TEXTURE_MODE_ARB = $884B;

GL_TEXTURE_COMPARE_MODE_ARB = $884C;

GL_TEXTURE_COMPARE_FUNC_ARB = $884D;

GL_COMPARE_R_TO_TEXTURE_ARB = $884E;

GL_TEXTURE_COMPARE_FAIL_VALUE_ARB = $80BF;

GL_COLOR_SUM_ARB = $8458;

GL_VERTEX_PROGRAM_ARB = $8620;

GL_VERTEX_ATTRIB_ARRAY_ENABLED_ARB = $8622;

GL_VERTEX_ATTRIB_ARRAY_SIZE_ARB = $8623;

GL_VERTEX_ATTRIB_ARRAY_STRIDE_ARB = $8624;

GL_VERTEX_ATTRIB_ARRAY_TYPE_ARB = $8625;

GL_CURRENT_VERTEX_ATTRIB_ARB = $8626;

GL_PROGRAM_LENGTH_ARB = $8627;

GL_PROGRAM_STRING_ARB = $8628;

GL_MAX_PROGRAM_MATRIX_STACK_DEPTH_ARB = $862E;

GL_MAX_PROGRAM_MATRICES_ARB = $862F;

GL_CURRENT_MATRIX_STACK_DEPTH_ARB = $8640;

GL_CURRENT_MATRIX_ARB = $8641;

GL_VERTEX_PROGRAM_POINT_SIZE_ARB = $8642;

GL_VERTEX_PROGRAM_TWO_SIDE_ARB = $8643;

GL_VERTEX_ATTRIB_ARRAY_POINTER_ARB = $8645;

GL_PROGRAM_ERROR_POSITION_ARB = $864B;

GL_PROGRAM_BINDING_ARB = $8677;

GL_MAX_VERTEX_ATTRIBS_ARB = $8869;

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED_ARB = $886A;

GL_PROGRAM_ERROR_STRING_ARB = $8874;

GL_PROGRAM_FORMAT_ASCII_ARB = $8875;

GL_PROGRAM_FORMAT_ARB = $8876;

GL_PROGRAM_INSTRUCTIONS_ARB = $88A0;

GL_MAX_PROGRAM_INSTRUCTIONS_ARB = $88A1;

GL_PROGRAM_NATIVE_INSTRUCTIONS_ARB = $88A2;

GL_MAX_PROGRAM_NATIVE_INSTRUCTIONS_ARB = $88A3;

GL_PROGRAM_TEMPORARIES_ARB = $88A4;

GL_MAX_PROGRAM_TEMPORARIES_ARB = $88A5;

GL_PROGRAM_NATIVE_TEMPORARIES_ARB = $88A6;

GL_MAX_PROGRAM_NATIVE_TEMPORARIES_ARB = $88A7;

GL_PROGRAM_PARAMETERS_ARB = $88A8;

GL_MAX_PROGRAM_PARAMETERS_ARB = $88A9;

GL_PROGRAM_NATIVE_PARAMETERS_ARB = $88AA;

GL_MAX_PROGRAM_NATIVE_PARAMETERS_ARB = $88AB;

GL_PROGRAM_ATTRIBS_ARB = $88AC;

GL_MAX_PROGRAM_ATTRIBS_ARB = $88AD;

GL_PROGRAM_NATIVE_ATTRIBS_ARB = $88AE;

GL_MAX_PROGRAM_NATIVE_ATTRIBS_ARB = $88AF;

GL_PROGRAM_ADDRESS_REGISTERS_ARB = $88B0;

GL_MAX_PROGRAM_ADDRESS_REGISTERS_ARB = $88B1;

GL_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB = $88B2;

GL_MAX_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB = $88B3;

GL_MAX_PROGRAM_LOCAL_PARAMETERS_ARB = $88B4;

GL_MAX_PROGRAM_ENV_PARAMETERS_ARB = $88B5;

GL_PROGRAM_UNDER_NATIVE_LIMITS_ARB = $88B6;

GL_TRANSPOSE_CURRENT_MATRIX_ARB = $88B7;

GL_MATRIX0_ARB = $88C0;

GL_MATRIX1_ARB = $88C1;

GL_MATRIX2_ARB = $88C2;

GL_MATRIX3_ARB = $88C3;

GL_MATRIX4_ARB = $88C4;

GL_MATRIX5_ARB = $88C5;

GL_MATRIX6_ARB = $88C6;

GL_MATRIX7_ARB = $88C7;

GL_MATRIX8_ARB = $88C8;

GL_MATRIX9_ARB = $88C9;

GL_MATRIX10_ARB = $88CA;

GL_MATRIX11_ARB = $88CB;

GL_MATRIX12_ARB = $88CC;

GL_MATRIX13_ARB = $88CD;

GL_MATRIX14_ARB = $88CE;

GL_MATRIX15_ARB = $88CF;

GL_MATRIX16_ARB = $88D0;

GL_MATRIX17_ARB = $88D1;

GL_MATRIX18_ARB = $88D2;

GL_MATRIX19_ARB = $88D3;

GL_MATRIX20_ARB = $88D4;

GL_MATRIX21_ARB = $88D5;

GL_MATRIX22_ARB = $88D6;

GL_MATRIX23_ARB = $88D7;

GL_MATRIX24_ARB = $88D8;

GL_MATRIX25_ARB = $88D9;

GL_MATRIX26_ARB = $88DA;

GL_MATRIX27_ARB = $88DB;

GL_MATRIX28_ARB = $88DC;

GL_MATRIX29_ARB = $88DD;

GL_MATRIX30_ARB = $88DE;

GL_MATRIX31_ARB = $88DF;

GL_FRAGMENT_PROGRAM_ARB = $8804;

GL_PROGRAM_ALU_INSTRUCTIONS_ARB = $8805;

GL_PROGRAM_TEX_INSTRUCTIONS_ARB = $8806;

GL_PROGRAM_TEX_INDIRECTIONS_ARB = $8807;

GL_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB = $8808;

GL_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB = $8809;

GL_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB = $880A;

GL_MAX_PROGRAM_ALU_INSTRUCTIONS_ARB = $880B;

GL_MAX_PROGRAM_TEX_INSTRUCTIONS_ARB = $880C;

GL_MAX_PROGRAM_TEX_INDIRECTIONS_ARB = $880D;

GL_MAX_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB = $880E;

GL_MAX_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB = $880F;

GL_MAX_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB = $8810;

GL_MAX_TEXTURE_COORDS_ARB = $8871;

GL_MAX_TEXTURE_IMAGE_UNITS_ARB = $8872;

GL_BUFFER_SIZE_ARB = $8764;

GL_BUFFER_USAGE_ARB = $8765;

GL_ARRAY_BUFFER_ARB = $8892;

GL_ELEMENT_ARRAY_BUFFER_ARB = $8893;

GL_ARRAY_BUFFER_BINDING_ARB = $8894;

GL_ELEMENT_ARRAY_BUFFER_BINDING_ARB = $8895;

GL_VERTEX_ARRAY_BUFFER_BINDING_ARB = $8896;

GL_NORMAL_ARRAY_BUFFER_BINDING_ARB = $8897;

GL_COLOR_ARRAY_BUFFER_BINDING_ARB = $8898;

GL_INDEX_ARRAY_BUFFER_BINDING_ARB = $8899;

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING_ARB = $889A;

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING_ARB = $889B;

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING_ARB = $889C;

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING_ARB = $889D;

GL_WEIGHT_ARRAY_BUFFER_BINDING_ARB = $889E;

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING_ARB = $889F;

GL_READ_ONLY_ARB = $88B8;

GL_WRITE_ONLY_ARB = $88B9;

GL_READ_WRITE_ARB = $88BA;

GL_BUFFER_ACCESS_ARB = $88BB;

GL_BUFFER_MAPPED_ARB = $88BC;

GL_BUFFER_MAP_POINTER_ARB = $88BD;

GL_STREAM_DRAW_ARB = $88E0;

GL_STREAM_READ_ARB = $88E1;

GL_STREAM_COPY_ARB = $88E2;

GL_STATIC_DRAW_ARB = $88E4;

GL_STATIC_READ_ARB = $88E5;

GL_STATIC_COPY_ARB = $88E6;

GL_DYNAMIC_DRAW_ARB = $88E8;

GL_DYNAMIC_READ_ARB = $88E9;

GL_DYNAMIC_COPY_ARB = $88EA;

GL_QUERY_COUNTER_BITS_ARB = $8864;

GL_CURRENT_QUERY_ARB = $8865;

GL_QUERY_RESULT_ARB = $8866;

GL_QUERY_RESULT_AVAILABLE_ARB = $8867;

GL_SAMPLES_PASSED_ARB = $8914;

GL_PROGRAM_OBJECT_ARB = $8B40;

GL_SHADER_OBJECT_ARB = $8B48;

GL_OBJECT_TYPE_ARB = $8B4E;

GL_OBJECT_SUBTYPE_ARB = $8B4F;

GL_FLOAT_VEC2_ARB = $8B50;

GL_FLOAT_VEC3_ARB = $8B51;

GL_FLOAT_VEC4_ARB = $8B52;

GL_INT_VEC2_ARB = $8B53;

GL_INT_VEC3_ARB = $8B54;

GL_INT_VEC4_ARB = $8B55;

GL_BOOL_ARB = $8B56;

GL_BOOL_VEC2_ARB = $8B57;

GL_BOOL_VEC3_ARB = $8B58;

GL_BOOL_VEC4_ARB = $8B59;

GL_FLOAT_MAT2_ARB = $8B5A;

GL_FLOAT_MAT3_ARB = $8B5B;

GL_FLOAT_MAT4_ARB = $8B5C;

GL_SAMPLER_1D_ARB = $8B5D;

GL_SAMPLER_2D_ARB = $8B5E;

GL_SAMPLER_3D_ARB = $8B5F;

GL_SAMPLER_CUBE_ARB = $8B60;

GL_SAMPLER_1D_SHADOW_ARB = $8B61;

GL_SAMPLER_2D_SHADOW_ARB = $8B62;

GL_SAMPLER_2D_RECT_ARB = $8B63;

GL_SAMPLER_2D_RECT_SHADOW_ARB = $8B64;

GL_OBJECT_DELETE_STATUS_ARB = $8B80;

GL_OBJECT_COMPILE_STATUS_ARB = $8B81;

GL_OBJECT_LINK_STATUS_ARB = $8B82;

GL_OBJECT_VALIDATE_STATUS_ARB = $8B83;

GL_OBJECT_INFO_LOG_LENGTH_ARB = $8B84;

GL_OBJECT_ATTACHED_OBJECTS_ARB = $8B85;

GL_OBJECT_ACTIVE_UNIFORMS_ARB = $8B86;

GL_OBJECT_ACTIVE_UNIFORM_MAX_LENGTH_ARB = $8B87;

GL_OBJECT_SHADER_SOURCE_LENGTH_ARB = $8B88;

GL_VERTEX_SHADER_ARB = $8B31;

GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB = $8B4A;

GL_MAX_VARYING_FLOATS_ARB = $8B4B;

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB = $8B4C;

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB = $8B4D;

GL_OBJECT_ACTIVE_ATTRIBUTES_ARB = $8B89;

GL_OBJECT_ACTIVE_ATTRIBUTE_MAX_LENGTH_ARB = $8B8A;

GL_FRAGMENT_SHADER_ARB = $8B30;

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB = $8B49;

GL_FRAGMENT_SHADER_DERIVATIVE_HINT_ARB = $8B8B;

GL_SHADING_LANGUAGE_VERSION_ARB = $8B8C;

GL_POINT_SPRITE_ARB = $8861;

GL_COORD_REPLACE_ARB = $8862;

GL_MAX_DRAW_BUFFERS_ARB = $8824;

GL_DRAW_BUFFER0_ARB = $8825;

GL_DRAW_BUFFER1_ARB = $8826;

GL_DRAW_BUFFER2_ARB = $8827;

GL_DRAW_BUFFER3_ARB = $8828;

GL_DRAW_BUFFER4_ARB = $8829;

GL_DRAW_BUFFER5_ARB = $882A;

GL_DRAW_BUFFER6_ARB = $882B;

GL_DRAW_BUFFER7_ARB = $882C;

GL_DRAW_BUFFER8_ARB = $882D;

GL_DRAW_BUFFER9_ARB = $882E;

GL_DRAW_BUFFER10_ARB = $882F;

GL_DRAW_BUFFER11_ARB = $8830;

GL_DRAW_BUFFER12_ARB = $8831;

GL_DRAW_BUFFER13_ARB = $8832;

GL_DRAW_BUFFER14_ARB = $8833;

GL_DRAW_BUFFER15_ARB = $8834;

GL_TEXTURE_RECTANGLE_ARB = $84F5;

GL_TEXTURE_BINDING_RECTANGLE_ARB = $84F6;

GL_PROXY_TEXTURE_RECTANGLE_ARB = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE_ARB = $84F8;

GL_RGBA_FLOAT_MODE_ARB = $8820;

GL_CLAMP_VERTEX_COLOR_ARB = $891A;

GL_CLAMP_FRAGMENT_COLOR_ARB = $891B;

GL_CLAMP_READ_COLOR_ARB = $891C;

GL_FIXED_ONLY_ARB = $891D;

WGL_TYPE_RGBA_FLOAT_ARB = $21A0;

GLX_RGBA_FLOAT_TYPE_ARB = $20B9;

GLX_RGBA_FLOAT_BIT_ARB = $00000004;

GL_HALF_FLOAT_ARB = $140B;

GL_TEXTURE_RED_TYPE_ARB = $8C10;

GL_TEXTURE_GREEN_TYPE_ARB = $8C11;

GL_TEXTURE_BLUE_TYPE_ARB = $8C12;

GL_TEXTURE_ALPHA_TYPE_ARB = $8C13;

GL_TEXTURE_LUMINANCE_TYPE_ARB = $8C14;

GL_TEXTURE_INTENSITY_TYPE_ARB = $8C15;

GL_TEXTURE_DEPTH_TYPE_ARB = $8C16;

GL_UNSIGNED_NORMALIZED_ARB = $8C17;

GL_RGBA32F_ARB = $8814;

GL_RGB32F_ARB = $8815;

GL_ALPHA32F_ARB = $8816;

GL_INTENSITY32F_ARB = $8817;

GL_LUMINANCE32F_ARB = $8818;

GL_LUMINANCE_ALPHA32F_ARB = $8819;

GL_RGBA16F_ARB = $881A;

GL_RGB16F_ARB = $881B;

GL_ALPHA16F_ARB = $881C;

GL_INTENSITY16F_ARB = $881D;

GL_LUMINANCE16F_ARB = $881E;

GL_LUMINANCE_ALPHA16F_ARB = $881F;

GL_PIXEL_PACK_BUFFER_ARB = $88EB;

GL_PIXEL_UNPACK_BUFFER_ARB = $88EC;

GL_PIXEL_PACK_BUFFER_BINDING_ARB = $88ED;

GL_PIXEL_UNPACK_BUFFER_BINDING_ARB = $88EF;

GL_DEPTH_COMPONENT32F = $8CAC;

GL_DEPTH32F_STENCIL8 = $8CAD;

GL_FLOAT_32_UNSIGNED_INT_24_8_REV = $8DAD;

GL_INVALID_FRAMEBUFFER_OPERATION = $0506;

GL_FRAMEBUFFER_ATTACHMENT_COLOR_ENCODING = $8210;

GL_FRAMEBUFFER_ATTACHMENT_COMPONENT_TYPE = $8211;

GL_FRAMEBUFFER_ATTACHMENT_RED_SIZE = $8212;

GL_FRAMEBUFFER_ATTACHMENT_GREEN_SIZE = $8213;

GL_FRAMEBUFFER_ATTACHMENT_BLUE_SIZE = $8214;

GL_FRAMEBUFFER_ATTACHMENT_ALPHA_SIZE = $8215;

GL_FRAMEBUFFER_ATTACHMENT_DEPTH_SIZE = $8216;

GL_FRAMEBUFFER_ATTACHMENT_STENCIL_SIZE = $8217;

GL_FRAMEBUFFER_DEFAULT = $8218;

GL_FRAMEBUFFER_UNDEFINED = $8219;

GL_DEPTH_STENCIL_ATTACHMENT = $821A;

GL_INDEX = $8222;

GL_MAX_RENDERBUFFER_SIZE = $84E8;

GL_DEPTH_STENCIL = $84F9;

GL_UNSIGNED_INT_24_8 = $84FA;

GL_DEPTH24_STENCIL8 = $88F0;

GL_TEXTURE_STENCIL_SIZE = $88F1;

GL_TEXTURE_RED_TYPE = $8C10;

GL_TEXTURE_GREEN_TYPE = $8C11;

GL_TEXTURE_BLUE_TYPE = $8C12;

GL_TEXTURE_ALPHA_TYPE = $8C13;

GL_TEXTURE_LUMINANCE_TYPE = $8C14;

GL_TEXTURE_INTENSITY_TYPE = $8C15;

GL_TEXTURE_DEPTH_TYPE = $8C16;

GL_UNSIGNED_NORMALIZED = $8C17;

GL_FRAMEBUFFER_BINDING = $8CA6;

GL_DRAW_FRAMEBUFFER_BINDING = GL_FRAMEBUFFER_BINDING;

GL_RENDERBUFFER_BINDING = $8CA7;

GL_READ_FRAMEBUFFER = $8CA8;

GL_DRAW_FRAMEBUFFER = $8CA9;

GL_READ_FRAMEBUFFER_BINDING = $8CAA;

GL_RENDERBUFFER_SAMPLES = $8CAB;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE = $8CD0;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME = $8CD1;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL = $8CD2;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE = $8CD3;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER = $8CD4;

GL_FRAMEBUFFER_COMPLETE = $8CD5;

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT = $8CD6;

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT = $8CD7;

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER = $8CDB;

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER = $8CDC;

GL_FRAMEBUFFER_UNSUPPORTED = $8CDD;

GL_MAX_COLOR_ATTACHMENTS = $8CDF;

GL_COLOR_ATTACHMENT0 = $8CE0;

GL_COLOR_ATTACHMENT1 = $8CE1;

GL_COLOR_ATTACHMENT2 = $8CE2;

GL_COLOR_ATTACHMENT3 = $8CE3;

GL_COLOR_ATTACHMENT4 = $8CE4;

GL_COLOR_ATTACHMENT5 = $8CE5;

GL_COLOR_ATTACHMENT6 = $8CE6;

GL_COLOR_ATTACHMENT7 = $8CE7;

GL_COLOR_ATTACHMENT8 = $8CE8;

GL_COLOR_ATTACHMENT9 = $8CE9;

GL_COLOR_ATTACHMENT10 = $8CEA;

GL_COLOR_ATTACHMENT11 = $8CEB;

GL_COLOR_ATTACHMENT12 = $8CEC;

GL_COLOR_ATTACHMENT13 = $8CED;

GL_COLOR_ATTACHMENT14 = $8CEE;

GL_COLOR_ATTACHMENT15 = $8CEF;

GL_DEPTH_ATTACHMENT = $8D00;

GL_STENCIL_ATTACHMENT = $8D20;

GL_FRAMEBUFFER = $8D40;

GL_RENDERBUFFER = $8D41;

GL_RENDERBUFFER_WIDTH = $8D42;

GL_RENDERBUFFER_HEIGHT = $8D43;

GL_RENDERBUFFER_INTERNAL_FORMAT = $8D44;

GL_STENCIL_INDEX1 = $8D46;

GL_STENCIL_INDEX4 = $8D47;

GL_STENCIL_INDEX8 = $8D48;

GL_STENCIL_INDEX16 = $8D49;

GL_RENDERBUFFER_RED_SIZE = $8D50;

GL_RENDERBUFFER_GREEN_SIZE = $8D51;

GL_RENDERBUFFER_BLUE_SIZE = $8D52;

GL_RENDERBUFFER_ALPHA_SIZE = $8D53;

GL_RENDERBUFFER_DEPTH_SIZE = $8D54;

GL_RENDERBUFFER_STENCIL_SIZE = $8D55;

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE = $8D56;

GL_MAX_SAMPLES = $8D57;

GLX_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20B2;

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20A9;

GL_FRAMEBUFFER_SRGB = $8DB9;

GL_GEOMETRY_SHADER_ARB = $8DD9;

GL_GEOMETRY_VERTICES_OUT_ARB = $8DDA;

GL_GEOMETRY_INPUT_TYPE_ARB = $8DDB;

GL_GEOMETRY_OUTPUT_TYPE_ARB = $8DDC;

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_ARB = $8C29;

GL_MAX_GEOMETRY_VARYING_COMPONENTS_ARB = $8DDD;

GL_MAX_VERTEX_VARYING_COMPONENTS_ARB = $8DDE;

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_ARB = $8DDF;

GL_MAX_GEOMETRY_OUTPUT_VERTICES_ARB = $8DE0;

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_ARB = $8DE1;

GL_LINES_ADJACENCY_ARB = $A;

GL_LINE_STRIP_ADJACENCY_ARB = $B;

GL_TRIANGLES_ADJACENCY_ARB = $C;

GL_TRIANGLE_STRIP_ADJACENCY_ARB = $D;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_ARB = $8DA8;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_ARB = $8DA9;

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_ARB = $8DA7;

GL_PROGRAM_POINT_SIZE_ARB = $8642;

GL_HALF_FLOAT = $140B;

GL_VERTEX_ATTRIB_ARRAY_DIVISOR_ARB = $88FE;

GL_MAP_READ_BIT = $0001;

GL_MAP_WRITE_BIT = $0002;

GL_MAP_INVALIDATE_RANGE_BIT = $0004;

GL_MAP_INVALIDATE_BUFFER_BIT = $0008;

GL_MAP_FLUSH_EXPLICIT_BIT = $0010;

GL_MAP_UNSYNCHRONIZED_BIT = $0020;

GL_TEXTURE_BUFFER_ARB = $8C2A;

GL_MAX_TEXTURE_BUFFER_SIZE_ARB = $8C2B;

GL_TEXTURE_BINDING_BUFFER_ARB = $8C2C;

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_ARB = $8C2D;

GL_TEXTURE_BUFFER_FORMAT_ARB = $8C2E;

GL_COMPRESSED_RED_RGTC1 = $8DBB;

GL_COMPRESSED_SIGNED_RED_RGTC1 = $8DBC;

GL_COMPRESSED_RG_RGTC2 = $8DBD;

GL_COMPRESSED_SIGNED_RG_RGTC2 = $8DBE;

GL_R8 = $8229;

GL_R16 = $822A;

GL_RG8 = $822B;

GL_RG16 = $822C;

GL_R16F = $822D;

GL_R32F = $822E;

GL_RG16F = $822F;

GL_RG32F = $8230;

GL_R8I = $8231;

GL_R8UI = $8232;

GL_R16I = $8233;

GL_R16UI = $8234;

GL_R32I = $8235;

GL_R32UI = $8236;

GL_RG8I = $8237;

GL_RG8UI = $8238;

GL_RG16I = $8239;

GL_RG16UI = $823A;

GL_RG32I = $823B;

GL_RG32UI = $823C;

GL_RG = $8227;

GL_RG_INTEGER = $8228;

GL_VERTEX_ARRAY_BINDING = $85B5;

WGL_CONTEXT_MAJOR_VERSION_ARB = $2091;

WGL_CONTEXT_MINOR_VERSION_ARB = $2092;

WGL_CONTEXT_LAYER_PLANE_ARB = $2093;

WGL_CONTEXT_FLAGS_ARB = $2094;

WGL_CONTEXT_DEBUG_BIT_ARB = $0001;

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $0002;

ERROR_INVALID_VERSION_ARB = $2095;

WGL_CONTEXT_ES2_PROFILE_BIT_EXT = $0004;

GLX_CONTEXT_MAJOR_VERSION_ARB = $2091;

GLX_CONTEXT_MINOR_VERSION_ARB = $2092;

GLX_CONTEXT_FLAGS_ARB = $2094;

GLX_CONTEXT_DEBUG_BIT_ARB = $00000001;

GLX_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $00000002;

GL_UNIFORM_BUFFER = $8A11;

GL_UNIFORM_BUFFER_BINDING = $8A28;

GL_UNIFORM_BUFFER_START = $8A29;

GL_UNIFORM_BUFFER_SIZE = $8A2A;

GL_MAX_VERTEX_UNIFORM_BLOCKS = $8A2B;

GL_MAX_GEOMETRY_UNIFORM_BLOCKS = $8A2C;

GL_MAX_FRAGMENT_UNIFORM_BLOCKS = $8A2D;

GL_MAX_COMBINED_UNIFORM_BLOCKS = $8A2E;

GL_MAX_UNIFORM_BUFFER_BINDINGS = $8A2F;

GL_MAX_UNIFORM_BLOCK_SIZE = $8A30;

GL_MAX_COMBINED_VERTEX_UNIFORM_COMPONENTS = $8A31;

GL_MAX_COMBINED_GEOMETRY_UNIFORM_COMPONENTS = $8A32;

GL_MAX_COMBINED_FRAGMENT_UNIFORM_COMPONENTS = $8A33;

GL_UNIFORM_BUFFER_OFFSET_ALIGNMENT = $8A34;

GL_ACTIVE_UNIFORM_BLOCK_MAX_NAME_LENGTH = $8A35;

GL_ACTIVE_UNIFORM_BLOCKS = $8A36;

GL_UNIFORM_TYPE = $8A37;

GL_UNIFORM_SIZE = $8A38;

GL_UNIFORM_NAME_LENGTH = $8A39;

GL_UNIFORM_BLOCK_INDEX = $8A3A;

GL_UNIFORM_OFFSET = $8A3B;

GL_UNIFORM_ARRAY_STRIDE = $8A3C;

GL_UNIFORM_MATRIX_STRIDE = $8A3D;

GL_UNIFORM_IS_ROW_MAJOR = $8A3E;

GL_UNIFORM_BLOCK_BINDING = $8A3F;

GL_UNIFORM_BLOCK_DATA_SIZE = $8A40;

GL_UNIFORM_BLOCK_NAME_LENGTH = $8A41;

GL_UNIFORM_BLOCK_ACTIVE_UNIFORMS = $8A42;

GL_UNIFORM_BLOCK_ACTIVE_UNIFORM_INDICES = $8A43;

GL_UNIFORM_BLOCK_REFERENCED_BY_VERTEX_SHADER = $8A44;

GL_UNIFORM_BLOCK_REFERENCED_BY_GEOMETRY_SHADER = $8A45;

GL_UNIFORM_BLOCK_REFERENCED_BY_FRAGMENT_SHADER = $8A46;

GL_INVALID_INDEX = $FFFFFFFF;

GL_COPY_READ_BUFFER = $8F36;

GL_COPY_WRITE_BUFFER = $8F37;

GL_DEPTH_CLAMP = $864F;

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION = $8E4C;

GL_FIRST_VERTEX_CONVENTION = $8E4D;

GL_LAST_VERTEX_CONVENTION = $8E4E;

GL_PROVOKING_VERTEX = $8E4F;

GL_TEXTURE_CUBE_MAP_SEAMLESS = $884F;

GL_MAX_SERVER_WAIT_TIMEOUT = $9111;

GL_OBJECT_TYPE = $9112;

GL_SYNC_CONDITION = $9113;

GL_SYNC_STATUS = $9114;

GL_SYNC_FLAGS = $9115;

GL_SYNC_FENCE = $9116;

GL_SYNC_GPU_COMMANDS_COMPLETE = $9117;

GL_UNSIGNALED = $9118;

GL_SIGNALED = $9119;

GL_ALREADY_SIGNALED = $911A;

GL_TIMEOUT_EXPIRED = $911B;

GL_CONDITION_SATISFIED = $911C;

GL_WAIT_FAILED = $911D;

GL_SYNC_FLUSH_COMMANDS_BIT = $00000001;

GL_TIMEOUT_IGNORED = $FFFFFFFFFFFFFFFF;

GL_SAMPLE_POSITION = $8E50;

GL_SAMPLE_MASK = $8E51;

GL_SAMPLE_MASK_VALUE = $8E52;

GL_MAX_SAMPLE_MASK_WORDS = $8E59;

GL_TEXTURE_2D_MULTISAMPLE = $9100;

GL_PROXY_TEXTURE_2D_MULTISAMPLE = $9101;

GL_TEXTURE_2D_MULTISAMPLE_ARRAY = $9102;

GL_PROXY_TEXTURE_2D_MULTISAMPLE_ARRAY = $9103;

GL_TEXTURE_BINDING_2D_MULTISAMPLE = $9104;

GL_TEXTURE_BINDING_2D_MULTISAMPLE_ARRAY = $9105;

GL_TEXTURE_SAMPLES = $9106;

GL_TEXTURE_FIXED_SAMPLE_LOCATIONS = $9107;

GL_SAMPLER_2D_MULTISAMPLE = $9108;

GL_INT_SAMPLER_2D_MULTISAMPLE = $9109;

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE = $910A;

GL_SAMPLER_2D_MULTISAMPLE_ARRAY = $910B;

GL_INT_SAMPLER_2D_MULTISAMPLE_ARRAY = $910C;

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE_ARRAY = $910D;

GL_MAX_COLOR_TEXTURE_SAMPLES = $910E;

GL_MAX_DEPTH_TEXTURE_SAMPLES = $910F;

GL_MAX_INTEGER_SAMPLES = $9110;

GL_SAMPLE_SHADING_ARB = $8C36;

GL_MIN_SAMPLE_SHADING_VALUE_ARB = $8C37;

GL_TEXTURE_CUBE_MAP_ARRAY_ARB = $9009;

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY_ARB = $900A;

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY_ARB = $900B;

GL_SAMPLER_CUBE_MAP_ARRAY_ARB = $900C;

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW_ARB = $900D;

GL_INT_SAMPLER_CUBE_MAP_ARRAY_ARB = $900E;

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY_ARB = $900F;

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_ARB = $8E5E;

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_ARB = $8E5F;

GL_MAX_PROGRAM_TEXTURE_GATHER_COMPONENTS_ARB = $8F9F;

WGL_CONTEXT_PROFILE_MASK_ARB = $9126;

WGL_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;

ERROR_INVALID_PROFILE_ARB = $2096;

GLX_CONTEXT_PROFILE_MASK_ARB = $9126;

GLX_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;

GLX_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;

GL_SRC1_COLOR = $88F9;

GL_ONE_MINUS_SRC1_COLOR = $88FA;

GL_ONE_MINUS_SRC1_ALPHA = $88FB;

GL_MAX_DUAL_SOURCE_DRAW_BUFFERS = $88FC;

GL_ANY_SAMPLES_PASSED = $8C2F;

GL_SAMPLER_BINDING = $8919;

GL_RGB10_A2UI = $906F;

GL_TEXTURE_SWIZZLE_R = $8E42;

GL_TEXTURE_SWIZZLE_G = $8E43;

GL_TEXTURE_SWIZZLE_B = $8E44;

GL_TEXTURE_SWIZZLE_A = $8E45;

GL_TEXTURE_SWIZZLE_RGBA = $8E46;

GL_TIME_ELAPSED = $88BF;

GL_TIMESTAMP = $8E28;

GL_INT_2_10_10_10_REV = $8D9F;

GL_DRAW_INDIRECT_BUFFER = $8F3F;

GL_DRAW_INDIRECT_BUFFER_BINDING = $8F43;

GL_GEOMETRY_SHADER_INVOCATIONS = $887F;

GL_MAX_GEOMETRY_SHADER_INVOCATIONS = $8E5A;

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET = $8E5B;

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET = $8E5C;

GL_FRAGMENT_INTERPOLATION_OFFSET_BITS = $8E5D;

GL_MAX_VERTEX_STREAMS = $8E71;

GL_DOUBLE_VEC2 = $8FFC;

GL_DOUBLE_VEC3 = $8FFD;

GL_DOUBLE_VEC4 = $8FFE;

GL_DOUBLE_MAT2 = $8F46;

GL_DOUBLE_MAT3 = $8F47;

GL_DOUBLE_MAT4 = $8F48;

GL_DOUBLE_MAT2x3 = $8F49;

GL_DOUBLE_MAT2x4 = $8F4A;

GL_DOUBLE_MAT3x2 = $8F4B;

GL_DOUBLE_MAT3x4 = $8F4C;

GL_DOUBLE_MAT4x2 = $8F4D;

GL_DOUBLE_MAT4x3 = $8F4E;

GL_ACTIVE_SUBROUTINES = $8DE5;

GL_ACTIVE_SUBROUTINE_UNIFORMS = $8DE6;

GL_ACTIVE_SUBROUTINE_UNIFORM_LOCATIONS = $8E47;

GL_ACTIVE_SUBROUTINE_MAX_LENGTH = $8E48;

GL_ACTIVE_SUBROUTINE_UNIFORM_MAX_LENGTH = $8E49;

GL_MAX_SUBROUTINES = $8DE7;

GL_MAX_SUBROUTINE_UNIFORM_LOCATIONS = $8DE8;

GL_NUM_COMPATIBLE_SUBROUTINES = $8E4A;

GL_COMPATIBLE_SUBROUTINES = $8E4B;

GL_PATCHES = $000E;

GL_PATCH_VERTICES = $8E72;

GL_PATCH_DEFAULT_INNER_LEVEL = $8E73;

GL_PATCH_DEFAULT_OUTER_LEVEL = $8E74;

GL_TESS_CONTROL_OUTPUT_VERTICES = $8E75;

GL_TESS_GEN_MODE = $8E76;

GL_TESS_GEN_SPACING = $8E77;

GL_TESS_GEN_VERTEX_ORDER = $8E78;

GL_TESS_GEN_POINT_MODE = $8E79;

GL_ISOLINES = $8E7A;

GL_FRACTIONAL_ODD = $8E7B;

GL_FRACTIONAL_EVEN = $8E7C;

GL_MAX_PATCH_VERTICES = $8E7D;

GL_MAX_TESS_GEN_LEVEL = $8E7E;

GL_MAX_TESS_CONTROL_UNIFORM_COMPONENTS = $8E7F;

GL_MAX_TESS_EVALUATION_UNIFORM_COMPONENTS = $8E80;

GL_MAX_TESS_CONTROL_TEXTURE_IMAGE_UNITS = $8E81;

GL_MAX_TESS_EVALUATION_TEXTURE_IMAGE_UNITS = $8E82;

GL_MAX_TESS_CONTROL_OUTPUT_COMPONENTS = $8E83;

GL_MAX_TESS_PATCH_COMPONENTS = $8E84;

GL_MAX_TESS_CONTROL_TOTAL_OUTPUT_COMPONENTS = $8E85;

GL_MAX_TESS_EVALUATION_OUTPUT_COMPONENTS = $8E86;

GL_MAX_TESS_CONTROL_UNIFORM_BLOCKS = $8E89;

GL_MAX_TESS_EVALUATION_UNIFORM_BLOCKS = $8E8A;

GL_MAX_TESS_CONTROL_INPUT_COMPONENTS = $886C;

GL_MAX_TESS_EVALUATION_INPUT_COMPONENTS = $886D;

GL_MAX_COMBINED_TESS_CONTROL_UNIFORM_COMPONENTS = $8E1E;

GL_MAX_COMBINED_TESS_EVALUATION_UNIFORM_COMPONENTS = $8E1F;

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_CONTROL_SHADER = $84F0;

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_EVALUATION_SHADER = $84F1;

GL_TESS_EVALUATION_SHADER = $8E87;

GL_TESS_CONTROL_SHADER = $8E88;

GL_TRANSFORM_FEEDBACK = $8E22;

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED = $8E23;

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE = $8E24;

GL_TRANSFORM_FEEDBACK_BINDING = $8E25;

GL_MAX_TRANSFORM_FEEDBACK_BUFFERS = $8E70;

GL_FIXED = $140C;

GL_IMPLEMENTATION_COLOR_READ_TYPE = $8B9A;

GL_IMPLEMENTATION_COLOR_READ_FORMAT = $8B9B;

GL_LOW_FLOAT = $8DF0;

GL_MEDIUM_FLOAT = $8DF1;

GL_HIGH_FLOAT = $8DF2;

GL_LOW_INT = $8DF3;

GL_MEDIUM_INT = $8DF4;

GL_HIGH_INT = $8DF5;

GL_SHADER_COMPILER = $8DFA;

GL_NUM_SHADER_BINARY_FORMATS = $8DF9;

GL_MAX_VERTEX_UNIFORM_VECTORS = $8DFB;

GL_MAX_VARYING_VECTORS = $8DFC;

GL_MAX_FRAGMENT_UNIFORM_VECTORS = $8DFD;

GL_PROGRAM_BINARY_RETRIEVABLE_HINT = $8257;

GL_PROGRAM_BINARY_LENGTH = $8741;

GL_NUM_PROGRAM_BINARY_FORMATS = $87FE;

GL_PROGRAM_BINARY_FORMATS = $87FF;

GL_VERTEX_SHADER_BIT = $00000001;

GL_FRAGMENT_SHADER_BIT = $00000002;

GL_GEOMETRY_SHADER_BIT = $00000004;

GL_TESS_CONTROL_SHADER_BIT = $00000008;

GL_TESS_EVALUATION_SHADER_BIT = $00000010;

GL_ALL_SHADER_BITS = $FFFFFFFF;

GL_PROGRAM_SEPARABLE = $8258;

GL_ACTIVE_PROGRAM = $8259;

GL_PROGRAM_PIPELINE_BINDING = $825A;

GL_MAX_VIEWPORTS = $825B;

GL_VIEWPORT_SUBPIXEL_BITS = $825C;

GL_VIEWPORT_BOUNDS_RANGE = $825D;

GL_LAYER_PROVOKING_VERTEX = $825E;

GL_VIEWPORT_INDEX_PROVOKING_VERTEX = $825F;

GL_UNDEFINED_VERTEX = $8260;

GL_DEBUG_OUTPUT_SYNCHRONOUS_ARB = $8242;

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH_ARB = $8243;

GL_DEBUG_CALLBACK_FUNCTION_ARB = $8244;

GL_DEBUG_CALLBACK_USER_PARAM_ARB = $8245;

GL_DEBUG_SOURCE_API_ARB = $8246;

GL_DEBUG_SOURCE_WINDOW_SYSTEM_ARB = $8247;

GL_DEBUG_SOURCE_SHADER_COMPILER_ARB = $8248;

GL_DEBUG_SOURCE_THIRD_PARTY_ARB = $8249;

GL_DEBUG_SOURCE_APPLICATION_ARB = $824A;

GL_DEBUG_SOURCE_OTHER_ARB = $824B;

GL_DEBUG_TYPE_ERROR_ARB = $824C;

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR_ARB = $824D;

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR_ARB = $824E;

GL_DEBUG_TYPE_PORTABILITY_ARB = $824F;

GL_DEBUG_TYPE_PERFORMANCE_ARB = $8250;

GL_DEBUG_TYPE_OTHER_ARB = $8251;

GL_MAX_DEBUG_MESSAGE_LENGTH_ARB = $9143;

GL_MAX_DEBUG_LOGGED_MESSAGES_ARB = $9144;

GL_DEBUG_LOGGED_MESSAGES_ARB = $9145;

GL_DEBUG_SEVERITY_HIGH_ARB = $9146;

GL_DEBUG_SEVERITY_MEDIUM_ARB = $9147;

GL_DEBUG_SEVERITY_LOW_ARB = $9148;

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT_ARB = $00000004;

GL_LOSE_CONTEXT_ON_RESET_ARB = $8252;

GL_GUILTY_CONTEXT_RESET_ARB = $8253;

GL_INNOCENT_CONTEXT_RESET_ARB = $8254;

GL_UNKNOWN_CONTEXT_RESET_ARB = $8255;

GL_RESET_NOTIFICATION_STRATEGY_ARB = $8256;

GL_NO_RESET_NOTIFICATION_ARB = $8261;

GL_TEXTURE_RECTANGLE_EXT = $84F5;

GL_TEXTURE_BINDING_RECTANGLE_EXT = $84F6;

GL_PROXY_TEXTURE_RECTANGLE_EXT = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE_EXT = $84F8;

GLX_BIND_TO_TEXTURE_RGB_EXT = $20D0;

GLX_BIND_TO_TEXTURE_RGBA_EXT = $20D1;

GLX_BIND_TO_MIPMAP_TEXTURE_EXT = $20D2;

GLX_BIND_TO_TEXTURE_TARGETS_EXT = $20D3;

GLX_Y_INVERTED_EXT = $20D4;

GLX_TEXTURE_FORMAT_EXT = $20D5;

GLX_TEXTURE_TARGET_EXT = $20D6;

GLX_MIPMAP_TEXTURE_EXT = $20D7;

GLX_TEXTURE_FORMAT_NONE_EXT = $20D8;

GLX_TEXTURE_FORMAT_RGB_EXT = $20D9;

GLX_TEXTURE_FORMAT_RGBA_EXT = $20DA;

GLX_TEXTURE_1D_EXT = $20DB;

GLX_TEXTURE_2D_EXT = $20DC;

GLX_TEXTURE_RECTANGLE_EXT = $20DD;

GLX_FRONT_LEFT_EXT = $20DE;

GLX_FRONT_RIGHT_EXT = $20DF;

GLX_BACK_LEFT_EXT = $20E0;

GLX_BACK_RIGHT_EXT = $20E1;

GLX_FRONT_EXT = GLX_FRONT_LEFT_EXT;

GLX_BACK_EXT = GLX_BACK_LEFT_EXT;

GLX_AUX0_EXT = $20E2;

GLX_AUX1_EXT = $20E3;

GLX_AUX2_EXT = $20E4;

GLX_AUX3_EXT = 420E5;

GLX_AUX4_EXT = $20E6;

GLX_AUX5_EXT = $20E7;

GLX_AUX6_EXT = $20E8;

GLX_AUX7_EXT = $20E9;

GLX_AUX8_EXT = $20EA;

GLX_AUX9_EXT = $20EB;

GL_ABGR_EXT = $8000;

GL_CONSTANT_COLOR_EXT = $8001;

GL_ONE_MINUS_CONSTANT_COLOR_EXT = $8002;

GL_CONSTANT_ALPHA_EXT = $8003;

GL_ONE_MINUS_CONSTANT_ALPHA_EXT = $8004;

GL_BLEND_COLOR_EXT = $8005;

GL_POLYGON_OFFSET_EXT = $8037;

GL_POLYGON_OFFSET_FACTOR_EXT = $8038;

GL_POLYGON_OFFSET_BIAS_EXT = $8039;

GL_ALPHA4_EXT = $803B;

GL_ALPHA8_EXT = $803C;

GL_ALPHA12_EXT = $803D;

GL_ALPHA16_EXT = $803E;

GL_LUMINANCE4_EXT = $803F;

GL_LUMINANCE8_EXT = $8040;

GL_LUMINANCE12_EXT = $8041;

GL_LUMINANCE16_EXT = $8042;

GL_LUMINANCE4_ALPHA4_EXT = $8043;

GL_LUMINANCE6_ALPHA2_EXT = $8044;

GL_LUMINANCE8_ALPHA8_EXT = $8045;

GL_LUMINANCE12_ALPHA4_EXT = $8046;

GL_LUMINANCE12_ALPHA12_EXT = $8047;

GL_LUMINANCE16_ALPHA16_EXT = $8048;

GL_INTENSITY_EXT = $8049;

GL_INTENSITY4_EXT = $804A;

GL_INTENSITY8_EXT = $804B;

GL_INTENSITY12_EXT = $804C;

GL_INTENSITY16_EXT = $804D;

GL_RGB2_EXT = $804E;

GL_RGB4_EXT = $804F;

GL_RGB5_EXT = $8050;

GL_RGB8_EXT = $8051;

GL_RGB10_EXT = $8052;

GL_RGB12_EXT = $8053;

GL_RGB16_EXT = $8054;

GL_RGBA2_EXT = $8055;

GL_RGBA4_EXT = $8056;

GL_RGB5_A1_EXT = $8057;

GL_RGBA8_EXT = $8058;

GL_RGB10_A2_EXT = $8059;

GL_RGBA12_EXT = $805A;

GL_RGBA16_EXT = $805B;

GL_TEXTURE_RED_SIZE_EXT = $805C;

GL_TEXTURE_GREEN_SIZE_EXT = $805D;

GL_TEXTURE_BLUE_SIZE_EXT = $805E;

GL_TEXTURE_ALPHA_SIZE_EXT = $805F;

GL_TEXTURE_LUMINANCE_SIZE_EXT = $8060;

GL_TEXTURE_INTENSITY_SIZE_EXT = $8061;

GL_REPLACE_EXT = $8062;

GL_PROXY_TEXTURE_1D_EXT = $8063;

GL_PROXY_TEXTURE_2D_EXT = $8064;

GL_TEXTURE_TOO_LARGE_EXT = $8065;

GL_RGB_S3TC = $83A0;

GL_RGB4_S3TC = $83A1;

GL_RGBA_S3TC = $83A2;

GL_RGBA4_S3TC = $83A3;

GL_RGBA_DXT5_S3TC = $83A4;

GL_RGBA4_DXT5_S3TC = $83A5;

GL_PACK_SKIP_IMAGES_EXT = $806B;

GL_PACK_IMAGE_HEIGHT_EXT = $806C;

GL_UNPACK_SKIP_IMAGES_EXT = $806D;

GL_UNPACK_IMAGE_HEIGHT_EXT = $806E;

GL_TEXTURE_3D_EXT = $806F;

GL_PROXY_TEXTURE_3D_EXT = $8070;

GL_TEXTURE_DEPTH_EXT = $8071;

GL_TEXTURE_WRAP_R_EXT = $8072;

GL_MAX_3D_TEXTURE_SIZE_EXT = $8073;

GL_HISTOGRAM_EXT = $8024;

GL_PROXY_HISTOGRAM_EXT = $8025;

GL_HISTOGRAM_WIDTH_EXT = $8026;

GL_HISTOGRAM_FORMAT_EXT = $8027;

GL_HISTOGRAM_RED_SIZE_EXT = $8028;

GL_HISTOGRAM_GREEN_SIZE_EXT = $8029;

GL_HISTOGRAM_BLUE_SIZE_EXT = $802A;

GL_HISTOGRAM_ALPHA_SIZE_EXT = $802B;

GL_HISTOGRAM_LUMINANCE_SIZE_EXT = $802C;

GL_HISTOGRAM_SINK_EXT = $802D;

GL_MINMAX_EXT = $802E;

GL_MINMAX_FORMAT_EXT = $802F;

GL_MINMAX_SINK_EXT = $8030;

GL_CONVOLUTION_1D_EXT = $8010;

GL_CONVOLUTION_2D_EXT = $8011;

GL_SEPARABLE_2D_EXT = $8012;

GL_CONVOLUTION_BORDER_MODE_EXT = $8013;

GL_CONVOLUTION_FILTER_SCALE_EXT = $8014;

GL_CONVOLUTION_FILTER_BIAS_EXT = $8015;

GL_REDUCE_EXT = $8016;

GL_CONVOLUTION_FORMAT_EXT = $8017;

GL_CONVOLUTION_WIDTH_EXT = $8018;

GL_CONVOLUTION_HEIGHT_EXT = $8019;

GL_MAX_CONVOLUTION_WIDTH_EXT = $801A;

GL_MAX_CONVOLUTION_HEIGHT_EXT = $801B;

GL_POST_CONVOLUTION_RED_SCALE_EXT = $801C;

GL_POST_CONVOLUTION_GREEN_SCALE_EXT = $801D;

GL_POST_CONVOLUTION_BLUE_SCALE_EXT = $801E;

GL_POST_CONVOLUTION_ALPHA_SCALE_EXT = $801F;

GL_POST_CONVOLUTION_RED_BIAS_EXT = $8020;

GL_POST_CONVOLUTION_GREEN_BIAS_EXT = $8021;

GL_POST_CONVOLUTION_BLUE_BIAS_EXT = $8022;

GL_POST_CONVOLUTION_ALPHA_BIAS_EXT = $8023;

GL_COLOR_MATRIX_SGI = $80B1;

GL_COLOR_MATRIX_STACK_DEPTH_SGI = $80B2;

GL_MAX_COLOR_MATRIX_STACK_DEPTH_SGI = $80B3;

GL_POST_COLOR_MATRIX_RED_SCALE_SGI = $80B4;

GL_POST_COLOR_MATRIX_GREEN_SCALE_SGI = $80B5;

GL_POST_COLOR_MATRIX_BLUE_SCALE_SGI = $80B6;

GL_POST_COLOR_MATRIX_ALPHA_SCALE_SGI = $80B7;

GL_POST_COLOR_MATRIX_RED_BIAS_SGI = $80B8;

GL_POST_COLOR_MATRIX_GREEN_BIAS_SGI = $80B9;

GL_POST_COLOR_MATRIX_BLUE_BIAS_SGI = $80BA;

GL_POST_COLOR_MATRIX_ALPHA_BIAS_SGI = $80BB;

GL_TEXTURE_PRIORITY_EXT = $8066;

GL_TEXTURE_RESIDENT_EXT = $8067;

GL_TEXTURE_1D_BINDING_EXT = $8068;

GL_TEXTURE_2D_BINDING_EXT = $8069;

GL_TEXTURE_3D_BINDING_EXT = $806A;

GL_UNSIGNED_BYTE_3_3_2_EXT = $8032;

GL_UNSIGNED_SHORT_4_4_4_4_EXT = $8033;

GL_UNSIGNED_SHORT_5_5_5_1_EXT = $8034;

GL_UNSIGNED_INT_8_8_8_8_EXT = $8035;

GL_UNSIGNED_INT_10_10_10_2_EXT = $8036;

GL_TEXTURE_MIN_LOD_SGIS = $813A;

GL_TEXTURE_MAX_LOD_SGIS = $813B;

GL_TEXTURE_BASE_LEVEL_SGIS = $813C;

GL_TEXTURE_MAX_LEVEL_SGIS = $813D;

GL_MULTISAMPLE_SGIS = $809D;

GL_SAMPLE_ALPHA_TO_MASK_SGIS = $809E;

GL_SAMPLE_ALPHA_TO_ONE_SGIS = $809F;

GL_SAMPLE_MASK_SGIS = $80A0;

GL_1PASS_SGIS = $80A1;

GL_2PASS_0_SGIS = $80A2;

GL_2PASS_1_SGIS = $80A3;

GL_4PASS_0_SGIS = $80A4;

GL_4PASS_1_SGIS = $80A5;

GL_4PASS_2_SGIS = $80A6;

GL_4PASS_3_SGIS = $80A7;

GL_SAMPLE_BUFFERS_SGIS = $80A8;

GL_SAMPLES_SGIS = $80A9;

GL_SAMPLE_MASK_VALUE_SGIS = $80AA;

GL_SAMPLE_MASK_INVERT_SGIS = $80AB;

GL_SAMPLE_PATTERN_SGIS = $80AC;

GL_RESCALE_NORMAL_EXT = $803A;

GL_GENERATE_MIPMAP_SGIS = $8191;

GL_GENERATE_MIPMAP_HINT_SGIS = $8192;

GL_TEXTURE_COMPARE_SGIX = $819A;

GL_TEXTURE_COMPARE_OPERATOR_SGIX = $819B;

GL_TEXTURE_LEQUAL_R_SGIX = $819C;

GL_TEXTURE_GEQUAL_R_SGIX = $819D;

GL_CLAMP_TO_EDGE_SGIS = $812F;

GL_CLAMP_TO_BORDER_SGIS = $812D;

GL_FUNC_ADD_EXT = $8006;

GL_MIN_EXT = $8007;

GL_MAX_EXT = $8008;

GL_BLEND_EQUATION_EXT = $8009;

GL_FUNC_SUBTRACT_EXT = $800A;

GL_FUNC_REVERSE_SUBTRACT_EXT = $800B;

GLU_OBJECT_PARAMETRIC_ERROR_EXT = 100208;

GLU_OBJECT_PATH_LENGTH_EXT = 100209;

GL_COLOR_INDEX1_EXT = $80E2;

GL_COLOR_INDEX2_EXT = $80E3;

GL_COLOR_INDEX4_EXT = $80E4;

GL_COLOR_INDEX8_EXT = $80E5;

GL_COLOR_INDEX12_EXT = $80E6;

GL_COLOR_INDEX16_EXT = $80E7;

GL_TEXTURE_INDEX_SIZE_EXT = $80ED;

GL_CLIP_VOLUME_CLIPPING_HINT_EXT = $80F0;

GL_SHADOW_AMBIENT_SGIX = $80BF;

GL_ARRAY_ELEMENT_LOCK_FIRST_EXT = $81A8;

GL_ARRAY_ELEMENT_LOCK_COUNT_EXT = $81A9;

GLU_NURBS_MODE_EXT = 100160;

GLU_NURBS_TESSELLATOR_EXT = 100161;

GLU_NURBS_RENDERER_EXT = 100162;

GLU_NURBS_BEGIN_EXT = 100164;

GLU_NURBS_VERTEX_EXT = 100165;

GLU_NURBS_NORMAL_EXT = 100166;

GLU_NURBS_COLOR_EXT = 100167;

GLU_NURBS_TEX_COORD_EXT = 100168;

GLU_NURBS_END_EXT = 100169;

GLU_NURBS_BEGIN_DATA_EXT = 100170;

GLU_NURBS_VERTEX_DATA_EXT = 100171;

GLU_NURBS_NORMAL_DATA_EXT = 100172;

GLU_NURBS_COLOR_DATA_EXT = 100173;

GLU_NURBS_TEX_COORD_DATA_EXT = 100174;

GLU_NURBS_END_DATA_EXT = 100175;

GL_RASTER_POSITION_UNCLIPPED_IBM = $19262;

GL_MAX_ELEMENTS_VERTICES_EXT = $80E8;

GL_MAX_ELEMENTS_INDICES_EXT = $80E9;

GL_BGR_EXT = $80E0;

GL_BGRA_EXT = $80E1;

GL_OCCLUSION_TEST_HP = $8165;

GL_OCCLUSION_TEST_RESULT_HP = $8166;

GL_SHARED_TEXTURE_PALETTE_EXT = $81FB;

GL_LIGHT_MODEL_COLOR_CONTROL_EXT = $81F8;

GL_SINGLE_COLOR_EXT = $81F9;

GL_SEPARATE_SPECULAR_COLOR_EXT = $81FA;

GL_COLOR_SUM_EXT = $8458;

GL_CURRENT_SECONDARY_COLOR_EXT = $8459;

GL_SECONDARY_COLOR_ARRAY_SIZE_EXT = $845A;

GL_SECONDARY_COLOR_ARRAY_TYPE_EXT = $845B;

GL_SECONDARY_COLOR_ARRAY_STRIDE_EXT = $845C;

GL_SECONDARY_COLOR_ARRAY_POINTER_EXT = $845D;

GL_SECONDARY_COLOR_ARRAY_EXT = $845E;

GL_FOG_COORDINATE_SOURCE_EXT = $8450;

GL_FOG_COORDINATE_EXT = $8451;

GL_FRAGMENT_DEPTH_EXT = $8452;

GL_CURRENT_FOG_COORDINATE_EXT = $8453;

GL_FOG_COORDINATE_ARRAY_TYPE_EXT = $8454;

GL_FOG_COORDINATE_ARRAY_STRIDE_EXT = $8455;

GL_FOG_COORDINATE_ARRAY_POINTER_EXT = $8456;

GL_FOG_COORDINATE_ARRAY_EXT = $8457;

GL_COMBINE_EXT = $8570;

GL_COMBINE_RGB_EXT = $8571;

GL_COMBINE_ALPHA_EXT = $8572;

GL_RGB_SCALE_EXT = $8573;

GL_ADD_SIGNED_EXT = $8574;

GL_INTERPOLATE_EXT = $8575;

GL_CONSTANT_EXT = $8576;

GL_PRIMARY_COLOR_EXT = $8577;

GL_PREVIOUS_EXT = $8578;

GL_SOURCE0_RGB_EXT = $8580;

GL_SOURCE1_RGB_EXT = $8581;

GL_SOURCE2_RGB_EXT = $8582;

GL_SOURCE0_ALPHA_EXT = $8588;

GL_SOURCE1_ALPHA_EXT = $8589;

GL_SOURCE2_ALPHA_EXT = $858A;

GL_OPERAND0_RGB_EXT = $8590;

GL_OPERAND1_RGB_EXT = $8591;

GL_OPERAND2_RGB_EXT = $8592;

GL_OPERAND0_ALPHA_EXT = $8598;

GL_OPERAND1_ALPHA_EXT = $8599;

GL_OPERAND2_ALPHA_EXT = $859A;

GL_SOURCE3_RGB_EXT = $8583;

GL_SOURCE4_RGB_EXT = $8584;

GL_SOURCE5_RGB_EXT = $8585;

GL_SOURCE6_RGB_EXT = $8586;

GL_SOURCE7_RGB_EXT = $8587;

GL_SOURCE3_ALPHA_EXT = $858B;

GL_SOURCE4_ALPHA_EXT = $858C;

GL_SOURCE5_ALPHA_EXT = $858D;

GL_SOURCE6_ALPHA_EXT = $858E;

GL_SOURCE7_ALPHA_EXT = $858F;

GL_OPERAND3_RGB_EXT = $8593;

GL_OPERAND4_RGB_EXT = $8594;

GL_OPERAND5_RGB_EXT = $8595;

GL_OPERAND6_RGB_EXT = $8596;

GL_OPERAND7_RGB_EXT = $8597;

GL_OPERAND3_ALPHA_EXT = $859B;

GL_OPERAND4_ALPHA_EXT = $859C;

GL_OPERAND5_ALPHA_EXT = $859D;

GL_OPERAND6_ALPHA_EXT = $859E;

GL_OPERAND7_ALPHA_EXT = $859F;

GL_BLEND_DST_RGB_EXT = $80C8;

GL_BLEND_SRC_RGB_EXT = $80C9;

GL_BLEND_DST_ALPHA_EXT = $80CA;

GL_BLEND_SRC_ALPHA_EXT = $80CB;

GL_NORMAL_MAP_EXT = $8511;

GL_REFLECTION_MAP_EXT = $8512;

GL_TEXTURE_CUBE_MAP_EXT = $8513;

GL_TEXTURE_BINDING_CUBE_MAP_EXT = $8514;

GL_TEXTURE_CUBE_MAP_POSITIVE_X_EXT = $8515;

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_EXT = $8516;

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_EXT = $8517;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_EXT = $8518;

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_EXT = $8519;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_EXT = $851A;

GL_PROXY_TEXTURE_CUBE_MAP_EXT = $851B;

GL_MAX_CUBE_MAP_TEXTURE_SIZE_EXT = $851C;

GL_INCR_WRAP_EXT = $8507;

GL_DECR_WRAP_EXT = $8508;

GL_NORMAL_MAP_NV = $8511;

GL_REFLECTION_MAP_NV = $8512;

GL_MAX_TEXTURE_LOD_BIAS_EXT = $84FD;

GL_TEXTURE_FILTER_CONTROL_EXT = $8500;

GL_TEXTURE_LOD_BIAS_EXT = $8501;

GL_TEXTURE_MAX_ANISOTROPY_EXT = $84FE;

GL_MAX_TEXTURE_MAX_ANISOTROPY_EXT = $84FF;

GL_MAX_SHININESS_NV = $8504;

GL_MAX_SPOT_EXPONENT_NV = $8505;

GL_VERTEX_ARRAY_RANGE_NV = $851D;

GL_VERTEX_ARRAY_RANGE_LENGTH_NV = $851E;

GL_VERTEX_ARRAY_RANGE_VALID_NV = $851F;

GL_MAX_VERTEX_ARRAY_RANGE_ELEMENT_NV = $8520;

GL_VERTEX_ARRAY_RANGE_POINTER_NV = $8521;

GL_REGISTER_COMBINERS_NV = $8522;

GL_VARIABLE_A_NV = $8523;

GL_VARIABLE_B_NV = $8524;

GL_VARIABLE_C_NV = $8525;

GL_VARIABLE_D_NV = $8526;

GL_VARIABLE_E_NV = $8527;

GL_VARIABLE_F_NV = $8528;

GL_VARIABLE_G_NV = $8529;

GL_CONSTANT_COLOR0_NV = $852A;

GL_CONSTANT_COLOR1_NV = $852B;

GL_PRIMARY_COLOR_NV = $852C;

GL_SECONDARY_COLOR_NV = $852D;

GL_SPARE0_NV = $852E;

GL_SPARE1_NV = $852F;

GL_DISCARD_NV = $8530;

GL_E_TIMES_F_NV = $8531;

GL_SPARE0_PLUS_SECONDARY_COLOR_NV = $8532;

GL_UNSIGNED_IDENTITY_NV = $8536;

GL_UNSIGNED_INVERT_NV = $8537;

GL_EXPAND_NORMAL_NV = $8538;

GL_EXPAND_NEGATE_NV = $8539;

GL_HALF_BIAS_NORMAL_NV = $853A;

GL_HALF_BIAS_NEGATE_NV = $853B;

GL_SIGNED_IDENTITY_NV = $853C;

GL_SIGNED_NEGATE_NV = $853D;

GL_SCALE_BY_TWO_NV = $853E;

GL_SCALE_BY_FOUR_NV = $853F;

GL_SCALE_BY_ONE_HALF_NV = $8540;

GL_BIAS_BY_NEGATIVE_ONE_HALF_NV = $8541;

GL_COMBINER_INPUT_NV = $8542;

GL_COMBINER_MAPPING_NV = $8543;

GL_COMBINER_COMPONENT_USAGE_NV = $8544;

GL_COMBINER_AB_DOT_PRODUCT_NV = $8545;

GL_COMBINER_CD_DOT_PRODUCT_NV = $8546;

GL_COMBINER_MUX_SUM_NV = $8547;

GL_COMBINER_SCALE_NV = $8548;

GL_COMBINER_BIAS_NV = $8549;

GL_COMBINER_AB_OUTPUT_NV = $854A;

GL_COMBINER_CD_OUTPUT_NV = $854B;

GL_COMBINER_SUM_OUTPUT_NV = $854C;

GL_MAX_GENERAL_COMBINERS_NV = $854D;

GL_NUM_GENERAL_COMBINERS_NV = $854E;

GL_COLOR_SUM_CLAMP_NV = $854F;

GL_COMBINER0_NV = $8550;

GL_COMBINER1_NV = $8551;

GL_COMBINER2_NV = $8552;

GL_COMBINER3_NV = $8553;

GL_COMBINER4_NV = $8554;

GL_COMBINER5_NV = $8555;

GL_COMBINER6_NV = $8556;

GL_COMBINER7_NV = $8557;

GLX_VIDEO_OUT_COLOR_NV = $20C3;

GLX_VIDEO_OUT_ALPHA_NV = $20C4;

GLX_VIDEO_OUT_DEPTH_NV = $20C5;

GLX_VIDEO_OUT_COLOR_AND_ALPHA_NV = $20C6;

GLX_VIDEO_OUT_COLOR_AND_DEPTH_NV = $20C7;

GLX_VIDEO_OUT_FRAME_NV = $20C8;

GLX_VIDEO_OUT_FIELD_1_NV = $20C9;

GLX_VIDEO_OUT_FIELD_2_NV = $20CA;

GLX_VIDEO_OUT_STACKED_FIELDS_1_2_NV = $20CB;

GLX_VIDEO_OUT_STACKED_FIELDS_2_1_NV = $20CC;

GLX_NUM_VIDEO_SLOTS_NV = $20F0;

GLX_SWAP_INTERVAL_EXT = $20F1;

GLX_MAX_SWAP_INTERVAL_EXT = $20F2;

GLX_DEVICE_ID_NV = $20CD;

GLX_UNIQUE_ID_NV = $20CE;

GLX_NUM_VIDEO_CAPTURE_SLOTS_NV = $20CF;

GL_FOG_DISTANCE_MODE_NV = $855A;

GL_EYE_RADIAL_NV = $855B;

GL_EYE_PLANE_ABSOLUTE_NV = $855C;

GL_COMBINE4_NV = $8503;

GL_SOURCE3_RGB_NV = $8583;

GL_SOURCE3_ALPHA_NV = $858B;

GL_OPERAND3_RGB_NV = $8593;

GL_OPERAND3_ALPHA_NV = $859B;

GL_COMPRESSED_RGB_S3TC_DXT1_EXT = $83F0;

GL_COMPRESSED_RGBA_S3TC_DXT1_EXT = $83F1;

GL_COMPRESSED_RGBA_S3TC_DXT3_EXT = $83F2;

GL_COMPRESSED_RGBA_S3TC_DXT5_EXT = $83F3;

GL_COMPRESSED_RGB_FXT1_3DFX = $86B0;

GL_COMPRESSED_RGBA_FXT1_3DFX = $86B1;

GL_MULTISAMPLE_3DFX = $86B2;

GL_SAMPLE_BUFFERS_3DFX = $86B3;

GL_SAMPLES_3DFX = $86B4;

GL_MULTISAMPLE_BIT_3DFX = $20000000;

GL_MULTISAMPLE_EXT = $809D;

GL_SAMPLE_ALPHA_TO_MASK_EXT = $809E;

GL_SAMPLE_ALPHA_TO_ONE_EXT = $809F;

GL_SAMPLE_MASK_EXT = $80A0;

GL_1PASS_EXT = $80A1;

GL_2PASS_0_EXT = $80A2;

GL_2PASS_1_EXT = $80A3;

GL_4PASS_0_EXT = $80A4;

GL_4PASS_1_EXT = $80A5;

GL_4PASS_2_EXT = $80A6;

GL_4PASS_3_EXT = $80A7;

GL_SAMPLE_BUFFERS_EXT = $80A8;

GL_SAMPLES_EXT = $80A9;

GL_SAMPLE_MASK_VALUE_EXT = $80AA;

GL_SAMPLE_MASK_INVERT_EXT = $80AB;

GL_SAMPLE_PATTERN_EXT = $80AC;

WGL_SAMPLE_BUFFERS_EXT = $2041;

WGL_SAMPLES_EXT = $2042;

GL_TEXTURE_COLOR_WRITEMASK_SGIS = $81EF;

GL_DOT3_RGB_EXT = $8740;

GL_DOT3_RGBA_EXT = $8741;

GL_MIRROR_CLAMP_ATI = $8742;

GL_MIRROR_CLAMP_TO_EDGE_ATI = $8743;

GL_ALL_COMPLETED_NV = $84F2;

GL_FENCE_STATUS_NV = $84F3;

GL_FENCE_CONDITION_NV = $84F4;

GL_TEXTURE_RECTANGLE_NV = $84F5;

GL_TEXTURE_BINDING_RECTANGLE_NV = $84F6;

GL_PROXY_TEXTURE_RECTANGLE_NV = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE_NV = $84F8;

GL_OFFSET_TEXTURE_RECTANGLE_NV = $864C;

GL_OFFSET_TEXTURE_RECTANGLE_SCALE_NV = $864D;

GL_DOT_PRODUCT_TEXTURE_RECTANGLE_NV = $864E;

GL_RGBA_UNSIGNED_DOT_PRODUCT_MAPPING_NV = $86D9;

GL_UNSIGNED_INT_S8_S8_8_8_NV = $86DA;

GL_UNSIGNED_INT_8_8_S8_S8_REV_NV = $86DB;

GL_DSDT_MAG_INTENSITY_NV = $86DC;

GL_SHADER_CONSISTENT_NV = $86DD;

GL_TEXTURE_SHADER_NV = $86DE;

GL_SHADER_OPERATION_NV = $86DF;

GL_CULL_MODES_NV = $86E0;

GL_OFFSET_TEXTURE_MATRIX_NV = $86E1;

GL_OFFSET_TEXTURE_SCALE_NV = $86E2;

GL_OFFSET_TEXTURE_BIAS_NV = $86E3;

GL_OFFSET_TEXTURE_2D_MATRIX_NV = GL_OFFSET_TEXTURE_MATRIX_NV;

GL_OFFSET_TEXTURE_2D_SCALE_NV = GL_OFFSET_TEXTURE_SCALE_NV;

GL_OFFSET_TEXTURE_2D_BIAS_NV = GL_OFFSET_TEXTURE_BIAS_NV;

GL_PREVIOUS_TEXTURE_INPUT_NV = $86E4;

GL_CONST_EYE_NV = $86E5;

GL_PASS_THROUGH_NV = $86E6;

GL_CULL_FRAGMENT_NV = $86E7;

GL_OFFSET_TEXTURE_2D_NV = $86E8;

GL_DEPENDENT_AR_TEXTURE_2D_NV = $86E9;

GL_DEPENDENT_GB_TEXTURE_2D_NV = $86EA;

GL_DOT_PRODUCT_NV = $86EC;

GL_DOT_PRODUCT_DEPTH_REPLACE_NV = $86ED;

GL_DOT_PRODUCT_TEXTURE_2D_NV = $86EE;

GL_DOT_PRODUCT_TEXTURE_CUBE_MAP_NV = $86F0;

GL_DOT_PRODUCT_DIFFUSE_CUBE_MAP_NV = $86F1;

GL_DOT_PRODUCT_REFLECT_CUBE_MAP_NV = $86F2;

GL_DOT_PRODUCT_CONST_EYE_REFLECT_CUBE_MAP_NV = $86F3;

GL_HILO_NV = $86F4;

GL_DSDT_NV = $86F5;

GL_DSDT_MAG_NV = $86F6;

GL_DSDT_MAG_VIB_NV = $86F7;

GL_HILO16_NV = $86F8;

GL_SIGNED_HILO_NV = $86F9;

GL_SIGNED_HILO16_NV = $86FA;

GL_SIGNED_RGBA_NV = $86FB;

GL_SIGNED_RGBA8_NV = $86FC;

GL_SIGNED_RGB_NV = $86FE;

GL_SIGNED_RGB8_NV = $86FF;

GL_SIGNED_LUMINANCE_NV = $8701;

GL_SIGNED_LUMINANCE8_NV = $8702;

GL_SIGNED_LUMINANCE_ALPHA_NV = $8703;

GL_SIGNED_LUMINANCE8_ALPHA8_NV = $8704;

GL_SIGNED_ALPHA_NV = $8705;

GL_SIGNED_ALPHA8_NV = $8706;

GL_SIGNED_INTENSITY_NV = $8707;

GL_SIGNED_INTENSITY8_NV = $8708;

GL_DSDT8_NV = $8709;

GL_DSDT8_MAG8_NV = $870A;

GL_DSDT8_MAG8_INTENSITY8_NV = $870B;

GL_SIGNED_RGB_UNSIGNED_ALPHA_NV = $870C;

GL_SIGNED_RGB8_UNSIGNED_ALPHA8_NV = $870D;

GL_HI_SCALE_NV = $870E;

GL_LO_SCALE_NV = $870F;

GL_DS_SCALE_NV = $8710;

GL_DT_SCALE_NV = $8711;

GL_MAGNITUDE_SCALE_NV = $8712;

GL_VIBRANCE_SCALE_NV = $8713;

GL_HI_BIAS_NV = $8714;

GL_LO_BIAS_NV = $8715;

GL_DS_BIAS_NV = $8716;

GL_DT_BIAS_NV = $8717;

GL_MAGNITUDE_BIAS_NV = $8718;

GL_VIBRANCE_BIAS_NV = $8719;

GL_TEXTURE_BORDER_VALUES_NV = $871A;

GL_TEXTURE_HI_SIZE_NV = $871B;

GL_TEXTURE_LO_SIZE_NV = $871C;

GL_TEXTURE_DS_SIZE_NV = $871D;

GL_TEXTURE_DT_SIZE_NV = $871E;

GL_TEXTURE_MAG_SIZE_NV = $871F;

GL_DOT_PRODUCT_TEXTURE_3D_NV = $86EF;

GL_VERTEX_ARRAY_RANGE_WITHOUT_FLUSH_NV = $8533;

GL_VERTEX_PROGRAM_NV = $8620;

GL_VERTEX_STATE_PROGRAM_NV = $8621;

GL_ATTRIB_ARRAY_SIZE_NV = $8623;

GL_ATTRIB_ARRAY_STRIDE_NV = $8624;

GL_ATTRIB_ARRAY_TYPE_NV = $8625;

GL_CURRENT_ATTRIB_NV = $8626;

GL_PROGRAM_LENGTH_NV = $8627;

GL_PROGRAM_STRING_NV = $8628;

GL_MODELVIEW_PROJECTION_NV = $8629;

GL_IDENTITY_NV = $862A;

GL_INVERSE_NV = $862B;

GL_TRANSPOSE_NV = $862C;

GL_INVERSE_TRANSPOSE_NV = $862D;

GL_MAX_TRACK_MATRIX_STACK_DEPTH_NV = $862E;

GL_MAX_TRACK_MATRICES_NV = $862F;

GL_MATRIX0_NV = $8630;

GL_MATRIX1_NV = $8631;

GL_MATRIX2_NV = $8632;

GL_MATRIX3_NV = $8633;

GL_MATRIX4_NV = $8634;

GL_MATRIX5_NV = $8635;

GL_MATRIX6_NV = $8636;

GL_MATRIX7_NV = $8637;

GL_CURRENT_MATRIX_STACK_DEPTH_NV = $8640;

GL_CURRENT_MATRIX_NV = $8641;

GL_VERTEX_PROGRAM_POINT_SIZE_NV = $8642;

GL_VERTEX_PROGRAM_TWO_SIDE_NV = $8643;

GL_PROGRAM_PARAMETER_NV = $8644;

GL_ATTRIB_ARRAY_POINTER_NV = $8645;

GL_PROGRAM_TARGET_NV = $8646;

GL_PROGRAM_RESIDENT_NV = $8647;

GL_TRACK_MATRIX_NV = $8648;

GL_TRACK_MATRIX_TRANSFORM_NV = $8649;

GL_VERTEX_PROGRAM_BINDING_NV = $864A;

GL_PROGRAM_ERROR_POSITION_NV = $864B;

GL_VERTEX_ATTRIB_ARRAY0_NV = $8650;

GL_VERTEX_ATTRIB_ARRAY1_NV = $8651;

GL_VERTEX_ATTRIB_ARRAY2_NV = $8652;

GL_VERTEX_ATTRIB_ARRAY3_NV = $8653;

GL_VERTEX_ATTRIB_ARRAY4_NV = $8654;

GL_VERTEX_ATTRIB_ARRAY5_NV = $8655;

GL_VERTEX_ATTRIB_ARRAY6_NV = $8656;

GL_VERTEX_ATTRIB_ARRAY7_NV = $8657;

GL_VERTEX_ATTRIB_ARRAY8_NV = $8658;

GL_VERTEX_ATTRIB_ARRAY9_NV = $8659;

GL_VERTEX_ATTRIB_ARRAY10_NV = $865A;

GL_VERTEX_ATTRIB_ARRAY11_NV = $865B;

GL_VERTEX_ATTRIB_ARRAY12_NV = $865C;

GL_VERTEX_ATTRIB_ARRAY13_NV = $865D;

GL_VERTEX_ATTRIB_ARRAY14_NV = $865E;

GL_VERTEX_ATTRIB_ARRAY15_NV = $865F;

GL_MAP1_VERTEX_ATTRIB0_4_NV = $8660;

GL_MAP1_VERTEX_ATTRIB1_4_NV = $8661;

GL_MAP1_VERTEX_ATTRIB2_4_NV = $8662;

GL_MAP1_VERTEX_ATTRIB3_4_NV = $8663;

GL_MAP1_VERTEX_ATTRIB4_4_NV = $8664;

GL_MAP1_VERTEX_ATTRIB5_4_NV = $8665;

GL_MAP1_VERTEX_ATTRIB6_4_NV = $8666;

GL_MAP1_VERTEX_ATTRIB7_4_NV = $8667;

GL_MAP1_VERTEX_ATTRIB8_4_NV = $8668;

GL_MAP1_VERTEX_ATTRIB9_4_NV = $8669;

GL_MAP1_VERTEX_ATTRIB10_4_NV = $866A;

GL_MAP1_VERTEX_ATTRIB11_4_NV = $866B;

GL_MAP1_VERTEX_ATTRIB12_4_NV = $866C;

GL_MAP1_VERTEX_ATTRIB13_4_NV = $866D;

GL_MAP1_VERTEX_ATTRIB14_4_NV = $866E;

GL_MAP1_VERTEX_ATTRIB15_4_NV = $866F;

GL_MAP2_VERTEX_ATTRIB0_4_NV = $8670;

GL_MAP2_VERTEX_ATTRIB1_4_NV = $8671;

GL_MAP2_VERTEX_ATTRIB2_4_NV = $8672;

GL_MAP2_VERTEX_ATTRIB3_4_NV = $8673;

GL_MAP2_VERTEX_ATTRIB4_4_NV = $8674;

GL_MAP2_VERTEX_ATTRIB5_4_NV = $8675;

GL_MAP2_VERTEX_ATTRIB6_4_NV = $8676;

GL_MAP2_VERTEX_ATTRIB7_4_NV = $8677;

GL_MAP2_VERTEX_ATTRIB8_4_NV = $8678;

GL_MAP2_VERTEX_ATTRIB9_4_NV = $8679;

GL_MAP2_VERTEX_ATTRIB10_4_NV = $867A;

GL_MAP2_VERTEX_ATTRIB11_4_NV = $867B;

GL_MAP2_VERTEX_ATTRIB12_4_NV = $867C;

GL_MAP2_VERTEX_ATTRIB13_4_NV = $867D;

GL_MAP2_VERTEX_ATTRIB14_4_NV = $867E;

GL_MAP2_VERTEX_ATTRIB15_4_NV = $867F;

GL_MULTISAMPLE_FILTER_HINT_NV = $8534;

GL_PIXEL_COUNTER_BITS_NV = $8864;

GL_CURRENT_OCCLUSION_QUERY_ID_NV = $8865;

GL_PIXEL_COUNT_NV = $8866;

GL_PIXEL_COUNT_AVAILABLE_NV = $8867;

GL_POINT_SPRITE_NV = $8861;

GL_COORD_REPLACE_NV = $8862;

GL_POINT_SPRITE_R_MODE_NV = $8863;

GL_OFFSET_PROJECTIVE_TEXTURE_2D_NV = $8850;

GL_OFFSET_PROJECTIVE_TEXTURE_2D_SCALE_NV = $8851;

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_NV = $8852;

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_SCALE_NV = $8853;

GL_OFFSET_HILO_TEXTURE_2D_NV = $8854;

GL_OFFSET_HILO_TEXTURE_RECTANGLE_NV = $8855;

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_2D_NV = $8856;

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_RECTANGLE_NV = $8857;

GL_DEPENDENT_HILO_TEXTURE_2D_NV = $8858;

GL_DEPENDENT_RGB_TEXTURE_3D_NV = $8859;

GL_DEPENDENT_RGB_TEXTURE_CUBE_MAP_NV = $885A;

GL_DOT_PRODUCT_PASS_THROUGH_NV = $885B;

GL_DOT_PRODUCT_TEXTURE_1D_NV = $885C;

GL_DOT_PRODUCT_AFFINE_DEPTH_REPLACE_NV = $885D;

GL_HILO8_NV = $885E;

GL_SIGNED_HILO8_NV = $885F;

GL_FORCE_BLUE_TO_ONE_NV = $8860;

GL_STENCIL_TEST_TWO_SIDE_EXT = $8910;

GL_ACTIVE_STENCIL_FACE_EXT = $8911;

GL_MAX_DRAW_BUFFERS_ATI = $8824;

GL_DRAW_BUFFER0_ATI = $8825;

GL_DRAW_BUFFER1_ATI = $8826;

GL_DRAW_BUFFER2_ATI = $8827;

GL_DRAW_BUFFER3_ATI = $8828;

GL_DRAW_BUFFER4_ATI = $8829;

GL_DRAW_BUFFER5_ATI = $882A;

GL_DRAW_BUFFER6_ATI = $882B;

GL_DRAW_BUFFER7_ATI = $882C;

GL_DRAW_BUFFER8_ATI = $882D;

GL_DRAW_BUFFER9_ATI = $882E;

GL_DRAW_BUFFER10_ATI = $882F;

GL_DRAW_BUFFER11_ATI = $8830;

GL_DRAW_BUFFER12_ATI = $8831;

GL_DRAW_BUFFER13_ATI = $8832;

GL_DRAW_BUFFER14_ATI = $8833;

GL_DRAW_BUFFER15_ATI = $8834;

WGL_TYPE_RGBA_FLOAT_ATI = $21A0;

GL_TYPE_RGBA_FLOAT_ATI = $8820;

GL_COLOR_CLEAR_UNCLAMPED_VALUE_ATI = $8835;

GL_RGBA_FLOAT32_ATI = $8814;

GL_RGB_FLOAT32_ATI = $8815;

GL_ALPHA_FLOAT32_ATI = $8816;

GL_INTENSITY_FLOAT32_ATI = $8817;

GL_LUMINANCE_FLOAT32_ATI = $8818;

GL_LUMINANCE_ALPHA_FLOAT32_ATI = $8819;

GL_RGBA_FLOAT16_ATI = $881A;

GL_RGB_FLOAT16_ATI = $881B;

GL_ALPHA_FLOAT16_ATI = $881C;

GL_INTENSITY_FLOAT16_ATI = $881D;

GL_LUMINANCE_FLOAT16_ATI = $881E;

GL_LUMINANCE_ALPHA_FLOAT16_ATI = $881F;

GL_FLOAT_R_NV = $8880;

GL_FLOAT_RG_NV = $8881;

GL_FLOAT_RGB_NV = $8882;

GL_FLOAT_RGBA_NV = $8883;

GL_FLOAT_R16_NV = $8884;

GL_FLOAT_R32_NV = $8885;

GL_FLOAT_RG16_NV = $8886;

GL_FLOAT_RG32_NV = $8887;

GL_FLOAT_RGB16_NV = $8888;

GL_FLOAT_RGB32_NV = $8889;

GL_FLOAT_RGBA16_NV = $888A;

GL_FLOAT_RGBA32_NV = $888B;

GL_TEXTURE_FLOAT_COMPONENTS_NV = $888C;

GL_FLOAT_CLEAR_COLOR_VALUE_NV = $888D;

GL_FLOAT_RGBA_MODE_NV = $888E;

WGL_FLOAT_COMPONENTS_NV = $20B0;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV = $20B1;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV = $20B2;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV = $20B3;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV = $20B4;

WGL_TEXTURE_FLOAT_R_NV = $20B5;

WGL_TEXTURE_FLOAT_RG_NV = $20B6;

WGL_TEXTURE_FLOAT_RGB_NV = $20B7;

WGL_TEXTURE_FLOAT_RGBA_NV = $20B8;

GLX_FLOAT_COMPONENTS_NV = $20B0;

GL_PRIMITIVE_RESTART_NV = $8558;

GL_PRIMITIVE_RESTART_INDEX_NV = $8559;

GL_DEPTH_BOUNDS_TEST_EXT = $8890;

GL_DEPTH_BOUNDS_EXT = $8891;

GL_MIRROR_CLAMP_EXT = $8742;

GL_MIRROR_CLAMP_TO_EDGE_EXT = $8743;

GL_MIRROR_CLAMP_TO_BORDER_EXT = $8912;

GL_BLEND_EQUATION_RGB_EXT = $8009;

GL_BLEND_EQUATION_ALPHA_EXT = $883D;

GL_PIXEL_PACK_BUFFER_EXT = $88EB;

GL_PIXEL_UNPACK_BUFFER_EXT = $88EC;

GL_PIXEL_PACK_BUFFER_BINDING_EXT = $88ED;

GL_PIXEL_UNPACK_BUFFER_BINDING_EXT = $88EF;

GL_FRAMEBUFFER_EXT = $8D40;

GL_RENDERBUFFER_EXT = $8D41;

GL_STENCIL_INDEX1_EXT = $8D46;

GL_STENCIL_INDEX4_EXT = $8D47;

GL_STENCIL_INDEX8_EXT = $8D48;

GL_STENCIL_INDEX16_EXT = $8D49;

GL_DEPTH24_STENCIL8_EXT = $88F0;

GL_RENDERBUFFER_WIDTH_EXT = $8D42;

GL_RENDERBUFFER_HEIGHT_EXT = $8D43;

GL_RENDERBUFFER_INTERNAL_FORMAT_EXT = $8D44;

GL_RENDERBUFFER_RED_SIZE_EXT = $8D50;

GL_RENDERBUFFER_GREEN_SIZE_EXT = $8D51;

GL_RENDERBUFFER_BLUE_SIZE_EXT = $8D52;

GL_RENDERBUFFER_ALPHA_SIZE_EXT = $8D53;

GL_RENDERBUFFER_DEPTH_SIZE_EXT = $8D54;

GL_RENDERBUFFER_STENCIL_SIZE_EXT = $8D55;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE_EXT = $8CD0;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME_EXT = $8CD1;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL_EXT = $8CD2;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE_EXT = $8CD3;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_3D_ZOFFSET_EXT = $8CD4;

GL_COLOR_ATTACHMENT0_EXT = $8CE0;

GL_COLOR_ATTACHMENT1_EXT = $8CE1;

GL_COLOR_ATTACHMENT2_EXT = $8CE2;

GL_COLOR_ATTACHMENT3_EXT = $8CE3;

GL_COLOR_ATTACHMENT4_EXT = $8CE4;

GL_COLOR_ATTACHMENT5_EXT = $8CE5;

GL_COLOR_ATTACHMENT6_EXT = $8CE6;

GL_COLOR_ATTACHMENT7_EXT = $8CE7;

GL_COLOR_ATTACHMENT8_EXT = $8CE8;

GL_COLOR_ATTACHMENT9_EXT = $8CE9;

GL_COLOR_ATTACHMENT10_EXT = $8CEA;

GL_COLOR_ATTACHMENT11_EXT = $8CEB;

GL_COLOR_ATTACHMENT12_EXT = $8CEC;

GL_COLOR_ATTACHMENT13_EXT = $8CED;

GL_COLOR_ATTACHMENT14_EXT = $8CEE;

GL_COLOR_ATTACHMENT15_EXT = $8CEF;

GL_DEPTH_ATTACHMENT_EXT = $8D00;

GL_STENCIL_ATTACHMENT_EXT = $8D20;

GL_FRAMEBUFFER_COMPLETE_EXT = $8CD5;

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT_EXT = $8CD6;

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT_EXT = $8CD7;

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT = $8CD8;

GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS_EXT = $8CD9;

GL_FRAMEBUFFER_INCOMPLETE_FORMATS_EXT = $8CDA;

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER_EXT = $8CDB;

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER_EXT = $8CDC;

GL_FRAMEBUFFER_UNSUPPORTED_EXT = $8CDD;

GL_FRAMEBUFFER_BINDING_EXT = $8CA6;

GL_RENDERBUFFER_BINDING_EXT = $8CA7;

GL_MAX_COLOR_ATTACHMENTS_EXT = $8CDF;

GL_MAX_RENDERBUFFER_SIZE_EXT = $84E8;

GL_INVALID_FRAMEBUFFER_OPERATION_EXT = $0506;

GL_DEPTH_STENCIL_EXT = $84F9;

GL_UNSIGNED_INT_24_8_EXT = $84FA;

GL_TEXTURE_STENCIL_SIZE_EXT = $88F1;

GL_STENCIL_TAG_BITS_EXT = $88F2;

GL_STENCIL_CLEAR_TAG_VALUE_EXT = $88F3;

GL_SRGB_EXT = $8C40;

GL_SRGB8_EXT = $8C41;

GL_SRGB_ALPHA_EXT = $8C42;

GL_SRGB8_ALPHA8_EXT = $8C43;

GL_SLUMINANCE_ALPHA_EXT = $8C44;

GL_SLUMINANCE8_ALPHA8_EXT = $8C45;

GL_SLUMINANCE_EXT = $8C46;

GL_SLUMINANCE8_EXT = $8C47;

GL_COMPRESSED_SRGB_EXT = $8C48;

GL_COMPRESSED_SRGB_ALPHA_EXT = $8C49;

GL_COMPRESSED_SLUMINANCE_EXT = $8C4A;

GL_COMPRESSED_SLUMINANCE_ALPHA_EXT = $8C4B;

GL_COMPRESSED_SRGB_S3TC_DXT1_EXT = $8C4C;

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT1_EXT = $8C4D;

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT3_EXT = $8C4E;

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT5_EXT = $8C4F;

GL_READ_FRAMEBUFFER_EXT = $8CA8;

GL_DRAW_FRAMEBUFFER_EXT = $8CA9;

GL_DRAW_FRAMEBUFFER_BINDING_EXT = $8CA6;

GL_READ_FRAMEBUFFER_BINDING_EXT = $8CAA;

GL_RENDERBUFFER_SAMPLES_EXT = $8CAB;

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE_EXT = $8D56;

GL_MAX_SAMPLES_EXT = $8D57;

GL_TIME_ELAPSED_EXT = $88BF;

GL_GEOMETRY_PROGRAM_NV = $8C26;

GL_MAX_PROGRAM_OUTPUT_VERTICES_NV = $8C27;

GL_MAX_PROGRAM_TOTAL_OUTPUT_COMPONENTS_NV = $8C28;

GL_GEOMETRY_SHADER_EXT = $8DD9;

GL_GEOMETRY_VERTICES_OUT_EXT = $8DDA;

GL_GEOMETRY_INPUT_TYPE_EXT = $8DDB;

GL_GEOMETRY_OUTPUT_TYPE_EXT = $8DDC;

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_EXT = $8C29;

GL_MAX_GEOMETRY_VARYING_COMPONENTS_EXT = $8DDD;

GL_MAX_VERTEX_VARYING_COMPONENTS_EXT = $8DDE;

GL_MAX_VARYING_COMPONENTS_EXT = $8B4B;

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_EXT = $8DDF;

GL_MAX_GEOMETRY_OUTPUT_VERTICES_EXT = $8DE0;

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_EXT = $8DE1;

GL_LINES_ADJACENCY_EXT = $A;

GL_LINE_STRIP_ADJACENCY_EXT = $B;

GL_TRIANGLES_ADJACENCY_EXT = $C;

GL_TRIANGLE_STRIP_ADJACENCY_EXT = $D;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_EXT = $8DA8;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_EXT = $8DA9;

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_EXT = $8DA7;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER_EXT = $8CD4;

GL_PROGRAM_POINT_SIZE_EXT = $8642;

GL_VERTEX_ATTRIB_ARRAY_INTEGER_EXT = $88FD;

GL_SAMPLER_1D_ARRAY_EXT = $8DC0;

GL_SAMPLER_2D_ARRAY_EXT = $8DC1;

GL_SAMPLER_BUFFER_EXT = $8DC2;

GL_SAMPLER_1D_ARRAY_SHADOW_EXT = $8DC3;

GL_SAMPLER_2D_ARRAY_SHADOW_EXT = $8DC4;

GL_SAMPLER_CUBE_SHADOW_EXT = $8DC5;

GL_UNSIGNED_INT_VEC2_EXT = $8DC6;

GL_UNSIGNED_INT_VEC3_EXT = $8DC7;

GL_UNSIGNED_INT_VEC4_EXT = $8DC8;

GL_INT_SAMPLER_1D_EXT = $8DC9;

GL_INT_SAMPLER_2D_EXT = $8DCA;

GL_INT_SAMPLER_3D_EXT = $8DCB;

GL_INT_SAMPLER_CUBE_EXT = $8DCC;

GL_INT_SAMPLER_2D_RECT_EXT = $8DCD;

GL_INT_SAMPLER_1D_ARRAY_EXT = $8DCE;

GL_INT_SAMPLER_2D_ARRAY_EXT = $8DCF;

GL_INT_SAMPLER_BUFFER_EXT = $8DD0;

GL_UNSIGNED_INT_SAMPLER_1D_EXT = $8DD1;

GL_UNSIGNED_INT_SAMPLER_2D_EXT = $8DD2;

GL_UNSIGNED_INT_SAMPLER_3D_EXT = $8DD3;

GL_UNSIGNED_INT_SAMPLER_CUBE_EXT = $8DD4;

GL_UNSIGNED_INT_SAMPLER_2D_RECT_EXT = $8DD5;

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY_EXT = $8DD6;

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY_EXT = $8DD7;

GL_UNSIGNED_INT_SAMPLER_BUFFER_EXT = $8DD8;

GL_MIN_PROGRAM_TEXEL_OFFSET_EXT = $8904;

GL_MAX_PROGRAM_TEXEL_OFFSET_EXT = $8905;

GL_R11F_G11F_B10F_EXT = $8C3A;

GL_UNSIGNED_INT_10F_11F_11F_REV_EXT = $8C3B;

GL_RGBA_SIGNED_COMPONENTS_EXT = $8C3C;

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT = $20A8;

GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT = $20B1;

GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT = $00000008;

GL_TEXTURE_1D_ARRAY_EXT = $8C18;

GL_TEXTURE_2D_ARRAY_EXT = $8C1A;

GL_PROXY_TEXTURE_2D_ARRAY_EXT = $8C1B;

GL_PROXY_TEXTURE_1D_ARRAY_EXT = $8C19;

GL_TEXTURE_BINDING_1D_ARRAY_EXT = $8C1C;

GL_TEXTURE_BINDING_2D_ARRAY_EXT = $8C1D;

GL_MAX_ARRAY_TEXTURE_LAYERS_EXT = $88FF;

GL_COMPARE_REF_DEPTH_TO_TEXTURE_EXT = $884E;

GL_TEXTURE_BUFFER_EXT = $8C2A;

GL_MAX_TEXTURE_BUFFER_SIZE_EXT = $8C2B;

GL_TEXTURE_BINDING_BUFFER_EXT = $8C2C;

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_EXT = $8C2D;

GL_TEXTURE_BUFFER_FORMAT_EXT = $8C2E;

GL_COMPRESSED_LUMINANCE_LATC1_EXT = $8C70;

GL_COMPRESSED_SIGNED_LUMINANCE_LATC1_EXT = $8C71;

GL_COMPRESSED_LUMINANCE_ALPHA_LATC2_EXT = $8C72;

GL_COMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2_EXT = $8C73;

GL_COMPRESSED_LUMINANCE_ALPHA_3DC_ATI = $8837;

GL_COMPRESSED_RED_RGTC1_EXT = $8DBB;

GL_COMPRESSED_SIGNED_RED_RGTC1_EXT = $8DBC;

GL_COMPRESSED_RED_GREEN_RGTC2_EXT = $8DBD;

GL_COMPRESSED_SIGNED_RED_GREEN_RGTC2_EXT = $8DBE;

GL_RGB9_E5_EXT = $8C3D;

GL_UNSIGNED_INT_5_9_9_9_REV_EXT = $8C3E;

GL_TEXTURE_SHARED_SIZE_EXT = $8C3F;

GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20B2;

WGL_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20A9;

GL_FRAMEBUFFER_SRGB_EXT = $8DB9;

GL_FRAMEBUFFER_SRGB_CAPABLE_EXT = $8DBA;

GL_TRANSFORM_FEEDBACK_BUFFER_NV = $8C8E;

GL_TRANSFORM_FEEDBACK_BUFFER_START_NV = $8C84;

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_NV = $8C85;

GL_TRANSFORM_FEEDBACK_RECORD_NV = $8C86;

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_NV = $8C8F;

GL_INTERLEAVED_ATTRIBS_NV = $8C8C;

GL_SEPARATE_ATTRIBS_NV = $8C8D;

GL_PRIMITIVES_GENERATED_NV = $8C87;

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_NV = $8C88;

GL_RASTERIZER_DISCARD_NV = $8C89;

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_NV = $8C8A;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_NV = $8C8B;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_NV = $8C80;

GL_TRANSFORM_FEEDBACK_ATTRIBS_NV = $8C7E;

GL_ACTIVE_VARYINGS_NV = $8C81;

GL_ACTIVE_VARYING_MAX_LENGTH_NV = $8C82;

GL_TRANSFORM_FEEDBACK_VARYINGS_NV = $8C83;

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_NV = $8C7F;

GL_BACK_PRIMARY_COLOR_NV = $8C77;

GL_BACK_SECONDARY_COLOR_NV = $8C78;

GL_TEXTURE_COORD_NV = $8C79;

GL_CLIP_DISTANCE_NV = $8C7A;

GL_VERTEX_ID_NV = $8C7B;

GL_PRIMITIVE_ID_NV = $8C7C;

GL_GENERIC_ATTRIB_NV = $8C7D;

GL_LAYER_NV = $8DAA;

GL_MAX_VERTEX_BINDABLE_UNIFORMS_EXT = $8DE2;

GL_MAX_FRAGMENT_BINDABLE_UNIFORMS_EXT = $8DE3;

GL_MAX_GEOMETRY_BINDABLE_UNIFORMS_EXT = $8DE4;

GL_MAX_BINDABLE_UNIFORM_SIZE_EXT = $8DED;

GL_UNIFORM_BUFFER_BINDING_EXT = $8DEF;

GL_UNIFORM_BUFFER_EXT = $8DEE;

GL_RGBA_INTEGER_MODE_EXT = $8D9E;

GL_RGBA32UI_EXT = $8D70;

GL_RGB32UI_EXT = $8D71;

GL_ALPHA32UI_EXT = $8D72;

GL_INTENSITY32UI_EXT = $8D73;

GL_LUMINANCE32UI_EXT = $8D74;

GL_LUMINANCE_ALPHA32UI_EXT = $8D75;

GL_RGBA16UI_EXT = $8D76;

GL_RGB16UI_EXT = $8D77;

GL_ALPHA16UI_EXT = $8D78;

GL_INTENSITY16UI_EXT = $8D79;

GL_LUMINANCE16UI_EXT = $8D7A;

GL_LUMINANCE_ALPHA16UI_EXT = $8D7B;

GL_RGBA8UI_EXT = $8D7C;

GL_RGB8UI_EXT = $8D7D;

GL_ALPHA8UI_EXT = $8D7E;

GL_INTENSITY8UI_EXT = $8D7F;

GL_LUMINANCE8UI_EXT = $8D80;

GL_LUMINANCE_ALPHA8UI_EXT = $8D81;

GL_RGBA32I_EXT = $8D82;

GL_RGB32I_EXT = $8D83;

GL_ALPHA32I_EXT = $8D84;

GL_INTENSITY32I_EXT = $8D85;

GL_LUMINANCE32I_EXT = $8D86;

GL_LUMINANCE_ALPHA32I_EXT = $8D87;

GL_RGBA16I_EXT = $8D88;

GL_RGB16I_EXT = $8D89;

GL_ALPHA16I_EXT = $8D8A;

GL_INTENSITY16I_EXT = $8D8B;

GL_LUMINANCE16I_EXT = $8D8C;

GL_LUMINANCE_ALPHA16I_EXT = $8D8D;

GL_RGBA8I_EXT = $8D8E;

GL_RGB8I_EXT = $8D8F;

GL_ALPHA8I_EXT = $8D90;

GL_INTENSITY8I_EXT = $8D91;

GL_LUMINANCE8I_EXT = $8D92;

GL_LUMINANCE_ALPHA8I_EXT = $8D93;

GL_RED_INTEGER_EXT = $8D94;

GL_GREEN_INTEGER_EXT = $8D95;

GL_BLUE_INTEGER_EXT = $8D96;

GL_ALPHA_INTEGER_EXT = $8D97;

GL_RGB_INTEGER_EXT = $8D98;

GL_RGBA_INTEGER_EXT = $8D99;

GL_BGR_INTEGER_EXT = $8D9A;

GL_BGRA_INTEGER_EXT = $8D9B;

GL_LUMINANCE_INTEGER_EXT = $8D9C;

GL_LUMINANCE_ALPHA_INTEGER_EXT = $8D9D;

GL_QUERY_WAIT_NV = $8E13;

GL_QUERY_NO_WAIT_NV = $8E14;

GL_QUERY_BY_REGION_WAIT_NV = $8E15;

GL_QUERY_BY_REGION_NO_WAIT_NV = $8E16;

GL_TRANSFORM_FEEDBACK_BUFFER_EXT = $8C8E;

GL_TRANSFORM_FEEDBACK_BUFFER_START_EXT = $8C84;

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_EXT = $8C85;

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_EXT = $8C8F;

GL_INTERLEAVED_ATTRIBS_EXT = $8C8C;

GL_SEPARATE_ATTRIBS_EXT = $8C8D;

GL_PRIMITIVES_GENERATED_EXT = $8C87;

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_EXT = $8C88;

GL_RASTERIZER_DISCARD_EXT = $8C89;

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_EXT = $8C8A;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_EXT = $8C8B;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_EXT = $8C80;

GL_TRANSFORM_FEEDBACK_VARYINGS_EXT = $8C83;

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_EXT = $8C7F;

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH_EXT = $8C76;

GL_VBO_FREE_MEMORY_ATI = $87FB;

GL_TEXTURE_FREE_MEMORY_ATI = $87FC;

GL_RENDERBUFFER_FREE_MEMORY_ATI = $87FD;

GL_SAMPLER_BUFFER_AMD = $9001;

GL_INT_SAMPLER_BUFFER_AMD = $9002;

GL_UNSIGNED_INT_SAMPLER_BUFFER_AMD = $9003;

GL_DISCRETE_AMD = $9006;

GL_CONTINUOUS_AMD = $9007;

GL_TESSELLATION_MODE_AMD = $9004;

GL_TESSELLATION_FACTOR_AMD = $9005;

GL_BUFFER_GPU_ADDRESS_NV = $8F1D;

GL_GPU_ADDRESS_NV = $8F34;

GL_MAX_SHADER_BUFFER_ADDRESS_NV = $8F35;

GL_VERTEX_ATTRIB_ARRAY_UNIFIED_NV = $8F1E;

GL_ELEMENT_ARRAY_UNIFIED_NV = $8F1F;

GL_VERTEX_ATTRIB_ARRAY_ADDRESS_NV = $8F20;

GL_VERTEX_ARRAY_ADDRESS_NV = $8F21;

GL_NORMAL_ARRAY_ADDRESS_NV = $8F22;

GL_COLOR_ARRAY_ADDRESS_NV = $8F23;

GL_INDEX_ARRAY_ADDRESS_NV = $8F24;

GL_TEXTURE_COORD_ARRAY_ADDRESS_NV = $8F25;

GL_EDGE_FLAG_ARRAY_ADDRESS_NV = $8F26;

GL_SECONDARY_COLOR_ARRAY_ADDRESS_NV = $8F27;

GL_FOG_COORD_ARRAY_ADDRESS_NV = $8F28;

GL_ELEMENT_ARRAY_ADDRESS_NV = $8F29;

GL_VERTEX_ATTRIB_ARRAY_LENGTH_NV = $8F2A;

GL_VERTEX_ARRAY_LENGTH_NV = $8F2B;

GL_NORMAL_ARRAY_LENGTH_NV = $8F2C;

GL_COLOR_ARRAY_LENGTH_NV = $8F2D;

GL_INDEX_ARRAY_LENGTH_NV = $8F2E;

GL_TEXTURE_COORD_ARRAY_LENGTH_NV = $8F2F;

GL_EDGE_FLAG_ARRAY_LENGTH_NV = $8F30;

GL_SECONDARY_COLOR_ARRAY_LENGTH_NV = $8F31;

GL_FOG_COORD_ARRAY_LENGTH_NV = $8F32;

GL_ELEMENT_ARRAY_LENGTH_NV = $8F33;

GL_SURFACE_STATE_NV = $86EB;

GL_SURFACE_REGISTERED_NV = $86FD;

GL_SURFACE_MAPPED_NV = $8700;

GL_WRITE_DISCARD_NV = $88BE;

WGL_COLOR_SAMPLES_NV = $20B9;

GL_GPU_MEMORY_INFO_DEDICATED_VIDMEM_NVX = $9047;

GL_GPU_MEMORY_INFO_TOTAL_AVAILABLE_MEMORY_NVX = $9048;

GL_GPU_MEMORY_INFO_CURRENT_AVAILABLE_VIDMEM_NVX = $9049;

GL_GPU_MEMORY_INFO_EVICTION_COUNT_NVX = $904A;

GL_GPU_MEMORY_INFO_EVICTED_MEMORY_NVX = $904B;

GL_TEXTURE_SRGB_DECODE_EXT = $8A48;

GL_DECODE_EXT = $8A49;

GL_SKIP_DECODE_EXT = $8A4A;

GL_CLOSE_PATH_NV = $00;

GL_MOVE_TO_NV = $02;

GL_RELATIVE_MOVE_TO_NV = $03;

GL_LINE_TO_NV = $04;

GL_RELATIVE_LINE_TO_NV = $05;

GL_HORIZONTAL_LINE_TO_NV = $06;

GL_RELATIVE_HORIZONTAL_LINE_TO_NV = $07;

GL_VERTICAL_LINE_TO_NV = $08;

GL_RELATIVE_VERTICAL_LINE_TO_NV = $09;

GL_QUADRATIC_CURVE_TO_NV = $0A;

GL_RELATIVE_QUADRATIC_CURVE_TO_NV = $0B;

GL_CUBIC_CURVE_TO_NV = $0C;

GL_RELATIVE_CUBIC_CURVE_TO_NV = $0D;

GL_SMOOTH_QUADRATIC_CURVE_TO_NV = $0E;

GL_RELATIVE_SMOOTH_QUADRATIC_CURVE_TO_NV = $0F;

GL_SMOOTH_CUBIC_CURVE_TO_NV = $10;

GL_RELATIVE_SMOOTH_CUBIC_CURVE_TO_NV = $11;

GL_SMALL_CCW_ARC_TO_NV = $12;

GL_RELATIVE_SMALL_CCW_ARC_TO_NV = $13;

GL_SMALL_CW_ARC_TO_NV = $14;

GL_RELATIVE_SMALL_CW_ARC_TO_NV = $15;

GL_LARGE_CCW_ARC_TO_NV = $16;

GL_RELATIVE_LARGE_CCW_ARC_TO_NV = $17;

GL_LARGE_CW_ARC_TO_NV = $18;

GL_RELATIVE_LARGE_CW_ARC_TO_NV = $19;

GL_CIRCULAR_CCW_ARC_TO_NV = $F8;

GL_CIRCULAR_CW_ARC_TO_NV = $FA;

GL_CIRCULAR_TANGENT_ARC_TO_NV = $FC;

GL_ARC_TO_NV = $FE;

GL_RELATIVE_ARC_TO_NV = $FF;

GL_PATH_FORMAT_SVG_NV = $9070;

GL_PATH_FORMAT_PS_NV = $9071;

GL_STANDARD_FONT_NAME_NV = $9072;

GL_SYSTEM_FONT_NAME_NV = $9073;

GL_FILE_NAME_NV = $9074;

GL_PATH_STROKE_WIDTH_NV = $9075;

GL_PATH_END_CAPS_NV = $9076;

GL_PATH_INITIAL_END_CAP_NV = $9077;

GL_PATH_TERMINAL_END_CAP_NV = $9078;

GL_PATH_JOIN_STYLE_NV = $9079;

GL_PATH_MITER_LIMIT_NV = $907A;

GL_PATH_DASH_CAPS_NV = $907B;

GL_PATH_INITIAL_DASH_CAP_NV = $907C;

GL_PATH_TERMINAL_DASH_CAP_NV = $907D;

GL_PATH_DASH_OFFSET_NV = $907E;

GL_PATH_CLIENT_LENGTH_NV = $907F;

GL_PATH_FILL_MODE_NV = $9080;

GL_PATH_FILL_MASK_NV = $9081;

GL_PATH_FILL_COVER_MODE_NV = $9082;

GL_PATH_STROKE_COVER_MODE_NV = $9083;

GL_PATH_STROKE_MASK_NV = $9084;

GL_PATH_SAMPLE_QUALITY_NV = $9085;

GL_COUNT_UP_NV = $9088;

GL_COUNT_DOWN_NV = $9089;

GL_PATH_OBJECT_BOUNDING_BOX_NV = $908A;

GL_CONVEX_HULL_NV = $908B;

GL_BOUNDING_BOX_NV = $908D;

GL_TRANSLATE_X_NV = $908E;

GL_TRANSLATE_Y_NV = $908F;

GL_TRANSLATE_2D_NV = $9090;

GL_TRANSLATE_3D_NV = $9091;

GL_AFFINE_2D_NV = $9092;

GL_AFFINE_3D_NV = $9094;

GL_TRANSPOSE_AFFINE_2D_NV = $9096;

GL_TRANSPOSE_AFFINE_3D_NV = $9098;

GL_UTF8_NV = $909A;

GL_UTF16_NV = $909B;

GL_BOUNDING_BOX_OF_BOUNDING_BOXES_NV = $909C;

GL_PATH_COMMAND_COUNT_NV = $909D;

GL_PATH_COORD_COUNT_NV = $909E;

GL_PATH_DASH_ARRAY_COUNT_NV = $909F;

GL_PATH_COMPUTED_LENGTH_NV = $90A0;

GL_PATH_FILL_BOUNDING_BOX_NV = $90A1;

GL_PATH_STROKE_BOUNDING_BOX_NV = $90A2;

GL_SQUARE_NV = $90A3;

GL_ROUND_NV = $90A4;

GL_TRIANGULAR_NV = $90A5;

GL_BEVEL_NV = $90A6;

GL_MITER_REVERT_NV = $90A7;

GL_MITER_TRUNCATE_NV = $90A8;

GL_SKIP_MISSING_GLYPH_NV = $90A9;

GL_USE_MISSING_GLYPH_NV = $90AA;

GL_PATH_DASH_OFFSET_RESET_NV = $90B4;

GL_MOVE_TO_RESETS_NV = $90B5;

GL_MOVE_TO_CONTINUES_NV = $90B6;

GL_BOLD_BIT_NV = $01;

GL_ITALIC_BIT_NV = $02;

GL_PATH_ERROR_POSITION_NV = $90AB;

GL_PATH_FOG_GEN_MODE_NV = $90AC;

GL_GLYPH_WIDTH_BIT_NV = $01;

GL_GLYPH_HEIGHT_BIT_NV = $02;

GL_GLYPH_HORIZONTAL_BEARING_X_BIT_NV = $04;

GL_GLYPH_HORIZONTAL_BEARING_Y_BIT_NV = $08;

GL_GLYPH_HORIZONTAL_BEARING_ADVANCE_BIT_NV = $10;

GL_GLYPH_VERTICAL_BEARING_X_BIT_NV = $20;

GL_GLYPH_VERTICAL_BEARING_Y_BIT_NV = $40;

GL_GLYPH_VERTICAL_BEARING_ADVANCE_BIT_NV = $80;

GL_GLYPH_HAS_KERNING_NV = $100;

GL_FONT_X_MIN_BOUNDS_NV = $00010000;

GL_FONT_Y_MIN_BOUNDS_NV = $00020000;

GL_FONT_X_MAX_BOUNDS_NV = $00040000;

GL_FONT_Y_MAX_BOUNDS_NV = $00080000;

GL_FONT_UNITS_PER_EM_NV = $00100000;

GL_FONT_ASCENDER_NV = $00200000;

GL_FONT_DESCENDER_NV = $00400000;

GL_FONT_HEIGHT_NV = $00800000;

GL_FONT_MAX_ADVANCE_WIDTH_NV = $01000000;

GL_FONT_MAX_ADVANCE_HEIGHT_NV = $02000000;

GL_FONT_UNDERLINE_POSITION_NV = $04000000;

GL_FONT_UNDERLINE_THICKNESS_NV = $08000000;

GL_FONT_HAS_KERNING_NV = $10000000;

GL_ACCUM_ADJACENT_PAIRS_NV = $90AD;

GL_ADJACENT_PAIRS_NV = $90AE;

GL_FIRST_TO_REST_NV = $90AF;

GL_PATH_GEN_MODE_NV = $90B0;

GL_PATH_GEN_COEFF_NV = $90B1;

GL_PATH_GEN_COLOR_FORMAT_NV = $90B2;

GL_PATH_GEN_COMPONENTS_NV = $90B3;

GL_PATH_STENCIL_FUNC_NV = $90B7;

GL_PATH_STENCIL_REF_NV = $90B8;

GL_PATH_STENCIL_VALUE_MASK_NV = $90B9;

GL_PATH_STENCIL_DEPTH_OFFSET_FACTOR_NV = $90BD;

GL_PATH_STENCIL_DEPTH_OFFSET_UNITS_NV = $90BE;

GL_PATH_COVER_DEPTH_FUNC_NV = $90BF;

WGL_ACCESS_READ_ONLY_NV = $0000;

WGL_ACCESS_READ_WRITE_NV = $0001;

WGL_ACCESS_WRITE_DISCARD_NV = $0002;

GLX_EXTENSION_NAME = 'GLX';

GLX_USE_GL = 1;

GLX_BUFFER_SIZE = 2;

GLX_LEVEL = 3;

GLX_RGBA = 4;

GLX_DOUBLEBUFFER = 5;

GLX_STEREO = 6;

GLX_AUX_BUFFERS = 7;

GLX_RED_SIZE = 8;

GLX_GREEN_SIZE = 9;

GLX_BLUE_SIZE = 10;

GLX_ALPHA_SIZE = 11;

GLX_DEPTH_SIZE = 12;

GLX_STENCIL_SIZE = 13;

GLX_ACCUM_RED_SIZE = 14;

GLX_ACCUM_GREEN_SIZE = 15;

GLX_ACCUM_BLUE_SIZE = 16;

GLX_ACCUM_ALPHA_SIZE = 17;

GLX_BAD_SCREEN = 1;

GLX_BAD_ATTRIBUTE = 2;

GLX_NO_EXTENSION = 3;

GLX_BAD_VISUAL = 4;

GLX_BAD_CONTEXT = 5;

GLX_BAD_VALUE = 6;

GLX_BAD_ENUM = 7;

GLX_BAD_HYPERPIPE_CONFIG_SGIX = 91;

GLX_BAD_HYPERPIPE_SGIX = 92;

GLX_VENDOR = 1;

GLX_VERSION = 2;

GLX_EXTENSIONS = 3;

GLX_CONFIG_CAVEAT = $20;

GLX_NONE = $8000;

GLX_DONT_CARE = $FFFFFFFF;

GLX_SLOW_CONFIG = $8001;

GLX_NON_CONFORMANT_CONFIG = $800D;

GLX_X_VISUAL_TYPE = $22;

GLX_TRANSPARENT_TYPE = $23;

GLX_TRANSPARENT_INDEX_VALUE = $24;

GLX_TRANSPARENT_RED_VALUE = $25;

GLX_TRANSPARENT_GREEN_VALUE = $26;

GLX_TRANSPARENT_BLUE_VALUE = $27;

GLX_TRANSPARENT_ALPHA_VALUE = $28;

GLX_TRUE_COLOR = $8002;

GLX_DIRECT_COLOR = $8003;

GLX_PSEUDO_COLOR = $8004;

GLX_STATIC_COLOR = $8005;

GLX_GRAY_SCALE = $8006;

GLX_STATIC_GRAY = $8007;

GLX_TRANSPARENT_RGB = $8008;

GLX_TRANSPARENT_INDEX = $8009;

GLX_MAX_PBUFFER_WIDTH = $8016;

GLX_MAX_PBUFFER_HEIGHT = $8017;

GLX_MAX_PBUFFER_PIXELS = $8018;

GLX_PRESERVED_CONTENTS = $801B;

GLX_LARGEST_BUFFER = $801C;

GLX_WIDTH = $801D;

GLX_HEIGHT = $801E;

GLX_EVENT_MASK = $801F;

GLX_DRAWABLE_TYPE = $8010;

GLX_FBCONFIG_ID = $8013;

GLX_VISUAL_ID = $800B;

GLX_WINDOW_BIT = $00000001;

GLX_PIXMAP_BIT = $00000002;

GLX_PBUFFER_BIT = $00000004;

GLX_WINDOW_BIT_SGIX = $00000001;

GLX_PIXMAP_BIT_SGIX = $00000002;

GLX_PBUFFER_BIT_SGIX = $00000004;

GLX_AUX_BUFFERS_BIT = $00000010;

GLX_FRONT_LEFT_BUFFER_BIT = $00000001;

GLX_FRONT_RIGHT_BUFFER_BIT = $00000002;

GLX_BACK_LEFT_BUFFER_BIT = $00000004;

GLX_BACK_RIGHT_BUFFER_BIT = $00000008;

GLX_DEPTH_BUFFER_BIT = $00000020;

GLX_STENCIL_BUFFER_BIT = $00000040;

GLX_ACCUM_BUFFER_BIT = $00000080;

GLX_FRONT_LEFT_BUFFER_BIT_SGIX = $00000001;

GLX_FRONT_RIGHT_BUFFER_BIT_SGIX = $00000002;

GLX_BACK_LEFT_BUFFER_BIT_SGIX = $00000004;

GLX_BACK_RIGHT_BUFFER_BIT_SGIX = $00000008;

GLX_AUX_BUFFERS_BIT_SGIX = $00000010;

GLX_DEPTH_BUFFER_BIT_SGIX = $00000020;

GLX_STENCIL_BUFFER_BIT_SGIX = $00000040;

GLX_ACCUM_BUFFER_BIT_SGIX = $00000080;

GLX_SAMPLE_BUFFERS_BIT_SGIX = $00000100;

GLX_RENDER_TYPE = $8011;

GLX_X_RENDERABLE = $8012;

GLX_RGBA_TYPE = $8014;

GLX_RGBA_BIT = $00000001;

GLX_COLOR_INDEX_TYPE = $8015;

GLX_COLOR_INDEX_BIT = $00000002;

GLX_RGBA_BIT_SGIX = $00000001 ;

GLX_COLOR_INDEX_BIT_SGIX = $00000002 ;

GLX_SCREEN = $800C;

GLX_PBUFFER_CLOBBER_MASK = $08000000;

GLX_DAMAGED = $8020;

GLX_SAVED = $8021;

GLX_WINDOW = $8022;

GLX_PBUFFER = $8023;

GLX_PBUFFER_HEIGHT = $8040;

GLX_PBUFFER_WIDTH = $8041;

GLX_X_VISUAL_TYPE_EXT = $22;

GLX_TRANSPARENT_TYPE_EXT = $23;

GLX_TRANSPARENT_INDEX_VALUE_EXT = $24;

GLX_TRANSPARENT_RED_VALUE_EXT = $25;

GLX_TRANSPARENT_GREEN_VALUE_EXT = $26;

GLX_TRANSPARENT_BLUE_VALUE_EXT = $27;

GLX_TRANSPARENT_ALPHA_VALUE_EXT = $28;

GLX_TRUE_COLOR_EXT = $8002;

GLX_DIRECT_COLOR_EXT = $8003;

GLX_PSEUDO_COLOR_EXT = $8004;

GLX_STATIC_COLOR_EXT = $8005;

GLX_GRAY_SCALE_EXT = $8006;

GLX_STATIC_GRAY_EXT = $8007;

GLX_TRANSPARENT_RGB_EXT = $8008;

GLX_TRANSPARENT_INDEX_EXT = $8009;

GLX_VISUAL_CAVEAT_EXT = $20;

GLX_NONE_EXT = $8000;

GLX_SLOW_VISUAL_EXT = $8001;

GLX_NON_CONFORMANT_VISUAL_EXT = $800D;

GLX_SHARE_CONTEXT_EXT = $800A;

GLX_VISUAL_ID_EXT = $800B;

GLX_SCREEN_EXT = $800C;

GLX_3DFX_WINDOW_MODE_MESA = $1;

GLX_3DFX_FULLSCREEN_MODE_MESA = $2;

GLX_DRAWABLE_TYPE_SGIX = $8010;

GLX_RENDER_TYPE_SGIX = $8011;

GLX_X_RENDERABLE_SGIX = $8012;

GLX_FBCONFIG_ID_SGIX = 48013;

GLX_RGBA_TYPE_SGIX = $8014;

GLX_COLOR_INDEX_TYPE_SGIX = $8015;

GLX_MAX_PBUFFER_WIDTH_SGIX = $8016;

GLX_MAX_PBUFFER_HEIGHT_SGIX = $8017;

GLX_MAX_PBUFFER_PIXELS_SGIX = $8018;

GLX_OPTIMAL_PBUFFER_WIDTH_SGIX = $8019;

GLX_OPTIMAL_PBUFFER_HEIGHT_SGIX = $801A;

GLX_PRESERVED_CONTENTS_SGIX = $801B;

GLX_LARGEST_PBUFFER_SGIX = $801C;

GLX_WIDTH_SGIX = $801D;

GLX_HEIGHT_SGIX = $801E;

GLX_EVENT_MASK_SGIX = $801F;

GLX_DAMAGED_SGIX = $8020;

GLX_SAVED_SGIX = $8021;

GLX_WINDOW_SGIX = $8022;

GLX_PBUFFER_SGIX = $8023;

GLX_DIGITAL_MEDIA_PBUFFER_SGIX = $8024;

GLX_BLENDED_RGBA_SGIS = $8025;

GLX_MULTISAMPLE_SUB_RECT_WIDTH_SGIS = $8026;

GLX_MULTISAMPLE_SUB_RECT_HEIGHT_SGIS = $8027;

GLX_VISUAL_SELECT_GROUP_SGIX = $8028;

GLX_HYPERPIPE_ID_SGIX = $8030;

GLX_SYNC_FRAME_SGIX = $00000000 ;

GLX_SYNC_SWAP_SGIX = $00000001;

GLX_BUFFER_CLOBBER_MASK_SGIX = $08000000;

GLX_BUFFER_SWAP_COMPLETE_INTEL_MASK = $04000000;

GLX_HYPERPIPE_DISPLAY_PIPE_SGIX = $00000001;

GLX_HYPERPIPE_RENDER_PIPE_SGIX = $00000002;

GLX_PIPE_RECT_SGIX = $00000001;

GLX_PIPE_RECT_LIMITS_SGIX = $00000002;

GLX_HYPERPIPE_STEREO_SGIX = $00000003;

GLX_HYPERPIPE_PIXEL_AVERAGE_SGIX = $00000004;

GLX_HYPERPIPE_PIPE_NAME_LENGTH_SGIX = $80 ;

GLX_TEXTURE_1D_BIT_EXT = $00000001;

GLX_TEXTURE_2D_BIT_EXT = $00000002;

GLX_TEXTURE_RECTANGLE_BIT_EXT = $00000004;

GLX_SWAP_METHOD_OML = $8060;

GLX_SWAP_EXCHANGE_OML = $8061;

GLX_SWAP_COPY_OML = $8062;

GLX_SWAP_UNDEFINED_OML = $8063;

GLX_EXCHANGE_COMPLETE_INTEL = $8180;

GLX_COPY_COMPLETE_INTEL = $8181;

GLX_FLIP_COMPLETE_INTEL = $8182;

GLX_COLOR_SAMPLES_NV = $20B3;

AGL_NONE = 0;

AGL_ALL_RENDERERS = 1;

AGL_BUFFER_SIZE = 2;

AGL_LEVEL = 3;

AGL_RGBA = 4;

AGL_DOUBLEBUFFER = 5;

AGL_STEREO = 6;

AGL_AUX_BUFFERS = 7;

AGL_RED_SIZE = 8;

AGL_GREEN_SIZE = 9;

AGL_BLUE_SIZE = 10;

AGL_ALPHA_SIZE = 11;

AGL_DEPTH_SIZE = 12;

AGL_STENCIL_SIZE = 13;

AGL_ACCUM_RED_SIZE = 14;

AGL_ACCUM_GREEN_SIZE = 15;

AGL_ACCUM_BLUE_SIZE = 16;

AGL_ACCUM_ALPHA_SIZE = 17;

AGL_PIXEL_SIZE = 50;

AGL_MINIMUM_POLICY = 51;

AGL_MAXIMUM_POLICY = 52;

AGL_OFFSCREEN = 53;

AGL_FULLSCREEN = 54;

AGL_SAMPLE_BUFFERS_ARB = 55;

AGL_SAMPLES_ARB = 56;

AGL_AUX_DEPTH_STENCIL = 57;

AGL_COLOR_FLOAT = 58;

AGL_MULTISAMPLE = 59;

AGL_SUPERSAMPLE = 60;

AGL_SAMPLE_ALPHA = 61;

AGL_RENDERER_ID = 70;

AGL_SINGLE_RENDERER = 71;

AGL_NO_RECOVERY = 72;

AGL_ACCELERATED = 73;

AGL_CLOSEST_POLICY = 74;

AGL_ROBUST = 75;

AGL_BACKING_STORE = 76;

AGL_MP_SAFE = 78;

AGL_WINDOW = 80;

AGL_MULTISCREEN = 81;

AGL_VIRTUAL_SCREEN = 82;

AGL_COMPLIANT = 83;

AGL_PBUFFER = 90;

AGL_REMOTE_PBUFFER = 91;

AGL_BUFFER_MODES = 100;

AGL_MIN_LEVEL = 101;

AGL_MAX_LEVEL = 102;

AGL_COLOR_MODES = 103;

AGL_ACCUM_MODES = 104;

AGL_DEPTH_MODES = 105;

AGL_STENCIL_MODES = 106;

AGL_MAX_AUX_BUFFERS = 107;

AGL_VIDEO_MEMORY = 120;

AGL_TEXTURE_MEMORY = 121;

AGL_RENDERER_COUNT = 128;

AGL_SWAP_RECT = 200;

AGL_BUFFER_RECT = 202;

AGL_SWAP_LIMIT = 203;

AGL_COLORMAP_TRACKING = 210;

AGL_COLORMAP_ENTRY = 212;

AGL_RASTERIZATION = 220;

AGL_SWAP_INTERVAL = 222;

AGL_STATE_VALIDATION = 230;

AGL_BUFFER_NAME = 231;

AGL_ORDER_CONTEXT_TO_FRONT = 232;

AGL_CONTEXT_SURFACE_ID = 233;

AGL_CONTEXT_DISPLAY_ID = 234;

AGL_SURFACE_ORDER = 235;

AGL_SURFACE_OPACITY = 236;

AGL_CLIP_REGION = 254;

AGL_FS_CAPTURE_SINGLE = 255;

AGL_SURFACE_BACKING_SIZE = 304;

AGL_ENABLE_SURFACE_BACKING_SIZE = 305;

AGL_SURFACE_VOLATILE = 306;

AGL_FORMAT_CACHE_SIZE = 501;

AGL_CLEAR_FORMAT_CACHE = 502;

AGL_RETAIN_RENDERERS = 503;

AGL_MONOSCOPIC_BIT = $00000001;

AGL_STEREOSCOPIC_BIT = $00000002;

AGL_SINGLEBUFFER_BIT = $00000004;

AGL_DOUBLEBUFFER_BIT = $00000008;

AGL_0_BIT = $00000001;

AGL_1_BIT = $00000002;

AGL_2_BIT = $00000004;

AGL_3_BIT = $00000008;

AGL_4_BIT = $00000010;

AGL_5_BIT = $00000020;

AGL_6_BIT = $00000040;

AGL_8_BIT = $00000080;

AGL_10_BIT = $00000100;

AGL_12_BIT = $00000200;

AGL_16_BIT = $00000400;

AGL_24_BIT = $00000800;

AGL_32_BIT = $00001000;

AGL_48_BIT = $00002000;

AGL_64_BIT = $00004000;

AGL_96_BIT = $00008000;

AGL_128_BIT = $00010000;

AGL_RGB8_BIT = $00000001;

AGL_RGB8_A8_BIT = $00000002;

AGL_BGR233_BIT = $00000004;

AGL_BGR233_A8_BIT = $00000008;

AGL_RGB332_BIT = $00000010;

AGL_RGB332_A8_BIT = $00000020;

AGL_RGB444_BIT = $00000040;

AGL_ARGB4444_BIT = $00000080;

AGL_RGB444_A8_BIT = $00000100;

AGL_RGB555_BIT = $00000200;

AGL_ARGB1555_BIT = $00000400;

AGL_RGB555_A8_BIT = $00000800;

AGL_RGB565_BIT = $00001000;

AGL_RGB565_A8_BIT = $00002000;

AGL_RGB888_BIT = $00004000;

AGL_ARGB8888_BIT = $00008000;

AGL_RGB888_A8_BIT = $00010000;

AGL_RGB101010_BIT = $00020000;

AGL_ARGB2101010_BIT = $00040000;

AGL_RGB101010_A8_BIT = $00080000;

AGL_RGB121212_BIT = $00100000;

AGL_ARGB12121212_BIT = $00200000;

AGL_RGB161616_BIT = $00400000;

AGL_ARGB16161616_BIT = $00800000;

AGL_INDEX8_BIT = $20000000;

AGL_INDEX16_BIT = $40000000;

AGL_RGBFLOAT64_BIT = $01000000;

AGL_RGBAFLOAT64_BIT = $02000000;

AGL_RGBFLOAT128_BIT = $04000000;

AGL_RGBAFLOAT128_BIT = $08000000;

AGL_RGBFLOAT256_BIT = $10000000;

AGL_RGBAFLOAT256_BIT = $20000000;

AGL_NO_ERROR = 0;

AGL_BAD_ATTRIBUTE = 10000;

AGL_BAD_PROPERTY = 10001;

AGL_BAD_PIXELFMT = 10002;

AGL_BAD_RENDINFO = 10003;

AGL_BAD_CONTEXT = 10004;

AGL_BAD_DRAWABLE = 10005;

AGL_BAD_GDEV = 10006;

AGL_BAD_STATE = 10007;

AGL_BAD_VALUE = 10008;

AGL_BAD_MATCH = 10009;

AGL_BAD_ENUM = 10010;

AGL_BAD_OFFSCREEN = 10011;

AGL_BAD_FULLSCREEN = 10012;

AGL_BAD_WINDOW = 10013;

AGL_BAD_POINTER = 10014;

AGL_BAD_MODULE = 10015;

AGL_BAD_ALLOC = 10016;

AGL_BAD_CONNECTION = 10017;

GLU_INVALID_ENUM = 100900;

GLU_INVALID_VALUE = 100901;

GLU_OUT_OF_MEMORY = 100902;

GLU_INCOMPATIBLE_GL_VERSION = 100903;

GLU_VERSION = 100800;

GLU_EXTENSIONS = 100801;

GLU_TRUE = GL_TRUE;

GLU_FALSE = GL_FALSE;

GLU_SMOOTH = 100000;

GLU_FLAT = 100001;

GLU_NONE = 100002;

GLU_POINT = 100010;

GLU_LINE = 100011;

GLU_FILL = 100012;

GLU_SILHOUETTE = 100013;

GLU_OUTSIDE = 100020;

GLU_INSIDE = 100021;

GLU_TESS_MAX_COORD = 1.0e150;

GLU_TESS_WINDING_RULE = 100140;

GLU_TESS_BOUNDARY_ONLY = 100141;

GLU_TESS_TOLERANCE = 100142;

GLU_TESS_WINDING_ODD = 100130;

GLU_TESS_WINDING_NONZERO = 100131;

GLU_TESS_WINDING_POSITIVE = 100132;

GLU_TESS_WINDING_NEGATIVE = 100133;

GLU_TESS_WINDING_ABS_GEQ_TWO = 100134;

GLU_TESS_BEGIN = 100100;

GLU_TESS_VERTEX = 100101;

GLU_TESS_END = 100102;

GLU_TESS_ERROR = 100103;

GLU_TESS_EDGE_FLAG = 100104;

GLU_TESS_COMBINE = 100105;

GLU_TESS_BEGIN_DATA = 100106;

GLU_TESS_VERTEX_DATA = 100107;

GLU_TESS_END_DATA = 100108;

GLU_TESS_ERROR_DATA = 100109;

GLU_TESS_EDGE_FLAG_DATA = 100110;

GLU_TESS_COMBINE_DATA = 100111;

GLU_TESS_ERROR1 = 100151;

GLU_TESS_ERROR2 = 100152;

GLU_TESS_ERROR3 = 100153;

GLU_TESS_ERROR4 = 100154;

GLU_TESS_ERROR5 = 100155;

GLU_TESS_ERROR6 = 100156;

GLU_TESS_ERROR7 = 100157;

GLU_TESS_ERROR8 = 100158;

GLU_TESS_MISSING_BEGIN_POLYGON = GLU_TESS_ERROR1;

GLU_TESS_MISSING_BEGIN_CONTOUR = GLU_TESS_ERROR2;

GLU_TESS_MISSING_END_POLYGON = GLU_TESS_ERROR3;

GLU_TESS_MISSING_END_CONTOUR = GLU_TESS_ERROR4;

GLU_TESS_COORD_TOO_LARGE = GLU_TESS_ERROR5;

GLU_TESS_NEED_COMBINE_CALLBACK = GLU_TESS_ERROR6;

GLU_AUTO_LOAD_MATRIX = 100200;

GLU_CULLING = 100201;

GLU_SAMPLING_TOLERANCE = 100203;

GLU_DISPLAY_MODE = 100204;

GLU_PARAMETRIC_TOLERANCE = 100202;

GLU_SAMPLING_METHOD = 100205;

GLU_U_STEP = 100206;

GLU_V_STEP = 100207;

GLU_PATH_LENGTH = 100215;

GLU_PARAMETRIC_ERROR = 100216;

GLU_DOMAIN_DISTANCE = 100217;

GLU_MAP1_TRIM_2 = 100210;

GLU_MAP1_TRIM_3 = 100211;

GLU_OUTLINE_POLYGON = 100240;

GLU_OUTLINE_PATCH = 100241;

GLU_NURBS_ERROR1 = 100251;

GLU_NURBS_ERROR2 = 100252;

GLU_NURBS_ERROR3 = 100253;

GLU_NURBS_ERROR4 = 100254;

GLU_NURBS_ERROR5 = 100255;

GLU_NURBS_ERROR6 = 100256;

GLU_NURBS_ERROR7 = 100257;

GLU_NURBS_ERROR8 = 100258;

GLU_NURBS_ERROR9 = 100259;

GLU_NURBS_ERROR10 = 100260;

GLU_NURBS_ERROR11 = 100261;

GLU_NURBS_ERROR12 = 100262;

GLU_NURBS_ERROR13 = 100263;

GLU_NURBS_ERROR14 = 100264;

GLU_NURBS_ERROR15 = 100265;

GLU_NURBS_ERROR16 = 100266;

GLU_NURBS_ERROR17 = 100267;

GLU_NURBS_ERROR18 = 100268;

GLU_NURBS_ERROR19 = 100269;

GLU_NURBS_ERROR20 = 100270;

GLU_NURBS_ERROR21 = 100271;

GLU_NURBS_ERROR22 = 100272;

GLU_NURBS_ERROR23 = 100273;

GLU_NURBS_ERROR24 = 100274;

GLU_NURBS_ERROR25 = 100275;

GLU_NURBS_ERROR26 = 100276;

GLU_NURBS_ERROR27 = 100277;

GLU_NURBS_ERROR28 = 100278;

GLU_NURBS_ERROR29 = 100279;

GLU_NURBS_ERROR30 = 100280;

GLU_NURBS_ERROR31 = 100281;

GLU_NURBS_ERROR32 = 100282;

GLU_NURBS_ERROR33 = 100283;

GLU_NURBS_ERROR34 = 100284;

GLU_NURBS_ERROR35 = 100285;

GLU_NURBS_ERROR36 = 100286;

GLU_NURBS_ERROR37 = 100287;

GLU_CW = 100120;

GLU_CCW = 100121;

GLU_INTERIOR = 100122;

GLU_EXTERIOR = 100123;

GLU_UNKNOWN = 100124;

GLU_BEGIN = GLU_TESS_BEGIN;

GLU_VERTEX = GLU_TESS_VERTEX;

GLU_END = GLU_TESS_END;

GLU_ERROR = GLU_TESS_ERROR;

GLU_EDGE_FLAG = GLU_TESS_EDGE_FLAG;

Description

Types

PGLChar = PAnsiChar;

TGLString = AnsiString;

GLenum = UINT;

TGLenum = UINT;

PGLenum = ˆTGLenum;

GLboolean = BYTEBOOL;

TGLboolean = BYTEBOOL;

PGLboolean = ˆTGLboolean;

GLbitfield = UINT;

TGLbitfield = UINT;

PGLbitfield = ˆTGLbitfield;

GLbyte = ShortInt;

TGLbyte = ShortInt;

PGLbyte = ˆTGLbyte;

GLshort = SmallInt;

TGLshort = SmallInt;

PGLshort = ˆTGLshort;

GLint = Integer;

TGLint = Integer;

PGLint = ˆInteger;

GLsizei = Integer;

TGLsizei = Integer;

PGLsizei = ˆTGLsizei;

GLint64 = Int64;

TGLint64 = Int64;

PGLint64 = ˆTGLInt64;

GLint64EXT = Int64;

TGLint64EXT = Int64;

PGLint64EXT = ˆTGLint64EXT;

GLuint64 = UInt64;

TGLuint64 = UInt64;

PGLuint64 = ˆTGLuint64;

GLuint64EXT = UInt64;

TGLuint64EXT = UInt64;

PGLuint64EXT = ˆTGLuint64EXT;

GLubyte = Byte;

TGLubyte = Byte;

PGLubyte = System.PByte;

GLushort = Word;

TGLushort = Word;

PGLushort = System.PWord;

GLuint = UINT;

TGLuint = UINT;

PGLuint = ˆTGLuint;

GLfloat = Single;

TGLfloat = Single;

PGLfloat = System.PSingle;

GLclampf = Single;

TGLclampf = Single;

PGLclampf = ˆTGLclampf;

GLdouble = Double;

TGLdouble = Double;

PGLdouble = System.PDouble;

GLclampd = Double;

TGLclampd = Double;

PGLclampd = ˆTGLclampd;

GLhandleARB = Cardinal;

PGLhandleARB = ˆGLhandleARB;

PGLPCharArray = ˆPGLChar;

PGLvoid = Pointer;

PGLPointer = ˆPointer;

GLintptr = PtrInt;

TGLintptr = PtrInt;

GLsizeiptr = SizeInt;

TGLsizeiptr = SizeInt;

GLsync = PtrInt;

TGLsync = PtrInt;

PWGLswap = ˆTWGLswap;

TWGLswap = _WGLSWAP;

WGLSWAP = _WGLSWAP;

HPBUFFERARB = Integer;

PHGPUNV = ˆHGPUNV;

HGPUNV = THandle;

PGPUDevice = ˆTGPUDevice;

TDebugProc = procedure( source: GLenum; type_: GLenum; id: GLuint; severity: GLenum; length: GLsizei; const message: PGLchar; userParam: Pointer); stdcall;

TGLDEBUGPROCARB = TDebugProc;

TDebugProcAMD = procedure( id: GLuint; category: GLenum; severity: GLenum; length: GLsizei; message: PGLchar; userParam: Pointer); stdcall;

TGLvdpauSurfaceNV = GLintptr;

PGLvdpauSurfaceNV = ˆTGLvdpauSurfaceNV;

PGLUNurbs = ˆTGLUNurbs;

PGLUQuadric = ˆTGLUQuadric;

PGLUTesselator= ˆTGLUTesselator;

TGLUNurbsObj = TGLUNurbs;

TGLUQuadricObj = TGLUQuadric;

TGLUTesselatorObj = TGLUTesselator;

TGLUTriangulatorObj = TGLUTesselator;

PGLUNurbsObj = PGLUNurbs;

PGLUQuadricObj = PGLUQuadric;

PGLUTesselatorObj = PGLUTesselator;

PGLUTriangulatorObj = PGLUTesselator;

TGLUQuadricErrorProc = procedure(errorCode: TGLEnum); stdcall;

TGLUTessBeginProc = procedure(AType: TGLEnum); stdcall;

TGLUTessEdgeFlagProc = procedure(Flag: TGLboolean); stdcall;

TGLUTessVertexProc = procedure(VertexData: Pointer); stdcall;

TGLUTessEndProc = procedure; stdcall;

TGLUTessErrorProc = procedure(ErrNo: TGLEnum); stdcall;

TGLUTessCombineProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer); stdcall;

TGLUTessBeginDataProc = procedure(AType: TGLEnum; UserData: Pointer); stdcall;

TGLUTessEdgeFlagDataProc = procedure(Flag: TGLboolean; UserData: Pointer); stdcall;

TGLUTessVertexDataProc = procedure(VertexData: Pointer; UserData: Pointer); stdcall;

TGLUTessEndDataProc = procedure(UserData: Pointer); stdcall;

TGLUTessErrorDataProc = procedure(ErrNo: TGLEnum; UserData: Pointer); stdcall;

TGLUTessCombineDataProc = procedure(const Coords: TVector3d; const VertexData: TVector4p; const Weight: TVector4f; OutData: PGLPointer; UserData: Pointer); stdcall;

TGLUNurbsErrorProc = procedure(ErrorCode: TGLEnum); stdcall;

PFNGLBLENDCOLORPROC = procedure(red, green, blue, alpha: TGLclampf); stdcall;

PFNGLBLENDEQUATIONPROC = procedure(mode: TGLEnum); stdcall;

PFNGLDRAWRANGEELEMENTSPROC = procedure(mode: TGLEnum; Astart, Aend: TGLuint; count: TGLsizei; Atype: TGLEnum; indices: Pointer); stdcall;

PFNGLTEXIMAGE3DPROC = procedure(target: TGLEnum; level: TGLint; internalformat: TGLEnum; width, height, depth: TGLsizei; border: TGLint; format: TGLEnum; Atype: TGLEnum; pixels: Pointer); stdcall;

PFNGLTEXSUBIMAGE3DPROC = procedure(target: TGLEnum; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format: TGLEnum; Atype: TGLEnum; pixels: Pointer); stdcall;

PFNGLCOPYTEXSUBIMAGE3DPROC = procedure(target: TGLEnum; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

PFNGLCOLORTABLEPROC = procedure(target, internalformat: TGLEnum; width: TGLsizei; format, Atype: TGLEnum; table: Pointer); stdcall;

PFNGLCOLORTABLEPARAMETERFVPROC = procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;

PFNGLCOLORTABLEPARAMETERIVPROC = procedure(target, pname: TGLEnum; params: PGLint); stdcall;

PFNGLCOPYCOLORTABLEPROC = procedure(target, internalformat: TGLEnum; x, y: TGLint; width: TGLsizei); stdcall;

PFNGLGETCOLORTABLEPROC = procedure(target, format, Atype: TGLEnum; table: Pointer); stdcall;

PFNGLGETCOLORTABLEPARAMETERFVPROC = procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;

PFNGLGETCOLORTABLEPARAMETERIVPROC = procedure(target, pname: TGLEnum; params: PGLint); stdcall;

PFNGLCOLORSUBTABLEPROC = procedure(target: TGLEnum; start, count: TGLsizei; format, Atype: TGLEnum; data: Pointer); stdcall;

PFNGLCOPYCOLORSUBTABLEPROC = procedure(target: TGLEnum; start: TGLsizei; x, y: TGLint; width: TGLsizei); stdcall;

PFNGLCONVOLUTIONFILTER1DPROC = procedure(target, internalformat: TGLEnum; width: TGLsizei; format, Atype: TGLEnum; image: Pointer); stdcall;

PFNGLCONVOLUTIONFILTER2DPROC = procedure(target, internalformat: TGLEnum; width, height: TGLsizei; format, Atype: TGLEnum; image: Pointer); stdcall;

PFNGLCONVOLUTIONPARAMETERFPROC = procedure(target, pname: TGLEnum; param: TGLfloat); stdcall;

PFNGLCONVOLUTIONPARAMETERFVPROC = procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;

PFNGLCONVOLUTIONPARAMETERIPROC = procedure(target, pname: TGLEnum; param: TGLint); stdcall;

PFNGLCONVOLUTIONPARAMETERIVPROC = procedure(target, pname: TGLEnum; params: PGLint); stdcall;

PFNGLCOPYCONVOLUTIONFILTER1DPROC = procedure(target, internalformat: TGLEnum; x, y: TGLint; width: TGLsizei); stdcall;

PFNGLCOPYCONVOLUTIONFILTER2DPROC = procedure(target, internalformat: TGLEnum; x, y: TGLint; width, height: TGLsizei); stdcall;

PFNGLGETCONVOLUTIONFILTERPROC = procedure(target, internalformat, Atype: TGLEnum; image: Pointer); stdcall;

PFNGLGETCONVOLUTIONPARAMETERFVPROC = procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;

PFNGLGETCONVOLUTIONPARAMETERIVPROC = procedure(target, pname: TGLEnum; params: PGLint); stdcall;

PFNGLGETSEPARABLEFILTERPROC = procedure(target, format, Atype: TGLEnum; row, column, span: Pointer); stdcall;

PFNGLSEPARABLEFILTER2DPROC = procedure(target, internalformat: TGLEnum; width, height: TGLsizei; format, Atype: TGLEnum; row, column: Pointer); stdcall;

PFNGLGETHISTOGRAMPROC = procedure(target: TGLEnum; reset: TGLboolean; format, Atype: TGLEnum; values: Pointer); stdcall;

PFNGLGETHISTOGRAMPARAMETERFVPROC = procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;

PFNGLGETHISTOGRAMPARAMETERIVPROC = procedure(target, pname: TGLEnum; params: PGLint); stdcall;

PFNGLGETMINMAXPROC = procedure(target: TGLEnum; reset: TGLboolean; format, Atype: TGLEnum; values: Pointer); stdcall;

PFNGLGETMINMAXPARAMETERFVPROC = procedure(target, pname: TGLEnum; params: PGLfloat); stdcall;

PFNGLGETMINMAXPARAMETERIVPROC = procedure(target, pname: TGLEnum; params: PGLint); stdcall;

PFNGLHISTOGRAMPROC = procedure(target: TGLEnum; width: TGLsizei; internalformat: TGLEnum; sink: TGLboolean); stdcall;

PFNGLMINMAXPROC = procedure(target, internalformat: TGLEnum; sink: TGLboolean); stdcall;

PFNGLRESETHISTOGRAMPROC = procedure(target: TGLEnum); stdcall;

PFNGLRESETMINMAXPROC = procedure(target: TGLEnum); stdcall;

PFNGLACTIVETEXTUREPROC = procedure(texture: TGLenum); stdcall;

PFNGLSAMPLECOVERAGEPROC = procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

PFNGLCOMPRESSEDTEXIMAGE3DPROC = procedure(target: TGLenum; level: TGLint; internalformat: TGLenum; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXIMAGE2DPROC = procedure(target: TGLenum; level: TGLint; internalformat: TGLenum; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXIMAGE1DPROC = procedure(target: TGLenum; level: TGLint; internalformat: TGLenum; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC = procedure(target: TGLenum; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: TGLenum; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC = procedure(target: TGLenum; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: TGLenum; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC = procedure(target: TGLenum; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: TGLenum; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLGETCOMPRESSEDTEXIMAGEPROC = procedure(target: TGLenum; level: TGLint; img: pointer); stdcall;

PFNGLCLIENTACTIVETEXTUREPROC = procedure(texture: TGLenum); stdcall;

PFNGLMULTITEXCOORD1DPROC = procedure(target: TGLenum; s: TGLdouble); stdcall;

PFNGLMULTITEXCOORD1DVPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD1FPROC = procedure(target: TGLenum; s: TGLfloat); stdcall;

PFNGLMULTITEXCOORD1FVPROC = procedure(target: TGLenum; v: TGLfloat); stdcall;

PFNGLMULTITEXCOORD1IPROC = procedure(target: TGLenum; s: TGLint); stdcall;

PFNGLMULTITEXCOORD1IVPROC = procedure(target: TGLenum; v: PGLInt); stdcall;

PFNGLMULTITEXCOORD1SPROC = procedure(target: TGLenum; s: TGLshort); stdcall;

PFNGLMULTITEXCOORD1SVPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLMULTITEXCOORD2DPROC = procedure(target: TGLenum; s, t: TGLdouble); stdcall;

PFNGLMULTITEXCOORD2DVPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD2FPROC = procedure(target: TGLenum; s, t: TGLfloat); stdcall;

PFNGLMULTITEXCOORD2FVPROC = procedure(target: TGLenum; v: PGLfloat); stdcall;

PFNGLMULTITEXCOORD2IPROC = procedure(target: TGLenum; s, t: TGLint); stdcall;

PFNGLMULTITEXCOORD2IVPROC = procedure(target: TGLenum; v: PGLint); stdcall;

PFNGLMULTITEXCOORD2SPROC = procedure(target: TGLenum; s, t: TGLshort); stdcall;

PFNGLMULTITEXCOORD2SVPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLMULTITEXCOORD3DPROC = procedure(target: TGLenum; s, t, r: TGLdouble); stdcall;

PFNGLMULTITEXCOORD3DVPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD3FPROC = procedure(target: TGLenum; s, t, r: TGLfloat); stdcall;

PFNGLMULTITEXCOORD3FVPROC = procedure(target: TGLenum; v: PGLfloat); stdcall;

PFNGLMULTITEXCOORD3IPROC = procedure(target: TGLenum; s, t, r: TGLint); stdcall;

PFNGLMULTITEXCOORD3IVPROC = procedure(target: TGLenum; v: PGLint); stdcall;

PFNGLMULTITEXCOORD3SPROC = procedure(target: TGLenum; s, t, r: TGLshort); stdcall;

PFNGLMULTITEXCOORD3SVPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLMULTITEXCOORD4DPROC = procedure(target: TGLenum; s, t, r, q: TGLdouble); stdcall;

PFNGLMULTITEXCOORD4DVPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD4FPROC = procedure(target: TGLenum; s, t, r, q: TGLfloat); stdcall;

PFNGLMULTITEXCOORD4FVPROC = procedure(target: TGLenum; v: PGLfloat); stdcall;

PFNGLMULTITEXCOORD4IPROC = procedure(target: TGLenum; s, t, r, q: TGLint); stdcall;

PFNGLMULTITEXCOORD4IVPROC = procedure(target: TGLenum; v: PGLint); stdcall;

PFNGLMULTITEXCOORD4SPROC = procedure(target: TGLenum; s, t, r, q: TGLshort); stdcall;

PFNGLMULTITEXCOORD4SVPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLLOADTRANSPOSEMATRIXFPROC = procedure(m: PGLfloat); stdcall;

PFNGLLOADTRANSPOSEMATRIXDPROC = procedure(m: PGLdouble); stdcall;

PFNGLMULTTRANSPOSEMATRIXFPROC = procedure(m: PGLfloat); stdcall;

PFNGLMULTTRANSPOSEMATRIXDPROC = procedure(m: PGLdouble); stdcall;

PFNGLBLENDFUNCSEPARATEPROC = procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: TGLenum); stdcall;

PFNGLMULTIDRAWARRAYSPROC = procedure(mode: TGLenum; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

PFNGLMULTIDRAWELEMENTSPROC = procedure(mode: TGLenum; Count: PGLsizei; AType: TGLenum; var indices; primcount: TGLsizei); stdcall;

PFNGLPOINTPARAMETERFPROC = procedure(pname: TGLenum; param: TGLfloat); stdcall;

PFNGLPOINTPARAMETERFVPROC = procedure(pname: TGLenum; params: PGLfloat); stdcall;

PFNGLPOINTPARAMETERIPROC = procedure(pname: TGLenum; param: TGLint); stdcall;

PFNGLPOINTPARAMETERIVPROC = procedure(pname: TGLenum; params: PGLint); stdcall;

PFNGLFOGCOORDFPROC = procedure(coord: TGLfloat); stdcall;

PFNGLFOGCOORDFVPROC = procedure(coord: PGLfloat); stdcall;

PFNGLFOGCOORDDPROC = procedure(coord: TGLdouble); stdcall;

PFNGLFOGCOORDDVPROC = procedure(coord: PGLdouble); stdcall;

PFNGLFOGCOORDPOINTERPROC = procedure(AType: TGLenum; stride: TGLsizei; p: Pointer); stdcall;

PFNGLSECONDARYCOLOR3BPROC = procedure(red, green, blue: TGLbyte); stdcall;

PFNGLSECONDARYCOLOR3BVPROC = procedure(v: PGLbyte); stdcall;

PFNGLSECONDARYCOLOR3DPROC = procedure(red, green, blue: TGLdouble); stdcall;

PFNGLSECONDARYCOLOR3DVPROC = procedure(v: PGLdouble); stdcall;

PFNGLSECONDARYCOLOR3FPROC = procedure(red, green, blue: TGLfloat); stdcall;

PFNGLSECONDARYCOLOR3FVPROC = procedure(v: PGLfloat); stdcall;

PFNGLSECONDARYCOLOR3IPROC = procedure(red, green, blue: TGLint); stdcall;

PFNGLSECONDARYCOLOR3IVPROC = procedure(v: PGLint); stdcall;

PFNGLSECONDARYCOLOR3SPROC = procedure(red, green, blue: TGLshort); stdcall;

PFNGLSECONDARYCOLOR3SVPROC = procedure(v: PGLshort); stdcall;

PFNGLSECONDARYCOLOR3UBPROC = procedure(red, green, blue: TGLubyte); stdcall;

PFNGLSECONDARYCOLOR3UBVPROC = procedure(v: PGLubyte); stdcall;

PFNGLSECONDARYCOLOR3UIPROC = procedure(red, green, blue: TGLuint); stdcall;

PFNGLSECONDARYCOLOR3UIVPROC = procedure(v: PGLuint); stdcall;

PFNGLSECONDARYCOLOR3USPROC = procedure(red, green, blue: TGLushort); stdcall;

PFNGLSECONDARYCOLOR3USVPROC = procedure(v: PGLushort); stdcall;

PFNGLSECONDARYCOLORPOINTERPROC = procedure(Size: TGLint; Atype: TGLenum; stride: TGLsizei; p: pointer); stdcall;

PFNGLWINDOWPOS2DPROC = procedure(x,y : TGLdouble); stdcall;

PFNGLWINDOWPOS2DVPROC = procedure(v : PGLdouble); stdcall;

PFNGLWINDOWPOS2FPROC = procedure(x,y : TGLfloat); stdcall;

PFNGLWINDOWPOS2FVPROC = procedure(v : PGLfloat); stdcall;

PFNGLWINDOWPOS2IPROC = procedure(x,y : TGLint); stdcall;

PFNGLWINDOWPOS2IVPROC = procedure(v : PGLint); stdcall;

PFNGLWINDOWPOS2SPROC = procedure(x,y : TGLshort); stdcall;

PFNGLWINDOWPOS2SVPROC = procedure(v : PGLshort); stdcall;

PFNGLWINDOWPOS3DPROC = procedure(x,y,z : TGLdouble); stdcall;

PFNGLWINDOWPOS3DVPROC = procedure(v : PGLdouble); stdcall;

PFNGLWINDOWPOS3FPROC = procedure(x,y,z : TGLfloat); stdcall;

PFNGLWINDOWPOS3FVPROC = procedure(v : PGLfloat); stdcall;

PFNGLWINDOWPOS3IPROC = procedure(x,y,z : TGLint); stdcall;

PFNGLWINDOWPOS3IVPROC = procedure(v : PGLint); stdcall;

PFNGLWINDOWPOS3SPROC = procedure(x,y,z : TGLshort); stdcall;

PFNGLWINDOWPOS3SVPROC = procedure(v : PGLshort); stdcall;

PFNGLGENQUERIESPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

PFNGLDELETEQUERIESPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

PFNGLISQUERYPROC = function(id: TGLuint): TGLboolean; stdcall;

PFNGLBEGINQUERYPROC = procedure(target: TGLenum; id: TGLuint); stdcall;

PFNGLENDQUERYPROC = procedure(target: TGLenum); stdcall;

PFNGLGETQUERYIVPROC = procedure(target: TGLEnum; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETQUERYOBJECTIVPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETQUERYOBJECTUIVPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLuint); stdcall;

PFNGLBINDBUFFERPROC = procedure(target: GLenum; buffer: GLuint); stdcall;

PFNGLDELETEBUFFERSPROC = procedure(n: GLsizei; const buffers: PGLuint); stdcall;

PFNGLGENBUFFERSPROC = procedure(n: GLsizei; buffers: PGLuint); stdcall;

PFNGLISBUFFERPROC = function(buffer: GLuint): GLboolean; stdcall;

PFNGLBUFFERDATAPROC = procedure(target: GLenum; size: GLsizei; const data: Pointer; usage: GLenum); stdcall;

PFNGLBUFFERSUBDATAPROC = procedure(target: GLenum; offset: GLuint; size: GLsizei; const data: Pointer); stdcall;

PFNGLGETBUFFERSUBDATAPROC = procedure(target: GLenum; offset: GLuint; size: GLsizei; data: Pointer); stdcall;

PFNGLMAPBUFFERPROC = function(target: GLenum; access: GLenum): Pointer; stdcall;

PFNGLUNMAPBUFFERPROC = function(target: GLenum): GLboolean; stdcall;

PFNGLGETBUFFERPARAMETERIVPROC = procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETBUFFERPOINTERVPROC = procedure(target: GLenum; pname: GLenum; params: Pointer); stdcall;

PFNGLBLENDEQUATIONSEPARATEPROC = procedure(modeRGB: TGLenum; modeAlpha: TGLenum); stdcall;

PFNGLDRAWBUFFERSPROC = procedure(n: GLSizei; const bufs: PGLenum); stdcall;

PFNGLSTENCILOPSEPARATEPROC = procedure(face, sfail, dpfail, dppass: TGLenum); stdcall;

PFNGLSTENCILFUNCSEPARATEPROC = procedure(face, func: TGLenum; ref: TGLint; mask: TGLuint); stdcall;

PFNGLSTENCILMASKSEPARATEPROC = procedure(face: TGLenum; mask: TGLuint); stdcall;

PFNGLATTACHSHADERPROC = procedure(_program: TGLuint; shader: TGLuint); stdcall;

PFNGLBINDATTRIBLOCATIONPROC = procedure(_program: TGLuint; index: TGLuint; const name: PGLChar); stdcall;

PFNGLCOMPILESHADERPROC = procedure(shader: TGLuint); stdcall;

PFNGLCREATEPROGRAMPROC = function(): TGLuint; stdcall;

PFNGLCREATESHADERPROC = function(_type: TGLenum): TGLuint; stdcall;

PFNGLDELETEPROGRAMPROC = procedure(_program: TGLuint); stdcall;

PFNGLDELETESHADERPROC = procedure(shader: TGLuint); stdcall;

PFNGLDETACHSHADERPROC = procedure(_program: TGLuint; shader: TGLuint); stdcall;

PFNGLDISABLEVERTEXATTRIBARRAYPROC = procedure(index: TGLuint); stdcall;

PFNGLENABLEVERTEXATTRIBARRAYPROC = procedure(index: TGLuint); stdcall;

PFNGLGETACTIVEATTRIBPROC = procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

PFNGLGETACTIVEUNIFORMPROC = procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

PFNGLGETATTACHEDSHADERSPROC = procedure(_program: TGLuint; maxCount: TGLsizei; count: PGLSizei; obj: PGLuint); stdcall;

PFNGLGETATTRIBLOCATIONPROC = function(_program: TGLuint; const name: PGLChar): TGLint; stdcall;

PFNGLGETPROGRAMIVPROC = procedure(_program: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETPROGRAMINFOLOGPROC = procedure(_program: TGLuint; bufSize: TGLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

PFNGLGETSHADERIVPROC = procedure(shader: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETSHADERINFOLOGPROC = procedure(shader: TGLuint; bufSize: TGLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

PFNGLGETSHADERSOURCEPROC = procedure(shader:TGLuint; bufSize: TGLsizei; length: PGLsizei; source: PGLChar); stdcall;

PFNGLGETUNIFORMLOCATIONPROC = function(_program: TGLuint; const name: PGLChar): TGLint; stdcall;

PFNGLGETUNIFORMFVPROC = procedure(_program: TGLuint; location: TGLint; params: PGLfloat); stdcall;

PFNGLGETUNIFORMIVPROC = procedure(_program: TGLuint; location: TGLint; params: PGLint); stdcall;

PFNGLGETVERTEXATTRIBDVPROC = procedure(index:TGLuint; pname: TGLenum; params: PGLdouble); stdcall;

PFNGLGETVERTEXATTRIBFVPROC = procedure(index: TGLuint; pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETVERTEXATTRIBIVPROC = procedure(index: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETVERTEXATTRIBPOINTERVPROC = procedure(index: TGLuint; pname: TGLenum; _pointer:pointer); stdcall;

PFNGLISPROGRAMPROC = function(_program: TGLuint):TGLboolean; stdcall;

PFNGLISSHADERPROC = function(shader: TGLuint): TGLboolean; stdcall;

PFNGLLINKPROGRAMPROC = procedure(_program: TGLuint); stdcall;

PFNGLSHADERSOURCEPROC = procedure(shader: TGLuint; count: TGLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

PFNGLUSEPROGRAMPROC = procedure(_program: TGLuint); stdcall;

PFNGLUNIFORM1FPROC = procedure(location: GLint; v0: GLfloat); stdcall;

PFNGLUNIFORM2FPROC = procedure(location: GLint; v0: GLfloat; v1: GLfloat); stdcall;

PFNGLUNIFORM3FPROC = procedure(location: GLint; v0: GLfloat; v1: GLfloat; v2: GLfloat); stdcall;

PFNGLUNIFORM4FPROC = procedure(location: GLint; v0: GLfloat; v1: GLfloat; v2: GLfloat; v3: GLfloat); stdcall;

PFNGLUNIFORM1IPROC = procedure(location: GLint; v0: GLint); stdcall;

PFNGLUNIFORM2IPROC = procedure(location: GLint; v0: GLint; v1: GLint); stdcall;

PFNGLUNIFORM3IPROC = procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint); stdcall;

PFNGLUNIFORM4IPROC = procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint; v3: GLint); stdcall;

PFNGLUNIFORM1FVPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM2FVPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM3FVPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM4FVPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM1IVPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORM2IVPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORM3IVPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORM4IVPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORMMATRIX2FVPROC = procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX3FVPROC = procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX4FVPROC = procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

PFNGLVALIDATEPROGRAMPROC = procedure(_program: TGLuint); stdcall;

PFNGLVERTEXATTRIB1DPROC = procedure(index:TGLuint; x: TGLdouble); stdcall;

PFNGLVERTEXATTRIB1DVPROC = procedure(index:TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB1FPROC = procedure(index:TGLuint; x: TGLfloat); stdcall;

PFNGLVERTEXATTRIB1FVPROC = procedure(index:TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB1SPROC = procedure(index:TGLuint; x: TGLshort); stdcall;

PFNGLVERTEXATTRIB1SVPROC = procedure(index:TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB2DPROC = procedure(index:TGLuint; x,y: TGLdouble); stdcall;

PFNGLVERTEXATTRIB2DVPROC = procedure(index:TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB2FPROC = procedure(index:TGLuint; x,y: TGLfloat); stdcall;

PFNGLVERTEXATTRIB2FVPROC = procedure(index:TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB2SPROC = procedure(index:TGLuint; x,y: TGLshort); stdcall;

PFNGLVERTEXATTRIB2SVPROC = procedure(index:TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB3DPROC = procedure(index:TGLuint; x,y,z: TGLdouble); stdcall;

PFNGLVERTEXATTRIB3DVPROC = procedure(index:TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB3FPROC = procedure(index:TGLuint; x,y,z: TGLfloat); stdcall;

PFNGLVERTEXATTRIB3FVPROC = procedure(index:TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB3SPROC = procedure(index:TGLuint; x,y,z: TGLshort); stdcall;

PFNGLVERTEXATTRIB3SVPROC = procedure(index:TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4NBVPROC = procedure(index:TGLuint; v: PGLbyte); stdcall;

PFNGLVERTEXATTRIB4NIVPROC = procedure(index:TGLuint; v: PGLint); stdcall;

PFNGLVERTEXATTRIB4NSVPROC = procedure(index:TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4NUBPROC = procedure(index:TGLuint; x,y,z,w: TGLubyte); stdcall;

PFNGLVERTEXATTRIB4NUBVPROC = procedure(index:TGLuint; v: PGLubyte); stdcall;

PFNGLVERTEXATTRIB4NUIVPROC = procedure(index:TGLuint; v: PGLuint); stdcall;

PFNGLVERTEXATTRIB4NUSVPROC = procedure(index:TGLuint; v: PGLushort); stdcall;

PFNGLVERTEXATTRIB4BVPROC = procedure(index:TGLuint; v: PGLbyte); stdcall;

PFNGLVERTEXATTRIB4DPROC = procedure(index:TGLuint; x,y,z,w: TGLdouble); stdcall;

PFNGLVERTEXATTRIB4DVPROC = procedure(index:TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB4FPROC = procedure(index:TGLuint; x,y,z,w: TGLfloat); stdcall;

PFNGLVERTEXATTRIB4FVPROC = procedure(index:TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB4IVPROC = procedure(index:TGLuint; v: PGLint); stdcall;

PFNGLVERTEXATTRIB4SPROC = procedure(index:TGLuint; x,y,z,w: TGLshort); stdcall;

PFNGLVERTEXATTRIB4SVPROC = procedure(index:TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4UBVPROC = procedure(index:TGLuint; v: PGLubyte); stdcall;

PFNGLVERTEXATTRIB4UIVPROC = procedure(index:TGLuint; v: PGLuint); stdcall;

PFNGLVERTEXATTRIB4USVPROC = procedure(index:TGLuint; v: PGLushort); stdcall;

PFNGLVERTEXATTRIBPOINTERPROC = procedure(index:TGLuint; size: TGLint; _type: TGLenum; normalized: TGLboolean; stride:TGLsizei; _pointer:pointer); stdcall;

PFNGLUNIFORMMATRIX2X3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX3X2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX2X4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX4X2FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX3X4FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX4X3FVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLBoolean; value: PGLfloat); stdcall;

PFNGLVERTEXATTRIBI1IPROC = procedure(index: TGLuint; x: TGLint); stdcall;

PFNGLVERTEXATTRIBI2IPROC = procedure(index: TGLuint; x: TGLint; y: TGLint); stdcall;

PFNGLVERTEXATTRIBI3IPROC = procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint); stdcall;

PFNGLVERTEXATTRIBI4IPROC = procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

PFNGLVERTEXATTRIBI1UIPROC = procedure(index: TGLuint; x: TGLuint); stdcall;

PFNGLVERTEXATTRIBI2UIPROC = procedure(index: TGLuint; x: TGLuint; y: TGLuint); stdcall;

PFNGLVERTEXATTRIBI3UIPROC = procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint); stdcall;

PFNGLVERTEXATTRIBI4UIPROC = procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint; w: TGLuint); stdcall;

PFNGLVERTEXATTRIBI1IVPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI2IVPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI3IVPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI4IVPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI1UIVPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI2UIVPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI3UIVPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI4UIVPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI4BVPROC = procedure(index: TGLuint; v:PGLbyte); stdcall;

PFNGLVERTEXATTRIBI4SVPROC = procedure(index: TGLuint; v:PGLshort); stdcall;

PFNGLVERTEXATTRIBI4UBVPROC = procedure(index: TGLuint; v: PGLUbyte); stdcall;

PFNGLVERTEXATTRIBI4USVPROC = procedure(index: TGLuint; v: PGLushort); stdcall;

PFNGLVERTEXATTRIBIPOINTERPROC = procedure(index: TGLuint; size: TGLint; _type: TGLenum; stride: TGLsizei; _pointer: pointer); stdcall;

PFNGLGETVERTEXATTRIBIIVPROC = procedure(index: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETVERTEXATTRIBIUIVPROC = procedure(index: TGLuint; pname: TGLenum; params: PGLuint); stdcall;

PFNGLUNIFORM1UIPROC = procedure(location: TGLInt; v0: TGLuint); stdcall;

PFNGLUNIFORM2UIPROC = procedure(location: TGLInt; v0: TGLuint; v1: TGLuint); stdcall;

PFNGLUNIFORM3UIPROC = procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint); stdcall;

PFNGLUNIFORM4UIPROC = procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint; v3: TGLuint); stdcall;

PFNGLUNIFORM1UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLUNIFORM2UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLUNIFORM3UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLUNIFORM4UIVPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLGETUNIFORMUIVPROC = procedure(_program: TGLuint; location: TGLint; params: PGLuint); stdcall;

PFNGLBINDFRAGDATALOCATIONPROC = procedure(_program: TGLuint; colorNumber: TGLuint; name: PGLChar); stdcall;

PFNGLGETFRAGDATALOCATIONPROC = function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

PFNGLBEGINCONDITIONALRENDERPROC = procedure(id: TGLuint; mode: TGLenum); stdcall;

PFNGLENDCONDITIONALRENDERPROC = procedure(); stdcall;

PFNGLCLAMPCOLORPROC = procedure (target: TGLenum; clamp: TGLenum); stdcall;

PFNGLTEXPARAMETERIIVPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLTEXPARAMETERIUIVPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLuint); stdcall;

PFNGLGETTEXPARAMETERIIVPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETTEXPARAMETERIUIVPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLuint); stdcall;

PFNGLCOLORMASKIPROC = procedure(index: TGLuint; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

PFNGLGETBOOLEANI_VPROC = procedure(target: TGLenum; index: TGLuint; data: PGLboolean); stdcall;

PFNGLGETINTEGERI_VPROC = procedure(target: TGLenum; index: TGLuint; data: PGLint); stdcall;

PFNGLENABLEIPROC = procedure(target: TGLenum; index: TGLuint); stdcall;

PFNGLDISABLEIPROC = procedure(target: TGLenum; index: TGLuint); stdcall;

PFNGLISENABLEDIPROC = function(target: TGLenum; index: TGLuint): TGLboolean; stdcall;

PFNGLBINDBUFFERRANGEPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint; offset:TGLintptr; size: TGLsizeiptr); stdcall;

PFNGLBINDBUFFERBASEPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint); stdcall;

PFNGLBEGINTRANSFORMFEEDBACKPROC = procedure(primitiveMode: TGLenum); stdcall;

PFNGLENDTRANSFORMFEEDBACKPROC = procedure(); stdcall;

PFNGLTRANSFORMFEEDBACKVARYINGSPROC = procedure(_program: TGLuint; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: TGLenum); stdcall;

PFNGLGETTRANSFORMFEEDBACKVARYINGPROC = procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PGLenum; name: PGLChar); stdcall;

PFNGLCLEARBUFFERIVPROC = procedure(buffer: TGLenum; drawbuffer: TGLint; value: PGLint); stdcall;

PFNGLCLEARBUFFERUIVPROC = procedure(buffer: TGLenum; drawbuffer: TGLint; value: PGLuint); stdcall;

PFNGLCLEARBUFFERFVPROC = procedure(buffer: TGLenum; drawbuffer: TGLint; value: PGLfloat); stdcall;

PFNGLCLEARBUFFERFIPROC = procedure(buffer: TGLenum; drawbuffer: TGLint; depth: TGLfloat; stencil: TGLint); stdcall;

PFNGLGETSTRINGIPROC = function(name: TGLenum; index: TGLuint): PGLChar; stdcall;

PFNGLDRAWARRAYSINSTANCEDPROC = procedure(mode: TGLenum; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

PFNGLDRAWELEMENTSINSTANCEDPROC = procedure(mode: TGLenum; count: TGLsizei; _type: TGLenum; indices: PGLvoid; primcount: TGLsizei); stdcall;

PFNGLTEXBUFFERPROC = procedure(target: TGLenum; internalformat: TGLenum; buffer: TGLuint); stdcall;

PFNGLPRIMITIVERESTARTINDEXPROC = procedure(index: TGLuint); stdcall;

PFNGLGETINTEGER64I_VPROC = procedure(target: TGLenum; index: TGLuint; data: PGLint64); stdcall;

PFNGLGETBUFFERPARAMETERI64VPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLint64); stdcall;

PFNGLFRAMEBUFFERTEXTUREPROC = procedure(target: TGLenum; attachment: TGLenum; texture: TGLuint; level: TGLint); stdcall;

PFNGLVERTEXATTRIBDIVISORPROC = procedure(index: TGLuint; divisor: TGLuint); stdcall;

PFNGLBLENDEQUATIONIPROC = procedure(buf: TGLuint; mode: TGLenum); stdcall;

PFNGLBLENDEQUATIONSEPARATEIPROC = procedure(buf: TGLuint; modeRGB: TGLenum; modeAlpha: TGLenum); stdcall;

PFNGLBLENDFUNCIPROC = procedure(buf: TGLuint; src: TGLenum; dst: TGLenum); stdcall;

PFNGLBLENDFUNCSEPARATEIPROC = procedure(buf: TGLuint; srcRGB: TGLenum; dstRGB: TGLenum; srcAlpha: TGLenum; dstAlpha: TGLenum); stdcall;

PFNGLMINSAMPLESHADINGPROC = procedure(value: TGLclampf); stdcall;

PFNGLUNURBSCALLBACKDATAEXTPROC = procedure(nurb: PGLUnurbs; userData: Pointer); stdcall;

PFNGLUNEWNURBSTESSELLATOREXTPROC = function: PGLUnurbs; stdcall;

PFNGLUDELETENURBSTESSELLATOREXTPROC = procedure(nurb: PGLUnurbs); stdcall;

PFNWGLCREATEBUFFERREGIONARBPROC = function(DC: HDC; iLayerPlane: Integer; uType: TGLenum) : Integer; stdcall;

PFNWGLDELETEBUFFERREGIONARBPROC = procedure(hRegion: Integer); stdcall;

PFNWGLSAVEBUFFERREGIONARBPROC = function(hRegion: Integer; x, y, width, height: Integer): BOOL; stdcall;

PFNWGLRESTOREBUFFERREGIONARBPROC = function(hRegion: Integer; x, y, width, height: Integer; xSrc, ySrc: Integer): BOOL; stdcall;

PFNWGLGETEXTENSIONSSTRINGARBPROC = function(DC: HDC): PGLChar; stdcall;

PFNWGLGETPIXELFORMATATTRIBIVARBPROC = function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: TGLenum; const piAttributes: PGLint; piValues : PGLint) : BOOL; stdcall;

PFNWGLGETPIXELFORMATATTRIBFVARBPROC = function(DC: HDC; iPixelFormat, iLayerPlane: Integer; nAttributes: TGLenum; const piAttributes: PGLint; piValues: PGLFloat) : BOOL; stdcall;

PFNWGLCHOOSEPIXELFORMATARBPROC = function(DC: HDC; const piAttribIList: PGLint; const pfAttribFList: PGLFloat; nMaxFormats: GLuint; piFormats: PGLint; nNumFormats: PGLenum) : BOOL; stdcall;

PFNWGLMAKECONTEXTCURRENTARBPROC = function(hDrawDC: HDC; hReadDC: HDC; _hglrc: HGLRC): BOOL; stdcall;

PFNWGLGETCURRENTREADDCARBPROC = function(): HDC; stdcall;

PFNWGLCREATEPBUFFERARBPROC = function(DC: HDC; iPixelFormat: GLInt; iWidth, iHeight : GLInt; const piAttribList: PGLint) : HPBUFFERARB; stdcall;

PFNWGLGETPBUFFERDCARBPROC = function(hPbuffer: HPBUFFERARB) : HDC; stdcall;

PFNWGLRELEASEPBUFFERDCARBPROC = function(hPbuffer: HPBUFFERARB; DC: HDC) : Integer; stdcall;

PFNWGLDESTROYPBUFFERARBPROC = function(hPbuffer: HPBUFFERARB): BOOL; stdcall;

PFNWGLQUERYPBUFFERARBPROC = function(hPbuffer: HPBUFFERARB; iAttribute : Integer; piValue: PGLint) : BOOL; stdcall;

PFNWGLBINDTEXIMAGEARBPROC = function(hPbuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

PFNWGLRELEASETEXIMAGEARBPROC = function(hpBuffer: HPBUFFERARB; iBuffer: Integer): BOOL; stdcall;

PFNWGLSETPBUFFERATTRIBARBPROC = function(hpBuffer: HPBUFFERARB; const piAttribList: PGLint): BOOL; stdcall;

PFNWGLCREATECONTEXTATTRIBSARBPROC = function(DC: HDC; hShareContext: HGLRC; attribList: PGLint):HGLRC; stdcall;

PFNWGLSWAPINTERVALEXTPROC = function(interval : Integer) : BOOL; stdcall;

PFNWGLGETSWAPINTERVALEXTPROC = function : Integer; stdcall;

PFNWGLENUMGPUSNVPROC = function(iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean; stdcall;

PFNWGLENUMGPUDEVICESNVPROC = function(hGpu: HGPUNV; iDeviceIndex: Cardinal; lpGpuDevice: PGPUDevice): Boolean; stdcall;

PFNWGLCREATEAFFINITYDCNVPROC = function(hGpuList: PHGPUNV): HDC; stdcall;

PFNWGLENUMGPUSFROMAFFINITYDCNVPROC = function(hAffinityDC: HDC; iGpuIndex: Cardinal; var hGpu: HGPUNV): Boolean; stdcall;

PFNWGLDELETEDCNVPROC = function(hdc: HDC): Boolean; stdcall;

PFNWGLDXSETRESOURCESHAREHANDLEPROC = function (dxObject: Pointer; shareHandle: THandle): BOOL; stdcall;

PFNWGLDXOPENDEVICEPROC = function(dxDevice: Pointer): THandle; stdcall;

PFNWGLDXCLOSEDEVICEPROC = function(hDevice: THandle): BOOL; stdcall;

PFNWGLDXREGISTEROBJECTPROC = function(hDevice: THandle; dxObject: Pointer; name: GLuint; atype: GLuint; access: GLuint): THandle; stdcall;

PFNWGLDXUNREGISTEROBJECTPROC = function(hDevice: THandle; hObject: THandle): BOOL; stdcall;

PFNWGLDXOBJECTACCESSPROC = function(hObject: THandle; access: GLenum): BOOL; stdcall;

PFNWGLDXLOCKOBJECTSPROC = function(hDevice: THandle; count: GLint; hObjects: PHandle): BOOL; stdcall;

PFNWGLDXUNLOCKOBJECTSNVPROC = function (hDevice: THandle; count: GLint; hObjects: PHandle): BOOL; stdcall;

PFNGLSAMPLEPASSARBPROC = procedure(pass: TGLenum); stdcall;

PFNGLACTIVETEXTUREARBPROC = procedure(target: TGLenum); stdcall;

PFNGLCLIENTACTIVETEXTUREARBPROC = procedure(target: TGLenum); stdcall;

PFNGLMULTITEXCOORD1DARBPROC = procedure(target: TGLenum; s: TGLdouble); stdcall;

PFNGLMULTITEXCOORD1DVARBPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD1FARBPROC = procedure(target: TGLenum; s: TGLfloat); stdcall;

PFNGLMULTITEXCOORD1FVARBPROC = procedure(target: TGLenum; v: TGLfloat); stdcall;

PFNGLMULTITEXCOORD1IARBPROC = procedure(target: TGLenum; s: TGLint); stdcall;

PFNGLMULTITEXCOORD1IVARBPROC = procedure(target: TGLenum; v: PGLInt); stdcall;

PFNGLMULTITEXCOORD1SARBPROC = procedure(target: TGLenum; s: TGLshort); stdcall;

PFNGLMULTITEXCOORD1SVARBPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLMULTITEXCOORD2DARBPROC = procedure(target: TGLenum; s, t: TGLdouble); stdcall;

PFNGLMULTITEXCOORD2DVARBPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD2FARBPROC = procedure(target: TGLenum; s, t: TGLfloat); stdcall;

PFNGLMULTITEXCOORD2FVARBPROC = procedure(target: TGLenum; v: PGLfloat); stdcall;

PFNGLMULTITEXCOORD2IARBPROC = procedure(target: TGLenum; s, t: TGLint); stdcall;

PFNGLMULTITEXCOORD2IVARBPROC = procedure(target: TGLenum; v: PGLint); stdcall;

PFNGLMULTITEXCOORD2SARBPROC = procedure(target: TGLenum; s, t: TGLshort); stdcall;

PFNGLMULTITEXCOORD2SVARBPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLMULTITEXCOORD3DARBPROC = procedure(target: TGLenum; s, t, r: TGLdouble); stdcall;

PFNGLMULTITEXCOORD3DVARBPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD3FARBPROC = procedure(target: TGLenum; s, t, r: TGLfloat); stdcall;

PFNGLMULTITEXCOORD3FVARBPROC = procedure(target: TGLenum; v: PGLfloat); stdcall;

PFNGLMULTITEXCOORD3IARBPROC = procedure(target: TGLenum; s, t, r: TGLint); stdcall;

PFNGLMULTITEXCOORD3IVARBPROC = procedure(target: TGLenum; v: PGLint); stdcall;

PFNGLMULTITEXCOORD3SARBPROC = procedure(target: TGLenum; s, t, r: TGLshort); stdcall;

PFNGLMULTITEXCOORD3SVARBPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLMULTITEXCOORD4DARBPROC = procedure(target: TGLenum; s, t, r, q: TGLdouble); stdcall;

PFNGLMULTITEXCOORD4DVARBPROC = procedure(target: TGLenum; v: PGLdouble); stdcall;

PFNGLMULTITEXCOORD4FARBPROC = procedure(target: TGLenum; s, t, r, q: TGLfloat); stdcall;

PFNGLMULTITEXCOORD4FVARBPROC = procedure(target: TGLenum; v: PGLfloat); stdcall;

PFNGLMULTITEXCOORD4IARBPROC = procedure(target: TGLenum; s, t, r, q: TGLint); stdcall;

PFNGLMULTITEXCOORD4IVARBPROC = procedure(target: TGLenum; v: PGLint); stdcall;

PFNGLMULTITEXCOORD4SARBPROC = procedure(target: TGLenum; s, t, r, q: TGLshort); stdcall;

PFNGLMULTITEXCOORD4SVARBPROC = procedure(target: TGLenum; v: PGLshort); stdcall;

PFNGLLOADTRANSPOSEMATRIXFARBPROC = procedure(m: PGLfloat); stdcall;

PFNGLLOADTRANSPOSEMATRIXDARBPROC = procedure(m: PGLdouble); stdcall;

PFNGLMULTTRANSPOSEMATRIXFARBPROC = procedure(m: PGLfloat); stdcall;

PFNGLMULTTRANSPOSEMATRIXDARBPROC = procedure(m: PGLdouble); stdcall;

PFNGLSAMPLECOVERAGEARBPROC = procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

PFNGLCOMPRESSEDTEXIMAGE3DARBPROC = procedure(target: TGLenum; level: TGLint; internalformat: TGLenum; Width, Height, depth: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXIMAGE2DARBPROC = procedure(target: TGLenum; level: TGLint; internalformat: TGLenum; Width, Height: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXIMAGE1DARBPROC = procedure(target: TGLenum; level: TGLint; internalformat: TGLenum; Width: TGLsizei; border: TGLint; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXSUBIMAGE3DARBPROC = procedure(target: TGLenum; level: TGLint; xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; Format: TGLenum; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXSUBIMAGE2DARBPROC = procedure(target: TGLenum; level: TGLint; xoffset, yoffset: TGLint; width, height: TGLsizei; Format: TGLenum; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLCOMPRESSEDTEXSUBIMAGE1DARBPROC = procedure(target: TGLenum; level: TGLint; xoffset: TGLint; width: TGLsizei; Format: TGLenum; imageSize: TGLsizei; data: pointer); stdcall;

PFNGLGETCOMPRESSEDTEXIMAGEARBPROC = procedure(target: TGLenum; level: TGLint; img: pointer); stdcall;

PFNGLPOINTPARAMETERFARBPROC = procedure(pname: TGLenum; param: TGLfloat); stdcall;

PFNGLPOINTPARAMETERFVARBPROC = procedure(pname: TGLenum; params: PGLfloat); stdcall;

PFNGLWEIGHTBVARBPROC = procedure(size: TGLint; weights: PGLbyte); stdcall;

PFNGLWEIGHTSVARBPROC = procedure(size: TGLint; weights: PGLshort); stdcall;

PFNGLWEIGHTIVARBPROC = procedure(size: TGLint; weights: PGLint); stdcall;

PFNGLWEIGHTFVARBPROC = procedure(size: TGLint; weights: PGLfloat); stdcall;

PFNGLWEIGHTDVARBPROC = procedure(size: TGLint; weights: PGLdouble); stdcall;

PFNGLWEIGHTUBVARBPROC = procedure(size: TGLint; weights: PGLubyte); stdcall;

PFNGLWEIGHTUSVARBPROC = procedure(size: TGLint; weights: PGLushort); stdcall;

PFNGLWEIGHTUIVARBPROC = procedure(size: TGLint; weights: PGLuint); stdcall;

PFNGLWEIGHTPOINTERARBPROC = procedure(size: TGLint; _type: TGLenum; stride:TGLsizei; _pointer:pointer); stdcall;

PFNGLVERTEXBLENDARBPROC = procedure(count: TGLint); stdcall;

PFNGLCURRENTPALETTEMATRIXARBPROC = procedure(index: TGLint); stdcall;

PFNGLMATRIXINDEXUBVARBPROC = procedure(size: TGLint; indices: PGLubyte); stdcall;

PFNGLMATRIXINDEXUSVARBPROC = procedure(size: TGLint; indices: PGLushort); stdcall;

PFNGLMATRIXINDEXUIVARBPROC = procedure(size: TGLint; indices: PGLuint); stdcall;

PFNGLMATRIXINDEXPOINTERARBPROC = procedure(size: TGLint; _type: TGLenum; stride: TGLsizei; _pointer:pointer); stdcall;

PFNGLWINDOWPOS2DARBPROC = procedure(x,y : TGLdouble); stdcall;

PFNGLWINDOWPOS2DVARBPROC = procedure(v : PGLdouble); stdcall;

PFNGLWINDOWPOS2FARBPROC = procedure(x,y : TGLfloat); stdcall;

PFNGLWINDOWPOS2FVARBPROC = procedure(v : PGLfloat); stdcall;

PFNGLWINDOWPOS2IARBPROC = procedure(x,y : TGLint); stdcall;

PFNGLWINDOWPOS2IVARBPROC = procedure(v : PGLint); stdcall;

PFNGLWINDOWPOS2SARBPROC = procedure(x,y : TGLshort); stdcall;

PFNGLWINDOWPOS2SVARBPROC = procedure(v : PGLshort); stdcall;

PFNGLWINDOWPOS3DARBPROC = procedure(x,y,z : TGLdouble); stdcall;

PFNGLWINDOWPOS3DVARBPROC = procedure(v : PGLdouble); stdcall;

PFNGLWINDOWPOS3FARBPROC = procedure(x,y,z : TGLfloat); stdcall;

PFNGLWINDOWPOS3FVARBPROC = procedure(v : PGLfloat); stdcall;

PFNGLWINDOWPOS3IARBPROC = procedure(x,y,z : TGLint); stdcall;

PFNGLWINDOWPOS3IVARBPROC = procedure(v : PGLint); stdcall;

PFNGLWINDOWPOS3SARBPROC = procedure(x,y,z : TGLshort); stdcall;

PFNGLWINDOWPOS3SVARBPROC = procedure(v : PGLshort); stdcall;

PFNGLVERTEXATTRIB1DARBPROC = procedure(index: GLuint; x: GLdouble); stdcall;

PFNGLVERTEXATTRIB1DVARBPROC = procedure(index: GLuint; const v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB1FARBPROC = procedure(index: GLuint; x: GLfloat); stdcall;

PFNGLVERTEXATTRIB1FVARBPROC = procedure(index: GLuint; const v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB1SARBPROC = procedure(index: GLuint; x: GLshort); stdcall;

PFNGLVERTEXATTRIB1SVARBPROC = procedure(index: GLuint; const v: PGLshort); stdcall;

PFNGLVERTEXATTRIB2DARBPROC = procedure(index: GLuint; x: GLdouble; y: GLdouble); stdcall;

PFNGLVERTEXATTRIB2DVARBPROC = procedure(index: GLuint; const v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB2FARBPROC = procedure(index: GLuint; x: GLfloat; y: GLfloat); stdcall;

PFNGLVERTEXATTRIB2FVARBPROC = procedure(index: GLuint; const v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB2SARBPROC = procedure(index: GLuint; x: GLshort; y: GLshort); stdcall;

PFNGLVERTEXATTRIB2SVARBPROC = procedure(index: GLuint; const v: PGLshort); stdcall;

PFNGLVERTEXATTRIB3DARBPROC = procedure(index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble); stdcall;

PFNGLVERTEXATTRIB3DVARBPROC = procedure(index: GLuint; const v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB3FARBPROC = procedure(index: GLuint; x: GLfloat; y: GLfloat; z: GLfloat); stdcall;

PFNGLVERTEXATTRIB3FVARBPROC = procedure(index: GLuint; const v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB3SARBPROC = procedure(index: GLuint; x: GLshort; y: GLshort; z: GLshort); stdcall;

PFNGLVERTEXATTRIB3SVARBPROC = procedure(index: GLuint; const v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4NBVARBPROC = procedure(index: GLuint; const v: PGLbyte); stdcall;

PFNGLVERTEXATTRIB4NIVARBPROC = procedure(index: GLuint; const v: PGLint); stdcall;

PFNGLVERTEXATTRIB4NSVARBPROC = procedure(index: GLuint; const v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4NUBARBPROC = procedure(index: GLuint; x: GLubyte; y: GLubyte; z: GLubyte; w: GLubyte); stdcall;

PFNGLVERTEXATTRIB4NUBVARBPROC = procedure(index: GLuint; const v: PGLubyte); stdcall;

PFNGLVERTEXATTRIB4NUIVARBPROC = procedure(index: GLuint; const v: PGLuint); stdcall;

PFNGLVERTEXATTRIB4NUSVARBPROC = procedure(index: GLuint; const v: PGLushort); stdcall;

PFNGLVERTEXATTRIB4BVARBPROC = procedure(index: GLuint; const v: PGLbyte); stdcall;

PFNGLVERTEXATTRIB4DARBPROC = procedure(index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

PFNGLVERTEXATTRIB4DVARBPROC = procedure(index: GLuint; const v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB4FARBPROC = procedure(index: GLuint; x: GLfloat; y: GLfloat; z: GLfloat; w: GLfloat); stdcall;

PFNGLVERTEXATTRIB4FVARBPROC = procedure(index: GLuint; const v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB4IVARBPROC = procedure(index: GLuint; const v: PGLint); stdcall;

PFNGLVERTEXATTRIB4SARBPROC = procedure(index: GLuint; x: GLshort; y: GLshort; z: GLshort; w: GLshort); stdcall;

PFNGLVERTEXATTRIB4SVARBPROC = procedure(index: GLuint; const v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4UBVARBPROC = procedure(index: GLuint; const v: PGLubyte); stdcall;

PFNGLVERTEXATTRIB4UIVARBPROC = procedure(index: GLuint; const v: PGLuint); stdcall;

PFNGLVERTEXATTRIB4USVARBPROC = procedure(index: GLuint; const v: PGLushort); stdcall;

PFNGLVERTEXATTRIBPOINTERARBPROC = procedure(index: GLuint; size: GLint; _type: GLenum; normalized: GLboolean; stride: GLsizei; const _pointer: pointer); stdcall;

PFNGLENABLEVERTEXATTRIBARRAYARBPROC = procedure(index: GLuint); stdcall;

PFNGLDISABLEVERTEXATTRIBARRAYARBPROC = procedure(index: GLuint); stdcall;

PFNGLPROGRAMSTRINGARBPROC = procedure(target: GLenum; format: GLenum; len: GLsizei; const _string: pointer); stdcall;

PFNGLBINDPROGRAMARBPROC = procedure(target: GLenum; _program: GLuint); stdcall;

PFNGLDELETEPROGRAMSARBPROC = procedure(n: GLsizei; const programs: PGLuint); stdcall;

PFNGLGENPROGRAMSARBPROC = procedure(n: GLsizei; programs: PGLuint); stdcall;

PFNGLPROGRAMENVPARAMETER4DARBPROC = procedure(target: GLenum; index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

PFNGLPROGRAMENVPARAMETER4DVARBPROC = procedure(target: GLenum; index: GLuint; const params: PGLdouble); stdcall;

PFNGLPROGRAMENVPARAMETER4FARBPROC = procedure(target: GLenum; index: GLuint; x: GLfloat; y: GLfloat; z: GLfloat; w: GLfloat); stdcall;

PFNGLPROGRAMENVPARAMETER4FVARBPROC = procedure(target: GLenum; index: GLuint; const params: PGLfloat); stdcall;

PFNGLPROGRAMLOCALPARAMETER4DARBPROC = procedure(target: GLenum; index: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

PFNGLPROGRAMLOCALPARAMETER4DVARBPROC = procedure(target: GLenum; index: GLuint; const params: PGLdouble); stdcall;

PFNGLPROGRAMLOCALPARAMETER4FARBPROC = procedure(target: GLenum; index: GLuint; x: GLfloat; y: GLfloat; z: GLfloat; w: GLfloat); stdcall;

PFNGLPROGRAMLOCALPARAMETER4FVARBPROC = procedure(target: GLenum; index: GLuint; const params: PGLfloat); stdcall;

PFNGLGETPROGRAMENVPARAMETERDVARBPROC = procedure(target: GLenum; index: GLuint; params: PGLdouble); stdcall;

PFNGLGETPROGRAMENVPARAMETERFVARBPROC = procedure(target: GLenum; index: GLuint; params: PGLfloat); stdcall;

PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC = procedure(target: GLenum; index: GLuint; params: PGLdouble); stdcall;

PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC = procedure(target: GLenum; index: GLuint; params: PGLfloat); stdcall;

PFNGLGETPROGRAMIVARBPROC = procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETPROGRAMSTRINGARBPROC = procedure(target: GLenum; pname: GLenum; _string: pointer); stdcall;

PFNGLGETVERTEXATTRIBDVARBPROC = procedure(index: GLuint; pname: GLenum; params: PGLdouble); stdcall;

PFNGLGETVERTEXATTRIBFVARBPROC = procedure(index: GLuint; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETVERTEXATTRIBIVARBPROC = procedure(index: GLuint; pname: GLenum; params: PGLint); stdcall;

PFNGLGETVERTEXATTRIBPOINTERVARBPROC = procedure(index: GLuint; pname: GLenum; _pointer: pointer); stdcall;

PFNGLISPROGRAMARBPROC = function(_program: GLuint): GLboolean; stdcall;

PFNGLBINDBUFFERARBPROC = procedure(target: GLenum; buffer: GLuint); stdcall;

PFNGLDELETEBUFFERSARBPROC = procedure(n: GLsizei; const buffers: PGLuint); stdcall;

PFNGLGENBUFFERSARBPROC = procedure(n: GLsizei; buffers: PGLuint); stdcall;

PFNGLISBUFFERARBPROC = function(buffer: GLuint): GLboolean; stdcall;

PFNGLBUFFERDATAARBPROC = procedure(target: GLenum; size: GLsizei; const data: Pointer; usage: GLenum); stdcall;

PFNGLBUFFERSUBDATAARBPROC = procedure(target: GLenum; offset: GLuint; size: GLsizei; const data: Pointer); stdcall;

PFNGLGETBUFFERSUBDATAARBPROC = procedure(target: GLenum; offset: GLuint; size: GLsizei; data: Pointer); stdcall;

PFNGLMAPBUFFERARBPROC = function(target: GLenum; access: GLenum): Pointer; stdcall;

PFNGLUNMAPBUFFERARBPROC = function(target: GLenum): GLboolean; stdcall;

PFNGLGETBUFFERPARAMETERIVARBPROC = procedure(target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETBUFFERPOINTERVARBPROC = procedure(target: GLenum; pname: GLenum; params: Pointer); stdcall;

PFNGLGENQUERIESARBPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

PFNGLDELETEQUERIESARBPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

PFNGLISQUERYARBPROC = function(id: TGLuint): TGLboolean; stdcall;

PFNGLBEGINQUERYARBPROC = procedure(target: TGLenum; id: TGLuint); stdcall;

PFNGLENDQUERYARBPROC = procedure(target: TGLenum); stdcall;

PFNGLGETQUERYIVARBPROC = procedure(target: TGLEnum; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETQUERYOBJECTIVARBPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETQUERYOBJECTUIVARBPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLuint); stdcall;

PFNGLDELETEOBJECTARBPROC = procedure(obj: GLhandleARB); stdcall;

PFNGLGETHANDLEARBPROC = function(pname: GLenum): GLhandleARB; stdcall;

PFNGLDETACHOBJECTARBPROC = procedure(containerObj: GLhandleARB; attachedObj: GLhandleARB); stdcall;

PFNGLCREATESHADEROBJECTARBPROC = function(shaderType: GLenum): GLhandleARB; stdcall;

PFNGLSHADERSOURCEARBPROC = procedure(shaderObj: GLhandleARB; count: GLsizei; const _string: PGLPCharArray; const length: PGLint); stdcall;

PFNGLCOMPILESHADERARBPROC = procedure(shaderObj: GLhandleARB); stdcall;

PFNGLCREATEPROGRAMOBJECTARBPROC = function(): GLhandleARB; stdcall;

PFNGLATTACHOBJECTARBPROC = procedure(containerObj: GLhandleARB; obj: GLhandleARB); stdcall;

PFNGLLINKPROGRAMARBPROC = procedure(programObj: GLhandleARB); stdcall;

PFNGLUSEPROGRAMOBJECTARBPROC = procedure(programObj: GLhandleARB); stdcall;

PFNGLVALIDATEPROGRAMARBPROC = procedure(programObj: GLhandleARB); stdcall;

PFNGLUNIFORM1FARBPROC = procedure(location: GLint; v0: GLfloat); stdcall;

PFNGLUNIFORM2FARBPROC = procedure(location: GLint; v0: GLfloat; v1: GLfloat); stdcall;

PFNGLUNIFORM3FARBPROC = procedure(location: GLint; v0: GLfloat; v1: GLfloat; v2: GLfloat); stdcall;

PFNGLUNIFORM4FARBPROC = procedure(location: GLint; v0: GLfloat; v1: GLfloat; v2: GLfloat; v3: GLfloat); stdcall;

PFNGLUNIFORM1IARBPROC = procedure(location: GLint; v0: GLint); stdcall;

PFNGLUNIFORM2IARBPROC = procedure(location: GLint; v0: GLint; v1: GLint); stdcall;

PFNGLUNIFORM3IARBPROC = procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint); stdcall;

PFNGLUNIFORM4IARBPROC = procedure(location: GLint; v0: GLint; v1: GLint; v2: GLint; v3: GLint); stdcall;

PFNGLUNIFORM1FVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM2FVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM3FVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM4FVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLfloat); stdcall;

PFNGLUNIFORM1IVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORM2IVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORM3IVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORM4IVARBPROC = procedure(location: GLint; count: GLsizei; value: PGLint); stdcall;

PFNGLUNIFORMMATRIX2FVARBPROC = procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX3FVARBPROC = procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

PFNGLUNIFORMMATRIX4FVARBPROC = procedure(location: GLint; count: GLsizei; transpose: GLboolean; value: PGLfloat); stdcall;

PFNGLGETOBJECTPARAMETERFVARBPROC = procedure(obj: GLhandleARB; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETOBJECTPARAMETERIVARBPROC = procedure(obj: GLhandleARB; pname: GLenum; params: PGLint); stdcall;

PFNGLGETINFOLOGARBPROC = procedure(obj: GLhandleARB; maxLength: GLsizei; length: PGLsizei; infoLog: PGLChar); stdcall;

PFNGLGETATTACHEDOBJECTSARBPROC = procedure(containerObj: GLhandleARB; maxCount: GLsizei; count: PGLsizei; obj: PGLhandleARB); stdcall;

PFNGLGETUNIFORMLOCATIONARBPROC = function(programObj: GLhandleARB; const name: PGLChar): GLint; stdcall;

PFNGLGETACTIVEUNIFORMARBPROC = procedure(programObj: GLhandleARB; index: GLuint; maxLength: GLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

PFNGLGETUNIFORMFVARBPROC = procedure(programObj: GLhandleARB; location: GLint; params: PGLfloat); stdcall;

PFNGLGETUNIFORMIVARBPROC = procedure(programObj: GLhandleARB; location: GLint; params: PGLint); stdcall;

PFNGLGETSHADERSOURCEARBPROC = procedure(obj: GLhandleARB; maxLength: GLsizei; length: PGLsizei; source: PGLChar); stdcall;

PFNGLBINDATTRIBLOCATIONARBPROC = procedure(programObj: GLhandleARB; index: GLuint; const name: PGLChar); stdcall;

PFNGLGETACTIVEATTRIBARBPROC = procedure(programObj: GLhandleARB; index: GLuint; maxLength: GLsizei; length: PGLsizei; size: PGLint; _type: PGLenum; name: PGLChar); stdcall;

PFNGLGETATTRIBLOCATIONARBPROC = function(programObj: GLhandleARB; const name: PGLChar): GLint; stdcall;

PFNGLDRAWBUFFERSARBPROC = procedure (n: GLSizei; const bufs: PGLenum); stdcall;

PFNGLCLAMPCOLORARBPROC = procedure (target: TGLenum; clamp: TGLenum); stdcall;

PFNGLDRAWARRAYSINSTANCEDARBPROC = procedure(mode: TGLenum; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

PFNGLDRAWELEMENTSINSTANCEDARBPROC = procedure(mode: TGLenum; count: TGLSizei; _type: TGLenum; indices: PGLvoid; primcount: TGLsizei); stdcall;

PFNGLISRENDERBUFFERPROC = function(renderbuffer: TGLuint): TGLBoolean; stdcall;

PFNGLBINDRENDERBUFFERPROC = procedure(target: TGLenum; renderbuffer: TGLuint); stdcall;

PFNGLDELETERENDERBUFFERSPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

PFNGLGENRENDERBUFFERSPROC = procedure(n: TGLSizei; renderbuffers: PGLuint); stdcall;

PFNGLRENDERBUFFERSTORAGEPROC = procedure(target: TGLenum; internalformat: TGLenum; width: TGLsizei; height: TGLsizei); stdcall;

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC = procedure(target: TGLenum; samples: TGLsizei; internalformat: TGLenum; width: TGLsizei; height: TGLsizei); stdcall;

PFNGLGETRENDERBUFFERPARAMETERIVPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLISFRAMEBUFFERPROC = function(framebuffer: TGLuint): TGLboolean; stdcall;

PFNGLBINDFRAMEBUFFERPROC = procedure(target: TGLenum; framebuffer: TGLuint); stdcall;

PFNGLDELETEFRAMEBUFFERSPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

PFNGLGENFRAMEBUFFERSPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

PFNGLCHECKFRAMEBUFFERSTATUSPROC = function(target: TGLenum): TGLenum; stdcall;

PFNGLFRAMEBUFFERTEXTURE1DPROC = procedure(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTURE2DPROC = procedure(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTURE3DPROC = procedure(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint; layer: TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTURELAYERPROC = procedure(target: TGLenum; attachment: TGLenum; texture: TGLuint; level: TGLint; layer: TGLint); stdcall;

PFNGLFRAMEBUFFERRENDERBUFFERPROC = procedure(target: TGLenum; attachment: TGLenum; renderbuffertarget: TGLenum; renderbuffer: TGLuint); stdcall;

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC = procedure(target: TGLenum; attachment: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLBLITFRAMEBUFFERPROC = procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: TGLenum); stdcall;

PFNGLGENERATEMIPMAPPROC = procedure(target: TGLenum); stdcall;

PFNGLPROGRAMPARAMETERIARBPROC = procedure ( _program:TGLuint; pname:TGLenum; value: TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTUREARBPROC = procedure ( target:TGLenum; attachment:TGLenum; texture:TGLuint; level:TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTURELAYERARBPROC = procedure ( target:TGLenum; attachment:TGLenum; texture:TGLuint; level:TGLint; layer:TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTUREFACEARBPROC = procedure ( target:TGLenum; attachment:TGLenum; texture:TGLuint; level:TGLint; face:TGLenum); stdcall;

PFNGLVERTEXATTRIBDIVISORARBPROC = procedure(index: TGLuint; divisor: TGLuint); stdcall;

PFNGLMAPBUFFERRANGEPROC = function(target: TGLenum; offset: TGLint; length: TGLsizei; access: TGLbitfield ): Pointer; stdcall;

PFNGLFLUSHMAPPEDBUFFERRANGEPROC = procedure( target: TGLenum; offset: TGLint; length: TGLsizei ); stdcall;

PFNGLTEXBUFFERARBPROC = procedure(target: TGLenum; internalformat: TGLEnum; buffer: TGLuint); stdcall;

PFNGLBINDVERTEXARRAYPROC = procedure(_array: TGLuint); stdcall;

PFNGLDELETEVERTEXARRAYSPROC = procedure(n: TGLsizei; arrays: PGLuint); stdcall;

PFNGLGENVERTEXARRAYSPROC = procedure(n: TGLsizei; arrays: PGLuint); stdcall;

PFNGLISVERTEXARRAYPROC = function(_array: TGLuint): TGLboolean; stdcall;

PFNGLGETUNIFORMINDICESPROC = procedure(_program: TGLuint; uniformCount: TGLsizei; uniformNames: PGLPCharArray; uniformIndices: PGLuint); stdcall;

PFNGLGETACTIVEUNIFORMSIVPROC = procedure(_program: TGLuint; uniformCount: TGLsizei; uniformIndices: PGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETACTIVEUNIFORMNAMEPROC = procedure(_program: TGLuint; uniformIndex: TGLuint; bufSize: TGLsizei; length: PGLsizei; uniformName: PGLchar); stdcall;

PFNGLGETUNIFORMBLOCKINDEXPROC = function(_program: TGLuint; uniformBlockName: PGLchar): TGLuint; stdcall;

PFNGLGETACTIVEUNIFORMBLOCKIVPROC = procedure(_program: TGLuint; uniformBlockIndex: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC = procedure(_program: TGLuint; uniformBlockIndex: TGLuint; bufSize: TGLsizei; length: PGLsizei; uniformBlockName: PGLchar); stdcall;

PFNGLUNIFORMBLOCKBINDINGPROC = procedure(_program: TGLuint; uniformBlockIndex: TGLuint; uniformBlockBinding: TGLuint); stdcall;

PFNGLCOPYBUFFERSUBDATAPROC = procedure(readTarget: TGLenum; writeTarget: TGLenum; readOffset: TGLintptr; writeOffset: TGLintptr; size: TGLsizeiptr); stdcall;

PFNGLDRAWELEMENTSBASEVERTEXPROC = procedure(mode: TGLenum; count: TGLsizei; _type: TGLenum; indices: PGLvoid; basevertex: TGLint); stdcall;

PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC = procedure(mode: TGLenum; start: TGLuint; _end: TGLuint; count: TGLsizei; _type: TGLenum; indices: PGLvoid; basevertex: TGLint); stdcall;

PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC = procedure(mode: TGLenum; count: TGLsizei; _type: TGLenum; indices: PGLvoid; primcount: TGLsizei; basevertex: TGLint); stdcall;

PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC = procedure(mode: TGLenum; count: PGLsizei; _type: TGLenum; var indices; primcount: TGLsizei; basevertex: PGLint); stdcall;

PFNGLPROVOKINGVERTEXPROC = procedure(mode: TGLenum); stdcall;

PFNGLFENCESYNCPROC = function(condition: TGLenum; flags: TGLbitfield): TGLsync; stdcall;

PFNGLISSYNCPROC = function(sync: TGLsync): TGLboolean; stdcall;

PFNGLDELETESYNCPROC = procedure(sync: TGLsync); stdcall;

PFNGLCLIENTWAITSYNCPROC = function(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64): TGLenum; stdcall;

PFNGLWAITSYNCPROC = procedure(sync: TGLsync; flags: TGLbitfield; timeout: TGLuint64); stdcall;

PFNGLGETINTEGER64VPROC = procedure(pname: TGLenum; params: PGLint64); stdcall;

PFNGLGETSYNCIVPROC = procedure(sync: TGLsync; pname: TGLenum; bufSize: TGLsizei; length: PGLsizei; values: PGLint); stdcall;

PFNGLTEXIMAGE2DMULTISAMPLEPROC = procedure(target: TGLenum; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

PFNGLTEXIMAGE3DMULTISAMPLEPROC = procedure(target: TGLenum; samples: TGLsizei; internalformat: TGLint; width: TGLsizei; height: TGLsizei; depth: TGLsizei; fixedsamplelocations: TGLboolean); stdcall;

PFNGLGETMULTISAMPLEFVPROC = procedure(pname: TGLenum; index: TGLuint; val: PGLfloat); stdcall;

PFNGLSAMPLEMASKIPROC = procedure(index: TGLuint; mask: TGLbitfield); stdcall;

PFNGLBLENDEQUATIONIARBPROC = procedure(buf: TGLuint; mode: TGLenum); stdcall;

PFNGLBLENDEQUATIONSEPARATEIARBPROC = procedure(buf: TGLuint; modeRGB: TGLenum; modeAlpha: TGLenum); stdcall;

PFNGLBLENDFUNCIARBPROC = procedure(buf: TGLuint; src: TGLenum; dst: TGLenum); stdcall;

PFNGLBLENDFUNCSEPARATEIARBPROC = procedure(buf: TGLuint; srcRGB: TGLenum; dstRGB: TGLenum; srcAlpha: TGLenum; dstAlpha: TGLenum); stdcall;

PFNGLMINSAMPLESHADINGARBPROC = procedure(value: TGLclampf); stdcall;

PFNGLBINDFRAGDATALOCATIONINDEXEDPROC = procedure (_program: TGLuint; colorNumber: TGLuint; index: TGLuint; const name: PGLchar); stdcall;

PFNGLGETFRAGDATAINDEXPROC = function (_program: TGLuint; const name: PGLchar): TGLint; stdcall;

PFNGLGENSAMPLERSPROC = procedure(count: TGLsizei; samplers: PGLuint); stdcall;

PFNGLDELETESAMPLERSPROC = procedure(count: TGLsizei; const samplers: PGLuint); stdcall;

PFNGLISSAMPLERPROC = function(sampler: TGLuint): TGLboolean; stdcall;

PFNGLBINDSAMPLERPROC = procedure(_unit: TGLuint; sampler: TGLuint); stdcall;

PFNGLSAMPLERPARAMETERIPROC = procedure(sampler: TGLuint; pname: TGLenum; param: TGLint); stdcall;

PFNGLSAMPLERPARAMETERIVPROC = procedure(sampler: TGLuint; pname: TGLenum; const params: PGLint); stdcall;

PFNGLSAMPLERPARAMETERFPROC = procedure(sampler: TGLuint; pname: TGLenum; param: TGLfloat); stdcall;

PFNGLSAMPLERPARAMETERFVPROC = procedure(sampler: TGLuint; pname: TGLenum; const params: PGLfloat); stdcall;

PFNGLSAMPLERPARAMETERIIVPROC = procedure(sampler: TGLuint; pname: TGLenum; const params: PGLint); stdcall;

PFNGLSAMPLERPARAMETERIUIVPROC = procedure(sampler: TGLuint; pname: TGLenum; const params: PGLuint); stdcall;

PFNGLGETSAMPLERPARAMETERIVPROC = procedure(sampler: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETSAMPLERPARAMETERIIVPROC = procedure(sampler: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETSAMPLERPARAMETERFVPROC = procedure(sampler: TGLuint; pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETSAMPLERPARAMETERIFVPROC = procedure(sampler: TGLuint; pname: TGLenum; params: PGLfloat); stdcall;

PFNGLQUERYCOUNTERPROC = procedure(id: TGLuint; target: TGLenum); stdcall;

PFNGLGETQUERYOBJECTI64VPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLint64); stdcall;

PFNGLGETQUERYOBJECTUI64VPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLuint64); stdcall;

PFNGLVERTEXP2UIPROC = procedure(_type: TGLenum; value: TGLuint); stdcall;

PFNGLVERTEXP2UIVPROC = procedure(_type: TGLenum; const value: PGLuint ); stdcall;

PFNGLVERTEXP3UIPROC = procedure(_type: TGLenum; value: TGLuint); stdcall;

PFNGLVERTEXP3UIVPROC = procedure(_type: TGLenum; const value: PGLuint); stdcall;

PFNGLVERTEXP4UIPROC = procedure(_type: TGLenum; value: TGLuint); stdcall;

PFNGLVERTEXP4UIVPROC = procedure(_type: TGLenum; const value: PGLuint); stdcall;

PFNGLTEXCOORDP1UIPROC = procedure(_type: TGLenum; coords: TGLuint); stdcall;

PFNGLTEXCOORDP1UIVPROC = procedure(_type: TGLenum; const coords: PGLuint); stdcall;

PFNGLTEXCOORDP2UIPROC = procedure(_type: TGLenum; coords: TGLuint); stdcall;

PFNGLTEXCOORDP2UIVPROC = procedure(_type: TGLenum; const coords: PGLuint); stdcall;

PFNGLTEXCOORDP3UIPROC = procedure(_type: TGLenum; coords: TGLuint); stdcall;

PFNGLTEXCOORDP3UIVPROC = procedure(_type: TGLenum; const coords: PGLuint); stdcall;

PFNGLTEXCOORDP4UIPROC = procedure(_type: TGLenum; coords: TGLuint); stdcall;

PFNGLTEXCOORDP4UIVPROC = procedure(_type: TGLenum; const coords: PGLuint); stdcall;

PFNGLMULTITEXCOORDP1UIPROC = procedure(texture: TGLenum; _type: GLenum; coords: TGLuint); stdcall;

PFNGLMULTITEXCOORDP1UIVPROC = procedure(texture: TGLenum; _type: GLenum; const coords: PGLuint); stdcall;

PFNGLMULTITEXCOORDP2UIPROC = procedure(texture: TGLenum; _type: GLenum; coords: TGLuint); stdcall;

PFNGLMULTITEXCOORDP2UIVPROC = procedure(texture: TGLenum; _type: GLenum; const coords: PGLuint); stdcall;

PFNGLMULTITEXCOORDP3UIPROC = procedure(texture: TGLenum; _type: GLenum; coords: TGLuint); stdcall;

PFNGLMULTITEXCOORDP3UIVPROC = procedure(texture: TGLenum; _type: GLenum; const coords: PGLuint); stdcall;

PFNGLMULTITEXCOORDP4UIPROC = procedure(texture: TGLenum; _type: GLenum; coords: TGLuint); stdcall;

PFNGLMULTITEXCOORDP4UIVPROC = procedure(texture: TGLenum; _type: GLenum; const coords: PGLuint); stdcall;

PFNGLNORMALP3UIPROC = procedure(_type: TGLenum; coords: TGLuint); stdcall;

PFNGLNORMALP3UIVPROC = procedure(_type: TGLenum; const coords: PGLuint); stdcall;

PFNGLCOLORP3UIPROC = procedure(_type: TGLenum; color: TGLuint); stdcall;

PFNGLCOLORP3UIVPROC = procedure(_type: TGLenum; const color: PGLuint); stdcall;

PFNGLCOLORP4UIPROC = procedure(_type: TGLenum; color: TGLuint); stdcall;

PFNGLCOLORP4UIVPROC = procedure(_type: TGLenum; const color: PGLuint); stdcall;

PFNGLSECONDARYCOLORP3UIPROC = procedure(_type: TGLenum; color: TGLuint); stdcall;

PFNGLSECONDARYCOLORP3UIVPROC = procedure(_type: TGLenum; const color: PGLuint); stdcall;

PFNGLVERTEXATTRIBP1UIPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; value: TGLuint); stdcall;

PFNGLVERTEXATTRIBP1UIVPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; const value: PGLuint); stdcall;

PFNGLVERTEXATTRIBP2UIPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; value: TGLuint); stdcall;

PFNGLVERTEXATTRIBP2UIVPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; const value: PGLuint); stdcall;

PFNGLVERTEXATTRIBP3UIPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; value: TGLuint); stdcall;

PFNGLVERTEXATTRIBP3UIVPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; const value: PGLuint); stdcall;

PFNGLVERTEXATTRIBP4UIPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; value: TGLuint); stdcall;

PFNGLVERTEXATTRIBP4UIVPROC = procedure(index: TGLuint; _type: TGLenum; normalized: TGLboolean; const value: PGLuint); stdcall;

PFNGLDRAWARRAYSINDIRECTPROC = procedure(mode: TGLenum; const indirect: PGLvoid); stdcall;

PFNGLDRAWELEMENTSINDIRECTPROC = procedure(mode: TGLenum; _type: TGLenum; const indirect: PGLvoid); stdcall;

PFNGLUNIFORM1DPROC = procedure(location: TGLint; x: TGLdouble); stdcall;

PFNGLUNIFORM2DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

PFNGLUNIFORM3DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

PFNGLUNIFORM4DPROC = procedure(location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

PFNGLUNIFORM1DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLUNIFORM2DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLUNIFORM3DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLUNIFORM4DVPROC = procedure(location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX2X3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX2X4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX3X2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX3X4DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX4X2DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLUNIFORMMATRIX4X3DVPROC = procedure(location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLGETUNIFORMDVPROC = procedure(_program: TGLuint; location: TGLint; params : PGLdouble); stdcall;

PFNGLCLIENTATTRIBDEFAULTEXTPROC = procedure(mask: GLbitfield); stdcall;

PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC = procedure(mask: GLbitfield); stdcall;

PFNGLMATRIXLOADFEXTPROC = procedure(mode: GLenum; const m: PGLfloat); stdcall;

PFNGLMATRIXLOADDEXTPROC = procedure(mode: GLenum; const m: PGLdouble); stdcall;

PFNGLMATRIXMULTFEXTPROC = procedure(mode: GLenum; const m: PGLfloat); stdcall;

PFNGLMATRIXMULTDEXTPROC = procedure(mode: GLenum; const m: PGLdouble); stdcall;

PFNGLMATRIXLOADIDENTITYEXTPROC = procedure(mode: GLenum); stdcall;

PFNGLMATRIXROTATEFEXTPROC = procedure(mode: GLenum; angle: GLfloat; x: GLfloat; y: GLfloat; z: GLfloat); stdcall;

PFNGLMATRIXROTATEDEXTPROC = procedure(mode: GLenum; angle: GLdouble; x: GLdouble; y: GLdouble; z: GLdouble); stdcall;

PFNGLMATRIXSCALEFEXTPROC = procedure(mode: GLenum; x: GLfloat; y: GLfloat; z: GLfloat); stdcall;

PFNGLMATRIXSCALEDEXTPROC = procedure(mode: GLenum; x: GLdouble; y: GLdouble; z: GLdouble); stdcall;

PFNGLMATRIXTRANSLATEFEXTPROC = procedure(mode: GLenum; x: GLfloat; y: GLfloat; z: GLfloat); stdcall;

PFNGLMATRIXTRANSLATEDEXTPROC = procedure(mode: GLenum; x: GLdouble; y: GLdouble; z: GLdouble); stdcall;

PFNGLMATRIXFRUSTUMEXTPROC = procedure(mode: GLenum; left: GLdouble; right: GLdouble; bottom: GLdouble; top: GLdouble; zNear: GLdouble; zFar: GLdouble); stdcall;

PFNGLMATRIXORTHOEXTPROC = procedure(mode: GLenum; left: GLdouble; right: GLdouble; bottom: GLdouble; top: GLdouble; zNear: GLdouble; zFar: GLdouble); stdcall;

PFNGLMATRIXPOPEXTPROC = procedure(mode: GLenum); stdcall;

PFNGLMATRIXPUSHEXTPROC = procedure(mode: GLenum); stdcall;

PFNGLMATRIXLOADTRANSPOSEFEXTPROC = procedure(mode: GLenum; const m: PGLfloat); stdcall;

PFNGLMATRIXLOADTRANSPOSEDEXTPROC = procedure(mode: GLenum; const m: PGLdouble); stdcall;

PFNGLMATRIXMULTTRANSPOSEFEXTPROC = procedure(mode: GLenum; const m: PGLfloat); stdcall;

PFNGLMATRIXMULTTRANSPOSEDEXTPROC = procedure(mode: GLenum; const m: PGLdouble); stdcall;

PFNGLTEXTUREPARAMETERFEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; param: GLfloat); stdcall;

PFNGLTEXTUREPARAMETERFVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; const params: PGLfloat); stdcall;

PFNGLTEXTUREPARAMETERIEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; param: GLint); stdcall;

PFNGLTEXTUREPARAMETERIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; const params: PGLint); stdcall;

PFNGLTEXTUREIMAGE1DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; border: GLint; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLTEXTUREIMAGE2DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; border: GLint; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLTEXTURESUBIMAGE1DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; width: GLsizei; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLTEXTURESUBIMAGE2DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; width: GLsizei; height: GLsizei; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLCOPYTEXTUREIMAGE1DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; x: GLint; y: GLint; width: GLsizei; border: GLint); stdcall;

PFNGLCOPYTEXTUREIMAGE2DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; x: GLint; y: GLint; width: GLsizei; height: GLsizei; border: GLint); stdcall;

PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; x: GLint; y: GLint; width: GLsizei); stdcall;

PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; x: GLint; y: GLint; width: GLsizei; height: GLsizei); stdcall;

PFNGLGETTEXTUREIMAGEEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; format: GLenum; type_: GLenum; pixels: PGLvoid); stdcall;

PFNGLGETTEXTUREPARAMETERFVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETTEXTUREPARAMETERIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; pname: GLenum; params: GLint); stdcall;

PFNGLTEXTUREIMAGE3DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; depth: GLsizei; border: GLint; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLTEXTURESUBIMAGE3DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; zoffset: GLint; width: GLsizei; height: GLsizei; depth: GLsizei; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; zoffset: GLint; x: GLint; y: GLint; width: GLsizei; height: GLsizei); stdcall;

PFNGLMULTITEXPARAMETERFEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; param: GLfloat); stdcall;

PFNGLMULTITEXPARAMETERFVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; const params: PGLfloat); stdcall;

PFNGLMULTITEXPARAMETERIEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; param: GLint); stdcall;

PFNGLMULTITEXPARAMETERIVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; const params: PGLint); stdcall;

PFNGLMULTITEXIMAGE1DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; border: GLint; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLMULTITEXIMAGE2DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; border: GLint; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; width: GLsizei; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; width: GLsizei; height: GLsizei; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLCOPYMULTITEXIMAGE1DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; x: GLint; y: GLint; width: GLsizei; border: GLint); stdcall;

PFNGLCOPYMULTITEXIMAGE2DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; x: GLint; y: GLint; width: GLsizei; height: GLsizei; border: GLint); stdcall;

PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; x: GLint; y: GLint; width: GLsizei); stdcall;

PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; x: GLint; y: GLint; width: GLsizei; height: GLsizei); stdcall;

PFNGLGETMULTITEXIMAGEEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; format: GLenum; type_: GLenum; pixels: PGLvoid); stdcall;

PFNGLGETMULTITEXPARAMETERFVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETMULTITEXPARAMETERIVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; pname: GLenum; params: PGLint); stdcall;

PFNGLMULTITEXIMAGE3DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; depth: GLsizei; border: GLint; format: GLenum; type_: GLenum; const pixels: PGLvoid); stdcall;

PFNGLMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; zoffset: GLint; width: GLsizei; height: GLsizei; depth: GLsizei; format: GLenum; type_: GLenum; const pixels:PGLvoid); stdcall;

PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; zoffset: GLint; x: GLint; y: GLint; width: GLsizei; height: GLsizei); stdcall;

PFNGLBINDMULTITEXTUREEXTPROC = procedure(texunit: GLenum; target: GLenum; texture: GLuint); stdcall;

PFNGLENABLECLIENTSTATEINDEXEDEXTPROC = procedure(array_: GLenum; index_: GLuint); stdcall;

PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC = procedure(array_: GLenum; index_: GLuint); stdcall;

PFNGLMULTITEXCOORDPOINTEREXTPROC = procedure(texunit: GLenum; size: GLint; type_: GLenum; stride: GLsizei; const pointer: PGLvoid); stdcall;

PFNGLMULTITEXENVFEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; param: GLfloat); stdcall;

PFNGLMULTITEXENVFVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; const params: PGLfloat); stdcall;

PFNGLMULTITEXENVIEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; param: GLint); stdcall;

PFNGLMULTITEXENVIVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; const params: PGLint); stdcall;

PFNGLMULTITEXGENDEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; param: GLdouble); stdcall;

PFNGLMULTITEXGENDVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; const params: PGLdouble); stdcall;

PFNGLMULTITEXGENFEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; param: GLfloat); stdcall;

PFNGLMULTITEXGENFVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; const params: PGLfloat); stdcall;

PFNGLMULTITEXGENIEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; param: GLint); stdcall;

PFNGLMULTITEXGENIVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; const params: PGLint); stdcall;

PFNGLGETMULTITEXENVFVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETMULTITEXENVIVEXTPROC = procedure(texunit: GLenum; target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETMULTITEXGENDVEXTPROC = procedure(texunit: GLenum; coord: GLenum; pname: GLenum; params: PGLdouble); stdcall;

PFNGLGETMULTITEXGENFVEXTPROC = procedure(texunit: GLenum; coord: GLenum; pname: GLenum; params: PGLfloat); stdcall;

PFNGLGETMULTITEXGENIVEXTPROC = procedure(texunit: GLenum; coord: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETFLOATINDEXEDVEXTPROC = procedure(target: GLenum; index_: GLuint; data: PGLfloat); stdcall;

PFNGLGETDOUBLEINDEXEDVEXTPROC = procedure(target: GLenum; index_: GLuint; data: PGLdouble); stdcall;

PFNGLGETPOINTERINDEXEDVEXTPROC = procedure(target: GLenum; index_: GLuint; data: PGLvoid); stdcall;

PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; depth: GLsizei; border: GLint; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; border: GLint; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; border: GLint; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; zoffset: GLint; width: GLsizei; height: GLsizei; depth: GLsizei; format: GLenum; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; width: GLsizei; height: GLsizei; format: GLenum; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC = procedure(texture: GLuint; target: GLenum; level: GLint; xoffset: GLint; width: GLsizei; format: GLenum; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC = procedure(texture: GLuint; target: GLenum; lod: GLint; img: PGLvoid); stdcall;

PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; depth: GLsizei; border: GLint; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; height: GLsizei; border: GLint; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; internalformat: GLenum; width: GLsizei; border: GLint; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; zoffset: GLint; width: GLsizei; height: GLsizei; depth: GLsizei; format: GLenum; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; yoffset: GLint; width: GLsizei; height: GLsizei; format: GLenum; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC = procedure(texunit: GLenum; target: GLenum; level: GLint; xoffset: GLint; width: GLsizei; format: GLenum; imageSize: GLsizei; const bits: PGLvoid); stdcall;

PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC = procedure(texunit: GLenum; target: GLenum; lod: GLint; img: PGLvoid); stdcall;

PFNGLNAMEDPROGRAMSTRINGEXTPROC = procedure(program_: GLuint; target: GLenum; format: GLenum; len: GLsizei; const string_: PGLvoid); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; x: GLdouble; y: GLdouble; z: GLdouble; w: GLdouble); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; const params: PGLdouble); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; x: GLfloat; y: GLfloat; z: GLfloat; w: GLfloat); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; const params: PGLfloat); stdcall;

PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; params: PGLdouble); stdcall;

PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; params: PGLfloat); stdcall;

PFNGLGETNAMEDPROGRAMIVEXTPROC = procedure(program_: GLuint; target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETNAMEDPROGRAMSTRINGEXTPROC = procedure(program_: GLuint; target: GLenum; pname: GLenum; string_: PGLvoid); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; count: GLsizei; const params: PGLfloat); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; x: GLint; y: GLint; z: GLint; w: GLint); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; const params: PGLint); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; count: GLsizei; const params: PGLint); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; x: GLuint; y: GLuint; z: GLuint; w: GLuint); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; const params: PGLuint); stdcall;

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; count: GLsizei; const params: PGLuint); stdcall;

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; params: PGLint); stdcall;

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC = procedure(program_: GLuint; target: GLenum; index_: GLuint; params: PGLuint); stdcall;

PFNGLTEXTUREPARAMETERIIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; const params: PGLint); stdcall;

PFNGLTEXTUREPARAMETERIUIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; const params: PGLuint); stdcall;

PFNGLGETTEXTUREPARAMETERIIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETTEXTUREPARAMETERIUIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; params: PGLuint); stdcall;

PFNGLMULTITEXPARAMETERIIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; const params: PGLint); stdcall;

PFNGLMULTITEXPARAMETERIUIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; const params: PGLuint); stdcall;

PFNGLGETMULTITEXPARAMETERIIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGETMULTITEXPARAMETERIUIVEXTPROC = procedure(texture: GLuint; target: GLenum; pname: GLenum; params: PGLuint); stdcall;

PFNGLNAMEDBUFFERDATAEXTPROC = procedure(buffer: GLuint; size: GLsizei; const data: PGLvoid; usage: GLenum); stdcall;

PFNGLNAMEDBUFFERSUBDATAEXTPROC = procedure(buffer: GLuint; offset: GLintptr; size: GLsizeiptr; const data: PGLvoid); stdcall;

PFNGLMAPNAMEDBUFFEREXTPROC = function(buffer: GLuint; access: GLenum): PGLvoid; stdcall;

PFNGLUNMAPNAMEDBUFFEREXTPROC = function(buffer: GLuint): GLboolean; stdcall;

PFNGLMAPNAMEDBUFFERRANGEEXTPROC = function(buffer: GLuint; offset: GLintptr; length: GLsizeiptr; access: GLbitfield): PGLvoid; stdcall;

PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC = procedure(buffer: GLuint; offset: GLintptr; length: GLsizeiptr); stdcall;

PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC = procedure(readBuffer: GLuint; writeBuffer: GLuint; readOffset: GLintptr; writeOffset: GLintptr; size: GLsizeiptr); stdcall;

PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC = procedure(buffer: GLuint; pname: GLenum; params: PGLint); stdcall;

PFNGLGETNAMEDBUFFERPOINTERVEXTPROC = procedure(buffer: GLuint; pname: GLenum; params: PGLvoid); stdcall;

PFNGLGETNAMEDBUFFERSUBDATAEXTPROC = procedure(buffer: GLuint; offset: GLintptr; size: GLsizeiptr; data: PGLvoid); stdcall;

PFNGLTEXTUREBUFFEREXTPROC = procedure(texture: GLuint; target: GLenum; internalformat: GLenum; buffer: GLuint); stdcall;

PFNGLMULTITEXBUFFEREXTPROC = procedure(texunit: GLenum; target: GLenum; interformat: GLenum; buffer: GLuint); stdcall;

PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC = procedure(renderbuffer: GLuint; interformat: GLenum; width: GLsizei; height: GLsizei); stdcall;

PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC = procedure(renderbuffer: GLuint; pname: GLenum; params: PGLint); stdcall;

PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC = function(framebuffer: GLuint; target: GLenum): GLenum; stdcall;

PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; textarget: GLenum; texture: GLuint; level: GLint); stdcall;

PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; textarget: GLenum; texture: GLuint; level: GLint); stdcall;

PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; textarget: GLenum; texture: GLuint; level: GLint; zoffset: GLint); stdcall;

PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; renderbuffertarget: GLenum; renderbuffer: GLuint); stdcall;

PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; pname: GLenum; params: PGLint); stdcall;

PFNGLGENERATETEXTUREMIPMAPEXTPROC = procedure(texture: GLuint; target: GLenum); stdcall;

PFNGLGENERATEMULTITEXMIPMAPEXTPROC = procedure(texunit: GLenum; target: GLenum); stdcall;

PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC = procedure(framebuffer: GLuint; mode: GLenum); stdcall;

PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC = procedure(framebuffer: GLuint; n: GLsizei; const bufs: PGLenum); stdcall;

PFNGLFRAMEBUFFERREADBUFFEREXTPROC = procedure(framebuffer: GLuint; mode: GLenum); stdcall;

PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC = procedure(framebuffer: GLuint; pname: GLenum; params: PGLint); stdcall;

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC = procedure(renderbuffer: GLuint; samples: GLsizei; internalformat: GLenum; width: GLsizei; height: GLsizei); stdcall;

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC = procedure(renderbuffer: GLuint; coverageSamples: GLsizei; colorSamples: GLsizei; internalformat: GLenum; width: GLsizei; height: GLsizei); stdcall;

PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; texture: GLuint; level: GLint); stdcall;

PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; texture: GLuint; level: GLint; layer: GLint); stdcall;

PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC = procedure(framebuffer: GLuint; attachment: GLenum; texture: GLuint; level: GLint; face: GLenum); stdcall;

PFNGLTEXTURERENDERBUFFEREXTPROC = procedure(texture: GLuint; target: GLenum; renderbuffer: GLuint); stdcall;

PFNGLMULTITEXRENDERBUFFEREXTPROC = procedure(texunit: GLenum; target: GLenum; renderbuffer: GLuint); stdcall;

PFNGLPROGRAMUNIFORM1DEXTPROC = procedure(_program: TGLuint; location: TGLint; x: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM2DEXTPROC = procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM3DEXTPROC = procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM4DEXTPROC = procedure(_program: TGLuint; location: TGLint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM1DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORM2DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORM3DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORM4DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2X3DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2X4DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3X2DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3X4DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4X2DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4X3DVEXTPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; const value: PGLdouble); stdcall;

PFNGLGETSUBROUTINEUNIFORMLOCATIONPROC = function(_program: TGLuint; shadertype: TGLenum; const name: PGLchar): TGLint; stdcall;

PFNGLGETSUBROUTINEINDEXPROC = function(_program: TGLuint; shadertype: TGLenum; const name: PGLchar): TGLuint; stdcall;

PFNGLGETACTIVESUBROUTINEUNIFORMIVPROC = procedure(_program: TGLuint; shadertype: TGLenum; index: TGLuint; pname: TGLenum; values: PGLint); stdcall;

PFNGLGETACTIVESUBROUTINEUNIFORMNAMEPROC = procedure(_program: TGLuint; shadertype: TGLenum; index: TGLuint; bufsize: TGLsizei; length: PGLsizei; name: PGLchar); stdcall;

PFNGLGETACTIVESUBROUTINENAMEPROC = procedure(_program: TGLuint; shadertype: TGLenum; index: TGLuint; bufsize: TGLsizei; length: PGLsizei; name: PGLchar); stdcall;

PFNGLUNIFORMSUBROUTINESUIVPROC = procedure(shadertype: TGLenum; count: TGLsizei; const indices: PGLuint); stdcall;

PFNGLGETUNIFORMSUBROUTINEUIVPROC = procedure(shadertype: TGLenum; location: TGLint; params: PGLuint); stdcall;

PFNGLGETPROGRAMSTAGEIVPROC = procedure(_program: TGLuint; shadertype: TGLenum; pname: TGLenum; values: PGLint); stdcall;

PFNGLPATCHPARAMETERIPROC = procedure(pname: TGLenum; value: TGLint); stdcall;

PFNGLPATCHPARAMETERFVPROC = procedure(pname: TGLenum; const values: PGLfloat); stdcall;

PFNGLBINDTRANSFORMFEEDBACKPROC = procedure(target: TGLenum; id: TGLuint); stdcall;

PFNGLDELETETRANSFORMFEEDBACKSPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

PFNGLGENTRANSFORMFEEDBACKSPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

PFNGLISTRANSFORMFEEDBACKPROC = function(id: TGLuint): TGLboolean; stdcall;

PFNGLPAUSETRANSFORMFEEDBACKPROC = procedure(); stdcall;

PFNGLRESUMETRANSFORMFEEDBACKPROC = procedure(); stdcall;

PFNGLDRAWTRANSFORMFEEDBACKPROC = procedure(mode: TGLenum; id: TGLuint); stdcall;

PFNGLDRAWTRANSFORMFEEDBACKSTREAMPROC = procedure(mode: TGLenum; id: TGLuint; stream: TGLuint); stdcall;

PFNGLBEGINQUERYINDEXEDPROC = procedure(target: TGLenum; index: TGLuint; id: TGLuint); stdcall;

PFNGLENDQUERYINDEXEDPROC = procedure(target: TGLenum; index: TGLuint); stdcall;

PFNGLGETQUERYINDEXEDIVPROC = procedure(target: TGLenum; index: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLRELEASESHADERCOMPILERPROC = procedure(); stdcall;

PFNGLSHADERBINARYPROC = procedure(count: TGLsizei; shaders: PGLuint; binaryformat: TGLenum; binary: Pointer; length: TGLsizei); stdcall;

PFNGLGETSHADERPRECISIONFORMATPROC = procedure(shadertype: TGLenum; precisiontype: TGLenum; range: PGLint; precision: PGLint); stdcall;

PFNGLDEPTHRANGEFPROC = procedure(n: TGLclampf; f: TGLclampf); stdcall;

PFNGLCLEARDEPTHFPROC = procedure(d: TGLclampf); stdcall;

PFNGLGETPROGRAMBINARYPROC = procedure(_program: TGLuint; bufSize: TGLsizei; length: PGLsizei; binaryFormat: PGLenum; binary: Pointer); stdcall;

PFNGLPROGRAMBINARYPROC = procedure(_program: TGLuint; binaryFormat: TGLEnum; binary: Pointer; length: TGLsizei); stdcall;

PFNGLPROGRAMPARAMETERIPROC = procedure(_program: TGLuint; pname: TGLenum; value: TGLint); stdcall;

PFNGLUSEPROGRAMSTAGESPROC = procedure(pipeline: TGLuint; stages: TGLbitfield; _program: TGLuint); stdcall;

PFNGLACTIVESHADERPROGRAMPROC = procedure(pipeline: TGLuint; _program: TGLuint); stdcall;

PFNGLCREATESHADERPROGRAMVPROC = function(_type: TGLenum; count: TGLsizei; const strings: PGLPCharArray): TGLuint; stdcall;

PFNGLBINDPROGRAMPIPELINEPROC = procedure(pipeline: TGLuint); stdcall;

PFNGLDELETEPROGRAMPIPELINESPROC = procedure(n: TGLsizei; pipelines: PGLuint); stdcall;

PFNGLGENPROGRAMPIPELINESPROC = procedure(n: TGLsizei; pipelines: PGLuint); stdcall;

PFNGLISPROGRAMPIPELINEPROC = function(pipeline: TGLuint): TGLboolean; stdcall;

PFNGLGETPROGRAMPIPELINEIVPROC = procedure(pipeline: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLPROGRAMUNIFORM1IPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLint); stdcall;

PFNGLPROGRAMUNIFORM1IVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

PFNGLPROGRAMUNIFORM1FPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLfloat); stdcall;

PFNGLPROGRAMUNIFORM1FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORM1DPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM1DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORM1UIPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLuint); stdcall;

PFNGLPROGRAMUNIFORM1UIVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

PFNGLPROGRAMUNIFORM2IPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLint; v1: TGLint); stdcall;

PFNGLPROGRAMUNIFORM2IVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

PFNGLPROGRAMUNIFORM2FPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLfloat; v1: TGLfloat); stdcall;

PFNGLPROGRAMUNIFORM2FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORM2DPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLdouble; v1: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM2DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORM2UIPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLuint; v1: TGLuint); stdcall;

PFNGLPROGRAMUNIFORM2UIVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

PFNGLPROGRAMUNIFORM3IPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint); stdcall;

PFNGLPROGRAMUNIFORM3IVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

PFNGLPROGRAMUNIFORM3FPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat); stdcall;

PFNGLPROGRAMUNIFORM3FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORM3DPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLdouble; v1: TGLdouble; v2: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM3DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORM3UIPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLuint; v1: TGLuint; v2: TGLuint); stdcall;

PFNGLPROGRAMUNIFORM3UIVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

PFNGLPROGRAMUNIFORM4IPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLint; v1: TGLint; v2: TGLint; v3: TGLint); stdcall;

PFNGLPROGRAMUNIFORM4IVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLint); stdcall;

PFNGLPROGRAMUNIFORM4FPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLfloat; v1: TGLfloat; v2: TGLfloat; v3: TGLfloat); stdcall;

PFNGLPROGRAMUNIFORM4FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORM4DPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLdouble; v1: TGLdouble; v2: TGLdouble; v3: TGLdouble); stdcall;

PFNGLPROGRAMUNIFORM4DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORM4UIPROC = procedure(_program: TGLuint; location: TGLint; v0: TGLuint; v1: TGLuint; v2: TGLuint; v3: TGLuint); stdcall;

PFNGLPROGRAMUNIFORM4UIVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; value: PGLuint); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLfloat); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; transpose: TGLboolean; value: PGLdouble); stdcall;

PFNGLVALIDATEPROGRAMPIPELINEPROC = procedure(pipeline: TGLuint); stdcall;

PFNGLGETPROGRAMPIPELINEINFOLOGPROC = procedure(pipeline: TGLuint; bufSize: TGLsizei; length: PGLsizei; infoLog: PGLchar); stdcall;

PFNGLVERTEXATTRIBL1DPROC = procedure(index: TGLuint; x: TGLdouble); stdcall;

PFNGLVERTEXATTRIBL2DPROC = procedure(index: TGLuint; x: TGLdouble; y: TGLdouble); stdcall;

PFNGLVERTEXATTRIBL3DPROC = procedure(index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

PFNGLVERTEXATTRIBL4DPROC = procedure(index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

PFNGLVERTEXATTRIBL1DVPROC = procedure(index: TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIBL2DVPROC = procedure(index: TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIBL3DVPROC = procedure(index: TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIBL4DVPROC = procedure(index: TGLuint; v :PGLdouble); stdcall;

PFNGLVERTEXATTRIBLPOINTERPROC = procedure(index: TGLuint; size: TGLint; _type: TGLenum; stride: TGLsizei; ptr: Pointer); stdcall;

PFNGLGETVERTEXATTRIBLDVPROC = procedure(index: TGLuint; pname: TGLenum; params: PGLdouble); stdcall;

PFNGLVERTEXARRAYVERTEXATTRIBLOFFSETEXTPROC = procedure (vaobj: TGLuint; buffer: TGLuint; index: TGLuint; size: TGLint; _type: TGLenum; stride: TGLsizei; offset: TGLintptr); stdcall;

PFNGLVIEWPORTARRAYVPROC = procedure(first: TGLuint; count: TGLsizei; v: PGLfloat); stdcall;

PFNGLVIEWPORTINDEXEDFPROC = procedure(index: TGLuint; x: TGLfloat; y: TGLfloat; w: TGLfloat; h: TGLfloat); stdcall;

PFNGLVIEWPORTINDEXEDFVPROC = procedure(index: TGLuint; v: PGLfloat); stdcall;

PFNGLSCISSORARRAYVPROC = procedure(first: TGLuint; count: TGLsizei; v: PGLint); stdcall;

PFNGLSCISSORINDEXEDPROC = procedure(index: TGLuint; left: TGLint; bottom: TGLint; width: TGLsizei; height: TGLsizei); stdcall;

PFNGLSCISSORINDEXEDVPROC = procedure(index: TGLuint; v: PGLint); stdcall;

PFNGLDEPTHRANGEARRAYVPROC = procedure(first: TGLuint; count: TGLsizei; v: PGLclampd); stdcall;

PFNGLDEPTHRANGEINDEXEDPROC = procedure(index: TGLuint; n: TGLclampd; f: TGLclampd); stdcall;

PFNGLGETFLOATI_VPROC = procedure(target: TGLenum; index: TGLuint; data: PGLfloat); stdcall;

PFNGLGETDOUBLEI_VPROC = procedure(target: TGLenum; index: TGLuint; data: PGLdouble); stdcall;

PFNGLDEBUGMESSAGECONTROLARBPROC = procedure(source: TGLenum; _type: TGLenum; severity: TGLenum; count: TGLsizei; ids: PGLuint; enabled: TGLboolean); stdcall;

PFNGLDEBUGMESSAGEINSERTARBPROC = procedure(source: TGLenum; _type: TGLenum; id: TGLuint; severity: TGLenum; length: TGLsizei; buf: PGLchar); stdcall;

PFNGLDEBUGMESSAGECALLBACKARBPROC = procedure(callback: TGLDEBUGPROCARB; userParam: Pointer); stdcall;

PFNGLGETDEBUGMESSAGELOGARBPROC = function(count: TGLuint; bufsize: TGLsizei; sources: PGLenum; types: PGLenum; ids: PGLuint; severities: PGLenum; lengths: PGLsizei; messageLog: PGLchar): TGLuint; stdcall;

PFNGLGETGRAPHICSRESETSTATUSARBPROC = function(): TGLenum; stdcall;

PFNGLGETNMAPDVARBPROC = procedure(target: TGLenum; query: TGLenum; bufSize: TGLsizei; v: PGLdouble); stdcall;

PFNGLGETNMAPFVARBPROC = procedure(target: TGLenum; query: TGLenum; bufSize: TGLsizei; v: PGLfloat); stdcall;

PFNGLGETNMAPIVARBPROC = procedure(target: TGLenum; query: TGLenum; bufSize: TGLsizei; v: PGLint); stdcall;

PFNGLGETNPIXELMAPFVARBPROC = procedure(map: TGLenum; bufSize: TGLsizei; values: PGLfloat); stdcall;

PFNGLGETNPIXELMAPUIVARBPROC = procedure(map: TGLenum; bufSize: TGLsizei; values: PGLuint); stdcall;

PFNGLGETNPIXELMAPUSVARBPROC = procedure(map: TGLenum; bufSize: TGLsizei; values: PGLushort); stdcall;

PFNGLGETNPOLYGONSTIPPLEARBPROC = procedure(bufSize: TGLsizei; pattern: PGLubyte); stdcall;

PFNGLGETNCOLORTABLEARBPROC = procedure(target: TGLenum; format: TGLenum; _type: TGLenum; bufSize: TGLsizei; table: Pointer); stdcall;

PFNGLGETNCONVOLUTIONFILTERARBPROC = procedure(target: TGLenum; format: TGLenum; _type: TGLenum; bufSize: TGLsizei; image: Pointer); stdcall;

PFNGLGETNSEPARABLEFILTERARBPROC = procedure(target: TGLenum; format: TGLenum; _type: TGLenum; rowBufSize: TGLsizei; row: Pointer; columnBufSize: TGLsizei; column: Pointer; span: Pointer); stdcall;

PFNGLGETNHISTOGRAMARBPROC = procedure(target: TGLenum; reset: TGLboolean; format: TGLenum; _type: TGLenum; bufSize: TGLsizei; values: Pointer); stdcall;

PFNGLGETNMINMAXARBPROC = procedure(target: TGLenum; reset: TGLboolean; format: TGLenum; _type: TGLenum; bufSize: TGLsizei; values: Pointer); stdcall;

PFNGLGETNTEXIMAGEARBPROC = procedure(target: TGLenum; level: TGLint; format: TGLenum; _type: TGLenum; bufSize: TGLsizei; img: Pointer); stdcall;

PFNGLREADNPIXELSARBPROC = procedure(x: TGLint; y: TGLint; width: TGLsizei; height: TGLsizei; format: TGLenum; _type: TGLenum; bufSize: TGLsizei; data: Pointer); stdcall;

PFNGLGETNCOMPRESSEDTEXIMAGEARBPROC = procedure(target: TGLenum; lod: TGLint; bufSize: TGLsizei; img: Pointer); stdcall;

PFNGLGETNUNIFORMFVARBPROC = procedure(_program: TGLuint; location: TGLint; bufSize: TGLsizei; params: PGLfloat); stdcall;

PFNGLGETNUNIFORMIVARBPROC = procedure(_program: TGLuint; location: TGLint; bufSize: TGLsizei; params: PGLint); stdcall;

PFNGLGETNUNIFORMUIVARBPROC = procedure(_program: TGLuint; location: TGLint; bufSize: TGLsizei; params: PGLuint); stdcall;

PFNGLGETNUNIFORMDVARBPROC = procedure(_program: TGLuint; location: TGLint; bufSize: TGLsizei; params: PGLdouble); stdcall;

PFNGLARRAYELEMENTARRAYEXTPROC = procedure(mode: TGLEnum; count: TGLsizei; pi: Pointer); stdcall;

PFNGLADDSWAPHINTRECTWINPROC = procedure(x, y: TGLint; width, height: TGLsizei); stdcall;

PFNGLBLENDCOLOREXTPROC = procedure(red, green, blue: TGLclampf; alpha: TGLclampf); stdcall;

PFNGLPOLYGONOFFSETEXTPROC = procedure(factor, bias: TGLfloat); stdcall;

PFNGLTEXIMAGE3DEXTPROC = procedure(target: TGLenum; level: TGLint; internalformat: TGLenum; width, height, depth: TGLsizei; border: TGLint; Format, AType: TGLenum; pixels: Pointer); stdcall;

PFNGLTEXSUBIMAGE1DEXTPROC = procedure(target: TGLEnum; level, xoffset: TGLint; width: TGLsizei; format, Atype: TGLEnum; pixels: Pointer); stdcall;

PFNGLTEXSUBIMAGE2DEXTPROC = procedure(target: TGLEnum; level, xoffset, yoffset: TGLint; width, height: TGLsizei; format, Atype: TGLEnum; pixels: Pointer); stdcall;

PFNGLTEXSUBIMAGE3DEXTPROC = procedure(target: TGLEnum; level, xoffset, yoffset, zoffset: TGLint; width, height, depth: TGLsizei; format, Atype: TGLEnum; pixels: Pointer); stdcall;

PFNGLCOPYTEXIMAGE1DEXTPROC = procedure(target: TGLEnum; level: TGLint; internalFormat: TGLEnum; x, y: TGLint; width: TGLsizei; border: TGLint); stdcall;

PFNGLCOPYTEXIMAGE2DEXTPROC = procedure(target: TGLEnum; level: TGLint; internalFormat: TGLEnum; x, y: TGLint; width, height: TGLsizei; border: TGLint); stdcall;

PFNGLCOPYTEXSUBIMAGE1DEXTPROC = procedure(target: TGLEnum; level, xoffset, x, y: TGLint; width: TGLsizei); stdcall;

PFNGLCOPYTEXSUBIMAGE2DEXTPROC = procedure(target: TGLEnum; level, xoffset, yoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

PFNGLCOPYTEXSUBIMAGE3DEXTPROC = procedure(target: TGLEnum; level, xoffset, yoffset, zoffset, x, y: TGLint; width, height: TGLsizei); stdcall;

PFNGLGENTEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint); stdcall;

PFNGLDELETETEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint); stdcall;

PFNGLBINDTEXTUREEXTPROC = procedure(target: TGLEnum; texture: TGLuint); stdcall;

PFNGLPRIORITIZETEXTURESEXTPROC = procedure(n: TGLsizei; textures: PGLuint; priorities: PGLclampf); stdcall;

PFNGLARETEXTURESRESIDENTEXTPROC = function(n: TGLsizei; textures: PGLuint; residences: PGLBoolean): TGLboolean; stdcall;

PFNGLISTEXTUREEXTPROC = function(texture: TGLuint): TGLboolean; stdcall;

PFNGLSAMPLEMASKSGISPROC = procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

PFNGLSAMPLEPATTERNSGISPROC = procedure(pattern: TGLenum); stdcall;

PFNGLBLENDEQUATIONEXTPROC = procedure(mode: TGLenum); stdcall;

PFNGLCOLORTABLEEXTPROC = procedure(target, internalFormat: TGLEnum; width: TGLsizei; format, atype: TGLEnum; data: Pointer); stdcall;

PFNGLCOLORSUBTABLEEXTPROC = procedure(target: TGLEnum; start, count: TGLsizei; format, atype: TGLEnum; data: Pointer); stdcall;

PFNGLGETCOLORTABLEEXTPROC = procedure(target, format, atype: TGLEnum; data: Pointer); stdcall;

PFNGLGETCOLORTABLEPARAMETERFVEXTPROC = procedure(target, pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETCOLORTABLEPARAMETERIVEXTPROC = procedure(target, pname: TGLenum; params: PGLint); stdcall;

PFNGLINDEXMATERIALEXTPROC = procedure(face: TGLEnum; mode: TGLEnum); stdcall;

PFNGLINDEXFUNCEXTPROC = procedure(func: TGLEnum; ref: TGLfloat); stdcall;

PFNGLLOCKARRAYSEXTPROC = procedure(first: TGLint; count: TGLsizei); stdcall;

PFNGLUNLOCKARRAYSEXTPROC = procedure; stdcall;

PFNGLDRAWRANGEELEMENTSEXTPROC = procedure(mode: TGLenum; start, Aend: TGLuint; Count: TGLsizei; Atype: TGLenum; indices: Pointer); stdcall;

PFNGLBEGINSCENEEXTPROC = procedure; stdcall;

PFNGLENDSCENEEXTPROC = procedure; stdcall;

PFNGLSECONDARYCOLOR3BEXTPROC = procedure(red, green, blue: TGLbyte); stdcall;

PFNGLSECONDARYCOLOR3BVEXTPROC = procedure(v: PGLbyte); stdcall;

PFNGLSECONDARYCOLOR3DEXTPROC = procedure(red, green, blue: TGLdouble); stdcall;

PFNGLSECONDARYCOLOR3DVEXTPROC = procedure(v: PGLdouble); stdcall;

PFNGLSECONDARYCOLOR3FEXTPROC = procedure(red, green, blue: TGLfloat); stdcall;

PFNGLSECONDARYCOLOR3FVEXTPROC = procedure(v: PGLfloat); stdcall;

PFNGLSECONDARYCOLOR3IEXTPROC = procedure(red, green, blue: TGLint); stdcall;

PFNGLSECONDARYCOLOR3IVEXTPROC = procedure(v: PGLint); stdcall;

PFNGLSECONDARYCOLOR3SEXTPROC = procedure(red, green, blue: TGLshort); stdcall;

PFNGLSECONDARYCOLOR3SVEXTPROC = procedure(v: PGLshort); stdcall;

PFNGLSECONDARYCOLOR3UBEXTPROC = procedure(red, green, blue: TGLubyte); stdcall;

PFNGLSECONDARYCOLOR3UBVEXTPROC = procedure(v: PGLubyte); stdcall;

PFNGLSECONDARYCOLOR3UIEXTPROC = procedure(red, green, blue: TGLuint); stdcall;

PFNGLSECONDARYCOLOR3UIVEXTPROC = procedure(v: PGLuint); stdcall;

PFNGLSECONDARYCOLOR3USEXTPROC = procedure(red, green, blue: TGLushort); stdcall;

PFNGLSECONDARYCOLOR3USVEXTPROC = procedure(v: PGLushort); stdcall;

PFNGLSECONDARYCOLORPOINTEREXTPROC = procedure(Size: TGLint; Atype: TGLenum; stride: TGLsizei; p: pointer); stdcall;

PFNGLMULTIDRAWARRAYSEXTPROC = procedure(mode: TGLenum; First: PGLint; Count: PGLsizei; primcount: TGLsizei); stdcall;

PFNGLMULTIDRAWELEMENTSEXTPROC = procedure(mode: TGLenum; Count: PGLsizei; AType: TGLenum; var indices; primcount: TGLsizei); stdcall;

PFNGLFOGCOORDFEXTPROC = procedure(coord: TGLfloat); stdcall;

PFNGLFOGCOORDFVEXTPROC = procedure(coord: PGLfloat); stdcall;

PFNGLFOGCOORDDEXTPROC = procedure(coord: TGLdouble); stdcall;

PFNGLFOGCOORDDVEXTPROC = procedure(coord: PGLdouble); stdcall;

PFNGLFOGCOORDPOINTEREXTPROC = procedure(AType: TGLenum; stride: TGLsizei; p: Pointer); stdcall;

PFNGLBLENDFUNCSEPARATEEXTPROC = procedure(sfactorRGB, dfactorRGB, sfactorAlpha, dfactorAlpha: TGLenum); stdcall;

PFNGLFLUSHVERTEXARRAYRANGENVPROC = procedure; stdcall;

PFNGLVERTEXARRAYRANGENVPROC = procedure(Size: TGLsizei; p: pointer); stdcall;

PFNWGLALLOCATEMEMORYNVPROC = function(size: TGLsizei; readFrequency, writeFrequency, priority: Single): Pointer; stdcall;

PFNWGLFREEMEMORYNVPROC = procedure(ptr: Pointer); stdcall;

PFNGLCOMBINERPARAMETERFVNVPROC = procedure(pname: TGLenum; params: PGLfloat); stdcall;

PFNGLCOMBINERPARAMETERFNVPROC = procedure(pname: TGLenum; param: TGLfloat); stdcall;

PFNGLCOMBINERPARAMETERIVNVPROC = procedure(pname: TGLenum; params: PGLint); stdcall;

PFNGLCOMBINERPARAMETERINVPROC = procedure(pname: TGLenum; param: TGLint); stdcall;

PFNGLCOMBINERINPUTNVPROC = procedure(stage, portion, variable, input, mapping, componentUsage: TGLenum); stdcall;

PFNGLCOMBINEROUTPUTNVPROC = procedure(stage, portion, abOutput, cdOutput, sumOutput, scale, bias: TGLenum; abDotProduct, cdDotProduct, muxSum: TGLboolean); stdcall;

PFNGLFINALCOMBINERINPUTNVPROC = procedure(variable, input, mapping, componentUsage: TGLenum); stdcall;

PFNGLGETCOMBINERINPUTPARAMETERFVNVPROC = procedure(stage, portion, variable, pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETCOMBINERINPUTPARAMETERIVNVPROC = procedure(stage, portion, variable, pname: TGLenum; params: PGLint); stdcall;

PFNGLGETCOMBINEROUTPUTPARAMETERFVNVPROC = procedure(stage, portion, pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC = procedure(stage, portion, pname: TGLenum; params: PGLint); stdcall;

PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC = procedure(variable, pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC = procedure(variable, pname: TGLenum; params: PGLint); stdcall;

PFNGLRESIZEBUFFERSMESAPROC = procedure; stdcall;

PFNGLTBUFFERMASK3DFXPROC = procedure(mask: TGLuint); stdcall;

PFNGLSAMPLEMASKEXTPROC = procedure(Value: TGLclampf; invert: TGLboolean); stdcall;

PFNGLSAMPLEPATTERNEXTPROC = procedure(pattern: TGLenum); stdcall;

PFNGLTEXTURECOLORMASKSGISPROC = procedure(red, green, blue, alpha: TGLboolean); stdcall;

PFNGLGENFENCESNVPROC = procedure(n: TGLsizei; fences: PGLuint); stdcall;

PFNGLDELETEFENCESNVPROC = procedure(n: TGLsizei; fences: PGLuint); stdcall;

PFNGLSETFENCENVPROC = procedure(fence: TGLuint; condition: TGLenum); stdcall;

PFNGLTESTFENCENVPROC = function(fence: TGLuint): TGLboolean; stdcall;

PFNGLFINISHFENCENVPROC = procedure(fence: TGLuint); stdcall;

PFNGLISFENCENVPROC = function(fence: TGLuint): TGLboolean; stdcall;

PFNGLGETFENCEIVNVPROC = procedure(fence: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLAREPROGRAMSRESIDENTNVPROC = procedure(n: TGLSizei; programs: PGLuint; residences: PGLboolean); stdcall;

PFNGLBINDPROGRAMNVPROC = procedure(target: TGLenum; id: TGLuint); stdcall;

PFNGLDELETEPROGRAMSNVPROC = procedure(n: TGLSizei; programs: PGLuint); stdcall;

PFNGLEXECUTEPROGRAMNVPROC = procedure(target: TGLenum; id: TGLuint; params: PGLfloat); stdcall;

PFNGLGENPROGRAMSNVPROC = procedure(n: TGLSizei; programs: PGLuint); stdcall;

PFNGLGETPROGRAMPARAMETERDVNVPROC = procedure (target: TGLenum; index: TGLuint; pname: TGLenum; params: PGLdouble); stdcall;

PFNGLGETPROGRAMPARAMETERFVNVPROC = procedure (target: TGLenum; index: TGLuint; pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETPROGRAMIVNVPROC = procedure (id: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETPROGRAMSTRINGNVPROC = procedure (id: TGLuint; pname: TGLenum; programIdx: PGLubyte); stdcall;

PFNGLGETTRACKMATRIXIVNVPROC = procedure (target: TGLenum; address: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETVERTEXATTRIBDVNVPROC = procedure (index: TGLuint; pname: TGLenum; params: PGLdouble); stdcall;

PFNGLGETVERTEXATTRIBFVNVPROC = procedure (index: TGLuint; pname: TGLenum; params: PGLfloat); stdcall;

PFNGLGETVERTEXATTRIBIVNVPROC = procedure (index: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETVERTEXATTRIBPOINTERVNVPROC = procedure (index: TGLuint; pname: TGLenum; pointer: PGLPointer); stdcall;

PFNGLISPROGRAMNVPROC = function (id: TGLuint): TGLboolean; stdcall;

PFNGLLOADPROGRAMNVPROC = procedure (target: TGLenum; id: TGLuint; len: TGLSizei; programIdx: PGLubyte); stdcall;

PFNGLPROGRAMPARAMETER4DNVPROC = procedure (target: TGLenum; index: TGLuint; x, y, z, w: TGLdouble); stdcall;

PFNGLPROGRAMPARAMETER4DVNVPROC = procedure (target: TGLenum; index: TGLuint; v: PGLdouble ); stdcall;

PFNGLPROGRAMPARAMETER4FNVPROC = procedure (target: TGLenum; index: TGLuint; x, y, z, w: TGLfloat); stdcall;

PFNGLPROGRAMPARAMETER4FVNVPROC = procedure (target: TGLenum; index: TGLuint; v: PGLfloat); stdcall;

PFNGLPROGRAMPARAMETERS4DVNVPROC = procedure (target: TGLenum; index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

PFNGLPROGRAMPARAMETERS4FVNVPROC = procedure (target: TGLenum; index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

PFNGLREQUESTRESIDENTPROGRAMSNVPROC = procedure (n: TGLSizei; programs: PGLuint); stdcall;

PFNGLTRACKMATRIXNVPROC = procedure (target: TGLenum; address: TGLuint; matrix: TGLenum; transform: TGLenum); stdcall;

PFNGLVERTEXATTRIBPOINTERNVPROC = procedure (index: TGLuint; fsize: TGLint; vertextype: TGLenum; stride: TGLSizei; pointer: Pointer); stdcall;

PFNGLVERTEXATTRIB1DNVPROC = procedure (index: TGLuint; x: TGLdouble); stdcall;

PFNGLVERTEXATTRIB1DVNVPROC = procedure (index: TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB1FNVPROC = procedure (index: TGLuint; x: TGLfloat); stdcall;

PFNGLVERTEXATTRIB1FVNVPROC = procedure (index: TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB1SNVPROC = procedure (index: TGLuint; x: TGLshort); stdcall;

PFNGLVERTEXATTRIB1SVNVPROC = procedure (index: TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB2DNVPROC = procedure (index: TGLuint; x: TGLdouble; y: TGLdouble); stdcall;

PFNGLVERTEXATTRIB2DVNVPROC = procedure (index: TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB2FNVPROC = procedure (index: TGLuint; x: TGLfloat; y: TGLfloat); stdcall;

PFNGLVERTEXATTRIB2FVNVPROC = procedure (index: TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB2SNVPROC = procedure (index: TGLuint; x: TGLshort; y: TGLshort); stdcall;

PFNGLVERTEXATTRIB2SVNVPROC = procedure (index: TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB3DNVPROC = procedure (index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble); stdcall;

PFNGLVERTEXATTRIB3DVNVPROC = procedure (index: TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB3FNVPROC = procedure (index: TGLuint; x: TGLfloat; y: TGLfloat; z: TGLfloat); stdcall;

PFNGLVERTEXATTRIB3FVNVPROC = procedure (index: TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB3SNVPROC = procedure (index: TGLuint; x: TGLshort; y: TGLshort; z: TGLshort); stdcall;

PFNGLVERTEXATTRIB3SVNVPROC = procedure (index: TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4DNVPROC = procedure (index: TGLuint; x: TGLdouble; y: TGLdouble; z: TGLdouble; w: TGLdouble); stdcall;

PFNGLVERTEXATTRIB4DVNVPROC = procedure (index: TGLuint; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIB4FNVPROC = procedure(index: TGLuint; x: TGLfloat; y: TGLfloat; z: TGLfloat; w: TGLfloat); stdcall;

PFNGLVERTEXATTRIB4FVNVPROC = procedure(index: TGLuint; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIB4SNVPROC = procedure (index: TGLuint; x: TGLshort; y: TGLshort; z: TGLdouble; w: TGLshort); stdcall;

PFNGLVERTEXATTRIB4SVNVPROC = procedure (index: TGLuint; v: PGLshort); stdcall;

PFNGLVERTEXATTRIB4UBVNVPROC = procedure (index: TGLuint; v: PGLubyte); stdcall;

PFNGLVERTEXATTRIBS1DVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIBS1FVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIBS1SVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

PFNGLVERTEXATTRIBS2DVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIBS2FVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIBS2SVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

PFNGLVERTEXATTRIBS3DVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIBS3FVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIBS3SVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

PFNGLVERTEXATTRIBS4DVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLdouble); stdcall;

PFNGLVERTEXATTRIBS4FVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLfloat); stdcall;

PFNGLVERTEXATTRIBS4SVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLshort); stdcall;

PFNGLVERTEXATTRIBS4UBVNVPROC = procedure (index: TGLuint; count: TGLSizei; v: PGLubyte); stdcall;

PFNGLGENOCCLUSIONQUERIESNVPROC = procedure(n: TGLsizei; ids: PGLuint); stdcall;

PFNGLDELETEOCCLUSIONQUERIESNVPROC = procedure(n: TGLsizei; const ids: PGLuint); stdcall;

PFNGLISOCCLUSIONQUERYNVPROC = function(id: TGLuint): TGLboolean; stdcall;

PFNGLBEGINOCCLUSIONQUERYNVPROC = procedure(id: TGLuint); stdcall;

PFNGLENDOCCLUSIONQUERYNVPROC = procedure; stdcall;

PFNGLGETOCCLUSIONQUERYIVNVPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETOCCLUSIONQUERYUIVNVPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLuint); stdcall;

PFNGLPOINTPARAMETERINVPROC = procedure(pname: TGLenum; param: TGLint); stdcall;

PFNGLPOINTPARAMETERIVNVPROC = procedure(pname: TGLenum; params: PGLint); stdcall;

PFNGLACTIVESTENCILFACEEXTPROC = procedure(face: TGLenum); stdcall;

PFNGLDRAWBUFFERSATIPROC = procedure(n: GLsizei; const bufs: PGLenum); stdcall;

PFNGLPRIMITIVERESTARTNVPROC = procedure(); stdcall;

PFNGLPRIMITIVERESTARTINDEXNVPROC = procedure(index: TGLuint); stdcall;

PFNGLDEPTHBOUNDSEXTPROC = procedure(zmin: TGLclampd; zmax: TGLclampd); stdcall;

PFNGLBLENDEQUATIONSEPARATEEXTPROC = procedure(modeRGB: TGLenum; modeAlpha: TGLenum); stdcall;

PFNGLISRENDERBUFFEREXTPROC = function(renderbuffer: TGLuint): TGLboolean; stdcall;

PFNGLBINDRENDERBUFFEREXTPROC = procedure(target: TGLenum; renderbuffer: TGLuint); stdcall;

PFNGLDELETERENDERBUFFERSEXTPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

PFNGLGENRENDERBUFFERSEXTPROC = procedure(n: TGLsizei; renderbuffers: PGLuint); stdcall;

PFNGLRENDERBUFFERSTORAGEEXTPROC = procedure(target: TGLenum; internalformat: TGLenum; width: TGLsizei; height: TGLsizei); stdcall;

PFNGLGETRENDERBUFFERPARAMETERIVEXTPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLISFRAMEBUFFEREXTPROC = function(framebuffer: TGLuint): TGLboolean; stdcall;

PFNGLBINDFRAMEBUFFEREXTPROC = procedure(target: TGLenum; framebuffer: TGLuint); stdcall;

PFNGLDELETEFRAMEBUFFERSEXTPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

PFNGLGENFRAMEBUFFERSEXTPROC = procedure(n: TGLsizei; framebuffers: PGLuint); stdcall;

PFNGLCHECKFRAMEBUFFERSTATUSEXTPROC = function(target: TGLenum): TGLenum; stdcall;

PFNGLFRAMEBUFFERTEXTURE1DEXTPROC = procedure(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTURE2DEXTPROC = procedure(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTURE3DEXTPROC = procedure(target: TGLenum; attachment: TGLenum; textarget: TGLenum; texture: TGLuint; level: TGLint; zoffset: TGLint); stdcall;

PFNGLFRAMEBUFFERRENDERBUFFEREXTPROC = procedure(target: TGLenum; attachment: TGLenum; renderbuffertarget: TGLenum; renderbuffer: TGLuint); stdcall;

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC = procedure(target: TGLenum; attachment: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLGENERATEMIPMAPEXTPROC = procedure(target: TGLenum); stdcall;

PFNGLSTRINGMARKERGREMEDYPROC = procedure(len: GLsizei; str: PGLChar); stdcall;

PFNGLSTENCILCLEARTAGEXTPROC = procedure(stencilTagBits: TGLsizei; stencilClearTag: TGLuint); stdcall;

PFNGLBLITFRAMEBUFFEREXTPROC = procedure(srcX0: TGLint; srcY0: TGLint; srcX1: TGLint; srcY1: TGLint; dstX0: TGLint; dstY0: TGLint; dstX1: TGLint; dstY1: TGLint; mask: TGLbitfield; filter: TGLenum); stdcall;

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC = procedure(target: TGLenum; samples: TGLsizei; internalformat: TGLenum; width: TGLsizei; height: TGLsizei); stdcall;

PFNGLGETQUERYOBJECTI64VEXTPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLint64EXT); stdcall;

PFNGLGETQUERYOBJECTUI64VEXTPROC = procedure(id: TGLuint; pname: TGLenum; params: PGLuint64EXT); stdcall;

PFNGLPROGRAMENVPARAMETERS4FVEXTPROC = procedure(target:TGLenum; index:TGLuint; count:TGLsizei; const params:PGLfloat); stdcall;

PFNGLPROGRAMLOCALPARAMETERS4FVEXTPROC = procedure(target:TGLenum; index:TGLuint; count:TGLsizei; const params:PGLFloat); stdcall;

PFNGLPROGRAMVERTEXLIMITNVPROC = procedure (target: TGLenum; limit: TGLint); stdcall;

PFNGLPROGRAMPARAMETERIEXTPROC = procedure ( _program:TGLuint; pname:TGLenum; value: TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTUREEXTPROC = procedure ( target:TGLenum; attachment:TGLenum; texture:TGLuint; level:TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTURELAYEREXTPROC = procedure ( target:TGLenum; attachment:TGLenum; texture:TGLuint; level:TGLint; layer:TGLint); stdcall;

PFNGLFRAMEBUFFERTEXTUREFACEEXTPROC = procedure ( target:TGLenum; attachment:TGLenum; texture:TGLuint; level:TGLint; face:TGLenum); stdcall;

PFNGLVERTEXATTRIBI1IEXTPROC = procedure(index: TGLuint; x: TGLint); stdcall;

PFNGLVERTEXATTRIBI2IEXTPROC = procedure(index: TGLuint; x: TGLint; y: TGLint); stdcall;

PFNGLVERTEXATTRIBI3IEXTPROC = procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint); stdcall;

PFNGLVERTEXATTRIBI4IEXTPROC = procedure(index: TGLuint; x: TGLint; y: TGLint; z: TGLint; w: TGLint); stdcall;

PFNGLVERTEXATTRIBI1UIEXTPROC = procedure(index: TGLuint; x: TGLuint); stdcall;

PFNGLVERTEXATTRIBI2UIEXTPROC = procedure(index: TGLuint; x: TGLuint; y: TGLuint); stdcall;

PFNGLVERTEXATTRIBI3UIEXTPROC = procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint); stdcall;

PFNGLVERTEXATTRIBI4UIEXTPROC = procedure(index: TGLuint; x: TGLuint; y: TGLuint; z: TGLuint; w: TGLuint); stdcall;

PFNGLVERTEXATTRIBI1IVEXTPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI2IVEXTPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI3IVEXTPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI4IVEXTPROC = procedure(index: TGLuint; v:PGLint); stdcall;

PFNGLVERTEXATTRIBI1UIVEXTPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI2UIVEXTPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI3UIVEXTPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI4UIVEXTPROC = procedure(index: TGLuint; v:PGLuint); stdcall;

PFNGLVERTEXATTRIBI4BVEXTPROC = procedure(index: TGLuint; v:PGLbyte); stdcall;

PFNGLVERTEXATTRIBI4SVEXTPROC = procedure(index: TGLuint; v:PGLshort); stdcall;

PFNGLVERTEXATTRIBI4UBVEXTPROC = procedure(index: TGLuint; v: PGLUbyte); stdcall;

PFNGLVERTEXATTRIBI4USVEXTPROC = procedure(index: TGLuint; v: PGLushort); stdcall;

PFNGLVERTEXATTRIBIPOINTEREXTPROC = procedure(index: TGLuint; size: TGLint; _type: TGLenum; stride: TGLsizei; _pointer: pointer); stdcall;

PFNGLGETVERTEXATTRIBIIVEXTPROC = procedure(index: TGLuint; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETVERTEXATTRIBIUIVEXTPROC = procedure(index: TGLuint; pname: TGLenum; params: PGLuint); stdcall;

PFNGLUNIFORM1UIEXTPROC = procedure(location: TGLInt; v0: TGLuint); stdcall;

PFNGLUNIFORM2UIEXTPROC = procedure(location: TGLInt; v0: TGLuint; v1: TGLuint); stdcall;

PFNGLUNIFORM3UIEXTPROC = procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint); stdcall;

PFNGLUNIFORM4UIEXTPROC = procedure(location: TGLInt; v0: TGLuint; v1: TGLuint; v2: TGLuint; v3: TGLuint); stdcall;

PFNGLUNIFORM1UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLUNIFORM2UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLUNIFORM3UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLUNIFORM4UIVEXTPROC = procedure(location: TGLInt; count: TGLsizei; value: PGLuint); stdcall;

PFNGLGETUNIFORMUIVEXTPROC = procedure(_program: TGLuint; location: TGLint; params: PGLuint); stdcall;

PFNGLBINDFRAGDATALOCATIONEXTPROC = procedure(_program: TGLuint; colorNumber: TGLuint; name: PGLChar); stdcall;

PFNGLGETFRAGDATALOCATIONEXTPROC = function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

PFNGLDRAWARRAYSINSTANCEDEXTPROC = procedure(mode: TGLenum; first: TGLint; count: TGLsizei; primcount: TGLsizei); stdcall;

PFNGLDRAWELEMENTSINSTANCEDEXTPROC = procedure(mode: TGLenum; count: TGLSizei; _type: TGLenum; indices: PGLvoid; primcount: TGLsizei); stdcall;

PFNGLTEXBUFFEREXTPROC = procedure(target: TGLenum; internalformat: TGLenum; buffer: TGLuint); stdcall;

PFNGLCOLORMASKINDEXEDEXTPROC = procedure(buf: TGLuint; r: TGLboolean; g: TGLboolean; b: TGLboolean; a: TGLboolean); stdcall;

PFNGLGETBOOLEANINDEXEDVEXTPROC = procedure(value: TGLenum; index: TGLuint; data: PGLboolean); stdcall;

PFNGLGETINTEGERINDEXEDVEXTPROC = procedure(value: TGLenum; index: TGLuint; data: PGLint); stdcall;

PFNGLENABLEINDEXEDEXTPROC = procedure(target: TGLenum; index: TGLuint); stdcall;

PFNGLDISABLEINDEXEDEXTPROC = procedure(target: TGLenum; index: TGLuint); stdcall;

PFNGLISENABLEDINDEXEDEXTPROC = function(target: TGLenum; index: TGLuint): TGLboolean; stdcall;

PFNGLBINDBUFFERRANGENVPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint; offset: TGLintptr; size: TGLsizeiptr); stdcall;

PFNGLBINDBUFFEROFFSETNVPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint; offset: TGLintptr); stdcall;

PFNGLBINDBUFFERBASENVPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint); stdcall;

PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC = procedure(count: TGLsizei; attribs: PGLint; bufferMode: TGLenum); stdcall;

PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC = procedure(_program: TGLuint; count: TGLsizei; locations: PGLint; bufferMode: TGLenum); stdcall;

PFNGLBEGINTRANSFORMFEEDBACKNVPROC = procedure(primitiveMode: TGLenum); stdcall;

PFNGLENDTRANSFORMFEEDBACKNVPROC = procedure(); stdcall;

PFNGLGETVARYINGLOCATIONNVPROC = function(_program: TGLuint; name: PGLChar): TGLint; stdcall;

PFNGLGETACTIVEVARYINGNVPROC = procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: TGLenum; name: PGLChar); stdcall;

PFNGLACTIVEVARYINGNVPROC = procedure(_program: TGLuint; name: PGLChar); stdcall;

PFNGLGETTRANSFORMFEEDBACKVARYINGNVPROC = procedure(_program: TGLuint; index: TGLuint; location: PGLint); stdcall;

PFNGLUNIFORMBUFFEREXTPROC = procedure(_program: TGLUint; location: TGLint; buffer: TGLuint); stdcall;

PFNGLGETUNIFORMBUFFERSIZEEXTPROC = function(_program: TGLuint; location: TGLint): TGLint; stdcall;

PFNGLGETUNIFORMOFFSETEXTPROC = function(_program: TGLuint; location: TGLint): PGLint; stdcall;

PFNGLCLEARCOLORIIEXTPROC = procedure(r: TGLint; g: TGLint; b: TGLint; a: TGLint); stdcall;

PFNGLCLEARCOLORIUIEXTPROC = procedure(r: TGLuint; g: TGLuint; b: TGLuint; a: TGLuint); stdcall;

PFNGLTEXPARAMETERIIVEXTPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLTEXPARAMETERIUIVEXTPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLuint); stdcall;

PFNGLGETTEXPARAMETERIIVEXTPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLint); stdcall;

PFNGLGETTEXPARAMETERIUIVEXTPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLuint); stdcall;

PFNGLFRAMETERMINATORGREMEDYPROC = procedure(); stdcall;

PFNGLBEGINCONDITIONALRENDERNVPROC = procedure(id: TGLuint; mode: TGLenum); stdcall;

PFNGLENDCONDITIONALRENDERNVPROC = procedure(); stdcall;

PFNGLBINDBUFFERRANGEEXTPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint; offset:TGLintptr; size: TGLsizeiptr); stdcall;

PFNGLBINDBUFFEROFFSETEXTPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint; offset:TGLintptr); stdcall;

PFNGLBINDBUFFERBASEEXTPROC = procedure(target: TGLenum; index: TGLuint; buffer: TGLuint); stdcall;

PFNGLBEGINTRANSFORMFEEDBACKEXTPROC = procedure(primitiveMode: TGLenum); stdcall;

PFNGLENDTRANSFORMFEEDBACKEXTPROC = procedure(); stdcall;

PFNGLTRANSFORMFEEDBACKVARYINGSEXTPROC = procedure(_program: TGLuint; count: TGLsizei; const varyings: PGLPCharArray; bufferMode: TGLenum); stdcall;

PFNGLGETTRANSFORMFEEDBACKVARYINGEXTPROC = procedure(_program: TGLuint; index: TGLuint; bufSize: TGLsizei; length: PGLsizei; size: PGLsizei; _type: PGLenum; name: PGLChar); stdcall;

PFNGLTESSELLATIONFACTORAMDPROC = procedure(factor: GLfloat); stdcall;

PFNGLTESSELLATIONMODEAMDPROC = procedure(mode: TGLenum); stdcall;

PFNGLCOPYIMAGESUBDATANVPROC = procedure( srcName: GLuint; srcTarget: GLenum; srcLevel: GLint; srcX: GLint; srcY: GLint; srcZ: GLint; dstName: GLuint; dstTarget: GLenum; dstLevel: GLint; dstX: GLint; dstY: GLint; dstZ: GLint; width: GLsizei; height: GLsizei; depth: GLsizei); stdcall;

PFNGLMAKEBUFFERRESIDENTNVPROC = procedure(target: TGLenum; access: TGLenum); stdcall;

PFNGLMAKEBUFFERNONRESIDENTNVPROC = procedure(target: TGLenum); stdcall;

PFNGLISBUFFERRESIDENTNVPROC = function(target: TGLenum): TGLboolean; stdcall;

PFNGLMAKENAMEDBUFFERRESIDENTNVPROC = procedure(buffer: TGLuint; access: TGLenum); stdcall;

PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC = procedure(buffer: TGLuint); stdcall;

PFNGLISNAMEDBUFFERRESIDENTNVPROC = function (buffer: TGLuint): TGLboolean; stdcall;

PFNGLGETBUFFERPARAMETERUI64VNVPROC = procedure(target: TGLenum; pname: TGLenum; params: PGLuint64EXT ); stdcall;

PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC = procedure(buffer: TGLuint; pname: TGLenum; params: PGLuint64EXT); stdcall;

PFNGLGETINTEGERUI64VNVPROC = procedure(value: TGLenum; result: PGLuint64EXT); stdcall;

PFNGLUNIFORMUI64NVPROC = procedure(location: TGLint; value: TGLuint64EXT); stdcall;

PFNGLUNIFORMUI64VNVPROC = procedure(location: GLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

PFNGLGETUNIFORMUI64VNVPROC = procedure(_program: TGLuint; location: TGLint; params: PGLuint64EXT); stdcall;

PFNGLPROGRAMUNIFORMUI64NVPROC = procedure(_program: TGLuint; location: TGLint; value: TGLuint64EXT); stdcall;

PFNGLPROGRAMUNIFORMUI64VNVPROC = procedure(_program: TGLuint; location: TGLint; count: TGLsizei; const value: PGLuint64EXT); stdcall;

PFNGLBUFFERADDRESSRANGENVPROC = procedure(pname: TGLenum; index: TGLuint; address: TGLuint64EXT; length: TGLsizeiptr); stdcall;

PFNGLVERTEXFORMATNVPROC = procedure(size: TGLint; _type: TGLenum; stride: TGLsizei); stdcall;

PFNGLNORMALFORMATNVPROC = procedure(_type: TGLenum; stride: TGLsizei); stdcall;

PFNGLCOLORFORMATNVPROC = procedure(size: TGLint; _type: TGLenum; stride: TGLsizei); stdcall;

PFNGLINDEXFORMATNVPROC = procedure(_type: TGLenum; stride: TGLsizei); stdcall;

PFNGLTEXCOORDFORMATNVPROC = procedure(size: TGLint; _type: TGLenum; stride: TGLsizei); stdcall;

PFNGLEDGEFLAGFORMATNVPROC = procedure(stride: TGLsizei); stdcall;

PFNGLSECONDARYCOLORFORMATNVPROC = procedure(size: TGLint; _type: TGLenum; stride: TGLsizei); stdcall;

PFNGLFOGCOORDFORMATNVPROC = procedure(_type: TGLenum; stride: TGLsizei); stdcall;

PFNGLVERTEXATTRIBFORMATNVPROC = procedure(index: TGLuint; size: TGLint; _type: TGLenum; normalized: TGLboolean; stride: TGLsizei); stdcall;

PFNGLVERTEXATTRIBIFORMATNVPROC = procedure(index: TGLuint; size: TGLint; _type: TGLenum; stride: TGLsizei); stdcall;

PFNGLGETINTEGERUI64I_VNVPROC = procedure(value: TGLenum; index: TGLuint; result: PGLuint64EXT); stdcall;

PGNGLGETBUFFERPARAMETERUI64VNV = procedure(value: TGLenum; index: TGLuint; result: PGLuint64EXT); stdcall;

PFNGLGENPATHSNVPROC = function (range: GLsizei): GLuint; stdcall;

PFNGLDELETEPATHSNVPROC = procedure(path: GLuint; range: GLsizei); stdcall;

PFNGLISPATHNVPROC = function(path: GLuint): GLboolean; stdcall;

PFNGLPATHCOMMANDSNVPROC = procedure(path: GLuint; numCommands: GLsizei; commands: PGLubyte; numCoords: GLsizei; coordType: GLenum; coords: PGLvoid); stdcall;

PFNGLPATHCOORDSNVPROC = procedure(path: GLuint; numCoords: GLsizei; coordType: GLenum; coords: PGLvoid); stdcall;

PFNGLPATHSUBCOMMANDSNVPROC = procedure(path: GLuint; commandStart: GLsizei; commandsToDelete: GLsizei; numCommands: GLsizei; commands: PGLubyte; numCoords: GLsizei; coordType: GLenum; coords: PGLvoid); stdcall;

PFNGLPATHSUBCOORDSNVPROC = procedure(path: GLuint; coordStart: GLsizei; numCoords: GLsizei; coordType: GLenum; coords: PGLvoid); stdcall;

PFNGLPATHSTRINGNVPROC = procedure(path: GLuint; format: GLenum; length: GLsizei; pathString: PGLvoid); stdcall;

PFNGLPATHGLYPHSNVPROC = procedure(firstPathName: GLuint; fontTarget: GLenum; fontName: PGLvoid; fontStyle: GLbitfield; numGlyphs: GLsizei; _type: GLenum; charcodes: PGLvoid; handleMissingGlyphs: GLenum; pathParameterTemplate: GLuint; emScale: GLfloat); stdcall;

PFNGLPATHGLYPHRANGENVPROC = procedure(firstPathName: GLuint; fontTarget: GLenum; fontName: PGLChar; fontStyle: GLbitfield; firstGlyph: GLuint; numGlyphs: GLsizei; handleMissingGlyphs: GLenum; pathParameterTemplate: GLuint; emScale: GLfloat); stdcall;

PFNGLWEIGHTPATHSNVPROC = procedure (resultPath: GLuint; numPaths: GLsizei; paths: PGLuint; weights: PGLfloat); stdcall;

PFNGLCOPYPATHNVPROC = procedure (resultPath: GLuint; srcPath: GLuint); stdcall;

PFNGLINTERPOLATEPATHSNVPROC = procedure (resultPath: GLuint; pathA: GLuint; pathB: GLuint; weight: GLfloat); stdcall;

PFNGLTRANSFORMPATHNVPROC = procedure ( resultPath: GLuint; srcPath: GLuint; transformType: GLenum; transformValues: PGLfloat); stdcall;

PFNGLPATHPARAMETERIVNVPROC = procedure (path: GLuint; pname: GLenum; value: PGLint); stdcall;

PFNGLPATHPARAMETERINVPROC = procedure (path: GLuint; pname: GLenum; value: GLint); stdcall;

PFNGLPATHPARAMETERFVNVPROC = procedure (path: GLuint; pname: GLenum; value: PGLfloat); stdcall;

PFNGLPATHPARAMETERFNVPROC = procedure (path: GLuint; pname: GLenum; value: GLfloat); stdcall;

PFNGLPATHDASHARRAYNVPROC = procedure (path: GLuint; dashCount: GLsizei; dashArray: PGLfloat); stdcall;

PFNGLPATHSTENCILFUNCNVPROC = procedure (func: GLenum; ref: GLint; mask: GLuint); stdcall;

PFNGLPATHSTENCILDEPTHOFFSETNVPROC = procedure (factor: GLfloat; units: GLfloat); stdcall;

PFNGLSTENCILFILLPATHNVPROC = procedure (path: GLuint; fillMode: GLenum; mask: GLuint); stdcall;

PFNGLSTENCILSTROKEPATHNVPROC = procedure(path: GLuint; reference: GLint; mask: GLuint); stdcall;

PFNGLSTENCILFILLPATHINSTANCEDNVPROC = procedure (numPaths: GLsizei; pathNameType: GLenum; paths: PGLvoid; pathBase: GLuint; fillMode: GLenum; mask: GLuint; transformType: GLenum; transformValues: PGLfloat); stdcall;

PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC = procedure (numPaths: GLsizei; pathNameType: GLenum; paths: PGLvoid; pathBase: GLuint; reference: GLint; mask: GLuint; transformType: GLenum; transformValues: PGLfloat); stdcall;

PFNGLPATHCOVERDEPTHFUNCNVPROC = procedure (func: GLenum); stdcall;

PFNGLPATHCOLORGENNVPROC = procedure (color: GLenum; genMode: GLenum; colorFormat: GLenum; coeffs: PGLfloat); stdcall;

PFNGLPATHTEXGENNVPROC = procedure (texCoordSet: GLenum; genMode: GLenum; components: GLint; coeffs: PGLfloat); stdcall;

PFNGLPATHFOGGENNVPROC = procedure (genMode: GLenum); stdcall;

PFNGLCOVERFILLPATHNVPROC = procedure (path: GLuint; coverMode: GLenum); stdcall;

PFNGLCOVERSTROKEPATHNVPROC = procedure (path: GLuint; coverMode: GLenum); stdcall;

PFNGLCOVERFILLPATHINSTANCEDNVPROC = procedure (numPaths: GLsizei; pathNameType: GLenum; paths: PGLvoid; pathBase: GLuint; coverMode: GLenum; transformType: GLenum; transformValues: PGLfloat); stdcall;

PFNGLCOVERSTROKEPATHINSTANCEDNVPROC = procedure (numPaths: GLsizei; pathNameType: GLenum; paths: PGLvoid; pathBase: GLuint; coverMode: GLenum; transformType: GLenum; transformValues: PGLfloat); stdcall;

PFNGLGETPATHPARAMETERIVNVPROC = procedure (path: GLuint; pname: GLenum; value: PGLint); stdcall;

PFNGLGETPATHPARAMETERFVNVPROC = procedure (path: GLuint; pname: GLenum; value: PGLfloat); stdcall;

PFNGLGETPATHCOMMANDSNVPROC = procedure (path: GLuint; commands: PGLubyte); stdcall;

PFNGLGETPATHCOORDSNVPROC = procedure (path: GLuint; coords: PGLfloat); stdcall;

PFNGLGETPATHDASHARRAYNVPROC = procedure (path: GLuint; dashArray: PGLfloat); stdcall;

PFNGLGETPATHMETRICSNVPROC = procedure (metricQueryMask: GLbitfield; numPaths: GLsizei; pathNameType: GLenum; paths: PGLvoid; pathBase: GLuint; stride: GLsizei; metrics: PGLfloat); stdcall;

PFNGLGETPATHMETRICRANGENVPROC = procedure (metricQueryMask: GLbitfield; firstPathName: GLuint; numPaths: GLsizei; stride: GLsizei; metrics: PGLfloat); stdcall;

PFNGLGETPATHSPACINGNVPROC = procedure (pathListMode: GLenum; numPaths: GLsizei; pathNameType: GLenum; paths: PGLvoid; pathBase: GLuint; advanceScale: GLfloat; kerningScale: GLfloat; transformType: GLenum; returnedSpacing: PGLfloat); stdcall;

PFNGLGETPATHCOLORGENIVNVPROC = procedure (color: GLenum; pname: GLenum; value: PGLint); stdcall;

PFNGLGETPATHCOLORGENFVNVPROC = procedure (color: GLenum; pname: GLenum; value: PGLfloat); stdcall;

PFNGLGETPATHTEXGENIVNVPROC = procedure (texCoordSet: GLenum; pname: GLenum; value: PGLint); stdcall;

PFNGLGETPATHTEXGENFVNVPROC = procedure (texCoordSet: GLenum; pname: GLenum; value: PGLfloat); stdcall;

PFNGLISPOINTINFILLPATHNVPROC = function (path: GLuint; mask: GLuint; x: GLfloat; y: GLfloat): GLboolean; stdcall;

PFNGLISPOINTINSTROKEPATHNVPROC = function (path: GLuint; x: GLfloat; y: GLfloat): GLboolean; stdcall;

PFNGLGETPATHLENGTHNVPROC = function (path: GLuint; startSegment: GLsizei; numSegments: GLsizei): GLfloat; stdcall;

PFNGLPOINTALONGPATHNVPROC = function (path: GLuint; startSegment: GLsizei; numSegments: GLsizei; distance: GLfloat; x: PGLfloat; y: PGLfloat; tangentX: PGLfloat; tangentY: PGLfloat): GLboolean; stdcall;

Constants

opengl32 = 'OpenGL32.dll';

glu32 = 'GLU32.dll';

libEGL = 'libEGL.dll';

libGLES2 = 'libGLESv2.dll';

GL_DEPTH_BUFFER_BIT = $00000100;

GL_STENCIL_BUFFER_BIT = $00000400;

GL_COLOR_BUFFER_BIT = $00004000;

GL_FALSE = 0;

GL_TRUE = 1;

GL_POINTS = $0000;

GL_LINES = $0001;

GL_LINE_LOOP = $0002;

GL_LINE_STRIP = $0003;

GL_TRIANGLES = $0004;

GL_TRIANGLE_STRIP = $0005;

GL_TRIANGLE_FAN = $0006;

GL_NEVER = $0200;

GL_LESS = $0201;

GL_EQUAL = $0202;

GL_LEQUAL = $0203;

GL_GREATER = $0204;

GL_NOTEQUAL = $0205;

GL_GEQUAL = $0206;

GL_ALWAYS = $0207;

GL_ZERO = 0;

GL_ONE = 1;

GL_SRC_COLOR = $0300;

GL_ONE_MINUS_SRC_COLOR = $0301;

GL_SRC_ALPHA = $0302;

GL_ONE_MINUS_SRC_ALPHA = $0303;

GL_DST_ALPHA = $0304;

GL_ONE_MINUS_DST_ALPHA = $0305;

GL_DST_COLOR = $0306;

GL_ONE_MINUS_DST_COLOR = $0307;

GL_SRC_ALPHA_SATURATE = $0308;

GL_NONE = 0;

GL_FRONT_LEFT = $0400;

GL_FRONT_RIGHT = $0401;

GL_BACK_LEFT = $0402;

GL_BACK_RIGHT = $0403;

GL_FRONT = $0404;

GL_BACK = $0405;

GL_LEFT = $0406;

GL_RIGHT = $0407;

GL_FRONT_AND_BACK = $0408;

GL_NO_ERROR = 0;

GL_INVALID_ENUM = $0500;

GL_INVALID_VALUE = $0501;

GL_INVALID_OPERATION = $0502;

GL_OUT_OF_MEMORY = $0505;

GL_CW = $0900;

GL_CCW = $0901;

GL_POINT_SIZE = $0B11;

GL_POINT_SIZE_RANGE = $0B12;

GL_POINT_SIZE_GRANULARITY = $0B13;

GL_LINE_SMOOTH = $0B20;

GL_LINE_WIDTH = $0B21;

GL_LINE_WIDTH_RANGE = $0B22;

GL_LINE_WIDTH_GRANULARITY = $0B23;

GL_POLYGON_SMOOTH = $0B41;

GL_CULL_FACE = $0B44;

GL_CULL_FACE_MODE = $0B45;

GL_FRONT_FACE = $0B46;

GL_DEPTH_RANGE = $0B70;

GL_DEPTH_TEST = $0B71;

GL_DEPTH_WRITEMASK = $0B72;

GL_DEPTH_CLEAR_VALUE = $0B73;

GL_DEPTH_FUNC = $0B74;

GL_STENCIL_TEST = $0B90;

GL_STENCIL_CLEAR_VALUE = $0B91;

GL_STENCIL_FUNC = $0B92;

GL_STENCIL_VALUE_MASK = $0B93;

GL_STENCIL_FAIL = $0B94;

GL_STENCIL_PASS_DEPTH_FAIL = $0B95;

GL_STENCIL_PASS_DEPTH_PASS = $0B96;

GL_STENCIL_REF = $0B97;

GL_STENCIL_WRITEMASK = $0B98;

GL_MATRIX_MODE = $0BA0;

GL_VIEWPORT = $0BA2;

GL_DITHER = $0BD0;

GL_BLEND_DST = $0BE0;

GL_BLEND_SRC = $0BE1;

GL_BLEND = $0BE2;

GL_LOGIC_OP_MODE = $0BF0;

GL_COLOR_LOGIC_OP = $0BF2;

GL_DRAW_BUFFER = $0C01;

GL_READ_BUFFER = $0C02;

GL_SCISSOR_BOX = $0C10;

GL_SCISSOR_TEST = $0C11;

GL_COLOR_CLEAR_VALUE = $0C22;

GL_COLOR_WRITEMASK = $0C23;

GL_DOUBLEBUFFER = $0C32;

GL_STEREO = $0C33;

GL_LINE_SMOOTH_HINT = $0C52;

GL_POLYGON_SMOOTH_HINT = $0C53;

GL_UNPACK_SWAP_BYTES = $0CF0;

GL_UNPACK_LSB_FIRST = $0CF1;

GL_UNPACK_ROW_LENGTH = $0CF2;

GL_UNPACK_SKIP_ROWS = $0CF3;

GL_UNPACK_SKIP_PIXELS = $0CF4;

GL_UNPACK_ALIGNMENT = $0CF5;

GL_PACK_SWAP_BYTES = $0D00;

GL_PACK_LSB_FIRST = $0D01;

GL_PACK_ROW_LENGTH = $0D02;

GL_PACK_SKIP_ROWS = $0D03;

GL_PACK_SKIP_PIXELS = $0D04;

GL_PACK_ALIGNMENT = $0D05;

GL_MAX_TEXTURE_SIZE = $0D33;

GL_MAX_VIEWPORT_DIMS = $0D3A;

GL_SUBPIXEL_BITS = $0D50;

GL_TEXTURE_1D = $0DE0;

GL_TEXTURE_2D = $0DE1;

GL_POLYGON_OFFSET_UNITS = $2A00;

GL_POLYGON_OFFSET_POINT = $2A01;

GL_POLYGON_OFFSET_LINE = $2A02;

GL_POLYGON_OFFSET_FILL = $8037;

GL_POLYGON_OFFSET_FACTOR = $8038;

GL_TEXTURE_BINDING_1D = $8068;

GL_TEXTURE_BINDING_2D = $8069;

GL_TEXTURE_WIDTH = $1000;

GL_TEXTURE_HEIGHT = $1001;

GL_TEXTURE_INTERNAL_FORMAT = $1003;

GL_TEXTURE_BORDER_COLOR = $1004;

GL_TEXTURE_BORDER = $1005;

GL_TEXTURE_RED_SIZE = $805C;

GL_TEXTURE_GREEN_SIZE = $805D;

GL_TEXTURE_BLUE_SIZE = $805E;

GL_TEXTURE_ALPHA_SIZE = $805F;

GL_DONT_CARE = $1100;

GL_FASTEST = $1101;

GL_NICEST = $1102;

GL_BYTE = $1400;

GL_UNSIGNED_BYTE = $1401;

GL_SHORT = $1402;

GL_UNSIGNED_SHORT = $1403;

GL_INT = $1404;

GL_UNSIGNED_INT = $1405;

GL_FLOAT = $1406;

GL_DOUBLE = $140A;

GL_CLEAR = $1500;

GL_AND = $1501;

GL_AND_REVERSE = $1502;

GL_COPY = $1503;

GL_AND_INVERTED = $1504;

GL_NOOP = $1505;

GL_XOR = $1506;

GL_OR = $1507;

GL_NOR = $1508;

GL_EQUIV = $1509;

GL_INVERT = $150A;

GL_OR_REVERSE = $150B;

GL_COPY_INVERTED = $150C;

GL_OR_INVERTED = $150D;

GL_NAND = $150E;

GL_SET = $150F;

GL_TEXTURE = $1702;

GL_COLOR = $1800;

GL_DEPTH = $1801;

GL_STENCIL = $1802;

GL_STENCIL_INDEX = $1901;

GL_DEPTH_COMPONENT = $1902;

GL_RED = $1903;

GL_GREEN = $1904;

GL_BLUE = $1905;

GL_ALPHA = $1906;

GL_RGB = $1907;

GL_RGBA = $1908;

GL_POINT = $1B00;

GL_LINE = $1B01;

GL_FILL = $1B02;

GL_KEEP = $1E00;

GL_REPLACE = $1E01;

GL_INCR = $1E02;

GL_DECR = $1E03;

GL_VENDOR = $1F00;

GL_RENDERER = $1F01;

GL_VERSION = $1F02;

GL_EXTENSIONS = $1F03;

GL_NEAREST = $2600;

GL_LINEAR = $2601;

GL_NEAREST_MIPMAP_NEAREST = $2700;

GL_LINEAR_MIPMAP_NEAREST = $2701;

GL_NEAREST_MIPMAP_LINEAR = $2702;

GL_LINEAR_MIPMAP_LINEAR = $2703;

GL_TEXTURE_MAG_FILTER = $2800;

GL_TEXTURE_MIN_FILTER = $2801;

GL_TEXTURE_WRAP_S = $2802;

GL_TEXTURE_WRAP_T = $2803;

GL_PROXY_TEXTURE_1D = $8063;

GL_PROXY_TEXTURE_2D = $8064;

GL_REPEAT = $2901;

GL_R3_G3_B2 = $2A10;

GL_RGB4 = $804F;

GL_RGB5 = $8050;

GL_RGB8 = $8051;

GL_RGB10 = $8052;

GL_RGB12 = $8053;

GL_RGB16 = $8054;

GL_RGBA2 = $8055;

GL_RGBA4 = $8056;

GL_RGB5_A1 = $8057;

GL_RGBA8 = $8058;

GL_RGB10_A2 = $8059;

GL_RGBA12 = $805A;

GL_RGBA16 = $805B;

GL_CURRENT_BIT = $00000001 ;

GL_POINT_BIT = $00000002 ;

GL_LINE_BIT = $00000004 ;

GL_POLYGON_BIT = $00000008 ;

GL_POLYGON_STIPPLE_BIT = $00000010 ;

GL_PIXEL_MODE_BIT = $00000020 ;

GL_LIGHTING_BIT = $00000040 ;

GL_FOG_BIT = $00000080 ;

GL_ACCUM_BUFFER_BIT = $00000200 ;

GL_VIEWPORT_BIT = $00000800 ;

GL_TRANSFORM_BIT = $00001000 ;

GL_ENABLE_BIT = $00002000 ;

GL_HINT_BIT = $00008000 ;

GL_EVAL_BIT = $00010000 ;

GL_LIST_BIT = $00020000 ;

GL_TEXTURE_BIT = $00040000 ;

GL_SCISSOR_BIT = $00080000 ;

GL_ALL_ATTRIB_BITS = $FFFFFFFF ;

GL_CLIENT_PIXEL_STORE_BIT = $00000001 ;

GL_CLIENT_VERTEX_ARRAY_BIT = $00000002 ;

GL_CLIENT_ALL_ATTRIB_BITS = $FFFFFFFF ;

GL_QUADS = $0007 ;

GL_QUAD_STRIP = $0008 ;

GL_POLYGON = $0009 ;

GL_ACCUM = $0100 ;

GL_LOAD = $0101 ;

GL_RETURN = $0102 ;

GL_MULT = $0103 ;

GL_ADD = $0104 ;

GL_AUX0 = $0409 ;

GL_AUX1 = $040A ;

GL_AUX2 = $040B ;

GL_AUX3 = $040C ;

GL_STACK_OVERFLOW = $0503 ;

GL_STACK_UNDERFLOW = $0504 ;

GL_2D = $0600 ;

GL_3D = $0601 ;

GL_3D_COLOR = $0602 ;

GL_3D_COLOR_TEXTURE = $0603 ;

GL_4D_COLOR_TEXTURE = $0604 ;

GL_PASS_THROUGH_TOKEN = $0700 ;

GL_POINT_TOKEN = $0701 ;

GL_LINE_TOKEN = $0702 ;

GL_POLYGON_TOKEN = $0703 ;

GL_BITMAP_TOKEN = $0704 ;

GL_DRAW_PIXEL_TOKEN = $0705 ;

GL_COPY_PIXEL_TOKEN = $0706 ;

GL_LINE_RESET_TOKEN = $0707 ;

GL_EXP = $0800 ;

GL_EXP2 = $0801 ;

GL_COEFF = $0A00 ;

GL_ORDER = $0A01 ;

GL_DOMAIN = $0A02 ;

GL_CURRENT_COLOR = $0B00 ;

GL_CURRENT_INDEX = $0B01 ;

GL_CURRENT_NORMAL = $0B02 ;

GL_CURRENT_TEXTURE_COORDS = $0B03 ;

GL_CURRENT_RASTER_COLOR = $0B04 ;

GL_CURRENT_RASTER_INDEX = $0B05 ;

GL_CURRENT_RASTER_TEXTURE_COORDS = $0B06 ;

GL_CURRENT_RASTER_POSITION = $0B07 ;

GL_CURRENT_RASTER_POSITION_VALID = $0B08 ;

GL_CURRENT_RASTER_DISTANCE = $0B09 ;

GL_POINT_SMOOTH = $0B10 ;

GL_LINE_STIPPLE = $0B24 ;

GL_LINE_STIPPLE_PATTERN = $0B25 ;

GL_LINE_STIPPLE_REPEAT = $0B26 ;

GL_LIST_MODE = $0B30 ;

GL_MAX_LIST_NESTING = $0B31 ;

GL_LIST_BASE = $0B32 ;

GL_LIST_INDEX = $0B33 ;

GL_POLYGON_MODE = $0B40 ;

GL_POLYGON_STIPPLE = $0B42 ;

GL_EDGE_FLAG = $0B43 ;

GL_LIGHTING = $0B50 ;

GL_LIGHT_MODEL_LOCAL_VIEWER = $0B51 ;

GL_LIGHT_MODEL_TWO_SIDE = $0B52 ;

GL_LIGHT_MODEL_AMBIENT = $0B53 ;

GL_SHADE_MODEL = $0B54 ;

GL_COLOR_MATERIAL_FACE = $0B55 ;

GL_COLOR_MATERIAL_PARAMETER = $0B56 ;

GL_COLOR_MATERIAL = $0B57 ;

GL_FOG = $0B60 ;

GL_FOG_INDEX = $0B61 ;

GL_FOG_DENSITY = $0B62 ;

GL_FOG_START = $0B63 ;

GL_FOG_END = $0B64 ;

GL_FOG_MODE = $0B65 ;

GL_FOG_COLOR = $0B66 ;

GL_ACCUM_CLEAR_VALUE = $0B80 ;

GL_NORMALIZE = $0BA1 ;

GL_MODELVIEW_STACK_DEPTH = $0BA3 ;

GL_PROJECTION_STACK_DEPTH = $0BA4 ;

GL_TEXTURE_STACK_DEPTH = $0BA5 ;

GL_MODELVIEW_MATRIX = $0BA6 ;

GL_PROJECTION_MATRIX = $0BA7 ;

GL_TEXTURE_MATRIX = $0BA8 ;

GL_ATTRIB_STACK_DEPTH = $0BB0 ;

GL_CLIENT_ATTRIB_STACK_DEPTH = $0BB1 ;

GL_ALPHA_TEST = $0BC0 ;

GL_ALPHA_TEST_FUNC = $0BC1 ;

GL_ALPHA_TEST_REF = $0BC2 ;

GL_INDEX_LOGIC_OP = $0BF1 ;

GL_LOGIC_OP = $0BF1 ;

GL_AUX_BUFFERS = $0C00 ;

GL_INDEX_CLEAR_VALUE = $0C20 ;

GL_INDEX_WRITEMASK = $0C21 ;

GL_INDEX_MODE = $0C30 ;

GL_RGBA_MODE = $0C31 ;

GL_RENDER_MODE = $0C40 ;

GL_PERSPECTIVE_CORRECTION_HINT = $0C50 ;

GL_POINT_SMOOTH_HINT = $0C51 ;

GL_FOG_HINT = $0C54 ;

GL_TEXTURE_GEN_S = $0C60 ;

GL_TEXTURE_GEN_T = $0C61 ;

GL_TEXTURE_GEN_R = $0C62 ;

GL_TEXTURE_GEN_Q = $0C63 ;

GL_PIXEL_MAP_I_TO_I = $0C70 ;

GL_PIXEL_MAP_S_TO_S = $0C71 ;

GL_PIXEL_MAP_I_TO_R = $0C72 ;

GL_PIXEL_MAP_I_TO_G = $0C73 ;

GL_PIXEL_MAP_I_TO_B = $0C74 ;

GL_PIXEL_MAP_I_TO_A = $0C75 ;

GL_PIXEL_MAP_R_TO_R = $0C76 ;

GL_PIXEL_MAP_G_TO_G = $0C77 ;

GL_PIXEL_MAP_B_TO_B = $0C78 ;

GL_PIXEL_MAP_A_TO_A = $0C79 ;

GL_PIXEL_MAP_I_TO_I_SIZE = $0CB0 ;

GL_PIXEL_MAP_S_TO_S_SIZE = $0CB1 ;

GL_PIXEL_MAP_I_TO_R_SIZE = $0CB2 ;

GL_PIXEL_MAP_I_TO_G_SIZE = $0CB3 ;

GL_PIXEL_MAP_I_TO_B_SIZE = $0CB4 ;

GL_PIXEL_MAP_I_TO_A_SIZE = $0CB5 ;

GL_PIXEL_MAP_R_TO_R_SIZE = $0CB6 ;

GL_PIXEL_MAP_G_TO_G_SIZE = $0CB7 ;

GL_PIXEL_MAP_B_TO_B_SIZE = $0CB8 ;

GL_PIXEL_MAP_A_TO_A_SIZE = $0CB9 ;

GL_MAP_COLOR = $0D10 ;

GL_MAP_STENCIL = $0D11 ;

GL_INDEX_SHIFT = $0D12 ;

GL_INDEX_OFFSET = $0D13 ;

GL_RED_SCALE = $0D14 ;

GL_RED_BIAS = $0D15 ;

GL_ZOOM_X = $0D16 ;

GL_ZOOM_Y = $0D17 ;

GL_GREEN_SCALE = $0D18 ;

GL_GREEN_BIAS = $0D19 ;

GL_BLUE_SCALE = $0D1A ;

GL_BLUE_BIAS = $0D1B ;

GL_ALPHA_SCALE = $0D1C ;

GL_ALPHA_BIAS = $0D1D ;

GL_DEPTH_SCALE = $0D1E ;

GL_DEPTH_BIAS = $0D1F ;

GL_MAX_EVAL_ORDER = $0D30 ;

GL_MAX_LIGHTS = $0D31 ;

GL_MAX_CLIP_PLANES = $0D32 ;

GL_MAX_PIXEL_MAP_TABLE = $0D34 ;

GL_MAX_ATTRIB_STACK_DEPTH = $0D35 ;

GL_MAX_MODELVIEW_STACK_DEPTH = $0D36 ;

GL_MAX_NAME_STACK_DEPTH = $0D37 ;

GL_MAX_PROJECTION_STACK_DEPTH = $0D38 ;

GL_MAX_TEXTURE_STACK_DEPTH = $0D39 ;

GL_MAX_CLIENT_ATTRIB_STACK_DEPTH = $0D3B ;

GL_INDEX_BITS = $0D51 ;

GL_RED_BITS = $0D52 ;

GL_GREEN_BITS = $0D53 ;

GL_BLUE_BITS = $0D54 ;

GL_ALPHA_BITS = $0D55 ;

GL_DEPTH_BITS = $0D56 ;

GL_STENCIL_BITS = $0D57 ;

GL_ACCUM_RED_BITS = $0D58 ;

GL_ACCUM_GREEN_BITS = $0D59 ;

GL_ACCUM_BLUE_BITS = $0D5A ;

GL_ACCUM_ALPHA_BITS = $0D5B ;

GL_NAME_STACK_DEPTH = $0D70 ;

GL_AUTO_NORMAL = $0D80 ;

GL_MAP1_COLOR_4 = $0D90 ;

GL_MAP1_INDEX = $0D91 ;

GL_MAP1_NORMAL = $0D92 ;

GL_MAP1_TEXTURE_COORD_1 = $0D93 ;

GL_MAP1_TEXTURE_COORD_2 = $0D94 ;

GL_MAP1_TEXTURE_COORD_3 = $0D95 ;

GL_MAP1_TEXTURE_COORD_4 = $0D96 ;

GL_MAP1_VERTEX_3 = $0D97 ;

GL_MAP1_VERTEX_4 = $0D98 ;

GL_MAP2_COLOR_4 = $0DB0 ;

GL_MAP2_INDEX = $0DB1 ;

GL_MAP2_NORMAL = $0DB2 ;

GL_MAP2_TEXTURE_COORD_1 = $0DB3 ;

GL_MAP2_TEXTURE_COORD_2 = $0DB4 ;

GL_MAP2_TEXTURE_COORD_3 = $0DB5 ;

GL_MAP2_TEXTURE_COORD_4 = $0DB6 ;

GL_MAP2_VERTEX_3 = $0DB7 ;

GL_MAP2_VERTEX_4 = $0DB8 ;

GL_MAP1_GRID_DOMAIN = $0DD0 ;

GL_MAP1_GRID_SEGMENTS = $0DD1 ;

GL_MAP2_GRID_DOMAIN = $0DD2 ;

GL_MAP2_GRID_SEGMENTS = $0DD3 ;

GL_FEEDBACK_BUFFER_POINTER = $0DF0 ;

GL_FEEDBACK_BUFFER_SIZE = $0DF1 ;

GL_FEEDBACK_BUFFER_TYPE = $0DF2 ;

GL_SELECTION_BUFFER_POINTER = $0DF3 ;

GL_SELECTION_BUFFER_SIZE = $0DF4 ;

GL_TEXTURE_COMPONENTS = $1003 ;

GL_TEXTURE_LUMINANCE_SIZE = $8060 ;

GL_TEXTURE_INTENSITY_SIZE = $8061 ;

GL_TEXTURE_PRIORITY = $8066 ;

GL_TEXTURE_RESIDENT = $8067 ;

GL_AMBIENT = $1200 ;

GL_DIFFUSE = $1201 ;

GL_SPECULAR = $1202 ;

GL_POSITION = $1203 ;

GL_SPOT_DIRECTION = $1204 ;

GL_SPOT_EXPONENT = $1205 ;

GL_SPOT_CUTOFF = $1206 ;

GL_CONSTANT_ATTENUATION = $1207 ;

GL_LINEAR_ATTENUATION = $1208 ;

GL_QUADRATIC_ATTENUATION = $1209 ;

GL_COMPILE = $1300 ;

GL_COMPILE_AND_EXECUTE = $1301 ;

GL_2_BYTES = $1407 ;

GL_3_BYTES = $1408 ;

GL_4_BYTES = $1409 ;

GL_DOUBLE_EXT = $140A ;

GL_EMISSION = $1600 ;

GL_SHININESS = $1601 ;

GL_AMBIENT_AND_DIFFUSE = $1602 ;

GL_COLOR_INDEXES = $1603 ;

GL_MODELVIEW = $1700 ;

GL_PROJECTION = $1701 ;

GL_COLOR_INDEX = $1900 ;

GL_LUMINANCE = $1909 ;

GL_LUMINANCE_ALPHA = $190A ;

GL_BITMAP = $1A00 ;

GL_RENDER = $1C00 ;

GL_FEEDBACK = $1C01 ;

GL_SELECT = $1C02 ;

GL_FLAT = $1D00 ;

GL_SMOOTH = $1D01 ;

GL_S = $2000 ;

GL_T = $2001 ;

GL_R = $2002 ;

GL_Q = $2003 ;

GL_MODULATE = $2100 ;

GL_DECAL = $2101 ;

GL_TEXTURE_ENV_MODE = $2200 ;

GL_TEXTURE_ENV_COLOR = $2201 ;

GL_TEXTURE_ENV = $2300 ;

GL_EYE_LINEAR = $2400 ;

GL_OBJECT_LINEAR = $2401 ;

GL_SPHERE_MAP = $2402 ;

GL_TEXTURE_GEN_MODE = $2500 ;

GL_OBJECT_PLANE = $2501 ;

GL_EYE_PLANE = $2502 ;

GL_CLAMP = $2900 ;

GL_ALPHA4 = $803B ;

GL_ALPHA8 = $803C ;

GL_ALPHA12 = $803D ;

GL_ALPHA16 = $803E ;

GL_LUMINANCE4 = $803F ;

GL_LUMINANCE8 = $8040 ;

GL_LUMINANCE12 = $8041 ;

GL_LUMINANCE16 = $8042 ;

GL_LUMINANCE4_ALPHA4 = $8043 ;

GL_LUMINANCE6_ALPHA2 = $8044 ;

GL_LUMINANCE8_ALPHA8 = $8045 ;

GL_LUMINANCE12_ALPHA4 = $8046 ;

GL_LUMINANCE12_ALPHA12 = $8047 ;

GL_LUMINANCE16_ALPHA16 = $8048 ;

GL_INTENSITY = $8049 ;

GL_INTENSITY4 = $804A ;

GL_INTENSITY8 = $804B ;

GL_INTENSITY12 = $804C ;

GL_INTENSITY16 = $804D ;

GL_VERTEX_ARRAY = $8074 ;

GL_NORMAL_ARRAY = $8075 ;

GL_COLOR_ARRAY = $8076 ;

GL_INDEX_ARRAY = $8077 ;

GL_TEXTURE_COORD_ARRAY = $8078 ;

GL_EDGE_FLAG_ARRAY = $8079 ;

GL_VERTEX_ARRAY_SIZE = $807A ;

GL_VERTEX_ARRAY_TYPE = $807B ;

GL_VERTEX_ARRAY_STRIDE = $807C ;

GL_NORMAL_ARRAY_TYPE = $807E ;

GL_NORMAL_ARRAY_STRIDE = $807F ;

GL_COLOR_ARRAY_SIZE = $8081 ;

GL_COLOR_ARRAY_TYPE = $8082 ;

GL_COLOR_ARRAY_STRIDE = $8083 ;

GL_INDEX_ARRAY_TYPE = $8085 ;

GL_INDEX_ARRAY_STRIDE = $8086 ;

GL_TEXTURE_COORD_ARRAY_SIZE = $8088 ;

GL_TEXTURE_COORD_ARRAY_TYPE = $8089 ;

GL_TEXTURE_COORD_ARRAY_STRIDE = $808A ;

GL_EDGE_FLAG_ARRAY_STRIDE = $808C ;

GL_VERTEX_ARRAY_POINTER = $808E ;

GL_NORMAL_ARRAY_POINTER = $808F ;

GL_COLOR_ARRAY_POINTER = $8090 ;

GL_INDEX_ARRAY_POINTER = $8091 ;

GL_TEXTURE_COORD_ARRAY_POINTER = $8092 ;

GL_EDGE_FLAG_ARRAY_POINTER = $8093 ;

GL_V2F = $2A20 ;

GL_V3F = $2A21 ;

GL_C4UB_V2F = $2A22 ;

GL_C4UB_V3F = $2A23 ;

GL_C3F_V3F = $2A24 ;

GL_N3F_V3F = $2A25 ;

GL_C4F_N3F_V3F = $2A26 ;

GL_T2F_V3F = $2A27 ;

GL_T4F_V4F = $2A28 ;

GL_T2F_C4UB_V3F = $2A29 ;

GL_T2F_C3F_V3F = $2A2A ;

GL_T2F_N3F_V3F = $2A2B ;

GL_T2F_C4F_N3F_V3F = $2A2C ;

GL_T4F_C4F_N3F_V4F = $2A2D ;

GL_CLIP_PLANE0 = $3000 ;

GL_CLIP_PLANE1 = $3001 ;

GL_CLIP_PLANE2 = $3002 ;

GL_CLIP_PLANE3 = $3003 ;

GL_CLIP_PLANE4 = $3004 ;

GL_CLIP_PLANE5 = $3005 ;

GL_LIGHT0 = $4000 ;

GL_LIGHT1 = $4001 ;

GL_LIGHT2 = $4002 ;

GL_LIGHT3 = $4003 ;

GL_LIGHT4 = $4004 ;

GL_LIGHT5 = $4005 ;

GL_LIGHT6 = $4006 ;

GL_LIGHT7 = $4007 ;

GL_UNSIGNED_BYTE_3_3_2 = $8032;

GL_UNSIGNED_SHORT_4_4_4_4 = $8033;

GL_UNSIGNED_SHORT_5_5_5_1 = $8034;

GL_UNSIGNED_INT_8_8_8_8 = $8035;

GL_UNSIGNED_INT_10_10_10_2 = $8036;

GL_PACK_SKIP_IMAGES = $806B;

GL_PACK_IMAGE_HEIGHT = $806C;

GL_UNPACK_SKIP_IMAGES = $806D;

GL_UNPACK_IMAGE_HEIGHT = $806E;

GL_TEXTURE_3D = $806F;

GL_TEXTURE_BINDING_3D = $806A;

GL_PROXY_TEXTURE_3D = $8070;

GL_TEXTURE_DEPTH = $8071;

GL_TEXTURE_WRAP_R = $8072;

GL_MAX_3D_TEXTURE_SIZE = $8073;

GL_UNSIGNED_BYTE_2_3_3_REV = $8362;

GL_UNSIGNED_SHORT_5_6_5 = $8363;

GL_UNSIGNED_SHORT_5_6_5_REV = $8364;

GL_UNSIGNED_SHORT_4_4_4_4_REV = $8365;

GL_UNSIGNED_SHORT_1_5_5_5_REV = $8366;

GL_UNSIGNED_INT_8_8_8_8_REV = $8367;

GL_UNSIGNED_INT_2_10_10_10_REV = $8368;

GL_BGR = $80E0;

GL_BGRA = $80E1;

GL_MAX_ELEMENTS_VERTICES = $80E8;

GL_MAX_ELEMENTS_INDICES = $80E9;

GL_CLAMP_TO_EDGE = $812F;

GL_TEXTURE_MIN_LOD = $813A;

GL_TEXTURE_MAX_LOD = $813B;

GL_TEXTURE_BASE_LEVEL = $813C;

GL_TEXTURE_MAX_LEVEL = $813D;

GL_SMOOTH_POINT_SIZE_RANGE = $0B12;

GL_SMOOTH_POINT_SIZE_GRANULARITY = $0B13;

GL_SMOOTH_LINE_WIDTH_RANGE = $0B22;

GL_SMOOTH_LINE_WIDTH_GRANULARITY = $0B23;

GL_ALIASED_LINE_WIDTH_RANGE = $846E;

GL_CONSTANT_COLOR = $8001;

GL_ONE_MINUS_CONSTANT_COLOR = $8002;

GL_CONSTANT_ALPHA = $8003;

GL_ONE_MINUS_CONSTANT_ALPHA = $8004;

GL_BLEND_COLOR = $8005;

GL_FUNC_ADD = $8006;

GL_MIN = $8007;

GL_MAX = $8008;

GL_BLEND_EQUATION = $8009;

GL_FUNC_SUBTRACT = $800A;

GL_FUNC_REVERSE_SUBTRACT = $800B;

GL_RESCALE_NORMAL = $803A ;

GL_LIGHT_MODEL_COLOR_CONTROL = $81F8 ;

GL_SINGLE_COLOR = $81F9 ;

GL_SEPARATE_SPECULAR_COLOR = $81FA ;

GL_ALIASED_POINT_SIZE_RANGE = $846D ;

GL_CONVOLUTION_1D = $8010 ;

GL_CONVOLUTION_2D = $8011 ;

GL_SEPARABLE_2D = $8012 ;

GL_CONVOLUTION_BORDER_MODE = $8013 ;

GL_CONVOLUTION_FILTER_SCALE = $8014 ;

GL_CONVOLUTION_FILTER_BIAS = $8015 ;

GL_REDUCE = $8016 ;

GL_CONVOLUTION_FORMAT = $8017 ;

GL_CONVOLUTION_WIDTH = $8018 ;

GL_CONVOLUTION_HEIGHT = $8019 ;

GL_MAX_CONVOLUTION_WIDTH = $801A ;

GL_MAX_CONVOLUTION_HEIGHT = $801B ;

GL_POST_CONVOLUTION_RED_SCALE = $801C ;

GL_POST_CONVOLUTION_GREEN_SCALE = $801D ;

GL_POST_CONVOLUTION_BLUE_SCALE = $801E ;

GL_POST_CONVOLUTION_ALPHA_SCALE = $801F ;

GL_POST_CONVOLUTION_RED_BIAS = $8020 ;

GL_POST_CONVOLUTION_GREEN_BIAS = $8021 ;

GL_POST_CONVOLUTION_BLUE_BIAS = $8022 ;

GL_POST_CONVOLUTION_ALPHA_BIAS = $8023 ;

GL_HISTOGRAM = $8024 ;

GL_PROXY_HISTOGRAM = $8025 ;

GL_HISTOGRAM_WIDTH = $8026 ;

GL_HISTOGRAM_FORMAT = $8027 ;

GL_HISTOGRAM_RED_SIZE = $8028 ;

GL_HISTOGRAM_GREEN_SIZE = $8029 ;

GL_HISTOGRAM_BLUE_SIZE = $802A ;

GL_HISTOGRAM_ALPHA_SIZE = $802B ;

GL_HISTOGRAM_LUMINANCE_SIZE = $802C ;

GL_HISTOGRAM_SINK = $802D ;

GL_MINMAX = $802E ;

GL_MINMAX_FORMAT = $802F ;

GL_MINMAX_SINK = $8030 ;

GL_TABLE_TOO_LARGE = $8031 ;

GL_COLOR_MATRIX = $80B1 ;

GL_COLOR_MATRIX_STACK_DEPTH = $80B2 ;

GL_MAX_COLOR_MATRIX_STACK_DEPTH = $80B3 ;

GL_POST_COLOR_MATRIX_RED_SCALE = $80B4 ;

GL_POST_COLOR_MATRIX_GREEN_SCALE = $80B5 ;

GL_POST_COLOR_MATRIX_BLUE_SCALE = $80B6 ;

GL_POST_COLOR_MATRIX_ALPHA_SCALE = $80B7 ;

GL_POST_COLOR_MATRIX_RED_BIAS = $80B8 ;

GL_POST_COLOR_MATRIX_GREEN_BIAS = $80B9 ;

GL_POST_COLOR_MATRIX_BLUE_BIAS = $80BA ;

GL_POST_COLOR_MATRIX_ALPHA_BIAS = $80BB ;

GL_COLOR_TABLE = $80D0 ;

GL_POST_CONVOLUTION_COLOR_TABLE = $80D1 ;

GL_POST_COLOR_MATRIX_COLOR_TABLE = $80D2 ;

GL_PROXY_COLOR_TABLE = $80D3 ;

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE = $80D4 ;

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE = $80D5 ;

GL_COLOR_TABLE_SCALE = $80D6 ;

GL_COLOR_TABLE_BIAS = $80D7 ;

GL_COLOR_TABLE_FORMAT = $80D8 ;

GL_COLOR_TABLE_WIDTH = $80D9 ;

GL_COLOR_TABLE_RED_SIZE = $80DA ;

GL_COLOR_TABLE_GREEN_SIZE = $80DB ;

GL_COLOR_TABLE_BLUE_SIZE = $80DC ;

GL_COLOR_TABLE_ALPHA_SIZE = $80DD ;

GL_COLOR_TABLE_LUMINANCE_SIZE = $80DE ;

GL_COLOR_TABLE_INTENSITY_SIZE = $80DF ;

GL_CONSTANT_BORDER = $8151 ;

GL_REPLICATE_BORDER = $8153 ;

GL_CONVOLUTION_BORDER_COLOR = $8154 ;

GL_TEXTURE0 = $84C0;

GL_TEXTURE1 = $84C1;

GL_TEXTURE2 = $84C2;

GL_TEXTURE3 = $84C3;

GL_TEXTURE4 = $84C4;

GL_TEXTURE5 = $84C5;

GL_TEXTURE6 = $84C6;

GL_TEXTURE7 = $84C7;

GL_TEXTURE8 = $84C8;

GL_TEXTURE9 = $84C9;

GL_TEXTURE10 = $84CA;

GL_TEXTURE11 = $84CB;

GL_TEXTURE12 = $84CC;

GL_TEXTURE13 = $84CD;

GL_TEXTURE14 = $84CE;

GL_TEXTURE15 = $84CF;

GL_TEXTURE16 = $84D0;

GL_TEXTURE17 = $84D1;

GL_TEXTURE18 = $84D2;

GL_TEXTURE19 = $84D3;

GL_TEXTURE20 = $84D4;

GL_TEXTURE21 = $84D5;

GL_TEXTURE22 = $84D6;

GL_TEXTURE23 = $84D7;

GL_TEXTURE24 = $84D8;

GL_TEXTURE25 = $84D9;

GL_TEXTURE26 = $84DA;

GL_TEXTURE27 = $84DB;

GL_TEXTURE28 = $84DC;

GL_TEXTURE29 = $84DD;

GL_TEXTURE30 = $84DE;

GL_TEXTURE31 = $84DF;

GL_ACTIVE_TEXTURE = $84E0;

GL_MULTISAMPLE = $809D;

GL_SAMPLE_ALPHA_TO_COVERAGE = $809E;

GL_SAMPLE_ALPHA_TO_ONE = $809F;

GL_SAMPLE_COVERAGE = $80A0;

GL_SAMPLE_BUFFERS = $80A8;

GL_SAMPLES = $80A9;

GL_SAMPLE_COVERAGE_VALUE = $80AA;

GL_SAMPLE_COVERAGE_INVERT = $80AB;

GL_TEXTURE_CUBE_MAP = $8513;

GL_TEXTURE_BINDING_CUBE_MAP = $8514;

GL_TEXTURE_CUBE_MAP_POSITIVE_X = $8515;

GL_TEXTURE_CUBE_MAP_NEGATIVE_X = $8516;

GL_TEXTURE_CUBE_MAP_POSITIVE_Y = $8517;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y = $8518;

GL_TEXTURE_CUBE_MAP_POSITIVE_Z = $8519;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z = $851A;

GL_PROXY_TEXTURE_CUBE_MAP = $851B;

GL_MAX_CUBE_MAP_TEXTURE_SIZE = $851C;

GL_COMPRESSED_RGB = $84ED;

GL_COMPRESSED_RGBA = $84EE;

GL_TEXTURE_COMPRESSION_HINT = $84EF;

GL_TEXTURE_COMPRESSED_IMAGE_SIZE = $86A0;

GL_TEXTURE_COMPRESSED = $86A1;

GL_NUM_COMPRESSED_TEXTURE_FORMATS = $86A2;

GL_COMPRESSED_TEXTURE_FORMATS = $86A3;

GL_CLAMP_TO_BORDER = $812D;

GL_CLIENT_ACTIVE_TEXTURE = $84E1 ;

GL_MAX_TEXTURE_UNITS = $84E2 ;

GL_TRANSPOSE_MODELVIEW_MATRIX = $84E3 ;

GL_TRANSPOSE_PROJECTION_MATRIX = $84E4 ;

GL_TRANSPOSE_TEXTURE_MATRIX = $84E5 ;

GL_TRANSPOSE_COLOR_MATRIX = $84E6 ;

GL_MULTISAMPLE_BIT = $20000000 ;

GL_NORMAL_MAP = $8511 ;

GL_REFLECTION_MAP = $8512 ;

GL_COMPRESSED_ALPHA = $84E9 ;

GL_COMPRESSED_LUMINANCE = $84EA ;

GL_COMPRESSED_LUMINANCE_ALPHA = $84EB ;

GL_COMPRESSED_INTENSITY = $84EC ;

GL_COMBINE = $8570 ;

GL_COMBINE_RGB = $8571 ;

GL_COMBINE_ALPHA = $8572 ;

GL_SOURCE0_RGB = $8580 ;

GL_SOURCE1_RGB = $8581 ;

GL_SOURCE2_RGB = $8582 ;

GL_SOURCE0_ALPHA = $8588 ;

GL_SOURCE1_ALPHA = $8589 ;

GL_SOURCE2_ALPHA = $858A ;

GL_OPERAND0_RGB = $8590 ;

GL_OPERAND1_RGB = $8591 ;

GL_OPERAND2_RGB = $8592 ;

GL_OPERAND0_ALPHA = $8598 ;

GL_OPERAND1_ALPHA = $8599 ;

GL_OPERAND2_ALPHA = $859A ;

GL_RGB_SCALE = $8573 ;

GL_ADD_SIGNED = $8574 ;

GL_INTERPOLATE = $8575 ;

GL_SUBTRACT = $84E7 ;

GL_CONSTANT = $8576 ;

GL_PRIMARY_COLOR = $8577 ;

GL_PREVIOUS = $8578 ;

GL_DOT3_RGB = $86AE ;

GL_DOT3_RGBA = $86AF ;

GL_BLEND_DST_RGB = $80C8;

GL_BLEND_SRC_RGB = $80C9;

GL_BLEND_DST_ALPHA = $80CA;

GL_BLEND_SRC_ALPHA = $80CB;

GL_POINT_FADE_THRESHOLD_SIZE = $8128;

GL_DEPTH_COMPONENT16 = $81A5;

GL_DEPTH_COMPONENT24 = $81A6;

GL_DEPTH_COMPONENT32 = $81A7;

GL_MIRRORED_REPEAT = $8370;

GL_MAX_TEXTURE_LOD_BIAS = $84FD;

GL_TEXTURE_LOD_BIAS = $8501;

GL_INCR_WRAP = $8507;

GL_DECR_WRAP = $8508;

GL_TEXTURE_DEPTH_SIZE = $884A;

GL_TEXTURE_COMPARE_MODE = $884C;

GL_TEXTURE_COMPARE_FUNC = $884D;

GL_POINT_SIZE_MIN = $8126 ;

GL_POINT_SIZE_MAX = $8127 ;

GL_POINT_DISTANCE_ATTENUATION = $8129 ;

GL_GENERATE_MIPMAP = $8191 ;

GL_GENERATE_MIPMAP_HINT = $8192 ;

GL_FOG_COORDINATE_SOURCE = $8450 ;

GL_FOG_COORDINATE = $8451 ;

GL_FRAGMENT_DEPTH = $8452 ;

GL_CURRENT_FOG_COORDINATE = $8453 ;

GL_FOG_COORDINATE_ARRAY_TYPE = $8454 ;

GL_FOG_COORDINATE_ARRAY_STRIDE = $8455 ;

GL_FOG_COORDINATE_ARRAY_POINTER = $8456 ;

GL_FOG_COORDINATE_ARRAY = $8457 ;

GL_COLOR_SUM = $8458 ;

GL_CURRENT_SECONDARY_COLOR = $8459 ;

GL_SECONDARY_COLOR_ARRAY_SIZE = $845A ;

GL_SECONDARY_COLOR_ARRAY_TYPE = $845B ;

GL_SECONDARY_COLOR_ARRAY_STRIDE = $845C ;

GL_SECONDARY_COLOR_ARRAY_POINTER = $845D ;

GL_SECONDARY_COLOR_ARRAY = $845E ;

GL_TEXTURE_FILTER_CONTROL = $8500 ;

GL_DEPTH_TEXTURE_MODE = $884B ;

GL_COMPARE_R_TO_TEXTURE = $884E ;

GL_BUFFER_SIZE = $8764;

GL_BUFFER_USAGE = $8765;

GL_QUERY_COUNTER_BITS = $8864;

GL_CURRENT_QUERY = $8865;

GL_QUERY_RESULT = $8866;

GL_QUERY_RESULT_AVAILABLE = $8867;

GL_ARRAY_BUFFER = $8892;

GL_ELEMENT_ARRAY_BUFFER = $8893;

GL_ARRAY_BUFFER_BINDING = $8894;

GL_ELEMENT_ARRAY_BUFFER_BINDING = $8895;

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING = $889F;

GL_READ_ONLY = $88B8;

GL_WRITE_ONLY = $88B9;

GL_READ_WRITE = $88BA;

GL_BUFFER_ACCESS = $88BB;

GL_BUFFER_MAPPED = $88BC;

GL_BUFFER_MAP_POINTER = $88BD;

GL_STREAM_DRAW = $88E0;

GL_STREAM_READ = $88E1;

GL_STREAM_COPY = $88E2;

GL_STATIC_DRAW = $88E4;

GL_STATIC_READ = $88E5;

GL_STATIC_COPY = $88E6;

GL_DYNAMIC_DRAW = $88E8;

GL_DYNAMIC_READ = $88E9;

GL_DYNAMIC_COPY = $88EA;

GL_SAMPLES_PASSED = $8914;

GL_SRC1_ALPHA = GL_SOURCE1_ALPHA;

GL_VERTEX_ARRAY_BUFFER_BINDING = $8896 ;

GL_NORMAL_ARRAY_BUFFER_BINDING = $8897 ;

GL_COLOR_ARRAY_BUFFER_BINDING = $8898 ;

GL_INDEX_ARRAY_BUFFER_BINDING = $8899 ;

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING = $889A ;

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING = $889B ;

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING = $889C ;

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING = $889D ;

GL_WEIGHT_ARRAY_BUFFER_BINDING = $889E ;

GL_FOG_COORD_SRC = GL_FOG_COORDINATE_SOURCE ;

GL_FOG_COORD = GL_FOG_COORDINATE ;

GL_CURRENT_FOG_COORD = GL_CURRENT_FOG_COORDINATE ;

GL_FOG_COORD_ARRAY_TYPE = GL_FOG_COORDINATE_ARRAY_TYPE ;

GL_FOG_COORD_ARRAY_STRIDE = GL_FOG_COORDINATE_ARRAY_STRIDE ;

GL_FOG_COORD_ARRAY_POINTER = GL_FOG_COORDINATE_ARRAY_POINTER ;

GL_FOG_COORD_ARRAY = GL_FOG_COORDINATE_ARRAY ;

GL_FOG_COORD_ARRAY_BUFFER_BINDING = GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING ;

GL_SRC0_RGB = GL_SOURCE0_RGB ;

GL_SRC1_RGB = GL_SOURCE1_RGB ;

GL_SRC2_RGB = GL_SOURCE2_RGB ;

GL_SRC0_ALPHA = GL_SOURCE0_ALPHA ;

GL_SRC2_ALPHA = GL_SOURCE2_ALPHA ;

GL_BLEND_EQUATION_RGB = GL_BLEND_EQUATION;

GL_VERTEX_ATTRIB_ARRAY_ENABLED = $8622;

GL_VERTEX_ATTRIB_ARRAY_SIZE = $8623;

GL_VERTEX_ATTRIB_ARRAY_STRIDE = $8624;

GL_VERTEX_ATTRIB_ARRAY_TYPE = $8625;

GL_CURRENT_VERTEX_ATTRIB = $8626;

GL_VERTEX_PROGRAM_POINT_SIZE = $8642;

GL_VERTEX_ATTRIB_ARRAY_POINTER = $8645;

GL_STENCIL_BACK_FUNC = $8800;

GL_STENCIL_BACK_FAIL = $8801;

GL_STENCIL_BACK_PASS_DEPTH_FAIL = $8802;

GL_STENCIL_BACK_PASS_DEPTH_PASS = $8803;

GL_MAX_DRAW_BUFFERS = $8824;

GL_DRAW_BUFFER0 = $8825;

GL_DRAW_BUFFER1 = $8826;

GL_DRAW_BUFFER2 = $8827;

GL_DRAW_BUFFER3 = $8828;

GL_DRAW_BUFFER4 = $8829;

GL_DRAW_BUFFER5 = $882A;

GL_DRAW_BUFFER6 = $882B;

GL_DRAW_BUFFER7 = $882C;

GL_DRAW_BUFFER8 = $882D;

GL_DRAW_BUFFER9 = $882E;

GL_DRAW_BUFFER10 = $882F;

GL_DRAW_BUFFER11 = $8830;

GL_DRAW_BUFFER12 = $8831;

GL_DRAW_BUFFER13 = $8832;

GL_DRAW_BUFFER14 = $8833;

GL_DRAW_BUFFER15 = $8834;

GL_BLEND_EQUATION_ALPHA = $883D;

GL_MAX_VERTEX_ATTRIBS = $8869;

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED = $886A;

GL_MAX_TEXTURE_IMAGE_UNITS = $8872;

GL_FRAGMENT_SHADER = $8B30;

GL_VERTEX_SHADER = $8B31;

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS = $8B49;

GL_MAX_VERTEX_UNIFORM_COMPONENTS = $8B4A;

GL_MAX_VARYING_FLOATS = $8B4B ;

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS = $8B4C;

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS = $8B4D;

GL_SHADER_TYPE = $8B4F;

GL_FLOAT_VEC2 = $8B50;

GL_FLOAT_VEC3 = $8B51;

GL_FLOAT_VEC4 = $8B52;

GL_INT_VEC2 = $8B53;

GL_INT_VEC3 = $8B54;

GL_INT_VEC4 = $8B55;

GL_BOOL = $8B56;

GL_BOOL_VEC2 = $8B57;

GL_BOOL_VEC3 = $8B58;

GL_BOOL_VEC4 = $8B59;

GL_FLOAT_MAT2 = $8B5A;

GL_FLOAT_MAT3 = $8B5B;

GL_FLOAT_MAT4 = $8B5C;

GL_SAMPLER_1D = $8B5D;

GL_SAMPLER_2D = $8B5E;

GL_SAMPLER_3D = $8B5F;

GL_SAMPLER_CUBE = $8B60;

GL_SAMPLER_1D_SHADOW = $8B61;

GL_SAMPLER_2D_SHADOW = $8B62;

GL_DELETE_STATUS = $8B80;

GL_COMPILE_STATUS = $8B81;

GL_LINK_STATUS = $8B82;

GL_VALIDATE_STATUS = $8B83;

GL_INFO_LOG_LENGTH = $8B84;

GL_ATTACHED_SHADERS = $8B85;

GL_ACTIVE_UNIFORMS = $8B86;

GL_ACTIVE_UNIFORM_MAX_LENGTH = $8B87;

GL_SHADER_SOURCE_LENGTH = $8B88;

GL_ACTIVE_ATTRIBUTES = $8B89;

GL_ACTIVE_ATTRIBUTE_MAX_LENGTH = $8B8A;

GL_FRAGMENT_SHADER_DERIVATIVE_HINT = $8B8B;

GL_SHADING_LANGUAGE_VERSION = $8B8C;

GL_CURRENT_PROGRAM = $8B8D;

GL_POINT_SPRITE_COORD_ORIGIN = $8CA0;

GL_LOWER_LEFT = $8CA1;

GL_UPPER_LEFT = $8CA2;

GL_STENCIL_BACK_REF = $8CA3;

GL_STENCIL_BACK_VALUE_MASK = $8CA4;

GL_STENCIL_BACK_WRITEMASK = $8CA5;

GL_VERTEX_PROGRAM_TWO_SIDE = $8643 ;

GL_POINT_SPRITE = $8861 ;

GL_COORD_REPLACE = $8862 ;

GL_MAX_TEXTURE_COORDS = $8871 ;

GL_PIXEL_PACK_BUFFER = $88EB;

GL_PIXEL_UNPACK_BUFFER = $88EC;

GL_PIXEL_PACK_BUFFER_BINDING = $88ED;

GL_PIXEL_UNPACK_BUFFER_BINDING = $88EF;

GL_FLOAT_MAT2x3 = $8B65;

GL_FLOAT_MAT2x4 = $8B66;

GL_FLOAT_MAT3x2 = $8B67;

GL_FLOAT_MAT3x4 = $8B68;

GL_FLOAT_MAT4x2 = $8B69;

GL_FLOAT_MAT4x3 = $8B6A;

GL_SRGB = $8C40;

GL_SRGB8 = $8C41;

GL_SRGB_ALPHA = $8C42;

GL_SRGB8_ALPHA8 = $8C43;

GL_COMPRESSED_SRGB = $8C48;

GL_COMPRESSED_SRGB_ALPHA = $8C49;

GL_CURRENT_RASTER_SECONDARY_COLOR = $845F ;

GL_SLUMINANCE_ALPHA = $8C44 ;

GL_SLUMINANCE8_ALPHA8 = $8C45 ;

GL_SLUMINANCE = $8C46 ;

GL_SLUMINANCE8 = $8C47 ;

GL_COMPRESSED_SLUMINANCE = $8C4A ;

GL_COMPRESSED_SLUMINANCE_ALPHA = $8C4B ;

GL_COMPARE_REF_TO_TEXTURE = $884E;

GL_CLIP_DISTANCE0 = $3000;

GL_CLIP_DISTANCE1 = $3001;

GL_CLIP_DISTANCE2 = $3002;

GL_CLIP_DISTANCE3 = $3003;

GL_CLIP_DISTANCE4 = $3004;

GL_CLIP_DISTANCE5 = $3005;

GL_CLIP_DISTANCE6 = $3006;

GL_CLIP_DISTANCE7 = $3007;

GL_MAX_CLIP_DISTANCES = $0D32;

GL_MAJOR_VERSION = $821B;

GL_MINOR_VERSION = $821C;

GL_NUM_EXTENSIONS = $821D;

GL_CONTEXT_FLAGS = $821E;

GL_DEPTH_BUFFER = $8223;

GL_STENCIL_BUFFER = $8224;

GL_COMPRESSED_RED = $8225;

GL_COMPRESSED_RG = $8226;

GL_CONTEXT_FLAG_FORWARD_COMPATIBLE_BIT = $0001;

GL_RGBA32F = $8814;

GL_RGB32F = $8815;

GL_RGBA16F = $881A;

GL_RGB16F = $881B;

GL_VERTEX_ATTRIB_ARRAY_INTEGER = $88FD;

GL_MAX_ARRAY_TEXTURE_LAYERS = $88FF;

GL_MIN_PROGRAM_TEXEL_OFFSET = $8904;

GL_MAX_PROGRAM_TEXEL_OFFSET = $8905;

GL_CLAMP_VERTEX_COLOR = $891A;

GL_CLAMP_FRAGMENT_COLOR = $891B;

GL_CLAMP_READ_COLOR = $891C;

GL_FIXED_ONLY = $891D;

GL_MAX_VARYING_COMPONENTS = GL_MAX_VARYING_FLOATS ;

GL_TEXTURE_1D_ARRAY = $8C18;

GL_PROXY_TEXTURE_1D_ARRAY = $8C19;

GL_TEXTURE_2D_ARRAY = $8C1A;

GL_PROXY_TEXTURE_2D_ARRAY = $8C1B;

GL_TEXTURE_BINDING_1D_ARRAY = $8C1C;

GL_TEXTURE_BINDING_2D_ARRAY = $8C1D;

GL_R11F_G11F_B10F = $8C3A;

GL_UNSIGNED_INT_10F_11F_11F_REV = $8C3B;

GL_RGB9_E5 = $8C3D;

GL_UNSIGNED_INT_5_9_9_9_REV = $8C3E;

GL_TEXTURE_SHARED_SIZE = $8C3F;

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH = $8C76;

GL_TRANSFORM_FEEDBACK_BUFFER_MODE = $8C7F;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS = $8C80;

GL_TRANSFORM_FEEDBACK_VARYINGS = $8C83;

GL_TRANSFORM_FEEDBACK_BUFFER_START = $8C84;

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE = $8C85;

GL_PRIMITIVES_GENERATED = $8C87;

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN = $8C88;

GL_RASTERIZER_DISCARD = $8C89;

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS = $8C8A;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS = $8C8B;

GL_INTERLEAVED_ATTRIBS = $8C8C;

GL_SEPARATE_ATTRIBS = $8C8D;

GL_TRANSFORM_FEEDBACK_BUFFER = $8C8E;

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING = $8C8F;

GL_RGBA32UI = $8D70;

GL_RGB32UI = $8D71;

GL_RGBA16UI = $8D76;

GL_RGB16UI = $8D77;

GL_RGBA8UI = $8D7C;

GL_RGB8UI = $8D7D;

GL_RGBA32I = $8D82;

GL_RGB32I = $8D83;

GL_RGBA16I = $8D88;

GL_RGB16I = $8D89;

GL_RGBA8I = $8D8E;

GL_RGB8I = $8D8F;

GL_RED_INTEGER = $8D94;

GL_GREEN_INTEGER = $8D95;

GL_BLUE_INTEGER = $8D96;

GL_ALPHA_INTEGER = $8D97;

GL_RGB_INTEGER = $8D98;

GL_RGBA_INTEGER = $8D99;

GL_BGR_INTEGER = $8D9A;

GL_BGRA_INTEGER = $8D9B;

GL_SAMPLER_1D_ARRAY = $8DC0;

GL_SAMPLER_2D_ARRAY = $8DC1;

GL_SAMPLER_1D_ARRAY_SHADOW = $8DC3;

GL_SAMPLER_2D_ARRAY_SHADOW = $8DC4;

GL_SAMPLER_CUBE_SHADOW = $8DC5;

GL_UNSIGNED_INT_VEC2 = $8DC6;

GL_UNSIGNED_INT_VEC3 = $8DC7;

GL_UNSIGNED_INT_VEC4 = $8DC8;

GL_INT_SAMPLER_1D = $8DC9;

GL_INT_SAMPLER_2D = $8DCA;

GL_INT_SAMPLER_3D = $8DCB;

GL_INT_SAMPLER_CUBE = $8DCC;

GL_INT_SAMPLER_1D_ARRAY = $8DCE;

GL_INT_SAMPLER_2D_ARRAY = $8DCF;

GL_UNSIGNED_INT_SAMPLER_1D = $8DD1;

GL_UNSIGNED_INT_SAMPLER_2D = $8DD2;

GL_UNSIGNED_INT_SAMPLER_3D = $8DD3;

GL_UNSIGNED_INT_SAMPLER_CUBE = $8DD4;

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY = $8DD6;

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY = $8DD7;

GL_QUERY_WAIT = $8E13;

GL_QUERY_NO_WAIT = $8E14;

GL_QUERY_BY_REGION_WAIT = $8E15;

GL_QUERY_BY_REGION_NO_WAIT = $8E16;

GL_BUFFER_ACCESS_FLAGS = $911F;

GL_BUFFER_MAP_LENGTH = $9120;

GL_BUFFER_MAP_OFFSET = $9121;

GL_SAMPLER_2D_RECT = $8B63;

GL_SAMPLER_2D_RECT_SHADOW = $8B64;

GL_SAMPLER_BUFFER = $8DC2;

GL_INT_SAMPLER_2D_RECT = $8DCD;

GL_INT_SAMPLER_BUFFER = $8DD0;

GL_UNSIGNED_INT_SAMPLER_2D_RECT = $8DD5;

GL_UNSIGNED_INT_SAMPLER_BUFFER = $8DD8;

GL_TEXTURE_BUFFER = $8C2A;

GL_MAX_TEXTURE_BUFFER_SIZE = $8C2B;

GL_TEXTURE_BINDING_BUFFER = $8C2C;

GL_TEXTURE_BUFFER_DATA_STORE_BINDING = $8C2D;

GL_TEXTURE_BUFFER_FORMAT = $8C2E;

GL_TEXTURE_RECTANGLE = $84F5;

GL_TEXTURE_BINDING_RECTANGLE = $84F6;

GL_PROXY_TEXTURE_RECTANGLE = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE = $84F8;

GL_RED_SNORM = $8F90;

GL_RG_SNORM = $8F91;

GL_RGB_SNORM = $8F92;

GL_RGBA_SNORM = $8F93;

GL_R8_SNORM = $8F94;

GL_RG8_SNORM = $8F95;

GL_RGB8_SNORM = $8F96;

GL_RGBA8_SNORM = $8F97;

GL_R16_SNORM = $8F98;

GL_RG16_SNORM = $8F99;

GL_RGB16_SNORM = $8F9A;

GL_RGBA16_SNORM = $8F9B;

GL_SIGNED_NORMALIZED = $8F9C;

GL_PRIMITIVE_RESTART = $8F9D;

GL_PRIMITIVE_RESTART_INDEX = $8F9E;

GL_COMPRESSED_RGBA_BPTC_UNORM_ARB = $8E8C;

GL_COMPRESSED_SRGB_ALPHA_BPTC_UNORM_ARB = $8E8D;

GL_COMPRESSED_RGB_BPTC_SIGNED_FLOAT_ARB = $8E8E;

GL_COMPRESSED_RGB_BPTC_UNSIGNED_FLOAT_ARB = $8E8F;

GL_CONTEXT_CORE_PROFILE_BIT = $00000001;

GL_CONTEXT_COMPATIBILITY_PROFILE_BIT = $00000002;

GL_LINES_ADJACENCY = $000A;

GL_LINE_STRIP_ADJACENCY = $000B;

GL_TRIANGLES_ADJACENCY = $000C;

GL_TRIANGLE_STRIP_ADJACENCY = $000D;

GL_PROGRAM_POINT_SIZE = $8642;

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS = $8C29;

GL_FRAMEBUFFER_ATTACHMENT_LAYERED = $8DA7;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS = $8DA8;

GL_GEOMETRY_SHADER = $8DD9;

GL_GEOMETRY_VERTICES_OUT = $8916;

GL_GEOMETRY_INPUT_TYPE = $8917;

GL_GEOMETRY_OUTPUT_TYPE = $8918;

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS = $8DDF;

GL_MAX_GEOMETRY_OUTPUT_VERTICES = $8DE0;

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS = $8DE1;

GL_MAX_VERTEX_OUTPUT_COMPONENTS = $9122;

GL_MAX_GEOMETRY_INPUT_COMPONENTS = $9123;

GL_MAX_GEOMETRY_OUTPUT_COMPONENTS = $9124;

GL_MAX_FRAGMENT_INPUT_COMPONENTS = $9125;

GL_CONTEXT_PROFILE_MASK = $9126;

GL_VERTEX_ATTRIB_ARRAY_DIVISOR = $88FE;

GL_SAMPLE_SHADING = $8C36;

GL_MIN_SAMPLE_SHADING_VALUE = $8C37;

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET = $8E5E;

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET = $8E5F;

GL_TEXTURE_CUBE_MAP_ARRAY = $9009;

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY = $900A;

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY = $900B;

GL_SAMPLER_CUBE_MAP_ARRAY = $900C;

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW = $900D;

GL_INT_SAMPLER_CUBE_MAP_ARRAY = $900E;

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY = $900F;

GL_ACTIVE_TEXTURE_ARB = $84E0;

GL_CLIENT_ACTIVE_TEXTURE_ARB = $84E1;

GL_MAX_TEXTURE_UNITS_ARB = $84E2;

GL_TEXTURE0_ARB = $84C0;

GL_TEXTURE1_ARB = $84C1;

GL_TEXTURE2_ARB = $84C2;

GL_TEXTURE3_ARB = $84C3;

GL_TEXTURE4_ARB = $84C4;

GL_TEXTURE5_ARB = $84C5;

GL_TEXTURE6_ARB = $84C6;

GL_TEXTURE7_ARB = $84C7;

GL_TEXTURE8_ARB = $84C8;

GL_TEXTURE9_ARB = $84C9;

GL_TEXTURE10_ARB = $84CA;

GL_TEXTURE11_ARB = $84CB;

GL_TEXTURE12_ARB = $84CC;

GL_TEXTURE13_ARB = $84CD;

GL_TEXTURE14_ARB = $84CE;

GL_TEXTURE15_ARB = $84CF;

GL_TEXTURE16_ARB = $84D0;

GL_TEXTURE17_ARB = $84D1;

GL_TEXTURE18_ARB = $84D2;

GL_TEXTURE19_ARB = $84D3;

GL_TEXTURE20_ARB = $84D4;

GL_TEXTURE21_ARB = $84D5;

GL_TEXTURE22_ARB = $84D6;

GL_TEXTURE23_ARB = $84D7;

GL_TEXTURE24_ARB = $84D8;

GL_TEXTURE25_ARB = $84D9;

GL_TEXTURE26_ARB = $84DA;

GL_TEXTURE27_ARB = $84DB;

GL_TEXTURE28_ARB = $84DC;

GL_TEXTURE29_ARB = $84DD;

GL_TEXTURE30_ARB = $84DE;

GL_TEXTURE31_ARB = $84DF;

GL_TRANSPOSE_MODELVIEW_MATRIX_ARB = $84E3;

GL_TRANSPOSE_PROJECTION_MATRIX_ARB = $84E4;

GL_TRANSPOSE_TEXTURE_MATRIX_ARB = $84E5;

GL_TRANSPOSE_COLOR_MATRIX_ARB = $84E6;

WGL_FRONT_COLOR_BUFFER_BIT_ARB = $00000001;

WGL_BACK_COLOR_BUFFER_BIT_ARB = $00000002;

WGL_DEPTH_BUFFER_BIT_ARB = $00000004;

WGL_STENCIL_BUFFER_BIT_ARB = $00000008;

GL_MULTISAMPLE_ARB = $809D;

GL_SAMPLE_ALPHA_TO_COVERAGE_ARB = $809E;

GL_SAMPLE_ALPHA_TO_ONE_ARB = $809F;

GL_SAMPLE_COVERAGE_ARB = $80A0;

GL_SAMPLE_BUFFERS_ARB = $80A8;

GL_SAMPLES_ARB = $80A9;

GL_SAMPLE_COVERAGE_VALUE_ARB = $80AA;

GL_SAMPLE_COVERAGE_INVERT_ARB = $80AB;

GL_MULTISAMPLE_BIT_ARB = $20000000;

GLX_SAMPLE_BUFFERS_ARB = 100000;

GLX_SAMPLES_ARB = 100001;

WGL_SAMPLE_BUFFERS_ARB = $2041;

WGL_SAMPLES_ARB = $2042;

GLX_SAMPLE_BUFFERS_SGIS = $100000;

GLX_SAMPLES_SGIS = $100001;

GLX_SAMPLE_BUFFERS = $100000;

GLX_SAMPLES = $100001;

GL_NORMAL_MAP_ARB = $8511;

GL_REFLECTION_MAP_ARB = $8512;

GL_TEXTURE_CUBE_MAP_ARB = $8513;

GL_TEXTURE_BINDING_CUBE_MAP_ARB = $8514;

GL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $8515;

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $8516;

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $8517;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $8518;

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $8519;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $851A;

GL_PROXY_TEXTURE_CUBE_MAP_ARB = $851B;

GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB = $851C;

WGL_NUMBER_PIXEL_FORMATS_ARB = $2000;

WGL_DRAW_TO_WINDOW_ARB = $2001;

WGL_DRAW_TO_BITMAP_ARB = $2002;

WGL_ACCELERATION_ARB = $2003;

WGL_NEED_PALETTE_ARB = $2004;

WGL_NEED_SYSTEM_PALETTE_ARB = $2005;

WGL_SWAP_LAYER_BUFFERS_ARB = $2006;

WGL_SWAP_METHOD_ARB = $2007;

WGL_NUMBER_OVERLAYS_ARB = $2008;

WGL_NUMBER_UNDERLAYS_ARB = $2009;

WGL_TRANSPARENT_ARB = $200A;

WGL_TRANSPARENT_RED_VALUE_ARB = $2037;

WGL_TRANSPARENT_GREEN_VALUE_ARB = $2038;

WGL_TRANSPARENT_BLUE_VALUE_ARB = $2039;

WGL_TRANSPARENT_ALPHA_VALUE_ARB = $203A;

WGL_TRANSPARENT_INDEX_VALUE_ARB = $203B;

WGL_SHARE_DEPTH_ARB = $200C;

WGL_SHARE_STENCIL_ARB = $200D;

WGL_SHARE_ACCUM_ARB = $200E;

WGL_SUPPORT_GDI_ARB = $200F;

WGL_SUPPORT_OPENGL_ARB = $2010;

WGL_DOUBLE_BUFFER_ARB = $2011;

WGL_STEREO_ARB = $2012;

WGL_PIXEL_TYPE_ARB = $2013;

WGL_COLOR_BITS_ARB = $2014;

WGL_RED_BITS_ARB = $2015;

WGL_RED_SHIFT_ARB = $2016;

WGL_GREEN_BITS_ARB = $2017;

WGL_GREEN_SHIFT_ARB = $2018;

WGL_BLUE_BITS_ARB = $2019;

WGL_BLUE_SHIFT_ARB = $201A;

WGL_ALPHA_BITS_ARB = $201B;

WGL_ALPHA_SHIFT_ARB = $201C;

WGL_ACCUM_BITS_ARB = $201D;

WGL_ACCUM_RED_BITS_ARB = $201E;

WGL_ACCUM_GREEN_BITS_ARB = $201F;

WGL_ACCUM_BLUE_BITS_ARB = $2020;

WGL_ACCUM_ALPHA_BITS_ARB = $2021;

WGL_DEPTH_BITS_ARB = $2022;

WGL_STENCIL_BITS_ARB = $2023;

WGL_AUX_BUFFERS_ARB = $2024;

WGL_NO_ACCELERATION_ARB = $2025;

WGL_GENERIC_ACCELERATION_ARB = $2026;

WGL_FULL_ACCELERATION_ARB = $2027;

WGL_SWAP_EXCHANGE_ARB = $2028;

WGL_SWAP_COPY_ARB = $2029;

WGL_SWAP_UNDEFINED_ARB = $202A;

WGL_TYPE_RGBA_ARB = $202B;

WGL_TYPE_COLORINDEX_ARB = $202C;

ERROR_INVALID_PIXEL_TYPE_ARB = $2043;

ERROR_INCOMPATIBLE_DEVICE_CONTEXTS_ARB = $2054;

WGL_DRAW_TO_PBUFFER_ARB = $202D;

WGL_MAX_PBUFFER_PIXELS_ARB = $202E;

WGL_MAX_PBUFFER_WIDTH_ARB = $202F;

WGL_MAX_PBUFFER_HEIGHT_ARB = $2030;

WGL_PBUFFER_LARGEST_ARB = $2033;

WGL_PBUFFER_WIDTH_ARB = $2034;

WGL_PBUFFER_HEIGHT_ARB = $2035;

WGL_PBUFFER_LOST_ARB = $2036;

GL_COMPRESSED_ALPHA_ARB = $84E9;

GL_COMPRESSED_LUMINANCE_ARB = $84EA;

GL_COMPRESSED_LUMINANCE_ALPHA_ARB = $84EB;

GL_COMPRESSED_INTENSITY_ARB = $84EC;

GL_COMPRESSED_RGB_ARB = $84ED;

GL_COMPRESSED_RGBA_ARB = $84EE;

GL_TEXTURE_COMPRESSION_HINT_ARB = $84EF;

GL_TEXTURE_COMPRESSED_IMAGE_SIZE_ARB = $86A0;

GL_TEXTURE_COMPRESSED_ARB = $86A1;

GL_NUM_COMPRESSED_TEXTURE_FORMATS_ARB = $86A2;

GL_COMPRESSED_TEXTURE_FORMATS_ARB = $86A3;

GL_CLAMP_TO_BORDER_ARB = $812D;

GL_POINT_SIZE_MIN_ARB = $8126;

GL_POINT_SIZE_MAX_ARB = $8127;

GL_POINT_FADE_THRESHOLD_SIZE_ARB = $8128;

GL_DISTANCE_ATTENUATION_ARB = $8129;

GL_MAX_VERTEX_UNITS_ARB = $86A4;

GL_ACTIVE_VERTEX_UNITS_ARB = $86A5;

GL_WEIGHT_SUM_UNITY_ARB = $86A6;

GL_VERTEX_BLEND_ARB = $86A7;

GL_CURRENT_WEIGHT_ARB = $86A8;

GL_WEIGHT_ARRAY_TYPE_ARB = $86A9;

GL_WEIGHT_ARRAY_STRIDE_ARB = $86AA;

GL_WEIGHT_ARRAY_SIZE_ARB = $86AB;

GL_WEIGHT_ARRAY_POINTER_ARB = $86AC;

GL_WEIGHT_ARRAY_ARB = $86AD;

GL_MODELVIEW0_ARB = $1700;

GL_MODELVIEW1_ARB = $850A;

GL_MODELVIEW2_ARB = $8722;

GL_MODELVIEW3_ARB = $8723;

GL_MODELVIEW4_ARB = $8724;

GL_MODELVIEW5_ARB = $8725;

GL_MODELVIEW6_ARB = $8726;

GL_MODELVIEW7_ARB = $8727;

GL_MODELVIEW8_ARB = $8728;

GL_MODELVIEW9_ARB = $8729;

GL_MODELVIEW10_ARB = $872A;

GL_MODELVIEW11_ARB = $872B;

GL_MODELVIEW12_ARB = $872C;

GL_MODELVIEW13_ARB = $872D;

GL_MODELVIEW14_ARB = $872E;

GL_MODELVIEW15_ARB = $872F;

GL_MODELVIEW16_ARB = $8730;

GL_MODELVIEW17_ARB = $8731;

GL_MODELVIEW18_ARB = $8732;

GL_MODELVIEW19_ARB = $8733;

GL_MODELVIEW20_ARB = $8734;

GL_MODELVIEW21_ARB = $8735;

GL_MODELVIEW22_ARB = $8736;

GL_MODELVIEW23_ARB = $8737;

GL_MODELVIEW24_ARB = $8738;

GL_MODELVIEW25_ARB = $8739;

GL_MODELVIEW26_ARB = $873A;

GL_MODELVIEW27_ARB = $873B;

GL_MODELVIEW28_ARB = $873C;

GL_MODELVIEW29_ARB = $873D;

GL_MODELVIEW30_ARB = $873E;

GL_MODELVIEW31_ARB = $873F;

GL_MATRIX_PALETTE_ARB = $8840;

GL_MAX_MATRIX_PALETTE_STACK_DEPTH_ARB = $8841;

GL_MAX_PALETTE_MATRICES_ARB = $8842;

GL_CURRENT_PALETTE_MATRIX_ARB = $8843;

GL_MATRIX_INDEX_ARRAY_ARB = $8844;

GL_CURRENT_MATRIX_INDEX_ARB = $8845;

GL_MATRIX_INDEX_ARRAY_SIZE_ARB = $8846;

GL_MATRIX_INDEX_ARRAY_TYPE_ARB = $8847;

GL_MATRIX_INDEX_ARRAY_STRIDE_ARB = $8848;

GL_MATRIX_INDEX_ARRAY_POINTER_ARB = $8849;

GL_COMBINE_ARB = $8570;

GL_COMBINE_RGB_ARB = $8571;

GL_COMBINE_ALPHA_ARB = $8572;

GL_RGB_SCALE_ARB = $8573;

GL_ADD_SIGNED_ARB = $8574;

GL_INTERPOLATE_ARB = $8575;

GL_CONSTANT_ARB = $8576;

GL_CONSTANT_COLOR_ARB = $8576;

GL_PRIMARY_COLOR_ARB = $8577;

GL_PREVIOUS_ARB = $8578;

GL_SOURCE0_RGB_ARB = $8580;

GL_SOURCE1_RGB_ARB = $8581;

GL_SOURCE2_RGB_ARB = $8582;

GL_SOURCE0_ALPHA_ARB = $8588;

GL_SOURCE1_ALPHA_ARB = $8589;

GL_SOURCE2_ALPHA_ARB = $858A;

GL_OPERAND0_RGB_ARB = $8590;

GL_OPERAND1_RGB_ARB = $8591;

GL_OPERAND2_RGB_ARB = $8592;

GL_OPERAND0_ALPHA_ARB = $8598;

GL_OPERAND1_ALPHA_ARB = $8599;

GL_OPERAND2_ALPHA_ARB = $859A;

GL_SUBTRACT_ARB = $84E7;

GL_DOT3_RGB_ARB = $86AE;

GL_DOT3_RGBA_ARB = $86AF;

WGL_BIND_TO_TEXTURE_RGB_ARB = $2070;

WGL_BIND_TO_TEXTURE_RGBA_ARB = $2071;

WGL_TEXTURE_FORMAT_ARB = $2072;

WGL_TEXTURE_TARGET_ARB = $2073;

WGL_MIPMAP_TEXTURE_ARB = $2074;

WGL_TEXTURE_RGB_ARB = $2075;

WGL_TEXTURE_RGBA_ARB = $2076;

WGL_NO_TEXTURE_ARB = $2077;

WGL_TEXTURE_CUBE_MAP_ARB = $2078;

WGL_TEXTURE_1D_ARB = $2079;

WGL_TEXTURE_2D_ARB = $207A;

WGL_MIPMAP_LEVEL_ARB = $207B;

WGL_CUBE_MAP_FACE_ARB = $207C;

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB = $207D;

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB = $207E;

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB = $207F;

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB = $2080;

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB = $2081;

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB = $2082;

WGL_FRONT_LEFT_ARB = $2083;

WGL_FRONT_RIGHT_ARB = $2084;

WGL_BACK_LEFT_ARB = $2085;

WGL_BACK_RIGHT_ARB = $2086;

WGL_AUX0_ARB = $2087;

WGL_AUX1_ARB = $2088;

WGL_AUX2_ARB = $2089;

WGL_AUX3_ARB = $208A;

WGL_AUX4_ARB = $208B;

WGL_AUX5_ARB = $208C;

WGL_AUX6_ARB = $208D;

WGL_AUX7_ARB = $208E;

WGL_AUX8_ARB = $208F;

WGL_AUX9_ARB = $2090;

GL_MIRRORED_REPEAT_ARB = $8370;

GL_DEPTH_COMPONENT16_ARB = $81A5;

GL_DEPTH_COMPONENT24_ARB = $81A6;

GL_DEPTH_COMPONENT32_ARB = $81A7;

GL_TEXTURE_DEPTH_SIZE_ARB = $884A;

GL_DEPTH_TEXTURE_MODE_ARB = $884B;

GL_TEXTURE_COMPARE_MODE_ARB = $884C;

GL_TEXTURE_COMPARE_FUNC_ARB = $884D;

GL_COMPARE_R_TO_TEXTURE_ARB = $884E;

GL_TEXTURE_COMPARE_FAIL_VALUE_ARB = $80BF;

GL_COLOR_SUM_ARB = $8458;

GL_VERTEX_PROGRAM_ARB = $8620;

GL_VERTEX_ATTRIB_ARRAY_ENABLED_ARB = $8622;

GL_VERTEX_ATTRIB_ARRAY_SIZE_ARB = $8623;

GL_VERTEX_ATTRIB_ARRAY_STRIDE_ARB = $8624;

GL_VERTEX_ATTRIB_ARRAY_TYPE_ARB = $8625;

GL_CURRENT_VERTEX_ATTRIB_ARB = $8626;

GL_PROGRAM_LENGTH_ARB = $8627;

GL_PROGRAM_STRING_ARB = $8628;

GL_MAX_PROGRAM_MATRIX_STACK_DEPTH_ARB = $862E;

GL_MAX_PROGRAM_MATRICES_ARB = $862F;

GL_CURRENT_MATRIX_STACK_DEPTH_ARB = $8640;

GL_CURRENT_MATRIX_ARB = $8641;

GL_VERTEX_PROGRAM_POINT_SIZE_ARB = $8642;

GL_VERTEX_PROGRAM_TWO_SIDE_ARB = $8643;

GL_VERTEX_ATTRIB_ARRAY_POINTER_ARB = $8645;

GL_PROGRAM_ERROR_POSITION_ARB = $864B;

GL_PROGRAM_BINDING_ARB = $8677;

GL_MAX_VERTEX_ATTRIBS_ARB = $8869;

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED_ARB = $886A;

GL_PROGRAM_ERROR_STRING_ARB = $8874;

GL_PROGRAM_FORMAT_ASCII_ARB = $8875;

GL_PROGRAM_FORMAT_ARB = $8876;

GL_PROGRAM_INSTRUCTIONS_ARB = $88A0;

GL_MAX_PROGRAM_INSTRUCTIONS_ARB = $88A1;

GL_PROGRAM_NATIVE_INSTRUCTIONS_ARB = $88A2;

GL_MAX_PROGRAM_NATIVE_INSTRUCTIONS_ARB = $88A3;

GL_PROGRAM_TEMPORARIES_ARB = $88A4;

GL_MAX_PROGRAM_TEMPORARIES_ARB = $88A5;

GL_PROGRAM_NATIVE_TEMPORARIES_ARB = $88A6;

GL_MAX_PROGRAM_NATIVE_TEMPORARIES_ARB = $88A7;

GL_PROGRAM_PARAMETERS_ARB = $88A8;

GL_MAX_PROGRAM_PARAMETERS_ARB = $88A9;

GL_PROGRAM_NATIVE_PARAMETERS_ARB = $88AA;

GL_MAX_PROGRAM_NATIVE_PARAMETERS_ARB = $88AB;

GL_PROGRAM_ATTRIBS_ARB = $88AC;

GL_MAX_PROGRAM_ATTRIBS_ARB = $88AD;

GL_PROGRAM_NATIVE_ATTRIBS_ARB = $88AE;

GL_MAX_PROGRAM_NATIVE_ATTRIBS_ARB = $88AF;

GL_PROGRAM_ADDRESS_REGISTERS_ARB = $88B0;

GL_MAX_PROGRAM_ADDRESS_REGISTERS_ARB = $88B1;

GL_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB = $88B2;

GL_MAX_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB = $88B3;

GL_MAX_PROGRAM_LOCAL_PARAMETERS_ARB = $88B4;

GL_MAX_PROGRAM_ENV_PARAMETERS_ARB = $88B5;

GL_PROGRAM_UNDER_NATIVE_LIMITS_ARB = $88B6;

GL_TRANSPOSE_CURRENT_MATRIX_ARB = $88B7;

GL_MATRIX0_ARB = $88C0;

GL_MATRIX1_ARB = $88C1;

GL_MATRIX2_ARB = $88C2;

GL_MATRIX3_ARB = $88C3;

GL_MATRIX4_ARB = $88C4;

GL_MATRIX5_ARB = $88C5;

GL_MATRIX6_ARB = $88C6;

GL_MATRIX7_ARB = $88C7;

GL_MATRIX8_ARB = $88C8;

GL_MATRIX9_ARB = $88C9;

GL_MATRIX10_ARB = $88CA;

GL_MATRIX11_ARB = $88CB;

GL_MATRIX12_ARB = $88CC;

GL_MATRIX13_ARB = $88CD;

GL_MATRIX14_ARB = $88CE;

GL_MATRIX15_ARB = $88CF;

GL_MATRIX16_ARB = $88D0;

GL_MATRIX17_ARB = $88D1;

GL_MATRIX18_ARB = $88D2;

GL_MATRIX19_ARB = $88D3;

GL_MATRIX20_ARB = $88D4;

GL_MATRIX21_ARB = $88D5;

GL_MATRIX22_ARB = $88D6;

GL_MATRIX23_ARB = $88D7;

GL_MATRIX24_ARB = $88D8;

GL_MATRIX25_ARB = $88D9;

GL_MATRIX26_ARB = $88DA;

GL_MATRIX27_ARB = $88DB;

GL_MATRIX28_ARB = $88DC;

GL_MATRIX29_ARB = $88DD;

GL_MATRIX30_ARB = $88DE;

GL_MATRIX31_ARB = $88DF;

GL_FRAGMENT_PROGRAM_ARB = $8804;

GL_PROGRAM_ALU_INSTRUCTIONS_ARB = $8805;

GL_PROGRAM_TEX_INSTRUCTIONS_ARB = $8806;

GL_PROGRAM_TEX_INDIRECTIONS_ARB = $8807;

GL_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB = $8808;

GL_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB = $8809;

GL_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB = $880A;

GL_MAX_PROGRAM_ALU_INSTRUCTIONS_ARB = $880B;

GL_MAX_PROGRAM_TEX_INSTRUCTIONS_ARB = $880C;

GL_MAX_PROGRAM_TEX_INDIRECTIONS_ARB = $880D;

GL_MAX_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB = $880E;

GL_MAX_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB = $880F;

GL_MAX_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB = $8810;

GL_MAX_TEXTURE_COORDS_ARB = $8871;

GL_MAX_TEXTURE_IMAGE_UNITS_ARB = $8872;

GL_BUFFER_SIZE_ARB = $8764;

GL_BUFFER_USAGE_ARB = $8765;

GL_ARRAY_BUFFER_ARB = $8892;

GL_ELEMENT_ARRAY_BUFFER_ARB = $8893;

GL_ARRAY_BUFFER_BINDING_ARB = $8894;

GL_ELEMENT_ARRAY_BUFFER_BINDING_ARB = $8895;

GL_VERTEX_ARRAY_BUFFER_BINDING_ARB = $8896;

GL_NORMAL_ARRAY_BUFFER_BINDING_ARB = $8897;

GL_COLOR_ARRAY_BUFFER_BINDING_ARB = $8898;

GL_INDEX_ARRAY_BUFFER_BINDING_ARB = $8899;

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING_ARB = $889A;

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING_ARB = $889B;

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING_ARB = $889C;

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING_ARB = $889D;

GL_WEIGHT_ARRAY_BUFFER_BINDING_ARB = $889E;

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING_ARB = $889F;

GL_READ_ONLY_ARB = $88B8;

GL_WRITE_ONLY_ARB = $88B9;

GL_READ_WRITE_ARB = $88BA;

GL_BUFFER_ACCESS_ARB = $88BB;

GL_BUFFER_MAPPED_ARB = $88BC;

GL_BUFFER_MAP_POINTER_ARB = $88BD;

GL_STREAM_DRAW_ARB = $88E0;

GL_STREAM_READ_ARB = $88E1;

GL_STREAM_COPY_ARB = $88E2;

GL_STATIC_DRAW_ARB = $88E4;

GL_STATIC_READ_ARB = $88E5;

GL_STATIC_COPY_ARB = $88E6;

GL_DYNAMIC_DRAW_ARB = $88E8;

GL_DYNAMIC_READ_ARB = $88E9;

GL_DYNAMIC_COPY_ARB = $88EA;

GL_QUERY_COUNTER_BITS_ARB = $8864;

GL_CURRENT_QUERY_ARB = $8865;

GL_QUERY_RESULT_ARB = $8866;

GL_QUERY_RESULT_AVAILABLE_ARB = $8867;

GL_SAMPLES_PASSED_ARB = $8914;

GL_PROGRAM_OBJECT_ARB = $8B40;

GL_SHADER_OBJECT_ARB = $8B48;

GL_OBJECT_TYPE_ARB = $8B4E;

GL_OBJECT_SUBTYPE_ARB = $8B4F;

GL_FLOAT_VEC2_ARB = $8B50;

GL_FLOAT_VEC3_ARB = $8B51;

GL_FLOAT_VEC4_ARB = $8B52;

GL_INT_VEC2_ARB = $8B53;

GL_INT_VEC3_ARB = $8B54;

GL_INT_VEC4_ARB = $8B55;

GL_BOOL_ARB = $8B56;

GL_BOOL_VEC2_ARB = $8B57;

GL_BOOL_VEC3_ARB = $8B58;

GL_BOOL_VEC4_ARB = $8B59;

GL_FLOAT_MAT2_ARB = $8B5A;

GL_FLOAT_MAT3_ARB = $8B5B;

GL_FLOAT_MAT4_ARB = $8B5C;

GL_SAMPLER_1D_ARB = $8B5D;

GL_SAMPLER_2D_ARB = $8B5E;

GL_SAMPLER_3D_ARB = $8B5F;

GL_SAMPLER_CUBE_ARB = $8B60;

GL_SAMPLER_1D_SHADOW_ARB = $8B61;

GL_SAMPLER_2D_SHADOW_ARB = $8B62;

GL_SAMPLER_2D_RECT_ARB = $8B63;

GL_SAMPLER_2D_RECT_SHADOW_ARB = $8B64;

GL_OBJECT_DELETE_STATUS_ARB = $8B80;

GL_OBJECT_COMPILE_STATUS_ARB = $8B81;

GL_OBJECT_LINK_STATUS_ARB = $8B82;

GL_OBJECT_VALIDATE_STATUS_ARB = $8B83;

GL_OBJECT_INFO_LOG_LENGTH_ARB = $8B84;

GL_OBJECT_ATTACHED_OBJECTS_ARB = $8B85;

GL_OBJECT_ACTIVE_UNIFORMS_ARB = $8B86;

GL_OBJECT_ACTIVE_UNIFORM_MAX_LENGTH_ARB = $8B87;

GL_OBJECT_SHADER_SOURCE_LENGTH_ARB = $8B88;

GL_VERTEX_SHADER_ARB = $8B31;

GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB = $8B4A;

GL_MAX_VARYING_FLOATS_ARB = $8B4B;

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB = $8B4C;

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB = $8B4D;

GL_OBJECT_ACTIVE_ATTRIBUTES_ARB = $8B89;

GL_OBJECT_ACTIVE_ATTRIBUTE_MAX_LENGTH_ARB = $8B8A;

GL_FRAGMENT_SHADER_ARB = $8B30;

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB = $8B49;

GL_FRAGMENT_SHADER_DERIVATIVE_HINT_ARB = $8B8B;

GL_SHADING_LANGUAGE_VERSION_ARB = $8B8C;

GL_POINT_SPRITE_ARB = $8861;

GL_COORD_REPLACE_ARB = $8862;

GL_MAX_DRAW_BUFFERS_ARB = $8824;

GL_DRAW_BUFFER0_ARB = $8825;

GL_DRAW_BUFFER1_ARB = $8826;

GL_DRAW_BUFFER2_ARB = $8827;

GL_DRAW_BUFFER3_ARB = $8828;

GL_DRAW_BUFFER4_ARB = $8829;

GL_DRAW_BUFFER5_ARB = $882A;

GL_DRAW_BUFFER6_ARB = $882B;

GL_DRAW_BUFFER7_ARB = $882C;

GL_DRAW_BUFFER8_ARB = $882D;

GL_DRAW_BUFFER9_ARB = $882E;

GL_DRAW_BUFFER10_ARB = $882F;

GL_DRAW_BUFFER11_ARB = $8830;

GL_DRAW_BUFFER12_ARB = $8831;

GL_DRAW_BUFFER13_ARB = $8832;

GL_DRAW_BUFFER14_ARB = $8833;

GL_DRAW_BUFFER15_ARB = $8834;

GL_TEXTURE_RECTANGLE_ARB = $84F5;

GL_TEXTURE_BINDING_RECTANGLE_ARB = $84F6;

GL_PROXY_TEXTURE_RECTANGLE_ARB = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE_ARB = $84F8;

GL_RGBA_FLOAT_MODE_ARB = $8820;

GL_CLAMP_VERTEX_COLOR_ARB = $891A;

GL_CLAMP_FRAGMENT_COLOR_ARB = $891B;

GL_CLAMP_READ_COLOR_ARB = $891C;

GL_FIXED_ONLY_ARB = $891D;

WGL_TYPE_RGBA_FLOAT_ARB = $21A0;

GLX_RGBA_FLOAT_TYPE_ARB = $20B9;

GLX_RGBA_FLOAT_BIT_ARB = $00000004;

GL_HALF_FLOAT_ARB = $140B;

GL_TEXTURE_RED_TYPE_ARB = $8C10;

GL_TEXTURE_GREEN_TYPE_ARB = $8C11;

GL_TEXTURE_BLUE_TYPE_ARB = $8C12;

GL_TEXTURE_ALPHA_TYPE_ARB = $8C13;

GL_TEXTURE_LUMINANCE_TYPE_ARB = $8C14;

GL_TEXTURE_INTENSITY_TYPE_ARB = $8C15;

GL_TEXTURE_DEPTH_TYPE_ARB = $8C16;

GL_UNSIGNED_NORMALIZED_ARB = $8C17;

GL_RGBA32F_ARB = $8814;

GL_RGB32F_ARB = $8815;

GL_ALPHA32F_ARB = $8816;

GL_INTENSITY32F_ARB = $8817;

GL_LUMINANCE32F_ARB = $8818;

GL_LUMINANCE_ALPHA32F_ARB = $8819;

GL_RGBA16F_ARB = $881A;

GL_RGB16F_ARB = $881B;

GL_ALPHA16F_ARB = $881C;

GL_INTENSITY16F_ARB = $881D;

GL_LUMINANCE16F_ARB = $881E;

GL_LUMINANCE_ALPHA16F_ARB = $881F;

GL_PIXEL_PACK_BUFFER_ARB = $88EB;

GL_PIXEL_UNPACK_BUFFER_ARB = $88EC;

GL_PIXEL_PACK_BUFFER_BINDING_ARB = $88ED;

GL_PIXEL_UNPACK_BUFFER_BINDING_ARB = $88EF;

GL_DEPTH_COMPONENT32F = $8CAC;

GL_DEPTH32F_STENCIL8 = $8CAD;

GL_FLOAT_32_UNSIGNED_INT_24_8_REV = $8DAD;

GL_INVALID_FRAMEBUFFER_OPERATION = $0506;

GL_FRAMEBUFFER_ATTACHMENT_COLOR_ENCODING = $8210;

GL_FRAMEBUFFER_ATTACHMENT_COMPONENT_TYPE = $8211;

GL_FRAMEBUFFER_ATTACHMENT_RED_SIZE = $8212;

GL_FRAMEBUFFER_ATTACHMENT_GREEN_SIZE = $8213;

GL_FRAMEBUFFER_ATTACHMENT_BLUE_SIZE = $8214;

GL_FRAMEBUFFER_ATTACHMENT_ALPHA_SIZE = $8215;

GL_FRAMEBUFFER_ATTACHMENT_DEPTH_SIZE = $8216;

GL_FRAMEBUFFER_ATTACHMENT_STENCIL_SIZE = $8217;

GL_FRAMEBUFFER_DEFAULT = $8218;

GL_FRAMEBUFFER_UNDEFINED = $8219;

GL_DEPTH_STENCIL_ATTACHMENT = $821A;

GL_INDEX = $8222;

GL_MAX_RENDERBUFFER_SIZE = $84E8;

GL_DEPTH_STENCIL = $84F9;

GL_UNSIGNED_INT_24_8 = $84FA;

GL_DEPTH24_STENCIL8 = $88F0;

GL_TEXTURE_STENCIL_SIZE = $88F1;

GL_TEXTURE_RED_TYPE = $8C10;

GL_TEXTURE_GREEN_TYPE = $8C11;

GL_TEXTURE_BLUE_TYPE = $8C12;

GL_TEXTURE_ALPHA_TYPE = $8C13;

GL_TEXTURE_LUMINANCE_TYPE = $8C14;

GL_TEXTURE_INTENSITY_TYPE = $8C15;

GL_TEXTURE_DEPTH_TYPE = $8C16;

GL_UNSIGNED_NORMALIZED = $8C17;

GL_FRAMEBUFFER_BINDING = $8CA6;

GL_DRAW_FRAMEBUFFER_BINDING = GL_FRAMEBUFFER_BINDING;

GL_RENDERBUFFER_BINDING = $8CA7;

GL_READ_FRAMEBUFFER = $8CA8;

GL_DRAW_FRAMEBUFFER = $8CA9;

GL_READ_FRAMEBUFFER_BINDING = $8CAA;

GL_RENDERBUFFER_SAMPLES = $8CAB;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE = $8CD0;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME = $8CD1;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL = $8CD2;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE = $8CD3;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER = $8CD4;

GL_FRAMEBUFFER_COMPLETE = $8CD5;

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT = $8CD6;

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT = $8CD7;

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER = $8CDB;

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER = $8CDC;

GL_FRAMEBUFFER_UNSUPPORTED = $8CDD;

GL_MAX_COLOR_ATTACHMENTS = $8CDF;

GL_COLOR_ATTACHMENT0 = $8CE0;

GL_COLOR_ATTACHMENT1 = $8CE1;

GL_COLOR_ATTACHMENT2 = $8CE2;

GL_COLOR_ATTACHMENT3 = $8CE3;

GL_COLOR_ATTACHMENT4 = $8CE4;

GL_COLOR_ATTACHMENT5 = $8CE5;

GL_COLOR_ATTACHMENT6 = $8CE6;

GL_COLOR_ATTACHMENT7 = $8CE7;

GL_COLOR_ATTACHMENT8 = $8CE8;

GL_COLOR_ATTACHMENT9 = $8CE9;

GL_COLOR_ATTACHMENT10 = $8CEA;

GL_COLOR_ATTACHMENT11 = $8CEB;

GL_COLOR_ATTACHMENT12 = $8CEC;

GL_COLOR_ATTACHMENT13 = $8CED;

GL_COLOR_ATTACHMENT14 = $8CEE;

GL_COLOR_ATTACHMENT15 = $8CEF;

GL_DEPTH_ATTACHMENT = $8D00;

GL_STENCIL_ATTACHMENT = $8D20;

GL_FRAMEBUFFER = $8D40;

GL_RENDERBUFFER = $8D41;

GL_RENDERBUFFER_WIDTH = $8D42;

GL_RENDERBUFFER_HEIGHT = $8D43;

GL_RENDERBUFFER_INTERNAL_FORMAT = $8D44;

GL_STENCIL_INDEX1 = $8D46;

GL_STENCIL_INDEX4 = $8D47;

GL_STENCIL_INDEX8 = $8D48;

GL_STENCIL_INDEX16 = $8D49;

GL_RENDERBUFFER_RED_SIZE = $8D50;

GL_RENDERBUFFER_GREEN_SIZE = $8D51;

GL_RENDERBUFFER_BLUE_SIZE = $8D52;

GL_RENDERBUFFER_ALPHA_SIZE = $8D53;

GL_RENDERBUFFER_DEPTH_SIZE = $8D54;

GL_RENDERBUFFER_STENCIL_SIZE = $8D55;

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE = $8D56;

GL_MAX_SAMPLES = $8D57;

GLX_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20B2;

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB = $20A9;

GL_FRAMEBUFFER_SRGB = $8DB9;

GL_GEOMETRY_SHADER_ARB = $8DD9;

GL_GEOMETRY_VERTICES_OUT_ARB = $8DDA;

GL_GEOMETRY_INPUT_TYPE_ARB = $8DDB;

GL_GEOMETRY_OUTPUT_TYPE_ARB = $8DDC;

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_ARB = $8C29;

GL_MAX_GEOMETRY_VARYING_COMPONENTS_ARB = $8DDD;

GL_MAX_VERTEX_VARYING_COMPONENTS_ARB = $8DDE;

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_ARB = $8DDF;

GL_MAX_GEOMETRY_OUTPUT_VERTICES_ARB = $8DE0;

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_ARB = $8DE1;

GL_LINES_ADJACENCY_ARB = $A;

GL_LINE_STRIP_ADJACENCY_ARB = $B;

GL_TRIANGLES_ADJACENCY_ARB = $C;

GL_TRIANGLE_STRIP_ADJACENCY_ARB = $D;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_ARB = $8DA8;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_ARB = $8DA9;

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_ARB = $8DA7;

GL_PROGRAM_POINT_SIZE_ARB = $8642;

GL_HALF_FLOAT = $140B;

GL_VERTEX_ATTRIB_ARRAY_DIVISOR_ARB = $88FE;

GL_MAP_READ_BIT = $0001;

GL_MAP_WRITE_BIT = $0002;

GL_MAP_INVALIDATE_RANGE_BIT = $0004;

GL_MAP_INVALIDATE_BUFFER_BIT = $0008;

GL_MAP_FLUSH_EXPLICIT_BIT = $0010;

GL_MAP_UNSYNCHRONIZED_BIT = $0020;

GL_TEXTURE_BUFFER_ARB = $8C2A;

GL_MAX_TEXTURE_BUFFER_SIZE_ARB = $8C2B;

GL_TEXTURE_BINDING_BUFFER_ARB = $8C2C;

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_ARB = $8C2D;

GL_TEXTURE_BUFFER_FORMAT_ARB = $8C2E;

GL_COMPRESSED_RED_RGTC1 = $8DBB;

GL_COMPRESSED_SIGNED_RED_RGTC1 = $8DBC;

GL_COMPRESSED_RG_RGTC2 = $8DBD;

GL_COMPRESSED_SIGNED_RG_RGTC2 = $8DBE;

GL_R8 = $8229;

GL_R16 = $822A;

GL_RG8 = $822B;

GL_RG16 = $822C;

GL_R16F = $822D;

GL_R32F = $822E;

GL_RG16F = $822F;

GL_RG32F = $8230;

GL_R8I = $8231;

GL_R8UI = $8232;

GL_R16I = $8233;

GL_R16UI = $8234;

GL_R32I = $8235;

GL_R32UI = $8236;

GL_RG8I = $8237;

GL_RG8UI = $8238;

GL_RG16I = $8239;

GL_RG16UI = $823A;

GL_RG32I = $823B;

GL_RG32UI = $823C;

GL_RG = $8227;

GL_RG_INTEGER = $8228;

GL_VERTEX_ARRAY_BINDING = $85B5;

WGL_CONTEXT_MAJOR_VERSION_ARB = $2091;

WGL_CONTEXT_MINOR_VERSION_ARB = $2092;

WGL_CONTEXT_LAYER_PLANE_ARB = $2093;

WGL_CONTEXT_FLAGS_ARB = $2094;

WGL_CONTEXT_DEBUG_BIT_ARB = $0001;

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $0002;

ERROR_INVALID_VERSION_ARB = $2095;

WGL_CONTEXT_ES2_PROFILE_BIT_EXT = $0004;

GLX_CONTEXT_MAJOR_VERSION_ARB = $2091;

GLX_CONTEXT_MINOR_VERSION_ARB = $2092;

GLX_CONTEXT_FLAGS_ARB = $2094;

GLX_CONTEXT_DEBUG_BIT_ARB = $00000001;

GLX_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB = $00000002;

GL_UNIFORM_BUFFER = $8A11;

GL_UNIFORM_BUFFER_BINDING = $8A28;

GL_UNIFORM_BUFFER_START = $8A29;

GL_UNIFORM_BUFFER_SIZE = $8A2A;

GL_MAX_VERTEX_UNIFORM_BLOCKS = $8A2B;

GL_MAX_GEOMETRY_UNIFORM_BLOCKS = $8A2C;

GL_MAX_FRAGMENT_UNIFORM_BLOCKS = $8A2D;

GL_MAX_COMBINED_UNIFORM_BLOCKS = $8A2E;

GL_MAX_UNIFORM_BUFFER_BINDINGS = $8A2F;

GL_MAX_UNIFORM_BLOCK_SIZE = $8A30;

GL_MAX_COMBINED_VERTEX_UNIFORM_COMPONENTS = $8A31;

GL_MAX_COMBINED_GEOMETRY_UNIFORM_COMPONENTS = $8A32;

GL_MAX_COMBINED_FRAGMENT_UNIFORM_COMPONENTS = $8A33;

GL_UNIFORM_BUFFER_OFFSET_ALIGNMENT = $8A34;

GL_ACTIVE_UNIFORM_BLOCK_MAX_NAME_LENGTH = $8A35;

GL_ACTIVE_UNIFORM_BLOCKS = $8A36;

GL_UNIFORM_TYPE = $8A37;

GL_UNIFORM_SIZE = $8A38;

GL_UNIFORM_NAME_LENGTH = $8A39;

GL_UNIFORM_BLOCK_INDEX = $8A3A;

GL_UNIFORM_OFFSET = $8A3B;

GL_UNIFORM_ARRAY_STRIDE = $8A3C;

GL_UNIFORM_MATRIX_STRIDE = $8A3D;

GL_UNIFORM_IS_ROW_MAJOR = $8A3E;

GL_UNIFORM_BLOCK_BINDING = $8A3F;

GL_UNIFORM_BLOCK_DATA_SIZE = $8A40;

GL_UNIFORM_BLOCK_NAME_LENGTH = $8A41;

GL_UNIFORM_BLOCK_ACTIVE_UNIFORMS = $8A42;

GL_UNIFORM_BLOCK_ACTIVE_UNIFORM_INDICES = $8A43;

GL_UNIFORM_BLOCK_REFERENCED_BY_VERTEX_SHADER = $8A44;

GL_UNIFORM_BLOCK_REFERENCED_BY_GEOMETRY_SHADER = $8A45;

GL_UNIFORM_BLOCK_REFERENCED_BY_FRAGMENT_SHADER = $8A46;

GL_INVALID_INDEX = $FFFFFFFF;

GL_COPY_READ_BUFFER = $8F36;

GL_COPY_WRITE_BUFFER = $8F37;

GL_DEPTH_CLAMP = $864F;

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION = $8E4C;

GL_FIRST_VERTEX_CONVENTION = $8E4D;

GL_LAST_VERTEX_CONVENTION = $8E4E;

GL_PROVOKING_VERTEX = $8E4F;

GL_TEXTURE_CUBE_MAP_SEAMLESS = $884F;

GL_MAX_SERVER_WAIT_TIMEOUT = $9111;

GL_OBJECT_TYPE = $9112;

GL_SYNC_CONDITION = $9113;

GL_SYNC_STATUS = $9114;

GL_SYNC_FLAGS = $9115;

GL_SYNC_FENCE = $9116;

GL_SYNC_GPU_COMMANDS_COMPLETE = $9117;

GL_UNSIGNALED = $9118;

GL_SIGNALED = $9119;

GL_ALREADY_SIGNALED = $911A;

GL_TIMEOUT_EXPIRED = $911B;

GL_CONDITION_SATISFIED = $911C;

GL_WAIT_FAILED = $911D;

GL_SYNC_FLUSH_COMMANDS_BIT = $00000001;

GL_TIMEOUT_IGNORED = $FFFFFFFFFFFFFFFF;

GL_SAMPLE_POSITION = $8E50;

GL_SAMPLE_MASK = $8E51;

GL_SAMPLE_MASK_VALUE = $8E52;

GL_MAX_SAMPLE_MASK_WORDS = $8E59;

GL_TEXTURE_2D_MULTISAMPLE = $9100;

GL_PROXY_TEXTURE_2D_MULTISAMPLE = $9101;

GL_TEXTURE_2D_MULTISAMPLE_ARRAY = $9102;

GL_PROXY_TEXTURE_2D_MULTISAMPLE_ARRAY = $9103;

GL_TEXTURE_BINDING_2D_MULTISAMPLE = $9104;

GL_TEXTURE_BINDING_2D_MULTISAMPLE_ARRAY = $9105;

GL_TEXTURE_SAMPLES = $9106;

GL_TEXTURE_FIXED_SAMPLE_LOCATIONS = $9107;

GL_SAMPLER_2D_MULTISAMPLE = $9108;

GL_INT_SAMPLER_2D_MULTISAMPLE = $9109;

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE = $910A;

GL_SAMPLER_2D_MULTISAMPLE_ARRAY = $910B;

GL_INT_SAMPLER_2D_MULTISAMPLE_ARRAY = $910C;

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE_ARRAY = $910D;

GL_MAX_COLOR_TEXTURE_SAMPLES = $910E;

GL_MAX_DEPTH_TEXTURE_SAMPLES = $910F;

GL_MAX_INTEGER_SAMPLES = $9110;

GL_SAMPLE_SHADING_ARB = $8C36;

GL_MIN_SAMPLE_SHADING_VALUE_ARB = $8C37;

GL_TEXTURE_CUBE_MAP_ARRAY_ARB = $9009;

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY_ARB = $900A;

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY_ARB = $900B;

GL_SAMPLER_CUBE_MAP_ARRAY_ARB = $900C;

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW_ARB = $900D;

GL_INT_SAMPLER_CUBE_MAP_ARRAY_ARB = $900E;

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY_ARB = $900F;

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_ARB = $8E5E;

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_ARB = $8E5F;

GL_MAX_PROGRAM_TEXTURE_GATHER_COMPONENTS_ARB = $8F9F;

WGL_CONTEXT_PROFILE_MASK_ARB = $9126;

WGL_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;

ERROR_INVALID_PROFILE_ARB = $2096;

GLX_CONTEXT_PROFILE_MASK_ARB = $9126;

GLX_CONTEXT_CORE_PROFILE_BIT_ARB = $00000001;

GLX_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB = $00000002;

GL_SRC1_COLOR = $88F9;

GL_ONE_MINUS_SRC1_COLOR = $88FA;

GL_ONE_MINUS_SRC1_ALPHA = $88FB;

GL_MAX_DUAL_SOURCE_DRAW_BUFFERS = $88FC;

GL_ANY_SAMPLES_PASSED = $8C2F;

GL_SAMPLER_BINDING = $8919;

GL_RGB10_A2UI = $906F;

GL_TEXTURE_SWIZZLE_R = $8E42;

GL_TEXTURE_SWIZZLE_G = $8E43;

GL_TEXTURE_SWIZZLE_B = $8E44;

GL_TEXTURE_SWIZZLE_A = $8E45;

GL_TEXTURE_SWIZZLE_RGBA = $8E46;

GL_TIME_ELAPSED = $88BF;

GL_TIMESTAMP = $8E28;

GL_INT_2_10_10_10_REV = $8D9F;

GL_DRAW_INDIRECT_BUFFER = $8F3F;

GL_DRAW_INDIRECT_BUFFER_BINDING = $8F43;

GL_GEOMETRY_SHADER_INVOCATIONS = $887F;

GL_MAX_GEOMETRY_SHADER_INVOCATIONS = $8E5A;

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET = $8E5B;

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET = $8E5C;

GL_FRAGMENT_INTERPOLATION_OFFSET_BITS = $8E5D;

GL_MAX_VERTEX_STREAMS = $8E71;

GL_DOUBLE_VEC2 = $8FFC;

GL_DOUBLE_VEC3 = $8FFD;

GL_DOUBLE_VEC4 = $8FFE;

GL_DOUBLE_MAT2 = $8F46;

GL_DOUBLE_MAT3 = $8F47;

GL_DOUBLE_MAT4 = $8F48;

GL_DOUBLE_MAT2x3 = $8F49;

GL_DOUBLE_MAT2x4 = $8F4A;

GL_DOUBLE_MAT3x2 = $8F4B;

GL_DOUBLE_MAT3x4 = $8F4C;

GL_DOUBLE_MAT4x2 = $8F4D;

GL_DOUBLE_MAT4x3 = $8F4E;

GL_ACTIVE_SUBROUTINES = $8DE5;

GL_ACTIVE_SUBROUTINE_UNIFORMS = $8DE6;

GL_ACTIVE_SUBROUTINE_UNIFORM_LOCATIONS = $8E47;

GL_ACTIVE_SUBROUTINE_MAX_LENGTH = $8E48;

GL_ACTIVE_SUBROUTINE_UNIFORM_MAX_LENGTH = $8E49;

GL_MAX_SUBROUTINES = $8DE7;

GL_MAX_SUBROUTINE_UNIFORM_LOCATIONS = $8DE8;

GL_NUM_COMPATIBLE_SUBROUTINES = $8E4A;

GL_COMPATIBLE_SUBROUTINES = $8E4B;

GL_PATCHES = $000E;

GL_PATCH_VERTICES = $8E72;

GL_PATCH_DEFAULT_INNER_LEVEL = $8E73;

GL_PATCH_DEFAULT_OUTER_LEVEL = $8E74;

GL_TESS_CONTROL_OUTPUT_VERTICES = $8E75;

GL_TESS_GEN_MODE = $8E76;

GL_TESS_GEN_SPACING = $8E77;

GL_TESS_GEN_VERTEX_ORDER = $8E78;

GL_TESS_GEN_POINT_MODE = $8E79;

GL_ISOLINES = $8E7A;

GL_FRACTIONAL_ODD = $8E7B;

GL_FRACTIONAL_EVEN = $8E7C;

GL_MAX_PATCH_VERTICES = $8E7D;

GL_MAX_TESS_GEN_LEVEL = $8E7E;

GL_MAX_TESS_CONTROL_UNIFORM_COMPONENTS = $8E7F;

GL_MAX_TESS_EVALUATION_UNIFORM_COMPONENTS = $8E80;

GL_MAX_TESS_CONTROL_TEXTURE_IMAGE_UNITS = $8E81;

GL_MAX_TESS_EVALUATION_TEXTURE_IMAGE_UNITS = $8E82;

GL_MAX_TESS_CONTROL_OUTPUT_COMPONENTS = $8E83;

GL_MAX_TESS_PATCH_COMPONENTS = $8E84;

GL_MAX_TESS_CONTROL_TOTAL_OUTPUT_COMPONENTS = $8E85;

GL_MAX_TESS_EVALUATION_OUTPUT_COMPONENTS = $8E86;

GL_MAX_TESS_CONTROL_UNIFORM_BLOCKS = $8E89;

GL_MAX_TESS_EVALUATION_UNIFORM_BLOCKS = $8E8A;

GL_MAX_TESS_CONTROL_INPUT_COMPONENTS = $886C;

GL_MAX_TESS_EVALUATION_INPUT_COMPONENTS = $886D;

GL_MAX_COMBINED_TESS_CONTROL_UNIFORM_COMPONENTS = $8E1E;

GL_MAX_COMBINED_TESS_EVALUATION_UNIFORM_COMPONENTS = $8E1F;

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_CONTROL_SHADER = $84F0;

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_EVALUATION_SHADER = $84F1;

GL_TESS_EVALUATION_SHADER = $8E87;

GL_TESS_CONTROL_SHADER = $8E88;

GL_TRANSFORM_FEEDBACK = $8E22;

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED = $8E23;

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE = $8E24;

GL_TRANSFORM_FEEDBACK_BINDING = $8E25;

GL_MAX_TRANSFORM_FEEDBACK_BUFFERS = $8E70;

GL_FIXED = $140C;

GL_IMPLEMENTATION_COLOR_READ_TYPE = $8B9A;

GL_IMPLEMENTATION_COLOR_READ_FORMAT = $8B9B;

GL_LOW_FLOAT = $8DF0;

GL_MEDIUM_FLOAT = $8DF1;

GL_HIGH_FLOAT = $8DF2;

GL_LOW_INT = $8DF3;

GL_MEDIUM_INT = $8DF4;

GL_HIGH_INT = $8DF5;

GL_SHADER_COMPILER = $8DFA;

GL_NUM_SHADER_BINARY_FORMATS = $8DF9;

GL_MAX_VERTEX_UNIFORM_VECTORS = $8DFB;

GL_MAX_VARYING_VECTORS = $8DFC;

GL_MAX_FRAGMENT_UNIFORM_VECTORS = $8DFD;

GL_PROGRAM_BINARY_RETRIEVABLE_HINT = $8257;

GL_PROGRAM_BINARY_LENGTH = $8741;

GL_NUM_PROGRAM_BINARY_FORMATS = $87FE;

GL_PROGRAM_BINARY_FORMATS = $87FF;

GL_VERTEX_SHADER_BIT = $00000001;

GL_FRAGMENT_SHADER_BIT = $00000002;

GL_GEOMETRY_SHADER_BIT = $00000004;

GL_TESS_CONTROL_SHADER_BIT = $00000008;

GL_TESS_EVALUATION_SHADER_BIT = $00000010;

GL_ALL_SHADER_BITS = $FFFFFFFF;

GL_PROGRAM_SEPARABLE = $8258;

GL_ACTIVE_PROGRAM = $8259;

GL_PROGRAM_PIPELINE_BINDING = $825A;

GL_MAX_VIEWPORTS = $825B;

GL_VIEWPORT_SUBPIXEL_BITS = $825C;

GL_VIEWPORT_BOUNDS_RANGE = $825D;

GL_LAYER_PROVOKING_VERTEX = $825E;

GL_VIEWPORT_INDEX_PROVOKING_VERTEX = $825F;

GL_UNDEFINED_VERTEX = $8260;

GL_DEBUG_OUTPUT_SYNCHRONOUS_ARB = $8242;

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH_ARB = $8243;

GL_DEBUG_CALLBACK_FUNCTION_ARB = $8244;

GL_DEBUG_CALLBACK_USER_PARAM_ARB = $8245;

GL_DEBUG_SOURCE_API_ARB = $8246;

GL_DEBUG_SOURCE_WINDOW_SYSTEM_ARB = $8247;

GL_DEBUG_SOURCE_SHADER_COMPILER_ARB = $8248;

GL_DEBUG_SOURCE_THIRD_PARTY_ARB = $8249;

GL_DEBUG_SOURCE_APPLICATION_ARB = $824A;

GL_DEBUG_SOURCE_OTHER_ARB = $824B;

GL_DEBUG_TYPE_ERROR_ARB = $824C;

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR_ARB = $824D;

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR_ARB = $824E;

GL_DEBUG_TYPE_PORTABILITY_ARB = $824F;

GL_DEBUG_TYPE_PERFORMANCE_ARB = $8250;

GL_DEBUG_TYPE_OTHER_ARB = $8251;

GL_MAX_DEBUG_MESSAGE_LENGTH_ARB = $9143;

GL_MAX_DEBUG_LOGGED_MESSAGES_ARB = $9144;

GL_DEBUG_LOGGED_MESSAGES_ARB = $9145;

GL_DEBUG_SEVERITY_HIGH_ARB = $9146;

GL_DEBUG_SEVERITY_MEDIUM_ARB = $9147;

GL_DEBUG_SEVERITY_LOW_ARB = $9148;

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT_ARB = $00000004;

GL_LOSE_CONTEXT_ON_RESET_ARB = $8252;

GL_GUILTY_CONTEXT_RESET_ARB = $8253;

GL_INNOCENT_CONTEXT_RESET_ARB = $8254;

GL_UNKNOWN_CONTEXT_RESET_ARB = $8255;

GL_RESET_NOTIFICATION_STRATEGY_ARB = $8256;

GL_NO_RESET_NOTIFICATION_ARB = $8261;

GL_TEXTURE_RECTANGLE_EXT = $84F5;

GL_TEXTURE_BINDING_RECTANGLE_EXT = $84F6;

GL_PROXY_TEXTURE_RECTANGLE_EXT = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE_EXT = $84F8;

GLX_BIND_TO_TEXTURE_RGB_EXT = $20D0;

GLX_BIND_TO_TEXTURE_RGBA_EXT = $20D1;

GLX_BIND_TO_MIPMAP_TEXTURE_EXT = $20D2;

GLX_BIND_TO_TEXTURE_TARGETS_EXT = $20D3;

GLX_Y_INVERTED_EXT = $20D4;

GLX_TEXTURE_FORMAT_EXT = $20D5;

GLX_TEXTURE_TARGET_EXT = $20D6;

GLX_MIPMAP_TEXTURE_EXT = $20D7;

GLX_TEXTURE_FORMAT_NONE_EXT = $20D8;

GLX_TEXTURE_FORMAT_RGB_EXT = $20D9;

GLX_TEXTURE_FORMAT_RGBA_EXT = $20DA;

GLX_TEXTURE_1D_EXT = $20DB;

GLX_TEXTURE_2D_EXT = $20DC;

GLX_TEXTURE_RECTANGLE_EXT = $20DD;

GLX_FRONT_LEFT_EXT = $20DE;

GLX_FRONT_RIGHT_EXT = $20DF;

GLX_BACK_LEFT_EXT = $20E0;

GLX_BACK_RIGHT_EXT = $20E1;

GLX_FRONT_EXT = GLX_FRONT_LEFT_EXT;

GLX_BACK_EXT = GLX_BACK_LEFT_EXT;

GLX_AUX0_EXT = $20E2;

GLX_AUX1_EXT = $20E3;

GLX_AUX2_EXT = $20E4;

GLX_AUX3_EXT = 420E5;

GLX_AUX4_EXT = $20E6;

GLX_AUX5_EXT = $20E7;

GLX_AUX6_EXT = $20E8;

GLX_AUX7_EXT = $20E9;

GLX_AUX8_EXT = $20EA;

GLX_AUX9_EXT = $20EB;

GL_ABGR_EXT = $8000;

GL_CONSTANT_COLOR_EXT = $8001;

GL_ONE_MINUS_CONSTANT_COLOR_EXT = $8002;

GL_CONSTANT_ALPHA_EXT = $8003;

GL_ONE_MINUS_CONSTANT_ALPHA_EXT = $8004;

GL_BLEND_COLOR_EXT = $8005;

GL_POLYGON_OFFSET_EXT = $8037;

GL_POLYGON_OFFSET_FACTOR_EXT = $8038;

GL_POLYGON_OFFSET_BIAS_EXT = $8039;

GL_ALPHA4_EXT = $803B;

GL_ALPHA8_EXT = $803C;

GL_ALPHA12_EXT = $803D;

GL_ALPHA16_EXT = $803E;

GL_LUMINANCE4_EXT = $803F;

GL_LUMINANCE8_EXT = $8040;

GL_LUMINANCE12_EXT = $8041;

GL_LUMINANCE16_EXT = $8042;

GL_LUMINANCE4_ALPHA4_EXT = $8043;

GL_LUMINANCE6_ALPHA2_EXT = $8044;

GL_LUMINANCE8_ALPHA8_EXT = $8045;

GL_LUMINANCE12_ALPHA4_EXT = $8046;

GL_LUMINANCE12_ALPHA12_EXT = $8047;

GL_LUMINANCE16_ALPHA16_EXT = $8048;

GL_INTENSITY_EXT = $8049;

GL_INTENSITY4_EXT = $804A;

GL_INTENSITY8_EXT = $804B;

GL_INTENSITY12_EXT = $804C;

GL_INTENSITY16_EXT = $804D;

GL_RGB2_EXT = $804E;

GL_RGB4_EXT = $804F;

GL_RGB5_EXT = $8050;

GL_RGB8_EXT = $8051;

GL_RGB10_EXT = $8052;

GL_RGB12_EXT = $8053;

GL_RGB16_EXT = $8054;

GL_RGBA2_EXT = $8055;

GL_RGBA4_EXT = $8056;

GL_RGB5_A1_EXT = $8057;

GL_RGBA8_EXT = $8058;

GL_RGB10_A2_EXT = $8059;

GL_RGBA12_EXT = $805A;

GL_RGBA16_EXT = $805B;

GL_TEXTURE_RED_SIZE_EXT = $805C;

GL_TEXTURE_GREEN_SIZE_EXT = $805D;

GL_TEXTURE_BLUE_SIZE_EXT = $805E;

GL_TEXTURE_ALPHA_SIZE_EXT = $805F;

GL_TEXTURE_LUMINANCE_SIZE_EXT = $8060;

GL_TEXTURE_INTENSITY_SIZE_EXT = $8061;

GL_REPLACE_EXT = $8062;

GL_PROXY_TEXTURE_1D_EXT = $8063;

GL_PROXY_TEXTURE_2D_EXT = $8064;

GL_TEXTURE_TOO_LARGE_EXT = $8065;

GL_RGB_S3TC = $83A0;

GL_RGB4_S3TC = $83A1;

GL_RGBA_S3TC = $83A2;

GL_RGBA4_S3TC = $83A3;

GL_RGBA_DXT5_S3TC = $83A4;

GL_RGBA4_DXT5_S3TC = $83A5;

GL_PACK_SKIP_IMAGES_EXT = $806B;

GL_PACK_IMAGE_HEIGHT_EXT = $806C;

GL_UNPACK_SKIP_IMAGES_EXT = $806D;

GL_UNPACK_IMAGE_HEIGHT_EXT = $806E;

GL_TEXTURE_3D_EXT = $806F;

GL_PROXY_TEXTURE_3D_EXT = $8070;

GL_TEXTURE_DEPTH_EXT = $8071;

GL_TEXTURE_WRAP_R_EXT = $8072;

GL_MAX_3D_TEXTURE_SIZE_EXT = $8073;

GL_HISTOGRAM_EXT = $8024;

GL_PROXY_HISTOGRAM_EXT = $8025;

GL_HISTOGRAM_WIDTH_EXT = $8026;

GL_HISTOGRAM_FORMAT_EXT = $8027;

GL_HISTOGRAM_RED_SIZE_EXT = $8028;

GL_HISTOGRAM_GREEN_SIZE_EXT = $8029;

GL_HISTOGRAM_BLUE_SIZE_EXT = $802A;

GL_HISTOGRAM_ALPHA_SIZE_EXT = $802B;

GL_HISTOGRAM_LUMINANCE_SIZE_EXT = $802C;

GL_HISTOGRAM_SINK_EXT = $802D;

GL_MINMAX_EXT = $802E;

GL_MINMAX_FORMAT_EXT = $802F;

GL_MINMAX_SINK_EXT = $8030;

GL_CONVOLUTION_1D_EXT = $8010;

GL_CONVOLUTION_2D_EXT = $8011;

GL_SEPARABLE_2D_EXT = $8012;

GL_CONVOLUTION_BORDER_MODE_EXT = $8013;

GL_CONVOLUTION_FILTER_SCALE_EXT = $8014;

GL_CONVOLUTION_FILTER_BIAS_EXT = $8015;

GL_REDUCE_EXT = $8016;

GL_CONVOLUTION_FORMAT_EXT = $8017;

GL_CONVOLUTION_WIDTH_EXT = $8018;

GL_CONVOLUTION_HEIGHT_EXT = $8019;

GL_MAX_CONVOLUTION_WIDTH_EXT = $801A;

GL_MAX_CONVOLUTION_HEIGHT_EXT = $801B;

GL_POST_CONVOLUTION_RED_SCALE_EXT = $801C;

GL_POST_CONVOLUTION_GREEN_SCALE_EXT = $801D;

GL_POST_CONVOLUTION_BLUE_SCALE_EXT = $801E;

GL_POST_CONVOLUTION_ALPHA_SCALE_EXT = $801F;

GL_POST_CONVOLUTION_RED_BIAS_EXT = $8020;

GL_POST_CONVOLUTION_GREEN_BIAS_EXT = $8021;

GL_POST_CONVOLUTION_BLUE_BIAS_EXT = $8022;

GL_POST_CONVOLUTION_ALPHA_BIAS_EXT = $8023;

GL_COLOR_MATRIX_SGI = $80B1;

GL_COLOR_MATRIX_STACK_DEPTH_SGI = $80B2;

GL_MAX_COLOR_MATRIX_STACK_DEPTH_SGI = $80B3;

GL_POST_COLOR_MATRIX_RED_SCALE_SGI = $80B4;

GL_POST_COLOR_MATRIX_GREEN_SCALE_SGI = $80B5;

GL_POST_COLOR_MATRIX_BLUE_SCALE_SGI = $80B6;

GL_POST_COLOR_MATRIX_ALPHA_SCALE_SGI = $80B7;

GL_POST_COLOR_MATRIX_RED_BIAS_SGI = $80B8;

GL_POST_COLOR_MATRIX_GREEN_BIAS_SGI = $80B9;

GL_POST_COLOR_MATRIX_BLUE_BIAS_SGI = $80BA;

GL_POST_COLOR_MATRIX_ALPHA_BIAS_SGI = $80BB;

GL_TEXTURE_PRIORITY_EXT = $8066;

GL_TEXTURE_RESIDENT_EXT = $8067;

GL_TEXTURE_1D_BINDING_EXT = $8068;

GL_TEXTURE_2D_BINDING_EXT = $8069;

GL_TEXTURE_3D_BINDING_EXT = $806A;

GL_UNSIGNED_BYTE_3_3_2_EXT = $8032;

GL_UNSIGNED_SHORT_4_4_4_4_EXT = $8033;

GL_UNSIGNED_SHORT_5_5_5_1_EXT = $8034;

GL_UNSIGNED_INT_8_8_8_8_EXT = $8035;

GL_UNSIGNED_INT_10_10_10_2_EXT = $8036;

GL_TEXTURE_MIN_LOD_SGIS = $813A;

GL_TEXTURE_MAX_LOD_SGIS = $813B;

GL_TEXTURE_BASE_LEVEL_SGIS = $813C;

GL_TEXTURE_MAX_LEVEL_SGIS = $813D;

GL_MULTISAMPLE_SGIS = $809D;

GL_SAMPLE_ALPHA_TO_MASK_SGIS = $809E;

GL_SAMPLE_ALPHA_TO_ONE_SGIS = $809F;

GL_SAMPLE_MASK_SGIS = $80A0;

GL_1PASS_SGIS = $80A1;

GL_2PASS_0_SGIS = $80A2;

GL_2PASS_1_SGIS = $80A3;

GL_4PASS_0_SGIS = $80A4;

GL_4PASS_1_SGIS = $80A5;

GL_4PASS_2_SGIS = $80A6;

GL_4PASS_3_SGIS = $80A7;

GL_SAMPLE_BUFFERS_SGIS = $80A8;

GL_SAMPLES_SGIS = $80A9;

GL_SAMPLE_MASK_VALUE_SGIS = $80AA;

GL_SAMPLE_MASK_INVERT_SGIS = $80AB;

GL_SAMPLE_PATTERN_SGIS = $80AC;

GL_RESCALE_NORMAL_EXT = $803A;

GL_GENERATE_MIPMAP_SGIS = $8191;

GL_GENERATE_MIPMAP_HINT_SGIS = $8192;

GL_TEXTURE_COMPARE_SGIX = $819A;

GL_TEXTURE_COMPARE_OPERATOR_SGIX = $819B;

GL_TEXTURE_LEQUAL_R_SGIX = $819C;

GL_TEXTURE_GEQUAL_R_SGIX = $819D;

GL_CLAMP_TO_EDGE_SGIS = $812F;

GL_CLAMP_TO_BORDER_SGIS = $812D;

GL_FUNC_ADD_EXT = $8006;

GL_MIN_EXT = $8007;

GL_MAX_EXT = $8008;

GL_BLEND_EQUATION_EXT = $8009;

GL_FUNC_SUBTRACT_EXT = $800A;

GL_FUNC_REVERSE_SUBTRACT_EXT = $800B;

GLU_OBJECT_PARAMETRIC_ERROR_EXT = 100208;

GLU_OBJECT_PATH_LENGTH_EXT = 100209;

GL_COLOR_INDEX1_EXT = $80E2;

GL_COLOR_INDEX2_EXT = $80E3;

GL_COLOR_INDEX4_EXT = $80E4;

GL_COLOR_INDEX8_EXT = $80E5;

GL_COLOR_INDEX12_EXT = $80E6;

GL_COLOR_INDEX16_EXT = $80E7;

GL_TEXTURE_INDEX_SIZE_EXT = $80ED;

GL_CLIP_VOLUME_CLIPPING_HINT_EXT = $80F0;

GL_SHADOW_AMBIENT_SGIX = $80BF;

GL_ARRAY_ELEMENT_LOCK_FIRST_EXT = $81A8;

GL_ARRAY_ELEMENT_LOCK_COUNT_EXT = $81A9;

GLU_NURBS_MODE_EXT = 100160;

GLU_NURBS_TESSELLATOR_EXT = 100161;

GLU_NURBS_RENDERER_EXT = 100162;

GLU_NURBS_BEGIN_EXT = 100164;

GLU_NURBS_VERTEX_EXT = 100165;

GLU_NURBS_NORMAL_EXT = 100166;

GLU_NURBS_COLOR_EXT = 100167;

GLU_NURBS_TEX_COORD_EXT = 100168;

GLU_NURBS_END_EXT = 100169;

GLU_NURBS_BEGIN_DATA_EXT = 100170;

GLU_NURBS_VERTEX_DATA_EXT = 100171;

GLU_NURBS_NORMAL_DATA_EXT = 100172;

GLU_NURBS_COLOR_DATA_EXT = 100173;

GLU_NURBS_TEX_COORD_DATA_EXT = 100174;

GLU_NURBS_END_DATA_EXT = 100175;

GL_RASTER_POSITION_UNCLIPPED_IBM = $19262;

GL_MAX_ELEMENTS_VERTICES_EXT = $80E8;

GL_MAX_ELEMENTS_INDICES_EXT = $80E9;

GL_BGR_EXT = $80E0;

GL_BGRA_EXT = $80E1;

GL_OCCLUSION_TEST_HP = $8165;

GL_OCCLUSION_TEST_RESULT_HP = $8166;

GL_SHARED_TEXTURE_PALETTE_EXT = $81FB;

GL_LIGHT_MODEL_COLOR_CONTROL_EXT = $81F8;

GL_SINGLE_COLOR_EXT = $81F9;

GL_SEPARATE_SPECULAR_COLOR_EXT = $81FA;

GL_COLOR_SUM_EXT = $8458;

GL_CURRENT_SECONDARY_COLOR_EXT = $8459;

GL_SECONDARY_COLOR_ARRAY_SIZE_EXT = $845A;

GL_SECONDARY_COLOR_ARRAY_TYPE_EXT = $845B;

GL_SECONDARY_COLOR_ARRAY_STRIDE_EXT = $845C;

GL_SECONDARY_COLOR_ARRAY_POINTER_EXT = $845D;

GL_SECONDARY_COLOR_ARRAY_EXT = $845E;

GL_FOG_COORDINATE_SOURCE_EXT = $8450;

GL_FOG_COORDINATE_EXT = $8451;

GL_FRAGMENT_DEPTH_EXT = $8452;

GL_CURRENT_FOG_COORDINATE_EXT = $8453;

GL_FOG_COORDINATE_ARRAY_TYPE_EXT = $8454;

GL_FOG_COORDINATE_ARRAY_STRIDE_EXT = $8455;

GL_FOG_COORDINATE_ARRAY_POINTER_EXT = $8456;

GL_FOG_COORDINATE_ARRAY_EXT = $8457;

GL_COMBINE_EXT = $8570;

GL_COMBINE_RGB_EXT = $8571;

GL_COMBINE_ALPHA_EXT = $8572;

GL_RGB_SCALE_EXT = $8573;

GL_ADD_SIGNED_EXT = $8574;

GL_INTERPOLATE_EXT = $8575;

GL_CONSTANT_EXT = $8576;

GL_PRIMARY_COLOR_EXT = $8577;

GL_PREVIOUS_EXT = $8578;

GL_SOURCE0_RGB_EXT = $8580;

GL_SOURCE1_RGB_EXT = $8581;

GL_SOURCE2_RGB_EXT = $8582;

GL_SOURCE0_ALPHA_EXT = $8588;

GL_SOURCE1_ALPHA_EXT = $8589;

GL_SOURCE2_ALPHA_EXT = $858A;

GL_OPERAND0_RGB_EXT = $8590;

GL_OPERAND1_RGB_EXT = $8591;

GL_OPERAND2_RGB_EXT = $8592;

GL_OPERAND0_ALPHA_EXT = $8598;

GL_OPERAND1_ALPHA_EXT = $8599;

GL_OPERAND2_ALPHA_EXT = $859A;

GL_SOURCE3_RGB_EXT = $8583;

GL_SOURCE4_RGB_EXT = $8584;

GL_SOURCE5_RGB_EXT = $8585;

GL_SOURCE6_RGB_EXT = $8586;

GL_SOURCE7_RGB_EXT = $8587;

GL_SOURCE3_ALPHA_EXT = $858B;

GL_SOURCE4_ALPHA_EXT = $858C;

GL_SOURCE5_ALPHA_EXT = $858D;

GL_SOURCE6_ALPHA_EXT = $858E;

GL_SOURCE7_ALPHA_EXT = $858F;

GL_OPERAND3_RGB_EXT = $8593;

GL_OPERAND4_RGB_EXT = $8594;

GL_OPERAND5_RGB_EXT = $8595;

GL_OPERAND6_RGB_EXT = $8596;

GL_OPERAND7_RGB_EXT = $8597;

GL_OPERAND3_ALPHA_EXT = $859B;

GL_OPERAND4_ALPHA_EXT = $859C;

GL_OPERAND5_ALPHA_EXT = $859D;

GL_OPERAND6_ALPHA_EXT = $859E;

GL_OPERAND7_ALPHA_EXT = $859F;

GL_BLEND_DST_RGB_EXT = $80C8;

GL_BLEND_SRC_RGB_EXT = $80C9;

GL_BLEND_DST_ALPHA_EXT = $80CA;

GL_BLEND_SRC_ALPHA_EXT = $80CB;

GL_NORMAL_MAP_EXT = $8511;

GL_REFLECTION_MAP_EXT = $8512;

GL_TEXTURE_CUBE_MAP_EXT = $8513;

GL_TEXTURE_BINDING_CUBE_MAP_EXT = $8514;

GL_TEXTURE_CUBE_MAP_POSITIVE_X_EXT = $8515;

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_EXT = $8516;

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_EXT = $8517;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_EXT = $8518;

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_EXT = $8519;

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_EXT = $851A;

GL_PROXY_TEXTURE_CUBE_MAP_EXT = $851B;

GL_MAX_CUBE_MAP_TEXTURE_SIZE_EXT = $851C;

GL_INCR_WRAP_EXT = $8507;

GL_DECR_WRAP_EXT = $8508;

GL_NORMAL_MAP_NV = $8511;

GL_REFLECTION_MAP_NV = $8512;

GL_MAX_TEXTURE_LOD_BIAS_EXT = $84FD;

GL_TEXTURE_FILTER_CONTROL_EXT = $8500;

GL_TEXTURE_LOD_BIAS_EXT = $8501;

GL_TEXTURE_MAX_ANISOTROPY_EXT = $84FE;

GL_MAX_TEXTURE_MAX_ANISOTROPY_EXT = $84FF;

GL_MAX_SHININESS_NV = $8504;

GL_MAX_SPOT_EXPONENT_NV = $8505;

GL_VERTEX_ARRAY_RANGE_NV = $851D;

GL_VERTEX_ARRAY_RANGE_LENGTH_NV = $851E;

GL_VERTEX_ARRAY_RANGE_VALID_NV = $851F;

GL_MAX_VERTEX_ARRAY_RANGE_ELEMENT_NV = $8520;

GL_VERTEX_ARRAY_RANGE_POINTER_NV = $8521;

GL_REGISTER_COMBINERS_NV = $8522;

GL_VARIABLE_A_NV = $8523;

GL_VARIABLE_B_NV = $8524;

GL_VARIABLE_C_NV = $8525;

GL_VARIABLE_D_NV = $8526;

GL_VARIABLE_E_NV = $8527;

GL_VARIABLE_F_NV = $8528;

GL_VARIABLE_G_NV = $8529;

GL_CONSTANT_COLOR0_NV = $852A;

GL_CONSTANT_COLOR1_NV = $852B;

GL_PRIMARY_COLOR_NV = $852C;

GL_SECONDARY_COLOR_NV = $852D;

GL_SPARE0_NV = $852E;

GL_SPARE1_NV = $852F;

GL_DISCARD_NV = $8530;

GL_E_TIMES_F_NV = $8531;

GL_SPARE0_PLUS_SECONDARY_COLOR_NV = $8532;

GL_UNSIGNED_IDENTITY_NV = $8536;

GL_UNSIGNED_INVERT_NV = $8537;

GL_EXPAND_NORMAL_NV = $8538;

GL_EXPAND_NEGATE_NV = $8539;

GL_HALF_BIAS_NORMAL_NV = $853A;

GL_HALF_BIAS_NEGATE_NV = $853B;

GL_SIGNED_IDENTITY_NV = $853C;

GL_SIGNED_NEGATE_NV = $853D;

GL_SCALE_BY_TWO_NV = $853E;

GL_SCALE_BY_FOUR_NV = $853F;

GL_SCALE_BY_ONE_HALF_NV = $8540;

GL_BIAS_BY_NEGATIVE_ONE_HALF_NV = $8541;

GL_COMBINER_INPUT_NV = $8542;

GL_COMBINER_MAPPING_NV = $8543;

GL_COMBINER_COMPONENT_USAGE_NV = $8544;

GL_COMBINER_AB_DOT_PRODUCT_NV = $8545;

GL_COMBINER_CD_DOT_PRODUCT_NV = $8546;

GL_COMBINER_MUX_SUM_NV = $8547;

GL_COMBINER_SCALE_NV = $8548;

GL_COMBINER_BIAS_NV = $8549;

GL_COMBINER_AB_OUTPUT_NV = $854A;

GL_COMBINER_CD_OUTPUT_NV = $854B;

GL_COMBINER_SUM_OUTPUT_NV = $854C;

GL_MAX_GENERAL_COMBINERS_NV = $854D;

GL_NUM_GENERAL_COMBINERS_NV = $854E;

GL_COLOR_SUM_CLAMP_NV = $854F;

GL_COMBINER0_NV = $8550;

GL_COMBINER1_NV = $8551;

GL_COMBINER2_NV = $8552;

GL_COMBINER3_NV = $8553;

GL_COMBINER4_NV = $8554;

GL_COMBINER5_NV = $8555;

GL_COMBINER6_NV = $8556;

GL_COMBINER7_NV = $8557;

GLX_VIDEO_OUT_COLOR_NV = $20C3;

GLX_VIDEO_OUT_ALPHA_NV = $20C4;

GLX_VIDEO_OUT_DEPTH_NV = $20C5;

GLX_VIDEO_OUT_COLOR_AND_ALPHA_NV = $20C6;

GLX_VIDEO_OUT_COLOR_AND_DEPTH_NV = $20C7;

GLX_VIDEO_OUT_FRAME_NV = $20C8;

GLX_VIDEO_OUT_FIELD_1_NV = $20C9;

GLX_VIDEO_OUT_FIELD_2_NV = $20CA;

GLX_VIDEO_OUT_STACKED_FIELDS_1_2_NV = $20CB;

GLX_VIDEO_OUT_STACKED_FIELDS_2_1_NV = $20CC;

GLX_NUM_VIDEO_SLOTS_NV = $20F0;

GLX_SWAP_INTERVAL_EXT = $20F1;

GLX_MAX_SWAP_INTERVAL_EXT = $20F2;

GLX_DEVICE_ID_NV = $20CD;

GLX_UNIQUE_ID_NV = $20CE;

GLX_NUM_VIDEO_CAPTURE_SLOTS_NV = $20CF;

GL_FOG_DISTANCE_MODE_NV = $855A;

GL_EYE_RADIAL_NV = $855B;

GL_EYE_PLANE_ABSOLUTE_NV = $855C;

GL_COMBINE4_NV = $8503;

GL_SOURCE3_RGB_NV = $8583;

GL_SOURCE3_ALPHA_NV = $858B;

GL_OPERAND3_RGB_NV = $8593;

GL_OPERAND3_ALPHA_NV = $859B;

GL_COMPRESSED_RGB_S3TC_DXT1_EXT = $83F0;

GL_COMPRESSED_RGBA_S3TC_DXT1_EXT = $83F1;

GL_COMPRESSED_RGBA_S3TC_DXT3_EXT = $83F2;

GL_COMPRESSED_RGBA_S3TC_DXT5_EXT = $83F3;

GL_COMPRESSED_RGB_FXT1_3DFX = $86B0;

GL_COMPRESSED_RGBA_FXT1_3DFX = $86B1;

GL_MULTISAMPLE_3DFX = $86B2;

GL_SAMPLE_BUFFERS_3DFX = $86B3;

GL_SAMPLES_3DFX = $86B4;

GL_MULTISAMPLE_BIT_3DFX = $20000000;

GL_MULTISAMPLE_EXT = $809D;

GL_SAMPLE_ALPHA_TO_MASK_EXT = $809E;

GL_SAMPLE_ALPHA_TO_ONE_EXT = $809F;

GL_SAMPLE_MASK_EXT = $80A0;

GL_1PASS_EXT = $80A1;

GL_2PASS_0_EXT = $80A2;

GL_2PASS_1_EXT = $80A3;

GL_4PASS_0_EXT = $80A4;

GL_4PASS_1_EXT = $80A5;

GL_4PASS_2_EXT = $80A6;

GL_4PASS_3_EXT = $80A7;

GL_SAMPLE_BUFFERS_EXT = $80A8;

GL_SAMPLES_EXT = $80A9;

GL_SAMPLE_MASK_VALUE_EXT = $80AA;

GL_SAMPLE_MASK_INVERT_EXT = $80AB;

GL_SAMPLE_PATTERN_EXT = $80AC;

WGL_SAMPLE_BUFFERS_EXT = $2041;

WGL_SAMPLES_EXT = $2042;

GL_TEXTURE_COLOR_WRITEMASK_SGIS = $81EF;

GL_DOT3_RGB_EXT = $8740;

GL_DOT3_RGBA_EXT = $8741;

GL_MIRROR_CLAMP_ATI = $8742;

GL_MIRROR_CLAMP_TO_EDGE_ATI = $8743;

GL_ALL_COMPLETED_NV = $84F2;

GL_FENCE_STATUS_NV = $84F3;

GL_FENCE_CONDITION_NV = $84F4;

GL_TEXTURE_RECTANGLE_NV = $84F5;

GL_TEXTURE_BINDING_RECTANGLE_NV = $84F6;

GL_PROXY_TEXTURE_RECTANGLE_NV = $84F7;

GL_MAX_RECTANGLE_TEXTURE_SIZE_NV = $84F8;

GL_OFFSET_TEXTURE_RECTANGLE_NV = $864C;

GL_OFFSET_TEXTURE_RECTANGLE_SCALE_NV = $864D;

GL_DOT_PRODUCT_TEXTURE_RECTANGLE_NV = $864E;

GL_RGBA_UNSIGNED_DOT_PRODUCT_MAPPING_NV = $86D9;

GL_UNSIGNED_INT_S8_S8_8_8_NV = $86DA;

GL_UNSIGNED_INT_8_8_S8_S8_REV_NV = $86DB;

GL_DSDT_MAG_INTENSITY_NV = $86DC;

GL_SHADER_CONSISTENT_NV = $86DD;

GL_TEXTURE_SHADER_NV = $86DE;

GL_SHADER_OPERATION_NV = $86DF;

GL_CULL_MODES_NV = $86E0;

GL_OFFSET_TEXTURE_MATRIX_NV = $86E1;

GL_OFFSET_TEXTURE_SCALE_NV = $86E2;

GL_OFFSET_TEXTURE_BIAS_NV = $86E3;

GL_OFFSET_TEXTURE_2D_MATRIX_NV = GL_OFFSET_TEXTURE_MATRIX_NV;

GL_OFFSET_TEXTURE_2D_SCALE_NV = GL_OFFSET_TEXTURE_SCALE_NV;

GL_OFFSET_TEXTURE_2D_BIAS_NV = GL_OFFSET_TEXTURE_BIAS_NV;

GL_PREVIOUS_TEXTURE_INPUT_NV = $86E4;

GL_CONST_EYE_NV = $86E5;

GL_PASS_THROUGH_NV = $86E6;

GL_CULL_FRAGMENT_NV = $86E7;

GL_OFFSET_TEXTURE_2D_NV = $86E8;

GL_DEPENDENT_AR_TEXTURE_2D_NV = $86E9;

GL_DEPENDENT_GB_TEXTURE_2D_NV = $86EA;

GL_DOT_PRODUCT_NV = $86EC;

GL_DOT_PRODUCT_DEPTH_REPLACE_NV = $86ED;

GL_DOT_PRODUCT_TEXTURE_2D_NV = $86EE;

GL_DOT_PRODUCT_TEXTURE_CUBE_MAP_NV = $86F0;

GL_DOT_PRODUCT_DIFFUSE_CUBE_MAP_NV = $86F1;

GL_DOT_PRODUCT_REFLECT_CUBE_MAP_NV = $86F2;

GL_DOT_PRODUCT_CONST_EYE_REFLECT_CUBE_MAP_NV = $86F3;

GL_HILO_NV = $86F4;

GL_DSDT_NV = $86F5;

GL_DSDT_MAG_NV = $86F6;

GL_DSDT_MAG_VIB_NV = $86F7;

GL_HILO16_NV = $86F8;

GL_SIGNED_HILO_NV = $86F9;

GL_SIGNED_HILO16_NV = $86FA;

GL_SIGNED_RGBA_NV = $86FB;

GL_SIGNED_RGBA8_NV = $86FC;

GL_SIGNED_RGB_NV = $86FE;

GL_SIGNED_RGB8_NV = $86FF;

GL_SIGNED_LUMINANCE_NV = $8701;

GL_SIGNED_LUMINANCE8_NV = $8702;

GL_SIGNED_LUMINANCE_ALPHA_NV = $8703;

GL_SIGNED_LUMINANCE8_ALPHA8_NV = $8704;

GL_SIGNED_ALPHA_NV = $8705;

GL_SIGNED_ALPHA8_NV = $8706;

GL_SIGNED_INTENSITY_NV = $8707;

GL_SIGNED_INTENSITY8_NV = $8708;

GL_DSDT8_NV = $8709;

GL_DSDT8_MAG8_NV = $870A;

GL_DSDT8_MAG8_INTENSITY8_NV = $870B;

GL_SIGNED_RGB_UNSIGNED_ALPHA_NV = $870C;

GL_SIGNED_RGB8_UNSIGNED_ALPHA8_NV = $870D;

GL_HI_SCALE_NV = $870E;

GL_LO_SCALE_NV = $870F;

GL_DS_SCALE_NV = $8710;

GL_DT_SCALE_NV = $8711;

GL_MAGNITUDE_SCALE_NV = $8712;

GL_VIBRANCE_SCALE_NV = $8713;

GL_HI_BIAS_NV = $8714;

GL_LO_BIAS_NV = $8715;

GL_DS_BIAS_NV = $8716;

GL_DT_BIAS_NV = $8717;

GL_MAGNITUDE_BIAS_NV = $8718;

GL_VIBRANCE_BIAS_NV = $8719;

GL_TEXTURE_BORDER_VALUES_NV = $871A;

GL_TEXTURE_HI_SIZE_NV = $871B;

GL_TEXTURE_LO_SIZE_NV = $871C;

GL_TEXTURE_DS_SIZE_NV = $871D;

GL_TEXTURE_DT_SIZE_NV = $871E;

GL_TEXTURE_MAG_SIZE_NV = $871F;

GL_DOT_PRODUCT_TEXTURE_3D_NV = $86EF;

GL_VERTEX_ARRAY_RANGE_WITHOUT_FLUSH_NV = $8533;

GL_VERTEX_PROGRAM_NV = $8620;

GL_VERTEX_STATE_PROGRAM_NV = $8621;

GL_ATTRIB_ARRAY_SIZE_NV = $8623;

GL_ATTRIB_ARRAY_STRIDE_NV = $8624;

GL_ATTRIB_ARRAY_TYPE_NV = $8625;

GL_CURRENT_ATTRIB_NV = $8626;

GL_PROGRAM_LENGTH_NV = $8627;

GL_PROGRAM_STRING_NV = $8628;

GL_MODELVIEW_PROJECTION_NV = $8629;

GL_IDENTITY_NV = $862A;

GL_INVERSE_NV = $862B;

GL_TRANSPOSE_NV = $862C;

GL_INVERSE_TRANSPOSE_NV = $862D;

GL_MAX_TRACK_MATRIX_STACK_DEPTH_NV = $862E;

GL_MAX_TRACK_MATRICES_NV = $862F;

GL_MATRIX0_NV = $8630;

GL_MATRIX1_NV = $8631;

GL_MATRIX2_NV = $8632;

GL_MATRIX3_NV = $8633;

GL_MATRIX4_NV = $8634;

GL_MATRIX5_NV = $8635;

GL_MATRIX6_NV = $8636;

GL_MATRIX7_NV = $8637;

GL_CURRENT_MATRIX_STACK_DEPTH_NV = $8640;

GL_CURRENT_MATRIX_NV = $8641;

GL_VERTEX_PROGRAM_POINT_SIZE_NV = $8642;

GL_VERTEX_PROGRAM_TWO_SIDE_NV = $8643;

GL_PROGRAM_PARAMETER_NV = $8644;

GL_ATTRIB_ARRAY_POINTER_NV = $8645;

GL_PROGRAM_TARGET_NV = $8646;

GL_PROGRAM_RESIDENT_NV = $8647;

GL_TRACK_MATRIX_NV = $8648;

GL_TRACK_MATRIX_TRANSFORM_NV = $8649;

GL_VERTEX_PROGRAM_BINDING_NV = $864A;

GL_PROGRAM_ERROR_POSITION_NV = $864B;

GL_VERTEX_ATTRIB_ARRAY0_NV = $8650;

GL_VERTEX_ATTRIB_ARRAY1_NV = $8651;

GL_VERTEX_ATTRIB_ARRAY2_NV = $8652;

GL_VERTEX_ATTRIB_ARRAY3_NV = $8653;

GL_VERTEX_ATTRIB_ARRAY4_NV = $8654;

GL_VERTEX_ATTRIB_ARRAY5_NV = $8655;

GL_VERTEX_ATTRIB_ARRAY6_NV = $8656;

GL_VERTEX_ATTRIB_ARRAY7_NV = $8657;

GL_VERTEX_ATTRIB_ARRAY8_NV = $8658;

GL_VERTEX_ATTRIB_ARRAY9_NV = $8659;

GL_VERTEX_ATTRIB_ARRAY10_NV = $865A;

GL_VERTEX_ATTRIB_ARRAY11_NV = $865B;

GL_VERTEX_ATTRIB_ARRAY12_NV = $865C;

GL_VERTEX_ATTRIB_ARRAY13_NV = $865D;

GL_VERTEX_ATTRIB_ARRAY14_NV = $865E;

GL_VERTEX_ATTRIB_ARRAY15_NV = $865F;

GL_MAP1_VERTEX_ATTRIB0_4_NV = $8660;

GL_MAP1_VERTEX_ATTRIB1_4_NV = $8661;

GL_MAP1_VERTEX_ATTRIB2_4_NV = $8662;

GL_MAP1_VERTEX_ATTRIB3_4_NV = $8663;

GL_MAP1_VERTEX_ATTRIB4_4_NV = $8664;

GL_MAP1_VERTEX_ATTRIB5_4_NV = $8665;

GL_MAP1_VERTEX_ATTRIB6_4_NV = $8666;

GL_MAP1_VERTEX_ATTRIB7_4_NV = $8667;

GL_MAP1_VERTEX_ATTRIB8_4_NV = $8668;

GL_MAP1_VERTEX_ATTRIB9_4_NV = $8669;

GL_MAP1_VERTEX_ATTRIB10_4_NV = $866A;

GL_MAP1_VERTEX_ATTRIB11_4_NV = $866B;

GL_MAP1_VERTEX_ATTRIB12_4_NV = $866C;

GL_MAP1_VERTEX_ATTRIB13_4_NV = $866D;

GL_MAP1_VERTEX_ATTRIB14_4_NV = $866E;

GL_MAP1_VERTEX_ATTRIB15_4_NV = $866F;

GL_MAP2_VERTEX_ATTRIB0_4_NV = $8670;

GL_MAP2_VERTEX_ATTRIB1_4_NV = $8671;

GL_MAP2_VERTEX_ATTRIB2_4_NV = $8672;

GL_MAP2_VERTEX_ATTRIB3_4_NV = $8673;

GL_MAP2_VERTEX_ATTRIB4_4_NV = $8674;

GL_MAP2_VERTEX_ATTRIB5_4_NV = $8675;

GL_MAP2_VERTEX_ATTRIB6_4_NV = $8676;

GL_MAP2_VERTEX_ATTRIB7_4_NV = $8677;

GL_MAP2_VERTEX_ATTRIB8_4_NV = $8678;

GL_MAP2_VERTEX_ATTRIB9_4_NV = $8679;

GL_MAP2_VERTEX_ATTRIB10_4_NV = $867A;

GL_MAP2_VERTEX_ATTRIB11_4_NV = $867B;

GL_MAP2_VERTEX_ATTRIB12_4_NV = $867C;

GL_MAP2_VERTEX_ATTRIB13_4_NV = $867D;

GL_MAP2_VERTEX_ATTRIB14_4_NV = $867E;

GL_MAP2_VERTEX_ATTRIB15_4_NV = $867F;

GL_MULTISAMPLE_FILTER_HINT_NV = $8534;

GL_PIXEL_COUNTER_BITS_NV = $8864;

GL_CURRENT_OCCLUSION_QUERY_ID_NV = $8865;

GL_PIXEL_COUNT_NV = $8866;

GL_PIXEL_COUNT_AVAILABLE_NV = $8867;

GL_POINT_SPRITE_NV = $8861;

GL_COORD_REPLACE_NV = $8862;

GL_POINT_SPRITE_R_MODE_NV = $8863;

GL_OFFSET_PROJECTIVE_TEXTURE_2D_NV = $8850;

GL_OFFSET_PROJECTIVE_TEXTURE_2D_SCALE_NV = $8851;

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_NV = $8852;

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_SCALE_NV = $8853;

GL_OFFSET_HILO_TEXTURE_2D_NV = $8854;

GL_OFFSET_HILO_TEXTURE_RECTANGLE_NV = $8855;

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_2D_NV = $8856;

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_RECTANGLE_NV = $8857;

GL_DEPENDENT_HILO_TEXTURE_2D_NV = $8858;

GL_DEPENDENT_RGB_TEXTURE_3D_NV = $8859;

GL_DEPENDENT_RGB_TEXTURE_CUBE_MAP_NV = $885A;

GL_DOT_PRODUCT_PASS_THROUGH_NV = $885B;

GL_DOT_PRODUCT_TEXTURE_1D_NV = $885C;

GL_DOT_PRODUCT_AFFINE_DEPTH_REPLACE_NV = $885D;

GL_HILO8_NV = $885E;

GL_SIGNED_HILO8_NV = $885F;

GL_FORCE_BLUE_TO_ONE_NV = $8860;

GL_STENCIL_TEST_TWO_SIDE_EXT = $8910;

GL_ACTIVE_STENCIL_FACE_EXT = $8911;

GL_MAX_DRAW_BUFFERS_ATI = $8824;

GL_DRAW_BUFFER0_ATI = $8825;

GL_DRAW_BUFFER1_ATI = $8826;

GL_DRAW_BUFFER2_ATI = $8827;

GL_DRAW_BUFFER3_ATI = $8828;

GL_DRAW_BUFFER4_ATI = $8829;

GL_DRAW_BUFFER5_ATI = $882A;

GL_DRAW_BUFFER6_ATI = $882B;

GL_DRAW_BUFFER7_ATI = $882C;

GL_DRAW_BUFFER8_ATI = $882D;

GL_DRAW_BUFFER9_ATI = $882E;

GL_DRAW_BUFFER10_ATI = $882F;

GL_DRAW_BUFFER11_ATI = $8830;

GL_DRAW_BUFFER12_ATI = $8831;

GL_DRAW_BUFFER13_ATI = $8832;

GL_DRAW_BUFFER14_ATI = $8833;

GL_DRAW_BUFFER15_ATI = $8834;

WGL_TYPE_RGBA_FLOAT_ATI = $21A0;

GL_TYPE_RGBA_FLOAT_ATI = $8820;

GL_COLOR_CLEAR_UNCLAMPED_VALUE_ATI = $8835;

GL_RGBA_FLOAT32_ATI = $8814;

GL_RGB_FLOAT32_ATI = $8815;

GL_ALPHA_FLOAT32_ATI = $8816;

GL_INTENSITY_FLOAT32_ATI = $8817;

GL_LUMINANCE_FLOAT32_ATI = $8818;

GL_LUMINANCE_ALPHA_FLOAT32_ATI = $8819;

GL_RGBA_FLOAT16_ATI = $881A;

GL_RGB_FLOAT16_ATI = $881B;

GL_ALPHA_FLOAT16_ATI = $881C;

GL_INTENSITY_FLOAT16_ATI = $881D;

GL_LUMINANCE_FLOAT16_ATI = $881E;

GL_LUMINANCE_ALPHA_FLOAT16_ATI = $881F;

GL_FLOAT_R_NV = $8880;

GL_FLOAT_RG_NV = $8881;

GL_FLOAT_RGB_NV = $8882;

GL_FLOAT_RGBA_NV = $8883;

GL_FLOAT_R16_NV = $8884;

GL_FLOAT_R32_NV = $8885;

GL_FLOAT_RG16_NV = $8886;

GL_FLOAT_RG32_NV = $8887;

GL_FLOAT_RGB16_NV = $8888;

GL_FLOAT_RGB32_NV = $8889;

GL_FLOAT_RGBA16_NV = $888A;

GL_FLOAT_RGBA32_NV = $888B;

GL_TEXTURE_FLOAT_COMPONENTS_NV = $888C;

GL_FLOAT_CLEAR_COLOR_VALUE_NV = $888D;

GL_FLOAT_RGBA_MODE_NV = $888E;

WGL_FLOAT_COMPONENTS_NV = $20B0;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV = $20B1;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV = $20B2;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV = $20B3;

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV = $20B4;

WGL_TEXTURE_FLOAT_R_NV = $20B5;

WGL_TEXTURE_FLOAT_RG_NV = $20B6;

WGL_TEXTURE_FLOAT_RGB_NV = $20B7;

WGL_TEXTURE_FLOAT_RGBA_NV = $20B8;

GLX_FLOAT_COMPONENTS_NV = $20B0;

GL_PRIMITIVE_RESTART_NV = $8558;

GL_PRIMITIVE_RESTART_INDEX_NV = $8559;

GL_DEPTH_BOUNDS_TEST_EXT = $8890;

GL_DEPTH_BOUNDS_EXT = $8891;

GL_MIRROR_CLAMP_EXT = $8742;

GL_MIRROR_CLAMP_TO_EDGE_EXT = $8743;

GL_MIRROR_CLAMP_TO_BORDER_EXT = $8912;

GL_BLEND_EQUATION_RGB_EXT = $8009;

GL_BLEND_EQUATION_ALPHA_EXT = $883D;

GL_PIXEL_PACK_BUFFER_EXT = $88EB;

GL_PIXEL_UNPACK_BUFFER_EXT = $88EC;

GL_PIXEL_PACK_BUFFER_BINDING_EXT = $88ED;

GL_PIXEL_UNPACK_BUFFER_BINDING_EXT = $88EF;

GL_FRAMEBUFFER_EXT = $8D40;

GL_RENDERBUFFER_EXT = $8D41;

GL_STENCIL_INDEX1_EXT = $8D46;

GL_STENCIL_INDEX4_EXT = $8D47;

GL_STENCIL_INDEX8_EXT = $8D48;

GL_STENCIL_INDEX16_EXT = $8D49;

GL_DEPTH24_STENCIL8_EXT = $88F0;

GL_RENDERBUFFER_WIDTH_EXT = $8D42;

GL_RENDERBUFFER_HEIGHT_EXT = $8D43;

GL_RENDERBUFFER_INTERNAL_FORMAT_EXT = $8D44;

GL_RENDERBUFFER_RED_SIZE_EXT = $8D50;

GL_RENDERBUFFER_GREEN_SIZE_EXT = $8D51;

GL_RENDERBUFFER_BLUE_SIZE_EXT = $8D52;

GL_RENDERBUFFER_ALPHA_SIZE_EXT = $8D53;

GL_RENDERBUFFER_DEPTH_SIZE_EXT = $8D54;

GL_RENDERBUFFER_STENCIL_SIZE_EXT = $8D55;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE_EXT = $8CD0;

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME_EXT = $8CD1;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL_EXT = $8CD2;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE_EXT = $8CD3;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_3D_ZOFFSET_EXT = $8CD4;

GL_COLOR_ATTACHMENT0_EXT = $8CE0;

GL_COLOR_ATTACHMENT1_EXT = $8CE1;

GL_COLOR_ATTACHMENT2_EXT = $8CE2;

GL_COLOR_ATTACHMENT3_EXT = $8CE3;

GL_COLOR_ATTACHMENT4_EXT = $8CE4;

GL_COLOR_ATTACHMENT5_EXT = $8CE5;

GL_COLOR_ATTACHMENT6_EXT = $8CE6;

GL_COLOR_ATTACHMENT7_EXT = $8CE7;

GL_COLOR_ATTACHMENT8_EXT = $8CE8;

GL_COLOR_ATTACHMENT9_EXT = $8CE9;

GL_COLOR_ATTACHMENT10_EXT = $8CEA;

GL_COLOR_ATTACHMENT11_EXT = $8CEB;

GL_COLOR_ATTACHMENT12_EXT = $8CEC;

GL_COLOR_ATTACHMENT13_EXT = $8CED;

GL_COLOR_ATTACHMENT14_EXT = $8CEE;

GL_COLOR_ATTACHMENT15_EXT = $8CEF;

GL_DEPTH_ATTACHMENT_EXT = $8D00;

GL_STENCIL_ATTACHMENT_EXT = $8D20;

GL_FRAMEBUFFER_COMPLETE_EXT = $8CD5;

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT_EXT = $8CD6;

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT_EXT = $8CD7;

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT = $8CD8;

GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS_EXT = $8CD9;

GL_FRAMEBUFFER_INCOMPLETE_FORMATS_EXT = $8CDA;

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER_EXT = $8CDB;

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER_EXT = $8CDC;

GL_FRAMEBUFFER_UNSUPPORTED_EXT = $8CDD;

GL_FRAMEBUFFER_BINDING_EXT = $8CA6;

GL_RENDERBUFFER_BINDING_EXT = $8CA7;

GL_MAX_COLOR_ATTACHMENTS_EXT = $8CDF;

GL_MAX_RENDERBUFFER_SIZE_EXT = $84E8;

GL_INVALID_FRAMEBUFFER_OPERATION_EXT = $0506;

GL_DEPTH_STENCIL_EXT = $84F9;

GL_UNSIGNED_INT_24_8_EXT = $84FA;

GL_TEXTURE_STENCIL_SIZE_EXT = $88F1;

GL_STENCIL_TAG_BITS_EXT = $88F2;

GL_STENCIL_CLEAR_TAG_VALUE_EXT = $88F3;

GL_SRGB_EXT = $8C40;

GL_SRGB8_EXT = $8C41;

GL_SRGB_ALPHA_EXT = $8C42;

GL_SRGB8_ALPHA8_EXT = $8C43;

GL_SLUMINANCE_ALPHA_EXT = $8C44;

GL_SLUMINANCE8_ALPHA8_EXT = $8C45;

GL_SLUMINANCE_EXT = $8C46;

GL_SLUMINANCE8_EXT = $8C47;

GL_COMPRESSED_SRGB_EXT = $8C48;

GL_COMPRESSED_SRGB_ALPHA_EXT = $8C49;

GL_COMPRESSED_SLUMINANCE_EXT = $8C4A;

GL_COMPRESSED_SLUMINANCE_ALPHA_EXT = $8C4B;

GL_COMPRESSED_SRGB_S3TC_DXT1_EXT = $8C4C;

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT1_EXT = $8C4D;

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT3_EXT = $8C4E;

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT5_EXT = $8C4F;

GL_READ_FRAMEBUFFER_EXT = $8CA8;

GL_DRAW_FRAMEBUFFER_EXT = $8CA9;

GL_DRAW_FRAMEBUFFER_BINDING_EXT = $8CA6;

GL_READ_FRAMEBUFFER_BINDING_EXT = $8CAA;

GL_RENDERBUFFER_SAMPLES_EXT = $8CAB;

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE_EXT = $8D56;

GL_MAX_SAMPLES_EXT = $8D57;

GL_TIME_ELAPSED_EXT = $88BF;

GL_GEOMETRY_PROGRAM_NV = $8C26;

GL_MAX_PROGRAM_OUTPUT_VERTICES_NV = $8C27;

GL_MAX_PROGRAM_TOTAL_OUTPUT_COMPONENTS_NV = $8C28;

GL_GEOMETRY_SHADER_EXT = $8DD9;

GL_GEOMETRY_VERTICES_OUT_EXT = $8DDA;

GL_GEOMETRY_INPUT_TYPE_EXT = $8DDB;

GL_GEOMETRY_OUTPUT_TYPE_EXT = $8DDC;

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_EXT = $8C29;

GL_MAX_GEOMETRY_VARYING_COMPONENTS_EXT = $8DDD;

GL_MAX_VERTEX_VARYING_COMPONENTS_EXT = $8DDE;

GL_MAX_VARYING_COMPONENTS_EXT = $8B4B;

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_EXT = $8DDF;

GL_MAX_GEOMETRY_OUTPUT_VERTICES_EXT = $8DE0;

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_EXT = $8DE1;

GL_LINES_ADJACENCY_EXT = $A;

GL_LINE_STRIP_ADJACENCY_EXT = $B;

GL_TRIANGLES_ADJACENCY_EXT = $C;

GL_TRIANGLE_STRIP_ADJACENCY_EXT = $D;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_EXT = $8DA8;

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_EXT = $8DA9;

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_EXT = $8DA7;

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER_EXT = $8CD4;

GL_PROGRAM_POINT_SIZE_EXT = $8642;

GL_VERTEX_ATTRIB_ARRAY_INTEGER_EXT = $88FD;

GL_SAMPLER_1D_ARRAY_EXT = $8DC0;

GL_SAMPLER_2D_ARRAY_EXT = $8DC1;

GL_SAMPLER_BUFFER_EXT = $8DC2;

GL_SAMPLER_1D_ARRAY_SHADOW_EXT = $8DC3;

GL_SAMPLER_2D_ARRAY_SHADOW_EXT = $8DC4;

GL_SAMPLER_CUBE_SHADOW_EXT = $8DC5;

GL_UNSIGNED_INT_VEC2_EXT = $8DC6;

GL_UNSIGNED_INT_VEC3_EXT = $8DC7;

GL_UNSIGNED_INT_VEC4_EXT = $8DC8;

GL_INT_SAMPLER_1D_EXT = $8DC9;

GL_INT_SAMPLER_2D_EXT = $8DCA;

GL_INT_SAMPLER_3D_EXT = $8DCB;

GL_INT_SAMPLER_CUBE_EXT = $8DCC;

GL_INT_SAMPLER_2D_RECT_EXT = $8DCD;

GL_INT_SAMPLER_1D_ARRAY_EXT = $8DCE;

GL_INT_SAMPLER_2D_ARRAY_EXT = $8DCF;

GL_INT_SAMPLER_BUFFER_EXT = $8DD0;

GL_UNSIGNED_INT_SAMPLER_1D_EXT = $8DD1;

GL_UNSIGNED_INT_SAMPLER_2D_EXT = $8DD2;

GL_UNSIGNED_INT_SAMPLER_3D_EXT = $8DD3;

GL_UNSIGNED_INT_SAMPLER_CUBE_EXT = $8DD4;

GL_UNSIGNED_INT_SAMPLER_2D_RECT_EXT = $8DD5;

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY_EXT = $8DD6;

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY_EXT = $8DD7;

GL_UNSIGNED_INT_SAMPLER_BUFFER_EXT = $8DD8;

GL_MIN_PROGRAM_TEXEL_OFFSET_EXT = $8904;

GL_MAX_PROGRAM_TEXEL_OFFSET_EXT = $8905;

GL_R11F_G11F_B10F_EXT = $8C3A;

GL_UNSIGNED_INT_10F_11F_11F_REV_EXT = $8C3B;

GL_RGBA_SIGNED_COMPONENTS_EXT = $8C3C;

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT = $20A8;

GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT = $20B1;

GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT = $00000008;

GL_TEXTURE_1D_ARRAY_EXT = $8C18;

GL_TEXTURE_2D_ARRAY_EXT = $8C1A;

GL_PROXY_TEXTURE_2D_ARRAY_EXT = $8C1B;

GL_PROXY_TEXTURE_1D_ARRAY_EXT = $8C19;

GL_TEXTURE_BINDING_1D_ARRAY_EXT = $8C1C;

GL_TEXTURE_BINDING_2D_ARRAY_EXT = $8C1D;

GL_MAX_ARRAY_TEXTURE_LAYERS_EXT = $88FF;

GL_COMPARE_REF_DEPTH_TO_TEXTURE_EXT = $884E;

GL_TEXTURE_BUFFER_EXT = $8C2A;

GL_MAX_TEXTURE_BUFFER_SIZE_EXT = $8C2B;

GL_TEXTURE_BINDING_BUFFER_EXT = $8C2C;

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_EXT = $8C2D;

GL_TEXTURE_BUFFER_FORMAT_EXT = $8C2E;

GL_COMPRESSED_LUMINANCE_LATC1_EXT = $8C70;

GL_COMPRESSED_SIGNED_LUMINANCE_LATC1_EXT = $8C71;

GL_COMPRESSED_LUMINANCE_ALPHA_LATC2_EXT = $8C72;

GL_COMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2_EXT = $8C73;

GL_COMPRESSED_LUMINANCE_ALPHA_3DC_ATI = $8837;

GL_COMPRESSED_RED_RGTC1_EXT = $8DBB;

GL_COMPRESSED_SIGNED_RED_RGTC1_EXT = $8DBC;

GL_COMPRESSED_RED_GREEN_RGTC2_EXT = $8DBD;

GL_COMPRESSED_SIGNED_RED_GREEN_RGTC2_EXT = $8DBE;

GL_RGB9_E5_EXT = $8C3D;

GL_UNSIGNED_INT_5_9_9_9_REV_EXT = $8C3E;

GL_TEXTURE_SHARED_SIZE_EXT = $8C3F;

GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20B2;

WGL_FRAMEBUFFER_SRGB_CAPABLE_EXT = $20A9;

GL_FRAMEBUFFER_SRGB_EXT = $8DB9;

GL_FRAMEBUFFER_SRGB_CAPABLE_EXT = $8DBA;

GL_TRANSFORM_FEEDBACK_BUFFER_NV = $8C8E;

GL_TRANSFORM_FEEDBACK_BUFFER_START_NV = $8C84;

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_NV = $8C85;

GL_TRANSFORM_FEEDBACK_RECORD_NV = $8C86;

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_NV = $8C8F;

GL_INTERLEAVED_ATTRIBS_NV = $8C8C;

GL_SEPARATE_ATTRIBS_NV = $8C8D;

GL_PRIMITIVES_GENERATED_NV = $8C87;

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_NV = $8C88;

GL_RASTERIZER_DISCARD_NV = $8C89;

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_NV = $8C8A;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_NV = $8C8B;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_NV = $8C80;

GL_TRANSFORM_FEEDBACK_ATTRIBS_NV = $8C7E;

GL_ACTIVE_VARYINGS_NV = $8C81;

GL_ACTIVE_VARYING_MAX_LENGTH_NV = $8C82;

GL_TRANSFORM_FEEDBACK_VARYINGS_NV = $8C83;

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_NV = $8C7F;

GL_BACK_PRIMARY_COLOR_NV = $8C77;

GL_BACK_SECONDARY_COLOR_NV = $8C78;

GL_TEXTURE_COORD_NV = $8C79;

GL_CLIP_DISTANCE_NV = $8C7A;

GL_VERTEX_ID_NV = $8C7B;

GL_PRIMITIVE_ID_NV = $8C7C;

GL_GENERIC_ATTRIB_NV = $8C7D;

GL_LAYER_NV = $8DAA;

GL_MAX_VERTEX_BINDABLE_UNIFORMS_EXT = $8DE2;

GL_MAX_FRAGMENT_BINDABLE_UNIFORMS_EXT = $8DE3;

GL_MAX_GEOMETRY_BINDABLE_UNIFORMS_EXT = $8DE4;

GL_MAX_BINDABLE_UNIFORM_SIZE_EXT = $8DED;

GL_UNIFORM_BUFFER_BINDING_EXT = $8DEF;

GL_UNIFORM_BUFFER_EXT = $8DEE;

GL_RGBA_INTEGER_MODE_EXT = $8D9E;

GL_RGBA32UI_EXT = $8D70;

GL_RGB32UI_EXT = $8D71;

GL_ALPHA32UI_EXT = $8D72;

GL_INTENSITY32UI_EXT = $8D73;

GL_LUMINANCE32UI_EXT = $8D74;

GL_LUMINANCE_ALPHA32UI_EXT = $8D75;

GL_RGBA16UI_EXT = $8D76;

GL_RGB16UI_EXT = $8D77;

GL_ALPHA16UI_EXT = $8D78;

GL_INTENSITY16UI_EXT = $8D79;

GL_LUMINANCE16UI_EXT = $8D7A;

GL_LUMINANCE_ALPHA16UI_EXT = $8D7B;

GL_RGBA8UI_EXT = $8D7C;

GL_RGB8UI_EXT = $8D7D;

GL_ALPHA8UI_EXT = $8D7E;

GL_INTENSITY8UI_EXT = $8D7F;

GL_LUMINANCE8UI_EXT = $8D80;

GL_LUMINANCE_ALPHA8UI_EXT = $8D81;

GL_RGBA32I_EXT = $8D82;

GL_RGB32I_EXT = $8D83;

GL_ALPHA32I_EXT = $8D84;

GL_INTENSITY32I_EXT = $8D85;

GL_LUMINANCE32I_EXT = $8D86;

GL_LUMINANCE_ALPHA32I_EXT = $8D87;

GL_RGBA16I_EXT = $8D88;

GL_RGB16I_EXT = $8D89;

GL_ALPHA16I_EXT = $8D8A;

GL_INTENSITY16I_EXT = $8D8B;

GL_LUMINANCE16I_EXT = $8D8C;

GL_LUMINANCE_ALPHA16I_EXT = $8D8D;

GL_RGBA8I_EXT = $8D8E;

GL_RGB8I_EXT = $8D8F;

GL_ALPHA8I_EXT = $8D90;

GL_INTENSITY8I_EXT = $8D91;

GL_LUMINANCE8I_EXT = $8D92;

GL_LUMINANCE_ALPHA8I_EXT = $8D93;

GL_RED_INTEGER_EXT = $8D94;

GL_GREEN_INTEGER_EXT = $8D95;

GL_BLUE_INTEGER_EXT = $8D96;

GL_ALPHA_INTEGER_EXT = $8D97;

GL_RGB_INTEGER_EXT = $8D98;

GL_RGBA_INTEGER_EXT = $8D99;

GL_BGR_INTEGER_EXT = $8D9A;

GL_BGRA_INTEGER_EXT = $8D9B;

GL_LUMINANCE_INTEGER_EXT = $8D9C;

GL_LUMINANCE_ALPHA_INTEGER_EXT = $8D9D;

GL_QUERY_WAIT_NV = $8E13;

GL_QUERY_NO_WAIT_NV = $8E14;

GL_QUERY_BY_REGION_WAIT_NV = $8E15;

GL_QUERY_BY_REGION_NO_WAIT_NV = $8E16;

GL_TRANSFORM_FEEDBACK_BUFFER_EXT = $8C8E;

GL_TRANSFORM_FEEDBACK_BUFFER_START_EXT = $8C84;

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_EXT = $8C85;

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_EXT = $8C8F;

GL_INTERLEAVED_ATTRIBS_EXT = $8C8C;

GL_SEPARATE_ATTRIBS_EXT = $8C8D;

GL_PRIMITIVES_GENERATED_EXT = $8C87;

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_EXT = $8C88;

GL_RASTERIZER_DISCARD_EXT = $8C89;

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_EXT = $8C8A;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_EXT = $8C8B;

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_EXT = $8C80;

GL_TRANSFORM_FEEDBACK_VARYINGS_EXT = $8C83;

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_EXT = $8C7F;

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH_EXT = $8C76;

GL_VBO_FREE_MEMORY_ATI = $87FB;

GL_TEXTURE_FREE_MEMORY_ATI = $87FC;

GL_RENDERBUFFER_FREE_MEMORY_ATI = $87FD;

GL_SAMPLER_BUFFER_AMD = $9001;

GL_INT_SAMPLER_BUFFER_AMD = $9002;

GL_UNSIGNED_INT_SAMPLER_BUFFER_AMD = $9003;

GL_DISCRETE_AMD = $9006;

GL_CONTINUOUS_AMD = $9007;

GL_TESSELLATION_MODE_AMD = $9004;

GL_TESSELLATION_FACTOR_AMD = $9005;

GL_BUFFER_GPU_ADDRESS_NV = $8F1D;

GL_GPU_ADDRESS_NV = $8F34;

GL_MAX_SHADER_BUFFER_ADDRESS_NV = $8F35;

GL_VERTEX_ATTRIB_ARRAY_UNIFIED_NV = $8F1E;

GL_ELEMENT_ARRAY_UNIFIED_NV = $8F1F;

GL_VERTEX_ATTRIB_ARRAY_ADDRESS_NV = $8F20;

GL_VERTEX_ARRAY_ADDRESS_NV = $8F21;

GL_NORMAL_ARRAY_ADDRESS_NV = $8F22;

GL_COLOR_ARRAY_ADDRESS_NV = $8F23;

GL_INDEX_ARRAY_ADDRESS_NV = $8F24;

GL_TEXTURE_COORD_ARRAY_ADDRESS_NV = $8F25;

GL_EDGE_FLAG_ARRAY_ADDRESS_NV = $8F26;

GL_SECONDARY_COLOR_ARRAY_ADDRESS_NV = $8F27;

GL_FOG_COORD_ARRAY_ADDRESS_NV = $8F28;

GL_ELEMENT_ARRAY_ADDRESS_NV = $8F29;

GL_VERTEX_ATTRIB_ARRAY_LENGTH_NV = $8F2A;

GL_VERTEX_ARRAY_LENGTH_NV = $8F2B;

GL_NORMAL_ARRAY_LENGTH_NV = $8F2C;

GL_COLOR_ARRAY_LENGTH_NV = $8F2D;

GL_INDEX_ARRAY_LENGTH_NV = $8F2E;

GL_TEXTURE_COORD_ARRAY_LENGTH_NV = $8F2F;

GL_EDGE_FLAG_ARRAY_LENGTH_NV = $8F30;

GL_SECONDARY_COLOR_ARRAY_LENGTH_NV = $8F31;

GL_FOG_COORD_ARRAY_LENGTH_NV = $8F32;

GL_ELEMENT_ARRAY_LENGTH_NV = $8F33;

GL_SURFACE_STATE_NV = $86EB;

GL_SURFACE_REGISTERED_NV = $86FD;

GL_SURFACE_MAPPED_NV = $8700;

GL_WRITE_DISCARD_NV = $88BE;

WGL_COLOR_SAMPLES_NV = $20B9;

GL_GPU_MEMORY_INFO_DEDICATED_VIDMEM_NVX = $9047;

GL_GPU_MEMORY_INFO_TOTAL_AVAILABLE_MEMORY_NVX = $9048;

GL_GPU_MEMORY_INFO_CURRENT_AVAILABLE_VIDMEM_NVX = $9049;

GL_GPU_MEMORY_INFO_EVICTION_COUNT_NVX = $904A;

GL_GPU_MEMORY_INFO_EVICTED_MEMORY_NVX = $904B;

GL_TEXTURE_SRGB_DECODE_EXT = $8A48;

GL_DECODE_EXT = $8A49;

GL_SKIP_DECODE_EXT = $8A4A;

GL_CLOSE_PATH_NV = $00;

GL_MOVE_TO_NV = $02;

GL_RELATIVE_MOVE_TO_NV = $03;

GL_LINE_TO_NV = $04;

GL_RELATIVE_LINE_TO_NV = $05;

GL_HORIZONTAL_LINE_TO_NV = $06;

GL_RELATIVE_HORIZONTAL_LINE_TO_NV = $07;

GL_VERTICAL_LINE_TO_NV = $08;

GL_RELATIVE_VERTICAL_LINE_TO_NV = $09;

GL_QUADRATIC_CURVE_TO_NV = $0A;

GL_RELATIVE_QUADRATIC_CURVE_TO_NV = $0B;

GL_CUBIC_CURVE_TO_NV = $0C;

GL_RELATIVE_CUBIC_CURVE_TO_NV = $0D;

GL_SMOOTH_QUADRATIC_CURVE_TO_NV = $0E;

GL_RELATIVE_SMOOTH_QUADRATIC_CURVE_TO_NV = $0F;

GL_SMOOTH_CUBIC_CURVE_TO_NV = $10;

GL_RELATIVE_SMOOTH_CUBIC_CURVE_TO_NV = $11;

GL_SMALL_CCW_ARC_TO_NV = $12;

GL_RELATIVE_SMALL_CCW_ARC_TO_NV = $13;

GL_SMALL_CW_ARC_TO_NV = $14;

GL_RELATIVE_SMALL_CW_ARC_TO_NV = $15;

GL_LARGE_CCW_ARC_TO_NV = $16;

GL_RELATIVE_LARGE_CCW_ARC_TO_NV = $17;

GL_LARGE_CW_ARC_TO_NV = $18;

GL_RELATIVE_LARGE_CW_ARC_TO_NV = $19;

GL_CIRCULAR_CCW_ARC_TO_NV = $F8;

GL_CIRCULAR_CW_ARC_TO_NV = $FA;

GL_CIRCULAR_TANGENT_ARC_TO_NV = $FC;

GL_ARC_TO_NV = $FE;

GL_RELATIVE_ARC_TO_NV = $FF;

GL_PATH_FORMAT_SVG_NV = $9070;

GL_PATH_FORMAT_PS_NV = $9071;

GL_STANDARD_FONT_NAME_NV = $9072;

GL_SYSTEM_FONT_NAME_NV = $9073;

GL_FILE_NAME_NV = $9074;

GL_PATH_STROKE_WIDTH_NV = $9075;

GL_PATH_END_CAPS_NV = $9076;

GL_PATH_INITIAL_END_CAP_NV = $9077;

GL_PATH_TERMINAL_END_CAP_NV = $9078;

GL_PATH_JOIN_STYLE_NV = $9079;

GL_PATH_MITER_LIMIT_NV = $907A;

GL_PATH_DASH_CAPS_NV = $907B;

GL_PATH_INITIAL_DASH_CAP_NV = $907C;

GL_PATH_TERMINAL_DASH_CAP_NV = $907D;

GL_PATH_DASH_OFFSET_NV = $907E;

GL_PATH_CLIENT_LENGTH_NV = $907F;

GL_PATH_FILL_MODE_NV = $9080;

GL_PATH_FILL_MASK_NV = $9081;

GL_PATH_FILL_COVER_MODE_NV = $9082;

GL_PATH_STROKE_COVER_MODE_NV = $9083;

GL_PATH_STROKE_MASK_NV = $9084;

GL_PATH_SAMPLE_QUALITY_NV = $9085;

GL_COUNT_UP_NV = $9088;

GL_COUNT_DOWN_NV = $9089;

GL_PATH_OBJECT_BOUNDING_BOX_NV = $908A;

GL_CONVEX_HULL_NV = $908B;

GL_BOUNDING_BOX_NV = $908D;

GL_TRANSLATE_X_NV = $908E;

GL_TRANSLATE_Y_NV = $908F;

GL_TRANSLATE_2D_NV = $9090;

GL_TRANSLATE_3D_NV = $9091;

GL_AFFINE_2D_NV = $9092;

GL_AFFINE_3D_NV = $9094;

GL_TRANSPOSE_AFFINE_2D_NV = $9096;

GL_TRANSPOSE_AFFINE_3D_NV = $9098;

GL_UTF8_NV = $909A;

GL_UTF16_NV = $909B;

GL_BOUNDING_BOX_OF_BOUNDING_BOXES_NV = $909C;

GL_PATH_COMMAND_COUNT_NV = $909D;

GL_PATH_COORD_COUNT_NV = $909E;

GL_PATH_DASH_ARRAY_COUNT_NV = $909F;

GL_PATH_COMPUTED_LENGTH_NV = $90A0;

GL_PATH_FILL_BOUNDING_BOX_NV = $90A1;

GL_PATH_STROKE_BOUNDING_BOX_NV = $90A2;

GL_SQUARE_NV = $90A3;

GL_ROUND_NV = $90A4;

GL_TRIANGULAR_NV = $90A5;

GL_BEVEL_NV = $90A6;

GL_MITER_REVERT_NV = $90A7;

GL_MITER_TRUNCATE_NV = $90A8;

GL_SKIP_MISSING_GLYPH_NV = $90A9;

GL_USE_MISSING_GLYPH_NV = $90AA;

GL_PATH_DASH_OFFSET_RESET_NV = $90B4;

GL_MOVE_TO_RESETS_NV = $90B5;

GL_MOVE_TO_CONTINUES_NV = $90B6;

GL_BOLD_BIT_NV = $01;

GL_ITALIC_BIT_NV = $02;

GL_PATH_ERROR_POSITION_NV = $90AB;

GL_PATH_FOG_GEN_MODE_NV = $90AC;

GL_GLYPH_WIDTH_BIT_NV = $01;

GL_GLYPH_HEIGHT_BIT_NV = $02;

GL_GLYPH_HORIZONTAL_BEARING_X_BIT_NV = $04;

GL_GLYPH_HORIZONTAL_BEARING_Y_BIT_NV = $08;

GL_GLYPH_HORIZONTAL_BEARING_ADVANCE_BIT_NV = $10;

GL_GLYPH_VERTICAL_BEARING_X_BIT_NV = $20;

GL_GLYPH_VERTICAL_BEARING_Y_BIT_NV = $40;

GL_GLYPH_VERTICAL_BEARING_ADVANCE_BIT_NV = $80;

GL_GLYPH_HAS_KERNING_NV = $100;

GL_FONT_X_MIN_BOUNDS_NV = $00010000;

GL_FONT_Y_MIN_BOUNDS_NV = $00020000;

GL_FONT_X_MAX_BOUNDS_NV = $00040000;

GL_FONT_Y_MAX_BOUNDS_NV = $00080000;

GL_FONT_UNITS_PER_EM_NV = $00100000;

GL_FONT_ASCENDER_NV = $00200000;

GL_FONT_DESCENDER_NV = $00400000;

GL_FONT_HEIGHT_NV = $00800000;

GL_FONT_MAX_ADVANCE_WIDTH_NV = $01000000;

GL_FONT_MAX_ADVANCE_HEIGHT_NV = $02000000;

GL_FONT_UNDERLINE_POSITION_NV = $04000000;

GL_FONT_UNDERLINE_THICKNESS_NV = $08000000;

GL_FONT_HAS_KERNING_NV = $10000000;

GL_ACCUM_ADJACENT_PAIRS_NV = $90AD;

GL_ADJACENT_PAIRS_NV = $90AE;

GL_FIRST_TO_REST_NV = $90AF;

GL_PATH_GEN_MODE_NV = $90B0;

GL_PATH_GEN_COEFF_NV = $90B1;

GL_PATH_GEN_COLOR_FORMAT_NV = $90B2;

GL_PATH_GEN_COMPONENTS_NV = $90B3;

GL_PATH_STENCIL_FUNC_NV = $90B7;

GL_PATH_STENCIL_REF_NV = $90B8;

GL_PATH_STENCIL_VALUE_MASK_NV = $90B9;

GL_PATH_STENCIL_DEPTH_OFFSET_FACTOR_NV = $90BD;

GL_PATH_STENCIL_DEPTH_OFFSET_UNITS_NV = $90BE;

GL_PATH_COVER_DEPTH_FUNC_NV = $90BF;

WGL_ACCESS_READ_ONLY_NV = $0000;

WGL_ACCESS_READ_WRITE_NV = $0001;

WGL_ACCESS_WRITE_DISCARD_NV = $0002;

GLX_EXTENSION_NAME = 'GLX';

GLX_USE_GL = 1;

GLX_BUFFER_SIZE = 2;

GLX_LEVEL = 3;

GLX_RGBA = 4;

GLX_DOUBLEBUFFER = 5;

GLX_STEREO = 6;

GLX_AUX_BUFFERS = 7;

GLX_RED_SIZE = 8;

GLX_GREEN_SIZE = 9;

GLX_BLUE_SIZE = 10;

GLX_ALPHA_SIZE = 11;

GLX_DEPTH_SIZE = 12;

GLX_STENCIL_SIZE = 13;

GLX_ACCUM_RED_SIZE = 14;

GLX_ACCUM_GREEN_SIZE = 15;

GLX_ACCUM_BLUE_SIZE = 16;

GLX_ACCUM_ALPHA_SIZE = 17;

GLX_BAD_SCREEN = 1;

GLX_BAD_ATTRIBUTE = 2;

GLX_NO_EXTENSION = 3;

GLX_BAD_VISUAL = 4;

GLX_BAD_CONTEXT = 5;

GLX_BAD_VALUE = 6;

GLX_BAD_ENUM = 7;

GLX_BAD_HYPERPIPE_CONFIG_SGIX = 91;

GLX_BAD_HYPERPIPE_SGIX = 92;

GLX_VENDOR = 1;

GLX_VERSION = 2;

GLX_EXTENSIONS = 3;

GLX_CONFIG_CAVEAT = $20;

GLX_NONE = $8000;

GLX_DONT_CARE = $FFFFFFFF;

GLX_SLOW_CONFIG = $8001;

GLX_NON_CONFORMANT_CONFIG = $800D;

GLX_X_VISUAL_TYPE = $22;

GLX_TRANSPARENT_TYPE = $23;

GLX_TRANSPARENT_INDEX_VALUE = $24;

GLX_TRANSPARENT_RED_VALUE = $25;

GLX_TRANSPARENT_GREEN_VALUE = $26;

GLX_TRANSPARENT_BLUE_VALUE = $27;

GLX_TRANSPARENT_ALPHA_VALUE = $28;

GLX_TRUE_COLOR = $8002;

GLX_DIRECT_COLOR = $8003;

GLX_PSEUDO_COLOR = $8004;

GLX_STATIC_COLOR = $8005;

GLX_GRAY_SCALE = $8006;

GLX_STATIC_GRAY = $8007;

GLX_TRANSPARENT_RGB = $8008;

GLX_TRANSPARENT_INDEX = $8009;

GLX_MAX_PBUFFER_WIDTH = $8016;

GLX_MAX_PBUFFER_HEIGHT = $8017;

GLX_MAX_PBUFFER_PIXELS = $8018;

GLX_PRESERVED_CONTENTS = $801B;

GLX_LARGEST_BUFFER = $801C;

GLX_WIDTH = $801D;

GLX_HEIGHT = $801E;

GLX_EVENT_MASK = $801F;

GLX_DRAWABLE_TYPE = $8010;

GLX_FBCONFIG_ID = $8013;

GLX_VISUAL_ID = $800B;

GLX_WINDOW_BIT = $00000001;

GLX_PIXMAP_BIT = $00000002;

GLX_PBUFFER_BIT = $00000004;

GLX_WINDOW_BIT_SGIX = $00000001;

GLX_PIXMAP_BIT_SGIX = $00000002;

GLX_PBUFFER_BIT_SGIX = $00000004;

GLX_AUX_BUFFERS_BIT = $00000010;

GLX_FRONT_LEFT_BUFFER_BIT = $00000001;

GLX_FRONT_RIGHT_BUFFER_BIT = $00000002;

GLX_BACK_LEFT_BUFFER_BIT = $00000004;

GLX_BACK_RIGHT_BUFFER_BIT = $00000008;

GLX_DEPTH_BUFFER_BIT = $00000020;

GLX_STENCIL_BUFFER_BIT = $00000040;

GLX_ACCUM_BUFFER_BIT = $00000080;

GLX_FRONT_LEFT_BUFFER_BIT_SGIX = $00000001;

GLX_FRONT_RIGHT_BUFFER_BIT_SGIX = $00000002;

GLX_BACK_LEFT_BUFFER_BIT_SGIX = $00000004;

GLX_BACK_RIGHT_BUFFER_BIT_SGIX = $00000008;

GLX_AUX_BUFFERS_BIT_SGIX = $00000010;

GLX_DEPTH_BUFFER_BIT_SGIX = $00000020;

GLX_STENCIL_BUFFER_BIT_SGIX = $00000040;

GLX_ACCUM_BUFFER_BIT_SGIX = $00000080;

GLX_SAMPLE_BUFFERS_BIT_SGIX = $00000100;

GLX_RENDER_TYPE = $8011;

GLX_X_RENDERABLE = $8012;

GLX_RGBA_TYPE = $8014;

GLX_RGBA_BIT = $00000001;

GLX_COLOR_INDEX_TYPE = $8015;

GLX_COLOR_INDEX_BIT = $00000002;

GLX_RGBA_BIT_SGIX = $00000001 ;

GLX_COLOR_INDEX_BIT_SGIX = $00000002 ;

GLX_SCREEN = $800C;

GLX_PBUFFER_CLOBBER_MASK = $08000000;

GLX_DAMAGED = $8020;

GLX_SAVED = $8021;

GLX_WINDOW = $8022;

GLX_PBUFFER = $8023;

GLX_PBUFFER_HEIGHT = $8040;

GLX_PBUFFER_WIDTH = $8041;

GLX_X_VISUAL_TYPE_EXT = $22;

GLX_TRANSPARENT_TYPE_EXT = $23;

GLX_TRANSPARENT_INDEX_VALUE_EXT = $24;

GLX_TRANSPARENT_RED_VALUE_EXT = $25;

GLX_TRANSPARENT_GREEN_VALUE_EXT = $26;

GLX_TRANSPARENT_BLUE_VALUE_EXT = $27;

GLX_TRANSPARENT_ALPHA_VALUE_EXT = $28;

GLX_TRUE_COLOR_EXT = $8002;

GLX_DIRECT_COLOR_EXT = $8003;

GLX_PSEUDO_COLOR_EXT = $8004;

GLX_STATIC_COLOR_EXT = $8005;

GLX_GRAY_SCALE_EXT = $8006;

GLX_STATIC_GRAY_EXT = $8007;

GLX_TRANSPARENT_RGB_EXT = $8008;

GLX_TRANSPARENT_INDEX_EXT = $8009;

GLX_VISUAL_CAVEAT_EXT = $20;

GLX_NONE_EXT = $8000;

GLX_SLOW_VISUAL_EXT = $8001;

GLX_NON_CONFORMANT_VISUAL_EXT = $800D;

GLX_SHARE_CONTEXT_EXT = $800A;

GLX_VISUAL_ID_EXT = $800B;

GLX_SCREEN_EXT = $800C;

GLX_3DFX_WINDOW_MODE_MESA = $1;

GLX_3DFX_FULLSCREEN_MODE_MESA = $2;

GLX_DRAWABLE_TYPE_SGIX = $8010;

GLX_RENDER_TYPE_SGIX = $8011;

GLX_X_RENDERABLE_SGIX = $8012;

GLX_FBCONFIG_ID_SGIX = 48013;

GLX_RGBA_TYPE_SGIX = $8014;

GLX_COLOR_INDEX_TYPE_SGIX = $8015;

GLX_MAX_PBUFFER_WIDTH_SGIX = $8016;

GLX_MAX_PBUFFER_HEIGHT_SGIX = $8017;

GLX_MAX_PBUFFER_PIXELS_SGIX = $8018;

GLX_OPTIMAL_PBUFFER_WIDTH_SGIX = $8019;

GLX_OPTIMAL_PBUFFER_HEIGHT_SGIX = $801A;

GLX_PRESERVED_CONTENTS_SGIX = $801B;

GLX_LARGEST_PBUFFER_SGIX = $801C;

GLX_WIDTH_SGIX = $801D;

GLX_HEIGHT_SGIX = $801E;

GLX_EVENT_MASK_SGIX = $801F;

GLX_DAMAGED_SGIX = $8020;

GLX_SAVED_SGIX = $8021;

GLX_WINDOW_SGIX = $8022;

GLX_PBUFFER_SGIX = $8023;

GLX_DIGITAL_MEDIA_PBUFFER_SGIX = $8024;

GLX_BLENDED_RGBA_SGIS = $8025;

GLX_MULTISAMPLE_SUB_RECT_WIDTH_SGIS = $8026;

GLX_MULTISAMPLE_SUB_RECT_HEIGHT_SGIS = $8027;

GLX_VISUAL_SELECT_GROUP_SGIX = $8028;

GLX_HYPERPIPE_ID_SGIX = $8030;

GLX_SYNC_FRAME_SGIX = $00000000 ;

GLX_SYNC_SWAP_SGIX = $00000001;

GLX_BUFFER_CLOBBER_MASK_SGIX = $08000000;

GLX_BUFFER_SWAP_COMPLETE_INTEL_MASK = $04000000;

GLX_HYPERPIPE_DISPLAY_PIPE_SGIX = $00000001;

GLX_HYPERPIPE_RENDER_PIPE_SGIX = $00000002;

GLX_PIPE_RECT_SGIX = $00000001;

GLX_PIPE_RECT_LIMITS_SGIX = $00000002;

GLX_HYPERPIPE_STEREO_SGIX = $00000003;

GLX_HYPERPIPE_PIXEL_AVERAGE_SGIX = $00000004;

GLX_HYPERPIPE_PIPE_NAME_LENGTH_SGIX = $80 ;

GLX_TEXTURE_1D_BIT_EXT = $00000001;

GLX_TEXTURE_2D_BIT_EXT = $00000002;

GLX_TEXTURE_RECTANGLE_BIT_EXT = $00000004;

GLX_SWAP_METHOD_OML = $8060;

GLX_SWAP_EXCHANGE_OML = $8061;

GLX_SWAP_COPY_OML = $8062;

GLX_SWAP_UNDEFINED_OML = $8063;

GLX_EXCHANGE_COMPLETE_INTEL = $8180;

GLX_COPY_COMPLETE_INTEL = $8181;

GLX_FLIP_COMPLETE_INTEL = $8182;

GLX_COLOR_SAMPLES_NV = $20B3;

AGL_NONE = 0;

AGL_ALL_RENDERERS = 1;

AGL_BUFFER_SIZE = 2;

AGL_LEVEL = 3;

AGL_RGBA = 4;

AGL_DOUBLEBUFFER = 5;

AGL_STEREO = 6;

AGL_AUX_BUFFERS = 7;

AGL_RED_SIZE = 8;

AGL_GREEN_SIZE = 9;

AGL_BLUE_SIZE = 10;

AGL_ALPHA_SIZE = 11;

AGL_DEPTH_SIZE = 12;

AGL_STENCIL_SIZE = 13;

AGL_ACCUM_RED_SIZE = 14;

AGL_ACCUM_GREEN_SIZE = 15;

AGL_ACCUM_BLUE_SIZE = 16;

AGL_ACCUM_ALPHA_SIZE = 17;

AGL_PIXEL_SIZE = 50;

AGL_MINIMUM_POLICY = 51;

AGL_MAXIMUM_POLICY = 52;

AGL_OFFSCREEN = 53;

AGL_FULLSCREEN = 54;

AGL_SAMPLE_BUFFERS_ARB = 55;

AGL_SAMPLES_ARB = 56;

AGL_AUX_DEPTH_STENCIL = 57;

AGL_COLOR_FLOAT = 58;

AGL_MULTISAMPLE = 59;

AGL_SUPERSAMPLE = 60;

AGL_SAMPLE_ALPHA = 61;

AGL_RENDERER_ID = 70;

AGL_SINGLE_RENDERER = 71;

AGL_NO_RECOVERY = 72;

AGL_ACCELERATED = 73;

AGL_CLOSEST_POLICY = 74;

AGL_ROBUST = 75;

AGL_BACKING_STORE = 76;

AGL_MP_SAFE = 78;

AGL_WINDOW = 80;

AGL_MULTISCREEN = 81;

AGL_VIRTUAL_SCREEN = 82;

AGL_COMPLIANT = 83;

AGL_PBUFFER = 90;

AGL_REMOTE_PBUFFER = 91;

AGL_BUFFER_MODES = 100;

AGL_MIN_LEVEL = 101;

AGL_MAX_LEVEL = 102;

AGL_COLOR_MODES = 103;

AGL_ACCUM_MODES = 104;

AGL_DEPTH_MODES = 105;

AGL_STENCIL_MODES = 106;

AGL_MAX_AUX_BUFFERS = 107;

AGL_VIDEO_MEMORY = 120;

AGL_TEXTURE_MEMORY = 121;

AGL_RENDERER_COUNT = 128;

AGL_SWAP_RECT = 200;

AGL_BUFFER_RECT = 202;

AGL_SWAP_LIMIT = 203;

AGL_COLORMAP_TRACKING = 210;

AGL_COLORMAP_ENTRY = 212;

AGL_RASTERIZATION = 220;

AGL_SWAP_INTERVAL = 222;

AGL_STATE_VALIDATION = 230;

AGL_BUFFER_NAME = 231;

AGL_ORDER_CONTEXT_TO_FRONT = 232;

AGL_CONTEXT_SURFACE_ID = 233;

AGL_CONTEXT_DISPLAY_ID = 234;

AGL_SURFACE_ORDER = 235;

AGL_SURFACE_OPACITY = 236;

AGL_CLIP_REGION = 254;

AGL_FS_CAPTURE_SINGLE = 255;

AGL_SURFACE_BACKING_SIZE = 304;

AGL_ENABLE_SURFACE_BACKING_SIZE = 305;

AGL_SURFACE_VOLATILE = 306;

AGL_FORMAT_CACHE_SIZE = 501;

AGL_CLEAR_FORMAT_CACHE = 502;

AGL_RETAIN_RENDERERS = 503;

AGL_MONOSCOPIC_BIT = $00000001;

AGL_STEREOSCOPIC_BIT = $00000002;

AGL_SINGLEBUFFER_BIT = $00000004;

AGL_DOUBLEBUFFER_BIT = $00000008;

AGL_0_BIT = $00000001;

AGL_1_BIT = $00000002;

AGL_2_BIT = $00000004;

AGL_3_BIT = $00000008;

AGL_4_BIT = $00000010;

AGL_5_BIT = $00000020;

AGL_6_BIT = $00000040;

AGL_8_BIT = $00000080;

AGL_10_BIT = $00000100;

AGL_12_BIT = $00000200;

AGL_16_BIT = $00000400;

AGL_24_BIT = $00000800;

AGL_32_BIT = $00001000;

AGL_48_BIT = $00002000;

AGL_64_BIT = $00004000;

AGL_96_BIT = $00008000;

AGL_128_BIT = $00010000;

AGL_RGB8_BIT = $00000001;

AGL_RGB8_A8_BIT = $00000002;

AGL_BGR233_BIT = $00000004;

AGL_BGR233_A8_BIT = $00000008;

AGL_RGB332_BIT = $00000010;

AGL_RGB332_A8_BIT = $00000020;

AGL_RGB444_BIT = $00000040;

AGL_ARGB4444_BIT = $00000080;

AGL_RGB444_A8_BIT = $00000100;

AGL_RGB555_BIT = $00000200;

AGL_ARGB1555_BIT = $00000400;

AGL_RGB555_A8_BIT = $00000800;

AGL_RGB565_BIT = $00001000;

AGL_RGB565_A8_BIT = $00002000;

AGL_RGB888_BIT = $00004000;

AGL_ARGB8888_BIT = $00008000;

AGL_RGB888_A8_BIT = $00010000;

AGL_RGB101010_BIT = $00020000;

AGL_ARGB2101010_BIT = $00040000;

AGL_RGB101010_A8_BIT = $00080000;

AGL_RGB121212_BIT = $00100000;

AGL_ARGB12121212_BIT = $00200000;

AGL_RGB161616_BIT = $00400000;

AGL_ARGB16161616_BIT = $00800000;

AGL_INDEX8_BIT = $20000000;

AGL_INDEX16_BIT = $40000000;

AGL_RGBFLOAT64_BIT = $01000000;

AGL_RGBAFLOAT64_BIT = $02000000;

AGL_RGBFLOAT128_BIT = $04000000;

AGL_RGBAFLOAT128_BIT = $08000000;

AGL_RGBFLOAT256_BIT = $10000000;

AGL_RGBAFLOAT256_BIT = $20000000;

AGL_NO_ERROR = 0;

AGL_BAD_ATTRIBUTE = 10000;

AGL_BAD_PROPERTY = 10001;

AGL_BAD_PIXELFMT = 10002;

AGL_BAD_RENDINFO = 10003;

AGL_BAD_CONTEXT = 10004;

AGL_BAD_DRAWABLE = 10005;

AGL_BAD_GDEV = 10006;

AGL_BAD_STATE = 10007;

AGL_BAD_VALUE = 10008;

AGL_BAD_MATCH = 10009;

AGL_BAD_ENUM = 10010;

AGL_BAD_OFFSCREEN = 10011;

AGL_BAD_FULLSCREEN = 10012;

AGL_BAD_WINDOW = 10013;

AGL_BAD_POINTER = 10014;

AGL_BAD_MODULE = 10015;

AGL_BAD_ALLOC = 10016;

AGL_BAD_CONNECTION = 10017;

GLU_INVALID_ENUM = 100900;

GLU_INVALID_VALUE = 100901;

GLU_OUT_OF_MEMORY = 100902;

GLU_INCOMPATIBLE_GL_VERSION = 100903;

GLU_VERSION = 100800;

GLU_EXTENSIONS = 100801;

GLU_TRUE = GL_TRUE;

GLU_FALSE = GL_FALSE;

GLU_SMOOTH = 100000;

GLU_FLAT = 100001;

GLU_NONE = 100002;

GLU_POINT = 100010;

GLU_LINE = 100011;

GLU_FILL = 100012;

GLU_SILHOUETTE = 100013;

GLU_OUTSIDE = 100020;

GLU_INSIDE = 100021;

GLU_TESS_MAX_COORD = 1.0e150;

GLU_TESS_WINDING_RULE = 100140;

GLU_TESS_BOUNDARY_ONLY = 100141;

GLU_TESS_TOLERANCE = 100142;

GLU_TESS_WINDING_ODD = 100130;

GLU_TESS_WINDING_NONZERO = 100131;

GLU_TESS_WINDING_POSITIVE = 100132;

GLU_TESS_WINDING_NEGATIVE = 100133;

GLU_TESS_WINDING_ABS_GEQ_TWO = 100134;

GLU_TESS_BEGIN = 100100;

GLU_TESS_VERTEX = 100101;

GLU_TESS_END = 100102;

GLU_TESS_ERROR = 100103;

GLU_TESS_EDGE_FLAG = 100104;

GLU_TESS_COMBINE = 100105;

GLU_TESS_BEGIN_DATA = 100106;

GLU_TESS_VERTEX_DATA = 100107;

GLU_TESS_END_DATA = 100108;

GLU_TESS_ERROR_DATA = 100109;

GLU_TESS_EDGE_FLAG_DATA = 100110;

GLU_TESS_COMBINE_DATA = 100111;

GLU_TESS_ERROR1 = 100151;

GLU_TESS_ERROR2 = 100152;

GLU_TESS_ERROR3 = 100153;

GLU_TESS_ERROR4 = 100154;

GLU_TESS_ERROR5 = 100155;

GLU_TESS_ERROR6 = 100156;

GLU_TESS_ERROR7 = 100157;

GLU_TESS_ERROR8 = 100158;

GLU_TESS_MISSING_BEGIN_POLYGON = GLU_TESS_ERROR1;

GLU_TESS_MISSING_BEGIN_CONTOUR = GLU_TESS_ERROR2;

GLU_TESS_MISSING_END_POLYGON = GLU_TESS_ERROR3;

GLU_TESS_MISSING_END_CONTOUR = GLU_TESS_ERROR4;

GLU_TESS_COORD_TOO_LARGE = GLU_TESS_ERROR5;

GLU_TESS_NEED_COMBINE_CALLBACK = GLU_TESS_ERROR6;

GLU_AUTO_LOAD_MATRIX = 100200;

GLU_CULLING = 100201;

GLU_SAMPLING_TOLERANCE = 100203;

GLU_DISPLAY_MODE = 100204;

GLU_PARAMETRIC_TOLERANCE = 100202;

GLU_SAMPLING_METHOD = 100205;

GLU_U_STEP = 100206;

GLU_V_STEP = 100207;

GLU_PATH_LENGTH = 100215;

GLU_PARAMETRIC_ERROR = 100216;

GLU_DOMAIN_DISTANCE = 100217;

GLU_MAP1_TRIM_2 = 100210;

GLU_MAP1_TRIM_3 = 100211;

GLU_OUTLINE_POLYGON = 100240;

GLU_OUTLINE_PATCH = 100241;

GLU_NURBS_ERROR1 = 100251;

GLU_NURBS_ERROR2 = 100252;

GLU_NURBS_ERROR3 = 100253;

GLU_NURBS_ERROR4 = 100254;

GLU_NURBS_ERROR5 = 100255;

GLU_NURBS_ERROR6 = 100256;

GLU_NURBS_ERROR7 = 100257;

GLU_NURBS_ERROR8 = 100258;

GLU_NURBS_ERROR9 = 100259;

GLU_NURBS_ERROR10 = 100260;

GLU_NURBS_ERROR11 = 100261;

GLU_NURBS_ERROR12 = 100262;

GLU_NURBS_ERROR13 = 100263;

GLU_NURBS_ERROR14 = 100264;

GLU_NURBS_ERROR15 = 100265;

GLU_NURBS_ERROR16 = 100266;

GLU_NURBS_ERROR17 = 100267;

GLU_NURBS_ERROR18 = 100268;

GLU_NURBS_ERROR19 = 100269;

GLU_NURBS_ERROR20 = 100270;

GLU_NURBS_ERROR21 = 100271;

GLU_NURBS_ERROR22 = 100272;

GLU_NURBS_ERROR23 = 100273;

GLU_NURBS_ERROR24 = 100274;

GLU_NURBS_ERROR25 = 100275;

GLU_NURBS_ERROR26 = 100276;

GLU_NURBS_ERROR27 = 100277;

GLU_NURBS_ERROR28 = 100278;

GLU_NURBS_ERROR29 = 100279;

GLU_NURBS_ERROR30 = 100280;

GLU_NURBS_ERROR31 = 100281;

GLU_NURBS_ERROR32 = 100282;

GLU_NURBS_ERROR33 = 100283;

GLU_NURBS_ERROR34 = 100284;

GLU_NURBS_ERROR35 = 100285;

GLU_NURBS_ERROR36 = 100286;

GLU_NURBS_ERROR37 = 100287;

GLU_CW = 100120;

GLU_CCW = 100121;

GLU_INTERIOR = 100122;

GLU_EXTERIOR = 100123;

GLU_UNKNOWN = 100124;

GLU_BEGIN = GLU_TESS_BEGIN;

GLU_VERTEX = GLU_TESS_VERTEX;

GLU_END = GLU_TESS_END;

GLU_ERROR = GLU_TESS_ERROR;

GLU_EDGE_FLAG = GLU_TESS_EDGE_FLAG;

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:37


GLScene v.1.1.2: OpenGLTokens: packed record _WGLSWAP

packed record _WGLSWAP

Unit

OpenGLTokens

Declaration

type _WGLSWAP = packed record

Description

Overview

Fields

hdc: HDC;
uiFlags: UINT;

Description

Fields

hdc: HDC;
uiFlags: UINT;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:37


GLScene v.1.1.2: OpenGLTokens: record TGPUDevice

record TGPUDevice

Unit

OpenGLTokens

Declaration

type TGPUDevice = record

Description

Overview

Fields

cb: Cardinal;
DeviceName: array[0..31] of AnsiChar;
DeviceString: array[0..127] of AnsiChar;
Flags: Cardinal;
rcVirtualScreen: TRect;

Description

Fields

cb: Cardinal;
DeviceName: array[0..31] of AnsiChar;
DeviceString: array[0..127] of AnsiChar;
Flags: Cardinal;
rcVirtualScreen: TRect;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:37


GLScene v.1.1.2: OpenGLTokens: record TGLUNurbs

record TGLUNurbs

Unit

OpenGLTokens

Declaration

type TGLUNurbs = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:37


GLScene v.1.1.2: OpenGLTokens: record TGLUQuadric

record TGLUQuadric

Unit

OpenGLTokens

Declaration

type TGLUQuadric = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:37


GLScene v.1.1.2: OpenGLTokens: record TGLUTesselator

record TGLUTesselator

Unit

OpenGLTokens

Declaration

type TGLUTesselator = record

Description

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:37


GLScene v.1.1.2: PerlinNoise

Unit PerlinNoise

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

PerlinNoise.<p>

Classes and function for generation of PerlinNoise.<p>

<b>History : </b><font size=-1><ul> <li>31/08/10 - Bugfixed range error in TPerlin3DNoise.Initialize <li>30/03/07 - DaStr - Added $I GLScene.inc <li>14/04/04 - EG - Creation </ul></font>

Loosely based on Tom Nuydens's (www.delphi3d.com) Noise.pas unit, itself based on http://students.vassar.edu/mazucker/code/perlin-noise-math-faq.html Darwin Peachey's chapter in "Texturing & Modeling: A Procedural Approach" Further bugs are mine :)

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TPerlin3DNoise |

Constants

cPERLIN_TABLE_SIZE = 256;

Description

Constants

cPERLIN_TABLE_SIZE = 256;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:37


GLScene v.1.1.2: PerlinNoise: Class TPerlin3DNoise

Class TPerlin3DNoise

Unit

PerlinNoise

Declaration

type TPerlin3DNoise = class(TObject)

Description

Generates Perlin Noise in the [-1; 1] range.<p> 2D noise requests are taken in the Z=0 slice

Hierarchy

  • TObject
  • TPerlin3DNoise

Overview

Fields

Protected | FPermutations: packed [0..cPERLIN_TABLE_SIZE-1] of Integer;
Protected | FGradients: packed [0..cPERLIN_TABLE_SIZE*3-1] of Single;

Methods

Public | constructor Create(randomSeed : Integer);
Public | function Noise(const x, y : Single) : Single; overload;
Public | function Noise(const v : TAffineVector) : Single; overload;
Public | function Noise(const x, y, z : Single) : Single; overload;
Public | function Noise(const v : TVector) : Single; overload;
Protected | function Lattice(ix, iy, iz : Integer; fx, fy, fz : Single) : Single; overload;
Protected | function Lattice(ix, iy : Integer; fx, fy : Single) : Single; overload;
Public | procedure Initialize(randomSeed : Integer);

Description

Fields

Protected FPermutations: packed [0..cPERLIN_TABLE_SIZE-1] of Integer;
Protected FGradients: packed [0..cPERLIN_TABLE_SIZE*3-1] of Single;

Methods

Public constructor Create(randomSeed : Integer);
Public function Noise(const x, y : Single) : Single; overload;
Public function Noise(const v : TAffineVector) : Single; overload;
Public function Noise(const x, y, z : Single) : Single; overload;
Public function Noise(const v : TVector) : Single; overload;
Protected function Lattice(ix, iy, iz : Integer; fx, fy, fz : Single) : Single; overload;
Protected function Lattice(ix, iy : Integer; fx, fy : Single) : Single; overload;
Public procedure Initialize(randomSeed : Integer);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:37


GLScene v.1.1.2: PersistentClasses

Unit PersistentClasses

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

PersistentClasses<p>

Base persistence classes.<p>

These classes are used in GLScene, but are designed for generic purpose.<br> They implement a slightly different persistence mechanism than that of the VCL, allowing for object-level versioning (100% backward compatibility) and full polymorphic persistence.<p>

Internal Note: stripped down versions of XClasses & XLists.<p>

<b>History : </b><font size=-1><ul> <li>10/05/12 - Yar - Patched TBinaryReader.ReadFloat/WriteFloat for Win64 (thanks Massimo Zanoletti) In future need to replase extended floating point type! <li>06/12/10 - DaStr - Added GUID to IPersistentObject <li>19/08/10 - Yar - Fixed WriteWideString for empty strings <li>20/05/10 - Yar - Fixes for Linux x64 <li>07/11/09 - DaStr - Improved FPC compatibility (BugtrackerID = 2893580) <li>16/10/08 - UweR - Delphi 2009 compatibility fix for TPersistentObject, TTextReader and TTextWriter <li>16/10/08 - DanB - Delphi 2009 compatibility fix for TBinaryReader.ReadString / WriteString <li>10/04/08 - DaStr - Added classes TGLInterfacedPersistent and TGLInterfacedCollectionItem (BugTracker ID = 1938988) <li>11/02/08 - DaStr - Bugfixed TPersistentObjectList.Move() once again (BugTracker ID = 1857974) (thanks Yann PAPOUIN and Burkhard Carstens) <li>04/02/08 - DaStr - Bugfixed TPersistentObjectList.Move() (BugTracker ID = 1857974) <li>06/03/07 - DaStr - Added TGLOwnedPersistent <li>04/01/04 - EG - Fixed ReadString & ReadWideString for empty strings (thx Kenguru) <li>28/06/04 - LR - Removed ..\ from the GLScene.inc <li>08/12/03 - EG - TBinaryReader/Writer no longer rely on VCL TReader/TWriter <li>26/12/03 - EG - Added sorting support to TPersistentObjectList + misc. changes <li>04/09/03 - EG - Improved some TPersistentObjectList methods <li>12/02/03 - EG - Added IPersistentObject <li>09/09/01 - EG - Optimized Pack (x2.5) <li>14/08/01 - EG - Added AfterObjectCreatedByReader <li>03/08/01 - EG - Big update with addition of Virtual filers <li>24/07/01 - EG - D6-related changes <li>15/03/01 - EG - Creation </ul></font><p>

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TExtended80Rec |
Class TVirtualReader |
Class TVirtualWriter |
Interface IPersistentObject |
Class TPersistentObject |
Class TPersistentObjectList |
Class TBinaryReader |
Class TBinaryWriter |
Class TTextReader |
Class TTextWriter |
Class TGLOwnedPersistent |
Class TGLInterfacedPersistent |
Class TGLInterfacedCollectionItem |
Class EInvalidFileSignature |
Class EFilerException |

Functions and Procedures

procedure RaiseFilerException(aClass: TClass; archiveVersion: Integer);
function UTF8ToWideString(const s: AnsiString): WideString;

Types

PObject = ˆTObject;
TVirtualReaderClass = class of TVirtualReader;
TVirtualWriterClass = class of TVirtualWriter;
TPersistentObjectClass = class of TPersistentObject;
TPointerObjectList = array[0..MaxInt div (2*SizeOf(Pointer))] of TObject;
PPointerObjectList = ˆTPointerObjectList;
TObjectListSortCompare = function(item1, item2: TObject): Integer;

Description

Functions and Procedures

procedure RaiseFilerException(aClass: TClass; archiveVersion: Integer);
function UTF8ToWideString(const s: AnsiString): WideString;

Types

PObject = ˆTObject;
TVirtualReaderClass = class of TVirtualReader;
TVirtualWriterClass = class of TVirtualWriter;
TPersistentObjectClass = class of TPersistentObject;
TPointerObjectList = array[0..MaxInt div (2*SizeOf(Pointer))] of TObject;
PPointerObjectList = ˆTPointerObjectList;
TObjectListSortCompare = function(item1, item2: TObject): Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:37


GLScene v.1.1.2: PersistentClasses: packed record TExtended80Rec

packed record TExtended80Rec

Unit

PersistentClasses

Declaration

type TExtended80Rec = packed record

Description

Overview

Fields

Bytes: array[0..9] of Byte
Float: Extended

Description

Fields

Bytes: array[0..9] of Byte
Float: Extended
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PersistentClasses: Class TVirtualReader

Class TVirtualReader

Unit

PersistentClasses

Declaration

type TVirtualReader = class(TObject)

Description

Virtual layer similar to VCL's TReader (but reusable)

Hierarchy

  • TObject
  • TVirtualReader

Overview

Methods

Public | constructor Create(Stream: TStream); virtual;
Public | function EndOfList: Boolean; virtual; abstract;
Public | function NextValue: TValueType; virtual; abstract;
Public | function ReadBoolean: Boolean; virtual; abstract;
Public | function ReadFloat: Extended; virtual; abstract;
Public | function ReadInteger: Integer; virtual; abstract;
Public | function ReadString: string; virtual; abstract;
Public | procedure Read(var Buf; Count: Longint); virtual; abstract;
Public | procedure ReadListBegin; virtual; abstract;
Public | procedure ReadListEnd; virtual; abstract;
Public | procedure ReadTStrings(aStrings: TStrings);
Public | procedure ReadTypeError;

Properties

Public property Stream: TStream read FStream;

Description

Methods

Public constructor Create(Stream: TStream); virtual;
Public function EndOfList: Boolean; virtual; abstract;
Public function NextValue: TValueType; virtual; abstract;
Public function ReadBoolean: Boolean; virtual; abstract;
Public function ReadFloat: Extended; virtual; abstract;
Public function ReadInteger: Integer; virtual; abstract;
Public function ReadString: string; virtual; abstract;
Public procedure Read(var Buf; Count: Longint); virtual; abstract;
Public procedure ReadListBegin; virtual; abstract;
Public procedure ReadListEnd; virtual; abstract;
Public procedure ReadTStrings(aStrings: TStrings);
Public procedure ReadTypeError;

Properties

Public property Stream: TStream read FStream;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PersistentClasses: Class TVirtualWriter

Class TVirtualWriter

Unit

PersistentClasses

Declaration

type TVirtualWriter = class(TObject)

Description

Virtual layer similar to VCL's TWriter (but reusable)

Hierarchy

  • TObject
  • TVirtualWriter

Overview

Methods

Public | constructor Create(Stream: TStream); virtual;
Public | procedure Write(const Buf; Count: Longint); virtual; abstract;
Public | procedure WriteBoolean(aBoolean: Boolean); virtual; abstract;
Public | procedure WriteFloat(const aFloat: Extended); virtual; abstract;
Public | procedure WriteInteger(anInteger: Integer); virtual; abstract;
Public | procedure WriteListBegin; virtual; abstract;
Public | procedure WriteListEnd; virtual; abstract;
Public | procedure WriteString(const aString: string); virtual; abstract;
Public | procedure WriteTStrings(const aStrings: TStrings; storeObjects: Boolean = True);

Properties

Public property Stream: TStream read FStream;

Description

Methods

Public constructor Create(Stream: TStream); virtual;
Public procedure Write(const Buf; Count: Longint); virtual; abstract;
Public procedure WriteBoolean(aBoolean: Boolean); virtual; abstract;
Public procedure WriteFloat(const aFloat: Extended); virtual; abstract;
Public procedure WriteInteger(anInteger: Integer); virtual; abstract;
Public procedure WriteListBegin; virtual; abstract;
Public procedure WriteListEnd; virtual; abstract;
Public procedure WriteString(const aString: string); virtual; abstract;
Public procedure WriteTStrings(const aStrings: TStrings; storeObjects: Boolean = True);

Properties

Public property Stream: TStream read FStream;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PersistentClasses: Interface IPersistentObject

Interface IPersistentObject

Unit

PersistentClasses

Declaration

type IPersistentObject = interface(IInterface)

Description

Interface for persistent objects.<p> This interface does not really allow polymorphic persistence, but is rather intended as a way to unify persistence calls for iterators.

Hierarchy

  • IInterface
  • IPersistentObject

Overview

Methods

Public | procedure ReadFromFiler(reader: TVirtualReader);
Public | procedure WriteToFiler(writer: TVirtualWriter);

Description

Methods

Public procedure ReadFromFiler(reader: TVirtualReader);
Public procedure WriteToFiler(writer: TVirtualWriter);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PersistentClasses: Class TPersistentObject

Class TPersistentObject

Unit

PersistentClasses

Declaration

type TPersistentObject = class(TPersistent, IPersistentObject)

Description

Base class for persistent objects.<p> The base requirement is implementation of ReadFromFiler & WriteToFiler in sub-classes, the immediate benefits are support of streaming (to stream, file or string), assignment and cloning.<br> The other requirement being the use of a virtual constructor, which allows polymorphic construction (don't forget to register your subclasses).<p> Note that TPersistentObject implements IUnknown, but does *not* implement reference counting.

Hierarchy

  • TPersistent
  • TPersistentObject

Overview

Methods

Public | constructor Create; virtual;
Public | constructor CreateFromFiler(reader: TVirtualReader);
Public | destructor Destroy; override;
Public | function CreateClone: TPersistentObject; dynamic;
Public | class function FileSignature: string; virtual;
Public | class function FileVirtualReader: TVirtualReaderClass; virtual;
Public | class function FileVirtualWriter: TVirtualWriterClass; virtual;
Public | function SaveToString(writerClass: TVirtualWriterClass = nil): string; dynamic;
Protected | function QueryInterface(const IID: TGUID; out Obj): HResult; stdcall;
Protected | function _AddRef: Integer; stdcall;
Protected | function _Release: Integer; stdcall;
Public | procedure Assign(source: TPersistent); override;
Public | procedure LoadFromFile(const fileName: string; readerClass: TVirtualReaderClass = nil); dynamic;
Public | procedure LoadFromStream(stream: TStream; readerClass: TVirtualReaderClass = nil); dynamic;
Public | procedure LoadFromString(const data: string; readerClass: TVirtualReaderClass = nil); dynamic;
Public | procedure ReadFromFiler(reader: TVirtualReader); dynamic;
Public | procedure SaveToFile(const fileName: string; writerClass: TVirtualWriterClass = nil); dynamic;
Public | procedure SaveToStream(stream: TStream; writerClass: TVirtualWriterClass = nil); dynamic;
Public | procedure WriteToFiler(writer: TVirtualWriter); dynamic;
Protected | procedure RaiseFilerException(const archiveVersion: Integer);

Description

Methods

Public constructor Create; virtual;
Public constructor CreateFromFiler(reader: TVirtualReader);
Public destructor Destroy; override;
Public function CreateClone: TPersistentObject; dynamic;
Public class function FileSignature: string; virtual;
Public class function FileVirtualReader: TVirtualReaderClass; virtual;
Public class function FileVirtualWriter: TVirtualWriterClass; virtual;
Public function SaveToString(writerClass: TVirtualWriterClass = nil): string; dynamic;
Protected function QueryInterface(const IID: TGUID; out Obj): HResult; stdcall;
Protected function _AddRef: Integer; stdcall;
Protected function _Release: Integer; stdcall;
Public procedure Assign(source: TPersistent); override;
Public procedure LoadFromFile(const fileName: string; readerClass: TVirtualReaderClass = nil); dynamic;
Public procedure LoadFromStream(stream: TStream; readerClass: TVirtualReaderClass = nil); dynamic;
Public procedure LoadFromString(const data: string; readerClass: TVirtualReaderClass = nil); dynamic;
Public procedure ReadFromFiler(reader: TVirtualReader); dynamic;
Public procedure SaveToFile(const fileName: string; writerClass: TVirtualWriterClass = nil); dynamic;
Public procedure SaveToStream(stream: TStream; writerClass: TVirtualWriterClass = nil); dynamic;
Public procedure WriteToFiler(writer: TVirtualWriter); dynamic;
Protected procedure RaiseFilerException(const archiveVersion: Integer);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PersistentClasses: Class TPersistentObjectList

Class TPersistentObjectList

Unit

PersistentClasses

Declaration

type TPersistentObjectList = class(TPersistentObject)

Description

A persistent Object list.<p> Similar to TList but works on TObject items and has facilities for persistence of contained data. Unlike the VCL's TObjectList, this one does NOT free its objects upon destruction or Clear, use Clean and CleanFree for that, and as such can be used for object referral lists too.<br> But only TPersistentObject items will be streamed appropriately.<p> The list can be used in a stack-like fashion with Push & Pop, and can perform basic boolean set operations.<p> Note: the IndexOf implementation is up to 3 times faster than that of TList

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function Add(const item: TObject): Integer;
Public | function AddObjects(const objectList: TPersistentObjectList): Integer;
Public | function Expand: TPersistentObjectList;
Public | function IndexOf(Item: TObject): Integer;
Public | function Pop: TObject;
Public | function Remove(Item: TObject): Integer;
Public | function RemoveAndFree(item: TObject): Integer;
Protected | function Get(Index: Integer): TObject;
Protected | function GetFirst: TObject;
Protected | function GetLast: TObject;
Public | procedure AddNils(nbVals: Cardinal);
Public | procedure Clean; dynamic;
Public | procedure CleanFree;
Public | procedure Clear; dynamic;
Public | procedure Delete(index: Integer);
Public | procedure DeleteAndFree(index: Integer);
Public | procedure DeleteAndFreeItems(index: Integer; nbVals: Cardinal);
Public | procedure DeleteItems(index: Integer; nbVals: Cardinal);
Public | procedure Exchange(Index1, Index2: Integer);
Public | procedure Insert(Index: Integer; Item: TObject);
Public | procedure InsertNils(index: Integer; nbVals: Cardinal);
Public | procedure Move(CurIndex, NewIndex: Integer);
Public | procedure Pack;
Public | procedure PopAndFree;
Public | procedure Push(item: TObject);
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure ReadFromFilerWithEvent(reader: TVirtualReader; afterSenderObjectCreated: TNotifyEvent);
Public | procedure RemoveObjects(const objectList: TPersistentObjectList);
Public | procedure RequiredCapacity(aCapacity: Integer);
Public | procedure Sort(compareFunc: TObjectListSortCompare);
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure AfterObjectCreatedByReader(Sender: TObject); virtual;
Protected | procedure DoClean;
Protected | procedure Error; virtual;
Protected | procedure Put(Index: Integer; Item: TObject);
Protected | procedure SetCapacity(newCapacity: Integer);
Protected | procedure SetCount(NewCount: Integer);
Protected | procedure SetFirst(item: TObject);
Protected | procedure SetLast(item: TObject);

Properties

Public | property Capacity: Integer read FCapacity write SetCapacity;
Public | property Count: Integer read FCount write SetCount;
Public | property First: TObject read GetFirst write SetFirst;
Public | property GrowthDelta: integer read FGrowthDelta write FGrowthDelta;
Public | property Items[Index: Integer]: TObject read Get write Put;
Public | property Last: TObject read GetLast write SetLast;
Public | property List: PPointerObjectList read FList;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function Add(const item: TObject): Integer;
Public function AddObjects(const objectList: TPersistentObjectList): Integer;
Public function Expand: TPersistentObjectList;
Public function IndexOf(Item: TObject): Integer;
Public function Pop: TObject;
Public function Remove(Item: TObject): Integer;
Public function RemoveAndFree(item: TObject): Integer;
Protected function Get(Index: Integer): TObject;
Protected function GetFirst: TObject;
Protected function GetLast: TObject;
Public procedure AddNils(nbVals: Cardinal);
Public procedure Clean; dynamic;

Empty the list and free the objects.

Public procedure CleanFree;

Empty the list, free the objects and Free self.

Public procedure Clear; dynamic;

Empty the list without freeing the objects.

Public procedure Delete(index: Integer);
Public procedure DeleteAndFree(index: Integer);
Public procedure DeleteAndFreeItems(index: Integer; nbVals: Cardinal);
Public procedure DeleteItems(index: Integer; nbVals: Cardinal);
Public procedure Exchange(Index1, Index2: Integer);
Public procedure Insert(Index: Integer; Item: TObject);
Public procedure InsertNils(index: Integer; nbVals: Cardinal);
Public procedure Move(CurIndex, NewIndex: Integer);
Public procedure Pack;

Removes all "nil" from the list.<p> Note: Capacity is unchanged, no memory us freed, the list is just made shorter. This functions is orders of magnitude faster than its TList eponymous.

Public procedure PopAndFree;
Public procedure Push(item: TObject);
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure ReadFromFilerWithEvent(reader: TVirtualReader; afterSenderObjectCreated: TNotifyEvent);
Public procedure RemoveObjects(const objectList: TPersistentObjectList);
Public procedure RequiredCapacity(aCapacity: Integer);

Makes sure capacity is at least aCapacity.

Public procedure Sort(compareFunc: TObjectListSortCompare);
Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure AfterObjectCreatedByReader(Sender: TObject); virtual;

Default event for ReadFromFiler

Protected procedure DoClean;
Protected procedure Error; virtual;
Protected procedure Put(Index: Integer; Item: TObject);
Protected procedure SetCapacity(newCapacity: Integer);
Protected procedure SetCount(NewCount: Integer);
Protected procedure SetFirst(item: TObject);
Protected procedure SetLast(item: TObject);

Properties

Public property Capacity: Integer read FCapacity write SetCapacity;
Public property Count: Integer read FCount write SetCount;
Public property First: TObject read GetFirst write SetFirst;
Public property GrowthDelta: integer read FGrowthDelta write FGrowthDelta;
Public property Items[Index: Integer]: TObject read Get write Put;
Public property Last: TObject read GetLast write SetLast;
Public property List: PPointerObjectList read FList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PersistentClasses: Class TBinaryReader

Class TBinaryReader

Unit

PersistentClasses

Declaration

type TBinaryReader = class(TVirtualReader)

Description

Wraps a TReader-compatible reader.

Hierarchy

  • TObject
  • TVirtualReader
  • TBinaryReader

Overview

Methods

Public | function EndOfList: Boolean; override;
Public | function NextValue: TValueType; override;
Public | function ReadBoolean: Boolean; override;
Public | function ReadFloat: Extended; override;
Public | function ReadInteger: Integer; override;
Public | function ReadString: string; override;
Protected | function ReadValue: TValueType;
Protected | function ReadWideString(vType: TValueType): WideString;
Public | procedure Read(var Buf; Count: Longint); override;
Public | procedure ReadListBegin; override;
Public | procedure ReadListEnd; override;

Description

Methods

Public function EndOfList: Boolean; override;
Public function NextValue: TValueType; override;
Public function ReadBoolean: Boolean; override;
Public function ReadFloat: Extended; override;
Public function ReadInteger: Integer; override;
Public function ReadString: string; override;
Protected function ReadValue: TValueType;
Protected function ReadWideString(vType: TValueType): WideString;
Public procedure Read(var Buf; Count: Longint); override;
Public procedure ReadListBegin; override;
Public procedure ReadListEnd; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PersistentClasses: Class TBinaryWriter

Class TBinaryWriter

Unit

PersistentClasses

Declaration

type TBinaryWriter = class(TVirtualWriter)

Description

Wraps a TWriter-compatible writer.

Hierarchy

  • TObject
  • TVirtualWriter
  • TBinaryWriter

Overview

Methods

Public | procedure Write(const Buf; Count: Longint); override;
Public | procedure WriteBoolean(aBoolean: Boolean); override;
Public | procedure WriteFloat(const aFloat: Extended); override;
Public | procedure WriteInteger(anInteger: Integer); override;
Public | procedure WriteListBegin; override;
Public | procedure WriteListEnd; override;
Public | procedure WriteString(const aString: string); override;
Protected | procedure WriteAnsiString(const aString: AnsiString); virtual;
Protected | procedure WriteWideString(const aString: WideString); virtual;

Description

Methods

Public procedure Write(const Buf; Count: Longint); override;
Public procedure WriteBoolean(aBoolean: Boolean); override;
Public procedure WriteFloat(const aFloat: Extended); override;
Public procedure WriteInteger(anInteger: Integer); override;
Public procedure WriteListBegin; override;
Public procedure WriteListEnd; override;
Public procedure WriteString(const aString: string); override;
Protected procedure WriteAnsiString(const aString: AnsiString); virtual;
Protected procedure WriteWideString(const aString: WideString); virtual;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PersistentClasses: Class TTextReader

Class TTextReader

Unit

PersistentClasses

Declaration

type TTextReader = class(TVirtualReader)

Description

Reads object persistence in Text format.

Hierarchy

  • TObject
  • TVirtualReader
  • TTextReader

Overview

Methods

Public | function EndOfList: Boolean; override;
Public | function NextValue: TValueType; override;
Public | function ReadBoolean: Boolean; override;
Public | function ReadFloat: Extended; override;
Public | function ReadInteger: Integer; override;
Public | function ReadString: string; override;
Public | procedure Read(var Buf; Count: Longint); override;
Public | procedure ReadListBegin; override;
Public | procedure ReadListEnd; override;
Protected | procedure ReadLine(const requestedType: string = '');

Description

Methods

Public function EndOfList: Boolean; override;
Public function NextValue: TValueType; override;
Public function ReadBoolean: Boolean; override;
Public function ReadFloat: Extended; override;
Public function ReadInteger: Integer; override;
Public function ReadString: string; override;
Public procedure Read(var Buf; Count: Longint); override;
Public procedure ReadListBegin; override;
Public procedure ReadListEnd; override;
Protected procedure ReadLine(const requestedType: string = '');
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PersistentClasses: Class TTextWriter

Class TTextWriter

Unit

PersistentClasses

Declaration

type TTextWriter = class(TVirtualWriter)

Description

Writes object persistence in Text format.

Hierarchy

  • TObject
  • TVirtualWriter
  • TTextWriter

Overview

Methods

Public | constructor Create(aStream: TStream); override;
Public | destructor Destroy; override;
Public | procedure Write(const Buf; Count: Longint); override;
Public | procedure WriteBoolean(aBoolean: Boolean); override;
Public | procedure WriteFloat(const aFloat: Extended); override;
Public | procedure WriteInteger(anInteger: Integer); override;
Public | procedure WriteListBegin; override;
Public | procedure WriteListEnd; override;
Public | procedure WriteString(const aString: string); override;
Protected | procedure WriteLine(const valueType, data: string);

Description

Methods

Public constructor Create(aStream: TStream); override;
Public destructor Destroy; override;
Public procedure Write(const Buf; Count: Longint); override;
Public procedure WriteBoolean(aBoolean: Boolean); override;
Public procedure WriteFloat(const aFloat: Extended); override;
Public procedure WriteInteger(anInteger: Integer); override;
Public procedure WriteListBegin; override;
Public procedure WriteListEnd; override;
Public procedure WriteString(const aString: string); override;
Protected procedure WriteLine(const valueType, data: string);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PersistentClasses: Class TGLOwnedPersistent

Class TGLOwnedPersistent

Unit

PersistentClasses

Declaration

type TGLOwnedPersistent = class(TPersistent)

Description

TPersistent which has knowledge of its owner.

Hierarchy

  • TPersistent
  • TGLOwnedPersistent

Overview

Methods

Public | constructor Create(AOwner: TPersistent); virtual;
Protected | function GetOwner: TPersistent; override;

Description

Methods

Public constructor Create(AOwner: TPersistent); virtual;
Protected function GetOwner: TPersistent; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PersistentClasses: Class TGLInterfacedPersistent

Class TGLInterfacedPersistent

Unit

PersistentClasses

Declaration

type TGLInterfacedPersistent = class(TPersistent, IInterface)

Description

TPersistent thet inplements IInterface.

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent

Overview

Methods

Protected | function QueryInterface(const IID: TGUID; out Obj): HResult; stdcall;
Protected | function _AddRef: Integer; stdcall;
Protected | function _Release: Integer; stdcall;

Description

Methods

Protected function QueryInterface(const IID: TGUID; out Obj): HResult; stdcall;
Protected function _AddRef: Integer; stdcall;
Protected function _Release: Integer; stdcall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PersistentClasses: Class TGLInterfacedCollectionItem

Class TGLInterfacedCollectionItem

Unit

PersistentClasses

Declaration

type TGLInterfacedCollectionItem = class(TCollectionItem, IInterface)

Description

TCollectionItem thet inplements IInterface.

Hierarchy

  • TCollectionItem
  • TGLInterfacedCollectionItem

Overview

Methods

Protected | function QueryInterface(const IID: TGUID; out Obj): HResult; virtual; stdcall;
Protected | function _AddRef: Integer; virtual; stdcall;
Protected | function _Release: Integer; virtual; stdcall;

Description

Methods

Protected function QueryInterface(const IID: TGUID; out Obj): HResult; virtual; stdcall;
Protected function _AddRef: Integer; virtual; stdcall;
Protected function _Release: Integer; virtual; stdcall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PersistentClasses: Class EInvalidFileSignature

Class EInvalidFileSignature

Unit

PersistentClasses

Declaration

type EInvalidFileSignature = class(Exception)

Description

Triggered when file signature does not match.

Hierarchy

  • Exception
  • EInvalidFileSignature
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PersistentClasses: Class EFilerException

Class EFilerException

Unit

PersistentClasses

Declaration

type EFilerException = class(Exception)

Description

Usually triggered when a filing error is detected.

Hierarchy

  • Exception
  • EFilerException
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PictureRegisteredFormats

Unit PictureRegisteredFormats

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

PictureRegisteredFormats<p>

Hacks into the VCL to access the list of TPicture registered TGraphic formats<p>

<b>History : </b><font size=-1><ul> <li>19/06/11 - Yar - Improved for Lazarus (thanks to Johannes Pretorius, Bugtracker ID = 1586936) <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>19/09/10 - YP - Range check auto disabled in HackTPictureRegisteredFormats <li>31/05/10 - Yar - Fixes for Linux x64 <li>25/01/10 - DaStr - Updated warning about a possible crash while using the 'Use Debug DCUs' compiler option (BugTrackerID=1586936) <li>10/11/09 - DaStr - Replaced all Delphi2005+ IFDEFs with a single one <li>07/11/09 - DaStr - Improved FPC compatibility (BugtrackerID = 2893580) (thanks Predator) <li>16/10/08 - UweR - Added IFDEF for Delphi 2009 <li>06/04/08 - DanB - Change to HackTPictureRegisteredFormats due to Char changing size in Delphi 2009 <li>06/04/08 - DaStr - Added IFDEFs for Delphi 5 compatibility <li>20/12/06 - DaStr - Added a warning about optimization turned off in HackTPictureRegisteredFormats (BugTrackerID=1586936) <li>08/03/06 - ur - Added Delphi 2006 support <li>28/02/05 - EG - Added BPL support <li>24/02/05 - EG - Creation </ul></font>

Overview

Functions and Procedures

function GraphicClassForExtension(const anExtension: string): TGraphicClass;
procedure HackTPictureRegisteredFormats(destList: TStrings);

Description

Functions and Procedures

function GraphicClassForExtension(const anExtension: string): TGraphicClass;

Returns the TGraphicClass associated to the extension, if any.<p> Accepts anExtension with or without the '.'

procedure HackTPictureRegisteredFormats(destList: TStrings);

Adds to the passed TStrings the list of registered formats.<p> Convention is "extension=description" for the string, the Objects hold the corresponding TGraphicClass (extensions do not include the '.').

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PlugInIntf

Unit PlugInIntf

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

PlugInManagerPropEditor<p>

An interface unit to GLScene plug-ins.<p> For more information see help file for writing plug-ins.<p>

<b>History : </b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 PlugIn interface stays at PAnsiChar <li>02/04/07 - DaStr - Added $I GLScene.inc <li>28/07/01 - EG - Creation </ul></font>

Overview

Types

TPIServiceType = (...);
TPIServices = set of TPIServiceType;
TEnumCallBack = procedure(Name: PAnsiChar); stdcall;
TEnumResourceNames = procedure(Service: TPIServiceType; Callback: TEnumCallback); stdcall;
TGetServices = function : TPIServices; stdcall;
TGetVendor = function : PAnsiChar; stdcall;
TGetDescription = function : PAnsiChar; stdcall;
TGetVersion = function : PAnsiChar; stdcall;

Description

Types

TPIServiceType = (...);
Values
  • stRaw:
  • stObject:
  • stBitmap:
  • stTexture:
  • stImport:
  • stExport:
TPIServices = set of TPIServiceType;
TEnumCallBack = procedure(Name: PAnsiChar); stdcall;
TEnumResourceNames = procedure(Service: TPIServiceType; Callback: TEnumCallback); stdcall;
TGetServices = function : TPIServices; stdcall;
TGetVendor = function : PAnsiChar; stdcall;
TGetDescription = function : PAnsiChar; stdcall;
TGetVersion = function : PAnsiChar; stdcall;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PlugInManager

Unit PlugInManager

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TPlugInEntry |
Class TResourceManager |
Class TPlugInList |
record TResManagerEntry |
Class TPlugInManager |

Types

PPlugInEntry = ˆTPlugInEntry;
PResManagerEntry = ˆTResManagerEntry;

Description

Types

PPlugInEntry = ˆTPlugInEntry;
PResManagerEntry = ˆTResManagerEntry;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PlugInManager: record TPlugInEntry

record TPlugInEntry

Unit

PlugInManager

Declaration

type TPlugInEntry = record

Description

Overview

Fields

Path: TFileName;
Handle: HINST;
FileSize: Integer;
FileDate: TDateTime;
EnumResourcenames: TEnumResourceNames;
GetServices: TGetServices;
GetVendor: TGetVendor;
GetDescription: TGetDescription;
GetVersion: TGetVersion;

Description

Fields

Path: TFileName;
Handle: HINST;
FileSize: Integer;
FileDate: TDateTime;
EnumResourcenames: TEnumResourceNames;
GetServices: TGetServices;
GetVendor: TGetVendor;
GetDescription: TGetDescription;
GetVersion: TGetVersion;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PlugInManager: Class TResourceManager

Class TResourceManager

Unit

PlugInManager

Declaration

type TResourceManager = class(TComponent)

Description

Hierarchy

  • TComponent
  • TResourceManager

Overview

Methods

Public procedure Notify(Sender: TPlugInManager; Operation: TOperation; Service: TPIServiceType; PlugIn: Integer); virtual; abstract;

Description

Methods

Public procedure Notify(Sender: TPlugInManager; Operation: TOperation; Service: TPIServiceType; PlugIn: Integer); virtual; abstract;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PlugInManager: Class TPlugInList

Class TPlugInList

Unit

PlugInManager

Declaration

type TPlugInList = class(TStringList)

Description

Hierarchy

  • TStringList
  • TPlugInList

Overview

Methods

Public | constructor Create(AOwner: TPlugInManager); virtual;
Public | procedure ClearList;
Protected | procedure DefineProperties(Filer: TFiler); override;
Protected | procedure ReadPlugIns(Reader: TReader);
Protected | procedure WritePlugIns(Writer: TWriter);

Properties

Public | property Objects[Index: Integer]: PPlugInEntry read GetPlugInEntry write SetPlugInEntry;
Public | property Owner: TPlugInManager read FOwner;

Description

Methods

Public constructor Create(AOwner: TPlugInManager); virtual;
Public procedure ClearList;
Protected procedure DefineProperties(Filer: TFiler); override;
Protected procedure ReadPlugIns(Reader: TReader);
Protected procedure WritePlugIns(Writer: TWriter);

Properties

Public property Objects[Index: Integer]: PPlugInEntry read GetPlugInEntry write SetPlugInEntry;
Public property Owner: TPlugInManager read FOwner;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PlugInManager: record TResManagerEntry

record TResManagerEntry

Unit

PlugInManager

Declaration

type TResManagerEntry = record

Description

Overview

Fields

Manager: TResourceManager;
Services: TPIServices;

Description

Fields

Manager: TResourceManager;
Services: TPIServices;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PlugInManager: Class TPlugInManager

Class TPlugInManager

Unit

PlugInManager

Declaration

type TPlugInManager = class(TComponent)

Description

Hierarchy

  • TComponent
  • TPlugInManager

Overview

Methods

Public | constructor Create(AOwner: TComponent); override;
Public | destructor Destroy; override;
Public | function AddPlugIn(Path: TFileName): Integer;
Protected | function FindResManager(AManager: TResourceManager): PResManagerEntry;
Protected | function GetIndexFromFilename(FileName: String): Integer;
Protected | function GetPlugInFromFilename(FileName: String): PPlugInEntry;
Public | procedure EditPlugInList;
Public | procedure RegisterResourceManager(AManager: TResourceManager; Services: TPIServices);
Public | procedure RemovePlugIn(Index: Integer);
Public | procedure UnRegisterRessourceManager(AManager: TResourceManager; Services: TPIServices);
Protected | procedure DoNotify(Operation: TOperation; Service: TPIServiceType; PlugIn: Integer);

Properties

Published property PlugIns: TPlugInList read FLibraryList write FLibraryList;

Description

Methods

Public constructor Create(AOwner: TComponent); override;
Public destructor Destroy; override;
Public function AddPlugIn(Path: TFileName): Integer;
Protected function FindResManager(AManager: TResourceManager): PResManagerEntry;
Protected function GetIndexFromFilename(FileName: String): Integer;
Protected function GetPlugInFromFilename(FileName: String): PPlugInEntry;
Public procedure EditPlugInList;
Public procedure RegisterResourceManager(AManager: TResourceManager; Services: TPIServices);
Public procedure RemovePlugIn(Index: Integer);
Public procedure UnRegisterRessourceManager(AManager: TResourceManager; Services: TPIServices);
Protected procedure DoNotify(Operation: TOperation; Service: TPIServiceType; PlugIn: Integer);

Properties

Published property PlugIns: TPlugInList read FLibraryList write FLibraryList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PlugInManagerPropEditor

Unit PlugInManagerPropEditor

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TPlugInManagerPropForm |

Variables

PlugInManagerPropForm: TPlugInManagerPropForm;

Description

Variables

PlugInManagerPropForm: TPlugInManagerPropForm;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: PlugInManagerPropEditor: Class TPlugInManagerPropForm

Class TPlugInManagerPropForm

Unit

PlugInManagerPropEditor

Declaration

type TPlugInManagerPropForm = class(TForm)

Description

Hierarchy

  • TForm
  • TPlugInManagerPropForm

Overview

Fields

Published | OpenDialog: TOpenDialog;
Published | ListBox: TListBox;
Published | Label1: TLabel;
Published | OKButton: TSpeedButton;
Published | LoadButton: TSpeedButton;
Published | UnloadButton: TSpeedButton;
Published | GroupBox: TGroupBox;
Published | DescriptionMemo: TMemo;
Published | Label2: TLabel;
Published | Label3: TLabel;
Published | DateLabel: TLabel;
Published | SizeLabel: TLabel;
Published | Label4: TLabel;
Published | Label5: TLabel;
Published | ServiceBox: TComboBox;
Published | NameBox: TComboBox;

Methods

Published | procedure ListBoxClick(Sender: TObject);
Published | procedure LoadButtonClick(Sender: TObject);
Published | procedure OKButtonClick(Sender: TObject);
Published | procedure ServiceBoxChange(Sender: TObject);
Published | procedure UnloadButtonClick(Sender: TObject);
Public | class procedure EditPlugIns(AManager: TPlugInManager);

Description

Fields

Published OpenDialog: TOpenDialog;
Published ListBox: TListBox;
Published Label1: TLabel;
Published OKButton: TSpeedButton;
Published LoadButton: TSpeedButton;
Published UnloadButton: TSpeedButton;
Published GroupBox: TGroupBox;
Published DescriptionMemo: TMemo;
Published Label2: TLabel;
Published Label3: TLabel;
Published DateLabel: TLabel;
Published SizeLabel: TLabel;
Published Label4: TLabel;
Published Label5: TLabel;
Published ServiceBox: TComboBox;
Published NameBox: TComboBox;

Methods

Published procedure ListBoxClick(Sender: TObject);
Published procedure LoadButtonClick(Sender: TObject);
Published procedure OKButtonClick(Sender: TObject);
Published procedure ServiceBoxChange(Sender: TObject);
Published procedure UnloadButtonClick(Sender: TObject);
Public class procedure EditPlugIns(AManager: TPlugInManager);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Polynomials

Unit Polynomials

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Polynomials.<p>

********* IN PROGRESS - LIMITED PRECISION **********

Utility functions for manipulationg and solving polynomials.<p>

Direct solving is supported for polynoms up to the 4th degree.<p>

Polynom solving code based on Jochen Schwarze (schwarze@isa.de) solver published in Graphics Gem (1990).<p>

Adapted to pascal by Eric Grange (egrange@glscene.org), if you find errors, they are probably mine. Note that contrary to the original code, the functions accept 'zero' values for any of the parameters.<br> I also made some changes for certain limit cases that (seemingly) weren't properly handled, these are marked by comments in the code.<p>

<b>History : </b><font size=-1><ul> <li>30/03/07 - DaStr - Added $I GLScene.inc <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>21/07/02 - EG - Added MinPositiveCoef <li>14/01/02 - EG - Switched to Jochen Schwarze's solver, droped complex stuff, added utility funcs <li>22/08/01 - EG - Some fixes, qtcrt still no up to what I expected <li>21/08/01 - EG - Creation </ul></font>

Overview

Functions and Procedures

function EvalPolynom(const poly : TDoubleArray; const x : Double) : Double;
function DerivatedPolynom(const poly : TDoubleArray) : TDoubleArray;
function FindRoot(const poly : TDoubleArray; min, max, epsilon : Double) : Double;
function MinPositiveCoef(const coefs : TDoubleArray; var aMin : Double) : Boolean;
function cbrt(const x : Double) : Double;
function SolveQuadric(const c : PDoubleArray) : TDoubleArray;
function SolveCubic(const c : PDoubleArray) : TDoubleArray;
function SolveQuartic(const c : PDoubleArray) : TDoubleArray;

Types

TDoubleArray = array of Double;

Description

Functions and Procedures

function EvalPolynom(const poly : TDoubleArray; const x : Double) : Double;

Computes polynom's value for given x.

function DerivatedPolynom(const poly : TDoubleArray) : TDoubleArray;

Calculates the polynom's derivative.

function FindRoot(const poly : TDoubleArray; min, max, epsilon : Double) : Double;

Finds a root between min and max with a precision of epsilon.<p> The evaluation of min/max must be of opposit sign

function MinPositiveCoef(const coefs : TDoubleArray; var aMin : Double) : Boolean;

Finds the minimum positive coef in the array in aMin.<p> Returns true if such an item was found.

function cbrt(const x : Double) : Double;

Calculates the cube root of its parameter.

function SolveQuadric(const c : PDoubleArray) : TDoubleArray;

Computes the real roots of a real polynomial of the 2nd degree.<p> The polynomial is of the form:<br> A(0) + A(1)*Z + A(2)*Z**2

function SolveCubic(const c : PDoubleArray) : TDoubleArray;

Computes the real roots of a real polynomial of the 3rd degree.<p> The polynomial is of the form:<br> A(0) + A(1)*Z + A(2)*Z**2 + A(3)*Z**3

function SolveQuartic(const c : PDoubleArray) : TDoubleArray;

Computes the real roots of a real polynomial of the 4th degree.<p> The polynomial is of the form:<br> A(0) + A(1)*Z + ... + A(4)*Z**4

Types

TDoubleArray = array of Double;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Q3BSP

Unit Q3BSP

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Q3BSP<p>

Simple Quake III BSP file loader.<p>

<b>History : </b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>30/01/03 - Egg - Creation, based on Philip Stefou's document and bits from Jan Horn's loader </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TBSPHeader |
record TBSPLump |
record TBSPNode |
record TBSPLeaf |
record TBSPModel |
record TBSPVertex |
record TBSPFace |
record TBSPTexture |
record TBSPLightmap |
record TBSPVisData |
Class TQ3BSP |

Types

TBSPBBox = array [0..5] of Integer;
PBSPVertex = ˆTBSPVertex;
PBSPFace = ˆTBSPFace;
PBSPTexture = ˆTBSPTexture;
PBSPLightmap = ˆTBSPLightmap;

Constants

FACE_POLYGON = 1;
MAX_TEXTURES = 1000;
kEntities = 0;
kTextures = 1;
kPlanes = 2;
kNodes = 3;
kLeafs = 4;
kLeafFaces = 5;
kLeafBrushes = 6;
kModels = 7;
kBrushes = 8;
kBrushSides = 9;
kVertices = 10;
kMeshVerts = 11;
kShaders = 12;
kFaces = 13;
kLightmaps = 14;
kLightVolumes= 15;
kVisData = 16;
kMaxLumps = 17;

Description

Types

TBSPBBox = array [0..5] of Integer;
PBSPVertex = ˆTBSPVertex;
PBSPFace = ˆTBSPFace;
PBSPTexture = ˆTBSPTexture;
PBSPLightmap = ˆTBSPLightmap;

Constants

FACE_POLYGON = 1;
MAX_TEXTURES = 1000;
kEntities = 0;
kTextures = 1;
kPlanes = 2;
kNodes = 3;
kLeafs = 4;
kLeafFaces = 5;
kLeafBrushes = 6;
kModels = 7;
kBrushes = 8;
kBrushSides = 9;
kVertices = 10;
kMeshVerts = 11;
kShaders = 12;
kFaces = 13;
kLightmaps = 14;
kLightVolumes= 15;
kVisData = 16;
kMaxLumps = 17;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Q3BSP: record TBSPHeader

record TBSPHeader

Unit

Q3BSP

Declaration

type TBSPHeader = record

Description

Overview

Fields

StrID: array [0..3] of AnsiChar;
Version: Integer;

Description

Fields

StrID: array [0..3] of AnsiChar;
Version: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Q3BSP: record TBSPLump

record TBSPLump

Unit

Q3BSP

Declaration

type TBSPLump = record

Description

Overview

Fields

Offset: Integer;
Length: Integer;

Description

Fields

Offset: Integer;
Length: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Q3BSP: record TBSPNode

record TBSPNode

Unit

Q3BSP

Declaration

type TBSPNode = record

Description

Overview

Fields

Plane: Integer;
Children: array [0..1] of Integer;
BBox: TBSPBBox;

Description

Fields

Plane: Integer;
Children: array [0..1] of Integer;
BBox: TBSPBBox;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Q3BSP: record TBSPLeaf

record TBSPLeaf

Unit

Q3BSP

Declaration

type TBSPLeaf = record

Description

Overview

Fields

Cluster: Integer;
Area: Integer;
BBox: TBSPBBox;
FirstFace: Integer;
NumFaces: Integer;
FirstBrush: Integer;
NumBrushes: Integer;

Description

Fields

Cluster: Integer;
Area: Integer;
BBox: TBSPBBox;
FirstFace: Integer;
NumFaces: Integer;
FirstBrush: Integer;
NumBrushes: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Q3BSP: record TBSPModel

record TBSPModel

Unit

Q3BSP

Declaration

type TBSPModel = record

Description

Overview

Fields

BBox: TBSPBBox;
FirstFace: Integer;
NumFaces: Integer;
FirstBrush: Integer;
NumBrushes: Integer;

Description

Fields

BBox: TBSPBBox;
FirstFace: Integer;
NumFaces: Integer;
FirstBrush: Integer;
NumBrushes: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Q3BSP: record TBSPVertex

record TBSPVertex

Unit

Q3BSP

Declaration

type TBSPVertex = record

Description

Overview

Fields

Position: TVector3f;
TextureCoord: TVector2f;
LightmapCoord: TVector2f;
Normal: TVector3f;
Color: array [0..3] of Byte

Description

Fields

Position: TVector3f;
TextureCoord: TVector2f;
LightmapCoord: TVector2f;
Normal: TVector3f;
Color: array [0..3] of Byte
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Q3BSP: record TBSPFace

record TBSPFace

Unit

Q3BSP

Declaration

type TBSPFace = record

Description

Overview

Fields

textureID: Integer;
effect: Integer;
FaceType: Integer;
startVertIndex: Integer;
numOfVerts: Integer;
meshVertIndex: Integer;
numMeshVerts: Integer;
lightmapID: Integer;
lMapCorner: array [0..1] of Integer;
lMapSize: array [0..1] of Integer;
lMapPos: TVector3f;
lMapVecs: array [0..1] of TVector3f;
vNormal: TVector3f;
Size: array [0..1] of Integer;

Description

Fields

textureID: Integer;
effect: Integer;
FaceType: Integer;
startVertIndex: Integer;
numOfVerts: Integer;
meshVertIndex: Integer;
numMeshVerts: Integer;
lightmapID: Integer;
lMapCorner: array [0..1] of Integer;
lMapSize: array [0..1] of Integer;
lMapPos: TVector3f;
lMapVecs: array [0..1] of TVector3f;
vNormal: TVector3f;
Size: array [0..1] of Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Q3BSP: record TBSPTexture

record TBSPTexture

Unit

Q3BSP

Declaration

type TBSPTexture = record

Description

Overview

Fields

TextureName: array [0..63] of AnsiChar;
flags: Integer;
contents: Integer;

Description

Fields

TextureName: array [0..63] of AnsiChar;
flags: Integer;
contents: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Q3BSP: record TBSPLightmap

record TBSPLightmap

Unit

Q3BSP

Declaration

type TBSPLightmap = record

Description

Overview

Fields

imageBits: array [0..49151] of Byte;

Description

Fields

imageBits: array [0..49151] of Byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Q3BSP: record TBSPVisData

record TBSPVisData

Unit

Q3BSP

Declaration

type TBSPVisData = record

Description

Overview

Fields

numOfClusters: Integer;
bytesPerCluster: Integer;
bitSets: array of Byte;

Description

Fields

numOfClusters: Integer;
bytesPerCluster: Integer;
bitSets: array of Byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Q3BSP: Class TQ3BSP

Class TQ3BSP

Unit

Q3BSP

Declaration

type TQ3BSP = class(TObject)

Description

Hierarchy

  • TObject
  • TQ3BSP

Overview

Fields

Public | Header: TBSPHeader;
Public | Lumps: array of TBSPLump;
Public | NumOfVerts: Integer;
Public | NumOfNodes: Integer;
Public | NumOfPlanes: Integer;
Public | NumOfLeaves: Integer;
Public | NumOfFaces: Integer;
Public | NumOfTextures: Integer;
Public | NumOfLightmaps: Integer;
Public | Vertices: array of TBSPVertex;
Public | Nodes: array of TBSPNode;
Public | Planes: array of TVector4f;
Public | Leaves: array of TBSPLeaf;
Public | Faces: array of TBSPFace;
Public | Textures: array of TBSPTexture;
Public | Lightmaps: array of TBSPLightmap;
Public | VisData: TBSPVisData;

Methods

Public constructor Create(bspStream : TStream);

Description

Fields

Public Header: TBSPHeader;
Public Lumps: array of TBSPLump;
Public NumOfVerts: Integer;
Public NumOfNodes: Integer;
Public NumOfPlanes: Integer;
Public NumOfLeaves: Integer;
Public NumOfFaces: Integer;
Public NumOfTextures: Integer;
Public NumOfLightmaps: Integer;
Public Vertices: array of TBSPVertex;
Public Nodes: array of TBSPNode;
Public Planes: array of TVector4f;
Public Leaves: array of TBSPLeaf;
Public Faces: array of TBSPFace;
Public Textures: array of TBSPTexture;
Public Lightmaps: array of TBSPLightmap;
Public VisData: TBSPVisData;

Methods

Public constructor Create(bspStream : TStream);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Q3MD3

Unit Q3MD3

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Q3MD3<p>

Helper classes and methods for Quake3 MD3 actors<p>

History : 14/04/03 - SG - Streamlined the TMD3TagList.LoadFromStream a little 04/04/03 - SG - Changes made to LoadQ3Skin procedure (as suggested by Mrqzzz) 03/04/03 - SG - Added LoadQ3Skin procedure 01/04/03 - Mrqzzz - "LEGS_" animations read from .CFG fixed 17/02/03 - SG - Creation

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMD3TagList |

Functions and Procedures

procedure LoadQ3Anims(Animations:TActorAnimations; FileName:string; NamePrefix:string); overload;
procedure LoadQ3Anims(Animations:TActorAnimations; Strings:TStrings; NamePrefix:string); overload;
procedure LoadQ3Skin(FileName:string; Actor:TGLActor);

Description

Functions and Procedures

procedure LoadQ3Anims(Animations:TActorAnimations; FileName:string; NamePrefix:string); overload;
procedure LoadQ3Anims(Animations:TActorAnimations; Strings:TStrings; NamePrefix:string); overload;
procedure LoadQ3Skin(FileName:string; Actor:TGLActor);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: Q3MD3: Class TMD3TagList

Class TMD3TagList

Unit

Q3MD3

Declaration

type TMD3TagList = class(TObject)

Description

Hierarchy

  • TObject
  • TMD3TagList

Overview

Methods

Public | function GetTransform(TagName:string; Frame:integer):TMatrix;
Public | procedure LoadFromFile(FileName:String);
Public | procedure LoadFromStream(AStream:TStream);

Properties

Public | property FrameCount : integer read FNumFrames;
Public | property TagCount : integer read FNumTags;
Public | property Tags[index:integer]: TMD3Tag read GetTag;

Description

Methods

Public function GetTransform(TagName:string; Frame:integer):TMatrix;
Public procedure LoadFromFile(FileName:String);
Public procedure LoadFromStream(AStream:TStream);

Properties

Public property FrameCount : integer read FNumFrames;
Public property TagCount : integer read FNumTags;
Public property Tags[index:integer]: TMD3Tag read GetTag;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: RegisterXCollection

Unit RegisterXCollection

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

RegisterXCollection<p>

Register TXCollection property editor<p>

<b>History : </b><font size=-1><ul> <li>20/05/10 - Yar - Fixes for Linux x64 <li>11/11/09 - DaStr - Improved FPC compatibility (thanks Predator) (BugtrackerID = 2893580) <li>03/07/04 - LR - Removed ..\ from the GLScene.inc <li>16/04/00 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TXCollectionProperty |

Functions and Procedures

procedure Register;

Description

Functions and Procedures

procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: RegisterXCollection: Class TXCollectionProperty

Class TXCollectionProperty

Unit

RegisterXCollection

Declaration

type TXCollectionProperty = class(TClassProperty)

Description

Hierarchy

  • TClassProperty
  • TXCollectionProperty

Overview

Methods

Public | function GetAttributes: TPropertyAttributes; override;
Public | procedure Edit; override;

Description

Methods

Public function GetAttributes: TPropertyAttributes; override;
Public procedure Edit; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: RGBE

Unit RGBE

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Functions and Procedures

procedure Float2rgbe(var RGBE: TVector4b; const Red, Green, Blue: Single);
procedure Rgbe2float(var Red, Green, Blue: Single; const RGBE: TVector4b);
procedure LoadRLEpixels(Stream: TStream; Dst: PSingle; Scanline_width, Num_scanlines: Integer);
procedure LoadRGBEpixels(Stream: TStream; Dst: PSingle; Numpixels: Integer);

Description

Functions and Procedures

procedure Float2rgbe(var RGBE: TVector4b; const Red, Green, Blue: Single);
procedure Rgbe2float(var Red, Green, Blue: Single; const RGBE: TVector4b);
procedure LoadRLEpixels(Stream: TStream; Dst: PSingle; Scanline_width, Num_scanlines: Integer);
procedure LoadRGBEpixels(Stream: TStream; Dst: PSingle; Numpixels: Integer);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: ScreenSaver

Unit ScreenSaver

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

ScreenSaver<p>

Component for making screen-savers an easy task<p>

<b>History : </b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>17/03/07 - DaStr - Dropped Kylix support in favor of FPC (BugTracekrID=1681585) <li>09/07/01 - Egg - Fix in PreviewSaver (from Marco Dissel) <li>12/04/00 - Egg - Added ssoEnhancedMouseMoveDetection <li>11/04/00 - Egg - Creation </ul></font>

Parts of this code are based on DeskSpin sample by Tom Nuydens (http://www.gamedeveloper.org/delphi3d/).<p>

NB : The password stuff does NOT work under NT, dll references I found in Tom's sample simply did not exist under my NT4...

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TScreenSaver |

Functions and Procedures

procedure SetScreenSaverPassword;

Types

TScreenSaverOption = (...);
TScreenSaverOptions = set of TScreenSaverOption;
TScreenSaverPreviewEvent = procedure (Sender: TObject; previewHwnd : HWND) of object;

Constants

cDefaultScreenSaverOptions = [ssoAutoAdjustFormProperties, ssoAutoHookKeyboardEvents, ssoEnhancedMouseMoveDetection];

Description

Functions and Procedures

procedure SetScreenSaverPassword;

Invokes the standard Windows dialog to set the password.<p> May be invoked from your Properties/Configuration dialog.

Types

TScreenSaverOption = (...);

Options d'automatisation du screen-saver.<p> <ul> <li>ssoAutoAdjustFormProperties : all relevant properties of main form will be auto-adjusted (form style, border style, form size and for preview, ParentWindow). <li>ssoAutoHookKeyboardEvents : hooks to main form's OnKeyPress and closes screen saver when a key is pressed (form's KeyPreview is also set to True) <li>ssoAutoHookMouseEvents : hooks to main form's OnMouseMove and closes screen saver when mouse is moved (you mays have to handle other mouse move events manually if you have placed components on the form) <li>ssoEnhancedMouseMoveDetection : gets the mouse position every half-second and closes the saver if position changed (uses GetCursorPos and a TTimer) </ul>

Values
  • ssoAutoAdjustFormProperties:
  • ssoAutoHookKeyboardEvents:
  • ssoAutoHookMouseEvents:
  • ssoEnhancedMouseMoveDetection:
TScreenSaverOptions = set of TScreenSaverOption;
TScreenSaverPreviewEvent = procedure (Sender: TObject; previewHwnd : HWND) of object;

This event is fired when screen saver should start in preview mode.<p> The passed hwnd is that of the small preview window in Windows Display Properties (or any other screen-saver previewing utility, so don't assume width/height is constant/universal or whatever).

Constants

cDefaultScreenSaverOptions = [ssoAutoAdjustFormProperties, ssoAutoHookKeyboardEvents, ssoEnhancedMouseMoveDetection];
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:38


GLScene v.1.1.2: ScreenSaver: Class TScreenSaver

Class TScreenSaver

Unit

ScreenSaver

Declaration

type TScreenSaver = class(TComponent)

Description

Drop this component on your main form to make it a screensaver.<p> You'll also need to change the extension from ".exe" to ".scr" (in the project options / application tab).<p> How this component works :<ul> <li>At design-time, the only event you may want to hook is OnPropertiesRequested (to diplay your screen-saver's config dialog, if you don't have one, at least fill in the AboutString property and it will be used in a ShowMessage) <li>At run-time, once its props are loaded, this component will parse the command line and trigger relevant events <li>Basicly, you only need to care about drawing in your main form's client area (in a resolution/size independant way if possible) </ul><br> There is no real difference between execution and preview modes, except for the events fired... and the size of the form :).

Hierarchy

  • TComponent
  • TScreenSaver

Overview

Methods

Public | constructor Create(AOwner : TComponent); override;
Public | destructor Destroy; override;
Public | function CloseSaver : Boolean;
Public | procedure SetPassword;
Protected | procedure ConfigureSaver;
Protected | procedure ExecuteSaver;
Protected | procedure FormKeyPress(Sender: TObject; var Key: Char);
Protected | procedure FormMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Protected | procedure Loaded; override;
Protected | procedure OnMouseTimer(Sender: TObject);
Protected | procedure PreviewSaver;

Properties

Published | property AboutString : String read FAboutString write FAboutString;
Published | property HonourWindowsPassword : Boolean read FHonourWindowsPassword write FHonourWindowsPassword default True;
Public | property InPreviewMode : Boolean read FInPreviewMode;
Published | property OnCloseQuery : TCloseQueryEvent read FOnCloseQuery write FOnCloseQuery;
Published | property OnExecute : TNotifyEvent read FOnExecute write FOnExecute;
Published | property OnPreview : TScreenSaverPreviewEvent read FOnPreview write FOnPreview;
Published | property OnPropertiesRequested : TNotifyEvent read FOnPropertiesRequested write FOnPropertiesRequested;
Published | property Options : TScreenSaverOptions read FOptions write FOptions default cDefaultScreenSaverOptions;

Description

Methods

Public constructor Create(AOwner : TComponent); override;
Public destructor Destroy; override;
Public function CloseSaver : Boolean;

Properly handles request to close the main window.<p> Returns True if the Close request wasn't canceled (by event or password fail) and will actually happen. Use this if you implemented specific screen-saver exiting in your main form.<br> It first triggers the OnCloseQuery, where the close request can be canceled, if this passed, the password is checked if there is any, then sends a WM_CLOSE to the saver windows.

Public procedure SetPassword;

Invokes the standard Windows dialog to set the password.<p> May be invoked from your Properties/Configuration dialog.

Protected procedure ConfigureSaver;
Protected procedure ExecuteSaver;
Protected procedure FormKeyPress(Sender: TObject; var Key: Char);
Protected procedure FormMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
Protected procedure Loaded; override;
Protected procedure OnMouseTimer(Sender: TObject);
Protected procedure PreviewSaver;

Properties

Published property AboutString : String read FAboutString write FAboutString;

This string is displayed if OnPropertiesRequested is not used.<p> You may use it as a quick "AboutBox".

Published property HonourWindowsPassword : Boolean read FHonourWindowsPassword write FHonourWindowsPassword default True;

If True, windows screen-saver password is checked before closing.<p> You may be wanting to set this prop to false if you're using your own password scheme or do not want any password to be set.

Public property InPreviewMode : Boolean read FInPreviewMode;

True if the screen-save is in preview mode.<p> Valid only when the TScreenSaver has completed loading.

Published property OnCloseQuery : TCloseQueryEvent read FOnCloseQuery write FOnCloseQuery;

Fired when screen-saver execution should close.<p> It is invoked before querying for password (if there is a password).

Published property OnExecute : TNotifyEvent read FOnExecute write FOnExecute;

Fired when the saver should start executing, after form props are adjusted.

Published property OnPreview : TScreenSaverPreviewEvent read FOnPreview write FOnPreview;

Fired when preview is requested, after form props are adjusted.

Published property OnPropertiesRequested : TNotifyEvent read FOnPropertiesRequested write FOnPropertiesRequested;

Display the properties dialog when this event is triggered.<p> This event may be called before Delphi's form auto-creation is complete, and should not rely on auto-created dialogs/forms but create what needs be.

Published property Options : TScreenSaverOptions read FOptions write FOptions default cDefaultScreenSaverOptions;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: SpatialPartitioning

Unit SpatialPartitioning

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TSPCone |
record TExtendedFrustum |
Class TSpacePartitionLeaf |
Class TSpacePartitionLeafList |
Class TBaseSpacePartition |
Class TLeavedSpacePartition |
Class TSectorNode |
Class TSectoredSpacePartition |
Class TSPOctreeNode |
Class TOctreeSpacePartition |
Class TSPQuadtreeNode |
Class TQuadtreeSpacePartition |

Functions and Procedures

function ConeContainsBSphere(const Cone: TSPCone; BSphere: TBSphere) : TSpaceContains;
function ExtendedFrustumIntersectsBSphere(const AExtendedFrustum : TExtendedFrustum; ABSphere: TBSphere): Boolean;
function ExtendedFrustumMake(const AFrustum: TFrustum; const ANearDist, AFarDist, AFieldOfViewRadians: Single; const ACameraPosition, ALookVector: TAffineVector ): TExtendedFrustum;

Types

TCullingMode = (...);
TSectorNodeArray = array [0 .. 7] of TSectorNode;
TGrowMethod = (...);

Constants

COctree_LEAF_TRHESHOLD = 30;
COctree_MAX_TREE_DEPTH = 8;
COctree_GROW_GRAVY = 0.1;

Description

Functions and Procedures

function ConeContainsBSphere(const Cone: TSPCone; BSphere: TBSphere) : TSpaceContains;
function ExtendedFrustumIntersectsBSphere(const AExtendedFrustum : TExtendedFrustum; ABSphere: TBSphere): Boolean;
function ExtendedFrustumMake(const AFrustum: TFrustum; const ANearDist, AFarDist, AFieldOfViewRadians: Single; const ACameraPosition, ALookVector: TAffineVector ): TExtendedFrustum;

Types

TCullingMode = (...);
Values
  • CmFineCulling:
  • CmGrossCulling:
TSectorNodeArray = array [0 .. 7] of TSectorNode;
TGrowMethod = (...);
Values
  • GmNever:
  • GmBestFit:
  • GmIncreaseToFitAll:

Constants

COctree_LEAF_TRHESHOLD = 30;
COctree_MAX_TREE_DEPTH = 8;
COctree_GROW_GRAVY = 0.1;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: SpatialPartitioning: record TSPCone

record TSPCone

Unit

SpatialPartitioning

Declaration

type TSPCone = record

Description

Overview

Fields

Base: TAffineVector;
Axis: TAffineVector;
Angle: Single;
Length: Single;

Description

Fields

Base: TAffineVector;
Axis: TAffineVector;
Angle: Single;
Length: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: SpatialPartitioning: record TExtendedFrustum

record TExtendedFrustum

Unit

SpatialPartitioning

Declaration

type TExtendedFrustum = record

Description

Overview

Fields

Frustum: TFrustum;
BSphere: TBSphere;

Description

Fields

Frustum: TFrustum;
BSphere: TBSphere;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: SpatialPartitioning: Class TSpacePartitionLeaf

Class TSpacePartitionLeaf

Unit

SpatialPartitioning

Declaration

type TSpacePartitionLeaf = class(TPersistentObject)

Description

no description available, TPersistentObject description follows

Base class for persistent objects.<p> The base requirement is implementation of ReadFromFiler & WriteToFiler in sub-classes, the immediate benefits are support of streaming (to stream, file or string), assignment and cloning.<br> The other requirement being the use of a virtual constructor, which allows polymorphic construction (don't forget to register your subclasses).<p> Note that TPersistentObject implements IUnknown, but does *not* implement reference counting.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSpacePartitionLeaf

Overview

Fields

Public | FPartitionTag: Pointer;
Public | FCachedAABB: TAABB;
Public | FCachedBSphere: TBSphere;

Methods

Public | constructor CreateOwned(SpacePartition: TBaseSpacePartition);
Public | destructor Destroy; override;
Public | procedure Changed; virtual;
Public | procedure UpdateCachedAABBAndBSphere; virtual;

Properties

Public | property PartitionTag: Pointer read FPartitionTag;
Public | property SpacePartition: TBaseSpacePartition read FSpacePartition write SetSpacePartition;

Description

Fields

Public FPartitionTag: Pointer;
Public FCachedAABB: TAABB;
Public FCachedBSphere: TBSphere;

Methods

Public constructor CreateOwned(SpacePartition: TBaseSpacePartition);
Public destructor Destroy; override;
Public procedure Changed; virtual;
Public procedure UpdateCachedAABBAndBSphere; virtual;

Properties

Public property PartitionTag: Pointer read FPartitionTag;
Public property SpacePartition: TBaseSpacePartition read FSpacePartition write SetSpacePartition;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: SpatialPartitioning: Class TSpacePartitionLeafList

Class TSpacePartitionLeafList

Unit

SpatialPartitioning

Declaration

type TSpacePartitionLeafList = class(TPersistentObjectList)

Description

no description available, TPersistentObjectList description follows

A persistent Object list.<p> Similar to TList but works on TObject items and has facilities for persistence of contained data. Unlike the VCL's TObjectList, this one does NOT free its objects upon destruction or Clear, use Clean and CleanFree for that, and as such can be used for object referral lists too.<br> But only TPersistentObject items will be streamed appropriately.<p> The list can be used in a stack-like fashion with Push & Pop, and can perform basic boolean set operations.<p> Note: the IndexOf implementation is up to 3 times faster than that of TList

Hierarchy

  • TPersistent
  • TPersistentObject
  • TPersistentObjectList
  • TSpacePartitionLeafList

Overview

Methods

Public constructor Create; override;

Properties

Public property Items[I: Integer]: TSpacePartitionLeaf read GetItems write SetItems;

Description

Methods

Public constructor Create; override;

Properties

Public property Items[I: Integer]: TSpacePartitionLeaf read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: SpatialPartitioning: Class TBaseSpacePartition

Class TBaseSpacePartition

Unit

SpatialPartitioning

Declaration

type TBaseSpacePartition = class(TPersistentObject)

Description

no description available, TPersistentObject description follows

Base class for persistent objects.<p> The base requirement is implementation of ReadFromFiler & WriteToFiler in sub-classes, the immediate benefits are support of streaming (to stream, file or string), assignment and cloning.<br> The other requirement being the use of a virtual constructor, which allows polymorphic construction (don't forget to register your subclasses).<p> Note that TPersistentObject implements IUnknown, but does *not* implement reference counting.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseSpacePartition

Overview

Fields

Protected | FQueryResult: TSpacePartitionLeafList;
Protected | FQueryInterObjectTests: Integer;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function QueryAABB(const AAABB: TAABB): Integer; virtual;
Public | function QueryBSphere(const ABSphere: TBSphere): Integer; virtual;
Public | function QueryFrustum(const Frustum: TFrustum): Integer; virtual;
Public | function QueryFrustumEx(const ExtendedFrustum: TExtendedFrustum) : Integer; virtual;
Public | function QueryLeaf(const ALeaf: TSpacePartitionLeaf): Integer; virtual;
Public | function QueryPlane(const Location, Normal: TAffineVector) : Integer; virtual;
Public | procedure AddLeaf(ALeaf: TSpacePartitionLeaf); virtual;
Public | procedure Clear; virtual;
Public | procedure LeafChanged(ALeaf: TSpacePartitionLeaf); virtual;
Public | procedure ProcessUpdated; virtual;
Public | procedure RemoveLeaf(ALeaf: TSpacePartitionLeaf); virtual;
Protected | procedure FlushQueryResult; virtual;

Properties

Public | property CullingMode: TCullingMode read FCullingMode write FCullingMode;
Public | property QueryInterObjectTests: Integer read FQueryInterObjectTests;
Public | property QueryResult: TSpacePartitionLeafList read FQueryResult;

Description

Fields

Protected FQueryResult: TSpacePartitionLeafList;
Protected FQueryInterObjectTests: Integer;

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function QueryAABB(const AAABB: TAABB): Integer; virtual;
Public function QueryBSphere(const ABSphere: TBSphere): Integer; virtual;
Public function QueryFrustum(const Frustum: TFrustum): Integer; virtual;
Public function QueryFrustumEx(const ExtendedFrustum: TExtendedFrustum) : Integer; virtual;
Public function QueryLeaf(const ALeaf: TSpacePartitionLeaf): Integer; virtual;
Public function QueryPlane(const Location, Normal: TAffineVector) : Integer; virtual;
Public procedure AddLeaf(ALeaf: TSpacePartitionLeaf); virtual;
Public procedure Clear; virtual;
Public procedure LeafChanged(ALeaf: TSpacePartitionLeaf); virtual;
Public procedure ProcessUpdated; virtual;
Public procedure RemoveLeaf(ALeaf: TSpacePartitionLeaf); virtual;
Protected procedure FlushQueryResult; virtual;

Properties

Public property CullingMode: TCullingMode read FCullingMode write FCullingMode;
Public property QueryInterObjectTests: Integer read FQueryInterObjectTests;
Public property QueryResult: TSpacePartitionLeafList read FQueryResult;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: SpatialPartitioning: Class TLeavedSpacePartition

Class TLeavedSpacePartition

Unit

SpatialPartitioning

Declaration

type TLeavedSpacePartition = class(TBaseSpacePartition)

Description

no description available, TBaseSpacePartition description follows
no description available, TPersistentObject description follows

Base class for persistent objects.<p> The base requirement is implementation of ReadFromFiler & WriteToFiler in sub-classes, the immediate benefits are support of streaming (to stream, file or string), assignment and cloning.<br> The other requirement being the use of a virtual constructor, which allows polymorphic construction (don't forget to register your subclasses).<p> Note that TPersistentObject implements IUnknown, but does *not* implement reference counting.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseSpacePartition
  • TLeavedSpacePartition

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function QueryAABB(const AAABB: TAABB): Integer; override;
Public | function QueryBSphere(const ABSphere: TBSphere): Integer; override;
Public | function QueryPlane(const FLocation, FNormal: TAffineVector) : Integer; override;
Public | procedure AddLeaf(ALeaf: TSpacePartitionLeaf); override;
Public | procedure Clear; override;
Public | procedure RemoveLeaf(ALeaf: TSpacePartitionLeaf); override;

Properties

Published property Leaves: TSpacePartitionLeafList read FLeaves;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function QueryAABB(const AAABB: TAABB): Integer; override;
Public function QueryBSphere(const ABSphere: TBSphere): Integer; override;
Public function QueryPlane(const FLocation, FNormal: TAffineVector) : Integer; override;
Public procedure AddLeaf(ALeaf: TSpacePartitionLeaf); override;
Public procedure Clear; override;
Public procedure RemoveLeaf(ALeaf: TSpacePartitionLeaf); override;

Properties

Published property Leaves: TSpacePartitionLeafList read FLeaves;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: SpatialPartitioning: Class TSectorNode

Class TSectorNode

Unit

SpatialPartitioning

Declaration

type TSectorNode = class(TObject)

Description

Hierarchy

  • TObject
  • TSectorNode

Overview

Methods

Public | constructor Create(ASectoredSpacePartition: TSectoredSpacePartition; AParent: TSectorNode);
Public | destructor Destroy; override;
Public | function AABBContainsSector(const AABB: TAABB): TSpaceContains; virtual;
Public | function AABBFitsInNode(const AAABB: TAABB): Boolean; virtual;
Public | function AABBIntersectsNode(const AAABB: TAABB): Boolean; virtual;
Public | function AddLeaf(ALeaf: TSpacePartitionLeaf): TSectorNode;
Public | function BSphereContainsSector(const BSphere: TBSphere) : TSpaceContains; virtual;
Public | function BSphereFitsInNode(const BSphere: TBSphere): Boolean; virtual;
Public | function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; virtual;
Public | function ContainsAABB(const AAABB: TAABB): TSpaceContains; virtual;
Public | function ContainsBSphere(const ABSphere: TBSphere): TSpaceContains; virtual;
Public | function GetChildForAABB(AABB: TAABB): TSectorNode; virtual;
Public | function GetNodeCount: Integer;
Public | function RemoveLeaf(ALeaf: TSpacePartitionLeaf; OwnerByThis: Boolean): Boolean;
Protected | function CalcRecursiveLeafCount: Integer;
Protected | function PlaceLeafInChild(ALeaf: TSpacePartitionLeaf): TSectorNode;
Protected | function VerifyRecursiveLeafCount: string;
Public | procedure AddAllLeavesRecursive(const QueryResult: TSpacePartitionLeafList);
Public | procedure Clear;
Public | procedure CollapseNode;
Public | procedure CreateChildren; virtual;
Public | procedure ExpandNode;
Public | procedure QueryAABB(const AAABB: TAABB; const QueryResult: TSpacePartitionLeafList);
Public | procedure QueryBSphere(const ABSphere: TBSphere; const QueryResult: TSpacePartitionLeafList);
Public | procedure QueryFrustum(const Frustum: TFrustum; const QueryResult: TSpacePartitionLeafList);
Public | procedure QueryFrustumEx(const ExtendedFrustum: TExtendedFrustum; const QueryResult: TSpacePartitionLeafList);
Public | procedure QueryPlane(const Location, Normal: TAffineVector; const QueryResult: TSpacePartitionLeafList);
Protected | procedure ChildrenChanged; virtual;

Properties

Public | property AABB: TAABB read FAABB write SetAABB;
Public | property BSphere: TBSphere read FBSphere;
Public | property Center: TAffineVector read GetCenter;
Public | property ChildCount: Integer read FChildCount;
Public | property Children: TSectorNodeArray read FChildren;
Public | property Leaves: TSpacePartitionLeafList read FLeaves;
Public | property NoChildren: Boolean read GetNoChildren;
Public | property NodeDepth: Integer read FNodeDepth;
Public | property Parent: TSectorNode read FParent;
Public | property RecursiveLeafCount: Integer read FRecursiveLeafCount;
Public | property SectoredSpacePartition: TSectoredSpacePartition read FSectoredSpacePartition;

Description

Methods

Public constructor Create(ASectoredSpacePartition: TSectoredSpacePartition; AParent: TSectorNode);
Public destructor Destroy; override;
Public function AABBContainsSector(const AABB: TAABB): TSpaceContains; virtual;
Public function AABBFitsInNode(const AAABB: TAABB): Boolean; virtual;
Public function AABBIntersectsNode(const AAABB: TAABB): Boolean; virtual;
Public function AddLeaf(ALeaf: TSpacePartitionLeaf): TSectorNode;
Public function BSphereContainsSector(const BSphere: TBSphere) : TSpaceContains; virtual;
Public function BSphereFitsInNode(const BSphere: TBSphere): Boolean; virtual;
Public function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; virtual;
Public function ContainsAABB(const AAABB: TAABB): TSpaceContains; virtual;
Public function ContainsBSphere(const ABSphere: TBSphere): TSpaceContains; virtual;
Public function GetChildForAABB(AABB: TAABB): TSectorNode; virtual;
Public function GetNodeCount: Integer;
Public function RemoveLeaf(ALeaf: TSpacePartitionLeaf; OwnerByThis: Boolean): Boolean;
Protected function CalcRecursiveLeafCount: Integer;
Protected function PlaceLeafInChild(ALeaf: TSpacePartitionLeaf): TSectorNode;
Protected function VerifyRecursiveLeafCount: string;
Public procedure AddAllLeavesRecursive(const QueryResult: TSpacePartitionLeafList);
Public procedure Clear;
Public procedure CollapseNode;
Public procedure CreateChildren; virtual;
Public procedure ExpandNode;
Public procedure QueryAABB(const AAABB: TAABB; const QueryResult: TSpacePartitionLeafList);
Public procedure QueryBSphere(const ABSphere: TBSphere; const QueryResult: TSpacePartitionLeafList);
Public procedure QueryFrustum(const Frustum: TFrustum; const QueryResult: TSpacePartitionLeafList);
Public procedure QueryFrustumEx(const ExtendedFrustum: TExtendedFrustum; const QueryResult: TSpacePartitionLeafList);
Public procedure QueryPlane(const Location, Normal: TAffineVector; const QueryResult: TSpacePartitionLeafList);
Protected procedure ChildrenChanged; virtual;

Properties

Public property AABB: TAABB read FAABB write SetAABB;
Public property BSphere: TBSphere read FBSphere;
Public property Center: TAffineVector read GetCenter;
Public property ChildCount: Integer read FChildCount;
Public property Children: TSectorNodeArray read FChildren;
Public property Leaves: TSpacePartitionLeafList read FLeaves;
Public property NoChildren: Boolean read GetNoChildren;
Public property NodeDepth: Integer read FNodeDepth;
Public property Parent: TSectorNode read FParent;
Public property RecursiveLeafCount: Integer read FRecursiveLeafCount;
Public property SectoredSpacePartition: TSectoredSpacePartition read FSectoredSpacePartition;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: SpatialPartitioning: Class TSectoredSpacePartition

Class TSectoredSpacePartition

Unit

SpatialPartitioning

Declaration

type TSectoredSpacePartition = class(TLeavedSpacePartition)

Description

no description available, TLeavedSpacePartition description follows
no description available, TBaseSpacePartition description follows
no description available, TPersistentObject description follows

Base class for persistent objects.<p> The base requirement is implementation of ReadFromFiler & WriteToFiler in sub-classes, the immediate benefits are support of streaming (to stream, file or string), assignment and cloning.<br> The other requirement being the use of a virtual constructor, which allows polymorphic construction (don't forget to register your subclasses).<p> Note that TPersistentObject implements IUnknown, but does *not* implement reference counting.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseSpacePartition
  • TLeavedSpacePartition
  • TSectoredSpacePartition

Overview

Fields

Protected FQueryNodeTests: Integer;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function CreateNewNode(AParent: TSectorNode): TSectorNode; virtual;
Public | function GetAABB: TAABB;
Public | function GetNodeCount: Integer;
Public | function QueryAABB(const AAABB: TAABB): Integer; override;
Public | function QueryBSphere(const ABSphere: TBSphere): Integer; override;
Public | function QueryFrustum(const Frustum: TFrustum): Integer; override;
Public | function QueryFrustumEx(const ExtendedFrustum: TExtendedFrustum) : Integer; override;
Public | function QueryLeaf(const ALeaf: TSpacePartitionLeaf): Integer; override;
Public | function QueryPlane(const Location, Normal: TAffineVector) : Integer; override;
Public | procedure AddLeaf(ALeaf: TSpacePartitionLeaf); override;
Public | procedure Clear; override;
Public | procedure LeafChanged(ALeaf: TSpacePartitionLeaf); override;
Public | procedure RebuildTree(const NewAABB: TAABB);
Public | procedure RemoveLeaf(ALeaf: TSpacePartitionLeaf); override;
Public | procedure UpdateStructureSize(Gravy: Single);
Protected | procedure FlushQueryResult; override;

Properties

Published | property GrowGravy: Single read FGrowGravy write FGrowGravy;
Published | property GrowMethod: TGrowMethod read FGrowMethod write FGrowMethod;
Published | property LeafThreshold: Integer read FLeafThreshold write SetLeafThreshold;
Published | property MaxTreeDepth: Integer read FMaxTreeDepth write SetMaxTreeDepth;
Public | property QueryNodeTests: Integer read FQueryNodeTests;
Published | property RootNode: TSectorNode read FRootNode;

Description

Fields

Protected FQueryNodeTests: Integer;

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function CreateNewNode(AParent: TSectorNode): TSectorNode; virtual;
Public function GetAABB: TAABB;
Public function GetNodeCount: Integer;
Public function QueryAABB(const AAABB: TAABB): Integer; override;
Public function QueryBSphere(const ABSphere: TBSphere): Integer; override;
Public function QueryFrustum(const Frustum: TFrustum): Integer; override;
Public function QueryFrustumEx(const ExtendedFrustum: TExtendedFrustum) : Integer; override;
Public function QueryLeaf(const ALeaf: TSpacePartitionLeaf): Integer; override;
Public function QueryPlane(const Location, Normal: TAffineVector) : Integer; override;
Public procedure AddLeaf(ALeaf: TSpacePartitionLeaf); override;
Public procedure Clear; override;
Public procedure LeafChanged(ALeaf: TSpacePartitionLeaf); override;
Public procedure RebuildTree(const NewAABB: TAABB);
Public procedure RemoveLeaf(ALeaf: TSpacePartitionLeaf); override;
Public procedure UpdateStructureSize(Gravy: Single);
Protected procedure FlushQueryResult; override;

Properties

Published property GrowGravy: Single read FGrowGravy write FGrowGravy;
Published property GrowMethod: TGrowMethod read FGrowMethod write FGrowMethod;
Published property LeafThreshold: Integer read FLeafThreshold write SetLeafThreshold;
Published property MaxTreeDepth: Integer read FMaxTreeDepth write SetMaxTreeDepth;
Public property QueryNodeTests: Integer read FQueryNodeTests;
Published property RootNode: TSectorNode read FRootNode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: SpatialPartitioning: Class TSPOctreeNode

Class TSPOctreeNode

Unit

SpatialPartitioning

Declaration

type TSPOctreeNode = class(TSectorNode)

Description

no description available, TSectorNode description follows

Hierarchy

  • TObject
  • TSectorNode
  • TSPOctreeNode

Overview

Methods

Public | function AABBFitsInNode(const AAABB: TAABB): Boolean; override;
Public | function AABBIntersectsNode(const AAABB: TAABB): Boolean; override;
Public | function BSphereFitsInNode(const BSphere: TBSphere): Boolean; override;
Public | function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; override;
Public | procedure CreateChildren; override;

Description

Methods

Public function AABBFitsInNode(const AAABB: TAABB): Boolean; override;
Public function AABBIntersectsNode(const AAABB: TAABB): Boolean; override;
Public function BSphereFitsInNode(const BSphere: TBSphere): Boolean; override;
Public function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; override;
Public procedure CreateChildren; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: SpatialPartitioning: Class TOctreeSpacePartition

Class TOctreeSpacePartition

Unit

SpatialPartitioning

Declaration

type TOctreeSpacePartition = class(TSectoredSpacePartition)

Description

no description available, TSectoredSpacePartition description follows
no description available, TLeavedSpacePartition description follows
no description available, TBaseSpacePartition description follows
no description available, TPersistentObject description follows

Base class for persistent objects.<p> The base requirement is implementation of ReadFromFiler & WriteToFiler in sub-classes, the immediate benefits are support of streaming (to stream, file or string), assignment and cloning.<br> The other requirement being the use of a virtual constructor, which allows polymorphic construction (don't forget to register your subclasses).<p> Note that TPersistentObject implements IUnknown, but does *not* implement reference counting.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseSpacePartition
  • TLeavedSpacePartition
  • TSectoredSpacePartition
  • TOctreeSpacePartition

Overview

Methods

Public | function CreateNewNode(AParent: TSectorNode): TSectorNode; override;
Public | procedure SetSize(const Min, Max: TAffineVector);

Description

Methods

Public function CreateNewNode(AParent: TSectorNode): TSectorNode; override;
Public procedure SetSize(const Min, Max: TAffineVector);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: SpatialPartitioning: Class TSPQuadtreeNode

Class TSPQuadtreeNode

Unit

SpatialPartitioning

Declaration

type TSPQuadtreeNode = class(TSPOctreeNode)

Description

no description available, TSPOctreeNode description follows
no description available, TSectorNode description follows

Hierarchy

  • TObject
  • TSectorNode
  • TSPOctreeNode
  • TSPQuadtreeNode

Overview

Methods

Public | function AABBFitsInNode(const AAABB: TAABB): Boolean; override;
Public | function AABBIntersectsNode(const AAABB: TAABB): Boolean; override;
Public | function BSphereFitsInNode(const BSphere: TBSphere): Boolean; override;
Public | function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; override;
Public | function GetChildForAABB(AABB: TAABB): TSectorNode; override;
Public | procedure CreateChildren; override;
Protected | procedure ChildrenChanged; override;

Description

Methods

Public function AABBFitsInNode(const AAABB: TAABB): Boolean; override;
Public function AABBIntersectsNode(const AAABB: TAABB): Boolean; override;
Public function BSphereFitsInNode(const BSphere: TBSphere): Boolean; override;
Public function BSphereIntersectsNode(const BSphere: TBSphere): Boolean; override;
Public function GetChildForAABB(AABB: TAABB): TSectorNode; override;
Public procedure CreateChildren; override;
Protected procedure ChildrenChanged; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: SpatialPartitioning: Class TQuadtreeSpacePartition

Class TQuadtreeSpacePartition

Unit

SpatialPartitioning

Declaration

type TQuadtreeSpacePartition = class(TSectoredSpacePartition)

Description

no description available, TSectoredSpacePartition description follows
no description available, TLeavedSpacePartition description follows
no description available, TBaseSpacePartition description follows
no description available, TPersistentObject description follows

Base class for persistent objects.<p> The base requirement is implementation of ReadFromFiler & WriteToFiler in sub-classes, the immediate benefits are support of streaming (to stream, file or string), assignment and cloning.<br> The other requirement being the use of a virtual constructor, which allows polymorphic construction (don't forget to register your subclasses).<p> Note that TPersistentObject implements IUnknown, but does *not* implement reference counting.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseSpacePartition
  • TLeavedSpacePartition
  • TSectoredSpacePartition
  • TQuadtreeSpacePartition

Overview

Methods

Public | function CreateNewNode(AParent: TSectorNode): TSectorNode; override;
Public | procedure SetSize(const Min, Max: TAffineVector);

Description

Methods

Public function CreateNewNode(AParent: TSectorNode): TSectorNode; override;
Public procedure SetSize(const Min, Max: TAffineVector);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Spline

Unit Spline

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Spline<p>

Cubic spline interpolation functions<p>

<b>History : </b><font size=-1><ul> <li>30/12/12 - PW - Restored CPP compatibility with record arrays <li>08/07/04 - LR - Removed ../ from the GLScene.inc <li>16/07/02 - Egg - Added methods to access slope per axis <li>28/05/00 - Egg - Javadocisation, minor changes & optimizations, Renamed TSpline to TCubicSpline, added W component and a bunch of helper methods <li>20/05/00 - RoC - Created, based on the C source code from Eric </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TCubicSpline |

Types

TCubicSplineMatrix = array of array [0..3] of Single;

Description

Types

TCubicSplineMatrix = array of array [0..3] of Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Spline: Class TCubicSpline

Class TCubicSpline

Unit

Spline

Declaration

type TCubicSpline = class(TObject)

Description

3D cubic spline handler class.<p> This class allows to describe and calculate values of a time-based, three-dimensionnal cubic spline.<p> Cubic spline pass through all given points and tangent on point N is given by the (N-1) to (N+1) vector.<p> Note : X, Y & Z are actually interpolated independently.

Hierarchy

  • TObject
  • TCubicSpline

Overview

Methods

Public | constructor Create(const X, Y, Z, W : PFloatArray; const nb : Integer);
Public | destructor Destroy; override;
Public | function SplineAffineVector(const t : single) : TAffineVector; overload;
Public | function SplineIntersecXY(Z: Single; var X, Y: Single): Boolean;
Public | function SplineIntersecXZ(Y: Single; var X, Z: Single): Boolean;
Public | function SplineIntersecYZ(X: Single; var Y, Z: Single): Boolean;
Public | function SplineSlopeVector(const t : single) : TAffineVector; overload;
Public | function SplineSlopeW(const t : single): Single;
Public | function SplineSlopeX(const t : Single): Single;
Public | function SplineSlopeY(const t : single): Single;
Public | function SplineSlopeZ(const t : single): Single;
Public | function SplineVector(const t : single) : TVector; overload;
Public | function SplineW(const t : single): Single;
Public | function SplineX(const t : Single): Single;
Public | function SplineY(const t : single): Single;
Public | function SplineZ(const t : single): Single;
Public | procedure SplineAffineVector(const t : single; var vector : TAffineVector); overload;
Public | procedure SplineVector(const t : single; var vector : TVector); overload;
Public | procedure SplineXY(const t : single; var X, Y : Single);
Public | procedure SplineXYZ(const t : single; var X, Y, Z : Single);
Public | procedure SplineXYZW(const t : single; var X, Y, Z, W : Single);

Description

Methods

Public constructor Create(const X, Y, Z, W : PFloatArray; const nb : Integer);

Creates the spline and declares interpolation points.<p> Time references go from 0 (first point) to nb-1 (last point), the first and last reference matrices respectively are used when T is used beyond this range.<p> Note : "nil" single arrays are accepted, in this case the axis is disabled and calculus will return 0 (zero) for this component.

Public destructor Destroy; override;
Public function SplineAffineVector(const t : single) : TAffineVector; overload;

Calculates affine vector at time t.<p>

Public function SplineIntersecXY(Z: Single; var X, Y: Single): Boolean;

Calculates the intersection of the spline with the XY plane.<p> Returns True if an intersection was found.

Public function SplineIntersecXZ(Y: Single; var X, Z: Single): Boolean;

Calculates the intersection of the spline with the XZ plane.<p> Returns True if an intersection was found.

Public function SplineIntersecYZ(X: Single; var Y, Z: Single): Boolean;

Calculates the intersection of the spline with the YZ plane.<p> Returns True if an intersection was found.

Public function SplineSlopeVector(const t : single) : TAffineVector; overload;

Calculates the spline slope at time t.

Public function SplineSlopeW(const t : single): Single;

Calculates W component slope at time t.<p>

Public function SplineSlopeX(const t : Single): Single;

Calculates X component slope at time t.<p>

Public function SplineSlopeY(const t : single): Single;

Calculates Y component slope at time t.<p>

Public function SplineSlopeZ(const t : single): Single;

Calculates Z component slope at time t.<p>

Public function SplineVector(const t : single) : TVector; overload;

Calculates vector at time t.<p>

Public function SplineW(const t : single): Single;

Calculates W component at time t.<p>

Public function SplineX(const t : Single): Single;

Calculates X component at time t.<p>

Public function SplineY(const t : single): Single;

Calculates Y component at time t.<p>

Public function SplineZ(const t : single): Single;

Calculates Z component at time t.<p>

Public procedure SplineAffineVector(const t : single; var vector : TAffineVector); overload;

Calculates affine vector at time t.<p>

Public procedure SplineVector(const t : single; var vector : TVector); overload;

Calculates vector at time t.<p>

Public procedure SplineXY(const t : single; var X, Y : Single);

Calculates X and Y components at time t.<p>

Public procedure SplineXYZ(const t : single; var X, Y, Z : Single);

Calculates X, Y and Z components at time t.<p>

Public procedure SplineXYZW(const t : single; var X, Y, Z, W : Single);

Calculates X, Y, Z and W components at time t.<p>

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: TGA

Unit TGA

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

TGA<p>

Simple TGA formats supports for Delphi.<br> Currently supports only 24 and 32 bits RGB formats (uncompressed and RLE compressed).<p>

Based on David McDuffee's document from www.wotsit.org<p>

<b>History : </b><font size=-1><ul> <li>07/03/11 - Yar - Removed LazTGA, added workaround of ScanLine for Lazarus <li>20/04/10 - Yar - Removed registration for FPC (thanks to Rustam Asmandiarov aka Predator) <li>07/01/10 - DaStr - TTGAImage is now replaced by LazTGA.TTGAImage in Lazarus (thanks Predator) <li>08/07/04 - LR - Uses of Graphics replaced by GLCrossPlatform for Linux <li>21/11/02 - Egg - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TTGAImage |
Class ETGAException |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: TGA: Class TTGAImage

Class TTGAImage

Unit

TGA

Declaration

type TTGAImage = class(TGLBitmap)

Description

TGA image load/save capable class for Delphi.<p> TGA formats supported : 24 and 32 bits uncompressed or RLE compressed, saves only to uncompressed TGA.

Hierarchy

  • TTGAImage

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | procedure LoadFromStream(stream : TStream); override;
Public | procedure SaveToStream(stream : TStream); override;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public procedure LoadFromStream(stream : TStream); override;
Public procedure SaveToStream(stream : TStream); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: TGA: Class ETGAException

Class ETGAException

Unit

TGA

Declaration

type ETGAException = class(Exception)

Description

Hierarchy

  • Exception
  • ETGAException
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS

Unit Types3DS

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TPoint3DS |
record TFColor3DS |
packed record TFace3DS |
record TTexVert3DS |
record TTrackHeader3DS |
record TKeyHeader3DS |
record TKFRotKey3DS |
record TChunkListEntry3DS |
record TChunkList3DS |
record TNodeList |
record TDatabase3DS |
record TViewSize3DS |
record TOrthoView3DS |
record TUserView3DS |
record TViewport3DS |
record TShadowSets3DS |
record TMeshSet3DS |
record TFogSettings3DS |
record TLayerFogSettings3DS |
record TDCueSettings3DS |
record TAtmosphere3DS |
record TVGradientBgnd3DS |
record TBackground3DS |
record TACubic3DS |
record TBitmap3DS |
record TMapSet3DS |
record TRMapSet3DS |
record TMaterial3DS |
record TMapInfo3DS |
record TObjMat3DS |
record TMesh3DS |
record TSpotShadow3DS |
record TSpotCone3DS |
record TSpotProjector3DS |
record TSpotLight3DS |
record TLiteAttenuate3DS |
record TLight3DS |
record TCamRanges3DS |
record TCamera3DS |
record TKFKeyInfo3DS |
record TKFSegment3DS |
record TKFSets3DS |
record TKFCamera3DS |
record TKFAmbient3DS |
record TKFMesh3DS |
record TKFOmni3DS |
record TKFSpot3DS |
record TXDataRaw3DS |
record TColorF |
record TColor24 |
record TFog |
record TLayerFog |
record TDistanceCue |
record TViewStandard |
record TViewUser |
record TMatAcubic |
record TIpasData |
record TPointArray |
record TPointFlagArray |
record TFaceArray |
record TMshMatGroup |
record TSmoothGroup |
record TTexVerts |
record TMeshTextureInfo |
record TDlSpotlight |
record TDlLocalShadow2 |
record TNCamera |
record TCamRanges |
record TViewportLayout |
record TViewportSize |
record TViewportData |
record TKFHdr |
record TKFSeg |
record TNodeHdr |
record TBoundBox |
record TPosTrackTag |
record TColTrackTag |
record TRotTrackTag |
record TScaleTrackTag |
record TMorphTrackTag |
record THideTrackTag |
record TFovTrackTag |
record TRollTrackTag |
record THotTrackTag |
record TFallTrackTag |
record TXDataEntry |
record TChunkData |
record TChunk3DS |

Types

TDumpLevel = (...);
PChar3DS = PAnsiChar;
String3DS = AnsiString;
String64 = string[64];
PWordList = ˆTWordList;
TWordList = array[0..MaxInt div (2*SizeOf(Word))] of Word;
PIntegerArray = ˆTIntegerArray;
TIntegerArray = array[0..MaxInt div (2*SizeOf(Integer))] of Integer;
PCardinalArray = ˆTCardinalArray;
TCardinalArray = array[0..MaxInt div (2*SizeOf(Cardinal))] of Cardinal;
PSingleList = ˆTSingleList;
TSingleList = array[0..MaxInt div (2*SizeOf(Single))] of Single;
PPoint3DS = ˆTPoint3DS;
PPointList = ˆTPointList;
TPointList = array[0..MaxInt div (2*SizeOf(TPoint3DS))] of TPoint3DS;
PFColor3DS = ˆTFColor3DS;
PFColorList = ˆTFColorList;
TFColorList = array[0..MaxInt div (2*SizeOf(TFColor3DS))] of TFColor3DS;
PFace3DS = ˆTFace3DS;
PFaceList = ˆTFaceList;
TFaceList = array[0..MaxInt div (2*SizeOf(TFace3DS))] of TFace3DS;
PTexVert3DS = ˆTTexVert3DS;
PTexVertList = ˆTTexVertList;
TTexVertList = array[0..MaxInt div (2*SizeOf(TTexVert3DS))] of TTexVert3DS;
PTrackHeader3DS = ˆTTrackHeader3DS;
PKeyHeader3DS = ˆTKeyHeader3DS;
PKeyHeaderList = ˆTKeyHeaderList;
TKeyHeaderList = array[0..MaxInt div (2*SizeOf(TKeyHeader3DS))] of TKeyHeader3DS;
PKFRotKey3DS = ˆTKFRotKey3DS;
PKFRotKeyList = ˆTKFRotKeyList;
TKFRotKeyList = array[0..MaxInt div (2*SizeOf(TKFRotKey3DS))] of TKFRotKey3DS;
PKFMorphKey3DS = ˆTKFMorphKey3DS;
TKFMorphKey3DS = String;
PKFMorphKeyList = ˆTKFMorphKeyList;
TKFMorphKeyList = array[0..MaxInt div (2*SizeOf(TKFMorphKey3DS))] of TKFMorphKey3DS;
PChunk3DS = ˆTChunk3DS;
PChunkListEntry3DS = ˆTChunkListEntry3DS;
PChunkList = ˆTChunkList;
TChunkList = array[0..MaxInt div (2*SizeOf(TChunkListEntry3DS))] of TChunkListEntry3DS;
PChunkList3DS = ˆTChunkList3DS;
TDBType3DS = (...);
PNodeList = ˆTNodeList;
PDatabase3DS = ˆTDatabase3DS;
TViewType3DS = (...);
PViewSize3DS = ˆTViewSize3DS;
POrthoView3DS = ˆTOrthoView3DS;
PUserView3DS = ˆTUserView3DS;
PViewport3DS = ˆTViewport3DS;
TShadowStyle3DS = (...);
PShadowSets3DS = ˆTShadowSets3DS;
PMeshSet3DS = ˆTMeshSet3DS;
TAtmosphereType3DS = (...);
TLayerFogFalloff3DS = (...);
PFogSettings3DS = ˆTFogSettings3DS;
PLayerFogSettings3DS = ˆTLayerFogSettings3DS;
PDCueSettings3DS = ˆTDCueSettings3DS;
PAtmosphere3DS = ˆTAtmosphere3DS;
TBackgroundType3DS = (...);
PBitmapBgnd3DS = ˆTBitmapBgnd3DS;
TBitmapBgnd3DS = AnsiString;
TSolidBgnd3DS = TFColor3DS;
PVGradientBgnd3DS = ˆTVGradientBgnd3DS;
PBackground3DS = ˆTBackground3DS;
TShadeType3DS = (...);
TTileType3DS = (...);
TFilterType3DS = (...);
TTintType3DS = (...);
PACubic3DS = ˆTACubic3DS;
PBitmap3DS = ˆTBitmap3DS;
PMapSet3DS = ˆTMapSet3DS;
PMaterial3DS = ˆTMaterial3DS;
PMeshMatrix = ˆTMeshMatrix;
TMeshMatrix = array[0..11] of Single;
PMapInfo3DS = ˆTMapInfo3DS;
PObjMat3DS = ˆTObjMat3DS;
PObjMatList = ˆTObjMatList;
TObjMatList = array[0..MaxInt div (2*SizeOf(TObjMat3DS))] of TObjMat3DS;
PMesh3DS = ˆTMesh3DS;
TConeStyle3DS = (...);
PSpotShadow3DS = ˆTSpotShadow3DS;
PSpotCone3DS = ˆTSpotCone3DS;
PSpotProjector3DS = ˆTSpotProjector3DS;
PSpotLight3DS = ˆTSpotLight3DS;
PLiteAttenuate3DS = ˆTLiteAttenuate3DS;
PLight3DS = ˆTLight3DS;
PCamRanges3DS = ˆTCamRanges3DS;
PCamera3DS = ˆTCamera3DS;
PKFKeyInfo3DS = ˆTKFKeyInfo3DS;
PKFSegment3DS = ˆTKFSegment3DS;
PKFSets3DS = ˆTKFSets3DS;
PKFCamera3DS = ˆTKFCamera3DS;
PKFAmbient3DS = ˆTKFAmbient3DS;
PKFMesh3DS = ˆTKFMesh3DS;
PKFOmni3DS = ˆTKFOmni3DS;
PKFSpot3DS = ˆTKFSpot3DS;
PXDataRaw3DS = ˆTXDataRaw3DS;
TTargetType3DS = (...);
PM3dVersion = ˆTM3dVersion;
TM3dVersion = Cardinal;
PColorF = ˆTColorF;
PLinColorF = ˆTLinColorF;
TLinColorF = TColorF;
PColor24 = ˆTColor24;
PLinColor24 = ˆTLinColor24;
TLinColor24 = TColor24;
PMatMapRCol = ˆTMatMapRCol;
TMatMapRCol = TLinColor24;
PMatMapGCol = ˆTMatMapGCol;
TMatMapGCol = TMatMapRCol;
PMatMapBCol = ˆTMatMapBCol;
TMatMapBCol = TMatMapGCol;
PMatMapCol1 = ˆTMatMapCol1;
TMatMapCol1 = TMatMapBCol;
PMatMapCol2 = ˆTMatMapCol2;
TMatMapCol2 = TMatMapCol1;
PIntPercentage = ˆTIntPercentage;
TIntPercentage = SmallInt;
PMatBumpPercent = ˆTMatBumpPercent;
TMatBumpPercent = TIntPercentage;
PFloatPercentage = ˆTFloatPercentage;
TFloatPercentage = Single;
PMatMapname = PChar3DS;
PMeshVersion = ˆTMeshVersion;
TMeshVersion = Integer;
PMasterScale = ˆTMasterScale;
TMasterScale = Single;
PLoShadowBias = ˆTLoShadowBias;
TLoShadowBias = Single;
PHiShadowBias = ˆTHiShadowBias;
THiShadowBias = TLoShadowBias;
PRayBias = ˆTRayBias;
TRayBias = THiShadowBias;
PShadowMapSize = ˆTShadowMapSize;
TShadowMapSize = SmallInt;
PShadowSamples = ˆTShadowSamples;
TShadowSamples = SmallInt;
PShadowRange = ˆTShadowRange;
TShadowRange = Integer;
PShadowFilter = ˆTShadowFilter;
TShadowFilter = Single;
POConsts = ˆTOConsts;
TOConsts = TPoint3DS;
PBitMapName = PChar3DS;
PVGradient = ˆTVGradient;
TVGradient = Single;
PFog = ˆTFog;
PLayerFog = ˆTLayerFog;
PDistanceCue = ˆTDistanceCue;
PViewStandard = ˆTViewStandard;
PViewUser = ˆTViewUser;
PViewCamera = PChar3DS;
PMatName = PChar3DS;
PMatShading = ˆTMatShading;
TMatShading = SmallInt;
PMatAcubic = ˆTMatAcubic;
PIpasData = ˆTIpasData;
PMatWireSize = ˆTMatWireSize;
TMatWireSize = Single;
PMatMapTiling = ˆTMatMapTiling;
TMatMapTiling = Word;
PMatMapTexblur = ˆTMatMapTexblur;
TMatMapTexblur = Single;
PMatMapUScale = ˆTMatMapUScale;
TMatMapUScale = Single;
PMatMapVScale = ˆTMatMapVScale;
TMatMapVScale = TMatMapUScale;
PMatMapUOffset = ˆTMatMapUOffset;
TMatMapUOffset = Single;
PMatMapVOffset = ˆTMatMapVOffset;
TMatMapVOffset = TMatMapUOffset;
PMatMapAng = ˆTMatMapAng;
TMatMapAng = Single;
PNamedObject = PChar3DS;
PPointArray = ˆTPointArray;
PPointFlagArray = ˆTPointFlagArray;
PFaceArray = ˆTFaceArray;
PMshMatGroup = ˆTMshMatGroup;
PMshBoxmap = ˆTMshBoxmap;
TMshBoxmap = array[0..5] of AnsiString;
PSmoothGroup = ˆTSmoothGroup;
PTexVerts = ˆTTexVerts;
PMeshColor = ˆTMeshColor;
TMeshColor = Byte;
PMeshTextureInfo = ˆTMeshTextureInfo;
PProcName = PChar3DS;
PNDirectLight = ˆTNDirectLight;
TNDirectLight = TPoint3DS;
PDlExclude = PChar3DS;
PDlSpotlight = ˆTDlSpotlight;
PDlOuterRange = ˆTDlOuterRange;
TDlOuterRange = Single;
PDlInnerRange = ˆTDlInnerRange;
TDlInnerRange = TDlOuterRange;
PDlMultiplier = ˆTDlMultiplier;
TDlMultiplier = Single;
PDlSpotRoll = ˆTDlSpotRoll;
TDlSpotRoll = Single;
PDlSpotAspect = ˆTDlSpotAspect;
TDlSpotAspect = Single;
PDlSpotProjector = PChar3DS;
PDlRayBias = ˆTDlRayBias;
TDlRayBias = Single;
PDlLocalShadow2 = ˆTDlLocalShadow2;
PNCamera = ˆTNCamera;
PCamRanges = ˆTCamRanges;
PViewportLayout = ˆTViewportLayout;
PViewportSize = ˆTViewportSize;
PViewportData = ˆTViewportData;
PViewportData3 = ˆTViewportData3;
TViewportData3 = TViewportData;
PKFHdr = ˆTKFHdr;
PKFId = ˆTKFId;
TKFId = SmallInt;
PKFSeg = ˆTKFSeg;
PKFCurtime = ˆTKFCurtime;
TKFCurtime = Integer;
PNodeHdr = ˆTNodeHdr;
PPivot = ˆTPivot;
TPivot = TPoint3DS;
PInstanceName = PChar3DS;
PMorphSmooth = ˆTMorphSmooth;
TMorphSmooth = Single;
PBoundBox = ˆTBoundBox;
PPosTrackTag = ˆTPosTrackTag;
PColTrackTag = ˆTColTrackTag;
PRotTrackTag = ˆTRotTrackTag;
PScaleTrackTag = ˆTScaleTrackTag;
PMorphTrackTag = ˆTMorphTrackTag;
PHideTrackTag = ˆTHideTrackTag;
PFovTrackTag = ˆTFovTrackTag;
PRollTrackTag = ˆTRollTrackTag;
PHotTrackTag = ˆTHotTrackTag;
PFallTrackTag = ˆTFallTrackTag;
PXDataEntry = ˆTXDataEntry;
PXDataAppName = PChar3DS;
PXDataString = PChar3DS;
PXDataFloat = ˆTXDataFloat;
TXDataFloat = Single;
PXDataDouble = ˆTXDataDouble;
TXDataDouble = Double;
PXDataShort = ˆTXDataShort;
TXDataShort = SmallInt;
PXDataLong = ˆTXDataLong;
TXDataLong = Integer;
PXDataVoid = ˆTXDataVoid;
TXDataVoid = Pointer;
TReleaseLevel = (...);

Description

Types

TDumpLevel = (...);
Values
  • dlTerseDump:
  • dlMediumDump:
  • dlMaximumDump:
PChar3DS = PAnsiChar;
String3DS = AnsiString;
String64 = string[64];
PWordList = ˆTWordList;
TWordList = array[0..MaxInt div (2*SizeOf(Word))] of Word;
PIntegerArray = ˆTIntegerArray;
TIntegerArray = array[0..MaxInt div (2*SizeOf(Integer))] of Integer;
PCardinalArray = ˆTCardinalArray;
TCardinalArray = array[0..MaxInt div (2*SizeOf(Cardinal))] of Cardinal;
PSingleList = ˆTSingleList;
TSingleList = array[0..MaxInt div (2*SizeOf(Single))] of Single;
PPoint3DS = ˆTPoint3DS;
PPointList = ˆTPointList;
TPointList = array[0..MaxInt div (2*SizeOf(TPoint3DS))] of TPoint3DS;
PFColor3DS = ˆTFColor3DS;
PFColorList = ˆTFColorList;
TFColorList = array[0..MaxInt div (2*SizeOf(TFColor3DS))] of TFColor3DS;
PFace3DS = ˆTFace3DS;
PFaceList = ˆTFaceList;
TFaceList = array[0..MaxInt div (2*SizeOf(TFace3DS))] of TFace3DS;
PTexVert3DS = ˆTTexVert3DS;
PTexVertList = ˆTTexVertList;
TTexVertList = array[0..MaxInt div (2*SizeOf(TTexVert3DS))] of TTexVert3DS;
PTrackHeader3DS = ˆTTrackHeader3DS;
PKeyHeader3DS = ˆTKeyHeader3DS;
PKeyHeaderList = ˆTKeyHeaderList;
TKeyHeaderList = array[0..MaxInt div (2*SizeOf(TKeyHeader3DS))] of TKeyHeader3DS;
PKFRotKey3DS = ˆTKFRotKey3DS;
PKFRotKeyList = ˆTKFRotKeyList;
TKFRotKeyList = array[0..MaxInt div (2*SizeOf(TKFRotKey3DS))] of TKFRotKey3DS;
PKFMorphKey3DS = ˆTKFMorphKey3DS;
TKFMorphKey3DS = String;
PKFMorphKeyList = ˆTKFMorphKeyList;
TKFMorphKeyList = array[0..MaxInt div (2*SizeOf(TKFMorphKey3DS))] of TKFMorphKey3DS;
PChunk3DS = ˆTChunk3DS;
PChunkListEntry3DS = ˆTChunkListEntry3DS;
PChunkList = ˆTChunkList;
TChunkList = array[0..MaxInt div (2*SizeOf(TChunkListEntry3DS))] of TChunkListEntry3DS;
PChunkList3DS = ˆTChunkList3DS;
TDBType3DS = (...);
Values
  • dbUnknown:
  • dbMeshFile:
  • dbProjectFile:
  • dbMaterialFile:
PNodeList = ˆTNodeList;
PDatabase3DS = ˆTDatabase3DS;
TViewType3DS = (...);
Values
  • vtNoView3DS:
  • vtTopView3DS:
  • vtBottomView3DS:
  • vtLeftView3DS:
  • vtRightView3DS:
  • vtFrontView3DS:
  • vtBackView3DS:
  • vtUserView3DS:
  • vtCameraView3DS:
  • vtSpotlightView3DS:
PViewSize3DS = ˆTViewSize3DS;
POrthoView3DS = ˆTOrthoView3DS;
PUserView3DS = ˆTUserView3DS;
PViewport3DS = ˆTViewport3DS;
TShadowStyle3DS = (...);
Values
  • ssUseShadowMap:
  • ssUseRayTraceShadow:
PShadowSets3DS = ˆTShadowSets3DS;
PMeshSet3DS = ˆTMeshSet3DS;
TAtmosphereType3DS = (...);
Values
  • atNoAtmo:
  • atUseFog:
  • atUseLayerFog:
  • atUseDistanceCue:
TLayerFogFalloff3DS = (...);
Values
  • lfNoFall:
  • lfTopFall:
  • lfBottomFall:
PFogSettings3DS = ˆTFogSettings3DS;
PLayerFogSettings3DS = ˆTLayerFogSettings3DS;
PDCueSettings3DS = ˆTDCueSettings3DS;
PAtmosphere3DS = ˆTAtmosphere3DS;
TBackgroundType3DS = (...);
Values
  • btNoBgnd:
  • btUseSolidBgnd:
  • btUseVGradientBgnd:
  • btUseBitmapBgnd:
PBitmapBgnd3DS = ˆTBitmapBgnd3DS;
TBitmapBgnd3DS = AnsiString;
TSolidBgnd3DS = TFColor3DS;
PVGradientBgnd3DS = ˆTVGradientBgnd3DS;
PBackground3DS = ˆTBackground3DS;
TShadeType3DS = (...);
Values
  • stWire:
  • stFlat:
  • stGouraud:
  • stPhong:
  • stMetal:
TTileType3DS = (...);
Values
  • ttTile:
  • ttDecal:
  • ttBoth:
TFilterType3DS = (...);
Values
  • ftPyramidal:
  • ftSummedArea:
TTintType3DS = (...);
Values
  • ttRGB:
  • ttAlpha:
  • ttRGBLumaTint:
  • ttAlphaTint:
  • ttRGBTint:
PACubic3DS = ˆTACubic3DS;
PBitmap3DS = ˆTBitmap3DS;
PMapSet3DS = ˆTMapSet3DS;
PMaterial3DS = ˆTMaterial3DS;
PMeshMatrix = ˆTMeshMatrix;
TMeshMatrix = array[0..11] of Single;
PMapInfo3DS = ˆTMapInfo3DS;
PObjMat3DS = ˆTObjMat3DS;
PObjMatList = ˆTObjMatList;
TObjMatList = array[0..MaxInt div (2*SizeOf(TObjMat3DS))] of TObjMat3DS;
PMesh3DS = ˆTMesh3DS;
TConeStyle3DS = (...);
Values
  • csCircular:
  • csRectangular:
PSpotShadow3DS = ˆTSpotShadow3DS;
PSpotCone3DS = ˆTSpotCone3DS;
PSpotProjector3DS = ˆTSpotProjector3DS;
PSpotLight3DS = ˆTSpotLight3DS;
PLiteAttenuate3DS = ˆTLiteAttenuate3DS;
PLight3DS = ˆTLight3DS;
PCamRanges3DS = ˆTCamRanges3DS;
PCamera3DS = ˆTCamera3DS;
PKFKeyInfo3DS = ˆTKFKeyInfo3DS;
PKFSegment3DS = ˆTKFSegment3DS;
PKFSets3DS = ˆTKFSets3DS;
PKFCamera3DS = ˆTKFCamera3DS;
PKFAmbient3DS = ˆTKFAmbient3DS;
PKFMesh3DS = ˆTKFMesh3DS;
PKFOmni3DS = ˆTKFOmni3DS;
PKFSpot3DS = ˆTKFSpot3DS;
PXDataRaw3DS = ˆTXDataRaw3DS;
TTargetType3DS = (...);
Values
  • ttLightTarget:
  • ttCameraTarget:
PM3dVersion = ˆTM3dVersion;
TM3dVersion = Cardinal;
PColorF = ˆTColorF;
PLinColorF = ˆTLinColorF;
TLinColorF = TColorF;
PColor24 = ˆTColor24;
PLinColor24 = ˆTLinColor24;
TLinColor24 = TColor24;
PMatMapRCol = ˆTMatMapRCol;
TMatMapRCol = TLinColor24;
PMatMapGCol = ˆTMatMapGCol;
TMatMapGCol = TMatMapRCol;
PMatMapBCol = ˆTMatMapBCol;
TMatMapBCol = TMatMapGCol;
PMatMapCol1 = ˆTMatMapCol1;
TMatMapCol1 = TMatMapBCol;
PMatMapCol2 = ˆTMatMapCol2;
TMatMapCol2 = TMatMapCol1;
PIntPercentage = ˆTIntPercentage;
TIntPercentage = SmallInt;
PMatBumpPercent = ˆTMatBumpPercent;
TMatBumpPercent = TIntPercentage;
PFloatPercentage = ˆTFloatPercentage;
TFloatPercentage = Single;
PMatMapname = PChar3DS;
PMeshVersion = ˆTMeshVersion;
TMeshVersion = Integer;
PMasterScale = ˆTMasterScale;
TMasterScale = Single;
PLoShadowBias = ˆTLoShadowBias;
TLoShadowBias = Single;
PHiShadowBias = ˆTHiShadowBias;
THiShadowBias = TLoShadowBias;
PRayBias = ˆTRayBias;
TRayBias = THiShadowBias;
PShadowMapSize = ˆTShadowMapSize;
TShadowMapSize = SmallInt;
PShadowSamples = ˆTShadowSamples;
TShadowSamples = SmallInt;
PShadowRange = ˆTShadowRange;
TShadowRange = Integer;
PShadowFilter = ˆTShadowFilter;
TShadowFilter = Single;
POConsts = ˆTOConsts;
TOConsts = TPoint3DS;
PBitMapName = PChar3DS;
PVGradient = ˆTVGradient;
TVGradient = Single;
PFog = ˆTFog;
PLayerFog = ˆTLayerFog;
PDistanceCue = ˆTDistanceCue;
PViewStandard = ˆTViewStandard;
PViewUser = ˆTViewUser;
PViewCamera = PChar3DS;
PMatName = PChar3DS;
PMatShading = ˆTMatShading;
TMatShading = SmallInt;
PMatAcubic = ˆTMatAcubic;
PIpasData = ˆTIpasData;
PMatWireSize = ˆTMatWireSize;
TMatWireSize = Single;
PMatMapTiling = ˆTMatMapTiling;
TMatMapTiling = Word;
PMatMapTexblur = ˆTMatMapTexblur;
TMatMapTexblur = Single;
PMatMapUScale = ˆTMatMapUScale;
TMatMapUScale = Single;
PMatMapVScale = ˆTMatMapVScale;
TMatMapVScale = TMatMapUScale;
PMatMapUOffset = ˆTMatMapUOffset;
TMatMapUOffset = Single;
PMatMapVOffset = ˆTMatMapVOffset;
TMatMapVOffset = TMatMapUOffset;
PMatMapAng = ˆTMatMapAng;
TMatMapAng = Single;
PNamedObject = PChar3DS;
PPointArray = ˆTPointArray;
PPointFlagArray = ˆTPointFlagArray;
PFaceArray = ˆTFaceArray;
PMshMatGroup = ˆTMshMatGroup;
PMshBoxmap = ˆTMshBoxmap;
TMshBoxmap = array[0..5] of AnsiString;
PSmoothGroup = ˆTSmoothGroup;
PTexVerts = ˆTTexVerts;
PMeshColor = ˆTMeshColor;
TMeshColor = Byte;
PMeshTextureInfo = ˆTMeshTextureInfo;
PProcName = PChar3DS;
PNDirectLight = ˆTNDirectLight;
TNDirectLight = TPoint3DS;
PDlExclude = PChar3DS;
PDlSpotlight = ˆTDlSpotlight;
PDlOuterRange = ˆTDlOuterRange;
TDlOuterRange = Single;
PDlInnerRange = ˆTDlInnerRange;
TDlInnerRange = TDlOuterRange;
PDlMultiplier = ˆTDlMultiplier;
TDlMultiplier = Single;
PDlSpotRoll = ˆTDlSpotRoll;
TDlSpotRoll = Single;
PDlSpotAspect = ˆTDlSpotAspect;
TDlSpotAspect = Single;
PDlSpotProjector = PChar3DS;
PDlRayBias = ˆTDlRayBias;
TDlRayBias = Single;
PDlLocalShadow2 = ˆTDlLocalShadow2;
PNCamera = ˆTNCamera;
PCamRanges = ˆTCamRanges;
PViewportLayout = ˆTViewportLayout;
PViewportSize = ˆTViewportSize;
PViewportData = ˆTViewportData;
PViewportData3 = ˆTViewportData3;
TViewportData3 = TViewportData;
PKFHdr = ˆTKFHdr;
PKFId = ˆTKFId;
TKFId = SmallInt;
PKFSeg = ˆTKFSeg;
PKFCurtime = ˆTKFCurtime;
TKFCurtime = Integer;
PNodeHdr = ˆTNodeHdr;
PPivot = ˆTPivot;
TPivot = TPoint3DS;
PInstanceName = PChar3DS;
PMorphSmooth = ˆTMorphSmooth;
TMorphSmooth = Single;
PBoundBox = ˆTBoundBox;
PPosTrackTag = ˆTPosTrackTag;
PColTrackTag = ˆTColTrackTag;
PRotTrackTag = ˆTRotTrackTag;
PScaleTrackTag = ˆTScaleTrackTag;
PMorphTrackTag = ˆTMorphTrackTag;
PHideTrackTag = ˆTHideTrackTag;
PFovTrackTag = ˆTFovTrackTag;
PRollTrackTag = ˆTRollTrackTag;
PHotTrackTag = ˆTHotTrackTag;
PFallTrackTag = ˆTFallTrackTag;
PXDataEntry = ˆTXDataEntry;
PXDataAppName = PChar3DS;
PXDataString = PChar3DS;
PXDataFloat = ˆTXDataFloat;
TXDataFloat = Single;
PXDataDouble = ˆTXDataDouble;
TXDataDouble = Double;
PXDataShort = ˆTXDataShort;
TXDataShort = SmallInt;
PXDataLong = ˆTXDataLong;
TXDataLong = Integer;
PXDataVoid = ˆTXDataVoid;
TXDataVoid = Pointer;
TReleaseLevel = (...);
Values
  • rlRelease1:
  • rlRelease2:
  • rlRelease3:
  • rlReleaseNotKnown:
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TPoint3DS

record TPoint3DS

Unit

Types3DS

Declaration

type TPoint3DS = record

Description

Overview

Fields

X: Single;
Y: Single;
Z: Single;

Description

Fields

X: Single;
Y: Single;
Z: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TFColor3DS

record TFColor3DS

Unit

Types3DS

Declaration

type TFColor3DS = record

Description

Overview

Fields

R: Single;
G: Single;
B: Single;

Description

Fields

R: Single;
G: Single;
B: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: packed record TFace3DS

packed record TFace3DS

Unit

Types3DS

Declaration

type TFace3DS = packed record

Description

Overview

Fields

V1: Word
V2: Word
V3: Word
Flag: Word
FaceRec: array[0..3] of Word

Description

Fields

V1: Word
V2: Word
V3: Word
Flag: Word
FaceRec: array[0..3] of Word
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TTexVert3DS

record TTexVert3DS

Unit

Types3DS

Declaration

type TTexVert3DS = record

Description

Overview

Fields

U: Single;
V: Single;

Description

Fields

U: Single;
V: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TTrackHeader3DS

record TTrackHeader3DS

Unit

Types3DS

Declaration

type TTrackHeader3DS = record

Description

Overview

Fields

Flags: Word;
nu1: Integer;
nu2: Integer;
KeyCount: Integer;

Description

Fields

Flags: Word;
nu1: Integer;
nu2: Integer;
KeyCount: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TKeyHeader3DS

record TKeyHeader3DS

Unit

Types3DS

Declaration

type TKeyHeader3DS = record

Description

Overview

Fields

Time: Integer;
RFlags: Word;
Tension: Single;
Continuity: Single;
Bias: Single;
EaseTo: Single;
EaseFrom: Single;

Description

Fields

Time: Integer;
RFlags: Word;
Tension: Single;
Continuity: Single;
Bias: Single;
EaseTo: Single;
EaseFrom: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TKFRotKey3DS

record TKFRotKey3DS

Unit

Types3DS

Declaration

type TKFRotKey3DS = record

Description

Overview

Fields

Angle: Single;
X: Single;
Y: Single;
Z: Single;

Description

Fields

Angle: Single;
X: Single;
Y: Single;
Z: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TChunkListEntry3DS

record TChunkListEntry3DS

Unit

Types3DS

Declaration

type TChunkListEntry3DS = record

Description

Overview

Fields

NameStr: String;
Chunk: PChunk3DS;

Description

Fields

NameStr: String;
Chunk: PChunk3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TChunkList3DS

record TChunkList3DS

Unit

Types3DS

Declaration

type TChunkList3DS = record

Description

Overview

Fields

Count: Integer;
List: PChunkList;

Description

Fields

Count: Integer;
List: PChunkList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TNodeList

record TNodeList

Unit

Types3DS

Declaration

type TNodeList = record

Description

Overview

Fields

ID: SmallInt;
Tag: Word;
Name: String;
InstStr: String;
ParentID: SmallInt;
Next: PNodeList;

Description

Fields

ID: SmallInt;
Tag: Word;
Name: String;
InstStr: String;
ParentID: SmallInt;
Next: PNodeList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TDatabase3DS

record TDatabase3DS

Unit

Types3DS

Declaration

type TDatabase3DS = record

Description

Overview

Fields

TopChunk: PChunk3DS;
ObjListDirty: Boolean;
MatListDirty: Boolean;
NodeListDirty: Boolean;
ObjList: PChunkList3DS;
MatList: PChunkList3DS;
NodeList: PChunkList3DS;

Description

Fields

TopChunk: PChunk3DS;
ObjListDirty: Boolean;
MatListDirty: Boolean;
NodeListDirty: Boolean;
ObjList: PChunkList3DS;
MatList: PChunkList3DS;
NodeList: PChunkList3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TViewSize3DS

record TViewSize3DS

Unit

Types3DS

Declaration

type TViewSize3DS = record

Description

Overview

Fields

XPos: Word;
YPos: Word;
Width: Word;
Height: Word;

Description

Fields

XPos: Word;
YPos: Word;
Width: Word;
Height: Word;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TOrthoView3DS

record TOrthoView3DS

Unit

Types3DS

Declaration

type TOrthoView3DS = record

Description

Overview

Fields

Center: TPoint3DS;
Zoom: Single;

Description

Fields

Center: TPoint3DS;
Zoom: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TUserView3DS

record TUserView3DS

Unit

Types3DS

Declaration

type TUserView3DS = record

Description

Overview

Fields

Center: TPoint3DS;
Zoom: Single;
HorAng: Single;
VerAng: Single;

Description

Fields

Center: TPoint3DS;
Zoom: Single;
HorAng: Single;
VerAng: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TViewport3DS

record TViewport3DS

Unit

Types3DS

Declaration

type TViewport3DS = record

Description

Overview

Fields

AType: TViewType3DS;
Size: TViewSize3DS;
Ortho: TOrthoView3DS;
User: TUserView3DS;
CameraStr: String;

Description

Fields

AType: TViewType3DS;
Size: TViewSize3DS;
Ortho: TOrthoView3DS;
User: TUserView3DS;
CameraStr: String;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TShadowSets3DS

record TShadowSets3DS

Unit

Types3DS

Declaration

type TShadowSets3DS = record

Description

Overview

Fields

AType: TShadowStyle3DS;
Bias: Single;
RayBias: Single;
MapSize: Smallint;
Filter: Single;

Description

Fields

AType: TShadowStyle3DS;
Bias: Single;
RayBias: Single;
MapSize: Smallint;
Filter: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TMeshSet3DS

record TMeshSet3DS

Unit

Types3DS

Declaration

type TMeshSet3DS = record

Description

Overview

Fields

MasterScale: Single;
Shadow: TShadowSets3DS;
AmbientLight: TFColor3DS;
OConsts: TPoint3DS;

Description

Fields

MasterScale: Single;
Shadow: TShadowSets3DS;
AmbientLight: TFColor3DS;
OConsts: TPoint3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TFogSettings3DS

record TFogSettings3DS

Unit

Types3DS

Declaration

type TFogSettings3DS = record

Description

Overview

Fields

NearPlane: Single;
NearDensity: Single;
FarPlane: Single;
FarDensity: Single;
FogColor: TFColor3DS;
FogBgnd: Boolean;

Description

Fields

NearPlane: Single;
NearDensity: Single;
FarPlane: Single;
FarDensity: Single;
FogColor: TFColor3DS;
FogBgnd: Boolean;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TLayerFogSettings3DS

record TLayerFogSettings3DS

Unit

Types3DS

Declaration

type TLayerFogSettings3DS = record

Description

Overview

Fields

ZMin: Single;
ZMax: Single;
Density: Single;
FogColor: TFColor3DS;
FallOff: TLayerFogFalloff3DS;
FogBgnd: Boolean;

Description

Fields

ZMin: Single;
ZMax: Single;
Density: Single;
FogColor: TFColor3DS;
FallOff: TLayerFogFalloff3DS;
FogBgnd: Boolean;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TDCueSettings3DS

record TDCueSettings3DS

Unit

Types3DS

Declaration

type TDCueSettings3DS = record

Description

Overview

Fields

NearPlane: Single;
NearDim: Single;
FarPlane: Single;
FarDim: Single;
DCueBgnd: Boolean;

Description

Fields

NearPlane: Single;
NearDim: Single;
FarPlane: Single;
FarDim: Single;
DCueBgnd: Boolean;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TAtmosphere3DS

record TAtmosphere3DS

Unit

Types3DS

Declaration

type TAtmosphere3DS = record

Description

Overview

Fields

Fog: TFogSettings3DS;
LayerFog: TLayerFogSettings3DS;
DCue: TDCueSettings3DS;
ActiveAtmo: TAtmosphereType3DS;

Description

Fields

Fog: TFogSettings3DS;
LayerFog: TLayerFogSettings3DS;
DCue: TDCueSettings3DS;
ActiveAtmo: TAtmosphereType3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TVGradientBgnd3DS

record TVGradientBgnd3DS

Unit

Types3DS

Declaration

type TVGradientBgnd3DS = record

Description

Overview

Fields

GradPercent: Single;
Top: TFColor3DS;
Mid: TFColor3DS;
Bottom: TFColor3DS;

Description

Fields

GradPercent: Single;
Top: TFColor3DS;
Mid: TFColor3DS;
Bottom: TFColor3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TBackground3DS

record TBackground3DS

Unit

Types3DS

Declaration

type TBackground3DS = record

Description

Overview

Fields

Bitmap: TBitmapBgnd3DS;
Solid: TSolidBgnd3DS;
VGradient: TVGradientBgnd3DS;
BgndUsed: TBackgroundType3DS;

Description

Fields

Bitmap: TBitmapBgnd3DS;
Solid: TSolidBgnd3DS;
VGradient: TVGradientBgnd3DS;
BgndUsed: TBackgroundType3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:39


GLScene v.1.1.2: Types3DS: record TACubic3DS

record TACubic3DS

Unit

Types3DS

Declaration

type TACubic3DS = record

Description

Overview

Fields

FirstFrame: Boolean;
Flat: Boolean;
Size: Integer;
nthFrame: Integer;

Description

Fields

FirstFrame: Boolean;
Flat: Boolean;
Size: Integer;
nthFrame: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TBitmap3DS

record TBitmap3DS

Unit

Types3DS

Declaration

type TBitmap3DS = record

Description

Overview

Fields

NameStr: AnsiString;
Percent: Single;
Tiling: TTileType3DS;
IgnoreAlpha: Boolean;
Filter: TFilterType3DS;
Blur: Single;
Mirror: Boolean;
Negative: Boolean;
UScale: Single;
VScale: Single;
UOffset: Single;
VOffset: Single;
Rotation: Single;
Source: TTintType3DS;
Tint1: TFColor3DS;
Tint2: TFColor3DS;
RedTint: TFColor3DS;
GreenTint: TFColor3DS;
BlueTint: TFColor3DS;
DataSize: Integer;
Data: Pointer;

Description

Fields

NameStr: AnsiString;
Percent: Single;
Tiling: TTileType3DS;
IgnoreAlpha: Boolean;
Filter: TFilterType3DS;
Blur: Single;
Mirror: Boolean;
Negative: Boolean;
UScale: Single;
VScale: Single;
UOffset: Single;
VOffset: Single;
Rotation: Single;
Source: TTintType3DS;
Tint1: TFColor3DS;
Tint2: TFColor3DS;
RedTint: TFColor3DS;
GreenTint: TFColor3DS;
BlueTint: TFColor3DS;
DataSize: Integer;
Data: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TMapSet3DS

record TMapSet3DS

Unit

Types3DS

Declaration

type TMapSet3DS = record

Description

Overview

Fields

Map: TBitmap3DS;
Mask: TBitmap3DS;

Description

Fields

Map: TBitmap3DS;
Mask: TBitmap3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TRMapSet3DS

record TRMapSet3DS

Unit

Types3DS

Declaration

type TRMapSet3DS = record

Description

Overview

Fields

Map: TBitmap3DS;
UseAuto: Boolean;
AutoMap: TACubic3DS;
Mask: TBitmap3DS;

Description

Fields

Map: TBitmap3DS;
UseAuto: Boolean;
AutoMap: TACubic3DS;
Mask: TBitmap3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TMaterial3DS

record TMaterial3DS

Unit

Types3DS

Declaration

type TMaterial3DS = record

Description

Overview

Fields

NameStr: AnsiString;
Ambient: TFColor3DS;
Diffuse: TFColor3DS;
Specular: TFColor3DS;
Shininess: Single;
ShinStrength: Single;
Blur: Single;
Transparency: Single;
TransFallOff: Single;
SelfIllumPct: Single;
WireSize: Single;
Shading: TShadeType3DS;
UseBlur: Boolean;
UseFall: Boolean;
TwoSided: Boolean;
SelFillum: Boolean;
Additive: Boolean;
UseWire: Boolean;
UseWireAbs: Boolean;
FaceMap: Boolean;
Soften: Boolean;
Texture: TMapSet3DS;
Texture2: TMapSet3DS;
Opacity: TMapSet3DS;
Bump: TMapSet3DS;
SpecMap: TMapSet3DS;
ShinMap: TMapSet3DS;
IllumMap: TMapSet3DS;
Reflect: TRMapSet3DS;

Description

Fields

NameStr: AnsiString;
Ambient: TFColor3DS;
Diffuse: TFColor3DS;
Specular: TFColor3DS;
Shininess: Single;
ShinStrength: Single;
Blur: Single;
Transparency: Single;
TransFallOff: Single;
SelfIllumPct: Single;
WireSize: Single;
Shading: TShadeType3DS;
UseBlur: Boolean;
UseFall: Boolean;
TwoSided: Boolean;
SelFillum: Boolean;
Additive: Boolean;
UseWire: Boolean;
UseWireAbs: Boolean;
FaceMap: Boolean;
Soften: Boolean;
Texture: TMapSet3DS;
Texture2: TMapSet3DS;
Opacity: TMapSet3DS;
Bump: TMapSet3DS;
SpecMap: TMapSet3DS;
ShinMap: TMapSet3DS;
IllumMap: TMapSet3DS;
Reflect: TRMapSet3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TMapInfo3DS

record TMapInfo3DS

Unit

Types3DS

Declaration

type TMapInfo3DS = record

Description

Overview

Fields

MapType: Word;
TileX: Single;
TileY: Single;
CenX: Single;
CenY: Single;
CenZ: Single;
Scale: Single;
Matrix: TMeshMatrix;
PW: Single;
PH: Single;
CH: Single;

Description

Fields

MapType: Word;
TileX: Single;
TileY: Single;
CenX: Single;
CenY: Single;
CenZ: Single;
Scale: Single;
Matrix: TMeshMatrix;
PW: Single;
PH: Single;
CH: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TObjMat3DS

record TObjMat3DS

Unit

Types3DS

Declaration

type TObjMat3DS = record

Description

Overview

Fields

NameStr: AnsiString;
NFaces: Word;
FaceIndex: PWordList;

Description

Fields

NameStr: AnsiString;
NFaces: Word;
FaceIndex: PWordList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TMesh3DS

record TMesh3DS

Unit

Types3DS

Declaration

type TMesh3DS = record

Description

Overview

Fields

NameStr: AnsiString;
IsHidden: Boolean;
IsvisLofter: Boolean;
IsMatte: Boolean;
IsNoCast: Boolean;
IsFast: Boolean;
IsNorcvShad: boolean;
IsFrozen: Boolean;
NVertices: Word;
VertexArray: PPointList;
NVFlags: Word;
VFlagArray: PWordList;
NTextVerts: Word;
TextArray: PTexVertList;
UseMapInfo: Boolean;
Map: TMapInfo3DS;
LocMatrix: TMeshMatrix;
NFaces: Word;
FaceArray: PFaceList;
SmoothArray: PCardinalArray;
UseBoxMap: Boolean;
BoxMapStr: array[0..5] of String;
MeshColor: Byte;
NMats: Word;
MatArray: PObjMatList;
UseProc: Boolean;
ProcSize: Integer;
ProcNameStr: String;
ProcData: Pointer;

Description

Fields

NameStr: AnsiString;
IsHidden: Boolean;
IsvisLofter: Boolean;
IsMatte: Boolean;
IsNoCast: Boolean;
IsFast: Boolean;
IsNorcvShad: boolean;
IsFrozen: Boolean;
NVertices: Word;
VertexArray: PPointList;
NVFlags: Word;
VFlagArray: PWordList;
NTextVerts: Word;
TextArray: PTexVertList;
UseMapInfo: Boolean;
Map: TMapInfo3DS;
LocMatrix: TMeshMatrix;
NFaces: Word;
FaceArray: PFaceList;
SmoothArray: PCardinalArray;
UseBoxMap: Boolean;
BoxMapStr: array[0..5] of String;
MeshColor: Byte;
NMats: Word;
MatArray: PObjMatList;
UseProc: Boolean;
ProcSize: Integer;
ProcNameStr: String;
ProcData: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TSpotShadow3DS

record TSpotShadow3DS

Unit

Types3DS

Declaration

type TSpotShadow3DS = record

Description

Overview

Fields

Cast: Boolean;
AType: TShadowStyle3DS;
Local: Boolean;
Bias: Single;
Filter: Single;
MapSize: Word;
RayBias: Single;

Description

Fields

Cast: Boolean;
AType: TShadowStyle3DS;
Local: Boolean;
Bias: Single;
Filter: Single;
MapSize: Word;
RayBias: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TSpotCone3DS

record TSpotCone3DS

Unit

Types3DS

Declaration

type TSpotCone3DS = record

Description

Overview

Fields

AType: TConeStyle3DS;
Show: Boolean;
Overshoot: Boolean;

Description

Fields

AType: TConeStyle3DS;
Show: Boolean;
Overshoot: Boolean;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TSpotProjector3DS

record TSpotProjector3DS

Unit

Types3DS

Declaration

type TSpotProjector3DS = record

Description

Overview

Fields

Use: Boolean;
BitmapStr: String;

Description

Fields

Use: Boolean;
BitmapStr: String;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TSpotLight3DS

record TSpotLight3DS

Unit

Types3DS

Declaration

type TSpotLight3DS = record

Description

Overview

Fields

Target: TPoint3DS;
Hotspot: Single;
FallOff: Single;
Roll: Single;
Aspect: Single;
Shadows: TSpotShadow3DS;
Cone: TSpotCone3DS;
Projector: TSpotProjector3DS;

Description

Fields

Target: TPoint3DS;
Hotspot: Single;
FallOff: Single;
Roll: Single;
Aspect: Single;
Shadows: TSpotShadow3DS;
Cone: TSpotCone3DS;
Projector: TSpotProjector3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TLiteAttenuate3DS

record TLiteAttenuate3DS

Unit

Types3DS

Declaration

type TLiteAttenuate3DS = record

Description

Overview

Fields

IsOn: Boolean;
Inner: Single;
Outer: Single;

Description

Fields

IsOn: Boolean;
Inner: Single;
Outer: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TLight3DS

record TLight3DS

Unit

Types3DS

Declaration

type TLight3DS = record

Description

Overview

Fields

NameStr: AnsiString;
Pos: TPoint3DS;
Color: TFColor3DS;
Multiplier: Single;
DLOff: Boolean;
Attenuation: TLiteAttenuate3DS;
Exclude: TStringList;
Spot: PSpotLight3DS;

Description

Fields

NameStr: AnsiString;
Pos: TPoint3DS;
Color: TFColor3DS;
Multiplier: Single;
DLOff: Boolean;
Attenuation: TLiteAttenuate3DS;
Exclude: TStringList;
Spot: PSpotLight3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TCamRanges3DS

record TCamRanges3DS

Unit

Types3DS

Declaration

type TCamRanges3DS = record

Description

Overview

Fields

CamNear: Single;
CamFar: Single;

Description

Fields

CamNear: Single;
CamFar: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TCamera3DS

record TCamera3DS

Unit

Types3DS

Declaration

type TCamera3DS = record

Description

Overview

Fields

NameStr: AnsiString;
Position: TPoint3DS;
Target: TPoint3DS;
Roll: Single;
FOV: Single;
ShowCone: Boolean;
Ranges: TCamRanges3DS;

Description

Fields

NameStr: AnsiString;
Position: TPoint3DS;
Target: TPoint3DS;
Roll: Single;
FOV: Single;
ShowCone: Boolean;
Ranges: TCamRanges3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TKFKeyInfo3DS

record TKFKeyInfo3DS

Unit

Types3DS

Declaration

type TKFKeyInfo3DS = record

Description

Overview

Fields

Length: Integer;
CurFrame: Integer;

Description

Fields

Length: Integer;
CurFrame: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TKFSegment3DS

record TKFSegment3DS

Unit

Types3DS

Declaration

type TKFSegment3DS = record

Description

Overview

Fields

Use: Boolean;
SegBegin: Integer;
SegEnd: Integer;

Description

Fields

Use: Boolean;
SegBegin: Integer;
SegEnd: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TKFSets3DS

record TKFSets3DS

Unit

Types3DS

Declaration

type TKFSets3DS = record

Description

Overview

Fields

Anim: TKFKeyInfo3DS;
Seg: TKFSegment3DS;

Description

Fields

Anim: TKFKeyInfo3DS;
Seg: TKFSegment3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TKFCamera3DS

record TKFCamera3DS

Unit

Types3DS

Declaration

type TKFCamera3DS = record

Description

Overview

Fields

NameStr: AnsiString;
ParentStr: AnsiString;
Flags1: Word;
Flags2: Word;
NPKeys: Integer;
NPFlag: Word;
PKeys: PKeyHeaderList;
Pos: PPointList;
NFKeys: Integer;
NFFlag: Word;
FKeys: PKeyHeaderList;
FOV: PSingleList;
NRKeys: Integer;
NRFlag: Word;
RKeys: PKeyHeaderList;
Roll: PSingleList;
TParentStr: String;
NTKeys: Integer;
NTFlag: Word;
TKeys: PKeyHeaderList;
TPos: PPointList;
TFlags1: Word;
TFlags2: Word;

Description

Fields

NameStr: AnsiString;
ParentStr: AnsiString;
Flags1: Word;
Flags2: Word;
NPKeys: Integer;
NPFlag: Word;
PKeys: PKeyHeaderList;
Pos: PPointList;
NFKeys: Integer;
NFFlag: Word;
FKeys: PKeyHeaderList;
FOV: PSingleList;
NRKeys: Integer;
NRFlag: Word;
RKeys: PKeyHeaderList;
Roll: PSingleList;
TParentStr: String;
NTKeys: Integer;
NTFlag: Word;
TKeys: PKeyHeaderList;
TPos: PPointList;
TFlags1: Word;
TFlags2: Word;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TKFAmbient3DS

record TKFAmbient3DS

Unit

Types3DS

Declaration

type TKFAmbient3DS = record

Description

Overview

Fields

Flags1: Word;
Flags2: Word;
NCKeys: Integer;
NCFlag: Word;
CKeys: PKeyHeaderList;
Color: PFColorList;

Description

Fields

Flags1: Word;
Flags2: Word;
NCKeys: Integer;
NCFlag: Word;
CKeys: PKeyHeaderList;
Color: PFColorList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TKFMesh3DS

record TKFMesh3DS

Unit

Types3DS

Declaration

type TKFMesh3DS = record

Description

Overview

Fields

NameStr: AnsiString;
ParentStr: AnsiString;
Flags1: Word;
Flags2: Word;
Pivot: TPoint3DS;
InstanceStr: AnsiString;
BoundMin: TPoint3DS;
BoundMax: TPoint3DS;
NPKeys: Integer;
NPFlag: Smallint;
PKeys: PKeyHeaderList;
Pos: PPointList;
NRKeys: Integer;
NRFlag: Smallint;
RKeys: PKeyHeaderList;
Rot: PKFRotKeyList;
NSKeys: Integer;
NSFlag: Smallint;
SKeys: PKeyHeaderList;
Scale: PPointList;
NMKeys: Integer;
NMFlag: Smallint;
MKeys: PKeyHeaderList;
Morph: PKFMorphKeyList;
NHKeys: Integer;
NHFlag: Smallint;
HKeys: PKeyHeaderList;
MSAngle: Single;

Description

Fields

NameStr: AnsiString;
ParentStr: AnsiString;
Flags1: Word;
Flags2: Word;
Pivot: TPoint3DS;
InstanceStr: AnsiString;
BoundMin: TPoint3DS;
BoundMax: TPoint3DS;
NPKeys: Integer;
NPFlag: Smallint;
PKeys: PKeyHeaderList;
Pos: PPointList;
NRKeys: Integer;
NRFlag: Smallint;
RKeys: PKeyHeaderList;
Rot: PKFRotKeyList;
NSKeys: Integer;
NSFlag: Smallint;
SKeys: PKeyHeaderList;
Scale: PPointList;
NMKeys: Integer;
NMFlag: Smallint;
MKeys: PKeyHeaderList;
Morph: PKFMorphKeyList;
NHKeys: Integer;
NHFlag: Smallint;
HKeys: PKeyHeaderList;
MSAngle: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TKFOmni3DS

record TKFOmni3DS

Unit

Types3DS

Declaration

type TKFOmni3DS = record

Description

Overview

Fields

Name: AnsiString;
Parent: AnsiString;
Flags1: Word;
Flags2: Word;
NPKeys: Integer;
NPFlag: Word;
PKeys: PKeyHeaderList;
Pos: PPointList;
NCKeys: Integer;
NCFlag: Word;
CKeys: PKeyHeaderList;
Color: PFColorList;

Description

Fields

Name: AnsiString;
Parent: AnsiString;
Flags1: Word;
Flags2: Word;
NPKeys: Integer;
NPFlag: Word;
PKeys: PKeyHeaderList;
Pos: PPointList;
NCKeys: Integer;
NCFlag: Word;
CKeys: PKeyHeaderList;
Color: PFColorList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TKFSpot3DS

record TKFSpot3DS

Unit

Types3DS

Declaration

type TKFSpot3DS = record

Description

Overview

Fields

Name: AnsiString;
Parent: AnsiString;
Flags1: Word;
Flags2: Word;
NPKeys: Integer;
NPFlag: Word;
PKeys: PKeyHeaderList;
Pos: PPointList;
NCKeys: Integer;
NCFlag: Word;
CKeys: PKeyHeaderList;
Color: PFColorList;
NHKeys: Integer;
NHFlag: Word;
HKeys: PKeyHeaderList;
Hot: PSingleList;
NFKeys: Integer;
NFFlag: Word;
FKeys: PKeyHeaderList;
Fall: PSingleList;
NRKeys: Integer;
NRFlag: Word;
RKeys: PKeyHeaderList;
Roll: PSingleList;
TParent: AnsiString;
NTKeys: Integer;
NTFlag: Word;
TKeys: PKeyHeaderList;
TPos: PPointList;
TFlags1: Word;
TFlags2: Word;

Description

Fields

Name: AnsiString;
Parent: AnsiString;
Flags1: Word;
Flags2: Word;
NPKeys: Integer;
NPFlag: Word;
PKeys: PKeyHeaderList;
Pos: PPointList;
NCKeys: Integer;
NCFlag: Word;
CKeys: PKeyHeaderList;
Color: PFColorList;
NHKeys: Integer;
NHFlag: Word;
HKeys: PKeyHeaderList;
Hot: PSingleList;
NFKeys: Integer;
NFFlag: Word;
FKeys: PKeyHeaderList;
Fall: PSingleList;
NRKeys: Integer;
NRFlag: Word;
RKeys: PKeyHeaderList;
Roll: PSingleList;
TParent: AnsiString;
NTKeys: Integer;
NTFlag: Word;
TKeys: PKeyHeaderList;
TPos: PPointList;
TFlags1: Word;
TFlags2: Word;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TXDataRaw3DS

record TXDataRaw3DS

Unit

Types3DS

Declaration

type TXDataRaw3DS = record

Description

Overview

Fields

Size: Integer;
Data: Pointer;

Description

Fields

Size: Integer;
Data: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TColorF

record TColorF

Unit

Types3DS

Declaration

type TColorF = record

Description

Overview

Fields

Red: Single;
Green: Single;
Blue: Single;

Description

Fields

Red: Single;
Green: Single;
Blue: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TColor24

record TColor24

Unit

Types3DS

Declaration

type TColor24 = record

Description

Overview

Fields

Red: Byte;
Green: Byte;
Blue: Byte;

Description

Fields

Red: Byte;
Green: Byte;
Blue: Byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TFog

record TFog

Unit

Types3DS

Declaration

type TFog = record

Description

Overview

Fields

NearPlaneDist: Single;
NearPlaneDensity: Single;
FarPlaneDist: Single;
FarPlaneDensity: Single;

Description

Fields

NearPlaneDist: Single;
NearPlaneDensity: Single;
FarPlaneDist: Single;
FarPlaneDensity: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TLayerFog

record TLayerFog

Unit

Types3DS

Declaration

type TLayerFog = record

Description

Overview

Fields

ZMin: Single;
ZMax: Single;
Density: Single;
AType: Cardinal;

Description

Fields

ZMin: Single;
ZMax: Single;
Density: Single;
AType: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TDistanceCue

record TDistanceCue

Unit

Types3DS

Declaration

type TDistanceCue = record

Description

Overview

Fields

NearPlaneDist: Single;
NearPlaneDimming: Single;
FarPlaneDist: Single;
FarPlaneDimming: Single;

Description

Fields

NearPlaneDist: Single;
NearPlaneDimming: Single;
FarPlaneDist: Single;
FarPlaneDimming: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TViewStandard

record TViewStandard

Unit

Types3DS

Declaration

type TViewStandard = record

Description

Overview

Fields

ViewTargetCoord: TPoint3DS;
ViewWidth: Single;

Description

Fields

ViewTargetCoord: TPoint3DS;
ViewWidth: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TViewUser

record TViewUser

Unit

Types3DS

Declaration

type TViewUser = record

Description

Overview

Fields

ViewTargetCoord: TPoint3DS;
ViewWidth: Single;
XYViewangle: Single;
YZViewangle: Single;
BankAngle: Single;

Description

Fields

ViewTargetCoord: TPoint3DS;
ViewWidth: Single;
XYViewangle: Single;
YZViewangle: Single;
BankAngle: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TMatAcubic

record TMatAcubic

Unit

Types3DS

Declaration

type TMatAcubic = record

Description

Overview

Fields

ShadeLevel: Byte;
Antialias: Byte;
Flags: SmallInt;
MapSize: Cardinal;
FrameInterval: Cardinal;

Description

Fields

ShadeLevel: Byte;
Antialias: Byte;
Flags: SmallInt;
MapSize: Cardinal;
FrameInterval: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TIpasData

record TIpasData

Unit

Types3DS

Declaration

type TIpasData = record

Description

Overview

Fields

Size: Integer;
Data: Pointer;

Description

Fields

Size: Integer;
Data: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TPointArray

record TPointArray

Unit

Types3DS

Declaration

type TPointArray = record

Description

Overview

Fields

Vertices: Word;
PointList: PPointList;

Description

Fields

Vertices: Word;
PointList: PPointList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TPointFlagArray

record TPointFlagArray

Unit

Types3DS

Declaration

type TPointFlagArray = record

Description

Overview

Fields

Flags: Word;
FlagList: PWordList;

Description

Fields

Flags: Word;
FlagList: PWordList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TFaceArray

record TFaceArray

Unit

Types3DS

Declaration

type TFaceArray = record

Description

Overview

Fields

Faces: Word;
FaceList: PFaceList;

Description

Fields

Faces: Word;
FaceList: PFaceList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TMshMatGroup

record TMshMatGroup

Unit

Types3DS

Declaration

type TMshMatGroup = record

Description

Overview

Fields

MatNameStr: AnsiString;
Faces: Word;
FaceList: PWordList;

Description

Fields

MatNameStr: AnsiString;
Faces: Word;
FaceList: PWordList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TSmoothGroup

record TSmoothGroup

Unit

Types3DS

Declaration

type TSmoothGroup = record

Description

Overview

Fields

Groups: Word;
GroupList: PCardinalArray;

Description

Fields

Groups: Word;
GroupList: PCardinalArray;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TTexVerts

record TTexVerts

Unit

Types3DS

Declaration

type TTexVerts = record

Description

Overview

Fields

NumCoords: Word;
TextVertList: PTexVertList;

Description

Fields

NumCoords: Word;
TextVertList: PTexVertList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TMeshTextureInfo

record TMeshTextureInfo

Unit

Types3DS

Declaration

type TMeshTextureInfo = record

Description

Overview

Fields

MapType: Word;
XTiling: Single;
YTiling: Single;
IconPos: TPoint3DS;
IconScaling: Single;
XMatrix: TMeshMatrix;
IconWidth: Single;
IconHeight: Single;
CylIconHeight: Single;

Description

Fields

MapType: Word;
XTiling: Single;
YTiling: Single;
IconPos: TPoint3DS;
IconScaling: Single;
XMatrix: TMeshMatrix;
IconWidth: Single;
IconHeight: Single;
CylIconHeight: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TDlSpotlight

record TDlSpotlight

Unit

Types3DS

Declaration

type TDlSpotlight = record

Description

Overview

Fields

SpotLightTarg: TPoint3DS;
HotspotAngle: Single;
FalloffAngle: Single;

Description

Fields

SpotLightTarg: TPoint3DS;
HotspotAngle: Single;
FalloffAngle: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TDlLocalShadow2

record TDlLocalShadow2

Unit

Types3DS

Declaration

type TDlLocalShadow2 = record

Description

Overview

Fields

LocalShadowBias: Single;
LocalShadowFilter: Single;
LocalShadowMapSize: SmallInt

Description

Fields

LocalShadowBias: Single;
LocalShadowFilter: Single;
LocalShadowMapSize: SmallInt
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TNCamera

record TNCamera

Unit

Types3DS

Declaration

type TNCamera = record

Description

Overview

Fields

CameraPos: TPoint3DS;
TargetPos: TPoint3DS;
CameraBank: Single;
CameraFocalLength: Single;

Description

Fields

CameraPos: TPoint3DS;
TargetPos: TPoint3DS;
CameraBank: Single;
CameraFocalLength: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TCamRanges

record TCamRanges

Unit

Types3DS

Declaration

type TCamRanges = record

Description

Overview

Fields

NearPlane: Single;
FarPlane: Single;

Description

Fields

NearPlane: Single;
FarPlane: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TViewportLayout

record TViewportLayout

Unit

Types3DS

Declaration

type TViewportLayout = record

Description

Overview

Fields

Form: SmallInt;
Top: SmallInt;
Ready: SmallInt;
WState: SmallInt;
SwapWS: SmallInt;
SwapPort: SmallInt;
SwapCur: SmallInt;

Description

Fields

Form: SmallInt;
Top: SmallInt;
Ready: SmallInt;
WState: SmallInt;
SwapWS: SmallInt;
SwapPort: SmallInt;
SwapCur: SmallInt;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TViewportSize

record TViewportSize

Unit

Types3DS

Declaration

type TViewportSize = record

Description

Overview

Fields

XPos: Word;
YPos: Word;
Width: Word;
Height: Word;

Description

Fields

XPos: Word;
YPos: Word;
Width: Word;
Height: Word;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TViewportData

record TViewportData

Unit

Types3DS

Declaration

type TViewportData = record

Description

Overview

Fields

Flags: Word;
AxisLockout: Word;
WinXPos: Word;
WinYPos: Word;
WinWidth: Word;
WinHeight: Word;
View: Word;
ZoomFactor: Single;
Center: TPoint3DS;
HorizAng: Single;
VertAng: Single;
CamNameStr: AnsiString;

Description

Fields

Flags: Word;
AxisLockout: Word;
WinXPos: Word;
WinYPos: Word;
WinWidth: Word;
WinHeight: Word;
View: Word;
ZoomFactor: Single;
Center: TPoint3DS;
HorizAng: Single;
VertAng: Single;
CamNameStr: AnsiString;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TKFHdr

record TKFHdr

Unit

Types3DS

Declaration

type TKFHdr = record

Description

Overview

Fields

Revision: SmallInt;
Filename: String;
AnimLength: Integer;

Description

Fields

Revision: SmallInt;
Filename: String;
AnimLength: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TKFSeg

record TKFSeg

Unit

Types3DS

Declaration

type TKFSeg = record

Description

Overview

Fields

First: Integer;
Last: Integer;

Description

Fields

First: Integer;
Last: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TNodeHdr

record TNodeHdr

Unit

Types3DS

Declaration

type TNodeHdr = record

Description

Overview

Fields

ObjNameStr: String;
Flags1: Word;
Flags2: Word;
ParentIndex: SmallInt;

Description

Fields

ObjNameStr: String;
Flags1: Word;
Flags2: Word;
ParentIndex: SmallInt;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TBoundBox

record TBoundBox

Unit

Types3DS

Declaration

type TBoundBox = record

Description

Overview

Fields

Min: TPoint3DS;
Max: TPoint3DS;

Description

Fields

Min: TPoint3DS;
Max: TPoint3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TPosTrackTag

record TPosTrackTag

Unit

Types3DS

Declaration

type TPosTrackTag = record

Description

Overview

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
PositionList: PPointList;

Description

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
PositionList: PPointList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TColTrackTag

record TColTrackTag

Unit

Types3DS

Declaration

type TColTrackTag = record

Description

Overview

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
ColorList: PFColorList;

Description

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
ColorList: PFColorList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TRotTrackTag

record TRotTrackTag

Unit

Types3DS

Declaration

type TRotTrackTag = record

Description

Overview

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
RotationList: PKFRotKeyList;

Description

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
RotationList: PKFRotKeyList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TScaleTrackTag

record TScaleTrackTag

Unit

Types3DS

Declaration

type TScaleTrackTag = record

Description

Overview

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
ScaleList: PPointList;

Description

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
ScaleList: PPointList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TMorphTrackTag

record TMorphTrackTag

Unit

Types3DS

Declaration

type TMorphTrackTag = record

Description

Overview

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
MorphList: PKFMorphKeyList;

Description

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
MorphList: PKFMorphKeyList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record THideTrackTag

record THideTrackTag

Unit

Types3DS

Declaration

type THideTrackTag = record

Description

Overview

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;

Description

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TFovTrackTag

record TFovTrackTag

Unit

Types3DS

Declaration

type TFovTrackTag = record

Description

Overview

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
FOVAngleList: PSingleList;

Description

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
FOVAngleList: PSingleList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TRollTrackTag

record TRollTrackTag

Unit

Types3DS

Declaration

type TRollTrackTag = record

Description

Overview

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
RollAngleList: PSingleList;

Description

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
RollAngleList: PSingleList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record THotTrackTag

record THotTrackTag

Unit

Types3DS

Declaration

type THotTrackTag = record

Description

Overview

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
HotspotAngleList: PSingleList;

Description

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
HotspotAngleList: PSingleList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TFallTrackTag

record TFallTrackTag

Unit

Types3DS

Declaration

type TFallTrackTag = record

Description

Overview

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
FalloffAngleList: PSingleList;

Description

Fields

TrackHdr: TTrackHeader3DS;
KeyHdrList: PKeyHeaderList;
FalloffAngleList: PSingleList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TXDataEntry

record TXDataEntry

Unit

Types3DS

Declaration

type TXDataEntry = record

Description

Overview

Fields

Size: Integer;
Data: Pointer;

Description

Fields

Size: Integer;
Data: Pointer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TChunkData

record TChunkData

Unit

Types3DS

Declaration

type TChunkData = record

Description

Overview

Fields

ColorF: PColorF
LinColorF: PLinColorF
Color24: PColor24
LinColor24: PLinColor24
IntPercentage: PIntPercentage
FloatPercentage: PFloatPercentage
MatMapname: PMatMapname
M3dVersion: PM3dVersion
MeshVersion: PMeshVersion
MasterScale: PMasterScale
LoShadowBias: PLoShadowBias
ShadowFilter: PShadowFilter
ShadowRange: PShadowRange
HiShadowBias: PHiShadowBias
RayBias: PRayBias
ShadowMapSize: PShadowMapSize
ShadowSamples: PShadowSamples
OConsts: POConsts
BitMapName: PBitMapName
VGradient: PVGradient
Fog: PFog
LayerFog: PLayerFog
DistanceCue: PDistanceCue
ViewStandard: PViewStandard
ViewUser: PViewUser
ViewCamera: PViewCamera
MatName: PMatName
MatShading: PMatShading
MatAcubic: PMatAcubic
IpasData: PIpasData
MatWireSize: PMatWireSize
MatMapTiling: PMatMapTiling
MatMapTexblur: PMatMapTexblur
MatMapUScale: PMatMapUScale
MatMapVScale: PMatMapVScale
MatMapUOffset: PMatMapUOffset
MatMapVOffset: PMatMapVOffset
MatMapAng: PMatMapAng
MatMapCol1: PMatMapCol1
MatMapCol2: PMatMapCol2
MatMapRCol: PMatMapRCol
MatMapGCol: PMatMapGCol
MatMapBCol: PMatMapBCol
MatBumpPercent: PMatBumpPercent
NamedObject: PNamedObject
PointArray: PPointArray
PointFlagArray: PPointFlagArray
FaceArray: PFaceArray
MshMatGroup: PMshMatGroup
MshBoxmap: PMshBoxmap
SmoothGroup: PSmoothGroup
TexVerts: PTexVerts
MeshMatrix: PMeshMatrix
MeshColor: PMeshColor
MeshTextureInfo: PMeshTextureInfo
ProcName: PProcName
NDirectLight: PNDirectLight
DlExclude: PDlExclude
DlInnerRange: PDlInnerRange
DlOuterRange: PDlOuterRange
DlMultiplier: PDlMultiplier
DlSpotlight: PDlSpotlight
DlLocalShadow2: PDlLocalShadow2
DlSpotRoll: PDlSpotRoll
DlSpotAspect: PDlSpotAspect
DlSpotProjector: PDlSpotProjector
DlRayBias: PDlRayBias
NCamera: PNCamera
CamRanges: PCamRanges
ViewportLayout: PViewportLayout
ViewportSize: PViewportSize
ViewportData: PViewportData
XDataEntry: PXDataEntry
XDataAppName: PXDataAppName
XDataString: PXDataString
KFHdr: PKFHdr
KFSeg: PKFSeg
KFCurtime: PKFCurtime
KFId: PKFId
NodeHdr: PNodeHdr
Pivot: PPivot
InstanceName: PInstanceName
MorphSmooth: PMorphSmooth
BoundBox: PBoundBox
PosTrackTag: PPosTrackTag
ColTrackTag: PColTrackTag
RotTrackTag: PRotTrackTag
ScaleTrackTag: PScaleTrackTag
MorphTrackTag: PMorphTrackTag
FovTrackTag: PFovTrackTag
RollTrackTag: PRollTrackTag
HotTrackTag: PHotTrackTag
FallTrackTag: PFallTrackTag
HideTrackTag: PHideTrackTag
Dummy: Pointer

Description

Fields

ColorF: PColorF
LinColorF: PLinColorF
Color24: PColor24
LinColor24: PLinColor24
IntPercentage: PIntPercentage
FloatPercentage: PFloatPercentage
MatMapname: PMatMapname
M3dVersion: PM3dVersion
MeshVersion: PMeshVersion
MasterScale: PMasterScale
LoShadowBias: PLoShadowBias
ShadowFilter: PShadowFilter
ShadowRange: PShadowRange
HiShadowBias: PHiShadowBias
RayBias: PRayBias
ShadowMapSize: PShadowMapSize
ShadowSamples: PShadowSamples
OConsts: POConsts
BitMapName: PBitMapName
VGradient: PVGradient
Fog: PFog
LayerFog: PLayerFog
DistanceCue: PDistanceCue
ViewStandard: PViewStandard
ViewUser: PViewUser
ViewCamera: PViewCamera
MatName: PMatName
MatShading: PMatShading
MatAcubic: PMatAcubic
IpasData: PIpasData
MatWireSize: PMatWireSize
MatMapTiling: PMatMapTiling
MatMapTexblur: PMatMapTexblur
MatMapUScale: PMatMapUScale
MatMapVScale: PMatMapVScale
MatMapUOffset: PMatMapUOffset
MatMapVOffset: PMatMapVOffset
MatMapAng: PMatMapAng
MatMapCol1: PMatMapCol1
MatMapCol2: PMatMapCol2
MatMapRCol: PMatMapRCol
MatMapGCol: PMatMapGCol
MatMapBCol: PMatMapBCol
MatBumpPercent: PMatBumpPercent
NamedObject: PNamedObject
PointArray: PPointArray
PointFlagArray: PPointFlagArray
FaceArray: PFaceArray
MshMatGroup: PMshMatGroup
MshBoxmap: PMshBoxmap
SmoothGroup: PSmoothGroup
TexVerts: PTexVerts
MeshMatrix: PMeshMatrix
MeshColor: PMeshColor
MeshTextureInfo: PMeshTextureInfo
ProcName: PProcName
NDirectLight: PNDirectLight
DlExclude: PDlExclude
DlInnerRange: PDlInnerRange
DlOuterRange: PDlOuterRange
DlMultiplier: PDlMultiplier
DlSpotlight: PDlSpotlight
DlLocalShadow2: PDlLocalShadow2
DlSpotRoll: PDlSpotRoll
DlSpotAspect: PDlSpotAspect
DlSpotProjector: PDlSpotProjector
DlRayBias: PDlRayBias
NCamera: PNCamera
CamRanges: PCamRanges
ViewportLayout: PViewportLayout
ViewportSize: PViewportSize
ViewportData: PViewportData
XDataEntry: PXDataEntry
XDataAppName: PXDataAppName
XDataString: PXDataString
KFHdr: PKFHdr
KFSeg: PKFSeg
KFCurtime: PKFCurtime
KFId: PKFId
NodeHdr: PNodeHdr
Pivot: PPivot
InstanceName: PInstanceName
MorphSmooth: PMorphSmooth
BoundBox: PBoundBox
PosTrackTag: PPosTrackTag
ColTrackTag: PColTrackTag
RotTrackTag: PRotTrackTag
ScaleTrackTag: PScaleTrackTag
MorphTrackTag: PMorphTrackTag
FovTrackTag: PFovTrackTag
RollTrackTag: PRollTrackTag
HotTrackTag: PHotTrackTag
FallTrackTag: PFallTrackTag
HideTrackTag: PHideTrackTag
Dummy: Pointer
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: Types3DS: record TChunk3DS

record TChunk3DS

Unit

Types3DS

Declaration

type TChunk3DS = record

Description

Overview

Fields

Tag: Word;
Size: Cardinal;
Position: Cardinal;
Data: TChunkData;
Sibling: PChunk3DS;
Children: PChunk3DS;

Description

Fields

Tag: Word;
Size: Cardinal;
Position: Cardinal;
Data: TChunkData;
Sibling: PChunk3DS;
Children: PChunk3DS;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesB3D

Unit TypesB3D

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

TypesB3D<p>

Types used on the B3D file loader<p>

<b>History :</b><font size=-1><ul> <li>22/12/05 - Mathx - Added to the GLScene Project. </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TB3DChunk |
record TBB3DChunk |
record TTEXSChunk |
record TBRUSChunk |
record TVertexData |
record TVRTSChunk |
record TTRISChunk |
record TMESHChunk |
record TBONEChunk |
record TKEYSChunk |
record TANIMChunk |
record TNODEChunk |

Types

TB3DChunkType = (...);
PB3DChunk = ˆTB3DChunk;
PBB3DChunk = ˆTBB3DChunk;
PTEXSChunk = ˆTTEXSChunk;
PBRUSChunk = ˆTBRUSChunk;
PVertexData = ˆTVertexData;
PVRTSChunk = ˆTVRTSChunk;
PTRISChunk = ˆTTRISChunk;
PMESHChunk = ˆTMESHChunk;
PBONEChunk = ˆTBONEChunk;
PKEYSChunk = ˆTKEYSChunk;
PANIMChunk = ˆTANIMChunk;
PNODEChunk = ˆTNODEChunk;

Description

Types

TB3DChunkType = (...);
Values
  • bctUnknown:
  • bctHeader:
  • bctTexture:
  • bctBrush:
  • bctNode:
  • bctVertex:
  • bctTriangle:
  • bctMesh:
  • bctBone:
  • bctKeyFrame:
  • bctAnimation:
PB3DChunk = ˆTB3DChunk;
PBB3DChunk = ˆTBB3DChunk;
PTEXSChunk = ˆTTEXSChunk;
PBRUSChunk = ˆTBRUSChunk;
PVertexData = ˆTVertexData;
PVRTSChunk = ˆTVRTSChunk;
PTRISChunk = ˆTTRISChunk;
PMESHChunk = ˆTMESHChunk;
PBONEChunk = ˆTBONEChunk;
PKEYSChunk = ˆTKEYSChunk;
PANIMChunk = ˆTANIMChunk;
PNODEChunk = ˆTNODEChunk;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesB3D: record TB3DChunk

record TB3DChunk

Unit

TypesB3D

Declaration

type TB3DChunk = record

Description

Overview

Fields

chunk: array[0..3] of char;
length: Integer;

Description

Fields

chunk: array[0..3] of char;
length: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesB3D: record TBB3DChunk

record TBB3DChunk

Unit

TypesB3D

Declaration

type TBB3DChunk = record

Description

Overview

Fields

Version: Integer;

Description

Fields

Version: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesB3D: record TTEXSChunk

record TTEXSChunk

Unit

TypesB3D

Declaration

type TTEXSChunk = record

Description

Overview

Fields

fileName: array[0..255] of char;
flags: Integer;
blend: Integer;
x_pos: Single;
y_pos: Single;
x_scale: Single;
y_scale: Single;
rotation: Single;

Description

Fields

fileName: array[0..255] of char;
flags: Integer;
blend: Integer;
x_pos: Single;
y_pos: Single;
x_scale: Single;
y_scale: Single;
rotation: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesB3D: record TBRUSChunk

record TBRUSChunk

Unit

TypesB3D

Declaration

type TBRUSChunk = record

Description

Overview

Fields

n_texs: Integer;
name: array[0..255] of Char;
red: Single;
green: Single;
blue: Single;
alpha: Single;
shininess: Single;
blend: Integer;
fx: Integer;
texture_id: array of Integer;

Description

Fields

n_texs: Integer;
name: array[0..255] of Char;
red: Single;
green: Single;
blue: Single;
alpha: Single;
shininess: Single;
blend: Integer;
fx: Integer;
texture_id: array of Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesB3D: record TVertexData

record TVertexData

Unit

TypesB3D

Declaration

type TVertexData = record

Description

Overview

Fields

next: PVertexData;
x: Single;
y: Single;
z: Single;
nx: Single;
ny: Single;
nz: Single;
red: Single;
green: Single;
blue: Single;
alpha: Single;
tex_coords: array of Single;

Description

Fields

next: PVertexData;
x: Single;
y: Single;
z: Single;
nx: Single;
ny: Single;
nz: Single;
red: Single;
green: Single;
blue: Single;
alpha: Single;
tex_coords: array of Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesB3D: record TVRTSChunk

record TVRTSChunk

Unit

TypesB3D

Declaration

type TVRTSChunk = record

Description

Overview

Fields

flags: Integer;
tex_coord_sets: Integer;
tex_coord_set_size: Integer;
vertices: PVertexData;

Description

Fields

flags: Integer;
tex_coord_sets: Integer;
tex_coord_set_size: Integer;
vertices: PVertexData;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesB3D: record TTRISChunk

record TTRISChunk

Unit

TypesB3D

Declaration

type TTRISChunk = record

Description

Overview

Fields

next: PTRISChunk;
brush_id: Integer;
vertex_id: array of Integer;

Description

Fields

next: PTRISChunk;
brush_id: Integer;
vertex_id: array of Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesB3D: record TMESHChunk

record TMESHChunk

Unit

TypesB3D

Declaration

type TMESHChunk = record

Description

Overview

Fields

brush_id: Integer;
vertices: TVRTSChunk;
triangles: PTRISChunk;

Description

Fields

brush_id: Integer;
vertices: TVRTSChunk;
triangles: PTRISChunk;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesB3D: record TBONEChunk

record TBONEChunk

Unit

TypesB3D

Declaration

type TBONEChunk = record

Description

Overview

Fields

vertex_id: Integer;
weight: Single;

Description

Fields

vertex_id: Integer;
weight: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesB3D: record TKEYSChunk

record TKEYSChunk

Unit

TypesB3D

Declaration

type TKEYSChunk = record

Description

Overview

Fields

next: PKEYSChunk;
flags: Integer;
frame: Integer;
position: TAffineVector;
scale: TAffineVector;
rotation: TVector;

Description

Fields

next: PKEYSChunk;
flags: Integer;
frame: Integer;
position: TAffineVector;
scale: TAffineVector;
rotation: TVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesB3D: record TANIMChunk

record TANIMChunk

Unit

TypesB3D

Declaration

type TANIMChunk = record

Description

Overview

Fields

flags: Integer;
frames: Integer;
fps: Single;

Description

Fields

flags: Integer;
frames: Integer;
fps: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesB3D: record TNODEChunk

record TNODEChunk

Unit

TypesB3D

Declaration

type TNODEChunk = record

Description

Overview

Fields

name: array[0..255] of char;
position: TAffineVector;
scale: TAffineVector;
rotation: TVector;
meshes: PMESHChunk;
keys: PKEYSChunk;
nodes: PNODEChunk;
animation: TANIMChunk;
next: PNODEChunk;
level: Integer;

Description

Fields

name: array[0..255] of char;
position: TAffineVector;
scale: TAffineVector;
rotation: TVector;
meshes: PMESHChunk;
keys: PKEYSChunk;
nodes: PNODEChunk;
animation: TANIMChunk;
next: PNODEChunk;
level: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesMD2

Unit TypesMD2

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TMD2VertexIndex |
record TMD2Triangle |
record TMD2TriangleVertex |
record TMD2AliasFrame |
record TMD2Header |

Types

PMD2VertexIndex = ˆTMD2VertexIndex;
PMD2AliasFrame = ˆTMD2AliasFrame;
TIndexList = array of TMD2VertexIndex;
TVertexList = array of array of TVector3f;

Constants

MAX_MD2_TRIANGLES = 4096;
MAX_MD2_VERTICES = 2048;
MAX_MD2_FRAMES = 512;
MAX_MD2_SKINS = 32;
MAX_MD2_SKINNAME = 64;

Description

Types

PMD2VertexIndex = ˆTMD2VertexIndex;
PMD2AliasFrame = ˆTMD2AliasFrame;
TIndexList = array of TMD2VertexIndex;
TVertexList = array of array of TVector3f;

Constants

MAX_MD2_TRIANGLES = 4096;
MAX_MD2_VERTICES = 2048;
MAX_MD2_FRAMES = 512;
MAX_MD2_SKINS = 32;
MAX_MD2_SKINNAME = 64;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesMD2: record TMD2VertexIndex

record TMD2VertexIndex

Unit

TypesMD2

Declaration

type TMD2VertexIndex = record

Description

Overview

Fields

A: integer;
B: integer;
C: integer;
A_S: single;
A_T: single;
B_S: single;
B_T: single;
C_S: single;
C_T: single;

Description

Fields

A: integer;
B: integer;
C: integer;
A_S: single;
A_T: single;
B_S: single;
B_T: single;
C_S: single;
C_T: single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesMD2: record TMD2Triangle

record TMD2Triangle

Unit

TypesMD2

Declaration

type TMD2Triangle = record

Description

Overview

Fields

VertexIndex: TVector3s;
TextureCoordIndex: TVector3s;

Description

Fields

VertexIndex: TVector3s;
TextureCoordIndex: TVector3s;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesMD2: record TMD2TriangleVertex

record TMD2TriangleVertex

Unit

TypesMD2

Declaration

type TMD2TriangleVertex = record

Description

Overview

Fields

V: array[0..2] of byte;
LightnormalIndex: byte;

Description

Fields

V: array[0..2] of byte;
LightnormalIndex: byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesMD2: record TMD2AliasFrame

record TMD2AliasFrame

Unit

TypesMD2

Declaration

type TMD2AliasFrame = record

Description

Overview

Fields

Scale: TVector3f;
Translate: TVector3f;
Name: array[0..15] of AnsiChar;
Vertices: array[0..0] of TMD2TriangleVertex;

Description

Fields

Scale: TVector3f;
Translate: TVector3f;
Name: array[0..15] of AnsiChar;
Vertices: array[0..0] of TMD2TriangleVertex;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:40


GLScene v.1.1.2: TypesMD2: record TMD2Header

record TMD2Header

Unit

TypesMD2

Declaration

type TMD2Header = record

Description

Overview

Fields

Ident: integer;
Version: integer;
SkinWidth: integer;
SkinHeight: integer;
FrameSize: integer;
Num_Skins: integer;
Num_Vertices: integer;
Num_TextureCoords: integer;
Num_VertexIndices: integer;
Num_GLCommdands: integer;
Num_Frames: integer;
Offset_skins: integer;
Offset_st: integer;
Offset_tris: integer;
Offset_frames: integer;
Offset_glcmds: integer;
Offset_end: integer;

Description

Fields

Ident: integer;
Version: integer;
SkinWidth: integer;
SkinHeight: integer;
FrameSize: integer;
Num_Skins: integer;
Num_Vertices: integer;
Num_TextureCoords: integer;
Num_VertexIndices: integer;
Num_GLCommdands: integer;
Num_Frames: integer;
Offset_skins: integer;
Offset_st: integer;
Offset_tris: integer;
Offset_frames: integer;
Offset_glcmds: integer;
Offset_end: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMDC

Unit TypesMDC

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

TypesMDC<p>

Types for Return to Castle Wolfenstein's MDC file format.<p>

Original code by Osman Turan (osmanturancom@yahoo.com)<p>

<b>History :</b><font size=-1><ul> <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>18/12/04 - PhP - fixed constants, improve performance <li>11/05/04 - SG - Added to CVS <li>07/02/04 - OT - Creation (Osman Turan) </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TMDCFileHeader |
packed record TMDCBorderFrame |
packed record TMDCTagName |
packed record TMDCTagFrame |
packed record TMDCTag |
packed record TMDCSurfaceHeader |
packed record TMDCSkin |
packed record TMDCBaseFrame |
packed record TMDCCompFrame |

Types

TMDCPoint = array[0..2] of Single;
TMDCAngle = TMDCPoint;
PMDCTagName = ˆTMDCTagName;
PMDCTagFrame = ˆTMDCTagFrame;
TMDCTriangle = array[0..2] of Cardinal;
TMDCTexCoord = array[0..1] of Single;
TMDCBaseVertex = array[0..3] of SmallInt;
TMDCCompVertex = array[0..3] of Byte;

Constants

MDCFILE_IDENTITY = 'IDPC';
MDCFILE_VERSION = 2;
MDC_BASEVERTEX_FACTOR = 0.015625;
MDC_COMPVERTEX_FACTOR = 0.046875;

Description

Types

TMDCPoint = array[0..2] of Single;
TMDCAngle = TMDCPoint;
PMDCTagName = ˆTMDCTagName;
PMDCTagFrame = ˆTMDCTagFrame;
TMDCTriangle = array[0..2] of Cardinal;
TMDCTexCoord = array[0..1] of Single;
TMDCBaseVertex = array[0..3] of SmallInt;
TMDCCompVertex = array[0..3] of Byte;

Constants

MDCFILE_IDENTITY = 'IDPC';
MDCFILE_VERSION = 2;
MDC_BASEVERTEX_FACTOR = 0.015625;
MDC_COMPVERTEX_FACTOR = 0.046875;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMDC: packed record TMDCFileHeader

packed record TMDCFileHeader

Unit

TypesMDC

Declaration

type TMDCFileHeader = packed record

Description

Overview

Fields

Ident: array[0..3] of AnsiChar;
Version: Cardinal;
Name: array[0..63] of AnsiChar;
Flags: Cardinal;
NumFrames: Cardinal;
NumTags: Cardinal;
NumSurfaces: Cardinal;
NumSkins: Cardinal;
OffsetBorderFrames: Cardinal;
OffsetTagNames: Cardinal;
OffsetTagFrames: Cardinal;
OffsetSurfaces: Cardinal;
OffsetEnd: Cardinal;

Description

Fields

Ident: array[0..3] of AnsiChar;
Version: Cardinal;
Name: array[0..63] of AnsiChar;
Flags: Cardinal;
NumFrames: Cardinal;
NumTags: Cardinal;
NumSurfaces: Cardinal;
NumSkins: Cardinal;
OffsetBorderFrames: Cardinal;
OffsetTagNames: Cardinal;
OffsetTagFrames: Cardinal;
OffsetSurfaces: Cardinal;
OffsetEnd: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMDC: packed record TMDCBorderFrame

packed record TMDCBorderFrame

Unit

TypesMDC

Declaration

type TMDCBorderFrame = packed record

Description

Overview

Fields

BBMin: TMDCPoint;
BBMax: TMDCPoint;
LocalOrigin: TMDCPoint;
Radius: Single;
Name: array[0..15] of AnsiChar;

Description

Fields

BBMin: TMDCPoint;
BBMax: TMDCPoint;
LocalOrigin: TMDCPoint;
Radius: Single;
Name: array[0..15] of AnsiChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMDC: packed record TMDCTagName

packed record TMDCTagName

Unit

TypesMDC

Declaration

type TMDCTagName = packed record

Description

Overview

Fields

Name: array[0..63] of AnsiChar;

Description

Fields

Name: array[0..63] of AnsiChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMDC: packed record TMDCTagFrame

packed record TMDCTagFrame

Unit

TypesMDC

Declaration

type TMDCTagFrame = packed record

Description

Overview

Fields

TagPosition: array[0..2] of Word;
TagAngle: array[0..2] of Word;

Description

Fields

TagPosition: array[0..2] of Word;
TagAngle: array[0..2] of Word;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMDC: packed record TMDCTag

packed record TMDCTag

Unit

TypesMDC

Declaration

type TMDCTag = packed record

Description

Overview

Fields

TagName: PMDCTagName;
TagFrame: PMDCTagFrame;

Description

Fields

TagName: PMDCTagName;
TagFrame: PMDCTagFrame;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMDC: packed record TMDCSurfaceHeader

packed record TMDCSurfaceHeader

Unit

TypesMDC

Declaration

type TMDCSurfaceHeader = packed record

Description

Overview

Fields

Ident: array[0..3] of AnsiChar;
Name: array[0..63] of AnsiChar;
Flags: Cardinal;
NumCompFrames: Cardinal;
NumBaseFrames: Cardinal;
NumSkins: Cardinal;
NumVertices: Cardinal;
NumTriangles: Cardinal;
OffsetTriangles: Cardinal;
OffsetSkins: Cardinal;
OffsetTexCoords: Cardinal;
OffsetBaseVerts: Cardinal;
OffsetCompVerts: Cardinal;
OffsetFrameBaseFrames: Cardinal;
OffsetFrameCompFrames: Cardinal;
OffsetEnd: Cardinal;

Description

Fields

Ident: array[0..3] of AnsiChar;
Name: array[0..63] of AnsiChar;
Flags: Cardinal;
NumCompFrames: Cardinal;
NumBaseFrames: Cardinal;
NumSkins: Cardinal;
NumVertices: Cardinal;
NumTriangles: Cardinal;
OffsetTriangles: Cardinal;
OffsetSkins: Cardinal;
OffsetTexCoords: Cardinal;
OffsetBaseVerts: Cardinal;
OffsetCompVerts: Cardinal;
OffsetFrameBaseFrames: Cardinal;
OffsetFrameCompFrames: Cardinal;
OffsetEnd: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMDC: packed record TMDCSkin

packed record TMDCSkin

Unit

TypesMDC

Declaration

type TMDCSkin = packed record

Description

Overview

Fields

Shader: array[0..63] of AnsiChar;
Flags: Cardinal;

Description

Fields

Shader: array[0..63] of AnsiChar;
Flags: Cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMDC: packed record TMDCBaseFrame

packed record TMDCBaseFrame

Unit

TypesMDC

Declaration

type TMDCBaseFrame = packed record

Description

Overview

Fields

BaseVertices: array of TMDCBaseVertex;

Description

Fields

BaseVertices: array of TMDCBaseVertex;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMDC: packed record TMDCCompFrame

packed record TMDCCompFrame

Unit

TypesMDC

Declaration

type TMDCCompFrame = packed record

Description

Overview

Fields

CompVertices: array of TMDCCompVertex;

Description

Fields

CompVertices: array of TMDCCompVertex;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMS3D

Unit TypesMS3D

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

TypesMS3D<p>

Types and structures for the MS3D file format.<p>

<b>Historique : </b><font size=-1><ul> <li>27/04/10 - Yar - Added more types (by TL) <li>24/07/09 - DaStr - TMS3DGroup.MaterialIndex is now Shortint (BugtrackerID = 2353633) <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>06/06/07 - DaStr - Added $I GLScene.inc Added GLColor to uses (BugtrackerID = 1732211) <li>31/08/03 - DanB - Some code standardisation (by Philipp) <li>16/06/03 - EG - Updated headers <li>10/03/03 - Matt - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TMS3DGroup |
record TMS3DHeader |
record TMS3DVertex |
record TMS3DTriangle |
record TMS3DMaterial |
record TMS3DKeyframeRotation |
record TMS3DKeyframePosition |
record TMS3DJointBase |
record TMS3DJoint |
record TMS3DComment |
Class TMS3DCommentList |
record TMS3D_vertex_ex_t |
Class TVertexWeightList |

Types

PMS3DVertexArray = ˆTMS3DVertexArray;
TMS3DVertexArray = array[0..MAX_MS3D_VERTICES - 1] of TMS3DVertex;
PMS3DTriangleArray = ˆTMS3DTriangleArray;
TMS3DTriangleArray = array[0..MAX_MS3D_TRIANGLES - 1] of TMS3DTriangle;
PMS3DKeyframeRotationArray = ˆTMS3DKeyframeRotationArray;
TMS3DKeyframeRotationArray = array[0..MAX_MS3D_KEYFRAMES - 1] of TMS3DKeyframeRotation;
PMS3DKeyframePositionArray = ˆTMS3DKeyframePositionArray;
TMS3DKeyframePositionArray = array[0..MAX_MS3D_KEYFRAMES - 1] of TMS3DKeyframePosition;
PMS3DJointArray = ˆTMS3DJointArray;
TMS3DJointArray = array[0..MAX_MS3D_JOINTS - 1] of TMS3DJoint;
pMS3DComment=ˆTMS3DComment;
pMS3D_vertex_ex_t=ˆTMS3D_vertex_ex_t;

Constants

MAX_MS3D_VERTICES = 8192;
MAX_MS3D_TRIANGLES = 16384;
MAX_MS3D_GROUPS = 128;
MAX_MS3D_MATERIALS = 128;
MAX_MS3D_JOINTS = 128;
MAX_MS3D_KEYFRAMES = 5000;

Description

Types

PMS3DVertexArray = ˆTMS3DVertexArray;
TMS3DVertexArray = array[0..MAX_MS3D_VERTICES - 1] of TMS3DVertex;
PMS3DTriangleArray = ˆTMS3DTriangleArray;
TMS3DTriangleArray = array[0..MAX_MS3D_TRIANGLES - 1] of TMS3DTriangle;
PMS3DKeyframeRotationArray = ˆTMS3DKeyframeRotationArray;
TMS3DKeyframeRotationArray = array[0..MAX_MS3D_KEYFRAMES - 1] of TMS3DKeyframeRotation;
PMS3DKeyframePositionArray = ˆTMS3DKeyframePositionArray;
TMS3DKeyframePositionArray = array[0..MAX_MS3D_KEYFRAMES - 1] of TMS3DKeyframePosition;
PMS3DJointArray = ˆTMS3DJointArray;
TMS3DJointArray = array[0..MAX_MS3D_JOINTS - 1] of TMS3DJoint;
pMS3DComment=ˆTMS3DComment;
pMS3D_vertex_ex_t=ˆTMS3D_vertex_ex_t;

Constants

MAX_MS3D_VERTICES = 8192;
MAX_MS3D_TRIANGLES = 16384;
MAX_MS3D_GROUPS = 128;
MAX_MS3D_MATERIALS = 128;
MAX_MS3D_JOINTS = 128;
MAX_MS3D_KEYFRAMES = 5000;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMS3D: Class TMS3DGroup

Class TMS3DGroup

Unit

TypesMS3D

Declaration

type TMS3DGroup = class(TObject)

Description

Hierarchy

  • TObject
  • TMS3DGroup

Overview

Fields

Public | Flags: byte;
Public | Name: array[0..31] of AnsiChar;
Public | NumTriangles: word;
Public | TriangleIndices: TList;
Public | MaterialIndex: Shortint;

Methods

Public | constructor Create;
Public | destructor Destroy; override;

Description

Fields

Public Flags: byte;
Public Name: array[0..31] of AnsiChar;
Public NumTriangles: word;
Public TriangleIndices: TList;
Public MaterialIndex: Shortint;

Methods

Public constructor Create;
Public destructor Destroy; override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMS3D: record TMS3DHeader

record TMS3DHeader

Unit

TypesMS3D

Declaration

type TMS3DHeader = record

Description

Overview

Fields

ID: array[0..9] of AnsiChar;
Version: integer;

Description

Fields

ID: array[0..9] of AnsiChar;
Version: integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMS3D: record TMS3DVertex

record TMS3DVertex

Unit

TypesMS3D

Declaration

type TMS3DVertex = record

Description

Overview

Fields

Flags: byte;
Vertex: TD3DVector;
BoneId: AnsiChar;
ReferenceCount: byte;

Description

Fields

Flags: byte;
Vertex: TD3DVector;
BoneId: AnsiChar;
ReferenceCount: byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMS3D: record TMS3DTriangle

record TMS3DTriangle

Unit

TypesMS3D

Declaration

type TMS3DTriangle = record

Description

Overview

Fields

Flags: word;
VertexIndices: array[0..2] of word;
VertexNormals: array[0..2] of TD3DVector;
S: array[0..2] of single;
T: array[0..2] of single;
SmoothingGroup: byte;
GroupIndex: byte;

Description

Fields

Flags: word;
VertexIndices: array[0..2] of word;
VertexNormals: array[0..2] of TD3DVector;
S: array[0..2] of single;
T: array[0..2] of single;
SmoothingGroup: byte;
GroupIndex: byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMS3D: record TMS3DMaterial

record TMS3DMaterial

Unit

TypesMS3D

Declaration

type TMS3DMaterial = record

Description

Overview

Fields

Name: array[0..31] of AnsiChar;
Ambient: TColorVector;
Diffuse: TColorVector;
Specular: TColorVector;
Emissive: TColorVector;
Shininess: single;
Transparency: single;
Mode: AnsiChar;
Texture: array[0..127] of AnsiChar;
Alphamap: array[0..127] of AnsiChar;

Description

Fields

Name: array[0..31] of AnsiChar;
Ambient: TColorVector;
Diffuse: TColorVector;
Specular: TColorVector;
Emissive: TColorVector;
Shininess: single;
Transparency: single;
Mode: AnsiChar;
Texture: array[0..127] of AnsiChar;
Alphamap: array[0..127] of AnsiChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMS3D: record TMS3DKeyframeRotation

record TMS3DKeyframeRotation

Unit

TypesMS3D

Declaration

type TMS3DKeyframeRotation = record

Description

Overview

Fields

Time: single;
Rotation: TD3DVector;

Description

Fields

Time: single;
Rotation: TD3DVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMS3D: record TMS3DKeyframePosition

record TMS3DKeyframePosition

Unit

TypesMS3D

Declaration

type TMS3DKeyframePosition = record

Description

Overview

Fields

Time: single;
Position: TD3DVector;

Description

Fields

Time: single;
Position: TD3DVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMS3D: record TMS3DJointBase

record TMS3DJointBase

Unit

TypesMS3D

Declaration

type TMS3DJointBase = record

Description

Overview

Fields

Flags: byte;
Name: array[0..31] of AnsiChar;
ParentName: array[0..31] of AnsiChar;
Rotation: TD3DVector;
Position: TD3DVector;
NumKeyFramesRot: word;
NumKeyFramesTrans: word;

Description

Fields

Flags: byte;
Name: array[0..31] of AnsiChar;
ParentName: array[0..31] of AnsiChar;
Rotation: TD3DVector;
Position: TD3DVector;
NumKeyFramesRot: word;
NumKeyFramesTrans: word;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMS3D: record TMS3DJoint

record TMS3DJoint

Unit

TypesMS3D

Declaration

type TMS3DJoint = record

Description

Overview

Fields

Base: TMS3DJointBase;
KeyFramesRot: PMS3DKeyframeRotationArray;
KeyFramesTrans: PMS3DKeyframePositionArray;

Description

Fields

Base: TMS3DJointBase;
KeyFramesRot: PMS3DKeyframeRotationArray;
KeyFramesTrans: PMS3DKeyframePositionArray;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMS3D: record TMS3DComment

record TMS3DComment

Unit

TypesMS3D

Declaration

type TMS3DComment = record

Description

Overview

Fields

index: Integer;
commentLength: integer;
comment: array of AnsiChar;

Description

Fields

index: Integer;
commentLength: integer;
comment: array of AnsiChar;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMS3D: Class TMS3DCommentList

Class TMS3DCommentList

Unit

TypesMS3D

Declaration

type TMS3DCommentList = class(TList)

Description

Hierarchy

  • TList
  • TMS3DCommentList

Overview

Methods

Public | destructor Destroy; override;
Public | function NewComment: pMS3DComment;

Description

Methods

Public destructor Destroy; override;
Public function NewComment: pMS3DComment;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMS3D: record TMS3D_vertex_ex_t

record TMS3D_vertex_ex_t

Unit

TypesMS3D

Declaration

type TMS3D_vertex_ex_t = record

Description

Overview

Fields

boneIds: array[0..2] of byte;
weights: array[0..2] of byte;
extra: cardinal;
unknown: cardinal;

Description

Fields

boneIds: array[0..2] of byte;
weights: array[0..2] of byte;
extra: cardinal;
unknown: cardinal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesMS3D: Class TVertexWeightList

Class TVertexWeightList

Unit

TypesMS3D

Declaration

type TVertexWeightList = class(TList)

Description

Hierarchy

  • TList
  • TVertexWeightList

Overview

Methods

Public | destructor Destroy; override;
Public | function newWeight: pMS3D_vertex_ex_t;
Public | procedure Clear; override;

Properties

Public | property subVersion: Integer read FsubVersion write SetsubVersion;
Public | property Weight[idx: Integer]: pMS3D_vertex_ex_t read GetWeight;

Description

Methods

Public destructor Destroy; override;
Public function newWeight: pMS3D_vertex_ex_t;
Public procedure Clear; override;

Properties

Public property subVersion: Integer read FsubVersion write SetsubVersion;
Public property Weight[idx: Integer]: pMS3D_vertex_ex_t read GetWeight;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesSTL

Unit TypesSTL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TSTLHeader |
packed record TSTLFace |

Types

TSTLVertex = TAffineVector;

Description

Types

TSTLVertex = TAffineVector;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesSTL: packed record TSTLHeader

packed record TSTLHeader

Unit

TypesSTL

Declaration

type TSTLHeader = packed record

Description

Overview

Fields

dummy: array[0..79] of byte;
nbFaces: Longint;

Description

Fields

dummy: array[0..79] of byte;
nbFaces: Longint;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: TypesSTL: packed record TSTLFace

packed record TSTLFace

Unit

TypesSTL

Declaration

type TSTLFace = packed record

Description

Overview

Fields

normal: TSTLVertex;
v1: TSTLVertex;
v2: TSTLVertex;
v3: TSTLVertex;
padding: array[0..1] of byte;

Description

Fields

normal: TSTLVertex;
v1: TSTLVertex;
v2: TSTLVertex;
v3: TSTLVertex;
padding: array[0..1] of byte;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_ApplicationFileIO

Unit uPSI_ApplicationFileIO

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TPSImport_ApplicationFileIO |

Functions and Procedures

procedure SIRegister_TDataFile(CL: TPSPascalCompiler);
procedure SIRegister_TApplicationFileIO(CL: TPSPascalCompiler);
procedure SIRegister_ApplicationFileIO(CL: TPSPascalCompiler);
procedure RIRegister_ApplicationFileIO_Routines(S: TPSExec);
procedure RIRegister_TDataFile(CL: TPSRuntimeClassImporter);
procedure RIRegister_TApplicationFileIO(CL: TPSRuntimeClassImporter);
procedure RIRegister_ApplicationFileIO(CL: TPSRuntimeClassImporter);
procedure Register;

Description

Functions and Procedures

procedure SIRegister_TDataFile(CL: TPSPascalCompiler);
procedure SIRegister_TApplicationFileIO(CL: TPSPascalCompiler);
procedure SIRegister_ApplicationFileIO(CL: TPSPascalCompiler);
procedure RIRegister_ApplicationFileIO_Routines(S: TPSExec);
procedure RIRegister_TDataFile(CL: TPSRuntimeClassImporter);
procedure RIRegister_TApplicationFileIO(CL: TPSRuntimeClassImporter);
procedure RIRegister_ApplicationFileIO(CL: TPSRuntimeClassImporter);
procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_ApplicationFileIO: Class TPSImport_ApplicationFileIO

Class TPSImport_ApplicationFileIO

Unit

uPSI_ApplicationFileIO

Declaration

type TPSImport_ApplicationFileIO = class(TPSPlugin)

Description

Hierarchy

  • TPSPlugin
  • TPSImport_ApplicationFileIO

Overview

Methods

Protected | procedure CompileImport1(CompExec: TPSScript); override;
Protected | procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;

Description

Methods

Protected procedure CompileImport1(CompExec: TPSScript); override;
Protected procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_GLStrings

Unit uPSI_GLStrings

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TPSImport_GLStrings |

Functions and Procedures

procedure SIRegister_GLStrings(CL: TPSPascalCompiler);
procedure Register;

Description

Functions and Procedures

procedure SIRegister_GLStrings(CL: TPSPascalCompiler);
procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_GLStrings: Class TPSImport_GLStrings

Class TPSImport_GLStrings

Unit

uPSI_GLStrings

Declaration

type TPSImport_GLStrings = class(TPSPlugin)

Description

Hierarchy

  • TPSPlugin
  • TPSImport_GLStrings

Overview

Methods

Protected | procedure CompileImport1(CompExec: TPSScript); override;
Protected | procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;

Description

Methods

Protected procedure CompileImport1(CompExec: TPSScript); override;
Protected procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_GLUtils

Unit uPSI_GLUtils

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TPSImport_GLUtils |

Functions and Procedures

procedure SIRegister_GLUtils(CL: TPSPascalCompiler);
procedure RIRegister_GLUtils_Routines(S: TPSExec);
procedure RIRegister_GLUtils(CL: TPSRuntimeClassImporter);
procedure Register;

Description

Functions and Procedures

procedure SIRegister_GLUtils(CL: TPSPascalCompiler);
procedure RIRegister_GLUtils_Routines(S: TPSExec);
procedure RIRegister_GLUtils(CL: TPSRuntimeClassImporter);
procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_GLUtils: Class TPSImport_GLUtils

Class TPSImport_GLUtils

Unit

uPSI_GLUtils

Declaration

type TPSImport_GLUtils = class(TPSPlugin)

Description

Hierarchy

  • TPSPlugin
  • TPSImport_GLUtils

Overview

Methods

Protected | procedure CompileImport1(CompExec: TPSScript); override;
Protected | procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;

Description

Methods

Protected procedure CompileImport1(CompExec: TPSScript); override;
Protected procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_PersistentClasses

Unit uPSI_PersistentClasses

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TPSImport_PersistentClasses |

Functions and Procedures

procedure SIRegister_EFilerException(CL: TPSPascalCompiler);
procedure SIRegister_EInvalidFileSignature(CL: TPSPascalCompiler);
procedure SIRegister_TGLInterfacedCollectionItem(CL: TPSPascalCompiler);
procedure SIRegister_TGLInterfacedPersistent(CL: TPSPascalCompiler);
procedure SIRegister_TGLOwnedPersistent(CL: TPSPascalCompiler);
procedure SIRegister_TTextWriter(CL: TPSPascalCompiler);
procedure SIRegister_TTextReader(CL: TPSPascalCompiler);
procedure SIRegister_TBinaryWriter(CL: TPSPascalCompiler);
procedure SIRegister_TBinaryReader(CL: TPSPascalCompiler);
procedure SIRegister_TPersistentObjectList(CL: TPSPascalCompiler);
procedure SIRegister_TPersistentObject(CL: TPSPascalCompiler);
procedure SIRegister_IPersistentObject(CL: TPSPascalCompiler);
procedure SIRegister_TVirtualWriter(CL: TPSPascalCompiler);
procedure SIRegister_TVirtualReader(CL: TPSPascalCompiler);
procedure SIRegister_PersistentClasses(CL: TPSPascalCompiler);
procedure RIRegister_PersistentClasses_Routines(S: TPSExec);
procedure RIRegister_EFilerException(CL: TPSRuntimeClassImporter);
procedure RIRegister_EInvalidFileSignature(CL: TPSRuntimeClassImporter);
procedure RIRegister_TGLInterfacedCollectionItem(CL: TPSRuntimeClassImporter);
procedure RIRegister_TGLInterfacedPersistent(CL: TPSRuntimeClassImporter);
procedure RIRegister_TGLOwnedPersistent(CL: TPSRuntimeClassImporter);
procedure RIRegister_TTextWriter(CL: TPSRuntimeClassImporter);
procedure RIRegister_TTextReader(CL: TPSRuntimeClassImporter);
procedure RIRegister_TBinaryWriter(CL: TPSRuntimeClassImporter);
procedure RIRegister_TBinaryReader(CL: TPSRuntimeClassImporter);
procedure RIRegister_TPersistentObjectList(CL: TPSRuntimeClassImporter);
procedure RIRegister_TPersistentObject(CL: TPSRuntimeClassImporter);
procedure RIRegister_TVirtualWriter(CL: TPSRuntimeClassImporter);
procedure RIRegister_TVirtualReader(CL: TPSRuntimeClassImporter);
procedure RIRegister_PersistentClasses(CL: TPSRuntimeClassImporter);
procedure Register;

Description

Functions and Procedures

procedure SIRegister_EFilerException(CL: TPSPascalCompiler);
procedure SIRegister_EInvalidFileSignature(CL: TPSPascalCompiler);
procedure SIRegister_TGLInterfacedCollectionItem(CL: TPSPascalCompiler);
procedure SIRegister_TGLInterfacedPersistent(CL: TPSPascalCompiler);
procedure SIRegister_TGLOwnedPersistent(CL: TPSPascalCompiler);
procedure SIRegister_TTextWriter(CL: TPSPascalCompiler);
procedure SIRegister_TTextReader(CL: TPSPascalCompiler);
procedure SIRegister_TBinaryWriter(CL: TPSPascalCompiler);
procedure SIRegister_TBinaryReader(CL: TPSPascalCompiler);
procedure SIRegister_TPersistentObjectList(CL: TPSPascalCompiler);
procedure SIRegister_TPersistentObject(CL: TPSPascalCompiler);
procedure SIRegister_IPersistentObject(CL: TPSPascalCompiler);
procedure SIRegister_TVirtualWriter(CL: TPSPascalCompiler);
procedure SIRegister_TVirtualReader(CL: TPSPascalCompiler);
procedure SIRegister_PersistentClasses(CL: TPSPascalCompiler);
procedure RIRegister_PersistentClasses_Routines(S: TPSExec);
procedure RIRegister_EFilerException(CL: TPSRuntimeClassImporter);
procedure RIRegister_EInvalidFileSignature(CL: TPSRuntimeClassImporter);
procedure RIRegister_TGLInterfacedCollectionItem(CL: TPSRuntimeClassImporter);
procedure RIRegister_TGLInterfacedPersistent(CL: TPSRuntimeClassImporter);
procedure RIRegister_TGLOwnedPersistent(CL: TPSRuntimeClassImporter);
procedure RIRegister_TTextWriter(CL: TPSRuntimeClassImporter);
procedure RIRegister_TTextReader(CL: TPSRuntimeClassImporter);
procedure RIRegister_TBinaryWriter(CL: TPSRuntimeClassImporter);
procedure RIRegister_TBinaryReader(CL: TPSRuntimeClassImporter);
procedure RIRegister_TPersistentObjectList(CL: TPSRuntimeClassImporter);
procedure RIRegister_TPersistentObject(CL: TPSRuntimeClassImporter);
procedure RIRegister_TVirtualWriter(CL: TPSRuntimeClassImporter);
procedure RIRegister_TVirtualReader(CL: TPSRuntimeClassImporter);
procedure RIRegister_PersistentClasses(CL: TPSRuntimeClassImporter);
procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_PersistentClasses: Class TPSImport_PersistentClasses

Class TPSImport_PersistentClasses

Unit

uPSI_PersistentClasses

Declaration

type TPSImport_PersistentClasses = class(TPSPlugin)

Description

Hierarchy

  • TPSPlugin
  • TPSImport_PersistentClasses

Overview

Methods

Public | procedure CompileImport1(CompExec: TPSScript); override;
Public | procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;

Description

Methods

Public procedure CompileImport1(CompExec: TPSScript); override;
Public procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_VectorGeometry

Unit uPSI_VectorGeometry

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TPSImport_VectorGeometry |

Functions and Procedures

procedure SIRegister_VectorGeometry(CL: TPSPascalCompiler);
procedure RIRegister_VectorGeometry_Routines(S: TPSExec);
procedure Register;

Description

Functions and Procedures

procedure SIRegister_VectorGeometry(CL: TPSPascalCompiler);
procedure RIRegister_VectorGeometry_Routines(S: TPSExec);
procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_VectorGeometry: Class TPSImport_VectorGeometry

Class TPSImport_VectorGeometry

Unit

uPSI_VectorGeometry

Declaration

type TPSImport_VectorGeometry = class(TPSPlugin)

Description

Hierarchy

  • TPSPlugin
  • TPSImport_VectorGeometry

Overview

Methods

Protected | procedure CompileImport1(CompExec: TPSScript); override;
Protected | procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;

Description

Methods

Protected procedure CompileImport1(CompExec: TPSScript); override;
Protected procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_VectorLists

Unit uPSI_VectorLists

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TPSImport_VectorLists |

Functions and Procedures

procedure SIRegister_TByteList(CL: TPSPascalCompiler);
procedure SIRegister_TDoubleList(CL: TPSPascalCompiler);
procedure SIRegister_TSingleList(CL: TPSPascalCompiler);
procedure SIRegister_TIntegerList(CL: TPSPascalCompiler);
procedure SIRegister_TBaseList(CL: TPSPascalCompiler);
procedure SIRegister_VectorLists(CL: TPSPascalCompiler);
procedure RIRegister_VectorLists_Routines(S: TPSExec);
procedure RIRegister_TByteList(CL: TPSRuntimeClassImporter);
procedure RIRegister_TDoubleList(CL: TPSRuntimeClassImporter);
procedure RIRegister_TSingleList(CL: TPSRuntimeClassImporter);
procedure RIRegister_TIntegerList(CL: TPSRuntimeClassImporter);
procedure RIRegister_TBaseList(CL: TPSRuntimeClassImporter);
procedure RIRegister_VectorLists(CL: TPSRuntimeClassImporter);
procedure Register;

Description

Functions and Procedures

procedure SIRegister_TByteList(CL: TPSPascalCompiler);
procedure SIRegister_TDoubleList(CL: TPSPascalCompiler);
procedure SIRegister_TSingleList(CL: TPSPascalCompiler);
procedure SIRegister_TIntegerList(CL: TPSPascalCompiler);
procedure SIRegister_TBaseList(CL: TPSPascalCompiler);
procedure SIRegister_VectorLists(CL: TPSPascalCompiler);
procedure RIRegister_VectorLists_Routines(S: TPSExec);
procedure RIRegister_TByteList(CL: TPSRuntimeClassImporter);
procedure RIRegister_TDoubleList(CL: TPSRuntimeClassImporter);
procedure RIRegister_TSingleList(CL: TPSRuntimeClassImporter);
procedure RIRegister_TIntegerList(CL: TPSRuntimeClassImporter);
procedure RIRegister_TBaseList(CL: TPSRuntimeClassImporter);
procedure RIRegister_VectorLists(CL: TPSRuntimeClassImporter);
procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_VectorLists: Class TPSImport_VectorLists

Class TPSImport_VectorLists

Unit

uPSI_VectorLists

Declaration

type TPSImport_VectorLists = class(TPSPlugin)

Description

Hierarchy

  • TPSPlugin
  • TPSImport_VectorLists

Overview

Methods

Protected | procedure CompileImport1(CompExec: TPSScript); override;
Protected | procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;

Description

Methods

Protected procedure CompileImport1(CompExec: TPSScript); override;
Protected procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_VectorTypes

Unit uPSI_VectorTypes

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TPSImport_VectorTypes |

Functions and Procedures

procedure SIRegister_VectorTypes(CL: TPSPascalCompiler);
procedure Register;

Description

Functions and Procedures

procedure SIRegister_VectorTypes(CL: TPSPascalCompiler);
procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_VectorTypes: Class TPSImport_VectorTypes

Class TPSImport_VectorTypes

Unit

uPSI_VectorTypes

Declaration

type TPSImport_VectorTypes = class(TPSPlugin)

Description

Hierarchy

  • TPSPlugin
  • TPSImport_VectorTypes

Overview

Methods

Protected | procedure CompileImport1(CompExec: TPSScript); override;
Protected | procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;

Description

Methods

Protected procedure CompileImport1(CompExec: TPSScript); override;
Protected procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_XCollection

Unit uPSI_XCollection

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TPSImport_XCollection |

Functions and Procedures

procedure SIRegister_TXCollection(CL: TPSPascalCompiler);
procedure SIRegister_TXCollectionItem(CL: TPSPascalCompiler);
procedure SIRegister_EFilerException(CL: TPSPascalCompiler);
procedure SIRegister_XCollection(CL: TPSPascalCompiler);
procedure RIRegister_XCollection_Routines(S: TPSExec);
procedure RIRegister_TXCollection(CL: TPSRuntimeClassImporter);
procedure RIRegister_TXCollectionItem(CL: TPSRuntimeClassImporter);
procedure RIRegister_EFilerException(CL: TPSRuntimeClassImporter);
procedure RIRegister_XCollection(CL: TPSRuntimeClassImporter);
procedure Register;

Description

Functions and Procedures

procedure SIRegister_TXCollection(CL: TPSPascalCompiler);
procedure SIRegister_TXCollectionItem(CL: TPSPascalCompiler);
procedure SIRegister_EFilerException(CL: TPSPascalCompiler);
procedure SIRegister_XCollection(CL: TPSPascalCompiler);
procedure RIRegister_XCollection_Routines(S: TPSExec);
procedure RIRegister_TXCollection(CL: TPSRuntimeClassImporter);
procedure RIRegister_TXCollectionItem(CL: TPSRuntimeClassImporter);
procedure RIRegister_EFilerException(CL: TPSRuntimeClassImporter);
procedure RIRegister_XCollection(CL: TPSRuntimeClassImporter);
procedure Register;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: uPSI_XCollection: Class TPSImport_XCollection

Class TPSImport_XCollection

Unit

uPSI_XCollection

Declaration

type TPSImport_XCollection = class(TPSPlugin)

Description

Hierarchy

  • TPSPlugin
  • TPSImport_XCollection

Overview

Methods

Protected | procedure CompileImport1(CompExec: TPSScript); override;
Protected | procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;

Description

Methods

Protected procedure CompileImport1(CompExec: TPSScript); override;
Protected procedure ExecImport1(CompExec: TPSScript; const ri: TPSRuntimeClassImporter); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: Utils3DS

Unit Utils3DS

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

Utils3DS<p>

Utility functions for the universal 3DS file reader and writer (TFile3DS). Essentially, the functions here are the heart of the import library as they deal actually with the database and chunks.

<b>History :</b><font size=-1><ul> <li>19/06/11 - Yar - Bugfixed undefined result of GetKFSegment (thanks to Johannes Pretorius, Bugtracker ID = 3319394) <li>12/06/10 - Yar - Fixes for Linux x64 <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>02/11/07 - DaStr - Fixed incorrect positioning when importing 3ds animation (Bugtracker ID = 1824372) Fixed memory leaks in the FreeChunkData() procedure (Bugtracker ID = 1823781) Added a standard GLScene header <li>30/03/07 - DaStr - Added $I GLScene.inc <li>24/03/07 - DaStr - Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>09/03/07 - DaStr - Fixed a potential AV in two InitMeshObj procedures (thanks Burkhard Carstens) (BugtrackerID = 1678649) <li>27/10/06 - LC - Fixed memory leak in RelMeshObjField (Bugtracker ID = 1585639) <li>12/08/02 - EG - ReadMatEntryChunk fix / COLOR_F chunk (coerni) </ul></font>

(c) Copyright 1999, Dipl. Ing. Mike Lischke (public@lischke-online.de)

Overview

Functions and Procedures

function GetAtmosphere(const Source: TFile3DS; var DB: TDatabase3DS): TAtmosphere3DS;
function GetBackground(const Source: TFile3DS; var DB: TDatabase3DS): TBackground3DS;
function GetMeshSet(const Source: TFile3DS; var DB: TDatabase3DS): TMeshSet3DS;
function GetViewport(const Source: TFile3DS; var DB: TDatabase3DS): TViewport3DS;
procedure AddChild(Parent, Child: PChunk3DS);
procedure AddChildOrdered(Parent, Child: PChunk3DS);
function FindChunk(Top: PChunk3DS; Tag: word): PChunk3DS;
function FindNextChunk(Local: PChunk3DS; Tag: word): PChunk3DS;
procedure FreeChunkData(var Chunk: PChunk3DS);
function GetCameraByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TCamera3DS;
function GetCameraCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetChunkValue(Tag: word): integer;
function GetMaterialByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TMaterial3DS;
function GetMaterialCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetMeshByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TMesh3DS;
function GetMeshCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetOmnilightByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TLight3DS;
function GetSpotlightByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TLight3DS;
function GetOmnilightCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetSpotlightCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
procedure InitChunk(var Chunk: PChunk3DS);
procedure ReleaseCamera(Camera: PCamera3DS);
procedure ReleaseChunk(var Chunk: PChunk3DS);
procedure ReleaseChunkList(var List: PChunkList3DS);
procedure ReleaseLight(Light: PLight3DS);
procedure ReleaseMaterial(Mat: PMaterial3DS);
procedure ReleaseMeshObj(Mesh: PMesh3DS);
function GetKFSettings(const Source: TFile3DS; var DB: TDatabase3DS): TKFSets3DS;
procedure ReleaseCameraMotion(Camera: PKFCamera3DS);
procedure GetCameraNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);
function GetCameraNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetCameraMotion(const Source: TFile3DS; CamChunk, TargetChunk: PChunk3DS): TKFCamera3DS;
function GetCameraMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TKFCamera3DS;
procedure ReleaseAmbientLightMotion(Light: PKFAmbient3DS);
function GetAmbientLightMotion(const Source: TFile3DS; var DB: TDatabase3DS): TKFAmbient3DS;
procedure InitObjectMotion(var Obj: TKFMesh3DS; NewNPKeys, NewNRKeys, NewNSKeys, NewNMKeys, NewNHKeys: cardinal);
procedure ReleaseObjectMotion(Obj: PKFMesh3DS);
procedure GetObjectNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);
function GetObjectNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetObjectMotionByName(const Source: TFile3DS; var DB: TDatabase3DS; Name: string): TKFMesh3DS;
function GetObjectMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: cardinal): TKFMesh3DS;
procedure ReleaseOmnilightMotion(Light: PKFOmni3DS);
procedure GetOmnilightNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);
function GetOmnilightNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): cardinal;
function GetOmnilightMotionByName(const Source: TFile3DS; var DB: TDatabase3DS; Name: string): TKFOmni3DS;
function GetOmnilightMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: cardinal): TKFOmni3DS;
procedure ReleaseSpotlightMotion(Spot: PKFSpot3DS);
procedure GetSpotlightNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);
function GetSpotlightNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): cardinal;
function GetSpotlightMotionByName(const Source: TFile3DS; var DB: TDatabase3DS; Name: string): TKFSpot3DS;
function GetSpotlightMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: cardinal): TKFSpot3DS;
function GetM3dMagicRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;
function GetMeshRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;
function GetKfRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;
function GetDatabaseRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;
procedure ChunkHeaderReport(var Strings: TStrings; Chunk: PChunk3DS; IndentLevel: integer);
function ChunkTagToString(Tag: word): string;
procedure DumpChunk(const Source: TFile3DS; var Strings: TStrings; Chunk: PChunk3DS; IndentLevel: integer; DumpLevel: TDumpLevel);
procedure DumpKeyHeader(Strings: TStrings; Key: TKeyHeader3DS; IndentLevel: integer);
procedure DeleteChunk(var Chunk: PChunk3DS);
function FindNamedObjectByIndex(Source: TFile3DS; DB: TDatabase3DS; AType: word; Index: integer): PChunk3DS;
procedure ShowError(ErrorMessage: string);
procedure ShowErrorFormatted(ErrorMessage: string; const Args: array of const);

Description

Functions and Procedures

function GetAtmosphere(const Source: TFile3DS; var DB: TDatabase3DS): TAtmosphere3DS;
function GetBackground(const Source: TFile3DS; var DB: TDatabase3DS): TBackground3DS;
function GetMeshSet(const Source: TFile3DS; var DB: TDatabase3DS): TMeshSet3DS;
function GetViewport(const Source: TFile3DS; var DB: TDatabase3DS): TViewport3DS;
procedure AddChild(Parent, Child: PChunk3DS);
procedure AddChildOrdered(Parent, Child: PChunk3DS);
function FindChunk(Top: PChunk3DS; Tag: word): PChunk3DS;
function FindNextChunk(Local: PChunk3DS; Tag: word): PChunk3DS;
procedure FreeChunkData(var Chunk: PChunk3DS);
function GetCameraByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TCamera3DS;
function GetCameraCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetChunkValue(Tag: word): integer;
function GetMaterialByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TMaterial3DS;
function GetMaterialCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetMeshByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TMesh3DS;
function GetMeshCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetOmnilightByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TLight3DS;
function GetSpotlightByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TLight3DS;
function GetOmnilightCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetSpotlightCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
procedure InitChunk(var Chunk: PChunk3DS);
procedure ReleaseCamera(Camera: PCamera3DS);
procedure ReleaseChunk(var Chunk: PChunk3DS);
procedure ReleaseChunkList(var List: PChunkList3DS);
procedure ReleaseLight(Light: PLight3DS);
procedure ReleaseMaterial(Mat: PMaterial3DS);
procedure ReleaseMeshObj(Mesh: PMesh3DS);
function GetKFSettings(const Source: TFile3DS; var DB: TDatabase3DS): TKFSets3DS;
procedure ReleaseCameraMotion(Camera: PKFCamera3DS);
procedure GetCameraNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);
function GetCameraNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetCameraMotion(const Source: TFile3DS; CamChunk, TargetChunk: PChunk3DS): TKFCamera3DS;
function GetCameraMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: integer): TKFCamera3DS;
procedure ReleaseAmbientLightMotion(Light: PKFAmbient3DS);
function GetAmbientLightMotion(const Source: TFile3DS; var DB: TDatabase3DS): TKFAmbient3DS;
procedure InitObjectMotion(var Obj: TKFMesh3DS; NewNPKeys, NewNRKeys, NewNSKeys, NewNMKeys, NewNHKeys: cardinal);
procedure ReleaseObjectMotion(Obj: PKFMesh3DS);
procedure GetObjectNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);
function GetObjectNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): integer;
function GetObjectMotionByName(const Source: TFile3DS; var DB: TDatabase3DS; Name: string): TKFMesh3DS;
function GetObjectMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: cardinal): TKFMesh3DS;
procedure ReleaseOmnilightMotion(Light: PKFOmni3DS);
procedure GetOmnilightNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);
function GetOmnilightNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): cardinal;
function GetOmnilightMotionByName(const Source: TFile3DS; var DB: TDatabase3DS; Name: string): TKFOmni3DS;
function GetOmnilightMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: cardinal): TKFOmni3DS;
procedure ReleaseSpotlightMotion(Spot: PKFSpot3DS);
procedure GetSpotlightNodeNameList(const Source: TFile3DS; var DB: TDatabase3DS; List: TStringList);
function GetSpotlightNodeCount(const Source: TFile3DS; var DB: TDatabase3DS): cardinal;
function GetSpotlightMotionByName(const Source: TFile3DS; var DB: TDatabase3DS; Name: string): TKFSpot3DS;
function GetSpotlightMotionByIndex(const Source: TFile3DS; var DB: TDatabase3DS; Index: cardinal): TKFSpot3DS;
function GetM3dMagicRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;
function GetMeshRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;
function GetKfRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;
function GetDatabaseRelease(const Source: TFile3DS; var DB: TDatabase3DS): TReleaseLevel;
procedure ChunkHeaderReport(var Strings: TStrings; Chunk: PChunk3DS; IndentLevel: integer);
function ChunkTagToString(Tag: word): string;
procedure DumpChunk(const Source: TFile3DS; var Strings: TStrings; Chunk: PChunk3DS; IndentLevel: integer; DumpLevel: TDumpLevel);
procedure DumpKeyHeader(Strings: TStrings; Key: TKeyHeader3DS; IndentLevel: integer);
procedure DeleteChunk(var Chunk: PChunk3DS);
function FindNamedObjectByIndex(Source: TFile3DS; DB: TDatabase3DS; AType: word; Index: integer): PChunk3DS;
procedure ShowError(ErrorMessage: string);
procedure ShowErrorFormatted(ErrorMessage: string; const Args: array of const);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:41


GLScene v.1.1.2: VectorGeometry

Unit VectorGeometry

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

VectorGeometry<p>

Base classes and structures for GLScene.<p>

Most common functions/procedures come in various flavours (using overloads), the naming convention is :<ul> <li>TypeOperation: functions returning a result, or accepting a "var" as last parameter to place result (VectorAdd, VectorCrossProduct...) <li>OperationType : procedures taking as first parameter a "var" that will be used as operand and result (AddVector, CombineVector...) </ul><p> As a general rule, procedures implementations (asm or not) are the fastest (up to 800% faster than function equivalents), due to reduced return value duplication overhead (the exception being the matrix operations).<p>

For better performance, it is recommended <b>not</b> to use the "Math" unit that comes with Delphi, and only use functions/procedures from this unit (the single-based functions have been optimized and are up to 100% faster, than extended-based ones from "Math").<p>

3DNow! SIMD instructions are automatically detected and used in *some* of the functions/procedures, typical gains (over FPU implementation) are approx a 100% speed increase on K6-2/3, and 20-60% on K7, and sometimes more (f.i. 650% on 4x4 matrix multiplication for the K6, 300% for RSqrt on K7).<p>

Cyrix, NexGen and other "exotic" CPUs may fault in the 3DNow! detection (initialization section), comment out or replace with your own detection routines if you want to support these. All AMD processors after K5, and all Intel processors after Pentium should be immune to this.<p>

<b>History : </b><font size=-1><ul>

<li>20/11/12 - PW - Added CPP compatibility using records instead arrays for vectors, moved IsPointInPolygon from GLGizmoEx; <li>05/06/12 - Maverick - Added SegmentPlaneIntersection routine <li>10/05/12 - Maverick - Added quad/disk intersection routines, c3PIdiv2 constant, some asm blocks <li>10/05/12 - Maverick - Added plane/triangle intersection routines, overloaded plane routines, linelinedistance routine <li>28/03/12 - Maverick - Added IsColinear test and Vector2d dot product <li>19/12/11 - Yar - Added VectorAdd for 2d vector (thanks microalexx)

<li>10/06/11 - DaStr - Added some Vector2f routines Overloaded some procedures to accept both 3f and 4f vectors Marked some methods as inline Added SignStrict, MoveObjectAround(), GetSafeTurnAngle(), RectanglesIntersect(), RectangleContains(), AngleBetweenVectors(), ShiftObjectFromCenter() <li>11/05/11 - Yar - Added ClampInteger <li>25/11/10 - DaStr - Added InterpolateExp() and itExp mode <li>04/11/10 - DaStr - Removed duplicate standard type definitions <li>09/08/10 - Yar - Added CreateLookAtMatrix, CreateMatrixFromFrustum, CreatePerspectiveMatrix, CreateOrthoMatrix, CreatePickMatrix, Project, UnProject <li>14/06/10 - Yar - Added VectorArrayLerp for TTexPointArray <li>06/06/10 - Yar - Fixed warnings for FPC <li>15/04/10 - Yar - Bugfixed vector normalization on Intel processors (thanks mif) (BugTracker ID = 2987779) <li>02/04/10 - Yar - Added inline directive for small vector operations <li>12/03/09 - DanB - Added overloaded versions of IsVolumeClipped <li>09/10/08 - DanB - moved TRenderContextClippingInfo + IsVolumeClipped functions that use TRenderContextClippingInfo to GLRenderContextInfo.pas <li>21/02/07 - DaStr - Bugfixed InterpolatePower() to support negative Base and not round Exponent parameters <li>12/02/08 - Mrqzzz - Removed cPIdiv360, not needed anymore, by Pete,Dan Bartlett <li>12/02/08 - Mrqzzz - Dave Gravel added const cPIdiv360 to fix ResetAndPitchTurnRoll <li>18/11/07 - DaStr - Added MatrixInvert(), VectorDivide() functions <li>19/09/07 - DaStr - Added AddPoint() and PointAdd() procedures <li>18/09/07 - DaStr - Added two more overloaded versions of VectorScale() <li>29/08/07 - LC - Fixed BarycentricCoordinates to work with triangles in yz plane <li>27/08/07 - DaStr - Bugfixed VectorAffineFltToDbl and VectorFltToDbl (thanks Biot!) (BugTracker ID = 1782005) <li>23/08/07 - LC - Added BarycentricCoordinates <li>16/04/07 - DaStr - Removed TMatrix[3/4][w/e] types (declared in VectorTypes.pas) <li>25/03/07 - DaStr - Replaced Types with GLCrossPlatform for Delphi 5 support Added YZHmgVector and XZHmgVector <li>21/03/07 - DaStr - Bugfixed MatrixDecompose (thanks Burkhard Carstens) (BugTrackerID=1684438) <li>06/03/07 - DaStr - Added InterpolateXXX and MatrixLerp functions <li>03/03/07 - DaStr - Added [Vector/Matrix/Rect]Equals, Vector[2/3/4][i/f/s/b/d]Make Added Vector[More/Less](Equal)Then <li>15/02/07 - DaStr - Returned to old code formating style <li>29/01/07 - DaStr - Added IntersectSphereBox (Thanks to dikoe Kenguru) <li>23/01/07 - fig - Added TexpointEquals() function <li>13/01/07 - DaStr - Added RayCastBoxIntersect and IntersectTriangleBox (Thanx to dikoe Kenguru) Deleted types that were duplicated (BugTrackerID = 1586318), some other types moved to VectorTypes unit <li>07/04/06 - DB - Fixed VectorArrayLerp_3DNow (affine) for n<=1 (dikoe Kenguru) <li>02/12/04 - MF - Added IsVolumeClipped overload that uses Frustum instead of rcci <li>02/08/04 - LR, YHC - BCB corrections: use record instead array move PAffineVectorArray, PVectorArray and PMatrixArray to VectorTypes Unit <li>08/07/04 - LR - Removed ../ from the GLScene.inc <li>26/10/03 - EG - Renamed from "Geometry.pas" to "VectorGeometry.pas" <li>17/10/03 - EG - Optimized Min/MaxInteger, some of the Min/MaxFloat <li>13/08/03 - SG - Added TQuaternionArray, PQuaternionArray and PQuaternion <li>21/07/03 - EG - Added RoundInt, faster Round/Round64, updated Power <li>04/07/03 - EG - New VectorCombine overload, some optimizations <li>18/06/03 - MF - Added PointSegmentClosestPoint, PointSegmentDistance, PointLineClosestPoint and PointLineDistance. <li>26/05/03 - EG - NO_ASM variant creation completed <li>22/05/03 - EG - All vSIMD asm tests should now be under GEOMETRY_NO_ASM control <li>20/05/03 - EG - Added MakeParallelProjectionMatrix <li>13/05/03 - EG - 3DNow! optimization for ClampValue <li>30/04/03 - EG - Hyperbolic trig functions (Aaron Hochwimmer) <li>14/02/03 - EG - Added ScaleAndRound <li>28/01/03 - EG - Affine matrix inversion and related functions (Dan Barlett) <li>29/10/02 - EG - New MinFloat overloads (Bob) <li>04/09/02 - EG - New Abs/Max functions, VectorTransform(affine, hmgMatrix) now considers the matrix as 4x3 (was 3x3) <li>21/08/02 - EG - Added Pack/UnPackRotationMatrix <li>13/08/02 - EG - Added Area functions <li>20/07/02 - EG - Fixed RayCastTriangleIntersect "backward" hits <li>05/07/02 - EG - Started adding non-asm variants (GEOMETRY_NO_ASM) <li>22/02/02 - EG - Temporary Quaternion fix for VectorAngleLerp <li>12/02/02 - EG - Added QuaternionFromEuler (Alex Grigny de Castro) <li>11/02/02 - EG - Non-spinned QuaternionSlerp (Alex Grigny de Castro) <li>07/02/02 - EG - Added AnglePreservingMatrixInvert <li>30/01/02 - EG - New Quaternion<->Matrix code (Alex Grigny de Castro) <li>29/01/02 - EG - Fixed AngleLerp, added DistanceBetweenAngles (Alex Grigny de Castro) <li>20/01/02 - EG - Added VectorArrayAdd, ScaleFloatArray, OffsetFloatArray <li>11/01/02 - EG - 3DNow Optim for VectorAdd (hmg) <li>10/01/02 - EG - Fixed VectorEquals ("True" wasn't Pascal compliant "1"), 3DNow optims for vector mormalizations (affine), Added RSqrt <li>04/01/02 - EG - Updated/fixed RayCastTriangleIntersect <li>13/12/01 - EG - Fixed MakeReflectionMatrix <li>02/11/01 - EG - Faster mode for PrepareSinCosCache (by Nelson Chu) <li>22/08/01 - EG - Some new overloads <li>19/08/01 - EG - Added sphere raycasting functions <li>08/08/01 - EG - Added MaxFloat overloads <li>24/07/01 - EG - VectorAngle renamed to VectorAngleCosine to avoid confusions <li>06/07/01 - EG - Added NormalizeDegAngle <li>04/07/01 - EG - Now uses VectorTypes <li>18/03/01 - EG - Added AngleLerp and NormalizeAngle <li>15/03/01 - EG - Added Int, Ceil and Floor, faster "Frac" <li>06/03/01 - EG - Fix in PointInPolygon by Pavel Vassiliev <li>04/03/01 - EG - Added NormalizeVectorArray <li>03/03/01 - EG - Added MakeReflectionMatrix <li>02/03/01 - EG - New PointInPolygon code by Pavel Vassiliev <li>25/02/01 - EG - Fixed 'VectorSubstract', added VectorArrayLerp and a few minors <li>22/02/01 - EG - Added MinXYZ/MaxXYZ variants and Plane-Line intersection <li>21/02/01 - EG - Added Sign, MinFloat & MaxFloat <li>15/02/01 - EG - Faster Vector Transforms (3DNow! optimizations) <li>14/02/01 - EG - Faster Matrix multiplications (3DNow! & FPU optimizations), Added support for FPU-only sections <li>05/02/01 - EG - Faster VectorEquals <li>21/01/01 - EG - Fixed MakePoint/Vector affine variants (thx Jacques Tur) <li>17/01/00 - EG - VectoAdd return type fix (thx Jacques Tur), also added a few new overloads <li>05/11/00 - EG - Added RayCastPlaneIntersect <li>08/10/00 - EG - Added SetMatrix <li>13/08/00 - EG - Added Plane geometry support <li>06/08/00 - EG - Various minor additions <li>16/07/00 - EG - Added some new mixed vector/scalar funcs and new overloads <li>12/07/00 - EG - New overloads and replacements for Power, Trunc, Frac & Round <li>25/06/00 - EG - End of major update <li>13/06/00 - EG - Start of major update <li>09/06/00 - EG - Some additions and fixes in preparation for major changes <li>05/06/00 - EG - Added VectorLength overloads <li>26/05/00 - EG - [0..0] arrays changed to [0..cMaxArray] <li>23/05/00 - EG - Added intersection functions, Replaced some xxxAffinexxx funcs with overloads <li>22/03/00 - EG - Added MakeShadowMatrix (adapted from "OpenGL SuperBible" book) <li>21/03/00 - EG - Removed PWordArray (was a SysUtils's duplicate) <li>06/02/00 - EG - Added VectorEquals <li>05/02/00 - EG - Added some "const", more still needed, Added overloads for some of the MakeXXXVector funcs, Added homogeneous vector consts, VectorSpacing </ul>

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TTexPoint |
record TQuaternion |
record TRectangle |
record TFrustum |

Functions and Procedures

function TexPointMake(const s, t : Single) : TTexPoint;
function AffineVectorMake(const x, y, z : Single) : TAffineVector; overload;
function AffineVectorMake(const v : TVector) : TAffineVector; overload;
procedure SetAffineVector(out v : TAffineVector; const x, y, z : Single); overload;
procedure SetVector(out v : TAffineVector; const x, y, z : Single); overload;
procedure SetVector(out v : TAffineVector; const vSrc : TVector); overload;
procedure SetVector(out v : TAffineVector; const vSrc : TAffineVector); overload;
procedure SetVector(out v : TAffineDblVector; const vSrc : TAffineVector); overload;
procedure SetVector(out v : TAffineDblVector; const vSrc : TVector); overload;
function VectorMake(const v : TAffineVector; w : Single = 0) : TVector; overload;
function VectorMake(const x, y, z: Single; w : Single = 0) : TVector; overload;
function PointMake(const x, y, z: Single) : TVector; overload;
function PointMake(const v : TAffineVector) : TVector; overload;
function PointMake(const v : TVector) : TVector; overload;
procedure SetVector(out v : TVector; const x, y, z : Single; w : Single = 0); overload;
procedure SetVector(out v : TVector; const av : TAffineVector; w : Single = 0); overload;
procedure SetVector(out v : TVector; const vSrc : TVector); overload;
procedure MakePoint(out v : TVector; const x, y, z: Single); overload;
procedure MakePoint(out v : TVector; const av : TAffineVector); overload;
procedure MakePoint(out v : TVector; const av : TVector); overload;
procedure MakeVector(out v : TAffineVector; const x, y, z: Single); overload;
procedure MakeVector(out v : TVector; const x, y, z: Single); overload;
procedure MakeVector(out v : TVector; const av : TAffineVector); overload;
procedure MakeVector(out v : TVector; const av : TVector); overload;
procedure RstVector(var v : TAffineVector); overload;
procedure RstVector(var v : TVector); overload;
function VectorEquals(const Vector1, Vector2: TVector2f): Boolean; overload;
function VectorEquals(const Vector1, Vector2: TVector2i): Boolean; overload;
function VectorEquals(const V1, V2: TVector2d): Boolean; overload;
function VectorEquals(const V1, V2: TVector2s): Boolean; overload;
function VectorEquals(const V1, V2: TVector2b): Boolean; overload;
function VectorEquals(const V1, V2: TVector3i): Boolean; overload;
function VectorEquals(const V1, V2: TVector3d): Boolean; overload;
function VectorEquals(const V1, V2: TVector3s): Boolean; overload;
function VectorEquals(const V1, V2: TVector3b): Boolean; overload;
function VectorEquals(const V1, V2: TVector4i): Boolean; overload;
function VectorEquals(const V1, V2: TVector4d): Boolean; overload;
function VectorEquals(const V1, V2: TVector4s): Boolean; overload;
function VectorEquals(const V1, V2: TVector4b): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3f): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3i): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3d): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3s): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3b): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4f): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4i): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4d): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4s): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4b): Boolean; overload;
function Vector2fMake(const X, Y: Single): TVector2f; overload;
function Vector2iMake(const X, Y: Longint): TVector2i; overload;
function Vector2sMake(const X, Y: Smallint): TVector2s; overload;
function Vector2dMake(const X, Y: Double): TVector2d; overload;
function Vector2bMake(const X, Y: Byte): TVector2b; overload;
function Vector2fMake(const Vector: TVector3f): TVector2f; overload;
function Vector2iMake(const Vector: TVector3i): TVector2i; overload;
function Vector2sMake(const Vector: TVector3s): TVector2s; overload;
function Vector2dMake(const Vector: TVector3d): TVector2d; overload;
function Vector2bMake(const Vector: TVector3b): TVector2b; overload;
function Vector2fMake(const Vector: TVector4f): TVector2f; overload;
function Vector2iMake(const Vector: TVector4i): TVector2i; overload;
function Vector2sMake(const Vector: TVector4s): TVector2s; overload;
function Vector2dMake(const Vector: TVector4d): TVector2d; overload;
function Vector2bMake(const Vector: TVector4b): TVector2b; overload;
function Vector3fMake(const X: Single; const Y: Single = 0; const Z: Single = 0): TVector3f; overload;
function Vector3iMake(const X: Longint; const Y: Longint = 0; const Z: Longint = 0): TVector3i; overload;
function Vector3sMake(const X: Smallint; const Y: Smallint = 0; const Z: Smallint = 0): TVector3s; overload;
function Vector3dMake(const X: Double; const Y: Double = 0; const Z: Double = 0): TVector3d; overload;
function Vector3bMake(const X: Byte; const Y: Byte = 0; const Z: Byte = 0): TVector3b; overload;
function Vector3fMake(const Vector: TVector2f; const Z: Single = 0): TVector3f; overload;
function Vector3iMake(const Vector: TVector2i; const Z: Longint = 0): TVector3i; overload;
function Vector3sMake(const Vector: TVector2s; const Z: Smallint = 0): TVector3s; overload;
function Vector3dMake(const Vector: TVector2d; const Z: Double = 0): TVector3d; overload;
function Vector3bMake(const Vector: TVector2b; const Z: Byte = 0): TVector3b; overload;
function Vector3fMake(const Vector: TVector4f): TVector3f; overload;
function Vector3iMake(const Vector: TVector4i): TVector3i; overload;
function Vector3sMake(const Vector: TVector4s): TVector3s; overload;
function Vector3dMake(const Vector: TVector4d): TVector3d; overload;
function Vector3bMake(const Vector: TVector4b): TVector3b; overload;
function Vector4fMake(const X: Single; const Y: Single = 0; const Z: Single = 0; const W: Single = 0): TVector4f; overload;
function Vector4iMake(const X: Longint; const Y: Longint = 0; const Z: Longint = 0; const W: Longint = 0): TVector4i; overload;
function Vector4sMake(const X: Smallint; const Y: Smallint = 0; const Z: Smallint = 0; const W: Smallint = 0): TVector4s; overload;
function Vector4dMake(const X: Double; const Y: Double = 0; const Z: Double = 0; const W: Double = 0): TVector4d; overload;
function Vector4bMake(const X: Byte; const Y: Byte = 0; const Z: Byte = 0; const W: Byte = 0): TVector4b; overload;
function Vector4fMake(const Vector: TVector3f; const W: Single = 0): TVector4f; overload;
function Vector4iMake(const Vector: TVector3i; const W: Longint = 0): TVector4i; overload;
function Vector4sMake(const Vector: TVector3s; const W: Smallint = 0): TVector4s; overload;
function Vector4dMake(const Vector: TVector3d; const W: Double = 0): TVector4d; overload;
function Vector4bMake(const Vector: TVector3b; const W: Byte = 0): TVector4b; overload;
function Vector4fMake(const Vector: TVector2f; const Z: Single = 0; const W: Single = 0): TVector4f; overload;
function Vector4iMake(const Vector: TVector2i; const Z: Longint = 0; const W: Longint = 0): TVector4i; overload;
function Vector4sMake(const Vector: TVector2s; const Z: Smallint = 0; const W: Smallint = 0): TVector4s; overload;
function Vector4dMake(const Vector: TVector2d; const Z: Double = 0; const W: Double = 0): TVector4d; overload;
function Vector4bMake(const Vector: TVector2b; const Z: Byte = 0; const W: Byte = 0): TVector4b; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorAdd(const v1, v2 : TVector2f) : TVector2f; overload;
function VectorAdd(const v1, v2 : TAffineVector) : TAffineVector; overload;
procedure VectorAdd(const v1, v2 : TAffineVector; var vr : TAffineVector); overload;
procedure VectorAdd(const v1, v2 : TAffineVector; vr : PAffineVector); overload;
function VectorAdd(const v1, v2 : TVector) : TVector; overload;
procedure VectorAdd(const v1, v2 : TVector; var vr : TVector); overload;
function VectorAdd(const v : TAffineVector; const f : Single) : TAffineVector; overload;
function VectorAdd(const v : TVector; const f : Single) : TVector; overload;
procedure AddVector(var v1 : TAffineVector; const v2 : TAffineVector); overload;
procedure AddVector(var v1 : TAffineVector; const v2 : TVector); overload;
procedure AddVector(var v1 : TVector; const v2 : TVector); overload;
procedure AddVector(var v : TAffineVector; const f : Single); overload;
procedure AddVector(var v : TVector; const f : Single); overload;
procedure AddPoint(var v1 : TVector; const v2 : TVector); overload;
function PointAdd(var v1 : TVector; const v2 : TVector): TVector; overload;
procedure TexPointArrayAdd(const src : PTexPointArray; const delta : TTexPoint; const nb : Integer; dest : PTexPointArray); overload;
procedure TexPointArrayScaleAndAdd(const src : PTexPointArray; const delta : TTexPoint; const nb : Integer; const scale : TTexPoint; dest : PTexPointArray); overload;
procedure VectorArrayAdd(const src : PAffineVectorArray; const delta : TAffineVector; const nb : Integer; dest : PAffineVectorArray); overload;
function VectorSubtract(const V1, V2 : TVector2f) : TVector2f; overload;
procedure SubtractVector(var V1 : TVector2f; const V2 : TVector2f); overload;
function VectorSubtract(const V1, V2 : TAffineVector) : TAffineVector; overload;
procedure VectorSubtract(const v1, v2 : TAffineVector; var result : TAffineVector); overload;
procedure VectorSubtract(const v1, v2 : TAffineVector; var result : TVector); overload;
procedure VectorSubtract(const v1 : TVector; v2 : TAffineVector; var result : TVector); overload;
function VectorSubtract(const V1, V2 : TVector) : TVector; overload;
procedure VectorSubtract(const v1, v2 : TVector; var result : TVector); overload;
procedure VectorSubtract(const v1, v2 : TVector; var result : TAffineVector); overload;
function VectorSubtract(const v1 : TAffineVector; delta : Single) : TAffineVector; overload;
function VectorSubtract(const v1 : TVector; delta : Single) : TVector; overload;
procedure SubtractVector(var V1 : TAffineVector; const V2 : TAffineVector); overload;
procedure SubtractVector(var V1 : TVector; const V2 : TVector); overload;
procedure CombineVector(var vr : TAffineVector; const v : TAffineVector; var f : Single); overload;
procedure CombineVector(var vr : TAffineVector; const v : TAffineVector; pf : PFloat); overload;
function TexPointCombine(const t1, t2 : TTexPoint; f1, f2 : Single) : TTexPoint;
function VectorCombine(const V1, V2: TAffineVector; const F1, F2: Single): TAffineVector; overload;
function VectorCombine3(const V1, V2, V3: TAffineVector; const F1, F2, F3: Single): TAffineVector; overload;
procedure VectorCombine3(const V1, V2, V3: TAffineVector; const F1, F2, F3: Single; var vr : TAffineVector); overload;
procedure CombineVector(var vr : TVector; const v : TVector; var f : Single); overload;
procedure CombineVector(var vr : TVector; const v : TAffineVector; var f : Single); overload;
function VectorCombine(const V1, V2: TVector; const F1, F2: Single): TVector; overload;
function VectorCombine(const V1 : TVector; const V2: TAffineVector; const F1, F2: Single): TVector; overload;
procedure VectorCombine(const V1 : TVector; const V2: TAffineVector; const F1, F2: Single; var vr : TVector); overload;
procedure VectorCombine(const V1, V2: TVector; const F1, F2: Single; var vr : TVector); overload;
procedure VectorCombine(const V1, V2: TVector; const F2: Single; var vr : TVector); overload;
function VectorCombine3(const V1, V2, V3: TVector; const F1, F2, F3: Single): TVector; overload;
procedure VectorCombine3(const V1, V2, V3: TVector; const F1, F2, F3: Single; var vr : TVector); overload;
function VectorDotProduct(const V1, V2 : Tvector2f) : Single; overload;
function VectorDotProduct(const V1, V2 : TAffineVector) : Single; overload;
function VectorDotProduct(const V1, V2 : TVector) : Single; overload;
function VectorDotProduct(const V1 : TVector; const V2 : TAffineVector) : Single; overload;
function PointProject(const p, origin, direction : TAffineVector) : Single; overload;
function PointProject(const p, origin, direction : TVector) : Single; overload;
function VectorCrossProduct(const V1, V2 : TAffineVector): TAffineVector; overload;
function VectorCrossProduct(const V1, V2 : TVector): TVector; overload;
procedure VectorCrossProduct(const v1, v2 : TVector; var vr : TVector); overload;
procedure VectorCrossProduct(const v1, v2 : TAffineVector; var vr : TVector); overload;
procedure VectorCrossProduct(const v1, v2 : TVector; var vr : TAffineVector); overload;
procedure VectorCrossProduct(const v1, v2 : TAffineVector; var vr : TAffineVector); overload;
function Lerp(const start, stop, t : Single) : Single;
function AngleLerp(start, stop, t : Single) : Single;
function MatrixLerp(const m1, m2: TMatrix; const Delta: Single): TMatrix;
function DistanceBetweenAngles(angle1, angle2 : Single) : Single;
function TexPointLerp(const t1, t2 : TTexPoint; t : Single) : TTexPoint; overload;
function VectorLerp(const v1, v2 : TAffineVector; t : Single) : TAffineVector; overload;
procedure VectorLerp(const v1, v2 : TAffineVector; t : Single; var vr : TAffineVector); overload;
function VectorLerp(const v1, v2 : TVector; t : Single) : TVector; overload;
procedure VectorLerp(const v1, v2 : TVector; t : Single; var vr : TVector); overload;
function VectorAngleLerp(const v1, v2 : TAffineVector; t : Single) : TAffineVector; overload;
function VectorAngleCombine(const v1, v2 : TAffineVector; f : Single) : TAffineVector; overload;
procedure VectorArrayLerp(const src1, src2 : PVectorArray; t : Single; n : Integer; dest : PVectorArray); overload;
procedure VectorArrayLerp(const src1, src2 : PAffineVectorArray; t : Single; n : Integer; dest : PAffineVectorArray); overload;
procedure VectorArrayLerp(const src1, src2 : PTexPointArray; t : Single; n : Integer; dest : PTexPointArray); overload;
function InterpolatePower(const Start, Stop, Delta: Single; const DistortionDegree: Single): Single;
function InterpolateLn(const Start, Stop, Delta: Single; const DistortionDegree: Single): Single;
function InterpolateExp(const Start, Stop, Delta: Single; const DistortionDegree: Single): Single;
function InterpolateSin(const Start, Stop, Delta: Single): Single;
function InterpolateTan(const Start, Stop, Delta: Single): Single;
function InterpolateSinAlt(const Start, Stop, Delta: Single): Single;
function InterpolateCombinedFastPower(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single): Single;
function InterpolateCombinedSafe(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single;
function InterpolateCombinedFast(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single;
function InterpolateCombined(const Start, Stop, Delta: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single;
function VectorLength(const x, y : Single) : Single; overload;
function VectorLength(const x, y, z : Single) : Single; overload;
function VectorLength(const v : TVector2f) : Single; overload;
function VectorLength(const v : TAffineVector) : Single; overload;
function VectorLength(const v : TVector) : Single; overload;
function VectorLength(const v : array of Single) : Single; overload;
function VectorNorm(const x, y : Single) : Single; overload;
function VectorNorm(const v : TAffineVector) : Single; overload;
function VectorNorm(const v : TVector) : Single; overload;
function VectorNorm(var V: array of Single) : Single; overload;
procedure NormalizeVector(var v : TVector2f); overload;
procedure NormalizeVector(var v : TAffineVector); overload;
procedure NormalizeVector(var v : TVector); overload;
function VectorNormalize(const v : TVector2f) : TVector2f; overload;
function VectorNormalize(const v : TAffineVector) : TAffineVector; overload;
function VectorNormalize(const v : TVector) : TVector; overload;
procedure NormalizeVectorArray(list : PAffineVectorArray; n : Integer); overload;
function VectorAngleCosine(const V1, V2: TAffineVector) : Single; overload;
function VectorAngleCosine(const V1, V2: TVector) : Single; overload;
function VectorNegate(const Vector : TAffineVector) : TAffineVector; overload;
function VectorNegate(const Vector : TVector) : TVector; overload;
procedure NegateVector(var V : TAffineVector); overload;
procedure NegateVector(var V : TVector); overload;
procedure NegateVector(var V : array of Single); overload;
procedure ScaleVector(var v : TVector2f; factor : Single); overload;
procedure ScaleVector(var v : TAffineVector; factor : Single); overload;
procedure ScaleVector(var v : TAffineVector; const factor : TAffineVector); overload;
procedure ScaleVector(var v : TVector; factor : Single); overload;
procedure ScaleVector(var v : TVector; const factor : TVector); overload;
function VectorScale(const v : TVector2f; factor : Single) : TVector2f; overload;
function VectorScale(const v : TAffineVector; factor : Single) : TAffineVector; overload;
procedure VectorScale(const v : TAffineVector; factor : Single; var vr : TAffineVector); overload;
function VectorScale(const v : TVector; factor : Single) : TVector; overload;
procedure VectorScale(const v : TVector; factor : Single; var vr : TVector); overload;
procedure VectorScale(const v : TVector; factor : Single; var vr : TAffineVector); overload;
function VectorScale(const v : TAffineVector; const Factor : TAffineVector): TAffineVector; overload;
function VectorScale(const v : TVector; const Factor : TVector): TVector; overload;
procedure DivideVector(var v : TVector; const divider : TVector); overload;
procedure DivideVector(var v : TAffineVector; const divider : TAffineVector); overload;
function VectorDivide(const v: TVector; const divider : TVector): TVector; overload;
function VectorDivide(const v: TAffineVector; const divider : TAffineVector): TAffineVector; overload;
function TexpointEquals(const p1, p2: TTexpoint): Boolean;
function RectEquals(const Rect1, Rect2: TRect): Boolean;
function VectorEquals(const V1, V2: TVector) : Boolean; overload;
function VectorEquals(const V1, V2: TAffineVector) : Boolean; overload;
function AffineVectorEquals(const V1, V2: TVector) : Boolean; overload;
function VectorIsNull(const v : TVector) : Boolean; overload;
function VectorIsNull(const v : TAffineVector) : Boolean; overload;
function VectorSpacing(const v1, v2 : TTexPoint): Single; overload;
function VectorSpacing(const v1, v2 : TAffineVector): Single; overload;
function VectorSpacing(const v1, v2 : TVector): Single; overload;
function VectorDistance(const v1, v2 : TAffineVector): Single; overload;
function VectorDistance(const v1, v2 : TVector): Single; overload;
function VectorDistance2(const v1, v2 : TAffineVector): Single; overload;
function VectorDistance2(const v1, v2 : TVector): Single; overload;
function VectorPerpendicular(const V, N: TAffineVector): TAffineVector;
function VectorReflect(const V, N: TAffineVector): TAffineVector;
procedure RotateVector(var vector : TVector; const axis : TAffineVector; angle : Single); overload;
procedure RotateVector(var vector : TVector; const axis : TVector; angle : Single); overload;
procedure RotateVectorAroundY(var v : TAffineVector; alpha : Single);
function VectorRotateAroundX(const v : TAffineVector; alpha : Single) : TAffineVector; overload;
function VectorRotateAroundY(const v : TAffineVector; alpha : Single) : TAffineVector; overload;
procedure VectorRotateAroundY(const v : TAffineVector; alpha : Single; var vr : TAffineVector); overload;
function VectorRotateAroundZ(const v : TAffineVector; alpha : Single) : TAffineVector; overload;
procedure AbsVector(var v : TVector); overload;
procedure AbsVector(var v : TAffineVector); overload;
function VectorAbs(const v : TVector) : TVector; overload;
function VectorAbs(const v : TAffineVector) : TAffineVector; overload;
function IsColinear(const v1, v2: TVector2f) : Boolean; overload;
function IsColinear(const v1, v2: TAffineVector) : Boolean; overload;
function IsColinear(const v1, v2: TVector) : Boolean; overload;
procedure SetMatrix(var dest : THomogeneousDblMatrix; const src : TMatrix); overload;
procedure SetMatrix(var dest : TAffineMatrix; const src : TMatrix); overload;
procedure SetMatrix(var dest : TMatrix; const src : TAffineMatrix); overload;
procedure SetMatrixRow(var dest : TMatrix; rowNb : Integer; const aRow : TVector); overload;
function CreateScaleMatrix(const v : TAffineVector) : TMatrix; overload;
function CreateScaleMatrix(const v : TVector) : TMatrix; overload;
function CreateTranslationMatrix(const V : TAffineVector): TMatrix; overload;
function CreateTranslationMatrix(const V : TVector): TMatrix; overload;
function CreateScaleAndTranslationMatrix(const scale, offset : TVector): TMatrix; overload;
function CreateRotationMatrixX(const sine, cosine: Single) : TMatrix; overload;
function CreateRotationMatrixX(const angle: Single) : TMatrix; overload;
function CreateRotationMatrixY(const sine, cosine: Single) : TMatrix; overload;
function CreateRotationMatrixY(const angle: Single) : TMatrix; overload;
function CreateRotationMatrixZ(const sine, cosine: Single) : TMatrix; overload;
function CreateRotationMatrixZ(const angle: Single) : TMatrix; overload;
function CreateRotationMatrix(const anAxis : TAffineVector; angle : Single) : TMatrix; overload;
function CreateRotationMatrix(const anAxis : TVector; angle : Single) : TMatrix; overload;
function CreateAffineRotationMatrix(const anAxis: TAffineVector; angle: Single): TAffineMatrix;
function MatrixMultiply(const M1, M2 : TAffineMatrix) : TAffineMatrix; overload;
function MatrixMultiply(const M1, M2 : TMatrix) : TMatrix; overload;
procedure MatrixMultiply(const M1, M2 : TMatrix; var MResult : TMatrix); overload;
function VectorTransform(const V: TVector; const M: TMatrix): TVector; overload;
function VectorTransform(const V: TVector; const M: TAffineMatrix): TVector; overload;
function VectorTransform(const V: TAffineVector; const M: TMatrix): TAffineVector; overload;
function VectorTransform(const V: TAffineVector; const M: TAffineMatrix): TAffineVector; overload;
function MatrixDeterminant(const M: TAffineMatrix): Single; overload;
function MatrixDeterminant(const M: TMatrix): Single; overload;
procedure AdjointMatrix(var M : TMatrix); overload;
procedure AdjointMatrix(var M : TAffineMatrix); overload;
procedure ScaleMatrix(var M : TAffineMatrix; const factor : Single); overload;
procedure ScaleMatrix(var M : TMatrix; const factor : Single); overload;
procedure TranslateMatrix(var M : TMatrix; const v : TAffineVector); overload;
procedure TranslateMatrix(var M : TMatrix; const v : TVector); overload;
procedure NormalizeMatrix(var M : TMatrix);
procedure TransposeMatrix(var M: TAffineMatrix); overload;
procedure TransposeMatrix(var M: TMatrix); overload;
procedure InvertMatrix(var M : TMatrix); overload;
function MatrixInvert(const M: TMatrix): TMatrix; overload;
procedure InvertMatrix(var M : TAffineMatrix); overload;
function MatrixInvert(const M: TAffineMatrix): TAffineMatrix; overload;
function AnglePreservingMatrixInvert(const mat : TMatrix) : TMatrix;
function MatrixDecompose(const M: TMatrix; var Tran: TTransformations): Boolean;
function CreateLookAtMatrix(const eye, center, normUp: TVector): TMatrix;
function CreateMatrixFromFrustum(Left, Right, Bottom, Top, ZNear, ZFar: Single): TMatrix;
function CreatePerspectiveMatrix(FOV, Aspect, ZNear, ZFar: Single): TMatrix;
function CreateOrthoMatrix(Left, Right, Bottom, Top, ZNear, ZFar: Single): TMatrix;
function CreatePickMatrix(x, y, deltax, deltay: Single; const viewport: TVector4i): TMatrix;
function Project(objectVector: TVector; const ViewProjMatrix: TMatrix; const viewport: TVector4i; out WindowVector: TVector): Boolean;
function UnProject(WindowVector: TVector; ViewProjMatrix: TMatrix; const viewport: TVector4i; out objectVector: TVector): Boolean;
function PlaneMake(const p1, p2, p3 : TAffineVector) : THmgPlane; overload;
function PlaneMake(const p1, p2, p3 : TVector) : THmgPlane; overload;
function PlaneMake(const point, normal : TAffineVector) : THmgPlane; overload;
function PlaneMake(const point, normal : TVector) : THmgPlane; overload;
procedure SetPlane(var dest : TDoubleHmgPlane; const src : THmgPlane);
procedure NormalizePlane(var plane : THmgPlane);
function PlaneEvaluatePoint(const plane : THmgPlane; const point : TAffineVector) : Single; overload;
function PlaneEvaluatePoint(const plane : THmgPlane; const point : TVector) : Single; overload;
function CalcPlaneNormal(const p1, p2, p3 : TAffineVector) : TAffineVector; overload;
procedure CalcPlaneNormal(const p1, p2, p3 : TAffineVector; var vr : TAffineVector); overload;
procedure CalcPlaneNormal(const p1, p2, p3 : TVector; var vr : TAffineVector); overload;
function PointIsInHalfSpace(const point, planePoint, planeNormal : TVector) : Boolean; overload;
function PointIsInHalfSpace(const point, planePoint, planeNormal : TAffineVector) : Boolean; overload;
function PointIsInHalfSpace(const point: TAffineVector; plane : THmgPlane) : Boolean; overload;
function PointPlaneDistance(const point, planePoint, planeNormal : TVector) : Single; overload;
function PointPlaneDistance(const point, planePoint, planeNormal : TAffineVector) : Single; overload;
function PointPlaneDistance(const point : TAffineVector; plane : THmgPlane) : Single; overload;
function PointPlaneOrthoProjection(const point: TAffineVector; const plane : THmgPlane; var inter : TAffineVector; bothface : Boolean = True) : Boolean;
function PointPlaneProjection(const point, direction : TAffineVector; const plane : THmgPlane; var inter : TAffineVector; bothface : Boolean = True) : Boolean;
function SegmentPlaneIntersection(const ptA, ptB : TAffineVector; const plane : THmgPlane; var inter : TAffineVector) : Boolean;
function PointTriangleOrthoProjection(const point, ptA, ptB, ptC : TAffineVector; var inter : TAffineVector; bothface : Boolean = True) : Boolean;
function PointTriangleProjection(const point, direction, ptA, ptB, ptC : TAffineVector; var inter : TAffineVector; bothface : Boolean = True) : Boolean;
function IsLineIntersectTriangle(const point, direction, ptA, ptB, ptC : TAffineVector) : Boolean;
function PointQuadOrthoProjection(const point, ptA, ptB, ptC, ptD : TAffineVector; var inter : TAffineVector; bothface : Boolean = True) : Boolean;
function PointQuadProjection(const point, direction, ptA, ptB, ptC, ptD : TAffineVector; var inter : TAffineVector; bothface : Boolean = True) : Boolean;
function IsLineIntersectQuad(const point, direction, ptA, ptB, ptC, ptD : TAffineVector) : Boolean;
function PointDiskOrthoProjection(const point, center, up : TAffineVector; const radius: Single; var inter : TAffineVector; bothface : Boolean = True) : Boolean;
function PointDiskProjection(const point, direction, center, up : TAffineVector; const radius: Single; var inter : TAffineVector; bothface : Boolean = True) : Boolean;
function PointSegmentClosestPoint(const point, segmentStart, segmentStop : TAffineVector) : TAffineVector; overload;
function PointSegmentClosestPoint(const point, segmentStart, segmentStop : TVector) : TVector; overload;
function PointSegmentDistance(const point, segmentStart, segmentStop : TAffineVector) : single;
function PointLineClosestPoint(const point, linePoint, lineDirection : TAffineVector) : TAffineVector;
function PointLineDistance(const point, linePoint, lineDirection : TAffineVector) : Single;
procedure SegmentSegmentClosestPoint(const S0Start, S0Stop, S1Start, S1Stop : TAffineVector; var Segment0Closest, Segment1Closest : TAffineVector);
function SegmentSegmentDistance(const S0Start, S0Stop, S1Start, S1Stop : TAffineVector) : single;
function LineLineDistance(const linePt0, lineDir0, linePt1, lineDir1 : TAffineVector) : Single;
function QuaternionMake(const Imag: array of Single; Real : Single) : TQuaternion;
function QuaternionConjugate(const Q : TQuaternion) : TQuaternion;
function QuaternionMagnitude(const Q : TQuaternion) : Single;
procedure NormalizeQuaternion(var Q : TQuaternion);
function QuaternionFromPoints(const V1, V2: TAffineVector): TQuaternion;
procedure QuaternionToPoints(const Q: TQuaternion; var ArcFrom, ArcTo: TAffineVector);
function QuaternionFromMatrix(const mat : TMatrix) : TQuaternion;
function QuaternionToMatrix(quat : TQuaternion) : TMatrix;
function QuaternionToAffineMatrix(quat : TQuaternion) : TAffineMatrix;
function QuaternionFromAngleAxis(const angle : Single; const axis : TAffineVector) : TQuaternion;
function QuaternionFromRollPitchYaw(const r, p, y : Single) : TQuaternion;
function QuaternionFromEuler(const x, y, z: Single; eulerOrder : TEulerOrder) : TQuaternion;
function QuaternionMultiply(const qL, qR : TQuaternion): TQuaternion;
function QuaternionSlerp(const QStart, QEnd: TQuaternion; Spin: Integer; t: Single): TQuaternion; overload;
function QuaternionSlerp(const source, dest: TQuaternion; const t : Single) : TQuaternion; overload;
function LnXP1(X: Extended): Extended;
function Log10(X: Extended): Extended;
function Log2(X: Extended): Extended; overload;
function Log2(X: Single): Single; overload;
function LogN(Base, X: Extended): Extended;
function IntPower(Base: Extended; Exponent: Integer): Extended;
function Power(const Base, Exponent: Single): Single; overload;
function Power(Base: Single; Exponent: Integer): Single; overload;
function Power(Base: Single; Exponent: Int64): Single; overload;
function DegToRad(const Degrees: Extended): Extended; overload;
function DegToRad(const Degrees: Single): Single; overload;
function RadToDeg(const Radians: Extended): Extended; overload;
function RadToDeg(const Radians: Single): Single; overload;
function NormalizeAngle(angle : Single) : Single;
function NormalizeDegAngle(angle : Single) : Single;
procedure SinCos(const Theta: Double; out Sin, Cos: Double); overload;
procedure SinCos(const Theta: Single; out Sin, Cos: Single); overload;
procedure SinCos(const theta, radius : Double; out Sin, Cos: Double); overload;
procedure SinCos(const theta, radius : Single; out Sin, Cos: Single); overload;
procedure PrepareSinCosCache(var s, c : array of Single; startAngle, stopAngle : Single);
function ArcCos(const X: Extended) : Extended; overload;
function ArcCos(const x : Single) : Single; overload;
function ArcSin(const X : Extended) : Extended; overload;
function ArcSin(const X : Single) : Single; overload;
function ArcTan2(const Y, X : Extended) : Extended; overload;
function ArcTan2(const Y, X : Single) : Single; overload;
function FastArcTan2(y, x : Single) : Single;
function Tan(const X : Extended) : Extended; overload;
function Tan(const X : Single) : Single; overload;
function CoTan(const X : Extended) : Extended; overload;
function CoTan(const X : Single) : Single; overload;
function Sinh(const x : Single) : Single; overload;
function Sinh(const x : Double) : Double; overload;
function Cosh(const x : Single) : Single; overload;
function Cosh(const x : Double) : Double; overload;
function RSqrt(v : Single) : Single;
function RLength(x, y : Single) : Single;
function ISqrt(i : Integer) : Integer;
function ILength(x, y : Integer) : Integer; overload;
function ILength(x, y, z : Integer) : Integer; overload;
procedure RandomPointOnSphere(var p : TAffineVector);
function RoundInt(v : Single) : Single; overload;
function RoundInt(v : Extended) : Extended; overload;
function Trunc(X: Extended): Int64;
function Round(X: Extended): Int64;
function Frac(X: Extended): Extended;
function Ceil(v : Single) : Integer; overload;
function Ceil64(v : Extended) : Int64; overload;
function Floor(v : Single) : Integer; overload;
function Floor64(v : Extended) : Int64; overload;
function ScaleAndRound(i : Integer; var s : Single) : Integer;
function Sign(x : Single) : Integer;
function SignStrict(x : Single) : Integer;
function IsInRange(const x, a, b : Single) : Boolean; overload;
function IsInRange(const x, a, b : Double) : Boolean; overload;
function IsInCube(const p, d : TAffineVector) : Boolean; overload;
function IsInCube(const p, d : TVector) : Boolean; overload;
function MinFloat(values : PSingleArray; nbItems : Integer) : Single; overload;
function MinFloat(values : PDoubleArray; nbItems : Integer) : Double; overload;
function MinFloat(values : PExtendedArray; nbItems : Integer) : Extended; overload;
function MinFloat(const v1, v2 : Single) : Single; overload;
function MinFloat(const v : array of Single) : Single; overload;
function MinFloat(const v1, v2 : Double) : Double; overload;
function MinFloat(const v1, v2, v3 : Single) : Single; overload;
function MinFloat(const v1, v2, v3 : Double) : Double; overload;
function MaxFloat(values : PSingleArray; nbItems : Integer) : Single; overload;
function MaxFloat(values : PDoubleArray; nbItems : Integer) : Double; overload;
function MaxFloat(values : PExtendedArray; nbItems : Integer) : Extended; overload;
function MaxFloat(const v : array of Single) : Single; overload;
function MaxFloat(const v1, v2 : Single) : Single; overload;
function MaxFloat(const v1, v2 : Double) : Double; overload;
function MaxFloat(const v1, v2, v3 : Single) : Single; overload;
function MaxFloat(const v1, v2, v3 : Double) : Double; overload;
function MinInteger(const v1, v2 : Integer) : Integer; overload;
function MinInteger(const v1, v2 : Cardinal) : Cardinal; overload;
function MinInteger(const v1, v2, v3 : Integer) : Integer; overload;
function MinInteger(const v1, v2, v3 : Cardinal) : Cardinal; overload;
function MaxInteger(const v1, v2 : Integer) : Integer; overload;
function MaxInteger(const v1, v2 : Cardinal) : Cardinal; overload;
function MaxInteger(const v1, v2, v3 : Integer) : Integer; overload;
function MaxInteger(const v1, v2, v3 : Cardinal) : Cardinal; overload;
function ClampInteger(const value, min, max : Integer) : Integer; overload;
function ClampInteger(const value, min, max : Cardinal) : Cardinal; overload;
function TriangleArea(const p1, p2, p3 : TAffineVector) : Single; overload;
function PolygonArea(const p : PAffineVectorArray; nSides : Integer) : Single; overload;
function TriangleSignedArea(const p1, p2, p3 : TAffineVector) : Single; overload;
function PolygonSignedArea(const p : PAffineVectorArray; nSides : Integer) : Single; overload;
procedure ScaleFloatArray(values : PSingleArray; nb : Integer; var factor : Single); overload;
procedure ScaleFloatArray(var values : TSingleArray; factor : Single); overload;
procedure OffsetFloatArray(values : PSingleArray; nb : Integer; var delta : Single); overload;
procedure OffsetFloatArray(var values : array of Single; delta : Single); overload;
procedure OffsetFloatArray(valuesDest, valuesDelta : PSingleArray; nb : Integer); overload;
function MaxXYZComponent(const v : TVector) : Single; overload;
function MaxXYZComponent(const v: TAffineVector): single; overload;
function MinXYZComponent(const v : TVector) : Single; overload;
function MinXYZComponent(const v: TAffineVector): single; overload;
function MaxAbsXYZComponent(v : TVector) : Single;
function MinAbsXYZComponent(v : TVector) : Single;
procedure MaxVector(var v : TVector; const v1 : TVector); overload;
procedure MaxVector(var v : TAffineVector; const v1 : TAffineVector); overload;
procedure MinVector(var v : TVector; const v1 : TVector); overload;
procedure MinVector(var v : TAffineVector; const v1 : TAffineVector); overload;
procedure SortArrayAscending(var a : array of Extended);
function ClampValue(const aValue, aMin, aMax : Single) : Single; overload;
function ClampValue(const aValue, aMin : Single) : Single; overload;
function GeometryOptimizationMode : String;
procedure BeginFPUOnlySection;
procedure EndFPUOnlySection;
function ConvertRotation(const Angles : TAffineVector) : TVector;
function MakeAffineDblVector(var v : array of Double) : TAffineDblVector;
function MakeDblVector(var v : array of Double) : THomogeneousDblVector;
function VectorAffineDblToFlt(const v : TAffineDblVector) : TAffineVector;
function VectorDblToFlt(const v : THomogeneousDblVector) : THomogeneousVector;
function VectorAffineFltToDbl(const v : TAffineVector) : TAffineDblVector;
function VectorFltToDbl(const v : TVector): THomogeneousDblVector;
function PointInPolygon(var xp, yp : array of Single; x, y : Single) : Boolean;
function IsPointInPolygon(Polygon: array of TPoint; p: TPoint): Boolean;
procedure DivMod(Dividend: Integer; Divisor: Word; var Result, Remainder: Word);
function Turn(const Matrix: TMatrix; angle : Single) : TMatrix; overload;
function Turn(const Matrix: TMatrix; const MasterUp : TAffineVector; Angle : Single) : TMatrix; overload;
function Pitch(const Matrix: TMatrix; Angle: Single): TMatrix; overload;
function Pitch(const Matrix: TMatrix; const MasterRight: TAffineVector; Angle: Single): TMatrix; overload;
function Roll(const Matrix: TMatrix; Angle: Single): TMatrix; overload;
function Roll(const Matrix: TMatrix; const MasterDirection: TAffineVector; Angle: Single): TMatrix; overload;
function IntersectLinePlane(const point, direction : TVector; const plane : THmgPlane; intersectPoint : PVector = nil) : Integer; overload;
function IntersectTriangleBox( const p1, p2, p3, aMinExtent, aMaxExtent : TAffineVector): Boolean;
function IntersectSphereBox( const SpherePos : TVector; const SphereRadius : Single; const BoxMatrix : TMatrix; const BoxScale : TAffineVector ; intersectPoint : PAffineVector = nil ; normal : PAffineVector = nil ; depth : PSingle = nil ) : Boolean;
function RayCastPlaneIntersect(const rayStart, rayVector : TVector; const planePoint, planeNormal : TVector; intersectPoint : PVector = nil) : Boolean; overload;
function RayCastPlaneXZIntersect(const rayStart, rayVector : TVector; const planeY : Single; intersectPoint : PVector = nil) : Boolean; overload;
function RayCastTriangleIntersect(const rayStart, rayVector : TVector; const p1, p2, p3 : TAffineVector; intersectPoint : PVector = nil; intersectNormal : PVector = nil) : Boolean; overload;
function RayCastMinDistToPoint(const rayStart, rayVector : TVector; const point : TVector) : Single;
function RayCastIntersectsSphere(const rayStart, rayVector : TVector; const sphereCenter : TVector; const sphereRadius : Single) : Boolean; overload;
function RayCastSphereIntersect(const rayStart, rayVector : TVector; const sphereCenter : TVector; const sphereRadius : Single; var i1, i2 : TVector) : Integer; overload;
function RayCastBoxIntersect( const rayStart, rayVector, aMinExtent, aMaxExtent : TAffineVector; intersectPoint : PAffineVector = nil) : Boolean;
function RectanglesIntersect(const ACenterOfRect1, ACenterOfRect2, ASizeOfRect1, ASizeOfRect2: TVector2f): Boolean;
function RectangleContains(const ACenterOfBigRect1, ACenterOfSmallRect2, ASizeOfBigRect1, ASizeOfSmallRect2: TVector2f; const AEps: Single = 0.0): Boolean;
function SphereVisibleRadius(distance, radius : Single) : Single;
function ExtractFrustumFromModelViewProjection(const modelViewProj : TMatrix) : TFrustum;
function IsVolumeClipped(const objPos : TAffineVector; const objRadius : Single; const Frustum : TFrustum) : Boolean; overload;
function IsVolumeClipped(const objPos : TVector; const objRadius : Single; const Frustum : TFrustum) : Boolean; overload;
function IsVolumeClipped(const min, max : TAffineVector; const Frustum : TFrustum) : Boolean; overload;
function MakeParallelProjectionMatrix(const plane : THmgPlane; const dir : TVector) : TMatrix;
function MakeShadowMatrix(const planePoint, planeNormal, lightPos : TVector) : TMatrix;
function MakeReflectionMatrix(const planePoint, planeNormal : TAffineVector) : TMatrix;
function PackRotationMatrix(const mat : TMatrix) : TPackedRotationMatrix;
function UnPackRotationMatrix(const packedMatrix : TPackedRotationMatrix) : TMatrix;
function BarycentricCoordinates(const v1, v2, v3, p: TAffineVector; var u, v: single): boolean;
function GetSafeTurnAngle(const AOriginalPosition, AOriginalUpVector, ATargetPosition, AMoveAroundTargetCenter: TVector): TVector2f; overload;
function GetSafeTurnAngle(const AOriginalPosition, AOriginalUpVector, ATargetPosition, AMoveAroundTargetCenter: TAffineVector): TVector2f; overload;
function MoveObjectAround(const AMovingObjectPosition, AMovingObjectUp, ATargetPosition: TVector; pitchDelta, turnDelta: Single): TVector;
function AngleBetweenVectors(const A, B, ACenterPoint: TVector): Single; overload;
function AngleBetweenVectors(const A, B, ACenterPoint: TAffineVector): Single; overload;
function ShiftObjectFromCenter(const AOriginalPosition: TVector; const ACenter: TVector; const ADistance: Single; const AFromCenterSpot: Boolean): TVector; overload;
function ShiftObjectFromCenter(const AOriginalPosition: TAffineVector; const ACenter: TAffineVector; const ADistance: Single; const AFromCenterSpot: Boolean): TAffineVector; overload;

Types

PFloat = PSingle;
PTexPoint = ˆTTexPoint;
PByteVector = ˆTByteVector;
PByteArray = PByteVector;
TByteVector = array[0..cMaxArray] of Byte;
PWordVector = ˆTWordVector;
TWordVector = array[0..cMaxArray] of Word;
PIntegerVector = ˆTIntegerVector;
PIntegerArray = PIntegerVector;
TIntegerVector = array[0..cMaxArray] of Integer;
PFloatVector = ˆTFloatVector;
PFloatArray = PFloatVector;
PSingleArray = PFloatArray;
TFloatVector = array[0..cMaxArray] of Single;
TSingleArray = array of Single;
PDoubleVector = ˆTDoubleVector;
PDoubleArray = PDoubleVector;
TDoubleVector = array[0..cMaxArray] of Double;
PExtendedVector = ˆTExtendedVector;
PExtendedArray = PExtendedVector;
TExtendedVector = array[0..cMaxArray] of Extended;
PPointerVector = ˆTPointerVector;
PPointerArray = PPointerVector;
TPointerVector = array[0..cMaxArray] of Pointer;
PCardinalVector = ˆTCardinalVector;
PCardinalArray = PCardinalVector;
TCardinalVector = array[0..cMaxArray] of Cardinal;
PLongWordVector = ˆTLongWordVector;
PLongWordArray = PLongWordVector;
TLongWordVector = array[0..cMaxArray] of LongWord;
PHomogeneousByteVector = ˆTHomogeneousByteVector;
THomogeneousByteVector = TVector4b;
PHomogeneousWordVector = ˆTHomogeneousWordVector;
THomogeneousWordVector = TVector4w;
PHomogeneousIntVector = ˆTHomogeneousIntVector;
THomogeneousIntVector = TVector4i;
PHomogeneousFltVector = ˆTHomogeneousFltVector;
THomogeneousFltVector = TVector4f;
PHomogeneousDblVector = ˆTHomogeneousDblVector;
THomogeneousDblVector = TVector4d;
PHomogeneousExtVector = ˆTHomogeneousExtVector;
THomogeneousExtVector = TVector4e;
PHomogeneousPtrVector = ˆTHomogeneousPtrVector;
THomogeneousPtrVector = TVector4p;
PAffineByteVector = ˆTAffineByteVector;
TAffineByteVector = TVector3b;
PAffineWordVector = ˆTAffineWordVector;
TAffineWordVector = TVector3w;
PAffineIntVector = ˆTAffineIntVector;
TAffineIntVector = TVector3i;
PAffineFltVector = ˆTAffineFltVector;
TAffineFltVector = TVector3f;
PAffineDblVector = ˆTAffineDblVector;
TAffineDblVector = TVector3d;
PAffineExtVector = ˆTAffineExtVector;
TAffineExtVector = TVector3e;
PAffinePtrVector = ˆTAffinePtrVector;
TAffinePtrVector = TVector3p;
PVector2f = ˆTVector2f;
PVector = ˆTVector;
TVector = THomogeneousFltVector;
PHomogeneousVector = ˆTHomogeneousVector;
THomogeneousVector = THomogeneousFltVector;
PAffineVector = ˆTAffineVector;
TAffineVector = TVector3f;
PVertex = ˆTVertex;
TVertex = TAffineVector;
PAffineVectorArray = ˆTAffineVectorArray;
TAffineVectorArray = array[0..MAXINT shr 4] of TAffineVector;
PVectorArray = ˆTVectorArray;
TVectorArray = array[0..MAXINT shr 5] of TVector;
PTexPointArray = ˆTTexPointArray;
TTexPointArray = array [0..MaxInt shr 4] of TTexPoint;
THomogeneousByteMatrix = TMatrix4b;
THomogeneousWordMatrix = array[0..3] of THomogeneousWordVector;
THomogeneousIntMatrix = TMatrix4i;
THomogeneousFltMatrix = TMatrix4f;
THomogeneousDblMatrix = TMatrix4d;
THomogeneousExtMatrix = array[0..3] of THomogeneousExtVector;
TAffineByteMatrix = TMatrix3b;
TAffineWordMatrix = array[0..2] of TAffineWordVector;
TAffineIntMatrix = TMatrix3i;
TAffineFltMatrix = TMatrix3f;
TAffineDblMatrix = TMatrix3d;
TAffineExtMatrix = array[0..2] of TAffineExtVector;
PMatrix = ˆTMatrix;
TMatrix = THomogeneousFltMatrix;
TMatrixArray = array [0..MaxInt shr 7] of TMatrix;
PMatrixArray = ˆTMatrixArray;
PHomogeneousMatrix = ˆTHomogeneousMatrix;
THomogeneousMatrix = THomogeneousFltMatrix;
PAffineMatrix = ˆTAffineMatrix;
TAffineMatrix = TAffineFltMatrix;
THmgPlane = TVector;
TDoubleHmgPlane = THomogeneousDblVector;
PQuaternion = ˆTQuaternion;
PQuaternionArray = ˆTQuaternionArray;
TQuaternionArray = array[0..MAXINT shr 5] of TQuaternion;
TTransType = (...);
TTransformations = array [TTransType] of Single;
TPackedRotationMatrix = array [0..2] of SmallInt;
TGLInterpolationType = (...);
TEulerOrder = (...);

Constants

cMaxArray = (MaxInt shr 4);
cColinearBias = 1e-8;
XTexPoint : TTexPoint = (S:1; T:0);
YTexPoint : TTexPoint = (S:0; T:1);
XYTexPoint : TTexPoint = (S:1; T:1);
NullTexPoint : TTexPoint = (S:0; T:0);
MidTexPoint : TTexPoint = (S:0.5; T:0.5);
XVector : TAffineVector = (X:1; Y:0; Z:0);
YVector : TAffineVector = (X:0; Y:1; Z:0);
ZVector : TAffineVector = (X:0; Y:0; Z:1);
XYVector : TAffineVector = (X:1; Y:1; Z:0);
XZVector : TAffineVector = (X:1; Y:0; Z:1);
YZVector : TAffineVector = (X:0; Y:1; Z:1);
XYZVector : TAffineVector = (X:1; Y:1; Z:1);
NullVector : TAffineVector = (X:0; Y:0; Z:0);
MinusXVector : TAffineVector = (X:-1; Y: 0; Z: 0);
MinusYVector : TAffineVector = (X: 0; Y:-1; Z: 0);
MinusZVector : TAffineVector = (X: 0; Y: 0; Z:-1);
XHmgVector : THomogeneousVector = (X:1; Y:0; Z:0; W:0);
YHmgVector : THomogeneousVector = (X:0; Y:1; Z:0; W:0);
ZHmgVector : THomogeneousVector = (X:0; Y:0; Z:1; W:0);
WHmgVector : THomogeneousVector = (X:0; Y:0; Z:0; W:1);
XYHmgVector : THomogeneousVector = (X:1; Y:1; Z:0; W:0);
YZHmgVector : THomogeneousVector = (X:0; Y:1; Z:1; W:0);
XZHmgVector : THomogeneousVector = (X:1; Y:0; Z:1; W:0);
XYZHmgVector : THomogeneousVector = (X:1; Y:1; Z:1; W:0);
XYZWHmgVector : THomogeneousVector = (X:1; Y:1; Z:1; W:1);
NullHmgVector : THomogeneousVector = (X:0; Y:0; Z:0; W:0);
XHmgPoint : THomogeneousVector = (X:1; Y:0; Z:0; W:1);
YHmgPoint : THomogeneousVector = (X:0; Y:1; Z:0; W:1);
ZHmgPoint : THomogeneousVector = (X:0; Y:0; Z:1; W:1);
WHmgPoint : THomogeneousVector = (X:0; Y:0; Z:0; W:1);
NullHmgPoint : THomogeneousVector = (X:0; Y:0; Z:0; W:1);
IdentityMatrix: TAffineMatrix = (V:((X:1; Y:0; Z:0), (X:0; Y:1; Z:0), (X:0; Y:0; Z:1)));
IdentityHmgMatrix: TMatrix = (V:((X:1; Y:0; Z:0; W:0), (X:0; Y:1; Z:0; W:0), (X:0; Y:0; Z:1; W:0), (X:0; Y:0; Z:0; W:1)));
IdentityHmgDblMatrix: THomogeneousDblMatrix = (V:((X:1; Y:0; Z:0; W:0), (X:0; Y:1; Z:0; W:0), (X:0; Y:0; Z:1; W:0), (X:0; Y:0; Z:0; W:1)));
EmptyMatrix: TAffineMatrix = (V:((X:0; Y:0; Z:0), (X:0; Y:0; Z:0), (X:0; Y:0; Z:0)));
EmptyHmgMatrix: TMatrix = (V:((X:0; Y:0; Z:0; W:0), (X:0; Y:0; Z:0; W:0), (X:0; Y:0; Z:0; W:0), (X:0; Y:0; Z:0; W:0)));
IdentityQuaternion: TQuaternion = (ImagPart:(X:0; Y:0; Z:0); RealPart: 1);
EPSILON : Single = 1e-40;
EPSILON2 : Single = 1e-30;
cPI : Single = 3.141592654;
cPIdiv180 : Single = 0.017453292;
c180divPI : Single = 57.29577951;
c2PI : Single = 6.283185307;
cPIdiv2 : Single = 1.570796326;
cPIdiv4 : Single = 0.785398163;
c3PIdiv2 : Single = 4.71238898;
c3PIdiv4 : Single = 2.35619449;
cInv2PI : Single = 1/6.283185307;
cInv360 : Single = 1/360;
c180 : Single = 180;
c360 : Single = 360;
cOneHalf : Single = 0.5;
cLn10 : Single = 2.302585093;
MinSingle = 1.5e-45;
MaxSingle = 3.4e+38;
MinDouble = 5.0e-324;
MaxDouble = 1.7e+308;
MinExtended = 3.4e-4932;
MaxExtended = 1.1e+4932;
MinComp = -9.223372036854775807e+18;
MaxComp = 9.223372036854775807e+18;

Variables

vSIMD: Byte = 0;

Description

Functions and Procedures

function TexPointMake(const s, t : Single) : TTexPoint;
function AffineVectorMake(const x, y, z : Single) : TAffineVector; overload;
function AffineVectorMake(const v : TVector) : TAffineVector; overload;
procedure SetAffineVector(out v : TAffineVector; const x, y, z : Single); overload;
procedure SetVector(out v : TAffineVector; const x, y, z : Single); overload;
procedure SetVector(out v : TAffineVector; const vSrc : TVector); overload;
procedure SetVector(out v : TAffineVector; const vSrc : TAffineVector); overload;
procedure SetVector(out v : TAffineDblVector; const vSrc : TAffineVector); overload;
procedure SetVector(out v : TAffineDblVector; const vSrc : TVector); overload;
function VectorMake(const v : TAffineVector; w : Single = 0) : TVector; overload;
function VectorMake(const x, y, z: Single; w : Single = 0) : TVector; overload;
function PointMake(const x, y, z: Single) : TVector; overload;
function PointMake(const v : TAffineVector) : TVector; overload;
function PointMake(const v : TVector) : TVector; overload;
procedure SetVector(out v : TVector; const x, y, z : Single; w : Single = 0); overload;
procedure SetVector(out v : TVector; const av : TAffineVector; w : Single = 0); overload;
procedure SetVector(out v : TVector; const vSrc : TVector); overload;
procedure MakePoint(out v : TVector; const x, y, z: Single); overload;
procedure MakePoint(out v : TVector; const av : TAffineVector); overload;
procedure MakePoint(out v : TVector; const av : TVector); overload;
procedure MakeVector(out v : TAffineVector; const x, y, z: Single); overload;
procedure MakeVector(out v : TVector; const x, y, z: Single); overload;
procedure MakeVector(out v : TVector; const av : TAffineVector); overload;
procedure MakeVector(out v : TVector; const av : TVector); overload;
procedure RstVector(var v : TAffineVector); overload;
procedure RstVector(var v : TVector); overload;
function VectorEquals(const Vector1, Vector2: TVector2f): Boolean; overload;
function VectorEquals(const Vector1, Vector2: TVector2i): Boolean; overload;
function VectorEquals(const V1, V2: TVector2d): Boolean; overload;
function VectorEquals(const V1, V2: TVector2s): Boolean; overload;
function VectorEquals(const V1, V2: TVector2b): Boolean; overload;
function VectorEquals(const V1, V2: TVector3i): Boolean; overload;
function VectorEquals(const V1, V2: TVector3d): Boolean; overload;
function VectorEquals(const V1, V2: TVector3s): Boolean; overload;
function VectorEquals(const V1, V2: TVector3b): Boolean; overload;
function VectorEquals(const V1, V2: TVector4i): Boolean; overload;
function VectorEquals(const V1, V2: TVector4d): Boolean; overload;
function VectorEquals(const V1, V2: TVector4s): Boolean; overload;
function VectorEquals(const V1, V2: TVector4b): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3f): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3i): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3d): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3s): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix3b): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4f): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4i): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4d): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4s): Boolean; overload;
function MatrixEquals(const Matrix1, Matrix2: TMatrix4b): Boolean; overload;
function Vector2fMake(const X, Y: Single): TVector2f; overload;
function Vector2iMake(const X, Y: Longint): TVector2i; overload;
function Vector2sMake(const X, Y: Smallint): TVector2s; overload;
function Vector2dMake(const X, Y: Double): TVector2d; overload;
function Vector2bMake(const X, Y: Byte): TVector2b; overload;
function Vector2fMake(const Vector: TVector3f): TVector2f; overload;
function Vector2iMake(const Vector: TVector3i): TVector2i; overload;
function Vector2sMake(const Vector: TVector3s): TVector2s; overload;
function Vector2dMake(const Vector: TVector3d): TVector2d; overload;
function Vector2bMake(const Vector: TVector3b): TVector2b; overload;
function Vector2fMake(const Vector: TVector4f): TVector2f; overload;
function Vector2iMake(const Vector: TVector4i): TVector2i; overload;
function Vector2sMake(const Vector: TVector4s): TVector2s; overload;
function Vector2dMake(const Vector: TVector4d): TVector2d; overload;
function Vector2bMake(const Vector: TVector4b): TVector2b; overload;
function Vector3fMake(const X: Single; const Y: Single = 0; const Z: Single = 0): TVector3f; overload;
function Vector3iMake(const X: Longint; const Y: Longint = 0; const Z: Longint = 0): TVector3i; overload;
function Vector3sMake(const X: Smallint; const Y: Smallint = 0; const Z: Smallint = 0): TVector3s; overload;
function Vector3dMake(const X: Double; const Y: Double = 0; const Z: Double = 0): TVector3d; overload;
function Vector3bMake(const X: Byte; const Y: Byte = 0; const Z: Byte = 0): TVector3b; overload;
function Vector3fMake(const Vector: TVector2f; const Z: Single = 0): TVector3f; overload;
function Vector3iMake(const Vector: TVector2i; const Z: Longint = 0): TVector3i; overload;
function Vector3sMake(const Vector: TVector2s; const Z: Smallint = 0): TVector3s; overload;
function Vector3dMake(const Vector: TVector2d; const Z: Double = 0): TVector3d; overload;
function Vector3bMake(const Vector: TVector2b; const Z: Byte = 0): TVector3b; overload;
function Vector3fMake(const Vector: TVector4f): TVector3f; overload;
function Vector3iMake(const Vector: TVector4i): TVector3i; overload;
function Vector3sMake(const Vector: TVector4s): TVector3s; overload;
function Vector3dMake(const Vector: TVector4d): TVector3d; overload;
function Vector3bMake(const Vector: TVector4b): TVector3b; overload;
function Vector4fMake(const X: Single; const Y: Single = 0; const Z: Single = 0; const W: Single = 0): TVector4f; overload;
function Vector4iMake(const X: Longint; const Y: Longint = 0; const Z: Longint = 0; const W: Longint = 0): TVector4i; overload;
function Vector4sMake(const X: Smallint; const Y: Smallint = 0; const Z: Smallint = 0; const W: Smallint = 0): TVector4s; overload;
function Vector4dMake(const X: Double; const Y: Double = 0; const Z: Double = 0; const W: Double = 0): TVector4d; overload;
function Vector4bMake(const X: Byte; const Y: Byte = 0; const Z: Byte = 0; const W: Byte = 0): TVector4b; overload;
function Vector4fMake(const Vector: TVector3f; const W: Single = 0): TVector4f; overload;
function Vector4iMake(const Vector: TVector3i; const W: Longint = 0): TVector4i; overload;
function Vector4sMake(const Vector: TVector3s; const W: Smallint = 0): TVector4s; overload;
function Vector4dMake(const Vector: TVector3d; const W: Double = 0): TVector4d; overload;
function Vector4bMake(const Vector: TVector3b; const W: Byte = 0): TVector4b; overload;
function Vector4fMake(const Vector: TVector2f; const Z: Single = 0; const W: Single = 0): TVector4f; overload;
function Vector4iMake(const Vector: TVector2i; const Z: Longint = 0; const W: Longint = 0): TVector4i; overload;
function Vector4sMake(const Vector: TVector2s; const Z: Smallint = 0; const W: Smallint = 0): TVector4s; overload;
function Vector4dMake(const Vector: TVector2d; const Z: Double = 0; const W: Double = 0): TVector4d; overload;
function Vector4bMake(const Vector: TVector2b; const Z: Byte = 0; const W: Byte = 0): TVector4b; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;

Vector comparison functions:

function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3f): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4f): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3i): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4i): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector3s): Boolean; overload;
function VectorMoreThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorMoreEqualThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorLessThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorLessEqualThen(const SourceVector, ComparedVector: TVector4s): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector3f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector4f; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector3i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector4i; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector3s; const ComparedNumber: Single): Boolean; overload;
function VectorMoreThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorMoreEqualThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorLessThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorLessEqualThen(const SourceVector: TVector4s; const ComparedNumber: Single): Boolean; overload;
function VectorAdd(const v1, v2 : TVector2f) : TVector2f; overload;
function VectorAdd(const v1, v2 : TAffineVector) : TAffineVector; overload;

Returns the sum of two affine vectors

procedure VectorAdd(const v1, v2 : TAffineVector; var vr : TAffineVector); overload;

Adds two vectors and places result in vr

procedure VectorAdd(const v1, v2 : TAffineVector; vr : PAffineVector); overload;
function VectorAdd(const v1, v2 : TVector) : TVector; overload;

Returns the sum of two homogeneous vectors

procedure VectorAdd(const v1, v2 : TVector; var vr : TVector); overload;
function VectorAdd(const v : TAffineVector; const f : Single) : TAffineVector; overload;

Sums up f to each component of the vector

function VectorAdd(const v : TVector; const f : Single) : TVector; overload;

Sums up f to each component of the vector

procedure AddVector(var v1 : TAffineVector; const v2 : TAffineVector); overload;

Adds V2 to V1, result is placed in V1

procedure AddVector(var v1 : TAffineVector; const v2 : TVector); overload;

Adds V2 to V1, result is placed in V1

procedure AddVector(var v1 : TVector; const v2 : TVector); overload;

Adds V2 to V1, result is placed in V1

procedure AddVector(var v : TAffineVector; const f : Single); overload;

Sums up f to each component of the vector

procedure AddVector(var v : TVector; const f : Single); overload;

Sums up f to each component of the vector

procedure AddPoint(var v1 : TVector; const v2 : TVector); overload;

Adds V2 to V1, result is placed in V1. W coordinate is always 1.

function PointAdd(var v1 : TVector; const v2 : TVector): TVector; overload;

Returns the sum of two homogeneous vectors. W coordinate is always 1.

procedure TexPointArrayAdd(const src : PTexPointArray; const delta : TTexPoint; const nb : Integer; dest : PTexPointArray); overload;

Adds delta to nb texpoints in src and places result in dest

procedure TexPointArrayScaleAndAdd(const src : PTexPointArray; const delta : TTexPoint; const nb : Integer; const scale : TTexPoint; dest : PTexPointArray); overload;
procedure VectorArrayAdd(const src : PAffineVectorArray; const delta : TAffineVector; const nb : Integer; dest : PAffineVectorArray); overload;

Adds delta to nb vectors in src and places result in dest

function VectorSubtract(const V1, V2 : TVector2f) : TVector2f; overload;

Returns V1-V2

procedure SubtractVector(var V1 : TVector2f; const V2 : TVector2f); overload;

Subtracts V2 from V1, result is placed in V1

function VectorSubtract(const V1, V2 : TAffineVector) : TAffineVector; overload;

Returns V1-V2

procedure VectorSubtract(const v1, v2 : TAffineVector; var result : TAffineVector); overload;

Subtracts V2 from V1 and return value in result

procedure VectorSubtract(const v1, v2 : TAffineVector; var result : TVector); overload;

Subtracts V2 from V1 and return value in result

procedure VectorSubtract(const v1 : TVector; v2 : TAffineVector; var result : TVector); overload;

Subtracts V2 from V1 and return value in result

function VectorSubtract(const V1, V2 : TVector) : TVector; overload;

Returns V1-V2

procedure VectorSubtract(const v1, v2 : TVector; var result : TVector); overload;

Subtracts V2 from V1 and return value in result

procedure VectorSubtract(const v1, v2 : TVector; var result : TAffineVector); overload;

Subtracts V2 from V1 and return value in result

function VectorSubtract(const v1 : TAffineVector; delta : Single) : TAffineVector; overload;
function VectorSubtract(const v1 : TVector; delta : Single) : TVector; overload;
procedure SubtractVector(var V1 : TAffineVector; const V2 : TAffineVector); overload;

Subtracts V2 from V1, result is placed in V1

procedure SubtractVector(var V1 : TVector; const V2 : TVector); overload;

Subtracts V2 from V1, result is placed in V1

procedure CombineVector(var vr : TAffineVector; const v : TAffineVector; var f : Single); overload;

Combine the first vector with the second : vr:=vr+v*f

procedure CombineVector(var vr : TAffineVector; const v : TAffineVector; pf : PFloat); overload;
function TexPointCombine(const t1, t2 : TTexPoint; f1, f2 : Single) : TTexPoint;

Makes a linear combination of two texpoints

function VectorCombine(const V1, V2: TAffineVector; const F1, F2: Single): TAffineVector; overload;

Makes a linear combination of two vectors and return the result

function VectorCombine3(const V1, V2, V3: TAffineVector; const F1, F2, F3: Single): TAffineVector; overload;

Makes a linear combination of three vectors and return the result

procedure VectorCombine3(const V1, V2, V3: TAffineVector; const F1, F2, F3: Single; var vr : TAffineVector); overload;
procedure CombineVector(var vr : TVector; const v : TVector; var f : Single); overload;

Combine the first vector with the second : vr:=vr+v*f

procedure CombineVector(var vr : TVector; const v : TAffineVector; var f : Single); overload;

Combine the first vector with the second : vr:=vr+v*f

function VectorCombine(const V1, V2: TVector; const F1, F2: Single): TVector; overload;

Makes a linear combination of two vectors and return the result

function VectorCombine(const V1 : TVector; const V2: TAffineVector; const F1, F2: Single): TVector; overload;

Makes a linear combination of two vectors and return the result

procedure VectorCombine(const V1 : TVector; const V2: TAffineVector; const F1, F2: Single; var vr : TVector); overload;

Makes a linear combination of two vectors and place result in vr

procedure VectorCombine(const V1, V2: TVector; const F1, F2: Single; var vr : TVector); overload;

Makes a linear combination of two vectors and place result in vr

procedure VectorCombine(const V1, V2: TVector; const F2: Single; var vr : TVector); overload;

Makes a linear combination of two vectors and place result in vr, F1=1.0

function VectorCombine3(const V1, V2, V3: TVector; const F1, F2, F3: Single): TVector; overload;

Makes a linear combination of three vectors and return the result

procedure VectorCombine3(const V1, V2, V3: TVector; const F1, F2, F3: Single; var vr : TVector); overload;

Makes a linear combination of three vectors and return the result

function VectorDotProduct(const V1, V2 : Tvector2f) : Single; overload;

Calculates the dot product between V1 and V2.<p> Result:=V1[X] * V2[X] + V1[Y] * V2[Y]

function VectorDotProduct(const V1, V2 : TAffineVector) : Single; overload;

Calculates the dot product between V1 and V2.<p> Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

function VectorDotProduct(const V1, V2 : TVector) : Single; overload;

Calculates the dot product between V1 and V2.<p> Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

function VectorDotProduct(const V1 : TVector; const V2 : TAffineVector) : Single; overload;

Calculates the dot product between V1 and V2.<p> Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

function PointProject(const p, origin, direction : TAffineVector) : Single; overload;

Projects p on the line defined by o and direction.<p> Performs VectorDotProduct(VectorSubtract(p, origin), direction), which, if direction is normalized, computes the distance between origin and the projection of p on the (origin, direction) line.

function PointProject(const p, origin, direction : TVector) : Single; overload;
function VectorCrossProduct(const V1, V2 : TAffineVector): TAffineVector; overload;

Calculates the cross product between vector 1 and 2

function VectorCrossProduct(const V1, V2 : TVector): TVector; overload;

Calculates the cross product between vector 1 and 2

procedure VectorCrossProduct(const v1, v2 : TVector; var vr : TVector); overload;

Calculates the cross product between vector 1 and 2, place result in vr

procedure VectorCrossProduct(const v1, v2 : TAffineVector; var vr : TVector); overload;

Calculates the cross product between vector 1 and 2, place result in vr

procedure VectorCrossProduct(const v1, v2 : TVector; var vr : TAffineVector); overload;

Calculates the cross product between vector 1 and 2, place result in vr

procedure VectorCrossProduct(const v1, v2 : TAffineVector; var vr : TAffineVector); overload;

Calculates the cross product between vector 1 and 2, place result in vr

function Lerp(const start, stop, t : Single) : Single;

Calculates linear interpolation between start and stop at point t

function AngleLerp(start, stop, t : Single) : Single;

Calculates angular interpolation between start and stop at point t

function MatrixLerp(const m1, m2: TMatrix; const Delta: Single): TMatrix;

This is used for interpolating between 2 matrices. The result is used to reposition the model parts each frame.

function DistanceBetweenAngles(angle1, angle2 : Single) : Single;

Calculates the angular distance between two angles in radians.<p> Result is in the [0; PI] range.

function TexPointLerp(const t1, t2 : TTexPoint; t : Single) : TTexPoint; overload;

Calculates linear interpolation between texpoint1 and texpoint2 at point t

function VectorLerp(const v1, v2 : TAffineVector; t : Single) : TAffineVector; overload;

Calculates linear interpolation between vector1 and vector2 at point t

procedure VectorLerp(const v1, v2 : TAffineVector; t : Single; var vr : TAffineVector); overload;

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr

function VectorLerp(const v1, v2 : TVector; t : Single) : TVector; overload;

Calculates linear interpolation between vector1 and vector2 at point t

procedure VectorLerp(const v1, v2 : TVector; t : Single; var vr : TVector); overload;

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr

function VectorAngleLerp(const v1, v2 : TAffineVector; t : Single) : TAffineVector; overload;
function VectorAngleCombine(const v1, v2 : TAffineVector; f : Single) : TAffineVector; overload;
procedure VectorArrayLerp(const src1, src2 : PVectorArray; t : Single; n : Integer; dest : PVectorArray); overload;

Calculates linear interpolation between vector arrays

procedure VectorArrayLerp(const src1, src2 : PAffineVectorArray; t : Single; n : Integer; dest : PAffineVectorArray); overload;
procedure VectorArrayLerp(const src1, src2 : PTexPointArray; t : Single; n : Integer; dest : PTexPointArray); overload;
function InterpolatePower(const Start, Stop, Delta: Single; const DistortionDegree: Single): Single;

There functions that do the same as "Lerp", but add some distortions.

function InterpolateLn(const Start, Stop, Delta: Single; const DistortionDegree: Single): Single;
function InterpolateExp(const Start, Stop, Delta: Single; const DistortionDegree: Single): Single;
function InterpolateSin(const Start, Stop, Delta: Single): Single;

Only valid where Delta belongs to [0..1]

function InterpolateTan(const Start, Stop, Delta: Single): Single;
function InterpolateSinAlt(const Start, Stop, Delta: Single): Single;

"Alt" functions are valid everywhere

function InterpolateCombinedFastPower(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single): Single;
function InterpolateCombinedSafe(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single;
function InterpolateCombinedFast(const OriginalStart, OriginalStop, OriginalCurrent: Single; const TargetStart, TargetStop: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single;
function InterpolateCombined(const Start, Stop, Delta: Single; const DistortionDegree: Single; const InterpolationType: TGLInterpolationType): Single;
function VectorLength(const x, y : Single) : Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y).

function VectorLength(const x, y, z : Single) : Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).

function VectorLength(const v : TVector2f) : Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y).

function VectorLength(const v : TAffineVector) : Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).

function VectorLength(const v : TVector) : Single; overload;

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z+w*w).

function VectorLength(const v : array of Single) : Single; overload;

Calculates the length of a vector following the equation: sqrt(x*x+y*y+...).<p> Note: The parameter of this function is declared as open array. Thus there's no restriction about the number of the components of the vector.

function VectorNorm(const x, y : Single) : Single; overload;

Calculates norm of a vector which is defined as norm = x * x + y * y<p> Also known as "Norm 2" in the math world, this is sqr(VectorLength).

function VectorNorm(const v : TAffineVector) : Single; overload;

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z<p> Also known as "Norm 2" in the math world, this is sqr(VectorLength).

function VectorNorm(const v : TVector) : Single; overload;

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z<p> Also known as "Norm 2" in the math world, this is sqr(VectorLength).

function VectorNorm(var V: array of Single) : Single; overload;

Calculates norm of a vector which is defined as norm = v.V[0]*v.V[0] + ...<p> Also known as "Norm 2" in the math world, this is sqr(VectorLength).

procedure NormalizeVector(var v : TVector2f); overload;

Transforms a vector to unit length

procedure NormalizeVector(var v : TAffineVector); overload;

Returns the vector transformed to unit length Transforms a vector to unit length

procedure NormalizeVector(var v : TVector); overload;

Transforms a vector to unit length

function VectorNormalize(const v : TVector2f) : TVector2f; overload;

Returns the vector transformed to unit length

function VectorNormalize(const v : TAffineVector) : TAffineVector; overload;

Returns the vector transformed to unit length

function VectorNormalize(const v : TVector) : TVector; overload;

Returns the vector transformed to unit length (w component dropped)

procedure NormalizeVectorArray(list : PAffineVectorArray; n : Integer); overload;

Transforms vectors to unit length

function VectorAngleCosine(const V1, V2: TAffineVector) : Single; overload;

Calculates the cosine of the angle between Vector1 and Vector2.<p> Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))

function VectorAngleCosine(const V1, V2: TVector) : Single; overload;

Calculates the cosine of the angle between Vector1 and Vector2.<p> Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))

function VectorNegate(const Vector : TAffineVector) : TAffineVector; overload;

Negates the vector

function VectorNegate(const Vector : TVector) : TVector; overload;
procedure NegateVector(var V : TAffineVector); overload;

Negates the vector

procedure NegateVector(var V : TVector); overload;

Negates the vector

procedure NegateVector(var V : array of Single); overload;

Negates the vector

procedure ScaleVector(var v : TVector2f; factor : Single); overload;

Scales given vector by a factor

procedure ScaleVector(var v : TAffineVector; factor : Single); overload;

Scales given vector by a factor

procedure ScaleVector(var v : TAffineVector; const factor : TAffineVector); overload;

Scales given vector by another vector.<p> v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.

procedure ScaleVector(var v : TVector; factor : Single); overload;

Scales given vector by a factor

procedure ScaleVector(var v : TVector; const factor : TVector); overload;

Scales given vector by another vector.<p> v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.

function VectorScale(const v : TVector2f; factor : Single) : TVector2f; overload;

Returns a vector scaled by a factor

function VectorScale(const v : TAffineVector; factor : Single) : TAffineVector; overload;

Returns a vector scaled by a factor

procedure VectorScale(const v : TAffineVector; factor : Single; var vr : TAffineVector); overload;

Scales a vector by a factor and places result in vr

function VectorScale(const v : TVector; factor : Single) : TVector; overload;

Returns a vector scaled by a factor

procedure VectorScale(const v : TVector; factor : Single; var vr : TVector); overload;

Scales a vector by a factor and places result in vr

procedure VectorScale(const v : TVector; factor : Single; var vr : TAffineVector); overload;

Scales a vector by a factor and places result in vr

function VectorScale(const v : TAffineVector; const Factor : TAffineVector): TAffineVector; overload;

Scales given vector by another vector

function VectorScale(const v : TVector; const Factor : TVector): TVector; overload;

RScales given vector by another vector

procedure DivideVector(var v : TVector; const divider : TVector); overload;

Divides given vector by another vector.<p> v[x]:=v[x]/divider[x], v[y]:=v[y]/divider[y] etc.

procedure DivideVector(var v : TAffineVector; const divider : TAffineVector); overload;
function VectorDivide(const v: TVector; const divider : TVector): TVector; overload;
function VectorDivide(const v: TAffineVector; const divider : TAffineVector): TAffineVector; overload;
function TexpointEquals(const p1, p2: TTexpoint): Boolean;

True if all components are equal.

function RectEquals(const Rect1, Rect2: TRect): Boolean;

True if all components are equal.

function VectorEquals(const V1, V2: TVector) : Boolean; overload;

True if all components are equal.

function VectorEquals(const V1, V2: TAffineVector) : Boolean; overload;

True if all components are equal.

function AffineVectorEquals(const V1, V2: TVector) : Boolean; overload;

True if X, Y and Z components are equal.

function VectorIsNull(const v : TVector) : Boolean; overload;

True if x=y=z=0, w ignored

function VectorIsNull(const v : TAffineVector) : Boolean; overload;

True if x=y=z=0, w ignored

function VectorSpacing(const v1, v2 : TTexPoint): Single; overload;

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y]), also know as "Norm1".<p>

function VectorSpacing(const v1, v2 : TAffineVector): Single; overload;

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".<p>

function VectorSpacing(const v1, v2 : TVector): Single; overload;

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".<p>

function VectorDistance(const v1, v2 : TAffineVector): Single; overload;

Calculates distance between two vectors.<p> ie. sqrt(sqr(v1[x]-v2[x])+...)

function VectorDistance(const v1, v2 : TVector): Single; overload;

Calculates distance between two vectors.<p> ie. sqrt(sqr(v1[x]-v2[x])+...) (w component ignored)

function VectorDistance2(const v1, v2 : TAffineVector): Single; overload;

Calculates the "Norm 2" between two vectors.<p> ie. sqr(v1[x]-v2[x])+...

function VectorDistance2(const v1, v2 : TVector): Single; overload;

Calculates the "Norm 2" between two vectors.<p> ie. sqr(v1[x]-v2[x])+... (w component ignored)

function VectorPerpendicular(const V, N: TAffineVector): TAffineVector;

Calculates a vector perpendicular to N.<p> N is assumed to be of unit length, subtract out any component parallel to N

function VectorReflect(const V, N: TAffineVector): TAffineVector;

Reflects vector V against N (assumes N is normalized)

procedure RotateVector(var vector : TVector; const axis : TAffineVector; angle : Single); overload;

Rotates Vector about Axis with Angle radians

procedure RotateVector(var vector : TVector; const axis : TVector; angle : Single); overload;

Rotates Vector about Axis with Angle radians

procedure RotateVectorAroundY(var v : TAffineVector; alpha : Single);

Rotate given vector around the Y axis (alpha is in rad)

function VectorRotateAroundX(const v : TAffineVector; alpha : Single) : TAffineVector; overload;

Returns given vector rotated around the X axis (alpha is in rad)

function VectorRotateAroundY(const v : TAffineVector; alpha : Single) : TAffineVector; overload;

Returns given vector rotated around the Y axis (alpha is in rad)

procedure VectorRotateAroundY(const v : TAffineVector; alpha : Single; var vr : TAffineVector); overload;

Returns given vector rotated around the Y axis in vr (alpha is in rad)

function VectorRotateAroundZ(const v : TAffineVector; alpha : Single) : TAffineVector; overload;

Returns given vector rotated around the Z axis (alpha is in rad)

procedure AbsVector(var v : TVector); overload;

Vector components are replaced by their Abs() value. }

procedure AbsVector(var v : TAffineVector); overload;

Vector components are replaced by their Abs() value. }

function VectorAbs(const v : TVector) : TVector; overload;

Returns a vector with components replaced by their Abs value. }

function VectorAbs(const v : TAffineVector) : TAffineVector; overload;

Returns a vector with components replaced by their Abs value. }

function IsColinear(const v1, v2: TVector2f) : Boolean; overload;

Returns true if both vector are colinear

function IsColinear(const v1, v2: TAffineVector) : Boolean; overload;

Returns true if both vector are colinear

function IsColinear(const v1, v2: TVector) : Boolean; overload;

Returns true if both vector are colinear

procedure SetMatrix(var dest : THomogeneousDblMatrix; const src : TMatrix); overload;
procedure SetMatrix(var dest : TAffineMatrix; const src : TMatrix); overload;
procedure SetMatrix(var dest : TMatrix; const src : TAffineMatrix); overload;
procedure SetMatrixRow(var dest : TMatrix; rowNb : Integer; const aRow : TVector); overload;
function CreateScaleMatrix(const v : TAffineVector) : TMatrix; overload;

Creates scale matrix

function CreateScaleMatrix(const v : TVector) : TMatrix; overload;

Creates scale matrix

function CreateTranslationMatrix(const V : TAffineVector): TMatrix; overload;

Creates translation matrix

function CreateTranslationMatrix(const V : TVector): TMatrix; overload;

Creates translation matrix

function CreateScaleAndTranslationMatrix(const scale, offset : TVector): TMatrix; overload;

Creates a scale+translation matrix.<p> Scale is applied BEFORE applying offset

function CreateRotationMatrixX(const sine, cosine: Single) : TMatrix; overload;

Creates matrix for rotation about x-axis (angle in rad)

function CreateRotationMatrixX(const angle: Single) : TMatrix; overload;
function CreateRotationMatrixY(const sine, cosine: Single) : TMatrix; overload;

Creates matrix for rotation about y-axis (angle in rad)

function CreateRotationMatrixY(const angle: Single) : TMatrix; overload;
function CreateRotationMatrixZ(const sine, cosine: Single) : TMatrix; overload;

Creates matrix for rotation about z-axis (angle in rad)

function CreateRotationMatrixZ(const angle: Single) : TMatrix; overload;
function CreateRotationMatrix(const anAxis : TAffineVector; angle : Single) : TMatrix; overload;

Creates a rotation matrix along the given Axis by the given Angle in radians.

function CreateRotationMatrix(const anAxis : TVector; angle : Single) : TMatrix; overload;
function CreateAffineRotationMatrix(const anAxis: TAffineVector; angle: Single): TAffineMatrix;

Creates a rotation matrix along the given Axis by the given Angle in radians.

function MatrixMultiply(const M1, M2 : TAffineMatrix) : TAffineMatrix; overload;

Multiplies two 3x3 matrices

function MatrixMultiply(const M1, M2 : TMatrix) : TMatrix; overload;

Multiplies two 4x4 matrices

procedure MatrixMultiply(const M1, M2 : TMatrix; var MResult : TMatrix); overload;

Multiplies M1 by M2 and places result in MResult

function VectorTransform(const V: TVector; const M: TMatrix): TVector; overload;

Transforms a homogeneous vector by multiplying it with a matrix

function VectorTransform(const V: TVector; const M: TAffineMatrix): TVector; overload;

Transforms a homogeneous vector by multiplying it with a matrix

function VectorTransform(const V: TAffineVector; const M: TMatrix): TAffineVector; overload;

Transforms an affine vector by multiplying it with a matrix

function VectorTransform(const V: TAffineVector; const M: TAffineMatrix): TAffineVector; overload;

Transforms an affine vector by multiplying it with a matrix

function MatrixDeterminant(const M: TAffineMatrix): Single; overload;

Determinant of a 3x3 matrix

function MatrixDeterminant(const M: TMatrix): Single; overload;

Determinant of a 4x4 matrix

procedure AdjointMatrix(var M : TMatrix); overload;

Adjoint of a 4x4 matrix.<p> used in the computation of the inverse of a 4x4 matrix

procedure AdjointMatrix(var M : TAffineMatrix); overload;

Adjoint of a 3x3 matrix.<p> used in the computation of the inverse of a 3x3 matrix

procedure ScaleMatrix(var M : TAffineMatrix; const factor : Single); overload;

Multiplies all elements of a 3x3 matrix with a factor

procedure ScaleMatrix(var M : TMatrix; const factor : Single); overload;

Multiplies all elements of a 4x4 matrix with a factor

procedure TranslateMatrix(var M : TMatrix; const v : TAffineVector); overload;

Adds the translation vector into the matrix

procedure TranslateMatrix(var M : TMatrix; const v : TVector); overload;
procedure NormalizeMatrix(var M : TMatrix);

Normalize the matrix and remove the translation component.<p> The resulting matrix is an orthonormal matrix (Y direction preserved, then Z)

procedure TransposeMatrix(var M: TAffineMatrix); overload;

Computes transpose of 3x3 matrix

procedure TransposeMatrix(var M: TMatrix); overload;

Computes transpose of 4x4 matrix

procedure InvertMatrix(var M : TMatrix); overload;

Finds the inverse of a 4x4 matrix

function MatrixInvert(const M: TMatrix): TMatrix; overload;
procedure InvertMatrix(var M : TAffineMatrix); overload;

Finds the inverse of a 3x3 matrix;

function MatrixInvert(const M: TAffineMatrix): TAffineMatrix; overload;
function AnglePreservingMatrixInvert(const mat : TMatrix) : TMatrix;

Finds the inverse of an angle preserving matrix.<p> Angle preserving matrices can combine translation, rotation and isotropic scaling, other matrices won't be properly inverted by this function.

function MatrixDecompose(const M: TMatrix; var Tran: TTransformations): Boolean;

Decompose a non-degenerated 4x4 transformation matrix into the sequence of transformations that produced it.<p> Modified by ml then eg, original Author: Spencer W. Thomas, University of Michigan<p> The coefficient of each transformation is returned in the corresponding element of the vector Tran.<p> Returns true upon success, false if the matrix is singular.

function CreateLookAtMatrix(const eye, center, normUp: TVector): TMatrix;
function CreateMatrixFromFrustum(Left, Right, Bottom, Top, ZNear, ZFar: Single): TMatrix;
function CreatePerspectiveMatrix(FOV, Aspect, ZNear, ZFar: Single): TMatrix;
function CreateOrthoMatrix(Left, Right, Bottom, Top, ZNear, ZFar: Single): TMatrix;
function CreatePickMatrix(x, y, deltax, deltay: Single; const viewport: TVector4i): TMatrix;
function Project(objectVector: TVector; const ViewProjMatrix: TMatrix; const viewport: TVector4i; out WindowVector: TVector): Boolean;
function UnProject(WindowVector: TVector; ViewProjMatrix: TMatrix; const viewport: TVector4i; out objectVector: TVector): Boolean;
function PlaneMake(const p1, p2, p3 : TAffineVector) : THmgPlane; overload;

Computes the parameters of a plane defined by three points.

function PlaneMake(const p1, p2, p3 : TVector) : THmgPlane; overload;
function PlaneMake(const point, normal : TAffineVector) : THmgPlane; overload;

Computes the parameters of a plane defined by a point and a normal.

function PlaneMake(const point, normal : TVector) : THmgPlane; overload;
procedure SetPlane(var dest : TDoubleHmgPlane; const src : THmgPlane);

Converts from single to double representation

procedure NormalizePlane(var plane : THmgPlane);

Normalize a plane so that point evaluation = plane distance. }

function PlaneEvaluatePoint(const plane : THmgPlane; const point : TAffineVector) : Single; overload;

Calculates the cross-product between the plane normal and plane to point vector.<p> This functions gives an hint as to were the point is, if the point is in the half-space pointed by the vector, result is positive.<p> This function performs an homogeneous space dot-product.

function PlaneEvaluatePoint(const plane : THmgPlane; const point : TVector) : Single; overload;
function CalcPlaneNormal(const p1, p2, p3 : TAffineVector) : TAffineVector; overload;

Calculate the normal of a plane defined by three points.

procedure CalcPlaneNormal(const p1, p2, p3 : TAffineVector; var vr : TAffineVector); overload;
procedure CalcPlaneNormal(const p1, p2, p3 : TVector; var vr : TAffineVector); overload;
function PointIsInHalfSpace(const point, planePoint, planeNormal : TVector) : Boolean; overload;

Returns true if point is in the half-space defined by a plane with normal.<p> The plane itself is not considered to be in the tested halfspace.

function PointIsInHalfSpace(const point, planePoint, planeNormal : TAffineVector) : Boolean; overload;
function PointIsInHalfSpace(const point: TAffineVector; plane : THmgPlane) : Boolean; overload;
function PointPlaneDistance(const point, planePoint, planeNormal : TVector) : Single; overload;

Computes algebraic distance between point and plane.<p> Value will be positive if the point is in the halfspace pointed by the normal, negative on the other side.

function PointPlaneDistance(const point, planePoint, planeNormal : TAffineVector) : Single; overload;
function PointPlaneDistance(const point : TAffineVector; plane : THmgPlane) : Single; overload;
function PointPlaneOrthoProjection(const point: TAffineVector; const plane : THmgPlane; var inter : TAffineVector; bothface : Boolean = True) : Boolean;

Computes point to plane projection. Plane and direction have to be normalized

function PointPlaneProjection(const point, direction : TAffineVector; const plane : THmgPlane; var inter : TAffineVector; bothface : Boolean = True) : Boolean;
function SegmentPlaneIntersection(const ptA, ptB : TAffineVector; const plane : THmgPlane; var inter : TAffineVector) : Boolean;

Computes segment / plane intersection return false if there isn't an intersection

function PointTriangleOrthoProjection(const point, ptA, ptB, ptC : TAffineVector; var inter : TAffineVector; bothface : Boolean = True) : Boolean;

Computes point to triangle projection. Direction has to be normalized

function PointTriangleProjection(const point, direction, ptA, ptB, ptC : TAffineVector; var inter : TAffineVector; bothface : Boolean = True) : Boolean;
function IsLineIntersectTriangle(const point, direction, ptA, ptB, ptC : TAffineVector) : Boolean;

Returns true if line intersect ABC triangle.

function PointQuadOrthoProjection(const point, ptA, ptB, ptC, ptD : TAffineVector; var inter : TAffineVector; bothface : Boolean = True) : Boolean;

Computes point to Quad projection. Direction has to be normalized. Quad have to be flat and convex

function PointQuadProjection(const point, direction, ptA, ptB, ptC, ptD : TAffineVector; var inter : TAffineVector; bothface : Boolean = True) : Boolean;
function IsLineIntersectQuad(const point, direction, ptA, ptB, ptC, ptD : TAffineVector) : Boolean;

Returns true if line intersect ABCD quad. Quad have to be flat and convex

function PointDiskOrthoProjection(const point, center, up : TAffineVector; const radius: Single; var inter : TAffineVector; bothface : Boolean = True) : Boolean;

Computes point to disk projection. Direction has to be normalized

function PointDiskProjection(const point, direction, center, up : TAffineVector; const radius: Single; var inter : TAffineVector; bothface : Boolean = True) : Boolean;
function PointSegmentClosestPoint(const point, segmentStart, segmentStop : TAffineVector) : TAffineVector; overload;

Computes closest point on a segment (a segment is a limited line).

function PointSegmentClosestPoint(const point, segmentStart, segmentStop : TVector) : TVector; overload;
function PointSegmentDistance(const point, segmentStart, segmentStop : TAffineVector) : single;

Computes algebraic distance between segment and line (a segment is a limited line).

function PointLineClosestPoint(const point, linePoint, lineDirection : TAffineVector) : TAffineVector;

Computes closest point on a line.

function PointLineDistance(const point, linePoint, lineDirection : TAffineVector) : Single;

Computes algebraic distance between point and line.

procedure SegmentSegmentClosestPoint(const S0Start, S0Stop, S1Start, S1Stop : TAffineVector; var Segment0Closest, Segment1Closest : TAffineVector);

Computes the closest points (2) given two segments.

function SegmentSegmentDistance(const S0Start, S0Stop, S1Start, S1Stop : TAffineVector) : single;

Computes the closest distance between two segments.

function LineLineDistance(const linePt0, lineDir0, linePt1, lineDir1 : TAffineVector) : Single;

Computes the closest distance between two lines.

function QuaternionMake(const Imag: array of Single; Real : Single) : TQuaternion;

Creates a quaternion from the given values

function QuaternionConjugate(const Q : TQuaternion) : TQuaternion;

Returns the conjugate of a quaternion

function QuaternionMagnitude(const Q : TQuaternion) : Single;

Returns the magnitude of the quaternion

procedure NormalizeQuaternion(var Q : TQuaternion);

Normalizes the given quaternion

function QuaternionFromPoints(const V1, V2: TAffineVector): TQuaternion;

Constructs a unit quaternion from two points on unit sphere

procedure QuaternionToPoints(const Q: TQuaternion; var ArcFrom, ArcTo: TAffineVector);

Converts a unit quaternion into two points on a unit sphere

function QuaternionFromMatrix(const mat : TMatrix) : TQuaternion;

Constructs a unit quaternion from a rotation matrix

function QuaternionToMatrix(quat : TQuaternion) : TMatrix;

Constructs a rotation matrix from (possibly non-unit) quaternion.<p> Assumes matrix is used to multiply column vector on the left:<br> vnew = mat vold.<p> Works correctly for right-handed coordinate system and right-handed rotations.

function QuaternionToAffineMatrix(quat : TQuaternion) : TAffineMatrix;

Constructs an affine rotation matrix from (possibly non-unit) quaternion.<p>

function QuaternionFromAngleAxis(const angle : Single; const axis : TAffineVector) : TQuaternion;

Constructs quaternion from angle (in deg) and axis

function QuaternionFromRollPitchYaw(const r, p, y : Single) : TQuaternion;

Constructs quaternion from Euler angles

function QuaternionFromEuler(const x, y, z: Single; eulerOrder : TEulerOrder) : TQuaternion;

Constructs quaternion from Euler angles in arbitrary order (angles in degrees)

function QuaternionMultiply(const qL, qR : TQuaternion): TQuaternion;

Returns quaternion product qL * qR.<p> Note: order is important!<p> To combine rotations, use the product QuaternionMuliply(qSecond, qFirst), which gives the effect of rotating by qFirst then qSecond.

function QuaternionSlerp(const QStart, QEnd: TQuaternion; Spin: Integer; t: Single): TQuaternion; overload;

Spherical linear interpolation of unit quaternions with spins.<p> QStart, QEnd - start and end unit quaternions<br> t - interpolation parameter (0 to 1)<br> Spin - number of extra spin rotations to involve<br>

function QuaternionSlerp(const source, dest: TQuaternion; const t : Single) : TQuaternion; overload;
function LnXP1(X: Extended): Extended;

Return ln(1 + X), accurate for X near 0.

function Log10(X: Extended): Extended;

Log base 10 of X

function Log2(X: Extended): Extended; overload;

Log base 2 of X

function Log2(X: Single): Single; overload;

Log base 2 of X

function LogN(Base, X: Extended): Extended;

Log base N of X

function IntPower(Base: Extended; Exponent: Integer): Extended;

Raise base to an integer.

function Power(const Base, Exponent: Single): Single; overload;

Raise base to any power.<p> For fractional exponents, or |exponents| > MaxInt, base must be > 0.

function Power(Base: Single; Exponent: Integer): Single; overload;

Raise base to an integer.

function Power(Base: Single; Exponent: Int64): Single; overload;
function DegToRad(const Degrees: Extended): Extended; overload;
function DegToRad(const Degrees: Single): Single; overload;
function RadToDeg(const Radians: Extended): Extended; overload;
function RadToDeg(const Radians: Single): Single; overload;
function NormalizeAngle(angle : Single) : Single;

Normalize to an angle in the [-PI; +PI] range

function NormalizeDegAngle(angle : Single) : Single;

Normalize to an angle in the [-180; 180] range

procedure SinCos(const Theta: Double; out Sin, Cos: Double); overload;

Calculates sine and cosine from the given angle Theta Calculates sine and cosine from the given angle Theta

procedure SinCos(const Theta: Single; out Sin, Cos: Single); overload;

Calculates sine and cosine from the given angle Theta

procedure SinCos(const theta, radius : Double; out Sin, Cos: Double); overload;

Calculates sine and cosine from the given angle Theta and Radius.<p> sin and cos values calculated from theta are multiplicated by radius.

procedure SinCos(const theta, radius : Single; out Sin, Cos: Single); overload;

Calculates sine and cosine from the given angle Theta and Radius.<p> sin and cos values calculated from theta are multiplicated by radius.

procedure PrepareSinCosCache(var s, c : array of Single; startAngle, stopAngle : Single);

Fills up the two given dynamic arrays with sin cos values.<p> start and stop angles must be given in degrees, the number of steps is determined by the length of the given arrays.

function ArcCos(const X: Extended) : Extended; overload;
function ArcCos(const x : Single) : Single; overload;
function ArcSin(const X : Extended) : Extended; overload;
function ArcSin(const X : Single) : Single; overload;
function ArcTan2(const Y, X : Extended) : Extended; overload;
function ArcTan2(const Y, X : Single) : Single; overload;
function FastArcTan2(y, x : Single) : Single;

Fast ArcTan2 approximation, about 0.07 rads accuracy.

function Tan(const X : Extended) : Extended; overload;
function Tan(const X : Single) : Single; overload;
function CoTan(const X : Extended) : Extended; overload;
function CoTan(const X : Single) : Single; overload;
function Sinh(const x : Single) : Single; overload;
function Sinh(const x : Double) : Double; overload;
function Cosh(const x : Single) : Single; overload;
function Cosh(const x : Double) : Double; overload;
function RSqrt(v : Single) : Single;

Computes 1/Sqrt(v).<p>

function RLength(x, y : Single) : Single;

Computes 1/Sqrt(Sqr(x)+Sqr(y)).

function ISqrt(i : Integer) : Integer;

Computes an integer sqrt approximation.<p>

function ILength(x, y : Integer) : Integer; overload;

Computes an integer length Result:=Sqrt(x*x+y*y).

function ILength(x, y, z : Integer) : Integer; overload;
procedure RandomPointOnSphere(var p : TAffineVector);

Generates a random point on the unit sphere.<p> Point repartition is correctly isotropic with no privilegied direction.

function RoundInt(v : Single) : Single; overload;

Rounds the floating point value to the closest integer.<p> Behaves like Round but returns a floating point value like Int.

function RoundInt(v : Extended) : Extended; overload;
function Trunc(X: Extended): Int64;
function Round(X: Extended): Int64;
function Frac(X: Extended): Extended;
function Ceil(v : Single) : Integer; overload;
function Ceil64(v : Extended) : Int64; overload;
function Floor(v : Single) : Integer; overload;
function Floor64(v : Extended) : Int64; overload;
function ScaleAndRound(i : Integer; var s : Single) : Integer;

Multiples i by s and returns the rounded result.<p>

function Sign(x : Single) : Integer;

Returns the sign of the x value using the (-1, 0, +1) convention

function SignStrict(x : Single) : Integer;
function IsInRange(const x, a, b : Single) : Boolean; overload;

Returns True if x is in [a; b]

function IsInRange(const x, a, b : Double) : Boolean; overload;
function IsInCube(const p, d : TAffineVector) : Boolean; overload;

Returns True if p is in the cube defined by d.

function IsInCube(const p, d : TVector) : Boolean; overload;
function MinFloat(values : PSingleArray; nbItems : Integer) : Single; overload;

Returns the minimum value of the array.

function MinFloat(values : PDoubleArray; nbItems : Integer) : Double; overload;
function MinFloat(values : PExtendedArray; nbItems : Integer) : Extended; overload;
function MinFloat(const v1, v2 : Single) : Single; overload;

Returns the minimum of given values.

function MinFloat(const v : array of Single) : Single; overload;
function MinFloat(const v1, v2 : Double) : Double; overload;
function MinFloat(const v1, v2, v3 : Single) : Single; overload;
function MinFloat(const v1, v2, v3 : Double) : Double; overload;
function MaxFloat(values : PSingleArray; nbItems : Integer) : Single; overload;

Returns the maximum value of the array.

function MaxFloat(values : PDoubleArray; nbItems : Integer) : Double; overload;
function MaxFloat(values : PExtendedArray; nbItems : Integer) : Extended; overload;
function MaxFloat(const v : array of Single) : Single; overload;
function MaxFloat(const v1, v2 : Single) : Single; overload;

Returns the maximum of given values.

function MaxFloat(const v1, v2 : Double) : Double; overload;
function MaxFloat(const v1, v2, v3 : Single) : Single; overload;
function MaxFloat(const v1, v2, v3 : Double) : Double; overload;
function MinInteger(const v1, v2 : Integer) : Integer; overload;
function MinInteger(const v1, v2 : Cardinal) : Cardinal; overload;
function MinInteger(const v1, v2, v3 : Integer) : Integer; overload;
function MinInteger(const v1, v2, v3 : Cardinal) : Cardinal; overload;
function MaxInteger(const v1, v2 : Integer) : Integer; overload;
function MaxInteger(const v1, v2 : Cardinal) : Cardinal; overload;
function MaxInteger(const v1, v2, v3 : Integer) : Integer; overload;
function MaxInteger(const v1, v2, v3 : Cardinal) : Cardinal; overload;
function ClampInteger(const value, min, max : Integer) : Integer; overload;
function ClampInteger(const value, min, max : Cardinal) : Cardinal; overload;
function TriangleArea(const p1, p2, p3 : TAffineVector) : Single; overload;

Computes the triangle's area.

function PolygonArea(const p : PAffineVectorArray; nSides : Integer) : Single; overload;

Computes the polygons's area.<p> Points must be coplanar. Polygon needs not be convex.

function TriangleSignedArea(const p1, p2, p3 : TAffineVector) : Single; overload;

Computes a 2D triangle's signed area.<p> Only X and Y coordinates are used, Z is ignored.

function PolygonSignedArea(const p : PAffineVectorArray; nSides : Integer) : Single; overload;

Computes a 2D polygon's signed area.<p> Only X and Y coordinates are used, Z is ignored. Polygon needs not be convex.

procedure ScaleFloatArray(values : PSingleArray; nb : Integer; var factor : Single); overload;

Multiplies values in the array by factor.<p> This function is especially efficient for large arrays, it is not recommended for arrays that have less than 10 items.<br> Expected performance is 4 to 5 times that of a Deliph-compiled loop on AMD CPUs, and 2 to 3 when 3DNow! isn't available.

procedure ScaleFloatArray(var values : TSingleArray; factor : Single); overload;
procedure OffsetFloatArray(values : PSingleArray; nb : Integer; var delta : Single); overload;

Adds delta to values in the array.<p> Array size must be a multiple of four.

procedure OffsetFloatArray(var values : array of Single; delta : Single); overload;
procedure OffsetFloatArray(valuesDest, valuesDelta : PSingleArray; nb : Integer); overload;
function MaxXYZComponent(const v : TVector) : Single; overload;

Returns the max of the X, Y and Z components of a vector (W is ignored).

function MaxXYZComponent(const v: TAffineVector): single; overload;
function MinXYZComponent(const v : TVector) : Single; overload;

Returns the min of the X, Y and Z components of a vector (W is ignored).

function MinXYZComponent(const v: TAffineVector): single; overload;
function MaxAbsXYZComponent(v : TVector) : Single;

Returns the max of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored).

function MinAbsXYZComponent(v : TVector) : Single;

Returns the min of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored).

procedure MaxVector(var v : TVector; const v1 : TVector); overload;

Replace components of v with the max of v or v1 component.<p> Maximum is computed per component.

procedure MaxVector(var v : TAffineVector; const v1 : TAffineVector); overload;
procedure MinVector(var v : TVector; const v1 : TVector); overload;

Replace components of v with the min of v or v1 component.<p> Minimum is computed per component.

procedure MinVector(var v : TAffineVector; const v1 : TAffineVector); overload;
procedure SortArrayAscending(var a : array of Extended);

Sorts given array in ascending order.<p> NOTE : current implementation is a slow bubble sort...

function ClampValue(const aValue, aMin, aMax : Single) : Single; overload;

Clamps aValue in the aMin-aMax interval.<p>

function ClampValue(const aValue, aMin : Single) : Single; overload;

Clamps aValue in the aMin-INF interval.<p>

function GeometryOptimizationMode : String;

Returns the detected optimization mode.<p> Returned values is either 'FPU', '3DNow!' or 'SSE'.

procedure BeginFPUOnlySection;

Begins a FPU-only section.<p> You can use a FPU-only section to force use of FPU versions of the math functions, though typically slower than their SIMD counterparts, they have a higher precision (80 bits internally) that may be required in some cases.<p> Each BeginFPUOnlySection call must be balanced by a EndFPUOnlySection (calls can be nested).

procedure EndFPUOnlySection;

Ends a FPU-only section.<p> See BeginFPUOnlySection.

function ConvertRotation(const Angles : TAffineVector) : TVector;

Turn a triplet of rotations about x, y, and z (in that order) into an equivalent rotation around a single axis (all in radians).<p>

function MakeAffineDblVector(var v : array of Double) : TAffineDblVector;
function MakeDblVector(var v : array of Double) : THomogeneousDblVector;
function VectorAffineDblToFlt(const v : TAffineDblVector) : TAffineVector;
function VectorDblToFlt(const v : THomogeneousDblVector) : THomogeneousVector;
function VectorAffineFltToDbl(const v : TAffineVector) : TAffineDblVector;
function VectorFltToDbl(const v : TVector): THomogeneousDblVector;
function PointInPolygon(var xp, yp : array of Single; x, y : Single) : Boolean;
function IsPointInPolygon(Polygon: array of TPoint; p: TPoint): Boolean;
procedure DivMod(Dividend: Integer; Divisor: Word; var Result, Remainder: Word);
function Turn(const Matrix: TMatrix; angle : Single) : TMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around its Y-axis

function Turn(const Matrix: TMatrix; const MasterUp : TAffineVector; Angle : Single) : TMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around MasterUp

function Pitch(const Matrix: TMatrix; Angle: Single): TMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around its X-axis

function Pitch(const Matrix: TMatrix; const MasterRight: TAffineVector; Angle: Single): TMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around MasterRight

function Roll(const Matrix: TMatrix; Angle: Single): TMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around its Z-axis

function Roll(const Matrix: TMatrix; const MasterDirection: TAffineVector; Angle: Single): TMatrix; overload;

Rotates the given coordinate system (represented by the matrix) around MasterDirection

function IntersectLinePlane(const point, direction : TVector; const plane : THmgPlane; intersectPoint : PVector = nil) : Integer; overload;

Compute the intersection point "res" of a line with a plane.<p> Return value:<ul> <li>0 : no intersection, line parallel to plane <li>1 : res is valid <li>-1 : line is inside plane </ul><br> Adapted from:<br> E.Hartmann, Computeruntersttzte Darstellende Geometrie, B.G. Teubner Stuttgart 1988

function IntersectTriangleBox( const p1, p2, p3, aMinExtent, aMaxExtent : TAffineVector): Boolean;

Compute intersection between a triangle and a box.<p> Returns True if an intersection was found.

function IntersectSphereBox( const SpherePos : TVector; const SphereRadius : Single; const BoxMatrix : TMatrix; const BoxScale : TAffineVector ; intersectPoint : PAffineVector = nil ; normal : PAffineVector = nil ; depth : PSingle = nil ) : Boolean;

Compute intersection between a Sphere and a box.<p> Up, Direction and Right must be normalized! Use CubDepht, CubeHeight and CubeWidth to scale TGLCube.

function RayCastPlaneIntersect(const rayStart, rayVector : TVector; const planePoint, planeNormal : TVector; intersectPoint : PVector = nil) : Boolean; overload;

Compute intersection between a ray and a plane.<p> Returns True if an intersection was found, the intersection point is placed in intersectPoint is the reference is not nil.

function RayCastPlaneXZIntersect(const rayStart, rayVector : TVector; const planeY : Single; intersectPoint : PVector = nil) : Boolean; overload;
function RayCastTriangleIntersect(const rayStart, rayVector : TVector; const p1, p2, p3 : TAffineVector; intersectPoint : PVector = nil; intersectNormal : PVector = nil) : Boolean; overload;

Compute intersection between a ray and a triangle.

function RayCastMinDistToPoint(const rayStart, rayVector : TVector; const point : TVector) : Single;

Compute the min distance a ray will pass to a point.<p>

function RayCastIntersectsSphere(const rayStart, rayVector : TVector; const sphereCenter : TVector; const sphereRadius : Single) : Boolean; overload;

Determines if a ray will intersect with a given sphere.<p>

function RayCastSphereIntersect(const rayStart, rayVector : TVector; const sphereCenter : TVector; const sphereRadius : Single; var i1, i2 : TVector) : Integer; overload;

Calculates the intersections between a sphere and a ray.<p> Returns 0 if no intersection is found (i1 and i2 untouched), 1 if one intersection was found (i1 defined, i2 untouched), and 2 is two intersections were found (i1 and i2 defined).

function RayCastBoxIntersect( const rayStart, rayVector, aMinExtent, aMaxExtent : TAffineVector; intersectPoint : PAffineVector = nil) : Boolean;

Compute intersection between a ray and a box.<p> Returns True if an intersection was found, the intersection point is placed in intersectPoint if the reference is not nil.

function RectanglesIntersect(const ACenterOfRect1, ACenterOfRect2, ASizeOfRect1, ASizeOfRect2: TVector2f): Boolean;

Determine if 2 rectanges intersect.

function RectangleContains(const ACenterOfBigRect1, ACenterOfSmallRect2, ASizeOfBigRect1, ASizeOfSmallRect2: TVector2f; const AEps: Single = 0.0): Boolean;

Determine if BigRect completely contains SmallRect.

function SphereVisibleRadius(distance, radius : Single) : Single;

Computes the visible radius of a sphere in a perspective projection.<p> This radius can be used for occlusion culling (cone extrusion) or 2D intersection testing.

function ExtractFrustumFromModelViewProjection(const modelViewProj : TMatrix) : TFrustum;

Extracts a TFrustum for combined modelview and projection matrices.

function IsVolumeClipped(const objPos : TAffineVector; const objRadius : Single; const Frustum : TFrustum) : Boolean; overload;

Determines if volume is clipped or not

function IsVolumeClipped(const objPos : TVector; const objRadius : Single; const Frustum : TFrustum) : Boolean; overload;
function IsVolumeClipped(const min, max : TAffineVector; const Frustum : TFrustum) : Boolean; overload;
function MakeParallelProjectionMatrix(const plane : THmgPlane; const dir : TVector) : TMatrix;

Creates a parallel projection matrix.<p> Transformed points will projected on the plane along the specified direction.

function MakeShadowMatrix(const planePoint, planeNormal, lightPos : TVector) : TMatrix;

Creates a shadow projection matrix.<p> Shadows will be projected onto the plane defined by planePoint and planeNormal, from lightPos.

function MakeReflectionMatrix(const planePoint, planeNormal : TAffineVector) : TMatrix;

Builds a reflection matrix for the given plane.<p> Reflection matrix allow implementing planar reflectors in OpenGL (mirrors).

function PackRotationMatrix(const mat : TMatrix) : TPackedRotationMatrix;

Packs an homogeneous rotation matrix to 6 bytes.<p> The 6:64 (or 6:36) compression ratio is achieved by computing the quaternion associated to the matrix and storing its Imaginary components at 16 bits precision each.<br> Deviation is typically below 0.01% and around 0.1% in worst case situations.<p> Note: quaternion conversion is faster and more robust than an angle decomposition.

function UnPackRotationMatrix(const packedMatrix : TPackedRotationMatrix) : TMatrix;

Restores a packed rotation matrix.<p> See PackRotationMatrix.

function BarycentricCoordinates(const v1, v2, v3, p: TAffineVector; var u, v: single): boolean;

Calculates the barycentric coordinates for the point p on the triangle defined by the vertices v1, v2 and v3. That is, solves p = u * v1 + v * v2 + (1-u-v) * v3 for u,v. Returns true if the point is inside the triangle, false otherwise.<p> NOTE: This function assumes that the point lies on the plane defined by the triangle. If this is not the case, the function will not work correctly!

function GetSafeTurnAngle(const AOriginalPosition, AOriginalUpVector, ATargetPosition, AMoveAroundTargetCenter: TVector): TVector2f; overload;

Calculates angles for the Camera.MoveAroundTarget(pitch, turn) procedure. Initially from then GLCameraColtroller unit, requires AOriginalUpVector to contain only -1, 0 or 1. Result contains pitch and turn angles.

function GetSafeTurnAngle(const AOriginalPosition, AOriginalUpVector, ATargetPosition, AMoveAroundTargetCenter: TAffineVector): TVector2f; overload;
function MoveObjectAround(const AMovingObjectPosition, AMovingObjectUp, ATargetPosition: TVector; pitchDelta, turnDelta: Single): TVector;

Extracted from Camera.MoveAroundTarget(pitch, turn).

function AngleBetweenVectors(const A, B, ACenterPoint: TVector): Single; overload;

Calcualtes Angle between 2 Vectors: (A-CenterPoint) and (B-CenterPoint). In radians.

function AngleBetweenVectors(const A, B, ACenterPoint: TAffineVector): Single; overload;
function ShiftObjectFromCenter(const AOriginalPosition: TVector; const ACenter: TVector; const ADistance: Single; const AFromCenterSpot: Boolean): TVector; overload;

AOriginalPosition - Object initial position. ACenter - some point, from which is should be distanced.

ADistance + AFromCenterSpot - distance, which object should keep from ACenter or ADistance + not AFromCenterSpot - distance, which object should shift from his current position away from center.

function ShiftObjectFromCenter(const AOriginalPosition: TAffineVector; const ACenter: TAffineVector; const ADistance: Single; const AFromCenterSpot: Boolean): TAffineVector; overload;

Types

PFloat = PSingle;
PTexPoint = ˆTTexPoint;
PByteVector = ˆTByteVector;
PByteArray = PByteVector;
TByteVector = array[0..cMaxArray] of Byte;
PWordVector = ˆTWordVector;
TWordVector = array[0..cMaxArray] of Word;
PIntegerVector = ˆTIntegerVector;
PIntegerArray = PIntegerVector;
TIntegerVector = array[0..cMaxArray] of Integer;
PFloatVector = ˆTFloatVector;
PFloatArray = PFloatVector;
PSingleArray = PFloatArray;
TFloatVector = array[0..cMaxArray] of Single;
TSingleArray = array of Single;
PDoubleVector = ˆTDoubleVector;
PDoubleArray = PDoubleVector;
TDoubleVector = array[0..cMaxArray] of Double;
PExtendedVector = ˆTExtendedVector;
PExtendedArray = PExtendedVector;
TExtendedVector = array[0..cMaxArray] of Extended;
PPointerVector = ˆTPointerVector;
PPointerArray = PPointerVector;
TPointerVector = array[0..cMaxArray] of Pointer;
PCardinalVector = ˆTCardinalVector;
PCardinalArray = PCardinalVector;
TCardinalVector = array[0..cMaxArray] of Cardinal;
PLongWordVector = ˆTLongWordVector;
PLongWordArray = PLongWordVector;
TLongWordVector = array[0..cMaxArray] of LongWord;
PHomogeneousByteVector = ˆTHomogeneousByteVector;
THomogeneousByteVector = TVector4b;
PHomogeneousWordVector = ˆTHomogeneousWordVector;
THomogeneousWordVector = TVector4w;
PHomogeneousIntVector = ˆTHomogeneousIntVector;
THomogeneousIntVector = TVector4i;
PHomogeneousFltVector = ˆTHomogeneousFltVector;
THomogeneousFltVector = TVector4f;
PHomogeneousDblVector = ˆTHomogeneousDblVector;
THomogeneousDblVector = TVector4d;
PHomogeneousExtVector = ˆTHomogeneousExtVector;
THomogeneousExtVector = TVector4e;
PHomogeneousPtrVector = ˆTHomogeneousPtrVector;
THomogeneousPtrVector = TVector4p;
PAffineByteVector = ˆTAffineByteVector;
TAffineByteVector = TVector3b;
PAffineWordVector = ˆTAffineWordVector;
TAffineWordVector = TVector3w;
PAffineIntVector = ˆTAffineIntVector;
TAffineIntVector = TVector3i;
PAffineFltVector = ˆTAffineFltVector;
TAffineFltVector = TVector3f;
PAffineDblVector = ˆTAffineDblVector;
TAffineDblVector = TVector3d;
PAffineExtVector = ˆTAffineExtVector;
TAffineExtVector = TVector3e;
PAffinePtrVector = ˆTAffinePtrVector;
TAffinePtrVector = TVector3p;
PVector2f = ˆTVector2f;
PVector = ˆTVector;
TVector = THomogeneousFltVector;
PHomogeneousVector = ˆTHomogeneousVector;
THomogeneousVector = THomogeneousFltVector;
PAffineVector = ˆTAffineVector;
TAffineVector = TVector3f;
PVertex = ˆTVertex;
TVertex = TAffineVector;
PAffineVectorArray = ˆTAffineVectorArray;
TAffineVectorArray = array[0..MAXINT shr 4] of TAffineVector;
PVectorArray = ˆTVectorArray;
TVectorArray = array[0..MAXINT shr 5] of TVector;
PTexPointArray = ˆTTexPointArray;
TTexPointArray = array [0..MaxInt shr 4] of TTexPoint;
THomogeneousByteMatrix = TMatrix4b;
THomogeneousWordMatrix = array[0..3] of THomogeneousWordVector;
THomogeneousIntMatrix = TMatrix4i;
THomogeneousFltMatrix = TMatrix4f;
THomogeneousDblMatrix = TMatrix4d;
THomogeneousExtMatrix = array[0..3] of THomogeneousExtVector;
TAffineByteMatrix = TMatrix3b;
TAffineWordMatrix = array[0..2] of TAffineWordVector;
TAffineIntMatrix = TMatrix3i;
TAffineFltMatrix = TMatrix3f;
TAffineDblMatrix = TMatrix3d;
TAffineExtMatrix = array[0..2] of TAffineExtVector;
PMatrix = ˆTMatrix;
TMatrix = THomogeneousFltMatrix;
TMatrixArray = array [0..MaxInt shr 7] of TMatrix;
PMatrixArray = ˆTMatrixArray;
PHomogeneousMatrix = ˆTHomogeneousMatrix;
THomogeneousMatrix = THomogeneousFltMatrix;
PAffineMatrix = ˆTAffineMatrix;
TAffineMatrix = TAffineFltMatrix;
THmgPlane = TVector;

A plane equation.<p> Defined by its equation A.x+B.y+C.z+D<p>, a plane can be mapped to the homogeneous space coordinates, and this is what we are doing here.<br> The typename is just here for easing up data manipulation.

TDoubleHmgPlane = THomogeneousDblVector;
PQuaternion = ˆTQuaternion;
PQuaternionArray = ˆTQuaternionArray;
TQuaternionArray = array[0..MAXINT shr 5] of TQuaternion;
TTransType = (...);
Values
  • ttScaleX:
  • ttScaleY:
  • ttScaleZ:
  • ttShearXY:
  • ttShearXZ:
  • ttShearYZ:
  • ttRotateX:
  • ttRotateY:
  • ttRotateZ:
  • ttTranslateX:
  • ttTranslateY:
  • ttTranslateZ:
  • ttPerspectiveX:
  • ttPerspectiveY:
  • ttPerspectiveZ:
  • ttPerspectiveW:
TTransformations = array [TTransType] of Single;
TPackedRotationMatrix = array [0..2] of SmallInt;
TGLInterpolationType = (...);
Values
  • itLinear:
  • itPower:
  • itSin:
  • itSinAlt:
  • itTan:
  • itLn:
  • itExp:
TEulerOrder = (...);
Values
  • eulXYZ:
  • eulXZY:
  • eulYXZ:
  • eulYZX:
  • eulZXY:
  • eulZYX:

Constants

cMaxArray = (MaxInt shr 4);
cColinearBias = 1e-8;
XTexPoint : TTexPoint = (S:1; T:0);
YTexPoint : TTexPoint = (S:0; T:1);
XYTexPoint : TTexPoint = (S:1; T:1);
NullTexPoint : TTexPoint = (S:0; T:0);
MidTexPoint : TTexPoint = (S:0.5; T:0.5);
XVector : TAffineVector = (X:1; Y:0; Z:0);
YVector : TAffineVector = (X:0; Y:1; Z:0);
ZVector : TAffineVector = (X:0; Y:0; Z:1);
XYVector : TAffineVector = (X:1; Y:1; Z:0);
XZVector : TAffineVector = (X:1; Y:0; Z:1);
YZVector : TAffineVector = (X:0; Y:1; Z:1);
XYZVector : TAffineVector = (X:1; Y:1; Z:1);
NullVector : TAffineVector = (X:0; Y:0; Z:0);
MinusXVector : TAffineVector = (X:-1; Y: 0; Z: 0);
MinusYVector : TAffineVector = (X: 0; Y:-1; Z: 0);
MinusZVector : TAffineVector = (X: 0; Y: 0; Z:-1);
XHmgVector : THomogeneousVector = (X:1; Y:0; Z:0; W:0);
YHmgVector : THomogeneousVector = (X:0; Y:1; Z:0; W:0);
ZHmgVector : THomogeneousVector = (X:0; Y:0; Z:1; W:0);
WHmgVector : THomogeneousVector = (X:0; Y:0; Z:0; W:1);
XYHmgVector : THomogeneousVector = (X:1; Y:1; Z:0; W:0);
YZHmgVector : THomogeneousVector = (X:0; Y:1; Z:1; W:0);
XZHmgVector : THomogeneousVector = (X:1; Y:0; Z:1; W:0);
XYZHmgVector : THomogeneousVector = (X:1; Y:1; Z:1; W:0);
XYZWHmgVector : THomogeneousVector = (X:1; Y:1; Z:1; W:1);
NullHmgVector : THomogeneousVector = (X:0; Y:0; Z:0; W:0);
XHmgPoint : THomogeneousVector = (X:1; Y:0; Z:0; W:1);
YHmgPoint : THomogeneousVector = (X:0; Y:1; Z:0; W:1);
ZHmgPoint : THomogeneousVector = (X:0; Y:0; Z:1; W:1);
WHmgPoint : THomogeneousVector = (X:0; Y:0; Z:0; W:1);
NullHmgPoint : THomogeneousVector = (X:0; Y:0; Z:0; W:1);
IdentityMatrix: TAffineMatrix = (V:((X:1; Y:0; Z:0), (X:0; Y:1; Z:0), (X:0; Y:0; Z:1)));
IdentityHmgMatrix: TMatrix = (V:((X:1; Y:0; Z:0; W:0), (X:0; Y:1; Z:0; W:0), (X:0; Y:0; Z:1; W:0), (X:0; Y:0; Z:0; W:1)));
IdentityHmgDblMatrix: THomogeneousDblMatrix = (V:((X:1; Y:0; Z:0; W:0), (X:0; Y:1; Z:0; W:0), (X:0; Y:0; Z:1; W:0), (X:0; Y:0; Z:0; W:1)));
EmptyMatrix: TAffineMatrix = (V:((X:0; Y:0; Z:0), (X:0; Y:0; Z:0), (X:0; Y:0; Z:0)));
EmptyHmgMatrix: TMatrix = (V:((X:0; Y:0; Z:0; W:0), (X:0; Y:0; Z:0; W:0), (X:0; Y:0; Z:0; W:0), (X:0; Y:0; Z:0; W:0)));
IdentityQuaternion: TQuaternion = (ImagPart:(X:0; Y:0; Z:0); RealPart: 1);
EPSILON : Single = 1e-40;
EPSILON2 : Single = 1e-30;
cPI : Single = 3.141592654;
cPIdiv180 : Single = 0.017453292;
c180divPI : Single = 57.29577951;
c2PI : Single = 6.283185307;
cPIdiv2 : Single = 1.570796326;
cPIdiv4 : Single = 0.785398163;
c3PIdiv2 : Single = 4.71238898;
c3PIdiv4 : Single = 2.35619449;
cInv2PI : Single = 1/6.283185307;
cInv360 : Single = 1/360;
c180 : Single = 180;
c360 : Single = 360;
cOneHalf : Single = 0.5;
cLn10 : Single = 2.302585093;
MinSingle = 1.5e-45;
MaxSingle = 3.4e+38;
MinDouble = 5.0e-324;
MaxDouble = 1.7e+308;
MinExtended = 3.4e-4932;
MaxExtended = 1.1e+4932;
MinComp = -9.223372036854775807e+18;
MaxComp = 9.223372036854775807e+18;

Variables

vSIMD: Byte = 0;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:43


GLScene v.1.1.2: VectorGeometry: packed record TTexPoint

packed record TTexPoint

Unit

VectorGeometry

Declaration

type TTexPoint = packed record

Description

Overview

Fields

S: Single;
T: Single;

Description

Fields

S: Single;
T: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:43


GLScene v.1.1.2: VectorGeometry: record TQuaternion

record TQuaternion

Unit

VectorGeometry

Declaration

type TQuaternion = record

Description

Overview

Fields

ImagPart: TAffineVector;
RealPart: Single;

Description

Fields

ImagPart: TAffineVector;
RealPart: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:43


GLScene v.1.1.2: VectorGeometry: record TRectangle

record TRectangle

Unit

VectorGeometry

Declaration

type TRectangle = record

Description

Overview

Fields

Left: Integer;
Top: Integer;
Width: Integer;
Height: Integer;

Description

Fields

Left: Integer;
Top: Integer;
Width: Integer;
Height: Integer;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:43


GLScene v.1.1.2: VectorGeometry: record TFrustum

record TFrustum

Unit

VectorGeometry

Declaration

type TFrustum = record

Description

Overview

Fields

pLeft: THmgPlane;
pTop: THmgPlane;
pRight: THmgPlane;
pBottom: THmgPlane;
pNear: THmgPlane;
pFar: THmgPlane;

Description

Fields

pLeft: THmgPlane;
pTop: THmgPlane;
pRight: THmgPlane;
pBottom: THmgPlane;
pNear: THmgPlane;
pFar: THmgPlane;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:43


GLScene v.1.1.2: VectorLists

Unit VectorLists

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

VectorLists<p>

Misc. lists of vectors and entities<p>

<b>History : </b><font size=-1><ul> <li>23/02/11 - Yar - Added Revision mechanism to TAffineVectorList <li>15/12/10 - DaStr - Added Min() and Max() for TSingleList and TDoubleList <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>24/08/10 - Yar - Added to T4ByteList more overload of Add method <li>11/06/10 - Yar - Bugfixed binary reading TTexPointList for FPC <li>20/05/10 - Yar - Fixes for Linux x64 <li>27/02/10 - Yar - Added TLongWordList <li>06/02/10 - Yar - Added methods to TSingleList Added T4ByteList <li>25/11/09 - DanB - Fixed FastQuickSortLists for 64bit (thanks YarUnderoaker) ASM code protected with IFDEFs <li>16/10/08 - UweR - Compatibility fix for Delphi 2009 <li>01/03/08 - DaStr - Added Borland-style persistency support to TBaseList <li>29/03/07 - DaStr - Added more explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>28/03/07 - DaStr - Renamed parameters in some methods (thanks Burkhard Carstens) (Bugtracker ID = 1678658) <li>25/01/07 - DaStr - Reformated code according to VCL standard Added explicit pointer dereferencing (thanks Burkhard Carstens) (Bugtracker ID = 1678644) <li>23/01/07 - fig - Added FindOrAdd() or IndexOf() to TTexpointList <li>16/01/07 - DaStr - Added TDoubleList <li>28/06/04 - LR - Removed ..\ from the GLScene.inc <li>03/09/03 - EG - Added TBaseList.Move, faster TIntegerList.Offset <li>22/08/03 - EG - Faster FastQuickSortLists <li>13/08/03 - SG - Added TQuaternionList <li>05/06/03 - EG - Added MinInteger, some TIntegerList optimizations <li>03/06/03 - EG - Added TIntegerList.BinarySearch and AddSorted (Mattias Fagerlund) <li>22/01/03 - EG - Added AddIntegers <li>20/01/03 - EG - Added TIntegerList.SortAndRemoveDuplicates <li>22/10/02 - EG - Added TransformXxxx to TAffineVectorList <li>04/07/02 - EG - Fixed TIntegerList.Add( 2 at once ) <li>15/06/02 - EG - Added TBaseListOption stuff <li>28/05/02 - EG - TBaseList.SetCount now properly resets new items <li>23/02/02 - EG - Added TBaseList.UseMemory <li>20/01/02 - EG - Now uses new funcs Add/ScaleVectorArray and VectorArrayAdd <li>06/12/01 - EG - Added Sort & MaxInteger to TIntegerList <li>04/12/01 - EG - Added TIntegerList.IndexOf <li>18/08/01 - EG - Fixed TAffineVectorList.Add (list) <li>03/08/01 - EG - Added TIntegerList.AddSerie <li>19/07/01 - EG - Added TAffineVectorList.Add (list variant) <li>18/03/01 - EG - Additions and enhancements <li>16/03/01 - EG - Introduced new PersistentClasses <li>04/03/01 - EG - Optimized TAffineVectorList.Normalize (x2 speed on K7) <li>26/02/01 - EG - VectorArrayLerp 3DNow optimized (x2 speed on K7) <li>08/08/00 - EG - Added TSingleList <li>20/07/00 - EG - Creation </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TBaseList |
Class TBaseVectorList |
Class TAffineVectorList |
Class TVectorList |
Class TTexPointList |
Class TIntegerList |
Class TSingleList |
Class TDoubleList |
Class TByteList |
Class TQuaternionList |
packed record T4ByteData |
Class T4ByteList |
Class TLongWordList |

Functions and Procedures

procedure QuickSortLists(startIndex, endIndex: Integer; refList: TSingleList; objList: TList); overload;
procedure QuickSortLists(startIndex, endIndex: Integer; refList: TSingleList; objList: TBaseList); overload;
procedure FastQuickSortLists(startIndex, endIndex: Integer; refList: TSingleList; objList: TPersistentObjectList);

Types

TBaseListOption = (...);
TBaseListOptions = set of TBaseListOption;
TSingleArrayList = array[0..MaxInt shr 4] of Single;
PSingleArrayList = ˆTSingleArrayList;
TDoubleArrayList = array[0..MaxInt shr 4] of Double;
PDoubleArrayList = ˆTDoubleArrayList;
T4ByteArrayList = array[0..MaxInt shr 4] of T4ByteData;
P4ByteArrayList = ˆT4ByteArrayList;

Description

Functions and Procedures

procedure QuickSortLists(startIndex, endIndex: Integer; refList: TSingleList; objList: TList); overload;

Sort the refList in ascending order, ordering objList (TList) on the way.

procedure QuickSortLists(startIndex, endIndex: Integer; refList: TSingleList; objList: TBaseList); overload;

Sort the refList in ascending order, ordering objList (TBaseList) on the way.

procedure FastQuickSortLists(startIndex, endIndex: Integer; refList: TSingleList; objList: TPersistentObjectList);

Sort the refList in ascending order, ordering objList on the way.<p> Use if, and *ONLY* if refList contains only values superior or equal to 1.

Types

TBaseListOption = (...);
Values
  • bloExternalMemory:
  • bloSetCountResetsMemory:
TBaseListOptions = set of TBaseListOption;
TSingleArrayList = array[0..MaxInt shr 4] of Single;
PSingleArrayList = ˆTSingleArrayList;
TDoubleArrayList = array[0..MaxInt shr 4] of Double;
PDoubleArrayList = ˆTDoubleArrayList;
T4ByteArrayList = array[0..MaxInt shr 4] of T4ByteData;
P4ByteArrayList = ˆT4ByteArrayList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:43


GLScene v.1.1.2: VectorLists: Class TBaseList

Class TBaseList

Unit

VectorLists

Declaration

type TBaseList = class(TPersistentObject)

Description

Base class for lists, introduces common behaviours.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseList

Overview

Fields

Protected | FBaseList: VectorGeometry.PByteArray;
Protected | FItemSize: Integer;

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;
Public | function DataSize: Integer;
Protected | function BufferItem: PByteArray;
Protected | function GetSetCountResetsMemory: Boolean;
Public | procedure AddNulls(nbVals: Cardinal);
Public | procedure AdjustCapacityToAtLeast(const size: Integer);
Public | procedure Assign(Src: TPersistent); override;
Public | procedure Clear;
Public | procedure Delete(Index: Integer);
Public | procedure DeleteItems(Index: Integer; nbVals: Cardinal);
Public | procedure Exchange(index1, index2: Integer);
Public | procedure Flush;
Public | procedure InsertNulls(Index: Integer; nbVals: Cardinal);
Public | procedure Move(curIndex, newIndex: Integer);
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure Reverse;
Public | procedure UseMemory(rangeStart: Pointer; rangeCapacity: Integer);
Public | procedure WriteToFiler(writer: TVirtualWriter); override;
Protected | procedure DefineProperties(AFiler: TFiler); override;
Protected | procedure ReadItemsData(AReader : TReader); virtual;
Protected | procedure SetCapacity(NewCapacity: Integer); virtual;
Protected | procedure SetCount(Val: Integer);
Protected | procedure SetSetCountResetsMemory(const Val: Boolean);
Protected | procedure WriteItemsData(AWriter : TWriter); virtual;

Properties

Public | property Capacity: Integer read FCapacity write SetCapacity;
Public | property Count: Integer read FCount write SetCount;
Public | property GrowthDelta: Integer read FGrowthDelta write FGrowthDelta;
Public | property Revision: LongWord read FRevision write FRevision;
Public | property SetCountResetsMemory: Boolean read GetSetCountResetsMemory write SetSetCountResetsMemory;
Public | property TagString: string read FTagString write FTagString;

Description

Fields

Protected FBaseList: VectorGeometry.PByteArray;

The base list pointer (untyped)

Protected FItemSize: Integer;

Must be defined by all subclasses in their constructor(s)

Methods

Public constructor Create; override;
Public destructor Destroy; override;
Public function DataSize: Integer;
Protected function BufferItem: PByteArray;
Protected function GetSetCountResetsMemory: Boolean;
Public procedure AddNulls(nbVals: Cardinal);
Public procedure AdjustCapacityToAtLeast(const size: Integer);
Public procedure Assign(Src: TPersistent); override;
Public procedure Clear;

Empties the list and release.

Public procedure Delete(Index: Integer);
Public procedure DeleteItems(Index: Integer; nbVals: Cardinal);
Public procedure Exchange(index1, index2: Integer);
Public procedure Flush;

Empties the list without altering capacity.

Public procedure InsertNulls(Index: Integer; nbVals: Cardinal);
Public procedure Move(curIndex, newIndex: Integer);
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure Reverse;
Public procedure UseMemory(rangeStart: Pointer; rangeCapacity: Integer);

Tell the list to use the specified range instead of its own.<p> rangeCapacity should be expressed in bytes.<p> The allocated memory is NOT managed by the list, current content if copied to the location, if the capacity is later changed, regular memory will be allocated, and the specified range no longer used.

Public procedure WriteToFiler(writer: TVirtualWriter); override;
Protected procedure DefineProperties(AFiler: TFiler); override;
Protected procedure ReadItemsData(AReader : TReader); virtual;
Protected procedure SetCapacity(NewCapacity: Integer); virtual;

Only function where list may be alloc'ed & freed.<p> Resizes the array pointed by FBaseList, adjust the subclass's typed pointer accordingly if any.

Protected procedure SetCount(Val: Integer);
Protected procedure SetSetCountResetsMemory(const Val: Boolean);
Protected procedure WriteItemsData(AWriter : TWriter); virtual;

Properties

Public property Capacity: Integer read FCapacity write SetCapacity;

Current list capacity.<p> Not persistent.

Public property Count: Integer read FCount write SetCount;

Nb of items in the list.<p> When assigning a Count, added items are reset to zero.

Public property GrowthDelta: Integer read FGrowthDelta write FGrowthDelta;

List growth granularity.<p> Not persistent.

Public property Revision: LongWord read FRevision write FRevision;

Increase by one after every content changes.

Public property SetCountResetsMemory: Boolean read GetSetCountResetsMemory write SetSetCountResetsMemory;

If true (default value) adjusting count will reset added values.<p> Switching this option to true will turn off this memory reset, which can improve performance is that having empty values isn't required.

Public property TagString: string read FTagString write FTagString;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorLists: Class TBaseVectorList

Class TBaseVectorList

Unit

VectorLists

Declaration

type TBaseVectorList = class(TBaseList)

Description

Base class for vector lists, introduces common behaviours.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseList
  • TBaseVectorList

Overview

Methods

Public | function MaxSpacing(list2: TBaseVectorList): Single; dynamic;
Public | function Sum: TAffineVector; dynamic;
Protected | function GetItemAddress(Index: Integer): PFloatArray;
Public | procedure AngleCombine(const list1: TBaseVectorList; intensity: Single);
Public | procedure AngleLerp(const list1, list2: TBaseVectorList; lerpFactor: Single);
Public | procedure Combine(const list2: TBaseVectorList; factor: Single); dynamic;
Public | procedure GetExtents(out min, max: TAffineVector); dynamic;
Public | procedure Lerp(const list1, list2: TBaseVectorList; lerpFactor: Single); dynamic; abstract;
Public | procedure Normalize; dynamic;
Public | procedure ReadFromFiler(reader: TVirtualReader); override;
Public | procedure Translate(const delta: TAffineVector); overload; dynamic;
Public | procedure Translate(const delta: TBaseVectorList); overload; dynamic;
Public | procedure TranslateInv(const delta: TBaseVectorList); overload; dynamic;
Public | procedure WriteToFiler(writer: TVirtualWriter); override;

Properties

Public property ItemAddress[Index: Integer]: PFloatArray read GetItemAddress;

Description

Methods

Public function MaxSpacing(list2: TBaseVectorList): Single; dynamic;
Public function Sum: TAffineVector; dynamic;
Protected function GetItemAddress(Index: Integer): PFloatArray;
Public procedure AngleCombine(const list1: TBaseVectorList; intensity: Single);
Public procedure AngleLerp(const list1, list2: TBaseVectorList; lerpFactor: Single);

Replace content of the list with angle lerp between the two given lists.<p> Note: you can't Lerp with Self!!!

Public procedure Combine(const list2: TBaseVectorList; factor: Single); dynamic;

Linear combination of Self with another list.<p> Self[i]:=Self[i]+list2[i]*factor

Public procedure GetExtents(out min, max: TAffineVector); dynamic;
Public procedure Lerp(const list1, list2: TBaseVectorList; lerpFactor: Single); dynamic; abstract;

Replace content of the list with lerp results between the two given lists.<p> Note: you can't Lerp with Self!!!

Public procedure Normalize; dynamic;
Public procedure ReadFromFiler(reader: TVirtualReader); override;
Public procedure Translate(const delta: TAffineVector); overload; dynamic;
Public procedure Translate(const delta: TBaseVectorList); overload; dynamic;
Public procedure TranslateInv(const delta: TBaseVectorList); overload; dynamic;
Public procedure WriteToFiler(writer: TVirtualWriter); override;

Properties

Public property ItemAddress[Index: Integer]: PFloatArray read GetItemAddress;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorLists: Class TAffineVectorList

Class TAffineVectorList

Unit

VectorLists

Declaration

type TAffineVectorList = class(TBaseVectorList)

Description

A list of TAffineVector.<p> Similar to TList, but using TAffineVector as items.<p> The list has stack-like push/pop methods.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseList
  • TBaseVectorList
  • TAffineVectorList

Overview

Methods

Public | constructor Create; override;
Public | function Add(const item: TTexPoint): Integer; overload;
Public | function Add(const item: TVector2f): Integer; overload;
Public | function Add(const xy: PIntegerArray; const Z: Integer): Integer; overload;
Public | function Add(const X, Y, Z: Single): Integer; overload;
Public | function Add(const X, Y: Single): Integer; overload;
Public | function Add(const X, Y, Z: Integer): Integer; overload;
Public | function Add(const item: TAffineVector): Integer; overload;
Public | function Add(const item: TVector): Integer; overload;
Public | function AddNC(const X, Y, Z: Integer): Integer; overload;
Public | function AddNC(const xy: PIntegerArray; const Z: Integer): Integer; overload;
Public | function FindOrAdd(const item: TAffineVector): Integer;
Public | function IndexOf(const item: TAffineVector): Integer;
Public | function Pop: TAffineVector;
Protected | function Get(Index: Integer): TAffineVector;
Public | procedure Add(const list: TAffineVectorList); overload;
Public | procedure Add(const i1, i2: TAffineVector); overload;
Public | procedure Add(const i1, i2, i3: TAffineVector); overload;
Public | procedure Assign(Src: TPersistent); override;
Public | procedure CombineItem(Index: Integer; const vector: TAffineVector; const f: Single);
Public | procedure Insert(Index: Integer; const item: TAffineVector);
Public | procedure Lerp(const list1, list2: TBaseVectorList; lerpFactor: Single); override;
Public | procedure Normalize; override;
Public | procedure Push(const Val: TAffineVector);
Public | procedure Scale(factor: Single); overload;
Public | procedure Scale(const factors: TAffineVector); overload;
Public | procedure TransformAsPoints(const matrix: TMatrix);
Public | procedure TransformAsVectors(const matrix: TMatrix); overload;
Public | procedure TransformAsVectors(const matrix: TAffineMatrix); overload;
Public | procedure Translate(const delta: TAffineVector); overload; override;
Public | procedure Translate(const delta: TAffineVector; base, nb: Integer); overload;
Public | procedure TranslateItem(Index: Integer; const delta: TAffineVector);
Public | procedure TranslateItems(Index: Integer; const delta: TAffineVector; nb: Integer);
Protected | procedure Put(Index: Integer; const item: TAffineVector);
Protected | procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public | property Items[Index: Integer]: TAffineVector read Get write Put;
Public | property List: PAffineVectorArray read FList;

Description

Methods

Public constructor Create; override;
Public function Add(const item: TTexPoint): Integer; overload;
Public function Add(const item: TVector2f): Integer; overload;
Public function Add(const xy: PIntegerArray; const Z: Integer): Integer; overload;
Public function Add(const X, Y, Z: Single): Integer; overload;
Public function Add(const X, Y: Single): Integer; overload;
Public function Add(const X, Y, Z: Integer): Integer; overload;
Public function Add(const item: TAffineVector): Integer; overload;
Public function Add(const item: TVector): Integer; overload;
Public function AddNC(const X, Y, Z: Integer): Integer; overload;
Public function AddNC(const xy: PIntegerArray; const Z: Integer): Integer; overload;
Public function FindOrAdd(const item: TAffineVector): Integer;
Public function IndexOf(const item: TAffineVector): Integer;
Public function Pop: TAffineVector;
Protected function Get(Index: Integer): TAffineVector;
Public procedure Add(const list: TAffineVectorList); overload;
Public procedure Add(const i1, i2: TAffineVector); overload;
Public procedure Add(const i1, i2, i3: TAffineVector); overload;
Public procedure Assign(Src: TPersistent); override;
Public procedure CombineItem(Index: Integer; const vector: TAffineVector; const f: Single);

Combines the given item

Public procedure Insert(Index: Integer; const item: TAffineVector);
Public procedure Lerp(const list1, list2: TBaseVectorList; lerpFactor: Single); override;
Public procedure Normalize; override;
Public procedure Push(const Val: TAffineVector);
Public procedure Scale(factor: Single); overload;
Public procedure Scale(const factors: TAffineVector); overload;
Public procedure TransformAsPoints(const matrix: TMatrix);

Transforms all items by the matrix as if they were points.<p> ie. the translation component of the matrix is honoured.

Public procedure TransformAsVectors(const matrix: TMatrix); overload;

Transforms all items by the matrix as if they were vectors.<p> ie. the translation component of the matrix is not honoured.

Public procedure TransformAsVectors(const matrix: TAffineMatrix); overload;
Public procedure Translate(const delta: TAffineVector); overload; override;
Public procedure Translate(const delta: TAffineVector; base, nb: Integer); overload;
Public procedure TranslateItem(Index: Integer; const delta: TAffineVector);

Translates the given item

Public procedure TranslateItems(Index: Integer; const delta: TAffineVector; nb: Integer);

Translates given items

Protected procedure Put(Index: Integer; const item: TAffineVector);
Protected procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public property Items[Index: Integer]: TAffineVector read Get write Put;
Public property List: PAffineVectorArray read FList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorLists: Class TVectorList

Class TVectorList

Unit

VectorLists

Declaration

type TVectorList = class(TBaseVectorList)

Description

A list of TVector.<p> Similar to TList, but using TVector as items.<p> The list has stack-like push/pop methods.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseList
  • TBaseVectorList
  • TVectorList

Overview

Methods

Public | constructor Create; override;
Public | function Add(const X, Y, Z, w: Single): Integer; overload;
Public | function Add(const item: TVector): Integer; overload;
Public | function Add(const item: TAffineVector; w: Single): Integer; overload;
Public | function AddPoint(const item: TAffineVector): Integer; overload;
Public | function AddPoint(const X, Y: Single; const Z: Single = 0): Integer; overload;
Public | function AddVector(const item: TAffineVector): Integer; overload;
Public | function FindOrAdd(const item: TVector): Integer;
Public | function FindOrAddPoint(const item: TAffineVector): Integer;
Public | function IndexOf(const item: TVector): Integer;
Public | function Pop: TVector;
Protected | function Get(Index: Integer): TVector;
Public | procedure Add(const i1, i2, i3: TAffineVector; w: Single); overload;
Public | procedure Assign(Src: TPersistent); override;
Public | procedure Insert(Index: Integer; const item: TVector);
Public | procedure Lerp(const list1, list2: TBaseVectorList; lerpFactor: Single); override;
Public | procedure Push(const Val: TVector);
Protected | procedure Put(Index: Integer; const item: TVector);
Protected | procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public | property Items[Index: Integer]: TVector read Get write Put;
Public | property List: PVectorArray read FList;

Description

Methods

Public constructor Create; override;
Public function Add(const X, Y, Z, w: Single): Integer; overload;
Public function Add(const item: TVector): Integer; overload;
Public function Add(const item: TAffineVector; w: Single): Integer; overload;
Public function AddPoint(const item: TAffineVector): Integer; overload;
Public function AddPoint(const X, Y: Single; const Z: Single = 0): Integer; overload;
Public function AddVector(const item: TAffineVector): Integer; overload;
Public function FindOrAdd(const item: TVector): Integer;
Public function FindOrAddPoint(const item: TAffineVector): Integer;
Public function IndexOf(const item: TVector): Integer;
Public function Pop: TVector;
Protected function Get(Index: Integer): TVector;
Public procedure Add(const i1, i2, i3: TAffineVector; w: Single); overload;
Public procedure Assign(Src: TPersistent); override;
Public procedure Insert(Index: Integer; const item: TVector);
Public procedure Lerp(const list1, list2: TBaseVectorList; lerpFactor: Single); override;
Public procedure Push(const Val: TVector);
Protected procedure Put(Index: Integer; const item: TVector);
Protected procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public property Items[Index: Integer]: TVector read Get write Put;
Public property List: PVectorArray read FList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorLists: Class TTexPointList

Class TTexPointList

Unit

VectorLists

Declaration

type TTexPointList = class(TBaseVectorList)

Description

A list of TTexPoint.<p> Similar to TList, but using TTexPoint as items.<p> The list has stack-like push/pop methods.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseList
  • TBaseVectorList
  • TTexPointList

Overview

Methods

Public | constructor Create; override;
Public | function Add(const item: TVector2f): Integer; overload;
Public | function Add(const item: TTexPoint): Integer; overload;
Public | function Add(const texST: PIntegerArray): Integer; overload;
Public | function Add(const texS, Text: Integer): Integer; overload;
Public | function Add(const texS, Text: Single): Integer; overload;
Public | function AddNC(const texS, Text: Integer): Integer; overload;
Public | function AddNC(const texST: PIntegerArray): Integer; overload;
Public | function FindOrAdd(const item: TTexpoint): Integer;
Public | function IndexOf(const item: TTexpoint): Integer;
Public | function Pop: TTexPoint;
Protected | function Get(Index: Integer): TTexPoint;
Public | procedure Assign(Src: TPersistent); override;
Public | procedure Insert(Index: Integer; const item: TTexPoint);
Public | procedure Lerp(const list1, list2: TBaseVectorList; lerpFactor: Single); override;
Public | procedure Push(const Val: TTexPoint);
Public | procedure ScaleAndTranslate(const scale, delta: TTexPoint); overload;
Public | procedure ScaleAndTranslate(const scale, delta: TTexPoint; base, nb: Integer); overload;
Public | procedure Translate(const delta: TTexPoint);
Protected | procedure Put(Index: Integer; const item: TTexPoint);
Protected | procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public | property Items[Index: Integer]: TTexPoint read Get write Put;
Public | property List: PTexPointArray read FList;

Description

Methods

Public constructor Create; override;
Public function Add(const item: TVector2f): Integer; overload;
Public function Add(const item: TTexPoint): Integer; overload;
Public function Add(const texST: PIntegerArray): Integer; overload;
Public function Add(const texS, Text: Integer): Integer; overload;
Public function Add(const texS, Text: Single): Integer; overload;
Public function AddNC(const texS, Text: Integer): Integer; overload;
Public function AddNC(const texST: PIntegerArray): Integer; overload;
Public function FindOrAdd(const item: TTexpoint): Integer;
Public function IndexOf(const item: TTexpoint): Integer;
Public function Pop: TTexPoint;
Protected function Get(Index: Integer): TTexPoint;
Public procedure Assign(Src: TPersistent); override;
Public procedure Insert(Index: Integer; const item: TTexPoint);
Public procedure Lerp(const list1, list2: TBaseVectorList; lerpFactor: Single); override;
Public procedure Push(const Val: TTexPoint);
Public procedure ScaleAndTranslate(const scale, delta: TTexPoint); overload;
Public procedure ScaleAndTranslate(const scale, delta: TTexPoint; base, nb: Integer); overload;
Public procedure Translate(const delta: TTexPoint);
Protected procedure Put(Index: Integer; const item: TTexPoint);
Protected procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public property Items[Index: Integer]: TTexPoint read Get write Put;
Public property List: PTexPointArray read FList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorLists: Class TIntegerList

Class TIntegerList

Unit

VectorLists

Declaration

type TIntegerList = class(TBaseList)

Description

A list of Integers.<p> Similar to TList, but using TTexPoint as items.<p> The list has stack-like push/pop methods.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseList
  • TIntegerList

Overview

Methods

Public | constructor Create; override;
Public | function Add(const item: Integer): Integer; overload;
Public | function AddNC(const item: Integer): Integer; overload;
Public | function AddSorted(const Value: Integer; const ignoreDuplicates: Boolean = False): Integer;
Public | function BinarySearch(const Value: Integer; returnBestFit: Boolean; var found: Boolean): Integer; overload;
Public | function BinarySearch(const Value: Integer): Integer; overload;
Public | function IndexOf(item: Integer): Integer;
Public | function MaxInteger: Integer;
Public | function MinInteger: Integer;
Public | function Pop: Integer;
Protected | function Get(Index: Integer): Integer;
Public | procedure Add(const i1, i2: Integer); overload;
Public | procedure Add(const i1, i2, i3: Integer); overload;
Public | procedure Add(const AList: TIntegerList); overload;
Public | procedure AddIntegers(const aList: TIntegerList); overload;
Public | procedure AddIntegers(const anArray: array of Integer); overload;
Public | procedure AddIntegers(const First: PInteger; n: Integer); overload;
Public | procedure AddSerie(aBase, aDelta, aCount: Integer);
Public | procedure Assign(src: TPersistent); override;
Public | procedure Insert(Index: Integer; const item: Integer);
Public | procedure Offset(delta: Integer; const base, nb: Integer); overload;
Public | procedure Offset(delta: Integer); overload;
Public | procedure Push(const Val: Integer);
Public | procedure Remove(const item: Integer);
Public | procedure RemoveSorted(const Value: Integer);
Public | procedure Sort;
Public | procedure SortAndRemoveDuplicates;
Protected | procedure Put(Index: Integer; const item: Integer);
Protected | procedure SetCapacity(newCapacity: Integer); override;

Properties

Public | property Items[Index: Integer]: Integer read Get write Put;
Public | property List: PIntegerArray read FList;

Description

Methods

Public constructor Create; override;
Public function Add(const item: Integer): Integer; overload;
Public function AddNC(const item: Integer): Integer; overload;
Public function AddSorted(const Value: Integer; const ignoreDuplicates: Boolean = False): Integer;

Add integer to a sorted list.<p> Maintains the list sorted. If you have to add "a lot" of integers at once, use the Add method then Sort the list for better performance.

Public function BinarySearch(const Value: Integer; returnBestFit: Boolean; var found: Boolean): Integer; overload;

Locate a value in a sorted list.<p> If ReturnBestFit is set to true, the routine will return the position of the largest value that's smaller than the sought value. Found will be set to True if the exact value was found, False if a "BestFit" was found.

Public function BinarySearch(const Value: Integer): Integer; overload;

Locate a value in a sorted list.

Public function IndexOf(item: Integer): Integer;
Public function MaxInteger: Integer;

Returns the maximum integer item, zero if list is empty.

Public function MinInteger: Integer;

Returns the minimum integer item, zero if list is empty.

Public function Pop: Integer;
Protected function Get(Index: Integer): Integer;
Public procedure Add(const i1, i2: Integer); overload;
Public procedure Add(const i1, i2, i3: Integer); overload;
Public procedure Add(const AList: TIntegerList); overload;
Public procedure AddIntegers(const aList: TIntegerList); overload;

Add all integers from aList into the list.

Public procedure AddIntegers(const anArray: array of Integer); overload;

Add all integers from anArray into the list.

Public procedure AddIntegers(const First: PInteger; n: Integer); overload;

Add n integers at the address starting at (and including) first.

Public procedure AddSerie(aBase, aDelta, aCount: Integer);

Adds count items in an arithmetic serie.<p> Items are (aBase), (aBase+aDelta) ... (aBase+(aCount-1)*aDelta)

Public procedure Assign(src: TPersistent); override;
Public procedure Insert(Index: Integer; const item: Integer);
Public procedure Offset(delta: Integer; const base, nb: Integer); overload;
Public procedure Offset(delta: Integer); overload;

Adds delta to all items in the list.

Public procedure Push(const Val: Integer);
Public procedure Remove(const item: Integer);
Public procedure RemoveSorted(const Value: Integer);

Removes an integer from a sorted list.<p>

Public procedure Sort;

Sort items in ascending order.

Public procedure SortAndRemoveDuplicates;

Sort items in ascending order and remove duplicated integers.

Protected procedure Put(Index: Integer; const item: Integer);
Protected procedure SetCapacity(newCapacity: Integer); override;

Properties

Public property Items[Index: Integer]: Integer read Get write Put;
Public property List: PIntegerArray read FList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorLists: Class TSingleList

Class TSingleList

Unit

VectorLists

Declaration

type TSingleList = class(TBaseList)

Description

A list of Single.<p> Similar to TList, but using Single as items.<p> The list has stack-like push/pop methods.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseList
  • TSingleList

Overview

Methods

Public | constructor Create; override;
Public | function Add(const item: Single): Integer; overload;
Public | function Max: Single;
Public | function Min: Single;
Public | function Pop: Single;
Public | function Sum: Single;
Protected | function Get(Index: Integer): Single;
Public | procedure Add(const i1, i2: Single); overload;
Public | procedure AddSerie(aBase, aDelta: Single; aCount: Integer);
Public | procedure AddSingles(const anArray: array of Single); overload;
Public | procedure AddSingles(const First: PSingle; n: Integer); overload;
Public | procedure Assign(Src: TPersistent); override;
Public | procedure Insert(Index: Integer; const item: Single);
Public | procedure Offset(const delta: TSingleList); overload;
Public | procedure Offset(delta: Single); overload;
Public | procedure Push(const Val: Single);
Public | procedure Scale(factor: Single);
Public | procedure Sqr;
Public | procedure Sqrt;
Protected | procedure Put(Index: Integer; const item: Single);
Protected | procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public | property Items[Index: Integer]: Single read Get write Put;
Public | property List: PSingleArrayList read FList;

Description

Methods

Public constructor Create; override;
Public function Add(const item: Single): Integer; overload;
Public function Max: Single;
Public function Min: Single;
Public function Pop: Single;
Public function Sum: Single;

Computes the sum of all elements.

Protected function Get(Index: Integer): Single;
Public procedure Add(const i1, i2: Single); overload;
Public procedure AddSerie(aBase, aDelta: Single; aCount: Integer);
Public procedure AddSingles(const anArray: array of Single); overload;
Public procedure AddSingles(const First: PSingle; n: Integer); overload;
Public procedure Assign(Src: TPersistent); override;
Public procedure Insert(Index: Integer; const item: Single);
Public procedure Offset(const delta: TSingleList); overload;

Adds to each item the corresponding item in the delta list.<p> Performs 'Items[i]:=Items[i]+delta[i]'.<br> If both lists don't have the same item count, an exception is raised.

Public procedure Offset(delta: Single); overload;

Adds delta to all items in the list.

Public procedure Push(const Val: Single);
Public procedure Scale(factor: Single);

Multiplies all items by factor.

Public procedure Sqr;

Square all items.

Public procedure Sqrt;

SquareRoot all items.

Protected procedure Put(Index: Integer; const item: Single);
Protected procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public property Items[Index: Integer]: Single read Get write Put;
Public property List: PSingleArrayList read FList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorLists: Class TDoubleList

Class TDoubleList

Unit

VectorLists

Declaration

type TDoubleList = class(TBaseList)

Description

A list of Double.<p> Similar to TList, but using Double as items.<p> The list has stack-like push/pop methods.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseList
  • TDoubleList

Overview

Methods

Public | constructor Create; override;
Public | function Add(const item: Double): Integer;
Public | function Max: Single;
Public | function Min: Single;
Public | function Pop: Double;
Public | function Sum: Double;
Protected | function Get(Index: Integer): Double;
Public | procedure AddSerie(aBase, aDelta: Double; aCount: Integer);
Public | procedure Assign(Src: TPersistent); override;
Public | procedure Insert(Index: Integer; const item: Double);
Public | procedure Offset(const delta: TDoubleList); overload;
Public | procedure Offset(delta: Double); overload;
Public | procedure Push(const Val: Double);
Public | procedure Scale(factor: Double);
Public | procedure Sqr;
Public | procedure Sqrt;
Protected | procedure Put(Index: Integer; const item: Double);
Protected | procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public | property Items[Index: Integer]: Double read Get write Put;
Public | property List: PDoubleArrayList read FList;

Description

Methods

Public constructor Create; override;
Public function Add(const item: Double): Integer;
Public function Max: Single;
Public function Min: Single;
Public function Pop: Double;
Public function Sum: Double;

Computes the sum of all elements.

Protected function Get(Index: Integer): Double;
Public procedure AddSerie(aBase, aDelta: Double; aCount: Integer);
Public procedure Assign(Src: TPersistent); override;
Public procedure Insert(Index: Integer; const item: Double);
Public procedure Offset(const delta: TDoubleList); overload;

Adds to each item the corresponding item in the delta list.<p> Performs 'Items[i]:=Items[i]+delta[i]'.<br> If both lists don't have the same item count, an exception is raised.

Public procedure Offset(delta: Double); overload;

Adds delta to all items in the list.

Public procedure Push(const Val: Double);
Public procedure Scale(factor: Double);

Multiplies all items by factor.

Public procedure Sqr;

Square all items.

Public procedure Sqrt;

SquareRoot all items.

Protected procedure Put(Index: Integer; const item: Double);
Protected procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public property Items[Index: Integer]: Double read Get write Put;
Public property List: PDoubleArrayList read FList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorLists: Class TByteList

Class TByteList

Unit

VectorLists

Declaration

type TByteList = class(TBaseList)

Description

A list of bytes.<p> Similar to TList, but using Byte as items.<p>

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseList
  • TByteList

Overview

Methods

Public | constructor Create; override;
Public | function Add(const item: Byte): Integer;
Protected | function Get(Index: Integer): Byte;
Public | procedure Assign(Src: TPersistent); override;
Public | procedure Insert(Index: Integer; const item: Byte);
Protected | procedure Put(Index: Integer; const item: Byte);
Protected | procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public | property Items[Index: Integer]: Byte read Get write Put;
Public | property List: PByteArray read FList;

Description

Methods

Public constructor Create; override;
Public function Add(const item: Byte): Integer;
Protected function Get(Index: Integer): Byte;
Public procedure Assign(Src: TPersistent); override;
Public procedure Insert(Index: Integer; const item: Byte);
Protected procedure Put(Index: Integer; const item: Byte);
Protected procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public property Items[Index: Integer]: Byte read Get write Put;
Public property List: PByteArray read FList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorLists: Class TQuaternionList

Class TQuaternionList

Unit

VectorLists

Declaration

type TQuaternionList = class(TBaseVectorList)

Description

A list of TQuaternion.<p> Similar to TList, but using TQuaternion as items.<p> The list has stack-like push/pop methods.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseList
  • TBaseVectorList
  • TQuaternionList

Overview

Methods

Public | constructor Create; override;
Public | function Add(const item: TQuaternion): Integer; overload;
Public | function Add(const X, Y, Z, W: Single): Integer; overload;
Public | function Add(const item: TAffineVector; w: Single): Integer; overload;
Public | function FindOrAdd(const item: TQuaternion): Integer;
Public | function IndexOf(const item: TQuaternion): Integer;
Public | function Pop: TQuaternion;
Protected | function Get(Index: Integer): TQuaternion;
Public | procedure Assign(Src: TPersistent); override;
Public | procedure Combine(const list2: TBaseVectorList; factor: Single); override;
Public | procedure Insert(Index: Integer; const item: TQuaternion);
Public | procedure Lerp(const list1, list2: TBaseVectorList; lerpFactor: Single); override;
Public | procedure Push(const Val: TQuaternion);
Protected | procedure Put(Index: Integer; const item: TQuaternion);
Protected | procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public | property Items[Index: Integer]: TQuaternion read Get write Put;
Public | property List: PQuaternionArray read FList;

Description

Methods

Public constructor Create; override;
Public function Add(const item: TQuaternion): Integer; overload;
Public function Add(const X, Y, Z, W: Single): Integer; overload;
Public function Add(const item: TAffineVector; w: Single): Integer; overload;
Public function FindOrAdd(const item: TQuaternion): Integer;
Public function IndexOf(const item: TQuaternion): Integer;
Public function Pop: TQuaternion;
Protected function Get(Index: Integer): TQuaternion;
Public procedure Assign(Src: TPersistent); override;
Public procedure Combine(const list2: TBaseVectorList; factor: Single); override;

Multiplies corresponding quaternions after the second quaternion is slerped with the IdentityQuaternion using factor. This allows for weighted combining of rotation transforms using quaternions.

Public procedure Insert(Index: Integer; const item: TQuaternion);
Public procedure Lerp(const list1, list2: TBaseVectorList; lerpFactor: Single); override;

Lerps corresponding quaternions from both lists using QuaternionSlerp.

Public procedure Push(const Val: TQuaternion);
Protected procedure Put(Index: Integer; const item: TQuaternion);
Protected procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public property Items[Index: Integer]: TQuaternion read Get write Put;
Public property List: PQuaternionArray read FList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorLists: packed record T4ByteData

packed record T4ByteData

Unit

VectorLists

Declaration

type T4ByteData = packed record

Description

Overview

Fields

Bytes: record
Int: record
UInt: record
Float: record
Word: record

Description

Fields

Bytes: record
Int: record
UInt: record
Float: record
Word: record
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorLists: Class T4ByteList

Class T4ByteList

Unit

VectorLists

Declaration

type T4ByteList = class(TBaseList)

Description

A list of T4ByteData.<p>

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseList
  • T4ByteList

Overview

Methods

Public | constructor Create; override;
Public | function Add(const item: T4ByteData): Integer; overload;
Public | function Pop: T4ByteData;
Protected | function Get(Index: Integer): T4ByteData;
Public | procedure Add(const i1: Cardinal); overload;
Public | procedure Add(const i1, i2, i3: Integer); overload;
Public | procedure Add(const i1, i2, i3, i4: Integer); overload;
Public | procedure Add(const i1, i2: Cardinal); overload;
Public | procedure Add(const AList: T4ByteList); overload;
Public | procedure Add(const i1, i2, i3, i4: Cardinal); overload;
Public | procedure Add(const i1, i2, i3: Cardinal); overload;
Public | procedure Add(const i1, i2: Integer); overload;
Public | procedure Add(const i1, i2: Single); overload;
Public | procedure Add(const i1: Single); overload;
Public | procedure Add(const i1, i2, i3: Single); overload;
Public | procedure Add(const i1: Integer); overload;
Public | procedure Add(const i1, i2, i3, i4: Single); overload;
Public | procedure Assign(Src: TPersistent); override;
Public | procedure Insert(Index: Integer; const item: T4ByteData);
Public | procedure Push(const Val: T4ByteData);
Protected | procedure Put(Index: Integer; const item: T4ByteData);
Protected | procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public | property Items[Index: Integer]: T4ByteData read Get write Put;
Public | property List: P4ByteArrayList read FList;

Description

Methods

Public constructor Create; override;
Public function Add(const item: T4ByteData): Integer; overload;
Public function Pop: T4ByteData;
Protected function Get(Index: Integer): T4ByteData;
Public procedure Add(const i1: Cardinal); overload;
Public procedure Add(const i1, i2, i3: Integer); overload;
Public procedure Add(const i1, i2, i3, i4: Integer); overload;
Public procedure Add(const i1, i2: Cardinal); overload;
Public procedure Add(const AList: T4ByteList); overload;
Public procedure Add(const i1, i2, i3, i4: Cardinal); overload;
Public procedure Add(const i1, i2, i3: Cardinal); overload;
Public procedure Add(const i1, i2: Integer); overload;
Public procedure Add(const i1, i2: Single); overload;
Public procedure Add(const i1: Single); overload;
Public procedure Add(const i1, i2, i3: Single); overload;
Public procedure Add(const i1: Integer); overload;
Public procedure Add(const i1, i2, i3, i4: Single); overload;
Public procedure Assign(Src: TPersistent); override;
Public procedure Insert(Index: Integer; const item: T4ByteData);
Public procedure Push(const Val: T4ByteData);
Protected procedure Put(Index: Integer; const item: T4ByteData);
Protected procedure SetCapacity(NewCapacity: Integer); override;

Properties

Public property Items[Index: Integer]: T4ByteData read Get write Put;
Public property List: P4ByteArrayList read FList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorLists: Class TLongWordList

Class TLongWordList

Unit

VectorLists

Declaration

type TLongWordList = class(TBaseList)

Description

no description available, TBaseList description follows

Base class for lists, introduces common behaviours.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TBaseList
  • TLongWordList

Overview

Methods

Public | constructor Create; override;
Public | function Add(const item: LongWord): Integer; overload;
Public | function AddNC(const item: LongWord): Integer; overload;
Public | function IndexOf(item: Integer): LongWord;
Public | function Pop: LongWord;
Protected | function Get(Index: Integer): LongWord;
Public | procedure Add(const i1, i2, i3: LongWord); overload;
Public | procedure Add(const AList: TLongWordList); overload;
Public | procedure Add(const i1, i2: LongWord); overload;
Public | procedure AddLongWords(const aList: TLongWordList); overload;
Public | procedure AddLongWords(const First: PLongWord; n: Integer); overload;
Public | procedure AddLongWords(const anArray: array of LongWord); overload;
Public | procedure Assign(src: TPersistent); override;
Public | procedure Insert(Index: Integer; const item: LongWord);
Public | procedure Push(const Val: LongWord);
Public | procedure Remove(const item: LongWord);
Protected | procedure Put(Index: Integer; const item: LongWord);
Protected | procedure SetCapacity(newCapacity: Integer); override;

Properties

Public | property Items[Index: Integer]: LongWord read Get write Put;
Public | property List: PLongWordArray read FList;

Description

Methods

Public constructor Create; override;
Public function Add(const item: LongWord): Integer; overload;
Public function AddNC(const item: LongWord): Integer; overload;
Public function IndexOf(item: Integer): LongWord;
Public function Pop: LongWord;
Protected function Get(Index: Integer): LongWord;
Public procedure Add(const i1, i2, i3: LongWord); overload;
Public procedure Add(const AList: TLongWordList); overload;
Public procedure Add(const i1, i2: LongWord); overload;
Public procedure AddLongWords(const aList: TLongWordList); overload;

Add all integers from aList into the list.

Public procedure AddLongWords(const First: PLongWord; n: Integer); overload;

Add n integers at the address starting at (and including) first.

Public procedure AddLongWords(const anArray: array of LongWord); overload;

Add all integers from anArray into the list.

Public procedure Assign(src: TPersistent); override;
Public procedure Insert(Index: Integer; const item: LongWord);
Public procedure Push(const Val: LongWord);
Public procedure Remove(const item: LongWord);
Protected procedure Put(Index: Integer; const item: LongWord);
Protected procedure SetCapacity(newCapacity: Integer); override;

Properties

Public property Items[Index: Integer]: LongWord read Get write Put;
Public property List: PLongWordArray read FList;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorTypes

Unit VectorTypes

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

VectorTypes<p>

Defines base vector types for use in Geometry.pas and OpenGL1x.pas.<p>

The sole aim of this unit is to limit dependency between the Geometry and OpenGL1x units by introducing the base compatibility types (and only the *base* types).<p>

Conventions:<ul> <li><b>d</b> is used for Double precision floating points values (64 bits) <li><b>f</b> is used for Single precision floating points values (32 bits) <li><b>i</b> is used for 32 bits signed integers (longint) <li><b>s</b> is uses for 16 bits signed integers (smallint) </ul>

Note : D3D types untested.<p>

<b>History : </b><font size=-1><ul> <li>18/12/12 - PW - Restored CPP compatibility: changed arrays to records <li>21/02/11 - Yar - Added half and signed byte vectors <li>03/03/07 - DaStr - Added TMatrix2[d/d/i/s/b/e/w/p] types <li>13/01/07 - DaStr - Added T[Matrix/Vector][2/3/4][e/w/p] types <li>19/12/04 - PhP - Added byte vectors <li>02/08/04 - LR, YHC - BCB corrections: use record instead array move PAffineVectorArray, PVectorArray and PMatrixArray from VectorGeometry to this Unit <li>28/06/04 - LR - Removed ..\ from the GLScene.inc <li>24/08/03 - PhP - Added smallint vectors <li>04/07/01 - EG - Creation </ul>

Overview

Classes, Interfaces, Objects and Records

Name | Description
record TVector2d |
record TVector2f |
record TVector2h |
record TVector2i |
record TVector2ui |
record TVector2s |
record TVector2b |
record TVector2sb |
record TVector2e |
record TVector2w |
record TVector2p |
record TVector3d |
record TVector3f |
record TVector3h |
record TVector3i |
record TVector3ui |
record TVector3s |
record TVector3b |
record TVector3sb |
record TVector3e |
record TVector3w |
record TVector3p |
record TVector4d |
record TVector4f |
record TVector4h |
record TVector4i |
record TVector4ui |
record TVector4s |
record TVector4b |
record TVector4sb |
record TVector4e |
record TVector4w |
record TVector4p |
record TMatrix2d |
record TMatrix2f |
record TMatrix2i |
record TMatrix2s |
record TMatrix2b |
record TMatrix2e |
record TMatrix2w |
record TMatrix2p |
record TMatrix3d |
record TMatrix3f |
record TMatrix3i |
record TMatrix3s |
record TMatrix3b |
record TMatrix3e |
record TMatrix3w |
record TMatrix3p |
record TMatrix4d |
record TMatrix4f |
record TMatrix4i |
record TMatrix4s |
record TMatrix4b |
record TMatrix4e |
record TMatrix4w |
record TMatrix4p |
packed record TD3DVector |
packed record TD3DMatrix |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorTypes: record TVector2d

record TVector2d

Unit

VectorTypes

Declaration

type TVector2d = record

Description

Overview

Fields

V: array[0..1] of double
X: double;
Y: double

Description

Fields

V: array[0..1] of double
X: double;
Y: double
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorTypes: record TVector2f

record TVector2f

Unit

VectorTypes

Declaration

type TVector2f = record

Description

Overview

Fields

V: array[0..1] of single
X: single
Y: single

Description

Fields

V: array[0..1] of single
X: single
Y: single
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorTypes: record TVector2h

record TVector2h

Unit

VectorTypes

Declaration

type TVector2h = record

Description

Overview

Fields

V: array[0..1] of THalfFloat
X: THalfFloat
Y: THalfFloat

Description

Fields

V: array[0..1] of THalfFloat
X: THalfFloat
Y: THalfFloat
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorTypes: record TVector2i

record TVector2i

Unit

VectorTypes

Declaration

type TVector2i = record

Description

Overview

Fields

V: array[0..1] of longint
X: longint
Y: longint

Description

Fields

V: array[0..1] of longint
X: longint
Y: longint
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorTypes: record TVector2ui

record TVector2ui

Unit

VectorTypes

Declaration

type TVector2ui = record

Description

Overview

Fields

V: array[0..1] of longword
X: longword
Y: longword

Description

Fields

V: array[0..1] of longword
X: longword
Y: longword
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorTypes: record TVector2s

record TVector2s

Unit

VectorTypes

Declaration

type TVector2s = record

Description

Overview

Fields

V: array[0..1] of smallint
X: smallint
Y: smallint

Description

Fields

V: array[0..1] of smallint
X: smallint
Y: smallint
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorTypes: record TVector2b

record TVector2b

Unit

VectorTypes

Declaration

type TVector2b = record

Description

Overview

Fields

V: array[0..1] of byte
X: byte
Y: byte

Description

Fields

V: array[0..1] of byte
X: byte
Y: byte
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorTypes: record TVector2sb

record TVector2sb

Unit

VectorTypes

Declaration

type TVector2sb = record

Description

Overview

Fields

V: array[0..1] of ShortInt
X: ShortInt
Y: ShortInt

Description

Fields

V: array[0..1] of ShortInt
X: ShortInt
Y: ShortInt
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorTypes: record TVector2e

record TVector2e

Unit

VectorTypes

Declaration

type TVector2e = record

Description

Overview

Fields

V: array[0..1] of Extended
X: Extended
Y: Extended

Description

Fields

V: array[0..1] of Extended
X: Extended
Y: Extended
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorTypes: record TVector2w

record TVector2w

Unit

VectorTypes

Declaration

type TVector2w = record

Description

Overview

Fields

V: array[0..1] of Word
X: Word
Y: Word

Description

Fields

V: array[0..1] of Word
X: Word
Y: Word
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorTypes: record TVector2p

record TVector2p

Unit

VectorTypes

Declaration

type TVector2p = record

Description

Overview

Fields

V: array[0..1] of Pointer
X: Pointer
Y: Pointer

Description

Fields

V: array[0..1] of Pointer
X: Pointer
Y: Pointer
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorTypes: record TVector3d

record TVector3d

Unit

VectorTypes

Declaration

type TVector3d = record

Description

Overview

Fields

V: array[0..2] of double
X: double
Y: double
Z: double

Description

Fields

V: array[0..2] of double
X: double
Y: double
Z: double
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:44


GLScene v.1.1.2: VectorTypes: record TVector3f

record TVector3f

Unit

VectorTypes

Declaration

type TVector3f = record

Description

Overview

Fields

V: array[0..2] of single
X: single
Y: single
Z: single

Description

Fields

V: array[0..2] of single
X: single
Y: single
Z: single
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector3h

record TVector3h

Unit

VectorTypes

Declaration

type TVector3h = record

Description

Overview

Fields

V: array[0..2] of THalfFloat
X: THalfFloat
Y: THalfFloat
Z: THalfFloat

Description

Fields

V: array[0..2] of THalfFloat
X: THalfFloat
Y: THalfFloat
Z: THalfFloat
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector3i

record TVector3i

Unit

VectorTypes

Declaration

type TVector3i = record

Description

Overview

Fields

V: array[0..2] of longint
X: longint
Y: longint
Z: longint

Description

Fields

V: array[0..2] of longint
X: longint
Y: longint
Z: longint
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector3ui

record TVector3ui

Unit

VectorTypes

Declaration

type TVector3ui = record

Description

Overview

Fields

V: array[0..2] of Longword
X: Longword
Y: Longword
Z: Longword

Description

Fields

V: array[0..2] of Longword
X: Longword
Y: Longword
Z: Longword
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector3s

record TVector3s

Unit

VectorTypes

Declaration

type TVector3s = record

Description

Overview

Fields

V: array[0..2] of smallint
X: smallint
Y: smallint
Z: smallint

Description

Fields

V: array[0..2] of smallint
X: smallint
Y: smallint
Z: smallint
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector3b

record TVector3b

Unit

VectorTypes

Declaration

type TVector3b = record

Description

Overview

Fields

V: array[0..2] of byte
X: byte
Y: byte
Z: byte

Description

Fields

V: array[0..2] of byte
X: byte
Y: byte
Z: byte
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector3sb

record TVector3sb

Unit

VectorTypes

Declaration

type TVector3sb = record

Description

Overview

Fields

V: array[0..2] of ShortInt
X: ShortInt
Y: ShortInt
Z: ShortInt

Description

Fields

V: array[0..2] of ShortInt
X: ShortInt
Y: ShortInt
Z: ShortInt
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector3e

record TVector3e

Unit

VectorTypes

Declaration

type TVector3e = record

Description

Overview

Fields

V: array[0..2] of Extended
X: Extended
Y: Extended
Z: Extended

Description

Fields

V: array[0..2] of Extended
X: Extended
Y: Extended
Z: Extended
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector3w

record TVector3w

Unit

VectorTypes

Declaration

type TVector3w = record

Description

Overview

Fields

V: array[0..2] of Word
X: Word
Y: Word
Z: Word

Description

Fields

V: array[0..2] of Word
X: Word
Y: Word
Z: Word
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector3p

record TVector3p

Unit

VectorTypes

Declaration

type TVector3p = record

Description

Overview

Fields

V: array[0..2] of Pointer
X: Pointer
Y: Pointer
Z: Pointer

Description

Fields

V: array[0..2] of Pointer
X: Pointer
Y: Pointer
Z: Pointer
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector4d

record TVector4d

Unit

VectorTypes

Declaration

type TVector4d = record

Description

Overview

Fields

V: array[0..3] of double
X: double
Y: double
Z: double
W: double

Description

Fields

V: array[0..3] of double
X: double
Y: double
Z: double
W: double
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector4f

record TVector4f

Unit

VectorTypes

Declaration

type TVector4f = record

Description

Overview

Fields

V: array[0..3] of single
X: single
Y: single
Z: single
W: single

Description

Fields

V: array[0..3] of single
X: single
Y: single
Z: single
W: single
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector4h

record TVector4h

Unit

VectorTypes

Declaration

type TVector4h = record

Description

Overview

Fields

V: array[0..3] of THalfFloat
X: THalfFloat
Y: THalfFloat
Z: THalfFloat
W: THalfFloat

Description

Fields

V: array[0..3] of THalfFloat
X: THalfFloat
Y: THalfFloat
Z: THalfFloat
W: THalfFloat
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector4i

record TVector4i

Unit

VectorTypes

Declaration

type TVector4i = record

Description

Overview

Fields

V: array[0..3] of LongInt
X: longint
Y: longint
Z: longint
W: longint

Description

Fields

V: array[0..3] of LongInt
X: longint
Y: longint
Z: longint
W: longint
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector4ui

record TVector4ui

Unit

VectorTypes

Declaration

type TVector4ui = record

Description

Overview

Fields

V: array[0..3] of LongWord
X: LongWord
Y: LongWord
Z: LongWord
W: LongWord

Description

Fields

V: array[0..3] of LongWord
X: LongWord
Y: LongWord
Z: LongWord
W: LongWord
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector4s

record TVector4s

Unit

VectorTypes

Declaration

type TVector4s = record

Description

Overview

Fields

V: array[0..3] of SmallInt
X: SmallInt
Y: SmallInt
Z: SmallInt
W: SmallInt

Description

Fields

V: array[0..3] of SmallInt
X: SmallInt
Y: SmallInt
Z: SmallInt
W: SmallInt
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector4b

record TVector4b

Unit

VectorTypes

Declaration

type TVector4b = record

Description

Overview

Fields

V: array[0..3] of Byte
X: byte
Y: byte
Z: byte
W: byte

Description

Fields

V: array[0..3] of Byte
X: byte
Y: byte
Z: byte
W: byte
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector4sb

record TVector4sb

Unit

VectorTypes

Declaration

type TVector4sb = record

Description

Overview

Fields

V: array[0..3] of ShortInt
X: ShortInt
Y: ShortInt
Z: ShortInt
W: ShortInt

Description

Fields

V: array[0..3] of ShortInt
X: ShortInt
Y: ShortInt
Z: ShortInt
W: ShortInt
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector4e

record TVector4e

Unit

VectorTypes

Declaration

type TVector4e = record

Description

Overview

Fields

V: array[0..3] of Extended
X: Extended
Y: Extended
Z: Extended
W: Extended

Description

Fields

V: array[0..3] of Extended
X: Extended
Y: Extended
Z: Extended
W: Extended
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector4w

record TVector4w

Unit

VectorTypes

Declaration

type TVector4w = record

Description

Overview

Fields

V: array[0..3] of Word
X: Word
Y: Word
Z: Word
W: Word

Description

Fields

V: array[0..3] of Word
X: Word
Y: Word
Z: Word
W: Word
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TVector4p

record TVector4p

Unit

VectorTypes

Declaration

type TVector4p = record

Description

Overview

Fields

V: array[0..3] of Pointer
X: Pointer
Y: Pointer
Z: Pointer
W: Pointer

Description

Fields

V: array[0..3] of Pointer
X: Pointer
Y: Pointer
Z: Pointer
W: Pointer
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix2d

record TMatrix2d

Unit

VectorTypes

Declaration

type TMatrix2d = record

Description

Overview

Fields

V: array[0..1] of TVector2d
X: TVector2d
Y: TVector2d

Description

Fields

V: array[0..1] of TVector2d
X: TVector2d
Y: TVector2d
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix2f

record TMatrix2f

Unit

VectorTypes

Declaration

type TMatrix2f = record

Description

Overview

Fields

V: array[0..1] of TVector2f
X: TVector2f
Y: TVector2f

Description

Fields

V: array[0..1] of TVector2f
X: TVector2f
Y: TVector2f
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix2i

record TMatrix2i

Unit

VectorTypes

Declaration

type TMatrix2i = record

Description

Overview

Fields

V: array[0..1] of TVector2i
X: TVector2i
Y: TVector2i

Description

Fields

V: array[0..1] of TVector2i
X: TVector2i
Y: TVector2i
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix2s

record TMatrix2s

Unit

VectorTypes

Declaration

type TMatrix2s = record

Description

Overview

Fields

V: array[0..1] of TVector2s
X: TVector2s
Y: TVector2s

Description

Fields

V: array[0..1] of TVector2s
X: TVector2s
Y: TVector2s
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix2b

record TMatrix2b

Unit

VectorTypes

Declaration

type TMatrix2b = record

Description

Overview

Fields

V: array[0..1] of TVector2b
X: TVector2b
Y: TVector2b

Description

Fields

V: array[0..1] of TVector2b
X: TVector2b
Y: TVector2b
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix2e

record TMatrix2e

Unit

VectorTypes

Declaration

type TMatrix2e = record

Description

Overview

Fields

V: array[0..1] of TVector2e
X: TVector2e
Y: TVector2e

Description

Fields

V: array[0..1] of TVector2e
X: TVector2e
Y: TVector2e
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix2w

record TMatrix2w

Unit

VectorTypes

Declaration

type TMatrix2w = record

Description

Overview

Fields

V: array[0..1] of TVector2w
X: TVector2w
Y: TVector2w

Description

Fields

V: array[0..1] of TVector2w
X: TVector2w
Y: TVector2w
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix2p

record TMatrix2p

Unit

VectorTypes

Declaration

type TMatrix2p = record

Description

Overview

Fields

V: array[0..1] of TVector2p
X: TVector2p
Y: TVector2p

Description

Fields

V: array[0..1] of TVector2p
X: TVector2p
Y: TVector2p
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix3d

record TMatrix3d

Unit

VectorTypes

Declaration

type TMatrix3d = record

Description

Overview

Fields

V: array[0..2] of TVector3d
X: TVector3d
Y: TVector3d
Z: TVector3d

Description

Fields

V: array[0..2] of TVector3d
X: TVector3d
Y: TVector3d
Z: TVector3d
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix3f

record TMatrix3f

Unit

VectorTypes

Declaration

type TMatrix3f = record

Description

Overview

Fields

V: array[0..2] of TVector3f
X: TVector3f
Y: TVector3f
Z: TVector3f

Description

Fields

V: array[0..2] of TVector3f
X: TVector3f
Y: TVector3f
Z: TVector3f
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix3i

record TMatrix3i

Unit

VectorTypes

Declaration

type TMatrix3i = record

Description

Overview

Fields

V: array[0..2] of TVector3i
X: TVector3i
Y: TVector3i
Z: TVector3i

Description

Fields

V: array[0..2] of TVector3i
X: TVector3i
Y: TVector3i
Z: TVector3i
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix3s

record TMatrix3s

Unit

VectorTypes

Declaration

type TMatrix3s = record

Description

Overview

Fields

V: array[0..2] of TVector3s
X: TVector3s
Y: TVector3s
Z: TVector3s

Description

Fields

V: array[0..2] of TVector3s
X: TVector3s
Y: TVector3s
Z: TVector3s
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix3b

record TMatrix3b

Unit

VectorTypes

Declaration

type TMatrix3b = record

Description

Overview

Fields

V: array[0..2] of TVector3b
X: TVector3b
Y: TVector3b
Z: TVector3b

Description

Fields

V: array[0..2] of TVector3b
X: TVector3b
Y: TVector3b
Z: TVector3b
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix3e

record TMatrix3e

Unit

VectorTypes

Declaration

type TMatrix3e = record

Description

Overview

Fields

V: array[0..2] of TVector3e
X: TVector3e
Y: TVector3e
Z: TVector3e

Description

Fields

V: array[0..2] of TVector3e
X: TVector3e
Y: TVector3e
Z: TVector3e
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix3w

record TMatrix3w

Unit

VectorTypes

Declaration

type TMatrix3w = record

Description

Overview

Fields

V: array[0..2] of TVector3w
X: TVector3w
Y: TVector3w
Z: TVector3w

Description

Fields

V: array[0..2] of TVector3w
X: TVector3w
Y: TVector3w
Z: TVector3w
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix3p

record TMatrix3p

Unit

VectorTypes

Declaration

type TMatrix3p = record

Description

Overview

Fields

V: array[0..2] of TVector3p
X: TVector3p
Y: TVector3p
Z: TVector3p

Description

Fields

V: array[0..2] of TVector3p
X: TVector3p
Y: TVector3p
Z: TVector3p
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix4d

record TMatrix4d

Unit

VectorTypes

Declaration

type TMatrix4d = record

Description

Overview

Fields

V: array[0..3] of TVector4d
X: TVector4d
Y: TVector4d
Z: TVector4d
W: TVector4d

Description

Fields

V: array[0..3] of TVector4d
X: TVector4d
Y: TVector4d
Z: TVector4d
W: TVector4d
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix4f

record TMatrix4f

Unit

VectorTypes

Declaration

type TMatrix4f = record

Description

Overview

Fields

V: array[0..3] of TVector4f
X: TVector4f
Y: TVector4f
Z: TVector4f
W: TVector4f

Description

Fields

V: array[0..3] of TVector4f
X: TVector4f
Y: TVector4f
Z: TVector4f
W: TVector4f
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix4i

record TMatrix4i

Unit

VectorTypes

Declaration

type TMatrix4i = record

Description

Overview

Fields

V: array[0..3] of TVector4i
X: TVector4i
Y: TVector4i
Z: TVector4i
W: TVector4i

Description

Fields

V: array[0..3] of TVector4i
X: TVector4i
Y: TVector4i
Z: TVector4i
W: TVector4i
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix4s

record TMatrix4s

Unit

VectorTypes

Declaration

type TMatrix4s = record

Description

Overview

Fields

V: array[0..3] of TVector4s
X: TVector4s
Y: TVector4s
Z: TVector4s
W: TVector4s

Description

Fields

V: array[0..3] of TVector4s
X: TVector4s
Y: TVector4s
Z: TVector4s
W: TVector4s
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix4b

record TMatrix4b

Unit

VectorTypes

Declaration

type TMatrix4b = record

Description

Overview

Fields

V: array[0..3] of TVector4b
X: TVector4b
Y: TVector4b
Z: TVector4b
W: TVector4b

Description

Fields

V: array[0..3] of TVector4b
X: TVector4b
Y: TVector4b
Z: TVector4b
W: TVector4b
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix4e

record TMatrix4e

Unit

VectorTypes

Declaration

type TMatrix4e = record

Description

Overview

Fields

V: array[0..3] of TVector4e
X: TVector4e
Y: TVector4e
Z: TVector4e
W: TVector4e

Description

Fields

V: array[0..3] of TVector4e
X: TVector4e
Y: TVector4e
Z: TVector4e
W: TVector4e
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix4w

record TMatrix4w

Unit

VectorTypes

Declaration

type TMatrix4w = record

Description

Overview

Fields

V: array[0..3] of TVector4w
X: TVector4w
Y: TVector4w
Z: TVector4w
W: TVector4w

Description

Fields

V: array[0..3] of TVector4w
X: TVector4w
Y: TVector4w
Z: TVector4w
W: TVector4w
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: record TMatrix4p

record TMatrix4p

Unit

VectorTypes

Declaration

type TMatrix4p = record

Description

Overview

Fields

V: array[0..3] of TVector4p
X: TVector4p
Y: TVector4p
Z: TVector4p
W: TVector4p

Description

Fields

V: array[0..3] of TVector4p
X: TVector4p
Y: TVector4p
Z: TVector4p
W: TVector4p
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: packed record TD3DVector

packed record TD3DVector

Unit

VectorTypes

Declaration

type TD3DVector = packed record

Description

Overview

Fields

X: single;
Y: single;
Z: single
V: TVector3f

Description

Fields

X: single;
Y: single;
Z: single
V: TVector3f
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VectorTypes: packed record TD3DMatrix

packed record TD3DMatrix

Unit

VectorTypes

Declaration

type TD3DMatrix = packed record

Description

Overview

Fields

_11: single;
_12: single;
_13: single;
_14: single;
_21: single;
_22: single;
_23: single;
_24: single;
_31: single;
_32: single;
_33: single;
_34: single;
_41: single
_42: single
_43: single
_44: single
M: TMatrix4f

Description

Fields

_11: single;
_12: single;
_13: single;
_14: single;
_21: single;
_22: single;
_23: single;
_24: single;
_31: single;
_32: single;
_33: single;
_34: single;
_41: single
_42: single
_43: single
_44: single
M: TMatrix4f
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses

Unit VerletClasses

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

VerletClasses<p>

Base Verlet modelling/simulation classes.<p> This unit is generic, GLScene-specific sub-classes are in GLVerletClasses.<p>

Note that currently, the SatisfyConstraintForEdge methods push the nodes in the edge uniformly - it should push the closer node more for correct physics. It's a matter of leverage. <p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPP compatibility: changed vector arrays to records <li>25/11/09 - DanB - Fix for TVerletGlobalConstraint.TranslateKickbackTorque <li>31/03/07 - DaStr - Added $I GLScene.inc <li>14/04/04 - MF - Fixed force for springs, was referring to deltaP... <li>13/04/04 - MF - Minor drag changes <li>13/04/04 - EG - Added TVCHeightField and TVCSlider, fixed TVCFloor and TVFSpring, altered the way world Drag operates <li>06/03/04 - MF - Small updates to accomodate hair <li>11/07/03 - EG - Optimized TVCCube collider <li>11/07/03 - MF - A bit of a documentation effort <li>10/07/03 - MF - Verlets now use spatial partitioning objects to speed up space queries <li>10/07/03 - MF - Renaming TVerletAssembly to TVerletWorld <li>24/06/03 - MF - Added force kickbacks for integration with external physics. Needs to be split into force+torque and add friction to the kickback <li>19/06/03 - MF - Added TVerletGlobalConstraint.SatisfyConstraintForEdge and implemented for TVCSphere and TVCCapsule <li>19/06/03 - MF - Added friction to TVCCylinder <li>19/06/03 - MF - Added surface normals to all colliders - surface normal is identical to Normalize(Movement)! <li>18/06/03 - MF - Moved FrictionRatio to TVerletGlobalFrictionConstraint <li>18/06/03 - EG - Updated TVCCapsule <li>18/06/03 - MF - Updated TVCFloor to use a normal and a point <li>18/06/03 - MF - Added TVCCapsule <li>17/06/03 - MF - Added TVFAirResistance <li>17/06/03 - MF - Added TVCCube collider <li>16/06/03 - MF - Fixed TVFSpring.SetRestlengthToCurrent <li>24/07/02 - EG - Added TVCCylinder <li>18/07/02 - EG - Improved forces & constraints <li>23/06/02 - EG - Stricter encapsulation, fixed some leaks, Various optimizations (+25%) <li>21/06/02 - EG - Creation (original code by Mattias Fagerlund) </ul>

Overview

Classes, Interfaces, Objects and Records

Name | Description
packed record TVerletProgressTimes |
Class TVerletNode |
Class TVerletNodeList |
Class TVerletConstraint |
Class TVerletDualConstraint |
Class TVerletGroupConstraint |
Class TVerletEdge |
Class TVerletEdgeList |
Class TVerletGlobalConstraint |
Class TVerletGlobalFrictionConstraint |
Class TVerletGlobalFrictionConstraintSP |
Class TVerletGlobalFrictionConstraintSphere |
Class TVerletGlobalFrictionConstraintBox |
Class TVerletConstraintList |
Class TVerletForce |
Class TVerletDualForce |
Class TVerletGroupForce |
Class TVerletGlobalForce |
Class TVerletForceList |
Class TVerletWorld |
Class TVFGravity |
Class TVFAirResistance |
Class TVFSpring |
Class TVCFloor |
Class TVCHeightField |
Class TVCStick |
Class TVCRigidBody |
Class TVCSlider |
Class TVCSphere |
Class TVCCylinder |
Class TVCCube |
Class TVCCapsule |

Types

TVerletNodeClass = class of TVerletNode;
TUpdateSpacePartion = (...);
TCollisionConstraintTypes = (...);
TCollisionConstraintTypesSet = set of TCollisionConstraintTypes;
TVCHeightFieldOnNeedHeight = function (hfConstraint : TVCHeightField; node : TVerletNode) : Single of object;

Constants

G_DRAG = 0.0001;
cDEFAULT_CONSTRAINT_FRICTION = 0.6;

Description

Types

TVerletNodeClass = class of TVerletNode;
TUpdateSpacePartion = (...);
Values
  • uspEveryIteration:
  • uspEveryFrame:
  • uspNever:
TCollisionConstraintTypes = (...);
Values
  • cctEdge:
  • cctNode:
TCollisionConstraintTypesSet = set of TCollisionConstraintTypes;
TVCHeightFieldOnNeedHeight = function (hfConstraint : TVCHeightField; node : TVerletNode) : Single of object;

Constants

G_DRAG = 0.0001;
cDEFAULT_CONSTRAINT_FRICTION = 0.6;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: packed record TVerletProgressTimes

packed record TVerletProgressTimes

Unit

VerletClasses

Declaration

type TVerletProgressTimes = packed record

Description

Overview

Fields

deltaTime: Double;
newTime: Double;
sqrDeltaTime: Single;
invSqrDeltaTime: Single;

Description

Fields

deltaTime: Double;
newTime: Double;
sqrDeltaTime: Single;
invSqrDeltaTime: Single;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletNode

Class TVerletNode

Unit

VerletClasses

Declaration

type TVerletNode = class(TSpacePartitionLeaf)

Description

Basic verlet node

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSpacePartitionLeaf
  • TVerletNode

Overview

Fields

Protected | FLocation: TAffineVector;
Protected | FOldLocation: TAffineVector;

Methods

Public | constructor CreateOwned(const aOwner : TVerletWorld); virtual;
Public | destructor Destroy; override;
Public | function DistanceToNode(const node : TVerletNode) : Single;
Public | function GetMovement : TAffineVector;
Public | procedure ApplyFriction(const friction, penetrationDepth : Single; const surfaceNormal : TAffineVector);
Public | procedure Initialize; dynamic;
Public | procedure OldApplyFriction(const friction, penetrationDepth : Single);
Public | procedure UpdateCachedAABBAndBSphere; override;
Public | procedure Verlet(const vpt : TVerletProgressTimes); virtual;
Protected | procedure AfterProgress; virtual;
Protected | procedure SetLocation(const Value: TAffineVector); virtual;
Protected | procedure SetWeight(const value : Single);

Properties

Public | property ChangedOnStep : Integer read FChangedOnStep;
Public | property Force : TAffineVector read FForce write FForce;
Public | property Friction : Single read FFriction write FFriction;
Public | property InvWeight : Single read FInvWeight;
Public | property Location : TAffineVector read FLocation write SetLocation;
Public | property NailedDown : Boolean read FNailedDown write FNailedDown;
Public | property OldLocation : TAffineVector read FOldLocation write FOldLocation;
Public | property Owner : TVerletWorld read FOwner;
Public | property Radius : Single read FRadius write FRadius;
Public | property Speed : TAffineVector read GetSpeed;
Public | property Weight : Single read FWeight write SetWeight;

Description

Fields

Protected FLocation: TAffineVector;
Protected FOldLocation: TAffineVector;

Methods

Public constructor CreateOwned(const aOwner : TVerletWorld); virtual;
Public destructor Destroy; override;
Public function DistanceToNode(const node : TVerletNode) : Single;

Calculates the distance to another node

Public function GetMovement : TAffineVector;

Calculates the movement of the node

Public procedure ApplyFriction(const friction, penetrationDepth : Single; const surfaceNormal : TAffineVector);

Applies friction

Public procedure Initialize; dynamic;

Initlializes the node. For the base class, it just makes sure that FOldPosition = FPosition, so that speed is zero

Public procedure OldApplyFriction(const friction, penetrationDepth : Single);

Simple and less accurate method for friction

Public procedure UpdateCachedAABBAndBSphere; override;

The TVerletNode inherits from TSpacePartitionLeaf, and it needs to know how to publish itself. The owner ( a TVerletWorld ) has a spatial partitioning object

Public procedure Verlet(const vpt : TVerletProgressTimes); virtual;

Perform Verlet integration

Protected procedure AfterProgress; virtual;
Protected procedure SetLocation(const Value: TAffineVector); virtual;
Protected procedure SetWeight(const value : Single);

Properties

Public property ChangedOnStep : Integer read FChangedOnStep;

What phyisics step was this node last changed? Used to keep track of when the spatial partitioning needs to be updated

Public property Force : TAffineVector read FForce write FForce;

A sum of all forces that has been applied to this verlet node during a step

Public property Friction : Single read FFriction write FFriction;

Each node has a friction that effects how it reacts during contacts.

Public property InvWeight : Single read FInvWeight;

InvWeight is 1/Weight, and is kept up to date automatically

Public property Location : TAffineVector read FLocation write SetLocation;

The location of the verlet

Public property NailedDown : Boolean read FNailedDown write FNailedDown;

If the node is nailed down, it can't be moved by either force, constraint or verlet integration - but you can still move it by hand

Public property OldLocation : TAffineVector read FOldLocation write FOldLocation;

The old location of the verlet. This is used for verlet integration

Public property Owner : TVerletWorld read FOwner;

The VerletWorld that owns this verlet

Public property Radius : Single read FRadius write FRadius;

The radius of the verlet node - this has been more or less deprecated

Public property Speed : TAffineVector read GetSpeed;

Returns the speed of the verlet node. Speed = Movement / deltatime

Public property Weight : Single read FWeight write SetWeight;

The weight of a node determines how much it's affected by a force

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletNodeList

Class TVerletNodeList

Unit

VerletClasses

Declaration

type TVerletNodeList = class(TList)

Description

Hierarchy

  • TList
  • TVerletNodeList

Overview

Properties

Public property Items[i : Integer]: TVerletNode read GetItems write SetItems;

Description

Properties

Public property Items[i : Integer]: TVerletNode read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletConstraint

Class TVerletConstraint

Unit

VerletClasses

Declaration

type TVerletConstraint = class(TObject)

Description

Hierarchy

  • TObject
  • TVerletConstraint

Overview

Methods

Public | constructor Create(const aOwner : TVerletWorld); virtual;
Public | destructor Destroy; override;
Public | procedure BeforeIterations; virtual;
Public | procedure RemoveNode(const aNode : TVerletNode); virtual; abstract;
Public | procedure SatisfyConstraint(const iteration, maxIterations : Integer); virtual; abstract;

Properties

Public | property Enabled : Boolean read FEnabled write FEnabled;
Public | property Owner : TVerletWorld read FOwner;
Public | property Tag : Integer read FTag write FTag;

Description

Methods

Public constructor Create(const aOwner : TVerletWorld); virtual;
Public destructor Destroy; override;
Public procedure BeforeIterations; virtual;

Method that's fired before the physics iterations are performed

Public procedure RemoveNode(const aNode : TVerletNode); virtual; abstract;

Notifies removal of a node

Public procedure SatisfyConstraint(const iteration, maxIterations : Integer); virtual; abstract;

Updates the position of one or several nodes to make sure that they don't violate the constraint

Properties

Public property Enabled : Boolean read FEnabled write FEnabled;

Determines if the constraint should be enforced or not

Public property Owner : TVerletWorld read FOwner;

Onwer of the constraint

Public property Tag : Integer read FTag write FTag;

Tag field reserved for the user.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletDualConstraint

Class TVerletDualConstraint

Unit

VerletClasses

Declaration

type TVerletDualConstraint = class(TVerletConstraint)

Description

no description available, TVerletConstraint description follows

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletDualConstraint

Overview

Methods

Public procedure RemoveNode(const aNode : TVerletNode); override;

Properties

Public | property NodeA : TVerletNode read FNodeA write FNodeA;
Public | property NodeB : TVerletNode read FNodeB write FNodeB;

Description

Methods

Public procedure RemoveNode(const aNode : TVerletNode); override;

Properties

Public property NodeA : TVerletNode read FNodeA write FNodeA;

Reference to NodeA.

Public property NodeB : TVerletNode read FNodeB write FNodeB;

Reference to NodeB.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletGroupConstraint

Class TVerletGroupConstraint

Unit

VerletClasses

Declaration

type TVerletGroupConstraint = class(TVerletConstraint)

Description

no description available, TVerletConstraint description follows

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletGroupConstraint

Overview

Methods

Public | constructor Create(const aOwner : TVerletWorld); override;
Public | destructor Destroy; override;
Public | procedure RemoveNode(const aNode : TVerletNode); override;

Properties

Public property Nodes : TVerletNodeList read FNodes;

Description

Methods

Public constructor Create(const aOwner : TVerletWorld); override;
Public destructor Destroy; override;
Public procedure RemoveNode(const aNode : TVerletNode); override;

Properties

Public property Nodes : TVerletNodeList read FNodes;

The list of nodes that this constraint will effect

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletEdge

Class TVerletEdge

Unit

VerletClasses

Declaration

type TVerletEdge = class(TSpacePartitionLeaf)

Description

no description available, TSpacePartitionLeaf description follows
no description available, TPersistentObject description follows

Base class for persistent objects.<p> The base requirement is implementation of ReadFromFiler & WriteToFiler in sub-classes, the immediate benefits are support of streaming (to stream, file or string), assignment and cloning.<br> The other requirement being the use of a virtual constructor, which allows polymorphic construction (don't forget to register your subclasses).<p> Note that TPersistentObject implements IUnknown, but does *not* implement reference counting.

Hierarchy

  • TPersistent
  • TPersistentObject
  • TSpacePartitionLeaf
  • TVerletEdge

Overview

Methods

Public | constructor CreateEdgeOwned(const aNodeA, aNodeB : TVerletNode);
Public | procedure UpdateCachedAABBAndBSphere; override;

Properties

Public | property NodeA : TVerletNode read FNodeA write FNodeA;
Public | property NodeB : TVerletNode read FNodeB write FNodeB;

Description

Methods

Public constructor CreateEdgeOwned(const aNodeA, aNodeB : TVerletNode);
Public procedure UpdateCachedAABBAndBSphere; override;

The TVerletEdge inherits from TSpacePartitionLeaf, and it needs to know how to publish itself. The owner ( a TVerletWorld ) has a spatial partitioning object

Properties

Public property NodeA : TVerletNode read FNodeA write FNodeA;

One of the nodes in the edge

Public property NodeB : TVerletNode read FNodeB write FNodeB;

One of the nodes in the edge

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletEdgeList

Class TVerletEdgeList

Unit

VerletClasses

Declaration

type TVerletEdgeList = class(TList)

Description

Hierarchy

  • TList
  • TVerletEdgeList

Overview

Properties

Public property Items[i : Integer]: TVerletEdge read GetItems write SetItems;

Description

Properties

Public property Items[i : Integer]: TVerletEdge read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletGlobalConstraint

Class TVerletGlobalConstraint

Unit

VerletClasses

Declaration

type TVerletGlobalConstraint = class(TVerletConstraint)

Description

no description available, TVerletConstraint description follows

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletGlobalConstraint

Overview

Methods

Public | constructor Create(const aOwner : TVerletWorld); override;
Public | destructor Destroy; override;
Public | function TranslateKickbackTorque(const TorqueCenter : TAffineVector) : TAffineVector;
Public | procedure AddKickbackForceAt(const Pos : TAffineVector; const Force : TAffineVector);
Public | procedure BeforeIterations; override;
Public | procedure RemoveNode(const aNode : TVerletNode); override;
Public | procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;
Public | procedure SatisfyConstraintForEdge(const aEdge : TVerletEdge; const iteration, maxIterations : Integer); virtual;
Public | procedure SatisfyConstraintForNode(const aNode : TVerletNode; const iteration, maxIterations : Integer); virtual; abstract;

Properties

Public | property KickbackForce : TAffineVector read FKickbackForce write FKickbackForce;
Public | property KickbackTorque : TAffineVector read FKickbackTorque write FKickbackTorque;
Public | property Location : TAffineVector read FLocation write SetLocation;

Description

Methods

Public constructor Create(const aOwner : TVerletWorld); override;
Public destructor Destroy; override;
Public function TranslateKickbackTorque(const TorqueCenter : TAffineVector) : TAffineVector;
Public procedure AddKickbackForceAt(const Pos : TAffineVector; const Force : TAffineVector);
Public procedure BeforeIterations; override;
Public procedure RemoveNode(const aNode : TVerletNode); override;
Public procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;
Public procedure SatisfyConstraintForEdge(const aEdge : TVerletEdge; const iteration, maxIterations : Integer); virtual;
Public procedure SatisfyConstraintForNode(const aNode : TVerletNode; const iteration, maxIterations : Integer); virtual; abstract;

Properties

Public property KickbackForce : TAffineVector read FKickbackForce write FKickbackForce;

The force that this collider has experienced while correcting the verlet possitions. This force can be applied to ODE bodies, for instance

Public property KickbackTorque : TAffineVector read FKickbackTorque write FKickbackTorque;

The torque that this collider has experienced while correcting the verlet possitions, in reference to the center of the collider. The torque force can be applied to ODE bodies, but it must first be translated. A torque can be trasnalted by <p> <p> EM(b) = EM(a) + EF x VectorSubtract(b, a). <p> <P> Simply adding the torque to the body will NOT work correctly. See TranslateKickbackTorque

Public property Location : TAffineVector read FLocation write SetLocation;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletGlobalFrictionConstraint

Class TVerletGlobalFrictionConstraint

Unit

VerletClasses

Declaration

type TVerletGlobalFrictionConstraint = class(TVerletGlobalConstraint)

Description

no description available, TVerletGlobalConstraint description follows
no description available, TVerletConstraint description follows

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletGlobalConstraint
  • TVerletGlobalFrictionConstraint

Overview

Methods

Public constructor Create(const aOwner : TVerletWorld); override;

Properties

Public property FrictionRatio : Single read FFrictionRatio write FFrictionRatio;

Description

Methods

Public constructor Create(const aOwner : TVerletWorld); override;

Properties

Public property FrictionRatio : Single read FFrictionRatio write FFrictionRatio;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletGlobalFrictionConstraintSP

Class TVerletGlobalFrictionConstraintSP

Unit

VerletClasses

Declaration

type TVerletGlobalFrictionConstraintSP = class(TVerletGlobalFrictionConstraint)

Description

no description available, TVerletGlobalFrictionConstraint description follows
no description available, TVerletGlobalConstraint description follows
no description available, TVerletConstraint description follows

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletGlobalConstraint
  • TVerletGlobalFrictionConstraint
  • TVerletGlobalFrictionConstraintSP

Overview

Methods

Public | procedure PerformSpaceQuery; virtual; abstract;
Public | procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;

Description

Methods

Public procedure PerformSpaceQuery; virtual; abstract;
Public procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletGlobalFrictionConstraintSphere

Class TVerletGlobalFrictionConstraintSphere

Unit

VerletClasses

Declaration

type TVerletGlobalFrictionConstraintSphere = class(TVerletGlobalFrictionConstraintSP)

Description

no description available, TVerletGlobalFrictionConstraintSP description follows
no description available, TVerletGlobalFrictionConstraint description follows
no description available, TVerletGlobalConstraint description follows
no description available, TVerletConstraint description follows

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletGlobalConstraint
  • TVerletGlobalFrictionConstraint
  • TVerletGlobalFrictionConstraintSP
  • TVerletGlobalFrictionConstraintSphere

Overview

Methods

Public | function GetBSphere : TBSphere; virtual; abstract;
Public | procedure PerformSpaceQuery; override;
Public | procedure UpdateCachedBSphere;

Properties

Public property CachedBSphere : TBSphere read FCachedBSphere;

Description

Methods

Public function GetBSphere : TBSphere; virtual; abstract;
Public procedure PerformSpaceQuery; override;
Public procedure UpdateCachedBSphere;

Properties

Public property CachedBSphere : TBSphere read FCachedBSphere;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletGlobalFrictionConstraintBox

Class TVerletGlobalFrictionConstraintBox

Unit

VerletClasses

Declaration

type TVerletGlobalFrictionConstraintBox = class(TVerletGlobalFrictionConstraintSP)

Description

no description available, TVerletGlobalFrictionConstraintSP description follows
no description available, TVerletGlobalFrictionConstraint description follows
no description available, TVerletGlobalConstraint description follows
no description available, TVerletConstraint description follows

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletGlobalConstraint
  • TVerletGlobalFrictionConstraint
  • TVerletGlobalFrictionConstraintSP
  • TVerletGlobalFrictionConstraintBox

Overview

Methods

Public | function GetAABB : TAABB; virtual; abstract;
Public | procedure PerformSpaceQuery; override;
Public | procedure UpdateCachedAABB;

Properties

Public property CachedAABB : TAABB read FCachedAABB;

Description

Methods

Public function GetAABB : TAABB; virtual; abstract;
Public procedure PerformSpaceQuery; override;
Public procedure UpdateCachedAABB;

Properties

Public property CachedAABB : TAABB read FCachedAABB;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletConstraintList

Class TVerletConstraintList

Unit

VerletClasses

Declaration

type TVerletConstraintList = class(TList)

Description

Hierarchy

  • TList
  • TVerletConstraintList

Overview

Properties

Public property Items[i : Integer]: TVerletConstraint read GetItems write SetItems;

Description

Properties

Public property Items[i : Integer]: TVerletConstraint read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletForce

Class TVerletForce

Unit

VerletClasses

Declaration

type TVerletForce = class(TObject)

Description

Generic verlet force.

Hierarchy

  • TObject
  • TVerletForce

Overview

Methods

Public | constructor Create(const aOwner : TVerletWorld); virtual;
Public | destructor Destroy; override;
Public | procedure AddForce(const vpt : TVerletProgressTimes); virtual; abstract;
Public | procedure RemoveNode(const aNode : TVerletNode); virtual; abstract;

Properties

Public property Owner : TVerletWorld read FOwner;

Description

Methods

Public constructor Create(const aOwner : TVerletWorld); virtual;
Public destructor Destroy; override;
Public procedure AddForce(const vpt : TVerletProgressTimes); virtual; abstract;

Implementation should add force to force resultant for all relevant nodes

Public procedure RemoveNode(const aNode : TVerletNode); virtual; abstract;

Notifies removal of a node

Properties

Public property Owner : TVerletWorld read FOwner;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletDualForce

Class TVerletDualForce

Unit

VerletClasses

Declaration

type TVerletDualForce = class(TVerletForce)

Description

A verlet force that applies to two specified nodes.

Hierarchy

  • TObject
  • TVerletForce
  • TVerletDualForce

Overview

Methods

Public procedure RemoveNode(const aNode : TVerletNode); override;

Properties

Public | property NodeA : TVerletNode read FNodeA write FNodeA;
Public | property NodeB : TVerletNode read FNodeB write FNodeB;

Description

Methods

Public procedure RemoveNode(const aNode : TVerletNode); override;

Properties

Public property NodeA : TVerletNode read FNodeA write FNodeA;

Reference to NodeA.

Public property NodeB : TVerletNode read FNodeB write FNodeB;

Reference to NodeB.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletGroupForce

Class TVerletGroupForce

Unit

VerletClasses

Declaration

type TVerletGroupForce = class(TVerletForce)

Description

A verlet force that applies to a specified group of nodes.

Hierarchy

  • TObject
  • TVerletForce
  • TVerletGroupForce

Overview

Methods

Public | constructor Create(const aOwner : TVerletWorld); override;
Public | destructor Destroy; override;
Public | procedure RemoveNode(const aNode : TVerletNode); override;

Properties

Public property Nodes : TVerletNodeList read FNodes;

Description

Methods

Public constructor Create(const aOwner : TVerletWorld); override;
Public destructor Destroy; override;
Public procedure RemoveNode(const aNode : TVerletNode); override;

Properties

Public property Nodes : TVerletNodeList read FNodes;

Nodes of the force group, referred, NOT owned.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletGlobalForce

Class TVerletGlobalForce

Unit

VerletClasses

Declaration

type TVerletGlobalForce = class(TVerletForce)

Description

A global force (applied to all verlet nodes).

Hierarchy

  • TObject
  • TVerletForce
  • TVerletGlobalForce

Overview

Methods

Public | procedure AddForce(const vpt : TVerletProgressTimes); override;
Public | procedure AddForceToNode(const aNode : TVerletNode); virtual; abstract;
Public | procedure RemoveNode(const aNode : TVerletNode); override;

Description

Methods

Public procedure AddForce(const vpt : TVerletProgressTimes); override;
Public procedure AddForceToNode(const aNode : TVerletNode); virtual; abstract;
Public procedure RemoveNode(const aNode : TVerletNode); override;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletForceList

Class TVerletForceList

Unit

VerletClasses

Declaration

type TVerletForceList = class(TList)

Description

Hierarchy

  • TList
  • TVerletForceList

Overview

Properties

Public property Items[i : Integer]: TVerletForce read GetItems write SetItems;

Description

Properties

Public property Items[i : Integer]: TVerletForce read GetItems write SetItems;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:45


GLScene v.1.1.2: VerletClasses: Class TVerletWorld

Class TVerletWorld

Unit

VerletClasses

Declaration

type TVerletWorld = class(TObject)

Description

Hierarchy

  • TObject
  • TVerletWorld

Overview

Methods

Public | constructor Create; virtual;
Public | destructor Destroy; override;
Public | function AddConstraint(const aConstraint : TVerletConstraint) : Integer;
Public | function AddForce(const aForce : TVerletForce) : Integer;
Public | function AddNode(const aNode : TVerletNode) : Integer;
Public | function CreateOwnedNode(const location : TAffineVector; const aRadius : Single = 0; const aWeight : Single = 1) : TVerletNode;
Public | function CreateSlider(const aNodeA, aNodeB : TVerletNode; const aSlideDirection : TAffineVector) : TVCSlider;
Public | function CreateSpring(const aNodeA, aNodeB : TVerletNode; const aStrength, aDamping : Single; const aSlack : Single = 0) : TVFSpring;
Public | function CreateStick(const aNodeA, aNodeB : TVerletNode; const Slack : Single = 0) : TVCStick;
Public | function FirstNode : TVerletNode;
Public | function LastNode : TVerletNode;
Public | function Progress(const deltaTime, newTime : Double) : Integer; virtual;
Public | procedure AddSolidEdge(const aNodeA, aNodeB : TVerletNode);
Public | procedure CreateOctree(const OctreeMin, OctreeMax : TAffineVector; const LeafThreshold, MaxTreeDepth : Integer);
Public | procedure Initialize; dynamic;
Public | procedure PauseInertia(const IterationSteps : Integer);
Public | procedure RemoveConstraint(const aConstraint : TVerletConstraint);
Public | procedure RemoveForce(const aForce : TVerletForce);
Public | procedure RemoveNode(const aNode : TVerletNode);
Protected | procedure AccumulateForces(const vpt : TVerletProgressTimes); virtual;
Protected | procedure DoUpdateSpacePartition;
Protected | procedure SatisfyConstraints(const vpt : TVerletProgressTimes); virtual;
Protected | procedure Verlet(const vpt : TVerletProgressTimes); virtual;

Properties

Public | property CollisionConstraintTypes : TCollisionConstraintTypesSet read FCollisionConstraintTypes write FCollisionConstraintTypes;
Public | property Constraints : TVerletConstraintList read FConstraints;
Public | property ConstraintsWithBeforeIterations : TVerletConstraintList read FConstraintsWithBeforeIterations;
Public | property CurrentDeltaTime : Single read FCurrentDeltaTime;
Public | property CurrentStepCount : Integer read FCurrentStepCount;
Public | property Drag : Single read FDrag write FDrag;
Public | property Inertia : boolean read FInertia write FInertia;
Public | property Iterations : Integer read FIterations write FIterations;
Public | property MaxDeltaTime : Single read FMaxDeltaTime write FMaxDeltaTime;
Public | property Nodes : TVerletNodeList read FNodes;
Public | property SimTime : Single read FSimTime write FSimTime;
Public | property SolidEdges : TVerletEdgeList read FSolidEdges write FSolidEdges;
Public | property SpacePartition: TBaseSpacePartition read FSpacePartition;
Public | property UpdateSpacePartion : TUpdateSpacePartion read FUpdateSpacePartion write FUpdateSpacePartion;
Public | property VerletNodeClass : TVerletNodeClass read FVerletNodeClass write FVerletNodeClass;

Description

Methods

Public constructor Create; virtual;
Public destructor Destroy; override;
Public function AddConstraint(const aConstraint : TVerletConstraint) : Integer;
Public function AddForce(const aForce : TVerletForce) : Integer;
Public function AddNode(const aNode : TVerletNode) : Integer;
Public function CreateOwnedNode(const location : TAffineVector; const aRadius : Single = 0; const aWeight : Single = 1) : TVerletNode;
Public function CreateSlider(const aNodeA, aNodeB : TVerletNode; const aSlideDirection : TAffineVector) : TVCSlider;
Public function CreateSpring(const aNodeA, aNodeB : TVerletNode; const aStrength, aDamping : Single; const aSlack : Single = 0) : TVFSpring;
Public function CreateStick(const aNodeA, aNodeB : TVerletNode; const Slack : Single = 0) : TVCStick;
Public function FirstNode : TVerletNode;
Public function LastNode : TVerletNode;
Public function Progress(const deltaTime, newTime : Double) : Integer; virtual;
Public procedure AddSolidEdge(const aNodeA, aNodeB : TVerletNode);
Public procedure CreateOctree(const OctreeMin, OctreeMax : TAffineVector; const LeafThreshold, MaxTreeDepth : Integer);
Public procedure Initialize; dynamic;
Public procedure PauseInertia(const IterationSteps : Integer);
Public procedure RemoveConstraint(const aConstraint : TVerletConstraint);
Public procedure RemoveForce(const aForce : TVerletForce);
Public procedure RemoveNode(const aNode : TVerletNode);
Protected procedure AccumulateForces(const vpt : TVerletProgressTimes); virtual;
Protected procedure DoUpdateSpacePartition;
Protected procedure SatisfyConstraints(const vpt : TVerletProgressTimes); virtual;
Protected procedure Verlet(const vpt : TVerletProgressTimes); virtual;

Properties

Public property CollisionConstraintTypes : TCollisionConstraintTypesSet read FCollisionConstraintTypes write FCollisionConstraintTypes;
Public property Constraints : TVerletConstraintList read FConstraints;
Public property ConstraintsWithBeforeIterations : TVerletConstraintList read FConstraintsWithBeforeIterations;
Public property CurrentDeltaTime : Single read FCurrentDeltaTime;
Public property CurrentStepCount : Integer read FCurrentStepCount;
Public property Drag : Single read FDrag write FDrag;
Public property Inertia : boolean read FInertia write FInertia;
Public property Iterations : Integer read FIterations write FIterations;
Public property MaxDeltaTime : Single read FMaxDeltaTime write FMaxDeltaTime;
Public property Nodes : TVerletNodeList read FNodes;
Public property SimTime : Single read FSimTime write FSimTime;
Public property SolidEdges : TVerletEdgeList read FSolidEdges write FSolidEdges;
Public property SpacePartition: TBaseSpacePartition read FSpacePartition;
Public property UpdateSpacePartion : TUpdateSpacePartion read FUpdateSpacePartion write FUpdateSpacePartion;
Public property VerletNodeClass : TVerletNodeClass read FVerletNodeClass write FVerletNodeClass;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VerletClasses: Class TVFGravity

Class TVFGravity

Unit

VerletClasses

Declaration

type TVFGravity = class(TVerletGlobalForce)

Description

no description available, TVerletGlobalForce description follows

A global force (applied to all verlet nodes).

Hierarchy

  • TObject
  • TVerletForce
  • TVerletGlobalForce
  • TVFGravity

Overview

Methods

Public | constructor Create(const aOwner : TVerletWorld); override;
Public | procedure AddForceToNode(const aNode : TVerletNode); override;

Properties

Public property Gravity : TAffineVector read FGravity write FGravity;

Description

Methods

Public constructor Create(const aOwner : TVerletWorld); override;
Public procedure AddForceToNode(const aNode : TVerletNode); override;

Properties

Public property Gravity : TAffineVector read FGravity write FGravity;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VerletClasses: Class TVFAirResistance

Class TVFAirResistance

Unit

VerletClasses

Declaration

type TVFAirResistance = class(TVerletGlobalForce)

Description

no description available, TVerletGlobalForce description follows

A global force (applied to all verlet nodes).

Hierarchy

  • TObject
  • TVerletForce
  • TVerletGlobalForce
  • TVFAirResistance

Overview

Methods

Public | constructor Create(const aOwner : TVerletWorld); override;
Public | procedure AddForceToNode(const aNode : TVerletNode); override;

Properties

Public | property DragCoeff : Single read FDragCoeff write FDragCoeff;
Public | property WindChaos : Single read FWindChaos write FWindChaos;
Public | property WindDirection : TAffineVector read FWindDirection write SetWindDirection;
Public | property WindMagnitude : Single read FWindMagnitude write FWindMagnitude;

Description

Methods

Public constructor Create(const aOwner : TVerletWorld); override;
Public procedure AddForceToNode(const aNode : TVerletNode); override;

Properties

Public property DragCoeff : Single read FDragCoeff write FDragCoeff;
Public property WindChaos : Single read FWindChaos write FWindChaos;

Measures how chaotic the wind is, as a fraction of the wind magnitude

Public property WindDirection : TAffineVector read FWindDirection write SetWindDirection;
Public property WindMagnitude : Single read FWindMagnitude write FWindMagnitude;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VerletClasses: Class TVFSpring

Class TVFSpring

Unit

VerletClasses

Declaration

type TVFSpring = class(TVerletDualForce)

Description

no description available, TVerletDualForce description follows

A verlet force that applies to two specified nodes.

Hierarchy

  • TObject
  • TVerletForce
  • TVerletDualForce
  • TVFSpring

Overview

Methods

Public | procedure AddForce(const vpt : TVerletProgressTimes); override;
Public | procedure SetRestLengthToCurrent;
Protected | procedure SetSlack(const value : Single);

Properties

Public | property Damping : Single read FDamping write FDamping;
Public | property Slack : Single read FSlack write SetSlack;
Public | property Strength : Single read FStrength write FStrength;

Description

Methods

Public procedure AddForce(const vpt : TVerletProgressTimes); override;
Public procedure SetRestLengthToCurrent;

Must be invoked after adjust node locations or strength

Protected procedure SetSlack(const value : Single);

Properties

Public property Damping : Single read FDamping write FDamping;
Public property Slack : Single read FSlack write SetSlack;
Public property Strength : Single read FStrength write FStrength;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VerletClasses: Class TVCFloor

Class TVCFloor

Unit

VerletClasses

Declaration

type TVCFloor = class(TVerletGlobalFrictionConstraintSP)

Description

Floor collision constraint

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletGlobalConstraint
  • TVerletGlobalFrictionConstraint
  • TVerletGlobalFrictionConstraintSP
  • TVCFloor

Overview

Methods

Public | constructor Create(const aOwner : TVerletWorld); override;
Public | procedure PerformSpaceQuery; override;
Public | procedure SatisfyConstraintForNode(const aNode : TVerletNode; const iteration, maxIterations : Integer); override;
Protected | procedure SetNormal(const value : TAffineVector);

Properties

Public | property BounceRatio : Single read FBounceRatio write FBounceRatio;
Public | property FloorLevel : Single read FFloorLevel write FFloorLevel;
Public | property Normal : TAffineVector read FNormal write SetNormal;

Description

Methods

Public constructor Create(const aOwner : TVerletWorld); override;
Public procedure PerformSpaceQuery; override;
Public procedure SatisfyConstraintForNode(const aNode : TVerletNode; const iteration, maxIterations : Integer); override;
Protected procedure SetNormal(const value : TAffineVector);

Properties

Public property BounceRatio : Single read FBounceRatio write FBounceRatio;
Public property FloorLevel : Single read FFloorLevel write FFloorLevel;
Public property Normal : TAffineVector read FNormal write SetNormal;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VerletClasses: Class TVCHeightField

Class TVCHeightField

Unit

VerletClasses

Declaration

type TVCHeightField = class(TVCFloor)

Description

HeightField collision constraint (punctual!)

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletGlobalConstraint
  • TVerletGlobalFrictionConstraint
  • TVerletGlobalFrictionConstraintSP
  • TVCFloor
  • TVCHeightField

Overview

Methods

Public procedure SatisfyConstraintForNode(const aNode : TVerletNode; const iteration, maxIterations : Integer); override;

Properties

Public property OnNeedHeight : TVCHeightFieldOnNeedHeight read FOnNeedHeight write FOnNeedHeight;

Description

Methods

Public procedure SatisfyConstraintForNode(const aNode : TVerletNode; const iteration, maxIterations : Integer); override;

Properties

Public property OnNeedHeight : TVCHeightFieldOnNeedHeight read FOnNeedHeight write FOnNeedHeight;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VerletClasses: Class TVCStick

Class TVCStick

Unit

VerletClasses

Declaration

type TVCStick = class(TVerletDualConstraint)

Description

Stick constraint.<p> Imposes a fixed distance between two nodes.

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletDualConstraint
  • TVCStick

Overview

Methods

Public | procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;
Public | procedure SetRestLengthToCurrent;

Properties

Public | property RestLength : Single read FRestLength write FRestLength;
Public | property Slack : Single read FSlack write FSlack;

Description

Methods

Public procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;
Public procedure SetRestLengthToCurrent;

Properties

Public property RestLength : Single read FRestLength write FRestLength;
Public property Slack : Single read FSlack write FSlack;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VerletClasses: Class TVCRigidBody

Class TVCRigidBody

Unit

VerletClasses

Declaration

type TVCRigidBody = class(TVerletGroupConstraint)

Description

Rigid body constraint.<p> Regroups several nodes in a rigid body conformation, somewhat similar to a stick but for multiple nodes. <p> EXPERIMENTAL, DOES NOT WORK!

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletGroupConstraint
  • TVCRigidBody

Overview

Methods

Public | procedure ComputeRigidityParameters;
Public | procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;
Protected | procedure ComputeBarycenter(var barycenter : TAffineVector);
Protected | procedure ComputeNaturals(const barycenter : TAffineVector; var natX, natY, natZ : TAffineVector);

Description

Methods

Public procedure ComputeRigidityParameters;
Public procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;
Protected procedure ComputeBarycenter(var barycenter : TAffineVector);
Protected procedure ComputeNaturals(const barycenter : TAffineVector; var natX, natY, natZ : TAffineVector);
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VerletClasses: Class TVCSlider

Class TVCSlider

Unit

VerletClasses

Declaration

type TVCSlider = class(TVerletDualConstraint)

Description

Slider constraint.<p> Imposes that two nodes be aligned on a defined direction, on which they can slide freely. Note that the direction is fixed and won't rotate with the verlet assembly!.

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletDualConstraint
  • TVCSlider

Overview

Methods

Public | procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;
Protected | procedure SetSlideDirection(const value : TAffineVector);

Properties

Public | property Constrained : Boolean read FConstrained write FConstrained;
Public | property SlideDirection : TAffineVector read FSlideDirection write SetSlideDirection;

Description

Methods

Public procedure SatisfyConstraint(const iteration, maxIterations : Integer); override;
Protected procedure SetSlideDirection(const value : TAffineVector);

Properties

Public property Constrained : Boolean read FConstrained write FConstrained;

Constrain NodeB to the halfplane defined by NodeA and SlideDirection.

Public property SlideDirection : TAffineVector read FSlideDirection write SetSlideDirection;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VerletClasses: Class TVCSphere

Class TVCSphere

Unit

VerletClasses

Declaration

type TVCSphere = class(TVerletGlobalFrictionConstraintSphere)

Description

Sphere collision constraint.

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletGlobalConstraint
  • TVerletGlobalFrictionConstraint
  • TVerletGlobalFrictionConstraintSP
  • TVerletGlobalFrictionConstraintSphere
  • TVCSphere

Overview

Methods

Public | function GetBSphere : TBSphere; override;
Public | procedure SatisfyConstraintForEdge(const aEdge : TVerletEdge; const iteration, maxIterations : Integer); override;
Public | procedure SatisfyConstraintForNode(const aNode : TVerletNode; const iteration, maxIterations : Integer); override;

Properties

Public property Radius : Single read FRadius write FRadius;

Description

Methods

Public function GetBSphere : TBSphere; override;
Public procedure SatisfyConstraintForEdge(const aEdge : TVerletEdge; const iteration, maxIterations : Integer); override;
Public procedure SatisfyConstraintForNode(const aNode : TVerletNode; const iteration, maxIterations : Integer); override;

Properties

Public property Radius : Single read FRadius write FRadius;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VerletClasses: Class TVCCylinder

Class TVCCylinder

Unit

VerletClasses

Declaration

type TVCCylinder = class(TVerletGlobalFrictionConstraint)

Description

Cylinder collision constraint.<p> The cylinder is considered infinite by this constraint.

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletGlobalConstraint
  • TVerletGlobalFrictionConstraint
  • TVCCylinder

Overview

Methods

Public | procedure SatisfyConstraintForNode(const aNode : TVerletNode; const iteration, maxIterations : Integer); override;
Protected | procedure SetRadius(const val : Single);

Properties

Public | property Axis : TAffineVector read FAxis write FAxis;
Public | property Radius : Single read FRadius write SetRadius;

Description

Methods

Public procedure SatisfyConstraintForNode(const aNode : TVerletNode; const iteration, maxIterations : Integer); override;
Protected procedure SetRadius(const val : Single);

Properties

Public property Axis : TAffineVector read FAxis write FAxis;

Cylinder axis vector.<p> Must be normalized.

Public property Radius : Single read FRadius write SetRadius;

Cylinder radius.

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VerletClasses: Class TVCCube

Class TVCCube

Unit

VerletClasses

Declaration

type TVCCube = class(TVerletGlobalFrictionConstraintBox)

Description

Cube collision constraint.

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletGlobalConstraint
  • TVerletGlobalFrictionConstraint
  • TVerletGlobalFrictionConstraintSP
  • TVerletGlobalFrictionConstraintBox
  • TVCCube

Overview

Methods

Public | function GetAABB : TAABB; override;
Public | procedure SatisfyConstraintForEdge(const aEdge : TVerletEdge; const iteration, maxIterations : Integer); override;
Public | procedure SatisfyConstraintForNode(const aNode : TVerletNode; const iteration, maxIterations : Integer); override;

Properties

Public | property Direction : TAffineVector read FDirection write FDirection;
Public | property Sides : TAffineVector read FSides write SetSides;

Description

Methods

Public function GetAABB : TAABB; override;
Public procedure SatisfyConstraintForEdge(const aEdge : TVerletEdge; const iteration, maxIterations : Integer); override;
Public procedure SatisfyConstraintForNode(const aNode : TVerletNode; const iteration, maxIterations : Integer); override;

Properties

Public property Direction : TAffineVector read FDirection write FDirection;
Public property Sides : TAffineVector read FSides write SetSides;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VerletClasses: Class TVCCapsule

Class TVCCapsule

Unit

VerletClasses

Declaration

type TVCCapsule = class(TVerletGlobalFrictionConstraintSphere)

Description

Capsule collision constraint.

Hierarchy

  • TObject
  • TVerletConstraint
  • TVerletGlobalConstraint
  • TVerletGlobalFrictionConstraint
  • TVerletGlobalFrictionConstraintSP
  • TVerletGlobalFrictionConstraintSphere
  • TVCCapsule

Overview

Methods

Public | function GetBSphere: TBSphere; override;
Public | procedure SatisfyConstraintForEdge(const aEdge : TVerletEdge; const iteration, maxIterations : Integer); override;
Public | procedure SatisfyConstraintForNode(const aNode : TVerletNode; const iteration, maxIterations : Integer); override;
Protected | procedure SetAxis(const val : TAffineVector);
Protected | procedure SetLength(const val : Single);
Protected | procedure SetRadius(const val : Single);

Properties

Public | property Axis : TAffineVector read FAxis write SetAxis;
Public | property Length : Single read FLength write SetLength;
Public | property Radius : Single read FRadius write SetRadius;

Description

Methods

Public function GetBSphere: TBSphere; override;
Public procedure SatisfyConstraintForEdge(const aEdge : TVerletEdge; const iteration, maxIterations : Integer); override;
Public procedure SatisfyConstraintForNode(const aNode : TVerletNode; const iteration, maxIterations : Integer); override;
Protected procedure SetAxis(const val : TAffineVector);
Protected procedure SetLength(const val : Single);
Protected procedure SetRadius(const val : Single);

Properties

Public property Axis : TAffineVector read FAxis write SetAxis;
Public property Length : Single read FLength write SetLength;
Public property Radius : Single read FRadius write SetRadius;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VerletHairClasses

Unit VerletHairClasses

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

VerletHairClasses<p>

Creates a single strand of hair using verlet classes. Can be used to simulate ropes, fur or hair.<p>

<b>History : </b><font size=-1><ul> <li>29/05/08 - DaStr - Added $I GLScene.inc <li>06/03/04 - MF - Creation </ul>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TVerletHair |

Types

TVHStiffness = (...);
TVHStiffnessSet = set of TVHStiffness;

Description

Types

TVHStiffness = (...);
Values
  • vhsFull:
  • vhsSkip1Node:
  • vhsSkip2Node:
  • vhsSkip3Node:
  • vhsSkip4Node:
  • vhsSkip5Node:
  • vhsSkip6Node:
  • vhsSkip7Node:
  • vhsSkip8Node:
  • vhsSkip9Node:
TVHStiffnessSet = set of TVHStiffness;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VerletHairClasses: Class TVerletHair

Class TVerletHair

Unit

VerletHairClasses

Declaration

type TVerletHair = class(TObject)

Description

Hierarchy

  • TObject
  • TVerletHair

Overview

Methods

Public | constructor Create(const AVerletWorld : TVerletWorld; const ARootDepth, AHairLength : single; ALinkCount : integer; const AAnchorPosition, AHairDirection : TAffineVector; const AStiffness : TVHStiffnessSet);
Public | destructor Destroy; override;
Public | procedure BuildHair(const AAnchorPosition, AHairDirection: TAffineVector);
Public | procedure BuildStiffness;
Public | procedure Clear;
Public | procedure ClearStiffness;

Properties

Public | property Anchor : TVerletNode read GetAnchor;
Public | property Data : pointer read FData write FData;
Public | property HairLength : single read FHairLength;
Public | property LinkCount : integer read FLinkCount;
Public | property LinkLength : single read GetLinkLength;
Public | property NodeList : TVerletNodeList read FNodeList;
Public | property Root : TVerletNode read GetRoot;
Public | property RootDepth : single read FRootDepth;
Public | property Stiffness : TVHStiffnessSet read FStiffness write SetStiffness;
Public | property VerletWorld : TVerletWorld read FVerletWorld;

Description

Methods

Public constructor Create(const AVerletWorld : TVerletWorld; const ARootDepth, AHairLength : single; ALinkCount : integer; const AAnchorPosition, AHairDirection : TAffineVector; const AStiffness : TVHStiffnessSet);
Public destructor Destroy; override;
Public procedure BuildHair(const AAnchorPosition, AHairDirection: TAffineVector);
Public procedure BuildStiffness;
Public procedure Clear;
Public procedure ClearStiffness;

Properties

Public property Anchor : TVerletNode read GetAnchor;

Anchor should be nailed down to give the hair stability

Public property Data : pointer read FData write FData;
Public property HairLength : single read FHairLength;
Public property LinkCount : integer read FLinkCount;
Public property LinkLength : single read GetLinkLength;
Public property NodeList : TVerletNodeList read FNodeList;
Public property Root : TVerletNode read GetRoot;

Root should be nailed down to give the hair stability

Public property RootDepth : single read FRootDepth;
Public property Stiffness : TVHStiffnessSet read FStiffness write SetStiffness;
Public property VerletWorld : TVerletWorld read FVerletWorld;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VRMLParser

Unit VRMLParser

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

VRMLParser<p>

VRML file format parser.<p>

<b>History :</b><font size=-1><ul> <li>02/04/07 - DaStr - Added $I GLScene.inc <li>29/03/07 - DaStr - Added missing parameters in procedure's implementation (thanks Burkhard Carstens) (Bugtracker ID = 1681409) <li>25/01/05 - SG - Added ShapeHints (creaseAngle), Normal and TexCoord support <li>14/01/05 - SG - Added to CVS </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TVRMLNode |
Class TVRMLSingleArray |
Class TVRMLIntegerArray |
Class TVRMLMaterial |
Class TVRMLUse |
Class TVRMLShapeHints |
Class TVRMLTransform |
Class TVRMLParser |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VRMLParser: Class TVRMLNode

Class TVRMLNode

Unit

VRMLParser

Declaration

type TVRMLNode = class(TObject)

Description

Hierarchy

  • TObject
  • TVRMLNode

Overview

Methods

Public | constructor Create; virtual;
Public | constructor CreateOwned(AParent : TVRMLNode);
Public | destructor Destroy; override;
Public | function Count : Integer;
Public | procedure Add(node : TVRMLNode);
Public | procedure Clear;
Public | procedure Delete(index : Integer);
Public | procedure Remove(node : TVRMLNode);

Properties

Public | property DefName : String read FDefName write FDefName;
Public | property Name : String read FName write FName;
Public | property Nodes[index : Integer]: TVRMLNode read GetNode;
Public | property Parent : TVRMLNode read FParent;

Description

Methods

Public constructor Create; virtual;
Public constructor CreateOwned(AParent : TVRMLNode);
Public destructor Destroy; override;
Public function Count : Integer;
Public procedure Add(node : TVRMLNode);
Public procedure Clear;
Public procedure Delete(index : Integer);
Public procedure Remove(node : TVRMLNode);

Properties

Public property DefName : String read FDefName write FDefName;
Public property Name : String read FName write FName;
Public property Nodes[index : Integer]: TVRMLNode read GetNode;
Public property Parent : TVRMLNode read FParent;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VRMLParser: Class TVRMLSingleArray

Class TVRMLSingleArray

Unit

VRMLParser

Declaration

type TVRMLSingleArray = class(TVRMLNode)

Description

no description available, TVRMLNode description follows

Hierarchy

  • TObject
  • TVRMLNode
  • TVRMLSingleArray

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;

Properties

Public property Values : TSingleList read FValues;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;

Properties

Public property Values : TSingleList read FValues;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VRMLParser: Class TVRMLIntegerArray

Class TVRMLIntegerArray

Unit

VRMLParser

Declaration

type TVRMLIntegerArray = class(TVRMLNode)

Description

no description available, TVRMLNode description follows

Hierarchy

  • TObject
  • TVRMLNode
  • TVRMLIntegerArray

Overview

Methods

Public | constructor Create; override;
Public | destructor Destroy; override;

Properties

Public property Values : TIntegerList read FValues;

Description

Methods

Public constructor Create; override;
Public destructor Destroy; override;

Properties

Public property Values : TIntegerList read FValues;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VRMLParser: Class TVRMLMaterial

Class TVRMLMaterial

Unit

VRMLParser

Declaration

type TVRMLMaterial = class(TVRMLNode)

Description

no description available, TVRMLNode description follows

Hierarchy

  • TObject
  • TVRMLNode
  • TVRMLMaterial

Overview

Methods

Public constructor Create; override;

Properties

Public | property AmbientColor : TVector3f read FAmbientColor write FAmbientColor;
Public | property DiffuseColor : TVector3f read FDiffuseColor write FDiffuseColor;
Public | property EmissiveColor : TVector3f read FEmissiveColor write FEmissiveColor;
Public | property HasAmbient : Boolean read FHasAmbient write FHasAmbient;
Public | property HasDiffuse : Boolean read FHasDiffuse write FHasDiffuse;
Public | property HasEmissive : Boolean read FHasEmissive write FHasEmissive;
Public | property HasShininess : Boolean read FHasShininess write FHasShininess;
Public | property HasSpecular : Boolean read FHasSpecular write FHasSpecular;
Public | property HasTransparency : Boolean read FHasTransparency write FHasTransparency;
Public | property Shininess : Single read FShininess write FShininess;
Public | property SpecularColor : TVector3f read FSpecularColor write FSpecularColor;
Public | property Transparency : Single read FTransparency write FTransparency;

Description

Methods

Public constructor Create; override;

Properties

Public property AmbientColor : TVector3f read FAmbientColor write FAmbientColor;
Public property DiffuseColor : TVector3f read FDiffuseColor write FDiffuseColor;
Public property EmissiveColor : TVector3f read FEmissiveColor write FEmissiveColor;
Public property HasAmbient : Boolean read FHasAmbient write FHasAmbient;
Public property HasDiffuse : Boolean read FHasDiffuse write FHasDiffuse;
Public property HasEmissive : Boolean read FHasEmissive write FHasEmissive;
Public property HasShininess : Boolean read FHasShininess write FHasShininess;
Public property HasSpecular : Boolean read FHasSpecular write FHasSpecular;
Public property HasTransparency : Boolean read FHasTransparency write FHasTransparency;
Public property Shininess : Single read FShininess write FShininess;
Public property SpecularColor : TVector3f read FSpecularColor write FSpecularColor;
Public property Transparency : Single read FTransparency write FTransparency;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VRMLParser: Class TVRMLUse

Class TVRMLUse

Unit

VRMLParser

Declaration

type TVRMLUse = class(TVRMLNode)

Description

no description available, TVRMLNode description follows

Hierarchy

  • TObject
  • TVRMLNode
  • TVRMLUse

Overview

Properties

Public property Value : String read FValue write FValue;

Description

Properties

Public property Value : String read FValue write FValue;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VRMLParser: Class TVRMLShapeHints

Class TVRMLShapeHints

Unit

VRMLParser

Declaration

type TVRMLShapeHints = class(TVRMLNode)

Description

no description available, TVRMLNode description follows

Hierarchy

  • TObject
  • TVRMLNode
  • TVRMLShapeHints

Overview

Properties

Public property CreaseAngle : Single read FCreaseAngle write FCreaseAngle;

Description

Properties

Public property CreaseAngle : Single read FCreaseAngle write FCreaseAngle;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VRMLParser: Class TVRMLTransform

Class TVRMLTransform

Unit

VRMLParser

Declaration

type TVRMLTransform = class(TVRMLNode)

Description

no description available, TVRMLNode description follows

Hierarchy

  • TObject
  • TVRMLNode
  • TVRMLTransform

Overview

Methods

Public constructor Create; override;

Properties

Public | property Center : TVector3f read FCenter write FCenter;
Public | property Rotation : TVector4f read FRotation write FRotation;
Public | property ScaleFactor : TVector3f read FScaleFactor write FScaleFactor;

Description

Methods

Public constructor Create; override;

Properties

Public property Center : TVector3f read FCenter write FCenter;
Public property Rotation : TVector4f read FRotation write FRotation;
Public property ScaleFactor : TVector3f read FScaleFactor write FScaleFactor;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: VRMLParser: Class TVRMLParser

Class TVRMLParser

Unit

VRMLParser

Declaration

type TVRMLParser = class(TObject)

Description

Hierarchy

  • TObject
  • TVRMLParser

Overview

Methods

Public | constructor Create;
Public | destructor Destroy; override;
Protected | function ReadSingle : Single;
Protected | function ReadToken : String;
Protected | function ReadVector3f : TVector3f;
Protected | function ReadVector4f : TVector4f;
Public | procedure Parse(Text : String);
Protected | procedure ReadCoordinate3(defname : String = '');
Protected | procedure ReadCoordIndexArray(defname : String = '');
Protected | procedure ReadDef;
Protected | procedure ReadGroup(defname : String = '');
Protected | procedure ReadIndexedFaceSet(defname : String = '');
Protected | procedure ReadMaterial(defname : String = '');
Protected | procedure ReadNormal(defname : String = '');
Protected | procedure ReadNormalIndexArray(defname : String = '');
Protected | procedure ReadPointArray(defname : String = '');
Protected | procedure ReadSeparator(defname : String = '');
Protected | procedure ReadShapeHints(defname : String = '');
Protected | procedure ReadTextureCoordinate2(defname : String = '');
Protected | procedure ReadTextureCoordIndexArray(defname : String = '');
Protected | procedure ReadTransform(defname : String = '');
Protected | procedure ReadUnknown(unknown_token : String; defname : String = '');
Protected | procedure ReadUnknownArray(defname : String = '');
Protected | procedure ReadUnknownHeirachy(defname : String = '');
Protected | procedure ReadUse;

Properties

Public | property AllowUnknownNodes : Boolean read FAllowUnknownNodes write FAllowUnknownNodes;
Public | property RootNode : TVRMLNode read FRootNode;

Description

Methods

Public constructor Create;
Public destructor Destroy; override;
Protected function ReadSingle : Single;
Protected function ReadToken : String;
Protected function ReadVector3f : TVector3f;
Protected function ReadVector4f : TVector4f;
Public procedure Parse(Text : String);
Protected procedure ReadCoordinate3(defname : String = '');
Protected procedure ReadCoordIndexArray(defname : String = '');
Protected procedure ReadDef;
Protected procedure ReadGroup(defname : String = '');
Protected procedure ReadIndexedFaceSet(defname : String = '');
Protected procedure ReadMaterial(defname : String = '');
Protected procedure ReadNormal(defname : String = '');
Protected procedure ReadNormalIndexArray(defname : String = '');
Protected procedure ReadPointArray(defname : String = '');
Protected procedure ReadSeparator(defname : String = '');
Protected procedure ReadShapeHints(defname : String = '');
Protected procedure ReadTextureCoordinate2(defname : String = '');
Protected procedure ReadTextureCoordIndexArray(defname : String = '');
Protected procedure ReadTransform(defname : String = '');
Protected procedure ReadUnknown(unknown_token : String; defname : String = '');
Protected procedure ReadUnknownArray(defname : String = '');
Protected procedure ReadUnknownHeirachy(defname : String = '');
Protected procedure ReadUse;

Properties

Public property AllowUnknownNodes : Boolean read FAllowUnknownNodes write FAllowUnknownNodes;
Public property RootNode : TVRMLNode read FRootNode;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: XCollection

Unit XCollection

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

XCollection<p>

A polymorphism-enabled TCollection-like set of classes<p>

<b>History : </b><font size=-1><ul> <li>10/11/12 - PW - Added CPPB compatibility: used dummy method instead abstract definition in class function FriendlyName for GLS_CPPB <li>20/01/11 - DanB - TXCollectionItem no longer sets initial Name = FriendlyName <li>04/11/10 - DaStr - Restored Delphi5 and Delphi6 compatibility <li>31/08/10 - Yar - Bugfixed TXCollectionItem.ReadFromFiler when Assertion off <li>07/11/09 - DaStr - Added DEBUG_XCOLLECTION option <li>10/04/08 - DaStr - TXCollectionItem now descends from TGLInterfacedPersistent (BugTracker ID = 1938988) <li>08/12/04 - SG - Added TXCollectionItem.CanAddTo class function <li>02/08/04 - LR, YHC - BCB corrections: use record instead array Add dummy method for the abstract problem <li>03/07/04 - LR - Removed ..\ from the GLScene.inc <li>12/07/03 - DanB - Added (De)RegisterXCollectionDestroyEvent <li>19/06/03 - DanB - Added TXCollection.GetOrCreate <li>18/02/01 - EG - Fixed TXCollectionItem.Destroy (count decrementation) <li>02/02/01 - EG - CanAdd now virtual <li>09/06/00 - EG - Added GetByClass <li>23/05/00 - EG - Added "Loaded" mechanism <li>17/04/00 - EG - Optimized TXCollection.Assign <li>16/04/00 - EG - Creation from GLScene split </ul></font>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class EFilerException |
Class TXCollectionItem |
Class TXCollection |

Functions and Procedures

procedure RegisterXCollectionDestroyEvent(notifyEvent: TNotifyEvent);
procedure DeRegisterXCollectionDestroyEvent(notifyEvent: TNotifyEvent);
procedure RegisterXCollectionItemClass(aClass: TXCollectionItemClass);
procedure UnregisterXCollectionItemClass(aClass: TXCollectionItemClass);
function FindXCollectionItemClass(const ClassName: string): TXCollectionItemClass;
function GetXCollectionItemClassesList(baseClass: TXCollectionItemClass = nil): TList;
procedure GetXCollectionClassesList(var ClassesList: TList; baseClass: TXCollectionItemClass = nil);

Types

TXCollectionItemClass = class of TXCollectionItem;

Constants

cUnknownArchiveVersion = 'Unknown archive version : ';

Description

Functions and Procedures

procedure RegisterXCollectionDestroyEvent(notifyEvent: TNotifyEvent);

Registers an event to be called when an XCollection is destroyed.

procedure DeRegisterXCollectionDestroyEvent(notifyEvent: TNotifyEvent);

DeRegisters event.

procedure RegisterXCollectionItemClass(aClass: TXCollectionItemClass);

Registers a TXCollectionItem subclass for persistence requirements.

procedure UnregisterXCollectionItemClass(aClass: TXCollectionItemClass);

Removes a TXCollectionItem subclass from the list.

function FindXCollectionItemClass(const ClassName: string): TXCollectionItemClass;

Retrieves a registered TXCollectionItemClass from its classname.

function GetXCollectionItemClassesList(baseClass: TXCollectionItemClass = nil): TList;

Creates and returns a copy of internal list of TXCollectionItem classes.<p> Returned list should be freed by caller, the parameter defines an ancestor class filter. If baseClass is left nil, TXCollectionItem is used as ancestor.

procedure GetXCollectionClassesList(var ClassesList: TList; baseClass: TXCollectionItemClass = nil);

Types

TXCollectionItemClass = class of TXCollectionItem;

Constants

cUnknownArchiveVersion = 'Unknown archive version : ';
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: XCollection: Class EFilerException

Class EFilerException

Unit

XCollection

Declaration

type EFilerException = class(Exception)

Description

Hierarchy

  • Exception
  • EFilerException
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: XCollection: Class TXCollectionItem

Class TXCollectionItem

Unit

XCollection

Declaration

type TXCollectionItem = class(TGLInterfacedPersistent)

Description

Base class for implementing a XCollection item.<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation </ul>

Hierarchy

  • TPersistent
  • TGLInterfacedPersistent
  • TXCollectionItem

Overview

Methods

Public | constructor Create(aOwner: TXCollection); virtual;
Public | destructor Destroy; override;
Public | class function CanAddTo(collection: TXCollection): boolean; virtual;
Public | class function FriendlyDescription: String; virtual;
Public | class function FriendlyName: String; virtual; abstract;
Public | function GetNamePath: string; override;
Public | function Index: integer;
Public | class function ItemCategory: string; virtual;
Public | class function UniqueItem: Boolean; virtual;
Protected | function GetName: string; virtual;
Protected | function GetOwner: TPersistent; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure MoveDown;
Public | procedure MoveUp;
Protected | procedure Loaded; dynamic;
Protected | procedure RaiseFilerException(const archiveVersion: integer);
Protected | procedure ReadFromFiler(reader: TReader); virtual;
Protected | procedure SetName(const val: string); virtual;
Protected | procedure WriteToFiler(writer: TWriter); virtual;

Properties

Published | property Name: string read FName write SetName;
Public | property Owner: TXCollection read FOwner;

Description

Methods

Public constructor Create(aOwner: TXCollection); virtual;
Public destructor Destroy; override;
Public class function CanAddTo(collection: TXCollection): boolean; virtual;

Allows the XCollectionItem class to determine if it should be allowed to be added to the given collection.

Public class function FriendlyDescription: String; virtual;

Returns a user-friendly description for the class.<p> This denomination is used for helping the user when picking a texture image class in the IDE expert. If it's not overriden, takes its value from FriendlyName.

Public class function FriendlyName: String; virtual; abstract;

Returns a user-friendly denomination for the class.<p> This denomination is used for picking a texture image class in the IDE expert.

Public function GetNamePath: string; override;
Public function Index: integer;
Public class function ItemCategory: string; virtual;

Category of the item class.<p> This is a free string, it will used by the XCollectionEditor to regroup collectionitems and menu items

Public class function UniqueItem: Boolean; virtual;

If true only one such XCollectionItem is allowed per BaseSceneObject.<p> Inheritance is accounted for UniqueXCollectionItem resolution, ie. if TClassA is unique, and TClassB is a subclass of TClassA, whatever the unicity of TClassB, TClassA and TClassB won't be allowed to mix (since TClassB is a TClassA, and TClassA is unique).<br> Attempting to break the unicity rules will not be possible at design-time (in Delphi IDE) and will trigger an exception at run-time.

Protected function GetName: string; virtual;
Protected function GetOwner: TPersistent; override;
Public procedure Assign(Source: TPersistent); override;

Default implementation uses WriteToFiler/ReadFromFiler.<p>

Public procedure MoveDown;
Public procedure MoveUp;
Protected procedure Loaded; dynamic;

Override to perform things when owner form has been loaded.

Protected procedure RaiseFilerException(const archiveVersion: integer);

Triggers an EFilerException with appropriate version message.

Protected procedure ReadFromFiler(reader: TReader); virtual;

Override this function to read subclass data.

Protected procedure SetName(const val: string); virtual;
Protected procedure WriteToFiler(writer: TWriter); virtual;

Override this function to write subclass data.

Properties

Published property Name: string read FName write SetName;
Public property Owner: TXCollection read FOwner;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: XCollection: Class TXCollection

Class TXCollection

Unit

XCollection

Declaration

type TXCollection = class(TPersistent)

Description

Holds a list of TXCollectionItem objects.<p> This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList and persistence classes (XClasses & XLists), if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than Borland's lists and persistence mechanisms (and unlike Borland's, with polymorphism-support and full backward compatibility).

Hierarchy

  • TPersistent
  • TXCollection

Overview

Methods

Public | constructor Create(aOwner: TPersistent); virtual;
Public | destructor Destroy; override;
Public | function Add(anItem: TXCollectionItem): integer;
Public | function CanAdd(aClass: TXCollectionItemClass): boolean; virtual;
Public | function GetByClass(aClass: TXCollectionItemClass): TXCollectionItem;
Public | function GetNamePath: string; override;
Public | function GetOrCreate(anItem: TXCollectionItemClass): TXCollectionItem;
Public | function IndexOf(anItem: TXCollectionItem): integer;
Public | function IndexOfClass(aClass: TXCollectionItemClass): integer;
Public | function IndexOfName(const aName: string): integer;
Public | class function ItemsClass: TXCollectionItemClass; virtual;
Protected | function GetItems(index: integer): TXCollectionItem;
Protected | function GetOwner: TPersistent; override;
Public | procedure Assign(Source: TPersistent); override;
Public | procedure Clear;
Public | procedure Delete(index: integer);
Public | procedure Loaded;
Public | procedure Remove(anItem: TXCollectionItem);
Protected | procedure ReadFromFiler(reader: TReader);
Protected | procedure WriteToFiler(writer: TWriter);

Properties

Public | property ArchiveVersion: integer read FArchiveVersion;
Public | property Count: integer read FCount;
Public | property Items[index: integer]: TXCollectionItem read GetItems;
Public | property Owner: TPersistent read FOwner write FOwner;

Description

Methods

Public constructor Create(aOwner: TPersistent); virtual;
Public destructor Destroy; override;
Public function Add(anItem: TXCollectionItem): integer;
Public function CanAdd(aClass: TXCollectionItemClass): boolean; virtual;

Indicates if an object of the given class can be added.<p> This function is used to enforce Unique XCollection.

Public function GetByClass(aClass: TXCollectionItemClass): TXCollectionItem;

Returns the first XCollection of the given class (or nil)

Public function GetNamePath: string; override;
Public function GetOrCreate(anItem: TXCollectionItemClass): TXCollectionItem;
Public function IndexOf(anItem: TXCollectionItem): integer;
Public function IndexOfClass(aClass: TXCollectionItemClass): integer;

Returns the index of the first XCollectionItem of the given class (or -1)

Public function IndexOfName(const aName: string): integer;

Returns the index of the first XCollectionItem of the given name (or -1)

Public class function ItemsClass: TXCollectionItemClass; virtual;

Class of the items.<p> Unlike TCollection, items can be of ItemsClass OR ANY of its subclasses, ie. this function is used only for asserting your adding objects of the right class, and not for persistence.

Protected function GetItems(index: integer): TXCollectionItem;
Protected function GetOwner: TPersistent; override;
Public procedure Assign(Source: TPersistent); override;
Public procedure Clear;
Public procedure Delete(index: integer);
Public procedure Loaded;
Public procedure Remove(anItem: TXCollectionItem);
Protected procedure ReadFromFiler(reader: TReader);
Protected procedure WriteToFiler(writer: TWriter);

Properties

Public property ArchiveVersion: integer read FArchiveVersion;
Public property Count: integer read FCount;
Public property Items[index: integer]: TXCollectionItem read GetItems;
Public property Owner: TPersistent read FOwner write FOwner;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: XOpenGL

Unit XOpenGL

Description uses Classes, Interfaces, Objects and Records Functions and Procedures Types Constants Variables

Description

XOpenGL<p>

"Alternate" OpenGL functions to handle multi-texturing.<p>

Using this functions allows specifying none/one/multiple ARB multi-texture coordinates with standard texture specification call.<p>

Before using any of the xglTexCoordXxxx fonctions, call one of the xglMapTexCoordToXxxx functions to establish the redirectors.<p>

This unit is Open-Source under MPL<br> Copyright 2001 - Eric Grange (egrange@glscene.org)<br> http://glscene.org<p>

<b>History :</b><ul> <li>25/11/10 - Yar - Wrapped multitexturing in TGLMultitextureCoordinator class <li>23/08/10 - Yar - Added OpenGLTokens to uses, replaced OpenGL1x functions to OpenGLAdapter <li>29/03/10 - Yar - Replaced MULTITHREADOPENGL to GLS_MULTITHREAD (thanks Controler) <li>16/03/07 - DaStr - Dropped Kylix support in favor of FPC (thanks Burkhard Carstens) (BugTracekrID=1681585) <li>08/07/04 - LR - Removed ../ from the GLScene.inc <li>23/05/03 - EG - Support for arbitrary (complex) mappings <li>01/02/03 - EG - Added State stack <li>01/07/02 - EG - Added mtcmUndefined, fixed initial state <li>03/01/02 - EG - Added xglDisableClientState <li>26/01/02 - EG - Added xglBegin/EndUpdate mechanism <li>21/12/01 - EG - Fixed xglTexCoordPointer and xglEnableClientState <li>18/12/01 - EG - Added xglEnableClientState <li>24/08/01 - EG - Now supports MULTITHREADOPENGL (same as OpenGL1x) <li>17/08/01 - EG - Made declarations Kylix compatible (cdecl vs stdcall) <li>16/08/01 - EG - Renamed xglMapTextCoordMode to xglMapTexCoordMode <li>14/08/01 - EG - Added xglMapTexCoordToSecond <li>21/02/01 - EG - Added TexGen and vertex arrays mappings </ul>

Overview

Classes, Interfaces, Objects and Records

Name | Description
Class TGLMultitextureCoordinator |

Functions and Procedures

function xgl(): TGLMultitextureCoordinator;

Types

TMapTexCoordMode = (...);

Description

Functions and Procedures

function xgl(): TGLMultitextureCoordinator;

Types

TMapTexCoordMode = (...);
Values
  • mtcmUndefined:
  • mtcmNull:
  • mtcmMain:
  • mtcmDual:
  • mtcmSecond:
  • mtcmArbitrary:
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:46


GLScene v.1.1.2: XOpenGL: Class TGLMultitextureCoordinator

Class TGLMultitextureCoordinator

Unit

XOpenGL

Declaration

type TGLMultitextureCoordinator = class(TAbstractMultitextureCoordinator)

Description

no description available, TAbstractMultitextureCoordinator description follows

Hierarchy

  • TObject
  • TAbstractMultitextureCoordinator
  • TGLMultitextureCoordinator

Overview

Fields

Public | TexCoord2f: procedure(s, t: TGLfloat); stdcall;
Public | TexCoord2fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord3f: procedure(s, t, r: TGLfloat); stdcall;
Public | TexCoord3fv: procedure(v: PGLfloat); stdcall;
Public | TexCoord4f: procedure(s, t, r, q: TGLfloat); stdcall;
Public | TexCoord4fv: procedure(v: PGLfloat); stdcall;
Public | TexGenf: procedure(coord, pname: TGLEnum; param: TGLfloat); stdcall;
Public | TexGenfv: procedure(coord, pname: TGLEnum; params: PGLfloat); stdcall;
Public | TexGeni: procedure(coord, pname: TGLEnum; param: TGLint); stdcall;
Public | TexGeniv: procedure(coord, pname: TGLEnum; params: PGLint); stdcall;
Public | TexCoordPointer: procedure(size: TGLint; atype: TGLEnum; stride: TGLsizei; data: pointer); stdcall;
Public | EnableClientState: procedure(aarray: TGLEnum); stdcall;
Public | DisableClientState: procedure(aarray: TGLEnum); stdcall;
Public | Enable: procedure(cap: TGLEnum); stdcall;
Public | Disable: procedure(cap: TGLEnum); stdcall;

Methods

Public | constructor Create(AOwner: TGLContext); override;
Public | function GetBitWiseMapping: Cardinal;
Public | procedure AllowSecondTextureUnit;
Public | procedure BeginUpdate;
Public | procedure EndUpdate;
Public | procedure ForbidSecondTextureUnit;
Public | procedure MapTexCoordToArbitrary(const bitWiseUnits: Cardinal); overload;
Public | procedure MapTexCoordToArbitrary(const units: array of Cardinal); overload;
Public | procedure MapTexCoordToArbitraryAdd(const bitWiseUnits: Cardinal);
Public | procedure MapTexCoordToDual;
Public | procedure MapTexCoordToMain;
Public | procedure MapTexCoordToNull;
Public | procedure MapTexCoordToSecond;
Public | procedure PopState;
Public | procedure PushState;

Properties

Public | property MapTexCoordMode: TMapTexCoordMode read FMapTexCoordMode write FMapTexCoordMode;
Public | property SecondTextureUnitForbidden: Boolean read FSecondTextureUnitForbidden;

Description

Fields

Public TexCoord2f: procedure(s, t: TGLfloat); stdcall;
Public TexCoord2fv: procedure(v: PGLfloat); stdcall;
Public TexCoord3f: procedure(s, t, r: TGLfloat); stdcall;
Public TexCoord3fv: procedure(v: PGLfloat); stdcall;
Public TexCoord4f: procedure(s, t, r, q: TGLfloat); stdcall;
Public TexCoord4fv: procedure(v: PGLfloat); stdcall;
Public TexGenf: procedure(coord, pname: TGLEnum; param: TGLfloat); stdcall;
Public TexGenfv: procedure(coord, pname: TGLEnum; params: PGLfloat); stdcall;
Public TexGeni: procedure(coord, pname: TGLEnum; param: TGLint); stdcall;
Public TexGeniv: procedure(coord, pname: TGLEnum; params: PGLint); stdcall;
Public TexCoordPointer: procedure(size: TGLint; atype: TGLEnum; stride: TGLsizei; data: pointer); stdcall;
Public EnableClientState: procedure(aarray: TGLEnum); stdcall;
Public DisableClientState: procedure(aarray: TGLEnum); stdcall;
Public Enable: procedure(cap: TGLEnum); stdcall;
Public Disable: procedure(cap: TGLEnum); stdcall;

Methods

Public constructor Create(AOwner: TGLContext); override;
Public function GetBitWiseMapping: Cardinal;

Returns the complex mapping in bitwise form.

Public procedure AllowSecondTextureUnit;

Allow XOpenGL to use the second texture unit again.

Public procedure BeginUpdate;

Defers Map calls execution until EndUpdate is met.<p> Calls to Begin/EndUpdate may be nested.

Public procedure EndUpdate;

Applies Map calls if there were any since BeginUpdate was invoked.<p> Calls to Begin/EndUpdate may be nested.

Public procedure ForbidSecondTextureUnit;

Whenever called, 2nd texture units changes will be forbidden to .<p> Use this function when you're using the 2nd texture unit for your own purposes and don't want XOpenGL to alter it.

Public procedure MapTexCoordToArbitrary(const bitWiseUnits: Cardinal); overload;
Public procedure MapTexCoordToArbitrary(const units: array of Cardinal); overload;

TexCoord functions will define the specified texture units coordinates.

Public procedure MapTexCoordToArbitraryAdd(const bitWiseUnits: Cardinal);
Public procedure MapTexCoordToDual;

TexCoord functions will define the two first texture units coordinates.

Public procedure MapTexCoordToMain;

TexCoord functions will define the main texture coordinates.

Public procedure MapTexCoordToNull;

TexCoord functions will be ignored.

Public procedure MapTexCoordToSecond;

TexCoord functions will define the second texture unit coordinates.

Public procedure PopState;

Restores XOpenGL State from the stack.

Public procedure PushState;

Saves XOpenGL State on the stack.

Properties

Public property MapTexCoordMode: TMapTexCoordMode read FMapTexCoordMode write FMapTexCoordMode;
Public property SecondTextureUnitForbidden: Boolean read FSecondTextureUnitForbidden;
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:47


GLScene v.1.1.2: Class Hierarchy

Class Hierarchy

  • Exception
    • EDDSException
    • EFilerException
    • EGLAtmosphereException
    • EGLCameraController
    • EGLConsoleException
    • EGLContext
      • EGLShader
    • EGLFile3DS
    • EGLImageUtils
    • EGLMotionBlurException
    • EGLOBJFileError
    • EGLPostShaderHolderException
    • EGLProxyException
    • EGLROAMException
    • EGLShaderException
      • EGLCGShaderException
        • EGLCgBombShaderException
      • EGLCustomShaderException
        • EGLSLShaderException
          • EGLSLBumpShaderException
          • EGLSLDiffuseSpecularShaderException
    • EGLUtilsException
    • EInvalidArchiveFile
    • EInvalidFileSignature
    • EInvalidGraphic
    • EInvalidGraphicOperation
    • EInvalidRasterFile
    • EInvalidVectorFile
    • EOpenGLError
    • EPBuffer
    • ESDLError
    • ETexture
    • ETextureCombinerError
    • ETGAException
    • EZBufferException
    • EZLibError
      • EZCompressionError
      • EZDecompressionError
  • IInterface
    • IGLCoordinatesUpdateAble
    • IGLInitializable
    • IGLMaterialLibrarySupported
    • IGLNotifyAble
      • IGLTextureNotifyAble
    • IGLPostShader
    • IGLProgessAble
    • IGLShaderDescription
    • IPersistentObject
    • IShaderParameter
  • IUnknown
    • IAVIEditStream
    • IAVIFile
    • IAVIStream
    • IAVIStreaming
    • IGetFrame
  • TClassProperty
    • TGLColorProperty
    • TGLCoordinatesProperty
    • TGLImageClassProperty
    • TGLMaterialProperty
    • TGLShaderEditorProperty
    • TGLTextureImageProperty
    • TGLTextureProperty
    • TSoundFileProperty
    • TXCollectionProperty
  • TCollection
    • TActorAnimations
    • TBitmapFontRanges
    • TGLConsoleCommandList
    • TGLEParticleMasks
    • TGLSLTextureEmitters
    • TGLSoundSamples
    • TGLSoundSources
    • TGLTextureEmitters
    • TGLTextureEx
    • TSkyDomeBands
    • TSkyDomeStars
    • TTimeEvents
  • TCollectionItem
    • TActorAnimation
    • TBitmapFontRange
    • TGLAbstractLibMaterial
      • TGLLibMaterial
      • TGLLibMaterialEx
    • TGLBaseSoundSource
      • TGLSoundSource
    • TGLConsoleCommand
    • TGLContour
    • TGLEParticleMask
    • TGLGizmoExActionHistoryItem
    • TGLGizmoExObjectItem
    • TGLGizmoUndoItem
    • TGLGuiComponent
    • TGLGuiElement
    • TGLInterfacedCollectionItem
      • TGLMaterialMultiProxyMaster
      • TGLTextureSharingShaderMaterial
    • TGLMaterialLibraryItem
    • TGLMovementPath
    • TGLMultiProxyMaster
    • TGLNode
      • TGLLinesNode
      • TGLPipeNode
    • TGLPathNode
    • TGLPostShaderCollectionItem
    • TGLShaderItem
    • TGLShadowVolumeCaster
      • TGLShadowVolumeLight
      • TGLShadowVolumeOccluder
    • TGLSimpleNavigationKeyCombination
    • TGLSLTextureEmitterItem
    • TGLSoundSample
    • TGLStaticImposterBuilderCorona
    • TGLTextureEmitterItem
    • TGLTextureExItem
    • TGLVertexAttribute
    • TLibArchive
    • TNGDJoint
    • TNGDSurfaceItem
    • TNGDSurfacePair
    • TPFXLifeColor
    • TSkyDomeBand
    • TSkyDomeStar
    • TTimeEvent
  • TComponent
    • TApplicationFileIO
    • TAsyncTimer
    • TAVIRecorder
    • TCollisionManager
    • TCUDAHandlesMaster
      • TCUDAComponent
        • TCUDAFFTPlan
        • TCUDAFunction
        • TCUDAGraphicResource
          • TCUDAGLGeometryResource
          • TCUDAGLImageResource
        • TCUDAMemData
        • TCUDAModule
        • TCUDATexture
        • TCUDAUniform
          • TCUDAConstant
          • TCUDAFuncParam
        • TGLSCUDA
    • TGLBaseAnimationControler
      • TGLAnimationControler
    • TGLBasePerlin
      • TGL1DPerlin
      • TGL2DPerlin
    • TGLCadencer
    • TGLCameraController
    • TGLComponent
      • TGLCadenceAbleComponent
        • TGLAbstractMaterialLibrary
          • TGLMaterialLibrary
          • TGLMaterialLibraryEx
        • TGLFireFXManager
        • TGLSoundManager
          • TGLSMBASS
          • TGLSMFMOD
          • TGLSMOpenAL
          • TGLSMWaveOut
        • TGLThorFXManager
        • TGLUpdateAbleComponent
          • TGLCoordinatesUpdateAbleComponent
            • TGLBaseSceneObject
              • TGLAnimatedSprite
              • TGLBaseGuiObject
                • TGLBaseComponent
                  • TGLBaseControl
                    • TGLBaseFontControl
                      • TGLBaseTextControl
                        • TGLFocusControl
                          • TGLAdvancedLabel
                          • TGLButton
                          • TGLCustomControl
                          • TGLEdit
                          • TGLPopupMenu
                          • TGLScrollbar
                          • TGLStringGrid
                        • TGLForm
                        • TGLLabel
                    • TGLCheckBox
                    • TGLPanel
              • TGLCamera
                • TGLFile3DSCamera
              • TGLCustomAtmosphere
                • TGLAtmosphere
              • TGLCustomConsole
                • TGLConsole
              • TGLCustomFeedBackMesh
                • TGLFeedBackMesh
              • TGLCustomSceneObject
                • TGLImmaterialSceneObject
                  • TGLCameraInvariantObject
                    • TGLDummyCube
                    • TGLSkyBox
                    • TGLSkyDome
                      • TGLEarthSkyDome
                  • TGLDirectOpenGL
                  • TGLFlatText
                    • TGLGizmoExUIFlatText
                  • TGLHUDText
                    • TGLAbsoluteHUDText
                    • TGLResolutionIndependantHUDText
                  • TGLImposter
                  • TGLLineBase
                    • TGLNodedLines
                      • TGLLines
                        • TGLGizmoExUILines
                    • TGLXYZGrid
                  • TGLParticles
                  • TGLPoints
                  • TGLProjectedTextures
                  • TGLRenderPoint
                  • TGLShadowVolume
                  • TGLTilePlane
                  • TGLTree
                • TGLMotionBlur
                • TGLSceneObject
                  • TGLBaseMesh
                    • TGLActor
                      • TGLFile3DSActor
                    • TGLFreeForm
                      • TGLFile3DSFreeForm
                    • TGLPortal
                  • TGLCapsule
                  • TGLCube
                    • TGLGizmoPickCube
                    • TODERagdollCube
                  • TGLDodecahedron
                  • TGLFrustrum
                    • TGLGizmoExUIFrustrum
                  • TGLGameMenu
                  • TGLHeightField
                  • TGLIcosahedron
                  • TGLMesh
                    • TGLTrail
                  • TGLMirror
                  • TGLMultiProxy
                  • TGLPlane
                    • TGLShadowPlane
                  • TGLPolygonBase
                    • TGLPipe
                    • TGLPolygon
                      • TGLGizmoExUIPolygon
                    • TGLRevolutionSolid
                  • TGLQuadricObject
                    • TGLCylinderBase
                      • TGLAnnulus
                      • TGLArrowArc
                      • TGLArrowLine
                        • TGLGizmoExUIArrowLine
                      • TGLCone
                      • TGLCylinder
                    • TGLDisk
                      • TGLGizmoExUIDisk
                    • TGLSphere
                      • TGLGizmoExUISphere
                  • TGLSLProjectedTextures
                  • TGLSpaceText
                  • TGLSprite
                    • TGLHUDSprite
                      • TGLBlur
                  • TGLTeapot
                  • TGLTerrainRenderer
                  • TGLTextureEmitter
                  • TGLTorus
                    • TGLGizmoExUITorus
                    • TGLGizmoPickTorus
                  • TGLWaterPlane
                  • TMultiPolygonBase
                    • TGLExtrusionSolid
                    • TGLMultiPolygon
              • TGLFBORenderer
              • TGLFeedback
              • TGLLensFlare
              • TGLLightSource
                • TGLFile3DSLight
              • TGLMaterialMultiProxy
              • TGLParticleFXRenderer
              • TGLPostEffect
              • TGLPostShaderHolder
              • TGLProxyObject
                • TGLActorProxy
                • TGLColorProxy
                • TGLFreeFormProxy
                • TGLMaterialProxy
              • TGLSceneRootObject
              • TGLSLTextureEmitter
              • TGLTextureLensFlare
              • TGLZShadows
          • TGLCustomBitmapFont
            • TGLBitmapFont
            • TGLWindowsBitmapFont
          • TGLCustomCadencedComponent
            • TGLCadencedComponent
              • TGLParticleFXManager
                • TGLDynamicPFXManager
                  • TGLLifeColoredPFXManager
                    • TGLBaseSpritePFXManager
                      • TGLCustomSpritePFXManager
                      • TGLPerlinPFXManager
                      • TGLPointLightPFXManager
                    • TGLCustomPFXManager
                    • TGLLinePFXManager
                    • TGLPolygonPFXManager
          • TGLGuiLayout
          • TGLImposterBuilder
            • TGLDynamicImposterBuilder
            • TGLStaticImposterBuilder
          • TGLScene
          • TGLShader
            • TCustomCgShader
              • TCadencableCustomCgShader
                • TGLCustomCGBombShader
                  • TGLCgBombShader
              • TCgShader
              • TGLCustomCGPostTransformationShader
                • TGLCGPostTransformationShader
            • TGLBumpShader
            • TGLCelShader
            • TGLCustomShader
              • TGLCustomAsmShader
                • TGLAsmShader
                • TGLPhongShader
              • TGLCustomGLSLShader
                • TGLBaseCustomGLSLBumpShader
                  • TGLBaseCustomGLSLBumpShaderMT
                    • TGLCustomGLSLBumpShaderAM
                      • TGLSLBumpShaderAM
                    • TGLCustomGLSLBumpShaderMT
                      • TGLSLBumpShaderMT
                    • TGLCustomGLSLMLBumpShaderMT
                      • TGLSLMLBumpShaderMT
                  • TGLCustomGLSLBumpShader
                    • TGLSLBumpShader
                  • TGLCustomGLSLMLBumpShader
                    • TGLSLMLBumpShader
                • TGLBaseCustomGLSLDiffuseSpecular
                  • TGLBaseGLSLDiffuseSpecularShaderMT
                    • TGLCustomGLSLDiffuseSpecularShaderAM
                      • TGLSLDiffuseSpecularShaderAM
                    • TGLCustomGLSLDiffuseSpecularShaderMT
                      • TGLSLDiffuseSpecularShaderMT
                    • TGLCustomGLSLMLDiffuseSpecularShaderMT
                      • TGLSLMLDiffuseSpecularShaderMT
                  • TGLCustomGLSLDiffuseSpecularShader
                    • TGLSLDiffuseSpecularShader
                  • TGLCustomGLSLMLDiffuseSpecularShader
                    • TGLSLMLDiffuseSpecularShader
                • TGLCustomGLSLPostBlurShader
                  • TGLSLPostBlurShader
                • TGLSLShader
            • TGLCustomShaderCombiner
              • TGLShaderCombiner
            • TGLHiddenLineShader
            • TGLMultiMaterialShader
            • TGLOutlineShader
            • TGLTexCombineShader
            • TGLTextureSharingShader
            • TGLUserShader
          • TGLTimeEventsMGR
    • TGLDCEManager
    • TGLEParticleMasksManager
    • TGLFPSMovementManager
    • TGLGizmo
    • TGLGizmoEx
    • TGLMaterialScripter
    • TGLNavigator
      • TGLSmoothNavigator
    • TGLNGDManager
    • TGLNonVisualViewer
      • TGLFullScreenViewer
      • TGLMemoryViewer
      • TGLSDLViewer
    • TGLODEJointList
    • TGLODEManager
    • TGLSArchiveManager
    • TGLScriptLibrary
    • TGLSCUDACompiler
    • TGLSCUDADevice
    • TGLSimpleNavigation
    • TGLSLanguage
    • TGLSLogger
    • TGLSmoothUserInterface
    • TGLSoundLibrary
    • TGLUserInterface
    • TGLVfsPAK
    • THeightDataSource
      • TGLBitmapHDS
      • TGLCustomHDS
      • TGLHeightTileFileHDS
      • TGLPerlinHDS
      • TGLTerrainBaseHDS
      • TGLTexturedHDS
      • THeightDataSourceFilter
        • TGLAsyncHDS
        • TGLBumpmapHDS
        • TGLShadowHDS
    • TJoystick
    • TObjectManager
    • TPlugInManager
    • TResourceManager
    • TScreenSaver
    • TSDLWindow
  • TComponentEditor
    • TGLGUILayoutEditor
    • TGLSceneEditor
    • TGLSceneViewerEditor
    • TGLSCUDACompilerEditor
    • TGLSCUDAEditor
    • TReuseableDefaultEditor
      • TGLMaterialLibraryEditor
      • TGLSArchiveManagerEditor
  • TCustomControl
    • TGLSMemoAbstractScrollableObject
      • TGLSCustomMemo
        • TGLSMemo
        • TGLSSynHiMemo
  • TDelphiWebScriptII
    • TGLDelphiWebScriptII
  • Tdws2UnitComponent
    • Tdws2ClassesUnit
    • Tdws2GLSceneUnit
    • Tdws2OpenGLUnit
    • Tdws2VectorGeometryUnit
  • TEvent
    • TFinishTaskEvent
  • TFileDescPascalUnitWithResource
    • TGLSceneBaseFileDescriptor
      • TGLSceneExtendedFileDescriptor
      • TGLSceneSimpleFileDescriptor
  • TForm
    • TGLSceneEditorForm
    • TGLSceneForm
    • TGLSCUDAEditorForm
    • TGLShaderEditor
    • TGUISkinEditor
    • TInfoForm
    • Tlayouts_form
    • TLibMaterialPicker
    • TMaterialEditorForm
    • TPlugInManagerPropForm
    • TShaderUniformEditor
    • TVectorEditorForm
    • TXCollectionEditor
  • TFrame
    • TRColorEditor
    • TRFaceEditor
    • TRMaterialPreview
    • TRTextureEdit
    • TRTrackBarEdit
  • TGLBitmap
    • TDDSImage
    • THDRImage
    • TO3TCImage
    • TTGAImage
  • TList
    • TBodyList
    • TCollisionStates
    • TDXNode
      • TDXFrame
      • TDXMaterialList
      • TDXMesh
    • TEdgeList
    • TFaceList
    • TFontManager
    • TGeomList
    • TGLColorManager
    • TGLInitializableObjectList
    • TGLNGDBehaviourList
    • TGLSMemoUndoList
    • TGLSoundFileFormatsList
    • TLWChunkList
    • TMS3DCommentList
    • TStyleList
    • TVerletConstraintList
    • TVerletEdgeList
    • TVerletForceList
    • TVerletNodeList
    • TVertexWeightList
  • TObject
    • CUDAContextManager
    • TAbstractMultitextureCoordinator
      • TGLMultitextureCoordinator
    • TArchiveFileFormat
    • TB3DMaterial
    • TB3DNode
    • TB3DTexture
    • TBaseConnectivity
      • TConnectivity
        • TFaceGroupConnectivity
      • TGLBaseMeshConnectivity
    • TBoneMatrixObj
    • TBSPClusterVisibility
    • TCgParameter
    • TCollisionState
    • TContactPoint
    • TCubicSpline
    • TCUDAContext
    • TCUDAModuleInfo
    • TDXFile
    • TECPlane
    • TEdge
    • TFace
    • TFaceExtractor
      • TEdgeDetector
    • TFile3DS
    • TFileB3D
    • TFileGLA
    • TFileGLM
    • TFileMD2
    • TFileMD3
    • TFileNMF
    • TGLAbstractMemoObject
      • TGLSMemoScrollBar
    • TGLASEFace
    • TGLASEFaceList
    • TGLASEMaterial
    • TGLASEMaterialList
    • TGLASEMeshObject
    • TGLBasePerlinOctav
      • TGL2DPerlinOctav
    • TGLBaseSelectTechnique
      • TGLSelectRenderModeTechnique
    • TGLCameraJob
      • TGLMoveToPosJob
      • TGLOrbitToPosAdvJob
        • TGLSmoothOrbitToPosAdvJob
      • TGLOrbitToPosJob
        • TGLSmoothOrbitToPos
      • TGLZoomToDistanceJob
    • TGLCanvas
    • TGLContext
      • TGLScreenControlingContext
        • TGLSDLContext
      • TGLWin32Context
        • TGLWidgetContext
    • TGLContextHandle
      • TGLARBProgramHandle
        • TGLARBFragmentProgramHandle
        • TGLARBGeometryProgramHandle
        • TGLARBVertexProgramHandle
      • TGLBufferObjectHandle
        • TGLPackPBOHandle
        • TGLTextureBufferHandle
        • TGLTransformFeedbackBufferHandle
        • TGLUniformBufferHandle
        • TGLUnpackPBOHandle
        • TGLVBOHandle
          • TGLVBOArrayBufferHandle
          • TGLVBOElementArrayHandle
      • TGLFramebufferHandle
      • TGLListHandle
      • TGLQueryHandle
        • TGLBooleanOcclusionQueryHandle
        • TGLOcclusionQueryHandle
        • TGLPrimitiveQueryHandle
        • TGLTimerQueryHandle
      • TGLRenderbufferHandle
      • TGLSamplerHandle
      • TGLSLHandle
        • TGLProgramHandle
        • TGLShaderHandle
          • TGLFragmentShaderHandle
          • TGLGeometryShaderHandle
          • TGLTessControlShaderHandle
          • TGLTessEvaluationShaderHandle
          • TGLVertexShaderHandle
      • TGLTextureHandle
      • TGLVertexArrayHandle
      • TGLVirtualHandle
        • TGLVirtualHandleTransf
    • TGLContextManager
    • TGLCustomShaderParameter
      • TGLAsmShaderParameter
      • TGLSLShaderParameter
    • TGLExtensionsAndEntryPoints
    • TGLFrameBuffer
    • TGLRenderbuffer
      • TGLDepthRBO
      • TGLStencilRBO
    • TGLROAMPatch
    • TGLSilhouette
    • TGLSMemoGutter
    • TGLSMemoUndo
      • TGLSMemoDelCharUndo
      • TGLSMEmoDelLineUndo
      • TGLSMemoInsCharUndo
      • TGLSMemoPasteUndo
      • TGLSMemoSelUndo
        • TGLSMemoDeleteBufUndo
    • TGLStateCache
    • TGLTextureImageEditor
      • TGLBlankTIE
      • TGLPersistentTIE
      • TGLPicFileTIE
      • TGLProcTextureNoiseTIE
    • TGLTransformation
    • TGLTreeBranch
    • TGLTreeBranches
    • TGLTreeBranchNoise
    • TGLTreeLeaves
    • THeightTileFile
    • TImposter
      • TStaticImposter
    • TKeyFramer
    • TLanguage
      • TLanguageExt
    • TLineProp
    • TLogSession
    • TLWContentDir
    • TLWObjectFile
    • TMaterialList
    • TMD3TagList
    • TMS3DGroup
    • TObjectList
      • TGLCameraJobList
    • TOCTFile
    • TOctree
    • TODERagdollWorld
    • TPerlin3DNoise
    • TPickRecord
    • TQ3BSP
    • TRagdollJoint
      • TODERagdollDummyJoint
      • TODERagdollHingeJoint
        • TODERagdollUniversalJoint
    • TRasterFileFormat
    • TSectorNode
      • TSPOctreeNode
        • TSPQuadtreeNode
    • TVectorFileFormat
    • TVerletConstraint
      • TVerletDualConstraint
        • TVCSlider
        • TVCStick
      • TVerletGlobalConstraint
        • TVerletGlobalFrictionConstraint
          • TVCCylinder
          • TVerletGlobalFrictionConstraintSP
            • TVCFloor
              • TVCHeightField
            • TVerletGlobalFrictionConstraintBox
              • TVCCube
            • TVerletGlobalFrictionConstraintSphere
              • TVCCapsule
              • TVCSphere
      • TVerletGroupConstraint
        • TVCRigidBody
    • TVerletForce
      • TVerletDualForce
        • TVFSpring
      • TVerletGlobalForce
        • TVFAirResistance
        • TVFGravity
      • TVerletGroupForce
    • TVerletHair
    • TVerletWorld
    • TVirtualReader
      • TBinaryReader
      • TTextReader
    • TVirtualWriter
      • TBinaryWriter
      • TTextWriter
    • TVRMLNode
      • TVRMLIntegerArray
      • TVRMLMaterial
      • TVRMLShapeHints
      • TVRMLSingleArray
      • TVRMLTransform
      • TVRMLUse
    • TVRMLParser
    • TZCustomBuffer
      • TZCompressionBuffer
      • TZDecompressionBuffer
  • TOwnedCollection
    • TGLAbstractLibMaterials
      • TGLLibMaterials
      • TGLLibMaterialsEx
    • TGLGizmoExActionHistoryCollection
    • TGLGizmoExObjectCollection
    • TGLGizmoUndoCollection
    • TGLGuiComponentList
    • TGLGuiElementList
    • TGLMaterialLibraryItems
    • TGLMaterialMultiProxyMasters
    • TGLMovementPaths
    • TGLMultiProxyMasters
    • TGLNodes
      • TGLContourNodes
      • TGLLinesNodes
        • TGLPipeNodes
    • TGLPathNodes
    • TGLPostShaderCollection
    • TGLShaderItems
    • TGLShadowVolumeCasters
    • TGLSimpleNavigationKeyCombinations
    • TGLStaticImposterBuilderCoronas
    • TGLTextureSharingShaderMaterials
    • TGLVertexAttributes
    • TLibArchives
    • TNotifyCollection
      • TGLContours
    • TPFXLifeColors
  • TPersistent
    • TCharStyle
    • TCUDADevice
    • TDisplayOptions
    • TGLConsoleControls
    • TGLFullScreenVideoMode
    • TGLGizmoRayCastHitData
    • TGLInterfacedPersistent
      • TGLUpdateAbleObject
        • TCgProgram
          • TCgFragmentProgram
          • TCgVertexProgram
        • TCUDADimensions
        • TDataFile
          • TBaseArchive
            • TPAKArchive
            • TZLibArchive
          • TGLBaseImage
            • TGLBMPImage
            • TGLDDSImage
            • TGLHDRImage
            • TGLImage
            • TGLJPEGImage
            • TGLO3TCImage
            • TGLPGMImage
            • TGLPNGImage
            • TGLTGAImage
          • TGLSoundFile
            • TGLMP3File
            • TGLWAVFile
          • TVectorFile
            • TGL3DSVectorFile
            • TGLASEVectorFile
            • TGLB3DVectorFile
            • TGLGLAVectorFile
            • TGLGLMVectorFile
            • TGLGLSMVectorFile
            • TGLGTSVectorFile
            • TGLLMTSVectorFile
            • TGLLWOVectorFile
            • TGLMD2VectorFile
            • TGLMD3VectorFile
            • TGLMD5VectorFile
            • TGLMDCVectorFile
            • TGLMS3DVectorFile
            • TGLNMFVectorFile
            • TGLNurbsVectorFile
            • TGLOBJVectorFile
            • TGLOCTVectorFile
            • TGLPLYVectorFile
            • TGLQ3BSPVectorFile
            • TGLSMDVectorFile
            • TGLSTLVectorFile
            • TGLTINVectorFile
            • TGLVRMLVectorFile
            • TGLXVectorFile
        • TGLAbstractShaderUniform
          • TGLShaderUniform
            • TGLShaderUniformDSA
            • TGLShaderUniformTexture
        • TGLBlendingParameters
        • TGLColor
        • TGLCustomCoordinates
          • TGLCoordinates2
          • TGLCoordinates3
          • TGLCoordinates4
        • TGLDamping
        • TGLDepthProperties
        • TGLFaceProperties
        • TGLFlareGradient
        • TGLFogEnvironment
        • TGLLibMaterialProperty
          • TGLBaseShaderModel
            • TGLShaderModel3
            • TGLShaderModel4
            • TGLShaderModel5
          • TGLFixedFunctionProperties
          • TGLMultitexturingProperties
          • TGLTextureProperties
        • TGLLineSettings
        • TGLMaterial
        • TGLPointParameters
        • TGLSamplingScale
        • TGLSceneBuffer
        • TGLTexture
        • TGLTextureImage
          • TGLBlankImage
            • TGLDynamicTextureImage
          • TGLCompositeImage
          • TGLCubeMapImage
          • TGLMultisampleImage
          • TGLPictureImage
            • TGLPersistentImage
            • TGLPicFileImage
          • TGLProcTextureNoise
        • TGLTextureSwizzling
        • THeightData
        • TVertexList
      • TXCollectionItem
        • TGLBaseBehaviour
          • TGLBehaviour
            • TGLBAcceleration
            • TGLBCollision
            • TGLBFPSMovement
            • TGLBInertia
            • TGLBSoundEmitter
            • TGLDCEDynamic
            • TGLDCEStatic
            • TGLDWS2ActiveBehaviour
            • TGLMovement
            • TGLNGDBehaviour
              • TGLNGDDynamic
              • TGLNGDStatic
            • TGLODEBehaviour
              • TGLODECustomCollider
                • TGLODEHeightField
              • TGLODEDynamic
              • TGLODEStatic
          • TGLObjectEffect
            • TGLObjectAfterEffect
            • TGLObjectPostEffect
              • TGLBFireFX
              • TGLBThorFX
              • TGLParticleFXEffect
                • TGLSourcePFXEffect
            • TGLObjectPreEffect
              • TGLBExplosionFX
        • TGLBaseMaterialCollectionItem
          • TGLAbstractTexture
            • TGLFrameBufferAttachment
            • TGLTextureImageEx
          • TGLASMVertexProgram
          • TGLShaderEx
          • TGLTextureCombiner
          • TGLTextureSampler
        • TGLMapCollectionItem
        • TGLNavigatorSmoothChangeItem
          • TGLNavigatorSmoothChangeSingle
          • TGLNavigatorSmoothChangeVector
        • TGLScriptBase
          • TGLScriptDWS2
          • TGLScriptPython
        • TODEElementBase
          • TODEElementBox
          • TODEElementCapsule
          • TODEElementCylinder
          • TODEElementPlane
          • TODEElementSphere
          • TODEElementTriMesh
        • TODEJointBase
          • TODEJointBall
          • TODEJointFixed
          • TODEJointHinge
          • TODEJointHinge2
          • TODEJointSlider
          • TODEJointUniversal
        • TSpriteAnimation
        • TSpriteAnimFrame
    • TGLNavigatorAbstractParameters
      • TGLNavigatorAdjustDistanceParameters
      • TGLNavigatorAdjustDistanceParametersEx
    • TGLNavigatorGeneralParameters
    • TGLNavigatorInertiaParameters
    • TGLNavigatorMoveAroundParameters
    • TGLOwnedPersistent
    • TGLShaderProgram
      • TGLFragmentProgram
      • TGLGeometryProgram
      • TGLVertexProgram
    • TGLSoundSampling
    • TGLTextAdjust
    • TGLzBuffer
    • TLWChunk
      • TLWParentChunk
        • TLWClip
        • TLWLayr
        • TLWPnts
        • TLWPols
        • TLWSurf
      • TLWPTag
      • TLWSubChunk
      • TLWTags
      • TLWVMap
    • TNGDDebugOption
    • TNGDJointKinematicController
    • TNGDJointPivot
      • TNGDJointBallAndSocket
      • TNGDJointPin
        • TNGDJointHinge
        • TNGDJointPin2
        • TNGDJointSlider
    • TODECollisionSurface
    • TODEJointParams
    • TPersistentObject
      • TBaseList
        • T4ByteList
        • TBaseVectorList
          • TAffineVectorList
          • TQuaternionList
          • TTexPointList
          • TVectorList
        • TByteList
        • TDoubleList
        • TIntegerList
        • TLongWordList
        • TSingleList
      • TBaseMeshObject
        • TMeshMorphTarget
        • TMeshObject
          • TBSPMeshObject
          • TMOParametricSurface
          • TMorphableMeshObject
            • TGLFile3DSDummyObject
              • TGLFile3DSCameraObject
              • TGLFile3DSMeshObject
              • TGLFile3DSOmniLightObject
                • TGLFile3DSSpotLightObject
            • TSectorMeshObject
            • TSkeletonMeshObject
      • TBaseSpacePartition
        • TLeavedSpacePartition
          • TSectoredSpacePartition
            • TOctreeSpacePartition
            • TQuadtreeSpacePartition
      • TDXMaterial
      • TFaceGroup
        • TFGBezierSurface
        • TFGVertexIndexList
          • TFGBSPNode
          • TFGIndexTexCoordList
          • TFGVertexNormalTexIndexList
            • TFGPolygon
              • TFGPortalPolygon
      • TGLFile3DSAnimationKeyList
      • TGLFile3DSAnimationKeys
        • TGLFile3DSColorAnimationKeys
        • TGLFile3DSLightHotSpotAnimationKeys
        • TGLFile3DSPositionAnimationKeys
        • TGLFile3DSRollAnimationKeys
        • TGLFile3DSRotationAnimationKeys
        • TGLFile3DSScaleAnimationKeys
        • TGLFile3DSSpotLightCutOffAnimationKeys
        • TTGLFile3DSPositionAnimationKeys
      • TGLParticle
        • TGLLineParticle
      • TGLParticleList
      • TGLRagdoll
        • TODERagdoll
      • TGLTiledArea
      • TGLTiledAreaRow
      • TPersistentObjectList
        • TArchiveFileFormatsList
        • TFaceGroups
        • TGLPickList
        • TMeshMorphTargetList
        • TMeshObjectList
          • TPortalMeshObjectList
        • TPolygonList
        • TRagdollBoneList
          • TRagdollBone
            • TODERagdollBone
        • TRasterFileFormatsList
        • TSkeletonBoneList
          • TSkeletonBone
          • TSkeletonRootBoneList
        • TSkeletonColliderList
        • TSkeletonFrameList
        • TSpacePartitionLeafList
        • TVectorFileFormatsList
      • TSkeleton
      • TSkeletonCollider
        • TSCODEBase
          • TSCODEBox
          • TSCODECCylinder
          • TSCODESphere
        • TSCVerletBase
          • TSCVerletCapsule
          • TSCVerletSphere
      • TSkeletonFrame
      • TSpacePartitionLeaf
        • TSceneObj
        • TVerletEdge
        • TVerletNode
          • TGLVerletNode
          • TMeshObjectVerletNode
    • TSpriteAnimMargins
    • TXCollection
      • TGLBehaviours
      • TGLMapCollection
      • TGLMatLibComponents
      • TGLNavigatorSmoothChangeItems
      • TGLObjectEffects
      • TGLScripts
      • TODEElements
      • TODEJoints
      • TSpriteAnimationList
      • TSpriteAnimFrameList
  • TProjectDescriptor
    • TGLSceneBaseFormDescriptor
      • TGLSceneExtendedFormDescriptor
      • TGLSceneSimpleFormDescriptor
  • TPropertyEditor
    • TResolutionProperty
    • TUniformAutoSetProperty
  • TPSPlugin
    • TPSImport_ApplicationFileIO
    • TPSImport_GLStrings
    • TPSImport_GLUtils
    • TPSImport_PersistentClasses
    • TPSImport_VectorGeometry
    • TPSImport_VectorLists
    • TPSImport_VectorTypes
    • TPSImport_XCollection
  • TPythonEngine
    • TGLPythonEngine
  • TStream
    • TCustomZStream
      • TZCompressionStream
      • TZDecompressionStream
  • TStringList
    • TGLConsoleStringList
    • TGLMTLFile
    • TGLSMemoStringList
    • TGLSMemoStrings
    • TPlugInList
  • TStringProperty
    • TAsmProgFileProperty
    • TGLAnimationNameProperty
    • TGLLibMaterialNameProperty
    • TGLMaterialComponentNameProperty
      • TGLLibAsmProgNameProperty
      • TGLLibAttachmentNameProperty
      • TGLLibCombinerNameProperty
      • TGLLibSamplerNameProperty
      • TGLLibShaderNameProperty
      • TGLLibTextureNameProperty
    • TGLSCUDACompilerSourceProperty
    • TGLSCUDADeviceProperty
    • TPictureFileProperty
    • TShaderFileProperty
    • TSoundNameProperty
  • TThread
    • THeightDataThread
      • TGLAsyncHDThread
      • TGLPerlinHDSThread
    • TLogBufferFlushThread
    • TLogCheckSizeThread
  • TWin32WSForm
    • TGLSOpenGLForm
  • TWin32WSWinControl
    • TGLSOpenGLControl
  • TWinControl
    • TGLSceneViewer
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:48


GLScene v.1.1.2: All Classes, Interfaces, Objects and Records

All Classes, Interfaces, Objects and Records

Name | Unit | Description
BASS_3DVECTOR Bass
BASS_CHANNELINFO Bass
BASS_FXCHORUS Bass
BASS_FXCOMPRESSOR Bass
BASS_FXDISTORTION Bass
BASS_FXECHO Bass
BASS_FXFLANGER Bass
BASS_FXGARGLE Bass
BASS_FXI3DL2REVERB Bass
BASS_FXPARAMEQ Bass
BASS_FXREVERB Bass
BASS_INFO Bass
BASS_PLUGINFORM Bass
BASS_PLUGININFO Bass
BASS_RECORDINFO Bass
BASS_SAMPLE Bass
CUDAContextManager GLSCUDAContext
DXT3AlphaBlock DXTC
DXT5AlphaBlock DXTC
DXTColBlock DXTC
EDDSException DDSImage
EFilerException | PersistentClasses | Usually triggered when a filing error is detected.
EFilerException XCollection
EGLAtmosphereException GLAtmosphere
EGLCameraController GLCameraController
EGLCgBombShaderException GLCgBombShader
EGLCGShaderException GLCgShader
EGLConsoleException GLConsole
EGLContext GLContext
EGLCustomShaderException GLCustomShader
EGLFile3DS GLFile3DS
EGLImageUtils ImageUtils
EGLMotionBlurException GLBlur
EGLOBJFileError GLFileOBJ
EGLPostShaderHolderException GLPostEffects
EGLProxyException GLProxyObjects
EGLROAMException GLROAMPatch
EGLShader GLContext
EGLShaderException GLTexture
EGLSLBumpShaderException GLSLBumpShader
EGLSLDiffuseSpecularShaderException GLSLDiffuseSpecularShader
EGLSLShaderException GLSLShader
EGLUtilsException GLUtils
EInvalidArchiveFile GLSArchiveManager
EInvalidFileSignature | PersistentClasses | Triggered when file signature does not match.
EInvalidGraphic GLSJPG
EInvalidGraphicOperation GLSJPG
EInvalidRasterFile GLGraphics
EInvalidVectorFile GLVectorFileObjects
EOpenGLError OpenGL1x
EOpenGLError OpenGLAdapter
EPBuffer GLContext
ESDLError GLSDLWindow
ETexture GLTexture
ETextureCombinerError GLTextureCombiners
ETGAException TGA
EZBufferException GLzBuffer
EZCompressionError GLSZLibEx
EZDecompressionError GLSZLibEx
EZLibError GLSZLibEx
FTC_CMapCacheRec_ LIBFREETYPE
FTC_ImageCacheRec_ LIBFREETYPE
FTC_ImageTypeRec_ LIBFREETYPE
FTC_ManagerRec_ LIBFREETYPE
FTC_NodeRec_ LIBFREETYPE
FTC_SBitCacheRec_ LIBFREETYPE
FTC_SBitRec_ LIBFREETYPE
FTC_ScalerRec_ LIBFREETYPE
FT_BBox LIBFREETYPE
FT_Bitmap LIBFREETYPE
FT_Bitmap_Size LIBFREETYPE
FT_CharmapRec_ LIBFREETYPE
FT_FaceRec_ LIBFREETYPE
FT_Generic LIBFREETYPE
FT_GlyphRec_ LIBFREETYPE
FT_GlyphSlotRec_ LIBFREETYPE
FT_Glyph_ClassRec_ LIBFREETYPE
FT_Glyph_Metrics LIBFREETYPE
FT_LibraryRec_ LIBFREETYPE
FT_ListNodeRec_ LIBFREETYPE
FT_ListRec_ LIBFREETYPE
FT_Matrix LIBFREETYPE
FT_MemoryRec_ LIBFREETYPE
FT_MM_Axis LIBFREETYPE
FT_MM_Var LIBFREETYPE
FT_ModuleRec_ LIBFREETYPE
FT_Multi_Master LIBFREETYPE
FT_Open_Args LIBFREETYPE
FT_OutlineRec_ LIBFREETYPE
FT_Outline_Funcs LIBFREETYPE
FT_Parameter LIBFREETYPE
FT_RasterRec_ LIBFREETYPE
FT_Raster_Funcs LIBFREETYPE
FT_Raster_Params LIBFREETYPE
FT_RendererRec_ LIBFREETYPE
FT_Renderer_Class LIBFREETYPE
FT_SfntName LIBFREETYPE
FT_SizeRec_ LIBFREETYPE
FT_Size_Metrics LIBFREETYPE
FT_Size_RequestRec_ LIBFREETYPE
FT_Span LIBFREETYPE
FT_StreamDesc LIBFREETYPE
FT_StreamRec_ LIBFREETYPE
FT_StrokerRec_ LIBFREETYPE
FT_Subglyph LIBFREETYPE
FT_Var_Axis LIBFREETYPE
FT_Var_Named_Style LIBFREETYPE
FT_Vector LIBFREETYPE
FT_WinFNT_HeaderRec LIBFREETYPE
IAVIEditStream GLSVfw
IAVIFile GLSVfw
IAVIStream GLSVfw
IAVIStreaming GLSVfw
IGetFrame GLSVfw
IGLCoordinatesUpdateAble GLCoordinates
IGLInitializable | GLScene | Interface to objects that need initialization<p>
IGLMaterialLibrarySupported GLMaterial
IGLNotifyAble BaseClasses
IGLPostShader | GLCustomShader | Used in the TGLPostShaderHolder component.
IGLProgessAble BaseClasses
IGLShaderDescription | GLCustomShader | This interface describes user shaders, in order to be able to access them via a unified interface. If user shader does not support some option, don't raise an axception, just ignore it.
IGLTextureNotifyAble GLTexture
IPersistentObject | PersistentClasses | Interface for persistent objects.<p> This interface does not really allow polymorphic persistence, but is rather intended as a way to unify persistence calls for iterators.
IShaderParameter GLSLParameter
jmp_buf LIBPNG
jpeg_common_struct GLSJPG
jpeg_component_info GLSJPG
jpeg_compress_struct GLSJPG
jpeg_decompress_struct GLSJPG
jpeg_destination_mgr GLSJPG
jpeg_error_mgr GLSJPG
jpeg_marker_reader GLSJPG
jpeg_memory_mgr GLSJPG
jpeg_progress_mgr GLSJPG
jpeg_source_mgr GLSJPG
JQUANT_TBL GLSJPG
NewtonHingeSliderUpdateDesc NewtonImport
NewtonJointRecord NewtonImport
NewtonUserMeshCollisionCollideDesc NewtonImport
NewtonUserMeshCollisionRayHitDesc NewtonImport
NewtonWorldConvexCastReturnInfo NewtonImport
png_color | LIBPNG | Three color definitions. The order of the red, green, and blue, (and the exact size) is not important, although the size of the fields need to be png_byte or png_uint_16 (as defined below).
png_color_16 LIBPNG
png_color_8 LIBPNG
png_info LIBPNG
png_row_info LIBPNG
png_sPLT_entry LIBPNG
png_sPLT_t LIBPNG
png_struct LIBPNG
png_text LIBPNG
png_time LIBPNG
png_unknown_chunk | LIBPNG | png_unknown_chunk is a structure to hold queued chunks for which there is no specific support. The idea is that we can use this to queue up private chunks for output even though the library doesn't actually know about their semantics.
PS_FontInfoRec_ LIBFREETYPE
PS_PrivateRec_ LIBFREETYPE
SInt64 GLSDL
T4ByteData VectorLists
T4ByteList | VectorLists | A list of T4ByteData.<p>
TAABB GeometryBB
TAbstractMultitextureCoordinator GLContext
TActorAnimation | GLVectorFileObjects | An actor animation sequence.<p> An animation sequence is a named set of contiguous frames that can be used for animating an actor. The referred frames can be either morph or skeletal frames (choose which via the Reference property).<p> An animation can be directly "played" by the actor by selecting it with SwitchAnimation, and can also be "blended" via a TGLAnimationControler.
TActorAnimations | GLVectorFileObjects | Collection of actor animations sequences.
TACubic3DS Types3DS
TAffineVectorList | VectorLists | A list of TAffineVector.<p> Similar to TList, but using TAffineVector as items.<p> The list has stack-like push/pop methods.
TANIMChunk TypesB3D
TApplicationFileIO | ApplicationFileIO | Allows specifying a custom behaviour for ApplicationFileIO's CreateFileStream.<p> The component should be considered a helper only, you can directly specify a function via the vAFIOCreateFileStream variable.<br> If multiple TApplicationFileIO components exist in the application, the last one created will be the active one.
TArchiveFileFormat GLSArchiveManager
TArchiveFileFormatsList GLSArchiveManager
TArg GLSDL
TAsmProgFileProperty GLSceneRegister
TAsyncTimer AsyncTimer
TAtmosphere3DS Types3DS
TAVICOMPRESSOPTIONS GLSVfw
TAVIFileInfoA GLSVfw
TAVIFileInfoW GLSVfw
TAVIINDEXENTRY GLSVfw
TAVIPALCHANGE GLSVfw
TAVIRecorder | GLAVIRecorder | Component to make it easy to record GLScene frames into an AVI file.
TAVIStreamHeader GLSVfw
TAVIStreamInfoA GLSVfw
TAVIStreamInfoW GLSVfw
TB3DChunk TypesB3D
TB3DMaterial FileB3D
TB3DNode FileB3D
TB3DTexture FileB3D
TBackground3DS Types3DS
TBallDelta GLSDL
TBaseArchive GLSArchiveManager
TBaseConnectivity GLSilhouette
TBaseList | VectorLists | Base class for lists, introduces common behaviours.
TBaseMeshObject | GLVectorFileObjects | A base class for mesh objects.<p> The class introduces a set of vertices and normals for the object but does no rendering of its own.
TBaseSpacePartition SpatialPartitioning
TBaseVectorList | VectorLists | Base class for vector lists, introduces common behaviours.
TBB3DChunk TypesB3D
TBinaryReader | PersistentClasses | Wraps a TReader-compatible reader.
TBinaryWriter | PersistentClasses | Wraps a TWriter-compatible writer.
TBitmap3DS Types3DS
TBitmapFontRange | GLBitmapFont | An individual character range in a bitmap font.<p> A range allows mapping ASCII characters to character tiles in a font bitmap, tiles are enumerated line then column (raster).
TBitmapFontRanges GLBitmapFont
TBlendedLerpInfo | GLVectorFileObjects | Small structure to store a weighted lerp for use in blending.
TBodyList ODEImport
TBONEChunk TypesB3D
TBoneMatrixObj | GLProxyObjects | An object containing the bone matrix for TGLActorProxy.<p>
TBoundBox Types3DS
TBRUSChunk TypesB3D
TBSPClusterVisibility GLBSP
TBSPCullingSphere GLBSP
TBSPFace Q3BSP
TBSPHeader Q3BSP
TBSphere GeometryBB
TBSPLeaf Q3BSP
TBSPLightmap Q3BSP
TBSPLump Q3BSP
TBSPMeshObject GLBSP
TBSPModel Q3BSP
TBSPNode Q3BSP
TBSPRenderContextInfo GLBSP
TBSPTexture Q3BSP
TBSPVertex Q3BSP
TBSPVisData Q3BSP
TByteList | VectorLists | A list of bytes.<p> Similar to TList, but using Byte as items.<p>
TCadencableCustomCgShader | GLCgShader | Allows to use a Cadencer, which is used for noise generation in many shaders.
TCamera3DS Types3DS
TCamRanges Types3DS
TCamRanges3DS Types3DS
TCAPDRIVERCAPS GLSVfw
TCAPINFOCHUNK GLSVfw
TCAPSTATUS GLSVfw
TCAPTUREPARMS GLSVfw
TCellPos GLSMemo
TCellSize GLSMemo
TCgFragmentProgram GLCgShader
TCgParameter | GLCgShader | Wrapper around a Cg parameter of the main program.
TCgProgram | GLCgShader | Wrapper around a Cg program.
TCgShader GLCgShader
TCgVertexProgram GLCgShader
TChannelTypeAndNum GLSCUDA
TCHANNEL_CAPS GLSVfw
TCharInfo GLBitmapFont
TCharStyle GLSMemo
TChunk3DS Types3DS
TChunkData Types3DS
TChunkList3DS Types3DS
TChunkListEntry3DS Types3DS
TClipRect GeometryBB
Tcl_image_format GLS_CL
TCollisionManager GLCollision
TCollisionState GLFPSMovement
TCollisionStates GLFPSMovement
TColor24 Types3DS
TColorEntry GLColor
TColorF Types3DS
TColTrackTag Types3DS
TCombinerCommand GLTextureCombiners
TCOMPVARS GLSVfw
TConnectivity GLSilhouette
TContactPoint GLFPSMovement
TContactPoint GLODECustomColliders
TCoronaTangentLookup GLImposter
TCUarray GLS_CUDA_API
TCubicSpline | Spline | 3D cubic spline handler class.<p> This class allows to describe and calculate values of a time-based, three-dimensionnal cubic spline.<p> Cubic spline pass through all given points and tangent on point N is given by the (N-1) to (N+1) vector.<p> Note : X, Y & Z are actually interpolated independently.
TCUcontext GLS_CUDA_API
TcudaArray GLS_CUDA_Runtime
TCudaChannelFormatDesc GLS_CUDA_Runtime
TCUDAComponent GLSCUDA
TCUDAConstant GLSCUDA
TCUDAConstantInfo GLSCUDAParser
TCUDAContext GLSCUDAContext
TCUDADevice GLSCUDAContext
TCudaDeviceProp GLS_CUDA_Runtime
TCUDADimensions GLSCUDAContext
TcudaExtent GLS_CUDA_Runtime
TCUDAFFTPlan GLSCUDAFFTPlan
TCUDAFuncArgInfo GLSCUDAParser
TcudaFuncAttributes GLS_CUDA_API
TCUDAFuncInfo GLSCUDAParser
TCUDAFuncParam GLSCUDA
TCUDAFunction GLSCUDA
TCUDAGLGeometryResource GLSCUDAGraphics
TCUDAGLImageResource GLSCUDAGraphics
TCUDAGraphicResource GLSCUDA
TCUDAHandlesMaster GLSCUDAContext
TcudaMemcpy3DParms GLS_CUDA_Runtime
TCUDAMemData GLSCUDA
TCUDAModule GLSCUDA
TCUDAModuleInfo GLSCUDAParser
TcudaPitchedPtr GLS_CUDA_Runtime
TcudaPos GLS_CUDA_Runtime
TCUDATexRefInfo GLSCUDAParser
TCUDATexture GLSCUDA
TCUDAUniform GLSCUDA
TCUDA_ARRAY3D_DESCRIPTOR GLS_CUDA_API
TCUDA_ARRAY_DESCRIPTOR GLS_CUDA_API
TCUDA_MEMCPY2D GLS_CUDA_API
TCUDA_MEMCPY3D GLS_CUDA_API
TCUdevprop GLS_CUDA_API
TCUDPPConfiguration GLS_CUDA_ParallelPrimitives
TCUevent GLS_CUDA_API
TCUfunction GLS_CUDA_API
TCUgraphicsResource GLS_CUDA_API
TCUmodule GLS_CUDA_API
TCustomCgShader GLCgShader
TCustomZStream GLSZLibEx
TCUstream GLS_CUDA_API
TCUtexref GLS_CUDA_API
TD3DMatrix VectorTypes
TD3DVector VectorTypes
TDatabase3DS Types3DS
TDataFile | ApplicationFileIO | Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.
TDCECollision GLDCE
TdContact ODEImport
TdContactGeom ODEImport
TDCueSettings3DS Types3DS
TDDPIXELFORMAT DXTC
TDDSHeader DXTC
TDDSImage DDSImage
TDDSURFACEDESC2 DXTC
TDDS_HEADER_DXT10 DXTC
TdGeomClass ODEImport
TdGeomSpaceData ODEImport
TDisplayOptions GLScreen
TDistanceCue Types3DS
TdJointFeedback ODEImport
TDlLocalShadow2 Types3DS
TDlSpotlight Types3DS
TdMass ODEImport
TdObject ODEImport
TDoubleList | VectorLists | A list of Double.<p> Similar to TList, but using Double as items.<p> The list has stack-like push/pop methods.
TDRAWDIBTIME GLSVfw
TdSurfaceParameters ODEImport
Tdws2ClassesUnit dws2Classes
Tdws2GLSceneUnit dws2GLScene
Tdws2OpenGLUnit dws2OpenGLAdapter
Tdws2VectorGeometryUnit dws2VectorGeometry
TdxAutoDisable ODEImport
TdxBody ODEImport
TdxContactParameters ODEImport
TdxDampingParameters ODEImport
TDXFile FileX
TDXFileHeader FileX
TDXFrame FileX
TdxGeom ODEImport
TdxHashSpace ODEImport
TdxHeightfieldData ODEImport
TdxJoint ODEImport
TdxJointAMotor ODEImport
TdxJointBall ODEImport
TdxJointFixed ODEImport
TdxJointGroup ODEImport
TdxJointHinge ODEImport
TdxJointHinge2 ODEImport
TdxJointLimitMotor ODEImport
TdxJointLMotor ODEImport
TdxJointNode ODEImport
TdxJointPiston ODEImport
TdxJointPlane2D ODEImport
TdxJointPR ODEImport
TdxJointSlider ODEImport
TdxJointUniversial ODEImport
TDXMaterial FileX
TDXMaterialList FileX
TDXMesh FileX
TDXNode FileX
TdxPosR ODEImport
TdxQuadTreeSpace ODEImport
TdxQuickStepParameters ODEImport
TdxSpace ODEImport
TdxTriMeshData ODEImport
TdxWorld ODEImport
TEaxBufferProperties openal
TEaxListenerProperties openal
TECCollider GLEllipseCollision
TECCollisionPacket GLEllipseCollision
TECContact GLEllipseCollision
TECFreeForm GLEllipseCollision
TECMovePack GLEllipseCollision
TECObjectInfo GLEllipseCollision
TECPlane GLEllipseCollision
TECTriangle GLEllipseCollision
TECTriMesh GLEllipseCollision
TEdge GLVerletClothify
TEdgeDetector GLVerletClothify
TEdgeList GLVerletClothify
TExtended80Rec PersistentClasses
TExtendedFrustum SpatialPartitioning
TFace | GLVerletClothify | Class that represents a face. This structure is not used for rendering, but for extracting info from meshes
TFace3DS Types3DS
TFaceArray Types3DS
TFaceExtractor | GLVerletClothify | Class that extracts faces from a GLBaseMesh
TFaceGroup | GLVectorFileObjects | Describes a face group of a TMeshObject.<p> Face groups should be understood as "a way to use mesh data to render a part or the whole mesh object".<p> Subclasses implement the actual behaviours, and should have at least one "Add" method, taking in parameters all that is required to describe a single base facegroup element.
TFaceGroupConnectivity GLBaseMeshSilhouette
TFaceGroups | GLVectorFileObjects | A list of TFaceGroup objects.
TFaceList | GLVerletClothify | List of faces
TFallTrackTag Types3DS
TFColor3DS Types3DS
TFGBezierSurface | GLParametricSurfaces | A 3d bezier surface implemented through facegroups. The ControlPointIndices is an index to control points stored in the MeshObject.Vertices affine vector list. Similarly the TexCoordIndices point to the owner MeshObject.TexCoords, one for each control point. CountU and CountV define the width and height of the surface. Resolution sets the detail level of the mesh evaluation. MinU, MaxU, MinV and MaxV define the region of the surface to be rendered, this is especially useful for blending with neighbouring patches.
TFGBSPNode GLBSP
TFGIndexTexCoordList | GLVectorFileObjects | Adds per index texture coordinates to its ancestor.<p> Per index texture coordinates allows having different texture coordinates per triangle, depending on the face it is used in.
TFGPolygon | GLPortal | A portal polygon.<p> This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.
TFGPortalPolygon | GLPortal | A portal polygon.<p> This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.
TFGVertexIndexList | GLVectorFileObjects | A face group based on an indexlist.<p> The index list refers to items in the mesh object (vertices, normals, etc.), that are all considered in sync, the render is obtained issueing the items in the order given by the vertices.<p>
TFGVertexNormalTexIndexList | GLVectorFileObjects | Adds normals and texcoords indices.<p> Allows very compact description of a mesh. The Normals ad TexCoords indices are optionnal, if missing (empty), VertexIndices will be used.
TFile3DS File3DS
TFileB3D FileB3D
TFileGLA FileGL2
TFileGLM FileGL2
TFileMD2 FileMD2
TFileMD3 FileMD3
TFileNMF FileNMF
TFileSection GLFilePAK
TFileSection GLFileZLIB
TFileSection GLVfsPAK
TFinishTaskEvent GLContext
TFireParticle GLFireFX
TFog Types3DS
TFogSettings3DS Types3DS
TFontEntry GLSpaceText
TFontManager GLSpaceText
TFovTrackTag Types3DS
TFrustum VectorGeometry
TFSoundReverbChannelProperties fmodtypes
TFSoundReverbProperties fmodtypes
TFSoundTOCTag fmodtypes
TFSoundVector fmodtypes
TFullPos GLSMemo
TGeomList ODEImport
TGL1DPerlin GLPerlin
TGL2DPerlin GLPerlin
TGL2DPerlinOctav GLPerlin
TGL3DSVectorFile | GLFile3DS | The 3DStudio vector file.<p> Uses an upgraded version if a 3DS import library by Mike Lischke.<p> (http://www.lishcke-online.de). A 3DS file may contain material information and require textures when loading.
TGLAbsoluteHUDText GLHUDObjects
TGLAbstractLibMaterial GLMaterial
TGLAbstractLibMaterials GLMaterial
TGLAbstractMaterialLibrary GLMaterial
TGLAbstractMemoObject GLSMemo
TGLAbstractShaderUniform GLMaterialEx
TGLAbstractTexture GLMaterialEx
TGLActiveAttrib GLSLShader
TGLActor | GLVectorFileObjects | Mesh class specialized in animated meshes.<p> The TGLActor provides a quick interface to animated meshes based on morph or skeleton frames, it is capable of performing frame interpolation and animation blending (via TGLAnimationControler components).
TGLActorProxy | GLProxyObjects | A proxy object specialized for Actors.<p>
TGLAdvancedLabel GLWindows
TGLAHeader FileGL2
TGLAnimatedSprite | GLAnimatedSprite | An animated version of the TGLSprite using offset texture coordinate animation.
TGLAnimationControler | GLVectorFileObjects | Controls the blending of an additionnal skeletal animation into an actor.<p> The animation controler allows animating an actor with several animations at a time, for instance, you could use a "run" animation as base animation (in TGLActor), blend an animation that makes the arms move differently depending on what the actor is carrying, along with an animation that will make the head turn toward a target.
TGLAnimationNameProperty GLSceneRegister
TGLAnnulus GLGeomObjects
TGLARBFragmentProgramHandle GLContext
TGLARBGeometryProgramHandle GLContext
TGLARBProgramHandle GLContext
TGLARBVertexProgramHandle GLContext
TGLArrowArc GLGeomObjects
TGLArrowLine GLGeomObjects
TGLASEFace GLFileASE
TGLASEFaceList GLFileASE
TGLASEFaceTexure GLFileASE
TGLASEFaceTexureChannels GLFileASE
TGLASEMaterial GLFileASE
TGLASEMaterialList GLFileASE
TGLASEMaterialTextureMap GLFileASE
TGLASEMaterialTextureMaps GLFileASE
TGLASEMeshObject GLFileASE
TGLASESmoothingGroups GLFileASE
TGLASESubMaterial GLFileASE
TGLASESubMaterialList GLFileASE
TGLASEVectorFile GLFileASE
TGLASkeleton FileGL2
TGLAsmShader GLAsmShader
TGLAsmShaderParameter GLAsmShader
TGLASMVertexProgram GLMaterialEx
TGLAsyncHDS GLAsyncHDS
TGLAsyncHDThread GLAsyncHDS
TGLAtmosphere GLAtmosphere
TGLB3DVectorFile GLFileB3D
TGLBAcceleration | GLBehaviours | Applies a constant acceleration to a TGLBInertia.<p>
TGLBaseAnimationControler | GLVectorFileObjects | Base class for skeletal animation control.<p>
TGLBaseBehaviour | GLScene | Base class for implementing behaviours in TGLScene.<p> Behaviours are regrouped in a collection attached to a TGLBaseSceneObject, and are part of the "Progress" chain of events. Behaviours allows clean application of time-based alterations to objects (movements, shape or texture changes...).<p> Since behaviours are implemented as classes, there are basicly two kinds of strategies for subclasses :<ul> <li>stand-alone : the subclass does it all, and holds all necessary data (covers animation, inertia etc.) <li>proxy : the subclass is an interface to and external, shared operator (like gravity, force-field effects etc.) </ul><br> Some behaviours may be cooperative (like force-fields affects inertia) or unique (e.g. only one inertia behaviour per object).<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function </ul>
TGLBaseComponent GLWindows
TGLBaseControl GLWindows
TGLBaseCustomGLSLBumpShader GLSLBumpShader
TGLBaseCustomGLSLBumpShaderMT GLSLBumpShader
TGLBaseCustomGLSLDiffuseSpecular | GLSLDiffuseSpecularShader | Abstract class.
TGLBaseFontControl GLWindows
TGLBaseGLSLDiffuseSpecularShaderMT | GLSLDiffuseSpecularShader | Abstract class.
TGLBaseGuiObject GLGui
TGLBaseImage GLGraphics
TGLBaseMaterialCollectionItem GLMaterialEx
TGLBaseMesh | GLVectorFileObjects | Base class for mesh objects.
TGLBaseMeshConnectivity GLBaseMeshSilhouette
TGLBasePerlin GLPerlin
TGLBasePerlinOctav GLPerlin
TGLBaseSceneObject | GLScene | Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.
TGLBaseSelectTechnique GLSelection
TGLBaseShaderModel GLMaterialEx
TGLBaseSoundSource | GLSound | Base class for origin of sound playback.
TGLBaseSpritePFXManager | GLParticleFX | Base class for sprite-based particles FX managers.<p> The particles are made of optionally centered single-textured quads.
TGLBaseTextControl GLWindows
TGLBCollision | GLCollision | Collision detection behaviour.<p> Allows an object to register to a TCollisionManager and be accounted for in collision-detection and distance calculation mechanisms.<p> An object may have multiple TGLBCollision, registered to multiple collision managers, however if multiple behaviours share the same manager, only one of them will be accounted for, others will be ignored.
TGLBehaviour | GLScene | Ancestor for non-rendering behaviours.<p> This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLObjectEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".
TGLBehaviours | GLScene | Holds a list of TGLBehaviour objects.<p> This object expects itself to be owned by a TGLBaseSceneObject.<p> As a TXCollection (and contrary to a TCollection), this list can contain objects of varying class, the only constraint being that they should all be TGLBehaviour subclasses.
TGLBExplosionFX GLExplosionFx
TGLBFireFX | GLFireFX | Fire special effect.<p> This effect works as a client of TFireFXManager
TGLBFPSMovement GLFPSMovement
TGLBInertia | GLBehaviours | Simple translation and rotation Inertia behaviour.<p> Stores translation and rotation speeds, to which you can apply accelerations.<p> Note that the rotation model is not physical, so feel free to contribute a "realworld" inertia class with realistic, axis-free, rotation inertia if this approximation does not suits your needs :).
TGLBitmapFont | GLBitmapFont | See TGLCustomBitmapFont.<p> This class only publuishes some of the properties.
TGLBitmapHDS GLHeightData
TGLBlankImage | GLTexture | A texture image with no specified content, only a size.<p> This texture image type is of use if the context of your texture is calculated at run-time (with a TGLMemoryViewer for instance).
TGLBlankTIE GLTextureImageEditors
TGLBlendingParameters GLMaterial
TGLBlur GLBlur
TGLBMPImage GLFileBMP
TGLBooleanOcclusionQueryHandle GLContext
TGLBox GLTypes
TGLBSoundEmitter | GLSound | A sound emitter behaviour, plug it on any object to make it noisy.<p> This behaviour is just an interface to a TGLSoundSource, for editing convenience.
TGLBThorFX GLThorFX
TGLBufferObjectHandle | GLContext | Manages a handle to a Buffer Object.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.<br>
TGLBumpmapHDS | GLBumpmapHDS | An Height Data Source that generates elevation bumpmaps automatically.<p> The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where bumpmaps will be placed.
TGLBumpShader | GLBumpShader | A generic bump shader.<p>
TGLButton GLWindows
TGLCadenceAbleComponent | BaseClasses | A base class describing the "cadenceing" interface.<p>
TGLCadencedComponent GLCadencer
TGLCadencer | GLCadencer | This component allows auto-progression of animation.<p> Basicly dropping this component and linking it to your TGLScene will send it real-time progression events (time will be measured in seconds) while keeping the CPU 100% busy if possible (ie. if things change in your scene).<p> The progression time (the one you'll see in you progression events) is calculated using (CurrentTime-OriginTime)*TimeMultiplier, CurrentTime being either manually or automatically updated using TimeReference (setting CurrentTime does NOT trigger progression).
TGLCamera | GLScene | Camera object.<p> This object is commonly referred by TGLSceneViewer and defines a position, direction, focal length, depth of view... all the properties needed for defining a point of view and optical characteristics.
TGLCameraController GLCameraController
TGLCameraInvariantObject | GLScene | Base class for camera invariant objects.<p> Camera invariant objects bypass camera settings, such as camera position (object is always centered on camera) or camera orientation (object always has same orientation as camera).
TGLCameraJob GLCameraController
TGLCameraJobList GLCameraController
TGLCanvas | GLCanvas | A simple Canvas-like interface for OpenGL.<p> This class implements a small "shell" for 2D operations in OpenGL, it operates over the current OpenGL context and provides methods for drawing lines, ellipses and points.<br> This class is typically used by creating an instance, using it for drawing, and freeing the instance. When drawing (0, 0) is the top left corner.<br> All coordinates are internally maintained with floating point precision.<p> Several states are cached and it is of primary importance not to invoke OpenGL directly throughout the life of an instance (at the cost of unespected behaviour).
TGLCapsule GLGeomObjects
TGLCelShader | GLCelShader | A generic cel shader.<p>
TGLCgBombShader GLCgBombShader
TGLCGPostTransformationShader CGPostTransformationShader
TGLCheckBox GLWindows
TGLColor | GLColor | Wraps an OpenGL color.
TGLColorManager GLColor
TGLColorProperty GLSceneRegister
TGLColorProxy | GLProxyObjects | A proxy object with its own color.<p> This proxy object can have a unique color. Note that multi-material objects (Freeforms linked to a material library f.i.) won't honour the color.
TGLComponent GLCrossPlatform
TGLCompositeImage GLCompositeImage
TGLCone GLGeomObjects
TGLConsole GLConsole
TGLConsoleCommand GLConsole
TGLConsoleCommandList GLConsole
TGLConsoleControls GLConsole
TGLConsoleStringList GLConsole
TGLContext | GLContext | Wrapper around an OpenGL rendering context.<p> The aim of this class is to offer platform-independant initialization, activation and management of OpenGL rendering context. The class also offers notifications event and error/problems detection.<br> This is a virtual abstract a class, and platform-specific subclasses must be used.<br> All rendering context share the same lists.
TGLContextHandle | GLContext | Wrapper around an OpenGL context handle.<p> This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TGLListHandle and TGLTextureHandle subclasses.
TGLContextManager | GLContext | Stores and manages all the TGLContext objects.<p>
TGLContextNotification GLContext
TGLContour GLMultiPolygon
TGLContourNodes GLMultiPolygon
TGLContours GLMultiPolygon
TGLCoordinates2 GLCoordinates
TGLCoordinates3 GLCoordinates
TGLCoordinates4 GLCoordinates
TGLCoordinatesProperty GLSceneRegister
TGLCoordinatesUpdateAbleComponent GLCoordinates
TGLCube GLObjects
TGLCubeMapImage | GLTexture | A texture image used for specifying and stroing a cube map.<p> Not unlike TGLPictureImage, but storing 6 of them instead of just one.<br> Saving & loading as a whole currently not supported.
TGLCustomAsmShader GLAsmShader
TGLCustomAtmosphere | GLAtmosphere | This class imitates an atmosphere around a planet.
TGLCustomBitmapFont | GLBitmapFont | Provides access to individual characters in a BitmapFont.<p> Only fixed-width bitmap fonts are supported, the characters are enumerated in a raster fashion (line then column).<br> Transparency is all or nothing, the transparent color being that of the top left pixel of the Glyphs bitmap.<p> Performance note: as usual, for best performance, you base font bitmap dimensions should be close to a power of two, and have at least 1 pixel spacing between characters (horizontally and vertically) to avoid artefacts when rendering with linear filtering.
TGLCustomCadencedComponent | GLCadencer | Adds a property to connect/subscribe to a cadencer.<p>
TGLCustomCGBombShader | GLCgBombShader | Just a good-looking shader.
TGLCustomCGPostTransformationShader CGPostTransformationShader
TGLCustomConsole | GLConsole | TGLCustomConsole
TGLCustomControl GLWindows
TGLCustomCoordinates GLCoordinates
TGLCustomFeedBackMesh GLSCUDAGraphics
TGLCustomGLSLBumpShader GLSLBumpShader
TGLCustomGLSLBumpShaderAM GLSLBumpShader
TGLCustomGLSLBumpShaderMT GLSLBumpShader
TGLCustomGLSLDiffuseSpecularShader GLSLDiffuseSpecularShader
TGLCustomGLSLDiffuseSpecularShaderAM GLSLDiffuseSpecularShader
TGLCustomGLSLDiffuseSpecularShaderMT GLSLDiffuseSpecularShader
TGLCustomGLSLMLBumpShader GLSLBumpShader
TGLCustomGLSLMLBumpShaderMT GLSLBumpShader
TGLCustomGLSLMLDiffuseSpecularShader | GLSLDiffuseSpecularShader | Note: probably LightCount should be replaced by LightSources, like in GLSLBumpShader.pas
TGLCustomGLSLMLDiffuseSpecularShaderMT GLSLDiffuseSpecularShader
TGLCustomGLSLPostBlurShader GLSLPostBlurShader
TGLCustomGLSLShader GLSLShader
TGLCustomHDS GLHeightData
TGLCustomPFXManager | GLParticleFX | A particles FX manager offering events for customization/experimentation.<p> This manager essentially surfaces the PFX methods as events, and is best suited when you have specific particles that don't fall into any existing category, or when you want to experiment with particles and later plan to wrap things up in a full-blown manager.<br> If the events aren't handled, nothing will be rendered.
TGLCustomSceneObject | GLScene | Extended base scene object class with a material property.<p> The material allows defining a color and texture for the object, see TGLMaterial.
TGLCustomShader | GLCustomShader | A pure abstract class, must be overriden.
TGLCustomShaderCombiner GLShaderCombiner
TGLCustomShaderParameter | GLCustomShader | Wrapper around a parameter of the main program.
TGLCustomSpritePFXManager | GLParticleFX | A sprite-based particles FX managers using user-specified code to prepare the texture.<p>
TGLCylinder GLGeomObjects
TGLCylinderBase GLGeomObjects
TGLDamping | GLBehaviours | Holds parameters for TGLScene basic damping model.<p> Damping is modeled by calculating a force from the speed, this force can then be transformed to an acceleration is you know the object's mass.<br> Formulas :<ul> <li>damping = constant + linear * Speed + quadratic * Speedˆ2 <li>accel = damping / Mass </ul> That's just basic physics :). A note on the components :<ul> <li>constant : use it for solid friction (will stop abruptly an object after decreasing its speed. <li>linear : linear friction damping. <li>quadratic : expresses viscosity. </ul>
TGLDCEDynamic GLDCE
TGLDCEManager GLDCE
TGLDCEStatic GLDCE
TGLDDSImage GLFileDDS
TGLDelphiWebScriptII | GLScriptDWS2 | This class only adds manager registration logic to the TDelphiWebScriptII class to enable the XCollection items (ie. TGLScriptDWS2) retain it's assigned compiler from design to run -time.
TGLDepthProperties GLMaterial
TGLDepthRBO GLFBO
TGLDirectOpenGL | GLScene | Provides a way to issue direct OpenGL calls during the rendering.<p> You can use this object to do your specific rendering task in its OnRender event. The OpenGL calls shall restore the OpenGL states they found when entering, or exclusively use the GLMisc utility functions to alter the states.<br>
TGLDisk GLGeomObjects
TGLDodecahedron | GLPolyhedron | A Dodecahedron.<p> The dodecahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.
TGLDummyCube GLObjects
TGLDWS2ActiveBehaviour GLDWS2Objects
TGLDynamicImposterBuilder GLImposter
TGLDynamicPFXManager | GLParticleFX | An abstract PFX manager for simple dynamic particles.<p> Adds properties and progress implementation for handling moving particles (simple velocity and const acceleration integration).
TGLDynamicTextureImage | GLDynamicTexture | Allows for fast updating of the texture at runtime.
TGLEarthSkyDome | GLSkydome | Render a skydome like what can be seen on earth.<p> Color is based on sun position and turbidity, to "mimic" atmospheric Rayleigh and Mie scatterings. The colors can be adjusted to render weird/extra-terrestrial atmospheres too.<p> The default slices/stacks values make for an average quality rendering, for a very clean rendering, use 64/64 (more is overkill in most cases). The complexity is quite high though, making a T&L 3D board a necessity for using TGLEarthSkyDome.
TGLEdit GLWindows
TGLEParticleMask GLEParticleMasksManager
TGLEParticleMasks GLEParticleMasksManager
TGLEParticleMasksManager GLEParticleMasksManager
TGLExtensionsAndEntryPoints OpenGLAdapter
TGLExtrusionSolid GLExtrusion
TGLFaceProperties | GLMaterial | Stores basic face lighting properties.<p> The lighting is described with the standard ambient/diffuse/emission/specular properties that behave like those of most rendering tools.<br> You also have control over shininess (governs specular lighting) and polygon mode (lines / fill).
TGLFBORenderer GLFBORenderer
TGLFeedback | GLFeedback | An object encapsulating the OpenGL feedback rendering mode.
TGLFeedBackMesh GLSCUDAGraphics
TGLFile3DSActor GLFile3DSSceneObjects
TGLFile3DSAnimationData | GLFile3DS | TGLFile3DSAnimationData. A record that holds all the information that is used during 3ds animation.
TGLFile3DSAnimationKeyList GLFile3DS
TGLFile3DSAnimationKeys GLFile3DS TGLFile3DSAnimationKeys.

An abstract class that describes how to interpolate animation keys.

TGLFile3DSCamera GLFile3DSSceneObjects
TGLFile3DSCameraObject | GLFile3DS | TGLFile3DSCameraObject. A 3ds-specific camera.
TGLFile3DSColorAnimationKeys GLFile3DS
TGLFile3DSDummyObject | GLFile3DS | TGLFile3DSDummyObject. A 3ds-specific TMorphableMeshObject.
TGLFile3DSFreeForm GLFile3DSSceneObjects
TGLFile3DSLight GLFile3DSSceneObjects
TGLFile3DSLightHotSpotAnimationKeys GLFile3DS
TGLFile3DSMeshObject | GLFile3DS | TGLFile3DSDummyObject. A 3ds-specific mesh object.
TGLFile3DSOmniLightObject | GLFile3DS | TGLFile3DSDummyObject. A 3ds-specific omni light.
TGLFile3DSPositionAnimationKeys GLFile3DS
TGLFile3DSRollAnimationKeys GLFile3DS
TGLFile3DSRotationAnimationKeys GLFile3DS
TGLFile3DSScaleAnimationKeys GLFile3DS
TGLFile3DSSpotLightCutOffAnimationKeys GLFile3DS
TGLFile3DSSpotLightObject | GLFile3DS | TGLFile3DSSpotLightObject. A 3ds-specific spot light.
TGLFireFXManager | GLFireFX | Fire special effect manager.<p> Defines the looks and behaviour of a particle system that can be made to look fire-like.
TGLFixedFunctionProperties GLMaterialEx
TGLFlareGradient | GLLensFlare | The actual gradients between two colors are, of course, calculated by OpenGL.<p> The start and end colors of a gradient are stored to represent the color of lens flare elements.
TGLFlatText | GLBitmapFont | A 2D text displayed and positionned in 3D coordinates.<p> The FlatText uses a character font defined and stored by a TGLBitmapFont component. Default character scale is 1 font pixel = 1 space unit.
TGLFocusControl GLWindows
TGLFogEnvironment | GLScene | Parameters for fog environment in a scene.<p> The fog descibed by this object is a distance-based fog, ie. the "intensity" of the fog is given by a formula depending solely on the distance, this intensity is used for blending to a fixed color.
TGLForm GLWindows
TGLFPSMovementManager GLFPSMovement
TGLFragmentProgram GLCustomShader
TGLFragmentShaderHandle | GLContext | Manages a handle to a Fragment Shader Object.
TGLFrameBuffer GLFBO
TGLFrameBufferAttachment GLMaterialEx
TGLFramebufferHandle | GLContext | Manages a handle to a Framebuffer Object (FBO). Framebuffer objects provide a way of drawing to rendering destinations other than the buffers provided to the GL by the window-system. One or more "framebuffer-attachable images" can be attached to a Framebuffer for uses such as: offscreen rendering, "render to texture" + "multiple render targets" (MRT). There are several types of framebuffer-attachable images: - The image of a renderbuffer object, which is always 2D. - A single level of a 1D texture, which is treated as a 2D image with a height of one. - A single level of a 2D or rectangle texture. - A single face of a cube map texture level, which is treated as a 2D image. - A single layer of a 1D or 2D array texture or 3D texture, which is treated as a 2D image. Additionally, an entire level of a 3D texture, cube map texture, or 1D or 2D array texture can be attached to an attachment point. Such attachments are treated as an array of 2D images, arranged in layers, and the corresponding attachment point is considered to be layered.
TGLFreeForm | GLVectorFileObjects | Container objects for a vector file mesh.<p> FreeForms allows loading and rendering vector files (like 3DStudio ".3DS" file) in GLScene. Meshes can be loaded with the LoadFromFile method.<p> A FreeForm may contain more than one mesh, but they will all be handled as a single object in a scene.
TGLFreeFormProxy | GLProxyObjects | A proxy object specialized for FreeForms.<p>
TGLFrustrum GLGeomObjects
TGLFullScreenVideoMode | GLSceneForm | Screen mode settings
TGLFullScreenViewer GLFullScreenViewer
TGLGameMenu | GLGameMenu | Classic game menu interface made of several lines.<p>
TGLGeometryProgram GLCustomShader
TGLGeometryShaderHandle | GLContext | Manages a handle to a Geometry Shader Object.
TGLGizmo GLGizmo
TGLGizmoEx GLGizmoEx
TGLGizmoExActionHistoryCollection GLGizmoEx
TGLGizmoExActionHistoryItem GLGizmoEx
TGLGizmoExObjectCollection GLGizmoEx
TGLGizmoExObjectItem GLGizmoEx
TGLGizmoExUIArrowLine GLGizmoEx
TGLGizmoExUIDisk GLGizmoEx
TGLGizmoExUIFlatText GLGizmoEx
TGLGizmoExUIFrustrum GLGizmoEx
TGLGizmoExUILines GLGizmoEx
TGLGizmoExUIPolygon GLGizmoEx
TGLGizmoExUISphere GLGizmoEx
TGLGizmoExUITorus GLGizmoEx
TGLGizmoPickCube GLGizmo
TGLGizmoPickTorus GLGizmo
TGLGizmoRayCastHitData GLGizmo
TGLGizmoUndoCollection GLGizmo
TGLGizmoUndoItem GLGizmo
TGLGLAVectorFile GLFileGL2
TGLGLMVectorFile GLFileGL2
TGLGLSMVectorFile | GLVectorFileObjects | GLSM (GLScene Mesh) vector file.<p> This corresponds to the 'native' GLScene format, and object persistence stream, which should be the 'fastest' of all formats to load, and supports all of GLScene features.
TGLGTSVectorFile | GLFileGTS | The GTS vector file (GNU Triangulated Surface library).<p> It is a simple text format, with indexed vertices. The first line contains the number of vertices, the number of edges and the number of faces separated by spaces.<br> Following lines contain the x/y/z coordinates of vertices, then the edges (two indices) and the faces (three indices).<br> http://gts.sourceforge.net/
TGLGuiComponent GLGui
TGLGuiComponentList GLGui
TGLGuiElement GLGui
TGLGuiElementList GLGui
TGLGuiLayout GLGui
TGLGUILayoutEditor GLSceneRegister
TGLHDRImage GLFileHDR
TGLHeightField GLGraph
TGLHeightTileFileHDS | GLHeightTileFileHDS | An Height Data Source for the HTF format.<p>
TGLHiddenLineShader GLHiddenLineShader
TGLHUDSprite GLHUDObjects
TGLHUDText GLHUDObjects
TGLIcosahedron | GLPolyhedron | A Icosahedron.<p> The icosahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.
TGLImage | GLGraphics | Contains and manipulates a 32 bits (24+8) bitmap.<p> This is the base class for preparing and manipulating textures in GLScene, this function does not rely on a windows handle and should be used for in-memory manipulations only.<br> 16 bits textures are automatically converted to 24 bits and an opaque (255) alpha channel is assumed for all planes, the byte order is as specified in GL_RGBA. If 32 bits is used in this class, it can however output 16 bits texture data for use in OpenGL.<p> The class has support for registering its content as a texture, as well as for directly drawing/reading from the current OpenGL buffer.
TGLImageClassProperty GLSceneRegister
TGLImageDataFormat DXTC
TGLImageLevelDesc GLGraphics
TGLImmaterialSceneObject | GLScene | Base class for objects that do not have a published "material".<p> Note that the material is available in public properties, but isn't applied automatically before invoking BuildList.<br> Subclassing should be reserved to structural objects and objects that have no material of their own.
TGLImposter GLImposter
TGLImposterBuilder | GLImposter | Abstract ImposterBuilder class.
TGLInitializableObjectList | GLScene | Just a list of objects that support IGLInitializable.<p>
TGLInterfacedCollectionItem | PersistentClasses | TCollectionItem thet inplements IInterface.
TGLInterfacedPersistent | PersistentClasses | TPersistent thet inplements IInterface.
TGLJPEGImage GLFileJPEG
TGLLabel GLWindows
TGLLensFlare GLLensFlare
TGLLibAsmProgNameProperty GLSceneRegister
TGLLibAttachmentNameProperty GLSceneRegister
TGLLibCombinerNameProperty GLSceneRegister
TGLLibMaterial | GLMaterial | Material in a material library.<p> Introduces Texture transformations (offset and scale). Those transformations are available only for lib materials to minimize the memory cost of basic materials (which are used in almost all objects).
TGLLibMaterialEx GLMaterialEx
TGLLibMaterialNameProperty GLSceneRegister
TGLLibMaterialNameProperty GLSceneRegisterLCL
TGLLibMaterialProperty GLMaterialEx
TGLLibMaterials | GLMaterial | A collection of materials, mainly used in material libraries.
TGLLibMaterialsEx GLMaterialEx
TGLLibSamplerNameProperty GLSceneRegister
TGLLibShaderNameProperty GLSceneRegister
TGLLibTextureNameProperty GLSceneRegister
TGLLifeColoredPFXManager | GLParticleFX | Base PFX manager for particles with life colors.<p> Particles have a core and edge color, for subclassing.
TGLLightSource | GLScene | Standard light source.<p> The standard GLScene light source covers spotlights, omnidirectionnal and parallel sources (see TLightStyle).<br> Lights are colored, have distance attenuation parameters and are turned on/off through their Shining property.<p> Lightsources are managed in a specific object by the TGLScene for rendering purposes. The maximum number of light source in a scene is limited by the OpenGL implementation (8 lights are supported under most ICDs), though the more light you use, the slower rendering may get. If you want to render many more light/lightsource, you may have to resort to other techniques like lightmapping.
TGLLineBase GLObjects
TGLLineParticle | GLLinePFX | Linear particle.<p>
TGLLinePFXManager | GLLinePFX | Polygonal particles FX manager.<p> The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available.<br> If you render large particles and don't have T&L acceleration, consider using TGLPointLightPFXManager.
TGLLines GLObjects
TGLLineSettings GLHiddenLineShader
TGLLinesNode GLObjects
TGLLinesNodes GLObjects
TGLListHandle | GLContext | Manages a handle to a display list.
TGLLMTSVectorFile GLFileLMTS
TGLLWOVectorFile GLFileLWO
TGLMapCollection GLFPSMovement
TGLMapCollectionItem GLFPSMovement
TGLMaterial | GLMaterial | Describes a rendering material.<p> A material is basicly a set of face properties (front and back) that take care of standard material rendering parameters (diffuse, ambient, emission and specular) and texture mapping.<br> An instance of this class is available for almost all objects in GLScene to allow quick definition of material properties. It can link to a TGLLibMaterial (taken for a material library).<p> The TGLLibMaterial has more adavanced properties (like texture transforms) and provides a standard way of sharing definitions and texture maps.
TGLMaterialComponentNameProperty GLSceneRegister
TGLMaterialLibrary | GLMaterial | Stores a set of materials, to be used and shared by scene objects.<p> Use a material libraries for storing commonly used materials, it provides an efficient way to share texture and material data among many objects, thus reducing memory needs and rendering time.<p> Materials in a material library also feature advanced control properties like texture coordinates transforms.
TGLMaterialLibraryEditor | GLSceneRegister | Editor for material library.<p>
TGLMaterialLibraryEx GLMaterialEx
TGLMaterialLibraryItem GLMaterialScript
TGLMaterialLibraryItems GLMaterialScript
TGLMaterialMultiProxy | GLMaterialMultiProxy | Multiple Proxy object.<p> This proxy has multiple Master objects, which are individually made visible depending on a Distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation.<p> For dimensionsn raycasting and silhouette purposes, the first Master is used (item zero in the MasterObjects collection).
TGLMaterialMultiProxyMaster | GLMaterialMultiProxy | MasterObject description for a MultiProxy object.
TGLMaterialMultiProxyMasters | GLMaterialMultiProxy | Collection of TGLMaterialMultiProxyMaster.
TGLMaterialProperty GLSceneRegister
TGLMaterialProxy | GLProxyObjects | A proxy object with its own material.<p> This proxy object can take a mesh from one master and a materia from a material library.
TGLMaterialScripter GLMaterialScript
TGLMatLibComponents GLMaterialEx
TGLMatrix2D GLTypes
TGLMatrix3D GLTypes
TGLMD2VectorFile | GLFileMD2 | The MD2 vector file (Quake2 actor file).<p> Stores a set of "frames" describing the different postures of the actor, it may be animated by TGLActor. The "Skin" must be loaded indepentendly (the whole mesh uses a single texture bitmap).<p> Based on code by Roger Cao.
TGLMD3VectorFile GLFileMD3
TGLMD5VectorFile GLFileMD5
TGLMDCVectorFile GLFileMDC
TGLMemoryViewer | GLScene | Component to render a scene to memory only.<p> This component curently requires that the OpenGL ICD supports the WGL_ARB_pbuffer extension (indirectly).
TGLMesh GLMesh
TGLMesh2DVertex GLTypes
TGLMesh3DVertex GLTypes
TGLMHeader FileGL2
TGLMirror | GLMirror | A simple plane mirror.<p> This mirror requires a stencil buffer for optimal rendering!<p> The object is a mix between a plane and a proxy object, in that the plane defines the mirror's surface, while the proxy part is used to reference the objects that should be mirrored (it is legal to self-mirror, but no self-mirror visuals will be rendered).<p> It is strongly recommended to read and understand the explanations in the materials/mirror demo before using this component.
TGLMLODInfo FileGL2
TGLMLODs FileGL2
TGLMotionBlur GLBlur This component blurs everything thatis rendered BEFORE it. So if you want part of your scene blured, the other not blured, make sure that the other part is rendered after this component. It is fast and does not require shaders.

Note: it is FPS-dependant. Also also can produce a "blury trail effect", which stays on the screen until something new is rendered over it. It can be overcome by changing the Material.FrontProperties.Diffuse property. This, however, also has a drawback - the picture becomes more blured altogether. For example, if your backgroud color is Black, set the Material.FrontProperties.Diffuse to White. If it is White, set Material.FrontProperties.Diffuse to Black. I haven't tried any others, but I hope you get the idea ;)

I've seen this effect in different Bruring components, even in shaders, but if anyone knows another way to fix this issue - please post it on the glscene newsgroup.

TGLMovement GLMovement
TGLMovementPath GLMovement
TGLMovementPaths GLMovement
TGLMoveToPosJob GLCameraController
TGLMP3File | GLFileMP3 | Support for MP3 format.<p> *Partial* support only, access to PCMData is NOT supported.
TGLMS3DVectorFile | GLFileMS3D | The MilkShape vector file.<p> By Mattias Fagerlund, mattias@cambrianlabs.com. Yada yada. Eric rules!
TGLMSurface FileGL2
TGLMSurfaceHeader FileGL2
TGLMSurfaceHeirachy FileGL2
TGLMTLFile | GLFileOBJ | A simple class that know how to extract infos from a mtl file.<p> mtl files are companion files of the obj, they store material information. Guessed content (imported ones denoted with a '*', please help if you know more):<ul> <li>materials begin with a 'newmtl' command followed by material name <li>*Kd command defines the diffuse color <li>*map_Kd command defines the diffuse texture image <li>*Ka/map_Ka define the ambient color and texmap <li>*Ks/map_Ks define the specular color and texmap <li>map_Bump specifies the bump map <li>*d specifies transparency (alpha-channel, range [0; 1]) <li>map_d specifies the opcaity texture map <li>Ns defines the specular exponent or shininess or phong specular (?) <li>Ni is the refraction index (greater than 1) <li>*illum defines the illumination model (0 for no lighting, 1 for ambient and diffuse, 2 for full lighting) </ul>
TGLMTriangle FileGL2
TGLMultiMaterialShader GLMultiMaterialShader
TGLMultiPolygon | GLMultiPolygon | A polygon that can have holes and multiple contours.<p> Use the Path property to access a contour or one of the AddNode methods to add a node to a contour (contours are allocated automatically).
TGLMultiProxy | GLMultiProxy | Multiple Proxy object.<p> This proxy has multiple master objects, which are individually made visible depending on a distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation.<p> For dimensionsn raycasting and silhouette purposes, the first master is used (item zero in the MasterObjects collection).
TGLMultiProxyMaster | GLMultiProxy | MasterObject description for a MultiProxy object.
TGLMultiProxyMasters | GLMultiProxy | Collection of TGLMultiProxyMaster.
TGLMultisampleImage GLMultisampleImage
TGLMultitextureCoordinator XOpenGL
TGLMultitexturingProperties GLMaterialEx
TGLMVertex FileGL2
TGLNavigator GLNavigator TGLNavigator is the component for moving a TGLBaseSceneObject, and all Classes based on it, this includes all the objects from the Scene Editor.<p>

The four calls to get you started is <ul> <li>TurnHorisontal : it turns left and right. <li>TurnVertical : it turns up and down. <li>MoveForward : moves back and forth. <li>FlyForward : moves back and forth in the movingobject's direction </ul> The three properties to get you started is <ul> <li>MovingObject : The Object that you are moving. <li>UseVirtualUp : When UseVirtualUp is set you navigate Quake style. If it isn't it's more like Descent. <li>AngleLock : Allows you to block the Vertical angles. Should only be used in conjunction with UseVirtualUp. <li>MoveUpWhenMovingForward : Changes movement from Quake to Arcade Airplane... (no tilt and flying) <li>InvertHorizontalSteeringWhenUpsideDown : When using virtual up, and vertically rotating beyond 90 degrees, will make steering seem inverted, so we "invert" back to normal. </ul>

TGLNavigatorAbstractParameters | GLSmoothNavigator | TGLNavigatorAdjustDistanceParameters includes a basic set of parameters that control the smoothness of movement.<p>
TGLNavigatorAdjustDistanceParameters | GLSmoothNavigator | TGLNavigatorAdjustDistanceParameters is wrapper for all parameters that affect how the AdjustDisanceTo[...] methods work<p>
TGLNavigatorAdjustDistanceParametersEx GLSmoothNavigator TGLNavigatorAdjustDistanceParameters is wrapper for all parameters that affect how the AdjustDisanceTo[...]Ex methods work<p>

You need to set the TargetObject and desired distance to it, then call AdjustDisanceTo[...]Ex() in your Cadencer.OnProgress code.

TGLNavigatorGeneralParameters GLSmoothNavigator TGLNavigatorGeneralParameters is a wrapper for all general inertia parameters.

These properties mean that if ExpectedMaxFPS is 100, FAutoScaleMin is 0.1, FAutoScaleMax is 0.75 then the "safe range" for it to change is [10..75]. If these bounds are violated, then ExpectedMaxFPS is automaticly increased or decreased by AutoScaleMult.

TGLNavigatorInertiaParameters | GLSmoothNavigator | TGLNavigatorInertiaParameters is wrapper for all parameters that affect the smoothness of movement<p>
TGLNavigatorMoveAroundParameters | GLSmoothNavigator | TGLNavigatorMoveAroundParameters is a wrapper for all parameters that effect how the TGLBaseSceneObject.MoveObjectAround() procedure works
TGLNavigatorSmoothChangeItem | GLSmoothNavigator | TGLNavigatorSmoothChangeItem includes a basic set of parameters that control the smoothness of movement.<p>
TGLNavigatorSmoothChangeItems | GLSmoothNavigator | XCollection of TGLNavigatorSmoothChangeItem.
TGLNavigatorSmoothChangeSingle | GLSmoothNavigator | Smoothly change any Single value, so it will become TargetValue in the end.<p>
TGLNavigatorSmoothChangeVector | GLSmoothNavigator | Smoothly change any Vector4f value, so it will become TargetValue in the end.<p>
TGLNGDBehaviour GLNGDManager
TGLNGDBehaviourList GLNGDManager
TGLNGDDynamic GLNGDManager
TGLNGDManager GLNGDManager
TGLNGDStatic GLNGDManager
TGLNMFVectorFile GLFileNMF
TGLNode GLNodes
TGLNodedLines GLObjects
TGLNodes GLNodes
TGLNonVisualViewer | GLScene | Base class for non-visual viewer.<p> Non-visual viewer may actually render visuals, but they are non-visual (ie. non interactive) at design time. Such viewers include memory or full-screen viewers.
TGLNurbsVectorFile GLFileNurbs
TGLO3TCImage GLFileO3TC
TGLObjectAfterEffect | GLScene | An object effect that gets rendered at scene's end.<p> No particular OpenGL matrices or material should be assumed.
TGLObjectEffect GLScene
TGLObjectEffects | GLScene | Holds a list of object effects.<p> This object expects itself to be owned by a TGLBaseSceneObject.<p>
TGLObjectPostEffect | GLScene | An object effect that gets rendered after owner object's render.<p> The current OpenGL matrices and material are that of the owner object.
TGLObjectPreEffect | GLScene | An object effect that gets rendered before owner object's render.<p> The current OpenGL matrices and material are that of the owner object.
TGLOBJVectorFile GLFileOBJ
TGLOcclusionQueryHandle | GLContext | Manages a handle to an occlusion query.<br> Requires OpenGL 1.5+<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.
TGLOCTVectorFile | GLFileOCT | The OCT vector file (FSRad output).<p>
TGLODEBehaviour | GLODEManager | Basis structures for GLScene behaviour style implementations.
TGLODECustomCollider GLODECustomColliders The custom collider is designed for generic contact handling. There is a contact point generator for sphere, box, capped cylinder, cylinder and cone geoms.<p>

Once the contact points for a collision are generated the abstract Collide function is called to generate the depth and the contact position and normal. These points are then sorted and the deepest are applied to ODE.

TGLODEDynamic GLODEManager
TGLODEHeightField | GLODECustomColliders | Add this behaviour to a TGLHeightField or TGLTerrainRenderer to enable height based collisions for spheres, boxes, capped cylinders, cylinders and cones.
TGLODEJointList | GLODEManager | Component front-end for storing ODE Joints.
TGLODEManager GLODEManager
TGLODEStatic GLODEManager
TGLOrbitToPosAdvJob GLCameraController
TGLOrbitToPosJob GLCameraController
TGLOutlineShader GLOutlineShader
TGLOwnedPersistent | PersistentClasses | TPersistent which has knowledge of its owner.
TGLPackPBOHandle | GLContext | Manages a handle to PBO Pixel Pack Buffer.<p> When bound, commands such as ReadPixels write their data into a buffer object.
TGLPanel GLWindows
TGLParticle | GLParticleFX | Base class for particles.<p> The class implements properties for position, velocity and time, whatever you need in excess of that will have to be placed in subclasses (this class should remain as compact as possible).
TGLParticleFXEffect | GLParticleFX | Base class for linking scene objects to a particle FX manager.<p>
TGLParticleFXManager | GLParticleFX | Base class for particle FX managers.<p> Managers take care of life and death of particles for a particular particles FX system. You can have multiple scene-wide particle FX managers in a scene, handled by the same ParticleFxRenderer.<p> Before subclassing, make sure you understood how the Initialize/Finalize Rendering, Begin/End Particles and RenderParticles methods (and also understood that rendering of manager's particles may be interwoven).
TGLParticleFXRenderer | GLParticleFX | Rendering interface for scene-wide particle FX.<p> A renderer can take care of rendering any number of particle systems, its main task being to depth-sort the particles so that they are blended appropriately.<br> This object will usually be placed at the end of the scene hierarchy, just before the HUD overlays, its position, rotation etc. is of no importance and has no effect on the rendering of the particles.
TGLParticleList | GLParticleFX | List of particles.<p> This list is managed with particles and performance in mind, make sure to check methods doc.
TGLParticles | GLParticles | Manager object of a particle system.<p> Particles in a TGLParticles system are described as normal scene objects, however their children are to be :<ul> <li>"particle template" : the first object (index=0), this one will be duplicated to create new particles, it does not receive progression events and is visible at design-time only. <li>"live particle" : the other objects (index>0), this ones are rendered and receive progression events. </ul><br>TGLParticles may also maintain an internal, non-persistent ("freezed") set of objects : the allocated objects pool. Why ? Creating and freeing objects takes cpu-cycles, especially for the TComponent class, and GLScene objects are TComponent. To reduce this load (and at the expense of memory space), the particle systems can move "dead" particles to a pool instead of freeing them, and will pick in the pool instead of creating new objects when new particles are requested. To take advantage of this behaviour, you should set the ParticlePoolSize property to a non-null value and use the KillParticle function instead of "Free" to kill a particle.<br> All direct access to a TGLParticles children should be avoided.<p> For high-performance particle systems of basic particles, you should look into GLParticleFX instead, TGLParticles being rather focused on complex particles.
TGLPathNode GLMovement
TGLPathNodes GLMovement
TGLPerlinHDS GLPerlin
TGLPerlinHDSThread GLPerlin
TGLPerlinPFXManager | GLPerlinPFX | A sprite-based particles FX manager using perlin-based sprites.<p> This PFX manager is more suited for smoke or fire effects, and with proper tweaking of the texture and perlin parameters, may help render a convincing effect with less particles.<p> The sprite generate by this manager is the composition of a distance-based intensity and a perlin noise.
TGLPersistentImage | GLTexture | Stores any image compatible with Delphi's TPicture mechanism.<p> The picture's data is actually stored into the DFM, the original picture name or path is not remembered. It is similar in behaviour to Delphi's TImage.<p> Note that if original image is for instance JPEG format, only the JPEG data will be stored in the DFM (compact)
TGLPersistentTIE GLTextureImageEditors
TGLPGMImage GLFilePGM
TGLPhongShader GLPhongShader
TGLPicFileImage | GLTexture | Uses a picture whose data is found in a file (only filename is stored).<p> The image is unloaded after upload to OpenGL.
TGLPicFileTIE GLTextureImageEditors
TGLPickList | GLSelection | List class for object picking.<p> This list is used to store the results of a PickObjects call.
TGLPictureImage | GLTexture | Base class for image data classes internally based on a TPicture.
TGLPipe | GLExtrusion | A solid object generated by extruding a circle along a trajectory.<p> Texture coordinates NOT supported yet.
TGLPipeNode GLExtrusion
TGLPipeNodes GLExtrusion
TGLPixel24 GLGraphics
TGLPixel32 GLGraphics
TGLPlane GLObjects
TGLPLYVectorFile | GLFilePLY | The PLY vector file aka Stanford Triangle Format.<p> This is a format for storing graphical objects that are described as a collection of polygons. The format is extensible, supports variations and subformats. This importer only works for the simplest variant (triangles without specified normals, and will ignore most header specifications.
TGLPNGImage GLFilePNG
TGLPoint2D GLTypes
TGLPoint3D GLTypes
TGLPointLightPFXManager | GLParticleFX | A sprite-based particles FX managers using point light maps.<p> The texture map is a round, distance-based transparency map (center "opaque"), you can adjust the quality (size) of the underlying texture map with the TexMapSize property.<p> This PFX manager renders particles similar to what you can get with TGLPolygonPFXManager but stresses fillrate more than T&L rate (and will usually be slower than the PolygonPFX when nbSides is low or T&L acceleration available). Consider this implementation as a sample for your own PFX managers that may use particles with more complex textures.
TGLPointParameters GLObjects
TGLPoints GLObjects
TGLPolygon GLGeomObjects
TGLPolygonBase GLObjects
TGLPolygonPFXManager | GLParticleFX | Polygonal particles FX manager.<p> The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available.<br> If you render large particles and don't have T&L acceleration, consider using TGLPointLightPFXManager.
TGLPopupMenu GLWindows
TGLPortal | GLPortal | Portal Renderer class.
TGLPostEffect | GLPostEffects | Provides a simple way to producing post-effects without shaders.<p> It is slow as hell, but it's worth it in some cases.
TGLPostEffectColor GLPostEffects
TGLPostShaderCollection GLPostEffects
TGLPostShaderCollectionItem GLPostEffects
TGLPostShaderHolder | GLPostEffects | A class that allows several post-shaders to be applied to the scene, one after another. It does not provide any optimizations related to multi-shader rendering, just a convenient interface.
TGLPrimitiveQueryHandle | GLContext | Manages a handle to a primitive query.<br> Requires OpenGL 3.0+<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.
TGLProcTextureNoise GLProcTextures
TGLProcTextureNoiseTIE GLTextureImageEditors
TGLProgramHandle | GLContext | Manages a GLSL Program Object.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.<br>
TGLProjectedTextures | GLProjectedTextures | Projected Textures Manager.<p> Specifies active texture Emitters (whose texture will be projected) and receivers (children of this object).
TGLProxyObject | GLScene | A full proxy object.<p> This object literally uses another object's Render method to do its own rendering, however, it has a coordinate system and a life of its own.<br> Use it for duplicates of an object.
TGLPythonEngine | GLScriptPython | This class only adds manager registration logic to the TPythonEngine class to enable the XCollection items (ie. TGLScriptPython) retain it's assigned compiler from design to run -time.
TGLQ3BSPVectorFile | GLFileQ3BSP | The Q3BSP vector file (Quake III BSP).<p>
TGLQuadricObject GLObjects
TGLQuaternion3D GLTypes
TGLQueryHandle | GLContext | Manages a handle to a query.<br> Do not use this class directly, use one of its subclasses instead.
TGLRagdoll GLRagdoll
TGLRCHandle GLContext
TGLRenderbuffer GLFBO
TGLRenderbufferHandle | GLContext | Manages a handle to a Renderbuffer Object. A Renderbuffer is a "framebuffer-attachable image" for generalized offscreen rendering and it also provides a means to support rendering to GL logical buffer types which have no corresponding texture format (stencil, accum, etc).
TGLRenderPoint | GLScene | Scene object that allows other objects to issue rendering at some point.<p> This object is used to specify a render point for which other components have (rendering) tasks to perform. It doesn't render anything itself and is invisible, but other components can register and be notified when the point is reached in the rendering phase.<br> Callbacks must be explicitly unregistered.
TGLResolutionIndependantHUDText GLHUDObjects
TGLRevolutionSolid | GLExtrusion | A solid object generated by rotating a curve along the Y axis.<p> The curve is described by the Nodes and SplineMode properties, and it is rotated in the trigonometrical direction (CCW when seen from Y->INF).<p> The TGLRevolutionSolid can also be used to render regular helicoidions, by setting a non-null YOffsetPerTurn, and adjusting start/finish angles to make more than one revolution.<p> If you want top/bottom caps, just add a first/last node that will make the curve start/finish on the Y axis.
TGLROAMPatch GLROAMPatch
TGLSamplerHandle | GLContext | Manages a handle to a sampler.
TGLSamplingScale GLGraph
TGLSArchiveManager GLSArchiveManager
TGLSArchiveManagerEditor | GLSceneRegister | Editor for GLScene Archive Manager.<p>
TGLScene | GLScene | Scene object.<p> The scene contains the scene description (lights, geometry...), which is basicly a hierarchical scene graph made of TGLBaseSceneObject. It will usually contain one or more TGLCamera object, which can be referred by a Viewer component for rendering purposes.<p> The scene's objects can be accessed directly from Delphi code (as regular components), but those are edited with a specific editor (double-click on the TGLScene component at design-time to invoke it). To add objects at runtime, use the AddNewChild method of TGLBaseSceneObject.
TGLSceneBaseFileDescriptor GLSceneFormDesign
TGLSceneBaseFormDescriptor GLSceneFormDesign
TGLSceneBuffer | GLScene | Encapsulates an OpenGL frame/rendering buffer.<p>
TGLSceneEditor GLSceneRegister
TGLSceneEditorForm GLSceneEdit
TGLSceneEditorForm GLSceneEditLCL
TGLSceneExtendedFileDescriptor GLSceneFormDesign
TGLSceneExtendedFormDescriptor GLSceneFormDesign
TGLSceneForm GLSceneForm
TGLSceneObject | GLScene | Base class for standard scene objects.<p> Publishes the Material property.
TGLSceneObjectEntry GLObjectManager
TGLSceneRootObject | GLScene | This class shall be used only as a hierarchy root.<p> It exists only as a container and shall never be rotated/scaled etc. as the class type is used in parenting optimizations.<p> Shall never implement or add any functionality, the "Create" override only take cares of disabling the build list.
TGLSceneSimpleFileDescriptor GLSceneFormDesign
TGLSceneSimpleFormDescriptor GLSceneFormDesign
TGLSceneViewer | GLLCLViewer | Component where the GLScene objects get rendered.<p> This component delimits the area where OpenGL renders the scene, it represents the 3D scene viewed from a camera (specified in the camera property). This component can also render to a file or to a bitmap.<p> It is primarily a windowed component, but it can handle full-screen operations : simply make this component fit the whole screen (use a borderless form).<p> This viewer also allows to define rendering options such a fog, face culling, depth testing, etc. and can take care of framerate calculation.<p>
TGLSceneViewer | GLWin32Viewer | Component where the GLScene objects get rendered.<p> This component delimits the area where OpenGL renders the scene, it represents the 3D scene viewed from a camera (specified in the camera property). This component can also render to a file or to a bitmap.<p> It is primarily a windowed component, but it can handle full-screen operations : simply make this component fit the whole screen (use a borderless form).<p> This viewer also allows to define rendering options such a fog, face culling, depth testing, etc. and can take care of framerate calculation.<p>
TGLSceneViewerEditor GLSceneRegister
TGLScreenControlingContext | GLContext | A TGLContext with screen control property and methods.<p> This variety of contexts is for drivers that access windows and OpenGL through an intermediate opaque cross-platform API.<p> TGLSceneViewer won't use them, TGLMemoryViewer may be able to use them, but most of the time they will be accessed through a specific viewer class/subclass.
TGLScriptBase | GLScriptBase | The base script class that defines the abstract functions and properties. Don't use this class directly, use the script classes descended from this base class.
TGLScriptDWS2 | GLScriptDWS2 | Implements DelphiWebScriptII scripting functionality through the abstracted GLScriptBase .
TGLScriptLibrary | GLScriptBase | Encapsulation of the scripts XCollection to help with script handling at design-time. Links the scripts to Delphi's persistence model.
TGLScriptPython | GLScriptPython | Implements Python scripting functionality through the abstracted GLScriptBase.
TGLScripts | GLScriptBase | XCollection descendant for storing and handling scripts.
TGLScrollbar GLWindows
TGLSCUDA GLSCUDA
TGLSCUDACompiler GLSCUDACompiler
TGLSCUDACompilerEditor GLSComputingRegister
TGLSCUDACompilerSourceProperty GLSComputingRegister
TGLSCUDADevice GLSCUDAContext
TGLSCUDADeviceProperty GLSComputingRegister
TGLSCUDAEditor GLSComputingRegister
TGLSCUDAEditorForm GLSCUDAEditor
TGLSCustomMemo GLSMemo
TGLSDLContext | GLSDLContext | A context driver for OpenGL via SDL (libsdl.org).<p> Due to limitations of SDL:<ul> <li>you may have only one SDL window opened at any time (you cannot have memory viewers) <li>closing the SDL window will terminate the application </ul>
TGLSDLViewer | GLSDLContext | A viewer using SDL.<p> Beware: only one at a time, no other viewers allowed!<br> Will also close the application when the window is closed!
TGLSelectRenderModeTechnique GLSelection
TGLShader | GLMaterial | Generic, abstract shader class.<p> Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities.<br> Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.
TGLShaderCombiner GLShaderCombiner
TGLShaderEditor FShaderMemo
TGLShaderEditorProperty GLSceneRegister
TGLShaderEx GLMaterialEx
TGLShaderHandle | GLContext | Manages a handle to a Shader Object.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.<br> Do not use this class directly, use one of its subclasses instead.
TGLShaderItem GLMaterialScript
TGLShaderItems GLMaterialScript
TGLShaderModel3 GLMaterialEx
TGLShaderModel4 GLMaterialEx
TGLShaderModel5 GLMaterialEx
TGLShaderProgram | GLCustomShader | A custom shader program.
TGLShaderUniform GLMaterialEx
TGLShaderUniformDSA GLMaterialEx
TGLShaderUniformTexture GLMaterialEx
TGLShadowHDS | GLShadowHDS | An Height Data Source that generates terrain shadow maps automatically.<p> The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where shadowmaps will be placed.
TGLShadowPlane | GLShadowPlane | A simple shadow plane.<p> This mirror requires a stencil buffer for optimal rendering!<p> The object is a mix between a plane and a proxy object, in that the plane defines where the shadows are cast, while the proxy part is used to reference the objects that should be shadowing (it is legal to self-shadow, but no self-shadow visuals will be rendered).<br> If stenciling isn't used, the shadow will 'paint' the ShadowColor instead of blending it transparently.<p> You can have lower quality shadow geometry: add a dummycube, set it to invisible (so it won't be rendered in the "regular" pass), and under it place another visible dummycube under which you have all your low quality objects, use it as shadowing object. Apply the same movements to the low-quality objects that you apply to the visible, high-quality ones.
TGLShadowVolume | GLShadowVolume | Simple shadow volumes.<p> Shadow receiving objects are the ShadowVolume's children, shadow casters (opaque objects or lights) must be explicitly specified in the Casters collection.<p> Shadow volumes require that the buffer allows stencil buffers, GLSceneViewer.Buffer.ContextOptions contain roStencinBuffer. Without stencil buffers, shadow volumes will not work properly.<p> Another issue to look out for is the fact that shadow volume capping requires that the camera depth of view is either very high (fi 1e9) or that the camera style is csInfinitePerspective.
TGLShadowVolumeCaster | GLShadowVolume | Specifies an individual shadow caster.<p> Can be a light or an opaque object.
TGLShadowVolumeCasters | GLShadowVolume | Collection of TGLShadowVolumeCaster.
TGLShadowVolumeLight | GLShadowVolume | Specifies an individual shadow casting light.<p>
TGLShadowVolumeOccluder | GLShadowVolume | Specifies an individual shadow casting occluder.<p>
TGLSilhouette | GLSilhouette | Base class storing a volume silhouette.<p> Made of a set of indexed vertices defining an outline, and another set of indexed vertices defining a capping volume. Coordinates system is the object's unscaled local coordinates system.<br> This is the base class, you can use the TGLSilhouette subclass if you need some helper methods for generating the indexed sets.
TGLSilhouetteParameters | GLSilhouette | Silouhette generation parameters.<p> SeenFrom and LightDirection are expected in local coordinates.
TGLSimpleNavigation GLSimpleNavigation
TGLSimpleNavigationKeyCombination GLSimpleNavigation
TGLSimpleNavigationKeyCombinations GLSimpleNavigation
TGLSize GLRenderContextInfo
TGLSkyBox GLSkyBox
TGLSkyDome | GLSkydome | Renders a sky dome always centered on the camera.<p> If you use this object make sure it is rendered *first*, as it ignores depth buffering and overwrites everything. All children of a skydome are rendered in the skydome's coordinate system.<p> The skydome is described by "bands", each "band" is an horizontal cut of a sphere, and you can have as many bands as you wish.<p> Estimated CPU cost (K7-500, GeForce SDR, default bands):<ul> <li>800x600 fullscreen filled: 4.5 ms (220 FPS, worst case) <li>Geometry cost (0% fill): 0.7 ms (1300 FPS, best case) </ul>
TGLSLanguage | GLSLanguage | Àáñòðàêòíûé êëàññ, äëÿ ïàëèòðû êîìïîíåíòîâ<p>
TGLSLBumpShader GLSLBumpShader
TGLSLBumpShaderAM GLSLBumpShader
TGLSLBumpShaderMT GLSLBumpShader
TGLSLDiffuseSpecularShader GLSLDiffuseSpecularShader
TGLSLDiffuseSpecularShaderAM GLSLDiffuseSpecularShader
TGLSLDiffuseSpecularShaderMT GLSLDiffuseSpecularShader
TGLSLHandle | GLContext | Base class for GLSL handles (programs and shaders).<p> Do not use this class directly, use one of its subclasses instead.
TGLSLMLBumpShader GLSLBumpShader
TGLSLMLBumpShaderMT GLSLBumpShader
TGLSLMLDiffuseSpecularShader GLSLDiffuseSpecularShader
TGLSLMLDiffuseSpecularShaderMT GLSLDiffuseSpecularShader
TGLSLogger GLSLog
TGLSLPostBlurShader GLSLPostBlurShader
TGLSLProjectedTextures | GLSLProjectedTextures | Projected Texture Manager.<p> Specifies active Emitters and receivers (children of this object). At the moment, only 1 texture can be used.
TGLSLShader GLSLShader
TGLSLShaderParameter | GLSLShader | Wrapper around a parameter of a GLSL program.
TGLSLTextureEmitter | GLSLProjectedTextures | A projected texture emmiter.<p> Can be places anywhere in the scene. Used to generate a modelview and texture matrix for the shader
TGLSLTextureEmitterItem | GLSLProjectedTextures | Specifies an item on the TGLSLTextureEmitters collection.
TGLSLTextureEmitters | GLSLProjectedTextures | Collection of TGLSLTextureEmitter.
TGLSMBASS GLSMBASS
TGLSMDVectorFile | GLFileSMD | The SMD vector file is Half-life's skeleton format.<p> The SMD is a text-based file format. They come in two flavors: one that old Skeleton and triangle (mesh) data, and animation files that store Skeleton frames.<p> This reader curently reads both, but requires that the main file (the one with mesh data) be read first.
TGLSMemo GLSMemo
TGLSMemoAbstractScrollableObject GLSMemo
TGLSMemoDelCharUndo GLSMemo
TGLSMemoDeleteBufUndo GLSMemo
TGLSMEmoDelLineUndo GLSMemo
TGLSMemoGutter GLSMemo
TGLSMemoInsCharUndo GLSMemo
TGLSMemoPasteUndo GLSMemo
TGLSMemoScrollBar GLSMemo
TGLSMemoSelUndo GLSMemo
TGLSMemoStringList GLSMemo
TGLSMemoStrings GLSMemo
TGLSMemoUndo GLSMemo
TGLSMemoUndoList GLSMemo
TGLSMFMOD GLSMFMOD
TGLSmoothNavigator GLSmoothNavigator TGLSmoothNavigator is the component for moving a TGLBaseSceneObject, and all classes based on it, this includes all the objects from the Scene Editor.<p>

It uses complex smoothing algorithms, most of which are FPS-dependant. Make sure your limit your FPS and set MaxExpectedDeltaTime to a value that is aproximatly 5 times less than your usual deltatime.

TGLSmoothOrbitToPos GLCameraController
TGLSmoothOrbitToPosAdvJob GLCameraController
TGLSmoothUserInterface | GLSmoothNavigator | TGLSmoothUserInterface is the component which reads the userinput and transform it into action.<p> <ul> <li>Mouselook(ADeltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works everywhere!) </ul> The four properties to get you started are: <ul> <li>InvertMouse : Inverts the mouse Y axis. <li>AutoUpdateMouse : If enabled (by defaul), than handles all mouse updates. <li>GLNavigator : The Navigator which receives the user movement. <li>GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras.... </ul>
TGLSMOpenAL GLSMOpenAL
TGLSMWaveOut | GLSMWaveOut | Basic sound manager based on WinMM <i>waveOut</i> function.<p> This manager has NO 3D miximing capacity, this is merely a default manager that should work on any windows based system, and help showcasing/testing basic GLSS core functionality.<p> Apart from 3D, mute, pause, priority and volume are ignored too, and only sampling conversions supported by the windows ACM driver are supported (ie. no 4bits samples playback etc.).
TGLSOpenGLControl GLWidgetContext
TGLSOpenGLForm GLSceneForm
TGLSoundFile | GLSoundFileObjects | Abstract base class for different Sound file formats.<p> The actual implementation for these files (WAV, RAW...) must be done seperately. The concept for TGLSoundFile is very similar to TGraphic (see Delphi Help).<p> Default implementation for LoadFromFile/SaveToFile are to directly call the relevent stream-based methods, ie. you will just have to override the stream methods in most cases.
TGLSoundFileFormat GLSoundFileObjects
TGLSoundFileFormatsList GLSoundFileObjects
TGLSoundLibrary GLSound
TGLSoundManager | GLSound | Base class for sound manager components.<p> The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this).<p> Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.
TGLSoundSample | GLSound | Stores a single PCM coded sound sample.
TGLSoundSamples GLSound
TGLSoundSampling | GLSoundFileObjects | Defines a sound sampling quality.
TGLSoundSource | GLSound | Origin of sound playback.<p> Just publishes the 'Origin' property.<p> Note that the "orientation" is the the source's Direction, ie. the "Z" vector.
TGLSoundSources GLSound
TGLSourcePFXEffect | GLParticleFX | Simple Particles Source.<p>
TGLSpaceText GLSpaceText
TGLSphere GLObjects
TGLSprite GLObjects
TGLSSynHiMemo GLSMemo
TGLStarRecord GLStarRecord
TGLStateCache | GLState | Manages an application-side cache of OpenGL states and parameters.<p> Purpose of this class is to eliminate redundant state and parameter changes, and there will typically be no more than one state cache per OpenGL context.
TGLStaticImposterBuilder | GLImposter | Builds imposters whose texture is a catalog of prerendered views.
TGLStaticImposterBuilderCorona | GLImposter | Describes a set of orientation in a corona fashion.
TGLStaticImposterBuilderCoronas GLImposter
TGLStencilRBO GLFBO
TGLSTLVectorFile | GLFileSTL | The STL vector file (stereolithography format).<p> It is a list of the triangular surfaces that describe a computer generated solid model. This is the standard input for most rapid prototyping machines.<p> There are two flavors of STL, the "text" and the "binary", this class reads both, but exports only the "binary" version.<p> Original Binary importer code by Paul M. Bearne, Text importer by Adem.
TGLStringGrid GLWindows
TGLTeapot | GLTeapot | The classic teapot.<p> The only use of this object is as placeholder for testing...
TGLTerrainBaseHDS GLHeightData
TGLTerrainRenderer GLTerrainRenderer
TGLTessControlShaderHandle | GLContext | Manages a handle to a Tessellation Control Shader Object.
TGLTessEvaluationShaderHandle | GLContext | Manages a handle to a Tessellation Evaluation Shader Object.
TGLTexCombineShader | GLTexCombineShader | A shader that can setup the texture combiner.<p>
TGLTextAdjust GLSpaceText
TGLTexture | GLTexture | Defines basic texturing properties.<p> You can control texture wrapping, smoothing/filtering and of course define the texture map (note that texturing is disabled by default).<p> A built-in mechanism (through ImageAlpha) allows auto-generation of an Alpha channel for all bitmaps (see TGLTextureImageAlpha).
TGLTextureBufferHandle | GLContext | Manages a handle to a Buffer Texture. (TBO)
TGLTextureCombiner GLMaterialEx
TGLTexturedHDS GLTexturedHDS
TGLTextureEmitter | GLProjectedTextures | A projected texture emmiter.<p> It's material property will be used as the projected texture. Can be places anywhere in the scene.
TGLTextureEmitterItem | GLProjectedTextures | Specifies an item on the TGLTextureEmitters collection.
TGLTextureEmitters | GLProjectedTextures | Collection of TGLTextureEmitter.
TGLTextureEx GLTexture
TGLTextureExItem GLTexture
TGLTextureHandle | GLContext | Manages a handle to a texture.
TGLTextureImage | GLTexture | Base class for texture image data.<p> Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source).<br> SubClasses should be registered using RegisterGLTextureImageClass to allow proper persistence and editability in the IDE experts.
TGLTextureImageEditor GLTextureImageEditors
TGLTextureImageEx GLMaterialEx
TGLTextureImageProperty GLSceneRegister
TGLTextureLensFlare GLTexLensFlare
TGLTextureProperties GLMaterialEx
TGLTextureProperty GLSceneRegister
TGLTextureSampler GLMaterialEx
TGLTextureSharingShader GLTextureSharingShader
TGLTextureSharingShaderMaterial GLTextureSharingShader
TGLTextureSharingShaderMaterials GLTextureSharingShader
TGLTextureSwizzling | GLMaterialEx | Swizzle the components of a texture fetches in shader or fixed-function pipeline.
TGLTGAImage GLFileTGA
TGLThorFXManager GLThorFX
TGLTiledArea | GLTilePlane | Stores tile information in a tiled area.<p> Each tile stores an integer value with zero the default value, assumed as "empty".
TGLTiledAreaRow | GLTilePlane | Stores row information for a tiled area.<p>
TGLTilePlane | GLTilePlane | A tiled textured plane.<p> This plane object stores and displays texture tiles that composes it, and is optimized to minimize texture switches when rendering.<br> Its bounding dimensions are determined by its painted tile.
TGLTimeEventsMGR GLTimeEventsMgr
TGLTimerQueryHandle | GLContext | Manages a handle to a timer query.<br> Requires GL_EXT_timer_query extension.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.
TGLTINVectorFile | GLFileTIN | The TIN vector file (triangle irregular network).<p> It is a simple text format, with one triangle record per line, no materials, no texturing (there may be more, but I never saw anything in this files).<p> This format is encountered in the DEM/DTED world and used in place of grids.
TGLTorus GLGeomObjects
TGLTrail GLTrail
TGLTransformation GLPipelineTransformation
TGLTransformFeedbackBufferHandle | GLContext | Manages a handle to a Transform Feedback Buffer Object.<p> Transform feedback buffers can be used to capture vertex data from the vertex or geometry shader stage to perform further processing without going on to the fragment shader stage.
TGLTree GLTree
TGLTreeBranch GLTree
TGLTreeBranches GLTree
TGLTreeBranchNoise GLTree
TGLTreeLeaves GLTree
TGLUniformBufferHandle | GLContext | Manages a handle to a Uniform Buffer Object (UBO). Uniform buffer objects store "uniform blocks"; groups of uniforms that can be passed as a group into a GLSL program.
TGLUnpackPBOHandle | GLContext | Manages a handle to PBO Pixel Unpack Buffer.<p> When bound, commands such as DrawPixels read their data from a buffer object.
TGLUNurbs OpenGLTokens
TGLUpdateAbleComponent | BaseClasses | A base class describing the "update" interface.<p>
TGLUpdateAbleObject | BaseClasses | An abstract class describing the "update" interface.<p>
TGLUQuadric OpenGLTokens
TGLUserInputCommand | GLConsole | Stores info on a command. A command is a parsed input line. Should be transformed into a class, I think...
TGLUserInterface GLNavigator TGLUserInterface is the component which reads the userinput and transform it into action.<p>

The four calls to get you started is <ul> <li>MouseLookActivate : set us up the bomb. <li>MouseLookDeActivate : defuses it. <li>Mouselook(deltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works every where!) <li>MouseUpdate : Resets mouse position so that you don't notice that the mouse is limited to the screen should be called after Mouselook. </ul> The four properties to get you started are: <ul> <li>InvertMouse : Inverts the mouse Y axis. <li>MouseSpeed : Also known as mouse sensitivity. <li>GLNavigator : The Navigator which receives the user movement. <li>GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras.... </ul>

TGLUserShader GLUserShader
TGLUTesselator OpenGLTokens
TGLVBOArrayBufferHandle | GLContext | Manages a handle to VBO Array Buffer.<p> Typically used to store vertices, normals, texcoords, etc.
TGLVBOElementArrayHandle | GLContext | Manages a handle to VBO Element Array Buffer.<p> Typically used to store vertex indices.
TGLVBOHandle | GLContext | Manages a handle to an Vertex Buffer Object.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.<br> Do not use this class directly, use one of its subclasses instead.
TGLVector2D GLTypes
TGLVector3D GLTypes
TGLVerletNode | GLVerletClasses | Specialized verlet node that can be anchored to a GLScene object. If it's anchored and has the property "NailedDown" set, it will remain in the same relative position to the GLScene object.
TGLVertexArrayHandle | GLContext | Manages a handle to a Vertex Array Object (VAO). Vertex array objects are used to rapidly switch between large sets of array state.
TGLVertexAttribute GLSCUDAGraphics
TGLVertexAttributes GLSCUDAGraphics
TGLVertexProgram GLCustomShader
TGLVertexShaderHandle | GLContext | Manages a handle to a Vertex Shader Object.
TGLVfsPAK GLVfsPAK
TGLVirtualHandle | GLContext | A context handle with event-based handle allocation and destruction.
TGLVirtualHandleTransf | GLContext | Transferable virtual handle.
TGLVRMLVectorFile GLFileVRML
TGLWaterPlane GLWaterPlane
TGLWAVFile | GLFileWAV | Support for Windows WAV format.
TGLWidgetContext GLWidgetContext
TGLWin32Context | GLWin32Context | A context driver for standard Windows OpenGL (via MS OpenGL).
TGLWindowsBitmapFont | GLWindowsFont | A bitmap font automatically built from a TFont.<p> It works like a TGLBitmapfont, you set ranges and which chars are assigned to which indexes, however here you also set the Font property to any TFont available to the system and it renders in GLScene as close to that font as posible, on some font types this is 100% on some a slight difference in spacing can occur at most 1 pixel per char on some char combinations.<p> Ranges must be sorted in ascending ASCII order and should not overlap. As the font texture is automatically layed out, the Ranges StartGlyphIdx property is ignored and replaced appropriately.
TGLXVectorFile GlFileX
TGLXYZGrid GLGraph
TGLzBuffer GLzBuffer
TGLZoomToDistanceJob GLCameraController
TGLZShadows GLzBuffer
TGPUDevice OpenGLTokens
TGUIRect GLGui
TGUISkinEditor GuiSkinEditorFormUnit
TGUISkinEditor GuiSkinEditorFormUnitLCL
THDRImage HDRImage
THeightData GLHeightData
THeightDataSource GLHeightData
THeightDataSourceFilter GLHeightData
THeightDataThread GLHeightData
THeightDataUser GLHeightData
THeightField GLNGDManager
THeightTile HeightTileFile
THeightTileFile | HeightTileFile | Interfaces a Tiled file
THeightTileInfo HeightTileFile
THideTrackTag Types3DS
THmgBoundingBox GeometryBB
THotTrackTag Types3DS
THTFHeader HeightTileFile
TICCOMPRESS GLSVfw
TICCOMPRESSFRAMES GLSVfw
TICDECOMPRESS GLSVfw
TICDECOMPRESSEX GLSVfw
TICDRAW GLSVfw
TICDRAWBEGIN GLSVfw
TICDRAWSUGGEST GLSVfw
TICINFO GLSVfw
TICOPEN GLSVfw
TICPALETTE GLSVfw
TICSETSTATUSPROC GLSVfw
TImposter GLImposter Base class for imposters manipulation and handling.<br> Rendering imposters is performed by three methods, BeginRender must be invoked first, then Render for each of the impostr This class assumes a single impostor per texture.

Note: Remeber to enable Destination Alpha on your viewer.

TInfoForm Info
TInfoForm InfoLCL
TIntegerList | VectorLists | A list of Integers.<p> Similar to TList, but using TTexPoint as items.<p> The list has stack-like push/pop methods.
TIntermediateFormat ImageUtils
TIpasData Types3DS
TJointInfo1 ODEImport
TJointInfo2 ODEImport
TJoystick | Joystick | A component interfacing the Joystick via the (regular) windows API.
TJoystick_hwdata GLSDL
TJPEGContext GLSJPG
TKeyFramer File3DS
TKeyHeader3DS Types3DS
TKEYSChunk TypesB3D
TKFAmbient3DS Types3DS
TKFCamera3DS Types3DS
TKFHdr Types3DS
TKFKeyInfo3DS Types3DS
TKFMesh3DS Types3DS
TKFOmni3DS Types3DS
TKFRotKey3DS Types3DS
TKFSeg Types3DS
TKFSegment3DS Types3DS
TKFSets3DS Types3DS
TKFSpot3DS Types3DS
TLanguage GLSLanguage
TLanguageEntry GLSLanguage
TLanguageExt GLSLanguage
TLayerFog Types3DS
TLayerFogSettings3DS Types3DS
Tlayouts_form FGUILayoutEditor
TLeavedSpacePartition SpatialPartitioning
TLibArchive GLSArchiveManager
TLibArchives GLSArchiveManager
TLibMaterialPicker FLibMaterialPicker
TLibMaterialPicker FLibMaterialPickerLCL
TLight3DS Types3DS
TLightSourceState GLState
TLineProp GLSMemo
TLiteAttenuate3DS Types3DS
TLMTS GLFileLMTS
TLMTS_Header GLFileLMTS
TLMTS_Subset GLFileLMTS
TLMTS_TexData GLFileLMTS
TLMTS_Vertex GLFileLMTS
TLogBufferFlushThread | GLSLog | Thread that periodically flushes the buffer to disk.
TLogCheckSizeThread | GLSLog | Thread that checks file size and splits the file if nessesary.
TLogSession | GLSLog | Abstract Logger class
TLongWordList VectorLists
TLWChunk LWObjects
TLWChunkList LWObjects
TLWChunkRec LWObjects
TLWClip LWObjects
TLWContentDir LWObjects
TLWLayr LWObjects
TLWObjectFile LWObjects
TLWParentChunk LWObjects
TLWPnts LWObjects
TLWPntsInfo LWObjects
TLWPols LWObjects
TLWPolsInfo LWObjects
TLWPolyTagMap LWObjects
TLWPTag LWObjects
TLWSubChunk LWObjects
TLWSubChunkRec LWObjects
TLWSurf LWObjects
TLWTags LWObjects
TLWVertexMap LWObjects
TLWVMap LWObjects
TMainAVIHeader GLSVfw
TMapInfo3DS Types3DS
TMapSet3DS Types3DS
TMatAcubic Types3DS
TMaterial3DS Types3DS
TMaterialEditorForm FMaterialEditorForm
TMaterialEditorForm FMaterialEditorFormLCL
TMaterialInfo GLFileLMTS
TMaterialList File3DS
TMatrix2b VectorTypes
TMatrix2d VectorTypes
TMatrix2e VectorTypes
TMatrix2f VectorTypes
TMatrix2i VectorTypes
TMatrix2p VectorTypes
TMatrix2s VectorTypes
TMatrix2w VectorTypes
TMatrix3b VectorTypes
TMatrix3d VectorTypes
TMatrix3e VectorTypes
TMatrix3f VectorTypes
TMatrix3i VectorTypes
TMatrix3p VectorTypes
TMatrix3s VectorTypes
TMatrix3w VectorTypes
TMatrix4b VectorTypes
TMatrix4d VectorTypes
TMatrix4e VectorTypes
TMatrix4f VectorTypes
TMatrix4i VectorTypes
TMatrix4p VectorTypes
TMatrix4s VectorTypes
TMatrix4w VectorTypes
TMD2AliasFrame TypesMD2
TMD2Header TypesMD2
TMD2Triangle TypesMD2
TMD2TriangleVertex TypesMD2
TMD2VertexIndex TypesMD2
TMD3Bone FileMD3
TMD3Face FileMD3
TMD3Header FileMD3
TMD3MeshData FileMD3
TMD3MeshHeader FileMD3
TMD3Skin FileMD3
TMD3Tag FileMD3
TMD3TagList Q3MD3
TMD3TexCoord FileMD3
TMD3Triangle FileMD3
TMDCBaseFrame TypesMDC
TMDCBorderFrame TypesMDC
TMDCCompFrame TypesMDC
TMDCFileHeader TypesMDC
TMDCSkin TypesMDC
TMDCSurfaceHeader TypesMDC
TMDCTag TypesMDC
TMDCTagFrame TypesMDC
TMDCTagName TypesMDC
TMem GLSDL
TMesh3DS Types3DS
TMESHChunk TypesB3D
TMeshMorphTarget | GLVectorFileObjects | A morph target, stores alternate lists of vertices and normals.
TMeshMorphTargetList | GLVectorFileObjects | A list of TMeshMorphTarget objects.
TMeshObject | GLVectorFileObjects | Base mesh class.<p> Introduces base methods and properties for mesh objects.<p> Subclasses are named "TMOxxx".
TMeshObjectList | GLVectorFileObjects | A list of TMeshObject objects.
TMeshObjectVerletNode GLVerletClothify
TMeshSet3DS Types3DS
TMeshTextureInfo Types3DS
TMOParametricSurface GLParametricSurfaces
TMorphableMeshObject | GLVectorFileObjects | Mesh object with support for morph targets.<p> The morph targets allow to change vertices and normals according to pre- existing "morph targets".
TMorphTrackTag Types3DS
TMS3DComment TypesMS3D
TMS3DCommentList TypesMS3D
TMS3DGroup TypesMS3D
TMS3DHeader TypesMS3D
TMS3DJoint TypesMS3D
TMS3DJointBase TypesMS3D
TMS3DKeyframePosition TypesMS3D
TMS3DKeyframeRotation TypesMS3D
TMS3DMaterial TypesMS3D
TMS3DTriangle TypesMS3D
TMS3DVertex TypesMS3D
TMS3D_vertex_ex_t TypesMS3D
TMshMatGroup Types3DS
TMultiPolygonBase GLMultiPolygon Multipolygon is defined with multiple contours.<p> The contours have to be in the X-Y plane, otherwise they are projected to it (this is done automatically by the tesselator).<br> The plane normal is pointing in +Z. All contours are automatically closed, so there is no need to specify the last node equal to the first one.<br> Contours should be defined counterclockwise, the first contour (index = 0) is taken as is, all following are reversed. This means you can define the outer contour first and the holes and cutouts after that. If you give the following contours in clockwise order, the first contour is extended.<p>

TMultiPolygonBase will take the input contours and let the tesselator make an outline from it (this is done in RetreiveOutline). This outline is used for Rendering. Only when there are changes in the contours, the outline will be recalculated. The ouline in fact is a list of VectorLists.

TNCamera Types3DS
TNewtonBoxParam NewtonImport
TNewtonCapsuleParam NewtonImport
TNewtonChamferCylinderParam NewtonImport
TNewtonCollisionInfoRecord NewtonImport
TNewtonCollisionNullParam NewtonImport
TNewtonCollisionTreeParam NewtonImport
TNewtonCompoundCollisionParam NewtonImport
TNewtonConeParam NewtonImport
TNewtonConvexHullModifierParam NewtonImport
TNewtonConvexHullParam NewtonImport
TNewtonCylinderParam NewtonImport
TNewtonHeightFieldCollisionParam NewtonImport
TNewtonSceneCollisionParam NewtonImport
TNewtonSphereParam NewtonImport
TNGDDebugOption GLNGDManager
TNGDJoint GLNGDManager
TNGDJointBallAndSocket GLNGDManager
TNGDJointHinge GLNGDManager
TNGDJointKinematicController GLNGDManager
TNGDJointPin GLNGDManager
TNGDJointPin2 GLNGDManager
TNGDJointPivot GLNGDManager
TNGDJointSlider GLNGDManager
TNGDSurfaceItem GLNGDManager
TNGDSurfacePair GLNGDManager
TNmHeader FileNMF
TNmRawTriangle FileNMF
TNODEChunk TypesB3D
TNodeHdr Types3DS
TNodeList Types3DS
TNotifyCollection BaseClasses
TO3TCImage O3TCImage
TObjectList File3DS
TObjectManager GLObjectManager
TObjMat3DS Types3DS
TOCTFace FileOCT
TOCTFile FileOCT
TOCTHeader FileOCT
TOCTLight FileOCT
TOCTLightmap FileOCT
TOctree Octree
TOctreeNode Octree
TOctreeSpacePartition SpatialPartitioning
TOctreeTriangleInfo Octree
TOCTTexture FileOCT
TOCTVertex FileOCT
TODECollisionSurface GLODEManager
TODEElementBase GLODEManager
TODEElementBox | GLODEManager | ODE box implementation.
TODEElementCapsule | GLODEManager | ODE capped cylinder implementation.
TODEElementCylinder | GLODEManager | ODE cylinder implementation.
TODEElementPlane | GLODEManager | ODE plane implementation.
TODEElements GLODEManager
TODEElementSphere | GLODEManager | ODE sphere implementation.
TODEElementTriMesh | GLODEManager | ODE tri-mesh implementation.
TODEJointBall | GLODEManager | ODE ball joint implementation.
TODEJointBase | GLODEManager | Base structures for ODE Joints.
TODEJointFixed | GLODEManager | ODE fixed joint implementation.
TODEJointHinge | GLODEManager | ODE hinge joint implementation.
TODEJointHinge2 | GLODEManager | ODE hinge2 joint implementation.
TODEJointParams GLODEManager
TODEJoints | GLODEManager | An XCollection decendant for ODE Joints.
TODEJointSlider | GLODEManager | ODE slider joint implementation.
TODEJointUniversal | GLODEManager | ODE universal joint implementation.
TODERagdoll GLODERagdoll
TODERagdollBone GLODERagdoll
TODERagdollCube GLODERagdoll
TODERagdollDummyJoint GLODERagdoll
TODERagdollHingeJoint GLODERagdoll
TODERagdollUniversalJoint GLODERagdoll
TODERagdollWorld GLODERagdoll
TOrthoView3DS Types3DS
TPAKArchive GLFilePAK
TPakHeader GLFilePAK
TPakHeader GLVfsPAK
TParticleReference GLParticleFX
TPerlin3DNoise | PerlinNoise | Generates Perlin Noise in the [-1; 1] range.<p> 2D noise requests are taken in the Z=0 slice
TPersistentObject | PersistentClasses | Base class for persistent objects.<p> The base requirement is implementation of ReadFromFiler & WriteToFiler in sub-classes, the immediate benefits are support of streaming (to stream, file or string), assignment and cloning.<br> The other requirement being the use of a virtual constructor, which allows polymorphic construction (don't forget to register your subclasses).<p> Note that TPersistentObject implements IUnknown, but does *not* implement reference counting.
TPersistentObjectList | PersistentClasses | A persistent Object list.<p> Similar to TList but works on TObject items and has facilities for persistence of contained data. Unlike the VCL's TObjectList, this one does NOT free its objects upon destruction or Clear, use Clean and CleanFree for that, and as such can be used for object referral lists too.<br> But only TPersistentObject items will be streamed appropriately.<p> The list can be used in a stack-like fashion with Push & Pop, and can perform basic boolean set operations.<p> Note: the IndexOf implementation is up to 3 times faster than that of TList
TPFXLifeColor GLParticleFX
TPFXLifeColors GLParticleFX
TPFXRegion GLParticleFX
TPickRecord GLSelection
TPictureFileProperty GLSceneRegister
TPlatformInfo GLCrossPlatform
TPlugInEntry PlugInManager
TPlugInList PlugInManager
TPlugInManager PlugInManager
TPlugInManagerPropForm PlugInManagerPropEditor
TPoint GLSDL
TPoint3DS Types3DS
TPointArray Types3DS
TPointFlagArray Types3DS
TPolygonList GLMultiPolygon
TPortalMeshObjectList | GLPortal | A mesh object list that handles portal rendering.<p> The items are treated as being sectors.
TPosTrackTag Types3DS
TProgressTimes BaseClasses
TPSImport_ApplicationFileIO uPSI_ApplicationFileIO
TPSImport_GLStrings uPSI_GLStrings
TPSImport_GLUtils uPSI_GLUtils
TPSImport_PersistentClasses uPSI_PersistentClasses
TPSImport_VectorGeometry uPSI_VectorGeometry
TPSImport_VectorLists uPSI_VectorLists
TPSImport_VectorTypes uPSI_VectorTypes
TPSImport_XCollection uPSI_XCollection
TQ3BSP Q3BSP
TQuadtreeSpacePartition SpatialPartitioning
TQuaternion VectorGeometry
TQuaternionList | VectorLists | A list of TQuaternion.<p> Similar to TList, but using TQuaternion as items.<p> The list has stack-like push/pop methods.
TRagdollBone GLRagdoll
TRagdollBoneList GLRagdoll
TRagdollJoint GLRagdoll
TRasterFileFormat GLGraphics
TRasterFileFormatsList | GLGraphics | Stores registered raster file formats.
TRColorEditor FRColorEditor
TRColorEditor FRColorEditorLCL
TRect GLSDL
TRectangle VectorGeometry
TRenderContextClippingInfo GLRenderContextInfo
TRenderContextInfo | GLRenderContextInfo | Stores contextual info useful during rendering methods.
TResManagerEntry PlugInManager
TResolutionProperty GLSceneRegister
TResourceManager PlugInManager
TReuseableDefaultEditor | GLSceneRegister | Editor copied from DsgnIntf.<p> Could have been avoided, if only that guy at Borland didn't chose to publish only half of the stuff (and that's not the only class with that problem, most of the subitems handling code in TGLSceneBaseObject is here for the same reason...), the "protected" wasn't meant just to lure programmers into code they can't reuse... Arrr! and he did that again in D6! Grrr...
TRFaceEditor FRFaceEditor
TRFaceEditor FRFaceEditorLCL
TRGBPixel GLBlur
TRMapSet3DS Types3DS
TRMaterialPreview FRMaterialPreview
TRMaterialPreview FRMaterialPreviewLCL
TROAMRenderPoint GLROAMPatch
TROAMTriangleNode GLROAMPatch
TRollTrackTag Types3DS
TRotTrackTag Types3DS
TRTextureEdit FRTextureEdit
TRTextureEdit FRTextureEditLCL
TRTrackBarEdit FRTrackBarEdit
TRTrackBarEdit FRTrackBarEditLCL
TScaleTrackTag Types3DS
TSceneObj | GLSpatialPartitioning | Object for holding glscene objects in a spatial partitioning
TSCODEBase | GLODESkeletonColliders | Base ODE skeleton collider class.
TSCODEBox | GLODESkeletonColliders | Box shaped ODE geom in a skeleton collider.
TSCODECCylinder | GLODESkeletonColliders | Capsule (sphere capped cylinder) shaped ODE geom in a skeleton collider.
TSCODESphere | GLODESkeletonColliders | Sphere shaped ODE geom in a skeleton collider.
TScreenSaver | ScreenSaver | Drop this component on your main form to make it a screensaver.<p> You'll also need to change the extension from ".exe" to ".scr" (in the project options / application tab).<p> How this component works :<ul> <li>At design-time, the only event you may want to hook is OnPropertiesRequested (to diplay your screen-saver's config dialog, if you don't have one, at least fill in the AboutString property and it will be used in a ShowMessage) <li>At run-time, once its props are loaded, this component will parse the command line and trigger relevant events <li>Basicly, you only need to care about drawing in your main form's client area (in a resolution/size independant way if possible) </ul><br> There is no real difference between execution and preview modes, except for the events fired... and the size of the form :).
TSCVerletBase | GLVerletSkeletonColliders | Base verlet skeleton collider class.
TSCVerletCapsule | GLVerletSkeletonColliders | Capsule shaped verlet constraint in a skeleton collider.
TSCVerletSphere | GLVerletSkeletonColliders | Sphere shaped verlet constraint in a skeleton collider.
TSDLWindow GLSDLWindow
TSDL_ActiveEvent GLSDL
TSDL_AudioCVT GLSDL
TSDL_AudioCVTFilter GLSDL
TSDL_AudioSpec GLSDL
TSDL_BlitInfo GLSDL
TSDL_CD GLSDL
TSDL_CDTrack GLSDL
TSDL_Color GLSDL
TSDL_Cond GLSDL
TSDL_Cursor GLSDL
TSDL_error GLSDL
TSDL_Event GLSDL
TSDL_ExposeEvent GLSDL
TSDL_JoyAxisEvent GLSDL
TSDL_JoyBallEvent GLSDL
TSDL_JoyButtonEvent GLSDL
TSDL_JoyHatEvent GLSDL
TSDL_Joystick GLSDL
TSDL_KeyboardEvent GLSDL
TSDL_KeySym GLSDL
TSDL_MouseButtonEvent GLSDL
TSDL_MouseMotionEvent GLSDL
TSDL_Mutex GLSDL
TSDL_Overlay GLSDL
TSDL_Palette GLSDL
TSDL_PixelFormat GLSDL
TSDL_QuitEvent GLSDL
TSDL_Rect GLSDL
TSDL_ResizeEvent GLSDL
TSDL_RWops GLSDL
TSDL_semaphore GLSDL
TSDL_Surface GLSDL
TSDL_SysWMEvent GLSDL
TSDL_SysWMmsg GLSDL
TSDL_Thread GLSDL
TSDL_TimerID GLSDL
TSDL_UserEvent GLSDL
TSDL_version GLSDL
TSDL_VideoInfo GLSDL
TSectoredSpacePartition SpatialPartitioning
TSectorMeshObject | GLPortal | A portal renderer sector.<p>
TSectorNode SpatialPartitioning
TServiceContextTask GLContext
TShaderFileProperty GLSceneRegister
TShaderLightSourceState GLState
TShaderUniformEditor FRUniformEditor
TShadowSets3DS Types3DS
TSingleList | VectorLists | A list of Single.<p> Similar to TList, but using Single as items.<p> The list has stack-like push/pop methods.
TSkeleton | GLVectorFileObjects | Main skeleton object.<p> This class stores the bones hierarchy and animation frames.<br> It is also responsible for maintaining the "CurrentFrame" and allowing various frame blending operations.
TSkeletonBone | GLVectorFileObjects | A skeleton bone or node and its children.<p> This class is the base item of the bones hierarchy in a skeletal model. The joint values are stored in a TSkeletonFrame, but the calculated bone matrices are stored here.
TSkeletonBoneList | GLVectorFileObjects | A list of skeleton bones.<p>
TSkeletonCollider | GLVectorFileObjects | A general class storing the base level info required for skeleton based collision methods. This class is meant to be inherited from to create skeleton driven Verlet Constraints, ODE Geoms, etc. Overriden classes should be named as TSCxxxxx.
TSkeletonColliderList | GLVectorFileObjects | List class for storing TSkeletonCollider objects.
TSkeletonFrame | GLVectorFileObjects | Stores position and rotation for skeleton joints.<p> If you directly alter some values, make sure to call FlushLocalMatrixList so that the local matrices will be recalculated (the call to Flush does not recalculate the matrices, but marks the current ones as dirty).
TSkeletonFrameList | GLVectorFileObjects | A list of TSkeletonFrame objects.
TSkeletonMeshObject | GLVectorFileObjects | A mesh object with vertice bone attachments.<p> The class adds per vertex bone weights to the standard morphable mesh.<br> The TVertexBoneWeight structures are accessed via VerticesBonesWeights, they must be initialized by adjusting the BonesPerVertex and VerticeBoneWeightCount properties, you can also add vertex by vertex by using the AddWeightedBone method.<p> When BonesPerVertex is 1, the weight is ignored (set to 1.0).
TSkeletonRootBoneList | GLVectorFileObjects | This list store skeleton root bones exclusively.<p>
TSkyDomeBand GLSkydome
TSkyDomeBands GLSkydome
TSkyDomeStar GLSkydome
TSkyDomeStars GLSkydome
TSmoothGroup Types3DS
TSoundFileProperty GLSceneRegister
TSoundNameProperty GLSceneRegister
TSpacePartitionLeaf SpatialPartitioning
TSpacePartitionLeafList SpatialPartitioning
TSPCone SpatialPartitioning
TSPOctreeNode SpatialPartitioning
TSpotCone3DS Types3DS
TSpotLight3DS Types3DS
TSpotProjector3DS Types3DS
TSpotShadow3DS Types3DS
TSPQuadtreeNode SpatialPartitioning
TSpriteAnimation | GLAnimatedSprite | Animations define how the texture coordinates for each offset are to be determined.
TSpriteAnimationList | GLAnimatedSprite | A collection for storing TSpriteAnimation objects.
TSpriteAnimFrame | GLAnimatedSprite | Used by the SpriteAnimation when Dimensions are set manual. The animation will use the offsets, width and height to determine the texture coodinates for this frame.
TSpriteAnimFrameList | GLAnimatedSprite | The XCollection used for the TSpriteAnimFrame object.
TSpriteAnimMargins | GLAnimatedSprite | Used to mask the auto generated frames. The Left, Top, Right and Bottom properties determines the number of pixels to be cropped from each corresponding side of the frame. Only applicable to auto dimensions.
TStateRecord GLState
TStaticImposter | GLImposter | Imposter class whose texture contains several views from different angles.
TStdio GLSDL
TSTLFace TypesSTL
TSTLHeader TypesSTL
TStyleList GLSMemo
TTexPoint VectorGeometry
TTexPointList | VectorLists | A list of TTexPoint.<p> Similar to TList, but using TTexPoint as items.<p> The list has stack-like push/pop methods.
TTEXSChunk TypesB3D
TTextReader | PersistentClasses | Reads object persistence in Text format.
TTextureReference GLS_CUDA_Runtime
TTextWriter | PersistentClasses | Writes object persistence in Text format.
TTexVert3DS Types3DS
TTexVerts Types3DS
TTGAImage | TGA | TGA image load/save capable class for Delphi.<p> TGA formats supported : 24 and 32 bits uncompressed or RLE compressed, saves only to uncompressed TGA.
TTGLFile3DSPositionAnimationKeys GLFile3DS
TThorpoint GLThorFX
TTimeEvent GLTimeEventsMgr
TTimeEvents GLTimeEventsMgr
TTrackHeader3DS Types3DS
TTransAxis GLSDL
TTransformationRec GLPipelineTransformation
TTRISChunk TypesB3D
TUBOStates GLState
TUniformAutoSetProperty GLSceneRegister
TUnknown GLSDL
TUserView3DS Types3DS
TVCCapsule | VerletClasses | Capsule collision constraint.
TVCCube | VerletClasses | Cube collision constraint.
TVCCylinder | VerletClasses | Cylinder collision constraint.<p> The cylinder is considered infinite by this constraint.
TVCFloor | VerletClasses | Floor collision constraint
TVCHeightField | VerletClasses | HeightField collision constraint (punctual!)
TVCRigidBody | VerletClasses | Rigid body constraint.<p> Regroups several nodes in a rigid body conformation, somewhat similar to a stick but for multiple nodes. <p> EXPERIMENTAL, DOES NOT WORK!
TVCSlider | VerletClasses | Slider constraint.<p> Imposes that two nodes be aligned on a defined direction, on which they can slide freely. Note that the direction is fixed and won't rotate with the verlet assembly!.
TVCSphere | VerletClasses | Sphere collision constraint.
TVCStick | VerletClasses | Stick constraint.<p> Imposes a fixed distance between two nodes.
TVdpBitstreamBuffer GLS_VDPAU_API
TVdpColor GLS_VDPAU_API
TVdpLayer GLS_VDPAU_API
TVdpOutputSurfaceRenderBlendState GLS_VDPAU_API
TVdpPictureInfoH264 GLS_VDPAU_API
TVdpPictureInfoMPEG1Or2 GLS_VDPAU_API
TVdpPictureInfoMPEG4Part2 GLS_VDPAU_API
TVdpPictureInfoVC1 GLS_VDPAU_API
TVdpPoint GLS_VDPAU_API
TVdpProcamp GLS_VDPAU_API
TVdpRect GLS_VDPAU_API
TVdpReferenceFrameH264 GLS_VDPAU_API
TVector2b VectorTypes
TVector2d VectorTypes
TVector2e VectorTypes
TVector2f VectorTypes
TVector2h VectorTypes
TVector2i VectorTypes
TVector2p VectorTypes
TVector2s VectorTypes
TVector2sb VectorTypes
TVector2ui VectorTypes
TVector2w VectorTypes
TVector3b VectorTypes
TVector3d VectorTypes
TVector3e VectorTypes
TVector3f VectorTypes
TVector3h VectorTypes
TVector3i VectorTypes
TVector3p VectorTypes
TVector3s VectorTypes
TVector3sb VectorTypes
TVector3ui VectorTypes
TVector3w VectorTypes
TVector4b VectorTypes
TVector4d VectorTypes
TVector4e VectorTypes
TVector4f VectorTypes
TVector4h VectorTypes
TVector4i VectorTypes
TVector4p VectorTypes
TVector4s VectorTypes
TVector4sb VectorTypes
TVector4ui VectorTypes
TVector4w VectorTypes
TVectorEditorForm FVectorEditor
TVectorEditorForm FVectorEditorLCL
TVectorFile | GLVectorFileObjects | Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).
TVectorFileFormat GLVectorFileObjects
TVectorFileFormatsList | GLVectorFileObjects | Stores registered vector file formats.
TVectorList | VectorLists | A list of TVector.<p> Similar to TList, but using TVector as items.<p> The list has stack-like push/pop methods.
TVerletConstraint VerletClasses
TVerletConstraintList VerletClasses
TVerletDualConstraint VerletClasses
TVerletDualForce | VerletClasses | A verlet force that applies to two specified nodes.
TVerletEdge VerletClasses
TVerletEdgeList VerletClasses
TVerletForce | VerletClasses | Generic verlet force.
TVerletForceList VerletClasses
TVerletGlobalConstraint VerletClasses
TVerletGlobalForce | VerletClasses | A global force (applied to all verlet nodes).
TVerletGlobalFrictionConstraint VerletClasses
TVerletGlobalFrictionConstraintBox VerletClasses
TVerletGlobalFrictionConstraintSP VerletClasses
TVerletGlobalFrictionConstraintSphere VerletClasses
TVerletGroupConstraint VerletClasses
TVerletGroupForce | VerletClasses | A verlet force that applies to a specified group of nodes.
TVerletHair VerletHairClasses
TVerletNode | VerletClasses | Basic verlet node
TVerletNodeList VerletClasses
TVerletProgressTimes VerletClasses
TVerletWorld VerletClasses
TVertexBoneWeight GLVectorFileObjects
TVertexData GLMesh
TVertexData TypesB3D
TVertexList GLMesh
TVertexRec GLObjects
TVertexWeightList TypesMS3D
TVFAirResistance VerletClasses
TVFGravity VerletClasses
TVFSpring VerletClasses
TVGradientBgnd3DS Types3DS
TVIDEOHDR GLSVfw
TVideoMode GLScreen
TViewport3DS Types3DS
TViewportData Types3DS
TViewportLayout Types3DS
TViewportSize Types3DS
TViewSize3DS Types3DS
TViewStandard Types3DS
TViewUser Types3DS
TVirtualReader | PersistentClasses | Virtual layer similar to VCL's TReader (but reusable)
TVirtualWriter | PersistentClasses | Virtual layer similar to VCL's TWriter (but reusable)
TVRMLIntegerArray VRMLParser
TVRMLMaterial VRMLParser
TVRMLNode VRMLParser
TVRMLParser VRMLParser
TVRMLShapeHints VRMLParser
TVRMLSingleArray VRMLParser
TVRMLTransform VRMLParser
TVRMLUse VRMLParser
TVRTSChunk TypesB3D
TXCollection | XCollection | Holds a list of TXCollectionItem objects.<p> This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList and persistence classes (XClasses & XLists), if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than Borland's lists and persistence mechanisms (and unlike Borland's, with polymorphism-support and full backward compatibility).
TXCollectionEditor FXCollectionEditor
TXCollectionEditor FXCollectionEditorLCL
TXCollectionItem | XCollection | Base class for implementing a XCollection item.<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation </ul>
TXCollectionProperty RegisterXCollection
TXDataEntry Types3DS
TXDataRaw3DS Types3DS
TZCompressionBuffer GLSZLibEx
TZCompressionStream GLSZLibEx
TZCustomBuffer GLSZLibEx
TZDecompressionBuffer GLSZLibEx
TZDecompressionStream GLSZLibEx
TZInformation GLSZLibEx
TZLibArchive GLFileZLIB
TZLibHeader GLFileZLIB
TZStreamRec GLSZLibExApi
TZStreamRec LIBPNG
T_cl_command_queue GLS_CL
T_cl_context GLS_CL
T_cl_device_id GLS_CL
T_cl_event GLS_CL
T_cl_kernel GLS_CL
T_cl_mem GLS_CL
T_cl_platform_id GLS_CL
T_cl_program GLS_CL
T_cl_sampler GLS_CL
UInt64 GLSDL
_EFXEAXREVERBPROPERTIES openal
_EFXLOWPASSFILTER openal
_WGLSWAP OpenGLTokens
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:49


GLScene v.1.1.2: All Types

All Types

Name | Unit | Description
AFT_Bitmap_Size LIBFREETYPE
BlankJointGetInfo NewtonImport_JointLibrary
Bool NewtonImport
BOOL Bass
CGGLenum cgGL
CGLAbstractShaderUniform GLMaterialEx
CGLBaseMaterialCollectionItem GLMaterialEx
CharArray NewtonImport
CLogSession GLSLog
cudaError_t GLS_CUDA_Runtime
cudaEvent_t GLS_CUDA_Runtime
cudaStream_t GLS_CUDA_Runtime
DGRaycastVehicleTireTransformCallback NewtonImport_JointLibrary
DOWNLOADPROC Bass
DSPPROC Bass
DSPROPERTY_EAX_BUFFERPROPERTY openal
DSPROPERTY_EAX_LISTENERPROPERTY openal
DWORD GLCrossPlatform
DWORD Bass
EFXEAXREVERBPROPERTIES openal
EFXLOWPASSFILTER openal
EGLOSError GLCrossPlatform
EnqueueNativeKernel_user_func GLS_CL
EOpenALError GLSMOpenAL
EZLibErrorClass GLSZLibEx
Float NewtonImport
FLOAT Bass
FSOUND_SPEAKERMODES fmodtypes
FTC_CMapCache LIBFREETYPE
FTC_FaceID LIBFREETYPE
FTC_Face_Requester LIBFREETYPE
FTC_ImageCache LIBFREETYPE
FTC_ImageType LIBFREETYPE
FTC_Manager LIBFREETYPE
FTC_Node LIBFREETYPE
FTC_SBit LIBFREETYPE
FTC_SBitCache LIBFREETYPE
FTC_Scaler LIBFREETYPE
FT_Alloc_Func LIBFREETYPE
FT_Angle LIBFREETYPE
FT_BBox_ptr LIBFREETYPE
FT_Bitmap_ptr LIBFREETYPE
FT_Bitmap_Size_ptr LIBFREETYPE
FT_Bool LIBFREETYPE
FT_Byte LIBFREETYPE
FT_Bytes LIBFREETYPE
FT_Byte_array LIBFREETYPE
FT_Byte_ptr LIBFREETYPE
FT_Char LIBFREETYPE
FT_Charmap LIBFREETYPE
FT_Charmap_array LIBFREETYPE
FT_Charmap_ptr LIBFREETYPE
FT_DebugHook_Func LIBFREETYPE
FT_Encoding LIBFREETYPE
FT_Error LIBFREETYPE
FT_F26Dot6 LIBFREETYPE
FT_Face LIBFREETYPE
FT_Face_array LIBFREETYPE
FT_Face_ptr LIBFREETYPE
FT_Fixed LIBFREETYPE
FT_Fixed_ptr LIBFREETYPE
FT_Free_Func LIBFREETYPE
FT_Generic_Finalizer LIBFREETYPE
FT_Glyph LIBFREETYPE
FT_GlyphSlot LIBFREETYPE
FT_Glyph_Class LIBFREETYPE
FT_Glyph_Format LIBFREETYPE
FT_Int LIBFREETYPE
FT_Int32 LIBFREETYPE
FT_Library LIBFREETYPE
FT_Library_array LIBFREETYPE
FT_Library_ptr LIBFREETYPE
FT_List LIBFREETYPE
FT_ListNode LIBFREETYPE
FT_List_Destructor LIBFREETYPE
FT_List_Iterator LIBFREETYPE
FT_Long LIBFREETYPE
FT_Long_ptr LIBFREETYPE
FT_Memory LIBFREETYPE
FT_Module LIBFREETYPE
FT_Module_Class LIBFREETYPE
FT_Orientation LIBFREETYPE
FT_Outline LIBFREETYPE
FT_Outline_ConicToFunc LIBFREETYPE
FT_Outline_CubicToFunc LIBFREETYPE
FT_Outline_LineToFunc LIBFREETYPE
FT_Outline_MoveToFunc LIBFREETYPE
FT_Pointer LIBFREETYPE
FT_Pos LIBFREETYPE
FT_Raster LIBFREETYPE
FT_Raster_BitSet_Func LIBFREETYPE
FT_Raster_BitTest_Func LIBFREETYPE
FT_Raster_DoneFunc LIBFREETYPE
FT_Raster_NewFunc LIBFREETYPE
FT_Raster_RenderFunc LIBFREETYPE
FT_Raster_Render_Func LIBFREETYPE
FT_Raster_ResetFunc LIBFREETYPE
FT_Raster_SetModeFunc LIBFREETYPE
FT_Realloc_Func LIBFREETYPE
FT_Renderer LIBFREETYPE
FT_Renderer_GetCBoxFunc LIBFREETYPE
FT_Renderer_RenderFunc LIBFREETYPE
FT_Renderer_SetModeFunc LIBFREETYPE
FT_Renderer_TransformFunc LIBFREETYPE
FT_Render_Mode LIBFREETYPE
FT_Sfnt_Tag LIBFREETYPE
FT_Short LIBFREETYPE
FT_Short_array LIBFREETYPE
FT_Short_ptr LIBFREETYPE
FT_Size LIBFREETYPE
FT_Size_Request LIBFREETYPE
FT_Size_Request_Type LIBFREETYPE
FT_SpanFunc LIBFREETYPE
FT_Stream LIBFREETYPE
FT_Stream_CloseFunc LIBFREETYPE
FT_Stream_IoFunc LIBFREETYPE
FT_String LIBFREETYPE
FT_Stroker LIBFREETYPE
FT_StrokerBorder LIBFREETYPE
FT_Stroker_LineCap LIBFREETYPE
FT_Stroker_LineJoin LIBFREETYPE
FT_Subglyph_ptr LIBFREETYPE
FT_Tables LIBFREETYPE
FT_TrueTypeEngineType LIBFREETYPE
FT_UInt LIBFREETYPE
FT_UInt32 LIBFREETYPE
FT_UInt_ptr LIBFREETYPE
FT_ULong LIBFREETYPE
FT_UShort LIBFREETYPE
FT_Vector_array LIBFREETYPE
FT_Vector_ptr LIBFREETYPE
GETJSAMPLE GLSJPG
GLbitfield OpenGLTokens
GLboolean OpenGLTokens
GLbyte OpenGLTokens
GLclampd OpenGLTokens
GLclampf OpenGLTokens
GLdouble OpenGLTokens
GLenum OpenGLTokens
GLfloat OpenGLTokens
GLhandleARB OpenGLTokens
GLint OpenGLTokens
GLint64 OpenGLTokens
GLint64EXT OpenGLTokens
GLintptr OpenGLTokens
GLSDOMNode GLSCrossXML
GLshort OpenGLTokens
GLsizei OpenGLTokens
GLsizeiptr OpenGLTokens
GLSXMLDocument GLSCrossXML
GLSXMLNode GLSCrossXML
GLsync OpenGLTokens
GLubyte OpenGLTokens
GLuint OpenGLTokens
GLuint64 OpenGLTokens
GLuint64EXT OpenGLTokens
GLushort OpenGLTokens
HCHANNEL Bass
HDRAWDIB GLSVfw
HDSP Bass
HFX Bass
HGPUNV GLS_CUDA_API
HGPUNV OpenGLTokens
HIC GLSVfw
HMODULE openal
HMUSIC Bass
HPBUFFERARB OpenGLTokens
HPLUGIN Bass
HRECORD Bass
HSAMPLE Bass
HSTREAM Bass
HSYNC Bass
HVIDEO GLSVfw
Int NewtonImport
int GLSVfw
int LIBPNG
INT16 GLSJPG
INT32 GLSJPG
INT32PTR GLSJPG
int8array GLSJPG
intptr_t GLS_CL_Platform
JCOEF GLSJPG
JCOEF_PTR GLSJPG
JDIMENSION GLSJPG
jmp_bufp LIBPNG
JOCTET GLSJPG
JOCTETPTR GLSJPG
JOCTET_FIELD GLSJPG
JOCTET_FIELD_PTR GLSJPG
jpeg_component_info_ptr GLSJPG
jpeg_destination_mgr_ptr GLSJPG
jpeg_error_mgr_ptr GLSJPG
jpeg_marker_parser_method GLSJPG
jpeg_marker_reader_ptr GLSJPG
jpeg_memory_mgr_ptr GLSJPG
jpeg_progress_mgr_ptr GLSJPG
jpeg_source_mgr_ptr GLSJPG
JQUANT_TBL_ptr GLSJPG
JSAMPARRAY GLSJPG
JSAMPIMAGE GLSJPG
JSAMPLE GLSJPG
JSAMPLE_ARRAY GLSJPG
JSAMPLE_PTR GLSJPG
JSAMPROW GLSJPG
JSAMPROW_ARRAY GLSJPG
JSAMPROW_PTR GLSJPG
JSAMP_ARRAY GLSJPG
jTArray GLSJPG
jTOctet GLSJPG
jTRow GLSJPG
jTSample GLSJPG
J_COLOR_SPACE GLSJPG
j_common_ptr GLSJPG
j_compress_ptr GLSJPG
J_DCT_METHOD GLSJPG
j_decompress_ptr GLSJPG
J_DITHER_MODE GLSJPG
logging_fn GLS_CL
Long NewtonImport
LONG GLSVfw
Long_double NewtonImport
NChar NewtonImport
NewtonAllocMemory NewtonImport
NewtonApplyForceAndTorque NewtonImport
NewtonBallCallBack NewtonImport
NewtonBodyDestructor NewtonImport
NewtonBodyIterator NewtonImport
NewtonBodyLeaveWorld NewtonImport
NewtonCollisionCompoundBreakableCallback NewtonImport
NewtonCollisionDestructor NewtonImport
NewtonCollisionIterator NewtonImport
NewtonCollisionTreeRayCastCallback NewtonImport
NewtonConstraintDestructor NewtonImport
NewtonContactsProcess NewtonImport
NewtonCorkscrewCallBack NewtonImport
NewtonDeserialize NewtonImport
NewtonDestroyBodyByExeciveForce NewtonImport
NewtonDestroyWorld NewtonImport
NewtonFreeMemory NewtonImport
NewtonGetBuoyancyPlane NewtonImport
NewtonGetTicksCountCallback NewtonImport
NewtonHeightFieldRayCastCallback NewtonImport
NewtonHingeCallBack NewtonImport
NewtonIslandUpdate NewtonImport
NewtonJointIterator NewtonImport
NewtonOnAABBOverlap NewtonImport
NewtonSerialize NewtonImport
NewtonSetTransform NewtonImport
NewtonSliderCallBack NewtonImport
NewtonTreeCollisionCallback NewtonImport
NewtonUniversalCallBack NewtonImport
NewtonUserBilateralCallBack NewtonImport
NewtonUserBilateralGetInfoCallBack NewtonImport
NewtonUserJointDestructorCallback NewtonImport_JointLibrary
NewtonUserJointSubmitConstraintCallback NewtonImport_JointLibrary
NewtonUserMeshCollisionCollideCallback NewtonImport
NewtonUserMeshCollisionDestroyCallback NewtonImport
NewtonUserMeshCollisionGetCollisionInfo NewtonImport
NewtonUserMeshCollisionGetFacesInAABB NewtonImport
NewtonUserMeshCollisionRayHitCallback NewtonImport
NewtonWorldRayFilterCallback NewtonImport
NewtonWorldRayPrefilterCallback NewtonImport
NGDFloat GLNGDManager
P2Char NewtonImport
P4ByteArrayList VectorLists
PAABB GeometryBB
PAArray GLzBuffer
PACubic3DS Types3DS
PAffineByteVector VectorGeometry
PAffineDblVector VectorGeometry
PAffineExtVector VectorGeometry
PAffineFltVector VectorGeometry
PAffineIntVector VectorGeometry
PAffineMatrix VectorGeometry
PAffinePtrVector VectorGeometry
PAffineVector VectorGeometry
PAffineVectorArray VectorGeometry
PAffineWordVector VectorGeometry
PALbitfield openal
PALboolean openal
PALbyte openal
PALCboolean openal
PALCbyte openal
PALCchar openal
PALCcontext openal
PALCdevice openal
PALCdouble openal
PALCenum openal
PALCfloat openal
PALchar openal
PALCint openal
PALclampd openal
PALclampf openal
PALCshort openal
PALCsizei openal
PALCubyte openal
PALCuint openal
PALCushort openal
PALCvoid openal
PALdouble openal
PALenum openal
PALfloat openal
PALint openal
PALshort openal
PALsizei openal
PALuByte openal
PALuint openal
PALushort openal
PALvoid openal
PANG4 LWObjects
PANIMChunk TypesB3D
PAtmosphere3DS Types3DS
PAVICOMPRESSOPTIONS GLSVfw
PAVIFileInfo GLSVfw
PAVIFileInfoA GLSVfw
PAVIFileInfoW GLSVfw
PAVIINDEXENTRY GLSVfw
PAVIPALCHANGE GLSVfw
PAVIStream GLAVIRecorder
PAVIStreamHeader GLSVfw
PAVIStreamInfo GLSVfw
PAVIStreamInfoA GLSVfw
PAVIStreamInfoW GLSVfw
PB3DChunk TypesB3D
PBackground3DS Types3DS
PBallDelta GLSDL
PBASS_PLUGINFORMS Bass
PBASS_PLUGININFO Bass
PBB3DChunk TypesB3D
PBitmap3DS Types3DS
PBitmapBgnd3DS Types3DS
PBitMapName Types3DS
PBlankJointGetInfo NewtonImport_JointLibrary
PBONEChunk TypesB3D
PBool NewtonImport
PBoundBox Types3DS
PBRUSChunk TypesB3D
PBSPFace Q3BSP
PBSPLightmap Q3BSP
PBSPTexture Q3BSP
PBSPVertex Q3BSP
PByte HeightTileFile
PByte GLSDL
PByteArray VectorGeometry
PByteArray GLSDL
PByteRaster GLHeightData
PByteVector VectorGeometry
PCamera3DS Types3DS
PCamRanges Types3DS
PCamRanges3DS Types3DS
PCAPDRIVERCAPS GLSVfw
PCAPINFOCHUNK GLSVfw
PCAPSTATUS GLSVfw
PCAPTUREPARMS GLSVfw
PCardinalArray VectorGeometry
PCardinalArray Types3DS
PCardinalVector VectorGeometry
PCHANNEL_CAPS GLSVfw
PChar3DS Types3DS
PCharArray NewtonImport
PCharInfo GLBitmapFont
PChunk3DS Types3DS
PChunkList Types3DS
PChunkList3DS Types3DS
PChunkListEntry3DS Types3DS
Pcl_addressing_mode GLS_CL
Pcl_bitfield GLS_CL
Pcl_bool GLS_CL
Pcl_build_status GLS_CL
Pcl_channel_order GLS_CL
Pcl_channel_type GLS_CL
Pcl_char GLS_CL_Platform
Pcl_command_queue GLS_CL
Pcl_command_queue_info GLS_CL
Pcl_command_queue_properties GLS_CL
Pcl_command_type GLS_CL
Pcl_context GLS_CL
Pcl_context_info GLS_CL
Pcl_context_properties GLS_CL
Pcl_device_address_info GLS_CL
Pcl_device_exec_capabilities GLS_CL
Pcl_device_fp_config GLS_CL
Pcl_device_id GLS_CL
Pcl_device_info GLS_CL
Pcl_device_local_mem_type GLS_CL
Pcl_device_mem_cache_type GLS_CL
Pcl_device_type GLS_CL
Pcl_double GLS_CL_Platform
Pcl_event GLS_CL
Pcl_event_info GLS_CL
Pcl_filter_mode GLS_CL
Pcl_float GLS_CL_Platform
Pcl_gl_object_type GLS_CL_GL
Pcl_gl_platform_info GLS_CL_GL
Pcl_gl_texture_info GLS_CL_GL
Pcl_half GLS_CL_Platform
Pcl_image_format GLS_CL
Pcl_image_info GLS_CL
Pcl_int GLS_CL_Platform
Pcl_kernel GLS_CL
Pcl_kernel_info GLS_CL
Pcl_kernel_work_group_info GLS_CL
Pcl_long GLS_CL_Platform
Pcl_map_flags GLS_CL
Pcl_mem GLS_CL
Pcl_mem_flags GLS_CL
Pcl_mem_info GLS_CL
Pcl_mem_object_type GLS_CL
Pcl_platform_id GLS_CL
Pcl_platform_info GLS_CL
Pcl_profiling_info GLS_CL
Pcl_program GLS_CL
Pcl_program_build_info GLS_CL
Pcl_program_info GLS_CL
Pcl_sampler GLS_CL
Pcl_sampler_info GLS_CL
Pcl_short GLS_CL_Platform
Pcl_uchar GLS_CL_Platform
Pcl_uint GLS_CL_Platform
Pcl_ulong GLS_CL_Platform
Pcl_ushort GLS_CL_Platform
PColor24 Types3DS
PColorEntry GLColor
PColorF Types3DS
PColorVector GLColor
PColr12 LWObjects
PColr4 LWObjects
PColTrackTag Types3DS
PCOMPVARS GLSVfw
PCUarray GLS_CUDA_API
PCUcontext GLS_CUDA_API
PcudaArray GLS_CUDA_Runtime
PcudaChannelFormatDesc GLS_CUDA_Runtime
PCudaDeviceProp GLS_CUDA_Runtime
PCUDA_ARRAY_DESCRIPTOR GLS_CUDA_API
PCUDA_MEMCPY2D GLS_CUDA_API
PCUevent GLS_CUDA_API
PcufftComplex GLS_CUDA_FourierTransform
PcufftDoubleComplex GLS_CUDA_FourierTransform
PcufftDoubleReal GLS_CUDA_FourierTransform
PcufftReal GLS_CUDA_FourierTransform
PCUfunction GLS_CUDA_API
PCUgraphicsResource GLS_CUDA_API
PCUmodule GLS_CUDA_API
PCUstream GLS_CUDA_API
PCUtexref GLS_CUDA_API
Pd3Axis ODEImport
PDatabase3DS Types3DS
PdContact ODEImport
PdContactGeom ODEImport
PDCueSettings3DS Types3DS
PdGeomClass ODEImport
PDGRaycastVehicleTireTransformCallback NewtonImport_JointLibrary
PdInteger3 ODEImport
PdIntegerArray ODEImport
PDisplay GLS_VDPAU_X11
PDistanceCue Types3DS
PDlExclude Types3DS
PDlInnerRange Types3DS
PDlLocalShadow2 Types3DS
PDlMultiplier Types3DS
PDlOuterRange Types3DS
PDlRayBias Types3DS
PDlSpotAspect Types3DS
PDlSpotlight Types3DS
PDlSpotProjector Types3DS
PDlSpotRoll Types3DS
PdMass ODEImport
PdMatrix3 ODEImport
PdMatrix3_As3x4 ODEImport
PdMatrix4 ODEImport
PdMatrix6 ODEImport
PdObject ODEImport
PDoubleArray VectorGeometry
PDoubleArrayList VectorLists
PDoubleVector VectorGeometry
PdQuaternion ODEImport
PDRAWDIBTIME GLSVfw
PdReal ODEImport
PdRealArray ODEImport
PdRealHugeArray ODEImport
PdVector3 ODEImport
PdVector3Array ODEImport
PdVector4 ODEImport
PdxBody ODEImport
PdxGeom ODEImport
PdxHashSpace ODEImport
PdxHeightfieldData ODEImport
PdxJoint ODEImport
PdxJointBall ODEImport
PdxJointGroup ODEImport
PdxJointHinge ODEImport
PdxJointHinge2 ODEImport
PdxJointLimitMotor ODEImport
PdxJointLimitMotor3 ODEImport
PdxJointNode ODEImport
PdxJointPiston ODEImport
PdxJointPR ODEImport
PdxJointSlider ODEImport
PdxJointUniversial ODEImport
PdxPosR ODEImport
PdxSimpleSpace ODEImport
PdxSpace ODEImport
PDXT3AlphaBlock DXTC
PDXT5AlphaBlock DXTC
PDXTColBlock DXTC
PdxTriMeshData ODEImport
PdxWorld ODEImport
PEaxBufferProperties openal
PEaxListenerProperties openal
PEFXEAXREVERBPROPERTIES openal
PEFXLOWPASSFILTER openal
PExtendedArray VectorGeometry
PExtendedVector VectorGeometry
PF4 LWObjects
PF4Array LWObjects
PFace3DS Types3DS
PFaceArray Types3DS
PFaceList Types3DS
PFallTrackTag Types3DS
PFastCollisionChecker GLCollision
PFColor3DS Types3DS
PFColorList Types3DS
PFireParticle GLFireFX
PFireParticleArray GLFireFX
PFloat NewtonImport
PFloat VectorGeometry
PFloatArray VectorGeometry
PFloatPercentage Types3DS
PFloatVector VectorGeometry
PFMusicModule fmodtypes
PFNGLACTIVESHADERPROGRAMPROC OpenGLTokens
PFNGLACTIVESTENCILFACEEXTPROC OpenGLTokens
PFNGLACTIVETEXTUREARBPROC OpenGLTokens
PFNGLACTIVETEXTUREPROC OpenGLTokens
PFNGLACTIVEVARYINGNVPROC OpenGLTokens
PFNGLADDSWAPHINTRECTWINPROC OpenGLTokens
PFNGLAREPROGRAMSRESIDENTNVPROC OpenGLTokens
PFNGLARETEXTURESRESIDENTEXTPROC OpenGLTokens
PFNGLARRAYELEMENTARRAYEXTPROC OpenGLTokens
PFNGLATTACHOBJECTARBPROC OpenGLTokens
PFNGLATTACHSHADERPROC OpenGLTokens
PFNGLBEGINCONDITIONALRENDERNVPROC OpenGLTokens
PFNGLBEGINCONDITIONALRENDERPROC OpenGLTokens
PFNGLBEGINOCCLUSIONQUERYNVPROC OpenGLTokens
PFNGLBEGINQUERYARBPROC OpenGLTokens
PFNGLBEGINQUERYINDEXEDPROC OpenGLTokens
PFNGLBEGINQUERYPROC OpenGLTokens
PFNGLBEGINSCENEEXTPROC OpenGLTokens
PFNGLBEGINTRANSFORMFEEDBACKEXTPROC OpenGLTokens
PFNGLBEGINTRANSFORMFEEDBACKNVPROC OpenGLTokens
PFNGLBEGINTRANSFORMFEEDBACKPROC OpenGLTokens
PFNGLBINDATTRIBLOCATIONARBPROC OpenGLTokens
PFNGLBINDATTRIBLOCATIONPROC OpenGLTokens
PFNGLBINDBUFFERARBPROC OpenGLTokens
PFNGLBINDBUFFERBASEEXTPROC OpenGLTokens
PFNGLBINDBUFFERBASENVPROC OpenGLTokens
PFNGLBINDBUFFERBASEPROC OpenGLTokens
PFNGLBINDBUFFEROFFSETEXTPROC OpenGLTokens
PFNGLBINDBUFFEROFFSETNVPROC OpenGLTokens
PFNGLBINDBUFFERPROC OpenGLTokens
PFNGLBINDBUFFERRANGEEXTPROC OpenGLTokens
PFNGLBINDBUFFERRANGENVPROC OpenGLTokens
PFNGLBINDBUFFERRANGEPROC OpenGLTokens
PFNGLBINDFRAGDATALOCATIONEXTPROC OpenGLTokens
PFNGLBINDFRAGDATALOCATIONINDEXEDPROC OpenGLTokens
PFNGLBINDFRAGDATALOCATIONPROC OpenGLTokens
PFNGLBINDFRAMEBUFFEREXTPROC OpenGLTokens
PFNGLBINDFRAMEBUFFERPROC OpenGLTokens
PFNGLBINDMULTITEXTUREEXTPROC OpenGLTokens
PFNGLBINDPROGRAMARBPROC OpenGLTokens
PFNGLBINDPROGRAMNVPROC OpenGLTokens
PFNGLBINDPROGRAMPIPELINEPROC OpenGLTokens
PFNGLBINDRENDERBUFFEREXTPROC OpenGLTokens
PFNGLBINDRENDERBUFFERPROC OpenGLTokens
PFNGLBINDSAMPLERPROC OpenGLTokens
PFNGLBINDTEXTUREEXTPROC OpenGLTokens
PFNGLBINDTRANSFORMFEEDBACKPROC OpenGLTokens
PFNGLBINDVERTEXARRAYPROC OpenGLTokens
PFNGLBLENDCOLOREXTPROC OpenGLTokens
PFNGLBLENDCOLORPROC OpenGLTokens
PFNGLBLENDEQUATIONEXTPROC OpenGLTokens
PFNGLBLENDEQUATIONIARBPROC OpenGLTokens
PFNGLBLENDEQUATIONIPROC OpenGLTokens
PFNGLBLENDEQUATIONPROC OpenGLTokens
PFNGLBLENDEQUATIONSEPARATEEXTPROC OpenGLTokens
PFNGLBLENDEQUATIONSEPARATEIARBPROC OpenGLTokens
PFNGLBLENDEQUATIONSEPARATEIPROC OpenGLTokens
PFNGLBLENDEQUATIONSEPARATEPROC OpenGLTokens
PFNGLBLENDFUNCIARBPROC OpenGLTokens
PFNGLBLENDFUNCIPROC OpenGLTokens
PFNGLBLENDFUNCSEPARATEEXTPROC OpenGLTokens
PFNGLBLENDFUNCSEPARATEIARBPROC OpenGLTokens
PFNGLBLENDFUNCSEPARATEIPROC OpenGLTokens
PFNGLBLENDFUNCSEPARATEPROC OpenGLTokens
PFNGLBLITFRAMEBUFFEREXTPROC OpenGLTokens
PFNGLBLITFRAMEBUFFERPROC OpenGLTokens
PFNGLBUFFERADDRESSRANGENVPROC OpenGLTokens
PFNGLBUFFERDATAARBPROC OpenGLTokens
PFNGLBUFFERDATAPROC OpenGLTokens
PFNGLBUFFERSUBDATAARBPROC OpenGLTokens
PFNGLBUFFERSUBDATAPROC OpenGLTokens
PFNGLCHECKFRAMEBUFFERSTATUSEXTPROC OpenGLTokens
PFNGLCHECKFRAMEBUFFERSTATUSPROC OpenGLTokens
PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC OpenGLTokens
PFNGLCLAMPCOLORARBPROC OpenGLTokens
PFNGLCLAMPCOLORPROC OpenGLTokens
PFNGLCLEARBUFFERFIPROC OpenGLTokens
PFNGLCLEARBUFFERFVPROC OpenGLTokens
PFNGLCLEARBUFFERIVPROC OpenGLTokens
PFNGLCLEARBUFFERUIVPROC OpenGLTokens
PFNGLCLEARCOLORIIEXTPROC OpenGLTokens
PFNGLCLEARCOLORIUIEXTPROC OpenGLTokens
PFNGLCLEARDEPTHFPROC OpenGLTokens
PFNGLCLIENTACTIVETEXTUREARBPROC OpenGLTokens
PFNGLCLIENTACTIVETEXTUREPROC OpenGLTokens
PFNGLCLIENTATTRIBDEFAULTEXTPROC OpenGLTokens
PFNGLCLIENTWAITSYNCPROC OpenGLTokens
PFNGLCOLORFORMATNVPROC OpenGLTokens
PFNGLCOLORMASKINDEXEDEXTPROC OpenGLTokens
PFNGLCOLORMASKIPROC OpenGLTokens
PFNGLCOLORP3UIPROC OpenGLTokens
PFNGLCOLORP3UIVPROC OpenGLTokens
PFNGLCOLORP4UIPROC OpenGLTokens
PFNGLCOLORP4UIVPROC OpenGLTokens
PFNGLCOLORSUBTABLEEXTPROC OpenGLTokens
PFNGLCOLORSUBTABLEPROC OpenGLTokens
PFNGLCOLORTABLEEXTPROC OpenGLTokens
PFNGLCOLORTABLEPARAMETERFVPROC OpenGLTokens
PFNGLCOLORTABLEPARAMETERIVPROC OpenGLTokens
PFNGLCOLORTABLEPROC OpenGLTokens
PFNGLCOMBINERINPUTNVPROC OpenGLTokens
PFNGLCOMBINEROUTPUTNVPROC OpenGLTokens
PFNGLCOMBINERPARAMETERFNVPROC OpenGLTokens
PFNGLCOMBINERPARAMETERFVNVPROC OpenGLTokens
PFNGLCOMBINERPARAMETERINVPROC OpenGLTokens
PFNGLCOMBINERPARAMETERIVNVPROC OpenGLTokens
PFNGLCOMPILESHADERARBPROC OpenGLTokens
PFNGLCOMPILESHADERPROC OpenGLTokens
PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC OpenGLTokens
PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC OpenGLTokens
PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC OpenGLTokens
PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC OpenGLTokens
PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC OpenGLTokens
PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC OpenGLTokens
PFNGLCOMPRESSEDTEXIMAGE1DARBPROC OpenGLTokens
PFNGLCOMPRESSEDTEXIMAGE1DPROC OpenGLTokens
PFNGLCOMPRESSEDTEXIMAGE2DARBPROC OpenGLTokens
PFNGLCOMPRESSEDTEXIMAGE2DPROC OpenGLTokens
PFNGLCOMPRESSEDTEXIMAGE3DARBPROC OpenGLTokens
PFNGLCOMPRESSEDTEXIMAGE3DPROC OpenGLTokens
PFNGLCOMPRESSEDTEXSUBIMAGE1DARBPROC OpenGLTokens
PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC OpenGLTokens
PFNGLCOMPRESSEDTEXSUBIMAGE2DARBPROC OpenGLTokens
PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC OpenGLTokens
PFNGLCOMPRESSEDTEXSUBIMAGE3DARBPROC OpenGLTokens
PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC OpenGLTokens
PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC OpenGLTokens
PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC OpenGLTokens
PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC OpenGLTokens
PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC OpenGLTokens
PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC OpenGLTokens
PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC OpenGLTokens
PFNGLCONVOLUTIONFILTER1DPROC OpenGLTokens
PFNGLCONVOLUTIONFILTER2DPROC OpenGLTokens
PFNGLCONVOLUTIONPARAMETERFPROC OpenGLTokens
PFNGLCONVOLUTIONPARAMETERFVPROC OpenGLTokens
PFNGLCONVOLUTIONPARAMETERIPROC OpenGLTokens
PFNGLCONVOLUTIONPARAMETERIVPROC OpenGLTokens
PFNGLCOPYBUFFERSUBDATAPROC OpenGLTokens
PFNGLCOPYCOLORSUBTABLEPROC OpenGLTokens
PFNGLCOPYCOLORTABLEPROC OpenGLTokens
PFNGLCOPYCONVOLUTIONFILTER1DPROC OpenGLTokens
PFNGLCOPYCONVOLUTIONFILTER2DPROC OpenGLTokens
PFNGLCOPYIMAGESUBDATANVPROC OpenGLTokens
PFNGLCOPYMULTITEXIMAGE1DEXTPROC OpenGLTokens
PFNGLCOPYMULTITEXIMAGE2DEXTPROC OpenGLTokens
PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC OpenGLTokens
PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC OpenGLTokens
PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC OpenGLTokens
PFNGLCOPYPATHNVPROC OpenGLTokens
PFNGLCOPYTEXIMAGE1DEXTPROC OpenGLTokens
PFNGLCOPYTEXIMAGE2DEXTPROC OpenGLTokens
PFNGLCOPYTEXSUBIMAGE1DEXTPROC OpenGLTokens
PFNGLCOPYTEXSUBIMAGE2DEXTPROC OpenGLTokens
PFNGLCOPYTEXSUBIMAGE3DEXTPROC OpenGLTokens
PFNGLCOPYTEXSUBIMAGE3DPROC OpenGLTokens
PFNGLCOPYTEXTUREIMAGE1DEXTPROC OpenGLTokens
PFNGLCOPYTEXTUREIMAGE2DEXTPROC OpenGLTokens
PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC OpenGLTokens
PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC OpenGLTokens
PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC OpenGLTokens
PFNGLCOVERFILLPATHINSTANCEDNVPROC OpenGLTokens
PFNGLCOVERFILLPATHNVPROC OpenGLTokens
PFNGLCOVERSTROKEPATHINSTANCEDNVPROC OpenGLTokens
PFNGLCOVERSTROKEPATHNVPROC OpenGLTokens
PFNGLCREATEPROGRAMOBJECTARBPROC OpenGLTokens
PFNGLCREATEPROGRAMPROC OpenGLTokens
PFNGLCREATESHADEROBJECTARBPROC OpenGLTokens
PFNGLCREATESHADERPROC OpenGLTokens
PFNGLCREATESHADERPROGRAMVPROC OpenGLTokens
PFNGLCURRENTPALETTEMATRIXARBPROC OpenGLTokens
PFNGLDEBUGMESSAGECALLBACKARBPROC OpenGLTokens
PFNGLDEBUGMESSAGECONTROLARBPROC OpenGLTokens
PFNGLDEBUGMESSAGEINSERTARBPROC OpenGLTokens
PFNGLDELETEBUFFERSARBPROC OpenGLTokens
PFNGLDELETEBUFFERSPROC OpenGLTokens
PFNGLDELETEFENCESNVPROC OpenGLTokens
PFNGLDELETEFRAMEBUFFERSEXTPROC OpenGLTokens
PFNGLDELETEFRAMEBUFFERSPROC OpenGLTokens
PFNGLDELETEOBJECTARBPROC OpenGLTokens
PFNGLDELETEOCCLUSIONQUERIESNVPROC OpenGLTokens
PFNGLDELETEPATHSNVPROC OpenGLTokens
PFNGLDELETEPROGRAMPIPELINESPROC OpenGLTokens
PFNGLDELETEPROGRAMPROC OpenGLTokens
PFNGLDELETEPROGRAMSARBPROC OpenGLTokens
PFNGLDELETEPROGRAMSNVPROC OpenGLTokens
PFNGLDELETEQUERIESARBPROC OpenGLTokens
PFNGLDELETEQUERIESPROC OpenGLTokens
PFNGLDELETERENDERBUFFERSEXTPROC OpenGLTokens
PFNGLDELETERENDERBUFFERSPROC OpenGLTokens
PFNGLDELETESAMPLERSPROC OpenGLTokens
PFNGLDELETESHADERPROC OpenGLTokens
PFNGLDELETESYNCPROC OpenGLTokens
PFNGLDELETETEXTURESEXTPROC OpenGLTokens
PFNGLDELETETRANSFORMFEEDBACKSPROC OpenGLTokens
PFNGLDELETEVERTEXARRAYSPROC OpenGLTokens
PFNGLDEPTHBOUNDSEXTPROC OpenGLTokens
PFNGLDEPTHRANGEARRAYVPROC OpenGLTokens
PFNGLDEPTHRANGEFPROC OpenGLTokens
PFNGLDEPTHRANGEINDEXEDPROC OpenGLTokens
PFNGLDETACHOBJECTARBPROC OpenGLTokens
PFNGLDETACHSHADERPROC OpenGLTokens
PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC OpenGLTokens
PFNGLDISABLEINDEXEDEXTPROC OpenGLTokens
PFNGLDISABLEIPROC OpenGLTokens
PFNGLDISABLEVERTEXATTRIBARRAYARBPROC OpenGLTokens
PFNGLDISABLEVERTEXATTRIBARRAYPROC OpenGLTokens
PFNGLDRAWARRAYSINDIRECTPROC OpenGLTokens
PFNGLDRAWARRAYSINSTANCEDARBPROC OpenGLTokens
PFNGLDRAWARRAYSINSTANCEDEXTPROC OpenGLTokens
PFNGLDRAWARRAYSINSTANCEDPROC OpenGLTokens
PFNGLDRAWBUFFERSARBPROC OpenGLTokens
PFNGLDRAWBUFFERSATIPROC OpenGLTokens
PFNGLDRAWBUFFERSPROC OpenGLTokens
PFNGLDRAWELEMENTSBASEVERTEXPROC OpenGLTokens
PFNGLDRAWELEMENTSINDIRECTPROC OpenGLTokens
PFNGLDRAWELEMENTSINSTANCEDARBPROC OpenGLTokens
PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC OpenGLTokens
PFNGLDRAWELEMENTSINSTANCEDEXTPROC OpenGLTokens
PFNGLDRAWELEMENTSINSTANCEDPROC OpenGLTokens
PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC OpenGLTokens
PFNGLDRAWRANGEELEMENTSEXTPROC OpenGLTokens
PFNGLDRAWRANGEELEMENTSPROC OpenGLTokens
PFNGLDRAWTRANSFORMFEEDBACKPROC OpenGLTokens
PFNGLDRAWTRANSFORMFEEDBACKSTREAMPROC OpenGLTokens
PFNGLEDGEFLAGFORMATNVPROC OpenGLTokens
PFNGLENABLECLIENTSTATEINDEXEDEXTPROC OpenGLTokens
PFNGLENABLEINDEXEDEXTPROC OpenGLTokens
PFNGLENABLEIPROC OpenGLTokens
PFNGLENABLEVERTEXATTRIBARRAYARBPROC OpenGLTokens
PFNGLENABLEVERTEXATTRIBARRAYPROC OpenGLTokens
PFNGLENDCONDITIONALRENDERNVPROC OpenGLTokens
PFNGLENDCONDITIONALRENDERPROC OpenGLTokens
PFNGLENDOCCLUSIONQUERYNVPROC OpenGLTokens
PFNGLENDQUERYARBPROC OpenGLTokens
PFNGLENDQUERYINDEXEDPROC OpenGLTokens
PFNGLENDQUERYPROC OpenGLTokens
PFNGLENDSCENEEXTPROC OpenGLTokens
PFNGLENDTRANSFORMFEEDBACKEXTPROC OpenGLTokens
PFNGLENDTRANSFORMFEEDBACKNVPROC OpenGLTokens
PFNGLENDTRANSFORMFEEDBACKPROC OpenGLTokens
PFNGLEXECUTEPROGRAMNVPROC OpenGLTokens
PFNGLFENCESYNCPROC OpenGLTokens
PFNGLFINALCOMBINERINPUTNVPROC OpenGLTokens
PFNGLFINISHFENCENVPROC OpenGLTokens
PFNGLFLUSHMAPPEDBUFFERRANGEPROC OpenGLTokens
PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC OpenGLTokens
PFNGLFLUSHVERTEXARRAYRANGENVPROC OpenGLTokens
PFNGLFOGCOORDDEXTPROC OpenGLTokens
PFNGLFOGCOORDDPROC OpenGLTokens
PFNGLFOGCOORDDVEXTPROC OpenGLTokens
PFNGLFOGCOORDDVPROC OpenGLTokens
PFNGLFOGCOORDFEXTPROC OpenGLTokens
PFNGLFOGCOORDFORMATNVPROC OpenGLTokens
PFNGLFOGCOORDFPROC OpenGLTokens
PFNGLFOGCOORDFVEXTPROC OpenGLTokens
PFNGLFOGCOORDFVPROC OpenGLTokens
PFNGLFOGCOORDPOINTEREXTPROC OpenGLTokens
PFNGLFOGCOORDPOINTERPROC OpenGLTokens
PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC OpenGLTokens
PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC OpenGLTokens
PFNGLFRAMEBUFFERREADBUFFEREXTPROC OpenGLTokens
PFNGLFRAMEBUFFERRENDERBUFFEREXTPROC OpenGLTokens
PFNGLFRAMEBUFFERRENDERBUFFERPROC OpenGLTokens
PFNGLFRAMEBUFFERTEXTURE1DEXTPROC OpenGLTokens
PFNGLFRAMEBUFFERTEXTURE1DPROC OpenGLTokens
PFNGLFRAMEBUFFERTEXTURE2DEXTPROC OpenGLTokens
PFNGLFRAMEBUFFERTEXTURE2DPROC OpenGLTokens
PFNGLFRAMEBUFFERTEXTURE3DEXTPROC OpenGLTokens
PFNGLFRAMEBUFFERTEXTURE3DPROC OpenGLTokens
PFNGLFRAMEBUFFERTEXTUREARBPROC OpenGLTokens
PFNGLFRAMEBUFFERTEXTUREEXTPROC OpenGLTokens
PFNGLFRAMEBUFFERTEXTUREFACEARBPROC OpenGLTokens
PFNGLFRAMEBUFFERTEXTUREFACEEXTPROC OpenGLTokens
PFNGLFRAMEBUFFERTEXTURELAYERARBPROC OpenGLTokens
PFNGLFRAMEBUFFERTEXTURELAYEREXTPROC OpenGLTokens
PFNGLFRAMEBUFFERTEXTURELAYERPROC OpenGLTokens
PFNGLFRAMEBUFFERTEXTUREPROC OpenGLTokens
PFNGLFRAMETERMINATORGREMEDYPROC OpenGLTokens
PFNGLGENBUFFERSARBPROC OpenGLTokens
PFNGLGENBUFFERSPROC OpenGLTokens
PFNGLGENERATEMIPMAPEXTPROC OpenGLTokens
PFNGLGENERATEMIPMAPPROC OpenGLTokens
PFNGLGENERATEMULTITEXMIPMAPEXTPROC OpenGLTokens
PFNGLGENERATETEXTUREMIPMAPEXTPROC OpenGLTokens
PFNGLGENFENCESNVPROC OpenGLTokens
PFNGLGENFRAMEBUFFERSEXTPROC OpenGLTokens
PFNGLGENFRAMEBUFFERSPROC OpenGLTokens
PFNGLGENOCCLUSIONQUERIESNVPROC OpenGLTokens
PFNGLGENPATHSNVPROC OpenGLTokens
PFNGLGENPROGRAMPIPELINESPROC OpenGLTokens
PFNGLGENPROGRAMSARBPROC OpenGLTokens
PFNGLGENPROGRAMSNVPROC OpenGLTokens
PFNGLGENQUERIESARBPROC OpenGLTokens
PFNGLGENQUERIESPROC OpenGLTokens
PFNGLGENRENDERBUFFERSEXTPROC OpenGLTokens
PFNGLGENRENDERBUFFERSPROC OpenGLTokens
PFNGLGENSAMPLERSPROC OpenGLTokens
PFNGLGENTEXTURESEXTPROC OpenGLTokens
PFNGLGENTRANSFORMFEEDBACKSPROC OpenGLTokens
PFNGLGENVERTEXARRAYSPROC OpenGLTokens
PFNGLGETACTIVEATTRIBARBPROC OpenGLTokens
PFNGLGETACTIVEATTRIBPROC OpenGLTokens
PFNGLGETACTIVESUBROUTINENAMEPROC OpenGLTokens
PFNGLGETACTIVESUBROUTINEUNIFORMIVPROC OpenGLTokens
PFNGLGETACTIVESUBROUTINEUNIFORMNAMEPROC OpenGLTokens
PFNGLGETACTIVEUNIFORMARBPROC OpenGLTokens
PFNGLGETACTIVEUNIFORMBLOCKIVPROC OpenGLTokens
PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC OpenGLTokens
PFNGLGETACTIVEUNIFORMNAMEPROC OpenGLTokens
PFNGLGETACTIVEUNIFORMPROC OpenGLTokens
PFNGLGETACTIVEUNIFORMSIVPROC OpenGLTokens
PFNGLGETACTIVEVARYINGNVPROC OpenGLTokens
PFNGLGETATTACHEDOBJECTSARBPROC OpenGLTokens
PFNGLGETATTACHEDSHADERSPROC OpenGLTokens
PFNGLGETATTRIBLOCATIONARBPROC OpenGLTokens
PFNGLGETATTRIBLOCATIONPROC OpenGLTokens
PFNGLGETBOOLEANINDEXEDVEXTPROC OpenGLTokens
PFNGLGETBOOLEANI_VPROC OpenGLTokens
PFNGLGETBUFFERPARAMETERI64VPROC OpenGLTokens
PFNGLGETBUFFERPARAMETERIVARBPROC OpenGLTokens
PFNGLGETBUFFERPARAMETERIVPROC OpenGLTokens
PFNGLGETBUFFERPARAMETERUI64VNVPROC OpenGLTokens
PFNGLGETBUFFERPOINTERVARBPROC OpenGLTokens
PFNGLGETBUFFERPOINTERVPROC OpenGLTokens
PFNGLGETBUFFERSUBDATAARBPROC OpenGLTokens
PFNGLGETBUFFERSUBDATAPROC OpenGLTokens
PFNGLGETCOLORTABLEEXTPROC OpenGLTokens
PFNGLGETCOLORTABLEPARAMETERFVEXTPROC OpenGLTokens
PFNGLGETCOLORTABLEPARAMETERFVPROC OpenGLTokens
PFNGLGETCOLORTABLEPARAMETERIVEXTPROC OpenGLTokens
PFNGLGETCOLORTABLEPARAMETERIVPROC OpenGLTokens
PFNGLGETCOLORTABLEPROC OpenGLTokens
PFNGLGETCOMBINERINPUTPARAMETERFVNVPROC OpenGLTokens
PFNGLGETCOMBINERINPUTPARAMETERIVNVPROC OpenGLTokens
PFNGLGETCOMBINEROUTPUTPARAMETERFVNVPROC OpenGLTokens
PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC OpenGLTokens
PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC OpenGLTokens
PFNGLGETCOMPRESSEDTEXIMAGEARBPROC OpenGLTokens
PFNGLGETCOMPRESSEDTEXIMAGEPROC OpenGLTokens
PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC OpenGLTokens
PFNGLGETCONVOLUTIONFILTERPROC OpenGLTokens
PFNGLGETCONVOLUTIONPARAMETERFVPROC OpenGLTokens
PFNGLGETCONVOLUTIONPARAMETERIVPROC OpenGLTokens
PFNGLGETDEBUGMESSAGELOGARBPROC OpenGLTokens
PFNGLGETDOUBLEINDEXEDVEXTPROC OpenGLTokens
PFNGLGETDOUBLEI_VPROC OpenGLTokens
PFNGLGETFENCEIVNVPROC OpenGLTokens
PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC OpenGLTokens
PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC OpenGLTokens
PFNGLGETFLOATINDEXEDVEXTPROC OpenGLTokens
PFNGLGETFLOATI_VPROC OpenGLTokens
PFNGLGETFRAGDATAINDEXPROC OpenGLTokens
PFNGLGETFRAGDATALOCATIONEXTPROC OpenGLTokens
PFNGLGETFRAGDATALOCATIONPROC OpenGLTokens
PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC OpenGLTokens
PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC OpenGLTokens
PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC OpenGLTokens
PFNGLGETGRAPHICSRESETSTATUSARBPROC OpenGLTokens
PFNGLGETHANDLEARBPROC OpenGLTokens
PFNGLGETHISTOGRAMPARAMETERFVPROC OpenGLTokens
PFNGLGETHISTOGRAMPARAMETERIVPROC OpenGLTokens
PFNGLGETHISTOGRAMPROC OpenGLTokens
PFNGLGETINFOLOGARBPROC OpenGLTokens
PFNGLGETINTEGER64I_VPROC OpenGLTokens
PFNGLGETINTEGER64VPROC OpenGLTokens
PFNGLGETINTEGERINDEXEDVEXTPROC OpenGLTokens
PFNGLGETINTEGERI_VPROC OpenGLTokens
PFNGLGETINTEGERUI64I_VNVPROC OpenGLTokens
PFNGLGETINTEGERUI64VNVPROC OpenGLTokens
PFNGLGETMINMAXPARAMETERFVPROC OpenGLTokens
PFNGLGETMINMAXPARAMETERIVPROC OpenGLTokens
PFNGLGETMINMAXPROC OpenGLTokens
PFNGLGETMULTISAMPLEFVPROC OpenGLTokens
PFNGLGETMULTITEXENVFVEXTPROC OpenGLTokens
PFNGLGETMULTITEXENVIVEXTPROC OpenGLTokens
PFNGLGETMULTITEXGENDVEXTPROC OpenGLTokens
PFNGLGETMULTITEXGENFVEXTPROC OpenGLTokens
PFNGLGETMULTITEXGENIVEXTPROC OpenGLTokens
PFNGLGETMULTITEXIMAGEEXTPROC OpenGLTokens
PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC OpenGLTokens
PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC OpenGLTokens
PFNGLGETMULTITEXPARAMETERFVEXTPROC OpenGLTokens
PFNGLGETMULTITEXPARAMETERIIVEXTPROC OpenGLTokens
PFNGLGETMULTITEXPARAMETERIUIVEXTPROC OpenGLTokens
PFNGLGETMULTITEXPARAMETERIVEXTPROC OpenGLTokens
PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC OpenGLTokens
PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC OpenGLTokens
PFNGLGETNAMEDBUFFERPOINTERVEXTPROC OpenGLTokens
PFNGLGETNAMEDBUFFERSUBDATAEXTPROC OpenGLTokens
PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC OpenGLTokens
PFNGLGETNAMEDPROGRAMIVEXTPROC OpenGLTokens
PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC OpenGLTokens
PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC OpenGLTokens
PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC OpenGLTokens
PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC OpenGLTokens
PFNGLGETNAMEDPROGRAMSTRINGEXTPROC OpenGLTokens
PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC OpenGLTokens
PFNGLGETNCOLORTABLEARBPROC OpenGLTokens
PFNGLGETNCOMPRESSEDTEXIMAGEARBPROC OpenGLTokens
PFNGLGETNCONVOLUTIONFILTERARBPROC OpenGLTokens
PFNGLGETNHISTOGRAMARBPROC OpenGLTokens
PFNGLGETNMAPDVARBPROC OpenGLTokens
PFNGLGETNMAPFVARBPROC OpenGLTokens
PFNGLGETNMAPIVARBPROC OpenGLTokens
PFNGLGETNMINMAXARBPROC OpenGLTokens
PFNGLGETNPIXELMAPFVARBPROC OpenGLTokens
PFNGLGETNPIXELMAPUIVARBPROC OpenGLTokens
PFNGLGETNPIXELMAPUSVARBPROC OpenGLTokens
PFNGLGETNPOLYGONSTIPPLEARBPROC OpenGLTokens
PFNGLGETNSEPARABLEFILTERARBPROC OpenGLTokens
PFNGLGETNTEXIMAGEARBPROC OpenGLTokens
PFNGLGETNUNIFORMDVARBPROC OpenGLTokens
PFNGLGETNUNIFORMFVARBPROC OpenGLTokens
PFNGLGETNUNIFORMIVARBPROC OpenGLTokens
PFNGLGETNUNIFORMUIVARBPROC OpenGLTokens
PFNGLGETOBJECTPARAMETERFVARBPROC OpenGLTokens
PFNGLGETOBJECTPARAMETERIVARBPROC OpenGLTokens
PFNGLGETOCCLUSIONQUERYIVNVPROC OpenGLTokens
PFNGLGETOCCLUSIONQUERYUIVNVPROC OpenGLTokens
PFNGLGETPATHCOLORGENFVNVPROC OpenGLTokens
PFNGLGETPATHCOLORGENIVNVPROC OpenGLTokens
PFNGLGETPATHCOMMANDSNVPROC OpenGLTokens
PFNGLGETPATHCOORDSNVPROC OpenGLTokens
PFNGLGETPATHDASHARRAYNVPROC OpenGLTokens
PFNGLGETPATHLENGTHNVPROC OpenGLTokens
PFNGLGETPATHMETRICRANGENVPROC OpenGLTokens
PFNGLGETPATHMETRICSNVPROC OpenGLTokens
PFNGLGETPATHPARAMETERFVNVPROC OpenGLTokens
PFNGLGETPATHPARAMETERIVNVPROC OpenGLTokens
PFNGLGETPATHSPACINGNVPROC OpenGLTokens
PFNGLGETPATHTEXGENFVNVPROC OpenGLTokens
PFNGLGETPATHTEXGENIVNVPROC OpenGLTokens
PFNGLGETPOINTERINDEXEDVEXTPROC OpenGLTokens
PFNGLGETPROGRAMBINARYPROC OpenGLTokens
PFNGLGETPROGRAMENVPARAMETERDVARBPROC OpenGLTokens
PFNGLGETPROGRAMENVPARAMETERFVARBPROC OpenGLTokens
PFNGLGETPROGRAMINFOLOGPROC OpenGLTokens
PFNGLGETPROGRAMIVARBPROC OpenGLTokens
PFNGLGETPROGRAMIVNVPROC OpenGLTokens
PFNGLGETPROGRAMIVPROC OpenGLTokens
PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC OpenGLTokens
PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC OpenGLTokens
PFNGLGETPROGRAMPARAMETERDVNVPROC OpenGLTokens
PFNGLGETPROGRAMPARAMETERFVNVPROC OpenGLTokens
PFNGLGETPROGRAMPIPELINEINFOLOGPROC OpenGLTokens
PFNGLGETPROGRAMPIPELINEIVPROC OpenGLTokens
PFNGLGETPROGRAMSTAGEIVPROC OpenGLTokens
PFNGLGETPROGRAMSTRINGARBPROC OpenGLTokens
PFNGLGETPROGRAMSTRINGNVPROC OpenGLTokens
PFNGLGETQUERYINDEXEDIVPROC OpenGLTokens
PFNGLGETQUERYIVARBPROC OpenGLTokens
PFNGLGETQUERYIVPROC OpenGLTokens
PFNGLGETQUERYOBJECTI64VEXTPROC OpenGLTokens
PFNGLGETQUERYOBJECTI64VPROC OpenGLTokens
PFNGLGETQUERYOBJECTIVARBPROC OpenGLTokens
PFNGLGETQUERYOBJECTIVPROC OpenGLTokens
PFNGLGETQUERYOBJECTUI64VEXTPROC OpenGLTokens
PFNGLGETQUERYOBJECTUI64VPROC OpenGLTokens
PFNGLGETQUERYOBJECTUIVARBPROC OpenGLTokens
PFNGLGETQUERYOBJECTUIVPROC OpenGLTokens
PFNGLGETRENDERBUFFERPARAMETERIVEXTPROC OpenGLTokens
PFNGLGETRENDERBUFFERPARAMETERIVPROC OpenGLTokens
PFNGLGETSAMPLERPARAMETERFVPROC OpenGLTokens
PFNGLGETSAMPLERPARAMETERIFVPROC OpenGLTokens
PFNGLGETSAMPLERPARAMETERIIVPROC OpenGLTokens
PFNGLGETSAMPLERPARAMETERIVPROC OpenGLTokens
PFNGLGETSEPARABLEFILTERPROC OpenGLTokens
PFNGLGETSHADERINFOLOGPROC OpenGLTokens
PFNGLGETSHADERIVPROC OpenGLTokens
PFNGLGETSHADERPRECISIONFORMATPROC OpenGLTokens
PFNGLGETSHADERSOURCEARBPROC OpenGLTokens
PFNGLGETSHADERSOURCEPROC OpenGLTokens
PFNGLGETSTRINGIPROC OpenGLTokens
PFNGLGETSUBROUTINEINDEXPROC OpenGLTokens
PFNGLGETSUBROUTINEUNIFORMLOCATIONPROC OpenGLTokens
PFNGLGETSYNCIVPROC OpenGLTokens
PFNGLGETTEXPARAMETERIIVEXTPROC OpenGLTokens
PFNGLGETTEXPARAMETERIIVPROC OpenGLTokens
PFNGLGETTEXPARAMETERIUIVEXTPROC OpenGLTokens
PFNGLGETTEXPARAMETERIUIVPROC OpenGLTokens
PFNGLGETTEXTUREIMAGEEXTPROC OpenGLTokens
PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC OpenGLTokens
PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC OpenGLTokens
PFNGLGETTEXTUREPARAMETERFVEXTPROC OpenGLTokens
PFNGLGETTEXTUREPARAMETERIIVEXTPROC OpenGLTokens
PFNGLGETTEXTUREPARAMETERIUIVEXTPROC OpenGLTokens
PFNGLGETTEXTUREPARAMETERIVEXTPROC OpenGLTokens
PFNGLGETTRACKMATRIXIVNVPROC OpenGLTokens
PFNGLGETTRANSFORMFEEDBACKVARYINGEXTPROC OpenGLTokens
PFNGLGETTRANSFORMFEEDBACKVARYINGNVPROC OpenGLTokens
PFNGLGETTRANSFORMFEEDBACKVARYINGPROC OpenGLTokens
PFNGLGETUNIFORMBLOCKINDEXPROC OpenGLTokens
PFNGLGETUNIFORMBUFFERSIZEEXTPROC OpenGLTokens
PFNGLGETUNIFORMDVPROC OpenGLTokens
PFNGLGETUNIFORMFVARBPROC OpenGLTokens
PFNGLGETUNIFORMFVPROC OpenGLTokens
PFNGLGETUNIFORMINDICESPROC OpenGLTokens
PFNGLGETUNIFORMIVARBPROC OpenGLTokens
PFNGLGETUNIFORMIVPROC OpenGLTokens
PFNGLGETUNIFORMLOCATIONARBPROC OpenGLTokens
PFNGLGETUNIFORMLOCATIONPROC OpenGLTokens
PFNGLGETUNIFORMOFFSETEXTPROC OpenGLTokens
PFNGLGETUNIFORMSUBROUTINEUIVPROC OpenGLTokens
PFNGLGETUNIFORMUI64VNVPROC OpenGLTokens
PFNGLGETUNIFORMUIVEXTPROC OpenGLTokens
PFNGLGETUNIFORMUIVPROC OpenGLTokens
PFNGLGETVARYINGLOCATIONNVPROC OpenGLTokens
PFNGLGETVERTEXATTRIBDVARBPROC OpenGLTokens
PFNGLGETVERTEXATTRIBDVNVPROC OpenGLTokens
PFNGLGETVERTEXATTRIBDVPROC OpenGLTokens
PFNGLGETVERTEXATTRIBFVARBPROC OpenGLTokens
PFNGLGETVERTEXATTRIBFVNVPROC OpenGLTokens
PFNGLGETVERTEXATTRIBFVPROC OpenGLTokens
PFNGLGETVERTEXATTRIBIIVEXTPROC OpenGLTokens
PFNGLGETVERTEXATTRIBIIVPROC OpenGLTokens
PFNGLGETVERTEXATTRIBIUIVEXTPROC OpenGLTokens
PFNGLGETVERTEXATTRIBIUIVPROC OpenGLTokens
PFNGLGETVERTEXATTRIBIVARBPROC OpenGLTokens
PFNGLGETVERTEXATTRIBIVNVPROC OpenGLTokens
PFNGLGETVERTEXATTRIBIVPROC OpenGLTokens
PFNGLGETVERTEXATTRIBLDVPROC OpenGLTokens
PFNGLGETVERTEXATTRIBPOINTERVARBPROC OpenGLTokens
PFNGLGETVERTEXATTRIBPOINTERVNVPROC OpenGLTokens
PFNGLGETVERTEXATTRIBPOINTERVPROC OpenGLTokens
PFNGLHISTOGRAMPROC OpenGLTokens
PFNGLINDEXFORMATNVPROC OpenGLTokens
PFNGLINDEXFUNCEXTPROC OpenGLTokens
PFNGLINDEXMATERIALEXTPROC OpenGLTokens
PFNGLINTERPOLATEPATHSNVPROC OpenGLTokens
PFNGLISBUFFERARBPROC OpenGLTokens
PFNGLISBUFFERPROC OpenGLTokens
PFNGLISBUFFERRESIDENTNVPROC OpenGLTokens
PFNGLISENABLEDINDEXEDEXTPROC OpenGLTokens
PFNGLISENABLEDIPROC OpenGLTokens
PFNGLISFENCENVPROC OpenGLTokens
PFNGLISFRAMEBUFFEREXTPROC OpenGLTokens
PFNGLISFRAMEBUFFERPROC OpenGLTokens
PFNGLISNAMEDBUFFERRESIDENTNVPROC OpenGLTokens
PFNGLISOCCLUSIONQUERYNVPROC OpenGLTokens
PFNGLISPATHNVPROC OpenGLTokens
PFNGLISPOINTINFILLPATHNVPROC OpenGLTokens
PFNGLISPOINTINSTROKEPATHNVPROC OpenGLTokens
PFNGLISPROGRAMARBPROC OpenGLTokens
PFNGLISPROGRAMNVPROC OpenGLTokens
PFNGLISPROGRAMPIPELINEPROC OpenGLTokens
PFNGLISPROGRAMPROC OpenGLTokens
PFNGLISQUERYARBPROC OpenGLTokens
PFNGLISQUERYPROC OpenGLTokens
PFNGLISRENDERBUFFEREXTPROC OpenGLTokens
PFNGLISRENDERBUFFERPROC OpenGLTokens
PFNGLISSAMPLERPROC OpenGLTokens
PFNGLISSHADERPROC OpenGLTokens
PFNGLISSYNCPROC OpenGLTokens
PFNGLISTEXTUREEXTPROC OpenGLTokens
PFNGLISTRANSFORMFEEDBACKPROC OpenGLTokens
PFNGLISVERTEXARRAYPROC OpenGLTokens
PFNGLLINKPROGRAMARBPROC OpenGLTokens
PFNGLLINKPROGRAMPROC OpenGLTokens
PFNGLLOADPROGRAMNVPROC OpenGLTokens
PFNGLLOADTRANSPOSEMATRIXDARBPROC OpenGLTokens
PFNGLLOADTRANSPOSEMATRIXDPROC OpenGLTokens
PFNGLLOADTRANSPOSEMATRIXFARBPROC OpenGLTokens
PFNGLLOADTRANSPOSEMATRIXFPROC OpenGLTokens
PFNGLLOCKARRAYSEXTPROC OpenGLTokens
PFNGLMAKEBUFFERNONRESIDENTNVPROC OpenGLTokens
PFNGLMAKEBUFFERRESIDENTNVPROC OpenGLTokens
PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC OpenGLTokens
PFNGLMAKENAMEDBUFFERRESIDENTNVPROC OpenGLTokens
PFNGLMAPBUFFERARBPROC OpenGLTokens
PFNGLMAPBUFFERPROC OpenGLTokens
PFNGLMAPBUFFERRANGEPROC OpenGLTokens
PFNGLMAPNAMEDBUFFEREXTPROC OpenGLTokens
PFNGLMAPNAMEDBUFFERRANGEEXTPROC OpenGLTokens
PFNGLMATRIXFRUSTUMEXTPROC OpenGLTokens
PFNGLMATRIXINDEXPOINTERARBPROC OpenGLTokens
PFNGLMATRIXINDEXUBVARBPROC OpenGLTokens
PFNGLMATRIXINDEXUIVARBPROC OpenGLTokens
PFNGLMATRIXINDEXUSVARBPROC OpenGLTokens
PFNGLMATRIXLOADDEXTPROC OpenGLTokens
PFNGLMATRIXLOADFEXTPROC OpenGLTokens
PFNGLMATRIXLOADIDENTITYEXTPROC OpenGLTokens
PFNGLMATRIXLOADTRANSPOSEDEXTPROC OpenGLTokens
PFNGLMATRIXLOADTRANSPOSEFEXTPROC OpenGLTokens
PFNGLMATRIXMULTDEXTPROC OpenGLTokens
PFNGLMATRIXMULTFEXTPROC OpenGLTokens
PFNGLMATRIXMULTTRANSPOSEDEXTPROC OpenGLTokens
PFNGLMATRIXMULTTRANSPOSEFEXTPROC OpenGLTokens
PFNGLMATRIXORTHOEXTPROC OpenGLTokens
PFNGLMATRIXPOPEXTPROC OpenGLTokens
PFNGLMATRIXPUSHEXTPROC OpenGLTokens
PFNGLMATRIXROTATEDEXTPROC OpenGLTokens
PFNGLMATRIXROTATEFEXTPROC OpenGLTokens
PFNGLMATRIXSCALEDEXTPROC OpenGLTokens
PFNGLMATRIXSCALEFEXTPROC OpenGLTokens
PFNGLMATRIXTRANSLATEDEXTPROC OpenGLTokens
PFNGLMATRIXTRANSLATEFEXTPROC OpenGLTokens
PFNGLMINMAXPROC OpenGLTokens
PFNGLMINSAMPLESHADINGARBPROC OpenGLTokens
PFNGLMINSAMPLESHADINGPROC OpenGLTokens
PFNGLMULTIDRAWARRAYSEXTPROC OpenGLTokens
PFNGLMULTIDRAWARRAYSPROC OpenGLTokens
PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC OpenGLTokens
PFNGLMULTIDRAWELEMENTSEXTPROC OpenGLTokens
PFNGLMULTIDRAWELEMENTSPROC OpenGLTokens
PFNGLMULTITEXBUFFEREXTPROC OpenGLTokens
PFNGLMULTITEXCOORD1DARBPROC OpenGLTokens
PFNGLMULTITEXCOORD1DPROC OpenGLTokens
PFNGLMULTITEXCOORD1DVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD1DVPROC OpenGLTokens
PFNGLMULTITEXCOORD1FARBPROC OpenGLTokens
PFNGLMULTITEXCOORD1FPROC OpenGLTokens
PFNGLMULTITEXCOORD1FVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD1FVPROC OpenGLTokens
PFNGLMULTITEXCOORD1IARBPROC OpenGLTokens
PFNGLMULTITEXCOORD1IPROC OpenGLTokens
PFNGLMULTITEXCOORD1IVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD1IVPROC OpenGLTokens
PFNGLMULTITEXCOORD1SARBPROC OpenGLTokens
PFNGLMULTITEXCOORD1SPROC OpenGLTokens
PFNGLMULTITEXCOORD1SVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD1SVPROC OpenGLTokens
PFNGLMULTITEXCOORD2DARBPROC OpenGLTokens
PFNGLMULTITEXCOORD2DPROC OpenGLTokens
PFNGLMULTITEXCOORD2DVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD2DVPROC OpenGLTokens
PFNGLMULTITEXCOORD2FARBPROC OpenGLTokens
PFNGLMULTITEXCOORD2FPROC OpenGLTokens
PFNGLMULTITEXCOORD2FVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD2FVPROC OpenGLTokens
PFNGLMULTITEXCOORD2IARBPROC OpenGLTokens
PFNGLMULTITEXCOORD2IPROC OpenGLTokens
PFNGLMULTITEXCOORD2IVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD2IVPROC OpenGLTokens
PFNGLMULTITEXCOORD2SARBPROC OpenGLTokens
PFNGLMULTITEXCOORD2SPROC OpenGLTokens
PFNGLMULTITEXCOORD2SVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD2SVPROC OpenGLTokens
PFNGLMULTITEXCOORD3DARBPROC OpenGLTokens
PFNGLMULTITEXCOORD3DPROC OpenGLTokens
PFNGLMULTITEXCOORD3DVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD3DVPROC OpenGLTokens
PFNGLMULTITEXCOORD3FARBPROC OpenGLTokens
PFNGLMULTITEXCOORD3FPROC OpenGLTokens
PFNGLMULTITEXCOORD3FVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD3FVPROC OpenGLTokens
PFNGLMULTITEXCOORD3IARBPROC OpenGLTokens
PFNGLMULTITEXCOORD3IPROC OpenGLTokens
PFNGLMULTITEXCOORD3IVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD3IVPROC OpenGLTokens
PFNGLMULTITEXCOORD3SARBPROC OpenGLTokens
PFNGLMULTITEXCOORD3SPROC OpenGLTokens
PFNGLMULTITEXCOORD3SVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD3SVPROC OpenGLTokens
PFNGLMULTITEXCOORD4DARBPROC OpenGLTokens
PFNGLMULTITEXCOORD4DPROC OpenGLTokens
PFNGLMULTITEXCOORD4DVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD4DVPROC OpenGLTokens
PFNGLMULTITEXCOORD4FARBPROC OpenGLTokens
PFNGLMULTITEXCOORD4FPROC OpenGLTokens
PFNGLMULTITEXCOORD4FVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD4FVPROC OpenGLTokens
PFNGLMULTITEXCOORD4IARBPROC OpenGLTokens
PFNGLMULTITEXCOORD4IPROC OpenGLTokens
PFNGLMULTITEXCOORD4IVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD4IVPROC OpenGLTokens
PFNGLMULTITEXCOORD4SARBPROC OpenGLTokens
PFNGLMULTITEXCOORD4SPROC OpenGLTokens
PFNGLMULTITEXCOORD4SVARBPROC OpenGLTokens
PFNGLMULTITEXCOORD4SVPROC OpenGLTokens
PFNGLMULTITEXCOORDP1UIPROC OpenGLTokens
PFNGLMULTITEXCOORDP1UIVPROC OpenGLTokens
PFNGLMULTITEXCOORDP2UIPROC OpenGLTokens
PFNGLMULTITEXCOORDP2UIVPROC OpenGLTokens
PFNGLMULTITEXCOORDP3UIPROC OpenGLTokens
PFNGLMULTITEXCOORDP3UIVPROC OpenGLTokens
PFNGLMULTITEXCOORDP4UIPROC OpenGLTokens
PFNGLMULTITEXCOORDP4UIVPROC OpenGLTokens
PFNGLMULTITEXCOORDPOINTEREXTPROC OpenGLTokens
PFNGLMULTITEXENVFEXTPROC OpenGLTokens
PFNGLMULTITEXENVFVEXTPROC OpenGLTokens
PFNGLMULTITEXENVIEXTPROC OpenGLTokens
PFNGLMULTITEXENVIVEXTPROC OpenGLTokens
PFNGLMULTITEXGENDEXTPROC OpenGLTokens
PFNGLMULTITEXGENDVEXTPROC OpenGLTokens
PFNGLMULTITEXGENFEXTPROC OpenGLTokens
PFNGLMULTITEXGENFVEXTPROC OpenGLTokens
PFNGLMULTITEXGENIEXTPROC OpenGLTokens
PFNGLMULTITEXGENIVEXTPROC OpenGLTokens
PFNGLMULTITEXIMAGE1DEXTPROC OpenGLTokens
PFNGLMULTITEXIMAGE2DEXTPROC OpenGLTokens
PFNGLMULTITEXIMAGE3DEXTPROC OpenGLTokens
PFNGLMULTITEXPARAMETERFEXTPROC OpenGLTokens
PFNGLMULTITEXPARAMETERFVEXTPROC OpenGLTokens
PFNGLMULTITEXPARAMETERIEXTPROC OpenGLTokens
PFNGLMULTITEXPARAMETERIIVEXTPROC OpenGLTokens
PFNGLMULTITEXPARAMETERIUIVEXTPROC OpenGLTokens
PFNGLMULTITEXPARAMETERIVEXTPROC OpenGLTokens
PFNGLMULTITEXRENDERBUFFEREXTPROC OpenGLTokens
PFNGLMULTITEXSUBIMAGE1DEXTPROC OpenGLTokens
PFNGLMULTITEXSUBIMAGE2DEXTPROC OpenGLTokens
PFNGLMULTITEXSUBIMAGE3DEXTPROC OpenGLTokens
PFNGLMULTTRANSPOSEMATRIXDARBPROC OpenGLTokens
PFNGLMULTTRANSPOSEMATRIXDPROC OpenGLTokens
PFNGLMULTTRANSPOSEMATRIXFARBPROC OpenGLTokens
PFNGLMULTTRANSPOSEMATRIXFPROC OpenGLTokens
PFNGLNAMEDBUFFERDATAEXTPROC OpenGLTokens
PFNGLNAMEDBUFFERSUBDATAEXTPROC OpenGLTokens
PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC OpenGLTokens
PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC OpenGLTokens
PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC OpenGLTokens
PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC OpenGLTokens
PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC OpenGLTokens
PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC OpenGLTokens
PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC OpenGLTokens
PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC OpenGLTokens
PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC OpenGLTokens
PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC OpenGLTokens
PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC OpenGLTokens
PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC OpenGLTokens
PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC OpenGLTokens
PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC OpenGLTokens
PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC OpenGLTokens
PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC OpenGLTokens
PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC OpenGLTokens
PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC OpenGLTokens
PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC OpenGLTokens
PFNGLNAMEDPROGRAMSTRINGEXTPROC OpenGLTokens
PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC OpenGLTokens
PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC OpenGLTokens
PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC OpenGLTokens
PFNGLNORMALFORMATNVPROC OpenGLTokens
PFNGLNORMALP3UIPROC OpenGLTokens
PFNGLNORMALP3UIVPROC OpenGLTokens
PFNGLPATCHPARAMETERFVPROC OpenGLTokens
PFNGLPATCHPARAMETERIPROC OpenGLTokens
PFNGLPATHCOLORGENNVPROC OpenGLTokens
PFNGLPATHCOMMANDSNVPROC OpenGLTokens
PFNGLPATHCOORDSNVPROC OpenGLTokens
PFNGLPATHCOVERDEPTHFUNCNVPROC OpenGLTokens
PFNGLPATHDASHARRAYNVPROC OpenGLTokens
PFNGLPATHFOGGENNVPROC OpenGLTokens
PFNGLPATHGLYPHRANGENVPROC OpenGLTokens
PFNGLPATHGLYPHSNVPROC OpenGLTokens
PFNGLPATHPARAMETERFNVPROC OpenGLTokens
PFNGLPATHPARAMETERFVNVPROC OpenGLTokens
PFNGLPATHPARAMETERINVPROC OpenGLTokens
PFNGLPATHPARAMETERIVNVPROC OpenGLTokens
PFNGLPATHSTENCILDEPTHOFFSETNVPROC OpenGLTokens
PFNGLPATHSTENCILFUNCNVPROC OpenGLTokens
PFNGLPATHSTRINGNVPROC OpenGLTokens
PFNGLPATHSUBCOMMANDSNVPROC OpenGLTokens
PFNGLPATHSUBCOORDSNVPROC OpenGLTokens
PFNGLPATHTEXGENNVPROC OpenGLTokens
PFNGLPAUSETRANSFORMFEEDBACKPROC OpenGLTokens
PFNGLPOINTALONGPATHNVPROC OpenGLTokens
PFNGLPOINTPARAMETERFARBPROC OpenGLTokens
PFNGLPOINTPARAMETERFPROC OpenGLTokens
PFNGLPOINTPARAMETERFVARBPROC OpenGLTokens
PFNGLPOINTPARAMETERFVPROC OpenGLTokens
PFNGLPOINTPARAMETERINVPROC OpenGLTokens
PFNGLPOINTPARAMETERIPROC OpenGLTokens
PFNGLPOINTPARAMETERIVNVPROC OpenGLTokens
PFNGLPOINTPARAMETERIVPROC OpenGLTokens
PFNGLPOLYGONOFFSETEXTPROC OpenGLTokens
PFNGLPRIMITIVERESTARTINDEXNVPROC OpenGLTokens
PFNGLPRIMITIVERESTARTINDEXPROC OpenGLTokens
PFNGLPRIMITIVERESTARTNVPROC OpenGLTokens
PFNGLPRIORITIZETEXTURESEXTPROC OpenGLTokens
PFNGLPROGRAMBINARYPROC OpenGLTokens
PFNGLPROGRAMENVPARAMETER4DARBPROC OpenGLTokens
PFNGLPROGRAMENVPARAMETER4DVARBPROC OpenGLTokens
PFNGLPROGRAMENVPARAMETER4FARBPROC OpenGLTokens
PFNGLPROGRAMENVPARAMETER4FVARBPROC OpenGLTokens
PFNGLPROGRAMENVPARAMETERS4FVEXTPROC OpenGLTokens
PFNGLPROGRAMLOCALPARAMETER4DARBPROC OpenGLTokens
PFNGLPROGRAMLOCALPARAMETER4DVARBPROC OpenGLTokens
PFNGLPROGRAMLOCALPARAMETER4FARBPROC OpenGLTokens
PFNGLPROGRAMLOCALPARAMETER4FVARBPROC OpenGLTokens
PFNGLPROGRAMLOCALPARAMETERS4FVEXTPROC OpenGLTokens
PFNGLPROGRAMPARAMETER4DNVPROC OpenGLTokens
PFNGLPROGRAMPARAMETER4DVNVPROC OpenGLTokens
PFNGLPROGRAMPARAMETER4FNVPROC OpenGLTokens
PFNGLPROGRAMPARAMETER4FVNVPROC OpenGLTokens
PFNGLPROGRAMPARAMETERIARBPROC OpenGLTokens
PFNGLPROGRAMPARAMETERIEXTPROC OpenGLTokens
PFNGLPROGRAMPARAMETERIPROC OpenGLTokens
PFNGLPROGRAMPARAMETERS4DVNVPROC OpenGLTokens
PFNGLPROGRAMPARAMETERS4FVNVPROC OpenGLTokens
PFNGLPROGRAMSTRINGARBPROC OpenGLTokens
PFNGLPROGRAMUNIFORM1DEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORM1DPROC OpenGLTokens
PFNGLPROGRAMUNIFORM1DVEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORM1DVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM1FPROC OpenGLTokens
PFNGLPROGRAMUNIFORM1FVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM1IPROC OpenGLTokens
PFNGLPROGRAMUNIFORM1IVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM1UIPROC OpenGLTokens
PFNGLPROGRAMUNIFORM1UIVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM2DEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORM2DPROC OpenGLTokens
PFNGLPROGRAMUNIFORM2DVEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORM2DVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM2FPROC OpenGLTokens
PFNGLPROGRAMUNIFORM2FVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM2IPROC OpenGLTokens
PFNGLPROGRAMUNIFORM2IVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM2UIPROC OpenGLTokens
PFNGLPROGRAMUNIFORM2UIVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM3DEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORM3DPROC OpenGLTokens
PFNGLPROGRAMUNIFORM3DVEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORM3DVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM3FPROC OpenGLTokens
PFNGLPROGRAMUNIFORM3FVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM3IPROC OpenGLTokens
PFNGLPROGRAMUNIFORM3IVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM3UIPROC OpenGLTokens
PFNGLPROGRAMUNIFORM3UIVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM4DEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORM4DPROC OpenGLTokens
PFNGLPROGRAMUNIFORM4DVEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORM4DVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM4FPROC OpenGLTokens
PFNGLPROGRAMUNIFORM4FVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM4IPROC OpenGLTokens
PFNGLPROGRAMUNIFORM4IVPROC OpenGLTokens
PFNGLPROGRAMUNIFORM4UIPROC OpenGLTokens
PFNGLPROGRAMUNIFORM4UIVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX2DVEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX2DVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX2FVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX2X3DVEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX2X4DVEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX3DVEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX3DVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX3FVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX3X2DVEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX3X4DVEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX4DVEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX4DVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX4FVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX4X2DVEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX4X3DVEXTPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMUI64NVPROC OpenGLTokens
PFNGLPROGRAMUNIFORMUI64VNVPROC OpenGLTokens
PFNGLPROGRAMVERTEXLIMITNVPROC OpenGLTokens
PFNGLPROVOKINGVERTEXPROC OpenGLTokens
PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC OpenGLTokens
PFNGLQUERYCOUNTERPROC OpenGLTokens
PFNGLREADNPIXELSARBPROC OpenGLTokens
PFNGLRELEASESHADERCOMPILERPROC OpenGLTokens
PFNGLRENDERBUFFERSTORAGEEXTPROC OpenGLTokens
PFNGLRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC OpenGLTokens
PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC OpenGLTokens
PFNGLRENDERBUFFERSTORAGEPROC OpenGLTokens
PFNGLREQUESTRESIDENTPROGRAMSNVPROC OpenGLTokens
PFNGLRESETHISTOGRAMPROC OpenGLTokens
PFNGLRESETMINMAXPROC OpenGLTokens
PFNGLRESIZEBUFFERSMESAPROC OpenGLTokens
PFNGLRESUMETRANSFORMFEEDBACKPROC OpenGLTokens
PFNGLSAMPLECOVERAGEARBPROC OpenGLTokens
PFNGLSAMPLECOVERAGEPROC OpenGLTokens
PFNGLSAMPLEMASKEXTPROC OpenGLTokens
PFNGLSAMPLEMASKIPROC OpenGLTokens
PFNGLSAMPLEMASKSGISPROC OpenGLTokens
PFNGLSAMPLEPASSARBPROC OpenGLTokens
PFNGLSAMPLEPATTERNEXTPROC OpenGLTokens
PFNGLSAMPLEPATTERNSGISPROC OpenGLTokens
PFNGLSAMPLERPARAMETERFPROC OpenGLTokens
PFNGLSAMPLERPARAMETERFVPROC OpenGLTokens
PFNGLSAMPLERPARAMETERIIVPROC OpenGLTokens
PFNGLSAMPLERPARAMETERIPROC OpenGLTokens
PFNGLSAMPLERPARAMETERIUIVPROC OpenGLTokens
PFNGLSAMPLERPARAMETERIVPROC OpenGLTokens
PFNGLSCISSORARRAYVPROC OpenGLTokens
PFNGLSCISSORINDEXEDPROC OpenGLTokens
PFNGLSCISSORINDEXEDVPROC OpenGLTokens
PFNGLSECONDARYCOLOR3BEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3BPROC OpenGLTokens
PFNGLSECONDARYCOLOR3BVEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3BVPROC OpenGLTokens
PFNGLSECONDARYCOLOR3DEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3DPROC OpenGLTokens
PFNGLSECONDARYCOLOR3DVEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3DVPROC OpenGLTokens
PFNGLSECONDARYCOLOR3FEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3FPROC OpenGLTokens
PFNGLSECONDARYCOLOR3FVEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3FVPROC OpenGLTokens
PFNGLSECONDARYCOLOR3IEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3IPROC OpenGLTokens
PFNGLSECONDARYCOLOR3IVEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3IVPROC OpenGLTokens
PFNGLSECONDARYCOLOR3SEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3SPROC OpenGLTokens
PFNGLSECONDARYCOLOR3SVEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3SVPROC OpenGLTokens
PFNGLSECONDARYCOLOR3UBEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3UBPROC OpenGLTokens
PFNGLSECONDARYCOLOR3UBVEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3UBVPROC OpenGLTokens
PFNGLSECONDARYCOLOR3UIEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3UIPROC OpenGLTokens
PFNGLSECONDARYCOLOR3UIVEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3UIVPROC OpenGLTokens
PFNGLSECONDARYCOLOR3USEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3USPROC OpenGLTokens
PFNGLSECONDARYCOLOR3USVEXTPROC OpenGLTokens
PFNGLSECONDARYCOLOR3USVPROC OpenGLTokens
PFNGLSECONDARYCOLORFORMATNVPROC OpenGLTokens
PFNGLSECONDARYCOLORP3UIPROC OpenGLTokens
PFNGLSECONDARYCOLORP3UIVPROC OpenGLTokens
PFNGLSECONDARYCOLORPOINTEREXTPROC OpenGLTokens
PFNGLSECONDARYCOLORPOINTERPROC OpenGLTokens
PFNGLSEPARABLEFILTER2DPROC OpenGLTokens
PFNGLSETFENCENVPROC OpenGLTokens
PFNGLSHADERBINARYPROC OpenGLTokens
PFNGLSHADERSOURCEARBPROC OpenGLTokens
PFNGLSHADERSOURCEPROC OpenGLTokens
PFNGLSTENCILCLEARTAGEXTPROC OpenGLTokens
PFNGLSTENCILFILLPATHINSTANCEDNVPROC OpenGLTokens
PFNGLSTENCILFILLPATHNVPROC OpenGLTokens
PFNGLSTENCILFUNCSEPARATEPROC OpenGLTokens
PFNGLSTENCILMASKSEPARATEPROC OpenGLTokens
PFNGLSTENCILOPSEPARATEPROC OpenGLTokens
PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC OpenGLTokens
PFNGLSTENCILSTROKEPATHNVPROC OpenGLTokens
PFNGLSTRINGMARKERGREMEDYPROC OpenGLTokens
PFNGLTBUFFERMASK3DFXPROC OpenGLTokens
PFNGLTESSELLATIONFACTORAMDPROC OpenGLTokens
PFNGLTESSELLATIONMODEAMDPROC OpenGLTokens
PFNGLTESTFENCENVPROC OpenGLTokens
PFNGLTEXBUFFERARBPROC OpenGLTokens
PFNGLTEXBUFFEREXTPROC OpenGLTokens
PFNGLTEXBUFFERPROC OpenGLTokens
PFNGLTEXCOORDFORMATNVPROC OpenGLTokens
PFNGLTEXCOORDP1UIPROC OpenGLTokens
PFNGLTEXCOORDP1UIVPROC OpenGLTokens
PFNGLTEXCOORDP2UIPROC OpenGLTokens
PFNGLTEXCOORDP2UIVPROC OpenGLTokens
PFNGLTEXCOORDP3UIPROC OpenGLTokens
PFNGLTEXCOORDP3UIVPROC OpenGLTokens
PFNGLTEXCOORDP4UIPROC OpenGLTokens
PFNGLTEXCOORDP4UIVPROC OpenGLTokens
PFNGLTEXIMAGE2DMULTISAMPLEPROC OpenGLTokens
PFNGLTEXIMAGE3DEXTPROC OpenGLTokens
PFNGLTEXIMAGE3DMULTISAMPLEPROC OpenGLTokens
PFNGLTEXIMAGE3DPROC OpenGLTokens
PFNGLTEXPARAMETERIIVEXTPROC OpenGLTokens
PFNGLTEXPARAMETERIIVPROC OpenGLTokens
PFNGLTEXPARAMETERIUIVEXTPROC OpenGLTokens
PFNGLTEXPARAMETERIUIVPROC OpenGLTokens
PFNGLTEXSUBIMAGE1DEXTPROC OpenGLTokens
PFNGLTEXSUBIMAGE2DEXTPROC OpenGLTokens
PFNGLTEXSUBIMAGE3DEXTPROC OpenGLTokens
PFNGLTEXSUBIMAGE3DPROC OpenGLTokens
PFNGLTEXTUREBUFFEREXTPROC OpenGLTokens
PFNGLTEXTURECOLORMASKSGISPROC OpenGLTokens
PFNGLTEXTUREIMAGE1DEXTPROC OpenGLTokens
PFNGLTEXTUREIMAGE2DEXTPROC OpenGLTokens
PFNGLTEXTUREIMAGE3DEXTPROC OpenGLTokens
PFNGLTEXTUREPARAMETERFEXTPROC OpenGLTokens
PFNGLTEXTUREPARAMETERFVEXTPROC OpenGLTokens
PFNGLTEXTUREPARAMETERIEXTPROC OpenGLTokens
PFNGLTEXTUREPARAMETERIIVEXTPROC OpenGLTokens
PFNGLTEXTUREPARAMETERIUIVEXTPROC OpenGLTokens
PFNGLTEXTUREPARAMETERIVEXTPROC OpenGLTokens
PFNGLTEXTURERENDERBUFFEREXTPROC OpenGLTokens
PFNGLTEXTURESUBIMAGE1DEXTPROC OpenGLTokens
PFNGLTEXTURESUBIMAGE2DEXTPROC OpenGLTokens
PFNGLTEXTURESUBIMAGE3DEXTPROC OpenGLTokens
PFNGLTRACKMATRIXNVPROC OpenGLTokens
PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC OpenGLTokens
PFNGLTRANSFORMFEEDBACKVARYINGSEXTPROC OpenGLTokens
PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC OpenGLTokens
PFNGLTRANSFORMFEEDBACKVARYINGSPROC OpenGLTokens
PFNGLTRANSFORMPATHNVPROC OpenGLTokens
PFNGLUDELETENURBSTESSELLATOREXTPROC OpenGLTokens
PFNGLUNEWNURBSTESSELLATOREXTPROC OpenGLTokens
PFNGLUNIFORM1DPROC OpenGLTokens
PFNGLUNIFORM1DVPROC OpenGLTokens
PFNGLUNIFORM1FARBPROC OpenGLTokens
PFNGLUNIFORM1FPROC OpenGLTokens
PFNGLUNIFORM1FVARBPROC OpenGLTokens
PFNGLUNIFORM1FVPROC OpenGLTokens
PFNGLUNIFORM1IARBPROC OpenGLTokens
PFNGLUNIFORM1IPROC OpenGLTokens
PFNGLUNIFORM1IVARBPROC OpenGLTokens
PFNGLUNIFORM1IVPROC OpenGLTokens
PFNGLUNIFORM1UIEXTPROC OpenGLTokens
PFNGLUNIFORM1UIPROC OpenGLTokens
PFNGLUNIFORM1UIVEXTPROC OpenGLTokens
PFNGLUNIFORM1UIVPROC OpenGLTokens
PFNGLUNIFORM2DPROC OpenGLTokens
PFNGLUNIFORM2DVPROC OpenGLTokens
PFNGLUNIFORM2FARBPROC OpenGLTokens
PFNGLUNIFORM2FPROC OpenGLTokens
PFNGLUNIFORM2FVARBPROC OpenGLTokens
PFNGLUNIFORM2FVPROC OpenGLTokens
PFNGLUNIFORM2IARBPROC OpenGLTokens
PFNGLUNIFORM2IPROC OpenGLTokens
PFNGLUNIFORM2IVARBPROC OpenGLTokens
PFNGLUNIFORM2IVPROC OpenGLTokens
PFNGLUNIFORM2UIEXTPROC OpenGLTokens
PFNGLUNIFORM2UIPROC OpenGLTokens
PFNGLUNIFORM2UIVEXTPROC OpenGLTokens
PFNGLUNIFORM2UIVPROC OpenGLTokens
PFNGLUNIFORM3DPROC OpenGLTokens
PFNGLUNIFORM3DVPROC OpenGLTokens
PFNGLUNIFORM3FARBPROC OpenGLTokens
PFNGLUNIFORM3FPROC OpenGLTokens
PFNGLUNIFORM3FVARBPROC OpenGLTokens
PFNGLUNIFORM3FVPROC OpenGLTokens
PFNGLUNIFORM3IARBPROC OpenGLTokens
PFNGLUNIFORM3IPROC OpenGLTokens
PFNGLUNIFORM3IVARBPROC OpenGLTokens
PFNGLUNIFORM3IVPROC OpenGLTokens
PFNGLUNIFORM3UIEXTPROC OpenGLTokens
PFNGLUNIFORM3UIPROC OpenGLTokens
PFNGLUNIFORM3UIVEXTPROC OpenGLTokens
PFNGLUNIFORM3UIVPROC OpenGLTokens
PFNGLUNIFORM4DPROC OpenGLTokens
PFNGLUNIFORM4DVPROC OpenGLTokens
PFNGLUNIFORM4FARBPROC OpenGLTokens
PFNGLUNIFORM4FPROC OpenGLTokens
PFNGLUNIFORM4FVARBPROC OpenGLTokens
PFNGLUNIFORM4FVPROC OpenGLTokens
PFNGLUNIFORM4IARBPROC OpenGLTokens
PFNGLUNIFORM4IPROC OpenGLTokens
PFNGLUNIFORM4IVARBPROC OpenGLTokens
PFNGLUNIFORM4IVPROC OpenGLTokens
PFNGLUNIFORM4UIEXTPROC OpenGLTokens
PFNGLUNIFORM4UIPROC OpenGLTokens
PFNGLUNIFORM4UIVEXTPROC OpenGLTokens
PFNGLUNIFORM4UIVPROC OpenGLTokens
PFNGLUNIFORMBLOCKBINDINGPROC OpenGLTokens
PFNGLUNIFORMBUFFEREXTPROC OpenGLTokens
PFNGLUNIFORMMATRIX2DVPROC OpenGLTokens
PFNGLUNIFORMMATRIX2FVARBPROC OpenGLTokens
PFNGLUNIFORMMATRIX2FVPROC OpenGLTokens
PFNGLUNIFORMMATRIX2X3DVPROC OpenGLTokens
PFNGLUNIFORMMATRIX2X3FVPROC OpenGLTokens
PFNGLUNIFORMMATRIX2X4DVPROC OpenGLTokens
PFNGLUNIFORMMATRIX2X4FVPROC OpenGLTokens
PFNGLUNIFORMMATRIX3DVPROC OpenGLTokens
PFNGLUNIFORMMATRIX3FVARBPROC OpenGLTokens
PFNGLUNIFORMMATRIX3FVPROC OpenGLTokens
PFNGLUNIFORMMATRIX3X2DVPROC OpenGLTokens
PFNGLUNIFORMMATRIX3X2FVPROC OpenGLTokens
PFNGLUNIFORMMATRIX3X4DVPROC OpenGLTokens
PFNGLUNIFORMMATRIX3X4FVPROC OpenGLTokens
PFNGLUNIFORMMATRIX4DVPROC OpenGLTokens
PFNGLUNIFORMMATRIX4FVARBPROC OpenGLTokens
PFNGLUNIFORMMATRIX4FVPROC OpenGLTokens
PFNGLUNIFORMMATRIX4X2DVPROC OpenGLTokens
PFNGLUNIFORMMATRIX4X2FVPROC OpenGLTokens
PFNGLUNIFORMMATRIX4X3DVPROC OpenGLTokens
PFNGLUNIFORMMATRIX4X3FVPROC OpenGLTokens
PFNGLUNIFORMSUBROUTINESUIVPROC OpenGLTokens
PFNGLUNIFORMUI64NVPROC OpenGLTokens
PFNGLUNIFORMUI64VNVPROC OpenGLTokens
PFNGLUNLOCKARRAYSEXTPROC OpenGLTokens
PFNGLUNMAPBUFFERARBPROC OpenGLTokens
PFNGLUNMAPBUFFERPROC OpenGLTokens
PFNGLUNMAPNAMEDBUFFEREXTPROC OpenGLTokens
PFNGLUNURBSCALLBACKDATAEXTPROC OpenGLTokens
PFNGLUSEPROGRAMOBJECTARBPROC OpenGLTokens
PFNGLUSEPROGRAMPROC OpenGLTokens
PFNGLUSEPROGRAMSTAGESPROC OpenGLTokens
PFNGLVALIDATEPROGRAMARBPROC OpenGLTokens
PFNGLVALIDATEPROGRAMPIPELINEPROC OpenGLTokens
PFNGLVALIDATEPROGRAMPROC OpenGLTokens
PFNGLVERTEXARRAYRANGENVPROC OpenGLTokens
PFNGLVERTEXARRAYVERTEXATTRIBLOFFSETEXTPROC OpenGLTokens
PFNGLVERTEXATTRIB1DARBPROC OpenGLTokens
PFNGLVERTEXATTRIB1DNVPROC OpenGLTokens
PFNGLVERTEXATTRIB1DPROC OpenGLTokens
PFNGLVERTEXATTRIB1DVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB1DVNVPROC OpenGLTokens
PFNGLVERTEXATTRIB1DVPROC OpenGLTokens
PFNGLVERTEXATTRIB1FARBPROC OpenGLTokens
PFNGLVERTEXATTRIB1FNVPROC OpenGLTokens
PFNGLVERTEXATTRIB1FPROC OpenGLTokens
PFNGLVERTEXATTRIB1FVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB1FVNVPROC OpenGLTokens
PFNGLVERTEXATTRIB1FVPROC OpenGLTokens
PFNGLVERTEXATTRIB1SARBPROC OpenGLTokens
PFNGLVERTEXATTRIB1SNVPROC OpenGLTokens
PFNGLVERTEXATTRIB1SPROC OpenGLTokens
PFNGLVERTEXATTRIB1SVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB1SVNVPROC OpenGLTokens
PFNGLVERTEXATTRIB1SVPROC OpenGLTokens
PFNGLVERTEXATTRIB2DARBPROC OpenGLTokens
PFNGLVERTEXATTRIB2DNVPROC OpenGLTokens
PFNGLVERTEXATTRIB2DPROC OpenGLTokens
PFNGLVERTEXATTRIB2DVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB2DVNVPROC OpenGLTokens
PFNGLVERTEXATTRIB2DVPROC OpenGLTokens
PFNGLVERTEXATTRIB2FARBPROC OpenGLTokens
PFNGLVERTEXATTRIB2FNVPROC OpenGLTokens
PFNGLVERTEXATTRIB2FPROC OpenGLTokens
PFNGLVERTEXATTRIB2FVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB2FVNVPROC OpenGLTokens
PFNGLVERTEXATTRIB2FVPROC OpenGLTokens
PFNGLVERTEXATTRIB2SARBPROC OpenGLTokens
PFNGLVERTEXATTRIB2SNVPROC OpenGLTokens
PFNGLVERTEXATTRIB2SPROC OpenGLTokens
PFNGLVERTEXATTRIB2SVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB2SVNVPROC OpenGLTokens
PFNGLVERTEXATTRIB2SVPROC OpenGLTokens
PFNGLVERTEXATTRIB3DARBPROC OpenGLTokens
PFNGLVERTEXATTRIB3DNVPROC OpenGLTokens
PFNGLVERTEXATTRIB3DPROC OpenGLTokens
PFNGLVERTEXATTRIB3DVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB3DVNVPROC OpenGLTokens
PFNGLVERTEXATTRIB3DVPROC OpenGLTokens
PFNGLVERTEXATTRIB3FARBPROC OpenGLTokens
PFNGLVERTEXATTRIB3FNVPROC OpenGLTokens
PFNGLVERTEXATTRIB3FPROC OpenGLTokens
PFNGLVERTEXATTRIB3FVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB3FVNVPROC OpenGLTokens
PFNGLVERTEXATTRIB3FVPROC OpenGLTokens
PFNGLVERTEXATTRIB3SARBPROC OpenGLTokens
PFNGLVERTEXATTRIB3SNVPROC OpenGLTokens
PFNGLVERTEXATTRIB3SPROC OpenGLTokens
PFNGLVERTEXATTRIB3SVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB3SVNVPROC OpenGLTokens
PFNGLVERTEXATTRIB3SVPROC OpenGLTokens
PFNGLVERTEXATTRIB4BVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4BVPROC OpenGLTokens
PFNGLVERTEXATTRIB4DARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4DNVPROC OpenGLTokens
PFNGLVERTEXATTRIB4DPROC OpenGLTokens
PFNGLVERTEXATTRIB4DVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4DVNVPROC OpenGLTokens
PFNGLVERTEXATTRIB4DVPROC OpenGLTokens
PFNGLVERTEXATTRIB4FARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4FNVPROC OpenGLTokens
PFNGLVERTEXATTRIB4FPROC OpenGLTokens
PFNGLVERTEXATTRIB4FVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4FVNVPROC OpenGLTokens
PFNGLVERTEXATTRIB4FVPROC OpenGLTokens
PFNGLVERTEXATTRIB4IVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4IVPROC OpenGLTokens
PFNGLVERTEXATTRIB4NBVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4NBVPROC OpenGLTokens
PFNGLVERTEXATTRIB4NIVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4NIVPROC OpenGLTokens
PFNGLVERTEXATTRIB4NSVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4NSVPROC OpenGLTokens
PFNGLVERTEXATTRIB4NUBARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4NUBPROC OpenGLTokens
PFNGLVERTEXATTRIB4NUBVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4NUBVPROC OpenGLTokens
PFNGLVERTEXATTRIB4NUIVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4NUIVPROC OpenGLTokens
PFNGLVERTEXATTRIB4NUSVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4NUSVPROC OpenGLTokens
PFNGLVERTEXATTRIB4SARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4SNVPROC OpenGLTokens
PFNGLVERTEXATTRIB4SPROC OpenGLTokens
PFNGLVERTEXATTRIB4SVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4SVNVPROC OpenGLTokens
PFNGLVERTEXATTRIB4SVPROC OpenGLTokens
PFNGLVERTEXATTRIB4UBVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4UBVNVPROC OpenGLTokens
PFNGLVERTEXATTRIB4UBVPROC OpenGLTokens
PFNGLVERTEXATTRIB4UIVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4UIVPROC OpenGLTokens
PFNGLVERTEXATTRIB4USVARBPROC OpenGLTokens
PFNGLVERTEXATTRIB4USVPROC OpenGLTokens
PFNGLVERTEXATTRIBDIVISORARBPROC OpenGLTokens
PFNGLVERTEXATTRIBDIVISORPROC OpenGLTokens
PFNGLVERTEXATTRIBFORMATNVPROC OpenGLTokens
PFNGLVERTEXATTRIBI1IEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI1IPROC OpenGLTokens
PFNGLVERTEXATTRIBI1IVEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI1IVPROC OpenGLTokens
PFNGLVERTEXATTRIBI1UIEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI1UIPROC OpenGLTokens
PFNGLVERTEXATTRIBI1UIVEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI1UIVPROC OpenGLTokens
PFNGLVERTEXATTRIBI2IEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI2IPROC OpenGLTokens
PFNGLVERTEXATTRIBI2IVEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI2IVPROC OpenGLTokens
PFNGLVERTEXATTRIBI2UIEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI2UIPROC OpenGLTokens
PFNGLVERTEXATTRIBI2UIVEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI2UIVPROC OpenGLTokens
PFNGLVERTEXATTRIBI3IEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI3IPROC OpenGLTokens
PFNGLVERTEXATTRIBI3IVEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI3IVPROC OpenGLTokens
PFNGLVERTEXATTRIBI3UIEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI3UIPROC OpenGLTokens
PFNGLVERTEXATTRIBI3UIVEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI3UIVPROC OpenGLTokens
PFNGLVERTEXATTRIBI4BVEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI4BVPROC OpenGLTokens
PFNGLVERTEXATTRIBI4IEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI4IPROC OpenGLTokens
PFNGLVERTEXATTRIBI4IVEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI4IVPROC OpenGLTokens
PFNGLVERTEXATTRIBI4SVEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI4SVPROC OpenGLTokens
PFNGLVERTEXATTRIBI4UBVEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI4UBVPROC OpenGLTokens
PFNGLVERTEXATTRIBI4UIEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI4UIPROC OpenGLTokens
PFNGLVERTEXATTRIBI4UIVEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI4UIVPROC OpenGLTokens
PFNGLVERTEXATTRIBI4USVEXTPROC OpenGLTokens
PFNGLVERTEXATTRIBI4USVPROC OpenGLTokens
PFNGLVERTEXATTRIBIFORMATNVPROC OpenGLTokens
PFNGLVERTEXATTRIBIPOINTEREXTPROC OpenGLTokens
PFNGLVERTEXATTRIBIPOINTERPROC OpenGLTokens
PFNGLVERTEXATTRIBL1DPROC OpenGLTokens
PFNGLVERTEXATTRIBL1DVPROC OpenGLTokens
PFNGLVERTEXATTRIBL2DPROC OpenGLTokens
PFNGLVERTEXATTRIBL2DVPROC OpenGLTokens
PFNGLVERTEXATTRIBL3DPROC OpenGLTokens
PFNGLVERTEXATTRIBL3DVPROC OpenGLTokens
PFNGLVERTEXATTRIBL4DPROC OpenGLTokens
PFNGLVERTEXATTRIBL4DVPROC OpenGLTokens
PFNGLVERTEXATTRIBLPOINTERPROC OpenGLTokens
PFNGLVERTEXATTRIBP1UIPROC OpenGLTokens
PFNGLVERTEXATTRIBP1UIVPROC OpenGLTokens
PFNGLVERTEXATTRIBP2UIPROC OpenGLTokens
PFNGLVERTEXATTRIBP2UIVPROC OpenGLTokens
PFNGLVERTEXATTRIBP3UIPROC OpenGLTokens
PFNGLVERTEXATTRIBP3UIVPROC OpenGLTokens
PFNGLVERTEXATTRIBP4UIPROC OpenGLTokens
PFNGLVERTEXATTRIBP4UIVPROC OpenGLTokens
PFNGLVERTEXATTRIBPOINTERARBPROC OpenGLTokens
PFNGLVERTEXATTRIBPOINTERNVPROC OpenGLTokens
PFNGLVERTEXATTRIBPOINTERPROC OpenGLTokens
PFNGLVERTEXATTRIBS1DVNVPROC OpenGLTokens
PFNGLVERTEXATTRIBS1FVNVPROC OpenGLTokens
PFNGLVERTEXATTRIBS1SVNVPROC OpenGLTokens
PFNGLVERTEXATTRIBS2DVNVPROC OpenGLTokens
PFNGLVERTEXATTRIBS2FVNVPROC OpenGLTokens
PFNGLVERTEXATTRIBS2SVNVPROC OpenGLTokens
PFNGLVERTEXATTRIBS3DVNVPROC OpenGLTokens
PFNGLVERTEXATTRIBS3FVNVPROC OpenGLTokens
PFNGLVERTEXATTRIBS3SVNVPROC OpenGLTokens
PFNGLVERTEXATTRIBS4DVNVPROC OpenGLTokens
PFNGLVERTEXATTRIBS4FVNVPROC OpenGLTokens
PFNGLVERTEXATTRIBS4SVNVPROC OpenGLTokens
PFNGLVERTEXATTRIBS4UBVNVPROC OpenGLTokens
PFNGLVERTEXBLENDARBPROC OpenGLTokens
PFNGLVERTEXFORMATNVPROC OpenGLTokens
PFNGLVERTEXP2UIPROC OpenGLTokens
PFNGLVERTEXP2UIVPROC OpenGLTokens
PFNGLVERTEXP3UIPROC OpenGLTokens
PFNGLVERTEXP3UIVPROC OpenGLTokens
PFNGLVERTEXP4UIPROC OpenGLTokens
PFNGLVERTEXP4UIVPROC OpenGLTokens
PFNGLVIEWPORTARRAYVPROC OpenGLTokens
PFNGLVIEWPORTINDEXEDFPROC OpenGLTokens
PFNGLVIEWPORTINDEXEDFVPROC OpenGLTokens
PFNGLWAITSYNCPROC OpenGLTokens
PFNGLWEIGHTBVARBPROC OpenGLTokens
PFNGLWEIGHTDVARBPROC OpenGLTokens
PFNGLWEIGHTFVARBPROC OpenGLTokens
PFNGLWEIGHTIVARBPROC OpenGLTokens
PFNGLWEIGHTPATHSNVPROC OpenGLTokens
PFNGLWEIGHTPOINTERARBPROC OpenGLTokens
PFNGLWEIGHTSVARBPROC OpenGLTokens
PFNGLWEIGHTUBVARBPROC OpenGLTokens
PFNGLWEIGHTUIVARBPROC OpenGLTokens
PFNGLWEIGHTUSVARBPROC OpenGLTokens
PFNGLWINDOWPOS2DARBPROC OpenGLTokens
PFNGLWINDOWPOS2DPROC OpenGLTokens
PFNGLWINDOWPOS2DVARBPROC OpenGLTokens
PFNGLWINDOWPOS2DVPROC OpenGLTokens
PFNGLWINDOWPOS2FARBPROC OpenGLTokens
PFNGLWINDOWPOS2FPROC OpenGLTokens
PFNGLWINDOWPOS2FVARBPROC OpenGLTokens
PFNGLWINDOWPOS2FVPROC OpenGLTokens
PFNGLWINDOWPOS2IARBPROC OpenGLTokens
PFNGLWINDOWPOS2IPROC OpenGLTokens
PFNGLWINDOWPOS2IVARBPROC OpenGLTokens
PFNGLWINDOWPOS2IVPROC OpenGLTokens
PFNGLWINDOWPOS2SARBPROC OpenGLTokens
PFNGLWINDOWPOS2SPROC OpenGLTokens
PFNGLWINDOWPOS2SVARBPROC OpenGLTokens
PFNGLWINDOWPOS2SVPROC OpenGLTokens
PFNGLWINDOWPOS3DARBPROC OpenGLTokens
PFNGLWINDOWPOS3DPROC OpenGLTokens
PFNGLWINDOWPOS3DVARBPROC OpenGLTokens
PFNGLWINDOWPOS3DVPROC OpenGLTokens
PFNGLWINDOWPOS3FARBPROC OpenGLTokens
PFNGLWINDOWPOS3FPROC OpenGLTokens
PFNGLWINDOWPOS3FVARBPROC OpenGLTokens
PFNGLWINDOWPOS3FVPROC OpenGLTokens
PFNGLWINDOWPOS3IARBPROC OpenGLTokens
PFNGLWINDOWPOS3IPROC OpenGLTokens
PFNGLWINDOWPOS3IVARBPROC OpenGLTokens
PFNGLWINDOWPOS3IVPROC OpenGLTokens
PFNGLWINDOWPOS3SARBPROC OpenGLTokens
PFNGLWINDOWPOS3SPROC OpenGLTokens
PFNGLWINDOWPOS3SVARBPROC OpenGLTokens
PFNGLWINDOWPOS3SVPROC OpenGLTokens
PFNWGLALLOCATEMEMORYNVPROC OpenGLTokens
PFNWGLBINDTEXIMAGEARBPROC OpenGLTokens
PFNWGLCHOOSEPIXELFORMATARBPROC OpenGLTokens
PFNWGLCREATEAFFINITYDCNVPROC OpenGLTokens
PFNWGLCREATEBUFFERREGIONARBPROC OpenGLTokens
PFNWGLCREATECONTEXTATTRIBSARBPROC OpenGLTokens
PFNWGLCREATEPBUFFERARBPROC OpenGLTokens
PFNWGLDELETEBUFFERREGIONARBPROC OpenGLTokens
PFNWGLDELETEDCNVPROC OpenGLTokens
PFNWGLDESTROYPBUFFERARBPROC OpenGLTokens
PFNWGLDXCLOSEDEVICEPROC OpenGLTokens
PFNWGLDXLOCKOBJECTSPROC OpenGLTokens
PFNWGLDXOBJECTACCESSPROC OpenGLTokens
PFNWGLDXOPENDEVICEPROC OpenGLTokens
PFNWGLDXREGISTEROBJECTPROC OpenGLTokens
PFNWGLDXSETRESOURCESHAREHANDLEPROC OpenGLTokens
PFNWGLDXUNLOCKOBJECTSNVPROC OpenGLTokens
PFNWGLDXUNREGISTEROBJECTPROC OpenGLTokens
PFNWGLENUMGPUDEVICESNVPROC OpenGLTokens
PFNWGLENUMGPUSFROMAFFINITYDCNVPROC OpenGLTokens
PFNWGLENUMGPUSNVPROC OpenGLTokens
PFNWGLFREEMEMORYNVPROC OpenGLTokens
PFNWGLGETCURRENTREADDCARBPROC OpenGLTokens
PFNWGLGETEXTENSIONSSTRINGARBPROC OpenGLTokens
PFNWGLGETPBUFFERDCARBPROC OpenGLTokens
PFNWGLGETPIXELFORMATATTRIBFVARBPROC OpenGLTokens
PFNWGLGETPIXELFORMATATTRIBIVARBPROC OpenGLTokens
PFNWGLGETSWAPINTERVALEXTPROC OpenGLTokens
PFNWGLMAKECONTEXTCURRENTARBPROC OpenGLTokens
PFNWGLQUERYPBUFFERARBPROC OpenGLTokens
PFNWGLRELEASEPBUFFERDCARBPROC OpenGLTokens
PFNWGLRELEASETEXIMAGEARBPROC OpenGLTokens
PFNWGLRESTOREBUFFERREGIONARBPROC OpenGLTokens
PFNWGLSAVEBUFFERREGIONARBPROC OpenGLTokens
PFNWGLSETPBUFFERATTRIBARBPROC OpenGLTokens
PFNWGLSWAPINTERVALEXTPROC OpenGLTokens
PFog Types3DS
PFogSettings3DS Types3DS
PFontEntry GLSpaceText
PFovTrackTag Types3DS
PFSoundDSPUnit fmodtypes
PFSoundSample fmodtypes
PFSoundStream fmodtypes
PFSoundVector fmodtypes
PFSyncPoint fmodtypes
pFT_Raster_Params LIBFREETYPE
PFXPointerList GLParticleFX
PGLbitfield OpenGLTokens
PGLboolean OpenGLTokens
PGLbyte OpenGLTokens
PGLChar OpenGLTokens
PGLclampd OpenGLTokens
PGLclampf OpenGLTokens
PGLdouble OpenGLTokens
PGLenum OpenGLTokens
PGLfloat OpenGLTokens
PGLhandleARB OpenGLTokens
PGLint OpenGLTokens
PGLint64 OpenGLTokens
PGLint64EXT OpenGLTokens
PGLParticleArray GLParticleFX
PGLPCharArray OpenGLTokens
PGLPixel24 GLGraphics
PGLPixel32 GLGraphics
PGLPixel32Array GLGraphics
PGLPoint GLCrossPlatform
PGLPoint2D GLTypes
PGLPoint3D GLTypes
PGLPointer OpenGLTokens
PGLRCHandle GLContext
PGLRect GLCrossPlatform
PGLshort OpenGLTokens
PGLsizei OpenGLTokens
PGLStarRecord GLStarRecord
PGLubyte OpenGLTokens
PGLuint OpenGLTokens
PGLuint64 OpenGLTokens
PGLuint64EXT OpenGLTokens
PGLUNurbs OpenGLTokens
PGLUNurbsObj OpenGLTokens
PGLUQuadric OpenGLTokens
PGLUQuadricObj OpenGLTokens
PGLushort OpenGLTokens
PGLUTesselator OpenGLTokens
PGLUTesselatorObj OpenGLTokens
PGLUTriangulatorObj OpenGLTokens
PGLvdpauSurfaceNV OpenGLTokens
PGLvoid OpenGLTokens
PGNGLGETBUFFERPARAMETERUI64VNV OpenGLTokens
PGPUDevice OpenGLTokens
PHalfFloat GLCrossPlatform
PHeightTile HeightTileFile
PHeightTileInfo HeightTileFile
PHGPUNV OpenGLTokens
PHideTrackTag Types3DS
PHiShadowBias Types3DS
PHmgBoundingBox GeometryBB
PHomogeneousByteVector VectorGeometry
PHomogeneousDblVector VectorGeometry
PHomogeneousExtVector VectorGeometry
PHomogeneousFltVector VectorGeometry
PHomogeneousIntVector VectorGeometry
PHomogeneousMatrix VectorGeometry
PHomogeneousPtrVector VectorGeometry
PHomogeneousVector VectorGeometry
PHomogeneousWordVector VectorGeometry
PHotTrackTag Types3DS
PHVIDEO GLSVfw
PI1 LWObjects
PI2 LWObjects
PI4 LWObjects
PICCOMPRESS GLSVfw
PICCOMPRESSFRAMES GLSVfw
PICDECOMPRESS GLSVfw
PICDECOMPRESSEX GLSVfw
PICDRAW GLSVfw
PICDRAWBEGIN GLSVfw
PICDRAWSUGGEST GLSVfw
PICINFO GLSVfw
PICOPEN GLSVfw
PICPALETTE GLSVfw
PICSETSTATUSPROC GLSVfw
PID4 LWObjects
PInstanceName Types3DS
PInt NewtonImport
PInt GLSDL
PInteger GLSDL
PInteger HeightTileFile
PIntegerArray VectorGeometry
PIntegerArray Types3DS
PIntegerArray HeightTileFile
PIntegerVector VectorGeometry
PIntermediateFormatArray ImageUtils
PIntPercentage Types3DS
PIpasData Types3DS
PJoystick_hwdata GLSDL
PKeyHeader3DS Types3DS
PKeyHeaderList Types3DS
PKEYSChunk TypesB3D
PKeyStateArr GLSDL
PKFAmbient3DS Types3DS
PKFCamera3DS Types3DS
PKFCurtime Types3DS
PKFHdr Types3DS
PKFId Types3DS
PKFKeyInfo3DS Types3DS
PKFMesh3DS Types3DS
PKFMorphKey3DS Types3DS
PKFMorphKeyList Types3DS
PKFOmni3DS Types3DS
PKFRotKey3DS Types3DS
PKFRotKeyList Types3DS
PKFSeg Types3DS
PKFSegment3DS Types3DS
PKFSets3DS Types3DS
PKFSpot3DS Types3DS
PLayerFog Types3DS
PLayerFogSettings3DS Types3DS
PLight3DS Types3DS
PLinColor24 Types3DS
PLinColorF Types3DS
PLiteAttenuate3DS Types3DS
PLMTS GLFileLMTS
PLMTS_Header GLFileLMTS
PLMTS_Subset GLFileLMTS
PLMTS_TexData GLFileLMTS
PLMTS_Vertex GLFileLMTS
PLONG GLSVfw
PLong NewtonImport
PLongWord GLSDL
PLongWordArray VectorGeometry
PLongWordVector VectorGeometry
PLong_double NewtonImport
PLoShadowBias Types3DS
PLWChunkRec LWObjects
PLWPolyTagMap LWObjects
PLWSubChunkRec LWObjects
PM3dVersion Types3DS
PMainAVIHeader GLSVfw
PMapInfo3DS Types3DS
PMapSet3DS Types3DS
PMasterScale Types3DS
PMatAcubic Types3DS
PMatBumpPercent Types3DS
PMaterial3DS Types3DS
PMatMapAng Types3DS
PMatMapBCol Types3DS
PMatMapCol1 Types3DS
PMatMapCol2 Types3DS
PMatMapGCol Types3DS
PMatMapname Types3DS
PMatMapRCol Types3DS
PMatMapTexblur Types3DS
PMatMapTiling Types3DS
PMatMapUOffset Types3DS
PMatMapUScale Types3DS
PMatMapVOffset Types3DS
PMatMapVScale Types3DS
PMatName Types3DS
PMatrix VectorGeometry
PMatrixArray VectorGeometry
PMatShading Types3DS
PMatWireSize Types3DS
PMD2AliasFrame TypesMD2
PMD2VertexIndex TypesMD2
PMDCTagFrame TypesMDC
PMDCTagName TypesMDC
PMesh3DS Types3DS
PMESHChunk TypesB3D
PMeshColor Types3DS
PMeshMatrix Types3DS
PMeshSet3DS Types3DS
PMeshTextureInfo Types3DS
PMeshVersion Types3DS
PMorphSmooth Types3DS
PMorphTrackTag Types3DS
pMS3DComment TypesMS3D
PMS3DJointArray TypesMS3D
PMS3DKeyframePositionArray TypesMS3D
PMS3DKeyframeRotationArray TypesMS3D
PMS3DTriangleArray TypesMS3D
PMS3DVertexArray TypesMS3D
pMS3D_vertex_ex_t TypesMS3D
PMshBoxmap Types3DS
PMshMatGroup Types3DS
PNamedObject Types3DS
PNCamera Types3DS
PNDirectLight Types3DS
PNewtonAllocMemory NewtonImport
PNewtonApplyForceAndTorque NewtonImport
PNewtonBallCallBack NewtonImport
PNewtonBody NewtonImport
PNewtonBodyDestructor NewtonImport
PNewtonBodyIterator NewtonImport
PNewtonBodyLeaveWorld NewtonImport
PNewtonBreakableComponentMesh NewtonImport
PNewtonCollision NewtonImport
PNewtonCollisionCompoundBreakableCallback NewtonImport
PNewtonCollisionDestructor NewtonImport
PNewtonCollisionInfoRecord NewtonImport
PNewtonCollisionIterator NewtonImport
PNewtonCollisionTreeRayCastCallback NewtonImport
PNewtonConstraintDestructor NewtonImport
PNewtonContact NewtonImport
PNewtonContactsProcess NewtonImport
PNewtonCorkscrewCallBack NewtonImport
PNewtonDeserialize NewtonImport
PNewtonDestroyBodyByExeciveForce NewtonImport
PNewtonDestroyWorld NewtonImport
PNewtonFreeMemory NewtonImport
PNewtonGetBuoyancyPlane NewtonImport
PNewtonGetTicksCountCallback NewtonImport
PNewtonHeightFieldRayCastCallback NewtonImport
PNewtonHingeCallBack NewtonImport
PNewtonHingeSliderUpdateDesc NewtonImport
PNewtonIslandUpdate NewtonImport
PNewtonJoint NewtonImport
PNewtonJointIterator NewtonImport
PNewtonJointRecord NewtonImport
PNewtonMaterial NewtonImport
PNewtonMesh NewtonImport
PNewtonMeshEdge NewtonImport
PNewtonMeshFace NewtonImport
PNewtonMeshPoint NewtonImport
PNewtonMeshVertex NewtonImport
PNewtonOnAABBOverlap NewtonImport
PNewtonSceneProxy NewtonImport
PNewtonSerialize NewtonImport
PNewtonSetTransform NewtonImport
PNewtonSliderCallBack NewtonImport
PNewtonTreeCollisionCallback NewtonImport
PNewtonUniversalCallBack NewtonImport
PNewtonUserBilateralCallBack NewtonImport
PNewtonUserBilateralGetInfoCallBack NewtonImport
PNewtonUserJoint NewtonImport
PNewtonUserJointDestructorCallback NewtonImport_JointLibrary
PNewtonUserJointSubmitConstraintCallback NewtonImport_JointLibrary
PNewtonUserMeshCollisionCollideCallback NewtonImport
PNewtonUserMeshCollisionCollideDesc NewtonImport
PNewtonUserMeshCollisionDestroyCallback NewtonImport
PNewtonUserMeshCollisionGetCollisionInfo NewtonImport
PNewtonUserMeshCollisionGetFacesInAABB NewtonImport
PNewtonUserMeshCollisionRayHitCallback NewtonImport
PNewtonUserMeshCollisionRayHitDesc NewtonImport
PNewtonWorld NewtonImport
PNewtonWorldConvexCastReturnInfo NewtonImport
PNewtonWorldRayFilterCallback NewtonImport
PNewtonWorldRayPrefilterCallback NewtonImport
PNGDFloat GLNGDManager
png_byte LIBPNG
png_bytep LIBPNG
png_bytepp LIBPNG
png_bytep_array LIBPNG
png_bytep_arrayp LIBPNG
png_byte_array LIBPNG
png_charp LIBPNG
png_charpp LIBPNG
png_charp_array LIBPNG
png_charp_arrayp LIBPNG
png_colorp LIBPNG
png_colorpp LIBPNG
png_color_16p LIBPNG
png_color_16pp LIBPNG
png_color_8p LIBPNG
png_color_8pp LIBPNG
png_color_array LIBPNG
png_const_charp LIBPNG
png_doublep LIBPNG
png_error_ptr LIBPNG
png_FILE_p LIBPNG
png_fixed_point LIBPNG
png_fixed_point_p LIBPNG
png_flush_ptr LIBPNG
png_free_ptr LIBPNG
png_infop LIBPNG
png_infopp LIBPNG
png_int_16 LIBPNG
png_int_16p LIBPNG
png_int_32 LIBPNG
png_int_32p LIBPNG
png_longjmp_ptr LIBPNG
png_malloc_ptr LIBPNG
png_progressive_end_ptr LIBPNG
png_progressive_info_ptr LIBPNG
png_progressive_row_ptr LIBPNG
png_read_status_ptr LIBPNG
png_row_infop LIBPNG
png_rw_ptr LIBPNG
png_size_t LIBPNG
png_sPLT_entryp LIBPNG
png_sPLT_entrypp LIBPNG
png_sPLT_tp LIBPNG
png_sPLT_tpp LIBPNG
png_sPLT_tp_array | LIBPNG | number of palette entries
png_sPLT_tp_arrayp LIBPNG
png_structp LIBPNG
png_structpp LIBPNG
png_textp LIBPNG
png_textpp LIBPNG
png_text_array LIBPNG
png_text_arrayp LIBPNG
png_timep | LIBPNG | second of minute, 0 - 60 (for leap seconds)
png_timepp LIBPNG
png_uint_16 LIBPNG
png_uint_16p LIBPNG
png_uint_16pp LIBPNG
png_uint_32 LIBPNG
png_uint_32p LIBPNG
png_unknown_chunkp LIBPNG
png_unknown_chunkpp LIBPNG
png_unknown_chunk_array | LIBPNG | libpng-using applications should NOT directly modify this byte. png_byte location; mode of operation at read time
png_unknown_chunk_arrayp LIBPNG
png_user_chunk_ptr LIBPNG
png_user_transform_ptr LIBPNG
png_voidp LIBPNG
png_write_status_ptr LIBPNG
PNODEChunk TypesB3D
PNodeHdr Types3DS
PNodeList Types3DS
PObject PersistentClasses
PObjMat3DS Types3DS
PObjMatList Types3DS
POConsts Types3DS
POCTFace FileOCT
POCTLightmap FileOCT
POctreeNode Octree
POctreeTriangleInfo Octree
POrthoView3DS Types3DS
PPALvoid openal
PParticleReference GLParticleFX
PParticleReferenceArray GLParticleFX
PPCUgraphicsResource GLS_CUDA_API
PPdObject ODEImport
PPdxGeom ODEImport
PPFXRegion GLParticleFX
PPHeightTileInfo HeightTileFile
PPivot Types3DS
PPlugInEntry PlugInManager
ppng_byte LIBPNG
ppng_bytep LIBPNG
ppng_charp LIBPNG
ppng_charpp LIBPNG
ppng_colorp LIBPNG
ppng_color_16p LIBPNG
ppng_color_8p LIBPNG
ppng_fixed_point LIBPNG
ppng_int_16 LIBPNG
ppng_int_32 LIBPNG
ppng_textp LIBPNG
ppng_timep LIBPNG
ppng_uint_16 LIBPNG
ppng_uint_16p LIBPNG
ppng_uint_32 LIBPNG
PPoint GLSDL
PPoint GLCrossPlatform
PPoint3DS Types3DS
PPointArray Types3DS
PPointerArray VectorGeometry
PPointerObjectList PersistentClasses
PPointerVector VectorGeometry
PPointFlagArray Types3DS
PPointList Types3DS
PPosTrackTag Types3DS
pppng_byte LIBPNG
pppng_fixed_point LIBPNG
pppng_int_16 LIBPNG
pppng_int_32 LIBPNG
pppng_uint_16 LIBPNG
pppng_uint_32 LIBPNG
PProcName Types3DS
PPSDL_Rect GLSDL
PQuaternion VectorGeometry
PQuaternionArray VectorGeometry
PRayBias Types3DS
PRect GLSDL
PRect GLCrossPlatform
PRenderContextInfo GLRenderContextInfo
PResManagerEntry PlugInManager
PRGBA32F ImageUtils
PRGBColor GLColor
PROAMTriangleNode GLROAMPatch
ProgramBuilt_notify_fn GLS_CL
PRollTrackTag Types3DS
PRotTrackTag Types3DS
PScaleTrackTag Types3DS
PSceneObjectEntry GLObjectManager
PSDL_AudioCVT GLSDL
PSDL_AudioCVTFilter GLSDL
PSDL_AudioCVTFilterArray GLSDL
PSDL_AudioSpec GLSDL
PSDL_BlitInfo GLSDL
PSDL_CD GLSDL
PSDL_CDTrack GLSDL
PSDL_Color GLSDL
PSDL_ColorArray GLSDL
PSDL_Cond GLSDL
PSDL_Cursor GLSDL
PSDL_error GLSDL
PSDL_Event GLSDL
PSDL_ExposeEvent GLSDL
PSDL_Joystick GLSDL
PSDL_KeySym GLSDL
PSDL_Mutex GLSDL
PSDL_Overlay GLSDL
PSDL_Palette GLSDL
PSDL_PixelFormat GLSDL
PSDL_QuitEvent GLSDL
PSDL_Rect GLSDL
PSDL_RWops GLSDL
PSDL_Sem GLSDL
PSDL_semaphore GLSDL
PSDL_Surface GLSDL
PSDL_SysWMEvent GLSDL
PSDL_SysWMmsg GLSDL
PSDL_Thread GLSDL
PSDL_TimerID GLSDL
PSDL_UserEvent GLSDL
PSDL_version GLSDL
PSDL_VideoInfo GLSDL
PShadowFilter Types3DS
PShadowMapSize Types3DS
PShadowRange Types3DS
PShadowSamples Types3DS
PShadowSets3DS Types3DS
PShort NewtonImport
PShortInt HeightTileFile
PShortIntArray HeightTileFile
PSingleArray VectorGeometry
PSingleArrayList VectorLists
PSingleList Types3DS
PSingleRaster GLHeightData
PSInt64 GLSDL
Psize_t NewtonImport
Psize_t GLS_CL_Platform
PSmallInt HeightTileFile
PSmallIntArray GLHeightData
PSmallIntArray HeightTileFile
PSmallIntRaster GLHeightData
PSmoothGroup Types3DS
PSoundFileFormat GLSoundFileObjects
PSpotCone3DS Types3DS
PSpotLight3DS Types3DS
PSpotProjector3DS Types3DS
PSpotShadow3DS Types3DS
PSqrt255Array GLUtils
PS_FontInfo LIBFREETYPE
PS_Private LIBFREETYPE
PTdJointFeedback ODEImport
PTexPoint VectorGeometry
PTexPointArray VectorGeometry
PTEXSChunk TypesB3D
PTextureReference GLS_CUDA_Runtime
PTexVert3DS Types3DS
PTexVertList Types3DS
PTexVerts Types3DS
PThorpoint GLThorFX
PThorpointArray GLThorFX
PTrackHeader3DS Types3DS
PTransAxis GLSDL
PTransformationRec GLPipelineTransformation
PTRISChunk TypesB3D
PU1 LWObjects
PU2 LWObjects
PU2Array LWObjects
PU4 LWObjects
PU4Array LWObjects
PUInt16 GLSDL
PUInt32 GLSDL
PUInt64 GLSDL
PUInt8 GLSDL
PUInt8Array GLSDL
PUnknown GLSVfw
PUnsigned_char NewtonImport
PUnsigned_int NewtonImport
PUnsigned_long NewtonImport
PUnsigned_short NewtonImport
PUserView3DS Types3DS
PVdpBitmapSurface GLS_VDPAU_API
PVdpBitstreamBuffer GLS_VDPAU_API
PVdpBool GLS_VDPAU_API
PVdpChromaType GLS_VDPAU_API
PVdpColor GLS_VDPAU_API
PVdpColorStandard GLS_VDPAU_API
PVdpColorTableFormat GLS_VDPAU_API
PVdpCSCMatrix GLS_VDPAU_API
PVdpDecoder GLS_VDPAU_API
PVdpDecoderProfile GLS_VDPAU_API
PVdpDevice GLS_VDPAU_API
PVdpDevice GLS_VDPAU_X11
PVdpFuncId GLS_VDPAU_API
PVdpGetErrorString GLS_VDPAU_API
PVdpGetProcAddress GLS_VDPAU_X11
PVdpIndexedFormat GLS_VDPAU_API
PVdpLayer GLS_VDPAU_API
PVdpOutputSurface GLS_VDPAU_API
PVdpOutputSurfaceRenderBlendEquation GLS_VDPAU_API
PVdpOutputSurfaceRenderBlendFactor GLS_VDPAU_API
PVdpOutputSurfaceRenderBlendState GLS_VDPAU_API
PVdpPictureInfo GLS_VDPAU_API
PVdpPictureInfoDivX4 GLS_VDPAU_API
PVdpPictureInfoDivX5 GLS_VDPAU_API
PVdpPictureInfoH264 GLS_VDPAU_API
PVdpPictureInfoMPEG1Or2 GLS_VDPAU_API
PVdpPictureInfoMPEG4Part2 GLS_VDPAU_API
PVdpPictureInfoVC1 GLS_VDPAU_API
PVdpPoint GLS_VDPAU_API
PVdpPresentationQueue GLS_VDPAU_API
PVdpPresentationQueueStatus GLS_VDPAU_API
PVdpPresentationQueueTarget GLS_VDPAU_API
PVdpPresentationQueueTarget GLS_VDPAU_X11
PVdpProcamp GLS_VDPAU_API
PVdpRect GLS_VDPAU_API
PVdpReferenceFrameH264 GLS_VDPAU_API
PVdpRGBAFormat GLS_VDPAU_API
PVdpStatus GLS_VDPAU_API
PVdpTime GLS_VDPAU_API
PVdpVideoMixer GLS_VDPAU_API
PVdpVideoMixerAttribute GLS_VDPAU_API
PVdpVideoMixerFeature GLS_VDPAU_API
PVdpVideoMixerParameter GLS_VDPAU_API
PVdpVideoMixerPictureStructure GLS_VDPAU_API
PVdpVideoSurface GLS_VDPAU_API
PVdpYCbCrFormat GLS_VDPAU_API
PVec12 LWObjects
PVec12Array LWObjects
PVector VectorGeometry
PVector2f VectorGeometry
PVectorArray VectorGeometry
PVertex VectorGeometry
PVertexBoneWeightArray GLVectorFileObjects
PVertexData TypesB3D
PVertexData GLMesh
PVertexDataArray GLMesh
PVertexRec GLObjects
PVerticesBoneWeights GLVectorFileObjects
PVGradient Types3DS
PVGradientBgnd3DS Types3DS
PVIDEOHDR GLSVfw
PVideoMode GLScreen
PViewCamera Types3DS
PViewport3DS Types3DS
PViewportData Types3DS
PViewportData3 Types3DS
PViewportLayout Types3DS
PViewportSize Types3DS
PViewSize3DS Types3DS
PViewStandard Types3DS
PViewUser Types3DS
PVOID GLSVfw
Pvoid NewtonImport
PVRTSChunk TypesB3D
PWGLswap OpenGLTokens
PWord GLSDL
PWordArray GLSDL
PWordList Types3DS
PWordVector VectorGeometry
PXDataAppName Types3DS
PXDataDouble Types3DS
PXDataEntry Types3DS
PXDataFloat Types3DS
PXDataLong Types3DS
PXDataRaw3DS Types3DS
PXDataShort Types3DS
PXDataString Types3DS
PXDataVoid Types3DS
PZArray GLzBuffer
P__int16 NewtonImport
P__int32 NewtonImport
P__int64 NewtonImport
P__int8 NewtonImport
QWORD Bass
RawByteString GLSZLibEx
RECORDPROC Bass
SDL_errorcode GLSDL
SDL_Rect GLSDL
SDL_RWops GLSDL
Short NewtonImport
SInt16 GLSDL
SInt32 GLSDL
size_t NewtonImport
STREAMFILEPROC Bass
STREAMPROC Bass
String3DS Types3DS
String64 Types3DS
SYNCPROC Bass
T1DPerlinArray GLPerlinBase
T2DPerlinArray GLPerlinBase
T48BitBlock ImageUtils
T4ByteArrayList VectorLists
TAABBCorners GeometryBB
TAABBOverlapEvent GLNGDManager
TAArray GLzBuffer
TAArrayIdx GLzBuffer
TAbstractMultitextureCoordinatorClass GLContext
TActorAnimationMode | GLVectorFileObjects | Defines how an actor plays between its StartFrame and EndFrame.<p> <ul> <li>aamNone : no animation is performed <li>aamPlayOnce : play from current frame to EndFrame, once end frame has been reached, switches to aamNone <li>aamLoop : play from current frame to EndFrame, once end frame has been reached, sets CurrentFrame to StartFrame <li>aamBounceForward : play from current frame to EndFrame, once end frame has been reached, switches to aamBounceBackward <li>aamBounceBackward : play from current frame to StartFrame, once start frame has been reached, switches to aamBounceForward <li>aamExternal : Allows for external animation control </ul>
TActorAnimationName GLVectorFileObjects
TActorAnimationReference GLVectorFileObjects
TActorFrameInterpolation | GLVectorFileObjects | Actor frame-interpolation mode.<p> - afpNone : no interpolation, display CurrentFrame only<br> - afpLinear : perform linear interpolation between current and next frame
TAffineByteMatrix VectorGeometry
TAffineByteVector VectorGeometry
TAffineDblMatrix VectorGeometry
TAffineDblVector VectorGeometry
TAffineExtMatrix VectorGeometry
TAffineExtVector VectorGeometry
TAffineFltMatrix VectorGeometry
TAffineFltVector VectorGeometry
TAffineIntMatrix VectorGeometry
TAffineIntVector VectorGeometry
TAffineMatrix VectorGeometry
TAffinePtrVector VectorGeometry
TAffineVector VectorGeometry
TAffineVectorArray VectorGeometry
TAffineWordMatrix VectorGeometry
TAffineWordVector VectorGeometry
TAFIOCreateFileStream ApplicationFileIO
TAFIOFileStreamEvent ApplicationFileIO
TAFIOFileStreamExists ApplicationFileIO
TAFIOFileStreamExistsEvent ApplicationFileIO
TALbitfield openal
TALboolean openal
TALbyte openal
TALCboolean openal
TALCbyte openal
TALCchar openal
TALCcontext openal
TALCdevice openal
TALCdouble openal
TALCenum openal
TALCfloat openal
TALchar openal
TALCint openal
TALclampd openal
TALclampf openal
TALCshort openal
TALCsizei openal
TALCubyte openal
TALCuint openal
TALCushort openal
TALCvoid openal
TALdouble openal
TALenum openal
TALfloat openal
TALint openal
TAlloc LIBPNG
TALshort openal
TALsizei openal
TALuByte openal
TALuint openal
TALushort openal
TALvoid openal
TANG4 LWObjects
TAngleLimit1 GLObjects
TAngleLimit2 GLObjects
TAnnulusPart GLGeomObjects
TAnnulusParts GLGeomObjects
TApplyForceAndTorqueEvent GLNGDManager
TArcDirection GLCanvas
TArrowArcPart GLGeomObjects
TArrowArcParts GLGeomObjects
TArrowHeadStackingStyle GLGeomObjects
TArrowLinePart GLGeomObjects
TArrowLineParts GLGeomObjects
TASETextureMap GLFileASE
TAtmosphereType3DS Types3DS
TAVICompressor GLAVIRecorder
TAVIFileInfo GLSVfw
TAVIImageRetrievalMode | GLAVIRecorder | Image retrieval mode for frame capture.<p> Following modes are supported:<p> <li>irmSnapShot : retrieve OpenGL framebuffer content using glReadPixels <li>irmRenderToBitmap : renders the whole scene to a bitmap, this is the slowest mode, but it won't be affected by driver-side specifics. <li>irmBitBlt : tranfers the framebuffer using the BitBlt function, usually the fastest solution </ul>
TAVIRecorderPostProcessEvent GLAVIRecorder
TAVIRecorderState GLAVIRecorder
TAVISAVECALLBACK GLSVfw
TAVISizeRestriction | GLAVIRecorder | Frame size restriction.<p> Forces frame dimensions to be a multiple of 2, 4, or 8. Some compressors require this. e.g. DivX 5.2.1 requires mutiples of 2.
TAVIStreamInfo GLSVfw
TB3DChunkType TypesB3D
TBackgroundType3DS Types3DS
TBaseArchiveClass GLSArchiveManager
TBaseListOption VectorLists
TBaseListOptions VectorLists
TBASS3DAlgorithm GLSMBASS
TBASSModuleHandle Bass
TBASS_PLUGINFORMS Bass
TBitmapBgnd3DS Types3DS
TBlendEquation GLState
TBlendFunction GLState
TBlendingMode | GLMaterial | Simplified blending options.<p> bmOpaque : disable blending<br> bmTransparency : uses standard alpha blending<br> bmAdditive : activates additive blending (with saturation)<br> bmAlphaTest50 : uses opaque blending, with alpha-testing at 50% (full transparency if alpha is below 0.5, full opacity otherwise)<br> bmAlphaTest100 : uses opaque blending, with alpha-testing at 100%<br> bmModulate : uses modulation blending<br> bmCustom : uses TGLBlendingParameters options
TBodyFlags ODEImport
TBorderType GLSMemo
TBSPBBox Q3BSP
TBSplineContinuity CurvesAndSurfaces
TBSPRenderSort GLBSP
TBumpMethod GLBumpShader
TBumpOption GLBumpShader
TBumpOptions GLBumpShader
TBumpSpace GLBumpShader
TByteArray GLHeightData
TByteArray GLSDL
TByteRaster GLHeightData
TByteVector VectorGeometry
TCalcPointEvent GLThorFX
TCAPCONTROLCALLBACK GLSVfw
TCAPERRORCALLBACK GLSVfw
TCAPERRORCALLBACKA GLSVfw
TCAPERRORCALLBACKW GLSVfw
TCAPSTATUSCALLBACK GLSVfw
TCAPSTATUSCALLBACKA GLSVfw
TCAPSTATUSCALLBACKW GLSVfw
TCapType GLObjects
TCAPVIDEOCALLBACK GLSVfw
TCAPWAVECALLBACK GLSVfw
TCAPYIELDCALLBACK GLSVfw
TCardinalArray Types3DS
TCardinalVector VectorGeometry
TCgApplyEvent GLCgShader
TCgFPProfile GLCgShader
TCGGLenum cgGL
TcgProgramType GLCgShader
TCgShaderEvent GLCgShader
TCgUnApplyEvent GLCgShader
TCgVPProfile GLCgShader
TChunkList Types3DS
TClose GLSDL
Tcl_addressing_mode GLS_CL
Tcl_bitfield GLS_CL
Tcl_bool GLS_CL
Tcl_build_status GLS_CL
Tcl_channel_order GLS_CL
Tcl_channel_type GLS_CL
Tcl_char GLS_CL_Platform
Tcl_char16 GLS_CL_Platform
Tcl_char2 GLS_CL_Platform
Tcl_char4 GLS_CL_Platform
Tcl_char8 GLS_CL_Platform
Tcl_command_queue GLS_CL
Tcl_command_queue_info GLS_CL
Tcl_command_queue_properties GLS_CL
Tcl_command_type GLS_CL
Tcl_context GLS_CL
Tcl_context_info GLS_CL
Tcl_context_properties GLS_CL
Tcl_device_address_info GLS_CL
Tcl_device_exec_capabilities GLS_CL
Tcl_device_fp_config GLS_CL
Tcl_device_id GLS_CL
Tcl_device_info GLS_CL
Tcl_device_local_mem_type GLS_CL
Tcl_device_mem_cache_type GLS_CL
Tcl_device_type GLS_CL
Tcl_double GLS_CL_Platform
Tcl_double16 GLS_CL_Platform
Tcl_double2 GLS_CL_Platform
Tcl_double4 GLS_CL_Platform
Tcl_double8 GLS_CL_Platform
Tcl_event GLS_CL
Tcl_event_info GLS_CL
Tcl_filter_mode GLS_CL
Tcl_float GLS_CL_Platform
Tcl_float16 GLS_CL_Platform
Tcl_float2 GLS_CL_Platform
Tcl_float4 GLS_CL_Platform
Tcl_float8 GLS_CL_Platform
Tcl_gl_object_type GLS_CL_GL
Tcl_gl_platform_info GLS_CL_GL
Tcl_gl_texture_info GLS_CL_GL
Tcl_half GLS_CL_Platform
Tcl_image_info GLS_CL
Tcl_int GLS_CL_Platform
Tcl_int16 GLS_CL_Platform
Tcl_int2 GLS_CL_Platform
Tcl_int4 GLS_CL_Platform
Tcl_int8 GLS_CL_Platform
Tcl_kernel GLS_CL
Tcl_kernel_info GLS_CL
Tcl_kernel_work_group_info GLS_CL
Tcl_long GLS_CL_Platform
Tcl_long16 GLS_CL_Platform
Tcl_long2 GLS_CL_Platform
Tcl_long4 GLS_CL_Platform
Tcl_long8 GLS_CL_Platform
Tcl_map_flags GLS_CL
Tcl_mem GLS_CL
Tcl_mem_flags GLS_CL
Tcl_mem_info GLS_CL
Tcl_mem_object_type GLS_CL
Tcl_platform_id GLS_CL
Tcl_platform_info GLS_CL
Tcl_profiling_info GLS_CL
Tcl_program GLS_CL
Tcl_program_build_info GLS_CL
Tcl_program_info GLS_CL
Tcl_sampler GLS_CL
Tcl_sampler_info GLS_CL
Tcl_short GLS_CL_Platform
Tcl_short16 GLS_CL_Platform
Tcl_short2 GLS_CL_Platform
Tcl_short4 GLS_CL_Platform
Tcl_short8 GLS_CL_Platform
Tcl_uchar GLS_CL_Platform
Tcl_uchar16 GLS_CL_Platform
Tcl_uchar2 GLS_CL_Platform
Tcl_uchar4 GLS_CL_Platform
Tcl_uchar8 GLS_CL_Platform
Tcl_uint GLS_CL_Platform
Tcl_uint16 GLS_CL_Platform
Tcl_uint2 GLS_CL_Platform
Tcl_uint4 GLS_CL_Platform
Tcl_uint8 GLS_CL_Platform
Tcl_ulong GLS_CL_Platform
Tcl_ulong16 GLS_CL_Platform
Tcl_ulong2 GLS_CL_Platform
Tcl_ulong4 GLS_CL_Platform
Tcl_ulong8 GLS_CL_Platform
Tcl_ushort GLS_CL_Platform
Tcl_ushort16 GLS_CL_Platform
Tcl_ushort2 GLS_CL_Platform
Tcl_ushort4 GLS_CL_Platform
Tcl_ushort8 GLS_CL_Platform
TCollisionBoundingMode | GLCollision | Defines how fine collision bounding is for a particular object.<p> Possible values are :<ul> <li>cbmPoint : the object is punctual and may only collide with volumes <li>cbmSphere : the object is defined by its bounding sphere (sphere radius is the max of axis-aligned dimensions) <li>cbmEllipsoid the object is defined by its bounding axis-aligned ellipsoid <li>cbmCube : the object is defined by a bounding axis-aligned "cube" <li>cbmFaces : the object is defined by its faces (needs object-level support, if unavalaible, uses cbmCube code) </ul>
TCollisionConstraintTypes VerletClasses
TCollisionConstraintTypesSet VerletClasses
TCollisionIteratorEvent GLNGDManager
TCollisionPrimitiveArray NewtonImport
TColorComponent GLState
TColorMask GLState
TColorVector GLColor
TColr12 LWObjects
TColr12DynArray LWObjects
TColr4 LWObjects
TCombinerCache GLTextureCombiners
TCommand GLSMemo
TComparisonFunction GLState
TCompressionLevel GLSArchiveManager
TConePart GLGeomObjects
TConeParts GLGeomObjects
TConeStyle3DS Types3DS
TContactProcessEvent GLNGDManager
TContextOption | GLScene | Options for the rendering context.<p> roSoftwareMode: force software rendering. roDoubleBuffer: enables double-buffering.<br> roRenderToWindows: ignored (legacy).<br> roTwoSideLighting: enables two-side lighting model.<br> roStereo: enables stereo support in the driver (dunno if it works, I don't have a stereo device to test...)<br> roDestinationAlpha: request an Alpha channel for the rendered output<br> roNoColorBuffer: don't request a color buffer (color depth setting ignored)<br> roNoColorBufferClear: do not clear the color buffer automatically, if the whole viewer is fully repainted each frame, this can improve framerate<br> roNoSwapBuffers: don't perform RenderingContext.SwapBuffers after rendering roNoDepthBufferClear: do not clear the depth buffer automatically. Useful for early-z culling.<br> roForwardContext: force OpenGL forward context
TContextOptions GLScene
TConvertEncodingList GLSLanguage
TCSGOperation GLMeshCSG
TCuAddresMode GLSCUDA
TCUaddress_mode GLS_CUDA_API
TcuArray3DCreate GLS_CUDA_API
TcuArray3DGetDescriptor GLS_CUDA_API
TcuArrayCreate GLS_CUDA_API
TcuArrayDestroy GLS_CUDA_API
TcuArrayGetDescriptor GLS_CUDA_API
TCUarray_cubemap_face GLS_CUDA_API
TCUarray_format GLS_CUDA_API
TCubePart GLObjects
TCubeParts GLObjects
TCubicSplineMatrix Spline
TCUcomputemode GLS_CUDA_API
TcuCtxAttach GLS_CUDA_API
TcuCtxCreate GLS_CUDA_API
TcuCtxDestroy GLS_CUDA_API
TcuCtxDetach GLS_CUDA_API
TcuCtxGetDevice GLS_CUDA_API
TcuCtxPopCurrent GLS_CUDA_API
TcuCtxPushCurrent GLS_CUDA_API
TcuCtxSynchronize GLS_CUDA_API
TCUctx_flags GLS_CUDA_API
TCUDAChange GLSCUDA
TCUDAChanges GLSCUDA
TCudaChannelFormatKind GLS_CUDA_Runtime
TCUDAChannelNum GLSCUDA
TCUDAChannelType GLSCUDA
TCUDAComponentClass GLSCUDA
TCUDAContextList GLSCUDAContext
TCUDADeviceList GLSCUDAContext
TcudaError GLS_CUDA_Runtime
TCUDAFFTdir GLSCUDAFFTPlan
TCUDAFFTransform GLSCUDAFFTPlan
TcudaFuncCache GLS_CUDA_API
TCudaGLMapFlags GLS_CUDA_Runtime
TCUDAHandleList GLSCUDAContext
TcudaLimit GLS_CUDA_API
TCUDAMapping GLSCUDA
TcudaMemcpyKind GLS_CUDA_Runtime
TCUDAMemMapFlag GLSCUDA
TCUDAMemMapFlags GLSCUDA
TCUDAMemType GLSCUDA
TcudaRoundMode GLS_CUDA_FourierTransform
TcudaTextureAddressMode GLS_CUDA_Runtime
TcudaTextureFilterMode GLS_CUDA_Runtime
TcudaTextureReadMode GLS_CUDA_Runtime
TCUDAType GLSCUDAParser
TCUdevice GLS_CUDA_API
TcuDeviceComputeCapability GLS_CUDA_API
TcuDeviceGet GLS_CUDA_API
TcuDeviceGetAttribute GLS_CUDA_API
TcuDeviceGetCount GLS_CUDA_API
TcuDeviceGetName GLS_CUDA_API
TcuDeviceGetProperties GLS_CUDA_API
TCUdeviceptr GLS_CUDA_API
TcuDeviceTotalMem GLS_CUDA_API
TCUdevice_attribute GLS_CUDA_API
TCUDPPAlgorithm GLS_CUDA_ParallelPrimitives
TCUDPPDatatype GLS_CUDA_ParallelPrimitives
TCUDPPHandle GLS_CUDA_ParallelPrimitives
TCUDPPOperator GLS_CUDA_ParallelPrimitives
TCUDPPOption GLS_CUDA_ParallelPrimitives
TCUDPPResult GLS_CUDA_ParallelPrimitives
TcuDriverGetVersion GLS_CUDA_API
TcuEventCreate GLS_CUDA_API
TcuEventDestroy GLS_CUDA_API
TcuEventElapsedTime GLS_CUDA_API
TcuEventQuery GLS_CUDA_API
TcuEventRecord GLS_CUDA_API
TcuEventSynchronize GLS_CUDA_API
TCUevent_flags GLS_CUDA_API
TcufftCompatibility GLS_CUDA_FourierTransform
TcufftComplex GLS_CUDA_FourierTransform
TcufftDestroy GLS_CUDA_FourierTransform
TcufftDoubleComplex GLS_CUDA_FourierTransform
TcufftDoubleReal GLS_CUDA_FourierTransform
TcufftExecC2C GLS_CUDA_FourierTransform
TcufftExecC2R GLS_CUDA_FourierTransform
TcufftExecD2Z GLS_CUDA_FourierTransform
TcufftExecR2C GLS_CUDA_FourierTransform
TcufftExecZ2D GLS_CUDA_FourierTransform
TcufftExecZ2Z GLS_CUDA_FourierTransform
TcufftHandle GLS_CUDA_FourierTransform
TcufftPlan1d GLS_CUDA_FourierTransform
TcufftPlan2d GLS_CUDA_FourierTransform
TcufftPlan3d GLS_CUDA_FourierTransform
TcufftPlanMany GLS_CUDA_FourierTransform
TcufftReal GLS_CUDA_FourierTransform
TcufftRealfloat GLS_CUDA_FourierTransform
TcufftResult GLS_CUDA_FourierTransform
TcufftSetCompatibilityMode GLS_CUDA_FourierTransform
TcufftSetStream GLS_CUDA_FourierTransform
TcufftType GLS_CUDA_FourierTransform
TCuFilterMode GLSCUDA
TCUfilter_mode GLS_CUDA_API
TcuFuncGetAttribute GLS_CUDA_API
TcuFuncSetBlockShape GLS_CUDA_API
TcuFuncSetSharedSize GLS_CUDA_API
TCUfunction_attribute GLS_CUDA_API
TcuGLCtxCreate GLS_CUDA_API
TcuGLInit GLS_CUDA_API
TcuGLMapBufferObject GLS_CUDA_API
TcuGLMapBufferObjectAsync GLS_CUDA_API
TCUGLmap_flags GLS_CUDA_API
TcuGLRegisterBufferObject GLS_CUDA_API
TcuGLSetBufferObjectMapFlags GLS_CUDA_API
TcuGLUnmapBufferObject GLS_CUDA_API
TcuGLUnmapBufferObjectAsync GLS_CUDA_API
TcuGLUnregisterBufferObject GLS_CUDA_API
TcuGraphicsGLRegisterBuffer GLS_CUDA_API
TcuGraphicsGLRegisterImage GLS_CUDA_API
TCUgraphicsMapResourceFlags GLS_CUDA_API
TcuGraphicsMapResources GLS_CUDA_API
TCUgraphicsRegisterFlags GLS_CUDA_API
TcuGraphicsResourceGetMappedPointer GLS_CUDA_API
TcuGraphicsResourceSetMapFlags GLS_CUDA_API
TcuGraphicsSubResourceGetMappedArray GLS_CUDA_API
TcuGraphicsUnmapResources GLS_CUDA_API
TcuGraphicsUnregisterResource GLS_CUDA_API
TcuInit GLS_CUDA_API
TCUjit_fallback GLS_CUDA_API
TCUjit_option GLS_CUDA_API
TCUjit_target GLS_CUDA_API
TcuLaunch GLS_CUDA_API
TcuLaunchGrid GLS_CUDA_API
TcuLaunchGridAsync GLS_CUDA_API
TCullFaceMode GLState
TCullingMode SpatialPartitioning
TcuMemAlloc GLS_CUDA_API
TcuMemAllocHost GLS_CUDA_API
TcuMemAllocPitch GLS_CUDA_API
TcuMemcpy2D GLS_CUDA_API
TcuMemcpy2DAsync GLS_CUDA_API
TcuMemcpy2DUnaligned GLS_CUDA_API
TcuMemcpy3D GLS_CUDA_API
TcuMemcpy3DAsync GLS_CUDA_API
TcuMemcpyAtoA GLS_CUDA_API
TcuMemcpyAtoD GLS_CUDA_API
TcuMemcpyAtoH GLS_CUDA_API
TcuMemcpyAtoHAsync GLS_CUDA_API
TcuMemcpyDtoA GLS_CUDA_API
TcuMemcpyDtoD GLS_CUDA_API
TcuMemcpyDtoDAsync GLS_CUDA_API
TcuMemcpyDtoH GLS_CUDA_API
TcuMemcpyDtoHAsync GLS_CUDA_API
TcuMemcpyHtoA GLS_CUDA_API
TcuMemcpyHtoAAsync GLS_CUDA_API
TcuMemcpyHtoD GLS_CUDA_API
TcuMemcpyHtoDAsync GLS_CUDA_API
TcuMemFree GLS_CUDA_API
TcuMemFreeHost GLS_CUDA_API
TcuMemGetAddressRange GLS_CUDA_API
TcuMemGetInfo GLS_CUDA_API
TcuMemHostAlloc GLS_CUDA_API
TcuMemHostGetDevicePointer GLS_CUDA_API
TcuMemHostGetFlags GLS_CUDA_API
TCUmemorytype GLS_CUDA_API
TcuMemsetD16 GLS_CUDA_API
TcuMemsetD2D16 GLS_CUDA_API
TcuMemsetD2D32 GLS_CUDA_API
TcuMemsetD2D8 GLS_CUDA_API
TcuMemsetD32 GLS_CUDA_API
TcuMemsetD8 GLS_CUDA_API
TcuModuleGetFunction GLS_CUDA_API
TcuModuleGetGlobal GLS_CUDA_API
TcuModuleGetTexRef GLS_CUDA_API
TcuModuleLoad GLS_CUDA_API
TcuModuleLoadData GLS_CUDA_API
TcuModuleLoadDataEx GLS_CUDA_API
TcuModuleLoadFatBinary GLS_CUDA_API
TcuModuleUnload GLS_CUDA_API
TcuParamSetf GLS_CUDA_API
TcuParamSeti GLS_CUDA_API
TcuParamSetSize GLS_CUDA_API
TcuParamSetTexRef GLS_CUDA_API
TcuParamSetv GLS_CUDA_API
TCUresult GLS_CUDA_API
TcuStreamCreate GLS_CUDA_API
TcuStreamDestroy GLS_CUDA_API
TcuStreamQuery GLS_CUDA_API
TcuStreamSynchronize GLS_CUDA_API
TcuTexRefCreate GLS_CUDA_API
TcuTexRefDestroy GLS_CUDA_API
TcuTexRefGetAddress GLS_CUDA_API
TcuTexRefGetAddressMode GLS_CUDA_API
TcuTexRefGetArray GLS_CUDA_API
TcuTexRefGetFilterMode GLS_CUDA_API
TcuTexRefGetFlags GLS_CUDA_API
TcuTexRefGetFormat GLS_CUDA_API
TcuTexRefSetAddress GLS_CUDA_API
TcuTexRefSetAddress2D GLS_CUDA_API
TcuTexRefSetAddressMode GLS_CUDA_API
TcuTexRefSetArray GLS_CUDA_API
TcuTexRefSetFilterMode GLS_CUDA_API
TcuTexRefSetFlags GLS_CUDA_API
TcuTexRefSetFormat GLS_CUDA_API
TcuWGLGetDevice GLS_CUDA_API
TCylinderAlignment GLGeomObjects
TCylinderPart GLGeomObjects
TCylinderParts GLGeomObjects
Td3Axis ODEImport
TdAABB ODEImport
TdAABBTestFn ODEImport
TdAngularMotorModeNumbers ODEImport
TDataFileCapabilities ApplicationFileIO
TDataFileCapability ApplicationFileIO
TDataFileClass ApplicationFileIO
TDBType3DS Types3DS
TDCECollisionEvent GLDCE
TDCECollisionSelection | GLDCE | Indicates which type of layer comparison is made when trying to detect collisions between 2 bodies (A and B). Possible values are: <ul> <li>ccsDCEStandard: Collides bodies if A.layer <= B.layer <li>ccsCollisionStandard: Collides bodies if either A or B have layer equal to zero or if their layers are different. <li>ccsHybrid: Collides bodies if either one of the previous checks would pass (i.e. if the layer of either body is equal to 0 or if A.layer <= B.layer) *and* if both layers are positive (that is, turns off collision for bodies whose layer is < 0) </ul>
TDCEObjectCollisionEvent GLDCE
TDCEShape GLDCE
TDCESlideOrBounce GLDCE
TdColliderFn ODEImport
TdContactType ODEImport
TDebugProc OpenGLTokens
TDebugProcAMD OpenGLTokens
TDelimiters GLSMemo
TDelphiColor GLCrossPlatform
TDepthFunction GLState
TdErrorType ODEImport
TDeSerializeEvent GLNGDManager
TdGeomDtorFn ODEImport
TdGetAABBFn ODEImport
TdGetColliderFnFn ODEImport
TDim3 GLS_CUDA_API
TdInteger3 ODEImport
TdIntegerArray ODEImport
TDirectRenderEvent | GLScene | Event for user-specific rendering in a TGLDirectOpenGL object.
TDirPlan GeometryBB
TdJointGroupID ODEImport
TdJointID ODEImport
TdJointTypeNumbers ODEImport
TDlInnerRange Types3DS
TDlMultiplier Types3DS
TDlOuterRange Types3DS
TDlRayBias Types3DS
TDlSpotAspect Types3DS
TDlSpotRoll Types3DS
TdMatrix3 ODEImport
TdMatrix3_As3x4 ODEImport
TdMatrix4 ODEImport
TdMatrix6 ODEImport
TdMovedCallback ODEImport
TdNearCallback ODEImport
TDoubleArray Polynomials
TDoubleArrayList VectorLists
TDoubleHmgPlane VectorGeometry
TDoubleVector VectorGeometry
TdQuaternion ODEImport
TDrawState GLRenderContextInfo
TdReal ODEImport
TdRealArray ODEImport
TdRealHugeArray ODEImport
TDstBlendFunction GLState
TdTriArrayCallback ODEImport
TdTriCallback ODEImport
TdTriRayCallback ODEImport
TDumpLevel Types3DS
TdVector3 ODEImport
TdVector3Array ODEImport
TdVector4 ODEImport
TdxJointLimitMotor3 ODEImport
TdxJointNull ODEImport
TdxSimpleSpace ODEImport
TEarthSkydomeOption GLSkydome
TEarthSkydomeOptions GLSkydome
TEaseType AnimationUtils
TECColliderList GLEllipseCollision
TECColliderShape GLEllipseCollision
TECContactList GLEllipseCollision
TECFreeFormList GLEllipseCollision
TECTriMeshList GLEllipseCollision
TEnumCallBack PlugInIntf
TEnumResourceNames PlugInIntf
TEulerOrder VectorGeometry
TExtendedVector VectorGeometry
TExtrusionSolidPart GLExtrusion
TExtrusionSolidParts GLExtrusion
TF4 LWObjects
TF4Array LWObjects
TF4DynArray LWObjects
TFaceCulling GLMaterial
TFaceGroupMeshMode | GLVectorFileObjects | Known descriptions for face group mesh modes.<p> - fgmmTriangles : issue all vertices with GL_TRIANGLES.<br> - fgmmTriangleStrip : issue all vertices with GL_TRIANGLE_STRIP.<br> - fgmmFlatTriangles : same as fgmmTriangles, but take advantage of having the same normal for all vertices of a triangle.<br> - fgmmTriangleFan : issue all vertices with GL_TRIANGLE_FAN.<br> - fgmmQuads : issue all vertices with GL_QUADS.
TFaceList Types3DS
TFaceWinding | GLState | Describe what kind of winding has a front face
TFastCollisionChecker GLCollision
TFColorList Types3DS
TFeedBackMeshLaunching GLSCUDAGraphics
TFeedBackMeshPrimitive GLSCUDAGraphics
TFeedbackMode GLFeedback
TFile LIBPNG
TFilterType3DS Types3DS
TFindCuFileFunc GLSCUDACompiler
TFireParticleArray GLFireFX
TFlareElement GLLensFlare
TFlareElements GLLensFlare
TFloatPercentage Types3DS
TFloatVector VectorGeometry
TFMetaDataCallback fmodtypes
TFModErrors fmodtypes
TFMusicCallback fmodtypes
TFMusicTypes fmodtypes
TFogDistance | GLScene | Fog distance calculation mode.<p> <ul> <li>fdDefault: let OpenGL use its default formula <li>fdEyeRadial: uses radial "true" distance (best quality) <li>fdEyePlane: uses the distance to the projection plane (same as Z-Buffer, faster) </ul>Requires support of GL_NV_fog_distance extension, otherwise, it is ignored.
TFogMode GLScene
TFOURCC DXTC
TFree LIBPNG
TFrustrumPart GLGeomObjects
TFrustrumParts GLGeomObjects
TFSoundAllocCallback fmodtypes
TFSoundCloseCallback fmodtypes
TFSoundDSPCallback fmodtypes
TFSoundFreeCallback fmodtypes
TFSoundFXModes fmodtypes
TFSoundMixerTypes fmodtypes
TFSoundOpenCallback fmodtypes
TFSoundOutputTypes fmodtypes
TFSoundReadCallback fmodtypes
TFSoundReallocCallback fmodtypes
TFSoundSeekCallback fmodtypes
TFSoundSpeakerModes fmodtypes
TFSoundStreamCallback fmodtypes
TFSoundStreamNetStatus fmodtypes
TFSoundTagFieldType fmodtypes
TFSoundTellCallback fmodtypes
TFXPointerList GLParticleFX
TGetDescription PlugInIntf
TGetLineAttrsEvent GLSMemo
TGetServices PlugInIntf
TGetTerrainBoundsEvent GLTerrainRenderer
TGetVendor PlugInIntf
TGetVersion PlugInIntf
TGLABone FileGL2
TGLAcceptMouseQuery GLWindows
TGLACompQuatBone FileGL2
TGLActiveAttribArray GLSLShader
TGLActorOption | GLVectorFileObjects | Miscellanious actor options.<p> <ul> <li>aoSkeletonNormalizeNormals : if set the normals of a skeleton-animated mesh will be normalized, this is not required if no normals-based texture coordinates generation occurs, and thus may be unset to improve performance. </ul>
TGLActorOptions GLVectorFileObjects
TGLActorProxyAnimationMode GLProxyObjects
TGLAdvancedBlurImagePrepareEvent GLBlur
TGlAlphaFunc GLMaterial
TGLAntiAliasing GLContext
TGLASkeletonOffsets FileGL2
TGLAsmShaderEvent GLAsmShader
TGLAsmShaderUnUplyEvent GLAsmShader
TGLAtmosphereBlendingMode GLAtmosphere With aabmOneMinusSrcAlpha atmosphere is transparent to other objects, but has problems, which are best seen when the Atmosphere radius is big.

With bmOneMinusDstColor atmosphere doesn't have these problems, but offers limited transparency (when you look closely on the side).

TGLBaseImageClass GLGraphics
TGLBaseSelectTechniqueClass GLSelection
TGLBehaviourClass GLScene
TGLbitfield OpenGLTokens
TGLBitmap GLCrossPlatform
TGLBitmap32 GLGraphics
TGLBlendingModeEx | GLCustomShader | Adds two more blending modes to standard ones. Not sure how to name them or if they should be included in TBlending mode, so I created a new type here.
TGLBlurkind GLBlur
TGLBlurPreset GLBlur
TGLboolean OpenGLTokens
TGLBufferBindingTarget GLState
TGLbyte OpenGLTokens
TGLCadencerMode | GLCadencer | Determines how the TGLCadencer operates.<p> - cmManual : you must trigger progress manually (in your code)<br> - cmASAP : progress is triggered As Soon As Possible after a previous progress (uses windows messages). - cmApplicationIdle : will hook Application.OnIdle, this will overwrite any previous event handle, and only one cadencer may be in this mode.
TGLCadencerTimeReference | GLCadencer | Determines which time reference the TGLCadencer should use.<p> - cmRTC : the Real Time Clock is used (precise over long periods, but not accurate to the millisecond, may limit your effective framerate to less than 50 FPS on some systems)<br> - cmPerformanceCounter : the windows performance counter is used (nice precision, may derive over long periods, this is the default option as it allows the smoothest animation on fast systems)<br> - cmExternal : the CurrentTime property is used
TGLCall GLPipelineTransformation
TGLCameraInvarianceMode GLScene
TGLCameraJobEvent GLCameraController
TGLCameraKeepFOVMode GLScene
TGLCameraStyle GLScene
TGLCelShaderGetIntensity | GLCelShader | An event for user defined cel intensity.
TGLCelShaderOption | GLCelShader | Cel shading options.<p> csoOutlines: Render a second outline pass. csoTextured: Allows for a primary texture that the cel shading is modulated with and forces the shade definition to render as a second texture.
TGLCelShaderOptions GLCelShader
TGLCgBombShaderTextureSource GLCgBombShader
TGLclampd OpenGLTokens
TGLclampf OpenGLTokens
TGLColorDepth GLScene
TGLConsoleMatchList GLConsole
TGLConsoleOption GLConsole
TGLConsoleOptions GLConsole
TGLContextAcceleration GLContext
TGLContextClass GLContext
TGLContextLayer GLContext
TGLContourClass GLMultiPolygon
TGLCoordinates GLCoordinates
TGLCoordinatesStyle GLCoordinates
TGLCubeMapTarget GLTexture
TGLCustomRenderEvent GLWindows
TGLDDSDetailLevels GLFileDDS
TGLDEBUGPROCARB OpenGLTokens
TGLDepthCompareFunc GLTexture
TGLDepthPrecision GLScene
TGLDepthTextureMode GLTexture
TGLdouble OpenGLTokens
TGLEnabledRenderBuffer GLFBORenderer
TGLEnabledRenderBuffers GLFBORenderer
TGLenum OpenGLTokens
TGLEProjectedParticleMask GLEParticleMasksManager
TGLFBOClearOption GLFBORenderer
TGLFBOClearOptions GLFBORenderer
TGLFBOTargetVisibility GLFBORenderer
TGLFile3DSAnimKeysClassType | GLFile3DS | Used only for serialization. There probably is a more efficient way to do it.
TGLFlatTextOption GLBitmapFont
TGLFlatTextOptions GLBitmapFont
TGLfloat OpenGLTokens
TGLFormCanClose GLWindows
TGLFormCanRequest GLWindows
TGLFormCloseOptions GLWindows
TGLFormMove GLWindows
TGLFormNotify GLWindows
TGLFramebufferStatus GLContext
TGLFullScreenResolution | GLSceneForm | Defines how GLSceneForm will handle fullscreen request fcWindowMaximize: Use current resolution (just maximize form and hide OS bars) fcNearestResolution: Change to nearest valid resolution from current window size fcManualResolution: Use FFullScreenVideoMode settings
TGLGameMenuScale GLGameMenu
TGLGizmoAcceptEvent GLGizmo
TGLGizmoAxis GLGizmo
TGLGizmoElement GLGizmo
TGLGizmoElements GLGizmo
TGLGizmoExAcceptEvent GLGizmoEx
TGLGizmoExAxis GLGizmoEx
TGLGizmoExAxisSelected GLGizmoEx
TGLGizmoExOperation GLGizmoEx
TGLGizmoExOperationMode GLGizmoEx
TGLGizmoExPickMode GLGizmoEx
TGLGizmoExReferenceCoordinateSystem GLGizmoEx
TGLGizmoExSelectionRegion GLGizmoEx
TGLGizmoExSelRec GLGizmoEx
TGLGizmoExVisibleInfoLabel GLGizmoEx
TGLGizmoExVisibleInfoLabels GLGizmoEx
TGLGizmoOperation GLGizmo
TGLGizmoPickMode GLGizmo
TGLGizmoUpdateEvent GLGizmo
TGLGizmoVisibleInfoLabel GLGizmo
TGLGizmoVisibleInfoLabels GLGizmo
TGLGraphic GLCrossPlatform
TGLgsInTypes GLSLParameter
TGLgsOutTypes GLSLParameter
TGLGuiComponentName GLGui
TGLGuiElementName GLGui
TGLImageLODRange GLGraphics
TGLImagePiramid GLGraphics
TGLint OpenGLTokens
TGLint64 OpenGLTokens
TGLint64EXT OpenGLTokens
TGLInternalCompression | GLTextureFormat | Texture compression option.<p> If OpenGL supports it, this will activate a compressed texture format:<ul> <li>tcDefault : uses global default compression option <li>tcNone : do not use compression <li>tcStandard : use standard compression, average quality, average rate <li>tcHighQuality : choose a high-quality, low-speed compression <li>tcHighSpeed : choose a high-speed, low-quality compression </ul>.
TGLInternalFormat GLTextureFormat
TGLInterpolationType VectorGeometry
TGLintptr OpenGLTokens
TGLKeyEvent GLCrossPlatform
TGLKeyPressEvent GLCrossPlatform
TGLlConsoleEvent | GLConsole | Event called when used presses the "Enter"
TGLLibMaterialName GLMaterial
TGLLightSourceEnum GLCustomShader
TGLLightSourceSet GLCustomShader
TGLLODStreamingState GLGraphics
TGLMagFilter GLTexture
TGLMapCollectionItemClass GLFPSMovement
TGLMaterialComponentName GLMaterialEx
TGLMaterialLevel GLState
TGLMatrix2DArray GLTypes
TGLMatrix2DType GLTypes
TGLMatrix3DArray GLTypes
TGLMatrix3DType GLTypes
TGLMesh2D GLTypes
TGLMesh3D GLTypes
TGLMeshPrimitive GLState
TGLMeshPrimitives GLState
TGLMinFilter GLTexture
TGLMLODSurfaceOffsets FileGL2
TGLMouseAction GLWindows
TGLMouseButton GLCrossPlatform
TGLMouseEvent GLCrossPlatform
TGLMouseMoveEvent GLCrossPlatform
TGLMovementRotationMode GLMovement
TGLMSurfaceHeirachyOffsets FileGL2
TGLNavigatorSmoothChangeItemClass GLSmoothNavigator
TGLNavigatorSmoothChangeSingleGetEvent GLSmoothNavigator
TGLNavigatorSmoothChangeSingleSetEvent GLSmoothNavigator
TGLNavigatorSmoothChangeVectorGetEvent GLSmoothNavigator
TGLNavigatorSmoothChangeVectorSetEvent GLSmoothNavigator
TGLNodesClass GLNodes
TGLObjectEffectClass GLScene
TGLObjectsSorting | GLRenderContextInfo | Determines if objects are sorted, and how.<p> Sorting is done level by level (and not for all entities), values are :<ul> <li>osInherited : use inherited sorting mode, defaults to osRenderFarthestFirst <li>osNone : do not sort objects. <li>osRenderFarthestFirst : render objects whose Position is the farthest from the camera first. <li>osRenderBlendedLast : opaque objects are not sorted and rendered first, blended ones are rendered afterwards and depth sorted. <li>osRenderNearestFirst : render objects whose Position is the nearest to the camera first. </ul>
TGLObjectStyle | GLScene | Possible styles/options for a GLScene object.<p> Allowed styles are:<ul> <li>osDirectDraw : object shall not make use of compiled call lists, but issue direct calls each time a render should be performed. <li>osIgnoreDepthBuffer : object is rendered with depth test disabled, this is true for its children too. <li>osNoVisibilityCulling : whatever the VisibilityCulling setting, it will be ignored and the object rendered </ul>
TGLObjectStyles GLScene
TGLOnCustomPostEffectEvent GLPostEffects
TGLParticleArray GLParticleFX
TGLParticleClass GLParticleFX
TGLParticleEvent GLParticles
TGLPerlinInterpolation GLPerlin
TGLPerlinOctav GLPerlin
TGLPicture GLCrossPlatform
TGLPipelineTransformationState GLPipelineTransformation
TGLPipelineTransformationStates GLPipelineTransformation
TGLPixel32Array GLGraphics
TGLPoint GLCrossPlatform
TGLPoint2DArray GLTypes
TGLPoint3DArray GLTypes
TGLPointStyle GLObjects
TGLPolygon2D GLTypes
TGLPolygon3D GLTypes
TGLPolyhedron GLTypes
TGLPopupMenuClick GLWindows
TGLPostEffectBuffer GLPostEffects
TGLPostEffectPreset | GLPostEffects | Some presets for TGLPostEffect: pepNone - does nothing. pepGray - makes picture gray. pepNegative - inverts all colors. pepDistort - simulates shaky TV image. pepNoise - just adds random niose. pepNightVision - simulates nightvision goggles. pepBlur - blurs the scene. pepCustom - calls the OnCustomEffect event.
TGLProgressEvent | BaseClasses | Progression event for time-base animations/simulations.<p> deltaTime is the time delta since last progress and newTime is the new time after the progress event is completed.
TGLProjectedTexturesStyle | GLProjectedTextures | Possible styles of texture projection. Possible values:<ul> <li>ptsOriginal: Original projection method (first pass, is default scene render, second pass is texture projection). <li>ptsInverse: Inverse projection method (first pass is texture projection, sencond pass is regular scene render). This method is useful if you want to simulate lighting only through projected textures (the textures of the scene are "masked" into the white areas of the projection textures). </ul>
TGLProxyObjectClass GLScene
TGLProxyObjectOption | GLScene | Defines which features are taken from the master object.
TGLProxyObjectOptions GLScene
TGLRCOption GLContext
TGLRCOptions GLContext
TGLRect GLCrossPlatform
TGLResourceType GLSCUDA
TGLSApplicationResource ApplicationFileIO
TGLSceneObjectClass GLScene
TGLSceneViewer GLViewer
TGLSceneViewerMode GLScene
TGLScreenDepth GLFullScreenViewer
TGLScriptState GLScriptBase
TGLSCUDACompilerOutput GLSCUDACompiler
TGLSCUDARealArch | GLSCUDACompiler | sm_10 ISA_1 Basic features sm_11 + atomic memory operations on global memory sm_12 + atomic memory operations on shared memory + vote instructions sm_13 + double precision floating point support sm_20 + FERMI support. sm_21 + Unknown
TGLSCUDARealArchs GLSCUDACompiler
TGLSCUDAVirtArch | GLSCUDACompiler | compute_10 Basic features compute_11 + atomic memory operations on global memory compute_12 + atomic memory operations on shared memory + vote instructions compute_13 + double precision floating point support Compute_20 + FERMI support
TGLSeparateTextureWrap GLTextureFormat
TGLShadeModel GLScene
TGLShaderClass GLMaterial
TGLShaderCombinerType GLShaderCombiner MP - multipass, SP-singlepass, AP - anypass (single or multi) One-Two or Two-One determines the order of how the shaders should be applied For example, sctTwoMPOneSP means that first one will be applied Shader Two, which can be a multipass shader, then Shader One is applied, which should be a singlepass shader.

sctOneMPTwoSP and sctTwoMPOneSP modes are actualy quite Str@nge, because... well look at the code yourself

TODO: Add more modes here, including sctOneAPTwoAP, which should be the default one.

By the way, I admit - the names do look stupid, and if someone gives them proper names, I will be only glad.

TGLShaderEvent GLCustomShader
TGLShaderFailedInitAction | GLMaterial | Defines what to do if for some reason shader failed to initialize.<ul> <li>fiaSilentdisable: just disable it <li>fiaRaiseHandledException: raise an exception, and handle it right away (usefull, when debigging within Delphi) <li>fiaRaiseStardardException: raises the exception with a string from this function GetStardardNotSupportedMessage <li>fiaReRaiseException: Re-raises the exception <li>fiaGenerateEvent: Handles the exception, but generates an event that user can respond to. For example, he can try to compile a substitude shader, or replace it by a material. Note: HandleFailedInitialization does *not* create this event, it is left to user shaders which may chose to override this procedure. Commented out, because not sure if this option should exist, let other generations of developers decide ;) </ul>
TGLShaderFogSupport GLCustomShader
TGLShaderHandleClass GLContext
TGLShaderStyle | GLMaterial | Define GLShader style application relatively to a material.<ul> <li>ssHighLevel: shader is applied before material application, and unapplied after material unapplication <li>ssLowLevel: shader is applied after material application, and unapplied before material unapplication <li>ssReplace: shader is applied in place of the material (and material is completely ignored) </ul>
TGLShaderType GLMaterialEx
TGLShaderUnAplyEvent GLCustomShader
TGLShadowCastingMode | GLShadowVolume | Determines when a caster should actually produce a shadow; <ul> <li>scmAlways : Caster always produces a shadow, ignoring visibility <li>scmVisible : Caster casts shadow if the object has visible=true <li>scmRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true <li>scmParentVisible : Caster produces shadow if parent has visible=true <li>scmParentRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true, starting from the parent (ignoring own visible setting) </ul>
TGLShadowVolumeCapping | GLShadowVolume | Determines when a shadow volume should generate a cap at the beginning and end of the volume. This is ONLY necessary when there's a chance that the camera could end up inside the shadow _or_ between the light source and the camera. If those two situations can't occur then not using capping is the best option.<br> Note that if you use the capping, you must either set the depth of view of your camera to something very large (f.i. 1e9), or you could use the infinite mode (csInfinitePerspective) of your camera. <ul> <li>svcDefault : Default behaviour <li>svcAlways : Always generates caps <li>svcNever : Never generates caps </ul>
TGLShadowVolumeMode | GLShadowVolume | Shadow rendering modes.<p> <ul> <li>svmAccurate : will render the scene with ambient lighting only, then for each light will make a diffuse+specular pass <li>svmDarkening : renders the scene with lighting on as usual, then darkens shadowed areas (i.e. inaccurate lighting, but will "shadow" objects that don't honour to diffuse or specular lighting) <li>svmOff : no shadowing will take place </ul>
TGLShadowVolumeOption | GLShadowVolume | Shadow volume rendering options/optimizations.<p> <ul> <li>svoShowVolumes : make the shadow volumes visible <li>svoDesignVisible : the shadow are visible at design-time <li>svoCacheSilhouettes : cache shadow volume silhouettes, beneficial when some objects are static relatively to their light(s) <li>svoScissorClips : use scissor clipping per light, beneficial when lights are attenuated and don't illuminate the whole scene <li>svoWorldScissorClip : use scissor clipping for the world, beneficial when shadow receivers don't cover the whole viewer surface </ul>
TGLShadowVolumeOptions GLShadowVolume
TGLshort OpenGLTokens
TGLSilhouetteStyle GLSilhouette
TGLSimpleNavigationAction GLSimpleNavigation
TGLSimpleNavigationOption GLSimpleNavigation
TGLSimpleNavigationOptions GLSimpleNavigation
TGLsizei OpenGLTokens
TGLsizeiptr OpenGLTokens
TGLSkyBoxStyle GLSkyBox
TGLSLDataType GLSLParameter
TGLSLProjectedTexturesStyle GLSLProjectedTextures
TGLSLSamplerType GLSLParameter
TGLSLShaderEvent GLSLShader
TGLSLShaderEventEx GLSLShader
TGLSLShaderUnApplyEvent GLSLShader
TGLSoundEnvironment | GLSound | EAX standard sound environments.
TGLSoundFileClass GLSoundFileObjects
TGLSoundSourceChange GLSound
TGLSoundSourceChanges GLSound
TGLSourcePFXDispersionMode GLParticleFX
TGLSourcePFXPositionMode GLParticleFX
TGLSourcePFXVelocityMode GLParticleFX
TGLSResourceStream ApplicationFileIO
TGLState | GLState | Reflects all relevant (binary) states of OpenGL subsystem
TGLStates GLState
TGLStateType GLState
TGLStateTypes GLState
TGLStencilPrecision GLFBO
TGLString OpenGLTokens
TGLsync OpenGLTokens
TGLTextHorzAdjust GLSpaceText
TGLTextLayout GLCrossPlatform
TGLTextureChange GLTexture
TGLTextureChanges GLTexture
TGLTextureCompareMode GLTextureFormat
TGLTextureCompression GLTexture
TGLTextureFilteringQuality GLTextureFormat
TGLTextureFormat | GLTexture | Texture format for OpenGL (rendering) use.<p> Internally, GLScene handles all "base" images as 32 Bits RGBA, but you can specify a generic format to reduce OpenGL texture memory use:<ul>
TGLTextureImageAlpha | GLTexture | Defines how and if Alpha channel is defined for a texture image.<ul> <li>tiaDefault : uses the alpha channel in the image if any <li>tiaAlphaFromIntensity : the alpha channel value is deduced from other RGB components intensity (the brighter, the more opaque) <li>tiaSuperBlackTransparent : pixels with a RGB color of (0, 0, 0) are completely transparent, others are completely opaque <li>tiaLuminance : the luminance value is calculated for each pixel and used for RGB and Alpha values <li>tiaLuminanceSqrt : same as tiaLuminance but with an Sqrt(Luminance) <li>tiaOpaque : alpha channel is uniformously set to 1.0 <li>tiaTopLeftPointColorTransparent : points of the same color as the top left point of the bitmap are transparent, others are opaque. </ul>
TGLTextureImageClass GLTexture
TGLTextureImageEditorClass GLTextureImageEditors
TGLTextureMappingMode GLTexture
TGLTextureMode GLTexture
TGLTextureSwizzle GLTextureFormat
TGLTextureTarget GLTextureFormat
TGLTextureWrap GLTexture
TGLTextVertAdjust GLSpaceText
TGLTransformFeedBackMode GLCustomShader
TGLubyte OpenGLTokens
TGLuint OpenGLTokens
TGLuint64 OpenGLTokens
TGLuint64EXT OpenGLTokens
TGLUNurbsErrorProc OpenGLTokens
TGLUNurbsObj OpenGLTokens
TGLUQuadricErrorProc OpenGLTokens
TGLUQuadricObj OpenGLTokens
TGLushort OpenGLTokens
TGLUTessBeginDataProc OpenGLTokens
TGLUTessBeginProc OpenGLTokens
TGLUTessCombineDataProc OpenGLTokens
TGLUTessCombineProc OpenGLTokens
TGLUTessEdgeFlagDataProc OpenGLTokens
TGLUTessEdgeFlagProc OpenGLTokens
TGLUTesselatorObj OpenGLTokens
TGLUTessEndDataProc OpenGLTokens
TGLUTessEndProc OpenGLTokens
TGLUTessErrorDataProc OpenGLTokens
TGLUTessErrorProc OpenGLTokens
TGLUTessVertexDataProc OpenGLTokens
TGLUTessVertexProc OpenGLTokens
TGLUTriangulatorObj OpenGLTokens
TGLvdpauSurfaceNV OpenGLTokens
TGLVector2DType GLTypes
TGLVector3DType GLTypes
TGLVirtualHandleEvent GLContext
TGLVisibilityCulling | GLRenderContextInfo | Determines the visibility culling mode. Culling is done level by level, allowed values are:<ul> <li>vcInherited : use inherited culling value, if selected for the root level, defaults to vcNone <li>vcNone : no visibility culling is performed <li>vcObjectBased : culling is done on a per-object basis, each object may or may not be culled base on its own AxisAlignedDimensions, culling has no impact on the visibility of its children <li>vcHierarchical : culling is performed hierarchically, using hierarchical bounding boxes, if a parent is culled, all of its children, whatever their culling options are invisible. <li><br>Depending on the structure of your scene the most efficient culling method will be either vcObjectBased or vcHierarchical. Also note that if you use many objects with "static" geometry and have a T&amp;L graphics board, it may be faster not to cull at all (ie. leave this to the hardware).
TGLVisibilityDeterminationEvent GLObjects
TGLWaterPlaneOption GLWaterPlane
TGLWaterPlaneOptions GLWaterPlane
TGraphicClass GLCrossPlatform
TGrowMethod SpatialPartitioning
TGUIAlignments GLGui
TGUIDrawResult GLGui
TGutterClickEvent GLSMemo
TGutterDrawEvent GLSMemo
THalfFloat GLCrossPlatform
THDTextureCoordinatesMode GLHeightData
THeightDataClass GLHeightData
THeightDataPostRenderEvent GLTerrainRenderer
THeightDataState GLHeightData
THeightDataType GLHeightData
THeightFieldColorMode GLGraph
THeightFieldGetHeight2Event GLGraph
THeightFieldGetHeightEvent GLGraph
THeightFieldOption GLGraph
THeightFieldOptions GLGraph
THintType GLState
THiShadowBias Types3DS
THmgPlane | VectorGeometry | A plane equation.<p> Defined by its equation A.x+B.y+C.z+D<p>, a plane can be mapped to the homogeneous space coordinates, and this is what we are doing here.<br> The typename is just here for easing up data manipulation.
THomogeneousByteMatrix VectorGeometry
THomogeneousByteVector VectorGeometry
THomogeneousDblMatrix VectorGeometry
THomogeneousDblVector VectorGeometry
THomogeneousExtMatrix VectorGeometry
THomogeneousExtVector VectorGeometry
THomogeneousFltMatrix VectorGeometry
THomogeneousFltVector VectorGeometry
THomogeneousIntMatrix VectorGeometry
THomogeneousIntVector VectorGeometry
THomogeneousMatrix VectorGeometry
THomogeneousPtrVector VectorGeometry
THomogeneousVector VectorGeometry
THomogeneousWordMatrix VectorGeometry
THomogeneousWordVector VectorGeometry
TI1 LWObjects
TI2 LWObjects
TI4 LWObjects
TICCompressProc GLSVfw
TICStatusProc GLSVfw
TID4 LWObjects
TID4DynArray LWObjects
TIDELogProc GLSLog
TIdleEvent GLAsyncHDS
TImageAlphaProc ImageUtils
TImageFilterFunction ImageUtils
time_t LIBPNG
TImposterLoadedEvent GLImposter
TImposterOption | GLImposter | Imposter rendering options.<p> Following options are supported:<ul> <li>impoBlended : the imposters are transparently blended during renders, this will smooth their edges but requires them to be rendered sorted from back to front <li>impoAlphaTest : alpha test is used to eliminate transparent pixels, the alpha treshold is adjusted by the AlphaTreshold property <li>impoNearestFiltering : use nearest texture filtering (the alternative is linear filtering) <li>impoPerspectiveCorrection : activates a special imposter rendering projection suitable for distorting the sprites when seen from a level angle of view with a wide focal camera (think trees/grass when walking in a forest), if not active, the imposter sprites are camera-facing </ul>
TImposterOptions GLImposter
TImposterReference GLImposter
TIndexList TypesMD2
TInfoLabelCoordType GLGizmoEx
TInFunc LIBPNG
TIntegerArray HeightTileFile
TIntegerArray Types3DS
TIntegerVector VectorGeometry
TIntermediateFormatArray ImageUtils
TIntPercentage Types3DS
TInvokeInfoForm GLScene
TJointFlag ODEImport
TJointOption GLODEManager
TJointOptions GLODEManager
TJointParams ODEImport
TJoyAxis Joystick
TJoyPos Joystick
TJoystickButton Joystick
TJoystickButtons Joystick
TJoystickDesignMode Joystick
TJoystickEvent Joystick
TJoystickID Joystick
TJPEGPixelFormat GLSJPG
TJPGColorDepth GLSJPG
TKeyHeaderList Types3DS
TKeyStateArr GLSDL
TKFCurtime Types3DS
TKFId Types3DS
TKFMorphKey3DS Types3DS
TKFMorphKeyList Types3DS
TKFRotKeyList Types3DS
TLanguageEntryArray GLSLanguage
TLayerFogFalloff3DS Types3DS
TLightDir2TexEnvColor GLMaterialEx
TLightStyle | GLScene | Defines the various styles for lightsources.<p> <ul> <li>lsSpot : a spot light, oriented and with a cutoff zone (note that if cutoff is 180, the spot is rendered as an omni source) <li>lsOmni : an omnidirectionnal source, punctual and sending light in all directions uniformously <li>lsParallel : a parallel light, oriented as the light source is (this type of light can help speed up rendering) </ul>
TLimitType GLScene
TLinColor24 Types3DS
TLinColorF Types3DS
TLineNodesAspect GLObjects
TLinesOption GLObjects
TLinesOptions GLObjects
TLineSplineMode GLObjects
TLoadingImposterEvent GLImposter
TLoadProgress File3DS
TLogBufferingMode | GLSLog | How log is buffered.
TLogicOp GLState
TLogLevel GLSLog
TLogLevels GLSLog
TLogMessageLimitAction | GLSLog | What to do when number of messages exceeds message limit.
TLogTimeFormat GLSLog
TLongWordVector VectorGeometry
TLoShadowBias Types3DS
TLWChunkClass LWObjects
TLWChunkFind LWObjects
TLWContentNotify LWObjects
TLWOReadCallback LWObjects
TLWPntsInfoDynArray LWObjects
TLWPolsDynArray LWObjects
TLWPolsInfoDynArray LWObjects
TLWPolyTagMapDynArray LWObjects
TLWVertexMapDynArray LWObjects
TM3dVersion Types3DS
TMapTexCoordMode XOpenGL
TMarkDirtyEvent GLHeightData
TMarkStyle GLTrail
TMasterScale Types3DS
TMatBumpPercent Types3DS
TMaterialOption | GLMaterial | Control special rendering options for a material.<p> moIgnoreFog : fog is deactivated when the material is rendered
TMaterialOptions GLMaterial
TMatMapAng Types3DS
TMatMapBCol Types3DS
TMatMapCol1 Types3DS
TMatMapCol2 Types3DS
TMatMapGCol Types3DS
TMatMapRCol Types3DS
TMatMapTexblur Types3DS
TMatMapTiling Types3DS
TMatMapUOffset Types3DS
TMatMapUScale Types3DS
TMatMapVOffset Types3DS
TMatMapVScale Types3DS
TMatrix VectorGeometry
TMatrixArray VectorGeometry
TMatShading Types3DS
TMatWireSize Types3DS
TMaxCLODTrianglesReachedEvent GLTerrainRenderer
TMDCAngle TypesMDC
TMDCBaseVertex TypesMDC
TMDCCompVertex TypesMDC
TMDCPoint TypesMDC
TMDCTexCoord TypesMDC
TMDCTriangle TypesMDC
TMeshAutoCentering GLVectorFileObjects
TMeshAutoCenterings GLVectorFileObjects
TMeshColor Types3DS
TMeshMatrix Types3DS
TMeshMode GLMesh
TMeshNormalsOrientation | GLVectorFileObjects | Determines how normals orientation is defined in a mesh.<p> - mnoDefault : uses default orientation<br> - mnoInvert : inverse of default orientation<br> - mnoAutoSolid : autocalculate to make the mesh globally solid<br> - mnoAutoHollow : autocalculate to make the mesh globally hollow<br>
TMeshObjectListClass GLVectorFileObjects
TMeshObjectMode GLVectorFileObjects
TMeshObjectRenderingOption | GLVectorFileObjects | Rendering options per TMeshObject.<p> <ul> <li>moroGroupByMaterial : if set, the facegroups will be rendered by material in batchs, this will optimize rendering by reducing material switches, but also implies that facegroups will not be rendered in the order they are in the list. </ul>
TMeshObjectRenderingOptions GLVectorFileObjects
TMeshOptimizerOption GLMeshOptimizer
TMeshOptimizerOptions GLMeshOptimizer
TMeshVersion Types3DS
TMipmapGenerationMode GLMaterialEx
TMirrorOption GLMirror
TMirrorOptions GLMirror
TMirrorShapes GLMirror
TModuleHandle GLSModuleLoader
TMorphSmooth Types3DS
TMS3DJointArray TypesMS3D
TMS3DKeyframePositionArray TypesMS3D
TMS3DKeyframeRotationArray TypesMS3D
TMS3DTriangleArray TypesMS3D
TMS3DVertexArray TypesMS3D
TMshBoxmap Types3DS
TNDirectLight Types3DS
TNewTilePreparedEvent GLAsyncHDS
TNewTilePreparedEvent GLShadowHDS
TNewTilePreparedEvent GLBumpmapHDS
TNGDFrictionModels GLNGDManager
TNGDManagerDebug GLNGDManager
TNGDManagerDebugs GLNGDManager
TNGDNewtonCollisions GLNGDManager
TNGDNewtonJoints GLNGDManager
TNGDPickedActions GLNGDManager
TNGDSolverModels GLNGDManager
TNormalDirection GLScene
TNormalMapSpace BumpMapping
TNormalSmoothing GLObjects
TObjectBBChange GLScene
TObjectBBChanges GLScene
TObjectChange GLScene
TObjectChanges GLScene
TObjectCollisionEvent GLCollision
TObjectListSortCompare PersistentClasses
TObjMatList Types3DS
TOConsts Types3DS
TODECollisionEvent GLODEManager
TODECollisionSurfaceMode GLODEManager
TODECustomCollisionEvent GLODEManager
TODEElementClass GLODEManager
TODEGetParamCallback GLODEManager
TODEObjectCollisionEvent GLODEManager
TODESetParamCallback GLODEManager
TODESolverMethod GLODEManager
TOnAsmProgSetting GLMaterialEx
TOnBeforeKernelLaunch GLSCUDAGraphics
TOnCustomPerspective GLScene
TOnDoApplyEvent GLUserShader
TOnDoUnApplyEvent GLUserShader
TOnHeightDataDirtyEvent GLHeightData
TOnLightsChanged GLState
TOnMatricesPush GLPipelineTransformation
TOnOpenGLInteropInit GLSCUDAContext
TOnPrepareHandleData GLContext
TOnUniformInitialize GLMaterialEx
TOnUniformSetting GLMaterialEx
TOptimise GLzBuffer
TOutFunc LIBPNG
TPackedRotationMatrix VectorGeometry
TParametricSurfaceBasis | GLParametricSurfaces | psbBezier indicates building the surface with Bernstein basis functions, no knot or order properties are used. psbBSpline indicates building the surface using BSpline basis functions, these require orders and knot vectors to define the control point influences on the surface.
TParametricSurfaceRenderer | GLParametricSurfaces | psrGLScene tells the surface to render using GLScene code to build the mesh, whereas, psrOpenGL uses glEvalMesh2 or gluNurbsRenderer calls to render the surface.
TParticleReferenceArray GLParticleFX
TPatchPostRenderEvent GLTerrainRenderer
TPathTravelStartEvent GLMovement
TPathTravelStopEvent GLMovement
TPersistentObjectClass PersistentClasses
TPFXCreateParticleEvent GLParticleFX
TPFXDirectRenderEvent GLParticleFX
TPFXGetParticleCountEvent GLParticleFX
TPFXParticleProgress GLParticleFX
TPFXPrepareTextureImageEvent GLParticleFX
TPFXProgressEvent GLParticleFX
TPFXSortAccuracy GLParticleFX
TPickSortType GLSelection
TPickSubObjects GLSelection
TPipeNodesColorMode GLExtrusion
TPipeNormalMode GLExtrusion
TPipePart GLExtrusion
TPipeParts GLExtrusion
TPipeTexCoordMode GLExtrusion
TPIServices PlugInIntf
TPIServiceType PlugInIntf
TPivot Types3DS
TPlanBB GeometryBB
TPlaneStyle GLObjects
TPlaneStyles GLObjects
TPlanIndices GeometryBB
TPlatformVersion GLCrossPlatform
TPoint GLCrossPlatform
TPoint GLSimpleNavigation
TPointerArray ImageUtils
TPointerObjectList PersistentClasses
TPointerVector VectorGeometry
TPointList Types3DS
TPolygonMode GLState
TPolygonPart GLGeomObjects
TPolygonParts GLGeomObjects
TPrecisionSetting GLCgShader
TProcAffineAffineAffine Octree
TProcInt Octree
TProjectTargetNameFunc GLCrossPlatform
TQuaternionArray VectorGeometry
TQueryType GLState
TRayBias Types3DS
TRead GLSDL
TRect GLCrossPlatform
TReleaseLevel Types3DS
TResolution GLScreen
TRevolutionSolidPart GLExtrusion
TRevolutionSolidParts GLExtrusion
TRGBColor GLColor
TRGBPixelBuffer GLBlur
TsbState GLSMemo
TSceneOperation GLScene
TScreenSaverOption | ScreenSaver | Options d'automatisation du screen-saver.<p> <ul> <li>ssoAutoAdjustFormProperties : all relevant properties of main form will be auto-adjusted (form style, border style, form size and for preview, ParentWindow). <li>ssoAutoHookKeyboardEvents : hooks to main form's OnKeyPress and closes screen saver when a key is pressed (form's KeyPreview is also set to True) <li>ssoAutoHookMouseEvents : hooks to main form's OnMouseMove and closes screen saver when mouse is moved (you mays have to handle other mouse move events manually if you have placed components on the form) <li>ssoEnhancedMouseMoveDetection : gets the mouse position every half-second and closes the saver if position changed (uses GetCursorPos and a TTimer) </ul>
TScreenSaverOptions ScreenSaver
TScreenSaverPreviewEvent | ScreenSaver | This event is fired when screen saver should start in preview mode.<p> The passed hwnd is that of the small preview window in Windows Display Properties (or any other screen-saver previewing utility, so don't assume width/height is constant/universal or whatever).
TScrollMode GLSMemo
TSDLEvent GLSDLWindow
TSDLKey GLSDL
TSDLMod GLSDL
TSDLWindowOption GLSDLWindow
TSDLWindowOptions GLSDLWindow
TSDLWindowPixelDepth GLSDLWindow
TSDL_AudioCVTFilterArray GLSDL
TSDL_Audiostatus GLSDL
TSDL_Blit GLSDL
TSDL_Bool GLSDL
TSDL_CDStatus GLSDL
TSDL_ColorArray GLSDL
TSDL_errorcode GLSDL
TSDL_EventAction GLSDL
TSDL_EventFilter GLSDL
TSDL_GLAttr GLSDL
TSDL_GrabMode GLSDL
TSDL_NewTimerCallback GLSDL
TSDL_Sem GLSDL
TSDL_TimerCallback GLSDL
TSectorNodeArray SpatialPartitioning
TSeek GLSDL
TSerializeEvent GLNGDManager
TServiceContextTaskList GLContext
TSetSubItemsEvent GLSceneEditLCL
TSetSubItemsEvent GLSceneEdit
TSetTransformEvent GLNGDManager
TShadeType3DS Types3DS
TShadowFilter Types3DS
TShadowMapSize Types3DS
TShadowPlaneOption GLShadowPlane
TShadowPlaneOptions GLShadowPlane
TShadowRange Types3DS
TShadowSamples Types3DS
TShadowStyle3DS Types3DS
TShininess GLMaterial
TShortIntArray HeightTileFile
TSIBLigthing GLImposter
TSimpleNavigationCustomActionEvent GLSimpleNavigation
TSingleArray VectorGeometry
TSingleArrayList VectorLists
TSingleList Types3DS
TSingleRaster GLHeightData
TSize_T GLS_CL_Platform
TSkeletonFrameTransform GLVectorFileObjects
TSkyDomeOption GLSkydome
TSkyDomeOptions GLSkydome
TSmallIntArray HeightTileFile
TSmallintArray GLHeightData
TSmallIntRaster GLHeightData
TSolidBgnd3DS Types3DS
TSourceDataFetchedEvent GLHeightData
TSpaceContains GeometryBB
TSpaceTextCharRange GLSpaceText
TSpecularMode GLBumpShader
TSpriteAnimationMode | GLAnimatedSprite | Sets the current animation playback mode: <ul> <li>samNone - No playback, the animation does not progress. <li>samPlayOnce - Plays the animation once then switches to samNone. <li>samLoop - Play the animation forward in a continuous loop. <li>samLoopBackward - Same as samLoop but reversed direction. <li>samBounceForward - Plays forward and switches to samBounceBackward when EndFrame is reached. <li>samBounceBackward - Plays backward and switches to samBounceForward when StartFrame is reached. </ul>.
TSpriteColorMode | GLParticleFX | Sprite color modes.<p> <ul> <li>scmFade: vertex coloring is used to fade inner-outer <li>scmInner: vertex coloring uses inner color only <li>scmOuter: vertex coloring uses outer color only <li>scmNone: vertex coloring is NOT used (colors are ignored). </ul>
TSpriteFrameDimensions | GLAnimatedSprite | Determines if the texture coordinates are Automatically generated from the Animations properties or if they are Manually set through the Frames collection.
TSpritesPerTexture | GLParticleFX | Sprites per sprite texture for the SpritePFX.
TSqrt255Array GLUtils
TStartPreparingDataEvent GLHeightData
TStencilFunction GLState
TStencilOp GLState
TSTLVertex TypesSTL
TStreamPos GLSZLibEx
TSubdivideEdgeEvent MeshUtils
TSurfaceModes GLODEManager
TSwizzleVector GLTextureFormat
TSYS_ThreadHandle GLSDL
TTargetType3DS Types3DS
TTaskProcedure GLContext
TTerrainHighResStyle GLTerrainRenderer
TTerrainOcclusionTesselate GLTerrainRenderer
TTexPointArray VectorGeometry
TTextureNeededEvent GLTexture
TTexVertList Types3DS
TThorpointArray GLThorFX
TThreadBmp32 GLShadowHDS
TTileManagementFlag GLTerrainRenderer
TTileManagementFlags GLTerrainRenderer
TTileType3DS Types3DS
TTimeEventProc GLTimeEventsMgr
TTimeEventType GLTimeEventsMgr
TTintType3DS Types3DS
TTokenType GLSMemo
TTorusPart GLGeomObjects
TTorusParts GLGeomObjects
TTouchEvent GLWin32Viewer
TTransformations VectorGeometry
TTransType VectorGeometry
TU1 LWObjects
TU1DynArray LWObjects
TU2 LWObjects
TU2Array LWObjects
TU2DynArray LWObjects
TU4 LWObjects
TU48BitBlock ImageUtils
TU4Array LWObjects
TU4DynArray LWObjects
TUInt8Array GLSDL
TUndoChangeEvent GLSMemo
TUniformAutoSetMethod GLSLParameter
TUpdateSpacePartion VerletClasses
TUseDirtyTiles GLAsyncHDS TUseDirtyTiles determines if/how dirty tiles are displayed and when they are released. <ul> <li>TUseDirtyTiles <li> <li> When a tile is maked as dirty, a replacement is queued immediately. <li> However, the replacement cant be used until the HDThread has finished preparing it. <li> Dirty tiles can be deleted as soon as they are no longer used/displayed.

Possible states for a TUseDirtyTiles.<p> <li>hdsNever : Dirty tiles get released immediately, leaving a hole in the terrain, until the replacement is hdsReady. <li>hdsUntilReplaced : Dirty tiles are used, until the HDThread has finished preparing the queued replacement. <li>hdsUntilAllReplaced : Waits until the HDSThread has finished preparing ALL queued tiles, <li> before allowing the renderer to switch over to the new set of tiles. <li> (This prevents a fading checkerbox effect.) </ul>

TVBOBuffer GLVectorFileObjects
TVBOBuffers GLVectorFileObjects
TVCHeightFieldOnNeedHeight VerletClasses
TVdpBitmapSurface GLS_VDPAU_API
TVdpBitmapSurfaceCreate GLS_VDPAU_API
TVdpBitmapSurfaceDestroy GLS_VDPAU_API
TVdpBitmapSurfaceGetParameters GLS_VDPAU_API
TVdpBitmapSurfacePutBitsNative GLS_VDPAU_API
TVdpBitmapSurfaceQueryCapabilities GLS_VDPAU_API
TVdpBool GLS_VDPAU_API
TVdpChromaType GLS_VDPAU_API
TVdpColorStandard GLS_VDPAU_API
TVdpColorTableFormat GLS_VDPAU_API
TVdpCSCMatrix GLS_VDPAU_API
TVdpDecoder GLS_VDPAU_API
TVdpDecoderCreate GLS_VDPAU_API
TVdpDecoderDestroy GLS_VDPAU_API
TVdpDecoderGetParameters GLS_VDPAU_API
TVdpDecoderProfile GLS_VDPAU_API
TVdpDecoderQueryCapabilities GLS_VDPAU_API
TVdpDecoderRender GLS_VDPAU_API
TVdpDevice GLS_VDPAU_API
TVdpDeviceCreateX11 GLS_VDPAU_X11
TVdpDeviceDestroy GLS_VDPAU_API
TVdpFuncId GLS_VDPAU_API
TVdpGenerateCSCMatrix GLS_VDPAU_API
TVdpGetApiVersion GLS_VDPAU_API
TVdpGetErrorString GLS_VDPAU_API
TVdpGetInformationString GLS_VDPAU_API
TVdpGetProcAddress GLS_VDPAU_API
TVdpIndexedFormat GLS_VDPAU_API
TVdpOutputSurface GLS_VDPAU_API
TVdpOutputSurfaceCreate GLS_VDPAU_API
TVdpOutputSurfaceDestroy GLS_VDPAU_API
TVdpOutputSurfaceGetBitsNative GLS_VDPAU_API
TVdpOutputSurfaceGetParameters GLS_VDPAU_API
TVdpOutputSurfacePutBitsIndexed GLS_VDPAU_API
TVdpOutputSurfacePutBitsNative GLS_VDPAU_API
TVdpOutputSurfacePutBitsYCbCr GLS_VDPAU_API
TVdpOutputSurfaceQueryCapabilities GLS_VDPAU_API
TVdpOutputSurfaceQueryGetPutBitsNativeCapabilities GLS_VDPAU_API
TVdpOutputSurfaceQueryPutBitsIndexedCapabilities GLS_VDPAU_API
TVdpOutputSurfaceQueryPutBitsYCbCrCapabilities GLS_VDPAU_API
TVdpOutputSurfaceRenderBitmapSurface GLS_VDPAU_API
TVdpOutputSurfaceRenderBlendEquation GLS_VDPAU_API
TVdpOutputSurfaceRenderBlendFactor GLS_VDPAU_API
TVdpOutputSurfaceRenderOutputSurface GLS_VDPAU_API
TVdpPictureInfo GLS_VDPAU_API
TVdpPictureInfoDivX4 GLS_VDPAU_API
TVdpPictureInfoDivX5 GLS_VDPAU_API
TVdpPreemptionCallback GLS_VDPAU_API
TVdpPreemptionCallbackRegister GLS_VDPAU_API
TVdpPresentationQueue GLS_VDPAU_API
TVdpPresentationQueueBlockUntilSurfaceIdle GLS_VDPAU_API
TVdpPresentationQueueCreate GLS_VDPAU_API
TVdpPresentationQueueDestroy GLS_VDPAU_API
TVdpPresentationQueueDisplay GLS_VDPAU_API
TVdpPresentationQueueGetBackgroundColor GLS_VDPAU_API
TVdpPresentationQueueGetTime GLS_VDPAU_API
TVdpPresentationQueueQuerySurfaceStatus GLS_VDPAU_API
TVdpPresentationQueueSetBackgroundColor GLS_VDPAU_API
TVdpPresentationQueueStatus GLS_VDPAU_API
TVdpPresentationQueueTarget GLS_VDPAU_API
TVdpPresentationQueueTargetCreateX11 GLS_VDPAU_X11
TVdpPresentationQueueTargetDestroy GLS_VDPAU_API
TVdpRGBAFormat GLS_VDPAU_API
TVdpStatus GLS_VDPAU_API
TVdpTime GLS_VDPAU_API
TVdpVideoMixer GLS_VDPAU_API
TVdpVideoMixerAttribute GLS_VDPAU_API
TVdpVideoMixerCreate GLS_VDPAU_API
TVdpVideoMixerDestroy GLS_VDPAU_API
TVdpVideoMixerFeature GLS_VDPAU_API
TVdpVideoMixerGetAttributeValues GLS_VDPAU_API
TVdpVideoMixerGetFeatureEnables GLS_VDPAU_API
TVdpVideoMixerGetFeatureSupport GLS_VDPAU_API
TVdpVideoMixerGetParameterValues GLS_VDPAU_API
TVdpVideoMixerParameter GLS_VDPAU_API
TVdpVideoMixerPictureStructure GLS_VDPAU_API
TVdpVideoMixerQueryAttributeSupport GLS_VDPAU_API
TVdpVideoMixerQueryAttributeValueRange GLS_VDPAU_API
TVdpVideoMixerQueryFeatureSupport GLS_VDPAU_API
TVdpVideoMixerQueryParameterSupport GLS_VDPAU_API
TVdpVideoMixerQueryParameterValueRange GLS_VDPAU_API
TVdpVideoMixerRender GLS_VDPAU_API
TVdpVideoMixerSetAttributeValues GLS_VDPAU_API
TVdpVideoMixerSetFeatureEnables GLS_VDPAU_API
TVdpVideoSurface GLS_VDPAU_API
TVdpVideoSurfaceCreate GLS_VDPAU_API
TVdpVideoSurfaceDestroy GLS_VDPAU_API
TVdpVideoSurfaceGetBitsYCbCr GLS_VDPAU_API
TVdpVideoSurfaceGetParameters GLS_VDPAU_API
TVdpVideoSurfacePutBitsYCbCr GLS_VDPAU_API
TVdpVideoSurfaceQueryCapabilities GLS_VDPAU_API
TVdpVideoSurfaceQueryGetPutBitsYCbCrCapabilities GLS_VDPAU_API
TVdpYCbCrFormat GLS_VDPAU_API
TVec12 LWObjects
TVec12Array LWObjects
TVec12DynArray LWObjects
TVector VectorGeometry
TVectorArray VectorGeometry
TVectorFileClass GLVectorFileObjects
TVerletNodeClass VerletClasses
TVertex VectorGeometry
TVertexBoneWeightArray GLVectorFileObjects
TVertexBoneWeightDynArray GLVectorFileObjects
TVertexDataArray GLMesh
TVertexList TypesMD2
TVertexMode GLMesh
TVerticesBoneWeights GLVectorFileObjects
TVGradient Types3DS
TVHStiffness VerletHairClasses
TVHStiffnessSet VerletHairClasses
TViewportData3 Types3DS
TViewType3DS Types3DS
TVirtualKeyCode GLKeyboard
TVirtualReaderClass PersistentClasses
TVirtualWriterClass PersistentClasses
TVSyncMode GLContext
TWGLswap OpenGLTokens
TWindowAttribute GLScreen
TWindowAttributes GLScreen
TWindowFitting GLScreen
TWOCC GLSVfw
TWordArray GLSDL
TWordList Types3DS
TWordVector VectorGeometry
TWrite GLSDL
TXCollectionItemClass XCollection
TXDataDouble Types3DS
TXDataFloat Types3DS
TXDataLong Types3DS
TXDataShort Types3DS
TXDataVoid Types3DS
TXYZGridLinesStyle GLGraph
TXYZGridPart GLGraph
TXYZGridParts GLGraph
TZAlloc GLSZLibExApi
TZArray GLzBuffer
TZArrayIdx GLzBuffer
TZCompressedMode GLVfsPAK
TZCompressionLevel GLSZLibEx
TZError GLSZLibEx
TZFlush GLSZLibEx
TZFree GLSZLibExApi
TZReadFunction GLSZLibEx
TZStrategy GLSZLibEx
TZWriteFunction GLSZLibEx
UINT16 GLSJPG
UInt16 GLSDL
UINT32 GLSJPG
UInt32 GLSDL
UInt8 GLSDL
UINT8 GLSJPG
UnicodeChar GLSZLibEx
UnicodeString GLSZLibEx
Unsigned_char NewtonImport
Unsigned_int NewtonImport
Unsigned_long NewtonImport
Unsigned_short NewtonImport
WGLSWAP OpenGLTokens
__int16 NewtonImport
__int32 NewtonImport
__int64 NewtonImport
__int8 NewtonImport
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:49


GLScene v.1.1.2: All Variables

All Variables

Name | Unit | Description
ActiveVfsPAK | GLVfsPAK |
adler32 | GLSZLibExApi |
ALAUXILIARYEFFECTSLOTF | openal |
ALAUXILIARYEFFECTSLOTFV | openal |
ALAUXILIARYEFFECTSLOTI | openal |
ALAUXILIARYEFFECTSLOTIV | openal |
alBuffer3f | openal |
alBuffer3i | openal |
alBufferData | openal |
alBufferf | openal |
alBufferfv | openal |
alBufferi | openal |
alBufferiv | openal |
alcCaptureCloseDevice | openal |
alcCaptureOpenDevice | openal |
alcCaptureSamples | openal |
alcCaptureStart | openal |
alcCaptureStop | openal |
alcCloseDevice | openal |
alcCreateContext | openal |
alcDestroyContext | openal |
alcGetContextsDevice | openal |
alcGetCurrentContext | openal |
alcGetEnumValue | openal |
alcGetError | openal |
alcGetIntegerv | openal |
alcGetProcAddress | openal |
alcGetString | openal |
alcIsExtensionPresent | openal |
alcMakeContextCurrent | openal |
alcOpenDevice | openal |
alcProcessContext | openal |
alcSuspendContext | openal |
ALDELETEAUXILIARYEFFECTSLOTS | openal |
alDeleteBuffers | openal |
ALDELETEEFFECTS | openal |
ALDELETEFILTERS | openal |
alDeleteSources | openal |
alDisable | openal |
alDistanceModel | openal |
alDopplerFactor | openal |
alDopplerVelocity | openal |
ALEFFECTF | openal |
ALEFFECTFV | openal |
ALEFFECTI | openal |
ALEFFECTIV | openal |
alEnable | openal |
ALFILTERF | openal |
ALFILTERFV | openal |
ALFILTERI | openal |
ALFILTERIV | openal |
ALGENAUXILIARYEFFECTSLOTS | openal |
alGenBuffers | openal |
ALGENEFFECTS | openal |
ALGENFILTERS | openal |
alGenSources | openal |
ALGETAUXILIARYEFFECTSLOTF | openal |
ALGETAUXILIARYEFFECTSLOTFV | openal |
ALGETAUXILIARYEFFECTSLOTI | openal |
ALGETAUXILIARYEFFECTSLOTIV | openal |
alGetBoolean | openal |
alGetBooleanv | openal |
alGetBuffer3f | openal |
alGetBuffer3i | openal |
alGetBufferf | openal |
alGetBufferfv | openal |
alGetBufferi | openal |
alGetBufferiv | openal |
alGetDouble | openal |
alGetDoublev | openal |
ALGETEFFECTF | openal |
ALGETEFFECTFV | openal |
ALGETEFFECTI | openal |
ALGETEFFECTIV | openal |
alGetEnumValue | openal |
alGetError | openal |
ALGETFILTERF | openal |
ALGETFILTERFV | openal |
ALGETFILTERI | openal |
ALGETFILTERIV | openal |
alGetFloat | openal |
alGetFloatv | openal |
alGetInteger | openal |
alGetIntegerv | openal |
alGetListenerfv | openal |
alGetListeneriv | openal |
alGetProcAddress | openal |
alGetSource3f | openal |
alGetSource3i | openal |
alGetSourcef | openal |
alGetSourcefv | openal |
alGetSourcei | openal |
alGetSourceiv | openal |
alGetString | openal |
alHint | openal |
ALISAUXILIARYEFFECTSLOT | openal |
alIsBuffer | openal |
ALISEFFECT | openal |
alIsEnabled | openal |
alIsExtensionPresent | openal |
ALISFILTER | openal |
alIsSource | openal |
alListener3f | openal |
alListener3i | openal |
alListenerf | openal |
alListenerfv | openal |
alListeneri | openal |
alListeneriv | openal |
alSource3f | openal |
alSource3i | openal |
alSourcef | openal |
alSourcefv | openal |
alSourcei | openal |
alSourceiv | openal |
alSourcePause | openal |
alSourcePausev | openal |
alSourcePlay | openal |
alSourcePlayv | openal |
alSourceQueueBuffers | openal |
alSourceRewind | openal |
alSourceRewindv | openal |
alSourceStop | openal |
alSourceStopv | openal |
alSourceUnqueueBuffers | openal |
alSpeedOfSound | openal |
AL_EAX_RAM_FREE | openal |
AL_EAX_RAM_SIZE | openal |
AL_STORAGE_ACCESSIBLE | openal |
AL_STORAGE_AUTOMATIC | openal |
AL_STORAGE_HARDWARE | openal |
BASS_Apply3D | Bass |
BASS_ChannelBytes2Seconds | Bass |
BASS_ChannelGet3DAttributes | Bass |
BASS_ChannelGet3DPosition | Bass |
BASS_ChannelGetAttributes | Bass |
BASS_ChannelGetData | Bass |
BASS_ChannelGetDevice | Bass |
BASS_ChannelGetEAXMix | Bass |
BASS_ChannelGetInfo | Bass |
BASS_ChannelGetLength | Bass |
BASS_ChannelGetLevel | Bass |
BASS_ChannelGetPosition | Bass |
BASS_ChannelGetTags | Bass |
BASS_ChannelIsActive | Bass |
BASS_ChannelIsSliding | Bass |
BASS_ChannelPause | Bass |
BASS_ChannelPlay | Bass |
BASS_ChannelPreBuf | Bass |
BASS_ChannelRemoveDSP | Bass |
BASS_ChannelRemoveFX | Bass |
BASS_ChannelRemoveLink | Bass |
BASS_ChannelRemoveSync | Bass |
BASS_ChannelSeconds2Bytes | Bass |
BASS_ChannelSet3DAttributes | Bass |
BASS_ChannelSet3DPosition | Bass |
BASS_ChannelSetAttributes | Bass |
BASS_ChannelSetDevice | Bass |
BASS_ChannelSetDSP | Bass |
BASS_ChannelSetEAXMix | Bass |
BASS_ChannelSetFlags | Bass |
BASS_ChannelSetFX | Bass |
BASS_ChannelSetLink | Bass |
BASS_ChannelSetPosition | Bass |
BASS_ChannelSetSync | Bass |
BASS_ChannelSlideAttributes | Bass |
BASS_ChannelStop | Bass |
BASS_ErrorGetCode | Bass |
BASS_Free | Bass |
BASS_FXGetParameters | Bass |
BASS_FXReset | Bass |
BASS_FXSetParameters | Bass |
BASS_Get3DFactors | Bass |
BASS_Get3DPosition | Bass |
BASS_GetConfig | Bass |
BASS_GetCPU | Bass |
BASS_GetDevice | Bass |
BASS_GetDeviceDescription | Bass |
BASS_GetDSoundObject | Bass |
BASS_GetEAXParameters | Bass |
BASS_GetInfo | Bass |
BASS_GetVersion | Bass |
BASS_GetVolume | Bass |
BASS_Init | Bass |
BASS_MusicFree | Bass |
BASS_MusicGetAttribute | Bass |
BASS_MusicGetOrderPosition | Bass |
BASS_MusicGetOrders | Bass |
BASS_MusicLoad | Bass |
BASS_MusicSetAttribute | Bass |
BASS_Pause | Bass |
BASS_PluginFree | Bass |
BASS_PluginGetInfo | Bass |
BASS_PluginLoad | Bass |
BASS_RecordFree | Bass |
BASS_RecordGetDevice | Bass |
BASS_RecordGetDeviceDescription | Bass |
BASS_RecordGetInfo | Bass |
BASS_RecordGetInput | Bass |
BASS_RecordGetInputName | Bass |
BASS_RecordInit | Bass |
BASS_RecordSetDevice | Bass |
BASS_RecordSetInput | Bass |
BASS_RecordStart | Bass |
BASS_SampleCreate | Bass |
BASS_SampleCreateDone | Bass |
BASS_SampleFree | Bass |
BASS_SampleGetChannel | Bass |
BASS_SampleGetChannels | Bass |
BASS_SampleGetInfo | Bass |
BASS_SampleLoad | Bass |
BASS_SampleSetInfo | Bass |
BASS_SampleStop | Bass |
BASS_Set3DFactors | Bass |
BASS_Set3DPosition | Bass |
BASS_SetConfig | Bass |
BASS_SetDevice | Bass |
BASS_SetEAXParameters | Bass |
BASS_SetVolume | Bass |
BASS_Start | Bass |
BASS_Stop | Bass |
BASS_StreamCreate | Bass |
BASS_StreamCreateFile | Bass |
BASS_StreamCreateFileUser | Bass |
BASS_StreamCreateURL | Bass |
BASS_StreamFree | Bass |
BASS_StreamGetFilePosition | Bass |
BASS_Update | Bass |
BinormalAttributeName | GLObjects |
clBuildProgram | GLS_CL |
clCreateBuffer | GLS_CL |
clCreateCommandQueue | GLS_CL |
clCreateContext | GLS_CL |
clCreateContextFromType | GLS_CL |
clCreateImage2D | GLS_CL |
clCreateImage3D | GLS_CL |
clCreateKernel | GLS_CL |
clCreateKernelsInProgram | GLS_CL |
clCreateProgramWithBinary | GLS_CL |
clCreateProgramWithSource | GLS_CL |
clCreateSampler | GLS_CL |
clEnqueueBarrier | GLS_CL |
clEnqueueCopyBuffer | GLS_CL |
clEnqueueCopyBufferToImage | GLS_CL |
clEnqueueCopyImage | GLS_CL |
clEnqueueCopyImageToBuffer | GLS_CL |
clEnqueueMapBuffer | GLS_CL |
clEnqueueMapImage | GLS_CL |
clEnqueueMarker | GLS_CL |
clEnqueueNativeKernel | GLS_CL |
clEnqueueNDRangeKernel | GLS_CL |
clEnqueueReadBuffer | GLS_CL |
clEnqueueReadImage | GLS_CL |
clEnqueueTask | GLS_CL |
clEnqueueUnmapMemObject | GLS_CL |
clEnqueueWaitForEvents | GLS_CL |
clEnqueueWriteBuffer | GLS_CL |
clEnqueueWriteImage | GLS_CL |
clFinish | GLS_CL |
clFlush | GLS_CL |
clGetCommandQueueInfo | GLS_CL |
clGetContextInfo | GLS_CL |
clGetDeviceIDs | GLS_CL |
clGetDeviceInfo | GLS_CL |
clGetEventInfo | GLS_CL |
clGetEventProfilingInfo | GLS_CL |
clGetExtensionFunctionAddress | GLS_CL |
clGetImageInfo | GLS_CL |
clGetKernelInfo | GLS_CL |
clGetKernelWorkGroupInfo | GLS_CL |
clGetMemObjectInfo | GLS_CL |
clGetPlatformIDs | GLS_CL |
clGetPlatformInfo | GLS_CL |
clGetProgramBuildInfo | GLS_CL |
clGetProgramInfo | GLS_CL |
clGetSamplerInfo | GLS_CL |
clGetSupportedImageFormats | GLS_CL |
clReleaseCommandQueue | GLS_CL |
clReleaseContext | GLS_CL |
clReleaseEvent | GLS_CL |
clReleaseKernel | GLS_CL |
clReleaseMemObject | GLS_CL |
clReleaseProgram | GLS_CL |
clReleaseSampler | GLS_CL |
clRetainCommandQueue | GLS_CL |
clRetainContext | GLS_CL |
clRetainEvent | GLS_CL |
clRetainKernel | GLS_CL |
clRetainMemObject | GLS_CL |
clRetainProgram | GLS_CL |
clRetainSampler | GLS_CL |
clSetCommandQueueProperty | GLS_CL |
clSetKernelArg | GLS_CL |
clUnloadCompiler | GLS_CL |
clWaitForEvents | GLS_CL |
crc32 | GLSZLibExApi |
cuArray3DCreate | GLS_CUDA_API |
cuArray3DGetDescriptor | GLS_CUDA_API |
cuArrayCreate | GLS_CUDA_API |
cuArrayDestroy | GLS_CUDA_API |
cuArrayGetDescriptor | GLS_CUDA_API |
cuCtxAttach | GLS_CUDA_API |
cuCtxCreate | GLS_CUDA_API |
cuCtxDestroy | GLS_CUDA_API |
cuCtxDetach | GLS_CUDA_API |
cuCtxGetDevice | GLS_CUDA_API |
cuCtxPopCurrent | GLS_CUDA_API |
cuCtxPushCurrent | GLS_CUDA_API |
cuCtxSynchronize | GLS_CUDA_API |
cudaBindTexture | GLS_CUDA_Runtime |
cudaBindTexture2D | GLS_CUDA_Runtime |
cudaBindTextureToArray | GLS_CUDA_Runtime |
cudaChooseDevice | GLS_CUDA_Runtime |
cudaConfigureCall | GLS_CUDA_Runtime |
cudaCreateChannelDesc | GLS_CUDA_Runtime |
cudaDriverGetVersion | GLS_CUDA_Runtime |
cudaEventCreate | GLS_CUDA_Runtime |
cudaEventCreateWithFlags | GLS_CUDA_Runtime |
cudaEventDestroy | GLS_CUDA_Runtime |
cudaEventElapsedTime | GLS_CUDA_Runtime |
cudaEventQuery | GLS_CUDA_Runtime |
cudaEventRecord | GLS_CUDA_Runtime |
cudaEventSynchronize | GLS_CUDA_Runtime |
cudaFree | GLS_CUDA_Runtime |
cudaFreeArray | GLS_CUDA_Runtime |
cudaFreeHost | GLS_CUDA_Runtime |
cudaFuncGetAttributes | GLS_CUDA_Runtime |
cudaFuncSetCacheConfig | GLS_CUDA_Runtime |
cudaGetChannelDesc | GLS_CUDA_Runtime |
cudaGetDevice | GLS_CUDA_Runtime |
cudaGetDeviceCount | GLS_CUDA_Runtime |
cudaGetDeviceProperties | GLS_CUDA_Runtime |
cudaGetErrorString | GLS_CUDA_Runtime |
cudaGetLastError | GLS_CUDA_Runtime |
cudaGetSymbolAddress | GLS_CUDA_Runtime |
cudaGetSymbolSize | GLS_CUDA_Runtime |
cudaGetTextureAlignmentOffset | GLS_CUDA_Runtime |
cudaGetTextureReference | GLS_CUDA_Runtime |
cudaGLMapBufferObject | GLS_CUDA_Runtime |
cudaGLMapBufferObjectAsync | GLS_CUDA_Runtime |
cudaGLRegisterBufferObject | GLS_CUDA_Runtime |
cudaGLSetBufferObjectMapFlags | GLS_CUDA_Runtime |
cudaGLSetGLDevice | GLS_CUDA_Runtime |
cudaGLUnmapBufferObject | GLS_CUDA_Runtime |
cudaGLUnmapBufferObjectAsync | GLS_CUDA_Runtime |
cudaGLUnregisterBufferObject | GLS_CUDA_Runtime |
cudaGraphicsGLRegisterBuffer | GLS_CUDA_Runtime |
cudaGraphicsGLRegisterImage | GLS_CUDA_Runtime |
cudaGraphicsMapResources | GLS_CUDA_Runtime |
cudaGraphicsResourceGetMappedPointer | GLS_CUDA_Runtime |
cudaGraphicsResourceSetMapFlags | GLS_CUDA_Runtime |
cudaGraphicsSubResourceGetMappedArray | GLS_CUDA_Runtime |
cudaGraphicsUnmapResources | GLS_CUDA_Runtime |
cudaGraphicsUnregisterResource | GLS_CUDA_Runtime |
cudaHostAlloc | GLS_CUDA_Runtime |
cudaHostGetDevicePointer | GLS_CUDA_Runtime |
cudaHostGetFlags | GLS_CUDA_Runtime |
cudaLaunch | GLS_CUDA_Runtime |
cudaMalloc | GLS_CUDA_Runtime |
cudaMalloc3D | GLS_CUDA_Runtime |
cudaMalloc3DArray | GLS_CUDA_Runtime |
cudaMallocArray | GLS_CUDA_Runtime |
cudaMallocHost | GLS_CUDA_Runtime |
cudaMallocPitch | GLS_CUDA_Runtime |
cudaMemcpy | GLS_CUDA_Runtime |
cudaMemcpy2D | GLS_CUDA_Runtime |
cudaMemcpy2DArrayToArray | GLS_CUDA_Runtime |
cudaMemcpy2DAsync | GLS_CUDA_Runtime |
cudaMemcpy2DFromArray | GLS_CUDA_Runtime |
cudaMemcpy2DFromArrayAsync | GLS_CUDA_Runtime |
cudaMemcpy2DToArray | GLS_CUDA_Runtime |
cudaMemcpy2DToArrayAsync | GLS_CUDA_Runtime |
cudaMemcpy3D | GLS_CUDA_Runtime |
cudaMemcpy3DAsync | GLS_CUDA_Runtime |
cudaMemcpyArrayToArray | GLS_CUDA_Runtime |
cudaMemcpyAsync | GLS_CUDA_Runtime |
cudaMemcpyFromArray | GLS_CUDA_Runtime |
cudaMemcpyFromArrayAsync | GLS_CUDA_Runtime |
cudaMemcpyFromSymbol | GLS_CUDA_Runtime |
cudaMemcpyFromSymbolAsync | GLS_CUDA_Runtime |
cudaMemcpyToArray | GLS_CUDA_Runtime |
cudaMemcpyToArrayAsync | GLS_CUDA_Runtime |
cudaMemcpyToSymbol | GLS_CUDA_Runtime |
cudaMemcpyToSymbolAsync | GLS_CUDA_Runtime |
cudaMemGetInfo | GLS_CUDA_Runtime |
cudaMemset | GLS_CUDA_Runtime |
cudaMemset2D | GLS_CUDA_Runtime |
cudaMemset3D | GLS_CUDA_Runtime |
cudaRuntimeGetVersion | GLS_CUDA_Runtime |
cudaSetDevice | GLS_CUDA_Runtime |
cudaSetDeviceFlags | GLS_CUDA_Runtime |
cudaSetDoubleForDevice | GLS_CUDA_Runtime |
cudaSetDoubleForHost | GLS_CUDA_Runtime |
cudaSetupArgument | GLS_CUDA_Runtime |
cudaSetValidDevices | GLS_CUDA_Runtime |
cudaStreamCreate | GLS_CUDA_Runtime |
cudaStreamDestroy | GLS_CUDA_Runtime |
cudaStreamQuery | GLS_CUDA_Runtime |
cudaStreamSynchronize | GLS_CUDA_Runtime |
cudaThreadExit | GLS_CUDA_Runtime |
cudaThreadGetLimit | GLS_CUDA_Runtime |
cudaThreadSetLimit | GLS_CUDA_Runtime |
cudaThreadSynchronize | GLS_CUDA_Runtime |
cudaUnbindTexture | GLS_CUDA_Runtime |
cudaWGLGetDevice | GLS_CUDA_Runtime |
cuDeviceComputeCapability | GLS_CUDA_API |
cuDeviceGet | GLS_CUDA_API |
cuDeviceGetAttribute | GLS_CUDA_API |
cuDeviceGetCount | GLS_CUDA_API |
cuDeviceGetName | GLS_CUDA_API |
cuDeviceGetProperties | GLS_CUDA_API |
cuDeviceTotalMem | GLS_CUDA_API |
cuDriverGetVersion | GLS_CUDA_API |
cuEventCreate | GLS_CUDA_API |
cuEventDestroy | GLS_CUDA_API |
cuEventElapsedTime | GLS_CUDA_API |
cuEventQuery | GLS_CUDA_API |
cuEventRecord | GLS_CUDA_API |
cuEventSynchronize | GLS_CUDA_API |
cufftDestroy | GLS_CUDA_FourierTransform |
cufftExecC2C | GLS_CUDA_FourierTransform |
cufftExecC2R | GLS_CUDA_FourierTransform |
cufftExecD2Z | GLS_CUDA_FourierTransform |
cufftExecR2C | GLS_CUDA_FourierTransform |
cufftExecZ2D | GLS_CUDA_FourierTransform |
cufftExecZ2Z | GLS_CUDA_FourierTransform |
cufftPlan1d | GLS_CUDA_FourierTransform |
cufftPlan2d | GLS_CUDA_FourierTransform |
cufftPlan3d | GLS_CUDA_FourierTransform |
cufftPlanMany | GLS_CUDA_FourierTransform |
cufftSetCompatibilityMode | GLS_CUDA_FourierTransform |
cufftSetStream | GLS_CUDA_FourierTransform |
cuFuncGetAttribute | GLS_CUDA_API |
cuFuncSetBlockShape | GLS_CUDA_API |
cuFuncSetSharedSize | GLS_CUDA_API |
cuGLCtxCreate | GLS_CUDA_API |
cuGLInit | GLS_CUDA_API |
cuGLMapBufferObject | GLS_CUDA_API |
cuGLMapBufferObjectAsync | GLS_CUDA_API |
cuGLRegisterBufferObject | GLS_CUDA_API |
cuGLSetBufferObjectMapFlags | GLS_CUDA_API |
cuGLUnmapBufferObject | GLS_CUDA_API |
cuGLUnmapBufferObjectAsync | GLS_CUDA_API |
cuGLUnregisterBufferObject | GLS_CUDA_API |
cuGraphicsGLRegisterBuffer | GLS_CUDA_API |
cuGraphicsGLRegisterImage | GLS_CUDA_API |
cuGraphicsMapResources | GLS_CUDA_API |
cuGraphicsResourceGetMappedPointer | GLS_CUDA_API |
cuGraphicsResourceSetMapFlags | GLS_CUDA_API |
cuGraphicsSubResourceGetMappedArray | GLS_CUDA_API |
cuGraphicsUnmapResources | GLS_CUDA_API |
cuGraphicsUnregisterResource | GLS_CUDA_API |
cuInit | GLS_CUDA_API |
cuLaunch | GLS_CUDA_API |
cuLaunchGrid | GLS_CUDA_API |
cuLaunchGridAsync | GLS_CUDA_API |
cuMemAlloc | GLS_CUDA_API |
cuMemAllocHost | GLS_CUDA_API |
cuMemAllocPitch | GLS_CUDA_API |
cuMemcpy2D | GLS_CUDA_API |
cuMemcpy2DAsync | GLS_CUDA_API |
cuMemcpy2DUnaligned | GLS_CUDA_API |
cuMemcpy3D | GLS_CUDA_API |
cuMemcpy3DAsync | GLS_CUDA_API |
cuMemcpyAtoA | GLS_CUDA_API |
cuMemcpyAtoD | GLS_CUDA_API |
cuMemcpyAtoH | GLS_CUDA_API |
cuMemcpyAtoHAsync | GLS_CUDA_API |
cuMemcpyDtoA | GLS_CUDA_API |
cuMemcpyDtoD | GLS_CUDA_API |
cuMemcpyDtoDAsync | GLS_CUDA_API |
cuMemcpyDtoH | GLS_CUDA_API |
cuMemcpyDtoHAsync | GLS_CUDA_API |
cuMemcpyHtoA | GLS_CUDA_API |
cuMemcpyHtoAAsync | GLS_CUDA_API |
cuMemcpyHtoD | GLS_CUDA_API |
cuMemcpyHtoDAsync | GLS_CUDA_API |
cuMemFree | GLS_CUDA_API |
cuMemFreeHost | GLS_CUDA_API |
cuMemGetAddressRange | GLS_CUDA_API |
cuMemGetInfo | GLS_CUDA_API |
cuMemHostAlloc | GLS_CUDA_API |
cuMemHostGetDevicePointer | GLS_CUDA_API |
cuMemHostGetFlags | GLS_CUDA_API |
cuMemsetD16 | GLS_CUDA_API |
cuMemsetD2D16 | GLS_CUDA_API |
cuMemsetD2D32 | GLS_CUDA_API |
cuMemsetD2D8 | GLS_CUDA_API |
cuMemsetD32 | GLS_CUDA_API |
cuMemsetD8 | GLS_CUDA_API |
cuModuleGetFunction | GLS_CUDA_API |
cuModuleGetGlobal | GLS_CUDA_API |
cuModuleGetTexRef | GLS_CUDA_API |
cuModuleLoad | GLS_CUDA_API |
cuModuleLoadData | GLS_CUDA_API |
cuModuleLoadDataEx | GLS_CUDA_API |
cuModuleLoadFatBinary | GLS_CUDA_API |
cuModuleUnload | GLS_CUDA_API |
cuParamSetf | GLS_CUDA_API |
cuParamSeti | GLS_CUDA_API |
cuParamSetSize | GLS_CUDA_API |
cuParamSetTexRef | GLS_CUDA_API |
cuParamSetv | GLS_CUDA_API |
cuStreamCreate | GLS_CUDA_API |
cuStreamDestroy | GLS_CUDA_API |
cuStreamQuery | GLS_CUDA_API |
cuStreamSynchronize | GLS_CUDA_API |
cutComparef | GLS_CUDA_Utility |
cutComparefe | GLS_CUDA_Utility |
cutComparefet | GLS_CUDA_Utility |
cutComparei | GLS_CUDA_Utility |
cutCompareL2fe | GLS_CUDA_Utility |
cutCompareub | GLS_CUDA_Utility |
cutCompareube | GLS_CUDA_Utility |
cutCompareubt | GLS_CUDA_Utility |
cutCompareuit | GLS_CUDA_Utility |
cutCreateTimer | GLS_CUDA_Utility |
cutDeleteTimer | GLS_CUDA_Utility |
cuTexRefCreate | GLS_CUDA_API |
cuTexRefDestroy | GLS_CUDA_API |
cuTexRefGetAddress | GLS_CUDA_API |
cuTexRefGetAddressMode | GLS_CUDA_API |
cuTexRefGetArray | GLS_CUDA_API |
cuTexRefGetFilterMode | GLS_CUDA_API |
cuTexRefGetFlags | GLS_CUDA_API |
cuTexRefGetFormat | GLS_CUDA_API |
cuTexRefSetAddress | GLS_CUDA_API |
cuTexRefSetAddress2D | GLS_CUDA_API |
cuTexRefSetAddressMode | GLS_CUDA_API |
cuTexRefSetArray | GLS_CUDA_API |
cuTexRefSetFilterMode | GLS_CUDA_API |
cuTexRefSetFlags | GLS_CUDA_API |
cuTexRefSetFormat | GLS_CUDA_API |
cutFindFilePath | GLS_CUDA_Utility |
cutFree | GLS_CUDA_Utility |
cutGetAverageTimerValue | GLS_CUDA_Utility |
cutGetTimerValue | GLS_CUDA_Utility |
cutLoadPGMf | GLS_CUDA_Utility |
cutLoadPGMi | GLS_CUDA_Utility |
cutLoadPGMs | GLS_CUDA_Utility |
cutLoadPGMub | GLS_CUDA_Utility |
cutLoadPPM4ub | GLS_CUDA_Utility |
cutLoadPPMub | GLS_CUDA_Utility |
cutResetTimer | GLS_CUDA_Utility |
cutSavePGMf | GLS_CUDA_Utility |
cutSavePGMi | GLS_CUDA_Utility |
cutSavePGMs | GLS_CUDA_Utility |
cutSavePGMub | GLS_CUDA_Utility |
cutSavePPM4ub | GLS_CUDA_Utility |
cutSavePPMub | GLS_CUDA_Utility |
cutStartTimer | GLS_CUDA_Utility |
cutStopTimer | GLS_CUDA_Utility |
cuWGLGetDevice | GLS_CUDA_API |
dBoxClass | ODEImport |
dCapsuleClass | ODEImport |
dConvexClass | ODEImport |
dCylinderClass | ODEImport |
debug_tri | GLEllipseCollision |
deflate | GLSZLibExApi |
deflateEnd | GLSZLibExApi |
deflateInit2_ | GLSZLibExApi |
deflateInit_ | GLSZLibExApi |
deflateReset | GLSZLibExApi |
dFirstSpaceClass | ODEImport |
dFirstUserClass | ODEImport |
dGeomNumClasses | ODEImport |
dGeomTransformClass | ODEImport |
dHashSpaceClass | ODEImport |
dHeightFieldClass | ODEImport |
DisabledDebugCollision | ODEImport |
DisabledDebugGeom | ODEImport |
dLastSpaceClass | ODEImport |
dLastUserClass | ODEImport |
dPlaneClass | ODEImport |
dQuadTreeSpaceClass | ODEImport |
dRayClass | ODEImport |
dSimpleSpaceClass | ODEImport |
dSphereClass | ODEImport |
dSweepAndPruneSpaceClass | ODEImport |
dTriMeshClass | ODEImport |
EAXGet | openal |
EAXGetBufferMode | openal |
EAXSet | openal |
EAXSetBufferMode | openal |
EFXUtilLibHandle | openal |
FMUSIC_FreeSong | fmoddyn |
FMUSIC_GetBPM | fmoddyn |
FMUSIC_GetGlobalVolume | fmoddyn |
FMUSIC_GetMasterVolume | fmoddyn |
FMUSIC_GetName | fmoddyn |
FMUSIC_GetNumChannels | fmoddyn |
FMUSIC_GetNumInstruments | fmoddyn |
FMUSIC_GetNumOrders | fmoddyn |
FMUSIC_GetNumPatterns | fmoddyn |
FMUSIC_GetNumSamples | fmoddyn |
FMUSIC_GetOpenState | fmoddyn |
FMUSIC_GetOrder | fmoddyn |
FMUSIC_GetPattern | fmoddyn |
FMUSIC_GetPatternLength | fmoddyn |
FMUSIC_GetPaused | fmoddyn |
FMUSIC_GetRealChannel | fmoddyn |
FMUSIC_GetRow | fmoddyn |
FMUSIC_GetSample | fmoddyn |
FMUSIC_GetSpeed | fmoddyn |
FMUSIC_GetTime | fmoddyn |
FMUSIC_GetType | fmoddyn |
FMUSIC_GetUserData | fmoddyn |
FMUSIC_IsFinished | fmoddyn |
FMUSIC_IsPlaying | fmoddyn |
FMUSIC_LoadSong | fmoddyn |
FMUSIC_LoadSongEx | fmoddyn |
FMUSIC_OptimizeChannels | fmoddyn |
FMUSIC_PlaySong | fmoddyn |
FMUSIC_SetInstCallback | fmoddyn |
FMUSIC_SetLooping | fmoddyn |
FMUSIC_SetMasterSpeed | fmoddyn |
FMUSIC_SetMasterVolume | fmoddyn |
FMUSIC_SetOrder | fmoddyn |
FMUSIC_SetOrderCallback | fmoddyn |
FMUSIC_SetPanSeperation | fmoddyn |
FMUSIC_SetPaused | fmoddyn |
FMUSIC_SetReverb | fmoddyn |
FMUSIC_SetRowCallback | fmoddyn |
FMUSIC_SetSample | fmoddyn |
FMUSIC_SetUserData | fmoddyn |
FMUSIC_SetZxxCallback | fmoddyn |
FMUSIC_StopAllSongs | fmoddyn |
FMUSIC_StopSong | fmoddyn |
FSOUND_3D_GetAttributes | fmoddyn |
FSOUND_3D_GetMinMaxDistance | fmoddyn |
FSOUND_3D_Listener_GetAttributes | fmoddyn |
FSOUND_3D_Listener_SetAttributes | fmoddyn |
FSOUND_3D_Listener_SetCurrent | fmoddyn |
FSOUND_3D_SetAttributes | fmoddyn |
FSOUND_3D_SetDistanceFactor | fmoddyn |
FSOUND_3D_SetDopplerFactor | fmoddyn |
FSOUND_3D_SetMinMaxDistance | fmoddyn |
FSOUND_3D_SetRolloffFactor | fmoddyn |
FSOUND_CD_GetNumTracks | fmoddyn |
FSOUND_CD_GetPaused | fmoddyn |
FSOUND_CD_GetTrack | fmoddyn |
FSOUND_CD_GetTrackLength | fmoddyn |
FSOUND_CD_GetTrackTime | fmoddyn |
FSOUND_CD_GetVolume | fmoddyn |
FSOUND_CD_OpenTray | fmoddyn |
FSOUND_CD_Play | fmoddyn |
FSOUND_CD_SetPaused | fmoddyn |
FSOUND_CD_SetPlayMode | fmoddyn |
FSOUND_CD_SetTrackTime | fmoddyn |
FSOUND_CD_SetVolume | fmoddyn |
FSOUND_CD_Stop | fmoddyn |
FSOUND_Close | fmoddyn |
FSOUND_DSP_ClearMixBuffer | fmoddyn |
FSOUND_DSP_Create | fmoddyn |
FSOUND_DSP_Free | fmoddyn |
FSOUND_DSP_GetActive | fmoddyn |
FSOUND_DSP_GetBufferLength | fmoddyn |
FSOUND_DSP_GetBufferLengthTotal | fmoddyn |
FSOUND_DSP_GetClearUnit | fmoddyn |
FSOUND_DSP_GetClipAndCopyUnit | fmoddyn |
FSOUND_DSP_GetFFTUnit | fmoddyn |
FSOUND_DSP_GetMusicUnit | fmoddyn |
FSOUND_DSP_GetPriority | fmoddyn |
FSOUND_DSP_GetSFXUnit | fmoddyn |
FSOUND_DSP_GetSpectrum | fmoddyn |
FSOUND_DSP_MixBuffers | fmoddyn |
FSOUND_DSP_SetActive | fmoddyn |
FSOUND_DSP_SetPriority | fmoddyn |
FSOUND_File_SetCallbacks | fmoddyn |
FSOUND_FX_Disable | fmoddyn |
FSOUND_FX_Enable | fmoddyn |
FSOUND_FX_SetChorus | fmoddyn |
FSOUND_FX_SetCompressor | fmoddyn |
FSOUND_FX_SetDistortion | fmoddyn |
FSOUND_FX_SetEcho | fmoddyn |
FSOUND_FX_SetFlanger | fmoddyn |
FSOUND_FX_SetGargle | fmoddyn |
FSOUND_FX_SetI3DL2Reverb | fmoddyn |
FSOUND_FX_SetParamEQ | fmoddyn |
FSOUND_FX_SetWavesReverb | fmoddyn |
FSOUND_GetAmplitude | fmoddyn |
FSOUND_GetChannelsPlaying | fmoddyn |
FSOUND_GetCPUUsage | fmoddyn |
FSOUND_GetCurrentLevels | fmoddyn |
FSOUND_GetCurrentPosition | fmoddyn |
FSOUND_GetCurrentSample | fmoddyn |
FSOUND_GetDriver | fmoddyn |
FSOUND_GetDriverCaps | fmoddyn |
FSOUND_GetDriverName | fmoddyn |
FSOUND_GetError | fmoddyn |
FSOUND_GetFrequency | fmoddyn |
FSOUND_GetLoopMode | fmoddyn |
FSOUND_GetMaxChannels | fmoddyn |
FSOUND_GetMaxSamples | fmoddyn |
FSOUND_GetMemoryStats | fmoddyn |
FSOUND_GetMixer | fmoddyn |
FSOUND_GetMute | fmoddyn |
FSOUND_GetNumDrivers | fmoddyn |
FSOUND_GetNumHWChannels | fmoddyn |
FSOUND_GetNumSubChannels | fmoddyn |
FSOUND_GetOutput | fmoddyn |
FSOUND_GetOutputHandle | fmoddyn |
FSOUND_GetOutputRate | fmoddyn |
FSOUND_GetPan | fmoddyn |
FSOUND_GetPaused | fmoddyn |
FSOUND_GetPriority | fmoddyn |
FSOUND_GetReserved | fmoddyn |
FSOUND_GetSFXMasterVolume | fmoddyn |
FSOUND_GetSpeakerMode | fmoddyn |
FSOUND_GetSubChannel | fmoddyn |
FSOUND_GetSurround | fmoddyn |
FSOUND_GetVersion | fmoddyn |
FSOUND_GetVolume | fmoddyn |
FSOUND_Init | fmoddyn |
FSOUND_IsPlaying | fmoddyn |
FSOUND_PlaySound | fmoddyn |
FSOUND_PlaySoundEx | fmoddyn |
FSOUND_Record_GetDriver | fmoddyn |
FSOUND_Record_GetDriverName | fmoddyn |
FSOUND_Record_GetNumDrivers | fmoddyn |
FSOUND_Record_GetPosition | fmoddyn |
FSOUND_Record_SetDriver | fmoddyn |
FSOUND_Record_StartSample | fmoddyn |
FSOUND_Record_Stop | fmoddyn |
FSOUND_Reverb_GetChannelProperties | fmoddyn |
FSOUND_Reverb_GetProperties | fmoddyn |
FSOUND_Reverb_SetChannelProperties | fmoddyn |
FSOUND_Reverb_SetProperties | fmoddyn |
FSOUND_Sample_Alloc | fmoddyn |
FSOUND_Sample_Free | fmoddyn |
FSOUND_Sample_Get | fmoddyn |
FSOUND_Sample_GetDefaults | fmoddyn |
FSOUND_Sample_GetDefaultsEx | fmoddyn |
FSOUND_Sample_GetLength | fmoddyn |
FSOUND_Sample_GetLoopPoints | fmoddyn |
FSOUND_Sample_GetMinMaxDistance | fmoddyn |
FSOUND_Sample_GetMode | fmoddyn |
FSOUND_Sample_GetName | fmoddyn |
FSOUND_Sample_Load | fmoddyn |
FSOUND_Sample_Lock | fmoddyn |
FSOUND_Sample_SetDefaults | fmoddyn |
FSOUND_Sample_SetDefaultsEx | fmoddyn |
FSOUND_Sample_SetLoopPoints | fmoddyn |
FSOUND_Sample_SetMaxPlaybacks | fmoddyn |
FSOUND_Sample_SetMinMaxDistance | fmoddyn |
FSOUND_Sample_SetMode | fmoddyn |
FSOUND_Sample_Unlock | fmoddyn |
FSOUND_Sample_Upload | fmoddyn |
FSOUND_SetBufferSize | fmoddyn |
FSOUND_SetCurrentPosition | fmoddyn |
FSOUND_SetDriver | fmoddyn |
FSOUND_SetFrequency | fmoddyn |
FSOUND_SetHWND | fmoddyn |
FSOUND_SetLoopMode | fmoddyn |
FSOUND_SetMaxHardwareChannels | fmoddyn |
FSOUND_SetMemorySystem | fmoddyn |
FSOUND_SetMinHardwareChannels | fmoddyn |
FSOUND_SetMixer | fmoddyn |
FSOUND_SetMute | fmoddyn |
FSOUND_SetOutput | fmoddyn |
FSOUND_SetPan | fmoddyn |
FSOUND_SetPanSeperation | fmoddyn |
FSOUND_SetPaused | fmoddyn |
FSOUND_SetPriority | fmoddyn |
FSOUND_SetReserved | fmoddyn |
FSOUND_SetSFXMasterVolume | fmoddyn |
FSOUND_SetSpeakerMode | fmoddyn |
FSOUND_SetSurround | fmoddyn |
FSOUND_SetVolume | fmoddyn |
FSOUND_SetVolumeAbsolute | fmoddyn |
FSOUND_StopSound | fmoddyn |
FSOUND_Stream_AddSyncPoint | fmoddyn |
FSOUND_Stream_Close | fmoddyn |
FSOUND_Stream_Create | fmoddyn |
FSOUND_Stream_CreateDSP | fmoddyn |
FSOUND_Stream_DeleteSyncPoint | fmoddyn |
FSOUND_Stream_FindTagField | fmoddyn |
FSOUND_Stream_GetLength | fmoddyn |
FSOUND_Stream_GetLengthMs | fmoddyn |
FSOUND_Stream_GetMode | fmoddyn |
FSOUND_Stream_GetNumSubStreams | fmoddyn |
FSOUND_Stream_GetNumSyncPoints | fmoddyn |
FSOUND_Stream_GetNumTagFields | fmoddyn |
FSOUND_Stream_GetOpenState | fmoddyn |
FSOUND_Stream_GetPosition | fmoddyn |
FSOUND_Stream_GetSample | fmoddyn |
FSOUND_Stream_GetSyncPoint | fmoddyn |
FSOUND_Stream_GetSyncPointInfo | fmoddyn |
FSOUND_Stream_GetTagField | fmoddyn |
FSOUND_Stream_GetTime | fmoddyn |
FSOUND_Stream_Net_GetBufferProperties | fmoddyn |
FSOUND_Stream_Net_GetLastServerStatus | fmoddyn |
FSOUND_Stream_Net_GetStatus | fmoddyn |
FSOUND_Stream_Net_SetBufferProperties | fmoddyn |
FSOUND_Stream_Net_SetMetadataCallback | fmoddyn |
FSOUND_Stream_Net_SetProxy | fmoddyn |
FSOUND_Stream_Open | fmoddyn |
FSOUND_Stream_Play | fmoddyn |
FSOUND_Stream_PlayEx | fmoddyn |
FSOUND_Stream_SetBufferSize | fmoddyn |
FSOUND_Stream_SetEndCallback | fmoddyn |
FSOUND_Stream_SetLoopCount | fmoddyn |
FSOUND_Stream_SetLoopPoints | fmoddyn |
FSOUND_Stream_SetMode | fmoddyn |
FSOUND_Stream_SetPosition | fmoddyn |
FSOUND_Stream_SetSubStream | fmoddyn |
FSOUND_Stream_SetSubStreamSentence | fmoddyn |
FSOUND_Stream_SetSyncCallback | fmoddyn |
FSOUND_Stream_SetTime | fmoddyn |
FSOUND_Stream_Stop | fmoddyn |
FSOUND_Update | fmoddyn |
FTC_CMapCache_Lookup | LIBFREETYPE |
FTC_CMapCache_New | LIBFREETYPE |
FTC_ImageCache_Lookup | LIBFREETYPE |
FTC_ImageCache_LookupScaler | LIBFREETYPE |
FTC_ImageCache_New | LIBFREETYPE |
FTC_Manager_Done | LIBFREETYPE |
FTC_Manager_LookupFace | LIBFREETYPE |
FTC_Manager_LookupSize | LIBFREETYPE |
FTC_Manager_New | LIBFREETYPE |
FTC_Manager_RemoveFaceID | LIBFREETYPE |
FTC_Manager_Reset | LIBFREETYPE |
FTC_Node_Unref | LIBFREETYPE |
FTC_SBitCache_Lookup | LIBFREETYPE |
FTC_SBitCache_LookupScaler | LIBFREETYPE |
FTC_SBitCache_New | LIBFREETYPE |
FT_Activate_Size | LIBFREETYPE |
FT_Add_Default_Modules | LIBFREETYPE |
FT_Add_Module | LIBFREETYPE |
FT_Angle_Diff | LIBFREETYPE |
FT_Atan2 | LIBFREETYPE |
FT_Attach_File | LIBFREETYPE |
FT_Attach_Stream | LIBFREETYPE |
FT_Bitmap_Convert | LIBFREETYPE |
FT_Bitmap_Copy | LIBFREETYPE |
FT_Bitmap_Done | LIBFREETYPE |
FT_Bitmap_Embolden | LIBFREETYPE |
FT_Bitmap_New | LIBFREETYPE |
FT_CeilFix | LIBFREETYPE |
FT_ClassicKern_Free | LIBFREETYPE |
FT_ClassicKern_Validate | LIBFREETYPE |
FT_Cos | LIBFREETYPE |
FT_DivFix | LIBFREETYPE |
FT_Done_Face | LIBFREETYPE |
FT_Done_FreeType | LIBFREETYPE |
FT_Done_Glyph | LIBFREETYPE |
FT_Done_Library | LIBFREETYPE |
FT_Done_Size | LIBFREETYPE |
FT_Face_CheckTrueTypePatents | LIBFREETYPE |
FT_Face_SetUnpatentedHinting | LIBFREETYPE |
FT_FloorFix | LIBFREETYPE |
FT_Get_Charmap_Index | LIBFREETYPE |
FT_Get_Char_Index | LIBFREETYPE |
FT_Get_CMap_Format | LIBFREETYPE |
FT_Get_CMap_Language_ID | LIBFREETYPE |
FT_Get_First_Char | LIBFREETYPE |
FT_Get_Glyph | LIBFREETYPE |
FT_Get_Glyph_Name | LIBFREETYPE |
FT_Get_Kerning | LIBFREETYPE |
FT_Get_MM_Var | LIBFREETYPE |
FT_Get_Module | LIBFREETYPE |
FT_Get_Multi_Master | LIBFREETYPE |
FT_Get_Name_Index | LIBFREETYPE |
FT_Get_Next_Char | LIBFREETYPE |
FT_Get_PFR_Advance | LIBFREETYPE |
FT_Get_PFR_Kerning | LIBFREETYPE |
FT_Get_PFR_Metrics | LIBFREETYPE |
FT_Get_Postscript_Name | LIBFREETYPE |
FT_Get_PS_Font_Info | LIBFREETYPE |
FT_Get_PS_Font_Private | LIBFREETYPE |
FT_Get_Renderer | LIBFREETYPE |
FT_Get_Sfnt_Name | LIBFREETYPE |
FT_Get_Sfnt_Name_Count | LIBFREETYPE |
FT_Get_Sfnt_Table | LIBFREETYPE |
FT_Get_SubGlyph_Info | LIBFREETYPE |
FT_Get_Track_Kerning | LIBFREETYPE |
FT_Get_TrueType_Engine_Type | LIBFREETYPE |
FT_Get_WinFNT_Header | LIBFREETYPE |
FT_GlyphSlot_Embolden | LIBFREETYPE |
FT_GlyphSlot_Oblique | LIBFREETYPE |
FT_GlyphSlot_Own_Bitmap | LIBFREETYPE |
FT_Glyph_Copy | LIBFREETYPE |
FT_Glyph_Get_CBox | LIBFREETYPE |
FT_Glyph_Stroke | LIBFREETYPE |
FT_Glyph_StrokeBorder | LIBFREETYPE |
FT_Glyph_To_Bitmap | LIBFREETYPE |
FT_Glyph_Transform | LIBFREETYPE |
FT_Has_PS_Glyph_Names | LIBFREETYPE |
FT_Init_FreeType | LIBFREETYPE |
FT_Library_Version | LIBFREETYPE |
FT_List_Add | LIBFREETYPE |
FT_List_Finalize | LIBFREETYPE |
FT_List_Find | LIBFREETYPE |
FT_List_Insert | LIBFREETYPE |
FT_List_Iterate | LIBFREETYPE |
FT_List_Remove | LIBFREETYPE |
FT_List_Up | LIBFREETYPE |
FT_Load_Char | LIBFREETYPE |
FT_Load_Glyph | LIBFREETYPE |
FT_Load_Sfnt_Table | LIBFREETYPE |
FT_Matrix_Invert | LIBFREETYPE |
FT_Matrix_Multiply | LIBFREETYPE |
FT_MulDiv | LIBFREETYPE |
FT_MulFix | LIBFREETYPE |
FT_New_Face | LIBFREETYPE |
FT_New_Library | LIBFREETYPE |
FT_New_Memory_Face | LIBFREETYPE |
FT_New_Size | LIBFREETYPE |
FT_OpenType_Free | LIBFREETYPE |
FT_OpenType_Validate | LIBFREETYPE |
FT_Open_Face | LIBFREETYPE |
FT_Outline_Check | LIBFREETYPE |
FT_Outline_Copy | LIBFREETYPE |
FT_Outline_Decompose | LIBFREETYPE |
FT_Outline_Done | LIBFREETYPE |
FT_Outline_Done_Internal | LIBFREETYPE |
FT_Outline_Embolden | LIBFREETYPE |
FT_Outline_GetInsideBorder | LIBFREETYPE |
FT_Outline_GetOutsideBorder | LIBFREETYPE |
FT_Outline_Get_BBox | LIBFREETYPE |
FT_Outline_Get_Bitmap | LIBFREETYPE |
FT_Outline_Get_CBox | LIBFREETYPE |
FT_Outline_Get_Orientation | LIBFREETYPE |
FT_Outline_New | LIBFREETYPE |
FT_Outline_New_Internal | LIBFREETYPE |
FT_Outline_Render | LIBFREETYPE |
FT_Outline_Reverse | LIBFREETYPE |
FT_Outline_Transform | LIBFREETYPE |
FT_Outline_Translate | LIBFREETYPE |
FT_Remove_Module | LIBFREETYPE |
FT_Render_Glyph | LIBFREETYPE |
FT_Request_Size | LIBFREETYPE |
FT_RoundFix | LIBFREETYPE |
FT_Select_Charmap | LIBFREETYPE |
FT_Select_Size | LIBFREETYPE |
FT_Set_Charmap | LIBFREETYPE |
FT_Set_Char_Size | LIBFREETYPE |
FT_Set_Debug_Hook | LIBFREETYPE |
FT_Set_MM_Blend_Coordinates | LIBFREETYPE |
FT_Set_MM_Design_Coordinates | LIBFREETYPE |
FT_Set_Pixel_Sizes | LIBFREETYPE |
FT_Set_Renderer | LIBFREETYPE |
FT_Set_Transform | LIBFREETYPE |
FT_Set_Var_Blend_Coordinates | LIBFREETYPE |
FT_Set_Var_Design_Coordinates | LIBFREETYPE |
FT_Sfnt_Table_Info | LIBFREETYPE |
FT_Sin | LIBFREETYPE |
FT_Stream_OpenGzip | LIBFREETYPE |
FT_Stream_OpenLZW | LIBFREETYPE |
FT_Stroker_BeginSubPath | LIBFREETYPE |
FT_Stroker_ConicTo | LIBFREETYPE |
FT_Stroker_CubicTo | LIBFREETYPE |
FT_Stroker_Done | LIBFREETYPE |
FT_Stroker_EndSubPath | LIBFREETYPE |
FT_Stroker_Export | LIBFREETYPE |
FT_Stroker_ExportBorder | LIBFREETYPE |
FT_Stroker_GetBorderCounts | LIBFREETYPE |
FT_Stroker_GetCounts | LIBFREETYPE |
FT_Stroker_LineTo | LIBFREETYPE |
FT_Stroker_New | LIBFREETYPE |
FT_Stroker_ParseOutline | LIBFREETYPE |
FT_Stroker_Rewind | LIBFREETYPE |
FT_Stroker_Set | LIBFREETYPE |
FT_Tan | LIBFREETYPE |
FT_TrueTypeGX_Free | LIBFREETYPE |
FT_TrueTypeGX_Validate | LIBFREETYPE |
FT_Vector_From_Polar | LIBFREETYPE |
FT_Vector_Length | LIBFREETYPE |
FT_Vector_Polarize | LIBFREETYPE |
FT_Vector_Rotate | LIBFREETYPE |
FT_Vector_Transform | LIBFREETYPE |
FT_Vector_Unit | LIBFREETYPE |
get_crc_table | GLSZLibExApi |
glActiveShaderProgram | OpenGL1x |
glActiveStencilFaceEXT | OpenGL1x |
glActiveTexture | OpenGL1x |
glActiveTextureARB | OpenGL1x |
glActiveVaryingNV | OpenGL1x |
glAddSwapHintRectWIN | OpenGL1x |
glAreProgramsResidentNV | OpenGL1x |
glAreTexturesResidentEXT | OpenGL1x |
glArrayElementArrayEXT | OpenGL1x |
glAttachObjectARB | OpenGL1x |
glAttachShader | OpenGL1x |
glBeginConditionalRender | OpenGL1x |
glBeginConditionalRenderNV | OpenGL1x |
glBeginOcclusionQueryNV | OpenGL1x |
glBeginQuery | OpenGL1x |
glBeginQueryARB | OpenGL1x |
glBeginQueryIndexed | OpenGL1x |
glBeginSceneEXT | OpenGL1x |
glBeginTransformFeedback | OpenGL1x |
glBeginTransformFeedbackEXT | OpenGL1x |
glBeginTransformFeedbackNV | OpenGL1x |
glBindAttribLocation | OpenGL1x |
glBindAttribLocationARB | OpenGL1x |
glBindBuffer | OpenGL1x |
glBindBufferARB | OpenGL1x |
glBindBufferBase | OpenGL1x |
glBindBufferBaseEXT | OpenGL1x |
glBindBufferBaseNV | OpenGL1x |
glBindBufferOffsetEXT | OpenGL1x |
glBindBufferOffsetNV | OpenGL1x |
glBindBufferRange | OpenGL1x |
glBindBufferRangeEXT | OpenGL1x |
glBindBufferRangeNV | OpenGL1x |
glBindFragDataLocation | OpenGL1x |
glBindFragDataLocationEXT | OpenGL1x |
glBindFragDataLocationIndexed | OpenGL1x |
glBindFramebuffer | OpenGL1x |
glBindFramebufferEXT | OpenGL1x |
glBindProgramARB | OpenGL1x |
glBindProgramNV | OpenGL1x |
glBindProgramPipeline | OpenGL1x |
glBindRenderbuffer | OpenGL1x |
glBindRenderbufferEXT | OpenGL1x |
glBindSampler | OpenGL1x |
glBindTextureEXT | OpenGL1x |
glBindTransformFeedback | OpenGL1x |
glBindVertexArray | OpenGL1x |
glBlendColor | OpenGL1x |
glBlendColorEXT | OpenGL1x |
glBlendEquation | OpenGL1x |
glBlendEquationEXT | OpenGL1x |
glBlendEquationi | OpenGL1x |
glBlendEquationiARB | OpenGL1x |
glBlendEquationSeparate | OpenGL1x |
glBlendEquationSeparateEXT | OpenGL1x |
glBlendEquationSeparatei | OpenGL1x |
glBlendEquationSeparateiARB | OpenGL1x |
glBlendFunci | OpenGL1x |
glBlendFunciARB | OpenGL1x |
glBlendFuncSeparate | OpenGL1x |
glBlendFuncSeparateEXT | OpenGL1x |
glBlendFuncSeparatei | OpenGL1x |
glBlendFuncSeparateiARB | OpenGL1x |
glBlitFramebuffer | OpenGL1x |
glBlitFramebufferEXT | OpenGL1x |
glBufferAddressRangeNV | OpenGL1x |
glBufferData | OpenGL1x |
glBufferDataARB | OpenGL1x |
glBufferSubData | OpenGL1x |
glBufferSubDataARB | OpenGL1x |
glCheckFramebufferStatus | OpenGL1x |
glCheckFramebufferStatusEXT | OpenGL1x |
glClampColor | OpenGL1x |
glClampColorARB | OpenGL1x |
glClearBufferfi | OpenGL1x |
glClearBufferfv | OpenGL1x |
glClearBufferiv | OpenGL1x |
glClearBufferuiv | OpenGL1x |
glClearColorIiEXT | OpenGL1x |
glClearColorIuiEXT | OpenGL1x |
glClearDepthf | OpenGL1x |
glClientActiveTexture | OpenGL1x |
glClientActiveTextureARB | OpenGL1x |
glClientWaitSync | OpenGL1x |
glColorFormatNV | OpenGL1x |
glColorMaski | OpenGL1x |
glColorMaskIndexedEXT | OpenGL1x |
glColorP3ui | OpenGL1x |
glColorP3uiv | OpenGL1x |
glColorP4ui | OpenGL1x |
glColorP4uiv | OpenGL1x |
glColorSubTable | OpenGL1x |
glColorSubTableExt | OpenGL1x |
glColorTable | OpenGL1x |
glColorTableEXT | OpenGL1x |
glColorTableParameterfv | OpenGL1x |
glColorTableParameteriv | OpenGL1x |
glCombinerInputNV | OpenGL1x |
glCombinerOutputNV | OpenGL1x |
glCombinerParameterfNV | OpenGL1x |
glCombinerParameterfvNV | OpenGL1x |
glCombinerParameteriNV | OpenGL1x |
glCombinerParameterivNV | OpenGL1x |
glCompileShader | OpenGL1x |
glCompileShaderARB | OpenGL1x |
glCompressedTexImage1D | OpenGL1x |
glCompressedTexImage1DARB | OpenGL1x |
glCompressedTexImage2D | OpenGL1x |
glCompressedTexImage2DARB | OpenGL1x |
glCompressedTexImage3D | OpenGL1x |
glCompressedTexImage3DARB | OpenGL1x |
glCompressedTexSubImage1D | OpenGL1x |
glCompressedTexSubImage1DARB | OpenGL1x |
glCompressedTexSubImage2D | OpenGL1x |
glCompressedTexSubImage2DARB | OpenGL1x |
glCompressedTexSubImage3D | OpenGL1x |
glCompressedTexSubImage3DARB | OpenGL1x |
GLContextManager | GLContext |
glConvolutionFilter1D | OpenGL1x |
glConvolutionFilter2D | OpenGL1x |
glConvolutionParameterf | OpenGL1x |
glConvolutionParameterfv | OpenGL1x |
glConvolutionParameteri | OpenGL1x |
glConvolutionParameteriv | OpenGL1x |
glCopyBufferSubData | OpenGL1x |
glCopyColorSubTable | OpenGL1x |
glCopyColorTable | OpenGL1x |
glCopyConvolutionFilter1D | OpenGL1x |
glCopyConvolutionFilter2D | OpenGL1x |
glCopyImageSubDataNV | OpenGL1x |
glCopyTexImage1DEXT | OpenGL1x |
glCopyTexImage2DEXT | OpenGL1x |
glCopyTexSubImage1DEXT | OpenGL1x |
glCopyTexSubImage2DEXT | OpenGL1x |
glCopyTexSubImage3D | OpenGL1x |
glCopyTexSubImage3DEXT | OpenGL1x |
glCreateProgram | OpenGL1x |
glCreateProgramObjectARB | OpenGL1x |
glCreateShader | OpenGL1x |
glCreateShaderObjectARB | OpenGL1x |
glCreateShaderProgramv | OpenGL1x |
glCurrentPaletteMatrixARB | OpenGL1x |
glDebugMessageCallbackARB | OpenGL1x |
glDebugMessageControlARB | OpenGL1x |
glDebugMessageInsertARB | OpenGL1x |
glDeleteBuffers | OpenGL1x |
glDeleteBuffersARB | OpenGL1x |
glDeleteFencesNV | OpenGL1x |
glDeleteFramebuffers | OpenGL1x |
glDeleteFramebuffersEXT | OpenGL1x |
glDeleteObjectARB | OpenGL1x |
glDeleteOcclusionQueriesNV | OpenGL1x |
glDeleteProgram | OpenGL1x |
glDeleteProgramPipelines | OpenGL1x |
glDeleteProgramsARB | OpenGL1x |
glDeleteProgramsNV | OpenGL1x |
glDeleteQueries | OpenGL1x |
glDeleteQueriesARB | OpenGL1x |
glDeleteRenderbuffers | OpenGL1x |
glDeleteRenderbuffersEXT | OpenGL1x |
glDeleteSamplers | OpenGL1x |
glDeleteShader | OpenGL1x |
glDeleteSync | OpenGL1x |
glDeleteTexturesEXT | OpenGL1x |
glDeleteTransformFeedbacks | OpenGL1x |
glDeleteVertexArrays | OpenGL1x |
glDepthBoundsEXT | OpenGL1x |
glDepthRangeArrayv | OpenGL1x |
glDepthRangef | OpenGL1x |
glDepthRangeIndexed | OpenGL1x |
glDetachObjectARB | OpenGL1x |
glDetachShader | OpenGL1x |
glDisablei | OpenGL1x |
glDisableIndexedEXT | OpenGL1x |
glDisableVertexAttribArray | OpenGL1x |
glDisableVertexAttribArrayARB | OpenGL1x |
glDrawArraysIndirect | OpenGL1x |
glDrawArraysInstanced | OpenGL1x |
glDrawArraysInstancedARB | OpenGL1x |
glDrawArraysInstancedEXT | OpenGL1x |
glDrawBuffers | OpenGL1x |
glDrawBuffersARB | OpenGL1x |
glDrawBuffersATI | OpenGL1x |
glDrawElementsBaseVertex | OpenGL1x |
glDrawElementsIndirect | OpenGL1x |
glDrawElementsInstanced | OpenGL1x |
glDrawElementsInstancedARB | OpenGL1x |
glDrawElementsInstancedBaseVertex | OpenGL1x |
glDrawElementsInstancedEXT | OpenGL1x |
glDrawRangeElements | OpenGL1x |
glDrawRangeElementsBaseVertex | OpenGL1x |
glDrawRangeElementsEXT | OpenGL1x |
glDrawTransformFeedback | OpenGL1x |
glDrawTransformFeedbackStream | OpenGL1x |
glEdgeFlagFormatNV | OpenGL1x |
glEnablei | OpenGL1x |
glEnableIndexedEXT | OpenGL1x |
glEnableVertexAttribArray | OpenGL1x |
glEnableVertexAttribArrayARB | OpenGL1x |
glEndConditionalRender | OpenGL1x |
glEndConditionalRenderNV | OpenGL1x |
glEndOcclusionQueryNV | OpenGL1x |
glEndQuery | OpenGL1x |
glEndQueryARB | OpenGL1x |
glEndQueryIndexed | OpenGL1x |
glEndSceneEXT | OpenGL1x |
glEndTransformFeedback | OpenGL1x |
glEndTransformFeedbackEXT | OpenGL1x |
glEndTransformFeedbackNV | OpenGL1x |
glExecuteProgramNV | OpenGL1x |
glFenceSync | OpenGL1x |
glFinalCombinerInputNV | OpenGL1x |
glFinishFenceNV | OpenGL1x |
glFlushMappedBufferRange | OpenGL1x |
glFlushVertexArrayRangeNV | OpenGL1x |
glFogCoordd | OpenGL1x |
glFogCoorddEXT | OpenGL1x |
glFogCoorddv | OpenGL1x |
glFogCoorddvEXT | OpenGL1x |
glFogCoordf | OpenGL1x |
glFogCoordfEXT | OpenGL1x |
glFogCoordFormatNV | OpenGL1x |
glFogCoordfv | OpenGL1x |
glFogCoordfvEXT | OpenGL1x |
glFogCoordPointer | OpenGL1x |
glFogCoordPointerEXT | OpenGL1x |
glFramebufferRenderbuffer | OpenGL1x |
glFramebufferRenderbufferEXT | OpenGL1x |
glFramebufferTexture | OpenGL1x |
glFramebufferTexture1D | OpenGL1x |
glFramebufferTexture1DEXT | OpenGL1x |
glFramebufferTexture2D | OpenGL1x |
glFramebufferTexture2DEXT | OpenGL1x |
glFramebufferTexture3D | OpenGL1x |
glFramebufferTexture3DEXT | OpenGL1x |
glFramebufferTextureARB | OpenGL1x |
glFramebufferTextureEXT | OpenGL1x |
glFramebufferTextureFaceARB | OpenGL1x |
glFramebufferTextureFaceEXT | OpenGL1x |
glFramebufferTextureLayer | OpenGL1x |
glFramebufferTextureLayerARB | OpenGL1x |
glFramebufferTextureLayerEXT | OpenGL1x |
glFrameTerminatorGREMEDY | OpenGL1x |
glGenBuffers | OpenGL1x |
glGenBuffersARB | OpenGL1x |
glGenerateMipmap | OpenGL1x |
glGenerateMipmapEXT | OpenGL1x |
glGenFencesNV | OpenGL1x |
glGenFramebuffers | OpenGL1x |
glGenFramebuffersEXT | OpenGL1x |
glGenOcclusionQueriesNV | OpenGL1x |
glGenProgramPipelines | OpenGL1x |
glGenProgramsARB | OpenGL1x |
glGenProgramsNV | OpenGL1x |
glGenQueries | OpenGL1x |
glGenQueriesARB | OpenGL1x |
glGenRenderbuffers | OpenGL1x |
glGenRenderbuffersEXT | OpenGL1x |
glGenSamplers | OpenGL1x |
glGenTexturesEXT | OpenGL1x |
glGenTransformFeedbacks | OpenGL1x |
glGenVertexArrays | OpenGL1x |
glGetActiveAttrib | OpenGL1x |
glGetActiveAttribARB | OpenGL1x |
glGetActiveSubroutineName | OpenGL1x |
glGetActiveSubroutineUniformiv | OpenGL1x |
glGetActiveSubroutineUniformName | OpenGL1x |
glGetActiveUniform | OpenGL1x |
glGetActiveUniformARB | OpenGL1x |
glGetActiveUniformBlockiv | OpenGL1x |
glGetActiveUniformBlockName | OpenGL1x |
glGetActiveUniformName | OpenGL1x |
glGetActiveUniformsiv | OpenGL1x |
glGetActiveVaryingNV | OpenGL1x |
glGetAttachedObjectsARB | OpenGL1x |
glGetAttachedShaders | OpenGL1x |
glGetAttribLocation | OpenGL1x |
glGetAttribLocationARB | OpenGL1x |
glGetBooleanIndexedvEXT | OpenGL1x |
glGetBooleani_v | OpenGL1x |
glGetBufferParameteri64v | OpenGL1x |
glGetBufferParameteriv | OpenGL1x |
glGetBufferParameterivARB | OpenGL1x |
glGetBufferParameterui64vNV | OpenGL1x |
glGetBufferPointerv | OpenGL1x |
glGetBufferPointervARB | OpenGL1x |
glGetBufferSubData | OpenGL1x |
glGetBufferSubDataARB | OpenGL1x |
glGetColorTable | OpenGL1x |
glGetColorTableEXT | OpenGL1x |
glGetColorTableParameterfv | OpenGL1x |
glGetColorTableParameterfvEXT | OpenGL1x |
glGetColorTableParameteriv | OpenGL1x |
glGetColorTableParameterivEXT | OpenGL1x |
glGetCombinerInputParameterfvNV | OpenGL1x |
glGetCombinerInputParameterivNV | OpenGL1x |
glGetCombinerOutputParameterfvNV | OpenGL1x |
glGetCombinerOutputParameterivNV | OpenGL1x |
glGetCompressedTexImage | OpenGL1x |
glGetCompressedTexImageARB | OpenGL1x |
glGetConvolutionFilter | OpenGL1x |
glGetConvolutionParameterfv | OpenGL1x |
glGetConvolutionParameteriv | OpenGL1x |
glGetDebugMessageLogARB | OpenGL1x |
glGetDoublei_v | OpenGL1x |
glGetFenceivNV | OpenGL1x |
glGetFinalCombinerInputParameterfvNV | OpenGL1x |
glGetFinalCombinerInputParameterivNV | OpenGL1x |
glGetFloati_v | OpenGL1x |
glGetFragDataIndex | OpenGL1x |
glGetFragDataLocation | OpenGL1x |
glGetFragDataLocationEXT | OpenGL1x |
glGetFramebufferAttachmentParameteriv | OpenGL1x |
glGetFramebufferAttachmentParameterivEXT | OpenGL1x |
glGetGraphicsResetStatusARB | OpenGL1x |
glGetHandleARB | OpenGL1x |
glGetHistogram | OpenGL1x |
glGetHistogramParameterfv | OpenGL1x |
glGetHistogramParameteriv | OpenGL1x |
glGetInfoLogARB | OpenGL1x |
glGetInteger64i_v | OpenGL1x |
glGetInteger64v | OpenGL1x |
glGetIntegerIndexedvEXT | OpenGL1x |
glGetIntegeri_v | OpenGL1x |
glGetIntegerui64i_vNV | OpenGL1x |
glGetIntegerui64vNV | OpenGL1x |
glGetMinmax | OpenGL1x |
glGetMinmaxParameterfv | OpenGL1x |
glGetMinmaxParameteriv | OpenGL1x |
glGetMultisamplefv | OpenGL1x |
glGetNamedBufferParameterui64vNV | OpenGL1x |
glGetnColorTableARB | OpenGL1x |
glGetnCompressedTexImageARB | OpenGL1x |
glGetnConvolutionFilterARB | OpenGL1x |
glGetnHistogramARB | OpenGL1x |
glGetnMapdvARB | OpenGL1x |
glGetnMapfvARB | OpenGL1x |
glGetnMapivARB | OpenGL1x |
glGetnMinmaxARB | OpenGL1x |
glGetnPixelMapfvARB | OpenGL1x |
glGetnPixelMapuivARB | OpenGL1x |
glGetnPixelMapusvARB | OpenGL1x |
glGetnPolygonStippleARB | OpenGL1x |
glGetnSeparableFilterARB | OpenGL1x |
glGetnTexImageARB | OpenGL1x |
glGetnUniformdvARB | OpenGL1x |
glGetnUniformfvARB | OpenGL1x |
glGetnUniformivARB | OpenGL1x |
glGetnUniformuivARB | OpenGL1x |
glGetObjectParameterfvARB | OpenGL1x |
glGetObjectParameterivARB | OpenGL1x |
glGetOcclusionQueryivNV | OpenGL1x |
glGetOcclusionQueryuivNV | OpenGL1x |
glGetProgramBinary | OpenGL1x |
glGetProgramEnvParameterdvARB | OpenGL1x |
glGetProgramEnvParameterfvARB | OpenGL1x |
glGetProgramInfoLog | OpenGL1x |
glGetProgramiv | OpenGL1x |
glGetProgramivARB | OpenGL1x |
glGetProgramivNV | OpenGL1x |
glGetProgramLocalParameterdvARB | OpenGL1x |
glGetProgramLocalParameterfvARB | OpenGL1x |
glGetProgramParameterdvNV | OpenGL1x |
glGetProgramParameterfvNV | OpenGL1x |
glGetProgramPipelineInfoLog | OpenGL1x |
glGetProgramPipelineiv | OpenGL1x |
glGetProgramStageiv | OpenGL1x |
glGetProgramStringARB | OpenGL1x |
glGetProgramStringNV | OpenGL1x |
glGetQueryIndexediv | OpenGL1x |
glGetQueryiv | OpenGL1x |
glGetQueryivARB | OpenGL1x |
glGetQueryObjecti64v | OpenGL1x |
glGetQueryObjecti64vEXT | OpenGL1x |
glGetQueryObjectiv | OpenGL1x |
glGetQueryObjectivARB | OpenGL1x |
glGetQueryObjectui64v | OpenGL1x |
glGetQueryObjectui64vEXT | OpenGL1x |
glGetQueryObjectuiv | OpenGL1x |
glGetQueryObjectuivARB | OpenGL1x |
glGetRenderbufferParameteriv | OpenGL1x |
glGetRenderbufferParameterivEXT | OpenGL1x |
glGetSamplerParameterfv | OpenGL1x |
glGetSamplerParameterIfv | OpenGL1x |
glGetSamplerParameterIiv | OpenGL1x |
glGetSamplerParameteriv | OpenGL1x |
glGetSeparableFilter | OpenGL1x |
glGetShaderInfoLog | OpenGL1x |
glGetShaderiv | OpenGL1x |
glGetShaderPrecisionFormat | OpenGL1x |
glGetShaderSource | OpenGL1x |
glGetShaderSourceARB | OpenGL1x |
glGetStringi | OpenGL1x |
glGetSubroutineIndex | OpenGL1x |
glGetSubroutineUniformLocation | OpenGL1x |
glGetSynciv | OpenGL1x |
glGetTexParameterIiv | OpenGL1x |
glGetTexParameterIivEXT | OpenGL1x |
glGetTexParameterIuiv | OpenGL1x |
glGetTexParameterIuivEXT | OpenGL1x |
glGetTrackMatrixivNV | OpenGL1x |
glGetTransformFeedbackVarying | OpenGL1x |
glGetTransformFeedbackVaryingEXT | OpenGL1x |
glGetTransformFeedbackVaryingNV | OpenGL1x |
glGetUniformBlockIndex | OpenGL1x |
glGetUniformBufferSizeEXT | OpenGL1x |
glGetUniformdv | OpenGL1x |
glGetUniformfv | OpenGL1x |
glGetUniformfvARB | OpenGL1x |
glGetUniformIndices | OpenGL1x |
glGetUniformiv | OpenGL1x |
glGetUniformivARB | OpenGL1x |
glGetUniformLocation | OpenGL1x |
glGetUniformLocationARB | OpenGL1x |
glGetUniformOffsetEXT | OpenGL1x |
glGetUniformSubroutineuiv | OpenGL1x |
glGetUniformui64vNV | OpenGL1x |
glGetUniformuiv | OpenGL1x |
glGetUniformuivEXT | OpenGL1x |
glGetVaryingLocationNV | OpenGL1x |
glGetVertexAttribdv | OpenGL1x |
glGetVertexAttribdvARB | OpenGL1x |
glGetVertexAttribdvNV | OpenGL1x |
glGetVertexAttribfv | OpenGL1x |
glGetVertexAttribfvARB | OpenGL1x |
glGetVertexAttribfvNV | OpenGL1x |
glGetVertexAttribIiv | OpenGL1x |
glGetVertexAttribIivEXT | OpenGL1x |
glGetVertexAttribIuiv | OpenGL1x |
glGetVertexAttribIuivEXT | OpenGL1x |
glGetVertexAttribiv | OpenGL1x |
glGetVertexAttribivARB | OpenGL1x |
glGetVertexAttribivNV | OpenGL1x |
glGetVertexAttribLdv | OpenGL1x |
glGetVertexAttribPointerv | OpenGL1x |
glGetVertexAttribPointervARB | OpenGL1x |
glGetVertexAttribPointervNV | OpenGL1x |
glHistogram | OpenGL1x |
glIndexFormatNV | OpenGL1x |
glIndexFuncEXT | OpenGL1x |
glIndexMaterialEXT | OpenGL1x |
glIsBuffer | OpenGL1x |
glIsBufferARB | OpenGL1x |
glIsBufferResidentNV | OpenGL1x |
glIsEnabledi | OpenGL1x |
glIsEnabledIndexedEXT | OpenGL1x |
glIsFenceNV | OpenGL1x |
glIsFramebuffer | OpenGL1x |
glIsFramebufferEXT | OpenGL1x |
glIsNamedBufferResidentNV | OpenGL1x |
glIsOcclusionQueryNV | OpenGL1x |
glIsProgram | OpenGL1x |
glIsProgramARB | OpenGL1x |
glIsProgramNV | OpenGL1x |
glIsProgramPipeline | OpenGL1x |
glIsQuery | OpenGL1x |
glIsQueryARB | OpenGL1x |
glIsRenderbuffer | OpenGL1x |
glIsRenderbufferEXT | OpenGL1x |
glIsSampler | OpenGL1x |
glIsShader | OpenGL1x |
glIsSync | OpenGL1x |
glIsTextureEXT | OpenGL1x |
glIsTransformFeedback | OpenGL1x |
glIsVertexArray | OpenGL1x |
glLinkProgram | OpenGL1x |
glLinkProgramARB | OpenGL1x |
glLoadProgramNV | OpenGL1x |
glLoadTransposeMatrixd | OpenGL1x |
glLoadTransposeMatrixdARB | OpenGL1x |
glLoadTransposeMatrixf | OpenGL1x |
glLoadTransposeMatrixfARB | OpenGL1x |
glLockArraysEXT | OpenGL1x |
glMakeBufferNonResidentNV | OpenGL1x |
glMakeBufferResidentNV | OpenGL1x |
glMakeNamedBufferNonResidentNV | OpenGL1x |
glMakeNamedBufferResidentNV | OpenGL1x |
glMapBuffer | OpenGL1x |
glMapBufferARB | OpenGL1x |
glMapBufferRange | OpenGL1x |
glMatrixIndexPointerARB | OpenGL1x |
glMatrixIndexubvARB | OpenGL1x |
glMatrixIndexuivARB | OpenGL1x |
glMatrixIndexusvARB | OpenGL1x |
glMinmax | OpenGL1x |
glMinSampleShading | OpenGL1x |
glMinSampleShadingARB | OpenGL1x |
glMultiDrawArrays | OpenGL1x |
glMultiDrawArraysEXT | OpenGL1x |
glMultiDrawElements | OpenGL1x |
glMultiDrawElementsBaseVertex | OpenGL1x |
glMultiDrawElementsEXT | OpenGL1x |
glMultiTexCoord1d | OpenGL1x |
glMultiTexCoord1dARB | OpenGL1x |
glMultiTexCoord1dV | OpenGL1x |
glMultiTexCoord1dVARB | OpenGL1x |
glMultiTexCoord1f | OpenGL1x |
glMultiTexCoord1fARB | OpenGL1x |
glMultiTexCoord1fV | OpenGL1x |
glMultiTexCoord1fVARB | OpenGL1x |
glMultiTexCoord1i | OpenGL1x |
glMultiTexCoord1iARB | OpenGL1x |
glMultiTexCoord1iV | OpenGL1x |
glMultiTexCoord1iVARB | OpenGL1x |
glMultiTexCoord1s | OpenGL1x |
glMultiTexCoord1sARB | OpenGL1x |
glMultiTexCoord1sV | OpenGL1x |
glMultiTexCoord1sVARB | OpenGL1x |
glMultiTexCoord2d | OpenGL1x |
glMultiTexCoord2dARB | OpenGL1x |
glMultiTexCoord2dv | OpenGL1x |
glMultiTexCoord2dvARB | OpenGL1x |
glMultiTexCoord2f | OpenGL1x |
glMultiTexCoord2fARB | OpenGL1x |
glMultiTexCoord2fv | OpenGL1x |
glMultiTexCoord2fvARB | OpenGL1x |
glMultiTexCoord2i | OpenGL1x |
glMultiTexCoord2iARB | OpenGL1x |
glMultiTexCoord2iv | OpenGL1x |
glMultiTexCoord2ivARB | OpenGL1x |
glMultiTexCoord2s | OpenGL1x |
glMultiTexCoord2sARB | OpenGL1x |
glMultiTexCoord2sv | OpenGL1x |
glMultiTexCoord2svARB | OpenGL1x |
glMultiTexCoord3d | OpenGL1x |
glMultiTexCoord3dARB | OpenGL1x |
glMultiTexCoord3dv | OpenGL1x |
glMultiTexCoord3dvARB | OpenGL1x |
glMultiTexCoord3f | OpenGL1x |
glMultiTexCoord3fARB | OpenGL1x |
glMultiTexCoord3fv | OpenGL1x |
glMultiTexCoord3fvARB | OpenGL1x |
glMultiTexCoord3i | OpenGL1x |
glMultiTexCoord3iARB | OpenGL1x |
glMultiTexCoord3iv | OpenGL1x |
glMultiTexCoord3ivARB | OpenGL1x |
glMultiTexCoord3s | OpenGL1x |
glMultiTexCoord3sARB | OpenGL1x |
glMultiTexCoord3sv | OpenGL1x |
glMultiTexCoord3svARB | OpenGL1x |
glMultiTexCoord4d | OpenGL1x |
glMultiTexCoord4dARB | OpenGL1x |
glMultiTexCoord4dv | OpenGL1x |
glMultiTexCoord4dvARB | OpenGL1x |
glMultiTexCoord4f | OpenGL1x |
glMultiTexCoord4fARB | OpenGL1x |
glMultiTexCoord4fv | OpenGL1x |
glMultiTexCoord4fvARB | OpenGL1x |
glMultiTexCoord4i | OpenGL1x |
glMultiTexCoord4iARB | OpenGL1x |
glMultiTexCoord4iv | OpenGL1x |
glMultiTexCoord4ivARB | OpenGL1x |
glMultiTexCoord4s | OpenGL1x |
glMultiTexCoord4sARB | OpenGL1x |
glMultiTexCoord4sv | OpenGL1x |
glMultiTexCoord4svARB | OpenGL1x |
glMultiTexCoordP1ui | OpenGL1x |
glMultiTexCoordP1uiv | OpenGL1x |
glMultiTexCoordP2ui | OpenGL1x |
glMultiTexCoordP2uiv | OpenGL1x |
glMultiTexCoordP3ui | OpenGL1x |
glMultiTexCoordP3uiv | OpenGL1x |
glMultiTexCoordP4ui | OpenGL1x |
glMultiTexCoordP4uiv | OpenGL1x |
glMultTransposeMatrixd | OpenGL1x |
glMultTransposeMatrixdARB | OpenGL1x |
glMultTransposeMatrixf | OpenGL1x |
glMultTransposeMatrixfARB | OpenGL1x |
glNormalFormatNV | OpenGL1x |
glNormalP3ui | OpenGL1x |
glNormalP3uiv | OpenGL1x |
glPatchParameterfv | OpenGL1x |
glPatchParameteri | OpenGL1x |
glPauseTransformFeedback | OpenGL1x |
glPointParameterf | OpenGL1x |
glPointParameterfARB | OpenGL1x |
glPointParameterfv | OpenGL1x |
glPointParameterfvARB | OpenGL1x |
glPointParameteri | OpenGL1x |
glPointParameteriNV | OpenGL1x |
glPointParameteriv | OpenGL1x |
glPointParameterivNV | OpenGL1x |
glPolygonOffsetEXT | OpenGL1x |
glPrimitiveRestartIndex | OpenGL1x |
glPrimitiveRestartIndexNV | OpenGL1x |
glPrimitiveRestartNV | OpenGL1x |
glPrioritizeTexturesEXT | OpenGL1x |
glProgramBinary | OpenGL1x |
glProgramEnvParameter4dARB | OpenGL1x |
glProgramEnvParameter4dvARB | OpenGL1x |
glProgramEnvParameter4fARB | OpenGL1x |
glProgramEnvParameter4fvARB | OpenGL1x |
glProgramEnvParameters4fvEXT | OpenGL1x |
glProgramLocalParameter4dARB | OpenGL1x |
glProgramLocalParameter4dvARB | OpenGL1x |
glProgramLocalParameter4fARB | OpenGL1x |
glProgramLocalParameter4fvARB | OpenGL1x |
glProgramLocalParameters4fvEXT | OpenGL1x |
glProgramParameter4dNV | OpenGL1x |
glProgramParameter4dvNV | OpenGL1x |
glProgramParameter4fNV | OpenGL1x |
glProgramParameter4fvNV | OpenGL1x |
glProgramParameteri | OpenGL1x |
glProgramParameteriARB | OpenGL1x |
glProgramParameteriEXT | OpenGL1x |
glProgramParameters4dvNV | OpenGL1x |
glProgramParameters4fvNV | OpenGL1x |
glProgramStringARB | OpenGL1x |
glProgramUniform1d | OpenGL1x |
glProgramUniform1dEXT | OpenGL1x |
glProgramUniform1dv | OpenGL1x |
glProgramUniform1dvEXT | OpenGL1x |
glProgramUniform1f | OpenGL1x |
glProgramUniform1fv | OpenGL1x |
glProgramUniform1i | OpenGL1x |
glProgramUniform1iv | OpenGL1x |
glProgramUniform1ui | OpenGL1x |
glProgramUniform1uiv | OpenGL1x |
glProgramUniform2d | OpenGL1x |
glProgramUniform2dEXT | OpenGL1x |
glProgramUniform2dv | OpenGL1x |
glProgramUniform2dvEXT | OpenGL1x |
glProgramUniform2f | OpenGL1x |
glProgramUniform2fv | OpenGL1x |
glProgramUniform2i | OpenGL1x |
glProgramUniform2iv | OpenGL1x |
glProgramUniform2ui | OpenGL1x |
glProgramUniform2uiv | OpenGL1x |
glProgramUniform3d | OpenGL1x |
glProgramUniform3dEXT | OpenGL1x |
glProgramUniform3dv | OpenGL1x |
glProgramUniform3dvEXT | OpenGL1x |
glProgramUniform3f | OpenGL1x |
glProgramUniform3fv | OpenGL1x |
glProgramUniform3i | OpenGL1x |
glProgramUniform3iv | OpenGL1x |
glProgramUniform3ui | OpenGL1x |
glProgramUniform3uiv | OpenGL1x |
glProgramUniform4d | OpenGL1x |
glProgramUniform4dEXT | OpenGL1x |
glProgramUniform4dv | OpenGL1x |
glProgramUniform4dvEXT | OpenGL1x |
glProgramUniform4f | OpenGL1x |
glProgramUniform4fv | OpenGL1x |
glProgramUniform4i | OpenGL1x |
glProgramUniform4iv | OpenGL1x |
glProgramUniform4ui | OpenGL1x |
glProgramUniform4uiv | OpenGL1x |
glProgramUniformMatrix2dv | OpenGL1x |
glProgramUniformMatrix2dvEXT | OpenGL1x |
glProgramUniformMatrix2fv | OpenGL1x |
glProgramUniformMatrix2x3dv | OpenGL1x |
glProgramUniformMatrix2x3dvEXT | OpenGL1x |
glProgramUniformMatrix2x3fv | OpenGL1x |
glProgramUniformMatrix2x4dv | OpenGL1x |
glProgramUniformMatrix2x4dvEXT | OpenGL1x |
glProgramUniformMatrix2x4fv | OpenGL1x |
glProgramUniformMatrix3dv | OpenGL1x |
glProgramUniformMatrix3dvEXT | OpenGL1x |
glProgramUniformMatrix3fv | OpenGL1x |
glProgramUniformMatrix3x2dv | OpenGL1x |
glProgramUniformMatrix3x2dvEXT | OpenGL1x |
glProgramUniformMatrix3x2fv | OpenGL1x |
glProgramUniformMatrix3x4dv | OpenGL1x |
glProgramUniformMatrix3x4dvEXT | OpenGL1x |
glProgramUniformMatrix3x4fv | OpenGL1x |
glProgramUniformMatrix4dv | OpenGL1x |
glProgramUniformMatrix4dvEXT | OpenGL1x |
glProgramUniformMatrix4fv | OpenGL1x |
glProgramUniformMatrix4x2dv | OpenGL1x |
glProgramUniformMatrix4x2dvEXT | OpenGL1x |
glProgramUniformMatrix4x2fv | OpenGL1x |
glProgramUniformMatrix4x3dv | OpenGL1x |
glProgramUniformMatrix4x3dvEXT | OpenGL1x |
glProgramUniformMatrix4x3fv | OpenGL1x |
glProgramUniformui64NV | OpenGL1x |
glProgramUniformui64vNV | OpenGL1x |
glProgramVertexLimitNV | OpenGL1x |
glProvokingVertex | OpenGL1x |
glQueryCounter | OpenGL1x |
glReadnPixelsARB | OpenGL1x |
glReleaseShaderCompiler | OpenGL1x |
glRenderbufferStorage | OpenGL1x |
glRenderbufferStorageEXT | OpenGL1x |
glRenderbufferStorageMultisample | OpenGL1x |
glRenderbufferStorageMultisampleEXT | OpenGL1x |
glRequestResidentProgramsNV | OpenGL1x |
glResetHistogram | OpenGL1x |
glResetMinmax | OpenGL1x |
glResizeBuffersMESA | OpenGL1x |
glResumeTransformFeedback | OpenGL1x |
glSampleCoverage | OpenGL1x |
glSampleCoverageARB | OpenGL1x |
glSampleMaskEXT | OpenGL1x |
glSampleMaski | OpenGL1x |
glSampleMaskSGIS | OpenGL1x |
glSamplePassARB | OpenGL1x |
glSamplePatternEXT | OpenGL1x |
glSamplePatternSGIS | OpenGL1x |
glSamplerParameterf | OpenGL1x |
glSamplerParameterfv | OpenGL1x |
glSamplerParameteri | OpenGL1x |
glSamplerParameterIiv | OpenGL1x |
glSamplerParameterIuiv | OpenGL1x |
glSamplerParameteriv | OpenGL1x |
glScissorArrayv | OpenGL1x |
glScissorIndexed | OpenGL1x |
glScissorIndexedv | OpenGL1x |
glSecondaryColor3b | OpenGL1x |
glSecondaryColor3bEXT | OpenGL1x |
glSecondaryColor3bv | OpenGL1x |
glSecondaryColor3bvEXT | OpenGL1x |
glSecondaryColor3d | OpenGL1x |
glSecondaryColor3dEXT | OpenGL1x |
glSecondaryColor3dv | OpenGL1x |
glSecondaryColor3dvEXT | OpenGL1x |
glSecondaryColor3f | OpenGL1x |
glSecondaryColor3fEXT | OpenGL1x |
glSecondaryColor3fv | OpenGL1x |
glSecondaryColor3fvEXT | OpenGL1x |
glSecondaryColor3i | OpenGL1x |
glSecondaryColor3iEXT | OpenGL1x |
glSecondaryColor3iv | OpenGL1x |
glSecondaryColor3ivEXT | OpenGL1x |
glSecondaryColor3s | OpenGL1x |
glSecondaryColor3sEXT | OpenGL1x |
glSecondaryColor3sv | OpenGL1x |
glSecondaryColor3svEXT | OpenGL1x |
glSecondaryColor3ub | OpenGL1x |
glSecondaryColor3ubEXT | OpenGL1x |
glSecondaryColor3ubv | OpenGL1x |
glSecondaryColor3ubvEXT | OpenGL1x |
glSecondaryColor3ui | OpenGL1x |
glSecondaryColor3uiEXT | OpenGL1x |
glSecondaryColor3uiv | OpenGL1x |
glSecondaryColor3uivEXT | OpenGL1x |
glSecondaryColor3us | OpenGL1x |
glSecondaryColor3usEXT | OpenGL1x |
glSecondaryColor3usv | OpenGL1x |
glSecondaryColor3usvEXT | OpenGL1x |
glSecondaryColorFormatNV | OpenGL1x |
glSecondaryColorP3ui | OpenGL1x |
glSecondaryColorP3uiv | OpenGL1x |
glSecondaryColorPointer | OpenGL1x |
glSecondaryColorPointerEXT | OpenGL1x |
glSeparableFilter2D | OpenGL1x |
glSetFenceNV | OpenGL1x |
glShaderBinary | OpenGL1x |
glShaderSource | OpenGL1x |
glShaderSourceARB | OpenGL1x |
glStencilClearTagEXT | OpenGL1x |
glStencilFuncSeparate | OpenGL1x |
glStencilMaskSeparate | OpenGL1x |
glStencilOpSeparate | OpenGL1x |
glStringMarkerGREMEDY | OpenGL1x |
glTbufferMask3DFX | OpenGL1x |
glTessellationFactorAMD | OpenGL1x |
glTessellationModeAMD | OpenGL1x |
glTestFenceNV | OpenGL1x |
glTexBuffer | OpenGL1x |
glTexBufferARB | OpenGL1x |
glTexBufferEXT | OpenGL1x |
glTexCoordFormatNV | OpenGL1x |
glTexCoordP1ui | OpenGL1x |
glTexCoordP1uiv | OpenGL1x |
glTexCoordP2ui | OpenGL1x |
glTexCoordP2uiv | OpenGL1x |
glTexCoordP3ui | OpenGL1x |
glTexCoordP3uiv | OpenGL1x |
glTexCoordP4ui | OpenGL1x |
glTexCoordP4uiv | OpenGL1x |
glTexImage2DMultisample | OpenGL1x |
glTexImage3D | OpenGL1x |
glTexImage3DEXT | OpenGL1x |
glTexImage3DMultisample | OpenGL1x |
glTexParameterIiv | OpenGL1x |
glTexParameterIivEXT | OpenGL1x |
glTexParameterIuiv | OpenGL1x |
glTexParameterIuivEXT | OpenGL1x |
glTexSubImage1DEXT | OpenGL1x |
glTexSubImage2DEXT | OpenGL1x |
glTexSubImage3D | OpenGL1x |
glTexSubImage3DEXT | OpenGL1x |
glTextureColorMaskSGIS | OpenGL1x |
glTrackMatrixNV | OpenGL1x |
glTransformFeedbackAttribsNV | OpenGL1x |
glTransformFeedbackVaryings | OpenGL1x |
glTransformFeedbackVaryingsEXT | OpenGL1x |
glTransformFeedbackVaryingsNV | OpenGL1x |
gluDeleteNurbsTessellatorEXT | OpenGL1x |
gluNewNurbsTessellatorEXT | OpenGL1x |
glUniform1d | OpenGL1x |
glUniform1dv | OpenGL1x |
glUniform1f | OpenGL1x |
glUniform1fARB | OpenGL1x |
glUniform1fv | OpenGL1x |
glUniform1fvARB | OpenGL1x |
glUniform1i | OpenGL1x |
glUniform1iARB | OpenGL1x |
glUniform1iv | OpenGL1x |
glUniform1ivARB | OpenGL1x |
glUniform1ui | OpenGL1x |
glUniform1uiEXT | OpenGL1x |
glUniform1uiv | OpenGL1x |
glUniform1uivEXT | OpenGL1x |
glUniform2d | OpenGL1x |
glUniform2dv | OpenGL1x |
glUniform2f | OpenGL1x |
glUniform2fARB | OpenGL1x |
glUniform2fv | OpenGL1x |
glUniform2fvARB | OpenGL1x |
glUniform2i | OpenGL1x |
glUniform2iARB | OpenGL1x |
glUniform2iv | OpenGL1x |
glUniform2ivARB | OpenGL1x |
glUniform2ui | OpenGL1x |
glUniform2uiEXT | OpenGL1x |
glUniform2uiv | OpenGL1x |
glUniform2uivEXT | OpenGL1x |
glUniform3d | OpenGL1x |
glUniform3dv | OpenGL1x |
glUniform3f | OpenGL1x |
glUniform3fARB | OpenGL1x |
glUniform3fv | OpenGL1x |
glUniform3fvARB | OpenGL1x |
glUniform3i | OpenGL1x |
glUniform3iARB | OpenGL1x |
glUniform3iv | OpenGL1x |
glUniform3ivARB | OpenGL1x |
glUniform3ui | OpenGL1x |
glUniform3uiEXT | OpenGL1x |
glUniform3uiv | OpenGL1x |
glUniform3uivEXT | OpenGL1x |
glUniform4d | OpenGL1x |
glUniform4dv | OpenGL1x |
glUniform4f | OpenGL1x |
glUniform4fARB | OpenGL1x |
glUniform4fv | OpenGL1x |
glUniform4fvARB | OpenGL1x |
glUniform4i | OpenGL1x |
glUniform4iARB | OpenGL1x |
glUniform4iv | OpenGL1x |
glUniform4ivARB | OpenGL1x |
glUniform4ui | OpenGL1x |
glUniform4uiEXT | OpenGL1x |
glUniform4uiv | OpenGL1x |
glUniform4uivEXT | OpenGL1x |
glUniformBlockBinding | OpenGL1x |
glUniformBufferEXT | OpenGL1x |
glUniformMatrix2dv | OpenGL1x |
glUniformMatrix2fv | OpenGL1x |
glUniformMatrix2fvARB | OpenGL1x |
glUniformMatrix2x3dv | OpenGL1x |
glUniformMatrix2x3fv | OpenGL1x |
glUniformMatrix2x4dv | OpenGL1x |
glUniformMatrix2x4fv | OpenGL1x |
glUniformMatrix3dv | OpenGL1x |
glUniformMatrix3fv | OpenGL1x |
glUniformMatrix3fvARB | OpenGL1x |
glUniformMatrix3x2dv | OpenGL1x |
glUniformMatrix3x2fv | OpenGL1x |
glUniformMatrix3x4dv | OpenGL1x |
glUniformMatrix3x4fv | OpenGL1x |
glUniformMatrix4dv | OpenGL1x |
glUniformMatrix4fv | OpenGL1x |
glUniformMatrix4fvARB | OpenGL1x |
glUniformMatrix4x2dv | OpenGL1x |
glUniformMatrix4x2fv | OpenGL1x |
glUniformMatrix4x3dv | OpenGL1x |
glUniformMatrix4x3fv | OpenGL1x |
glUniformSubroutinesuiv | OpenGL1x |
glUniformui64NV | OpenGL1x |
glUniformui64vNV | OpenGL1x |
glUnlockArraysEXT | OpenGL1x |
glUnmapBuffer | OpenGL1x |
glUnmapBufferARB | OpenGL1x |
gluNurbsCallbackDataEXT | OpenGL1x |
glUseProgram | OpenGL1x |
glUseProgramObjectARB | OpenGL1x |
glUseProgramStages | OpenGL1x |
GLU_EXT_nurbs_tessellator | OpenGL1x |
GLU_EXT_object_space_tess | OpenGL1x |
GLU_EXT_Texture | OpenGL1x |
GLU_VERSION_1_1 | OpenGL1x |
GLU_VERSION_1_2 | OpenGL1x |
GLU_VERSION_1_3 | OpenGL1x |
glValidateProgram | OpenGL1x |
glValidateProgramARB | OpenGL1x |
glValidateProgramPipeline | OpenGL1x |
glVertexArrayRangeNV | OpenGL1x |
glVertexArrayVertexAttribLOffsetEXT | OpenGL1x |
glVertexAttrib1d | OpenGL1x |
glVertexAttrib1dARB | OpenGL1x |
glVertexAttrib1dNV | OpenGL1x |
glVertexAttrib1dv | OpenGL1x |
glVertexAttrib1dvARB | OpenGL1x |
glVertexAttrib1dvNV | OpenGL1x |
glVertexAttrib1f | OpenGL1x |
glVertexAttrib1fARB | OpenGL1x |
glVertexAttrib1fNV | OpenGL1x |
glVertexAttrib1fv | OpenGL1x |
glVertexAttrib1fvARB | OpenGL1x |
glVertexAttrib1fvNV | OpenGL1x |
glVertexAttrib1s | OpenGL1x |
glVertexAttrib1sARB | OpenGL1x |
glVertexAttrib1sNV | OpenGL1x |
glVertexAttrib1sv | OpenGL1x |
glVertexAttrib1svARB | OpenGL1x |
glVertexAttrib1svNV | OpenGL1x |
glVertexAttrib2d | OpenGL1x |
glVertexAttrib2dARB | OpenGL1x |
glVertexAttrib2dNV | OpenGL1x |
glVertexAttrib2dv | OpenGL1x |
glVertexAttrib2dvARB | OpenGL1x |
glVertexAttrib2dvNV | OpenGL1x |
glVertexAttrib2f | OpenGL1x |
glVertexAttrib2fARB | OpenGL1x |
glVertexAttrib2fNV | OpenGL1x |
glVertexAttrib2fv | OpenGL1x |
glVertexAttrib2fvARB | OpenGL1x |
glVertexAttrib2fvNV | OpenGL1x |
glVertexAttrib2s | OpenGL1x |
glVertexAttrib2sARB | OpenGL1x |
glVertexAttrib2sNV | OpenGL1x |
glVertexAttrib2sv | OpenGL1x |
glVertexAttrib2svARB | OpenGL1x |
glVertexAttrib2svNV | OpenGL1x |
glVertexAttrib3d | OpenGL1x |
glVertexAttrib3dARB | OpenGL1x |
glVertexAttrib3dNV | OpenGL1x |
glVertexAttrib3dv | OpenGL1x |
glVertexAttrib3dvARB | OpenGL1x |
glVertexAttrib3dvNV | OpenGL1x |
glVertexAttrib3f | OpenGL1x |
glVertexAttrib3fARB | OpenGL1x |
glVertexAttrib3fNV | OpenGL1x |
glVertexAttrib3fv | OpenGL1x |
glVertexAttrib3fvARB | OpenGL1x |
glVertexAttrib3fvNV | OpenGL1x |
glVertexAttrib3s | OpenGL1x |
glVertexAttrib3sARB | OpenGL1x |
glVertexAttrib3sNV | OpenGL1x |
glVertexAttrib3sv | OpenGL1x |
glVertexAttrib3svARB | OpenGL1x |
glVertexAttrib3svNV | OpenGL1x |
glVertexAttrib4bv | OpenGL1x |
glVertexAttrib4bvARB | OpenGL1x |
glVertexAttrib4d | OpenGL1x |
glVertexAttrib4dARB | OpenGL1x |
glVertexAttrib4dNV | OpenGL1x |
glVertexAttrib4dv | OpenGL1x |
glVertexAttrib4dvARB | OpenGL1x |
glVertexAttrib4dvNV | OpenGL1x |
glVertexAttrib4f | OpenGL1x |
glVertexAttrib4fARB | OpenGL1x |
glVertexAttrib4fNV | OpenGL1x |
glVertexAttrib4fv | OpenGL1x |
glVertexAttrib4fvARB | OpenGL1x |
glVertexAttrib4fvNV | OpenGL1x |
glVertexAttrib4iv | OpenGL1x |
glVertexAttrib4ivARB | OpenGL1x |
glVertexAttrib4Nbv | OpenGL1x |
glVertexAttrib4NbvARB | OpenGL1x |
glVertexAttrib4Niv | OpenGL1x |
glVertexAttrib4NivARB | OpenGL1x |
glVertexAttrib4Nsv | OpenGL1x |
glVertexAttrib4NsvARB | OpenGL1x |
glVertexAttrib4Nub | OpenGL1x |
glVertexAttrib4NubARB | OpenGL1x |
glVertexAttrib4Nubv | OpenGL1x |
glVertexAttrib4NubvARB | OpenGL1x |
glVertexAttrib4Nuiv | OpenGL1x |
glVertexAttrib4NuivARB | OpenGL1x |
glVertexAttrib4Nusv | OpenGL1x |
glVertexAttrib4NusvARB | OpenGL1x |
glVertexAttrib4s | OpenGL1x |
glVertexAttrib4sARB | OpenGL1x |
glVertexAttrib4sNV | OpenGL1x |
glVertexAttrib4sv | OpenGL1x |
glVertexAttrib4svARB | OpenGL1x |
glVertexAttrib4svNV | OpenGL1x |
glVertexAttrib4ubv | OpenGL1x |
glVertexAttrib4ubvARB | OpenGL1x |
glVertexAttrib4ubvNV | OpenGL1x |
glVertexAttrib4uiv | OpenGL1x |
glVertexAttrib4uivARB | OpenGL1x |
glVertexAttrib4usv | OpenGL1x |
glVertexAttrib4usvARB | OpenGL1x |
glVertexAttribDivisor | OpenGL1x |
glVertexAttribDivisorARB | OpenGL1x |
glVertexAttribFormatNV | OpenGL1x |
glVertexAttribI1i | OpenGL1x |
glVertexAttribI1iEXT | OpenGL1x |
glVertexAttribI1iv | OpenGL1x |
glVertexAttribI1ivEXT | OpenGL1x |
glVertexAttribI1ui | OpenGL1x |
glVertexAttribI1uiEXT | OpenGL1x |
glVertexAttribI1uiv | OpenGL1x |
glVertexAttribI1uivEXT | OpenGL1x |
glVertexAttribI2i | OpenGL1x |
glVertexAttribI2iEXT | OpenGL1x |
glVertexAttribI2iv | OpenGL1x |
glVertexAttribI2ivEXT | OpenGL1x |
glVertexAttribI2ui | OpenGL1x |
glVertexAttribI2uiEXT | OpenGL1x |
glVertexAttribI2uiv | OpenGL1x |
glVertexAttribI2uivEXT | OpenGL1x |
glVertexAttribI3i | OpenGL1x |
glVertexAttribI3iEXT | OpenGL1x |
glVertexAttribI3iv | OpenGL1x |
glVertexAttribI3ivEXT | OpenGL1x |
glVertexAttribI3ui | OpenGL1x |
glVertexAttribI3uiEXT | OpenGL1x |
glVertexAttribI3uiv | OpenGL1x |
glVertexAttribI3uivEXT | OpenGL1x |
glVertexAttribI4bv | OpenGL1x |
glVertexAttribI4bvEXT | OpenGL1x |
glVertexAttribI4i | OpenGL1x |
glVertexAttribI4iEXT | OpenGL1x |
glVertexAttribI4iv | OpenGL1x |
glVertexAttribI4ivEXT | OpenGL1x |
glVertexAttribI4sv | OpenGL1x |
glVertexAttribI4svEXT | OpenGL1x |
glVertexAttribI4ubv | OpenGL1x |
glVertexAttribI4ubvEXT | OpenGL1x |
glVertexAttribI4ui | OpenGL1x |
glVertexAttribI4uiEXT | OpenGL1x |
glVertexAttribI4uiv | OpenGL1x |
glVertexAttribI4uivEXT | OpenGL1x |
glVertexAttribI4usv | OpenGL1x |
glVertexAttribI4usvEXT | OpenGL1x |
glVertexAttribIFormatNV | OpenGL1x |
glVertexAttribIPointer | OpenGL1x |
glVertexAttribIPointerEXT | OpenGL1x |
glVertexAttribL1d | OpenGL1x |
glVertexAttribL1dv | OpenGL1x |
glVertexAttribL2d | OpenGL1x |
glVertexAttribL2dv | OpenGL1x |
glVertexAttribL3d | OpenGL1x |
glVertexAttribL3dv | OpenGL1x |
glVertexAttribL4d | OpenGL1x |
glVertexAttribL4dv | OpenGL1x |
glVertexAttribLPointer | OpenGL1x |
glVertexAttribP1ui | OpenGL1x |
glVertexAttribP1uiv | OpenGL1x |
glVertexAttribP2ui | OpenGL1x |
glVertexAttribP2uiv | OpenGL1x |
glVertexAttribP3ui | OpenGL1x |
glVertexAttribP3uiv | OpenGL1x |
glVertexAttribP4ui | OpenGL1x |
glVertexAttribP4uiv | OpenGL1x |
glVertexAttribPointer | OpenGL1x |
glVertexAttribPointerARB | OpenGL1x |
glVertexAttribPointerNV | OpenGL1x |
glVertexAttribs1dvNV | OpenGL1x |
glVertexAttribs1fvNV | OpenGL1x |
glVertexAttribs1svNV | OpenGL1x |
glVertexAttribs2dvNV | OpenGL1x |
glVertexAttribs2fvNV | OpenGL1x |
glVertexAttribs2svNV | OpenGL1x |
glVertexAttribs3dvNV | OpenGL1x |
glVertexAttribs3fvNV | OpenGL1x |
glVertexAttribs3svNV | OpenGL1x |
glVertexAttribs4dvNV | OpenGL1x |
glVertexAttribs4fvNV | OpenGL1x |
glVertexAttribs4svNV | OpenGL1x |
glVertexAttribs4ubvNV | OpenGL1x |
glVertexBlendARB | OpenGL1x |
glVertexFormatNV | OpenGL1x |
glVertexP2ui | OpenGL1x |
glVertexP2uiv | OpenGL1x |
glVertexP3ui | OpenGL1x |
glVertexP3uiv | OpenGL1x |
glVertexP4ui | OpenGL1x |
glVertexP4uiv | OpenGL1x |
glViewportArrayv | OpenGL1x |
glViewportIndexedf | OpenGL1x |
glViewportIndexedfv | OpenGL1x |
glWaitSync | OpenGL1x |
glWeightbvARB | OpenGL1x |
glWeightdvARB | OpenGL1x |
glWeightfvARB | OpenGL1x |
glWeightivARB | OpenGL1x |
glWeightPointerARB | OpenGL1x |
glWeightsvARB | OpenGL1x |
glWeightubvARB | OpenGL1x |
glWeightuivARB | OpenGL1x |
glWeightusvARB | OpenGL1x |
glWindowPos2d | OpenGL1x |
glWindowPos2dARB | OpenGL1x |
glWindowPos2dv | OpenGL1x |
glWindowPos2dvARB | OpenGL1x |
glWindowPos2f | OpenGL1x |
glWindowPos2fARB | OpenGL1x |
glWindowPos2fv | OpenGL1x |
glWindowPos2fvARB | OpenGL1x |
glWindowPos2i | OpenGL1x |
glWindowPos2iARB | OpenGL1x |
glWindowPos2iv | OpenGL1x |
glWindowPos2ivARB | OpenGL1x |
glWindowPos2s | OpenGL1x |
glWindowPos2sARB | OpenGL1x |
glWindowPos2sv | OpenGL1x |
glWindowPos2svARB | OpenGL1x |
glWindowPos3d | OpenGL1x |
glWindowPos3dARB | OpenGL1x |
glWindowPos3dv | OpenGL1x |
glWindowPos3dvARB | OpenGL1x |
glWindowPos3f | OpenGL1x |
glWindowPos3fARB | OpenGL1x |
glWindowPos3fv | OpenGL1x |
glWindowPos3fvARB | OpenGL1x |
glWindowPos3i | OpenGL1x |
glWindowPos3iARB | OpenGL1x |
glWindowPos3iv | OpenGL1x |
glWindowPos3ivARB | OpenGL1x |
glWindowPos3s | OpenGL1x |
glWindowPos3sARB | OpenGL1x |
glWindowPos3sv | OpenGL1x |
glWindowPos3svARB | OpenGL1x |
GLX_3DFX_multisample | OpenGL1x |
GLX_ARB_create_context | OpenGL1x |
GLX_ARB_create_context_profile | OpenGL1x |
GLX_ARB_framebuffer_sRGB | OpenGL1x |
GLX_ARB_multisample | OpenGL1x |
GLX_EXT_fbconfig_packed_float | OpenGL1x |
GLX_EXT_framebuffer_sRGB | OpenGL1x |
GLX_EXT_import_context | OpenGL1x |
GLX_EXT_visual_info | OpenGL1x |
GLX_EXT_visual_rating | OpenGL1x |
GLX_MESA_copy_sub_buffer | OpenGL1x |
GLX_MESA_pixmap_colormap | OpenGL1x |
GLX_MESA_release_buffers | OpenGL1x |
GLX_MESA_set_3dfx_mode | OpenGL1x |
GLX_SGIS_blended_overlay | OpenGL1x |
GLX_SGIS_multisample | OpenGL1x |
GLX_SGIS_shared_multisample | OpenGL1x |
GLX_SGIX_dmbuffer | OpenGL1x |
GLX_SGIX_fbconfig | OpenGL1x |
GLX_SGIX_hyperpipe | OpenGL1x |
GLX_SGIX_pbuffer | OpenGL1x |
GLX_SGIX_swap_barrier | OpenGL1x |
GLX_SGIX_swap_group | OpenGL1x |
GLX_SGIX_video_resize | OpenGL1x |
GLX_SGIX_video_source | OpenGL1x |
GLX_SGIX_visual_select_group | OpenGL1x |
GLX_SGI_cushion | OpenGL1x |
GLX_SGI_make_current_read | OpenGL1x |
GLX_SGI_swap_control | OpenGL1x |
GLX_SGI_video_sync | OpenGL1x |
GLX_SUN_get_transparent_index | OpenGL1x |
GLX_VERSION_1_1 | OpenGL1x |
GLX_VERSION_1_2 | OpenGL1x |
GLX_VERSION_1_3 | OpenGL1x |
GLX_VERSION_1_4 | OpenGL1x |
GL_3DFX_multisample | OpenGL1x |
GL_3DFX_tbuffer | OpenGL1x |
GL_3DFX_texture_compression_FXT1 | OpenGL1x |
GL_AMD_vertex_shader_tessellator | OpenGL1x |
GL_ARB_blend_func_extended | OpenGL1x |
GL_ARB_color_buffer_float | OpenGL1x |
GL_ARB_compatibility | OpenGL1x |
GL_ARB_copy_buffer | OpenGL1x |
GL_ARB_debug_output | OpenGL1x |
GL_ARB_depth_buffer_float | OpenGL1x |
GL_ARB_depth_clamp | OpenGL1x |
GL_ARB_depth_texture | OpenGL1x |
GL_ARB_draw_buffers | OpenGL1x |
GL_ARB_draw_buffers_blend | OpenGL1x |
GL_ARB_draw_elements_base_vertex | OpenGL1x |
GL_ARB_draw_indirect | OpenGL1x |
GL_ARB_draw_instanced | OpenGL1x |
GL_ARB_ES2_compatibility | OpenGL1x |
GL_ARB_explicit_attrib_location | OpenGL1x |
GL_ARB_fragment_coord_conventions | OpenGL1x |
GL_ARB_fragment_program | OpenGL1x |
GL_ARB_fragment_program_shadow | OpenGL1x |
GL_ARB_fragment_shader | OpenGL1x |
GL_ARB_framebuffer_object | OpenGL1x |
GL_ARB_framebuffer_sRGB | OpenGL1x |
GL_ARB_geometry_shader4 | OpenGL1x |
GL_ARB_get_program_binary | OpenGL1x |
GL_ARB_gpu_shader5 | OpenGL1x |
GL_ARB_gpu_shader_fp64 | OpenGL1x |
GL_ARB_half_float_pixel | OpenGL1x |
GL_ARB_half_float_vertex | OpenGL1x |
GL_ARB_imaging | OpenGL1x |
GL_ARB_instanced_arrays | OpenGL1x |
GL_ARB_map_buffer_range | OpenGL1x |
GL_ARB_matrix_palette | OpenGL1x |
GL_ARB_multisample | OpenGL1x |
GL_ARB_multitexture | OpenGL1x |
GL_ARB_occlusion_query | OpenGL1x |
GL_ARB_occlusion_query2 | OpenGL1x |
GL_ARB_pixel_buffer_object | OpenGL1x |
GL_ARB_point_parameters | OpenGL1x |
GL_ARB_point_sprite | OpenGL1x |
GL_ARB_provoking_vertex | OpenGL1x |
GL_ARB_robustness | OpenGL1x |
GL_ARB_sampler_objects | OpenGL1x |
GL_ARB_sample_shading | OpenGL1x |
GL_ARB_seamless_cube_map | OpenGL1x |
GL_ARB_separate_shader_objects | OpenGL1x |
GL_ARB_shader_bit_encoding | OpenGL1x |
GL_ARB_shader_objects | OpenGL1x |
GL_ARB_shader_precision | OpenGL1x |
GL_ARB_shader_stencil_export | OpenGL1x |
GL_ARB_shader_subroutine | OpenGL1x |
GL_ARB_shader_texture_lod | OpenGL1x |
GL_ARB_shading_language_100 | OpenGL1x |
GL_ARB_shadow | OpenGL1x |
GL_ARB_shadow_ambient | OpenGL1x |
GL_ARB_sync | OpenGL1x |
GL_ARB_tessellation_shader | OpenGL1x |
GL_ARB_texture_border_clamp | OpenGL1x |
GL_ARB_texture_buffer_object | OpenGL1x |
GL_ARB_texture_buffer_object_rgb32 | OpenGL1x |
GL_ARB_texture_compression | OpenGL1x |
GL_ARB_texture_compression_bptc | OpenGL1x |
GL_ARB_texture_compression_rgtc | OpenGL1x |
GL_ARB_texture_cube_map | OpenGL1x |
GL_ARB_texture_cube_map_array | OpenGL1x |
GL_ARB_texture_env_add | OpenGL1x |
GL_ARB_texture_env_combine | OpenGL1x |
GL_ARB_texture_env_crossbar | OpenGL1x |
GL_ARB_texture_env_dot3 | OpenGL1x |
GL_ARB_texture_float | OpenGL1x |
GL_ARB_texture_gather | OpenGL1x |
GL_ARB_texture_mirrored_repeat | OpenGL1x |
GL_ARB_texture_multisample | OpenGL1x |
GL_ARB_texture_non_power_of_two | OpenGL1x |
GL_ARB_texture_query_lod | OpenGL1x |
GL_ARB_texture_rectangle | OpenGL1x |
GL_ARB_texture_rg | OpenGL1x |
GL_ARB_texture_rgb10_a2ui | OpenGL1x |
GL_ARB_texture_swizzle | OpenGL1x |
GL_ARB_timer_query | OpenGL1x |
GL_ARB_transform_feedback2 | OpenGL1x |
GL_ARB_transform_feedback3 | OpenGL1x |
GL_ARB_transpose_matrix | OpenGL1x |
GL_ARB_uniform_buffer_object | OpenGL1x |
GL_ARB_vertex_array_bgra | OpenGL1x |
GL_ARB_vertex_array_object | OpenGL1x |
GL_ARB_vertex_attrib_64bit | OpenGL1x |
GL_ARB_vertex_blend | OpenGL1x |
GL_ARB_vertex_buffer_object | OpenGL1x |
GL_ARB_vertex_program | OpenGL1x |
GL_ARB_vertex_shader | OpenGL1x |
GL_ARB_vertex_type_2_10_10_10_rev | OpenGL1x |
GL_ARB_viewport_array | OpenGL1x |
GL_ARB_window_pos | OpenGL1x |
GL_ATI_draw_buffers | OpenGL1x |
GL_ATI_texture_compression_3dc | OpenGL1x |
GL_ATI_texture_float | OpenGL1x |
GL_ATI_texture_mirror_once | OpenGL1x |
GL_EXT_abgr | OpenGL1x |
GL_EXT_bgra | OpenGL1x |
GL_EXT_bindable_uniform | OpenGL1x |
GL_EXT_blend_color | OpenGL1x |
GL_EXT_blend_equation_separate | OpenGL1x |
GL_EXT_blend_func_separate | OpenGL1x |
GL_EXT_blend_logic_op | OpenGL1x |
GL_EXT_blend_minmax | OpenGL1x |
GL_EXT_blend_subtract | OpenGL1x |
GL_EXT_Cg_shader | OpenGL1x |
GL_EXT_clip_volume_hint | OpenGL1x |
GL_EXT_compiled_vertex_array | OpenGL1x |
GL_EXT_copy_texture | OpenGL1x |
GL_EXT_depth_bounds_test | OpenGL1x |
GL_EXT_draw_buffers2 | OpenGL1x |
GL_EXT_draw_instanced | OpenGL1x |
GL_EXT_draw_range_elements | OpenGL1x |
GL_EXT_fog_coord | OpenGL1x |
GL_EXT_framebuffer_blit | OpenGL1x |
GL_EXT_framebuffer_multisample | OpenGL1x |
GL_EXT_framebuffer_object | OpenGL1x |
GL_EXT_framebuffer_sRGB | OpenGL1x |
GL_EXT_geometry_shader4 | OpenGL1x |
GL_EXT_gpu_program_parameters | OpenGL1x |
GL_EXT_gpu_shader4 | OpenGL1x |
GL_EXT_multisample | OpenGL1x |
GL_EXT_multi_draw_arrays | OpenGL1x |
GL_EXT_packed_depth_stencil | OpenGL1x |
GL_EXT_packed_float | OpenGL1x |
GL_EXT_packed_pixels | OpenGL1x |
GL_EXT_paletted_texture | OpenGL1x |
GL_EXT_pixel_buffer_object | OpenGL1x |
GL_EXT_polygon_offset | OpenGL1x |
GL_EXT_rescale_normal | OpenGL1x |
GL_EXT_secondary_color | OpenGL1x |
GL_EXT_separate_specular_color | OpenGL1x |
GL_EXT_shadow_funcs | OpenGL1x |
GL_EXT_shared_texture_palette | OpenGL1x |
GL_EXT_stencil_clear_tag | OpenGL1x |
GL_EXT_stencil_two_side | OpenGL1x |
GL_EXT_stencil_wrap | OpenGL1x |
GL_EXT_texture3D | OpenGL1x |
GL_EXT_texture_array | OpenGL1x |
GL_EXT_texture_buffer_object | OpenGL1x |
GL_EXT_texture_compression_latc | OpenGL1x |
GL_EXT_texture_compression_rgtc | OpenGL1x |
GL_EXT_texture_compression_s3tc | OpenGL1x |
GL_EXT_texture_cube_map | OpenGL1x |
GL_EXT_texture_edge_clamp | OpenGL1x |
GL_EXT_texture_env_add | OpenGL1x |
GL_EXT_texture_env_combine | OpenGL1x |
GL_EXT_texture_env_dot3 | OpenGL1x |
GL_EXT_texture_filter_anisotropic | OpenGL1x |
GL_EXT_texture_integer | OpenGL1x |
GL_EXT_texture_lod | OpenGL1x |
GL_EXT_texture_lod_bias | OpenGL1x |
GL_EXT_texture_mirror_clamp | OpenGL1x |
GL_EXT_texture_object | OpenGL1x |
GL_EXT_texture_rectangle | OpenGL1x |
GL_EXT_texture_shared_exponent | OpenGL1x |
GL_EXT_texture_sRGB | OpenGL1x |
GL_EXT_timer_query | OpenGL1x |
GL_EXT_transform_feedback | OpenGL1x |
GL_EXT_vertex_array | OpenGL1x |
GL_GREMEDY_frame_terminator | OpenGL1x |
GL_GREMEDY_string_marker | OpenGL1x |
GL_HP_occlusion_test | OpenGL1x |
GL_IBM_rasterpos_clip | OpenGL1x |
GL_KTX_buffer_region | OpenGL1x |
GL_MESA_resize_buffers | OpenGL1x |
GL_NV_blend_square | OpenGL1x |
GL_NV_conditional_render | OpenGL1x |
GL_NV_copy_image | OpenGL1x |
GL_NV_depth_buffer_float | OpenGL1x |
GL_NV_fence | OpenGL1x |
GL_NV_float_buffer | OpenGL1x |
GL_NV_fog_distance | OpenGL1x |
GL_NV_geometry_program4 | OpenGL1x |
GL_NV_light_max_exponent | OpenGL1x |
GL_NV_multisample_filter_hint | OpenGL1x |
GL_NV_occlusion_query | OpenGL1x |
GL_NV_point_sprite | OpenGL1x |
GL_NV_primitive_restart | OpenGL1x |
GL_NV_register_combiners | OpenGL1x |
GL_NV_shader_buffer_load | OpenGL1x |
GL_NV_texgen_reflection | OpenGL1x |
GL_NV_texture_compression_vtc | OpenGL1x |
GL_NV_texture_env_combine4 | OpenGL1x |
GL_NV_texture_rectangle | OpenGL1x |
GL_NV_texture_shader | OpenGL1x |
GL_NV_texture_shader2 | OpenGL1x |
GL_NV_texture_shader3 | OpenGL1x |
GL_NV_transform_feedback | OpenGL1x |
GL_NV_vertex_array_range | OpenGL1x |
GL_NV_vertex_array_range2 | OpenGL1x |
GL_NV_vertex_buffer_unified_memory | OpenGL1x |
GL_NV_vertex_program | OpenGL1x |
GL_S3_s3tc | OpenGL1x |
GL_SGIS_generate_mipmap | OpenGL1x |
GL_SGIS_multisample | OpenGL1x |
GL_SGIS_texture_border_clamp | OpenGL1x |
GL_SGIS_texture_color_mask | OpenGL1x |
GL_SGIS_texture_edge_clamp | OpenGL1x |
GL_SGIS_texture_lod | OpenGL1x |
GL_SGIX_depth_texture | OpenGL1x |
GL_SGIX_shadow | OpenGL1x |
GL_SGIX_shadow_ambient | OpenGL1x |
GL_SGI_color_matrix | OpenGL1x |
GL_VERSION_1_0 | OpenGL1x |
GL_VERSION_1_1 | OpenGL1x |
GL_VERSION_1_2 | OpenGL1x |
GL_VERSION_1_3 | OpenGL1x |
GL_VERSION_1_4 | OpenGL1x |
GL_VERSION_1_5 | OpenGL1x |
GL_VERSION_2_0 | OpenGL1x |
GL_VERSION_2_1 | OpenGL1x |
GL_VERSION_3_0 | OpenGL1x |
GL_VERSION_3_1 | OpenGL1x |
GL_VERSION_3_2 | OpenGL1x |
GL_VERSION_3_3 | OpenGL1x |
GL_VERSION_4_0 | OpenGL1x |
GL_VERSION_4_1 | OpenGL1x |
GL_WIN_swap_hint | OpenGL1x |
GUISkinEditor | GuiSkinEditorFormUnitLCL |
GUISkinEditor | GuiSkinEditorFormUnit |
IncludeFilePath | GLCgShader | Set IncludeFilePath to indicate where to find your include file for your Cg source files. This avoids error from the Cg Compiler when the current directory is not the right path as the shader is being compiled.
inflate | GLSZLibExApi |
inflateEnd | GLSZLibExApi |
inflateInit2_ | GLSZLibExApi |
inflateInit_ | GLSZLibExApi |
inflateReset | GLSZLibExApi |
inflateSyncPoint | GLSZLibExApi |
IsDesignTime | GLCrossPlatform |
IsODEInitialized | ODEImport |
jpeg_std_error | GLSJPG |
LibHandle | openal |
lkPrefix | GLSLog |
llMessageLimit | GLSLog |
PlugInManagerPropForm | PlugInManagerPropEditor |
TangentAttributeName | GLObjects |
vAFIOCreateFileStream | ApplicationFileIO |
vAFIOFileStreamExists | ApplicationFileIO |
vContextActivationFailureOccurred | GLContext |
vCurrentVideoMode | GLScreen |
vDDSDetailLevel | GLFileDDS | Variable determines which resolution to use textures, high - it loads all levels, midle - skipped the first level, low - skipped the first two levels.
vDefaultMeshOptimizerOptions | GLMeshOptimizer |
vDefaultTextureCompression | GLTextureFormat |
vDefaultTextureFormat | GLTextureFormat |
vdp_device_create_x11 | GLS_VDPAU_X11 |
vEdgeInfoReserveSize | MeshUtils |
vFindCuFileFunc | GLSCUDACompiler |
vFontManagerMsgID | GLSpaceText |
vGhoul2LevelOfDetail | GLFileGL2 |
vGhoul2MaxBonesPerVertex | GLFileGL2 |
vGLFile3DSSceneObjects_RenderCameraAndLights | GLFile3DSSceneObjects |
vGLFile3DS_EnableAnimation | GLFile3DS | If enabled, allows 3ds animation and fixes loading of some 3ds models, but has a few bugs: - TGLFreeForm.AutoCentering does now work correctly. - TMeshObject.vertices return values different from TMeshObject.ExtractTriangles()
vGLFile3DS_FixDefaultUpAxisY | GLFile3DS | If enabled, a -90 degrees (-PI/2) rotation will occured on X Axis. By design 3dsmax has a Z Up-Axis, after the rotation the Up axis will be Y. (Note: you need vGLFile3DS_EnableAnimation = true)
vGLFile3DS_LoadedStaticFrame | GLFile3DS | If >= 0, then the vertices list will be updated with selected frame animation data. (Note: you need vGLFile3DS_EnableAnimation = true). Be aware that in that case animation will not be usable, it is made to be used with a static mesh like GLFreeForm.
vGLFile3DS_UseTextureEx | GLFile3DS | If enabled, advanced parameters will be loaded from a 3ds file (TextureScale, TextureOffset), but it might break backwards compatibility. If disabled, it won't break anything, but some parameters will not be loaded correctly from a 3ds file. Also there is a significant drop in FPS when this option is on (for unknown reasons), so it is off by default.
vGLFileOBJ_SplitMesh | GLFileOBJ | If enabled, main mesh will be splitted into multiple mesh from facegroup data.
vGLFileOCTAllocateMaterials | GLFileOCT |
vGLFileOCTLightmapBrightness | GLFileOCT |
vGLFileOCTLightmapGammaCorrection | GLFileOCT |
vGLFileQ3BSPLoadMaterials | GLFileQ3BSP |
vGLODEObjectRegister | GLODEManager |
vGLODERagdoll_cDensity | GLODERagdoll |
vGLODERagdoll_cMass | GLODERagdoll |
vGLVectorFileObjectsAllocateMaterials | GLVectorFileObjects |
vGLVectorFileObjectsEnableVBOByDefault | GLVectorFileObjects |
vIDELogProc | GLSLog |
vIgnoreOpenGLErrors | GLContext |
vIgnoreOpenGLErrors | OpenGL1x |
vImageScaleFilterWidth | ImageUtils |
vImprovedFixingOpenTriangleEdge | MeshUtils |
vLastWheelDelta | GLKeyboard |
vLocalGL | GLPipelineTransformation |
vMD5TextureExtensions | GLFileMD5 |
vMultitextureCoordinatorClass | GLContext |
vNumberVideoModes | GLScreen |
vProjectTargetName | GLCrossPlatform |
vQ3BSPLightmapBrightness | GLFileQ3BSP |
vQ3BSPLightmapGammaCorrection | GLFileQ3BSP |
vSIMD | VectorGeometry |
vUseDefaultColorSets | GLColor |
VUseDefaultCoordinateSets | GLCoordinates |
vUseWindowTrackingHook | GLWin32Context |
vVerboseGLSMErrors | GLSound |
vVerticalFlipDDS | GLGraphics |
vVideoModes | GLScreen |
wglAllocateMemoryNV | OpenGL1x |
wglBindTexImageARB | OpenGL1x |
wglChoosePixelFormatARB | OpenGL1x |
wglCreateAffinityDCNV | OpenGL1x |
wglCreateBufferRegionARB | OpenGL1x |
wglCreateContextAttribsARB | OpenGL1x |
wglCreatePbufferARB | OpenGL1x |
wglDeleteBufferRegionARB | OpenGL1x |
wglDeleteDCNV | OpenGL1x |
wglDestroyPbufferARB | OpenGL1x |
wglEnumGpuDevicesNV | OpenGL1x |
wglEnumGpusFromAffinityDCNV | OpenGL1x |
wglEnumGpusNV | OpenGL1x |
wglFreeMemoryNV | OpenGL1x |
wglGetCurrentReadDCARB | OpenGL1x |
wglGetExtensionsStringARB | OpenGL1x |
wglGetPbufferDCARB | OpenGL1x |
wglGetPixelFormatAttribfvARB | OpenGL1x |
wglGetPixelFormatAttribivARB | OpenGL1x |
wglGetSwapIntervalEXT | OpenGL1x |
wglMakeContextCurrentARB | OpenGL1x |
wglQueryPbufferARB | OpenGL1x |
wglReleasePbufferDCARB | OpenGL1x |
wglReleaseTexImageARB | OpenGL1x |
wglRestoreBufferRegionARB | OpenGL1x |
wglSaveBufferRegionARB | OpenGL1x |
wglSetPbufferAttribARB | OpenGL1x |
wglSwapIntervalEXT | OpenGL1x |
WGL_ARB_buffer_region | OpenGL1x |
WGL_ARB_create_context | OpenGL1x |
WGL_ARB_create_context_profile | OpenGL1x |
WGL_ARB_extensions_string | OpenGL1x |
WGL_ARB_framebuffer_sRGB | OpenGL1x |
WGL_ARB_make_current_read | OpenGL1x |
WGL_ARB_multisample | OpenGL1x |
WGL_ARB_pbuffer | OpenGL1x |
WGL_ARB_pixel_format | OpenGL1x |
WGL_ARB_pixel_format_float | OpenGL1x |
WGL_ARB_render_texture | OpenGL1x |
WGL_ATI_pixel_format_float | OpenGL1x |
WGL_EXT_framebuffer_sRGB | OpenGL1x |
WGL_EXT_pixel_format_packed_float | OpenGL1x |
WGL_EXT_swap_control | OpenGL1x |
WGL_NV_gpu_affinity | OpenGL1x |
zErrorpchar | GLSZLibExApi |
zlibVersionpchar | GLSZLibExApi |
_png_access_version_number | LIBPNG |
_png_build_grayscale_palette | LIBPNG |
_png_check_sig | LIBPNG |
_png_chunk_error | LIBPNG |
_png_chunk_warning | LIBPNG |
_png_convert_from_struct_tm | LIBPNG |
_png_convert_from_time_t | LIBPNG |
_png_convert_to_rfc1123 | LIBPNG |
_png_create_info_struct | LIBPNG |
_png_create_read_struct | LIBPNG |
_png_create_write_struct | LIBPNG |
_png_data_freer | LIBPNG |
_png_destroy_info_struct | LIBPNG |
_png_destroy_read_struct | LIBPNG |
_png_destroy_write_struct | LIBPNG |
_png_error | LIBPNG |
_png_free | LIBPNG |
_png_free_data | LIBPNG |
_png_get_bit_depth | LIBPNG |
_png_get_bKGD | LIBPNG |
_png_get_channels | LIBPNG |
_png_get_cHRM | LIBPNG |
_png_get_cHRM_fixed | LIBPNG |
_png_get_color_type | LIBPNG |
_png_get_compression_buffer_size | LIBPNG |
_png_get_compression_type | LIBPNG |
_png_get_error_ptr | LIBPNG |
_png_get_filter_type | LIBPNG |
_png_get_gAMA | LIBPNG |
_png_get_gAMA_fixed | LIBPNG |
_png_get_header_ver | LIBPNG |
_png_get_header_version | LIBPNG |
_png_get_hIST | LIBPNG |
_png_get_iCCP | LIBPNG |
_png_get_IHDR | LIBPNG |
_png_get_image_height | LIBPNG |
_png_get_image_width | LIBPNG |
_png_get_interlace_type | LIBPNG |
_png_get_io_ptr | LIBPNG |
_png_get_libpng_ver | LIBPNG |
_png_get_oFFs | LIBPNG |
_png_get_pCAL | LIBPNG |
_png_get_pHYs | LIBPNG |
_png_get_pixels_per_meter | LIBPNG |
_png_get_pixel_aspect_ratio | LIBPNG |
_png_get_PLTE | LIBPNG |
_png_get_progressive_ptr | LIBPNG |
_png_get_rgb_to_gray_status | LIBPNG |
_png_get_rowbytes | LIBPNG |
_png_get_rows | LIBPNG |
_png_get_sBIT | LIBPNG |
_png_get_sCAL | LIBPNG |
_png_get_signature | LIBPNG |
_png_get_sPLT | LIBPNG |
_png_get_sRGB | LIBPNG |
_png_get_text | LIBPNG |
_png_get_tIME | LIBPNG |
_png_get_tRNS | LIBPNG |
_png_get_unknown_chunks | LIBPNG |
_png_get_user_chunk_ptr | LIBPNG |
_png_get_user_transform_ptr | LIBPNG |
_png_get_valid | LIBPNG |
_png_get_x_offset_microns | LIBPNG |
_png_get_x_offset_pixels | LIBPNG |
_png_get_x_pixels_per_meter | LIBPNG |
_png_get_y_offset_microns | LIBPNG |
_png_get_y_offset_pixels | LIBPNG |
_png_get_y_pixels_per_meter | LIBPNG |
_png_info_init | LIBPNG |
_png_init_io | LIBPNG |
_png_malloc | LIBPNG |
_png_memcpy_check | LIBPNG |
_png_memset_check | LIBPNG |
_png_permit_empty_plte | LIBPNG |
_png_process_data | LIBPNG |
_png_progressive_combine_row | LIBPNG |
_png_read_destroy | LIBPNG |
_png_read_end | LIBPNG |
_png_read_image | LIBPNG |
_png_read_info | LIBPNG |
_png_read_png | LIBPNG |
_png_read_row | LIBPNG |
_png_read_rows | LIBPNG |
_png_read_update_info | LIBPNG |
_png_reset_zstream | LIBPNG |
_png_set_background | LIBPNG |
_png_set_bgr | LIBPNG |
_png_set_bKGD | LIBPNG |
_png_set_cHRM | LIBPNG |
_png_set_cHRM_fixed | LIBPNG |
_png_set_compression_buffer_size | LIBPNG |
_png_set_compression_level | LIBPNG |
_png_set_compression_mem_level | LIBPNG |
_png_set_compression_method | LIBPNG |
_png_set_compression_strategy | LIBPNG |
_png_set_compression_window_bits | LIBPNG |
_png_set_crc_action | LIBPNG |
_png_set_dither | LIBPNG |
_png_set_error_fn | LIBPNG |
_png_set_expand | LIBPNG |
_png_set_filler | LIBPNG |
_png_set_filter | LIBPNG |
_png_set_filter_heuristics | LIBPNG |
_png_set_flush | LIBPNG |
_png_set_gAMA | LIBPNG |
_png_set_gAMA_fixed | LIBPNG |
_png_set_gamma | LIBPNG |
_png_set_gray_1_2_4_to_8 | LIBPNG |
_png_set_gray_to_rgb | LIBPNG |
_png_set_hIST | LIBPNG |
_png_set_iCCP | LIBPNG |
_png_set_IHDR | LIBPNG |
_png_set_interlace_handling | LIBPNG |
_png_set_invalid | LIBPNG |
_png_set_invert_alpha | LIBPNG |
_png_set_invert_mono | LIBPNG |
_png_set_keep_unknown_chunks | LIBPNG |
_png_set_oFFs | LIBPNG |
_png_set_packing | LIBPNG |
_png_set_packswap | LIBPNG |
_png_set_palette_to_rgb | LIBPNG |
_png_set_pCAL | LIBPNG |
_png_set_pHYs | LIBPNG |
_png_set_PLTE | LIBPNG |
_png_set_progressive_read_fn | LIBPNG |
_png_set_read_fn | LIBPNG |
_png_set_read_status_fn | LIBPNG |
_png_set_read_user_chunk_fn | LIBPNG |
_png_set_read_user_transform_fn | LIBPNG |
_png_set_rgb_to_gray | LIBPNG |
_png_set_rgb_to_gray_fixed | LIBPNG |
_png_set_rows | LIBPNG |
_png_set_sBIT | LIBPNG |
_png_set_sCAL | LIBPNG |
_png_set_sCAL_s | LIBPNG |
_png_set_shift | LIBPNG |
_png_set_sig_bytes | LIBPNG |
_png_set_sPLT | LIBPNG |
_png_set_sRGB | LIBPNG |
_png_set_sRGB_gAMA_and_cHRM | LIBPNG |
_png_set_strip_16 | LIBPNG |
_png_set_strip_alpha | LIBPNG |
_png_set_swap | LIBPNG |
_png_set_swap_alpha | LIBPNG |
_png_set_text | LIBPNG |
_png_set_tIME | LIBPNG |
_png_set_tRNS | LIBPNG |
_png_set_tRNS_to_alpha | LIBPNG |
_png_set_unknown_chunks | LIBPNG |
_png_set_unknown_chunk_location | LIBPNG |
_png_set_user_transform_info | LIBPNG |
_png_set_write_fn | LIBPNG |
_png_set_write_status_fn | LIBPNG |
_png_set_write_user_transform_fn | LIBPNG |
_png_sig_cmp | LIBPNG |
_png_start_read_image | LIBPNG |
_png_warning | LIBPNG |
_png_write_chunk | LIBPNG |
_png_write_chunk_data | LIBPNG |
_png_write_chunk_end | LIBPNG |
_png_write_chunk_start | LIBPNG |
_png_write_destroy | LIBPNG |
_png_write_destroy_info | LIBPNG |
_png_write_end | LIBPNG |
_png_write_flush | LIBPNG |
_png_write_image | LIBPNG |
_png_write_info | LIBPNG |
_png_write_info_before_PLTE | LIBPNG |
_png_write_png | LIBPNG |
_png_write_row | LIBPNG |
_png_write_rows | LIBPNG |
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:49


GLScene v.1.1.2: All Constants

All Constants

Name

Unit

Description

ACubicFirst3DS

Const3DS

ACubicFlat3DS

Const3DS

AGL_0_BIT

OpenGLTokens

AGL_10_BIT

OpenGLTokens

AGL_128_BIT

OpenGLTokens

AGL_12_BIT

OpenGLTokens

AGL_16_BIT

OpenGLTokens

AGL_1_BIT

OpenGLTokens

AGL_24_BIT

OpenGLTokens

AGL_2_BIT

OpenGLTokens

AGL_32_BIT

OpenGLTokens

AGL_3_BIT

OpenGLTokens

AGL_48_BIT

OpenGLTokens

AGL_4_BIT

OpenGLTokens

AGL_5_BIT

OpenGLTokens

AGL_64_BIT

OpenGLTokens

AGL_6_BIT

OpenGLTokens

AGL_8_BIT

OpenGLTokens

AGL_96_BIT

OpenGLTokens

AGL_ACCELERATED

OpenGLTokens

AGL_ACCUM_ALPHA_SIZE

OpenGLTokens

AGL_ACCUM_BLUE_SIZE

OpenGLTokens

AGL_ACCUM_GREEN_SIZE

OpenGLTokens

AGL_ACCUM_MODES

OpenGLTokens

AGL_ACCUM_RED_SIZE

OpenGLTokens

AGL_ALL_RENDERERS

OpenGLTokens

AGL_ALPHA_SIZE

OpenGLTokens

AGL_ARGB12121212_BIT

OpenGLTokens

AGL_ARGB1555_BIT

OpenGLTokens

AGL_ARGB16161616_BIT

OpenGLTokens

AGL_ARGB2101010_BIT

OpenGLTokens

AGL_ARGB4444_BIT

OpenGLTokens

AGL_ARGB8888_BIT

OpenGLTokens

AGL_AUX_BUFFERS

OpenGLTokens

AGL_AUX_DEPTH_STENCIL

OpenGLTokens

AGL_BACKING_STORE

OpenGLTokens

AGL_BAD_ALLOC

OpenGLTokens

AGL_BAD_ATTRIBUTE

OpenGLTokens

AGL_BAD_CONNECTION

OpenGLTokens

AGL_BAD_CONTEXT

OpenGLTokens

AGL_BAD_DRAWABLE

OpenGLTokens

AGL_BAD_ENUM

OpenGLTokens

AGL_BAD_FULLSCREEN

OpenGLTokens

AGL_BAD_GDEV

OpenGLTokens

AGL_BAD_MATCH

OpenGLTokens

AGL_BAD_MODULE

OpenGLTokens

AGL_BAD_OFFSCREEN

OpenGLTokens

AGL_BAD_PIXELFMT

OpenGLTokens

AGL_BAD_POINTER

OpenGLTokens

AGL_BAD_PROPERTY

OpenGLTokens

AGL_BAD_RENDINFO

OpenGLTokens

AGL_BAD_STATE

OpenGLTokens

AGL_BAD_VALUE

OpenGLTokens

AGL_BAD_WINDOW

OpenGLTokens

AGL_BGR233_A8_BIT

OpenGLTokens

AGL_BGR233_BIT

OpenGLTokens

AGL_BLUE_SIZE

OpenGLTokens

AGL_BUFFER_MODES

OpenGLTokens

AGL_BUFFER_NAME

OpenGLTokens

AGL_BUFFER_RECT

OpenGLTokens

AGL_BUFFER_SIZE

OpenGLTokens

AGL_CLEAR_FORMAT_CACHE

OpenGLTokens

AGL_CLIP_REGION

OpenGLTokens

AGL_CLOSEST_POLICY

OpenGLTokens

AGL_COLORMAP_ENTRY

OpenGLTokens

AGL_COLORMAP_TRACKING

OpenGLTokens

AGL_COLOR_FLOAT

OpenGLTokens

AGL_COLOR_MODES

OpenGLTokens

AGL_COMPLIANT

OpenGLTokens

AGL_CONTEXT_DISPLAY_ID

OpenGLTokens

AGL_CONTEXT_SURFACE_ID

OpenGLTokens

AGL_DEPTH_MODES

OpenGLTokens

AGL_DEPTH_SIZE

OpenGLTokens

AGL_DOUBLEBUFFER

OpenGLTokens

AGL_DOUBLEBUFFER_BIT

OpenGLTokens

AGL_ENABLE_SURFACE_BACKING_SIZE

OpenGLTokens

AGL_FORMAT_CACHE_SIZE

OpenGLTokens

AGL_FS_CAPTURE_SINGLE

OpenGLTokens

AGL_FULLSCREEN

OpenGLTokens

AGL_GREEN_SIZE

OpenGLTokens

AGL_INDEX16_BIT

OpenGLTokens

AGL_INDEX8_BIT

OpenGLTokens

AGL_LEVEL

OpenGLTokens

AGL_MAXIMUM_POLICY

OpenGLTokens

AGL_MAX_AUX_BUFFERS

OpenGLTokens

AGL_MAX_LEVEL

OpenGLTokens

AGL_MINIMUM_POLICY

OpenGLTokens

AGL_MIN_LEVEL

OpenGLTokens

AGL_MONOSCOPIC_BIT

OpenGLTokens

AGL_MP_SAFE

OpenGLTokens

AGL_MULTISAMPLE

OpenGLTokens

AGL_MULTISCREEN

OpenGLTokens

AGL_NONE

OpenGLTokens

AGL_NO_ERROR

OpenGLTokens

AGL_NO_RECOVERY

OpenGLTokens

AGL_OFFSCREEN

OpenGLTokens

AGL_ORDER_CONTEXT_TO_FRONT

OpenGLTokens

AGL_PBUFFER

OpenGLTokens

AGL_PIXEL_SIZE

OpenGLTokens

AGL_RASTERIZATION

OpenGLTokens

AGL_RED_SIZE

OpenGLTokens

AGL_REMOTE_PBUFFER

OpenGLTokens

AGL_RENDERER_COUNT

OpenGLTokens

AGL_RENDERER_ID

OpenGLTokens

AGL_RETAIN_RENDERERS

OpenGLTokens

AGL_RGB101010_A8_BIT

OpenGLTokens

AGL_RGB101010_BIT

OpenGLTokens

AGL_RGB121212_BIT

OpenGLTokens

AGL_RGB161616_BIT

OpenGLTokens

AGL_RGB332_A8_BIT

OpenGLTokens

AGL_RGB332_BIT

OpenGLTokens

AGL_RGB444_A8_BIT

OpenGLTokens

AGL_RGB444_BIT

OpenGLTokens

AGL_RGB555_A8_BIT

OpenGLTokens

AGL_RGB555_BIT

OpenGLTokens

AGL_RGB565_A8_BIT

OpenGLTokens

AGL_RGB565_BIT

OpenGLTokens

AGL_RGB888_A8_BIT

OpenGLTokens

AGL_RGB888_BIT

OpenGLTokens

AGL_RGB8_A8_BIT

OpenGLTokens

AGL_RGB8_BIT

OpenGLTokens

AGL_RGBA

OpenGLTokens

AGL_RGBAFLOAT128_BIT

OpenGLTokens

AGL_RGBAFLOAT256_BIT

OpenGLTokens

AGL_RGBAFLOAT64_BIT

OpenGLTokens

AGL_RGBFLOAT128_BIT

OpenGLTokens

AGL_RGBFLOAT256_BIT

OpenGLTokens

AGL_RGBFLOAT64_BIT

OpenGLTokens

AGL_ROBUST

OpenGLTokens

AGL_SAMPLES_ARB

OpenGLTokens

AGL_SAMPLE_ALPHA

OpenGLTokens

AGL_SAMPLE_BUFFERS_ARB

OpenGLTokens

AGL_SINGLEBUFFER_BIT

OpenGLTokens

AGL_SINGLE_RENDERER

OpenGLTokens

AGL_STATE_VALIDATION

OpenGLTokens

AGL_STENCIL_MODES

OpenGLTokens

AGL_STENCIL_SIZE

OpenGLTokens

AGL_STEREO

OpenGLTokens

AGL_STEREOSCOPIC_BIT

OpenGLTokens

AGL_SUPERSAMPLE

OpenGLTokens

AGL_SURFACE_BACKING_SIZE

OpenGLTokens

AGL_SURFACE_OPACITY

OpenGLTokens

AGL_SURFACE_ORDER

OpenGLTokens

AGL_SURFACE_VOLATILE

OpenGLTokens

AGL_SWAP_INTERVAL

OpenGLTokens

AGL_SWAP_LIMIT

OpenGLTokens

AGL_SWAP_RECT

OpenGLTokens

AGL_TEXTURE_MEMORY

OpenGLTokens

AGL_VIDEO_MEMORY

OpenGLTokens

AGL_VIRTUAL_SCREEN

OpenGLTokens

AGL_WINDOW

OpenGLTokens

ALC_ALL_ATTRIBUTES

openal

ALC_ALL_DEVICES_SPECIFIER

openal

ALC_ATTRIBUTES_SIZE

openal

ALC_CAPTURE_DEFAULT_DEVICE_SPECIFIER

openal

ALC_CAPTURE_DEVICE_SPECIFIER

openal

ALC_CAPTURE_SAMPLES

openal

ALC_DEFAULT_ALL_DEVICES_SPECIFIER

openal

ALC_DEFAULT_DEVICE_SPECIFIER

openal

ALC_DEVICE_SPECIFIER

openal

ALC_EFX_MAJOR_VERSION

openal

ALC_EFX_MINOR_VERSION

openal

ALC_EXTENSIONS

openal

ALC_EXT_EFX_NAME

openal

ALC_FALSE

openal

ALC_FREQUENCY

openal

ALC_INVALID

openal

ALC_INVALID_CONTEXT

openal

ALC_INVALID_DEVICE

openal

ALC_INVALID_ENUM

openal

ALC_INVALID_VALUE

openal

ALC_MAJOR_VERSION

openal

ALC_MAX_AUXILIARY_SENDS

openal

ALC_MINOR_VERSION

openal

ALC_MONO_SOURCES

openal

ALC_NO_ERROR

openal

ALC_OUT_OF_MEMORY

openal

ALC_REFRESH

openal

ALC_STEREO_SOURCES

openal

ALC_SYNC

openal

ALC_TRUE

openal

AL_AIR_ABSORPTION_FACTOR

openal

AL_AUTOWAH_ATTACK_TIME

openal

AL_AUTOWAH_DEFAULT_ATTACK_TIME

openal

AL_AUTOWAH_DEFAULT_PEAK_GAIN

openal

AL_AUTOWAH_DEFAULT_RELEASE_TIME

openal

AL_AUTOWAH_DEFAULT_RESONANCE

openal

AL_AUTOWAH_MAX_ATTACK_TIME

openal

AL_AUTOWAH_MAX_PEAK_GAIN

openal

AL_AUTOWAH_MAX_RELEASE_TIME

openal

AL_AUTOWAH_MAX_RESONANCE

openal

AL_AUTOWAH_MIN_ATTACK_TIME

openal

AL_AUTOWAH_MIN_PEAK_GAIN

openal

AL_AUTOWAH_MIN_RELEASE_TIME

openal

AL_AUTOWAH_MIN_RESONANCE

openal

AL_AUTOWAH_PEAK_GAIN

openal

AL_AUTOWAH_RELEASE_TIME

openal

AL_AUTOWAH_RESONANCE

openal

AL_AUXILIARY_SEND_FILTER

openal

AL_AUXILIARY_SEND_FILTER_GAINHF_AUTO

openal

AL_AUXILIARY_SEND_FILTER_GAIN_AUTO

openal

AL_BANDPASS_GAIN

openal

AL_BANDPASS_GAINHF

openal

AL_BANDPASS_GAINLF

openal

AL_BITS

openal

AL_BUFFER

openal

AL_BUFFERS_PROCESSED

openal

AL_BUFFERS_QUEUED

openal

AL_BYTE_OFFSET

openal

AL_CHANNELS

openal

AL_CHANNEL_MASK

openal

AL_CHORUS_DEFAULT_DELAY

openal

AL_CHORUS_DEFAULT_DEPTH

openal

AL_CHORUS_DEFAULT_FEEDBACK

openal

AL_CHORUS_DEFAULT_PHASE

openal

AL_CHORUS_DEFAULT_RATE

openal

AL_CHORUS_DEFAULT_WAVEFORM

openal

AL_CHORUS_DELAY

openal

AL_CHORUS_DEPTH

openal

AL_CHORUS_FEEDBACK

openal

AL_CHORUS_MAX_DELAY

openal

AL_CHORUS_MAX_DEPTH

openal

AL_CHORUS_MAX_FEEDBACK

openal

AL_CHORUS_MAX_PHASE

openal

AL_CHORUS_MAX_RATE

openal

AL_CHORUS_MAX_WAVEFORM

openal

AL_CHORUS_MIN_DELAY

openal

AL_CHORUS_MIN_DEPTH

openal

AL_CHORUS_MIN_FEEDBACK

openal

AL_CHORUS_MIN_PHASE

openal

AL_CHORUS_MIN_RATE

openal

AL_CHORUS_MIN_WAVEFORM

openal

AL_CHORUS_PHASE

openal

AL_CHORUS_RATE

openal

AL_CHORUS_WAVEFORM

openal

AL_CHORUS_WAVEFORM_SINUSOID

openal

AL_CHORUS_WAVEFORM_TRIANGLE

openal

AL_COMPRESSOR_DEFAULT_ONOFF

openal

AL_COMPRESSOR_MAX_ONOFF

openal

AL_COMPRESSOR_MIN_ONOFF

openal

AL_COMPRESSOR_ONOFF

openal

AL_CONE_INNER_ANGLE

openal

AL_CONE_OUTER_ANGLE

openal

AL_CONE_OUTER_GAIN

openal

AL_CONE_OUTER_GAINHF

openal

AL_DEFAULT_AIR_ABSORPTION_FACTOR

openal

AL_DEFAULT_AUXILIARY_SEND_FILTER_GAINHF_AUTO

openal

AL_DEFAULT_AUXILIARY_SEND_FILTER_GAIN_AUTO

openal

AL_DEFAULT_CONE_OUTER_GAINHF

openal

AL_DEFAULT_DIRECT_FILTER_GAINHF_AUTO

openal

AL_DEFAULT_METERS_PER_UNIT

openal

AL_DEFAULT_ROOM_ROLLOFF_FACTOR

openal

AL_DIRECTION

openal

AL_DIRECT_FILTER

openal

AL_DIRECT_FILTER_GAINHF_AUTO

openal

AL_DISTANCE_MODEL

openal

AL_DISTORTION_DEFAULT_EDGE

openal

AL_DISTORTION_DEFAULT_EQBANDWIDTH

openal

AL_DISTORTION_DEFAULT_EQCENTER

openal

AL_DISTORTION_DEFAULT_GAIN

openal

AL_DISTORTION_DEFAULT_LOWPASS_CUTOFF

openal

AL_DISTORTION_EDGE

openal

AL_DISTORTION_EQBANDWIDTH

openal

AL_DISTORTION_EQCENTER

openal

AL_DISTORTION_GAIN

openal

AL_DISTORTION_LOWPASS_CUTOFF

openal

AL_DISTORTION_MAX_EDGE

openal

AL_DISTORTION_MAX_EQBANDWIDTH

openal

AL_DISTORTION_MAX_EQCENTER

openal

AL_DISTORTION_MAX_GAIN

openal

AL_DISTORTION_MAX_LOWPASS_CUTOFF

openal

AL_DISTORTION_MIN_EDGE

openal

AL_DISTORTION_MIN_EQBANDWIDTH

openal

AL_DISTORTION_MIN_EQCENTER

openal

AL_DISTORTION_MIN_GAIN

openal

AL_DISTORTION_MIN_LOWPASS_CUTOFF

openal

AL_DOPPLER_FACTOR

openal

AL_DOPPLER_VELOCITY

openal

AL_EAXREVERB_AIR_ABSORPTION_GAINHF

openal

AL_EAXREVERB_DECAY_HFLIMIT

openal

AL_EAXREVERB_DECAY_HFRATIO

openal

AL_EAXREVERB_DECAY_LFRATIO

openal

AL_EAXREVERB_DECAY_TIME

openal

AL_EAXREVERB_DEFAULT_AIR_ABSORPTION_GAINHF

openal

AL_EAXREVERB_DEFAULT_DECAY_HFLIMIT

openal

AL_EAXREVERB_DEFAULT_DECAY_HFRATIO

openal

AL_EAXREVERB_DEFAULT_DECAY_LFRATIO

openal

AL_EAXREVERB_DEFAULT_DECAY_TIME

openal

AL_EAXREVERB_DEFAULT_DENSITY

openal

AL_EAXREVERB_DEFAULT_DIFFUSION

openal

AL_EAXREVERB_DEFAULT_ECHO_DEPTH

openal

AL_EAXREVERB_DEFAULT_ECHO_TIME

openal

AL_EAXREVERB_DEFAULT_GAIN

openal

AL_EAXREVERB_DEFAULT_GAINHF

openal

AL_EAXREVERB_DEFAULT_GAINLF

openal

AL_EAXREVERB_DEFAULT_HFREFERENCE

openal

AL_EAXREVERB_DEFAULT_LATE_REVERB_DELAY

openal

AL_EAXREVERB_DEFAULT_LATE_REVERB_GAIN

openal

AL_EAXREVERB_DEFAULT_LATE_REVERB_PAN

openal

AL_EAXREVERB_DEFAULT_LFREFERENCE

openal

AL_EAXREVERB_DEFAULT_MODULATION_DEPTH

openal

AL_EAXREVERB_DEFAULT_MODULATION_TIME

openal

AL_EAXREVERB_DEFAULT_REFLECTIONS_DELAY

openal

AL_EAXREVERB_DEFAULT_REFLECTIONS_GAIN

openal

AL_EAXREVERB_DEFAULT_REFLECTIONS_PAN

openal

AL_EAXREVERB_DEFAULT_ROOM_ROLLOFF_FACTOR

openal

AL_EAXREVERB_DENSITY

openal

AL_EAXREVERB_DIFFUSION

openal

AL_EAXREVERB_ECHO_DEPTH

openal

AL_EAXREVERB_ECHO_TIME

openal

AL_EAXREVERB_GAIN

openal

AL_EAXREVERB_GAINHF

openal

AL_EAXREVERB_GAINLF

openal

AL_EAXREVERB_HFREFERENCE

openal

AL_EAXREVERB_LATE_REVERB_DELAY

openal

AL_EAXREVERB_LATE_REVERB_GAIN

openal

AL_EAXREVERB_LATE_REVERB_PAN

openal

AL_EAXREVERB_LFREFERENCE

openal

AL_EAXREVERB_MAX_AIR_ABSORPTION_GAINHF

openal

AL_EAXREVERB_MAX_DECAY_HFLIMIT

openal

AL_EAXREVERB_MAX_DECAY_HFRATIO

openal

AL_EAXREVERB_MAX_DECAY_LFRATIO

openal

AL_EAXREVERB_MAX_DECAY_TIME

openal

AL_EAXREVERB_MAX_DENSITY

openal

AL_EAXREVERB_MAX_DIFFUSION

openal

AL_EAXREVERB_MAX_ECHO_DEPTH

openal

AL_EAXREVERB_MAX_ECHO_TIME

openal

AL_EAXREVERB_MAX_GAIN

openal

AL_EAXREVERB_MAX_GAINHF

openal

AL_EAXREVERB_MAX_GAINLF

openal

AL_EAXREVERB_MAX_HFREFERENCE

openal

AL_EAXREVERB_MAX_LATE_REVERB_DELAY

openal

AL_EAXREVERB_MAX_LATE_REVERB_GAIN

openal

AL_EAXREVERB_MAX_LFREFERENCE

openal

AL_EAXREVERB_MAX_MODULATION_DEPTH

openal

AL_EAXREVERB_MAX_MODULATION_TIME

openal

AL_EAXREVERB_MAX_REFLECTIONS_DELAY

openal

AL_EAXREVERB_MAX_REFLECTIONS_GAIN

openal

AL_EAXREVERB_MAX_ROOM_ROLLOFF_FACTOR

openal

AL_EAXREVERB_MIN_AIR_ABSORPTION_GAINHF

openal

AL_EAXREVERB_MIN_DECAY_HFLIMIT

openal

AL_EAXREVERB_MIN_DECAY_HFRATIO

openal

AL_EAXREVERB_MIN_DECAY_LFRATIO

openal

AL_EAXREVERB_MIN_DECAY_TIME

openal

AL_EAXREVERB_MIN_DENSITY

openal

AL_EAXREVERB_MIN_DIFFUSION

openal

AL_EAXREVERB_MIN_ECHO_DEPTH

openal

AL_EAXREVERB_MIN_ECHO_TIME

openal

AL_EAXREVERB_MIN_GAIN

openal

AL_EAXREVERB_MIN_GAINHF

openal

AL_EAXREVERB_MIN_GAINLF

openal

AL_EAXREVERB_MIN_HFREFERENCE

openal

AL_EAXREVERB_MIN_LATE_REVERB_DELAY

openal

AL_EAXREVERB_MIN_LATE_REVERB_GAIN

openal

AL_EAXREVERB_MIN_LFREFERENCE

openal

AL_EAXREVERB_MIN_MODULATION_DEPTH

openal

AL_EAXREVERB_MIN_MODULATION_TIME

openal

AL_EAXREVERB_MIN_REFLECTIONS_DELAY

openal

AL_EAXREVERB_MIN_REFLECTIONS_GAIN

openal

AL_EAXREVERB_MIN_ROOM_ROLLOFF_FACTOR

openal

AL_EAXREVERB_MODULATION_DEPTH

openal

AL_EAXREVERB_MODULATION_TIME

openal

AL_EAXREVERB_REFLECTIONS_DELAY

openal

AL_EAXREVERB_REFLECTIONS_GAIN

openal

AL_EAXREVERB_REFLECTIONS_PAN

openal

AL_EAXREVERB_ROOM_ROLLOFF_FACTOR

openal

AL_ECHO_DAMPING

openal

AL_ECHO_DEFAULT_DAMPING

openal

AL_ECHO_DEFAULT_DELAY

openal

AL_ECHO_DEFAULT_FEEDBACK

openal

AL_ECHO_DEFAULT_LRDELAY

openal

AL_ECHO_DEFAULT_SPREAD

openal

AL_ECHO_DELAY

openal

AL_ECHO_FEEDBACK

openal

AL_ECHO_LRDELAY

openal

AL_ECHO_MAX_DAMPING

openal

AL_ECHO_MAX_DELAY

openal

AL_ECHO_MAX_FEEDBACK

openal

AL_ECHO_MAX_LRDELAY

openal

AL_ECHO_MAX_SPREAD

openal

AL_ECHO_MIN_DAMPING

openal

AL_ECHO_MIN_DELAY

openal

AL_ECHO_MIN_FEEDBACK

openal

AL_ECHO_MIN_LRDELAY

openal

AL_ECHO_MIN_SPREAD

openal

AL_ECHO_SPREAD

openal

AL_EFFECTSLOT_AUXILIARY_SEND_AUTO

openal

AL_EFFECTSLOT_EFFECT

openal

AL_EFFECTSLOT_GAIN

openal

AL_EFFECTSLOT_NULL

openal

AL_EFFECT_AUTOWAH

openal

AL_EFFECT_CHORUS

openal

AL_EFFECT_COMPRESSOR

openal

AL_EFFECT_DISTORTION

openal

AL_EFFECT_EAXREVERB

openal

AL_EFFECT_ECHO

openal

AL_EFFECT_EQUALIZER

openal

AL_EFFECT_FIRST_PARAMETER

openal

AL_EFFECT_FLANGER

openal

AL_EFFECT_FREQUENCY_SHIFTER

openal

AL_EFFECT_LAST_PARAMETER

openal

AL_EFFECT_NULL

openal

AL_EFFECT_PITCH_SHIFTER

openal

AL_EFFECT_REVERB

openal

AL_EFFECT_RING_MODULATOR

openal

AL_EFFECT_TYPE

openal

AL_EFFECT_VOCAL_MORPHER

openal

AL_EQUALIZER_DEFAULT_HIGH_CUTOFF

openal

AL_EQUALIZER_DEFAULT_HIGH_GAIN

openal

AL_EQUALIZER_DEFAULT_LOW_CUTOFF

openal

AL_EQUALIZER_DEFAULT_LOW_GAIN

openal

AL_EQUALIZER_DEFAULT_MID1_CENTER

openal

AL_EQUALIZER_DEFAULT_MID1_GAIN

openal

AL_EQUALIZER_DEFAULT_MID1_WIDTH

openal

AL_EQUALIZER_DEFAULT_MID2_CENTER

openal

AL_EQUALIZER_DEFAULT_MID2_GAIN

openal

AL_EQUALIZER_DEFAULT_MID2_WIDTH

openal

AL_EQUALIZER_HIGH_CUTOFF

openal

AL_EQUALIZER_HIGH_GAIN

openal

AL_EQUALIZER_LOW_CUTOFF

openal

AL_EQUALIZER_LOW_GAIN

openal

AL_EQUALIZER_MAX_HIGH_CUTOFF

openal

AL_EQUALIZER_MAX_HIGH_GAIN

openal

AL_EQUALIZER_MAX_LOW_CUTOFF

openal

AL_EQUALIZER_MAX_LOW_GAIN

openal

AL_EQUALIZER_MAX_MID1_CENTER

openal

AL_EQUALIZER_MAX_MID1_GAIN

openal

AL_EQUALIZER_MAX_MID1_WIDTH

openal

AL_EQUALIZER_MAX_MID2_CENTER

openal

AL_EQUALIZER_MAX_MID2_GAIN

openal

AL_EQUALIZER_MAX_MID2_WIDTH

openal

AL_EQUALIZER_MID1_CENTER

openal

AL_EQUALIZER_MID1_GAIN

openal

AL_EQUALIZER_MID1_WIDTH

openal

AL_EQUALIZER_MID2_CENTER

openal

AL_EQUALIZER_MID2_GAIN

openal

AL_EQUALIZER_MID2_WIDTH

openal

AL_EQUALIZER_MIN_HIGH_CUTOFF

openal

AL_EQUALIZER_MIN_HIGH_GAIN

openal

AL_EQUALIZER_MIN_LOW_CUTOFF

openal

AL_EQUALIZER_MIN_LOW_GAIN

openal

AL_EQUALIZER_MIN_MID1_CENTER

openal

AL_EQUALIZER_MIN_MID1_GAIN

openal

AL_EQUALIZER_MIN_MID1_WIDTH

openal

AL_EQUALIZER_MIN_MID2_CENTER

openal

AL_EQUALIZER_MIN_MID2_GAIN

openal

AL_EQUALIZER_MIN_MID2_WIDTH

openal

AL_EXPONENT_DISTANCE

openal

AL_EXPONENT_DISTANCE_CLAMPED

openal

AL_EXTENSIONS

openal

AL_FALSE

openal

AL_FILTER_BANDPASS

openal

AL_FILTER_FIRST_PARAMETER

openal

AL_FILTER_HIGHPASS

openal

AL_FILTER_LAST_PARAMETER

openal

AL_FILTER_LOWPASS

openal

AL_FILTER_NULL

openal

AL_FILTER_TYPE

openal

AL_FLANGER_DEFAULT_DELAY

openal

AL_FLANGER_DEFAULT_DEPTH

openal

AL_FLANGER_DEFAULT_FEEDBACK

openal

AL_FLANGER_DEFAULT_PHASE

openal

AL_FLANGER_DEFAULT_RATE

openal

AL_FLANGER_DEFAULT_WAVEFORM

openal

AL_FLANGER_DELAY

openal

AL_FLANGER_DEPTH

openal

AL_FLANGER_FEEDBACK

openal

AL_FLANGER_MAX_DELAY

openal

AL_FLANGER_MAX_DEPTH

openal

AL_FLANGER_MAX_FEEDBACK

openal

AL_FLANGER_MAX_PHASE

openal

AL_FLANGER_MAX_RATE

openal

AL_FLANGER_MAX_WAVEFORM

openal

AL_FLANGER_MIN_DELAY

openal

AL_FLANGER_MIN_DEPTH

openal

AL_FLANGER_MIN_FEEDBACK

openal

AL_FLANGER_MIN_PHASE

openal

AL_FLANGER_MIN_RATE

openal

AL_FLANGER_MIN_WAVEFORM

openal

AL_FLANGER_PHASE

openal

AL_FLANGER_RATE

openal

AL_FLANGER_WAVEFORM

openal

AL_FLANGER_WAVEFORM_SINUSOID

openal

AL_FLANGER_WAVEFORM_TRIANGLE

openal

AL_FORMAT_MONO16

openal

AL_FORMAT_MONO8

openal

AL_FORMAT_STEREO16

openal

AL_FORMAT_STEREO8

openal

AL_FREQUENCY

openal

AL_FREQUENCY_SHIFTER_DEFAULT_FREQUENCY

openal

AL_FREQUENCY_SHIFTER_DEFAULT_LEFT_DIRECTION

openal

AL_FREQUENCY_SHIFTER_DEFAULT_RIGHT_DIRECTION

openal

AL_FREQUENCY_SHIFTER_DIRECTION_DOWN

openal

AL_FREQUENCY_SHIFTER_DIRECTION_OFF

openal

AL_FREQUENCY_SHIFTER_DIRECTION_UP

openal

AL_FREQUENCY_SHIFTER_FREQUENCY

openal

AL_FREQUENCY_SHIFTER_LEFT_DIRECTION

openal

AL_FREQUENCY_SHIFTER_MAX_FREQUENCY

openal

AL_FREQUENCY_SHIFTER_MAX_LEFT_DIRECTION

openal

AL_FREQUENCY_SHIFTER_MAX_RIGHT_DIRECTION

openal

AL_FREQUENCY_SHIFTER_MIN_FREQUENCY

openal

AL_FREQUENCY_SHIFTER_MIN_LEFT_DIRECTION

openal

AL_FREQUENCY_SHIFTER_MIN_RIGHT_DIRECTION

openal

AL_FREQUENCY_SHIFTER_RIGHT_DIRECTION

openal

AL_GAIN

openal

AL_HIGHPASS_GAIN

openal

AL_HIGHPASS_GAINLF

openal

AL_ILLEGAL_COMMAND

openal

AL_ILLEGAL_ENUM

openal

AL_INITIAL

openal

AL_INVALID

openal

AL_INVALID_ENUM

openal

AL_INVALID_NAME

openal

AL_INVALID_OPERATION

openal

AL_INVALID_VALUE

openal

AL_INVERSE_DISTANCE

openal

AL_INVERSE_DISTANCE_CLAMPED

openal

AL_LINEAR_DISTANCE

openal

AL_LINEAR_DISTANCE_CLAMPED

openal

AL_LOOPING

openal

AL_LOWPASS_GAIN

openal

AL_LOWPASS_GAINHF

openal

AL_MAX_AIR_ABSORPTION_FACTOR

openal

AL_MAX_AUXILIARY_SEND_FILTER_GAINHF_AUTO

openal

AL_MAX_AUXILIARY_SEND_FILTER_GAIN_AUTO

openal

AL_MAX_CONE_OUTER_GAINHF

openal

AL_MAX_DIRECT_FILTER_GAINHF_AUTO

openal

AL_MAX_DISTANCE

openal

AL_MAX_GAIN

openal

AL_MAX_ROOM_ROLLOFF_FACTOR

openal

AL_METERS_PER_UNIT

openal

AL_MIN_AIR_ABSORPTION_FACTOR

openal

AL_MIN_AUXILIARY_SEND_FILTER_GAINHF_AUTO

openal

AL_MIN_AUXILIARY_SEND_FILTER_GAIN_AUTO

openal

AL_MIN_CONE_OUTER_GAINHF

openal

AL_MIN_DIRECT_FILTER_GAINHF_AUTO

openal

AL_MIN_GAIN

openal

AL_MIN_ROOM_ROLLOFF_FACTOR

openal

AL_NONE

openal

AL_NO_ERROR

openal

AL_ORIENTATION

openal

AL_OUT_OF_MEMORY

openal

AL_PAUSED

openal

AL_PENDING

openal

AL_PITCH

openal

AL_PITCH_SHIFTER_COARSE_TUNE

openal

AL_PITCH_SHIFTER_DEFAULT_COARSE_TUNE

openal

AL_PITCH_SHIFTER_DEFAULT_FINE_TUNE

openal

AL_PITCH_SHIFTER_FINE_TUNE

openal

AL_PITCH_SHIFTER_MAX_COARSE_TUNE

openal

AL_PITCH_SHIFTER_MAX_FINE_TUNE

openal

AL_PITCH_SHIFTER_MIN_COARSE_TUNE

openal

AL_PITCH_SHIFTER_MIN_FINE_TUNE

openal

AL_PLAYING

openal

AL_POSITION

openal

AL_PROCESSED

openal

AL_REFERENCE_DISTANCE

openal

AL_RENDERER

openal

AL_REVERB_AIR_ABSORPTION_GAINHF

openal

AL_REVERB_DECAY_HFLIMIT

openal

AL_REVERB_DECAY_HFRATIO

openal

AL_REVERB_DECAY_TIME

openal

AL_REVERB_DEFAULT_AIR_ABSORPTION_GAINHF

openal

AL_REVERB_DEFAULT_DECAY_HFLIMIT

openal

AL_REVERB_DEFAULT_DECAY_HFRATIO

openal

AL_REVERB_DEFAULT_DECAY_TIME

openal

AL_REVERB_DEFAULT_DENSITY

openal

AL_REVERB_DEFAULT_DIFFUSION

openal

AL_REVERB_DEFAULT_GAIN

openal

AL_REVERB_DEFAULT_GAINHF

openal

AL_REVERB_DEFAULT_LATE_REVERB_DELAY

openal

AL_REVERB_DEFAULT_LATE_REVERB_GAIN

openal

AL_REVERB_DEFAULT_REFLECTIONS_DELAY

openal

AL_REVERB_DEFAULT_REFLECTIONS_GAIN

openal

AL_REVERB_DEFAULT_ROOM_ROLLOFF_FACTOR

openal

AL_REVERB_DENSITY

openal

AL_REVERB_DIFFUSION

openal

AL_REVERB_GAIN

openal

AL_REVERB_GAINHF

openal

AL_REVERB_LATE_REVERB_DELAY

openal

AL_REVERB_LATE_REVERB_GAIN

openal

AL_REVERB_MAX_AIR_ABSORPTION_GAINHF

openal

AL_REVERB_MAX_DECAY_HFLIMIT

openal

AL_REVERB_MAX_DECAY_HFRATIO

openal

AL_REVERB_MAX_DECAY_TIME

openal

AL_REVERB_MAX_DENSITY

openal

AL_REVERB_MAX_DIFFUSION

openal

AL_REVERB_MAX_GAIN

openal

AL_REVERB_MAX_GAINHF

openal

AL_REVERB_MAX_LATE_REVERB_DELAY

openal

AL_REVERB_MAX_LATE_REVERB_GAIN

openal

AL_REVERB_MAX_REFLECTIONS_DELAY

openal

AL_REVERB_MAX_REFLECTIONS_GAIN

openal

AL_REVERB_MAX_ROOM_ROLLOFF_FACTOR

openal

AL_REVERB_MIN_AIR_ABSORPTION_GAINHF

openal

AL_REVERB_MIN_DECAY_HFLIMIT

openal

AL_REVERB_MIN_DECAY_HFRATIO

openal

AL_REVERB_MIN_DECAY_TIME

openal

AL_REVERB_MIN_DENSITY

openal

AL_REVERB_MIN_DIFFUSION

openal

AL_REVERB_MIN_GAIN

openal

AL_REVERB_MIN_GAINHF

openal

AL_REVERB_MIN_LATE_REVERB_DELAY

openal

AL_REVERB_MIN_LATE_REVERB_GAIN

openal

AL_REVERB_MIN_REFLECTIONS_DELAY

openal

AL_REVERB_MIN_REFLECTIONS_GAIN

openal

AL_REVERB_MIN_ROOM_ROLLOFF_FACTOR

openal

AL_REVERB_REFLECTIONS_DELAY

openal

AL_REVERB_REFLECTIONS_GAIN

openal

AL_REVERB_ROOM_ROLLOFF_FACTOR

openal

AL_RING_MODULATOR_DEFAULT_FREQUENCY

openal

AL_RING_MODULATOR_DEFAULT_HIGHPASS_CUTOFF

openal

AL_RING_MODULATOR_DEFAULT_WAVEFORM

openal

AL_RING_MODULATOR_FREQUENCY

openal

AL_RING_MODULATOR_HIGHPASS_CUTOFF

openal

AL_RING_MODULATOR_MAX_FREQUENCY

openal

AL_RING_MODULATOR_MAX_HIGHPASS_CUTOFF

openal

AL_RING_MODULATOR_MAX_WAVEFORM

openal

AL_RING_MODULATOR_MIN_FREQUENCY

openal

AL_RING_MODULATOR_MIN_HIGHPASS_CUTOFF

openal

AL_RING_MODULATOR_MIN_WAVEFORM

openal

AL_RING_MODULATOR_SAWTOOTH

openal

AL_RING_MODULATOR_SINUSOID

openal

AL_RING_MODULATOR_SQUARE

openal

AL_RING_MODULATOR_WAVEFORM

openal

AL_ROLLOFF_FACTOR

openal

AL_ROOM_ROLLOFF_FACTOR

openal

AL_SAMPLE_OFFSET

openal

AL_SEC_OFFSET

openal

AL_SIZE

openal

AL_SOURCE_ABSOLUTE

openal

AL_SOURCE_RELATIVE

openal

AL_SOURCE_STATE

openal

AL_SOURCE_TYPE

openal

AL_SPEED_OF_SOUND

openal

AL_STATIC

openal

AL_STOPPED

openal

AL_STREAMING

openal

AL_TRUE

openal

AL_UNDETERMINED

openal

AL_UNUSED

openal

AL_VELOCITY

openal

AL_VENDOR

openal

AL_VERSION

openal

AL_VOCAL_MORPHER_DEFAULT_PHONEMEA

openal

AL_VOCAL_MORPHER_DEFAULT_PHONEMEA_COARSE_TUNING

openal

AL_VOCAL_MORPHER_DEFAULT_PHONEMEB

openal

AL_VOCAL_MORPHER_DEFAULT_PHONEMEB_COARSE_TUNING

openal

AL_VOCAL_MORPHER_DEFAULT_RATE

openal

AL_VOCAL_MORPHER_DEFAULT_WAVEFORM

openal

AL_VOCAL_MORPHER_MAX_PHONEMEA

openal

AL_VOCAL_MORPHER_MAX_PHONEMEA_COARSE_TUNING

openal

AL_VOCAL_MORPHER_MAX_PHONEMEB

openal

AL_VOCAL_MORPHER_MAX_PHONEMEB_COARSE_TUNING

openal

AL_VOCAL_MORPHER_MAX_RATE

openal

AL_VOCAL_MORPHER_MAX_WAVEFORM

openal

AL_VOCAL_MORPHER_MIN_PHONEMEA

openal

AL_VOCAL_MORPHER_MIN_PHONEMEA_COARSE_TUNING

openal

AL_VOCAL_MORPHER_MIN_PHONEMEB

openal

AL_VOCAL_MORPHER_MIN_PHONEMEB_COARSE_TUNING

openal

AL_VOCAL_MORPHER_MIN_RATE

openal

AL_VOCAL_MORPHER_MIN_WAVEFORM

openal

AL_VOCAL_MORPHER_PHONEMEA

openal

AL_VOCAL_MORPHER_PHONEMEA_COARSE_TUNING

openal

AL_VOCAL_MORPHER_PHONEMEB

openal

AL_VOCAL_MORPHER_PHONEMEB_COARSE_TUNING

openal

AL_VOCAL_MORPHER_PHONEME_A

openal

AL_VOCAL_MORPHER_PHONEME_AA

openal

AL_VOCAL_MORPHER_PHONEME_AE

openal

AL_VOCAL_MORPHER_PHONEME_AH

openal

AL_VOCAL_MORPHER_PHONEME_AO

openal

AL_VOCAL_MORPHER_PHONEME_B

openal

AL_VOCAL_MORPHER_PHONEME_D

openal

AL_VOCAL_MORPHER_PHONEME_E

openal

AL_VOCAL_MORPHER_PHONEME_EH

openal

AL_VOCAL_MORPHER_PHONEME_ER

openal

AL_VOCAL_MORPHER_PHONEME_F

openal

AL_VOCAL_MORPHER_PHONEME_G

openal

AL_VOCAL_MORPHER_PHONEME_I

openal

AL_VOCAL_MORPHER_PHONEME_IH

openal

AL_VOCAL_MORPHER_PHONEME_IY

openal

AL_VOCAL_MORPHER_PHONEME_J

openal

AL_VOCAL_MORPHER_PHONEME_K

openal

AL_VOCAL_MORPHER_PHONEME_L

openal

AL_VOCAL_MORPHER_PHONEME_M

openal

AL_VOCAL_MORPHER_PHONEME_N

openal

AL_VOCAL_MORPHER_PHONEME_O

openal

AL_VOCAL_MORPHER_PHONEME_P

openal

AL_VOCAL_MORPHER_PHONEME_R

openal

AL_VOCAL_MORPHER_PHONEME_S

openal

AL_VOCAL_MORPHER_PHONEME_T

openal

AL_VOCAL_MORPHER_PHONEME_U

openal

AL_VOCAL_MORPHER_PHONEME_UH

openal

AL_VOCAL_MORPHER_PHONEME_UW

openal

AL_VOCAL_MORPHER_PHONEME_V

openal

AL_VOCAL_MORPHER_PHONEME_Z

openal

AL_VOCAL_MORPHER_RATE

openal

AL_VOCAL_MORPHER_WAVEFORM

openal

AL_VOCAL_MORPHER_WAVEFORM_SAWTOOTH

openal

AL_VOCAL_MORPHER_WAVEFORM_SINUSOID

openal

AL_VOCAL_MORPHER_WAVEFORM_TRIANGLE

openal

AMBIENT_LIGHT

Const3DS

AMBIENT_NODE_TAG

Const3DS

ATKEY1

Const3DS

ATKEY2

Const3DS

ATKEY3

Const3DS

ATKEY4

Const3DS

ATKEY5

Const3DS

ATKEYFLAGS

Const3DS

AUDIO_S16

GLSDL

AUDIO_S16LSB

GLSDL

AUDIO_S16MSB

GLSDL

AUDIO_S16SYS

GLSDL

AUDIO_S8

GLSDL

AUDIO_U16

GLSDL

AUDIO_U16LSB

GLSDL

AUDIO_U16MSB

GLSDL

AUDIO_U16SYS

GLSDL

AUDIO_U8

GLSDL

AVICOMPRESSF_DATARATE

GLSVfw

AVICOMPRESSF_INTERLEAVE

GLSVfw

AVICOMPRESSF_KEYFRAMES

GLSVfw

AVICOMPRESSF_VALID

GLSVfw

AVIERR_BADFLAGS

GLSVfw

AVIERR_BADFORMAT

GLSVfw

AVIERR_BADHANDLE

GLSVfw

AVIERR_BADPARAM

GLSVfw

AVIERR_BADSIZE

GLSVfw

AVIERR_BUFFERTOOSMALL

GLSVfw

AVIERR_CANTCOMPRESS

GLSVfw

AVIERR_COMPRESSOR

GLSVfw

AVIERR_ERROR

GLSVfw

AVIERR_FILEOPEN

GLSVfw

AVIERR_FILEREAD

GLSVfw

AVIERR_FILEWRITE

GLSVfw

AVIERR_INTERNAL

GLSVfw

AVIERR_MEMORY

GLSVfw

AVIERR_NOCOMPRESSOR

GLSVfw

AVIERR_NODATA

GLSVfw

AVIERR_OK

GLSVfw

AVIERR_READONLY

GLSVfw

AVIERR_UNSUPPORTED

GLSVfw

AVIERR_USERABORT

GLSVfw

AVIFILECAPS_ALLKEYFRAMES

GLSVfw

AVIFILECAPS_CANREAD

GLSVfw

AVIFILECAPS_CANWRITE

GLSVfw

AVIFILECAPS_NOCOMPRESSION

GLSVfw

AVIFILEHANDLER_CANACCEPTNONRGB

GLSVfw

AVIFILEHANDLER_CANREAD

GLSVfw

AVIFILEHANDLER_CANWRITE

GLSVfw

AVIFILEINFO_COPYRIGHTED

GLSVfw

AVIFILEINFO_HASINDEX

GLSVfw

AVIFILEINFO_ISINTERLEAVED

GLSVfw

AVIFILEINFO_MUSTUSEINDEX

GLSVfw

AVIFILEINFO_WASCAPTUREFILE

GLSVfw

AVIF_COPYRIGHTED

GLSVfw

AVIF_HASINDEX

GLSVfw

AVIF_ISINTERLEAVED

GLSVfw

AVIF_MUSTUSEINDEX

GLSVfw

AVIF_TRUSTCKTYPE

GLSVfw

AVIF_WASCAPTUREFILE

GLSVfw

AVIGETFRAMEF_BESTDISPLAYFMT

GLSVfw

AVIIF_COMPUSE

GLSVfw

AVIIF_KEYFRAME

GLSVfw

AVIIF_LIST

GLSVfw

AVIIF_NOTIME

GLSVfw

AVIIF_TWOCC

GLSVfw

AVISF_DISABLED

GLSVfw

AVISF_VIDEO_PALCHANGES

GLSVfw

AVISTREAMINFO_DISABLED

GLSVfw

AVISTREAMINFO_FORMATCHANGES

GLSVfw

AVISTREAMREAD_CONVENIENT

GLSVfw

AVI_HEADERSIZE

GLSVfw

AVSTREAMMASTER_AUDIO

GLSVfw

AVSTREAMMASTER_NONE

GLSVfw

AXIS_MAX

GLSDL

AXIS_MIN

GLSDL

BANDPASS_DEFAULT_GAIN

openal

BANDPASS_DEFAULT_GAINHF

openal

BANDPASS_DEFAULT_GAINLF

openal

BANDPASS_MAX_GAIN

openal

BANDPASS_MAX_GAINHF

openal

BANDPASS_MAX_GAINLF

openal

BANDPASS_MIN_GAIN

openal

BANDPASS_MIN_GAINHF

openal

BANDPASS_MIN_GAINLF

openal

BASSVERSION

Bass

BASS_3DALG_DEFAULT

Bass

BASS_3DALG_FULL

Bass

BASS_3DALG_LIGHT

Bass

BASS_3DALG_OFF

Bass

BASS_3DMODE_NORMAL

Bass

BASS_3DMODE_OFF

Bass

BASS_3DMODE_RELATIVE

Bass

BASS_ACTIVE_PAUSED

Bass

BASS_ACTIVE_PLAYING

Bass

BASS_ACTIVE_STALLED

Bass

BASS_ACTIVE_STOPPED

Bass

BASS_CONFIG_3DALGORITHM

Bass

BASS_CONFIG_BUFFER

Bass

BASS_CONFIG_CURVE_PAN

Bass

BASS_CONFIG_CURVE_VOL

Bass

BASS_CONFIG_FLOATDSP

Bass

BASS_CONFIG_GVOL_MUSIC

Bass

BASS_CONFIG_GVOL_SAMPLE

Bass

BASS_CONFIG_GVOL_STREAM

Bass

BASS_CONFIG_MAXVOL

Bass

BASS_CONFIG_MUSIC_VIRTUAL

Bass

BASS_CONFIG_NET_AGENT

Bass

BASS_CONFIG_NET_BUFFER

Bass

BASS_CONFIG_NET_PASSIVE

Bass

BASS_CONFIG_NET_PLAYLIST

Bass

BASS_CONFIG_NET_PREBUF

Bass

BASS_CONFIG_NET_PROXY

Bass

BASS_CONFIG_NET_TIMEOUT

Bass

BASS_CONFIG_PAUSE_NOPLAY

Bass

BASS_CONFIG_REC_BUFFER

Bass

BASS_CONFIG_UPDATEPERIOD

Bass

BASS_CTYPE_MUSIC_IT

Bass

BASS_CTYPE_MUSIC_MO3

Bass

BASS_CTYPE_MUSIC_MOD

Bass

BASS_CTYPE_MUSIC_MTM

Bass

BASS_CTYPE_MUSIC_S3M

Bass

BASS_CTYPE_MUSIC_XM

Bass

BASS_CTYPE_RECORD

Bass

BASS_CTYPE_SAMPLE

Bass

BASS_CTYPE_STREAM

Bass

BASS_CTYPE_STREAM_AIFF

Bass

BASS_CTYPE_STREAM_MP1

Bass

BASS_CTYPE_STREAM_MP2

Bass

BASS_CTYPE_STREAM_MP3

Bass

BASS_CTYPE_STREAM_OGG

Bass

BASS_CTYPE_STREAM_WAV

Bass

BASS_CTYPE_STREAM_WAV_FLOAT

Bass

BASS_CTYPE_STREAM_WAV_PCM

Bass

BASS_DATA_AVAILABLE

Bass

BASS_DATA_FFT1024

Bass

BASS_DATA_FFT2048

Bass

BASS_DATA_FFT4096

Bass

BASS_DATA_FFT512

Bass

BASS_DATA_FFT8192

Bass

BASS_DATA_FFT_INDIVIDUAL

Bass

BASS_DATA_FFT_NOWINDOW

Bass

BASS_DATA_FLOAT

Bass

BASS_DEVICE_3D

Bass

BASS_DEVICE_8BITS

Bass

BASS_DEVICE_LATENCY

Bass

BASS_DEVICE_MONO

Bass

BASS_DEVICE_NOSPEAKER

Bass

BASS_DEVICE_SPEAKERS

Bass

BASS_DLL

Bass

BASS_ERROR_ALREADY

Bass

BASS_ERROR_BUFLOST

Bass

BASS_ERROR_CODEC

Bass

BASS_ERROR_CREATE

Bass

BASS_ERROR_DECODE

Bass

BASS_ERROR_DEVICE

Bass

BASS_ERROR_DRIVER

Bass

BASS_ERROR_DX

Bass

BASS_ERROR_EMPTY

Bass

BASS_ERROR_FILEFORM

Bass

BASS_ERROR_FILEOPEN

Bass

BASS_ERROR_FORMAT

Bass

BASS_ERROR_FREQ

Bass

BASS_ERROR_HANDLE

Bass

BASS_ERROR_ILLPARAM

Bass

BASS_ERROR_ILLTYPE

Bass

BASS_ERROR_INIT

Bass

BASS_ERROR_MEM

Bass

BASS_ERROR_NO3D

Bass

BASS_ERROR_NOCHAN

Bass

BASS_ERROR_NOEAX

Bass

BASS_ERROR_NOFX

Bass

BASS_ERROR_NOHW

Bass

BASS_ERROR_NONET

Bass

BASS_ERROR_NOPAUSE

Bass

BASS_ERROR_NOPLAY

Bass

BASS_ERROR_NOTAVAIL

Bass

BASS_ERROR_NOTFILE

Bass

BASS_ERROR_PLAYING

Bass

BASS_ERROR_POSITION

Bass

BASS_ERROR_SPEAKER

Bass

BASS_ERROR_START

Bass

BASS_ERROR_TIMEOUT

Bass

BASS_ERROR_UNKNOWN

Bass

BASS_ERROR_VERSION

Bass

BASS_FILEPOS_CONNECTED

Bass

BASS_FILEPOS_CURRENT

Bass

BASS_FILEPOS_DECODE

Bass

BASS_FILEPOS_DOWNLOAD

Bass

BASS_FILEPOS_END

Bass

BASS_FILEPOS_START

Bass

BASS_FILE_CLOSE

Bass

BASS_FILE_LEN

Bass

BASS_FILE_READ

Bass

BASS_FILE_SEEK

Bass

BASS_FX_CHORUS

Bass

BASS_FX_COMPRESSOR

Bass

BASS_FX_DISTORTION

Bass

BASS_FX_ECHO

Bass

BASS_FX_FLANGER

Bass

BASS_FX_GARGLE

Bass

BASS_FX_I3DL2REVERB

Bass

BASS_FX_PARAMEQ

Bass

BASS_FX_PHASE_180

Bass

BASS_FX_PHASE_90

Bass

BASS_FX_PHASE_NEG_180

Bass

BASS_FX_PHASE_NEG_90

Bass

BASS_FX_PHASE_ZERO

Bass

BASS_FX_REVERB

Bass

BASS_INPUT_LEVEL

Bass

BASS_INPUT_OFF

Bass

BASS_INPUT_ON

Bass

BASS_INPUT_TYPE_ANALOG

Bass

BASS_INPUT_TYPE_AUX

Bass

BASS_INPUT_TYPE_CD

Bass

BASS_INPUT_TYPE_DIGITAL

Bass

BASS_INPUT_TYPE_LINE

Bass

BASS_INPUT_TYPE_MASK

Bass

BASS_INPUT_TYPE_MIC

Bass

BASS_INPUT_TYPE_PHONE

Bass

BASS_INPUT_TYPE_SPEAKER

Bass

BASS_INPUT_TYPE_SYNTH

Bass

BASS_INPUT_TYPE_UNDEF

Bass

BASS_INPUT_TYPE_WAVE

Bass

BASS_MP3_SETPOS

Bass

BASS_MUSIC_3D

Bass

BASS_MUSIC_ATTRIB_AMPLIFY

Bass

BASS_MUSIC_ATTRIB_BPM

Bass

BASS_MUSIC_ATTRIB_PANSEP

Bass

BASS_MUSIC_ATTRIB_PSCALER

Bass

BASS_MUSIC_ATTRIB_SPEED

Bass

BASS_MUSIC_ATTRIB_VOL_CHAN

Bass

BASS_MUSIC_ATTRIB_VOL_GLOBAL

Bass

BASS_MUSIC_ATTRIB_VOL_INST

Bass

BASS_MUSIC_AUTOFREE

Bass

BASS_MUSIC_CALCLEN

Bass

BASS_MUSIC_DECODE

Bass

BASS_MUSIC_FLOAT

Bass

BASS_MUSIC_FT2MOD

Bass

BASS_MUSIC_FX

Bass

BASS_MUSIC_LOOP

Bass

BASS_MUSIC_MONO

Bass

BASS_MUSIC_NONINTER

Bass

BASS_MUSIC_NOSAMPLE

Bass

BASS_MUSIC_POSRESET

Bass

BASS_MUSIC_POSRESETEX

Bass

BASS_MUSIC_PRESCAN

Bass

BASS_MUSIC_PT1MOD

Bass

BASS_MUSIC_RAMP

Bass

BASS_MUSIC_RAMPS

Bass

BASS_MUSIC_STOPBACK

Bass

BASS_MUSIC_SURROUND

Bass

BASS_MUSIC_SURROUND2

Bass

BASS_NET_BUFFER

Bass

BASS_NET_TIMEOUT

Bass

BASS_OBJECT_DS

Bass

BASS_OBJECT_DS3DL

Bass

BASS_OK

Bass

BASS_RECORD_PAUSE

Bass

BASS_SAMPLE_3D

Bass

BASS_SAMPLE_8BITS

Bass

BASS_SAMPLE_FLOAT

Bass

BASS_SAMPLE_FX

Bass

BASS_SAMPLE_LOOP

Bass

BASS_SAMPLE_MONO

Bass

BASS_SAMPLE_MUTEMAX

Bass

BASS_SAMPLE_OVER_DIST

Bass

BASS_SAMPLE_OVER_POS

Bass

BASS_SAMPLE_OVER_VOL

Bass

BASS_SAMPLE_SOFTWARE

Bass

BASS_SAMPLE_VAM

Bass

BASS_SLIDE_FREQ

Bass

BASS_SLIDE_PAN

Bass

BASS_SLIDE_VOL

Bass

BASS_SPEAKER_CENLFE

Bass

BASS_SPEAKER_CENTER

Bass

BASS_SPEAKER_FRONT

Bass

BASS_SPEAKER_FRONTLEFT

Bass

BASS_SPEAKER_FRONTRIGHT

Bass

BASS_SPEAKER_LEFT

Bass

BASS_SPEAKER_LFE

Bass

BASS_SPEAKER_REAR

Bass

BASS_SPEAKER_REAR2

Bass

BASS_SPEAKER_REAR2LEFT

Bass

BASS_SPEAKER_REAR2RIGHT

Bass

BASS_SPEAKER_REARLEFT

Bass

BASS_SPEAKER_REARRIGHT

Bass

BASS_SPEAKER_RIGHT

Bass

BASS_STREAMPROC_END

Bass

BASS_STREAM_AUTOFREE

Bass

BASS_STREAM_BLOCK

Bass

BASS_STREAM_DECODE

Bass

BASS_STREAM_PRESCAN

Bass

BASS_STREAM_RESTRATE

Bass

BASS_STREAM_STATUS

Bass

BASS_SYNC_DOWNLOAD

Bass

BASS_SYNC_END

Bass

BASS_SYNC_FREE

Bass

BASS_SYNC_MESSAGE

Bass

BASS_SYNC_META

Bass

BASS_SYNC_MIXTIME

Bass

BASS_SYNC_MUSICFX

Bass

BASS_SYNC_MUSICINST

Bass

BASS_SYNC_MUSICPOS

Bass

BASS_SYNC_ONETIME

Bass

BASS_SYNC_POS

Bass

BASS_SYNC_SETPOS

Bass

BASS_SYNC_SLIDE

Bass

BASS_SYNC_STALL

Bass

BASS_TAG_HTTP

Bass

BASS_TAG_ICY

Bass

BASS_TAG_ID3

Bass

BASS_TAG_ID3V2

Bass

BASS_TAG_LYRICS3

Bass

BASS_TAG_META

Bass

BASS_TAG_MUSIC_INST

Bass

BASS_TAG_MUSIC_MESSAGE

Bass

BASS_TAG_MUSIC_NAME

Bass

BASS_TAG_MUSIC_SAMPLE

Bass

BASS_TAG_OGG

Bass

BASS_TAG_RIFF_INFO

Bass

BASS_TAG_VENDOR

Bass

BASS_UNICODE

Bass

BASS_VAM_HARDWARE

Bass

BASS_VAM_SOFTWARE

Bass

BASS_VAM_TERM_DIST

Bass

BASS_VAM_TERM_PRIO

Bass

BASS_VAM_TERM_TIME

Bass

BEHAVIOURS_SELECTED

GLSceneEditLCL

BEHAVIOURS_SELECTED

GLSceneEdit

BitMapStrMax3DS

Const3DS

BIT_MAP

Const3DS

BI_1632

GLSVfw

BottomFalloff

Const3DS

BOUNDBOX

Const3DS

BufSize

GLFileOBJ

c180

VectorGeometry

c180divPI

VectorGeometry

c2PI

VectorGeometry

c360

VectorGeometry

c3PIdiv2

VectorGeometry

c3PIdiv4

VectorGeometry

cAllAttribBits

GLState

cAllColorComponents

GLState

cAllFrustrumParts

GLGeomObjects

callibname

openal

cAllMeshPrimitive

GLState

cAllStatesChanged

GLPipelineTransformation

calutlibname

openal

CAMERA_NODE_TAG

Const3DS

CAM_RANGES

Const3DS

CAM_SEE_CONE

Const3DS

cBackwardContextFailed

GLWin32Context

CBBBack

GeometryBB

CBBBottom

GeometryBB

CBBFront

GeometryBB

CBBLeft

GeometryBB

CBBPlans

GeometryBB

CBBRight

GeometryBB

CBBTop

GeometryBB

cColinearBias

VectorGeometry

cContextActivationFailed

GLContext

cContextDeactivationFailed

GLContext

cDefaultFlareElements

GLLensFlare

cDefaultGLActorOptions

GLVectorFileObjects

cDefaultImposterOptions

GLImposter

cDefaultMirrorOptions

GLMirror

cDefaultNormalMapScale

GLColor

cDefaultNormalMapScale

GLTexture

cDefaultProxyOptions

GLScene

cDefaultScreenSaverOptions

ScreenSaver

cDefaultSDLWindowOptions

GLSDLWindow

cDefaultShadowPlaneOptions

GLShadowPlane

cDefaultSwizzleVector

GLTextureFormat

cDefaultWaterPlaneOptions

GLWaterPlane

cDEFAULT_CONSTRAINT_FRICTION

VerletClasses

cDEFAULT_TIMER_INTERVAL

AsyncTimer

cDeleteContextFailed

GLContext

CDirPlan

GeometryBB

CD_FPS

GLSDL

cECCloseDistance

GLEllipseCollision

CENTERJSAMPLE

GLSJPG

cFailHWRC

GLWin32Context

cForwardContextFailed

GLWin32Context

CgGLlibrary

cgGL

cGLBlendEquationToGLEnum

GLState

cGLBlendFunctionToGLEnum

GLState

cGLBufferBindingTarget

GLState

cGLComparisonFunctionToGLEnum

GLState

cGLCullFaceModeToGLEnum

GLState

cGLFaceWindingToGLEnum

GLState

cGLgsInTypes

GLSLParameter

cGLgsOutTypes

GLSLParameter

cGLHintToGLEnum

GLState

cGLLogicOpToGLEnum

GLState

cGLPolygonModeToGLEnum

GLState

cGLQueryTypeToGLEnum

GLState

cGLSLSamplerString

GLSLParameter

cGLSLTypeString

GLSLParameter

cGLStateToGLEnum

GLState

cGLStateTypeToGLEnum

GLState

cGLStencilOpToGLEnum

GLState

cGLTexTypeToGLEnum

GLState

CG_GL_FRAGMENT

cgGL

CG_GL_MATRIX_IDENTITY

cgGL

CG_GL_MATRIX_INVERSE

cgGL

CG_GL_MATRIX_INVERSE_TRANSPOSE

cgGL

CG_GL_MATRIX_TRANSPOSE

cgGL

CG_GL_MODELVIEW_MATRIX

cgGL

CG_GL_MODELVIEW_PROJECTION_MATRIX

cgGL

CG_GL_PROJECTION_MATRIX

cgGL

CG_GL_TEXTURE_MATRIX

cgGL

CG_GL_VERTEX

cgGL

cHTFHashTableSize

HeightTileFile

cHTFQuadTableSize

HeightTileFile

ChunkType

Const3DS

ChunkUnique

Const3DS

cImageDataFormat16bits

DXTC

cImageDataFormat24bits

DXTC

cImageDataFormat32bits

DXTC

cImageDataFormat8bits

DXTC

cIncompatibleContexts

GLContext

cInv2PI

VectorGeometry

cInv360

VectorGeometry

ckidAVIMAINHDR

GLSVfw

ckidAVINEWINDEX

GLSVfw

ckidAVIPADDING

GLSVfw

ckidSTREAMFORMAT

GLSVfw

ckidSTREAMHANDLERDATA

GLSVfw

ckidSTREAMHEADER

GLSVfw

ckidSTREAMNAME

GLSVfw

cktypeDIBbits

GLSVfw

cktypeDIBcompressed

GLSVfw

cktypePALchange

GLSVfw

cktypeWAVEbytes

GLSVfw

clActiveBackground

GLColor

clActiveBase

GLColor

clActiveBrightText

GLColor

clActiveButton

GLColor

clActiveButtonText

GLColor

clActiveDark

GLColor

clActiveForeground

GLColor

clActiveHighlight

GLColor

clActiveHighlightedText

GLColor

clActiveLight

GLColor

clActiveMid

GLColor

clActiveMidlight

GLColor

clActiveShadow

GLColor

clActiveText

GLColor

clBackground

GLColor

clBase

GLColor

clBrightText

GLColor

clButton

GLColor

clButtonText

GLColor

clDark

GLColor

clDisabledBackground

GLColor

clDisabledBase

GLColor

clDisabledBrightText

GLColor

clDisabledButton

GLColor

clDisabledButtonText

GLColor

clDisabledDark

GLColor

clDisabledForeground

GLColor

clDisabledHighlight

GLColor

clDisabledHighlightedText

GLColor

clDisabledLight

GLColor

clDisabledMid

GLColor

clDisabledMidlight

GLColor

clDisabledShadow

GLColor

clDisabledText

GLColor

clDontMask

GLColor

clFirstSpecialColor

GLColor

clForeground

GLColor

clHighlight

GLColor

clHighlightedText

GLColor

clLight

GLColor

clMask

GLColor

clMid

GLColor

clMidlight

GLColor

cLn10

VectorGeometry

clNormalBackground

GLColor

clNormalBase

GLColor

clNormalBrightText

GLColor

clNormalButton

GLColor

clNormalButtonText

GLColor

clNormalDark

GLColor

clNormalForeground

GLColor

clNormalHighlight

GLColor

clNormalHighlightedText

GLColor

clNormalLight

GLColor

clNormalMid

GLColor

clNormalMidlight

GLColor

clNormalShadow

GLColor

clNormalText

GLColor

cloActive

GLColor

cloDisabled

GLColor

cloNormal

GLColor

ClosedPolygon2D

GLTypes

ClosedPolygon3D

GLTypes

clr3DDkShadow

GLColor

clr3DLight

GLColor

clrActiveBorder

GLColor

clrActiveCaption

GLColor

clrAppWorkSpace

GLColor

clrAqua

GLColor

clrAquamarine

GLColor

clrBackground

GLColor

clrBakersChoc

GLColor

clrBlack

GLColor

clrBlue

GLColor

clrBlueViolet

GLColor

clrBrass

GLColor

clrBrightGold

GLColor

clrBronze

GLColor

clrBronze2

GLColor

clrBrown

GLColor

clrBtnFace

GLColor

clrBtnHighlight

GLColor

clrBtnShadow

GLColor

clrBtnText

GLColor

clrCadetBlue

GLColor

clrCaptionText

GLColor

clrCoolCopper

GLColor

clrCopper

GLColor

clrCoral

GLColor

clrCornflowerBlue

GLColor

clrDarkBrown

GLColor

clrDarkGreen

GLColor

clrDarkOliveGreen

GLColor

clrDarkOrchid

GLColor

clrDarkPurple

GLColor

clrDarkSlateBlue

GLColor

clrDarkSlateGray

GLColor

clrDarkSlateGrey

GLColor

clrDarkTan

GLColor

clrDarkTurquoise

GLColor

clrDarkWood

GLColor

clrDimGray

GLColor

clrDkGreenCopper

GLColor

clrDustyRose

GLColor

clrFeldspar

GLColor

clrFirebrick

GLColor

clrFlesh

GLColor

clrForestGreen

GLColor

clrFuchsia

GLColor

clrGold

GLColor

clrGoldenrod

GLColor

clrGray

GLColor

clrGray05

GLColor

clrGray10

GLColor

clrGray15

GLColor

clrGray20

GLColor

clrGray25

GLColor

clrGray30

GLColor

clrGray35

GLColor

clrGray40

GLColor

clrGray45

GLColor

clrGray50

GLColor

clrGray55

GLColor

clrGray60

GLColor

clrGray65

GLColor

clrGray70

GLColor

clrGray75

GLColor

clrGray80

GLColor

clrGray85

GLColor

clrGray90

GLColor

clrGray95

GLColor

clrGrayText

GLColor

clrGreen

GLColor

clrGreenCopper

GLColor

clrGreenYellow

GLColor

clrHighlight

GLColor

clrHighlightText

GLColor

clrHuntersGreen

GLColor

clrInactiveBorder

GLColor

clrInactiveCaption

GLColor

clrInactiveCaptionText

GLColor

clrIndian

GLColor

clrInfoBk

GLColor

clrInfoText

GLColor

clrKhaki

GLColor

clrLightBlue

GLColor

clrLightGray

GLColor

clrLightPurple

GLColor

clrLightSteelBlue

GLColor

clrLightWood

GLColor

clrLime

GLColor

clrLimeGreen

GLColor

clrMandarinOrange

GLColor

clrMaroon

GLColor

clrMediumAquamarine

GLColor

clrMediumBlue

GLColor

clrMediumForestGreen

GLColor

clrMediumGoldenrod

GLColor

clrMediumOrchid

GLColor

clrMediumPurple

GLColor

clrMediumSeaGreen

GLColor

clrMediumSlateBlue

GLColor

clrMediumSpringGreen

GLColor

clrMediumTurquoise

GLColor

clrMediumViolet

GLColor

clrMediumWood

GLColor

clrMenu

GLColor

clrMenuText

GLColor

clrMidnightBlue

GLColor

clrNavy

GLColor

clrNavyBlue

GLColor

clrNeonBlue

GLColor

clrNeonPink

GLColor

clrNewMidnightBlue

GLColor

clrNewTan

GLColor

clrOldGold

GLColor

clrOlive

GLColor

clrOrange

GLColor

clrOrangeRed

GLColor

clrOrchid

GLColor

clrPaleGreen

GLColor

clrPink

GLColor

clrPlum

GLColor

clrPurple

GLColor

clrQuartz

GLColor

clrRed

GLColor

clrRichBlue

GLColor

clrSalmon

GLColor

clrScarlet

GLColor

clrScrollBar

GLColor

clrSeaGreen

GLColor

clrSemiSweetChoc

GLColor

clrSienna

GLColor

clrSilver

GLColor

clrSkyBlue

GLColor

clrSlateBlue

GLColor

clrSpicyPink

GLColor

clrSpringGreen

GLColor

clrSteelBlue

GLColor

clrSummerSky

GLColor

clrTan

GLColor

clrTeal

GLColor

clrThistle

GLColor

clrTransparent

GLColor

clrTurquoise

GLColor

clrVeryDarkBrown

GLColor

clrVeryLightPurple

GLColor

clrViolet

GLColor

clrVioletRed

GLColor

clrWheat

GLColor

clrWhite

GLColor

clrWindow

GLColor

clrWindowFrame

GLColor

clrWindowText

GLColor

clrYellow

GLColor

clrYellowGreen

GLColor

clShadow

GLColor

CLSID_AVIFile

GLSVfw

CLSID_AVISimpleUnMarshal

GLSVfw

clText

GLColor

CL_A

GLS_CL

CL_ADDRESS_CLAMP

GLS_CL

CL_ADDRESS_CLAMP_TO_EDGE

GLS_CL

CL_ADDRESS_NONE

GLS_CL

CL_ADDRESS_REPEAT

GLS_CL

CL_ARGB

GLS_CL

CL_BGRA

GLS_CL

CL_BUILD_ERROR

GLS_CL

CL_BUILD_IN_PROGRESS

GLS_CL

CL_BUILD_NONE

GLS_CL

CL_BUILD_PROGRAM_FAILURE

GLS_CL

CL_BUILD_SUCCESS

GLS_CL

CL_CHAR_BIT

GLS_CL_Platform

CL_CHAR_MAX

GLS_CL_Platform

CL_CHAR_MIN

GLS_CL_Platform

CL_COMMAND_ACQUIRE_GL_OBJECTS

GLS_CL

CL_COMMAND_COPY_BUFFER

GLS_CL

CL_COMMAND_COPY_BUFFER_TO_IMAGE

GLS_CL

CL_COMMAND_COPY_IMAGE

GLS_CL

CL_COMMAND_COPY_IMAGE_TO_BUFFER

GLS_CL

CL_COMMAND_MAP_BUFFER

GLS_CL

CL_COMMAND_MAP_IMAGE

GLS_CL

CL_COMMAND_MARKER

GLS_CL

CL_COMMAND_NATIVE_KERNEL

GLS_CL

CL_COMMAND_NDRANGE_KERNEL

GLS_CL

CL_COMMAND_READ_BUFFER

GLS_CL

CL_COMMAND_READ_IMAGE

GLS_CL

CL_COMMAND_RELEASE_GL_OBJECTS

GLS_CL

CL_COMMAND_TASK

GLS_CL

CL_COMMAND_UNMAP_MEM_OBJECT

GLS_CL

CL_COMMAND_WRITE_BUFFER

GLS_CL

CL_COMMAND_WRITE_IMAGE

GLS_CL

CL_COMPILER_NOT_AVAILABLE

GLS_CL

CL_COMPLETE

GLS_CL

CL_CONTEXT_DEVICES

GLS_CL

CL_CONTEXT_PLATFORM

GLS_CL

CL_CONTEXT_PROPERTIES

GLS_CL

CL_CONTEXT_REFERENCE_COUNT

GLS_CL

CL_DBL_DIG

GLS_CL_Platform

CL_DBL_EPSILON

GLS_CL_Platform

CL_DBL_MANT_DIG

GLS_CL_Platform

CL_DBL_MAX

GLS_CL_Platform

CL_DBL_MAX_10_EXP

GLS_CL_Platform

CL_DBL_MAX_EXP

GLS_CL_Platform

CL_DBL_MIN

GLS_CL_Platform

CL_DBL_MIN_10_EXP

GLS_CL_Platform

CL_DBL_MIN_EXP

GLS_CL_Platform

CL_DBL_RADIX

GLS_CL_Platform

CL_DEVICE_ADDRESS_BITS

GLS_CL

CL_DEVICE_AVAILABLE

GLS_CL

CL_DEVICE_COMPILER_AVAILABLE

GLS_CL

CL_DEVICE_ENDIAN_LITTLE

GLS_CL

CL_DEVICE_ERROR_CORRECTION_SUPPORT

GLS_CL

CL_DEVICE_EXECUTION_CAPABILITIES

GLS_CL

CL_DEVICE_EXTENSIONS

GLS_CL

CL_DEVICE_GLOBAL_MEM_CACHELINE_SIZE

GLS_CL

CL_DEVICE_GLOBAL_MEM_CACHE_SIZE

GLS_CL

CL_DEVICE_GLOBAL_MEM_CACHE_TYPE

GLS_CL

CL_DEVICE_GLOBAL_MEM_SIZE

GLS_CL

CL_DEVICE_IMAGE2D_MAX_HEIGHT

GLS_CL

CL_DEVICE_IMAGE2D_MAX_WIDTH

GLS_CL

CL_DEVICE_IMAGE3D_MAX_DEPTH

GLS_CL

CL_DEVICE_IMAGE3D_MAX_HEIGHT

GLS_CL

CL_DEVICE_IMAGE3D_MAX_WIDTH

GLS_CL

CL_DEVICE_IMAGE_SUPPORT

GLS_CL

CL_DEVICE_LOCAL_MEM_SIZE

GLS_CL

CL_DEVICE_LOCAL_MEM_TYPE

GLS_CL

CL_DEVICE_MAX_CLOCK_FREQUENCY

GLS_CL

CL_DEVICE_MAX_COMPUTE_UNITS

GLS_CL

CL_DEVICE_MAX_CONSTANT_ARGS

GLS_CL

CL_DEVICE_MAX_CONSTANT_BUFFER_SIZE

GLS_CL

CL_DEVICE_MAX_MEM_ALLOC_SIZE

GLS_CL

CL_DEVICE_MAX_PARAMETER_SIZE

GLS_CL

CL_DEVICE_MAX_READ_IMAGE_ARGS

GLS_CL

CL_DEVICE_MAX_SAMPLERS

GLS_CL

CL_DEVICE_MAX_WORK_GROUP_SIZE

GLS_CL

CL_DEVICE_MAX_WORK_ITEM_DIMENSIONS

GLS_CL

CL_DEVICE_MAX_WORK_ITEM_SIZES

GLS_CL

CL_DEVICE_MAX_WRITE_IMAGE_ARGS

GLS_CL

CL_DEVICE_MEM_BASE_ADDR_ALIGN

GLS_CL

CL_DEVICE_MIN_DATA_TYPE_ALIGN_SIZE

GLS_CL

CL_DEVICE_NAME

GLS_CL

CL_DEVICE_NOT_AVAILABLE

GLS_CL

CL_DEVICE_NOT_FOUND

GLS_CL

CL_DEVICE_PLATFORM

GLS_CL

CL_DEVICE_PREFERRED_VECTOR_WIDTH_CHAR

GLS_CL

CL_DEVICE_PREFERRED_VECTOR_WIDTH_DOUBLE

GLS_CL

CL_DEVICE_PREFERRED_VECTOR_WIDTH_FLOAT

GLS_CL

CL_DEVICE_PREFERRED_VECTOR_WIDTH_INT

GLS_CL

CL_DEVICE_PREFERRED_VECTOR_WIDTH_LONG

GLS_CL

CL_DEVICE_PREFERRED_VECTOR_WIDTH_SHORT

GLS_CL

CL_DEVICE_PROFILE

GLS_CL

CL_DEVICE_PROFILING_TIMER_RESOLUTION

GLS_CL

CL_DEVICE_QUEUE_PROPERTIES

GLS_CL

CL_DEVICE_SINGLE_FP_CONFIG

GLS_CL

CL_DEVICE_TYPE

GLS_CL

CL_DEVICE_TYPE_ACCELERATOR

GLS_CL

CL_DEVICE_TYPE_ALL

GLS_CL

CL_DEVICE_TYPE_CPU

GLS_CL

CL_DEVICE_TYPE_DEFAULT

GLS_CL

CL_DEVICE_TYPE_GPU

GLS_CL

CL_DEVICE_VENDOR

GLS_CL

CL_DEVICE_VENDOR_ID

GLS_CL

CL_DEVICE_VERSION

GLS_CL

CL_DRIVER_VERSION

GLS_CL

CL_EVENT_COMMAND_EXECUTION_STATUS

GLS_CL

CL_EVENT_COMMAND_QUEUE

GLS_CL

CL_EVENT_COMMAND_TYPE

GLS_CL

CL_EVENT_REFERENCE_COUNT

GLS_CL

CL_EXEC_KERNEL

GLS_CL

CL_EXEC_NATIVE_KERNEL

GLS_CL

CL_FALSE

GLS_CL

CL_FILTER_LINEAR

GLS_CL

CL_FILTER_NEAREST

GLS_CL

CL_FLOAT

GLS_CL

CL_FLT_DIG

GLS_CL_Platform

CL_FLT_EPSILON

GLS_CL_Platform

CL_FLT_MANT_DIG

GLS_CL_Platform

CL_FLT_MAX

GLS_CL_Platform

CL_FLT_MAX_10_EXP

GLS_CL_Platform

CL_FLT_MAX_EXP

GLS_CL_Platform

CL_FLT_MIN

GLS_CL_Platform

CL_FLT_MIN_10_EXP

GLS_CL_Platform

CL_FLT_MIN_EXP

GLS_CL_Platform

CL_FLT_RADIX

GLS_CL_Platform

CL_FP_DENORM

GLS_CL

CL_FP_FMA

GLS_CL

CL_FP_INF_NAN

GLS_CL

CL_FP_ROUND_TO_INF

GLS_CL

CL_FP_ROUND_TO_NEAREST

GLS_CL

CL_FP_ROUND_TO_ZERO

GLS_CL

CL_GLOBAL

GLS_CL

CL_GL_MIPMAP_LEVEL

GLS_CL_GL

CL_GL_OBJECT_BUFFER

GLS_CL_GL

CL_GL_OBJECT_RENDERBUFFER

GLS_CL_GL

CL_GL_OBJECT_TEXTURE2D

GLS_CL_GL

CL_GL_OBJECT_TEXTURE3D

GLS_CL_GL

CL_GL_TEXTURE_TARGET

GLS_CL_GL

CL_HALF_FLOAT

GLS_CL

CL_IMAGE_DEPTH

GLS_CL

CL_IMAGE_ELEMENT_SIZE

GLS_CL

CL_IMAGE_FORMAT

GLS_CL

CL_IMAGE_FORMAT_MISMATCH

GLS_CL

CL_IMAGE_FORMAT_NOT_SUPPORTED

GLS_CL

CL_IMAGE_HEIGHT

GLS_CL

CL_IMAGE_ROW_PITCH

GLS_CL

CL_IMAGE_SLICE_PITCH

GLS_CL

CL_IMAGE_WIDTH

GLS_CL

CL_INTENSITY

GLS_CL

CL_INT_MAX

GLS_CL_Platform

CL_INT_MIN

GLS_CL_Platform

CL_INVALID_ARG_INDEX

GLS_CL

CL_INVALID_ARG_SIZE

GLS_CL

CL_INVALID_ARG_VALUE

GLS_CL

CL_INVALID_BINARY

GLS_CL

CL_INVALID_BUFFER_SIZE

GLS_CL

CL_INVALID_BUILD_OPTIONS

GLS_CL

CL_INVALID_COMMAND_QUEUE

GLS_CL

CL_INVALID_CONTEXT

GLS_CL

CL_INVALID_DEVICE

GLS_CL

CL_INVALID_DEVICE_TYPE

GLS_CL

CL_INVALID_EVENT

GLS_CL

CL_INVALID_EVENT_WAIT_LIST

GLS_CL

CL_INVALID_GLOBAL_OFFSET

GLS_CL

CL_INVALID_GLOBAL_WORK_SIZE

GLS_CL

CL_INVALID_GL_OBJECT

GLS_CL

CL_INVALID_HOST_PTR

GLS_CL

CL_INVALID_IMAGE_FORMAT_DESCRIPTOR

GLS_CL

CL_INVALID_IMAGE_SIZE

GLS_CL

CL_INVALID_KERNEL

GLS_CL

CL_INVALID_KERNEL_ARGS

GLS_CL

CL_INVALID_KERNEL_DEFINITION

GLS_CL

CL_INVALID_KERNEL_NAME

GLS_CL

CL_INVALID_MEM_OBJECT

GLS_CL

CL_INVALID_MIP_LEVEL

GLS_CL

CL_INVALID_OPERATION

GLS_CL

CL_INVALID_PLATFORM

GLS_CL

CL_INVALID_PROGRAM

GLS_CL

CL_INVALID_PROGRAM_EXECUTABLE

GLS_CL

CL_INVALID_QUEUE_PROPERTIES

GLS_CL

CL_INVALID_SAMPLER

GLS_CL

CL_INVALID_VALUE

GLS_CL

CL_INVALID_WORK_DIMENSION

GLS_CL

CL_INVALID_WORK_GROUP_SIZE

GLS_CL

CL_INVALID_WORK_ITEM_SIZE

GLS_CL

CL_KERNEL_COMPILE_WORK_GROUP_SIZE

GLS_CL

CL_KERNEL_CONTEXT

GLS_CL

CL_KERNEL_FUNCTION_NAME

GLS_CL

CL_KERNEL_LOCAL_MEM_SIZE

GLS_CL

CL_KERNEL_NUM_ARGS

GLS_CL

CL_KERNEL_PROGRAM

GLS_CL

CL_KERNEL_REFERENCE_COUNT

GLS_CL

CL_KERNEL_WORK_GROUP_SIZE

GLS_CL

CL_LOCAL

GLS_CL

CL_LONG_MAX

GLS_CL_Platform

CL_LONG_MIN

GLS_CL_Platform

CL_LUMINANCE

GLS_CL

CL_MAP_FAILURE

GLS_CL

CL_MAP_READ

GLS_CL

CL_MAP_WRITE

GLS_CL

CL_MEM_ALLOC_HOST_PTR

GLS_CL

CL_MEM_CONTEXT

GLS_CL

CL_MEM_COPY_HOST_PTR

GLS_CL

CL_MEM_COPY_OVERLAP

GLS_CL

CL_MEM_FLAGS

GLS_CL

CL_MEM_HOST_PTR

GLS_CL

CL_MEM_MAP_COUNT

GLS_CL

CL_MEM_OBJECT_ALLOCATION_FAILURE

GLS_CL

CL_MEM_OBJECT_BUFFER

GLS_CL

CL_MEM_OBJECT_IMAGE2D

GLS_CL

CL_MEM_OBJECT_IMAGE3D

GLS_CL

CL_MEM_READ_ONLY

GLS_CL

CL_MEM_READ_WRITE

GLS_CL

CL_MEM_REFERENCE_COUNT

GLS_CL

CL_MEM_SIZE

GLS_CL

CL_MEM_TYPE

GLS_CL

CL_MEM_USE_HOST_PTR

GLS_CL

CL_MEM_WRITE_ONLY

GLS_CL

CL_NONE

GLS_CL

CL_OUT_OF_HOST_MEMORY

GLS_CL

CL_OUT_OF_RESOURCES

GLS_CL

CL_PLATFORM_EXTENSIONS

GLS_CL

CL_PLATFORM_NAME

GLS_CL

CL_PLATFORM_PROFILE

GLS_CL

CL_PLATFORM_VENDOR

GLS_CL

CL_PLATFORM_VERSION

GLS_CL

CL_PROFILING_COMMAND_END

GLS_CL

CL_PROFILING_COMMAND_QUEUED

GLS_CL

CL_PROFILING_COMMAND_START

GLS_CL

CL_PROFILING_COMMAND_SUBMIT

GLS_CL

CL_PROFILING_INFO_NOT_AVAILABLE

GLS_CL

CL_PROGRAM_BINARIES

GLS_CL

CL_PROGRAM_BINARY_SIZES

GLS_CL

CL_PROGRAM_BUILD_LOG

GLS_CL

CL_PROGRAM_BUILD_OPTIONS

GLS_CL

CL_PROGRAM_BUILD_STATUS

GLS_CL

CL_PROGRAM_CONTEXT

GLS_CL

CL_PROGRAM_DEVICES

GLS_CL

CL_PROGRAM_NUM_DEVICES

GLS_CL

CL_PROGRAM_REFERENCE_COUNT

GLS_CL

CL_PROGRAM_SOURCE

GLS_CL

CL_QUEUED

GLS_CL

CL_QUEUE_CONTEXT

GLS_CL

CL_QUEUE_DEVICE

GLS_CL

CL_QUEUE_OUT_OF_ORDER_EXEC_MODE_ENABLE

GLS_CL

CL_QUEUE_PROFILING_ENABLE

GLS_CL

CL_QUEUE_PROPERTIES

GLS_CL

CL_QUEUE_REFERENCE_COUNT

GLS_CL

CL_R

GLS_CL

CL_RA

GLS_CL

CL_READ_ONLY_CACHE

GLS_CL

CL_READ_WRITE_CACHE

GLS_CL

CL_RG

GLS_CL

CL_RGB

GLS_CL

CL_RGBA

GLS_CL

CL_RUNNING

GLS_CL

CL_SAMPLER_ADDRESSING_MODE

GLS_CL

CL_SAMPLER_CONTEXT

GLS_CL

CL_SAMPLER_FILTER_MODE

GLS_CL

CL_SAMPLER_NORMALIZED_COORDS

GLS_CL

CL_SAMPLER_REFERENCE_COUNT

GLS_CL

CL_SCHAR_MAX

GLS_CL_Platform

CL_SCHAR_MIN

GLS_CL_Platform

CL_SHRT_MAX

GLS_CL_Platform

CL_SHRT_MIN

GLS_CL_Platform

CL_SIGNED_INT16

GLS_CL

CL_SIGNED_INT32

GLS_CL

CL_SIGNED_INT8

GLS_CL

CL_SNORM_INT16

GLS_CL

CL_SNORM_INT8

GLS_CL

CL_SUBMITTED

GLS_CL

CL_SUCCESS

GLS_CL

CL_TRUE

GLS_CL

CL_UCHAR_MAX

GLS_CL_Platform

CL_UINT_MAX

GLS_CL_Platform

CL_ULONG_MAX

GLS_CL_Platform

CL_UNORM_INT16

GLS_CL

CL_UNORM_INT8

GLS_CL

CL_UNORM_INT_101010

GLS_CL

CL_UNORM_SHORT_555

GLS_CL

CL_UNORM_SHORT_565

GLS_CL

CL_UNSIGNED_INT16

GLS_CL

CL_UNSIGNED_INT32

GLS_CL

CL_UNSIGNED_INT8

GLS_CL

CL_USHRT_MAX

GLS_CL_Platform

CL_VERSION_1_0

GLS_CL

CMAGIC

Const3DS

cMaxArray

VectorGeometry

cMaxContacts

GLODERagdoll

cMaxVerts

GLTrail

cMeshModeToGLEnum

GLMesh

CmtNX

GLTexture

CmtNY

GLTexture

CmtNZ

GLTexture

CmtPX

GLTexture

CmtPY

GLTexture

CmtPZ

GLTexture

cNoActiveRC

GLContext

COctree_GROW_GRAVY

SpatialPartitioning

COctree_LEAF_TRHESHOLD

SpatialPartitioning

COctree_MAX_TREE_DEPTH

SpatialPartitioning

ColorFMax3DS

Const3DS

ColorFMin3DS

Const3DS

COLOR_24

Const3DS

COLOR_F

Const3DS

ColTrackTagMax3DS

Const3DS

ColTrackTagMin3DS

Const3DS

COL_TRACK_TAG

Const3DS

COL_TRACK_TAG_KEY

Const3DS

comptypeDIB

GLSVfw

cOneHalf

VectorGeometry

CONSOLE_MAX_COMMANDS

GLConsole

CONTACTS_UNIMPORTANT

ODEImport

Container

Const3DS

CONTROLCALLBACK_CAPTURING

GLSVfw

CONTROLCALLBACK_PREROLL

GLSVfw

cPERLIN_TABLE_SIZE

PerlinNoise

cPFXGranularity

GLParticleFX

cPFXNbRegions

GLParticleFX

cPI

VectorGeometry

cPIdiv180

VectorGeometry

cPIdiv2

VectorGeometry

cPIdiv4

VectorGeometry

CSTATE_RAW_OK

GLSJPG

CSTATE_SCANNING

GLSJPG

CSTATE_START

GLSJPG

CSTATE_WRCOEFS

GLSJPG

cTilesHashSize

GLTerrainRenderer

CUDAAPIDLL

GLS_CUDA_API

CUDARTDLLNAMES

GLS_CUDA_Runtime

CUDART_2_OVER_PI

GLS_CUDA_Runtime

CUDART_2_OVER_PI_F

GLS_CUDA_Runtime

CUDART_3PIO4

GLS_CUDA_Runtime

CUDART_3PIO4_F

GLS_CUDA_Runtime

CUDART_INF

GLS_CUDA_Runtime

CUDART_INF_F

GLS_CUDA_Runtime

CUDART_L2E

GLS_CUDA_Runtime

CUDART_L2E_F

GLS_CUDA_Runtime

CUDART_L2E_HI

GLS_CUDA_Runtime

CUDART_L2E_LO

GLS_CUDA_Runtime

CUDART_L2T

GLS_CUDA_Runtime

CUDART_L2T_F

GLS_CUDA_Runtime

CUDART_LG2

GLS_CUDA_Runtime

CUDART_LG2_F

GLS_CUDA_Runtime

CUDART_LG2_HI

GLS_CUDA_Runtime

CUDART_LG2_LO

GLS_CUDA_Runtime

CUDART_LG2_X_1024

GLS_CUDA_Runtime

CUDART_LG2_X_1075

GLS_CUDA_Runtime

CUDART_LGE

GLS_CUDA_Runtime

CUDART_LGE_F

GLS_CUDA_Runtime

CUDART_LGE_HI

GLS_CUDA_Runtime

CUDART_LGE_LO

GLS_CUDA_Runtime

CUDART_LN2

GLS_CUDA_Runtime

CUDART_LN2_F

GLS_CUDA_Runtime

CUDART_LN2_HI

GLS_CUDA_Runtime

CUDART_LN2_LO

GLS_CUDA_Runtime

CUDART_LN2_X_1024

GLS_CUDA_Runtime

CUDART_LN2_X_1025

GLS_CUDA_Runtime

CUDART_LN2_X_1075

GLS_CUDA_Runtime

CUDART_LNPI

GLS_CUDA_Runtime

CUDART_LNPI_F

GLS_CUDA_Runtime

CUDART_LNT

GLS_CUDA_Runtime

CUDART_LNT_F

GLS_CUDA_Runtime

CUDART_LNT_HI

GLS_CUDA_Runtime

CUDART_LNT_LO

GLS_CUDA_Runtime

CUDART_MAX_NORMAL_F

GLS_CUDA_Runtime

CUDART_MIN_DENORM

GLS_CUDA_Runtime

CUDART_MIN_DENORM_F

GLS_CUDA_Runtime

CUDART_NAN

GLS_CUDA_Runtime

CUDART_NAN_F

GLS_CUDA_Runtime

CUDART_NEG_ZERO

GLS_CUDA_Runtime

CUDART_NEG_ZERO_F

GLS_CUDA_Runtime

CUDART_NORM_HUGE_F

GLS_CUDA_Runtime

CUDART_ONE

GLS_CUDA_Runtime

CUDART_ONE_F

GLS_CUDA_Runtime

CUDART_PI

GLS_CUDA_Runtime

CUDART_PIO2

GLS_CUDA_Runtime

CUDART_PIO2_F

GLS_CUDA_Runtime

CUDART_PIO2_HI

GLS_CUDA_Runtime

CUDART_PIO2_LO

GLS_CUDA_Runtime

CUDART_PIO4

GLS_CUDA_Runtime

CUDART_PIO4_F

GLS_CUDA_Runtime

CUDART_PIO4_HI

GLS_CUDA_Runtime

CUDART_PIO4_LO

GLS_CUDA_Runtime

CUDART_PI_F

GLS_CUDA_Runtime

CUDART_PI_HI

GLS_CUDA_Runtime

CUDART_PI_LO

GLS_CUDA_Runtime

CUDART_REMQUO_BITS_F

GLS_CUDA_Runtime

CUDART_REMQUO_MASK_F

GLS_CUDA_Runtime

CUDART_SQRT_2PI_HI

GLS_CUDA_Runtime

CUDART_SQRT_2PI_LO

GLS_CUDA_Runtime

CUDART_SQRT_HALF

GLS_CUDA_Runtime

CUDART_SQRT_HALF_F

GLS_CUDA_Runtime

CUDART_SQRT_PIO2_HI

GLS_CUDA_Runtime

CUDART_SQRT_PIO2_LO

GLS_CUDA_Runtime

CUDART_SQRT_TWO

GLS_CUDA_Runtime

CUDART_SQRT_TWO_F

GLS_CUDA_Runtime

CUDART_THIRD

GLS_CUDA_Runtime

CUDART_THIRD_F

GLS_CUDA_Runtime

CUDART_TRIG_PLOSS

GLS_CUDA_Runtime

CUDART_TRIG_PLOSS_F

GLS_CUDA_Runtime

CUDART_TWOTHIRD

GLS_CUDA_Runtime

CUDART_TWO_TO_126_F

GLS_CUDA_Runtime

CUDART_TWO_TO_23

GLS_CUDA_Runtime

CUDART_TWO_TO_23_F

GLS_CUDA_Runtime

CUDART_TWO_TO_24_F

GLS_CUDA_Runtime

CUDART_TWO_TO_31_F

GLS_CUDA_Runtime

CUDART_TWO_TO_32_F

GLS_CUDA_Runtime

CUDART_TWO_TO_52

GLS_CUDA_Runtime

CUDART_TWO_TO_54

GLS_CUDA_Runtime

CUDART_TWO_TO_M1022

GLS_CUDA_Runtime

CUDART_TWO_TO_M126_F

GLS_CUDA_Runtime

CUDART_TWO_TO_M54

GLS_CUDA_Runtime

CUDART_ZERO

GLS_CUDA_Runtime

CUDART_ZERO_F

GLS_CUDA_Runtime

cudasFailMap

GLSCUDA

cudasFailUnmap

GLSCUDA

cudasFuncNotConnected

GLSCUDA

cudasInvalidParamType

GLSCUDA

cudasInvalidValue

GLSCUDA

cudasLaunchFailed

GLSCUDA

cudasModuleAbsent

GLSCUDA

cudasOnlyHostData

GLSCUDA

cudasOutOfRange

GLSCUDA

cudasWrongParamSetup

GLSCUDA

CUDA_ERROR_ALREADY_ACQUIRED

GLS_CUDA_API

CUDA_ERROR_ALREADY_MAPPED

GLS_CUDA_API

CUDA_ERROR_ARRAY_IS_MAPPED

GLS_CUDA_API

CUDA_ERROR_CONTEXT_ALREADY_CURRENT

GLS_CUDA_API

CUDA_ERROR_DEINITIALIZED

GLS_CUDA_API

CUDA_ERROR_FILE_NOT_FOUND

GLS_CUDA_API

CUDA_ERROR_INVALID_CONTEXT

GLS_CUDA_API

CUDA_ERROR_INVALID_DEVICE

GLS_CUDA_API

CUDA_ERROR_INVALID_HANDLE

GLS_CUDA_API

CUDA_ERROR_INVALID_IMAGE

GLS_CUDA_API

CUDA_ERROR_INVALID_SOURCE

GLS_CUDA_API

CUDA_ERROR_INVALID_VALUE

GLS_CUDA_API

CUDA_ERROR_LAUNCH_FAILED

GLS_CUDA_API

CUDA_ERROR_LAUNCH_INCOMPATIBLE_TEXTURING

GLS_CUDA_API

CUDA_ERROR_LAUNCH_OUT_OF_RESOURCES

GLS_CUDA_API

CUDA_ERROR_LAUNCH_TIMEOUT

GLS_CUDA_API

CUDA_ERROR_MAP_FAILED

GLS_CUDA_API

CUDA_ERROR_NOT_FOUND

GLS_CUDA_API

CUDA_ERROR_NOT_INITIALIZED

GLS_CUDA_API

CUDA_ERROR_NOT_MAPPED

GLS_CUDA_API

CUDA_ERROR_NOT_MAPPED_AS_ARRAY

GLS_CUDA_API

CUDA_ERROR_NOT_MAPPED_AS_POINTER

GLS_CUDA_API

CUDA_ERROR_NOT_READY

GLS_CUDA_API

CUDA_ERROR_NO_BINARY_FOR_GPU

GLS_CUDA_API

CUDA_ERROR_NO_DEVICE

GLS_CUDA_API

CUDA_ERROR_OUT_OF_MEMORY

GLS_CUDA_API

CUDA_ERROR_POINTER_IS_64BIT

GLS_CUDA_API

CUDA_ERROR_SIZE_IS_64BIT

GLS_CUDA_API

CUDA_ERROR_UNKNOWN

GLS_CUDA_API

CUDA_ERROR_UNMAP_FAILED

GLS_CUDA_API

CUDA_SUCCESS

GLS_CUDA_API

CUDPPDLL

GLS_CUDA_ParallelPrimitives

CUDPP_INVALID_HANDLE

GLS_CUDA_ParallelPrimitives

CUFFTDLLNAMES

GLS_CUDA_FourierTransform

CUFFT_ALLOC_FAILED

GLS_CUDA_FourierTransform

CUFFT_C2C

GLS_CUDA_FourierTransform

CUFFT_C2R

GLS_CUDA_FourierTransform

CUFFT_COMPATIBILITY_FFTW

GLS_CUDA_FourierTransform

CUFFT_COMPATIBILITY_FFTW_C2R_ASYMMETRIC

GLS_CUDA_FourierTransform

CUFFT_COMPATIBILITY_FFTW_PADDING

GLS_CUDA_FourierTransform

CUFFT_COMPATIBILITY_NORMAL

GLS_CUDA_FourierTransform

CUFFT_D2Z

GLS_CUDA_FourierTransform

CUFFT_EXEC_FAILED

GLS_CUDA_FourierTransform

CUFFT_FORWARD

GLS_CUDA_FourierTransform

CUFFT_INTERNAL_ERROR

GLS_CUDA_FourierTransform

CUFFT_INVALID_PLAN

GLS_CUDA_FourierTransform

CUFFT_INVALID_SIZE

GLS_CUDA_FourierTransform

CUFFT_INVALID_TYPE

GLS_CUDA_FourierTransform

CUFFT_INVALID_VALUE

GLS_CUDA_FourierTransform

CUFFT_INVERSE

GLS_CUDA_FourierTransform

CUFFT_R2C

GLS_CUDA_FourierTransform

CUFFT_SETUP_FAILED

GLS_CUDA_FourierTransform

CUFFT_SUCCESS

GLS_CUDA_FourierTransform

CUFFT_Z2D

GLS_CUDA_FourierTransform

CUFFT_Z2Z

GLS_CUDA_FourierTransform

cUnableToCreateLegacyContext

GLContext

cUnknownArchiveVersion

XCollection

CURV_CONTINUITY_FIRST

LWObjects

CURV_CONTINUITY_LAST

LWObjects

CUTILDLL

GLS_CUDA_Utility

CU_MEMHOSTALLOC_DEVICEMAP

GLS_CUDA_API

CU_MEMHOSTALLOC_PORTABLE

GLS_CUDA_API

CU_MEMHOSTALLOC_WRITECOMBINED

GLS_CUDA_API

CU_PARAM_TR_DEFAULT

GLS_CUDA_API

CU_TRSA_OVERRIDE_FORMAT

GLS_CUDA_API

CU_TRSF_NORMALIZED_COORDINATES

GLS_CUDA_API

CU_TRSF_READ_AS_INTEGER

GLS_CUDA_API

cVertexModeToGLEnum

GLMesh

C_ALL_LINES

Const3DS

C_ALPHA_SPLIT

Const3DS

C_ANG_THRESH

Const3DS

C_ANIMLENGTH

Const3DS

C_APPLY_DISP_GAMMA

Const3DS

C_APPLY_FBUF_GAMMA

Const3DS

C_APPLY_FILE_GAMMA

Const3DS

C_ARCH_DENOM

Const3DS

C_ASNAPS

Const3DS

C_AUTO_REFLECT

Const3DS

C_AUTO_SMOOTH

Const3DS

C_AUTO_UNIFY

Const3DS

C_AUTO_WELD

Const3DS

C_BACKUP_FILE

Const3DS

C_BACK_TYPE

Const3DS

C_BGND_METHOD

Const3DS

C_BGND_PRES_RATIO

Const3DS

C_BGTYPE

Const3DS

C_BIAS_DEFAULT

Const3DS

C_BITMAP_DRAWER

Const3DS

C_BLUR_DUR

Const3DS

C_BLUR_FRAMES

Const3DS

C_BLUR_SAMPLES

Const3DS

C_BOOLTYPE

Const3DS

C_BOOLWELD

Const3DS

C_CAMNAME

Const3DS

C_COMM_PORT

Const3DS

C_CONESEGS

Const3DS

C_CONESIDES

Const3DS

C_CONSTS

Const3DS

C_CONT_DEFAULT

Const3DS

C_CUBDRAWER

Const3DS

C_CURMTL_FROM_MESH

Const3DS

C_CURTIME

Const3DS

C_CUR_MNAME

Const3DS

C_DETAIL

Const3DS

C_DISP_GAMMA

Const3DS

C_DITHER_24

Const3DS

C_DITHER_256

Const3DS

C_DXFNAME_SRC

Const3DS

C_DXF_SMOOTH_ANG

Const3DS

C_EDITOR_OK

Const3DS

C_ETAPE

Const3DS

C_FBUF_GAMMA

Const3DS

C_FILE_IN_GAMMA

Const3DS

C_FILE_OUT_GAMMA

Const3DS

C_FLIDRAWER

Const3DS

C_FLIFILE

Const3DS

C_FONTSEL

Const3DS

C_FORCE_WIRE

Const3DS

C_FROZ_DISPLAY

Const3DS

C_GAMMA_CORRECT

Const3DS

C_GEOSMOOTH

Const3DS

C_GET_SHAPE_MAKE_FACES

Const3DS

C_GRIDS

Const3DS

C_GRID_RANGE

Const3DS

C_HEBOT

Const3DS

C_HEDEG

Const3DS

C_HEDIR

Const3DS

C_HEHT

Const3DS

C_HEMISEGS

Const3DS

C_HESEG

Const3DS

C_HETOP

Const3DS

C_HETURNS

Const3DS

C_HI_CONTRAST

Const3DS

C_HOT_CHECK

Const3DS

C_HOT_METHOD

Const3DS

C_IN_DEVICE

Const3DS

C_JPEG_COMPRESSION

Const3DS

C_KEYFRAMER_OK

Const3DS

C_KF_SHOW_BACKFACE

Const3DS

C_KTAPE

Const3DS

C_LMTS_ID

GLFileLMTS

C_LMTS_SUBS

GLFileLMTS

C_LMTS_TEXFNLEN

GLFileLMTS

C_LMTS_TEXT

GLFileLMTS

C_LMTS_TRIS

GLFileLMTS

C_LMTS_VER

GLFileLMTS

C_LOFTER_OK

Const3DS

C_LOFT_L_REPEAT

Const3DS

C_LOFT_UV_NORMALIZE

Const3DS

C_LOFT_WITH_TEXTURE

Const3DS

C_LOFT_W_REPEAT

Const3DS

C_LO_CONTRAST

Const3DS

C_LTAPE

Const3DS

C_LTNAME

Const3DS

C_MAPDRAWER

Const3DS

C_MAPDRAWER1

Const3DS

C_MAPDRAWER2

Const3DS

C_MAPDRAWER3

Const3DS

C_MAPDRAWER4

Const3DS

C_MAPDRAWER5

Const3DS

C_MAPDRAWER6

Const3DS

C_MAPDRAWER7

Const3DS

C_MAPDRAWER8

Const3DS

C_MAPDRAWER9

Const3DS

C_MAPDRAWER_ENTRY

Const3DS

C_MAPTYPE

Const3DS

C_MAP_DISPLAY

Const3DS

C_MAP_MATRIX

Const3DS

C_MAP_MATRIX_OLD

Const3DS

C_MAP_SCALE

Const3DS

C_MAP_WID_HT

Const3DS

C_MAP_XYZ

Const3DS

C_MASTER_AMBIENT

Const3DS

C_MASTER_SCALES

Const3DS

C_MAX_BLOCKS_IN_MCU

GLSJPG

C_MBLUR_DITHER

Const3DS

C_MDRAWER

Const3DS

C_MD_CE

Const3DS

C_MD_CS

Const3DS

C_MD_PDET

Const3DS

C_MD_SDET

Const3DS

C_MD_SML

Const3DS

C_MD_SMW

Const3DS

C_MEDTILE

Const3DS

C_MESHSEL

Const3DS

C_MESHUNSEL

Const3DS

C_MFILE

Const3DS

C_MFTSYM

Const3DS

C_MODDRAWER

Const3DS

C_MODFILE

Const3DS

C_MODICOUNT

Const3DS

C_MODMODEL

Const3DS

C_MODWMODE

Const3DS

C_MSCALE

Const3DS

C_MSCSYM

Const3DS

C_MSHAX

Const3DS

C_MSHCP

Const3DS

C_MSHLOCAL

Const3DS

C_MTLDRAWER

Const3DS

C_MTLFILE

Const3DS

C_MTTSYM

Const3DS

C_NET_FIELD_ORDER

Const3DS

C_NET_USE_GAMMA

Const3DS

C_NET_USE_VPOST

Const3DS

C_NGPARMS

Const3DS

C_NTH_SERIAL_NUM

Const3DS

C_NUM_FORMAT

Const3DS

C_OBJECT_MBLUR

Const3DS

C_OBNAME

Const3DS

C_OPTIMIZE_LOFT

Const3DS

C_PALFILE

Const3DS

C_PAL_TYPE

Const3DS

C_PDRAWER

Const3DS

C_PFILE

Const3DS

C_PICKSIZE

Const3DS

C_PIXEL_SIZE

Const3DS

C_POLYSEL

Const3DS

C_POLYUNSEL

Const3DS

C_PREVMODE

Const3DS

C_PRISMSEGS

Const3DS

C_PRISMSIDES

Const3DS

C_PROGMODE

Const3DS

C_PTHLEVEL

Const3DS

C_PV_DOFNUM

Const3DS

C_PV_FPS

Const3DS

C_PV_FROM

Const3DS

C_PV_METHOD

Const3DS

C_PV_NTH

Const3DS

C_PV_RNG

Const3DS

C_PV_TO

Const3DS

C_PV_TYPE

Const3DS

C_QUIKSTUFF

Const3DS

C_RAX

Const3DS

C_RAY_SHADOWS

Const3DS

C_REFLIP

Const3DS

C_RENDER_ALL

Const3DS

C_RENDTYPE

Const3DS

C_REND_FIELDS

Const3DS

C_REND_FROM

Const3DS

C_REND_NTH

Const3DS

C_REND_TO

Const3DS

C_REND_TSTEP

Const3DS

C_RGB_AA

Const3DS

C_RGB_ANIMTYPE

Const3DS

C_RGB_COMPRESS

Const3DS

C_RGB_DISPDEV

Const3DS

C_RGB_FILE

Const3DS

C_RGB_HARDDEV

Const3DS

C_RGB_HIDE

Const3DS

C_RGB_MAPSW

Const3DS

C_RGB_OUTPUT

Const3DS

C_RGB_OVASPECT

Const3DS

C_RGB_OVH

Const3DS

C_RGB_OVW

Const3DS

C_RGB_PATH

Const3DS

C_RGB_PICTYPE

Const3DS

C_RGB_RMODE

Const3DS

C_RGB_SHADOW

Const3DS

C_RGB_TODISK

Const3DS

C_RGB_TWOSIDE

Const3DS

C_RIPDRAWER

Const3DS

C_RIPFILE

Const3DS

C_RND_MIP

Const3DS

C_RND_TURBO

Const3DS

C_SAFE_FRAME

Const3DS

C_SAVE_LAST

Const3DS

C_SEE_3D

Const3DS

C_SEE_CAMERAS

Const3DS

C_SEE_LIGHTS

Const3DS

C_SEG_END

Const3DS

C_SEG_START

Const3DS

C_SEL_ITEMTOG

Const3DS

C_SEL_RESET

Const3DS

C_SHAPER_OK

Const3DS

C_SHOOK

Const3DS

C_SHOW_1STVERT

Const3DS

C_SHPDRAWER

Const3DS

C_SHPFILE

Const3DS

C_SHPLOCAL

Const3DS

C_SMOOTHING

Const3DS

C_SMOOTH_ANG

Const3DS

C_SNAPS

Const3DS

C_SPHSEGS

Const3DS

C_SRDEG

Const3DS

C_SRDIAM

Const3DS

C_SRDIR

Const3DS

C_SRSEG

Const3DS

C_SS_THRESH

Const3DS

C_STAPE

Const3DS

C_STICKY_KEYINF

Const3DS

C_SUPER_BLACK

Const3DS

C_SUPER_SAMPLE

Const3DS

C_SXP_BUMP_DATA

Const3DS

C_SXP_BUMP_MASKDATA

Const3DS

C_SXP_OPAC_DATA

Const3DS

C_SXP_OPAC_MASKDATA

Const3DS

C_SXP_REFL_MASKDATA

Const3DS

C_SXP_SELFI_DATA

Const3DS

C_SXP_SELFI_MASKDATA

Const3DS

C_SXP_SHIN_DATA

Const3DS

C_SXP_SHIN_MASKDATA

Const3DS

C_SXP_SPEC_DATA

Const3DS

C_SXP_SPEC_MASKDATA

Const3DS

C_SXP_TEXT2_DATA

Const3DS

C_SXP_TEXT2_MASKDATA

Const3DS

C_SXP_TEXT_DATA

Const3DS

C_SXP_TEXT_MASKDATA

Const3DS

C_TAB_BASES

Const3DS

C_TAB_DIVS

Const3DS

C_TDRAWER

Const3DS

C_TENS_DEFAULT

Const3DS

C_TESS_TENSION

Const3DS

C_TESS_TYPE

Const3DS

C_TEXTURE_BLUR_DEFAULT

Const3DS

C_TGA_DEPTH

Const3DS

C_TILE_XY

Const3DS

C_TORSEGS

Const3DS

C_TORSIDES

Const3DS

C_TUBESEGS

Const3DS

C_TUBESIDES

Const3DS

C_TXDRAWER

Const3DS

C_TXFILE

Const3DS

C_TX_STRING

Const3DS

C_USERAX

Const3DS

C_USE_ALPHA

Const3DS

C_VERTMARK

Const3DS

C_VIEW_PRES_RATIO

Const3DS

C_VP_FROM

Const3DS

C_VP_NTH

Const3DS

C_VP_TO

Const3DS

C_VP_TSTEP

Const3DS

C_VTR_FRAMES

Const3DS

C_VTR_HD

Const3DS

C_VTR_HDTL

Const3DS

C_VTR_IN

Const3DS

C_VTR_PK

Const3DS

C_VTR_SH

Const3DS

C_VTR_TL

Const3DS

C_WELD_LOFT

Const3DS

C_WELD_THRESHOLD

Const3DS

C_WORKMTL

Const3DS

C_WORK_MTLS

Const3DS

C_WORK_MTLS_2

Const3DS

C_WORK_MTLS_3

Const3DS

C_WORK_MTLS_4

Const3DS

C_WORK_MTLS_5

Const3DS

C_WORK_MTLS_6

Const3DS

C_WORK_MTLS_7

Const3DS

C_WORK_MTLS_8

Const3DS

C_ZCLIP_POINT

Const3DS

D3D11_RESOURCE_DIMENSION_BUFFER

DXTC

D3D11_RESOURCE_DIMENSION_TEXTURE1D

DXTC

D3D11_RESOURCE_DIMENSION_TEXTURE2D

DXTC

D3D11_RESOURCE_DIMENSION_TEXTURE3D

DXTC

D3D11_RESOURCE_DIMENSION_UNKNOWN

DXTC

DAMP_SHIFT

GLProcTextures

DCEBox

GLDCEMisc

dContactApprox0

ODEImport

dContactApprox1

ODEImport

dContactApprox1_1

ODEImport

dContactApprox1_2

ODEImport

dContactBounce

ODEImport

dContactFDir1

ODEImport

dContactMotion1

ODEImport

dContactMotion2

ODEImport

dContactMotionN

ODEImport

dContactMu2

ODEImport

dContactSlip1

ODEImport

dContactSlip2

ODEImport

dContactSoftCFM

ODEImport

dContactSoftERP

ODEImport

DCTSIZE

GLSJPG

DCTSIZE2

GLSJPG

DCUE_BGND

Const3DS

DDF_ANIMATE

GLSVfw

DDF_BACKGROUNDPAL

GLSVfw

DDF_BUFFER

GLSVfw

DDF_DONTDRAW

GLSVfw

DDF_FULLSCREEN

GLSVfw

DDF_HALFTONE

GLSVfw

DDF_HURRYUP

GLSVfw

DDF_JUSTDRAWIT

GLSVfw

DDF_NOTKEYFRAME

GLSVfw

DDF_PREROLL

GLSVfw

DDF_SAME_DIB

GLSVfw

DDF_SAME_DRAW

GLSVfw

DDF_SAME_HDC

GLSVfw

DDF_SAME_SIZE

GLSVfw

DDF_UPDATE

GLSVfw

DDPF_A

DXTC

DDPF_ALPHAPIXELS

DXTC

DDPF_FOURCC

DXTC

DDPF_L

DXTC

DDPF_LA

DXTC

DDPF_RGB

DXTC

DDPF_RGBA

DXTC

DDSCAPS2_CUBEMAP

DXTC

DDSCAPS2_CUBEMAP_NEGATIVEX

DXTC

DDSCAPS2_CUBEMAP_NEGATIVEY

DXTC

DDSCAPS2_CUBEMAP_NEGATIVEZ

DXTC

DDSCAPS2_CUBEMAP_POSITIVEX

DXTC

DDSCAPS2_CUBEMAP_POSITIVEY

DXTC

DDSCAPS2_CUBEMAP_POSITIVEZ

DXTC

DDSCAPS2_VOLUME

DXTC

DDSCAPS_COMPLEX

DXTC

DDSCAPS_MIPMAP

DXTC

DDSCAPS_TEXTURE

DXTC

DDSD_CAPS

DXTC

DDSD_DEPTH

DXTC

DDSD_HEIGHT

DXTC

DDSD_LINEARSIZE

DXTC

DDSD_MIPMAPCOUNT

DXTC

DDSD_PITCH

DXTC

DDSD_PIXELFORMAT

DXTC

DDSD_WIDTH

DXTC

DEFAULT_VIEW

Const3DS

DefFace3DS

Const3DS

DefKeyHeader3DS

Const3DS

DefKFRotKey3DS

Const3DS

DefObjMat3DS

Const3DS

DEFORM_LIMIT

Const3DS

DefPoint3DS

Const3DS

DefTextVert3DS

Const3DS

DefTrackHeader3DS

Const3DS

DISABLE_NODE

Const3DS

DistanceCueMax3DS

Const3DS

DistanceCueMin3DS

Const3DS

DISTANCE_CUE

Const3DS

dJOINT_INGROUP

ODEImport

dJOINT_REVERSE

ODEImport

dJOINT_TWOBODIES

ODEImport

DLLocalShadow2FMax3DS

Const3DS

DLLocalShadow2FMin3DS

Const3DS

DLLocalShadow2SMax3DS

Const3DS

DLLocalShadow2SMin3DS

Const3DS

DLSpotlightMax3DS

Const3DS

DLSpotlightMin3DS

Const3DS

DL_ATTENUATE

Const3DS

DL_EXCLUDE

Const3DS

DL_INNER_RANGE

Const3DS

DL_LOCAL_SHADOW

Const3DS

DL_LOCAL_SHADOW2

Const3DS

DL_MULTIPLIER

Const3DS

DL_OFF

Const3DS

DL_OUTER_RANGE

Const3DS

DL_RANGE

Const3DS

DL_RAYSHAD

Const3DS

DL_RAY_BIAS

Const3DS

DL_SEE_CONE

Const3DS

DL_SHADOWED

Const3DS

DL_SPOTLIGHT

Const3DS

DL_SPOT_ASPECT

Const3DS

DL_SPOT_OVERSHOOT

Const3DS

DL_SPOT_PROJECTOR

Const3DS

DL_SPOT_RECTANGULAR

Const3DS

DL_SPOT_ROLL

Const3DS

dParamBounce

ODEImport

dParamBounce1

ODEImport

dParamBounce2

ODEImport

dParamBounce3

ODEImport

dParamCFM

ODEImport

dParamCFM1

ODEImport

dParamCFM2

ODEImport

dParamCFM3

ODEImport

dParamERP

ODEImport

dParamERP1

ODEImport

dParamERP2

ODEImport

dParamERP3

ODEImport

dParamFMax

ODEImport

dParamFMax1

ODEImport

dParamFMax2

ODEImport

dParamFMax3

ODEImport

dParamFudgeFactor

ODEImport

dParamFudgeFactor1

ODEImport

dParamFudgeFactor2

ODEImport

dParamFudgeFactor3

ODEImport

dParamGroup

ODEImport

dParamGroup1

ODEImport

dParamGroup2

ODEImport

dParamGroup3

ODEImport

dParamHiStop

ODEImport

dParamHiStop1

ODEImport

dParamHiStop2

ODEImport

dParamHiStop3

ODEImport

dParamLoStop

ODEImport

dParamLoStop1

ODEImport

dParamLoStop2

ODEImport

dParamLoStop3

ODEImport

dParamStopCFM

ODEImport

dParamStopCFM1

ODEImport

dParamStopCFM2

ODEImport

dParamStopCFM3

ODEImport

dParamStopERP

ODEImport

dParamStopERP1

ODEImport

dParamStopERP2

ODEImport

dParamStopERP3

ODEImport

dParamSuspensionCFM

ODEImport

dParamSuspensionCFM1

ODEImport

dParamSuspensionCFM2

ODEImport

dParamSuspensionCFM3

ODEImport

dParamSuspensionERP

ODEImport

dParamSuspensionERP1

ODEImport

dParamSuspensionERP2

ODEImport

dParamSuspensionERP3

ODEImport

dParamVel

ODEImport

dParamVel1

ODEImport

dParamVel2

ODEImport

dParamVel3

ODEImport

DSCAPS_CERTIFIED

Bass

DSCAPS_CONTINUOUSRATE

Bass

DSCAPS_EMULDRIVER

Bass

DSCAPS_SECONDARY16BIT

Bass

DSCAPS_SECONDARY8BIT

Bass

DSCAPS_SECONDARYMONO

Bass

DSCAPS_SECONDARYSTEREO

Bass

DSCCAPS_CERTIFIED

Bass

DSCCAPS_EMULDRIVER

Bass

DSPROPERTY_EAXBUFFER_AIRABSORPTIONFACTOR

openal

DSPROPERTY_EAXBUFFER_ALLPARAMETERS

openal

DSPROPERTY_EAXBUFFER_COMMITDEFERREDSETTINGS

openal

DSPROPERTY_EAXBUFFER_DEFERRED

openal

DSPROPERTY_EAXBUFFER_DIRECT

openal

DSPROPERTY_EAXBUFFER_DIRECTHF

openal

DSPROPERTY_EAXBUFFER_FLAG

openal

DSPROPERTY_EAXBUFFER_IMMEDIATE

openal

DSPROPERTY_EAXBUFFER_NONE

openal

DSPROPERTY_EAXBUFFER_OBSTRUCTION

openal

DSPROPERTY_EAXBUFFER_OBSTRUCTIONLFRATIO

openal

DSPROPERTY_EAXBUFFER_OCCLUSION

openal

DSPROPERTY_EAXBUFFER_OCCLUSIONLFRATIO

openal

DSPROPERTY_EAXBUFFER_OCCLUSIONROOMRATIO

openal

DSPROPERTY_EAXBUFFER_OUTSIDEVOLUMEHF

openal

DSPROPERTY_EAXBUFFER_ROOM

openal

DSPROPERTY_EAXBUFFER_ROOMHF

openal

DSPROPERTY_EAXBUFFER_ROOMROLLOFFFACTOR

openal

DSPROPERTY_EAXLISTENER_AIRABSORPTIONHF

openal

DSPROPERTY_EAXLISTENER_ALLPARAMETERS

openal

DSPROPERTY_EAXLISTENER_COMMITDEFERREDSETTINGS

openal

DSPROPERTY_EAXLISTENER_DECAYHFRATIO

openal

DSPROPERTY_EAXLISTENER_DECAYTIME

openal

DSPROPERTY_EAXLISTENER_DEFERRED

openal

DSPROPERTY_EAXLISTENER_ENVIRONMENT

openal

DSPROPERTY_EAXLISTENER_ENVIRONMENTDIFFUSION

openal

DSPROPERTY_EAXLISTENER_ENVIRONMENTSIZE

openal

DSPROPERTY_EAXLISTENER_FLAGS

openal

DSPROPERTY_EAXLISTENER_IMMEDIATE

openal

DSPROPERTY_EAXLISTENER_NONE

openal

DSPROPERTY_EAXLISTENER_REFLECTIONS

openal

DSPROPERTY_EAXLISTENER_REFLECTIONSDELAY

openal

DSPROPERTY_EAXLISTENER_REVERB

openal

DSPROPERTY_EAXLISTENER_REVERBDELAY

openal

DSPROPERTY_EAXLISTENER_ROOM

openal

DSPROPERTY_EAXLISTENER_ROOMHF

openal

DSPROPERTY_EAXLISTENER_ROOMROLLOFFFACTOR

openal

DSPROPSETID_EAX20_BufferProperties

openal

DSPROPSETID_EAX20_ListenerProperties

openal

DSTATE_BUFIMAGE

GLSJPG

DSTATE_BUFPOST

GLSJPG

DSTATE_INHEADER

GLSJPG

DSTATE_PRELOAD

GLSJPG

DSTATE_PRESCAN

GLSJPG

DSTATE_RAW_OK

GLSJPG

DSTATE_RDCOEFS

GLSJPG

DSTATE_READY

GLSJPG

DSTATE_SCANNING

GLSJPG

DSTATE_START

GLSJPG

DSTATE_STOPPING

GLSJPG

DUMMY

Const3DS

DummyName3DS

Const3DS

DVM_CONFIGURE_END

GLSVfw

DVM_CONFIGURE_START

GLSVfw

DVM_DST_RECT

GLSVfw

DVM_FORMAT

GLSVfw

DVM_PALETTE

GLSVfw

DVM_PALETTERGB555

GLSVfw

DVM_SRC_RECT

GLSVfw

DVM_USER

GLSVfw

DV_ERR_13

GLSVfw

DV_ERR_ALLOCATED

GLSVfw

DV_ERR_BADDEVICEID

GLSVfw

DV_ERR_BADERRNUM

GLSVfw

DV_ERR_BADFORMAT

GLSVfw

DV_ERR_BADINSTALL

GLSVfw

DV_ERR_BASE

GLSVfw

DV_ERR_CONFIG1

GLSVfw

DV_ERR_CONFIG2

GLSVfw

DV_ERR_CREATEPALETTE

GLSVfw

DV_ERR_DMA_CONFLICT

GLSVfw

DV_ERR_FLAGS

GLSVfw

DV_ERR_INT_CONFLICT

GLSVfw

DV_ERR_INVALHANDLE

GLSVfw

DV_ERR_IO_CONFLICT

GLSVfw

DV_ERR_LASTERROR

GLSVfw

DV_ERR_MEM_CONFLICT

GLSVfw

DV_ERR_NOMEM

GLSVfw

DV_ERR_NONSPECIFIC

GLSVfw

DV_ERR_NOTDETECTED

GLSVfw

DV_ERR_NOTSUPPORTED

GLSVfw

DV_ERR_NO_BUFFERS

GLSVfw

DV_ERR_OK

GLSVfw

DV_ERR_PARAM1

GLSVfw

DV_ERR_PARAM2

GLSVfw

DV_ERR_PROTECT_ONLY

GLSVfw

DV_ERR_SIZEFIELD

GLSVfw

DV_ERR_STILLPLAYING

GLSVfw

DV_ERR_SYNC

GLSVfw

DV_ERR_TOOMANYCHANNELS

GLSVfw

DV_ERR_UNPREPARED

GLSVfw

DV_ERR_USER_MSG

GLSVfw

DV_VM_CLOSE

GLSVfw

DV_VM_DATA

GLSVfw

DV_VM_ERROR

GLSVfw

DV_VM_OPEN

GLSVfw

DW_ERROR

Bass

dxBodyDisabled

ODEImport

dxBodyFlagFiniteRotation

ODEImport

dxBodyFlagFiniteRotationAxis

ODEImport

dxBodyNoGravity

ODEImport

DXGI_FORMAT_A8_UNORM

DXTC

DXGI_FORMAT_B5G5R5A1_UNORM

DXTC

DXGI_FORMAT_B5G6R5_UNORM

DXTC

DXGI_FORMAT_B8G8R8A8_TYPELESS

DXTC

DXGI_FORMAT_B8G8R8A8_UNORM

DXTC

DXGI_FORMAT_B8G8R8A8_UNORM_SRGB

DXTC

DXGI_FORMAT_B8G8R8X8_TYPELESS

DXTC

DXGI_FORMAT_B8G8R8X8_UNORM

DXTC

DXGI_FORMAT_B8G8R8X8_UNORM_SRGB

DXTC

DXGI_FORMAT_BC1_TYPELESS

DXTC

DXGI_FORMAT_BC1_UNORM

DXTC

DXGI_FORMAT_BC1_UNORM_SRGB

DXTC

DXGI_FORMAT_BC2_TYPELESS

DXTC

DXGI_FORMAT_BC2_UNORM

DXTC

DXGI_FORMAT_BC2_UNORM_SRGB

DXTC

DXGI_FORMAT_BC3_TYPELESS

DXTC

DXGI_FORMAT_BC3_UNORM

DXTC

DXGI_FORMAT_BC3_UNORM_SRGB

DXTC

DXGI_FORMAT_BC4_SNORM

DXTC

DXGI_FORMAT_BC4_TYPELESS

DXTC

DXGI_FORMAT_BC4_UNORM

DXTC

DXGI_FORMAT_BC5_SNORM

DXTC

DXGI_FORMAT_BC5_TYPELESS

DXTC

DXGI_FORMAT_BC5_UNORM

DXTC

DXGI_FORMAT_BC6H_SF16

DXTC

DXGI_FORMAT_BC6H_TYPELESS

DXTC

DXGI_FORMAT_BC6H_UF16

DXTC

DXGI_FORMAT_BC7_TYPELESS

DXTC

DXGI_FORMAT_BC7_UNORM

DXTC

DXGI_FORMAT_BC7_UNORM_SRGB

DXTC

DXGI_FORMAT_D16_UNORM

DXTC

DXGI_FORMAT_D24_UNORM_S8_UINT

DXTC

DXGI_FORMAT_D32_FLOAT

DXTC

DXGI_FORMAT_D32_FLOAT_S8X24_UINT

DXTC

DXGI_FORMAT_FORCE_UINT

DXTC

DXGI_FORMAT_G8R8_G8B8_UNORM

DXTC

DXGI_FORMAT_R10G10B10A2_TYPELESS

DXTC

DXGI_FORMAT_R10G10B10A2_UINT

DXTC

DXGI_FORMAT_R10G10B10A2_UNORM

DXTC

DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM

DXTC

DXGI_FORMAT_R11G11B10_FLOAT

DXTC

DXGI_FORMAT_R16G16B16A16_FLOAT

DXTC

DXGI_FORMAT_R16G16B16A16_SINT

DXTC

DXGI_FORMAT_R16G16B16A16_SNORM

DXTC

DXGI_FORMAT_R16G16B16A16_TYPELESS

DXTC

DXGI_FORMAT_R16G16B16A16_UINT

DXTC

DXGI_FORMAT_R16G16B16A16_UNORM

DXTC

DXGI_FORMAT_R16G16_FLOAT

DXTC

DXGI_FORMAT_R16G16_SINT

DXTC

DXGI_FORMAT_R16G16_SNORM

DXTC

DXGI_FORMAT_R16G16_TYPELESS

DXTC

DXGI_FORMAT_R16G16_UINT

DXTC

DXGI_FORMAT_R16G16_UNORM

DXTC

DXGI_FORMAT_R16_FLOAT

DXTC

DXGI_FORMAT_R16_SINT

DXTC

DXGI_FORMAT_R16_SNORM

DXTC

DXGI_FORMAT_R16_TYPELESS

DXTC

DXGI_FORMAT_R16_UINT

DXTC

DXGI_FORMAT_R16_UNORM

DXTC

DXGI_FORMAT_R1_UNORM

DXTC

DXGI_FORMAT_R24G8_TYPELESS

DXTC

DXGI_FORMAT_R24_UNORM_X8_TYPELESS

DXTC

DXGI_FORMAT_R32G32B32A32_FLOAT

DXTC

DXGI_FORMAT_R32G32B32A32_SINT

DXTC

DXGI_FORMAT_R32G32B32A32_TYPELESS

DXTC

DXGI_FORMAT_R32G32B32A32_UINT

DXTC

DXGI_FORMAT_R32G32B32_FLOAT

DXTC

DXGI_FORMAT_R32G32B32_SINT

DXTC

DXGI_FORMAT_R32G32B32_TYPELESS

DXTC

DXGI_FORMAT_R32G32B32_UINT

DXTC

DXGI_FORMAT_R32G32_FLOAT

DXTC

DXGI_FORMAT_R32G32_SINT

DXTC

DXGI_FORMAT_R32G32_TYPELESS

DXTC

DXGI_FORMAT_R32G32_UINT

DXTC

DXGI_FORMAT_R32G8X24_TYPELESS

DXTC

DXGI_FORMAT_R32_FLOAT

DXTC

DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS

DXTC

DXGI_FORMAT_R32_SINT

DXTC

DXGI_FORMAT_R32_TYPELESS

DXTC

DXGI_FORMAT_R32_UINT

DXTC

DXGI_FORMAT_R8G8B8A8_SINT

DXTC

DXGI_FORMAT_R8G8B8A8_SNORM

DXTC

DXGI_FORMAT_R8G8B8A8_TYPELESS

DXTC

DXGI_FORMAT_R8G8B8A8_UINT

DXTC

DXGI_FORMAT_R8G8B8A8_UNORM

DXTC

DXGI_FORMAT_R8G8B8A8_UNORM_SRGB

DXTC

DXGI_FORMAT_R8G8_B8G8_UNORM

DXTC

DXGI_FORMAT_R8G8_SINT

DXTC

DXGI_FORMAT_R8G8_SNORM

DXTC

DXGI_FORMAT_R8G8_TYPELESS

DXTC

DXGI_FORMAT_R8G8_UINT

DXTC

DXGI_FORMAT_R8G8_UNORM

DXTC

DXGI_FORMAT_R8_SINT

DXTC

DXGI_FORMAT_R8_SNORM

DXTC

DXGI_FORMAT_R8_TYPELESS

DXTC

DXGI_FORMAT_R8_UINT

DXTC

DXGI_FORMAT_R8_UNORM

DXTC

DXGI_FORMAT_R9G9B9E5_SHAREDEXP

DXTC

DXGI_FORMAT_UNKNOWN

DXTC

DXGI_FORMAT_X24_TYPELESS_G8_UINT

DXTC

DXGI_FORMAT_X32_TYPELESS_G8X24_UINT

DXTC

D_MAX_BLOCKS_IN_MCU

GLSJPG

EAXBUFFERFLAGS_DIRECTHFAUTO

openal

EAXBUFFERFLAGS_RESERVED

openal

EAXBUFFERFLAGS_ROOMAUTO

openal

EAXBUFFERFLAGS_ROOMHFAUTO

openal

EAXBUFFER_DEFAULTAIRABSORPTIONFACTOR

openal

EAXBUFFER_DEFAULTDIRECT

openal

EAXBUFFER_DEFAULTDIRECTHF

openal

EAXBUFFER_DEFAULTFLAGS

openal

EAXBUFFER_DEFAULTOBSTRUCTION

openal

EAXBUFFER_DEFAULTOBSTRUCTIONLFRATIO

openal

EAXBUFFER_DEFAULTOCCLUSION

openal

EAXBUFFER_DEFAULTOCCLUSIONLFRATIO

openal

EAXBUFFER_DEFAULTOCCLUSIONROOMRATIO

openal

EAXBUFFER_DEFAULTOUTSIDEVOLUMEHF

openal

EAXBUFFER_DEFAULTROOM

openal

EAXBUFFER_DEFAULTROOMHF

openal

EAXBUFFER_DEFAULTROOMROLLOFFFACTOR

openal

EAXBUFFER_MAXAIRABSORPTIONFACTOR

openal

EAXBUFFER_MAXDIRECT

openal

EAXBUFFER_MAXDIRECTHF

openal

EAXBUFFER_MAXOBSTRUCTION

openal

EAXBUFFER_MAXOBSTRUCTIONLFRATIO

openal

EAXBUFFER_MAXOCCLUSION

openal

EAXBUFFER_MAXOCCLUSIONLFRATIO

openal

EAXBUFFER_MAXOCCLUSIONROOMRATIO

openal

EAXBUFFER_MAXOUTSIDEVOLUMEHF

openal

EAXBUFFER_MAXROOM

openal

EAXBUFFER_MAXROOMHF

openal

EAXBUFFER_MAXROOMROLLOFFFACTOR

openal

EAXBUFFER_MINAIRABSORPTIONFACTOR

openal

EAXBUFFER_MINDIRECT

openal

EAXBUFFER_MINDIRECTHF

openal

EAXBUFFER_MINOBSTRUCTION

openal

EAXBUFFER_MINOBSTRUCTIONLFRATIO

openal

EAXBUFFER_MINOCCLUSION

openal

EAXBUFFER_MINOCCLUSIONLFRATIO

openal

EAXBUFFER_MINOCCLUSIONROOMRATIO

openal

EAXBUFFER_MINOUTSIDEVOLUMEHF

openal

EAXBUFFER_MINROOM

openal

EAXBUFFER_MINROOMHF

openal

EAXBUFFER_MINROOMROLLOFFFACTOR

openal

EAXLISTENERFLAGS_DECAYHFLIMIT

openal

EAXLISTENERFLAGS_DECAYTIMESCALE

openal

EAXLISTENERFLAGS_REFLECTIONSDELAYSCALE

openal

EAXLISTENERFLAGS_REFLECTIONSSCALE

openal

EAXLISTENERFLAGS_RESERVED

openal

EAXLISTENERFLAGS_REVERBDELAYSCALE

openal

EAXLISTENERFLAGS_REVERBSCALE

openal

EAXLISTENER_DEFAULTAIRABSORPTIONHF

openal

EAXLISTENER_DEFAULTDECAYHFRATIO

openal

EAXLISTENER_DEFAULTDECAYTIME

openal

EAXLISTENER_DEFAULTENVIRONMENT

openal

EAXLISTENER_DEFAULTENVIRONMENTDIFFUSION

openal

EAXLISTENER_DEFAULTENVIRONMENTSIZE

openal

EAXLISTENER_DEFAULTFLAGS

openal

EAXLISTENER_DEFAULTREFLECTIONS

openal

EAXLISTENER_DEFAULTREFLECTIONSDELAY

openal

EAXLISTENER_DEFAULTREVERB

openal

EAXLISTENER_DEFAULTREVERBDELAY

openal

EAXLISTENER_DEFAULTROOM

openal

EAXLISTENER_DEFAULTROOMHF

openal

EAXLISTENER_DEFAULTROOMROLLOFFFACTOR

openal

EAXLISTENER_MAXAIRABSORPTIONHF

openal

EAXLISTENER_MAXDECAYHFRATIO

openal

EAXLISTENER_MAXDECAYTIME

openal

EAXLISTENER_MAXENVIRONMENT

openal

EAXLISTENER_MAXENVIRONMENTDIFFUSION

openal

EAXLISTENER_MAXENVIRONMENTSIZE

openal

EAXLISTENER_MAXREFLECTIONS

openal

EAXLISTENER_MAXREFLECTIONSDELAY

openal

EAXLISTENER_MAXREVERB

openal

EAXLISTENER_MAXREVERBDELAY

openal

EAXLISTENER_MAXROOM

openal

EAXLISTENER_MAXROOMHF

openal

EAXLISTENER_MAXROOMROLLOFFFACTOR

openal

EAXLISTENER_MINAIRABSORPTIONHF

openal

EAXLISTENER_MINDECAYHFRATIO

openal

EAXLISTENER_MINDECAYTIME

openal

EAXLISTENER_MINENVIRONMENT

openal

EAXLISTENER_MINENVIRONMENTDIFFUSION

openal

EAXLISTENER_MINENVIRONMENTSIZE

openal

EAXLISTENER_MINREFLECTIONS

openal

EAXLISTENER_MINREFLECTIONSDELAY

openal

EAXLISTENER_MINREVERB

openal

EAXLISTENER_MINREVERBDELAY

openal

EAXLISTENER_MINROOM

openal

EAXLISTENER_MINROOMHF

openal

EAXLISTENER_MINROOMROLLOFFFACTOR

openal

EAX_ENVIRONMENT_ALLEY

Bass

EAX_ENVIRONMENT_ALLEY

openal

EAX_ENVIRONMENT_ARENA

Bass

EAX_ENVIRONMENT_ARENA

openal

EAX_ENVIRONMENT_AUDITORIUM

Bass

EAX_ENVIRONMENT_AUDITORIUM

openal

EAX_ENVIRONMENT_BATHROOM

openal

EAX_ENVIRONMENT_BATHROOM

Bass

EAX_ENVIRONMENT_CARPETEDHALLWAY

Bass

EAX_ENVIRONMENT_CARPETEDHALLWAY

openal

EAX_ENVIRONMENT_CAVE

Bass

EAX_ENVIRONMENT_CAVE

openal

EAX_ENVIRONMENT_CITY

Bass

EAX_ENVIRONMENT_CITY

openal

EAX_ENVIRONMENT_CONCERTHALL

openal

EAX_ENVIRONMENT_CONCERTHALL

Bass

EAX_ENVIRONMENT_COUNT

openal

EAX_ENVIRONMENT_COUNT

Bass

EAX_ENVIRONMENT_DIZZY

openal

EAX_ENVIRONMENT_DIZZY

Bass

EAX_ENVIRONMENT_DRUGGED

openal

EAX_ENVIRONMENT_DRUGGED

Bass

EAX_ENVIRONMENT_FOREST

openal

EAX_ENVIRONMENT_FOREST

Bass

EAX_ENVIRONMENT_GENERIC

openal

EAX_ENVIRONMENT_GENERIC

Bass

EAX_ENVIRONMENT_HALLWAY

Bass

EAX_ENVIRONMENT_HALLWAY

openal

EAX_ENVIRONMENT_HANGAR

Bass

EAX_ENVIRONMENT_HANGAR

openal

EAX_ENVIRONMENT_LIVINGROOM

Bass

EAX_ENVIRONMENT_LIVINGROOM

openal

EAX_ENVIRONMENT_MOUNTAINS

Bass

EAX_ENVIRONMENT_MOUNTAINS

openal

EAX_ENVIRONMENT_PADDEDCELL

openal

EAX_ENVIRONMENT_PADDEDCELL

Bass

EAX_ENVIRONMENT_PARKINGLOT

Bass

EAX_ENVIRONMENT_PARKINGLOT

openal

EAX_ENVIRONMENT_PLAIN

openal

EAX_ENVIRONMENT_PLAIN

Bass

EAX_ENVIRONMENT_PSYCHOTIC

openal

EAX_ENVIRONMENT_PSYCHOTIC

Bass

EAX_ENVIRONMENT_QUARRY

Bass

EAX_ENVIRONMENT_QUARRY

openal

EAX_ENVIRONMENT_ROOM

Bass

EAX_ENVIRONMENT_ROOM

openal

EAX_ENVIRONMENT_SEWERPIPE

Bass

EAX_ENVIRONMENT_SEWERPIPE

openal

EAX_ENVIRONMENT_STONECORRIDOR

Bass

EAX_ENVIRONMENT_STONECORRIDOR

openal

EAX_ENVIRONMENT_STONEROOM

openal

EAX_ENVIRONMENT_STONEROOM

Bass

EAX_ENVIRONMENT_UNDERWATER

Bass

EAX_ENVIRONMENT_UNDERWATER

openal

EAX_MATERIAL_BRICKWALL

openal

EAX_MATERIAL_BRICKWALLLF

openal

EAX_MATERIAL_BRICKWALLROOMRATIO

openal

EAX_MATERIAL_CURTAIN

openal

EAX_MATERIAL_CURTAINLF

openal

EAX_MATERIAL_CURTAINROOMRATIO

openal

EAX_MATERIAL_DOUBLEWINDOW

openal

EAX_MATERIAL_DOUBLEWINDOWHF

openal

EAX_MATERIAL_DOUBLEWINDOWROOMRATIO

openal

EAX_MATERIAL_SINGLEWINDOW

openal

EAX_MATERIAL_SINGLEWINDOWLF

openal

EAX_MATERIAL_SINGLEWINDOWROOMRATIO

openal

EAX_MATERIAL_STONEWALL

openal

EAX_MATERIAL_STONEWALLLF

openal

EAX_MATERIAL_STONEWALLROOMRATIO

openal

EAX_MATERIAL_THICKDOOR

openal

EAX_MATERIAL_THICKDOORLF

openal

EAX_MATERIAL_THICKDOORROOMRTATION

openal

EAX_MATERIAL_THINDOOR

openal

EAX_MATERIAL_THINDOORLF

openal

EAX_MATERIAL_THINDOORROOMRATIO

openal

EAX_MATERIAL_WOODWALL

openal

EAX_MATERIAL_WOODWALLLF

openal

EAX_MATERIAL_WOODWALLROOMRATIO

openal

EFFECTS_SELECTED

GLSceneEdit

EFFECTS_SELECTED

GLSceneEditLCL

EmptyHmgMatrix

VectorGeometry

EmptyMatrix

VectorGeometry

ENVL_CHAN

LWObjects

ENVL_KEY

LWObjects

ENVL_NAME

LWObjects

ENVL_POST

LWObjects

ENVL_PRE

LWObjects

ENVL_SPAN

LWObjects

EPSILON

VectorGeometry

EPSILON2

VectorGeometry

Error3DS_CLOSING_FILE

Const3DS

Error3DS_CREATING_DATABASE

Const3DS

Error3DS_GET_FAIL

Const3DS

Error3DS_INIT_FAILED

Const3DS

Error3DS_INVALID_ARG

Const3DS

Error3DS_INVALID_CHUNK

Const3DS

Error3DS_INVALID_DATA

Const3DS

Error3DS_INVALID_DATABASE

Const3DS

Error3DS_INVALID_INDEX

Const3DS

Error3DS_NO_MEM

Const3DS

Error3DS_NO_SUCH_FILE

Const3DS

Error3DS_OPENING_FILE

Const3DS

Error3DS_PUT_FAIL

Const3DS

Error3DS_READING_DATABASE

Const3DS

Error3DS_READING_FILE

Const3DS

Error3DS_STRING_TOO_LONG

Const3DS

Error3DS_UNFOUND_CHUNK

Const3DS

Error3DS_WRITING_DATABASE

Const3DS

Error3DS_WRITING_FILE

Const3DS

Error3DS_WRONG_DATABASE

Const3DS

Error3DS_WRONG_OBJECT

Const3DS

ERROR_INCOMPATIBLE_DEVICE_CONTEXTS_ARB

OpenGLTokens

ERROR_INVALID_PIXEL_TYPE_ARB

OpenGLTokens

ERROR_INVALID_PROFILE_ARB

OpenGLTokens

ERROR_INVALID_VERSION_ARB

OpenGLTokens

ERR_MAX_ARGS

GLSDL

ERR_MAX_STRLEN

GLSDL

FaceABVisable3DS

Const3DS

FaceArrayMin3DS

Const3DS

FaceBCVisable3DS

Const3DS

FaceCAVisable3DS

Const3DS

FaceUWrap3DS

Const3DS

FaceVWrap3DS

Const3DS

FACE_ARRAY

Const3DS

FACE_ARRAY_ENTRY

Const3DS

FACE_POLYGON

Q3BSP

FallTrackTagMax3DS

Const3DS

FallTrackTagMin3DS

Const3DS

FALL_TRACK_TAG

Const3DS

FALL_TRACK_TAG_KEY

Const3DS

FAST_NODE

Const3DS

FileAttrStrMax3DS

Const3DS

FileNameStrMax3DS

Const3DS

FIND_ANY

GLSVfw

FIND_DIR

GLSVfw

FIND_FORMAT

GLSVfw

FIND_FROM_START

GLSVfw

FIND_INDEX

GLSVfw

FIND_KEY

GLSVfw

FIND_LENGTH

GLSVfw

FIND_NEXT

GLSVfw

FIND_OFFSET

GLSVfw

FIND_POS

GLSVfw

FIND_PREV

GLSVfw

FIND_RET

GLSVfw

FIND_SIZE

GLSVfw

FIND_TYPE

GLSVfw

FloatPercentageMax3DS

Const3DS

FLOAT_PERCENTAGE

Const3DS

FMOD_VERSION

fmodtypes

FOG

Const3DS

FogMax3DS

Const3DS

FogMin3DS

Const3DS

FOG_BGND

Const3DS

formtypeAVI

GLSVfw

FOURCC_A16B16G16R16

DXTC

FOURCC_A16B16G16R16F

DXTC

FOURCC_A1R5G5B5

DXTC

FOURCC_A2B10G10R10

DXTC

FOURCC_A2R10G10B10

DXTC

FOURCC_A32B32G32R32F

DXTC

FOURCC_A4L4

DXTC

FOURCC_A4R4G4B4

DXTC

FOURCC_A8

DXTC

FOURCC_A8B8G8R8

DXTC

FOURCC_A8L8

DXTC

FOURCC_A8R3G3B2

DXTC

FOURCC_A8R8G8B8

DXTC

FOURCC_ATI1

DXTC

FOURCC_ATI2

DXTC

FOURCC_D16

DXTC

FOURCC_D16_LOCKABLE

DXTC

FOURCC_D24X8

DXTC

FOURCC_D32

DXTC

FOURCC_D32F_LOCKABLE

DXTC

FOURCC_DX10

DXTC

FOURCC_DXT1

DXTC

FOURCC_DXT2

DXTC

FOURCC_DXT3

DXTC

FOURCC_DXT4

DXTC

FOURCC_DXT5

DXTC

FOURCC_G16R16

DXTC

FOURCC_G16R16F

DXTC

FOURCC_G32R32F

DXTC

FOURCC_L16

DXTC

FOURCC_L8

DXTC

FOURCC_R16F

DXTC

FOURCC_R32F

DXTC

FOURCC_R3G3B2

DXTC

FOURCC_R5G6B5

DXTC

FOURCC_R8G8B8

DXTC

FOURCC_UNKNOWN

DXTC

FOURCC_X1R5G5B5

DXTC

FOURCC_X4R4G4B4

DXTC

FOURCC_X8B8G8R8

DXTC

FOURCC_X8R8G8B8

DXTC

FOVTrackTagMax3DS

Const3DS

FOVTrackTagMin3DS

Const3DS

FOV_TRACK_TAG

Const3DS

FOV_TRACK_TAG_KEY

Const3DS

FSOUND_16BITS

fmodtypes

FSOUND_2D

fmodtypes

FSOUND_8BITS

fmodtypes

FSOUND_ALL

fmodtypes

FSOUND_CAPS_EAX2

fmodtypes

FSOUND_CAPS_EAX3

fmodtypes

FSOUND_CAPS_HARDWARE

fmodtypes

FSOUND_CD_PLAYCONTINUOUS

fmodtypes

FSOUND_CD_PLAYLOOPED

fmodtypes

FSOUND_CD_PLAYONCE

fmodtypes

FSOUND_CD_PLAYRANDOM

fmodtypes

FSOUND_DELTA

fmodtypes

FSOUND_DSP_DEFAULTPRIORITY_CLEARUNIT

fmodtypes

FSOUND_DSP_DEFAULTPRIORITY_CLIPANDCOPYUNIT

fmodtypes

FSOUND_DSP_DEFAULTPRIORITY_FFTUNIT

fmodtypes

FSOUND_DSP_DEFAULTPRIORITY_MUSICUNIT

fmodtypes

FSOUND_DSP_DEFAULTPRIORITY_SFXUNIT

fmodtypes

FSOUND_DSP_DEFAULTPRIORITY_USER

fmodtypes

FSOUND_ENABLEFX

fmodtypes

FSOUND_FORCEMONO

fmodtypes

FSOUND_FORMAT_MPEG

fmodtypes

FSOUND_FORMAT_OGGVORBIS

fmodtypes

FSOUND_FREE

fmodtypes

FSOUND_GCADPCM

fmodtypes

FSOUND_HW2D

fmodtypes

FSOUND_HW3D

fmodtypes

FSOUND_INIT_ACCURATEVULEVELS

fmodtypes

FSOUND_INIT_DONTLATENCYADJUST

fmodtypes

FSOUND_INIT_DSOUND_DEFERRED

fmodtypes

FSOUND_INIT_DSOUND_HRTF_FULL

fmodtypes

FSOUND_INIT_DSOUND_HRTF_LIGHT

fmodtypes

FSOUND_INIT_ENABLESYSTEMCHANNELFX

fmodtypes

FSOUND_INIT_GC_INITLIBS

fmodtypes

FSOUND_INIT_GLOBALFOCUS

fmodtypes

FSOUND_INIT_PS2_DISABLECORE0REVERB

fmodtypes

FSOUND_INIT_PS2_DISABLECORE1REVERB

fmodtypes

FSOUND_INIT_PS2_SWAPDMACORES

fmodtypes

FSOUND_INIT_PS2_USEVOLUMERAMPING

fmodtypes

FSOUND_INIT_PSP_SILENCEONUNDERRUN

fmodtypes

FSOUND_INIT_STREAM_FROM_MAIN_THREAD

fmodtypes

FSOUND_INIT_USEDEFAULTMIDISYNTH

fmodtypes

FSOUND_INIT_XBOX_REMOVEHEADROOM

fmodtypes

FSOUND_IT214

fmodtypes

FSOUND_IT215

fmodtypes

FSOUND_LOADMEMORY

fmodtypes

FSOUND_LOADMEMORYIOP

fmodtypes

FSOUND_LOADRAW

fmodtypes

FSOUND_LOOP_BIDI

fmodtypes

FSOUND_LOOP_NORMAL

fmodtypes

FSOUND_LOOP_OFF

fmodtypes

FSOUND_MONO

fmodtypes

FSOUND_MPEGACCURATE

fmodtypes

FSOUND_MPEGHALFRATE

fmodtypes

FSOUND_MULTICHANNEL

fmodtypes

FSOUND_NONBLOCKING

fmodtypes

FSOUND_NORMAL

fmodtypes

FSOUND_PRESET_ALLEY

fmodpresets

FSOUND_PRESET_ARENA

fmodpresets

FSOUND_PRESET_AUDITORIUM

fmodpresets

FSOUND_PRESET_BATHROOM

fmodpresets

FSOUND_PRESET_CARPETTEDHALLWAY

fmodpresets

FSOUND_PRESET_CAVE

fmodpresets

FSOUND_PRESET_CITY

fmodpresets

FSOUND_PRESET_CONCERTHALL

fmodpresets

FSOUND_PRESET_DIZZY

fmodpresets

FSOUND_PRESET_DRUGGED

fmodpresets

FSOUND_PRESET_FOREST

fmodpresets

FSOUND_PRESET_GENERIC

fmodpresets

FSOUND_PRESET_HALLWAY

fmodpresets

FSOUND_PRESET_HANGAR

fmodpresets

FSOUND_PRESET_LIVINGROOM

fmodpresets

FSOUND_PRESET_MOUNTAINS

fmodpresets

FSOUND_PRESET_OFF

fmodpresets

FSOUND_PRESET_PADDEDCELL

fmodpresets

FSOUND_PRESET_PARKINGLOT

fmodpresets

FSOUND_PRESET_PLAIN

fmodpresets

FSOUND_PRESET_PSYCHOTIC

fmodpresets

FSOUND_PRESET_QUARRY

fmodpresets

FSOUND_PRESET_ROOM

fmodpresets

FSOUND_PRESET_SEWERPIPE

fmodpresets

FSOUND_PRESET_STONECORRIDOR

fmodpresets

FSOUND_PRESET_STONEROOM

fmodpresets

FSOUND_PRESET_UNDERWATER

fmodpresets

FSOUND_PROTOCOL_HTTP

fmodtypes

FSOUND_PROTOCOL_ICECAST

fmodtypes

FSOUND_PROTOCOL_SHOUTCAST

fmodtypes

FSOUND_REVERBFLAGS_DECAYHFLIMIT

fmodtypes

FSOUND_REVERBFLAGS_DECAYTIMESCALE

fmodtypes

FSOUND_REVERBFLAGS_DEFAULT

fmodtypes

FSOUND_REVERBFLAGS_ECHOTIMESCALE

fmodtypes

FSOUND_REVERBFLAGS_MODULATIONTIMESCALE

fmodtypes

FSOUND_REVERBFLAGS_REFLECTIONSDELAYSCALE

fmodtypes

FSOUND_REVERBFLAGS_REFLECTIONSSCALE

fmodtypes

FSOUND_REVERBFLAGS_REVERBDELAYSCALE

fmodtypes

FSOUND_REVERBFLAGS_REVERBSCALE

fmodtypes

FSOUND_REVERB_CHANNELFLAGS_DEFAULT

fmodtypes

FSOUND_REVERB_CHANNELFLAGS_DIRECTHFAUTO

fmodtypes

FSOUND_REVERB_CHANNELFLAGS_ROOMAUTO

fmodtypes

FSOUND_REVERB_CHANNELFLAGS_ROOMHFAUTO

fmodtypes

FSOUND_REVERB_FLAGS_CORE0

fmodtypes

FSOUND_REVERB_FLAGS_CORE1

fmodtypes

FSOUND_SIGNED

fmodtypes

FSOUND_STEREO

fmodtypes

FSOUND_STEREOPAN

fmodtypes

FSOUND_STREAMABLE

fmodtypes

FSOUND_SYSTEMCHANNEL

fmodtypes

FSOUND_SYSTEMSAMPLE

fmodtypes

FSOUND_UNMANAGED

fmodtypes

FSOUND_UNSIGNED

fmodtypes

FSOUND_USECORE0

fmodtypes

FSOUND_USECORE1

fmodtypes

FSOUND_VAG

fmodtypes

FSOUND_XADPCM

fmodtypes

FTLIBNAME

LIBFREETYPE

FT_CURVE_TAG_CONIC

LIBFREETYPE

FT_CURVE_TAG_CUBIC

LIBFREETYPE

FT_CURVE_TAG_ON

LIBFREETYPE

FT_ENCODING_NONE

LIBFREETYPE

FT_FACE_FLAG_KERNING

LIBFREETYPE

FT_FACE_FLAG_SCALABLE

LIBFREETYPE

FT_KERNING_DEFAULT

LIBFREETYPE

FT_KERNING_UNFITTED

LIBFREETYPE

FT_KERNING_UNSCALED

LIBFREETYPE

FT_LOAD_DEFAULT

LIBFREETYPE

FT_LOAD_FORCE_AUTOHINT

LIBFREETYPE

FT_LOAD_NO_HINTING

LIBFREETYPE

FT_OPEN_DRIVER

LIBFREETYPE

FT_OPEN_MEMORY

LIBFREETYPE

FT_OPEN_PARAMS

LIBFREETYPE

FT_OPEN_PATHNAME

LIBFREETYPE

FT_OPEN_STREAM

LIBFREETYPE

FT_OUTLINE_EVEN_ODD_FILL

LIBFREETYPE

FT_OUTLINE_HIGH_PRECISION

LIBFREETYPE

FT_OUTLINE_IGNORE_DROPOUTS

LIBFREETYPE

FT_OUTLINE_NONE

LIBFREETYPE

FT_OUTLINE_OWNER

LIBFREETYPE

FT_OUTLINE_REVERSE_FILL

LIBFREETYPE

FT_OUTLINE_SINGLE_PASS

LIBFREETYPE

FT_RENDER_MODE_LCD

LIBFREETYPE

FT_RENDER_MODE_LCD_V

LIBFREETYPE

FT_RENDER_MODE_LIGHT

LIBFREETYPE

FT_RENDER_MODE_MAX

LIBFREETYPE

FT_RENDER_MODE_MONO

LIBFREETYPE

FT_RENDER_MODE_NORMAL

LIBFREETYPE

FT_STYLE_FLAG_BOLD

LIBFREETYPE

FT_STYLE_FLAG_ITALIC

LIBFREETYPE

FT_VALIDATE_bsln_INDEX

LIBFREETYPE

FT_VALIDATE_feat_INDEX

LIBFREETYPE

FT_VALIDATE_GX_LAST_INDEX

LIBFREETYPE

FT_VALIDATE_GX_LENGTH

LIBFREETYPE

FT_VALIDATE_just_INDEX

LIBFREETYPE

FT_VALIDATE_kern_INDEX

LIBFREETYPE

FT_VALIDATE_lcar_INDEX

LIBFREETYPE

FT_VALIDATE_mort_INDEX

LIBFREETYPE

FT_VALIDATE_morx_INDEX

LIBFREETYPE

FT_VALIDATE_opbd_INDEX

LIBFREETYPE

FT_VALIDATE_prop_INDEX

LIBFREETYPE

FT_VALIDATE_trak_INDEX

LIBFREETYPE

glKey_CANCEL

GLCrossPlatform

glKey_CONTROL

GLCrossPlatform

glKey_DELETE

GLCrossPlatform

glKey_DOWN

GLCrossPlatform

glKey_END

GLCrossPlatform

glKey_HOME

GLCrossPlatform

glKey_LEFT

GLCrossPlatform

glKey_NEXT

GLCrossPlatform

glKey_PRIOR

GLCrossPlatform

glKey_RETURN

GLCrossPlatform

glKey_RIGHT

GLCrossPlatform

glKey_SPACE

GLCrossPlatform

glKey_TAB

GLCrossPlatform

glKey_UP

GLCrossPlatform

glpf24bit

GLCrossPlatform

glpf32Bit

GLCrossPlatform

glpf8Bit

GLCrossPlatform

glpfDevice

GLCrossPlatform

glsAllFilter

GLCrossPlatform

glsAlreadyRendering

GLStrings

glsCadencerNotDefined

GLStrings

glsCadencerNotDefinedEx

GLStrings

glsCamera

GLStrings

glsCameraRoot

GLStrings

GLSCENE_REVISION

GLScene

GLSCENE_VERSION

GLScene

glsDisplayList

GLStrings

glsDot

GLStrings

glsDriverNotSupportDebugRC

GLWin32Context

glsDriverNotSupportFRC

GLWin32Context

glsDriverNotSupportOESRC

GLWin32Context

glsError

GLStrings

glsErrorEx

GLStrings

glsFailedOpenFile

GLStrings

glsFailedOpenFileFromCurrentDir

GLStrings

glsFailedToShare

GLContext

glsFileNotFound

GLStrings

glsFRC_created

GLWin32Context

glsImageInvalid

GLStrings

glsIncompatibleTypes

GLStrings

glsInterleaveNotSupported

GLStrings

glsMaterialNotFound

GLStrings

glsMaterialNotFoundInMatlib

GLStrings

glsMaterialNotFoundInMatlibEx

GLStrings

glsMatLibNotDefined

GLStrings

glsMissingResource

GLStrings

glsNoDescriptionAvailable

GLStrings

glsNoNewTexture

GLStrings

glsNoRenderingContext

GLStrings

glsObjectRoot

GLStrings

glsOCAdvancedGeometry

GLStrings

glsOCBasicGeometry

GLStrings

glsOCDoodad

GLStrings

glsOCEnvironmentObjects

GLStrings

glsOCExperimental

GLStrings

glsOCGraphPlottingObjects

GLStrings

glsOCGuiObjects

GLStrings

glsOCHUDObjects

GLStrings

glsOCMeshObjects

GLStrings

glsOCParticleSystems

GLStrings

glsOCProxyObjects

GLStrings

glsOCSpecialObjects

GLStrings

glsOESRC_created

GLWin32Context

glsOESvsForwardRC

GLWin32Context

glsOutOfMemory

GLStrings

glsPBufferRC_created

GLWin32Context

glsSceneRoot

GLStrings

glsSceneViewerNotDefined

GLStrings

glsShaderMaxLightSources

GLCustomShader

glsShaderNeedsAtLeastOneLightSource

GLStrings

glsShaderNeedsAtLeastOneLightSourceEx

GLStrings

glsSphereStartStop

GLStrings

glsSphereTopBottom

GLStrings

glsTmpRC_Created

GLWin32Context

glsTooManyLights

GLStrings

glsUnBalancedBeginEndUpdate

GLStrings

glsUnknownArchive

GLStrings

glsUnknownExtension

GLStrings

glsUnknownParam

GLStrings

glsUnknownType

GLStrings

glsUnsupportedType

GLStrings

glsWrongBitmapCanvas

GLStrings

glsWrongPrinter

GLStrings

glsWrongVersion

GLStrings

GLS_FONT_CHARS_COUNT

GLCrossPlatform

GLS_RC_DDS_Type

ApplicationFileIO

GLS_RC_JPG_Type

ApplicationFileIO

GLS_RC_String_Type

ApplicationFileIO

GLS_RC_XML_Type

ApplicationFileIO

GLS_VERTEX_ATTR_NUM

GLState

glu32

OpenGLTokens

GLU_AUTO_LOAD_MATRIX

OpenGLTokens

GLU_BEGIN

OpenGLTokens

GLU_CCW

OpenGLTokens

GLU_CULLING

OpenGLTokens

GLU_CW

OpenGLTokens

GLU_DISPLAY_MODE

OpenGLTokens

GLU_DOMAIN_DISTANCE

OpenGLTokens

GLU_EDGE_FLAG

OpenGLTokens

GLU_END

OpenGLTokens

GLU_ERROR

OpenGLTokens

GLU_EXTENSIONS

OpenGLTokens

GLU_EXTERIOR

OpenGLTokens

GLU_FALSE

OpenGLTokens

GLU_FILL

OpenGLTokens

GLU_FLAT

OpenGLTokens

GLU_INCOMPATIBLE_GL_VERSION

OpenGLTokens

GLU_INSIDE

OpenGLTokens

GLU_INTERIOR

OpenGLTokens

GLU_INVALID_ENUM

OpenGLTokens

GLU_INVALID_VALUE

OpenGLTokens

GLU_LINE

OpenGLTokens

GLU_MAP1_TRIM_2

OpenGLTokens

GLU_MAP1_TRIM_3

OpenGLTokens

GLU_NONE

OpenGLTokens

GLU_NURBS_BEGIN_DATA_EXT

OpenGLTokens

GLU_NURBS_BEGIN_EXT

OpenGLTokens

GLU_NURBS_COLOR_DATA_EXT

OpenGLTokens

GLU_NURBS_COLOR_EXT

OpenGLTokens

GLU_NURBS_END_DATA_EXT

OpenGLTokens

GLU_NURBS_END_EXT

OpenGLTokens

GLU_NURBS_ERROR1

OpenGLTokens

GLU_NURBS_ERROR10

OpenGLTokens

GLU_NURBS_ERROR11

OpenGLTokens

GLU_NURBS_ERROR12

OpenGLTokens

GLU_NURBS_ERROR13

OpenGLTokens

GLU_NURBS_ERROR14

OpenGLTokens

GLU_NURBS_ERROR15

OpenGLTokens

GLU_NURBS_ERROR16

OpenGLTokens

GLU_NURBS_ERROR17

OpenGLTokens

GLU_NURBS_ERROR18

OpenGLTokens

GLU_NURBS_ERROR19

OpenGLTokens

GLU_NURBS_ERROR2

OpenGLTokens

GLU_NURBS_ERROR20

OpenGLTokens

GLU_NURBS_ERROR21

OpenGLTokens

GLU_NURBS_ERROR22

OpenGLTokens

GLU_NURBS_ERROR23

OpenGLTokens

GLU_NURBS_ERROR24

OpenGLTokens

GLU_NURBS_ERROR25

OpenGLTokens

GLU_NURBS_ERROR26

OpenGLTokens

GLU_NURBS_ERROR27

OpenGLTokens

GLU_NURBS_ERROR28

OpenGLTokens

GLU_NURBS_ERROR29

OpenGLTokens

GLU_NURBS_ERROR3

OpenGLTokens

GLU_NURBS_ERROR30

OpenGLTokens

GLU_NURBS_ERROR31

OpenGLTokens

GLU_NURBS_ERROR32

OpenGLTokens

GLU_NURBS_ERROR33

OpenGLTokens

GLU_NURBS_ERROR34

OpenGLTokens

GLU_NURBS_ERROR35

OpenGLTokens

GLU_NURBS_ERROR36

OpenGLTokens

GLU_NURBS_ERROR37

OpenGLTokens

GLU_NURBS_ERROR4

OpenGLTokens

GLU_NURBS_ERROR5

OpenGLTokens

GLU_NURBS_ERROR6

OpenGLTokens

GLU_NURBS_ERROR7

OpenGLTokens

GLU_NURBS_ERROR8

OpenGLTokens

GLU_NURBS_ERROR9

OpenGLTokens

GLU_NURBS_MODE_EXT

OpenGLTokens

GLU_NURBS_NORMAL_DATA_EXT

OpenGLTokens

GLU_NURBS_NORMAL_EXT

OpenGLTokens

GLU_NURBS_RENDERER_EXT

OpenGLTokens

GLU_NURBS_TESSELLATOR_EXT

OpenGLTokens

GLU_NURBS_TEX_COORD_DATA_EXT

OpenGLTokens

GLU_NURBS_TEX_COORD_EXT

OpenGLTokens

GLU_NURBS_VERTEX_DATA_EXT

OpenGLTokens

GLU_NURBS_VERTEX_EXT

OpenGLTokens

GLU_OBJECT_PARAMETRIC_ERROR_EXT

OpenGLTokens

GLU_OBJECT_PATH_LENGTH_EXT

OpenGLTokens

GLU_OUTLINE_PATCH

OpenGLTokens

GLU_OUTLINE_POLYGON

OpenGLTokens

GLU_OUTSIDE

OpenGLTokens

GLU_OUT_OF_MEMORY

OpenGLTokens

GLU_PARAMETRIC_ERROR

OpenGLTokens

GLU_PARAMETRIC_TOLERANCE

OpenGLTokens

GLU_PATH_LENGTH

OpenGLTokens

GLU_POINT

OpenGLTokens

GLU_SAMPLING_METHOD

OpenGLTokens

GLU_SAMPLING_TOLERANCE

OpenGLTokens

GLU_SILHOUETTE

OpenGLTokens

GLU_SMOOTH

OpenGLTokens

GLU_TESS_BEGIN

OpenGLTokens

GLU_TESS_BEGIN_DATA

OpenGLTokens

GLU_TESS_BOUNDARY_ONLY

OpenGLTokens

GLU_TESS_COMBINE

OpenGLTokens

GLU_TESS_COMBINE_DATA

OpenGLTokens

GLU_TESS_COORD_TOO_LARGE

OpenGLTokens

GLU_TESS_EDGE_FLAG

OpenGLTokens

GLU_TESS_EDGE_FLAG_DATA

OpenGLTokens

GLU_TESS_END

OpenGLTokens

GLU_TESS_END_DATA

OpenGLTokens

GLU_TESS_ERROR

OpenGLTokens

GLU_TESS_ERROR1

OpenGLTokens

GLU_TESS_ERROR2

OpenGLTokens

GLU_TESS_ERROR3

OpenGLTokens

GLU_TESS_ERROR4

OpenGLTokens

GLU_TESS_ERROR5

OpenGLTokens

GLU_TESS_ERROR6

OpenGLTokens

GLU_TESS_ERROR7

OpenGLTokens

GLU_TESS_ERROR8

OpenGLTokens

GLU_TESS_ERROR_DATA

OpenGLTokens

GLU_TESS_MAX_COORD

OpenGLTokens

GLU_TESS_MISSING_BEGIN_CONTOUR

OpenGLTokens

GLU_TESS_MISSING_BEGIN_POLYGON

OpenGLTokens

GLU_TESS_MISSING_END_CONTOUR

OpenGLTokens

GLU_TESS_MISSING_END_POLYGON

OpenGLTokens

GLU_TESS_NEED_COMBINE_CALLBACK

OpenGLTokens

GLU_TESS_TOLERANCE

OpenGLTokens

GLU_TESS_VERTEX

OpenGLTokens

GLU_TESS_VERTEX_DATA

OpenGLTokens

GLU_TESS_WINDING_ABS_GEQ_TWO

OpenGLTokens

GLU_TESS_WINDING_NEGATIVE

OpenGLTokens

GLU_TESS_WINDING_NONZERO

OpenGLTokens

GLU_TESS_WINDING_ODD

OpenGLTokens

GLU_TESS_WINDING_POSITIVE

OpenGLTokens

GLU_TESS_WINDING_RULE

OpenGLTokens

GLU_TRUE

OpenGLTokens

GLU_UNKNOWN

OpenGLTokens

GLU_U_STEP

OpenGLTokens

GLU_VERSION

OpenGLTokens

GLU_VERTEX

OpenGLTokens

GLU_V_STEP

OpenGLTokens

GLX_3DFX_FULLSCREEN_MODE_MESA

OpenGLTokens

GLX_3DFX_WINDOW_MODE_MESA

OpenGLTokens

GLX_ACCUM_ALPHA_SIZE

OpenGLTokens

GLX_ACCUM_BLUE_SIZE

OpenGLTokens

GLX_ACCUM_BUFFER_BIT

OpenGLTokens

GLX_ACCUM_BUFFER_BIT_SGIX

OpenGLTokens

GLX_ACCUM_GREEN_SIZE

OpenGLTokens

GLX_ACCUM_RED_SIZE

OpenGLTokens

GLX_ALPHA_SIZE

OpenGLTokens

GLX_AUX0_EXT

OpenGLTokens

GLX_AUX1_EXT

OpenGLTokens

GLX_AUX2_EXT

OpenGLTokens

GLX_AUX3_EXT

OpenGLTokens

GLX_AUX4_EXT

OpenGLTokens

GLX_AUX5_EXT

OpenGLTokens

GLX_AUX6_EXT

OpenGLTokens

GLX_AUX7_EXT

OpenGLTokens

GLX_AUX8_EXT

OpenGLTokens

GLX_AUX9_EXT

OpenGLTokens

GLX_AUX_BUFFERS

OpenGLTokens

GLX_AUX_BUFFERS_BIT

OpenGLTokens

GLX_AUX_BUFFERS_BIT_SGIX

OpenGLTokens

GLX_BACK_EXT

OpenGLTokens

GLX_BACK_LEFT_BUFFER_BIT

OpenGLTokens

GLX_BACK_LEFT_BUFFER_BIT_SGIX

OpenGLTokens

GLX_BACK_LEFT_EXT

OpenGLTokens

GLX_BACK_RIGHT_BUFFER_BIT

OpenGLTokens

GLX_BACK_RIGHT_BUFFER_BIT_SGIX

OpenGLTokens

GLX_BACK_RIGHT_EXT

OpenGLTokens

GLX_BAD_ATTRIBUTE

OpenGLTokens

GLX_BAD_CONTEXT

OpenGLTokens

GLX_BAD_ENUM

OpenGLTokens

GLX_BAD_HYPERPIPE_CONFIG_SGIX

OpenGLTokens

GLX_BAD_HYPERPIPE_SGIX

OpenGLTokens

GLX_BAD_SCREEN

OpenGLTokens

GLX_BAD_VALUE

OpenGLTokens

GLX_BAD_VISUAL

OpenGLTokens

GLX_BIND_TO_MIPMAP_TEXTURE_EXT

OpenGLTokens

GLX_BIND_TO_TEXTURE_RGBA_EXT

OpenGLTokens

GLX_BIND_TO_TEXTURE_RGB_EXT

OpenGLTokens

GLX_BIND_TO_TEXTURE_TARGETS_EXT

OpenGLTokens

GLX_BLENDED_RGBA_SGIS

OpenGLTokens

GLX_BLUE_SIZE

OpenGLTokens

GLX_BUFFER_CLOBBER_MASK_SGIX

OpenGLTokens

GLX_BUFFER_SIZE

OpenGLTokens

GLX_BUFFER_SWAP_COMPLETE_INTEL_MASK

OpenGLTokens

GLX_COLOR_INDEX_BIT

OpenGLTokens

GLX_COLOR_INDEX_BIT_SGIX

OpenGLTokens

GLX_COLOR_INDEX_TYPE

OpenGLTokens

GLX_COLOR_INDEX_TYPE_SGIX

OpenGLTokens

GLX_COLOR_SAMPLES_NV

OpenGLTokens

GLX_CONFIG_CAVEAT

OpenGLTokens

GLX_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB

OpenGLTokens

GLX_CONTEXT_CORE_PROFILE_BIT_ARB

OpenGLTokens

GLX_CONTEXT_DEBUG_BIT_ARB

OpenGLTokens

GLX_CONTEXT_FLAGS_ARB

OpenGLTokens

GLX_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB

OpenGLTokens

GLX_CONTEXT_MAJOR_VERSION_ARB

OpenGLTokens

GLX_CONTEXT_MINOR_VERSION_ARB

OpenGLTokens

GLX_CONTEXT_PROFILE_MASK_ARB

OpenGLTokens

GLX_COPY_COMPLETE_INTEL

OpenGLTokens

GLX_DAMAGED

OpenGLTokens

GLX_DAMAGED_SGIX

OpenGLTokens

GLX_DEPTH_BUFFER_BIT

OpenGLTokens

GLX_DEPTH_BUFFER_BIT_SGIX

OpenGLTokens

GLX_DEPTH_SIZE

OpenGLTokens

GLX_DEVICE_ID_NV

OpenGLTokens

GLX_DIGITAL_MEDIA_PBUFFER_SGIX

OpenGLTokens

GLX_DIRECT_COLOR

OpenGLTokens

GLX_DIRECT_COLOR_EXT

OpenGLTokens

GLX_DONT_CARE

OpenGLTokens

GLX_DOUBLEBUFFER

OpenGLTokens

GLX_DRAWABLE_TYPE

OpenGLTokens

GLX_DRAWABLE_TYPE_SGIX

OpenGLTokens

GLX_EVENT_MASK

OpenGLTokens

GLX_EVENT_MASK_SGIX

OpenGLTokens

GLX_EXCHANGE_COMPLETE_INTEL

OpenGLTokens

GLX_EXTENSIONS

OpenGLTokens

GLX_EXTENSION_NAME

OpenGLTokens

GLX_FBCONFIG_ID

OpenGLTokens

GLX_FBCONFIG_ID_SGIX

OpenGLTokens

GLX_FLIP_COMPLETE_INTEL

OpenGLTokens

GLX_FLOAT_COMPONENTS_NV

OpenGLTokens

GLX_FRAMEBUFFER_SRGB_CAPABLE_ARB

OpenGLTokens

GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT

OpenGLTokens

GLX_FRONT_EXT

OpenGLTokens

GLX_FRONT_LEFT_BUFFER_BIT

OpenGLTokens

GLX_FRONT_LEFT_BUFFER_BIT_SGIX

OpenGLTokens

GLX_FRONT_LEFT_EXT

OpenGLTokens

GLX_FRONT_RIGHT_BUFFER_BIT

OpenGLTokens

GLX_FRONT_RIGHT_BUFFER_BIT_SGIX

OpenGLTokens

GLX_FRONT_RIGHT_EXT

OpenGLTokens

GLX_GRAY_SCALE

OpenGLTokens

GLX_GRAY_SCALE_EXT

OpenGLTokens

GLX_GREEN_SIZE

OpenGLTokens

GLX_HEIGHT

OpenGLTokens

GLX_HEIGHT_SGIX

OpenGLTokens

GLX_HYPERPIPE_DISPLAY_PIPE_SGIX

OpenGLTokens

GLX_HYPERPIPE_ID_SGIX

OpenGLTokens

GLX_HYPERPIPE_PIPE_NAME_LENGTH_SGIX

OpenGLTokens

GLX_HYPERPIPE_PIXEL_AVERAGE_SGIX

OpenGLTokens

GLX_HYPERPIPE_RENDER_PIPE_SGIX

OpenGLTokens

GLX_HYPERPIPE_STEREO_SGIX

OpenGLTokens

GLX_LARGEST_BUFFER

OpenGLTokens

GLX_LARGEST_PBUFFER_SGIX

OpenGLTokens

GLX_LEVEL

OpenGLTokens

GLX_MAX_PBUFFER_HEIGHT

OpenGLTokens

GLX_MAX_PBUFFER_HEIGHT_SGIX

OpenGLTokens

GLX_MAX_PBUFFER_PIXELS

OpenGLTokens

GLX_MAX_PBUFFER_PIXELS_SGIX

OpenGLTokens

GLX_MAX_PBUFFER_WIDTH

OpenGLTokens

GLX_MAX_PBUFFER_WIDTH_SGIX

OpenGLTokens

GLX_MAX_SWAP_INTERVAL_EXT

OpenGLTokens

GLX_MIPMAP_TEXTURE_EXT

OpenGLTokens

GLX_MULTISAMPLE_SUB_RECT_HEIGHT_SGIS

OpenGLTokens

GLX_MULTISAMPLE_SUB_RECT_WIDTH_SGIS

OpenGLTokens

GLX_NONE

OpenGLTokens

GLX_NONE_EXT

OpenGLTokens

GLX_NON_CONFORMANT_CONFIG

OpenGLTokens

GLX_NON_CONFORMANT_VISUAL_EXT

OpenGLTokens

GLX_NO_EXTENSION

OpenGLTokens

GLX_NUM_VIDEO_CAPTURE_SLOTS_NV

OpenGLTokens

GLX_NUM_VIDEO_SLOTS_NV

OpenGLTokens

GLX_OPTIMAL_PBUFFER_HEIGHT_SGIX

OpenGLTokens

GLX_OPTIMAL_PBUFFER_WIDTH_SGIX

OpenGLTokens

GLX_PBUFFER

OpenGLTokens

GLX_PBUFFER_BIT

OpenGLTokens

GLX_PBUFFER_BIT_SGIX

OpenGLTokens

GLX_PBUFFER_CLOBBER_MASK

OpenGLTokens

GLX_PBUFFER_HEIGHT

OpenGLTokens

GLX_PBUFFER_SGIX

OpenGLTokens

GLX_PBUFFER_WIDTH

OpenGLTokens

GLX_PIPE_RECT_LIMITS_SGIX

OpenGLTokens

GLX_PIPE_RECT_SGIX

OpenGLTokens

GLX_PIXMAP_BIT

OpenGLTokens

GLX_PIXMAP_BIT_SGIX

OpenGLTokens

GLX_PRESERVED_CONTENTS

OpenGLTokens

GLX_PRESERVED_CONTENTS_SGIX

OpenGLTokens

GLX_PSEUDO_COLOR

OpenGLTokens

GLX_PSEUDO_COLOR_EXT

OpenGLTokens

GLX_RED_SIZE

OpenGLTokens

GLX_RENDER_TYPE

OpenGLTokens

GLX_RENDER_TYPE_SGIX

OpenGLTokens

GLX_RGBA

OpenGLTokens

GLX_RGBA_BIT

OpenGLTokens

GLX_RGBA_BIT_SGIX

OpenGLTokens

GLX_RGBA_FLOAT_BIT_ARB

OpenGLTokens

GLX_RGBA_FLOAT_TYPE_ARB

OpenGLTokens

GLX_RGBA_TYPE

OpenGLTokens

GLX_RGBA_TYPE_SGIX

OpenGLTokens

GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT

OpenGLTokens

GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT

OpenGLTokens

GLX_SAMPLES

OpenGLTokens

GLX_SAMPLES_ARB

OpenGLTokens

GLX_SAMPLES_SGIS

OpenGLTokens

GLX_SAMPLE_BUFFERS

OpenGLTokens

GLX_SAMPLE_BUFFERS_ARB

OpenGLTokens

GLX_SAMPLE_BUFFERS_BIT_SGIX

OpenGLTokens

GLX_SAMPLE_BUFFERS_SGIS

OpenGLTokens

GLX_SAVED

OpenGLTokens

GLX_SAVED_SGIX

OpenGLTokens

GLX_SCREEN

OpenGLTokens

GLX_SCREEN_EXT

OpenGLTokens

GLX_SHARE_CONTEXT_EXT

OpenGLTokens

GLX_SLOW_CONFIG

OpenGLTokens

GLX_SLOW_VISUAL_EXT

OpenGLTokens

GLX_STATIC_COLOR

OpenGLTokens

GLX_STATIC_COLOR_EXT

OpenGLTokens

GLX_STATIC_GRAY

OpenGLTokens

GLX_STATIC_GRAY_EXT

OpenGLTokens

GLX_STENCIL_BUFFER_BIT

OpenGLTokens

GLX_STENCIL_BUFFER_BIT_SGIX

OpenGLTokens

GLX_STENCIL_SIZE

OpenGLTokens

GLX_STEREO

OpenGLTokens

GLX_SWAP_COPY_OML

OpenGLTokens

GLX_SWAP_EXCHANGE_OML

OpenGLTokens

GLX_SWAP_INTERVAL_EXT

OpenGLTokens

GLX_SWAP_METHOD_OML

OpenGLTokens

GLX_SWAP_UNDEFINED_OML

OpenGLTokens

GLX_SYNC_FRAME_SGIX

OpenGLTokens

GLX_SYNC_SWAP_SGIX

OpenGLTokens

GLX_TEXTURE_1D_BIT_EXT

OpenGLTokens

GLX_TEXTURE_1D_EXT

OpenGLTokens

GLX_TEXTURE_2D_BIT_EXT

OpenGLTokens

GLX_TEXTURE_2D_EXT

OpenGLTokens

GLX_TEXTURE_FORMAT_EXT

OpenGLTokens

GLX_TEXTURE_FORMAT_NONE_EXT

OpenGLTokens

GLX_TEXTURE_FORMAT_RGBA_EXT

OpenGLTokens

GLX_TEXTURE_FORMAT_RGB_EXT

OpenGLTokens

GLX_TEXTURE_RECTANGLE_BIT_EXT

OpenGLTokens

GLX_TEXTURE_RECTANGLE_EXT

OpenGLTokens

GLX_TEXTURE_TARGET_EXT

OpenGLTokens

GLX_TRANSPARENT_ALPHA_VALUE

OpenGLTokens

GLX_TRANSPARENT_ALPHA_VALUE_EXT

OpenGLTokens

GLX_TRANSPARENT_BLUE_VALUE

OpenGLTokens

GLX_TRANSPARENT_BLUE_VALUE_EXT

OpenGLTokens

GLX_TRANSPARENT_GREEN_VALUE

OpenGLTokens

GLX_TRANSPARENT_GREEN_VALUE_EXT

OpenGLTokens

GLX_TRANSPARENT_INDEX

OpenGLTokens

GLX_TRANSPARENT_INDEX_EXT

OpenGLTokens

GLX_TRANSPARENT_INDEX_VALUE

OpenGLTokens

GLX_TRANSPARENT_INDEX_VALUE_EXT

OpenGLTokens

GLX_TRANSPARENT_RED_VALUE

OpenGLTokens

GLX_TRANSPARENT_RED_VALUE_EXT

OpenGLTokens

GLX_TRANSPARENT_RGB

OpenGLTokens

GLX_TRANSPARENT_RGB_EXT

OpenGLTokens

GLX_TRANSPARENT_TYPE

OpenGLTokens

GLX_TRANSPARENT_TYPE_EXT

OpenGLTokens

GLX_TRUE_COLOR

OpenGLTokens

GLX_TRUE_COLOR_EXT

OpenGLTokens

GLX_UNIQUE_ID_NV

OpenGLTokens

GLX_USE_GL

OpenGLTokens

GLX_VENDOR

OpenGLTokens

GLX_VERSION

OpenGLTokens

GLX_VIDEO_OUT_ALPHA_NV

OpenGLTokens

GLX_VIDEO_OUT_COLOR_AND_ALPHA_NV

OpenGLTokens

GLX_VIDEO_OUT_COLOR_AND_DEPTH_NV

OpenGLTokens

GLX_VIDEO_OUT_COLOR_NV

OpenGLTokens

GLX_VIDEO_OUT_DEPTH_NV

OpenGLTokens

GLX_VIDEO_OUT_FIELD_1_NV

OpenGLTokens

GLX_VIDEO_OUT_FIELD_2_NV

OpenGLTokens

GLX_VIDEO_OUT_FRAME_NV

OpenGLTokens

GLX_VIDEO_OUT_STACKED_FIELDS_1_2_NV

OpenGLTokens

GLX_VIDEO_OUT_STACKED_FIELDS_2_1_NV

OpenGLTokens

GLX_VISUAL_CAVEAT_EXT

OpenGLTokens

GLX_VISUAL_ID

OpenGLTokens

GLX_VISUAL_ID_EXT

OpenGLTokens

GLX_VISUAL_SELECT_GROUP_SGIX

OpenGLTokens

GLX_WIDTH

OpenGLTokens

GLX_WIDTH_SGIX

OpenGLTokens

GLX_WINDOW

OpenGLTokens

GLX_WINDOW_BIT

OpenGLTokens

GLX_WINDOW_BIT_SGIX

OpenGLTokens

GLX_WINDOW_SGIX

OpenGLTokens

GLX_X_RENDERABLE

OpenGLTokens

GLX_X_RENDERABLE_SGIX

OpenGLTokens

GLX_X_VISUAL_TYPE

OpenGLTokens

GLX_X_VISUAL_TYPE_EXT

OpenGLTokens

GLX_Y_INVERTED_EXT

OpenGLTokens

GL_1PASS_EXT

OpenGLTokens

GL_1PASS_SGIS

OpenGLTokens

GL_2D

OpenGLTokens

GL_2PASS_0_EXT

OpenGLTokens

GL_2PASS_0_SGIS

OpenGLTokens

GL_2PASS_1_EXT

OpenGLTokens

GL_2PASS_1_SGIS

OpenGLTokens

GL_2_BYTES

OpenGLTokens

GL_3D

OpenGLTokens

GL_3D_COLOR

OpenGLTokens

GL_3D_COLOR_TEXTURE

OpenGLTokens

GL_3_BYTES

OpenGLTokens

GL_4D_COLOR_TEXTURE

OpenGLTokens

GL_4PASS_0_EXT

OpenGLTokens

GL_4PASS_0_SGIS

OpenGLTokens

GL_4PASS_1_EXT

OpenGLTokens

GL_4PASS_1_SGIS

OpenGLTokens

GL_4PASS_2_EXT

OpenGLTokens

GL_4PASS_2_SGIS

OpenGLTokens

GL_4PASS_3_EXT

OpenGLTokens

GL_4PASS_3_SGIS

OpenGLTokens

GL_4_BYTES

OpenGLTokens

GL_ABGR_EXT

OpenGLTokens

GL_ACCUM

OpenGLTokens

GL_ACCUM_ADJACENT_PAIRS_NV

OpenGLTokens

GL_ACCUM_ALPHA_BITS

OpenGLTokens

GL_ACCUM_BLUE_BITS

OpenGLTokens

GL_ACCUM_BUFFER_BIT

OpenGLTokens

GL_ACCUM_CLEAR_VALUE

OpenGLTokens

GL_ACCUM_GREEN_BITS

OpenGLTokens

GL_ACCUM_RED_BITS

OpenGLTokens

GL_ACTIVE_ATTRIBUTES

OpenGLTokens

GL_ACTIVE_ATTRIBUTE_MAX_LENGTH

OpenGLTokens

GL_ACTIVE_PROGRAM

OpenGLTokens

GL_ACTIVE_STENCIL_FACE_EXT

OpenGLTokens

GL_ACTIVE_SUBROUTINES

OpenGLTokens

GL_ACTIVE_SUBROUTINE_MAX_LENGTH

OpenGLTokens

GL_ACTIVE_SUBROUTINE_UNIFORMS

OpenGLTokens

GL_ACTIVE_SUBROUTINE_UNIFORM_LOCATIONS

OpenGLTokens

GL_ACTIVE_SUBROUTINE_UNIFORM_MAX_LENGTH

OpenGLTokens

GL_ACTIVE_TEXTURE

OpenGLTokens

GL_ACTIVE_TEXTURE_ARB

OpenGLTokens

GL_ACTIVE_UNIFORMS

OpenGLTokens

GL_ACTIVE_UNIFORM_BLOCKS

OpenGLTokens

GL_ACTIVE_UNIFORM_BLOCK_MAX_NAME_LENGTH

OpenGLTokens

GL_ACTIVE_UNIFORM_MAX_LENGTH

OpenGLTokens

GL_ACTIVE_VARYINGS_NV

OpenGLTokens

GL_ACTIVE_VARYING_MAX_LENGTH_NV

OpenGLTokens

GL_ACTIVE_VERTEX_UNITS_ARB

OpenGLTokens

GL_ADD

OpenGLTokens

GL_ADD_SIGNED

OpenGLTokens

GL_ADD_SIGNED_ARB

OpenGLTokens

GL_ADD_SIGNED_EXT

OpenGLTokens

GL_ADJACENT_PAIRS_NV

OpenGLTokens

GL_AFFINE_2D_NV

OpenGLTokens

GL_AFFINE_3D_NV

OpenGLTokens

GL_ALIASED_LINE_WIDTH_RANGE

OpenGLTokens

GL_ALIASED_POINT_SIZE_RANGE

OpenGLTokens

GL_ALL_ATTRIB_BITS

OpenGLTokens

GL_ALL_COMPLETED_NV

OpenGLTokens

GL_ALL_SHADER_BITS

OpenGLTokens

GL_ALPHA

OpenGLTokens

GL_ALPHA12

OpenGLTokens

GL_ALPHA12_EXT

OpenGLTokens

GL_ALPHA16

OpenGLTokens

GL_ALPHA16F_ARB

OpenGLTokens

GL_ALPHA16I_EXT

OpenGLTokens

GL_ALPHA16UI_EXT

OpenGLTokens

GL_ALPHA16_EXT

OpenGLTokens

GL_ALPHA32F_ARB

OpenGLTokens

GL_ALPHA32I_EXT

OpenGLTokens

GL_ALPHA32UI_EXT

OpenGLTokens

GL_ALPHA4

OpenGLTokens

GL_ALPHA4_EXT

OpenGLTokens

GL_ALPHA8

OpenGLTokens

GL_ALPHA8I_EXT

OpenGLTokens

GL_ALPHA8UI_EXT

OpenGLTokens

GL_ALPHA8_EXT

OpenGLTokens

GL_ALPHA_BIAS

OpenGLTokens

GL_ALPHA_BITS

OpenGLTokens

GL_ALPHA_FLOAT16_ATI

OpenGLTokens

GL_ALPHA_FLOAT32_ATI

OpenGLTokens

GL_ALPHA_INTEGER

OpenGLTokens

GL_ALPHA_INTEGER_EXT

OpenGLTokens

GL_ALPHA_SCALE

OpenGLTokens

GL_ALPHA_TEST

OpenGLTokens

GL_ALPHA_TEST_FUNC

OpenGLTokens

GL_ALPHA_TEST_REF

OpenGLTokens

GL_ALREADY_SIGNALED

OpenGLTokens

GL_ALWAYS

OpenGLTokens

GL_AMBIENT

OpenGLTokens

GL_AMBIENT_AND_DIFFUSE

OpenGLTokens

GL_AND

OpenGLTokens

GL_AND_INVERTED

OpenGLTokens

GL_AND_REVERSE

OpenGLTokens

GL_ANY_SAMPLES_PASSED

OpenGLTokens

GL_ARC_TO_NV

OpenGLTokens

GL_ARRAY_BUFFER

OpenGLTokens

GL_ARRAY_BUFFER_ARB

OpenGLTokens

GL_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_ARRAY_ELEMENT_LOCK_COUNT_EXT

OpenGLTokens

GL_ARRAY_ELEMENT_LOCK_FIRST_EXT

OpenGLTokens

GL_ASE_MAX_SMOOTH_GROUPS

GLFileASE

GL_ASE_MAX_SUBMATERIALS

GLFileASE

GL_ASE_MAX_TEXTURE_MAPS

GLFileASE

GL_ASE_MAX_TEXURE_CHANNELS

GLFileASE

GL_ATTACHED_SHADERS

OpenGLTokens

GL_ATTRIB_ARRAY_POINTER_NV

OpenGLTokens

GL_ATTRIB_ARRAY_SIZE_NV

OpenGLTokens

GL_ATTRIB_ARRAY_STRIDE_NV

OpenGLTokens

GL_ATTRIB_ARRAY_TYPE_NV

OpenGLTokens

GL_ATTRIB_STACK_DEPTH

OpenGLTokens

GL_AUTO_NORMAL

OpenGLTokens

GL_AUX0

OpenGLTokens

GL_AUX1

OpenGLTokens

GL_AUX2

OpenGLTokens

GL_AUX3

OpenGLTokens

GL_AUX_BUFFERS

OpenGLTokens

GL_BACK

OpenGLTokens

GL_BACK_LEFT

OpenGLTokens

GL_BACK_PRIMARY_COLOR_NV

OpenGLTokens

GL_BACK_RIGHT

OpenGLTokens

GL_BACK_SECONDARY_COLOR_NV

OpenGLTokens

GL_BEVEL_NV

OpenGLTokens

GL_BGR

OpenGLTokens

GL_BGRA

OpenGLTokens

GL_BGRA_EXT

OpenGLTokens

GL_BGRA_INTEGER

OpenGLTokens

GL_BGRA_INTEGER_EXT

OpenGLTokens

GL_BGR_EXT

OpenGLTokens

GL_BGR_INTEGER

OpenGLTokens

GL_BGR_INTEGER_EXT

OpenGLTokens

GL_BIAS_BY_NEGATIVE_ONE_HALF_NV

OpenGLTokens

GL_BITMAP

OpenGLTokens

GL_BITMAP_TOKEN

OpenGLTokens

GL_BLEND

OpenGLTokens

GL_BLEND_COLOR

OpenGLTokens

GL_BLEND_COLOR_EXT

OpenGLTokens

GL_BLEND_DST

OpenGLTokens

GL_BLEND_DST_ALPHA

OpenGLTokens

GL_BLEND_DST_ALPHA_EXT

OpenGLTokens

GL_BLEND_DST_RGB

OpenGLTokens

GL_BLEND_DST_RGB_EXT

OpenGLTokens

GL_BLEND_EQUATION

OpenGLTokens

GL_BLEND_EQUATION_ALPHA

OpenGLTokens

GL_BLEND_EQUATION_ALPHA_EXT

OpenGLTokens

GL_BLEND_EQUATION_EXT

OpenGLTokens

GL_BLEND_EQUATION_RGB

OpenGLTokens

GL_BLEND_EQUATION_RGB_EXT

OpenGLTokens

GL_BLEND_SRC

OpenGLTokens

GL_BLEND_SRC_ALPHA

OpenGLTokens

GL_BLEND_SRC_ALPHA_EXT

OpenGLTokens

GL_BLEND_SRC_RGB

OpenGLTokens

GL_BLEND_SRC_RGB_EXT

OpenGLTokens

GL_BLUE

OpenGLTokens

GL_BLUE_BIAS

OpenGLTokens

GL_BLUE_BITS

OpenGLTokens

GL_BLUE_INTEGER

OpenGLTokens

GL_BLUE_INTEGER_EXT

OpenGLTokens

GL_BLUE_SCALE

OpenGLTokens

GL_BOLD_BIT_NV

OpenGLTokens

GL_BOOL

OpenGLTokens

GL_BOOL_ARB

OpenGLTokens

GL_BOOL_VEC2

OpenGLTokens

GL_BOOL_VEC2_ARB

OpenGLTokens

GL_BOOL_VEC3

OpenGLTokens

GL_BOOL_VEC3_ARB

OpenGLTokens

GL_BOOL_VEC4

OpenGLTokens

GL_BOOL_VEC4_ARB

OpenGLTokens

GL_BOUNDING_BOX_NV

OpenGLTokens

GL_BOUNDING_BOX_OF_BOUNDING_BOXES_NV

OpenGLTokens

GL_BUFFER_ACCESS

OpenGLTokens

GL_BUFFER_ACCESS_ARB

OpenGLTokens

GL_BUFFER_ACCESS_FLAGS

OpenGLTokens

GL_BUFFER_GPU_ADDRESS_NV

OpenGLTokens

GL_BUFFER_MAPPED

OpenGLTokens

GL_BUFFER_MAPPED_ARB

OpenGLTokens

GL_BUFFER_MAP_LENGTH

OpenGLTokens

GL_BUFFER_MAP_OFFSET

OpenGLTokens

GL_BUFFER_MAP_POINTER

OpenGLTokens

GL_BUFFER_MAP_POINTER_ARB

OpenGLTokens

GL_BUFFER_SIZE

OpenGLTokens

GL_BUFFER_SIZE_ARB

OpenGLTokens

GL_BUFFER_USAGE

OpenGLTokens

GL_BUFFER_USAGE_ARB

OpenGLTokens

GL_BYTE

OpenGLTokens

GL_C3F_V3F

OpenGLTokens

GL_C4F_N3F_V3F

OpenGLTokens

GL_C4UB_V2F

OpenGLTokens

GL_C4UB_V3F

OpenGLTokens

GL_CCW

OpenGLTokens

GL_CIRCULAR_CCW_ARC_TO_NV

OpenGLTokens

GL_CIRCULAR_CW_ARC_TO_NV

OpenGLTokens

GL_CIRCULAR_TANGENT_ARC_TO_NV

OpenGLTokens

GL_CLAMP

OpenGLTokens

GL_CLAMP_FRAGMENT_COLOR

OpenGLTokens

GL_CLAMP_FRAGMENT_COLOR_ARB

OpenGLTokens

GL_CLAMP_READ_COLOR

OpenGLTokens

GL_CLAMP_READ_COLOR_ARB

OpenGLTokens

GL_CLAMP_TO_BORDER

OpenGLTokens

GL_CLAMP_TO_BORDER_ARB

OpenGLTokens

GL_CLAMP_TO_BORDER_SGIS

OpenGLTokens

GL_CLAMP_TO_EDGE

OpenGLTokens

GL_CLAMP_TO_EDGE_SGIS

OpenGLTokens

GL_CLAMP_VERTEX_COLOR

OpenGLTokens

GL_CLAMP_VERTEX_COLOR_ARB

OpenGLTokens

GL_CLEAR

OpenGLTokens

GL_CLIENT_ACTIVE_TEXTURE

OpenGLTokens

GL_CLIENT_ACTIVE_TEXTURE_ARB

OpenGLTokens

GL_CLIENT_ALL_ATTRIB_BITS

OpenGLTokens

GL_CLIENT_ATTRIB_STACK_DEPTH

OpenGLTokens

GL_CLIENT_PIXEL_STORE_BIT

OpenGLTokens

GL_CLIENT_VERTEX_ARRAY_BIT

OpenGLTokens

GL_CLIP_DISTANCE0

OpenGLTokens

GL_CLIP_DISTANCE1

OpenGLTokens

GL_CLIP_DISTANCE2

OpenGLTokens

GL_CLIP_DISTANCE3

OpenGLTokens

GL_CLIP_DISTANCE4

OpenGLTokens

GL_CLIP_DISTANCE5

OpenGLTokens

GL_CLIP_DISTANCE6

OpenGLTokens

GL_CLIP_DISTANCE7

OpenGLTokens

GL_CLIP_DISTANCE_NV

OpenGLTokens

GL_CLIP_PLANE0

OpenGLTokens

GL_CLIP_PLANE1

OpenGLTokens

GL_CLIP_PLANE2

OpenGLTokens

GL_CLIP_PLANE3

OpenGLTokens

GL_CLIP_PLANE4

OpenGLTokens

GL_CLIP_PLANE5

OpenGLTokens

GL_CLIP_VOLUME_CLIPPING_HINT_EXT

OpenGLTokens

GL_CLOSE_PATH_NV

OpenGLTokens

GL_COEFF

OpenGLTokens

GL_COLOR

OpenGLTokens

GL_COLOR_ARRAY

OpenGLTokens

GL_COLOR_ARRAY_ADDRESS_NV

OpenGLTokens

GL_COLOR_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_COLOR_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_COLOR_ARRAY_LENGTH_NV

OpenGLTokens

GL_COLOR_ARRAY_POINTER

OpenGLTokens

GL_COLOR_ARRAY_SIZE

OpenGLTokens

GL_COLOR_ARRAY_STRIDE

OpenGLTokens

GL_COLOR_ARRAY_TYPE

OpenGLTokens

GL_COLOR_ATTACHMENT0

OpenGLTokens

GL_COLOR_ATTACHMENT0_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT1

OpenGLTokens

GL_COLOR_ATTACHMENT10

OpenGLTokens

GL_COLOR_ATTACHMENT10_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT11

OpenGLTokens

GL_COLOR_ATTACHMENT11_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT12

OpenGLTokens

GL_COLOR_ATTACHMENT12_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT13

OpenGLTokens

GL_COLOR_ATTACHMENT13_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT14

OpenGLTokens

GL_COLOR_ATTACHMENT14_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT15

OpenGLTokens

GL_COLOR_ATTACHMENT15_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT1_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT2

OpenGLTokens

GL_COLOR_ATTACHMENT2_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT3

OpenGLTokens

GL_COLOR_ATTACHMENT3_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT4

OpenGLTokens

GL_COLOR_ATTACHMENT4_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT5

OpenGLTokens

GL_COLOR_ATTACHMENT5_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT6

OpenGLTokens

GL_COLOR_ATTACHMENT6_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT7

OpenGLTokens

GL_COLOR_ATTACHMENT7_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT8

OpenGLTokens

GL_COLOR_ATTACHMENT8_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT9

OpenGLTokens

GL_COLOR_ATTACHMENT9_EXT

OpenGLTokens

GL_COLOR_BUFFER_BIT

OpenGLTokens

GL_COLOR_CLEAR_UNCLAMPED_VALUE_ATI

OpenGLTokens

GL_COLOR_CLEAR_VALUE

OpenGLTokens

GL_COLOR_INDEX

OpenGLTokens

GL_COLOR_INDEX12_EXT

OpenGLTokens

GL_COLOR_INDEX16_EXT

OpenGLTokens

GL_COLOR_INDEX1_EXT

OpenGLTokens

GL_COLOR_INDEX2_EXT

OpenGLTokens

GL_COLOR_INDEX4_EXT

OpenGLTokens

GL_COLOR_INDEX8_EXT

OpenGLTokens

GL_COLOR_INDEXES

OpenGLTokens

GL_COLOR_LOGIC_OP

OpenGLTokens

GL_COLOR_MATERIAL

OpenGLTokens

GL_COLOR_MATERIAL_FACE

OpenGLTokens

GL_COLOR_MATERIAL_PARAMETER

OpenGLTokens

GL_COLOR_MATRIX

OpenGLTokens

GL_COLOR_MATRIX_SGI

OpenGLTokens

GL_COLOR_MATRIX_STACK_DEPTH

OpenGLTokens

GL_COLOR_MATRIX_STACK_DEPTH_SGI

OpenGLTokens

GL_COLOR_SUM

OpenGLTokens

GL_COLOR_SUM_ARB

OpenGLTokens

GL_COLOR_SUM_CLAMP_NV

OpenGLTokens

GL_COLOR_SUM_EXT

OpenGLTokens

GL_COLOR_TABLE

OpenGLTokens

GL_COLOR_TABLE_ALPHA_SIZE

OpenGLTokens

GL_COLOR_TABLE_BIAS

OpenGLTokens

GL_COLOR_TABLE_BLUE_SIZE

OpenGLTokens

GL_COLOR_TABLE_FORMAT

OpenGLTokens

GL_COLOR_TABLE_GREEN_SIZE

OpenGLTokens

GL_COLOR_TABLE_INTENSITY_SIZE

OpenGLTokens

GL_COLOR_TABLE_LUMINANCE_SIZE

OpenGLTokens

GL_COLOR_TABLE_RED_SIZE

OpenGLTokens

GL_COLOR_TABLE_SCALE

OpenGLTokens

GL_COLOR_TABLE_WIDTH

OpenGLTokens

GL_COLOR_WRITEMASK

OpenGLTokens

GL_COMBINE

OpenGLTokens

GL_COMBINE4_NV

OpenGLTokens

GL_COMBINER0_NV

OpenGLTokens

GL_COMBINER1_NV

OpenGLTokens

GL_COMBINER2_NV

OpenGLTokens

GL_COMBINER3_NV

OpenGLTokens

GL_COMBINER4_NV

OpenGLTokens

GL_COMBINER5_NV

OpenGLTokens

GL_COMBINER6_NV

OpenGLTokens

GL_COMBINER7_NV

OpenGLTokens

GL_COMBINER_AB_DOT_PRODUCT_NV

OpenGLTokens

GL_COMBINER_AB_OUTPUT_NV

OpenGLTokens

GL_COMBINER_BIAS_NV

OpenGLTokens

GL_COMBINER_CD_DOT_PRODUCT_NV

OpenGLTokens

GL_COMBINER_CD_OUTPUT_NV

OpenGLTokens

GL_COMBINER_COMPONENT_USAGE_NV

OpenGLTokens

GL_COMBINER_INPUT_NV

OpenGLTokens

GL_COMBINER_MAPPING_NV

OpenGLTokens

GL_COMBINER_MUX_SUM_NV

OpenGLTokens

GL_COMBINER_SCALE_NV

OpenGLTokens

GL_COMBINER_SUM_OUTPUT_NV

OpenGLTokens

GL_COMBINE_ALPHA

OpenGLTokens

GL_COMBINE_ALPHA_ARB

OpenGLTokens

GL_COMBINE_ALPHA_EXT

OpenGLTokens

GL_COMBINE_ARB

OpenGLTokens

GL_COMBINE_EXT

OpenGLTokens

GL_COMBINE_RGB

OpenGLTokens

GL_COMBINE_RGB_ARB

OpenGLTokens

GL_COMBINE_RGB_EXT

OpenGLTokens

GL_COMPARE_REF_DEPTH_TO_TEXTURE_EXT

OpenGLTokens

GL_COMPARE_REF_TO_TEXTURE

OpenGLTokens

GL_COMPARE_R_TO_TEXTURE

OpenGLTokens

GL_COMPARE_R_TO_TEXTURE_ARB

OpenGLTokens

GL_COMPATIBLE_SUBROUTINES

OpenGLTokens

GL_COMPILE

OpenGLTokens

GL_COMPILE_AND_EXECUTE

OpenGLTokens

GL_COMPILE_STATUS

OpenGLTokens

GL_COMPRESSED_ALPHA

OpenGLTokens

GL_COMPRESSED_ALPHA_ARB

OpenGLTokens

GL_COMPRESSED_INTENSITY

OpenGLTokens

GL_COMPRESSED_INTENSITY_ARB

OpenGLTokens

GL_COMPRESSED_LUMINANCE

OpenGLTokens

GL_COMPRESSED_LUMINANCE_ALPHA

OpenGLTokens

GL_COMPRESSED_LUMINANCE_ALPHA_3DC_ATI

OpenGLTokens

GL_COMPRESSED_LUMINANCE_ALPHA_ARB

OpenGLTokens

GL_COMPRESSED_LUMINANCE_ALPHA_LATC2_EXT

OpenGLTokens

GL_COMPRESSED_LUMINANCE_ARB

OpenGLTokens

GL_COMPRESSED_LUMINANCE_LATC1_EXT

OpenGLTokens

GL_COMPRESSED_RED

OpenGLTokens

GL_COMPRESSED_RED_GREEN_RGTC2_EXT

OpenGLTokens

GL_COMPRESSED_RED_RGTC1

OpenGLTokens

GL_COMPRESSED_RED_RGTC1_EXT

OpenGLTokens

GL_COMPRESSED_RG

OpenGLTokens

GL_COMPRESSED_RGB

OpenGLTokens

GL_COMPRESSED_RGBA

OpenGLTokens

GL_COMPRESSED_RGBA_ARB

OpenGLTokens

GL_COMPRESSED_RGBA_BPTC_UNORM_ARB

OpenGLTokens

GL_COMPRESSED_RGBA_FXT1_3DFX

OpenGLTokens

GL_COMPRESSED_RGBA_S3TC_DXT1_EXT

OpenGLTokens

GL_COMPRESSED_RGBA_S3TC_DXT3_EXT

OpenGLTokens

GL_COMPRESSED_RGBA_S3TC_DXT5_EXT

OpenGLTokens

GL_COMPRESSED_RGB_ARB

OpenGLTokens

GL_COMPRESSED_RGB_BPTC_SIGNED_FLOAT_ARB

OpenGLTokens

GL_COMPRESSED_RGB_BPTC_UNSIGNED_FLOAT_ARB

OpenGLTokens

GL_COMPRESSED_RGB_FXT1_3DFX

OpenGLTokens

GL_COMPRESSED_RGB_S3TC_DXT1_EXT

OpenGLTokens

GL_COMPRESSED_RG_RGTC2

OpenGLTokens

GL_COMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2_EXT

OpenGLTokens

GL_COMPRESSED_SIGNED_LUMINANCE_LATC1_EXT

OpenGLTokens

GL_COMPRESSED_SIGNED_RED_GREEN_RGTC2_EXT

OpenGLTokens

GL_COMPRESSED_SIGNED_RED_RGTC1

OpenGLTokens

GL_COMPRESSED_SIGNED_RED_RGTC1_EXT

OpenGLTokens

GL_COMPRESSED_SIGNED_RG_RGTC2

OpenGLTokens

GL_COMPRESSED_SLUMINANCE

OpenGLTokens

GL_COMPRESSED_SLUMINANCE_ALPHA

OpenGLTokens

GL_COMPRESSED_SLUMINANCE_ALPHA_EXT

OpenGLTokens

GL_COMPRESSED_SLUMINANCE_EXT

OpenGLTokens

GL_COMPRESSED_SRGB

OpenGLTokens

GL_COMPRESSED_SRGB_ALPHA

OpenGLTokens

GL_COMPRESSED_SRGB_ALPHA_BPTC_UNORM_ARB

OpenGLTokens

GL_COMPRESSED_SRGB_ALPHA_EXT

OpenGLTokens

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT1_EXT

OpenGLTokens

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT3_EXT

OpenGLTokens

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT5_EXT

OpenGLTokens

GL_COMPRESSED_SRGB_EXT

OpenGLTokens

GL_COMPRESSED_SRGB_S3TC_DXT1_EXT

OpenGLTokens

GL_COMPRESSED_TEXTURE_FORMATS

OpenGLTokens

GL_COMPRESSED_TEXTURE_FORMATS_ARB

OpenGLTokens

GL_CONDITION_SATISFIED

OpenGLTokens

GL_CONSTANT

OpenGLTokens

GL_CONSTANT_ALPHA

OpenGLTokens

GL_CONSTANT_ALPHA_EXT

OpenGLTokens

GL_CONSTANT_ARB

OpenGLTokens

GL_CONSTANT_ATTENUATION

OpenGLTokens

GL_CONSTANT_BORDER

OpenGLTokens

GL_CONSTANT_COLOR

OpenGLTokens

GL_CONSTANT_COLOR0_NV

OpenGLTokens

GL_CONSTANT_COLOR1_NV

OpenGLTokens

GL_CONSTANT_COLOR_ARB

OpenGLTokens

GL_CONSTANT_COLOR_EXT

OpenGLTokens

GL_CONSTANT_EXT

OpenGLTokens

GL_CONST_EYE_NV

OpenGLTokens

GL_CONTEXT_COMPATIBILITY_PROFILE_BIT

OpenGLTokens

GL_CONTEXT_CORE_PROFILE_BIT

OpenGLTokens

GL_CONTEXT_FLAGS

OpenGLTokens

GL_CONTEXT_FLAG_FORWARD_COMPATIBLE_BIT

OpenGLTokens

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT_ARB

OpenGLTokens

GL_CONTEXT_PROFILE_MASK

OpenGLTokens

GL_CONTINUOUS_AMD

OpenGLTokens

GL_CONVEX_HULL_NV

OpenGLTokens

GL_CONVOLUTION_1D

OpenGLTokens

GL_CONVOLUTION_1D_EXT

OpenGLTokens

GL_CONVOLUTION_2D

OpenGLTokens

GL_CONVOLUTION_2D_EXT

OpenGLTokens

GL_CONVOLUTION_BORDER_COLOR

OpenGLTokens

GL_CONVOLUTION_BORDER_MODE

OpenGLTokens

GL_CONVOLUTION_BORDER_MODE_EXT

OpenGLTokens

GL_CONVOLUTION_FILTER_BIAS

OpenGLTokens

GL_CONVOLUTION_FILTER_BIAS_EXT

OpenGLTokens

GL_CONVOLUTION_FILTER_SCALE

OpenGLTokens

GL_CONVOLUTION_FILTER_SCALE_EXT

OpenGLTokens

GL_CONVOLUTION_FORMAT

OpenGLTokens

GL_CONVOLUTION_FORMAT_EXT

OpenGLTokens

GL_CONVOLUTION_HEIGHT

OpenGLTokens

GL_CONVOLUTION_HEIGHT_EXT

OpenGLTokens

GL_CONVOLUTION_WIDTH

OpenGLTokens

GL_CONVOLUTION_WIDTH_EXT

OpenGLTokens

GL_COORD_REPLACE

OpenGLTokens

GL_COORD_REPLACE_ARB

OpenGLTokens

GL_COORD_REPLACE_NV

OpenGLTokens

GL_COPY

OpenGLTokens

GL_COPY_INVERTED

OpenGLTokens

GL_COPY_PIXEL_TOKEN

OpenGLTokens

GL_COPY_READ_BUFFER

OpenGLTokens

GL_COPY_WRITE_BUFFER

OpenGLTokens

GL_COUNT_DOWN_NV

OpenGLTokens

GL_COUNT_UP_NV

OpenGLTokens

GL_CUBIC_CURVE_TO_NV

OpenGLTokens

GL_CULL_FACE

OpenGLTokens

GL_CULL_FACE_MODE

OpenGLTokens

GL_CULL_FRAGMENT_NV

OpenGLTokens

GL_CULL_MODES_NV

OpenGLTokens

GL_CURRENT_ATTRIB_NV

OpenGLTokens

GL_CURRENT_BIT

OpenGLTokens

GL_CURRENT_COLOR

OpenGLTokens

GL_CURRENT_FOG_COORD

OpenGLTokens

GL_CURRENT_FOG_COORDINATE

OpenGLTokens

GL_CURRENT_FOG_COORDINATE_EXT

OpenGLTokens

GL_CURRENT_INDEX

OpenGLTokens

GL_CURRENT_MATRIX_ARB

OpenGLTokens

GL_CURRENT_MATRIX_INDEX_ARB

OpenGLTokens

GL_CURRENT_MATRIX_NV

OpenGLTokens

GL_CURRENT_MATRIX_STACK_DEPTH_ARB

OpenGLTokens

GL_CURRENT_MATRIX_STACK_DEPTH_NV

OpenGLTokens

GL_CURRENT_NORMAL

OpenGLTokens

GL_CURRENT_OCCLUSION_QUERY_ID_NV

OpenGLTokens

GL_CURRENT_PALETTE_MATRIX_ARB

OpenGLTokens

GL_CURRENT_PROGRAM

OpenGLTokens

GL_CURRENT_QUERY

OpenGLTokens

GL_CURRENT_QUERY_ARB

OpenGLTokens

GL_CURRENT_RASTER_COLOR

OpenGLTokens

GL_CURRENT_RASTER_DISTANCE

OpenGLTokens

GL_CURRENT_RASTER_INDEX

OpenGLTokens

GL_CURRENT_RASTER_POSITION

OpenGLTokens

GL_CURRENT_RASTER_POSITION_VALID

OpenGLTokens

GL_CURRENT_RASTER_SECONDARY_COLOR

OpenGLTokens

GL_CURRENT_RASTER_TEXTURE_COORDS

OpenGLTokens

GL_CURRENT_SECONDARY_COLOR

OpenGLTokens

GL_CURRENT_SECONDARY_COLOR_EXT

OpenGLTokens

GL_CURRENT_TEXTURE_COORDS

OpenGLTokens

GL_CURRENT_VERTEX_ATTRIB

OpenGLTokens

GL_CURRENT_VERTEX_ATTRIB_ARB

OpenGLTokens

GL_CURRENT_WEIGHT_ARB

OpenGLTokens

GL_CW

OpenGLTokens

GL_DEBUG_CALLBACK_FUNCTION_ARB

OpenGLTokens

GL_DEBUG_CALLBACK_USER_PARAM_ARB

OpenGLTokens

GL_DEBUG_LOGGED_MESSAGES_ARB

OpenGLTokens

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH_ARB

OpenGLTokens

GL_DEBUG_OUTPUT_SYNCHRONOUS_ARB

OpenGLTokens

GL_DEBUG_SEVERITY_HIGH_ARB

OpenGLTokens

GL_DEBUG_SEVERITY_LOW_ARB

OpenGLTokens

GL_DEBUG_SEVERITY_MEDIUM_ARB

OpenGLTokens

GL_DEBUG_SOURCE_API_ARB

OpenGLTokens

GL_DEBUG_SOURCE_APPLICATION_ARB

OpenGLTokens

GL_DEBUG_SOURCE_OTHER_ARB

OpenGLTokens

GL_DEBUG_SOURCE_SHADER_COMPILER_ARB

OpenGLTokens

GL_DEBUG_SOURCE_THIRD_PARTY_ARB

OpenGLTokens

GL_DEBUG_SOURCE_WINDOW_SYSTEM_ARB

OpenGLTokens

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR_ARB

OpenGLTokens

GL_DEBUG_TYPE_ERROR_ARB

OpenGLTokens

GL_DEBUG_TYPE_OTHER_ARB

OpenGLTokens

GL_DEBUG_TYPE_PERFORMANCE_ARB

OpenGLTokens

GL_DEBUG_TYPE_PORTABILITY_ARB

OpenGLTokens

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR_ARB

OpenGLTokens

GL_DECAL

OpenGLTokens

GL_DECODE_EXT

OpenGLTokens

GL_DECR

OpenGLTokens

GL_DECR_WRAP

OpenGLTokens

GL_DECR_WRAP_EXT

OpenGLTokens

GL_DELETE_STATUS

OpenGLTokens

GL_DEPENDENT_AR_TEXTURE_2D_NV

OpenGLTokens

GL_DEPENDENT_GB_TEXTURE_2D_NV

OpenGLTokens

GL_DEPENDENT_HILO_TEXTURE_2D_NV

OpenGLTokens

GL_DEPENDENT_RGB_TEXTURE_3D_NV

OpenGLTokens

GL_DEPENDENT_RGB_TEXTURE_CUBE_MAP_NV

OpenGLTokens

GL_DEPTH

OpenGLTokens

GL_DEPTH24_STENCIL8

OpenGLTokens

GL_DEPTH24_STENCIL8_EXT

OpenGLTokens

GL_DEPTH32F_STENCIL8

OpenGLTokens

GL_DEPTH_ATTACHMENT

OpenGLTokens

GL_DEPTH_ATTACHMENT_EXT

OpenGLTokens

GL_DEPTH_BIAS

OpenGLTokens

GL_DEPTH_BITS

OpenGLTokens

GL_DEPTH_BOUNDS_EXT

OpenGLTokens

GL_DEPTH_BOUNDS_TEST_EXT

OpenGLTokens

GL_DEPTH_BUFFER

OpenGLTokens

GL_DEPTH_BUFFER_BIT

OpenGLTokens

GL_DEPTH_CLAMP

OpenGLTokens

GL_DEPTH_CLEAR_VALUE

OpenGLTokens

GL_DEPTH_COMPONENT

OpenGLTokens

GL_DEPTH_COMPONENT16

OpenGLTokens

GL_DEPTH_COMPONENT16_ARB

OpenGLTokens

GL_DEPTH_COMPONENT24

OpenGLTokens

GL_DEPTH_COMPONENT24_ARB

OpenGLTokens

GL_DEPTH_COMPONENT32

OpenGLTokens

GL_DEPTH_COMPONENT32F

OpenGLTokens

GL_DEPTH_COMPONENT32_ARB

OpenGLTokens

GL_DEPTH_FUNC

OpenGLTokens

GL_DEPTH_RANGE

OpenGLTokens

GL_DEPTH_SCALE

OpenGLTokens

GL_DEPTH_STENCIL

OpenGLTokens

GL_DEPTH_STENCIL_ATTACHMENT

OpenGLTokens

GL_DEPTH_STENCIL_EXT

OpenGLTokens

GL_DEPTH_TEST

OpenGLTokens

GL_DEPTH_TEXTURE_MODE

OpenGLTokens

GL_DEPTH_TEXTURE_MODE_ARB

OpenGLTokens

GL_DEPTH_WRITEMASK

OpenGLTokens

GL_DIFFUSE

OpenGLTokens

GL_DISCARD_NV

OpenGLTokens

GL_DISCRETE_AMD

OpenGLTokens

GL_DISTANCE_ATTENUATION_ARB

OpenGLTokens

GL_DITHER

OpenGLTokens

GL_DOMAIN

OpenGLTokens

GL_DONT_CARE

OpenGLTokens

GL_DOT3_RGB

OpenGLTokens

GL_DOT3_RGBA

OpenGLTokens

GL_DOT3_RGBA_ARB

OpenGLTokens

GL_DOT3_RGBA_EXT

OpenGLTokens

GL_DOT3_RGB_ARB

OpenGLTokens

GL_DOT3_RGB_EXT

OpenGLTokens

GL_DOT_PRODUCT_AFFINE_DEPTH_REPLACE_NV

OpenGLTokens

GL_DOT_PRODUCT_CONST_EYE_REFLECT_CUBE_MAP_NV

OpenGLTokens

GL_DOT_PRODUCT_DEPTH_REPLACE_NV

OpenGLTokens

GL_DOT_PRODUCT_DIFFUSE_CUBE_MAP_NV

OpenGLTokens

GL_DOT_PRODUCT_NV

OpenGLTokens

GL_DOT_PRODUCT_PASS_THROUGH_NV

OpenGLTokens

GL_DOT_PRODUCT_REFLECT_CUBE_MAP_NV

OpenGLTokens

GL_DOT_PRODUCT_TEXTURE_1D_NV

OpenGLTokens

GL_DOT_PRODUCT_TEXTURE_2D_NV

OpenGLTokens

GL_DOT_PRODUCT_TEXTURE_3D_NV

OpenGLTokens

GL_DOT_PRODUCT_TEXTURE_CUBE_MAP_NV

OpenGLTokens

GL_DOT_PRODUCT_TEXTURE_RECTANGLE_NV

OpenGLTokens

GL_DOUBLE

OpenGLTokens

GL_DOUBLEBUFFER

OpenGLTokens

GL_DOUBLE_EXT

OpenGLTokens

GL_DOUBLE_MAT2

OpenGLTokens

GL_DOUBLE_MAT2x3

OpenGLTokens

GL_DOUBLE_MAT2x4

OpenGLTokens

GL_DOUBLE_MAT3

OpenGLTokens

GL_DOUBLE_MAT3x2

OpenGLTokens

GL_DOUBLE_MAT3x4

OpenGLTokens

GL_DOUBLE_MAT4

OpenGLTokens

GL_DOUBLE_MAT4x2

OpenGLTokens

GL_DOUBLE_MAT4x3

OpenGLTokens

GL_DOUBLE_VEC2

OpenGLTokens

GL_DOUBLE_VEC3

OpenGLTokens

GL_DOUBLE_VEC4

OpenGLTokens

GL_DRAW_BUFFER

OpenGLTokens

GL_DRAW_BUFFER0

OpenGLTokens

GL_DRAW_BUFFER0_ARB

OpenGLTokens

GL_DRAW_BUFFER0_ATI

OpenGLTokens

GL_DRAW_BUFFER1

OpenGLTokens

GL_DRAW_BUFFER10

OpenGLTokens

GL_DRAW_BUFFER10_ARB

OpenGLTokens

GL_DRAW_BUFFER10_ATI

OpenGLTokens

GL_DRAW_BUFFER11

OpenGLTokens

GL_DRAW_BUFFER11_ARB

OpenGLTokens

GL_DRAW_BUFFER11_ATI

OpenGLTokens

GL_DRAW_BUFFER12

OpenGLTokens

GL_DRAW_BUFFER12_ARB

OpenGLTokens

GL_DRAW_BUFFER12_ATI

OpenGLTokens

GL_DRAW_BUFFER13

OpenGLTokens

GL_DRAW_BUFFER13_ARB

OpenGLTokens

GL_DRAW_BUFFER13_ATI

OpenGLTokens

GL_DRAW_BUFFER14

OpenGLTokens

GL_DRAW_BUFFER14_ARB

OpenGLTokens

GL_DRAW_BUFFER14_ATI

OpenGLTokens

GL_DRAW_BUFFER15

OpenGLTokens

GL_DRAW_BUFFER15_ARB

OpenGLTokens

GL_DRAW_BUFFER15_ATI

OpenGLTokens

GL_DRAW_BUFFER1_ARB

OpenGLTokens

GL_DRAW_BUFFER1_ATI

OpenGLTokens

GL_DRAW_BUFFER2

OpenGLTokens

GL_DRAW_BUFFER2_ARB

OpenGLTokens

GL_DRAW_BUFFER2_ATI

OpenGLTokens

GL_DRAW_BUFFER3

OpenGLTokens

GL_DRAW_BUFFER3_ARB

OpenGLTokens

GL_DRAW_BUFFER3_ATI

OpenGLTokens

GL_DRAW_BUFFER4

OpenGLTokens

GL_DRAW_BUFFER4_ARB

OpenGLTokens

GL_DRAW_BUFFER4_ATI

OpenGLTokens

GL_DRAW_BUFFER5

OpenGLTokens

GL_DRAW_BUFFER5_ARB

OpenGLTokens

GL_DRAW_BUFFER5_ATI

OpenGLTokens

GL_DRAW_BUFFER6

OpenGLTokens

GL_DRAW_BUFFER6_ARB

OpenGLTokens

GL_DRAW_BUFFER6_ATI

OpenGLTokens

GL_DRAW_BUFFER7

OpenGLTokens

GL_DRAW_BUFFER7_ARB

OpenGLTokens

GL_DRAW_BUFFER7_ATI

OpenGLTokens

GL_DRAW_BUFFER8

OpenGLTokens

GL_DRAW_BUFFER8_ARB

OpenGLTokens

GL_DRAW_BUFFER8_ATI

OpenGLTokens

GL_DRAW_BUFFER9

OpenGLTokens

GL_DRAW_BUFFER9_ARB

OpenGLTokens

GL_DRAW_BUFFER9_ATI

OpenGLTokens

GL_DRAW_FRAMEBUFFER

OpenGLTokens

GL_DRAW_FRAMEBUFFER_BINDING

OpenGLTokens

GL_DRAW_FRAMEBUFFER_BINDING_EXT

OpenGLTokens

GL_DRAW_FRAMEBUFFER_EXT

OpenGLTokens

GL_DRAW_INDIRECT_BUFFER

OpenGLTokens

GL_DRAW_INDIRECT_BUFFER_BINDING

OpenGLTokens

GL_DRAW_PIXEL_TOKEN

OpenGLTokens

GL_DSDT8_MAG8_INTENSITY8_NV

OpenGLTokens

GL_DSDT8_MAG8_NV

OpenGLTokens

GL_DSDT8_NV

OpenGLTokens

GL_DSDT_MAG_INTENSITY_NV

OpenGLTokens

GL_DSDT_MAG_NV

OpenGLTokens

GL_DSDT_MAG_VIB_NV

OpenGLTokens

GL_DSDT_NV

OpenGLTokens

GL_DST_ALPHA

OpenGLTokens

GL_DST_COLOR

OpenGLTokens

GL_DS_BIAS_NV

OpenGLTokens

GL_DS_SCALE_NV

OpenGLTokens

GL_DT_BIAS_NV

OpenGLTokens

GL_DT_SCALE_NV

OpenGLTokens

GL_DYNAMIC_COPY

OpenGLTokens

GL_DYNAMIC_COPY_ARB

OpenGLTokens

GL_DYNAMIC_DRAW

OpenGLTokens

GL_DYNAMIC_DRAW_ARB

OpenGLTokens

GL_DYNAMIC_READ

OpenGLTokens

GL_DYNAMIC_READ_ARB

OpenGLTokens

GL_EDGE_FLAG

OpenGLTokens

GL_EDGE_FLAG_ARRAY

OpenGLTokens

GL_EDGE_FLAG_ARRAY_ADDRESS_NV

OpenGLTokens

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_EDGE_FLAG_ARRAY_LENGTH_NV

OpenGLTokens

GL_EDGE_FLAG_ARRAY_POINTER

OpenGLTokens

GL_EDGE_FLAG_ARRAY_STRIDE

OpenGLTokens

GL_ELEMENT_ARRAY_ADDRESS_NV

OpenGLTokens

GL_ELEMENT_ARRAY_BUFFER

OpenGLTokens

GL_ELEMENT_ARRAY_BUFFER_ARB

OpenGLTokens

GL_ELEMENT_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_ELEMENT_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_ELEMENT_ARRAY_LENGTH_NV

OpenGLTokens

GL_ELEMENT_ARRAY_UNIFIED_NV

OpenGLTokens

GL_EMISSION

OpenGLTokens

GL_ENABLE_BIT

OpenGLTokens

GL_EQUAL

OpenGLTokens

GL_EQUIV

OpenGLTokens

GL_EVAL_BIT

OpenGLTokens

GL_EXP

OpenGLTokens

GL_EXP2

OpenGLTokens

GL_EXPAND_NEGATE_NV

OpenGLTokens

GL_EXPAND_NORMAL_NV

OpenGLTokens

GL_EXTENSIONS

OpenGLTokens

GL_EYE_LINEAR

OpenGLTokens

GL_EYE_PLANE

OpenGLTokens

GL_EYE_PLANE_ABSOLUTE_NV

OpenGLTokens

GL_EYE_RADIAL_NV

OpenGLTokens

GL_E_TIMES_F_NV

OpenGLTokens

GL_FALSE

OpenGLTokens

GL_FASTEST

OpenGLTokens

GL_FEEDBACK

OpenGLTokens

GL_FEEDBACK_BUFFER_POINTER

OpenGLTokens

GL_FEEDBACK_BUFFER_SIZE

OpenGLTokens

GL_FEEDBACK_BUFFER_TYPE

OpenGLTokens

GL_FENCE_CONDITION_NV

OpenGLTokens

GL_FENCE_STATUS_NV

OpenGLTokens

GL_FILE_NAME_NV

OpenGLTokens

GL_FILL

OpenGLTokens

GL_FIRST_TO_REST_NV

OpenGLTokens

GL_FIRST_VERTEX_CONVENTION

OpenGLTokens

GL_FIXED

OpenGLTokens

GL_FIXED_ONLY

OpenGLTokens

GL_FIXED_ONLY_ARB

OpenGLTokens

GL_FLAT

OpenGLTokens

GL_FLOAT

OpenGLTokens

GL_FLOAT_32_UNSIGNED_INT_24_8_REV

OpenGLTokens

GL_FLOAT_CLEAR_COLOR_VALUE_NV

OpenGLTokens

GL_FLOAT_MAT2

OpenGLTokens

GL_FLOAT_MAT2x3

OpenGLTokens

GL_FLOAT_MAT2x4

OpenGLTokens

GL_FLOAT_MAT2_ARB

OpenGLTokens

GL_FLOAT_MAT3

OpenGLTokens

GL_FLOAT_MAT3x2

OpenGLTokens

GL_FLOAT_MAT3x4

OpenGLTokens

GL_FLOAT_MAT3_ARB

OpenGLTokens

GL_FLOAT_MAT4

OpenGLTokens

GL_FLOAT_MAT4x2

OpenGLTokens

GL_FLOAT_MAT4x3

OpenGLTokens

GL_FLOAT_MAT4_ARB

OpenGLTokens

GL_FLOAT_R16_NV

OpenGLTokens

GL_FLOAT_R32_NV

OpenGLTokens

GL_FLOAT_RG16_NV

OpenGLTokens

GL_FLOAT_RG32_NV

OpenGLTokens

GL_FLOAT_RGB16_NV

OpenGLTokens

GL_FLOAT_RGB32_NV

OpenGLTokens

GL_FLOAT_RGBA16_NV

OpenGLTokens

GL_FLOAT_RGBA32_NV

OpenGLTokens

GL_FLOAT_RGBA_MODE_NV

OpenGLTokens

GL_FLOAT_RGBA_NV

OpenGLTokens

GL_FLOAT_RGB_NV

OpenGLTokens

GL_FLOAT_RG_NV

OpenGLTokens

GL_FLOAT_R_NV

OpenGLTokens

GL_FLOAT_VEC2

OpenGLTokens

GL_FLOAT_VEC2_ARB

OpenGLTokens

GL_FLOAT_VEC3

OpenGLTokens

GL_FLOAT_VEC3_ARB

OpenGLTokens

GL_FLOAT_VEC4

OpenGLTokens

GL_FLOAT_VEC4_ARB

OpenGLTokens

GL_FOG

OpenGLTokens

GL_FOG_BIT

OpenGLTokens

GL_FOG_COLOR

OpenGLTokens

GL_FOG_COORD

OpenGLTokens

GL_FOG_COORDINATE

OpenGLTokens

GL_FOG_COORDINATE_ARRAY

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_EXT

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_POINTER

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_POINTER_EXT

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_STRIDE

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_STRIDE_EXT

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_TYPE

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_TYPE_EXT

OpenGLTokens

GL_FOG_COORDINATE_EXT

OpenGLTokens

GL_FOG_COORDINATE_SOURCE

OpenGLTokens

GL_FOG_COORDINATE_SOURCE_EXT

OpenGLTokens

GL_FOG_COORD_ARRAY

OpenGLTokens

GL_FOG_COORD_ARRAY_ADDRESS_NV

OpenGLTokens

GL_FOG_COORD_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_FOG_COORD_ARRAY_LENGTH_NV

OpenGLTokens

GL_FOG_COORD_ARRAY_POINTER

OpenGLTokens

GL_FOG_COORD_ARRAY_STRIDE

OpenGLTokens

GL_FOG_COORD_ARRAY_TYPE

OpenGLTokens

GL_FOG_COORD_SRC

OpenGLTokens

GL_FOG_DENSITY

OpenGLTokens

GL_FOG_DISTANCE_MODE_NV

OpenGLTokens

GL_FOG_END

OpenGLTokens

GL_FOG_HINT

OpenGLTokens

GL_FOG_INDEX

OpenGLTokens

GL_FOG_MODE

OpenGLTokens

GL_FOG_START

OpenGLTokens

GL_FONT_ASCENDER_NV

OpenGLTokens

GL_FONT_DESCENDER_NV

OpenGLTokens

GL_FONT_HAS_KERNING_NV

OpenGLTokens

GL_FONT_HEIGHT_NV

OpenGLTokens

GL_FONT_MAX_ADVANCE_HEIGHT_NV

OpenGLTokens

GL_FONT_MAX_ADVANCE_WIDTH_NV

OpenGLTokens

GL_FONT_UNDERLINE_POSITION_NV

OpenGLTokens

GL_FONT_UNDERLINE_THICKNESS_NV

OpenGLTokens

GL_FONT_UNITS_PER_EM_NV

OpenGLTokens

GL_FONT_X_MAX_BOUNDS_NV

OpenGLTokens

GL_FONT_X_MIN_BOUNDS_NV

OpenGLTokens

GL_FONT_Y_MAX_BOUNDS_NV

OpenGLTokens

GL_FONT_Y_MIN_BOUNDS_NV

OpenGLTokens

GL_FORCE_BLUE_TO_ONE_NV

OpenGLTokens

GL_FRACTIONAL_EVEN

OpenGLTokens

GL_FRACTIONAL_ODD

OpenGLTokens

GL_FRAGMENT_DEPTH

OpenGLTokens

GL_FRAGMENT_DEPTH_EXT

OpenGLTokens

GL_FRAGMENT_INTERPOLATION_OFFSET_BITS

OpenGLTokens

GL_FRAGMENT_PROGRAM_ARB

OpenGLTokens

GL_FRAGMENT_SHADER

OpenGLTokens

GL_FRAGMENT_SHADER_ARB

OpenGLTokens

GL_FRAGMENT_SHADER_BIT

OpenGLTokens

GL_FRAGMENT_SHADER_DERIVATIVE_HINT

OpenGLTokens

GL_FRAGMENT_SHADER_DERIVATIVE_HINT_ARB

OpenGLTokens

GL_FRAMEBUFFER

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_ALPHA_SIZE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_BLUE_SIZE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_COLOR_ENCODING

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_COMPONENT_TYPE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_DEPTH_SIZE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_GREEN_SIZE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_LAYERED

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_ARB

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_EXT

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME_EXT

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE_EXT

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_RED_SIZE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_STENCIL_SIZE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_3D_ZOFFSET_EXT

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE_EXT

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER_EXT

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL_EXT

OpenGLTokens

GL_FRAMEBUFFER_BINDING

OpenGLTokens

GL_FRAMEBUFFER_BINDING_EXT

OpenGLTokens

GL_FRAMEBUFFER_COMPLETE

OpenGLTokens

GL_FRAMEBUFFER_COMPLETE_EXT

OpenGLTokens

GL_FRAMEBUFFER_DEFAULT

OpenGLTokens

GL_FRAMEBUFFER_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_FORMATS_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_ARB

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_ARB

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER_EXT

OpenGLTokens

GL_FRAMEBUFFER_SRGB

OpenGLTokens

GL_FRAMEBUFFER_SRGB_CAPABLE_EXT

OpenGLTokens

GL_FRAMEBUFFER_SRGB_EXT

OpenGLTokens

GL_FRAMEBUFFER_UNDEFINED

OpenGLTokens

GL_FRAMEBUFFER_UNSUPPORTED

OpenGLTokens

GL_FRAMEBUFFER_UNSUPPORTED_EXT

OpenGLTokens

GL_FRONT

OpenGLTokens

GL_FRONT_AND_BACK

OpenGLTokens

GL_FRONT_FACE

OpenGLTokens

GL_FRONT_LEFT

OpenGLTokens

GL_FRONT_RIGHT

OpenGLTokens

GL_FUNC_ADD

OpenGLTokens

GL_FUNC_ADD_EXT

OpenGLTokens

GL_FUNC_REVERSE_SUBTRACT

OpenGLTokens

GL_FUNC_REVERSE_SUBTRACT_EXT

OpenGLTokens

GL_FUNC_SUBTRACT

OpenGLTokens

GL_FUNC_SUBTRACT_EXT

OpenGLTokens

GL_GENERATE_MIPMAP

OpenGLTokens

GL_GENERATE_MIPMAP_HINT

OpenGLTokens

GL_GENERATE_MIPMAP_HINT_SGIS

OpenGLTokens

GL_GENERATE_MIPMAP_SGIS

OpenGLTokens

GL_GENERIC_ATTRIB_NV

OpenGLTokens

GL_GEOMETRY_INPUT_TYPE

OpenGLTokens

GL_GEOMETRY_INPUT_TYPE_ARB

OpenGLTokens

GL_GEOMETRY_INPUT_TYPE_EXT

OpenGLTokens

GL_GEOMETRY_OUTPUT_TYPE

OpenGLTokens

GL_GEOMETRY_OUTPUT_TYPE_ARB

OpenGLTokens

GL_GEOMETRY_OUTPUT_TYPE_EXT

OpenGLTokens

GL_GEOMETRY_PROGRAM_NV

OpenGLTokens

GL_GEOMETRY_SHADER

OpenGLTokens

GL_GEOMETRY_SHADER_ARB

OpenGLTokens

GL_GEOMETRY_SHADER_BIT

OpenGLTokens

GL_GEOMETRY_SHADER_EXT

OpenGLTokens

GL_GEOMETRY_SHADER_INVOCATIONS

OpenGLTokens

GL_GEOMETRY_VERTICES_OUT

OpenGLTokens

GL_GEOMETRY_VERTICES_OUT_ARB

OpenGLTokens

GL_GEOMETRY_VERTICES_OUT_EXT

OpenGLTokens

GL_GEQUAL

OpenGLTokens

GL_GLYPH_HAS_KERNING_NV

OpenGLTokens

GL_GLYPH_HEIGHT_BIT_NV

OpenGLTokens

GL_GLYPH_HORIZONTAL_BEARING_ADVANCE_BIT_NV

OpenGLTokens

GL_GLYPH_HORIZONTAL_BEARING_X_BIT_NV

OpenGLTokens

GL_GLYPH_HORIZONTAL_BEARING_Y_BIT_NV

OpenGLTokens

GL_GLYPH_VERTICAL_BEARING_ADVANCE_BIT_NV

OpenGLTokens

GL_GLYPH_VERTICAL_BEARING_X_BIT_NV

OpenGLTokens

GL_GLYPH_VERTICAL_BEARING_Y_BIT_NV

OpenGLTokens

GL_GLYPH_WIDTH_BIT_NV

OpenGLTokens

GL_GPU_ADDRESS_NV

OpenGLTokens

GL_GPU_MEMORY_INFO_CURRENT_AVAILABLE_VIDMEM_NVX

OpenGLTokens

GL_GPU_MEMORY_INFO_DEDICATED_VIDMEM_NVX

OpenGLTokens

GL_GPU_MEMORY_INFO_EVICTED_MEMORY_NVX

OpenGLTokens

GL_GPU_MEMORY_INFO_EVICTION_COUNT_NVX

OpenGLTokens

GL_GPU_MEMORY_INFO_TOTAL_AVAILABLE_MEMORY_NVX

OpenGLTokens

GL_GREATER

OpenGLTokens

GL_GREEN

OpenGLTokens

GL_GREEN_BIAS

OpenGLTokens

GL_GREEN_BITS

OpenGLTokens

GL_GREEN_INTEGER

OpenGLTokens

GL_GREEN_INTEGER_EXT

OpenGLTokens

GL_GREEN_SCALE

OpenGLTokens

GL_GUILTY_CONTEXT_RESET_ARB

OpenGLTokens

GL_HALF_BIAS_NEGATE_NV

OpenGLTokens

GL_HALF_BIAS_NORMAL_NV

OpenGLTokens

GL_HALF_FLOAT

OpenGLTokens

GL_HALF_FLOAT_ARB

OpenGLTokens

GL_HIGH_FLOAT

OpenGLTokens

GL_HIGH_INT

OpenGLTokens

GL_HILO16_NV

OpenGLTokens

GL_HILO8_NV

OpenGLTokens

GL_HILO_NV

OpenGLTokens

GL_HINT_BIT

OpenGLTokens

GL_HISTOGRAM

OpenGLTokens

GL_HISTOGRAM_ALPHA_SIZE

OpenGLTokens

GL_HISTOGRAM_ALPHA_SIZE_EXT

OpenGLTokens

GL_HISTOGRAM_BLUE_SIZE

OpenGLTokens

GL_HISTOGRAM_BLUE_SIZE_EXT

OpenGLTokens

GL_HISTOGRAM_EXT

OpenGLTokens

GL_HISTOGRAM_FORMAT

OpenGLTokens

GL_HISTOGRAM_FORMAT_EXT

OpenGLTokens

GL_HISTOGRAM_GREEN_SIZE

OpenGLTokens

GL_HISTOGRAM_GREEN_SIZE_EXT

OpenGLTokens

GL_HISTOGRAM_LUMINANCE_SIZE

OpenGLTokens

GL_HISTOGRAM_LUMINANCE_SIZE_EXT

OpenGLTokens

GL_HISTOGRAM_RED_SIZE

OpenGLTokens

GL_HISTOGRAM_RED_SIZE_EXT

OpenGLTokens

GL_HISTOGRAM_SINK

OpenGLTokens

GL_HISTOGRAM_SINK_EXT

OpenGLTokens

GL_HISTOGRAM_WIDTH

OpenGLTokens

GL_HISTOGRAM_WIDTH_EXT

OpenGLTokens

GL_HI_BIAS_NV

OpenGLTokens

GL_HI_SCALE_NV

OpenGLTokens

GL_HORIZONTAL_LINE_TO_NV

OpenGLTokens

GL_IDENTITY_NV

OpenGLTokens

GL_IMPLEMENTATION_COLOR_READ_FORMAT

OpenGLTokens

GL_IMPLEMENTATION_COLOR_READ_TYPE

OpenGLTokens

GL_INCR

OpenGLTokens

GL_INCR_WRAP

OpenGLTokens

GL_INCR_WRAP_EXT

OpenGLTokens

GL_INDEX

OpenGLTokens

GL_INDEX_ARRAY

OpenGLTokens

GL_INDEX_ARRAY_ADDRESS_NV

OpenGLTokens

GL_INDEX_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_INDEX_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_INDEX_ARRAY_LENGTH_NV

OpenGLTokens

GL_INDEX_ARRAY_POINTER

OpenGLTokens

GL_INDEX_ARRAY_STRIDE

OpenGLTokens

GL_INDEX_ARRAY_TYPE

OpenGLTokens

GL_INDEX_BITS

OpenGLTokens

GL_INDEX_CLEAR_VALUE

OpenGLTokens

GL_INDEX_LOGIC_OP

OpenGLTokens

GL_INDEX_MODE

OpenGLTokens

GL_INDEX_OFFSET

OpenGLTokens

GL_INDEX_SHIFT

OpenGLTokens

GL_INDEX_WRITEMASK

OpenGLTokens

GL_INFO_LOG_LENGTH

OpenGLTokens

GL_INNOCENT_CONTEXT_RESET_ARB

OpenGLTokens

GL_INT

OpenGLTokens

GL_INTENSITY

OpenGLTokens

GL_INTENSITY12

OpenGLTokens

GL_INTENSITY12_EXT

OpenGLTokens

GL_INTENSITY16

OpenGLTokens

GL_INTENSITY16F_ARB

OpenGLTokens

GL_INTENSITY16I_EXT

OpenGLTokens

GL_INTENSITY16UI_EXT

OpenGLTokens

GL_INTENSITY16_EXT

OpenGLTokens

GL_INTENSITY32F_ARB

OpenGLTokens

GL_INTENSITY32I_EXT

OpenGLTokens

GL_INTENSITY32UI_EXT

OpenGLTokens

GL_INTENSITY4

OpenGLTokens

GL_INTENSITY4_EXT

OpenGLTokens

GL_INTENSITY8

OpenGLTokens

GL_INTENSITY8I_EXT

OpenGLTokens

GL_INTENSITY8UI_EXT

OpenGLTokens

GL_INTENSITY8_EXT

OpenGLTokens

GL_INTENSITY_EXT

OpenGLTokens

GL_INTENSITY_FLOAT16_ATI

OpenGLTokens

GL_INTENSITY_FLOAT32_ATI

OpenGLTokens

GL_INTERLEAVED_ATTRIBS

OpenGLTokens

GL_INTERLEAVED_ATTRIBS_EXT

OpenGLTokens

GL_INTERLEAVED_ATTRIBS_NV

OpenGLTokens

GL_INTERPOLATE

OpenGLTokens

GL_INTERPOLATE_ARB

OpenGLTokens

GL_INTERPOLATE_EXT

OpenGLTokens

GL_INT_2_10_10_10_REV

OpenGLTokens

GL_INT_SAMPLER_1D

OpenGLTokens

GL_INT_SAMPLER_1D_ARRAY

OpenGLTokens

GL_INT_SAMPLER_1D_ARRAY_EXT

OpenGLTokens

GL_INT_SAMPLER_1D_EXT

OpenGLTokens

GL_INT_SAMPLER_2D

OpenGLTokens

GL_INT_SAMPLER_2D_ARRAY

OpenGLTokens

GL_INT_SAMPLER_2D_ARRAY_EXT

OpenGLTokens

GL_INT_SAMPLER_2D_EXT

OpenGLTokens

GL_INT_SAMPLER_2D_MULTISAMPLE

OpenGLTokens

GL_INT_SAMPLER_2D_MULTISAMPLE_ARRAY

OpenGLTokens

GL_INT_SAMPLER_2D_RECT

OpenGLTokens

GL_INT_SAMPLER_2D_RECT_EXT

OpenGLTokens

GL_INT_SAMPLER_3D

OpenGLTokens

GL_INT_SAMPLER_3D_EXT

OpenGLTokens

GL_INT_SAMPLER_BUFFER

OpenGLTokens

GL_INT_SAMPLER_BUFFER_AMD

OpenGLTokens

GL_INT_SAMPLER_BUFFER_EXT

OpenGLTokens

GL_INT_SAMPLER_CUBE

OpenGLTokens

GL_INT_SAMPLER_CUBE_EXT

OpenGLTokens

GL_INT_SAMPLER_CUBE_MAP_ARRAY

OpenGLTokens

GL_INT_SAMPLER_CUBE_MAP_ARRAY_ARB

OpenGLTokens

GL_INT_VEC2

OpenGLTokens

GL_INT_VEC2_ARB

OpenGLTokens

GL_INT_VEC3

OpenGLTokens

GL_INT_VEC3_ARB

OpenGLTokens

GL_INT_VEC4

OpenGLTokens

GL_INT_VEC4_ARB

OpenGLTokens

GL_INVALID_ENUM

OpenGLTokens

GL_INVALID_FRAMEBUFFER_OPERATION

OpenGLTokens

GL_INVALID_FRAMEBUFFER_OPERATION_EXT

OpenGLTokens

GL_INVALID_INDEX

OpenGLTokens

GL_INVALID_OPERATION

OpenGLTokens

GL_INVALID_VALUE

OpenGLTokens

GL_INVERSE_NV

OpenGLTokens

GL_INVERSE_TRANSPOSE_NV

OpenGLTokens

GL_INVERT

OpenGLTokens

GL_ISOLINES

OpenGLTokens

GL_ITALIC_BIT_NV

OpenGLTokens

GL_KEEP

OpenGLTokens

GL_LARGE_CCW_ARC_TO_NV

OpenGLTokens

GL_LARGE_CW_ARC_TO_NV

OpenGLTokens

GL_LAST_VERTEX_CONVENTION

OpenGLTokens

GL_LAYER_NV

OpenGLTokens

GL_LAYER_PROVOKING_VERTEX

OpenGLTokens

GL_LEFT

OpenGLTokens

GL_LEQUAL

OpenGLTokens

GL_LESS

OpenGLTokens

GL_LIGHT0

OpenGLTokens

GL_LIGHT1

OpenGLTokens

GL_LIGHT2

OpenGLTokens

GL_LIGHT3

OpenGLTokens

GL_LIGHT4

OpenGLTokens

GL_LIGHT5

OpenGLTokens

GL_LIGHT6

OpenGLTokens

GL_LIGHT7

OpenGLTokens

GL_LIGHTING

OpenGLTokens

GL_LIGHTING_BIT

OpenGLTokens

GL_LIGHT_MODEL_AMBIENT

OpenGLTokens

GL_LIGHT_MODEL_COLOR_CONTROL

OpenGLTokens

GL_LIGHT_MODEL_COLOR_CONTROL_EXT

OpenGLTokens

GL_LIGHT_MODEL_LOCAL_VIEWER

OpenGLTokens

GL_LIGHT_MODEL_TWO_SIDE

OpenGLTokens

GL_LINE

OpenGLTokens

GL_LINEAR

OpenGLTokens

GL_LINEAR_ATTENUATION

OpenGLTokens

GL_LINEAR_MIPMAP_LINEAR

OpenGLTokens

GL_LINEAR_MIPMAP_NEAREST

OpenGLTokens

GL_LINES

OpenGLTokens

GL_LINES_ADJACENCY

OpenGLTokens

GL_LINES_ADJACENCY_ARB

OpenGLTokens

GL_LINES_ADJACENCY_EXT

OpenGLTokens

GL_LINE_BIT

OpenGLTokens

GL_LINE_LOOP

OpenGLTokens

GL_LINE_RESET_TOKEN

OpenGLTokens

GL_LINE_SMOOTH

OpenGLTokens

GL_LINE_SMOOTH_HINT

OpenGLTokens

GL_LINE_STIPPLE

OpenGLTokens

GL_LINE_STIPPLE_PATTERN

OpenGLTokens

GL_LINE_STIPPLE_REPEAT

OpenGLTokens

GL_LINE_STRIP

OpenGLTokens

GL_LINE_STRIP_ADJACENCY

OpenGLTokens

GL_LINE_STRIP_ADJACENCY_ARB

OpenGLTokens

GL_LINE_STRIP_ADJACENCY_EXT

OpenGLTokens

GL_LINE_TOKEN

OpenGLTokens

GL_LINE_TO_NV

OpenGLTokens

GL_LINE_WIDTH

OpenGLTokens

GL_LINE_WIDTH_GRANULARITY

OpenGLTokens

GL_LINE_WIDTH_RANGE

OpenGLTokens

GL_LINK_STATUS

OpenGLTokens

GL_LIST_BASE

OpenGLTokens

GL_LIST_BIT

OpenGLTokens

GL_LIST_INDEX

OpenGLTokens

GL_LIST_MODE

OpenGLTokens

GL_LOAD

OpenGLTokens

GL_LOGIC_OP

OpenGLTokens

GL_LOGIC_OP_MODE

OpenGLTokens

GL_LOSE_CONTEXT_ON_RESET_ARB

OpenGLTokens

GL_LOWER_LEFT

OpenGLTokens

GL_LOW_FLOAT

OpenGLTokens

GL_LOW_INT

OpenGLTokens

GL_LO_BIAS_NV

OpenGLTokens

GL_LO_SCALE_NV

OpenGLTokens

GL_LUMINANCE

OpenGLTokens

GL_LUMINANCE12

OpenGLTokens

GL_LUMINANCE12_ALPHA12

OpenGLTokens

GL_LUMINANCE12_ALPHA12_EXT

OpenGLTokens

GL_LUMINANCE12_ALPHA4

OpenGLTokens

GL_LUMINANCE12_ALPHA4_EXT

OpenGLTokens

GL_LUMINANCE12_EXT

OpenGLTokens

GL_LUMINANCE16

OpenGLTokens

GL_LUMINANCE16F_ARB

OpenGLTokens

GL_LUMINANCE16I_EXT

OpenGLTokens

GL_LUMINANCE16UI_EXT

OpenGLTokens

GL_LUMINANCE16_ALPHA16

OpenGLTokens

GL_LUMINANCE16_ALPHA16_EXT

OpenGLTokens

GL_LUMINANCE16_EXT

OpenGLTokens

GL_LUMINANCE32F_ARB

OpenGLTokens

GL_LUMINANCE32I_EXT

OpenGLTokens

GL_LUMINANCE32UI_EXT

OpenGLTokens

GL_LUMINANCE4

OpenGLTokens

GL_LUMINANCE4_ALPHA4

OpenGLTokens

GL_LUMINANCE4_ALPHA4_EXT

OpenGLTokens

GL_LUMINANCE4_EXT

OpenGLTokens

GL_LUMINANCE6_ALPHA2

OpenGLTokens

GL_LUMINANCE6_ALPHA2_EXT

OpenGLTokens

GL_LUMINANCE8

OpenGLTokens

GL_LUMINANCE8I_EXT

OpenGLTokens

GL_LUMINANCE8UI_EXT

OpenGLTokens

GL_LUMINANCE8_ALPHA8

OpenGLTokens

GL_LUMINANCE8_ALPHA8_EXT

OpenGLTokens

GL_LUMINANCE8_EXT

OpenGLTokens

GL_LUMINANCE_ALPHA

OpenGLTokens

GL_LUMINANCE_ALPHA16F_ARB

OpenGLTokens

GL_LUMINANCE_ALPHA16I_EXT

OpenGLTokens

GL_LUMINANCE_ALPHA16UI_EXT

OpenGLTokens

GL_LUMINANCE_ALPHA32F_ARB

OpenGLTokens

GL_LUMINANCE_ALPHA32I_EXT

OpenGLTokens

GL_LUMINANCE_ALPHA32UI_EXT

OpenGLTokens

GL_LUMINANCE_ALPHA8I_EXT

OpenGLTokens

GL_LUMINANCE_ALPHA8UI_EXT

OpenGLTokens

GL_LUMINANCE_ALPHA_FLOAT16_ATI

OpenGLTokens

GL_LUMINANCE_ALPHA_FLOAT32_ATI

OpenGLTokens

GL_LUMINANCE_ALPHA_INTEGER_EXT

OpenGLTokens

GL_LUMINANCE_FLOAT16_ATI

OpenGLTokens

GL_LUMINANCE_FLOAT32_ATI

OpenGLTokens

GL_LUMINANCE_INTEGER_EXT

OpenGLTokens

GL_MAGNITUDE_BIAS_NV

OpenGLTokens

GL_MAGNITUDE_SCALE_NV

OpenGLTokens

GL_MAJOR_VERSION

OpenGLTokens

GL_MAP1_COLOR_4

OpenGLTokens

GL_MAP1_GRID_DOMAIN

OpenGLTokens

GL_MAP1_GRID_SEGMENTS

OpenGLTokens

GL_MAP1_INDEX

OpenGLTokens

GL_MAP1_NORMAL

OpenGLTokens

GL_MAP1_TEXTURE_COORD_1

OpenGLTokens

GL_MAP1_TEXTURE_COORD_2

OpenGLTokens

GL_MAP1_TEXTURE_COORD_3

OpenGLTokens

GL_MAP1_TEXTURE_COORD_4

OpenGLTokens

GL_MAP1_VERTEX_3

OpenGLTokens

GL_MAP1_VERTEX_4

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB0_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB10_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB11_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB12_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB13_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB14_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB15_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB1_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB2_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB3_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB4_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB5_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB6_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB7_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB8_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB9_4_NV

OpenGLTokens

GL_MAP2_COLOR_4

OpenGLTokens

GL_MAP2_GRID_DOMAIN

OpenGLTokens

GL_MAP2_GRID_SEGMENTS

OpenGLTokens

GL_MAP2_INDEX

OpenGLTokens

GL_MAP2_NORMAL

OpenGLTokens

GL_MAP2_TEXTURE_COORD_1

OpenGLTokens

GL_MAP2_TEXTURE_COORD_2

OpenGLTokens

GL_MAP2_TEXTURE_COORD_3

OpenGLTokens

GL_MAP2_TEXTURE_COORD_4

OpenGLTokens

GL_MAP2_VERTEX_3

OpenGLTokens

GL_MAP2_VERTEX_4

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB0_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB10_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB11_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB12_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB13_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB14_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB15_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB1_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB2_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB3_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB4_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB5_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB6_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB7_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB8_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB9_4_NV

OpenGLTokens

GL_MAP_COLOR

OpenGLTokens

GL_MAP_FLUSH_EXPLICIT_BIT

OpenGLTokens

GL_MAP_INVALIDATE_BUFFER_BIT

OpenGLTokens

GL_MAP_INVALIDATE_RANGE_BIT

OpenGLTokens

GL_MAP_READ_BIT

OpenGLTokens

GL_MAP_STENCIL

OpenGLTokens

GL_MAP_UNSYNCHRONIZED_BIT

OpenGLTokens

GL_MAP_WRITE_BIT

OpenGLTokens

GL_MATRIX0_ARB

OpenGLTokens

GL_MATRIX0_NV

OpenGLTokens

GL_MATRIX10_ARB

OpenGLTokens

GL_MATRIX11_ARB

OpenGLTokens

GL_MATRIX12_ARB

OpenGLTokens

GL_MATRIX13_ARB

OpenGLTokens

GL_MATRIX14_ARB

OpenGLTokens

GL_MATRIX15_ARB

OpenGLTokens

GL_MATRIX16_ARB

OpenGLTokens

GL_MATRIX17_ARB

OpenGLTokens

GL_MATRIX18_ARB

OpenGLTokens

GL_MATRIX19_ARB

OpenGLTokens

GL_MATRIX1_ARB

OpenGLTokens

GL_MATRIX1_NV

OpenGLTokens

GL_MATRIX20_ARB

OpenGLTokens

GL_MATRIX21_ARB

OpenGLTokens

GL_MATRIX22_ARB

OpenGLTokens

GL_MATRIX23_ARB

OpenGLTokens

GL_MATRIX24_ARB

OpenGLTokens

GL_MATRIX25_ARB

OpenGLTokens

GL_MATRIX26_ARB

OpenGLTokens

GL_MATRIX27_ARB

OpenGLTokens

GL_MATRIX28_ARB

OpenGLTokens

GL_MATRIX29_ARB

OpenGLTokens

GL_MATRIX2_ARB

OpenGLTokens

GL_MATRIX2_NV

OpenGLTokens

GL_MATRIX30_ARB

OpenGLTokens

GL_MATRIX31_ARB

OpenGLTokens

GL_MATRIX3_ARB

OpenGLTokens

GL_MATRIX3_NV

OpenGLTokens

GL_MATRIX4_ARB

OpenGLTokens

GL_MATRIX4_NV

OpenGLTokens

GL_MATRIX5_ARB

OpenGLTokens

GL_MATRIX5_NV

OpenGLTokens

GL_MATRIX6_ARB

OpenGLTokens

GL_MATRIX6_NV

OpenGLTokens

GL_MATRIX7_ARB

OpenGLTokens

GL_MATRIX7_NV

OpenGLTokens

GL_MATRIX8_ARB

OpenGLTokens

GL_MATRIX9_ARB

OpenGLTokens

GL_MATRIX_INDEX_ARRAY_ARB

OpenGLTokens

GL_MATRIX_INDEX_ARRAY_POINTER_ARB

OpenGLTokens

GL_MATRIX_INDEX_ARRAY_SIZE_ARB

OpenGLTokens

GL_MATRIX_INDEX_ARRAY_STRIDE_ARB

OpenGLTokens

GL_MATRIX_INDEX_ARRAY_TYPE_ARB

OpenGLTokens

GL_MATRIX_MODE

OpenGLTokens

GL_MATRIX_PALETTE_ARB

OpenGLTokens

GL_MAX

OpenGLTokens

GL_MAX_3D_TEXTURE_SIZE

OpenGLTokens

GL_MAX_3D_TEXTURE_SIZE_EXT

OpenGLTokens

GL_MAX_ARRAY_TEXTURE_LAYERS

OpenGLTokens

GL_MAX_ARRAY_TEXTURE_LAYERS_EXT

OpenGLTokens

GL_MAX_ATTRIB_STACK_DEPTH

OpenGLTokens

GL_MAX_BINDABLE_UNIFORM_SIZE_EXT

OpenGLTokens

GL_MAX_CLIENT_ATTRIB_STACK_DEPTH

OpenGLTokens

GL_MAX_CLIP_DISTANCES

OpenGLTokens

GL_MAX_CLIP_PLANES

OpenGLTokens

GL_MAX_COLOR_ATTACHMENTS

OpenGLTokens

GL_MAX_COLOR_ATTACHMENTS_EXT

OpenGLTokens

GL_MAX_COLOR_MATRIX_STACK_DEPTH

OpenGLTokens

GL_MAX_COLOR_MATRIX_STACK_DEPTH_SGI

OpenGLTokens

GL_MAX_COLOR_TEXTURE_SAMPLES

OpenGLTokens

GL_MAX_COMBINED_FRAGMENT_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_COMBINED_GEOMETRY_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_COMBINED_TESS_CONTROL_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_COMBINED_TESS_EVALUATION_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS

OpenGLTokens

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB

OpenGLTokens

GL_MAX_COMBINED_UNIFORM_BLOCKS

OpenGLTokens

GL_MAX_COMBINED_VERTEX_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_CONVOLUTION_HEIGHT

OpenGLTokens

GL_MAX_CONVOLUTION_HEIGHT_EXT

OpenGLTokens

GL_MAX_CONVOLUTION_WIDTH

OpenGLTokens

GL_MAX_CONVOLUTION_WIDTH_EXT

OpenGLTokens

GL_MAX_CUBE_MAP_TEXTURE_SIZE

OpenGLTokens

GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB

OpenGLTokens

GL_MAX_CUBE_MAP_TEXTURE_SIZE_EXT

OpenGLTokens

GL_MAX_DEBUG_LOGGED_MESSAGES_ARB

OpenGLTokens

GL_MAX_DEBUG_MESSAGE_LENGTH_ARB

OpenGLTokens

GL_MAX_DEPTH_TEXTURE_SAMPLES

OpenGLTokens

GL_MAX_DRAW_BUFFERS

OpenGLTokens

GL_MAX_DRAW_BUFFERS_ARB

OpenGLTokens

GL_MAX_DRAW_BUFFERS_ATI

OpenGLTokens

GL_MAX_DUAL_SOURCE_DRAW_BUFFERS

OpenGLTokens

GL_MAX_ELEMENTS_INDICES

OpenGLTokens

GL_MAX_ELEMENTS_INDICES_EXT

OpenGLTokens

GL_MAX_ELEMENTS_VERTICES

OpenGLTokens

GL_MAX_ELEMENTS_VERTICES_EXT

OpenGLTokens

GL_MAX_EVAL_ORDER

OpenGLTokens

GL_MAX_EXT

OpenGLTokens

GL_MAX_FRAGMENT_BINDABLE_UNIFORMS_EXT

OpenGLTokens

GL_MAX_FRAGMENT_INPUT_COMPONENTS

OpenGLTokens

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET

OpenGLTokens

GL_MAX_FRAGMENT_UNIFORM_BLOCKS

OpenGLTokens

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB

OpenGLTokens

GL_MAX_FRAGMENT_UNIFORM_VECTORS

OpenGLTokens

GL_MAX_GENERAL_COMBINERS_NV

OpenGLTokens

GL_MAX_GEOMETRY_BINDABLE_UNIFORMS_EXT

OpenGLTokens

GL_MAX_GEOMETRY_INPUT_COMPONENTS

OpenGLTokens

GL_MAX_GEOMETRY_OUTPUT_COMPONENTS

OpenGLTokens

GL_MAX_GEOMETRY_OUTPUT_VERTICES

OpenGLTokens

GL_MAX_GEOMETRY_OUTPUT_VERTICES_ARB

OpenGLTokens

GL_MAX_GEOMETRY_OUTPUT_VERTICES_EXT

OpenGLTokens

GL_MAX_GEOMETRY_SHADER_INVOCATIONS

OpenGLTokens

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS

OpenGLTokens

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_ARB

OpenGLTokens

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_EXT

OpenGLTokens

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS

OpenGLTokens

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_ARB

OpenGLTokens

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_EXT

OpenGLTokens

GL_MAX_GEOMETRY_UNIFORM_BLOCKS

OpenGLTokens

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_ARB

OpenGLTokens

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_EXT

OpenGLTokens

GL_MAX_GEOMETRY_VARYING_COMPONENTS_ARB

OpenGLTokens

GL_MAX_GEOMETRY_VARYING_COMPONENTS_EXT

OpenGLTokens

GL_MAX_INTEGER_SAMPLES

OpenGLTokens

GL_MAX_LIGHTS

OpenGLTokens

GL_MAX_LIST_NESTING

OpenGLTokens

GL_MAX_MATRIX_PALETTE_STACK_DEPTH_ARB

OpenGLTokens

GL_MAX_MODELVIEW_STACK_DEPTH

OpenGLTokens

GL_MAX_NAME_STACK_DEPTH

OpenGLTokens

GL_MAX_PALETTE_MATRICES_ARB

OpenGLTokens

GL_MAX_PATCH_VERTICES

OpenGLTokens

GL_MAX_PIXEL_MAP_TABLE

OpenGLTokens

GL_MAX_PROGRAM_ADDRESS_REGISTERS_ARB

OpenGLTokens

GL_MAX_PROGRAM_ALU_INSTRUCTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_ATTRIBS_ARB

OpenGLTokens

GL_MAX_PROGRAM_ENV_PARAMETERS_ARB

OpenGLTokens

GL_MAX_PROGRAM_INSTRUCTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_LOCAL_PARAMETERS_ARB

OpenGLTokens

GL_MAX_PROGRAM_MATRICES_ARB

OpenGLTokens

GL_MAX_PROGRAM_MATRIX_STACK_DEPTH_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_ATTRIBS_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_INSTRUCTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_PARAMETERS_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_TEMPORARIES_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_OUTPUT_VERTICES_NV

OpenGLTokens

GL_MAX_PROGRAM_PARAMETERS_ARB

OpenGLTokens

GL_MAX_PROGRAM_TEMPORARIES_ARB

OpenGLTokens

GL_MAX_PROGRAM_TEXEL_OFFSET

OpenGLTokens

GL_MAX_PROGRAM_TEXEL_OFFSET_EXT

OpenGLTokens

GL_MAX_PROGRAM_TEXTURE_GATHER_COMPONENTS_ARB

OpenGLTokens

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET

OpenGLTokens

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_ARB

OpenGLTokens

GL_MAX_PROGRAM_TEX_INDIRECTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_TEX_INSTRUCTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_TOTAL_OUTPUT_COMPONENTS_NV

OpenGLTokens

GL_MAX_PROJECTION_STACK_DEPTH

OpenGLTokens

GL_MAX_RECTANGLE_TEXTURE_SIZE

OpenGLTokens

GL_MAX_RECTANGLE_TEXTURE_SIZE_ARB

OpenGLTokens

GL_MAX_RECTANGLE_TEXTURE_SIZE_EXT

OpenGLTokens

GL_MAX_RECTANGLE_TEXTURE_SIZE_NV

OpenGLTokens

GL_MAX_RENDERBUFFER_SIZE

OpenGLTokens

GL_MAX_RENDERBUFFER_SIZE_EXT

OpenGLTokens

GL_MAX_SAMPLES

OpenGLTokens

GL_MAX_SAMPLES_EXT

OpenGLTokens

GL_MAX_SAMPLE_MASK_WORDS

OpenGLTokens

GL_MAX_SERVER_WAIT_TIMEOUT

OpenGLTokens

GL_MAX_SHADER_BUFFER_ADDRESS_NV

OpenGLTokens

GL_MAX_SHININESS_NV

OpenGLTokens

GL_MAX_SPOT_EXPONENT_NV

OpenGLTokens

GL_MAX_SUBROUTINES

OpenGLTokens

GL_MAX_SUBROUTINE_UNIFORM_LOCATIONS

OpenGLTokens

GL_MAX_TESS_CONTROL_INPUT_COMPONENTS

OpenGLTokens

GL_MAX_TESS_CONTROL_OUTPUT_COMPONENTS

OpenGLTokens

GL_MAX_TESS_CONTROL_TEXTURE_IMAGE_UNITS

OpenGLTokens

GL_MAX_TESS_CONTROL_TOTAL_OUTPUT_COMPONENTS

OpenGLTokens

GL_MAX_TESS_CONTROL_UNIFORM_BLOCKS

OpenGLTokens

GL_MAX_TESS_CONTROL_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_TESS_EVALUATION_INPUT_COMPONENTS

OpenGLTokens

GL_MAX_TESS_EVALUATION_OUTPUT_COMPONENTS

OpenGLTokens

GL_MAX_TESS_EVALUATION_TEXTURE_IMAGE_UNITS

OpenGLTokens

GL_MAX_TESS_EVALUATION_UNIFORM_BLOCKS

OpenGLTokens

GL_MAX_TESS_EVALUATION_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_TESS_GEN_LEVEL

OpenGLTokens

GL_MAX_TESS_PATCH_COMPONENTS

OpenGLTokens

GL_MAX_TEXTURE_BUFFER_SIZE

OpenGLTokens

GL_MAX_TEXTURE_BUFFER_SIZE_ARB

OpenGLTokens

GL_MAX_TEXTURE_BUFFER_SIZE_EXT

OpenGLTokens

GL_MAX_TEXTURE_COORDS

OpenGLTokens

GL_MAX_TEXTURE_COORDS_ARB

OpenGLTokens

GL_MAX_TEXTURE_IMAGE_UNITS

OpenGLTokens

GL_MAX_TEXTURE_IMAGE_UNITS_ARB

OpenGLTokens

GL_MAX_TEXTURE_LOD_BIAS

OpenGLTokens

GL_MAX_TEXTURE_LOD_BIAS_EXT

OpenGLTokens

GL_MAX_TEXTURE_MAX_ANISOTROPY_EXT

OpenGLTokens

GL_MAX_TEXTURE_SIZE

OpenGLTokens

GL_MAX_TEXTURE_STACK_DEPTH

OpenGLTokens

GL_MAX_TEXTURE_UNITS

OpenGLTokens

GL_MAX_TEXTURE_UNITS_ARB

OpenGLTokens

GL_MAX_TRACK_MATRICES_NV

OpenGLTokens

GL_MAX_TRACK_MATRIX_STACK_DEPTH_NV

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_BUFFERS

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_EXT

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_NV

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_EXT

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_NV

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_EXT

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_NV

OpenGLTokens

GL_MAX_UNIFORM_BLOCK_SIZE

OpenGLTokens

GL_MAX_UNIFORM_BUFFER_BINDINGS

OpenGLTokens

GL_MAX_VARYING_COMPONENTS

OpenGLTokens

GL_MAX_VARYING_COMPONENTS_EXT

OpenGLTokens

GL_MAX_VARYING_FLOATS

OpenGLTokens

GL_MAX_VARYING_FLOATS_ARB

OpenGLTokens

GL_MAX_VARYING_VECTORS

OpenGLTokens

GL_MAX_VERTEX_ARRAY_RANGE_ELEMENT_NV

OpenGLTokens

GL_MAX_VERTEX_ATTRIBS

OpenGLTokens

GL_MAX_VERTEX_ATTRIBS_ARB

OpenGLTokens

GL_MAX_VERTEX_BINDABLE_UNIFORMS_EXT

OpenGLTokens

GL_MAX_VERTEX_OUTPUT_COMPONENTS

OpenGLTokens

GL_MAX_VERTEX_STREAMS

OpenGLTokens

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS

OpenGLTokens

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB

OpenGLTokens

GL_MAX_VERTEX_UNIFORM_BLOCKS

OpenGLTokens

GL_MAX_VERTEX_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB

OpenGLTokens

GL_MAX_VERTEX_UNIFORM_VECTORS

OpenGLTokens

GL_MAX_VERTEX_UNITS_ARB

OpenGLTokens

GL_MAX_VERTEX_VARYING_COMPONENTS_ARB

OpenGLTokens

GL_MAX_VERTEX_VARYING_COMPONENTS_EXT

OpenGLTokens

GL_MAX_VIEWPORTS

OpenGLTokens

GL_MAX_VIEWPORT_DIMS

OpenGLTokens

GL_MEDIUM_FLOAT

OpenGLTokens

GL_MEDIUM_INT

OpenGLTokens

GL_MIN

OpenGLTokens

GL_MINMAX

OpenGLTokens

GL_MINMAX_EXT

OpenGLTokens

GL_MINMAX_FORMAT

OpenGLTokens

GL_MINMAX_FORMAT_EXT

OpenGLTokens

GL_MINMAX_SINK

OpenGLTokens

GL_MINMAX_SINK_EXT

OpenGLTokens

GL_MINOR_VERSION

OpenGLTokens

GL_MIN_EXT

OpenGLTokens

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET

OpenGLTokens

GL_MIN_PROGRAM_TEXEL_OFFSET

OpenGLTokens

GL_MIN_PROGRAM_TEXEL_OFFSET_EXT

OpenGLTokens

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET

OpenGLTokens

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_ARB

OpenGLTokens

GL_MIN_SAMPLE_SHADING_VALUE

OpenGLTokens

GL_MIN_SAMPLE_SHADING_VALUE_ARB

OpenGLTokens

GL_MIRRORED_REPEAT

OpenGLTokens

GL_MIRRORED_REPEAT_ARB

OpenGLTokens

GL_MIRROR_CLAMP_ATI

OpenGLTokens

GL_MIRROR_CLAMP_EXT

OpenGLTokens

GL_MIRROR_CLAMP_TO_BORDER_EXT

OpenGLTokens

GL_MIRROR_CLAMP_TO_EDGE_ATI

OpenGLTokens

GL_MIRROR_CLAMP_TO_EDGE_EXT

OpenGLTokens

GL_MITER_REVERT_NV

OpenGLTokens

GL_MITER_TRUNCATE_NV

OpenGLTokens

GL_MODELVIEW

OpenGLTokens

GL_MODELVIEW0_ARB

OpenGLTokens

GL_MODELVIEW10_ARB

OpenGLTokens

GL_MODELVIEW11_ARB

OpenGLTokens

GL_MODELVIEW12_ARB

OpenGLTokens

GL_MODELVIEW13_ARB

OpenGLTokens

GL_MODELVIEW14_ARB

OpenGLTokens

GL_MODELVIEW15_ARB

OpenGLTokens

GL_MODELVIEW16_ARB

OpenGLTokens

GL_MODELVIEW17_ARB

OpenGLTokens

GL_MODELVIEW18_ARB

OpenGLTokens

GL_MODELVIEW19_ARB

OpenGLTokens

GL_MODELVIEW1_ARB

OpenGLTokens

GL_MODELVIEW20_ARB

OpenGLTokens

GL_MODELVIEW21_ARB

OpenGLTokens

GL_MODELVIEW22_ARB

OpenGLTokens

GL_MODELVIEW23_ARB

OpenGLTokens

GL_MODELVIEW24_ARB

OpenGLTokens

GL_MODELVIEW25_ARB

OpenGLTokens

GL_MODELVIEW26_ARB

OpenGLTokens

GL_MODELVIEW27_ARB

OpenGLTokens

GL_MODELVIEW28_ARB

OpenGLTokens

GL_MODELVIEW29_ARB

OpenGLTokens

GL_MODELVIEW2_ARB

OpenGLTokens

GL_MODELVIEW30_ARB

OpenGLTokens

GL_MODELVIEW31_ARB

OpenGLTokens

GL_MODELVIEW3_ARB

OpenGLTokens

GL_MODELVIEW4_ARB

OpenGLTokens

GL_MODELVIEW5_ARB

OpenGLTokens

GL_MODELVIEW6_ARB

OpenGLTokens

GL_MODELVIEW7_ARB

OpenGLTokens

GL_MODELVIEW8_ARB

OpenGLTokens

GL_MODELVIEW9_ARB

OpenGLTokens

GL_MODELVIEW_MATRIX

OpenGLTokens

GL_MODELVIEW_PROJECTION_NV

OpenGLTokens

GL_MODELVIEW_STACK_DEPTH

OpenGLTokens

GL_MODULATE

OpenGLTokens

GL_MOVE_TO_CONTINUES_NV

OpenGLTokens

GL_MOVE_TO_NV

OpenGLTokens

GL_MOVE_TO_RESETS_NV

OpenGLTokens

GL_MULT

OpenGLTokens

GL_MULTISAMPLE

OpenGLTokens

GL_MULTISAMPLE_3DFX

OpenGLTokens

GL_MULTISAMPLE_ARB

OpenGLTokens

GL_MULTISAMPLE_BIT

OpenGLTokens

GL_MULTISAMPLE_BIT_3DFX

OpenGLTokens

GL_MULTISAMPLE_BIT_ARB

OpenGLTokens

GL_MULTISAMPLE_EXT

OpenGLTokens

GL_MULTISAMPLE_FILTER_HINT_NV

OpenGLTokens

GL_MULTISAMPLE_SGIS

OpenGLTokens

GL_N3F_V3F

OpenGLTokens

GL_NAME_STACK_DEPTH

OpenGLTokens

GL_NAND

OpenGLTokens

GL_NEAREST

OpenGLTokens

GL_NEAREST_MIPMAP_LINEAR

OpenGLTokens

GL_NEAREST_MIPMAP_NEAREST

OpenGLTokens

GL_NEVER

OpenGLTokens

GL_NICEST

OpenGLTokens

GL_NONE

OpenGLTokens

GL_NOOP

OpenGLTokens

GL_NOR

OpenGLTokens

GL_NORMALIZE

OpenGLTokens

GL_NORMAL_ARRAY

OpenGLTokens

GL_NORMAL_ARRAY_ADDRESS_NV

OpenGLTokens

GL_NORMAL_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_NORMAL_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_NORMAL_ARRAY_LENGTH_NV

OpenGLTokens

GL_NORMAL_ARRAY_POINTER

OpenGLTokens

GL_NORMAL_ARRAY_STRIDE

OpenGLTokens

GL_NORMAL_ARRAY_TYPE

OpenGLTokens

GL_NORMAL_MAP

OpenGLTokens

GL_NORMAL_MAP_ARB

OpenGLTokens

GL_NORMAL_MAP_EXT

OpenGLTokens

GL_NORMAL_MAP_NV

OpenGLTokens

GL_NOTEQUAL

OpenGLTokens

GL_NO_ERROR

OpenGLTokens

GL_NO_RESET_NOTIFICATION_ARB

OpenGLTokens

GL_NUM_COMPATIBLE_SUBROUTINES

OpenGLTokens

GL_NUM_COMPRESSED_TEXTURE_FORMATS

OpenGLTokens

GL_NUM_COMPRESSED_TEXTURE_FORMATS_ARB

OpenGLTokens

GL_NUM_EXTENSIONS

OpenGLTokens

GL_NUM_GENERAL_COMBINERS_NV

OpenGLTokens

GL_NUM_PROGRAM_BINARY_FORMATS

OpenGLTokens

GL_NUM_SHADER_BINARY_FORMATS

OpenGLTokens

GL_OBJECT_ACTIVE_ATTRIBUTES_ARB

OpenGLTokens

GL_OBJECT_ACTIVE_ATTRIBUTE_MAX_LENGTH_ARB

OpenGLTokens

GL_OBJECT_ACTIVE_UNIFORMS_ARB

OpenGLTokens

GL_OBJECT_ACTIVE_UNIFORM_MAX_LENGTH_ARB

OpenGLTokens

GL_OBJECT_ATTACHED_OBJECTS_ARB

OpenGLTokens

GL_OBJECT_COMPILE_STATUS_ARB

OpenGLTokens

GL_OBJECT_DELETE_STATUS_ARB

OpenGLTokens

GL_OBJECT_INFO_LOG_LENGTH_ARB

OpenGLTokens

GL_OBJECT_LINEAR

OpenGLTokens

GL_OBJECT_LINK_STATUS_ARB

OpenGLTokens

GL_OBJECT_PLANE

OpenGLTokens

GL_OBJECT_SHADER_SOURCE_LENGTH_ARB

OpenGLTokens

GL_OBJECT_SUBTYPE_ARB

OpenGLTokens

GL_OBJECT_TYPE

OpenGLTokens

GL_OBJECT_TYPE_ARB

OpenGLTokens

GL_OBJECT_VALIDATE_STATUS_ARB

OpenGLTokens

GL_OCCLUSION_TEST_HP

OpenGLTokens

GL_OCCLUSION_TEST_RESULT_HP

OpenGLTokens

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_2D_NV

OpenGLTokens

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_RECTANGLE_NV

OpenGLTokens

GL_OFFSET_HILO_TEXTURE_2D_NV

OpenGLTokens

GL_OFFSET_HILO_TEXTURE_RECTANGLE_NV

OpenGLTokens

GL_OFFSET_PROJECTIVE_TEXTURE_2D_NV

OpenGLTokens

GL_OFFSET_PROJECTIVE_TEXTURE_2D_SCALE_NV

OpenGLTokens

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_NV

OpenGLTokens

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_SCALE_NV

OpenGLTokens

GL_OFFSET_TEXTURE_2D_BIAS_NV

OpenGLTokens

GL_OFFSET_TEXTURE_2D_MATRIX_NV

OpenGLTokens

GL_OFFSET_TEXTURE_2D_NV

OpenGLTokens

GL_OFFSET_TEXTURE_2D_SCALE_NV

OpenGLTokens

GL_OFFSET_TEXTURE_BIAS_NV

OpenGLTokens

GL_OFFSET_TEXTURE_MATRIX_NV

OpenGLTokens

GL_OFFSET_TEXTURE_RECTANGLE_NV

OpenGLTokens

GL_OFFSET_TEXTURE_RECTANGLE_SCALE_NV

OpenGLTokens

GL_OFFSET_TEXTURE_SCALE_NV

OpenGLTokens

GL_ONE

OpenGLTokens

GL_ONE_MINUS_CONSTANT_ALPHA

OpenGLTokens

GL_ONE_MINUS_CONSTANT_ALPHA_EXT

OpenGLTokens

GL_ONE_MINUS_CONSTANT_COLOR

OpenGLTokens

GL_ONE_MINUS_CONSTANT_COLOR_EXT

OpenGLTokens

GL_ONE_MINUS_DST_ALPHA

OpenGLTokens

GL_ONE_MINUS_DST_COLOR

OpenGLTokens

GL_ONE_MINUS_SRC1_ALPHA

OpenGLTokens

GL_ONE_MINUS_SRC1_COLOR

OpenGLTokens

GL_ONE_MINUS_SRC_ALPHA

OpenGLTokens

GL_ONE_MINUS_SRC_COLOR

OpenGLTokens

GL_OPERAND0_ALPHA

OpenGLTokens

GL_OPERAND0_ALPHA_ARB

OpenGLTokens

GL_OPERAND0_ALPHA_EXT

OpenGLTokens

GL_OPERAND0_RGB

OpenGLTokens

GL_OPERAND0_RGB_ARB

OpenGLTokens

GL_OPERAND0_RGB_EXT

OpenGLTokens

GL_OPERAND1_ALPHA

OpenGLTokens

GL_OPERAND1_ALPHA_ARB

OpenGLTokens

GL_OPERAND1_ALPHA_EXT

OpenGLTokens

GL_OPERAND1_RGB

OpenGLTokens

GL_OPERAND1_RGB_ARB

OpenGLTokens

GL_OPERAND1_RGB_EXT

OpenGLTokens

GL_OPERAND2_ALPHA

OpenGLTokens

GL_OPERAND2_ALPHA_ARB

OpenGLTokens

GL_OPERAND2_ALPHA_EXT

OpenGLTokens

GL_OPERAND2_RGB

OpenGLTokens

GL_OPERAND2_RGB_ARB

OpenGLTokens

GL_OPERAND2_RGB_EXT

OpenGLTokens

GL_OPERAND3_ALPHA_EXT

OpenGLTokens

GL_OPERAND3_ALPHA_NV

OpenGLTokens

GL_OPERAND3_RGB_EXT

OpenGLTokens

GL_OPERAND3_RGB_NV

OpenGLTokens

GL_OPERAND4_ALPHA_EXT

OpenGLTokens

GL_OPERAND4_RGB_EXT

OpenGLTokens

GL_OPERAND5_ALPHA_EXT

OpenGLTokens

GL_OPERAND5_RGB_EXT

OpenGLTokens

GL_OPERAND6_ALPHA_EXT

OpenGLTokens

GL_OPERAND6_RGB_EXT

OpenGLTokens

GL_OPERAND7_ALPHA_EXT

OpenGLTokens

GL_OPERAND7_RGB_EXT

OpenGLTokens

GL_OR

OpenGLTokens

GL_ORDER

OpenGLTokens

GL_OR_INVERTED

OpenGLTokens

GL_OR_REVERSE

OpenGLTokens

GL_OUT_OF_MEMORY

OpenGLTokens

GL_PACK_ALIGNMENT

OpenGLTokens

GL_PACK_IMAGE_HEIGHT

OpenGLTokens

GL_PACK_IMAGE_HEIGHT_EXT

OpenGLTokens

GL_PACK_LSB_FIRST

OpenGLTokens

GL_PACK_ROW_LENGTH

OpenGLTokens

GL_PACK_SKIP_IMAGES

OpenGLTokens

GL_PACK_SKIP_IMAGES_EXT

OpenGLTokens

GL_PACK_SKIP_PIXELS

OpenGLTokens

GL_PACK_SKIP_ROWS

OpenGLTokens

GL_PACK_SWAP_BYTES

OpenGLTokens

GL_PASS_THROUGH_NV

OpenGLTokens

GL_PASS_THROUGH_TOKEN

OpenGLTokens

GL_PATCHES

OpenGLTokens

GL_PATCH_DEFAULT_INNER_LEVEL

OpenGLTokens

GL_PATCH_DEFAULT_OUTER_LEVEL

OpenGLTokens

GL_PATCH_VERTICES

OpenGLTokens

GL_PATH_CLIENT_LENGTH_NV

OpenGLTokens

GL_PATH_COMMAND_COUNT_NV

OpenGLTokens

GL_PATH_COMPUTED_LENGTH_NV

OpenGLTokens

GL_PATH_COORD_COUNT_NV

OpenGLTokens

GL_PATH_COVER_DEPTH_FUNC_NV

OpenGLTokens

GL_PATH_DASH_ARRAY_COUNT_NV

OpenGLTokens

GL_PATH_DASH_CAPS_NV

OpenGLTokens

GL_PATH_DASH_OFFSET_NV

OpenGLTokens

GL_PATH_DASH_OFFSET_RESET_NV

OpenGLTokens

GL_PATH_END_CAPS_NV

OpenGLTokens

GL_PATH_ERROR_POSITION_NV

OpenGLTokens

GL_PATH_FILL_BOUNDING_BOX_NV

OpenGLTokens

GL_PATH_FILL_COVER_MODE_NV

OpenGLTokens

GL_PATH_FILL_MASK_NV

OpenGLTokens

GL_PATH_FILL_MODE_NV

OpenGLTokens

GL_PATH_FOG_GEN_MODE_NV

OpenGLTokens

GL_PATH_FORMAT_PS_NV

OpenGLTokens

GL_PATH_FORMAT_SVG_NV

OpenGLTokens

GL_PATH_GEN_COEFF_NV

OpenGLTokens

GL_PATH_GEN_COLOR_FORMAT_NV

OpenGLTokens

GL_PATH_GEN_COMPONENTS_NV

OpenGLTokens

GL_PATH_GEN_MODE_NV

OpenGLTokens

GL_PATH_INITIAL_DASH_CAP_NV

OpenGLTokens

GL_PATH_INITIAL_END_CAP_NV

OpenGLTokens

GL_PATH_JOIN_STYLE_NV

OpenGLTokens

GL_PATH_MITER_LIMIT_NV

OpenGLTokens

GL_PATH_OBJECT_BOUNDING_BOX_NV

OpenGLTokens

GL_PATH_SAMPLE_QUALITY_NV

OpenGLTokens

GL_PATH_STENCIL_DEPTH_OFFSET_FACTOR_NV

OpenGLTokens

GL_PATH_STENCIL_DEPTH_OFFSET_UNITS_NV

OpenGLTokens

GL_PATH_STENCIL_FUNC_NV

OpenGLTokens

GL_PATH_STENCIL_REF_NV

OpenGLTokens

GL_PATH_STENCIL_VALUE_MASK_NV

OpenGLTokens

GL_PATH_STROKE_BOUNDING_BOX_NV

OpenGLTokens

GL_PATH_STROKE_COVER_MODE_NV

OpenGLTokens

GL_PATH_STROKE_MASK_NV

OpenGLTokens

GL_PATH_STROKE_WIDTH_NV

OpenGLTokens

GL_PATH_TERMINAL_DASH_CAP_NV

OpenGLTokens

GL_PATH_TERMINAL_END_CAP_NV

OpenGLTokens

GL_PERSPECTIVE_CORRECTION_HINT

OpenGLTokens

GL_PIXEL_COUNTER_BITS_NV

OpenGLTokens

GL_PIXEL_COUNT_AVAILABLE_NV

OpenGLTokens

GL_PIXEL_COUNT_NV

OpenGLTokens

GL_PIXEL_MAP_A_TO_A

OpenGLTokens

GL_PIXEL_MAP_A_TO_A_SIZE

OpenGLTokens

GL_PIXEL_MAP_B_TO_B

OpenGLTokens

GL_PIXEL_MAP_B_TO_B_SIZE

OpenGLTokens

GL_PIXEL_MAP_G_TO_G

OpenGLTokens

GL_PIXEL_MAP_G_TO_G_SIZE

OpenGLTokens

GL_PIXEL_MAP_I_TO_A

OpenGLTokens

GL_PIXEL_MAP_I_TO_A_SIZE

OpenGLTokens

GL_PIXEL_MAP_I_TO_B

OpenGLTokens

GL_PIXEL_MAP_I_TO_B_SIZE

OpenGLTokens

GL_PIXEL_MAP_I_TO_G

OpenGLTokens

GL_PIXEL_MAP_I_TO_G_SIZE

OpenGLTokens

GL_PIXEL_MAP_I_TO_I

OpenGLTokens

GL_PIXEL_MAP_I_TO_I_SIZE

OpenGLTokens

GL_PIXEL_MAP_I_TO_R

OpenGLTokens

GL_PIXEL_MAP_I_TO_R_SIZE

OpenGLTokens

GL_PIXEL_MAP_R_TO_R

OpenGLTokens

GL_PIXEL_MAP_R_TO_R_SIZE

OpenGLTokens

GL_PIXEL_MAP_S_TO_S

OpenGLTokens

GL_PIXEL_MAP_S_TO_S_SIZE

OpenGLTokens

GL_PIXEL_MODE_BIT

OpenGLTokens

GL_PIXEL_PACK_BUFFER

OpenGLTokens

GL_PIXEL_PACK_BUFFER_ARB

OpenGLTokens

GL_PIXEL_PACK_BUFFER_BINDING

OpenGLTokens

GL_PIXEL_PACK_BUFFER_BINDING_ARB

OpenGLTokens

GL_PIXEL_PACK_BUFFER_BINDING_EXT

OpenGLTokens

GL_PIXEL_PACK_BUFFER_EXT

OpenGLTokens

GL_PIXEL_UNPACK_BUFFER

OpenGLTokens

GL_PIXEL_UNPACK_BUFFER_ARB

OpenGLTokens

GL_PIXEL_UNPACK_BUFFER_BINDING

OpenGLTokens

GL_PIXEL_UNPACK_BUFFER_BINDING_ARB

OpenGLTokens

GL_PIXEL_UNPACK_BUFFER_BINDING_EXT

OpenGLTokens

GL_PIXEL_UNPACK_BUFFER_EXT

OpenGLTokens

GL_POINT

OpenGLTokens

GL_POINTS

OpenGLTokens

GL_POINT_BIT

OpenGLTokens

GL_POINT_DISTANCE_ATTENUATION

OpenGLTokens

GL_POINT_FADE_THRESHOLD_SIZE

OpenGLTokens

GL_POINT_FADE_THRESHOLD_SIZE_ARB

OpenGLTokens

GL_POINT_SIZE

OpenGLTokens

GL_POINT_SIZE_GRANULARITY

OpenGLTokens

GL_POINT_SIZE_MAX

OpenGLTokens

GL_POINT_SIZE_MAX_ARB

OpenGLTokens

GL_POINT_SIZE_MIN

OpenGLTokens

GL_POINT_SIZE_MIN_ARB

OpenGLTokens

GL_POINT_SIZE_RANGE

OpenGLTokens

GL_POINT_SMOOTH

OpenGLTokens

GL_POINT_SMOOTH_HINT

OpenGLTokens

GL_POINT_SPRITE

OpenGLTokens

GL_POINT_SPRITE_ARB

OpenGLTokens

GL_POINT_SPRITE_COORD_ORIGIN

OpenGLTokens

GL_POINT_SPRITE_NV

OpenGLTokens

GL_POINT_SPRITE_R_MODE_NV

OpenGLTokens

GL_POINT_TOKEN

OpenGLTokens

GL_POLYGON

OpenGLTokens

GL_POLYGON_BIT

OpenGLTokens

GL_POLYGON_MODE

OpenGLTokens

GL_POLYGON_OFFSET_BIAS_EXT

OpenGLTokens

GL_POLYGON_OFFSET_EXT

OpenGLTokens

GL_POLYGON_OFFSET_FACTOR

OpenGLTokens

GL_POLYGON_OFFSET_FACTOR_EXT

OpenGLTokens

GL_POLYGON_OFFSET_FILL

OpenGLTokens

GL_POLYGON_OFFSET_LINE

OpenGLTokens

GL_POLYGON_OFFSET_POINT

OpenGLTokens

GL_POLYGON_OFFSET_UNITS

OpenGLTokens

GL_POLYGON_SMOOTH

OpenGLTokens

GL_POLYGON_SMOOTH_HINT

OpenGLTokens

GL_POLYGON_STIPPLE

OpenGLTokens

GL_POLYGON_STIPPLE_BIT

OpenGLTokens

GL_POLYGON_TOKEN

OpenGLTokens

GL_POSITION

OpenGLTokens

GL_POST_COLOR_MATRIX_ALPHA_BIAS

OpenGLTokens

GL_POST_COLOR_MATRIX_ALPHA_BIAS_SGI

OpenGLTokens

GL_POST_COLOR_MATRIX_ALPHA_SCALE

OpenGLTokens

GL_POST_COLOR_MATRIX_ALPHA_SCALE_SGI

OpenGLTokens

GL_POST_COLOR_MATRIX_BLUE_BIAS

OpenGLTokens

GL_POST_COLOR_MATRIX_BLUE_BIAS_SGI

OpenGLTokens

GL_POST_COLOR_MATRIX_BLUE_SCALE

OpenGLTokens

GL_POST_COLOR_MATRIX_BLUE_SCALE_SGI

OpenGLTokens

GL_POST_COLOR_MATRIX_COLOR_TABLE

OpenGLTokens

GL_POST_COLOR_MATRIX_GREEN_BIAS

OpenGLTokens

GL_POST_COLOR_MATRIX_GREEN_BIAS_SGI

OpenGLTokens

GL_POST_COLOR_MATRIX_GREEN_SCALE

OpenGLTokens

GL_POST_COLOR_MATRIX_GREEN_SCALE_SGI

OpenGLTokens

GL_POST_COLOR_MATRIX_RED_BIAS

OpenGLTokens

GL_POST_COLOR_MATRIX_RED_BIAS_SGI

OpenGLTokens

GL_POST_COLOR_MATRIX_RED_SCALE

OpenGLTokens

GL_POST_COLOR_MATRIX_RED_SCALE_SGI

OpenGLTokens

GL_POST_CONVOLUTION_ALPHA_BIAS

OpenGLTokens

GL_POST_CONVOLUTION_ALPHA_BIAS_EXT

OpenGLTokens

GL_POST_CONVOLUTION_ALPHA_SCALE

OpenGLTokens

GL_POST_CONVOLUTION_ALPHA_SCALE_EXT

OpenGLTokens

GL_POST_CONVOLUTION_BLUE_BIAS

OpenGLTokens

GL_POST_CONVOLUTION_BLUE_BIAS_EXT

OpenGLTokens

GL_POST_CONVOLUTION_BLUE_SCALE

OpenGLTokens

GL_POST_CONVOLUTION_BLUE_SCALE_EXT

OpenGLTokens

GL_POST_CONVOLUTION_COLOR_TABLE

OpenGLTokens

GL_POST_CONVOLUTION_GREEN_BIAS

OpenGLTokens

GL_POST_CONVOLUTION_GREEN_BIAS_EXT

OpenGLTokens

GL_POST_CONVOLUTION_GREEN_SCALE

OpenGLTokens

GL_POST_CONVOLUTION_GREEN_SCALE_EXT

OpenGLTokens

GL_POST_CONVOLUTION_RED_BIAS

OpenGLTokens

GL_POST_CONVOLUTION_RED_BIAS_EXT

OpenGLTokens

GL_POST_CONVOLUTION_RED_SCALE

OpenGLTokens

GL_POST_CONVOLUTION_RED_SCALE_EXT

OpenGLTokens

GL_PREVIOUS

OpenGLTokens

GL_PREVIOUS_ARB

OpenGLTokens

GL_PREVIOUS_EXT

OpenGLTokens

GL_PREVIOUS_TEXTURE_INPUT_NV

OpenGLTokens

GL_PRIMARY_COLOR

OpenGLTokens

GL_PRIMARY_COLOR_ARB

OpenGLTokens

GL_PRIMARY_COLOR_EXT

OpenGLTokens

GL_PRIMARY_COLOR_NV

OpenGLTokens

GL_PRIMITIVES_GENERATED

OpenGLTokens

GL_PRIMITIVES_GENERATED_EXT

OpenGLTokens

GL_PRIMITIVES_GENERATED_NV

OpenGLTokens

GL_PRIMITIVE_ID_NV

OpenGLTokens

GL_PRIMITIVE_RESTART

OpenGLTokens

GL_PRIMITIVE_RESTART_INDEX

OpenGLTokens

GL_PRIMITIVE_RESTART_INDEX_NV

OpenGLTokens

GL_PRIMITIVE_RESTART_NV

OpenGLTokens

GL_PROGRAM_ADDRESS_REGISTERS_ARB

OpenGLTokens

GL_PROGRAM_ALU_INSTRUCTIONS_ARB

OpenGLTokens

GL_PROGRAM_ATTRIBS_ARB

OpenGLTokens

GL_PROGRAM_BINARY_FORMATS

OpenGLTokens

GL_PROGRAM_BINARY_LENGTH

OpenGLTokens

GL_PROGRAM_BINARY_RETRIEVABLE_HINT

OpenGLTokens

GL_PROGRAM_BINDING_ARB

OpenGLTokens

GL_PROGRAM_ERROR_POSITION_ARB

OpenGLTokens

GL_PROGRAM_ERROR_POSITION_NV

OpenGLTokens

GL_PROGRAM_ERROR_STRING_ARB

OpenGLTokens

GL_PROGRAM_FORMAT_ARB

OpenGLTokens

GL_PROGRAM_FORMAT_ASCII_ARB

OpenGLTokens

GL_PROGRAM_INSTRUCTIONS_ARB

OpenGLTokens

GL_PROGRAM_LENGTH_ARB

OpenGLTokens

GL_PROGRAM_LENGTH_NV

OpenGLTokens

GL_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB

OpenGLTokens

GL_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB

OpenGLTokens

GL_PROGRAM_NATIVE_ATTRIBS_ARB

OpenGLTokens

GL_PROGRAM_NATIVE_INSTRUCTIONS_ARB

OpenGLTokens

GL_PROGRAM_NATIVE_PARAMETERS_ARB

OpenGLTokens

GL_PROGRAM_NATIVE_TEMPORARIES_ARB

OpenGLTokens

GL_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB

OpenGLTokens

GL_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB

OpenGLTokens

GL_PROGRAM_OBJECT_ARB

OpenGLTokens

GL_PROGRAM_PARAMETERS_ARB

OpenGLTokens

GL_PROGRAM_PARAMETER_NV

OpenGLTokens

GL_PROGRAM_PIPELINE_BINDING

OpenGLTokens

GL_PROGRAM_POINT_SIZE

OpenGLTokens

GL_PROGRAM_POINT_SIZE_ARB

OpenGLTokens

GL_PROGRAM_POINT_SIZE_EXT

OpenGLTokens

GL_PROGRAM_RESIDENT_NV

OpenGLTokens

GL_PROGRAM_SEPARABLE

OpenGLTokens

GL_PROGRAM_STRING_ARB

OpenGLTokens

GL_PROGRAM_STRING_NV

OpenGLTokens

GL_PROGRAM_TARGET_NV

OpenGLTokens

GL_PROGRAM_TEMPORARIES_ARB

OpenGLTokens

GL_PROGRAM_TEX_INDIRECTIONS_ARB

OpenGLTokens

GL_PROGRAM_TEX_INSTRUCTIONS_ARB

OpenGLTokens

GL_PROGRAM_UNDER_NATIVE_LIMITS_ARB

OpenGLTokens

GL_PROJECTION

OpenGLTokens

GL_PROJECTION_MATRIX

OpenGLTokens

GL_PROJECTION_STACK_DEPTH

OpenGLTokens

GL_PROVOKING_VERTEX

OpenGLTokens

GL_PROXY_COLOR_TABLE

OpenGLTokens

GL_PROXY_HISTOGRAM

OpenGLTokens

GL_PROXY_HISTOGRAM_EXT

OpenGLTokens

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE

OpenGLTokens

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE

OpenGLTokens

GL_PROXY_TEXTURE_1D

OpenGLTokens

GL_PROXY_TEXTURE_1D_ARRAY

OpenGLTokens

GL_PROXY_TEXTURE_1D_ARRAY_EXT

OpenGLTokens

GL_PROXY_TEXTURE_1D_EXT

OpenGLTokens

GL_PROXY_TEXTURE_2D

OpenGLTokens

GL_PROXY_TEXTURE_2D_ARRAY

OpenGLTokens

GL_PROXY_TEXTURE_2D_ARRAY_EXT

OpenGLTokens

GL_PROXY_TEXTURE_2D_EXT

OpenGLTokens

GL_PROXY_TEXTURE_2D_MULTISAMPLE

OpenGLTokens

GL_PROXY_TEXTURE_2D_MULTISAMPLE_ARRAY

OpenGLTokens

GL_PROXY_TEXTURE_3D

OpenGLTokens

GL_PROXY_TEXTURE_3D_EXT

OpenGLTokens

GL_PROXY_TEXTURE_CUBE_MAP

OpenGLTokens

GL_PROXY_TEXTURE_CUBE_MAP_ARB

OpenGLTokens

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY

OpenGLTokens

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY_ARB

OpenGLTokens

GL_PROXY_TEXTURE_CUBE_MAP_EXT

OpenGLTokens

GL_PROXY_TEXTURE_RECTANGLE

OpenGLTokens

GL_PROXY_TEXTURE_RECTANGLE_ARB

OpenGLTokens

GL_PROXY_TEXTURE_RECTANGLE_EXT

OpenGLTokens

GL_PROXY_TEXTURE_RECTANGLE_NV

OpenGLTokens

GL_Q

OpenGLTokens

GL_QUADRATIC_ATTENUATION

OpenGLTokens

GL_QUADRATIC_CURVE_TO_NV

OpenGLTokens

GL_QUADS

OpenGLTokens

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION

OpenGLTokens

GL_QUAD_STRIP

OpenGLTokens

GL_QUERY_BY_REGION_NO_WAIT

OpenGLTokens

GL_QUERY_BY_REGION_NO_WAIT_NV

OpenGLTokens

GL_QUERY_BY_REGION_WAIT

OpenGLTokens

GL_QUERY_BY_REGION_WAIT_NV

OpenGLTokens

GL_QUERY_COUNTER_BITS

OpenGLTokens

GL_QUERY_COUNTER_BITS_ARB

OpenGLTokens

GL_QUERY_NO_WAIT

OpenGLTokens

GL_QUERY_NO_WAIT_NV

OpenGLTokens

GL_QUERY_RESULT

OpenGLTokens

GL_QUERY_RESULT_ARB

OpenGLTokens

GL_QUERY_RESULT_AVAILABLE

OpenGLTokens

GL_QUERY_RESULT_AVAILABLE_ARB

OpenGLTokens

GL_QUERY_WAIT

OpenGLTokens

GL_QUERY_WAIT_NV

OpenGLTokens

GL_R

OpenGLTokens

GL_R11F_G11F_B10F

OpenGLTokens

GL_R11F_G11F_B10F_EXT

OpenGLTokens

GL_R16

OpenGLTokens

GL_R16F

OpenGLTokens

GL_R16I

OpenGLTokens

GL_R16UI

OpenGLTokens

GL_R16_SNORM

OpenGLTokens

GL_R32F

OpenGLTokens

GL_R32I

OpenGLTokens

GL_R32UI

OpenGLTokens

GL_R3_G3_B2

OpenGLTokens

GL_R8

OpenGLTokens

GL_R8I

OpenGLTokens

GL_R8UI

OpenGLTokens

GL_R8_SNORM

OpenGLTokens

GL_RASTERIZER_DISCARD

OpenGLTokens

GL_RASTERIZER_DISCARD_EXT

OpenGLTokens

GL_RASTERIZER_DISCARD_NV

OpenGLTokens

GL_RASTER_POSITION_UNCLIPPED_IBM

OpenGLTokens

GL_READ_BUFFER

OpenGLTokens

GL_READ_FRAMEBUFFER

OpenGLTokens

GL_READ_FRAMEBUFFER_BINDING

OpenGLTokens

GL_READ_FRAMEBUFFER_BINDING_EXT

OpenGLTokens

GL_READ_FRAMEBUFFER_EXT

OpenGLTokens

GL_READ_ONLY

OpenGLTokens

GL_READ_ONLY_ARB

OpenGLTokens

GL_READ_WRITE

OpenGLTokens

GL_READ_WRITE_ARB

OpenGLTokens

GL_RED

OpenGLTokens

GL_REDUCE

OpenGLTokens

GL_REDUCE_EXT

OpenGLTokens

GL_RED_BIAS

OpenGLTokens

GL_RED_BITS

OpenGLTokens

GL_RED_INTEGER

OpenGLTokens

GL_RED_INTEGER_EXT

OpenGLTokens

GL_RED_SCALE

OpenGLTokens

GL_RED_SNORM

OpenGLTokens

GL_REFLECTION_MAP

OpenGLTokens

GL_REFLECTION_MAP_ARB

OpenGLTokens

GL_REFLECTION_MAP_EXT

OpenGLTokens

GL_REFLECTION_MAP_NV

OpenGLTokens

GL_REGISTER_COMBINERS_NV

OpenGLTokens

GL_RELATIVE_ARC_TO_NV

OpenGLTokens

GL_RELATIVE_CUBIC_CURVE_TO_NV

OpenGLTokens

GL_RELATIVE_HORIZONTAL_LINE_TO_NV

OpenGLTokens

GL_RELATIVE_LARGE_CCW_ARC_TO_NV

OpenGLTokens

GL_RELATIVE_LARGE_CW_ARC_TO_NV

OpenGLTokens

GL_RELATIVE_LINE_TO_NV

OpenGLTokens

GL_RELATIVE_MOVE_TO_NV

OpenGLTokens

GL_RELATIVE_QUADRATIC_CURVE_TO_NV

OpenGLTokens

GL_RELATIVE_SMALL_CCW_ARC_TO_NV

OpenGLTokens

GL_RELATIVE_SMALL_CW_ARC_TO_NV

OpenGLTokens

GL_RELATIVE_SMOOTH_CUBIC_CURVE_TO_NV

OpenGLTokens

GL_RELATIVE_SMOOTH_QUADRATIC_CURVE_TO_NV

OpenGLTokens

GL_RELATIVE_VERTICAL_LINE_TO_NV

OpenGLTokens

GL_RENDER

OpenGLTokens

GL_RENDERBUFFER

OpenGLTokens

GL_RENDERBUFFER_ALPHA_SIZE

OpenGLTokens

GL_RENDERBUFFER_ALPHA_SIZE_EXT

OpenGLTokens

GL_RENDERBUFFER_BINDING

OpenGLTokens

GL_RENDERBUFFER_BINDING_EXT

OpenGLTokens

GL_RENDERBUFFER_BLUE_SIZE

OpenGLTokens

GL_RENDERBUFFER_BLUE_SIZE_EXT

OpenGLTokens

GL_RENDERBUFFER_DEPTH_SIZE

OpenGLTokens

GL_RENDERBUFFER_DEPTH_SIZE_EXT

OpenGLTokens

GL_RENDERBUFFER_EXT

OpenGLTokens

GL_RENDERBUFFER_FREE_MEMORY_ATI

OpenGLTokens

GL_RENDERBUFFER_GREEN_SIZE

OpenGLTokens

GL_RENDERBUFFER_GREEN_SIZE_EXT

OpenGLTokens

GL_RENDERBUFFER_HEIGHT

OpenGLTokens

GL_RENDERBUFFER_HEIGHT_EXT

OpenGLTokens

GL_RENDERBUFFER_INTERNAL_FORMAT

OpenGLTokens

GL_RENDERBUFFER_INTERNAL_FORMAT_EXT

OpenGLTokens

GL_RENDERBUFFER_RED_SIZE

OpenGLTokens

GL_RENDERBUFFER_RED_SIZE_EXT

OpenGLTokens

GL_RENDERBUFFER_SAMPLES

OpenGLTokens

GL_RENDERBUFFER_SAMPLES_EXT

OpenGLTokens

GL_RENDERBUFFER_STENCIL_SIZE

OpenGLTokens

GL_RENDERBUFFER_STENCIL_SIZE_EXT

OpenGLTokens

GL_RENDERBUFFER_WIDTH

OpenGLTokens

GL_RENDERBUFFER_WIDTH_EXT

OpenGLTokens

GL_RENDERER

OpenGLTokens

GL_RENDER_MODE

OpenGLTokens

GL_REPEAT

OpenGLTokens

GL_REPLACE

OpenGLTokens

GL_REPLACE_EXT

OpenGLTokens

GL_REPLICATE_BORDER

OpenGLTokens

GL_RESCALE_NORMAL

OpenGLTokens

GL_RESCALE_NORMAL_EXT

OpenGLTokens

GL_RESET_NOTIFICATION_STRATEGY_ARB

OpenGLTokens

GL_RETURN

OpenGLTokens

GL_RG

OpenGLTokens

GL_RG16

OpenGLTokens

GL_RG16F

OpenGLTokens

GL_RG16I

OpenGLTokens

GL_RG16UI

OpenGLTokens

GL_RG16_SNORM

OpenGLTokens

GL_RG32F

OpenGLTokens

GL_RG32I

OpenGLTokens

GL_RG32UI

OpenGLTokens

GL_RG8

OpenGLTokens

GL_RG8I

OpenGLTokens

GL_RG8UI

OpenGLTokens

GL_RG8_SNORM

OpenGLTokens

GL_RGB

OpenGLTokens

GL_RGB10

OpenGLTokens

GL_RGB10_A2

OpenGLTokens

GL_RGB10_A2UI

OpenGLTokens

GL_RGB10_A2_EXT

OpenGLTokens

GL_RGB10_EXT

OpenGLTokens

GL_RGB12

OpenGLTokens

GL_RGB12_EXT

OpenGLTokens

GL_RGB16

OpenGLTokens

GL_RGB16F

OpenGLTokens

GL_RGB16F_ARB

OpenGLTokens

GL_RGB16I

OpenGLTokens

GL_RGB16I_EXT

OpenGLTokens

GL_RGB16UI

OpenGLTokens

GL_RGB16UI_EXT

OpenGLTokens

GL_RGB16_EXT

OpenGLTokens

GL_RGB16_SNORM

OpenGLTokens

GL_RGB2_EXT

OpenGLTokens

GL_RGB32F

OpenGLTokens

GL_RGB32F_ARB

OpenGLTokens

GL_RGB32I

OpenGLTokens

GL_RGB32I_EXT

OpenGLTokens

GL_RGB32UI

OpenGLTokens

GL_RGB32UI_EXT

OpenGLTokens

GL_RGB4

OpenGLTokens

GL_RGB4_EXT

OpenGLTokens

GL_RGB4_S3TC

OpenGLTokens

GL_RGB5

OpenGLTokens

GL_RGB5_A1

OpenGLTokens

GL_RGB5_A1_EXT

OpenGLTokens

GL_RGB5_EXT

OpenGLTokens

GL_RGB8

OpenGLTokens

GL_RGB8I

OpenGLTokens

GL_RGB8I_EXT

OpenGLTokens

GL_RGB8UI

OpenGLTokens

GL_RGB8UI_EXT

OpenGLTokens

GL_RGB8_EXT

OpenGLTokens

GL_RGB8_SNORM

OpenGLTokens

GL_RGB9_E5

OpenGLTokens

GL_RGB9_E5_EXT

OpenGLTokens

GL_RGBA

OpenGLTokens

GL_RGBA12

OpenGLTokens

GL_RGBA12_EXT

OpenGLTokens

GL_RGBA16

OpenGLTokens

GL_RGBA16F

OpenGLTokens

GL_RGBA16F_ARB

OpenGLTokens

GL_RGBA16I

OpenGLTokens

GL_RGBA16I_EXT

OpenGLTokens

GL_RGBA16UI

OpenGLTokens

GL_RGBA16UI_EXT

OpenGLTokens

GL_RGBA16_EXT

OpenGLTokens

GL_RGBA16_SNORM

OpenGLTokens

GL_RGBA2

OpenGLTokens

GL_RGBA2_EXT

OpenGLTokens

GL_RGBA32F

OpenGLTokens

GL_RGBA32F_ARB

OpenGLTokens

GL_RGBA32I

OpenGLTokens

GL_RGBA32I_EXT

OpenGLTokens

GL_RGBA32UI

OpenGLTokens

GL_RGBA32UI_EXT

OpenGLTokens

GL_RGBA4

OpenGLTokens

GL_RGBA4_DXT5_S3TC

OpenGLTokens

GL_RGBA4_EXT

OpenGLTokens

GL_RGBA4_S3TC

OpenGLTokens

GL_RGBA8

OpenGLTokens

GL_RGBA8I

OpenGLTokens

GL_RGBA8I_EXT

OpenGLTokens

GL_RGBA8UI

OpenGLTokens

GL_RGBA8UI_EXT

OpenGLTokens

GL_RGBA8_EXT

OpenGLTokens

GL_RGBA8_SNORM

OpenGLTokens

GL_RGBA_DXT5_S3TC

OpenGLTokens

GL_RGBA_FLOAT16_ATI

OpenGLTokens

GL_RGBA_FLOAT32_ATI

OpenGLTokens

GL_RGBA_FLOAT_MODE_ARB

OpenGLTokens

GL_RGBA_INTEGER

OpenGLTokens

GL_RGBA_INTEGER_EXT

OpenGLTokens

GL_RGBA_INTEGER_MODE_EXT

OpenGLTokens

GL_RGBA_MODE

OpenGLTokens

GL_RGBA_S3TC

OpenGLTokens

GL_RGBA_SIGNED_COMPONENTS_EXT

OpenGLTokens

GL_RGBA_SNORM

OpenGLTokens

GL_RGBA_UNSIGNED_DOT_PRODUCT_MAPPING_NV

OpenGLTokens

GL_RGB_FLOAT16_ATI

OpenGLTokens

GL_RGB_FLOAT32_ATI

OpenGLTokens

GL_RGB_INTEGER

OpenGLTokens

GL_RGB_INTEGER_EXT

OpenGLTokens

GL_RGB_S3TC

OpenGLTokens

GL_RGB_SCALE

OpenGLTokens

GL_RGB_SCALE_ARB

OpenGLTokens

GL_RGB_SCALE_EXT

OpenGLTokens

GL_RGB_SNORM

OpenGLTokens

GL_RG_INTEGER

OpenGLTokens

GL_RG_SNORM

OpenGLTokens

GL_RIGHT

OpenGLTokens

GL_ROUND_NV

OpenGLTokens

GL_S

OpenGLTokens

GL_SAMPLER_1D

OpenGLTokens

GL_SAMPLER_1D_ARB

OpenGLTokens

GL_SAMPLER_1D_ARRAY

OpenGLTokens

GL_SAMPLER_1D_ARRAY_EXT

OpenGLTokens

GL_SAMPLER_1D_ARRAY_SHADOW

OpenGLTokens

GL_SAMPLER_1D_ARRAY_SHADOW_EXT

OpenGLTokens

GL_SAMPLER_1D_SHADOW

OpenGLTokens

GL_SAMPLER_1D_SHADOW_ARB

OpenGLTokens

GL_SAMPLER_2D

OpenGLTokens

GL_SAMPLER_2D_ARB

OpenGLTokens

GL_SAMPLER_2D_ARRAY

OpenGLTokens

GL_SAMPLER_2D_ARRAY_EXT

OpenGLTokens

GL_SAMPLER_2D_ARRAY_SHADOW

OpenGLTokens

GL_SAMPLER_2D_ARRAY_SHADOW_EXT

OpenGLTokens

GL_SAMPLER_2D_MULTISAMPLE

OpenGLTokens

GL_SAMPLER_2D_MULTISAMPLE_ARRAY

OpenGLTokens

GL_SAMPLER_2D_RECT

OpenGLTokens

GL_SAMPLER_2D_RECT_ARB

OpenGLTokens

GL_SAMPLER_2D_RECT_SHADOW

OpenGLTokens

GL_SAMPLER_2D_RECT_SHADOW_ARB

OpenGLTokens

GL_SAMPLER_2D_SHADOW

OpenGLTokens

GL_SAMPLER_2D_SHADOW_ARB

OpenGLTokens

GL_SAMPLER_3D

OpenGLTokens

GL_SAMPLER_3D_ARB

OpenGLTokens

GL_SAMPLER_BINDING

OpenGLTokens

GL_SAMPLER_BUFFER

OpenGLTokens

GL_SAMPLER_BUFFER_AMD

OpenGLTokens

GL_SAMPLER_BUFFER_EXT

OpenGLTokens

GL_SAMPLER_CUBE

OpenGLTokens

GL_SAMPLER_CUBE_ARB

OpenGLTokens

GL_SAMPLER_CUBE_MAP_ARRAY

OpenGLTokens

GL_SAMPLER_CUBE_MAP_ARRAY_ARB

OpenGLTokens

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW

OpenGLTokens

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW_ARB

OpenGLTokens

GL_SAMPLER_CUBE_SHADOW

OpenGLTokens

GL_SAMPLER_CUBE_SHADOW_EXT

OpenGLTokens

GL_SAMPLES

OpenGLTokens

GL_SAMPLES_3DFX

OpenGLTokens

GL_SAMPLES_ARB

OpenGLTokens

GL_SAMPLES_EXT

OpenGLTokens

GL_SAMPLES_PASSED

OpenGLTokens

GL_SAMPLES_PASSED_ARB

OpenGLTokens

GL_SAMPLES_SGIS

OpenGLTokens

GL_SAMPLE_ALPHA_TO_COVERAGE

OpenGLTokens

GL_SAMPLE_ALPHA_TO_COVERAGE_ARB

OpenGLTokens

GL_SAMPLE_ALPHA_TO_MASK_EXT

OpenGLTokens

GL_SAMPLE_ALPHA_TO_MASK_SGIS

OpenGLTokens

GL_SAMPLE_ALPHA_TO_ONE

OpenGLTokens

GL_SAMPLE_ALPHA_TO_ONE_ARB

OpenGLTokens

GL_SAMPLE_ALPHA_TO_ONE_EXT

OpenGLTokens

GL_SAMPLE_ALPHA_TO_ONE_SGIS

OpenGLTokens

GL_SAMPLE_BUFFERS

OpenGLTokens

GL_SAMPLE_BUFFERS_3DFX

OpenGLTokens

GL_SAMPLE_BUFFERS_ARB

OpenGLTokens

GL_SAMPLE_BUFFERS_EXT

OpenGLTokens

GL_SAMPLE_BUFFERS_SGIS

OpenGLTokens

GL_SAMPLE_COVERAGE

OpenGLTokens

GL_SAMPLE_COVERAGE_ARB

OpenGLTokens

GL_SAMPLE_COVERAGE_INVERT

OpenGLTokens

GL_SAMPLE_COVERAGE_INVERT_ARB

OpenGLTokens

GL_SAMPLE_COVERAGE_VALUE

OpenGLTokens

GL_SAMPLE_COVERAGE_VALUE_ARB

OpenGLTokens

GL_SAMPLE_MASK

OpenGLTokens

GL_SAMPLE_MASK_EXT

OpenGLTokens

GL_SAMPLE_MASK_INVERT_EXT

OpenGLTokens

GL_SAMPLE_MASK_INVERT_SGIS

OpenGLTokens

GL_SAMPLE_MASK_SGIS

OpenGLTokens

GL_SAMPLE_MASK_VALUE

OpenGLTokens

GL_SAMPLE_MASK_VALUE_EXT

OpenGLTokens

GL_SAMPLE_MASK_VALUE_SGIS

OpenGLTokens

GL_SAMPLE_PATTERN_EXT

OpenGLTokens

GL_SAMPLE_PATTERN_SGIS

OpenGLTokens

GL_SAMPLE_POSITION

OpenGLTokens

GL_SAMPLE_SHADING

OpenGLTokens

GL_SAMPLE_SHADING_ARB

OpenGLTokens

GL_SCALE_BY_FOUR_NV

OpenGLTokens

GL_SCALE_BY_ONE_HALF_NV

OpenGLTokens

GL_SCALE_BY_TWO_NV

OpenGLTokens

GL_SCISSOR_BIT

OpenGLTokens

GL_SCISSOR_BOX

OpenGLTokens

GL_SCISSOR_TEST

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_ADDRESS_NV

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_EXT

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_LENGTH_NV

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_POINTER

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_POINTER_EXT

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_SIZE

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_SIZE_EXT

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_STRIDE

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_STRIDE_EXT

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_TYPE

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_TYPE_EXT

OpenGLTokens

GL_SECONDARY_COLOR_NV

OpenGLTokens

GL_SELECT

OpenGLTokens

GL_SELECTION_BUFFER_POINTER

OpenGLTokens

GL_SELECTION_BUFFER_SIZE

OpenGLTokens

GL_SEPARABLE_2D

OpenGLTokens

GL_SEPARABLE_2D_EXT

OpenGLTokens

GL_SEPARATE_ATTRIBS

OpenGLTokens

GL_SEPARATE_ATTRIBS_EXT

OpenGLTokens

GL_SEPARATE_ATTRIBS_NV

OpenGLTokens

GL_SEPARATE_SPECULAR_COLOR

OpenGLTokens

GL_SEPARATE_SPECULAR_COLOR_EXT

OpenGLTokens

GL_SET

OpenGLTokens

GL_SHADER_COMPILER

OpenGLTokens

GL_SHADER_CONSISTENT_NV

OpenGLTokens

GL_SHADER_OBJECT_ARB

OpenGLTokens

GL_SHADER_OPERATION_NV

OpenGLTokens

GL_SHADER_SOURCE_LENGTH

OpenGLTokens

GL_SHADER_TYPE

OpenGLTokens

GL_SHADE_MODEL

OpenGLTokens

GL_SHADING_LANGUAGE_VERSION

OpenGLTokens

GL_SHADING_LANGUAGE_VERSION_ARB

OpenGLTokens

GL_SHADOW_AMBIENT_SGIX

OpenGLTokens

GL_SHARED_TEXTURE_PALETTE_EXT

OpenGLTokens

GL_SHININESS

OpenGLTokens

GL_SHORT

OpenGLTokens

GL_SIGNALED

OpenGLTokens

GL_SIGNED_ALPHA8_NV

OpenGLTokens

GL_SIGNED_ALPHA_NV

OpenGLTokens

GL_SIGNED_HILO16_NV

OpenGLTokens

GL_SIGNED_HILO8_NV

OpenGLTokens

GL_SIGNED_HILO_NV

OpenGLTokens

GL_SIGNED_IDENTITY_NV

OpenGLTokens

GL_SIGNED_INTENSITY8_NV

OpenGLTokens

GL_SIGNED_INTENSITY_NV

OpenGLTokens

GL_SIGNED_LUMINANCE8_ALPHA8_NV

OpenGLTokens

GL_SIGNED_LUMINANCE8_NV

OpenGLTokens

GL_SIGNED_LUMINANCE_ALPHA_NV

OpenGLTokens

GL_SIGNED_LUMINANCE_NV

OpenGLTokens

GL_SIGNED_NEGATE_NV

OpenGLTokens

GL_SIGNED_NORMALIZED

OpenGLTokens

GL_SIGNED_RGB8_NV

OpenGLTokens

GL_SIGNED_RGB8_UNSIGNED_ALPHA8_NV

OpenGLTokens

GL_SIGNED_RGBA8_NV

OpenGLTokens

GL_SIGNED_RGBA_NV

OpenGLTokens

GL_SIGNED_RGB_NV

OpenGLTokens

GL_SIGNED_RGB_UNSIGNED_ALPHA_NV

OpenGLTokens

GL_SINGLE_COLOR

OpenGLTokens

GL_SINGLE_COLOR_EXT

OpenGLTokens

GL_SKIP_DECODE_EXT

OpenGLTokens

GL_SKIP_MISSING_GLYPH_NV

OpenGLTokens

GL_SLUMINANCE

OpenGLTokens

GL_SLUMINANCE8

OpenGLTokens

GL_SLUMINANCE8_ALPHA8

OpenGLTokens

GL_SLUMINANCE8_ALPHA8_EXT

OpenGLTokens

GL_SLUMINANCE8_EXT

OpenGLTokens

GL_SLUMINANCE_ALPHA

OpenGLTokens

GL_SLUMINANCE_ALPHA_EXT

OpenGLTokens

GL_SLUMINANCE_EXT

OpenGLTokens

GL_SMALL_CCW_ARC_TO_NV

OpenGLTokens

GL_SMALL_CW_ARC_TO_NV

OpenGLTokens

GL_SMOOTH

OpenGLTokens

GL_SMOOTH_CUBIC_CURVE_TO_NV

OpenGLTokens

GL_SMOOTH_LINE_WIDTH_GRANULARITY

OpenGLTokens

GL_SMOOTH_LINE_WIDTH_RANGE

OpenGLTokens

GL_SMOOTH_POINT_SIZE_GRANULARITY

OpenGLTokens

GL_SMOOTH_POINT_SIZE_RANGE

OpenGLTokens

GL_SMOOTH_QUADRATIC_CURVE_TO_NV

OpenGLTokens

GL_SOURCE0_ALPHA

OpenGLTokens

GL_SOURCE0_ALPHA_ARB

OpenGLTokens

GL_SOURCE0_ALPHA_EXT

OpenGLTokens

GL_SOURCE0_RGB

OpenGLTokens

GL_SOURCE0_RGB_ARB

OpenGLTokens

GL_SOURCE0_RGB_EXT

OpenGLTokens

GL_SOURCE1_ALPHA

OpenGLTokens

GL_SOURCE1_ALPHA_ARB

OpenGLTokens

GL_SOURCE1_ALPHA_EXT

OpenGLTokens

GL_SOURCE1_RGB

OpenGLTokens

GL_SOURCE1_RGB_ARB

OpenGLTokens

GL_SOURCE1_RGB_EXT

OpenGLTokens

GL_SOURCE2_ALPHA

OpenGLTokens

GL_SOURCE2_ALPHA_ARB

OpenGLTokens

GL_SOURCE2_ALPHA_EXT

OpenGLTokens

GL_SOURCE2_RGB

OpenGLTokens

GL_SOURCE2_RGB_ARB

OpenGLTokens

GL_SOURCE2_RGB_EXT

OpenGLTokens

GL_SOURCE3_ALPHA_EXT

OpenGLTokens

GL_SOURCE3_ALPHA_NV

OpenGLTokens

GL_SOURCE3_RGB_EXT

OpenGLTokens

GL_SOURCE3_RGB_NV

OpenGLTokens

GL_SOURCE4_ALPHA_EXT

OpenGLTokens

GL_SOURCE4_RGB_EXT

OpenGLTokens

GL_SOURCE5_ALPHA_EXT

OpenGLTokens

GL_SOURCE5_RGB_EXT

OpenGLTokens

GL_SOURCE6_ALPHA_EXT

OpenGLTokens

GL_SOURCE6_RGB_EXT

OpenGLTokens

GL_SOURCE7_ALPHA_EXT

OpenGLTokens

GL_SOURCE7_RGB_EXT

OpenGLTokens

GL_SPARE0_NV

OpenGLTokens

GL_SPARE0_PLUS_SECONDARY_COLOR_NV

OpenGLTokens

GL_SPARE1_NV

OpenGLTokens

GL_SPECULAR

OpenGLTokens

GL_SPHERE_MAP

OpenGLTokens

GL_SPOT_CUTOFF

OpenGLTokens

GL_SPOT_DIRECTION

OpenGLTokens

GL_SPOT_EXPONENT

OpenGLTokens

GL_SQUARE_NV

OpenGLTokens

GL_SRC0_ALPHA

OpenGLTokens

GL_SRC0_RGB

OpenGLTokens

GL_SRC1_ALPHA

OpenGLTokens

GL_SRC1_COLOR

OpenGLTokens

GL_SRC1_RGB

OpenGLTokens

GL_SRC2_ALPHA

OpenGLTokens

GL_SRC2_RGB

OpenGLTokens

GL_SRC_ALPHA

OpenGLTokens

GL_SRC_ALPHA_SATURATE

OpenGLTokens

GL_SRC_COLOR

OpenGLTokens

GL_SRGB

OpenGLTokens

GL_SRGB8

OpenGLTokens

GL_SRGB8_ALPHA8

OpenGLTokens

GL_SRGB8_ALPHA8_EXT

OpenGLTokens

GL_SRGB8_EXT

OpenGLTokens

GL_SRGB_ALPHA

OpenGLTokens

GL_SRGB_ALPHA_EXT

OpenGLTokens

GL_SRGB_EXT

OpenGLTokens

GL_STACK_OVERFLOW

OpenGLTokens

GL_STACK_UNDERFLOW

OpenGLTokens

GL_STANDARD_FONT_NAME_NV

OpenGLTokens

GL_STATIC_COPY

OpenGLTokens

GL_STATIC_COPY_ARB

OpenGLTokens

GL_STATIC_DRAW

OpenGLTokens

GL_STATIC_DRAW_ARB

OpenGLTokens

GL_STATIC_READ

OpenGLTokens

GL_STATIC_READ_ARB

OpenGLTokens

GL_STENCIL

OpenGLTokens

GL_STENCIL_ATTACHMENT

OpenGLTokens

GL_STENCIL_ATTACHMENT_EXT

OpenGLTokens

GL_STENCIL_BACK_FAIL

OpenGLTokens

GL_STENCIL_BACK_FUNC

OpenGLTokens

GL_STENCIL_BACK_PASS_DEPTH_FAIL

OpenGLTokens

GL_STENCIL_BACK_PASS_DEPTH_PASS

OpenGLTokens

GL_STENCIL_BACK_REF

OpenGLTokens

GL_STENCIL_BACK_VALUE_MASK

OpenGLTokens

GL_STENCIL_BACK_WRITEMASK

OpenGLTokens

GL_STENCIL_BITS

OpenGLTokens

GL_STENCIL_BUFFER

OpenGLTokens

GL_STENCIL_BUFFER_BIT

OpenGLTokens

GL_STENCIL_CLEAR_TAG_VALUE_EXT

OpenGLTokens

GL_STENCIL_CLEAR_VALUE

OpenGLTokens

GL_STENCIL_FAIL

OpenGLTokens

GL_STENCIL_FUNC

OpenGLTokens

GL_STENCIL_INDEX

OpenGLTokens

GL_STENCIL_INDEX1

OpenGLTokens

GL_STENCIL_INDEX16

OpenGLTokens

GL_STENCIL_INDEX16_EXT

OpenGLTokens

GL_STENCIL_INDEX1_EXT

OpenGLTokens

GL_STENCIL_INDEX4

OpenGLTokens

GL_STENCIL_INDEX4_EXT

OpenGLTokens

GL_STENCIL_INDEX8

OpenGLTokens

GL_STENCIL_INDEX8_EXT

OpenGLTokens

GL_STENCIL_PASS_DEPTH_FAIL

OpenGLTokens

GL_STENCIL_PASS_DEPTH_PASS

OpenGLTokens

GL_STENCIL_REF

OpenGLTokens

GL_STENCIL_TAG_BITS_EXT

OpenGLTokens

GL_STENCIL_TEST

OpenGLTokens

GL_STENCIL_TEST_TWO_SIDE_EXT

OpenGLTokens

GL_STENCIL_VALUE_MASK

OpenGLTokens

GL_STENCIL_WRITEMASK

OpenGLTokens

GL_STEREO

OpenGLTokens

GL_STREAM_COPY

OpenGLTokens

GL_STREAM_COPY_ARB

OpenGLTokens

GL_STREAM_DRAW

OpenGLTokens

GL_STREAM_DRAW_ARB

OpenGLTokens

GL_STREAM_READ

OpenGLTokens

GL_STREAM_READ_ARB

OpenGLTokens

GL_SUBPIXEL_BITS

OpenGLTokens

GL_SUBTRACT

OpenGLTokens

GL_SUBTRACT_ARB

OpenGLTokens

GL_SURFACE_MAPPED_NV

OpenGLTokens

GL_SURFACE_REGISTERED_NV

OpenGLTokens

GL_SURFACE_STATE_NV

OpenGLTokens

GL_SYNC_CONDITION

OpenGLTokens

GL_SYNC_FENCE

OpenGLTokens

GL_SYNC_FLAGS

OpenGLTokens

GL_SYNC_FLUSH_COMMANDS_BIT

OpenGLTokens

GL_SYNC_GPU_COMMANDS_COMPLETE

OpenGLTokens

GL_SYNC_STATUS

OpenGLTokens

GL_SYSTEM_FONT_NAME_NV

OpenGLTokens

GL_T

OpenGLTokens

GL_T2F_C3F_V3F

OpenGLTokens

GL_T2F_C4F_N3F_V3F

OpenGLTokens

GL_T2F_C4UB_V3F

OpenGLTokens

GL_T2F_N3F_V3F

OpenGLTokens

GL_T2F_V3F

OpenGLTokens

GL_T4F_C4F_N3F_V4F

OpenGLTokens

GL_T4F_V4F

OpenGLTokens

GL_TABLE_TOO_LARGE

OpenGLTokens

GL_TESSELLATION_FACTOR_AMD

OpenGLTokens

GL_TESSELLATION_MODE_AMD

OpenGLTokens

GL_TESS_CONTROL_OUTPUT_VERTICES

OpenGLTokens

GL_TESS_CONTROL_SHADER

OpenGLTokens

GL_TESS_CONTROL_SHADER_BIT

OpenGLTokens

GL_TESS_EVALUATION_SHADER

OpenGLTokens

GL_TESS_EVALUATION_SHADER_BIT

OpenGLTokens

GL_TESS_GEN_MODE

OpenGLTokens

GL_TESS_GEN_POINT_MODE

OpenGLTokens

GL_TESS_GEN_SPACING

OpenGLTokens

GL_TESS_GEN_VERTEX_ORDER

OpenGLTokens

GL_TEXTURE

OpenGLTokens

GL_TEXTURE0

OpenGLTokens

GL_TEXTURE0_ARB

OpenGLTokens

GL_TEXTURE1

OpenGLTokens

GL_TEXTURE10

OpenGLTokens

GL_TEXTURE10_ARB

OpenGLTokens

GL_TEXTURE11

OpenGLTokens

GL_TEXTURE11_ARB

OpenGLTokens

GL_TEXTURE12

OpenGLTokens

GL_TEXTURE12_ARB

OpenGLTokens

GL_TEXTURE13

OpenGLTokens

GL_TEXTURE13_ARB

OpenGLTokens

GL_TEXTURE14

OpenGLTokens

GL_TEXTURE14_ARB

OpenGLTokens

GL_TEXTURE15

OpenGLTokens

GL_TEXTURE15_ARB

OpenGLTokens

GL_TEXTURE16

OpenGLTokens

GL_TEXTURE16_ARB

OpenGLTokens

GL_TEXTURE17

OpenGLTokens

GL_TEXTURE17_ARB

OpenGLTokens

GL_TEXTURE18

OpenGLTokens

GL_TEXTURE18_ARB

OpenGLTokens

GL_TEXTURE19

OpenGLTokens

GL_TEXTURE19_ARB

OpenGLTokens

GL_TEXTURE1_ARB

OpenGLTokens

GL_TEXTURE2

OpenGLTokens

GL_TEXTURE20

OpenGLTokens

GL_TEXTURE20_ARB

OpenGLTokens

GL_TEXTURE21

OpenGLTokens

GL_TEXTURE21_ARB

OpenGLTokens

GL_TEXTURE22

OpenGLTokens

GL_TEXTURE22_ARB

OpenGLTokens

GL_TEXTURE23

OpenGLTokens

GL_TEXTURE23_ARB

OpenGLTokens

GL_TEXTURE24

OpenGLTokens

GL_TEXTURE24_ARB

OpenGLTokens

GL_TEXTURE25

OpenGLTokens

GL_TEXTURE25_ARB

OpenGLTokens

GL_TEXTURE26

OpenGLTokens

GL_TEXTURE26_ARB

OpenGLTokens

GL_TEXTURE27

OpenGLTokens

GL_TEXTURE27_ARB

OpenGLTokens

GL_TEXTURE28

OpenGLTokens

GL_TEXTURE28_ARB

OpenGLTokens

GL_TEXTURE29

OpenGLTokens

GL_TEXTURE29_ARB

OpenGLTokens

GL_TEXTURE2_ARB

OpenGLTokens

GL_TEXTURE3

OpenGLTokens

GL_TEXTURE30

OpenGLTokens

GL_TEXTURE30_ARB

OpenGLTokens

GL_TEXTURE31

OpenGLTokens

GL_TEXTURE31_ARB

OpenGLTokens

GL_TEXTURE3_ARB

OpenGLTokens

GL_TEXTURE4

OpenGLTokens

GL_TEXTURE4_ARB

OpenGLTokens

GL_TEXTURE5

OpenGLTokens

GL_TEXTURE5_ARB

OpenGLTokens

GL_TEXTURE6

OpenGLTokens

GL_TEXTURE6_ARB

OpenGLTokens

GL_TEXTURE7

OpenGLTokens

GL_TEXTURE7_ARB

OpenGLTokens

GL_TEXTURE8

OpenGLTokens

GL_TEXTURE8_ARB

OpenGLTokens

GL_TEXTURE9

OpenGLTokens

GL_TEXTURE9_ARB

OpenGLTokens

GL_TEXTURE_1D

OpenGLTokens

GL_TEXTURE_1D_ARRAY

OpenGLTokens

GL_TEXTURE_1D_ARRAY_EXT

OpenGLTokens

GL_TEXTURE_1D_BINDING_EXT

OpenGLTokens

GL_TEXTURE_2D

OpenGLTokens

GL_TEXTURE_2D_ARRAY

OpenGLTokens

GL_TEXTURE_2D_ARRAY_EXT

OpenGLTokens

GL_TEXTURE_2D_BINDING_EXT

OpenGLTokens

GL_TEXTURE_2D_MULTISAMPLE

OpenGLTokens

GL_TEXTURE_2D_MULTISAMPLE_ARRAY

OpenGLTokens

GL_TEXTURE_3D

OpenGLTokens

GL_TEXTURE_3D_BINDING_EXT

OpenGLTokens

GL_TEXTURE_3D_EXT

OpenGLTokens

GL_TEXTURE_ALPHA_SIZE

OpenGLTokens

GL_TEXTURE_ALPHA_SIZE_EXT

OpenGLTokens

GL_TEXTURE_ALPHA_TYPE

OpenGLTokens

GL_TEXTURE_ALPHA_TYPE_ARB

OpenGLTokens

GL_TEXTURE_BASE_LEVEL

OpenGLTokens

GL_TEXTURE_BASE_LEVEL_SGIS

OpenGLTokens

GL_TEXTURE_BINDING_1D

OpenGLTokens

GL_TEXTURE_BINDING_1D_ARRAY

OpenGLTokens

GL_TEXTURE_BINDING_1D_ARRAY_EXT

OpenGLTokens

GL_TEXTURE_BINDING_2D

OpenGLTokens

GL_TEXTURE_BINDING_2D_ARRAY

OpenGLTokens

GL_TEXTURE_BINDING_2D_ARRAY_EXT

OpenGLTokens

GL_TEXTURE_BINDING_2D_MULTISAMPLE

OpenGLTokens

GL_TEXTURE_BINDING_2D_MULTISAMPLE_ARRAY

OpenGLTokens

GL_TEXTURE_BINDING_3D

OpenGLTokens

GL_TEXTURE_BINDING_BUFFER

OpenGLTokens

GL_TEXTURE_BINDING_BUFFER_ARB

OpenGLTokens

GL_TEXTURE_BINDING_BUFFER_EXT

OpenGLTokens

GL_TEXTURE_BINDING_CUBE_MAP

OpenGLTokens

GL_TEXTURE_BINDING_CUBE_MAP_ARB

OpenGLTokens

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY

OpenGLTokens

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY_ARB

OpenGLTokens

GL_TEXTURE_BINDING_CUBE_MAP_EXT

OpenGLTokens

GL_TEXTURE_BINDING_RECTANGLE

OpenGLTokens

GL_TEXTURE_BINDING_RECTANGLE_ARB

OpenGLTokens

GL_TEXTURE_BINDING_RECTANGLE_EXT

OpenGLTokens

GL_TEXTURE_BINDING_RECTANGLE_NV

OpenGLTokens

GL_TEXTURE_BIT

OpenGLTokens

GL_TEXTURE_BLUE_SIZE

OpenGLTokens

GL_TEXTURE_BLUE_SIZE_EXT

OpenGLTokens

GL_TEXTURE_BLUE_TYPE

OpenGLTokens

GL_TEXTURE_BLUE_TYPE_ARB

OpenGLTokens

GL_TEXTURE_BORDER

OpenGLTokens

GL_TEXTURE_BORDER_COLOR

OpenGLTokens

GL_TEXTURE_BORDER_VALUES_NV

OpenGLTokens

GL_TEXTURE_BUFFER

OpenGLTokens

GL_TEXTURE_BUFFER_ARB

OpenGLTokens

GL_TEXTURE_BUFFER_DATA_STORE_BINDING

OpenGLTokens

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_ARB

OpenGLTokens

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_EXT

OpenGLTokens

GL_TEXTURE_BUFFER_EXT

OpenGLTokens

GL_TEXTURE_BUFFER_FORMAT

OpenGLTokens

GL_TEXTURE_BUFFER_FORMAT_ARB

OpenGLTokens

GL_TEXTURE_BUFFER_FORMAT_EXT

OpenGLTokens

GL_TEXTURE_COLOR_WRITEMASK_SGIS

OpenGLTokens

GL_TEXTURE_COMPARE_FAIL_VALUE_ARB

OpenGLTokens

GL_TEXTURE_COMPARE_FUNC

OpenGLTokens

GL_TEXTURE_COMPARE_FUNC_ARB

OpenGLTokens

GL_TEXTURE_COMPARE_MODE

OpenGLTokens

GL_TEXTURE_COMPARE_MODE_ARB

OpenGLTokens

GL_TEXTURE_COMPARE_OPERATOR_SGIX

OpenGLTokens

GL_TEXTURE_COMPARE_SGIX

OpenGLTokens

GL_TEXTURE_COMPONENTS

OpenGLTokens

GL_TEXTURE_COMPRESSED

OpenGLTokens

GL_TEXTURE_COMPRESSED_ARB

OpenGLTokens

GL_TEXTURE_COMPRESSED_IMAGE_SIZE

OpenGLTokens

GL_TEXTURE_COMPRESSED_IMAGE_SIZE_ARB

OpenGLTokens

GL_TEXTURE_COMPRESSION_HINT

OpenGLTokens

GL_TEXTURE_COMPRESSION_HINT_ARB

OpenGLTokens

GL_TEXTURE_COORD_ARRAY

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_ADDRESS_NV

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_LENGTH_NV

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_POINTER

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_SIZE

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_STRIDE

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_TYPE

OpenGLTokens

GL_TEXTURE_COORD_NV

OpenGLTokens

GL_TEXTURE_CUBE_MAP

OpenGLTokens

GL_TEXTURE_CUBE_MAP_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_ARRAY

OpenGLTokens

GL_TEXTURE_CUBE_MAP_ARRAY_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_EXT

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_X

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_EXT

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_EXT

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_EXT

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_X

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_X_EXT

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_Y

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_EXT

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_Z

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_EXT

OpenGLTokens

GL_TEXTURE_CUBE_MAP_SEAMLESS

OpenGLTokens

GL_TEXTURE_DEPTH

OpenGLTokens

GL_TEXTURE_DEPTH_EXT

OpenGLTokens

GL_TEXTURE_DEPTH_SIZE

OpenGLTokens

GL_TEXTURE_DEPTH_SIZE_ARB

OpenGLTokens

GL_TEXTURE_DEPTH_TYPE

OpenGLTokens

GL_TEXTURE_DEPTH_TYPE_ARB

OpenGLTokens

GL_TEXTURE_DS_SIZE_NV

OpenGLTokens

GL_TEXTURE_DT_SIZE_NV

OpenGLTokens

GL_TEXTURE_ENV

OpenGLTokens

GL_TEXTURE_ENV_COLOR

OpenGLTokens

GL_TEXTURE_ENV_MODE

OpenGLTokens

GL_TEXTURE_FILTER_CONTROL

OpenGLTokens

GL_TEXTURE_FILTER_CONTROL_EXT

OpenGLTokens

GL_TEXTURE_FIXED_SAMPLE_LOCATIONS

OpenGLTokens

GL_TEXTURE_FLOAT_COMPONENTS_NV

OpenGLTokens

GL_TEXTURE_FREE_MEMORY_ATI

OpenGLTokens

GL_TEXTURE_GEN_MODE

OpenGLTokens

GL_TEXTURE_GEN_Q

OpenGLTokens

GL_TEXTURE_GEN_R

OpenGLTokens

GL_TEXTURE_GEN_S

OpenGLTokens

GL_TEXTURE_GEN_T

OpenGLTokens

GL_TEXTURE_GEQUAL_R_SGIX

OpenGLTokens

GL_TEXTURE_GREEN_SIZE

OpenGLTokens

GL_TEXTURE_GREEN_SIZE_EXT

OpenGLTokens

GL_TEXTURE_GREEN_TYPE

OpenGLTokens

GL_TEXTURE_GREEN_TYPE_ARB

OpenGLTokens

GL_TEXTURE_HEIGHT

OpenGLTokens

GL_TEXTURE_HI_SIZE_NV

OpenGLTokens

GL_TEXTURE_INDEX_SIZE_EXT

OpenGLTokens

GL_TEXTURE_INTENSITY_SIZE

OpenGLTokens

GL_TEXTURE_INTENSITY_SIZE_EXT

OpenGLTokens

GL_TEXTURE_INTENSITY_TYPE

OpenGLTokens

GL_TEXTURE_INTENSITY_TYPE_ARB

OpenGLTokens

GL_TEXTURE_INTERNAL_FORMAT

OpenGLTokens

GL_TEXTURE_LEQUAL_R_SGIX

OpenGLTokens

GL_TEXTURE_LOD_BIAS

OpenGLTokens

GL_TEXTURE_LOD_BIAS_EXT

OpenGLTokens

GL_TEXTURE_LO_SIZE_NV

OpenGLTokens

GL_TEXTURE_LUMINANCE_SIZE

OpenGLTokens

GL_TEXTURE_LUMINANCE_SIZE_EXT

OpenGLTokens

GL_TEXTURE_LUMINANCE_TYPE

OpenGLTokens

GL_TEXTURE_LUMINANCE_TYPE_ARB

OpenGLTokens

GL_TEXTURE_MAG_FILTER

OpenGLTokens

GL_TEXTURE_MAG_SIZE_NV

OpenGLTokens

GL_TEXTURE_MATRIX

OpenGLTokens

GL_TEXTURE_MAX_ANISOTROPY_EXT

OpenGLTokens

GL_TEXTURE_MAX_LEVEL

OpenGLTokens

GL_TEXTURE_MAX_LEVEL_SGIS

OpenGLTokens

GL_TEXTURE_MAX_LOD

OpenGLTokens

GL_TEXTURE_MAX_LOD_SGIS

OpenGLTokens

GL_TEXTURE_MIN_FILTER

OpenGLTokens

GL_TEXTURE_MIN_LOD

OpenGLTokens

GL_TEXTURE_MIN_LOD_SGIS

OpenGLTokens

GL_TEXTURE_PRIORITY

OpenGLTokens

GL_TEXTURE_PRIORITY_EXT

OpenGLTokens

GL_TEXTURE_RECTANGLE

OpenGLTokens

GL_TEXTURE_RECTANGLE_ARB

OpenGLTokens

GL_TEXTURE_RECTANGLE_EXT

OpenGLTokens

GL_TEXTURE_RECTANGLE_NV

OpenGLTokens

GL_TEXTURE_RED_SIZE

OpenGLTokens

GL_TEXTURE_RED_SIZE_EXT

OpenGLTokens

GL_TEXTURE_RED_TYPE

OpenGLTokens

GL_TEXTURE_RED_TYPE_ARB

OpenGLTokens

GL_TEXTURE_RESIDENT

OpenGLTokens

GL_TEXTURE_RESIDENT_EXT

OpenGLTokens

GL_TEXTURE_SAMPLES

OpenGLTokens

GL_TEXTURE_SHADER_NV

OpenGLTokens

GL_TEXTURE_SHARED_SIZE

OpenGLTokens

GL_TEXTURE_SHARED_SIZE_EXT

OpenGLTokens

GL_TEXTURE_SRGB_DECODE_EXT

OpenGLTokens

GL_TEXTURE_STACK_DEPTH

OpenGLTokens

GL_TEXTURE_STENCIL_SIZE

OpenGLTokens

GL_TEXTURE_STENCIL_SIZE_EXT

OpenGLTokens

GL_TEXTURE_SWIZZLE_A

OpenGLTokens

GL_TEXTURE_SWIZZLE_B

OpenGLTokens

GL_TEXTURE_SWIZZLE_G

OpenGLTokens

GL_TEXTURE_SWIZZLE_R

OpenGLTokens

GL_TEXTURE_SWIZZLE_RGBA

OpenGLTokens

GL_TEXTURE_TOO_LARGE_EXT

OpenGLTokens

GL_TEXTURE_WIDTH

OpenGLTokens

GL_TEXTURE_WRAP_R

OpenGLTokens

GL_TEXTURE_WRAP_R_EXT

OpenGLTokens

GL_TEXTURE_WRAP_S

OpenGLTokens

GL_TEXTURE_WRAP_T

OpenGLTokens

GL_TIMEOUT_EXPIRED

OpenGLTokens

GL_TIMEOUT_IGNORED

OpenGLTokens

GL_TIMESTAMP

OpenGLTokens

GL_TIME_ELAPSED

OpenGLTokens

GL_TIME_ELAPSED_EXT

OpenGLTokens

GL_TRACK_MATRIX_NV

OpenGLTokens

GL_TRACK_MATRIX_TRANSFORM_NV

OpenGLTokens

GL_TRANSFORM_BIT

OpenGLTokens

GL_TRANSFORM_FEEDBACK

OpenGLTokens

GL_TRANSFORM_FEEDBACK_ATTRIBS_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BINDING

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_EXT

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_EXT

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_MODE

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_EXT

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_EXT

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_START

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_START_EXT

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_START_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN

OpenGLTokens

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_EXT

OpenGLTokens

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_RECORD_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_VARYINGS

OpenGLTokens

GL_TRANSFORM_FEEDBACK_VARYINGS_EXT

OpenGLTokens

GL_TRANSFORM_FEEDBACK_VARYINGS_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH

OpenGLTokens

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH_EXT

OpenGLTokens

GL_TRANSLATE_2D_NV

OpenGLTokens

GL_TRANSLATE_3D_NV

OpenGLTokens

GL_TRANSLATE_X_NV

OpenGLTokens

GL_TRANSLATE_Y_NV

OpenGLTokens

GL_TRANSPOSE_AFFINE_2D_NV

OpenGLTokens

GL_TRANSPOSE_AFFINE_3D_NV

OpenGLTokens

GL_TRANSPOSE_COLOR_MATRIX

OpenGLTokens

GL_TRANSPOSE_COLOR_MATRIX_ARB

OpenGLTokens

GL_TRANSPOSE_CURRENT_MATRIX_ARB

OpenGLTokens

GL_TRANSPOSE_MODELVIEW_MATRIX

OpenGLTokens

GL_TRANSPOSE_MODELVIEW_MATRIX_ARB

OpenGLTokens

GL_TRANSPOSE_NV

OpenGLTokens

GL_TRANSPOSE_PROJECTION_MATRIX

OpenGLTokens

GL_TRANSPOSE_PROJECTION_MATRIX_ARB

OpenGLTokens

GL_TRANSPOSE_TEXTURE_MATRIX

OpenGLTokens

GL_TRANSPOSE_TEXTURE_MATRIX_ARB

OpenGLTokens

GL_TRIANGLES

OpenGLTokens

GL_TRIANGLES_ADJACENCY

OpenGLTokens

GL_TRIANGLES_ADJACENCY_ARB

OpenGLTokens

GL_TRIANGLES_ADJACENCY_EXT

OpenGLTokens

GL_TRIANGLE_FAN

OpenGLTokens

GL_TRIANGLE_STRIP

OpenGLTokens

GL_TRIANGLE_STRIP_ADJACENCY

OpenGLTokens

GL_TRIANGLE_STRIP_ADJACENCY_ARB

OpenGLTokens

GL_TRIANGLE_STRIP_ADJACENCY_EXT

OpenGLTokens

GL_TRIANGULAR_NV

OpenGLTokens

GL_TRUE

OpenGLTokens

GL_TYPE_RGBA_FLOAT_ATI

OpenGLTokens

GL_UNDEFINED_VERTEX

OpenGLTokens

GL_UNIFORM_ARRAY_STRIDE

OpenGLTokens

GL_UNIFORM_BLOCK_ACTIVE_UNIFORMS

OpenGLTokens

GL_UNIFORM_BLOCK_ACTIVE_UNIFORM_INDICES

OpenGLTokens

GL_UNIFORM_BLOCK_BINDING

OpenGLTokens

GL_UNIFORM_BLOCK_DATA_SIZE

OpenGLTokens

GL_UNIFORM_BLOCK_INDEX

OpenGLTokens

GL_UNIFORM_BLOCK_NAME_LENGTH

OpenGLTokens

GL_UNIFORM_BLOCK_REFERENCED_BY_FRAGMENT_SHADER

OpenGLTokens

GL_UNIFORM_BLOCK_REFERENCED_BY_GEOMETRY_SHADER

OpenGLTokens

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_CONTROL_SHADER

OpenGLTokens

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_EVALUATION_SHADER

OpenGLTokens

GL_UNIFORM_BLOCK_REFERENCED_BY_VERTEX_SHADER

OpenGLTokens

GL_UNIFORM_BUFFER

OpenGLTokens

GL_UNIFORM_BUFFER_BINDING

OpenGLTokens

GL_UNIFORM_BUFFER_BINDING_EXT

OpenGLTokens

GL_UNIFORM_BUFFER_EXT

OpenGLTokens

GL_UNIFORM_BUFFER_OFFSET_ALIGNMENT

OpenGLTokens

GL_UNIFORM_BUFFER_SIZE

OpenGLTokens

GL_UNIFORM_BUFFER_START

OpenGLTokens

GL_UNIFORM_IS_ROW_MAJOR

OpenGLTokens

GL_UNIFORM_MATRIX_STRIDE

OpenGLTokens

GL_UNIFORM_NAME_LENGTH

OpenGLTokens

GL_UNIFORM_OFFSET

OpenGLTokens

GL_UNIFORM_SIZE

OpenGLTokens

GL_UNIFORM_TYPE

OpenGLTokens

GL_UNKNOWN_CONTEXT_RESET_ARB

OpenGLTokens

GL_UNPACK_ALIGNMENT

OpenGLTokens

GL_UNPACK_IMAGE_HEIGHT

OpenGLTokens

GL_UNPACK_IMAGE_HEIGHT_EXT

OpenGLTokens

GL_UNPACK_LSB_FIRST

OpenGLTokens

GL_UNPACK_ROW_LENGTH

OpenGLTokens

GL_UNPACK_SKIP_IMAGES

OpenGLTokens

GL_UNPACK_SKIP_IMAGES_EXT

OpenGLTokens

GL_UNPACK_SKIP_PIXELS

OpenGLTokens

GL_UNPACK_SKIP_ROWS

OpenGLTokens

GL_UNPACK_SWAP_BYTES

OpenGLTokens

GL_UNSIGNALED

OpenGLTokens

GL_UNSIGNED_BYTE

OpenGLTokens

GL_UNSIGNED_BYTE_2_3_3_REV

OpenGLTokens

GL_UNSIGNED_BYTE_3_3_2

OpenGLTokens

GL_UNSIGNED_BYTE_3_3_2_EXT

OpenGLTokens

GL_UNSIGNED_IDENTITY_NV

OpenGLTokens

GL_UNSIGNED_INT

OpenGLTokens

GL_UNSIGNED_INT_10F_11F_11F_REV

OpenGLTokens

GL_UNSIGNED_INT_10F_11F_11F_REV_EXT

OpenGLTokens

GL_UNSIGNED_INT_10_10_10_2

OpenGLTokens

GL_UNSIGNED_INT_10_10_10_2_EXT

OpenGLTokens

GL_UNSIGNED_INT_24_8

OpenGLTokens

GL_UNSIGNED_INT_24_8_EXT

OpenGLTokens

GL_UNSIGNED_INT_2_10_10_10_REV

OpenGLTokens

GL_UNSIGNED_INT_5_9_9_9_REV

OpenGLTokens

GL_UNSIGNED_INT_5_9_9_9_REV_EXT

OpenGLTokens

GL_UNSIGNED_INT_8_8_8_8

OpenGLTokens

GL_UNSIGNED_INT_8_8_8_8_EXT

OpenGLTokens

GL_UNSIGNED_INT_8_8_8_8_REV

OpenGLTokens

GL_UNSIGNED_INT_8_8_S8_S8_REV_NV

OpenGLTokens

GL_UNSIGNED_INT_S8_S8_8_8_NV

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_1D

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_1D_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE_ARRAY

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D_RECT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D_RECT_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_3D

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_3D_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_BUFFER

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_BUFFER_AMD

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_BUFFER_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_CUBE

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_CUBE_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY_ARB

OpenGLTokens

GL_UNSIGNED_INT_VEC2

OpenGLTokens

GL_UNSIGNED_INT_VEC2_EXT

OpenGLTokens

GL_UNSIGNED_INT_VEC3

OpenGLTokens

GL_UNSIGNED_INT_VEC3_EXT

OpenGLTokens

GL_UNSIGNED_INT_VEC4

OpenGLTokens

GL_UNSIGNED_INT_VEC4_EXT

OpenGLTokens

GL_UNSIGNED_INVERT_NV

OpenGLTokens

GL_UNSIGNED_NORMALIZED

OpenGLTokens

GL_UNSIGNED_NORMALIZED_ARB

OpenGLTokens

GL_UNSIGNED_SHORT

OpenGLTokens

GL_UNSIGNED_SHORT_1_5_5_5_REV

OpenGLTokens

GL_UNSIGNED_SHORT_4_4_4_4

OpenGLTokens

GL_UNSIGNED_SHORT_4_4_4_4_EXT

OpenGLTokens

GL_UNSIGNED_SHORT_4_4_4_4_REV

OpenGLTokens

GL_UNSIGNED_SHORT_5_5_5_1

OpenGLTokens

GL_UNSIGNED_SHORT_5_5_5_1_EXT

OpenGLTokens

GL_UNSIGNED_SHORT_5_6_5

OpenGLTokens

GL_UNSIGNED_SHORT_5_6_5_REV

OpenGLTokens

GL_UPPER_LEFT

OpenGLTokens

GL_USE_MISSING_GLYPH_NV

OpenGLTokens

GL_UTF16_NV

OpenGLTokens

GL_UTF8_NV

OpenGLTokens

GL_V2F

OpenGLTokens

GL_V3F

OpenGLTokens

GL_VALIDATE_STATUS

OpenGLTokens

GL_VARIABLE_A_NV

OpenGLTokens

GL_VARIABLE_B_NV

OpenGLTokens

GL_VARIABLE_C_NV

OpenGLTokens

GL_VARIABLE_D_NV

OpenGLTokens

GL_VARIABLE_E_NV

OpenGLTokens

GL_VARIABLE_F_NV

OpenGLTokens

GL_VARIABLE_G_NV

OpenGLTokens

GL_VBO_FREE_MEMORY_ATI

OpenGLTokens

GL_VENDOR

OpenGLTokens

GL_VERSION

OpenGLTokens

GL_VERTEX_ARRAY

OpenGLTokens

GL_VERTEX_ARRAY_ADDRESS_NV

OpenGLTokens

GL_VERTEX_ARRAY_BINDING

OpenGLTokens

GL_VERTEX_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_VERTEX_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_VERTEX_ARRAY_LENGTH_NV

OpenGLTokens

GL_VERTEX_ARRAY_POINTER

OpenGLTokens

GL_VERTEX_ARRAY_RANGE_LENGTH_NV

OpenGLTokens

GL_VERTEX_ARRAY_RANGE_NV

OpenGLTokens

GL_VERTEX_ARRAY_RANGE_POINTER_NV

OpenGLTokens

GL_VERTEX_ARRAY_RANGE_VALID_NV

OpenGLTokens

GL_VERTEX_ARRAY_RANGE_WITHOUT_FLUSH_NV

OpenGLTokens

GL_VERTEX_ARRAY_SIZE

OpenGLTokens

GL_VERTEX_ARRAY_STRIDE

OpenGLTokens

GL_VERTEX_ARRAY_TYPE

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY0_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY10_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY11_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY12_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY13_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY14_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY15_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY1_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY2_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY3_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY4_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY5_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY6_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY7_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY8_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY9_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_ADDRESS_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_DIVISOR

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_DIVISOR_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_ENABLED

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_ENABLED_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_INTEGER

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_INTEGER_EXT

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_LENGTH_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_POINTER

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_POINTER_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_SIZE

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_SIZE_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_STRIDE

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_STRIDE_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_TYPE

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_TYPE_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_UNIFIED_NV

OpenGLTokens

GL_VERTEX_BLEND_ARB

OpenGLTokens

GL_VERTEX_ID_NV

OpenGLTokens

GL_VERTEX_PROGRAM_ARB

OpenGLTokens

GL_VERTEX_PROGRAM_BINDING_NV

OpenGLTokens

GL_VERTEX_PROGRAM_NV

OpenGLTokens

GL_VERTEX_PROGRAM_POINT_SIZE

OpenGLTokens

GL_VERTEX_PROGRAM_POINT_SIZE_ARB

OpenGLTokens

GL_VERTEX_PROGRAM_POINT_SIZE_NV

OpenGLTokens

GL_VERTEX_PROGRAM_TWO_SIDE

OpenGLTokens

GL_VERTEX_PROGRAM_TWO_SIDE_ARB

OpenGLTokens

GL_VERTEX_PROGRAM_TWO_SIDE_NV

OpenGLTokens

GL_VERTEX_SHADER

OpenGLTokens

GL_VERTEX_SHADER_ARB

OpenGLTokens

GL_VERTEX_SHADER_BIT

OpenGLTokens

GL_VERTEX_STATE_PROGRAM_NV

OpenGLTokens

GL_VERTICAL_LINE_TO_NV

OpenGLTokens

GL_VIBRANCE_BIAS_NV

OpenGLTokens

GL_VIBRANCE_SCALE_NV

OpenGLTokens

GL_VIEWPORT

OpenGLTokens

GL_VIEWPORT_BIT

OpenGLTokens

GL_VIEWPORT_BOUNDS_RANGE

OpenGLTokens

GL_VIEWPORT_INDEX_PROVOKING_VERTEX

OpenGLTokens

GL_VIEWPORT_SUBPIXEL_BITS

OpenGLTokens

GL_WAIT_FAILED

OpenGLTokens

GL_WEIGHT_ARRAY_ARB

OpenGLTokens

GL_WEIGHT_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_WEIGHT_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_WEIGHT_ARRAY_POINTER_ARB

OpenGLTokens

GL_WEIGHT_ARRAY_SIZE_ARB

OpenGLTokens

GL_WEIGHT_ARRAY_STRIDE_ARB

OpenGLTokens

GL_WEIGHT_ARRAY_TYPE_ARB

OpenGLTokens

GL_WEIGHT_SUM_UNITY_ARB

OpenGLTokens

GL_WRITE_DISCARD_NV

OpenGLTokens

GL_WRITE_ONLY

OpenGLTokens

GL_WRITE_ONLY_ARB

OpenGLTokens

GL_XOR

OpenGLTokens

GL_ZERO

OpenGLTokens

GL_ZOOM_X

OpenGLTokens

GL_ZOOM_Y

OpenGLTokens

GRADIENT_TABLE_SIZE

GLProcTextures

GuiNullRect

GLGui

G_DRAG

VerletClasses

HIDE_NODE

Const3DS

HIDE_TRACK_TAG

Const3DS

HIERARCHY

Const3DS

HIGHPASS_DEFAULT_GAIN

openal

HIGHPASS_DEFAULT_GAINLF

openal

HIGHPASS_MAX_GAIN

openal

HIGHPASS_MAX_GAINLF

openal

HIGHPASS_MIN_GAIN

openal

HIGHPASS_MIN_GAINLF

openal

HiShadowBiasMin3DS

Const3DS

HI_SHADOW_BIAS

Const3DS

HotTrackTagMax3DS

Const3DS

HotTrackTagMin3DS

Const3DS

HOT_TRACK_TAG

Const3DS

HOT_TRACK_TAG_KEY

Const3DS

ICCOMPRESSFRAMES_PADDING

GLSVfw

ICCOMPRESS_KEYFRAME

GLSVfw

ICDECOMPRESS_HURRYUP

GLSVfw

ICDECOMPRESS_NOTKEYFRAME

GLSVfw

ICDECOMPRESS_NULLFRAME

GLSVfw

ICDECOMPRESS_PREROLL

GLSVfw

ICDECOMPRESS_UPDATE

GLSVfw

ICDRAW_ANIMATE

GLSVfw

ICDRAW_BUFFER

GLSVfw

ICDRAW_CONTINUE

GLSVfw

ICDRAW_FULLSCREEN

GLSVfw

ICDRAW_HDC

GLSVfw

ICDRAW_HURRYUP

GLSVfw

ICDRAW_MEMORYDC

GLSVfw

ICDRAW_NOTKEYFRAME

GLSVfw

ICDRAW_NULLFRAME

GLSVfw

ICDRAW_PREROLL

GLSVfw

ICDRAW_QUERY

GLSVfw

ICDRAW_RENDER

GLSVfw

ICDRAW_UPDATE

GLSVfw

ICDRAW_UPDATING

GLSVfw

ICERR_ABORT

GLSVfw

ICERR_BADBITDEPTH

GLSVfw

ICERR_BADFLAGS

GLSVfw

ICERR_BADFORMAT

GLSVfw

ICERR_BADHANDLE

GLSVfw

ICERR_BADIMAGESIZE

GLSVfw

ICERR_BADPARAM

GLSVfw

ICERR_BADSIZE

GLSVfw

ICERR_CANTUPDATE

GLSVfw

ICERR_CUSTOM

GLSVfw

ICERR_DONTDRAW

GLSVfw

ICERR_ERROR

GLSVfw

ICERR_GOTOKEYFRAME

GLSVfw

ICERR_INTERNAL

GLSVfw

ICERR_MEMORY

GLSVfw

ICERR_NEWPALETTE

GLSVfw

ICERR_OK

GLSVfw

ICERR_STOPDRAWING

GLSVfw

ICERR_UNSUPPORTED

GLSVfw

ICINSTALL_DRIVER

GLSVfw

ICINSTALL_DRIVERW

GLSVfw

ICINSTALL_FUNCTION

GLSVfw

ICINSTALL_HDRV

GLSVfw

ICINSTALL_UNICODE

GLSVfw

ICMF_ABOUT_QUERY

GLSVfw

ICMF_CHOOSE_ALLCOMPRESSORS

GLSVfw

ICMF_CHOOSE_DATARATE

GLSVfw

ICMF_CHOOSE_KEYFRAME

GLSVfw

ICMF_CHOOSE_PREVIEW

GLSVfw

ICMF_COMPVARS_VALID

GLSVfw

ICMF_CONFIGURE_QUERY

GLSVfw

ICMODE_COMPRESS

GLSVfw

ICMODE_DECOMPRESS

GLSVfw

ICMODE_DRAW

GLSVfw

ICMODE_FASTCOMPRESS

GLSVfw

ICMODE_FASTDECOMPRESS

GLSVfw

ICMODE_QUERY

GLSVfw

ICM_ABOUT

GLSVfw

ICM_COMPRESS

GLSVfw

ICM_COMPRESS_BEGIN

GLSVfw

ICM_COMPRESS_END

GLSVfw

ICM_COMPRESS_FRAMES_INFO

GLSVfw

ICM_COMPRESS_GET_FORMAT

GLSVfw

ICM_COMPRESS_GET_SIZE

GLSVfw

ICM_COMPRESS_QUERY

GLSVfw

ICM_CONFIGURE

GLSVfw

ICM_DECOMPRESS

GLSVfw

ICM_DECOMPRESSEX

GLSVfw

ICM_DECOMPRESSEX_BEGIN

GLSVfw

ICM_DECOMPRESSEX_END

GLSVfw

ICM_DECOMPRESSEX_QUERY

GLSVfw

ICM_DECOMPRESS_BEGIN

GLSVfw

ICM_DECOMPRESS_END

GLSVfw

ICM_DECOMPRESS_GET_FORMAT

GLSVfw

ICM_DECOMPRESS_GET_PALETTE

GLSVfw

ICM_DECOMPRESS_QUERY

GLSVfw

ICM_DECOMPRESS_SET_PALETTE

GLSVfw

ICM_DRAW

GLSVfw

ICM_DRAW_BEGIN

GLSVfw

ICM_DRAW_CHANGEPALETTE

GLSVfw

ICM_DRAW_END

GLSVfw

ICM_DRAW_FLUSH

GLSVfw

ICM_DRAW_GETTIME

GLSVfw

ICM_DRAW_GET_PALETTE

GLSVfw

ICM_DRAW_QUERY

GLSVfw

ICM_DRAW_REALIZE

GLSVfw

ICM_DRAW_RENDERBUFFER

GLSVfw

ICM_DRAW_SETTIME

GLSVfw

ICM_DRAW_START

GLSVfw

ICM_DRAW_START_PLAY

GLSVfw

ICM_DRAW_STOP

GLSVfw

ICM_DRAW_STOP_PLAY

GLSVfw

ICM_DRAW_SUGGESTFORMAT

GLSVfw

ICM_DRAW_WINDOW

GLSVfw

ICM_FRAMERATE

GLSVfw

ICM_GET

GLSVfw

ICM_GETBUFFERSWANTED

GLSVfw

ICM_GETDEFAULTKEYFRAMERATE

GLSVfw

ICM_GETDEFAULTQUALITY

GLSVfw

ICM_GETINFO

GLSVfw

ICM_GETQUALITY

GLSVfw

ICM_GETSTATE

GLSVfw

ICM_KEYFRAMERATE

GLSVfw

ICM_RESERVED

GLSVfw

ICM_RESERVED_HIGH

GLSVfw

ICM_RESERVED_LOW

GLSVfw

ICM_SET

GLSVfw

ICM_SETQUALITY

GLSVfw

ICM_SETSTATE

GLSVfw

ICM_SET_STATUS_PROC

GLSVfw

ICM_USER

GLSVfw

ICQUALITY_DEFAULT

GLSVfw

ICQUALITY_HIGH

GLSVfw

ICQUALITY_LOW

GLSVfw

ICSTATUS_END

GLSVfw

ICSTATUS_ERROR

GLSVfw

ICSTATUS_START

GLSVfw

ICSTATUS_STATUS

GLSVfw

ICSTATUS_YIELD

GLSVfw

ICTYPE_AUDIO

GLSVfw

ICTYPE_VIDEO

GLSVfw

ICVERSION

GLSVfw

IdentityHmgDblMatrix

VectorGeometry

IdentityHmgMatrix

VectorGeometry

IdentityMatrix

VectorGeometry

IdentityQuaternion

VectorGeometry

IDS_CAP_AUDIO_DROP_ERROR

GLSVfw

IDS_CAP_AVI_DRAWDIB_ERROR

GLSVfw

IDS_CAP_AVI_INIT_ERROR

GLSVfw

IDS_CAP_BEGIN

GLSVfw

IDS_CAP_CANTOPEN

GLSVfw

IDS_CAP_COMPRESSOR_ERROR

GLSVfw

IDS_CAP_DEFAVIEXT

GLSVfw

IDS_CAP_DEFPALEXT

GLSVfw

IDS_CAP_DRIVER_ERROR

GLSVfw

IDS_CAP_END

GLSVfw

IDS_CAP_ERRORDIBSAVE

GLSVfw

IDS_CAP_ERRORPALOPEN

GLSVfw

IDS_CAP_ERRORPALSAVE

GLSVfw

IDS_CAP_FILEEXISTS

GLSVfw

IDS_CAP_FILE_OPEN_ERROR

GLSVfw

IDS_CAP_FILE_WRITE_ERROR

GLSVfw

IDS_CAP_INFO

GLSVfw

IDS_CAP_MCI_CANT_STEP_ERROR

GLSVfw

IDS_CAP_MCI_CONTROL_ERROR

GLSVfw

IDS_CAP_NODISKSPACE

GLSVfw

IDS_CAP_NO_AUDIO_CAP_ERROR

GLSVfw

IDS_CAP_NO_FRAME_CAP_ERROR

GLSVfw

IDS_CAP_NO_PALETTE_WARN

GLSVfw

IDS_CAP_OUTOFMEM

GLSVfw

IDS_CAP_READONLYFILE

GLSVfw

IDS_CAP_RECORDING_ERROR

GLSVfw

IDS_CAP_RECORDING_ERROR2

GLSVfw

IDS_CAP_SAVEASPERCENT

GLSVfw

IDS_CAP_SEQ_MSGSTART

GLSVfw

IDS_CAP_SEQ_MSGSTOP

GLSVfw

IDS_CAP_SETFILESIZE

GLSVfw

IDS_CAP_STAT_CAP_AUDIO

GLSVfw

IDS_CAP_STAT_CAP_FINI

GLSVfw

IDS_CAP_STAT_CAP_INIT

GLSVfw

IDS_CAP_STAT_CAP_L_FRAMES

GLSVfw

IDS_CAP_STAT_FRAMESDROPPED

GLSVfw

IDS_CAP_STAT_I_FRAMES

GLSVfw

IDS_CAP_STAT_LIVE_MODE

GLSVfw

IDS_CAP_STAT_L_FRAMES

GLSVfw

IDS_CAP_STAT_OPTPAL_BUILD

GLSVfw

IDS_CAP_STAT_OVERLAY_MODE

GLSVfw

IDS_CAP_STAT_PALETTE_BUILD

GLSVfw

IDS_CAP_STAT_VIDEOAUDIO

GLSVfw

IDS_CAP_STAT_VIDEOCURRENT

GLSVfw

IDS_CAP_STAT_VIDEOONLY

GLSVfw

IDS_CAP_VIDEDITERR

GLSVfw

IDS_CAP_VIDEO_ADD_ERROR

GLSVfw

IDS_CAP_VIDEO_ALLOC_ERROR

GLSVfw

IDS_CAP_VIDEO_OPEN_ERROR

GLSVfw

IDS_CAP_VIDEO_PREPARE_ERROR

GLSVfw

IDS_CAP_VIDEO_SIZE_ERROR

GLSVfw

IDS_CAP_WAVE_ADD_ERROR

GLSVfw

IDS_CAP_WAVE_ALLOC_ERROR

GLSVfw

IDS_CAP_WAVE_OPEN_ERROR

GLSVfw

IDS_CAP_WAVE_PREPARE_ERROR

GLSVfw

IDS_CAP_WAVE_SIZE_ERROR

GLSVfw

IDS_CAP_WRITEERROR

GLSVfw

ID_ALPH

LWObjects

ID_ANIM

LWObjects

ID_BBOX

LWObjects

ID_BRIT

LWObjects

ID_BTEX

LWObjects

ID_CLIP

LWObjects

ID_COLR

LWObjects

ID_CONT

LWObjects

ID_CRVS

LWObjects

ID_CTEX

LWObjects

ID_DESC

LWObjects

ID_DIFF

LWObjects

ID_DTEX

LWObjects

ID_EDGE

LWObjects

ID_ENVL

LWObjects

ID_FLAG

LWObjects

ID_FLYR

LWObjects

ID_FORM

LWObjects

ID_GAMMA

LWObjects

ID_GLOS

LWObjects

ID_HUE

LWObjects

ID_ICON

LWObjects

ID_IFLT

LWObjects

ID_IMCC

LWObjects

ID_IMSQ

LWObjects

ID_ISEQ

LWObjects

ID_LAYR

LWObjects

ID_LTEX

LWObjects

ID_LUMI

LWObjects

ID_LWLO

LWObjects

ID_LWO2

LWObjects

ID_LWOB

LWObjects

ID_LWSC

LWObjects

ID_NEGA

LWObjects

ID_NULL

LWObjects

ID_PCHS

LWObjects

ID_PFLT

LWObjects

ID_PNTS

LWObjects

ID_POLS

LWObjects

ID_PTAG

LWObjects

ID_REFL

LWObjects

ID_RFLT

LWObjects

ID_RFOP

LWObjects

ID_RIMG

LWObjects

ID_RIND

LWObjects

ID_RSAN

LWObjects

ID_RTEX

LWObjects

ID_SATR

LWObjects

ID_SDAT

LWObjects

ID_SHDR

LWObjects

ID_SIDE

LWObjects

ID_SMAN

LWObjects

ID_SPEC

LWObjects

ID_SRFS

LWObjects

ID_STCC

LWObjects

ID_STEX

LWObjects

ID_STIL

LWObjects

ID_SURF

LWObjects

ID_TAAS

LWObjects

ID_TAGS

LWObjects

ID_TALP

LWObjects

ID_TAMP

LWObjects

ID_TCLR

LWObjects

ID_TCTR

LWObjects

ID_TEXT

LWObjects

ID_TFAL

LWObjects

ID_TFLG

LWObjects

ID_TFP0

LWObjects

ID_TFP1

LWObjects

ID_TFP2

LWObjects

ID_TFRQ

LWObjects

ID_TIMG

LWObjects

ID_TIP0

LWObjects

ID_TIP1

LWObjects

ID_TIP2

LWObjects

ID_TOPC

LWObjects

ID_TRAN

LWObjects

ID_TREF

LWObjects

ID_TSIZ

LWObjects

ID_TSP0

LWObjects

ID_TSP1

LWObjects

ID_TSP2

LWObjects

ID_TTEX

LWObjects

ID_TVAL

LWObjects

ID_TVEL

LWObjects

ID_TWRP

LWObjects

ID_VDIF

LWObjects

ID_VLUM

LWObjects

ID_VMAD

LWObjects

ID_VMAP

LWObjects

ID_VRFL

LWObjects

ID_VSPC

LWObjects

ID_VTRN

LWObjects

IID_IAVIEditStream

GLSVfw

IID_IAVIFile

GLSVfw

IID_IAVIStream

GLSVfw

IID_IAVIStreaming

GLSVfw

IID_IGetFrame

GLSVfw

IMSQ_FLAG_INTERLACE

LWObjects

IMSQ_FLAG_LOOP

LWObjects

infotypeDIGITIZATION_TIME

GLSVfw

infotypeSMPTE_TIME

GLSVfw

InitFaceArray3DS

Const3DS

InitMatArray3DS

Const3DS

InitNoExtras3DS

Const3DS

InitProcData3DS

Const3DS

InitSmoothArray3DS

Const3DS

InitTextArray3DS

Const3DS

InitVertexArray3DS

Const3DS

InitVFlagArray3DS

Const3DS

InstanceNameStrMax3DS

Const3DS

INSTANCE_NAME

Const3DS

INTERPCT

Const3DS

IntPercentageMax3DS

Const3DS

INT_PERCENTAGE

Const3DS

INVALID_CUFFT_HANDLE

GLS_CUDA_FourierTransform

INVALID_MODULEHANDLE_VALUE

GLSModuleLoader

IsChunk

Const3DS

JMSG_LENGTH_MAX

GLSJPG

JMSG_STR_PARM_MAX

GLSJPG

JointLibraryDLL

NewtonImport_JointLibrary

JOY_AXIS_THRESHOLD

GLSDL

JPEG_APP0

GLSJPG

JPEG_COM

GLSJPG

JPEG_EOI

GLSJPG

JPEG_HEADER_OK

GLSJPG

JPEG_HEADER_TABLES_ONLY

GLSJPG

JPEG_LIB_VERSION

GLSJPG

JPEG_REACHED_EOI

GLSJPG

JPEG_REACHED_SOS

GLSJPG

JPEG_ROW_COMPLETED

GLSJPG

JPEG_RST0

GLSJPG

JPEG_SCAN_COMPLETED

GLSJPG

JPEG_SUSPENDED

GLSJPG

JPOOL_IMAGE

GLSJPG

JPOOL_PERMANENT

GLSJPG

kBrushes

Q3BSP

kBrushSides

Q3BSP

kEntities

Q3BSP

KeyUsesBias3DS

Const3DS

KeyUsesCont3DS

Const3DS

KeyUsesEaseFrom3DS

Const3DS

KeyUsesEaseTo3DS

Const3DS

KeyUsesTension3DS

Const3DS

kFaces

Q3BSP

KFBiasMax3DS

Const3DS

KFBiasMin3DS

Const3DS

KfBlurBranch3DS

Const3DS

KFContinuityMax3DS

Const3DS

KFContinuityMin3DS

Const3DS

KFCURTIME

Const3DS

KFDATA

Const3DS

KFEaseFromMax3DS

Const3DS

KFEaseFromMin3DS

Const3DS

KFEaseToMax3DS

Const3DS

KFEaseToMin3DS

Const3DS

KfFastNode3DS

Const3DS

KFHDR

Const3DS

KFHdrStrMax3DS

Const3DS

KfHideNode3DS

Const3DS

KfMorphMtl3DS

Const3DS

KfMorphOb3DS

Const3DS

KfMotionBlur3DS

Const3DS

KfNodeAutoSmooth3DS

Const3DS

KfNodeFrozen3DS

Const3DS

KfNodeHasPath3DS

Const3DS

KfNodeOff3DS

Const3DS

KFSEG

Const3DS

KFTensionMax3DS

Const3DS

KFTensionMin3DS

Const3DS

kLeafBrushes

Q3BSP

kLeafFaces

Q3BSP

kLeafs

Q3BSP

kLightmaps

Q3BSP

kLightVolumes

Q3BSP

kMaxLumps

Q3BSP

kMeshVerts

Q3BSP

kModels

Q3BSP

KMOD_ALT

GLSDL

KMOD_CAPS

GLSDL

KMOD_CTRL

GLSDL

KMOD_LALT

GLSDL

KMOD_LCTRL

GLSDL

KMOD_LMETA

GLSDL

KMOD_LSHIFT

GLSDL

KMOD_META

GLSDL

KMOD_MODE

GLSDL

KMOD_NONE

GLSDL

KMOD_NUM

GLSDL

KMOD_RALT

GLSDL

KMOD_RCTRL

GLSDL

KMOD_RESERVED

GLSDL

KMOD_RMETA

GLSDL

KMOD_RSHIFT

GLSDL

KMOD_SHIFT

GLSDL

kNodes

Q3BSP

KNoID

Const3DS

kPlanes

Q3BSP

kShaders

Q3BSP

kTextures

Q3BSP

kVertices

Q3BSP

kVisData

Q3BSP

LayerFogBgnd

Const3DS

LAYER_FOG

Const3DS

libEGL

OpenGLTokens

libGLES2

OpenGLTokens

LibName

GLSDL

LibOpenCL

GLS_CL

LibPng13

LIBPNG

LIBPNG_VERSION

LIBPNG

libz

GLSZLibExApi

LIGHT_NODE_TAG

Const3DS

LineLen

GLFileOBJ

LIN_COLOR_24

Const3DS

LIN_COLOR_F

Const3DS

listtypeAVIHEADER

GLSVfw

listtypeAVIMOVIE

GLSVfw

listtypeAVIRECORD

GLSVfw

listtypeSTREAMHEADER

GLSVfw

llMax

GLSLog

llMedium

GLSLog

llMin

GLSLog

LMAGIC

Const3DS

LoShadowBiasMin3DS

Const3DS

LOWPASS_DEFAULT_GAIN

openal

LOWPASS_DEFAULT_GAINHF

openal

LOWPASS_MAX_GAIN

openal

LOWPASS_MAX_GAINHF

openal

LOWPASS_MIN_GAIN

openal

LOWPASS_MIN_GAINHF

openal

LO_SHADOW_BIAS

Const3DS

L_TARGET_NODE_TAG

Const3DS

M3DMAGIC

Const3DS

M3D_KFVERSION

Const3DS

M3D_VERSION

Const3DS

MARK_NODE

Const3DS

MasterScaleMin3DS

Const3DS

MASTER_SCALE

Const3DS

MatACubicAMax3DS

Const3DS

MatACubicAMin3DS

Const3DS

MatACubicFMin3DS

Const3DS

MATMAGIC

Const3DS

MatMapNameStrMax3DS

Const3DS

MatNameStrMax3DS

Const3DS

MatShadingMax3DS

Const3DS

MatShadingMin3DS

Const3DS

MAT_ACUBIC

Const3DS

MAT_ADDITIVE

Const3DS

MAT_AMBIENT

Const3DS

MAT_BUMPMAP

Const3DS

MAT_BUMPMASK

Const3DS

MAT_BUMP_PERCENT

Const3DS

MAT_DECAL

Const3DS

MAT_DIFFUSE

Const3DS

MAT_ENTRY

Const3DS

MAT_FACEMAP

Const3DS

MAT_MAPNAME

Const3DS

MAT_MAP_ANG

Const3DS

MAT_MAP_BCOL

Const3DS

MAT_MAP_COL1

Const3DS

MAT_MAP_COL2

Const3DS

MAT_MAP_GCOL

Const3DS

MAT_MAP_RCOL

Const3DS

MAT_MAP_TEXBLUR

Const3DS

MAT_MAP_TEXBLUR_OLD

Const3DS

MAT_MAP_TILING

Const3DS

MAT_MAP_TILINGOLD

Const3DS

MAT_MAP_UOFFSET

Const3DS

MAT_MAP_USCALE

Const3DS

MAT_MAP_VOFFSET

Const3DS

MAT_MAP_VSCALE

Const3DS

MAT_NAME

Const3DS

MAT_OPACMAP

Const3DS

MAT_OPACMASK

Const3DS

MAT_PHONGSOFT

Const3DS

MAT_REFBLUR

Const3DS

MAT_REFLMAP

Const3DS

MAT_REFLMASK

Const3DS

MAT_SELFIMAP

Const3DS

MAT_SELFIMASK

Const3DS

MAT_SELF_ILLUM

Const3DS

MAT_SELF_ILPCT

Const3DS

MAT_SHADING

Const3DS

MAT_SHIN2PCT

Const3DS

MAT_SHIN3PCT

Const3DS

MAT_SHININESS

Const3DS

MAT_SHINMAP

Const3DS

MAT_SHINMASK

Const3DS

MAT_SPECMAP

Const3DS

MAT_SPECMASK

Const3DS

MAT_SPECULAR

Const3DS

MAT_SUPERSMP

Const3DS

MAT_SXP_BUMP_DATA

Const3DS

MAT_SXP_BUMP_MASKDATA

Const3DS

MAT_SXP_OPAC_DATA

Const3DS

MAT_SXP_OPAC_MASKDATA

Const3DS

MAT_SXP_REFL_MASKDATA

Const3DS

MAT_SXP_SELFI_DATA

Const3DS

MAT_SXP_SELFI_MASKDATA

Const3DS

MAT_SXP_SHIN_DATA

Const3DS

MAT_SXP_SHIN_MASKDATA

Const3DS

MAT_SXP_SPEC_DATA

Const3DS

MAT_SXP_SPEC_MASKDATA

Const3DS

MAT_SXP_TEXT2_DATA

Const3DS

MAT_SXP_TEXT2_MASKDATA

Const3DS

MAT_SXP_TEXT_DATA

Const3DS

MAT_SXP_TEXT_MASKDATA

Const3DS

MAT_TEX2MAP

Const3DS

MAT_TEX2MASK

Const3DS

MAT_TEXMAP

Const3DS

MAT_TEXMASK

Const3DS

MAT_TRANSPARENCY

Const3DS

MAT_TWO_SIDE

Const3DS

MAT_USE_REFBLUR

Const3DS

MAT_USE_XPFALL

Const3DS

MAT_WIRE

Const3DS

MAT_WIREABS

Const3DS

MAT_WIRESIZE

Const3DS

MAT_XPFALL

Const3DS

MAT_XPFALLIN

Const3DS

MaxColorAttachments

GLFBO

MaxComp

VectorGeometry

MaxDouble

VectorGeometry

MaxExtended

VectorGeometry

MAXJSAMPLE

GLSJPG

MaxSingle

VectorGeometry

MaxUserClasses

ODEImport

MaxVideoModes

GLScreen

MAX_AXES

GLSDL

MAX_BUTTONS

GLSDL

MAX_COMPONENTS

GLSJPG

MAX_COMPS_IN_SCAN

GLSJPG

MAX_HARDWARE_LIGHT

GLState

MAX_HARDWARE_TEXTURE_UNIT

GLState

MAX_HARDWARE_UNIFORM_BUFFER_BINDING

GLState

MAX_JOYSTICKS

GLSDL

MAX_MATRIX_STACK_DEPTH

GLPipelineTransformation

MAX_MD2_FRAMES

TypesMD2

MAX_MD2_SKINNAME

TypesMD2

MAX_MD2_SKINS

TypesMD2

MAX_MD2_TRIANGLES

TypesMD2

MAX_MD2_VERTICES

TypesMD2

MAX_MS3D_GROUPS

TypesMS3D

MAX_MS3D_JOINTS

TypesMS3D

MAX_MS3D_KEYFRAMES

TypesMS3D

MAX_MS3D_MATERIALS

TypesMS3D

MAX_MS3D_TRIANGLES

TypesMS3D

MAX_MS3D_VERTICES

TypesMS3D

MAX_OBJECT_STACK_DEPTH

GLSelection

MAX_SAMP_FACTOR

GLSJPG

MAX_SHADER_LIGHT

GLState

MAX_TEXTURES

Q3BSP

MCIWNDF_NOAUTOSIZEMOVIE

GLSVfw

MCIWNDF_NOAUTOSIZEWINDOW

GLSVfw

MCIWNDF_NOERRORDLG

GLSVfw

MCIWNDF_NOMENU

GLSVfw

MCIWNDF_NOOPEN

GLSVfw

MCIWNDF_NOPLAYBAR

GLSVfw

MCIWNDF_NOTIFYALL

GLSVfw

MCIWNDF_NOTIFYANSI

GLSVfw

MCIWNDF_NOTIFYERROR

GLSVfw

MCIWNDF_NOTIFYMEDIA

GLSVfw

MCIWNDF_NOTIFYMEDIAA

GLSVfw

MCIWNDF_NOTIFYMEDIAW

GLSVfw

MCIWNDF_NOTIFYMODE

GLSVfw

MCIWNDF_NOTIFYPOS

GLSVfw

MCIWNDF_NOTIFYSIZE

GLSVfw

MCIWNDF_RECORD

GLSVfw

MCIWNDF_SHOWALL

GLSVfw

MCIWNDF_SHOWMODE

GLSVfw

MCIWNDF_SHOWNAME

GLSVfw

MCIWNDF_SHOWPOS

GLSVfw

MCIWNDM_CAN_CONFIG

GLSVfw

MCIWNDM_CAN_EJECT

GLSVfw

MCIWNDM_CAN_PLAY

GLSVfw

MCIWNDM_CAN_RECORD

GLSVfw

MCIWNDM_CAN_SAVE

GLSVfw

MCIWNDM_CAN_WINDOW

GLSVfw

MCIWNDM_CHANGESTYLES

GLSVfw

MCIWNDM_EJECT

GLSVfw

MCIWNDM_GETACTIVETIMER

GLSVfw

MCIWNDM_GETALIAS

GLSVfw

MCIWNDM_GETDEVICE

GLSVfw

MCIWNDM_GETDEVICEA

GLSVfw

MCIWNDM_GETDEVICEID

GLSVfw

MCIWNDM_GETDEVICEW

GLSVfw

MCIWNDM_GETEND

GLSVfw

MCIWNDM_GETERROR

GLSVfw

MCIWNDM_GETERRORA

GLSVfw

MCIWNDM_GETERRORW

GLSVfw

MCIWNDM_GETFILENAME

GLSVfw

MCIWNDM_GETFILENAMEA

GLSVfw

MCIWNDM_GETFILENAMEW

GLSVfw

MCIWNDM_GETINACTIVETIMER

GLSVfw

MCIWNDM_GETLENGTH

GLSVfw

MCIWNDM_GETMODE

GLSVfw

MCIWNDM_GETMODEA

GLSVfw

MCIWNDM_GETMODEW

GLSVfw

MCIWNDM_GETPALETTE

GLSVfw

MCIWNDM_GETPOSITION

GLSVfw

MCIWNDM_GETPOSITIONA

GLSVfw

MCIWNDM_GETPOSITIONW

GLSVfw

MCIWNDM_GETREPEAT

GLSVfw

MCIWNDM_GETSPEED

GLSVfw

MCIWNDM_GETSTART

GLSVfw

MCIWNDM_GETSTYLES

GLSVfw

MCIWNDM_GETTIMEFORMAT

GLSVfw

MCIWNDM_GETTIMEFORMATA

GLSVfw

MCIWNDM_GETTIMEFORMATW

GLSVfw

MCIWNDM_GETVOLUME

GLSVfw

MCIWNDM_GETZOOM

GLSVfw

MCIWNDM_GET_DEST

GLSVfw

MCIWNDM_GET_SOURCE

GLSVfw

MCIWNDM_NEW

GLSVfw

MCIWNDM_NEWA

GLSVfw

MCIWNDM_NEWW

GLSVfw

MCIWNDM_NOTIFYERROR

GLSVfw

MCIWNDM_NOTIFYMEDIA

GLSVfw

MCIWNDM_NOTIFYMODE

GLSVfw

MCIWNDM_NOTIFYPOS

GLSVfw

MCIWNDM_NOTIFYSIZE

GLSVfw

MCIWNDM_OPEN

GLSVfw

MCIWNDM_OPENA

GLSVfw

MCIWNDM_OPENINTERFACE

GLSVfw

MCIWNDM_OPENW

GLSVfw

MCIWNDM_PALETTEKICK

GLSVfw

MCIWNDM_PLAYFROM

GLSVfw

MCIWNDM_PLAYREVERSE

GLSVfw

MCIWNDM_PLAYTO

GLSVfw

MCIWNDM_PUT_DEST

GLSVfw

MCIWNDM_PUT_SOURCE

GLSVfw

MCIWNDM_REALIZE

GLSVfw

MCIWNDM_RETURNSTRING

GLSVfw

MCIWNDM_RETURNSTRINGA

GLSVfw

MCIWNDM_RETURNSTRINGW

GLSVfw

MCIWNDM_SENDSTRING

GLSVfw

MCIWNDM_SENDSTRINGA

GLSVfw

MCIWNDM_SENDSTRINGW

GLSVfw

MCIWNDM_SETACTIVETIMER

GLSVfw

MCIWNDM_SETINACTIVETIMER

GLSVfw

MCIWNDM_SETOWNER

GLSVfw

MCIWNDM_SETPALETTE

GLSVfw

MCIWNDM_SETREPEAT

GLSVfw

MCIWNDM_SETSPEED

GLSVfw

MCIWNDM_SETTIMEFORMAT

GLSVfw

MCIWNDM_SETTIMEFORMATA

GLSVfw

MCIWNDM_SETTIMEFORMATW

GLSVfw

MCIWNDM_SETTIMERS

GLSVfw

MCIWNDM_SETVOLUME

GLSVfw

MCIWNDM_SETZOOM

GLSVfw

MCIWNDM_VALIDATEMEDIA

GLSVfw

MCIWNDOPENF_NEW

GLSVfw

MCIWND_END

GLSVfw

MCIWND_START

GLSVfw

MCIWND_WINDOW_CLASS

GLSVfw

MDATA

Const3DS

MDCFILE_IDENTITY

TypesMDC

MDCFILE_VERSION

TypesMDC

MDC_BASEVERTEX_FACTOR

TypesMDC

MDC_COMPVERTEX_FACTOR

TypesMDC

MESH_COLOR

Const3DS

MESH_MATRIX

Const3DS

MESH_TEXTURE_INFO

Const3DS

MESH_VERSION

Const3DS

MidTexPoint

VectorGeometry

MinComp

VectorGeometry

MinDouble

VectorGeometry

MinExtended

VectorGeometry

MinSingle

VectorGeometry

MinusXVector

VectorGeometry

MinusYVector

VectorGeometry

MinusZVector

VectorGeometry

MLIBMAGIC

Const3DS

MorphSmoothMax3DS

Const3DS

MorphSmoothMin3DS

Const3DS

MorphTrackStrMax3DS

Const3DS

MORPH_SMOOTH

Const3DS

MORPH_TRACK_TAG

Const3DS

MORPH_TRACK_TAG_KEY

Const3DS

MRT_BUFFERS

GLContext

MshMatGroupMin3DS

Const3DS

MshMatGroupStrMax3DS

Const3DS

MSH_BOXMAP

Const3DS

MSH_MAT_GROUP

Const3DS

MSH_MAT_GROUP_ENTRY

Const3DS

M_BEVEL

Const3DS

M_FIT

Const3DS

M_SCALE

Const3DS

M_TEETER

Const3DS

M_TWIST

Const3DS

NamedObjectStrMax3DS

Const3DS

NAMED_OBJECT

Const3DS

NCameraFocMax3DS

Const3DS

NCameraFocMin3DS

Const3DS

NCameraFOVMax3DS

Const3DS

NCameraFOVMin3DS

Const3DS

NETWORK_VIEW

Const3DS

NewtonDLL

NewtonImport

NEWTON_MAJOR_VERSION

NewtonImport

NEWTON_MINOR_VERSION

NewtonImport

NEWTON_PROFILER_COLLISION_UPDATE

NewtonImport

NEWTON_PROFILER_COLLISION_UPDATE_BROAD_PHASE

NewtonImport

NEWTON_PROFILER_COLLISION_UPDATE_NARROW_PHASE

NewtonImport

NEWTON_PROFILER_DYNAMICS_CONSTRAINT_GRAPH

NewtonImport

NEWTON_PROFILER_DYNAMICS_SOLVE_CONSTRAINT_GRAPH

NewtonImport

NEWTON_PROFILER_DYNAMICS_UPDATE

NewtonImport

NEWTON_PROFILER_FORCE_CALLBACK_UPDATE

NewtonImport

NEWTON_PROFILER_WORLD_UPDATE

NewtonImport

NMF_HEADER_TAG

FileNMF

NMF_TRIANGLE_TAG

FileNMF

NodeHdrStrMax3DS

Const3DS

NodeTagCount

Const3DS

NodeTags

Const3DS

NODE_ANI_HIDDEN

Const3DS

NODE_AUTO_SMOOTH

Const3DS

NODE_BLUR_BRANCH

Const3DS

NODE_CALC_PATH

Const3DS

NODE_FROZEN

Const3DS

NODE_HAS_PATH

Const3DS

NODE_HDR

Const3DS

NODE_ID

Const3DS

NODE_MORPH_MTL

Const3DS

NODE_MORPH_OB

Const3DS

NODE_MOTION_BLUR

Const3DS

NODE_OFF

Const3DS

NODE_RENDOB_HIDE

Const3DS

NoFalloff

Const3DS

NotChunk

Const3DS

NullBoundingBox

GeometryBB

NullHmgPoint

VectorGeometry

NullHmgVector

VectorGeometry

NullTexPoint

VectorGeometry

NullVector

VectorGeometry

NULL_CHUNK

Const3DS

NUM_ARITH_TBLS

GLSJPG

NUM_HUFF_TBLS

GLSJPG

NUM_QUANT_TBLS

GLSJPG

N_AMBIENT_LIGHT

Const3DS

N_CAMERA

Const3DS

N_CAM_OLD

Const3DS

N_DIRECT_LIGHT

Const3DS

N_D_L_OLD

Const3DS

N_TRI_OBJECT

Const3DS

OBJECT_NODE_TAG

Const3DS

OBJ_DOESNT_CAST

Const3DS

OBJ_DONT_RCVSHADOW

Const3DS

OBJ_FAST

Const3DS

OBJ_FROZEN

Const3DS

OBJ_HIDDEN

Const3DS

OBJ_MATTE

Const3DS

OBJ_PROCEDURAL

Const3DS

OBJ_VIS_LOFTER

Const3DS

ODEDLL

ODEImport

OLD_MAT_GROUP

Const3DS

opengl32

OpenGLTokens

O_CONSTS

Const3DS

PARENT_NAME

Const3DS

PARENT_OBJECT

Const3DS

PATH_3D

Const3DS

PATH_MATRIX

Const3DS

PD_CAN_DRAW_DIB

GLSVfw

PD_CAN_STRETCHDIB

GLSVfw

PD_STRETCHDIB_1_1_OK

GLSVfw

PD_STRETCHDIB_1_2_OK

GLSVfw

PD_STRETCHDIB_1_N_OK

GLSVfw

PIVOT

Const3DS

PIVOT_LIMITS

Const3DS

PIVOT_OBJECT

Const3DS

PIVOT_ORDER

Const3DS

PNG_16_TO_8

LIBPNG

PNG_ADD_ALPHA

LIBPNG

PNG_AFTER_IDAT

LIBPNG

PNG_ALL_MNG_FEATURES

LIBPNG

PNG_BACKGROUND

LIBPNG

PNG_BACKGROUND_EXPAND

LIBPNG

PNG_BACKGROUND_GAMMA_FILE

LIBPNG

PNG_BACKGROUND_GAMMA_SCREEN

LIBPNG

PNG_BACKGROUND_GAMMA_UNIQUE

LIBPNG

PNG_BACKGROUND_GAMMA_UNKNOWN

LIBPNG

PNG_BACKGROUND_IS_GRAY

LIBPNG

PNG_BGR

LIBPNG

PNG_COLOR_MASK_ALPHA

LIBPNG

PNG_COLOR_MASK_COLOR

LIBPNG

PNG_COLOR_MASK_PALETTE

LIBPNG

PNG_COLOR_TYPE_GRAY

LIBPNG

PNG_COLOR_TYPE_GRAY_ALPHA

LIBPNG

PNG_COLOR_TYPE_PALETTE

LIBPNG

PNG_COLOR_TYPE_RGB

LIBPNG

PNG_COLOR_TYPE_RGB_ALPHA

LIBPNG

PNG_COMPRESSION_TYPE_BASE

LIBPNG

PNG_COMPRESSION_TYPE_DEFAULT

LIBPNG

PNG_DITHER

LIBPNG

PNG_EXPAND

LIBPNG

PNG_EXPAND_tRNS

LIBPNG

PNG_FILLER

LIBPNG

PNG_FILTER_TYPE_BASE

LIBPNG

PNG_FILTER_TYPE_DEFAULT

LIBPNG

PNG_FLAG_ADD_ALPHA

LIBPNG

PNG_FLAG_BENIGN_ERRORS_WARN

LIBPNG

PNG_FLAG_CRC_ANCILLARY_MASK

LIBPNG

PNG_FLAG_CRC_ANCILLARY_NOWARN

LIBPNG

PNG_FLAG_CRC_ANCILLARY_USE

LIBPNG

PNG_FLAG_CRC_CRITICAL_IGNORE

LIBPNG

PNG_FLAG_CRC_CRITICAL_MASK

LIBPNG

PNG_FLAG_CRC_CRITICAL_USE

LIBPNG

PNG_FLAG_CRC_MASK

LIBPNG

PNG_FLAG_FILLER_AFTER

LIBPNG

PNG_FLAG_KEEP_UNKNOWN_CHUNKS

LIBPNG

PNG_FLAG_KEEP_UNSAFE_CHUNKS

LIBPNG

PNG_FLAG_LIBRARY_MISMATCH

LIBPNG

PNG_FLAG_MALLOC_NULL_MEM_OK

LIBPNG

PNG_FLAG_MNG_EMPTY_PLTE

LIBPNG

PNG_FLAG_MNG_FILTER_64

LIBPNG

PNG_FLAG_ROW_INIT

LIBPNG

PNG_FLAG_STRIP_ALPHA

LIBPNG

PNG_FLAG_STRIP_ERROR_NUMBERS

LIBPNG

PNG_FLAG_STRIP_ERROR_TEXT

LIBPNG

PNG_FLAG_ZLIB_CUSTOM_LEVEL

LIBPNG

PNG_FLAG_ZLIB_CUSTOM_MEM_LEVEL

LIBPNG

PNG_FLAG_ZLIB_CUSTOM_METHOD

LIBPNG

PNG_FLAG_ZLIB_CUSTOM_STRATEGY

LIBPNG

PNG_FLAG_ZLIB_CUSTOM_WINDOW_BITS

LIBPNG

PNG_FLAG_ZLIB_FINISHED

LIBPNG

PNG_FREE_ALL

LIBPNG

PNG_FREE_HIST

LIBPNG

PNG_FREE_ICCP

LIBPNG

PNG_FREE_LIST

LIBPNG

PNG_FREE_MUL

LIBPNG

PNG_FREE_PCAL

LIBPNG

PNG_FREE_PLTE

LIBPNG

PNG_FREE_ROWS

LIBPNG

PNG_FREE_SCAL

LIBPNG

PNG_FREE_SPLT

LIBPNG

PNG_FREE_TEXT

LIBPNG

PNG_FREE_TRNS

LIBPNG

PNG_FREE_UNKN

LIBPNG

PNG_GAMMA

LIBPNG

PNG_GAMMA_THRESHOLD

LIBPNG

PNG_GRAY_TO_RGB

LIBPNG

PNG_HAVE_cHRM

LIBPNG

PNG_HAVE_CHUNK_AFTER_IDAT

LIBPNG

PNG_HAVE_CHUNK_HEADER

LIBPNG

PNG_HAVE_gAMA

LIBPNG

PNG_HAVE_IDAT

LIBPNG

PNG_HAVE_IEND

LIBPNG

PNG_HAVE_IHDR

LIBPNG

PNG_HAVE_PLTE

LIBPNG

PNG_HAVE_PNG_SIGNATURE

LIBPNG

PNG_HAVE_sRGB

LIBPNG

PNG_INFO_bKGD

LIBPNG

PNG_INFO_cHRM

LIBPNG

PNG_INFO_gAMA

LIBPNG

PNG_INFO_hIST

LIBPNG

PNG_INFO_iCCP

LIBPNG

PNG_INFO_IDAT

LIBPNG

PNG_INFO_oFFs

LIBPNG

PNG_INFO_pCAL

LIBPNG

PNG_INFO_pHYs

LIBPNG

PNG_INFO_PLTE

LIBPNG

PNG_INFO_sBIT

LIBPNG

PNG_INFO_sCAL

LIBPNG

PNG_INFO_sPLT

LIBPNG

PNG_INFO_sRGB

LIBPNG

PNG_INFO_tIME

LIBPNG

PNG_INFO_tRNS

LIBPNG

PNG_INTERLACE

LIBPNG

PNG_INTERLACE_ADAM7

LIBPNG

PNG_INTERLACE_LAST

LIBPNG

PNG_INTERLACE_NONE

LIBPNG

PNG_INTRAPIXEL_DIFFERENCING

LIBPNG

PNG_INVERT_ALPHA

LIBPNG

PNG_INVERT_MONO

LIBPNG

PNG_PACK

LIBPNG

PNG_PACKSWAP

LIBPNG

PNG_RGBA

LIBPNG

PNG_RGB_TO_GRAY

LIBPNG

PNG_RGB_TO_GRAY_ERR

LIBPNG

PNG_RGB_TO_GRAY_WARN

LIBPNG

PNG_SHIFT

LIBPNG

PNG_STRIP_ALPHA

LIBPNG

PNG_SWAP_ALPHA

LIBPNG

PNG_SWAP_BYTES

LIBPNG

PNG_UINT_31_MAX

LIBPNG

PNG_UINT_32_MAX

LIBPNG

PNG_USER_HEIGHT_MAX

LIBPNG

PNG_USER_TRANSFORM

LIBPNG

PNG_USER_WIDTH_MAX

LIBPNG

PNG_WROTE_INFO_BEFORE_PLTE

LIBPNG

PNG_WROTE_tIME

LIBPNG

PointArrayMin3DS

Const3DS

POINT_ARRAY

Const3DS

POINT_ARRAY_ENTRY

Const3DS

POINT_FLAG_ARRAY

Const3DS

POINT_FLAG_ARRAY_ENTRY

Const3DS

POLS_FLAGS_MASK

LWObjects

POLS_TYPE_BONE

LWObjects

POLS_TYPE_CURV

LWObjects

POLS_TYPE_FACE

LWObjects

POLS_TYPE_MBAL

LWObjects

POLS_TYPE_PTCH

LWObjects

POLS_VCOUNT_MASK

LWObjects

POLY_2D

Const3DS

POS_TRACK_TAG

Const3DS

POS_TRACK_TAG_KEY

Const3DS

PRESCALE

Const3DS

PRE_POST_CONSTANT

LWObjects

PRE_POST_LINEAR

LWObjects

PRE_POST_OFFSET

LWObjects

PRE_POST_OSCILLATE

LWObjects

PRE_POST_REPEAT

LWObjects

PRE_POST_RESET

LWObjects

PRIMARY_NODE

Const3DS

ProcNameStrMax3DS

Const3DS

PROC_DATA

Const3DS

PROC_NAME

Const3DS

psInsideFrame

GLCrossPlatform

PTAG_TYPE_PART

LWObjects

PTAG_TYPE_SMGP

LWObjects

PTAG_TYPE_SURF

LWObjects

P_ALPHANEG

Const3DS

P_ALPH_ALPHA

Const3DS

P_ALPH_BLUR

Const3DS

P_ALPH_C0

Const3DS

P_ALPH_CUTOFF

Const3DS

P_ALPH_IMAGE

Const3DS

P_ALPH_KCOL

Const3DS

P_ALPH_NONE

Const3DS

P_ALPH_OP_KEY

Const3DS

P_ALPH_OP_NOCONV

Const3DS

P_ALPH_OP_PSEUDO

Const3DS

P_ALPH_PCOL

Const3DS

P_ALPH_PSEUDO

Const3DS

P_ALPH_QUEIMG

Const3DS

P_ALPH_QUES

Const3DS

P_CUSTOM_SIZE

Const3DS

P_PROC_DATA

Const3DS

P_QUEUE_ALIGN

Const3DS

P_QUEUE_ENTRY

Const3DS

P_QUEUE_GRADIENT

Const3DS

P_QUEUE_IMAGE

Const3DS

P_QUEUE_KF

Const3DS

P_QUEUE_MB_REPEAT

Const3DS

P_QUEUE_MOTBLUR

Const3DS

P_QUEUE_NONE

Const3DS

P_QUEUE_OFFSET

Const3DS

P_QUEUE_PROC

Const3DS

P_QUEUE_RESIZE

Const3DS

P_QUEUE_SOLID

Const3DS

P_QUEUE_USEIGAMMA

Const3DS

P_RANGES

Const3DS

P_TRANNEG

Const3DS

P_TRAN_FADEIN

Const3DS

P_TRAN_FADEOUT

Const3DS

P_TRAN_FRAMES

Const3DS

P_TRAN_IMAGE

Const3DS

P_TRAN_NONE

Const3DS

QW_ERROR

Bass

RAY_BIAS

Const3DS

rBaseFormLocalizedDescription

GLSceneFormDesign

rBaseFormLocalizedName

GLSceneFormDesign

rBaseProjectLocalizedDescription

GLSceneFormDesign

rBaseProjectLocalizedName

GLSceneFormDesign

RelAll3DS

Const3DS

RelFaceArray3ds

Const3DS

RelMatArray3ds

Const3DS

RelProcData3ds

Const3DS

RelSmoothArray3ds

Const3DS

RelTextArray3ds

Const3DS

RelVertexArray3ds

Const3DS

RelVFlagArray3ds

Const3DS

rExtendedFormLocalizedDescription

GLSceneFormDesign

rExtendedFormLocalizedName

GLSceneFormDesign

rExtendedProjectLocalizedDescription

GLSceneFormDesign

rExtendedProjectLocalizedName

GLSceneFormDesign

RFOP_BACKDROP

LWObjects

RFOP_RAYTRACEANDBACKDROP

LWObjects

RFOP_RAYTRACEANDSPHERICALMAP

LWObjects

RFOP_SPHERICALMAP

LWObjects

ROLL_TRACK_TAG

Const3DS

ROLL_TRACK_TAG_KEY

Const3DS

ROT_TRACK_TAG

Const3DS

ROT_TRACK_TAG_KEY

Const3DS

rSimpleFormLocalizedDescription

GLSceneFormDesign

rSimpleFormLocalizedName

GLSceneFormDesign

rSimpleProjectLocalizedDescription

GLSceneFormDesign

rSimpleProjectLocalizedName

GLSceneFormDesign

rstrNothing

GLSLParameter

SCENE_SELECTED

GLSceneEdit

SCENE_SELECTED

GLSceneEditLCL

SCL_TRACK_TAG

Const3DS

SCL_TRACK_TAG_KEY

Const3DS

SDLK_0

GLSDL

SDLK_1

GLSDL

SDLK_2

GLSDL

SDLK_3

GLSDL

SDLK_4

GLSDL

SDLK_5

GLSDL

SDLK_6

GLSDL

SDLK_7

GLSDL

SDLK_8

GLSDL

SDLK_9

GLSDL

SDLK_a

GLSDL

SDLK_AMPERSAND

GLSDL

SDLK_ASTERISK

GLSDL

SDLK_AT

GLSDL

SDLK_b

GLSDL

SDLK_BACKQUOTE

GLSDL

SDLK_BACKSLASH

GLSDL

SDLK_BACKSPACE

GLSDL

SDLK_BREAK

GLSDL

SDLK_c

GLSDL

SDLK_CAPSLOCK

GLSDL

SDLK_CARET

GLSDL

SDLK_CLEAR

GLSDL

SDLK_COLON

GLSDL

SDLK_COMMA

GLSDL

SDLK_COMPOSE

GLSDL

SDLK_d

GLSDL

SDLK_DELETE

GLSDL

SDLK_DOLLAR

GLSDL

SDLK_DOWN

GLSDL

SDLK_e

GLSDL

SDLK_END

GLSDL

SDLK_EQUALS

GLSDL

SDLK_ESCAPE

GLSDL

SDLK_EURO

GLSDL

SDLK_EXCLAIM

GLSDL

SDLK_f

GLSDL

SDLK_F1

GLSDL

SDLK_F10

GLSDL

SDLK_F11

GLSDL

SDLK_F12

GLSDL

SDLK_F13

GLSDL

SDLK_F14

GLSDL

SDLK_F15

GLSDL

SDLK_F2

GLSDL

SDLK_F3

GLSDL

SDLK_F4

GLSDL

SDLK_F5

GLSDL

SDLK_F6

GLSDL

SDLK_F7

GLSDL

SDLK_F8

GLSDL

SDLK_F9

GLSDL

SDLK_FIRST

GLSDL

SDLK_g

GLSDL

SDLK_GREATER

GLSDL

SDLK_h

GLSDL

SDLK_HASH

GLSDL

SDLK_HELP

GLSDL

SDLK_HOME

GLSDL

SDLK_i

GLSDL

SDLK_INSERT

GLSDL

SDLK_j

GLSDL

SDLK_k

GLSDL

SDLK_KP0

GLSDL

SDLK_KP1

GLSDL

SDLK_KP2

GLSDL

SDLK_KP3

GLSDL

SDLK_KP4

GLSDL

SDLK_KP5

GLSDL

SDLK_KP6

GLSDL

SDLK_KP7

GLSDL

SDLK_KP8

GLSDL

SDLK_KP9

GLSDL

SDLK_KP_DIVIDE

GLSDL

SDLK_KP_ENTER

GLSDL

SDLK_KP_EQUALS

GLSDL

SDLK_KP_MINUS

GLSDL

SDLK_KP_MULTIPLY

GLSDL

SDLK_KP_PERIOD

GLSDL

SDLK_KP_PLUS

GLSDL

SDLK_l

GLSDL

SDLK_LALT

GLSDL

SDLK_LCTRL

GLSDL

SDLK_LEFT

GLSDL

SDLK_LEFTBRACKET

GLSDL

SDLK_LEFTPAREN

GLSDL

SDLK_LESS

GLSDL

SDLK_LMETA

GLSDL

SDLK_LSHIFT

GLSDL

SDLK_LSUPER

GLSDL

SDLK_m

GLSDL

SDLK_MENU

GLSDL

SDLK_MINUS

GLSDL

SDLK_MODE

GLSDL

SDLK_n

GLSDL

SDLK_NUMLOCK

GLSDL

SDLK_o

GLSDL

SDLK_p

GLSDL

SDLK_PAGEDOWN

GLSDL

SDLK_PAGEUP

GLSDL

SDLK_PAUSE

GLSDL

SDLK_PERIOD

GLSDL

SDLK_PLUS

GLSDL

SDLK_POWER

GLSDL

SDLK_PRINT

GLSDL

SDLK_q

GLSDL

SDLK_QUESTION

GLSDL

SDLK_QUOTE

GLSDL

SDLK_QUOTEDBL

GLSDL

SDLK_r

GLSDL

SDLK_RALT

GLSDL

SDLK_RCTRL

GLSDL

SDLK_RETURN

GLSDL

SDLK_RIGHT

GLSDL

SDLK_RIGHTBRACKET

GLSDL

SDLK_RIGHTPAREN

GLSDL

SDLK_RMETA

GLSDL

SDLK_RSHIFT

GLSDL

SDLK_RSUPER

GLSDL

SDLK_s

GLSDL

SDLK_SCROLLOCK

GLSDL

SDLK_SEMICOLON

GLSDL

SDLK_SLASH

GLSDL

SDLK_SPACE

GLSDL

SDLK_SYSREQ

GLSDL

SDLK_t

GLSDL

SDLK_TAB

GLSDL

SDLK_u

GLSDL

SDLK_UNDERSCORE

GLSDL

SDLK_UNKNOWN

GLSDL

SDLK_UP

GLSDL

SDLK_v

GLSDL

SDLK_w

GLSDL

SDLK_WORLD_0

GLSDL

SDLK_WORLD_1

GLSDL

SDLK_WORLD_10

GLSDL

SDLK_WORLD_11

GLSDL

SDLK_WORLD_12

GLSDL

SDLK_WORLD_13

GLSDL

SDLK_WORLD_14

GLSDL

SDLK_WORLD_15

GLSDL

SDLK_WORLD_16

GLSDL

SDLK_WORLD_17

GLSDL

SDLK_WORLD_18

GLSDL

SDLK_WORLD_19

GLSDL

SDLK_WORLD_2

GLSDL

SDLK_WORLD_20

GLSDL

SDLK_WORLD_21

GLSDL

SDLK_WORLD_22

GLSDL

SDLK_WORLD_23

GLSDL

SDLK_WORLD_24

GLSDL

SDLK_WORLD_25

GLSDL

SDLK_WORLD_26

GLSDL

SDLK_WORLD_27

GLSDL

SDLK_WORLD_28

GLSDL

SDLK_WORLD_29

GLSDL

SDLK_WORLD_3

GLSDL

SDLK_WORLD_30

GLSDL

SDLK_WORLD_31

GLSDL

SDLK_WORLD_32

GLSDL

SDLK_WORLD_33

GLSDL

SDLK_WORLD_34

GLSDL

SDLK_WORLD_35

GLSDL

SDLK_WORLD_36

GLSDL

SDLK_WORLD_37

GLSDL

SDLK_WORLD_38

GLSDL

SDLK_WORLD_39

GLSDL

SDLK_WORLD_4

GLSDL

SDLK_WORLD_40

GLSDL

SDLK_WORLD_41

GLSDL

SDLK_WORLD_42

GLSDL

SDLK_WORLD_43

GLSDL

SDLK_WORLD_44

GLSDL

SDLK_WORLD_45

GLSDL

SDLK_WORLD_46

GLSDL

SDLK_WORLD_47

GLSDL

SDLK_WORLD_48

GLSDL

SDLK_WORLD_49

GLSDL

SDLK_WORLD_5

GLSDL

SDLK_WORLD_50

GLSDL

SDLK_WORLD_51

GLSDL

SDLK_WORLD_52

GLSDL

SDLK_WORLD_53

GLSDL

SDLK_WORLD_54

GLSDL

SDLK_WORLD_55

GLSDL

SDLK_WORLD_56

GLSDL

SDLK_WORLD_57

GLSDL

SDLK_WORLD_58

GLSDL

SDLK_WORLD_59

GLSDL

SDLK_WORLD_6

GLSDL

SDLK_WORLD_60

GLSDL

SDLK_WORLD_61

GLSDL

SDLK_WORLD_62

GLSDL

SDLK_WORLD_63

GLSDL

SDLK_WORLD_64

GLSDL

SDLK_WORLD_65

GLSDL

SDLK_WORLD_66

GLSDL

SDLK_WORLD_67

GLSDL

SDLK_WORLD_68

GLSDL

SDLK_WORLD_69

GLSDL

SDLK_WORLD_7

GLSDL

SDLK_WORLD_70

GLSDL

SDLK_WORLD_71

GLSDL

SDLK_WORLD_72

GLSDL

SDLK_WORLD_73

GLSDL

SDLK_WORLD_74

GLSDL

SDLK_WORLD_75

GLSDL

SDLK_WORLD_76

GLSDL

SDLK_WORLD_77

GLSDL

SDLK_WORLD_78

GLSDL

SDLK_WORLD_79

GLSDL

SDLK_WORLD_8

GLSDL

SDLK_WORLD_80

GLSDL

SDLK_WORLD_81

GLSDL

SDLK_WORLD_82

GLSDL

SDLK_WORLD_83

GLSDL

SDLK_WORLD_84

GLSDL

SDLK_WORLD_85

GLSDL

SDLK_WORLD_86

GLSDL

SDLK_WORLD_87

GLSDL

SDLK_WORLD_88

GLSDL

SDLK_WORLD_89

GLSDL

SDLK_WORLD_9

GLSDL

SDLK_WORLD_90

GLSDL

SDLK_WORLD_91

GLSDL

SDLK_WORLD_92

GLSDL

SDLK_WORLD_93

GLSDL

SDLK_WORLD_94

GLSDL

SDLK_WORLD_95

GLSDL

SDLK_x

GLSDL

SDLK_y

GLSDL

SDLK_z

GLSDL

SDL_ACTIVEEVENT

GLSDL

SDL_ACTIVEEVENTMASK

GLSDL

SDL_ALLEVENTS

GLSDL

SDL_ALL_HOTKEYS

GLSDL

SDL_ALPHA_OPAQUE

GLSDL

SDL_ALPHA_TRANSPARENT

GLSDL

SDL_ANYFORMAT

GLSDL

SDL_APPACTIVE

GLSDL

SDL_APPINPUTFOCUS

GLSDL

SDL_APPMOUSEFOCUS

GLSDL

SDL_ASYNCBLIT

GLSDL

SDL_AUDIO_TRACK

GLSDL

SDL_BIG_ENDIAN

GLSDL

SDL_BUTTON_LEFT

GLSDL

SDL_BUTTON_LMASK

GLSDL

SDL_BUTTON_MIDDLE

GLSDL

SDL_BUTTON_MMASK

GLSDL

SDL_BUTTON_RIGHT

GLSDL

SDL_BUTTON_RMask

GLSDL

SDL_BYTEORDER

GLSDL

SDL_DATA_TRACK

GLSDL

SDL_DEFAULT_REPEAT_DELAY

GLSDL

SDL_DEFAULT_REPEAT_INTERVAL

GLSDL

SDL_DISABLE

GLSDL

SDL_DOUBLEBUF

GLSDL

SDL_ENABLE

GLSDL

SDL_EVENT_RESERVED

GLSDL

SDL_EVENT_RESERVED2

GLSDL

SDL_EVENT_RESERVED3

GLSDL

SDL_EVENT_RESERVED4

GLSDL

SDL_EVENT_RESERVED5

GLSDL

SDL_EVENT_RESERVED6

GLSDL

SDL_EVENT_RESERVED7

GLSDL

SDL_EVENT_RESERVEDA

GLSDL

SDL_FULLSCREEN

GLSDL

SDL_HAT_CENTERED

GLSDL

SDL_HAT_DOWN

GLSDL

SDL_HAT_LEFT

GLSDL

SDL_HAT_LEFTDOWN

GLSDL

SDL_HAT_LEFTUP

GLSDL

SDL_HAT_RIGHT

GLSDL

SDL_HAT_RIGHTDOWN

GLSDL

SDL_HAT_RIGHTUP

GLSDL

SDL_HAT_UP

GLSDL

SDL_HWACCEL

GLSDL

SDL_HWPALETTE

GLSDL

SDL_HWSURFACE

GLSDL

SDL_IGNORE

GLSDL

SDL_INIT_AUDIO

GLSDL

SDL_INIT_CDROM

GLSDL

SDL_INIT_EVENTTHREAD

GLSDL

SDL_INIT_EVERYTHING

GLSDL

SDL_INIT_JOYSTICK

GLSDL

SDL_INIT_NOPARACHUTE

GLSDL

SDL_INIT_TIMER

GLSDL

SDL_INIT_VIDEO

GLSDL

SDL_IYUV_OVERLAY

GLSDL

SDL_JOYAXISMOTION

GLSDL

SDL_JOYAXISMOTIONMASK

GLSDL

SDL_JOYBALLMOTION

GLSDL

SDL_JOYBALLMOTIONMASK

GLSDL

SDL_JOYBUTTONDOWN

GLSDL

SDL_JOYBUTTONDOWNMASK

GLSDL

SDL_JOYBUTTONUP

GLSDL

SDL_JOYBUTTONUPMASK

GLSDL

SDL_JOYEVENTMASK

GLSDL

SDL_JOYHATMOTION

GLSDL

SDL_JOYHATMOTIONMASK

GLSDL

SDL_KEYDOWN

GLSDL

SDL_KEYDOWNMASK

GLSDL

SDL_KEYUP

GLSDL

SDL_KEYUPMASK

GLSDL

SDL_LIL_ENDIAN

GLSDL

SDL_LOGPAL

GLSDL

SDL_MAJOR_VERSION

GLSDL

SDL_MAX_TRACKS

GLSDL

SDL_MINOR_VERSION

GLSDL

SDL_MIX_MAXVOLUME

GLSDL

SDL_MOUSEBUTTONDOWN

GLSDL

SDL_MOUSEBUTTONDOWNMASK

GLSDL

SDL_MOUSEBUTTONUP

GLSDL

SDL_MOUSEBUTTONUPMASK

GLSDL

SDL_MOUSEEVENTMASK

GLSDL

SDL_MOUSEMOTION

GLSDL

SDL_MOUSEMOTIONMASK

GLSDL

SDL_MUTEX_MAXWAIT

GLSDL

SDL_MUTEX_TIMEDOUT

GLSDL

SDL_NOEVENT

GLSDL

SDL_NOFRAME

GLSDL

SDL_NUMEVENTS

GLSDL

SDL_OPENGL

GLSDL

SDL_OPENGLBLIT

GLSDL

SDL_PATCHLEVEL

GLSDL

SDL_PHYSPAL

GLSDL

SDL_PREALLOC

GLSDL

SDL_PRESSED

GLSDL

SDL_QUERY

GLSDL

SDL_QUITEV

GLSDL

SDL_QUITMASK

GLSDL

SDL_RELEASED

GLSDL

SDL_RESIZABLE

GLSDL

SDL_RLEACCEL

GLSDL

SDL_RLEACCELOK

GLSDL

SDL_SRCALPHA

GLSDL

SDL_SRCCLIPPING

GLSDL

SDL_SRCCOLORKEY

GLSDL

SDL_SWSURFACE

GLSDL

SDL_SYSWMEVENT

GLSDL

SDL_SYSWMEVENTMASK

GLSDL

SDL_TIMESLICE

GLSDL

SDL_USEREVENT

GLSDL

SDL_UYVY_OVERLAY

GLSDL

SDL_VIDEOEXPOSE

GLSDL

SDL_VIDEORESIZE

GLSDL

SDL_VIDEORESIZEMASK

GLSDL

SDL_YUY2_OVERLAY

GLSDL

SDL_YV12_OVERLAY

GLSDL

SDL_YVYU_OVERLAY

GLSDL

SEARCH_ANY

GLSVfw

SEARCH_BACKWARD

GLSVfw

SEARCH_FORWARD

GLSVfw

SEARCH_KEY

GLSVfw

SEARCH_NEAREST

GLSVfw

SERIALIZE_ID_BOX

NewtonImport

SERIALIZE_ID_CAPSULE

NewtonImport

SERIALIZE_ID_CHAMFERCYLINDER

NewtonImport

SERIALIZE_ID_COMPOUND

NewtonImport

SERIALIZE_ID_COMPOUND_BREAKABLE

NewtonImport

SERIALIZE_ID_CONE

NewtonImport

SERIALIZE_ID_CONVEXHULL

NewtonImport

SERIALIZE_ID_CONVEXMODIFIER

NewtonImport

SERIALIZE_ID_CYLINDER

NewtonImport

SERIALIZE_ID_HEIGHTFIELD

NewtonImport

SERIALIZE_ID_NULL

NewtonImport

SERIALIZE_ID_SCENE

NewtonImport

SERIALIZE_ID_SPHERE

NewtonImport

SERIALIZE_ID_TREE

NewtonImport

SERIALIZE_ID_USERMESH

NewtonImport

ShadowFilterMax3DS

Const3DS

ShadowFilterMin3DS

Const3DS

ShadowMapSizeMin3DS

Const3DS

ShadowRangeMin3DS

Const3DS

ShadowSamplesMin3DS

Const3DS

SHADOW_FILTER

Const3DS

SHADOW_MAP_SIZE

Const3DS

SHADOW_RANGE

Const3DS

SHADOW_SAMPLES

Const3DS

SHAPE_2D

Const3DS

SHAPE_HOOK

Const3DS

SHAPE_NOT_OK

Const3DS

SHAPE_OK

Const3DS

SIDE_BACK

LWObjects

SIDE_FRONT

LWObjects

SIDE_FRONT_AND_BACK

LWObjects

SIGN

GLVfsPAK

SIGN

GLFileZLIB

SIGN

GLFilePAK

SIGN_COMPRESSED

GLVfsPAK

SMAGIC

Const3DS

Smooth01Group3DS

Const3DS

Smooth02Group3DS

Const3DS

Smooth03Group3DS

Const3DS

Smooth04Group3DS

Const3DS

Smooth05Group3DS

Const3DS

Smooth06Group3DS

Const3DS

Smooth07Group3DS

Const3DS

Smooth08Group3DS

Const3DS

Smooth09Group3DS

Const3DS

Smooth10Group3DS

Const3DS

Smooth11Group3DS

Const3DS

Smooth12Group3DS

Const3DS

Smooth13Group3DS

Const3DS

Smooth14Group3DS

Const3DS

Smooth15Group3DS

Const3DS

Smooth16Group3DS

Const3DS

Smooth17Group3DS

Const3DS

Smooth18Group3DS

Const3DS

Smooth19Group3DS

Const3DS

Smooth20Group3DS

Const3DS

Smooth21Group3DS

Const3DS

Smooth22Group3DS

Const3DS

Smooth23Group3DS

Const3DS

Smooth24Group3DS

Const3DS

Smooth25Group3DS

Const3DS

Smooth26Group3DS

Const3DS

Smooth27Group3DS

Const3DS

Smooth28Group3DS

Const3DS

Smooth29Group3DS

Const3DS

Smooth30Group3DS

Const3DS

Smooth31Group3DS

Const3DS

Smooth32Group3DS

Const3DS

SMOOTH_GROUP

Const3DS

SMOOTH_GROUP_ENTRY

Const3DS

SOLID_BGND

Const3DS

sOpenGLCategoryName

GLSceneRegister

SPOTLIGHT_NODE_TAG

Const3DS

streamtypeAUDIO

GLSVfw

streamtypeMIDI

GLSVfw

streamtypeTEXT

GLSVfw

streamtypeVIDEO

GLSVfw

SURF_FLAG_ADDITIVE

LWObjects

SURF_FLAG_COLORFILTER

LWObjects

SURF_FLAG_COLORHIGHLIGHTS

LWObjects

SURF_FLAG_DOUBLESIDED

LWObjects

SURF_FLAG_LUMINOUS

LWObjects

SURF_FLAG_OPAQUEEDGE

LWObjects

SURF_FLAG_OUTLINE

LWObjects

SURF_FLAG_SHADOWALPHA

LWObjects

SURF_FLAG_SHARPTERMINATOR

LWObjects

SURF_FLAG_SMOOTHING

LWObjects

SURF_FLAG_TRANSPARENTEDGE

LWObjects

T1_MAX_MM_AXIS

LIBFREETYPE

TARGET_NODE_TAG

Const3DS

TEX_ALPHA_SOURCE

Const3DS

TEX_DECAL

Const3DS

TEX_DONT_USE_ALPHA

Const3DS

TEX_INVERT

Const3DS

TEX_MIRROR

Const3DS

TEX_NOWRAP

Const3DS

TEX_RGB_TINT

Const3DS

TEX_SAT

Const3DS

TEX_TINT

Const3DS

TEX_UNUSED1

Const3DS

TEX_VERTS

Const3DS

TEX_VERTS_ENTRY

Const3DS

TIMER_RESOLUTION

GLSDL

TopFalloff

Const3DS

TrackHeaderKeysMin3DS

Const3DS

TrackLockX3DS

Const3DS

TrackLockY3DS

Const3DS

TrackLockZ3DS

Const3DS

TrackLoops3DS

Const3DS

TrackNoLinkX3DS

Const3DS

TrackNoLinkY3DS

Const3DS

TrackNoLinkZ3DS

Const3DS

TrackRepeats3DS

Const3DS

TrackSingle3DS

Const3DS

TRIMESH_FACE_NORMALS

ODEImport

TRIMESH_LAST_TRANSFORMATION

ODEImport

TypByteID

dws2OpenGLAdapter

TypCardinalID

dws2OpenGLAdapter

USE_BEVEL

Const3DS

USE_BIT_MAP

Const3DS

USE_CONTOUR

Const3DS

USE_DISTANCE_CUE

Const3DS

USE_FIT

Const3DS

USE_FOG

Const3DS

USE_LAYER_FOG

Const3DS

USE_SCALE

Const3DS

USE_SOLID_BGND

Const3DS

USE_TEETER

Const3DS

USE_TWEEN

Const3DS

USE_TWIST

Const3DS

USE_V_GRADIENT

Const3DS

VCAPS_CAN_SCALE

GLSVfw

VCAPS_DST_CAN_CLIP

GLSVfw

VCAPS_OVERLAY

GLSVfw

VCAPS_SRC_CAN_CLIP

GLSVfw

VDPAU_INTERFACE_VERSION

GLS_VDPAU_API

VDPAU_VERSION

GLS_VDPAU_API

VDP_BITSTREAM_BUFFER_VERSION

GLS_VDPAU_API

VDP_CHROMA_TYPE_420

GLS_VDPAU_API

VDP_CHROMA_TYPE_422

GLS_VDPAU_API

VDP_CHROMA_TYPE_444

GLS_VDPAU_API

VDP_COLOR_STANDARD_ITUR_BT_601

GLS_VDPAU_API

VDP_COLOR_STANDARD_ITUR_BT_709

GLS_VDPAU_API

VDP_COLOR_STANDARD_SMPTE_240M

GLS_VDPAU_API

VDP_COLOR_TABLE_FORMAT_B8G8R8X8

GLS_VDPAU_API

VDP_DECODER_LEVEL_DIVX_NA

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_1

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_1b

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_1_1

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_1_2

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_1_3

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_2

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_2_1

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_2_2

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_3

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_3_1

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_3_2

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_4

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_4_1

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_4_2

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_5

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_5_1

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG1_NA

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG2_HL

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG2_HL14

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG2_LL

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG2_ML

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L0

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L1

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L2

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L3

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L4

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L5

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_SP_L0

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_SP_L1

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_SP_L2

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_SP_L3

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_ADVANCED_L0

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_ADVANCED_L1

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_ADVANCED_L2

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_ADVANCED_L3

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_ADVANCED_L4

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_MAIN_HIGH

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_MAIN_LOW

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_MAIN_MEDIUM

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_SIMPLE_LOW

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_SIMPLE_MEDIUM

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX4_HD_1080P

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX4_HOME_THEATER

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX4_MOBILE

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX4_QMOBILE

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX5_HD_1080P

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX5_HOME_THEATER

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX5_MOBILE

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX5_QMOBILE

GLS_VDPAU_API

VDP_DECODER_PROFILE_H264_BASELINE

GLS_VDPAU_API

VDP_DECODER_PROFILE_H264_HIGH

GLS_VDPAU_API

VDP_DECODER_PROFILE_H264_MAIN

GLS_VDPAU_API

VDP_DECODER_PROFILE_MPEG1

GLS_VDPAU_API

VDP_DECODER_PROFILE_MPEG2_MAIN

GLS_VDPAU_API

VDP_DECODER_PROFILE_MPEG2_SIMPLE

GLS_VDPAU_API

VDP_DECODER_PROFILE_MPEG4_PART2_ASP

GLS_VDPAU_API

VDP_DECODER_PROFILE_MPEG4_PART2_SP

GLS_VDPAU_API

VDP_DECODER_PROFILE_VC1_ADVANCED

GLS_VDPAU_API

VDP_DECODER_PROFILE_VC1_MAIN

GLS_VDPAU_API

VDP_DECODER_PROFILE_VC1_SIMPLE

GLS_VDPAU_API

VDP_FALSE

GLS_VDPAU_API

VDP_FUNC_ID_BASE_WINSYS

GLS_VDPAU_API

VDP_FUNC_ID_BITMAP_SURFACE_CREATE

GLS_VDPAU_API

VDP_FUNC_ID_BITMAP_SURFACE_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_BITMAP_SURFACE_GET_PARAMETERS

GLS_VDPAU_API

VDP_FUNC_ID_BITMAP_SURFACE_PUT_BITS_NATIVE

GLS_VDPAU_API

VDP_FUNC_ID_BITMAP_SURFACE_QUERY_CAPABILITIES

GLS_VDPAU_API

VDP_FUNC_ID_DECODER_CREATE

GLS_VDPAU_API

VDP_FUNC_ID_DECODER_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_DECODER_GET_PARAMETERS

GLS_VDPAU_API

VDP_FUNC_ID_DECODER_QUERY_CAPABILITIES

GLS_VDPAU_API

VDP_FUNC_ID_DECODER_RENDER

GLS_VDPAU_API

VDP_FUNC_ID_DEVICE_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_GENERATE_CSC_MATRIX

GLS_VDPAU_API

VDP_FUNC_ID_GET_API_VERSION

GLS_VDPAU_API

VDP_FUNC_ID_GET_ERROR_STRING

GLS_VDPAU_API

VDP_FUNC_ID_GET_INFORMATION_STRING

GLS_VDPAU_API

VDP_FUNC_ID_GET_PROC_ADDRESS

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_CREATE

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_GET_BITS_NATIVE

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_GET_PARAMETERS

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_PUT_BITS_INDEXED

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_PUT_BITS_NATIVE

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_PUT_BITS_Y_CB_CR

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_CAPABILITIES

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_GET_PUT_BITS_NATIVE_CAPABILITIES

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_PUT_BITS_INDEXED_CAPABILITIES

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_PUT_BITS_Y_CB_CR_CAPABILITIES

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_RENDER_BITMAP_SURFACE

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_RENDER_OUTPUT_SURFACE

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_RENDER_VIDEO_SURFACE_LUMA

GLS_VDPAU_API

VDP_FUNC_ID_PREEMPTION_CALLBACK_REGISTER

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_BLOCK_UNTIL_SURFACE_IDLE

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_CREATE

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_DISPLAY

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_GET_BACKGROUND_COLOR

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_GET_TIME

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_QUERY_SURFACE_STATUS

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_SET_BACKGROUND_COLOR

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_TARGET_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_CREATE

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_GET_ATTRIBUTE_VALUES

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_GET_FEATURE_ENABLES

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_GET_FEATURE_SUPPORT

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_GET_PARAMETER_VALUES

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_QUERY_ATTRIBUTE_SUPPORT

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_QUERY_ATTRIBUTE_VALUE_RANGE

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_QUERY_FEATURE_SUPPORT

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_QUERY_PARAMETER_SUPPORT

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_QUERY_PARAMETER_VALUE_RANGE

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_RENDER

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_SET_ATTRIBUTE_VALUES

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_SET_FEATURE_ENABLES

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_SURFACE_CREATE

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_SURFACE_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_SURFACE_GET_BITS_Y_CB_CR

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_SURFACE_GET_PARAMETERS

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_SURFACE_PUT_BITS_Y_CB_CR

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_SURFACE_QUERY_CAPABILITIES

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_SURFACE_QUERY_GET_PUT_BITS_Y_CB_CR_CAPABILITIES

GLS_VDPAU_API

VDP_INDEXED_FORMAT_A4I4

GLS_VDPAU_API

VDP_INDEXED_FORMAT_A8I8

GLS_VDPAU_API

VDP_INDEXED_FORMAT_I4A4

GLS_VDPAU_API

VDP_INDEXED_FORMAT_I8A8

GLS_VDPAU_API

VDP_INVALID_HANDLE

GLS_VDPAU_API

VDP_LAYER_VERSION

GLS_VDPAU_API

VDP_OUTPUT_SURFACE_RENDER_BLEND_STATE_VERSION

GLS_VDPAU_API

VDP_OUTPUT_SURFACE_RENDER_COLOR_PER_VERTEX

GLS_VDPAU_API

VDP_OUTPUT_SURFACE_RENDER_ROTATE_0

GLS_VDPAU_API

VDP_OUTPUT_SURFACE_RENDER_ROTATE_180

GLS_VDPAU_API

VDP_OUTPUT_SURFACE_RENDER_ROTATE_270

GLS_VDPAU_API

VDP_OUTPUT_SURFACE_RENDER_ROTATE_90

GLS_VDPAU_API

VDP_PROCAMP_VERSION

GLS_VDPAU_API

VDP_RGBA_FORMAT_A8

GLS_VDPAU_API

VDP_RGBA_FORMAT_B10G10R10A2

GLS_VDPAU_API

VDP_RGBA_FORMAT_B8G8R8A8

GLS_VDPAU_API

VDP_RGBA_FORMAT_R10G10B10A2

GLS_VDPAU_API

VDP_RGBA_FORMAT_R8G8B8A8

GLS_VDPAU_API

VDP_TRUE

GLS_VDPAU_API

VDP_VIDEO_MIXER_ATTRIBUTE_BACKGROUND_COLOR

GLS_VDPAU_API

VDP_VIDEO_MIXER_ATTRIBUTE_CSC_MATRIX

GLS_VDPAU_API

VDP_VIDEO_MIXER_ATTRIBUTE_LUMA_KEY_MAX_LUMA

GLS_VDPAU_API

VDP_VIDEO_MIXER_ATTRIBUTE_LUMA_KEY_MIN_LUMA

GLS_VDPAU_API

VDP_VIDEO_MIXER_ATTRIBUTE_NOISE_REDUCTION_LEVEL

GLS_VDPAU_API

VDP_VIDEO_MIXER_ATTRIBUTE_SHARPNESS_LEVEL

GLS_VDPAU_API

VDP_VIDEO_MIXER_ATTRIBUTE_SKIP_CHROMA_DEINTERLACE

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_DEINTERLACE_TEMPORAL

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_DEINTERLACE_TEMPORAL_SPATIAL

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L1

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L2

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L3

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L4

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L5

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L6

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L7

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L8

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L9

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_INVERSE_TELECINE

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_LUMA_KEY

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_NOISE_REDUCTION

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_SHARPNESS

GLS_VDPAU_API

VDP_VIDEO_MIXER_PARAMETER_CHROMA_TYPE

GLS_VDPAU_API

VDP_VIDEO_MIXER_PARAMETER_LAYERS

GLS_VDPAU_API

VDP_VIDEO_MIXER_PARAMETER_VIDEO_SURFACE_HEIGHT

GLS_VDPAU_API

VDP_VIDEO_MIXER_PARAMETER_VIDEO_SURFACE_WIDTH

GLS_VDPAU_API

VDP_YCBCR_FORMAT_NV12

GLS_VDPAU_API

VDP_YCBCR_FORMAT_UYVY

GLS_VDPAU_API

VDP_YCBCR_FORMAT_V8U8Y8A8

GLS_VDPAU_API

VDP_YCBCR_FORMAT_Y8U8V8A8

GLS_VDPAU_API

VDP_YCBCR_FORMAT_YUYV

GLS_VDPAU_API

VDP_YCBCR_FORMAT_YV12

GLS_VDPAU_API

VGradientMax3DS

Const3DS

VGradientMin3DS

Const3DS

VHDR_DONE

GLSVfw

VHDR_INQUEUE

GLSVfw

VHDR_KEYFRAME

GLSVfw

VHDR_PREPARED

GLSVfw

VIDCF_COMPRESSFRAMES

GLSVfw

VIDCF_CRUNCH

GLSVfw

VIDCF_DRAW

GLSVfw

VIDCF_FASTTEMPORALC

GLSVfw

VIDCF_FASTTEMPORALD

GLSVfw

VIDCF_QUALITY

GLSVfw

VIDCF_TEMPORAL

GLSVfw

VIDEO_CONFIGURE_CURRENT

GLSVfw

VIDEO_CONFIGURE_GET

GLSVfw

VIDEO_CONFIGURE_MAX

GLSVfw

VIDEO_CONFIGURE_MIN

GLSVfw

VIDEO_CONFIGURE_NOMINAL

GLSVfw

VIDEO_CONFIGURE_QUERY

GLSVfw

VIDEO_CONFIGURE_QUERYSIZE

GLSVfw

VIDEO_CONFIGURE_SET

GLSVfw

VIDEO_DLG_QUERY

GLSVfw

VIDEO_EXTERNALIN

GLSVfw

VIDEO_EXTERNALOUT

GLSVfw

VIDEO_IN

GLSVfw

VIDEO_OUT

GLSVfw

ViewCameraStrMax3DS

Const3DS

VIEWPORT_DATA

Const3DS

VIEWPORT_DATA_3

Const3DS

VIEWPORT_DATA_OLD

Const3DS

VIEWPORT_LAYOUT

Const3DS

VIEWPORT_LAYOUT_OLD

Const3DS

VIEWPORT_SIZE

Const3DS

VIEW_BACK

Const3DS

VIEW_BOTTOM

Const3DS

VIEW_CAMERA

Const3DS

VIEW_FRONT

Const3DS

VIEW_LEFT

Const3DS

VIEW_RIGHT

Const3DS

VIEW_TOP

Const3DS

VIEW_USER

Const3DS

VIEW_WINDOW

Const3DS

VK_MOUSEWHEELDOWN

GLKeyboard

VK_MOUSEWHEELUP

GLKeyboard

VMAP_TYPE_MNVW

LWObjects

VMAP_TYPE_MORF

LWObjects

VMAP_TYPE_PICK

LWObjects

VMAP_TYPE_RGB

LWObjects

VMAP_TYPE_RGBA

LWObjects

VMAP_TYPE_SPOT

LWObjects

VMAP_TYPE_TXUV

LWObjects

VMAP_TYPE_WGHT

LWObjects

VPDATA

Const3DS

V_GRADIENT

Const3DS

WAVE_FORMAT_1M08

Bass

WAVE_FORMAT_1M16

Bass

WAVE_FORMAT_1S08

Bass

WAVE_FORMAT_1S16

Bass

WAVE_FORMAT_2M08

Bass

WAVE_FORMAT_2M16

Bass

WAVE_FORMAT_2S08

Bass

WAVE_FORMAT_2S16

Bass

WAVE_FORMAT_4M08

Bass

WAVE_FORMAT_4M16

Bass

WAVE_FORMAT_4S08

Bass

WAVE_FORMAT_4S16

Bass

WGL_ACCELERATION_ARB

OpenGLTokens

WGL_ACCESS_READ_ONLY_NV

OpenGLTokens

WGL_ACCESS_READ_WRITE_NV

OpenGLTokens

WGL_ACCESS_WRITE_DISCARD_NV

OpenGLTokens

WGL_ACCUM_ALPHA_BITS_ARB

OpenGLTokens

WGL_ACCUM_BITS_ARB

OpenGLTokens

WGL_ACCUM_BLUE_BITS_ARB

OpenGLTokens

WGL_ACCUM_GREEN_BITS_ARB

OpenGLTokens

WGL_ACCUM_RED_BITS_ARB

OpenGLTokens

WGL_ALPHA_BITS_ARB

OpenGLTokens

WGL_ALPHA_SHIFT_ARB

OpenGLTokens

WGL_AUX0_ARB

OpenGLTokens

WGL_AUX1_ARB

OpenGLTokens

WGL_AUX2_ARB

OpenGLTokens

WGL_AUX3_ARB

OpenGLTokens

WGL_AUX4_ARB

OpenGLTokens

WGL_AUX5_ARB

OpenGLTokens

WGL_AUX6_ARB

OpenGLTokens

WGL_AUX7_ARB

OpenGLTokens

WGL_AUX8_ARB

OpenGLTokens

WGL_AUX9_ARB

OpenGLTokens

WGL_AUX_BUFFERS_ARB

OpenGLTokens

WGL_BACK_COLOR_BUFFER_BIT_ARB

OpenGLTokens

WGL_BACK_LEFT_ARB

OpenGLTokens

WGL_BACK_RIGHT_ARB

OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV

OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV

OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV

OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV

OpenGLTokens

WGL_BIND_TO_TEXTURE_RGBA_ARB

OpenGLTokens

WGL_BIND_TO_TEXTURE_RGB_ARB

OpenGLTokens

WGL_BLUE_BITS_ARB

OpenGLTokens

WGL_BLUE_SHIFT_ARB

OpenGLTokens

WGL_COLOR_BITS_ARB

OpenGLTokens

WGL_COLOR_SAMPLES_NV

OpenGLTokens

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB

OpenGLTokens

WGL_CONTEXT_CORE_PROFILE_BIT_ARB

OpenGLTokens

WGL_CONTEXT_DEBUG_BIT_ARB

OpenGLTokens

WGL_CONTEXT_ES2_PROFILE_BIT_EXT

OpenGLTokens

WGL_CONTEXT_FLAGS_ARB

OpenGLTokens

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB

OpenGLTokens

WGL_CONTEXT_LAYER_PLANE_ARB

OpenGLTokens

WGL_CONTEXT_MAJOR_VERSION_ARB

OpenGLTokens

WGL_CONTEXT_MINOR_VERSION_ARB

OpenGLTokens

WGL_CONTEXT_PROFILE_MASK_ARB

OpenGLTokens

WGL_CUBE_MAP_FACE_ARB

OpenGLTokens

WGL_DEPTH_BITS_ARB

OpenGLTokens

WGL_DEPTH_BUFFER_BIT_ARB

OpenGLTokens

WGL_DOUBLE_BUFFER_ARB

OpenGLTokens

WGL_DRAW_TO_BITMAP_ARB

OpenGLTokens

WGL_DRAW_TO_PBUFFER_ARB

OpenGLTokens

WGL_DRAW_TO_WINDOW_ARB

OpenGLTokens

WGL_FLOAT_COMPONENTS_NV

OpenGLTokens

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB

OpenGLTokens

WGL_FRAMEBUFFER_SRGB_CAPABLE_EXT

OpenGLTokens

WGL_FRONT_COLOR_BUFFER_BIT_ARB

OpenGLTokens

WGL_FRONT_LEFT_ARB

OpenGLTokens

WGL_FRONT_RIGHT_ARB

OpenGLTokens

WGL_FULL_ACCELERATION_ARB

OpenGLTokens

WGL_GENERIC_ACCELERATION_ARB

OpenGLTokens

WGL_GREEN_BITS_ARB

OpenGLTokens

WGL_GREEN_SHIFT_ARB

OpenGLTokens

WGL_MAX_PBUFFER_HEIGHT_ARB

OpenGLTokens

WGL_MAX_PBUFFER_PIXELS_ARB

OpenGLTokens

WGL_MAX_PBUFFER_WIDTH_ARB

OpenGLTokens

WGL_MIPMAP_LEVEL_ARB

OpenGLTokens

WGL_MIPMAP_TEXTURE_ARB

OpenGLTokens

WGL_NEED_PALETTE_ARB

OpenGLTokens

WGL_NEED_SYSTEM_PALETTE_ARB

OpenGLTokens

WGL_NO_ACCELERATION_ARB

OpenGLTokens

WGL_NO_TEXTURE_ARB

OpenGLTokens

WGL_NUMBER_OVERLAYS_ARB

OpenGLTokens

WGL_NUMBER_PIXEL_FORMATS_ARB

OpenGLTokens

WGL_NUMBER_UNDERLAYS_ARB

OpenGLTokens

WGL_PBUFFER_HEIGHT_ARB

OpenGLTokens

WGL_PBUFFER_LARGEST_ARB

OpenGLTokens

WGL_PBUFFER_LOST_ARB

OpenGLTokens

WGL_PBUFFER_WIDTH_ARB

OpenGLTokens

WGL_PIXEL_TYPE_ARB

OpenGLTokens

WGL_RED_BITS_ARB

OpenGLTokens

WGL_RED_SHIFT_ARB

OpenGLTokens

WGL_SAMPLES_ARB

OpenGLTokens

WGL_SAMPLES_EXT

OpenGLTokens

WGL_SAMPLE_BUFFERS_ARB

OpenGLTokens

WGL_SAMPLE_BUFFERS_EXT

OpenGLTokens

WGL_SHARE_ACCUM_ARB

OpenGLTokens

WGL_SHARE_DEPTH_ARB

OpenGLTokens

WGL_SHARE_STENCIL_ARB

OpenGLTokens

WGL_STENCIL_BITS_ARB

OpenGLTokens

WGL_STENCIL_BUFFER_BIT_ARB

OpenGLTokens

WGL_STEREO_ARB

OpenGLTokens

WGL_SUPPORT_GDI_ARB

OpenGLTokens

WGL_SUPPORT_OPENGL_ARB

OpenGLTokens

WGL_SWAP_COPY_ARB

OpenGLTokens

WGL_SWAP_EXCHANGE_ARB

OpenGLTokens

WGL_SWAP_LAYER_BUFFERS_ARB

OpenGLTokens

WGL_SWAP_MAIN_PLANE

GLWin32Context

WGL_SWAP_METHOD_ARB

OpenGLTokens

WGL_SWAP_OVERLAY1

GLWin32Context

WGL_SWAP_OVERLAY10

GLWin32Context

WGL_SWAP_OVERLAY11

GLWin32Context

WGL_SWAP_OVERLAY12

GLWin32Context

WGL_SWAP_OVERLAY13

GLWin32Context

WGL_SWAP_OVERLAY14

GLWin32Context

WGL_SWAP_OVERLAY15

GLWin32Context

WGL_SWAP_OVERLAY2

GLWin32Context

WGL_SWAP_OVERLAY3

GLWin32Context

WGL_SWAP_OVERLAY4

GLWin32Context

WGL_SWAP_OVERLAY5

GLWin32Context

WGL_SWAP_OVERLAY6

GLWin32Context

WGL_SWAP_OVERLAY7

GLWin32Context

WGL_SWAP_OVERLAY8

GLWin32Context

WGL_SWAP_OVERLAY9

GLWin32Context

WGL_SWAP_UNDEFINED_ARB

OpenGLTokens

WGL_SWAP_UNDERLAY1

GLWin32Context

WGL_SWAP_UNDERLAY10

GLWin32Context

WGL_SWAP_UNDERLAY11

GLWin32Context

WGL_SWAP_UNDERLAY12

GLWin32Context

WGL_SWAP_UNDERLAY13

GLWin32Context

WGL_SWAP_UNDERLAY14

GLWin32Context

WGL_SWAP_UNDERLAY15

GLWin32Context

WGL_SWAP_UNDERLAY2

GLWin32Context

WGL_SWAP_UNDERLAY3

GLWin32Context

WGL_SWAP_UNDERLAY4

GLWin32Context

WGL_SWAP_UNDERLAY5

GLWin32Context

WGL_SWAP_UNDERLAY6

GLWin32Context

WGL_SWAP_UNDERLAY7

GLWin32Context

WGL_SWAP_UNDERLAY8

GLWin32Context

WGL_SWAP_UNDERLAY9

GLWin32Context

WGL_TEXTURE_1D_ARB

OpenGLTokens

WGL_TEXTURE_2D_ARB

OpenGLTokens

WGL_TEXTURE_CUBE_MAP_ARB

OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB

OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB

OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB

OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB

OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB

OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB

OpenGLTokens

WGL_TEXTURE_FLOAT_RGBA_NV

OpenGLTokens

WGL_TEXTURE_FLOAT_RGB_NV

OpenGLTokens

WGL_TEXTURE_FLOAT_RG_NV

OpenGLTokens

WGL_TEXTURE_FLOAT_R_NV

OpenGLTokens

WGL_TEXTURE_FORMAT_ARB

OpenGLTokens

WGL_TEXTURE_RGBA_ARB

OpenGLTokens

WGL_TEXTURE_RGB_ARB

OpenGLTokens

WGL_TEXTURE_TARGET_ARB

OpenGLTokens

WGL_TRANSPARENT_ALPHA_VALUE_ARB

OpenGLTokens

WGL_TRANSPARENT_ARB

OpenGLTokens

WGL_TRANSPARENT_BLUE_VALUE_ARB

OpenGLTokens

WGL_TRANSPARENT_GREEN_VALUE_ARB

OpenGLTokens

WGL_TRANSPARENT_INDEX_VALUE_ARB

OpenGLTokens

WGL_TRANSPARENT_RED_VALUE_ARB

OpenGLTokens

WGL_TYPE_COLORINDEX_ARB

OpenGLTokens

WGL_TYPE_RGBA_ARB

OpenGLTokens

WGL_TYPE_RGBA_FLOAT_ARB

OpenGLTokens

WGL_TYPE_RGBA_FLOAT_ATI

OpenGLTokens

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT

OpenGLTokens

WHmgPoint

VectorGeometry

WHmgVector

VectorGeometry

WM_CAP_ABORT

GLSVfw

WM_CAP_DLG_VIDEOCOMPRESSION

GLSVfw

WM_CAP_DLG_VIDEODISPLAY

GLSVfw

WM_CAP_DLG_VIDEOFORMAT

GLSVfw

WM_CAP_DLG_VIDEOSOURCE

GLSVfw

WM_CAP_DRIVER_CONNECT

GLSVfw

WM_CAP_DRIVER_DISCONNECT

GLSVfw

WM_CAP_DRIVER_GET_CAPS

GLSVfw

WM_CAP_DRIVER_GET_NAME

GLSVfw

WM_CAP_DRIVER_GET_NAMEA

GLSVfw

WM_CAP_DRIVER_GET_NAMEW

GLSVfw

WM_CAP_DRIVER_GET_VERSION

GLSVfw

WM_CAP_DRIVER_GET_VERSIONA

GLSVfw

WM_CAP_DRIVER_GET_VERSIONW

GLSVfw

WM_CAP_EDIT_COPY

GLSVfw

WM_CAP_END

GLSVfw

WM_CAP_FILE_ALLOCATE

GLSVfw

WM_CAP_FILE_GET_CAPTURE_FILE

GLSVfw

WM_CAP_FILE_GET_CAPTURE_FILEA

GLSVfw

WM_CAP_FILE_GET_CAPTURE_FILEW

GLSVfw

WM_CAP_FILE_SAVEAS

GLSVfw

WM_CAP_FILE_SAVEASA

GLSVfw

WM_CAP_FILE_SAVEASW

GLSVfw

WM_CAP_FILE_SAVEDIB

GLSVfw

WM_CAP_FILE_SAVEDIBA

GLSVfw

WM_CAP_FILE_SAVEDIBW

GLSVfw

WM_CAP_FILE_SET_CAPTURE_FILE

GLSVfw

WM_CAP_FILE_SET_CAPTURE_FILEA

GLSVfw

WM_CAP_FILE_SET_CAPTURE_FILEW

GLSVfw

WM_CAP_FILE_SET_INFOCHUNK

GLSVfw

WM_CAP_GET_AUDIOFORMAT

GLSVfw

WM_CAP_GET_CAPSTREAMPTR

GLSVfw

WM_CAP_GET_MCI_DEVICE

GLSVfw

WM_CAP_GET_MCI_DEVICEA

GLSVfw

WM_CAP_GET_MCI_DEVICEW

GLSVfw

WM_CAP_GET_SEQUENCE_SETUP

GLSVfw

WM_CAP_GET_STATUS

GLSVfw

WM_CAP_GET_USER_DATA

GLSVfw

WM_CAP_GET_VIDEOFORMAT

GLSVfw

WM_CAP_GRAB_FRAME

GLSVfw

WM_CAP_GRAB_FRAME_NOSTOP

GLSVfw

WM_CAP_PAL_AUTOCREATE

GLSVfw

WM_CAP_PAL_MANUALCREATE

GLSVfw

WM_CAP_PAL_OPEN

GLSVfw

WM_CAP_PAL_OPENA

GLSVfw

WM_CAP_PAL_OPENW

GLSVfw

WM_CAP_PAL_PASTE

GLSVfw

WM_CAP_PAL_SAVE

GLSVfw

WM_CAP_PAL_SAVEA

GLSVfw

WM_CAP_PAL_SAVEW

GLSVfw

WM_CAP_SEQUENCE

GLSVfw

WM_CAP_SEQUENCE_NOFILE

GLSVfw

WM_CAP_SET_AUDIOFORMAT

GLSVfw

WM_CAP_SET_CALLBACK_CAPCONTROL

GLSVfw

WM_CAP_SET_CALLBACK_ERROR

GLSVfw

WM_CAP_SET_CALLBACK_ERRORA

GLSVfw

WM_CAP_SET_CALLBACK_ERRORW

GLSVfw

WM_CAP_SET_CALLBACK_FRAME

GLSVfw

WM_CAP_SET_CALLBACK_STATUS

GLSVfw

WM_CAP_SET_CALLBACK_STATUSA

GLSVfw

WM_CAP_SET_CALLBACK_STATUSW

GLSVfw

WM_CAP_SET_CALLBACK_VIDEOSTREAM

GLSVfw

WM_CAP_SET_CALLBACK_WAVESTREAM

GLSVfw

WM_CAP_SET_CALLBACK_YIELD

GLSVfw

WM_CAP_SET_MCI_DEVICE

GLSVfw

WM_CAP_SET_MCI_DEVICEA

GLSVfw

WM_CAP_SET_MCI_DEVICEW

GLSVfw

WM_CAP_SET_OVERLAY

GLSVfw

WM_CAP_SET_PREVIEW

GLSVfw

WM_CAP_SET_PREVIEWRATE

GLSVfw

WM_CAP_SET_SCALE

GLSVfw

WM_CAP_SET_SCROLL

GLSVfw

WM_CAP_SET_SEQUENCE_SETUP

GLSVfw

WM_CAP_SET_USER_DATA

GLSVfw

WM_CAP_SET_VIDEOFORMAT

GLSVfw

WM_CAP_SINGLE_FRAME

GLSVfw

WM_CAP_SINGLE_FRAME_CLOSE

GLSVfw

WM_CAP_SINGLE_FRAME_OPEN

GLSVfw

WM_CAP_START

GLSVfw

WM_CAP_STOP

GLSVfw

WM_CAP_UNICODE_END

GLSVfw

WM_CAP_UNICODE_START

GLSVfw

XDATA_APPNAME

Const3DS

XDATA_DOUBLE

Const3DS

XDATA_ENTRY

Const3DS

XDATA_FLOAT

Const3DS

XDATA_GROUP

Const3DS

XDATA_LONG

Const3DS

XDATA_RFU1

Const3DS

XDATA_RFU2

Const3DS

XDATA_RFU3

Const3DS

XDATA_RFU4

Const3DS

XDATA_RFU5

Const3DS

XDATA_RFU6

Const3DS

XDATA_SECTION

Const3DS

XDATA_SHORT

Const3DS

XDATA_STRING

Const3DS

XDATA_VOID

Const3DS

XHmgPoint

VectorGeometry

XHmgVector

VectorGeometry

XLATE_RANGE

Const3DS

XTexPoint

VectorGeometry

XVector

VectorGeometry

XYHmgVector

VectorGeometry

XYTexPoint

VectorGeometry

XYVector

VectorGeometry

XYZHmgVector

VectorGeometry

XYZVector

VectorGeometry

XYZWHmgVector

VectorGeometry

XZHmgVector

VectorGeometry

XZVector

VectorGeometry

XZ_CURVE

Const3DS

YHmgPoint

VectorGeometry

YHmgVector

VectorGeometry

YTexPoint

VectorGeometry

YVector

VectorGeometry

YZHmgVector

VectorGeometry

YZVector

VectorGeometry

YZ_CURVE

Const3DS

ZErrors

GLSZLibEx

ZFlushes

GLSZLibEx

ZHmgPoint

VectorGeometry

ZHmgVector

VectorGeometry

ZLevels

GLSZLibEx

ZLIB_VERSION

LIBPNG

ZStrategies

GLSZLibEx

ZVector

VectorGeometry

Z_ASCII

GLSZLibExApi

Z_BEST_COMPRESSION

GLSZLibExApi

Z_BEST_SPEED

GLSZLibExApi

Z_BINARY

GLSZLibExApi

Z_BLOCK

GLSZLibExApi

Z_BUF_ERROR

GLSZLibExApi

Z_DATA_ERROR

GLSZLibExApi

Z_DEFAULT_COMPRESSION

GLSZLibExApi

Z_DEFAULT_STRATEGY

GLSZLibExApi

Z_DEFLATED

GLSZLibExApi

Z_ERRNO

GLSZLibExApi

Z_FILTERED

GLSZLibExApi

Z_FINISH

GLSZLibExApi

Z_FIXED

GLSZLibExApi

Z_FULL_FLUSH

GLSZLibExApi

Z_HUFFMAN_ONLY

GLSZLibExApi

Z_INFO_DEFAULT

GLSZLibExApi

Z_INFO_FLAG_ADLER

GLSZLibExApi

Z_INFO_FLAG_CRC

GLSZLibExApi

Z_INFO_FLAG_SIZE

GLSZLibExApi

Z_INFO_NONE

GLSZLibExApi

Z_MEM_ERROR

GLSZLibExApi

Z_NEED_DICT

GLSZLibExApi

Z_NO_COMPRESSION

GLSZLibExApi

Z_NO_FLUSH

GLSZLibExApi

Z_OK

GLSZLibExApi

Z_PARTIAL_FLUSH

GLSZLibExApi

Z_RLE

GLSZLibExApi

Z_STREAM_END

GLSZLibExApi

Z_STREAM_ERROR

GLSZLibExApi

Z_SYNC_FLUSH

GLSZLibExApi

Z_TEXT

GLSZLibExApi

Z_TREES

GLSZLibExApi

Z_UNKNOWN

GLSZLibExApi

Z_VERSION_ERROR

GLSZLibExApi

_priv_dParamLoStop

ODEImport

_priv_dParamLoStop2

ODEImport

_priv_dParamLoStop3

ODEImport

_z_errmsg

GLSZLibExApi

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:50


GLScene v.1.1.2: All Functions and Procedures

All Functions and Procedures

Name | Unit | Description
AABBContainsAABB GeometryBB
AABBContainsBSphere GeometryBB
AABBFitsInAABBAbsolute GeometryBB
AABBFromSweep GeometryBB
AABBInclude GeometryBB
AABBIntersection GeometryBB
AABBScale GeometryBB
AABBToBB GeometryBB
AABBToBB GeometryBB
AABBToBSphere GeometryBB
AABBToClipRect GeometryBB
AABBTransform GeometryBB
AbsVector | VectorGeometry | Vector components are replaced by their Abs() value. }
AbsVector | VectorGeometry | Vector components are replaced by their Abs() value. }
ActiveSoundManager GLSound
AddAABB GeometryBB
AddBB GeometryBB
AddChild Utils3DS
AddChildOrdered Utils3DS
AddClassSymbol dws2HelperFunc
AddForwardDeclaration dws2HelperFunc
AddPoint | VectorGeometry | Adds V2 to V1, result is placed in V1. W coordinate is always 1.
AddPropertyToClass dws2HelperFunc
AddSCODEGeomsToODESpace | GLODESkeletonColliders | After loading call this function to add all the geoms in a skeleton collider list to a given ODE space.
AddSCVerletConstriantsToVerletWorld | GLVerletSkeletonColliders | After loading call this function to add all the constraints in a skeleton collider list to a given verlet world.
AddTaskForServiceContext GLContext
AddVector | VectorGeometry | Adds V2 to V1, result is placed in V1
AddVector | VectorGeometry | Adds V2 to V1, result is placed in V1
AddVector | VectorGeometry | Adds V2 to V1, result is placed in V1
AddVector | VectorGeometry | Sums up f to each component of the vector
AddVector | VectorGeometry | Sums up f to each component of the vector
AdjointMatrix | VectorGeometry | Adjoint of a 3x3 matrix.<p> used in the computation of the inverse of a 3x3 matrix
AdjointMatrix | VectorGeometry | Adjoint of a 4x4 matrix.<p> used in the computation of the inverse of a 4x4 matrix
AffineVectorEquals | VectorGeometry | True if X, Y and Z components are equal.
AffineVectorMake VectorGeometry
AffineVectorMake VectorGeometry
AlphaGammaBrightCorrection ImageUtils
alutExit openal
alutInit openal
alutLoadWAVFile openal
alutLoadWAVMemory openal
alutUnloadWAV openal
AngleBetweenVectors | VectorGeometry | Calcualtes Angle between 2 Vectors: (A-CenterPoint) and (B-CenterPoint). In radians.
AngleBetweenVectors VectorGeometry
AngleLerp | VectorGeometry | Calculates angular interpolation between start and stop at point t
AnglePreservingMatrixInvert | VectorGeometry | Finds the inverse of an angle preserving matrix.<p> Angle preserving matrices can combine translation, rotation and isotropic scaling, other matrices won't be properly inverted by this function.
AnsiStartsText GLCrossPlatform
ApplicationFileIODefined | ApplicationFileIO | Returns true if an ApplicationFileIO has been defined
ApplyBlendingModeEx GLCustomShader
ArcCos VectorGeometry
ArcCos VectorGeometry
ArcCreateFileStream GLSArchiveManager
ArcFileStreamExists GLSArchiveManager
ArcSin VectorGeometry
ArcSin VectorGeometry
ArcTan2 VectorGeometry
ArcTan2 VectorGeometry
ASESetPreferredLightmap GLFileASE
ASESetPreferredTexture GLFileASE
AVIBuildFilter GLSVfw
AVIBuildFilterA GLSVfw
AVIBuildFilterW GLSVfw
AVICapSM GLSVfw
AVIClearClipboard GLSVfw
AVIFileAddRef GLSVfw
AVIFileClose GLSVfw
AVIFileCreateStream GLSVfw
AVIFileCreateStreamA GLSVfw
AVIFileCreateStreamW GLSVfw
AVIFileEndRecord GLSVfw
AVIFileExit GLSVfw
AVIFileGetStream GLSVfw
AVIFileInfo GLSVfw
AVIFileInfoA GLSVfw
AVIFileInfoW GLSVfw
AVIFileInit GLSVfw
AVIFileOpen GLSVfw
AVIFileOpenA GLSVfw
AVIFileOpenW GLSVfw
AVIFileReadData GLSVfw
AVIFileRelease GLSVfw
AVIFileWriteData GLSVfw
AVIGetFromClipboard GLSVfw
AVIMakeCompressedStream GLSVfw
AVIMakeFileFromStreams GLSVfw
AVIMakeStreamFromClipboard GLSVfw
AVIPutFileOnClipboard GLSVfw
AVISaveOptions GLSVfw
AVISaveOptionsFree GLSVfw
AVISaveV GLSVfw
AVISaveVA GLSVfw
AVISaveVW GLSVfw
AVIStreamAddRef GLSVfw
AVIStreamBeginStreaming GLSVfw
AVIStreamClose GLSVfw
AVIStreamCreate GLSVfw
AVIStreamDataSize GLSVfw
AVIStreamEnd GLSVfw
AVIStreamEndStreaming GLSVfw
AVIStreamEndTime GLSVfw
AVIStreamExit GLSVfw
AVIStreamFindKeyFrame GLSVfw
AVIStreamFindSample GLSVfw
AVIStreamFormatSize GLSVfw
AVIStreamGetFrame GLSVfw
AVIStreamGetFrameClose GLSVfw
AVIStreamGetFrameOpen GLSVfw
AVIStreamInfo GLSVfw
AVIStreamInfoA GLSVfw
AVIStreamInfoW GLSVfw
AVIStreamInit GLSVfw
AVIStreamIsKeyFrame GLSVfw
AVIStreamLength GLSVfw
AVIStreamLengthTime GLSVfw
AVIStreamNearestKeyFrame GLSVfw
AVIStreamNearestKeyFrameTime GLSVfw
AVIStreamNearestSample GLSVfw
AVIStreamNearestSampleTime GLSVfw
AVIStreamNextKeyFrame GLSVfw
AVIStreamNextKeyFrameTime GLSVfw
AVIStreamNextSample GLSVfw
AVIStreamNextSampleTime GLSVfw
AVIStreamOpenFromFile GLSVfw
AVIStreamOpenFromFileA GLSVfw
AVIStreamOpenFromFileW GLSVfw
AVIStreamPrevKeyFrame GLSVfw
AVIStreamPrevKeyFrameTime GLSVfw
AVIStreamPrevSample GLSVfw
AVIStreamPrevSampleTime GLSVfw
AVIStreamRead GLSVfw
AVIStreamReadData GLSVfw
AVIStreamReadFormat GLSVfw
AVIStreamRelease GLSVfw
AVIStreamSampleSize GLSVfw
AVIStreamSampleToSample GLSVfw
AVIStreamSampleToTime GLSVfw
AVIStreamSetFormat GLSVfw
AVIStreamStart GLSVfw
AVIStreamStartTime GLSVfw
AVIStreamTimeToSample GLSVfw
AVIStreamWrite GLSVfw
AVIStreamWriteData GLSVfw
aviTWOCC GLSVfw
AxesBuildList | GLScene | Issues OpenGL calls for drawing X, Y, Z axes in a standard style.
BallAndSocketSetConeAngle NewtonImport_JointLibrary
BallAndSocketSetTwistAngle NewtonImport_JointLibrary
BarycentricCoordinates | VectorGeometry | Calculates the barycentric coordinates for the point p on the triangle defined by the vertices v1, v2 and v3. That is, solves p = u * v1 + v * v2 + (1-u-v) * v3 for u,v. Returns true if the point is inside the triangle, false otherwise.<p> NOTE: This function assumes that the point lies on the plane defined by the triangle. If this is not the case, the function will not work correctly!
BASS_IsLoaded Bass
BASS_Load Bass
BASS_SetEAXPreset Bass
BASS_SPEAKER_N Bass
BASS_UnLoad Bass
BBMaxX GeometryBB
BBMaxY GeometryBB
BBMaxZ GeometryBB
BBMinX GeometryBB
BBMinY GeometryBB
BBMinZ GeometryBB
BBToAABB GeometryBB
BBTransform GeometryBB
BeginFPUOnlySection | VectorGeometry | Begins a FPU-only section.<p> You can use a FPU-only section to force use of FPU versions of the math functions, though typically slower than their SIMD counterparts, they have a higher precision (80 bits internally) that may be required in some cases.<p> Each BeginFPUOnlySection call must be balanced by a EndFPUOnlySection (calls can be nested).
BezierCurvePoint CurvesAndSurfaces
BezierSurfacePoint CurvesAndSurfaces
BGR24ToRGB24 GLGraphics
BGR24ToRGBA32 GLGraphics
BGRA32ToRGBA32 GLGraphics
BipolarCylindrical_Cartesian | GeometryCoordinates | Convert Bipolar to Cartesian (with error check). u in rad
BipolarCylindrical_Cartesian | GeometryCoordinates | Convert Bipolar to Cartesian (with error check). [Double] u in rad
BipolarCylindrical_Cartesian | GeometryCoordinates | Convert Bipolar to Cartesian. u in rad
BipolarCylindrical_Cartesian | GeometryCoordinates | Convert Bipolar to Cartesian. [Double] u in rad
BitmapScanLine | GLCrossPlatform | Returns the bitmap's scanline for the specified row.
Border GLSMemo
BoundingBoxesAreEqual GeometryBB
BoundingBoxesAreEqual GeometryBB
BrightenRGBArray GLGraphics
BSphereContainsAABB GeometryBB
BSphereContainsBSphere GeometryBB
BSphereIntersectsBSphere GeometryBB
BSphereToAABB GeometryBB
BSphereToAABB GeometryBB
BSphereToAABB GeometryBB
BSplinePoint CurvesAndSurfaces
BSplineSurfacePoint CurvesAndSurfaces
Build2DMipmap ImageUtils
BuildCube GLMeshBuilder
BuildCylinder GLMeshBuilder
BuildCylinder2 GLMeshBuilder
BuildNonOrientedEdgesList | MeshUtils | Builds a list of non-oriented (non duplicated) edges list.<p> Each edge is represented by the two integers of its vertices, sorted in ascending order.<br> If not nil, triangleEdges is filled with the 3 indices of the 3 edges of the triangle, the edges ordering respecting the original triangle orientation.
BuildNormals | MeshUtils | Builds normals for a triangles list.<p> Builds one normal per reference vertex (may be NullVector is reference isn't used), which is the averaged for normals of all adjacent triangles.<p> Returned list must be freed by caller.
BuildVectorCountOptimizedIndices | MeshUtils | Builds a vector-count optimized indices list.<p> The returned list (to be freed by caller) contains an "optimized" indices list in which duplicates coordinates in the original vertices list are used only once (the first available duplicate in the list is used).<br> The vertices list is left untouched, to remap/cleanup, you may use the RemapAndCleanupReferences function.
CalcObjectSpaceLightVectors BumpMapping
CalcPlaneNormal | VectorGeometry | Calculate the normal of a plane defined by three points.
CalcPlaneNormal VectorGeometry
CalcPlaneNormal VectorGeometry
CalcTangentSpaceLightVectors BumpMapping
capCaptureAbort GLSVfw
capCaptureGetSetup GLSVfw
capCaptureSequence GLSVfw
capCaptureSequenceNoFile GLSVfw
capCaptureSetSetup GLSVfw
capCaptureSingleFrame GLSVfw
capCaptureSingleFrameClose GLSVfw
capCaptureSingleFrameOpen GLSVfw
capCaptureStop GLSVfw
capCreateCaptureWindow GLSVfw
capCreateCaptureWindowA GLSVfw
capCreateCaptureWindowW GLSVfw
capDlgVideoCompression GLSVfw
capDlgVideoDisplay GLSVfw
capDlgVideoFormat GLSVfw
capDlgVideoSource GLSVfw
capDriverConnect GLSVfw
capDriverDisconnect GLSVfw
capDriverGetCaps GLSVfw
capDriverGetName GLSVfw
capDriverGetVersion GLSVfw
capEditCopy GLSVfw
capFileAlloc GLSVfw
capFileGetCaptureFile GLSVfw
capFileSaveAs GLSVfw
capFileSaveDIB GLSVfw
capFileSetCaptureFile GLSVfw
capFileSetInfoChunk GLSVfw
capGetAudioFormat GLSVfw
capGetAudioFormatSize GLSVfw
capGetDriverDescription GLSVfw
capGetDriverDescriptionA GLSVfw
capGetDriverDescriptionW GLSVfw
capGetMCIDeviceName GLSVfw
capGetStatus GLSVfw
capGetUserData GLSVfw
capGetVideoFormat GLSVfw
capGetVideoFormatSize GLSVfw
capGrabFrame GLSVfw
capGrabFrameNoStop GLSVfw
capOverlay GLSVfw
capPaletteAuto GLSVfw
capPaletteManual GLSVfw
capPaletteOpen GLSVfw
capPalettePaste GLSVfw
capPaletteSave GLSVfw
capPreview GLSVfw
capPreviewRate GLSVfw
capPreviewScale GLSVfw
capSetAudioFormat GLSVfw
capSetCallbackOnCapControl GLSVfw
capSetCallbackOnError GLSVfw
capSetCallbackOnFrame GLSVfw
capSetCallbackOnStatus GLSVfw
capSetCallbackOnVideoStream GLSVfw
capSetCallbackOnWaveStream GLSVfw
capSetCallbackOnYield GLSVfw
capSetMCIDeviceName GLSVfw
capSetScrollPos GLSVfw
capSetUserData GLSVfw
capSetVideoFormat GLSVfw
Cartesian_Cylindrical | GeometryCoordinates | Convert cartesion to cylindrical [double]
Cartesian_Cylindrical | GeometryCoordinates | Convert cartesian to cylindrical [single]
Cartesian_Spherical | GeometryCoordinates | Convert cartesian to spherical [single]
Cartesian_Spherical | GeometryCoordinates | Convert cartesion to spherical [double]
Cartesian_Spherical GeometryCoordinates
cbrt | Polynomials | Calculates the cube root of its parameter.
Ceil VectorGeometry
Ceil64 VectorGeometry
cgGLBindProgram cgGL
cgGLDisableClientState cgGL
cgGLDisableProfile cgGL
cgGLDisableTextureParameter cgGL
cgGLEnableClientState cgGL
cgGLEnableProfile cgGL
cgGLEnableTextureParameter cgGL
cgGLGetLatestProfile cgGL
cgGLGetManageTextureParameters cgGL
cgGLGetMatrixParameterArraydc cgGL
cgGLGetMatrixParameterArraydr cgGL
cgGLGetMatrixParameterArrayfc cgGL
cgGLGetMatrixParameterArrayfr cgGL
cgGLGetMatrixParameterdc cgGL
cgGLGetMatrixParameterdr cgGL
cgGLGetMatrixParameterfc cgGL
cgGLGetMatrixParameterfr cgGL
cgGLGetParameter1d cgGL
cgGLGetParameter1f cgGL
cgGLGetParameter2d cgGL
cgGLGetParameter2f cgGL
cgGLGetParameter3d cgGL
cgGLGetParameter3f cgGL
cgGLGetParameter4d cgGL
cgGLGetParameter4f cgGL
cgGLGetParameterArray1d cgGL
cgGLGetParameterArray1f cgGL
cgGLGetParameterArray2d cgGL
cgGLGetParameterArray2f cgGL
cgGLGetParameterArray3d cgGL
cgGLGetParameterArray3f cgGL
cgGLGetParameterArray4d cgGL
cgGLGetParameterArray4f cgGL
cgGLGetProgramID cgGL
cgGLGetTextureEnum cgGL
cgGLGetTextureParameter cgGL
cgGLIsProfileSupported cgGL
cgGLIsProgramLoaded cgGL
cgGLLoadProgram cgGL
cgGLSetManageTextureParameters cgGL
cgGLSetMatrixParameterArraydc cgGL
cgGLSetMatrixParameterArraydr cgGL
cgGLSetMatrixParameterArrayfc cgGL
cgGLSetMatrixParameterArrayfr cgGL
cgGLSetMatrixParameterdc cgGL
cgGLSetMatrixParameterdr cgGL
cgGLSetMatrixParameterfc cgGL
cgGLSetMatrixParameterfr cgGL
cgGLSetOptimalOptions cgGL
cgGLSetParameter1d cgGL
cgGLSetParameter1dv cgGL
cgGLSetParameter1f cgGL
cgGLSetParameter1fv cgGL
cgGLSetParameter2d cgGL
cgGLSetParameter2dv cgGL
cgGLSetParameter2f cgGL
cgGLSetParameter2fv cgGL
cgGLSetParameter3d cgGL
cgGLSetParameter3dv cgGL
cgGLSetParameter3f cgGL
cgGLSetParameter3fv cgGL
cgGLSetParameter4d cgGL
cgGLSetParameter4dv cgGL
cgGLSetParameter4f cgGL
cgGLSetParameter4fv cgGL
cgGLSetParameterArray1d cgGL
cgGLSetParameterArray1f cgGL
cgGLSetParameterArray2d cgGL
cgGLSetParameterArray2f cgGL
cgGLSetParameterArray3d cgGL
cgGLSetParameterArray3f cgGL
cgGLSetParameterArray4d cgGL
cgGLSetParameterArray4f cgGL
cgGLSetParameterPointer cgGL
cgGLSetStateMatrixParameter cgGL
cgGLSetTextureParameter cgGL
cgGLUnbindProgram cgGL
CharInSet GLCrossPlatform
CharInSet GLCrossPlatform
CharToVirtualKeyCode | GLKeyboard | Returns the virtual keycode corresponding to the given char.<p> The returned code is untranslated, f.i. 'a' and 'A' will give the same result. A return value of -1 means that the characted cannot be entered using the keyboard.
CharToWideChar GLCrossPlatform
CheckOpenGLError | OpenGL1x | Gets the oldest error from OpenGL engine and tries to clear the error queue.<p>
ChunkHeaderReport Utils3DS
ChunkTagToString Utils3DS
ClampInteger VectorGeometry
ClampInteger VectorGeometry
ClampValue | VectorGeometry | Clamps aValue in the aMin-aMax interval.<p>
ClampValue | VectorGeometry | Clamps aValue in the aMin-INF interval.<p>
clCreateFromGLBuffer GLS_CL_GL
clCreateFromGLRenderbuffer GLS_CL_GL
clCreateFromGLTexture2D GLS_CL_GL
clCreateFromGLTexture3D GLS_CL_GL
ClearGLError | OpenGL1x | Clears all pending OpenGL errors.
clEnqueueAcquireGLObjects GLS_CL_GL
clEnqueueReleaseGLObjects GLS_CL_GL
clGetGLObjectInfo GLS_CL_GL
clGetGLTextureInfo GLS_CL_GL
ClipToAABB GeometryBB
CloseCUDA GLS_CUDA_API
CloseCUDART GLS_CUDA_Runtime
CloseCUFFT GLS_CUDA_FourierTransform
CloseCUTIL GLS_CUDA_Utility
CloseFreetype LIBFREETYPE
CloseODE ODEImport
CloseOpenCL GLS_CL
CloseOpenGL OpenGL1x
CloseOpenGL OpenGLAdapter
Closezlib GLSZLibExApi
CollideAndSlide GLEllipseCollision
CollideWithWorld GLEllipseCollision
ColorManager GLColor
CombineVector | VectorGeometry | Combine the first vector with the second : vr:=vr+v*f
CombineVector | VectorGeometry | Combine the first vector with the second : vr:=vr+v*f
CombineVector | VectorGeometry | Combine the first vector with the second : vr:=vr+v*f
CombineVector VectorGeometry
CompressedInternalFormatToOpenGL | GLTextureFormat | Give a compressed openGL texture format from GLScene texture format if format is have not compression than return same openGL format.
ConeContainsBSphere SpatialPartitioning
ConstArrayToString GLSLog
ConvertColorVector | GLColor | Converts a color vector (containing float values)
ConvertColorVector | GLColor | Converts a color vector (containing float values) and alter intensity.<p> intensity is in [0..1]
ConvertdVector3ToAffineVector ODEGL
ConvertdVector3ToAffineVector ODEGL
ConvertdVector3ToVector3f ODEGL
ConvertdVector3ToVector3f ODEGL
ConvertdVector3ToVector4f ODEGL
ConvertdVector3ToVector4f ODEGL
ConvertFansToList MeshUtils
ConvertImage ImageUtils
ConvertIndexedListToList | MeshUtils | Expands an indexed structure into a non-indexed structure.
ConvertRGBColor | GLColor | Converts RGB components into a color vector with correct range
ConvertRotation | VectorGeometry | Turn a triplet of rotations about x, y, and z (in that order) into an equivalent rotation around a single axis (all in radians).<p>
ConvertStripToList | MeshUtils | Converts a triangle strips into a triangle list.<p> Vertices are added to list, based on the content of strip. Both non-indexed and indexed variants are available, the output is *always* non indexed.
ConvertStripToList MeshUtils
ConvertStripToList MeshUtils
ConvertStripToList MeshUtils
ConvertVector3fTodVector3 ODEGL
ConvertVector3fToPdVector3 ODEGL
ConvertVector4fTodVector3 ODEGL
ConvertVector4fToPdVector3 ODEGL
ConvertWinColor | GLColor | Converts a delphi color into its RGB fragments and correct range.
CopyBodyFromCube ODEGL
CopyCubeSizeFromBox ODEGL
CopyPosFromGeomToGL ODEGL
CopyScreentoTexture GLCustomShader
CopyScreentoTexture2 GLCustomShader
Cosh VectorGeometry
Cosh VectorGeometry
Cosine_Interpolate GLPerlinBase
CoTan VectorGeometry
CoTan VectorGeometry
CreateAffineRotationMatrix | VectorGeometry | Creates a rotation matrix along the given Axis by the given Angle in radians.
CreateBodyFromCube ODEGL
CreateCustomBallAndSocket NewtonImport_JointLibrary
CreateCustomHinge NewtonImport_JointLibrary
CreateCustomJoint6DOF NewtonImport_JointLibrary
CreateCustomKinematicController NewtonImport_JointLibrary
CreateCustomPlayerController NewtonImport_JointLibrary
CreateCustomSlider NewtonImport_JointLibrary
CreateDOMNode GLSCrossXML
CreateEditableStream GLSVfw
CreateFileStream | ApplicationFileIO | Creates a file stream corresponding to the fileName.<p> If the file does not exists, an exception will be triggered.<br> Default mechanism creates a regular TFileStream, the 'mode' parameter is similar to the one for TFileStream.
CreateGeomFromCube ODEGL
CreateGraphicFromFile GLTexture
CreateLookAtMatrix VectorGeometry
CreateMatrixFromFrustum VectorGeometry
CreateObjectSpaceNormalMap BumpMapping
CreateODEPlaneFromGLPlane ODEGL
CreateOrthoMatrix VectorGeometry
CreatePerspectiveMatrix VectorGeometry
CreatePickMatrix VectorGeometry
CreateResourceStream | ApplicationFileIO | Create a resource stream.
CreateRotationMatrix | VectorGeometry | Creates a rotation matrix along the given Axis by the given Angle in radians.
CreateRotationMatrix VectorGeometry
CreateRotationMatrixX VectorGeometry
CreateRotationMatrixX | VectorGeometry | Creates matrix for rotation about x-axis (angle in rad)
CreateRotationMatrixY | VectorGeometry | Creates matrix for rotation about y-axis (angle in rad)
CreateRotationMatrixY VectorGeometry
CreateRotationMatrixZ VectorGeometry
CreateRotationMatrixZ | VectorGeometry | Creates matrix for rotation about z-axis (angle in rad)
CreateScaleAndTranslationMatrix | VectorGeometry | Creates a scale+translation matrix.<p> Scale is applied BEFORE applying offset
CreateScaleMatrix | VectorGeometry | Creates scale matrix
CreateScaleMatrix | VectorGeometry | Creates scale matrix
CreateTangentSpaceNormalMap BumpMapping
CreateTempWnd GLWin32Context
CreateTranslationMatrix | VectorGeometry | Creates translation matrix
CreateTranslationMatrix | VectorGeometry | Creates translation matrix
CreateTriMeshFromBaseMesh | ODEGL | Note that this method requires you to manually deallocate vertices and indices when you're done with the trimesh
CreateVCPlaneFromGLPlane GLVerletClasses
CSG_Operation GLMeshCSG
CubeWireframeBuildList GLObjects
Cubic_Interpolate GLPerlinBase
Cubic_Interpolate_Strip GLPerlinBase
cudaGetLastErrorString GLS_CUDA_Runtime
cudppCompact GLS_CUDA_ParallelPrimitives
cudppDestroyPlan GLS_CUDA_ParallelPrimitives
cudppDestroySparseMatrix GLS_CUDA_ParallelPrimitives
cudppMultiScan GLS_CUDA_ParallelPrimitives
cudppPlan GLS_CUDA_ParallelPrimitives
cudppRand GLS_CUDA_ParallelPrimitives
cudppRandSeed GLS_CUDA_ParallelPrimitives
cudppScan GLS_CUDA_ParallelPrimitives
cudppSegmentedScan GLS_CUDA_ParallelPrimitives
cudppSort GLS_CUDA_ParallelPrimitives
cudppSparseMatrix GLS_CUDA_ParallelPrimitives
cudppSparseMatrixVectorMultiply GLS_CUDA_ParallelPrimitives
CurrentGLContext | GLContext | The TGLContext that is the currently active context, if any.<p> Returns nil if no context is active.
CustomCreateBlankJoint NewtonImport_JointLibrary
CustomDestroyJoint NewtonImport_JointLibrary
CustomGetBodiesCollisionState NewtonImport_JointLibrary
CustomGetBody0 NewtonImport_JointLibrary
CustomGetBody1 NewtonImport_JointLibrary
CustomGetJointID NewtonImport_JointLibrary
CustomGetNewtonJoint NewtonImport_JointLibrary
CustomGetUserData NewtonImport_JointLibrary
CustomJoint6DOF_GetAngularLimits NewtonImport_JointLibrary
CustomJoint6DOF_GetLinearLimits NewtonImport_JointLibrary
CustomJoint6DOF_SetAngularLimits NewtonImport_JointLibrary
CustomJoint6DOF_SetLinearLimits NewtonImport_JointLibrary
CustomJoint6DOF_SetReverseUniversal NewtonImport_JointLibrary
CustomKinematicControllerGetTargetMatrix NewtonImport_JointLibrary
CustomKinematicControllerSetMaxAngularFriction NewtonImport_JointLibrary
CustomKinematicControllerSetMaxLinearFriction NewtonImport_JointLibrary
CustomKinematicControllerSetPickMode NewtonImport_JointLibrary
CustomKinematicControllerSetTargetMatrix NewtonImport_JointLibrary
CustomKinematicControllerSetTargetPosit NewtonImport_JointLibrary
CustomKinematicControllerSetTargetRotation NewtonImport_JointLibrary
CustomPlayerControllerGetMaxSlope NewtonImport_JointLibrary
CustomPlayerControllerGetSensorShape NewtonImport_JointLibrary
CustomPlayerControllerGetVisualMaTrix NewtonImport_JointLibrary
CustomPlayerControllerSetMaxSlope NewtonImport_JointLibrary
CustomPlayerControllerSetVelocity NewtonImport_JointLibrary
CustomSetBodiesCollisionState NewtonImport_JointLibrary
CustomSetDestructorCallback NewtonImport_JointLibrary
CustomSetJointID NewtonImport_JointLibrary
CustomSetSubmitContraintCallback NewtonImport_JointLibrary
CustomSetUserData NewtonImport_JointLibrary
Cylindrical_Cartesian | GeometryCoordinates | Convert cylindrical to cartesian [single]. theta in rad
Cylindrical_Cartesian | GeometryCoordinates | Convert cylindrical to cartesian [double] (with error check). theta in rad
Cylindrical_Cartesian | GeometryCoordinates | Convert cylindrical to cartesian [single] (with error check). theta in rad
Cylindrical_Cartesian | GeometryCoordinates | Convert cylindrical to cartesian [double]. theta in rads
dAreConnected ODEImport
dAreConnectedExcluding ODEImport
dBodyAddForce ODEImport
dBodyAddForceAtPos ODEImport
dBodyAddForceAtRelPos ODEImport
dBodyAddRelForce ODEImport
dBodyAddRelForceAtPos ODEImport
dBodyAddRelForceAtRelPos ODEImport
dBodyAddRelTorque ODEImport
dBodyAddTorque ODEImport
dBodyCopyPosition ODEImport
dBodyCopyQuaternion ODEImport
dBodyCopyRotation ODEImport
dBodyCreate ODEImport
dBodyDestroy ODEImport
dBodyDisable ODEImport
dBodyEnable ODEImport
dBodyGetAngularDamping ODEImport
dBodyGetAngularDampingThreshold ODEImport
dBodyGetAngularVel ODEImport
dBodyGetAutoDisableAngularThreshold ODEImport
dBodyGetAutoDisableFlag ODEImport
dBodyGetAutoDisableLinearThreshold ODEImport
dBodyGetAutoDisableSteps ODEImport
dBodyGetAutoDisableTime ODEImport
dBodyGetData ODEImport
dBodyGetFiniteRotationAxis ODEImport
dBodyGetFiniteRotationMode ODEImport
dBodyGetForce ODEImport
dBodyGetGravityMode ODEImport
dBodyGetJoint ODEImport
dBodyGetLinearDamping ODEImport
dBodyGetLinearDampingThreshold ODEImport
dBodyGetLinearVel ODEImport
dBodyGetMass ODEImport
dBodyGetMaxAngularSpeed ODEImport
dBodyGetNumJoints ODEImport
dBodyGetPointVel ODEImport
dBodyGetPosition ODEImport
dBodyGetPosRelPoint ODEImport
dBodyGetQuaternion ODEImport
dBodyGetRelPointPos ODEImport
dBodyGetRelPointVel ODEImport
dBodyGetRotation ODEImport
dBodyGetTorque ODEImport
dBodyIsEnabled ODEImport
dBodySetAngularDamping ODEImport
dBodySetAngularDampingThreshold ODEImport
dBodySetAngularVel ODEImport
dBodySetAutoDisableAngularThreshold ODEImport
dBodySetAutoDisableAverageSamplesCount ODEImport
dBodySetAutoDisableDefaults ODEImport
dBodySetAutoDisableFlag ODEImport
dBodySetAutoDisableLinearThreshold ODEImport
dBodySetAutoDisableSteps ODEImport
dBodySetAutoDisableTime ODEImport
dBodySetDamping ODEImport
dBodySetDampingDefaults ODEImport
dBodySetData ODEImport
dBodySetFiniteRotationAxis ODEImport
dBodySetFiniteRotationMode ODEImport
dBodySetForce ODEImport
dBodySetGravityMode ODEImport
dBodySetLinearDamping ODEImport
dBodySetLinearDampingThreshold ODEImport
dBodySetLinearVel ODEImport
dBodySetMass ODEImport
dBodySetMaxAngularSpeed ODEImport
dBodySetMovedCallback ODEImport
dBodySetPosition ODEImport
dBodySetQuaternion ODEImport
dBodySetRotation ODEImport
dBodySetTorque ODEImport
dBodyToBodyDistance ODEGL
dBodyVectorFromWorld ODEImport
dBodyVectorToWorld ODEImport
dBoxTouchesBox ODEImport
dClearUpperTriangle ODEImport
dCloseODE ODEImport
dClosestLineSegmentPoints ODEImport
dCollide ODEImport
dCreateBox ODEImport
dCreateCapsule ODEImport
dCreateConvex ODEImport
dCreateCylinder ODEImport
dCreateGeom ODEImport
dCreateGeomClass ODEImport
dCreateGeomTransform ODEImport
dCreateHeightfield ODEImport
dCreatePlane ODEImport
dCreateRay ODEImport
dCreateSphere ODEImport
dCreateTriMesh ODEImport
dDot ODEImport
dDot ODEImport
dDOT14 ODEImport
dDOT14 ODEImport
dDQfromW ODEImport
DDSHeaderToGLEnum DXTC
DecodeDXT1toBitmap32 DXTC
DecodeDXT3toBitmap32 DXTC
DecodeDXT5toBitmap32 DXTC
DecodeGLTextureTarget GLTextureFormat
deflateInit GLSZLibExApi
deflateInit2 GLSZLibExApi
DegToRad VectorGeometry
DegToRad VectorGeometry
DeleteChunk Utils3DS
DeRegisterCUDAComponentNameChangeEvent GLSCUDA
DeRegisterGLBaseSceneObjectNameChangeEvent | GLScene | Deregister an event handler triggered by any TGLBaseSceneObject Name change.<p> See RegisterGLBaseSceneObjectNameChangeEvent.
DeRegisterGLBehaviourNameChangeEvent | GLScene | Deregister an event handler triggered by any TGLBaseSceneObject Name change.<p> See RegisterGLBaseSceneObjectNameChangeEvent.
DeRegisterGLMaterialExNameChangeEvent GLMaterialEx
DeRegisterManager GLManager
DeRegisterXCollectionDestroyEvent | XCollection | DeRegisters event.
DerivatedPolynom | Polynomials | Calculates the polynom's derivative.
dGeomBoxGetLengths ODEImport
dGeomBoxPointDepth ODEImport
dGeomBoxSetLengths ODEImport
dGeomCapsuleGetParams ODEImport
dGeomCapsulePointDepth ODEImport
dGeomCapsuleSetParams ODEImport
dGeomClearOffset ODEImport
dGeomCopyOffsetPosition ODEImport
dGeomCopyOffsetRotation ODEImport
dGeomCopyPosition ODEImport
dGeomCopyQuaternion ODEImport
dGeomCopyRotation ODEImport
dGeomCylinderGetParams ODEImport
dGeomCylinderSetParams ODEImport
dGeomDestroy ODEImport
dGeomDisable ODEImport
dGeomEnable ODEImport
dGeomGetAABB ODEImport
dGeomGetBody ODEImport
dGeomGetCategoryBits ODEImport
dGeomGetClass ODEImport
dGeomGetClassData ODEImport
dGeomGetCollideBits ODEImport
dGeomGetData ODEImport
dGeomGetOffsetPosition ODEImport
dGeomGetOffsetQuaternion ODEImport
dGeomGetOffsetRotation ODEImport
dGeomGetPosition ODEImport
dGeomGetQuaternion ODEImport
dGeomGetRotation ODEImport
dGeomGetSpace ODEImport
dGeomHeightfieldDataCreate ODEImport
dGeomHeightfieldDataDestroy ODEImport
dGeomHeightfieldDataSetBounds ODEImport
dGeomHeightfieldGetHeightfieldData ODEImport
dGeomHeightfieldSetHeightfieldData ODEImport
dGeomIsEnabled ODEImport
dGeomIsOffset ODEImport
dGeomIsSpace ODEImport
dGeomPlaneGetParams ODEImport
dGeomPlanePointDepth ODEImport
dGeomPlaneSetParams ODEImport
dGeomRayGet ODEImport
dGeomRayGetClosestHit ODEImport
dGeomRayGetLength ODEImport
dGeomRayGetParams ODEImport
dGeomRaySet ODEImport
dGeomRaySetClosestHit ODEImport
dGeomRaySetLength ODEImport
dGeomRaySetParams ODEImport
dGeomSetBody ODEImport
dGeomSetCategoryBits ODEImport
dGeomSetCollideBits ODEImport
dGeomSetConvex ODEImport
dGeomSetData ODEImport
dGeomSetOffsetPosition ODEImport
dGeomSetOffsetQuaternion ODEImport
dGeomSetOffsetRotation ODEImport
dGeomSetOffsetWorldPosition ODEImport
dGeomSetOffsetWorldQuaternion ODEImport
dGeomSetOffsetWorldRotation ODEImport
dGeomSetPosition ODEImport
dGeomSetQuaternion ODEImport
dGeomSetRotation ODEImport
dGeomSphereGetRadius ODEImport
dGeomSpherePointDepth ODEImport
dGeomSphereSetRadius ODEImport
dGeomTransformGetCleanup ODEImport
dGeomTransformGetGeom ODEImport
dGeomTransformGetInfo ODEImport
dGeomTransformSetCleanup ODEImport
dGeomTransformSetGeom ODEImport
dGeomTransformSetInfo ODEImport
dGeomTriMeshClearTCCache ODEImport
dGeomTriMeshDataBuildDouble ODEImport
dGeomTriMeshDataBuildDouble1 ODEImport
dGeomTriMeshDataBuildSimple ODEImport
dGeomTriMeshDataBuildSimple1 ODEImport
dGeomTriMeshDataBuildSingle ODEImport
dGeomTriMeshDataBuildSingle1 ODEImport
dGeomTriMeshDataCreate ODEImport
dGeomTriMeshDataDestroy ODEImport
dGeomTriMeshDataSet ODEImport
dGeomTriMeshDataUpdate ODEImport
dGeomTriMeshEnableTC ODEImport
dGeomTriMeshGetArrayCallback ODEImport
dGeomTriMeshGetCallback ODEImport
dGeomTriMeshGetData ODEImport
dGeomTriMeshGetPoint ODEImport
dGeomTriMeshGetRayCallback ODEImport
dGeomTriMeshGetTriangle ODEImport
dGeomTriMeshGetTriangleCount ODEImport
dGeomTriMeshGetTriMeshDataID ODEImport
dGeomTriMeshIsTCEnabled ODEImport
dGeomTriMeshSetArrayCallback ODEImport
dGeomTriMeshSetCallback ODEImport
dGeomTriMeshSetData ODEImport
dGeomTriMeshSetRayCallback ODEImport
DGRaycastVehicleAddTire NewtonImport_JointLibrary
DGRaycastVehicleCreate NewtonImport_JointLibrary
DGRaycastVehicleGetTireMatrix NewtonImport_JointLibrary
DGRaycastVehicleGetTiresCount NewtonImport_JointLibrary
DGRaycastVehicleGetTiresUserData NewtonImport_JointLibrary
DGRaycastVehicleInitNormalizeTireLateralForce NewtonImport_JointLibrary
DGRaycastVehicleInitNormalizeTireLongitudinalForce NewtonImport_JointLibrary
DGRaycastVehicleSetTireTransformCallback NewtonImport_JointLibrary
dHashSpaceCreate ODEImport
dHashSpaceGetLevels ODEImport
dHashSpaceSetLevels ODEImport
dInfiniteAABB ODEImport
dInitODE ODEImport
dInitODE2 ODEImport
DistanceBetweenAngles | VectorGeometry | Calculates the angular distance between two angles in radians.<p> Result is in the [0; PI] range.
Div2 GLGraphics
DivideVector VectorGeometry
DivideVector | VectorGeometry | Divides given vector by another vector.<p> v[x]:=v[x]/divider[x], v[y]:=v[y]/divider[y] etc.
DivMod VectorGeometry
dJointAddAMotorTorques ODEImport
dJointAddHinge2Torques ODEImport
dJointAddHingeTorque ODEImport
dJointAddPistonForce ODEImport
dJointAddPRTorque ODEImport
dJointAddSliderForce ODEImport
dJointAddUniversalTorques ODEImport
dJointAttach ODEImport
dJointCorrectHinge2 ODEImport
dJointCreateAMotor ODEImport
dJointCreateBall ODEImport
dJointCreateContact ODEImport
dJointCreateFixed ODEImport
dJointCreateHinge ODEImport
dJointCreateHinge2 ODEImport
dJointCreateLMotor ODEImport
dJointCreatePiston ODEImport
dJointCreatePlane2D ODEImport
dJointCreatePR ODEImport
dJointCreateSlider ODEImport
dJointCreateUniversal ODEImport
dJointDestroy ODEImport
dJointGetAMotorAngle ODEImport
dJointGetAMotorAngleRate ODEImport
dJointGetAMotorAxis ODEImport
dJointGetAMotorAxisRel ODEImport
dJointGetAMotorMode ODEImport
dJointGetAMotorNumAxes ODEImport
dJointGetAMotorParam ODEImport
dJointGetBallAnchor ODEImport
dJointGetBallAnchor2 ODEImport
dJointGetBody ODEImport
dJointGetData ODEImport
dJointGetFeedback ODEImport
dJointGetHinge2Anchor ODEImport
dJointGetHinge2Anchor2 ODEImport
dJointGetHinge2Angle1 ODEImport
dJointGetHinge2Angle1Rate ODEImport
dJointGetHinge2Angle2Rate ODEImport
dJointGetHinge2Axis1 ODEImport
dJointGetHinge2Axis2 ODEImport
dJointGetHinge2Param ODEImport
dJointGetHingeAnchor ODEImport
dJointGetHingeAnchor2 ODEImport
dJointGetHingeAngle ODEImport
dJointGetHingeAngleRate ODEImport
dJointGetHingeAxis ODEImport
dJointGetHingeParam ODEImport
dJointGetLMotorAxis ODEImport
dJointGetLMotorNumAxes ODEImport
dJointGetLMotorParam ODEImport
dJointGetPistonAnchor ODEImport
dJointGetPistonAnchor2 ODEImport
dJointGetPistonAngle ODEImport
dJointGetPistonAngleRate ODEImport
dJointGetPistonAxis ODEImport
dJointGetPistonParam ODEImport
dJointGetPistonPosition ODEImport
dJointGetPistonRate ODEImport
dJointGetPRAxis1 ODEImport
dJointGetPRAxis2 ODEImport
dJointGetPRParam ODEImport
dJointGetSliderAxis ODEImport
dJointGetSliderParam ODEImport
dJointGetSliderPosition ODEImport
dJointGetSliderPositionRate ODEImport
dJointGetType ODEImport
dJointGetUniversalAnchor ODEImport
dJointGetUniversalAnchor2 ODEImport
dJointGetUniversalAngle1 ODEImport
dJointGetUniversalAngle1Rate ODEImport
dJointGetUniversalAngle2 ODEImport
dJointGetUniversalAngle2Rate ODEImport
dJointGetUniversalAxis1 ODEImport
dJointGetUniversalAxis2 ODEImport
dJointGetUniversalParam ODEImport
dJointGroupCreate ODEImport
dJointGroupDestroy ODEImport
dJointGroupEmpty ODEImport
dJointSetAMotorAngle ODEImport
dJointSetAMotorAxis ODEImport
dJointSetAMotorMode ODEImport
dJointSetAMotorNumAxes ODEImport
dJointSetAMotorParam ODEImport
dJointSetBallAnchor ODEImport
dJointSetData ODEImport
dJointSetFeedback ODEImport
dJointSetFixed ODEImport
dJointSetHinge2Anchor ODEImport
dJointSetHinge2Axis1 ODEImport
dJointSetHinge2Axis2 ODEImport
dJointSetHinge2Param ODEImport
dJointSetHingeAnchor ODEImport
dJointSetHingeAxis ODEImport
dJointSetHingeParam ODEImport
dJointSetLMotorAxis ODEImport
dJointSetLMotorNumAxes ODEImport
dJointSetLMotorParam ODEImport
dJointSetPistonAnchor ODEImport
dJointSetPistonAxis ODEImport
dJointSetPistonAxisDelta ODEImport
dJointSetPistonParam ODEImport
dJointSetPlane2DAngleParam ODEImport
dJointSetPlane2DXParam ODEImport
dJointSetPlane2DYParam ODEImport
dJointSetPRAnchor ODEImport
dJointSetPRAxis1 ODEImport
dJointSetPRAxis2 ODEImport
dJointSetPRParam ODEImport
dJointSetSliderAxis ODEImport
dJointSetSliderParam ODEImport
dJointSetUniversalAnchor ODEImport
dJointSetUniversalAxis1 ODEImport
dJointSetUniversalAxis2 ODEImport
dJointSetUniversalParam ODEImport
dMakeRandomMatrix ODEImport
dMakeRandomVector ODEImport
dMassAdd ODEImport
dMassAdjust ODEImport
dMassRotate ODEImport
dMassSetBox ODEImport
dMassSetBoxTotal ODEImport
dMassSetCapsule ODEImport
dMassSetCapsuleTotal ODEImport
dMassSetCylinder ODEImport
dMassSetCylinderTotal ODEImport
dMassSetParameters ODEImport
dMassSetSphere ODEImport
dMassSetSphereTotal ODEImport
dMassSetTrimesh ODEImport
dMassSetTrimeshTotal ODEImport
dMassSetZero ODEImport
dMassTranslate ODEImport
dMaxDifference ODEImport
dMultiply0 ODEImport
dMULTIPLY0_331 ODEImport
dMULTIPLY0_333 ODEImport
dMultiply1 ODEImport
dMultiply2 ODEImport
dNormalize3 ODEImport
dNormalize4 ODEImport
DodecahedronBuildList GLObjects
DoTesselate | GLGLUTesselation | Tesselates the polygon outlined by the Vertexes. And addeds them to the first facegroup of the Mesh.
dQFromAxisAndAngle ODEImport
dQfromR ODEImport
dQMultiply0 ODEImport
dQMultiply1 ODEImport
dQMultiply2 ODEImport
dQMultiply3 ODEImport
dQSetIdentity ODEImport
dQuadTreeSpaceCreate ODEImport
dRandGetSeed ODEImport
dRandInt ODEImport
dRandReal ODEImport
dRandSetSeed ODEImport
DrawBox ODEGL
DrawDibBegin GLSVfw
DrawDibChangePalette GLSVfw
DrawDibClose GLSVfw
DrawDibDraw GLSVfw
DrawDibEnd GLSVfw
DrawDibGetBuffer GLSVfw
DrawDibGetPalette GLSVfw
DrawDibOpen GLSVfw
DrawDibProfileDisplay GLSVfw
DrawDibRealize GLSVfw
DrawDibSetPalette GLSVfw
DrawDibStart GLSVfw
DrawDibStop GLSVfw
DrawDibTime GLSVfw
DrawDibUpdate GLSVfw
DrawTexturedScreenQuad GLCustomShader
DrawTexturedScreenQuad2 GLCustomShader
DrawTexturedScreenQuad3 GLCustomShader
DrawTexturedScreenQuad4 GLCustomShader
DrawTexturedScreenQuad5 GLCustomShader
DrawTexturedScreenQuad6 GLCustomShader
dRFrom2Axes ODEImport
dRFromAxisAndAngle ODEImport
dRFromEulerAngles ODEImport
dRfromQ ODEImport
dRFromZAxis ODEImport
dRSetIdentity ODEImport
dsDrawBox ODEGL
dsDrawBox ODEGL
dSimpleSpaceCreate ODEImport
dSpaceAdd ODEImport
dSpaceClean ODEImport
dSpaceCollide ODEImport
dSpaceCollide2 ODEImport
dSpaceDestroy ODEImport
dSpaceGetCleanup ODEImport
dSpaceGetGeom ODEImport
dSpaceGetNumGeoms ODEImport
dSpaceQuery ODEImport
dSpaceRemove ODEImport
dSpaceSetCleanup ODEImport
dTestMatrixComparison ODEImport
dTestRand ODEImport
dTestSolveLCP ODEImport
DumpChunk Utils3DS
DumpKeyHeader Utils3DS
dVector3Length ODEGL
dVector3Length ODEGL
dWorldCreate ODEImport
dWorldDestroy ODEImport
dWorldExportDIF ODEImport
dWorldGetAngularDamping ODEImport
dWorldGetAngularDampingThreshold ODEImport
dWorldGetAutoDisableAngularAverageThreshold ODEImport
dWorldGetAutoDisableAngularThreshold ODEImport
dWorldGetAutoDisableAverageSamplesCount ODEImport
dWorldGetAutoDisableFlag ODEImport
dWorldGetAutoDisableLinearAverageThreshold ODEImport
dWorldGetAutoDisableLinearThreshold ODEImport
dWorldGetAutoDisableSteps ODEImport
dWorldGetAutoDisableTime ODEImport
dWorldGetAutoEnableDepthSF1 ODEImport
dWorldGetCFM ODEImport
dWorldGetContactMaxCorrectingVel ODEImport
dWorldGetContactSurfaceLayer ODEImport
dWorldGetERP ODEImport
dWorldGetGravity ODEImport
dWorldGetLinearDamping ODEImport
dWorldGetLinearDampingThreshold ODEImport
dWorldGetMaxAngularSpeed ODEImport
dWorldGetQuickStepNumIterations ODEImport
dWorldGetQuickStepW ODEImport
dWorldImpulseToForce ODEImport
dWorldQuickStep ODEImport
dWorldSetAngularDamping ODEImport
dWorldSetAngularDampingThreshold ODEImport
dWorldSetAutoDisableAngularAverageThreshold ODEImport
dWorldSetAutoDisableAngularThreshold ODEImport
dWorldSetAutoDisableAverageSamplesCount ODEImport
dWorldSetAutoDisableFlag ODEImport
dWorldSetAutoDisableLinearAverageThreshold ODEImport
dWorldSetAutoDisableLinearThreshold ODEImport
dWorldSetAutoDisableSteps ODEImport
dWorldSetAutoDisableTime ODEImport
dWorldSetAutoEnableDepthSF1 ODEImport
dWorldSetCFM ODEImport
dWorldSetContactMaxCorrectingVel ODEImport
dWorldSetContactSurfaceLayer ODEImport
dWorldSetDamping ODEImport
dWorldSetERP ODEImport
dWorldSetGravity ODEImport
dWorldSetLinearDamping ODEImport
dWorldSetLinearDampingThreshold ODEImport
dWorldSetMaxAngularSpeed ODEImport
dWorldSetQuickStepNumIterations ODEImport
dWorldSetQuickStepW ODEImport
dWorldStep ODEImport
dWorldStepFast1 ODEImport
ECAddBox GLDCEMisc
ECAddEllipsoid GLDCEMisc
ECAddFreeForm GLDCEMisc
ECAddTerrain GLDCEMisc
ECResetColliders GLDCEMisc
ECSetCollisionRange GLDCEMisc
EditGLTextureImage | GLTextureImageEditors | Invokes the editor for the given TGLTextureImage
EditStreamClone GLSVfw
EditStreamCopy GLSVfw
EditStreamCut GLSVfw
EditStreamPaste GLSVfw
EditStreamSetInfo GLSVfw
EditStreamSetInfoA GLSVfw
EditStreamSetInfoW GLSVfw
EditStreamSetName GLSVfw
EditStreamSetNameA GLSVfw
EditStreamSetNameW GLSVfw
EncodeGLTextureTarget GLTextureFormat
EndFPUOnlySection | VectorGeometry | Ends a FPU-only section.<p> See BeginFPUOnlySection.
EvalPolynom | Polynomials | Computes polynom's value for given x.
ExponateCrap GLPerlinBase
ExtendedFrustumIntersectsBSphere SpatialPartitioning
ExtendedFrustumMake SpatialPartitioning
ExtendedFrustumMakeFromSceneViewer GLSpatialPartitioning
ExtendedFrustumMakeFromSceneViewer | GLSpatialPartitioning | Create an extended frustum from a GLSceneViewer - this makes the unit specific to the windows platform!
ExtractAABBCorners GeometryBB
ExtractFrustumFromModelViewProjection | VectorGeometry | Extracts a TFrustum for combined modelview and projection matrices.
FacesSmooth GLMeshOptimizer
FastArcTan2 | VectorGeometry | Fast ArcTan2 approximation, about 0.07 rads accuracy.
FastCheckCubeVsCube GLCollision
FastCheckCubeVsEllipsoid GLCollision
FastCheckCubeVsFace GLCollision
FastCheckCubeVsPoint GLCollision
FastCheckCubeVsSphere GLCollision
FastCheckEllipsoidVsCube GLCollision
FastCheckEllipsoidVsEllipsoid GLCollision
FastCheckEllipsoidVsPoint GLCollision
FastCheckEllipsoidVsSphere GLCollision
FastCheckFaceVsCube GLCollision
FastCheckFaceVsFace GLCollision
FastCheckPointVsCube GLCollision
FastCheckPointVsEllipsoid GLCollision
FastCheckPointVsPoint GLCollision
FastCheckPointVsSphere GLCollision
FastCheckSphereVsCube GLCollision
FastCheckSphereVsEllipsoid GLCollision
FastCheckSphereVsPoint GLCollision
FastCheckSphereVsSphere GLCollision
FastQuickSortLists | VectorLists | Sort the refList in ascending order, ordering objList on the way.<p> Use if, and *ONLY* if refList contains only values superior or equal to 1.
FileStreamExists | ApplicationFileIO | Queries is a file stream corresponding to the fileName exists.<p>
FillUniformAutoSetMethodList GLSLParameter
FillUniformAutoSetMethodList GLSLParameter
FindChunk Utils3DS
FindChunkById LWObjects
FindClipByClipIndex LWObjects
FindCompatibleDataFormat | GLTextureFormat | Give compatible openGL image format and data type.
FindDDSCompatibleDataFormat DXTC
FindGLTextureImageClass | GLTexture | Finds a registerer TGLTextureImageClass using its classname
FindGLTextureImageClassByFriendlyName | GLTexture | Finds a registerer TGLTextureImageClass using its FriendlyName
FindManager GLManager
FindNamedObjectByIndex Utils3DS
FindNextChunk Utils3DS
FindRoot | Polynomials | Finds a root between min and max with a precision of epsilon.<p> The evaluation of min/max must be of opposit sign
FindSurfaceByName LWObjects
FindSurfaceByTag LWObjects
FindVMapByName LWObjects
FindXCollectionItemClass | XCollection | Retrieves a registered TXCollectionItemClass from its classname.
FindXMLNode GLSCrossXML
FixPathDelimiter | GLCrossPlatform | Replace path delimiter to delimiter of the current platform.
flip_blocks_dxtc1 DXTC
flip_blocks_dxtc3 DXTC
flip_blocks_dxtc5 DXTC
flip_dxt5_alpha DXTC
Float2rgbe RGBE
FloatToHalf GLCrossPlatform
Floor VectorGeometry
Floor64 VectorGeometry
FMOD_ErrorString fmoderrors
FMOD_Load fmod
FMOD_Load fmoddyn
FMOD_Unload fmod
FMOD_Unload fmoddyn
FMUSIC_FreeSong fmod
FMUSIC_GetBPM fmod
FMUSIC_GetGlobalVolume fmod
FMUSIC_GetMasterVolume fmod
FMUSIC_GetName fmod
FMUSIC_GetNumChannels fmod
FMUSIC_GetNumInstruments fmod
FMUSIC_GetNumOrders fmod
FMUSIC_GetNumPatterns fmod
FMUSIC_GetNumSamples fmod
FMUSIC_GetOpenState fmod
FMUSIC_GetOrder fmod
FMUSIC_GetPattern fmod
FMUSIC_GetPatternLength fmod
FMUSIC_GetPaused fmod
FMUSIC_GetRealChannel fmod
FMUSIC_GetRow fmod
FMUSIC_GetSample fmod
FMUSIC_GetSpeed fmod
FMUSIC_GetTime fmod
FMUSIC_GetType fmod
FMUSIC_GetUserData fmod
FMUSIC_IsFinished fmod
FMUSIC_IsPlaying fmod
FMUSIC_LoadSong fmod
FMUSIC_LoadSongEx fmod
FMUSIC_OptimizeChannels fmod
FMUSIC_PlaySong fmod
FMUSIC_SetInstCallback fmod
FMUSIC_SetLooping fmod
FMUSIC_SetMasterSpeed fmod
FMUSIC_SetMasterVolume fmod
FMUSIC_SetOrder fmod
FMUSIC_SetOrderCallback fmod
FMUSIC_SetPanSeperation fmod
FMUSIC_SetPaused fmod
FMUSIC_SetReverb fmod
FMUSIC_SetRowCallback fmod
FMUSIC_SetSample fmod
FMUSIC_SetUserData fmod
FMUSIC_SetZxxCallback fmod
FMUSIC_StopAllSongs fmod
FMUSIC_StopSong fmod
FontManager GLSpaceText
Frac VectorGeometry
FRAMES_TO_MSF GLSDL
FreeAndNil GLSDL
FreeChunkData Utils3DS
FromHex GLSVfw
FrustumContainsAABB GeometryBB
FrustumContainsBSphere GeometryBB
FSOUND_3D_GetAttributes fmod
FSOUND_3D_GetMinMaxDistance fmod
FSOUND_3D_Listener_GetAttributes fmod
FSOUND_3D_Listener_SetAttributes fmod
FSOUND_3D_Listener_SetCurrent fmod
FSOUND_3D_SetAttributes fmod
FSOUND_3D_SetDistanceFactor fmod
FSOUND_3D_SetDopplerFactor fmod
FSOUND_3D_SetMinMaxDistance fmod
FSOUND_3D_SetRolloffFactor fmod
FSOUND_CD_GetNumTracks fmod
FSOUND_CD_GetPaused fmod
FSOUND_CD_GetTrack fmod
FSOUND_CD_GetTrackLength fmod
FSOUND_CD_GetTrackTime fmod
FSOUND_CD_GetVolume fmod
FSOUND_CD_OpenTray fmod
FSOUND_CD_Play fmod
FSOUND_CD_SetPaused fmod
FSOUND_CD_SetPlayMode fmod
FSOUND_CD_SetTrackTime fmod
FSOUND_CD_SetVolume fmod
FSOUND_CD_Stop fmod
FSOUND_Close fmod
FSOUND_DSP_ClearMixBuffer fmod
FSOUND_DSP_Create fmod
FSOUND_DSP_Free fmod
FSOUND_DSP_GetActive fmod
FSOUND_DSP_GetBufferLength fmod
FSOUND_DSP_GetBufferLengthTotal fmod
FSOUND_DSP_GetClearUnit fmod
FSOUND_DSP_GetClipAndCopyUnit fmod
FSOUND_DSP_GetFFTUnit fmod
FSOUND_DSP_GetMusicUnit fmod
FSOUND_DSP_GetPriority fmod
FSOUND_DSP_GetSFXUnit fmod
FSOUND_DSP_GetSpectrum fmod
FSOUND_DSP_MixBuffers fmod
FSOUND_DSP_SetActive fmod
FSOUND_DSP_SetPriority fmod
FSOUND_File_SetCallbacks fmod
FSOUND_FX_Disable fmod
FSOUND_FX_Enable fmod
FSOUND_FX_SetChorus fmod
FSOUND_FX_SetCompressor fmod
FSOUND_FX_SetDistortion fmod
FSOUND_FX_SetEcho fmod
FSOUND_FX_SetFlanger fmod
FSOUND_FX_SetGargle fmod
FSOUND_FX_SetI3DL2Reverb fmod
FSOUND_FX_SetParamEQ fmod
FSOUND_FX_SetWavesReverb fmod
FSOUND_GetAmplitude fmod
FSOUND_GetChannelsPlaying fmod
FSOUND_GetCPUUsage fmod
FSOUND_GetCurrentLevels fmod
FSOUND_GetCurrentPosition fmod
FSOUND_GetCurrentSample fmod
FSOUND_GetDriver fmod
FSOUND_GetDriverCaps fmod
FSOUND_GetDriverName fmod
FSOUND_GetError fmod
FSOUND_GetFrequency fmod
FSOUND_GetLoopMode fmod
FSOUND_GetMaxChannels fmod
FSOUND_GetMaxSamples fmod
FSOUND_GetMemoryStats fmod
FSOUND_GetMixer fmod
FSOUND_GetMute fmod
FSOUND_GetNumDrivers fmod
FSOUND_GetNumHWChannels fmod
FSOUND_GetNumSubChannels fmod
FSOUND_GetOutput fmod
FSOUND_GetOutputHandle fmod
FSOUND_GetOutputRate fmod
FSOUND_GetPan fmod
FSOUND_GetPaused fmod
FSOUND_GetPriority fmod
FSOUND_GetReserved fmod
FSOUND_GetSFXMasterVolume fmod
FSOUND_GetSubChannel fmod
FSOUND_GetSurround fmod
FSOUND_GetVersion fmod
FSOUND_GetVolume fmod
FSOUND_Init fmod
FSOUND_IsPlaying fmod
FSOUND_PlaySound fmod
FSOUND_PlaySoundEx fmod
FSOUND_Record_GetDriver fmod
FSOUND_Record_GetDriverName fmod
FSOUND_Record_GetNumDrivers fmod
FSOUND_Record_GetPosition fmod
FSOUND_Record_SetDriver fmod
FSOUND_Record_StartSample fmod
FSOUND_Record_Stop fmod
FSOUND_Reverb_GetChannelProperties fmod
FSOUND_Reverb_GetProperties fmod
FSOUND_Reverb_SetChannelProperties fmod
FSOUND_Reverb_SetProperties fmod
FSOUND_Sample_Alloc fmod
FSOUND_Sample_Free fmod
FSOUND_Sample_Get fmod
FSOUND_Sample_GetDefaults fmod
FSOUND_Sample_GetDefaultsEx fmod
FSOUND_Sample_GetLength fmod
FSOUND_Sample_GetLoopPoints fmod
FSOUND_Sample_GetMinMaxDistance fmod
FSOUND_Sample_GetMode fmod
FSOUND_Sample_GetName fmod
FSOUND_Sample_Load fmod
FSOUND_Sample_Lock fmod
FSOUND_Sample_SetDefaults fmod
FSOUND_Sample_SetDefaultsEx fmod
FSOUND_Sample_SetLoopPoints fmod
FSOUND_Sample_SetMaxPlaybacks fmod
FSOUND_Sample_SetMinMaxDistance fmod
FSOUND_Sample_SetMode fmod
FSOUND_Sample_Unlock fmod
FSOUND_Sample_Upload fmod
FSOUND_SetBufferSize fmod
FSOUND_SetCurrentPosition fmod
FSOUND_SetDriver fmod
FSOUND_SetFrequency fmod
FSOUND_SetHWND fmod
FSOUND_SetLoopMode fmod
FSOUND_SetMaxHardwareChannels fmod
FSOUND_SetMemorySystem fmod
FSOUND_SetMinHardwareChannels fmod
FSOUND_SetMixer fmod
FSOUND_SetMute fmod
FSOUND_SetOutput fmod
FSOUND_SetPan fmod
FSOUND_SetPanSeperation fmod
FSOUND_SetPaused fmod
FSOUND_SetPriority fmod
FSOUND_SetReserved fmod
FSOUND_SetSFXMasterVolume fmod
FSOUND_SetSpeakerMode fmod
FSOUND_SetSurround fmod
FSOUND_SetVolume fmod
FSOUND_SetVolumeAbsolute fmod
FSOUND_StopSound fmod
FSOUND_Stream_AddSyncPoint fmod
FSOUND_Stream_Close fmod
FSOUND_Stream_Create fmod
FSOUND_Stream_CreateDSP fmod
FSOUND_Stream_DeleteSyncPoint fmod
FSOUND_Stream_FindTagField fmod
FSOUND_Stream_GetLength fmod
FSOUND_Stream_GetLengthMs fmod
FSOUND_Stream_GetMode fmod
FSOUND_Stream_GetNumSubStreams fmod
FSOUND_Stream_GetNumSyncPoints fmod
FSOUND_Stream_GetNumTagFields fmod
FSOUND_Stream_GetOpenState fmod
FSOUND_Stream_GetPosition fmod
FSOUND_Stream_GetSample fmod
FSOUND_Stream_GetSyncPoint fmod
FSOUND_Stream_GetSyncPointInfo fmod
FSOUND_Stream_GetTagField fmod
FSOUND_Stream_GetTime fmod
FSOUND_Stream_Net_GetBufferProperties fmod
FSOUND_Stream_Net_GetLastServerStatus fmod
FSOUND_Stream_Net_GetStatus fmod
FSOUND_Stream_Net_SetBufferProperties fmod
FSOUND_Stream_Net_SetMetadataCallback fmod
FSOUND_Stream_Net_SetProxy fmod
FSOUND_Stream_Open fmod
FSOUND_Stream_Play fmod
FSOUND_Stream_PlayEx fmod
FSOUND_Stream_SetBufferSize fmod
FSOUND_Stream_SetEndCallback fmod
FSOUND_Stream_SetLoopCount fmod
FSOUND_Stream_SetLoopPoints fmod
FSOUND_Stream_SetMode fmod
FSOUND_Stream_SetPosition fmod
FSOUND_Stream_SetSubStream fmod
FSOUND_Stream_SetSubStreamSentence fmod
FSOUND_Stream_SetSyncCallback fmod
FSOUND_Stream_SetTime fmod
FSOUND_Stream_Stop fmod
FSOUND_Update fmod
FT_Curve_Tag LIBFREETYPE
FT_Has_Kerning LIBFREETYPE
FT_Is_Scalable LIBFREETYPE
G2_GetVertBoneIndex FileGL2
G2_GetVertBoneWeight FileGL2
G2_GetVertWeights FileGL2
GammaCorrectRGBArray GLGraphics
GenerateBezierCurve CurvesAndSurfaces
GenerateBezierSurface CurvesAndSurfaces
GenerateBSpline CurvesAndSurfaces
GenerateBSplineSurface CurvesAndSurfaces
GenerateKnotVector CurvesAndSurfaces
GeometryOptimizationMode | VectorGeometry | Returns the detected optimization mode.<p> Returned values is either 'FPU', '3DNow!' or 'SSE'.
GetActiveLightsList GLCustomShader
GetAmbientLightMotion Utils3DS
GetArchiveFileFormats GLSArchiveManager
GetArchiveManager GLSArchiveManager
GetAtmosphere Utils3DS
GetBackground Utils3DS
GetBestSelectorClass GLSelection
GetBodyFromGLSceneObject GLNGDManager
GetBodyFromGLSceneObject GLODEManager
GetBodyFromObject | GLODEManager | Helper functions for extracting data from objects with different inheritance.
GetBodyPositionAsAffineVector ODEGL
GetBValue GLColor
GetCameraByIndex Utils3DS
GetCameraCount Utils3DS
GetCameraMotion Utils3DS
GetCameraMotionByIndex Utils3DS
GetCameraNodeCount Utils3DS
GetCameraNodeNameList Utils3DS
GetChannelTypeAndNum GLSCUDA
GetChunkValue Utils3DS
GetContentDir LWObjects
GetCurrentColorDepth | GLCrossPlatform | Number of bits per pixel for the current desktop resolution.
GetCurrentRenderingObject GLScene
GetDatabaseRelease Utils3DS
GetDecimalSeparator GLCrossPlatform
GetDeviceLogicalPixelsX | GLCrossPlatform | Number of pixels per logical inch along the screen width for the device.<p> Under Win32 awaits a HDC and returns its LOGPIXELSX.
getenv GLSDL
GetFPSMovement GLFPSMovement
GetFPSMovement GLFPSMovement
GetGenericCompressedFormat | GLTextureFormat | Give generic compressed OpenGL texture format.
GetGLSceneObject GLODEManager
GetGLSoundFileFormats GLSoundFileObjects
GetGLTextureImageClassesAsStrings | GLTexture | Creates a TStrings with the list of registered TGLTextureImageClass.<p> To be freed by caller.
GetGValue GLColor
GetImageLodNumber | GLGraphics | Return an optimal number of texture pyramid
GetIndexFromResolution GLScreen
GetInertia | GLBehaviours | Returns or creates the TGLBInertia within the given behaviours.<p> This helper function is convenient way to access a TGLBInertia.
GetJPEGInfo GLSJPG
GetJPEGInfo GLSJPG
GetKfRelease Utils3DS
GetKFSettings Utils3DS
GetM3dMagicRelease Utils3DS
GetMaterialByIndex Utils3DS
GetMaterialCount Utils3DS
GetMeshByIndex Utils3DS
GetMeshCount Utils3DS
GetMeshRelease Utils3DS
GetMeshSet Utils3DS
GetModuleSymbol GLSModuleLoader
GetModuleSymbolEx GLSModuleLoader
GetMovement GLMovement
GetMovement GLMovement
GetNGDDynamic GLNGDManager
GetNGDStatic GLNGDManager
GetObjectMotionByIndex Utils3DS
GetObjectMotionByName Utils3DS
GetObjectNodeCount Utils3DS
GetObjectNodeNameList Utils3DS
GetOdeDynamic GLODEManager
GetODEHeightField GLODECustomColliders
GetOdeStatic GLODEManager
GetOmnilightByIndex Utils3DS
GetOmnilightCount Utils3DS
GetOmnilightMotionByIndex Utils3DS
GetOmnilightMotionByName Utils3DS
GetOmnilightNodeCount Utils3DS
GetOmnilightNodeNameList Utils3DS
GetOpenFileNamePreview GLSVfw
GetOpenFileNamePreviewA GLSVfw
GetOpenFileNamePreviewW GLSVfw
GetOrCreateAcceleration | GLBehaviours | Returns or creates the TGLBAcceleration within the given behaviours.<p> This helper function is convenient way to access a TGLBAcceleration.
GetOrCreateAcceleration GLBehaviours
GetOrCreateCollision | GLCollision | Returns or creates the TGLBCollision within the given object's behaviours.<p> This helper function is convenient way to access a TGLBCollision.
GetOrCreateCollision | GLCollision | Returns or creates the TGLBCollision within the given behaviours.<p> This helper function is convenient way to access a TGLBCollision.
GetOrCreateDCEDynamic GLDCE
GetOrCreateDCEDynamic GLDCE
GetOrCreateDCEStatic GLDCE
GetOrCreateDCEStatic GLDCE
GetOrCreateFireFX | GLFireFX | Returns or creates the TGLBFireFX within the given object's behaviours.<p> This helper function is convenient way to access a TGLBFireFX.
GetOrCreateFireFX | GLFireFX | Returns or creates the TGLBFireFX within the given behaviours.<p> This helper function is convenient way to access a TGLBFireFX.
GetOrCreateFPSMovement GLFPSMovement
GetOrCreateFPSMovement GLFPSMovement
GetOrCreateInertia GLBehaviours
GetOrCreateInertia GLBehaviours
GetOrCreateMovement GLMovement
GetOrCreateMovement GLMovement
GetOrCreateNGDDynamic GLNGDManager
GetOrCreateNGDStatic GLNGDManager
GetOrCreateOdeDynamic GLODEManager
GetOrCreateODEHeightField GLODECustomColliders
GetOrCreateOdeStatic GLODEManager
GetOrCreateSoundEmitter GLSound
GetOrCreateSoundEmitter GLSound
GetOrCreateSourcePFX | GLParticleFX | Returns or creates the TGLBInertia within the given object's behaviours.<p>
GetOrCreateThorFX GLThorFX
GetPlatformInfo GLCrossPlatform
GetPlatformVersion GLCrossPlatform
GetPlatformVersionStr GLCrossPlatform
GetRasterFileFormats | GLGraphics | Read access to the list of registered vector file formats
GetROAMTrianglesCapacity GLROAMPatch
GetRValue GLColor
GetSafeTurnAngle | VectorGeometry | Calculates angles for the Camera.MoveAroundTarget(pitch, turn) procedure. Initially from then GLCameraColtroller unit, requires AOriginalUpVector to contain only -1, 0 or 1. Result contains pitch and turn angles.
GetSafeTurnAngle VectorGeometry
GetSaveFileNamePreview GLSVfw
GetSaveFileNamePreviewA GLSVfw
GetSaveFileNamePreviewW GLSVfw
GetServiceWindow GLContext
GetSoundLibraryByName GLSound
GetSpotlightByIndex Utils3DS
GetSpotlightCount Utils3DS
GetSpotlightMotionByIndex Utils3DS
GetSpotlightMotionByName Utils3DS
GetSpotlightNodeCount Utils3DS
GetSpotlightNodeNameList Utils3DS
GetSqrt255Array | GLUtils | Returns a pointer to an array containing the results of "255*sqrt(i/255)".
GetSurfaceFromObject GLODEManager
GetTextureCombiners GLTextureCombiners Parses a TC text description and setups combiners accordingly.<p> *experimental*<br> Knowledge of texture combiners is a requirement<br> Syntax: pascal-like, one instruction per line, use '//' for comment.<p>

Examples:<ul> <li>Tex1:=Tex0; // replace texture 1 with texture 0 <li>Tex1:=Tex0+Tex1; // additive blending between textures 0 and 1 <li>Tex1:=Tex0-Tex1; // subtractive blending between textures 0 and 1 <li>Tex1:=Tex0*Tex1; // modulation between textures 0 and 1 <li>Tex1:=Tex0+Tex1-0.5; // signed additive blending between textures 0 and 1 <li>Tex1:=Interpolate(Tex0, Tex1, PrimaryColor); // interpolation between textures 0 and 1 using primary color as factor <li>Tex1:=Dot3(Tex0, Tex1); // dot3 product between textures 0 and 1 </ul><p>

Accepted tokens:<ul> <li>Tex0, Tex1, etc. : texture unit <li>PrimaryColor, Col : the primary color <li>ConstantColor, EnvCol : texture environment constant color </ul><br> Tokens can be qualified with '.a' or '.alpha' to specify the alpha channel explicitly, and '.rgb' to specify color channels (default). You cannot mix alpha and rgb tokens in the same line.

GetTextureElementSize GLTextureFormat
GetTextureElementSize | GLTextureFormat | Give a pixel size in bytes from texture format or data format.
GetUncompressedFormat | GLTextureFormat | Give uncompressed texture format and OpenGL color format.
GetUniformAutoSetMethod GLSLParameter
GetUniformAutoSetMethodName GLSLParameter
GetValueFromStringsIndex GLCrossPlatform
GetVectorFileFormats | GLVectorFileObjects | Read access to the list of registered vector file formats
GetViewport Utils3DS
GetXCollectionClassesList XCollection
GetXCollectionItemClassesList | XCollection | Creates and returns a copy of internal list of TXCollectionItem classes.<p> Returned list should be freed by caller, the parameter defines an ancestor class filter. If baseClass is left nil, TXCollectionItem is used as ancestor.
GetXMLAttribute GLSCrossXML
GetXMLAttribute GLSCrossXML
GetXMLAttributeCount GLSCrossXML
GetXMLText GLSCrossXML
Get_CUDA_API_Error_String GLS_CUDA_API
Get_CUDA_FFT_Error_String GLS_CUDA_FourierTransform
GL GLContext
glAccum OpenGL1x
glAlphaFunc OpenGL1x
glAreTexturesResident OpenGL1x
glArrayElement OpenGL1x
glBegin OpenGL1x
glBindTexture OpenGL1x
glBitmap OpenGL1x
glBlendFunc OpenGL1x
glCallList OpenGL1x
glCallLists OpenGL1x
glClear OpenGL1x
glClearAccum OpenGL1x
glClearColor OpenGL1x
glClearDepth OpenGL1x
glClearIndex OpenGL1x
glClearStencil OpenGL1x
glClipPlane OpenGL1x
glColor3b OpenGL1x
glColor3bv OpenGL1x
glColor3d OpenGL1x
glColor3dv OpenGL1x
glColor3f OpenGL1x
glColor3fv OpenGL1x
glColor3i OpenGL1x
glColor3iv OpenGL1x
glColor3s OpenGL1x
glColor3sv OpenGL1x
glColor3ub OpenGL1x
glColor3ubv OpenGL1x
glColor3ui OpenGL1x
glColor3uiv OpenGL1x
glColor3us OpenGL1x
glColor3usv OpenGL1x
glColor4b OpenGL1x
glColor4bv OpenGL1x
glColor4d OpenGL1x
glColor4dv OpenGL1x
glColor4f OpenGL1x
glColor4fv OpenGL1x
glColor4i OpenGL1x
glColor4iv OpenGL1x
glColor4s OpenGL1x
glColor4sv OpenGL1x
glColor4ub OpenGL1x
glColor4ubv OpenGL1x
glColor4ui OpenGL1x
glColor4uiv OpenGL1x
glColor4us OpenGL1x
glColor4usv OpenGL1x
glColorMask OpenGL1x
glColorMaterial OpenGL1x
glColorPointer OpenGL1x
glCopyPixels OpenGL1x
glCopyTexImage1D OpenGL1x
glCopyTexImage2D OpenGL1x
glCopyTexSubImage1D OpenGL1x
glCopyTexSubImage2D OpenGL1x
glCullFace OpenGL1x
glDeleteLists OpenGL1x
glDeleteTextures OpenGL1x
glDepthFunc OpenGL1x
glDepthMask OpenGL1x
glDepthRange OpenGL1x
GLDirectionFromGeom ODEGL
glDisable OpenGL1x
glDisableClientState OpenGL1x
glDrawArrays OpenGL1x
glDrawBuffer OpenGL1x
glDrawElements OpenGL1x
glDrawPixels OpenGL1x
glEdgeFlag OpenGL1x
glEdgeFlagPointer OpenGL1x
glEdgeFlagv OpenGL1x
glEnable OpenGL1x
glEnableClientState OpenGL1x
glEnd OpenGL1x
glEndList OpenGL1x
GLEnumToDDSHeader DXTC
glEvalCoord1d OpenGL1x
glEvalCoord1dv OpenGL1x
glEvalCoord1f OpenGL1x
glEvalCoord1fv OpenGL1x
glEvalCoord2d OpenGL1x
glEvalCoord2dv OpenGL1x
glEvalCoord2f OpenGL1x
glEvalCoord2fv OpenGL1x
glEvalMesh1 OpenGL1x
glEvalMesh2 OpenGL1x
glEvalPoint1 OpenGL1x
glEvalPoint2 OpenGL1x
glFeedbackBuffer OpenGL1x
glFinish OpenGL1x
glFlush OpenGL1x
glFogf OpenGL1x
glFogfv OpenGL1x
glFogi OpenGL1x
glFogiv OpenGL1x
glFrontFace OpenGL1x
glFrustum OpenGL1x
glGenLists OpenGL1x
glGenTextures OpenGL1x
glGetBooleanv OpenGL1x
glGetClipPlane OpenGL1x
GLGetCursorPos GLScreen
glGetDoublev OpenGL1x
glGetError OpenGL1x
glGetFloatv OpenGL1x
glGetIntegerv OpenGL1x
glGetLightfv OpenGL1x
glGetLightiv OpenGL1x
glGetMapdv OpenGL1x
glGetMapfv OpenGL1x
glGetMapiv OpenGL1x
glGetMaterialfv OpenGL1x
glGetMaterialiv OpenGL1x
glGetPixelMapfv OpenGL1x
glGetPixelMapuiv OpenGL1x
glGetPixelMapusv OpenGL1x
glGetPointerv OpenGL1x
glGetPolygonStipple OpenGL1x
GLGetProcAddress OpenGLAdapter
GLGetProcAddress OpenGL1x
GLGetScreenHeight GLScreen
GLGetScreenWidth GLScreen
glGetString OpenGL1x
glGetTexEnvfv OpenGL1x
glGetTexEnviv OpenGL1x
glGetTexGendv OpenGL1x
glGetTexGenfv OpenGL1x
glGetTexGeniv OpenGL1x
glGetTexImage OpenGL1x
glGetTexLevelParameterfv OpenGL1x
glGetTexLevelParameteriv OpenGL1x
glGetTexParameterfv OpenGL1x
glGetTexParameteriv OpenGL1x
GLGetTickCount GLCrossPlatform
glHint OpenGL1x
glIndexd OpenGL1x
glIndexdv OpenGL1x
glIndexf OpenGL1x
glIndexfv OpenGL1x
glIndexi OpenGL1x
glIndexiv OpenGL1x
glIndexMask OpenGL1x
glIndexPointer OpenGL1x
glIndexs OpenGL1x
glIndexsv OpenGL1x
glIndexub OpenGL1x
glIndexubv OpenGL1x
glInitNames OpenGL1x
glInterleavedArrays OpenGL1x
glIsEnabled OpenGL1x
glIsList OpenGL1x
glIsTexture OpenGL1x
GLLibGetProcAddress OpenGL1x
GLLibGetProcAddress OpenGLAdapter
glLightf OpenGL1x
glLightfv OpenGL1x
glLighti OpenGL1x
glLightiv OpenGL1x
glLightModelf OpenGL1x
glLightModelfv OpenGL1x
glLightModeli OpenGL1x
glLightModeliv OpenGL1x
glLineStipple OpenGL1x
glLineWidth OpenGL1x
glListBase OpenGL1x
GLLoadBitmapFromInstance GLCrossPlatform
glLoadIdentity OpenGL1x
glLoadMatrixd OpenGL1x
glLoadMatrixf OpenGL1x
glLoadName OpenGL1x
glLogicOp OpenGL1x
glMap1d OpenGL1x
glMap1f OpenGL1x
glMap2d OpenGL1x
glMap2f OpenGL1x
glMapGrid1d OpenGL1x
glMapGrid1f OpenGL1x
glMapGrid2d OpenGL1x
glMapGrid2f OpenGL1x
glMaterialf OpenGL1x
glMaterialfv OpenGL1x
glMateriali OpenGL1x
glMaterialiv OpenGL1x
GLMatrixFromGeom ODEGL
glMatrixMode OpenGL1x
glMultMatrixd OpenGL1x
glMultMatrixf OpenGL1x
glNewList OpenGL1x
glNormal3b OpenGL1x
glNormal3bv OpenGL1x
glNormal3d OpenGL1x
glNormal3dv OpenGL1x
glNormal3f OpenGL1x
glNormal3fv OpenGL1x
glNormal3i OpenGL1x
glNormal3iv OpenGL1x
glNormal3s OpenGL1x
glNormal3sv OpenGL1x
glNormalPointer OpenGL1x
GLOKMessageBox GLCrossPlatform
glOrtho OpenGL1x
glPassThrough OpenGL1x
glPixelMapfv OpenGL1x
glPixelMapuiv OpenGL1x
glPixelMapusv OpenGL1x
glPixelStoref OpenGL1x
glPixelStorei OpenGL1x
glPixelTransferf OpenGL1x
glPixelTransferi OpenGL1x
glPixelZoom OpenGL1x
GLPoint GLCrossPlatform
glPointSize OpenGL1x
glPolygonMode OpenGL1x
glPolygonOffset OpenGL1x
glPolygonStipple OpenGL1x
glPopAttrib OpenGL1x
glPopClientAttrib OpenGL1x
glPopMatrix OpenGL1x
glPopName OpenGL1x
glPrioritizeTextures OpenGL1x
glPushAttrib OpenGL1x
glPushClientAttrib OpenGL1x
glPushMatrix OpenGL1x
glPushName OpenGL1x
glRasterPos2d OpenGL1x
glRasterPos2dv OpenGL1x
glRasterPos2f OpenGL1x
glRasterPos2fv OpenGL1x
glRasterPos2i OpenGL1x
glRasterPos2iv OpenGL1x
glRasterPos2s OpenGL1x
glRasterPos2sv OpenGL1x
glRasterPos3d OpenGL1x
glRasterPos3dv OpenGL1x
glRasterPos3f OpenGL1x
glRasterPos3fv OpenGL1x
glRasterPos3i OpenGL1x
glRasterPos3iv OpenGL1x
glRasterPos3s OpenGL1x
glRasterPos3sv OpenGL1x
glRasterPos4d OpenGL1x
glRasterPos4dv OpenGL1x
glRasterPos4f OpenGL1x
glRasterPos4fv OpenGL1x
glRasterPos4i OpenGL1x
glRasterPos4iv OpenGL1x
glRasterPos4s OpenGL1x
glRasterPos4sv OpenGL1x
glReadBuffer OpenGL1x
glReadPixels OpenGL1x
GLRect GLCrossPlatform
glRectd OpenGL1x
glRectdv OpenGL1x
glRectf OpenGL1x
glRectfv OpenGL1x
glRecti OpenGL1x
glRectiv OpenGL1x
glRects OpenGL1x
glRectsv OpenGL1x
GLRegisterWSComponent GLSceneForm
GLRegisterWSComponent GLWidgetContext
glRenderMode OpenGL1x
glRotated OpenGL1x
glRotatef OpenGL1x
glScaled OpenGL1x
glScalef OpenGL1x
GLSceneEditorForm GLSceneEditLCL
GLSceneEditorForm GLSceneEdit
GLSceneMatrixToODER ODEGL
glScissor OpenGL1x
GLSCUDAEditorForm GLSCUDAEditor
glSelectBuffer OpenGL1x
GLSetCursorPos GLScreen
glShadeModel OpenGL1x
GLShaderEditorForm FShaderMemo
GLShowCursor GLScreen
GLSLogger GLSLog
GLSLTypeComponentCount GLSLParameter
GLSLTypeEnum GLSLParameter
GLSNewXMLDocument GLSCrossXML
glStencilFunc OpenGL1x
glStencilMask OpenGL1x
glStencilOp OpenGL1x
GLSTime | GLCrossPlatform | Returns time in milisecond from application start.<p>
glTexCoord1d OpenGL1x
glTexCoord1dv OpenGL1x
glTexCoord1f OpenGL1x
glTexCoord1fv OpenGL1x
glTexCoord1i OpenGL1x
glTexCoord1iv OpenGL1x
glTexCoord1s OpenGL1x
glTexCoord1sv OpenGL1x
glTexCoord2d OpenGL1x
glTexCoord2dv OpenGL1x
glTexCoord2f OpenGL1x
glTexCoord2fv OpenGL1x
glTexCoord2i OpenGL1x
glTexCoord2iv OpenGL1x
glTexCoord2s OpenGL1x
glTexCoord2sv OpenGL1x
glTexCoord3d OpenGL1x
glTexCoord3dv OpenGL1x
glTexCoord3f OpenGL1x
glTexCoord3fv OpenGL1x
glTexCoord3i OpenGL1x
glTexCoord3iv OpenGL1x
glTexCoord3s OpenGL1x
glTexCoord3sv OpenGL1x
glTexCoord4d OpenGL1x
glTexCoord4dv OpenGL1x
glTexCoord4f OpenGL1x
glTexCoord4fv OpenGL1x
glTexCoord4i OpenGL1x
glTexCoord4iv OpenGL1x
glTexCoord4s OpenGL1x
glTexCoord4sv OpenGL1x
glTexCoordPointer OpenGL1x
glTexEnvf OpenGL1x
glTexEnvfv OpenGL1x
glTexEnvi OpenGL1x
glTexEnviv OpenGL1x
glTexGend OpenGL1x
glTexGendv OpenGL1x
glTexGenf OpenGL1x
glTexGenfv OpenGL1x
glTexGeni OpenGL1x
glTexGeniv OpenGL1x
glTexImage1D OpenGL1x
glTexImage2D OpenGL1x
glTexParameterf OpenGL1x
glTexParameterfv OpenGL1x
glTexParameteri OpenGL1x
glTexParameteriv OpenGL1x
glTexSubImage1D OpenGL1x
glTexSubImage2D OpenGL1x
glTranslated OpenGL1x
glTranslatef OpenGL1x
gluBeginCurve OpenGL1x
gluBeginCurve OpenGLAdapter
gluBeginPolygon OpenGLAdapter
gluBeginPolygon OpenGL1x
gluBeginSurface OpenGLAdapter
gluBeginSurface OpenGL1x
gluBeginTrim OpenGL1x
gluBeginTrim OpenGLAdapter
gluBuild1DMipmaps OpenGLAdapter
gluBuild1DMipmaps OpenGL1x
gluBuild2DMipmaps OpenGL1x
gluBuild2DMipmaps OpenGLAdapter
gluCylinder OpenGL1x
gluCylinder OpenGLAdapter
gluDeleteNurbsRenderer OpenGL1x
gluDeleteNurbsRenderer OpenGLAdapter
gluDeleteQuadric OpenGL1x
gluDeleteQuadric OpenGLAdapter
gluDeleteTess OpenGL1x
gluDeleteTess OpenGLAdapter
gluDisk OpenGLAdapter
gluDisk OpenGL1x
gluEndCurve OpenGL1x
gluEndCurve OpenGLAdapter
gluEndPolygon OpenGL1x
gluEndPolygon OpenGLAdapter
gluEndSurface OpenGLAdapter
gluEndSurface OpenGL1x
gluEndTrim OpenGLAdapter
gluEndTrim OpenGL1x
gluErrorString OpenGLAdapter
gluErrorString OpenGL1x
gluGetNurbsProperty OpenGL1x
gluGetNurbsProperty OpenGLAdapter
gluGetString OpenGL1x
gluGetString OpenGLAdapter
gluGetTessProperty OpenGL1x
gluGetTessProperty OpenGLAdapter
gluLoadSamplingMatrices OpenGL1x
gluLoadSamplingMatrices OpenGLAdapter
gluLookAt OpenGL1x
gluLookAt OpenGLAdapter
gluNewNurbsRenderer OpenGLAdapter
gluNewNurbsRenderer OpenGL1x
gluNewQuadric OpenGLAdapter
gluNewQuadric OpenGL1x
gluNewTess OpenGL1x
gluNewTess OpenGLAdapter
gluNextContour OpenGL1x
gluNextContour OpenGLAdapter
gluNurbsCallback OpenGLAdapter
gluNurbsCallback OpenGL1x
gluNurbsCurve OpenGLAdapter
gluNurbsCurve OpenGL1x
gluNurbsProperty OpenGLAdapter
gluNurbsProperty OpenGL1x
gluNurbsSurface OpenGLAdapter
gluNurbsSurface OpenGL1x
gluOrtho2D OpenGLAdapter
gluOrtho2D OpenGL1x
gluPartialDisk OpenGL1x
gluPartialDisk OpenGLAdapter
gluPerspective OpenGL1x
gluPerspective OpenGLAdapter
gluPickMatrix OpenGLAdapter
gluPickMatrix OpenGL1x
gluProject OpenGLAdapter
gluProject OpenGL1x
gluPwlCurve OpenGLAdapter
gluPwlCurve OpenGL1x
gluQuadricCallback OpenGLAdapter
gluQuadricCallback OpenGL1x
gluQuadricDrawStyle OpenGL1x
gluQuadricDrawStyle OpenGLAdapter
gluQuadricNormals OpenGLAdapter
gluQuadricNormals OpenGL1x
gluQuadricOrientation OpenGLAdapter
gluQuadricOrientation OpenGL1x
gluQuadricTexture OpenGL1x
gluQuadricTexture OpenGLAdapter
gluScaleImage OpenGLAdapter
gluScaleImage OpenGL1x
gluSphere OpenGL1x
gluSphere OpenGLAdapter
gluTessBeginContour OpenGL1x
gluTessBeginContour OpenGLAdapter
gluTessBeginPolygon OpenGLAdapter
gluTessBeginPolygon OpenGL1x
gluTessCallback OpenGL1x
gluTessCallback OpenGLAdapter
gluTessEndContour OpenGL1x
gluTessEndContour OpenGLAdapter
gluTessEndPolygon OpenGLAdapter
gluTessEndPolygon OpenGL1x
gluTessNormal OpenGLAdapter
gluTessNormal OpenGL1x
gluTessProperty OpenGLAdapter
gluTessProperty OpenGL1x
gluTessVertex OpenGL1x
gluTessVertex OpenGLAdapter
gluUnProject OpenGL1x
gluUnProject OpenGLAdapter
glVertex2d OpenGL1x
glVertex2dv OpenGL1x
glVertex2f OpenGL1x
glVertex2fv OpenGL1x
glVertex2i OpenGL1x
glVertex2iv OpenGL1x
glVertex2s OpenGL1x
glVertex2sv OpenGL1x
glVertex3d OpenGL1x
glVertex3dv OpenGL1x
glVertex3f OpenGL1x
glVertex3fv OpenGL1x
glVertex3i OpenGL1x
glVertex3iv OpenGL1x
glVertex3s OpenGL1x
glVertex3sv OpenGL1x
glVertex4d OpenGL1x
glVertex4dv OpenGL1x
glVertex4f OpenGL1x
glVertex4fv OpenGL1x
glVertex4i OpenGL1x
glVertex4iv OpenGL1x
glVertex4s OpenGL1x
glVertex4sv OpenGL1x
glVertexPointer OpenGL1x
glViewport OpenGL1x
GraphicClassForExtension | PictureRegisteredFormats | Returns the TGraphicClass associated to the extension, if any.<p> Accepts anExtension with or without the '.'
GUIComponentDialog GuiSkinEditorFormUnitLCL
GUIComponentDialog GuiSkinEditorFormUnit
GUILayoutEditorForm FGUILayoutEditor
HackTPictureRegisteredFormats | PictureRegisteredFormats | Adds to the passed TStrings the list of registered formats.<p> Convention is "extension=description" for the string, the Objects hold the corresponding TGraphicClass (extensions do not include the '.').
HalfToFloat GLCrossPlatform
HingeCalculateJointOmega NewtonImport_JointLibrary
HingeEnableLimits NewtonImport_JointLibrary
HingeGetJointAngle NewtonImport_JointLibrary
HingeGetPinAxis NewtonImport_JointLibrary
HingeSetLimits NewtonImport_JointLibrary
ICAbout GLSVfw
ICClose GLSVfw
ICCompress GLSVfw
ICCompressBegin GLSVfw
ICCompressEnd GLSVfw
ICCompressGetFormat GLSVfw
ICCompressGetFormatSize GLSVfw
ICCompressGetSize GLSVfw
ICCompressorChoose GLSVfw
ICCompressorFree GLSVfw
ICCompressQuery GLSVfw
ICConfigure GLSVfw
ICDecompress GLSVfw
ICDecompressBegin GLSVfw
ICDecompressEnd GLSVfw
ICDecompressEx GLSVfw
ICDecompressExBegin GLSVfw
ICDecompressExEnd GLSVfw
ICDecompressExQuery GLSVfw
ICDecompressGetFormat GLSVfw
ICDecompressGetFormatSize GLSVfw
ICDecompressGetPalette GLSVfw
ICDecompressOpen GLSVfw
ICDecompressQuery GLSVfw
ICDecompressSetPalette GLSVfw
ICDraw GLSVfw
ICDrawBegin GLSVfw
ICDrawChangePalette GLSVfw
ICDrawEnd GLSVfw
ICDrawFlush GLSVfw
ICDrawGetTime GLSVfw
ICDrawOpen GLSVfw
ICDrawQuery GLSVfw
ICDrawRealize GLSVfw
ICDrawRenderBuffer GLSVfw
ICDrawSetTime GLSVfw
ICDrawStart GLSVfw
ICDrawStartPlay GLSVfw
ICDrawStop GLSVfw
ICDrawStopPlay GLSVfw
ICDrawSuggestFormat GLSVfw
ICDrawWindow GLSVfw
ICGetBuffersWanted GLSVfw
ICGetDefaultKeyFrameRate GLSVfw
ICGetDefaultQuality GLSVfw
ICGetDisplayFormat GLSVfw
ICGetInfo GLSVfw
ICGetState GLSVfw
ICGetStateSize GLSVfw
ICImageCompress GLSVfw
ICImageDecompress GLSVfw
ICInfo GLSVfw
ICInstall GLSVfw
ICLocate GLSVfw
ICOpen GLSVfw
ICOpenFunction GLSVfw
IcosahedronBuildList GLObjects
ICQueryAbout GLSVfw
ICQueryConfigure GLSVfw
ICRemove GLSVfw
ICSendMessage GLSVfw
ICSeqCompressFrame GLSVfw
ICSeqCompressFrameEnd GLSVfw
ICSeqCompressFrameStart GLSVfw
ICSetState GLSVfw
ICSetStatusProc GLSVfw
ID4ToInt LWObjects
ILength VectorGeometry
ILength | VectorGeometry | Computes an integer length Result:=Sqrt(x*x+y*y).
ImageAlphaBottomRightPointColorTransparent ImageUtils
ImageAlphaFromIntensity ImageUtils
ImageAlphaInverseLuminance ImageUtils
ImageAlphaInverseLuminanceSqrt ImageUtils
ImageAlphaLuminance ImageUtils
ImageAlphaLuminanceSqrt ImageUtils
ImageAlphaOpaque ImageUtils
ImageAlphaSuperBlackTransparent ImageUtils
ImageAlphaTopLeftPointColorTransparent ImageUtils
ImageBellFilter ImageUtils
ImageBoxFilter ImageUtils
ImageHermiteFilter ImageUtils
ImageLanczos3Filter ImageUtils
ImageMitchellFilter ImageUtils
ImageSplineFilter ImageUtils
ImageTriangleFilter ImageUtils
IncludeInClipRect GeometryBB
IncreaseCoherency | MeshUtils | Increases indices coherency wrt vertex caches.<p> The indices parameters is understood as vertex indices of a triangles set, the triangles are reordered to maximize coherency (vertex reuse) over the cacheSize latest indices. This allows higher rendering performance from hardware renderers that implement vertex cache (nVidia GeForce family f.i.), allowing reuse of T&amp;L performance (similar to stripification without the normals issues of strips).<p> This procedure performs a coherency optimization via a greedy hill-climber algorithm (ie. not optimal but fast).
InflateGLRect | GLCrossPlatform | Increases or decreases the width and height of the specified rectangle.<p> Adds dx units to the left and right ends of the rectangle and dy units to the top and bottom.
inflateInit GLSZLibExApi
inflateInit2 GLSZLibExApi
InformationDlg | GLUtils | Pops up a simple dialog with msg and an Ok button.
InitChunk Utils3DS
InitCUDA GLS_CUDA_API
InitCUDAFromLibrary GLS_CUDA_API
InitCUDART GLS_CUDA_Runtime
InitCUDARTFromLibrary GLS_CUDA_Runtime
InitCUFFT GLS_CUDA_FourierTransform
InitCUFFTFromLibrary GLS_CUDA_FourierTransform
InitCUTIL GLS_CUDA_Utility
InitCUTILFromLibrary GLS_CUDA_Utility
InitFreetype LIBFREETYPE
InitFreetypeFromLibrary LIBFREETYPE
InitGLSceneColors GLColor
InitObjectMotion Utils3DS
InitODE ODEImport
InitOpenAL openal
InitOpenCL GLS_CL
InitOpenCLFromLibrary GLS_CL
InitOpenGL OpenGL1x
InitOpenGL OpenGLAdapter
InitOpenGLFromLibrary OpenGL1x
InitOpenGLFromLibrary OpenGLAdapter
InitTexture GLCustomShader
Initzlib GLSZLibExApi
InputDlg | GLUtils | Posp a simple dialog with a string input.
InternalFormatToOpenGLFormat | GLTextureFormat | Give a openGL texture format from GLScene texture format.
InterpolateCombined VectorGeometry
InterpolateCombinedFast VectorGeometry
InterpolateCombinedFastPower VectorGeometry
InterpolateCombinedSafe VectorGeometry
InterpolateExp VectorGeometry
InterpolateLn VectorGeometry
InterpolatePower | VectorGeometry | There functions that do the same as "Lerp", but add some distortions.
InterpolateSin | VectorGeometry | Only valid where Delta belongs to [0..1]
InterpolateSinAlt | VectorGeometry | "Alt" functions are valid everywhere
InterpolateTan VectorGeometry
IntersectAABBs GeometryBB
IntersectAABBsAbsolute GeometryBB
IntersectAABBsAbsoluteXY GeometryBB
IntersectAABBsAbsoluteXZ GeometryBB
IntersectCubes | GLCollision | Returns true when the bounding box cubes does intersect the other.<p> Also true when the one cube does contain the other completely.
IntersectGLRect GLCrossPlatform
IntersectLinePlane | VectorGeometry | Compute the intersection point "res" of a line with a plane.<p> Return value:<ul> <li>0 : no intersection, line parallel to plane <li>1 : res is valid <li>-1 : line is inside plane </ul><br> Adapted from:<br> E.Hartmann, Computeruntersttzte Darstellende Geometrie, B.G. Teubner Stuttgart 1988
IntersectSphereBox | VectorGeometry | Compute intersection between a Sphere and a box.<p> Up, Direction and Right must be normalized! Use CubDepht, CubeHeight and CubeWidth to scale TGLCube.
IntersectTriangleBox | VectorGeometry | Compute intersection between a triangle and a box.<p> Returns True if an intersection was found.
IntPower | VectorGeometry | Raise base to an integer.
InvertMatrix | VectorGeometry | Finds the inverse of a 4x4 matrix
InvertMatrix | VectorGeometry | Finds the inverse of a 3x3 matrix;
InvertTrianglesWinding | MeshUtils | Inverts the triangles winding (vertex order).
InvokeInfoForm GLScene
IsCgProfileSupported GLCgShader
IsColinear | VectorGeometry | Returns true if both vector are colinear
IsColinear | VectorGeometry | Returns true if both vector are colinear
IsColinear | VectorGeometry | Returns true if both vector are colinear
IsCompressedFormat | GLTextureFormat | True if texture compressed.
IsCompressedFormat GLTextureFormat
IsCUDAInitialized GLS_CUDA_API
IsCUDARTInitialized GLS_CUDA_Runtime
IsCUFFTInitialized GLS_CUDA_FourierTransform
IsCUTILInitialized GLS_CUDA_Utility
IsDepthFormat GLTextureFormat
IsDepthFormat | GLTextureFormat | True if depth texture.
IsDirectoryWriteable | GLCrossPlatform | Determine if the directory is writable.<p>
IsFloatFormat GLTextureFormat
IsFloatFormat | GLTextureFormat | True if texture format is float.
IsFogEnabled GLCustomShader
IsFormatSupported | GLTextureFormat | True if texture format is supported by hardware or software.
IsFreetypeInitialized LIBFREETYPE
IsInCube VectorGeometry
IsInCube | VectorGeometry | Returns True if p is in the cube defined by d.
IsInRange VectorGeometry
IsInRange | VectorGeometry | Returns True if x is in [a; b]
IsInRect GLGui
IsKeyDown | GLKeyboard | Check if the key corresponding to the given Char is down.<p> The character is mapped to the <i>main keyboard</i> only, and not to the numeric keypad.<br> The Shift/Ctrl/Alt state combinations that may be required to type the character are ignored (ie. 'a' is equivalent to 'A', and on my french keyboard, '5' = '(' = '[' since they all share the same physical key).
IsKeyDown | GLKeyboard | Check if the given virtual key is down.<p> This function is just a wrapper for GetAsyncKeyState.
IsLineIntersectQuad | VectorGeometry | Returns true if line intersect ABCD quad. Quad have to be flat and convex
IsLineIntersectTriangle | VectorGeometry | Returns true if line intersect ABC triangle.
IsMainThread GLContext
IsMesaGL OpenGL1x
IsMesaGL OpenGLAdapter
IsOpenCLInitialized GLS_CL
IsOpenGLInitialized OpenGL1x
IsOpenGLInitialized OpenGLAdapter
IsOpenGLLoaded OpenGL1x
IsOpenGLLoaded OpenGLAdapter
IsOpenGLVersionMet OpenGL1x
IsPointInPolygon VectorGeometry
IsPowerOf2 | GLUtils | Returns True if value is a true power of two
ISqrt | VectorGeometry | Computes an integer sqrt approximation.<p>
IsServiceContextAvaible GLContext
IsSubComponent GLCrossPlatform
IsTargetSupported | GLTextureFormat | True if texture target supported.
IsTargetSupported GLTextureFormat
IsTargetSupportMipmap GLTextureFormat
IsTargetSupportMipmap GLTextureFormat
IsVersionMet OpenGL1x
IsVersionMet OpenGLAdapter
IsVolumeClipped | VectorGeometry | Determines if volume is clipped or not
IsVolumeClipped VectorGeometry
IsVolumeClipped VectorGeometry
JPEGLIBCallback GLSJPG
jpeg_abort GLSJPG
jpeg_calc_output_dimensions GLSJPG
jpeg_consume_input GLSJPG
jpeg_CreateCompress GLSJPG
jpeg_CreateDecompress GLSJPG
jpeg_destroy GLSJPG
jpeg_destroy_decompress GLSJPG
jpeg_finish_compress GLSJPG
jpeg_finish_decompress GLSJPG
jpeg_finish_output GLSJPG
jpeg_has_multiple_scans GLSJPG
jpeg_read_header GLSJPG
jpeg_read_raw_data GLSJPG
jpeg_read_scanlines GLSJPG
jpeg_resync_to_restart GLSJPG
jpeg_set_colorspace GLSJPG
jpeg_set_defaults GLSJPG
jpeg_set_quality GLSJPG
jpeg_simple_progression GLSJPG
jpeg_start_compress GLSJPG
jpeg_start_decompress GLSJPG
jpeg_start_output GLSJPG
jpeg_stdio_dest GLSJPG
jpeg_stdio_src GLSJPG
jpeg_write_scanlines GLSJPG
KeyboardNotifyWheelMoved | GLKeyboard | Use this procedure to notify a wheel movement and have it resurfaced as key stroke.<p> Honoured by IsKeyDown and KeyPressed
KeyNameToVirtualKeyCode | GLKeyboard | Converts a key name to its virtual key code.<p> The comparison is **NOT** case-sensitive, if no match is found, returns -1.<p> The name is expressed using the locale windows options, except for mouse buttons which are translated to 'LBUTTON', 'MBUTTON' and 'RBUTTON'.
KeyPressed | GLKeyboard | Returns the first pressed key whose virtual key code is >= to minVkCode.<p> If no key is pressed, the return value is -1, this function does NOT wait for user input.<br> If you don't care about multiple key presses, just don't use the parameter.
Lerp | VectorGeometry | Calculates linear interpolation between start and stop at point t
LibMaterialPicker FLibMaterialPicker
LibMaterialPicker FLibMaterialPickerLCL
Linear_Interpolate GLPerlinBase
LineLineDistance | VectorGeometry | Computes the closest distance between two lines.
LnXP1 | VectorGeometry | Return ln(1 + X), accurate for X near 0.
LoadAnsiStringFromFile | GLUtils | Returns the content of "filename".
LoadComponentFromFile | GLUtils | Loads component from a file.
LoadLW0FromStream LWObjects
LoadLWOFromFile LWObjects
LoadModule GLSModuleLoader
LoadModuleEx GLSModuleLoader
LoadOpenGL OpenGLAdapter
LoadOpenGL OpenGL1x
LoadOpenGLFromLibrary OpenGLAdapter
LoadOpenGLFromLibrary OpenGL1x
LoadQ3Anims Q3MD3
LoadQ3Anims Q3MD3
LoadQ3Skin Q3MD3
LoadRGBEpixels RGBE
LoadRLEpixels RGBE
Log10 | VectorGeometry | Log base 10 of X
Log2 | VectorGeometry | Log base 2 of X
Log2 | VectorGeometry | Log base 2 of X
LogN | VectorGeometry | Log base N of X
MakeAffineDblVector VectorGeometry
MAKEAVICKID GLSVfw
MakeDblVector VectorGeometry
MAKEMUSICPOS Bass
MakeParallelProjectionMatrix | VectorGeometry | Creates a parallel projection matrix.<p> Transformed points will projected on the plane along the specified direction.
MakePoint VectorGeometry
MakePoint VectorGeometry
MakePoint VectorGeometry
MakeReflectionMatrix | VectorGeometry | Builds a reflection matrix for the given plane.<p> Reflection matrix allow implementing planar reflectors in OpenGL (mirrors).
MakeShadowMatrix | VectorGeometry | Creates a shadow projection matrix.<p> Shadows will be projected onto the plane defined by planePoint and planeNormal, from lightPos.
MakeSubComponent GLCrossPlatform
MakeTriangleAdjacencyList | MeshUtils | Create list of indices of triangles with adjacency from triangle list
MakeVector VectorGeometry
MakeVector VectorGeometry
MakeVector VectorGeometry
MakeVector VectorGeometry
MaterialEditorForm FMaterialEditorFormLCL
MaterialEditorForm FMaterialEditorForm
MatrixDecompose | VectorGeometry | Decompose a non-degenerated 4x4 transformation matrix into the sequence of transformations that produced it.<p> Modified by ml then eg, original Author: Spencer W. Thomas, University of Michigan<p> The coefficient of each transformation is returned in the corresponding element of the vector Tran.<p> Returns true upon success, false if the matrix is singular.
MatrixDeterminant | VectorGeometry | Determinant of a 3x3 matrix
MatrixDeterminant | VectorGeometry | Determinant of a 4x4 matrix
MatrixEquals VectorGeometry
MatrixEquals VectorGeometry
MatrixEquals VectorGeometry
MatrixEquals VectorGeometry
MatrixEquals VectorGeometry
MatrixEquals VectorGeometry
MatrixEquals VectorGeometry
MatrixEquals VectorGeometry
MatrixEquals VectorGeometry
MatrixEquals VectorGeometry
MatrixInvert VectorGeometry
MatrixInvert VectorGeometry
MatrixLerp | VectorGeometry | This is used for interpolating between 2 matrices. The result is used to reposition the model parts each frame.
MatrixMultiply | VectorGeometry | Multiplies two 3x3 matrices
MatrixMultiply | VectorGeometry | Multiplies M1 by M2 and places result in MResult
MatrixMultiply | VectorGeometry | Multiplies two 4x4 matrices
MaxAbsXYZComponent | VectorGeometry | Returns the max of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored).
MaxFloat | VectorGeometry | Returns the maximum of given values.
MaxFloat VectorGeometry
MaxFloat VectorGeometry
MaxFloat VectorGeometry
MaxFloat VectorGeometry
MaxFloat VectorGeometry
MaxFloat | VectorGeometry | Returns the maximum value of the array.
MaxFloat VectorGeometry
MaxInteger VectorGeometry
MaxInteger VectorGeometry
MaxInteger VectorGeometry
MaxInteger VectorGeometry
MaxVector VectorGeometry
MaxVector | VectorGeometry | Replace components of v with the max of v or v1 component.<p> Maximum is computed per component.
MaxXYZComponent | VectorGeometry | Returns the max of the X, Y and Z components of a vector (W is ignored).
MaxXYZComponent VectorGeometry
MCIWndCanConfig GLSVfw
MCIWndCanEject GLSVfw
MCIWndCanPlay GLSVfw
MCIWndCanRecord GLSVfw
MCIWndCanSave GLSVfw
MCIWndCanWindow GLSVfw
MCIWndChangeStyles GLSVfw
MCIWndClose GLSVfw
MCIWndCreate GLSVfw
MCIWndCreateA GLSVfw
MCIWndCreateW GLSVfw
MCIWndDestroy GLSVfw
MCIWndEject GLSVfw
MCIWndEnd GLSVfw
MCIWndGetActiveTimer GLSVfw
MCIWndGetAlias GLSVfw
MCIWndGetDest GLSVfw
MCIWndGetDevice GLSVfw
MCIWndGetDeviceID GLSVfw
MCIWndGetEnd GLSVfw
MCIWndGetError GLSVfw
MCIWndGetFileName GLSVfw
MCIWndGetInactiveTimer GLSVfw
MCIWndGetLength GLSVfw
MCIWndGetMode GLSVfw
MCIWndGetPalette GLSVfw
MCIWndGetPosition GLSVfw
MCIWndGetPositionString GLSVfw
MCIWndGetRepeat GLSVfw
MCIWndGetSource GLSVfw
MCIWndGetSpeed GLSVfw
MCIWndGetStart GLSVfw
MCIWndGetStyles GLSVfw
MCIWndGetTimeFormat GLSVfw
MCIWndGetVolume GLSVfw
MCIWndGetZoom GLSVfw
MCIWndHome GLSVfw
MCIWndNew GLSVfw
MCIWndOpen GLSVfw
MCIWndOpenDialog GLSVfw
MCIWndOpenInterface GLSVfw
MCIWndPaletteKick GLSVfw
MCIWndPause GLSVfw
MCIWndPlay GLSVfw
MCIWndPlayFrom GLSVfw
MCIWndPlayFromTo GLSVfw
MCIWndPlayReverse GLSVfw
MCIWndPlayTo GLSVfw
MCIWndPutDest GLSVfw
MCIWndPutSource GLSVfw
MCIWndRealize GLSVfw
MCIWndRecord GLSVfw
MCIWndRegisterClass GLSVfw
MCIWndResume GLSVfw
MCIWndReturnString GLSVfw
MCIWndSave GLSVfw
MCIWndSaveDialog GLSVfw
MCIWndSeek GLSVfw
MCIWndSendString GLSVfw
MCIWndSetActiveTimer GLSVfw
MCIWndSetInactiveTimer GLSVfw
MCIWndSetOwner GLSVfw
MCIWndSetPalette GLSVfw
MCIWndSetRepeat GLSVfw
MCIWndSetSpeed GLSVfw
MCIWndSetTimeFormat GLSVfw
MCIWndSetTimers GLSVfw
MCIWndSetVolume GLSVfw
MCIWndSetZoom GLSVfw
MCIWndSM GLSVfw
MCIWndStep GLSVfw
MCIWndStop GLSVfw
MCIWndUseFrames GLSVfw
MCIWndUseTime GLSVfw
MCIWndValidateMedia GLSVfw
MC_UnCompressQuat FileGL2
MinAbsXYZComponent | VectorGeometry | Returns the min of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored).
MinFloat | VectorGeometry | Returns the minimum value of the array.
MinFloat VectorGeometry
MinFloat VectorGeometry
MinFloat VectorGeometry
MinFloat VectorGeometry
MinFloat VectorGeometry
MinFloat | VectorGeometry | Returns the minimum of given values.
MinFloat VectorGeometry
MinInteger VectorGeometry
MinInteger VectorGeometry
MinInteger VectorGeometry
MinInteger VectorGeometry
MinPositiveCoef | Polynomials | Finds the minimum positive coef in the array in aMin.<p> Returns true if such an item was found.
MinVector VectorGeometry
MinVector | VectorGeometry | Replace components of v with the min of v or v1 component.<p> Minimum is computed per component.
MinXYZComponent VectorGeometry
MinXYZComponent | VectorGeometry | Returns the min of the X, Y and Z components of a vector (W is ignored).
MKFOURCC GLSVfw
mmioFOURCC GLSVfw
MoveObjectAround | VectorGeometry | Extracted from Camera.MoveAroundTarget(pitch, turn).
MSF_TO_FRAMES GLSDL
nearCallBack | GLODEManager | ODE nearCallBack, throws near callback to the collision procedure of the ODE manager linked by the Data pointer.
NegateVector | VectorGeometry | Negates the vector
NegateVector | VectorGeometry | Negates the vector
NegateVector | VectorGeometry | Negates the vector
NewtonAddCollisionReference NewtonImport
NewtonBallGetJointAngle NewtonImport
NewtonBallGetJointForce NewtonImport
NewtonBallGetJointOmega NewtonImport
NewtonBallSetConeLimits NewtonImport
NewtonBallSetUserCallback NewtonImport
NewtonBodyAddBuoyancyForce NewtonImport
NewtonBodyAddForce NewtonImport
NewtonBodyAddImpulse NewtonImport
NewtonBodyAddTorque NewtonImport
NewtonBodyApplyImpulseArray NewtonImport
NewtonBodyCalculateInverseDynamicsForce NewtonImport
NewtonBodyGetAABB NewtonImport
NewtonBodyGetAngularDamping NewtonImport
NewtonBodyGetAutoSleep NewtonImport
NewtonBodyGetCentreOfMass NewtonImport
NewtonBodyGetCollision NewtonImport
NewtonBodyGetContinuousCollisionMode NewtonImport
NewtonBodyGetFirstContactJoint NewtonImport
NewtonBodyGetFirstJoint NewtonImport
NewtonBodyGetForce NewtonImport
NewtonBodyGetForceAcc NewtonImport
NewtonBodyGetForceAndTorqueCallback NewtonImport
NewtonBodyGetFreezeState NewtonImport
NewtonBodyGetFreezeTreshold NewtonImport
NewtonBodyGetInvMass NewtonImport
NewtonBodyGetJointRecursiveCollision NewtonImport
NewtonBodyGetLinearDamping NewtonImport
NewtonBodyGetMassMatrix NewtonImport
NewtonBodyGetMaterialGroupID NewtonImport
NewtonBodyGetMatrix NewtonImport
NewtonBodyGetNextContactJoint NewtonImport
NewtonBodyGetNextJoint NewtonImport
NewtonBodyGetOmega NewtonImport
NewtonBodyGetRotation NewtonImport
NewtonBodyGetSleepState NewtonImport
NewtonBodyGetTorque NewtonImport
NewtonBodyGetTorqueAcc NewtonImport
NewtonBodyGetTransformCallback NewtonImport
NewtonBodyGetUserData NewtonImport
NewtonBodyGetVelocity NewtonImport
NewtonBodyGetWorld NewtonImport
NewtonBodySetAngularDamping NewtonImport
NewtonBodySetAutoSleep NewtonImport
NewtonBodySetCentreOfMass NewtonImport
NewtonBodySetCollision NewtonImport
NewtonBodySetContinuousCollisionMode NewtonImport
NewtonBodySetDestructorCallback NewtonImport
NewtonBodySetForce NewtonImport
NewtonBodySetForceAndTorqueCallback NewtonImport
NewtonBodySetFreezeState NewtonImport
NewtonBodySetJointRecursiveCollision NewtonImport
NewtonBodySetLinearDamping NewtonImport
NewtonBodySetMassMatrix NewtonImport
NewtonBodySetMaterialGroupID NewtonImport
NewtonBodySetMatrix NewtonImport
NewtonBodySetMatrixRecursive NewtonImport
NewtonBodySetOmega NewtonImport
NewtonBodySetTorque NewtonImport
NewtonBodySetTransformCallback NewtonImport
NewtonBodySetUserData NewtonImport
NewtonBodySetVelocity NewtonImport
NewtonBreakableBeginDelete NewtonImport
NewtonBreakableCreateDebrieBody NewtonImport
NewtonBreakableDeleteComponent NewtonImport
NewtonBreakableEndDelete NewtonImport
NewtonBreakableGetComponentsInRadius NewtonImport
NewtonBreakableGetFirstComponent NewtonImport
NewtonBreakableGetFirstSegment NewtonImport
NewtonBreakableGetMainMesh NewtonImport
NewtonBreakableGetNextComponent NewtonImport
NewtonBreakableGetNextSegment NewtonImport
NewtonBreakableSegmentGetIndexCount NewtonImport
NewtonBreakableSegmentGetIndexStream NewtonImport
NewtonBreakableSegmentGetIndexStreamShort NewtonImport
NewtonBreakableSegmentGetMaterial NewtonImport
NewtonCalculateSpringDamperAcceleration NewtonImport
NewtonCollisionCalculateAABB NewtonImport
NewtonCollisionClosestPoint NewtonImport
NewtonCollisionCollide NewtonImport
NewtonCollisionCollideContinue NewtonImport
NewtonCollisionForEachPolygonDo NewtonImport
NewtonCollisionGetInfo NewtonImport
NewtonCollisionGetMaxBreakImpactImpulse NewtonImport
NewtonCollisionGetUserID NewtonImport
NewtonCollisionIsTriggerVolume NewtonImport
NewtonCollisionMakeUnique NewtonImport
NewtonCollisionPointDistance NewtonImport
NewtonCollisionRayCast NewtonImport
NewtonCollisionSerialize NewtonImport
NewtonCollisionSetAsTriggerVolume NewtonImport
NewtonCollisionSetMaxBreakImpactImpulse NewtonImport
NewtonCollisionSetUserID NewtonImport
NewtonCollisionSupportVertex NewtonImport
NewtonCollisionUpdate NewtonImport
NewtonCompoundBreakableGetVertexCount NewtonImport
NewtonCompoundBreakableGetVertexStreams NewtonImport
NewtonCompoundBreakableResetAnchoredPieces NewtonImport
NewtonCompoundBreakableSetAnchoredPieces NewtonImport
NewtonConstraintCreateBall NewtonImport
NewtonConstraintCreateCorkscrew NewtonImport
NewtonConstraintCreateHinge NewtonImport
NewtonConstraintCreateSlider NewtonImport
NewtonConstraintCreateUniversal NewtonImport
NewtonConstraintCreateUpVector NewtonImport
NewtonConstraintCreateUserJoint NewtonImport
NewtonContactGetMaterial NewtonImport
NewtonContactJointGetContactCount NewtonImport
NewtonContactJointGetFirstContact NewtonImport
NewtonContactJointGetNextContact NewtonImport
NewtonContactJointRemoveContact NewtonImport
NewtonConvexCollisionCalculateInertialMatrix NewtonImport
NewtonConvexCollisionCalculateVolume NewtonImport
NewtonConvexHullGetFaceIndices NewtonImport
NewtonConvexHullModifierGetMatrix NewtonImport
NewtonConvexHullModifierSetMatrix NewtonImport
NewtonCorkscrewCalculateStopAccel NewtonImport
NewtonCorkscrewCalculateStopAlpha NewtonImport
NewtonCorkscrewGetJointAngle NewtonImport
NewtonCorkscrewGetJointForce NewtonImport
NewtonCorkscrewGetJointOmega NewtonImport
NewtonCorkscrewGetJointPosit NewtonImport
NewtonCorkscrewGetJointVeloc NewtonImport
NewtonCorkscrewSetUserCallback NewtonImport
NewtonCreate NewtonImport
NewtonCreateBody NewtonImport
NewtonCreateBox NewtonImport
NewtonCreateCapsule NewtonImport
NewtonCreateChamferCylinder NewtonImport
NewtonCreateCollisionFromSerialization NewtonImport
NewtonCreateCompoundBreakable NewtonImport
NewtonCreateCompoundCollision NewtonImport
NewtonCreateCompoundCollisionFromMesh NewtonImport
NewtonCreateCone NewtonImport
NewtonCreateConvexHull NewtonImport
NewtonCreateConvexHullFromMesh NewtonImport
NewtonCreateConvexHullModifier NewtonImport
NewtonCreateCylinder NewtonImport
NewtonCreateHeightFieldCollision NewtonImport
NewtonCreateNull NewtonImport
NewtonCreateSceneCollision NewtonImport
NewtonCreateSphere NewtonImport
NewtonCreateTreeCollision NewtonImport
NewtonCreateTreeCollisionFromMesh NewtonImport
NewtonCreateUserMeshCollision NewtonImport
NewtonDestroy NewtonImport
NewtonDestroyAllBodies NewtonImport
NewtonDestroyBody NewtonImport
NewtonDestroyJoint NewtonImport
NewtonGetEulerAngle NewtonImport
NewtonGetMaxThreadsCount NewtonImport
NewtonGetMemoryUsed NewtonImport
NewtonGetMultiThreadSolverOnSingleIsland NewtonImport
NewtonGetPlatformArchitecture NewtonImport
NewtonGetThreadsCount NewtonImport
NewtonHeightFieldSetUserRayCastCallback NewtonImport
NewtonHingeCalculateStopAlpha NewtonImport
NewtonHingeGetJointAngle NewtonImport
NewtonHingeGetJointForce NewtonImport
NewtonHingeGetJointOmega NewtonImport
NewtonHingeSetUserCallback NewtonImport
NewtonInvalidateCache NewtonImport
NewtonIslandGetBody NewtonImport
NewtonIslandGetBodyAABB NewtonImport
NewtonJointGetBody0 NewtonImport
NewtonJointGetBody1 NewtonImport
NewtonJointGetCollisionState NewtonImport
NewtonJointGetInfo NewtonImport
NewtonJointGetStiffness NewtonImport
NewtonJointGetUserData NewtonImport
NewtonJointSetCollisionState NewtonImport
NewtonJointSetDestructor NewtonImport
NewtonJointSetStiffness NewtonImport
NewtonJointSetUserData NewtonImport
NewtonMaterialContactRotateTangentDirections NewtonImport
NewtonMaterialCreateGroupID NewtonImport
NewtonMaterialDestroyAllGroupID NewtonImport
NewtonMaterialGetBodyCollisionID NewtonImport
NewtonMaterialGetContactFaceAttribute NewtonImport
NewtonMaterialGetContactForce NewtonImport
NewtonMaterialGetContactNormalSpeed NewtonImport
NewtonMaterialGetContactPositionAndNormal NewtonImport
NewtonMaterialGetContactTangentDirections NewtonImport
NewtonMaterialGetContactTangentSpeed NewtonImport
NewtonMaterialGetDefaultGroupID NewtonImport
NewtonMaterialGetMaterialPairUserData NewtonImport
NewtonMaterialGetUserData NewtonImport
NewtonMaterialSetCollisionCallback NewtonImport
NewtonMaterialSetContactElasticity NewtonImport
NewtonMaterialSetContactFrictionCoef NewtonImport
NewtonMaterialSetContactFrictionState NewtonImport
NewtonMaterialSetContactNormalAcceleration NewtonImport
NewtonMaterialSetContactNormalDirection NewtonImport
NewtonMaterialSetContactSoftness NewtonImport
NewtonMaterialSetContactTangentAcceleration NewtonImport
NewtonMaterialSetContinuousCollisionMode NewtonImport
NewtonMaterialSetDefaultCollidable NewtonImport
NewtonMaterialSetDefaultElasticity NewtonImport
NewtonMaterialSetDefaultFriction NewtonImport
NewtonMaterialSetDefaultSoftness NewtonImport
NewtonMaterialSetSurfaceThickness NewtonImport
NewtonMesApplyTransform NewtonImport
NewtonMeshAddFace NewtonImport
NewtonMeshApplyBoxMapping NewtonImport
NewtonMeshApplyCylindricalMapping NewtonImport
NewtonMeshApplySphericalMapping NewtonImport
NewtonMeshBeginFace NewtonImport
NewtonMeshBeginHandle NewtonImport
NewtonMeshBuildFromVertexListIndexList NewtonImport
NewtonMeshCalculateOOBB NewtonImport
NewtonMeshCalculateVertexNormals NewtonImport
NewtonMeshClip NewtonImport
NewtonMeshConvexDecomposition NewtonImport
NewtonMeshConvexHull NewtonImport
NewtonMeshCreate NewtonImport
NewtonMeshCreateFirstLayer NewtonImport
NewtonMeshCreateFirstSingleSegment NewtonImport
NewtonMeshCreateFromCollision NewtonImport
NewtonMeshCreateFromMesh NewtonImport
NewtonMeshCreateNextLayer NewtonImport
NewtonMeshCreateNextSingleSegment NewtonImport
NewtonMeshCreatePlane NewtonImport
NewtonMeshDestroy NewtonImport
NewtonMeshDifference NewtonImport
NewtonMeshEndFace NewtonImport
NewtonMeshEndHandle NewtonImport
NewtonMeshFirstMaterial NewtonImport
NewtonMeshFixTJoints NewtonImport
NewtonMeshGetEdgeIndices NewtonImport
NewtonMeshGetFaceIndexCount NewtonImport
NewtonMeshGetFaceIndices NewtonImport
NewtonMeshGetFaceMaterial NewtonImport
NewtonMeshGetFacePointIndices NewtonImport
NewtonMeshGetFaces NewtonImport
NewtonMeshGetFirstEdge NewtonImport
NewtonMeshGetFirstFace NewtonImport
NewtonMeshGetFirstPoint NewtonImport
NewtonMeshGetFirstVertex NewtonImport
NewtonMeshGetIndirectVertexStreams NewtonImport
NewtonMeshGetNextEdge NewtonImport
NewtonMeshGetNextFace NewtonImport
NewtonMeshGetNextPoint NewtonImport
NewtonMeshGetNextVertex NewtonImport
NewtonMeshGetNormalArray NewtonImport
NewtonMeshGetPointArray NewtonImport
NewtonMeshGetPointCount NewtonImport
NewtonMeshGetPointIndex NewtonImport
NewtonMeshGetPointStrideInByte NewtonImport
NewtonMeshGetTotalFaceCount NewtonImport
NewtonMeshGetTotalIndexCount NewtonImport
NewtonMeshGetUV0Array NewtonImport
NewtonMeshGetUV1Array NewtonImport
NewtonMeshGetVertexArray NewtonImport
NewtonMeshGetVertexCount NewtonImport
NewtonMeshGetVertexIndex NewtonImport
NewtonMeshGetVertexIndexFromPoint NewtonImport
NewtonMeshGetVertexStreams NewtonImport
NewtonMeshGetVertexStrideInByte NewtonImport
NewtonMeshIntersection NewtonImport
NewtonMeshIsFaceOpen NewtonImport
NewtonMeshIsOpenMesh NewtonImport
NewtonMeshMaterialGetIndexCount NewtonImport
NewtonMeshMaterialGetIndexStream NewtonImport
NewtonMeshMaterialGetIndexStreamShort NewtonImport
NewtonMeshMaterialGetMaterial NewtonImport
NewtonMeshNextMaterial NewtonImport
NewtonMeshPlaneClip NewtonImport
NewtonMeshPolygonize NewtonImport
NewtonMeshTriangulate NewtonImport
NewtonMeshUnion NewtonImport
NewtonMeshVoronoiDecomposition NewtonImport
NewtonReadPerformanceTicks NewtonImport
NewtonReadThreadPerformanceTicks NewtonImport
NewtonReleaseCollision NewtonImport
NewtonRemoveUnusedVertices NewtonImport
NewtonSceneCollisionCreateProxy NewtonImport
NewtonSceneCollisionDestroyProxy NewtonImport
NewtonSceneCollisionOptimize NewtonImport
NewtonSceneGetFirstProxy NewtonImport
NewtonSceneGetNextProxy NewtonImport
NewtonSceneGetProxyUserData NewtonImport
NewtonSceneProxyGetMatrix NewtonImport
NewtonSceneProxySetMatrix NewtonImport
NewtonSceneSetProxyUserData NewtonImport
NewtonSetBodyLeaveWorldEvent NewtonImport
NewtonSetCollisionDestructor NewtonImport
NewtonSetDestroyBodyByExeciveForce NewtonImport
NewtonSetEulerAngle NewtonImport
NewtonSetFrictionModel NewtonImport
NewtonSetIslandUpdateEvent NewtonImport
NewtonSetMemorySystem NewtonImport
NewtonSetMinimumFrameRate NewtonImport
NewtonSetMultiThreadSolverOnSingleIsland NewtonImport
NewtonSetPerformanceClock NewtonImport
NewtonSetPlatformArchitecture NewtonImport
NewtonSetSolverModel NewtonImport
NewtonSetThreadsCount NewtonImport
NewtonSetWorldSize NewtonImport
NewtonSliderCalculateStopAccel NewtonImport
NewtonSliderGetJointForce NewtonImport
NewtonSliderGetJointPosit NewtonImport
NewtonSliderGetJointVeloc NewtonImport
NewtonSliderSetUserCallback NewtonImport
NewtonStaticCollisionSetDebugCallback NewtonImport
NewtonTreeCollisionAddFace NewtonImport
NewtonTreeCollisionBeginBuild NewtonImport
NewtonTreeCollisionEndBuild NewtonImport
NewtonTreeCollisionGetFaceAtribute NewtonImport
NewtonTreeCollisionGetVertexListIndexListInAABB NewtonImport
NewtonTreeCollisionSetFaceAtribute NewtonImport
NewtonTreeCollisionSetUserRayCastCallback NewtonImport
NewtonUniversalCalculateStopAlpha0 NewtonImport
NewtonUniversalCalculateStopAlpha1 NewtonImport
NewtonUniversalGetJointAngle0 NewtonImport
NewtonUniversalGetJointAngle1 NewtonImport
NewtonUniversalGetJointForce NewtonImport
NewtonUniversalGetJointOmega0 NewtonImport
NewtonUniversalGetJointOmega1 NewtonImport
NewtonUniversalSetUserCallback NewtonImport
NewtonUpdate NewtonImport
NewtonUpVectorGetPin NewtonImport
NewtonUpVectorSetPin NewtonImport
NewtonUserJointAddAngularRow NewtonImport
NewtonUserJointAddGeneralRow NewtonImport
NewtonUserJointAddLinearRow NewtonImport
NewtonUserJointGetRowForce NewtonImport
NewtonUserJointSetFeedbackCollectorCallback NewtonImport
NewtonUserJointSetRowAcceleration NewtonImport
NewtonUserJointSetRowMaximumFriction NewtonImport
NewtonUserJointSetRowMinimumFriction NewtonImport
NewtonUserJointSetRowSpringDamperAcceleration NewtonImport
NewtonUserJointSetRowStiffness NewtonImport
NewtonWorldConvexCast NewtonImport
NewtonWorldCriticalSectionLock NewtonImport
NewtonWorldCriticalSectionUnlock NewtonImport
NewtonWorldFloatSize NewtonImport
NewtonWorldForEachBodyInAABBDo NewtonImport
NewtonWorldForEachJointDo NewtonImport
NewtonWorldGetBodyCount NewtonImport
NewtonWorldGetConstraintCount NewtonImport
NewtonWorldGetDestructorCallBack NewtonImport
NewtonWorldGetFirstBody NewtonImport
NewtonWorldGetFirstMaterial NewtonImport
NewtonWorldGetNextBody NewtonImport
NewtonWorldGetNextMaterial NewtonImport
NewtonWorldGetUserData NewtonImport
NewtonWorldGetVersion NewtonImport
NewtonWorldRayCast NewtonImport
NewtonWorldSetDestructorCallBack NewtonImport
NewtonWorldSetUserData NewtonImport
NormalizeAngle | VectorGeometry | Normalize to an angle in the [-PI; +PI] range
NormalizeDegAngle | VectorGeometry | Normalize to an angle in the [-180; 180] range
NormalizeMatrix | VectorGeometry | Normalize the matrix and remove the translation component.<p> The resulting matrix is an orthonormal matrix (Y direction preserved, then Z)
NormalizePlane | VectorGeometry | Normalize a plane so that point evaluation = plane distance. }
NormalizeQuaternion | VectorGeometry | Normalizes the given quaternion
NormalizeVector | VectorGeometry | Transforms a vector to unit length
NormalizeVector | VectorGeometry | Transforms a vector to unit length
NormalizeVector | VectorGeometry | Returns the vector transformed to unit length Transforms a vector to unit length
NormalizeVectorArray | VectorGeometry | Transforms vectors to unit length
ObjectManager | GLSceneRegister | Auto-create for object manager
ObjectManager | GLSceneRegisterLCL | Auto-create for object manager
OblateSpheroidal_Cartesian | GeometryCoordinates | Convert Oblate-Spheroidal to Cartesian. [Double] eta, phi in rad
OblateSpheroidal_Cartesian | GeometryCoordinates | Convert Oblate-Spheroidal to Cartesian (with error check). eta,phi in rad
OblateSpheroidal_Cartesian | GeometryCoordinates | Convert Oblate-Spheroidal to Cartesian (with error check).[Double] eta,phi in rad
OblateSpheroidal_Cartesian | GeometryCoordinates | Convert Oblate-Spheroidal to Cartesian. [Single] eta, phi in rad
ODERToGLSceneMatrix ODEGL
ODERToGLSceneMatrix ODEGL
ODERToGLSceneMatrix ODEGL
OffsetAABB GeometryBB
OffsetAABB GeometryBB
OffsetBB GeometryBB
OffsetBB GeometryBB
OffsetBBPoint GeometryBB
OffsetFloatArray | VectorGeometry | Adds delta to values in the array.<p> Array size must be a multiple of four.
OffsetFloatArray VectorGeometry
OffsetFloatArray VectorGeometry
OpenGLFormatToInternalFormat | GLTextureFormat | Give a GLScene texture format from openGL texture format.
OpenPictureDialog | GLUtils | Pops up a simple open picture dialog.
OptimizeMesh GLMeshOptimizer
OptimizeMesh GLMeshOptimizer
OptimizeMesh GLMeshOptimizer
OptimizeMesh GLMeshOptimizer
PackRotationMatrix | VectorGeometry | Packs an homogeneous rotation matrix to 6 bytes.<p> The 6:64 (or 6:36) compression ratio is achieved by computing the quaternion associated to the matrix and storing its Imaginary components at 16 bits precision each.<br> Deviation is typically below 0.01% and around 0.1% in worst case situations.<p> Note: quaternion conversion is faster and more robust than an angle decomposition.
PAKCreateFileStream GLVfsPAK
PAKFileStreamExists GLVfsPAK
ParseFloat | GLUtils | Parses the next integer in the string.<p> Initial non-numeric characters are skipper, p is altered, returns 0 if none found. Both '.' and ',' are accepted as decimal separators.
ParseInteger | GLUtils | Parses the next integer in the string.<p> Initial non-numeric characters are skipper, p is altered, returns 0 if none found. '+' and '-' are acknowledged.
Perlin_Random1 GLPerlinBase
Perlin_Random1DStrip GLPerlinBase
Perlin_Random2 GLPerlinBase
Pitch | VectorGeometry | Rotates the given coordinate system (represented by the matrix) around MasterRight
Pitch | VectorGeometry | Rotates the given coordinate system (represented by the matrix) around its X-axis
PixelFormatToColorBits | GLCrossPlatform | Returns the number of color bits associated to the given pixel format.
PlaneAABBIntersection | GeometryBB | Compute the intersection between a plane and the AABB
PlaneContainsBSphere GeometryBB
PlaneEvaluatePoint VectorGeometry
PlaneEvaluatePoint | VectorGeometry | Calculates the cross-product between the plane normal and plane to point vector.<p> This functions gives an hint as to were the point is, if the point is in the half-space pointed by the vector, result is positive.<p> This function performs an homogeneous space dot-product.
PlaneIntersectAABB GeometryBB
PlaneMake VectorGeometry
PlaneMake | VectorGeometry | Computes the parameters of a plane defined by a point and a normal.
PlaneMake VectorGeometry
PlaneMake | VectorGeometry | Computes the parameters of a plane defined by three points.
PlayOnWaveOut GLSMWaveOut
PlayOnWaveOut GLSMWaveOut
pngErrorFn LIBPNG
pngReadFn LIBPNG
pngWarnFn LIBPNG
pngWriteFn LIBPNG
PointAdd | VectorGeometry | Returns the sum of two homogeneous vectors. W coordinate is always 1.
PointDiskOrthoProjection | VectorGeometry | Computes point to disk projection. Direction has to be normalized
PointDiskProjection VectorGeometry
PointInAABB GeometryBB
PointInAABB GeometryBB
PointInPolygon VectorGeometry
PointIsInHalfSpace VectorGeometry
PointIsInHalfSpace VectorGeometry
PointIsInHalfSpace | VectorGeometry | Returns true if point is in the half-space defined by a plane with normal.<p> The plane itself is not considered to be in the tested halfspace.
PointLineClosestPoint | VectorGeometry | Computes closest point on a line.
PointLineDistance | VectorGeometry | Computes algebraic distance between point and line.
PointMake VectorGeometry
PointMake VectorGeometry
PointMake VectorGeometry
PointPlaneDistance VectorGeometry
PointPlaneDistance | VectorGeometry | Computes algebraic distance between point and plane.<p> Value will be positive if the point is in the halfspace pointed by the normal, negative on the other side.
PointPlaneDistance VectorGeometry
PointPlaneOrthoProjection | VectorGeometry | Computes point to plane projection. Plane and direction have to be normalized
PointPlaneProjection VectorGeometry
PointProject | VectorGeometry | Projects p on the line defined by o and direction.<p> Performs VectorDotProduct(VectorSubtract(p, origin), direction), which, if direction is normalized, computes the distance between origin and the projection of p on the (origin, direction) line.
PointProject VectorGeometry
PointQuadOrthoProjection | VectorGeometry | Computes point to Quad projection. Direction has to be normalized. Quad have to be flat and convex
PointQuadProjection VectorGeometry
PointSegmentClosestPoint | VectorGeometry | Computes closest point on a segment (a segment is a limited line).
PointSegmentClosestPoint VectorGeometry
PointSegmentDistance | VectorGeometry | Computes algebraic distance between segment and line (a segment is a limited line).
PointTriangleOrthoProjection | VectorGeometry | Computes point to triangle projection. Direction has to be normalized
PointTriangleProjection VectorGeometry
PolygonArea | VectorGeometry | Computes the polygons's area.<p> Points must be coplanar. Polygon needs not be convex.
PolygonSignedArea | VectorGeometry | Computes a 2D polygon's signed area.<p> Only X and Y coordinates are used, Z is ignored. Polygon needs not be convex.
PositionSceneObject ODEGL
PositionSceneObjectForGeom ODEGL
Power VectorGeometry
Power | VectorGeometry | Raise base to any power.<p> For fractional exponents, or |exponents| > MaxInt, base must be > 0.
Power | VectorGeometry | Raise base to an integer.
PrecisionTimerLap | GLCrossPlatform | Computes time elapsed since timer start.<p> Return time lap in seconds.
PrepareSinCosCache | VectorGeometry | Fills up the two given dynamic arrays with sin cos values.<p> start and stop angles must be given in degrees, the number of steps is determined by the length of the given arrays.
Project VectorGeometry
ProlateSpheroidal_Cartesian | GeometryCoordinates | Convert Prolate-Spheroidal to Cartesian [single](with error check). eta,phi in rad
ProlateSpheroidal_Cartesian | GeometryCoordinates | Convert Prolate-Spheroidal to Cartesian. [single] eta, phi in rad
ProlateSpheroidal_Cartesian | GeometryCoordinates | Convert Prolate-Spheroidal to Cartesian [single](with error check). eta,phi in rad
ProlateSpheroidal_Cartesian | GeometryCoordinates | Convert Prolate-Spheroidal to Cantesian. [double] eta,phi in rad
PtInRect GLCrossPlatform
QuaternionConjugate | VectorGeometry | Returns the conjugate of a quaternion
QuaternionFromAngleAxis | VectorGeometry | Constructs quaternion from angle (in deg) and axis
QuaternionFromEuler | VectorGeometry | Constructs quaternion from Euler angles in arbitrary order (angles in degrees)
QuaternionFromMatrix | VectorGeometry | Constructs a unit quaternion from a rotation matrix
QuaternionFromPoints | VectorGeometry | Constructs a unit quaternion from two points on unit sphere
QuaternionFromRollPitchYaw | VectorGeometry | Constructs quaternion from Euler angles
QuaternionMagnitude | VectorGeometry | Returns the magnitude of the quaternion
QuaternionMake | VectorGeometry | Creates a quaternion from the given values
QuaternionMultiply | VectorGeometry | Returns quaternion product qL * qR.<p> Note: order is important!<p> To combine rotations, use the product QuaternionMuliply(qSecond, qFirst), which gives the effect of rotating by qFirst then qSecond.
QuaternionSlerp | VectorGeometry | Spherical linear interpolation of unit quaternions with spins.<p> QStart, QEnd - start and end unit quaternions<br> t - interpolation parameter (0 to 1)<br> Spin - number of extra spin rotations to involve<br>
QuaternionSlerp VectorGeometry
QuaternionToAffineMatrix | VectorGeometry | Constructs an affine rotation matrix from (possibly non-unit) quaternion.<p>
QuaternionToMatrix | VectorGeometry | Constructs a rotation matrix from (possibly non-unit) quaternion.<p> Assumes matrix is used to multiply column vector on the left:<br> vnew = mat vold.<p> Works correctly for right-handed coordinate system and right-handed rotations.
QuaternionToPoints | VectorGeometry | Converts a unit quaternion into two points on a unit sphere
QueryPerformanceCounter | GLCrossPlatform | Returns the current value of the highest-resolution counter.<p> If the platform has none, should return a value derived from the highest precision time reference available, avoiding, if possible, timers that allocate specific system resources.
QueryPerformanceFrequency | GLCrossPlatform | Returns the frequency of the counter used by QueryPerformanceCounter.<p> Return value is in ticks per second (Hz), returns False if no precision counter is available.
QuestionDlg | GLUtils | Pops up a simple question dialog with msg and yes/no buttons.<p> Returns True if answer was "yes".
QuickSortLists | VectorLists | Sort the refList in ascending order, ordering objList (TBaseList) on the way.
QuickSortLists | VectorLists | Sort the refList in ascending order, ordering objList (TList) on the way.
RadToDeg VectorGeometry
RadToDeg VectorGeometry
RaiseFilerException PersistentClasses
RaiseLastOSError GLCrossPlatform
RaiseOpenGLError | OpenGL1x | Raises an EOpenGLError with 'msg' error string.
RandomColorVector ODEGL
RandomPointOnSphere | VectorGeometry | Generates a random point on the unit sphere.<p> Point repartition is correctly isotropic with no privilegied direction.
RasterFileFormatExtensionByIndex | GLGraphics | Returns an extension by its index in the internal image files dialogs filter.<p> Use InternalImageFileFormatsFilter to obtain the filter.
RayCastAABBIntersect GeometryBB
RayCastAABBIntersect GeometryBB
RayCastBoxIntersect | VectorGeometry | Compute intersection between a ray and a box.<p> Returns True if an intersection was found, the intersection point is placed in intersectPoint if the reference is not nil.
RayCastIntersectsSphere | VectorGeometry | Determines if a ray will intersect with a given sphere.<p>
RayCastMinDistToPoint | VectorGeometry | Compute the min distance a ray will pass to a point.<p>
RayCastPlaneIntersect | VectorGeometry | Compute intersection between a ray and a plane.<p> Returns True if an intersection was found, the intersection point is placed in intersectPoint is the reference is not nil.
RayCastPlaneXZIntersect VectorGeometry
RayCastSphereIntersect | VectorGeometry | Calculates the intersections between a sphere and a ray.<p> Returns 0 if no intersection is found (i1 and i2 untouched), 1 if one intersection was found (i1 defined, i2 untouched), and 2 is two intersections were found (i1 and i2 defined).
RayCastTriangleIntersect | VectorGeometry | Compute intersection between a ray and a triangle.
RDTSC | GLCrossPlatform | Returns the number of CPU cycles since startup.<p> Use the similarly named CPU instruction.
ReadCRLFString | GLUtils | Read a CRLF terminated string from a stream.<p> The CRLF is NOT in the returned string.
ReadEntryPoints GLSZLibExApi
ReadExtensions OpenGL1x
ReadImplementationProperties OpenGL1x
ReadLine GLSLog
ReadModuleData GLSModuleLoader
ReadMotorolaNumber LWObjects
ReadOpenALExtensions openal
ReadS0 LWObjects
ReadScreenImage GLScreen
ReadVideoModes GLScreen
ReadVXAsU4 LWObjects
ReadWGLExtensions OpenGL1x
ReadWGLImplementationProperties OpenGL1x
ReadXMLFile GLSCrossXML
ReadXMLFile GLSCrossXML
RectangleContains | VectorGeometry | Determine if BigRect completely contains SmallRect.
RectanglesIntersect | VectorGeometry | Determine if 2 rectanges intersect.
RectEquals | VectorGeometry | True if all components are equal.
Register uPSI_VectorLists
Register GLSceneRegisterLCL
Register GLSceneRegister
Register uPSI_VectorGeometry
Register GLSceneFormDesign
Register uPSI_VectorTypes
Register GLScriptDWS2
Register GLScriptPython
Register uPSI_XCollection
Register GLSceneRegisterWinOnlyLCL
Register GLSComputingRegister
Register uPSI_ApplicationFileIO
Register uPSI_GLStrings
Register RegisterXCollection
Register GLSDLWindow
Register GLSDLContext
Register uPSI_GLUtils
Register dws2Classes
Register uPSI_PersistentClasses
Register dws2GLScene
Register dws2VectorGeometry
Register dws2OpenGLAdapter
Register GLODERegister
Register GLSMFMOD
Register GLDWS2Objects
Register GLSMOpenAL
Register GLSMBASS
Register GLFullScreenViewer
register GLNewtonRegister
Register GLCgRegister
RegisterArchiveFormat GLSArchiveManager
RegisterChunkClass LWObjects
RegisterColor GLColor
RegisterCUDAComponentNameChangeEvent GLSCUDA
RegisterGLBaseSceneObjectNameChangeEvent | GLScene | Register an event handler triggered by any TGLBaseSceneObject Name change.<p> *INCOMPLETE*, currently allows for only 1 (one) event, and is used by GLSceneEdit in the IDE.
RegisterGLBehaviourNameChangeEvent | GLScene | Register an event handler triggered by any TGLBehaviour Name change.<p> *INCOMPLETE*, currently allows for only 1 (one) event, and is used by FBehavioursEditor in the IDE.
RegisterGLContextClass | GLContext | Drivers should register themselves via this function.
RegisterGLMaterialExNameChangeEvent GLMaterialEx
RegisterGLSceneObject GLODEManager
RegisterGLTextureImageClass | GLTexture | Register a TGLTextureImageClass (used for persistence and IDE purposes)
RegisterGLTextureImageEditor GLTextureImageEditors
RegisterInfoForm | GLScene | Registers the procedure call used to invoke the info form.
RegisterManager GLManager
RegisterRasterFormat GLGraphics
RegisterSoundFileFormat GLSoundFileObjects
RegisterTGraphicClassFileExtension GLTexture
RegisterUniformAutoSetMethod GLSLParameter
RegisterVectorFileFormat GLVectorFileObjects
RegisterXCollectionDestroyEvent | XCollection | Registers an event to be called when an XCollection is destroyed.
RegisterXCollectionItemClass | XCollection | Registers a TXCollectionItem subclass for persistence requirements.
RelativePath | GLCrossPlatform | Remove if possible part of path witch leads to project executable.
ReleaseAmbientLightMotion Utils3DS
ReleaseCamera Utils3DS
ReleaseCameraMotion Utils3DS
ReleaseChunk Utils3DS
ReleaseChunkList Utils3DS
ReleaseFontManager GLSpaceText
ReleaseGLSceneEditorForm GLSceneEditLCL
ReleaseGLSceneEditorForm GLSceneEdit
ReleaseGLSCUDAEditorForm GLSCUDAEditor
ReleaseGLShaderEditor FShaderMemo
ReleaseGUILayoutEditor FGUILayoutEditor
ReleaseLibMaterialPicker FLibMaterialPicker
ReleaseLibMaterialPicker FLibMaterialPickerLCL
ReleaseLight Utils3DS
ReleaseMaterial Utils3DS
ReleaseMaterialEditorForm FMaterialEditorForm
ReleaseMaterialEditorForm FMaterialEditorFormLCL
ReleaseMeshObj Utils3DS
ReleaseObjectMotion Utils3DS
ReleaseOmnilightMotion Utils3DS
ReleaseShaderUniformEditor FRUniformEditor
ReleaseSpotlightMotion Utils3DS
ReleaseVectorEditorForm FVectorEditor
ReleaseVectorEditorForm FVectorEditorLCL
ReleaseXCollectionEditor FXCollectionEditorLCL
ReleaseXCollectionEditor FXCollectionEditor
ReleaseXMLDocument GLSCrossXML
RemapAndCleanupReferences | MeshUtils | Alters a reference/indice pair and removes unused reference values.<p> This functions scans the reference list and removes all values that aren't referred in the indices list, and the indices list is remapped so as to remain coherent.
RemapIndices | MeshUtils | Remaps a list of indices.<p> The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]
RemapIndicesToIndicesMap | MeshUtils | Creates an indices map from a remap list.<p> The remap list is what BuildVectorCountOptimizedIndices, a list of indices to distinct/unique items, the indices map contains the indices of these items after a remap and cleanup of the set referred by remapIndices... Clear?<br> In short it takes the output of BuildVectorCountOptimizedIndices and can change it to something suitable for RemapTrianglesIndices.<br> Any simpler documentation of this function welcome ;)
RemapReferences | MeshUtils | Alters a reference array and removes unused reference values.<p> This functions scans the reference list and removes all values that aren't referred in the indices list, the indices list is *not* remapped.
RemapReferences MeshUtils
RemapTrianglesIndices | MeshUtils | Remaps a list of triangles vertex indices and remove degenerate triangles.<p> The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]
RenderAABB | GLSpatialPartitioning | Renders an AABB as a line
RenderAABB GLSpatialPartitioning
RenderGeomList ODEGL
RenderSpatialPartitioning | GLSpatialPartitioning | Render a spacial partitioning descending from TSectoredSpacePartition (octree and quadtree) as a grid - great for debugging and visualisation
RescaleImage ImageUtils
RestoreDefaultMode GLScreen
ReverseByteOrder LWObjects
RGB | GLCrossPlatform | Builds a TColor from Red Green Blue components.
RGB24ToRGBA32 GLGraphics
Rgbe2float RGBE
RIRegister_ApplicationFileIO uPSI_ApplicationFileIO
RIRegister_ApplicationFileIO_Routines uPSI_ApplicationFileIO
RIRegister_EFilerException uPSI_XCollection
RIRegister_EFilerException uPSI_PersistentClasses
RIRegister_EInvalidFileSignature uPSI_PersistentClasses
RIRegister_GLUtils uPSI_GLUtils
RIRegister_GLUtils_Routines uPSI_GLUtils
RIRegister_PersistentClasses uPSI_PersistentClasses
RIRegister_PersistentClasses_Routines uPSI_PersistentClasses
RIRegister_TApplicationFileIO uPSI_ApplicationFileIO
RIRegister_TBaseList uPSI_VectorLists
RIRegister_TBinaryReader uPSI_PersistentClasses
RIRegister_TBinaryWriter uPSI_PersistentClasses
RIRegister_TByteList uPSI_VectorLists
RIRegister_TDataFile uPSI_ApplicationFileIO
RIRegister_TDoubleList uPSI_VectorLists
RIRegister_TGLInterfacedCollectionItem uPSI_PersistentClasses
RIRegister_TGLInterfacedPersistent uPSI_PersistentClasses
RIRegister_TGLOwnedPersistent uPSI_PersistentClasses
RIRegister_TIntegerList uPSI_VectorLists
RIRegister_TPersistentObject uPSI_PersistentClasses
RIRegister_TPersistentObjectList uPSI_PersistentClasses
RIRegister_TSingleList uPSI_VectorLists
RIRegister_TTextReader uPSI_PersistentClasses
RIRegister_TTextWriter uPSI_PersistentClasses
RIRegister_TVirtualReader uPSI_PersistentClasses
RIRegister_TVirtualWriter uPSI_PersistentClasses
RIRegister_TXCollection uPSI_XCollection
RIRegister_TXCollectionItem uPSI_XCollection
RIRegister_VectorGeometry_Routines uPSI_VectorGeometry
RIRegister_VectorLists uPSI_VectorLists
RIRegister_VectorLists_Routines uPSI_VectorLists
RIRegister_XCollection uPSI_XCollection
RIRegister_XCollection_Routines uPSI_XCollection
RLength | VectorGeometry | Computes 1/Sqrt(Sqr(x)+Sqr(y)).
Roll | VectorGeometry | Rotates the given coordinate system (represented by the matrix) around its Z-axis
Roll | VectorGeometry | Rotates the given coordinate system (represented by the matrix) around MasterDirection
RotateVector | VectorGeometry | Rotates Vector about Axis with Angle radians
RotateVector | VectorGeometry | Rotates Vector about Axis with Angle radians
RotateVectorAroundY | VectorGeometry | Rotate given vector around the Y axis (alpha is in rad)
Round VectorGeometry
RoundDownToPowerOf2 | GLUtils | Round down to the nearest power of two, value must be strictly positive
RoundInt VectorGeometry
RoundInt | VectorGeometry | Rounds the floating point value to the closest integer.<p> Behaves like Round but returns a floating point value like Int.
RoundUpToPowerOf2 | GLUtils | Round ups to the nearest power of two, value must be positive
RSqrt | VectorGeometry | Computes 1/Sqrt(v).<p>
RstVector VectorGeometry
RstVector VectorGeometry
SafeCurrentGLContext GLContext
SaveAnsiStringToFile | GLUtils | Saves "data" to "filename".
SaveComponentToFile | GLUtils | Saves component to a file.
SavePictureDialog | GLUtils | Pops up a simple save picture dialog.
ScaleAndRound | VectorGeometry | Multiples i by s and returns the rounded result.<p>
ScaleFloatArray | VectorGeometry | Multiplies values in the array by factor.<p> This function is especially efficient for large arrays, it is not recommended for arrays that have less than 10 items.<br> Expected performance is 4 to 5 times that of a Deliph-compiled loop on AMD CPUs, and 2 to 3 when 3DNow! isn't available.
ScaleFloatArray VectorGeometry
ScaleMatrix | VectorGeometry | Multiplies all elements of a 4x4 matrix with a factor
ScaleMatrix | VectorGeometry | Multiplies all elements of a 3x3 matrix with a factor
ScaleVector | VectorGeometry | Scales given vector by a factor
ScaleVector | VectorGeometry | Scales given vector by a factor
ScaleVector | VectorGeometry | Scales given vector by a factor
ScaleVector | VectorGeometry | Scales given vector by another vector.<p> v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.
ScaleVector | VectorGeometry | Scales given vector by another vector.<p> v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.
SDL_AddTimer GLSDL
SDL_AllocRW GLSDL
SDL_AllocSurface GLSDL
SDL_AudioDriverName GLSDL
SDL_AudioInit GLSDL
SDL_AudioQuit GLSDL
SDL_BlitSurface GLSDL
SDL_BuildAudioCVT GLSDL
SDL_BUTTON GLSDL
SDL_CDClose GLSDL
SDL_CDEject GLSDL
SDL_CDInDrive GLSDL
SDL_CDName GLSDL
SDL_CDNumDrives GLSDL
SDL_CDOpen GLSDL
SDL_CDPause GLSDL
SDL_CDPlay GLSDL
SDL_CDPlayTracks GLSDL
SDL_CDResume GLSDL
SDL_CDStatus GLSDL
SDL_CDStop GLSDL
SDL_ClearError GLSDL
SDL_CloseAudio GLSDL
SDL_COMPILEDVERSION GLSDL
SDL_CondBroadcast GLSDL
SDL_CondSignal GLSDL
SDL_CondWait GLSDL
SDL_CondWaitTimeout GLSDL
SDL_ConvertAudio GLSDL
SDL_ConvertSurface GLSDL
SDL_CreateCond GLSDL
SDL_CreateCursor GLSDL
SDL_CreateMutex GLSDL
SDL_CreateRGBSurface GLSDL
SDL_CreateRGBSurfaceFrom GLSDL
SDL_CreateSemaphore GLSDL
SDL_CreateThread GLSDL
SDL_CreateYUVOverlay GLSDL
SDL_Delay GLSDL
SDL_DestroyCond GLSDL
SDL_DestroyMutex GLSDL
SDL_DestroySemaphore GLSDL
SDL_DisplayFormat GLSDL
SDL_DisplayFormatAlpha GLSDL
SDL_DisplayYUVOverlay GLSDL
SDL_EnableKeyRepeat GLSDL
SDL_EnableUNICODE GLSDL
SDL_EventState GLSDL
SDL_FillRect GLSDL
SDL_Flip GLSDL
SDL_FreeCursor GLSDL
SDL_FreeRW GLSDL
SDL_FreeSurface GLSDL
SDL_FreeWAV GLSDL
SDL_FreeYUVOverlay GLSDL
SDL_GetAppState GLSDL
SDL_GetAudioStatus GLSDL
SDL_GetClipRect GLSDL
SDL_GetCursor GLSDL
SDL_getenv GLSDL
SDL_GetError GLSDL
SDL_GetEventFilter GLSDL
SDL_GetGammaRamp GLSDL
SDL_GetKeyName GLSDL
SDL_GetKeyState GLSDL
SDL_GetModState GLSDL
SDL_GetMouseState GLSDL
SDL_GetRelativeMouseState GLSDL
SDL_GetRGB GLSDL
SDL_GetRGBA GLSDL
SDL_GetThreadID GLSDL
SDL_GetTicks GLSDL
SDL_GetVideoInfo GLSDL
SDL_GetVideoSurface GLSDL
SDL_GL_GetAttribute GLSDL
SDL_GL_GetProcAddress GLSDL
SDL_GL_LoadLibrary GLSDL
SDL_GL_Lock GLSDL
SDL_GL_SetAttribute GLSDL
SDL_GL_SwapBuffers GLSDL
SDL_GL_Unlock GLSDL
SDL_GL_UpdateRects GLSDL
SDL_Init GLSDL
SDL_InitSubSystem GLSDL
SDL_JoystickClose GLSDL
SDL_JoystickEventState GLSDL
SDL_JoystickGetAxis GLSDL
SDL_JoystickGetBall GLSDL
SDL_JoystickGetButton GLSDL
SDL_JoystickGetHat GLSDL
SDL_JoystickIndex GLSDL
SDL_JoystickName GLSDL
SDL_JoystickNumAxes GLSDL
SDL_JoystickNumBalls GLSDL
SDL_JoystickNumButtons GLSDL
SDL_JoystickNumHats GLSDL
SDL_JoystickOpen GLSDL
SDL_JoystickOpened GLSDL
SDL_JoystickUpdate GLSDL
SDL_KillThread GLSDL
SDL_Linked_Version GLSDL
SDL_ListModes GLSDL
SDL_LoadBMP GLSDL
SDL_LoadBMP_RW GLSDL
SDL_LoadWAV GLSDL
SDL_LoadWAV_RW GLSDL
SDL_LockAudio GLSDL
SDL_LockMutex GLSDL
SDL_LockSurface GLSDL
SDL_LockYUVOverlay GLSDL
SDL_LowerBlit GLSDL
SDL_MapRGB GLSDL
SDL_MapRGBA GLSDL
SDL_MixAudio GLSDL
SDL_MustLock GLSDL
SDL_mutexP GLSDL
SDL_mutexV GLSDL
SDL_NumJoysticks GLSDL
SDL_OpenAudio GLSDL
SDL_OutOfMemory GLSDL
SDL_PauseAudio GLSDL
SDL_PeepEvents GLSDL
SDL_PollEvent GLSDL
SDL_PumpEvents GLSDL
SDL_PushEvent GLSDL
SDL_putenv GLSDL
SDL_Quit GLSDL
SDL_QuitSubSystem GLSDL
SDL_RegisterApp GLSDL
SDL_RemoveTimer GLSDL
SDL_RWClose GLSDL
SDL_RWFromFile GLSDL
SDL_RWFromFP GLSDL
SDL_RWFromMem GLSDL
SDL_RWRead GLSDL
SDL_RWSeek GLSDL
SDL_RWTell GLSDL
SDL_RWWrite GLSDL
SDL_SaveBMP GLSDL
SDL_SaveBMP_RW GLSDL
SDL_SemPost GLSDL
SDL_SemTryWait GLSDL
SDL_SemValue GLSDL
SDL_SemWait GLSDL
SDL_SemWaitTimeout GLSDL
SDL_SetAlpha GLSDL
SDL_SetClipRect GLSDL
SDL_SetColorKey GLSDL
SDL_SetColors GLSDL
SDL_SetCursor GLSDL
SDL_SetError GLSDL
SDL_SetEventFilter GLSDL
SDL_SetGamma GLSDL
SDL_SetGammaRamp GLSDL
SDL_SetModState GLSDL
SDL_SetPalette GLSDL
SDL_SetTimer GLSDL
SDL_SetVideoMode GLSDL
SDL_ShowCursor GLSDL
SDL_Swap32 GLSDL
SDL_TABLESIZE GLSDL
SDL_ThreadID GLSDL
SDL_UnlockAudio GLSDL
SDL_UnlockMutex GLSDL
SDL_UnlockSurface GLSDL
SDL_UnlockYUVOverlay GLSDL
SDL_UpdateRect GLSDL
SDL_UpdateRects GLSDL
SDL_UpperBlit GLSDL
SDL_VERSION GLSDL
SDL_VERSIONNUM GLSDL
SDL_VERSION_ATLEAST GLSDL
SDL_VideoDriverName GLSDL
SDL_VideoInit GLSDL
SDL_VideoModeOK GLSDL
SDL_VideoQuit GLSDL
SDL_WaitEvent GLSDL
SDL_WaitThread GLSDL
SDL_WarpMouse GLSDL
SDL_WasInit GLSDL
SDL_WM_GetCaption GLSDL
SDL_WM_GrabInput GLSDL
SDL_WM_IconifyWindow GLSDL
SDL_WM_SetCaption GLSDL
SDL_WM_SetIcon GLSDL
SDL_WM_ToggleFullScreen GLSDL
SegmentPlaneIntersection | VectorGeometry | Computes segment / plane intersection return false if there isn't an intersection
SegmentSegmentClosestPoint | VectorGeometry | Computes the closest points (2) given two segments.
SegmentSegmentDistance | VectorGeometry | Computes the closest distance between two segments.
SetAABB GeometryBB
SetAffineVector VectorGeometry
SetBB GeometryBB
SetDecimalSeparator GLCrossPlatform
SetExeDirectory GLCrossPlatform
SetFullscreenMode | GLScreen | Changes to the video mode given by 'Index'
SetGLSceneMediaDir GLUtils
SetGLTextureImageClassesToStrings | GLTexture | Defines a TStrings with the list of registered TGLTextureImageClass.
SetMatrix VectorGeometry
SetMatrix VectorGeometry
SetMatrix VectorGeometry
SetMatrixRow VectorGeometry
SetPlane | VectorGeometry | Converts from single to double representation
SetROAMTrianglesCapacity | GLROAMPatch | Specifies the maximum number of ROAM triangles that may be allocated.
SetScreenSaverPassword | ScreenSaver | Invokes the standard Windows dialog to set the password.<p> May be invoked from your Properties/Configuration dialog.
setTransform ODEGL
SetupTangentSpace BumpMapping
SetupVSync GLViewer
SetVector VectorGeometry
SetVector VectorGeometry
SetVector VectorGeometry
SetVector VectorGeometry
SetVector VectorGeometry
SetVector VectorGeometry
SetVector VectorGeometry
SetVector VectorGeometry
SetXMLAttribute GLSCrossXML
SetXMLText GLSCrossXML
ShaderUniformEditor FRUniformEditor
ShiftObjectFromCenter VectorGeometry
ShiftObjectFromCenter VectorGeometry AOriginalPosition - Object initial position. ACenter - some point, from which is should be distanced.

ADistance + AFromCenterSpot - distance, which object should keep from ACenter or ADistance + not AFromCenterSpot - distance, which object should shift from his current position away from center.

ShowError Utils3DS
ShowErrorFormatted Utils3DS
ShowHTMLUrl GLCrossPlatform
Sign | VectorGeometry | Returns the sign of the x value using the (-1, 0, +1) convention
SignStrict VectorGeometry
SinCos | VectorGeometry | Calculates sine and cosine from the given angle Theta
SinCos | VectorGeometry | Calculates sine and cosine from the given angle Theta Calculates sine and cosine from the given angle Theta
SinCos | VectorGeometry | Calculates sine and cosine from the given angle Theta and Radius.<p> sin and cos values calculated from theta are multiplicated by radius.
SinCos | VectorGeometry | Calculates sine and cosine from the given angle Theta and Radius.<p> sin and cos values calculated from theta are multiplicated by radius.
Sinh VectorGeometry
Sinh VectorGeometry
SIRegister_ApplicationFileIO uPSI_ApplicationFileIO
SIRegister_EFilerException uPSI_PersistentClasses
SIRegister_EFilerException uPSI_XCollection
SIRegister_EInvalidFileSignature uPSI_PersistentClasses
SIRegister_GLStrings uPSI_GLStrings
SIRegister_GLUtils uPSI_GLUtils
SIRegister_IPersistentObject uPSI_PersistentClasses
SIRegister_PersistentClasses uPSI_PersistentClasses
SIRegister_TApplicationFileIO uPSI_ApplicationFileIO
SIRegister_TBaseList uPSI_VectorLists
SIRegister_TBinaryReader uPSI_PersistentClasses
SIRegister_TBinaryWriter uPSI_PersistentClasses
SIRegister_TByteList uPSI_VectorLists
SIRegister_TDataFile uPSI_ApplicationFileIO
SIRegister_TDoubleList uPSI_VectorLists
SIRegister_TGLInterfacedCollectionItem uPSI_PersistentClasses
SIRegister_TGLInterfacedPersistent uPSI_PersistentClasses
SIRegister_TGLOwnedPersistent uPSI_PersistentClasses
SIRegister_TIntegerList uPSI_VectorLists
SIRegister_TPersistentObject uPSI_PersistentClasses
SIRegister_TPersistentObjectList uPSI_PersistentClasses
SIRegister_TSingleList uPSI_VectorLists
SIRegister_TTextReader uPSI_PersistentClasses
SIRegister_TTextWriter uPSI_PersistentClasses
SIRegister_TVirtualReader uPSI_PersistentClasses
SIRegister_TVirtualWriter uPSI_PersistentClasses
SIRegister_TXCollection uPSI_XCollection
SIRegister_TXCollectionItem uPSI_XCollection
SIRegister_VectorGeometry uPSI_VectorGeometry
SIRegister_VectorLists uPSI_VectorLists
SIRegister_VectorTypes uPSI_VectorTypes
SIRegister_XCollection uPSI_XCollection
SizeOfFile | GLUtils | Returns the size of "filename".<p> Returns 0 (zero) is file does not exists.
SkipBeforeSTR GLSLog
SliderEnableLimits NewtonImport_JointLibrary
SliderSetLimits NewtonImport_JointLibrary
Smooth_Interpolate_Strip GLPerlinBase
SolveCubic | Polynomials | Computes the real roots of a real polynomial of the 3rd degree.<p> The polynomial is of the form:<br> A(0) + A(1)*Z + A(2)*Z**2 + A(3)*Z**3
SolveQuadric | Polynomials | Computes the real roots of a real polynomial of the 2nd degree.<p> The polynomial is of the form:<br> A(0) + A(1)*Z + A(2)*Z**2
SolveQuartic | Polynomials | Computes the real roots of a real polynomial of the 4th degree.<p> The polynomial is of the form:<br> A(0) + A(1)*Z + ... + A(4)*Z**4
SortArrayAscending | VectorGeometry | Sorts given array in ascending order.<p> NOTE : current implementation is a slow bubble sort...
SphereVisibleRadius | VectorGeometry | Computes the visible radius of a sphere in a perspective projection.<p> This radius can be used for occlusion culling (cone extrusion) or 2D intersection testing.
Spherical_Cartesian | GeometryCoordinates | Convert spherical to cartesion. [single] theta,phi in rads
Spherical_Cartesian | GeometryCoordinates | Convert spherical to cartesian [single] (with error check).theta,phi in rad
Spherical_Cartesian | GeometryCoordinates | Convert spherical to cartesian [double] (with error check).theta,phi in rad
Spherical_Cartesian | GeometryCoordinates | Convert spherical to cartesion. [double] theta,phi in rads
StarRecordColor | GLStarRecord | Computes star color from BV index (RGB) and magnitude (alpha).
StarRecordPositionYUp | GLStarRecord | Computes position on the unit sphere of a star record (Y=up).
StarRecordPositionZUp | GLStarRecord | Computes position on the unit sphere of a star record (Z=up).
StartAllMovements GLMovement
StartPrecisionTimer | GLCrossPlatform | Starts a precision timer.<p> Returned value should just be considered as 'handle', even if it ain't so. Default platform implementation is to use QueryPerformanceCounter and QueryPerformanceFrequency, if higher precision references are available, they should be used. The timer will and must be stopped/terminated/released with StopPrecisionTimer.
StopAllMovements GLMovement
StopPrecisionTimer | GLCrossPlatform | Computes time elapsed since timer start and stop timer.<p> Return time lap in seconds.
StreamFromFOURCC GLSVfw
StringToColorAdvanced | GLUtils | Converts a string into color
StringToColorAdvancedSafe | GLUtils | Converts a string into color
StripifyMesh | MeshUtils | Attempts to create as few as possible triangle strips to cover the mesh.<p> The indices parameters define a set of triangles as a set of indices to vertices in a vertex pool, free of duplicate vertices (or resulting stripification will be of lower quality).<br> The function returns a list of TIntegerList, each of these lists hosting a triangle strip, returned objects must be freed by caller.<br> If agglomerateLoneTriangles is True, the first of the lists actually contains the agglomerated list of the triangles that couldn't be stripified.
StrToFloatDef | GLUtils | Similar to SysUtils.StrToFloatDef, but ignores user's locale
StrToGLSResType ApplicationFileIO
SubdivideTriangles | MeshUtils | Subdivides mesh triangles.<p> Splits along edges, each triangle becomes four. The smoothFactor can be used to control subdivision smoothing, zero means no smoothing (tesselation only), while 1 means "sphere" subdivision (a low res sphere will be subdivided in a higher-res sphere), values outside of the [0..1] range are for, er, artistic purposes.<p> The procedure is not intended for real-time use.
SubtractVector | VectorGeometry | Subtracts V2 from V1, result is placed in V1
SubtractVector | VectorGeometry | Subtracts V2 from V1, result is placed in V1
SubtractVector | VectorGeometry | Subtracts V2 from V1, result is placed in V1
Tan VectorGeometry
Tan VectorGeometry
TexPointArrayAdd | VectorGeometry | Adds delta to nb texpoints in src and places result in dest
TexPointArrayScaleAndAdd VectorGeometry
TexPointCombine | VectorGeometry | Makes a linear combination of two texpoints
TexpointEquals | VectorGeometry | True if all components are equal.
TexPointLerp | VectorGeometry | Calculates linear interpolation between texpoint1 and texpoint2 at point t
TexPointMake VectorGeometry
ToDosPath LWObjects
ToHex GLSVfw
ToUnixPath LWObjects
TranslateMatrix VectorGeometry
TranslateMatrix | VectorGeometry | Adds the translation vector into the matrix
TransposeMatrix | VectorGeometry | Computes transpose of 4x4 matrix
TransposeMatrix | VectorGeometry | Computes transpose of 3x3 matrix
TriangleArea | VectorGeometry | Computes the triangle's area.
TriangleIntersectAABB GeometryBB
TriangleSignedArea | VectorGeometry | Computes a 2D triangle's signed area.<p> Only X and Y coordinates are used, Z is ignored.
TrimAndSplitVersionString OpenGLAdapter
TrimAndSplitVersionString OpenGL1x
Trunc VectorGeometry
TryStringToColorAdvanced | GLUtils | Converts a string into color
TryStrToFloat | GLUtils | Similar to SysUtils.TryStrToFloat, but ignores user's locale
Turn | VectorGeometry | Rotates the given coordinate system (represented by the matrix) around MasterUp
Turn | VectorGeometry | Rotates the given coordinate system (represented by the matrix) around its Y-axis
Tweener AnimationUtils
Tweener AnimationUtils
Tweener AnimationUtils
TWOCCFromFOURCC GLSVfw
UnApplyBlendingModeEx GLCustomShader
UnifyTrianglesWinding | MeshUtils | Attempts to unify triangle winding.<p> Depending on topology, this may or may not be successful (some topologies can't be unified, f.i. those that have duplicate triangles, those that have edges shared by more than two triangles, those that have unconnected submeshes etc.)
UnloadModule GLSModuleLoader
UnloadOpenGL OpenGL1x
UnloadOpenGL OpenGLAdapter
UnPackRotationMatrix | VectorGeometry | Restores a packed rotation matrix.<p> See PackRotationMatrix.
UnpressGroup GLWindows
UnProject VectorGeometry
UnregisterArchiveFormat GLSArchiveManager
UnRegisterColor GLColor
UnregisterGLSceneObject GLODEManager
UnRegisterGLTextureImageEditor GLTextureImageEditors
UnregisterRasterFormat GLGraphics
UnregisterSoundFileClass GLSoundFileObjects
UnregisterVectorFileClass GLVectorFileObjects
UnregisterXCollectionItemClass | XCollection | Removes a TXCollectionItem subclass from the list.
UseCustomGLSLogger GLSLog
UserLog GLSLog
UTF8ToWideString PersistentClasses
ValidateExternalObject dws2HelperFunc
Vector2bMake VectorGeometry
Vector2bMake VectorGeometry
Vector2bMake VectorGeometry
Vector2dMake VectorGeometry
Vector2dMake VectorGeometry
Vector2dMake VectorGeometry
Vector2fMake VectorGeometry
Vector2fMake VectorGeometry
Vector2fMake VectorGeometry
Vector2iMake VectorGeometry
Vector2iMake VectorGeometry
Vector2iMake VectorGeometry
Vector2sMake VectorGeometry
Vector2sMake VectorGeometry
Vector2sMake VectorGeometry
Vector3ADD ODEImport
Vector3bMake VectorGeometry
Vector3bMake VectorGeometry
Vector3bMake VectorGeometry
Vector3Cross ODEImport
Vector3dMake VectorGeometry
Vector3dMake VectorGeometry
Vector3dMake VectorGeometry
Vector3fMake VectorGeometry
Vector3fMake VectorGeometry
Vector3fMake VectorGeometry
Vector3iMake VectorGeometry
Vector3iMake VectorGeometry
Vector3iMake VectorGeometry
Vector3Length ODEImport
Vector3Make ODEImport
Vector3ScalarMul ODEImport
Vector3sMake VectorGeometry
Vector3sMake VectorGeometry
Vector3sMake VectorGeometry
Vector3SUB ODEImport
Vector4bMake VectorGeometry
Vector4bMake VectorGeometry
Vector4bMake VectorGeometry
Vector4dMake VectorGeometry
Vector4dMake VectorGeometry
Vector4dMake VectorGeometry
Vector4fMake VectorGeometry
Vector4fMake VectorGeometry
Vector4fMake VectorGeometry
Vector4iMake VectorGeometry
Vector4iMake VectorGeometry
Vector4iMake VectorGeometry
Vector4sMake VectorGeometry
Vector4sMake VectorGeometry
Vector4sMake VectorGeometry
VectorAbs | VectorGeometry | Returns a vector with components replaced by their Abs value. }
VectorAbs | VectorGeometry | Returns a vector with components replaced by their Abs value. }
VectorAdd | VectorGeometry | Adds two vectors and places result in vr
VectorAdd VectorGeometry
VectorAdd | VectorGeometry | Returns the sum of two affine vectors
VectorAdd | VectorGeometry | Sums up f to each component of the vector
VectorAdd VectorGeometry
VectorAdd | VectorGeometry | Returns the sum of two homogeneous vectors
VectorAdd | VectorGeometry | Sums up f to each component of the vector
VectorAdd VectorGeometry
VectorAffineDblToFlt VectorGeometry
VectorAffineFltToDbl VectorGeometry
VectorAngleCombine VectorGeometry
VectorAngleCosine | VectorGeometry | Calculates the cosine of the angle between Vector1 and Vector2.<p> Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))
VectorAngleCosine | VectorGeometry | Calculates the cosine of the angle between Vector1 and Vector2.<p> Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))
VectorAngleLerp VectorGeometry
VectorArrayAdd | VectorGeometry | Adds delta to nb vectors in src and places result in dest
VectorArrayLerp | VectorGeometry | Calculates linear interpolation between vector arrays
VectorArrayLerp VectorGeometry
VectorArrayLerp VectorGeometry
VectorCombine | VectorGeometry | Makes a linear combination of two vectors and return the result
VectorCombine | VectorGeometry | Makes a linear combination of two vectors and place result in vr
VectorCombine | VectorGeometry | Makes a linear combination of two vectors and return the result
VectorCombine | VectorGeometry | Makes a linear combination of two vectors and place result in vr
VectorCombine | VectorGeometry | Makes a linear combination of two vectors and return the result
VectorCombine | VectorGeometry | Makes a linear combination of two vectors and place result in vr, F1=1.0
VectorCombine3 | VectorGeometry | Makes a linear combination of three vectors and return the result
VectorCombine3 | VectorGeometry | Makes a linear combination of three vectors and return the result
VectorCombine3 VectorGeometry
VectorCombine3 | VectorGeometry | Makes a linear combination of three vectors and return the result
VectorCrossProduct | VectorGeometry | Calculates the cross product between vector 1 and 2, place result in vr
VectorCrossProduct | VectorGeometry | Calculates the cross product between vector 1 and 2
VectorCrossProduct | VectorGeometry | Calculates the cross product between vector 1 and 2
VectorCrossProduct | VectorGeometry | Calculates the cross product between vector 1 and 2, place result in vr
VectorCrossProduct | VectorGeometry | Calculates the cross product between vector 1 and 2, place result in vr
VectorCrossProduct | VectorGeometry | Calculates the cross product between vector 1 and 2, place result in vr
VectorDblToFlt VectorGeometry
VectorDistance | VectorGeometry | Calculates distance between two vectors.<p> ie. sqrt(sqr(v1[x]-v2[x])+...)
VectorDistance | VectorGeometry | Calculates distance between two vectors.<p> ie. sqrt(sqr(v1[x]-v2[x])+...) (w component ignored)
VectorDistance2 | VectorGeometry | Calculates the "Norm 2" between two vectors.<p> ie. sqr(v1[x]-v2[x])+...
VectorDistance2 | VectorGeometry | Calculates the "Norm 2" between two vectors.<p> ie. sqr(v1[x]-v2[x])+... (w component ignored)
VectorDivide VectorGeometry
VectorDivide GLEllipseCollision
VectorDivide VectorGeometry
VectorDotProduct | VectorGeometry | Calculates the dot product between V1 and V2.<p> Result:=V1[X] * V2[X] + V1[Y] * V2[Y]
VectorDotProduct | VectorGeometry | Calculates the dot product between V1 and V2.<p> Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]
VectorDotProduct | VectorGeometry | Calculates the dot product between V1 and V2.<p> Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]
VectorDotProduct | VectorGeometry | Calculates the dot product between V1 and V2.<p> Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]
VectorEditorForm FVectorEditorLCL
VectorEditorForm FVectorEditor
VectorEquals VectorGeometry
VectorEquals VectorGeometry
VectorEquals VectorGeometry
VectorEquals VectorGeometry
VectorEquals VectorGeometry
VectorEquals VectorGeometry
VectorEquals | VectorGeometry | True if all components are equal.
VectorEquals | VectorGeometry | True if all components are equal.
VectorEquals VectorGeometry
VectorEquals VectorGeometry
VectorEquals VectorGeometry
VectorEquals VectorGeometry
VectorEquals VectorGeometry
VectorEquals VectorGeometry
VectorEquals VectorGeometry
VectorFileFormatExtensionByIndex | GLVectorFileObjects | Returns an extension by its index in the vector files dialogs filter.<p> Use VectorFileFormatsFilter to obtain the filter.
VectorFileFormatsFilter | GLVectorFileObjects | A file extension filter suitable for dialog's 'Filter' property
VectorFileFormatsSaveFilter | GLVectorFileObjects | A file extension filter suitable for a savedialog's 'Filter' property
VectorFltToDbl VectorGeometry
VectorIsNull | VectorGeometry | True if x=y=z=0, w ignored
VectorIsNull | VectorGeometry | True if x=y=z=0, w ignored
VectorLength | VectorGeometry | Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z+w*w).
VectorLength | VectorGeometry | Calculates the length of a vector following the equation: sqrt(x*x+y*y+...).<p> Note: The parameter of this function is declared as open array. Thus there's no restriction about the number of the components of the vector.
VectorLength | VectorGeometry | Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).
VectorLength | VectorGeometry | Calculates the length of a vector following the equation sqrt(x*x+y*y).
VectorLength | VectorGeometry | Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).
VectorLength | VectorGeometry | Calculates the length of a vector following the equation sqrt(x*x+y*y).
VectorLerp | VectorGeometry | Calculates linear interpolation between vector1 and vector2 at point t
VectorLerp | VectorGeometry | Calculates linear interpolation between vector1 and vector2 at point t, places result in vr
VectorLerp | VectorGeometry | Calculates linear interpolation between vector1 and vector2 at point t, places result in vr
VectorLerp | VectorGeometry | Calculates linear interpolation between vector1 and vector2 at point t
VectorLessEqualThen VectorGeometry
VectorLessEqualThen VectorGeometry
VectorLessEqualThen VectorGeometry
VectorLessEqualThen VectorGeometry
VectorLessEqualThen VectorGeometry
VectorLessEqualThen VectorGeometry
VectorLessEqualThen VectorGeometry
VectorLessEqualThen VectorGeometry
VectorLessEqualThen VectorGeometry
VectorLessEqualThen VectorGeometry
VectorLessEqualThen VectorGeometry
VectorLessEqualThen VectorGeometry
VectorLessThen VectorGeometry
VectorLessThen VectorGeometry
VectorLessThen VectorGeometry
VectorLessThen VectorGeometry
VectorLessThen VectorGeometry
VectorLessThen VectorGeometry
VectorLessThen VectorGeometry
VectorLessThen VectorGeometry
VectorLessThen VectorGeometry
VectorLessThen VectorGeometry
VectorLessThen VectorGeometry
VectorLessThen VectorGeometry
VectorMake VectorGeometry
VectorMake VectorGeometry
VectorMoreEqualThen VectorGeometry
VectorMoreEqualThen VectorGeometry
VectorMoreEqualThen VectorGeometry
VectorMoreEqualThen VectorGeometry
VectorMoreEqualThen VectorGeometry
VectorMoreEqualThen VectorGeometry
VectorMoreEqualThen VectorGeometry
VectorMoreEqualThen VectorGeometry
VectorMoreEqualThen VectorGeometry
VectorMoreEqualThen VectorGeometry
VectorMoreEqualThen VectorGeometry
VectorMoreEqualThen VectorGeometry
VectorMoreThen VectorGeometry
VectorMoreThen VectorGeometry
VectorMoreThen VectorGeometry
VectorMoreThen VectorGeometry
VectorMoreThen VectorGeometry
VectorMoreThen VectorGeometry
VectorMoreThen VectorGeometry
VectorMoreThen | VectorGeometry | Vector comparison functions:
VectorMoreThen VectorGeometry
VectorMoreThen VectorGeometry
VectorMoreThen VectorGeometry
VectorMoreThen VectorGeometry
VectorNegate | VectorGeometry | Negates the vector
VectorNegate VectorGeometry
VectorNorm | VectorGeometry | Calculates norm of a vector which is defined as norm = v.V[0]*v.V[0] + ...<p> Also known as "Norm 2" in the math world, this is sqr(VectorLength).
VectorNorm | VectorGeometry | Calculates norm of a vector which is defined as norm = x*x + y*y + z*z<p> Also known as "Norm 2" in the math world, this is sqr(VectorLength).
VectorNorm | VectorGeometry | Calculates norm of a vector which is defined as norm = x * x + y * y<p> Also known as "Norm 2" in the math world, this is sqr(VectorLength).
VectorNorm | VectorGeometry | Calculates norm of a vector which is defined as norm = x*x + y*y + z*z<p> Also known as "Norm 2" in the math world, this is sqr(VectorLength).
VectorNormalize | VectorGeometry | Returns the vector transformed to unit length (w component dropped)
VectorNormalize | VectorGeometry | Returns the vector transformed to unit length
VectorNormalize | VectorGeometry | Returns the vector transformed to unit length
VectorPerpendicular | VectorGeometry | Calculates a vector perpendicular to N.<p> N is assumed to be of unit length, subtract out any component parallel to N
VectorReflect | VectorGeometry | Reflects vector V against N (assumes N is normalized)
VectorRotateAroundX | VectorGeometry | Returns given vector rotated around the X axis (alpha is in rad)
VectorRotateAroundY | VectorGeometry | Returns given vector rotated around the Y axis in vr (alpha is in rad)
VectorRotateAroundY | VectorGeometry | Returns given vector rotated around the Y axis (alpha is in rad)
VectorRotateAroundZ | VectorGeometry | Returns given vector rotated around the Z axis (alpha is in rad)
VectorScale | VectorGeometry | Returns a vector scaled by a factor
VectorScale | VectorGeometry | Returns a vector scaled by a factor
VectorScale | VectorGeometry | Scales a vector by a factor and places result in vr
VectorScale | VectorGeometry | RScales given vector by another vector
VectorScale | VectorGeometry | Scales a vector by a factor and places result in vr
VectorScale | VectorGeometry | Returns a vector scaled by a factor
VectorScale | VectorGeometry | Scales a vector by a factor and places result in vr
VectorScale | VectorGeometry | Scales given vector by another vector
VectorSpacing | VectorGeometry | Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y]), also know as "Norm1".<p>
VectorSpacing | VectorGeometry | Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".<p>
VectorSpacing | VectorGeometry | Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".<p>
VectorSubtract | VectorGeometry | Subtracts V2 from V1 and return value in result
VectorSubtract | VectorGeometry | Subtracts V2 from V1 and return value in result
VectorSubtract | VectorGeometry | Subtracts V2 from V1 and return value in result
VectorSubtract | VectorGeometry | Returns V1-V2
VectorSubtract | VectorGeometry | Returns V1-V2
VectorSubtract VectorGeometry
VectorSubtract VectorGeometry
VectorSubtract | VectorGeometry | Subtracts V2 from V1 and return value in result
VectorSubtract | VectorGeometry | Returns V1-V2
VectorSubtract | VectorGeometry | Subtracts V2 from V1 and return value in result
VectorTransform | VectorGeometry | Transforms an affine vector by multiplying it with a matrix
VectorTransform | VectorGeometry | Transforms a homogeneous vector by multiplying it with a matrix
VectorTransform | VectorGeometry | Transforms a homogeneous vector by multiplying it with a matrix
VectorTransform | VectorGeometry | Transforms an affine vector by multiplying it with a matrix
VerifyDelphiODE ODEImport
VideoForWindowsVersion GLSVfw
VirtualKeyCodeToKeyName | GLKeyboard | Converts a virtual key code to its name.<p> The name is expressed using the locale windows options.
WeldVertices | MeshUtils | Welds all vertices separated by a distance inferior to weldRadius.<p> Any two vertices whose distance is inferior to weldRadius will be merged (ie. one of them will be removed, and the other replaced by the barycenter).<p> The indicesMap is constructed to allow remapping of indices lists with the simple rule: newVertexIndex:=indicesMap[oldVertexIndex].<p> The logic is protected from chain welding, and only vertices that were initially closer than weldRadius will be welded in the same resulting vertex.<p> This procedure can be used for mesh simplification, but preferably at design-time for it is not optimized for speed. This is more a "fixing" utility for meshes exported from high-polycount CAD tools (to remove duplicate vertices, quantification errors, etc.)
wglCopyContext OpenGLAdapter
wglCopyContext OpenGL1x
wglCreateContext OpenGLAdapter
wglCreateContext OpenGL1x
wglCreateLayerContext OpenGLAdapter
wglCreateLayerContext OpenGL1x
wglDeleteContext OpenGLAdapter
wglDeleteContext OpenGL1x
wglDescribeLayerPlane OpenGL1x
wglDescribeLayerPlane OpenGLAdapter
wglGetCurrentContext OpenGLAdapter
wglGetCurrentContext OpenGL1x
wglGetCurrentDC OpenGLAdapter
wglGetCurrentDC OpenGL1x
wglGetLayerPaletteEntries OpenGL1x
wglGetLayerPaletteEntries OpenGLAdapter
wglGetProcAddress OpenGL1x
wglGetProcAddress OpenGLAdapter
wglMakeCurrent OpenGLAdapter
wglMakeCurrent OpenGL1x
wglRealizeLayerPalette OpenGLAdapter
wglRealizeLayerPalette OpenGL1x
wglSetLayerPaletteEntries OpenGL1x
wglSetLayerPaletteEntries OpenGLAdapter
wglShareLists OpenGLAdapter
wglShareLists OpenGL1x
wglSwapLayerBuffers OpenGLAdapter
wglSwapLayerBuffers OpenGL1x
wglSwapMultipleBuffers OpenGL1x
wglSwapMultipleBuffers OpenGLAdapter
wglUseFontBitmaps OpenGLAdapter
wglUseFontBitmaps OpenGL1x
wglUseFontBitmapsA OpenGL1x
wglUseFontBitmapsA OpenGLAdapter
wglUseFontBitmapsW OpenGL1x
wglUseFontBitmapsW OpenGLAdapter
wglUseFontOutlines OpenGLAdapter
wglUseFontOutlines OpenGL1x
wglUseFontOutlinesA OpenGL1x
wglUseFontOutlinesA OpenGLAdapter
wglUseFontOutlinesW OpenGL1x
wglUseFontOutlinesW OpenGLAdapter
WordToIntegerArray | GLUtils | Copies the values of Source to Dest (converting word values to integer values)
WriteCRLFString | GLUtils | Write the string and a CRLF in the stream
WriteModuleData GLSModuleLoader
WriteMotorolaNumber LWObjects
WriteS0 LWObjects
WriteU4AsVX LWObjects
WriteXMLFile GLSCrossXML
WriteXMLFile GLSCrossXML
XCollectionEditor FXCollectionEditor
XCollectionEditor FXCollectionEditorLCL
xgl XOpenGL
ZAdler32 GLSZLibEx
ZCompress GLSZLibEx
ZCompress2 GLSZLibEx
ZCompressStr GLSZLibEx
ZCompressStr2 GLSZLibEx
ZCompressStream GLSZLibEx
ZCompressStream2 GLSZLibEx
ZCompressStreamWeb GLSZLibEx
ZCompressStrEx GLSZLibEx
ZCompressString GLSZLibEx
ZCompressString GLSZLibEx
ZCompressString2 GLSZLibEx
ZCompressString2 GLSZLibEx
ZCompressStringEx GLSZLibEx
ZCompressStringEx GLSZLibEx
ZCompressStringWeb GLSZLibEx
ZCompressStringWeb GLSZLibEx
ZCompressStrWeb GLSZLibEx
ZCrc32 GLSZLibEx
ZDecompress GLSZLibEx
ZDecompress2 GLSZLibEx
ZDecompressStr GLSZLibEx
ZDecompressStr2 GLSZLibEx
ZDecompressStream GLSZLibEx
ZDecompressStream2 GLSZLibEx
ZDecompressStrEx GLSZLibEx
ZDecompressString GLSZLibEx
ZDecompressString GLSZLibEx
ZDecompressString2 GLSZLibEx
ZDecompressString2 GLSZLibEx
ZDecompressStringEx GLSZLibEx
ZDecompressStringEx GLSZLibEx
ZDeflate GLSZLibEx
ZDeflateEnd GLSZLibEx
ZDeflateEx GLSZLibEx
ZDeflateInit GLSZLibEx
ZDeflateInit2 GLSZLibEx
ZDeflateReset GLSZLibEx
zGetProcAddress GLSZLibExApi
ZInflate GLSZLibEx
ZInflateEnd GLSZLibEx
ZInflateEx GLSZLibEx
ZInflateInit GLSZLibEx
ZInflateInit2 GLSZLibEx
ZInflateReset GLSZLibEx
zlibVersion GLSZLibExApi
ZLIB_VERSION GLSZLibExApi
_putenv GLSDL
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:50


GLScene v.1.1.2: All Identifiers

All Identifiers

Name

Unit

Description

AABBContainsAABB

GeometryBB

AABBContainsBSphere

GeometryBB

AABBFitsInAABBAbsolute

GeometryBB

AABBFromSweep

GeometryBB

AABBInclude

GeometryBB

AABBIntersection

GeometryBB

AABBScale

GeometryBB

AABBToBB

GeometryBB

AABBToBB

GeometryBB

AABBToBSphere

GeometryBB

AABBToClipRect

GeometryBB

AABBTransform

GeometryBB

AbsVector

VectorGeometry

Vector components are replaced by their Abs() value. }

AbsVector

VectorGeometry

Vector components are replaced by their Abs() value. }

ActiveSoundManager

GLSound

ActiveVfsPAK

GLVfsPAK

ACubicFirst3DS

Const3DS

ACubicFlat3DS

Const3DS

AddAABB

GeometryBB

AddBB

GeometryBB

AddChild

Utils3DS

AddChildOrdered

Utils3DS

AddClassSymbol

dws2HelperFunc

AddForwardDeclaration

dws2HelperFunc

AddPoint

VectorGeometry

Adds V2 to V1, result is placed in V1. W coordinate is always 1.

AddPropertyToClass

dws2HelperFunc

AddSCODEGeomsToODESpace

GLODESkeletonColliders

After loading call this function to add all the geoms in a skeleton collider list to a given ODE space.

AddSCVerletConstriantsToVerletWorld

GLVerletSkeletonColliders

After loading call this function to add all the constraints in a skeleton collider list to a given verlet world.

AddTaskForServiceContext

GLContext

AddVector

VectorGeometry

Adds V2 to V1, result is placed in V1

AddVector

VectorGeometry

Sums up f to each component of the vector

AddVector

VectorGeometry

Sums up f to each component of the vector

AddVector

VectorGeometry

Adds V2 to V1, result is placed in V1

AddVector

VectorGeometry

Adds V2 to V1, result is placed in V1

AdjointMatrix

VectorGeometry

Adjoint of a 3x3 matrix.<p> used in the computation of the inverse of a 3x3 matrix

AdjointMatrix

VectorGeometry

Adjoint of a 4x4 matrix.<p> used in the computation of the inverse of a 4x4 matrix

adler32

GLSZLibExApi

AffineVectorEquals

VectorGeometry

True if X, Y and Z components are equal.

AffineVectorMake

VectorGeometry

AffineVectorMake

VectorGeometry

AFT_Bitmap_Size

LIBFREETYPE

AGL_0_BIT

OpenGLTokens

AGL_10_BIT

OpenGLTokens

AGL_128_BIT

OpenGLTokens

AGL_12_BIT

OpenGLTokens

AGL_16_BIT

OpenGLTokens

AGL_1_BIT

OpenGLTokens

AGL_24_BIT

OpenGLTokens

AGL_2_BIT

OpenGLTokens

AGL_32_BIT

OpenGLTokens

AGL_3_BIT

OpenGLTokens

AGL_48_BIT

OpenGLTokens

AGL_4_BIT

OpenGLTokens

AGL_5_BIT

OpenGLTokens

AGL_64_BIT

OpenGLTokens

AGL_6_BIT

OpenGLTokens

AGL_8_BIT

OpenGLTokens

AGL_96_BIT

OpenGLTokens

AGL_ACCELERATED

OpenGLTokens

AGL_ACCUM_ALPHA_SIZE

OpenGLTokens

AGL_ACCUM_BLUE_SIZE

OpenGLTokens

AGL_ACCUM_GREEN_SIZE

OpenGLTokens

AGL_ACCUM_MODES

OpenGLTokens

AGL_ACCUM_RED_SIZE

OpenGLTokens

AGL_ALL_RENDERERS

OpenGLTokens

AGL_ALPHA_SIZE

OpenGLTokens

AGL_ARGB12121212_BIT

OpenGLTokens

AGL_ARGB1555_BIT

OpenGLTokens

AGL_ARGB16161616_BIT

OpenGLTokens

AGL_ARGB2101010_BIT

OpenGLTokens

AGL_ARGB4444_BIT

OpenGLTokens

AGL_ARGB8888_BIT

OpenGLTokens

AGL_AUX_BUFFERS

OpenGLTokens

AGL_AUX_DEPTH_STENCIL

OpenGLTokens

AGL_BACKING_STORE

OpenGLTokens

AGL_BAD_ALLOC

OpenGLTokens

AGL_BAD_ATTRIBUTE

OpenGLTokens

AGL_BAD_CONNECTION

OpenGLTokens

AGL_BAD_CONTEXT

OpenGLTokens

AGL_BAD_DRAWABLE

OpenGLTokens

AGL_BAD_ENUM

OpenGLTokens

AGL_BAD_FULLSCREEN

OpenGLTokens

AGL_BAD_GDEV

OpenGLTokens

AGL_BAD_MATCH

OpenGLTokens

AGL_BAD_MODULE

OpenGLTokens

AGL_BAD_OFFSCREEN

OpenGLTokens

AGL_BAD_PIXELFMT

OpenGLTokens

AGL_BAD_POINTER

OpenGLTokens

AGL_BAD_PROPERTY

OpenGLTokens

AGL_BAD_RENDINFO

OpenGLTokens

AGL_BAD_STATE

OpenGLTokens

AGL_BAD_VALUE

OpenGLTokens

AGL_BAD_WINDOW

OpenGLTokens

AGL_BGR233_A8_BIT

OpenGLTokens

AGL_BGR233_BIT

OpenGLTokens

AGL_BLUE_SIZE

OpenGLTokens

AGL_BUFFER_MODES

OpenGLTokens

AGL_BUFFER_NAME

OpenGLTokens

AGL_BUFFER_RECT

OpenGLTokens

AGL_BUFFER_SIZE

OpenGLTokens

AGL_CLEAR_FORMAT_CACHE

OpenGLTokens

AGL_CLIP_REGION

OpenGLTokens

AGL_CLOSEST_POLICY

OpenGLTokens

AGL_COLORMAP_ENTRY

OpenGLTokens

AGL_COLORMAP_TRACKING

OpenGLTokens

AGL_COLOR_FLOAT

OpenGLTokens

AGL_COLOR_MODES

OpenGLTokens

AGL_COMPLIANT

OpenGLTokens

AGL_CONTEXT_DISPLAY_ID

OpenGLTokens

AGL_CONTEXT_SURFACE_ID

OpenGLTokens

AGL_DEPTH_MODES

OpenGLTokens

AGL_DEPTH_SIZE

OpenGLTokens

AGL_DOUBLEBUFFER

OpenGLTokens

AGL_DOUBLEBUFFER_BIT

OpenGLTokens

AGL_ENABLE_SURFACE_BACKING_SIZE

OpenGLTokens

AGL_FORMAT_CACHE_SIZE

OpenGLTokens

AGL_FS_CAPTURE_SINGLE

OpenGLTokens

AGL_FULLSCREEN

OpenGLTokens

AGL_GREEN_SIZE

OpenGLTokens

AGL_INDEX16_BIT

OpenGLTokens

AGL_INDEX8_BIT

OpenGLTokens

AGL_LEVEL

OpenGLTokens

AGL_MAXIMUM_POLICY

OpenGLTokens

AGL_MAX_AUX_BUFFERS

OpenGLTokens

AGL_MAX_LEVEL

OpenGLTokens

AGL_MINIMUM_POLICY

OpenGLTokens

AGL_MIN_LEVEL

OpenGLTokens

AGL_MONOSCOPIC_BIT

OpenGLTokens

AGL_MP_SAFE

OpenGLTokens

AGL_MULTISAMPLE

OpenGLTokens

AGL_MULTISCREEN

OpenGLTokens

AGL_NONE

OpenGLTokens

AGL_NO_ERROR

OpenGLTokens

AGL_NO_RECOVERY

OpenGLTokens

AGL_OFFSCREEN

OpenGLTokens

AGL_ORDER_CONTEXT_TO_FRONT

OpenGLTokens

AGL_PBUFFER

OpenGLTokens

AGL_PIXEL_SIZE

OpenGLTokens

AGL_RASTERIZATION

OpenGLTokens

AGL_RED_SIZE

OpenGLTokens

AGL_REMOTE_PBUFFER

OpenGLTokens

AGL_RENDERER_COUNT

OpenGLTokens

AGL_RENDERER_ID

OpenGLTokens

AGL_RETAIN_RENDERERS

OpenGLTokens

AGL_RGB101010_A8_BIT

OpenGLTokens

AGL_RGB101010_BIT

OpenGLTokens

AGL_RGB121212_BIT

OpenGLTokens

AGL_RGB161616_BIT

OpenGLTokens

AGL_RGB332_A8_BIT

OpenGLTokens

AGL_RGB332_BIT

OpenGLTokens

AGL_RGB444_A8_BIT

OpenGLTokens

AGL_RGB444_BIT

OpenGLTokens

AGL_RGB555_A8_BIT

OpenGLTokens

AGL_RGB555_BIT

OpenGLTokens

AGL_RGB565_A8_BIT

OpenGLTokens

AGL_RGB565_BIT

OpenGLTokens

AGL_RGB888_A8_BIT

OpenGLTokens

AGL_RGB888_BIT

OpenGLTokens

AGL_RGB8_A8_BIT

OpenGLTokens

AGL_RGB8_BIT

OpenGLTokens

AGL_RGBA

OpenGLTokens

AGL_RGBAFLOAT128_BIT

OpenGLTokens

AGL_RGBAFLOAT256_BIT

OpenGLTokens

AGL_RGBAFLOAT64_BIT

OpenGLTokens

AGL_RGBFLOAT128_BIT

OpenGLTokens

AGL_RGBFLOAT256_BIT

OpenGLTokens

AGL_RGBFLOAT64_BIT

OpenGLTokens

AGL_ROBUST

OpenGLTokens

AGL_SAMPLES_ARB

OpenGLTokens

AGL_SAMPLE_ALPHA

OpenGLTokens

AGL_SAMPLE_BUFFERS_ARB

OpenGLTokens

AGL_SINGLEBUFFER_BIT

OpenGLTokens

AGL_SINGLE_RENDERER

OpenGLTokens

AGL_STATE_VALIDATION

OpenGLTokens

AGL_STENCIL_MODES

OpenGLTokens

AGL_STENCIL_SIZE

OpenGLTokens

AGL_STEREO

OpenGLTokens

AGL_STEREOSCOPIC_BIT

OpenGLTokens

AGL_SUPERSAMPLE

OpenGLTokens

AGL_SURFACE_BACKING_SIZE

OpenGLTokens

AGL_SURFACE_OPACITY

OpenGLTokens

AGL_SURFACE_ORDER

OpenGLTokens

AGL_SURFACE_VOLATILE

OpenGLTokens

AGL_SWAP_INTERVAL

OpenGLTokens

AGL_SWAP_LIMIT

OpenGLTokens

AGL_SWAP_RECT

OpenGLTokens

AGL_TEXTURE_MEMORY

OpenGLTokens

AGL_VIDEO_MEMORY

OpenGLTokens

AGL_VIRTUAL_SCREEN

OpenGLTokens

AGL_WINDOW

OpenGLTokens

ALAUXILIARYEFFECTSLOTF

openal

ALAUXILIARYEFFECTSLOTFV

openal

ALAUXILIARYEFFECTSLOTI

openal

ALAUXILIARYEFFECTSLOTIV

openal

alBuffer3f

openal

alBuffer3i

openal

alBufferData

openal

alBufferf

openal

alBufferfv

openal

alBufferi

openal

alBufferiv

openal

alcCaptureCloseDevice

openal

alcCaptureOpenDevice

openal

alcCaptureSamples

openal

alcCaptureStart

openal

alcCaptureStop

openal

alcCloseDevice

openal

alcCreateContext

openal

alcDestroyContext

openal

alcGetContextsDevice

openal

alcGetCurrentContext

openal

alcGetEnumValue

openal

alcGetError

openal

alcGetIntegerv

openal

alcGetProcAddress

openal

alcGetString

openal

alcIsExtensionPresent

openal

alcMakeContextCurrent

openal

alcOpenDevice

openal

alcProcessContext

openal

alcSuspendContext

openal

ALC_ALL_ATTRIBUTES

openal

ALC_ALL_DEVICES_SPECIFIER

openal

ALC_ATTRIBUTES_SIZE

openal

ALC_CAPTURE_DEFAULT_DEVICE_SPECIFIER

openal

ALC_CAPTURE_DEVICE_SPECIFIER

openal

ALC_CAPTURE_SAMPLES

openal

ALC_DEFAULT_ALL_DEVICES_SPECIFIER

openal

ALC_DEFAULT_DEVICE_SPECIFIER

openal

ALC_DEVICE_SPECIFIER

openal

ALC_EFX_MAJOR_VERSION

openal

ALC_EFX_MINOR_VERSION

openal

ALC_EXTENSIONS

openal

ALC_EXT_EFX_NAME

openal

ALC_FALSE

openal

ALC_FREQUENCY

openal

ALC_INVALID

openal

ALC_INVALID_CONTEXT

openal

ALC_INVALID_DEVICE

openal

ALC_INVALID_ENUM

openal

ALC_INVALID_VALUE

openal

ALC_MAJOR_VERSION

openal

ALC_MAX_AUXILIARY_SENDS

openal

ALC_MINOR_VERSION

openal

ALC_MONO_SOURCES

openal

ALC_NO_ERROR

openal

ALC_OUT_OF_MEMORY

openal

ALC_REFRESH

openal

ALC_STEREO_SOURCES

openal

ALC_SYNC

openal

ALC_TRUE

openal

ALDELETEAUXILIARYEFFECTSLOTS

openal

alDeleteBuffers

openal

ALDELETEEFFECTS

openal

ALDELETEFILTERS

openal

alDeleteSources

openal

alDisable

openal

alDistanceModel

openal

alDopplerFactor

openal

alDopplerVelocity

openal

ALEFFECTF

openal

ALEFFECTFV

openal

ALEFFECTI

openal

ALEFFECTIV

openal

alEnable

openal

ALFILTERF

openal

ALFILTERFV

openal

ALFILTERI

openal

ALFILTERIV

openal

ALGENAUXILIARYEFFECTSLOTS

openal

alGenBuffers

openal

ALGENEFFECTS

openal

ALGENFILTERS

openal

alGenSources

openal

ALGETAUXILIARYEFFECTSLOTF

openal

ALGETAUXILIARYEFFECTSLOTFV

openal

ALGETAUXILIARYEFFECTSLOTI

openal

ALGETAUXILIARYEFFECTSLOTIV

openal

alGetBoolean

openal

alGetBooleanv

openal

alGetBuffer3f

openal

alGetBuffer3i

openal

alGetBufferf

openal

alGetBufferfv

openal

alGetBufferi

openal

alGetBufferiv

openal

alGetDouble

openal

alGetDoublev

openal

ALGETEFFECTF

openal

ALGETEFFECTFV

openal

ALGETEFFECTI

openal

ALGETEFFECTIV

openal

alGetEnumValue

openal

alGetError

openal

ALGETFILTERF

openal

ALGETFILTERFV

openal

ALGETFILTERI

openal

ALGETFILTERIV

openal

alGetFloat

openal

alGetFloatv

openal

alGetInteger

openal

alGetIntegerv

openal

alGetListenerfv

openal

alGetListeneriv

openal

alGetProcAddress

openal

alGetSource3f

openal

alGetSource3i

openal

alGetSourcef

openal

alGetSourcefv

openal

alGetSourcei

openal

alGetSourceiv

openal

alGetString

openal

alHint

openal

ALISAUXILIARYEFFECTSLOT

openal

alIsBuffer

openal

ALISEFFECT

openal

alIsEnabled

openal

alIsExtensionPresent

openal

ALISFILTER

openal

alIsSource

openal

alListener3f

openal

alListener3i

openal

alListenerf

openal

alListenerfv

openal

alListeneri

openal

alListeneriv

openal

AlphaGammaBrightCorrection

ImageUtils

alSource3f

openal

alSource3i

openal

alSourcef

openal

alSourcefv

openal

alSourcei

openal

alSourceiv

openal

alSourcePause

openal

alSourcePausev

openal

alSourcePlay

openal

alSourcePlayv

openal

alSourceQueueBuffers

openal

alSourceRewind

openal

alSourceRewindv

openal

alSourceStop

openal

alSourceStopv

openal

alSourceUnqueueBuffers

openal

alSpeedOfSound

openal

alutExit

openal

alutInit

openal

alutLoadWAVFile

openal

alutLoadWAVMemory

openal

alutUnloadWAV

openal

AL_AIR_ABSORPTION_FACTOR

openal

AL_AUTOWAH_ATTACK_TIME

openal

AL_AUTOWAH_DEFAULT_ATTACK_TIME

openal

AL_AUTOWAH_DEFAULT_PEAK_GAIN

openal

AL_AUTOWAH_DEFAULT_RELEASE_TIME

openal

AL_AUTOWAH_DEFAULT_RESONANCE

openal

AL_AUTOWAH_MAX_ATTACK_TIME

openal

AL_AUTOWAH_MAX_PEAK_GAIN

openal

AL_AUTOWAH_MAX_RELEASE_TIME

openal

AL_AUTOWAH_MAX_RESONANCE

openal

AL_AUTOWAH_MIN_ATTACK_TIME

openal

AL_AUTOWAH_MIN_PEAK_GAIN

openal

AL_AUTOWAH_MIN_RELEASE_TIME

openal

AL_AUTOWAH_MIN_RESONANCE

openal

AL_AUTOWAH_PEAK_GAIN

openal

AL_AUTOWAH_RELEASE_TIME

openal

AL_AUTOWAH_RESONANCE

openal

AL_AUXILIARY_SEND_FILTER

openal

AL_AUXILIARY_SEND_FILTER_GAINHF_AUTO

openal

AL_AUXILIARY_SEND_FILTER_GAIN_AUTO

openal

AL_BANDPASS_GAIN

openal

AL_BANDPASS_GAINHF

openal

AL_BANDPASS_GAINLF

openal

AL_BITS

openal

AL_BUFFER

openal

AL_BUFFERS_PROCESSED

openal

AL_BUFFERS_QUEUED

openal

AL_BYTE_OFFSET

openal

AL_CHANNELS

openal

AL_CHANNEL_MASK

openal

AL_CHORUS_DEFAULT_DELAY

openal

AL_CHORUS_DEFAULT_DEPTH

openal

AL_CHORUS_DEFAULT_FEEDBACK

openal

AL_CHORUS_DEFAULT_PHASE

openal

AL_CHORUS_DEFAULT_RATE

openal

AL_CHORUS_DEFAULT_WAVEFORM

openal

AL_CHORUS_DELAY

openal

AL_CHORUS_DEPTH

openal

AL_CHORUS_FEEDBACK

openal

AL_CHORUS_MAX_DELAY

openal

AL_CHORUS_MAX_DEPTH

openal

AL_CHORUS_MAX_FEEDBACK

openal

AL_CHORUS_MAX_PHASE

openal

AL_CHORUS_MAX_RATE

openal

AL_CHORUS_MAX_WAVEFORM

openal

AL_CHORUS_MIN_DELAY

openal

AL_CHORUS_MIN_DEPTH

openal

AL_CHORUS_MIN_FEEDBACK

openal

AL_CHORUS_MIN_PHASE

openal

AL_CHORUS_MIN_RATE

openal

AL_CHORUS_MIN_WAVEFORM

openal

AL_CHORUS_PHASE

openal

AL_CHORUS_RATE

openal

AL_CHORUS_WAVEFORM

openal

AL_CHORUS_WAVEFORM_SINUSOID

openal

AL_CHORUS_WAVEFORM_TRIANGLE

openal

AL_COMPRESSOR_DEFAULT_ONOFF

openal

AL_COMPRESSOR_MAX_ONOFF

openal

AL_COMPRESSOR_MIN_ONOFF

openal

AL_COMPRESSOR_ONOFF

openal

AL_CONE_INNER_ANGLE

openal

AL_CONE_OUTER_ANGLE

openal

AL_CONE_OUTER_GAIN

openal

AL_CONE_OUTER_GAINHF

openal

AL_DEFAULT_AIR_ABSORPTION_FACTOR

openal

AL_DEFAULT_AUXILIARY_SEND_FILTER_GAINHF_AUTO

openal

AL_DEFAULT_AUXILIARY_SEND_FILTER_GAIN_AUTO

openal

AL_DEFAULT_CONE_OUTER_GAINHF

openal

AL_DEFAULT_DIRECT_FILTER_GAINHF_AUTO

openal

AL_DEFAULT_METERS_PER_UNIT

openal

AL_DEFAULT_ROOM_ROLLOFF_FACTOR

openal

AL_DIRECTION

openal

AL_DIRECT_FILTER

openal

AL_DIRECT_FILTER_GAINHF_AUTO

openal

AL_DISTANCE_MODEL

openal

AL_DISTORTION_DEFAULT_EDGE

openal

AL_DISTORTION_DEFAULT_EQBANDWIDTH

openal

AL_DISTORTION_DEFAULT_EQCENTER

openal

AL_DISTORTION_DEFAULT_GAIN

openal

AL_DISTORTION_DEFAULT_LOWPASS_CUTOFF

openal

AL_DISTORTION_EDGE

openal

AL_DISTORTION_EQBANDWIDTH

openal

AL_DISTORTION_EQCENTER

openal

AL_DISTORTION_GAIN

openal

AL_DISTORTION_LOWPASS_CUTOFF

openal

AL_DISTORTION_MAX_EDGE

openal

AL_DISTORTION_MAX_EQBANDWIDTH

openal

AL_DISTORTION_MAX_EQCENTER

openal

AL_DISTORTION_MAX_GAIN

openal

AL_DISTORTION_MAX_LOWPASS_CUTOFF

openal

AL_DISTORTION_MIN_EDGE

openal

AL_DISTORTION_MIN_EQBANDWIDTH

openal

AL_DISTORTION_MIN_EQCENTER

openal

AL_DISTORTION_MIN_GAIN

openal

AL_DISTORTION_MIN_LOWPASS_CUTOFF

openal

AL_DOPPLER_FACTOR

openal

AL_DOPPLER_VELOCITY

openal

AL_EAXREVERB_AIR_ABSORPTION_GAINHF

openal

AL_EAXREVERB_DECAY_HFLIMIT

openal

AL_EAXREVERB_DECAY_HFRATIO

openal

AL_EAXREVERB_DECAY_LFRATIO

openal

AL_EAXREVERB_DECAY_TIME

openal

AL_EAXREVERB_DEFAULT_AIR_ABSORPTION_GAINHF

openal

AL_EAXREVERB_DEFAULT_DECAY_HFLIMIT

openal

AL_EAXREVERB_DEFAULT_DECAY_HFRATIO

openal

AL_EAXREVERB_DEFAULT_DECAY_LFRATIO

openal

AL_EAXREVERB_DEFAULT_DECAY_TIME

openal

AL_EAXREVERB_DEFAULT_DENSITY

openal

AL_EAXREVERB_DEFAULT_DIFFUSION

openal

AL_EAXREVERB_DEFAULT_ECHO_DEPTH

openal

AL_EAXREVERB_DEFAULT_ECHO_TIME

openal

AL_EAXREVERB_DEFAULT_GAIN

openal

AL_EAXREVERB_DEFAULT_GAINHF

openal

AL_EAXREVERB_DEFAULT_GAINLF

openal

AL_EAXREVERB_DEFAULT_HFREFERENCE

openal

AL_EAXREVERB_DEFAULT_LATE_REVERB_DELAY

openal

AL_EAXREVERB_DEFAULT_LATE_REVERB_GAIN

openal

AL_EAXREVERB_DEFAULT_LATE_REVERB_PAN

openal

AL_EAXREVERB_DEFAULT_LFREFERENCE

openal

AL_EAXREVERB_DEFAULT_MODULATION_DEPTH

openal

AL_EAXREVERB_DEFAULT_MODULATION_TIME

openal

AL_EAXREVERB_DEFAULT_REFLECTIONS_DELAY

openal

AL_EAXREVERB_DEFAULT_REFLECTIONS_GAIN

openal

AL_EAXREVERB_DEFAULT_REFLECTIONS_PAN

openal

AL_EAXREVERB_DEFAULT_ROOM_ROLLOFF_FACTOR

openal

AL_EAXREVERB_DENSITY

openal

AL_EAXREVERB_DIFFUSION

openal

AL_EAXREVERB_ECHO_DEPTH

openal

AL_EAXREVERB_ECHO_TIME

openal

AL_EAXREVERB_GAIN

openal

AL_EAXREVERB_GAINHF

openal

AL_EAXREVERB_GAINLF

openal

AL_EAXREVERB_HFREFERENCE

openal

AL_EAXREVERB_LATE_REVERB_DELAY

openal

AL_EAXREVERB_LATE_REVERB_GAIN

openal

AL_EAXREVERB_LATE_REVERB_PAN

openal

AL_EAXREVERB_LFREFERENCE

openal

AL_EAXREVERB_MAX_AIR_ABSORPTION_GAINHF

openal

AL_EAXREVERB_MAX_DECAY_HFLIMIT

openal

AL_EAXREVERB_MAX_DECAY_HFRATIO

openal

AL_EAXREVERB_MAX_DECAY_LFRATIO

openal

AL_EAXREVERB_MAX_DECAY_TIME

openal

AL_EAXREVERB_MAX_DENSITY

openal

AL_EAXREVERB_MAX_DIFFUSION

openal

AL_EAXREVERB_MAX_ECHO_DEPTH

openal

AL_EAXREVERB_MAX_ECHO_TIME

openal

AL_EAXREVERB_MAX_GAIN

openal

AL_EAXREVERB_MAX_GAINHF

openal

AL_EAXREVERB_MAX_GAINLF

openal

AL_EAXREVERB_MAX_HFREFERENCE

openal

AL_EAXREVERB_MAX_LATE_REVERB_DELAY

openal

AL_EAXREVERB_MAX_LATE_REVERB_GAIN

openal

AL_EAXREVERB_MAX_LFREFERENCE

openal

AL_EAXREVERB_MAX_MODULATION_DEPTH

openal

AL_EAXREVERB_MAX_MODULATION_TIME

openal

AL_EAXREVERB_MAX_REFLECTIONS_DELAY

openal

AL_EAXREVERB_MAX_REFLECTIONS_GAIN

openal

AL_EAXREVERB_MAX_ROOM_ROLLOFF_FACTOR

openal

AL_EAXREVERB_MIN_AIR_ABSORPTION_GAINHF

openal

AL_EAXREVERB_MIN_DECAY_HFLIMIT

openal

AL_EAXREVERB_MIN_DECAY_HFRATIO

openal

AL_EAXREVERB_MIN_DECAY_LFRATIO

openal

AL_EAXREVERB_MIN_DECAY_TIME

openal

AL_EAXREVERB_MIN_DENSITY

openal

AL_EAXREVERB_MIN_DIFFUSION

openal

AL_EAXREVERB_MIN_ECHO_DEPTH

openal

AL_EAXREVERB_MIN_ECHO_TIME

openal

AL_EAXREVERB_MIN_GAIN

openal

AL_EAXREVERB_MIN_GAINHF

openal

AL_EAXREVERB_MIN_GAINLF

openal

AL_EAXREVERB_MIN_HFREFERENCE

openal

AL_EAXREVERB_MIN_LATE_REVERB_DELAY

openal

AL_EAXREVERB_MIN_LATE_REVERB_GAIN

openal

AL_EAXREVERB_MIN_LFREFERENCE

openal

AL_EAXREVERB_MIN_MODULATION_DEPTH

openal

AL_EAXREVERB_MIN_MODULATION_TIME

openal

AL_EAXREVERB_MIN_REFLECTIONS_DELAY

openal

AL_EAXREVERB_MIN_REFLECTIONS_GAIN

openal

AL_EAXREVERB_MIN_ROOM_ROLLOFF_FACTOR

openal

AL_EAXREVERB_MODULATION_DEPTH

openal

AL_EAXREVERB_MODULATION_TIME

openal

AL_EAXREVERB_REFLECTIONS_DELAY

openal

AL_EAXREVERB_REFLECTIONS_GAIN

openal

AL_EAXREVERB_REFLECTIONS_PAN

openal

AL_EAXREVERB_ROOM_ROLLOFF_FACTOR

openal

AL_EAX_RAM_FREE

openal

AL_EAX_RAM_SIZE

openal

AL_ECHO_DAMPING

openal

AL_ECHO_DEFAULT_DAMPING

openal

AL_ECHO_DEFAULT_DELAY

openal

AL_ECHO_DEFAULT_FEEDBACK

openal

AL_ECHO_DEFAULT_LRDELAY

openal

AL_ECHO_DEFAULT_SPREAD

openal

AL_ECHO_DELAY

openal

AL_ECHO_FEEDBACK

openal

AL_ECHO_LRDELAY

openal

AL_ECHO_MAX_DAMPING

openal

AL_ECHO_MAX_DELAY

openal

AL_ECHO_MAX_FEEDBACK

openal

AL_ECHO_MAX_LRDELAY

openal

AL_ECHO_MAX_SPREAD

openal

AL_ECHO_MIN_DAMPING

openal

AL_ECHO_MIN_DELAY

openal

AL_ECHO_MIN_FEEDBACK

openal

AL_ECHO_MIN_LRDELAY

openal

AL_ECHO_MIN_SPREAD

openal

AL_ECHO_SPREAD

openal

AL_EFFECTSLOT_AUXILIARY_SEND_AUTO

openal

AL_EFFECTSLOT_EFFECT

openal

AL_EFFECTSLOT_GAIN

openal

AL_EFFECTSLOT_NULL

openal

AL_EFFECT_AUTOWAH

openal

AL_EFFECT_CHORUS

openal

AL_EFFECT_COMPRESSOR

openal

AL_EFFECT_DISTORTION

openal

AL_EFFECT_EAXREVERB

openal

AL_EFFECT_ECHO

openal

AL_EFFECT_EQUALIZER

openal

AL_EFFECT_FIRST_PARAMETER

openal

AL_EFFECT_FLANGER

openal

AL_EFFECT_FREQUENCY_SHIFTER

openal

AL_EFFECT_LAST_PARAMETER

openal

AL_EFFECT_NULL

openal

AL_EFFECT_PITCH_SHIFTER

openal

AL_EFFECT_REVERB

openal

AL_EFFECT_RING_MODULATOR

openal

AL_EFFECT_TYPE

openal

AL_EFFECT_VOCAL_MORPHER

openal

AL_EQUALIZER_DEFAULT_HIGH_CUTOFF

openal

AL_EQUALIZER_DEFAULT_HIGH_GAIN

openal

AL_EQUALIZER_DEFAULT_LOW_CUTOFF

openal

AL_EQUALIZER_DEFAULT_LOW_GAIN

openal

AL_EQUALIZER_DEFAULT_MID1_CENTER

openal

AL_EQUALIZER_DEFAULT_MID1_GAIN

openal

AL_EQUALIZER_DEFAULT_MID1_WIDTH

openal

AL_EQUALIZER_DEFAULT_MID2_CENTER

openal

AL_EQUALIZER_DEFAULT_MID2_GAIN

openal

AL_EQUALIZER_DEFAULT_MID2_WIDTH

openal

AL_EQUALIZER_HIGH_CUTOFF

openal

AL_EQUALIZER_HIGH_GAIN

openal

AL_EQUALIZER_LOW_CUTOFF

openal

AL_EQUALIZER_LOW_GAIN

openal

AL_EQUALIZER_MAX_HIGH_CUTOFF

openal

AL_EQUALIZER_MAX_HIGH_GAIN

openal

AL_EQUALIZER_MAX_LOW_CUTOFF

openal

AL_EQUALIZER_MAX_LOW_GAIN

openal

AL_EQUALIZER_MAX_MID1_CENTER

openal

AL_EQUALIZER_MAX_MID1_GAIN

openal

AL_EQUALIZER_MAX_MID1_WIDTH

openal

AL_EQUALIZER_MAX_MID2_CENTER

openal

AL_EQUALIZER_MAX_MID2_GAIN

openal

AL_EQUALIZER_MAX_MID2_WIDTH

openal

AL_EQUALIZER_MID1_CENTER

openal

AL_EQUALIZER_MID1_GAIN

openal

AL_EQUALIZER_MID1_WIDTH

openal

AL_EQUALIZER_MID2_CENTER

openal

AL_EQUALIZER_MID2_GAIN

openal

AL_EQUALIZER_MID2_WIDTH

openal

AL_EQUALIZER_MIN_HIGH_CUTOFF

openal

AL_EQUALIZER_MIN_HIGH_GAIN

openal

AL_EQUALIZER_MIN_LOW_CUTOFF

openal

AL_EQUALIZER_MIN_LOW_GAIN

openal

AL_EQUALIZER_MIN_MID1_CENTER

openal

AL_EQUALIZER_MIN_MID1_GAIN

openal

AL_EQUALIZER_MIN_MID1_WIDTH

openal

AL_EQUALIZER_MIN_MID2_CENTER

openal

AL_EQUALIZER_MIN_MID2_GAIN

openal

AL_EQUALIZER_MIN_MID2_WIDTH

openal

AL_EXPONENT_DISTANCE

openal

AL_EXPONENT_DISTANCE_CLAMPED

openal

AL_EXTENSIONS

openal

AL_FALSE

openal

AL_FILTER_BANDPASS

openal

AL_FILTER_FIRST_PARAMETER

openal

AL_FILTER_HIGHPASS

openal

AL_FILTER_LAST_PARAMETER

openal

AL_FILTER_LOWPASS

openal

AL_FILTER_NULL

openal

AL_FILTER_TYPE

openal

AL_FLANGER_DEFAULT_DELAY

openal

AL_FLANGER_DEFAULT_DEPTH

openal

AL_FLANGER_DEFAULT_FEEDBACK

openal

AL_FLANGER_DEFAULT_PHASE

openal

AL_FLANGER_DEFAULT_RATE

openal

AL_FLANGER_DEFAULT_WAVEFORM

openal

AL_FLANGER_DELAY

openal

AL_FLANGER_DEPTH

openal

AL_FLANGER_FEEDBACK

openal

AL_FLANGER_MAX_DELAY

openal

AL_FLANGER_MAX_DEPTH

openal

AL_FLANGER_MAX_FEEDBACK

openal

AL_FLANGER_MAX_PHASE

openal

AL_FLANGER_MAX_RATE

openal

AL_FLANGER_MAX_WAVEFORM

openal

AL_FLANGER_MIN_DELAY

openal

AL_FLANGER_MIN_DEPTH

openal

AL_FLANGER_MIN_FEEDBACK

openal

AL_FLANGER_MIN_PHASE

openal

AL_FLANGER_MIN_RATE

openal

AL_FLANGER_MIN_WAVEFORM

openal

AL_FLANGER_PHASE

openal

AL_FLANGER_RATE

openal

AL_FLANGER_WAVEFORM

openal

AL_FLANGER_WAVEFORM_SINUSOID

openal

AL_FLANGER_WAVEFORM_TRIANGLE

openal

AL_FORMAT_MONO16

openal

AL_FORMAT_MONO8

openal

AL_FORMAT_STEREO16

openal

AL_FORMAT_STEREO8

openal

AL_FREQUENCY

openal

AL_FREQUENCY_SHIFTER_DEFAULT_FREQUENCY

openal

AL_FREQUENCY_SHIFTER_DEFAULT_LEFT_DIRECTION

openal

AL_FREQUENCY_SHIFTER_DEFAULT_RIGHT_DIRECTION

openal

AL_FREQUENCY_SHIFTER_DIRECTION_DOWN

openal

AL_FREQUENCY_SHIFTER_DIRECTION_OFF

openal

AL_FREQUENCY_SHIFTER_DIRECTION_UP

openal

AL_FREQUENCY_SHIFTER_FREQUENCY

openal

AL_FREQUENCY_SHIFTER_LEFT_DIRECTION

openal

AL_FREQUENCY_SHIFTER_MAX_FREQUENCY

openal

AL_FREQUENCY_SHIFTER_MAX_LEFT_DIRECTION

openal

AL_FREQUENCY_SHIFTER_MAX_RIGHT_DIRECTION

openal

AL_FREQUENCY_SHIFTER_MIN_FREQUENCY

openal

AL_FREQUENCY_SHIFTER_MIN_LEFT_DIRECTION

openal

AL_FREQUENCY_SHIFTER_MIN_RIGHT_DIRECTION

openal

AL_FREQUENCY_SHIFTER_RIGHT_DIRECTION

openal

AL_GAIN

openal

AL_HIGHPASS_GAIN

openal

AL_HIGHPASS_GAINLF

openal

AL_ILLEGAL_COMMAND

openal

AL_ILLEGAL_ENUM

openal

AL_INITIAL

openal

AL_INVALID

openal

AL_INVALID_ENUM

openal

AL_INVALID_NAME

openal

AL_INVALID_OPERATION

openal

AL_INVALID_VALUE

openal

AL_INVERSE_DISTANCE

openal

AL_INVERSE_DISTANCE_CLAMPED

openal

AL_LINEAR_DISTANCE

openal

AL_LINEAR_DISTANCE_CLAMPED

openal

AL_LOOPING

openal

AL_LOWPASS_GAIN

openal

AL_LOWPASS_GAINHF

openal

AL_MAX_AIR_ABSORPTION_FACTOR

openal

AL_MAX_AUXILIARY_SEND_FILTER_GAINHF_AUTO

openal

AL_MAX_AUXILIARY_SEND_FILTER_GAIN_AUTO

openal

AL_MAX_CONE_OUTER_GAINHF

openal

AL_MAX_DIRECT_FILTER_GAINHF_AUTO

openal

AL_MAX_DISTANCE

openal

AL_MAX_GAIN

openal

AL_MAX_ROOM_ROLLOFF_FACTOR

openal

AL_METERS_PER_UNIT

openal

AL_MIN_AIR_ABSORPTION_FACTOR

openal

AL_MIN_AUXILIARY_SEND_FILTER_GAINHF_AUTO

openal

AL_MIN_AUXILIARY_SEND_FILTER_GAIN_AUTO

openal

AL_MIN_CONE_OUTER_GAINHF

openal

AL_MIN_DIRECT_FILTER_GAINHF_AUTO

openal

AL_MIN_GAIN

openal

AL_MIN_ROOM_ROLLOFF_FACTOR

openal

AL_NONE

openal

AL_NO_ERROR

openal

AL_ORIENTATION

openal

AL_OUT_OF_MEMORY

openal

AL_PAUSED

openal

AL_PENDING

openal

AL_PITCH

openal

AL_PITCH_SHIFTER_COARSE_TUNE

openal

AL_PITCH_SHIFTER_DEFAULT_COARSE_TUNE

openal

AL_PITCH_SHIFTER_DEFAULT_FINE_TUNE

openal

AL_PITCH_SHIFTER_FINE_TUNE

openal

AL_PITCH_SHIFTER_MAX_COARSE_TUNE

openal

AL_PITCH_SHIFTER_MAX_FINE_TUNE

openal

AL_PITCH_SHIFTER_MIN_COARSE_TUNE

openal

AL_PITCH_SHIFTER_MIN_FINE_TUNE

openal

AL_PLAYING

openal

AL_POSITION

openal

AL_PROCESSED

openal

AL_REFERENCE_DISTANCE

openal

AL_RENDERER

openal

AL_REVERB_AIR_ABSORPTION_GAINHF

openal

AL_REVERB_DECAY_HFLIMIT

openal

AL_REVERB_DECAY_HFRATIO

openal

AL_REVERB_DECAY_TIME

openal

AL_REVERB_DEFAULT_AIR_ABSORPTION_GAINHF

openal

AL_REVERB_DEFAULT_DECAY_HFLIMIT

openal

AL_REVERB_DEFAULT_DECAY_HFRATIO

openal

AL_REVERB_DEFAULT_DECAY_TIME

openal

AL_REVERB_DEFAULT_DENSITY

openal

AL_REVERB_DEFAULT_DIFFUSION

openal

AL_REVERB_DEFAULT_GAIN

openal

AL_REVERB_DEFAULT_GAINHF

openal

AL_REVERB_DEFAULT_LATE_REVERB_DELAY

openal

AL_REVERB_DEFAULT_LATE_REVERB_GAIN

openal

AL_REVERB_DEFAULT_REFLECTIONS_DELAY

openal

AL_REVERB_DEFAULT_REFLECTIONS_GAIN

openal

AL_REVERB_DEFAULT_ROOM_ROLLOFF_FACTOR

openal

AL_REVERB_DENSITY

openal

AL_REVERB_DIFFUSION

openal

AL_REVERB_GAIN

openal

AL_REVERB_GAINHF

openal

AL_REVERB_LATE_REVERB_DELAY

openal

AL_REVERB_LATE_REVERB_GAIN

openal

AL_REVERB_MAX_AIR_ABSORPTION_GAINHF

openal

AL_REVERB_MAX_DECAY_HFLIMIT

openal

AL_REVERB_MAX_DECAY_HFRATIO

openal

AL_REVERB_MAX_DECAY_TIME

openal

AL_REVERB_MAX_DENSITY

openal

AL_REVERB_MAX_DIFFUSION

openal

AL_REVERB_MAX_GAIN

openal

AL_REVERB_MAX_GAINHF

openal

AL_REVERB_MAX_LATE_REVERB_DELAY

openal

AL_REVERB_MAX_LATE_REVERB_GAIN

openal

AL_REVERB_MAX_REFLECTIONS_DELAY

openal

AL_REVERB_MAX_REFLECTIONS_GAIN

openal

AL_REVERB_MAX_ROOM_ROLLOFF_FACTOR

openal

AL_REVERB_MIN_AIR_ABSORPTION_GAINHF

openal

AL_REVERB_MIN_DECAY_HFLIMIT

openal

AL_REVERB_MIN_DECAY_HFRATIO

openal

AL_REVERB_MIN_DECAY_TIME

openal

AL_REVERB_MIN_DENSITY

openal

AL_REVERB_MIN_DIFFUSION

openal

AL_REVERB_MIN_GAIN

openal

AL_REVERB_MIN_GAINHF

openal

AL_REVERB_MIN_LATE_REVERB_DELAY

openal

AL_REVERB_MIN_LATE_REVERB_GAIN

openal

AL_REVERB_MIN_REFLECTIONS_DELAY

openal

AL_REVERB_MIN_REFLECTIONS_GAIN

openal

AL_REVERB_MIN_ROOM_ROLLOFF_FACTOR

openal

AL_REVERB_REFLECTIONS_DELAY

openal

AL_REVERB_REFLECTIONS_GAIN

openal

AL_REVERB_ROOM_ROLLOFF_FACTOR

openal

AL_RING_MODULATOR_DEFAULT_FREQUENCY

openal

AL_RING_MODULATOR_DEFAULT_HIGHPASS_CUTOFF

openal

AL_RING_MODULATOR_DEFAULT_WAVEFORM

openal

AL_RING_MODULATOR_FREQUENCY

openal

AL_RING_MODULATOR_HIGHPASS_CUTOFF

openal

AL_RING_MODULATOR_MAX_FREQUENCY

openal

AL_RING_MODULATOR_MAX_HIGHPASS_CUTOFF

openal

AL_RING_MODULATOR_MAX_WAVEFORM

openal

AL_RING_MODULATOR_MIN_FREQUENCY

openal

AL_RING_MODULATOR_MIN_HIGHPASS_CUTOFF

openal

AL_RING_MODULATOR_MIN_WAVEFORM

openal

AL_RING_MODULATOR_SAWTOOTH

openal

AL_RING_MODULATOR_SINUSOID

openal

AL_RING_MODULATOR_SQUARE

openal

AL_RING_MODULATOR_WAVEFORM

openal

AL_ROLLOFF_FACTOR

openal

AL_ROOM_ROLLOFF_FACTOR

openal

AL_SAMPLE_OFFSET

openal

AL_SEC_OFFSET

openal

AL_SIZE

openal

AL_SOURCE_ABSOLUTE

openal

AL_SOURCE_RELATIVE

openal

AL_SOURCE_STATE

openal

AL_SOURCE_TYPE

openal

AL_SPEED_OF_SOUND

openal

AL_STATIC

openal

AL_STOPPED

openal

AL_STORAGE_ACCESSIBLE

openal

AL_STORAGE_AUTOMATIC

openal

AL_STORAGE_HARDWARE

openal

AL_STREAMING

openal

AL_TRUE

openal

AL_UNDETERMINED

openal

AL_UNUSED

openal

AL_VELOCITY

openal

AL_VENDOR

openal

AL_VERSION

openal

AL_VOCAL_MORPHER_DEFAULT_PHONEMEA

openal

AL_VOCAL_MORPHER_DEFAULT_PHONEMEA_COARSE_TUNING

openal

AL_VOCAL_MORPHER_DEFAULT_PHONEMEB

openal

AL_VOCAL_MORPHER_DEFAULT_PHONEMEB_COARSE_TUNING

openal

AL_VOCAL_MORPHER_DEFAULT_RATE

openal

AL_VOCAL_MORPHER_DEFAULT_WAVEFORM

openal

AL_VOCAL_MORPHER_MAX_PHONEMEA

openal

AL_VOCAL_MORPHER_MAX_PHONEMEA_COARSE_TUNING

openal

AL_VOCAL_MORPHER_MAX_PHONEMEB

openal

AL_VOCAL_MORPHER_MAX_PHONEMEB_COARSE_TUNING

openal

AL_VOCAL_MORPHER_MAX_RATE

openal

AL_VOCAL_MORPHER_MAX_WAVEFORM

openal

AL_VOCAL_MORPHER_MIN_PHONEMEA

openal

AL_VOCAL_MORPHER_MIN_PHONEMEA_COARSE_TUNING

openal

AL_VOCAL_MORPHER_MIN_PHONEMEB

openal

AL_VOCAL_MORPHER_MIN_PHONEMEB_COARSE_TUNING

openal

AL_VOCAL_MORPHER_MIN_RATE

openal

AL_VOCAL_MORPHER_MIN_WAVEFORM

openal

AL_VOCAL_MORPHER_PHONEMEA

openal

AL_VOCAL_MORPHER_PHONEMEA_COARSE_TUNING

openal

AL_VOCAL_MORPHER_PHONEMEB

openal

AL_VOCAL_MORPHER_PHONEMEB_COARSE_TUNING

openal

AL_VOCAL_MORPHER_PHONEME_A

openal

AL_VOCAL_MORPHER_PHONEME_AA

openal

AL_VOCAL_MORPHER_PHONEME_AE

openal

AL_VOCAL_MORPHER_PHONEME_AH

openal

AL_VOCAL_MORPHER_PHONEME_AO

openal

AL_VOCAL_MORPHER_PHONEME_B

openal

AL_VOCAL_MORPHER_PHONEME_D

openal

AL_VOCAL_MORPHER_PHONEME_E

openal

AL_VOCAL_MORPHER_PHONEME_EH

openal

AL_VOCAL_MORPHER_PHONEME_ER

openal

AL_VOCAL_MORPHER_PHONEME_F

openal

AL_VOCAL_MORPHER_PHONEME_G

openal

AL_VOCAL_MORPHER_PHONEME_I

openal

AL_VOCAL_MORPHER_PHONEME_IH

openal

AL_VOCAL_MORPHER_PHONEME_IY

openal

AL_VOCAL_MORPHER_PHONEME_J

openal

AL_VOCAL_MORPHER_PHONEME_K

openal

AL_VOCAL_MORPHER_PHONEME_L

openal

AL_VOCAL_MORPHER_PHONEME_M

openal

AL_VOCAL_MORPHER_PHONEME_N

openal

AL_VOCAL_MORPHER_PHONEME_O

openal

AL_VOCAL_MORPHER_PHONEME_P

openal

AL_VOCAL_MORPHER_PHONEME_R

openal

AL_VOCAL_MORPHER_PHONEME_S

openal

AL_VOCAL_MORPHER_PHONEME_T

openal

AL_VOCAL_MORPHER_PHONEME_U

openal

AL_VOCAL_MORPHER_PHONEME_UH

openal

AL_VOCAL_MORPHER_PHONEME_UW

openal

AL_VOCAL_MORPHER_PHONEME_V

openal

AL_VOCAL_MORPHER_PHONEME_Z

openal

AL_VOCAL_MORPHER_RATE

openal

AL_VOCAL_MORPHER_WAVEFORM

openal

AL_VOCAL_MORPHER_WAVEFORM_SAWTOOTH

openal

AL_VOCAL_MORPHER_WAVEFORM_SINUSOID

openal

AL_VOCAL_MORPHER_WAVEFORM_TRIANGLE

openal

AMBIENT_LIGHT

Const3DS

AMBIENT_NODE_TAG

Const3DS

AngleBetweenVectors

VectorGeometry

Calcualtes Angle between 2 Vectors: (A-CenterPoint) and (B-CenterPoint). In radians.

AngleBetweenVectors

VectorGeometry

AngleLerp

VectorGeometry

Calculates angular interpolation between start and stop at point t

AnglePreservingMatrixInvert

VectorGeometry

Finds the inverse of an angle preserving matrix.<p> Angle preserving matrices can combine translation, rotation and isotropic scaling, other matrices won't be properly inverted by this function.

AnsiStartsText

GLCrossPlatform

ApplicationFileIODefined

ApplicationFileIO

Returns true if an ApplicationFileIO has been defined

ApplyBlendingModeEx

GLCustomShader

ArcCos

VectorGeometry

ArcCos

VectorGeometry

ArcCreateFileStream

GLSArchiveManager

ArcFileStreamExists

GLSArchiveManager

ArcSin

VectorGeometry

ArcSin

VectorGeometry

ArcTan2

VectorGeometry

ArcTan2

VectorGeometry

ASESetPreferredLightmap

GLFileASE

ASESetPreferredTexture

GLFileASE

ATKEY1

Const3DS

ATKEY2

Const3DS

ATKEY3

Const3DS

ATKEY4

Const3DS

ATKEY5

Const3DS

ATKEYFLAGS

Const3DS

AUDIO_S16

GLSDL

AUDIO_S16LSB

GLSDL

AUDIO_S16MSB

GLSDL

AUDIO_S16SYS

GLSDL

AUDIO_S8

GLSDL

AUDIO_U16

GLSDL

AUDIO_U16LSB

GLSDL

AUDIO_U16MSB

GLSDL

AUDIO_U16SYS

GLSDL

AUDIO_U8

GLSDL

AVIBuildFilter

GLSVfw

AVIBuildFilterA

GLSVfw

AVIBuildFilterW

GLSVfw

AVICapSM

GLSVfw

AVIClearClipboard

GLSVfw

AVICOMPRESSF_DATARATE

GLSVfw

AVICOMPRESSF_INTERLEAVE

GLSVfw

AVICOMPRESSF_KEYFRAMES

GLSVfw

AVICOMPRESSF_VALID

GLSVfw

AVIERR_BADFLAGS

GLSVfw

AVIERR_BADFORMAT

GLSVfw

AVIERR_BADHANDLE

GLSVfw

AVIERR_BADPARAM

GLSVfw

AVIERR_BADSIZE

GLSVfw

AVIERR_BUFFERTOOSMALL

GLSVfw

AVIERR_CANTCOMPRESS

GLSVfw

AVIERR_COMPRESSOR

GLSVfw

AVIERR_ERROR

GLSVfw

AVIERR_FILEOPEN

GLSVfw

AVIERR_FILEREAD

GLSVfw

AVIERR_FILEWRITE

GLSVfw

AVIERR_INTERNAL

GLSVfw

AVIERR_MEMORY

GLSVfw

AVIERR_NOCOMPRESSOR

GLSVfw

AVIERR_NODATA

GLSVfw

AVIERR_OK

GLSVfw

AVIERR_READONLY

GLSVfw

AVIERR_UNSUPPORTED

GLSVfw

AVIERR_USERABORT

GLSVfw

AVIFileAddRef

GLSVfw

AVIFILECAPS_ALLKEYFRAMES

GLSVfw

AVIFILECAPS_CANREAD

GLSVfw

AVIFILECAPS_CANWRITE

GLSVfw

AVIFILECAPS_NOCOMPRESSION

GLSVfw

AVIFileClose

GLSVfw

AVIFileCreateStream

GLSVfw

AVIFileCreateStreamA

GLSVfw

AVIFileCreateStreamW

GLSVfw

AVIFileEndRecord

GLSVfw

AVIFileExit

GLSVfw

AVIFileGetStream

GLSVfw

AVIFILEHANDLER_CANACCEPTNONRGB

GLSVfw

AVIFILEHANDLER_CANREAD

GLSVfw

AVIFILEHANDLER_CANWRITE

GLSVfw

AVIFileInfo

GLSVfw

AVIFileInfoA

GLSVfw

AVIFileInfoW

GLSVfw

AVIFILEINFO_COPYRIGHTED

GLSVfw

AVIFILEINFO_HASINDEX

GLSVfw

AVIFILEINFO_ISINTERLEAVED

GLSVfw

AVIFILEINFO_MUSTUSEINDEX

GLSVfw

AVIFILEINFO_WASCAPTUREFILE

GLSVfw

AVIFileInit

GLSVfw

AVIFileOpen

GLSVfw

AVIFileOpenA

GLSVfw

AVIFileOpenW

GLSVfw

AVIFileReadData

GLSVfw

AVIFileRelease

GLSVfw

AVIFileWriteData

GLSVfw

AVIF_COPYRIGHTED

GLSVfw

AVIF_HASINDEX

GLSVfw

AVIF_ISINTERLEAVED

GLSVfw

AVIF_MUSTUSEINDEX

GLSVfw

AVIF_TRUSTCKTYPE

GLSVfw

AVIF_WASCAPTUREFILE

GLSVfw

AVIGETFRAMEF_BESTDISPLAYFMT

GLSVfw

AVIGetFromClipboard

GLSVfw

AVIIF_COMPUSE

GLSVfw

AVIIF_KEYFRAME

GLSVfw

AVIIF_LIST

GLSVfw

AVIIF_NOTIME

GLSVfw

AVIIF_TWOCC

GLSVfw

AVIMakeCompressedStream

GLSVfw

AVIMakeFileFromStreams

GLSVfw

AVIMakeStreamFromClipboard

GLSVfw

AVIPutFileOnClipboard

GLSVfw

AVISaveOptions

GLSVfw

AVISaveOptionsFree

GLSVfw

AVISaveV

GLSVfw

AVISaveVA

GLSVfw

AVISaveVW

GLSVfw

AVISF_DISABLED

GLSVfw

AVISF_VIDEO_PALCHANGES

GLSVfw

AVIStreamAddRef

GLSVfw

AVIStreamBeginStreaming

GLSVfw

AVIStreamClose

GLSVfw

AVIStreamCreate

GLSVfw

AVIStreamDataSize

GLSVfw

AVIStreamEnd

GLSVfw

AVIStreamEndStreaming

GLSVfw

AVIStreamEndTime

GLSVfw

AVIStreamExit

GLSVfw

AVIStreamFindKeyFrame

GLSVfw

AVIStreamFindSample

GLSVfw

AVIStreamFormatSize

GLSVfw

AVIStreamGetFrame

GLSVfw

AVIStreamGetFrameClose

GLSVfw

AVIStreamGetFrameOpen

GLSVfw

AVIStreamInfo

GLSVfw

AVIStreamInfoA

GLSVfw

AVIStreamInfoW

GLSVfw

AVISTREAMINFO_DISABLED

GLSVfw

AVISTREAMINFO_FORMATCHANGES

GLSVfw

AVIStreamInit

GLSVfw

AVIStreamIsKeyFrame

GLSVfw

AVIStreamLength

GLSVfw

AVIStreamLengthTime

GLSVfw

AVIStreamNearestKeyFrame

GLSVfw

AVIStreamNearestKeyFrameTime

GLSVfw

AVIStreamNearestSample

GLSVfw

AVIStreamNearestSampleTime

GLSVfw

AVIStreamNextKeyFrame

GLSVfw

AVIStreamNextKeyFrameTime

GLSVfw

AVIStreamNextSample

GLSVfw

AVIStreamNextSampleTime

GLSVfw

AVIStreamOpenFromFile

GLSVfw

AVIStreamOpenFromFileA

GLSVfw

AVIStreamOpenFromFileW

GLSVfw

AVIStreamPrevKeyFrame

GLSVfw

AVIStreamPrevKeyFrameTime

GLSVfw

AVIStreamPrevSample

GLSVfw

AVIStreamPrevSampleTime

GLSVfw

AVIStreamRead

GLSVfw

AVIStreamReadData

GLSVfw

AVIStreamReadFormat

GLSVfw

AVISTREAMREAD_CONVENIENT

GLSVfw

AVIStreamRelease

GLSVfw

AVIStreamSampleSize

GLSVfw

AVIStreamSampleToSample

GLSVfw

AVIStreamSampleToTime

GLSVfw

AVIStreamSetFormat

GLSVfw

AVIStreamStart

GLSVfw

AVIStreamStartTime

GLSVfw

AVIStreamTimeToSample

GLSVfw

AVIStreamWrite

GLSVfw

AVIStreamWriteData

GLSVfw

aviTWOCC

GLSVfw

AVI_HEADERSIZE

GLSVfw

AVSTREAMMASTER_AUDIO

GLSVfw

AVSTREAMMASTER_NONE

GLSVfw

AxesBuildList

GLScene

Issues OpenGL calls for drawing X, Y, Z axes in a standard style.

AXIS_MAX

GLSDL

AXIS_MIN

GLSDL

BallAndSocketSetConeAngle

NewtonImport_JointLibrary

BallAndSocketSetTwistAngle

NewtonImport_JointLibrary

BANDPASS_DEFAULT_GAIN

openal

BANDPASS_DEFAULT_GAINHF

openal

BANDPASS_DEFAULT_GAINLF

openal

BANDPASS_MAX_GAIN

openal

BANDPASS_MAX_GAINHF

openal

BANDPASS_MAX_GAINLF

openal

BANDPASS_MIN_GAIN

openal

BANDPASS_MIN_GAINHF

openal

BANDPASS_MIN_GAINLF

openal

BarycentricCoordinates

VectorGeometry

Calculates the barycentric coordinates for the point p on the triangle defined by the vertices v1, v2 and v3. That is, solves p = u * v1 + v * v2 + (1-u-v) * v3 for u,v. Returns true if the point is inside the triangle, false otherwise.<p> NOTE: This function assumes that the point lies on the plane defined by the triangle. If this is not the case, the function will not work correctly!

BASSVERSION

Bass

BASS_3DALG_DEFAULT

Bass

BASS_3DALG_FULL

Bass

BASS_3DALG_LIGHT

Bass

BASS_3DALG_OFF

Bass

BASS_3DMODE_NORMAL

Bass

BASS_3DMODE_OFF

Bass

BASS_3DMODE_RELATIVE

Bass

BASS_3DVECTOR

Bass

BASS_ACTIVE_PAUSED

Bass

BASS_ACTIVE_PLAYING

Bass

BASS_ACTIVE_STALLED

Bass

BASS_ACTIVE_STOPPED

Bass

BASS_Apply3D

Bass

BASS_ChannelBytes2Seconds

Bass

BASS_ChannelGet3DAttributes

Bass

BASS_ChannelGet3DPosition

Bass

BASS_ChannelGetAttributes

Bass

BASS_ChannelGetData

Bass

BASS_ChannelGetDevice

Bass

BASS_ChannelGetEAXMix

Bass

BASS_ChannelGetInfo

Bass

BASS_ChannelGetLength

Bass

BASS_ChannelGetLevel

Bass

BASS_ChannelGetPosition

Bass

BASS_ChannelGetTags

Bass

BASS_CHANNELINFO

Bass

BASS_ChannelIsActive

Bass

BASS_ChannelIsSliding

Bass

BASS_ChannelPause

Bass

BASS_ChannelPlay

Bass

BASS_ChannelPreBuf

Bass

BASS_ChannelRemoveDSP

Bass

BASS_ChannelRemoveFX

Bass

BASS_ChannelRemoveLink

Bass

BASS_ChannelRemoveSync

Bass

BASS_ChannelSeconds2Bytes

Bass

BASS_ChannelSet3DAttributes

Bass

BASS_ChannelSet3DPosition

Bass

BASS_ChannelSetAttributes

Bass

BASS_ChannelSetDevice

Bass

BASS_ChannelSetDSP

Bass

BASS_ChannelSetEAXMix

Bass

BASS_ChannelSetFlags

Bass

BASS_ChannelSetFX

Bass

BASS_ChannelSetLink

Bass

BASS_ChannelSetPosition

Bass

BASS_ChannelSetSync

Bass

BASS_ChannelSlideAttributes

Bass

BASS_ChannelStop

Bass

BASS_CONFIG_3DALGORITHM

Bass

BASS_CONFIG_BUFFER

Bass

BASS_CONFIG_CURVE_PAN

Bass

BASS_CONFIG_CURVE_VOL

Bass

BASS_CONFIG_FLOATDSP

Bass

BASS_CONFIG_GVOL_MUSIC

Bass

BASS_CONFIG_GVOL_SAMPLE

Bass

BASS_CONFIG_GVOL_STREAM

Bass

BASS_CONFIG_MAXVOL

Bass

BASS_CONFIG_MUSIC_VIRTUAL

Bass

BASS_CONFIG_NET_AGENT

Bass

BASS_CONFIG_NET_BUFFER

Bass

BASS_CONFIG_NET_PASSIVE

Bass

BASS_CONFIG_NET_PLAYLIST

Bass

BASS_CONFIG_NET_PREBUF

Bass

BASS_CONFIG_NET_PROXY

Bass

BASS_CONFIG_NET_TIMEOUT

Bass

BASS_CONFIG_PAUSE_NOPLAY

Bass

BASS_CONFIG_REC_BUFFER

Bass

BASS_CONFIG_UPDATEPERIOD

Bass

BASS_CTYPE_MUSIC_IT

Bass

BASS_CTYPE_MUSIC_MO3

Bass

BASS_CTYPE_MUSIC_MOD

Bass

BASS_CTYPE_MUSIC_MTM

Bass

BASS_CTYPE_MUSIC_S3M

Bass

BASS_CTYPE_MUSIC_XM

Bass

BASS_CTYPE_RECORD

Bass

BASS_CTYPE_SAMPLE

Bass

BASS_CTYPE_STREAM

Bass

BASS_CTYPE_STREAM_AIFF

Bass

BASS_CTYPE_STREAM_MP1

Bass

BASS_CTYPE_STREAM_MP2

Bass

BASS_CTYPE_STREAM_MP3

Bass

BASS_CTYPE_STREAM_OGG

Bass

BASS_CTYPE_STREAM_WAV

Bass

BASS_CTYPE_STREAM_WAV_FLOAT

Bass

BASS_CTYPE_STREAM_WAV_PCM

Bass

BASS_DATA_AVAILABLE

Bass

BASS_DATA_FFT1024

Bass

BASS_DATA_FFT2048

Bass

BASS_DATA_FFT4096

Bass

BASS_DATA_FFT512

Bass

BASS_DATA_FFT8192

Bass

BASS_DATA_FFT_INDIVIDUAL

Bass

BASS_DATA_FFT_NOWINDOW

Bass

BASS_DATA_FLOAT

Bass

BASS_DEVICE_3D

Bass

BASS_DEVICE_8BITS

Bass

BASS_DEVICE_LATENCY

Bass

BASS_DEVICE_MONO

Bass

BASS_DEVICE_NOSPEAKER

Bass

BASS_DEVICE_SPEAKERS

Bass

BASS_DLL

Bass

BASS_ErrorGetCode

Bass

BASS_ERROR_ALREADY

Bass

BASS_ERROR_BUFLOST

Bass

BASS_ERROR_CODEC

Bass

BASS_ERROR_CREATE

Bass

BASS_ERROR_DECODE

Bass

BASS_ERROR_DEVICE

Bass

BASS_ERROR_DRIVER

Bass

BASS_ERROR_DX

Bass

BASS_ERROR_EMPTY

Bass

BASS_ERROR_FILEFORM

Bass

BASS_ERROR_FILEOPEN

Bass

BASS_ERROR_FORMAT

Bass

BASS_ERROR_FREQ

Bass

BASS_ERROR_HANDLE

Bass

BASS_ERROR_ILLPARAM

Bass

BASS_ERROR_ILLTYPE

Bass

BASS_ERROR_INIT

Bass

BASS_ERROR_MEM

Bass

BASS_ERROR_NO3D

Bass

BASS_ERROR_NOCHAN

Bass

BASS_ERROR_NOEAX

Bass

BASS_ERROR_NOFX

Bass

BASS_ERROR_NOHW

Bass

BASS_ERROR_NONET

Bass

BASS_ERROR_NOPAUSE

Bass

BASS_ERROR_NOPLAY

Bass

BASS_ERROR_NOTAVAIL

Bass

BASS_ERROR_NOTFILE

Bass

BASS_ERROR_PLAYING

Bass

BASS_ERROR_POSITION

Bass

BASS_ERROR_SPEAKER

Bass

BASS_ERROR_START

Bass

BASS_ERROR_TIMEOUT

Bass

BASS_ERROR_UNKNOWN

Bass

BASS_ERROR_VERSION

Bass

BASS_FILEPOS_CONNECTED

Bass

BASS_FILEPOS_CURRENT

Bass

BASS_FILEPOS_DECODE

Bass

BASS_FILEPOS_DOWNLOAD

Bass

BASS_FILEPOS_END

Bass

BASS_FILEPOS_START

Bass

BASS_FILE_CLOSE

Bass

BASS_FILE_LEN

Bass

BASS_FILE_READ

Bass

BASS_FILE_SEEK

Bass

BASS_Free

Bass

BASS_FXCHORUS

Bass

BASS_FXCOMPRESSOR

Bass

BASS_FXDISTORTION

Bass

BASS_FXECHO

Bass

BASS_FXFLANGER

Bass

BASS_FXGARGLE

Bass

BASS_FXGetParameters

Bass

BASS_FXI3DL2REVERB

Bass

BASS_FXPARAMEQ

Bass

BASS_FXReset

Bass

BASS_FXREVERB

Bass

BASS_FXSetParameters

Bass

BASS_FX_CHORUS

Bass

BASS_FX_COMPRESSOR

Bass

BASS_FX_DISTORTION

Bass

BASS_FX_ECHO

Bass

BASS_FX_FLANGER

Bass

BASS_FX_GARGLE

Bass

BASS_FX_I3DL2REVERB

Bass

BASS_FX_PARAMEQ

Bass

BASS_FX_PHASE_180

Bass

BASS_FX_PHASE_90

Bass

BASS_FX_PHASE_NEG_180

Bass

BASS_FX_PHASE_NEG_90

Bass

BASS_FX_PHASE_ZERO

Bass

BASS_FX_REVERB

Bass

BASS_Get3DFactors

Bass

BASS_Get3DPosition

Bass

BASS_GetConfig

Bass

BASS_GetCPU

Bass

BASS_GetDevice

Bass

BASS_GetDeviceDescription

Bass

BASS_GetDSoundObject

Bass

BASS_GetEAXParameters

Bass

BASS_GetInfo

Bass

BASS_GetVersion

Bass

BASS_GetVolume

Bass

BASS_INFO

Bass

BASS_Init

Bass

BASS_INPUT_LEVEL

Bass

BASS_INPUT_OFF

Bass

BASS_INPUT_ON

Bass

BASS_INPUT_TYPE_ANALOG

Bass

BASS_INPUT_TYPE_AUX

Bass

BASS_INPUT_TYPE_CD

Bass

BASS_INPUT_TYPE_DIGITAL

Bass

BASS_INPUT_TYPE_LINE

Bass

BASS_INPUT_TYPE_MASK

Bass

BASS_INPUT_TYPE_MIC

Bass

BASS_INPUT_TYPE_PHONE

Bass

BASS_INPUT_TYPE_SPEAKER

Bass

BASS_INPUT_TYPE_SYNTH

Bass

BASS_INPUT_TYPE_UNDEF

Bass

BASS_INPUT_TYPE_WAVE

Bass

BASS_IsLoaded

Bass

BASS_Load

Bass

BASS_MP3_SETPOS

Bass

BASS_MusicFree

Bass

BASS_MusicGetAttribute

Bass

BASS_MusicGetOrderPosition

Bass

BASS_MusicGetOrders

Bass

BASS_MusicLoad

Bass

BASS_MusicSetAttribute

Bass

BASS_MUSIC_3D

Bass

BASS_MUSIC_ATTRIB_AMPLIFY

Bass

BASS_MUSIC_ATTRIB_BPM

Bass

BASS_MUSIC_ATTRIB_PANSEP

Bass

BASS_MUSIC_ATTRIB_PSCALER

Bass

BASS_MUSIC_ATTRIB_SPEED

Bass

BASS_MUSIC_ATTRIB_VOL_CHAN

Bass

BASS_MUSIC_ATTRIB_VOL_GLOBAL

Bass

BASS_MUSIC_ATTRIB_VOL_INST

Bass

BASS_MUSIC_AUTOFREE

Bass

BASS_MUSIC_CALCLEN

Bass

BASS_MUSIC_DECODE

Bass

BASS_MUSIC_FLOAT

Bass

BASS_MUSIC_FT2MOD

Bass

BASS_MUSIC_FX

Bass

BASS_MUSIC_LOOP

Bass

BASS_MUSIC_MONO

Bass

BASS_MUSIC_NONINTER

Bass

BASS_MUSIC_NOSAMPLE

Bass

BASS_MUSIC_POSRESET

Bass

BASS_MUSIC_POSRESETEX

Bass

BASS_MUSIC_PRESCAN

Bass

BASS_MUSIC_PT1MOD

Bass

BASS_MUSIC_RAMP

Bass

BASS_MUSIC_RAMPS

Bass

BASS_MUSIC_STOPBACK

Bass

BASS_MUSIC_SURROUND

Bass

BASS_MUSIC_SURROUND2

Bass

BASS_NET_BUFFER

Bass

BASS_NET_TIMEOUT

Bass

BASS_OBJECT_DS

Bass

BASS_OBJECT_DS3DL

Bass

BASS_OK

Bass

BASS_Pause

Bass

BASS_PLUGINFORM

Bass

BASS_PluginFree

Bass

BASS_PluginGetInfo

Bass

BASS_PLUGININFO

Bass

BASS_PluginLoad

Bass

BASS_RecordFree

Bass

BASS_RecordGetDevice

Bass

BASS_RecordGetDeviceDescription

Bass

BASS_RecordGetInfo

Bass

BASS_RecordGetInput

Bass

BASS_RecordGetInputName

Bass

BASS_RECORDINFO

Bass

BASS_RecordInit

Bass

BASS_RecordSetDevice

Bass

BASS_RecordSetInput

Bass

BASS_RecordStart

Bass

BASS_RECORD_PAUSE

Bass

BASS_SAMPLE

Bass

BASS_SampleCreate

Bass

BASS_SampleCreateDone

Bass

BASS_SampleFree

Bass

BASS_SampleGetChannel

Bass

BASS_SampleGetChannels

Bass

BASS_SampleGetInfo

Bass

BASS_SampleLoad

Bass

BASS_SampleSetInfo

Bass

BASS_SampleStop

Bass

BASS_SAMPLE_3D

Bass

BASS_SAMPLE_8BITS

Bass

BASS_SAMPLE_FLOAT

Bass

BASS_SAMPLE_FX

Bass

BASS_SAMPLE_LOOP

Bass

BASS_SAMPLE_MONO

Bass

BASS_SAMPLE_MUTEMAX

Bass

BASS_SAMPLE_OVER_DIST

Bass

BASS_SAMPLE_OVER_POS

Bass

BASS_SAMPLE_OVER_VOL

Bass

BASS_SAMPLE_SOFTWARE

Bass

BASS_SAMPLE_VAM

Bass

BASS_Set3DFactors

Bass

BASS_Set3DPosition

Bass

BASS_SetConfig

Bass

BASS_SetDevice

Bass

BASS_SetEAXParameters

Bass

BASS_SetEAXPreset

Bass

BASS_SetVolume

Bass

BASS_SLIDE_FREQ

Bass

BASS_SLIDE_PAN

Bass

BASS_SLIDE_VOL

Bass

BASS_SPEAKER_CENLFE

Bass

BASS_SPEAKER_CENTER

Bass

BASS_SPEAKER_FRONT

Bass

BASS_SPEAKER_FRONTLEFT

Bass

BASS_SPEAKER_FRONTRIGHT

Bass

BASS_SPEAKER_LEFT

Bass

BASS_SPEAKER_LFE

Bass

BASS_SPEAKER_N

Bass

BASS_SPEAKER_REAR

Bass

BASS_SPEAKER_REAR2

Bass

BASS_SPEAKER_REAR2LEFT

Bass

BASS_SPEAKER_REAR2RIGHT

Bass

BASS_SPEAKER_REARLEFT

Bass

BASS_SPEAKER_REARRIGHT

Bass

BASS_SPEAKER_RIGHT

Bass

BASS_Start

Bass

BASS_Stop

Bass

BASS_StreamCreate

Bass

BASS_StreamCreateFile

Bass

BASS_StreamCreateFileUser

Bass

BASS_StreamCreateURL

Bass

BASS_StreamFree

Bass

BASS_StreamGetFilePosition

Bass

BASS_STREAMPROC_END

Bass

BASS_STREAM_AUTOFREE

Bass

BASS_STREAM_BLOCK

Bass

BASS_STREAM_DECODE

Bass

BASS_STREAM_PRESCAN

Bass

BASS_STREAM_RESTRATE

Bass

BASS_STREAM_STATUS

Bass

BASS_SYNC_DOWNLOAD

Bass

BASS_SYNC_END

Bass

BASS_SYNC_FREE

Bass

BASS_SYNC_MESSAGE

Bass

BASS_SYNC_META

Bass

BASS_SYNC_MIXTIME

Bass

BASS_SYNC_MUSICFX

Bass

BASS_SYNC_MUSICINST

Bass

BASS_SYNC_MUSICPOS

Bass

BASS_SYNC_ONETIME

Bass

BASS_SYNC_POS

Bass

BASS_SYNC_SETPOS

Bass

BASS_SYNC_SLIDE

Bass

BASS_SYNC_STALL

Bass

BASS_TAG_HTTP

Bass

BASS_TAG_ICY

Bass

BASS_TAG_ID3

Bass

BASS_TAG_ID3V2

Bass

BASS_TAG_LYRICS3

Bass

BASS_TAG_META

Bass

BASS_TAG_MUSIC_INST

Bass

BASS_TAG_MUSIC_MESSAGE

Bass

BASS_TAG_MUSIC_NAME

Bass

BASS_TAG_MUSIC_SAMPLE

Bass

BASS_TAG_OGG

Bass

BASS_TAG_RIFF_INFO

Bass

BASS_TAG_VENDOR

Bass

BASS_UNICODE

Bass

BASS_UnLoad

Bass

BASS_Update

Bass

BASS_VAM_HARDWARE

Bass

BASS_VAM_SOFTWARE

Bass

BASS_VAM_TERM_DIST

Bass

BASS_VAM_TERM_PRIO

Bass

BASS_VAM_TERM_TIME

Bass

BBMaxX

GeometryBB

BBMaxY

GeometryBB

BBMaxZ

GeometryBB

BBMinX

GeometryBB

BBMinY

GeometryBB

BBMinZ

GeometryBB

BBToAABB

GeometryBB

BBTransform

GeometryBB

BeginFPUOnlySection

VectorGeometry

Begins a FPU-only section.<p> You can use a FPU-only section to force use of FPU versions of the math functions, though typically slower than their SIMD counterparts, they have a higher precision (80 bits internally) that may be required in some cases.<p> Each BeginFPUOnlySection call must be balanced by a EndFPUOnlySection (calls can be nested).

BEHAVIOURS_SELECTED

GLSceneEditLCL

BEHAVIOURS_SELECTED

GLSceneEdit

BezierCurvePoint

CurvesAndSurfaces

BezierSurfacePoint

CurvesAndSurfaces

BGR24ToRGB24

GLGraphics

BGR24ToRGBA32

GLGraphics

BGRA32ToRGBA32

GLGraphics

BinormalAttributeName

GLObjects

BipolarCylindrical_Cartesian

GeometryCoordinates

Convert Bipolar to Cartesian (with error check). u in rad

BipolarCylindrical_Cartesian

GeometryCoordinates

Convert Bipolar to Cartesian (with error check). [Double] u in rad

BipolarCylindrical_Cartesian

GeometryCoordinates

Convert Bipolar to Cartesian. [Double] u in rad

BipolarCylindrical_Cartesian

GeometryCoordinates

Convert Bipolar to Cartesian. u in rad

BitmapScanLine

GLCrossPlatform

Returns the bitmap's scanline for the specified row.

BitMapStrMax3DS

Const3DS

BIT_MAP

Const3DS

BI_1632

GLSVfw

BlankJointGetInfo

NewtonImport_JointLibrary

Bool

NewtonImport

BOOL

Bass

Border

GLSMemo

BottomFalloff

Const3DS

BOUNDBOX

Const3DS

BoundingBoxesAreEqual

GeometryBB

BoundingBoxesAreEqual

GeometryBB

BrightenRGBArray

GLGraphics

BSphereContainsAABB

GeometryBB

BSphereContainsBSphere

GeometryBB

BSphereIntersectsBSphere

GeometryBB

BSphereToAABB

GeometryBB

BSphereToAABB

GeometryBB

BSphereToAABB

GeometryBB

BSplinePoint

CurvesAndSurfaces

BSplineSurfacePoint

CurvesAndSurfaces

BufSize

GLFileOBJ

Build2DMipmap

ImageUtils

BuildCube

GLMeshBuilder

BuildCylinder

GLMeshBuilder

BuildCylinder2

GLMeshBuilder

BuildNonOrientedEdgesList

MeshUtils

Builds a list of non-oriented (non duplicated) edges list.<p> Each edge is represented by the two integers of its vertices, sorted in ascending order.<br> If not nil, triangleEdges is filled with the 3 indices of the 3 edges of the triangle, the edges ordering respecting the original triangle orientation.

BuildNormals

MeshUtils

Builds normals for a triangles list.<p> Builds one normal per reference vertex (may be NullVector is reference isn't used), which is the averaged for normals of all adjacent triangles.<p> Returned list must be freed by caller.

BuildVectorCountOptimizedIndices

MeshUtils

Builds a vector-count optimized indices list.<p> The returned list (to be freed by caller) contains an "optimized" indices list in which duplicates coordinates in the original vertices list are used only once (the first available duplicate in the list is used).<br> The vertices list is left untouched, to remap/cleanup, you may use the RemapAndCleanupReferences function.

c180

VectorGeometry

c180divPI

VectorGeometry

c2PI

VectorGeometry

c360

VectorGeometry

c3PIdiv2

VectorGeometry

c3PIdiv4

VectorGeometry

CalcObjectSpaceLightVectors

BumpMapping

CalcPlaneNormal

VectorGeometry

CalcPlaneNormal

VectorGeometry

Calculate the normal of a plane defined by three points.

CalcPlaneNormal

VectorGeometry

CalcTangentSpaceLightVectors

BumpMapping

cAllAttribBits

GLState

cAllColorComponents

GLState

cAllFrustrumParts

GLGeomObjects

callibname

openal

cAllMeshPrimitive

GLState

cAllStatesChanged

GLPipelineTransformation

calutlibname

openal

CAMERA_NODE_TAG

Const3DS

CAM_RANGES

Const3DS

CAM_SEE_CONE

Const3DS

capCaptureAbort

GLSVfw

capCaptureGetSetup

GLSVfw

capCaptureSequence

GLSVfw

capCaptureSequenceNoFile

GLSVfw

capCaptureSetSetup

GLSVfw

capCaptureSingleFrame

GLSVfw

capCaptureSingleFrameClose

GLSVfw

capCaptureSingleFrameOpen

GLSVfw

capCaptureStop

GLSVfw

capCreateCaptureWindow

GLSVfw

capCreateCaptureWindowA

GLSVfw

capCreateCaptureWindowW

GLSVfw

capDlgVideoCompression

GLSVfw

capDlgVideoDisplay

GLSVfw

capDlgVideoFormat

GLSVfw

capDlgVideoSource

GLSVfw

capDriverConnect

GLSVfw

capDriverDisconnect

GLSVfw

capDriverGetCaps

GLSVfw

capDriverGetName

GLSVfw

capDriverGetVersion

GLSVfw

capEditCopy

GLSVfw

capFileAlloc

GLSVfw

capFileGetCaptureFile

GLSVfw

capFileSaveAs

GLSVfw

capFileSaveDIB

GLSVfw

capFileSetCaptureFile

GLSVfw

capFileSetInfoChunk

GLSVfw

capGetAudioFormat

GLSVfw

capGetAudioFormatSize

GLSVfw

capGetDriverDescription

GLSVfw

capGetDriverDescriptionA

GLSVfw

capGetDriverDescriptionW

GLSVfw

capGetMCIDeviceName

GLSVfw

capGetStatus

GLSVfw

capGetUserData

GLSVfw

capGetVideoFormat

GLSVfw

capGetVideoFormatSize

GLSVfw

capGrabFrame

GLSVfw

capGrabFrameNoStop

GLSVfw

capOverlay

GLSVfw

capPaletteAuto

GLSVfw

capPaletteManual

GLSVfw

capPaletteOpen

GLSVfw

capPalettePaste

GLSVfw

capPaletteSave

GLSVfw

capPreview

GLSVfw

capPreviewRate

GLSVfw

capPreviewScale

GLSVfw

capSetAudioFormat

GLSVfw

capSetCallbackOnCapControl

GLSVfw

capSetCallbackOnError

GLSVfw

capSetCallbackOnFrame

GLSVfw

capSetCallbackOnStatus

GLSVfw

capSetCallbackOnVideoStream

GLSVfw

capSetCallbackOnWaveStream

GLSVfw

capSetCallbackOnYield

GLSVfw

capSetMCIDeviceName

GLSVfw

capSetScrollPos

GLSVfw

capSetUserData

GLSVfw

capSetVideoFormat

GLSVfw

Cartesian_Cylindrical

GeometryCoordinates

Convert cartesian to cylindrical [single]

Cartesian_Cylindrical

GeometryCoordinates

Convert cartesion to cylindrical [double]

Cartesian_Spherical

GeometryCoordinates

Cartesian_Spherical

GeometryCoordinates

Convert cartesion to spherical [double]

Cartesian_Spherical

GeometryCoordinates

Convert cartesian to spherical [single]

cBackwardContextFailed

GLWin32Context

CBBBack

GeometryBB

CBBBottom

GeometryBB

CBBFront

GeometryBB

CBBLeft

GeometryBB

CBBPlans

GeometryBB

CBBRight

GeometryBB

CBBTop

GeometryBB

cbrt

Polynomials

Calculates the cube root of its parameter.

cColinearBias

VectorGeometry

cContextActivationFailed

GLContext

cContextDeactivationFailed

GLContext

cDefaultFlareElements

GLLensFlare

cDefaultGLActorOptions

GLVectorFileObjects

cDefaultImposterOptions

GLImposter

cDefaultMirrorOptions

GLMirror

cDefaultNormalMapScale

GLTexture

cDefaultNormalMapScale

GLColor

cDefaultProxyOptions

GLScene

cDefaultScreenSaverOptions

ScreenSaver

cDefaultSDLWindowOptions

GLSDLWindow

cDefaultShadowPlaneOptions

GLShadowPlane

cDefaultSwizzleVector

GLTextureFormat

cDefaultWaterPlaneOptions

GLWaterPlane

cDEFAULT_CONSTRAINT_FRICTION

VerletClasses

cDEFAULT_TIMER_INTERVAL

AsyncTimer

cDeleteContextFailed

GLContext

CDirPlan

GeometryBB

CD_FPS

GLSDL

cECCloseDistance

GLEllipseCollision

Ceil

VectorGeometry

Ceil64

VectorGeometry

CENTERJSAMPLE

GLSJPG

cFailHWRC

GLWin32Context

cForwardContextFailed

GLWin32Context

cgGLBindProgram

cgGL

cgGLDisableClientState

cgGL

cgGLDisableProfile

cgGL

cgGLDisableTextureParameter

cgGL

cgGLEnableClientState

cgGL

cgGLEnableProfile

cgGL

cgGLEnableTextureParameter

cgGL

CGGLenum

cgGL

cgGLGetLatestProfile

cgGL

cgGLGetManageTextureParameters

cgGL

cgGLGetMatrixParameterArraydc

cgGL

cgGLGetMatrixParameterArraydr

cgGL

cgGLGetMatrixParameterArrayfc

cgGL

cgGLGetMatrixParameterArrayfr

cgGL

cgGLGetMatrixParameterdc

cgGL

cgGLGetMatrixParameterdr

cgGL

cgGLGetMatrixParameterfc

cgGL

cgGLGetMatrixParameterfr

cgGL

cgGLGetParameter1d

cgGL

cgGLGetParameter1f

cgGL

cgGLGetParameter2d

cgGL

cgGLGetParameter2f

cgGL

cgGLGetParameter3d

cgGL

cgGLGetParameter3f

cgGL

cgGLGetParameter4d

cgGL

cgGLGetParameter4f

cgGL

cgGLGetParameterArray1d

cgGL

cgGLGetParameterArray1f

cgGL

cgGLGetParameterArray2d

cgGL

cgGLGetParameterArray2f

cgGL

cgGLGetParameterArray3d

cgGL

cgGLGetParameterArray3f

cgGL

cgGLGetParameterArray4d

cgGL

cgGLGetParameterArray4f

cgGL

cgGLGetProgramID

cgGL

cgGLGetTextureEnum

cgGL

cgGLGetTextureParameter

cgGL

cgGLIsProfileSupported

cgGL

cgGLIsProgramLoaded

cgGL

CgGLlibrary

cgGL

cgGLLoadProgram

cgGL

cgGLSetManageTextureParameters

cgGL

cgGLSetMatrixParameterArraydc

cgGL

cgGLSetMatrixParameterArraydr

cgGL

cgGLSetMatrixParameterArrayfc

cgGL

cgGLSetMatrixParameterArrayfr

cgGL

cgGLSetMatrixParameterdc

cgGL

cgGLSetMatrixParameterdr

cgGL

cgGLSetMatrixParameterfc

cgGL

cgGLSetMatrixParameterfr

cgGL

cgGLSetOptimalOptions

cgGL

cgGLSetParameter1d

cgGL

cgGLSetParameter1dv

cgGL

cgGLSetParameter1f

cgGL

cgGLSetParameter1fv

cgGL

cgGLSetParameter2d

cgGL

cgGLSetParameter2dv

cgGL

cgGLSetParameter2f

cgGL

cgGLSetParameter2fv

cgGL

cgGLSetParameter3d

cgGL

cgGLSetParameter3dv

cgGL

cgGLSetParameter3f

cgGL

cgGLSetParameter3fv

cgGL

cgGLSetParameter4d

cgGL

cgGLSetParameter4dv

cgGL

cgGLSetParameter4f

cgGL

cgGLSetParameter4fv

cgGL

cgGLSetParameterArray1d

cgGL

cgGLSetParameterArray1f

cgGL

cgGLSetParameterArray2d

cgGL

cgGLSetParameterArray2f

cgGL

cgGLSetParameterArray3d

cgGL

cgGLSetParameterArray3f

cgGL

cgGLSetParameterArray4d

cgGL

cgGLSetParameterArray4f

cgGL

cgGLSetParameterPointer

cgGL

cgGLSetStateMatrixParameter

cgGL

cgGLSetTextureParameter

cgGL

cgGLUnbindProgram

cgGL

CGLAbstractShaderUniform

GLMaterialEx

CGLBaseMaterialCollectionItem

GLMaterialEx

cGLBlendEquationToGLEnum

GLState

cGLBlendFunctionToGLEnum

GLState

cGLBufferBindingTarget

GLState

cGLComparisonFunctionToGLEnum

GLState

cGLCullFaceModeToGLEnum

GLState

cGLFaceWindingToGLEnum

GLState

cGLgsInTypes

GLSLParameter

cGLgsOutTypes

GLSLParameter

cGLHintToGLEnum

GLState

cGLLogicOpToGLEnum

GLState

cGLPolygonModeToGLEnum

GLState

cGLQueryTypeToGLEnum

GLState

cGLSLSamplerString

GLSLParameter

cGLSLTypeString

GLSLParameter

cGLStateToGLEnum

GLState

cGLStateTypeToGLEnum

GLState

cGLStencilOpToGLEnum

GLState

cGLTexTypeToGLEnum

GLState

CG_GL_FRAGMENT

cgGL

CG_GL_MATRIX_IDENTITY

cgGL

CG_GL_MATRIX_INVERSE

cgGL

CG_GL_MATRIX_INVERSE_TRANSPOSE

cgGL

CG_GL_MATRIX_TRANSPOSE

cgGL

CG_GL_MODELVIEW_MATRIX

cgGL

CG_GL_MODELVIEW_PROJECTION_MATRIX

cgGL

CG_GL_PROJECTION_MATRIX

cgGL

CG_GL_TEXTURE_MATRIX

cgGL

CG_GL_VERTEX

cgGL

CharArray

NewtonImport

CharInSet

GLCrossPlatform

CharInSet

GLCrossPlatform

CharToVirtualKeyCode

GLKeyboard

Returns the virtual keycode corresponding to the given char.<p> The returned code is untranslated, f.i. 'a' and 'A' will give the same result. A return value of -1 means that the characted cannot be entered using the keyboard.

CharToWideChar

GLCrossPlatform

CheckOpenGLError

OpenGL1x

Gets the oldest error from OpenGL engine and tries to clear the error queue.<p>

cHTFHashTableSize

HeightTileFile

cHTFQuadTableSize

HeightTileFile

ChunkHeaderReport

Utils3DS

ChunkTagToString

Utils3DS

ChunkType

Const3DS

ChunkUnique

Const3DS

cImageDataFormat16bits

DXTC

cImageDataFormat24bits

DXTC

cImageDataFormat32bits

DXTC

cImageDataFormat8bits

DXTC

cIncompatibleContexts

GLContext

cInv2PI

VectorGeometry

cInv360

VectorGeometry

ckidAVIMAINHDR

GLSVfw

ckidAVINEWINDEX

GLSVfw

ckidAVIPADDING

GLSVfw

ckidSTREAMFORMAT

GLSVfw

ckidSTREAMHANDLERDATA

GLSVfw

ckidSTREAMHEADER

GLSVfw

ckidSTREAMNAME

GLSVfw

cktypeDIBbits

GLSVfw

cktypeDIBcompressed

GLSVfw

cktypePALchange

GLSVfw

cktypeWAVEbytes

GLSVfw

clActiveBackground

GLColor

clActiveBase

GLColor

clActiveBrightText

GLColor

clActiveButton

GLColor

clActiveButtonText

GLColor

clActiveDark

GLColor

clActiveForeground

GLColor

clActiveHighlight

GLColor

clActiveHighlightedText

GLColor

clActiveLight

GLColor

clActiveMid

GLColor

clActiveMidlight

GLColor

clActiveShadow

GLColor

clActiveText

GLColor

ClampInteger

VectorGeometry

ClampInteger

VectorGeometry

ClampValue

VectorGeometry

Clamps aValue in the aMin-aMax interval.<p>

ClampValue

VectorGeometry

Clamps aValue in the aMin-INF interval.<p>

clBackground

GLColor

clBase

GLColor

clBrightText

GLColor

clBuildProgram

GLS_CL

clButton

GLColor

clButtonText

GLColor

clCreateBuffer

GLS_CL

clCreateCommandQueue

GLS_CL

clCreateContext

GLS_CL

clCreateContextFromType

GLS_CL

clCreateFromGLBuffer

GLS_CL_GL

clCreateFromGLRenderbuffer

GLS_CL_GL

clCreateFromGLTexture2D

GLS_CL_GL

clCreateFromGLTexture3D

GLS_CL_GL

clCreateImage2D

GLS_CL

clCreateImage3D

GLS_CL

clCreateKernel

GLS_CL

clCreateKernelsInProgram

GLS_CL

clCreateProgramWithBinary

GLS_CL

clCreateProgramWithSource

GLS_CL

clCreateSampler

GLS_CL

clDark

GLColor

clDisabledBackground

GLColor

clDisabledBase

GLColor

clDisabledBrightText

GLColor

clDisabledButton

GLColor

clDisabledButtonText

GLColor

clDisabledDark

GLColor

clDisabledForeground

GLColor

clDisabledHighlight

GLColor

clDisabledHighlightedText

GLColor

clDisabledLight

GLColor

clDisabledMid

GLColor

clDisabledMidlight

GLColor

clDisabledShadow

GLColor

clDisabledText

GLColor

clDontMask

GLColor

ClearGLError

OpenGL1x

Clears all pending OpenGL errors.

clEnqueueAcquireGLObjects

GLS_CL_GL

clEnqueueBarrier

GLS_CL

clEnqueueCopyBuffer

GLS_CL

clEnqueueCopyBufferToImage

GLS_CL

clEnqueueCopyImage

GLS_CL

clEnqueueCopyImageToBuffer

GLS_CL

clEnqueueMapBuffer

GLS_CL

clEnqueueMapImage

GLS_CL

clEnqueueMarker

GLS_CL

clEnqueueNativeKernel

GLS_CL

clEnqueueNDRangeKernel

GLS_CL

clEnqueueReadBuffer

GLS_CL

clEnqueueReadImage

GLS_CL

clEnqueueReleaseGLObjects

GLS_CL_GL

clEnqueueTask

GLS_CL

clEnqueueUnmapMemObject

GLS_CL

clEnqueueWaitForEvents

GLS_CL

clEnqueueWriteBuffer

GLS_CL

clEnqueueWriteImage

GLS_CL

clFinish

GLS_CL

clFirstSpecialColor

GLColor

clFlush

GLS_CL

clForeground

GLColor

clGetCommandQueueInfo

GLS_CL

clGetContextInfo

GLS_CL

clGetDeviceIDs

GLS_CL

clGetDeviceInfo

GLS_CL

clGetEventInfo

GLS_CL

clGetEventProfilingInfo

GLS_CL

clGetExtensionFunctionAddress

GLS_CL

clGetGLObjectInfo

GLS_CL_GL

clGetGLTextureInfo

GLS_CL_GL

clGetImageInfo

GLS_CL

clGetKernelInfo

GLS_CL

clGetKernelWorkGroupInfo

GLS_CL

clGetMemObjectInfo

GLS_CL

clGetPlatformIDs

GLS_CL

clGetPlatformInfo

GLS_CL

clGetProgramBuildInfo

GLS_CL

clGetProgramInfo

GLS_CL

clGetSamplerInfo

GLS_CL

clGetSupportedImageFormats

GLS_CL

clHighlight

GLColor

clHighlightedText

GLColor

ClipToAABB

GeometryBB

clLight

GLColor

clMask

GLColor

clMid

GLColor

clMidlight

GLColor

cLn10

VectorGeometry

clNormalBackground

GLColor

clNormalBase

GLColor

clNormalBrightText

GLColor

clNormalButton

GLColor

clNormalButtonText

GLColor

clNormalDark

GLColor

clNormalForeground

GLColor

clNormalHighlight

GLColor

clNormalHighlightedText

GLColor

clNormalLight

GLColor

clNormalMid

GLColor

clNormalMidlight

GLColor

clNormalShadow

GLColor

clNormalText

GLColor

cloActive

GLColor

cloDisabled

GLColor

CLogSession

GLSLog

cloNormal

GLColor

CloseCUDA

GLS_CUDA_API

CloseCUDART

GLS_CUDA_Runtime

CloseCUFFT

GLS_CUDA_FourierTransform

CloseCUTIL

GLS_CUDA_Utility

ClosedPolygon2D

GLTypes

ClosedPolygon3D

GLTypes

CloseFreetype

LIBFREETYPE

CloseODE

ODEImport

CloseOpenCL

GLS_CL

CloseOpenGL

OpenGL1x

CloseOpenGL

OpenGLAdapter

Closezlib

GLSZLibExApi

clr3DDkShadow

GLColor

clr3DLight

GLColor

clrActiveBorder

GLColor

clrActiveCaption

GLColor

clrAppWorkSpace

GLColor

clrAqua

GLColor

clrAquamarine

GLColor

clrBackground

GLColor

clrBakersChoc

GLColor

clrBlack

GLColor

clrBlue

GLColor

clrBlueViolet

GLColor

clrBrass

GLColor

clrBrightGold

GLColor

clrBronze

GLColor

clrBronze2

GLColor

clrBrown

GLColor

clrBtnFace

GLColor

clrBtnHighlight

GLColor

clrBtnShadow

GLColor

clrBtnText

GLColor

clrCadetBlue

GLColor

clrCaptionText

GLColor

clrCoolCopper

GLColor

clrCopper

GLColor

clrCoral

GLColor

clrCornflowerBlue

GLColor

clrDarkBrown

GLColor

clrDarkGreen

GLColor

clrDarkOliveGreen

GLColor

clrDarkOrchid

GLColor

clrDarkPurple

GLColor

clrDarkSlateBlue

GLColor

clrDarkSlateGray

GLColor

clrDarkSlateGrey

GLColor

clrDarkTan

GLColor

clrDarkTurquoise

GLColor

clrDarkWood

GLColor

clrDimGray

GLColor

clrDkGreenCopper

GLColor

clrDustyRose

GLColor

clReleaseCommandQueue

GLS_CL

clReleaseContext

GLS_CL

clReleaseEvent

GLS_CL

clReleaseKernel

GLS_CL

clReleaseMemObject

GLS_CL

clReleaseProgram

GLS_CL

clReleaseSampler

GLS_CL

clRetainCommandQueue

GLS_CL

clRetainContext

GLS_CL

clRetainEvent

GLS_CL

clRetainKernel

GLS_CL

clRetainMemObject

GLS_CL

clRetainProgram

GLS_CL

clRetainSampler

GLS_CL

clrFeldspar

GLColor

clrFirebrick

GLColor

clrFlesh

GLColor

clrForestGreen

GLColor

clrFuchsia

GLColor

clrGold

GLColor

clrGoldenrod

GLColor

clrGray

GLColor

clrGray05

GLColor

clrGray10

GLColor

clrGray15

GLColor

clrGray20

GLColor

clrGray25

GLColor

clrGray30

GLColor

clrGray35

GLColor

clrGray40

GLColor

clrGray45

GLColor

clrGray50

GLColor

clrGray55

GLColor

clrGray60

GLColor

clrGray65

GLColor

clrGray70

GLColor

clrGray75

GLColor

clrGray80

GLColor

clrGray85

GLColor

clrGray90

GLColor

clrGray95

GLColor

clrGrayText

GLColor

clrGreen

GLColor

clrGreenCopper

GLColor

clrGreenYellow

GLColor

clrHighlight

GLColor

clrHighlightText

GLColor

clrHuntersGreen

GLColor

clrInactiveBorder

GLColor

clrInactiveCaption

GLColor

clrInactiveCaptionText

GLColor

clrIndian

GLColor

clrInfoBk

GLColor

clrInfoText

GLColor

clrKhaki

GLColor

clrLightBlue

GLColor

clrLightGray

GLColor

clrLightPurple

GLColor

clrLightSteelBlue

GLColor

clrLightWood

GLColor

clrLime

GLColor

clrLimeGreen

GLColor

clrMandarinOrange

GLColor

clrMaroon

GLColor

clrMediumAquamarine

GLColor

clrMediumBlue

GLColor

clrMediumForestGreen

GLColor

clrMediumGoldenrod

GLColor

clrMediumOrchid

GLColor

clrMediumPurple

GLColor

clrMediumSeaGreen

GLColor

clrMediumSlateBlue

GLColor

clrMediumSpringGreen

GLColor

clrMediumTurquoise

GLColor

clrMediumViolet

GLColor

clrMediumWood

GLColor

clrMenu

GLColor

clrMenuText

GLColor

clrMidnightBlue

GLColor

clrNavy

GLColor

clrNavyBlue

GLColor

clrNeonBlue

GLColor

clrNeonPink

GLColor

clrNewMidnightBlue

GLColor

clrNewTan

GLColor

clrOldGold

GLColor

clrOlive

GLColor

clrOrange

GLColor

clrOrangeRed

GLColor

clrOrchid

GLColor

clrPaleGreen

GLColor

clrPink

GLColor

clrPlum

GLColor

clrPurple

GLColor

clrQuartz

GLColor

clrRed

GLColor

clrRichBlue

GLColor

clrSalmon

GLColor

clrScarlet

GLColor

clrScrollBar

GLColor

clrSeaGreen

GLColor

clrSemiSweetChoc

GLColor

clrSienna

GLColor

clrSilver

GLColor

clrSkyBlue

GLColor

clrSlateBlue

GLColor

clrSpicyPink

GLColor

clrSpringGreen

GLColor

clrSteelBlue

GLColor

clrSummerSky

GLColor

clrTan

GLColor

clrTeal

GLColor

clrThistle

GLColor

clrTransparent

GLColor

clrTurquoise

GLColor

clrVeryDarkBrown

GLColor

clrVeryLightPurple

GLColor

clrViolet

GLColor

clrVioletRed

GLColor

clrWheat

GLColor

clrWhite

GLColor

clrWindow

GLColor

clrWindowFrame

GLColor

clrWindowText

GLColor

clrYellow

GLColor

clrYellowGreen

GLColor

clSetCommandQueueProperty

GLS_CL

clSetKernelArg

GLS_CL

clShadow

GLColor

CLSID_AVIFile

GLSVfw

CLSID_AVISimpleUnMarshal

GLSVfw

clText

GLColor

clUnloadCompiler

GLS_CL

clWaitForEvents

GLS_CL

CL_A

GLS_CL

CL_ADDRESS_CLAMP

GLS_CL

CL_ADDRESS_CLAMP_TO_EDGE

GLS_CL

CL_ADDRESS_NONE

GLS_CL

CL_ADDRESS_REPEAT

GLS_CL

CL_ARGB

GLS_CL

CL_BGRA

GLS_CL

CL_BUILD_ERROR

GLS_CL

CL_BUILD_IN_PROGRESS

GLS_CL

CL_BUILD_NONE

GLS_CL

CL_BUILD_PROGRAM_FAILURE

GLS_CL

CL_BUILD_SUCCESS

GLS_CL

CL_CHAR_BIT

GLS_CL_Platform

CL_CHAR_MAX

GLS_CL_Platform

CL_CHAR_MIN

GLS_CL_Platform

CL_COMMAND_ACQUIRE_GL_OBJECTS

GLS_CL

CL_COMMAND_COPY_BUFFER

GLS_CL

CL_COMMAND_COPY_BUFFER_TO_IMAGE

GLS_CL

CL_COMMAND_COPY_IMAGE

GLS_CL

CL_COMMAND_COPY_IMAGE_TO_BUFFER

GLS_CL

CL_COMMAND_MAP_BUFFER

GLS_CL

CL_COMMAND_MAP_IMAGE

GLS_CL

CL_COMMAND_MARKER

GLS_CL

CL_COMMAND_NATIVE_KERNEL

GLS_CL

CL_COMMAND_NDRANGE_KERNEL

GLS_CL

CL_COMMAND_READ_BUFFER

GLS_CL

CL_COMMAND_READ_IMAGE

GLS_CL

CL_COMMAND_RELEASE_GL_OBJECTS

GLS_CL

CL_COMMAND_TASK

GLS_CL

CL_COMMAND_UNMAP_MEM_OBJECT

GLS_CL

CL_COMMAND_WRITE_BUFFER

GLS_CL

CL_COMMAND_WRITE_IMAGE

GLS_CL

CL_COMPILER_NOT_AVAILABLE

GLS_CL

CL_COMPLETE

GLS_CL

CL_CONTEXT_DEVICES

GLS_CL

CL_CONTEXT_PLATFORM

GLS_CL

CL_CONTEXT_PROPERTIES

GLS_CL

CL_CONTEXT_REFERENCE_COUNT

GLS_CL

CL_DBL_DIG

GLS_CL_Platform

CL_DBL_EPSILON

GLS_CL_Platform

CL_DBL_MANT_DIG

GLS_CL_Platform

CL_DBL_MAX

GLS_CL_Platform

CL_DBL_MAX_10_EXP

GLS_CL_Platform

CL_DBL_MAX_EXP

GLS_CL_Platform

CL_DBL_MIN

GLS_CL_Platform

CL_DBL_MIN_10_EXP

GLS_CL_Platform

CL_DBL_MIN_EXP

GLS_CL_Platform

CL_DBL_RADIX

GLS_CL_Platform

CL_DEVICE_ADDRESS_BITS

GLS_CL

CL_DEVICE_AVAILABLE

GLS_CL

CL_DEVICE_COMPILER_AVAILABLE

GLS_CL

CL_DEVICE_ENDIAN_LITTLE

GLS_CL

CL_DEVICE_ERROR_CORRECTION_SUPPORT

GLS_CL

CL_DEVICE_EXECUTION_CAPABILITIES

GLS_CL

CL_DEVICE_EXTENSIONS

GLS_CL

CL_DEVICE_GLOBAL_MEM_CACHELINE_SIZE

GLS_CL

CL_DEVICE_GLOBAL_MEM_CACHE_SIZE

GLS_CL

CL_DEVICE_GLOBAL_MEM_CACHE_TYPE

GLS_CL

CL_DEVICE_GLOBAL_MEM_SIZE

GLS_CL

CL_DEVICE_IMAGE2D_MAX_HEIGHT

GLS_CL

CL_DEVICE_IMAGE2D_MAX_WIDTH

GLS_CL

CL_DEVICE_IMAGE3D_MAX_DEPTH

GLS_CL

CL_DEVICE_IMAGE3D_MAX_HEIGHT

GLS_CL

CL_DEVICE_IMAGE3D_MAX_WIDTH

GLS_CL

CL_DEVICE_IMAGE_SUPPORT

GLS_CL

CL_DEVICE_LOCAL_MEM_SIZE

GLS_CL

CL_DEVICE_LOCAL_MEM_TYPE

GLS_CL

CL_DEVICE_MAX_CLOCK_FREQUENCY

GLS_CL

CL_DEVICE_MAX_COMPUTE_UNITS

GLS_CL

CL_DEVICE_MAX_CONSTANT_ARGS

GLS_CL

CL_DEVICE_MAX_CONSTANT_BUFFER_SIZE

GLS_CL

CL_DEVICE_MAX_MEM_ALLOC_SIZE

GLS_CL

CL_DEVICE_MAX_PARAMETER_SIZE

GLS_CL

CL_DEVICE_MAX_READ_IMAGE_ARGS

GLS_CL

CL_DEVICE_MAX_SAMPLERS

GLS_CL

CL_DEVICE_MAX_WORK_GROUP_SIZE

GLS_CL

CL_DEVICE_MAX_WORK_ITEM_DIMENSIONS

GLS_CL

CL_DEVICE_MAX_WORK_ITEM_SIZES

GLS_CL

CL_DEVICE_MAX_WRITE_IMAGE_ARGS

GLS_CL

CL_DEVICE_MEM_BASE_ADDR_ALIGN

GLS_CL

CL_DEVICE_MIN_DATA_TYPE_ALIGN_SIZE

GLS_CL

CL_DEVICE_NAME

GLS_CL

CL_DEVICE_NOT_AVAILABLE

GLS_CL

CL_DEVICE_NOT_FOUND

GLS_CL

CL_DEVICE_PLATFORM

GLS_CL

CL_DEVICE_PREFERRED_VECTOR_WIDTH_CHAR

GLS_CL

CL_DEVICE_PREFERRED_VECTOR_WIDTH_DOUBLE

GLS_CL

CL_DEVICE_PREFERRED_VECTOR_WIDTH_FLOAT

GLS_CL

CL_DEVICE_PREFERRED_VECTOR_WIDTH_INT

GLS_CL

CL_DEVICE_PREFERRED_VECTOR_WIDTH_LONG

GLS_CL

CL_DEVICE_PREFERRED_VECTOR_WIDTH_SHORT

GLS_CL

CL_DEVICE_PROFILE

GLS_CL

CL_DEVICE_PROFILING_TIMER_RESOLUTION

GLS_CL

CL_DEVICE_QUEUE_PROPERTIES

GLS_CL

CL_DEVICE_SINGLE_FP_CONFIG

GLS_CL

CL_DEVICE_TYPE

GLS_CL

CL_DEVICE_TYPE_ACCELERATOR

GLS_CL

CL_DEVICE_TYPE_ALL

GLS_CL

CL_DEVICE_TYPE_CPU

GLS_CL

CL_DEVICE_TYPE_DEFAULT

GLS_CL

CL_DEVICE_TYPE_GPU

GLS_CL

CL_DEVICE_VENDOR

GLS_CL

CL_DEVICE_VENDOR_ID

GLS_CL

CL_DEVICE_VERSION

GLS_CL

CL_DRIVER_VERSION

GLS_CL

CL_EVENT_COMMAND_EXECUTION_STATUS

GLS_CL

CL_EVENT_COMMAND_QUEUE

GLS_CL

CL_EVENT_COMMAND_TYPE

GLS_CL

CL_EVENT_REFERENCE_COUNT

GLS_CL

CL_EXEC_KERNEL

GLS_CL

CL_EXEC_NATIVE_KERNEL

GLS_CL

CL_FALSE

GLS_CL

CL_FILTER_LINEAR

GLS_CL

CL_FILTER_NEAREST

GLS_CL

CL_FLOAT

GLS_CL

CL_FLT_DIG

GLS_CL_Platform

CL_FLT_EPSILON

GLS_CL_Platform

CL_FLT_MANT_DIG

GLS_CL_Platform

CL_FLT_MAX

GLS_CL_Platform

CL_FLT_MAX_10_EXP

GLS_CL_Platform

CL_FLT_MAX_EXP

GLS_CL_Platform

CL_FLT_MIN

GLS_CL_Platform

CL_FLT_MIN_10_EXP

GLS_CL_Platform

CL_FLT_MIN_EXP

GLS_CL_Platform

CL_FLT_RADIX

GLS_CL_Platform

CL_FP_DENORM

GLS_CL

CL_FP_FMA

GLS_CL

CL_FP_INF_NAN

GLS_CL

CL_FP_ROUND_TO_INF

GLS_CL

CL_FP_ROUND_TO_NEAREST

GLS_CL

CL_FP_ROUND_TO_ZERO

GLS_CL

CL_GLOBAL

GLS_CL

CL_GL_MIPMAP_LEVEL

GLS_CL_GL

CL_GL_OBJECT_BUFFER

GLS_CL_GL

CL_GL_OBJECT_RENDERBUFFER

GLS_CL_GL

CL_GL_OBJECT_TEXTURE2D

GLS_CL_GL

CL_GL_OBJECT_TEXTURE3D

GLS_CL_GL

CL_GL_TEXTURE_TARGET

GLS_CL_GL

CL_HALF_FLOAT

GLS_CL

CL_IMAGE_DEPTH

GLS_CL

CL_IMAGE_ELEMENT_SIZE

GLS_CL

CL_IMAGE_FORMAT

GLS_CL

CL_IMAGE_FORMAT_MISMATCH

GLS_CL

CL_IMAGE_FORMAT_NOT_SUPPORTED

GLS_CL

CL_IMAGE_HEIGHT

GLS_CL

CL_IMAGE_ROW_PITCH

GLS_CL

CL_IMAGE_SLICE_PITCH

GLS_CL

CL_IMAGE_WIDTH

GLS_CL

CL_INTENSITY

GLS_CL

CL_INT_MAX

GLS_CL_Platform

CL_INT_MIN

GLS_CL_Platform

CL_INVALID_ARG_INDEX

GLS_CL

CL_INVALID_ARG_SIZE

GLS_CL

CL_INVALID_ARG_VALUE

GLS_CL

CL_INVALID_BINARY

GLS_CL

CL_INVALID_BUFFER_SIZE

GLS_CL

CL_INVALID_BUILD_OPTIONS

GLS_CL

CL_INVALID_COMMAND_QUEUE

GLS_CL

CL_INVALID_CONTEXT

GLS_CL

CL_INVALID_DEVICE

GLS_CL

CL_INVALID_DEVICE_TYPE

GLS_CL

CL_INVALID_EVENT

GLS_CL

CL_INVALID_EVENT_WAIT_LIST

GLS_CL

CL_INVALID_GLOBAL_OFFSET

GLS_CL

CL_INVALID_GLOBAL_WORK_SIZE

GLS_CL

CL_INVALID_GL_OBJECT

GLS_CL

CL_INVALID_HOST_PTR

GLS_CL

CL_INVALID_IMAGE_FORMAT_DESCRIPTOR

GLS_CL

CL_INVALID_IMAGE_SIZE

GLS_CL

CL_INVALID_KERNEL

GLS_CL

CL_INVALID_KERNEL_ARGS

GLS_CL

CL_INVALID_KERNEL_DEFINITION

GLS_CL

CL_INVALID_KERNEL_NAME

GLS_CL

CL_INVALID_MEM_OBJECT

GLS_CL

CL_INVALID_MIP_LEVEL

GLS_CL

CL_INVALID_OPERATION

GLS_CL

CL_INVALID_PLATFORM

GLS_CL

CL_INVALID_PROGRAM

GLS_CL

CL_INVALID_PROGRAM_EXECUTABLE

GLS_CL

CL_INVALID_QUEUE_PROPERTIES

GLS_CL

CL_INVALID_SAMPLER

GLS_CL

CL_INVALID_VALUE

GLS_CL

CL_INVALID_WORK_DIMENSION

GLS_CL

CL_INVALID_WORK_GROUP_SIZE

GLS_CL

CL_INVALID_WORK_ITEM_SIZE

GLS_CL

CL_KERNEL_COMPILE_WORK_GROUP_SIZE

GLS_CL

CL_KERNEL_CONTEXT

GLS_CL

CL_KERNEL_FUNCTION_NAME

GLS_CL

CL_KERNEL_LOCAL_MEM_SIZE

GLS_CL

CL_KERNEL_NUM_ARGS

GLS_CL

CL_KERNEL_PROGRAM

GLS_CL

CL_KERNEL_REFERENCE_COUNT

GLS_CL

CL_KERNEL_WORK_GROUP_SIZE

GLS_CL

CL_LOCAL

GLS_CL

CL_LONG_MAX

GLS_CL_Platform

CL_LONG_MIN

GLS_CL_Platform

CL_LUMINANCE

GLS_CL

CL_MAP_FAILURE

GLS_CL

CL_MAP_READ

GLS_CL

CL_MAP_WRITE

GLS_CL

CL_MEM_ALLOC_HOST_PTR

GLS_CL

CL_MEM_CONTEXT

GLS_CL

CL_MEM_COPY_HOST_PTR

GLS_CL

CL_MEM_COPY_OVERLAP

GLS_CL

CL_MEM_FLAGS

GLS_CL

CL_MEM_HOST_PTR

GLS_CL

CL_MEM_MAP_COUNT

GLS_CL

CL_MEM_OBJECT_ALLOCATION_FAILURE

GLS_CL

CL_MEM_OBJECT_BUFFER

GLS_CL

CL_MEM_OBJECT_IMAGE2D

GLS_CL

CL_MEM_OBJECT_IMAGE3D

GLS_CL

CL_MEM_READ_ONLY

GLS_CL

CL_MEM_READ_WRITE

GLS_CL

CL_MEM_REFERENCE_COUNT

GLS_CL

CL_MEM_SIZE

GLS_CL

CL_MEM_TYPE

GLS_CL

CL_MEM_USE_HOST_PTR

GLS_CL

CL_MEM_WRITE_ONLY

GLS_CL

CL_NONE

GLS_CL

CL_OUT_OF_HOST_MEMORY

GLS_CL

CL_OUT_OF_RESOURCES

GLS_CL

CL_PLATFORM_EXTENSIONS

GLS_CL

CL_PLATFORM_NAME

GLS_CL

CL_PLATFORM_PROFILE

GLS_CL

CL_PLATFORM_VENDOR

GLS_CL

CL_PLATFORM_VERSION

GLS_CL

CL_PROFILING_COMMAND_END

GLS_CL

CL_PROFILING_COMMAND_QUEUED

GLS_CL

CL_PROFILING_COMMAND_START

GLS_CL

CL_PROFILING_COMMAND_SUBMIT

GLS_CL

CL_PROFILING_INFO_NOT_AVAILABLE

GLS_CL

CL_PROGRAM_BINARIES

GLS_CL

CL_PROGRAM_BINARY_SIZES

GLS_CL

CL_PROGRAM_BUILD_LOG

GLS_CL

CL_PROGRAM_BUILD_OPTIONS

GLS_CL

CL_PROGRAM_BUILD_STATUS

GLS_CL

CL_PROGRAM_CONTEXT

GLS_CL

CL_PROGRAM_DEVICES

GLS_CL

CL_PROGRAM_NUM_DEVICES

GLS_CL

CL_PROGRAM_REFERENCE_COUNT

GLS_CL

CL_PROGRAM_SOURCE

GLS_CL

CL_QUEUED

GLS_CL

CL_QUEUE_CONTEXT

GLS_CL

CL_QUEUE_DEVICE

GLS_CL

CL_QUEUE_OUT_OF_ORDER_EXEC_MODE_ENABLE

GLS_CL

CL_QUEUE_PROFILING_ENABLE

GLS_CL

CL_QUEUE_PROPERTIES

GLS_CL

CL_QUEUE_REFERENCE_COUNT

GLS_CL

CL_R

GLS_CL

CL_RA

GLS_CL

CL_READ_ONLY_CACHE

GLS_CL

CL_READ_WRITE_CACHE

GLS_CL

CL_RG

GLS_CL

CL_RGB

GLS_CL

CL_RGBA

GLS_CL

CL_RUNNING

GLS_CL

CL_SAMPLER_ADDRESSING_MODE

GLS_CL

CL_SAMPLER_CONTEXT

GLS_CL

CL_SAMPLER_FILTER_MODE

GLS_CL

CL_SAMPLER_NORMALIZED_COORDS

GLS_CL

CL_SAMPLER_REFERENCE_COUNT

GLS_CL

CL_SCHAR_MAX

GLS_CL_Platform

CL_SCHAR_MIN

GLS_CL_Platform

CL_SHRT_MAX

GLS_CL_Platform

CL_SHRT_MIN

GLS_CL_Platform

CL_SIGNED_INT16

GLS_CL

CL_SIGNED_INT32

GLS_CL

CL_SIGNED_INT8

GLS_CL

CL_SNORM_INT16

GLS_CL

CL_SNORM_INT8

GLS_CL

CL_SUBMITTED

GLS_CL

CL_SUCCESS

GLS_CL

CL_TRUE

GLS_CL

CL_UCHAR_MAX

GLS_CL_Platform

CL_UINT_MAX

GLS_CL_Platform

CL_ULONG_MAX

GLS_CL_Platform

CL_UNORM_INT16

GLS_CL

CL_UNORM_INT8

GLS_CL

CL_UNORM_INT_101010

GLS_CL

CL_UNORM_SHORT_555

GLS_CL

CL_UNORM_SHORT_565

GLS_CL

CL_UNSIGNED_INT16

GLS_CL

CL_UNSIGNED_INT32

GLS_CL

CL_UNSIGNED_INT8

GLS_CL

CL_USHRT_MAX

GLS_CL_Platform

CL_VERSION_1_0

GLS_CL

CMAGIC

Const3DS

cMaxArray

VectorGeometry

cMaxContacts

GLODERagdoll

cMaxVerts

GLTrail

cMeshModeToGLEnum

GLMesh

CmtNX

GLTexture

CmtNY

GLTexture

CmtNZ

GLTexture

CmtPX

GLTexture

CmtPY

GLTexture

CmtPZ

GLTexture

cNoActiveRC

GLContext

COctree_GROW_GRAVY

SpatialPartitioning

COctree_LEAF_TRHESHOLD

SpatialPartitioning

COctree_MAX_TREE_DEPTH

SpatialPartitioning

CollideAndSlide

GLEllipseCollision

CollideWithWorld

GLEllipseCollision

ColorFMax3DS

Const3DS

ColorFMin3DS

Const3DS

ColorManager

GLColor

COLOR_24

Const3DS

COLOR_F

Const3DS

ColTrackTagMax3DS

Const3DS

ColTrackTagMin3DS

Const3DS

COL_TRACK_TAG

Const3DS

COL_TRACK_TAG_KEY

Const3DS

CombineVector

VectorGeometry

Combine the first vector with the second : vr:=vr+v*f

CombineVector

VectorGeometry

CombineVector

VectorGeometry

Combine the first vector with the second : vr:=vr+v*f

CombineVector

VectorGeometry

Combine the first vector with the second : vr:=vr+v*f

CompressedInternalFormatToOpenGL

GLTextureFormat

Give a compressed openGL texture format from GLScene texture format if format is have not compression than return same openGL format.

comptypeDIB

GLSVfw

ConeContainsBSphere

SpatialPartitioning

cOneHalf

VectorGeometry

CONSOLE_MAX_COMMANDS

GLConsole

ConstArrayToString

GLSLog

CONTACTS_UNIMPORTANT

ODEImport

Container

Const3DS

CONTROLCALLBACK_CAPTURING

GLSVfw

CONTROLCALLBACK_PREROLL

GLSVfw

ConvertColorVector

GLColor

Converts a color vector (containing float values) and alter intensity.<p> intensity is in [0..1]

ConvertColorVector

GLColor

Converts a color vector (containing float values)

ConvertdVector3ToAffineVector

ODEGL

ConvertdVector3ToAffineVector

ODEGL

ConvertdVector3ToVector3f

ODEGL

ConvertdVector3ToVector3f

ODEGL

ConvertdVector3ToVector4f

ODEGL

ConvertdVector3ToVector4f

ODEGL

ConvertFansToList

MeshUtils

ConvertImage

ImageUtils

ConvertIndexedListToList

MeshUtils

Expands an indexed structure into a non-indexed structure.

ConvertRGBColor

GLColor

Converts RGB components into a color vector with correct range

ConvertRotation

VectorGeometry

Turn a triplet of rotations about x, y, and z (in that order) into an equivalent rotation around a single axis (all in radians).<p>

ConvertStripToList

MeshUtils

ConvertStripToList

MeshUtils

ConvertStripToList

MeshUtils

Converts a triangle strips into a triangle list.<p> Vertices are added to list, based on the content of strip. Both non-indexed and indexed variants are available, the output is *always* non indexed.

ConvertStripToList

MeshUtils

ConvertVector3fTodVector3

ODEGL

ConvertVector3fToPdVector3

ODEGL

ConvertVector4fTodVector3

ODEGL

ConvertVector4fToPdVector3

ODEGL

ConvertWinColor

GLColor

Converts a delphi color into its RGB fragments and correct range.

CopyBodyFromCube

ODEGL

CopyCubeSizeFromBox

ODEGL

CopyPosFromGeomToGL

ODEGL

CopyScreentoTexture

GLCustomShader

CopyScreentoTexture2

GLCustomShader

Cosh

VectorGeometry

Cosh

VectorGeometry

Cosine_Interpolate

GLPerlinBase

CoTan

VectorGeometry

CoTan

VectorGeometry

cPERLIN_TABLE_SIZE

PerlinNoise

cPFXGranularity

GLParticleFX

cPFXNbRegions

GLParticleFX

cPI

VectorGeometry

cPIdiv180

VectorGeometry

cPIdiv2

VectorGeometry

cPIdiv4

VectorGeometry

crc32

GLSZLibExApi

CreateAffineRotationMatrix

VectorGeometry

Creates a rotation matrix along the given Axis by the given Angle in radians.

CreateBodyFromCube

ODEGL

CreateCustomBallAndSocket

NewtonImport_JointLibrary

CreateCustomHinge

NewtonImport_JointLibrary

CreateCustomJoint6DOF

NewtonImport_JointLibrary

CreateCustomKinematicController

NewtonImport_JointLibrary

CreateCustomPlayerController

NewtonImport_JointLibrary

CreateCustomSlider

NewtonImport_JointLibrary

CreateDOMNode

GLSCrossXML

CreateEditableStream

GLSVfw

CreateFileStream

ApplicationFileIO

Creates a file stream corresponding to the fileName.<p> If the file does not exists, an exception will be triggered.<br> Default mechanism creates a regular TFileStream, the 'mode' parameter is similar to the one for TFileStream.

CreateGeomFromCube

ODEGL

CreateGraphicFromFile

GLTexture

CreateLookAtMatrix

VectorGeometry

CreateMatrixFromFrustum

VectorGeometry

CreateObjectSpaceNormalMap

BumpMapping

CreateODEPlaneFromGLPlane

ODEGL

CreateOrthoMatrix

VectorGeometry

CreatePerspectiveMatrix

VectorGeometry

CreatePickMatrix

VectorGeometry

CreateResourceStream

ApplicationFileIO

Create a resource stream.

CreateRotationMatrix

VectorGeometry

CreateRotationMatrix

VectorGeometry

Creates a rotation matrix along the given Axis by the given Angle in radians.

CreateRotationMatrixX

VectorGeometry

Creates matrix for rotation about x-axis (angle in rad)

CreateRotationMatrixX

VectorGeometry

CreateRotationMatrixY

VectorGeometry

CreateRotationMatrixY

VectorGeometry

Creates matrix for rotation about y-axis (angle in rad)

CreateRotationMatrixZ

VectorGeometry

CreateRotationMatrixZ

VectorGeometry

Creates matrix for rotation about z-axis (angle in rad)

CreateScaleAndTranslationMatrix

VectorGeometry

Creates a scale+translation matrix.<p> Scale is applied BEFORE applying offset

CreateScaleMatrix

VectorGeometry

Creates scale matrix

CreateScaleMatrix

VectorGeometry

Creates scale matrix

CreateTangentSpaceNormalMap

BumpMapping

CreateTempWnd

GLWin32Context

CreateTranslationMatrix

VectorGeometry

Creates translation matrix

CreateTranslationMatrix

VectorGeometry

Creates translation matrix

CreateTriMeshFromBaseMesh

ODEGL

Note that this method requires you to manually deallocate vertices and indices when you're done with the trimesh

CreateVCPlaneFromGLPlane

GLVerletClasses

CSG_Operation

GLMeshCSG

CSTATE_RAW_OK

GLSJPG

CSTATE_SCANNING

GLSJPG

CSTATE_START

GLSJPG

CSTATE_WRCOEFS

GLSJPG

cTilesHashSize

GLTerrainRenderer

cuArray3DCreate

GLS_CUDA_API

cuArray3DGetDescriptor

GLS_CUDA_API

cuArrayCreate

GLS_CUDA_API

cuArrayDestroy

GLS_CUDA_API

cuArrayGetDescriptor

GLS_CUDA_API

CubeWireframeBuildList

GLObjects

Cubic_Interpolate

GLPerlinBase

Cubic_Interpolate_Strip

GLPerlinBase

cuCtxAttach

GLS_CUDA_API

cuCtxCreate

GLS_CUDA_API

cuCtxDestroy

GLS_CUDA_API

cuCtxDetach

GLS_CUDA_API

cuCtxGetDevice

GLS_CUDA_API

cuCtxPopCurrent

GLS_CUDA_API

cuCtxPushCurrent

GLS_CUDA_API

cuCtxSynchronize

GLS_CUDA_API

CUDAAPIDLL

GLS_CUDA_API

cudaBindTexture

GLS_CUDA_Runtime

cudaBindTexture2D

GLS_CUDA_Runtime

cudaBindTextureToArray

GLS_CUDA_Runtime

cudaChooseDevice

GLS_CUDA_Runtime

cudaConfigureCall

GLS_CUDA_Runtime

CUDAContextManager

GLSCUDAContext

cudaCreateChannelDesc

GLS_CUDA_Runtime

cudaDriverGetVersion

GLS_CUDA_Runtime

cudaError_t

GLS_CUDA_Runtime

cudaEventCreate

GLS_CUDA_Runtime

cudaEventCreateWithFlags

GLS_CUDA_Runtime

cudaEventDestroy

GLS_CUDA_Runtime

cudaEventElapsedTime

GLS_CUDA_Runtime

cudaEventQuery

GLS_CUDA_Runtime

cudaEventRecord

GLS_CUDA_Runtime

cudaEventSynchronize

GLS_CUDA_Runtime

cudaEvent_t

GLS_CUDA_Runtime

cudaFree

GLS_CUDA_Runtime

cudaFreeArray

GLS_CUDA_Runtime

cudaFreeHost

GLS_CUDA_Runtime

cudaFuncGetAttributes

GLS_CUDA_Runtime

cudaFuncSetCacheConfig

GLS_CUDA_Runtime

cudaGetChannelDesc

GLS_CUDA_Runtime

cudaGetDevice

GLS_CUDA_Runtime

cudaGetDeviceCount

GLS_CUDA_Runtime

cudaGetDeviceProperties

GLS_CUDA_Runtime

cudaGetErrorString

GLS_CUDA_Runtime

cudaGetLastError

GLS_CUDA_Runtime

cudaGetLastErrorString

GLS_CUDA_Runtime

cudaGetSymbolAddress

GLS_CUDA_Runtime

cudaGetSymbolSize

GLS_CUDA_Runtime

cudaGetTextureAlignmentOffset

GLS_CUDA_Runtime

cudaGetTextureReference

GLS_CUDA_Runtime

cudaGLMapBufferObject

GLS_CUDA_Runtime

cudaGLMapBufferObjectAsync

GLS_CUDA_Runtime

cudaGLRegisterBufferObject

GLS_CUDA_Runtime

cudaGLSetBufferObjectMapFlags

GLS_CUDA_Runtime

cudaGLSetGLDevice

GLS_CUDA_Runtime

cudaGLUnmapBufferObject

GLS_CUDA_Runtime

cudaGLUnmapBufferObjectAsync

GLS_CUDA_Runtime

cudaGLUnregisterBufferObject

GLS_CUDA_Runtime

cudaGraphicsGLRegisterBuffer

GLS_CUDA_Runtime

cudaGraphicsGLRegisterImage

GLS_CUDA_Runtime

cudaGraphicsMapResources

GLS_CUDA_Runtime

cudaGraphicsResourceGetMappedPointer

GLS_CUDA_Runtime

cudaGraphicsResourceSetMapFlags

GLS_CUDA_Runtime

cudaGraphicsSubResourceGetMappedArray

GLS_CUDA_Runtime

cudaGraphicsUnmapResources

GLS_CUDA_Runtime

cudaGraphicsUnregisterResource

GLS_CUDA_Runtime

cudaHostAlloc

GLS_CUDA_Runtime

cudaHostGetDevicePointer

GLS_CUDA_Runtime

cudaHostGetFlags

GLS_CUDA_Runtime

cudaLaunch

GLS_CUDA_Runtime

cudaMalloc

GLS_CUDA_Runtime

cudaMalloc3D

GLS_CUDA_Runtime

cudaMalloc3DArray

GLS_CUDA_Runtime

cudaMallocArray

GLS_CUDA_Runtime

cudaMallocHost

GLS_CUDA_Runtime

cudaMallocPitch

GLS_CUDA_Runtime

cudaMemcpy

GLS_CUDA_Runtime

cudaMemcpy2D

GLS_CUDA_Runtime

cudaMemcpy2DArrayToArray

GLS_CUDA_Runtime

cudaMemcpy2DAsync

GLS_CUDA_Runtime

cudaMemcpy2DFromArray

GLS_CUDA_Runtime

cudaMemcpy2DFromArrayAsync

GLS_CUDA_Runtime

cudaMemcpy2DToArray

GLS_CUDA_Runtime

cudaMemcpy2DToArrayAsync

GLS_CUDA_Runtime

cudaMemcpy3D

GLS_CUDA_Runtime

cudaMemcpy3DAsync

GLS_CUDA_Runtime

cudaMemcpyArrayToArray

GLS_CUDA_Runtime

cudaMemcpyAsync

GLS_CUDA_Runtime

cudaMemcpyFromArray

GLS_CUDA_Runtime

cudaMemcpyFromArrayAsync

GLS_CUDA_Runtime

cudaMemcpyFromSymbol

GLS_CUDA_Runtime

cudaMemcpyFromSymbolAsync

GLS_CUDA_Runtime

cudaMemcpyToArray

GLS_CUDA_Runtime

cudaMemcpyToArrayAsync

GLS_CUDA_Runtime

cudaMemcpyToSymbol

GLS_CUDA_Runtime

cudaMemcpyToSymbolAsync

GLS_CUDA_Runtime

cudaMemGetInfo

GLS_CUDA_Runtime

cudaMemset

GLS_CUDA_Runtime

cudaMemset2D

GLS_CUDA_Runtime

cudaMemset3D

GLS_CUDA_Runtime

CUDARTDLLNAMES

GLS_CUDA_Runtime

CUDART_2_OVER_PI

GLS_CUDA_Runtime

CUDART_2_OVER_PI_F

GLS_CUDA_Runtime

CUDART_3PIO4

GLS_CUDA_Runtime

CUDART_3PIO4_F

GLS_CUDA_Runtime

CUDART_INF

GLS_CUDA_Runtime

CUDART_INF_F

GLS_CUDA_Runtime

CUDART_L2E

GLS_CUDA_Runtime

CUDART_L2E_F

GLS_CUDA_Runtime

CUDART_L2E_HI

GLS_CUDA_Runtime

CUDART_L2E_LO

GLS_CUDA_Runtime

CUDART_L2T

GLS_CUDA_Runtime

CUDART_L2T_F

GLS_CUDA_Runtime

CUDART_LG2

GLS_CUDA_Runtime

CUDART_LG2_F

GLS_CUDA_Runtime

CUDART_LG2_HI

GLS_CUDA_Runtime

CUDART_LG2_LO

GLS_CUDA_Runtime

CUDART_LG2_X_1024

GLS_CUDA_Runtime

CUDART_LG2_X_1075

GLS_CUDA_Runtime

CUDART_LGE

GLS_CUDA_Runtime

CUDART_LGE_F

GLS_CUDA_Runtime

CUDART_LGE_HI

GLS_CUDA_Runtime

CUDART_LGE_LO

GLS_CUDA_Runtime

CUDART_LN2

GLS_CUDA_Runtime

CUDART_LN2_F

GLS_CUDA_Runtime

CUDART_LN2_HI

GLS_CUDA_Runtime

CUDART_LN2_LO

GLS_CUDA_Runtime

CUDART_LN2_X_1024

GLS_CUDA_Runtime

CUDART_LN2_X_1025

GLS_CUDA_Runtime

CUDART_LN2_X_1075

GLS_CUDA_Runtime

CUDART_LNPI

GLS_CUDA_Runtime

CUDART_LNPI_F

GLS_CUDA_Runtime

CUDART_LNT

GLS_CUDA_Runtime

CUDART_LNT_F

GLS_CUDA_Runtime

CUDART_LNT_HI

GLS_CUDA_Runtime

CUDART_LNT_LO

GLS_CUDA_Runtime

CUDART_MAX_NORMAL_F

GLS_CUDA_Runtime

CUDART_MIN_DENORM

GLS_CUDA_Runtime

CUDART_MIN_DENORM_F

GLS_CUDA_Runtime

CUDART_NAN

GLS_CUDA_Runtime

CUDART_NAN_F

GLS_CUDA_Runtime

CUDART_NEG_ZERO

GLS_CUDA_Runtime

CUDART_NEG_ZERO_F

GLS_CUDA_Runtime

CUDART_NORM_HUGE_F

GLS_CUDA_Runtime

CUDART_ONE

GLS_CUDA_Runtime

CUDART_ONE_F

GLS_CUDA_Runtime

CUDART_PI

GLS_CUDA_Runtime

CUDART_PIO2

GLS_CUDA_Runtime

CUDART_PIO2_F

GLS_CUDA_Runtime

CUDART_PIO2_HI

GLS_CUDA_Runtime

CUDART_PIO2_LO

GLS_CUDA_Runtime

CUDART_PIO4

GLS_CUDA_Runtime

CUDART_PIO4_F

GLS_CUDA_Runtime

CUDART_PIO4_HI

GLS_CUDA_Runtime

CUDART_PIO4_LO

GLS_CUDA_Runtime

CUDART_PI_F

GLS_CUDA_Runtime

CUDART_PI_HI

GLS_CUDA_Runtime

CUDART_PI_LO

GLS_CUDA_Runtime

CUDART_REMQUO_BITS_F

GLS_CUDA_Runtime

CUDART_REMQUO_MASK_F

GLS_CUDA_Runtime

CUDART_SQRT_2PI_HI

GLS_CUDA_Runtime

CUDART_SQRT_2PI_LO

GLS_CUDA_Runtime

CUDART_SQRT_HALF

GLS_CUDA_Runtime

CUDART_SQRT_HALF_F

GLS_CUDA_Runtime

CUDART_SQRT_PIO2_HI

GLS_CUDA_Runtime

CUDART_SQRT_PIO2_LO

GLS_CUDA_Runtime

CUDART_SQRT_TWO

GLS_CUDA_Runtime

CUDART_SQRT_TWO_F

GLS_CUDA_Runtime

CUDART_THIRD

GLS_CUDA_Runtime

CUDART_THIRD_F

GLS_CUDA_Runtime

CUDART_TRIG_PLOSS

GLS_CUDA_Runtime

CUDART_TRIG_PLOSS_F

GLS_CUDA_Runtime

CUDART_TWOTHIRD

GLS_CUDA_Runtime

CUDART_TWO_TO_126_F

GLS_CUDA_Runtime

CUDART_TWO_TO_23

GLS_CUDA_Runtime

CUDART_TWO_TO_23_F

GLS_CUDA_Runtime

CUDART_TWO_TO_24_F

GLS_CUDA_Runtime

CUDART_TWO_TO_31_F

GLS_CUDA_Runtime

CUDART_TWO_TO_32_F

GLS_CUDA_Runtime

CUDART_TWO_TO_52

GLS_CUDA_Runtime

CUDART_TWO_TO_54

GLS_CUDA_Runtime

CUDART_TWO_TO_M1022

GLS_CUDA_Runtime

CUDART_TWO_TO_M126_F

GLS_CUDA_Runtime

CUDART_TWO_TO_M54

GLS_CUDA_Runtime

CUDART_ZERO

GLS_CUDA_Runtime

CUDART_ZERO_F

GLS_CUDA_Runtime

cudaRuntimeGetVersion

GLS_CUDA_Runtime

cudaSetDevice

GLS_CUDA_Runtime

cudaSetDeviceFlags

GLS_CUDA_Runtime

cudaSetDoubleForDevice

GLS_CUDA_Runtime

cudaSetDoubleForHost

GLS_CUDA_Runtime

cudaSetupArgument

GLS_CUDA_Runtime

cudaSetValidDevices

GLS_CUDA_Runtime

cudasFailMap

GLSCUDA

cudasFailUnmap

GLSCUDA

cudasFuncNotConnected

GLSCUDA

cudasInvalidParamType

GLSCUDA

cudasInvalidValue

GLSCUDA

cudasLaunchFailed

GLSCUDA

cudasModuleAbsent

GLSCUDA

cudasOnlyHostData

GLSCUDA

cudasOutOfRange

GLSCUDA

cudaStreamCreate

GLS_CUDA_Runtime

cudaStreamDestroy

GLS_CUDA_Runtime

cudaStreamQuery

GLS_CUDA_Runtime

cudaStreamSynchronize

GLS_CUDA_Runtime

cudaStream_t

GLS_CUDA_Runtime

cudasWrongParamSetup

GLSCUDA

cudaThreadExit

GLS_CUDA_Runtime

cudaThreadGetLimit

GLS_CUDA_Runtime

cudaThreadSetLimit

GLS_CUDA_Runtime

cudaThreadSynchronize

GLS_CUDA_Runtime

cudaUnbindTexture

GLS_CUDA_Runtime

cudaWGLGetDevice

GLS_CUDA_Runtime

CUDA_ERROR_ALREADY_ACQUIRED

GLS_CUDA_API

CUDA_ERROR_ALREADY_MAPPED

GLS_CUDA_API

CUDA_ERROR_ARRAY_IS_MAPPED

GLS_CUDA_API

CUDA_ERROR_CONTEXT_ALREADY_CURRENT

GLS_CUDA_API

CUDA_ERROR_DEINITIALIZED

GLS_CUDA_API

CUDA_ERROR_FILE_NOT_FOUND

GLS_CUDA_API

CUDA_ERROR_INVALID_CONTEXT

GLS_CUDA_API

CUDA_ERROR_INVALID_DEVICE

GLS_CUDA_API

CUDA_ERROR_INVALID_HANDLE

GLS_CUDA_API

CUDA_ERROR_INVALID_IMAGE

GLS_CUDA_API

CUDA_ERROR_INVALID_SOURCE

GLS_CUDA_API

CUDA_ERROR_INVALID_VALUE

GLS_CUDA_API

CUDA_ERROR_LAUNCH_FAILED

GLS_CUDA_API

CUDA_ERROR_LAUNCH_INCOMPATIBLE_TEXTURING

GLS_CUDA_API

CUDA_ERROR_LAUNCH_OUT_OF_RESOURCES

GLS_CUDA_API

CUDA_ERROR_LAUNCH_TIMEOUT

GLS_CUDA_API

CUDA_ERROR_MAP_FAILED

GLS_CUDA_API

CUDA_ERROR_NOT_FOUND

GLS_CUDA_API

CUDA_ERROR_NOT_INITIALIZED

GLS_CUDA_API

CUDA_ERROR_NOT_MAPPED

GLS_CUDA_API

CUDA_ERROR_NOT_MAPPED_AS_ARRAY

GLS_CUDA_API

CUDA_ERROR_NOT_MAPPED_AS_POINTER

GLS_CUDA_API

CUDA_ERROR_NOT_READY

GLS_CUDA_API

CUDA_ERROR_NO_BINARY_FOR_GPU

GLS_CUDA_API

CUDA_ERROR_NO_DEVICE

GLS_CUDA_API

CUDA_ERROR_OUT_OF_MEMORY

GLS_CUDA_API

CUDA_ERROR_POINTER_IS_64BIT

GLS_CUDA_API

CUDA_ERROR_SIZE_IS_64BIT

GLS_CUDA_API

CUDA_ERROR_UNKNOWN

GLS_CUDA_API

CUDA_ERROR_UNMAP_FAILED

GLS_CUDA_API

CUDA_SUCCESS

GLS_CUDA_API

cuDeviceComputeCapability

GLS_CUDA_API

cuDeviceGet

GLS_CUDA_API

cuDeviceGetAttribute

GLS_CUDA_API

cuDeviceGetCount

GLS_CUDA_API

cuDeviceGetName

GLS_CUDA_API

cuDeviceGetProperties

GLS_CUDA_API

cuDeviceTotalMem

GLS_CUDA_API

cudppCompact

GLS_CUDA_ParallelPrimitives

cudppDestroyPlan

GLS_CUDA_ParallelPrimitives

cudppDestroySparseMatrix

GLS_CUDA_ParallelPrimitives

CUDPPDLL

GLS_CUDA_ParallelPrimitives

cudppMultiScan

GLS_CUDA_ParallelPrimitives

cudppPlan

GLS_CUDA_ParallelPrimitives

cudppRand

GLS_CUDA_ParallelPrimitives

cudppRandSeed

GLS_CUDA_ParallelPrimitives

cudppScan

GLS_CUDA_ParallelPrimitives

cudppSegmentedScan

GLS_CUDA_ParallelPrimitives

cudppSort

GLS_CUDA_ParallelPrimitives

cudppSparseMatrix

GLS_CUDA_ParallelPrimitives

cudppSparseMatrixVectorMultiply

GLS_CUDA_ParallelPrimitives

CUDPP_INVALID_HANDLE

GLS_CUDA_ParallelPrimitives

cuDriverGetVersion

GLS_CUDA_API

cuEventCreate

GLS_CUDA_API

cuEventDestroy

GLS_CUDA_API

cuEventElapsedTime

GLS_CUDA_API

cuEventQuery

GLS_CUDA_API

cuEventRecord

GLS_CUDA_API

cuEventSynchronize

GLS_CUDA_API

cufftDestroy

GLS_CUDA_FourierTransform

CUFFTDLLNAMES

GLS_CUDA_FourierTransform

cufftExecC2C

GLS_CUDA_FourierTransform

cufftExecC2R

GLS_CUDA_FourierTransform

cufftExecD2Z

GLS_CUDA_FourierTransform

cufftExecR2C

GLS_CUDA_FourierTransform

cufftExecZ2D

GLS_CUDA_FourierTransform

cufftExecZ2Z

GLS_CUDA_FourierTransform

cufftPlan1d

GLS_CUDA_FourierTransform

cufftPlan2d

GLS_CUDA_FourierTransform

cufftPlan3d

GLS_CUDA_FourierTransform

cufftPlanMany

GLS_CUDA_FourierTransform

cufftSetCompatibilityMode

GLS_CUDA_FourierTransform

cufftSetStream

GLS_CUDA_FourierTransform

CUFFT_ALLOC_FAILED

GLS_CUDA_FourierTransform

CUFFT_C2C

GLS_CUDA_FourierTransform

CUFFT_C2R

GLS_CUDA_FourierTransform

CUFFT_COMPATIBILITY_FFTW

GLS_CUDA_FourierTransform

CUFFT_COMPATIBILITY_FFTW_C2R_ASYMMETRIC

GLS_CUDA_FourierTransform

CUFFT_COMPATIBILITY_FFTW_PADDING

GLS_CUDA_FourierTransform

CUFFT_COMPATIBILITY_NORMAL

GLS_CUDA_FourierTransform

CUFFT_D2Z

GLS_CUDA_FourierTransform

CUFFT_EXEC_FAILED

GLS_CUDA_FourierTransform

CUFFT_FORWARD

GLS_CUDA_FourierTransform

CUFFT_INTERNAL_ERROR

GLS_CUDA_FourierTransform

CUFFT_INVALID_PLAN

GLS_CUDA_FourierTransform

CUFFT_INVALID_SIZE

GLS_CUDA_FourierTransform

CUFFT_INVALID_TYPE

GLS_CUDA_FourierTransform

CUFFT_INVALID_VALUE

GLS_CUDA_FourierTransform

CUFFT_INVERSE

GLS_CUDA_FourierTransform

CUFFT_R2C

GLS_CUDA_FourierTransform

CUFFT_SETUP_FAILED

GLS_CUDA_FourierTransform

CUFFT_SUCCESS

GLS_CUDA_FourierTransform

CUFFT_Z2D

GLS_CUDA_FourierTransform

CUFFT_Z2Z

GLS_CUDA_FourierTransform

cuFuncGetAttribute

GLS_CUDA_API

cuFuncSetBlockShape

GLS_CUDA_API

cuFuncSetSharedSize

GLS_CUDA_API

cuGLCtxCreate

GLS_CUDA_API

cuGLInit

GLS_CUDA_API

cuGLMapBufferObject

GLS_CUDA_API

cuGLMapBufferObjectAsync

GLS_CUDA_API

cuGLRegisterBufferObject

GLS_CUDA_API

cuGLSetBufferObjectMapFlags

GLS_CUDA_API

cuGLUnmapBufferObject

GLS_CUDA_API

cuGLUnmapBufferObjectAsync

GLS_CUDA_API

cuGLUnregisterBufferObject

GLS_CUDA_API

cuGraphicsGLRegisterBuffer

GLS_CUDA_API

cuGraphicsGLRegisterImage

GLS_CUDA_API

cuGraphicsMapResources

GLS_CUDA_API

cuGraphicsResourceGetMappedPointer

GLS_CUDA_API

cuGraphicsResourceSetMapFlags

GLS_CUDA_API

cuGraphicsSubResourceGetMappedArray

GLS_CUDA_API

cuGraphicsUnmapResources

GLS_CUDA_API

cuGraphicsUnregisterResource

GLS_CUDA_API

cuInit

GLS_CUDA_API

cuLaunch

GLS_CUDA_API

cuLaunchGrid

GLS_CUDA_API

cuLaunchGridAsync

GLS_CUDA_API

cuMemAlloc

GLS_CUDA_API

cuMemAllocHost

GLS_CUDA_API

cuMemAllocPitch

GLS_CUDA_API

cuMemcpy2D

GLS_CUDA_API

cuMemcpy2DAsync

GLS_CUDA_API

cuMemcpy2DUnaligned

GLS_CUDA_API

cuMemcpy3D

GLS_CUDA_API

cuMemcpy3DAsync

GLS_CUDA_API

cuMemcpyAtoA

GLS_CUDA_API

cuMemcpyAtoD

GLS_CUDA_API

cuMemcpyAtoH

GLS_CUDA_API

cuMemcpyAtoHAsync

GLS_CUDA_API

cuMemcpyDtoA

GLS_CUDA_API

cuMemcpyDtoD

GLS_CUDA_API

cuMemcpyDtoDAsync

GLS_CUDA_API

cuMemcpyDtoH

GLS_CUDA_API

cuMemcpyDtoHAsync

GLS_CUDA_API

cuMemcpyHtoA

GLS_CUDA_API

cuMemcpyHtoAAsync

GLS_CUDA_API

cuMemcpyHtoD

GLS_CUDA_API

cuMemcpyHtoDAsync

GLS_CUDA_API

cuMemFree

GLS_CUDA_API

cuMemFreeHost

GLS_CUDA_API

cuMemGetAddressRange

GLS_CUDA_API

cuMemGetInfo

GLS_CUDA_API

cuMemHostAlloc

GLS_CUDA_API

cuMemHostGetDevicePointer

GLS_CUDA_API

cuMemHostGetFlags

GLS_CUDA_API

cuMemsetD16

GLS_CUDA_API

cuMemsetD2D16

GLS_CUDA_API

cuMemsetD2D32

GLS_CUDA_API

cuMemsetD2D8

GLS_CUDA_API

cuMemsetD32

GLS_CUDA_API

cuMemsetD8

GLS_CUDA_API

cuModuleGetFunction

GLS_CUDA_API

cuModuleGetGlobal

GLS_CUDA_API

cuModuleGetTexRef

GLS_CUDA_API

cuModuleLoad

GLS_CUDA_API

cuModuleLoadData

GLS_CUDA_API

cuModuleLoadDataEx

GLS_CUDA_API

cuModuleLoadFatBinary

GLS_CUDA_API

cuModuleUnload

GLS_CUDA_API

cUnableToCreateLegacyContext

GLContext

cUnknownArchiveVersion

XCollection

cuParamSetf

GLS_CUDA_API

cuParamSeti

GLS_CUDA_API

cuParamSetSize

GLS_CUDA_API

cuParamSetTexRef

GLS_CUDA_API

cuParamSetv

GLS_CUDA_API

CurrentGLContext

GLContext

The TGLContext that is the currently active context, if any.<p> Returns nil if no context is active.

CURV_CONTINUITY_FIRST

LWObjects

CURV_CONTINUITY_LAST

LWObjects

CustomCreateBlankJoint

NewtonImport_JointLibrary

CustomDestroyJoint

NewtonImport_JointLibrary

CustomGetBodiesCollisionState

NewtonImport_JointLibrary

CustomGetBody0

NewtonImport_JointLibrary

CustomGetBody1

NewtonImport_JointLibrary

CustomGetJointID

NewtonImport_JointLibrary

CustomGetNewtonJoint

NewtonImport_JointLibrary

CustomGetUserData

NewtonImport_JointLibrary

CustomJoint6DOF_GetAngularLimits

NewtonImport_JointLibrary

CustomJoint6DOF_GetLinearLimits

NewtonImport_JointLibrary

CustomJoint6DOF_SetAngularLimits

NewtonImport_JointLibrary

CustomJoint6DOF_SetLinearLimits

NewtonImport_JointLibrary

CustomJoint6DOF_SetReverseUniversal

NewtonImport_JointLibrary

CustomKinematicControllerGetTargetMatrix

NewtonImport_JointLibrary

CustomKinematicControllerSetMaxAngularFriction

NewtonImport_JointLibrary

CustomKinematicControllerSetMaxLinearFriction

NewtonImport_JointLibrary

CustomKinematicControllerSetPickMode

NewtonImport_JointLibrary

CustomKinematicControllerSetTargetMatrix

NewtonImport_JointLibrary

CustomKinematicControllerSetTargetPosit

NewtonImport_JointLibrary

CustomKinematicControllerSetTargetRotation

NewtonImport_JointLibrary

CustomPlayerControllerGetMaxSlope

NewtonImport_JointLibrary

CustomPlayerControllerGetSensorShape

NewtonImport_JointLibrary

CustomPlayerControllerGetVisualMaTrix

NewtonImport_JointLibrary

CustomPlayerControllerSetMaxSlope

NewtonImport_JointLibrary

CustomPlayerControllerSetVelocity

NewtonImport_JointLibrary

CustomSetBodiesCollisionState

NewtonImport_JointLibrary

CustomSetDestructorCallback

NewtonImport_JointLibrary

CustomSetJointID

NewtonImport_JointLibrary

CustomSetSubmitContraintCallback

NewtonImport_JointLibrary

CustomSetUserData

NewtonImport_JointLibrary

cuStreamCreate

GLS_CUDA_API

cuStreamDestroy

GLS_CUDA_API

cuStreamQuery

GLS_CUDA_API

cuStreamSynchronize

GLS_CUDA_API

cutComparef

GLS_CUDA_Utility

cutComparefe

GLS_CUDA_Utility

cutComparefet

GLS_CUDA_Utility

cutComparei

GLS_CUDA_Utility

cutCompareL2fe

GLS_CUDA_Utility

cutCompareub

GLS_CUDA_Utility

cutCompareube

GLS_CUDA_Utility

cutCompareubt

GLS_CUDA_Utility

cutCompareuit

GLS_CUDA_Utility

cutCreateTimer

GLS_CUDA_Utility

cutDeleteTimer

GLS_CUDA_Utility

cuTexRefCreate

GLS_CUDA_API

cuTexRefDestroy

GLS_CUDA_API

cuTexRefGetAddress

GLS_CUDA_API

cuTexRefGetAddressMode

GLS_CUDA_API

cuTexRefGetArray

GLS_CUDA_API

cuTexRefGetFilterMode

GLS_CUDA_API

cuTexRefGetFlags

GLS_CUDA_API

cuTexRefGetFormat

GLS_CUDA_API

cuTexRefSetAddress

GLS_CUDA_API

cuTexRefSetAddress2D

GLS_CUDA_API

cuTexRefSetAddressMode

GLS_CUDA_API

cuTexRefSetArray

GLS_CUDA_API

cuTexRefSetFilterMode

GLS_CUDA_API

cuTexRefSetFlags

GLS_CUDA_API

cuTexRefSetFormat

GLS_CUDA_API

cutFindFilePath

GLS_CUDA_Utility

cutFree

GLS_CUDA_Utility

cutGetAverageTimerValue

GLS_CUDA_Utility

cutGetTimerValue

GLS_CUDA_Utility

CUTILDLL

GLS_CUDA_Utility

cutLoadPGMf

GLS_CUDA_Utility

cutLoadPGMi

GLS_CUDA_Utility

cutLoadPGMs

GLS_CUDA_Utility

cutLoadPGMub

GLS_CUDA_Utility

cutLoadPPM4ub

GLS_CUDA_Utility

cutLoadPPMub

GLS_CUDA_Utility

cutResetTimer

GLS_CUDA_Utility

cutSavePGMf

GLS_CUDA_Utility

cutSavePGMi

GLS_CUDA_Utility

cutSavePGMs

GLS_CUDA_Utility

cutSavePGMub

GLS_CUDA_Utility

cutSavePPM4ub

GLS_CUDA_Utility

cutSavePPMub

GLS_CUDA_Utility

cutStartTimer

GLS_CUDA_Utility

cutStopTimer

GLS_CUDA_Utility

cuWGLGetDevice

GLS_CUDA_API

CU_MEMHOSTALLOC_DEVICEMAP

GLS_CUDA_API

CU_MEMHOSTALLOC_PORTABLE

GLS_CUDA_API

CU_MEMHOSTALLOC_WRITECOMBINED

GLS_CUDA_API

CU_PARAM_TR_DEFAULT

GLS_CUDA_API

CU_TRSA_OVERRIDE_FORMAT

GLS_CUDA_API

CU_TRSF_NORMALIZED_COORDINATES

GLS_CUDA_API

CU_TRSF_READ_AS_INTEGER

GLS_CUDA_API

cVertexModeToGLEnum

GLMesh

Cylindrical_Cartesian

GeometryCoordinates

Convert cylindrical to cartesian [double]. theta in rads

Cylindrical_Cartesian

GeometryCoordinates

Convert cylindrical to cartesian [single] (with error check). theta in rad

Cylindrical_Cartesian

GeometryCoordinates

Convert cylindrical to cartesian [single]. theta in rad

Cylindrical_Cartesian

GeometryCoordinates

Convert cylindrical to cartesian [double] (with error check). theta in rad

C_ALL_LINES

Const3DS

C_ALPHA_SPLIT

Const3DS

C_ANG_THRESH

Const3DS

C_ANIMLENGTH

Const3DS

C_APPLY_DISP_GAMMA

Const3DS

C_APPLY_FBUF_GAMMA

Const3DS

C_APPLY_FILE_GAMMA

Const3DS

C_ARCH_DENOM

Const3DS

C_ASNAPS

Const3DS

C_AUTO_REFLECT

Const3DS

C_AUTO_SMOOTH

Const3DS

C_AUTO_UNIFY

Const3DS

C_AUTO_WELD

Const3DS

C_BACKUP_FILE

Const3DS

C_BACK_TYPE

Const3DS

C_BGND_METHOD

Const3DS

C_BGND_PRES_RATIO

Const3DS

C_BGTYPE

Const3DS

C_BIAS_DEFAULT

Const3DS

C_BITMAP_DRAWER

Const3DS

C_BLUR_DUR

Const3DS

C_BLUR_FRAMES

Const3DS

C_BLUR_SAMPLES

Const3DS

C_BOOLTYPE

Const3DS

C_BOOLWELD

Const3DS

C_CAMNAME

Const3DS

C_COMM_PORT

Const3DS

C_CONESEGS

Const3DS

C_CONESIDES

Const3DS

C_CONSTS

Const3DS

C_CONT_DEFAULT

Const3DS

C_CUBDRAWER

Const3DS

C_CURMTL_FROM_MESH

Const3DS

C_CURTIME

Const3DS

C_CUR_MNAME

Const3DS

C_DETAIL

Const3DS

C_DISP_GAMMA

Const3DS

C_DITHER_24

Const3DS

C_DITHER_256

Const3DS

C_DXFNAME_SRC

Const3DS

C_DXF_SMOOTH_ANG

Const3DS

C_EDITOR_OK

Const3DS

C_ETAPE

Const3DS

C_FBUF_GAMMA

Const3DS

C_FILE_IN_GAMMA

Const3DS

C_FILE_OUT_GAMMA

Const3DS

C_FLIDRAWER

Const3DS

C_FLIFILE

Const3DS

C_FONTSEL

Const3DS

C_FORCE_WIRE

Const3DS

C_FROZ_DISPLAY

Const3DS

C_GAMMA_CORRECT

Const3DS

C_GEOSMOOTH

Const3DS

C_GET_SHAPE_MAKE_FACES

Const3DS

C_GRIDS

Const3DS

C_GRID_RANGE

Const3DS

C_HEBOT

Const3DS

C_HEDEG

Const3DS

C_HEDIR

Const3DS

C_HEHT

Const3DS

C_HEMISEGS

Const3DS

C_HESEG

Const3DS

C_HETOP

Const3DS

C_HETURNS

Const3DS

C_HI_CONTRAST

Const3DS

C_HOT_CHECK

Const3DS

C_HOT_METHOD

Const3DS

C_IN_DEVICE

Const3DS

C_JPEG_COMPRESSION

Const3DS

C_KEYFRAMER_OK

Const3DS

C_KF_SHOW_BACKFACE

Const3DS

C_KTAPE

Const3DS

C_LMTS_ID

GLFileLMTS

C_LMTS_SUBS

GLFileLMTS

C_LMTS_TEXFNLEN

GLFileLMTS

C_LMTS_TEXT

GLFileLMTS

C_LMTS_TRIS

GLFileLMTS

C_LMTS_VER

GLFileLMTS

C_LOFTER_OK

Const3DS

C_LOFT_L_REPEAT

Const3DS

C_LOFT_UV_NORMALIZE

Const3DS

C_LOFT_WITH_TEXTURE

Const3DS

C_LOFT_W_REPEAT

Const3DS

C_LO_CONTRAST

Const3DS

C_LTAPE

Const3DS

C_LTNAME

Const3DS

C_MAPDRAWER

Const3DS

C_MAPDRAWER1

Const3DS

C_MAPDRAWER2

Const3DS

C_MAPDRAWER3

Const3DS

C_MAPDRAWER4

Const3DS

C_MAPDRAWER5

Const3DS

C_MAPDRAWER6

Const3DS

C_MAPDRAWER7

Const3DS

C_MAPDRAWER8

Const3DS

C_MAPDRAWER9

Const3DS

C_MAPDRAWER_ENTRY

Const3DS

C_MAPTYPE

Const3DS

C_MAP_DISPLAY

Const3DS

C_MAP_MATRIX

Const3DS

C_MAP_MATRIX_OLD

Const3DS

C_MAP_SCALE

Const3DS

C_MAP_WID_HT

Const3DS

C_MAP_XYZ

Const3DS

C_MASTER_AMBIENT

Const3DS

C_MASTER_SCALES

Const3DS

C_MAX_BLOCKS_IN_MCU

GLSJPG

C_MBLUR_DITHER

Const3DS

C_MDRAWER

Const3DS

C_MD_CE

Const3DS

C_MD_CS

Const3DS

C_MD_PDET

Const3DS

C_MD_SDET

Const3DS

C_MD_SML

Const3DS

C_MD_SMW

Const3DS

C_MEDTILE

Const3DS

C_MESHSEL

Const3DS

C_MESHUNSEL

Const3DS

C_MFILE

Const3DS

C_MFTSYM

Const3DS

C_MODDRAWER

Const3DS

C_MODFILE

Const3DS

C_MODICOUNT

Const3DS

C_MODMODEL

Const3DS

C_MODWMODE

Const3DS

C_MSCALE

Const3DS

C_MSCSYM

Const3DS

C_MSHAX

Const3DS

C_MSHCP

Const3DS

C_MSHLOCAL

Const3DS

C_MTLDRAWER

Const3DS

C_MTLFILE

Const3DS

C_MTTSYM

Const3DS

C_NET_FIELD_ORDER

Const3DS

C_NET_USE_GAMMA

Const3DS

C_NET_USE_VPOST

Const3DS

C_NGPARMS

Const3DS

C_NTH_SERIAL_NUM

Const3DS

C_NUM_FORMAT

Const3DS

C_OBJECT_MBLUR

Const3DS

C_OBNAME

Const3DS

C_OPTIMIZE_LOFT

Const3DS

C_PALFILE

Const3DS

C_PAL_TYPE

Const3DS

C_PDRAWER

Const3DS

C_PFILE

Const3DS

C_PICKSIZE

Const3DS

C_PIXEL_SIZE

Const3DS

C_POLYSEL

Const3DS

C_POLYUNSEL

Const3DS

C_PREVMODE

Const3DS

C_PRISMSEGS

Const3DS

C_PRISMSIDES

Const3DS

C_PROGMODE

Const3DS

C_PTHLEVEL

Const3DS

C_PV_DOFNUM

Const3DS

C_PV_FPS

Const3DS

C_PV_FROM

Const3DS

C_PV_METHOD

Const3DS

C_PV_NTH

Const3DS

C_PV_RNG

Const3DS

C_PV_TO

Const3DS

C_PV_TYPE

Const3DS

C_QUIKSTUFF

Const3DS

C_RAX

Const3DS

C_RAY_SHADOWS

Const3DS

C_REFLIP

Const3DS

C_RENDER_ALL

Const3DS

C_RENDTYPE

Const3DS

C_REND_FIELDS

Const3DS

C_REND_FROM

Const3DS

C_REND_NTH

Const3DS

C_REND_TO

Const3DS

C_REND_TSTEP

Const3DS

C_RGB_AA

Const3DS

C_RGB_ANIMTYPE

Const3DS

C_RGB_COMPRESS

Const3DS

C_RGB_DISPDEV

Const3DS

C_RGB_FILE

Const3DS

C_RGB_HARDDEV

Const3DS

C_RGB_HIDE

Const3DS

C_RGB_MAPSW

Const3DS

C_RGB_OUTPUT

Const3DS

C_RGB_OVASPECT

Const3DS

C_RGB_OVH

Const3DS

C_RGB_OVW

Const3DS

C_RGB_PATH

Const3DS

C_RGB_PICTYPE

Const3DS

C_RGB_RMODE

Const3DS

C_RGB_SHADOW

Const3DS

C_RGB_TODISK

Const3DS

C_RGB_TWOSIDE

Const3DS

C_RIPDRAWER

Const3DS

C_RIPFILE

Const3DS

C_RND_MIP

Const3DS

C_RND_TURBO

Const3DS

C_SAFE_FRAME

Const3DS

C_SAVE_LAST

Const3DS

C_SEE_3D

Const3DS

C_SEE_CAMERAS

Const3DS

C_SEE_LIGHTS

Const3DS

C_SEG_END

Const3DS

C_SEG_START

Const3DS

C_SEL_ITEMTOG

Const3DS

C_SEL_RESET

Const3DS

C_SHAPER_OK

Const3DS

C_SHOOK

Const3DS

C_SHOW_1STVERT

Const3DS

C_SHPDRAWER

Const3DS

C_SHPFILE

Const3DS

C_SHPLOCAL

Const3DS

C_SMOOTHING

Const3DS

C_SMOOTH_ANG

Const3DS

C_SNAPS

Const3DS

C_SPHSEGS

Const3DS

C_SRDEG

Const3DS

C_SRDIAM

Const3DS

C_SRDIR

Const3DS

C_SRSEG

Const3DS

C_SS_THRESH

Const3DS

C_STAPE

Const3DS

C_STICKY_KEYINF

Const3DS

C_SUPER_BLACK

Const3DS

C_SUPER_SAMPLE

Const3DS

C_SXP_BUMP_DATA

Const3DS

C_SXP_BUMP_MASKDATA

Const3DS

C_SXP_OPAC_DATA

Const3DS

C_SXP_OPAC_MASKDATA

Const3DS

C_SXP_REFL_MASKDATA

Const3DS

C_SXP_SELFI_DATA

Const3DS

C_SXP_SELFI_MASKDATA

Const3DS

C_SXP_SHIN_DATA

Const3DS

C_SXP_SHIN_MASKDATA

Const3DS

C_SXP_SPEC_DATA

Const3DS

C_SXP_SPEC_MASKDATA

Const3DS

C_SXP_TEXT2_DATA

Const3DS

C_SXP_TEXT2_MASKDATA

Const3DS

C_SXP_TEXT_DATA

Const3DS

C_SXP_TEXT_MASKDATA

Const3DS

C_TAB_BASES

Const3DS

C_TAB_DIVS

Const3DS

C_TDRAWER

Const3DS

C_TENS_DEFAULT

Const3DS

C_TESS_TENSION

Const3DS

C_TESS_TYPE

Const3DS

C_TEXTURE_BLUR_DEFAULT

Const3DS

C_TGA_DEPTH

Const3DS

C_TILE_XY

Const3DS

C_TORSEGS

Const3DS

C_TORSIDES

Const3DS

C_TUBESEGS

Const3DS

C_TUBESIDES

Const3DS

C_TXDRAWER

Const3DS

C_TXFILE

Const3DS

C_TX_STRING

Const3DS

C_USERAX

Const3DS

C_USE_ALPHA

Const3DS

C_VERTMARK

Const3DS

C_VIEW_PRES_RATIO

Const3DS

C_VP_FROM

Const3DS

C_VP_NTH

Const3DS

C_VP_TO

Const3DS

C_VP_TSTEP

Const3DS

C_VTR_FRAMES

Const3DS

C_VTR_HD

Const3DS

C_VTR_HDTL

Const3DS

C_VTR_IN

Const3DS

C_VTR_PK

Const3DS

C_VTR_SH

Const3DS

C_VTR_TL

Const3DS

C_WELD_LOFT

Const3DS

C_WELD_THRESHOLD

Const3DS

C_WORKMTL

Const3DS

C_WORK_MTLS

Const3DS

C_WORK_MTLS_2

Const3DS

C_WORK_MTLS_3

Const3DS

C_WORK_MTLS_4

Const3DS

C_WORK_MTLS_5

Const3DS

C_WORK_MTLS_6

Const3DS

C_WORK_MTLS_7

Const3DS

C_WORK_MTLS_8

Const3DS

C_ZCLIP_POINT

Const3DS

D3D11_RESOURCE_DIMENSION_BUFFER

DXTC

D3D11_RESOURCE_DIMENSION_TEXTURE1D

DXTC

D3D11_RESOURCE_DIMENSION_TEXTURE2D

DXTC

D3D11_RESOURCE_DIMENSION_TEXTURE3D

DXTC

D3D11_RESOURCE_DIMENSION_UNKNOWN

DXTC

DAMP_SHIFT

GLProcTextures

dAreConnected

ODEImport

dAreConnectedExcluding

ODEImport

dBodyAddForce

ODEImport

dBodyAddForceAtPos

ODEImport

dBodyAddForceAtRelPos

ODEImport

dBodyAddRelForce

ODEImport

dBodyAddRelForceAtPos

ODEImport

dBodyAddRelForceAtRelPos

ODEImport

dBodyAddRelTorque

ODEImport

dBodyAddTorque

ODEImport

dBodyCopyPosition

ODEImport

dBodyCopyQuaternion

ODEImport

dBodyCopyRotation

ODEImport

dBodyCreate

ODEImport

dBodyDestroy

ODEImport

dBodyDisable

ODEImport

dBodyEnable

ODEImport

dBodyGetAngularDamping

ODEImport

dBodyGetAngularDampingThreshold

ODEImport

dBodyGetAngularVel

ODEImport

dBodyGetAutoDisableAngularThreshold

ODEImport

dBodyGetAutoDisableFlag

ODEImport

dBodyGetAutoDisableLinearThreshold

ODEImport

dBodyGetAutoDisableSteps

ODEImport

dBodyGetAutoDisableTime

ODEImport

dBodyGetData

ODEImport

dBodyGetFiniteRotationAxis

ODEImport

dBodyGetFiniteRotationMode

ODEImport

dBodyGetForce

ODEImport

dBodyGetGravityMode

ODEImport

dBodyGetJoint

ODEImport

dBodyGetLinearDamping

ODEImport

dBodyGetLinearDampingThreshold

ODEImport

dBodyGetLinearVel

ODEImport

dBodyGetMass

ODEImport

dBodyGetMaxAngularSpeed

ODEImport

dBodyGetNumJoints

ODEImport

dBodyGetPointVel

ODEImport

dBodyGetPosition

ODEImport

dBodyGetPosRelPoint

ODEImport

dBodyGetQuaternion

ODEImport

dBodyGetRelPointPos

ODEImport

dBodyGetRelPointVel

ODEImport

dBodyGetRotation

ODEImport

dBodyGetTorque

ODEImport

dBodyIsEnabled

ODEImport

dBodySetAngularDamping

ODEImport

dBodySetAngularDampingThreshold

ODEImport

dBodySetAngularVel

ODEImport

dBodySetAutoDisableAngularThreshold

ODEImport

dBodySetAutoDisableAverageSamplesCount

ODEImport

dBodySetAutoDisableDefaults

ODEImport

dBodySetAutoDisableFlag

ODEImport

dBodySetAutoDisableLinearThreshold

ODEImport

dBodySetAutoDisableSteps

ODEImport

dBodySetAutoDisableTime

ODEImport

dBodySetDamping

ODEImport

dBodySetDampingDefaults

ODEImport

dBodySetData

ODEImport

dBodySetFiniteRotationAxis

ODEImport

dBodySetFiniteRotationMode

ODEImport

dBodySetForce

ODEImport

dBodySetGravityMode

ODEImport

dBodySetLinearDamping

ODEImport

dBodySetLinearDampingThreshold

ODEImport

dBodySetLinearVel

ODEImport

dBodySetMass

ODEImport

dBodySetMaxAngularSpeed

ODEImport

dBodySetMovedCallback

ODEImport

dBodySetPosition

ODEImport

dBodySetQuaternion

ODEImport

dBodySetRotation

ODEImport

dBodySetTorque

ODEImport

dBodyToBodyDistance

ODEGL

dBodyVectorFromWorld

ODEImport

dBodyVectorToWorld

ODEImport

dBoxClass

ODEImport

dBoxTouchesBox

ODEImport

dCapsuleClass

ODEImport

DCEBox

GLDCEMisc

dClearUpperTriangle

ODEImport

dCloseODE

ODEImport

dClosestLineSegmentPoints

ODEImport

dCollide

ODEImport

dContactApprox0

ODEImport

dContactApprox1

ODEImport

dContactApprox1_1

ODEImport

dContactApprox1_2

ODEImport

dContactBounce

ODEImport

dContactFDir1

ODEImport

dContactMotion1

ODEImport

dContactMotion2

ODEImport

dContactMotionN

ODEImport

dContactMu2

ODEImport

dContactSlip1

ODEImport

dContactSlip2

ODEImport

dContactSoftCFM

ODEImport

dContactSoftERP

ODEImport

dConvexClass

ODEImport

dCreateBox

ODEImport

dCreateCapsule

ODEImport

dCreateConvex

ODEImport

dCreateCylinder

ODEImport

dCreateGeom

ODEImport

dCreateGeomClass

ODEImport

dCreateGeomTransform

ODEImport

dCreateHeightfield

ODEImport

dCreatePlane

ODEImport

dCreateRay

ODEImport

dCreateSphere

ODEImport

dCreateTriMesh

ODEImport

DCTSIZE

GLSJPG

DCTSIZE2

GLSJPG

DCUE_BGND

Const3DS

dCylinderClass

ODEImport

DDF_ANIMATE

GLSVfw

DDF_BACKGROUNDPAL

GLSVfw

DDF_BUFFER

GLSVfw

DDF_DONTDRAW

GLSVfw

DDF_FULLSCREEN

GLSVfw

DDF_HALFTONE

GLSVfw

DDF_HURRYUP

GLSVfw

DDF_JUSTDRAWIT

GLSVfw

DDF_NOTKEYFRAME

GLSVfw

DDF_PREROLL

GLSVfw

DDF_SAME_DIB

GLSVfw

DDF_SAME_DRAW

GLSVfw

DDF_SAME_HDC

GLSVfw

DDF_SAME_SIZE

GLSVfw

DDF_UPDATE

GLSVfw

dDot

ODEImport

dDot

ODEImport

dDOT14

ODEImport

dDOT14

ODEImport

DDPF_A

DXTC

DDPF_ALPHAPIXELS

DXTC

DDPF_FOURCC

DXTC

DDPF_L

DXTC

DDPF_LA

DXTC

DDPF_RGB

DXTC

DDPF_RGBA

DXTC

dDQfromW

ODEImport

DDSCAPS2_CUBEMAP

DXTC

DDSCAPS2_CUBEMAP_NEGATIVEX

DXTC

DDSCAPS2_CUBEMAP_NEGATIVEY

DXTC

DDSCAPS2_CUBEMAP_NEGATIVEZ

DXTC

DDSCAPS2_CUBEMAP_POSITIVEX

DXTC

DDSCAPS2_CUBEMAP_POSITIVEY

DXTC

DDSCAPS2_CUBEMAP_POSITIVEZ

DXTC

DDSCAPS2_VOLUME

DXTC

DDSCAPS_COMPLEX

DXTC

DDSCAPS_MIPMAP

DXTC

DDSCAPS_TEXTURE

DXTC

DDSD_CAPS

DXTC

DDSD_DEPTH

DXTC

DDSD_HEIGHT

DXTC

DDSD_LINEARSIZE

DXTC

DDSD_MIPMAPCOUNT

DXTC

DDSD_PITCH

DXTC

DDSD_PIXELFORMAT

DXTC

DDSD_WIDTH

DXTC

DDSHeaderToGLEnum

DXTC

debug_tri

GLEllipseCollision

DecodeDXT1toBitmap32

DXTC

DecodeDXT3toBitmap32

DXTC

DecodeDXT5toBitmap32

DXTC

DecodeGLTextureTarget

GLTextureFormat

DEFAULT_VIEW

Const3DS

DefFace3DS

Const3DS

DefKeyHeader3DS

Const3DS

DefKFRotKey3DS

Const3DS

deflate

GLSZLibExApi

deflateEnd

GLSZLibExApi

deflateInit

GLSZLibExApi

deflateInit2

GLSZLibExApi

deflateInit2_

GLSZLibExApi

deflateInit_

GLSZLibExApi

deflateReset

GLSZLibExApi

DefObjMat3DS

Const3DS

DEFORM_LIMIT

Const3DS

DefPoint3DS

Const3DS

DefTextVert3DS

Const3DS

DefTrackHeader3DS

Const3DS

DegToRad

VectorGeometry

DegToRad

VectorGeometry

DeleteChunk

Utils3DS

DeRegisterCUDAComponentNameChangeEvent

GLSCUDA

DeRegisterGLBaseSceneObjectNameChangeEvent

GLScene

Deregister an event handler triggered by any TGLBaseSceneObject Name change.<p> See RegisterGLBaseSceneObjectNameChangeEvent.

DeRegisterGLBehaviourNameChangeEvent

GLScene

Deregister an event handler triggered by any TGLBaseSceneObject Name change.<p> See RegisterGLBaseSceneObjectNameChangeEvent.

DeRegisterGLMaterialExNameChangeEvent

GLMaterialEx

DeRegisterManager

GLManager

DeRegisterXCollectionDestroyEvent

XCollection

DeRegisters event.

DerivatedPolynom

Polynomials

Calculates the polynom's derivative.

dFirstSpaceClass

ODEImport

dFirstUserClass

ODEImport

dGeomBoxGetLengths

ODEImport

dGeomBoxPointDepth

ODEImport

dGeomBoxSetLengths

ODEImport

dGeomCapsuleGetParams

ODEImport

dGeomCapsulePointDepth

ODEImport

dGeomCapsuleSetParams

ODEImport

dGeomClearOffset

ODEImport

dGeomCopyOffsetPosition

ODEImport

dGeomCopyOffsetRotation

ODEImport

dGeomCopyPosition

ODEImport

dGeomCopyQuaternion

ODEImport

dGeomCopyRotation

ODEImport

dGeomCylinderGetParams

ODEImport

dGeomCylinderSetParams

ODEImport

dGeomDestroy

ODEImport

dGeomDisable

ODEImport

dGeomEnable

ODEImport

dGeomGetAABB

ODEImport

dGeomGetBody

ODEImport

dGeomGetCategoryBits

ODEImport

dGeomGetClass

ODEImport

dGeomGetClassData

ODEImport

dGeomGetCollideBits

ODEImport

dGeomGetData

ODEImport

dGeomGetOffsetPosition

ODEImport

dGeomGetOffsetQuaternion

ODEImport

dGeomGetOffsetRotation

ODEImport

dGeomGetPosition

ODEImport

dGeomGetQuaternion

ODEImport

dGeomGetRotation

ODEImport

dGeomGetSpace

ODEImport

dGeomHeightfieldDataCreate

ODEImport

dGeomHeightfieldDataDestroy

ODEImport

dGeomHeightfieldDataSetBounds

ODEImport

dGeomHeightfieldGetHeightfieldData

ODEImport

dGeomHeightfieldSetHeightfieldData

ODEImport

dGeomIsEnabled

ODEImport

dGeomIsOffset

ODEImport

dGeomIsSpace

ODEImport

dGeomNumClasses

ODEImport

dGeomPlaneGetParams

ODEImport

dGeomPlanePointDepth

ODEImport

dGeomPlaneSetParams

ODEImport

dGeomRayGet

ODEImport

dGeomRayGetClosestHit

ODEImport

dGeomRayGetLength

ODEImport

dGeomRayGetParams

ODEImport

dGeomRaySet

ODEImport

dGeomRaySetClosestHit

ODEImport

dGeomRaySetLength

ODEImport

dGeomRaySetParams

ODEImport

dGeomSetBody

ODEImport

dGeomSetCategoryBits

ODEImport

dGeomSetCollideBits

ODEImport

dGeomSetConvex

ODEImport

dGeomSetData

ODEImport

dGeomSetOffsetPosition

ODEImport

dGeomSetOffsetQuaternion

ODEImport

dGeomSetOffsetRotation

ODEImport

dGeomSetOffsetWorldPosition

ODEImport

dGeomSetOffsetWorldQuaternion

ODEImport

dGeomSetOffsetWorldRotation

ODEImport

dGeomSetPosition

ODEImport

dGeomSetQuaternion

ODEImport

dGeomSetRotation

ODEImport

dGeomSphereGetRadius

ODEImport

dGeomSpherePointDepth

ODEImport

dGeomSphereSetRadius

ODEImport

dGeomTransformClass

ODEImport

dGeomTransformGetCleanup

ODEImport

dGeomTransformGetGeom

ODEImport

dGeomTransformGetInfo

ODEImport

dGeomTransformSetCleanup

ODEImport

dGeomTransformSetGeom

ODEImport

dGeomTransformSetInfo

ODEImport

dGeomTriMeshClearTCCache

ODEImport

dGeomTriMeshDataBuildDouble

ODEImport

dGeomTriMeshDataBuildDouble1

ODEImport

dGeomTriMeshDataBuildSimple

ODEImport

dGeomTriMeshDataBuildSimple1

ODEImport

dGeomTriMeshDataBuildSingle

ODEImport

dGeomTriMeshDataBuildSingle1

ODEImport

dGeomTriMeshDataCreate

ODEImport

dGeomTriMeshDataDestroy

ODEImport

dGeomTriMeshDataSet

ODEImport

dGeomTriMeshDataUpdate

ODEImport

dGeomTriMeshEnableTC

ODEImport

dGeomTriMeshGetArrayCallback

ODEImport

dGeomTriMeshGetCallback

ODEImport

dGeomTriMeshGetData

ODEImport

dGeomTriMeshGetPoint

ODEImport

dGeomTriMeshGetRayCallback

ODEImport

dGeomTriMeshGetTriangle

ODEImport

dGeomTriMeshGetTriangleCount

ODEImport

dGeomTriMeshGetTriMeshDataID

ODEImport

dGeomTriMeshIsTCEnabled

ODEImport

dGeomTriMeshSetArrayCallback

ODEImport

dGeomTriMeshSetCallback

ODEImport

dGeomTriMeshSetData

ODEImport

dGeomTriMeshSetRayCallback

ODEImport

DGRaycastVehicleAddTire

NewtonImport_JointLibrary

DGRaycastVehicleCreate

NewtonImport_JointLibrary

DGRaycastVehicleGetTireMatrix

NewtonImport_JointLibrary

DGRaycastVehicleGetTiresCount

NewtonImport_JointLibrary

DGRaycastVehicleGetTiresUserData

NewtonImport_JointLibrary

DGRaycastVehicleInitNormalizeTireLateralForce

NewtonImport_JointLibrary

DGRaycastVehicleInitNormalizeTireLongitudinalForce

NewtonImport_JointLibrary

DGRaycastVehicleSetTireTransformCallback

NewtonImport_JointLibrary

DGRaycastVehicleTireTransformCallback

NewtonImport_JointLibrary

dHashSpaceClass

ODEImport

dHashSpaceCreate

ODEImport

dHashSpaceGetLevels

ODEImport

dHashSpaceSetLevels

ODEImport

dHeightFieldClass

ODEImport

dInfiniteAABB

ODEImport

dInitODE

ODEImport

dInitODE2

ODEImport

DisabledDebugCollision

ODEImport

DisabledDebugGeom

ODEImport

DISABLE_NODE

Const3DS

DistanceBetweenAngles

VectorGeometry

Calculates the angular distance between two angles in radians.<p> Result is in the [0; PI] range.

DistanceCueMax3DS

Const3DS

DistanceCueMin3DS

Const3DS

DISTANCE_CUE

Const3DS

Div2

GLGraphics

DivideVector

VectorGeometry

Divides given vector by another vector.<p> v[x]:=v[x]/divider[x], v[y]:=v[y]/divider[y] etc.

DivideVector

VectorGeometry

DivMod

VectorGeometry

dJointAddAMotorTorques

ODEImport

dJointAddHinge2Torques

ODEImport

dJointAddHingeTorque

ODEImport

dJointAddPistonForce

ODEImport

dJointAddPRTorque

ODEImport

dJointAddSliderForce

ODEImport

dJointAddUniversalTorques

ODEImport

dJointAttach

ODEImport

dJointCorrectHinge2

ODEImport

dJointCreateAMotor

ODEImport

dJointCreateBall

ODEImport

dJointCreateContact

ODEImport

dJointCreateFixed

ODEImport

dJointCreateHinge

ODEImport

dJointCreateHinge2

ODEImport

dJointCreateLMotor

ODEImport

dJointCreatePiston

ODEImport

dJointCreatePlane2D

ODEImport

dJointCreatePR

ODEImport

dJointCreateSlider

ODEImport

dJointCreateUniversal

ODEImport

dJointDestroy

ODEImport

dJointGetAMotorAngle

ODEImport

dJointGetAMotorAngleRate

ODEImport

dJointGetAMotorAxis

ODEImport

dJointGetAMotorAxisRel

ODEImport

dJointGetAMotorMode

ODEImport

dJointGetAMotorNumAxes

ODEImport

dJointGetAMotorParam

ODEImport

dJointGetBallAnchor

ODEImport

dJointGetBallAnchor2

ODEImport

dJointGetBody

ODEImport

dJointGetData

ODEImport

dJointGetFeedback

ODEImport

dJointGetHinge2Anchor

ODEImport

dJointGetHinge2Anchor2

ODEImport

dJointGetHinge2Angle1

ODEImport

dJointGetHinge2Angle1Rate

ODEImport

dJointGetHinge2Angle2Rate

ODEImport

dJointGetHinge2Axis1

ODEImport

dJointGetHinge2Axis2

ODEImport

dJointGetHinge2Param

ODEImport

dJointGetHingeAnchor

ODEImport

dJointGetHingeAnchor2

ODEImport

dJointGetHingeAngle

ODEImport

dJointGetHingeAngleRate

ODEImport

dJointGetHingeAxis

ODEImport

dJointGetHingeParam

ODEImport

dJointGetLMotorAxis

ODEImport

dJointGetLMotorNumAxes

ODEImport

dJointGetLMotorParam

ODEImport

dJointGetPistonAnchor

ODEImport

dJointGetPistonAnchor2

ODEImport

dJointGetPistonAngle

ODEImport

dJointGetPistonAngleRate

ODEImport

dJointGetPistonAxis

ODEImport

dJointGetPistonParam

ODEImport

dJointGetPistonPosition

ODEImport

dJointGetPistonRate

ODEImport

dJointGetPRAxis1

ODEImport

dJointGetPRAxis2

ODEImport

dJointGetPRParam

ODEImport

dJointGetSliderAxis

ODEImport

dJointGetSliderParam

ODEImport

dJointGetSliderPosition

ODEImport

dJointGetSliderPositionRate

ODEImport

dJointGetType

ODEImport

dJointGetUniversalAnchor

ODEImport

dJointGetUniversalAnchor2

ODEImport

dJointGetUniversalAngle1

ODEImport

dJointGetUniversalAngle1Rate

ODEImport

dJointGetUniversalAngle2

ODEImport

dJointGetUniversalAngle2Rate

ODEImport

dJointGetUniversalAxis1

ODEImport

dJointGetUniversalAxis2

ODEImport

dJointGetUniversalParam

ODEImport

dJointGroupCreate

ODEImport

dJointGroupDestroy

ODEImport

dJointGroupEmpty

ODEImport

dJointSetAMotorAngle

ODEImport

dJointSetAMotorAxis

ODEImport

dJointSetAMotorMode

ODEImport

dJointSetAMotorNumAxes

ODEImport

dJointSetAMotorParam

ODEImport

dJointSetBallAnchor

ODEImport

dJointSetData

ODEImport

dJointSetFeedback

ODEImport

dJointSetFixed

ODEImport

dJointSetHinge2Anchor

ODEImport

dJointSetHinge2Axis1

ODEImport

dJointSetHinge2Axis2

ODEImport

dJointSetHinge2Param

ODEImport

dJointSetHingeAnchor

ODEImport

dJointSetHingeAxis

ODEImport

dJointSetHingeParam

ODEImport

dJointSetLMotorAxis

ODEImport

dJointSetLMotorNumAxes

ODEImport

dJointSetLMotorParam

ODEImport

dJointSetPistonAnchor

ODEImport

dJointSetPistonAxis

ODEImport

dJointSetPistonAxisDelta

ODEImport

dJointSetPistonParam

ODEImport

dJointSetPlane2DAngleParam

ODEImport

dJointSetPlane2DXParam

ODEImport

dJointSetPlane2DYParam

ODEImport

dJointSetPRAnchor

ODEImport

dJointSetPRAxis1

ODEImport

dJointSetPRAxis2

ODEImport

dJointSetPRParam

ODEImport

dJointSetSliderAxis

ODEImport

dJointSetSliderParam

ODEImport

dJointSetUniversalAnchor

ODEImport

dJointSetUniversalAxis1

ODEImport

dJointSetUniversalAxis2

ODEImport

dJointSetUniversalParam

ODEImport

dJOINT_INGROUP

ODEImport

dJOINT_REVERSE

ODEImport

dJOINT_TWOBODIES

ODEImport

dLastSpaceClass

ODEImport

dLastUserClass

ODEImport

DLLocalShadow2FMax3DS

Const3DS

DLLocalShadow2FMin3DS

Const3DS

DLLocalShadow2SMax3DS

Const3DS

DLLocalShadow2SMin3DS

Const3DS

DLSpotlightMax3DS

Const3DS

DLSpotlightMin3DS

Const3DS

DL_ATTENUATE

Const3DS

DL_EXCLUDE

Const3DS

DL_INNER_RANGE

Const3DS

DL_LOCAL_SHADOW

Const3DS

DL_LOCAL_SHADOW2

Const3DS

DL_MULTIPLIER

Const3DS

DL_OFF

Const3DS

DL_OUTER_RANGE

Const3DS

DL_RANGE

Const3DS

DL_RAYSHAD

Const3DS

DL_RAY_BIAS

Const3DS

DL_SEE_CONE

Const3DS

DL_SHADOWED

Const3DS

DL_SPOTLIGHT

Const3DS

DL_SPOT_ASPECT

Const3DS

DL_SPOT_OVERSHOOT

Const3DS

DL_SPOT_PROJECTOR

Const3DS

DL_SPOT_RECTANGULAR

Const3DS

DL_SPOT_ROLL

Const3DS

dMakeRandomMatrix

ODEImport

dMakeRandomVector

ODEImport

dMassAdd

ODEImport

dMassAdjust

ODEImport

dMassRotate

ODEImport

dMassSetBox

ODEImport

dMassSetBoxTotal

ODEImport

dMassSetCapsule

ODEImport

dMassSetCapsuleTotal

ODEImport

dMassSetCylinder

ODEImport

dMassSetCylinderTotal

ODEImport

dMassSetParameters

ODEImport

dMassSetSphere

ODEImport

dMassSetSphereTotal

ODEImport

dMassSetTrimesh

ODEImport

dMassSetTrimeshTotal

ODEImport

dMassSetZero

ODEImport

dMassTranslate

ODEImport

dMaxDifference

ODEImport

dMultiply0

ODEImport

dMULTIPLY0_331

ODEImport

dMULTIPLY0_333

ODEImport

dMultiply1

ODEImport

dMultiply2

ODEImport

dNormalize3

ODEImport

dNormalize4

ODEImport

DodecahedronBuildList

GLObjects

DoTesselate

GLGLUTesselation

Tesselates the polygon outlined by the Vertexes. And addeds them to the first facegroup of the Mesh.

DOWNLOADPROC

Bass

dParamBounce

ODEImport

dParamBounce1

ODEImport

dParamBounce2

ODEImport

dParamBounce3

ODEImport

dParamCFM

ODEImport

dParamCFM1

ODEImport

dParamCFM2

ODEImport

dParamCFM3

ODEImport

dParamERP

ODEImport

dParamERP1

ODEImport

dParamERP2

ODEImport

dParamERP3

ODEImport

dParamFMax

ODEImport

dParamFMax1

ODEImport

dParamFMax2

ODEImport

dParamFMax3

ODEImport

dParamFudgeFactor

ODEImport

dParamFudgeFactor1

ODEImport

dParamFudgeFactor2

ODEImport

dParamFudgeFactor3

ODEImport

dParamGroup

ODEImport

dParamGroup1

ODEImport

dParamGroup2

ODEImport

dParamGroup3

ODEImport

dParamHiStop

ODEImport

dParamHiStop1

ODEImport

dParamHiStop2

ODEImport

dParamHiStop3

ODEImport

dParamLoStop

ODEImport

dParamLoStop1

ODEImport

dParamLoStop2

ODEImport

dParamLoStop3

ODEImport

dParamStopCFM

ODEImport

dParamStopCFM1

ODEImport

dParamStopCFM2

ODEImport

dParamStopCFM3

ODEImport

dParamStopERP

ODEImport

dParamStopERP1

ODEImport

dParamStopERP2

ODEImport

dParamStopERP3

ODEImport

dParamSuspensionCFM

ODEImport

dParamSuspensionCFM1

ODEImport

dParamSuspensionCFM2

ODEImport

dParamSuspensionCFM3

ODEImport

dParamSuspensionERP

ODEImport

dParamSuspensionERP1

ODEImport

dParamSuspensionERP2

ODEImport

dParamSuspensionERP3

ODEImport

dParamVel

ODEImport

dParamVel1

ODEImport

dParamVel2

ODEImport

dParamVel3

ODEImport

dPlaneClass

ODEImport

dQFromAxisAndAngle

ODEImport

dQfromR

ODEImport

dQMultiply0

ODEImport

dQMultiply1

ODEImport

dQMultiply2

ODEImport

dQMultiply3

ODEImport

dQSetIdentity

ODEImport

dQuadTreeSpaceClass

ODEImport

dQuadTreeSpaceCreate

ODEImport

dRandGetSeed

ODEImport

dRandInt

ODEImport

dRandReal

ODEImport

dRandSetSeed

ODEImport

DrawBox

ODEGL

DrawDibBegin

GLSVfw

DrawDibChangePalette

GLSVfw

DrawDibClose

GLSVfw

DrawDibDraw

GLSVfw

DrawDibEnd

GLSVfw

DrawDibGetBuffer

GLSVfw

DrawDibGetPalette

GLSVfw

DrawDibOpen

GLSVfw

DrawDibProfileDisplay

GLSVfw

DrawDibRealize

GLSVfw

DrawDibSetPalette

GLSVfw

DrawDibStart

GLSVfw

DrawDibStop

GLSVfw

DrawDibTime

GLSVfw

DrawDibUpdate

GLSVfw

DrawTexturedScreenQuad

GLCustomShader

DrawTexturedScreenQuad2

GLCustomShader

DrawTexturedScreenQuad3

GLCustomShader

DrawTexturedScreenQuad4

GLCustomShader

DrawTexturedScreenQuad5

GLCustomShader

DrawTexturedScreenQuad6

GLCustomShader

dRayClass

ODEImport

dRFrom2Axes

ODEImport

dRFromAxisAndAngle

ODEImport

dRFromEulerAngles

ODEImport

dRfromQ

ODEImport

dRFromZAxis

ODEImport

dRSetIdentity

ODEImport

DSCAPS_CERTIFIED

Bass

DSCAPS_CONTINUOUSRATE

Bass

DSCAPS_EMULDRIVER

Bass

DSCAPS_SECONDARY16BIT

Bass

DSCAPS_SECONDARY8BIT

Bass

DSCAPS_SECONDARYMONO

Bass

DSCAPS_SECONDARYSTEREO

Bass

DSCCAPS_CERTIFIED

Bass

DSCCAPS_EMULDRIVER

Bass

dsDrawBox

ODEGL

dsDrawBox

ODEGL

dSimpleSpaceClass

ODEImport

dSimpleSpaceCreate

ODEImport

dSpaceAdd

ODEImport

dSpaceClean

ODEImport

dSpaceCollide

ODEImport

dSpaceCollide2

ODEImport

dSpaceDestroy

ODEImport

dSpaceGetCleanup

ODEImport

dSpaceGetGeom

ODEImport

dSpaceGetNumGeoms

ODEImport

dSpaceQuery

ODEImport

dSpaceRemove

ODEImport

dSpaceSetCleanup

ODEImport

dSphereClass

ODEImport

DSPPROC

Bass

DSPROPERTY_EAXBUFFER_AIRABSORPTIONFACTOR

openal

DSPROPERTY_EAXBUFFER_ALLPARAMETERS

openal

DSPROPERTY_EAXBUFFER_COMMITDEFERREDSETTINGS

openal

DSPROPERTY_EAXBUFFER_DEFERRED

openal

DSPROPERTY_EAXBUFFER_DIRECT

openal

DSPROPERTY_EAXBUFFER_DIRECTHF

openal

DSPROPERTY_EAXBUFFER_FLAG

openal

DSPROPERTY_EAXBUFFER_IMMEDIATE

openal

DSPROPERTY_EAXBUFFER_NONE

openal

DSPROPERTY_EAXBUFFER_OBSTRUCTION

openal

DSPROPERTY_EAXBUFFER_OBSTRUCTIONLFRATIO

openal

DSPROPERTY_EAXBUFFER_OCCLUSION

openal

DSPROPERTY_EAXBUFFER_OCCLUSIONLFRATIO

openal

DSPROPERTY_EAXBUFFER_OCCLUSIONROOMRATIO

openal

DSPROPERTY_EAXBUFFER_OUTSIDEVOLUMEHF

openal

DSPROPERTY_EAXBUFFER_ROOM

openal

DSPROPERTY_EAXBUFFER_ROOMHF

openal

DSPROPERTY_EAXBUFFER_ROOMROLLOFFFACTOR

openal

DSPROPERTY_EAXLISTENER_AIRABSORPTIONHF

openal

DSPROPERTY_EAXLISTENER_ALLPARAMETERS

openal

DSPROPERTY_EAXLISTENER_COMMITDEFERREDSETTINGS

openal

DSPROPERTY_EAXLISTENER_DECAYHFRATIO

openal

DSPROPERTY_EAXLISTENER_DECAYTIME

openal

DSPROPERTY_EAXLISTENER_DEFERRED

openal

DSPROPERTY_EAXLISTENER_ENVIRONMENT

openal

DSPROPERTY_EAXLISTENER_ENVIRONMENTDIFFUSION

openal

DSPROPERTY_EAXLISTENER_ENVIRONMENTSIZE

openal

DSPROPERTY_EAXLISTENER_FLAGS

openal

DSPROPERTY_EAXLISTENER_IMMEDIATE

openal

DSPROPERTY_EAXLISTENER_NONE

openal

DSPROPERTY_EAXLISTENER_REFLECTIONS

openal

DSPROPERTY_EAXLISTENER_REFLECTIONSDELAY

openal

DSPROPERTY_EAXLISTENER_REVERB

openal

DSPROPERTY_EAXLISTENER_REVERBDELAY

openal

DSPROPERTY_EAXLISTENER_ROOM

openal

DSPROPERTY_EAXLISTENER_ROOMHF

openal

DSPROPERTY_EAXLISTENER_ROOMROLLOFFFACTOR

openal

DSPROPERTY_EAX_BUFFERPROPERTY

openal

DSPROPERTY_EAX_LISTENERPROPERTY

openal

DSPROPSETID_EAX20_BufferProperties

openal

DSPROPSETID_EAX20_ListenerProperties

openal

DSTATE_BUFIMAGE

GLSJPG

DSTATE_BUFPOST

GLSJPG

DSTATE_INHEADER

GLSJPG

DSTATE_PRELOAD

GLSJPG

DSTATE_PRESCAN

GLSJPG

DSTATE_RAW_OK

GLSJPG

DSTATE_RDCOEFS

GLSJPG

DSTATE_READY

GLSJPG

DSTATE_SCANNING

GLSJPG

DSTATE_START

GLSJPG

DSTATE_STOPPING

GLSJPG

dSweepAndPruneSpaceClass

ODEImport

dTestMatrixComparison

ODEImport

dTestRand

ODEImport

dTestSolveLCP

ODEImport

dTriMeshClass

ODEImport

DUMMY

Const3DS

DummyName3DS

Const3DS

DumpChunk

Utils3DS

DumpKeyHeader

Utils3DS

dVector3Length

ODEGL

dVector3Length

ODEGL

DVM_CONFIGURE_END

GLSVfw

DVM_CONFIGURE_START

GLSVfw

DVM_DST_RECT

GLSVfw

DVM_FORMAT

GLSVfw

DVM_PALETTE

GLSVfw

DVM_PALETTERGB555

GLSVfw

DVM_SRC_RECT

GLSVfw

DVM_USER

GLSVfw

DV_ERR_13

GLSVfw

DV_ERR_ALLOCATED

GLSVfw

DV_ERR_BADDEVICEID

GLSVfw

DV_ERR_BADERRNUM

GLSVfw

DV_ERR_BADFORMAT

GLSVfw

DV_ERR_BADINSTALL

GLSVfw

DV_ERR_BASE

GLSVfw

DV_ERR_CONFIG1

GLSVfw

DV_ERR_CONFIG2

GLSVfw

DV_ERR_CREATEPALETTE

GLSVfw

DV_ERR_DMA_CONFLICT

GLSVfw

DV_ERR_FLAGS

GLSVfw

DV_ERR_INT_CONFLICT

GLSVfw

DV_ERR_INVALHANDLE

GLSVfw

DV_ERR_IO_CONFLICT

GLSVfw

DV_ERR_LASTERROR

GLSVfw

DV_ERR_MEM_CONFLICT

GLSVfw

DV_ERR_NOMEM

GLSVfw

DV_ERR_NONSPECIFIC

GLSVfw

DV_ERR_NOTDETECTED

GLSVfw

DV_ERR_NOTSUPPORTED

GLSVfw

DV_ERR_NO_BUFFERS

GLSVfw

DV_ERR_OK

GLSVfw

DV_ERR_PARAM1

GLSVfw

DV_ERR_PARAM2

GLSVfw

DV_ERR_PROTECT_ONLY

GLSVfw

DV_ERR_SIZEFIELD

GLSVfw

DV_ERR_STILLPLAYING

GLSVfw

DV_ERR_SYNC

GLSVfw

DV_ERR_TOOMANYCHANNELS

GLSVfw

DV_ERR_UNPREPARED

GLSVfw

DV_ERR_USER_MSG

GLSVfw

DV_VM_CLOSE

GLSVfw

DV_VM_DATA

GLSVfw

DV_VM_ERROR

GLSVfw

DV_VM_OPEN

GLSVfw

DWORD

Bass

DWORD

GLCrossPlatform

dWorldCreate

ODEImport

dWorldDestroy

ODEImport

dWorldExportDIF

ODEImport

dWorldGetAngularDamping

ODEImport

dWorldGetAngularDampingThreshold

ODEImport

dWorldGetAutoDisableAngularAverageThreshold

ODEImport

dWorldGetAutoDisableAngularThreshold

ODEImport

dWorldGetAutoDisableAverageSamplesCount

ODEImport

dWorldGetAutoDisableFlag

ODEImport

dWorldGetAutoDisableLinearAverageThreshold

ODEImport

dWorldGetAutoDisableLinearThreshold

ODEImport

dWorldGetAutoDisableSteps

ODEImport

dWorldGetAutoDisableTime

ODEImport

dWorldGetAutoEnableDepthSF1

ODEImport

dWorldGetCFM

ODEImport

dWorldGetContactMaxCorrectingVel

ODEImport

dWorldGetContactSurfaceLayer

ODEImport

dWorldGetERP

ODEImport

dWorldGetGravity

ODEImport

dWorldGetLinearDamping

ODEImport

dWorldGetLinearDampingThreshold

ODEImport

dWorldGetMaxAngularSpeed

ODEImport

dWorldGetQuickStepNumIterations

ODEImport

dWorldGetQuickStepW

ODEImport

dWorldImpulseToForce

ODEImport

dWorldQuickStep

ODEImport

dWorldSetAngularDamping

ODEImport

dWorldSetAngularDampingThreshold

ODEImport

dWorldSetAutoDisableAngularAverageThreshold

ODEImport

dWorldSetAutoDisableAngularThreshold

ODEImport

dWorldSetAutoDisableAverageSamplesCount

ODEImport

dWorldSetAutoDisableFlag

ODEImport

dWorldSetAutoDisableLinearAverageThreshold

ODEImport

dWorldSetAutoDisableLinearThreshold

ODEImport

dWorldSetAutoDisableSteps

ODEImport

dWorldSetAutoDisableTime

ODEImport

dWorldSetAutoEnableDepthSF1

ODEImport

dWorldSetCFM

ODEImport

dWorldSetContactMaxCorrectingVel

ODEImport

dWorldSetContactSurfaceLayer

ODEImport

dWorldSetDamping

ODEImport

dWorldSetERP

ODEImport

dWorldSetGravity

ODEImport

dWorldSetLinearDamping

ODEImport

dWorldSetLinearDampingThreshold

ODEImport

dWorldSetMaxAngularSpeed

ODEImport

dWorldSetQuickStepNumIterations

ODEImport

dWorldSetQuickStepW

ODEImport

dWorldStep

ODEImport

dWorldStepFast1

ODEImport

DW_ERROR

Bass

dxBodyDisabled

ODEImport

dxBodyFlagFiniteRotation

ODEImport

dxBodyFlagFiniteRotationAxis

ODEImport

dxBodyNoGravity

ODEImport

DXGI_FORMAT_A8_UNORM

DXTC

DXGI_FORMAT_B5G5R5A1_UNORM

DXTC

DXGI_FORMAT_B5G6R5_UNORM

DXTC

DXGI_FORMAT_B8G8R8A8_TYPELESS

DXTC

DXGI_FORMAT_B8G8R8A8_UNORM

DXTC

DXGI_FORMAT_B8G8R8A8_UNORM_SRGB

DXTC

DXGI_FORMAT_B8G8R8X8_TYPELESS

DXTC

DXGI_FORMAT_B8G8R8X8_UNORM

DXTC

DXGI_FORMAT_B8G8R8X8_UNORM_SRGB

DXTC

DXGI_FORMAT_BC1_TYPELESS

DXTC

DXGI_FORMAT_BC1_UNORM

DXTC

DXGI_FORMAT_BC1_UNORM_SRGB

DXTC

DXGI_FORMAT_BC2_TYPELESS

DXTC

DXGI_FORMAT_BC2_UNORM

DXTC

DXGI_FORMAT_BC2_UNORM_SRGB

DXTC

DXGI_FORMAT_BC3_TYPELESS

DXTC

DXGI_FORMAT_BC3_UNORM

DXTC

DXGI_FORMAT_BC3_UNORM_SRGB

DXTC

DXGI_FORMAT_BC4_SNORM

DXTC

DXGI_FORMAT_BC4_TYPELESS

DXTC

DXGI_FORMAT_BC4_UNORM

DXTC

DXGI_FORMAT_BC5_SNORM

DXTC

DXGI_FORMAT_BC5_TYPELESS

DXTC

DXGI_FORMAT_BC5_UNORM

DXTC

DXGI_FORMAT_BC6H_SF16

DXTC

DXGI_FORMAT_BC6H_TYPELESS

DXTC

DXGI_FORMAT_BC6H_UF16

DXTC

DXGI_FORMAT_BC7_TYPELESS

DXTC

DXGI_FORMAT_BC7_UNORM

DXTC

DXGI_FORMAT_BC7_UNORM_SRGB

DXTC

DXGI_FORMAT_D16_UNORM

DXTC

DXGI_FORMAT_D24_UNORM_S8_UINT

DXTC

DXGI_FORMAT_D32_FLOAT

DXTC

DXGI_FORMAT_D32_FLOAT_S8X24_UINT

DXTC

DXGI_FORMAT_FORCE_UINT

DXTC

DXGI_FORMAT_G8R8_G8B8_UNORM

DXTC

DXGI_FORMAT_R10G10B10A2_TYPELESS

DXTC

DXGI_FORMAT_R10G10B10A2_UINT

DXTC

DXGI_FORMAT_R10G10B10A2_UNORM

DXTC

DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM

DXTC

DXGI_FORMAT_R11G11B10_FLOAT

DXTC

DXGI_FORMAT_R16G16B16A16_FLOAT

DXTC

DXGI_FORMAT_R16G16B16A16_SINT

DXTC

DXGI_FORMAT_R16G16B16A16_SNORM

DXTC

DXGI_FORMAT_R16G16B16A16_TYPELESS

DXTC

DXGI_FORMAT_R16G16B16A16_UINT

DXTC

DXGI_FORMAT_R16G16B16A16_UNORM

DXTC

DXGI_FORMAT_R16G16_FLOAT

DXTC

DXGI_FORMAT_R16G16_SINT

DXTC

DXGI_FORMAT_R16G16_SNORM

DXTC

DXGI_FORMAT_R16G16_TYPELESS

DXTC

DXGI_FORMAT_R16G16_UINT

DXTC

DXGI_FORMAT_R16G16_UNORM

DXTC

DXGI_FORMAT_R16_FLOAT

DXTC

DXGI_FORMAT_R16_SINT

DXTC

DXGI_FORMAT_R16_SNORM

DXTC

DXGI_FORMAT_R16_TYPELESS

DXTC

DXGI_FORMAT_R16_UINT

DXTC

DXGI_FORMAT_R16_UNORM

DXTC

DXGI_FORMAT_R1_UNORM

DXTC

DXGI_FORMAT_R24G8_TYPELESS

DXTC

DXGI_FORMAT_R24_UNORM_X8_TYPELESS

DXTC

DXGI_FORMAT_R32G32B32A32_FLOAT

DXTC

DXGI_FORMAT_R32G32B32A32_SINT

DXTC

DXGI_FORMAT_R32G32B32A32_TYPELESS

DXTC

DXGI_FORMAT_R32G32B32A32_UINT

DXTC

DXGI_FORMAT_R32G32B32_FLOAT

DXTC

DXGI_FORMAT_R32G32B32_SINT

DXTC

DXGI_FORMAT_R32G32B32_TYPELESS

DXTC

DXGI_FORMAT_R32G32B32_UINT

DXTC

DXGI_FORMAT_R32G32_FLOAT

DXTC

DXGI_FORMAT_R32G32_SINT

DXTC

DXGI_FORMAT_R32G32_TYPELESS

DXTC

DXGI_FORMAT_R32G32_UINT

DXTC

DXGI_FORMAT_R32G8X24_TYPELESS

DXTC

DXGI_FORMAT_R32_FLOAT

DXTC

DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS

DXTC

DXGI_FORMAT_R32_SINT

DXTC

DXGI_FORMAT_R32_TYPELESS

DXTC

DXGI_FORMAT_R32_UINT

DXTC

DXGI_FORMAT_R8G8B8A8_SINT

DXTC

DXGI_FORMAT_R8G8B8A8_SNORM

DXTC

DXGI_FORMAT_R8G8B8A8_TYPELESS

DXTC

DXGI_FORMAT_R8G8B8A8_UINT

DXTC

DXGI_FORMAT_R8G8B8A8_UNORM

DXTC

DXGI_FORMAT_R8G8B8A8_UNORM_SRGB

DXTC

DXGI_FORMAT_R8G8_B8G8_UNORM

DXTC

DXGI_FORMAT_R8G8_SINT

DXTC

DXGI_FORMAT_R8G8_SNORM

DXTC

DXGI_FORMAT_R8G8_TYPELESS

DXTC

DXGI_FORMAT_R8G8_UINT

DXTC

DXGI_FORMAT_R8G8_UNORM

DXTC

DXGI_FORMAT_R8_SINT

DXTC

DXGI_FORMAT_R8_SNORM

DXTC

DXGI_FORMAT_R8_TYPELESS

DXTC

DXGI_FORMAT_R8_UINT

DXTC

DXGI_FORMAT_R8_UNORM

DXTC

DXGI_FORMAT_R9G9B9E5_SHAREDEXP

DXTC

DXGI_FORMAT_UNKNOWN

DXTC

DXGI_FORMAT_X24_TYPELESS_G8_UINT

DXTC

DXGI_FORMAT_X32_TYPELESS_G8X24_UINT

DXTC

DXT3AlphaBlock

DXTC

DXT5AlphaBlock

DXTC

DXTColBlock

DXTC

D_MAX_BLOCKS_IN_MCU

GLSJPG

EAXBUFFERFLAGS_DIRECTHFAUTO

openal

EAXBUFFERFLAGS_RESERVED

openal

EAXBUFFERFLAGS_ROOMAUTO

openal

EAXBUFFERFLAGS_ROOMHFAUTO

openal

EAXBUFFER_DEFAULTAIRABSORPTIONFACTOR

openal

EAXBUFFER_DEFAULTDIRECT

openal

EAXBUFFER_DEFAULTDIRECTHF

openal

EAXBUFFER_DEFAULTFLAGS

openal

EAXBUFFER_DEFAULTOBSTRUCTION

openal

EAXBUFFER_DEFAULTOBSTRUCTIONLFRATIO

openal

EAXBUFFER_DEFAULTOCCLUSION

openal

EAXBUFFER_DEFAULTOCCLUSIONLFRATIO

openal

EAXBUFFER_DEFAULTOCCLUSIONROOMRATIO

openal

EAXBUFFER_DEFAULTOUTSIDEVOLUMEHF

openal

EAXBUFFER_DEFAULTROOM

openal

EAXBUFFER_DEFAULTROOMHF

openal

EAXBUFFER_DEFAULTROOMROLLOFFFACTOR

openal

EAXBUFFER_MAXAIRABSORPTIONFACTOR

openal

EAXBUFFER_MAXDIRECT

openal

EAXBUFFER_MAXDIRECTHF

openal

EAXBUFFER_MAXOBSTRUCTION

openal

EAXBUFFER_MAXOBSTRUCTIONLFRATIO

openal

EAXBUFFER_MAXOCCLUSION

openal

EAXBUFFER_MAXOCCLUSIONLFRATIO

openal

EAXBUFFER_MAXOCCLUSIONROOMRATIO

openal

EAXBUFFER_MAXOUTSIDEVOLUMEHF

openal

EAXBUFFER_MAXROOM

openal

EAXBUFFER_MAXROOMHF

openal

EAXBUFFER_MAXROOMROLLOFFFACTOR

openal

EAXBUFFER_MINAIRABSORPTIONFACTOR

openal

EAXBUFFER_MINDIRECT

openal

EAXBUFFER_MINDIRECTHF

openal

EAXBUFFER_MINOBSTRUCTION

openal

EAXBUFFER_MINOBSTRUCTIONLFRATIO

openal

EAXBUFFER_MINOCCLUSION

openal

EAXBUFFER_MINOCCLUSIONLFRATIO

openal

EAXBUFFER_MINOCCLUSIONROOMRATIO

openal

EAXBUFFER_MINOUTSIDEVOLUMEHF

openal

EAXBUFFER_MINROOM

openal

EAXBUFFER_MINROOMHF

openal

EAXBUFFER_MINROOMROLLOFFFACTOR

openal

EAXGet

openal

EAXGetBufferMode

openal

EAXLISTENERFLAGS_DECAYHFLIMIT

openal

EAXLISTENERFLAGS_DECAYTIMESCALE

openal

EAXLISTENERFLAGS_REFLECTIONSDELAYSCALE

openal

EAXLISTENERFLAGS_REFLECTIONSSCALE

openal

EAXLISTENERFLAGS_RESERVED

openal

EAXLISTENERFLAGS_REVERBDELAYSCALE

openal

EAXLISTENERFLAGS_REVERBSCALE

openal

EAXLISTENER_DEFAULTAIRABSORPTIONHF

openal

EAXLISTENER_DEFAULTDECAYHFRATIO

openal

EAXLISTENER_DEFAULTDECAYTIME

openal

EAXLISTENER_DEFAULTENVIRONMENT

openal

EAXLISTENER_DEFAULTENVIRONMENTDIFFUSION

openal

EAXLISTENER_DEFAULTENVIRONMENTSIZE

openal

EAXLISTENER_DEFAULTFLAGS

openal

EAXLISTENER_DEFAULTREFLECTIONS

openal

EAXLISTENER_DEFAULTREFLECTIONSDELAY

openal

EAXLISTENER_DEFAULTREVERB

openal

EAXLISTENER_DEFAULTREVERBDELAY

openal

EAXLISTENER_DEFAULTROOM

openal

EAXLISTENER_DEFAULTROOMHF

openal

EAXLISTENER_DEFAULTROOMROLLOFFFACTOR

openal

EAXLISTENER_MAXAIRABSORPTIONHF

openal

EAXLISTENER_MAXDECAYHFRATIO

openal

EAXLISTENER_MAXDECAYTIME

openal

EAXLISTENER_MAXENVIRONMENT

openal

EAXLISTENER_MAXENVIRONMENTDIFFUSION

openal

EAXLISTENER_MAXENVIRONMENTSIZE

openal

EAXLISTENER_MAXREFLECTIONS

openal

EAXLISTENER_MAXREFLECTIONSDELAY

openal

EAXLISTENER_MAXREVERB

openal

EAXLISTENER_MAXREVERBDELAY

openal

EAXLISTENER_MAXROOM

openal

EAXLISTENER_MAXROOMHF

openal

EAXLISTENER_MAXROOMROLLOFFFACTOR

openal

EAXLISTENER_MINAIRABSORPTIONHF

openal

EAXLISTENER_MINDECAYHFRATIO

openal

EAXLISTENER_MINDECAYTIME

openal

EAXLISTENER_MINENVIRONMENT

openal

EAXLISTENER_MINENVIRONMENTDIFFUSION

openal

EAXLISTENER_MINENVIRONMENTSIZE

openal

EAXLISTENER_MINREFLECTIONS

openal

EAXLISTENER_MINREFLECTIONSDELAY

openal

EAXLISTENER_MINREVERB

openal

EAXLISTENER_MINREVERBDELAY

openal

EAXLISTENER_MINROOM

openal

EAXLISTENER_MINROOMHF

openal

EAXLISTENER_MINROOMROLLOFFFACTOR

openal

EAXSet

openal

EAXSetBufferMode

openal

EAX_ENVIRONMENT_ALLEY

Bass

EAX_ENVIRONMENT_ALLEY

openal

EAX_ENVIRONMENT_ARENA

Bass

EAX_ENVIRONMENT_ARENA

openal

EAX_ENVIRONMENT_AUDITORIUM

openal

EAX_ENVIRONMENT_AUDITORIUM

Bass

EAX_ENVIRONMENT_BATHROOM

Bass

EAX_ENVIRONMENT_BATHROOM

openal

EAX_ENVIRONMENT_CARPETEDHALLWAY

openal

EAX_ENVIRONMENT_CARPETEDHALLWAY

Bass

EAX_ENVIRONMENT_CAVE

openal

EAX_ENVIRONMENT_CAVE

Bass

EAX_ENVIRONMENT_CITY

openal

EAX_ENVIRONMENT_CITY

Bass

EAX_ENVIRONMENT_CONCERTHALL

Bass

EAX_ENVIRONMENT_CONCERTHALL

openal

EAX_ENVIRONMENT_COUNT

Bass

EAX_ENVIRONMENT_COUNT

openal

EAX_ENVIRONMENT_DIZZY

Bass

EAX_ENVIRONMENT_DIZZY

openal

EAX_ENVIRONMENT_DRUGGED

Bass

EAX_ENVIRONMENT_DRUGGED

openal

EAX_ENVIRONMENT_FOREST

Bass

EAX_ENVIRONMENT_FOREST

openal

EAX_ENVIRONMENT_GENERIC

Bass

EAX_ENVIRONMENT_GENERIC

openal

EAX_ENVIRONMENT_HALLWAY

openal

EAX_ENVIRONMENT_HALLWAY

Bass

EAX_ENVIRONMENT_HANGAR

openal

EAX_ENVIRONMENT_HANGAR

Bass

EAX_ENVIRONMENT_LIVINGROOM

openal

EAX_ENVIRONMENT_LIVINGROOM

Bass

EAX_ENVIRONMENT_MOUNTAINS

openal

EAX_ENVIRONMENT_MOUNTAINS

Bass

EAX_ENVIRONMENT_PADDEDCELL

Bass

EAX_ENVIRONMENT_PADDEDCELL

openal

EAX_ENVIRONMENT_PARKINGLOT

openal

EAX_ENVIRONMENT_PARKINGLOT

Bass

EAX_ENVIRONMENT_PLAIN

Bass

EAX_ENVIRONMENT_PLAIN

openal

EAX_ENVIRONMENT_PSYCHOTIC

Bass

EAX_ENVIRONMENT_PSYCHOTIC

openal

EAX_ENVIRONMENT_QUARRY

openal

EAX_ENVIRONMENT_QUARRY

Bass

EAX_ENVIRONMENT_ROOM

openal

EAX_ENVIRONMENT_ROOM

Bass

EAX_ENVIRONMENT_SEWERPIPE

openal

EAX_ENVIRONMENT_SEWERPIPE

Bass

EAX_ENVIRONMENT_STONECORRIDOR

openal

EAX_ENVIRONMENT_STONECORRIDOR

Bass

EAX_ENVIRONMENT_STONEROOM

openal

EAX_ENVIRONMENT_STONEROOM

Bass

EAX_ENVIRONMENT_UNDERWATER

openal

EAX_ENVIRONMENT_UNDERWATER

Bass

EAX_MATERIAL_BRICKWALL

openal

EAX_MATERIAL_BRICKWALLLF

openal

EAX_MATERIAL_BRICKWALLROOMRATIO

openal

EAX_MATERIAL_CURTAIN

openal

EAX_MATERIAL_CURTAINLF

openal

EAX_MATERIAL_CURTAINROOMRATIO

openal

EAX_MATERIAL_DOUBLEWINDOW

openal

EAX_MATERIAL_DOUBLEWINDOWHF

openal

EAX_MATERIAL_DOUBLEWINDOWROOMRATIO

openal

EAX_MATERIAL_SINGLEWINDOW

openal

EAX_MATERIAL_SINGLEWINDOWLF

openal

EAX_MATERIAL_SINGLEWINDOWROOMRATIO

openal

EAX_MATERIAL_STONEWALL

openal

EAX_MATERIAL_STONEWALLLF

openal

EAX_MATERIAL_STONEWALLROOMRATIO

openal

EAX_MATERIAL_THICKDOOR

openal

EAX_MATERIAL_THICKDOORLF

openal

EAX_MATERIAL_THICKDOORROOMRTATION

openal

EAX_MATERIAL_THINDOOR

openal

EAX_MATERIAL_THINDOORLF

openal

EAX_MATERIAL_THINDOORROOMRATIO

openal

EAX_MATERIAL_WOODWALL

openal

EAX_MATERIAL_WOODWALLLF

openal

EAX_MATERIAL_WOODWALLROOMRATIO

openal

ECAddBox

GLDCEMisc

ECAddEllipsoid

GLDCEMisc

ECAddFreeForm

GLDCEMisc

ECAddTerrain

GLDCEMisc

ECResetColliders

GLDCEMisc

ECSetCollisionRange

GLDCEMisc

EDDSException

DDSImage

EditGLTextureImage

GLTextureImageEditors

Invokes the editor for the given TGLTextureImage

EditStreamClone

GLSVfw

EditStreamCopy

GLSVfw

EditStreamCut

GLSVfw

EditStreamPaste

GLSVfw

EditStreamSetInfo

GLSVfw

EditStreamSetInfoA

GLSVfw

EditStreamSetInfoW

GLSVfw

EditStreamSetName

GLSVfw

EditStreamSetNameA

GLSVfw

EditStreamSetNameW

GLSVfw

EFFECTS_SELECTED

GLSceneEditLCL

EFFECTS_SELECTED

GLSceneEdit

EFilerException

PersistentClasses

Usually triggered when a filing error is detected.

EFilerException

XCollection

EFXEAXREVERBPROPERTIES

openal

EFXLOWPASSFILTER

openal

EFXUtilLibHandle

openal

EGLAtmosphereException

GLAtmosphere

EGLCameraController

GLCameraController

EGLCgBombShaderException

GLCgBombShader

EGLCGShaderException

GLCgShader

EGLConsoleException

GLConsole

EGLContext

GLContext

EGLCustomShaderException

GLCustomShader

EGLFile3DS

GLFile3DS

EGLImageUtils

ImageUtils

EGLMotionBlurException

GLBlur

EGLOBJFileError

GLFileOBJ

EGLOSError

GLCrossPlatform

EGLPostShaderHolderException

GLPostEffects

EGLProxyException

GLProxyObjects

EGLROAMException

GLROAMPatch

EGLShader

GLContext

EGLShaderException

GLTexture

EGLSLBumpShaderException

GLSLBumpShader

EGLSLDiffuseSpecularShaderException

GLSLDiffuseSpecularShader

EGLSLShaderException

GLSLShader

EGLUtilsException

GLUtils

EInvalidArchiveFile

GLSArchiveManager

EInvalidFileSignature

PersistentClasses

Triggered when file signature does not match.

EInvalidGraphic

GLSJPG

EInvalidGraphicOperation

GLSJPG

EInvalidRasterFile

GLGraphics

EInvalidVectorFile

GLVectorFileObjects

EmptyHmgMatrix

VectorGeometry

EmptyMatrix

VectorGeometry

EncodeGLTextureTarget

GLTextureFormat

EndFPUOnlySection

VectorGeometry

Ends a FPU-only section.<p> See BeginFPUOnlySection.

EnqueueNativeKernel_user_func

GLS_CL

ENVL_CHAN

LWObjects

ENVL_KEY

LWObjects

ENVL_NAME

LWObjects

ENVL_POST

LWObjects

ENVL_PRE

LWObjects

ENVL_SPAN

LWObjects

EOpenALError

GLSMOpenAL

EOpenGLError

OpenGL1x

EOpenGLError

OpenGLAdapter

EPBuffer

GLContext

EPSILON

VectorGeometry

EPSILON2

VectorGeometry

Error3DS_CLOSING_FILE

Const3DS

Error3DS_CREATING_DATABASE

Const3DS

Error3DS_GET_FAIL

Const3DS

Error3DS_INIT_FAILED

Const3DS

Error3DS_INVALID_ARG

Const3DS

Error3DS_INVALID_CHUNK

Const3DS

Error3DS_INVALID_DATA

Const3DS

Error3DS_INVALID_DATABASE

Const3DS

Error3DS_INVALID_INDEX

Const3DS

Error3DS_NO_MEM

Const3DS

Error3DS_NO_SUCH_FILE

Const3DS

Error3DS_OPENING_FILE

Const3DS

Error3DS_PUT_FAIL

Const3DS

Error3DS_READING_DATABASE

Const3DS

Error3DS_READING_FILE

Const3DS

Error3DS_STRING_TOO_LONG

Const3DS

Error3DS_UNFOUND_CHUNK

Const3DS

Error3DS_WRITING_DATABASE

Const3DS

Error3DS_WRITING_FILE

Const3DS

Error3DS_WRONG_DATABASE

Const3DS

Error3DS_WRONG_OBJECT

Const3DS

ERROR_INCOMPATIBLE_DEVICE_CONTEXTS_ARB

OpenGLTokens

ERROR_INVALID_PIXEL_TYPE_ARB

OpenGLTokens

ERROR_INVALID_PROFILE_ARB

OpenGLTokens

ERROR_INVALID_VERSION_ARB

OpenGLTokens

ERR_MAX_ARGS

GLSDL

ERR_MAX_STRLEN

GLSDL

ESDLError

GLSDLWindow

ETexture

GLTexture

ETextureCombinerError

GLTextureCombiners

ETGAException

TGA

EvalPolynom

Polynomials

Computes polynom's value for given x.

ExponateCrap

GLPerlinBase

ExtendedFrustumIntersectsBSphere

SpatialPartitioning

ExtendedFrustumMake

SpatialPartitioning

ExtendedFrustumMakeFromSceneViewer

GLSpatialPartitioning

ExtendedFrustumMakeFromSceneViewer

GLSpatialPartitioning

Create an extended frustum from a GLSceneViewer - this makes the unit specific to the windows platform!

ExtractAABBCorners

GeometryBB

ExtractFrustumFromModelViewProjection

VectorGeometry

Extracts a TFrustum for combined modelview and projection matrices.

EZBufferException

GLzBuffer

EZCompressionError

GLSZLibEx

EZDecompressionError

GLSZLibEx

EZLibError

GLSZLibEx

EZLibErrorClass

GLSZLibEx

FaceABVisable3DS

Const3DS

FaceArrayMin3DS

Const3DS

FaceBCVisable3DS

Const3DS

FaceCAVisable3DS

Const3DS

FacesSmooth

GLMeshOptimizer

FaceUWrap3DS

Const3DS

FaceVWrap3DS

Const3DS

FACE_ARRAY

Const3DS

FACE_ARRAY_ENTRY

Const3DS

FACE_POLYGON

Q3BSP

FallTrackTagMax3DS

Const3DS

FallTrackTagMin3DS

Const3DS

FALL_TRACK_TAG

Const3DS

FALL_TRACK_TAG_KEY

Const3DS

FastArcTan2

VectorGeometry

Fast ArcTan2 approximation, about 0.07 rads accuracy.

FastCheckCubeVsCube

GLCollision

FastCheckCubeVsEllipsoid

GLCollision

FastCheckCubeVsFace

GLCollision

FastCheckCubeVsPoint

GLCollision

FastCheckCubeVsSphere

GLCollision

FastCheckEllipsoidVsCube

GLCollision

FastCheckEllipsoidVsEllipsoid

GLCollision

FastCheckEllipsoidVsPoint

GLCollision

FastCheckEllipsoidVsSphere

GLCollision

FastCheckFaceVsCube

GLCollision

FastCheckFaceVsFace

GLCollision

FastCheckPointVsCube

GLCollision

FastCheckPointVsEllipsoid

GLCollision

FastCheckPointVsPoint

GLCollision

FastCheckPointVsSphere

GLCollision

FastCheckSphereVsCube

GLCollision

FastCheckSphereVsEllipsoid

GLCollision

FastCheckSphereVsPoint

GLCollision

FastCheckSphereVsSphere

GLCollision

FastQuickSortLists

VectorLists

Sort the refList in ascending order, ordering objList on the way.<p> Use if, and *ONLY* if refList contains only values superior or equal to 1.

FAST_NODE

Const3DS

FileAttrStrMax3DS

Const3DS

FileNameStrMax3DS

Const3DS

FileStreamExists

ApplicationFileIO

Queries is a file stream corresponding to the fileName exists.<p>

FillUniformAutoSetMethodList

GLSLParameter

FillUniformAutoSetMethodList

GLSLParameter

FindChunk

Utils3DS

FindChunkById

LWObjects

FindClipByClipIndex

LWObjects

FindCompatibleDataFormat

GLTextureFormat

Give compatible openGL image format and data type.

FindDDSCompatibleDataFormat

DXTC

FindGLTextureImageClass

GLTexture

Finds a registerer TGLTextureImageClass using its classname

FindGLTextureImageClassByFriendlyName

GLTexture

Finds a registerer TGLTextureImageClass using its FriendlyName

FindManager

GLManager

FindNamedObjectByIndex

Utils3DS

FindNextChunk

Utils3DS

FindRoot

Polynomials

Finds a root between min and max with a precision of epsilon.<p> The evaluation of min/max must be of opposit sign

FindSurfaceByName

LWObjects

FindSurfaceByTag

LWObjects

FindVMapByName

LWObjects

FindXCollectionItemClass

XCollection

Retrieves a registered TXCollectionItemClass from its classname.

FindXMLNode

GLSCrossXML

FIND_ANY

GLSVfw

FIND_DIR

GLSVfw

FIND_FORMAT

GLSVfw

FIND_FROM_START

GLSVfw

FIND_INDEX

GLSVfw

FIND_KEY

GLSVfw

FIND_LENGTH

GLSVfw

FIND_NEXT

GLSVfw

FIND_OFFSET

GLSVfw

FIND_POS

GLSVfw

FIND_PREV

GLSVfw

FIND_RET

GLSVfw

FIND_SIZE

GLSVfw

FIND_TYPE

GLSVfw

FixPathDelimiter

GLCrossPlatform

Replace path delimiter to delimiter of the current platform.

flip_blocks_dxtc1

DXTC

flip_blocks_dxtc3

DXTC

flip_blocks_dxtc5

DXTC

flip_dxt5_alpha

DXTC

Float

NewtonImport

FLOAT

Bass

Float2rgbe

RGBE

FloatPercentageMax3DS

Const3DS

FloatToHalf

GLCrossPlatform

FLOAT_PERCENTAGE

Const3DS

Floor

VectorGeometry

Floor64

VectorGeometry

FMOD_ErrorString

fmoderrors

FMOD_Load

fmod

FMOD_Load

fmoddyn

FMOD_Unload

fmod

FMOD_Unload

fmoddyn

FMOD_VERSION

fmodtypes

FMUSIC_FreeSong

fmod

FMUSIC_FreeSong

fmoddyn

FMUSIC_GetBPM

fmod

FMUSIC_GetBPM

fmoddyn

FMUSIC_GetGlobalVolume

fmod

FMUSIC_GetGlobalVolume

fmoddyn

FMUSIC_GetMasterVolume

fmod

FMUSIC_GetMasterVolume

fmoddyn

FMUSIC_GetName

fmoddyn

FMUSIC_GetName

fmod

FMUSIC_GetNumChannels

fmoddyn

FMUSIC_GetNumChannels

fmod

FMUSIC_GetNumInstruments

fmod

FMUSIC_GetNumInstruments

fmoddyn

FMUSIC_GetNumOrders

fmoddyn

FMUSIC_GetNumOrders

fmod

FMUSIC_GetNumPatterns

fmoddyn

FMUSIC_GetNumPatterns

fmod

FMUSIC_GetNumSamples

fmod

FMUSIC_GetNumSamples

fmoddyn

FMUSIC_GetOpenState

fmod

FMUSIC_GetOpenState

fmoddyn

FMUSIC_GetOrder

fmod

FMUSIC_GetOrder

fmoddyn

FMUSIC_GetPattern

fmod

FMUSIC_GetPattern

fmoddyn

FMUSIC_GetPatternLength

fmoddyn

FMUSIC_GetPatternLength

fmod

FMUSIC_GetPaused

fmoddyn

FMUSIC_GetPaused

fmod

FMUSIC_GetRealChannel

fmod

FMUSIC_GetRealChannel

fmoddyn

FMUSIC_GetRow

fmod

FMUSIC_GetRow

fmoddyn

FMUSIC_GetSample

fmod

FMUSIC_GetSample

fmoddyn

FMUSIC_GetSpeed

fmoddyn

FMUSIC_GetSpeed

fmod

FMUSIC_GetTime

fmoddyn

FMUSIC_GetTime

fmod

FMUSIC_GetType

fmoddyn

FMUSIC_GetType

fmod

FMUSIC_GetUserData

fmoddyn

FMUSIC_GetUserData

fmod

FMUSIC_IsFinished

fmoddyn

FMUSIC_IsFinished

fmod

FMUSIC_IsPlaying

fmoddyn

FMUSIC_IsPlaying

fmod

FMUSIC_LoadSong

fmoddyn

FMUSIC_LoadSong

fmod

FMUSIC_LoadSongEx

fmoddyn

FMUSIC_LoadSongEx

fmod

FMUSIC_OptimizeChannels

fmoddyn

FMUSIC_OptimizeChannels

fmod

FMUSIC_PlaySong

fmod

FMUSIC_PlaySong

fmoddyn

FMUSIC_SetInstCallback

fmod

FMUSIC_SetInstCallback

fmoddyn

FMUSIC_SetLooping

fmod

FMUSIC_SetLooping

fmoddyn

FMUSIC_SetMasterSpeed

fmod

FMUSIC_SetMasterSpeed

fmoddyn

FMUSIC_SetMasterVolume

fmoddyn

FMUSIC_SetMasterVolume

fmod

FMUSIC_SetOrder

fmoddyn

FMUSIC_SetOrder

fmod

FMUSIC_SetOrderCallback

fmoddyn

FMUSIC_SetOrderCallback

fmod

FMUSIC_SetPanSeperation

fmod

FMUSIC_SetPanSeperation

fmoddyn

FMUSIC_SetPaused

fmod

FMUSIC_SetPaused

fmoddyn

FMUSIC_SetReverb

fmod

FMUSIC_SetReverb

fmoddyn

FMUSIC_SetRowCallback

fmoddyn

FMUSIC_SetRowCallback

fmod

FMUSIC_SetSample

fmod

FMUSIC_SetSample

fmoddyn

FMUSIC_SetUserData

fmod

FMUSIC_SetUserData

fmoddyn

FMUSIC_SetZxxCallback

fmoddyn

FMUSIC_SetZxxCallback

fmod

FMUSIC_StopAllSongs

fmoddyn

FMUSIC_StopAllSongs

fmod

FMUSIC_StopSong

fmoddyn

FMUSIC_StopSong

fmod

FOG

Const3DS

FogMax3DS

Const3DS

FogMin3DS

Const3DS

FOG_BGND

Const3DS

FontManager

GLSpaceText

formtypeAVI

GLSVfw

FOURCC_A16B16G16R16

DXTC

FOURCC_A16B16G16R16F

DXTC

FOURCC_A1R5G5B5

DXTC

FOURCC_A2B10G10R10

DXTC

FOURCC_A2R10G10B10

DXTC

FOURCC_A32B32G32R32F

DXTC

FOURCC_A4L4

DXTC

FOURCC_A4R4G4B4

DXTC

FOURCC_A8

DXTC

FOURCC_A8B8G8R8

DXTC

FOURCC_A8L8

DXTC

FOURCC_A8R3G3B2

DXTC

FOURCC_A8R8G8B8

DXTC

FOURCC_ATI1

DXTC

FOURCC_ATI2

DXTC

FOURCC_D16

DXTC

FOURCC_D16_LOCKABLE

DXTC

FOURCC_D24X8

DXTC

FOURCC_D32

DXTC

FOURCC_D32F_LOCKABLE

DXTC

FOURCC_DX10

DXTC

FOURCC_DXT1

DXTC

FOURCC_DXT2

DXTC

FOURCC_DXT3

DXTC

FOURCC_DXT4

DXTC

FOURCC_DXT5

DXTC

FOURCC_G16R16

DXTC

FOURCC_G16R16F

DXTC

FOURCC_G32R32F

DXTC

FOURCC_L16

DXTC

FOURCC_L8

DXTC

FOURCC_R16F

DXTC

FOURCC_R32F

DXTC

FOURCC_R3G3B2

DXTC

FOURCC_R5G6B5

DXTC

FOURCC_R8G8B8

DXTC

FOURCC_UNKNOWN

DXTC

FOURCC_X1R5G5B5

DXTC

FOURCC_X4R4G4B4

DXTC

FOURCC_X8B8G8R8

DXTC

FOURCC_X8R8G8B8

DXTC

FOVTrackTagMax3DS

Const3DS

FOVTrackTagMin3DS

Const3DS

FOV_TRACK_TAG

Const3DS

FOV_TRACK_TAG_KEY

Const3DS

Frac

VectorGeometry

FRAMES_TO_MSF

GLSDL

FreeAndNil

GLSDL

FreeChunkData

Utils3DS

FromHex

GLSVfw

FrustumContainsAABB

GeometryBB

FrustumContainsBSphere

GeometryBB

FSOUND_16BITS

fmodtypes

FSOUND_2D

fmodtypes

FSOUND_3D_GetAttributes

fmod

FSOUND_3D_GetAttributes

fmoddyn

FSOUND_3D_GetMinMaxDistance

fmoddyn

FSOUND_3D_GetMinMaxDistance

fmod

FSOUND_3D_Listener_GetAttributes

fmod

FSOUND_3D_Listener_GetAttributes

fmoddyn

FSOUND_3D_Listener_SetAttributes

fmod

FSOUND_3D_Listener_SetAttributes

fmoddyn

FSOUND_3D_Listener_SetCurrent

fmoddyn

FSOUND_3D_Listener_SetCurrent

fmod

FSOUND_3D_SetAttributes

fmod

FSOUND_3D_SetAttributes

fmoddyn

FSOUND_3D_SetDistanceFactor

fmoddyn

FSOUND_3D_SetDistanceFactor

fmod

FSOUND_3D_SetDopplerFactor

fmoddyn

FSOUND_3D_SetDopplerFactor

fmod

FSOUND_3D_SetMinMaxDistance

fmod

FSOUND_3D_SetMinMaxDistance

fmoddyn

FSOUND_3D_SetRolloffFactor

fmod

FSOUND_3D_SetRolloffFactor

fmoddyn

FSOUND_8BITS

fmodtypes

FSOUND_ALL

fmodtypes

FSOUND_CAPS_EAX2

fmodtypes

FSOUND_CAPS_EAX3

fmodtypes

FSOUND_CAPS_HARDWARE

fmodtypes

FSOUND_CD_GetNumTracks

fmoddyn

FSOUND_CD_GetNumTracks

fmod

FSOUND_CD_GetPaused

fmoddyn

FSOUND_CD_GetPaused

fmod

FSOUND_CD_GetTrack

fmod

FSOUND_CD_GetTrack

fmoddyn

FSOUND_CD_GetTrackLength

fmoddyn

FSOUND_CD_GetTrackLength

fmod

FSOUND_CD_GetTrackTime

fmod

FSOUND_CD_GetTrackTime

fmoddyn

FSOUND_CD_GetVolume

fmoddyn

FSOUND_CD_GetVolume

fmod

FSOUND_CD_OpenTray

fmod

FSOUND_CD_OpenTray

fmoddyn

FSOUND_CD_Play

fmod

FSOUND_CD_Play

fmoddyn

FSOUND_CD_PLAYCONTINUOUS

fmodtypes

FSOUND_CD_PLAYLOOPED

fmodtypes

FSOUND_CD_PLAYONCE

fmodtypes

FSOUND_CD_PLAYRANDOM

fmodtypes

FSOUND_CD_SetPaused

fmoddyn

FSOUND_CD_SetPaused

fmod

FSOUND_CD_SetPlayMode

fmod

FSOUND_CD_SetPlayMode

fmoddyn

FSOUND_CD_SetTrackTime

fmod

FSOUND_CD_SetTrackTime

fmoddyn

FSOUND_CD_SetVolume

fmoddyn

FSOUND_CD_SetVolume

fmod

FSOUND_CD_Stop

fmoddyn

FSOUND_CD_Stop

fmod

FSOUND_Close

fmod

FSOUND_Close

fmoddyn

FSOUND_DELTA

fmodtypes

FSOUND_DSP_ClearMixBuffer

fmod

FSOUND_DSP_ClearMixBuffer

fmoddyn

FSOUND_DSP_Create

fmoddyn

FSOUND_DSP_Create

fmod

FSOUND_DSP_DEFAULTPRIORITY_CLEARUNIT

fmodtypes

FSOUND_DSP_DEFAULTPRIORITY_CLIPANDCOPYUNIT

fmodtypes

FSOUND_DSP_DEFAULTPRIORITY_FFTUNIT

fmodtypes

FSOUND_DSP_DEFAULTPRIORITY_MUSICUNIT

fmodtypes

FSOUND_DSP_DEFAULTPRIORITY_SFXUNIT

fmodtypes

FSOUND_DSP_DEFAULTPRIORITY_USER

fmodtypes

FSOUND_DSP_Free

fmod

FSOUND_DSP_Free

fmoddyn

FSOUND_DSP_GetActive

fmod

FSOUND_DSP_GetActive

fmoddyn

FSOUND_DSP_GetBufferLength

fmoddyn

FSOUND_DSP_GetBufferLength

fmod

FSOUND_DSP_GetBufferLengthTotal

fmod

FSOUND_DSP_GetBufferLengthTotal

fmoddyn

FSOUND_DSP_GetClearUnit

fmod

FSOUND_DSP_GetClearUnit

fmoddyn

FSOUND_DSP_GetClipAndCopyUnit

fmod

FSOUND_DSP_GetClipAndCopyUnit

fmoddyn

FSOUND_DSP_GetFFTUnit

fmod

FSOUND_DSP_GetFFTUnit

fmoddyn

FSOUND_DSP_GetMusicUnit

fmoddyn

FSOUND_DSP_GetMusicUnit

fmod

FSOUND_DSP_GetPriority

fmoddyn

FSOUND_DSP_GetPriority

fmod

FSOUND_DSP_GetSFXUnit

fmoddyn

FSOUND_DSP_GetSFXUnit

fmod

FSOUND_DSP_GetSpectrum

fmoddyn

FSOUND_DSP_GetSpectrum

fmod

FSOUND_DSP_MixBuffers

fmoddyn

FSOUND_DSP_MixBuffers

fmod

FSOUND_DSP_SetActive

fmoddyn

FSOUND_DSP_SetActive

fmod

FSOUND_DSP_SetPriority

fmoddyn

FSOUND_DSP_SetPriority

fmod

FSOUND_ENABLEFX

fmodtypes

FSOUND_File_SetCallbacks

fmoddyn

FSOUND_File_SetCallbacks

fmod

FSOUND_FORCEMONO

fmodtypes

FSOUND_FORMAT_MPEG

fmodtypes

FSOUND_FORMAT_OGGVORBIS

fmodtypes

FSOUND_FREE

fmodtypes

FSOUND_FX_Disable

fmoddyn

FSOUND_FX_Disable

fmod

FSOUND_FX_Enable

fmod

FSOUND_FX_Enable

fmoddyn

FSOUND_FX_SetChorus

fmoddyn

FSOUND_FX_SetChorus

fmod

FSOUND_FX_SetCompressor

fmoddyn

FSOUND_FX_SetCompressor

fmod

FSOUND_FX_SetDistortion

fmoddyn

FSOUND_FX_SetDistortion

fmod

FSOUND_FX_SetEcho

fmod

FSOUND_FX_SetEcho

fmoddyn

FSOUND_FX_SetFlanger

fmoddyn

FSOUND_FX_SetFlanger

fmod

FSOUND_FX_SetGargle

fmod

FSOUND_FX_SetGargle

fmoddyn

FSOUND_FX_SetI3DL2Reverb

fmod

FSOUND_FX_SetI3DL2Reverb

fmoddyn

FSOUND_FX_SetParamEQ

fmoddyn

FSOUND_FX_SetParamEQ

fmod

FSOUND_FX_SetWavesReverb

fmoddyn

FSOUND_FX_SetWavesReverb

fmod

FSOUND_GCADPCM

fmodtypes

FSOUND_GetAmplitude

fmoddyn

FSOUND_GetAmplitude

fmod

FSOUND_GetChannelsPlaying

fmoddyn

FSOUND_GetChannelsPlaying

fmod

FSOUND_GetCPUUsage

fmod

FSOUND_GetCPUUsage

fmoddyn

FSOUND_GetCurrentLevels

fmod

FSOUND_GetCurrentLevels

fmoddyn

FSOUND_GetCurrentPosition

fmoddyn

FSOUND_GetCurrentPosition

fmod

FSOUND_GetCurrentSample

fmod

FSOUND_GetCurrentSample

fmoddyn

FSOUND_GetDriver

fmoddyn

FSOUND_GetDriver

fmod

FSOUND_GetDriverCaps

fmoddyn

FSOUND_GetDriverCaps

fmod

FSOUND_GetDriverName

fmoddyn

FSOUND_GetDriverName

fmod

FSOUND_GetError

fmod

FSOUND_GetError

fmoddyn

FSOUND_GetFrequency

fmoddyn

FSOUND_GetFrequency

fmod

FSOUND_GetLoopMode

fmoddyn

FSOUND_GetLoopMode

fmod

FSOUND_GetMaxChannels

fmoddyn

FSOUND_GetMaxChannels

fmod

FSOUND_GetMaxSamples

fmod

FSOUND_GetMaxSamples

fmoddyn

FSOUND_GetMemoryStats

fmod

FSOUND_GetMemoryStats

fmoddyn

FSOUND_GetMixer

fmoddyn

FSOUND_GetMixer

fmod

FSOUND_GetMute

fmoddyn

FSOUND_GetMute

fmod

FSOUND_GetNumDrivers

fmoddyn

FSOUND_GetNumDrivers

fmod

FSOUND_GetNumHWChannels

fmod

FSOUND_GetNumHWChannels

fmoddyn

FSOUND_GetNumSubChannels

fmod

FSOUND_GetNumSubChannels

fmoddyn

FSOUND_GetOutput

fmod

FSOUND_GetOutput

fmoddyn

FSOUND_GetOutputHandle

fmod

FSOUND_GetOutputHandle

fmoddyn

FSOUND_GetOutputRate

fmoddyn

FSOUND_GetOutputRate

fmod

FSOUND_GetPan

fmoddyn

FSOUND_GetPan

fmod

FSOUND_GetPaused

fmoddyn

FSOUND_GetPaused

fmod

FSOUND_GetPriority

fmod

FSOUND_GetPriority

fmoddyn

FSOUND_GetReserved

fmoddyn

FSOUND_GetReserved

fmod

FSOUND_GetSFXMasterVolume

fmoddyn

FSOUND_GetSFXMasterVolume

fmod

FSOUND_GetSpeakerMode

fmoddyn

FSOUND_GetSubChannel

fmod

FSOUND_GetSubChannel

fmoddyn

FSOUND_GetSurround

fmoddyn

FSOUND_GetSurround

fmod

FSOUND_GetVersion

fmoddyn

FSOUND_GetVersion

fmod

FSOUND_GetVolume

fmoddyn

FSOUND_GetVolume

fmod

FSOUND_HW2D

fmodtypes

FSOUND_HW3D

fmodtypes

FSOUND_Init

fmod

FSOUND_Init

fmoddyn

FSOUND_INIT_ACCURATEVULEVELS

fmodtypes

FSOUND_INIT_DONTLATENCYADJUST

fmodtypes

FSOUND_INIT_DSOUND_DEFERRED

fmodtypes

FSOUND_INIT_DSOUND_HRTF_FULL

fmodtypes

FSOUND_INIT_DSOUND_HRTF_LIGHT

fmodtypes

FSOUND_INIT_ENABLESYSTEMCHANNELFX

fmodtypes

FSOUND_INIT_GC_INITLIBS

fmodtypes

FSOUND_INIT_GLOBALFOCUS

fmodtypes

FSOUND_INIT_PS2_DISABLECORE0REVERB

fmodtypes

FSOUND_INIT_PS2_DISABLECORE1REVERB

fmodtypes

FSOUND_INIT_PS2_SWAPDMACORES

fmodtypes

FSOUND_INIT_PS2_USEVOLUMERAMPING

fmodtypes

FSOUND_INIT_PSP_SILENCEONUNDERRUN

fmodtypes

FSOUND_INIT_STREAM_FROM_MAIN_THREAD

fmodtypes

FSOUND_INIT_USEDEFAULTMIDISYNTH

fmodtypes

FSOUND_INIT_XBOX_REMOVEHEADROOM

fmodtypes

FSOUND_IsPlaying

fmod

FSOUND_IsPlaying

fmoddyn

FSOUND_IT214

fmodtypes

FSOUND_IT215

fmodtypes

FSOUND_LOADMEMORY

fmodtypes

FSOUND_LOADMEMORYIOP

fmodtypes

FSOUND_LOADRAW

fmodtypes

FSOUND_LOOP_BIDI

fmodtypes

FSOUND_LOOP_NORMAL

fmodtypes

FSOUND_LOOP_OFF

fmodtypes

FSOUND_MONO

fmodtypes

FSOUND_MPEGACCURATE

fmodtypes

FSOUND_MPEGHALFRATE

fmodtypes

FSOUND_MULTICHANNEL

fmodtypes

FSOUND_NONBLOCKING

fmodtypes

FSOUND_NORMAL

fmodtypes

FSOUND_PlaySound

fmod

FSOUND_PlaySound

fmoddyn

FSOUND_PlaySoundEx

fmod

FSOUND_PlaySoundEx

fmoddyn

FSOUND_PRESET_ALLEY

fmodpresets

FSOUND_PRESET_ARENA

fmodpresets

FSOUND_PRESET_AUDITORIUM

fmodpresets

FSOUND_PRESET_BATHROOM

fmodpresets

FSOUND_PRESET_CARPETTEDHALLWAY

fmodpresets

FSOUND_PRESET_CAVE

fmodpresets

FSOUND_PRESET_CITY

fmodpresets

FSOUND_PRESET_CONCERTHALL

fmodpresets

FSOUND_PRESET_DIZZY

fmodpresets

FSOUND_PRESET_DRUGGED

fmodpresets

FSOUND_PRESET_FOREST

fmodpresets

FSOUND_PRESET_GENERIC

fmodpresets

FSOUND_PRESET_HALLWAY

fmodpresets

FSOUND_PRESET_HANGAR

fmodpresets

FSOUND_PRESET_LIVINGROOM

fmodpresets

FSOUND_PRESET_MOUNTAINS

fmodpresets

FSOUND_PRESET_OFF

fmodpresets

FSOUND_PRESET_PADDEDCELL

fmodpresets

FSOUND_PRESET_PARKINGLOT

fmodpresets

FSOUND_PRESET_PLAIN

fmodpresets

FSOUND_PRESET_PSYCHOTIC

fmodpresets

FSOUND_PRESET_QUARRY

fmodpresets

FSOUND_PRESET_ROOM

fmodpresets

FSOUND_PRESET_SEWERPIPE

fmodpresets

FSOUND_PRESET_STONECORRIDOR

fmodpresets

FSOUND_PRESET_STONEROOM

fmodpresets

FSOUND_PRESET_UNDERWATER

fmodpresets

FSOUND_PROTOCOL_HTTP

fmodtypes

FSOUND_PROTOCOL_ICECAST

fmodtypes

FSOUND_PROTOCOL_SHOUTCAST

fmodtypes

FSOUND_Record_GetDriver

fmod

FSOUND_Record_GetDriver

fmoddyn

FSOUND_Record_GetDriverName

fmod

FSOUND_Record_GetDriverName

fmoddyn

FSOUND_Record_GetNumDrivers

fmoddyn

FSOUND_Record_GetNumDrivers

fmod

FSOUND_Record_GetPosition

fmoddyn

FSOUND_Record_GetPosition

fmod

FSOUND_Record_SetDriver

fmod

FSOUND_Record_SetDriver

fmoddyn

FSOUND_Record_StartSample

fmoddyn

FSOUND_Record_StartSample

fmod

FSOUND_Record_Stop

fmoddyn

FSOUND_Record_Stop

fmod

FSOUND_REVERBFLAGS_DECAYHFLIMIT

fmodtypes

FSOUND_REVERBFLAGS_DECAYTIMESCALE

fmodtypes

FSOUND_REVERBFLAGS_DEFAULT

fmodtypes

FSOUND_REVERBFLAGS_ECHOTIMESCALE

fmodtypes

FSOUND_REVERBFLAGS_MODULATIONTIMESCALE

fmodtypes

FSOUND_REVERBFLAGS_REFLECTIONSDELAYSCALE

fmodtypes

FSOUND_REVERBFLAGS_REFLECTIONSSCALE

fmodtypes

FSOUND_REVERBFLAGS_REVERBDELAYSCALE

fmodtypes

FSOUND_REVERBFLAGS_REVERBSCALE

fmodtypes

FSOUND_REVERB_CHANNELFLAGS_DEFAULT

fmodtypes

FSOUND_REVERB_CHANNELFLAGS_DIRECTHFAUTO

fmodtypes

FSOUND_REVERB_CHANNELFLAGS_ROOMAUTO

fmodtypes

FSOUND_REVERB_CHANNELFLAGS_ROOMHFAUTO

fmodtypes

FSOUND_REVERB_FLAGS_CORE0

fmodtypes

FSOUND_REVERB_FLAGS_CORE1

fmodtypes

FSOUND_Reverb_GetChannelProperties

fmoddyn

FSOUND_Reverb_GetChannelProperties

fmod

FSOUND_Reverb_GetProperties

fmoddyn

FSOUND_Reverb_GetProperties

fmod

FSOUND_Reverb_SetChannelProperties

fmoddyn

FSOUND_Reverb_SetChannelProperties

fmod

FSOUND_Reverb_SetProperties

fmod

FSOUND_Reverb_SetProperties

fmoddyn

FSOUND_Sample_Alloc

fmoddyn

FSOUND_Sample_Alloc

fmod

FSOUND_Sample_Free

fmoddyn

FSOUND_Sample_Free

fmod

FSOUND_Sample_Get

fmoddyn

FSOUND_Sample_Get

fmod

FSOUND_Sample_GetDefaults

fmoddyn

FSOUND_Sample_GetDefaults

fmod

FSOUND_Sample_GetDefaultsEx

fmoddyn

FSOUND_Sample_GetDefaultsEx

fmod

FSOUND_Sample_GetLength

fmoddyn

FSOUND_Sample_GetLength

fmod

FSOUND_Sample_GetLoopPoints

fmod

FSOUND_Sample_GetLoopPoints

fmoddyn

FSOUND_Sample_GetMinMaxDistance

fmod

FSOUND_Sample_GetMinMaxDistance

fmoddyn

FSOUND_Sample_GetMode

fmoddyn

FSOUND_Sample_GetMode

fmod

FSOUND_Sample_GetName

fmod

FSOUND_Sample_GetName

fmoddyn

FSOUND_Sample_Load

fmod

FSOUND_Sample_Load

fmoddyn

FSOUND_Sample_Lock

fmod

FSOUND_Sample_Lock

fmoddyn

FSOUND_Sample_SetDefaults

fmod

FSOUND_Sample_SetDefaults

fmoddyn

FSOUND_Sample_SetDefaultsEx

fmod

FSOUND_Sample_SetDefaultsEx

fmoddyn

FSOUND_Sample_SetLoopPoints

fmoddyn

FSOUND_Sample_SetLoopPoints

fmod

FSOUND_Sample_SetMaxPlaybacks

fmod

FSOUND_Sample_SetMaxPlaybacks

fmoddyn

FSOUND_Sample_SetMinMaxDistance

fmoddyn

FSOUND_Sample_SetMinMaxDistance

fmod

FSOUND_Sample_SetMode

fmod

FSOUND_Sample_SetMode

fmoddyn

FSOUND_Sample_Unlock

fmod

FSOUND_Sample_Unlock

fmoddyn

FSOUND_Sample_Upload

fmoddyn

FSOUND_Sample_Upload

fmod

FSOUND_SetBufferSize

fmod

FSOUND_SetBufferSize

fmoddyn

FSOUND_SetCurrentPosition

fmod

FSOUND_SetCurrentPosition

fmoddyn

FSOUND_SetDriver

fmod

FSOUND_SetDriver

fmoddyn

FSOUND_SetFrequency

fmod

FSOUND_SetFrequency

fmoddyn

FSOUND_SetHWND

fmoddyn

FSOUND_SetHWND

fmod

FSOUND_SetLoopMode

fmod

FSOUND_SetLoopMode

fmoddyn

FSOUND_SetMaxHardwareChannels

fmod

FSOUND_SetMaxHardwareChannels

fmoddyn

FSOUND_SetMemorySystem

fmoddyn

FSOUND_SetMemorySystem

fmod

FSOUND_SetMinHardwareChannels

fmod

FSOUND_SetMinHardwareChannels

fmoddyn

FSOUND_SetMixer

fmoddyn

FSOUND_SetMixer

fmod

FSOUND_SetMute

fmod

FSOUND_SetMute

fmoddyn

FSOUND_SetOutput

fmod

FSOUND_SetOutput

fmoddyn

FSOUND_SetPan

fmoddyn

FSOUND_SetPan

fmod

FSOUND_SetPanSeperation

fmod

FSOUND_SetPanSeperation

fmoddyn

FSOUND_SetPaused

fmod

FSOUND_SetPaused

fmoddyn

FSOUND_SetPriority

fmod

FSOUND_SetPriority

fmoddyn

FSOUND_SetReserved

fmod

FSOUND_SetReserved

fmoddyn

FSOUND_SetSFXMasterVolume

fmoddyn

FSOUND_SetSFXMasterVolume

fmod

FSOUND_SetSpeakerMode

fmoddyn

FSOUND_SetSpeakerMode

fmod

FSOUND_SetSurround

fmod

FSOUND_SetSurround

fmoddyn

FSOUND_SetVolume

fmod

FSOUND_SetVolume

fmoddyn

FSOUND_SetVolumeAbsolute

fmoddyn

FSOUND_SetVolumeAbsolute

fmod

FSOUND_SIGNED

fmodtypes

FSOUND_SPEAKERMODES

fmodtypes

FSOUND_STEREO

fmodtypes

FSOUND_STEREOPAN

fmodtypes

FSOUND_StopSound

fmod

FSOUND_StopSound

fmoddyn

FSOUND_STREAMABLE

fmodtypes

FSOUND_Stream_AddSyncPoint

fmoddyn

FSOUND_Stream_AddSyncPoint

fmod

FSOUND_Stream_Close

fmoddyn

FSOUND_Stream_Close

fmod

FSOUND_Stream_Create

fmoddyn

FSOUND_Stream_Create

fmod

FSOUND_Stream_CreateDSP

fmoddyn

FSOUND_Stream_CreateDSP

fmod

FSOUND_Stream_DeleteSyncPoint

fmoddyn

FSOUND_Stream_DeleteSyncPoint

fmod

FSOUND_Stream_FindTagField

fmoddyn

FSOUND_Stream_FindTagField

fmod

FSOUND_Stream_GetLength

fmod

FSOUND_Stream_GetLength

fmoddyn

FSOUND_Stream_GetLengthMs

fmod

FSOUND_Stream_GetLengthMs

fmoddyn

FSOUND_Stream_GetMode

fmod

FSOUND_Stream_GetMode

fmoddyn

FSOUND_Stream_GetNumSubStreams

fmod

FSOUND_Stream_GetNumSubStreams

fmoddyn

FSOUND_Stream_GetNumSyncPoints

fmod

FSOUND_Stream_GetNumSyncPoints

fmoddyn

FSOUND_Stream_GetNumTagFields

fmoddyn

FSOUND_Stream_GetNumTagFields

fmod

FSOUND_Stream_GetOpenState

fmoddyn

FSOUND_Stream_GetOpenState

fmod

FSOUND_Stream_GetPosition

fmod

FSOUND_Stream_GetPosition

fmoddyn

FSOUND_Stream_GetSample

fmoddyn

FSOUND_Stream_GetSample

fmod

FSOUND_Stream_GetSyncPoint

fmod

FSOUND_Stream_GetSyncPoint

fmoddyn

FSOUND_Stream_GetSyncPointInfo

fmod

FSOUND_Stream_GetSyncPointInfo

fmoddyn

FSOUND_Stream_GetTagField

fmod

FSOUND_Stream_GetTagField

fmoddyn

FSOUND_Stream_GetTime

fmod

FSOUND_Stream_GetTime

fmoddyn

FSOUND_Stream_Net_GetBufferProperties

fmoddyn

FSOUND_Stream_Net_GetBufferProperties

fmod

FSOUND_Stream_Net_GetLastServerStatus

fmod

FSOUND_Stream_Net_GetLastServerStatus

fmoddyn

FSOUND_Stream_Net_GetStatus

fmod

FSOUND_Stream_Net_GetStatus

fmoddyn

FSOUND_Stream_Net_SetBufferProperties

fmoddyn

FSOUND_Stream_Net_SetBufferProperties

fmod

FSOUND_Stream_Net_SetMetadataCallback

fmod

FSOUND_Stream_Net_SetMetadataCallback

fmoddyn

FSOUND_Stream_Net_SetProxy

fmod

FSOUND_Stream_Net_SetProxy

fmoddyn

FSOUND_Stream_Open

fmod

FSOUND_Stream_Open

fmoddyn

FSOUND_Stream_Play

fmod

FSOUND_Stream_Play

fmoddyn

FSOUND_Stream_PlayEx

fmod

FSOUND_Stream_PlayEx

fmoddyn

FSOUND_Stream_SetBufferSize

fmoddyn

FSOUND_Stream_SetBufferSize

fmod

FSOUND_Stream_SetEndCallback

fmoddyn

FSOUND_Stream_SetEndCallback

fmod

FSOUND_Stream_SetLoopCount

fmoddyn

FSOUND_Stream_SetLoopCount

fmod

FSOUND_Stream_SetLoopPoints

fmod

FSOUND_Stream_SetLoopPoints

fmoddyn

FSOUND_Stream_SetMode

fmod

FSOUND_Stream_SetMode

fmoddyn

FSOUND_Stream_SetPosition

fmod

FSOUND_Stream_SetPosition

fmoddyn

FSOUND_Stream_SetSubStream

fmod

FSOUND_Stream_SetSubStream

fmoddyn

FSOUND_Stream_SetSubStreamSentence

fmod

FSOUND_Stream_SetSubStreamSentence

fmoddyn

FSOUND_Stream_SetSyncCallback

fmoddyn

FSOUND_Stream_SetSyncCallback

fmod

FSOUND_Stream_SetTime

fmoddyn

FSOUND_Stream_SetTime

fmod

FSOUND_Stream_Stop

fmoddyn

FSOUND_Stream_Stop

fmod

FSOUND_SYSTEMCHANNEL

fmodtypes

FSOUND_SYSTEMSAMPLE

fmodtypes

FSOUND_UNMANAGED

fmodtypes

FSOUND_UNSIGNED

fmodtypes

FSOUND_Update

fmoddyn

FSOUND_Update

fmod

FSOUND_USECORE0

fmodtypes

FSOUND_USECORE1

fmodtypes

FSOUND_VAG

fmodtypes

FSOUND_XADPCM

fmodtypes

FTC_CMapCache

LIBFREETYPE

FTC_CMapCacheRec_

LIBFREETYPE

FTC_CMapCache_Lookup

LIBFREETYPE

FTC_CMapCache_New

LIBFREETYPE

FTC_FaceID

LIBFREETYPE

FTC_Face_Requester

LIBFREETYPE

FTC_ImageCache

LIBFREETYPE

FTC_ImageCacheRec_

LIBFREETYPE

FTC_ImageCache_Lookup

LIBFREETYPE

FTC_ImageCache_LookupScaler

LIBFREETYPE

FTC_ImageCache_New

LIBFREETYPE

FTC_ImageType

LIBFREETYPE

FTC_ImageTypeRec_

LIBFREETYPE

FTC_Manager

LIBFREETYPE

FTC_ManagerRec_

LIBFREETYPE

FTC_Manager_Done

LIBFREETYPE

FTC_Manager_LookupFace

LIBFREETYPE

FTC_Manager_LookupSize

LIBFREETYPE

FTC_Manager_New

LIBFREETYPE

FTC_Manager_RemoveFaceID

LIBFREETYPE

FTC_Manager_Reset

LIBFREETYPE

FTC_Node

LIBFREETYPE

FTC_NodeRec_

LIBFREETYPE

FTC_Node_Unref

LIBFREETYPE

FTC_SBit

LIBFREETYPE

FTC_SBitCache

LIBFREETYPE

FTC_SBitCacheRec_

LIBFREETYPE

FTC_SBitCache_Lookup

LIBFREETYPE

FTC_SBitCache_LookupScaler

LIBFREETYPE

FTC_SBitCache_New

LIBFREETYPE

FTC_SBitRec_

LIBFREETYPE

FTC_Scaler

LIBFREETYPE

FTC_ScalerRec_

LIBFREETYPE

FTLIBNAME

LIBFREETYPE

FT_Activate_Size

LIBFREETYPE

FT_Add_Default_Modules

LIBFREETYPE

FT_Add_Module

LIBFREETYPE

FT_Alloc_Func

LIBFREETYPE

FT_Angle

LIBFREETYPE

FT_Angle_Diff

LIBFREETYPE

FT_Atan2

LIBFREETYPE

FT_Attach_File

LIBFREETYPE

FT_Attach_Stream

LIBFREETYPE

FT_BBox

LIBFREETYPE

FT_BBox_ptr

LIBFREETYPE

FT_Bitmap

LIBFREETYPE

FT_Bitmap_Convert

LIBFREETYPE

FT_Bitmap_Copy

LIBFREETYPE

FT_Bitmap_Done

LIBFREETYPE

FT_Bitmap_Embolden

LIBFREETYPE

FT_Bitmap_New

LIBFREETYPE

FT_Bitmap_ptr

LIBFREETYPE

FT_Bitmap_Size

LIBFREETYPE

FT_Bitmap_Size_ptr

LIBFREETYPE

FT_Bool

LIBFREETYPE

FT_Byte

LIBFREETYPE

FT_Bytes

LIBFREETYPE

FT_Byte_array

LIBFREETYPE

FT_Byte_ptr

LIBFREETYPE

FT_CeilFix

LIBFREETYPE

FT_Char

LIBFREETYPE

FT_Charmap

LIBFREETYPE

FT_CharmapRec_

LIBFREETYPE

FT_Charmap_array

LIBFREETYPE

FT_Charmap_ptr

LIBFREETYPE

FT_ClassicKern_Free

LIBFREETYPE

FT_ClassicKern_Validate

LIBFREETYPE

FT_Cos

LIBFREETYPE

FT_Curve_Tag

LIBFREETYPE

FT_CURVE_TAG_CONIC

LIBFREETYPE

FT_CURVE_TAG_CUBIC

LIBFREETYPE

FT_CURVE_TAG_ON

LIBFREETYPE

FT_DebugHook_Func

LIBFREETYPE

FT_DivFix

LIBFREETYPE

FT_Done_Face

LIBFREETYPE

FT_Done_FreeType

LIBFREETYPE

FT_Done_Glyph

LIBFREETYPE

FT_Done_Library

LIBFREETYPE

FT_Done_Size

LIBFREETYPE

FT_Encoding

LIBFREETYPE

FT_ENCODING_NONE

LIBFREETYPE

FT_Error

LIBFREETYPE

FT_F26Dot6

LIBFREETYPE

FT_Face

LIBFREETYPE

FT_FaceRec_

LIBFREETYPE

FT_Face_array

LIBFREETYPE

FT_Face_CheckTrueTypePatents

LIBFREETYPE

FT_FACE_FLAG_KERNING

LIBFREETYPE

FT_FACE_FLAG_SCALABLE

LIBFREETYPE

FT_Face_ptr

LIBFREETYPE

FT_Face_SetUnpatentedHinting

LIBFREETYPE

FT_Fixed

LIBFREETYPE

FT_Fixed_ptr

LIBFREETYPE

FT_FloorFix

LIBFREETYPE

FT_Free_Func

LIBFREETYPE

FT_Generic

LIBFREETYPE

FT_Generic_Finalizer

LIBFREETYPE

FT_Get_Charmap_Index

LIBFREETYPE

FT_Get_Char_Index

LIBFREETYPE

FT_Get_CMap_Format

LIBFREETYPE

FT_Get_CMap_Language_ID

LIBFREETYPE

FT_Get_First_Char

LIBFREETYPE

FT_Get_Glyph

LIBFREETYPE

FT_Get_Glyph_Name

LIBFREETYPE

FT_Get_Kerning

LIBFREETYPE

FT_Get_MM_Var

LIBFREETYPE

FT_Get_Module

LIBFREETYPE

FT_Get_Multi_Master

LIBFREETYPE

FT_Get_Name_Index

LIBFREETYPE

FT_Get_Next_Char

LIBFREETYPE

FT_Get_PFR_Advance

LIBFREETYPE

FT_Get_PFR_Kerning

LIBFREETYPE

FT_Get_PFR_Metrics

LIBFREETYPE

FT_Get_Postscript_Name

LIBFREETYPE

FT_Get_PS_Font_Info

LIBFREETYPE

FT_Get_PS_Font_Private

LIBFREETYPE

FT_Get_Renderer

LIBFREETYPE

FT_Get_Sfnt_Name

LIBFREETYPE

FT_Get_Sfnt_Name_Count

LIBFREETYPE

FT_Get_Sfnt_Table

LIBFREETYPE

FT_Get_SubGlyph_Info

LIBFREETYPE

FT_Get_Track_Kerning

LIBFREETYPE

FT_Get_TrueType_Engine_Type

LIBFREETYPE

FT_Get_WinFNT_Header

LIBFREETYPE

FT_Glyph

LIBFREETYPE

FT_GlyphRec_

LIBFREETYPE

FT_GlyphSlot

LIBFREETYPE

FT_GlyphSlotRec_

LIBFREETYPE

FT_GlyphSlot_Embolden

LIBFREETYPE

FT_GlyphSlot_Oblique

LIBFREETYPE

FT_GlyphSlot_Own_Bitmap

LIBFREETYPE

FT_Glyph_Class

LIBFREETYPE

FT_Glyph_ClassRec_

LIBFREETYPE

FT_Glyph_Copy

LIBFREETYPE

FT_Glyph_Format

LIBFREETYPE

FT_Glyph_Get_CBox

LIBFREETYPE

FT_Glyph_Metrics

LIBFREETYPE

FT_Glyph_Stroke

LIBFREETYPE

FT_Glyph_StrokeBorder

LIBFREETYPE

FT_Glyph_To_Bitmap

LIBFREETYPE

FT_Glyph_Transform

LIBFREETYPE

FT_Has_Kerning

LIBFREETYPE

FT_Has_PS_Glyph_Names

LIBFREETYPE

FT_Init_FreeType

LIBFREETYPE

FT_Int

LIBFREETYPE

FT_Int32

LIBFREETYPE

FT_Is_Scalable

LIBFREETYPE

FT_KERNING_DEFAULT

LIBFREETYPE

FT_KERNING_UNFITTED

LIBFREETYPE

FT_KERNING_UNSCALED

LIBFREETYPE

FT_Library

LIBFREETYPE

FT_LibraryRec_

LIBFREETYPE

FT_Library_array

LIBFREETYPE

FT_Library_ptr

LIBFREETYPE

FT_Library_Version

LIBFREETYPE

FT_List

LIBFREETYPE

FT_ListNode

LIBFREETYPE

FT_ListNodeRec_

LIBFREETYPE

FT_ListRec_

LIBFREETYPE

FT_List_Add

LIBFREETYPE

FT_List_Destructor

LIBFREETYPE

FT_List_Finalize

LIBFREETYPE

FT_List_Find

LIBFREETYPE

FT_List_Insert

LIBFREETYPE

FT_List_Iterate

LIBFREETYPE

FT_List_Iterator

LIBFREETYPE

FT_List_Remove

LIBFREETYPE

FT_List_Up

LIBFREETYPE

FT_Load_Char

LIBFREETYPE

FT_LOAD_DEFAULT

LIBFREETYPE

FT_LOAD_FORCE_AUTOHINT

LIBFREETYPE

FT_Load_Glyph

LIBFREETYPE

FT_LOAD_NO_HINTING

LIBFREETYPE

FT_Load_Sfnt_Table

LIBFREETYPE

FT_Long

LIBFREETYPE

FT_Long_ptr

LIBFREETYPE

FT_Matrix

LIBFREETYPE

FT_Matrix_Invert

LIBFREETYPE

FT_Matrix_Multiply

LIBFREETYPE

FT_Memory

LIBFREETYPE

FT_MemoryRec_

LIBFREETYPE

FT_MM_Axis

LIBFREETYPE

FT_MM_Var

LIBFREETYPE

FT_Module

LIBFREETYPE

FT_ModuleRec_

LIBFREETYPE

FT_Module_Class

LIBFREETYPE

FT_MulDiv

LIBFREETYPE

FT_MulFix

LIBFREETYPE

FT_Multi_Master

LIBFREETYPE

FT_New_Face

LIBFREETYPE

FT_New_Library

LIBFREETYPE

FT_New_Memory_Face

LIBFREETYPE

FT_New_Size

LIBFREETYPE

FT_OpenType_Free

LIBFREETYPE

FT_OpenType_Validate

LIBFREETYPE

FT_Open_Args

LIBFREETYPE

FT_OPEN_DRIVER

LIBFREETYPE

FT_Open_Face

LIBFREETYPE

FT_OPEN_MEMORY

LIBFREETYPE

FT_OPEN_PARAMS

LIBFREETYPE

FT_OPEN_PATHNAME

LIBFREETYPE

FT_OPEN_STREAM

LIBFREETYPE

FT_Orientation

LIBFREETYPE

FT_Outline

LIBFREETYPE

FT_OutlineRec_

LIBFREETYPE

FT_Outline_Check

LIBFREETYPE

FT_Outline_ConicToFunc

LIBFREETYPE

FT_Outline_Copy

LIBFREETYPE

FT_Outline_CubicToFunc

LIBFREETYPE

FT_Outline_Decompose

LIBFREETYPE

FT_Outline_Done

LIBFREETYPE

FT_Outline_Done_Internal

LIBFREETYPE

FT_Outline_Embolden

LIBFREETYPE

FT_OUTLINE_EVEN_ODD_FILL

LIBFREETYPE

FT_Outline_Funcs

LIBFREETYPE

FT_Outline_GetInsideBorder

LIBFREETYPE

FT_Outline_GetOutsideBorder

LIBFREETYPE

FT_Outline_Get_BBox

LIBFREETYPE

FT_Outline_Get_Bitmap

LIBFREETYPE

FT_Outline_Get_CBox

LIBFREETYPE

FT_Outline_Get_Orientation

LIBFREETYPE

FT_OUTLINE_HIGH_PRECISION

LIBFREETYPE

FT_OUTLINE_IGNORE_DROPOUTS

LIBFREETYPE

FT_Outline_LineToFunc

LIBFREETYPE

FT_Outline_MoveToFunc

LIBFREETYPE

FT_Outline_New

LIBFREETYPE

FT_Outline_New_Internal

LIBFREETYPE

FT_OUTLINE_NONE

LIBFREETYPE

FT_OUTLINE_OWNER

LIBFREETYPE

FT_Outline_Render

LIBFREETYPE

FT_Outline_Reverse

LIBFREETYPE

FT_OUTLINE_REVERSE_FILL

LIBFREETYPE

FT_OUTLINE_SINGLE_PASS

LIBFREETYPE

FT_Outline_Transform

LIBFREETYPE

FT_Outline_Translate

LIBFREETYPE

FT_Parameter

LIBFREETYPE

FT_Pointer

LIBFREETYPE

FT_Pos

LIBFREETYPE

FT_Raster

LIBFREETYPE

FT_RasterRec_

LIBFREETYPE

FT_Raster_BitSet_Func

LIBFREETYPE

FT_Raster_BitTest_Func

LIBFREETYPE

FT_Raster_DoneFunc

LIBFREETYPE

FT_Raster_Funcs

LIBFREETYPE

FT_Raster_NewFunc

LIBFREETYPE

FT_Raster_Params

LIBFREETYPE

FT_Raster_RenderFunc

LIBFREETYPE

FT_Raster_Render_Func

LIBFREETYPE

FT_Raster_ResetFunc

LIBFREETYPE

FT_Raster_SetModeFunc

LIBFREETYPE

FT_Realloc_Func

LIBFREETYPE

FT_Remove_Module

LIBFREETYPE

FT_Renderer

LIBFREETYPE

FT_RendererRec_

LIBFREETYPE

FT_Renderer_Class

LIBFREETYPE

FT_Renderer_GetCBoxFunc

LIBFREETYPE

FT_Renderer_RenderFunc

LIBFREETYPE

FT_Renderer_SetModeFunc

LIBFREETYPE

FT_Renderer_TransformFunc

LIBFREETYPE

FT_Render_Glyph

LIBFREETYPE

FT_Render_Mode

LIBFREETYPE

FT_RENDER_MODE_LCD

LIBFREETYPE

FT_RENDER_MODE_LCD_V

LIBFREETYPE

FT_RENDER_MODE_LIGHT

LIBFREETYPE

FT_RENDER_MODE_MAX

LIBFREETYPE

FT_RENDER_MODE_MONO

LIBFREETYPE

FT_RENDER_MODE_NORMAL

LIBFREETYPE

FT_Request_Size

LIBFREETYPE

FT_RoundFix

LIBFREETYPE

FT_Select_Charmap

LIBFREETYPE

FT_Select_Size

LIBFREETYPE

FT_Set_Charmap

LIBFREETYPE

FT_Set_Char_Size

LIBFREETYPE

FT_Set_Debug_Hook

LIBFREETYPE

FT_Set_MM_Blend_Coordinates

LIBFREETYPE

FT_Set_MM_Design_Coordinates

LIBFREETYPE

FT_Set_Pixel_Sizes

LIBFREETYPE

FT_Set_Renderer

LIBFREETYPE

FT_Set_Transform

LIBFREETYPE

FT_Set_Var_Blend_Coordinates

LIBFREETYPE

FT_Set_Var_Design_Coordinates

LIBFREETYPE

FT_SfntName

LIBFREETYPE

FT_Sfnt_Table_Info

LIBFREETYPE

FT_Sfnt_Tag

LIBFREETYPE

FT_Short

LIBFREETYPE

FT_Short_array

LIBFREETYPE

FT_Short_ptr

LIBFREETYPE

FT_Sin

LIBFREETYPE

FT_Size

LIBFREETYPE

FT_SizeRec_

LIBFREETYPE

FT_Size_Metrics

LIBFREETYPE

FT_Size_Request

LIBFREETYPE

FT_Size_RequestRec_

LIBFREETYPE

FT_Size_Request_Type

LIBFREETYPE

FT_Span

LIBFREETYPE

FT_SpanFunc

LIBFREETYPE

FT_Stream

LIBFREETYPE

FT_StreamDesc

LIBFREETYPE

FT_StreamRec_

LIBFREETYPE

FT_Stream_CloseFunc

LIBFREETYPE

FT_Stream_IoFunc

LIBFREETYPE

FT_Stream_OpenGzip

LIBFREETYPE

FT_Stream_OpenLZW

LIBFREETYPE

FT_String

LIBFREETYPE

FT_Stroker

LIBFREETYPE

FT_StrokerBorder

LIBFREETYPE

FT_StrokerRec_

LIBFREETYPE

FT_Stroker_BeginSubPath

LIBFREETYPE

FT_Stroker_ConicTo

LIBFREETYPE

FT_Stroker_CubicTo

LIBFREETYPE

FT_Stroker_Done

LIBFREETYPE

FT_Stroker_EndSubPath

LIBFREETYPE

FT_Stroker_Export

LIBFREETYPE

FT_Stroker_ExportBorder

LIBFREETYPE

FT_Stroker_GetBorderCounts

LIBFREETYPE

FT_Stroker_GetCounts

LIBFREETYPE

FT_Stroker_LineCap

LIBFREETYPE

FT_Stroker_LineJoin

LIBFREETYPE

FT_Stroker_LineTo

LIBFREETYPE

FT_Stroker_New

LIBFREETYPE

FT_Stroker_ParseOutline

LIBFREETYPE

FT_Stroker_Rewind

LIBFREETYPE

FT_Stroker_Set

LIBFREETYPE

FT_STYLE_FLAG_BOLD

LIBFREETYPE

FT_STYLE_FLAG_ITALIC

LIBFREETYPE

FT_Subglyph

LIBFREETYPE

FT_Subglyph_ptr

LIBFREETYPE

FT_Tables

LIBFREETYPE

FT_Tan

LIBFREETYPE

FT_TrueTypeEngineType

LIBFREETYPE

FT_TrueTypeGX_Free

LIBFREETYPE

FT_TrueTypeGX_Validate

LIBFREETYPE

FT_UInt

LIBFREETYPE

FT_UInt32

LIBFREETYPE

FT_UInt_ptr

LIBFREETYPE

FT_ULong

LIBFREETYPE

FT_UShort

LIBFREETYPE

FT_VALIDATE_bsln_INDEX

LIBFREETYPE

FT_VALIDATE_feat_INDEX

LIBFREETYPE

FT_VALIDATE_GX_LAST_INDEX

LIBFREETYPE

FT_VALIDATE_GX_LENGTH

LIBFREETYPE

FT_VALIDATE_just_INDEX

LIBFREETYPE

FT_VALIDATE_kern_INDEX

LIBFREETYPE

FT_VALIDATE_lcar_INDEX

LIBFREETYPE

FT_VALIDATE_mort_INDEX

LIBFREETYPE

FT_VALIDATE_morx_INDEX

LIBFREETYPE

FT_VALIDATE_opbd_INDEX

LIBFREETYPE

FT_VALIDATE_prop_INDEX

LIBFREETYPE

FT_VALIDATE_trak_INDEX

LIBFREETYPE

FT_Var_Axis

LIBFREETYPE

FT_Var_Named_Style

LIBFREETYPE

FT_Vector

LIBFREETYPE

FT_Vector_array

LIBFREETYPE

FT_Vector_From_Polar

LIBFREETYPE

FT_Vector_Length

LIBFREETYPE

FT_Vector_Polarize

LIBFREETYPE

FT_Vector_ptr

LIBFREETYPE

FT_Vector_Rotate

LIBFREETYPE

FT_Vector_Transform

LIBFREETYPE

FT_Vector_Unit

LIBFREETYPE

FT_WinFNT_HeaderRec

LIBFREETYPE

G2_GetVertBoneIndex

FileGL2

G2_GetVertBoneWeight

FileGL2

G2_GetVertWeights

FileGL2

GammaCorrectRGBArray

GLGraphics

GenerateBezierCurve

CurvesAndSurfaces

GenerateBezierSurface

CurvesAndSurfaces

GenerateBSpline

CurvesAndSurfaces

GenerateBSplineSurface

CurvesAndSurfaces

GenerateKnotVector

CurvesAndSurfaces

GeometryOptimizationMode

VectorGeometry

Returns the detected optimization mode.<p> Returned values is either 'FPU', '3DNow!' or 'SSE'.

GetActiveLightsList

GLCustomShader

GetAmbientLightMotion

Utils3DS

GetArchiveFileFormats

GLSArchiveManager

GetArchiveManager

GLSArchiveManager

GetAtmosphere

Utils3DS

GetBackground

Utils3DS

GetBestSelectorClass

GLSelection

GetBodyFromGLSceneObject

GLNGDManager

GetBodyFromGLSceneObject

GLODEManager

GetBodyFromObject

GLODEManager

Helper functions for extracting data from objects with different inheritance.

GetBodyPositionAsAffineVector

ODEGL

GetBValue

GLColor

GetCameraByIndex

Utils3DS

GetCameraCount

Utils3DS

GetCameraMotion

Utils3DS

GetCameraMotionByIndex

Utils3DS

GetCameraNodeCount

Utils3DS

GetCameraNodeNameList

Utils3DS

GetChannelTypeAndNum

GLSCUDA

GetChunkValue

Utils3DS

GetContentDir

LWObjects

GetCurrentColorDepth

GLCrossPlatform

Number of bits per pixel for the current desktop resolution.

GetCurrentRenderingObject

GLScene

GetDatabaseRelease

Utils3DS

GetDecimalSeparator

GLCrossPlatform

GetDeviceLogicalPixelsX

GLCrossPlatform

Number of pixels per logical inch along the screen width for the device.<p> Under Win32 awaits a HDC and returns its LOGPIXELSX.

getenv

GLSDL

GetFPSMovement

GLFPSMovement

GetFPSMovement

GLFPSMovement

GetGenericCompressedFormat

GLTextureFormat

Give generic compressed OpenGL texture format.

GetGLSceneObject

GLODEManager

GetGLSoundFileFormats

GLSoundFileObjects

GetGLTextureImageClassesAsStrings

GLTexture

Creates a TStrings with the list of registered TGLTextureImageClass.<p> To be freed by caller.

GetGValue

GLColor

GetImageLodNumber

GLGraphics

Return an optimal number of texture pyramid

GetIndexFromResolution

GLScreen

GetInertia

GLBehaviours

Returns or creates the TGLBInertia within the given behaviours.<p> This helper function is convenient way to access a TGLBInertia.

GetJPEGInfo

GLSJPG

GetJPEGInfo

GLSJPG

GETJSAMPLE

GLSJPG

GetKfRelease

Utils3DS

GetKFSettings

Utils3DS

GetM3dMagicRelease

Utils3DS

GetMaterialByIndex

Utils3DS

GetMaterialCount

Utils3DS

GetMeshByIndex

Utils3DS

GetMeshCount

Utils3DS

GetMeshRelease

Utils3DS

GetMeshSet

Utils3DS

GetModuleSymbol

GLSModuleLoader

GetModuleSymbolEx

GLSModuleLoader

GetMovement

GLMovement

GetMovement

GLMovement

GetNGDDynamic

GLNGDManager

GetNGDStatic

GLNGDManager

GetObjectMotionByIndex

Utils3DS

GetObjectMotionByName

Utils3DS

GetObjectNodeCount

Utils3DS

GetObjectNodeNameList

Utils3DS

GetOdeDynamic

GLODEManager

GetODEHeightField

GLODECustomColliders

GetOdeStatic

GLODEManager

GetOmnilightByIndex

Utils3DS

GetOmnilightCount

Utils3DS

GetOmnilightMotionByIndex

Utils3DS

GetOmnilightMotionByName

Utils3DS

GetOmnilightNodeCount

Utils3DS

GetOmnilightNodeNameList

Utils3DS

GetOpenFileNamePreview

GLSVfw

GetOpenFileNamePreviewA

GLSVfw

GetOpenFileNamePreviewW

GLSVfw

GetOrCreateAcceleration

GLBehaviours

GetOrCreateAcceleration

GLBehaviours

Returns or creates the TGLBAcceleration within the given behaviours.<p> This helper function is convenient way to access a TGLBAcceleration.

GetOrCreateCollision

GLCollision

Returns or creates the TGLBCollision within the given object's behaviours.<p> This helper function is convenient way to access a TGLBCollision.

GetOrCreateCollision

GLCollision

Returns or creates the TGLBCollision within the given behaviours.<p> This helper function is convenient way to access a TGLBCollision.

GetOrCreateDCEDynamic

GLDCE

GetOrCreateDCEDynamic

GLDCE

GetOrCreateDCEStatic

GLDCE

GetOrCreateDCEStatic

GLDCE

GetOrCreateFireFX

GLFireFX

Returns or creates the TGLBFireFX within the given behaviours.<p> This helper function is convenient way to access a TGLBFireFX.

GetOrCreateFireFX

GLFireFX

Returns or creates the TGLBFireFX within the given object's behaviours.<p> This helper function is convenient way to access a TGLBFireFX.

GetOrCreateFPSMovement

GLFPSMovement

GetOrCreateFPSMovement

GLFPSMovement

GetOrCreateInertia

GLBehaviours

GetOrCreateInertia

GLBehaviours

GetOrCreateMovement

GLMovement

GetOrCreateMovement

GLMovement

GetOrCreateNGDDynamic

GLNGDManager

GetOrCreateNGDStatic

GLNGDManager

GetOrCreateOdeDynamic

GLODEManager

GetOrCreateODEHeightField

GLODECustomColliders

GetOrCreateOdeStatic

GLODEManager

GetOrCreateSoundEmitter

GLSound

GetOrCreateSoundEmitter

GLSound

GetOrCreateSourcePFX

GLParticleFX

Returns or creates the TGLBInertia within the given object's behaviours.<p>

GetOrCreateThorFX

GLThorFX

GetPlatformInfo

GLCrossPlatform

GetPlatformVersion

GLCrossPlatform

GetPlatformVersionStr

GLCrossPlatform

GetRasterFileFormats

GLGraphics

Read access to the list of registered vector file formats

GetROAMTrianglesCapacity

GLROAMPatch

GetRValue

GLColor

GetSafeTurnAngle

VectorGeometry

GetSafeTurnAngle

VectorGeometry

Calculates angles for the Camera.MoveAroundTarget(pitch, turn) procedure. Initially from then GLCameraColtroller unit, requires AOriginalUpVector to contain only -1, 0 or 1. Result contains pitch and turn angles.

GetSaveFileNamePreview

GLSVfw

GetSaveFileNamePreviewA

GLSVfw

GetSaveFileNamePreviewW

GLSVfw

GetServiceWindow

GLContext

GetSoundLibraryByName

GLSound

GetSpotlightByIndex

Utils3DS

GetSpotlightCount

Utils3DS

GetSpotlightMotionByIndex

Utils3DS

GetSpotlightMotionByName

Utils3DS

GetSpotlightNodeCount

Utils3DS

GetSpotlightNodeNameList

Utils3DS

GetSqrt255Array

GLUtils

Returns a pointer to an array containing the results of "255*sqrt(i/255)".

GetSurfaceFromObject

GLODEManager

GetTextureCombiners

GLTextureCombiners

Parses a TC text description and setups combiners accordingly.<p> *experimental*<br> Knowledge of texture combiners is a requirement<br> Syntax: pascal-like, one instruction per line, use '//' for comment.<p>
Examples:<ul> <li>Tex1:=Tex0; // replace texture 1 with texture 0 <li>Tex1:=Tex0+Tex1; // additive blending between textures 0 and 1 <li>Tex1:=Tex0-Tex1; // subtractive blending between textures 0 and 1 <li>Tex1:=Tex0*Tex1; // modulation between textures 0 and 1 <li>Tex1:=Tex0+Tex1-0.5; // signed additive blending between textures 0 and 1 <li>Tex1:=Interpolate(Tex0, Tex1, PrimaryColor); // interpolation between textures 0 and 1 using primary color as factor <li>Tex1:=Dot3(Tex0, Tex1); // dot3 product between textures 0 and 1 </ul><p>
Accepted tokens:<ul> <li>Tex0, Tex1, etc. : texture unit <li>PrimaryColor, Col : the primary color <li>ConstantColor, EnvCol : texture environment constant color </ul><br> Tokens can be qualified with '.a' or '.alpha' to specify the alpha channel explicitly, and '.rgb' to specify color channels (default). You cannot mix alpha and rgb tokens in the same line.

GetTextureElementSize

GLTextureFormat

Give a pixel size in bytes from texture format or data format.

GetTextureElementSize

GLTextureFormat

GetUncompressedFormat

GLTextureFormat

Give uncompressed texture format and OpenGL color format.

GetUniformAutoSetMethod

GLSLParameter

GetUniformAutoSetMethodName

GLSLParameter

GetValueFromStringsIndex

GLCrossPlatform

GetVectorFileFormats

GLVectorFileObjects

Read access to the list of registered vector file formats

GetViewport

Utils3DS

GetXCollectionClassesList

XCollection

GetXCollectionItemClassesList

XCollection

Creates and returns a copy of internal list of TXCollectionItem classes.<p> Returned list should be freed by caller, the parameter defines an ancestor class filter. If baseClass is left nil, TXCollectionItem is used as ancestor.

GetXMLAttribute

GLSCrossXML

GetXMLAttribute

GLSCrossXML

GetXMLAttributeCount

GLSCrossXML

GetXMLText

GLSCrossXML

get_crc_table

GLSZLibExApi

Get_CUDA_API_Error_String

GLS_CUDA_API

Get_CUDA_FFT_Error_String

GLS_CUDA_FourierTransform

GL

GLContext

glAccum

OpenGL1x

glActiveShaderProgram

OpenGL1x

glActiveStencilFaceEXT

OpenGL1x

glActiveTexture

OpenGL1x

glActiveTextureARB

OpenGL1x

glActiveVaryingNV

OpenGL1x

glAddSwapHintRectWIN

OpenGL1x

glAlphaFunc

OpenGL1x

glAreProgramsResidentNV

OpenGL1x

glAreTexturesResident

OpenGL1x

glAreTexturesResidentEXT

OpenGL1x

glArrayElement

OpenGL1x

glArrayElementArrayEXT

OpenGL1x

glAttachObjectARB

OpenGL1x

glAttachShader

OpenGL1x

glBegin

OpenGL1x

glBeginConditionalRender

OpenGL1x

glBeginConditionalRenderNV

OpenGL1x

glBeginOcclusionQueryNV

OpenGL1x

glBeginQuery

OpenGL1x

glBeginQueryARB

OpenGL1x

glBeginQueryIndexed

OpenGL1x

glBeginSceneEXT

OpenGL1x

glBeginTransformFeedback

OpenGL1x

glBeginTransformFeedbackEXT

OpenGL1x

glBeginTransformFeedbackNV

OpenGL1x

glBindAttribLocation

OpenGL1x

glBindAttribLocationARB

OpenGL1x

glBindBuffer

OpenGL1x

glBindBufferARB

OpenGL1x

glBindBufferBase

OpenGL1x

glBindBufferBaseEXT

OpenGL1x

glBindBufferBaseNV

OpenGL1x

glBindBufferOffsetEXT

OpenGL1x

glBindBufferOffsetNV

OpenGL1x

glBindBufferRange

OpenGL1x

glBindBufferRangeEXT

OpenGL1x

glBindBufferRangeNV

OpenGL1x

glBindFragDataLocation

OpenGL1x

glBindFragDataLocationEXT

OpenGL1x

glBindFragDataLocationIndexed

OpenGL1x

glBindFramebuffer

OpenGL1x

glBindFramebufferEXT

OpenGL1x

glBindProgramARB

OpenGL1x

glBindProgramNV

OpenGL1x

glBindProgramPipeline

OpenGL1x

glBindRenderbuffer

OpenGL1x

glBindRenderbufferEXT

OpenGL1x

glBindSampler

OpenGL1x

glBindTexture

OpenGL1x

glBindTextureEXT

OpenGL1x

glBindTransformFeedback

OpenGL1x

glBindVertexArray

OpenGL1x

GLbitfield

OpenGLTokens

glBitmap

OpenGL1x

glBlendColor

OpenGL1x

glBlendColorEXT

OpenGL1x

glBlendEquation

OpenGL1x

glBlendEquationEXT

OpenGL1x

glBlendEquationi

OpenGL1x

glBlendEquationiARB

OpenGL1x

glBlendEquationSeparate

OpenGL1x

glBlendEquationSeparateEXT

OpenGL1x

glBlendEquationSeparatei

OpenGL1x

glBlendEquationSeparateiARB

OpenGL1x

glBlendFunc

OpenGL1x

glBlendFunci

OpenGL1x

glBlendFunciARB

OpenGL1x

glBlendFuncSeparate

OpenGL1x

glBlendFuncSeparateEXT

OpenGL1x

glBlendFuncSeparatei

OpenGL1x

glBlendFuncSeparateiARB

OpenGL1x

glBlitFramebuffer

OpenGL1x

glBlitFramebufferEXT

OpenGL1x

GLboolean

OpenGLTokens

glBufferAddressRangeNV

OpenGL1x

glBufferData

OpenGL1x

glBufferDataARB

OpenGL1x

glBufferSubData

OpenGL1x

glBufferSubDataARB

OpenGL1x

GLbyte

OpenGLTokens

glCallList

OpenGL1x

glCallLists

OpenGL1x

glCheckFramebufferStatus

OpenGL1x

glCheckFramebufferStatusEXT

OpenGL1x

glClampColor

OpenGL1x

glClampColorARB

OpenGL1x

GLclampd

OpenGLTokens

GLclampf

OpenGLTokens

glClear

OpenGL1x

glClearAccum

OpenGL1x

glClearBufferfi

OpenGL1x

glClearBufferfv

OpenGL1x

glClearBufferiv

OpenGL1x

glClearBufferuiv

OpenGL1x

glClearColor

OpenGL1x

glClearColorIiEXT

OpenGL1x

glClearColorIuiEXT

OpenGL1x

glClearDepth

OpenGL1x

glClearDepthf

OpenGL1x

glClearIndex

OpenGL1x

glClearStencil

OpenGL1x

glClientActiveTexture

OpenGL1x

glClientActiveTextureARB

OpenGL1x

glClientWaitSync

OpenGL1x

glClipPlane

OpenGL1x

glColor3b

OpenGL1x

glColor3bv

OpenGL1x

glColor3d

OpenGL1x

glColor3dv

OpenGL1x

glColor3f

OpenGL1x

glColor3fv

OpenGL1x

glColor3i

OpenGL1x

glColor3iv

OpenGL1x

glColor3s

OpenGL1x

glColor3sv

OpenGL1x

glColor3ub

OpenGL1x

glColor3ubv

OpenGL1x

glColor3ui

OpenGL1x

glColor3uiv

OpenGL1x

glColor3us

OpenGL1x

glColor3usv

OpenGL1x

glColor4b

OpenGL1x

glColor4bv

OpenGL1x

glColor4d

OpenGL1x

glColor4dv

OpenGL1x

glColor4f

OpenGL1x

glColor4fv

OpenGL1x

glColor4i

OpenGL1x

glColor4iv

OpenGL1x

glColor4s

OpenGL1x

glColor4sv

OpenGL1x

glColor4ub

OpenGL1x

glColor4ubv

OpenGL1x

glColor4ui

OpenGL1x

glColor4uiv

OpenGL1x

glColor4us

OpenGL1x

glColor4usv

OpenGL1x

glColorFormatNV

OpenGL1x

glColorMask

OpenGL1x

glColorMaski

OpenGL1x

glColorMaskIndexedEXT

OpenGL1x

glColorMaterial

OpenGL1x

glColorP3ui

OpenGL1x

glColorP3uiv

OpenGL1x

glColorP4ui

OpenGL1x

glColorP4uiv

OpenGL1x

glColorPointer

OpenGL1x

glColorSubTable

OpenGL1x

glColorSubTableExt

OpenGL1x

glColorTable

OpenGL1x

glColorTableEXT

OpenGL1x

glColorTableParameterfv

OpenGL1x

glColorTableParameteriv

OpenGL1x

glCombinerInputNV

OpenGL1x

glCombinerOutputNV

OpenGL1x

glCombinerParameterfNV

OpenGL1x

glCombinerParameterfvNV

OpenGL1x

glCombinerParameteriNV

OpenGL1x

glCombinerParameterivNV

OpenGL1x

glCompileShader

OpenGL1x

glCompileShaderARB

OpenGL1x

glCompressedTexImage1D

OpenGL1x

glCompressedTexImage1DARB

OpenGL1x

glCompressedTexImage2D

OpenGL1x

glCompressedTexImage2DARB

OpenGL1x

glCompressedTexImage3D

OpenGL1x

glCompressedTexImage3DARB

OpenGL1x

glCompressedTexSubImage1D

OpenGL1x

glCompressedTexSubImage1DARB

OpenGL1x

glCompressedTexSubImage2D

OpenGL1x

glCompressedTexSubImage2DARB

OpenGL1x

glCompressedTexSubImage3D

OpenGL1x

glCompressedTexSubImage3DARB

OpenGL1x

GLContextManager

GLContext

glConvolutionFilter1D

OpenGL1x

glConvolutionFilter2D

OpenGL1x

glConvolutionParameterf

OpenGL1x

glConvolutionParameterfv

OpenGL1x

glConvolutionParameteri

OpenGL1x

glConvolutionParameteriv

OpenGL1x

glCopyBufferSubData

OpenGL1x

glCopyColorSubTable

OpenGL1x

glCopyColorTable

OpenGL1x

glCopyConvolutionFilter1D

OpenGL1x

glCopyConvolutionFilter2D

OpenGL1x

glCopyImageSubDataNV

OpenGL1x

glCopyPixels

OpenGL1x

glCopyTexImage1D

OpenGL1x

glCopyTexImage1DEXT

OpenGL1x

glCopyTexImage2D

OpenGL1x

glCopyTexImage2DEXT

OpenGL1x

glCopyTexSubImage1D

OpenGL1x

glCopyTexSubImage1DEXT

OpenGL1x

glCopyTexSubImage2D

OpenGL1x

glCopyTexSubImage2DEXT

OpenGL1x

glCopyTexSubImage3D

OpenGL1x

glCopyTexSubImage3DEXT

OpenGL1x

glCreateProgram

OpenGL1x

glCreateProgramObjectARB

OpenGL1x

glCreateShader

OpenGL1x

glCreateShaderObjectARB

OpenGL1x

glCreateShaderProgramv

OpenGL1x

glCullFace

OpenGL1x

glCurrentPaletteMatrixARB

OpenGL1x

glDebugMessageCallbackARB

OpenGL1x

glDebugMessageControlARB

OpenGL1x

glDebugMessageInsertARB

OpenGL1x

glDeleteBuffers

OpenGL1x

glDeleteBuffersARB

OpenGL1x

glDeleteFencesNV

OpenGL1x

glDeleteFramebuffers

OpenGL1x

glDeleteFramebuffersEXT

OpenGL1x

glDeleteLists

OpenGL1x

glDeleteObjectARB

OpenGL1x

glDeleteOcclusionQueriesNV

OpenGL1x

glDeleteProgram

OpenGL1x

glDeleteProgramPipelines

OpenGL1x

glDeleteProgramsARB

OpenGL1x

glDeleteProgramsNV

OpenGL1x

glDeleteQueries

OpenGL1x

glDeleteQueriesARB

OpenGL1x

glDeleteRenderbuffers

OpenGL1x

glDeleteRenderbuffersEXT

OpenGL1x

glDeleteSamplers

OpenGL1x

glDeleteShader

OpenGL1x

glDeleteSync

OpenGL1x

glDeleteTextures

OpenGL1x

glDeleteTexturesEXT

OpenGL1x

glDeleteTransformFeedbacks

OpenGL1x

glDeleteVertexArrays

OpenGL1x

glDepthBoundsEXT

OpenGL1x

glDepthFunc

OpenGL1x

glDepthMask

OpenGL1x

glDepthRange

OpenGL1x

glDepthRangeArrayv

OpenGL1x

glDepthRangef

OpenGL1x

glDepthRangeIndexed

OpenGL1x

glDetachObjectARB

OpenGL1x

glDetachShader

OpenGL1x

GLDirectionFromGeom

ODEGL

glDisable

OpenGL1x

glDisableClientState

OpenGL1x

glDisablei

OpenGL1x

glDisableIndexedEXT

OpenGL1x

glDisableVertexAttribArray

OpenGL1x

glDisableVertexAttribArrayARB

OpenGL1x

GLdouble

OpenGLTokens

glDrawArrays

OpenGL1x

glDrawArraysIndirect

OpenGL1x

glDrawArraysInstanced

OpenGL1x

glDrawArraysInstancedARB

OpenGL1x

glDrawArraysInstancedEXT

OpenGL1x

glDrawBuffer

OpenGL1x

glDrawBuffers

OpenGL1x

glDrawBuffersARB

OpenGL1x

glDrawBuffersATI

OpenGL1x

glDrawElements

OpenGL1x

glDrawElementsBaseVertex

OpenGL1x

glDrawElementsIndirect

OpenGL1x

glDrawElementsInstanced

OpenGL1x

glDrawElementsInstancedARB

OpenGL1x

glDrawElementsInstancedBaseVertex

OpenGL1x

glDrawElementsInstancedEXT

OpenGL1x

glDrawPixels

OpenGL1x

glDrawRangeElements

OpenGL1x

glDrawRangeElementsBaseVertex

OpenGL1x

glDrawRangeElementsEXT

OpenGL1x

glDrawTransformFeedback

OpenGL1x

glDrawTransformFeedbackStream

OpenGL1x

glEdgeFlag

OpenGL1x

glEdgeFlagFormatNV

OpenGL1x

glEdgeFlagPointer

OpenGL1x

glEdgeFlagv

OpenGL1x

glEnable

OpenGL1x

glEnableClientState

OpenGL1x

glEnablei

OpenGL1x

glEnableIndexedEXT

OpenGL1x

glEnableVertexAttribArray

OpenGL1x

glEnableVertexAttribArrayARB

OpenGL1x

glEnd

OpenGL1x

glEndConditionalRender

OpenGL1x

glEndConditionalRenderNV

OpenGL1x

glEndList

OpenGL1x

glEndOcclusionQueryNV

OpenGL1x

glEndQuery

OpenGL1x

glEndQueryARB

OpenGL1x

glEndQueryIndexed

OpenGL1x

glEndSceneEXT

OpenGL1x

glEndTransformFeedback

OpenGL1x

glEndTransformFeedbackEXT

OpenGL1x

glEndTransformFeedbackNV

OpenGL1x

GLenum

OpenGLTokens

GLEnumToDDSHeader

DXTC

glEvalCoord1d

OpenGL1x

glEvalCoord1dv

OpenGL1x

glEvalCoord1f

OpenGL1x

glEvalCoord1fv

OpenGL1x

glEvalCoord2d

OpenGL1x

glEvalCoord2dv

OpenGL1x

glEvalCoord2f

OpenGL1x

glEvalCoord2fv

OpenGL1x

glEvalMesh1

OpenGL1x

glEvalMesh2

OpenGL1x

glEvalPoint1

OpenGL1x

glEvalPoint2

OpenGL1x

glExecuteProgramNV

OpenGL1x

glFeedbackBuffer

OpenGL1x

glFenceSync

OpenGL1x

glFinalCombinerInputNV

OpenGL1x

glFinish

OpenGL1x

glFinishFenceNV

OpenGL1x

GLfloat

OpenGLTokens

glFlush

OpenGL1x

glFlushMappedBufferRange

OpenGL1x

glFlushVertexArrayRangeNV

OpenGL1x

glFogCoordd

OpenGL1x

glFogCoorddEXT

OpenGL1x

glFogCoorddv

OpenGL1x

glFogCoorddvEXT

OpenGL1x

glFogCoordf

OpenGL1x

glFogCoordfEXT

OpenGL1x

glFogCoordFormatNV

OpenGL1x

glFogCoordfv

OpenGL1x

glFogCoordfvEXT

OpenGL1x

glFogCoordPointer

OpenGL1x

glFogCoordPointerEXT

OpenGL1x

glFogf

OpenGL1x

glFogfv

OpenGL1x

glFogi

OpenGL1x

glFogiv

OpenGL1x

glFramebufferRenderbuffer

OpenGL1x

glFramebufferRenderbufferEXT

OpenGL1x

glFramebufferTexture

OpenGL1x

glFramebufferTexture1D

OpenGL1x

glFramebufferTexture1DEXT

OpenGL1x

glFramebufferTexture2D

OpenGL1x

glFramebufferTexture2DEXT

OpenGL1x

glFramebufferTexture3D

OpenGL1x

glFramebufferTexture3DEXT

OpenGL1x

glFramebufferTextureARB

OpenGL1x

glFramebufferTextureEXT

OpenGL1x

glFramebufferTextureFaceARB

OpenGL1x

glFramebufferTextureFaceEXT

OpenGL1x

glFramebufferTextureLayer

OpenGL1x

glFramebufferTextureLayerARB

OpenGL1x

glFramebufferTextureLayerEXT

OpenGL1x

glFrameTerminatorGREMEDY

OpenGL1x

glFrontFace

OpenGL1x

glFrustum

OpenGL1x

glGenBuffers

OpenGL1x

glGenBuffersARB

OpenGL1x

glGenerateMipmap

OpenGL1x

glGenerateMipmapEXT

OpenGL1x

glGenFencesNV

OpenGL1x

glGenFramebuffers

OpenGL1x

glGenFramebuffersEXT

OpenGL1x

glGenLists

OpenGL1x

glGenOcclusionQueriesNV

OpenGL1x

glGenProgramPipelines

OpenGL1x

glGenProgramsARB

OpenGL1x

glGenProgramsNV

OpenGL1x

glGenQueries

OpenGL1x

glGenQueriesARB

OpenGL1x

glGenRenderbuffers

OpenGL1x

glGenRenderbuffersEXT

OpenGL1x

glGenSamplers

OpenGL1x

glGenTextures

OpenGL1x

glGenTexturesEXT

OpenGL1x

glGenTransformFeedbacks

OpenGL1x

glGenVertexArrays

OpenGL1x

glGetActiveAttrib

OpenGL1x

glGetActiveAttribARB

OpenGL1x

glGetActiveSubroutineName

OpenGL1x

glGetActiveSubroutineUniformiv

OpenGL1x

glGetActiveSubroutineUniformName

OpenGL1x

glGetActiveUniform

OpenGL1x

glGetActiveUniformARB

OpenGL1x

glGetActiveUniformBlockiv

OpenGL1x

glGetActiveUniformBlockName

OpenGL1x

glGetActiveUniformName

OpenGL1x

glGetActiveUniformsiv

OpenGL1x

glGetActiveVaryingNV

OpenGL1x

glGetAttachedObjectsARB

OpenGL1x

glGetAttachedShaders

OpenGL1x

glGetAttribLocation

OpenGL1x

glGetAttribLocationARB

OpenGL1x

glGetBooleanIndexedvEXT

OpenGL1x

glGetBooleani_v

OpenGL1x

glGetBooleanv

OpenGL1x

glGetBufferParameteri64v

OpenGL1x

glGetBufferParameteriv

OpenGL1x

glGetBufferParameterivARB

OpenGL1x

glGetBufferParameterui64vNV

OpenGL1x

glGetBufferPointerv

OpenGL1x

glGetBufferPointervARB

OpenGL1x

glGetBufferSubData

OpenGL1x

glGetBufferSubDataARB

OpenGL1x

glGetClipPlane

OpenGL1x

glGetColorTable

OpenGL1x

glGetColorTableEXT

OpenGL1x

glGetColorTableParameterfv

OpenGL1x

glGetColorTableParameterfvEXT

OpenGL1x

glGetColorTableParameteriv

OpenGL1x

glGetColorTableParameterivEXT

OpenGL1x

glGetCombinerInputParameterfvNV

OpenGL1x

glGetCombinerInputParameterivNV

OpenGL1x

glGetCombinerOutputParameterfvNV

OpenGL1x

glGetCombinerOutputParameterivNV

OpenGL1x

glGetCompressedTexImage

OpenGL1x

glGetCompressedTexImageARB

OpenGL1x

glGetConvolutionFilter

OpenGL1x

glGetConvolutionParameterfv

OpenGL1x

glGetConvolutionParameteriv

OpenGL1x

GLGetCursorPos

GLScreen

glGetDebugMessageLogARB

OpenGL1x

glGetDoublei_v

OpenGL1x

glGetDoublev

OpenGL1x

glGetError

OpenGL1x

glGetFenceivNV

OpenGL1x

glGetFinalCombinerInputParameterfvNV

OpenGL1x

glGetFinalCombinerInputParameterivNV

OpenGL1x

glGetFloati_v

OpenGL1x

glGetFloatv

OpenGL1x

glGetFragDataIndex

OpenGL1x

glGetFragDataLocation

OpenGL1x

glGetFragDataLocationEXT

OpenGL1x

glGetFramebufferAttachmentParameteriv

OpenGL1x

glGetFramebufferAttachmentParameterivEXT

OpenGL1x

glGetGraphicsResetStatusARB

OpenGL1x

glGetHandleARB

OpenGL1x

glGetHistogram

OpenGL1x

glGetHistogramParameterfv

OpenGL1x

glGetHistogramParameteriv

OpenGL1x

glGetInfoLogARB

OpenGL1x

glGetInteger64i_v

OpenGL1x

glGetInteger64v

OpenGL1x

glGetIntegerIndexedvEXT

OpenGL1x

glGetIntegeri_v

OpenGL1x

glGetIntegerui64i_vNV

OpenGL1x

glGetIntegerui64vNV

OpenGL1x

glGetIntegerv

OpenGL1x

glGetLightfv

OpenGL1x

glGetLightiv

OpenGL1x

glGetMapdv

OpenGL1x

glGetMapfv

OpenGL1x

glGetMapiv

OpenGL1x

glGetMaterialfv

OpenGL1x

glGetMaterialiv

OpenGL1x

glGetMinmax

OpenGL1x

glGetMinmaxParameterfv

OpenGL1x

glGetMinmaxParameteriv

OpenGL1x

glGetMultisamplefv

OpenGL1x

glGetNamedBufferParameterui64vNV

OpenGL1x

glGetnColorTableARB

OpenGL1x

glGetnCompressedTexImageARB

OpenGL1x

glGetnConvolutionFilterARB

OpenGL1x

glGetnHistogramARB

OpenGL1x

glGetnMapdvARB

OpenGL1x

glGetnMapfvARB

OpenGL1x

glGetnMapivARB

OpenGL1x

glGetnMinmaxARB

OpenGL1x

glGetnPixelMapfvARB

OpenGL1x

glGetnPixelMapuivARB

OpenGL1x

glGetnPixelMapusvARB

OpenGL1x

glGetnPolygonStippleARB

OpenGL1x

glGetnSeparableFilterARB

OpenGL1x

glGetnTexImageARB

OpenGL1x

glGetnUniformdvARB

OpenGL1x

glGetnUniformfvARB

OpenGL1x

glGetnUniformivARB

OpenGL1x

glGetnUniformuivARB

OpenGL1x

glGetObjectParameterfvARB

OpenGL1x

glGetObjectParameterivARB

OpenGL1x

glGetOcclusionQueryivNV

OpenGL1x

glGetOcclusionQueryuivNV

OpenGL1x

glGetPixelMapfv

OpenGL1x

glGetPixelMapuiv

OpenGL1x

glGetPixelMapusv

OpenGL1x

glGetPointerv

OpenGL1x

glGetPolygonStipple

OpenGL1x

GLGetProcAddress

OpenGL1x

GLGetProcAddress

OpenGLAdapter

glGetProgramBinary

OpenGL1x

glGetProgramEnvParameterdvARB

OpenGL1x

glGetProgramEnvParameterfvARB

OpenGL1x

glGetProgramInfoLog

OpenGL1x

glGetProgramiv

OpenGL1x

glGetProgramivARB

OpenGL1x

glGetProgramivNV

OpenGL1x

glGetProgramLocalParameterdvARB

OpenGL1x

glGetProgramLocalParameterfvARB

OpenGL1x

glGetProgramParameterdvNV

OpenGL1x

glGetProgramParameterfvNV

OpenGL1x

glGetProgramPipelineInfoLog

OpenGL1x

glGetProgramPipelineiv

OpenGL1x

glGetProgramStageiv

OpenGL1x

glGetProgramStringARB

OpenGL1x

glGetProgramStringNV

OpenGL1x

glGetQueryIndexediv

OpenGL1x

glGetQueryiv

OpenGL1x

glGetQueryivARB

OpenGL1x

glGetQueryObjecti64v

OpenGL1x

glGetQueryObjecti64vEXT

OpenGL1x

glGetQueryObjectiv

OpenGL1x

glGetQueryObjectivARB

OpenGL1x

glGetQueryObjectui64v

OpenGL1x

glGetQueryObjectui64vEXT

OpenGL1x

glGetQueryObjectuiv

OpenGL1x

glGetQueryObjectuivARB

OpenGL1x

glGetRenderbufferParameteriv

OpenGL1x

glGetRenderbufferParameterivEXT

OpenGL1x

glGetSamplerParameterfv

OpenGL1x

glGetSamplerParameterIfv

OpenGL1x

glGetSamplerParameterIiv

OpenGL1x

glGetSamplerParameteriv

OpenGL1x

GLGetScreenHeight

GLScreen

GLGetScreenWidth

GLScreen

glGetSeparableFilter

OpenGL1x

glGetShaderInfoLog

OpenGL1x

glGetShaderiv

OpenGL1x

glGetShaderPrecisionFormat

OpenGL1x

glGetShaderSource

OpenGL1x

glGetShaderSourceARB

OpenGL1x

glGetString

OpenGL1x

glGetStringi

OpenGL1x

glGetSubroutineIndex

OpenGL1x

glGetSubroutineUniformLocation

OpenGL1x

glGetSynciv

OpenGL1x

glGetTexEnvfv

OpenGL1x

glGetTexEnviv

OpenGL1x

glGetTexGendv

OpenGL1x

glGetTexGenfv

OpenGL1x

glGetTexGeniv

OpenGL1x

glGetTexImage

OpenGL1x

glGetTexLevelParameterfv

OpenGL1x

glGetTexLevelParameteriv

OpenGL1x

glGetTexParameterfv

OpenGL1x

glGetTexParameterIiv

OpenGL1x

glGetTexParameterIivEXT

OpenGL1x

glGetTexParameterIuiv

OpenGL1x

glGetTexParameterIuivEXT

OpenGL1x

glGetTexParameteriv

OpenGL1x

GLGetTickCount

GLCrossPlatform

glGetTrackMatrixivNV

OpenGL1x

glGetTransformFeedbackVarying

OpenGL1x

glGetTransformFeedbackVaryingEXT

OpenGL1x

glGetTransformFeedbackVaryingNV

OpenGL1x

glGetUniformBlockIndex

OpenGL1x

glGetUniformBufferSizeEXT

OpenGL1x

glGetUniformdv

OpenGL1x

glGetUniformfv

OpenGL1x

glGetUniformfvARB

OpenGL1x

glGetUniformIndices

OpenGL1x

glGetUniformiv

OpenGL1x

glGetUniformivARB

OpenGL1x

glGetUniformLocation

OpenGL1x

glGetUniformLocationARB

OpenGL1x

glGetUniformOffsetEXT

OpenGL1x

glGetUniformSubroutineuiv

OpenGL1x

glGetUniformui64vNV

OpenGL1x

glGetUniformuiv

OpenGL1x

glGetUniformuivEXT

OpenGL1x

glGetVaryingLocationNV

OpenGL1x

glGetVertexAttribdv

OpenGL1x

glGetVertexAttribdvARB

OpenGL1x

glGetVertexAttribdvNV

OpenGL1x

glGetVertexAttribfv

OpenGL1x

glGetVertexAttribfvARB

OpenGL1x

glGetVertexAttribfvNV

OpenGL1x

glGetVertexAttribIiv

OpenGL1x

glGetVertexAttribIivEXT

OpenGL1x

glGetVertexAttribIuiv

OpenGL1x

glGetVertexAttribIuivEXT

OpenGL1x

glGetVertexAttribiv

OpenGL1x

glGetVertexAttribivARB

OpenGL1x

glGetVertexAttribivNV

OpenGL1x

glGetVertexAttribLdv

OpenGL1x

glGetVertexAttribPointerv

OpenGL1x

glGetVertexAttribPointervARB

OpenGL1x

glGetVertexAttribPointervNV

OpenGL1x

GLhandleARB

OpenGLTokens

glHint

OpenGL1x

glHistogram

OpenGL1x

glIndexd

OpenGL1x

glIndexdv

OpenGL1x

glIndexf

OpenGL1x

glIndexFormatNV

OpenGL1x

glIndexFuncEXT

OpenGL1x

glIndexfv

OpenGL1x

glIndexi

OpenGL1x

glIndexiv

OpenGL1x

glIndexMask

OpenGL1x

glIndexMaterialEXT

OpenGL1x

glIndexPointer

OpenGL1x

glIndexs

OpenGL1x

glIndexsv

OpenGL1x

glIndexub

OpenGL1x

glIndexubv

OpenGL1x

glInitNames

OpenGL1x

GLint

OpenGLTokens

GLint64

OpenGLTokens

GLint64EXT

OpenGLTokens

glInterleavedArrays

OpenGL1x

GLintptr

OpenGLTokens

glIsBuffer

OpenGL1x

glIsBufferARB

OpenGL1x

glIsBufferResidentNV

OpenGL1x

glIsEnabled

OpenGL1x

glIsEnabledi

OpenGL1x

glIsEnabledIndexedEXT

OpenGL1x

glIsFenceNV

OpenGL1x

glIsFramebuffer

OpenGL1x

glIsFramebufferEXT

OpenGL1x

glIsList

OpenGL1x

glIsNamedBufferResidentNV

OpenGL1x

glIsOcclusionQueryNV

OpenGL1x

glIsProgram

OpenGL1x

glIsProgramARB

OpenGL1x

glIsProgramNV

OpenGL1x

glIsProgramPipeline

OpenGL1x

glIsQuery

OpenGL1x

glIsQueryARB

OpenGL1x

glIsRenderbuffer

OpenGL1x

glIsRenderbufferEXT

OpenGL1x

glIsSampler

OpenGL1x

glIsShader

OpenGL1x

glIsSync

OpenGL1x

glIsTexture

OpenGL1x

glIsTextureEXT

OpenGL1x

glIsTransformFeedback

OpenGL1x

glIsVertexArray

OpenGL1x

glKey_CANCEL

GLCrossPlatform

glKey_CONTROL

GLCrossPlatform

glKey_DELETE

GLCrossPlatform

glKey_DOWN

GLCrossPlatform

glKey_END

GLCrossPlatform

glKey_HOME

GLCrossPlatform

glKey_LEFT

GLCrossPlatform

glKey_NEXT

GLCrossPlatform

glKey_PRIOR

GLCrossPlatform

glKey_RETURN

GLCrossPlatform

glKey_RIGHT

GLCrossPlatform

glKey_SPACE

GLCrossPlatform

glKey_TAB

GLCrossPlatform

glKey_UP

GLCrossPlatform

GLLibGetProcAddress

OpenGLAdapter

GLLibGetProcAddress

OpenGL1x

glLightf

OpenGL1x

glLightfv

OpenGL1x

glLighti

OpenGL1x

glLightiv

OpenGL1x

glLightModelf

OpenGL1x

glLightModelfv

OpenGL1x

glLightModeli

OpenGL1x

glLightModeliv

OpenGL1x

glLineStipple

OpenGL1x

glLineWidth

OpenGL1x

glLinkProgram

OpenGL1x

glLinkProgramARB

OpenGL1x

glListBase

OpenGL1x

GLLoadBitmapFromInstance

GLCrossPlatform

glLoadIdentity

OpenGL1x

glLoadMatrixd

OpenGL1x

glLoadMatrixf

OpenGL1x

glLoadName

OpenGL1x

glLoadProgramNV

OpenGL1x

glLoadTransposeMatrixd

OpenGL1x

glLoadTransposeMatrixdARB

OpenGL1x

glLoadTransposeMatrixf

OpenGL1x

glLoadTransposeMatrixfARB

OpenGL1x

glLockArraysEXT

OpenGL1x

glLogicOp

OpenGL1x

glMakeBufferNonResidentNV

OpenGL1x

glMakeBufferResidentNV

OpenGL1x

glMakeNamedBufferNonResidentNV

OpenGL1x

glMakeNamedBufferResidentNV

OpenGL1x

glMap1d

OpenGL1x

glMap1f

OpenGL1x

glMap2d

OpenGL1x

glMap2f

OpenGL1x

glMapBuffer

OpenGL1x

glMapBufferARB

OpenGL1x

glMapBufferRange

OpenGL1x

glMapGrid1d

OpenGL1x

glMapGrid1f

OpenGL1x

glMapGrid2d

OpenGL1x

glMapGrid2f

OpenGL1x

glMaterialf

OpenGL1x

glMaterialfv

OpenGL1x

glMateriali

OpenGL1x

glMaterialiv

OpenGL1x

GLMatrixFromGeom

ODEGL

glMatrixIndexPointerARB

OpenGL1x

glMatrixIndexubvARB

OpenGL1x

glMatrixIndexuivARB

OpenGL1x

glMatrixIndexusvARB

OpenGL1x

glMatrixMode

OpenGL1x

glMinmax

OpenGL1x

glMinSampleShading

OpenGL1x

glMinSampleShadingARB

OpenGL1x

glMultiDrawArrays

OpenGL1x

glMultiDrawArraysEXT

OpenGL1x

glMultiDrawElements

OpenGL1x

glMultiDrawElementsBaseVertex

OpenGL1x

glMultiDrawElementsEXT

OpenGL1x

glMultiTexCoord1d

OpenGL1x

glMultiTexCoord1dARB

OpenGL1x

glMultiTexCoord1dV

OpenGL1x

glMultiTexCoord1dVARB

OpenGL1x

glMultiTexCoord1f

OpenGL1x

glMultiTexCoord1fARB

OpenGL1x

glMultiTexCoord1fV

OpenGL1x

glMultiTexCoord1fVARB

OpenGL1x

glMultiTexCoord1i

OpenGL1x

glMultiTexCoord1iARB

OpenGL1x

glMultiTexCoord1iV

OpenGL1x

glMultiTexCoord1iVARB

OpenGL1x

glMultiTexCoord1s

OpenGL1x

glMultiTexCoord1sARB

OpenGL1x

glMultiTexCoord1sV

OpenGL1x

glMultiTexCoord1sVARB

OpenGL1x

glMultiTexCoord2d

OpenGL1x

glMultiTexCoord2dARB

OpenGL1x

glMultiTexCoord2dv

OpenGL1x

glMultiTexCoord2dvARB

OpenGL1x

glMultiTexCoord2f

OpenGL1x

glMultiTexCoord2fARB

OpenGL1x

glMultiTexCoord2fv

OpenGL1x

glMultiTexCoord2fvARB

OpenGL1x

glMultiTexCoord2i

OpenGL1x

glMultiTexCoord2iARB

OpenGL1x

glMultiTexCoord2iv

OpenGL1x

glMultiTexCoord2ivARB

OpenGL1x

glMultiTexCoord2s

OpenGL1x

glMultiTexCoord2sARB

OpenGL1x

glMultiTexCoord2sv

OpenGL1x

glMultiTexCoord2svARB

OpenGL1x

glMultiTexCoord3d

OpenGL1x

glMultiTexCoord3dARB

OpenGL1x

glMultiTexCoord3dv

OpenGL1x

glMultiTexCoord3dvARB

OpenGL1x

glMultiTexCoord3f

OpenGL1x

glMultiTexCoord3fARB

OpenGL1x

glMultiTexCoord3fv

OpenGL1x

glMultiTexCoord3fvARB

OpenGL1x

glMultiTexCoord3i

OpenGL1x

glMultiTexCoord3iARB

OpenGL1x

glMultiTexCoord3iv

OpenGL1x

glMultiTexCoord3ivARB

OpenGL1x

glMultiTexCoord3s

OpenGL1x

glMultiTexCoord3sARB

OpenGL1x

glMultiTexCoord3sv

OpenGL1x

glMultiTexCoord3svARB

OpenGL1x

glMultiTexCoord4d

OpenGL1x

glMultiTexCoord4dARB

OpenGL1x

glMultiTexCoord4dv

OpenGL1x

glMultiTexCoord4dvARB

OpenGL1x

glMultiTexCoord4f

OpenGL1x

glMultiTexCoord4fARB

OpenGL1x

glMultiTexCoord4fv

OpenGL1x

glMultiTexCoord4fvARB

OpenGL1x

glMultiTexCoord4i

OpenGL1x

glMultiTexCoord4iARB

OpenGL1x

glMultiTexCoord4iv

OpenGL1x

glMultiTexCoord4ivARB

OpenGL1x

glMultiTexCoord4s

OpenGL1x

glMultiTexCoord4sARB

OpenGL1x

glMultiTexCoord4sv

OpenGL1x

glMultiTexCoord4svARB

OpenGL1x

glMultiTexCoordP1ui

OpenGL1x

glMultiTexCoordP1uiv

OpenGL1x

glMultiTexCoordP2ui

OpenGL1x

glMultiTexCoordP2uiv

OpenGL1x

glMultiTexCoordP3ui

OpenGL1x

glMultiTexCoordP3uiv

OpenGL1x

glMultiTexCoordP4ui

OpenGL1x

glMultiTexCoordP4uiv

OpenGL1x

glMultMatrixd

OpenGL1x

glMultMatrixf

OpenGL1x

glMultTransposeMatrixd

OpenGL1x

glMultTransposeMatrixdARB

OpenGL1x

glMultTransposeMatrixf

OpenGL1x

glMultTransposeMatrixfARB

OpenGL1x

glNewList

OpenGL1x

glNormal3b

OpenGL1x

glNormal3bv

OpenGL1x

glNormal3d

OpenGL1x

glNormal3dv

OpenGL1x

glNormal3f

OpenGL1x

glNormal3fv

OpenGL1x

glNormal3i

OpenGL1x

glNormal3iv

OpenGL1x

glNormal3s

OpenGL1x

glNormal3sv

OpenGL1x

glNormalFormatNV

OpenGL1x

glNormalP3ui

OpenGL1x

glNormalP3uiv

OpenGL1x

glNormalPointer

OpenGL1x

GLOKMessageBox

GLCrossPlatform

glOrtho

OpenGL1x

glPassThrough

OpenGL1x

glPatchParameterfv

OpenGL1x

glPatchParameteri

OpenGL1x

glPauseTransformFeedback

OpenGL1x

glpf24bit

GLCrossPlatform

glpf32Bit

GLCrossPlatform

glpf8Bit

GLCrossPlatform

glpfDevice

GLCrossPlatform

glPixelMapfv

OpenGL1x

glPixelMapuiv

OpenGL1x

glPixelMapusv

OpenGL1x

glPixelStoref

OpenGL1x

glPixelStorei

OpenGL1x

glPixelTransferf

OpenGL1x

glPixelTransferi

OpenGL1x

glPixelZoom

OpenGL1x

GLPoint

GLCrossPlatform

glPointParameterf

OpenGL1x

glPointParameterfARB

OpenGL1x

glPointParameterfv

OpenGL1x

glPointParameterfvARB

OpenGL1x

glPointParameteri

OpenGL1x

glPointParameteriNV

OpenGL1x

glPointParameteriv

OpenGL1x

glPointParameterivNV

OpenGL1x

glPointSize

OpenGL1x

glPolygonMode

OpenGL1x

glPolygonOffset

OpenGL1x

glPolygonOffsetEXT

OpenGL1x

glPolygonStipple

OpenGL1x

glPopAttrib

OpenGL1x

glPopClientAttrib

OpenGL1x

glPopMatrix

OpenGL1x

glPopName

OpenGL1x

glPrimitiveRestartIndex

OpenGL1x

glPrimitiveRestartIndexNV

OpenGL1x

glPrimitiveRestartNV

OpenGL1x

glPrioritizeTextures

OpenGL1x

glPrioritizeTexturesEXT

OpenGL1x

glProgramBinary

OpenGL1x

glProgramEnvParameter4dARB

OpenGL1x

glProgramEnvParameter4dvARB

OpenGL1x

glProgramEnvParameter4fARB

OpenGL1x

glProgramEnvParameter4fvARB

OpenGL1x

glProgramEnvParameters4fvEXT

OpenGL1x

glProgramLocalParameter4dARB

OpenGL1x

glProgramLocalParameter4dvARB

OpenGL1x

glProgramLocalParameter4fARB

OpenGL1x

glProgramLocalParameter4fvARB

OpenGL1x

glProgramLocalParameters4fvEXT

OpenGL1x

glProgramParameter4dNV

OpenGL1x

glProgramParameter4dvNV

OpenGL1x

glProgramParameter4fNV

OpenGL1x

glProgramParameter4fvNV

OpenGL1x

glProgramParameteri

OpenGL1x

glProgramParameteriARB

OpenGL1x

glProgramParameteriEXT

OpenGL1x

glProgramParameters4dvNV

OpenGL1x

glProgramParameters4fvNV

OpenGL1x

glProgramStringARB

OpenGL1x

glProgramUniform1d

OpenGL1x

glProgramUniform1dEXT

OpenGL1x

glProgramUniform1dv

OpenGL1x

glProgramUniform1dvEXT

OpenGL1x

glProgramUniform1f

OpenGL1x

glProgramUniform1fv

OpenGL1x

glProgramUniform1i

OpenGL1x

glProgramUniform1iv

OpenGL1x

glProgramUniform1ui

OpenGL1x

glProgramUniform1uiv

OpenGL1x

glProgramUniform2d

OpenGL1x

glProgramUniform2dEXT

OpenGL1x

glProgramUniform2dv

OpenGL1x

glProgramUniform2dvEXT

OpenGL1x

glProgramUniform2f

OpenGL1x

glProgramUniform2fv

OpenGL1x

glProgramUniform2i

OpenGL1x

glProgramUniform2iv

OpenGL1x

glProgramUniform2ui

OpenGL1x

glProgramUniform2uiv

OpenGL1x

glProgramUniform3d

OpenGL1x

glProgramUniform3dEXT

OpenGL1x

glProgramUniform3dv

OpenGL1x

glProgramUniform3dvEXT

OpenGL1x

glProgramUniform3f

OpenGL1x

glProgramUniform3fv

OpenGL1x

glProgramUniform3i

OpenGL1x

glProgramUniform3iv

OpenGL1x

glProgramUniform3ui

OpenGL1x

glProgramUniform3uiv

OpenGL1x

glProgramUniform4d

OpenGL1x

glProgramUniform4dEXT

OpenGL1x

glProgramUniform4dv

OpenGL1x

glProgramUniform4dvEXT

OpenGL1x

glProgramUniform4f

OpenGL1x

glProgramUniform4fv

OpenGL1x

glProgramUniform4i

OpenGL1x

glProgramUniform4iv

OpenGL1x

glProgramUniform4ui

OpenGL1x

glProgramUniform4uiv

OpenGL1x

glProgramUniformMatrix2dv

OpenGL1x

glProgramUniformMatrix2dvEXT

OpenGL1x

glProgramUniformMatrix2fv

OpenGL1x

glProgramUniformMatrix2x3dv

OpenGL1x

glProgramUniformMatrix2x3dvEXT

OpenGL1x

glProgramUniformMatrix2x3fv

OpenGL1x

glProgramUniformMatrix2x4dv

OpenGL1x

glProgramUniformMatrix2x4dvEXT

OpenGL1x

glProgramUniformMatrix2x4fv

OpenGL1x

glProgramUniformMatrix3dv

OpenGL1x

glProgramUniformMatrix3dvEXT

OpenGL1x

glProgramUniformMatrix3fv

OpenGL1x

glProgramUniformMatrix3x2dv

OpenGL1x

glProgramUniformMatrix3x2dvEXT

OpenGL1x

glProgramUniformMatrix3x2fv

OpenGL1x

glProgramUniformMatrix3x4dv

OpenGL1x

glProgramUniformMatrix3x4dvEXT

OpenGL1x

glProgramUniformMatrix3x4fv

OpenGL1x

glProgramUniformMatrix4dv

OpenGL1x

glProgramUniformMatrix4dvEXT

OpenGL1x

glProgramUniformMatrix4fv

OpenGL1x

glProgramUniformMatrix4x2dv

OpenGL1x

glProgramUniformMatrix4x2dvEXT

OpenGL1x

glProgramUniformMatrix4x2fv

OpenGL1x

glProgramUniformMatrix4x3dv

OpenGL1x

glProgramUniformMatrix4x3dvEXT

OpenGL1x

glProgramUniformMatrix4x3fv

OpenGL1x

glProgramUniformui64NV

OpenGL1x

glProgramUniformui64vNV

OpenGL1x

glProgramVertexLimitNV

OpenGL1x

glProvokingVertex

OpenGL1x

glPushAttrib

OpenGL1x

glPushClientAttrib

OpenGL1x

glPushMatrix

OpenGL1x

glPushName

OpenGL1x

glQueryCounter

OpenGL1x

glRasterPos2d

OpenGL1x

glRasterPos2dv

OpenGL1x

glRasterPos2f

OpenGL1x

glRasterPos2fv

OpenGL1x

glRasterPos2i

OpenGL1x

glRasterPos2iv

OpenGL1x

glRasterPos2s

OpenGL1x

glRasterPos2sv

OpenGL1x

glRasterPos3d

OpenGL1x

glRasterPos3dv

OpenGL1x

glRasterPos3f

OpenGL1x

glRasterPos3fv

OpenGL1x

glRasterPos3i

OpenGL1x

glRasterPos3iv

OpenGL1x

glRasterPos3s

OpenGL1x

glRasterPos3sv

OpenGL1x

glRasterPos4d

OpenGL1x

glRasterPos4dv

OpenGL1x

glRasterPos4f

OpenGL1x

glRasterPos4fv

OpenGL1x

glRasterPos4i

OpenGL1x

glRasterPos4iv

OpenGL1x

glRasterPos4s

OpenGL1x

glRasterPos4sv

OpenGL1x

glReadBuffer

OpenGL1x

glReadnPixelsARB

OpenGL1x

glReadPixels

OpenGL1x

GLRect

GLCrossPlatform

glRectd

OpenGL1x

glRectdv

OpenGL1x

glRectf

OpenGL1x

glRectfv

OpenGL1x

glRecti

OpenGL1x

glRectiv

OpenGL1x

glRects

OpenGL1x

glRectsv

OpenGL1x

GLRegisterWSComponent

GLWidgetContext

GLRegisterWSComponent

GLSceneForm

glReleaseShaderCompiler

OpenGL1x

glRenderbufferStorage

OpenGL1x

glRenderbufferStorageEXT

OpenGL1x

glRenderbufferStorageMultisample

OpenGL1x

glRenderbufferStorageMultisampleEXT

OpenGL1x

glRenderMode

OpenGL1x

glRequestResidentProgramsNV

OpenGL1x

glResetHistogram

OpenGL1x

glResetMinmax

OpenGL1x

glResizeBuffersMESA

OpenGL1x

glResumeTransformFeedback

OpenGL1x

glRotated

OpenGL1x

glRotatef

OpenGL1x

glsAllFilter

GLCrossPlatform

glsAlreadyRendering

GLStrings

glSampleCoverage

OpenGL1x

glSampleCoverageARB

OpenGL1x

glSampleMaskEXT

OpenGL1x

glSampleMaski

OpenGL1x

glSampleMaskSGIS

OpenGL1x

glSamplePassARB

OpenGL1x

glSamplePatternEXT

OpenGL1x

glSamplePatternSGIS

OpenGL1x

glSamplerParameterf

OpenGL1x

glSamplerParameterfv

OpenGL1x

glSamplerParameteri

OpenGL1x

glSamplerParameterIiv

OpenGL1x

glSamplerParameterIuiv

OpenGL1x

glSamplerParameteriv

OpenGL1x

glsCadencerNotDefined

GLStrings

glsCadencerNotDefinedEx

GLStrings

glScaled

OpenGL1x

glScalef

OpenGL1x

glsCamera

GLStrings

glsCameraRoot

GLStrings

GLSceneEditorForm

GLSceneEdit

GLSceneEditorForm

GLSceneEditLCL

GLSceneMatrixToODER

ODEGL

GLSCENE_REVISION

GLScene

GLSCENE_VERSION

GLScene

glScissor

OpenGL1x

glScissorArrayv

OpenGL1x

glScissorIndexed

OpenGL1x

glScissorIndexedv

OpenGL1x

GLSCUDAEditorForm

GLSCUDAEditor

glsDisplayList

GLStrings

GLSDOMNode

GLSCrossXML

glsDot

GLStrings

glsDriverNotSupportDebugRC

GLWin32Context

glsDriverNotSupportFRC

GLWin32Context

glsDriverNotSupportOESRC

GLWin32Context

glSecondaryColor3b

OpenGL1x

glSecondaryColor3bEXT

OpenGL1x

glSecondaryColor3bv

OpenGL1x

glSecondaryColor3bvEXT

OpenGL1x

glSecondaryColor3d

OpenGL1x

glSecondaryColor3dEXT

OpenGL1x

glSecondaryColor3dv

OpenGL1x

glSecondaryColor3dvEXT

OpenGL1x

glSecondaryColor3f

OpenGL1x

glSecondaryColor3fEXT

OpenGL1x

glSecondaryColor3fv

OpenGL1x

glSecondaryColor3fvEXT

OpenGL1x

glSecondaryColor3i

OpenGL1x

glSecondaryColor3iEXT

OpenGL1x

glSecondaryColor3iv

OpenGL1x

glSecondaryColor3ivEXT

OpenGL1x

glSecondaryColor3s

OpenGL1x

glSecondaryColor3sEXT

OpenGL1x

glSecondaryColor3sv

OpenGL1x

glSecondaryColor3svEXT

OpenGL1x

glSecondaryColor3ub

OpenGL1x

glSecondaryColor3ubEXT

OpenGL1x

glSecondaryColor3ubv

OpenGL1x

glSecondaryColor3ubvEXT

OpenGL1x

glSecondaryColor3ui

OpenGL1x

glSecondaryColor3uiEXT

OpenGL1x

glSecondaryColor3uiv

OpenGL1x

glSecondaryColor3uivEXT

OpenGL1x

glSecondaryColor3us

OpenGL1x

glSecondaryColor3usEXT

OpenGL1x

glSecondaryColor3usv

OpenGL1x

glSecondaryColor3usvEXT

OpenGL1x

glSecondaryColorFormatNV

OpenGL1x

glSecondaryColorP3ui

OpenGL1x

glSecondaryColorP3uiv

OpenGL1x

glSecondaryColorPointer

OpenGL1x

glSecondaryColorPointerEXT

OpenGL1x

glSelectBuffer

OpenGL1x

glSeparableFilter2D

OpenGL1x

glsError

GLStrings

glsErrorEx

GLStrings

GLSetCursorPos

GLScreen

glSetFenceNV

OpenGL1x

glsFailedOpenFile

GLStrings

glsFailedOpenFileFromCurrentDir

GLStrings

glsFailedToShare

GLContext

glsFileNotFound

GLStrings

glsFRC_created

GLWin32Context

glShadeModel

OpenGL1x

glShaderBinary

OpenGL1x

GLShaderEditorForm

FShaderMemo

glShaderSource

OpenGL1x

glShaderSourceARB

OpenGL1x

GLshort

OpenGLTokens

GLShowCursor

GLScreen

glsImageInvalid

GLStrings

glsIncompatibleTypes

GLStrings

glsInterleaveNotSupported

GLStrings

GLsizei

OpenGLTokens

GLsizeiptr

OpenGLTokens

GLSLogger

GLSLog

GLSLTypeComponentCount

GLSLParameter

GLSLTypeEnum

GLSLParameter

glsMaterialNotFound

GLStrings

glsMaterialNotFoundInMatlib

GLStrings

glsMaterialNotFoundInMatlibEx

GLStrings

glsMatLibNotDefined

GLStrings

glsMissingResource

GLStrings

GLSNewXMLDocument

GLSCrossXML

glsNoDescriptionAvailable

GLStrings

glsNoNewTexture

GLStrings

glsNoRenderingContext

GLStrings

glsObjectRoot

GLStrings

glsOCAdvancedGeometry

GLStrings

glsOCBasicGeometry

GLStrings

glsOCDoodad

GLStrings

glsOCEnvironmentObjects

GLStrings

glsOCExperimental

GLStrings

glsOCGraphPlottingObjects

GLStrings

glsOCGuiObjects

GLStrings

glsOCHUDObjects

GLStrings

glsOCMeshObjects

GLStrings

glsOCParticleSystems

GLStrings

glsOCProxyObjects

GLStrings

glsOCSpecialObjects

GLStrings

glsOESRC_created

GLWin32Context

glsOESvsForwardRC

GLWin32Context

glsOutOfMemory

GLStrings

glsPBufferRC_created

GLWin32Context

glsSceneRoot

GLStrings

glsSceneViewerNotDefined

GLStrings

glsShaderMaxLightSources

GLCustomShader

glsShaderNeedsAtLeastOneLightSource

GLStrings

glsShaderNeedsAtLeastOneLightSourceEx

GLStrings

glsSphereStartStop

GLStrings

glsSphereTopBottom

GLStrings

glStencilClearTagEXT

OpenGL1x

glStencilFunc

OpenGL1x

glStencilFuncSeparate

OpenGL1x

glStencilMask

OpenGL1x

glStencilMaskSeparate

OpenGL1x

glStencilOp

OpenGL1x

glStencilOpSeparate

OpenGL1x

GLSTime

GLCrossPlatform

Returns time in milisecond from application start.<p>

glsTmpRC_Created

GLWin32Context

glsTooManyLights

GLStrings

glStringMarkerGREMEDY

OpenGL1x

glsUnBalancedBeginEndUpdate

GLStrings

glsUnknownArchive

GLStrings

glsUnknownExtension

GLStrings

glsUnknownParam

GLStrings

glsUnknownType

GLStrings

glsUnsupportedType

GLStrings

glsWrongBitmapCanvas

GLStrings

glsWrongPrinter

GLStrings

glsWrongVersion

GLStrings

GLSXMLDocument

GLSCrossXML

GLSXMLNode

GLSCrossXML

GLsync

OpenGLTokens

GLS_FONT_CHARS_COUNT

GLCrossPlatform

GLS_RC_DDS_Type

ApplicationFileIO

GLS_RC_JPG_Type

ApplicationFileIO

GLS_RC_String_Type

ApplicationFileIO

GLS_RC_XML_Type

ApplicationFileIO

GLS_VERTEX_ATTR_NUM

GLState

glTbufferMask3DFX

OpenGL1x

glTessellationFactorAMD

OpenGL1x

glTessellationModeAMD

OpenGL1x

glTestFenceNV

OpenGL1x

glTexBuffer

OpenGL1x

glTexBufferARB

OpenGL1x

glTexBufferEXT

OpenGL1x

glTexCoord1d

OpenGL1x

glTexCoord1dv

OpenGL1x

glTexCoord1f

OpenGL1x

glTexCoord1fv

OpenGL1x

glTexCoord1i

OpenGL1x

glTexCoord1iv

OpenGL1x

glTexCoord1s

OpenGL1x

glTexCoord1sv

OpenGL1x

glTexCoord2d

OpenGL1x

glTexCoord2dv

OpenGL1x

glTexCoord2f

OpenGL1x

glTexCoord2fv

OpenGL1x

glTexCoord2i

OpenGL1x

glTexCoord2iv

OpenGL1x

glTexCoord2s

OpenGL1x

glTexCoord2sv

OpenGL1x

glTexCoord3d

OpenGL1x

glTexCoord3dv

OpenGL1x

glTexCoord3f

OpenGL1x

glTexCoord3fv

OpenGL1x

glTexCoord3i

OpenGL1x

glTexCoord3iv

OpenGL1x

glTexCoord3s

OpenGL1x

glTexCoord3sv

OpenGL1x

glTexCoord4d

OpenGL1x

glTexCoord4dv

OpenGL1x

glTexCoord4f

OpenGL1x

glTexCoord4fv

OpenGL1x

glTexCoord4i

OpenGL1x

glTexCoord4iv

OpenGL1x

glTexCoord4s

OpenGL1x

glTexCoord4sv

OpenGL1x

glTexCoordFormatNV

OpenGL1x

glTexCoordP1ui

OpenGL1x

glTexCoordP1uiv

OpenGL1x

glTexCoordP2ui

OpenGL1x

glTexCoordP2uiv

OpenGL1x

glTexCoordP3ui

OpenGL1x

glTexCoordP3uiv

OpenGL1x

glTexCoordP4ui

OpenGL1x

glTexCoordP4uiv

OpenGL1x

glTexCoordPointer

OpenGL1x

glTexEnvf

OpenGL1x

glTexEnvfv

OpenGL1x

glTexEnvi

OpenGL1x

glTexEnviv

OpenGL1x

glTexGend

OpenGL1x

glTexGendv

OpenGL1x

glTexGenf

OpenGL1x

glTexGenfv

OpenGL1x

glTexGeni

OpenGL1x

glTexGeniv

OpenGL1x

glTexImage1D

OpenGL1x

glTexImage2D

OpenGL1x

glTexImage2DMultisample

OpenGL1x

glTexImage3D

OpenGL1x

glTexImage3DEXT

OpenGL1x

glTexImage3DMultisample

OpenGL1x

glTexParameterf

OpenGL1x

glTexParameterfv

OpenGL1x

glTexParameteri

OpenGL1x

glTexParameterIiv

OpenGL1x

glTexParameterIivEXT

OpenGL1x

glTexParameterIuiv

OpenGL1x

glTexParameterIuivEXT

OpenGL1x

glTexParameteriv

OpenGL1x

glTexSubImage1D

OpenGL1x

glTexSubImage1DEXT

OpenGL1x

glTexSubImage2D

OpenGL1x

glTexSubImage2DEXT

OpenGL1x

glTexSubImage3D

OpenGL1x

glTexSubImage3DEXT

OpenGL1x

glTextureColorMaskSGIS

OpenGL1x

glTrackMatrixNV

OpenGL1x

glTransformFeedbackAttribsNV

OpenGL1x

glTransformFeedbackVaryings

OpenGL1x

glTransformFeedbackVaryingsEXT

OpenGL1x

glTransformFeedbackVaryingsNV

OpenGL1x

glTranslated

OpenGL1x

glTranslatef

OpenGL1x

glu32

OpenGLTokens

gluBeginCurve

OpenGLAdapter

gluBeginCurve

OpenGL1x

gluBeginPolygon

OpenGL1x

gluBeginPolygon

OpenGLAdapter

gluBeginSurface

OpenGL1x

gluBeginSurface

OpenGLAdapter

gluBeginTrim

OpenGLAdapter

gluBeginTrim

OpenGL1x

gluBuild1DMipmaps

OpenGL1x

gluBuild1DMipmaps

OpenGLAdapter

gluBuild2DMipmaps

OpenGL1x

gluBuild2DMipmaps

OpenGLAdapter

GLubyte

OpenGLTokens

gluCylinder

OpenGLAdapter

gluCylinder

OpenGL1x

gluDeleteNurbsRenderer

OpenGLAdapter

gluDeleteNurbsRenderer

OpenGL1x

gluDeleteNurbsTessellatorEXT

OpenGL1x

gluDeleteQuadric

OpenGLAdapter

gluDeleteQuadric

OpenGL1x

gluDeleteTess

OpenGLAdapter

gluDeleteTess

OpenGL1x

gluDisk

OpenGL1x

gluDisk

OpenGLAdapter

gluEndCurve

OpenGLAdapter

gluEndCurve

OpenGL1x

gluEndPolygon

OpenGLAdapter

gluEndPolygon

OpenGL1x

gluEndSurface

OpenGL1x

gluEndSurface

OpenGLAdapter

gluEndTrim

OpenGL1x

gluEndTrim

OpenGLAdapter

gluErrorString

OpenGL1x

gluErrorString

OpenGLAdapter

gluGetNurbsProperty

OpenGLAdapter

gluGetNurbsProperty

OpenGL1x

gluGetString

OpenGLAdapter

gluGetString

OpenGL1x

gluGetTessProperty

OpenGLAdapter

gluGetTessProperty

OpenGL1x

GLuint

OpenGLTokens

GLuint64

OpenGLTokens

GLuint64EXT

OpenGLTokens

gluLoadSamplingMatrices

OpenGL1x

gluLoadSamplingMatrices

OpenGLAdapter

gluLookAt

OpenGL1x

gluLookAt

OpenGLAdapter

gluNewNurbsRenderer

OpenGL1x

gluNewNurbsRenderer

OpenGLAdapter

gluNewNurbsTessellatorEXT

OpenGL1x

gluNewQuadric

OpenGL1x

gluNewQuadric

OpenGLAdapter

gluNewTess

OpenGL1x

gluNewTess

OpenGLAdapter

gluNextContour

OpenGLAdapter

gluNextContour

OpenGL1x

glUniform1d

OpenGL1x

glUniform1dv

OpenGL1x

glUniform1f

OpenGL1x

glUniform1fARB

OpenGL1x

glUniform1fv

OpenGL1x

glUniform1fvARB

OpenGL1x

glUniform1i

OpenGL1x

glUniform1iARB

OpenGL1x

glUniform1iv

OpenGL1x

glUniform1ivARB

OpenGL1x

glUniform1ui

OpenGL1x

glUniform1uiEXT

OpenGL1x

glUniform1uiv

OpenGL1x

glUniform1uivEXT

OpenGL1x

glUniform2d

OpenGL1x

glUniform2dv

OpenGL1x

glUniform2f

OpenGL1x

glUniform2fARB

OpenGL1x

glUniform2fv

OpenGL1x

glUniform2fvARB

OpenGL1x

glUniform2i

OpenGL1x

glUniform2iARB

OpenGL1x

glUniform2iv

OpenGL1x

glUniform2ivARB

OpenGL1x

glUniform2ui

OpenGL1x

glUniform2uiEXT

OpenGL1x

glUniform2uiv

OpenGL1x

glUniform2uivEXT

OpenGL1x

glUniform3d

OpenGL1x

glUniform3dv

OpenGL1x

glUniform3f

OpenGL1x

glUniform3fARB

OpenGL1x

glUniform3fv

OpenGL1x

glUniform3fvARB

OpenGL1x

glUniform3i

OpenGL1x

glUniform3iARB

OpenGL1x

glUniform3iv

OpenGL1x

glUniform3ivARB

OpenGL1x

glUniform3ui

OpenGL1x

glUniform3uiEXT

OpenGL1x

glUniform3uiv

OpenGL1x

glUniform3uivEXT

OpenGL1x

glUniform4d

OpenGL1x

glUniform4dv

OpenGL1x

glUniform4f

OpenGL1x

glUniform4fARB

OpenGL1x

glUniform4fv

OpenGL1x

glUniform4fvARB

OpenGL1x

glUniform4i

OpenGL1x

glUniform4iARB

OpenGL1x

glUniform4iv

OpenGL1x

glUniform4ivARB

OpenGL1x

glUniform4ui

OpenGL1x

glUniform4uiEXT

OpenGL1x

glUniform4uiv

OpenGL1x

glUniform4uivEXT

OpenGL1x

glUniformBlockBinding

OpenGL1x

glUniformBufferEXT

OpenGL1x

glUniformMatrix2dv

OpenGL1x

glUniformMatrix2fv

OpenGL1x

glUniformMatrix2fvARB

OpenGL1x

glUniformMatrix2x3dv

OpenGL1x

glUniformMatrix2x3fv

OpenGL1x

glUniformMatrix2x4dv

OpenGL1x

glUniformMatrix2x4fv

OpenGL1x

glUniformMatrix3dv

OpenGL1x

glUniformMatrix3fv

OpenGL1x

glUniformMatrix3fvARB

OpenGL1x

glUniformMatrix3x2dv

OpenGL1x

glUniformMatrix3x2fv

OpenGL1x

glUniformMatrix3x4dv

OpenGL1x

glUniformMatrix3x4fv

OpenGL1x

glUniformMatrix4dv

OpenGL1x

glUniformMatrix4fv

OpenGL1x

glUniformMatrix4fvARB

OpenGL1x

glUniformMatrix4x2dv

OpenGL1x

glUniformMatrix4x2fv

OpenGL1x

glUniformMatrix4x3dv

OpenGL1x

glUniformMatrix4x3fv

OpenGL1x

glUniformSubroutinesuiv

OpenGL1x

glUniformui64NV

OpenGL1x

glUniformui64vNV

OpenGL1x

glUnlockArraysEXT

OpenGL1x

glUnmapBuffer

OpenGL1x

glUnmapBufferARB

OpenGL1x

gluNurbsCallback

OpenGL1x

gluNurbsCallback

OpenGLAdapter

gluNurbsCallbackDataEXT

OpenGL1x

gluNurbsCurve

OpenGL1x

gluNurbsCurve

OpenGLAdapter

gluNurbsProperty

OpenGL1x

gluNurbsProperty

OpenGLAdapter

gluNurbsSurface

OpenGL1x

gluNurbsSurface

OpenGLAdapter

gluOrtho2D

OpenGL1x

gluOrtho2D

OpenGLAdapter

gluPartialDisk

OpenGLAdapter

gluPartialDisk

OpenGL1x

gluPerspective

OpenGLAdapter

gluPerspective

OpenGL1x

gluPickMatrix

OpenGL1x

gluPickMatrix

OpenGLAdapter

gluProject

OpenGL1x

gluProject

OpenGLAdapter

gluPwlCurve

OpenGL1x

gluPwlCurve

OpenGLAdapter

gluQuadricCallback

OpenGL1x

gluQuadricCallback

OpenGLAdapter

gluQuadricDrawStyle

OpenGLAdapter

gluQuadricDrawStyle

OpenGL1x

gluQuadricNormals

OpenGL1x

gluQuadricNormals

OpenGLAdapter

gluQuadricOrientation

OpenGL1x

gluQuadricOrientation

OpenGLAdapter

gluQuadricTexture

OpenGL1x

gluQuadricTexture

OpenGLAdapter

gluScaleImage

OpenGLAdapter

gluScaleImage

OpenGL1x

glUseProgram

OpenGL1x

glUseProgramObjectARB

OpenGL1x

glUseProgramStages

OpenGL1x

GLushort

OpenGLTokens

gluSphere

OpenGL1x

gluSphere

OpenGLAdapter

gluTessBeginContour

OpenGLAdapter

gluTessBeginContour

OpenGL1x

gluTessBeginPolygon

OpenGL1x

gluTessBeginPolygon

OpenGLAdapter

gluTessCallback

OpenGLAdapter

gluTessCallback

OpenGL1x

gluTessEndContour

OpenGLAdapter

gluTessEndContour

OpenGL1x

gluTessEndPolygon

OpenGL1x

gluTessEndPolygon

OpenGLAdapter

gluTessNormal

OpenGL1x

gluTessNormal

OpenGLAdapter

gluTessProperty

OpenGL1x

gluTessProperty

OpenGLAdapter

gluTessVertex

OpenGLAdapter

gluTessVertex

OpenGL1x

gluUnProject

OpenGLAdapter

gluUnProject

OpenGL1x

GLU_AUTO_LOAD_MATRIX

OpenGLTokens

GLU_BEGIN

OpenGLTokens

GLU_CCW

OpenGLTokens

GLU_CULLING

OpenGLTokens

GLU_CW

OpenGLTokens

GLU_DISPLAY_MODE

OpenGLTokens

GLU_DOMAIN_DISTANCE

OpenGLTokens

GLU_EDGE_FLAG

OpenGLTokens

GLU_END

OpenGLTokens

GLU_ERROR

OpenGLTokens

GLU_EXTENSIONS

OpenGLTokens

GLU_EXTERIOR

OpenGLTokens

GLU_EXT_nurbs_tessellator

OpenGL1x

GLU_EXT_object_space_tess

OpenGL1x

GLU_EXT_Texture

OpenGL1x

GLU_FALSE

OpenGLTokens

GLU_FILL

OpenGLTokens

GLU_FLAT

OpenGLTokens

GLU_INCOMPATIBLE_GL_VERSION

OpenGLTokens

GLU_INSIDE

OpenGLTokens

GLU_INTERIOR

OpenGLTokens

GLU_INVALID_ENUM

OpenGLTokens

GLU_INVALID_VALUE

OpenGLTokens

GLU_LINE

OpenGLTokens

GLU_MAP1_TRIM_2

OpenGLTokens

GLU_MAP1_TRIM_3

OpenGLTokens

GLU_NONE

OpenGLTokens

GLU_NURBS_BEGIN_DATA_EXT

OpenGLTokens

GLU_NURBS_BEGIN_EXT

OpenGLTokens

GLU_NURBS_COLOR_DATA_EXT

OpenGLTokens

GLU_NURBS_COLOR_EXT

OpenGLTokens

GLU_NURBS_END_DATA_EXT

OpenGLTokens

GLU_NURBS_END_EXT

OpenGLTokens

GLU_NURBS_ERROR1

OpenGLTokens

GLU_NURBS_ERROR10

OpenGLTokens

GLU_NURBS_ERROR11

OpenGLTokens

GLU_NURBS_ERROR12

OpenGLTokens

GLU_NURBS_ERROR13

OpenGLTokens

GLU_NURBS_ERROR14

OpenGLTokens

GLU_NURBS_ERROR15

OpenGLTokens

GLU_NURBS_ERROR16

OpenGLTokens

GLU_NURBS_ERROR17

OpenGLTokens

GLU_NURBS_ERROR18

OpenGLTokens

GLU_NURBS_ERROR19

OpenGLTokens

GLU_NURBS_ERROR2

OpenGLTokens

GLU_NURBS_ERROR20

OpenGLTokens

GLU_NURBS_ERROR21

OpenGLTokens

GLU_NURBS_ERROR22

OpenGLTokens

GLU_NURBS_ERROR23

OpenGLTokens

GLU_NURBS_ERROR24

OpenGLTokens

GLU_NURBS_ERROR25

OpenGLTokens

GLU_NURBS_ERROR26

OpenGLTokens

GLU_NURBS_ERROR27

OpenGLTokens

GLU_NURBS_ERROR28

OpenGLTokens

GLU_NURBS_ERROR29

OpenGLTokens

GLU_NURBS_ERROR3

OpenGLTokens

GLU_NURBS_ERROR30

OpenGLTokens

GLU_NURBS_ERROR31

OpenGLTokens

GLU_NURBS_ERROR32

OpenGLTokens

GLU_NURBS_ERROR33

OpenGLTokens

GLU_NURBS_ERROR34

OpenGLTokens

GLU_NURBS_ERROR35

OpenGLTokens

GLU_NURBS_ERROR36

OpenGLTokens

GLU_NURBS_ERROR37

OpenGLTokens

GLU_NURBS_ERROR4

OpenGLTokens

GLU_NURBS_ERROR5

OpenGLTokens

GLU_NURBS_ERROR6

OpenGLTokens

GLU_NURBS_ERROR7

OpenGLTokens

GLU_NURBS_ERROR8

OpenGLTokens

GLU_NURBS_ERROR9

OpenGLTokens

GLU_NURBS_MODE_EXT

OpenGLTokens

GLU_NURBS_NORMAL_DATA_EXT

OpenGLTokens

GLU_NURBS_NORMAL_EXT

OpenGLTokens

GLU_NURBS_RENDERER_EXT

OpenGLTokens

GLU_NURBS_TESSELLATOR_EXT

OpenGLTokens

GLU_NURBS_TEX_COORD_DATA_EXT

OpenGLTokens

GLU_NURBS_TEX_COORD_EXT

OpenGLTokens

GLU_NURBS_VERTEX_DATA_EXT

OpenGLTokens

GLU_NURBS_VERTEX_EXT

OpenGLTokens

GLU_OBJECT_PARAMETRIC_ERROR_EXT

OpenGLTokens

GLU_OBJECT_PATH_LENGTH_EXT

OpenGLTokens

GLU_OUTLINE_PATCH

OpenGLTokens

GLU_OUTLINE_POLYGON

OpenGLTokens

GLU_OUTSIDE

OpenGLTokens

GLU_OUT_OF_MEMORY

OpenGLTokens

GLU_PARAMETRIC_ERROR

OpenGLTokens

GLU_PARAMETRIC_TOLERANCE

OpenGLTokens

GLU_PATH_LENGTH

OpenGLTokens

GLU_POINT

OpenGLTokens

GLU_SAMPLING_METHOD

OpenGLTokens

GLU_SAMPLING_TOLERANCE

OpenGLTokens

GLU_SILHOUETTE

OpenGLTokens

GLU_SMOOTH

OpenGLTokens

GLU_TESS_BEGIN

OpenGLTokens

GLU_TESS_BEGIN_DATA

OpenGLTokens

GLU_TESS_BOUNDARY_ONLY

OpenGLTokens

GLU_TESS_COMBINE

OpenGLTokens

GLU_TESS_COMBINE_DATA

OpenGLTokens

GLU_TESS_COORD_TOO_LARGE

OpenGLTokens

GLU_TESS_EDGE_FLAG

OpenGLTokens

GLU_TESS_EDGE_FLAG_DATA

OpenGLTokens

GLU_TESS_END

OpenGLTokens

GLU_TESS_END_DATA

OpenGLTokens

GLU_TESS_ERROR

OpenGLTokens

GLU_TESS_ERROR1

OpenGLTokens

GLU_TESS_ERROR2

OpenGLTokens

GLU_TESS_ERROR3

OpenGLTokens

GLU_TESS_ERROR4

OpenGLTokens

GLU_TESS_ERROR5

OpenGLTokens

GLU_TESS_ERROR6

OpenGLTokens

GLU_TESS_ERROR7

OpenGLTokens

GLU_TESS_ERROR8

OpenGLTokens

GLU_TESS_ERROR_DATA

OpenGLTokens

GLU_TESS_MAX_COORD

OpenGLTokens

GLU_TESS_MISSING_BEGIN_CONTOUR

OpenGLTokens

GLU_TESS_MISSING_BEGIN_POLYGON

OpenGLTokens

GLU_TESS_MISSING_END_CONTOUR

OpenGLTokens

GLU_TESS_MISSING_END_POLYGON

OpenGLTokens

GLU_TESS_NEED_COMBINE_CALLBACK

OpenGLTokens

GLU_TESS_TOLERANCE

OpenGLTokens

GLU_TESS_VERTEX

OpenGLTokens

GLU_TESS_VERTEX_DATA

OpenGLTokens

GLU_TESS_WINDING_ABS_GEQ_TWO

OpenGLTokens

GLU_TESS_WINDING_NEGATIVE

OpenGLTokens

GLU_TESS_WINDING_NONZERO

OpenGLTokens

GLU_TESS_WINDING_ODD

OpenGLTokens

GLU_TESS_WINDING_POSITIVE

OpenGLTokens

GLU_TESS_WINDING_RULE

OpenGLTokens

GLU_TRUE

OpenGLTokens

GLU_UNKNOWN

OpenGLTokens

GLU_U_STEP

OpenGLTokens

GLU_VERSION

OpenGLTokens

GLU_VERSION_1_1

OpenGL1x

GLU_VERSION_1_2

OpenGL1x

GLU_VERSION_1_3

OpenGL1x

GLU_VERTEX

OpenGLTokens

GLU_V_STEP

OpenGLTokens

glValidateProgram

OpenGL1x

glValidateProgramARB

OpenGL1x

glValidateProgramPipeline

OpenGL1x

glVertex2d

OpenGL1x

glVertex2dv

OpenGL1x

glVertex2f

OpenGL1x

glVertex2fv

OpenGL1x

glVertex2i

OpenGL1x

glVertex2iv

OpenGL1x

glVertex2s

OpenGL1x

glVertex2sv

OpenGL1x

glVertex3d

OpenGL1x

glVertex3dv

OpenGL1x

glVertex3f

OpenGL1x

glVertex3fv

OpenGL1x

glVertex3i

OpenGL1x

glVertex3iv

OpenGL1x

glVertex3s

OpenGL1x

glVertex3sv

OpenGL1x

glVertex4d

OpenGL1x

glVertex4dv

OpenGL1x

glVertex4f

OpenGL1x

glVertex4fv

OpenGL1x

glVertex4i

OpenGL1x

glVertex4iv

OpenGL1x

glVertex4s

OpenGL1x

glVertex4sv

OpenGL1x

glVertexArrayRangeNV

OpenGL1x

glVertexArrayVertexAttribLOffsetEXT

OpenGL1x

glVertexAttrib1d

OpenGL1x

glVertexAttrib1dARB

OpenGL1x

glVertexAttrib1dNV

OpenGL1x

glVertexAttrib1dv

OpenGL1x

glVertexAttrib1dvARB

OpenGL1x

glVertexAttrib1dvNV

OpenGL1x

glVertexAttrib1f

OpenGL1x

glVertexAttrib1fARB

OpenGL1x

glVertexAttrib1fNV

OpenGL1x

glVertexAttrib1fv

OpenGL1x

glVertexAttrib1fvARB

OpenGL1x

glVertexAttrib1fvNV

OpenGL1x

glVertexAttrib1s

OpenGL1x

glVertexAttrib1sARB

OpenGL1x

glVertexAttrib1sNV

OpenGL1x

glVertexAttrib1sv

OpenGL1x

glVertexAttrib1svARB

OpenGL1x

glVertexAttrib1svNV

OpenGL1x

glVertexAttrib2d

OpenGL1x

glVertexAttrib2dARB

OpenGL1x

glVertexAttrib2dNV

OpenGL1x

glVertexAttrib2dv

OpenGL1x

glVertexAttrib2dvARB

OpenGL1x

glVertexAttrib2dvNV

OpenGL1x

glVertexAttrib2f

OpenGL1x

glVertexAttrib2fARB

OpenGL1x

glVertexAttrib2fNV

OpenGL1x

glVertexAttrib2fv

OpenGL1x

glVertexAttrib2fvARB

OpenGL1x

glVertexAttrib2fvNV

OpenGL1x

glVertexAttrib2s

OpenGL1x

glVertexAttrib2sARB

OpenGL1x

glVertexAttrib2sNV

OpenGL1x

glVertexAttrib2sv

OpenGL1x

glVertexAttrib2svARB

OpenGL1x

glVertexAttrib2svNV

OpenGL1x

glVertexAttrib3d

OpenGL1x

glVertexAttrib3dARB

OpenGL1x

glVertexAttrib3dNV

OpenGL1x

glVertexAttrib3dv

OpenGL1x

glVertexAttrib3dvARB

OpenGL1x

glVertexAttrib3dvNV

OpenGL1x

glVertexAttrib3f

OpenGL1x

glVertexAttrib3fARB

OpenGL1x

glVertexAttrib3fNV

OpenGL1x

glVertexAttrib3fv

OpenGL1x

glVertexAttrib3fvARB

OpenGL1x

glVertexAttrib3fvNV

OpenGL1x

glVertexAttrib3s

OpenGL1x

glVertexAttrib3sARB

OpenGL1x

glVertexAttrib3sNV

OpenGL1x

glVertexAttrib3sv

OpenGL1x

glVertexAttrib3svARB

OpenGL1x

glVertexAttrib3svNV

OpenGL1x

glVertexAttrib4bv

OpenGL1x

glVertexAttrib4bvARB

OpenGL1x

glVertexAttrib4d

OpenGL1x

glVertexAttrib4dARB

OpenGL1x

glVertexAttrib4dNV

OpenGL1x

glVertexAttrib4dv

OpenGL1x

glVertexAttrib4dvARB

OpenGL1x

glVertexAttrib4dvNV

OpenGL1x

glVertexAttrib4f

OpenGL1x

glVertexAttrib4fARB

OpenGL1x

glVertexAttrib4fNV

OpenGL1x

glVertexAttrib4fv

OpenGL1x

glVertexAttrib4fvARB

OpenGL1x

glVertexAttrib4fvNV

OpenGL1x

glVertexAttrib4iv

OpenGL1x

glVertexAttrib4ivARB

OpenGL1x

glVertexAttrib4Nbv

OpenGL1x

glVertexAttrib4NbvARB

OpenGL1x

glVertexAttrib4Niv

OpenGL1x

glVertexAttrib4NivARB

OpenGL1x

glVertexAttrib4Nsv

OpenGL1x

glVertexAttrib4NsvARB

OpenGL1x

glVertexAttrib4Nub

OpenGL1x

glVertexAttrib4NubARB

OpenGL1x

glVertexAttrib4Nubv

OpenGL1x

glVertexAttrib4NubvARB

OpenGL1x

glVertexAttrib4Nuiv

OpenGL1x

glVertexAttrib4NuivARB

OpenGL1x

glVertexAttrib4Nusv

OpenGL1x

glVertexAttrib4NusvARB

OpenGL1x

glVertexAttrib4s

OpenGL1x

glVertexAttrib4sARB

OpenGL1x

glVertexAttrib4sNV

OpenGL1x

glVertexAttrib4sv

OpenGL1x

glVertexAttrib4svARB

OpenGL1x

glVertexAttrib4svNV

OpenGL1x

glVertexAttrib4ubv

OpenGL1x

glVertexAttrib4ubvARB

OpenGL1x

glVertexAttrib4ubvNV

OpenGL1x

glVertexAttrib4uiv

OpenGL1x

glVertexAttrib4uivARB

OpenGL1x

glVertexAttrib4usv

OpenGL1x

glVertexAttrib4usvARB

OpenGL1x

glVertexAttribDivisor

OpenGL1x

glVertexAttribDivisorARB

OpenGL1x

glVertexAttribFormatNV

OpenGL1x

glVertexAttribI1i

OpenGL1x

glVertexAttribI1iEXT

OpenGL1x

glVertexAttribI1iv

OpenGL1x

glVertexAttribI1ivEXT

OpenGL1x

glVertexAttribI1ui

OpenGL1x

glVertexAttribI1uiEXT

OpenGL1x

glVertexAttribI1uiv

OpenGL1x

glVertexAttribI1uivEXT

OpenGL1x

glVertexAttribI2i

OpenGL1x

glVertexAttribI2iEXT

OpenGL1x

glVertexAttribI2iv

OpenGL1x

glVertexAttribI2ivEXT

OpenGL1x

glVertexAttribI2ui

OpenGL1x

glVertexAttribI2uiEXT

OpenGL1x

glVertexAttribI2uiv

OpenGL1x

glVertexAttribI2uivEXT

OpenGL1x

glVertexAttribI3i

OpenGL1x

glVertexAttribI3iEXT

OpenGL1x

glVertexAttribI3iv

OpenGL1x

glVertexAttribI3ivEXT

OpenGL1x

glVertexAttribI3ui

OpenGL1x

glVertexAttribI3uiEXT

OpenGL1x

glVertexAttribI3uiv

OpenGL1x

glVertexAttribI3uivEXT

OpenGL1x

glVertexAttribI4bv

OpenGL1x

glVertexAttribI4bvEXT

OpenGL1x

glVertexAttribI4i

OpenGL1x

glVertexAttribI4iEXT

OpenGL1x

glVertexAttribI4iv

OpenGL1x

glVertexAttribI4ivEXT

OpenGL1x

glVertexAttribI4sv

OpenGL1x

glVertexAttribI4svEXT

OpenGL1x

glVertexAttribI4ubv

OpenGL1x

glVertexAttribI4ubvEXT

OpenGL1x

glVertexAttribI4ui

OpenGL1x

glVertexAttribI4uiEXT

OpenGL1x

glVertexAttribI4uiv

OpenGL1x

glVertexAttribI4uivEXT

OpenGL1x

glVertexAttribI4usv

OpenGL1x

glVertexAttribI4usvEXT

OpenGL1x

glVertexAttribIFormatNV

OpenGL1x

glVertexAttribIPointer

OpenGL1x

glVertexAttribIPointerEXT

OpenGL1x

glVertexAttribL1d

OpenGL1x

glVertexAttribL1dv

OpenGL1x

glVertexAttribL2d

OpenGL1x

glVertexAttribL2dv

OpenGL1x

glVertexAttribL3d

OpenGL1x

glVertexAttribL3dv

OpenGL1x

glVertexAttribL4d

OpenGL1x

glVertexAttribL4dv

OpenGL1x

glVertexAttribLPointer

OpenGL1x

glVertexAttribP1ui

OpenGL1x

glVertexAttribP1uiv

OpenGL1x

glVertexAttribP2ui

OpenGL1x

glVertexAttribP2uiv

OpenGL1x

glVertexAttribP3ui

OpenGL1x

glVertexAttribP3uiv

OpenGL1x

glVertexAttribP4ui

OpenGL1x

glVertexAttribP4uiv

OpenGL1x

glVertexAttribPointer

OpenGL1x

glVertexAttribPointerARB

OpenGL1x

glVertexAttribPointerNV

OpenGL1x

glVertexAttribs1dvNV

OpenGL1x

glVertexAttribs1fvNV

OpenGL1x

glVertexAttribs1svNV

OpenGL1x

glVertexAttribs2dvNV

OpenGL1x

glVertexAttribs2fvNV

OpenGL1x

glVertexAttribs2svNV

OpenGL1x

glVertexAttribs3dvNV

OpenGL1x

glVertexAttribs3fvNV

OpenGL1x

glVertexAttribs3svNV

OpenGL1x

glVertexAttribs4dvNV

OpenGL1x

glVertexAttribs4fvNV

OpenGL1x

glVertexAttribs4svNV

OpenGL1x

glVertexAttribs4ubvNV

OpenGL1x

glVertexBlendARB

OpenGL1x

glVertexFormatNV

OpenGL1x

glVertexP2ui

OpenGL1x

glVertexP2uiv

OpenGL1x

glVertexP3ui

OpenGL1x

glVertexP3uiv

OpenGL1x

glVertexP4ui

OpenGL1x

glVertexP4uiv

OpenGL1x

glVertexPointer

OpenGL1x

glViewport

OpenGL1x

glViewportArrayv

OpenGL1x

glViewportIndexedf

OpenGL1x

glViewportIndexedfv

OpenGL1x

glWaitSync

OpenGL1x

glWeightbvARB

OpenGL1x

glWeightdvARB

OpenGL1x

glWeightfvARB

OpenGL1x

glWeightivARB

OpenGL1x

glWeightPointerARB

OpenGL1x

glWeightsvARB

OpenGL1x

glWeightubvARB

OpenGL1x

glWeightuivARB

OpenGL1x

glWeightusvARB

OpenGL1x

glWindowPos2d

OpenGL1x

glWindowPos2dARB

OpenGL1x

glWindowPos2dv

OpenGL1x

glWindowPos2dvARB

OpenGL1x

glWindowPos2f

OpenGL1x

glWindowPos2fARB

OpenGL1x

glWindowPos2fv

OpenGL1x

glWindowPos2fvARB

OpenGL1x

glWindowPos2i

OpenGL1x

glWindowPos2iARB

OpenGL1x

glWindowPos2iv

OpenGL1x

glWindowPos2ivARB

OpenGL1x

glWindowPos2s

OpenGL1x

glWindowPos2sARB

OpenGL1x

glWindowPos2sv

OpenGL1x

glWindowPos2svARB

OpenGL1x

glWindowPos3d

OpenGL1x

glWindowPos3dARB

OpenGL1x

glWindowPos3dv

OpenGL1x

glWindowPos3dvARB

OpenGL1x

glWindowPos3f

OpenGL1x

glWindowPos3fARB

OpenGL1x

glWindowPos3fv

OpenGL1x

glWindowPos3fvARB

OpenGL1x

glWindowPos3i

OpenGL1x

glWindowPos3iARB

OpenGL1x

glWindowPos3iv

OpenGL1x

glWindowPos3ivARB

OpenGL1x

glWindowPos3s

OpenGL1x

glWindowPos3sARB

OpenGL1x

glWindowPos3sv

OpenGL1x

glWindowPos3svARB

OpenGL1x

GLX_3DFX_FULLSCREEN_MODE_MESA

OpenGLTokens

GLX_3DFX_multisample

OpenGL1x

GLX_3DFX_WINDOW_MODE_MESA

OpenGLTokens

GLX_ACCUM_ALPHA_SIZE

OpenGLTokens

GLX_ACCUM_BLUE_SIZE

OpenGLTokens

GLX_ACCUM_BUFFER_BIT

OpenGLTokens

GLX_ACCUM_BUFFER_BIT_SGIX

OpenGLTokens

GLX_ACCUM_GREEN_SIZE

OpenGLTokens

GLX_ACCUM_RED_SIZE

OpenGLTokens

GLX_ALPHA_SIZE

OpenGLTokens

GLX_ARB_create_context

OpenGL1x

GLX_ARB_create_context_profile

OpenGL1x

GLX_ARB_framebuffer_sRGB

OpenGL1x

GLX_ARB_multisample

OpenGL1x

GLX_AUX0_EXT

OpenGLTokens

GLX_AUX1_EXT

OpenGLTokens

GLX_AUX2_EXT

OpenGLTokens

GLX_AUX3_EXT

OpenGLTokens

GLX_AUX4_EXT

OpenGLTokens

GLX_AUX5_EXT

OpenGLTokens

GLX_AUX6_EXT

OpenGLTokens

GLX_AUX7_EXT

OpenGLTokens

GLX_AUX8_EXT

OpenGLTokens

GLX_AUX9_EXT

OpenGLTokens

GLX_AUX_BUFFERS

OpenGLTokens

GLX_AUX_BUFFERS_BIT

OpenGLTokens

GLX_AUX_BUFFERS_BIT_SGIX

OpenGLTokens

GLX_BACK_EXT

OpenGLTokens

GLX_BACK_LEFT_BUFFER_BIT

OpenGLTokens

GLX_BACK_LEFT_BUFFER_BIT_SGIX

OpenGLTokens

GLX_BACK_LEFT_EXT

OpenGLTokens

GLX_BACK_RIGHT_BUFFER_BIT

OpenGLTokens

GLX_BACK_RIGHT_BUFFER_BIT_SGIX

OpenGLTokens

GLX_BACK_RIGHT_EXT

OpenGLTokens

GLX_BAD_ATTRIBUTE

OpenGLTokens

GLX_BAD_CONTEXT

OpenGLTokens

GLX_BAD_ENUM

OpenGLTokens

GLX_BAD_HYPERPIPE_CONFIG_SGIX

OpenGLTokens

GLX_BAD_HYPERPIPE_SGIX

OpenGLTokens

GLX_BAD_SCREEN

OpenGLTokens

GLX_BAD_VALUE

OpenGLTokens

GLX_BAD_VISUAL

OpenGLTokens

GLX_BIND_TO_MIPMAP_TEXTURE_EXT

OpenGLTokens

GLX_BIND_TO_TEXTURE_RGBA_EXT

OpenGLTokens

GLX_BIND_TO_TEXTURE_RGB_EXT

OpenGLTokens

GLX_BIND_TO_TEXTURE_TARGETS_EXT

OpenGLTokens

GLX_BLENDED_RGBA_SGIS

OpenGLTokens

GLX_BLUE_SIZE

OpenGLTokens

GLX_BUFFER_CLOBBER_MASK_SGIX

OpenGLTokens

GLX_BUFFER_SIZE

OpenGLTokens

GLX_BUFFER_SWAP_COMPLETE_INTEL_MASK

OpenGLTokens

GLX_COLOR_INDEX_BIT

OpenGLTokens

GLX_COLOR_INDEX_BIT_SGIX

OpenGLTokens

GLX_COLOR_INDEX_TYPE

OpenGLTokens

GLX_COLOR_INDEX_TYPE_SGIX

OpenGLTokens

GLX_COLOR_SAMPLES_NV

OpenGLTokens

GLX_CONFIG_CAVEAT

OpenGLTokens

GLX_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB

OpenGLTokens

GLX_CONTEXT_CORE_PROFILE_BIT_ARB

OpenGLTokens

GLX_CONTEXT_DEBUG_BIT_ARB

OpenGLTokens

GLX_CONTEXT_FLAGS_ARB

OpenGLTokens

GLX_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB

OpenGLTokens

GLX_CONTEXT_MAJOR_VERSION_ARB

OpenGLTokens

GLX_CONTEXT_MINOR_VERSION_ARB

OpenGLTokens

GLX_CONTEXT_PROFILE_MASK_ARB

OpenGLTokens

GLX_COPY_COMPLETE_INTEL

OpenGLTokens

GLX_DAMAGED

OpenGLTokens

GLX_DAMAGED_SGIX

OpenGLTokens

GLX_DEPTH_BUFFER_BIT

OpenGLTokens

GLX_DEPTH_BUFFER_BIT_SGIX

OpenGLTokens

GLX_DEPTH_SIZE

OpenGLTokens

GLX_DEVICE_ID_NV

OpenGLTokens

GLX_DIGITAL_MEDIA_PBUFFER_SGIX

OpenGLTokens

GLX_DIRECT_COLOR

OpenGLTokens

GLX_DIRECT_COLOR_EXT

OpenGLTokens

GLX_DONT_CARE

OpenGLTokens

GLX_DOUBLEBUFFER

OpenGLTokens

GLX_DRAWABLE_TYPE

OpenGLTokens

GLX_DRAWABLE_TYPE_SGIX

OpenGLTokens

GLX_EVENT_MASK

OpenGLTokens

GLX_EVENT_MASK_SGIX

OpenGLTokens

GLX_EXCHANGE_COMPLETE_INTEL

OpenGLTokens

GLX_EXTENSIONS

OpenGLTokens

GLX_EXTENSION_NAME

OpenGLTokens

GLX_EXT_fbconfig_packed_float

OpenGL1x

GLX_EXT_framebuffer_sRGB

OpenGL1x

GLX_EXT_import_context

OpenGL1x

GLX_EXT_visual_info

OpenGL1x

GLX_EXT_visual_rating

OpenGL1x

GLX_FBCONFIG_ID

OpenGLTokens

GLX_FBCONFIG_ID_SGIX

OpenGLTokens

GLX_FLIP_COMPLETE_INTEL

OpenGLTokens

GLX_FLOAT_COMPONENTS_NV

OpenGLTokens

GLX_FRAMEBUFFER_SRGB_CAPABLE_ARB

OpenGLTokens

GLX_FRAMEBUFFER_SRGB_CAPABLE_EXT

OpenGLTokens

GLX_FRONT_EXT

OpenGLTokens

GLX_FRONT_LEFT_BUFFER_BIT

OpenGLTokens

GLX_FRONT_LEFT_BUFFER_BIT_SGIX

OpenGLTokens

GLX_FRONT_LEFT_EXT

OpenGLTokens

GLX_FRONT_RIGHT_BUFFER_BIT

OpenGLTokens

GLX_FRONT_RIGHT_BUFFER_BIT_SGIX

OpenGLTokens

GLX_FRONT_RIGHT_EXT

OpenGLTokens

GLX_GRAY_SCALE

OpenGLTokens

GLX_GRAY_SCALE_EXT

OpenGLTokens

GLX_GREEN_SIZE

OpenGLTokens

GLX_HEIGHT

OpenGLTokens

GLX_HEIGHT_SGIX

OpenGLTokens

GLX_HYPERPIPE_DISPLAY_PIPE_SGIX

OpenGLTokens

GLX_HYPERPIPE_ID_SGIX

OpenGLTokens

GLX_HYPERPIPE_PIPE_NAME_LENGTH_SGIX

OpenGLTokens

GLX_HYPERPIPE_PIXEL_AVERAGE_SGIX

OpenGLTokens

GLX_HYPERPIPE_RENDER_PIPE_SGIX

OpenGLTokens

GLX_HYPERPIPE_STEREO_SGIX

OpenGLTokens

GLX_LARGEST_BUFFER

OpenGLTokens

GLX_LARGEST_PBUFFER_SGIX

OpenGLTokens

GLX_LEVEL

OpenGLTokens

GLX_MAX_PBUFFER_HEIGHT

OpenGLTokens

GLX_MAX_PBUFFER_HEIGHT_SGIX

OpenGLTokens

GLX_MAX_PBUFFER_PIXELS

OpenGLTokens

GLX_MAX_PBUFFER_PIXELS_SGIX

OpenGLTokens

GLX_MAX_PBUFFER_WIDTH

OpenGLTokens

GLX_MAX_PBUFFER_WIDTH_SGIX

OpenGLTokens

GLX_MAX_SWAP_INTERVAL_EXT

OpenGLTokens

GLX_MESA_copy_sub_buffer

OpenGL1x

GLX_MESA_pixmap_colormap

OpenGL1x

GLX_MESA_release_buffers

OpenGL1x

GLX_MESA_set_3dfx_mode

OpenGL1x

GLX_MIPMAP_TEXTURE_EXT

OpenGLTokens

GLX_MULTISAMPLE_SUB_RECT_HEIGHT_SGIS

OpenGLTokens

GLX_MULTISAMPLE_SUB_RECT_WIDTH_SGIS

OpenGLTokens

GLX_NONE

OpenGLTokens

GLX_NONE_EXT

OpenGLTokens

GLX_NON_CONFORMANT_CONFIG

OpenGLTokens

GLX_NON_CONFORMANT_VISUAL_EXT

OpenGLTokens

GLX_NO_EXTENSION

OpenGLTokens

GLX_NUM_VIDEO_CAPTURE_SLOTS_NV

OpenGLTokens

GLX_NUM_VIDEO_SLOTS_NV

OpenGLTokens

GLX_OPTIMAL_PBUFFER_HEIGHT_SGIX

OpenGLTokens

GLX_OPTIMAL_PBUFFER_WIDTH_SGIX

OpenGLTokens

GLX_PBUFFER

OpenGLTokens

GLX_PBUFFER_BIT

OpenGLTokens

GLX_PBUFFER_BIT_SGIX

OpenGLTokens

GLX_PBUFFER_CLOBBER_MASK

OpenGLTokens

GLX_PBUFFER_HEIGHT

OpenGLTokens

GLX_PBUFFER_SGIX

OpenGLTokens

GLX_PBUFFER_WIDTH

OpenGLTokens

GLX_PIPE_RECT_LIMITS_SGIX

OpenGLTokens

GLX_PIPE_RECT_SGIX

OpenGLTokens

GLX_PIXMAP_BIT

OpenGLTokens

GLX_PIXMAP_BIT_SGIX

OpenGLTokens

GLX_PRESERVED_CONTENTS

OpenGLTokens

GLX_PRESERVED_CONTENTS_SGIX

OpenGLTokens

GLX_PSEUDO_COLOR

OpenGLTokens

GLX_PSEUDO_COLOR_EXT

OpenGLTokens

GLX_RED_SIZE

OpenGLTokens

GLX_RENDER_TYPE

OpenGLTokens

GLX_RENDER_TYPE_SGIX

OpenGLTokens

GLX_RGBA

OpenGLTokens

GLX_RGBA_BIT

OpenGLTokens

GLX_RGBA_BIT_SGIX

OpenGLTokens

GLX_RGBA_FLOAT_BIT_ARB

OpenGLTokens

GLX_RGBA_FLOAT_TYPE_ARB

OpenGLTokens

GLX_RGBA_TYPE

OpenGLTokens

GLX_RGBA_TYPE_SGIX

OpenGLTokens

GLX_RGBA_UNSIGNED_FLOAT_BIT_EXT

OpenGLTokens

GLX_RGBA_UNSIGNED_FLOAT_TYPE_EXT

OpenGLTokens

GLX_SAMPLES

OpenGLTokens

GLX_SAMPLES_ARB

OpenGLTokens

GLX_SAMPLES_SGIS

OpenGLTokens

GLX_SAMPLE_BUFFERS

OpenGLTokens

GLX_SAMPLE_BUFFERS_ARB

OpenGLTokens

GLX_SAMPLE_BUFFERS_BIT_SGIX

OpenGLTokens

GLX_SAMPLE_BUFFERS_SGIS

OpenGLTokens

GLX_SAVED

OpenGLTokens

GLX_SAVED_SGIX

OpenGLTokens

GLX_SCREEN

OpenGLTokens

GLX_SCREEN_EXT

OpenGLTokens

GLX_SGIS_blended_overlay

OpenGL1x

GLX_SGIS_multisample

OpenGL1x

GLX_SGIS_shared_multisample

OpenGL1x

GLX_SGIX_dmbuffer

OpenGL1x

GLX_SGIX_fbconfig

OpenGL1x

GLX_SGIX_hyperpipe

OpenGL1x

GLX_SGIX_pbuffer

OpenGL1x

GLX_SGIX_swap_barrier

OpenGL1x

GLX_SGIX_swap_group

OpenGL1x

GLX_SGIX_video_resize

OpenGL1x

GLX_SGIX_video_source

OpenGL1x

GLX_SGIX_visual_select_group

OpenGL1x

GLX_SGI_cushion

OpenGL1x

GLX_SGI_make_current_read

OpenGL1x

GLX_SGI_swap_control

OpenGL1x

GLX_SGI_video_sync

OpenGL1x

GLX_SHARE_CONTEXT_EXT

OpenGLTokens

GLX_SLOW_CONFIG

OpenGLTokens

GLX_SLOW_VISUAL_EXT

OpenGLTokens

GLX_STATIC_COLOR

OpenGLTokens

GLX_STATIC_COLOR_EXT

OpenGLTokens

GLX_STATIC_GRAY

OpenGLTokens

GLX_STATIC_GRAY_EXT

OpenGLTokens

GLX_STENCIL_BUFFER_BIT

OpenGLTokens

GLX_STENCIL_BUFFER_BIT_SGIX

OpenGLTokens

GLX_STENCIL_SIZE

OpenGLTokens

GLX_STEREO

OpenGLTokens

GLX_SUN_get_transparent_index

OpenGL1x

GLX_SWAP_COPY_OML

OpenGLTokens

GLX_SWAP_EXCHANGE_OML

OpenGLTokens

GLX_SWAP_INTERVAL_EXT

OpenGLTokens

GLX_SWAP_METHOD_OML

OpenGLTokens

GLX_SWAP_UNDEFINED_OML

OpenGLTokens

GLX_SYNC_FRAME_SGIX

OpenGLTokens

GLX_SYNC_SWAP_SGIX

OpenGLTokens

GLX_TEXTURE_1D_BIT_EXT

OpenGLTokens

GLX_TEXTURE_1D_EXT

OpenGLTokens

GLX_TEXTURE_2D_BIT_EXT

OpenGLTokens

GLX_TEXTURE_2D_EXT

OpenGLTokens

GLX_TEXTURE_FORMAT_EXT

OpenGLTokens

GLX_TEXTURE_FORMAT_NONE_EXT

OpenGLTokens

GLX_TEXTURE_FORMAT_RGBA_EXT

OpenGLTokens

GLX_TEXTURE_FORMAT_RGB_EXT

OpenGLTokens

GLX_TEXTURE_RECTANGLE_BIT_EXT

OpenGLTokens

GLX_TEXTURE_RECTANGLE_EXT

OpenGLTokens

GLX_TEXTURE_TARGET_EXT

OpenGLTokens

GLX_TRANSPARENT_ALPHA_VALUE

OpenGLTokens

GLX_TRANSPARENT_ALPHA_VALUE_EXT

OpenGLTokens

GLX_TRANSPARENT_BLUE_VALUE

OpenGLTokens

GLX_TRANSPARENT_BLUE_VALUE_EXT

OpenGLTokens

GLX_TRANSPARENT_GREEN_VALUE

OpenGLTokens

GLX_TRANSPARENT_GREEN_VALUE_EXT

OpenGLTokens

GLX_TRANSPARENT_INDEX

OpenGLTokens

GLX_TRANSPARENT_INDEX_EXT

OpenGLTokens

GLX_TRANSPARENT_INDEX_VALUE

OpenGLTokens

GLX_TRANSPARENT_INDEX_VALUE_EXT

OpenGLTokens

GLX_TRANSPARENT_RED_VALUE

OpenGLTokens

GLX_TRANSPARENT_RED_VALUE_EXT

OpenGLTokens

GLX_TRANSPARENT_RGB

OpenGLTokens

GLX_TRANSPARENT_RGB_EXT

OpenGLTokens

GLX_TRANSPARENT_TYPE

OpenGLTokens

GLX_TRANSPARENT_TYPE_EXT

OpenGLTokens

GLX_TRUE_COLOR

OpenGLTokens

GLX_TRUE_COLOR_EXT

OpenGLTokens

GLX_UNIQUE_ID_NV

OpenGLTokens

GLX_USE_GL

OpenGLTokens

GLX_VENDOR

OpenGLTokens

GLX_VERSION

OpenGLTokens

GLX_VERSION_1_1

OpenGL1x

GLX_VERSION_1_2

OpenGL1x

GLX_VERSION_1_3

OpenGL1x

GLX_VERSION_1_4

OpenGL1x

GLX_VIDEO_OUT_ALPHA_NV

OpenGLTokens

GLX_VIDEO_OUT_COLOR_AND_ALPHA_NV

OpenGLTokens

GLX_VIDEO_OUT_COLOR_AND_DEPTH_NV

OpenGLTokens

GLX_VIDEO_OUT_COLOR_NV

OpenGLTokens

GLX_VIDEO_OUT_DEPTH_NV

OpenGLTokens

GLX_VIDEO_OUT_FIELD_1_NV

OpenGLTokens

GLX_VIDEO_OUT_FIELD_2_NV

OpenGLTokens

GLX_VIDEO_OUT_FRAME_NV

OpenGLTokens

GLX_VIDEO_OUT_STACKED_FIELDS_1_2_NV

OpenGLTokens

GLX_VIDEO_OUT_STACKED_FIELDS_2_1_NV

OpenGLTokens

GLX_VISUAL_CAVEAT_EXT

OpenGLTokens

GLX_VISUAL_ID

OpenGLTokens

GLX_VISUAL_ID_EXT

OpenGLTokens

GLX_VISUAL_SELECT_GROUP_SGIX

OpenGLTokens

GLX_WIDTH

OpenGLTokens

GLX_WIDTH_SGIX

OpenGLTokens

GLX_WINDOW

OpenGLTokens

GLX_WINDOW_BIT

OpenGLTokens

GLX_WINDOW_BIT_SGIX

OpenGLTokens

GLX_WINDOW_SGIX

OpenGLTokens

GLX_X_RENDERABLE

OpenGLTokens

GLX_X_RENDERABLE_SGIX

OpenGLTokens

GLX_X_VISUAL_TYPE

OpenGLTokens

GLX_X_VISUAL_TYPE_EXT

OpenGLTokens

GLX_Y_INVERTED_EXT

OpenGLTokens

GL_1PASS_EXT

OpenGLTokens

GL_1PASS_SGIS

OpenGLTokens

GL_2D

OpenGLTokens

GL_2PASS_0_EXT

OpenGLTokens

GL_2PASS_0_SGIS

OpenGLTokens

GL_2PASS_1_EXT

OpenGLTokens

GL_2PASS_1_SGIS

OpenGLTokens

GL_2_BYTES

OpenGLTokens

GL_3D

OpenGLTokens

GL_3DFX_multisample

OpenGL1x

GL_3DFX_tbuffer

OpenGL1x

GL_3DFX_texture_compression_FXT1

OpenGL1x

GL_3D_COLOR

OpenGLTokens

GL_3D_COLOR_TEXTURE

OpenGLTokens

GL_3_BYTES

OpenGLTokens

GL_4D_COLOR_TEXTURE

OpenGLTokens

GL_4PASS_0_EXT

OpenGLTokens

GL_4PASS_0_SGIS

OpenGLTokens

GL_4PASS_1_EXT

OpenGLTokens

GL_4PASS_1_SGIS

OpenGLTokens

GL_4PASS_2_EXT

OpenGLTokens

GL_4PASS_2_SGIS

OpenGLTokens

GL_4PASS_3_EXT

OpenGLTokens

GL_4PASS_3_SGIS

OpenGLTokens

GL_4_BYTES

OpenGLTokens

GL_ABGR_EXT

OpenGLTokens

GL_ACCUM

OpenGLTokens

GL_ACCUM_ADJACENT_PAIRS_NV

OpenGLTokens

GL_ACCUM_ALPHA_BITS

OpenGLTokens

GL_ACCUM_BLUE_BITS

OpenGLTokens

GL_ACCUM_BUFFER_BIT

OpenGLTokens

GL_ACCUM_CLEAR_VALUE

OpenGLTokens

GL_ACCUM_GREEN_BITS

OpenGLTokens

GL_ACCUM_RED_BITS

OpenGLTokens

GL_ACTIVE_ATTRIBUTES

OpenGLTokens

GL_ACTIVE_ATTRIBUTE_MAX_LENGTH

OpenGLTokens

GL_ACTIVE_PROGRAM

OpenGLTokens

GL_ACTIVE_STENCIL_FACE_EXT

OpenGLTokens

GL_ACTIVE_SUBROUTINES

OpenGLTokens

GL_ACTIVE_SUBROUTINE_MAX_LENGTH

OpenGLTokens

GL_ACTIVE_SUBROUTINE_UNIFORMS

OpenGLTokens

GL_ACTIVE_SUBROUTINE_UNIFORM_LOCATIONS

OpenGLTokens

GL_ACTIVE_SUBROUTINE_UNIFORM_MAX_LENGTH

OpenGLTokens

GL_ACTIVE_TEXTURE

OpenGLTokens

GL_ACTIVE_TEXTURE_ARB

OpenGLTokens

GL_ACTIVE_UNIFORMS

OpenGLTokens

GL_ACTIVE_UNIFORM_BLOCKS

OpenGLTokens

GL_ACTIVE_UNIFORM_BLOCK_MAX_NAME_LENGTH

OpenGLTokens

GL_ACTIVE_UNIFORM_MAX_LENGTH

OpenGLTokens

GL_ACTIVE_VARYINGS_NV

OpenGLTokens

GL_ACTIVE_VARYING_MAX_LENGTH_NV

OpenGLTokens

GL_ACTIVE_VERTEX_UNITS_ARB

OpenGLTokens

GL_ADD

OpenGLTokens

GL_ADD_SIGNED

OpenGLTokens

GL_ADD_SIGNED_ARB

OpenGLTokens

GL_ADD_SIGNED_EXT

OpenGLTokens

GL_ADJACENT_PAIRS_NV

OpenGLTokens

GL_AFFINE_2D_NV

OpenGLTokens

GL_AFFINE_3D_NV

OpenGLTokens

GL_ALIASED_LINE_WIDTH_RANGE

OpenGLTokens

GL_ALIASED_POINT_SIZE_RANGE

OpenGLTokens

GL_ALL_ATTRIB_BITS

OpenGLTokens

GL_ALL_COMPLETED_NV

OpenGLTokens

GL_ALL_SHADER_BITS

OpenGLTokens

GL_ALPHA

OpenGLTokens

GL_ALPHA12

OpenGLTokens

GL_ALPHA12_EXT

OpenGLTokens

GL_ALPHA16

OpenGLTokens

GL_ALPHA16F_ARB

OpenGLTokens

GL_ALPHA16I_EXT

OpenGLTokens

GL_ALPHA16UI_EXT

OpenGLTokens

GL_ALPHA16_EXT

OpenGLTokens

GL_ALPHA32F_ARB

OpenGLTokens

GL_ALPHA32I_EXT

OpenGLTokens

GL_ALPHA32UI_EXT

OpenGLTokens

GL_ALPHA4

OpenGLTokens

GL_ALPHA4_EXT

OpenGLTokens

GL_ALPHA8

OpenGLTokens

GL_ALPHA8I_EXT

OpenGLTokens

GL_ALPHA8UI_EXT

OpenGLTokens

GL_ALPHA8_EXT

OpenGLTokens

GL_ALPHA_BIAS

OpenGLTokens

GL_ALPHA_BITS

OpenGLTokens

GL_ALPHA_FLOAT16_ATI

OpenGLTokens

GL_ALPHA_FLOAT32_ATI

OpenGLTokens

GL_ALPHA_INTEGER

OpenGLTokens

GL_ALPHA_INTEGER_EXT

OpenGLTokens

GL_ALPHA_SCALE

OpenGLTokens

GL_ALPHA_TEST

OpenGLTokens

GL_ALPHA_TEST_FUNC

OpenGLTokens

GL_ALPHA_TEST_REF

OpenGLTokens

GL_ALREADY_SIGNALED

OpenGLTokens

GL_ALWAYS

OpenGLTokens

GL_AMBIENT

OpenGLTokens

GL_AMBIENT_AND_DIFFUSE

OpenGLTokens

GL_AMD_vertex_shader_tessellator

OpenGL1x

GL_AND

OpenGLTokens

GL_AND_INVERTED

OpenGLTokens

GL_AND_REVERSE

OpenGLTokens

GL_ANY_SAMPLES_PASSED

OpenGLTokens

GL_ARB_blend_func_extended

OpenGL1x

GL_ARB_color_buffer_float

OpenGL1x

GL_ARB_compatibility

OpenGL1x

GL_ARB_copy_buffer

OpenGL1x

GL_ARB_debug_output

OpenGL1x

GL_ARB_depth_buffer_float

OpenGL1x

GL_ARB_depth_clamp

OpenGL1x

GL_ARB_depth_texture

OpenGL1x

GL_ARB_draw_buffers

OpenGL1x

GL_ARB_draw_buffers_blend

OpenGL1x

GL_ARB_draw_elements_base_vertex

OpenGL1x

GL_ARB_draw_indirect

OpenGL1x

GL_ARB_draw_instanced

OpenGL1x

GL_ARB_ES2_compatibility

OpenGL1x

GL_ARB_explicit_attrib_location

OpenGL1x

GL_ARB_fragment_coord_conventions

OpenGL1x

GL_ARB_fragment_program

OpenGL1x

GL_ARB_fragment_program_shadow

OpenGL1x

GL_ARB_fragment_shader

OpenGL1x

GL_ARB_framebuffer_object

OpenGL1x

GL_ARB_framebuffer_sRGB

OpenGL1x

GL_ARB_geometry_shader4

OpenGL1x

GL_ARB_get_program_binary

OpenGL1x

GL_ARB_gpu_shader5

OpenGL1x

GL_ARB_gpu_shader_fp64

OpenGL1x

GL_ARB_half_float_pixel

OpenGL1x

GL_ARB_half_float_vertex

OpenGL1x

GL_ARB_imaging

OpenGL1x

GL_ARB_instanced_arrays

OpenGL1x

GL_ARB_map_buffer_range

OpenGL1x

GL_ARB_matrix_palette

OpenGL1x

GL_ARB_multisample

OpenGL1x

GL_ARB_multitexture

OpenGL1x

GL_ARB_occlusion_query

OpenGL1x

GL_ARB_occlusion_query2

OpenGL1x

GL_ARB_pixel_buffer_object

OpenGL1x

GL_ARB_point_parameters

OpenGL1x

GL_ARB_point_sprite

OpenGL1x

GL_ARB_provoking_vertex

OpenGL1x

GL_ARB_robustness

OpenGL1x

GL_ARB_sampler_objects

OpenGL1x

GL_ARB_sample_shading

OpenGL1x

GL_ARB_seamless_cube_map

OpenGL1x

GL_ARB_separate_shader_objects

OpenGL1x

GL_ARB_shader_bit_encoding

OpenGL1x

GL_ARB_shader_objects

OpenGL1x

GL_ARB_shader_precision

OpenGL1x

GL_ARB_shader_stencil_export

OpenGL1x

GL_ARB_shader_subroutine

OpenGL1x

GL_ARB_shader_texture_lod

OpenGL1x

GL_ARB_shading_language_100

OpenGL1x

GL_ARB_shadow

OpenGL1x

GL_ARB_shadow_ambient

OpenGL1x

GL_ARB_sync

OpenGL1x

GL_ARB_tessellation_shader

OpenGL1x

GL_ARB_texture_border_clamp

OpenGL1x

GL_ARB_texture_buffer_object

OpenGL1x

GL_ARB_texture_buffer_object_rgb32

OpenGL1x

GL_ARB_texture_compression

OpenGL1x

GL_ARB_texture_compression_bptc

OpenGL1x

GL_ARB_texture_compression_rgtc

OpenGL1x

GL_ARB_texture_cube_map

OpenGL1x

GL_ARB_texture_cube_map_array

OpenGL1x

GL_ARB_texture_env_add

OpenGL1x

GL_ARB_texture_env_combine

OpenGL1x

GL_ARB_texture_env_crossbar

OpenGL1x

GL_ARB_texture_env_dot3

OpenGL1x

GL_ARB_texture_float

OpenGL1x

GL_ARB_texture_gather

OpenGL1x

GL_ARB_texture_mirrored_repeat

OpenGL1x

GL_ARB_texture_multisample

OpenGL1x

GL_ARB_texture_non_power_of_two

OpenGL1x

GL_ARB_texture_query_lod

OpenGL1x

GL_ARB_texture_rectangle

OpenGL1x

GL_ARB_texture_rg

OpenGL1x

GL_ARB_texture_rgb10_a2ui

OpenGL1x

GL_ARB_texture_swizzle

OpenGL1x

GL_ARB_timer_query

OpenGL1x

GL_ARB_transform_feedback2

OpenGL1x

GL_ARB_transform_feedback3

OpenGL1x

GL_ARB_transpose_matrix

OpenGL1x

GL_ARB_uniform_buffer_object

OpenGL1x

GL_ARB_vertex_array_bgra

OpenGL1x

GL_ARB_vertex_array_object

OpenGL1x

GL_ARB_vertex_attrib_64bit

OpenGL1x

GL_ARB_vertex_blend

OpenGL1x

GL_ARB_vertex_buffer_object

OpenGL1x

GL_ARB_vertex_program

OpenGL1x

GL_ARB_vertex_shader

OpenGL1x

GL_ARB_vertex_type_2_10_10_10_rev

OpenGL1x

GL_ARB_viewport_array

OpenGL1x

GL_ARB_window_pos

OpenGL1x

GL_ARC_TO_NV

OpenGLTokens

GL_ARRAY_BUFFER

OpenGLTokens

GL_ARRAY_BUFFER_ARB

OpenGLTokens

GL_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_ARRAY_ELEMENT_LOCK_COUNT_EXT

OpenGLTokens

GL_ARRAY_ELEMENT_LOCK_FIRST_EXT

OpenGLTokens

GL_ASE_MAX_SMOOTH_GROUPS

GLFileASE

GL_ASE_MAX_SUBMATERIALS

GLFileASE

GL_ASE_MAX_TEXTURE_MAPS

GLFileASE

GL_ASE_MAX_TEXURE_CHANNELS

GLFileASE

GL_ATI_draw_buffers

OpenGL1x

GL_ATI_texture_compression_3dc

OpenGL1x

GL_ATI_texture_float

OpenGL1x

GL_ATI_texture_mirror_once

OpenGL1x

GL_ATTACHED_SHADERS

OpenGLTokens

GL_ATTRIB_ARRAY_POINTER_NV

OpenGLTokens

GL_ATTRIB_ARRAY_SIZE_NV

OpenGLTokens

GL_ATTRIB_ARRAY_STRIDE_NV

OpenGLTokens

GL_ATTRIB_ARRAY_TYPE_NV

OpenGLTokens

GL_ATTRIB_STACK_DEPTH

OpenGLTokens

GL_AUTO_NORMAL

OpenGLTokens

GL_AUX0

OpenGLTokens

GL_AUX1

OpenGLTokens

GL_AUX2

OpenGLTokens

GL_AUX3

OpenGLTokens

GL_AUX_BUFFERS

OpenGLTokens

GL_BACK

OpenGLTokens

GL_BACK_LEFT

OpenGLTokens

GL_BACK_PRIMARY_COLOR_NV

OpenGLTokens

GL_BACK_RIGHT

OpenGLTokens

GL_BACK_SECONDARY_COLOR_NV

OpenGLTokens

GL_BEVEL_NV

OpenGLTokens

GL_BGR

OpenGLTokens

GL_BGRA

OpenGLTokens

GL_BGRA_EXT

OpenGLTokens

GL_BGRA_INTEGER

OpenGLTokens

GL_BGRA_INTEGER_EXT

OpenGLTokens

GL_BGR_EXT

OpenGLTokens

GL_BGR_INTEGER

OpenGLTokens

GL_BGR_INTEGER_EXT

OpenGLTokens

GL_BIAS_BY_NEGATIVE_ONE_HALF_NV

OpenGLTokens

GL_BITMAP

OpenGLTokens

GL_BITMAP_TOKEN

OpenGLTokens

GL_BLEND

OpenGLTokens

GL_BLEND_COLOR

OpenGLTokens

GL_BLEND_COLOR_EXT

OpenGLTokens

GL_BLEND_DST

OpenGLTokens

GL_BLEND_DST_ALPHA

OpenGLTokens

GL_BLEND_DST_ALPHA_EXT

OpenGLTokens

GL_BLEND_DST_RGB

OpenGLTokens

GL_BLEND_DST_RGB_EXT

OpenGLTokens

GL_BLEND_EQUATION

OpenGLTokens

GL_BLEND_EQUATION_ALPHA

OpenGLTokens

GL_BLEND_EQUATION_ALPHA_EXT

OpenGLTokens

GL_BLEND_EQUATION_EXT

OpenGLTokens

GL_BLEND_EQUATION_RGB

OpenGLTokens

GL_BLEND_EQUATION_RGB_EXT

OpenGLTokens

GL_BLEND_SRC

OpenGLTokens

GL_BLEND_SRC_ALPHA

OpenGLTokens

GL_BLEND_SRC_ALPHA_EXT

OpenGLTokens

GL_BLEND_SRC_RGB

OpenGLTokens

GL_BLEND_SRC_RGB_EXT

OpenGLTokens

GL_BLUE

OpenGLTokens

GL_BLUE_BIAS

OpenGLTokens

GL_BLUE_BITS

OpenGLTokens

GL_BLUE_INTEGER

OpenGLTokens

GL_BLUE_INTEGER_EXT

OpenGLTokens

GL_BLUE_SCALE

OpenGLTokens

GL_BOLD_BIT_NV

OpenGLTokens

GL_BOOL

OpenGLTokens

GL_BOOL_ARB

OpenGLTokens

GL_BOOL_VEC2

OpenGLTokens

GL_BOOL_VEC2_ARB

OpenGLTokens

GL_BOOL_VEC3

OpenGLTokens

GL_BOOL_VEC3_ARB

OpenGLTokens

GL_BOOL_VEC4

OpenGLTokens

GL_BOOL_VEC4_ARB

OpenGLTokens

GL_BOUNDING_BOX_NV

OpenGLTokens

GL_BOUNDING_BOX_OF_BOUNDING_BOXES_NV

OpenGLTokens

GL_BUFFER_ACCESS

OpenGLTokens

GL_BUFFER_ACCESS_ARB

OpenGLTokens

GL_BUFFER_ACCESS_FLAGS

OpenGLTokens

GL_BUFFER_GPU_ADDRESS_NV

OpenGLTokens

GL_BUFFER_MAPPED

OpenGLTokens

GL_BUFFER_MAPPED_ARB

OpenGLTokens

GL_BUFFER_MAP_LENGTH

OpenGLTokens

GL_BUFFER_MAP_OFFSET

OpenGLTokens

GL_BUFFER_MAP_POINTER

OpenGLTokens

GL_BUFFER_MAP_POINTER_ARB

OpenGLTokens

GL_BUFFER_SIZE

OpenGLTokens

GL_BUFFER_SIZE_ARB

OpenGLTokens

GL_BUFFER_USAGE

OpenGLTokens

GL_BUFFER_USAGE_ARB

OpenGLTokens

GL_BYTE

OpenGLTokens

GL_C3F_V3F

OpenGLTokens

GL_C4F_N3F_V3F

OpenGLTokens

GL_C4UB_V2F

OpenGLTokens

GL_C4UB_V3F

OpenGLTokens

GL_CCW

OpenGLTokens

GL_CIRCULAR_CCW_ARC_TO_NV

OpenGLTokens

GL_CIRCULAR_CW_ARC_TO_NV

OpenGLTokens

GL_CIRCULAR_TANGENT_ARC_TO_NV

OpenGLTokens

GL_CLAMP

OpenGLTokens

GL_CLAMP_FRAGMENT_COLOR

OpenGLTokens

GL_CLAMP_FRAGMENT_COLOR_ARB

OpenGLTokens

GL_CLAMP_READ_COLOR

OpenGLTokens

GL_CLAMP_READ_COLOR_ARB

OpenGLTokens

GL_CLAMP_TO_BORDER

OpenGLTokens

GL_CLAMP_TO_BORDER_ARB

OpenGLTokens

GL_CLAMP_TO_BORDER_SGIS

OpenGLTokens

GL_CLAMP_TO_EDGE

OpenGLTokens

GL_CLAMP_TO_EDGE_SGIS

OpenGLTokens

GL_CLAMP_VERTEX_COLOR

OpenGLTokens

GL_CLAMP_VERTEX_COLOR_ARB

OpenGLTokens

GL_CLEAR

OpenGLTokens

GL_CLIENT_ACTIVE_TEXTURE

OpenGLTokens

GL_CLIENT_ACTIVE_TEXTURE_ARB

OpenGLTokens

GL_CLIENT_ALL_ATTRIB_BITS

OpenGLTokens

GL_CLIENT_ATTRIB_STACK_DEPTH

OpenGLTokens

GL_CLIENT_PIXEL_STORE_BIT

OpenGLTokens

GL_CLIENT_VERTEX_ARRAY_BIT

OpenGLTokens

GL_CLIP_DISTANCE0

OpenGLTokens

GL_CLIP_DISTANCE1

OpenGLTokens

GL_CLIP_DISTANCE2

OpenGLTokens

GL_CLIP_DISTANCE3

OpenGLTokens

GL_CLIP_DISTANCE4

OpenGLTokens

GL_CLIP_DISTANCE5

OpenGLTokens

GL_CLIP_DISTANCE6

OpenGLTokens

GL_CLIP_DISTANCE7

OpenGLTokens

GL_CLIP_DISTANCE_NV

OpenGLTokens

GL_CLIP_PLANE0

OpenGLTokens

GL_CLIP_PLANE1

OpenGLTokens

GL_CLIP_PLANE2

OpenGLTokens

GL_CLIP_PLANE3

OpenGLTokens

GL_CLIP_PLANE4

OpenGLTokens

GL_CLIP_PLANE5

OpenGLTokens

GL_CLIP_VOLUME_CLIPPING_HINT_EXT

OpenGLTokens

GL_CLOSE_PATH_NV

OpenGLTokens

GL_COEFF

OpenGLTokens

GL_COLOR

OpenGLTokens

GL_COLOR_ARRAY

OpenGLTokens

GL_COLOR_ARRAY_ADDRESS_NV

OpenGLTokens

GL_COLOR_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_COLOR_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_COLOR_ARRAY_LENGTH_NV

OpenGLTokens

GL_COLOR_ARRAY_POINTER

OpenGLTokens

GL_COLOR_ARRAY_SIZE

OpenGLTokens

GL_COLOR_ARRAY_STRIDE

OpenGLTokens

GL_COLOR_ARRAY_TYPE

OpenGLTokens

GL_COLOR_ATTACHMENT0

OpenGLTokens

GL_COLOR_ATTACHMENT0_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT1

OpenGLTokens

GL_COLOR_ATTACHMENT10

OpenGLTokens

GL_COLOR_ATTACHMENT10_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT11

OpenGLTokens

GL_COLOR_ATTACHMENT11_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT12

OpenGLTokens

GL_COLOR_ATTACHMENT12_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT13

OpenGLTokens

GL_COLOR_ATTACHMENT13_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT14

OpenGLTokens

GL_COLOR_ATTACHMENT14_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT15

OpenGLTokens

GL_COLOR_ATTACHMENT15_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT1_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT2

OpenGLTokens

GL_COLOR_ATTACHMENT2_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT3

OpenGLTokens

GL_COLOR_ATTACHMENT3_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT4

OpenGLTokens

GL_COLOR_ATTACHMENT4_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT5

OpenGLTokens

GL_COLOR_ATTACHMENT5_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT6

OpenGLTokens

GL_COLOR_ATTACHMENT6_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT7

OpenGLTokens

GL_COLOR_ATTACHMENT7_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT8

OpenGLTokens

GL_COLOR_ATTACHMENT8_EXT

OpenGLTokens

GL_COLOR_ATTACHMENT9

OpenGLTokens

GL_COLOR_ATTACHMENT9_EXT

OpenGLTokens

GL_COLOR_BUFFER_BIT

OpenGLTokens

GL_COLOR_CLEAR_UNCLAMPED_VALUE_ATI

OpenGLTokens

GL_COLOR_CLEAR_VALUE

OpenGLTokens

GL_COLOR_INDEX

OpenGLTokens

GL_COLOR_INDEX12_EXT

OpenGLTokens

GL_COLOR_INDEX16_EXT

OpenGLTokens

GL_COLOR_INDEX1_EXT

OpenGLTokens

GL_COLOR_INDEX2_EXT

OpenGLTokens

GL_COLOR_INDEX4_EXT

OpenGLTokens

GL_COLOR_INDEX8_EXT

OpenGLTokens

GL_COLOR_INDEXES

OpenGLTokens

GL_COLOR_LOGIC_OP

OpenGLTokens

GL_COLOR_MATERIAL

OpenGLTokens

GL_COLOR_MATERIAL_FACE

OpenGLTokens

GL_COLOR_MATERIAL_PARAMETER

OpenGLTokens

GL_COLOR_MATRIX

OpenGLTokens

GL_COLOR_MATRIX_SGI

OpenGLTokens

GL_COLOR_MATRIX_STACK_DEPTH

OpenGLTokens

GL_COLOR_MATRIX_STACK_DEPTH_SGI

OpenGLTokens

GL_COLOR_SUM

OpenGLTokens

GL_COLOR_SUM_ARB

OpenGLTokens

GL_COLOR_SUM_CLAMP_NV

OpenGLTokens

GL_COLOR_SUM_EXT

OpenGLTokens

GL_COLOR_TABLE

OpenGLTokens

GL_COLOR_TABLE_ALPHA_SIZE

OpenGLTokens

GL_COLOR_TABLE_BIAS

OpenGLTokens

GL_COLOR_TABLE_BLUE_SIZE

OpenGLTokens

GL_COLOR_TABLE_FORMAT

OpenGLTokens

GL_COLOR_TABLE_GREEN_SIZE

OpenGLTokens

GL_COLOR_TABLE_INTENSITY_SIZE

OpenGLTokens

GL_COLOR_TABLE_LUMINANCE_SIZE

OpenGLTokens

GL_COLOR_TABLE_RED_SIZE

OpenGLTokens

GL_COLOR_TABLE_SCALE

OpenGLTokens

GL_COLOR_TABLE_WIDTH

OpenGLTokens

GL_COLOR_WRITEMASK

OpenGLTokens

GL_COMBINE

OpenGLTokens

GL_COMBINE4_NV

OpenGLTokens

GL_COMBINER0_NV

OpenGLTokens

GL_COMBINER1_NV

OpenGLTokens

GL_COMBINER2_NV

OpenGLTokens

GL_COMBINER3_NV

OpenGLTokens

GL_COMBINER4_NV

OpenGLTokens

GL_COMBINER5_NV

OpenGLTokens

GL_COMBINER6_NV

OpenGLTokens

GL_COMBINER7_NV

OpenGLTokens

GL_COMBINER_AB_DOT_PRODUCT_NV

OpenGLTokens

GL_COMBINER_AB_OUTPUT_NV

OpenGLTokens

GL_COMBINER_BIAS_NV

OpenGLTokens

GL_COMBINER_CD_DOT_PRODUCT_NV

OpenGLTokens

GL_COMBINER_CD_OUTPUT_NV

OpenGLTokens

GL_COMBINER_COMPONENT_USAGE_NV

OpenGLTokens

GL_COMBINER_INPUT_NV

OpenGLTokens

GL_COMBINER_MAPPING_NV

OpenGLTokens

GL_COMBINER_MUX_SUM_NV

OpenGLTokens

GL_COMBINER_SCALE_NV

OpenGLTokens

GL_COMBINER_SUM_OUTPUT_NV

OpenGLTokens

GL_COMBINE_ALPHA

OpenGLTokens

GL_COMBINE_ALPHA_ARB

OpenGLTokens

GL_COMBINE_ALPHA_EXT

OpenGLTokens

GL_COMBINE_ARB

OpenGLTokens

GL_COMBINE_EXT

OpenGLTokens

GL_COMBINE_RGB

OpenGLTokens

GL_COMBINE_RGB_ARB

OpenGLTokens

GL_COMBINE_RGB_EXT

OpenGLTokens

GL_COMPARE_REF_DEPTH_TO_TEXTURE_EXT

OpenGLTokens

GL_COMPARE_REF_TO_TEXTURE

OpenGLTokens

GL_COMPARE_R_TO_TEXTURE

OpenGLTokens

GL_COMPARE_R_TO_TEXTURE_ARB

OpenGLTokens

GL_COMPATIBLE_SUBROUTINES

OpenGLTokens

GL_COMPILE

OpenGLTokens

GL_COMPILE_AND_EXECUTE

OpenGLTokens

GL_COMPILE_STATUS

OpenGLTokens

GL_COMPRESSED_ALPHA

OpenGLTokens

GL_COMPRESSED_ALPHA_ARB

OpenGLTokens

GL_COMPRESSED_INTENSITY

OpenGLTokens

GL_COMPRESSED_INTENSITY_ARB

OpenGLTokens

GL_COMPRESSED_LUMINANCE

OpenGLTokens

GL_COMPRESSED_LUMINANCE_ALPHA

OpenGLTokens

GL_COMPRESSED_LUMINANCE_ALPHA_3DC_ATI

OpenGLTokens

GL_COMPRESSED_LUMINANCE_ALPHA_ARB

OpenGLTokens

GL_COMPRESSED_LUMINANCE_ALPHA_LATC2_EXT

OpenGLTokens

GL_COMPRESSED_LUMINANCE_ARB

OpenGLTokens

GL_COMPRESSED_LUMINANCE_LATC1_EXT

OpenGLTokens

GL_COMPRESSED_RED

OpenGLTokens

GL_COMPRESSED_RED_GREEN_RGTC2_EXT

OpenGLTokens

GL_COMPRESSED_RED_RGTC1

OpenGLTokens

GL_COMPRESSED_RED_RGTC1_EXT

OpenGLTokens

GL_COMPRESSED_RG

OpenGLTokens

GL_COMPRESSED_RGB

OpenGLTokens

GL_COMPRESSED_RGBA

OpenGLTokens

GL_COMPRESSED_RGBA_ARB

OpenGLTokens

GL_COMPRESSED_RGBA_BPTC_UNORM_ARB

OpenGLTokens

GL_COMPRESSED_RGBA_FXT1_3DFX

OpenGLTokens

GL_COMPRESSED_RGBA_S3TC_DXT1_EXT

OpenGLTokens

GL_COMPRESSED_RGBA_S3TC_DXT3_EXT

OpenGLTokens

GL_COMPRESSED_RGBA_S3TC_DXT5_EXT

OpenGLTokens

GL_COMPRESSED_RGB_ARB

OpenGLTokens

GL_COMPRESSED_RGB_BPTC_SIGNED_FLOAT_ARB

OpenGLTokens

GL_COMPRESSED_RGB_BPTC_UNSIGNED_FLOAT_ARB

OpenGLTokens

GL_COMPRESSED_RGB_FXT1_3DFX

OpenGLTokens

GL_COMPRESSED_RGB_S3TC_DXT1_EXT

OpenGLTokens

GL_COMPRESSED_RG_RGTC2

OpenGLTokens

GL_COMPRESSED_SIGNED_LUMINANCE_ALPHA_LATC2_EXT

OpenGLTokens

GL_COMPRESSED_SIGNED_LUMINANCE_LATC1_EXT

OpenGLTokens

GL_COMPRESSED_SIGNED_RED_GREEN_RGTC2_EXT

OpenGLTokens

GL_COMPRESSED_SIGNED_RED_RGTC1

OpenGLTokens

GL_COMPRESSED_SIGNED_RED_RGTC1_EXT

OpenGLTokens

GL_COMPRESSED_SIGNED_RG_RGTC2

OpenGLTokens

GL_COMPRESSED_SLUMINANCE

OpenGLTokens

GL_COMPRESSED_SLUMINANCE_ALPHA

OpenGLTokens

GL_COMPRESSED_SLUMINANCE_ALPHA_EXT

OpenGLTokens

GL_COMPRESSED_SLUMINANCE_EXT

OpenGLTokens

GL_COMPRESSED_SRGB

OpenGLTokens

GL_COMPRESSED_SRGB_ALPHA

OpenGLTokens

GL_COMPRESSED_SRGB_ALPHA_BPTC_UNORM_ARB

OpenGLTokens

GL_COMPRESSED_SRGB_ALPHA_EXT

OpenGLTokens

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT1_EXT

OpenGLTokens

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT3_EXT

OpenGLTokens

GL_COMPRESSED_SRGB_ALPHA_S3TC_DXT5_EXT

OpenGLTokens

GL_COMPRESSED_SRGB_EXT

OpenGLTokens

GL_COMPRESSED_SRGB_S3TC_DXT1_EXT

OpenGLTokens

GL_COMPRESSED_TEXTURE_FORMATS

OpenGLTokens

GL_COMPRESSED_TEXTURE_FORMATS_ARB

OpenGLTokens

GL_CONDITION_SATISFIED

OpenGLTokens

GL_CONSTANT

OpenGLTokens

GL_CONSTANT_ALPHA

OpenGLTokens

GL_CONSTANT_ALPHA_EXT

OpenGLTokens

GL_CONSTANT_ARB

OpenGLTokens

GL_CONSTANT_ATTENUATION

OpenGLTokens

GL_CONSTANT_BORDER

OpenGLTokens

GL_CONSTANT_COLOR

OpenGLTokens

GL_CONSTANT_COLOR0_NV

OpenGLTokens

GL_CONSTANT_COLOR1_NV

OpenGLTokens

GL_CONSTANT_COLOR_ARB

OpenGLTokens

GL_CONSTANT_COLOR_EXT

OpenGLTokens

GL_CONSTANT_EXT

OpenGLTokens

GL_CONST_EYE_NV

OpenGLTokens

GL_CONTEXT_COMPATIBILITY_PROFILE_BIT

OpenGLTokens

GL_CONTEXT_CORE_PROFILE_BIT

OpenGLTokens

GL_CONTEXT_FLAGS

OpenGLTokens

GL_CONTEXT_FLAG_FORWARD_COMPATIBLE_BIT

OpenGLTokens

GL_CONTEXT_FLAG_ROBUST_ACCESS_BIT_ARB

OpenGLTokens

GL_CONTEXT_PROFILE_MASK

OpenGLTokens

GL_CONTINUOUS_AMD

OpenGLTokens

GL_CONVEX_HULL_NV

OpenGLTokens

GL_CONVOLUTION_1D

OpenGLTokens

GL_CONVOLUTION_1D_EXT

OpenGLTokens

GL_CONVOLUTION_2D

OpenGLTokens

GL_CONVOLUTION_2D_EXT

OpenGLTokens

GL_CONVOLUTION_BORDER_COLOR

OpenGLTokens

GL_CONVOLUTION_BORDER_MODE

OpenGLTokens

GL_CONVOLUTION_BORDER_MODE_EXT

OpenGLTokens

GL_CONVOLUTION_FILTER_BIAS

OpenGLTokens

GL_CONVOLUTION_FILTER_BIAS_EXT

OpenGLTokens

GL_CONVOLUTION_FILTER_SCALE

OpenGLTokens

GL_CONVOLUTION_FILTER_SCALE_EXT

OpenGLTokens

GL_CONVOLUTION_FORMAT

OpenGLTokens

GL_CONVOLUTION_FORMAT_EXT

OpenGLTokens

GL_CONVOLUTION_HEIGHT

OpenGLTokens

GL_CONVOLUTION_HEIGHT_EXT

OpenGLTokens

GL_CONVOLUTION_WIDTH

OpenGLTokens

GL_CONVOLUTION_WIDTH_EXT

OpenGLTokens

GL_COORD_REPLACE

OpenGLTokens

GL_COORD_REPLACE_ARB

OpenGLTokens

GL_COORD_REPLACE_NV

OpenGLTokens

GL_COPY

OpenGLTokens

GL_COPY_INVERTED

OpenGLTokens

GL_COPY_PIXEL_TOKEN

OpenGLTokens

GL_COPY_READ_BUFFER

OpenGLTokens

GL_COPY_WRITE_BUFFER

OpenGLTokens

GL_COUNT_DOWN_NV

OpenGLTokens

GL_COUNT_UP_NV

OpenGLTokens

GL_CUBIC_CURVE_TO_NV

OpenGLTokens

GL_CULL_FACE

OpenGLTokens

GL_CULL_FACE_MODE

OpenGLTokens

GL_CULL_FRAGMENT_NV

OpenGLTokens

GL_CULL_MODES_NV

OpenGLTokens

GL_CURRENT_ATTRIB_NV

OpenGLTokens

GL_CURRENT_BIT

OpenGLTokens

GL_CURRENT_COLOR

OpenGLTokens

GL_CURRENT_FOG_COORD

OpenGLTokens

GL_CURRENT_FOG_COORDINATE

OpenGLTokens

GL_CURRENT_FOG_COORDINATE_EXT

OpenGLTokens

GL_CURRENT_INDEX

OpenGLTokens

GL_CURRENT_MATRIX_ARB

OpenGLTokens

GL_CURRENT_MATRIX_INDEX_ARB

OpenGLTokens

GL_CURRENT_MATRIX_NV

OpenGLTokens

GL_CURRENT_MATRIX_STACK_DEPTH_ARB

OpenGLTokens

GL_CURRENT_MATRIX_STACK_DEPTH_NV

OpenGLTokens

GL_CURRENT_NORMAL

OpenGLTokens

GL_CURRENT_OCCLUSION_QUERY_ID_NV

OpenGLTokens

GL_CURRENT_PALETTE_MATRIX_ARB

OpenGLTokens

GL_CURRENT_PROGRAM

OpenGLTokens

GL_CURRENT_QUERY

OpenGLTokens

GL_CURRENT_QUERY_ARB

OpenGLTokens

GL_CURRENT_RASTER_COLOR

OpenGLTokens

GL_CURRENT_RASTER_DISTANCE

OpenGLTokens

GL_CURRENT_RASTER_INDEX

OpenGLTokens

GL_CURRENT_RASTER_POSITION

OpenGLTokens

GL_CURRENT_RASTER_POSITION_VALID

OpenGLTokens

GL_CURRENT_RASTER_SECONDARY_COLOR

OpenGLTokens

GL_CURRENT_RASTER_TEXTURE_COORDS

OpenGLTokens

GL_CURRENT_SECONDARY_COLOR

OpenGLTokens

GL_CURRENT_SECONDARY_COLOR_EXT

OpenGLTokens

GL_CURRENT_TEXTURE_COORDS

OpenGLTokens

GL_CURRENT_VERTEX_ATTRIB

OpenGLTokens

GL_CURRENT_VERTEX_ATTRIB_ARB

OpenGLTokens

GL_CURRENT_WEIGHT_ARB

OpenGLTokens

GL_CW

OpenGLTokens

GL_DEBUG_CALLBACK_FUNCTION_ARB

OpenGLTokens

GL_DEBUG_CALLBACK_USER_PARAM_ARB

OpenGLTokens

GL_DEBUG_LOGGED_MESSAGES_ARB

OpenGLTokens

GL_DEBUG_NEXT_LOGGED_MESSAGE_LENGTH_ARB

OpenGLTokens

GL_DEBUG_OUTPUT_SYNCHRONOUS_ARB

OpenGLTokens

GL_DEBUG_SEVERITY_HIGH_ARB

OpenGLTokens

GL_DEBUG_SEVERITY_LOW_ARB

OpenGLTokens

GL_DEBUG_SEVERITY_MEDIUM_ARB

OpenGLTokens

GL_DEBUG_SOURCE_API_ARB

OpenGLTokens

GL_DEBUG_SOURCE_APPLICATION_ARB

OpenGLTokens

GL_DEBUG_SOURCE_OTHER_ARB

OpenGLTokens

GL_DEBUG_SOURCE_SHADER_COMPILER_ARB

OpenGLTokens

GL_DEBUG_SOURCE_THIRD_PARTY_ARB

OpenGLTokens

GL_DEBUG_SOURCE_WINDOW_SYSTEM_ARB

OpenGLTokens

GL_DEBUG_TYPE_DEPRECATED_BEHAVIOR_ARB

OpenGLTokens

GL_DEBUG_TYPE_ERROR_ARB

OpenGLTokens

GL_DEBUG_TYPE_OTHER_ARB

OpenGLTokens

GL_DEBUG_TYPE_PERFORMANCE_ARB

OpenGLTokens

GL_DEBUG_TYPE_PORTABILITY_ARB

OpenGLTokens

GL_DEBUG_TYPE_UNDEFINED_BEHAVIOR_ARB

OpenGLTokens

GL_DECAL

OpenGLTokens

GL_DECODE_EXT

OpenGLTokens

GL_DECR

OpenGLTokens

GL_DECR_WRAP

OpenGLTokens

GL_DECR_WRAP_EXT

OpenGLTokens

GL_DELETE_STATUS

OpenGLTokens

GL_DEPENDENT_AR_TEXTURE_2D_NV

OpenGLTokens

GL_DEPENDENT_GB_TEXTURE_2D_NV

OpenGLTokens

GL_DEPENDENT_HILO_TEXTURE_2D_NV

OpenGLTokens

GL_DEPENDENT_RGB_TEXTURE_3D_NV

OpenGLTokens

GL_DEPENDENT_RGB_TEXTURE_CUBE_MAP_NV

OpenGLTokens

GL_DEPTH

OpenGLTokens

GL_DEPTH24_STENCIL8

OpenGLTokens

GL_DEPTH24_STENCIL8_EXT

OpenGLTokens

GL_DEPTH32F_STENCIL8

OpenGLTokens

GL_DEPTH_ATTACHMENT

OpenGLTokens

GL_DEPTH_ATTACHMENT_EXT

OpenGLTokens

GL_DEPTH_BIAS

OpenGLTokens

GL_DEPTH_BITS

OpenGLTokens

GL_DEPTH_BOUNDS_EXT

OpenGLTokens

GL_DEPTH_BOUNDS_TEST_EXT

OpenGLTokens

GL_DEPTH_BUFFER

OpenGLTokens

GL_DEPTH_BUFFER_BIT

OpenGLTokens

GL_DEPTH_CLAMP

OpenGLTokens

GL_DEPTH_CLEAR_VALUE

OpenGLTokens

GL_DEPTH_COMPONENT

OpenGLTokens

GL_DEPTH_COMPONENT16

OpenGLTokens

GL_DEPTH_COMPONENT16_ARB

OpenGLTokens

GL_DEPTH_COMPONENT24

OpenGLTokens

GL_DEPTH_COMPONENT24_ARB

OpenGLTokens

GL_DEPTH_COMPONENT32

OpenGLTokens

GL_DEPTH_COMPONENT32F

OpenGLTokens

GL_DEPTH_COMPONENT32_ARB

OpenGLTokens

GL_DEPTH_FUNC

OpenGLTokens

GL_DEPTH_RANGE

OpenGLTokens

GL_DEPTH_SCALE

OpenGLTokens

GL_DEPTH_STENCIL

OpenGLTokens

GL_DEPTH_STENCIL_ATTACHMENT

OpenGLTokens

GL_DEPTH_STENCIL_EXT

OpenGLTokens

GL_DEPTH_TEST

OpenGLTokens

GL_DEPTH_TEXTURE_MODE

OpenGLTokens

GL_DEPTH_TEXTURE_MODE_ARB

OpenGLTokens

GL_DEPTH_WRITEMASK

OpenGLTokens

GL_DIFFUSE

OpenGLTokens

GL_DISCARD_NV

OpenGLTokens

GL_DISCRETE_AMD

OpenGLTokens

GL_DISTANCE_ATTENUATION_ARB

OpenGLTokens

GL_DITHER

OpenGLTokens

GL_DOMAIN

OpenGLTokens

GL_DONT_CARE

OpenGLTokens

GL_DOT3_RGB

OpenGLTokens

GL_DOT3_RGBA

OpenGLTokens

GL_DOT3_RGBA_ARB

OpenGLTokens

GL_DOT3_RGBA_EXT

OpenGLTokens

GL_DOT3_RGB_ARB

OpenGLTokens

GL_DOT3_RGB_EXT

OpenGLTokens

GL_DOT_PRODUCT_AFFINE_DEPTH_REPLACE_NV

OpenGLTokens

GL_DOT_PRODUCT_CONST_EYE_REFLECT_CUBE_MAP_NV

OpenGLTokens

GL_DOT_PRODUCT_DEPTH_REPLACE_NV

OpenGLTokens

GL_DOT_PRODUCT_DIFFUSE_CUBE_MAP_NV

OpenGLTokens

GL_DOT_PRODUCT_NV

OpenGLTokens

GL_DOT_PRODUCT_PASS_THROUGH_NV

OpenGLTokens

GL_DOT_PRODUCT_REFLECT_CUBE_MAP_NV

OpenGLTokens

GL_DOT_PRODUCT_TEXTURE_1D_NV

OpenGLTokens

GL_DOT_PRODUCT_TEXTURE_2D_NV

OpenGLTokens

GL_DOT_PRODUCT_TEXTURE_3D_NV

OpenGLTokens

GL_DOT_PRODUCT_TEXTURE_CUBE_MAP_NV

OpenGLTokens

GL_DOT_PRODUCT_TEXTURE_RECTANGLE_NV

OpenGLTokens

GL_DOUBLE

OpenGLTokens

GL_DOUBLEBUFFER

OpenGLTokens

GL_DOUBLE_EXT

OpenGLTokens

GL_DOUBLE_MAT2

OpenGLTokens

GL_DOUBLE_MAT2x3

OpenGLTokens

GL_DOUBLE_MAT2x4

OpenGLTokens

GL_DOUBLE_MAT3

OpenGLTokens

GL_DOUBLE_MAT3x2

OpenGLTokens

GL_DOUBLE_MAT3x4

OpenGLTokens

GL_DOUBLE_MAT4

OpenGLTokens

GL_DOUBLE_MAT4x2

OpenGLTokens

GL_DOUBLE_MAT4x3

OpenGLTokens

GL_DOUBLE_VEC2

OpenGLTokens

GL_DOUBLE_VEC3

OpenGLTokens

GL_DOUBLE_VEC4

OpenGLTokens

GL_DRAW_BUFFER

OpenGLTokens

GL_DRAW_BUFFER0

OpenGLTokens

GL_DRAW_BUFFER0_ARB

OpenGLTokens

GL_DRAW_BUFFER0_ATI

OpenGLTokens

GL_DRAW_BUFFER1

OpenGLTokens

GL_DRAW_BUFFER10

OpenGLTokens

GL_DRAW_BUFFER10_ARB

OpenGLTokens

GL_DRAW_BUFFER10_ATI

OpenGLTokens

GL_DRAW_BUFFER11

OpenGLTokens

GL_DRAW_BUFFER11_ARB

OpenGLTokens

GL_DRAW_BUFFER11_ATI

OpenGLTokens

GL_DRAW_BUFFER12

OpenGLTokens

GL_DRAW_BUFFER12_ARB

OpenGLTokens

GL_DRAW_BUFFER12_ATI

OpenGLTokens

GL_DRAW_BUFFER13

OpenGLTokens

GL_DRAW_BUFFER13_ARB

OpenGLTokens

GL_DRAW_BUFFER13_ATI

OpenGLTokens

GL_DRAW_BUFFER14

OpenGLTokens

GL_DRAW_BUFFER14_ARB

OpenGLTokens

GL_DRAW_BUFFER14_ATI

OpenGLTokens

GL_DRAW_BUFFER15

OpenGLTokens

GL_DRAW_BUFFER15_ARB

OpenGLTokens

GL_DRAW_BUFFER15_ATI

OpenGLTokens

GL_DRAW_BUFFER1_ARB

OpenGLTokens

GL_DRAW_BUFFER1_ATI

OpenGLTokens

GL_DRAW_BUFFER2

OpenGLTokens

GL_DRAW_BUFFER2_ARB

OpenGLTokens

GL_DRAW_BUFFER2_ATI

OpenGLTokens

GL_DRAW_BUFFER3

OpenGLTokens

GL_DRAW_BUFFER3_ARB

OpenGLTokens

GL_DRAW_BUFFER3_ATI

OpenGLTokens

GL_DRAW_BUFFER4

OpenGLTokens

GL_DRAW_BUFFER4_ARB

OpenGLTokens

GL_DRAW_BUFFER4_ATI

OpenGLTokens

GL_DRAW_BUFFER5

OpenGLTokens

GL_DRAW_BUFFER5_ARB

OpenGLTokens

GL_DRAW_BUFFER5_ATI

OpenGLTokens

GL_DRAW_BUFFER6

OpenGLTokens

GL_DRAW_BUFFER6_ARB

OpenGLTokens

GL_DRAW_BUFFER6_ATI

OpenGLTokens

GL_DRAW_BUFFER7

OpenGLTokens

GL_DRAW_BUFFER7_ARB

OpenGLTokens

GL_DRAW_BUFFER7_ATI

OpenGLTokens

GL_DRAW_BUFFER8

OpenGLTokens

GL_DRAW_BUFFER8_ARB

OpenGLTokens

GL_DRAW_BUFFER8_ATI

OpenGLTokens

GL_DRAW_BUFFER9

OpenGLTokens

GL_DRAW_BUFFER9_ARB

OpenGLTokens

GL_DRAW_BUFFER9_ATI

OpenGLTokens

GL_DRAW_FRAMEBUFFER

OpenGLTokens

GL_DRAW_FRAMEBUFFER_BINDING

OpenGLTokens

GL_DRAW_FRAMEBUFFER_BINDING_EXT

OpenGLTokens

GL_DRAW_FRAMEBUFFER_EXT

OpenGLTokens

GL_DRAW_INDIRECT_BUFFER

OpenGLTokens

GL_DRAW_INDIRECT_BUFFER_BINDING

OpenGLTokens

GL_DRAW_PIXEL_TOKEN

OpenGLTokens

GL_DSDT8_MAG8_INTENSITY8_NV

OpenGLTokens

GL_DSDT8_MAG8_NV

OpenGLTokens

GL_DSDT8_NV

OpenGLTokens

GL_DSDT_MAG_INTENSITY_NV

OpenGLTokens

GL_DSDT_MAG_NV

OpenGLTokens

GL_DSDT_MAG_VIB_NV

OpenGLTokens

GL_DSDT_NV

OpenGLTokens

GL_DST_ALPHA

OpenGLTokens

GL_DST_COLOR

OpenGLTokens

GL_DS_BIAS_NV

OpenGLTokens

GL_DS_SCALE_NV

OpenGLTokens

GL_DT_BIAS_NV

OpenGLTokens

GL_DT_SCALE_NV

OpenGLTokens

GL_DYNAMIC_COPY

OpenGLTokens

GL_DYNAMIC_COPY_ARB

OpenGLTokens

GL_DYNAMIC_DRAW

OpenGLTokens

GL_DYNAMIC_DRAW_ARB

OpenGLTokens

GL_DYNAMIC_READ

OpenGLTokens

GL_DYNAMIC_READ_ARB

OpenGLTokens

GL_EDGE_FLAG

OpenGLTokens

GL_EDGE_FLAG_ARRAY

OpenGLTokens

GL_EDGE_FLAG_ARRAY_ADDRESS_NV

OpenGLTokens

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_EDGE_FLAG_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_EDGE_FLAG_ARRAY_LENGTH_NV

OpenGLTokens

GL_EDGE_FLAG_ARRAY_POINTER

OpenGLTokens

GL_EDGE_FLAG_ARRAY_STRIDE

OpenGLTokens

GL_ELEMENT_ARRAY_ADDRESS_NV

OpenGLTokens

GL_ELEMENT_ARRAY_BUFFER

OpenGLTokens

GL_ELEMENT_ARRAY_BUFFER_ARB

OpenGLTokens

GL_ELEMENT_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_ELEMENT_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_ELEMENT_ARRAY_LENGTH_NV

OpenGLTokens

GL_ELEMENT_ARRAY_UNIFIED_NV

OpenGLTokens

GL_EMISSION

OpenGLTokens

GL_ENABLE_BIT

OpenGLTokens

GL_EQUAL

OpenGLTokens

GL_EQUIV

OpenGLTokens

GL_EVAL_BIT

OpenGLTokens

GL_EXP

OpenGLTokens

GL_EXP2

OpenGLTokens

GL_EXPAND_NEGATE_NV

OpenGLTokens

GL_EXPAND_NORMAL_NV

OpenGLTokens

GL_EXTENSIONS

OpenGLTokens

GL_EXT_abgr

OpenGL1x

GL_EXT_bgra

OpenGL1x

GL_EXT_bindable_uniform

OpenGL1x

GL_EXT_blend_color

OpenGL1x

GL_EXT_blend_equation_separate

OpenGL1x

GL_EXT_blend_func_separate

OpenGL1x

GL_EXT_blend_logic_op

OpenGL1x

GL_EXT_blend_minmax

OpenGL1x

GL_EXT_blend_subtract

OpenGL1x

GL_EXT_Cg_shader

OpenGL1x

GL_EXT_clip_volume_hint

OpenGL1x

GL_EXT_compiled_vertex_array

OpenGL1x

GL_EXT_copy_texture

OpenGL1x

GL_EXT_depth_bounds_test

OpenGL1x

GL_EXT_draw_buffers2

OpenGL1x

GL_EXT_draw_instanced

OpenGL1x

GL_EXT_draw_range_elements

OpenGL1x

GL_EXT_fog_coord

OpenGL1x

GL_EXT_framebuffer_blit

OpenGL1x

GL_EXT_framebuffer_multisample

OpenGL1x

GL_EXT_framebuffer_object

OpenGL1x

GL_EXT_framebuffer_sRGB

OpenGL1x

GL_EXT_geometry_shader4

OpenGL1x

GL_EXT_gpu_program_parameters

OpenGL1x

GL_EXT_gpu_shader4

OpenGL1x

GL_EXT_multisample

OpenGL1x

GL_EXT_multi_draw_arrays

OpenGL1x

GL_EXT_packed_depth_stencil

OpenGL1x

GL_EXT_packed_float

OpenGL1x

GL_EXT_packed_pixels

OpenGL1x

GL_EXT_paletted_texture

OpenGL1x

GL_EXT_pixel_buffer_object

OpenGL1x

GL_EXT_polygon_offset

OpenGL1x

GL_EXT_rescale_normal

OpenGL1x

GL_EXT_secondary_color

OpenGL1x

GL_EXT_separate_specular_color

OpenGL1x

GL_EXT_shadow_funcs

OpenGL1x

GL_EXT_shared_texture_palette

OpenGL1x

GL_EXT_stencil_clear_tag

OpenGL1x

GL_EXT_stencil_two_side

OpenGL1x

GL_EXT_stencil_wrap

OpenGL1x

GL_EXT_texture3D

OpenGL1x

GL_EXT_texture_array

OpenGL1x

GL_EXT_texture_buffer_object

OpenGL1x

GL_EXT_texture_compression_latc

OpenGL1x

GL_EXT_texture_compression_rgtc

OpenGL1x

GL_EXT_texture_compression_s3tc

OpenGL1x

GL_EXT_texture_cube_map

OpenGL1x

GL_EXT_texture_edge_clamp

OpenGL1x

GL_EXT_texture_env_add

OpenGL1x

GL_EXT_texture_env_combine

OpenGL1x

GL_EXT_texture_env_dot3

OpenGL1x

GL_EXT_texture_filter_anisotropic

OpenGL1x

GL_EXT_texture_integer

OpenGL1x

GL_EXT_texture_lod

OpenGL1x

GL_EXT_texture_lod_bias

OpenGL1x

GL_EXT_texture_mirror_clamp

OpenGL1x

GL_EXT_texture_object

OpenGL1x

GL_EXT_texture_rectangle

OpenGL1x

GL_EXT_texture_shared_exponent

OpenGL1x

GL_EXT_texture_sRGB

OpenGL1x

GL_EXT_timer_query

OpenGL1x

GL_EXT_transform_feedback

OpenGL1x

GL_EXT_vertex_array

OpenGL1x

GL_EYE_LINEAR

OpenGLTokens

GL_EYE_PLANE

OpenGLTokens

GL_EYE_PLANE_ABSOLUTE_NV

OpenGLTokens

GL_EYE_RADIAL_NV

OpenGLTokens

GL_E_TIMES_F_NV

OpenGLTokens

GL_FALSE

OpenGLTokens

GL_FASTEST

OpenGLTokens

GL_FEEDBACK

OpenGLTokens

GL_FEEDBACK_BUFFER_POINTER

OpenGLTokens

GL_FEEDBACK_BUFFER_SIZE

OpenGLTokens

GL_FEEDBACK_BUFFER_TYPE

OpenGLTokens

GL_FENCE_CONDITION_NV

OpenGLTokens

GL_FENCE_STATUS_NV

OpenGLTokens

GL_FILE_NAME_NV

OpenGLTokens

GL_FILL

OpenGLTokens

GL_FIRST_TO_REST_NV

OpenGLTokens

GL_FIRST_VERTEX_CONVENTION

OpenGLTokens

GL_FIXED

OpenGLTokens

GL_FIXED_ONLY

OpenGLTokens

GL_FIXED_ONLY_ARB

OpenGLTokens

GL_FLAT

OpenGLTokens

GL_FLOAT

OpenGLTokens

GL_FLOAT_32_UNSIGNED_INT_24_8_REV

OpenGLTokens

GL_FLOAT_CLEAR_COLOR_VALUE_NV

OpenGLTokens

GL_FLOAT_MAT2

OpenGLTokens

GL_FLOAT_MAT2x3

OpenGLTokens

GL_FLOAT_MAT2x4

OpenGLTokens

GL_FLOAT_MAT2_ARB

OpenGLTokens

GL_FLOAT_MAT3

OpenGLTokens

GL_FLOAT_MAT3x2

OpenGLTokens

GL_FLOAT_MAT3x4

OpenGLTokens

GL_FLOAT_MAT3_ARB

OpenGLTokens

GL_FLOAT_MAT4

OpenGLTokens

GL_FLOAT_MAT4x2

OpenGLTokens

GL_FLOAT_MAT4x3

OpenGLTokens

GL_FLOAT_MAT4_ARB

OpenGLTokens

GL_FLOAT_R16_NV

OpenGLTokens

GL_FLOAT_R32_NV

OpenGLTokens

GL_FLOAT_RG16_NV

OpenGLTokens

GL_FLOAT_RG32_NV

OpenGLTokens

GL_FLOAT_RGB16_NV

OpenGLTokens

GL_FLOAT_RGB32_NV

OpenGLTokens

GL_FLOAT_RGBA16_NV

OpenGLTokens

GL_FLOAT_RGBA32_NV

OpenGLTokens

GL_FLOAT_RGBA_MODE_NV

OpenGLTokens

GL_FLOAT_RGBA_NV

OpenGLTokens

GL_FLOAT_RGB_NV

OpenGLTokens

GL_FLOAT_RG_NV

OpenGLTokens

GL_FLOAT_R_NV

OpenGLTokens

GL_FLOAT_VEC2

OpenGLTokens

GL_FLOAT_VEC2_ARB

OpenGLTokens

GL_FLOAT_VEC3

OpenGLTokens

GL_FLOAT_VEC3_ARB

OpenGLTokens

GL_FLOAT_VEC4

OpenGLTokens

GL_FLOAT_VEC4_ARB

OpenGLTokens

GL_FOG

OpenGLTokens

GL_FOG_BIT

OpenGLTokens

GL_FOG_COLOR

OpenGLTokens

GL_FOG_COORD

OpenGLTokens

GL_FOG_COORDINATE

OpenGLTokens

GL_FOG_COORDINATE_ARRAY

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_EXT

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_POINTER

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_POINTER_EXT

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_STRIDE

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_STRIDE_EXT

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_TYPE

OpenGLTokens

GL_FOG_COORDINATE_ARRAY_TYPE_EXT

OpenGLTokens

GL_FOG_COORDINATE_EXT

OpenGLTokens

GL_FOG_COORDINATE_SOURCE

OpenGLTokens

GL_FOG_COORDINATE_SOURCE_EXT

OpenGLTokens

GL_FOG_COORD_ARRAY

OpenGLTokens

GL_FOG_COORD_ARRAY_ADDRESS_NV

OpenGLTokens

GL_FOG_COORD_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_FOG_COORD_ARRAY_LENGTH_NV

OpenGLTokens

GL_FOG_COORD_ARRAY_POINTER

OpenGLTokens

GL_FOG_COORD_ARRAY_STRIDE

OpenGLTokens

GL_FOG_COORD_ARRAY_TYPE

OpenGLTokens

GL_FOG_COORD_SRC

OpenGLTokens

GL_FOG_DENSITY

OpenGLTokens

GL_FOG_DISTANCE_MODE_NV

OpenGLTokens

GL_FOG_END

OpenGLTokens

GL_FOG_HINT

OpenGLTokens

GL_FOG_INDEX

OpenGLTokens

GL_FOG_MODE

OpenGLTokens

GL_FOG_START

OpenGLTokens

GL_FONT_ASCENDER_NV

OpenGLTokens

GL_FONT_DESCENDER_NV

OpenGLTokens

GL_FONT_HAS_KERNING_NV

OpenGLTokens

GL_FONT_HEIGHT_NV

OpenGLTokens

GL_FONT_MAX_ADVANCE_HEIGHT_NV

OpenGLTokens

GL_FONT_MAX_ADVANCE_WIDTH_NV

OpenGLTokens

GL_FONT_UNDERLINE_POSITION_NV

OpenGLTokens

GL_FONT_UNDERLINE_THICKNESS_NV

OpenGLTokens

GL_FONT_UNITS_PER_EM_NV

OpenGLTokens

GL_FONT_X_MAX_BOUNDS_NV

OpenGLTokens

GL_FONT_X_MIN_BOUNDS_NV

OpenGLTokens

GL_FONT_Y_MAX_BOUNDS_NV

OpenGLTokens

GL_FONT_Y_MIN_BOUNDS_NV

OpenGLTokens

GL_FORCE_BLUE_TO_ONE_NV

OpenGLTokens

GL_FRACTIONAL_EVEN

OpenGLTokens

GL_FRACTIONAL_ODD

OpenGLTokens

GL_FRAGMENT_DEPTH

OpenGLTokens

GL_FRAGMENT_DEPTH_EXT

OpenGLTokens

GL_FRAGMENT_INTERPOLATION_OFFSET_BITS

OpenGLTokens

GL_FRAGMENT_PROGRAM_ARB

OpenGLTokens

GL_FRAGMENT_SHADER

OpenGLTokens

GL_FRAGMENT_SHADER_ARB

OpenGLTokens

GL_FRAGMENT_SHADER_BIT

OpenGLTokens

GL_FRAGMENT_SHADER_DERIVATIVE_HINT

OpenGLTokens

GL_FRAGMENT_SHADER_DERIVATIVE_HINT_ARB

OpenGLTokens

GL_FRAMEBUFFER

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_ALPHA_SIZE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_BLUE_SIZE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_COLOR_ENCODING

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_COMPONENT_TYPE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_DEPTH_SIZE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_GREEN_SIZE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_LAYERED

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_ARB

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_LAYERED_EXT

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_NAME_EXT

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_OBJECT_TYPE_EXT

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_RED_SIZE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_STENCIL_SIZE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_3D_ZOFFSET_EXT

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_CUBE_MAP_FACE_EXT

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LAYER_EXT

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL

OpenGLTokens

GL_FRAMEBUFFER_ATTACHMENT_TEXTURE_LEVEL_EXT

OpenGLTokens

GL_FRAMEBUFFER_BINDING

OpenGLTokens

GL_FRAMEBUFFER_BINDING_EXT

OpenGLTokens

GL_FRAMEBUFFER_COMPLETE

OpenGLTokens

GL_FRAMEBUFFER_COMPLETE_EXT

OpenGLTokens

GL_FRAMEBUFFER_DEFAULT

OpenGLTokens

GL_FRAMEBUFFER_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_DIMENSIONS_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_DRAW_BUFFER_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_DUPLICATE_ATTACHMENT_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_FORMATS_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_ARB

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_LAYER_COUNT_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_ARB

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_MISSING_ATTACHMENT_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_MULTISAMPLE_EXT

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER

OpenGLTokens

GL_FRAMEBUFFER_INCOMPLETE_READ_BUFFER_EXT

OpenGLTokens

GL_FRAMEBUFFER_SRGB

OpenGLTokens

GL_FRAMEBUFFER_SRGB_CAPABLE_EXT

OpenGLTokens

GL_FRAMEBUFFER_SRGB_EXT

OpenGLTokens

GL_FRAMEBUFFER_UNDEFINED

OpenGLTokens

GL_FRAMEBUFFER_UNSUPPORTED

OpenGLTokens

GL_FRAMEBUFFER_UNSUPPORTED_EXT

OpenGLTokens

GL_FRONT

OpenGLTokens

GL_FRONT_AND_BACK

OpenGLTokens

GL_FRONT_FACE

OpenGLTokens

GL_FRONT_LEFT

OpenGLTokens

GL_FRONT_RIGHT

OpenGLTokens

GL_FUNC_ADD

OpenGLTokens

GL_FUNC_ADD_EXT

OpenGLTokens

GL_FUNC_REVERSE_SUBTRACT

OpenGLTokens

GL_FUNC_REVERSE_SUBTRACT_EXT

OpenGLTokens

GL_FUNC_SUBTRACT

OpenGLTokens

GL_FUNC_SUBTRACT_EXT

OpenGLTokens

GL_GENERATE_MIPMAP

OpenGLTokens

GL_GENERATE_MIPMAP_HINT

OpenGLTokens

GL_GENERATE_MIPMAP_HINT_SGIS

OpenGLTokens

GL_GENERATE_MIPMAP_SGIS

OpenGLTokens

GL_GENERIC_ATTRIB_NV

OpenGLTokens

GL_GEOMETRY_INPUT_TYPE

OpenGLTokens

GL_GEOMETRY_INPUT_TYPE_ARB

OpenGLTokens

GL_GEOMETRY_INPUT_TYPE_EXT

OpenGLTokens

GL_GEOMETRY_OUTPUT_TYPE

OpenGLTokens

GL_GEOMETRY_OUTPUT_TYPE_ARB

OpenGLTokens

GL_GEOMETRY_OUTPUT_TYPE_EXT

OpenGLTokens

GL_GEOMETRY_PROGRAM_NV

OpenGLTokens

GL_GEOMETRY_SHADER

OpenGLTokens

GL_GEOMETRY_SHADER_ARB

OpenGLTokens

GL_GEOMETRY_SHADER_BIT

OpenGLTokens

GL_GEOMETRY_SHADER_EXT

OpenGLTokens

GL_GEOMETRY_SHADER_INVOCATIONS

OpenGLTokens

GL_GEOMETRY_VERTICES_OUT

OpenGLTokens

GL_GEOMETRY_VERTICES_OUT_ARB

OpenGLTokens

GL_GEOMETRY_VERTICES_OUT_EXT

OpenGLTokens

GL_GEQUAL

OpenGLTokens

GL_GLYPH_HAS_KERNING_NV

OpenGLTokens

GL_GLYPH_HEIGHT_BIT_NV

OpenGLTokens

GL_GLYPH_HORIZONTAL_BEARING_ADVANCE_BIT_NV

OpenGLTokens

GL_GLYPH_HORIZONTAL_BEARING_X_BIT_NV

OpenGLTokens

GL_GLYPH_HORIZONTAL_BEARING_Y_BIT_NV

OpenGLTokens

GL_GLYPH_VERTICAL_BEARING_ADVANCE_BIT_NV

OpenGLTokens

GL_GLYPH_VERTICAL_BEARING_X_BIT_NV

OpenGLTokens

GL_GLYPH_VERTICAL_BEARING_Y_BIT_NV

OpenGLTokens

GL_GLYPH_WIDTH_BIT_NV

OpenGLTokens

GL_GPU_ADDRESS_NV

OpenGLTokens

GL_GPU_MEMORY_INFO_CURRENT_AVAILABLE_VIDMEM_NVX

OpenGLTokens

GL_GPU_MEMORY_INFO_DEDICATED_VIDMEM_NVX

OpenGLTokens

GL_GPU_MEMORY_INFO_EVICTED_MEMORY_NVX

OpenGLTokens

GL_GPU_MEMORY_INFO_EVICTION_COUNT_NVX

OpenGLTokens

GL_GPU_MEMORY_INFO_TOTAL_AVAILABLE_MEMORY_NVX

OpenGLTokens

GL_GREATER

OpenGLTokens

GL_GREEN

OpenGLTokens

GL_GREEN_BIAS

OpenGLTokens

GL_GREEN_BITS

OpenGLTokens

GL_GREEN_INTEGER

OpenGLTokens

GL_GREEN_INTEGER_EXT

OpenGLTokens

GL_GREEN_SCALE

OpenGLTokens

GL_GREMEDY_frame_terminator

OpenGL1x

GL_GREMEDY_string_marker

OpenGL1x

GL_GUILTY_CONTEXT_RESET_ARB

OpenGLTokens

GL_HALF_BIAS_NEGATE_NV

OpenGLTokens

GL_HALF_BIAS_NORMAL_NV

OpenGLTokens

GL_HALF_FLOAT

OpenGLTokens

GL_HALF_FLOAT_ARB

OpenGLTokens

GL_HIGH_FLOAT

OpenGLTokens

GL_HIGH_INT

OpenGLTokens

GL_HILO16_NV

OpenGLTokens

GL_HILO8_NV

OpenGLTokens

GL_HILO_NV

OpenGLTokens

GL_HINT_BIT

OpenGLTokens

GL_HISTOGRAM

OpenGLTokens

GL_HISTOGRAM_ALPHA_SIZE

OpenGLTokens

GL_HISTOGRAM_ALPHA_SIZE_EXT

OpenGLTokens

GL_HISTOGRAM_BLUE_SIZE

OpenGLTokens

GL_HISTOGRAM_BLUE_SIZE_EXT

OpenGLTokens

GL_HISTOGRAM_EXT

OpenGLTokens

GL_HISTOGRAM_FORMAT

OpenGLTokens

GL_HISTOGRAM_FORMAT_EXT

OpenGLTokens

GL_HISTOGRAM_GREEN_SIZE

OpenGLTokens

GL_HISTOGRAM_GREEN_SIZE_EXT

OpenGLTokens

GL_HISTOGRAM_LUMINANCE_SIZE

OpenGLTokens

GL_HISTOGRAM_LUMINANCE_SIZE_EXT

OpenGLTokens

GL_HISTOGRAM_RED_SIZE

OpenGLTokens

GL_HISTOGRAM_RED_SIZE_EXT

OpenGLTokens

GL_HISTOGRAM_SINK

OpenGLTokens

GL_HISTOGRAM_SINK_EXT

OpenGLTokens

GL_HISTOGRAM_WIDTH

OpenGLTokens

GL_HISTOGRAM_WIDTH_EXT

OpenGLTokens

GL_HI_BIAS_NV

OpenGLTokens

GL_HI_SCALE_NV

OpenGLTokens

GL_HORIZONTAL_LINE_TO_NV

OpenGLTokens

GL_HP_occlusion_test

OpenGL1x

GL_IBM_rasterpos_clip

OpenGL1x

GL_IDENTITY_NV

OpenGLTokens

GL_IMPLEMENTATION_COLOR_READ_FORMAT

OpenGLTokens

GL_IMPLEMENTATION_COLOR_READ_TYPE

OpenGLTokens

GL_INCR

OpenGLTokens

GL_INCR_WRAP

OpenGLTokens

GL_INCR_WRAP_EXT

OpenGLTokens

GL_INDEX

OpenGLTokens

GL_INDEX_ARRAY

OpenGLTokens

GL_INDEX_ARRAY_ADDRESS_NV

OpenGLTokens

GL_INDEX_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_INDEX_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_INDEX_ARRAY_LENGTH_NV

OpenGLTokens

GL_INDEX_ARRAY_POINTER

OpenGLTokens

GL_INDEX_ARRAY_STRIDE

OpenGLTokens

GL_INDEX_ARRAY_TYPE

OpenGLTokens

GL_INDEX_BITS

OpenGLTokens

GL_INDEX_CLEAR_VALUE

OpenGLTokens

GL_INDEX_LOGIC_OP

OpenGLTokens

GL_INDEX_MODE

OpenGLTokens

GL_INDEX_OFFSET

OpenGLTokens

GL_INDEX_SHIFT

OpenGLTokens

GL_INDEX_WRITEMASK

OpenGLTokens

GL_INFO_LOG_LENGTH

OpenGLTokens

GL_INNOCENT_CONTEXT_RESET_ARB

OpenGLTokens

GL_INT

OpenGLTokens

GL_INTENSITY

OpenGLTokens

GL_INTENSITY12

OpenGLTokens

GL_INTENSITY12_EXT

OpenGLTokens

GL_INTENSITY16

OpenGLTokens

GL_INTENSITY16F_ARB

OpenGLTokens

GL_INTENSITY16I_EXT

OpenGLTokens

GL_INTENSITY16UI_EXT

OpenGLTokens

GL_INTENSITY16_EXT

OpenGLTokens

GL_INTENSITY32F_ARB

OpenGLTokens

GL_INTENSITY32I_EXT

OpenGLTokens

GL_INTENSITY32UI_EXT

OpenGLTokens

GL_INTENSITY4

OpenGLTokens

GL_INTENSITY4_EXT

OpenGLTokens

GL_INTENSITY8

OpenGLTokens

GL_INTENSITY8I_EXT

OpenGLTokens

GL_INTENSITY8UI_EXT

OpenGLTokens

GL_INTENSITY8_EXT

OpenGLTokens

GL_INTENSITY_EXT

OpenGLTokens

GL_INTENSITY_FLOAT16_ATI

OpenGLTokens

GL_INTENSITY_FLOAT32_ATI

OpenGLTokens

GL_INTERLEAVED_ATTRIBS

OpenGLTokens

GL_INTERLEAVED_ATTRIBS_EXT

OpenGLTokens

GL_INTERLEAVED_ATTRIBS_NV

OpenGLTokens

GL_INTERPOLATE

OpenGLTokens

GL_INTERPOLATE_ARB

OpenGLTokens

GL_INTERPOLATE_EXT

OpenGLTokens

GL_INT_2_10_10_10_REV

OpenGLTokens

GL_INT_SAMPLER_1D

OpenGLTokens

GL_INT_SAMPLER_1D_ARRAY

OpenGLTokens

GL_INT_SAMPLER_1D_ARRAY_EXT

OpenGLTokens

GL_INT_SAMPLER_1D_EXT

OpenGLTokens

GL_INT_SAMPLER_2D

OpenGLTokens

GL_INT_SAMPLER_2D_ARRAY

OpenGLTokens

GL_INT_SAMPLER_2D_ARRAY_EXT

OpenGLTokens

GL_INT_SAMPLER_2D_EXT

OpenGLTokens

GL_INT_SAMPLER_2D_MULTISAMPLE

OpenGLTokens

GL_INT_SAMPLER_2D_MULTISAMPLE_ARRAY

OpenGLTokens

GL_INT_SAMPLER_2D_RECT

OpenGLTokens

GL_INT_SAMPLER_2D_RECT_EXT

OpenGLTokens

GL_INT_SAMPLER_3D

OpenGLTokens

GL_INT_SAMPLER_3D_EXT

OpenGLTokens

GL_INT_SAMPLER_BUFFER

OpenGLTokens

GL_INT_SAMPLER_BUFFER_AMD

OpenGLTokens

GL_INT_SAMPLER_BUFFER_EXT

OpenGLTokens

GL_INT_SAMPLER_CUBE

OpenGLTokens

GL_INT_SAMPLER_CUBE_EXT

OpenGLTokens

GL_INT_SAMPLER_CUBE_MAP_ARRAY

OpenGLTokens

GL_INT_SAMPLER_CUBE_MAP_ARRAY_ARB

OpenGLTokens

GL_INT_VEC2

OpenGLTokens

GL_INT_VEC2_ARB

OpenGLTokens

GL_INT_VEC3

OpenGLTokens

GL_INT_VEC3_ARB

OpenGLTokens

GL_INT_VEC4

OpenGLTokens

GL_INT_VEC4_ARB

OpenGLTokens

GL_INVALID_ENUM

OpenGLTokens

GL_INVALID_FRAMEBUFFER_OPERATION

OpenGLTokens

GL_INVALID_FRAMEBUFFER_OPERATION_EXT

OpenGLTokens

GL_INVALID_INDEX

OpenGLTokens

GL_INVALID_OPERATION

OpenGLTokens

GL_INVALID_VALUE

OpenGLTokens

GL_INVERSE_NV

OpenGLTokens

GL_INVERSE_TRANSPOSE_NV

OpenGLTokens

GL_INVERT

OpenGLTokens

GL_ISOLINES

OpenGLTokens

GL_ITALIC_BIT_NV

OpenGLTokens

GL_KEEP

OpenGLTokens

GL_KTX_buffer_region

OpenGL1x

GL_LARGE_CCW_ARC_TO_NV

OpenGLTokens

GL_LARGE_CW_ARC_TO_NV

OpenGLTokens

GL_LAST_VERTEX_CONVENTION

OpenGLTokens

GL_LAYER_NV

OpenGLTokens

GL_LAYER_PROVOKING_VERTEX

OpenGLTokens

GL_LEFT

OpenGLTokens

GL_LEQUAL

OpenGLTokens

GL_LESS

OpenGLTokens

GL_LIGHT0

OpenGLTokens

GL_LIGHT1

OpenGLTokens

GL_LIGHT2

OpenGLTokens

GL_LIGHT3

OpenGLTokens

GL_LIGHT4

OpenGLTokens

GL_LIGHT5

OpenGLTokens

GL_LIGHT6

OpenGLTokens

GL_LIGHT7

OpenGLTokens

GL_LIGHTING

OpenGLTokens

GL_LIGHTING_BIT

OpenGLTokens

GL_LIGHT_MODEL_AMBIENT

OpenGLTokens

GL_LIGHT_MODEL_COLOR_CONTROL

OpenGLTokens

GL_LIGHT_MODEL_COLOR_CONTROL_EXT

OpenGLTokens

GL_LIGHT_MODEL_LOCAL_VIEWER

OpenGLTokens

GL_LIGHT_MODEL_TWO_SIDE

OpenGLTokens

GL_LINE

OpenGLTokens

GL_LINEAR

OpenGLTokens

GL_LINEAR_ATTENUATION

OpenGLTokens

GL_LINEAR_MIPMAP_LINEAR

OpenGLTokens

GL_LINEAR_MIPMAP_NEAREST

OpenGLTokens

GL_LINES

OpenGLTokens

GL_LINES_ADJACENCY

OpenGLTokens

GL_LINES_ADJACENCY_ARB

OpenGLTokens

GL_LINES_ADJACENCY_EXT

OpenGLTokens

GL_LINE_BIT

OpenGLTokens

GL_LINE_LOOP

OpenGLTokens

GL_LINE_RESET_TOKEN

OpenGLTokens

GL_LINE_SMOOTH

OpenGLTokens

GL_LINE_SMOOTH_HINT

OpenGLTokens

GL_LINE_STIPPLE

OpenGLTokens

GL_LINE_STIPPLE_PATTERN

OpenGLTokens

GL_LINE_STIPPLE_REPEAT

OpenGLTokens

GL_LINE_STRIP

OpenGLTokens

GL_LINE_STRIP_ADJACENCY

OpenGLTokens

GL_LINE_STRIP_ADJACENCY_ARB

OpenGLTokens

GL_LINE_STRIP_ADJACENCY_EXT

OpenGLTokens

GL_LINE_TOKEN

OpenGLTokens

GL_LINE_TO_NV

OpenGLTokens

GL_LINE_WIDTH

OpenGLTokens

GL_LINE_WIDTH_GRANULARITY

OpenGLTokens

GL_LINE_WIDTH_RANGE

OpenGLTokens

GL_LINK_STATUS

OpenGLTokens

GL_LIST_BASE

OpenGLTokens

GL_LIST_BIT

OpenGLTokens

GL_LIST_INDEX

OpenGLTokens

GL_LIST_MODE

OpenGLTokens

GL_LOAD

OpenGLTokens

GL_LOGIC_OP

OpenGLTokens

GL_LOGIC_OP_MODE

OpenGLTokens

GL_LOSE_CONTEXT_ON_RESET_ARB

OpenGLTokens

GL_LOWER_LEFT

OpenGLTokens

GL_LOW_FLOAT

OpenGLTokens

GL_LOW_INT

OpenGLTokens

GL_LO_BIAS_NV

OpenGLTokens

GL_LO_SCALE_NV

OpenGLTokens

GL_LUMINANCE

OpenGLTokens

GL_LUMINANCE12

OpenGLTokens

GL_LUMINANCE12_ALPHA12

OpenGLTokens

GL_LUMINANCE12_ALPHA12_EXT

OpenGLTokens

GL_LUMINANCE12_ALPHA4

OpenGLTokens

GL_LUMINANCE12_ALPHA4_EXT

OpenGLTokens

GL_LUMINANCE12_EXT

OpenGLTokens

GL_LUMINANCE16

OpenGLTokens

GL_LUMINANCE16F_ARB

OpenGLTokens

GL_LUMINANCE16I_EXT

OpenGLTokens

GL_LUMINANCE16UI_EXT

OpenGLTokens

GL_LUMINANCE16_ALPHA16

OpenGLTokens

GL_LUMINANCE16_ALPHA16_EXT

OpenGLTokens

GL_LUMINANCE16_EXT

OpenGLTokens

GL_LUMINANCE32F_ARB

OpenGLTokens

GL_LUMINANCE32I_EXT

OpenGLTokens

GL_LUMINANCE32UI_EXT

OpenGLTokens

GL_LUMINANCE4

OpenGLTokens

GL_LUMINANCE4_ALPHA4

OpenGLTokens

GL_LUMINANCE4_ALPHA4_EXT

OpenGLTokens

GL_LUMINANCE4_EXT

OpenGLTokens

GL_LUMINANCE6_ALPHA2

OpenGLTokens

GL_LUMINANCE6_ALPHA2_EXT

OpenGLTokens

GL_LUMINANCE8

OpenGLTokens

GL_LUMINANCE8I_EXT

OpenGLTokens

GL_LUMINANCE8UI_EXT

OpenGLTokens

GL_LUMINANCE8_ALPHA8

OpenGLTokens

GL_LUMINANCE8_ALPHA8_EXT

OpenGLTokens

GL_LUMINANCE8_EXT

OpenGLTokens

GL_LUMINANCE_ALPHA

OpenGLTokens

GL_LUMINANCE_ALPHA16F_ARB

OpenGLTokens

GL_LUMINANCE_ALPHA16I_EXT

OpenGLTokens

GL_LUMINANCE_ALPHA16UI_EXT

OpenGLTokens

GL_LUMINANCE_ALPHA32F_ARB

OpenGLTokens

GL_LUMINANCE_ALPHA32I_EXT

OpenGLTokens

GL_LUMINANCE_ALPHA32UI_EXT

OpenGLTokens

GL_LUMINANCE_ALPHA8I_EXT

OpenGLTokens

GL_LUMINANCE_ALPHA8UI_EXT

OpenGLTokens

GL_LUMINANCE_ALPHA_FLOAT16_ATI

OpenGLTokens

GL_LUMINANCE_ALPHA_FLOAT32_ATI

OpenGLTokens

GL_LUMINANCE_ALPHA_INTEGER_EXT

OpenGLTokens

GL_LUMINANCE_FLOAT16_ATI

OpenGLTokens

GL_LUMINANCE_FLOAT32_ATI

OpenGLTokens

GL_LUMINANCE_INTEGER_EXT

OpenGLTokens

GL_MAGNITUDE_BIAS_NV

OpenGLTokens

GL_MAGNITUDE_SCALE_NV

OpenGLTokens

GL_MAJOR_VERSION

OpenGLTokens

GL_MAP1_COLOR_4

OpenGLTokens

GL_MAP1_GRID_DOMAIN

OpenGLTokens

GL_MAP1_GRID_SEGMENTS

OpenGLTokens

GL_MAP1_INDEX

OpenGLTokens

GL_MAP1_NORMAL

OpenGLTokens

GL_MAP1_TEXTURE_COORD_1

OpenGLTokens

GL_MAP1_TEXTURE_COORD_2

OpenGLTokens

GL_MAP1_TEXTURE_COORD_3

OpenGLTokens

GL_MAP1_TEXTURE_COORD_4

OpenGLTokens

GL_MAP1_VERTEX_3

OpenGLTokens

GL_MAP1_VERTEX_4

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB0_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB10_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB11_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB12_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB13_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB14_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB15_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB1_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB2_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB3_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB4_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB5_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB6_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB7_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB8_4_NV

OpenGLTokens

GL_MAP1_VERTEX_ATTRIB9_4_NV

OpenGLTokens

GL_MAP2_COLOR_4

OpenGLTokens

GL_MAP2_GRID_DOMAIN

OpenGLTokens

GL_MAP2_GRID_SEGMENTS

OpenGLTokens

GL_MAP2_INDEX

OpenGLTokens

GL_MAP2_NORMAL

OpenGLTokens

GL_MAP2_TEXTURE_COORD_1

OpenGLTokens

GL_MAP2_TEXTURE_COORD_2

OpenGLTokens

GL_MAP2_TEXTURE_COORD_3

OpenGLTokens

GL_MAP2_TEXTURE_COORD_4

OpenGLTokens

GL_MAP2_VERTEX_3

OpenGLTokens

GL_MAP2_VERTEX_4

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB0_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB10_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB11_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB12_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB13_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB14_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB15_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB1_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB2_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB3_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB4_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB5_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB6_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB7_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB8_4_NV

OpenGLTokens

GL_MAP2_VERTEX_ATTRIB9_4_NV

OpenGLTokens

GL_MAP_COLOR

OpenGLTokens

GL_MAP_FLUSH_EXPLICIT_BIT

OpenGLTokens

GL_MAP_INVALIDATE_BUFFER_BIT

OpenGLTokens

GL_MAP_INVALIDATE_RANGE_BIT

OpenGLTokens

GL_MAP_READ_BIT

OpenGLTokens

GL_MAP_STENCIL

OpenGLTokens

GL_MAP_UNSYNCHRONIZED_BIT

OpenGLTokens

GL_MAP_WRITE_BIT

OpenGLTokens

GL_MATRIX0_ARB

OpenGLTokens

GL_MATRIX0_NV

OpenGLTokens

GL_MATRIX10_ARB

OpenGLTokens

GL_MATRIX11_ARB

OpenGLTokens

GL_MATRIX12_ARB

OpenGLTokens

GL_MATRIX13_ARB

OpenGLTokens

GL_MATRIX14_ARB

OpenGLTokens

GL_MATRIX15_ARB

OpenGLTokens

GL_MATRIX16_ARB

OpenGLTokens

GL_MATRIX17_ARB

OpenGLTokens

GL_MATRIX18_ARB

OpenGLTokens

GL_MATRIX19_ARB

OpenGLTokens

GL_MATRIX1_ARB

OpenGLTokens

GL_MATRIX1_NV

OpenGLTokens

GL_MATRIX20_ARB

OpenGLTokens

GL_MATRIX21_ARB

OpenGLTokens

GL_MATRIX22_ARB

OpenGLTokens

GL_MATRIX23_ARB

OpenGLTokens

GL_MATRIX24_ARB

OpenGLTokens

GL_MATRIX25_ARB

OpenGLTokens

GL_MATRIX26_ARB

OpenGLTokens

GL_MATRIX27_ARB

OpenGLTokens

GL_MATRIX28_ARB

OpenGLTokens

GL_MATRIX29_ARB

OpenGLTokens

GL_MATRIX2_ARB

OpenGLTokens

GL_MATRIX2_NV

OpenGLTokens

GL_MATRIX30_ARB

OpenGLTokens

GL_MATRIX31_ARB

OpenGLTokens

GL_MATRIX3_ARB

OpenGLTokens

GL_MATRIX3_NV

OpenGLTokens

GL_MATRIX4_ARB

OpenGLTokens

GL_MATRIX4_NV

OpenGLTokens

GL_MATRIX5_ARB

OpenGLTokens

GL_MATRIX5_NV

OpenGLTokens

GL_MATRIX6_ARB

OpenGLTokens

GL_MATRIX6_NV

OpenGLTokens

GL_MATRIX7_ARB

OpenGLTokens

GL_MATRIX7_NV

OpenGLTokens

GL_MATRIX8_ARB

OpenGLTokens

GL_MATRIX9_ARB

OpenGLTokens

GL_MATRIX_INDEX_ARRAY_ARB

OpenGLTokens

GL_MATRIX_INDEX_ARRAY_POINTER_ARB

OpenGLTokens

GL_MATRIX_INDEX_ARRAY_SIZE_ARB

OpenGLTokens

GL_MATRIX_INDEX_ARRAY_STRIDE_ARB

OpenGLTokens

GL_MATRIX_INDEX_ARRAY_TYPE_ARB

OpenGLTokens

GL_MATRIX_MODE

OpenGLTokens

GL_MATRIX_PALETTE_ARB

OpenGLTokens

GL_MAX

OpenGLTokens

GL_MAX_3D_TEXTURE_SIZE

OpenGLTokens

GL_MAX_3D_TEXTURE_SIZE_EXT

OpenGLTokens

GL_MAX_ARRAY_TEXTURE_LAYERS

OpenGLTokens

GL_MAX_ARRAY_TEXTURE_LAYERS_EXT

OpenGLTokens

GL_MAX_ATTRIB_STACK_DEPTH

OpenGLTokens

GL_MAX_BINDABLE_UNIFORM_SIZE_EXT

OpenGLTokens

GL_MAX_CLIENT_ATTRIB_STACK_DEPTH

OpenGLTokens

GL_MAX_CLIP_DISTANCES

OpenGLTokens

GL_MAX_CLIP_PLANES

OpenGLTokens

GL_MAX_COLOR_ATTACHMENTS

OpenGLTokens

GL_MAX_COLOR_ATTACHMENTS_EXT

OpenGLTokens

GL_MAX_COLOR_MATRIX_STACK_DEPTH

OpenGLTokens

GL_MAX_COLOR_MATRIX_STACK_DEPTH_SGI

OpenGLTokens

GL_MAX_COLOR_TEXTURE_SAMPLES

OpenGLTokens

GL_MAX_COMBINED_FRAGMENT_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_COMBINED_GEOMETRY_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_COMBINED_TESS_CONTROL_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_COMBINED_TESS_EVALUATION_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS

OpenGLTokens

GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS_ARB

OpenGLTokens

GL_MAX_COMBINED_UNIFORM_BLOCKS

OpenGLTokens

GL_MAX_COMBINED_VERTEX_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_CONVOLUTION_HEIGHT

OpenGLTokens

GL_MAX_CONVOLUTION_HEIGHT_EXT

OpenGLTokens

GL_MAX_CONVOLUTION_WIDTH

OpenGLTokens

GL_MAX_CONVOLUTION_WIDTH_EXT

OpenGLTokens

GL_MAX_CUBE_MAP_TEXTURE_SIZE

OpenGLTokens

GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB

OpenGLTokens

GL_MAX_CUBE_MAP_TEXTURE_SIZE_EXT

OpenGLTokens

GL_MAX_DEBUG_LOGGED_MESSAGES_ARB

OpenGLTokens

GL_MAX_DEBUG_MESSAGE_LENGTH_ARB

OpenGLTokens

GL_MAX_DEPTH_TEXTURE_SAMPLES

OpenGLTokens

GL_MAX_DRAW_BUFFERS

OpenGLTokens

GL_MAX_DRAW_BUFFERS_ARB

OpenGLTokens

GL_MAX_DRAW_BUFFERS_ATI

OpenGLTokens

GL_MAX_DUAL_SOURCE_DRAW_BUFFERS

OpenGLTokens

GL_MAX_ELEMENTS_INDICES

OpenGLTokens

GL_MAX_ELEMENTS_INDICES_EXT

OpenGLTokens

GL_MAX_ELEMENTS_VERTICES

OpenGLTokens

GL_MAX_ELEMENTS_VERTICES_EXT

OpenGLTokens

GL_MAX_EVAL_ORDER

OpenGLTokens

GL_MAX_EXT

OpenGLTokens

GL_MAX_FRAGMENT_BINDABLE_UNIFORMS_EXT

OpenGLTokens

GL_MAX_FRAGMENT_INPUT_COMPONENTS

OpenGLTokens

GL_MAX_FRAGMENT_INTERPOLATION_OFFSET

OpenGLTokens

GL_MAX_FRAGMENT_UNIFORM_BLOCKS

OpenGLTokens

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_FRAGMENT_UNIFORM_COMPONENTS_ARB

OpenGLTokens

GL_MAX_FRAGMENT_UNIFORM_VECTORS

OpenGLTokens

GL_MAX_GENERAL_COMBINERS_NV

OpenGLTokens

GL_MAX_GEOMETRY_BINDABLE_UNIFORMS_EXT

OpenGLTokens

GL_MAX_GEOMETRY_INPUT_COMPONENTS

OpenGLTokens

GL_MAX_GEOMETRY_OUTPUT_COMPONENTS

OpenGLTokens

GL_MAX_GEOMETRY_OUTPUT_VERTICES

OpenGLTokens

GL_MAX_GEOMETRY_OUTPUT_VERTICES_ARB

OpenGLTokens

GL_MAX_GEOMETRY_OUTPUT_VERTICES_EXT

OpenGLTokens

GL_MAX_GEOMETRY_SHADER_INVOCATIONS

OpenGLTokens

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS

OpenGLTokens

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_ARB

OpenGLTokens

GL_MAX_GEOMETRY_TEXTURE_IMAGE_UNITS_EXT

OpenGLTokens

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS

OpenGLTokens

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_ARB

OpenGLTokens

GL_MAX_GEOMETRY_TOTAL_OUTPUT_COMPONENTS_EXT

OpenGLTokens

GL_MAX_GEOMETRY_UNIFORM_BLOCKS

OpenGLTokens

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_ARB

OpenGLTokens

GL_MAX_GEOMETRY_UNIFORM_COMPONENTS_EXT

OpenGLTokens

GL_MAX_GEOMETRY_VARYING_COMPONENTS_ARB

OpenGLTokens

GL_MAX_GEOMETRY_VARYING_COMPONENTS_EXT

OpenGLTokens

GL_MAX_INTEGER_SAMPLES

OpenGLTokens

GL_MAX_LIGHTS

OpenGLTokens

GL_MAX_LIST_NESTING

OpenGLTokens

GL_MAX_MATRIX_PALETTE_STACK_DEPTH_ARB

OpenGLTokens

GL_MAX_MODELVIEW_STACK_DEPTH

OpenGLTokens

GL_MAX_NAME_STACK_DEPTH

OpenGLTokens

GL_MAX_PALETTE_MATRICES_ARB

OpenGLTokens

GL_MAX_PATCH_VERTICES

OpenGLTokens

GL_MAX_PIXEL_MAP_TABLE

OpenGLTokens

GL_MAX_PROGRAM_ADDRESS_REGISTERS_ARB

OpenGLTokens

GL_MAX_PROGRAM_ALU_INSTRUCTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_ATTRIBS_ARB

OpenGLTokens

GL_MAX_PROGRAM_ENV_PARAMETERS_ARB

OpenGLTokens

GL_MAX_PROGRAM_INSTRUCTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_LOCAL_PARAMETERS_ARB

OpenGLTokens

GL_MAX_PROGRAM_MATRICES_ARB

OpenGLTokens

GL_MAX_PROGRAM_MATRIX_STACK_DEPTH_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_ATTRIBS_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_INSTRUCTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_PARAMETERS_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_TEMPORARIES_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_OUTPUT_VERTICES_NV

OpenGLTokens

GL_MAX_PROGRAM_PARAMETERS_ARB

OpenGLTokens

GL_MAX_PROGRAM_TEMPORARIES_ARB

OpenGLTokens

GL_MAX_PROGRAM_TEXEL_OFFSET

OpenGLTokens

GL_MAX_PROGRAM_TEXEL_OFFSET_EXT

OpenGLTokens

GL_MAX_PROGRAM_TEXTURE_GATHER_COMPONENTS_ARB

OpenGLTokens

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET

OpenGLTokens

GL_MAX_PROGRAM_TEXTURE_GATHER_OFFSET_ARB

OpenGLTokens

GL_MAX_PROGRAM_TEX_INDIRECTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_TEX_INSTRUCTIONS_ARB

OpenGLTokens

GL_MAX_PROGRAM_TOTAL_OUTPUT_COMPONENTS_NV

OpenGLTokens

GL_MAX_PROJECTION_STACK_DEPTH

OpenGLTokens

GL_MAX_RECTANGLE_TEXTURE_SIZE

OpenGLTokens

GL_MAX_RECTANGLE_TEXTURE_SIZE_ARB

OpenGLTokens

GL_MAX_RECTANGLE_TEXTURE_SIZE_EXT

OpenGLTokens

GL_MAX_RECTANGLE_TEXTURE_SIZE_NV

OpenGLTokens

GL_MAX_RENDERBUFFER_SIZE

OpenGLTokens

GL_MAX_RENDERBUFFER_SIZE_EXT

OpenGLTokens

GL_MAX_SAMPLES

OpenGLTokens

GL_MAX_SAMPLES_EXT

OpenGLTokens

GL_MAX_SAMPLE_MASK_WORDS

OpenGLTokens

GL_MAX_SERVER_WAIT_TIMEOUT

OpenGLTokens

GL_MAX_SHADER_BUFFER_ADDRESS_NV

OpenGLTokens

GL_MAX_SHININESS_NV

OpenGLTokens

GL_MAX_SPOT_EXPONENT_NV

OpenGLTokens

GL_MAX_SUBROUTINES

OpenGLTokens

GL_MAX_SUBROUTINE_UNIFORM_LOCATIONS

OpenGLTokens

GL_MAX_TESS_CONTROL_INPUT_COMPONENTS

OpenGLTokens

GL_MAX_TESS_CONTROL_OUTPUT_COMPONENTS

OpenGLTokens

GL_MAX_TESS_CONTROL_TEXTURE_IMAGE_UNITS

OpenGLTokens

GL_MAX_TESS_CONTROL_TOTAL_OUTPUT_COMPONENTS

OpenGLTokens

GL_MAX_TESS_CONTROL_UNIFORM_BLOCKS

OpenGLTokens

GL_MAX_TESS_CONTROL_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_TESS_EVALUATION_INPUT_COMPONENTS

OpenGLTokens

GL_MAX_TESS_EVALUATION_OUTPUT_COMPONENTS

OpenGLTokens

GL_MAX_TESS_EVALUATION_TEXTURE_IMAGE_UNITS

OpenGLTokens

GL_MAX_TESS_EVALUATION_UNIFORM_BLOCKS

OpenGLTokens

GL_MAX_TESS_EVALUATION_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_TESS_GEN_LEVEL

OpenGLTokens

GL_MAX_TESS_PATCH_COMPONENTS

OpenGLTokens

GL_MAX_TEXTURE_BUFFER_SIZE

OpenGLTokens

GL_MAX_TEXTURE_BUFFER_SIZE_ARB

OpenGLTokens

GL_MAX_TEXTURE_BUFFER_SIZE_EXT

OpenGLTokens

GL_MAX_TEXTURE_COORDS

OpenGLTokens

GL_MAX_TEXTURE_COORDS_ARB

OpenGLTokens

GL_MAX_TEXTURE_IMAGE_UNITS

OpenGLTokens

GL_MAX_TEXTURE_IMAGE_UNITS_ARB

OpenGLTokens

GL_MAX_TEXTURE_LOD_BIAS

OpenGLTokens

GL_MAX_TEXTURE_LOD_BIAS_EXT

OpenGLTokens

GL_MAX_TEXTURE_MAX_ANISOTROPY_EXT

OpenGLTokens

GL_MAX_TEXTURE_SIZE

OpenGLTokens

GL_MAX_TEXTURE_STACK_DEPTH

OpenGLTokens

GL_MAX_TEXTURE_UNITS

OpenGLTokens

GL_MAX_TEXTURE_UNITS_ARB

OpenGLTokens

GL_MAX_TRACK_MATRICES_NV

OpenGLTokens

GL_MAX_TRACK_MATRIX_STACK_DEPTH_NV

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_BUFFERS

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_EXT

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_INTERLEAVED_COMPONENTS_NV

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_EXT

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_ATTRIBS_NV

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_EXT

OpenGLTokens

GL_MAX_TRANSFORM_FEEDBACK_SEPARATE_COMPONENTS_NV

OpenGLTokens

GL_MAX_UNIFORM_BLOCK_SIZE

OpenGLTokens

GL_MAX_UNIFORM_BUFFER_BINDINGS

OpenGLTokens

GL_MAX_VARYING_COMPONENTS

OpenGLTokens

GL_MAX_VARYING_COMPONENTS_EXT

OpenGLTokens

GL_MAX_VARYING_FLOATS

OpenGLTokens

GL_MAX_VARYING_FLOATS_ARB

OpenGLTokens

GL_MAX_VARYING_VECTORS

OpenGLTokens

GL_MAX_VERTEX_ARRAY_RANGE_ELEMENT_NV

OpenGLTokens

GL_MAX_VERTEX_ATTRIBS

OpenGLTokens

GL_MAX_VERTEX_ATTRIBS_ARB

OpenGLTokens

GL_MAX_VERTEX_BINDABLE_UNIFORMS_EXT

OpenGLTokens

GL_MAX_VERTEX_OUTPUT_COMPONENTS

OpenGLTokens

GL_MAX_VERTEX_STREAMS

OpenGLTokens

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS

OpenGLTokens

GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS_ARB

OpenGLTokens

GL_MAX_VERTEX_UNIFORM_BLOCKS

OpenGLTokens

GL_MAX_VERTEX_UNIFORM_COMPONENTS

OpenGLTokens

GL_MAX_VERTEX_UNIFORM_COMPONENTS_ARB

OpenGLTokens

GL_MAX_VERTEX_UNIFORM_VECTORS

OpenGLTokens

GL_MAX_VERTEX_UNITS_ARB

OpenGLTokens

GL_MAX_VERTEX_VARYING_COMPONENTS_ARB

OpenGLTokens

GL_MAX_VERTEX_VARYING_COMPONENTS_EXT

OpenGLTokens

GL_MAX_VIEWPORTS

OpenGLTokens

GL_MAX_VIEWPORT_DIMS

OpenGLTokens

GL_MEDIUM_FLOAT

OpenGLTokens

GL_MEDIUM_INT

OpenGLTokens

GL_MESA_resize_buffers

OpenGL1x

GL_MIN

OpenGLTokens

GL_MINMAX

OpenGLTokens

GL_MINMAX_EXT

OpenGLTokens

GL_MINMAX_FORMAT

OpenGLTokens

GL_MINMAX_FORMAT_EXT

OpenGLTokens

GL_MINMAX_SINK

OpenGLTokens

GL_MINMAX_SINK_EXT

OpenGLTokens

GL_MINOR_VERSION

OpenGLTokens

GL_MIN_EXT

OpenGLTokens

GL_MIN_FRAGMENT_INTERPOLATION_OFFSET

OpenGLTokens

GL_MIN_PROGRAM_TEXEL_OFFSET

OpenGLTokens

GL_MIN_PROGRAM_TEXEL_OFFSET_EXT

OpenGLTokens

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET

OpenGLTokens

GL_MIN_PROGRAM_TEXTURE_GATHER_OFFSET_ARB

OpenGLTokens

GL_MIN_SAMPLE_SHADING_VALUE

OpenGLTokens

GL_MIN_SAMPLE_SHADING_VALUE_ARB

OpenGLTokens

GL_MIRRORED_REPEAT

OpenGLTokens

GL_MIRRORED_REPEAT_ARB

OpenGLTokens

GL_MIRROR_CLAMP_ATI

OpenGLTokens

GL_MIRROR_CLAMP_EXT

OpenGLTokens

GL_MIRROR_CLAMP_TO_BORDER_EXT

OpenGLTokens

GL_MIRROR_CLAMP_TO_EDGE_ATI

OpenGLTokens

GL_MIRROR_CLAMP_TO_EDGE_EXT

OpenGLTokens

GL_MITER_REVERT_NV

OpenGLTokens

GL_MITER_TRUNCATE_NV

OpenGLTokens

GL_MODELVIEW

OpenGLTokens

GL_MODELVIEW0_ARB

OpenGLTokens

GL_MODELVIEW10_ARB

OpenGLTokens

GL_MODELVIEW11_ARB

OpenGLTokens

GL_MODELVIEW12_ARB

OpenGLTokens

GL_MODELVIEW13_ARB

OpenGLTokens

GL_MODELVIEW14_ARB

OpenGLTokens

GL_MODELVIEW15_ARB

OpenGLTokens

GL_MODELVIEW16_ARB

OpenGLTokens

GL_MODELVIEW17_ARB

OpenGLTokens

GL_MODELVIEW18_ARB

OpenGLTokens

GL_MODELVIEW19_ARB

OpenGLTokens

GL_MODELVIEW1_ARB

OpenGLTokens

GL_MODELVIEW20_ARB

OpenGLTokens

GL_MODELVIEW21_ARB

OpenGLTokens

GL_MODELVIEW22_ARB

OpenGLTokens

GL_MODELVIEW23_ARB

OpenGLTokens

GL_MODELVIEW24_ARB

OpenGLTokens

GL_MODELVIEW25_ARB

OpenGLTokens

GL_MODELVIEW26_ARB

OpenGLTokens

GL_MODELVIEW27_ARB

OpenGLTokens

GL_MODELVIEW28_ARB

OpenGLTokens

GL_MODELVIEW29_ARB

OpenGLTokens

GL_MODELVIEW2_ARB

OpenGLTokens

GL_MODELVIEW30_ARB

OpenGLTokens

GL_MODELVIEW31_ARB

OpenGLTokens

GL_MODELVIEW3_ARB

OpenGLTokens

GL_MODELVIEW4_ARB

OpenGLTokens

GL_MODELVIEW5_ARB

OpenGLTokens

GL_MODELVIEW6_ARB

OpenGLTokens

GL_MODELVIEW7_ARB

OpenGLTokens

GL_MODELVIEW8_ARB

OpenGLTokens

GL_MODELVIEW9_ARB

OpenGLTokens

GL_MODELVIEW_MATRIX

OpenGLTokens

GL_MODELVIEW_PROJECTION_NV

OpenGLTokens

GL_MODELVIEW_STACK_DEPTH

OpenGLTokens

GL_MODULATE

OpenGLTokens

GL_MOVE_TO_CONTINUES_NV

OpenGLTokens

GL_MOVE_TO_NV

OpenGLTokens

GL_MOVE_TO_RESETS_NV

OpenGLTokens

GL_MULT

OpenGLTokens

GL_MULTISAMPLE

OpenGLTokens

GL_MULTISAMPLE_3DFX

OpenGLTokens

GL_MULTISAMPLE_ARB

OpenGLTokens

GL_MULTISAMPLE_BIT

OpenGLTokens

GL_MULTISAMPLE_BIT_3DFX

OpenGLTokens

GL_MULTISAMPLE_BIT_ARB

OpenGLTokens

GL_MULTISAMPLE_EXT

OpenGLTokens

GL_MULTISAMPLE_FILTER_HINT_NV

OpenGLTokens

GL_MULTISAMPLE_SGIS

OpenGLTokens

GL_N3F_V3F

OpenGLTokens

GL_NAME_STACK_DEPTH

OpenGLTokens

GL_NAND

OpenGLTokens

GL_NEAREST

OpenGLTokens

GL_NEAREST_MIPMAP_LINEAR

OpenGLTokens

GL_NEAREST_MIPMAP_NEAREST

OpenGLTokens

GL_NEVER

OpenGLTokens

GL_NICEST

OpenGLTokens

GL_NONE

OpenGLTokens

GL_NOOP

OpenGLTokens

GL_NOR

OpenGLTokens

GL_NORMALIZE

OpenGLTokens

GL_NORMAL_ARRAY

OpenGLTokens

GL_NORMAL_ARRAY_ADDRESS_NV

OpenGLTokens

GL_NORMAL_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_NORMAL_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_NORMAL_ARRAY_LENGTH_NV

OpenGLTokens

GL_NORMAL_ARRAY_POINTER

OpenGLTokens

GL_NORMAL_ARRAY_STRIDE

OpenGLTokens

GL_NORMAL_ARRAY_TYPE

OpenGLTokens

GL_NORMAL_MAP

OpenGLTokens

GL_NORMAL_MAP_ARB

OpenGLTokens

GL_NORMAL_MAP_EXT

OpenGLTokens

GL_NORMAL_MAP_NV

OpenGLTokens

GL_NOTEQUAL

OpenGLTokens

GL_NO_ERROR

OpenGLTokens

GL_NO_RESET_NOTIFICATION_ARB

OpenGLTokens

GL_NUM_COMPATIBLE_SUBROUTINES

OpenGLTokens

GL_NUM_COMPRESSED_TEXTURE_FORMATS

OpenGLTokens

GL_NUM_COMPRESSED_TEXTURE_FORMATS_ARB

OpenGLTokens

GL_NUM_EXTENSIONS

OpenGLTokens

GL_NUM_GENERAL_COMBINERS_NV

OpenGLTokens

GL_NUM_PROGRAM_BINARY_FORMATS

OpenGLTokens

GL_NUM_SHADER_BINARY_FORMATS

OpenGLTokens

GL_NV_blend_square

OpenGL1x

GL_NV_conditional_render

OpenGL1x

GL_NV_copy_image

OpenGL1x

GL_NV_depth_buffer_float

OpenGL1x

GL_NV_fence

OpenGL1x

GL_NV_float_buffer

OpenGL1x

GL_NV_fog_distance

OpenGL1x

GL_NV_geometry_program4

OpenGL1x

GL_NV_light_max_exponent

OpenGL1x

GL_NV_multisample_filter_hint

OpenGL1x

GL_NV_occlusion_query

OpenGL1x

GL_NV_point_sprite

OpenGL1x

GL_NV_primitive_restart

OpenGL1x

GL_NV_register_combiners

OpenGL1x

GL_NV_shader_buffer_load

OpenGL1x

GL_NV_texgen_reflection

OpenGL1x

GL_NV_texture_compression_vtc

OpenGL1x

GL_NV_texture_env_combine4

OpenGL1x

GL_NV_texture_rectangle

OpenGL1x

GL_NV_texture_shader

OpenGL1x

GL_NV_texture_shader2

OpenGL1x

GL_NV_texture_shader3

OpenGL1x

GL_NV_transform_feedback

OpenGL1x

GL_NV_vertex_array_range

OpenGL1x

GL_NV_vertex_array_range2

OpenGL1x

GL_NV_vertex_buffer_unified_memory

OpenGL1x

GL_NV_vertex_program

OpenGL1x

GL_OBJECT_ACTIVE_ATTRIBUTES_ARB

OpenGLTokens

GL_OBJECT_ACTIVE_ATTRIBUTE_MAX_LENGTH_ARB

OpenGLTokens

GL_OBJECT_ACTIVE_UNIFORMS_ARB

OpenGLTokens

GL_OBJECT_ACTIVE_UNIFORM_MAX_LENGTH_ARB

OpenGLTokens

GL_OBJECT_ATTACHED_OBJECTS_ARB

OpenGLTokens

GL_OBJECT_COMPILE_STATUS_ARB

OpenGLTokens

GL_OBJECT_DELETE_STATUS_ARB

OpenGLTokens

GL_OBJECT_INFO_LOG_LENGTH_ARB

OpenGLTokens

GL_OBJECT_LINEAR

OpenGLTokens

GL_OBJECT_LINK_STATUS_ARB

OpenGLTokens

GL_OBJECT_PLANE

OpenGLTokens

GL_OBJECT_SHADER_SOURCE_LENGTH_ARB

OpenGLTokens

GL_OBJECT_SUBTYPE_ARB

OpenGLTokens

GL_OBJECT_TYPE

OpenGLTokens

GL_OBJECT_TYPE_ARB

OpenGLTokens

GL_OBJECT_VALIDATE_STATUS_ARB

OpenGLTokens

GL_OCCLUSION_TEST_HP

OpenGLTokens

GL_OCCLUSION_TEST_RESULT_HP

OpenGLTokens

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_2D_NV

OpenGLTokens

GL_OFFSET_HILO_PROJECTIVE_TEXTURE_RECTANGLE_NV

OpenGLTokens

GL_OFFSET_HILO_TEXTURE_2D_NV

OpenGLTokens

GL_OFFSET_HILO_TEXTURE_RECTANGLE_NV

OpenGLTokens

GL_OFFSET_PROJECTIVE_TEXTURE_2D_NV

OpenGLTokens

GL_OFFSET_PROJECTIVE_TEXTURE_2D_SCALE_NV

OpenGLTokens

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_NV

OpenGLTokens

GL_OFFSET_PROJECTIVE_TEXTURE_RECTANGLE_SCALE_NV

OpenGLTokens

GL_OFFSET_TEXTURE_2D_BIAS_NV

OpenGLTokens

GL_OFFSET_TEXTURE_2D_MATRIX_NV

OpenGLTokens

GL_OFFSET_TEXTURE_2D_NV

OpenGLTokens

GL_OFFSET_TEXTURE_2D_SCALE_NV

OpenGLTokens

GL_OFFSET_TEXTURE_BIAS_NV

OpenGLTokens

GL_OFFSET_TEXTURE_MATRIX_NV

OpenGLTokens

GL_OFFSET_TEXTURE_RECTANGLE_NV

OpenGLTokens

GL_OFFSET_TEXTURE_RECTANGLE_SCALE_NV

OpenGLTokens

GL_OFFSET_TEXTURE_SCALE_NV

OpenGLTokens

GL_ONE

OpenGLTokens

GL_ONE_MINUS_CONSTANT_ALPHA

OpenGLTokens

GL_ONE_MINUS_CONSTANT_ALPHA_EXT

OpenGLTokens

GL_ONE_MINUS_CONSTANT_COLOR

OpenGLTokens

GL_ONE_MINUS_CONSTANT_COLOR_EXT

OpenGLTokens

GL_ONE_MINUS_DST_ALPHA

OpenGLTokens

GL_ONE_MINUS_DST_COLOR

OpenGLTokens

GL_ONE_MINUS_SRC1_ALPHA

OpenGLTokens

GL_ONE_MINUS_SRC1_COLOR

OpenGLTokens

GL_ONE_MINUS_SRC_ALPHA

OpenGLTokens

GL_ONE_MINUS_SRC_COLOR

OpenGLTokens

GL_OPERAND0_ALPHA

OpenGLTokens

GL_OPERAND0_ALPHA_ARB

OpenGLTokens

GL_OPERAND0_ALPHA_EXT

OpenGLTokens

GL_OPERAND0_RGB

OpenGLTokens

GL_OPERAND0_RGB_ARB

OpenGLTokens

GL_OPERAND0_RGB_EXT

OpenGLTokens

GL_OPERAND1_ALPHA

OpenGLTokens

GL_OPERAND1_ALPHA_ARB

OpenGLTokens

GL_OPERAND1_ALPHA_EXT

OpenGLTokens

GL_OPERAND1_RGB

OpenGLTokens

GL_OPERAND1_RGB_ARB

OpenGLTokens

GL_OPERAND1_RGB_EXT

OpenGLTokens

GL_OPERAND2_ALPHA

OpenGLTokens

GL_OPERAND2_ALPHA_ARB

OpenGLTokens

GL_OPERAND2_ALPHA_EXT

OpenGLTokens

GL_OPERAND2_RGB

OpenGLTokens

GL_OPERAND2_RGB_ARB

OpenGLTokens

GL_OPERAND2_RGB_EXT

OpenGLTokens

GL_OPERAND3_ALPHA_EXT

OpenGLTokens

GL_OPERAND3_ALPHA_NV

OpenGLTokens

GL_OPERAND3_RGB_EXT

OpenGLTokens

GL_OPERAND3_RGB_NV

OpenGLTokens

GL_OPERAND4_ALPHA_EXT

OpenGLTokens

GL_OPERAND4_RGB_EXT

OpenGLTokens

GL_OPERAND5_ALPHA_EXT

OpenGLTokens

GL_OPERAND5_RGB_EXT

OpenGLTokens

GL_OPERAND6_ALPHA_EXT

OpenGLTokens

GL_OPERAND6_RGB_EXT

OpenGLTokens

GL_OPERAND7_ALPHA_EXT

OpenGLTokens

GL_OPERAND7_RGB_EXT

OpenGLTokens

GL_OR

OpenGLTokens

GL_ORDER

OpenGLTokens

GL_OR_INVERTED

OpenGLTokens

GL_OR_REVERSE

OpenGLTokens

GL_OUT_OF_MEMORY

OpenGLTokens

GL_PACK_ALIGNMENT

OpenGLTokens

GL_PACK_IMAGE_HEIGHT

OpenGLTokens

GL_PACK_IMAGE_HEIGHT_EXT

OpenGLTokens

GL_PACK_LSB_FIRST

OpenGLTokens

GL_PACK_ROW_LENGTH

OpenGLTokens

GL_PACK_SKIP_IMAGES

OpenGLTokens

GL_PACK_SKIP_IMAGES_EXT

OpenGLTokens

GL_PACK_SKIP_PIXELS

OpenGLTokens

GL_PACK_SKIP_ROWS

OpenGLTokens

GL_PACK_SWAP_BYTES

OpenGLTokens

GL_PASS_THROUGH_NV

OpenGLTokens

GL_PASS_THROUGH_TOKEN

OpenGLTokens

GL_PATCHES

OpenGLTokens

GL_PATCH_DEFAULT_INNER_LEVEL

OpenGLTokens

GL_PATCH_DEFAULT_OUTER_LEVEL

OpenGLTokens

GL_PATCH_VERTICES

OpenGLTokens

GL_PATH_CLIENT_LENGTH_NV

OpenGLTokens

GL_PATH_COMMAND_COUNT_NV

OpenGLTokens

GL_PATH_COMPUTED_LENGTH_NV

OpenGLTokens

GL_PATH_COORD_COUNT_NV

OpenGLTokens

GL_PATH_COVER_DEPTH_FUNC_NV

OpenGLTokens

GL_PATH_DASH_ARRAY_COUNT_NV

OpenGLTokens

GL_PATH_DASH_CAPS_NV

OpenGLTokens

GL_PATH_DASH_OFFSET_NV

OpenGLTokens

GL_PATH_DASH_OFFSET_RESET_NV

OpenGLTokens

GL_PATH_END_CAPS_NV

OpenGLTokens

GL_PATH_ERROR_POSITION_NV

OpenGLTokens

GL_PATH_FILL_BOUNDING_BOX_NV

OpenGLTokens

GL_PATH_FILL_COVER_MODE_NV

OpenGLTokens

GL_PATH_FILL_MASK_NV

OpenGLTokens

GL_PATH_FILL_MODE_NV

OpenGLTokens

GL_PATH_FOG_GEN_MODE_NV

OpenGLTokens

GL_PATH_FORMAT_PS_NV

OpenGLTokens

GL_PATH_FORMAT_SVG_NV

OpenGLTokens

GL_PATH_GEN_COEFF_NV

OpenGLTokens

GL_PATH_GEN_COLOR_FORMAT_NV

OpenGLTokens

GL_PATH_GEN_COMPONENTS_NV

OpenGLTokens

GL_PATH_GEN_MODE_NV

OpenGLTokens

GL_PATH_INITIAL_DASH_CAP_NV

OpenGLTokens

GL_PATH_INITIAL_END_CAP_NV

OpenGLTokens

GL_PATH_JOIN_STYLE_NV

OpenGLTokens

GL_PATH_MITER_LIMIT_NV

OpenGLTokens

GL_PATH_OBJECT_BOUNDING_BOX_NV

OpenGLTokens

GL_PATH_SAMPLE_QUALITY_NV

OpenGLTokens

GL_PATH_STENCIL_DEPTH_OFFSET_FACTOR_NV

OpenGLTokens

GL_PATH_STENCIL_DEPTH_OFFSET_UNITS_NV

OpenGLTokens

GL_PATH_STENCIL_FUNC_NV

OpenGLTokens

GL_PATH_STENCIL_REF_NV

OpenGLTokens

GL_PATH_STENCIL_VALUE_MASK_NV

OpenGLTokens

GL_PATH_STROKE_BOUNDING_BOX_NV

OpenGLTokens

GL_PATH_STROKE_COVER_MODE_NV

OpenGLTokens

GL_PATH_STROKE_MASK_NV

OpenGLTokens

GL_PATH_STROKE_WIDTH_NV

OpenGLTokens

GL_PATH_TERMINAL_DASH_CAP_NV

OpenGLTokens

GL_PATH_TERMINAL_END_CAP_NV

OpenGLTokens

GL_PERSPECTIVE_CORRECTION_HINT

OpenGLTokens

GL_PIXEL_COUNTER_BITS_NV

OpenGLTokens

GL_PIXEL_COUNT_AVAILABLE_NV

OpenGLTokens

GL_PIXEL_COUNT_NV

OpenGLTokens

GL_PIXEL_MAP_A_TO_A

OpenGLTokens

GL_PIXEL_MAP_A_TO_A_SIZE

OpenGLTokens

GL_PIXEL_MAP_B_TO_B

OpenGLTokens

GL_PIXEL_MAP_B_TO_B_SIZE

OpenGLTokens

GL_PIXEL_MAP_G_TO_G

OpenGLTokens

GL_PIXEL_MAP_G_TO_G_SIZE

OpenGLTokens

GL_PIXEL_MAP_I_TO_A

OpenGLTokens

GL_PIXEL_MAP_I_TO_A_SIZE

OpenGLTokens

GL_PIXEL_MAP_I_TO_B

OpenGLTokens

GL_PIXEL_MAP_I_TO_B_SIZE

OpenGLTokens

GL_PIXEL_MAP_I_TO_G

OpenGLTokens

GL_PIXEL_MAP_I_TO_G_SIZE

OpenGLTokens

GL_PIXEL_MAP_I_TO_I

OpenGLTokens

GL_PIXEL_MAP_I_TO_I_SIZE

OpenGLTokens

GL_PIXEL_MAP_I_TO_R

OpenGLTokens

GL_PIXEL_MAP_I_TO_R_SIZE

OpenGLTokens

GL_PIXEL_MAP_R_TO_R

OpenGLTokens

GL_PIXEL_MAP_R_TO_R_SIZE

OpenGLTokens

GL_PIXEL_MAP_S_TO_S

OpenGLTokens

GL_PIXEL_MAP_S_TO_S_SIZE

OpenGLTokens

GL_PIXEL_MODE_BIT

OpenGLTokens

GL_PIXEL_PACK_BUFFER

OpenGLTokens

GL_PIXEL_PACK_BUFFER_ARB

OpenGLTokens

GL_PIXEL_PACK_BUFFER_BINDING

OpenGLTokens

GL_PIXEL_PACK_BUFFER_BINDING_ARB

OpenGLTokens

GL_PIXEL_PACK_BUFFER_BINDING_EXT

OpenGLTokens

GL_PIXEL_PACK_BUFFER_EXT

OpenGLTokens

GL_PIXEL_UNPACK_BUFFER

OpenGLTokens

GL_PIXEL_UNPACK_BUFFER_ARB

OpenGLTokens

GL_PIXEL_UNPACK_BUFFER_BINDING

OpenGLTokens

GL_PIXEL_UNPACK_BUFFER_BINDING_ARB

OpenGLTokens

GL_PIXEL_UNPACK_BUFFER_BINDING_EXT

OpenGLTokens

GL_PIXEL_UNPACK_BUFFER_EXT

OpenGLTokens

GL_POINT

OpenGLTokens

GL_POINTS

OpenGLTokens

GL_POINT_BIT

OpenGLTokens

GL_POINT_DISTANCE_ATTENUATION

OpenGLTokens

GL_POINT_FADE_THRESHOLD_SIZE

OpenGLTokens

GL_POINT_FADE_THRESHOLD_SIZE_ARB

OpenGLTokens

GL_POINT_SIZE

OpenGLTokens

GL_POINT_SIZE_GRANULARITY

OpenGLTokens

GL_POINT_SIZE_MAX

OpenGLTokens

GL_POINT_SIZE_MAX_ARB

OpenGLTokens

GL_POINT_SIZE_MIN

OpenGLTokens

GL_POINT_SIZE_MIN_ARB

OpenGLTokens

GL_POINT_SIZE_RANGE

OpenGLTokens

GL_POINT_SMOOTH

OpenGLTokens

GL_POINT_SMOOTH_HINT

OpenGLTokens

GL_POINT_SPRITE

OpenGLTokens

GL_POINT_SPRITE_ARB

OpenGLTokens

GL_POINT_SPRITE_COORD_ORIGIN

OpenGLTokens

GL_POINT_SPRITE_NV

OpenGLTokens

GL_POINT_SPRITE_R_MODE_NV

OpenGLTokens

GL_POINT_TOKEN

OpenGLTokens

GL_POLYGON

OpenGLTokens

GL_POLYGON_BIT

OpenGLTokens

GL_POLYGON_MODE

OpenGLTokens

GL_POLYGON_OFFSET_BIAS_EXT

OpenGLTokens

GL_POLYGON_OFFSET_EXT

OpenGLTokens

GL_POLYGON_OFFSET_FACTOR

OpenGLTokens

GL_POLYGON_OFFSET_FACTOR_EXT

OpenGLTokens

GL_POLYGON_OFFSET_FILL

OpenGLTokens

GL_POLYGON_OFFSET_LINE

OpenGLTokens

GL_POLYGON_OFFSET_POINT

OpenGLTokens

GL_POLYGON_OFFSET_UNITS

OpenGLTokens

GL_POLYGON_SMOOTH

OpenGLTokens

GL_POLYGON_SMOOTH_HINT

OpenGLTokens

GL_POLYGON_STIPPLE

OpenGLTokens

GL_POLYGON_STIPPLE_BIT

OpenGLTokens

GL_POLYGON_TOKEN

OpenGLTokens

GL_POSITION

OpenGLTokens

GL_POST_COLOR_MATRIX_ALPHA_BIAS

OpenGLTokens

GL_POST_COLOR_MATRIX_ALPHA_BIAS_SGI

OpenGLTokens

GL_POST_COLOR_MATRIX_ALPHA_SCALE

OpenGLTokens

GL_POST_COLOR_MATRIX_ALPHA_SCALE_SGI

OpenGLTokens

GL_POST_COLOR_MATRIX_BLUE_BIAS

OpenGLTokens

GL_POST_COLOR_MATRIX_BLUE_BIAS_SGI

OpenGLTokens

GL_POST_COLOR_MATRIX_BLUE_SCALE

OpenGLTokens

GL_POST_COLOR_MATRIX_BLUE_SCALE_SGI

OpenGLTokens

GL_POST_COLOR_MATRIX_COLOR_TABLE

OpenGLTokens

GL_POST_COLOR_MATRIX_GREEN_BIAS

OpenGLTokens

GL_POST_COLOR_MATRIX_GREEN_BIAS_SGI

OpenGLTokens

GL_POST_COLOR_MATRIX_GREEN_SCALE

OpenGLTokens

GL_POST_COLOR_MATRIX_GREEN_SCALE_SGI

OpenGLTokens

GL_POST_COLOR_MATRIX_RED_BIAS

OpenGLTokens

GL_POST_COLOR_MATRIX_RED_BIAS_SGI

OpenGLTokens

GL_POST_COLOR_MATRIX_RED_SCALE

OpenGLTokens

GL_POST_COLOR_MATRIX_RED_SCALE_SGI

OpenGLTokens

GL_POST_CONVOLUTION_ALPHA_BIAS

OpenGLTokens

GL_POST_CONVOLUTION_ALPHA_BIAS_EXT

OpenGLTokens

GL_POST_CONVOLUTION_ALPHA_SCALE

OpenGLTokens

GL_POST_CONVOLUTION_ALPHA_SCALE_EXT

OpenGLTokens

GL_POST_CONVOLUTION_BLUE_BIAS

OpenGLTokens

GL_POST_CONVOLUTION_BLUE_BIAS_EXT

OpenGLTokens

GL_POST_CONVOLUTION_BLUE_SCALE

OpenGLTokens

GL_POST_CONVOLUTION_BLUE_SCALE_EXT

OpenGLTokens

GL_POST_CONVOLUTION_COLOR_TABLE

OpenGLTokens

GL_POST_CONVOLUTION_GREEN_BIAS

OpenGLTokens

GL_POST_CONVOLUTION_GREEN_BIAS_EXT

OpenGLTokens

GL_POST_CONVOLUTION_GREEN_SCALE

OpenGLTokens

GL_POST_CONVOLUTION_GREEN_SCALE_EXT

OpenGLTokens

GL_POST_CONVOLUTION_RED_BIAS

OpenGLTokens

GL_POST_CONVOLUTION_RED_BIAS_EXT

OpenGLTokens

GL_POST_CONVOLUTION_RED_SCALE

OpenGLTokens

GL_POST_CONVOLUTION_RED_SCALE_EXT

OpenGLTokens

GL_PREVIOUS

OpenGLTokens

GL_PREVIOUS_ARB

OpenGLTokens

GL_PREVIOUS_EXT

OpenGLTokens

GL_PREVIOUS_TEXTURE_INPUT_NV

OpenGLTokens

GL_PRIMARY_COLOR

OpenGLTokens

GL_PRIMARY_COLOR_ARB

OpenGLTokens

GL_PRIMARY_COLOR_EXT

OpenGLTokens

GL_PRIMARY_COLOR_NV

OpenGLTokens

GL_PRIMITIVES_GENERATED

OpenGLTokens

GL_PRIMITIVES_GENERATED_EXT

OpenGLTokens

GL_PRIMITIVES_GENERATED_NV

OpenGLTokens

GL_PRIMITIVE_ID_NV

OpenGLTokens

GL_PRIMITIVE_RESTART

OpenGLTokens

GL_PRIMITIVE_RESTART_INDEX

OpenGLTokens

GL_PRIMITIVE_RESTART_INDEX_NV

OpenGLTokens

GL_PRIMITIVE_RESTART_NV

OpenGLTokens

GL_PROGRAM_ADDRESS_REGISTERS_ARB

OpenGLTokens

GL_PROGRAM_ALU_INSTRUCTIONS_ARB

OpenGLTokens

GL_PROGRAM_ATTRIBS_ARB

OpenGLTokens

GL_PROGRAM_BINARY_FORMATS

OpenGLTokens

GL_PROGRAM_BINARY_LENGTH

OpenGLTokens

GL_PROGRAM_BINARY_RETRIEVABLE_HINT

OpenGLTokens

GL_PROGRAM_BINDING_ARB

OpenGLTokens

GL_PROGRAM_ERROR_POSITION_ARB

OpenGLTokens

GL_PROGRAM_ERROR_POSITION_NV

OpenGLTokens

GL_PROGRAM_ERROR_STRING_ARB

OpenGLTokens

GL_PROGRAM_FORMAT_ARB

OpenGLTokens

GL_PROGRAM_FORMAT_ASCII_ARB

OpenGLTokens

GL_PROGRAM_INSTRUCTIONS_ARB

OpenGLTokens

GL_PROGRAM_LENGTH_ARB

OpenGLTokens

GL_PROGRAM_LENGTH_NV

OpenGLTokens

GL_PROGRAM_NATIVE_ADDRESS_REGISTERS_ARB

OpenGLTokens

GL_PROGRAM_NATIVE_ALU_INSTRUCTIONS_ARB

OpenGLTokens

GL_PROGRAM_NATIVE_ATTRIBS_ARB

OpenGLTokens

GL_PROGRAM_NATIVE_INSTRUCTIONS_ARB

OpenGLTokens

GL_PROGRAM_NATIVE_PARAMETERS_ARB

OpenGLTokens

GL_PROGRAM_NATIVE_TEMPORARIES_ARB

OpenGLTokens

GL_PROGRAM_NATIVE_TEX_INDIRECTIONS_ARB

OpenGLTokens

GL_PROGRAM_NATIVE_TEX_INSTRUCTIONS_ARB

OpenGLTokens

GL_PROGRAM_OBJECT_ARB

OpenGLTokens

GL_PROGRAM_PARAMETERS_ARB

OpenGLTokens

GL_PROGRAM_PARAMETER_NV

OpenGLTokens

GL_PROGRAM_PIPELINE_BINDING

OpenGLTokens

GL_PROGRAM_POINT_SIZE

OpenGLTokens

GL_PROGRAM_POINT_SIZE_ARB

OpenGLTokens

GL_PROGRAM_POINT_SIZE_EXT

OpenGLTokens

GL_PROGRAM_RESIDENT_NV

OpenGLTokens

GL_PROGRAM_SEPARABLE

OpenGLTokens

GL_PROGRAM_STRING_ARB

OpenGLTokens

GL_PROGRAM_STRING_NV

OpenGLTokens

GL_PROGRAM_TARGET_NV

OpenGLTokens

GL_PROGRAM_TEMPORARIES_ARB

OpenGLTokens

GL_PROGRAM_TEX_INDIRECTIONS_ARB

OpenGLTokens

GL_PROGRAM_TEX_INSTRUCTIONS_ARB

OpenGLTokens

GL_PROGRAM_UNDER_NATIVE_LIMITS_ARB

OpenGLTokens

GL_PROJECTION

OpenGLTokens

GL_PROJECTION_MATRIX

OpenGLTokens

GL_PROJECTION_STACK_DEPTH

OpenGLTokens

GL_PROVOKING_VERTEX

OpenGLTokens

GL_PROXY_COLOR_TABLE

OpenGLTokens

GL_PROXY_HISTOGRAM

OpenGLTokens

GL_PROXY_HISTOGRAM_EXT

OpenGLTokens

GL_PROXY_POST_COLOR_MATRIX_COLOR_TABLE

OpenGLTokens

GL_PROXY_POST_CONVOLUTION_COLOR_TABLE

OpenGLTokens

GL_PROXY_TEXTURE_1D

OpenGLTokens

GL_PROXY_TEXTURE_1D_ARRAY

OpenGLTokens

GL_PROXY_TEXTURE_1D_ARRAY_EXT

OpenGLTokens

GL_PROXY_TEXTURE_1D_EXT

OpenGLTokens

GL_PROXY_TEXTURE_2D

OpenGLTokens

GL_PROXY_TEXTURE_2D_ARRAY

OpenGLTokens

GL_PROXY_TEXTURE_2D_ARRAY_EXT

OpenGLTokens

GL_PROXY_TEXTURE_2D_EXT

OpenGLTokens

GL_PROXY_TEXTURE_2D_MULTISAMPLE

OpenGLTokens

GL_PROXY_TEXTURE_2D_MULTISAMPLE_ARRAY

OpenGLTokens

GL_PROXY_TEXTURE_3D

OpenGLTokens

GL_PROXY_TEXTURE_3D_EXT

OpenGLTokens

GL_PROXY_TEXTURE_CUBE_MAP

OpenGLTokens

GL_PROXY_TEXTURE_CUBE_MAP_ARB

OpenGLTokens

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY

OpenGLTokens

GL_PROXY_TEXTURE_CUBE_MAP_ARRAY_ARB

OpenGLTokens

GL_PROXY_TEXTURE_CUBE_MAP_EXT

OpenGLTokens

GL_PROXY_TEXTURE_RECTANGLE

OpenGLTokens

GL_PROXY_TEXTURE_RECTANGLE_ARB

OpenGLTokens

GL_PROXY_TEXTURE_RECTANGLE_EXT

OpenGLTokens

GL_PROXY_TEXTURE_RECTANGLE_NV

OpenGLTokens

GL_Q

OpenGLTokens

GL_QUADRATIC_ATTENUATION

OpenGLTokens

GL_QUADRATIC_CURVE_TO_NV

OpenGLTokens

GL_QUADS

OpenGLTokens

GL_QUADS_FOLLOW_PROVOKING_VERTEX_CONVENTION

OpenGLTokens

GL_QUAD_STRIP

OpenGLTokens

GL_QUERY_BY_REGION_NO_WAIT

OpenGLTokens

GL_QUERY_BY_REGION_NO_WAIT_NV

OpenGLTokens

GL_QUERY_BY_REGION_WAIT

OpenGLTokens

GL_QUERY_BY_REGION_WAIT_NV

OpenGLTokens

GL_QUERY_COUNTER_BITS

OpenGLTokens

GL_QUERY_COUNTER_BITS_ARB

OpenGLTokens

GL_QUERY_NO_WAIT

OpenGLTokens

GL_QUERY_NO_WAIT_NV

OpenGLTokens

GL_QUERY_RESULT

OpenGLTokens

GL_QUERY_RESULT_ARB

OpenGLTokens

GL_QUERY_RESULT_AVAILABLE

OpenGLTokens

GL_QUERY_RESULT_AVAILABLE_ARB

OpenGLTokens

GL_QUERY_WAIT

OpenGLTokens

GL_QUERY_WAIT_NV

OpenGLTokens

GL_R

OpenGLTokens

GL_R11F_G11F_B10F

OpenGLTokens

GL_R11F_G11F_B10F_EXT

OpenGLTokens

GL_R16

OpenGLTokens

GL_R16F

OpenGLTokens

GL_R16I

OpenGLTokens

GL_R16UI

OpenGLTokens

GL_R16_SNORM

OpenGLTokens

GL_R32F

OpenGLTokens

GL_R32I

OpenGLTokens

GL_R32UI

OpenGLTokens

GL_R3_G3_B2

OpenGLTokens

GL_R8

OpenGLTokens

GL_R8I

OpenGLTokens

GL_R8UI

OpenGLTokens

GL_R8_SNORM

OpenGLTokens

GL_RASTERIZER_DISCARD

OpenGLTokens

GL_RASTERIZER_DISCARD_EXT

OpenGLTokens

GL_RASTERIZER_DISCARD_NV

OpenGLTokens

GL_RASTER_POSITION_UNCLIPPED_IBM

OpenGLTokens

GL_READ_BUFFER

OpenGLTokens

GL_READ_FRAMEBUFFER

OpenGLTokens

GL_READ_FRAMEBUFFER_BINDING

OpenGLTokens

GL_READ_FRAMEBUFFER_BINDING_EXT

OpenGLTokens

GL_READ_FRAMEBUFFER_EXT

OpenGLTokens

GL_READ_ONLY

OpenGLTokens

GL_READ_ONLY_ARB

OpenGLTokens

GL_READ_WRITE

OpenGLTokens

GL_READ_WRITE_ARB

OpenGLTokens

GL_RED

OpenGLTokens

GL_REDUCE

OpenGLTokens

GL_REDUCE_EXT

OpenGLTokens

GL_RED_BIAS

OpenGLTokens

GL_RED_BITS

OpenGLTokens

GL_RED_INTEGER

OpenGLTokens

GL_RED_INTEGER_EXT

OpenGLTokens

GL_RED_SCALE

OpenGLTokens

GL_RED_SNORM

OpenGLTokens

GL_REFLECTION_MAP

OpenGLTokens

GL_REFLECTION_MAP_ARB

OpenGLTokens

GL_REFLECTION_MAP_EXT

OpenGLTokens

GL_REFLECTION_MAP_NV

OpenGLTokens

GL_REGISTER_COMBINERS_NV

OpenGLTokens

GL_RELATIVE_ARC_TO_NV

OpenGLTokens

GL_RELATIVE_CUBIC_CURVE_TO_NV

OpenGLTokens

GL_RELATIVE_HORIZONTAL_LINE_TO_NV

OpenGLTokens

GL_RELATIVE_LARGE_CCW_ARC_TO_NV

OpenGLTokens

GL_RELATIVE_LARGE_CW_ARC_TO_NV

OpenGLTokens

GL_RELATIVE_LINE_TO_NV

OpenGLTokens

GL_RELATIVE_MOVE_TO_NV

OpenGLTokens

GL_RELATIVE_QUADRATIC_CURVE_TO_NV

OpenGLTokens

GL_RELATIVE_SMALL_CCW_ARC_TO_NV

OpenGLTokens

GL_RELATIVE_SMALL_CW_ARC_TO_NV

OpenGLTokens

GL_RELATIVE_SMOOTH_CUBIC_CURVE_TO_NV

OpenGLTokens

GL_RELATIVE_SMOOTH_QUADRATIC_CURVE_TO_NV

OpenGLTokens

GL_RELATIVE_VERTICAL_LINE_TO_NV

OpenGLTokens

GL_RENDER

OpenGLTokens

GL_RENDERBUFFER

OpenGLTokens

GL_RENDERBUFFER_ALPHA_SIZE

OpenGLTokens

GL_RENDERBUFFER_ALPHA_SIZE_EXT

OpenGLTokens

GL_RENDERBUFFER_BINDING

OpenGLTokens

GL_RENDERBUFFER_BINDING_EXT

OpenGLTokens

GL_RENDERBUFFER_BLUE_SIZE

OpenGLTokens

GL_RENDERBUFFER_BLUE_SIZE_EXT

OpenGLTokens

GL_RENDERBUFFER_DEPTH_SIZE

OpenGLTokens

GL_RENDERBUFFER_DEPTH_SIZE_EXT

OpenGLTokens

GL_RENDERBUFFER_EXT

OpenGLTokens

GL_RENDERBUFFER_FREE_MEMORY_ATI

OpenGLTokens

GL_RENDERBUFFER_GREEN_SIZE

OpenGLTokens

GL_RENDERBUFFER_GREEN_SIZE_EXT

OpenGLTokens

GL_RENDERBUFFER_HEIGHT

OpenGLTokens

GL_RENDERBUFFER_HEIGHT_EXT

OpenGLTokens

GL_RENDERBUFFER_INTERNAL_FORMAT

OpenGLTokens

GL_RENDERBUFFER_INTERNAL_FORMAT_EXT

OpenGLTokens

GL_RENDERBUFFER_RED_SIZE

OpenGLTokens

GL_RENDERBUFFER_RED_SIZE_EXT

OpenGLTokens

GL_RENDERBUFFER_SAMPLES

OpenGLTokens

GL_RENDERBUFFER_SAMPLES_EXT

OpenGLTokens

GL_RENDERBUFFER_STENCIL_SIZE

OpenGLTokens

GL_RENDERBUFFER_STENCIL_SIZE_EXT

OpenGLTokens

GL_RENDERBUFFER_WIDTH

OpenGLTokens

GL_RENDERBUFFER_WIDTH_EXT

OpenGLTokens

GL_RENDERER

OpenGLTokens

GL_RENDER_MODE

OpenGLTokens

GL_REPEAT

OpenGLTokens

GL_REPLACE

OpenGLTokens

GL_REPLACE_EXT

OpenGLTokens

GL_REPLICATE_BORDER

OpenGLTokens

GL_RESCALE_NORMAL

OpenGLTokens

GL_RESCALE_NORMAL_EXT

OpenGLTokens

GL_RESET_NOTIFICATION_STRATEGY_ARB

OpenGLTokens

GL_RETURN

OpenGLTokens

GL_RG

OpenGLTokens

GL_RG16

OpenGLTokens

GL_RG16F

OpenGLTokens

GL_RG16I

OpenGLTokens

GL_RG16UI

OpenGLTokens

GL_RG16_SNORM

OpenGLTokens

GL_RG32F

OpenGLTokens

GL_RG32I

OpenGLTokens

GL_RG32UI

OpenGLTokens

GL_RG8

OpenGLTokens

GL_RG8I

OpenGLTokens

GL_RG8UI

OpenGLTokens

GL_RG8_SNORM

OpenGLTokens

GL_RGB

OpenGLTokens

GL_RGB10

OpenGLTokens

GL_RGB10_A2

OpenGLTokens

GL_RGB10_A2UI

OpenGLTokens

GL_RGB10_A2_EXT

OpenGLTokens

GL_RGB10_EXT

OpenGLTokens

GL_RGB12

OpenGLTokens

GL_RGB12_EXT

OpenGLTokens

GL_RGB16

OpenGLTokens

GL_RGB16F

OpenGLTokens

GL_RGB16F_ARB

OpenGLTokens

GL_RGB16I

OpenGLTokens

GL_RGB16I_EXT

OpenGLTokens

GL_RGB16UI

OpenGLTokens

GL_RGB16UI_EXT

OpenGLTokens

GL_RGB16_EXT

OpenGLTokens

GL_RGB16_SNORM

OpenGLTokens

GL_RGB2_EXT

OpenGLTokens

GL_RGB32F

OpenGLTokens

GL_RGB32F_ARB

OpenGLTokens

GL_RGB32I

OpenGLTokens

GL_RGB32I_EXT

OpenGLTokens

GL_RGB32UI

OpenGLTokens

GL_RGB32UI_EXT

OpenGLTokens

GL_RGB4

OpenGLTokens

GL_RGB4_EXT

OpenGLTokens

GL_RGB4_S3TC

OpenGLTokens

GL_RGB5

OpenGLTokens

GL_RGB5_A1

OpenGLTokens

GL_RGB5_A1_EXT

OpenGLTokens

GL_RGB5_EXT

OpenGLTokens

GL_RGB8

OpenGLTokens

GL_RGB8I

OpenGLTokens

GL_RGB8I_EXT

OpenGLTokens

GL_RGB8UI

OpenGLTokens

GL_RGB8UI_EXT

OpenGLTokens

GL_RGB8_EXT

OpenGLTokens

GL_RGB8_SNORM

OpenGLTokens

GL_RGB9_E5

OpenGLTokens

GL_RGB9_E5_EXT

OpenGLTokens

GL_RGBA

OpenGLTokens

GL_RGBA12

OpenGLTokens

GL_RGBA12_EXT

OpenGLTokens

GL_RGBA16

OpenGLTokens

GL_RGBA16F

OpenGLTokens

GL_RGBA16F_ARB

OpenGLTokens

GL_RGBA16I

OpenGLTokens

GL_RGBA16I_EXT

OpenGLTokens

GL_RGBA16UI

OpenGLTokens

GL_RGBA16UI_EXT

OpenGLTokens

GL_RGBA16_EXT

OpenGLTokens

GL_RGBA16_SNORM

OpenGLTokens

GL_RGBA2

OpenGLTokens

GL_RGBA2_EXT

OpenGLTokens

GL_RGBA32F

OpenGLTokens

GL_RGBA32F_ARB

OpenGLTokens

GL_RGBA32I

OpenGLTokens

GL_RGBA32I_EXT

OpenGLTokens

GL_RGBA32UI

OpenGLTokens

GL_RGBA32UI_EXT

OpenGLTokens

GL_RGBA4

OpenGLTokens

GL_RGBA4_DXT5_S3TC

OpenGLTokens

GL_RGBA4_EXT

OpenGLTokens

GL_RGBA4_S3TC

OpenGLTokens

GL_RGBA8

OpenGLTokens

GL_RGBA8I

OpenGLTokens

GL_RGBA8I_EXT

OpenGLTokens

GL_RGBA8UI

OpenGLTokens

GL_RGBA8UI_EXT

OpenGLTokens

GL_RGBA8_EXT

OpenGLTokens

GL_RGBA8_SNORM

OpenGLTokens

GL_RGBA_DXT5_S3TC

OpenGLTokens

GL_RGBA_FLOAT16_ATI

OpenGLTokens

GL_RGBA_FLOAT32_ATI

OpenGLTokens

GL_RGBA_FLOAT_MODE_ARB

OpenGLTokens

GL_RGBA_INTEGER

OpenGLTokens

GL_RGBA_INTEGER_EXT

OpenGLTokens

GL_RGBA_INTEGER_MODE_EXT

OpenGLTokens

GL_RGBA_MODE

OpenGLTokens

GL_RGBA_S3TC

OpenGLTokens

GL_RGBA_SIGNED_COMPONENTS_EXT

OpenGLTokens

GL_RGBA_SNORM

OpenGLTokens

GL_RGBA_UNSIGNED_DOT_PRODUCT_MAPPING_NV

OpenGLTokens

GL_RGB_FLOAT16_ATI

OpenGLTokens

GL_RGB_FLOAT32_ATI

OpenGLTokens

GL_RGB_INTEGER

OpenGLTokens

GL_RGB_INTEGER_EXT

OpenGLTokens

GL_RGB_S3TC

OpenGLTokens

GL_RGB_SCALE

OpenGLTokens

GL_RGB_SCALE_ARB

OpenGLTokens

GL_RGB_SCALE_EXT

OpenGLTokens

GL_RGB_SNORM

OpenGLTokens

GL_RG_INTEGER

OpenGLTokens

GL_RG_SNORM

OpenGLTokens

GL_RIGHT

OpenGLTokens

GL_ROUND_NV

OpenGLTokens

GL_S

OpenGLTokens

GL_S3_s3tc

OpenGL1x

GL_SAMPLER_1D

OpenGLTokens

GL_SAMPLER_1D_ARB

OpenGLTokens

GL_SAMPLER_1D_ARRAY

OpenGLTokens

GL_SAMPLER_1D_ARRAY_EXT

OpenGLTokens

GL_SAMPLER_1D_ARRAY_SHADOW

OpenGLTokens

GL_SAMPLER_1D_ARRAY_SHADOW_EXT

OpenGLTokens

GL_SAMPLER_1D_SHADOW

OpenGLTokens

GL_SAMPLER_1D_SHADOW_ARB

OpenGLTokens

GL_SAMPLER_2D

OpenGLTokens

GL_SAMPLER_2D_ARB

OpenGLTokens

GL_SAMPLER_2D_ARRAY

OpenGLTokens

GL_SAMPLER_2D_ARRAY_EXT

OpenGLTokens

GL_SAMPLER_2D_ARRAY_SHADOW

OpenGLTokens

GL_SAMPLER_2D_ARRAY_SHADOW_EXT

OpenGLTokens

GL_SAMPLER_2D_MULTISAMPLE

OpenGLTokens

GL_SAMPLER_2D_MULTISAMPLE_ARRAY

OpenGLTokens

GL_SAMPLER_2D_RECT

OpenGLTokens

GL_SAMPLER_2D_RECT_ARB

OpenGLTokens

GL_SAMPLER_2D_RECT_SHADOW

OpenGLTokens

GL_SAMPLER_2D_RECT_SHADOW_ARB

OpenGLTokens

GL_SAMPLER_2D_SHADOW

OpenGLTokens

GL_SAMPLER_2D_SHADOW_ARB

OpenGLTokens

GL_SAMPLER_3D

OpenGLTokens

GL_SAMPLER_3D_ARB

OpenGLTokens

GL_SAMPLER_BINDING

OpenGLTokens

GL_SAMPLER_BUFFER

OpenGLTokens

GL_SAMPLER_BUFFER_AMD

OpenGLTokens

GL_SAMPLER_BUFFER_EXT

OpenGLTokens

GL_SAMPLER_CUBE

OpenGLTokens

GL_SAMPLER_CUBE_ARB

OpenGLTokens

GL_SAMPLER_CUBE_MAP_ARRAY

OpenGLTokens

GL_SAMPLER_CUBE_MAP_ARRAY_ARB

OpenGLTokens

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW

OpenGLTokens

GL_SAMPLER_CUBE_MAP_ARRAY_SHADOW_ARB

OpenGLTokens

GL_SAMPLER_CUBE_SHADOW

OpenGLTokens

GL_SAMPLER_CUBE_SHADOW_EXT

OpenGLTokens

GL_SAMPLES

OpenGLTokens

GL_SAMPLES_3DFX

OpenGLTokens

GL_SAMPLES_ARB

OpenGLTokens

GL_SAMPLES_EXT

OpenGLTokens

GL_SAMPLES_PASSED

OpenGLTokens

GL_SAMPLES_PASSED_ARB

OpenGLTokens

GL_SAMPLES_SGIS

OpenGLTokens

GL_SAMPLE_ALPHA_TO_COVERAGE

OpenGLTokens

GL_SAMPLE_ALPHA_TO_COVERAGE_ARB

OpenGLTokens

GL_SAMPLE_ALPHA_TO_MASK_EXT

OpenGLTokens

GL_SAMPLE_ALPHA_TO_MASK_SGIS

OpenGLTokens

GL_SAMPLE_ALPHA_TO_ONE

OpenGLTokens

GL_SAMPLE_ALPHA_TO_ONE_ARB

OpenGLTokens

GL_SAMPLE_ALPHA_TO_ONE_EXT

OpenGLTokens

GL_SAMPLE_ALPHA_TO_ONE_SGIS

OpenGLTokens

GL_SAMPLE_BUFFERS

OpenGLTokens

GL_SAMPLE_BUFFERS_3DFX

OpenGLTokens

GL_SAMPLE_BUFFERS_ARB

OpenGLTokens

GL_SAMPLE_BUFFERS_EXT

OpenGLTokens

GL_SAMPLE_BUFFERS_SGIS

OpenGLTokens

GL_SAMPLE_COVERAGE

OpenGLTokens

GL_SAMPLE_COVERAGE_ARB

OpenGLTokens

GL_SAMPLE_COVERAGE_INVERT

OpenGLTokens

GL_SAMPLE_COVERAGE_INVERT_ARB

OpenGLTokens

GL_SAMPLE_COVERAGE_VALUE

OpenGLTokens

GL_SAMPLE_COVERAGE_VALUE_ARB

OpenGLTokens

GL_SAMPLE_MASK

OpenGLTokens

GL_SAMPLE_MASK_EXT

OpenGLTokens

GL_SAMPLE_MASK_INVERT_EXT

OpenGLTokens

GL_SAMPLE_MASK_INVERT_SGIS

OpenGLTokens

GL_SAMPLE_MASK_SGIS

OpenGLTokens

GL_SAMPLE_MASK_VALUE

OpenGLTokens

GL_SAMPLE_MASK_VALUE_EXT

OpenGLTokens

GL_SAMPLE_MASK_VALUE_SGIS

OpenGLTokens

GL_SAMPLE_PATTERN_EXT

OpenGLTokens

GL_SAMPLE_PATTERN_SGIS

OpenGLTokens

GL_SAMPLE_POSITION

OpenGLTokens

GL_SAMPLE_SHADING

OpenGLTokens

GL_SAMPLE_SHADING_ARB

OpenGLTokens

GL_SCALE_BY_FOUR_NV

OpenGLTokens

GL_SCALE_BY_ONE_HALF_NV

OpenGLTokens

GL_SCALE_BY_TWO_NV

OpenGLTokens

GL_SCISSOR_BIT

OpenGLTokens

GL_SCISSOR_BOX

OpenGLTokens

GL_SCISSOR_TEST

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_ADDRESS_NV

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_EXT

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_LENGTH_NV

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_POINTER

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_POINTER_EXT

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_SIZE

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_SIZE_EXT

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_STRIDE

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_STRIDE_EXT

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_TYPE

OpenGLTokens

GL_SECONDARY_COLOR_ARRAY_TYPE_EXT

OpenGLTokens

GL_SECONDARY_COLOR_NV

OpenGLTokens

GL_SELECT

OpenGLTokens

GL_SELECTION_BUFFER_POINTER

OpenGLTokens

GL_SELECTION_BUFFER_SIZE

OpenGLTokens

GL_SEPARABLE_2D

OpenGLTokens

GL_SEPARABLE_2D_EXT

OpenGLTokens

GL_SEPARATE_ATTRIBS

OpenGLTokens

GL_SEPARATE_ATTRIBS_EXT

OpenGLTokens

GL_SEPARATE_ATTRIBS_NV

OpenGLTokens

GL_SEPARATE_SPECULAR_COLOR

OpenGLTokens

GL_SEPARATE_SPECULAR_COLOR_EXT

OpenGLTokens

GL_SET

OpenGLTokens

GL_SGIS_generate_mipmap

OpenGL1x

GL_SGIS_multisample

OpenGL1x

GL_SGIS_texture_border_clamp

OpenGL1x

GL_SGIS_texture_color_mask

OpenGL1x

GL_SGIS_texture_edge_clamp

OpenGL1x

GL_SGIS_texture_lod

OpenGL1x

GL_SGIX_depth_texture

OpenGL1x

GL_SGIX_shadow

OpenGL1x

GL_SGIX_shadow_ambient

OpenGL1x

GL_SGI_color_matrix

OpenGL1x

GL_SHADER_COMPILER

OpenGLTokens

GL_SHADER_CONSISTENT_NV

OpenGLTokens

GL_SHADER_OBJECT_ARB

OpenGLTokens

GL_SHADER_OPERATION_NV

OpenGLTokens

GL_SHADER_SOURCE_LENGTH

OpenGLTokens

GL_SHADER_TYPE

OpenGLTokens

GL_SHADE_MODEL

OpenGLTokens

GL_SHADING_LANGUAGE_VERSION

OpenGLTokens

GL_SHADING_LANGUAGE_VERSION_ARB

OpenGLTokens

GL_SHADOW_AMBIENT_SGIX

OpenGLTokens

GL_SHARED_TEXTURE_PALETTE_EXT

OpenGLTokens

GL_SHININESS

OpenGLTokens

GL_SHORT

OpenGLTokens

GL_SIGNALED

OpenGLTokens

GL_SIGNED_ALPHA8_NV

OpenGLTokens

GL_SIGNED_ALPHA_NV

OpenGLTokens

GL_SIGNED_HILO16_NV

OpenGLTokens

GL_SIGNED_HILO8_NV

OpenGLTokens

GL_SIGNED_HILO_NV

OpenGLTokens

GL_SIGNED_IDENTITY_NV

OpenGLTokens

GL_SIGNED_INTENSITY8_NV

OpenGLTokens

GL_SIGNED_INTENSITY_NV

OpenGLTokens

GL_SIGNED_LUMINANCE8_ALPHA8_NV

OpenGLTokens

GL_SIGNED_LUMINANCE8_NV

OpenGLTokens

GL_SIGNED_LUMINANCE_ALPHA_NV

OpenGLTokens

GL_SIGNED_LUMINANCE_NV

OpenGLTokens

GL_SIGNED_NEGATE_NV

OpenGLTokens

GL_SIGNED_NORMALIZED

OpenGLTokens

GL_SIGNED_RGB8_NV

OpenGLTokens

GL_SIGNED_RGB8_UNSIGNED_ALPHA8_NV

OpenGLTokens

GL_SIGNED_RGBA8_NV

OpenGLTokens

GL_SIGNED_RGBA_NV

OpenGLTokens

GL_SIGNED_RGB_NV

OpenGLTokens

GL_SIGNED_RGB_UNSIGNED_ALPHA_NV

OpenGLTokens

GL_SINGLE_COLOR

OpenGLTokens

GL_SINGLE_COLOR_EXT

OpenGLTokens

GL_SKIP_DECODE_EXT

OpenGLTokens

GL_SKIP_MISSING_GLYPH_NV

OpenGLTokens

GL_SLUMINANCE

OpenGLTokens

GL_SLUMINANCE8

OpenGLTokens

GL_SLUMINANCE8_ALPHA8

OpenGLTokens

GL_SLUMINANCE8_ALPHA8_EXT

OpenGLTokens

GL_SLUMINANCE8_EXT

OpenGLTokens

GL_SLUMINANCE_ALPHA

OpenGLTokens

GL_SLUMINANCE_ALPHA_EXT

OpenGLTokens

GL_SLUMINANCE_EXT

OpenGLTokens

GL_SMALL_CCW_ARC_TO_NV

OpenGLTokens

GL_SMALL_CW_ARC_TO_NV

OpenGLTokens

GL_SMOOTH

OpenGLTokens

GL_SMOOTH_CUBIC_CURVE_TO_NV

OpenGLTokens

GL_SMOOTH_LINE_WIDTH_GRANULARITY

OpenGLTokens

GL_SMOOTH_LINE_WIDTH_RANGE

OpenGLTokens

GL_SMOOTH_POINT_SIZE_GRANULARITY

OpenGLTokens

GL_SMOOTH_POINT_SIZE_RANGE

OpenGLTokens

GL_SMOOTH_QUADRATIC_CURVE_TO_NV

OpenGLTokens

GL_SOURCE0_ALPHA

OpenGLTokens

GL_SOURCE0_ALPHA_ARB

OpenGLTokens

GL_SOURCE0_ALPHA_EXT

OpenGLTokens

GL_SOURCE0_RGB

OpenGLTokens

GL_SOURCE0_RGB_ARB

OpenGLTokens

GL_SOURCE0_RGB_EXT

OpenGLTokens

GL_SOURCE1_ALPHA

OpenGLTokens

GL_SOURCE1_ALPHA_ARB

OpenGLTokens

GL_SOURCE1_ALPHA_EXT

OpenGLTokens

GL_SOURCE1_RGB

OpenGLTokens

GL_SOURCE1_RGB_ARB

OpenGLTokens

GL_SOURCE1_RGB_EXT

OpenGLTokens

GL_SOURCE2_ALPHA

OpenGLTokens

GL_SOURCE2_ALPHA_ARB

OpenGLTokens

GL_SOURCE2_ALPHA_EXT

OpenGLTokens

GL_SOURCE2_RGB

OpenGLTokens

GL_SOURCE2_RGB_ARB

OpenGLTokens

GL_SOURCE2_RGB_EXT

OpenGLTokens

GL_SOURCE3_ALPHA_EXT

OpenGLTokens

GL_SOURCE3_ALPHA_NV

OpenGLTokens

GL_SOURCE3_RGB_EXT

OpenGLTokens

GL_SOURCE3_RGB_NV

OpenGLTokens

GL_SOURCE4_ALPHA_EXT

OpenGLTokens

GL_SOURCE4_RGB_EXT

OpenGLTokens

GL_SOURCE5_ALPHA_EXT

OpenGLTokens

GL_SOURCE5_RGB_EXT

OpenGLTokens

GL_SOURCE6_ALPHA_EXT

OpenGLTokens

GL_SOURCE6_RGB_EXT

OpenGLTokens

GL_SOURCE7_ALPHA_EXT

OpenGLTokens

GL_SOURCE7_RGB_EXT

OpenGLTokens

GL_SPARE0_NV

OpenGLTokens

GL_SPARE0_PLUS_SECONDARY_COLOR_NV

OpenGLTokens

GL_SPARE1_NV

OpenGLTokens

GL_SPECULAR

OpenGLTokens

GL_SPHERE_MAP

OpenGLTokens

GL_SPOT_CUTOFF

OpenGLTokens

GL_SPOT_DIRECTION

OpenGLTokens

GL_SPOT_EXPONENT

OpenGLTokens

GL_SQUARE_NV

OpenGLTokens

GL_SRC0_ALPHA

OpenGLTokens

GL_SRC0_RGB

OpenGLTokens

GL_SRC1_ALPHA

OpenGLTokens

GL_SRC1_COLOR

OpenGLTokens

GL_SRC1_RGB

OpenGLTokens

GL_SRC2_ALPHA

OpenGLTokens

GL_SRC2_RGB

OpenGLTokens

GL_SRC_ALPHA

OpenGLTokens

GL_SRC_ALPHA_SATURATE

OpenGLTokens

GL_SRC_COLOR

OpenGLTokens

GL_SRGB

OpenGLTokens

GL_SRGB8

OpenGLTokens

GL_SRGB8_ALPHA8

OpenGLTokens

GL_SRGB8_ALPHA8_EXT

OpenGLTokens

GL_SRGB8_EXT

OpenGLTokens

GL_SRGB_ALPHA

OpenGLTokens

GL_SRGB_ALPHA_EXT

OpenGLTokens

GL_SRGB_EXT

OpenGLTokens

GL_STACK_OVERFLOW

OpenGLTokens

GL_STACK_UNDERFLOW

OpenGLTokens

GL_STANDARD_FONT_NAME_NV

OpenGLTokens

GL_STATIC_COPY

OpenGLTokens

GL_STATIC_COPY_ARB

OpenGLTokens

GL_STATIC_DRAW

OpenGLTokens

GL_STATIC_DRAW_ARB

OpenGLTokens

GL_STATIC_READ

OpenGLTokens

GL_STATIC_READ_ARB

OpenGLTokens

GL_STENCIL

OpenGLTokens

GL_STENCIL_ATTACHMENT

OpenGLTokens

GL_STENCIL_ATTACHMENT_EXT

OpenGLTokens

GL_STENCIL_BACK_FAIL

OpenGLTokens

GL_STENCIL_BACK_FUNC

OpenGLTokens

GL_STENCIL_BACK_PASS_DEPTH_FAIL

OpenGLTokens

GL_STENCIL_BACK_PASS_DEPTH_PASS

OpenGLTokens

GL_STENCIL_BACK_REF

OpenGLTokens

GL_STENCIL_BACK_VALUE_MASK

OpenGLTokens

GL_STENCIL_BACK_WRITEMASK

OpenGLTokens

GL_STENCIL_BITS

OpenGLTokens

GL_STENCIL_BUFFER

OpenGLTokens

GL_STENCIL_BUFFER_BIT

OpenGLTokens

GL_STENCIL_CLEAR_TAG_VALUE_EXT

OpenGLTokens

GL_STENCIL_CLEAR_VALUE

OpenGLTokens

GL_STENCIL_FAIL

OpenGLTokens

GL_STENCIL_FUNC

OpenGLTokens

GL_STENCIL_INDEX

OpenGLTokens

GL_STENCIL_INDEX1

OpenGLTokens

GL_STENCIL_INDEX16

OpenGLTokens

GL_STENCIL_INDEX16_EXT

OpenGLTokens

GL_STENCIL_INDEX1_EXT

OpenGLTokens

GL_STENCIL_INDEX4

OpenGLTokens

GL_STENCIL_INDEX4_EXT

OpenGLTokens

GL_STENCIL_INDEX8

OpenGLTokens

GL_STENCIL_INDEX8_EXT

OpenGLTokens

GL_STENCIL_PASS_DEPTH_FAIL

OpenGLTokens

GL_STENCIL_PASS_DEPTH_PASS

OpenGLTokens

GL_STENCIL_REF

OpenGLTokens

GL_STENCIL_TAG_BITS_EXT

OpenGLTokens

GL_STENCIL_TEST

OpenGLTokens

GL_STENCIL_TEST_TWO_SIDE_EXT

OpenGLTokens

GL_STENCIL_VALUE_MASK

OpenGLTokens

GL_STENCIL_WRITEMASK

OpenGLTokens

GL_STEREO

OpenGLTokens

GL_STREAM_COPY

OpenGLTokens

GL_STREAM_COPY_ARB

OpenGLTokens

GL_STREAM_DRAW

OpenGLTokens

GL_STREAM_DRAW_ARB

OpenGLTokens

GL_STREAM_READ

OpenGLTokens

GL_STREAM_READ_ARB

OpenGLTokens

GL_SUBPIXEL_BITS

OpenGLTokens

GL_SUBTRACT

OpenGLTokens

GL_SUBTRACT_ARB

OpenGLTokens

GL_SURFACE_MAPPED_NV

OpenGLTokens

GL_SURFACE_REGISTERED_NV

OpenGLTokens

GL_SURFACE_STATE_NV

OpenGLTokens

GL_SYNC_CONDITION

OpenGLTokens

GL_SYNC_FENCE

OpenGLTokens

GL_SYNC_FLAGS

OpenGLTokens

GL_SYNC_FLUSH_COMMANDS_BIT

OpenGLTokens

GL_SYNC_GPU_COMMANDS_COMPLETE

OpenGLTokens

GL_SYNC_STATUS

OpenGLTokens

GL_SYSTEM_FONT_NAME_NV

OpenGLTokens

GL_T

OpenGLTokens

GL_T2F_C3F_V3F

OpenGLTokens

GL_T2F_C4F_N3F_V3F

OpenGLTokens

GL_T2F_C4UB_V3F

OpenGLTokens

GL_T2F_N3F_V3F

OpenGLTokens

GL_T2F_V3F

OpenGLTokens

GL_T4F_C4F_N3F_V4F

OpenGLTokens

GL_T4F_V4F

OpenGLTokens

GL_TABLE_TOO_LARGE

OpenGLTokens

GL_TESSELLATION_FACTOR_AMD

OpenGLTokens

GL_TESSELLATION_MODE_AMD

OpenGLTokens

GL_TESS_CONTROL_OUTPUT_VERTICES

OpenGLTokens

GL_TESS_CONTROL_SHADER

OpenGLTokens

GL_TESS_CONTROL_SHADER_BIT

OpenGLTokens

GL_TESS_EVALUATION_SHADER

OpenGLTokens

GL_TESS_EVALUATION_SHADER_BIT

OpenGLTokens

GL_TESS_GEN_MODE

OpenGLTokens

GL_TESS_GEN_POINT_MODE

OpenGLTokens

GL_TESS_GEN_SPACING

OpenGLTokens

GL_TESS_GEN_VERTEX_ORDER

OpenGLTokens

GL_TEXTURE

OpenGLTokens

GL_TEXTURE0

OpenGLTokens

GL_TEXTURE0_ARB

OpenGLTokens

GL_TEXTURE1

OpenGLTokens

GL_TEXTURE10

OpenGLTokens

GL_TEXTURE10_ARB

OpenGLTokens

GL_TEXTURE11

OpenGLTokens

GL_TEXTURE11_ARB

OpenGLTokens

GL_TEXTURE12

OpenGLTokens

GL_TEXTURE12_ARB

OpenGLTokens

GL_TEXTURE13

OpenGLTokens

GL_TEXTURE13_ARB

OpenGLTokens

GL_TEXTURE14

OpenGLTokens

GL_TEXTURE14_ARB

OpenGLTokens

GL_TEXTURE15

OpenGLTokens

GL_TEXTURE15_ARB

OpenGLTokens

GL_TEXTURE16

OpenGLTokens

GL_TEXTURE16_ARB

OpenGLTokens

GL_TEXTURE17

OpenGLTokens

GL_TEXTURE17_ARB

OpenGLTokens

GL_TEXTURE18

OpenGLTokens

GL_TEXTURE18_ARB

OpenGLTokens

GL_TEXTURE19

OpenGLTokens

GL_TEXTURE19_ARB

OpenGLTokens

GL_TEXTURE1_ARB

OpenGLTokens

GL_TEXTURE2

OpenGLTokens

GL_TEXTURE20

OpenGLTokens

GL_TEXTURE20_ARB

OpenGLTokens

GL_TEXTURE21

OpenGLTokens

GL_TEXTURE21_ARB

OpenGLTokens

GL_TEXTURE22

OpenGLTokens

GL_TEXTURE22_ARB

OpenGLTokens

GL_TEXTURE23

OpenGLTokens

GL_TEXTURE23_ARB

OpenGLTokens

GL_TEXTURE24

OpenGLTokens

GL_TEXTURE24_ARB

OpenGLTokens

GL_TEXTURE25

OpenGLTokens

GL_TEXTURE25_ARB

OpenGLTokens

GL_TEXTURE26

OpenGLTokens

GL_TEXTURE26_ARB

OpenGLTokens

GL_TEXTURE27

OpenGLTokens

GL_TEXTURE27_ARB

OpenGLTokens

GL_TEXTURE28

OpenGLTokens

GL_TEXTURE28_ARB

OpenGLTokens

GL_TEXTURE29

OpenGLTokens

GL_TEXTURE29_ARB

OpenGLTokens

GL_TEXTURE2_ARB

OpenGLTokens

GL_TEXTURE3

OpenGLTokens

GL_TEXTURE30

OpenGLTokens

GL_TEXTURE30_ARB

OpenGLTokens

GL_TEXTURE31

OpenGLTokens

GL_TEXTURE31_ARB

OpenGLTokens

GL_TEXTURE3_ARB

OpenGLTokens

GL_TEXTURE4

OpenGLTokens

GL_TEXTURE4_ARB

OpenGLTokens

GL_TEXTURE5

OpenGLTokens

GL_TEXTURE5_ARB

OpenGLTokens

GL_TEXTURE6

OpenGLTokens

GL_TEXTURE6_ARB

OpenGLTokens

GL_TEXTURE7

OpenGLTokens

GL_TEXTURE7_ARB

OpenGLTokens

GL_TEXTURE8

OpenGLTokens

GL_TEXTURE8_ARB

OpenGLTokens

GL_TEXTURE9

OpenGLTokens

GL_TEXTURE9_ARB

OpenGLTokens

GL_TEXTURE_1D

OpenGLTokens

GL_TEXTURE_1D_ARRAY

OpenGLTokens

GL_TEXTURE_1D_ARRAY_EXT

OpenGLTokens

GL_TEXTURE_1D_BINDING_EXT

OpenGLTokens

GL_TEXTURE_2D

OpenGLTokens

GL_TEXTURE_2D_ARRAY

OpenGLTokens

GL_TEXTURE_2D_ARRAY_EXT

OpenGLTokens

GL_TEXTURE_2D_BINDING_EXT

OpenGLTokens

GL_TEXTURE_2D_MULTISAMPLE

OpenGLTokens

GL_TEXTURE_2D_MULTISAMPLE_ARRAY

OpenGLTokens

GL_TEXTURE_3D

OpenGLTokens

GL_TEXTURE_3D_BINDING_EXT

OpenGLTokens

GL_TEXTURE_3D_EXT

OpenGLTokens

GL_TEXTURE_ALPHA_SIZE

OpenGLTokens

GL_TEXTURE_ALPHA_SIZE_EXT

OpenGLTokens

GL_TEXTURE_ALPHA_TYPE

OpenGLTokens

GL_TEXTURE_ALPHA_TYPE_ARB

OpenGLTokens

GL_TEXTURE_BASE_LEVEL

OpenGLTokens

GL_TEXTURE_BASE_LEVEL_SGIS

OpenGLTokens

GL_TEXTURE_BINDING_1D

OpenGLTokens

GL_TEXTURE_BINDING_1D_ARRAY

OpenGLTokens

GL_TEXTURE_BINDING_1D_ARRAY_EXT

OpenGLTokens

GL_TEXTURE_BINDING_2D

OpenGLTokens

GL_TEXTURE_BINDING_2D_ARRAY

OpenGLTokens

GL_TEXTURE_BINDING_2D_ARRAY_EXT

OpenGLTokens

GL_TEXTURE_BINDING_2D_MULTISAMPLE

OpenGLTokens

GL_TEXTURE_BINDING_2D_MULTISAMPLE_ARRAY

OpenGLTokens

GL_TEXTURE_BINDING_3D

OpenGLTokens

GL_TEXTURE_BINDING_BUFFER

OpenGLTokens

GL_TEXTURE_BINDING_BUFFER_ARB

OpenGLTokens

GL_TEXTURE_BINDING_BUFFER_EXT

OpenGLTokens

GL_TEXTURE_BINDING_CUBE_MAP

OpenGLTokens

GL_TEXTURE_BINDING_CUBE_MAP_ARB

OpenGLTokens

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY

OpenGLTokens

GL_TEXTURE_BINDING_CUBE_MAP_ARRAY_ARB

OpenGLTokens

GL_TEXTURE_BINDING_CUBE_MAP_EXT

OpenGLTokens

GL_TEXTURE_BINDING_RECTANGLE

OpenGLTokens

GL_TEXTURE_BINDING_RECTANGLE_ARB

OpenGLTokens

GL_TEXTURE_BINDING_RECTANGLE_EXT

OpenGLTokens

GL_TEXTURE_BINDING_RECTANGLE_NV

OpenGLTokens

GL_TEXTURE_BIT

OpenGLTokens

GL_TEXTURE_BLUE_SIZE

OpenGLTokens

GL_TEXTURE_BLUE_SIZE_EXT

OpenGLTokens

GL_TEXTURE_BLUE_TYPE

OpenGLTokens

GL_TEXTURE_BLUE_TYPE_ARB

OpenGLTokens

GL_TEXTURE_BORDER

OpenGLTokens

GL_TEXTURE_BORDER_COLOR

OpenGLTokens

GL_TEXTURE_BORDER_VALUES_NV

OpenGLTokens

GL_TEXTURE_BUFFER

OpenGLTokens

GL_TEXTURE_BUFFER_ARB

OpenGLTokens

GL_TEXTURE_BUFFER_DATA_STORE_BINDING

OpenGLTokens

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_ARB

OpenGLTokens

GL_TEXTURE_BUFFER_DATA_STORE_BINDING_EXT

OpenGLTokens

GL_TEXTURE_BUFFER_EXT

OpenGLTokens

GL_TEXTURE_BUFFER_FORMAT

OpenGLTokens

GL_TEXTURE_BUFFER_FORMAT_ARB

OpenGLTokens

GL_TEXTURE_BUFFER_FORMAT_EXT

OpenGLTokens

GL_TEXTURE_COLOR_WRITEMASK_SGIS

OpenGLTokens

GL_TEXTURE_COMPARE_FAIL_VALUE_ARB

OpenGLTokens

GL_TEXTURE_COMPARE_FUNC

OpenGLTokens

GL_TEXTURE_COMPARE_FUNC_ARB

OpenGLTokens

GL_TEXTURE_COMPARE_MODE

OpenGLTokens

GL_TEXTURE_COMPARE_MODE_ARB

OpenGLTokens

GL_TEXTURE_COMPARE_OPERATOR_SGIX

OpenGLTokens

GL_TEXTURE_COMPARE_SGIX

OpenGLTokens

GL_TEXTURE_COMPONENTS

OpenGLTokens

GL_TEXTURE_COMPRESSED

OpenGLTokens

GL_TEXTURE_COMPRESSED_ARB

OpenGLTokens

GL_TEXTURE_COMPRESSED_IMAGE_SIZE

OpenGLTokens

GL_TEXTURE_COMPRESSED_IMAGE_SIZE_ARB

OpenGLTokens

GL_TEXTURE_COMPRESSION_HINT

OpenGLTokens

GL_TEXTURE_COMPRESSION_HINT_ARB

OpenGLTokens

GL_TEXTURE_COORD_ARRAY

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_ADDRESS_NV

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_LENGTH_NV

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_POINTER

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_SIZE

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_STRIDE

OpenGLTokens

GL_TEXTURE_COORD_ARRAY_TYPE

OpenGLTokens

GL_TEXTURE_COORD_NV

OpenGLTokens

GL_TEXTURE_CUBE_MAP

OpenGLTokens

GL_TEXTURE_CUBE_MAP_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_ARRAY

OpenGLTokens

GL_TEXTURE_CUBE_MAP_ARRAY_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_EXT

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_X

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_X_EXT

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_Y_EXT

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_NEGATIVE_Z_EXT

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_X

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_X_EXT

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_Y

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_Y_EXT

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_Z

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB

OpenGLTokens

GL_TEXTURE_CUBE_MAP_POSITIVE_Z_EXT

OpenGLTokens

GL_TEXTURE_CUBE_MAP_SEAMLESS

OpenGLTokens

GL_TEXTURE_DEPTH

OpenGLTokens

GL_TEXTURE_DEPTH_EXT

OpenGLTokens

GL_TEXTURE_DEPTH_SIZE

OpenGLTokens

GL_TEXTURE_DEPTH_SIZE_ARB

OpenGLTokens

GL_TEXTURE_DEPTH_TYPE

OpenGLTokens

GL_TEXTURE_DEPTH_TYPE_ARB

OpenGLTokens

GL_TEXTURE_DS_SIZE_NV

OpenGLTokens

GL_TEXTURE_DT_SIZE_NV

OpenGLTokens

GL_TEXTURE_ENV

OpenGLTokens

GL_TEXTURE_ENV_COLOR

OpenGLTokens

GL_TEXTURE_ENV_MODE

OpenGLTokens

GL_TEXTURE_FILTER_CONTROL

OpenGLTokens

GL_TEXTURE_FILTER_CONTROL_EXT

OpenGLTokens

GL_TEXTURE_FIXED_SAMPLE_LOCATIONS

OpenGLTokens

GL_TEXTURE_FLOAT_COMPONENTS_NV

OpenGLTokens

GL_TEXTURE_FREE_MEMORY_ATI

OpenGLTokens

GL_TEXTURE_GEN_MODE

OpenGLTokens

GL_TEXTURE_GEN_Q

OpenGLTokens

GL_TEXTURE_GEN_R

OpenGLTokens

GL_TEXTURE_GEN_S

OpenGLTokens

GL_TEXTURE_GEN_T

OpenGLTokens

GL_TEXTURE_GEQUAL_R_SGIX

OpenGLTokens

GL_TEXTURE_GREEN_SIZE

OpenGLTokens

GL_TEXTURE_GREEN_SIZE_EXT

OpenGLTokens

GL_TEXTURE_GREEN_TYPE

OpenGLTokens

GL_TEXTURE_GREEN_TYPE_ARB

OpenGLTokens

GL_TEXTURE_HEIGHT

OpenGLTokens

GL_TEXTURE_HI_SIZE_NV

OpenGLTokens

GL_TEXTURE_INDEX_SIZE_EXT

OpenGLTokens

GL_TEXTURE_INTENSITY_SIZE

OpenGLTokens

GL_TEXTURE_INTENSITY_SIZE_EXT

OpenGLTokens

GL_TEXTURE_INTENSITY_TYPE

OpenGLTokens

GL_TEXTURE_INTENSITY_TYPE_ARB

OpenGLTokens

GL_TEXTURE_INTERNAL_FORMAT

OpenGLTokens

GL_TEXTURE_LEQUAL_R_SGIX

OpenGLTokens

GL_TEXTURE_LOD_BIAS

OpenGLTokens

GL_TEXTURE_LOD_BIAS_EXT

OpenGLTokens

GL_TEXTURE_LO_SIZE_NV

OpenGLTokens

GL_TEXTURE_LUMINANCE_SIZE

OpenGLTokens

GL_TEXTURE_LUMINANCE_SIZE_EXT

OpenGLTokens

GL_TEXTURE_LUMINANCE_TYPE

OpenGLTokens

GL_TEXTURE_LUMINANCE_TYPE_ARB

OpenGLTokens

GL_TEXTURE_MAG_FILTER

OpenGLTokens

GL_TEXTURE_MAG_SIZE_NV

OpenGLTokens

GL_TEXTURE_MATRIX

OpenGLTokens

GL_TEXTURE_MAX_ANISOTROPY_EXT

OpenGLTokens

GL_TEXTURE_MAX_LEVEL

OpenGLTokens

GL_TEXTURE_MAX_LEVEL_SGIS

OpenGLTokens

GL_TEXTURE_MAX_LOD

OpenGLTokens

GL_TEXTURE_MAX_LOD_SGIS

OpenGLTokens

GL_TEXTURE_MIN_FILTER

OpenGLTokens

GL_TEXTURE_MIN_LOD

OpenGLTokens

GL_TEXTURE_MIN_LOD_SGIS

OpenGLTokens

GL_TEXTURE_PRIORITY

OpenGLTokens

GL_TEXTURE_PRIORITY_EXT

OpenGLTokens

GL_TEXTURE_RECTANGLE

OpenGLTokens

GL_TEXTURE_RECTANGLE_ARB

OpenGLTokens

GL_TEXTURE_RECTANGLE_EXT

OpenGLTokens

GL_TEXTURE_RECTANGLE_NV

OpenGLTokens

GL_TEXTURE_RED_SIZE

OpenGLTokens

GL_TEXTURE_RED_SIZE_EXT

OpenGLTokens

GL_TEXTURE_RED_TYPE

OpenGLTokens

GL_TEXTURE_RED_TYPE_ARB

OpenGLTokens

GL_TEXTURE_RESIDENT

OpenGLTokens

GL_TEXTURE_RESIDENT_EXT

OpenGLTokens

GL_TEXTURE_SAMPLES

OpenGLTokens

GL_TEXTURE_SHADER_NV

OpenGLTokens

GL_TEXTURE_SHARED_SIZE

OpenGLTokens

GL_TEXTURE_SHARED_SIZE_EXT

OpenGLTokens

GL_TEXTURE_SRGB_DECODE_EXT

OpenGLTokens

GL_TEXTURE_STACK_DEPTH

OpenGLTokens

GL_TEXTURE_STENCIL_SIZE

OpenGLTokens

GL_TEXTURE_STENCIL_SIZE_EXT

OpenGLTokens

GL_TEXTURE_SWIZZLE_A

OpenGLTokens

GL_TEXTURE_SWIZZLE_B

OpenGLTokens

GL_TEXTURE_SWIZZLE_G

OpenGLTokens

GL_TEXTURE_SWIZZLE_R

OpenGLTokens

GL_TEXTURE_SWIZZLE_RGBA

OpenGLTokens

GL_TEXTURE_TOO_LARGE_EXT

OpenGLTokens

GL_TEXTURE_WIDTH

OpenGLTokens

GL_TEXTURE_WRAP_R

OpenGLTokens

GL_TEXTURE_WRAP_R_EXT

OpenGLTokens

GL_TEXTURE_WRAP_S

OpenGLTokens

GL_TEXTURE_WRAP_T

OpenGLTokens

GL_TIMEOUT_EXPIRED

OpenGLTokens

GL_TIMEOUT_IGNORED

OpenGLTokens

GL_TIMESTAMP

OpenGLTokens

GL_TIME_ELAPSED

OpenGLTokens

GL_TIME_ELAPSED_EXT

OpenGLTokens

GL_TRACK_MATRIX_NV

OpenGLTokens

GL_TRACK_MATRIX_TRANSFORM_NV

OpenGLTokens

GL_TRANSFORM_BIT

OpenGLTokens

GL_TRANSFORM_FEEDBACK

OpenGLTokens

GL_TRANSFORM_FEEDBACK_ATTRIBS_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BINDING

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_ACTIVE

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_EXT

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_BINDING_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_EXT

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_MODE

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_EXT

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_MODE_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_PAUSED

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_EXT

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_SIZE_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_START

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_START_EXT

OpenGLTokens

GL_TRANSFORM_FEEDBACK_BUFFER_START_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN

OpenGLTokens

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_EXT

OpenGLTokens

GL_TRANSFORM_FEEDBACK_PRIMITIVES_WRITTEN_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_RECORD_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_VARYINGS

OpenGLTokens

GL_TRANSFORM_FEEDBACK_VARYINGS_EXT

OpenGLTokens

GL_TRANSFORM_FEEDBACK_VARYINGS_NV

OpenGLTokens

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH

OpenGLTokens

GL_TRANSFORM_FEEDBACK_VARYING_MAX_LENGTH_EXT

OpenGLTokens

GL_TRANSLATE_2D_NV

OpenGLTokens

GL_TRANSLATE_3D_NV

OpenGLTokens

GL_TRANSLATE_X_NV

OpenGLTokens

GL_TRANSLATE_Y_NV

OpenGLTokens

GL_TRANSPOSE_AFFINE_2D_NV

OpenGLTokens

GL_TRANSPOSE_AFFINE_3D_NV

OpenGLTokens

GL_TRANSPOSE_COLOR_MATRIX

OpenGLTokens

GL_TRANSPOSE_COLOR_MATRIX_ARB

OpenGLTokens

GL_TRANSPOSE_CURRENT_MATRIX_ARB

OpenGLTokens

GL_TRANSPOSE_MODELVIEW_MATRIX

OpenGLTokens

GL_TRANSPOSE_MODELVIEW_MATRIX_ARB

OpenGLTokens

GL_TRANSPOSE_NV

OpenGLTokens

GL_TRANSPOSE_PROJECTION_MATRIX

OpenGLTokens

GL_TRANSPOSE_PROJECTION_MATRIX_ARB

OpenGLTokens

GL_TRANSPOSE_TEXTURE_MATRIX

OpenGLTokens

GL_TRANSPOSE_TEXTURE_MATRIX_ARB

OpenGLTokens

GL_TRIANGLES

OpenGLTokens

GL_TRIANGLES_ADJACENCY

OpenGLTokens

GL_TRIANGLES_ADJACENCY_ARB

OpenGLTokens

GL_TRIANGLES_ADJACENCY_EXT

OpenGLTokens

GL_TRIANGLE_FAN

OpenGLTokens

GL_TRIANGLE_STRIP

OpenGLTokens

GL_TRIANGLE_STRIP_ADJACENCY

OpenGLTokens

GL_TRIANGLE_STRIP_ADJACENCY_ARB

OpenGLTokens

GL_TRIANGLE_STRIP_ADJACENCY_EXT

OpenGLTokens

GL_TRIANGULAR_NV

OpenGLTokens

GL_TRUE

OpenGLTokens

GL_TYPE_RGBA_FLOAT_ATI

OpenGLTokens

GL_UNDEFINED_VERTEX

OpenGLTokens

GL_UNIFORM_ARRAY_STRIDE

OpenGLTokens

GL_UNIFORM_BLOCK_ACTIVE_UNIFORMS

OpenGLTokens

GL_UNIFORM_BLOCK_ACTIVE_UNIFORM_INDICES

OpenGLTokens

GL_UNIFORM_BLOCK_BINDING

OpenGLTokens

GL_UNIFORM_BLOCK_DATA_SIZE

OpenGLTokens

GL_UNIFORM_BLOCK_INDEX

OpenGLTokens

GL_UNIFORM_BLOCK_NAME_LENGTH

OpenGLTokens

GL_UNIFORM_BLOCK_REFERENCED_BY_FRAGMENT_SHADER

OpenGLTokens

GL_UNIFORM_BLOCK_REFERENCED_BY_GEOMETRY_SHADER

OpenGLTokens

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_CONTROL_SHADER

OpenGLTokens

GL_UNIFORM_BLOCK_REFERENCED_BY_TESS_EVALUATION_SHADER

OpenGLTokens

GL_UNIFORM_BLOCK_REFERENCED_BY_VERTEX_SHADER

OpenGLTokens

GL_UNIFORM_BUFFER

OpenGLTokens

GL_UNIFORM_BUFFER_BINDING

OpenGLTokens

GL_UNIFORM_BUFFER_BINDING_EXT

OpenGLTokens

GL_UNIFORM_BUFFER_EXT

OpenGLTokens

GL_UNIFORM_BUFFER_OFFSET_ALIGNMENT

OpenGLTokens

GL_UNIFORM_BUFFER_SIZE

OpenGLTokens

GL_UNIFORM_BUFFER_START

OpenGLTokens

GL_UNIFORM_IS_ROW_MAJOR

OpenGLTokens

GL_UNIFORM_MATRIX_STRIDE

OpenGLTokens

GL_UNIFORM_NAME_LENGTH

OpenGLTokens

GL_UNIFORM_OFFSET

OpenGLTokens

GL_UNIFORM_SIZE

OpenGLTokens

GL_UNIFORM_TYPE

OpenGLTokens

GL_UNKNOWN_CONTEXT_RESET_ARB

OpenGLTokens

GL_UNPACK_ALIGNMENT

OpenGLTokens

GL_UNPACK_IMAGE_HEIGHT

OpenGLTokens

GL_UNPACK_IMAGE_HEIGHT_EXT

OpenGLTokens

GL_UNPACK_LSB_FIRST

OpenGLTokens

GL_UNPACK_ROW_LENGTH

OpenGLTokens

GL_UNPACK_SKIP_IMAGES

OpenGLTokens

GL_UNPACK_SKIP_IMAGES_EXT

OpenGLTokens

GL_UNPACK_SKIP_PIXELS

OpenGLTokens

GL_UNPACK_SKIP_ROWS

OpenGLTokens

GL_UNPACK_SWAP_BYTES

OpenGLTokens

GL_UNSIGNALED

OpenGLTokens

GL_UNSIGNED_BYTE

OpenGLTokens

GL_UNSIGNED_BYTE_2_3_3_REV

OpenGLTokens

GL_UNSIGNED_BYTE_3_3_2

OpenGLTokens

GL_UNSIGNED_BYTE_3_3_2_EXT

OpenGLTokens

GL_UNSIGNED_IDENTITY_NV

OpenGLTokens

GL_UNSIGNED_INT

OpenGLTokens

GL_UNSIGNED_INT_10F_11F_11F_REV

OpenGLTokens

GL_UNSIGNED_INT_10F_11F_11F_REV_EXT

OpenGLTokens

GL_UNSIGNED_INT_10_10_10_2

OpenGLTokens

GL_UNSIGNED_INT_10_10_10_2_EXT

OpenGLTokens

GL_UNSIGNED_INT_24_8

OpenGLTokens

GL_UNSIGNED_INT_24_8_EXT

OpenGLTokens

GL_UNSIGNED_INT_2_10_10_10_REV

OpenGLTokens

GL_UNSIGNED_INT_5_9_9_9_REV

OpenGLTokens

GL_UNSIGNED_INT_5_9_9_9_REV_EXT

OpenGLTokens

GL_UNSIGNED_INT_8_8_8_8

OpenGLTokens

GL_UNSIGNED_INT_8_8_8_8_EXT

OpenGLTokens

GL_UNSIGNED_INT_8_8_8_8_REV

OpenGLTokens

GL_UNSIGNED_INT_8_8_S8_S8_REV_NV

OpenGLTokens

GL_UNSIGNED_INT_S8_S8_8_8_NV

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_1D

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_1D_ARRAY_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_1D_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D_ARRAY_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D_MULTISAMPLE_ARRAY

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D_RECT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_2D_RECT_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_3D

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_3D_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_BUFFER

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_BUFFER_AMD

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_BUFFER_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_CUBE

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_CUBE_EXT

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY

OpenGLTokens

GL_UNSIGNED_INT_SAMPLER_CUBE_MAP_ARRAY_ARB

OpenGLTokens

GL_UNSIGNED_INT_VEC2

OpenGLTokens

GL_UNSIGNED_INT_VEC2_EXT

OpenGLTokens

GL_UNSIGNED_INT_VEC3

OpenGLTokens

GL_UNSIGNED_INT_VEC3_EXT

OpenGLTokens

GL_UNSIGNED_INT_VEC4

OpenGLTokens

GL_UNSIGNED_INT_VEC4_EXT

OpenGLTokens

GL_UNSIGNED_INVERT_NV

OpenGLTokens

GL_UNSIGNED_NORMALIZED

OpenGLTokens

GL_UNSIGNED_NORMALIZED_ARB

OpenGLTokens

GL_UNSIGNED_SHORT

OpenGLTokens

GL_UNSIGNED_SHORT_1_5_5_5_REV

OpenGLTokens

GL_UNSIGNED_SHORT_4_4_4_4

OpenGLTokens

GL_UNSIGNED_SHORT_4_4_4_4_EXT

OpenGLTokens

GL_UNSIGNED_SHORT_4_4_4_4_REV

OpenGLTokens

GL_UNSIGNED_SHORT_5_5_5_1

OpenGLTokens

GL_UNSIGNED_SHORT_5_5_5_1_EXT

OpenGLTokens

GL_UNSIGNED_SHORT_5_6_5

OpenGLTokens

GL_UNSIGNED_SHORT_5_6_5_REV

OpenGLTokens

GL_UPPER_LEFT

OpenGLTokens

GL_USE_MISSING_GLYPH_NV

OpenGLTokens

GL_UTF16_NV

OpenGLTokens

GL_UTF8_NV

OpenGLTokens

GL_V2F

OpenGLTokens

GL_V3F

OpenGLTokens

GL_VALIDATE_STATUS

OpenGLTokens

GL_VARIABLE_A_NV

OpenGLTokens

GL_VARIABLE_B_NV

OpenGLTokens

GL_VARIABLE_C_NV

OpenGLTokens

GL_VARIABLE_D_NV

OpenGLTokens

GL_VARIABLE_E_NV

OpenGLTokens

GL_VARIABLE_F_NV

OpenGLTokens

GL_VARIABLE_G_NV

OpenGLTokens

GL_VBO_FREE_MEMORY_ATI

OpenGLTokens

GL_VENDOR

OpenGLTokens

GL_VERSION

OpenGLTokens

GL_VERSION_1_0

OpenGL1x

GL_VERSION_1_1

OpenGL1x

GL_VERSION_1_2

OpenGL1x

GL_VERSION_1_3

OpenGL1x

GL_VERSION_1_4

OpenGL1x

GL_VERSION_1_5

OpenGL1x

GL_VERSION_2_0

OpenGL1x

GL_VERSION_2_1

OpenGL1x

GL_VERSION_3_0

OpenGL1x

GL_VERSION_3_1

OpenGL1x

GL_VERSION_3_2

OpenGL1x

GL_VERSION_3_3

OpenGL1x

GL_VERSION_4_0

OpenGL1x

GL_VERSION_4_1

OpenGL1x

GL_VERTEX_ARRAY

OpenGLTokens

GL_VERTEX_ARRAY_ADDRESS_NV

OpenGLTokens

GL_VERTEX_ARRAY_BINDING

OpenGLTokens

GL_VERTEX_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_VERTEX_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_VERTEX_ARRAY_LENGTH_NV

OpenGLTokens

GL_VERTEX_ARRAY_POINTER

OpenGLTokens

GL_VERTEX_ARRAY_RANGE_LENGTH_NV

OpenGLTokens

GL_VERTEX_ARRAY_RANGE_NV

OpenGLTokens

GL_VERTEX_ARRAY_RANGE_POINTER_NV

OpenGLTokens

GL_VERTEX_ARRAY_RANGE_VALID_NV

OpenGLTokens

GL_VERTEX_ARRAY_RANGE_WITHOUT_FLUSH_NV

OpenGLTokens

GL_VERTEX_ARRAY_SIZE

OpenGLTokens

GL_VERTEX_ARRAY_STRIDE

OpenGLTokens

GL_VERTEX_ARRAY_TYPE

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY0_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY10_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY11_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY12_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY13_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY14_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY15_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY1_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY2_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY3_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY4_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY5_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY6_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY7_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY8_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY9_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_ADDRESS_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_DIVISOR

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_DIVISOR_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_ENABLED

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_ENABLED_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_INTEGER

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_INTEGER_EXT

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_LENGTH_NV

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_NORMALIZED_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_POINTER

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_POINTER_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_SIZE

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_SIZE_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_STRIDE

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_STRIDE_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_TYPE

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_TYPE_ARB

OpenGLTokens

GL_VERTEX_ATTRIB_ARRAY_UNIFIED_NV

OpenGLTokens

GL_VERTEX_BLEND_ARB

OpenGLTokens

GL_VERTEX_ID_NV

OpenGLTokens

GL_VERTEX_PROGRAM_ARB

OpenGLTokens

GL_VERTEX_PROGRAM_BINDING_NV

OpenGLTokens

GL_VERTEX_PROGRAM_NV

OpenGLTokens

GL_VERTEX_PROGRAM_POINT_SIZE

OpenGLTokens

GL_VERTEX_PROGRAM_POINT_SIZE_ARB

OpenGLTokens

GL_VERTEX_PROGRAM_POINT_SIZE_NV

OpenGLTokens

GL_VERTEX_PROGRAM_TWO_SIDE

OpenGLTokens

GL_VERTEX_PROGRAM_TWO_SIDE_ARB

OpenGLTokens

GL_VERTEX_PROGRAM_TWO_SIDE_NV

OpenGLTokens

GL_VERTEX_SHADER

OpenGLTokens

GL_VERTEX_SHADER_ARB

OpenGLTokens

GL_VERTEX_SHADER_BIT

OpenGLTokens

GL_VERTEX_STATE_PROGRAM_NV

OpenGLTokens

GL_VERTICAL_LINE_TO_NV

OpenGLTokens

GL_VIBRANCE_BIAS_NV

OpenGLTokens

GL_VIBRANCE_SCALE_NV

OpenGLTokens

GL_VIEWPORT

OpenGLTokens

GL_VIEWPORT_BIT

OpenGLTokens

GL_VIEWPORT_BOUNDS_RANGE

OpenGLTokens

GL_VIEWPORT_INDEX_PROVOKING_VERTEX

OpenGLTokens

GL_VIEWPORT_SUBPIXEL_BITS

OpenGLTokens

GL_WAIT_FAILED

OpenGLTokens

GL_WEIGHT_ARRAY_ARB

OpenGLTokens

GL_WEIGHT_ARRAY_BUFFER_BINDING

OpenGLTokens

GL_WEIGHT_ARRAY_BUFFER_BINDING_ARB

OpenGLTokens

GL_WEIGHT_ARRAY_POINTER_ARB

OpenGLTokens

GL_WEIGHT_ARRAY_SIZE_ARB

OpenGLTokens

GL_WEIGHT_ARRAY_STRIDE_ARB

OpenGLTokens

GL_WEIGHT_ARRAY_TYPE_ARB

OpenGLTokens

GL_WEIGHT_SUM_UNITY_ARB

OpenGLTokens

GL_WIN_swap_hint

OpenGL1x

GL_WRITE_DISCARD_NV

OpenGLTokens

GL_WRITE_ONLY

OpenGLTokens

GL_WRITE_ONLY_ARB

OpenGLTokens

GL_XOR

OpenGLTokens

GL_ZERO

OpenGLTokens

GL_ZOOM_X

OpenGLTokens

GL_ZOOM_Y

OpenGLTokens

GRADIENT_TABLE_SIZE

GLProcTextures

GraphicClassForExtension

PictureRegisteredFormats

Returns the TGraphicClass associated to the extension, if any.<p> Accepts anExtension with or without the '.'

GUIComponentDialog

GuiSkinEditorFormUnit

GUIComponentDialog

GuiSkinEditorFormUnitLCL

GUILayoutEditorForm

FGUILayoutEditor

GuiNullRect

GLGui

GUISkinEditor

GuiSkinEditorFormUnitLCL

GUISkinEditor

GuiSkinEditorFormUnit

G_DRAG

VerletClasses

HackTPictureRegisteredFormats

PictureRegisteredFormats

Adds to the passed TStrings the list of registered formats.<p> Convention is "extension=description" for the string, the Objects hold the corresponding TGraphicClass (extensions do not include the '.').

HalfToFloat

GLCrossPlatform

HCHANNEL

Bass

HDRAWDIB

GLSVfw

HDSP

Bass

HFX

Bass

HGPUNV

OpenGLTokens

HGPUNV

GLS_CUDA_API

HIC

GLSVfw

HIDE_NODE

Const3DS

HIDE_TRACK_TAG

Const3DS

HIERARCHY

Const3DS

HIGHPASS_DEFAULT_GAIN

openal

HIGHPASS_DEFAULT_GAINLF

openal

HIGHPASS_MAX_GAIN

openal

HIGHPASS_MAX_GAINLF

openal

HIGHPASS_MIN_GAIN

openal

HIGHPASS_MIN_GAINLF

openal

HingeCalculateJointOmega

NewtonImport_JointLibrary

HingeEnableLimits

NewtonImport_JointLibrary

HingeGetJointAngle

NewtonImport_JointLibrary

HingeGetPinAxis

NewtonImport_JointLibrary

HingeSetLimits

NewtonImport_JointLibrary

HiShadowBiasMin3DS

Const3DS

HI_SHADOW_BIAS

Const3DS

HMODULE

openal

HMUSIC

Bass

HotTrackTagMax3DS

Const3DS

HotTrackTagMin3DS

Const3DS

HOT_TRACK_TAG

Const3DS

HOT_TRACK_TAG_KEY

Const3DS

HPBUFFERARB

OpenGLTokens

HPLUGIN

Bass

HRECORD

Bass

HSAMPLE

Bass

HSTREAM

Bass

HSYNC

Bass

HVIDEO

GLSVfw

IAVIEditStream

GLSVfw

IAVIFile

GLSVfw

IAVIStream

GLSVfw

IAVIStreaming

GLSVfw

ICAbout

GLSVfw

ICClose

GLSVfw

ICCompress

GLSVfw

ICCompressBegin

GLSVfw

ICCompressEnd

GLSVfw

ICCOMPRESSFRAMES_PADDING

GLSVfw

ICCompressGetFormat

GLSVfw

ICCompressGetFormatSize

GLSVfw

ICCompressGetSize

GLSVfw

ICCompressorChoose

GLSVfw

ICCompressorFree

GLSVfw

ICCompressQuery

GLSVfw

ICCOMPRESS_KEYFRAME

GLSVfw

ICConfigure

GLSVfw

ICDecompress

GLSVfw

ICDecompressBegin

GLSVfw

ICDecompressEnd

GLSVfw

ICDecompressEx

GLSVfw

ICDecompressExBegin

GLSVfw

ICDecompressExEnd

GLSVfw

ICDecompressExQuery

GLSVfw

ICDecompressGetFormat

GLSVfw

ICDecompressGetFormatSize

GLSVfw

ICDecompressGetPalette

GLSVfw

ICDecompressOpen

GLSVfw

ICDecompressQuery

GLSVfw

ICDecompressSetPalette

GLSVfw

ICDECOMPRESS_HURRYUP

GLSVfw

ICDECOMPRESS_NOTKEYFRAME

GLSVfw

ICDECOMPRESS_NULLFRAME

GLSVfw

ICDECOMPRESS_PREROLL

GLSVfw

ICDECOMPRESS_UPDATE

GLSVfw

ICDraw

GLSVfw

ICDrawBegin

GLSVfw

ICDrawChangePalette

GLSVfw

ICDrawEnd

GLSVfw

ICDrawFlush

GLSVfw

ICDrawGetTime

GLSVfw

ICDrawOpen

GLSVfw

ICDrawQuery

GLSVfw

ICDrawRealize

GLSVfw

ICDrawRenderBuffer

GLSVfw

ICDrawSetTime

GLSVfw

ICDrawStart

GLSVfw

ICDrawStartPlay

GLSVfw

ICDrawStop

GLSVfw

ICDrawStopPlay

GLSVfw

ICDrawSuggestFormat

GLSVfw

ICDrawWindow

GLSVfw

ICDRAW_ANIMATE

GLSVfw

ICDRAW_BUFFER

GLSVfw

ICDRAW_CONTINUE

GLSVfw

ICDRAW_FULLSCREEN

GLSVfw

ICDRAW_HDC

GLSVfw

ICDRAW_HURRYUP

GLSVfw

ICDRAW_MEMORYDC

GLSVfw

ICDRAW_NOTKEYFRAME

GLSVfw

ICDRAW_NULLFRAME

GLSVfw

ICDRAW_PREROLL

GLSVfw

ICDRAW_QUERY

GLSVfw

ICDRAW_RENDER

GLSVfw

ICDRAW_UPDATE

GLSVfw

ICDRAW_UPDATING

GLSVfw

ICERR_ABORT

GLSVfw

ICERR_BADBITDEPTH

GLSVfw

ICERR_BADFLAGS

GLSVfw

ICERR_BADFORMAT

GLSVfw

ICERR_BADHANDLE

GLSVfw

ICERR_BADIMAGESIZE

GLSVfw

ICERR_BADPARAM

GLSVfw

ICERR_BADSIZE

GLSVfw

ICERR_CANTUPDATE

GLSVfw

ICERR_CUSTOM

GLSVfw

ICERR_DONTDRAW

GLSVfw

ICERR_ERROR

GLSVfw

ICERR_GOTOKEYFRAME

GLSVfw

ICERR_INTERNAL

GLSVfw

ICERR_MEMORY

GLSVfw

ICERR_NEWPALETTE

GLSVfw

ICERR_OK

GLSVfw

ICERR_STOPDRAWING

GLSVfw

ICERR_UNSUPPORTED

GLSVfw

ICGetBuffersWanted

GLSVfw

ICGetDefaultKeyFrameRate

GLSVfw

ICGetDefaultQuality

GLSVfw

ICGetDisplayFormat

GLSVfw

ICGetInfo

GLSVfw

ICGetState

GLSVfw

ICGetStateSize

GLSVfw

ICImageCompress

GLSVfw

ICImageDecompress

GLSVfw

ICInfo

GLSVfw

ICInstall

GLSVfw

ICINSTALL_DRIVER

GLSVfw

ICINSTALL_DRIVERW

GLSVfw

ICINSTALL_FUNCTION

GLSVfw

ICINSTALL_HDRV

GLSVfw

ICINSTALL_UNICODE

GLSVfw

ICLocate

GLSVfw

ICMF_ABOUT_QUERY

GLSVfw

ICMF_CHOOSE_ALLCOMPRESSORS

GLSVfw

ICMF_CHOOSE_DATARATE

GLSVfw

ICMF_CHOOSE_KEYFRAME

GLSVfw

ICMF_CHOOSE_PREVIEW

GLSVfw

ICMF_COMPVARS_VALID

GLSVfw

ICMF_CONFIGURE_QUERY

GLSVfw

ICMODE_COMPRESS

GLSVfw

ICMODE_DECOMPRESS

GLSVfw

ICMODE_DRAW

GLSVfw

ICMODE_FASTCOMPRESS

GLSVfw

ICMODE_FASTDECOMPRESS

GLSVfw

ICMODE_QUERY

GLSVfw

ICM_ABOUT

GLSVfw

ICM_COMPRESS

GLSVfw

ICM_COMPRESS_BEGIN

GLSVfw

ICM_COMPRESS_END

GLSVfw

ICM_COMPRESS_FRAMES_INFO

GLSVfw

ICM_COMPRESS_GET_FORMAT

GLSVfw

ICM_COMPRESS_GET_SIZE

GLSVfw

ICM_COMPRESS_QUERY

GLSVfw

ICM_CONFIGURE

GLSVfw

ICM_DECOMPRESS

GLSVfw

ICM_DECOMPRESSEX

GLSVfw

ICM_DECOMPRESSEX_BEGIN

GLSVfw

ICM_DECOMPRESSEX_END

GLSVfw

ICM_DECOMPRESSEX_QUERY

GLSVfw

ICM_DECOMPRESS_BEGIN

GLSVfw

ICM_DECOMPRESS_END

GLSVfw

ICM_DECOMPRESS_GET_FORMAT

GLSVfw

ICM_DECOMPRESS_GET_PALETTE

GLSVfw

ICM_DECOMPRESS_QUERY

GLSVfw

ICM_DECOMPRESS_SET_PALETTE

GLSVfw

ICM_DRAW

GLSVfw

ICM_DRAW_BEGIN

GLSVfw

ICM_DRAW_CHANGEPALETTE

GLSVfw

ICM_DRAW_END

GLSVfw

ICM_DRAW_FLUSH

GLSVfw

ICM_DRAW_GETTIME

GLSVfw

ICM_DRAW_GET_PALETTE

GLSVfw

ICM_DRAW_QUERY

GLSVfw

ICM_DRAW_REALIZE

GLSVfw

ICM_DRAW_RENDERBUFFER

GLSVfw

ICM_DRAW_SETTIME

GLSVfw

ICM_DRAW_START

GLSVfw

ICM_DRAW_START_PLAY

GLSVfw

ICM_DRAW_STOP

GLSVfw

ICM_DRAW_STOP_PLAY

GLSVfw

ICM_DRAW_SUGGESTFORMAT

GLSVfw

ICM_DRAW_WINDOW

GLSVfw

ICM_FRAMERATE

GLSVfw

ICM_GET

GLSVfw

ICM_GETBUFFERSWANTED

GLSVfw

ICM_GETDEFAULTKEYFRAMERATE

GLSVfw

ICM_GETDEFAULTQUALITY

GLSVfw

ICM_GETINFO

GLSVfw

ICM_GETQUALITY

GLSVfw

ICM_GETSTATE

GLSVfw

ICM_KEYFRAMERATE

GLSVfw

ICM_RESERVED

GLSVfw

ICM_RESERVED_HIGH

GLSVfw

ICM_RESERVED_LOW

GLSVfw

ICM_SET

GLSVfw

ICM_SETQUALITY

GLSVfw

ICM_SETSTATE

GLSVfw

ICM_SET_STATUS_PROC

GLSVfw

ICM_USER

GLSVfw

ICOpen

GLSVfw

ICOpenFunction

GLSVfw

IcosahedronBuildList

GLObjects

ICQUALITY_DEFAULT

GLSVfw

ICQUALITY_HIGH

GLSVfw

ICQUALITY_LOW

GLSVfw

ICQueryAbout

GLSVfw

ICQueryConfigure

GLSVfw

ICRemove

GLSVfw

ICSendMessage

GLSVfw

ICSeqCompressFrame

GLSVfw

ICSeqCompressFrameEnd

GLSVfw

ICSeqCompressFrameStart

GLSVfw

ICSetState

GLSVfw

ICSetStatusProc

GLSVfw

ICSTATUS_END

GLSVfw

ICSTATUS_ERROR

GLSVfw

ICSTATUS_START

GLSVfw

ICSTATUS_STATUS

GLSVfw

ICSTATUS_YIELD

GLSVfw

ICTYPE_AUDIO

GLSVfw

ICTYPE_VIDEO

GLSVfw

ICVERSION

GLSVfw

ID4ToInt

LWObjects

IdentityHmgDblMatrix

VectorGeometry

IdentityHmgMatrix

VectorGeometry

IdentityMatrix

VectorGeometry

IdentityQuaternion

VectorGeometry

IDS_CAP_AUDIO_DROP_ERROR

GLSVfw

IDS_CAP_AVI_DRAWDIB_ERROR

GLSVfw

IDS_CAP_AVI_INIT_ERROR

GLSVfw

IDS_CAP_BEGIN

GLSVfw

IDS_CAP_CANTOPEN

GLSVfw

IDS_CAP_COMPRESSOR_ERROR

GLSVfw

IDS_CAP_DEFAVIEXT

GLSVfw

IDS_CAP_DEFPALEXT

GLSVfw

IDS_CAP_DRIVER_ERROR

GLSVfw

IDS_CAP_END

GLSVfw

IDS_CAP_ERRORDIBSAVE

GLSVfw

IDS_CAP_ERRORPALOPEN

GLSVfw

IDS_CAP_ERRORPALSAVE

GLSVfw

IDS_CAP_FILEEXISTS

GLSVfw

IDS_CAP_FILE_OPEN_ERROR

GLSVfw

IDS_CAP_FILE_WRITE_ERROR

GLSVfw

IDS_CAP_INFO

GLSVfw

IDS_CAP_MCI_CANT_STEP_ERROR

GLSVfw

IDS_CAP_MCI_CONTROL_ERROR

GLSVfw

IDS_CAP_NODISKSPACE

GLSVfw

IDS_CAP_NO_AUDIO_CAP_ERROR

GLSVfw

IDS_CAP_NO_FRAME_CAP_ERROR

GLSVfw

IDS_CAP_NO_PALETTE_WARN

GLSVfw

IDS_CAP_OUTOFMEM

GLSVfw

IDS_CAP_READONLYFILE

GLSVfw

IDS_CAP_RECORDING_ERROR

GLSVfw

IDS_CAP_RECORDING_ERROR2

GLSVfw

IDS_CAP_SAVEASPERCENT

GLSVfw

IDS_CAP_SEQ_MSGSTART

GLSVfw

IDS_CAP_SEQ_MSGSTOP

GLSVfw

IDS_CAP_SETFILESIZE

GLSVfw

IDS_CAP_STAT_CAP_AUDIO

GLSVfw

IDS_CAP_STAT_CAP_FINI

GLSVfw

IDS_CAP_STAT_CAP_INIT

GLSVfw

IDS_CAP_STAT_CAP_L_FRAMES

GLSVfw

IDS_CAP_STAT_FRAMESDROPPED

GLSVfw

IDS_CAP_STAT_I_FRAMES

GLSVfw

IDS_CAP_STAT_LIVE_MODE

GLSVfw

IDS_CAP_STAT_L_FRAMES

GLSVfw

IDS_CAP_STAT_OPTPAL_BUILD

GLSVfw

IDS_CAP_STAT_OVERLAY_MODE

GLSVfw

IDS_CAP_STAT_PALETTE_BUILD

GLSVfw

IDS_CAP_STAT_VIDEOAUDIO

GLSVfw

IDS_CAP_STAT_VIDEOCURRENT

GLSVfw

IDS_CAP_STAT_VIDEOONLY

GLSVfw

IDS_CAP_VIDEDITERR

GLSVfw

IDS_CAP_VIDEO_ADD_ERROR

GLSVfw

IDS_CAP_VIDEO_ALLOC_ERROR

GLSVfw

IDS_CAP_VIDEO_OPEN_ERROR

GLSVfw

IDS_CAP_VIDEO_PREPARE_ERROR

GLSVfw

IDS_CAP_VIDEO_SIZE_ERROR

GLSVfw

IDS_CAP_WAVE_ADD_ERROR

GLSVfw

IDS_CAP_WAVE_ALLOC_ERROR

GLSVfw

IDS_CAP_WAVE_OPEN_ERROR

GLSVfw

IDS_CAP_WAVE_PREPARE_ERROR

GLSVfw

IDS_CAP_WAVE_SIZE_ERROR

GLSVfw

IDS_CAP_WRITEERROR

GLSVfw

ID_ALPH

LWObjects

ID_ANIM

LWObjects

ID_BBOX

LWObjects

ID_BRIT

LWObjects

ID_BTEX

LWObjects

ID_CLIP

LWObjects

ID_COLR

LWObjects

ID_CONT

LWObjects

ID_CRVS

LWObjects

ID_CTEX

LWObjects

ID_DESC

LWObjects

ID_DIFF

LWObjects

ID_DTEX

LWObjects

ID_EDGE

LWObjects

ID_ENVL

LWObjects

ID_FLAG

LWObjects

ID_FLYR

LWObjects

ID_FORM

LWObjects

ID_GAMMA

LWObjects

ID_GLOS

LWObjects

ID_HUE

LWObjects

ID_ICON

LWObjects

ID_IFLT

LWObjects

ID_IMCC

LWObjects

ID_IMSQ

LWObjects

ID_ISEQ

LWObjects

ID_LAYR

LWObjects

ID_LTEX

LWObjects

ID_LUMI

LWObjects

ID_LWLO

LWObjects

ID_LWO2

LWObjects

ID_LWOB

LWObjects

ID_LWSC

LWObjects

ID_NEGA

LWObjects

ID_NULL

LWObjects

ID_PCHS

LWObjects

ID_PFLT

LWObjects

ID_PNTS

LWObjects

ID_POLS

LWObjects

ID_PTAG

LWObjects

ID_REFL

LWObjects

ID_RFLT

LWObjects

ID_RFOP

LWObjects

ID_RIMG

LWObjects

ID_RIND

LWObjects

ID_RSAN

LWObjects

ID_RTEX

LWObjects

ID_SATR

LWObjects

ID_SDAT

LWObjects

ID_SHDR

LWObjects

ID_SIDE

LWObjects

ID_SMAN

LWObjects

ID_SPEC

LWObjects

ID_SRFS

LWObjects

ID_STCC

LWObjects

ID_STEX

LWObjects

ID_STIL

LWObjects

ID_SURF

LWObjects

ID_TAAS

LWObjects

ID_TAGS

LWObjects

ID_TALP

LWObjects

ID_TAMP

LWObjects

ID_TCLR

LWObjects

ID_TCTR

LWObjects

ID_TEXT

LWObjects

ID_TFAL

LWObjects

ID_TFLG

LWObjects

ID_TFP0

LWObjects

ID_TFP1

LWObjects

ID_TFP2

LWObjects

ID_TFRQ

LWObjects

ID_TIMG

LWObjects

ID_TIP0

LWObjects

ID_TIP1

LWObjects

ID_TIP2

LWObjects

ID_TOPC

LWObjects

ID_TRAN

LWObjects

ID_TREF

LWObjects

ID_TSIZ

LWObjects

ID_TSP0

LWObjects

ID_TSP1

LWObjects

ID_TSP2

LWObjects

ID_TTEX

LWObjects

ID_TVAL

LWObjects

ID_TVEL

LWObjects

ID_TWRP

LWObjects

ID_VDIF

LWObjects

ID_VLUM

LWObjects

ID_VMAD

LWObjects

ID_VMAP

LWObjects

ID_VRFL

LWObjects

ID_VSPC

LWObjects

ID_VTRN

LWObjects

IGetFrame

GLSVfw

IGLCoordinatesUpdateAble

GLCoordinates

IGLInitializable

GLScene

Interface to objects that need initialization<p>

IGLMaterialLibrarySupported

GLMaterial

IGLNotifyAble

BaseClasses

IGLPostShader

GLCustomShader

Used in the TGLPostShaderHolder component.

IGLProgessAble

BaseClasses

IGLShaderDescription

GLCustomShader

This interface describes user shaders, in order to be able to access them via a unified interface. If user shader does not support some option, don't raise an axception, just ignore it.

IGLTextureNotifyAble

GLTexture

IID_IAVIEditStream

GLSVfw

IID_IAVIFile

GLSVfw

IID_IAVIStream

GLSVfw

IID_IAVIStreaming

GLSVfw

IID_IGetFrame

GLSVfw

ILength

VectorGeometry

Computes an integer length Result:=Sqrt(x*x+y*y).

ILength

VectorGeometry

ImageAlphaBottomRightPointColorTransparent

ImageUtils

ImageAlphaFromIntensity

ImageUtils

ImageAlphaInverseLuminance

ImageUtils

ImageAlphaInverseLuminanceSqrt

ImageUtils

ImageAlphaLuminance

ImageUtils

ImageAlphaLuminanceSqrt

ImageUtils

ImageAlphaOpaque

ImageUtils

ImageAlphaSuperBlackTransparent

ImageUtils

ImageAlphaTopLeftPointColorTransparent

ImageUtils

ImageBellFilter

ImageUtils

ImageBoxFilter

ImageUtils

ImageHermiteFilter

ImageUtils

ImageLanczos3Filter

ImageUtils

ImageMitchellFilter

ImageUtils

ImageSplineFilter

ImageUtils

ImageTriangleFilter

ImageUtils

IMSQ_FLAG_INTERLACE

LWObjects

IMSQ_FLAG_LOOP

LWObjects

IncludeFilePath

GLCgShader

Set IncludeFilePath to indicate where to find your include file for your Cg source files. This avoids error from the Cg Compiler when the current directory is not the right path as the shader is being compiled.

IncludeInClipRect

GeometryBB

IncreaseCoherency

MeshUtils

Increases indices coherency wrt vertex caches.<p> The indices parameters is understood as vertex indices of a triangles set, the triangles are reordered to maximize coherency (vertex reuse) over the cacheSize latest indices. This allows higher rendering performance from hardware renderers that implement vertex cache (nVidia GeForce family f.i.), allowing reuse of T&amp;L performance (similar to stripification without the normals issues of strips).<p> This procedure performs a coherency optimization via a greedy hill-climber algorithm (ie. not optimal but fast).

inflate

GLSZLibExApi

inflateEnd

GLSZLibExApi

InflateGLRect

GLCrossPlatform

Increases or decreases the width and height of the specified rectangle.<p> Adds dx units to the left and right ends of the rectangle and dy units to the top and bottom.

inflateInit

GLSZLibExApi

inflateInit2

GLSZLibExApi

inflateInit2_

GLSZLibExApi

inflateInit_

GLSZLibExApi

inflateReset

GLSZLibExApi

inflateSyncPoint

GLSZLibExApi

InformationDlg

GLUtils

Pops up a simple dialog with msg and an Ok button.

infotypeDIGITIZATION_TIME

GLSVfw

infotypeSMPTE_TIME

GLSVfw

InitChunk

Utils3DS

InitCUDA

GLS_CUDA_API

InitCUDAFromLibrary

GLS_CUDA_API

InitCUDART

GLS_CUDA_Runtime

InitCUDARTFromLibrary

GLS_CUDA_Runtime

InitCUFFT

GLS_CUDA_FourierTransform

InitCUFFTFromLibrary

GLS_CUDA_FourierTransform

InitCUTIL

GLS_CUDA_Utility

InitCUTILFromLibrary

GLS_CUDA_Utility

InitFaceArray3DS

Const3DS

InitFreetype

LIBFREETYPE

InitFreetypeFromLibrary

LIBFREETYPE

InitGLSceneColors

GLColor

InitMatArray3DS

Const3DS

InitNoExtras3DS

Const3DS

InitObjectMotion

Utils3DS

InitODE

ODEImport

InitOpenAL

openal

InitOpenCL

GLS_CL

InitOpenCLFromLibrary

GLS_CL

InitOpenGL

OpenGL1x

InitOpenGL

OpenGLAdapter

InitOpenGLFromLibrary

OpenGL1x

InitOpenGLFromLibrary

OpenGLAdapter

InitProcData3DS

Const3DS

InitSmoothArray3DS

Const3DS

InitTextArray3DS

Const3DS

InitTexture

GLCustomShader

InitVertexArray3DS

Const3DS

InitVFlagArray3DS

Const3DS

Initzlib

GLSZLibExApi

InputDlg

GLUtils

Posp a simple dialog with a string input.

InstanceNameStrMax3DS

Const3DS

INSTANCE_NAME

Const3DS

Int

NewtonImport

int

LIBPNG

int

GLSVfw

INT16

GLSJPG

INT32

GLSJPG

INT32PTR

GLSJPG

int8array

GLSJPG

InternalFormatToOpenGLFormat

GLTextureFormat

Give a openGL texture format from GLScene texture format.

INTERPCT

Const3DS

InterpolateCombined

VectorGeometry

InterpolateCombinedFast

VectorGeometry

InterpolateCombinedFastPower

VectorGeometry

InterpolateCombinedSafe

VectorGeometry

InterpolateExp

VectorGeometry

InterpolateLn

VectorGeometry

InterpolatePower

VectorGeometry

There functions that do the same as "Lerp", but add some distortions.

InterpolateSin

VectorGeometry

Only valid where Delta belongs to [0..1]

InterpolateSinAlt

VectorGeometry

"Alt" functions are valid everywhere

InterpolateTan

VectorGeometry

IntersectAABBs

GeometryBB

IntersectAABBsAbsolute

GeometryBB

IntersectAABBsAbsoluteXY

GeometryBB

IntersectAABBsAbsoluteXZ

GeometryBB

IntersectCubes

GLCollision

Returns true when the bounding box cubes does intersect the other.<p> Also true when the one cube does contain the other completely.

IntersectGLRect

GLCrossPlatform

IntersectLinePlane

VectorGeometry

Compute the intersection point "res" of a line with a plane.<p> Return value:<ul> <li>0 : no intersection, line parallel to plane <li>1 : res is valid <li>-1 : line is inside plane </ul><br> Adapted from:<br> E.Hartmann, Computeruntersttzte Darstellende Geometrie, B.G. Teubner Stuttgart 1988

IntersectSphereBox

VectorGeometry

Compute intersection between a Sphere and a box.<p> Up, Direction and Right must be normalized! Use CubDepht, CubeHeight and CubeWidth to scale TGLCube.

IntersectTriangleBox

VectorGeometry

Compute intersection between a triangle and a box.<p> Returns True if an intersection was found.

IntPercentageMax3DS

Const3DS

IntPower

VectorGeometry

Raise base to an integer.

intptr_t

GLS_CL_Platform

INT_PERCENTAGE

Const3DS

INVALID_CUFFT_HANDLE

GLS_CUDA_FourierTransform

INVALID_MODULEHANDLE_VALUE

GLSModuleLoader

InvertMatrix

VectorGeometry

Finds the inverse of a 3x3 matrix;

InvertMatrix

VectorGeometry

Finds the inverse of a 4x4 matrix

InvertTrianglesWinding

MeshUtils

Inverts the triangles winding (vertex order).

InvokeInfoForm

GLScene

IPersistentObject

PersistentClasses

Interface for persistent objects.<p> This interface does not really allow polymorphic persistence, but is rather intended as a way to unify persistence calls for iterators.

IsCgProfileSupported

GLCgShader

IsChunk

Const3DS

IsColinear

VectorGeometry

Returns true if both vector are colinear

IsColinear

VectorGeometry

Returns true if both vector are colinear

IsColinear

VectorGeometry

Returns true if both vector are colinear

IsCompressedFormat

GLTextureFormat

True if texture compressed.

IsCompressedFormat

GLTextureFormat

IsCUDAInitialized

GLS_CUDA_API

IsCUDARTInitialized

GLS_CUDA_Runtime

IsCUFFTInitialized

GLS_CUDA_FourierTransform

IsCUTILInitialized

GLS_CUDA_Utility

IsDepthFormat

GLTextureFormat

True if depth texture.

IsDepthFormat

GLTextureFormat

IsDesignTime

GLCrossPlatform

IsDirectoryWriteable

GLCrossPlatform

Determine if the directory is writable.<p>

IsFloatFormat

GLTextureFormat

IsFloatFormat

GLTextureFormat

True if texture format is float.

IsFogEnabled

GLCustomShader

IsFormatSupported

GLTextureFormat

True if texture format is supported by hardware or software.

IsFreetypeInitialized

LIBFREETYPE

IShaderParameter

GLSLParameter

IsInCube

VectorGeometry

Returns True if p is in the cube defined by d.

IsInCube

VectorGeometry

IsInRange

VectorGeometry

Returns True if x is in [a; b]

IsInRange

VectorGeometry

IsInRect

GLGui

IsKeyDown

GLKeyboard

Check if the given virtual key is down.<p> This function is just a wrapper for GetAsyncKeyState.

IsKeyDown

GLKeyboard

Check if the key corresponding to the given Char is down.<p> The character is mapped to the <i>main keyboard</i> only, and not to the numeric keypad.<br> The Shift/Ctrl/Alt state combinations that may be required to type the character are ignored (ie. 'a' is equivalent to 'A', and on my french keyboard, '5' = '(' = '[' since they all share the same physical key).

IsLineIntersectQuad

VectorGeometry

Returns true if line intersect ABCD quad. Quad have to be flat and convex

IsLineIntersectTriangle

VectorGeometry

Returns true if line intersect ABC triangle.

IsMainThread

GLContext

IsMesaGL

OpenGL1x

IsMesaGL

OpenGLAdapter

IsODEInitialized

ODEImport

IsOpenCLInitialized

GLS_CL

IsOpenGLInitialized

OpenGL1x

IsOpenGLInitialized

OpenGLAdapter

IsOpenGLLoaded

OpenGLAdapter

IsOpenGLLoaded

OpenGL1x

IsOpenGLVersionMet

OpenGL1x

IsPointInPolygon

VectorGeometry

IsPowerOf2

GLUtils

Returns True if value is a true power of two

ISqrt

VectorGeometry

Computes an integer sqrt approximation.<p>

IsServiceContextAvaible

GLContext

IsSubComponent

GLCrossPlatform

IsTargetSupported

GLTextureFormat

IsTargetSupported

GLTextureFormat

True if texture target supported.

IsTargetSupportMipmap

GLTextureFormat

IsTargetSupportMipmap

GLTextureFormat

IsVersionMet

OpenGLAdapter

IsVersionMet

OpenGL1x

IsVolumeClipped

VectorGeometry

Determines if volume is clipped or not

IsVolumeClipped

VectorGeometry

IsVolumeClipped

VectorGeometry

JCOEF

GLSJPG

JCOEF_PTR

GLSJPG

JDIMENSION

GLSJPG

jmp_buf

LIBPNG

jmp_bufp

LIBPNG

JMSG_LENGTH_MAX

GLSJPG

JMSG_STR_PARM_MAX

GLSJPG

JOCTET

GLSJPG

JOCTETPTR

GLSJPG

JOCTET_FIELD

GLSJPG

JOCTET_FIELD_PTR

GLSJPG

JointLibraryDLL

NewtonImport_JointLibrary

JOY_AXIS_THRESHOLD

GLSDL

JPEGLIBCallback

GLSJPG

jpeg_abort

GLSJPG

JPEG_APP0

GLSJPG

jpeg_calc_output_dimensions

GLSJPG

JPEG_COM

GLSJPG

jpeg_common_struct

GLSJPG

jpeg_component_info

GLSJPG

jpeg_component_info_ptr

GLSJPG

jpeg_compress_struct

GLSJPG

jpeg_consume_input

GLSJPG

jpeg_CreateCompress

GLSJPG

jpeg_CreateDecompress

GLSJPG

jpeg_decompress_struct

GLSJPG

jpeg_destination_mgr

GLSJPG

jpeg_destination_mgr_ptr

GLSJPG

jpeg_destroy

GLSJPG

jpeg_destroy_decompress

GLSJPG

JPEG_EOI

GLSJPG

jpeg_error_mgr

GLSJPG

jpeg_error_mgr_ptr

GLSJPG

jpeg_finish_compress

GLSJPG

jpeg_finish_decompress

GLSJPG

jpeg_finish_output

GLSJPG

jpeg_has_multiple_scans

GLSJPG

JPEG_HEADER_OK

GLSJPG

JPEG_HEADER_TABLES_ONLY

GLSJPG

JPEG_LIB_VERSION

GLSJPG

jpeg_marker_parser_method

GLSJPG

jpeg_marker_reader

GLSJPG

jpeg_marker_reader_ptr

GLSJPG

jpeg_memory_mgr

GLSJPG

jpeg_memory_mgr_ptr

GLSJPG

jpeg_progress_mgr

GLSJPG

jpeg_progress_mgr_ptr

GLSJPG

JPEG_REACHED_EOI

GLSJPG

JPEG_REACHED_SOS

GLSJPG

jpeg_read_header

GLSJPG

jpeg_read_raw_data

GLSJPG

jpeg_read_scanlines

GLSJPG

jpeg_resync_to_restart

GLSJPG

JPEG_ROW_COMPLETED

GLSJPG

JPEG_RST0

GLSJPG

JPEG_SCAN_COMPLETED

GLSJPG

jpeg_set_colorspace

GLSJPG

jpeg_set_defaults

GLSJPG

jpeg_set_quality

GLSJPG

jpeg_simple_progression

GLSJPG

jpeg_source_mgr

GLSJPG

jpeg_source_mgr_ptr

GLSJPG

jpeg_start_compress

GLSJPG

jpeg_start_decompress

GLSJPG

jpeg_start_output

GLSJPG

jpeg_stdio_dest

GLSJPG

jpeg_stdio_src

GLSJPG

jpeg_std_error

GLSJPG

JPEG_SUSPENDED

GLSJPG

jpeg_write_scanlines

GLSJPG

JPOOL_IMAGE

GLSJPG

JPOOL_PERMANENT

GLSJPG

JQUANT_TBL

GLSJPG

JQUANT_TBL_ptr

GLSJPG

JSAMPARRAY

GLSJPG

JSAMPIMAGE

GLSJPG

JSAMPLE

GLSJPG

JSAMPLE_ARRAY

GLSJPG

JSAMPLE_PTR

GLSJPG

JSAMPROW

GLSJPG

JSAMPROW_ARRAY

GLSJPG

JSAMPROW_PTR

GLSJPG

JSAMP_ARRAY

GLSJPG

jTArray

GLSJPG

jTOctet

GLSJPG

jTRow

GLSJPG

jTSample

GLSJPG

J_COLOR_SPACE

GLSJPG

j_common_ptr

GLSJPG

j_compress_ptr

GLSJPG

J_DCT_METHOD

GLSJPG

j_decompress_ptr

GLSJPG

J_DITHER_MODE

GLSJPG

kBrushes

Q3BSP

kBrushSides

Q3BSP

kEntities

Q3BSP

KeyboardNotifyWheelMoved

GLKeyboard

Use this procedure to notify a wheel movement and have it resurfaced as key stroke.<p> Honoured by IsKeyDown and KeyPressed

KeyNameToVirtualKeyCode

GLKeyboard

Converts a key name to its virtual key code.<p> The comparison is **NOT** case-sensitive, if no match is found, returns -1.<p> The name is expressed using the locale windows options, except for mouse buttons which are translated to 'LBUTTON', 'MBUTTON' and 'RBUTTON'.

KeyPressed

GLKeyboard

Returns the first pressed key whose virtual key code is >= to minVkCode.<p> If no key is pressed, the return value is -1, this function does NOT wait for user input.<br> If you don't care about multiple key presses, just don't use the parameter.

KeyUsesBias3DS

Const3DS

KeyUsesCont3DS

Const3DS

KeyUsesEaseFrom3DS

Const3DS

KeyUsesEaseTo3DS

Const3DS

KeyUsesTension3DS

Const3DS

kFaces

Q3BSP

KFBiasMax3DS

Const3DS

KFBiasMin3DS

Const3DS

KfBlurBranch3DS

Const3DS

KFContinuityMax3DS

Const3DS

KFContinuityMin3DS

Const3DS

KFCURTIME

Const3DS

KFDATA

Const3DS

KFEaseFromMax3DS

Const3DS

KFEaseFromMin3DS

Const3DS

KFEaseToMax3DS

Const3DS

KFEaseToMin3DS

Const3DS

KfFastNode3DS

Const3DS

KFHDR

Const3DS

KFHdrStrMax3DS

Const3DS

KfHideNode3DS

Const3DS

KfMorphMtl3DS

Const3DS

KfMorphOb3DS

Const3DS

KfMotionBlur3DS

Const3DS

KfNodeAutoSmooth3DS

Const3DS

KfNodeFrozen3DS

Const3DS

KfNodeHasPath3DS

Const3DS

KfNodeOff3DS

Const3DS

KFSEG

Const3DS

KFTensionMax3DS

Const3DS

KFTensionMin3DS

Const3DS

kLeafBrushes

Q3BSP

kLeafFaces

Q3BSP

kLeafs

Q3BSP

kLightmaps

Q3BSP

kLightVolumes

Q3BSP

kMaxLumps

Q3BSP

kMeshVerts

Q3BSP

kModels

Q3BSP

KMOD_ALT

GLSDL

KMOD_CAPS

GLSDL

KMOD_CTRL

GLSDL

KMOD_LALT

GLSDL

KMOD_LCTRL

GLSDL

KMOD_LMETA

GLSDL

KMOD_LSHIFT

GLSDL

KMOD_META

GLSDL

KMOD_MODE

GLSDL

KMOD_NONE

GLSDL

KMOD_NUM

GLSDL

KMOD_RALT

GLSDL

KMOD_RCTRL

GLSDL

KMOD_RESERVED

GLSDL

KMOD_RMETA

GLSDL

KMOD_RSHIFT

GLSDL

KMOD_SHIFT

GLSDL

kNodes

Q3BSP

KNoID

Const3DS

kPlanes

Q3BSP

kShaders

Q3BSP

kTextures

Q3BSP

kVertices

Q3BSP

kVisData

Q3BSP

LayerFogBgnd

Const3DS

LAYER_FOG

Const3DS

Lerp

VectorGeometry

Calculates linear interpolation between start and stop at point t

libEGL

OpenGLTokens

libGLES2

OpenGLTokens

LibHandle

openal

LibMaterialPicker

FLibMaterialPicker

LibMaterialPicker

FLibMaterialPickerLCL

LibName

GLSDL

LibOpenCL

GLS_CL

LibPng13

LIBPNG

LIBPNG_VERSION

LIBPNG

libz

GLSZLibExApi

LIGHT_NODE_TAG

Const3DS

Linear_Interpolate

GLPerlinBase

LineLen

GLFileOBJ

LineLineDistance

VectorGeometry

Computes the closest distance between two lines.

LIN_COLOR_24

Const3DS

LIN_COLOR_F

Const3DS

listtypeAVIHEADER

GLSVfw

listtypeAVIMOVIE

GLSVfw

listtypeAVIRECORD

GLSVfw

listtypeSTREAMHEADER

GLSVfw

lkPrefix

GLSLog

llMax

GLSLog

llMedium

GLSLog

llMessageLimit

GLSLog

llMin

GLSLog

LMAGIC

Const3DS

LnXP1

VectorGeometry

Return ln(1 + X), accurate for X near 0.

LoadAnsiStringFromFile

GLUtils

Returns the content of "filename".

LoadComponentFromFile

GLUtils

Loads component from a file.

LoadLW0FromStream

LWObjects

LoadLWOFromFile

LWObjects

LoadModule

GLSModuleLoader

LoadModuleEx

GLSModuleLoader

LoadOpenGL

OpenGL1x

LoadOpenGL

OpenGLAdapter

LoadOpenGLFromLibrary

OpenGLAdapter

LoadOpenGLFromLibrary

OpenGL1x

LoadQ3Anims

Q3MD3

LoadQ3Anims

Q3MD3

LoadQ3Skin

Q3MD3

LoadRGBEpixels

RGBE

LoadRLEpixels

RGBE

Log10

VectorGeometry

Log base 10 of X

Log2

VectorGeometry

Log base 2 of X

Log2

VectorGeometry

Log base 2 of X

logging_fn

GLS_CL

LogN

VectorGeometry

Log base N of X

Long

NewtonImport

LONG

GLSVfw

Long_double

NewtonImport

LoShadowBiasMin3DS

Const3DS

LOWPASS_DEFAULT_GAIN

openal

LOWPASS_DEFAULT_GAINHF

openal

LOWPASS_MAX_GAIN

openal

LOWPASS_MAX_GAINHF

openal

LOWPASS_MIN_GAIN

openal

LOWPASS_MIN_GAINHF

openal

LO_SHADOW_BIAS

Const3DS

L_TARGET_NODE_TAG

Const3DS

M3DMAGIC

Const3DS

M3D_KFVERSION

Const3DS

M3D_VERSION

Const3DS

MakeAffineDblVector

VectorGeometry

MAKEAVICKID

GLSVfw

MakeDblVector

VectorGeometry

MAKEMUSICPOS

Bass

MakeParallelProjectionMatrix

VectorGeometry

Creates a parallel projection matrix.<p> Transformed points will projected on the plane along the specified direction.

MakePoint

VectorGeometry

MakePoint

VectorGeometry

MakePoint

VectorGeometry

MakeReflectionMatrix

VectorGeometry

Builds a reflection matrix for the given plane.<p> Reflection matrix allow implementing planar reflectors in OpenGL (mirrors).

MakeShadowMatrix

VectorGeometry

Creates a shadow projection matrix.<p> Shadows will be projected onto the plane defined by planePoint and planeNormal, from lightPos.

MakeSubComponent

GLCrossPlatform

MakeTriangleAdjacencyList

MeshUtils

Create list of indices of triangles with adjacency from triangle list

MakeVector

VectorGeometry

MakeVector

VectorGeometry

MakeVector

VectorGeometry

MakeVector

VectorGeometry

MARK_NODE

Const3DS

MasterScaleMin3DS

Const3DS

MASTER_SCALE

Const3DS

MatACubicAMax3DS

Const3DS

MatACubicAMin3DS

Const3DS

MatACubicFMin3DS

Const3DS

MaterialEditorForm

FMaterialEditorFormLCL

MaterialEditorForm

FMaterialEditorForm

MATMAGIC

Const3DS

MatMapNameStrMax3DS

Const3DS

MatNameStrMax3DS

Const3DS

MatrixDecompose

VectorGeometry

Decompose a non-degenerated 4x4 transformation matrix into the sequence of transformations that produced it.<p> Modified by ml then eg, original Author: Spencer W. Thomas, University of Michigan<p> The coefficient of each transformation is returned in the corresponding element of the vector Tran.<p> Returns true upon success, false if the matrix is singular.

MatrixDeterminant

VectorGeometry

Determinant of a 4x4 matrix

MatrixDeterminant

VectorGeometry

Determinant of a 3x3 matrix

MatrixEquals

VectorGeometry

MatrixEquals

VectorGeometry

MatrixEquals

VectorGeometry

MatrixEquals

VectorGeometry

MatrixEquals

VectorGeometry

MatrixEquals

VectorGeometry

MatrixEquals

VectorGeometry

MatrixEquals

VectorGeometry

MatrixEquals

VectorGeometry

MatrixEquals

VectorGeometry

MatrixInvert

VectorGeometry

MatrixInvert

VectorGeometry

MatrixLerp

VectorGeometry

This is used for interpolating between 2 matrices. The result is used to reposition the model parts each frame.

MatrixMultiply

VectorGeometry

Multiplies two 3x3 matrices

MatrixMultiply

VectorGeometry

Multiplies two 4x4 matrices

MatrixMultiply

VectorGeometry

Multiplies M1 by M2 and places result in MResult

MatShadingMax3DS

Const3DS

MatShadingMin3DS

Const3DS

MAT_ACUBIC

Const3DS

MAT_ADDITIVE

Const3DS

MAT_AMBIENT

Const3DS

MAT_BUMPMAP

Const3DS

MAT_BUMPMASK

Const3DS

MAT_BUMP_PERCENT

Const3DS

MAT_DECAL

Const3DS

MAT_DIFFUSE

Const3DS

MAT_ENTRY

Const3DS

MAT_FACEMAP

Const3DS

MAT_MAPNAME

Const3DS

MAT_MAP_ANG

Const3DS

MAT_MAP_BCOL

Const3DS

MAT_MAP_COL1

Const3DS

MAT_MAP_COL2

Const3DS

MAT_MAP_GCOL

Const3DS

MAT_MAP_RCOL

Const3DS

MAT_MAP_TEXBLUR

Const3DS

MAT_MAP_TEXBLUR_OLD

Const3DS

MAT_MAP_TILING

Const3DS

MAT_MAP_TILINGOLD

Const3DS

MAT_MAP_UOFFSET

Const3DS

MAT_MAP_USCALE

Const3DS

MAT_MAP_VOFFSET

Const3DS

MAT_MAP_VSCALE

Const3DS

MAT_NAME

Const3DS

MAT_OPACMAP

Const3DS

MAT_OPACMASK

Const3DS

MAT_PHONGSOFT

Const3DS

MAT_REFBLUR

Const3DS

MAT_REFLMAP

Const3DS

MAT_REFLMASK

Const3DS

MAT_SELFIMAP

Const3DS

MAT_SELFIMASK

Const3DS

MAT_SELF_ILLUM

Const3DS

MAT_SELF_ILPCT

Const3DS

MAT_SHADING

Const3DS

MAT_SHIN2PCT

Const3DS

MAT_SHIN3PCT

Const3DS

MAT_SHININESS

Const3DS

MAT_SHINMAP

Const3DS

MAT_SHINMASK

Const3DS

MAT_SPECMAP

Const3DS

MAT_SPECMASK

Const3DS

MAT_SPECULAR

Const3DS

MAT_SUPERSMP

Const3DS

MAT_SXP_BUMP_DATA

Const3DS

MAT_SXP_BUMP_MASKDATA

Const3DS

MAT_SXP_OPAC_DATA

Const3DS

MAT_SXP_OPAC_MASKDATA

Const3DS

MAT_SXP_REFL_MASKDATA

Const3DS

MAT_SXP_SELFI_DATA

Const3DS

MAT_SXP_SELFI_MASKDATA

Const3DS

MAT_SXP_SHIN_DATA

Const3DS

MAT_SXP_SHIN_MASKDATA

Const3DS

MAT_SXP_SPEC_DATA

Const3DS

MAT_SXP_SPEC_MASKDATA

Const3DS

MAT_SXP_TEXT2_DATA

Const3DS

MAT_SXP_TEXT2_MASKDATA

Const3DS

MAT_SXP_TEXT_DATA

Const3DS

MAT_SXP_TEXT_MASKDATA

Const3DS

MAT_TEX2MAP

Const3DS

MAT_TEX2MASK

Const3DS

MAT_TEXMAP

Const3DS

MAT_TEXMASK

Const3DS

MAT_TRANSPARENCY

Const3DS

MAT_TWO_SIDE

Const3DS

MAT_USE_REFBLUR

Const3DS

MAT_USE_XPFALL

Const3DS

MAT_WIRE

Const3DS

MAT_WIREABS

Const3DS

MAT_WIRESIZE

Const3DS

MAT_XPFALL

Const3DS

MAT_XPFALLIN

Const3DS

MaxAbsXYZComponent

VectorGeometry

Returns the max of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored).

MaxColorAttachments

GLFBO

MaxComp

VectorGeometry

MaxDouble

VectorGeometry

MaxExtended

VectorGeometry

MaxFloat

VectorGeometry

MaxFloat

VectorGeometry

MaxFloat

VectorGeometry

Returns the maximum value of the array.

MaxFloat

VectorGeometry

MaxFloat

VectorGeometry

Returns the maximum of given values.

MaxFloat

VectorGeometry

MaxFloat

VectorGeometry

MaxFloat

VectorGeometry

MaxInteger

VectorGeometry

MaxInteger

VectorGeometry

MaxInteger

VectorGeometry

MaxInteger

VectorGeometry

MAXJSAMPLE

GLSJPG

MaxSingle

VectorGeometry

MaxUserClasses

ODEImport

MaxVector

VectorGeometry

MaxVector

VectorGeometry

Replace components of v with the max of v or v1 component.<p> Maximum is computed per component.

MaxVideoModes

GLScreen

MaxXYZComponent

VectorGeometry

MaxXYZComponent

VectorGeometry

Returns the max of the X, Y and Z components of a vector (W is ignored).

MAX_AXES

GLSDL

MAX_BUTTONS

GLSDL

MAX_COMPONENTS

GLSJPG

MAX_COMPS_IN_SCAN

GLSJPG

MAX_HARDWARE_LIGHT

GLState

MAX_HARDWARE_TEXTURE_UNIT

GLState

MAX_HARDWARE_UNIFORM_BUFFER_BINDING

GLState

MAX_JOYSTICKS

GLSDL

MAX_MATRIX_STACK_DEPTH

GLPipelineTransformation

MAX_MD2_FRAMES

TypesMD2

MAX_MD2_SKINNAME

TypesMD2

MAX_MD2_SKINS

TypesMD2

MAX_MD2_TRIANGLES

TypesMD2

MAX_MD2_VERTICES

TypesMD2

MAX_MS3D_GROUPS

TypesMS3D

MAX_MS3D_JOINTS

TypesMS3D

MAX_MS3D_KEYFRAMES

TypesMS3D

MAX_MS3D_MATERIALS

TypesMS3D

MAX_MS3D_TRIANGLES

TypesMS3D

MAX_MS3D_VERTICES

TypesMS3D

MAX_OBJECT_STACK_DEPTH

GLSelection

MAX_SAMP_FACTOR

GLSJPG

MAX_SHADER_LIGHT

GLState

MAX_TEXTURES

Q3BSP

MCIWndCanConfig

GLSVfw

MCIWndCanEject

GLSVfw

MCIWndCanPlay

GLSVfw

MCIWndCanRecord

GLSVfw

MCIWndCanSave

GLSVfw

MCIWndCanWindow

GLSVfw

MCIWndChangeStyles

GLSVfw

MCIWndClose

GLSVfw

MCIWndCreate

GLSVfw

MCIWndCreateA

GLSVfw

MCIWndCreateW

GLSVfw

MCIWndDestroy

GLSVfw

MCIWndEject

GLSVfw

MCIWndEnd

GLSVfw

MCIWNDF_NOAUTOSIZEMOVIE

GLSVfw

MCIWNDF_NOAUTOSIZEWINDOW

GLSVfw

MCIWNDF_NOERRORDLG

GLSVfw

MCIWNDF_NOMENU

GLSVfw

MCIWNDF_NOOPEN

GLSVfw

MCIWNDF_NOPLAYBAR

GLSVfw

MCIWNDF_NOTIFYALL

GLSVfw

MCIWNDF_NOTIFYANSI

GLSVfw

MCIWNDF_NOTIFYERROR

GLSVfw

MCIWNDF_NOTIFYMEDIA

GLSVfw

MCIWNDF_NOTIFYMEDIAA

GLSVfw

MCIWNDF_NOTIFYMEDIAW

GLSVfw

MCIWNDF_NOTIFYMODE

GLSVfw

MCIWNDF_NOTIFYPOS

GLSVfw

MCIWNDF_NOTIFYSIZE

GLSVfw

MCIWNDF_RECORD

GLSVfw

MCIWNDF_SHOWALL

GLSVfw

MCIWNDF_SHOWMODE

GLSVfw

MCIWNDF_SHOWNAME

GLSVfw

MCIWNDF_SHOWPOS

GLSVfw

MCIWndGetActiveTimer

GLSVfw

MCIWndGetAlias

GLSVfw

MCIWndGetDest

GLSVfw

MCIWndGetDevice

GLSVfw

MCIWndGetDeviceID

GLSVfw

MCIWndGetEnd

GLSVfw

MCIWndGetError

GLSVfw

MCIWndGetFileName

GLSVfw

MCIWndGetInactiveTimer

GLSVfw

MCIWndGetLength

GLSVfw

MCIWndGetMode

GLSVfw

MCIWndGetPalette

GLSVfw

MCIWndGetPosition

GLSVfw

MCIWndGetPositionString

GLSVfw

MCIWndGetRepeat

GLSVfw

MCIWndGetSource

GLSVfw

MCIWndGetSpeed

GLSVfw

MCIWndGetStart

GLSVfw

MCIWndGetStyles

GLSVfw

MCIWndGetTimeFormat

GLSVfw

MCIWndGetVolume

GLSVfw

MCIWndGetZoom

GLSVfw

MCIWndHome

GLSVfw

MCIWNDM_CAN_CONFIG

GLSVfw

MCIWNDM_CAN_EJECT

GLSVfw

MCIWNDM_CAN_PLAY

GLSVfw

MCIWNDM_CAN_RECORD

GLSVfw

MCIWNDM_CAN_SAVE

GLSVfw

MCIWNDM_CAN_WINDOW

GLSVfw

MCIWNDM_CHANGESTYLES

GLSVfw

MCIWNDM_EJECT

GLSVfw

MCIWNDM_GETACTIVETIMER

GLSVfw

MCIWNDM_GETALIAS

GLSVfw

MCIWNDM_GETDEVICE

GLSVfw

MCIWNDM_GETDEVICEA

GLSVfw

MCIWNDM_GETDEVICEID

GLSVfw

MCIWNDM_GETDEVICEW

GLSVfw

MCIWNDM_GETEND

GLSVfw

MCIWNDM_GETERROR

GLSVfw

MCIWNDM_GETERRORA

GLSVfw

MCIWNDM_GETERRORW

GLSVfw

MCIWNDM_GETFILENAME

GLSVfw

MCIWNDM_GETFILENAMEA

GLSVfw

MCIWNDM_GETFILENAMEW

GLSVfw

MCIWNDM_GETINACTIVETIMER

GLSVfw

MCIWNDM_GETLENGTH

GLSVfw

MCIWNDM_GETMODE

GLSVfw

MCIWNDM_GETMODEA

GLSVfw

MCIWNDM_GETMODEW

GLSVfw

MCIWNDM_GETPALETTE

GLSVfw

MCIWNDM_GETPOSITION

GLSVfw

MCIWNDM_GETPOSITIONA

GLSVfw

MCIWNDM_GETPOSITIONW

GLSVfw

MCIWNDM_GETREPEAT

GLSVfw

MCIWNDM_GETSPEED

GLSVfw

MCIWNDM_GETSTART

GLSVfw

MCIWNDM_GETSTYLES

GLSVfw

MCIWNDM_GETTIMEFORMAT

GLSVfw

MCIWNDM_GETTIMEFORMATA

GLSVfw

MCIWNDM_GETTIMEFORMATW

GLSVfw

MCIWNDM_GETVOLUME

GLSVfw

MCIWNDM_GETZOOM

GLSVfw

MCIWNDM_GET_DEST

GLSVfw

MCIWNDM_GET_SOURCE

GLSVfw

MCIWNDM_NEW

GLSVfw

MCIWNDM_NEWA

GLSVfw

MCIWNDM_NEWW

GLSVfw

MCIWNDM_NOTIFYERROR

GLSVfw

MCIWNDM_NOTIFYMEDIA

GLSVfw

MCIWNDM_NOTIFYMODE

GLSVfw

MCIWNDM_NOTIFYPOS

GLSVfw

MCIWNDM_NOTIFYSIZE

GLSVfw

MCIWNDM_OPEN

GLSVfw

MCIWNDM_OPENA

GLSVfw

MCIWNDM_OPENINTERFACE

GLSVfw

MCIWNDM_OPENW

GLSVfw

MCIWNDM_PALETTEKICK

GLSVfw

MCIWNDM_PLAYFROM

GLSVfw

MCIWNDM_PLAYREVERSE

GLSVfw

MCIWNDM_PLAYTO

GLSVfw

MCIWNDM_PUT_DEST

GLSVfw

MCIWNDM_PUT_SOURCE

GLSVfw

MCIWNDM_REALIZE

GLSVfw

MCIWNDM_RETURNSTRING

GLSVfw

MCIWNDM_RETURNSTRINGA

GLSVfw

MCIWNDM_RETURNSTRINGW

GLSVfw

MCIWNDM_SENDSTRING

GLSVfw

MCIWNDM_SENDSTRINGA

GLSVfw

MCIWNDM_SENDSTRINGW

GLSVfw

MCIWNDM_SETACTIVETIMER

GLSVfw

MCIWNDM_SETINACTIVETIMER

GLSVfw

MCIWNDM_SETOWNER

GLSVfw

MCIWNDM_SETPALETTE

GLSVfw

MCIWNDM_SETREPEAT

GLSVfw

MCIWNDM_SETSPEED

GLSVfw

MCIWNDM_SETTIMEFORMAT

GLSVfw

MCIWNDM_SETTIMEFORMATA

GLSVfw

MCIWNDM_SETTIMEFORMATW

GLSVfw

MCIWNDM_SETTIMERS

GLSVfw

MCIWNDM_SETVOLUME

GLSVfw

MCIWNDM_SETZOOM

GLSVfw

MCIWNDM_VALIDATEMEDIA

GLSVfw

MCIWndNew

GLSVfw

MCIWndOpen

GLSVfw

MCIWndOpenDialog

GLSVfw

MCIWNDOPENF_NEW

GLSVfw

MCIWndOpenInterface

GLSVfw

MCIWndPaletteKick

GLSVfw

MCIWndPause

GLSVfw

MCIWndPlay

GLSVfw

MCIWndPlayFrom

GLSVfw

MCIWndPlayFromTo

GLSVfw

MCIWndPlayReverse

GLSVfw

MCIWndPlayTo

GLSVfw

MCIWndPutDest

GLSVfw

MCIWndPutSource

GLSVfw

MCIWndRealize

GLSVfw

MCIWndRecord

GLSVfw

MCIWndRegisterClass

GLSVfw

MCIWndResume

GLSVfw

MCIWndReturnString

GLSVfw

MCIWndSave

GLSVfw

MCIWndSaveDialog

GLSVfw

MCIWndSeek

GLSVfw

MCIWndSendString

GLSVfw

MCIWndSetActiveTimer

GLSVfw

MCIWndSetInactiveTimer

GLSVfw

MCIWndSetOwner

GLSVfw

MCIWndSetPalette

GLSVfw

MCIWndSetRepeat

GLSVfw

MCIWndSetSpeed

GLSVfw

MCIWndSetTimeFormat

GLSVfw

MCIWndSetTimers

GLSVfw

MCIWndSetVolume

GLSVfw

MCIWndSetZoom

GLSVfw

MCIWndSM

GLSVfw

MCIWndStep

GLSVfw

MCIWndStop

GLSVfw

MCIWndUseFrames

GLSVfw

MCIWndUseTime

GLSVfw

MCIWndValidateMedia

GLSVfw

MCIWND_END

GLSVfw

MCIWND_START

GLSVfw

MCIWND_WINDOW_CLASS

GLSVfw

MC_UnCompressQuat

FileGL2

MDATA

Const3DS

MDCFILE_IDENTITY

TypesMDC

MDCFILE_VERSION

TypesMDC

MDC_BASEVERTEX_FACTOR

TypesMDC

MDC_COMPVERTEX_FACTOR

TypesMDC

MESH_COLOR

Const3DS

MESH_MATRIX

Const3DS

MESH_TEXTURE_INFO

Const3DS

MESH_VERSION

Const3DS

MidTexPoint

VectorGeometry

MinAbsXYZComponent

VectorGeometry

Returns the min of the Abs(X), Abs(Y) and Abs(Z) components of a vector (W is ignored).

MinComp

VectorGeometry

MinDouble

VectorGeometry

MinExtended

VectorGeometry

MinFloat

VectorGeometry

MinFloat

VectorGeometry

MinFloat

VectorGeometry

Returns the minimum of given values.

MinFloat

VectorGeometry

MinFloat

VectorGeometry

Returns the minimum value of the array.

MinFloat

VectorGeometry

MinFloat

VectorGeometry

MinFloat

VectorGeometry

MinInteger

VectorGeometry

MinInteger

VectorGeometry

MinInteger

VectorGeometry

MinInteger

VectorGeometry

MinPositiveCoef

Polynomials

Finds the minimum positive coef in the array in aMin.<p> Returns true if such an item was found.

MinSingle

VectorGeometry

MinusXVector

VectorGeometry

MinusYVector

VectorGeometry

MinusZVector

VectorGeometry

MinVector

VectorGeometry

Replace components of v with the min of v or v1 component.<p> Minimum is computed per component.

MinVector

VectorGeometry

MinXYZComponent

VectorGeometry

Returns the min of the X, Y and Z components of a vector (W is ignored).

MinXYZComponent

VectorGeometry

MKFOURCC

GLSVfw

MLIBMAGIC

Const3DS

mmioFOURCC

GLSVfw

MorphSmoothMax3DS

Const3DS

MorphSmoothMin3DS

Const3DS

MorphTrackStrMax3DS

Const3DS

MORPH_SMOOTH

Const3DS

MORPH_TRACK_TAG

Const3DS

MORPH_TRACK_TAG_KEY

Const3DS

MoveObjectAround

VectorGeometry

Extracted from Camera.MoveAroundTarget(pitch, turn).

MRT_BUFFERS

GLContext

MSF_TO_FRAMES

GLSDL

MshMatGroupMin3DS

Const3DS

MshMatGroupStrMax3DS

Const3DS

MSH_BOXMAP

Const3DS

MSH_MAT_GROUP

Const3DS

MSH_MAT_GROUP_ENTRY

Const3DS

M_BEVEL

Const3DS

M_FIT

Const3DS

M_SCALE

Const3DS

M_TEETER

Const3DS

M_TWIST

Const3DS

NamedObjectStrMax3DS

Const3DS

NAMED_OBJECT

Const3DS

NCameraFocMax3DS

Const3DS

NCameraFocMin3DS

Const3DS

NCameraFOVMax3DS

Const3DS

NCameraFOVMin3DS

Const3DS

NChar

NewtonImport

nearCallBack

GLODEManager

ODE nearCallBack, throws near callback to the collision procedure of the ODE manager linked by the Data pointer.

NegateVector

VectorGeometry

Negates the vector

NegateVector

VectorGeometry

Negates the vector

NegateVector

VectorGeometry

Negates the vector

NETWORK_VIEW

Const3DS

NewtonAddCollisionReference

NewtonImport

NewtonAllocMemory

NewtonImport

NewtonApplyForceAndTorque

NewtonImport

NewtonBallCallBack

NewtonImport

NewtonBallGetJointAngle

NewtonImport

NewtonBallGetJointForce

NewtonImport

NewtonBallGetJointOmega

NewtonImport

NewtonBallSetConeLimits

NewtonImport

NewtonBallSetUserCallback

NewtonImport

NewtonBodyAddBuoyancyForce

NewtonImport

NewtonBodyAddForce

NewtonImport

NewtonBodyAddImpulse

NewtonImport

NewtonBodyAddTorque

NewtonImport

NewtonBodyApplyImpulseArray

NewtonImport

NewtonBodyCalculateInverseDynamicsForce

NewtonImport

NewtonBodyDestructor

NewtonImport

NewtonBodyGetAABB

NewtonImport

NewtonBodyGetAngularDamping

NewtonImport

NewtonBodyGetAutoSleep

NewtonImport

NewtonBodyGetCentreOfMass

NewtonImport

NewtonBodyGetCollision

NewtonImport

NewtonBodyGetContinuousCollisionMode

NewtonImport

NewtonBodyGetFirstContactJoint

NewtonImport

NewtonBodyGetFirstJoint

NewtonImport

NewtonBodyGetForce

NewtonImport

NewtonBodyGetForceAcc

NewtonImport

NewtonBodyGetForceAndTorqueCallback

NewtonImport

NewtonBodyGetFreezeState

NewtonImport

NewtonBodyGetFreezeTreshold

NewtonImport

NewtonBodyGetInvMass

NewtonImport

NewtonBodyGetJointRecursiveCollision

NewtonImport

NewtonBodyGetLinearDamping

NewtonImport

NewtonBodyGetMassMatrix

NewtonImport

NewtonBodyGetMaterialGroupID

NewtonImport

NewtonBodyGetMatrix

NewtonImport

NewtonBodyGetNextContactJoint

NewtonImport

NewtonBodyGetNextJoint

NewtonImport

NewtonBodyGetOmega

NewtonImport

NewtonBodyGetRotation

NewtonImport

NewtonBodyGetSleepState

NewtonImport

NewtonBodyGetTorque

NewtonImport

NewtonBodyGetTorqueAcc

NewtonImport

NewtonBodyGetTransformCallback

NewtonImport

NewtonBodyGetUserData

NewtonImport

NewtonBodyGetVelocity

NewtonImport

NewtonBodyGetWorld

NewtonImport

NewtonBodyIterator

NewtonImport

NewtonBodyLeaveWorld

NewtonImport

NewtonBodySetAngularDamping

NewtonImport

NewtonBodySetAutoSleep

NewtonImport

NewtonBodySetCentreOfMass

NewtonImport

NewtonBodySetCollision

NewtonImport

NewtonBodySetContinuousCollisionMode

NewtonImport

NewtonBodySetDestructorCallback

NewtonImport

NewtonBodySetForce

NewtonImport

NewtonBodySetForceAndTorqueCallback

NewtonImport

NewtonBodySetFreezeState

NewtonImport

NewtonBodySetJointRecursiveCollision

NewtonImport

NewtonBodySetLinearDamping

NewtonImport

NewtonBodySetMassMatrix

NewtonImport

NewtonBodySetMaterialGroupID

NewtonImport

NewtonBodySetMatrix

NewtonImport

NewtonBodySetMatrixRecursive

NewtonImport

NewtonBodySetOmega

NewtonImport

NewtonBodySetTorque

NewtonImport

NewtonBodySetTransformCallback

NewtonImport

NewtonBodySetUserData

NewtonImport

NewtonBodySetVelocity

NewtonImport

NewtonBreakableBeginDelete

NewtonImport

NewtonBreakableCreateDebrieBody

NewtonImport

NewtonBreakableDeleteComponent

NewtonImport

NewtonBreakableEndDelete

NewtonImport

NewtonBreakableGetComponentsInRadius

NewtonImport

NewtonBreakableGetFirstComponent

NewtonImport

NewtonBreakableGetFirstSegment

NewtonImport

NewtonBreakableGetMainMesh

NewtonImport

NewtonBreakableGetNextComponent

NewtonImport

NewtonBreakableGetNextSegment

NewtonImport

NewtonBreakableSegmentGetIndexCount

NewtonImport

NewtonBreakableSegmentGetIndexStream

NewtonImport

NewtonBreakableSegmentGetIndexStreamShort

NewtonImport

NewtonBreakableSegmentGetMaterial

NewtonImport

NewtonCalculateSpringDamperAcceleration

NewtonImport

NewtonCollisionCalculateAABB

NewtonImport

NewtonCollisionClosestPoint

NewtonImport

NewtonCollisionCollide

NewtonImport

NewtonCollisionCollideContinue

NewtonImport

NewtonCollisionCompoundBreakableCallback

NewtonImport

NewtonCollisionDestructor

NewtonImport

NewtonCollisionForEachPolygonDo

NewtonImport

NewtonCollisionGetInfo

NewtonImport

NewtonCollisionGetMaxBreakImpactImpulse

NewtonImport

NewtonCollisionGetUserID

NewtonImport

NewtonCollisionIsTriggerVolume

NewtonImport

NewtonCollisionIterator

NewtonImport

NewtonCollisionMakeUnique

NewtonImport

NewtonCollisionPointDistance

NewtonImport

NewtonCollisionRayCast

NewtonImport

NewtonCollisionSerialize

NewtonImport

NewtonCollisionSetAsTriggerVolume

NewtonImport

NewtonCollisionSetMaxBreakImpactImpulse

NewtonImport

NewtonCollisionSetUserID

NewtonImport

NewtonCollisionSupportVertex

NewtonImport

NewtonCollisionTreeRayCastCallback

NewtonImport

NewtonCollisionUpdate

NewtonImport

NewtonCompoundBreakableGetVertexCount

NewtonImport

NewtonCompoundBreakableGetVertexStreams

NewtonImport

NewtonCompoundBreakableResetAnchoredPieces

NewtonImport

NewtonCompoundBreakableSetAnchoredPieces

NewtonImport

NewtonConstraintCreateBall

NewtonImport

NewtonConstraintCreateCorkscrew

NewtonImport

NewtonConstraintCreateHinge

NewtonImport

NewtonConstraintCreateSlider

NewtonImport

NewtonConstraintCreateUniversal

NewtonImport

NewtonConstraintCreateUpVector

NewtonImport

NewtonConstraintCreateUserJoint

NewtonImport

NewtonConstraintDestructor

NewtonImport

NewtonContactGetMaterial

NewtonImport

NewtonContactJointGetContactCount

NewtonImport

NewtonContactJointGetFirstContact

NewtonImport

NewtonContactJointGetNextContact

NewtonImport

NewtonContactJointRemoveContact

NewtonImport

NewtonContactsProcess

NewtonImport

NewtonConvexCollisionCalculateInertialMatrix

NewtonImport

NewtonConvexCollisionCalculateVolume

NewtonImport

NewtonConvexHullGetFaceIndices

NewtonImport

NewtonConvexHullModifierGetMatrix

NewtonImport

NewtonConvexHullModifierSetMatrix

NewtonImport

NewtonCorkscrewCalculateStopAccel

NewtonImport

NewtonCorkscrewCalculateStopAlpha

NewtonImport

NewtonCorkscrewCallBack

NewtonImport

NewtonCorkscrewGetJointAngle

NewtonImport

NewtonCorkscrewGetJointForce

NewtonImport

NewtonCorkscrewGetJointOmega

NewtonImport

NewtonCorkscrewGetJointPosit

NewtonImport

NewtonCorkscrewGetJointVeloc

NewtonImport

NewtonCorkscrewSetUserCallback

NewtonImport

NewtonCreate

NewtonImport

NewtonCreateBody

NewtonImport

NewtonCreateBox

NewtonImport

NewtonCreateCapsule

NewtonImport

NewtonCreateChamferCylinder

NewtonImport

NewtonCreateCollisionFromSerialization

NewtonImport

NewtonCreateCompoundBreakable

NewtonImport

NewtonCreateCompoundCollision

NewtonImport

NewtonCreateCompoundCollisionFromMesh

NewtonImport

NewtonCreateCone

NewtonImport

NewtonCreateConvexHull

NewtonImport

NewtonCreateConvexHullFromMesh

NewtonImport

NewtonCreateConvexHullModifier

NewtonImport

NewtonCreateCylinder

NewtonImport

NewtonCreateHeightFieldCollision

NewtonImport

NewtonCreateNull

NewtonImport

NewtonCreateSceneCollision

NewtonImport

NewtonCreateSphere

NewtonImport

NewtonCreateTreeCollision

NewtonImport

NewtonCreateTreeCollisionFromMesh

NewtonImport

NewtonCreateUserMeshCollision

NewtonImport

NewtonDeserialize

NewtonImport

NewtonDestroy

NewtonImport

NewtonDestroyAllBodies

NewtonImport

NewtonDestroyBody

NewtonImport

NewtonDestroyBodyByExeciveForce

NewtonImport

NewtonDestroyJoint

NewtonImport

NewtonDestroyWorld

NewtonImport

NewtonDLL

NewtonImport

NewtonFreeMemory

NewtonImport

NewtonGetBuoyancyPlane

NewtonImport

NewtonGetEulerAngle

NewtonImport

NewtonGetMaxThreadsCount

NewtonImport

NewtonGetMemoryUsed

NewtonImport

NewtonGetMultiThreadSolverOnSingleIsland

NewtonImport

NewtonGetPlatformArchitecture

NewtonImport

NewtonGetThreadsCount

NewtonImport

NewtonGetTicksCountCallback

NewtonImport

NewtonHeightFieldRayCastCallback

NewtonImport

NewtonHeightFieldSetUserRayCastCallback

NewtonImport

NewtonHingeCalculateStopAlpha

NewtonImport

NewtonHingeCallBack

NewtonImport

NewtonHingeGetJointAngle

NewtonImport

NewtonHingeGetJointForce

NewtonImport

NewtonHingeGetJointOmega

NewtonImport

NewtonHingeSetUserCallback

NewtonImport

NewtonHingeSliderUpdateDesc

NewtonImport

NewtonInvalidateCache

NewtonImport

NewtonIslandGetBody

NewtonImport

NewtonIslandGetBodyAABB

NewtonImport

NewtonIslandUpdate

NewtonImport

NewtonJointGetBody0

NewtonImport

NewtonJointGetBody1

NewtonImport

NewtonJointGetCollisionState

NewtonImport

NewtonJointGetInfo

NewtonImport

NewtonJointGetStiffness

NewtonImport

NewtonJointGetUserData

NewtonImport

NewtonJointIterator

NewtonImport

NewtonJointRecord

NewtonImport

NewtonJointSetCollisionState

NewtonImport

NewtonJointSetDestructor

NewtonImport

NewtonJointSetStiffness

NewtonImport

NewtonJointSetUserData

NewtonImport

NewtonMaterialContactRotateTangentDirections

NewtonImport

NewtonMaterialCreateGroupID

NewtonImport

NewtonMaterialDestroyAllGroupID

NewtonImport

NewtonMaterialGetBodyCollisionID

NewtonImport

NewtonMaterialGetContactFaceAttribute

NewtonImport

NewtonMaterialGetContactForce

NewtonImport

NewtonMaterialGetContactNormalSpeed

NewtonImport

NewtonMaterialGetContactPositionAndNormal

NewtonImport

NewtonMaterialGetContactTangentDirections

NewtonImport

NewtonMaterialGetContactTangentSpeed

NewtonImport

NewtonMaterialGetDefaultGroupID

NewtonImport

NewtonMaterialGetMaterialPairUserData

NewtonImport

NewtonMaterialGetUserData

NewtonImport

NewtonMaterialSetCollisionCallback

NewtonImport

NewtonMaterialSetContactElasticity

NewtonImport

NewtonMaterialSetContactFrictionCoef

NewtonImport

NewtonMaterialSetContactFrictionState

NewtonImport

NewtonMaterialSetContactNormalAcceleration

NewtonImport

NewtonMaterialSetContactNormalDirection

NewtonImport

NewtonMaterialSetContactSoftness

NewtonImport

NewtonMaterialSetContactTangentAcceleration

NewtonImport

NewtonMaterialSetContinuousCollisionMode

NewtonImport

NewtonMaterialSetDefaultCollidable

NewtonImport

NewtonMaterialSetDefaultElasticity

NewtonImport

NewtonMaterialSetDefaultFriction

NewtonImport

NewtonMaterialSetDefaultSoftness

NewtonImport

NewtonMaterialSetSurfaceThickness

NewtonImport

NewtonMesApplyTransform

NewtonImport

NewtonMeshAddFace

NewtonImport

NewtonMeshApplyBoxMapping

NewtonImport

NewtonMeshApplyCylindricalMapping

NewtonImport

NewtonMeshApplySphericalMapping

NewtonImport

NewtonMeshBeginFace

NewtonImport

NewtonMeshBeginHandle

NewtonImport

NewtonMeshBuildFromVertexListIndexList

NewtonImport

NewtonMeshCalculateOOBB

NewtonImport

NewtonMeshCalculateVertexNormals

NewtonImport

NewtonMeshClip

NewtonImport

NewtonMeshConvexDecomposition

NewtonImport

NewtonMeshConvexHull

NewtonImport

NewtonMeshCreate

NewtonImport

NewtonMeshCreateFirstLayer

NewtonImport

NewtonMeshCreateFirstSingleSegment

NewtonImport

NewtonMeshCreateFromCollision

NewtonImport

NewtonMeshCreateFromMesh

NewtonImport

NewtonMeshCreateNextLayer

NewtonImport

NewtonMeshCreateNextSingleSegment

NewtonImport

NewtonMeshCreatePlane

NewtonImport

NewtonMeshDestroy

NewtonImport

NewtonMeshDifference

NewtonImport

NewtonMeshEndFace

NewtonImport

NewtonMeshEndHandle

NewtonImport

NewtonMeshFirstMaterial

NewtonImport

NewtonMeshFixTJoints

NewtonImport

NewtonMeshGetEdgeIndices

NewtonImport

NewtonMeshGetFaceIndexCount

NewtonImport

NewtonMeshGetFaceIndices

NewtonImport

NewtonMeshGetFaceMaterial

NewtonImport

NewtonMeshGetFacePointIndices

NewtonImport

NewtonMeshGetFaces

NewtonImport

NewtonMeshGetFirstEdge

NewtonImport

NewtonMeshGetFirstFace

NewtonImport

NewtonMeshGetFirstPoint

NewtonImport

NewtonMeshGetFirstVertex

NewtonImport

NewtonMeshGetIndirectVertexStreams

NewtonImport

NewtonMeshGetNextEdge

NewtonImport

NewtonMeshGetNextFace

NewtonImport

NewtonMeshGetNextPoint

NewtonImport

NewtonMeshGetNextVertex

NewtonImport

NewtonMeshGetNormalArray

NewtonImport

NewtonMeshGetPointArray

NewtonImport

NewtonMeshGetPointCount

NewtonImport

NewtonMeshGetPointIndex

NewtonImport

NewtonMeshGetPointStrideInByte

NewtonImport

NewtonMeshGetTotalFaceCount

NewtonImport

NewtonMeshGetTotalIndexCount

NewtonImport

NewtonMeshGetUV0Array

NewtonImport

NewtonMeshGetUV1Array

NewtonImport

NewtonMeshGetVertexArray

NewtonImport

NewtonMeshGetVertexCount

NewtonImport

NewtonMeshGetVertexIndex

NewtonImport

NewtonMeshGetVertexIndexFromPoint

NewtonImport

NewtonMeshGetVertexStreams

NewtonImport

NewtonMeshGetVertexStrideInByte

NewtonImport

NewtonMeshIntersection

NewtonImport

NewtonMeshIsFaceOpen

NewtonImport

NewtonMeshIsOpenMesh

NewtonImport

NewtonMeshMaterialGetIndexCount

NewtonImport

NewtonMeshMaterialGetIndexStream

NewtonImport

NewtonMeshMaterialGetIndexStreamShort

NewtonImport

NewtonMeshMaterialGetMaterial

NewtonImport

NewtonMeshNextMaterial

NewtonImport

NewtonMeshPlaneClip

NewtonImport

NewtonMeshPolygonize

NewtonImport

NewtonMeshTriangulate

NewtonImport

NewtonMeshUnion

NewtonImport

NewtonMeshVoronoiDecomposition

NewtonImport

NewtonOnAABBOverlap

NewtonImport

NewtonReadPerformanceTicks

NewtonImport

NewtonReadThreadPerformanceTicks

NewtonImport

NewtonReleaseCollision

NewtonImport

NewtonRemoveUnusedVertices

NewtonImport

NewtonSceneCollisionCreateProxy

NewtonImport

NewtonSceneCollisionDestroyProxy

NewtonImport

NewtonSceneCollisionOptimize

NewtonImport

NewtonSceneGetFirstProxy

NewtonImport

NewtonSceneGetNextProxy

NewtonImport

NewtonSceneGetProxyUserData

NewtonImport

NewtonSceneProxyGetMatrix

NewtonImport

NewtonSceneProxySetMatrix

NewtonImport

NewtonSceneSetProxyUserData

NewtonImport

NewtonSerialize

NewtonImport

NewtonSetBodyLeaveWorldEvent

NewtonImport

NewtonSetCollisionDestructor

NewtonImport

NewtonSetDestroyBodyByExeciveForce

NewtonImport

NewtonSetEulerAngle

NewtonImport

NewtonSetFrictionModel

NewtonImport

NewtonSetIslandUpdateEvent

NewtonImport

NewtonSetMemorySystem

NewtonImport

NewtonSetMinimumFrameRate

NewtonImport

NewtonSetMultiThreadSolverOnSingleIsland

NewtonImport

NewtonSetPerformanceClock

NewtonImport

NewtonSetPlatformArchitecture

NewtonImport

NewtonSetSolverModel

NewtonImport

NewtonSetThreadsCount

NewtonImport

NewtonSetTransform

NewtonImport

NewtonSetWorldSize

NewtonImport

NewtonSliderCalculateStopAccel

NewtonImport

NewtonSliderCallBack

NewtonImport

NewtonSliderGetJointForce

NewtonImport

NewtonSliderGetJointPosit

NewtonImport

NewtonSliderGetJointVeloc

NewtonImport

NewtonSliderSetUserCallback

NewtonImport

NewtonStaticCollisionSetDebugCallback

NewtonImport

NewtonTreeCollisionAddFace

NewtonImport

NewtonTreeCollisionBeginBuild

NewtonImport

NewtonTreeCollisionCallback

NewtonImport

NewtonTreeCollisionEndBuild

NewtonImport

NewtonTreeCollisionGetFaceAtribute

NewtonImport

NewtonTreeCollisionGetVertexListIndexListInAABB

NewtonImport

NewtonTreeCollisionSetFaceAtribute

NewtonImport

NewtonTreeCollisionSetUserRayCastCallback

NewtonImport

NewtonUniversalCalculateStopAlpha0

NewtonImport

NewtonUniversalCalculateStopAlpha1

NewtonImport

NewtonUniversalCallBack

NewtonImport

NewtonUniversalGetJointAngle0

NewtonImport

NewtonUniversalGetJointAngle1

NewtonImport

NewtonUniversalGetJointForce

NewtonImport

NewtonUniversalGetJointOmega0

NewtonImport

NewtonUniversalGetJointOmega1

NewtonImport

NewtonUniversalSetUserCallback

NewtonImport

NewtonUpdate

NewtonImport

NewtonUpVectorGetPin

NewtonImport

NewtonUpVectorSetPin

NewtonImport

NewtonUserBilateralCallBack

NewtonImport

NewtonUserBilateralGetInfoCallBack

NewtonImport

NewtonUserJointAddAngularRow

NewtonImport

NewtonUserJointAddGeneralRow

NewtonImport

NewtonUserJointAddLinearRow

NewtonImport

NewtonUserJointDestructorCallback

NewtonImport_JointLibrary

NewtonUserJointGetRowForce

NewtonImport

NewtonUserJointSetFeedbackCollectorCallback

NewtonImport

NewtonUserJointSetRowAcceleration

NewtonImport

NewtonUserJointSetRowMaximumFriction

NewtonImport

NewtonUserJointSetRowMinimumFriction

NewtonImport

NewtonUserJointSetRowSpringDamperAcceleration

NewtonImport

NewtonUserJointSetRowStiffness

NewtonImport

NewtonUserJointSubmitConstraintCallback

NewtonImport_JointLibrary

NewtonUserMeshCollisionCollideCallback

NewtonImport

NewtonUserMeshCollisionCollideDesc

NewtonImport

NewtonUserMeshCollisionDestroyCallback

NewtonImport

NewtonUserMeshCollisionGetCollisionInfo

NewtonImport

NewtonUserMeshCollisionGetFacesInAABB

NewtonImport

NewtonUserMeshCollisionRayHitCallback

NewtonImport

NewtonUserMeshCollisionRayHitDesc

NewtonImport

NewtonWorldConvexCast

NewtonImport

NewtonWorldConvexCastReturnInfo

NewtonImport

NewtonWorldCriticalSectionLock

NewtonImport

NewtonWorldCriticalSectionUnlock

NewtonImport

NewtonWorldFloatSize

NewtonImport

NewtonWorldForEachBodyInAABBDo

NewtonImport

NewtonWorldForEachJointDo

NewtonImport

NewtonWorldGetBodyCount

NewtonImport

NewtonWorldGetConstraintCount

NewtonImport

NewtonWorldGetDestructorCallBack

NewtonImport

NewtonWorldGetFirstBody

NewtonImport

NewtonWorldGetFirstMaterial

NewtonImport

NewtonWorldGetNextBody

NewtonImport

NewtonWorldGetNextMaterial

NewtonImport

NewtonWorldGetUserData

NewtonImport

NewtonWorldGetVersion

NewtonImport

NewtonWorldRayCast

NewtonImport

NewtonWorldRayFilterCallback

NewtonImport

NewtonWorldRayPrefilterCallback

NewtonImport

NewtonWorldSetDestructorCallBack

NewtonImport

NewtonWorldSetUserData

NewtonImport

NEWTON_MAJOR_VERSION

NewtonImport

NEWTON_MINOR_VERSION

NewtonImport

NEWTON_PROFILER_COLLISION_UPDATE

NewtonImport

NEWTON_PROFILER_COLLISION_UPDATE_BROAD_PHASE

NewtonImport

NEWTON_PROFILER_COLLISION_UPDATE_NARROW_PHASE

NewtonImport

NEWTON_PROFILER_DYNAMICS_CONSTRAINT_GRAPH

NewtonImport

NEWTON_PROFILER_DYNAMICS_SOLVE_CONSTRAINT_GRAPH

NewtonImport

NEWTON_PROFILER_DYNAMICS_UPDATE

NewtonImport

NEWTON_PROFILER_FORCE_CALLBACK_UPDATE

NewtonImport

NEWTON_PROFILER_WORLD_UPDATE

NewtonImport

NGDFloat

GLNGDManager

NMF_HEADER_TAG

FileNMF

NMF_TRIANGLE_TAG

FileNMF

NodeHdrStrMax3DS

Const3DS

NodeTagCount

Const3DS

NodeTags

Const3DS

NODE_ANI_HIDDEN

Const3DS

NODE_AUTO_SMOOTH

Const3DS

NODE_BLUR_BRANCH

Const3DS

NODE_CALC_PATH

Const3DS

NODE_FROZEN

Const3DS

NODE_HAS_PATH

Const3DS

NODE_HDR

Const3DS

NODE_ID

Const3DS

NODE_MORPH_MTL

Const3DS

NODE_MORPH_OB

Const3DS

NODE_MOTION_BLUR

Const3DS

NODE_OFF

Const3DS

NODE_RENDOB_HIDE

Const3DS

NoFalloff

Const3DS

NormalizeAngle

VectorGeometry

Normalize to an angle in the [-PI; +PI] range

NormalizeDegAngle

VectorGeometry

Normalize to an angle in the [-180; 180] range

NormalizeMatrix

VectorGeometry

Normalize the matrix and remove the translation component.<p> The resulting matrix is an orthonormal matrix (Y direction preserved, then Z)

NormalizePlane

VectorGeometry

Normalize a plane so that point evaluation = plane distance. }

NormalizeQuaternion

VectorGeometry

Normalizes the given quaternion

NormalizeVector

VectorGeometry

Returns the vector transformed to unit length Transforms a vector to unit length

NormalizeVector

VectorGeometry

Transforms a vector to unit length

NormalizeVector

VectorGeometry

Transforms a vector to unit length

NormalizeVectorArray

VectorGeometry

Transforms vectors to unit length

NotChunk

Const3DS

NullBoundingBox

GeometryBB

NullHmgPoint

VectorGeometry

NullHmgVector

VectorGeometry

NullTexPoint

VectorGeometry

NullVector

VectorGeometry

NULL_CHUNK

Const3DS

NUM_ARITH_TBLS

GLSJPG

NUM_HUFF_TBLS

GLSJPG

NUM_QUANT_TBLS

GLSJPG

N_AMBIENT_LIGHT

Const3DS

N_CAMERA

Const3DS

N_CAM_OLD

Const3DS

N_DIRECT_LIGHT

Const3DS

N_D_L_OLD

Const3DS

N_TRI_OBJECT

Const3DS

ObjectManager

GLSceneRegisterLCL

Auto-create for object manager

ObjectManager

GLSceneRegister

Auto-create for object manager

OBJECT_NODE_TAG

Const3DS

OBJ_DOESNT_CAST

Const3DS

OBJ_DONT_RCVSHADOW

Const3DS

OBJ_FAST

Const3DS

OBJ_FROZEN

Const3DS

OBJ_HIDDEN

Const3DS

OBJ_MATTE

Const3DS

OBJ_PROCEDURAL

Const3DS

OBJ_VIS_LOFTER

Const3DS

OblateSpheroidal_Cartesian

GeometryCoordinates

Convert Oblate-Spheroidal to Cartesian. [Single] eta, phi in rad

OblateSpheroidal_Cartesian

GeometryCoordinates

Convert Oblate-Spheroidal to Cartesian. [Double] eta, phi in rad

OblateSpheroidal_Cartesian

GeometryCoordinates

Convert Oblate-Spheroidal to Cartesian (with error check). eta,phi in rad

OblateSpheroidal_Cartesian

GeometryCoordinates

Convert Oblate-Spheroidal to Cartesian (with error check).[Double] eta,phi in rad

ODEDLL

ODEImport

ODERToGLSceneMatrix

ODEGL

ODERToGLSceneMatrix

ODEGL

ODERToGLSceneMatrix

ODEGL

OffsetAABB

GeometryBB

OffsetAABB

GeometryBB

OffsetBB

GeometryBB

OffsetBB

GeometryBB

OffsetBBPoint

GeometryBB

OffsetFloatArray

VectorGeometry

OffsetFloatArray

VectorGeometry

OffsetFloatArray

VectorGeometry

Adds delta to values in the array.<p> Array size must be a multiple of four.

OLD_MAT_GROUP

Const3DS

opengl32

OpenGLTokens

OpenGLFormatToInternalFormat

GLTextureFormat

Give a GLScene texture format from openGL texture format.

OpenPictureDialog

GLUtils

Pops up a simple open picture dialog.

OptimizeMesh

GLMeshOptimizer

OptimizeMesh

GLMeshOptimizer

OptimizeMesh

GLMeshOptimizer

OptimizeMesh

GLMeshOptimizer

O_CONSTS

Const3DS

P2Char

NewtonImport

P4ByteArrayList

VectorLists

PAABB

GeometryBB

PAArray

GLzBuffer

PackRotationMatrix

VectorGeometry

Packs an homogeneous rotation matrix to 6 bytes.<p> The 6:64 (or 6:36) compression ratio is achieved by computing the quaternion associated to the matrix and storing its Imaginary components at 16 bits precision each.<br> Deviation is typically below 0.01% and around 0.1% in worst case situations.<p> Note: quaternion conversion is faster and more robust than an angle decomposition.

PACubic3DS

Types3DS

PAffineByteVector

VectorGeometry

PAffineDblVector

VectorGeometry

PAffineExtVector

VectorGeometry

PAffineFltVector

VectorGeometry

PAffineIntVector

VectorGeometry

PAffineMatrix

VectorGeometry

PAffinePtrVector

VectorGeometry

PAffineVector

VectorGeometry

PAffineVectorArray

VectorGeometry

PAffineWordVector

VectorGeometry

PAKCreateFileStream

GLVfsPAK

PAKFileStreamExists

GLVfsPAK

PALbitfield

openal

PALboolean

openal

PALbyte

openal

PALCboolean

openal

PALCbyte

openal

PALCchar

openal

PALCcontext

openal

PALCdevice

openal

PALCdouble

openal

PALCenum

openal

PALCfloat

openal

PALchar

openal

PALCint

openal

PALclampd

openal

PALclampf

openal

PALCshort

openal

PALCsizei

openal

PALCubyte

openal

PALCuint

openal

PALCushort

openal

PALCvoid

openal

PALdouble

openal

PALenum

openal

PALfloat

openal

PALint

openal

PALshort

openal

PALsizei

openal

PALuByte

openal

PALuint

openal

PALushort

openal

PALvoid

openal

PANG4

LWObjects

PANIMChunk

TypesB3D

PARENT_NAME

Const3DS

PARENT_OBJECT

Const3DS

ParseFloat

GLUtils

Parses the next integer in the string.<p> Initial non-numeric characters are skipper, p is altered, returns 0 if none found. Both '.' and ',' are accepted as decimal separators.

ParseInteger

GLUtils

Parses the next integer in the string.<p> Initial non-numeric characters are skipper, p is altered, returns 0 if none found. '+' and '-' are acknowledged.

PATH_3D

Const3DS

PATH_MATRIX

Const3DS

PAtmosphere3DS

Types3DS

PAVICOMPRESSOPTIONS

GLSVfw

PAVIFileInfo

GLSVfw

PAVIFileInfoA

GLSVfw

PAVIFileInfoW

GLSVfw

PAVIINDEXENTRY

GLSVfw

PAVIPALCHANGE

GLSVfw

PAVIStream

GLAVIRecorder

PAVIStreamHeader

GLSVfw

PAVIStreamInfo

GLSVfw

PAVIStreamInfoA

GLSVfw

PAVIStreamInfoW

GLSVfw

PB3DChunk

TypesB3D

PBackground3DS

Types3DS

PBallDelta

GLSDL

PBASS_PLUGINFORMS

Bass

PBASS_PLUGININFO

Bass

PBB3DChunk

TypesB3D

PBitmap3DS

Types3DS

PBitmapBgnd3DS

Types3DS

PBitMapName

Types3DS

PBlankJointGetInfo

NewtonImport_JointLibrary

PBONEChunk

TypesB3D

PBool

NewtonImport

PBoundBox

Types3DS

PBRUSChunk

TypesB3D

PBSPFace

Q3BSP

PBSPLightmap

Q3BSP

PBSPTexture

Q3BSP

PBSPVertex

Q3BSP

PByte

GLSDL

PByte

HeightTileFile

PByteArray

GLSDL

PByteArray

VectorGeometry

PByteRaster

GLHeightData

PByteVector

VectorGeometry

PCamera3DS

Types3DS

PCamRanges

Types3DS

PCamRanges3DS

Types3DS

PCAPDRIVERCAPS

GLSVfw

PCAPINFOCHUNK

GLSVfw

PCAPSTATUS

GLSVfw

PCAPTUREPARMS

GLSVfw

PCardinalArray

Types3DS

PCardinalArray

VectorGeometry

PCardinalVector

VectorGeometry

PCHANNEL_CAPS

GLSVfw

PChar3DS

Types3DS

PCharArray

NewtonImport

PCharInfo

GLBitmapFont

PChunk3DS

Types3DS

PChunkList

Types3DS

PChunkList3DS

Types3DS

PChunkListEntry3DS

Types3DS

Pcl_addressing_mode

GLS_CL

Pcl_bitfield

GLS_CL

Pcl_bool

GLS_CL

Pcl_build_status

GLS_CL

Pcl_channel_order

GLS_CL

Pcl_channel_type

GLS_CL

Pcl_char

GLS_CL_Platform

Pcl_command_queue

GLS_CL

Pcl_command_queue_info

GLS_CL

Pcl_command_queue_properties

GLS_CL

Pcl_command_type

GLS_CL

Pcl_context

GLS_CL

Pcl_context_info

GLS_CL

Pcl_context_properties

GLS_CL

Pcl_device_address_info

GLS_CL

Pcl_device_exec_capabilities

GLS_CL

Pcl_device_fp_config

GLS_CL

Pcl_device_id

GLS_CL

Pcl_device_info

GLS_CL

Pcl_device_local_mem_type

GLS_CL

Pcl_device_mem_cache_type

GLS_CL

Pcl_device_type

GLS_CL

Pcl_double

GLS_CL_Platform

Pcl_event

GLS_CL

Pcl_event_info

GLS_CL

Pcl_filter_mode

GLS_CL

Pcl_float

GLS_CL_Platform

Pcl_gl_object_type

GLS_CL_GL

Pcl_gl_platform_info

GLS_CL_GL

Pcl_gl_texture_info

GLS_CL_GL

Pcl_half

GLS_CL_Platform

Pcl_image_format

GLS_CL

Pcl_image_info

GLS_CL

Pcl_int

GLS_CL_Platform

Pcl_kernel

GLS_CL

Pcl_kernel_info

GLS_CL

Pcl_kernel_work_group_info

GLS_CL

Pcl_long

GLS_CL_Platform

Pcl_map_flags

GLS_CL

Pcl_mem

GLS_CL

Pcl_mem_flags

GLS_CL

Pcl_mem_info

GLS_CL

Pcl_mem_object_type

GLS_CL

Pcl_platform_id

GLS_CL

Pcl_platform_info

GLS_CL

Pcl_profiling_info

GLS_CL

Pcl_program

GLS_CL

Pcl_program_build_info

GLS_CL

Pcl_program_info

GLS_CL

Pcl_sampler

GLS_CL

Pcl_sampler_info

GLS_CL

Pcl_short

GLS_CL_Platform

Pcl_uchar

GLS_CL_Platform

Pcl_uint

GLS_CL_Platform

Pcl_ulong

GLS_CL_Platform

Pcl_ushort

GLS_CL_Platform

PColor24

Types3DS

PColorEntry

GLColor

PColorF

Types3DS

PColorVector

GLColor

PColr12

LWObjects

PColr4

LWObjects

PColTrackTag

Types3DS

PCOMPVARS

GLSVfw

PCUarray

GLS_CUDA_API

PCUcontext

GLS_CUDA_API

PcudaArray

GLS_CUDA_Runtime

PcudaChannelFormatDesc

GLS_CUDA_Runtime

PCudaDeviceProp

GLS_CUDA_Runtime

PCUDA_ARRAY_DESCRIPTOR

GLS_CUDA_API

PCUDA_MEMCPY2D

GLS_CUDA_API

PCUevent

GLS_CUDA_API

PcufftComplex

GLS_CUDA_FourierTransform

PcufftDoubleComplex

GLS_CUDA_FourierTransform

PcufftDoubleReal

GLS_CUDA_FourierTransform

PcufftReal

GLS_CUDA_FourierTransform

PCUfunction

GLS_CUDA_API

PCUgraphicsResource

GLS_CUDA_API

PCUmodule

GLS_CUDA_API

PCUstream

GLS_CUDA_API

PCUtexref

GLS_CUDA_API

Pd3Axis

ODEImport

PDatabase3DS

Types3DS

PdContact

ODEImport

PdContactGeom

ODEImport

PDCueSettings3DS

Types3DS

PdGeomClass

ODEImport

PDGRaycastVehicleTireTransformCallback

NewtonImport_JointLibrary

PdInteger3

ODEImport

PdIntegerArray

ODEImport

PDisplay

GLS_VDPAU_X11

PDistanceCue

Types3DS

PDlExclude

Types3DS

PDlInnerRange

Types3DS

PDlLocalShadow2

Types3DS

PDlMultiplier

Types3DS

PDlOuterRange

Types3DS

PDlRayBias

Types3DS

PDlSpotAspect

Types3DS

PDlSpotlight

Types3DS

PDlSpotProjector

Types3DS

PDlSpotRoll

Types3DS

PdMass

ODEImport

PdMatrix3

ODEImport

PdMatrix3_As3x4

ODEImport

PdMatrix4

ODEImport

PdMatrix6

ODEImport

PdObject

ODEImport

PDoubleArray

VectorGeometry

PDoubleArrayList

VectorLists

PDoubleVector

VectorGeometry

PdQuaternion

ODEImport

PDRAWDIBTIME

GLSVfw

PdReal

ODEImport

PdRealArray

ODEImport

PdRealHugeArray

ODEImport

PdVector3

ODEImport

PdVector3Array

ODEImport

PdVector4

ODEImport

PdxBody

ODEImport

PdxGeom

ODEImport

PdxHashSpace

ODEImport

PdxHeightfieldData

ODEImport

PdxJoint

ODEImport

PdxJointBall

ODEImport

PdxJointGroup

ODEImport

PdxJointHinge

ODEImport

PdxJointHinge2

ODEImport

PdxJointLimitMotor

ODEImport

PdxJointLimitMotor3

ODEImport

PdxJointNode

ODEImport

PdxJointPiston

ODEImport

PdxJointPR

ODEImport

PdxJointSlider

ODEImport

PdxJointUniversial

ODEImport

PdxPosR

ODEImport

PdxSimpleSpace

ODEImport

PdxSpace

ODEImport

PDXT3AlphaBlock

DXTC

PDXT5AlphaBlock

DXTC

PDXTColBlock

DXTC

PdxTriMeshData

ODEImport

PdxWorld

ODEImport

PD_CAN_DRAW_DIB

GLSVfw

PD_CAN_STRETCHDIB

GLSVfw

PD_STRETCHDIB_1_1_OK

GLSVfw

PD_STRETCHDIB_1_2_OK

GLSVfw

PD_STRETCHDIB_1_N_OK

GLSVfw

PEaxBufferProperties

openal

PEaxListenerProperties

openal

PEFXEAXREVERBPROPERTIES

openal

PEFXLOWPASSFILTER

openal

Perlin_Random1

GLPerlinBase

Perlin_Random1DStrip

GLPerlinBase

Perlin_Random2

GLPerlinBase

PExtendedArray

VectorGeometry

PExtendedVector

VectorGeometry

PF4

LWObjects

PF4Array

LWObjects

PFace3DS

Types3DS

PFaceArray

Types3DS

PFaceList

Types3DS

PFallTrackTag

Types3DS

PFastCollisionChecker

GLCollision

PFColor3DS

Types3DS

PFColorList

Types3DS

PFireParticle

GLFireFX

PFireParticleArray

GLFireFX

PFloat

VectorGeometry

PFloat

NewtonImport

PFloatArray

VectorGeometry

PFloatPercentage

Types3DS

PFloatVector

VectorGeometry

PFMusicModule

fmodtypes

PFNGLACTIVESHADERPROGRAMPROC

OpenGLTokens

PFNGLACTIVESTENCILFACEEXTPROC

OpenGLTokens

PFNGLACTIVETEXTUREARBPROC

OpenGLTokens

PFNGLACTIVETEXTUREPROC

OpenGLTokens

PFNGLACTIVEVARYINGNVPROC

OpenGLTokens

PFNGLADDSWAPHINTRECTWINPROC

OpenGLTokens

PFNGLAREPROGRAMSRESIDENTNVPROC

OpenGLTokens

PFNGLARETEXTURESRESIDENTEXTPROC

OpenGLTokens

PFNGLARRAYELEMENTARRAYEXTPROC

OpenGLTokens

PFNGLATTACHOBJECTARBPROC

OpenGLTokens

PFNGLATTACHSHADERPROC

OpenGLTokens

PFNGLBEGINCONDITIONALRENDERNVPROC

OpenGLTokens

PFNGLBEGINCONDITIONALRENDERPROC

OpenGLTokens

PFNGLBEGINOCCLUSIONQUERYNVPROC

OpenGLTokens

PFNGLBEGINQUERYARBPROC

OpenGLTokens

PFNGLBEGINQUERYINDEXEDPROC

OpenGLTokens

PFNGLBEGINQUERYPROC

OpenGLTokens

PFNGLBEGINSCENEEXTPROC

OpenGLTokens

PFNGLBEGINTRANSFORMFEEDBACKEXTPROC

OpenGLTokens

PFNGLBEGINTRANSFORMFEEDBACKNVPROC

OpenGLTokens

PFNGLBEGINTRANSFORMFEEDBACKPROC

OpenGLTokens

PFNGLBINDATTRIBLOCATIONARBPROC

OpenGLTokens

PFNGLBINDATTRIBLOCATIONPROC

OpenGLTokens

PFNGLBINDBUFFERARBPROC

OpenGLTokens

PFNGLBINDBUFFERBASEEXTPROC

OpenGLTokens

PFNGLBINDBUFFERBASENVPROC

OpenGLTokens

PFNGLBINDBUFFERBASEPROC

OpenGLTokens

PFNGLBINDBUFFEROFFSETEXTPROC

OpenGLTokens

PFNGLBINDBUFFEROFFSETNVPROC

OpenGLTokens

PFNGLBINDBUFFERPROC

OpenGLTokens

PFNGLBINDBUFFERRANGEEXTPROC

OpenGLTokens

PFNGLBINDBUFFERRANGENVPROC

OpenGLTokens

PFNGLBINDBUFFERRANGEPROC

OpenGLTokens

PFNGLBINDFRAGDATALOCATIONEXTPROC

OpenGLTokens

PFNGLBINDFRAGDATALOCATIONINDEXEDPROC

OpenGLTokens

PFNGLBINDFRAGDATALOCATIONPROC

OpenGLTokens

PFNGLBINDFRAMEBUFFEREXTPROC

OpenGLTokens

PFNGLBINDFRAMEBUFFERPROC

OpenGLTokens

PFNGLBINDMULTITEXTUREEXTPROC

OpenGLTokens

PFNGLBINDPROGRAMARBPROC

OpenGLTokens

PFNGLBINDPROGRAMNVPROC

OpenGLTokens

PFNGLBINDPROGRAMPIPELINEPROC

OpenGLTokens

PFNGLBINDRENDERBUFFEREXTPROC

OpenGLTokens

PFNGLBINDRENDERBUFFERPROC

OpenGLTokens

PFNGLBINDSAMPLERPROC

OpenGLTokens

PFNGLBINDTEXTUREEXTPROC

OpenGLTokens

PFNGLBINDTRANSFORMFEEDBACKPROC

OpenGLTokens

PFNGLBINDVERTEXARRAYPROC

OpenGLTokens

PFNGLBLENDCOLOREXTPROC

OpenGLTokens

PFNGLBLENDCOLORPROC

OpenGLTokens

PFNGLBLENDEQUATIONEXTPROC

OpenGLTokens

PFNGLBLENDEQUATIONIARBPROC

OpenGLTokens

PFNGLBLENDEQUATIONIPROC

OpenGLTokens

PFNGLBLENDEQUATIONPROC

OpenGLTokens

PFNGLBLENDEQUATIONSEPARATEEXTPROC

OpenGLTokens

PFNGLBLENDEQUATIONSEPARATEIARBPROC

OpenGLTokens

PFNGLBLENDEQUATIONSEPARATEIPROC

OpenGLTokens

PFNGLBLENDEQUATIONSEPARATEPROC

OpenGLTokens

PFNGLBLENDFUNCIARBPROC

OpenGLTokens

PFNGLBLENDFUNCIPROC

OpenGLTokens

PFNGLBLENDFUNCSEPARATEEXTPROC

OpenGLTokens

PFNGLBLENDFUNCSEPARATEIARBPROC

OpenGLTokens

PFNGLBLENDFUNCSEPARATEIPROC

OpenGLTokens

PFNGLBLENDFUNCSEPARATEPROC

OpenGLTokens

PFNGLBLITFRAMEBUFFEREXTPROC

OpenGLTokens

PFNGLBLITFRAMEBUFFERPROC

OpenGLTokens

PFNGLBUFFERADDRESSRANGENVPROC

OpenGLTokens

PFNGLBUFFERDATAARBPROC

OpenGLTokens

PFNGLBUFFERDATAPROC

OpenGLTokens

PFNGLBUFFERSUBDATAARBPROC

OpenGLTokens

PFNGLBUFFERSUBDATAPROC

OpenGLTokens

PFNGLCHECKFRAMEBUFFERSTATUSEXTPROC

OpenGLTokens

PFNGLCHECKFRAMEBUFFERSTATUSPROC

OpenGLTokens

PFNGLCHECKNAMEDFRAMEBUFFERSTATUSEXTPROC

OpenGLTokens

PFNGLCLAMPCOLORARBPROC

OpenGLTokens

PFNGLCLAMPCOLORPROC

OpenGLTokens

PFNGLCLEARBUFFERFIPROC

OpenGLTokens

PFNGLCLEARBUFFERFVPROC

OpenGLTokens

PFNGLCLEARBUFFERIVPROC

OpenGLTokens

PFNGLCLEARBUFFERUIVPROC

OpenGLTokens

PFNGLCLEARCOLORIIEXTPROC

OpenGLTokens

PFNGLCLEARCOLORIUIEXTPROC

OpenGLTokens

PFNGLCLEARDEPTHFPROC

OpenGLTokens

PFNGLCLIENTACTIVETEXTUREARBPROC

OpenGLTokens

PFNGLCLIENTACTIVETEXTUREPROC

OpenGLTokens

PFNGLCLIENTATTRIBDEFAULTEXTPROC

OpenGLTokens

PFNGLCLIENTWAITSYNCPROC

OpenGLTokens

PFNGLCOLORFORMATNVPROC

OpenGLTokens

PFNGLCOLORMASKINDEXEDEXTPROC

OpenGLTokens

PFNGLCOLORMASKIPROC

OpenGLTokens

PFNGLCOLORP3UIPROC

OpenGLTokens

PFNGLCOLORP3UIVPROC

OpenGLTokens

PFNGLCOLORP4UIPROC

OpenGLTokens

PFNGLCOLORP4UIVPROC

OpenGLTokens

PFNGLCOLORSUBTABLEEXTPROC

OpenGLTokens

PFNGLCOLORSUBTABLEPROC

OpenGLTokens

PFNGLCOLORTABLEEXTPROC

OpenGLTokens

PFNGLCOLORTABLEPARAMETERFVPROC

OpenGLTokens

PFNGLCOLORTABLEPARAMETERIVPROC

OpenGLTokens

PFNGLCOLORTABLEPROC

OpenGLTokens

PFNGLCOMBINERINPUTNVPROC

OpenGLTokens

PFNGLCOMBINEROUTPUTNVPROC

OpenGLTokens

PFNGLCOMBINERPARAMETERFNVPROC

OpenGLTokens

PFNGLCOMBINERPARAMETERFVNVPROC

OpenGLTokens

PFNGLCOMBINERPARAMETERINVPROC

OpenGLTokens

PFNGLCOMBINERPARAMETERIVNVPROC

OpenGLTokens

PFNGLCOMPILESHADERARBPROC

OpenGLTokens

PFNGLCOMPILESHADERPROC

OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE1DEXTPROC

OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE2DEXTPROC

OpenGLTokens

PFNGLCOMPRESSEDMULTITEXIMAGE3DEXTPROC

OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE1DEXTPROC

OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE2DEXTPROC

OpenGLTokens

PFNGLCOMPRESSEDMULTITEXSUBIMAGE3DEXTPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE1DARBPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE1DPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE2DARBPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE2DPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE3DARBPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXIMAGE3DPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE1DARBPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE1DPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE2DARBPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE2DPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE3DARBPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXSUBIMAGE3DPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE1DEXTPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE2DEXTPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXTUREIMAGE3DEXTPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE1DEXTPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE2DEXTPROC

OpenGLTokens

PFNGLCOMPRESSEDTEXTURESUBIMAGE3DEXTPROC

OpenGLTokens

PFNGLCONVOLUTIONFILTER1DPROC

OpenGLTokens

PFNGLCONVOLUTIONFILTER2DPROC

OpenGLTokens

PFNGLCONVOLUTIONPARAMETERFPROC

OpenGLTokens

PFNGLCONVOLUTIONPARAMETERFVPROC

OpenGLTokens

PFNGLCONVOLUTIONPARAMETERIPROC

OpenGLTokens

PFNGLCONVOLUTIONPARAMETERIVPROC

OpenGLTokens

PFNGLCOPYBUFFERSUBDATAPROC

OpenGLTokens

PFNGLCOPYCOLORSUBTABLEPROC

OpenGLTokens

PFNGLCOPYCOLORTABLEPROC

OpenGLTokens

PFNGLCOPYCONVOLUTIONFILTER1DPROC

OpenGLTokens

PFNGLCOPYCONVOLUTIONFILTER2DPROC

OpenGLTokens

PFNGLCOPYIMAGESUBDATANVPROC

OpenGLTokens

PFNGLCOPYMULTITEXIMAGE1DEXTPROC

OpenGLTokens

PFNGLCOPYMULTITEXIMAGE2DEXTPROC

OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE1DEXTPROC

OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE2DEXTPROC

OpenGLTokens

PFNGLCOPYMULTITEXSUBIMAGE3DEXTPROC

OpenGLTokens

PFNGLCOPYPATHNVPROC

OpenGLTokens

PFNGLCOPYTEXIMAGE1DEXTPROC

OpenGLTokens

PFNGLCOPYTEXIMAGE2DEXTPROC

OpenGLTokens

PFNGLCOPYTEXSUBIMAGE1DEXTPROC

OpenGLTokens

PFNGLCOPYTEXSUBIMAGE2DEXTPROC

OpenGLTokens

PFNGLCOPYTEXSUBIMAGE3DEXTPROC

OpenGLTokens

PFNGLCOPYTEXSUBIMAGE3DPROC

OpenGLTokens

PFNGLCOPYTEXTUREIMAGE1DEXTPROC

OpenGLTokens

PFNGLCOPYTEXTUREIMAGE2DEXTPROC

OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE1DEXTPROC

OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE2DEXTPROC

OpenGLTokens

PFNGLCOPYTEXTURESUBIMAGE3DEXTPROC

OpenGLTokens

PFNGLCOVERFILLPATHINSTANCEDNVPROC

OpenGLTokens

PFNGLCOVERFILLPATHNVPROC

OpenGLTokens

PFNGLCOVERSTROKEPATHINSTANCEDNVPROC

OpenGLTokens

PFNGLCOVERSTROKEPATHNVPROC

OpenGLTokens

PFNGLCREATEPROGRAMOBJECTARBPROC

OpenGLTokens

PFNGLCREATEPROGRAMPROC

OpenGLTokens

PFNGLCREATESHADEROBJECTARBPROC

OpenGLTokens

PFNGLCREATESHADERPROC

OpenGLTokens

PFNGLCREATESHADERPROGRAMVPROC

OpenGLTokens

PFNGLCURRENTPALETTEMATRIXARBPROC

OpenGLTokens

PFNGLDEBUGMESSAGECALLBACKARBPROC

OpenGLTokens

PFNGLDEBUGMESSAGECONTROLARBPROC

OpenGLTokens

PFNGLDEBUGMESSAGEINSERTARBPROC

OpenGLTokens

PFNGLDELETEBUFFERSARBPROC

OpenGLTokens

PFNGLDELETEBUFFERSPROC

OpenGLTokens

PFNGLDELETEFENCESNVPROC

OpenGLTokens

PFNGLDELETEFRAMEBUFFERSEXTPROC

OpenGLTokens

PFNGLDELETEFRAMEBUFFERSPROC

OpenGLTokens

PFNGLDELETEOBJECTARBPROC

OpenGLTokens

PFNGLDELETEOCCLUSIONQUERIESNVPROC

OpenGLTokens

PFNGLDELETEPATHSNVPROC

OpenGLTokens

PFNGLDELETEPROGRAMPIPELINESPROC

OpenGLTokens

PFNGLDELETEPROGRAMPROC

OpenGLTokens

PFNGLDELETEPROGRAMSARBPROC

OpenGLTokens

PFNGLDELETEPROGRAMSNVPROC

OpenGLTokens

PFNGLDELETEQUERIESARBPROC

OpenGLTokens

PFNGLDELETEQUERIESPROC

OpenGLTokens

PFNGLDELETERENDERBUFFERSEXTPROC

OpenGLTokens

PFNGLDELETERENDERBUFFERSPROC

OpenGLTokens

PFNGLDELETESAMPLERSPROC

OpenGLTokens

PFNGLDELETESHADERPROC

OpenGLTokens

PFNGLDELETESYNCPROC

OpenGLTokens

PFNGLDELETETEXTURESEXTPROC

OpenGLTokens

PFNGLDELETETRANSFORMFEEDBACKSPROC

OpenGLTokens

PFNGLDELETEVERTEXARRAYSPROC

OpenGLTokens

PFNGLDEPTHBOUNDSEXTPROC

OpenGLTokens

PFNGLDEPTHRANGEARRAYVPROC

OpenGLTokens

PFNGLDEPTHRANGEFPROC

OpenGLTokens

PFNGLDEPTHRANGEINDEXEDPROC

OpenGLTokens

PFNGLDETACHOBJECTARBPROC

OpenGLTokens

PFNGLDETACHSHADERPROC

OpenGLTokens

PFNGLDISABLECLIENTSTATEINDEXEDEXTPROC

OpenGLTokens

PFNGLDISABLEINDEXEDEXTPROC

OpenGLTokens

PFNGLDISABLEIPROC

OpenGLTokens

PFNGLDISABLEVERTEXATTRIBARRAYARBPROC

OpenGLTokens

PFNGLDISABLEVERTEXATTRIBARRAYPROC

OpenGLTokens

PFNGLDRAWARRAYSINDIRECTPROC

OpenGLTokens

PFNGLDRAWARRAYSINSTANCEDARBPROC

OpenGLTokens

PFNGLDRAWARRAYSINSTANCEDEXTPROC

OpenGLTokens

PFNGLDRAWARRAYSINSTANCEDPROC

OpenGLTokens

PFNGLDRAWBUFFERSARBPROC

OpenGLTokens

PFNGLDRAWBUFFERSATIPROC

OpenGLTokens

PFNGLDRAWBUFFERSPROC

OpenGLTokens

PFNGLDRAWELEMENTSBASEVERTEXPROC

OpenGLTokens

PFNGLDRAWELEMENTSINDIRECTPROC

OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDARBPROC

OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDBASEVERTEXPROC

OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDEXTPROC

OpenGLTokens

PFNGLDRAWELEMENTSINSTANCEDPROC

OpenGLTokens

PFNGLDRAWRANGEELEMENTSBASEVERTEXPROC

OpenGLTokens

PFNGLDRAWRANGEELEMENTSEXTPROC

OpenGLTokens

PFNGLDRAWRANGEELEMENTSPROC

OpenGLTokens

PFNGLDRAWTRANSFORMFEEDBACKPROC

OpenGLTokens

PFNGLDRAWTRANSFORMFEEDBACKSTREAMPROC

OpenGLTokens

PFNGLEDGEFLAGFORMATNVPROC

OpenGLTokens

PFNGLENABLECLIENTSTATEINDEXEDEXTPROC

OpenGLTokens

PFNGLENABLEINDEXEDEXTPROC

OpenGLTokens

PFNGLENABLEIPROC

OpenGLTokens

PFNGLENABLEVERTEXATTRIBARRAYARBPROC

OpenGLTokens

PFNGLENABLEVERTEXATTRIBARRAYPROC

OpenGLTokens

PFNGLENDCONDITIONALRENDERNVPROC

OpenGLTokens

PFNGLENDCONDITIONALRENDERPROC

OpenGLTokens

PFNGLENDOCCLUSIONQUERYNVPROC

OpenGLTokens

PFNGLENDQUERYARBPROC

OpenGLTokens

PFNGLENDQUERYINDEXEDPROC

OpenGLTokens

PFNGLENDQUERYPROC

OpenGLTokens

PFNGLENDSCENEEXTPROC

OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKEXTPROC

OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKNVPROC

OpenGLTokens

PFNGLENDTRANSFORMFEEDBACKPROC

OpenGLTokens

PFNGLEXECUTEPROGRAMNVPROC

OpenGLTokens

PFNGLFENCESYNCPROC

OpenGLTokens

PFNGLFINALCOMBINERINPUTNVPROC

OpenGLTokens

PFNGLFINISHFENCENVPROC

OpenGLTokens

PFNGLFLUSHMAPPEDBUFFERRANGEPROC

OpenGLTokens

PFNGLFLUSHMAPPEDNAMEDBUFFERRANGEEXTPROC

OpenGLTokens

PFNGLFLUSHVERTEXARRAYRANGENVPROC

OpenGLTokens

PFNGLFOGCOORDDEXTPROC

OpenGLTokens

PFNGLFOGCOORDDPROC

OpenGLTokens

PFNGLFOGCOORDDVEXTPROC

OpenGLTokens

PFNGLFOGCOORDDVPROC

OpenGLTokens

PFNGLFOGCOORDFEXTPROC

OpenGLTokens

PFNGLFOGCOORDFORMATNVPROC

OpenGLTokens

PFNGLFOGCOORDFPROC

OpenGLTokens

PFNGLFOGCOORDFVEXTPROC

OpenGLTokens

PFNGLFOGCOORDFVPROC

OpenGLTokens

PFNGLFOGCOORDPOINTEREXTPROC

OpenGLTokens

PFNGLFOGCOORDPOINTERPROC

OpenGLTokens

PFNGLFRAMEBUFFERDRAWBUFFEREXTPROC

OpenGLTokens

PFNGLFRAMEBUFFERDRAWBUFFERSEXTPROC

OpenGLTokens

PFNGLFRAMEBUFFERREADBUFFEREXTPROC

OpenGLTokens

PFNGLFRAMEBUFFERRENDERBUFFEREXTPROC

OpenGLTokens

PFNGLFRAMEBUFFERRENDERBUFFERPROC

OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE1DEXTPROC

OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE1DPROC

OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE2DEXTPROC

OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE2DPROC

OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE3DEXTPROC

OpenGLTokens

PFNGLFRAMEBUFFERTEXTURE3DPROC

OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREARBPROC

OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREEXTPROC

OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREFACEARBPROC

OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREFACEEXTPROC

OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYERARBPROC

OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYEREXTPROC

OpenGLTokens

PFNGLFRAMEBUFFERTEXTURELAYERPROC

OpenGLTokens

PFNGLFRAMEBUFFERTEXTUREPROC

OpenGLTokens

PFNGLFRAMETERMINATORGREMEDYPROC

OpenGLTokens

PFNGLGENBUFFERSARBPROC

OpenGLTokens

PFNGLGENBUFFERSPROC

OpenGLTokens

PFNGLGENERATEMIPMAPEXTPROC

OpenGLTokens

PFNGLGENERATEMIPMAPPROC

OpenGLTokens

PFNGLGENERATEMULTITEXMIPMAPEXTPROC

OpenGLTokens

PFNGLGENERATETEXTUREMIPMAPEXTPROC

OpenGLTokens

PFNGLGENFENCESNVPROC

OpenGLTokens

PFNGLGENFRAMEBUFFERSEXTPROC

OpenGLTokens

PFNGLGENFRAMEBUFFERSPROC

OpenGLTokens

PFNGLGENOCCLUSIONQUERIESNVPROC

OpenGLTokens

PFNGLGENPATHSNVPROC

OpenGLTokens

PFNGLGENPROGRAMPIPELINESPROC

OpenGLTokens

PFNGLGENPROGRAMSARBPROC

OpenGLTokens

PFNGLGENPROGRAMSNVPROC

OpenGLTokens

PFNGLGENQUERIESARBPROC

OpenGLTokens

PFNGLGENQUERIESPROC

OpenGLTokens

PFNGLGENRENDERBUFFERSEXTPROC

OpenGLTokens

PFNGLGENRENDERBUFFERSPROC

OpenGLTokens

PFNGLGENSAMPLERSPROC

OpenGLTokens

PFNGLGENTEXTURESEXTPROC

OpenGLTokens

PFNGLGENTRANSFORMFEEDBACKSPROC

OpenGLTokens

PFNGLGENVERTEXARRAYSPROC

OpenGLTokens

PFNGLGETACTIVEATTRIBARBPROC

OpenGLTokens

PFNGLGETACTIVEATTRIBPROC

OpenGLTokens

PFNGLGETACTIVESUBROUTINENAMEPROC

OpenGLTokens

PFNGLGETACTIVESUBROUTINEUNIFORMIVPROC

OpenGLTokens

PFNGLGETACTIVESUBROUTINEUNIFORMNAMEPROC

OpenGLTokens

PFNGLGETACTIVEUNIFORMARBPROC

OpenGLTokens

PFNGLGETACTIVEUNIFORMBLOCKIVPROC

OpenGLTokens

PFNGLGETACTIVEUNIFORMBLOCKNAMEPROC

OpenGLTokens

PFNGLGETACTIVEUNIFORMNAMEPROC

OpenGLTokens

PFNGLGETACTIVEUNIFORMPROC

OpenGLTokens

PFNGLGETACTIVEUNIFORMSIVPROC

OpenGLTokens

PFNGLGETACTIVEVARYINGNVPROC

OpenGLTokens

PFNGLGETATTACHEDOBJECTSARBPROC

OpenGLTokens

PFNGLGETATTACHEDSHADERSPROC

OpenGLTokens

PFNGLGETATTRIBLOCATIONARBPROC

OpenGLTokens

PFNGLGETATTRIBLOCATIONPROC

OpenGLTokens

PFNGLGETBOOLEANINDEXEDVEXTPROC

OpenGLTokens

PFNGLGETBOOLEANI_VPROC

OpenGLTokens

PFNGLGETBUFFERPARAMETERI64VPROC

OpenGLTokens

PFNGLGETBUFFERPARAMETERIVARBPROC

OpenGLTokens

PFNGLGETBUFFERPARAMETERIVPROC

OpenGLTokens

PFNGLGETBUFFERPARAMETERUI64VNVPROC

OpenGLTokens

PFNGLGETBUFFERPOINTERVARBPROC

OpenGLTokens

PFNGLGETBUFFERPOINTERVPROC

OpenGLTokens

PFNGLGETBUFFERSUBDATAARBPROC

OpenGLTokens

PFNGLGETBUFFERSUBDATAPROC

OpenGLTokens

PFNGLGETCOLORTABLEEXTPROC

OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERFVEXTPROC

OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERFVPROC

OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERIVEXTPROC

OpenGLTokens

PFNGLGETCOLORTABLEPARAMETERIVPROC

OpenGLTokens

PFNGLGETCOLORTABLEPROC

OpenGLTokens

PFNGLGETCOMBINERINPUTPARAMETERFVNVPROC

OpenGLTokens

PFNGLGETCOMBINERINPUTPARAMETERIVNVPROC

OpenGLTokens

PFNGLGETCOMBINEROUTPUTPARAMETERFVNVPROC

OpenGLTokens

PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC

OpenGLTokens

PFNGLGETCOMPRESSEDMULTITEXIMAGEEXTPROC

OpenGLTokens

PFNGLGETCOMPRESSEDTEXIMAGEARBPROC

OpenGLTokens

PFNGLGETCOMPRESSEDTEXIMAGEPROC

OpenGLTokens

PFNGLGETCOMPRESSEDTEXTUREIMAGEEXTPROC

OpenGLTokens

PFNGLGETCONVOLUTIONFILTERPROC

OpenGLTokens

PFNGLGETCONVOLUTIONPARAMETERFVPROC

OpenGLTokens

PFNGLGETCONVOLUTIONPARAMETERIVPROC

OpenGLTokens

PFNGLGETDEBUGMESSAGELOGARBPROC

OpenGLTokens

PFNGLGETDOUBLEINDEXEDVEXTPROC

OpenGLTokens

PFNGLGETDOUBLEI_VPROC

OpenGLTokens

PFNGLGETFENCEIVNVPROC

OpenGLTokens

PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC

OpenGLTokens

PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC

OpenGLTokens

PFNGLGETFLOATINDEXEDVEXTPROC

OpenGLTokens

PFNGLGETFLOATI_VPROC

OpenGLTokens

PFNGLGETFRAGDATAINDEXPROC

OpenGLTokens

PFNGLGETFRAGDATALOCATIONEXTPROC

OpenGLTokens

PFNGLGETFRAGDATALOCATIONPROC

OpenGLTokens

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC

OpenGLTokens

PFNGLGETFRAMEBUFFERATTACHMENTPARAMETERIVPROC

OpenGLTokens

PFNGLGETFRAMEBUFFERPARAMETERIVEXTPROC

OpenGLTokens

PFNGLGETGRAPHICSRESETSTATUSARBPROC

OpenGLTokens

PFNGLGETHANDLEARBPROC

OpenGLTokens

PFNGLGETHISTOGRAMPARAMETERFVPROC

OpenGLTokens

PFNGLGETHISTOGRAMPARAMETERIVPROC

OpenGLTokens

PFNGLGETHISTOGRAMPROC

OpenGLTokens

PFNGLGETINFOLOGARBPROC

OpenGLTokens

PFNGLGETINTEGER64I_VPROC

OpenGLTokens

PFNGLGETINTEGER64VPROC

OpenGLTokens

PFNGLGETINTEGERINDEXEDVEXTPROC

OpenGLTokens

PFNGLGETINTEGERI_VPROC

OpenGLTokens

PFNGLGETINTEGERUI64I_VNVPROC

OpenGLTokens

PFNGLGETINTEGERUI64VNVPROC

OpenGLTokens

PFNGLGETMINMAXPARAMETERFVPROC

OpenGLTokens

PFNGLGETMINMAXPARAMETERIVPROC

OpenGLTokens

PFNGLGETMINMAXPROC

OpenGLTokens

PFNGLGETMULTISAMPLEFVPROC

OpenGLTokens

PFNGLGETMULTITEXENVFVEXTPROC

OpenGLTokens

PFNGLGETMULTITEXENVIVEXTPROC

OpenGLTokens

PFNGLGETMULTITEXGENDVEXTPROC

OpenGLTokens

PFNGLGETMULTITEXGENFVEXTPROC

OpenGLTokens

PFNGLGETMULTITEXGENIVEXTPROC

OpenGLTokens

PFNGLGETMULTITEXIMAGEEXTPROC

OpenGLTokens

PFNGLGETMULTITEXLEVELPARAMETERFVEXTPROC

OpenGLTokens

PFNGLGETMULTITEXLEVELPARAMETERIVEXTPROC

OpenGLTokens

PFNGLGETMULTITEXPARAMETERFVEXTPROC

OpenGLTokens

PFNGLGETMULTITEXPARAMETERIIVEXTPROC

OpenGLTokens

PFNGLGETMULTITEXPARAMETERIUIVEXTPROC

OpenGLTokens

PFNGLGETMULTITEXPARAMETERIVEXTPROC

OpenGLTokens

PFNGLGETNAMEDBUFFERPARAMETERIVEXTPROC

OpenGLTokens

PFNGLGETNAMEDBUFFERPARAMETERUI64VNVPROC

OpenGLTokens

PFNGLGETNAMEDBUFFERPOINTERVEXTPROC

OpenGLTokens

PFNGLGETNAMEDBUFFERSUBDATAEXTPROC

OpenGLTokens

PFNGLGETNAMEDFRAMEBUFFERATTACHMENTPARAMETERIVEXTPROC

OpenGLTokens

PFNGLGETNAMEDPROGRAMIVEXTPROC

OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERDVEXTPROC

OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERFVEXTPROC

OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIIVEXTPROC

OpenGLTokens

PFNGLGETNAMEDPROGRAMLOCALPARAMETERIUIVEXTPROC

OpenGLTokens

PFNGLGETNAMEDPROGRAMSTRINGEXTPROC

OpenGLTokens

PFNGLGETNAMEDRENDERBUFFERPARAMETERIVEXTPROC

OpenGLTokens

PFNGLGETNCOLORTABLEARBPROC

OpenGLTokens

PFNGLGETNCOMPRESSEDTEXIMAGEARBPROC

OpenGLTokens

PFNGLGETNCONVOLUTIONFILTERARBPROC

OpenGLTokens

PFNGLGETNHISTOGRAMARBPROC

OpenGLTokens

PFNGLGETNMAPDVARBPROC

OpenGLTokens

PFNGLGETNMAPFVARBPROC

OpenGLTokens

PFNGLGETNMAPIVARBPROC

OpenGLTokens

PFNGLGETNMINMAXARBPROC

OpenGLTokens

PFNGLGETNPIXELMAPFVARBPROC

OpenGLTokens

PFNGLGETNPIXELMAPUIVARBPROC

OpenGLTokens

PFNGLGETNPIXELMAPUSVARBPROC

OpenGLTokens

PFNGLGETNPOLYGONSTIPPLEARBPROC

OpenGLTokens

PFNGLGETNSEPARABLEFILTERARBPROC

OpenGLTokens

PFNGLGETNTEXIMAGEARBPROC

OpenGLTokens

PFNGLGETNUNIFORMDVARBPROC

OpenGLTokens

PFNGLGETNUNIFORMFVARBPROC

OpenGLTokens

PFNGLGETNUNIFORMIVARBPROC

OpenGLTokens

PFNGLGETNUNIFORMUIVARBPROC

OpenGLTokens

PFNGLGETOBJECTPARAMETERFVARBPROC

OpenGLTokens

PFNGLGETOBJECTPARAMETERIVARBPROC

OpenGLTokens

PFNGLGETOCCLUSIONQUERYIVNVPROC

OpenGLTokens

PFNGLGETOCCLUSIONQUERYUIVNVPROC

OpenGLTokens

PFNGLGETPATHCOLORGENFVNVPROC

OpenGLTokens

PFNGLGETPATHCOLORGENIVNVPROC

OpenGLTokens

PFNGLGETPATHCOMMANDSNVPROC

OpenGLTokens

PFNGLGETPATHCOORDSNVPROC

OpenGLTokens

PFNGLGETPATHDASHARRAYNVPROC

OpenGLTokens

PFNGLGETPATHLENGTHNVPROC

OpenGLTokens

PFNGLGETPATHMETRICRANGENVPROC

OpenGLTokens

PFNGLGETPATHMETRICSNVPROC

OpenGLTokens

PFNGLGETPATHPARAMETERFVNVPROC

OpenGLTokens

PFNGLGETPATHPARAMETERIVNVPROC

OpenGLTokens

PFNGLGETPATHSPACINGNVPROC

OpenGLTokens

PFNGLGETPATHTEXGENFVNVPROC

OpenGLTokens

PFNGLGETPATHTEXGENIVNVPROC

OpenGLTokens

PFNGLGETPOINTERINDEXEDVEXTPROC

OpenGLTokens

PFNGLGETPROGRAMBINARYPROC

OpenGLTokens

PFNGLGETPROGRAMENVPARAMETERDVARBPROC

OpenGLTokens

PFNGLGETPROGRAMENVPARAMETERFVARBPROC

OpenGLTokens

PFNGLGETPROGRAMINFOLOGPROC

OpenGLTokens

PFNGLGETPROGRAMIVARBPROC

OpenGLTokens

PFNGLGETPROGRAMIVNVPROC

OpenGLTokens

PFNGLGETPROGRAMIVPROC

OpenGLTokens

PFNGLGETPROGRAMLOCALPARAMETERDVARBPROC

OpenGLTokens

PFNGLGETPROGRAMLOCALPARAMETERFVARBPROC

OpenGLTokens

PFNGLGETPROGRAMPARAMETERDVNVPROC

OpenGLTokens

PFNGLGETPROGRAMPARAMETERFVNVPROC

OpenGLTokens

PFNGLGETPROGRAMPIPELINEINFOLOGPROC

OpenGLTokens

PFNGLGETPROGRAMPIPELINEIVPROC

OpenGLTokens

PFNGLGETPROGRAMSTAGEIVPROC

OpenGLTokens

PFNGLGETPROGRAMSTRINGARBPROC

OpenGLTokens

PFNGLGETPROGRAMSTRINGNVPROC

OpenGLTokens

PFNGLGETQUERYINDEXEDIVPROC

OpenGLTokens

PFNGLGETQUERYIVARBPROC

OpenGLTokens

PFNGLGETQUERYIVPROC

OpenGLTokens

PFNGLGETQUERYOBJECTI64VEXTPROC

OpenGLTokens

PFNGLGETQUERYOBJECTI64VPROC

OpenGLTokens

PFNGLGETQUERYOBJECTIVARBPROC

OpenGLTokens

PFNGLGETQUERYOBJECTIVPROC

OpenGLTokens

PFNGLGETQUERYOBJECTUI64VEXTPROC

OpenGLTokens

PFNGLGETQUERYOBJECTUI64VPROC

OpenGLTokens

PFNGLGETQUERYOBJECTUIVARBPROC

OpenGLTokens

PFNGLGETQUERYOBJECTUIVPROC

OpenGLTokens

PFNGLGETRENDERBUFFERPARAMETERIVEXTPROC

OpenGLTokens

PFNGLGETRENDERBUFFERPARAMETERIVPROC

OpenGLTokens

PFNGLGETSAMPLERPARAMETERFVPROC

OpenGLTokens

PFNGLGETSAMPLERPARAMETERIFVPROC

OpenGLTokens

PFNGLGETSAMPLERPARAMETERIIVPROC

OpenGLTokens

PFNGLGETSAMPLERPARAMETERIVPROC

OpenGLTokens

PFNGLGETSEPARABLEFILTERPROC

OpenGLTokens

PFNGLGETSHADERINFOLOGPROC

OpenGLTokens

PFNGLGETSHADERIVPROC

OpenGLTokens

PFNGLGETSHADERPRECISIONFORMATPROC

OpenGLTokens

PFNGLGETSHADERSOURCEARBPROC

OpenGLTokens

PFNGLGETSHADERSOURCEPROC

OpenGLTokens

PFNGLGETSTRINGIPROC

OpenGLTokens

PFNGLGETSUBROUTINEINDEXPROC

OpenGLTokens

PFNGLGETSUBROUTINEUNIFORMLOCATIONPROC

OpenGLTokens

PFNGLGETSYNCIVPROC

OpenGLTokens

PFNGLGETTEXPARAMETERIIVEXTPROC

OpenGLTokens

PFNGLGETTEXPARAMETERIIVPROC

OpenGLTokens

PFNGLGETTEXPARAMETERIUIVEXTPROC

OpenGLTokens

PFNGLGETTEXPARAMETERIUIVPROC

OpenGLTokens

PFNGLGETTEXTUREIMAGEEXTPROC

OpenGLTokens

PFNGLGETTEXTURELEVELPARAMETERFVEXTPROC

OpenGLTokens

PFNGLGETTEXTURELEVELPARAMETERIVEXTPROC

OpenGLTokens

PFNGLGETTEXTUREPARAMETERFVEXTPROC

OpenGLTokens

PFNGLGETTEXTUREPARAMETERIIVEXTPROC

OpenGLTokens

PFNGLGETTEXTUREPARAMETERIUIVEXTPROC

OpenGLTokens

PFNGLGETTEXTUREPARAMETERIVEXTPROC

OpenGLTokens

PFNGLGETTRACKMATRIXIVNVPROC

OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGEXTPROC

OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGNVPROC

OpenGLTokens

PFNGLGETTRANSFORMFEEDBACKVARYINGPROC

OpenGLTokens

PFNGLGETUNIFORMBLOCKINDEXPROC

OpenGLTokens

PFNGLGETUNIFORMBUFFERSIZEEXTPROC

OpenGLTokens

PFNGLGETUNIFORMDVPROC

OpenGLTokens

PFNGLGETUNIFORMFVARBPROC

OpenGLTokens

PFNGLGETUNIFORMFVPROC

OpenGLTokens

PFNGLGETUNIFORMINDICESPROC

OpenGLTokens

PFNGLGETUNIFORMIVARBPROC

OpenGLTokens

PFNGLGETUNIFORMIVPROC

OpenGLTokens

PFNGLGETUNIFORMLOCATIONARBPROC

OpenGLTokens

PFNGLGETUNIFORMLOCATIONPROC

OpenGLTokens

PFNGLGETUNIFORMOFFSETEXTPROC

OpenGLTokens

PFNGLGETUNIFORMSUBROUTINEUIVPROC

OpenGLTokens

PFNGLGETUNIFORMUI64VNVPROC

OpenGLTokens

PFNGLGETUNIFORMUIVEXTPROC

OpenGLTokens

PFNGLGETUNIFORMUIVPROC

OpenGLTokens

PFNGLGETVARYINGLOCATIONNVPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBDVARBPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBDVNVPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBDVPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBFVARBPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBFVNVPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBFVPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBIIVEXTPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBIIVPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBIUIVEXTPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBIUIVPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBIVARBPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBIVNVPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBIVPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBLDVPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVARBPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVNVPROC

OpenGLTokens

PFNGLGETVERTEXATTRIBPOINTERVPROC

OpenGLTokens

PFNGLHISTOGRAMPROC

OpenGLTokens

PFNGLINDEXFORMATNVPROC

OpenGLTokens

PFNGLINDEXFUNCEXTPROC

OpenGLTokens

PFNGLINDEXMATERIALEXTPROC

OpenGLTokens

PFNGLINTERPOLATEPATHSNVPROC

OpenGLTokens

PFNGLISBUFFERARBPROC

OpenGLTokens

PFNGLISBUFFERPROC

OpenGLTokens

PFNGLISBUFFERRESIDENTNVPROC

OpenGLTokens

PFNGLISENABLEDINDEXEDEXTPROC

OpenGLTokens

PFNGLISENABLEDIPROC

OpenGLTokens

PFNGLISFENCENVPROC

OpenGLTokens

PFNGLISFRAMEBUFFEREXTPROC

OpenGLTokens

PFNGLISFRAMEBUFFERPROC

OpenGLTokens

PFNGLISNAMEDBUFFERRESIDENTNVPROC

OpenGLTokens

PFNGLISOCCLUSIONQUERYNVPROC

OpenGLTokens

PFNGLISPATHNVPROC

OpenGLTokens

PFNGLISPOINTINFILLPATHNVPROC

OpenGLTokens

PFNGLISPOINTINSTROKEPATHNVPROC

OpenGLTokens

PFNGLISPROGRAMARBPROC

OpenGLTokens

PFNGLISPROGRAMNVPROC

OpenGLTokens

PFNGLISPROGRAMPIPELINEPROC

OpenGLTokens

PFNGLISPROGRAMPROC

OpenGLTokens

PFNGLISQUERYARBPROC

OpenGLTokens

PFNGLISQUERYPROC

OpenGLTokens

PFNGLISRENDERBUFFEREXTPROC

OpenGLTokens

PFNGLISRENDERBUFFERPROC

OpenGLTokens

PFNGLISSAMPLERPROC

OpenGLTokens

PFNGLISSHADERPROC

OpenGLTokens

PFNGLISSYNCPROC

OpenGLTokens

PFNGLISTEXTUREEXTPROC

OpenGLTokens

PFNGLISTRANSFORMFEEDBACKPROC

OpenGLTokens

PFNGLISVERTEXARRAYPROC

OpenGLTokens

PFNGLLINKPROGRAMARBPROC

OpenGLTokens

PFNGLLINKPROGRAMPROC

OpenGLTokens

PFNGLLOADPROGRAMNVPROC

OpenGLTokens

PFNGLLOADTRANSPOSEMATRIXDARBPROC

OpenGLTokens

PFNGLLOADTRANSPOSEMATRIXDPROC

OpenGLTokens

PFNGLLOADTRANSPOSEMATRIXFARBPROC

OpenGLTokens

PFNGLLOADTRANSPOSEMATRIXFPROC

OpenGLTokens

PFNGLLOCKARRAYSEXTPROC

OpenGLTokens

PFNGLMAKEBUFFERNONRESIDENTNVPROC

OpenGLTokens

PFNGLMAKEBUFFERRESIDENTNVPROC

OpenGLTokens

PFNGLMAKENAMEDBUFFERNONRESIDENTNVPROC

OpenGLTokens

PFNGLMAKENAMEDBUFFERRESIDENTNVPROC

OpenGLTokens

PFNGLMAPBUFFERARBPROC

OpenGLTokens

PFNGLMAPBUFFERPROC

OpenGLTokens

PFNGLMAPBUFFERRANGEPROC

OpenGLTokens

PFNGLMAPNAMEDBUFFEREXTPROC

OpenGLTokens

PFNGLMAPNAMEDBUFFERRANGEEXTPROC

OpenGLTokens

PFNGLMATRIXFRUSTUMEXTPROC

OpenGLTokens

PFNGLMATRIXINDEXPOINTERARBPROC

OpenGLTokens

PFNGLMATRIXINDEXUBVARBPROC

OpenGLTokens

PFNGLMATRIXINDEXUIVARBPROC

OpenGLTokens

PFNGLMATRIXINDEXUSVARBPROC

OpenGLTokens

PFNGLMATRIXLOADDEXTPROC

OpenGLTokens

PFNGLMATRIXLOADFEXTPROC

OpenGLTokens

PFNGLMATRIXLOADIDENTITYEXTPROC

OpenGLTokens

PFNGLMATRIXLOADTRANSPOSEDEXTPROC

OpenGLTokens

PFNGLMATRIXLOADTRANSPOSEFEXTPROC

OpenGLTokens

PFNGLMATRIXMULTDEXTPROC

OpenGLTokens

PFNGLMATRIXMULTFEXTPROC

OpenGLTokens

PFNGLMATRIXMULTTRANSPOSEDEXTPROC

OpenGLTokens

PFNGLMATRIXMULTTRANSPOSEFEXTPROC

OpenGLTokens

PFNGLMATRIXORTHOEXTPROC

OpenGLTokens

PFNGLMATRIXPOPEXTPROC

OpenGLTokens

PFNGLMATRIXPUSHEXTPROC

OpenGLTokens

PFNGLMATRIXROTATEDEXTPROC

OpenGLTokens

PFNGLMATRIXROTATEFEXTPROC

OpenGLTokens

PFNGLMATRIXSCALEDEXTPROC

OpenGLTokens

PFNGLMATRIXSCALEFEXTPROC

OpenGLTokens

PFNGLMATRIXTRANSLATEDEXTPROC

OpenGLTokens

PFNGLMATRIXTRANSLATEFEXTPROC

OpenGLTokens

PFNGLMINMAXPROC

OpenGLTokens

PFNGLMINSAMPLESHADINGARBPROC

OpenGLTokens

PFNGLMINSAMPLESHADINGPROC

OpenGLTokens

PFNGLMULTIDRAWARRAYSEXTPROC

OpenGLTokens

PFNGLMULTIDRAWARRAYSPROC

OpenGLTokens

PFNGLMULTIDRAWELEMENTSBASEVERTEXPROC

OpenGLTokens

PFNGLMULTIDRAWELEMENTSEXTPROC

OpenGLTokens

PFNGLMULTIDRAWELEMENTSPROC

OpenGLTokens

PFNGLMULTITEXBUFFEREXTPROC

OpenGLTokens

PFNGLMULTITEXCOORD1DARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD1DPROC

OpenGLTokens

PFNGLMULTITEXCOORD1DVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD1DVPROC

OpenGLTokens

PFNGLMULTITEXCOORD1FARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD1FPROC

OpenGLTokens

PFNGLMULTITEXCOORD1FVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD1FVPROC

OpenGLTokens

PFNGLMULTITEXCOORD1IARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD1IPROC

OpenGLTokens

PFNGLMULTITEXCOORD1IVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD1IVPROC

OpenGLTokens

PFNGLMULTITEXCOORD1SARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD1SPROC

OpenGLTokens

PFNGLMULTITEXCOORD1SVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD1SVPROC

OpenGLTokens

PFNGLMULTITEXCOORD2DARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD2DPROC

OpenGLTokens

PFNGLMULTITEXCOORD2DVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD2DVPROC

OpenGLTokens

PFNGLMULTITEXCOORD2FARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD2FPROC

OpenGLTokens

PFNGLMULTITEXCOORD2FVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD2FVPROC

OpenGLTokens

PFNGLMULTITEXCOORD2IARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD2IPROC

OpenGLTokens

PFNGLMULTITEXCOORD2IVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD2IVPROC

OpenGLTokens

PFNGLMULTITEXCOORD2SARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD2SPROC

OpenGLTokens

PFNGLMULTITEXCOORD2SVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD2SVPROC

OpenGLTokens

PFNGLMULTITEXCOORD3DARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD3DPROC

OpenGLTokens

PFNGLMULTITEXCOORD3DVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD3DVPROC

OpenGLTokens

PFNGLMULTITEXCOORD3FARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD3FPROC

OpenGLTokens

PFNGLMULTITEXCOORD3FVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD3FVPROC

OpenGLTokens

PFNGLMULTITEXCOORD3IARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD3IPROC

OpenGLTokens

PFNGLMULTITEXCOORD3IVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD3IVPROC

OpenGLTokens

PFNGLMULTITEXCOORD3SARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD3SPROC

OpenGLTokens

PFNGLMULTITEXCOORD3SVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD3SVPROC

OpenGLTokens

PFNGLMULTITEXCOORD4DARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD4DPROC

OpenGLTokens

PFNGLMULTITEXCOORD4DVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD4DVPROC

OpenGLTokens

PFNGLMULTITEXCOORD4FARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD4FPROC

OpenGLTokens

PFNGLMULTITEXCOORD4FVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD4FVPROC

OpenGLTokens

PFNGLMULTITEXCOORD4IARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD4IPROC

OpenGLTokens

PFNGLMULTITEXCOORD4IVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD4IVPROC

OpenGLTokens

PFNGLMULTITEXCOORD4SARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD4SPROC

OpenGLTokens

PFNGLMULTITEXCOORD4SVARBPROC

OpenGLTokens

PFNGLMULTITEXCOORD4SVPROC

OpenGLTokens

PFNGLMULTITEXCOORDP1UIPROC

OpenGLTokens

PFNGLMULTITEXCOORDP1UIVPROC

OpenGLTokens

PFNGLMULTITEXCOORDP2UIPROC

OpenGLTokens

PFNGLMULTITEXCOORDP2UIVPROC

OpenGLTokens

PFNGLMULTITEXCOORDP3UIPROC

OpenGLTokens

PFNGLMULTITEXCOORDP3UIVPROC

OpenGLTokens

PFNGLMULTITEXCOORDP4UIPROC

OpenGLTokens

PFNGLMULTITEXCOORDP4UIVPROC

OpenGLTokens

PFNGLMULTITEXCOORDPOINTEREXTPROC

OpenGLTokens

PFNGLMULTITEXENVFEXTPROC

OpenGLTokens

PFNGLMULTITEXENVFVEXTPROC

OpenGLTokens

PFNGLMULTITEXENVIEXTPROC

OpenGLTokens

PFNGLMULTITEXENVIVEXTPROC

OpenGLTokens

PFNGLMULTITEXGENDEXTPROC

OpenGLTokens

PFNGLMULTITEXGENDVEXTPROC

OpenGLTokens

PFNGLMULTITEXGENFEXTPROC

OpenGLTokens

PFNGLMULTITEXGENFVEXTPROC

OpenGLTokens

PFNGLMULTITEXGENIEXTPROC

OpenGLTokens

PFNGLMULTITEXGENIVEXTPROC

OpenGLTokens

PFNGLMULTITEXIMAGE1DEXTPROC

OpenGLTokens

PFNGLMULTITEXIMAGE2DEXTPROC

OpenGLTokens

PFNGLMULTITEXIMAGE3DEXTPROC

OpenGLTokens

PFNGLMULTITEXPARAMETERFEXTPROC

OpenGLTokens

PFNGLMULTITEXPARAMETERFVEXTPROC

OpenGLTokens

PFNGLMULTITEXPARAMETERIEXTPROC

OpenGLTokens

PFNGLMULTITEXPARAMETERIIVEXTPROC

OpenGLTokens

PFNGLMULTITEXPARAMETERIUIVEXTPROC

OpenGLTokens

PFNGLMULTITEXPARAMETERIVEXTPROC

OpenGLTokens

PFNGLMULTITEXRENDERBUFFEREXTPROC

OpenGLTokens

PFNGLMULTITEXSUBIMAGE1DEXTPROC

OpenGLTokens

PFNGLMULTITEXSUBIMAGE2DEXTPROC

OpenGLTokens

PFNGLMULTITEXSUBIMAGE3DEXTPROC

OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXDARBPROC

OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXDPROC

OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXFARBPROC

OpenGLTokens

PFNGLMULTTRANSPOSEMATRIXFPROC

OpenGLTokens

PFNGLNAMEDBUFFERDATAEXTPROC

OpenGLTokens

PFNGLNAMEDBUFFERSUBDATAEXTPROC

OpenGLTokens

PFNGLNAMEDCOPYBUFFERSUBDATAEXTPROC

OpenGLTokens

PFNGLNAMEDFRAMEBUFFERRENDERBUFFEREXTPROC

OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE1DEXTPROC

OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE2DEXTPROC

OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURE3DEXTPROC

OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTUREEXTPROC

OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTUREFACEEXTPROC

OpenGLTokens

PFNGLNAMEDFRAMEBUFFERTEXTURELAYEREXTPROC

OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4DEXTPROC

OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4DVEXTPROC

OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4FEXTPROC

OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETER4FVEXTPROC

OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IEXTPROC

OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4IVEXTPROC

OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIEXTPROC

OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERI4UIVEXTPROC

OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERS4FVEXTPROC

OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4IVEXTPROC

OpenGLTokens

PFNGLNAMEDPROGRAMLOCALPARAMETERSI4UIVEXTPROC

OpenGLTokens

PFNGLNAMEDPROGRAMSTRINGEXTPROC

OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEEXTPROC

OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLECOVERAGEEXTPROC

OpenGLTokens

PFNGLNAMEDRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC

OpenGLTokens

PFNGLNORMALFORMATNVPROC

OpenGLTokens

PFNGLNORMALP3UIPROC

OpenGLTokens

PFNGLNORMALP3UIVPROC

OpenGLTokens

PFNGLPATCHPARAMETERFVPROC

OpenGLTokens

PFNGLPATCHPARAMETERIPROC

OpenGLTokens

PFNGLPATHCOLORGENNVPROC

OpenGLTokens

PFNGLPATHCOMMANDSNVPROC

OpenGLTokens

PFNGLPATHCOORDSNVPROC

OpenGLTokens

PFNGLPATHCOVERDEPTHFUNCNVPROC

OpenGLTokens

PFNGLPATHDASHARRAYNVPROC

OpenGLTokens

PFNGLPATHFOGGENNVPROC

OpenGLTokens

PFNGLPATHGLYPHRANGENVPROC

OpenGLTokens

PFNGLPATHGLYPHSNVPROC

OpenGLTokens

PFNGLPATHPARAMETERFNVPROC

OpenGLTokens

PFNGLPATHPARAMETERFVNVPROC

OpenGLTokens

PFNGLPATHPARAMETERINVPROC

OpenGLTokens

PFNGLPATHPARAMETERIVNVPROC

OpenGLTokens

PFNGLPATHSTENCILDEPTHOFFSETNVPROC

OpenGLTokens

PFNGLPATHSTENCILFUNCNVPROC

OpenGLTokens

PFNGLPATHSTRINGNVPROC

OpenGLTokens

PFNGLPATHSUBCOMMANDSNVPROC

OpenGLTokens

PFNGLPATHSUBCOORDSNVPROC

OpenGLTokens

PFNGLPATHTEXGENNVPROC

OpenGLTokens

PFNGLPAUSETRANSFORMFEEDBACKPROC

OpenGLTokens

PFNGLPOINTALONGPATHNVPROC

OpenGLTokens

PFNGLPOINTPARAMETERFARBPROC

OpenGLTokens

PFNGLPOINTPARAMETERFPROC

OpenGLTokens

PFNGLPOINTPARAMETERFVARBPROC

OpenGLTokens

PFNGLPOINTPARAMETERFVPROC

OpenGLTokens

PFNGLPOINTPARAMETERINVPROC

OpenGLTokens

PFNGLPOINTPARAMETERIPROC

OpenGLTokens

PFNGLPOINTPARAMETERIVNVPROC

OpenGLTokens

PFNGLPOINTPARAMETERIVPROC

OpenGLTokens

PFNGLPOLYGONOFFSETEXTPROC

OpenGLTokens

PFNGLPRIMITIVERESTARTINDEXNVPROC

OpenGLTokens

PFNGLPRIMITIVERESTARTINDEXPROC

OpenGLTokens

PFNGLPRIMITIVERESTARTNVPROC

OpenGLTokens

PFNGLPRIORITIZETEXTURESEXTPROC

OpenGLTokens

PFNGLPROGRAMBINARYPROC

OpenGLTokens

PFNGLPROGRAMENVPARAMETER4DARBPROC

OpenGLTokens

PFNGLPROGRAMENVPARAMETER4DVARBPROC

OpenGLTokens

PFNGLPROGRAMENVPARAMETER4FARBPROC

OpenGLTokens

PFNGLPROGRAMENVPARAMETER4FVARBPROC

OpenGLTokens

PFNGLPROGRAMENVPARAMETERS4FVEXTPROC

OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4DARBPROC

OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4DVARBPROC

OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4FARBPROC

OpenGLTokens

PFNGLPROGRAMLOCALPARAMETER4FVARBPROC

OpenGLTokens

PFNGLPROGRAMLOCALPARAMETERS4FVEXTPROC

OpenGLTokens

PFNGLPROGRAMPARAMETER4DNVPROC

OpenGLTokens

PFNGLPROGRAMPARAMETER4DVNVPROC

OpenGLTokens

PFNGLPROGRAMPARAMETER4FNVPROC

OpenGLTokens

PFNGLPROGRAMPARAMETER4FVNVPROC

OpenGLTokens

PFNGLPROGRAMPARAMETERIARBPROC

OpenGLTokens

PFNGLPROGRAMPARAMETERIEXTPROC

OpenGLTokens

PFNGLPROGRAMPARAMETERIPROC

OpenGLTokens

PFNGLPROGRAMPARAMETERS4DVNVPROC

OpenGLTokens

PFNGLPROGRAMPARAMETERS4FVNVPROC

OpenGLTokens

PFNGLPROGRAMSTRINGARBPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM1DEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM1DPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM1DVEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM1DVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM1FPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM1FVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM1IPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM1IVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM1UIPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM1UIVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM2DEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM2DPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM2DVEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM2DVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM2FPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM2FVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM2IPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM2IVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM2UIPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM2UIVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM3DEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM3DPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM3DVEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM3DVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM3FPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM3FVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM3IPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM3IVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM3UIPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM3UIVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM4DEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM4DPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM4DVEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM4DVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM4FPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM4FVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM4IPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM4IVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM4UIPROC

OpenGLTokens

PFNGLPROGRAMUNIFORM4UIVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2DVEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2DVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2FVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3DVEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3DVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X3FVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4DVEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4DVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX2X4FVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3DVEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3DVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3FVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2DVEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2DVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X2FVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4DVEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4DVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX3X4FVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4DVEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4DVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4FVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2DVEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2DVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X2FVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3DVEXTPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3DVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMMATRIX4X3FVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMUI64NVPROC

OpenGLTokens

PFNGLPROGRAMUNIFORMUI64VNVPROC

OpenGLTokens

PFNGLPROGRAMVERTEXLIMITNVPROC

OpenGLTokens

PFNGLPROVOKINGVERTEXPROC

OpenGLTokens

PFNGLPUSHCLIENTATTRIBDEFAULTEXTPROC

OpenGLTokens

PFNGLQUERYCOUNTERPROC

OpenGLTokens

PFNGLREADNPIXELSARBPROC

OpenGLTokens

PFNGLRELEASESHADERCOMPILERPROC

OpenGLTokens

PFNGLRENDERBUFFERSTORAGEEXTPROC

OpenGLTokens

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEEXTPROC

OpenGLTokens

PFNGLRENDERBUFFERSTORAGEMULTISAMPLEPROC

OpenGLTokens

PFNGLRENDERBUFFERSTORAGEPROC

OpenGLTokens

PFNGLREQUESTRESIDENTPROGRAMSNVPROC

OpenGLTokens

PFNGLRESETHISTOGRAMPROC

OpenGLTokens

PFNGLRESETMINMAXPROC

OpenGLTokens

PFNGLRESIZEBUFFERSMESAPROC

OpenGLTokens

PFNGLRESUMETRANSFORMFEEDBACKPROC

OpenGLTokens

PFNGLSAMPLECOVERAGEARBPROC

OpenGLTokens

PFNGLSAMPLECOVERAGEPROC

OpenGLTokens

PFNGLSAMPLEMASKEXTPROC

OpenGLTokens

PFNGLSAMPLEMASKIPROC

OpenGLTokens

PFNGLSAMPLEMASKSGISPROC

OpenGLTokens

PFNGLSAMPLEPASSARBPROC

OpenGLTokens

PFNGLSAMPLEPATTERNEXTPROC

OpenGLTokens

PFNGLSAMPLEPATTERNSGISPROC

OpenGLTokens

PFNGLSAMPLERPARAMETERFPROC

OpenGLTokens

PFNGLSAMPLERPARAMETERFVPROC

OpenGLTokens

PFNGLSAMPLERPARAMETERIIVPROC

OpenGLTokens

PFNGLSAMPLERPARAMETERIPROC

OpenGLTokens

PFNGLSAMPLERPARAMETERIUIVPROC

OpenGLTokens

PFNGLSAMPLERPARAMETERIVPROC

OpenGLTokens

PFNGLSCISSORARRAYVPROC

OpenGLTokens

PFNGLSCISSORINDEXEDPROC

OpenGLTokens

PFNGLSCISSORINDEXEDVPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3BEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3BPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3BVEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3BVPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3DEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3DPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3DVEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3DVPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3FEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3FPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3FVEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3FVPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3IEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3IPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3IVEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3IVPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3SEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3SPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3SVEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3SVPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3UBEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3UBPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3UBVEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3UBVPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3UIEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3UIPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3UIVEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3UIVPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3USEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3USPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3USVEXTPROC

OpenGLTokens

PFNGLSECONDARYCOLOR3USVPROC

OpenGLTokens

PFNGLSECONDARYCOLORFORMATNVPROC

OpenGLTokens

PFNGLSECONDARYCOLORP3UIPROC

OpenGLTokens

PFNGLSECONDARYCOLORP3UIVPROC

OpenGLTokens

PFNGLSECONDARYCOLORPOINTEREXTPROC

OpenGLTokens

PFNGLSECONDARYCOLORPOINTERPROC

OpenGLTokens

PFNGLSEPARABLEFILTER2DPROC

OpenGLTokens

PFNGLSETFENCENVPROC

OpenGLTokens

PFNGLSHADERBINARYPROC

OpenGLTokens

PFNGLSHADERSOURCEARBPROC

OpenGLTokens

PFNGLSHADERSOURCEPROC

OpenGLTokens

PFNGLSTENCILCLEARTAGEXTPROC

OpenGLTokens

PFNGLSTENCILFILLPATHINSTANCEDNVPROC

OpenGLTokens

PFNGLSTENCILFILLPATHNVPROC

OpenGLTokens

PFNGLSTENCILFUNCSEPARATEPROC

OpenGLTokens

PFNGLSTENCILMASKSEPARATEPROC

OpenGLTokens

PFNGLSTENCILOPSEPARATEPROC

OpenGLTokens

PFNGLSTENCILSTROKEPATHINSTANCEDNVPROC

OpenGLTokens

PFNGLSTENCILSTROKEPATHNVPROC

OpenGLTokens

PFNGLSTRINGMARKERGREMEDYPROC

OpenGLTokens

PFNGLTBUFFERMASK3DFXPROC

OpenGLTokens

PFNGLTESSELLATIONFACTORAMDPROC

OpenGLTokens

PFNGLTESSELLATIONMODEAMDPROC

OpenGLTokens

PFNGLTESTFENCENVPROC

OpenGLTokens

PFNGLTEXBUFFERARBPROC

OpenGLTokens

PFNGLTEXBUFFEREXTPROC

OpenGLTokens

PFNGLTEXBUFFERPROC

OpenGLTokens

PFNGLTEXCOORDFORMATNVPROC

OpenGLTokens

PFNGLTEXCOORDP1UIPROC

OpenGLTokens

PFNGLTEXCOORDP1UIVPROC

OpenGLTokens

PFNGLTEXCOORDP2UIPROC

OpenGLTokens

PFNGLTEXCOORDP2UIVPROC

OpenGLTokens

PFNGLTEXCOORDP3UIPROC

OpenGLTokens

PFNGLTEXCOORDP3UIVPROC

OpenGLTokens

PFNGLTEXCOORDP4UIPROC

OpenGLTokens

PFNGLTEXCOORDP4UIVPROC

OpenGLTokens

PFNGLTEXIMAGE2DMULTISAMPLEPROC

OpenGLTokens

PFNGLTEXIMAGE3DEXTPROC

OpenGLTokens

PFNGLTEXIMAGE3DMULTISAMPLEPROC

OpenGLTokens

PFNGLTEXIMAGE3DPROC

OpenGLTokens

PFNGLTEXPARAMETERIIVEXTPROC

OpenGLTokens

PFNGLTEXPARAMETERIIVPROC

OpenGLTokens

PFNGLTEXPARAMETERIUIVEXTPROC

OpenGLTokens

PFNGLTEXPARAMETERIUIVPROC

OpenGLTokens

PFNGLTEXSUBIMAGE1DEXTPROC

OpenGLTokens

PFNGLTEXSUBIMAGE2DEXTPROC

OpenGLTokens

PFNGLTEXSUBIMAGE3DEXTPROC

OpenGLTokens

PFNGLTEXSUBIMAGE3DPROC

OpenGLTokens

PFNGLTEXTUREBUFFEREXTPROC

OpenGLTokens

PFNGLTEXTURECOLORMASKSGISPROC

OpenGLTokens

PFNGLTEXTUREIMAGE1DEXTPROC

OpenGLTokens

PFNGLTEXTUREIMAGE2DEXTPROC

OpenGLTokens

PFNGLTEXTUREIMAGE3DEXTPROC

OpenGLTokens

PFNGLTEXTUREPARAMETERFEXTPROC

OpenGLTokens

PFNGLTEXTUREPARAMETERFVEXTPROC

OpenGLTokens

PFNGLTEXTUREPARAMETERIEXTPROC

OpenGLTokens

PFNGLTEXTUREPARAMETERIIVEXTPROC

OpenGLTokens

PFNGLTEXTUREPARAMETERIUIVEXTPROC

OpenGLTokens

PFNGLTEXTUREPARAMETERIVEXTPROC

OpenGLTokens

PFNGLTEXTURERENDERBUFFEREXTPROC

OpenGLTokens

PFNGLTEXTURESUBIMAGE1DEXTPROC

OpenGLTokens

PFNGLTEXTURESUBIMAGE2DEXTPROC

OpenGLTokens

PFNGLTEXTURESUBIMAGE3DEXTPROC

OpenGLTokens

PFNGLTRACKMATRIXNVPROC

OpenGLTokens

PFNGLTRANSFORMFEEDBACKATTRIBSNVPROC

OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSEXTPROC

OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSNVPROC

OpenGLTokens

PFNGLTRANSFORMFEEDBACKVARYINGSPROC

OpenGLTokens

PFNGLTRANSFORMPATHNVPROC

OpenGLTokens

PFNGLUDELETENURBSTESSELLATOREXTPROC

OpenGLTokens

PFNGLUNEWNURBSTESSELLATOREXTPROC

OpenGLTokens

PFNGLUNIFORM1DPROC

OpenGLTokens

PFNGLUNIFORM1DVPROC

OpenGLTokens

PFNGLUNIFORM1FARBPROC

OpenGLTokens

PFNGLUNIFORM1FPROC

OpenGLTokens

PFNGLUNIFORM1FVARBPROC

OpenGLTokens

PFNGLUNIFORM1FVPROC

OpenGLTokens

PFNGLUNIFORM1IARBPROC

OpenGLTokens

PFNGLUNIFORM1IPROC

OpenGLTokens

PFNGLUNIFORM1IVARBPROC

OpenGLTokens

PFNGLUNIFORM1IVPROC

OpenGLTokens

PFNGLUNIFORM1UIEXTPROC

OpenGLTokens

PFNGLUNIFORM1UIPROC

OpenGLTokens

PFNGLUNIFORM1UIVEXTPROC

OpenGLTokens

PFNGLUNIFORM1UIVPROC

OpenGLTokens

PFNGLUNIFORM2DPROC

OpenGLTokens

PFNGLUNIFORM2DVPROC

OpenGLTokens

PFNGLUNIFORM2FARBPROC

OpenGLTokens

PFNGLUNIFORM2FPROC

OpenGLTokens

PFNGLUNIFORM2FVARBPROC

OpenGLTokens

PFNGLUNIFORM2FVPROC

OpenGLTokens

PFNGLUNIFORM2IARBPROC

OpenGLTokens

PFNGLUNIFORM2IPROC

OpenGLTokens

PFNGLUNIFORM2IVARBPROC

OpenGLTokens

PFNGLUNIFORM2IVPROC

OpenGLTokens

PFNGLUNIFORM2UIEXTPROC

OpenGLTokens

PFNGLUNIFORM2UIPROC

OpenGLTokens

PFNGLUNIFORM2UIVEXTPROC

OpenGLTokens

PFNGLUNIFORM2UIVPROC

OpenGLTokens

PFNGLUNIFORM3DPROC

OpenGLTokens

PFNGLUNIFORM3DVPROC

OpenGLTokens

PFNGLUNIFORM3FARBPROC

OpenGLTokens

PFNGLUNIFORM3FPROC

OpenGLTokens

PFNGLUNIFORM3FVARBPROC

OpenGLTokens

PFNGLUNIFORM3FVPROC

OpenGLTokens

PFNGLUNIFORM3IARBPROC

OpenGLTokens

PFNGLUNIFORM3IPROC

OpenGLTokens

PFNGLUNIFORM3IVARBPROC

OpenGLTokens

PFNGLUNIFORM3IVPROC

OpenGLTokens

PFNGLUNIFORM3UIEXTPROC

OpenGLTokens

PFNGLUNIFORM3UIPROC

OpenGLTokens

PFNGLUNIFORM3UIVEXTPROC

OpenGLTokens

PFNGLUNIFORM3UIVPROC

OpenGLTokens

PFNGLUNIFORM4DPROC

OpenGLTokens

PFNGLUNIFORM4DVPROC

OpenGLTokens

PFNGLUNIFORM4FARBPROC

OpenGLTokens

PFNGLUNIFORM4FPROC

OpenGLTokens

PFNGLUNIFORM4FVARBPROC

OpenGLTokens

PFNGLUNIFORM4FVPROC

OpenGLTokens

PFNGLUNIFORM4IARBPROC

OpenGLTokens

PFNGLUNIFORM4IPROC

OpenGLTokens

PFNGLUNIFORM4IVARBPROC

OpenGLTokens

PFNGLUNIFORM4IVPROC

OpenGLTokens

PFNGLUNIFORM4UIEXTPROC

OpenGLTokens

PFNGLUNIFORM4UIPROC

OpenGLTokens

PFNGLUNIFORM4UIVEXTPROC

OpenGLTokens

PFNGLUNIFORM4UIVPROC

OpenGLTokens

PFNGLUNIFORMBLOCKBINDINGPROC

OpenGLTokens

PFNGLUNIFORMBUFFEREXTPROC

OpenGLTokens

PFNGLUNIFORMMATRIX2DVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX2FVARBPROC

OpenGLTokens

PFNGLUNIFORMMATRIX2FVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX2X3DVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX2X3FVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX2X4DVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX2X4FVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX3DVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX3FVARBPROC

OpenGLTokens

PFNGLUNIFORMMATRIX3FVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX3X2DVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX3X2FVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX3X4DVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX3X4FVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX4DVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX4FVARBPROC

OpenGLTokens

PFNGLUNIFORMMATRIX4FVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX4X2DVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX4X2FVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX4X3DVPROC

OpenGLTokens

PFNGLUNIFORMMATRIX4X3FVPROC

OpenGLTokens

PFNGLUNIFORMSUBROUTINESUIVPROC

OpenGLTokens

PFNGLUNIFORMUI64NVPROC

OpenGLTokens

PFNGLUNIFORMUI64VNVPROC

OpenGLTokens

PFNGLUNLOCKARRAYSEXTPROC

OpenGLTokens

PFNGLUNMAPBUFFERARBPROC

OpenGLTokens

PFNGLUNMAPBUFFERPROC

OpenGLTokens

PFNGLUNMAPNAMEDBUFFEREXTPROC

OpenGLTokens

PFNGLUNURBSCALLBACKDATAEXTPROC

OpenGLTokens

PFNGLUSEPROGRAMOBJECTARBPROC

OpenGLTokens

PFNGLUSEPROGRAMPROC

OpenGLTokens

PFNGLUSEPROGRAMSTAGESPROC

OpenGLTokens

PFNGLVALIDATEPROGRAMARBPROC

OpenGLTokens

PFNGLVALIDATEPROGRAMPIPELINEPROC

OpenGLTokens

PFNGLVALIDATEPROGRAMPROC

OpenGLTokens

PFNGLVERTEXARRAYRANGENVPROC

OpenGLTokens

PFNGLVERTEXARRAYVERTEXATTRIBLOFFSETEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIB1DARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB1DNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB1DPROC

OpenGLTokens

PFNGLVERTEXATTRIB1DVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB1DVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB1DVPROC

OpenGLTokens

PFNGLVERTEXATTRIB1FARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB1FNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB1FPROC

OpenGLTokens

PFNGLVERTEXATTRIB1FVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB1FVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB1FVPROC

OpenGLTokens

PFNGLVERTEXATTRIB1SARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB1SNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB1SPROC

OpenGLTokens

PFNGLVERTEXATTRIB1SVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB1SVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB1SVPROC

OpenGLTokens

PFNGLVERTEXATTRIB2DARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB2DNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB2DPROC

OpenGLTokens

PFNGLVERTEXATTRIB2DVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB2DVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB2DVPROC

OpenGLTokens

PFNGLVERTEXATTRIB2FARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB2FNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB2FPROC

OpenGLTokens

PFNGLVERTEXATTRIB2FVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB2FVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB2FVPROC

OpenGLTokens

PFNGLVERTEXATTRIB2SARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB2SNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB2SPROC

OpenGLTokens

PFNGLVERTEXATTRIB2SVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB2SVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB2SVPROC

OpenGLTokens

PFNGLVERTEXATTRIB3DARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB3DNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB3DPROC

OpenGLTokens

PFNGLVERTEXATTRIB3DVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB3DVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB3DVPROC

OpenGLTokens

PFNGLVERTEXATTRIB3FARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB3FNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB3FPROC

OpenGLTokens

PFNGLVERTEXATTRIB3FVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB3FVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB3FVPROC

OpenGLTokens

PFNGLVERTEXATTRIB3SARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB3SNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB3SPROC

OpenGLTokens

PFNGLVERTEXATTRIB3SVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB3SVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB3SVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4BVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4BVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4DARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4DNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4DPROC

OpenGLTokens

PFNGLVERTEXATTRIB4DVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4DVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4DVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4FARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4FNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4FPROC

OpenGLTokens

PFNGLVERTEXATTRIB4FVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4FVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4FVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4IVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4IVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4NBVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4NBVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4NIVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4NIVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4NSVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4NSVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4NUBARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4NUBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4NUBVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4NUBVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4NUIVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4NUIVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4NUSVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4NUSVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4SARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4SNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4SPROC

OpenGLTokens

PFNGLVERTEXATTRIB4SVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4SVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4SVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4UBVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4UBVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4UBVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4UIVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4UIVPROC

OpenGLTokens

PFNGLVERTEXATTRIB4USVARBPROC

OpenGLTokens

PFNGLVERTEXATTRIB4USVPROC

OpenGLTokens

PFNGLVERTEXATTRIBDIVISORARBPROC

OpenGLTokens

PFNGLVERTEXATTRIBDIVISORPROC

OpenGLTokens

PFNGLVERTEXATTRIBFORMATNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBI1IEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI1IPROC

OpenGLTokens

PFNGLVERTEXATTRIBI1IVEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI1IVPROC

OpenGLTokens

PFNGLVERTEXATTRIBI1UIEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI1UIPROC

OpenGLTokens

PFNGLVERTEXATTRIBI1UIVEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI1UIVPROC

OpenGLTokens

PFNGLVERTEXATTRIBI2IEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI2IPROC

OpenGLTokens

PFNGLVERTEXATTRIBI2IVEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI2IVPROC

OpenGLTokens

PFNGLVERTEXATTRIBI2UIEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI2UIPROC

OpenGLTokens

PFNGLVERTEXATTRIBI2UIVEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI2UIVPROC

OpenGLTokens

PFNGLVERTEXATTRIBI3IEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI3IPROC

OpenGLTokens

PFNGLVERTEXATTRIBI3IVEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI3IVPROC

OpenGLTokens

PFNGLVERTEXATTRIBI3UIEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI3UIPROC

OpenGLTokens

PFNGLVERTEXATTRIBI3UIVEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI3UIVPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4BVEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4BVPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4IEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4IPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4IVEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4IVPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4SVEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4SVPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4UBVEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4UBVPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4UIEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4UIPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4UIVEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4UIVPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4USVEXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBI4USVPROC

OpenGLTokens

PFNGLVERTEXATTRIBIFORMATNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBIPOINTEREXTPROC

OpenGLTokens

PFNGLVERTEXATTRIBIPOINTERPROC

OpenGLTokens

PFNGLVERTEXATTRIBL1DPROC

OpenGLTokens

PFNGLVERTEXATTRIBL1DVPROC

OpenGLTokens

PFNGLVERTEXATTRIBL2DPROC

OpenGLTokens

PFNGLVERTEXATTRIBL2DVPROC

OpenGLTokens

PFNGLVERTEXATTRIBL3DPROC

OpenGLTokens

PFNGLVERTEXATTRIBL3DVPROC

OpenGLTokens

PFNGLVERTEXATTRIBL4DPROC

OpenGLTokens

PFNGLVERTEXATTRIBL4DVPROC

OpenGLTokens

PFNGLVERTEXATTRIBLPOINTERPROC

OpenGLTokens

PFNGLVERTEXATTRIBP1UIPROC

OpenGLTokens

PFNGLVERTEXATTRIBP1UIVPROC

OpenGLTokens

PFNGLVERTEXATTRIBP2UIPROC

OpenGLTokens

PFNGLVERTEXATTRIBP2UIVPROC

OpenGLTokens

PFNGLVERTEXATTRIBP3UIPROC

OpenGLTokens

PFNGLVERTEXATTRIBP3UIVPROC

OpenGLTokens

PFNGLVERTEXATTRIBP4UIPROC

OpenGLTokens

PFNGLVERTEXATTRIBP4UIVPROC

OpenGLTokens

PFNGLVERTEXATTRIBPOINTERARBPROC

OpenGLTokens

PFNGLVERTEXATTRIBPOINTERNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBPOINTERPROC

OpenGLTokens

PFNGLVERTEXATTRIBS1DVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBS1FVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBS1SVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBS2DVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBS2FVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBS2SVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBS3DVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBS3FVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBS3SVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBS4DVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBS4FVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBS4SVNVPROC

OpenGLTokens

PFNGLVERTEXATTRIBS4UBVNVPROC

OpenGLTokens

PFNGLVERTEXBLENDARBPROC

OpenGLTokens

PFNGLVERTEXFORMATNVPROC

OpenGLTokens

PFNGLVERTEXP2UIPROC

OpenGLTokens

PFNGLVERTEXP2UIVPROC

OpenGLTokens

PFNGLVERTEXP3UIPROC

OpenGLTokens

PFNGLVERTEXP3UIVPROC

OpenGLTokens

PFNGLVERTEXP4UIPROC

OpenGLTokens

PFNGLVERTEXP4UIVPROC

OpenGLTokens

PFNGLVIEWPORTARRAYVPROC

OpenGLTokens

PFNGLVIEWPORTINDEXEDFPROC

OpenGLTokens

PFNGLVIEWPORTINDEXEDFVPROC

OpenGLTokens

PFNGLWAITSYNCPROC

OpenGLTokens

PFNGLWEIGHTBVARBPROC

OpenGLTokens

PFNGLWEIGHTDVARBPROC

OpenGLTokens

PFNGLWEIGHTFVARBPROC

OpenGLTokens

PFNGLWEIGHTIVARBPROC

OpenGLTokens

PFNGLWEIGHTPATHSNVPROC

OpenGLTokens

PFNGLWEIGHTPOINTERARBPROC

OpenGLTokens

PFNGLWEIGHTSVARBPROC

OpenGLTokens

PFNGLWEIGHTUBVARBPROC

OpenGLTokens

PFNGLWEIGHTUIVARBPROC

OpenGLTokens

PFNGLWEIGHTUSVARBPROC

OpenGLTokens

PFNGLWINDOWPOS2DARBPROC

OpenGLTokens

PFNGLWINDOWPOS2DPROC

OpenGLTokens

PFNGLWINDOWPOS2DVARBPROC

OpenGLTokens

PFNGLWINDOWPOS2DVPROC

OpenGLTokens

PFNGLWINDOWPOS2FARBPROC

OpenGLTokens

PFNGLWINDOWPOS2FPROC

OpenGLTokens

PFNGLWINDOWPOS2FVARBPROC

OpenGLTokens

PFNGLWINDOWPOS2FVPROC

OpenGLTokens

PFNGLWINDOWPOS2IARBPROC

OpenGLTokens

PFNGLWINDOWPOS2IPROC

OpenGLTokens

PFNGLWINDOWPOS2IVARBPROC

OpenGLTokens

PFNGLWINDOWPOS2IVPROC

OpenGLTokens

PFNGLWINDOWPOS2SARBPROC

OpenGLTokens

PFNGLWINDOWPOS2SPROC

OpenGLTokens

PFNGLWINDOWPOS2SVARBPROC

OpenGLTokens

PFNGLWINDOWPOS2SVPROC

OpenGLTokens

PFNGLWINDOWPOS3DARBPROC

OpenGLTokens

PFNGLWINDOWPOS3DPROC

OpenGLTokens

PFNGLWINDOWPOS3DVARBPROC

OpenGLTokens

PFNGLWINDOWPOS3DVPROC

OpenGLTokens

PFNGLWINDOWPOS3FARBPROC

OpenGLTokens

PFNGLWINDOWPOS3FPROC

OpenGLTokens

PFNGLWINDOWPOS3FVARBPROC

OpenGLTokens

PFNGLWINDOWPOS3FVPROC

OpenGLTokens

PFNGLWINDOWPOS3IARBPROC

OpenGLTokens

PFNGLWINDOWPOS3IPROC

OpenGLTokens

PFNGLWINDOWPOS3IVARBPROC

OpenGLTokens

PFNGLWINDOWPOS3IVPROC

OpenGLTokens

PFNGLWINDOWPOS3SARBPROC

OpenGLTokens

PFNGLWINDOWPOS3SPROC

OpenGLTokens

PFNGLWINDOWPOS3SVARBPROC

OpenGLTokens

PFNGLWINDOWPOS3SVPROC

OpenGLTokens

PFNWGLALLOCATEMEMORYNVPROC

OpenGLTokens

PFNWGLBINDTEXIMAGEARBPROC

OpenGLTokens

PFNWGLCHOOSEPIXELFORMATARBPROC

OpenGLTokens

PFNWGLCREATEAFFINITYDCNVPROC

OpenGLTokens

PFNWGLCREATEBUFFERREGIONARBPROC

OpenGLTokens

PFNWGLCREATECONTEXTATTRIBSARBPROC

OpenGLTokens

PFNWGLCREATEPBUFFERARBPROC

OpenGLTokens

PFNWGLDELETEBUFFERREGIONARBPROC

OpenGLTokens

PFNWGLDELETEDCNVPROC

OpenGLTokens

PFNWGLDESTROYPBUFFERARBPROC

OpenGLTokens

PFNWGLDXCLOSEDEVICEPROC

OpenGLTokens

PFNWGLDXLOCKOBJECTSPROC

OpenGLTokens

PFNWGLDXOBJECTACCESSPROC

OpenGLTokens

PFNWGLDXOPENDEVICEPROC

OpenGLTokens

PFNWGLDXREGISTEROBJECTPROC

OpenGLTokens

PFNWGLDXSETRESOURCESHAREHANDLEPROC

OpenGLTokens

PFNWGLDXUNLOCKOBJECTSNVPROC

OpenGLTokens

PFNWGLDXUNREGISTEROBJECTPROC

OpenGLTokens

PFNWGLENUMGPUDEVICESNVPROC

OpenGLTokens

PFNWGLENUMGPUSFROMAFFINITYDCNVPROC

OpenGLTokens

PFNWGLENUMGPUSNVPROC

OpenGLTokens

PFNWGLFREEMEMORYNVPROC

OpenGLTokens

PFNWGLGETCURRENTREADDCARBPROC

OpenGLTokens

PFNWGLGETEXTENSIONSSTRINGARBPROC

OpenGLTokens

PFNWGLGETPBUFFERDCARBPROC

OpenGLTokens

PFNWGLGETPIXELFORMATATTRIBFVARBPROC

OpenGLTokens

PFNWGLGETPIXELFORMATATTRIBIVARBPROC

OpenGLTokens

PFNWGLGETSWAPINTERVALEXTPROC

OpenGLTokens

PFNWGLMAKECONTEXTCURRENTARBPROC

OpenGLTokens

PFNWGLQUERYPBUFFERARBPROC

OpenGLTokens

PFNWGLRELEASEPBUFFERDCARBPROC

OpenGLTokens

PFNWGLRELEASETEXIMAGEARBPROC

OpenGLTokens

PFNWGLRESTOREBUFFERREGIONARBPROC

OpenGLTokens

PFNWGLSAVEBUFFERREGIONARBPROC

OpenGLTokens

PFNWGLSETPBUFFERATTRIBARBPROC

OpenGLTokens

PFNWGLSWAPINTERVALEXTPROC

OpenGLTokens

PFog

Types3DS

PFogSettings3DS

Types3DS

PFontEntry

GLSpaceText

PFovTrackTag

Types3DS

PFSoundDSPUnit

fmodtypes

PFSoundSample

fmodtypes

PFSoundStream

fmodtypes

PFSoundVector

fmodtypes

PFSyncPoint

fmodtypes

pFT_Raster_Params

LIBFREETYPE

PFXPointerList

GLParticleFX

PGLbitfield

OpenGLTokens

PGLboolean

OpenGLTokens

PGLbyte

OpenGLTokens

PGLChar

OpenGLTokens

PGLclampd

OpenGLTokens

PGLclampf

OpenGLTokens

PGLdouble

OpenGLTokens

PGLenum

OpenGLTokens

PGLfloat

OpenGLTokens

PGLhandleARB

OpenGLTokens

PGLint

OpenGLTokens

PGLint64

OpenGLTokens

PGLint64EXT

OpenGLTokens

PGLParticleArray

GLParticleFX

PGLPCharArray

OpenGLTokens

PGLPixel24

GLGraphics

PGLPixel32

GLGraphics

PGLPixel32Array

GLGraphics

PGLPoint

GLCrossPlatform

PGLPoint2D

GLTypes

PGLPoint3D

GLTypes

PGLPointer

OpenGLTokens

PGLRCHandle

GLContext

PGLRect

GLCrossPlatform

PGLshort

OpenGLTokens

PGLsizei

OpenGLTokens

PGLStarRecord

GLStarRecord

PGLubyte

OpenGLTokens

PGLuint

OpenGLTokens

PGLuint64

OpenGLTokens

PGLuint64EXT

OpenGLTokens

PGLUNurbs

OpenGLTokens

PGLUNurbsObj

OpenGLTokens

PGLUQuadric

OpenGLTokens

PGLUQuadricObj

OpenGLTokens

PGLushort

OpenGLTokens

PGLUTesselator

OpenGLTokens

PGLUTesselatorObj

OpenGLTokens

PGLUTriangulatorObj

OpenGLTokens

PGLvdpauSurfaceNV

OpenGLTokens

PGLvoid

OpenGLTokens

PGNGLGETBUFFERPARAMETERUI64VNV

OpenGLTokens

PGPUDevice

OpenGLTokens

PHalfFloat

GLCrossPlatform

PHeightTile

HeightTileFile

PHeightTileInfo

HeightTileFile

PHGPUNV

OpenGLTokens

PHideTrackTag

Types3DS

PHiShadowBias

Types3DS

PHmgBoundingBox

GeometryBB

PHomogeneousByteVector

VectorGeometry

PHomogeneousDblVector

VectorGeometry

PHomogeneousExtVector

VectorGeometry

PHomogeneousFltVector

VectorGeometry

PHomogeneousIntVector

VectorGeometry

PHomogeneousMatrix

VectorGeometry

PHomogeneousPtrVector

VectorGeometry

PHomogeneousVector

VectorGeometry

PHomogeneousWordVector

VectorGeometry

PHotTrackTag

Types3DS

PHVIDEO

GLSVfw

PI1

LWObjects

PI2

LWObjects

PI4

LWObjects

PICCOMPRESS

GLSVfw

PICCOMPRESSFRAMES

GLSVfw

PICDECOMPRESS

GLSVfw

PICDECOMPRESSEX

GLSVfw

PICDRAW

GLSVfw

PICDRAWBEGIN

GLSVfw

PICDRAWSUGGEST

GLSVfw

PICINFO

GLSVfw

PICOPEN

GLSVfw

PICPALETTE

GLSVfw

PICSETSTATUSPROC

GLSVfw

PID4

LWObjects

PInstanceName

Types3DS

PInt

GLSDL

PInt

NewtonImport

PInteger

HeightTileFile

PInteger

GLSDL

PIntegerArray

VectorGeometry

PIntegerArray

Types3DS

PIntegerArray

HeightTileFile

PIntegerVector

VectorGeometry

PIntermediateFormatArray

ImageUtils

PIntPercentage

Types3DS

PIpasData

Types3DS

Pitch

VectorGeometry

Rotates the given coordinate system (represented by the matrix) around its X-axis

Pitch

VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterRight

PIVOT

Const3DS

PIVOT_LIMITS

Const3DS

PIVOT_OBJECT

Const3DS

PIVOT_ORDER

Const3DS

PixelFormatToColorBits

GLCrossPlatform

Returns the number of color bits associated to the given pixel format.

PJoystick_hwdata

GLSDL

PKeyHeader3DS

Types3DS

PKeyHeaderList

Types3DS

PKEYSChunk

TypesB3D

PKeyStateArr

GLSDL

PKFAmbient3DS

Types3DS

PKFCamera3DS

Types3DS

PKFCurtime

Types3DS

PKFHdr

Types3DS

PKFId

Types3DS

PKFKeyInfo3DS

Types3DS

PKFMesh3DS

Types3DS

PKFMorphKey3DS

Types3DS

PKFMorphKeyList

Types3DS

PKFOmni3DS

Types3DS

PKFRotKey3DS

Types3DS

PKFRotKeyList

Types3DS

PKFSeg

Types3DS

PKFSegment3DS

Types3DS

PKFSets3DS

Types3DS

PKFSpot3DS

Types3DS

PlaneAABBIntersection

GeometryBB

Compute the intersection between a plane and the AABB

PlaneContainsBSphere

GeometryBB

PlaneEvaluatePoint

VectorGeometry

PlaneEvaluatePoint

VectorGeometry

Calculates the cross-product between the plane normal and plane to point vector.<p> This functions gives an hint as to were the point is, if the point is in the half-space pointed by the vector, result is positive.<p> This function performs an homogeneous space dot-product.

PlaneIntersectAABB

GeometryBB

PlaneMake

VectorGeometry

PlaneMake

VectorGeometry

Computes the parameters of a plane defined by a point and a normal.

PlaneMake

VectorGeometry

PlaneMake

VectorGeometry

Computes the parameters of a plane defined by three points.

PLayerFog

Types3DS

PLayerFogSettings3DS

Types3DS

PlayOnWaveOut

GLSMWaveOut

PlayOnWaveOut

GLSMWaveOut

PLight3DS

Types3DS

PLinColor24

Types3DS

PLinColorF

Types3DS

PLiteAttenuate3DS

Types3DS

PLMTS

GLFileLMTS

PLMTS_Header

GLFileLMTS

PLMTS_Subset

GLFileLMTS

PLMTS_TexData

GLFileLMTS

PLMTS_Vertex

GLFileLMTS

PLong

NewtonImport

PLONG

GLSVfw

PLongWord

GLSDL

PLongWordArray

VectorGeometry

PLongWordVector

VectorGeometry

PLong_double

NewtonImport

PLoShadowBias

Types3DS

PlugInManagerPropForm

PlugInManagerPropEditor

PLWChunkRec

LWObjects

PLWPolyTagMap

LWObjects

PLWSubChunkRec

LWObjects

PM3dVersion

Types3DS

PMainAVIHeader

GLSVfw

PMapInfo3DS

Types3DS

PMapSet3DS

Types3DS

PMasterScale

Types3DS

PMatAcubic

Types3DS

PMatBumpPercent

Types3DS

PMaterial3DS

Types3DS

PMatMapAng

Types3DS

PMatMapBCol

Types3DS

PMatMapCol1

Types3DS

PMatMapCol2

Types3DS

PMatMapGCol

Types3DS

PMatMapname

Types3DS

PMatMapRCol

Types3DS

PMatMapTexblur

Types3DS

PMatMapTiling

Types3DS

PMatMapUOffset

Types3DS

PMatMapUScale

Types3DS

PMatMapVOffset

Types3DS

PMatMapVScale

Types3DS

PMatName

Types3DS

PMatrix

VectorGeometry

PMatrixArray

VectorGeometry

PMatShading

Types3DS

PMatWireSize

Types3DS

PMD2AliasFrame

TypesMD2

PMD2VertexIndex

TypesMD2

PMDCTagFrame

TypesMDC

PMDCTagName

TypesMDC

PMesh3DS

Types3DS

PMESHChunk

TypesB3D

PMeshColor

Types3DS

PMeshMatrix

Types3DS

PMeshSet3DS

Types3DS

PMeshTextureInfo

Types3DS

PMeshVersion

Types3DS

PMorphSmooth

Types3DS

PMorphTrackTag

Types3DS

pMS3DComment

TypesMS3D

PMS3DJointArray

TypesMS3D

PMS3DKeyframePositionArray

TypesMS3D

PMS3DKeyframeRotationArray

TypesMS3D

PMS3DTriangleArray

TypesMS3D

PMS3DVertexArray

TypesMS3D

pMS3D_vertex_ex_t

TypesMS3D

PMshBoxmap

Types3DS

PMshMatGroup

Types3DS

PNamedObject

Types3DS

PNCamera

Types3DS

PNDirectLight

Types3DS

PNewtonAllocMemory

NewtonImport

PNewtonApplyForceAndTorque

NewtonImport

PNewtonBallCallBack

NewtonImport

PNewtonBody

NewtonImport

PNewtonBodyDestructor

NewtonImport

PNewtonBodyIterator

NewtonImport

PNewtonBodyLeaveWorld

NewtonImport

PNewtonBreakableComponentMesh

NewtonImport

PNewtonCollision

NewtonImport

PNewtonCollisionCompoundBreakableCallback

NewtonImport

PNewtonCollisionDestructor

NewtonImport

PNewtonCollisionInfoRecord

NewtonImport

PNewtonCollisionIterator

NewtonImport

PNewtonCollisionTreeRayCastCallback

NewtonImport

PNewtonConstraintDestructor

NewtonImport

PNewtonContact

NewtonImport

PNewtonContactsProcess

NewtonImport

PNewtonCorkscrewCallBack

NewtonImport

PNewtonDeserialize

NewtonImport

PNewtonDestroyBodyByExeciveForce

NewtonImport

PNewtonDestroyWorld

NewtonImport

PNewtonFreeMemory

NewtonImport

PNewtonGetBuoyancyPlane

NewtonImport

PNewtonGetTicksCountCallback

NewtonImport

PNewtonHeightFieldRayCastCallback

NewtonImport

PNewtonHingeCallBack

NewtonImport

PNewtonHingeSliderUpdateDesc

NewtonImport

PNewtonIslandUpdate

NewtonImport

PNewtonJoint

NewtonImport

PNewtonJointIterator

NewtonImport

PNewtonJointRecord

NewtonImport

PNewtonMaterial

NewtonImport

PNewtonMesh

NewtonImport

PNewtonMeshEdge

NewtonImport

PNewtonMeshFace

NewtonImport

PNewtonMeshPoint

NewtonImport

PNewtonMeshVertex

NewtonImport

PNewtonOnAABBOverlap

NewtonImport

PNewtonSceneProxy

NewtonImport

PNewtonSerialize

NewtonImport

PNewtonSetTransform

NewtonImport

PNewtonSliderCallBack

NewtonImport

PNewtonTreeCollisionCallback

NewtonImport

PNewtonUniversalCallBack

NewtonImport

PNewtonUserBilateralCallBack

NewtonImport

PNewtonUserBilateralGetInfoCallBack

NewtonImport

PNewtonUserJoint

NewtonImport

PNewtonUserJointDestructorCallback

NewtonImport_JointLibrary

PNewtonUserJointSubmitConstraintCallback

NewtonImport_JointLibrary

PNewtonUserMeshCollisionCollideCallback

NewtonImport

PNewtonUserMeshCollisionCollideDesc

NewtonImport

PNewtonUserMeshCollisionDestroyCallback

NewtonImport

PNewtonUserMeshCollisionGetCollisionInfo

NewtonImport

PNewtonUserMeshCollisionGetFacesInAABB

NewtonImport

PNewtonUserMeshCollisionRayHitCallback

NewtonImport

PNewtonUserMeshCollisionRayHitDesc

NewtonImport

PNewtonWorld

NewtonImport

PNewtonWorldConvexCastReturnInfo

NewtonImport

PNewtonWorldRayFilterCallback

NewtonImport

PNewtonWorldRayPrefilterCallback

NewtonImport

PNGDFloat

GLNGDManager

pngErrorFn

LIBPNG

pngReadFn

LIBPNG

pngWarnFn

LIBPNG

pngWriteFn

LIBPNG

PNG_16_TO_8

LIBPNG

PNG_ADD_ALPHA

LIBPNG

PNG_AFTER_IDAT

LIBPNG

PNG_ALL_MNG_FEATURES

LIBPNG

PNG_BACKGROUND

LIBPNG

PNG_BACKGROUND_EXPAND

LIBPNG

PNG_BACKGROUND_GAMMA_FILE

LIBPNG

PNG_BACKGROUND_GAMMA_SCREEN

LIBPNG

PNG_BACKGROUND_GAMMA_UNIQUE

LIBPNG

PNG_BACKGROUND_GAMMA_UNKNOWN

LIBPNG

PNG_BACKGROUND_IS_GRAY

LIBPNG

PNG_BGR

LIBPNG

png_byte

LIBPNG

png_bytep

LIBPNG

png_bytepp

LIBPNG

png_bytep_array

LIBPNG

png_bytep_arrayp

LIBPNG

png_byte_array

LIBPNG

png_charp

LIBPNG

png_charpp

LIBPNG

png_charp_array

LIBPNG

png_charp_arrayp

LIBPNG

png_color

LIBPNG

Three color definitions. The order of the red, green, and blue, (and the exact size) is not important, although the size of the fields need to be png_byte or png_uint_16 (as defined below).

png_colorp

LIBPNG

png_colorpp

LIBPNG

png_color_16

LIBPNG

png_color_16p

LIBPNG

png_color_16pp

LIBPNG

png_color_8

LIBPNG

png_color_8p

LIBPNG

png_color_8pp

LIBPNG

png_color_array

LIBPNG

PNG_COLOR_MASK_ALPHA

LIBPNG

PNG_COLOR_MASK_COLOR

LIBPNG

PNG_COLOR_MASK_PALETTE

LIBPNG

PNG_COLOR_TYPE_GRAY

LIBPNG

PNG_COLOR_TYPE_GRAY_ALPHA

LIBPNG

PNG_COLOR_TYPE_PALETTE

LIBPNG

PNG_COLOR_TYPE_RGB

LIBPNG

PNG_COLOR_TYPE_RGB_ALPHA

LIBPNG

PNG_COMPRESSION_TYPE_BASE

LIBPNG

PNG_COMPRESSION_TYPE_DEFAULT

LIBPNG

png_const_charp

LIBPNG

PNG_DITHER

LIBPNG

png_doublep

LIBPNG

png_error_ptr

LIBPNG

PNG_EXPAND

LIBPNG

PNG_EXPAND_tRNS

LIBPNG

png_FILE_p

LIBPNG

PNG_FILLER

LIBPNG

PNG_FILTER_TYPE_BASE

LIBPNG

PNG_FILTER_TYPE_DEFAULT

LIBPNG

png_fixed_point

LIBPNG

png_fixed_point_p

LIBPNG

PNG_FLAG_ADD_ALPHA

LIBPNG

PNG_FLAG_BENIGN_ERRORS_WARN

LIBPNG

PNG_FLAG_CRC_ANCILLARY_MASK

LIBPNG

PNG_FLAG_CRC_ANCILLARY_NOWARN

LIBPNG

PNG_FLAG_CRC_ANCILLARY_USE

LIBPNG

PNG_FLAG_CRC_CRITICAL_IGNORE

LIBPNG

PNG_FLAG_CRC_CRITICAL_MASK

LIBPNG

PNG_FLAG_CRC_CRITICAL_USE

LIBPNG

PNG_FLAG_CRC_MASK

LIBPNG

PNG_FLAG_FILLER_AFTER

LIBPNG

PNG_FLAG_KEEP_UNKNOWN_CHUNKS

LIBPNG

PNG_FLAG_KEEP_UNSAFE_CHUNKS

LIBPNG

PNG_FLAG_LIBRARY_MISMATCH

LIBPNG

PNG_FLAG_MALLOC_NULL_MEM_OK

LIBPNG

PNG_FLAG_MNG_EMPTY_PLTE

LIBPNG

PNG_FLAG_MNG_FILTER_64

LIBPNG

PNG_FLAG_ROW_INIT

LIBPNG

PNG_FLAG_STRIP_ALPHA

LIBPNG

PNG_FLAG_STRIP_ERROR_NUMBERS

LIBPNG

PNG_FLAG_STRIP_ERROR_TEXT

LIBPNG

PNG_FLAG_ZLIB_CUSTOM_LEVEL

LIBPNG

PNG_FLAG_ZLIB_CUSTOM_MEM_LEVEL

LIBPNG

PNG_FLAG_ZLIB_CUSTOM_METHOD

LIBPNG

PNG_FLAG_ZLIB_CUSTOM_STRATEGY

LIBPNG

PNG_FLAG_ZLIB_CUSTOM_WINDOW_BITS

LIBPNG

PNG_FLAG_ZLIB_FINISHED

LIBPNG

png_flush_ptr

LIBPNG

PNG_FREE_ALL

LIBPNG

PNG_FREE_HIST

LIBPNG

PNG_FREE_ICCP

LIBPNG

PNG_FREE_LIST

LIBPNG

PNG_FREE_MUL

LIBPNG

PNG_FREE_PCAL

LIBPNG

PNG_FREE_PLTE

LIBPNG

png_free_ptr

LIBPNG

PNG_FREE_ROWS

LIBPNG

PNG_FREE_SCAL

LIBPNG

PNG_FREE_SPLT

LIBPNG

PNG_FREE_TEXT

LIBPNG

PNG_FREE_TRNS

LIBPNG

PNG_FREE_UNKN

LIBPNG

PNG_GAMMA

LIBPNG

PNG_GAMMA_THRESHOLD

LIBPNG

PNG_GRAY_TO_RGB

LIBPNG

PNG_HAVE_cHRM

LIBPNG

PNG_HAVE_CHUNK_AFTER_IDAT

LIBPNG

PNG_HAVE_CHUNK_HEADER

LIBPNG

PNG_HAVE_gAMA

LIBPNG

PNG_HAVE_IDAT

LIBPNG

PNG_HAVE_IEND

LIBPNG

PNG_HAVE_IHDR

LIBPNG

PNG_HAVE_PLTE

LIBPNG

PNG_HAVE_PNG_SIGNATURE

LIBPNG

PNG_HAVE_sRGB

LIBPNG

png_info

LIBPNG

png_infop

LIBPNG

png_infopp

LIBPNG

PNG_INFO_bKGD

LIBPNG

PNG_INFO_cHRM

LIBPNG

PNG_INFO_gAMA

LIBPNG

PNG_INFO_hIST

LIBPNG

PNG_INFO_iCCP

LIBPNG

PNG_INFO_IDAT

LIBPNG

PNG_INFO_oFFs

LIBPNG

PNG_INFO_pCAL

LIBPNG

PNG_INFO_pHYs

LIBPNG

PNG_INFO_PLTE

LIBPNG

PNG_INFO_sBIT

LIBPNG

PNG_INFO_sCAL

LIBPNG

PNG_INFO_sPLT

LIBPNG

PNG_INFO_sRGB

LIBPNG

PNG_INFO_tIME

LIBPNG

PNG_INFO_tRNS

LIBPNG

PNG_INTERLACE

LIBPNG

PNG_INTERLACE_ADAM7

LIBPNG

PNG_INTERLACE_LAST

LIBPNG

PNG_INTERLACE_NONE

LIBPNG

PNG_INTRAPIXEL_DIFFERENCING

LIBPNG

png_int_16

LIBPNG

png_int_16p

LIBPNG

png_int_32

LIBPNG

png_int_32p

LIBPNG

PNG_INVERT_ALPHA

LIBPNG

PNG_INVERT_MONO

LIBPNG

png_longjmp_ptr

LIBPNG

png_malloc_ptr

LIBPNG

PNG_PACK

LIBPNG

PNG_PACKSWAP

LIBPNG

png_progressive_end_ptr

LIBPNG

png_progressive_info_ptr

LIBPNG

png_progressive_row_ptr

LIBPNG

png_read_status_ptr

LIBPNG

PNG_RGBA

LIBPNG

PNG_RGB_TO_GRAY

LIBPNG

PNG_RGB_TO_GRAY_ERR

LIBPNG

PNG_RGB_TO_GRAY_WARN

LIBPNG

png_row_info

LIBPNG

png_row_infop

LIBPNG

png_rw_ptr

LIBPNG

PNG_SHIFT

LIBPNG

png_size_t

LIBPNG

png_sPLT_entry

LIBPNG

png_sPLT_entryp

LIBPNG

png_sPLT_entrypp

LIBPNG

png_sPLT_t

LIBPNG

png_sPLT_tp

LIBPNG

png_sPLT_tpp

LIBPNG

png_sPLT_tp_array

LIBPNG

number of palette entries

png_sPLT_tp_arrayp

LIBPNG

PNG_STRIP_ALPHA

LIBPNG

png_struct

LIBPNG

png_structp

LIBPNG

png_structpp

LIBPNG

PNG_SWAP_ALPHA

LIBPNG

PNG_SWAP_BYTES

LIBPNG

png_text

LIBPNG

png_textp

LIBPNG

png_textpp

LIBPNG

png_text_array

LIBPNG

png_text_arrayp

LIBPNG

png_time

LIBPNG

png_timep

LIBPNG

second of minute, 0 - 60 (for leap seconds)

png_timepp

LIBPNG

png_uint_16

LIBPNG

png_uint_16p

LIBPNG

png_uint_16pp

LIBPNG

PNG_UINT_31_MAX

LIBPNG

png_uint_32

LIBPNG

png_uint_32p

LIBPNG

PNG_UINT_32_MAX

LIBPNG

png_unknown_chunk

LIBPNG

png_unknown_chunk is a structure to hold queued chunks for which there is no specific support. The idea is that we can use this to queue up private chunks for output even though the library doesn't actually know about their semantics.

png_unknown_chunkp

LIBPNG

png_unknown_chunkpp

LIBPNG

png_unknown_chunk_array

LIBPNG

libpng-using applications should NOT directly modify this byte. png_byte location; mode of operation at read time

png_unknown_chunk_arrayp

LIBPNG

png_user_chunk_ptr

LIBPNG

PNG_USER_HEIGHT_MAX

LIBPNG

PNG_USER_TRANSFORM

LIBPNG

png_user_transform_ptr

LIBPNG

PNG_USER_WIDTH_MAX

LIBPNG

png_voidp

LIBPNG

png_write_status_ptr

LIBPNG

PNG_WROTE_INFO_BEFORE_PLTE

LIBPNG

PNG_WROTE_tIME

LIBPNG

PNODEChunk

TypesB3D

PNodeHdr

Types3DS

PNodeList

Types3DS

PObject

PersistentClasses

PObjMat3DS

Types3DS

PObjMatList

Types3DS

POConsts

Types3DS

POCTFace

FileOCT

POCTLightmap

FileOCT

POctreeNode

Octree

POctreeTriangleInfo

Octree

PointAdd

VectorGeometry

Returns the sum of two homogeneous vectors. W coordinate is always 1.

PointArrayMin3DS

Const3DS

PointDiskOrthoProjection

VectorGeometry

Computes point to disk projection. Direction has to be normalized

PointDiskProjection

VectorGeometry

PointInAABB

GeometryBB

PointInAABB

GeometryBB

PointInPolygon

VectorGeometry

PointIsInHalfSpace

VectorGeometry

Returns true if point is in the half-space defined by a plane with normal.<p> The plane itself is not considered to be in the tested halfspace.

PointIsInHalfSpace

VectorGeometry

PointIsInHalfSpace

VectorGeometry

PointLineClosestPoint

VectorGeometry

Computes closest point on a line.

PointLineDistance

VectorGeometry

Computes algebraic distance between point and line.

PointMake

VectorGeometry

PointMake

VectorGeometry

PointMake

VectorGeometry

PointPlaneDistance

VectorGeometry

PointPlaneDistance

VectorGeometry

Computes algebraic distance between point and plane.<p> Value will be positive if the point is in the halfspace pointed by the normal, negative on the other side.

PointPlaneDistance

VectorGeometry

PointPlaneOrthoProjection

VectorGeometry

Computes point to plane projection. Plane and direction have to be normalized

PointPlaneProjection

VectorGeometry

PointProject

VectorGeometry

Projects p on the line defined by o and direction.<p> Performs VectorDotProduct(VectorSubtract(p, origin), direction), which, if direction is normalized, computes the distance between origin and the projection of p on the (origin, direction) line.

PointProject

VectorGeometry

PointQuadOrthoProjection

VectorGeometry

Computes point to Quad projection. Direction has to be normalized. Quad have to be flat and convex

PointQuadProjection

VectorGeometry

PointSegmentClosestPoint

VectorGeometry

PointSegmentClosestPoint

VectorGeometry

Computes closest point on a segment (a segment is a limited line).

PointSegmentDistance

VectorGeometry

Computes algebraic distance between segment and line (a segment is a limited line).

PointTriangleOrthoProjection

VectorGeometry

Computes point to triangle projection. Direction has to be normalized

PointTriangleProjection

VectorGeometry

POINT_ARRAY

Const3DS

POINT_ARRAY_ENTRY

Const3DS

POINT_FLAG_ARRAY

Const3DS

POINT_FLAG_ARRAY_ENTRY

Const3DS

POLS_FLAGS_MASK

LWObjects

POLS_TYPE_BONE

LWObjects

POLS_TYPE_CURV

LWObjects

POLS_TYPE_FACE

LWObjects

POLS_TYPE_MBAL

LWObjects

POLS_TYPE_PTCH

LWObjects

POLS_VCOUNT_MASK

LWObjects

PolygonArea

VectorGeometry

Computes the polygons's area.<p> Points must be coplanar. Polygon needs not be convex.

PolygonSignedArea

VectorGeometry

Computes a 2D polygon's signed area.<p> Only X and Y coordinates are used, Z is ignored. Polygon needs not be convex.

POLY_2D

Const3DS

POrthoView3DS

Types3DS

PositionSceneObject

ODEGL

PositionSceneObjectForGeom

ODEGL

POS_TRACK_TAG

Const3DS

POS_TRACK_TAG_KEY

Const3DS

Power

VectorGeometry

Raise base to an integer.

Power

VectorGeometry

Power

VectorGeometry

Raise base to any power.<p> For fractional exponents, or |exponents| > MaxInt, base must be > 0.

PPALvoid

openal

PParticleReference

GLParticleFX

PParticleReferenceArray

GLParticleFX

PPCUgraphicsResource

GLS_CUDA_API

PPdObject

ODEImport

PPdxGeom

ODEImport

PPFXRegion

GLParticleFX

PPHeightTileInfo

HeightTileFile

PPivot

Types3DS

PPlugInEntry

PlugInManager

ppng_byte

LIBPNG

ppng_bytep

LIBPNG

ppng_charp

LIBPNG

ppng_charpp

LIBPNG

ppng_colorp

LIBPNG

ppng_color_16p

LIBPNG

ppng_color_8p

LIBPNG

ppng_fixed_point

LIBPNG

ppng_int_16

LIBPNG

ppng_int_32

LIBPNG

ppng_textp

LIBPNG

ppng_timep

LIBPNG

ppng_uint_16

LIBPNG

ppng_uint_16p

LIBPNG

ppng_uint_32

LIBPNG

PPoint

GLCrossPlatform

PPoint

GLSDL

PPoint3DS

Types3DS

PPointArray

Types3DS

PPointerArray

VectorGeometry

PPointerObjectList

PersistentClasses

PPointerVector

VectorGeometry

PPointFlagArray

Types3DS

PPointList

Types3DS

PPosTrackTag

Types3DS

pppng_byte

LIBPNG

pppng_fixed_point

LIBPNG

pppng_int_16

LIBPNG

pppng_int_32

LIBPNG

pppng_uint_16

LIBPNG

pppng_uint_32

LIBPNG

PProcName

Types3DS

PPSDL_Rect

GLSDL

PQuaternion

VectorGeometry

PQuaternionArray

VectorGeometry

PRayBias

Types3DS

PrecisionTimerLap

GLCrossPlatform

Computes time elapsed since timer start.<p> Return time lap in seconds.

PRect

GLSDL

PRect

GLCrossPlatform

PRenderContextInfo

GLRenderContextInfo

PrepareSinCosCache

VectorGeometry

Fills up the two given dynamic arrays with sin cos values.<p> start and stop angles must be given in degrees, the number of steps is determined by the length of the given arrays.

PRESCALE

Const3DS

PResManagerEntry

PlugInManager

PRE_POST_CONSTANT

LWObjects

PRE_POST_LINEAR

LWObjects

PRE_POST_OFFSET

LWObjects

PRE_POST_OSCILLATE

LWObjects

PRE_POST_REPEAT

LWObjects

PRE_POST_RESET

LWObjects

PRGBA32F

ImageUtils

PRGBColor

GLColor

PRIMARY_NODE

Const3DS

PROAMTriangleNode

GLROAMPatch

ProcNameStrMax3DS

Const3DS

PROC_DATA

Const3DS

PROC_NAME

Const3DS

ProgramBuilt_notify_fn

GLS_CL

Project

VectorGeometry

ProlateSpheroidal_Cartesian

GeometryCoordinates

Convert Prolate-Spheroidal to Cantesian. [double] eta,phi in rad

ProlateSpheroidal_Cartesian

GeometryCoordinates

Convert Prolate-Spheroidal to Cartesian. [single] eta, phi in rad

ProlateSpheroidal_Cartesian

GeometryCoordinates

Convert Prolate-Spheroidal to Cartesian [single](with error check). eta,phi in rad

ProlateSpheroidal_Cartesian

GeometryCoordinates

Convert Prolate-Spheroidal to Cartesian [single](with error check). eta,phi in rad

PRollTrackTag

Types3DS

PRotTrackTag

Types3DS

PScaleTrackTag

Types3DS

PSceneObjectEntry

GLObjectManager

PSDL_AudioCVT

GLSDL

PSDL_AudioCVTFilter

GLSDL

PSDL_AudioCVTFilterArray

GLSDL

PSDL_AudioSpec

GLSDL

PSDL_BlitInfo

GLSDL

PSDL_CD

GLSDL

PSDL_CDTrack

GLSDL

PSDL_Color

GLSDL

PSDL_ColorArray

GLSDL

PSDL_Cond

GLSDL

PSDL_Cursor

GLSDL

PSDL_error

GLSDL

PSDL_Event

GLSDL

PSDL_ExposeEvent

GLSDL

PSDL_Joystick

GLSDL

PSDL_KeySym

GLSDL

PSDL_Mutex

GLSDL

PSDL_Overlay

GLSDL

PSDL_Palette

GLSDL

PSDL_PixelFormat

GLSDL

PSDL_QuitEvent

GLSDL

PSDL_Rect

GLSDL

PSDL_RWops

GLSDL

PSDL_Sem

GLSDL

PSDL_semaphore

GLSDL

PSDL_Surface

GLSDL

PSDL_SysWMEvent

GLSDL

PSDL_SysWMmsg

GLSDL

PSDL_Thread

GLSDL

PSDL_TimerID

GLSDL

PSDL_UserEvent

GLSDL

PSDL_version

GLSDL

PSDL_VideoInfo

GLSDL

PShadowFilter

Types3DS

PShadowMapSize

Types3DS

PShadowRange

Types3DS

PShadowSamples

Types3DS

PShadowSets3DS

Types3DS

PShort

NewtonImport

PShortInt

HeightTileFile

PShortIntArray

HeightTileFile

PSingleArray

VectorGeometry

PSingleArrayList

VectorLists

PSingleList

Types3DS

PSingleRaster

GLHeightData

psInsideFrame

GLCrossPlatform

PSInt64

GLSDL

Psize_t

GLS_CL_Platform

Psize_t

NewtonImport

PSmallInt

HeightTileFile

PSmallIntArray

GLHeightData

PSmallIntArray

HeightTileFile

PSmallIntRaster

GLHeightData

PSmoothGroup

Types3DS

PSoundFileFormat

GLSoundFileObjects

PSpotCone3DS

Types3DS

PSpotLight3DS

Types3DS

PSpotProjector3DS

Types3DS

PSpotShadow3DS

Types3DS

PSqrt255Array

GLUtils

PS_FontInfo

LIBFREETYPE

PS_FontInfoRec_

LIBFREETYPE

PS_Private

LIBFREETYPE

PS_PrivateRec_

LIBFREETYPE

PTAG_TYPE_PART

LWObjects

PTAG_TYPE_SMGP

LWObjects

PTAG_TYPE_SURF

LWObjects

PTdJointFeedback

ODEImport

PTexPoint

VectorGeometry

PTexPointArray

VectorGeometry

PTEXSChunk

TypesB3D

PTextureReference

GLS_CUDA_Runtime

PTexVert3DS

Types3DS

PTexVertList

Types3DS

PTexVerts

Types3DS

PThorpoint

GLThorFX

PThorpointArray

GLThorFX

PtInRect

GLCrossPlatform

PTrackHeader3DS

Types3DS

PTransAxis

GLSDL

PTransformationRec

GLPipelineTransformation

PTRISChunk

TypesB3D

PU1

LWObjects

PU2

LWObjects

PU2Array

LWObjects

PU4

LWObjects

PU4Array

LWObjects

PUInt16

GLSDL

PUInt32

GLSDL

PUInt64

GLSDL

PUInt8

GLSDL

PUInt8Array

GLSDL

PUnknown

GLSVfw

PUnsigned_char

NewtonImport

PUnsigned_int

NewtonImport

PUnsigned_long

NewtonImport

PUnsigned_short

NewtonImport

PUserView3DS

Types3DS

PVdpBitmapSurface

GLS_VDPAU_API

PVdpBitstreamBuffer

GLS_VDPAU_API

PVdpBool

GLS_VDPAU_API

PVdpChromaType

GLS_VDPAU_API

PVdpColor

GLS_VDPAU_API

PVdpColorStandard

GLS_VDPAU_API

PVdpColorTableFormat

GLS_VDPAU_API

PVdpCSCMatrix

GLS_VDPAU_API

PVdpDecoder

GLS_VDPAU_API

PVdpDecoderProfile

GLS_VDPAU_API

PVdpDevice

GLS_VDPAU_X11

PVdpDevice

GLS_VDPAU_API

PVdpFuncId

GLS_VDPAU_API

PVdpGetErrorString

GLS_VDPAU_API

PVdpGetProcAddress

GLS_VDPAU_X11

PVdpIndexedFormat

GLS_VDPAU_API

PVdpLayer

GLS_VDPAU_API

PVdpOutputSurface

GLS_VDPAU_API

PVdpOutputSurfaceRenderBlendEquation

GLS_VDPAU_API

PVdpOutputSurfaceRenderBlendFactor

GLS_VDPAU_API

PVdpOutputSurfaceRenderBlendState

GLS_VDPAU_API

PVdpPictureInfo

GLS_VDPAU_API

PVdpPictureInfoDivX4

GLS_VDPAU_API

PVdpPictureInfoDivX5

GLS_VDPAU_API

PVdpPictureInfoH264

GLS_VDPAU_API

PVdpPictureInfoMPEG1Or2

GLS_VDPAU_API

PVdpPictureInfoMPEG4Part2

GLS_VDPAU_API

PVdpPictureInfoVC1

GLS_VDPAU_API

PVdpPoint

GLS_VDPAU_API

PVdpPresentationQueue

GLS_VDPAU_API

PVdpPresentationQueueStatus

GLS_VDPAU_API

PVdpPresentationQueueTarget

GLS_VDPAU_X11

PVdpPresentationQueueTarget

GLS_VDPAU_API

PVdpProcamp

GLS_VDPAU_API

PVdpRect

GLS_VDPAU_API

PVdpReferenceFrameH264

GLS_VDPAU_API

PVdpRGBAFormat

GLS_VDPAU_API

PVdpStatus

GLS_VDPAU_API

PVdpTime

GLS_VDPAU_API

PVdpVideoMixer

GLS_VDPAU_API

PVdpVideoMixerAttribute

GLS_VDPAU_API

PVdpVideoMixerFeature

GLS_VDPAU_API

PVdpVideoMixerParameter

GLS_VDPAU_API

PVdpVideoMixerPictureStructure

GLS_VDPAU_API

PVdpVideoSurface

GLS_VDPAU_API

PVdpYCbCrFormat

GLS_VDPAU_API

PVec12

LWObjects

PVec12Array

LWObjects

PVector

VectorGeometry

PVector2f

VectorGeometry

PVectorArray

VectorGeometry

PVertex

VectorGeometry

PVertexBoneWeightArray

GLVectorFileObjects

PVertexData

GLMesh

PVertexData

TypesB3D

PVertexDataArray

GLMesh

PVertexRec

GLObjects

PVerticesBoneWeights

GLVectorFileObjects

PVGradient

Types3DS

PVGradientBgnd3DS

Types3DS

PVIDEOHDR

GLSVfw

PVideoMode

GLScreen

PViewCamera

Types3DS

PViewport3DS

Types3DS

PViewportData

Types3DS

PViewportData3

Types3DS

PViewportLayout

Types3DS

PViewportSize

Types3DS

PViewSize3DS

Types3DS

PViewStandard

Types3DS

PViewUser

Types3DS

Pvoid

NewtonImport

PVOID

GLSVfw

PVRTSChunk

TypesB3D

PWGLswap

OpenGLTokens

PWord

GLSDL

PWordArray

GLSDL

PWordList

Types3DS

PWordVector

VectorGeometry

PXDataAppName

Types3DS

PXDataDouble

Types3DS

PXDataEntry

Types3DS

PXDataFloat

Types3DS

PXDataLong

Types3DS

PXDataRaw3DS

Types3DS

PXDataShort

Types3DS

PXDataString

Types3DS

PXDataVoid

Types3DS

PZArray

GLzBuffer

P_ALPHANEG

Const3DS

P_ALPH_ALPHA

Const3DS

P_ALPH_BLUR

Const3DS

P_ALPH_C0

Const3DS

P_ALPH_CUTOFF

Const3DS

P_ALPH_IMAGE

Const3DS

P_ALPH_KCOL

Const3DS

P_ALPH_NONE

Const3DS

P_ALPH_OP_KEY

Const3DS

P_ALPH_OP_NOCONV

Const3DS

P_ALPH_OP_PSEUDO

Const3DS

P_ALPH_PCOL

Const3DS

P_ALPH_PSEUDO

Const3DS

P_ALPH_QUEIMG

Const3DS

P_ALPH_QUES

Const3DS

P_CUSTOM_SIZE

Const3DS

P_PROC_DATA

Const3DS

P_QUEUE_ALIGN

Const3DS

P_QUEUE_ENTRY

Const3DS

P_QUEUE_GRADIENT

Const3DS

P_QUEUE_IMAGE

Const3DS

P_QUEUE_KF

Const3DS

P_QUEUE_MB_REPEAT

Const3DS

P_QUEUE_MOTBLUR

Const3DS

P_QUEUE_NONE

Const3DS

P_QUEUE_OFFSET

Const3DS

P_QUEUE_PROC

Const3DS

P_QUEUE_RESIZE

Const3DS

P_QUEUE_SOLID

Const3DS

P_QUEUE_USEIGAMMA

Const3DS

P_RANGES

Const3DS

P_TRANNEG

Const3DS

P_TRAN_FADEIN

Const3DS

P_TRAN_FADEOUT

Const3DS

P_TRAN_FRAMES

Const3DS

P_TRAN_IMAGE

Const3DS

P_TRAN_NONE

Const3DS

P__int16

NewtonImport

P__int32

NewtonImport

P__int64

NewtonImport

P__int8

NewtonImport

QuaternionConjugate

VectorGeometry

Returns the conjugate of a quaternion

QuaternionFromAngleAxis

VectorGeometry

Constructs quaternion from angle (in deg) and axis

QuaternionFromEuler

VectorGeometry

Constructs quaternion from Euler angles in arbitrary order (angles in degrees)

QuaternionFromMatrix

VectorGeometry

Constructs a unit quaternion from a rotation matrix

QuaternionFromPoints

VectorGeometry

Constructs a unit quaternion from two points on unit sphere

QuaternionFromRollPitchYaw

VectorGeometry

Constructs quaternion from Euler angles

QuaternionMagnitude

VectorGeometry

Returns the magnitude of the quaternion

QuaternionMake

VectorGeometry

Creates a quaternion from the given values

QuaternionMultiply

VectorGeometry

Returns quaternion product qL * qR.<p> Note: order is important!<p> To combine rotations, use the product QuaternionMuliply(qSecond, qFirst), which gives the effect of rotating by qFirst then qSecond.

QuaternionSlerp

VectorGeometry

Spherical linear interpolation of unit quaternions with spins.<p> QStart, QEnd - start and end unit quaternions<br> t - interpolation parameter (0 to 1)<br> Spin - number of extra spin rotations to involve<br>

QuaternionSlerp

VectorGeometry

QuaternionToAffineMatrix

VectorGeometry

Constructs an affine rotation matrix from (possibly non-unit) quaternion.<p>

QuaternionToMatrix

VectorGeometry

Constructs a rotation matrix from (possibly non-unit) quaternion.<p> Assumes matrix is used to multiply column vector on the left:<br> vnew = mat vold.<p> Works correctly for right-handed coordinate system and right-handed rotations.

QuaternionToPoints

VectorGeometry

Converts a unit quaternion into two points on a unit sphere

QueryPerformanceCounter

GLCrossPlatform

Returns the current value of the highest-resolution counter.<p> If the platform has none, should return a value derived from the highest precision time reference available, avoiding, if possible, timers that allocate specific system resources.

QueryPerformanceFrequency

GLCrossPlatform

Returns the frequency of the counter used by QueryPerformanceCounter.<p> Return value is in ticks per second (Hz), returns False if no precision counter is available.

QuestionDlg

GLUtils

Pops up a simple question dialog with msg and yes/no buttons.<p> Returns True if answer was "yes".

QuickSortLists

VectorLists

Sort the refList in ascending order, ordering objList (TBaseList) on the way.

QuickSortLists

VectorLists

Sort the refList in ascending order, ordering objList (TList) on the way.

QWORD

Bass

QW_ERROR

Bass

RadToDeg

VectorGeometry

RadToDeg

VectorGeometry

RaiseFilerException

PersistentClasses

RaiseLastOSError

GLCrossPlatform

RaiseOpenGLError

OpenGL1x

Raises an EOpenGLError with 'msg' error string.

RandomColorVector

ODEGL

RandomPointOnSphere

VectorGeometry

Generates a random point on the unit sphere.<p> Point repartition is correctly isotropic with no privilegied direction.

RasterFileFormatExtensionByIndex

GLGraphics

Returns an extension by its index in the internal image files dialogs filter.<p> Use InternalImageFileFormatsFilter to obtain the filter.

RawByteString

GLSZLibEx

RayCastAABBIntersect

GeometryBB

RayCastAABBIntersect

GeometryBB

RayCastBoxIntersect

VectorGeometry

Compute intersection between a ray and a box.<p> Returns True if an intersection was found, the intersection point is placed in intersectPoint if the reference is not nil.

RayCastIntersectsSphere

VectorGeometry

Determines if a ray will intersect with a given sphere.<p>

RayCastMinDistToPoint

VectorGeometry

Compute the min distance a ray will pass to a point.<p>

RayCastPlaneIntersect

VectorGeometry

Compute intersection between a ray and a plane.<p> Returns True if an intersection was found, the intersection point is placed in intersectPoint is the reference is not nil.

RayCastPlaneXZIntersect

VectorGeometry

RayCastSphereIntersect

VectorGeometry

Calculates the intersections between a sphere and a ray.<p> Returns 0 if no intersection is found (i1 and i2 untouched), 1 if one intersection was found (i1 defined, i2 untouched), and 2 is two intersections were found (i1 and i2 defined).

RayCastTriangleIntersect

VectorGeometry

Compute intersection between a ray and a triangle.

RAY_BIAS

Const3DS

rBaseFormLocalizedDescription

GLSceneFormDesign

rBaseFormLocalizedName

GLSceneFormDesign

rBaseProjectLocalizedDescription

GLSceneFormDesign

rBaseProjectLocalizedName

GLSceneFormDesign

RDTSC

GLCrossPlatform

Returns the number of CPU cycles since startup.<p> Use the similarly named CPU instruction.

ReadCRLFString

GLUtils

Read a CRLF terminated string from a stream.<p> The CRLF is NOT in the returned string.

ReadEntryPoints

GLSZLibExApi

ReadExtensions

OpenGL1x

ReadImplementationProperties

OpenGL1x

ReadLine

GLSLog

ReadModuleData

GLSModuleLoader

ReadMotorolaNumber

LWObjects

ReadOpenALExtensions

openal

ReadS0

LWObjects

ReadScreenImage

GLScreen

ReadVideoModes

GLScreen

ReadVXAsU4

LWObjects

ReadWGLExtensions

OpenGL1x

ReadWGLImplementationProperties

OpenGL1x

ReadXMLFile

GLSCrossXML

ReadXMLFile

GLSCrossXML

RECORDPROC

Bass

RectangleContains

VectorGeometry

Determine if BigRect completely contains SmallRect.

RectanglesIntersect

VectorGeometry

Determine if 2 rectanges intersect.

RectEquals

VectorGeometry

True if all components are equal.

Register

GLSceneRegisterLCL

Register

uPSI_VectorLists

register

GLNewtonRegister

Register

GLFullScreenViewer

Register

GLSMBASS

Register

GLCgRegister

Register

GLSceneRegister

Register

uPSI_XCollection

Register

GLScriptPython

Register

GLSComputingRegister

Register

GLSceneRegisterWinOnlyLCL

Register

GLScriptDWS2

Register

uPSI_VectorGeometry

Register

uPSI_ApplicationFileIO

Register

uPSI_VectorTypes

Register

GLSceneFormDesign

Register

GLSMOpenAL

Register

uPSI_PersistentClasses

Register

dws2GLScene

Register

dws2VectorGeometry

Register

dws2Classes

Register

GLSDLWindow

Register

GLSDLContext

Register

uPSI_GLStrings

Register

RegisterXCollection

Register

uPSI_GLUtils

Register

GLODERegister

Register

dws2OpenGLAdapter

Register

GLDWS2Objects

Register

GLSMFMOD

RegisterArchiveFormat

GLSArchiveManager

RegisterChunkClass

LWObjects

RegisterColor

GLColor

RegisterCUDAComponentNameChangeEvent

GLSCUDA

RegisterGLBaseSceneObjectNameChangeEvent

GLScene

Register an event handler triggered by any TGLBaseSceneObject Name change.<p> *INCOMPLETE*, currently allows for only 1 (one) event, and is used by GLSceneEdit in the IDE.

RegisterGLBehaviourNameChangeEvent

GLScene

Register an event handler triggered by any TGLBehaviour Name change.<p> *INCOMPLETE*, currently allows for only 1 (one) event, and is used by FBehavioursEditor in the IDE.

RegisterGLContextClass

GLContext

Drivers should register themselves via this function.

RegisterGLMaterialExNameChangeEvent

GLMaterialEx

RegisterGLSceneObject

GLODEManager

RegisterGLTextureImageClass

GLTexture

Register a TGLTextureImageClass (used for persistence and IDE purposes)

RegisterGLTextureImageEditor

GLTextureImageEditors

RegisterInfoForm

GLScene

Registers the procedure call used to invoke the info form.

RegisterManager

GLManager

RegisterRasterFormat

GLGraphics

RegisterSoundFileFormat

GLSoundFileObjects

RegisterTGraphicClassFileExtension

GLTexture

RegisterUniformAutoSetMethod

GLSLParameter

RegisterVectorFileFormat

GLVectorFileObjects

RegisterXCollectionDestroyEvent

XCollection

Registers an event to be called when an XCollection is destroyed.

RegisterXCollectionItemClass

XCollection

Registers a TXCollectionItem subclass for persistence requirements.

RelAll3DS

Const3DS

RelativePath

GLCrossPlatform

Remove if possible part of path witch leads to project executable.

ReleaseAmbientLightMotion

Utils3DS

ReleaseCamera

Utils3DS

ReleaseCameraMotion

Utils3DS

ReleaseChunk

Utils3DS

ReleaseChunkList

Utils3DS

ReleaseFontManager

GLSpaceText

ReleaseGLSceneEditorForm

GLSceneEdit

ReleaseGLSceneEditorForm

GLSceneEditLCL

ReleaseGLSCUDAEditorForm

GLSCUDAEditor

ReleaseGLShaderEditor

FShaderMemo

ReleaseGUILayoutEditor

FGUILayoutEditor

ReleaseLibMaterialPicker

FLibMaterialPickerLCL

ReleaseLibMaterialPicker

FLibMaterialPicker

ReleaseLight

Utils3DS

ReleaseMaterial

Utils3DS

ReleaseMaterialEditorForm

FMaterialEditorFormLCL

ReleaseMaterialEditorForm

FMaterialEditorForm

ReleaseMeshObj

Utils3DS

ReleaseObjectMotion

Utils3DS

ReleaseOmnilightMotion

Utils3DS

ReleaseShaderUniformEditor

FRUniformEditor

ReleaseSpotlightMotion

Utils3DS

ReleaseVectorEditorForm

FVectorEditorLCL

ReleaseVectorEditorForm

FVectorEditor

ReleaseXCollectionEditor

FXCollectionEditor

ReleaseXCollectionEditor

FXCollectionEditorLCL

ReleaseXMLDocument

GLSCrossXML

RelFaceArray3ds

Const3DS

RelMatArray3ds

Const3DS

RelProcData3ds

Const3DS

RelSmoothArray3ds

Const3DS

RelTextArray3ds

Const3DS

RelVertexArray3ds

Const3DS

RelVFlagArray3ds

Const3DS

RemapAndCleanupReferences

MeshUtils

Alters a reference/indice pair and removes unused reference values.<p> This functions scans the reference list and removes all values that aren't referred in the indices list, and the indices list is remapped so as to remain coherent.

RemapIndices

MeshUtils

Remaps a list of indices.<p> The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]

RemapIndicesToIndicesMap

MeshUtils

Creates an indices map from a remap list.<p> The remap list is what BuildVectorCountOptimizedIndices, a list of indices to distinct/unique items, the indices map contains the indices of these items after a remap and cleanup of the set referred by remapIndices... Clear?<br> In short it takes the output of BuildVectorCountOptimizedIndices and can change it to something suitable for RemapTrianglesIndices.<br> Any simpler documentation of this function welcome ;)

RemapReferences

MeshUtils

RemapReferences

MeshUtils

Alters a reference array and removes unused reference values.<p> This functions scans the reference list and removes all values that aren't referred in the indices list, the indices list is *not* remapped.

RemapTrianglesIndices

MeshUtils

Remaps a list of triangles vertex indices and remove degenerate triangles.<p> The indicesMap provides newVertexIndex:=indicesMap[oldVertexIndex]

RenderAABB

GLSpatialPartitioning

RenderAABB

GLSpatialPartitioning

Renders an AABB as a line

RenderGeomList

ODEGL

RenderSpatialPartitioning

GLSpatialPartitioning

Render a spacial partitioning descending from TSectoredSpacePartition (octree and quadtree) as a grid - great for debugging and visualisation

RescaleImage

ImageUtils

RestoreDefaultMode

GLScreen

ReverseByteOrder

LWObjects

rExtendedFormLocalizedDescription

GLSceneFormDesign

rExtendedFormLocalizedName

GLSceneFormDesign

rExtendedProjectLocalizedDescription

GLSceneFormDesign

rExtendedProjectLocalizedName

GLSceneFormDesign

RFOP_BACKDROP

LWObjects

RFOP_RAYTRACEANDBACKDROP

LWObjects

RFOP_RAYTRACEANDSPHERICALMAP

LWObjects

RFOP_SPHERICALMAP

LWObjects

RGB

GLCrossPlatform

Builds a TColor from Red Green Blue components.

RGB24ToRGBA32

GLGraphics

Rgbe2float

RGBE

RIRegister_ApplicationFileIO

uPSI_ApplicationFileIO

RIRegister_ApplicationFileIO_Routines

uPSI_ApplicationFileIO

RIRegister_EFilerException

uPSI_XCollection

RIRegister_EFilerException

uPSI_PersistentClasses

RIRegister_EInvalidFileSignature

uPSI_PersistentClasses

RIRegister_GLUtils

uPSI_GLUtils

RIRegister_GLUtils_Routines

uPSI_GLUtils

RIRegister_PersistentClasses

uPSI_PersistentClasses

RIRegister_PersistentClasses_Routines

uPSI_PersistentClasses

RIRegister_TApplicationFileIO

uPSI_ApplicationFileIO

RIRegister_TBaseList

uPSI_VectorLists

RIRegister_TBinaryReader

uPSI_PersistentClasses

RIRegister_TBinaryWriter

uPSI_PersistentClasses

RIRegister_TByteList

uPSI_VectorLists

RIRegister_TDataFile

uPSI_ApplicationFileIO

RIRegister_TDoubleList

uPSI_VectorLists

RIRegister_TGLInterfacedCollectionItem

uPSI_PersistentClasses

RIRegister_TGLInterfacedPersistent

uPSI_PersistentClasses

RIRegister_TGLOwnedPersistent

uPSI_PersistentClasses

RIRegister_TIntegerList

uPSI_VectorLists

RIRegister_TPersistentObject

uPSI_PersistentClasses

RIRegister_TPersistentObjectList

uPSI_PersistentClasses

RIRegister_TSingleList

uPSI_VectorLists

RIRegister_TTextReader

uPSI_PersistentClasses

RIRegister_TTextWriter

uPSI_PersistentClasses

RIRegister_TVirtualReader

uPSI_PersistentClasses

RIRegister_TVirtualWriter

uPSI_PersistentClasses

RIRegister_TXCollection

uPSI_XCollection

RIRegister_TXCollectionItem

uPSI_XCollection

RIRegister_VectorGeometry_Routines

uPSI_VectorGeometry

RIRegister_VectorLists

uPSI_VectorLists

RIRegister_VectorLists_Routines

uPSI_VectorLists

RIRegister_XCollection

uPSI_XCollection

RIRegister_XCollection_Routines

uPSI_XCollection

RLength

VectorGeometry

Computes 1/Sqrt(Sqr(x)+Sqr(y)).

Roll

VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterDirection

Roll

VectorGeometry

Rotates the given coordinate system (represented by the matrix) around its Z-axis

ROLL_TRACK_TAG

Const3DS

ROLL_TRACK_TAG_KEY

Const3DS

RotateVector

VectorGeometry

Rotates Vector about Axis with Angle radians

RotateVector

VectorGeometry

Rotates Vector about Axis with Angle radians

RotateVectorAroundY

VectorGeometry

Rotate given vector around the Y axis (alpha is in rad)

ROT_TRACK_TAG

Const3DS

ROT_TRACK_TAG_KEY

Const3DS

Round

VectorGeometry

RoundDownToPowerOf2

GLUtils

Round down to the nearest power of two, value must be strictly positive

RoundInt

VectorGeometry

Rounds the floating point value to the closest integer.<p> Behaves like Round but returns a floating point value like Int.

RoundInt

VectorGeometry

RoundUpToPowerOf2

GLUtils

Round ups to the nearest power of two, value must be positive

rSimpleFormLocalizedDescription

GLSceneFormDesign

rSimpleFormLocalizedName

GLSceneFormDesign

rSimpleProjectLocalizedDescription

GLSceneFormDesign

rSimpleProjectLocalizedName

GLSceneFormDesign

RSqrt

VectorGeometry

Computes 1/Sqrt(v).<p>

rstrNothing

GLSLParameter

RstVector

VectorGeometry

RstVector

VectorGeometry

SafeCurrentGLContext

GLContext

SaveAnsiStringToFile

GLUtils

Saves "data" to "filename".

SaveComponentToFile

GLUtils

Saves component to a file.

SavePictureDialog

GLUtils

Pops up a simple save picture dialog.

ScaleAndRound

VectorGeometry

Multiples i by s and returns the rounded result.<p>

ScaleFloatArray

VectorGeometry

ScaleFloatArray

VectorGeometry

Multiplies values in the array by factor.<p> This function is especially efficient for large arrays, it is not recommended for arrays that have less than 10 items.<br> Expected performance is 4 to 5 times that of a Deliph-compiled loop on AMD CPUs, and 2 to 3 when 3DNow! isn't available.

ScaleMatrix

VectorGeometry

Multiplies all elements of a 3x3 matrix with a factor

ScaleMatrix

VectorGeometry

Multiplies all elements of a 4x4 matrix with a factor

ScaleVector

VectorGeometry

Scales given vector by a factor

ScaleVector

VectorGeometry

Scales given vector by another vector.<p> v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.

ScaleVector

VectorGeometry

Scales given vector by another vector.<p> v[x]:=v[x]*factor[x], v[y]:=v[y]*factor[y] etc.

ScaleVector

VectorGeometry

Scales given vector by a factor

ScaleVector

VectorGeometry

Scales given vector by a factor

SCENE_SELECTED

GLSceneEditLCL

SCENE_SELECTED

GLSceneEdit

SCL_TRACK_TAG

Const3DS

SCL_TRACK_TAG_KEY

Const3DS

SDLK_0

GLSDL

SDLK_1

GLSDL

SDLK_2

GLSDL

SDLK_3

GLSDL

SDLK_4

GLSDL

SDLK_5

GLSDL

SDLK_6

GLSDL

SDLK_7

GLSDL

SDLK_8

GLSDL

SDLK_9

GLSDL

SDLK_a

GLSDL

SDLK_AMPERSAND

GLSDL

SDLK_ASTERISK

GLSDL

SDLK_AT

GLSDL

SDLK_b

GLSDL

SDLK_BACKQUOTE

GLSDL

SDLK_BACKSLASH

GLSDL

SDLK_BACKSPACE

GLSDL

SDLK_BREAK

GLSDL

SDLK_c

GLSDL

SDLK_CAPSLOCK

GLSDL

SDLK_CARET

GLSDL

SDLK_CLEAR

GLSDL

SDLK_COLON

GLSDL

SDLK_COMMA

GLSDL

SDLK_COMPOSE

GLSDL

SDLK_d

GLSDL

SDLK_DELETE

GLSDL

SDLK_DOLLAR

GLSDL

SDLK_DOWN

GLSDL

SDLK_e

GLSDL

SDLK_END

GLSDL

SDLK_EQUALS

GLSDL

SDLK_ESCAPE

GLSDL

SDLK_EURO

GLSDL

SDLK_EXCLAIM

GLSDL

SDLK_f

GLSDL

SDLK_F1

GLSDL

SDLK_F10

GLSDL

SDLK_F11

GLSDL

SDLK_F12

GLSDL

SDLK_F13

GLSDL

SDLK_F14

GLSDL

SDLK_F15

GLSDL

SDLK_F2

GLSDL

SDLK_F3

GLSDL

SDLK_F4

GLSDL

SDLK_F5

GLSDL

SDLK_F6

GLSDL

SDLK_F7

GLSDL

SDLK_F8

GLSDL

SDLK_F9

GLSDL

SDLK_FIRST

GLSDL

SDLK_g

GLSDL

SDLK_GREATER

GLSDL

SDLK_h

GLSDL

SDLK_HASH

GLSDL

SDLK_HELP

GLSDL

SDLK_HOME

GLSDL

SDLK_i

GLSDL

SDLK_INSERT

GLSDL

SDLK_j

GLSDL

SDLK_k

GLSDL

SDLK_KP0

GLSDL

SDLK_KP1

GLSDL

SDLK_KP2

GLSDL

SDLK_KP3

GLSDL

SDLK_KP4

GLSDL

SDLK_KP5

GLSDL

SDLK_KP6

GLSDL

SDLK_KP7

GLSDL

SDLK_KP8

GLSDL

SDLK_KP9

GLSDL

SDLK_KP_DIVIDE

GLSDL

SDLK_KP_ENTER

GLSDL

SDLK_KP_EQUALS

GLSDL

SDLK_KP_MINUS

GLSDL

SDLK_KP_MULTIPLY

GLSDL

SDLK_KP_PERIOD

GLSDL

SDLK_KP_PLUS

GLSDL

SDLK_l

GLSDL

SDLK_LALT

GLSDL

SDLK_LCTRL

GLSDL

SDLK_LEFT

GLSDL

SDLK_LEFTBRACKET

GLSDL

SDLK_LEFTPAREN

GLSDL

SDLK_LESS

GLSDL

SDLK_LMETA

GLSDL

SDLK_LSHIFT

GLSDL

SDLK_LSUPER

GLSDL

SDLK_m

GLSDL

SDLK_MENU

GLSDL

SDLK_MINUS

GLSDL

SDLK_MODE

GLSDL

SDLK_n

GLSDL

SDLK_NUMLOCK

GLSDL

SDLK_o

GLSDL

SDLK_p

GLSDL

SDLK_PAGEDOWN

GLSDL

SDLK_PAGEUP

GLSDL

SDLK_PAUSE

GLSDL

SDLK_PERIOD

GLSDL

SDLK_PLUS

GLSDL

SDLK_POWER

GLSDL

SDLK_PRINT

GLSDL

SDLK_q

GLSDL

SDLK_QUESTION

GLSDL

SDLK_QUOTE

GLSDL

SDLK_QUOTEDBL

GLSDL

SDLK_r

GLSDL

SDLK_RALT

GLSDL

SDLK_RCTRL

GLSDL

SDLK_RETURN

GLSDL

SDLK_RIGHT

GLSDL

SDLK_RIGHTBRACKET

GLSDL

SDLK_RIGHTPAREN

GLSDL

SDLK_RMETA

GLSDL

SDLK_RSHIFT

GLSDL

SDLK_RSUPER

GLSDL

SDLK_s

GLSDL

SDLK_SCROLLOCK

GLSDL

SDLK_SEMICOLON

GLSDL

SDLK_SLASH

GLSDL

SDLK_SPACE

GLSDL

SDLK_SYSREQ

GLSDL

SDLK_t

GLSDL

SDLK_TAB

GLSDL

SDLK_u

GLSDL

SDLK_UNDERSCORE

GLSDL

SDLK_UNKNOWN

GLSDL

SDLK_UP

GLSDL

SDLK_v

GLSDL

SDLK_w

GLSDL

SDLK_WORLD_0

GLSDL

SDLK_WORLD_1

GLSDL

SDLK_WORLD_10

GLSDL

SDLK_WORLD_11

GLSDL

SDLK_WORLD_12

GLSDL

SDLK_WORLD_13

GLSDL

SDLK_WORLD_14

GLSDL

SDLK_WORLD_15

GLSDL

SDLK_WORLD_16

GLSDL

SDLK_WORLD_17

GLSDL

SDLK_WORLD_18

GLSDL

SDLK_WORLD_19

GLSDL

SDLK_WORLD_2

GLSDL

SDLK_WORLD_20

GLSDL

SDLK_WORLD_21

GLSDL

SDLK_WORLD_22

GLSDL

SDLK_WORLD_23

GLSDL

SDLK_WORLD_24

GLSDL

SDLK_WORLD_25

GLSDL

SDLK_WORLD_26

GLSDL

SDLK_WORLD_27

GLSDL

SDLK_WORLD_28

GLSDL

SDLK_WORLD_29

GLSDL

SDLK_WORLD_3

GLSDL

SDLK_WORLD_30

GLSDL

SDLK_WORLD_31

GLSDL

SDLK_WORLD_32

GLSDL

SDLK_WORLD_33

GLSDL

SDLK_WORLD_34

GLSDL

SDLK_WORLD_35

GLSDL

SDLK_WORLD_36

GLSDL

SDLK_WORLD_37

GLSDL

SDLK_WORLD_38

GLSDL

SDLK_WORLD_39

GLSDL

SDLK_WORLD_4

GLSDL

SDLK_WORLD_40

GLSDL

SDLK_WORLD_41

GLSDL

SDLK_WORLD_42

GLSDL

SDLK_WORLD_43

GLSDL

SDLK_WORLD_44

GLSDL

SDLK_WORLD_45

GLSDL

SDLK_WORLD_46

GLSDL

SDLK_WORLD_47

GLSDL

SDLK_WORLD_48

GLSDL

SDLK_WORLD_49

GLSDL

SDLK_WORLD_5

GLSDL

SDLK_WORLD_50

GLSDL

SDLK_WORLD_51

GLSDL

SDLK_WORLD_52

GLSDL

SDLK_WORLD_53

GLSDL

SDLK_WORLD_54

GLSDL

SDLK_WORLD_55

GLSDL

SDLK_WORLD_56

GLSDL

SDLK_WORLD_57

GLSDL

SDLK_WORLD_58

GLSDL

SDLK_WORLD_59

GLSDL

SDLK_WORLD_6

GLSDL

SDLK_WORLD_60

GLSDL

SDLK_WORLD_61

GLSDL

SDLK_WORLD_62

GLSDL

SDLK_WORLD_63

GLSDL

SDLK_WORLD_64

GLSDL

SDLK_WORLD_65

GLSDL

SDLK_WORLD_66

GLSDL

SDLK_WORLD_67

GLSDL

SDLK_WORLD_68

GLSDL

SDLK_WORLD_69

GLSDL

SDLK_WORLD_7

GLSDL

SDLK_WORLD_70

GLSDL

SDLK_WORLD_71

GLSDL

SDLK_WORLD_72

GLSDL

SDLK_WORLD_73

GLSDL

SDLK_WORLD_74

GLSDL

SDLK_WORLD_75

GLSDL

SDLK_WORLD_76

GLSDL

SDLK_WORLD_77

GLSDL

SDLK_WORLD_78

GLSDL

SDLK_WORLD_79

GLSDL

SDLK_WORLD_8

GLSDL

SDLK_WORLD_80

GLSDL

SDLK_WORLD_81

GLSDL

SDLK_WORLD_82

GLSDL

SDLK_WORLD_83

GLSDL

SDLK_WORLD_84

GLSDL

SDLK_WORLD_85

GLSDL

SDLK_WORLD_86

GLSDL

SDLK_WORLD_87

GLSDL

SDLK_WORLD_88

GLSDL

SDLK_WORLD_89

GLSDL

SDLK_WORLD_9

GLSDL

SDLK_WORLD_90

GLSDL

SDLK_WORLD_91

GLSDL

SDLK_WORLD_92

GLSDL

SDLK_WORLD_93

GLSDL

SDLK_WORLD_94

GLSDL

SDLK_WORLD_95

GLSDL

SDLK_x

GLSDL

SDLK_y

GLSDL

SDLK_z

GLSDL

SDL_ACTIVEEVENT

GLSDL

SDL_ACTIVEEVENTMASK

GLSDL

SDL_AddTimer

GLSDL

SDL_ALLEVENTS

GLSDL

SDL_AllocRW

GLSDL

SDL_AllocSurface

GLSDL

SDL_ALL_HOTKEYS

GLSDL

SDL_ALPHA_OPAQUE

GLSDL

SDL_ALPHA_TRANSPARENT

GLSDL

SDL_ANYFORMAT

GLSDL

SDL_APPACTIVE

GLSDL

SDL_APPINPUTFOCUS

GLSDL

SDL_APPMOUSEFOCUS

GLSDL

SDL_ASYNCBLIT

GLSDL

SDL_AudioDriverName

GLSDL

SDL_AudioInit

GLSDL

SDL_AudioQuit

GLSDL

SDL_AUDIO_TRACK

GLSDL

SDL_BIG_ENDIAN

GLSDL

SDL_BlitSurface

GLSDL

SDL_BuildAudioCVT

GLSDL

SDL_BUTTON

GLSDL

SDL_BUTTON_LEFT

GLSDL

SDL_BUTTON_LMASK

GLSDL

SDL_BUTTON_MIDDLE

GLSDL

SDL_BUTTON_MMASK

GLSDL

SDL_BUTTON_RIGHT

GLSDL

SDL_BUTTON_RMask

GLSDL

SDL_BYTEORDER

GLSDL

SDL_CDClose

GLSDL

SDL_CDEject

GLSDL

SDL_CDInDrive

GLSDL

SDL_CDName

GLSDL

SDL_CDNumDrives

GLSDL

SDL_CDOpen

GLSDL

SDL_CDPause

GLSDL

SDL_CDPlay

GLSDL

SDL_CDPlayTracks

GLSDL

SDL_CDResume

GLSDL

SDL_CDStatus

GLSDL

SDL_CDStop

GLSDL

SDL_ClearError

GLSDL

SDL_CloseAudio

GLSDL

SDL_COMPILEDVERSION

GLSDL

SDL_CondBroadcast

GLSDL

SDL_CondSignal

GLSDL

SDL_CondWait

GLSDL

SDL_CondWaitTimeout

GLSDL

SDL_ConvertAudio

GLSDL

SDL_ConvertSurface

GLSDL

SDL_CreateCond

GLSDL

SDL_CreateCursor

GLSDL

SDL_CreateMutex

GLSDL

SDL_CreateRGBSurface

GLSDL

SDL_CreateRGBSurfaceFrom

GLSDL

SDL_CreateSemaphore

GLSDL

SDL_CreateThread

GLSDL

SDL_CreateYUVOverlay

GLSDL

SDL_DATA_TRACK

GLSDL

SDL_DEFAULT_REPEAT_DELAY

GLSDL

SDL_DEFAULT_REPEAT_INTERVAL

GLSDL

SDL_Delay

GLSDL

SDL_DestroyCond

GLSDL

SDL_DestroyMutex

GLSDL

SDL_DestroySemaphore

GLSDL

SDL_DISABLE

GLSDL

SDL_DisplayFormat

GLSDL

SDL_DisplayFormatAlpha

GLSDL

SDL_DisplayYUVOverlay

GLSDL

SDL_DOUBLEBUF

GLSDL

SDL_ENABLE

GLSDL

SDL_EnableKeyRepeat

GLSDL

SDL_EnableUNICODE

GLSDL

SDL_errorcode

GLSDL

SDL_EventState

GLSDL

SDL_EVENT_RESERVED

GLSDL

SDL_EVENT_RESERVED2

GLSDL

SDL_EVENT_RESERVED3

GLSDL

SDL_EVENT_RESERVED4

GLSDL

SDL_EVENT_RESERVED5

GLSDL

SDL_EVENT_RESERVED6

GLSDL

SDL_EVENT_RESERVED7

GLSDL

SDL_EVENT_RESERVEDA

GLSDL

SDL_FillRect

GLSDL

SDL_Flip

GLSDL

SDL_FreeCursor

GLSDL

SDL_FreeRW

GLSDL

SDL_FreeSurface

GLSDL

SDL_FreeWAV

GLSDL

SDL_FreeYUVOverlay

GLSDL

SDL_FULLSCREEN

GLSDL

SDL_GetAppState

GLSDL

SDL_GetAudioStatus

GLSDL

SDL_GetClipRect

GLSDL

SDL_GetCursor

GLSDL

SDL_getenv

GLSDL

SDL_GetError

GLSDL

SDL_GetEventFilter

GLSDL

SDL_GetGammaRamp

GLSDL

SDL_GetKeyName

GLSDL

SDL_GetKeyState

GLSDL

SDL_GetModState

GLSDL

SDL_GetMouseState

GLSDL

SDL_GetRelativeMouseState

GLSDL

SDL_GetRGB

GLSDL

SDL_GetRGBA

GLSDL

SDL_GetThreadID

GLSDL

SDL_GetTicks

GLSDL

SDL_GetVideoInfo

GLSDL

SDL_GetVideoSurface

GLSDL

SDL_GL_GetAttribute

GLSDL

SDL_GL_GetProcAddress

GLSDL

SDL_GL_LoadLibrary

GLSDL

SDL_GL_Lock

GLSDL

SDL_GL_SetAttribute

GLSDL

SDL_GL_SwapBuffers

GLSDL

SDL_GL_Unlock

GLSDL

SDL_GL_UpdateRects

GLSDL

SDL_HAT_CENTERED

GLSDL

SDL_HAT_DOWN

GLSDL

SDL_HAT_LEFT

GLSDL

SDL_HAT_LEFTDOWN

GLSDL

SDL_HAT_LEFTUP

GLSDL

SDL_HAT_RIGHT

GLSDL

SDL_HAT_RIGHTDOWN

GLSDL

SDL_HAT_RIGHTUP

GLSDL

SDL_HAT_UP

GLSDL

SDL_HWACCEL

GLSDL

SDL_HWPALETTE

GLSDL

SDL_HWSURFACE

GLSDL

SDL_IGNORE

GLSDL

SDL_Init

GLSDL

SDL_InitSubSystem

GLSDL

SDL_INIT_AUDIO

GLSDL

SDL_INIT_CDROM

GLSDL

SDL_INIT_EVENTTHREAD

GLSDL

SDL_INIT_EVERYTHING

GLSDL

SDL_INIT_JOYSTICK

GLSDL

SDL_INIT_NOPARACHUTE

GLSDL

SDL_INIT_TIMER

GLSDL

SDL_INIT_VIDEO

GLSDL

SDL_IYUV_OVERLAY

GLSDL

SDL_JOYAXISMOTION

GLSDL

SDL_JOYAXISMOTIONMASK

GLSDL

SDL_JOYBALLMOTION

GLSDL

SDL_JOYBALLMOTIONMASK

GLSDL

SDL_JOYBUTTONDOWN

GLSDL

SDL_JOYBUTTONDOWNMASK

GLSDL

SDL_JOYBUTTONUP

GLSDL

SDL_JOYBUTTONUPMASK

GLSDL

SDL_JOYEVENTMASK

GLSDL

SDL_JOYHATMOTION

GLSDL

SDL_JOYHATMOTIONMASK

GLSDL

SDL_JoystickClose

GLSDL

SDL_JoystickEventState

GLSDL

SDL_JoystickGetAxis

GLSDL

SDL_JoystickGetBall

GLSDL

SDL_JoystickGetButton

GLSDL

SDL_JoystickGetHat

GLSDL

SDL_JoystickIndex

GLSDL

SDL_JoystickName

GLSDL

SDL_JoystickNumAxes

GLSDL

SDL_JoystickNumBalls

GLSDL

SDL_JoystickNumButtons

GLSDL

SDL_JoystickNumHats

GLSDL

SDL_JoystickOpen

GLSDL

SDL_JoystickOpened

GLSDL

SDL_JoystickUpdate

GLSDL

SDL_KEYDOWN

GLSDL

SDL_KEYDOWNMASK

GLSDL

SDL_KEYUP

GLSDL

SDL_KEYUPMASK

GLSDL

SDL_KillThread

GLSDL

SDL_LIL_ENDIAN

GLSDL

SDL_Linked_Version

GLSDL

SDL_ListModes

GLSDL

SDL_LoadBMP

GLSDL

SDL_LoadBMP_RW

GLSDL

SDL_LoadWAV

GLSDL

SDL_LoadWAV_RW

GLSDL

SDL_LockAudio

GLSDL

SDL_LockMutex

GLSDL

SDL_LockSurface

GLSDL

SDL_LockYUVOverlay

GLSDL

SDL_LOGPAL

GLSDL

SDL_LowerBlit

GLSDL

SDL_MAJOR_VERSION

GLSDL

SDL_MapRGB

GLSDL

SDL_MapRGBA

GLSDL

SDL_MAX_TRACKS

GLSDL

SDL_MINOR_VERSION

GLSDL

SDL_MixAudio

GLSDL

SDL_MIX_MAXVOLUME

GLSDL

SDL_MOUSEBUTTONDOWN

GLSDL

SDL_MOUSEBUTTONDOWNMASK

GLSDL

SDL_MOUSEBUTTONUP

GLSDL

SDL_MOUSEBUTTONUPMASK

GLSDL

SDL_MOUSEEVENTMASK

GLSDL

SDL_MOUSEMOTION

GLSDL

SDL_MOUSEMOTIONMASK

GLSDL

SDL_MustLock

GLSDL

SDL_mutexP

GLSDL

SDL_mutexV

GLSDL

SDL_MUTEX_MAXWAIT

GLSDL

SDL_MUTEX_TIMEDOUT

GLSDL

SDL_NOEVENT

GLSDL

SDL_NOFRAME

GLSDL

SDL_NUMEVENTS

GLSDL

SDL_NumJoysticks

GLSDL

SDL_OpenAudio

GLSDL

SDL_OPENGL

GLSDL

SDL_OPENGLBLIT

GLSDL

SDL_OutOfMemory

GLSDL

SDL_PATCHLEVEL

GLSDL

SDL_PauseAudio

GLSDL

SDL_PeepEvents

GLSDL

SDL_PHYSPAL

GLSDL

SDL_PollEvent

GLSDL

SDL_PREALLOC

GLSDL

SDL_PRESSED

GLSDL

SDL_PumpEvents

GLSDL

SDL_PushEvent

GLSDL

SDL_putenv

GLSDL

SDL_QUERY

GLSDL

SDL_Quit

GLSDL

SDL_QUITEV

GLSDL

SDL_QUITMASK

GLSDL

SDL_QuitSubSystem

GLSDL

SDL_Rect

GLSDL

SDL_RegisterApp

GLSDL

SDL_RELEASED

GLSDL

SDL_RemoveTimer

GLSDL

SDL_RESIZABLE

GLSDL

SDL_RLEACCEL

GLSDL

SDL_RLEACCELOK

GLSDL

SDL_RWClose

GLSDL

SDL_RWFromFile

GLSDL

SDL_RWFromFP

GLSDL

SDL_RWFromMem

GLSDL

SDL_RWops

GLSDL

SDL_RWRead

GLSDL

SDL_RWSeek

GLSDL

SDL_RWTell

GLSDL

SDL_RWWrite

GLSDL

SDL_SaveBMP

GLSDL

SDL_SaveBMP_RW

GLSDL

SDL_SemPost

GLSDL

SDL_SemTryWait

GLSDL

SDL_SemValue

GLSDL

SDL_SemWait

GLSDL

SDL_SemWaitTimeout

GLSDL

SDL_SetAlpha

GLSDL

SDL_SetClipRect

GLSDL

SDL_SetColorKey

GLSDL

SDL_SetColors

GLSDL

SDL_SetCursor

GLSDL

SDL_SetError

GLSDL

SDL_SetEventFilter

GLSDL

SDL_SetGamma

GLSDL

SDL_SetGammaRamp

GLSDL

SDL_SetModState

GLSDL

SDL_SetPalette

GLSDL

SDL_SetTimer

GLSDL

SDL_SetVideoMode

GLSDL

SDL_ShowCursor

GLSDL

SDL_SRCALPHA

GLSDL

SDL_SRCCLIPPING

GLSDL

SDL_SRCCOLORKEY

GLSDL

SDL_Swap32

GLSDL

SDL_SWSURFACE

GLSDL

SDL_SYSWMEVENT

GLSDL

SDL_SYSWMEVENTMASK

GLSDL

SDL_TABLESIZE

GLSDL

SDL_ThreadID

GLSDL

SDL_TIMESLICE

GLSDL

SDL_UnlockAudio

GLSDL

SDL_UnlockMutex

GLSDL

SDL_UnlockSurface

GLSDL

SDL_UnlockYUVOverlay

GLSDL

SDL_UpdateRect

GLSDL

SDL_UpdateRects

GLSDL

SDL_UpperBlit

GLSDL

SDL_USEREVENT

GLSDL

SDL_UYVY_OVERLAY

GLSDL

SDL_VERSION

GLSDL

SDL_VERSIONNUM

GLSDL

SDL_VERSION_ATLEAST

GLSDL

SDL_VideoDriverName

GLSDL

SDL_VIDEOEXPOSE

GLSDL

SDL_VideoInit

GLSDL

SDL_VideoModeOK

GLSDL

SDL_VideoQuit

GLSDL

SDL_VIDEORESIZE

GLSDL

SDL_VIDEORESIZEMASK

GLSDL

SDL_WaitEvent

GLSDL

SDL_WaitThread

GLSDL

SDL_WarpMouse

GLSDL

SDL_WasInit

GLSDL

SDL_WM_GetCaption

GLSDL

SDL_WM_GrabInput

GLSDL

SDL_WM_IconifyWindow

GLSDL

SDL_WM_SetCaption

GLSDL

SDL_WM_SetIcon

GLSDL

SDL_WM_ToggleFullScreen

GLSDL

SDL_YUY2_OVERLAY

GLSDL

SDL_YV12_OVERLAY

GLSDL

SDL_YVYU_OVERLAY

GLSDL

SEARCH_ANY

GLSVfw

SEARCH_BACKWARD

GLSVfw

SEARCH_FORWARD

GLSVfw

SEARCH_KEY

GLSVfw

SEARCH_NEAREST

GLSVfw

SegmentPlaneIntersection

VectorGeometry

Computes segment / plane intersection return false if there isn't an intersection

SegmentSegmentClosestPoint

VectorGeometry

Computes the closest points (2) given two segments.

SegmentSegmentDistance

VectorGeometry

Computes the closest distance between two segments.

SERIALIZE_ID_BOX

NewtonImport

SERIALIZE_ID_CAPSULE

NewtonImport

SERIALIZE_ID_CHAMFERCYLINDER

NewtonImport

SERIALIZE_ID_COMPOUND

NewtonImport

SERIALIZE_ID_COMPOUND_BREAKABLE

NewtonImport

SERIALIZE_ID_CONE

NewtonImport

SERIALIZE_ID_CONVEXHULL

NewtonImport

SERIALIZE_ID_CONVEXMODIFIER

NewtonImport

SERIALIZE_ID_CYLINDER

NewtonImport

SERIALIZE_ID_HEIGHTFIELD

NewtonImport

SERIALIZE_ID_NULL

NewtonImport

SERIALIZE_ID_SCENE

NewtonImport

SERIALIZE_ID_SPHERE

NewtonImport

SERIALIZE_ID_TREE

NewtonImport

SERIALIZE_ID_USERMESH

NewtonImport

SetAABB

GeometryBB

SetAffineVector

VectorGeometry

SetBB

GeometryBB

SetDecimalSeparator

GLCrossPlatform

SetExeDirectory

GLCrossPlatform

SetFullscreenMode

GLScreen

Changes to the video mode given by 'Index'

SetGLSceneMediaDir

GLUtils

SetGLTextureImageClassesToStrings

GLTexture

Defines a TStrings with the list of registered TGLTextureImageClass.

SetMatrix

VectorGeometry

SetMatrix

VectorGeometry

SetMatrix

VectorGeometry

SetMatrixRow

VectorGeometry

SetPlane

VectorGeometry

Converts from single to double representation

SetROAMTrianglesCapacity

GLROAMPatch

Specifies the maximum number of ROAM triangles that may be allocated.

SetScreenSaverPassword

ScreenSaver

Invokes the standard Windows dialog to set the password.<p> May be invoked from your Properties/Configuration dialog.

setTransform

ODEGL

SetupTangentSpace

BumpMapping

SetupVSync

GLViewer

SetVector

VectorGeometry

SetVector

VectorGeometry

SetVector

VectorGeometry

SetVector

VectorGeometry

SetVector

VectorGeometry

SetVector

VectorGeometry

SetVector

VectorGeometry

SetVector

VectorGeometry

SetXMLAttribute

GLSCrossXML

SetXMLText

GLSCrossXML

ShaderUniformEditor

FRUniformEditor

ShadowFilterMax3DS

Const3DS

ShadowFilterMin3DS

Const3DS

ShadowMapSizeMin3DS

Const3DS

ShadowRangeMin3DS

Const3DS

ShadowSamplesMin3DS

Const3DS

SHADOW_FILTER

Const3DS

SHADOW_MAP_SIZE

Const3DS

SHADOW_RANGE

Const3DS

SHADOW_SAMPLES

Const3DS

SHAPE_2D

Const3DS

SHAPE_HOOK

Const3DS

SHAPE_NOT_OK

Const3DS

SHAPE_OK

Const3DS

ShiftObjectFromCenter

VectorGeometry

AOriginalPosition - Object initial position. ACenter - some point, from which is should be distanced.
ADistance + AFromCenterSpot - distance, which object should keep from ACenter or ADistance + not AFromCenterSpot - distance, which object should shift from his current position away from center.

ShiftObjectFromCenter

VectorGeometry

Short

NewtonImport

ShowError

Utils3DS

ShowErrorFormatted

Utils3DS

ShowHTMLUrl

GLCrossPlatform

SIDE_BACK

LWObjects

SIDE_FRONT

LWObjects

SIDE_FRONT_AND_BACK

LWObjects

SIGN

GLFilePAK

Sign

VectorGeometry

Returns the sign of the x value using the (-1, 0, +1) convention

SIGN

GLVfsPAK

SIGN

GLFileZLIB

SignStrict

VectorGeometry

SIGN_COMPRESSED

GLVfsPAK

SinCos

VectorGeometry

Calculates sine and cosine from the given angle Theta and Radius.<p> sin and cos values calculated from theta are multiplicated by radius.

SinCos

VectorGeometry

Calculates sine and cosine from the given angle Theta and Radius.<p> sin and cos values calculated from theta are multiplicated by radius.

SinCos

VectorGeometry

Calculates sine and cosine from the given angle Theta Calculates sine and cosine from the given angle Theta

SinCos

VectorGeometry

Calculates sine and cosine from the given angle Theta

Sinh

VectorGeometry

Sinh

VectorGeometry

SInt16

GLSDL

SInt32

GLSDL

SInt64

GLSDL

SIRegister_ApplicationFileIO

uPSI_ApplicationFileIO

SIRegister_EFilerException

uPSI_PersistentClasses

SIRegister_EFilerException

uPSI_XCollection

SIRegister_EInvalidFileSignature

uPSI_PersistentClasses

SIRegister_GLStrings

uPSI_GLStrings

SIRegister_GLUtils

uPSI_GLUtils

SIRegister_IPersistentObject

uPSI_PersistentClasses

SIRegister_PersistentClasses

uPSI_PersistentClasses

SIRegister_TApplicationFileIO

uPSI_ApplicationFileIO

SIRegister_TBaseList

uPSI_VectorLists

SIRegister_TBinaryReader

uPSI_PersistentClasses

SIRegister_TBinaryWriter

uPSI_PersistentClasses

SIRegister_TByteList

uPSI_VectorLists

SIRegister_TDataFile

uPSI_ApplicationFileIO

SIRegister_TDoubleList

uPSI_VectorLists

SIRegister_TGLInterfacedCollectionItem

uPSI_PersistentClasses

SIRegister_TGLInterfacedPersistent

uPSI_PersistentClasses

SIRegister_TGLOwnedPersistent

uPSI_PersistentClasses

SIRegister_TIntegerList

uPSI_VectorLists

SIRegister_TPersistentObject

uPSI_PersistentClasses

SIRegister_TPersistentObjectList

uPSI_PersistentClasses

SIRegister_TSingleList

uPSI_VectorLists

SIRegister_TTextReader

uPSI_PersistentClasses

SIRegister_TTextWriter

uPSI_PersistentClasses

SIRegister_TVirtualReader

uPSI_PersistentClasses

SIRegister_TVirtualWriter

uPSI_PersistentClasses

SIRegister_TXCollection

uPSI_XCollection

SIRegister_TXCollectionItem

uPSI_XCollection

SIRegister_VectorGeometry

uPSI_VectorGeometry

SIRegister_VectorLists

uPSI_VectorLists

SIRegister_VectorTypes

uPSI_VectorTypes

SIRegister_XCollection

uPSI_XCollection

SizeOfFile

GLUtils

Returns the size of "filename".<p> Returns 0 (zero) is file does not exists.

size_t

NewtonImport

SkipBeforeSTR

GLSLog

SliderEnableLimits

NewtonImport_JointLibrary

SliderSetLimits

NewtonImport_JointLibrary

SMAGIC

Const3DS

Smooth01Group3DS

Const3DS

Smooth02Group3DS

Const3DS

Smooth03Group3DS

Const3DS

Smooth04Group3DS

Const3DS

Smooth05Group3DS

Const3DS

Smooth06Group3DS

Const3DS

Smooth07Group3DS

Const3DS

Smooth08Group3DS

Const3DS

Smooth09Group3DS

Const3DS

Smooth10Group3DS

Const3DS

Smooth11Group3DS

Const3DS

Smooth12Group3DS

Const3DS

Smooth13Group3DS

Const3DS

Smooth14Group3DS

Const3DS

Smooth15Group3DS

Const3DS

Smooth16Group3DS

Const3DS

Smooth17Group3DS

Const3DS

Smooth18Group3DS

Const3DS

Smooth19Group3DS

Const3DS

Smooth20Group3DS

Const3DS

Smooth21Group3DS

Const3DS

Smooth22Group3DS

Const3DS

Smooth23Group3DS

Const3DS

Smooth24Group3DS

Const3DS

Smooth25Group3DS

Const3DS

Smooth26Group3DS

Const3DS

Smooth27Group3DS

Const3DS

Smooth28Group3DS

Const3DS

Smooth29Group3DS

Const3DS

Smooth30Group3DS

Const3DS

Smooth31Group3DS

Const3DS

Smooth32Group3DS

Const3DS

SMOOTH_GROUP

Const3DS

SMOOTH_GROUP_ENTRY

Const3DS

Smooth_Interpolate_Strip

GLPerlinBase

SOLID_BGND

Const3DS

SolveCubic

Polynomials

Computes the real roots of a real polynomial of the 3rd degree.<p> The polynomial is of the form:<br> A(0) + A(1)*Z + A(2)*Z**2 + A(3)*Z**3

SolveQuadric

Polynomials

Computes the real roots of a real polynomial of the 2nd degree.<p> The polynomial is of the form:<br> A(0) + A(1)*Z + A(2)*Z**2

SolveQuartic

Polynomials

Computes the real roots of a real polynomial of the 4th degree.<p> The polynomial is of the form:<br> A(0) + A(1)*Z + ... + A(4)*Z**4

sOpenGLCategoryName

GLSceneRegister

SortArrayAscending

VectorGeometry

Sorts given array in ascending order.<p> NOTE : current implementation is a slow bubble sort...

SphereVisibleRadius

VectorGeometry

Computes the visible radius of a sphere in a perspective projection.<p> This radius can be used for occlusion culling (cone extrusion) or 2D intersection testing.

Spherical_Cartesian

GeometryCoordinates

Convert spherical to cartesion. [double] theta,phi in rads

Spherical_Cartesian

GeometryCoordinates

Convert spherical to cartesian [double] (with error check).theta,phi in rad

Spherical_Cartesian

GeometryCoordinates

Convert spherical to cartesion. [single] theta,phi in rads

Spherical_Cartesian

GeometryCoordinates

Convert spherical to cartesian [single] (with error check).theta,phi in rad

SPOTLIGHT_NODE_TAG

Const3DS

StarRecordColor

GLStarRecord

Computes star color from BV index (RGB) and magnitude (alpha).

StarRecordPositionYUp

GLStarRecord

Computes position on the unit sphere of a star record (Y=up).

StarRecordPositionZUp

GLStarRecord

Computes position on the unit sphere of a star record (Z=up).

StartAllMovements

GLMovement

StartPrecisionTimer

GLCrossPlatform

Starts a precision timer.<p> Returned value should just be considered as 'handle', even if it ain't so. Default platform implementation is to use QueryPerformanceCounter and QueryPerformanceFrequency, if higher precision references are available, they should be used. The timer will and must be stopped/terminated/released with StopPrecisionTimer.

StopAllMovements

GLMovement

StopPrecisionTimer

GLCrossPlatform

Computes time elapsed since timer start and stop timer.<p> Return time lap in seconds.

STREAMFILEPROC

Bass

StreamFromFOURCC

GLSVfw

STREAMPROC

Bass

streamtypeAUDIO

GLSVfw

streamtypeMIDI

GLSVfw

streamtypeTEXT

GLSVfw

streamtypeVIDEO

GLSVfw

String3DS

Types3DS

String64

Types3DS

StringToColorAdvanced

GLUtils

Converts a string into color

StringToColorAdvancedSafe

GLUtils

Converts a string into color

StripifyMesh

MeshUtils

Attempts to create as few as possible triangle strips to cover the mesh.<p> The indices parameters define a set of triangles as a set of indices to vertices in a vertex pool, free of duplicate vertices (or resulting stripification will be of lower quality).<br> The function returns a list of TIntegerList, each of these lists hosting a triangle strip, returned objects must be freed by caller.<br> If agglomerateLoneTriangles is True, the first of the lists actually contains the agglomerated list of the triangles that couldn't be stripified.

StrToFloatDef

GLUtils

Similar to SysUtils.StrToFloatDef, but ignores user's locale

StrToGLSResType

ApplicationFileIO

SubdivideTriangles

MeshUtils

Subdivides mesh triangles.<p> Splits along edges, each triangle becomes four. The smoothFactor can be used to control subdivision smoothing, zero means no smoothing (tesselation only), while 1 means "sphere" subdivision (a low res sphere will be subdivided in a higher-res sphere), values outside of the [0..1] range are for, er, artistic purposes.<p> The procedure is not intended for real-time use.

SubtractVector

VectorGeometry

Subtracts V2 from V1, result is placed in V1

SubtractVector

VectorGeometry

Subtracts V2 from V1, result is placed in V1

SubtractVector

VectorGeometry

Subtracts V2 from V1, result is placed in V1

SURF_FLAG_ADDITIVE

LWObjects

SURF_FLAG_COLORFILTER

LWObjects

SURF_FLAG_COLORHIGHLIGHTS

LWObjects

SURF_FLAG_DOUBLESIDED

LWObjects

SURF_FLAG_LUMINOUS

LWObjects

SURF_FLAG_OPAQUEEDGE

LWObjects

SURF_FLAG_OUTLINE

LWObjects

SURF_FLAG_SHADOWALPHA

LWObjects

SURF_FLAG_SHARPTERMINATOR

LWObjects

SURF_FLAG_SMOOTHING

LWObjects

SURF_FLAG_TRANSPARENTEDGE

LWObjects

SYNCPROC

Bass

T1DPerlinArray

GLPerlinBase

T1_MAX_MM_AXIS

LIBFREETYPE

T2DPerlinArray

GLPerlinBase

T48BitBlock

ImageUtils

T4ByteArrayList

VectorLists

T4ByteData

VectorLists

T4ByteList

VectorLists

A list of T4ByteData.<p>

TAABB

GeometryBB

TAABBCorners

GeometryBB

TAABBOverlapEvent

GLNGDManager

TAArray

GLzBuffer

TAArrayIdx

GLzBuffer

TAbstractMultitextureCoordinator

GLContext

TAbstractMultitextureCoordinatorClass

GLContext

TActorAnimation

GLVectorFileObjects

An actor animation sequence.<p> An animation sequence is a named set of contiguous frames that can be used for animating an actor. The referred frames can be either morph or skeletal frames (choose which via the Reference property).<p> An animation can be directly "played" by the actor by selecting it with SwitchAnimation, and can also be "blended" via a TGLAnimationControler.

TActorAnimationMode

GLVectorFileObjects

Defines how an actor plays between its StartFrame and EndFrame.<p> <ul> <li>aamNone : no animation is performed <li>aamPlayOnce : play from current frame to EndFrame, once end frame has been reached, switches to aamNone <li>aamLoop : play from current frame to EndFrame, once end frame has been reached, sets CurrentFrame to StartFrame <li>aamBounceForward : play from current frame to EndFrame, once end frame has been reached, switches to aamBounceBackward <li>aamBounceBackward : play from current frame to StartFrame, once start frame has been reached, switches to aamBounceForward <li>aamExternal : Allows for external animation control </ul>

TActorAnimationName

GLVectorFileObjects

TActorAnimationReference

GLVectorFileObjects

TActorAnimations

GLVectorFileObjects

Collection of actor animations sequences.

TActorFrameInterpolation

GLVectorFileObjects

Actor frame-interpolation mode.<p> - afpNone : no interpolation, display CurrentFrame only<br> - afpLinear : perform linear interpolation between current and next frame

TACubic3DS

Types3DS

TAffineByteMatrix

VectorGeometry

TAffineByteVector

VectorGeometry

TAffineDblMatrix

VectorGeometry

TAffineDblVector

VectorGeometry

TAffineExtMatrix

VectorGeometry

TAffineExtVector

VectorGeometry

TAffineFltMatrix

VectorGeometry

TAffineFltVector

VectorGeometry

TAffineIntMatrix

VectorGeometry

TAffineIntVector

VectorGeometry

TAffineMatrix

VectorGeometry

TAffinePtrVector

VectorGeometry

TAffineVector

VectorGeometry

TAffineVectorArray

VectorGeometry

TAffineVectorList

VectorLists

A list of TAffineVector.<p> Similar to TList, but using TAffineVector as items.<p> The list has stack-like push/pop methods.

TAffineWordMatrix

VectorGeometry

TAffineWordVector

VectorGeometry

TAFIOCreateFileStream

ApplicationFileIO

TAFIOFileStreamEvent

ApplicationFileIO

TAFIOFileStreamExists

ApplicationFileIO

TAFIOFileStreamExistsEvent

ApplicationFileIO

TALbitfield

openal

TALboolean

openal

TALbyte

openal

TALCboolean

openal

TALCbyte

openal

TALCchar

openal

TALCcontext

openal

TALCdevice

openal

TALCdouble

openal

TALCenum

openal

TALCfloat

openal

TALchar

openal

TALCint

openal

TALclampd

openal

TALclampf

openal

TALCshort

openal

TALCsizei

openal

TALCubyte

openal

TALCuint

openal

TALCushort

openal

TALCvoid

openal

TALdouble

openal

TALenum

openal

TALfloat

openal

TALint

openal

TAlloc

LIBPNG

TALshort

openal

TALsizei

openal

TALuByte

openal

TALuint

openal

TALushort

openal

TALvoid

openal

Tan

VectorGeometry

Tan

VectorGeometry

TANG4

LWObjects

TangentAttributeName

GLObjects

TAngleLimit1

GLObjects

TAngleLimit2

GLObjects

TANIMChunk

TypesB3D

TAnnulusPart

GLGeomObjects

TAnnulusParts

GLGeomObjects

TApplicationFileIO

ApplicationFileIO

Allows specifying a custom behaviour for ApplicationFileIO's CreateFileStream.<p> The component should be considered a helper only, you can directly specify a function via the vAFIOCreateFileStream variable.<br> If multiple TApplicationFileIO components exist in the application, the last one created will be the active one.

TApplyForceAndTorqueEvent

GLNGDManager

TArcDirection

GLCanvas

TArchiveFileFormat

GLSArchiveManager

TArchiveFileFormatsList

GLSArchiveManager

TArg

GLSDL

TARGET_NODE_TAG

Const3DS

TArrowArcPart

GLGeomObjects

TArrowArcParts

GLGeomObjects

TArrowHeadStackingStyle

GLGeomObjects

TArrowLinePart

GLGeomObjects

TArrowLineParts

GLGeomObjects

TASETextureMap

GLFileASE

TAsmProgFileProperty

GLSceneRegister

TAsyncTimer

AsyncTimer

TAtmosphere3DS

Types3DS

TAtmosphereType3DS

Types3DS

TAVICOMPRESSOPTIONS

GLSVfw

TAVICompressor

GLAVIRecorder

TAVIFileInfo

GLSVfw

TAVIFileInfoA

GLSVfw

TAVIFileInfoW

GLSVfw

TAVIImageRetrievalMode

GLAVIRecorder

Image retrieval mode for frame capture.<p> Following modes are supported:<p> <li>irmSnapShot : retrieve OpenGL framebuffer content using glReadPixels <li>irmRenderToBitmap : renders the whole scene to a bitmap, this is the slowest mode, but it won't be affected by driver-side specifics. <li>irmBitBlt : tranfers the framebuffer using the BitBlt function, usually the fastest solution </ul>

TAVIINDEXENTRY

GLSVfw

TAVIPALCHANGE

GLSVfw

TAVIRecorder

GLAVIRecorder

Component to make it easy to record GLScene frames into an AVI file.

TAVIRecorderPostProcessEvent

GLAVIRecorder

TAVIRecorderState

GLAVIRecorder

TAVISAVECALLBACK

GLSVfw

TAVISizeRestriction

GLAVIRecorder

Frame size restriction.<p> Forces frame dimensions to be a multiple of 2, 4, or 8. Some compressors require this. e.g. DivX 5.2.1 requires mutiples of 2.

TAVIStreamHeader

GLSVfw

TAVIStreamInfo

GLSVfw

TAVIStreamInfoA

GLSVfw

TAVIStreamInfoW

GLSVfw

TB3DChunk

TypesB3D

TB3DChunkType

TypesB3D

TB3DMaterial

FileB3D

TB3DNode

FileB3D

TB3DTexture

FileB3D

TBackground3DS

Types3DS

TBackgroundType3DS

Types3DS

TBallDelta

GLSDL

TBaseArchive

GLSArchiveManager

TBaseArchiveClass

GLSArchiveManager

TBaseConnectivity

GLSilhouette

TBaseList

VectorLists

Base class for lists, introduces common behaviours.

TBaseListOption

VectorLists

TBaseListOptions

VectorLists

TBaseMeshObject

GLVectorFileObjects

A base class for mesh objects.<p> The class introduces a set of vertices and normals for the object but does no rendering of its own.

TBaseSpacePartition

SpatialPartitioning

TBaseVectorList

VectorLists

Base class for vector lists, introduces common behaviours.

TBASS3DAlgorithm

GLSMBASS

TBASSModuleHandle

Bass

TBASS_PLUGINFORMS

Bass

TBB3DChunk

TypesB3D

TBinaryReader

PersistentClasses

Wraps a TReader-compatible reader.

TBinaryWriter

PersistentClasses

Wraps a TWriter-compatible writer.

TBitmap3DS

Types3DS

TBitmapBgnd3DS

Types3DS

TBitmapFontRange

GLBitmapFont

An individual character range in a bitmap font.<p> A range allows mapping ASCII characters to character tiles in a font bitmap, tiles are enumerated line then column (raster).

TBitmapFontRanges

GLBitmapFont

TBlendedLerpInfo

GLVectorFileObjects

Small structure to store a weighted lerp for use in blending.

TBlendEquation

GLState

TBlendFunction

GLState

TBlendingMode

GLMaterial

Simplified blending options.<p> bmOpaque : disable blending<br> bmTransparency : uses standard alpha blending<br> bmAdditive : activates additive blending (with saturation)<br> bmAlphaTest50 : uses opaque blending, with alpha-testing at 50% (full transparency if alpha is below 0.5, full opacity otherwise)<br> bmAlphaTest100 : uses opaque blending, with alpha-testing at 100%<br> bmModulate : uses modulation blending<br> bmCustom : uses TGLBlendingParameters options

TBodyFlags

ODEImport

TBodyList

ODEImport

TBONEChunk

TypesB3D

TBoneMatrixObj

GLProxyObjects

An object containing the bone matrix for TGLActorProxy.<p>

TBorderType

GLSMemo

TBoundBox

Types3DS

TBRUSChunk

TypesB3D

TBSPBBox

Q3BSP

TBSPClusterVisibility

GLBSP

TBSPCullingSphere

GLBSP

TBSPFace

Q3BSP

TBSPHeader

Q3BSP

TBSphere

GeometryBB

TBSPLeaf

Q3BSP

TBSPLightmap

Q3BSP

TBSplineContinuity

CurvesAndSurfaces

TBSPLump

Q3BSP

TBSPMeshObject

GLBSP

TBSPModel

Q3BSP

TBSPNode

Q3BSP

TBSPRenderContextInfo

GLBSP

TBSPRenderSort

GLBSP

TBSPTexture

Q3BSP

TBSPVertex

Q3BSP

TBSPVisData

Q3BSP

TBumpMethod

GLBumpShader

TBumpOption

GLBumpShader

TBumpOptions

GLBumpShader

TBumpSpace

GLBumpShader

TByteArray

GLHeightData

TByteArray

GLSDL

TByteList

VectorLists

A list of bytes.<p> Similar to TList, but using Byte as items.<p>

TByteRaster

GLHeightData

TByteVector

VectorGeometry

TCadencableCustomCgShader

GLCgShader

Allows to use a Cadencer, which is used for noise generation in many shaders.

TCalcPointEvent

GLThorFX

TCamera3DS

Types3DS

TCamRanges

Types3DS

TCamRanges3DS

Types3DS

TCAPCONTROLCALLBACK

GLSVfw

TCAPDRIVERCAPS

GLSVfw

TCAPERRORCALLBACK

GLSVfw

TCAPERRORCALLBACKA

GLSVfw

TCAPERRORCALLBACKW

GLSVfw

TCAPINFOCHUNK

GLSVfw

TCAPSTATUS

GLSVfw

TCAPSTATUSCALLBACK

GLSVfw

TCAPSTATUSCALLBACKA

GLSVfw

TCAPSTATUSCALLBACKW

GLSVfw

TCAPTUREPARMS

GLSVfw

TCapType

GLObjects

TCAPVIDEOCALLBACK

GLSVfw

TCAPWAVECALLBACK

GLSVfw

TCAPYIELDCALLBACK

GLSVfw

TCardinalArray

Types3DS

TCardinalVector

VectorGeometry

TCellPos

GLSMemo

TCellSize

GLSMemo

TCgApplyEvent

GLCgShader

TCgFPProfile

GLCgShader

TCgFragmentProgram

GLCgShader

TCGGLenum

cgGL

TCgParameter

GLCgShader

Wrapper around a Cg parameter of the main program.

TCgProgram

GLCgShader

Wrapper around a Cg program.

TcgProgramType

GLCgShader

TCgShader

GLCgShader

TCgShaderEvent

GLCgShader

TCgUnApplyEvent

GLCgShader

TCgVertexProgram

GLCgShader

TCgVPProfile

GLCgShader

TChannelTypeAndNum

GLSCUDA

TCHANNEL_CAPS

GLSVfw

TCharInfo

GLBitmapFont

TCharStyle

GLSMemo

TChunk3DS

Types3DS

TChunkData

Types3DS

TChunkList

Types3DS

TChunkList3DS

Types3DS

TChunkListEntry3DS

Types3DS

TClipRect

GeometryBB

TClose

GLSDL

Tcl_addressing_mode

GLS_CL

Tcl_bitfield

GLS_CL

Tcl_bool

GLS_CL

Tcl_build_status

GLS_CL

Tcl_channel_order

GLS_CL

Tcl_channel_type

GLS_CL

Tcl_char

GLS_CL_Platform

Tcl_char16

GLS_CL_Platform

Tcl_char2

GLS_CL_Platform

Tcl_char4

GLS_CL_Platform

Tcl_char8

GLS_CL_Platform

Tcl_command_queue

GLS_CL

Tcl_command_queue_info

GLS_CL

Tcl_command_queue_properties

GLS_CL

Tcl_command_type

GLS_CL

Tcl_context

GLS_CL

Tcl_context_info

GLS_CL

Tcl_context_properties

GLS_CL

Tcl_device_address_info

GLS_CL

Tcl_device_exec_capabilities

GLS_CL

Tcl_device_fp_config

GLS_CL

Tcl_device_id

GLS_CL

Tcl_device_info

GLS_CL

Tcl_device_local_mem_type

GLS_CL

Tcl_device_mem_cache_type

GLS_CL

Tcl_device_type

GLS_CL

Tcl_double

GLS_CL_Platform

Tcl_double16

GLS_CL_Platform

Tcl_double2

GLS_CL_Platform

Tcl_double4

GLS_CL_Platform

Tcl_double8

GLS_CL_Platform

Tcl_event

GLS_CL

Tcl_event_info

GLS_CL

Tcl_filter_mode

GLS_CL

Tcl_float

GLS_CL_Platform

Tcl_float16

GLS_CL_Platform

Tcl_float2

GLS_CL_Platform

Tcl_float4

GLS_CL_Platform

Tcl_float8

GLS_CL_Platform

Tcl_gl_object_type

GLS_CL_GL

Tcl_gl_platform_info

GLS_CL_GL

Tcl_gl_texture_info

GLS_CL_GL

Tcl_half

GLS_CL_Platform

Tcl_image_format

GLS_CL

Tcl_image_info

GLS_CL

Tcl_int

GLS_CL_Platform

Tcl_int16

GLS_CL_Platform

Tcl_int2

GLS_CL_Platform

Tcl_int4

GLS_CL_Platform

Tcl_int8

GLS_CL_Platform

Tcl_kernel

GLS_CL

Tcl_kernel_info

GLS_CL

Tcl_kernel_work_group_info

GLS_CL

Tcl_long

GLS_CL_Platform

Tcl_long16

GLS_CL_Platform

Tcl_long2

GLS_CL_Platform

Tcl_long4

GLS_CL_Platform

Tcl_long8

GLS_CL_Platform

Tcl_map_flags

GLS_CL

Tcl_mem

GLS_CL

Tcl_mem_flags

GLS_CL

Tcl_mem_info

GLS_CL

Tcl_mem_object_type

GLS_CL

Tcl_platform_id

GLS_CL

Tcl_platform_info

GLS_CL

Tcl_profiling_info

GLS_CL

Tcl_program

GLS_CL

Tcl_program_build_info

GLS_CL

Tcl_program_info

GLS_CL

Tcl_sampler

GLS_CL

Tcl_sampler_info

GLS_CL

Tcl_short

GLS_CL_Platform

Tcl_short16

GLS_CL_Platform

Tcl_short2

GLS_CL_Platform

Tcl_short4

GLS_CL_Platform

Tcl_short8

GLS_CL_Platform

Tcl_uchar

GLS_CL_Platform

Tcl_uchar16

GLS_CL_Platform

Tcl_uchar2

GLS_CL_Platform

Tcl_uchar4

GLS_CL_Platform

Tcl_uchar8

GLS_CL_Platform

Tcl_uint

GLS_CL_Platform

Tcl_uint16

GLS_CL_Platform

Tcl_uint2

GLS_CL_Platform

Tcl_uint4

GLS_CL_Platform

Tcl_uint8

GLS_CL_Platform

Tcl_ulong

GLS_CL_Platform

Tcl_ulong16

GLS_CL_Platform

Tcl_ulong2

GLS_CL_Platform

Tcl_ulong4

GLS_CL_Platform

Tcl_ulong8

GLS_CL_Platform

Tcl_ushort

GLS_CL_Platform

Tcl_ushort16

GLS_CL_Platform

Tcl_ushort2

GLS_CL_Platform

Tcl_ushort4

GLS_CL_Platform

Tcl_ushort8

GLS_CL_Platform

TCollisionBoundingMode

GLCollision

Defines how fine collision bounding is for a particular object.<p> Possible values are :<ul> <li>cbmPoint : the object is punctual and may only collide with volumes <li>cbmSphere : the object is defined by its bounding sphere (sphere radius is the max of axis-aligned dimensions) <li>cbmEllipsoid the object is defined by its bounding axis-aligned ellipsoid <li>cbmCube : the object is defined by a bounding axis-aligned "cube" <li>cbmFaces : the object is defined by its faces (needs object-level support, if unavalaible, uses cbmCube code) </ul>

TCollisionConstraintTypes

VerletClasses

TCollisionConstraintTypesSet

VerletClasses

TCollisionIteratorEvent

GLNGDManager

TCollisionManager

GLCollision

TCollisionPrimitiveArray

NewtonImport

TCollisionState

GLFPSMovement

TCollisionStates

GLFPSMovement

TColor24

Types3DS

TColorComponent

GLState

TColorEntry

GLColor

TColorF

Types3DS

TColorMask

GLState

TColorVector

GLColor

TColr12

LWObjects

TColr12DynArray

LWObjects

TColr4

LWObjects

TColTrackTag

Types3DS

TCombinerCache

GLTextureCombiners

TCombinerCommand

GLTextureCombiners

TCommand

GLSMemo

TComparisonFunction

GLState

TCompressionLevel

GLSArchiveManager

TCOMPVARS

GLSVfw

TConePart

GLGeomObjects

TConeParts

GLGeomObjects

TConeStyle3DS

Types3DS

TConnectivity

GLSilhouette

TContactPoint

GLFPSMovement

TContactPoint

GLODECustomColliders

TContactProcessEvent

GLNGDManager

TContextOption

GLScene

Options for the rendering context.<p> roSoftwareMode: force software rendering. roDoubleBuffer: enables double-buffering.<br> roRenderToWindows: ignored (legacy).<br> roTwoSideLighting: enables two-side lighting model.<br> roStereo: enables stereo support in the driver (dunno if it works, I don't have a stereo device to test...)<br> roDestinationAlpha: request an Alpha channel for the rendered output<br> roNoColorBuffer: don't request a color buffer (color depth setting ignored)<br> roNoColorBufferClear: do not clear the color buffer automatically, if the whole viewer is fully repainted each frame, this can improve framerate<br> roNoSwapBuffers: don't perform RenderingContext.SwapBuffers after rendering roNoDepthBufferClear: do not clear the depth buffer automatically. Useful for early-z culling.<br> roForwardContext: force OpenGL forward context

TContextOptions

GLScene

TConvertEncodingList

GLSLanguage

TCoronaTangentLookup

GLImposter

TCSGOperation

GLMeshCSG

TCuAddresMode

GLSCUDA

TCUaddress_mode

GLS_CUDA_API

TCUarray

GLS_CUDA_API

TcuArray3DCreate

GLS_CUDA_API

TcuArray3DGetDescriptor

GLS_CUDA_API

TcuArrayCreate

GLS_CUDA_API

TcuArrayDestroy

GLS_CUDA_API

TcuArrayGetDescriptor

GLS_CUDA_API

TCUarray_cubemap_face

GLS_CUDA_API

TCUarray_format

GLS_CUDA_API

TCubePart

GLObjects

TCubeParts

GLObjects

TCubicSpline

Spline

3D cubic spline handler class.<p> This class allows to describe and calculate values of a time-based, three-dimensionnal cubic spline.<p> Cubic spline pass through all given points and tangent on point N is given by the (N-1) to (N+1) vector.<p> Note : X, Y & Z are actually interpolated independently.

TCubicSplineMatrix

Spline

TCUcomputemode

GLS_CUDA_API

TCUcontext

GLS_CUDA_API

TcuCtxAttach

GLS_CUDA_API

TcuCtxCreate

GLS_CUDA_API

TcuCtxDestroy

GLS_CUDA_API

TcuCtxDetach

GLS_CUDA_API

TcuCtxGetDevice

GLS_CUDA_API

TcuCtxPopCurrent

GLS_CUDA_API

TcuCtxPushCurrent

GLS_CUDA_API

TcuCtxSynchronize

GLS_CUDA_API

TCUctx_flags

GLS_CUDA_API

TcudaArray

GLS_CUDA_Runtime

TCUDAChange

GLSCUDA

TCUDAChanges

GLSCUDA

TCudaChannelFormatDesc

GLS_CUDA_Runtime

TCudaChannelFormatKind

GLS_CUDA_Runtime

TCUDAChannelNum

GLSCUDA

TCUDAChannelType

GLSCUDA

TCUDAComponent

GLSCUDA

TCUDAComponentClass

GLSCUDA

TCUDAConstant

GLSCUDA

TCUDAConstantInfo

GLSCUDAParser

TCUDAContext

GLSCUDAContext

TCUDAContextList

GLSCUDAContext

TCUDADevice

GLSCUDAContext

TCUDADeviceList

GLSCUDAContext

TCudaDeviceProp

GLS_CUDA_Runtime

TCUDADimensions

GLSCUDAContext

TcudaError

GLS_CUDA_Runtime

TcudaExtent

GLS_CUDA_Runtime

TCUDAFFTdir

GLSCUDAFFTPlan

TCUDAFFTPlan

GLSCUDAFFTPlan

TCUDAFFTransform

GLSCUDAFFTPlan

TCUDAFuncArgInfo

GLSCUDAParser

TcudaFuncAttributes

GLS_CUDA_API

TcudaFuncCache

GLS_CUDA_API

TCUDAFuncInfo

GLSCUDAParser

TCUDAFuncParam

GLSCUDA

TCUDAFunction

GLSCUDA

TCUDAGLGeometryResource

GLSCUDAGraphics

TCUDAGLImageResource

GLSCUDAGraphics

TCudaGLMapFlags

GLS_CUDA_Runtime

TCUDAGraphicResource

GLSCUDA

TCUDAHandleList

GLSCUDAContext

TCUDAHandlesMaster

GLSCUDAContext

TcudaLimit

GLS_CUDA_API

TCUDAMapping

GLSCUDA

TcudaMemcpy3DParms

GLS_CUDA_Runtime

TcudaMemcpyKind

GLS_CUDA_Runtime

TCUDAMemData

GLSCUDA

TCUDAMemMapFlag

GLSCUDA

TCUDAMemMapFlags

GLSCUDA

TCUDAMemType

GLSCUDA

TCUDAModule

GLSCUDA

TCUDAModuleInfo

GLSCUDAParser

TcudaPitchedPtr

GLS_CUDA_Runtime

TcudaPos

GLS_CUDA_Runtime

TcudaRoundMode

GLS_CUDA_FourierTransform

TCUDATexRefInfo

GLSCUDAParser

TCUDATexture

GLSCUDA

TcudaTextureAddressMode

GLS_CUDA_Runtime

TcudaTextureFilterMode

GLS_CUDA_Runtime

TcudaTextureReadMode

GLS_CUDA_Runtime

TCUDAType

GLSCUDAParser

TCUDAUniform

GLSCUDA

TCUDA_ARRAY3D_DESCRIPTOR

GLS_CUDA_API

TCUDA_ARRAY_DESCRIPTOR

GLS_CUDA_API

TCUDA_MEMCPY2D

GLS_CUDA_API

TCUDA_MEMCPY3D

GLS_CUDA_API

TCUdevice

GLS_CUDA_API

TcuDeviceComputeCapability

GLS_CUDA_API

TcuDeviceGet

GLS_CUDA_API

TcuDeviceGetAttribute

GLS_CUDA_API

TcuDeviceGetCount

GLS_CUDA_API

TcuDeviceGetName

GLS_CUDA_API

TcuDeviceGetProperties

GLS_CUDA_API

TCUdeviceptr

GLS_CUDA_API

TcuDeviceTotalMem

GLS_CUDA_API

TCUdevice_attribute

GLS_CUDA_API

TCUdevprop

GLS_CUDA_API

TCUDPPAlgorithm

GLS_CUDA_ParallelPrimitives

TCUDPPConfiguration

GLS_CUDA_ParallelPrimitives

TCUDPPDatatype

GLS_CUDA_ParallelPrimitives

TCUDPPHandle

GLS_CUDA_ParallelPrimitives

TCUDPPOperator

GLS_CUDA_ParallelPrimitives

TCUDPPOption

GLS_CUDA_ParallelPrimitives

TCUDPPResult

GLS_CUDA_ParallelPrimitives

TcuDriverGetVersion

GLS_CUDA_API

TCUevent

GLS_CUDA_API

TcuEventCreate

GLS_CUDA_API

TcuEventDestroy

GLS_CUDA_API

TcuEventElapsedTime

GLS_CUDA_API

TcuEventQuery

GLS_CUDA_API

TcuEventRecord

GLS_CUDA_API

TcuEventSynchronize

GLS_CUDA_API

TCUevent_flags

GLS_CUDA_API

TcufftCompatibility

GLS_CUDA_FourierTransform

TcufftComplex

GLS_CUDA_FourierTransform

TcufftDestroy

GLS_CUDA_FourierTransform

TcufftDoubleComplex

GLS_CUDA_FourierTransform

TcufftDoubleReal

GLS_CUDA_FourierTransform

TcufftExecC2C

GLS_CUDA_FourierTransform

TcufftExecC2R

GLS_CUDA_FourierTransform

TcufftExecD2Z

GLS_CUDA_FourierTransform

TcufftExecR2C

GLS_CUDA_FourierTransform

TcufftExecZ2D

GLS_CUDA_FourierTransform

TcufftExecZ2Z

GLS_CUDA_FourierTransform

TcufftHandle

GLS_CUDA_FourierTransform

TcufftPlan1d

GLS_CUDA_FourierTransform

TcufftPlan2d

GLS_CUDA_FourierTransform

TcufftPlan3d

GLS_CUDA_FourierTransform

TcufftPlanMany

GLS_CUDA_FourierTransform

TcufftReal

GLS_CUDA_FourierTransform

TcufftRealfloat

GLS_CUDA_FourierTransform

TcufftResult

GLS_CUDA_FourierTransform

TcufftSetCompatibilityMode

GLS_CUDA_FourierTransform

TcufftSetStream

GLS_CUDA_FourierTransform

TcufftType

GLS_CUDA_FourierTransform

TCuFilterMode

GLSCUDA

TCUfilter_mode

GLS_CUDA_API

TcuFuncGetAttribute

GLS_CUDA_API

TcuFuncSetBlockShape

GLS_CUDA_API

TcuFuncSetSharedSize

GLS_CUDA_API

TCUfunction

GLS_CUDA_API

TCUfunction_attribute

GLS_CUDA_API

TcuGLCtxCreate

GLS_CUDA_API

TcuGLInit

GLS_CUDA_API

TcuGLMapBufferObject

GLS_CUDA_API

TcuGLMapBufferObjectAsync

GLS_CUDA_API

TCUGLmap_flags

GLS_CUDA_API

TcuGLRegisterBufferObject

GLS_CUDA_API

TcuGLSetBufferObjectMapFlags

GLS_CUDA_API

TcuGLUnmapBufferObject

GLS_CUDA_API

TcuGLUnmapBufferObjectAsync

GLS_CUDA_API

TcuGLUnregisterBufferObject

GLS_CUDA_API

TcuGraphicsGLRegisterBuffer

GLS_CUDA_API

TcuGraphicsGLRegisterImage

GLS_CUDA_API

TCUgraphicsMapResourceFlags

GLS_CUDA_API

TcuGraphicsMapResources

GLS_CUDA_API

TCUgraphicsRegisterFlags

GLS_CUDA_API

TCUgraphicsResource

GLS_CUDA_API

TcuGraphicsResourceGetMappedPointer

GLS_CUDA_API

TcuGraphicsResourceSetMapFlags

GLS_CUDA_API

TcuGraphicsSubResourceGetMappedArray

GLS_CUDA_API

TcuGraphicsUnmapResources

GLS_CUDA_API

TcuGraphicsUnregisterResource

GLS_CUDA_API

TcuInit

GLS_CUDA_API

TCUjit_fallback

GLS_CUDA_API

TCUjit_option

GLS_CUDA_API

TCUjit_target

GLS_CUDA_API

TcuLaunch

GLS_CUDA_API

TcuLaunchGrid

GLS_CUDA_API

TcuLaunchGridAsync

GLS_CUDA_API

TCullFaceMode

GLState

TCullingMode

SpatialPartitioning

TcuMemAlloc

GLS_CUDA_API

TcuMemAllocHost

GLS_CUDA_API

TcuMemAllocPitch

GLS_CUDA_API

TcuMemcpy2D

GLS_CUDA_API

TcuMemcpy2DAsync

GLS_CUDA_API

TcuMemcpy2DUnaligned

GLS_CUDA_API

TcuMemcpy3D

GLS_CUDA_API

TcuMemcpy3DAsync

GLS_CUDA_API

TcuMemcpyAtoA

GLS_CUDA_API

TcuMemcpyAtoD

GLS_CUDA_API

TcuMemcpyAtoH

GLS_CUDA_API

TcuMemcpyAtoHAsync

GLS_CUDA_API

TcuMemcpyDtoA

GLS_CUDA_API

TcuMemcpyDtoD

GLS_CUDA_API

TcuMemcpyDtoDAsync

GLS_CUDA_API

TcuMemcpyDtoH

GLS_CUDA_API

TcuMemcpyDtoHAsync

GLS_CUDA_API

TcuMemcpyHtoA

GLS_CUDA_API

TcuMemcpyHtoAAsync

GLS_CUDA_API

TcuMemcpyHtoD

GLS_CUDA_API

TcuMemcpyHtoDAsync

GLS_CUDA_API

TcuMemFree

GLS_CUDA_API

TcuMemFreeHost

GLS_CUDA_API

TcuMemGetAddressRange

GLS_CUDA_API

TcuMemGetInfo

GLS_CUDA_API

TcuMemHostAlloc

GLS_CUDA_API

TcuMemHostGetDevicePointer

GLS_CUDA_API

TcuMemHostGetFlags

GLS_CUDA_API

TCUmemorytype

GLS_CUDA_API

TcuMemsetD16

GLS_CUDA_API

TcuMemsetD2D16

GLS_CUDA_API

TcuMemsetD2D32

GLS_CUDA_API

TcuMemsetD2D8

GLS_CUDA_API

TcuMemsetD32

GLS_CUDA_API

TcuMemsetD8

GLS_CUDA_API

TCUmodule

GLS_CUDA_API

TcuModuleGetFunction

GLS_CUDA_API

TcuModuleGetGlobal

GLS_CUDA_API

TcuModuleGetTexRef

GLS_CUDA_API

TcuModuleLoad

GLS_CUDA_API

TcuModuleLoadData

GLS_CUDA_API

TcuModuleLoadDataEx

GLS_CUDA_API

TcuModuleLoadFatBinary

GLS_CUDA_API

TcuModuleUnload

GLS_CUDA_API

TcuParamSetf

GLS_CUDA_API

TcuParamSeti

GLS_CUDA_API

TcuParamSetSize

GLS_CUDA_API

TcuParamSetTexRef

GLS_CUDA_API

TcuParamSetv

GLS_CUDA_API

TCUresult

GLS_CUDA_API

TCustomCgShader

GLCgShader

TCustomZStream

GLSZLibEx

TCUstream

GLS_CUDA_API

TcuStreamCreate

GLS_CUDA_API

TcuStreamDestroy

GLS_CUDA_API

TcuStreamQuery

GLS_CUDA_API

TcuStreamSynchronize

GLS_CUDA_API

TCUtexref

GLS_CUDA_API

TcuTexRefCreate

GLS_CUDA_API

TcuTexRefDestroy

GLS_CUDA_API

TcuTexRefGetAddress

GLS_CUDA_API

TcuTexRefGetAddressMode

GLS_CUDA_API

TcuTexRefGetArray

GLS_CUDA_API

TcuTexRefGetFilterMode

GLS_CUDA_API

TcuTexRefGetFlags

GLS_CUDA_API

TcuTexRefGetFormat

GLS_CUDA_API

TcuTexRefSetAddress

GLS_CUDA_API

TcuTexRefSetAddress2D

GLS_CUDA_API

TcuTexRefSetAddressMode

GLS_CUDA_API

TcuTexRefSetArray

GLS_CUDA_API

TcuTexRefSetFilterMode

GLS_CUDA_API

TcuTexRefSetFlags

GLS_CUDA_API

TcuTexRefSetFormat

GLS_CUDA_API

TcuWGLGetDevice

GLS_CUDA_API

TCylinderAlignment

GLGeomObjects

TCylinderPart

GLGeomObjects

TCylinderParts

GLGeomObjects

Td3Axis

ODEImport

TD3DMatrix

VectorTypes

TD3DVector

VectorTypes

TdAABB

ODEImport

TdAABBTestFn

ODEImport

TdAngularMotorModeNumbers

ODEImport

TDatabase3DS

Types3DS

TDataFile

ApplicationFileIO

Abstract base class for data file formats interfaces.<p> This class declares base file-related behaviours, ie. ability to load/save from a file or a stream.<p> It is highly recommended to overload ONLY the stream based methods, as the file-based one just call these, and stream-based behaviours allow for more enhancement (such as other I/O abilities, compression, cacheing, etc.) to this class, without the need to rewrite subclasses.

TDataFileCapabilities

ApplicationFileIO

TDataFileCapability

ApplicationFileIO

TDataFileClass

ApplicationFileIO

TDBType3DS

Types3DS

TDCECollision

GLDCE

TDCECollisionEvent

GLDCE

TDCECollisionSelection

GLDCE

Indicates which type of layer comparison is made when trying to detect collisions between 2 bodies (A and B). Possible values are: <ul> <li>ccsDCEStandard: Collides bodies if A.layer <= B.layer <li>ccsCollisionStandard: Collides bodies if either A or B have layer equal to zero or if their layers are different. <li>ccsHybrid: Collides bodies if either one of the previous checks would pass (i.e. if the layer of either body is equal to 0 or if A.layer <= B.layer) *and* if both layers are positive (that is, turns off collision for bodies whose layer is < 0) </ul>

TDCEObjectCollisionEvent

GLDCE

TDCEShape

GLDCE

TDCESlideOrBounce

GLDCE

TdColliderFn

ODEImport

TdContact

ODEImport

TdContactGeom

ODEImport

TdContactType

ODEImport

TDCueSettings3DS

Types3DS

TDDPIXELFORMAT

DXTC

TDDSHeader

DXTC

TDDSImage

DDSImage

TDDSURFACEDESC2

DXTC

TDDS_HEADER_DXT10

DXTC

TDebugProc

OpenGLTokens

TDebugProcAMD

OpenGLTokens

TDelimiters

GLSMemo

TDelphiColor

GLCrossPlatform

TDepthFunction

GLState

TdErrorType

ODEImport

TDeSerializeEvent

GLNGDManager

TdGeomClass

ODEImport

TdGeomDtorFn

ODEImport

TdGeomSpaceData

ODEImport

TdGetAABBFn

ODEImport

TdGetColliderFnFn

ODEImport

TDim3

GLS_CUDA_API

TdInteger3

ODEImport

TdIntegerArray

ODEImport

TDirectRenderEvent

GLScene

Event for user-specific rendering in a TGLDirectOpenGL object.

TDirPlan

GeometryBB

TDisplayOptions

GLScreen

TDistanceCue

Types3DS

TdJointFeedback

ODEImport

TdJointGroupID

ODEImport

TdJointID

ODEImport

TdJointTypeNumbers

ODEImport

TDlInnerRange

Types3DS

TDlLocalShadow2

Types3DS

TDlMultiplier

Types3DS

TDlOuterRange

Types3DS

TDlRayBias

Types3DS

TDlSpotAspect

Types3DS

TDlSpotlight

Types3DS

TDlSpotRoll

Types3DS

TdMass

ODEImport

TdMatrix3

ODEImport

TdMatrix3_As3x4

ODEImport

TdMatrix4

ODEImport

TdMatrix6

ODEImport

TdMovedCallback

ODEImport

TdNearCallback

ODEImport

TdObject

ODEImport

TDoubleArray

Polynomials

TDoubleArrayList

VectorLists

TDoubleHmgPlane

VectorGeometry

TDoubleList

VectorLists

A list of Double.<p> Similar to TList, but using Double as items.<p> The list has stack-like push/pop methods.

TDoubleVector

VectorGeometry

TdQuaternion

ODEImport

TDRAWDIBTIME

GLSVfw

TDrawState

GLRenderContextInfo

TdReal

ODEImport

TdRealArray

ODEImport

TdRealHugeArray

ODEImport

TDstBlendFunction

GLState

TdSurfaceParameters

ODEImport

TdTriArrayCallback

ODEImport

TdTriCallback

ODEImport

TdTriRayCallback

ODEImport

TDumpLevel

Types3DS

TdVector3

ODEImport

TdVector3Array

ODEImport

TdVector4

ODEImport

Tdws2ClassesUnit

dws2Classes

Tdws2GLSceneUnit

dws2GLScene

Tdws2OpenGLUnit

dws2OpenGLAdapter

Tdws2VectorGeometryUnit

dws2VectorGeometry

TdxAutoDisable

ODEImport

TdxBody

ODEImport

TdxContactParameters

ODEImport

TdxDampingParameters

ODEImport

TDXFile

FileX

TDXFileHeader

FileX

TDXFrame

FileX

TdxGeom

ODEImport

TdxHashSpace

ODEImport

TdxHeightfieldData

ODEImport

TdxJoint

ODEImport

TdxJointAMotor

ODEImport

TdxJointBall

ODEImport

TdxJointFixed

ODEImport

TdxJointGroup

ODEImport

TdxJointHinge

ODEImport

TdxJointHinge2

ODEImport

TdxJointLimitMotor

ODEImport

TdxJointLimitMotor3

ODEImport

TdxJointLMotor

ODEImport

TdxJointNode

ODEImport

TdxJointNull

ODEImport

TdxJointPiston

ODEImport

TdxJointPlane2D

ODEImport

TdxJointPR

ODEImport

TdxJointSlider

ODEImport

TdxJointUniversial

ODEImport

TDXMaterial

FileX

TDXMaterialList

FileX

TDXMesh

FileX

TDXNode

FileX

TdxPosR

ODEImport

TdxQuadTreeSpace

ODEImport

TdxQuickStepParameters

ODEImport

TdxSimpleSpace

ODEImport

TdxSpace

ODEImport

TdxTriMeshData

ODEImport

TdxWorld

ODEImport

TEarthSkydomeOption

GLSkydome

TEarthSkydomeOptions

GLSkydome

TEaseType

AnimationUtils

TEaxBufferProperties

openal

TEaxListenerProperties

openal

TECCollider

GLEllipseCollision

TECColliderList

GLEllipseCollision

TECColliderShape

GLEllipseCollision

TECCollisionPacket

GLEllipseCollision

TECContact

GLEllipseCollision

TECContactList

GLEllipseCollision

TECFreeForm

GLEllipseCollision

TECFreeFormList

GLEllipseCollision

TECMovePack

GLEllipseCollision

TECObjectInfo

GLEllipseCollision

TECPlane

GLEllipseCollision

TECTriangle

GLEllipseCollision

TECTriMesh

GLEllipseCollision

TECTriMeshList

GLEllipseCollision

TEdge

GLVerletClothify

TEdgeDetector

GLVerletClothify

TEdgeList

GLVerletClothify

TEnumCallBack

PlugInIntf

TEnumResourceNames

PlugInIntf

TEulerOrder

VectorGeometry

TexPointArrayAdd

VectorGeometry

Adds delta to nb texpoints in src and places result in dest

TexPointArrayScaleAndAdd

VectorGeometry

TexPointCombine

VectorGeometry

Makes a linear combination of two texpoints

TexpointEquals

VectorGeometry

True if all components are equal.

TexPointLerp

VectorGeometry

Calculates linear interpolation between texpoint1 and texpoint2 at point t

TexPointMake

VectorGeometry

TExtended80Rec

PersistentClasses

TExtendedFrustum

SpatialPartitioning

TExtendedVector

VectorGeometry

TExtrusionSolidPart

GLExtrusion

TExtrusionSolidParts

GLExtrusion

TEX_ALPHA_SOURCE

Const3DS

TEX_DECAL

Const3DS

TEX_DONT_USE_ALPHA

Const3DS

TEX_INVERT

Const3DS

TEX_MIRROR

Const3DS

TEX_NOWRAP

Const3DS

TEX_RGB_TINT

Const3DS

TEX_SAT

Const3DS

TEX_TINT

Const3DS

TEX_UNUSED1

Const3DS

TEX_VERTS

Const3DS

TEX_VERTS_ENTRY

Const3DS

TF4

LWObjects

TF4Array

LWObjects

TF4DynArray

LWObjects

TFace

GLVerletClothify

Class that represents a face. This structure is not used for rendering, but for extracting info from meshes

TFace3DS

Types3DS

TFaceArray

Types3DS

TFaceCulling

GLMaterial

TFaceExtractor

GLVerletClothify

Class that extracts faces from a GLBaseMesh

TFaceGroup

GLVectorFileObjects

Describes a face group of a TMeshObject.<p> Face groups should be understood as "a way to use mesh data to render a part or the whole mesh object".<p> Subclasses implement the actual behaviours, and should have at least one "Add" method, taking in parameters all that is required to describe a single base facegroup element.

TFaceGroupConnectivity

GLBaseMeshSilhouette

TFaceGroupMeshMode

GLVectorFileObjects

Known descriptions for face group mesh modes.<p> - fgmmTriangles : issue all vertices with GL_TRIANGLES.<br> - fgmmTriangleStrip : issue all vertices with GL_TRIANGLE_STRIP.<br> - fgmmFlatTriangles : same as fgmmTriangles, but take advantage of having the same normal for all vertices of a triangle.<br> - fgmmTriangleFan : issue all vertices with GL_TRIANGLE_FAN.<br> - fgmmQuads : issue all vertices with GL_QUADS.

TFaceGroups

GLVectorFileObjects

A list of TFaceGroup objects.

TFaceList

Types3DS

TFaceList

GLVerletClothify

List of faces

TFaceWinding

GLState

Describe what kind of winding has a front face

TFallTrackTag

Types3DS

TFastCollisionChecker

GLCollision

TFColor3DS

Types3DS

TFColorList

Types3DS

TFeedBackMeshLaunching

GLSCUDAGraphics

TFeedBackMeshPrimitive

GLSCUDAGraphics

TFeedbackMode

GLFeedback

TFGBezierSurface

GLParametricSurfaces

A 3d bezier surface implemented through facegroups. The ControlPointIndices is an index to control points stored in the MeshObject.Vertices affine vector list. Similarly the TexCoordIndices point to the owner MeshObject.TexCoords, one for each control point. CountU and CountV define the width and height of the surface. Resolution sets the detail level of the mesh evaluation. MinU, MaxU, MinV and MaxV define the region of the surface to be rendered, this is especially useful for blending with neighbouring patches.

TFGBSPNode

GLBSP

TFGIndexTexCoordList

GLVectorFileObjects

Adds per index texture coordinates to its ancestor.<p> Per index texture coordinates allows having different texture coordinates per triangle, depending on the face it is used in.

TFGPolygon

GLPortal

A portal polygon.<p> This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.

TFGPortalPolygon

GLPortal

A portal polygon.<p> This is the base class for portal polygons, the TFGPortalPolygon class implements the portal.

TFGVertexIndexList

GLVectorFileObjects

A face group based on an indexlist.<p> The index list refers to items in the mesh object (vertices, normals, etc.), that are all considered in sync, the render is obtained issueing the items in the order given by the vertices.<p>

TFGVertexNormalTexIndexList

GLVectorFileObjects

Adds normals and texcoords indices.<p> Allows very compact description of a mesh. The Normals ad TexCoords indices are optionnal, if missing (empty), VertexIndices will be used.

TFile

LIBPNG

TFile3DS

File3DS

TFileB3D

FileB3D

TFileGLA

FileGL2

TFileGLM

FileGL2

TFileMD2

FileMD2

TFileMD3

FileMD3

TFileNMF

FileNMF

TFileSection

GLFilePAK

TFileSection

GLFileZLIB

TFileSection

GLVfsPAK

TFilterType3DS

Types3DS

TFindCuFileFunc

GLSCUDACompiler

TFinishTaskEvent

GLContext

TFireParticle

GLFireFX

TFireParticleArray

GLFireFX

TFlareElement

GLLensFlare

TFlareElements

GLLensFlare

TFloatPercentage

Types3DS

TFloatVector

VectorGeometry

TFMetaDataCallback

fmodtypes

TFModErrors

fmodtypes

TFMusicCallback

fmodtypes

TFMusicTypes

fmodtypes

TFog

Types3DS

TFogDistance

GLScene

Fog distance calculation mode.<p> <ul> <li>fdDefault: let OpenGL use its default formula <li>fdEyeRadial: uses radial "true" distance (best quality) <li>fdEyePlane: uses the distance to the projection plane (same as Z-Buffer, faster) </ul>Requires support of GL_NV_fog_distance extension, otherwise, it is ignored.

TFogMode

GLScene

TFogSettings3DS

Types3DS

TFontEntry

GLSpaceText

TFontManager

GLSpaceText

TFOURCC

DXTC

TFovTrackTag

Types3DS

TFree

LIBPNG

TFrustrumPart

GLGeomObjects

TFrustrumParts

GLGeomObjects

TFrustum

VectorGeometry

TFSoundAllocCallback

fmodtypes

TFSoundCloseCallback

fmodtypes

TFSoundDSPCallback

fmodtypes

TFSoundFreeCallback

fmodtypes

TFSoundFXModes

fmodtypes

TFSoundMixerTypes

fmodtypes

TFSoundOpenCallback

fmodtypes

TFSoundOutputTypes

fmodtypes

TFSoundReadCallback

fmodtypes

TFSoundReallocCallback

fmodtypes

TFSoundReverbChannelProperties

fmodtypes

TFSoundReverbProperties

fmodtypes

TFSoundSeekCallback

fmodtypes

TFSoundSpeakerModes

fmodtypes

TFSoundStreamCallback

fmodtypes

TFSoundStreamNetStatus

fmodtypes

TFSoundTagFieldType

fmodtypes

TFSoundTellCallback

fmodtypes

TFSoundTOCTag

fmodtypes

TFSoundVector

fmodtypes

TFullPos

GLSMemo

TFXPointerList

GLParticleFX

TGeomList

ODEImport

TGetDescription

PlugInIntf

TGetLineAttrsEvent

GLSMemo

TGetServices

PlugInIntf

TGetTerrainBoundsEvent

GLTerrainRenderer

TGetVendor

PlugInIntf

TGetVersion

PlugInIntf

TGL1DPerlin

GLPerlin

TGL2DPerlin

GLPerlin

TGL2DPerlinOctav

GLPerlin

TGL3DSVectorFile

GLFile3DS

The 3DStudio vector file.<p> Uses an upgraded version if a 3DS import library by Mike Lischke.<p> (http://www.lishcke-online.de). A 3DS file may contain material information and require textures when loading.

TGLABone

FileGL2

TGLAbsoluteHUDText

GLHUDObjects

TGLAbstractLibMaterial

GLMaterial

TGLAbstractLibMaterials

GLMaterial

TGLAbstractMaterialLibrary

GLMaterial

TGLAbstractMemoObject

GLSMemo

TGLAbstractShaderUniform

GLMaterialEx

TGLAbstractTexture

GLMaterialEx

TGLAcceptMouseQuery

GLWindows

TGLACompQuatBone

FileGL2

TGLActiveAttrib

GLSLShader

TGLActiveAttribArray

GLSLShader

TGLActor

GLVectorFileObjects

Mesh class specialized in animated meshes.<p> The TGLActor provides a quick interface to animated meshes based on morph or skeleton frames, it is capable of performing frame interpolation and animation blending (via TGLAnimationControler components).

TGLActorOption

GLVectorFileObjects

Miscellanious actor options.<p> <ul> <li>aoSkeletonNormalizeNormals : if set the normals of a skeleton-animated mesh will be normalized, this is not required if no normals-based texture coordinates generation occurs, and thus may be unset to improve performance. </ul>

TGLActorOptions

GLVectorFileObjects

TGLActorProxy

GLProxyObjects

A proxy object specialized for Actors.<p>

TGLActorProxyAnimationMode

GLProxyObjects

TGLAdvancedBlurImagePrepareEvent

GLBlur

TGLAdvancedLabel

GLWindows

TGLAHeader

FileGL2

TGlAlphaFunc

GLMaterial

TGLAnimatedSprite

GLAnimatedSprite

An animated version of the TGLSprite using offset texture coordinate animation.

TGLAnimationControler

GLVectorFileObjects

Controls the blending of an additionnal skeletal animation into an actor.<p> The animation controler allows animating an actor with several animations at a time, for instance, you could use a "run" animation as base animation (in TGLActor), blend an animation that makes the arms move differently depending on what the actor is carrying, along with an animation that will make the head turn toward a target.

TGLAnimationNameProperty

GLSceneRegister

TGLAnnulus

GLGeomObjects

TGLAntiAliasing

GLContext

TGLARBFragmentProgramHandle

GLContext

TGLARBGeometryProgramHandle

GLContext

TGLARBProgramHandle

GLContext

TGLARBVertexProgramHandle

GLContext

TGLArrowArc

GLGeomObjects

TGLArrowLine

GLGeomObjects

TGLASEFace

GLFileASE

TGLASEFaceList

GLFileASE

TGLASEFaceTexure

GLFileASE

TGLASEFaceTexureChannels

GLFileASE

TGLASEMaterial

GLFileASE

TGLASEMaterialList

GLFileASE

TGLASEMaterialTextureMap

GLFileASE

TGLASEMaterialTextureMaps

GLFileASE

TGLASEMeshObject

GLFileASE

TGLASESmoothingGroups

GLFileASE

TGLASESubMaterial

GLFileASE

TGLASESubMaterialList

GLFileASE

TGLASEVectorFile

GLFileASE

TGLASkeleton

FileGL2

TGLASkeletonOffsets

FileGL2

TGLAsmShader

GLAsmShader

TGLAsmShaderEvent

GLAsmShader

TGLAsmShaderParameter

GLAsmShader

TGLAsmShaderUnUplyEvent

GLAsmShader

TGLASMVertexProgram

GLMaterialEx

TGLAsyncHDS

GLAsyncHDS

TGLAsyncHDThread

GLAsyncHDS

TGLAtmosphere

GLAtmosphere

TGLAtmosphereBlendingMode

GLAtmosphere

With aabmOneMinusSrcAlpha atmosphere is transparent to other objects, but has problems, which are best seen when the Atmosphere radius is big.
With bmOneMinusDstColor atmosphere doesn't have these problems, but offers limited transparency (when you look closely on the side).

TGLB3DVectorFile

GLFileB3D

TGLBAcceleration

GLBehaviours

Applies a constant acceleration to a TGLBInertia.<p>

TGLBaseAnimationControler

GLVectorFileObjects

Base class for skeletal animation control.<p>

TGLBaseBehaviour

GLScene

Base class for implementing behaviours in TGLScene.<p> Behaviours are regrouped in a collection attached to a TGLBaseSceneObject, and are part of the "Progress" chain of events. Behaviours allows clean application of time-based alterations to objects (movements, shape or texture changes...).<p> Since behaviours are implemented as classes, there are basicly two kinds of strategies for subclasses :<ul> <li>stand-alone : the subclass does it all, and holds all necessary data (covers animation, inertia etc.) <li>proxy : the subclass is an interface to and external, shared operator (like gravity, force-field effects etc.) </ul><br> Some behaviours may be cooperative (like force-fields affects inertia) or unique (e.g. only one inertia behaviour per object).<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function </ul>

TGLBaseComponent

GLWindows

TGLBaseControl

GLWindows

TGLBaseCustomGLSLBumpShader

GLSLBumpShader

TGLBaseCustomGLSLBumpShaderMT

GLSLBumpShader

TGLBaseCustomGLSLDiffuseSpecular

GLSLDiffuseSpecularShader

Abstract class.

TGLBaseFontControl

GLWindows

TGLBaseGLSLDiffuseSpecularShaderMT

GLSLDiffuseSpecularShader

Abstract class.

TGLBaseGuiObject

GLGui

TGLBaseImage

GLGraphics

TGLBaseImageClass

GLGraphics

TGLBaseMaterialCollectionItem

GLMaterialEx

TGLBaseMesh

GLVectorFileObjects

Base class for mesh objects.

TGLBaseMeshConnectivity

GLBaseMeshSilhouette

TGLBasePerlin

GLPerlin

TGLBasePerlinOctav

GLPerlin

TGLBaseSceneObject

GLScene

Base class for all scene objects.<p> A scene object is part of scene hierarchy (each scene object can have multiple children), this hierarchy primarily defines transformations (each child coordinates are relative to its parent), but is also used for depth-sorting, bounding and visibility culling purposes.<p> Subclasses implement either visual scene objects (that are made to be visible at runtime, like a Cube) or structural objects (that influence rendering or are used for varied structural manipulations, like the ProxyObject).<p> To add children at runtime, use the AddNewChild method of TGLBaseSceneObject; other children manipulations methods and properties are provided (to browse, move and delete them). Using the regular TComponent methods is not encouraged.

TGLBaseSelectTechnique

GLSelection

TGLBaseSelectTechniqueClass

GLSelection

TGLBaseShaderModel

GLMaterialEx

TGLBaseSoundSource

GLSound

Base class for origin of sound playback.

TGLBaseSpritePFXManager

GLParticleFX

Base class for sprite-based particles FX managers.<p> The particles are made of optionally centered single-textured quads.

TGLBaseTextControl

GLWindows

TGLBCollision

GLCollision

Collision detection behaviour.<p> Allows an object to register to a TCollisionManager and be accounted for in collision-detection and distance calculation mechanisms.<p> An object may have multiple TGLBCollision, registered to multiple collision managers, however if multiple behaviours share the same manager, only one of them will be accounted for, others will be ignored.

TGLBehaviour

GLScene

Ancestor for non-rendering behaviours.<p> This class shall never receive any properties, it's just here to differentiate rendereing and non-rendering behaviours. Rendereing behaviours are named "TGLObjectEffect", non-rendering effects (like inertia) are simply named "TGLBehaviour".

TGLBehaviourClass

GLScene

TGLBehaviours

GLScene

Holds a list of TGLBehaviour objects.<p> This object expects itself to be owned by a TGLBaseSceneObject.<p> As a TXCollection (and contrary to a TCollection), this list can contain objects of varying class, the only constraint being that they should all be TGLBehaviour subclasses.

TGLBExplosionFX

GLExplosionFx

TGLBFireFX

GLFireFX

Fire special effect.<p> This effect works as a client of TFireFXManager

TGLBFPSMovement

GLFPSMovement

TGLBInertia

GLBehaviours

Simple translation and rotation Inertia behaviour.<p> Stores translation and rotation speeds, to which you can apply accelerations.<p> Note that the rotation model is not physical, so feel free to contribute a "realworld" inertia class with realistic, axis-free, rotation inertia if this approximation does not suits your needs :).

TGLbitfield

OpenGLTokens

TGLBitmap

GLCrossPlatform

TGLBitmap32

GLGraphics

TGLBitmapFont

GLBitmapFont

See TGLCustomBitmapFont.<p> This class only publuishes some of the properties.

TGLBitmapHDS

GLHeightData

TGLBlankImage

GLTexture

A texture image with no specified content, only a size.<p> This texture image type is of use if the context of your texture is calculated at run-time (with a TGLMemoryViewer for instance).

TGLBlankTIE

GLTextureImageEditors

TGLBlendingModeEx

GLCustomShader

Adds two more blending modes to standard ones. Not sure how to name them or if they should be included in TBlending mode, so I created a new type here.

TGLBlendingParameters

GLMaterial

TGLBlur

GLBlur

TGLBlurkind

GLBlur

TGLBlurPreset

GLBlur

TGLBMPImage

GLFileBMP

TGLboolean

OpenGLTokens

TGLBooleanOcclusionQueryHandle

GLContext

TGLBox

GLTypes

TGLBSoundEmitter

GLSound

A sound emitter behaviour, plug it on any object to make it noisy.<p> This behaviour is just an interface to a TGLSoundSource, for editing convenience.

TGLBThorFX

GLThorFX

TGLBufferBindingTarget

GLState

TGLBufferObjectHandle

GLContext

Manages a handle to a Buffer Object.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.<br>

TGLBumpmapHDS

GLBumpmapHDS

An Height Data Source that generates elevation bumpmaps automatically.<p> The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where bumpmaps will be placed.

TGLBumpShader

GLBumpShader

A generic bump shader.<p>

TGLButton

GLWindows

TGLbyte

OpenGLTokens

TGLCadenceAbleComponent

BaseClasses

A base class describing the "cadenceing" interface.<p>

TGLCadencedComponent

GLCadencer

TGLCadencer

GLCadencer

This component allows auto-progression of animation.<p> Basicly dropping this component and linking it to your TGLScene will send it real-time progression events (time will be measured in seconds) while keeping the CPU 100% busy if possible (ie. if things change in your scene).<p> The progression time (the one you'll see in you progression events) is calculated using (CurrentTime-OriginTime)*TimeMultiplier, CurrentTime being either manually or automatically updated using TimeReference (setting CurrentTime does NOT trigger progression).

TGLCadencerMode

GLCadencer

Determines how the TGLCadencer operates.<p> - cmManual : you must trigger progress manually (in your code)<br> - cmASAP : progress is triggered As Soon As Possible after a previous progress (uses windows messages). - cmApplicationIdle : will hook Application.OnIdle, this will overwrite any previous event handle, and only one cadencer may be in this mode.

TGLCadencerTimeReference

GLCadencer

Determines which time reference the TGLCadencer should use.<p> - cmRTC : the Real Time Clock is used (precise over long periods, but not accurate to the millisecond, may limit your effective framerate to less than 50 FPS on some systems)<br> - cmPerformanceCounter : the windows performance counter is used (nice precision, may derive over long periods, this is the default option as it allows the smoothest animation on fast systems)<br> - cmExternal : the CurrentTime property is used

TGLCall

GLPipelineTransformation

TGLCamera

GLScene

Camera object.<p> This object is commonly referred by TGLSceneViewer and defines a position, direction, focal length, depth of view... all the properties needed for defining a point of view and optical characteristics.

TGLCameraController

GLCameraController

TGLCameraInvarianceMode

GLScene

TGLCameraInvariantObject

GLScene

Base class for camera invariant objects.<p> Camera invariant objects bypass camera settings, such as camera position (object is always centered on camera) or camera orientation (object always has same orientation as camera).

TGLCameraJob

GLCameraController

TGLCameraJobEvent

GLCameraController

TGLCameraJobList

GLCameraController

TGLCameraKeepFOVMode

GLScene

TGLCameraStyle

GLScene

TGLCanvas

GLCanvas

A simple Canvas-like interface for OpenGL.<p> This class implements a small "shell" for 2D operations in OpenGL, it operates over the current OpenGL context and provides methods for drawing lines, ellipses and points.<br> This class is typically used by creating an instance, using it for drawing, and freeing the instance. When drawing (0, 0) is the top left corner.<br> All coordinates are internally maintained with floating point precision.<p> Several states are cached and it is of primary importance not to invoke OpenGL directly throughout the life of an instance (at the cost of unespected behaviour).

TGLCapsule

GLGeomObjects

TGLCelShader

GLCelShader

A generic cel shader.<p>

TGLCelShaderGetIntensity

GLCelShader

An event for user defined cel intensity.

TGLCelShaderOption

GLCelShader

Cel shading options.<p> csoOutlines: Render a second outline pass. csoTextured: Allows for a primary texture that the cel shading is modulated with and forces the shade definition to render as a second texture.

TGLCelShaderOptions

GLCelShader

TGLCgBombShader

GLCgBombShader

TGLCgBombShaderTextureSource

GLCgBombShader

TGLCGPostTransformationShader

CGPostTransformationShader

TGLCheckBox

GLWindows

TGLclampd

OpenGLTokens

TGLclampf

OpenGLTokens

TGLColor

GLColor

Wraps an OpenGL color.

TGLColorDepth

GLScene

TGLColorManager

GLColor

TGLColorProperty

GLSceneRegister

TGLColorProxy

GLProxyObjects

A proxy object with its own color.<p> This proxy object can have a unique color. Note that multi-material objects (Freeforms linked to a material library f.i.) won't honour the color.

TGLComponent

GLCrossPlatform

TGLCompositeImage

GLCompositeImage

TGLCone

GLGeomObjects

TGLConsole

GLConsole

TGLConsoleCommand

GLConsole

TGLConsoleCommandList

GLConsole

TGLConsoleControls

GLConsole

TGLConsoleMatchList

GLConsole

TGLConsoleOption

GLConsole

TGLConsoleOptions

GLConsole

TGLConsoleStringList

GLConsole

TGLContext

GLContext

Wrapper around an OpenGL rendering context.<p> The aim of this class is to offer platform-independant initialization, activation and management of OpenGL rendering context. The class also offers notifications event and error/problems detection.<br> This is a virtual abstract a class, and platform-specific subclasses must be used.<br> All rendering context share the same lists.

TGLContextAcceleration

GLContext

TGLContextClass

GLContext

TGLContextHandle

GLContext

Wrapper around an OpenGL context handle.<p> This wrapper also takes care of context registrations and data releases related to context releases an cleanups. This is an abstract class, use the TGLListHandle and TGLTextureHandle subclasses.

TGLContextLayer

GLContext

TGLContextManager

GLContext

Stores and manages all the TGLContext objects.<p>

TGLContextNotification

GLContext

TGLContour

GLMultiPolygon

TGLContourClass

GLMultiPolygon

TGLContourNodes

GLMultiPolygon

TGLContours

GLMultiPolygon

TGLCoordinates

GLCoordinates

TGLCoordinates2

GLCoordinates

TGLCoordinates3

GLCoordinates

TGLCoordinates4

GLCoordinates

TGLCoordinatesProperty

GLSceneRegister

TGLCoordinatesStyle

GLCoordinates

TGLCoordinatesUpdateAbleComponent

GLCoordinates

TGLCube

GLObjects

TGLCubeMapImage

GLTexture

A texture image used for specifying and stroing a cube map.<p> Not unlike TGLPictureImage, but storing 6 of them instead of just one.<br> Saving & loading as a whole currently not supported.

TGLCubeMapTarget

GLTexture

TGLCustomAsmShader

GLAsmShader

TGLCustomAtmosphere

GLAtmosphere

This class imitates an atmosphere around a planet.

TGLCustomBitmapFont

GLBitmapFont

Provides access to individual characters in a BitmapFont.<p> Only fixed-width bitmap fonts are supported, the characters are enumerated in a raster fashion (line then column).<br> Transparency is all or nothing, the transparent color being that of the top left pixel of the Glyphs bitmap.<p> Performance note: as usual, for best performance, you base font bitmap dimensions should be close to a power of two, and have at least 1 pixel spacing between characters (horizontally and vertically) to avoid artefacts when rendering with linear filtering.

TGLCustomCadencedComponent

GLCadencer

Adds a property to connect/subscribe to a cadencer.<p>

TGLCustomCGBombShader

GLCgBombShader

Just a good-looking shader.

TGLCustomCGPostTransformationShader

CGPostTransformationShader

TGLCustomConsole

GLConsole

TGLCustomConsole

TGLCustomControl

GLWindows

TGLCustomCoordinates

GLCoordinates

TGLCustomFeedBackMesh

GLSCUDAGraphics

TGLCustomGLSLBumpShader

GLSLBumpShader

TGLCustomGLSLBumpShaderAM

GLSLBumpShader

TGLCustomGLSLBumpShaderMT

GLSLBumpShader

TGLCustomGLSLDiffuseSpecularShader

GLSLDiffuseSpecularShader

TGLCustomGLSLDiffuseSpecularShaderAM

GLSLDiffuseSpecularShader

TGLCustomGLSLDiffuseSpecularShaderMT

GLSLDiffuseSpecularShader

TGLCustomGLSLMLBumpShader

GLSLBumpShader

TGLCustomGLSLMLBumpShaderMT

GLSLBumpShader

TGLCustomGLSLMLDiffuseSpecularShader

GLSLDiffuseSpecularShader

Note: probably LightCount should be replaced by LightSources, like in GLSLBumpShader.pas

TGLCustomGLSLMLDiffuseSpecularShaderMT

GLSLDiffuseSpecularShader

TGLCustomGLSLPostBlurShader

GLSLPostBlurShader

TGLCustomGLSLShader

GLSLShader

TGLCustomHDS

GLHeightData

TGLCustomPFXManager

GLParticleFX

A particles FX manager offering events for customization/experimentation.<p> This manager essentially surfaces the PFX methods as events, and is best suited when you have specific particles that don't fall into any existing category, or when you want to experiment with particles and later plan to wrap things up in a full-blown manager.<br> If the events aren't handled, nothing will be rendered.

TGLCustomRenderEvent

GLWindows

TGLCustomSceneObject

GLScene

Extended base scene object class with a material property.<p> The material allows defining a color and texture for the object, see TGLMaterial.

TGLCustomShader

GLCustomShader

A pure abstract class, must be overriden.

TGLCustomShaderCombiner

GLShaderCombiner

TGLCustomShaderParameter

GLCustomShader

Wrapper around a parameter of the main program.

TGLCustomSpritePFXManager

GLParticleFX

A sprite-based particles FX managers using user-specified code to prepare the texture.<p>

TGLCylinder

GLGeomObjects

TGLCylinderBase

GLGeomObjects

TGLDamping

GLBehaviours

Holds parameters for TGLScene basic damping model.<p> Damping is modeled by calculating a force from the speed, this force can then be transformed to an acceleration is you know the object's mass.<br> Formulas :<ul> <li>damping = constant + linear * Speed + quadratic * Speedˆ2 <li>accel = damping / Mass </ul> That's just basic physics :). A note on the components :<ul> <li>constant : use it for solid friction (will stop abruptly an object after decreasing its speed. <li>linear : linear friction damping. <li>quadratic : expresses viscosity. </ul>

TGLDCEDynamic

GLDCE

TGLDCEManager

GLDCE

TGLDCEStatic

GLDCE

TGLDDSDetailLevels

GLFileDDS

TGLDDSImage

GLFileDDS

TGLDEBUGPROCARB

OpenGLTokens

TGLDelphiWebScriptII

GLScriptDWS2

This class only adds manager registration logic to the TDelphiWebScriptII class to enable the XCollection items (ie. TGLScriptDWS2) retain it's assigned compiler from design to run -time.

TGLDepthCompareFunc

GLTexture

TGLDepthPrecision

GLScene

TGLDepthProperties

GLMaterial

TGLDepthRBO

GLFBO

TGLDepthTextureMode

GLTexture

TGLDirectOpenGL

GLScene

Provides a way to issue direct OpenGL calls during the rendering.<p> You can use this object to do your specific rendering task in its OnRender event. The OpenGL calls shall restore the OpenGL states they found when entering, or exclusively use the GLMisc utility functions to alter the states.<br>

TGLDisk

GLGeomObjects

TGLDodecahedron

GLPolyhedron

A Dodecahedron.<p> The dodecahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

TGLdouble

OpenGLTokens

TGLDummyCube

GLObjects

TGLDWS2ActiveBehaviour

GLDWS2Objects

TGLDynamicImposterBuilder

GLImposter

TGLDynamicPFXManager

GLParticleFX

An abstract PFX manager for simple dynamic particles.<p> Adds properties and progress implementation for handling moving particles (simple velocity and const acceleration integration).

TGLDynamicTextureImage

GLDynamicTexture

Allows for fast updating of the texture at runtime.

TGLEarthSkyDome

GLSkydome

Render a skydome like what can be seen on earth.<p> Color is based on sun position and turbidity, to "mimic" atmospheric Rayleigh and Mie scatterings. The colors can be adjusted to render weird/extra-terrestrial atmospheres too.<p> The default slices/stacks values make for an average quality rendering, for a very clean rendering, use 64/64 (more is overkill in most cases). The complexity is quite high though, making a T&L 3D board a necessity for using TGLEarthSkyDome.

TGLEdit

GLWindows

TGLEnabledRenderBuffer

GLFBORenderer

TGLEnabledRenderBuffers

GLFBORenderer

TGLenum

OpenGLTokens

TGLEParticleMask

GLEParticleMasksManager

TGLEParticleMasks

GLEParticleMasksManager

TGLEParticleMasksManager

GLEParticleMasksManager

TGLEProjectedParticleMask

GLEParticleMasksManager

TGLExtensionsAndEntryPoints

OpenGLAdapter

TGLExtrusionSolid

GLExtrusion

TGLFaceProperties

GLMaterial

Stores basic face lighting properties.<p> The lighting is described with the standard ambient/diffuse/emission/specular properties that behave like those of most rendering tools.<br> You also have control over shininess (governs specular lighting) and polygon mode (lines / fill).

TGLFBOClearOption

GLFBORenderer

TGLFBOClearOptions

GLFBORenderer

TGLFBORenderer

GLFBORenderer

TGLFBOTargetVisibility

GLFBORenderer

TGLFeedback

GLFeedback

An object encapsulating the OpenGL feedback rendering mode.

TGLFeedBackMesh

GLSCUDAGraphics

TGLFile3DSActor

GLFile3DSSceneObjects

TGLFile3DSAnimationData

GLFile3DS

TGLFile3DSAnimationData. A record that holds all the information that is used during 3ds animation.

TGLFile3DSAnimationKeyList

GLFile3DS

TGLFile3DSAnimationKeys

GLFile3DS

TGLFile3DSAnimationKeys.
An abstract class that describes how to interpolate animation keys.

TGLFile3DSAnimKeysClassType

GLFile3DS

Used only for serialization. There probably is a more efficient way to do it.

TGLFile3DSCamera

GLFile3DSSceneObjects

TGLFile3DSCameraObject

GLFile3DS

TGLFile3DSCameraObject. A 3ds-specific camera.

TGLFile3DSColorAnimationKeys

GLFile3DS

TGLFile3DSDummyObject

GLFile3DS

TGLFile3DSDummyObject. A 3ds-specific TMorphableMeshObject.

TGLFile3DSFreeForm

GLFile3DSSceneObjects

TGLFile3DSLight

GLFile3DSSceneObjects

TGLFile3DSLightHotSpotAnimationKeys

GLFile3DS

TGLFile3DSMeshObject

GLFile3DS

TGLFile3DSDummyObject. A 3ds-specific mesh object.

TGLFile3DSOmniLightObject

GLFile3DS

TGLFile3DSDummyObject. A 3ds-specific omni light.

TGLFile3DSPositionAnimationKeys

GLFile3DS

TGLFile3DSRollAnimationKeys

GLFile3DS

TGLFile3DSRotationAnimationKeys

GLFile3DS

TGLFile3DSScaleAnimationKeys

GLFile3DS

TGLFile3DSSpotLightCutOffAnimationKeys

GLFile3DS

TGLFile3DSSpotLightObject

GLFile3DS

TGLFile3DSSpotLightObject. A 3ds-specific spot light.

TGLFireFXManager

GLFireFX

Fire special effect manager.<p> Defines the looks and behaviour of a particle system that can be made to look fire-like.

TGLFixedFunctionProperties

GLMaterialEx

TGLFlareGradient

GLLensFlare

The actual gradients between two colors are, of course, calculated by OpenGL.<p> The start and end colors of a gradient are stored to represent the color of lens flare elements.

TGLFlatText

GLBitmapFont

A 2D text displayed and positionned in 3D coordinates.<p> The FlatText uses a character font defined and stored by a TGLBitmapFont component. Default character scale is 1 font pixel = 1 space unit.

TGLFlatTextOption

GLBitmapFont

TGLFlatTextOptions

GLBitmapFont

TGLfloat

OpenGLTokens

TGLFocusControl

GLWindows

TGLFogEnvironment

GLScene

Parameters for fog environment in a scene.<p> The fog descibed by this object is a distance-based fog, ie. the "intensity" of the fog is given by a formula depending solely on the distance, this intensity is used for blending to a fixed color.

TGLForm

GLWindows

TGLFormCanClose

GLWindows

TGLFormCanRequest

GLWindows

TGLFormCloseOptions

GLWindows

TGLFormMove

GLWindows

TGLFormNotify

GLWindows

TGLFPSMovementManager

GLFPSMovement

TGLFragmentProgram

GLCustomShader

TGLFragmentShaderHandle

GLContext

Manages a handle to a Fragment Shader Object.

TGLFrameBuffer

GLFBO

TGLFrameBufferAttachment

GLMaterialEx

TGLFramebufferHandle

GLContext

Manages a handle to a Framebuffer Object (FBO). Framebuffer objects provide a way of drawing to rendering destinations other than the buffers provided to the GL by the window-system. One or more "framebuffer-attachable images" can be attached to a Framebuffer for uses such as: offscreen rendering, "render to texture" + "multiple render targets" (MRT). There are several types of framebuffer-attachable images: - The image of a renderbuffer object, which is always 2D. - A single level of a 1D texture, which is treated as a 2D image with a height of one. - A single level of a 2D or rectangle texture. - A single face of a cube map texture level, which is treated as a 2D image. - A single layer of a 1D or 2D array texture or 3D texture, which is treated as a 2D image. Additionally, an entire level of a 3D texture, cube map texture, or 1D or 2D array texture can be attached to an attachment point. Such attachments are treated as an array of 2D images, arranged in layers, and the corresponding attachment point is considered to be layered.

TGLFramebufferStatus

GLContext

TGLFreeForm

GLVectorFileObjects

Container objects for a vector file mesh.<p> FreeForms allows loading and rendering vector files (like 3DStudio ".3DS" file) in GLScene. Meshes can be loaded with the LoadFromFile method.<p> A FreeForm may contain more than one mesh, but they will all be handled as a single object in a scene.

TGLFreeFormProxy

GLProxyObjects

A proxy object specialized for FreeForms.<p>

TGLFrustrum

GLGeomObjects

TGLFullScreenResolution

GLSceneForm

Defines how GLSceneForm will handle fullscreen request fcWindowMaximize: Use current resolution (just maximize form and hide OS bars) fcNearestResolution: Change to nearest valid resolution from current window size fcManualResolution: Use FFullScreenVideoMode settings

TGLFullScreenVideoMode

GLSceneForm

Screen mode settings

TGLFullScreenViewer

GLFullScreenViewer

TGLGameMenu

GLGameMenu

Classic game menu interface made of several lines.<p>

TGLGameMenuScale

GLGameMenu

TGLGeometryProgram

GLCustomShader

TGLGeometryShaderHandle

GLContext

Manages a handle to a Geometry Shader Object.

TGLGizmo

GLGizmo

TGLGizmoAcceptEvent

GLGizmo

TGLGizmoAxis

GLGizmo

TGLGizmoElement

GLGizmo

TGLGizmoElements

GLGizmo

TGLGizmoEx

GLGizmoEx

TGLGizmoExAcceptEvent

GLGizmoEx

TGLGizmoExActionHistoryCollection

GLGizmoEx

TGLGizmoExActionHistoryItem

GLGizmoEx

TGLGizmoExAxis

GLGizmoEx

TGLGizmoExAxisSelected

GLGizmoEx

TGLGizmoExObjectCollection

GLGizmoEx

TGLGizmoExObjectItem

GLGizmoEx

TGLGizmoExOperation

GLGizmoEx

TGLGizmoExOperationMode

GLGizmoEx

TGLGizmoExPickMode

GLGizmoEx

TGLGizmoExReferenceCoordinateSystem

GLGizmoEx

TGLGizmoExSelectionRegion

GLGizmoEx

TGLGizmoExSelRec

GLGizmoEx

TGLGizmoExUIArrowLine

GLGizmoEx

TGLGizmoExUIDisk

GLGizmoEx

TGLGizmoExUIFlatText

GLGizmoEx

TGLGizmoExUIFrustrum

GLGizmoEx

TGLGizmoExUILines

GLGizmoEx

TGLGizmoExUIPolygon

GLGizmoEx

TGLGizmoExUISphere

GLGizmoEx

TGLGizmoExUITorus

GLGizmoEx

TGLGizmoExVisibleInfoLabel

GLGizmoEx

TGLGizmoExVisibleInfoLabels

GLGizmoEx

TGLGizmoOperation

GLGizmo

TGLGizmoPickCube

GLGizmo

TGLGizmoPickMode

GLGizmo

TGLGizmoPickTorus

GLGizmo

TGLGizmoRayCastHitData

GLGizmo

TGLGizmoUndoCollection

GLGizmo

TGLGizmoUndoItem

GLGizmo

TGLGizmoUpdateEvent

GLGizmo

TGLGizmoVisibleInfoLabel

GLGizmo

TGLGizmoVisibleInfoLabels

GLGizmo

TGLGLAVectorFile

GLFileGL2

TGLGLMVectorFile

GLFileGL2

TGLGLSMVectorFile

GLVectorFileObjects

GLSM (GLScene Mesh) vector file.<p> This corresponds to the 'native' GLScene format, and object persistence stream, which should be the 'fastest' of all formats to load, and supports all of GLScene features.

TGLGraphic

GLCrossPlatform

TGLgsInTypes

GLSLParameter

TGLgsOutTypes

GLSLParameter

TGLGTSVectorFile

GLFileGTS

The GTS vector file (GNU Triangulated Surface library).<p> It is a simple text format, with indexed vertices. The first line contains the number of vertices, the number of edges and the number of faces separated by spaces.<br> Following lines contain the x/y/z coordinates of vertices, then the edges (two indices) and the faces (three indices).<br> http://gts.sourceforge.net/

TGLGuiComponent

GLGui

TGLGuiComponentList

GLGui

TGLGuiComponentName

GLGui

TGLGuiElement

GLGui

TGLGuiElementList

GLGui

TGLGuiElementName

GLGui

TGLGuiLayout

GLGui

TGLGUILayoutEditor

GLSceneRegister

TGLHDRImage

GLFileHDR

TGLHeightField

GLGraph

TGLHeightTileFileHDS

GLHeightTileFileHDS

An Height Data Source for the HTF format.<p>

TGLHiddenLineShader

GLHiddenLineShader

TGLHUDSprite

GLHUDObjects

TGLHUDText

GLHUDObjects

TGLIcosahedron

GLPolyhedron

A Icosahedron.<p> The icosahedron has no texture coordinates defined, ie. without using a texture generation mode, no texture will be mapped.

TGLImage

GLGraphics

Contains and manipulates a 32 bits (24+8) bitmap.<p> This is the base class for preparing and manipulating textures in GLScene, this function does not rely on a windows handle and should be used for in-memory manipulations only.<br> 16 bits textures are automatically converted to 24 bits and an opaque (255) alpha channel is assumed for all planes, the byte order is as specified in GL_RGBA. If 32 bits is used in this class, it can however output 16 bits texture data for use in OpenGL.<p> The class has support for registering its content as a texture, as well as for directly drawing/reading from the current OpenGL buffer.

TGLImageClassProperty

GLSceneRegister

TGLImageDataFormat

DXTC

TGLImageLevelDesc

GLGraphics

TGLImageLODRange

GLGraphics

TGLImagePiramid

GLGraphics

TGLImmaterialSceneObject

GLScene

Base class for objects that do not have a published "material".<p> Note that the material is available in public properties, but isn't applied automatically before invoking BuildList.<br> Subclassing should be reserved to structural objects and objects that have no material of their own.

TGLImposter

GLImposter

TGLImposterBuilder

GLImposter

Abstract ImposterBuilder class.

TGLInitializableObjectList

GLScene

Just a list of objects that support IGLInitializable.<p>

TGLint

OpenGLTokens

TGLint64

OpenGLTokens

TGLint64EXT

OpenGLTokens

TGLInterfacedCollectionItem

PersistentClasses

TCollectionItem thet inplements IInterface.

TGLInterfacedPersistent

PersistentClasses

TPersistent thet inplements IInterface.

TGLInternalCompression

GLTextureFormat

Texture compression option.<p> If OpenGL supports it, this will activate a compressed texture format:<ul> <li>tcDefault : uses global default compression option <li>tcNone : do not use compression <li>tcStandard : use standard compression, average quality, average rate <li>tcHighQuality : choose a high-quality, low-speed compression <li>tcHighSpeed : choose a high-speed, low-quality compression </ul>.

TGLInternalFormat

GLTextureFormat

TGLInterpolationType

VectorGeometry

TGLintptr

OpenGLTokens

TGLJPEGImage

GLFileJPEG

TGLKeyEvent

GLCrossPlatform

TGLKeyPressEvent

GLCrossPlatform

TGLLabel

GLWindows

TGLlConsoleEvent

GLConsole

Event called when used presses the "Enter"

TGLLensFlare

GLLensFlare

TGLLibAsmProgNameProperty

GLSceneRegister

TGLLibAttachmentNameProperty

GLSceneRegister

TGLLibCombinerNameProperty

GLSceneRegister

TGLLibMaterial

GLMaterial

Material in a material library.<p> Introduces Texture transformations (offset and scale). Those transformations are available only for lib materials to minimize the memory cost of basic materials (which are used in almost all objects).

TGLLibMaterialEx

GLMaterialEx

TGLLibMaterialName

GLMaterial

TGLLibMaterialNameProperty

GLSceneRegister

TGLLibMaterialNameProperty

GLSceneRegisterLCL

TGLLibMaterialProperty

GLMaterialEx

TGLLibMaterials

GLMaterial

A collection of materials, mainly used in material libraries.

TGLLibMaterialsEx

GLMaterialEx

TGLLibSamplerNameProperty

GLSceneRegister

TGLLibShaderNameProperty

GLSceneRegister

TGLLibTextureNameProperty

GLSceneRegister

TGLLifeColoredPFXManager

GLParticleFX

Base PFX manager for particles with life colors.<p> Particles have a core and edge color, for subclassing.

TGLLightSource

GLScene

Standard light source.<p> The standard GLScene light source covers spotlights, omnidirectionnal and parallel sources (see TLightStyle).<br> Lights are colored, have distance attenuation parameters and are turned on/off through their Shining property.<p> Lightsources are managed in a specific object by the TGLScene for rendering purposes. The maximum number of light source in a scene is limited by the OpenGL implementation (8 lights are supported under most ICDs), though the more light you use, the slower rendering may get. If you want to render many more light/lightsource, you may have to resort to other techniques like lightmapping.

TGLLightSourceEnum

GLCustomShader

TGLLightSourceSet

GLCustomShader

TGLLineBase

GLObjects

TGLLineParticle

GLLinePFX

Linear particle.<p>

TGLLinePFXManager

GLLinePFX

Polygonal particles FX manager.<p> The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available.<br> If you render large particles and don't have T&L acceleration, consider using TGLPointLightPFXManager.

TGLLines

GLObjects

TGLLineSettings

GLHiddenLineShader

TGLLinesNode

GLObjects

TGLLinesNodes

GLObjects

TGLListHandle

GLContext

Manages a handle to a display list.

TGLLMTSVectorFile

GLFileLMTS

TGLLODStreamingState

GLGraphics

TGLLWOVectorFile

GLFileLWO

TGLMagFilter

GLTexture

TGLMapCollection

GLFPSMovement

TGLMapCollectionItem

GLFPSMovement

TGLMapCollectionItemClass

GLFPSMovement

TGLMaterial

GLMaterial

Describes a rendering material.<p> A material is basicly a set of face properties (front and back) that take care of standard material rendering parameters (diffuse, ambient, emission and specular) and texture mapping.<br> An instance of this class is available for almost all objects in GLScene to allow quick definition of material properties. It can link to a TGLLibMaterial (taken for a material library).<p> The TGLLibMaterial has more adavanced properties (like texture transforms) and provides a standard way of sharing definitions and texture maps.

TGLMaterialComponentName

GLMaterialEx

TGLMaterialComponentNameProperty

GLSceneRegister

TGLMaterialLevel

GLState

TGLMaterialLibrary

GLMaterial

Stores a set of materials, to be used and shared by scene objects.<p> Use a material libraries for storing commonly used materials, it provides an efficient way to share texture and material data among many objects, thus reducing memory needs and rendering time.<p> Materials in a material library also feature advanced control properties like texture coordinates transforms.

TGLMaterialLibraryEditor

GLSceneRegister

Editor for material library.<p>

TGLMaterialLibraryEx

GLMaterialEx

TGLMaterialLibraryItem

GLMaterialScript

TGLMaterialLibraryItems

GLMaterialScript

TGLMaterialMultiProxy

GLMaterialMultiProxy

Multiple Proxy object.<p> This proxy has multiple Master objects, which are individually made visible depending on a Distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation.<p> For dimensionsn raycasting and silhouette purposes, the first Master is used (item zero in the MasterObjects collection).

TGLMaterialMultiProxyMaster

GLMaterialMultiProxy

MasterObject description for a MultiProxy object.

TGLMaterialMultiProxyMasters

GLMaterialMultiProxy

Collection of TGLMaterialMultiProxyMaster.

TGLMaterialProperty

GLSceneRegister

TGLMaterialProxy

GLProxyObjects

A proxy object with its own material.<p> This proxy object can take a mesh from one master and a materia from a material library.

TGLMaterialScripter

GLMaterialScript

TGLMatLibComponents

GLMaterialEx

TGLMatrix2D

GLTypes

TGLMatrix2DArray

GLTypes

TGLMatrix2DType

GLTypes

TGLMatrix3D

GLTypes

TGLMatrix3DArray

GLTypes

TGLMatrix3DType

GLTypes

TGLMD2VectorFile

GLFileMD2

The MD2 vector file (Quake2 actor file).<p> Stores a set of "frames" describing the different postures of the actor, it may be animated by TGLActor. The "Skin" must be loaded indepentendly (the whole mesh uses a single texture bitmap).<p> Based on code by Roger Cao.

TGLMD3VectorFile

GLFileMD3

TGLMD5VectorFile

GLFileMD5

TGLMDCVectorFile

GLFileMDC

TGLMemoryViewer

GLScene

Component to render a scene to memory only.<p> This component curently requires that the OpenGL ICD supports the WGL_ARB_pbuffer extension (indirectly).

TGLMesh

GLMesh

TGLMesh2D

GLTypes

TGLMesh2DVertex

GLTypes

TGLMesh3D

GLTypes

TGLMesh3DVertex

GLTypes

TGLMeshPrimitive

GLState

TGLMeshPrimitives

GLState

TGLMHeader

FileGL2

TGLMinFilter

GLTexture

TGLMirror

GLMirror

A simple plane mirror.<p> This mirror requires a stencil buffer for optimal rendering!<p> The object is a mix between a plane and a proxy object, in that the plane defines the mirror's surface, while the proxy part is used to reference the objects that should be mirrored (it is legal to self-mirror, but no self-mirror visuals will be rendered).<p> It is strongly recommended to read and understand the explanations in the materials/mirror demo before using this component.

TGLMLODInfo

FileGL2

TGLMLODs

FileGL2

TGLMLODSurfaceOffsets

FileGL2

TGLMotionBlur

GLBlur

This component blurs everything thatis rendered BEFORE it. So if you want part of your scene blured, the other not blured, make sure that the other part is rendered after this component. It is fast and does not require shaders.
Note: it is FPS-dependant. Also also can produce a "blury trail effect", which stays on the screen until something new is rendered over it. It can be overcome by changing the Material.FrontProperties.Diffuse property. This, however, also has a drawback - the picture becomes more blured altogether. For example, if your backgroud color is Black, set the Material.FrontProperties.Diffuse to White. If it is White, set Material.FrontProperties.Diffuse to Black. I haven't tried any others, but I hope you get the idea ;)
I've seen this effect in different Bruring components, even in shaders, but if anyone knows another way to fix this issue - please post it on the glscene newsgroup.

TGLMouseAction

GLWindows

TGLMouseButton

GLCrossPlatform

TGLMouseEvent

GLCrossPlatform

TGLMouseMoveEvent

GLCrossPlatform

TGLMovement

GLMovement

TGLMovementPath

GLMovement

TGLMovementPaths

GLMovement

TGLMovementRotationMode

GLMovement

TGLMoveToPosJob

GLCameraController

TGLMP3File

GLFileMP3

Support for MP3 format.<p> *Partial* support only, access to PCMData is NOT supported.

TGLMS3DVectorFile

GLFileMS3D

The MilkShape vector file.<p> By Mattias Fagerlund, mattias@cambrianlabs.com. Yada yada. Eric rules!

TGLMSurface

FileGL2

TGLMSurfaceHeader

FileGL2

TGLMSurfaceHeirachy

FileGL2

TGLMSurfaceHeirachyOffsets

FileGL2

TGLMTLFile

GLFileOBJ

A simple class that know how to extract infos from a mtl file.<p> mtl files are companion files of the obj, they store material information. Guessed content (imported ones denoted with a '*', please help if you know more):<ul> <li>materials begin with a 'newmtl' command followed by material name <li>*Kd command defines the diffuse color <li>*map_Kd command defines the diffuse texture image <li>*Ka/map_Ka define the ambient color and texmap <li>*Ks/map_Ks define the specular color and texmap <li>map_Bump specifies the bump map <li>*d specifies transparency (alpha-channel, range [0; 1]) <li>map_d specifies the opcaity texture map <li>Ns defines the specular exponent or shininess or phong specular (?) <li>Ni is the refraction index (greater than 1) <li>*illum defines the illumination model (0 for no lighting, 1 for ambient and diffuse, 2 for full lighting) </ul>

TGLMTriangle

FileGL2

TGLMultiMaterialShader

GLMultiMaterialShader

TGLMultiPolygon

GLMultiPolygon

A polygon that can have holes and multiple contours.<p> Use the Path property to access a contour or one of the AddNode methods to add a node to a contour (contours are allocated automatically).

TGLMultiProxy

GLMultiProxy

Multiple Proxy object.<p> This proxy has multiple master objects, which are individually made visible depending on a distance to the camera criterion. It can be used to implement discreet level of detail directly for static objects, or objects that go through cyclic animation.<p> For dimensionsn raycasting and silhouette purposes, the first master is used (item zero in the MasterObjects collection).

TGLMultiProxyMaster

GLMultiProxy

MasterObject description for a MultiProxy object.

TGLMultiProxyMasters

GLMultiProxy

Collection of TGLMultiProxyMaster.

TGLMultisampleImage

GLMultisampleImage

TGLMultitextureCoordinator

XOpenGL

TGLMultitexturingProperties

GLMaterialEx

TGLMVertex

FileGL2

TGLNavigator

GLNavigator

TGLNavigator is the component for moving a TGLBaseSceneObject, and all Classes based on it, this includes all the objects from the Scene Editor.<p>
The four calls to get you started is <ul> <li>TurnHorisontal : it turns left and right. <li>TurnVertical : it turns up and down. <li>MoveForward : moves back and forth. <li>FlyForward : moves back and forth in the movingobject's direction </ul> The three properties to get you started is <ul> <li>MovingObject : The Object that you are moving. <li>UseVirtualUp : When UseVirtualUp is set you navigate Quake style. If it isn't it's more like Descent. <li>AngleLock : Allows you to block the Vertical angles. Should only be used in conjunction with UseVirtualUp. <li>MoveUpWhenMovingForward : Changes movement from Quake to Arcade Airplane... (no tilt and flying) <li>InvertHorizontalSteeringWhenUpsideDown : When using virtual up, and vertically rotating beyond 90 degrees, will make steering seem inverted, so we "invert" back to normal. </ul>

TGLNavigatorAbstractParameters

GLSmoothNavigator

TGLNavigatorAdjustDistanceParameters includes a basic set of parameters that control the smoothness of movement.<p>

TGLNavigatorAdjustDistanceParameters

GLSmoothNavigator

TGLNavigatorAdjustDistanceParameters is wrapper for all parameters that affect how the AdjustDisanceTo[...] methods work<p>

TGLNavigatorAdjustDistanceParametersEx

GLSmoothNavigator

TGLNavigatorAdjustDistanceParameters is wrapper for all parameters that affect how the AdjustDisanceTo[...]Ex methods work<p>
You need to set the TargetObject and desired distance to it, then call AdjustDisanceTo[...]Ex() in your Cadencer.OnProgress code.

TGLNavigatorGeneralParameters

GLSmoothNavigator

TGLNavigatorGeneralParameters is a wrapper for all general inertia parameters.
These properties mean that if ExpectedMaxFPS is 100, FAutoScaleMin is 0.1, FAutoScaleMax is 0.75 then the "safe range" for it to change is [10..75]. If these bounds are violated, then ExpectedMaxFPS is automaticly increased or decreased by AutoScaleMult.

TGLNavigatorInertiaParameters

GLSmoothNavigator

TGLNavigatorInertiaParameters is wrapper for all parameters that affect the smoothness of movement<p>

TGLNavigatorMoveAroundParameters

GLSmoothNavigator

TGLNavigatorMoveAroundParameters is a wrapper for all parameters that effect how the TGLBaseSceneObject.MoveObjectAround() procedure works

TGLNavigatorSmoothChangeItem

GLSmoothNavigator

TGLNavigatorSmoothChangeItem includes a basic set of parameters that control the smoothness of movement.<p>

TGLNavigatorSmoothChangeItemClass

GLSmoothNavigator

TGLNavigatorSmoothChangeItems

GLSmoothNavigator

XCollection of TGLNavigatorSmoothChangeItem.

TGLNavigatorSmoothChangeSingle

GLSmoothNavigator

Smoothly change any Single value, so it will become TargetValue in the end.<p>

TGLNavigatorSmoothChangeSingleGetEvent

GLSmoothNavigator

TGLNavigatorSmoothChangeSingleSetEvent

GLSmoothNavigator

TGLNavigatorSmoothChangeVector

GLSmoothNavigator

Smoothly change any Vector4f value, so it will become TargetValue in the end.<p>

TGLNavigatorSmoothChangeVectorGetEvent

GLSmoothNavigator

TGLNavigatorSmoothChangeVectorSetEvent

GLSmoothNavigator

TGLNGDBehaviour

GLNGDManager

TGLNGDBehaviourList

GLNGDManager

TGLNGDDynamic

GLNGDManager

TGLNGDManager

GLNGDManager

TGLNGDStatic

GLNGDManager

TGLNMFVectorFile

GLFileNMF

TGLNode

GLNodes

TGLNodedLines

GLObjects

TGLNodes

GLNodes

TGLNodesClass

GLNodes

TGLNonVisualViewer

GLScene

Base class for non-visual viewer.<p> Non-visual viewer may actually render visuals, but they are non-visual (ie. non interactive) at design time. Such viewers include memory or full-screen viewers.

TGLNurbsVectorFile

GLFileNurbs

TGLO3TCImage

GLFileO3TC

TGLObjectAfterEffect

GLScene

An object effect that gets rendered at scene's end.<p> No particular OpenGL matrices or material should be assumed.

TGLObjectEffect

GLScene

TGLObjectEffectClass

GLScene

TGLObjectEffects

GLScene

Holds a list of object effects.<p> This object expects itself to be owned by a TGLBaseSceneObject.<p>

TGLObjectPostEffect

GLScene

An object effect that gets rendered after owner object's render.<p> The current OpenGL matrices and material are that of the owner object.

TGLObjectPreEffect

GLScene

An object effect that gets rendered before owner object's render.<p> The current OpenGL matrices and material are that of the owner object.

TGLObjectsSorting

GLRenderContextInfo

Determines if objects are sorted, and how.<p> Sorting is done level by level (and not for all entities), values are :<ul> <li>osInherited : use inherited sorting mode, defaults to osRenderFarthestFirst <li>osNone : do not sort objects. <li>osRenderFarthestFirst : render objects whose Position is the farthest from the camera first. <li>osRenderBlendedLast : opaque objects are not sorted and rendered first, blended ones are rendered afterwards and depth sorted. <li>osRenderNearestFirst : render objects whose Position is the nearest to the camera first. </ul>

TGLObjectStyle

GLScene

Possible styles/options for a GLScene object.<p> Allowed styles are:<ul> <li>osDirectDraw : object shall not make use of compiled call lists, but issue direct calls each time a render should be performed. <li>osIgnoreDepthBuffer : object is rendered with depth test disabled, this is true for its children too. <li>osNoVisibilityCulling : whatever the VisibilityCulling setting, it will be ignored and the object rendered </ul>

TGLObjectStyles

GLScene

TGLOBJVectorFile

GLFileOBJ

TGLOcclusionQueryHandle

GLContext

Manages a handle to an occlusion query.<br> Requires OpenGL 1.5+<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.

TGLOCTVectorFile

GLFileOCT

The OCT vector file (FSRad output).<p>

TGLODEBehaviour

GLODEManager

Basis structures for GLScene behaviour style implementations.

TGLODECustomCollider

GLODECustomColliders

The custom collider is designed for generic contact handling. There is a contact point generator for sphere, box, capped cylinder, cylinder and cone geoms.<p>
Once the contact points for a collision are generated the abstract Collide function is called to generate the depth and the contact position and normal. These points are then sorted and the deepest are applied to ODE.

TGLODEDynamic

GLODEManager

TGLODEHeightField

GLODECustomColliders

Add this behaviour to a TGLHeightField or TGLTerrainRenderer to enable height based collisions for spheres, boxes, capped cylinders, cylinders and cones.

TGLODEJointList

GLODEManager

Component front-end for storing ODE Joints.

TGLODEManager

GLODEManager

TGLODEStatic

GLODEManager

TGLOnCustomPostEffectEvent

GLPostEffects

TGLOrbitToPosAdvJob

GLCameraController

TGLOrbitToPosJob

GLCameraController

TGLOutlineShader

GLOutlineShader

TGLOwnedPersistent

PersistentClasses

TPersistent which has knowledge of its owner.

TGLPackPBOHandle

GLContext

Manages a handle to PBO Pixel Pack Buffer.<p> When bound, commands such as ReadPixels write their data into a buffer object.

TGLPanel

GLWindows

TGLParticle

GLParticleFX

Base class for particles.<p> The class implements properties for position, velocity and time, whatever you need in excess of that will have to be placed in subclasses (this class should remain as compact as possible).

TGLParticleArray

GLParticleFX

TGLParticleClass

GLParticleFX

TGLParticleEvent

GLParticles

TGLParticleFXEffect

GLParticleFX

Base class for linking scene objects to a particle FX manager.<p>

TGLParticleFXManager

GLParticleFX

Base class for particle FX managers.<p> Managers take care of life and death of particles for a particular particles FX system. You can have multiple scene-wide particle FX managers in a scene, handled by the same ParticleFxRenderer.<p> Before subclassing, make sure you understood how the Initialize/Finalize Rendering, Begin/End Particles and RenderParticles methods (and also understood that rendering of manager's particles may be interwoven).

TGLParticleFXRenderer

GLParticleFX

Rendering interface for scene-wide particle FX.<p> A renderer can take care of rendering any number of particle systems, its main task being to depth-sort the particles so that they are blended appropriately.<br> This object will usually be placed at the end of the scene hierarchy, just before the HUD overlays, its position, rotation etc. is of no importance and has no effect on the rendering of the particles.

TGLParticleList

GLParticleFX

List of particles.<p> This list is managed with particles and performance in mind, make sure to check methods doc.

TGLParticles

GLParticles

Manager object of a particle system.<p> Particles in a TGLParticles system are described as normal scene objects, however their children are to be :<ul> <li>"particle template" : the first object (index=0), this one will be duplicated to create new particles, it does not receive progression events and is visible at design-time only. <li>"live particle" : the other objects (index>0), this ones are rendered and receive progression events. </ul><br>TGLParticles may also maintain an internal, non-persistent ("freezed") set of objects : the allocated objects pool. Why ? Creating and freeing objects takes cpu-cycles, especially for the TComponent class, and GLScene objects are TComponent. To reduce this load (and at the expense of memory space), the particle systems can move "dead" particles to a pool instead of freeing them, and will pick in the pool instead of creating new objects when new particles are requested. To take advantage of this behaviour, you should set the ParticlePoolSize property to a non-null value and use the KillParticle function instead of "Free" to kill a particle.<br> All direct access to a TGLParticles children should be avoided.<p> For high-performance particle systems of basic particles, you should look into GLParticleFX instead, TGLParticles being rather focused on complex particles.

TGLPathNode

GLMovement

TGLPathNodes

GLMovement

TGLPerlinHDS

GLPerlin

TGLPerlinHDSThread

GLPerlin

TGLPerlinInterpolation

GLPerlin

TGLPerlinOctav

GLPerlin

TGLPerlinPFXManager

GLPerlinPFX

A sprite-based particles FX manager using perlin-based sprites.<p> This PFX manager is more suited for smoke or fire effects, and with proper tweaking of the texture and perlin parameters, may help render a convincing effect with less particles.<p> The sprite generate by this manager is the composition of a distance-based intensity and a perlin noise.

TGLPersistentImage

GLTexture

Stores any image compatible with Delphi's TPicture mechanism.<p> The picture's data is actually stored into the DFM, the original picture name or path is not remembered. It is similar in behaviour to Delphi's TImage.<p> Note that if original image is for instance JPEG format, only the JPEG data will be stored in the DFM (compact)

TGLPersistentTIE

GLTextureImageEditors

TGLPGMImage

GLFilePGM

TGLPhongShader

GLPhongShader

TGLPicFileImage

GLTexture

Uses a picture whose data is found in a file (only filename is stored).<p> The image is unloaded after upload to OpenGL.

TGLPicFileTIE

GLTextureImageEditors

TGLPickList

GLSelection

List class for object picking.<p> This list is used to store the results of a PickObjects call.

TGLPicture

GLCrossPlatform

TGLPictureImage

GLTexture

Base class for image data classes internally based on a TPicture.

TGLPipe

GLExtrusion

A solid object generated by extruding a circle along a trajectory.<p> Texture coordinates NOT supported yet.

TGLPipelineTransformationState

GLPipelineTransformation

TGLPipelineTransformationStates

GLPipelineTransformation

TGLPipeNode

GLExtrusion

TGLPipeNodes

GLExtrusion

TGLPixel24

GLGraphics

TGLPixel32

GLGraphics

TGLPixel32Array

GLGraphics

TGLPlane

GLObjects

TGLPLYVectorFile

GLFilePLY

The PLY vector file aka Stanford Triangle Format.<p> This is a format for storing graphical objects that are described as a collection of polygons. The format is extensible, supports variations and subformats. This importer only works for the simplest variant (triangles without specified normals, and will ignore most header specifications.

TGLPNGImage

GLFilePNG

TGLPoint

GLCrossPlatform

TGLPoint2D

GLTypes

TGLPoint2DArray

GLTypes

TGLPoint3D

GLTypes

TGLPoint3DArray

GLTypes

TGLPointLightPFXManager

GLParticleFX

A sprite-based particles FX managers using point light maps.<p> The texture map is a round, distance-based transparency map (center "opaque"), you can adjust the quality (size) of the underlying texture map with the TexMapSize property.<p> This PFX manager renders particles similar to what you can get with TGLPolygonPFXManager but stresses fillrate more than T&L rate (and will usually be slower than the PolygonPFX when nbSides is low or T&L acceleration available). Consider this implementation as a sample for your own PFX managers that may use particles with more complex textures.

TGLPointParameters

GLObjects

TGLPoints

GLObjects

TGLPointStyle

GLObjects

TGLPolygon

GLGeomObjects

TGLPolygon2D

GLTypes

TGLPolygon3D

GLTypes

TGLPolygonBase

GLObjects

TGLPolygonPFXManager

GLParticleFX

Polygonal particles FX manager.<p> The particles of this manager are made of N-face regular polygon with a core and edge color. No texturing is available.<br> If you render large particles and don't have T&L acceleration, consider using TGLPointLightPFXManager.

TGLPolyhedron

GLTypes

TGLPopupMenu

GLWindows

TGLPopupMenuClick

GLWindows

TGLPortal

GLPortal

Portal Renderer class.

TGLPostEffect

GLPostEffects

Provides a simple way to producing post-effects without shaders.<p> It is slow as hell, but it's worth it in some cases.

TGLPostEffectBuffer

GLPostEffects

TGLPostEffectColor

GLPostEffects

TGLPostEffectPreset

GLPostEffects

Some presets for TGLPostEffect: pepNone - does nothing. pepGray - makes picture gray. pepNegative - inverts all colors. pepDistort - simulates shaky TV image. pepNoise - just adds random niose. pepNightVision - simulates nightvision goggles. pepBlur - blurs the scene. pepCustom - calls the OnCustomEffect event.

TGLPostShaderCollection

GLPostEffects

TGLPostShaderCollectionItem

GLPostEffects

TGLPostShaderHolder

GLPostEffects

A class that allows several post-shaders to be applied to the scene, one after another. It does not provide any optimizations related to multi-shader rendering, just a convenient interface.

TGLPrimitiveQueryHandle

GLContext

Manages a handle to a primitive query.<br> Requires OpenGL 3.0+<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.

TGLProcTextureNoise

GLProcTextures

TGLProcTextureNoiseTIE

GLTextureImageEditors

TGLProgramHandle

GLContext

Manages a GLSL Program Object.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.<br>

TGLProgressEvent

BaseClasses

Progression event for time-base animations/simulations.<p> deltaTime is the time delta since last progress and newTime is the new time after the progress event is completed.

TGLProjectedTextures

GLProjectedTextures

Projected Textures Manager.<p> Specifies active texture Emitters (whose texture will be projected) and receivers (children of this object).

TGLProjectedTexturesStyle

GLProjectedTextures

Possible styles of texture projection. Possible values:<ul> <li>ptsOriginal: Original projection method (first pass, is default scene render, second pass is texture projection). <li>ptsInverse: Inverse projection method (first pass is texture projection, sencond pass is regular scene render). This method is useful if you want to simulate lighting only through projected textures (the textures of the scene are "masked" into the white areas of the projection textures). </ul>

TGLProxyObject

GLScene

A full proxy object.<p> This object literally uses another object's Render method to do its own rendering, however, it has a coordinate system and a life of its own.<br> Use it for duplicates of an object.

TGLProxyObjectClass

GLScene

TGLProxyObjectOption

GLScene

Defines which features are taken from the master object.

TGLProxyObjectOptions

GLScene

TGLPythonEngine

GLScriptPython

This class only adds manager registration logic to the TPythonEngine class to enable the XCollection items (ie. TGLScriptPython) retain it's assigned compiler from design to run -time.

TGLQ3BSPVectorFile

GLFileQ3BSP

The Q3BSP vector file (Quake III BSP).<p>

TGLQuadricObject

GLObjects

TGLQuaternion3D

GLTypes

TGLQueryHandle

GLContext

Manages a handle to a query.<br> Do not use this class directly, use one of its subclasses instead.

TGLRagdoll

GLRagdoll

TGLRCHandle

GLContext

TGLRCOption

GLContext

TGLRCOptions

GLContext

TGLRect

GLCrossPlatform

TGLRenderbuffer

GLFBO

TGLRenderbufferHandle

GLContext

Manages a handle to a Renderbuffer Object. A Renderbuffer is a "framebuffer-attachable image" for generalized offscreen rendering and it also provides a means to support rendering to GL logical buffer types which have no corresponding texture format (stencil, accum, etc).

TGLRenderPoint

GLScene

Scene object that allows other objects to issue rendering at some point.<p> This object is used to specify a render point for which other components have (rendering) tasks to perform. It doesn't render anything itself and is invisible, but other components can register and be notified when the point is reached in the rendering phase.<br> Callbacks must be explicitly unregistered.

TGLResolutionIndependantHUDText

GLHUDObjects

TGLResourceType

GLSCUDA

TGLRevolutionSolid

GLExtrusion

A solid object generated by rotating a curve along the Y axis.<p> The curve is described by the Nodes and SplineMode properties, and it is rotated in the trigonometrical direction (CCW when seen from Y->INF).<p> The TGLRevolutionSolid can also be used to render regular helicoidions, by setting a non-null YOffsetPerTurn, and adjusting start/finish angles to make more than one revolution.<p> If you want top/bottom caps, just add a first/last node that will make the curve start/finish on the Y axis.

TGLROAMPatch

GLROAMPatch

TGLSamplerHandle

GLContext

Manages a handle to a sampler.

TGLSamplingScale

GLGraph

TGLSApplicationResource

ApplicationFileIO

TGLSArchiveManager

GLSArchiveManager

TGLSArchiveManagerEditor

GLSceneRegister

Editor for GLScene Archive Manager.<p>

TGLScene

GLScene

Scene object.<p> The scene contains the scene description (lights, geometry...), which is basicly a hierarchical scene graph made of TGLBaseSceneObject. It will usually contain one or more TGLCamera object, which can be referred by a Viewer component for rendering purposes.<p> The scene's objects can be accessed directly from Delphi code (as regular components), but those are edited with a specific editor (double-click on the TGLScene component at design-time to invoke it). To add objects at runtime, use the AddNewChild method of TGLBaseSceneObject.

TGLSceneBaseFileDescriptor

GLSceneFormDesign

TGLSceneBaseFormDescriptor

GLSceneFormDesign

TGLSceneBuffer

GLScene

Encapsulates an OpenGL frame/rendering buffer.<p>

TGLSceneEditor

GLSceneRegister

TGLSceneEditorForm

GLSceneEdit

TGLSceneEditorForm

GLSceneEditLCL

TGLSceneExtendedFileDescriptor

GLSceneFormDesign

TGLSceneExtendedFormDescriptor

GLSceneFormDesign

TGLSceneForm

GLSceneForm

TGLSceneObject

GLScene

Base class for standard scene objects.<p> Publishes the Material property.

TGLSceneObjectClass

GLScene

TGLSceneObjectEntry

GLObjectManager

TGLSceneRootObject

GLScene

This class shall be used only as a hierarchy root.<p> It exists only as a container and shall never be rotated/scaled etc. as the class type is used in parenting optimizations.<p> Shall never implement or add any functionality, the "Create" override only take cares of disabling the build list.

TGLSceneSimpleFileDescriptor

GLSceneFormDesign

TGLSceneSimpleFormDescriptor

GLSceneFormDesign

TGLSceneViewer

GLViewer

TGLSceneViewer

GLLCLViewer

Component where the GLScene objects get rendered.<p> This component delimits the area where OpenGL renders the scene, it represents the 3D scene viewed from a camera (specified in the camera property). This component can also render to a file or to a bitmap.<p> It is primarily a windowed component, but it can handle full-screen operations : simply make this component fit the whole screen (use a borderless form).<p> This viewer also allows to define rendering options such a fog, face culling, depth testing, etc. and can take care of framerate calculation.<p>

TGLSceneViewer

GLWin32Viewer

Component where the GLScene objects get rendered.<p> This component delimits the area where OpenGL renders the scene, it represents the 3D scene viewed from a camera (specified in the camera property). This component can also render to a file or to a bitmap.<p> It is primarily a windowed component, but it can handle full-screen operations : simply make this component fit the whole screen (use a borderless form).<p> This viewer also allows to define rendering options such a fog, face culling, depth testing, etc. and can take care of framerate calculation.<p>

TGLSceneViewerEditor

GLSceneRegister

TGLSceneViewerMode

GLScene

TGLScreenControlingContext

GLContext

A TGLContext with screen control property and methods.<p> This variety of contexts is for drivers that access windows and OpenGL through an intermediate opaque cross-platform API.<p> TGLSceneViewer won't use them, TGLMemoryViewer may be able to use them, but most of the time they will be accessed through a specific viewer class/subclass.

TGLScreenDepth

GLFullScreenViewer

TGLScriptBase

GLScriptBase

The base script class that defines the abstract functions and properties. Don't use this class directly, use the script classes descended from this base class.

TGLScriptDWS2

GLScriptDWS2

Implements DelphiWebScriptII scripting functionality through the abstracted GLScriptBase .

TGLScriptLibrary

GLScriptBase

Encapsulation of the scripts XCollection to help with script handling at design-time. Links the scripts to Delphi's persistence model.

TGLScriptPython

GLScriptPython

Implements Python scripting functionality through the abstracted GLScriptBase.

TGLScripts

GLScriptBase

XCollection descendant for storing and handling scripts.

TGLScriptState

GLScriptBase

TGLScrollbar

GLWindows

TGLSCUDA

GLSCUDA

TGLSCUDACompiler

GLSCUDACompiler

TGLSCUDACompilerEditor

GLSComputingRegister

TGLSCUDACompilerOutput

GLSCUDACompiler

TGLSCUDACompilerSourceProperty

GLSComputingRegister

TGLSCUDADevice

GLSCUDAContext

TGLSCUDADeviceProperty

GLSComputingRegister

TGLSCUDAEditor

GLSComputingRegister

TGLSCUDAEditorForm

GLSCUDAEditor

TGLSCUDARealArch

GLSCUDACompiler

sm_10 ISA_1 Basic features sm_11 + atomic memory operations on global memory sm_12 + atomic memory operations on shared memory + vote instructions sm_13 + double precision floating point support sm_20 + FERMI support. sm_21 + Unknown

TGLSCUDARealArchs

GLSCUDACompiler

TGLSCUDAVirtArch

GLSCUDACompiler

compute_10 Basic features compute_11 + atomic memory operations on global memory compute_12 + atomic memory operations on shared memory + vote instructions compute_13 + double precision floating point support Compute_20 + FERMI support

TGLSCustomMemo

GLSMemo

TGLSDLContext

GLSDLContext

A context driver for OpenGL via SDL (libsdl.org).<p> Due to limitations of SDL:<ul> <li>you may have only one SDL window opened at any time (you cannot have memory viewers) <li>closing the SDL window will terminate the application </ul>

TGLSDLViewer

GLSDLContext

A viewer using SDL.<p> Beware: only one at a time, no other viewers allowed!<br> Will also close the application when the window is closed!

TGLSelectRenderModeTechnique

GLSelection

TGLSeparateTextureWrap

GLTextureFormat

TGLShadeModel

GLScene

TGLShader

GLMaterial

Generic, abstract shader class.<p> Shaders are modeled here as an abstract material-altering entity with transaction-like behaviour. The base class provides basic context and user tracking, as well as setup/application facilities.<br> Subclasses are expected to provide implementation for DoInitialize, DoApply, DoUnApply and DoFinalize.

TGLShaderClass

GLMaterial

TGLShaderCombiner

GLShaderCombiner

TGLShaderCombinerType

GLShaderCombiner

MP - multipass, SP-singlepass, AP - anypass (single or multi) One-Two or Two-One determines the order of how the shaders should be applied For example, sctTwoMPOneSP means that first one will be applied Shader Two, which can be a multipass shader, then Shader One is applied, which should be a singlepass shader.
sctOneMPTwoSP and sctTwoMPOneSP modes are actualy quite Str@nge, because... well look at the code yourself
TODO: Add more modes here, including sctOneAPTwoAP, which should be the default one.
By the way, I admit - the names do look stupid, and if someone gives them proper names, I will be only glad.

TGLShaderEditor

FShaderMemo

TGLShaderEditorProperty

GLSceneRegister

TGLShaderEvent

GLCustomShader

TGLShaderEx

GLMaterialEx

TGLShaderFailedInitAction

GLMaterial

Defines what to do if for some reason shader failed to initialize.<ul> <li>fiaSilentdisable: just disable it <li>fiaRaiseHandledException: raise an exception, and handle it right away (usefull, when debigging within Delphi) <li>fiaRaiseStardardException: raises the exception with a string from this function GetStardardNotSupportedMessage <li>fiaReRaiseException: Re-raises the exception <li>fiaGenerateEvent: Handles the exception, but generates an event that user can respond to. For example, he can try to compile a substitude shader, or replace it by a material. Note: HandleFailedInitialization does *not* create this event, it is left to user shaders which may chose to override this procedure. Commented out, because not sure if this option should exist, let other generations of developers decide ;) </ul>

TGLShaderFogSupport

GLCustomShader

TGLShaderHandle

GLContext

Manages a handle to a Shader Object.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.<br> Do not use this class directly, use one of its subclasses instead.

TGLShaderHandleClass

GLContext

TGLShaderItem

GLMaterialScript

TGLShaderItems

GLMaterialScript

TGLShaderModel3

GLMaterialEx

TGLShaderModel4

GLMaterialEx

TGLShaderModel5

GLMaterialEx

TGLShaderProgram

GLCustomShader

A custom shader program.

TGLShaderStyle

GLMaterial

Define GLShader style application relatively to a material.<ul> <li>ssHighLevel: shader is applied before material application, and unapplied after material unapplication <li>ssLowLevel: shader is applied after material application, and unapplied before material unapplication <li>ssReplace: shader is applied in place of the material (and material is completely ignored) </ul>

TGLShaderType

GLMaterialEx

TGLShaderUnAplyEvent

GLCustomShader

TGLShaderUniform

GLMaterialEx

TGLShaderUniformDSA

GLMaterialEx

TGLShaderUniformTexture

GLMaterialEx

TGLShadowCastingMode

GLShadowVolume

Determines when a caster should actually produce a shadow; <ul> <li>scmAlways : Caster always produces a shadow, ignoring visibility <li>scmVisible : Caster casts shadow if the object has visible=true <li>scmRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true <li>scmParentVisible : Caster produces shadow if parent has visible=true <li>scmParentRecursivelyVisible : Caster casts shadow if ancestors up the hierarchy all have visible=true, starting from the parent (ignoring own visible setting) </ul>

TGLShadowHDS

GLShadowHDS

An Height Data Source that generates terrain shadow maps automatically.<p> The HDS must be connected to another HDS, which will provide the elevation data, and to a MaterialLibrary where shadowmaps will be placed.

TGLShadowPlane

GLShadowPlane

A simple shadow plane.<p> This mirror requires a stencil buffer for optimal rendering!<p> The object is a mix between a plane and a proxy object, in that the plane defines where the shadows are cast, while the proxy part is used to reference the objects that should be shadowing (it is legal to self-shadow, but no self-shadow visuals will be rendered).<br> If stenciling isn't used, the shadow will 'paint' the ShadowColor instead of blending it transparently.<p> You can have lower quality shadow geometry: add a dummycube, set it to invisible (so it won't be rendered in the "regular" pass), and under it place another visible dummycube under which you have all your low quality objects, use it as shadowing object. Apply the same movements to the low-quality objects that you apply to the visible, high-quality ones.

TGLShadowVolume

GLShadowVolume

Simple shadow volumes.<p> Shadow receiving objects are the ShadowVolume's children, shadow casters (opaque objects or lights) must be explicitly specified in the Casters collection.<p> Shadow volumes require that the buffer allows stencil buffers, GLSceneViewer.Buffer.ContextOptions contain roStencinBuffer. Without stencil buffers, shadow volumes will not work properly.<p> Another issue to look out for is the fact that shadow volume capping requires that the camera depth of view is either very high (fi 1e9) or that the camera style is csInfinitePerspective.

TGLShadowVolumeCapping

GLShadowVolume

Determines when a shadow volume should generate a cap at the beginning and end of the volume. This is ONLY necessary when there's a chance that the camera could end up inside the shadow _or_ between the light source and the camera. If those two situations can't occur then not using capping is the best option.<br> Note that if you use the capping, you must either set the depth of view of your camera to something very large (f.i. 1e9), or you could use the infinite mode (csInfinitePerspective) of your camera. <ul> <li>svcDefault : Default behaviour <li>svcAlways : Always generates caps <li>svcNever : Never generates caps </ul>

TGLShadowVolumeCaster

GLShadowVolume

Specifies an individual shadow caster.<p> Can be a light or an opaque object.

TGLShadowVolumeCasters

GLShadowVolume

Collection of TGLShadowVolumeCaster.

TGLShadowVolumeLight

GLShadowVolume

Specifies an individual shadow casting light.<p>

TGLShadowVolumeMode

GLShadowVolume

Shadow rendering modes.<p> <ul> <li>svmAccurate : will render the scene with ambient lighting only, then for each light will make a diffuse+specular pass <li>svmDarkening : renders the scene with lighting on as usual, then darkens shadowed areas (i.e. inaccurate lighting, but will "shadow" objects that don't honour to diffuse or specular lighting) <li>svmOff : no shadowing will take place </ul>

TGLShadowVolumeOccluder

GLShadowVolume

Specifies an individual shadow casting occluder.<p>

TGLShadowVolumeOption

GLShadowVolume

Shadow volume rendering options/optimizations.<p> <ul> <li>svoShowVolumes : make the shadow volumes visible <li>svoDesignVisible : the shadow are visible at design-time <li>svoCacheSilhouettes : cache shadow volume silhouettes, beneficial when some objects are static relatively to their light(s) <li>svoScissorClips : use scissor clipping per light, beneficial when lights are attenuated and don't illuminate the whole scene <li>svoWorldScissorClip : use scissor clipping for the world, beneficial when shadow receivers don't cover the whole viewer surface </ul>

TGLShadowVolumeOptions

GLShadowVolume

TGLshort

OpenGLTokens

TGLSilhouette

GLSilhouette

Base class storing a volume silhouette.<p> Made of a set of indexed vertices defining an outline, and another set of indexed vertices defining a capping volume. Coordinates system is the object's unscaled local coordinates system.<br> This is the base class, you can use the TGLSilhouette subclass if you need some helper methods for generating the indexed sets.

TGLSilhouetteParameters

GLSilhouette

Silouhette generation parameters.<p> SeenFrom and LightDirection are expected in local coordinates.

TGLSilhouetteStyle

GLSilhouette

TGLSimpleNavigation

GLSimpleNavigation

TGLSimpleNavigationAction

GLSimpleNavigation

TGLSimpleNavigationKeyCombination

GLSimpleNavigation

TGLSimpleNavigationKeyCombinations

GLSimpleNavigation

TGLSimpleNavigationOption

GLSimpleNavigation

TGLSimpleNavigationOptions

GLSimpleNavigation

TGLSize

GLRenderContextInfo

TGLsizei

OpenGLTokens

TGLsizeiptr

OpenGLTokens

TGLSkyBox

GLSkyBox

TGLSkyBoxStyle

GLSkyBox

TGLSkyDome

GLSkydome

Renders a sky dome always centered on the camera.<p> If you use this object make sure it is rendered *first*, as it ignores depth buffering and overwrites everything. All children of a skydome are rendered in the skydome's coordinate system.<p> The skydome is described by "bands", each "band" is an horizontal cut of a sphere, and you can have as many bands as you wish.<p> Estimated CPU cost (K7-500, GeForce SDR, default bands):<ul> <li>800x600 fullscreen filled: 4.5 ms (220 FPS, worst case) <li>Geometry cost (0% fill): 0.7 ms (1300 FPS, best case) </ul>

TGLSLanguage

GLSLanguage

Àáñòðàêòíûé êëàññ, äëÿ ïàëèòðû êîìïîíåíòîâ<p>

TGLSLBumpShader

GLSLBumpShader

TGLSLBumpShaderAM

GLSLBumpShader

TGLSLBumpShaderMT

GLSLBumpShader

TGLSLDataType

GLSLParameter

TGLSLDiffuseSpecularShader

GLSLDiffuseSpecularShader

TGLSLDiffuseSpecularShaderAM

GLSLDiffuseSpecularShader

TGLSLDiffuseSpecularShaderMT

GLSLDiffuseSpecularShader

TGLSLHandle

GLContext

Base class for GLSL handles (programs and shaders).<p> Do not use this class directly, use one of its subclasses instead.

TGLSLMLBumpShader

GLSLBumpShader

TGLSLMLBumpShaderMT

GLSLBumpShader

TGLSLMLDiffuseSpecularShader

GLSLDiffuseSpecularShader

TGLSLMLDiffuseSpecularShaderMT

GLSLDiffuseSpecularShader

TGLSLogger

GLSLog

TGLSLPostBlurShader

GLSLPostBlurShader

TGLSLProjectedTextures

GLSLProjectedTextures

Projected Texture Manager.<p> Specifies active Emitters and receivers (children of this object). At the moment, only 1 texture can be used.

TGLSLProjectedTexturesStyle

GLSLProjectedTextures

TGLSLSamplerType

GLSLParameter

TGLSLShader

GLSLShader

TGLSLShaderEvent

GLSLShader

TGLSLShaderEventEx

GLSLShader

TGLSLShaderParameter

GLSLShader

Wrapper around a parameter of a GLSL program.

TGLSLShaderUnApplyEvent

GLSLShader

TGLSLTextureEmitter

GLSLProjectedTextures

A projected texture emmiter.<p> Can be places anywhere in the scene. Used to generate a modelview and texture matrix for the shader

TGLSLTextureEmitterItem

GLSLProjectedTextures

Specifies an item on the TGLSLTextureEmitters collection.

TGLSLTextureEmitters

GLSLProjectedTextures

Collection of TGLSLTextureEmitter.

TGLSMBASS

GLSMBASS

TGLSMDVectorFile

GLFileSMD

The SMD vector file is Half-life's skeleton format.<p> The SMD is a text-based file format. They come in two flavors: one that old Skeleton and triangle (mesh) data, and animation files that store Skeleton frames.<p> This reader curently reads both, but requires that the main file (the one with mesh data) be read first.

TGLSMemo

GLSMemo

TGLSMemoAbstractScrollableObject

GLSMemo

TGLSMemoDelCharUndo

GLSMemo

TGLSMemoDeleteBufUndo

GLSMemo

TGLSMEmoDelLineUndo

GLSMemo

TGLSMemoGutter

GLSMemo

TGLSMemoInsCharUndo

GLSMemo

TGLSMemoPasteUndo

GLSMemo

TGLSMemoScrollBar

GLSMemo

TGLSMemoSelUndo

GLSMemo

TGLSMemoStringList

GLSMemo

TGLSMemoStrings

GLSMemo

TGLSMemoUndo

GLSMemo

TGLSMemoUndoList

GLSMemo

TGLSMFMOD

GLSMFMOD

TGLSmoothNavigator

GLSmoothNavigator

TGLSmoothNavigator is the component for moving a TGLBaseSceneObject, and all classes based on it, this includes all the objects from the Scene Editor.<p>
It uses complex smoothing algorithms, most of which are FPS-dependant. Make sure your limit your FPS and set MaxExpectedDeltaTime to a value that is aproximatly 5 times less than your usual deltatime.

TGLSmoothOrbitToPos

GLCameraController

TGLSmoothOrbitToPosAdvJob

GLCameraController

TGLSmoothUserInterface

GLSmoothNavigator

TGLSmoothUserInterface is the component which reads the userinput and transform it into action.<p> <ul> <li>Mouselook(ADeltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works everywhere!) </ul> The four properties to get you started are: <ul> <li>InvertMouse : Inverts the mouse Y axis. <li>AutoUpdateMouse : If enabled (by defaul), than handles all mouse updates. <li>GLNavigator : The Navigator which receives the user movement. <li>GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras.... </ul>

TGLSMOpenAL

GLSMOpenAL

TGLSMWaveOut

GLSMWaveOut

Basic sound manager based on WinMM <i>waveOut</i> function.<p> This manager has NO 3D miximing capacity, this is merely a default manager that should work on any windows based system, and help showcasing/testing basic GLSS core functionality.<p> Apart from 3D, mute, pause, priority and volume are ignored too, and only sampling conversions supported by the windows ACM driver are supported (ie. no 4bits samples playback etc.).

TGLSOpenGLControl

GLWidgetContext

TGLSOpenGLForm

GLSceneForm

TGLSoundEnvironment

GLSound

EAX standard sound environments.

TGLSoundFile

GLSoundFileObjects

Abstract base class for different Sound file formats.<p> The actual implementation for these files (WAV, RAW...) must be done seperately. The concept for TGLSoundFile is very similar to TGraphic (see Delphi Help).<p> Default implementation for LoadFromFile/SaveToFile are to directly call the relevent stream-based methods, ie. you will just have to override the stream methods in most cases.

TGLSoundFileClass

GLSoundFileObjects

TGLSoundFileFormat

GLSoundFileObjects

TGLSoundFileFormatsList

GLSoundFileObjects

TGLSoundLibrary

GLSound

TGLSoundManager

GLSound

Base class for sound manager components.<p> The sound manager component is the interface to a low-level audio API (like DirectSound), there can only be one active manager at any time (this class takes care of this).<p> Subclass should override the DoActivate and DoDeActivate protected methods to "initialize/unitialize" their sound layer, actual data releases should occur in destructor however.

TGLSoundSample

GLSound

Stores a single PCM coded sound sample.

TGLSoundSamples

GLSound

TGLSoundSampling

GLSoundFileObjects

Defines a sound sampling quality.

TGLSoundSource

GLSound

Origin of sound playback.<p> Just publishes the 'Origin' property.<p> Note that the "orientation" is the the source's Direction, ie. the "Z" vector.

TGLSoundSourceChange

GLSound

TGLSoundSourceChanges

GLSound

TGLSoundSources

GLSound

TGLSourcePFXDispersionMode

GLParticleFX

TGLSourcePFXEffect

GLParticleFX

Simple Particles Source.<p>

TGLSourcePFXPositionMode

GLParticleFX

TGLSourcePFXVelocityMode

GLParticleFX

TGLSpaceText

GLSpaceText

TGLSphere

GLObjects

TGLSprite

GLObjects

TGLSResourceStream

ApplicationFileIO

TGLSSynHiMemo

GLSMemo

TGLStarRecord

GLStarRecord

TGLState

GLState

Reflects all relevant (binary) states of OpenGL subsystem

TGLStateCache

GLState

Manages an application-side cache of OpenGL states and parameters.<p> Purpose of this class is to eliminate redundant state and parameter changes, and there will typically be no more than one state cache per OpenGL context.

TGLStates

GLState

TGLStateType

GLState

TGLStateTypes

GLState

TGLStaticImposterBuilder

GLImposter

Builds imposters whose texture is a catalog of prerendered views.

TGLStaticImposterBuilderCorona

GLImposter

Describes a set of orientation in a corona fashion.

TGLStaticImposterBuilderCoronas

GLImposter

TGLStencilPrecision

GLFBO

TGLStencilRBO

GLFBO

TGLSTLVectorFile

GLFileSTL

The STL vector file (stereolithography format).<p> It is a list of the triangular surfaces that describe a computer generated solid model. This is the standard input for most rapid prototyping machines.<p> There are two flavors of STL, the "text" and the "binary", this class reads both, but exports only the "binary" version.<p> Original Binary importer code by Paul M. Bearne, Text importer by Adem.

TGLString

OpenGLTokens

TGLStringGrid

GLWindows

TGLsync

OpenGLTokens

TGLTeapot

GLTeapot

The classic teapot.<p> The only use of this object is as placeholder for testing...

TGLTerrainBaseHDS

GLHeightData

TGLTerrainRenderer

GLTerrainRenderer

TGLTessControlShaderHandle

GLContext

Manages a handle to a Tessellation Control Shader Object.

TGLTessEvaluationShaderHandle

GLContext

Manages a handle to a Tessellation Evaluation Shader Object.

TGLTexCombineShader

GLTexCombineShader

A shader that can setup the texture combiner.<p>

TGLTextAdjust

GLSpaceText

TGLTextHorzAdjust

GLSpaceText

TGLTextLayout

GLCrossPlatform

TGLTexture

GLTexture

Defines basic texturing properties.<p> You can control texture wrapping, smoothing/filtering and of course define the texture map (note that texturing is disabled by default).<p> A built-in mechanism (through ImageAlpha) allows auto-generation of an Alpha channel for all bitmaps (see TGLTextureImageAlpha).

TGLTextureBufferHandle

GLContext

Manages a handle to a Buffer Texture. (TBO)

TGLTextureChange

GLTexture

TGLTextureChanges

GLTexture

TGLTextureCombiner

GLMaterialEx

TGLTextureCompareMode

GLTextureFormat

TGLTextureCompression

GLTexture

TGLTexturedHDS

GLTexturedHDS

TGLTextureEmitter

GLProjectedTextures

A projected texture emmiter.<p> It's material property will be used as the projected texture. Can be places anywhere in the scene.

TGLTextureEmitterItem

GLProjectedTextures

Specifies an item on the TGLTextureEmitters collection.

TGLTextureEmitters

GLProjectedTextures

Collection of TGLTextureEmitter.

TGLTextureEx

GLTexture

TGLTextureExItem

GLTexture

TGLTextureFilteringQuality

GLTextureFormat

TGLTextureFormat

GLTexture

Texture format for OpenGL (rendering) use.<p> Internally, GLScene handles all "base" images as 32 Bits RGBA, but you can specify a generic format to reduce OpenGL texture memory use:<ul>

TGLTextureHandle

GLContext

Manages a handle to a texture.

TGLTextureImage

GLTexture

Base class for texture image data.<p> Basicly, subclasses are to be considered as different ways of getting a HBitmap (interfacing the actual source).<br> SubClasses should be registered using RegisterGLTextureImageClass to allow proper persistence and editability in the IDE experts.

TGLTextureImageAlpha

GLTexture

Defines how and if Alpha channel is defined for a texture image.<ul> <li>tiaDefault : uses the alpha channel in the image if any <li>tiaAlphaFromIntensity : the alpha channel value is deduced from other RGB components intensity (the brighter, the more opaque) <li>tiaSuperBlackTransparent : pixels with a RGB color of (0, 0, 0) are completely transparent, others are completely opaque <li>tiaLuminance : the luminance value is calculated for each pixel and used for RGB and Alpha values <li>tiaLuminanceSqrt : same as tiaLuminance but with an Sqrt(Luminance) <li>tiaOpaque : alpha channel is uniformously set to 1.0 <li>tiaTopLeftPointColorTransparent : points of the same color as the top left point of the bitmap are transparent, others are opaque. </ul>

TGLTextureImageClass

GLTexture

TGLTextureImageEditor

GLTextureImageEditors

TGLTextureImageEditorClass

GLTextureImageEditors

TGLTextureImageEx

GLMaterialEx

TGLTextureImageProperty

GLSceneRegister

TGLTextureLensFlare

GLTexLensFlare

TGLTextureMappingMode

GLTexture

TGLTextureMode

GLTexture

TGLTextureProperties

GLMaterialEx

TGLTextureProperty

GLSceneRegister

TGLTextureSampler

GLMaterialEx

TGLTextureSharingShader

GLTextureSharingShader

TGLTextureSharingShaderMaterial

GLTextureSharingShader

TGLTextureSharingShaderMaterials

GLTextureSharingShader

TGLTextureSwizzle

GLTextureFormat

TGLTextureSwizzling

GLMaterialEx

Swizzle the components of a texture fetches in shader or fixed-function pipeline.

TGLTextureTarget

GLTextureFormat

TGLTextureWrap

GLTexture

TGLTextVertAdjust

GLSpaceText

TGLTGAImage

GLFileTGA

TGLThorFXManager

GLThorFX

TGLTiledArea

GLTilePlane

Stores tile information in a tiled area.<p> Each tile stores an integer value with zero the default value, assumed as "empty".

TGLTiledAreaRow

GLTilePlane

Stores row information for a tiled area.<p>

TGLTilePlane

GLTilePlane

A tiled textured plane.<p> This plane object stores and displays texture tiles that composes it, and is optimized to minimize texture switches when rendering.<br> Its bounding dimensions are determined by its painted tile.

TGLTimeEventsMGR

GLTimeEventsMgr

TGLTimerQueryHandle

GLContext

Manages a handle to a timer query.<br> Requires GL_EXT_timer_query extension.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.

TGLTINVectorFile

GLFileTIN

The TIN vector file (triangle irregular network).<p> It is a simple text format, with one triangle record per line, no materials, no texturing (there may be more, but I never saw anything in this files).<p> This format is encountered in the DEM/DTED world and used in place of grids.

TGLTorus

GLGeomObjects

TGLTrail

GLTrail

TGLTransformation

GLPipelineTransformation

TGLTransformFeedbackBufferHandle

GLContext

Manages a handle to a Transform Feedback Buffer Object.<p> Transform feedback buffers can be used to capture vertex data from the vertex or geometry shader stage to perform further processing without going on to the fragment shader stage.

TGLTransformFeedBackMode

GLCustomShader

TGLTree

GLTree

TGLTreeBranch

GLTree

TGLTreeBranches

GLTree

TGLTreeBranchNoise

GLTree

TGLTreeLeaves

GLTree

TGLubyte

OpenGLTokens

TGLuint

OpenGLTokens

TGLuint64

OpenGLTokens

TGLuint64EXT

OpenGLTokens

TGLUniformBufferHandle

GLContext

Manages a handle to a Uniform Buffer Object (UBO). Uniform buffer objects store "uniform blocks"; groups of uniforms that can be passed as a group into a GLSL program.

TGLUnpackPBOHandle

GLContext

Manages a handle to PBO Pixel Unpack Buffer.<p> When bound, commands such as DrawPixels read their data from a buffer object.

TGLUNurbs

OpenGLTokens

TGLUNurbsErrorProc

OpenGLTokens

TGLUNurbsObj

OpenGLTokens

TGLUpdateAbleComponent

BaseClasses

A base class describing the "update" interface.<p>

TGLUpdateAbleObject

BaseClasses

An abstract class describing the "update" interface.<p>

TGLUQuadric

OpenGLTokens

TGLUQuadricErrorProc

OpenGLTokens

TGLUQuadricObj

OpenGLTokens

TGLUserInputCommand

GLConsole

Stores info on a command. A command is a parsed input line. Should be transformed into a class, I think...

TGLUserInterface

GLNavigator

TGLUserInterface is the component which reads the userinput and transform it into action.<p>
The four calls to get you started is <ul> <li>MouseLookActivate : set us up the bomb. <li>MouseLookDeActivate : defuses it. <li>Mouselook(deltaTime: double) : handles mouse look... Should be called in the Cadencer event. (Though it works every where!) <li>MouseUpdate : Resets mouse position so that you don't notice that the mouse is limited to the screen should be called after Mouselook. </ul> The four properties to get you started are: <ul> <li>InvertMouse : Inverts the mouse Y axis. <li>MouseSpeed : Also known as mouse sensitivity. <li>GLNavigator : The Navigator which receives the user movement. <li>GLVertNavigator : The Navigator which if set receives the vertical user movement. Used mostly for cameras.... </ul>

TGLUserShader

GLUserShader

TGLushort

OpenGLTokens

TGLUTessBeginDataProc

OpenGLTokens

TGLUTessBeginProc

OpenGLTokens

TGLUTessCombineDataProc

OpenGLTokens

TGLUTessCombineProc

OpenGLTokens

TGLUTessEdgeFlagDataProc

OpenGLTokens

TGLUTessEdgeFlagProc

OpenGLTokens

TGLUTesselator

OpenGLTokens

TGLUTesselatorObj

OpenGLTokens

TGLUTessEndDataProc

OpenGLTokens

TGLUTessEndProc

OpenGLTokens

TGLUTessErrorDataProc

OpenGLTokens

TGLUTessErrorProc

OpenGLTokens

TGLUTessVertexDataProc

OpenGLTokens

TGLUTessVertexProc

OpenGLTokens

TGLUTriangulatorObj

OpenGLTokens

TGLVBOArrayBufferHandle

GLContext

Manages a handle to VBO Array Buffer.<p> Typically used to store vertices, normals, texcoords, etc.

TGLVBOElementArrayHandle

GLContext

Manages a handle to VBO Element Array Buffer.<p> Typically used to store vertex indices.

TGLVBOHandle

GLContext

Manages a handle to an Vertex Buffer Object.<br> Does *NOT* check for extension availability, this is assumed to have been checked by the user.<br> Do not use this class directly, use one of its subclasses instead.

TGLvdpauSurfaceNV

OpenGLTokens

TGLVector2D

GLTypes

TGLVector2DType

GLTypes

TGLVector3D

GLTypes

TGLVector3DType

GLTypes

TGLVerletNode

GLVerletClasses

Specialized verlet node that can be anchored to a GLScene object. If it's anchored and has the property "NailedDown" set, it will remain in the same relative position to the GLScene object.

TGLVertexArrayHandle

GLContext

Manages a handle to a Vertex Array Object (VAO). Vertex array objects are used to rapidly switch between large sets of array state.

TGLVertexAttribute

GLSCUDAGraphics

TGLVertexAttributes

GLSCUDAGraphics

TGLVertexProgram

GLCustomShader

TGLVertexShaderHandle

GLContext

Manages a handle to a Vertex Shader Object.

TGLVfsPAK

GLVfsPAK

TGLVirtualHandle

GLContext

A context handle with event-based handle allocation and destruction.

TGLVirtualHandleEvent

GLContext

TGLVirtualHandleTransf

GLContext

Transferable virtual handle.

TGLVisibilityCulling

GLRenderContextInfo

Determines the visibility culling mode. Culling is done level by level, allowed values are:<ul> <li>vcInherited : use inherited culling value, if selected for the root level, defaults to vcNone <li>vcNone : no visibility culling is performed <li>vcObjectBased : culling is done on a per-object basis, each object may or may not be culled base on its own AxisAlignedDimensions, culling has no impact on the visibility of its children <li>vcHierarchical : culling is performed hierarchically, using hierarchical bounding boxes, if a parent is culled, all of its children, whatever their culling options are invisible. <li><br>Depending on the structure of your scene the most efficient culling method will be either vcObjectBased or vcHierarchical. Also note that if you use many objects with "static" geometry and have a T&amp;L graphics board, it may be faster not to cull at all (ie. leave this to the hardware).

TGLVisibilityDeterminationEvent

GLObjects

TGLVRMLVectorFile

GLFileVRML

TGLWaterPlane

GLWaterPlane

TGLWaterPlaneOption

GLWaterPlane

TGLWaterPlaneOptions

GLWaterPlane

TGLWAVFile

GLFileWAV

Support for Windows WAV format.

TGLWidgetContext

GLWidgetContext

TGLWin32Context

GLWin32Context

A context driver for standard Windows OpenGL (via MS OpenGL).

TGLWindowsBitmapFont

GLWindowsFont

A bitmap font automatically built from a TFont.<p> It works like a TGLBitmapfont, you set ranges and which chars are assigned to which indexes, however here you also set the Font property to any TFont available to the system and it renders in GLScene as close to that font as posible, on some font types this is 100% on some a slight difference in spacing can occur at most 1 pixel per char on some char combinations.<p> Ranges must be sorted in ascending ASCII order and should not overlap. As the font texture is automatically layed out, the Ranges StartGlyphIdx property is ignored and replaced appropriately.

TGLXVectorFile

GlFileX

TGLXYZGrid

GLGraph

TGLzBuffer

GLzBuffer

TGLZoomToDistanceJob

GLCameraController

TGLZShadows

GLzBuffer

TGPUDevice

OpenGLTokens

TGraphicClass

GLCrossPlatform

TGrowMethod

SpatialPartitioning

TGUIAlignments

GLGui

TGUIDrawResult

GLGui

TGUIRect

GLGui

TGUISkinEditor

GuiSkinEditorFormUnit

TGUISkinEditor

GuiSkinEditorFormUnitLCL

TGutterClickEvent

GLSMemo

TGutterDrawEvent

GLSMemo

THalfFloat

GLCrossPlatform

THDRImage

HDRImage

THDTextureCoordinatesMode

GLHeightData

THeightData

GLHeightData

THeightDataClass

GLHeightData

THeightDataPostRenderEvent

GLTerrainRenderer

THeightDataSource

GLHeightData

THeightDataSourceFilter

GLHeightData

THeightDataState

GLHeightData

THeightDataThread

GLHeightData

THeightDataType

GLHeightData

THeightDataUser

GLHeightData

THeightField

GLNGDManager

THeightFieldColorMode

GLGraph

THeightFieldGetHeight2Event

GLGraph

THeightFieldGetHeightEvent

GLGraph

THeightFieldOption

GLGraph

THeightFieldOptions

GLGraph

THeightTile

HeightTileFile

THeightTileFile

HeightTileFile

Interfaces a Tiled file

THeightTileInfo

HeightTileFile

THideTrackTag

Types3DS

THintType

GLState

THiShadowBias

Types3DS

THmgBoundingBox

GeometryBB

THmgPlane

VectorGeometry

A plane equation.<p> Defined by its equation A.x+B.y+C.z+D<p>, a plane can be mapped to the homogeneous space coordinates, and this is what we are doing here.<br> The typename is just here for easing up data manipulation.

THomogeneousByteMatrix

VectorGeometry

THomogeneousByteVector

VectorGeometry

THomogeneousDblMatrix

VectorGeometry

THomogeneousDblVector

VectorGeometry

THomogeneousExtMatrix

VectorGeometry

THomogeneousExtVector

VectorGeometry

THomogeneousFltMatrix

VectorGeometry

THomogeneousFltVector

VectorGeometry

THomogeneousIntMatrix

VectorGeometry

THomogeneousIntVector

VectorGeometry

THomogeneousMatrix

VectorGeometry

THomogeneousPtrVector

VectorGeometry

THomogeneousVector

VectorGeometry

THomogeneousWordMatrix

VectorGeometry

THomogeneousWordVector

VectorGeometry

THotTrackTag

Types3DS

THTFHeader

HeightTileFile

TI1

LWObjects

TI2

LWObjects

TI4

LWObjects

TICCOMPRESS

GLSVfw

TICCOMPRESSFRAMES

GLSVfw

TICCompressProc

GLSVfw

TICDECOMPRESS

GLSVfw

TICDECOMPRESSEX

GLSVfw

TICDRAW

GLSVfw

TICDRAWBEGIN

GLSVfw

TICDRAWSUGGEST

GLSVfw

TICINFO

GLSVfw

TICOPEN

GLSVfw

TICPALETTE

GLSVfw

TICSETSTATUSPROC

GLSVfw

TICStatusProc

GLSVfw

TID4

LWObjects

TID4DynArray

LWObjects

TIDELogProc

GLSLog

TIdleEvent

GLAsyncHDS

TImageAlphaProc

ImageUtils

TImageFilterFunction

ImageUtils

TIMER_RESOLUTION

GLSDL

time_t

LIBPNG

TImposter

GLImposter

Base class for imposters manipulation and handling.<br> Rendering imposters is performed by three methods, BeginRender must be invoked first, then Render for each of the impostr This class assumes a single impostor per texture.
Note: Remeber to enable Destination Alpha on your viewer.

TImposterLoadedEvent

GLImposter

TImposterOption

GLImposter

Imposter rendering options.<p> Following options are supported:<ul> <li>impoBlended : the imposters are transparently blended during renders, this will smooth their edges but requires them to be rendered sorted from back to front <li>impoAlphaTest : alpha test is used to eliminate transparent pixels, the alpha treshold is adjusted by the AlphaTreshold property <li>impoNearestFiltering : use nearest texture filtering (the alternative is linear filtering) <li>impoPerspectiveCorrection : activates a special imposter rendering projection suitable for distorting the sprites when seen from a level angle of view with a wide focal camera (think trees/grass when walking in a forest), if not active, the imposter sprites are camera-facing </ul>

TImposterOptions

GLImposter

TImposterReference

GLImposter

TIndexList

TypesMD2

TInfoForm

Info

TInfoForm

InfoLCL

TInfoLabelCoordType

GLGizmoEx

TInFunc

LIBPNG

TIntegerArray

Types3DS

TIntegerArray

HeightTileFile

TIntegerList

VectorLists

A list of Integers.<p> Similar to TList, but using TTexPoint as items.<p> The list has stack-like push/pop methods.

TIntegerVector

VectorGeometry

TIntermediateFormat

ImageUtils

TIntermediateFormatArray

ImageUtils

TIntPercentage

Types3DS

TInvokeInfoForm

GLScene

TIpasData

Types3DS

TJointFlag

ODEImport

TJointInfo1

ODEImport

TJointInfo2

ODEImport

TJointOption

GLODEManager

TJointOptions

GLODEManager

TJointParams

ODEImport

TJoyAxis

Joystick

TJoyPos

Joystick

TJoystick

Joystick

A component interfacing the Joystick via the (regular) windows API.

TJoystickButton

Joystick

TJoystickButtons

Joystick

TJoystickDesignMode

Joystick

TJoystickEvent

Joystick

TJoystickID

Joystick

TJoystick_hwdata

GLSDL

TJPEGContext

GLSJPG

TJPEGPixelFormat

GLSJPG

TJPGColorDepth

GLSJPG

TKeyFramer

File3DS

TKeyHeader3DS

Types3DS

TKeyHeaderList

Types3DS

TKEYSChunk

TypesB3D

TKeyStateArr

GLSDL

TKFAmbient3DS

Types3DS

TKFCamera3DS

Types3DS

TKFCurtime

Types3DS

TKFHdr

Types3DS

TKFId

Types3DS

TKFKeyInfo3DS

Types3DS

TKFMesh3DS

Types3DS

TKFMorphKey3DS

Types3DS

TKFMorphKeyList

Types3DS

TKFOmni3DS

Types3DS

TKFRotKey3DS

Types3DS

TKFRotKeyList

Types3DS

TKFSeg

Types3DS

TKFSegment3DS

Types3DS

TKFSets3DS

Types3DS

TKFSpot3DS

Types3DS

TLanguage

GLSLanguage

TLanguageEntry

GLSLanguage

TLanguageEntryArray

GLSLanguage

TLanguageExt

GLSLanguage

TLayerFog

Types3DS

TLayerFogFalloff3DS

Types3DS

TLayerFogSettings3DS

Types3DS

Tlayouts_form

FGUILayoutEditor

TLeavedSpacePartition

SpatialPartitioning

TLibArchive

GLSArchiveManager

TLibArchives

GLSArchiveManager

TLibMaterialPicker

FLibMaterialPicker

TLibMaterialPicker

FLibMaterialPickerLCL

TLight3DS

Types3DS

TLightDir2TexEnvColor

GLMaterialEx

TLightSourceState

GLState

TLightStyle

GLScene

Defines the various styles for lightsources.<p> <ul> <li>lsSpot : a spot light, oriented and with a cutoff zone (note that if cutoff is 180, the spot is rendered as an omni source) <li>lsOmni : an omnidirectionnal source, punctual and sending light in all directions uniformously <li>lsParallel : a parallel light, oriented as the light source is (this type of light can help speed up rendering) </ul>

TLimitType

GLScene

TLinColor24

Types3DS

TLinColorF

Types3DS

TLineNodesAspect

GLObjects

TLineProp

GLSMemo

TLinesOption

GLObjects

TLinesOptions

GLObjects

TLineSplineMode

GLObjects

TLiteAttenuate3DS

Types3DS

TLMTS

GLFileLMTS

TLMTS_Header

GLFileLMTS

TLMTS_Subset

GLFileLMTS

TLMTS_TexData

GLFileLMTS

TLMTS_Vertex

GLFileLMTS

TLoadingImposterEvent

GLImposter

TLoadProgress

File3DS

TLogBufferFlushThread

GLSLog

Thread that periodically flushes the buffer to disk.

TLogBufferingMode

GLSLog

How log is buffered.

TLogCheckSizeThread

GLSLog

Thread that checks file size and splits the file if nessesary.

TLogicOp

GLState

TLogLevel

GLSLog

TLogLevels

GLSLog

TLogMessageLimitAction

GLSLog

What to do when number of messages exceeds message limit.

TLogSession

GLSLog

Abstract Logger class

TLogTimeFormat

GLSLog

TLongWordList

VectorLists

TLongWordVector

VectorGeometry

TLoShadowBias

Types3DS

TLWChunk

LWObjects

TLWChunkClass

LWObjects

TLWChunkFind

LWObjects

TLWChunkList

LWObjects

TLWChunkRec

LWObjects

TLWClip

LWObjects

TLWContentDir

LWObjects

TLWContentNotify

LWObjects

TLWLayr

LWObjects

TLWObjectFile

LWObjects

TLWOReadCallback

LWObjects

TLWParentChunk

LWObjects

TLWPnts

LWObjects

TLWPntsInfo

LWObjects

TLWPntsInfoDynArray

LWObjects

TLWPols

LWObjects

TLWPolsDynArray

LWObjects

TLWPolsInfo

LWObjects

TLWPolsInfoDynArray

LWObjects

TLWPolyTagMap

LWObjects

TLWPolyTagMapDynArray

LWObjects

TLWPTag

LWObjects

TLWSubChunk

LWObjects

TLWSubChunkRec

LWObjects

TLWSurf

LWObjects

TLWTags

LWObjects

TLWVertexMap

LWObjects

TLWVertexMapDynArray

LWObjects

TLWVMap

LWObjects

TM3dVersion

Types3DS

TMainAVIHeader

GLSVfw

TMapInfo3DS

Types3DS

TMapSet3DS

Types3DS

TMapTexCoordMode

XOpenGL

TMarkDirtyEvent

GLHeightData

TMarkStyle

GLTrail

TMasterScale

Types3DS

TMatAcubic

Types3DS

TMatBumpPercent

Types3DS

TMaterial3DS

Types3DS

TMaterialEditorForm

FMaterialEditorForm

TMaterialEditorForm

FMaterialEditorFormLCL

TMaterialInfo

GLFileLMTS

TMaterialList

File3DS

TMaterialOption

GLMaterial

Control special rendering options for a material.<p> moIgnoreFog : fog is deactivated when the material is rendered

TMaterialOptions

GLMaterial

TMatMapAng

Types3DS

TMatMapBCol

Types3DS

TMatMapCol1

Types3DS

TMatMapCol2

Types3DS

TMatMapGCol

Types3DS

TMatMapRCol

Types3DS

TMatMapTexblur

Types3DS

TMatMapTiling

Types3DS

TMatMapUOffset

Types3DS

TMatMapUScale

Types3DS

TMatMapVOffset

Types3DS

TMatMapVScale

Types3DS

TMatrix

VectorGeometry

TMatrix2b

VectorTypes

TMatrix2d

VectorTypes

TMatrix2e

VectorTypes

TMatrix2f

VectorTypes

TMatrix2i

VectorTypes

TMatrix2p

VectorTypes

TMatrix2s

VectorTypes

TMatrix2w

VectorTypes

TMatrix3b

VectorTypes

TMatrix3d

VectorTypes

TMatrix3e

VectorTypes

TMatrix3f

VectorTypes

TMatrix3i

VectorTypes

TMatrix3p

VectorTypes

TMatrix3s

VectorTypes

TMatrix3w

VectorTypes

TMatrix4b

VectorTypes

TMatrix4d

VectorTypes

TMatrix4e

VectorTypes

TMatrix4f

VectorTypes

TMatrix4i

VectorTypes

TMatrix4p

VectorTypes

TMatrix4s

VectorTypes

TMatrix4w

VectorTypes

TMatrixArray

VectorGeometry

TMatShading

Types3DS

TMatWireSize

Types3DS

TMaxCLODTrianglesReachedEvent

GLTerrainRenderer

TMD2AliasFrame

TypesMD2

TMD2Header

TypesMD2

TMD2Triangle

TypesMD2

TMD2TriangleVertex

TypesMD2

TMD2VertexIndex

TypesMD2

TMD3Bone

FileMD3

TMD3Face

FileMD3

TMD3Header

FileMD3

TMD3MeshData

FileMD3

TMD3MeshHeader

FileMD3

TMD3Skin

FileMD3

TMD3Tag

FileMD3

TMD3TagList

Q3MD3

TMD3TexCoord

FileMD3

TMD3Triangle

FileMD3

TMDCAngle

TypesMDC

TMDCBaseFrame

TypesMDC

TMDCBaseVertex

TypesMDC

TMDCBorderFrame

TypesMDC

TMDCCompFrame

TypesMDC

TMDCCompVertex

TypesMDC

TMDCFileHeader

TypesMDC

TMDCPoint

TypesMDC

TMDCSkin

TypesMDC

TMDCSurfaceHeader

TypesMDC

TMDCTag

TypesMDC

TMDCTagFrame

TypesMDC

TMDCTagName

TypesMDC

TMDCTexCoord

TypesMDC

TMDCTriangle

TypesMDC

TMem

GLSDL

TMesh3DS

Types3DS

TMeshAutoCentering

GLVectorFileObjects

TMeshAutoCenterings

GLVectorFileObjects

TMESHChunk

TypesB3D

TMeshColor

Types3DS

TMeshMatrix

Types3DS

TMeshMode

GLMesh

TMeshMorphTarget

GLVectorFileObjects

A morph target, stores alternate lists of vertices and normals.

TMeshMorphTargetList

GLVectorFileObjects

A list of TMeshMorphTarget objects.

TMeshNormalsOrientation

GLVectorFileObjects

Determines how normals orientation is defined in a mesh.<p> - mnoDefault : uses default orientation<br> - mnoInvert : inverse of default orientation<br> - mnoAutoSolid : autocalculate to make the mesh globally solid<br> - mnoAutoHollow : autocalculate to make the mesh globally hollow<br>

TMeshObject

GLVectorFileObjects

Base mesh class.<p> Introduces base methods and properties for mesh objects.<p> Subclasses are named "TMOxxx".

TMeshObjectList

GLVectorFileObjects

A list of TMeshObject objects.

TMeshObjectListClass

GLVectorFileObjects

TMeshObjectMode

GLVectorFileObjects

TMeshObjectRenderingOption

GLVectorFileObjects

Rendering options per TMeshObject.<p> <ul> <li>moroGroupByMaterial : if set, the facegroups will be rendered by material in batchs, this will optimize rendering by reducing material switches, but also implies that facegroups will not be rendered in the order they are in the list. </ul>

TMeshObjectRenderingOptions

GLVectorFileObjects

TMeshObjectVerletNode

GLVerletClothify

TMeshOptimizerOption

GLMeshOptimizer

TMeshOptimizerOptions

GLMeshOptimizer

TMeshSet3DS

Types3DS

TMeshTextureInfo

Types3DS

TMeshVersion

Types3DS

TMipmapGenerationMode

GLMaterialEx

TMirrorOption

GLMirror

TMirrorOptions

GLMirror

TMirrorShapes

GLMirror

TModuleHandle

GLSModuleLoader

TMOParametricSurface

GLParametricSurfaces

TMorphableMeshObject

GLVectorFileObjects

Mesh object with support for morph targets.<p> The morph targets allow to change vertices and normals according to pre- existing "morph targets".

TMorphSmooth

Types3DS

TMorphTrackTag

Types3DS

TMS3DComment

TypesMS3D

TMS3DCommentList

TypesMS3D

TMS3DGroup

TypesMS3D

TMS3DHeader

TypesMS3D

TMS3DJoint

TypesMS3D

TMS3DJointArray

TypesMS3D

TMS3DJointBase

TypesMS3D

TMS3DKeyframePosition

TypesMS3D

TMS3DKeyframePositionArray

TypesMS3D

TMS3DKeyframeRotation

TypesMS3D

TMS3DKeyframeRotationArray

TypesMS3D

TMS3DMaterial

TypesMS3D

TMS3DTriangle

TypesMS3D

TMS3DTriangleArray

TypesMS3D

TMS3DVertex

TypesMS3D

TMS3DVertexArray

TypesMS3D

TMS3D_vertex_ex_t

TypesMS3D

TMshBoxmap

Types3DS

TMshMatGroup

Types3DS

TMultiPolygonBase

GLMultiPolygon

Multipolygon is defined with multiple contours.<p> The contours have to be in the X-Y plane, otherwise they are projected to it (this is done automatically by the tesselator).<br> The plane normal is pointing in +Z. All contours are automatically closed, so there is no need to specify the last node equal to the first one.<br> Contours should be defined counterclockwise, the first contour (index = 0) is taken as is, all following are reversed. This means you can define the outer contour first and the holes and cutouts after that. If you give the following contours in clockwise order, the first contour is extended.<p>
TMultiPolygonBase will take the input contours and let the tesselator make an outline from it (this is done in RetreiveOutline). This outline is used for Rendering. Only when there are changes in the contours, the outline will be recalculated. The ouline in fact is a list of VectorLists.

TNCamera

Types3DS

TNDirectLight

Types3DS

TNewTilePreparedEvent

GLBumpmapHDS

TNewTilePreparedEvent

GLShadowHDS

TNewTilePreparedEvent

GLAsyncHDS

TNewtonBoxParam

NewtonImport

TNewtonCapsuleParam

NewtonImport

TNewtonChamferCylinderParam

NewtonImport

TNewtonCollisionInfoRecord

NewtonImport

TNewtonCollisionNullParam

NewtonImport

TNewtonCollisionTreeParam

NewtonImport

TNewtonCompoundCollisionParam

NewtonImport

TNewtonConeParam

NewtonImport

TNewtonConvexHullModifierParam

NewtonImport

TNewtonConvexHullParam

NewtonImport

TNewtonCylinderParam

NewtonImport

TNewtonHeightFieldCollisionParam

NewtonImport

TNewtonSceneCollisionParam

NewtonImport

TNewtonSphereParam

NewtonImport

TNGDDebugOption

GLNGDManager

TNGDFrictionModels

GLNGDManager

TNGDJoint

GLNGDManager

TNGDJointBallAndSocket

GLNGDManager

TNGDJointHinge

GLNGDManager

TNGDJointKinematicController

GLNGDManager

TNGDJointPin

GLNGDManager

TNGDJointPin2

GLNGDManager

TNGDJointPivot

GLNGDManager

TNGDJointSlider

GLNGDManager

TNGDManagerDebug

GLNGDManager

TNGDManagerDebugs

GLNGDManager

TNGDNewtonCollisions

GLNGDManager

TNGDNewtonJoints

GLNGDManager

TNGDPickedActions

GLNGDManager

TNGDSolverModels

GLNGDManager

TNGDSurfaceItem

GLNGDManager

TNGDSurfacePair

GLNGDManager

TNmHeader

FileNMF

TNmRawTriangle

FileNMF

TNODEChunk

TypesB3D

TNodeHdr

Types3DS

TNodeList

Types3DS

TNormalDirection

GLScene

TNormalMapSpace

BumpMapping

TNormalSmoothing

GLObjects

TNotifyCollection

BaseClasses

TO3TCImage

O3TCImage

TObjectBBChange

GLScene

TObjectBBChanges

GLScene

TObjectChange

GLScene

TObjectChanges

GLScene

TObjectCollisionEvent

GLCollision

TObjectList

File3DS

TObjectListSortCompare

PersistentClasses

TObjectManager

GLObjectManager

TObjMat3DS

Types3DS

TObjMatList

Types3DS

TOConsts

Types3DS

TOCTFace

FileOCT

TOCTFile

FileOCT

TOCTHeader

FileOCT

TOCTLight

FileOCT

TOCTLightmap

FileOCT

TOctree

Octree

TOctreeNode

Octree

TOctreeSpacePartition

SpatialPartitioning

TOctreeTriangleInfo

Octree

TOCTTexture

FileOCT

TOCTVertex

FileOCT

TODECollisionEvent

GLODEManager

TODECollisionSurface

GLODEManager

TODECollisionSurfaceMode

GLODEManager

TODECustomCollisionEvent

GLODEManager

TODEElementBase

GLODEManager

TODEElementBox

GLODEManager

ODE box implementation.

TODEElementCapsule

GLODEManager

ODE capped cylinder implementation.

TODEElementClass

GLODEManager

TODEElementCylinder

GLODEManager

ODE cylinder implementation.

TODEElementPlane

GLODEManager

ODE plane implementation.

TODEElements

GLODEManager

TODEElementSphere

GLODEManager

ODE sphere implementation.

TODEElementTriMesh

GLODEManager

ODE tri-mesh implementation.

TODEGetParamCallback

GLODEManager

TODEJointBall

GLODEManager

ODE ball joint implementation.

TODEJointBase

GLODEManager

Base structures for ODE Joints.

TODEJointFixed

GLODEManager

ODE fixed joint implementation.

TODEJointHinge

GLODEManager

ODE hinge joint implementation.

TODEJointHinge2

GLODEManager

ODE hinge2 joint implementation.

TODEJointParams

GLODEManager

TODEJoints

GLODEManager

An XCollection decendant for ODE Joints.

TODEJointSlider

GLODEManager

ODE slider joint implementation.

TODEJointUniversal

GLODEManager

ODE universal joint implementation.

TODEObjectCollisionEvent

GLODEManager

TODERagdoll

GLODERagdoll

TODERagdollBone

GLODERagdoll

TODERagdollCube

GLODERagdoll

TODERagdollDummyJoint

GLODERagdoll

TODERagdollHingeJoint

GLODERagdoll

TODERagdollUniversalJoint

GLODERagdoll

TODERagdollWorld

GLODERagdoll

TODESetParamCallback

GLODEManager

TODESolverMethod

GLODEManager

ToDosPath

LWObjects

ToHex

GLSVfw

TOnAsmProgSetting

GLMaterialEx

TOnBeforeKernelLaunch

GLSCUDAGraphics

TOnCustomPerspective

GLScene

TOnDoApplyEvent

GLUserShader

TOnDoUnApplyEvent

GLUserShader

TOnHeightDataDirtyEvent

GLHeightData

TOnLightsChanged

GLState

TOnMatricesPush

GLPipelineTransformation

TOnOpenGLInteropInit

GLSCUDAContext

TOnPrepareHandleData

GLContext

TOnUniformInitialize

GLMaterialEx

TOnUniformSetting

GLMaterialEx

TopFalloff

Const3DS

TOptimise

GLzBuffer

TOrthoView3DS

Types3DS

ToUnixPath

LWObjects

TOutFunc

LIBPNG

TPackedRotationMatrix

VectorGeometry

TPAKArchive

GLFilePAK

TPakHeader

GLFilePAK

TPakHeader

GLVfsPAK

TParametricSurfaceBasis

GLParametricSurfaces

psbBezier indicates building the surface with Bernstein basis functions, no knot or order properties are used. psbBSpline indicates building the surface using BSpline basis functions, these require orders and knot vectors to define the control point influences on the surface.

TParametricSurfaceRenderer

GLParametricSurfaces

psrGLScene tells the surface to render using GLScene code to build the mesh, whereas, psrOpenGL uses glEvalMesh2 or gluNurbsRenderer calls to render the surface.

TParticleReference

GLParticleFX

TParticleReferenceArray

GLParticleFX

TPatchPostRenderEvent

GLTerrainRenderer

TPathTravelStartEvent

GLMovement

TPathTravelStopEvent

GLMovement

TPerlin3DNoise

PerlinNoise

Generates Perlin Noise in the [-1; 1] range.<p> 2D noise requests are taken in the Z=0 slice

TPersistentObject

PersistentClasses

Base class for persistent objects.<p> The base requirement is implementation of ReadFromFiler & WriteToFiler in sub-classes, the immediate benefits are support of streaming (to stream, file or string), assignment and cloning.<br> The other requirement being the use of a virtual constructor, which allows polymorphic construction (don't forget to register your subclasses).<p> Note that TPersistentObject implements IUnknown, but does *not* implement reference counting.

TPersistentObjectClass

PersistentClasses

TPersistentObjectList

PersistentClasses

A persistent Object list.<p> Similar to TList but works on TObject items and has facilities for persistence of contained data. Unlike the VCL's TObjectList, this one does NOT free its objects upon destruction or Clear, use Clean and CleanFree for that, and as such can be used for object referral lists too.<br> But only TPersistentObject items will be streamed appropriately.<p> The list can be used in a stack-like fashion with Push & Pop, and can perform basic boolean set operations.<p> Note: the IndexOf implementation is up to 3 times faster than that of TList

TPFXCreateParticleEvent

GLParticleFX

TPFXDirectRenderEvent

GLParticleFX

TPFXGetParticleCountEvent

GLParticleFX

TPFXLifeColor

GLParticleFX

TPFXLifeColors

GLParticleFX

TPFXParticleProgress

GLParticleFX

TPFXPrepareTextureImageEvent

GLParticleFX

TPFXProgressEvent

GLParticleFX

TPFXRegion

GLParticleFX

TPFXSortAccuracy

GLParticleFX

TPickRecord

GLSelection

TPickSortType

GLSelection

TPickSubObjects

GLSelection

TPictureFileProperty

GLSceneRegister

TPipeNodesColorMode

GLExtrusion

TPipeNormalMode

GLExtrusion

TPipePart

GLExtrusion

TPipeParts

GLExtrusion

TPipeTexCoordMode

GLExtrusion

TPIServices

PlugInIntf

TPIServiceType

PlugInIntf

TPivot

Types3DS

TPlanBB

GeometryBB

TPlaneStyle

GLObjects

TPlaneStyles

GLObjects

TPlanIndices

GeometryBB

TPlatformInfo

GLCrossPlatform

TPlatformVersion

GLCrossPlatform

TPlugInEntry

PlugInManager

TPlugInList

PlugInManager

TPlugInManager

PlugInManager

TPlugInManagerPropForm

PlugInManagerPropEditor

TPoint

GLCrossPlatform

TPoint

GLSDL

TPoint

GLSimpleNavigation

TPoint3DS

Types3DS

TPointArray

Types3DS

TPointerArray

ImageUtils

TPointerObjectList

PersistentClasses

TPointerVector

VectorGeometry

TPointFlagArray

Types3DS

TPointList

Types3DS

TPolygonList

GLMultiPolygon

TPolygonMode

GLState

TPolygonPart

GLGeomObjects

TPolygonParts

GLGeomObjects

TPortalMeshObjectList

GLPortal

A mesh object list that handles portal rendering.<p> The items are treated as being sectors.

TPosTrackTag

Types3DS

TPrecisionSetting

GLCgShader

TProcAffineAffineAffine

Octree

TProcInt

Octree

TProgressTimes

BaseClasses

TProjectTargetNameFunc

GLCrossPlatform

TPSImport_ApplicationFileIO

uPSI_ApplicationFileIO

TPSImport_GLStrings

uPSI_GLStrings

TPSImport_GLUtils

uPSI_GLUtils

TPSImport_PersistentClasses

uPSI_PersistentClasses

TPSImport_VectorGeometry

uPSI_VectorGeometry

TPSImport_VectorLists

uPSI_VectorLists

TPSImport_VectorTypes

uPSI_VectorTypes

TPSImport_XCollection

uPSI_XCollection

TQ3BSP

Q3BSP

TQuadtreeSpacePartition

SpatialPartitioning

TQuaternion

VectorGeometry

TQuaternionArray

VectorGeometry

TQuaternionList

VectorLists

A list of TQuaternion.<p> Similar to TList, but using TQuaternion as items.<p> The list has stack-like push/pop methods.

TQueryType

GLState

TrackHeaderKeysMin3DS

Const3DS

TrackLockX3DS

Const3DS

TrackLockY3DS

Const3DS

TrackLockZ3DS

Const3DS

TrackLoops3DS

Const3DS

TrackNoLinkX3DS

Const3DS

TrackNoLinkY3DS

Const3DS

TrackNoLinkZ3DS

Const3DS

TrackRepeats3DS

Const3DS

TrackSingle3DS

Const3DS

TRagdollBone

GLRagdoll

TRagdollBoneList

GLRagdoll

TRagdollJoint

GLRagdoll

TranslateMatrix

VectorGeometry

Adds the translation vector into the matrix

TranslateMatrix

VectorGeometry

TransposeMatrix

VectorGeometry

Computes transpose of 4x4 matrix

TransposeMatrix

VectorGeometry

Computes transpose of 3x3 matrix

TRasterFileFormat

GLGraphics

TRasterFileFormatsList

GLGraphics

Stores registered raster file formats.

TRayBias

Types3DS

TRColorEditor

FRColorEditor

TRColorEditor

FRColorEditorLCL

TRead

GLSDL

TRect

GLSDL

TRect

GLCrossPlatform

TRectangle

VectorGeometry

TReleaseLevel

Types3DS

TRenderContextClippingInfo

GLRenderContextInfo

TRenderContextInfo

GLRenderContextInfo

Stores contextual info useful during rendering methods.

TResManagerEntry

PlugInManager

TResolution

GLScreen

TResolutionProperty

GLSceneRegister

TResourceManager

PlugInManager

TReuseableDefaultEditor

GLSceneRegister

Editor copied from DsgnIntf.<p> Could have been avoided, if only that guy at Borland didn't chose to publish only half of the stuff (and that's not the only class with that problem, most of the subitems handling code in TGLSceneBaseObject is here for the same reason...), the "protected" wasn't meant just to lure programmers into code they can't reuse... Arrr! and he did that again in D6! Grrr...

TRevolutionSolidPart

GLExtrusion

TRevolutionSolidParts

GLExtrusion

TRFaceEditor

FRFaceEditor

TRFaceEditor

FRFaceEditorLCL

TRGBColor

GLColor

TRGBPixel

GLBlur

TRGBPixelBuffer

GLBlur

TriangleArea

VectorGeometry

Computes the triangle's area.

TriangleIntersectAABB

GeometryBB

TriangleSignedArea

VectorGeometry

Computes a 2D triangle's signed area.<p> Only X and Y coordinates are used, Z is ignored.

TrimAndSplitVersionString

OpenGL1x

TrimAndSplitVersionString

OpenGLAdapter

TRIMESH_FACE_NORMALS

ODEImport

TRIMESH_LAST_TRANSFORMATION

ODEImport

TRMapSet3DS

Types3DS

TRMaterialPreview

FRMaterialPreview

TRMaterialPreview

FRMaterialPreviewLCL

TROAMRenderPoint

GLROAMPatch

TROAMTriangleNode

GLROAMPatch

TRollTrackTag

Types3DS

TRotTrackTag

Types3DS

TRTextureEdit

FRTextureEdit

TRTextureEdit

FRTextureEditLCL

TRTrackBarEdit

FRTrackBarEdit

TRTrackBarEdit

FRTrackBarEditLCL

Trunc

VectorGeometry

TryStringToColorAdvanced

GLUtils

Converts a string into color

TryStrToFloat

GLUtils

Similar to SysUtils.TryStrToFloat, but ignores user's locale

TsbState

GLSMemo

TScaleTrackTag

Types3DS

TSceneObj

GLSpatialPartitioning

Object for holding glscene objects in a spatial partitioning

TSceneOperation

GLScene

TSCODEBase

GLODESkeletonColliders

Base ODE skeleton collider class.

TSCODEBox

GLODESkeletonColliders

Box shaped ODE geom in a skeleton collider.

TSCODECCylinder

GLODESkeletonColliders

Capsule (sphere capped cylinder) shaped ODE geom in a skeleton collider.

TSCODESphere

GLODESkeletonColliders

Sphere shaped ODE geom in a skeleton collider.

TScreenSaver

ScreenSaver

Drop this component on your main form to make it a screensaver.<p> You'll also need to change the extension from ".exe" to ".scr" (in the project options / application tab).<p> How this component works :<ul> <li>At design-time, the only event you may want to hook is OnPropertiesRequested (to diplay your screen-saver's config dialog, if you don't have one, at least fill in the AboutString property and it will be used in a ShowMessage) <li>At run-time, once its props are loaded, this component will parse the command line and trigger relevant events <li>Basicly, you only need to care about drawing in your main form's client area (in a resolution/size independant way if possible) </ul><br> There is no real difference between execution and preview modes, except for the events fired... and the size of the form :).

TScreenSaverOption

ScreenSaver

Options d'automatisation du screen-saver.<p> <ul> <li>ssoAutoAdjustFormProperties : all relevant properties of main form will be auto-adjusted (form style, border style, form size and for preview, ParentWindow). <li>ssoAutoHookKeyboardEvents : hooks to main form's OnKeyPress and closes screen saver when a key is pressed (form's KeyPreview is also set to True) <li>ssoAutoHookMouseEvents : hooks to main form's OnMouseMove and closes screen saver when mouse is moved (you mays have to handle other mouse move events manually if you have placed components on the form) <li>ssoEnhancedMouseMoveDetection : gets the mouse position every half-second and closes the saver if position changed (uses GetCursorPos and a TTimer) </ul>

TScreenSaverOptions

ScreenSaver

TScreenSaverPreviewEvent

ScreenSaver

This event is fired when screen saver should start in preview mode.<p> The passed hwnd is that of the small preview window in Windows Display Properties (or any other screen-saver previewing utility, so don't assume width/height is constant/universal or whatever).

TScrollMode

GLSMemo

TSCVerletBase

GLVerletSkeletonColliders

Base verlet skeleton collider class.

TSCVerletCapsule

GLVerletSkeletonColliders

Capsule shaped verlet constraint in a skeleton collider.

TSCVerletSphere

GLVerletSkeletonColliders

Sphere shaped verlet constraint in a skeleton collider.

TSDLEvent

GLSDLWindow

TSDLKey

GLSDL

TSDLMod

GLSDL

TSDLWindow

GLSDLWindow

TSDLWindowOption

GLSDLWindow

TSDLWindowOptions

GLSDLWindow

TSDLWindowPixelDepth

GLSDLWindow

TSDL_ActiveEvent

GLSDL

TSDL_AudioCVT

GLSDL

TSDL_AudioCVTFilter

GLSDL

TSDL_AudioCVTFilterArray

GLSDL

TSDL_AudioSpec

GLSDL

TSDL_Audiostatus

GLSDL

TSDL_Blit

GLSDL

TSDL_BlitInfo

GLSDL

TSDL_Bool

GLSDL

TSDL_CD

GLSDL

TSDL_CDStatus

GLSDL

TSDL_CDTrack

GLSDL

TSDL_Color

GLSDL

TSDL_ColorArray

GLSDL

TSDL_Cond

GLSDL

TSDL_Cursor

GLSDL

TSDL_error

GLSDL

TSDL_errorcode

GLSDL

TSDL_Event

GLSDL

TSDL_EventAction

GLSDL

TSDL_EventFilter

GLSDL

TSDL_ExposeEvent

GLSDL

TSDL_GLAttr

GLSDL

TSDL_GrabMode

GLSDL

TSDL_JoyAxisEvent

GLSDL

TSDL_JoyBallEvent

GLSDL

TSDL_JoyButtonEvent

GLSDL

TSDL_JoyHatEvent

GLSDL

TSDL_Joystick

GLSDL

TSDL_KeyboardEvent

GLSDL

TSDL_KeySym

GLSDL

TSDL_MouseButtonEvent

GLSDL

TSDL_MouseMotionEvent

GLSDL

TSDL_Mutex

GLSDL

TSDL_NewTimerCallback

GLSDL

TSDL_Overlay

GLSDL

TSDL_Palette

GLSDL

TSDL_PixelFormat

GLSDL

TSDL_QuitEvent

GLSDL

TSDL_Rect

GLSDL

TSDL_ResizeEvent

GLSDL

TSDL_RWops

GLSDL

TSDL_Sem

GLSDL

TSDL_semaphore

GLSDL

TSDL_Surface

GLSDL

TSDL_SysWMEvent

GLSDL

TSDL_SysWMmsg

GLSDL

TSDL_Thread

GLSDL

TSDL_TimerCallback

GLSDL

TSDL_TimerID

GLSDL

TSDL_UserEvent

GLSDL

TSDL_version

GLSDL

TSDL_VideoInfo

GLSDL

TSectoredSpacePartition

SpatialPartitioning

TSectorMeshObject

GLPortal

A portal renderer sector.<p>

TSectorNode

SpatialPartitioning

TSectorNodeArray

SpatialPartitioning

TSeek

GLSDL

TSerializeEvent

GLNGDManager

TServiceContextTask

GLContext

TServiceContextTaskList

GLContext

TSetSubItemsEvent

GLSceneEditLCL

TSetSubItemsEvent

GLSceneEdit

TSetTransformEvent

GLNGDManager

TShaderFileProperty

GLSceneRegister

TShaderLightSourceState

GLState

TShaderUniformEditor

FRUniformEditor

TShadeType3DS

Types3DS

TShadowFilter

Types3DS

TShadowMapSize

Types3DS

TShadowPlaneOption

GLShadowPlane

TShadowPlaneOptions

GLShadowPlane

TShadowRange

Types3DS

TShadowSamples

Types3DS

TShadowSets3DS

Types3DS

TShadowStyle3DS

Types3DS

TShininess

GLMaterial

TShortIntArray

HeightTileFile

TSIBLigthing

GLImposter

TSimpleNavigationCustomActionEvent

GLSimpleNavigation

TSingleArray

VectorGeometry

TSingleArrayList

VectorLists

TSingleList

VectorLists

A list of Single.<p> Similar to TList, but using Single as items.<p> The list has stack-like push/pop methods.

TSingleList

Types3DS

TSingleRaster

GLHeightData

TSize_T

GLS_CL_Platform

TSkeleton

GLVectorFileObjects

Main skeleton object.<p> This class stores the bones hierarchy and animation frames.<br> It is also responsible for maintaining the "CurrentFrame" and allowing various frame blending operations.

TSkeletonBone

GLVectorFileObjects

A skeleton bone or node and its children.<p> This class is the base item of the bones hierarchy in a skeletal model. The joint values are stored in a TSkeletonFrame, but the calculated bone matrices are stored here.

TSkeletonBoneList

GLVectorFileObjects

A list of skeleton bones.<p>

TSkeletonCollider

GLVectorFileObjects

A general class storing the base level info required for skeleton based collision methods. This class is meant to be inherited from to create skeleton driven Verlet Constraints, ODE Geoms, etc. Overriden classes should be named as TSCxxxxx.

TSkeletonColliderList

GLVectorFileObjects

List class for storing TSkeletonCollider objects.

TSkeletonFrame

GLVectorFileObjects

Stores position and rotation for skeleton joints.<p> If you directly alter some values, make sure to call FlushLocalMatrixList so that the local matrices will be recalculated (the call to Flush does not recalculate the matrices, but marks the current ones as dirty).

TSkeletonFrameList

GLVectorFileObjects

A list of TSkeletonFrame objects.

TSkeletonFrameTransform

GLVectorFileObjects

TSkeletonMeshObject

GLVectorFileObjects

A mesh object with vertice bone attachments.<p> The class adds per vertex bone weights to the standard morphable mesh.<br> The TVertexBoneWeight structures are accessed via VerticesBonesWeights, they must be initialized by adjusting the BonesPerVertex and VerticeBoneWeightCount properties, you can also add vertex by vertex by using the AddWeightedBone method.<p> When BonesPerVertex is 1, the weight is ignored (set to 1.0).

TSkeletonRootBoneList

GLVectorFileObjects

This list store skeleton root bones exclusively.<p>

TSkyDomeBand

GLSkydome

TSkyDomeBands

GLSkydome

TSkyDomeOption

GLSkydome

TSkyDomeOptions

GLSkydome

TSkyDomeStar

GLSkydome

TSkyDomeStars

GLSkydome

TSmallIntArray

HeightTileFile

TSmallintArray

GLHeightData

TSmallIntRaster

GLHeightData

TSmoothGroup

Types3DS

TSolidBgnd3DS

Types3DS

TSoundFileProperty

GLSceneRegister

TSoundNameProperty

GLSceneRegister

TSourceDataFetchedEvent

GLHeightData

TSpaceContains

GeometryBB

TSpacePartitionLeaf

SpatialPartitioning

TSpacePartitionLeafList

SpatialPartitioning

TSpaceTextCharRange

GLSpaceText

TSPCone

SpatialPartitioning

TSpecularMode

GLBumpShader

TSPOctreeNode

SpatialPartitioning

TSpotCone3DS

Types3DS

TSpotLight3DS

Types3DS

TSpotProjector3DS

Types3DS

TSpotShadow3DS

Types3DS

TSPQuadtreeNode

SpatialPartitioning

TSpriteAnimation

GLAnimatedSprite

Animations define how the texture coordinates for each offset are to be determined.

TSpriteAnimationList

GLAnimatedSprite

A collection for storing TSpriteAnimation objects.

TSpriteAnimationMode

GLAnimatedSprite

Sets the current animation playback mode: <ul> <li>samNone - No playback, the animation does not progress. <li>samPlayOnce - Plays the animation once then switches to samNone. <li>samLoop - Play the animation forward in a continuous loop. <li>samLoopBackward - Same as samLoop but reversed direction. <li>samBounceForward - Plays forward and switches to samBounceBackward when EndFrame is reached. <li>samBounceBackward - Plays backward and switches to samBounceForward when StartFrame is reached. </ul>.

TSpriteAnimFrame

GLAnimatedSprite

Used by the SpriteAnimation when Dimensions are set manual. The animation will use the offsets, width and height to determine the texture coodinates for this frame.

TSpriteAnimFrameList

GLAnimatedSprite

The XCollection used for the TSpriteAnimFrame object.

TSpriteAnimMargins

GLAnimatedSprite

Used to mask the auto generated frames. The Left, Top, Right and Bottom properties determines the number of pixels to be cropped from each corresponding side of the frame. Only applicable to auto dimensions.

TSpriteColorMode

GLParticleFX

Sprite color modes.<p> <ul> <li>scmFade: vertex coloring is used to fade inner-outer <li>scmInner: vertex coloring uses inner color only <li>scmOuter: vertex coloring uses outer color only <li>scmNone: vertex coloring is NOT used (colors are ignored). </ul>

TSpriteFrameDimensions

GLAnimatedSprite

Determines if the texture coordinates are Automatically generated from the Animations properties or if they are Manually set through the Frames collection.

TSpritesPerTexture

GLParticleFX

Sprites per sprite texture for the SpritePFX.

TSqrt255Array

GLUtils

TStartPreparingDataEvent

GLHeightData

TStateRecord

GLState

TStaticImposter

GLImposter

Imposter class whose texture contains several views from different angles.

TStdio

GLSDL

TStencilFunction

GLState

TStencilOp

GLState

TSTLFace

TypesSTL

TSTLHeader

TypesSTL

TSTLVertex

TypesSTL

TStreamPos

GLSZLibEx

TStyleList

GLSMemo

TSubdivideEdgeEvent

MeshUtils

TSurfaceModes

GLODEManager

TSwizzleVector

GLTextureFormat

TSYS_ThreadHandle

GLSDL

TTargetType3DS

Types3DS

TTaskProcedure

GLContext

TTerrainHighResStyle

GLTerrainRenderer

TTerrainOcclusionTesselate

GLTerrainRenderer

TTexPoint

VectorGeometry

TTexPointArray

VectorGeometry

TTexPointList

VectorLists

A list of TTexPoint.<p> Similar to TList, but using TTexPoint as items.<p> The list has stack-like push/pop methods.

TTEXSChunk

TypesB3D

TTextReader

PersistentClasses

Reads object persistence in Text format.

TTextureNeededEvent

GLTexture

TTextureReference

GLS_CUDA_Runtime

TTextWriter

PersistentClasses

Writes object persistence in Text format.

TTexVert3DS

Types3DS

TTexVertList

Types3DS

TTexVerts

Types3DS

TTGAImage

TGA

TGA image load/save capable class for Delphi.<p> TGA formats supported : 24 and 32 bits uncompressed or RLE compressed, saves only to uncompressed TGA.

TTGLFile3DSPositionAnimationKeys

GLFile3DS

TThorpoint

GLThorFX

TThorpointArray

GLThorFX

TThreadBmp32

GLShadowHDS

TTileManagementFlag

GLTerrainRenderer

TTileManagementFlags

GLTerrainRenderer

TTileType3DS

Types3DS

TTimeEvent

GLTimeEventsMgr

TTimeEventProc

GLTimeEventsMgr

TTimeEvents

GLTimeEventsMgr

TTimeEventType

GLTimeEventsMgr

TTintType3DS

Types3DS

TTokenType

GLSMemo

TTorusPart

GLGeomObjects

TTorusParts

GLGeomObjects

TTouchEvent

GLWin32Viewer

TTrackHeader3DS

Types3DS

TTransAxis

GLSDL

TTransformationRec

GLPipelineTransformation

TTransformations

VectorGeometry

TTransType

VectorGeometry

TTRISChunk

TypesB3D

TU1

LWObjects

TU1DynArray

LWObjects

TU2

LWObjects

TU2Array

LWObjects

TU2DynArray

LWObjects

TU4

LWObjects

TU48BitBlock

ImageUtils

TU4Array

LWObjects

TU4DynArray

LWObjects

TUBOStates

GLState

TUInt8Array

GLSDL

TUndoChangeEvent

GLSMemo

TUniformAutoSetMethod

GLSLParameter

TUniformAutoSetProperty

GLSceneRegister

TUnknown

GLSDL

TUpdateSpacePartion

VerletClasses

Turn

VectorGeometry

Rotates the given coordinate system (represented by the matrix) around MasterUp

Turn

VectorGeometry

Rotates the given coordinate system (represented by the matrix) around its Y-axis

TUseDirtyTiles

GLAsyncHDS

TUseDirtyTiles determines if/how dirty tiles are displayed and when they are released. <ul> <li>TUseDirtyTiles <li> <li> When a tile is maked as dirty, a replacement is queued immediately. <li> However, the replacement cant be used until the HDThread has finished preparing it. <li> Dirty tiles can be deleted as soon as they are no longer used/displayed.
Possible states for a TUseDirtyTiles.<p> <li>hdsNever : Dirty tiles get released immediately, leaving a hole in the terrain, until the replacement is hdsReady. <li>hdsUntilReplaced : Dirty tiles are used, until the HDThread has finished preparing the queued replacement. <li>hdsUntilAllReplaced : Waits until the HDSThread has finished preparing ALL queued tiles, <li> before allowing the renderer to switch over to the new set of tiles. <li> (This prevents a fading checkerbox effect.) </ul>

TUserView3DS

Types3DS

TVBOBuffer

GLVectorFileObjects

TVBOBuffers

GLVectorFileObjects

TVCCapsule

VerletClasses

Capsule collision constraint.

TVCCube

VerletClasses

Cube collision constraint.

TVCCylinder

VerletClasses

Cylinder collision constraint.<p> The cylinder is considered infinite by this constraint.

TVCFloor

VerletClasses

Floor collision constraint

TVCHeightField

VerletClasses

HeightField collision constraint (punctual!)

TVCHeightFieldOnNeedHeight

VerletClasses

TVCRigidBody

VerletClasses

Rigid body constraint.<p> Regroups several nodes in a rigid body conformation, somewhat similar to a stick but for multiple nodes. <p> EXPERIMENTAL, DOES NOT WORK!

TVCSlider

VerletClasses

Slider constraint.<p> Imposes that two nodes be aligned on a defined direction, on which they can slide freely. Note that the direction is fixed and won't rotate with the verlet assembly!.

TVCSphere

VerletClasses

Sphere collision constraint.

TVCStick

VerletClasses

Stick constraint.<p> Imposes a fixed distance between two nodes.

TVdpBitmapSurface

GLS_VDPAU_API

TVdpBitmapSurfaceCreate

GLS_VDPAU_API

TVdpBitmapSurfaceDestroy

GLS_VDPAU_API

TVdpBitmapSurfaceGetParameters

GLS_VDPAU_API

TVdpBitmapSurfacePutBitsNative

GLS_VDPAU_API

TVdpBitmapSurfaceQueryCapabilities

GLS_VDPAU_API

TVdpBitstreamBuffer

GLS_VDPAU_API

TVdpBool

GLS_VDPAU_API

TVdpChromaType

GLS_VDPAU_API

TVdpColor

GLS_VDPAU_API

TVdpColorStandard

GLS_VDPAU_API

TVdpColorTableFormat

GLS_VDPAU_API

TVdpCSCMatrix

GLS_VDPAU_API

TVdpDecoder

GLS_VDPAU_API

TVdpDecoderCreate

GLS_VDPAU_API

TVdpDecoderDestroy

GLS_VDPAU_API

TVdpDecoderGetParameters

GLS_VDPAU_API

TVdpDecoderProfile

GLS_VDPAU_API

TVdpDecoderQueryCapabilities

GLS_VDPAU_API

TVdpDecoderRender

GLS_VDPAU_API

TVdpDevice

GLS_VDPAU_API

TVdpDeviceCreateX11

GLS_VDPAU_X11

TVdpDeviceDestroy

GLS_VDPAU_API

TVdpFuncId

GLS_VDPAU_API

TVdpGenerateCSCMatrix

GLS_VDPAU_API

TVdpGetApiVersion

GLS_VDPAU_API

TVdpGetErrorString

GLS_VDPAU_API

TVdpGetInformationString

GLS_VDPAU_API

TVdpGetProcAddress

GLS_VDPAU_API

TVdpIndexedFormat

GLS_VDPAU_API

TVdpLayer

GLS_VDPAU_API

TVdpOutputSurface

GLS_VDPAU_API

TVdpOutputSurfaceCreate

GLS_VDPAU_API

TVdpOutputSurfaceDestroy

GLS_VDPAU_API

TVdpOutputSurfaceGetBitsNative

GLS_VDPAU_API

TVdpOutputSurfaceGetParameters

GLS_VDPAU_API

TVdpOutputSurfacePutBitsIndexed

GLS_VDPAU_API

TVdpOutputSurfacePutBitsNative

GLS_VDPAU_API

TVdpOutputSurfacePutBitsYCbCr

GLS_VDPAU_API

TVdpOutputSurfaceQueryCapabilities

GLS_VDPAU_API

TVdpOutputSurfaceQueryGetPutBitsNativeCapabilities

GLS_VDPAU_API

TVdpOutputSurfaceQueryPutBitsIndexedCapabilities

GLS_VDPAU_API

TVdpOutputSurfaceQueryPutBitsYCbCrCapabilities

GLS_VDPAU_API

TVdpOutputSurfaceRenderBitmapSurface

GLS_VDPAU_API

TVdpOutputSurfaceRenderBlendEquation

GLS_VDPAU_API

TVdpOutputSurfaceRenderBlendFactor

GLS_VDPAU_API

TVdpOutputSurfaceRenderBlendState

GLS_VDPAU_API

TVdpOutputSurfaceRenderOutputSurface

GLS_VDPAU_API

TVdpPictureInfo

GLS_VDPAU_API

TVdpPictureInfoDivX4

GLS_VDPAU_API

TVdpPictureInfoDivX5

GLS_VDPAU_API

TVdpPictureInfoH264

GLS_VDPAU_API

TVdpPictureInfoMPEG1Or2

GLS_VDPAU_API

TVdpPictureInfoMPEG4Part2

GLS_VDPAU_API

TVdpPictureInfoVC1

GLS_VDPAU_API

TVdpPoint

GLS_VDPAU_API

TVdpPreemptionCallback

GLS_VDPAU_API

TVdpPreemptionCallbackRegister

GLS_VDPAU_API

TVdpPresentationQueue

GLS_VDPAU_API

TVdpPresentationQueueBlockUntilSurfaceIdle

GLS_VDPAU_API

TVdpPresentationQueueCreate

GLS_VDPAU_API

TVdpPresentationQueueDestroy

GLS_VDPAU_API

TVdpPresentationQueueDisplay

GLS_VDPAU_API

TVdpPresentationQueueGetBackgroundColor

GLS_VDPAU_API

TVdpPresentationQueueGetTime

GLS_VDPAU_API

TVdpPresentationQueueQuerySurfaceStatus

GLS_VDPAU_API

TVdpPresentationQueueSetBackgroundColor

GLS_VDPAU_API

TVdpPresentationQueueStatus

GLS_VDPAU_API

TVdpPresentationQueueTarget

GLS_VDPAU_API

TVdpPresentationQueueTargetCreateX11

GLS_VDPAU_X11

TVdpPresentationQueueTargetDestroy

GLS_VDPAU_API

TVdpProcamp

GLS_VDPAU_API

TVdpRect

GLS_VDPAU_API

TVdpReferenceFrameH264

GLS_VDPAU_API

TVdpRGBAFormat

GLS_VDPAU_API

TVdpStatus

GLS_VDPAU_API

TVdpTime

GLS_VDPAU_API

TVdpVideoMixer

GLS_VDPAU_API

TVdpVideoMixerAttribute

GLS_VDPAU_API

TVdpVideoMixerCreate

GLS_VDPAU_API

TVdpVideoMixerDestroy

GLS_VDPAU_API

TVdpVideoMixerFeature

GLS_VDPAU_API

TVdpVideoMixerGetAttributeValues

GLS_VDPAU_API

TVdpVideoMixerGetFeatureEnables

GLS_VDPAU_API

TVdpVideoMixerGetFeatureSupport

GLS_VDPAU_API

TVdpVideoMixerGetParameterValues

GLS_VDPAU_API

TVdpVideoMixerParameter

GLS_VDPAU_API

TVdpVideoMixerPictureStructure

GLS_VDPAU_API

TVdpVideoMixerQueryAttributeSupport

GLS_VDPAU_API

TVdpVideoMixerQueryAttributeValueRange

GLS_VDPAU_API

TVdpVideoMixerQueryFeatureSupport

GLS_VDPAU_API

TVdpVideoMixerQueryParameterSupport

GLS_VDPAU_API

TVdpVideoMixerQueryParameterValueRange

GLS_VDPAU_API

TVdpVideoMixerRender

GLS_VDPAU_API

TVdpVideoMixerSetAttributeValues

GLS_VDPAU_API

TVdpVideoMixerSetFeatureEnables

GLS_VDPAU_API

TVdpVideoSurface

GLS_VDPAU_API

TVdpVideoSurfaceCreate

GLS_VDPAU_API

TVdpVideoSurfaceDestroy

GLS_VDPAU_API

TVdpVideoSurfaceGetBitsYCbCr

GLS_VDPAU_API

TVdpVideoSurfaceGetParameters

GLS_VDPAU_API

TVdpVideoSurfacePutBitsYCbCr

GLS_VDPAU_API

TVdpVideoSurfaceQueryCapabilities

GLS_VDPAU_API

TVdpVideoSurfaceQueryGetPutBitsYCbCrCapabilities

GLS_VDPAU_API

TVdpYCbCrFormat

GLS_VDPAU_API

TVec12

LWObjects

TVec12Array

LWObjects

TVec12DynArray

LWObjects

TVector

VectorGeometry

TVector2b

VectorTypes

TVector2d

VectorTypes

TVector2e

VectorTypes

TVector2f

VectorTypes

TVector2h

VectorTypes

TVector2i

VectorTypes

TVector2p

VectorTypes

TVector2s

VectorTypes

TVector2sb

VectorTypes

TVector2ui

VectorTypes

TVector2w

VectorTypes

TVector3b

VectorTypes

TVector3d

VectorTypes

TVector3e

VectorTypes

TVector3f

VectorTypes

TVector3h

VectorTypes

TVector3i

VectorTypes

TVector3p

VectorTypes

TVector3s

VectorTypes

TVector3sb

VectorTypes

TVector3ui

VectorTypes

TVector3w

VectorTypes

TVector4b

VectorTypes

TVector4d

VectorTypes

TVector4e

VectorTypes

TVector4f

VectorTypes

TVector4h

VectorTypes

TVector4i

VectorTypes

TVector4p

VectorTypes

TVector4s

VectorTypes

TVector4sb

VectorTypes

TVector4ui

VectorTypes

TVector4w

VectorTypes

TVectorArray

VectorGeometry

TVectorEditorForm

FVectorEditor

TVectorEditorForm

FVectorEditorLCL

TVectorFile

GLVectorFileObjects

Abstract base class for different vector file formats.<p> The actual implementation for these files (3DS, DXF..) must be done seperately. The concept for TVectorFile is very similar to TGraphic (see Delphi Help).

TVectorFileClass

GLVectorFileObjects

TVectorFileFormat

GLVectorFileObjects

TVectorFileFormatsList

GLVectorFileObjects

Stores registered vector file formats.

TVectorList

VectorLists

A list of TVector.<p> Similar to TList, but using TVector as items.<p> The list has stack-like push/pop methods.

TVerletConstraint

VerletClasses

TVerletConstraintList

VerletClasses

TVerletDualConstraint

VerletClasses

TVerletDualForce

VerletClasses

A verlet force that applies to two specified nodes.

TVerletEdge

VerletClasses

TVerletEdgeList

VerletClasses

TVerletForce

VerletClasses

Generic verlet force.

TVerletForceList

VerletClasses

TVerletGlobalConstraint

VerletClasses

TVerletGlobalForce

VerletClasses

A global force (applied to all verlet nodes).

TVerletGlobalFrictionConstraint

VerletClasses

TVerletGlobalFrictionConstraintBox

VerletClasses

TVerletGlobalFrictionConstraintSP

VerletClasses

TVerletGlobalFrictionConstraintSphere

VerletClasses

TVerletGroupConstraint

VerletClasses

TVerletGroupForce

VerletClasses

A verlet force that applies to a specified group of nodes.

TVerletHair

VerletHairClasses

TVerletNode

VerletClasses

Basic verlet node

TVerletNodeClass

VerletClasses

TVerletNodeList

VerletClasses

TVerletProgressTimes

VerletClasses

TVerletWorld

VerletClasses

TVertex

VectorGeometry

TVertexBoneWeight

GLVectorFileObjects

TVertexBoneWeightArray

GLVectorFileObjects

TVertexBoneWeightDynArray

GLVectorFileObjects

TVertexData

GLMesh

TVertexData

TypesB3D

TVertexDataArray

GLMesh

TVertexList

GLMesh

TVertexList

TypesMD2

TVertexMode

GLMesh

TVertexRec

GLObjects

TVertexWeightList

TypesMS3D

TVerticesBoneWeights

GLVectorFileObjects

TVFAirResistance

VerletClasses

TVFGravity

VerletClasses

TVFSpring

VerletClasses

TVGradient

Types3DS

TVGradientBgnd3DS

Types3DS

TVHStiffness

VerletHairClasses

TVHStiffnessSet

VerletHairClasses

TVIDEOHDR

GLSVfw

TVideoMode

GLScreen

TViewport3DS

Types3DS

TViewportData

Types3DS

TViewportData3

Types3DS

TViewportLayout

Types3DS

TViewportSize

Types3DS

TViewSize3DS

Types3DS

TViewStandard

Types3DS

TViewType3DS

Types3DS

TViewUser

Types3DS

TVirtualKeyCode

GLKeyboard

TVirtualReader

PersistentClasses

Virtual layer similar to VCL's TReader (but reusable)

TVirtualReaderClass

PersistentClasses

TVirtualWriter

PersistentClasses

Virtual layer similar to VCL's TWriter (but reusable)

TVirtualWriterClass

PersistentClasses

TVRMLIntegerArray

VRMLParser

TVRMLMaterial

VRMLParser

TVRMLNode

VRMLParser

TVRMLParser

VRMLParser

TVRMLShapeHints

VRMLParser

TVRMLSingleArray

VRMLParser

TVRMLTransform

VRMLParser

TVRMLUse

VRMLParser

TVRTSChunk

TypesB3D

TVSyncMode

GLContext

Tweener

AnimationUtils

Tweener

AnimationUtils

Tweener

AnimationUtils

TWGLswap

OpenGLTokens

TWindowAttribute

GLScreen

TWindowAttributes

GLScreen

TWindowFitting

GLScreen

TWOCC

GLSVfw

TWOCCFromFOURCC

GLSVfw

TWordArray

GLSDL

TWordList

Types3DS

TWordVector

VectorGeometry

TWrite

GLSDL

TXCollection

XCollection

Holds a list of TXCollectionItem objects.<p> This class looks a lot like a polymorphic-enabled TCollection, it is a much stripped down version of a proprietary TObjectList and persistence classes (XClasses & XLists), if the copyrights are ever partially lifted on the originals, I'll base this code on them since they are way faster than Borland's lists and persistence mechanisms (and unlike Borland's, with polymorphism-support and full backward compatibility).

TXCollectionEditor

FXCollectionEditor

TXCollectionEditor

FXCollectionEditorLCL

TXCollectionItem

XCollection

Base class for implementing a XCollection item.<p> NOTES :<ul> <li>Don't forget to override the ReadFromFiler/WriteToFiler persistence methods if you add data in a subclass ! <li>Subclasses must be registered using the RegisterXCollectionItemClass function for proper operation </ul>

TXCollectionItemClass

XCollection

TXCollectionProperty

RegisterXCollection

TXDataDouble

Types3DS

TXDataEntry

Types3DS

TXDataFloat

Types3DS

TXDataLong

Types3DS

TXDataRaw3DS

Types3DS

TXDataShort

Types3DS

TXDataVoid

Types3DS

TXYZGridLinesStyle

GLGraph

TXYZGridPart

GLGraph

TXYZGridParts

GLGraph

TypByteID

dws2OpenGLAdapter

TypCardinalID

dws2OpenGLAdapter

TZAlloc

GLSZLibExApi

TZArray

GLzBuffer

TZArrayIdx

GLzBuffer

TZCompressedMode

GLVfsPAK

TZCompressionBuffer

GLSZLibEx

TZCompressionLevel

GLSZLibEx

TZCompressionStream

GLSZLibEx

TZCustomBuffer

GLSZLibEx

TZDecompressionBuffer

GLSZLibEx

TZDecompressionStream

GLSZLibEx

TZError

GLSZLibEx

TZFlush

GLSZLibEx

TZFree

GLSZLibExApi

TZInformation

GLSZLibEx

TZLibArchive

GLFileZLIB

TZLibHeader

GLFileZLIB

TZReadFunction

GLSZLibEx

TZStrategy

GLSZLibEx

TZStreamRec

GLSZLibExApi

TZStreamRec

LIBPNG

TZWriteFunction

GLSZLibEx

T_cl_command_queue

GLS_CL

T_cl_context

GLS_CL

T_cl_device_id

GLS_CL

T_cl_event

GLS_CL

T_cl_kernel

GLS_CL

T_cl_mem

GLS_CL

T_cl_platform_id

GLS_CL

T_cl_program

GLS_CL

T_cl_sampler

GLS_CL

UINT16

GLSJPG

UInt16

GLSDL

UInt32

GLSDL

UINT32

GLSJPG

UInt64

GLSDL

UInt8

GLSDL

UINT8

GLSJPG

UnApplyBlendingModeEx

GLCustomShader

UnicodeChar

GLSZLibEx

UnicodeString

GLSZLibEx

UnifyTrianglesWinding

MeshUtils

Attempts to unify triangle winding.<p> Depending on topology, this may or may not be successful (some topologies can't be unified, f.i. those that have duplicate triangles, those that have edges shared by more than two triangles, those that have unconnected submeshes etc.)

UnloadModule

GLSModuleLoader

UnloadOpenGL

OpenGL1x

UnloadOpenGL

OpenGLAdapter

UnPackRotationMatrix

VectorGeometry

Restores a packed rotation matrix.<p> See PackRotationMatrix.

UnpressGroup

GLWindows

UnProject

VectorGeometry

UnregisterArchiveFormat

GLSArchiveManager

UnRegisterColor

GLColor

UnregisterGLSceneObject

GLODEManager

UnRegisterGLTextureImageEditor

GLTextureImageEditors

UnregisterRasterFormat

GLGraphics

UnregisterSoundFileClass

GLSoundFileObjects

UnregisterVectorFileClass

GLVectorFileObjects

UnregisterXCollectionItemClass

XCollection

Removes a TXCollectionItem subclass from the list.

Unsigned_char

NewtonImport

Unsigned_int

NewtonImport

Unsigned_long

NewtonImport

Unsigned_short

NewtonImport

UseCustomGLSLogger

GLSLog

UserLog

GLSLog

USE_BEVEL

Const3DS

USE_BIT_MAP

Const3DS

USE_CONTOUR

Const3DS

USE_DISTANCE_CUE

Const3DS

USE_FIT

Const3DS

USE_FOG

Const3DS

USE_LAYER_FOG

Const3DS

USE_SCALE

Const3DS

USE_SOLID_BGND

Const3DS

USE_TEETER

Const3DS

USE_TWEEN

Const3DS

USE_TWIST

Const3DS

USE_V_GRADIENT

Const3DS

UTF8ToWideString

PersistentClasses

vAFIOCreateFileStream

ApplicationFileIO

vAFIOFileStreamExists

ApplicationFileIO

ValidateExternalObject

dws2HelperFunc

VCAPS_CAN_SCALE

GLSVfw

VCAPS_DST_CAN_CLIP

GLSVfw

VCAPS_OVERLAY

GLSVfw

VCAPS_SRC_CAN_CLIP

GLSVfw

vContextActivationFailureOccurred

GLContext

vCurrentVideoMode

GLScreen

vDDSDetailLevel

GLFileDDS

Variable determines which resolution to use textures, high - it loads all levels, midle - skipped the first level, low - skipped the first two levels.

vDefaultMeshOptimizerOptions

GLMeshOptimizer

vDefaultTextureCompression

GLTextureFormat

vDefaultTextureFormat

GLTextureFormat

VDPAU_INTERFACE_VERSION

GLS_VDPAU_API

VDPAU_VERSION

GLS_VDPAU_API

VDP_BITSTREAM_BUFFER_VERSION

GLS_VDPAU_API

VDP_CHROMA_TYPE_420

GLS_VDPAU_API

VDP_CHROMA_TYPE_422

GLS_VDPAU_API

VDP_CHROMA_TYPE_444

GLS_VDPAU_API

VDP_COLOR_STANDARD_ITUR_BT_601

GLS_VDPAU_API

VDP_COLOR_STANDARD_ITUR_BT_709

GLS_VDPAU_API

VDP_COLOR_STANDARD_SMPTE_240M

GLS_VDPAU_API

VDP_COLOR_TABLE_FORMAT_B8G8R8X8

GLS_VDPAU_API

VDP_DECODER_LEVEL_DIVX_NA

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_1

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_1b

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_1_1

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_1_2

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_1_3

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_2

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_2_1

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_2_2

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_3

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_3_1

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_3_2

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_4

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_4_1

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_4_2

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_5

GLS_VDPAU_API

VDP_DECODER_LEVEL_H264_5_1

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG1_NA

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG2_HL

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG2_HL14

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG2_LL

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG2_ML

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L0

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L1

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L2

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L3

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L4

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_ASP_L5

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_SP_L0

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_SP_L1

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_SP_L2

GLS_VDPAU_API

VDP_DECODER_LEVEL_MPEG4_PART2_SP_L3

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_ADVANCED_L0

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_ADVANCED_L1

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_ADVANCED_L2

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_ADVANCED_L3

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_ADVANCED_L4

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_MAIN_HIGH

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_MAIN_LOW

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_MAIN_MEDIUM

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_SIMPLE_LOW

GLS_VDPAU_API

VDP_DECODER_LEVEL_VC1_SIMPLE_MEDIUM

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX4_HD_1080P

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX4_HOME_THEATER

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX4_MOBILE

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX4_QMOBILE

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX5_HD_1080P

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX5_HOME_THEATER

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX5_MOBILE

GLS_VDPAU_API

VDP_DECODER_PROFILE_DIVX5_QMOBILE

GLS_VDPAU_API

VDP_DECODER_PROFILE_H264_BASELINE

GLS_VDPAU_API

VDP_DECODER_PROFILE_H264_HIGH

GLS_VDPAU_API

VDP_DECODER_PROFILE_H264_MAIN

GLS_VDPAU_API

VDP_DECODER_PROFILE_MPEG1

GLS_VDPAU_API

VDP_DECODER_PROFILE_MPEG2_MAIN

GLS_VDPAU_API

VDP_DECODER_PROFILE_MPEG2_SIMPLE

GLS_VDPAU_API

VDP_DECODER_PROFILE_MPEG4_PART2_ASP

GLS_VDPAU_API

VDP_DECODER_PROFILE_MPEG4_PART2_SP

GLS_VDPAU_API

VDP_DECODER_PROFILE_VC1_ADVANCED

GLS_VDPAU_API

VDP_DECODER_PROFILE_VC1_MAIN

GLS_VDPAU_API

VDP_DECODER_PROFILE_VC1_SIMPLE

GLS_VDPAU_API

vdp_device_create_x11

GLS_VDPAU_X11

VDP_FALSE

GLS_VDPAU_API

VDP_FUNC_ID_BASE_WINSYS

GLS_VDPAU_API

VDP_FUNC_ID_BITMAP_SURFACE_CREATE

GLS_VDPAU_API

VDP_FUNC_ID_BITMAP_SURFACE_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_BITMAP_SURFACE_GET_PARAMETERS

GLS_VDPAU_API

VDP_FUNC_ID_BITMAP_SURFACE_PUT_BITS_NATIVE

GLS_VDPAU_API

VDP_FUNC_ID_BITMAP_SURFACE_QUERY_CAPABILITIES

GLS_VDPAU_API

VDP_FUNC_ID_DECODER_CREATE

GLS_VDPAU_API

VDP_FUNC_ID_DECODER_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_DECODER_GET_PARAMETERS

GLS_VDPAU_API

VDP_FUNC_ID_DECODER_QUERY_CAPABILITIES

GLS_VDPAU_API

VDP_FUNC_ID_DECODER_RENDER

GLS_VDPAU_API

VDP_FUNC_ID_DEVICE_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_GENERATE_CSC_MATRIX

GLS_VDPAU_API

VDP_FUNC_ID_GET_API_VERSION

GLS_VDPAU_API

VDP_FUNC_ID_GET_ERROR_STRING

GLS_VDPAU_API

VDP_FUNC_ID_GET_INFORMATION_STRING

GLS_VDPAU_API

VDP_FUNC_ID_GET_PROC_ADDRESS

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_CREATE

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_GET_BITS_NATIVE

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_GET_PARAMETERS

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_PUT_BITS_INDEXED

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_PUT_BITS_NATIVE

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_PUT_BITS_Y_CB_CR

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_CAPABILITIES

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_GET_PUT_BITS_NATIVE_CAPABILITIES

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_PUT_BITS_INDEXED_CAPABILITIES

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_QUERY_PUT_BITS_Y_CB_CR_CAPABILITIES

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_RENDER_BITMAP_SURFACE

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_RENDER_OUTPUT_SURFACE

GLS_VDPAU_API

VDP_FUNC_ID_OUTPUT_SURFACE_RENDER_VIDEO_SURFACE_LUMA

GLS_VDPAU_API

VDP_FUNC_ID_PREEMPTION_CALLBACK_REGISTER

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_BLOCK_UNTIL_SURFACE_IDLE

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_CREATE

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_DISPLAY

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_GET_BACKGROUND_COLOR

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_GET_TIME

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_QUERY_SURFACE_STATUS

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_SET_BACKGROUND_COLOR

GLS_VDPAU_API

VDP_FUNC_ID_PRESENTATION_QUEUE_TARGET_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_CREATE

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_GET_ATTRIBUTE_VALUES

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_GET_FEATURE_ENABLES

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_GET_FEATURE_SUPPORT

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_GET_PARAMETER_VALUES

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_QUERY_ATTRIBUTE_SUPPORT

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_QUERY_ATTRIBUTE_VALUE_RANGE

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_QUERY_FEATURE_SUPPORT

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_QUERY_PARAMETER_SUPPORT

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_QUERY_PARAMETER_VALUE_RANGE

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_RENDER

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_SET_ATTRIBUTE_VALUES

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_MIXER_SET_FEATURE_ENABLES

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_SURFACE_CREATE

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_SURFACE_DESTROY

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_SURFACE_GET_BITS_Y_CB_CR

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_SURFACE_GET_PARAMETERS

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_SURFACE_PUT_BITS_Y_CB_CR

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_SURFACE_QUERY_CAPABILITIES

GLS_VDPAU_API

VDP_FUNC_ID_VIDEO_SURFACE_QUERY_GET_PUT_BITS_Y_CB_CR_CAPABILITIES

GLS_VDPAU_API

VDP_INDEXED_FORMAT_A4I4

GLS_VDPAU_API

VDP_INDEXED_FORMAT_A8I8

GLS_VDPAU_API

VDP_INDEXED_FORMAT_I4A4

GLS_VDPAU_API

VDP_INDEXED_FORMAT_I8A8

GLS_VDPAU_API

VDP_INVALID_HANDLE

GLS_VDPAU_API

VDP_LAYER_VERSION

GLS_VDPAU_API

VDP_OUTPUT_SURFACE_RENDER_BLEND_STATE_VERSION

GLS_VDPAU_API

VDP_OUTPUT_SURFACE_RENDER_COLOR_PER_VERTEX

GLS_VDPAU_API

VDP_OUTPUT_SURFACE_RENDER_ROTATE_0

GLS_VDPAU_API

VDP_OUTPUT_SURFACE_RENDER_ROTATE_180

GLS_VDPAU_API

VDP_OUTPUT_SURFACE_RENDER_ROTATE_270

GLS_VDPAU_API

VDP_OUTPUT_SURFACE_RENDER_ROTATE_90

GLS_VDPAU_API

VDP_PROCAMP_VERSION

GLS_VDPAU_API

VDP_RGBA_FORMAT_A8

GLS_VDPAU_API

VDP_RGBA_FORMAT_B10G10R10A2

GLS_VDPAU_API

VDP_RGBA_FORMAT_B8G8R8A8

GLS_VDPAU_API

VDP_RGBA_FORMAT_R10G10B10A2

GLS_VDPAU_API

VDP_RGBA_FORMAT_R8G8B8A8

GLS_VDPAU_API

VDP_TRUE

GLS_VDPAU_API

VDP_VIDEO_MIXER_ATTRIBUTE_BACKGROUND_COLOR

GLS_VDPAU_API

VDP_VIDEO_MIXER_ATTRIBUTE_CSC_MATRIX

GLS_VDPAU_API

VDP_VIDEO_MIXER_ATTRIBUTE_LUMA_KEY_MAX_LUMA

GLS_VDPAU_API

VDP_VIDEO_MIXER_ATTRIBUTE_LUMA_KEY_MIN_LUMA

GLS_VDPAU_API

VDP_VIDEO_MIXER_ATTRIBUTE_NOISE_REDUCTION_LEVEL

GLS_VDPAU_API

VDP_VIDEO_MIXER_ATTRIBUTE_SHARPNESS_LEVEL

GLS_VDPAU_API

VDP_VIDEO_MIXER_ATTRIBUTE_SKIP_CHROMA_DEINTERLACE

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_DEINTERLACE_TEMPORAL

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_DEINTERLACE_TEMPORAL_SPATIAL

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L1

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L2

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L3

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L4

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L5

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L6

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L7

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L8

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_HIGH_QUALITY_SCALING_L9

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_INVERSE_TELECINE

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_LUMA_KEY

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_NOISE_REDUCTION

GLS_VDPAU_API

VDP_VIDEO_MIXER_FEATURE_SHARPNESS

GLS_VDPAU_API

VDP_VIDEO_MIXER_PARAMETER_CHROMA_TYPE

GLS_VDPAU_API

VDP_VIDEO_MIXER_PARAMETER_LAYERS

GLS_VDPAU_API

VDP_VIDEO_MIXER_PARAMETER_VIDEO_SURFACE_HEIGHT

GLS_VDPAU_API

VDP_VIDEO_MIXER_PARAMETER_VIDEO_SURFACE_WIDTH

GLS_VDPAU_API

VDP_YCBCR_FORMAT_NV12

GLS_VDPAU_API

VDP_YCBCR_FORMAT_UYVY

GLS_VDPAU_API

VDP_YCBCR_FORMAT_V8U8Y8A8

GLS_VDPAU_API

VDP_YCBCR_FORMAT_Y8U8V8A8

GLS_VDPAU_API

VDP_YCBCR_FORMAT_YUYV

GLS_VDPAU_API

VDP_YCBCR_FORMAT_YV12

GLS_VDPAU_API

Vector2bMake

VectorGeometry

Vector2bMake

VectorGeometry

Vector2bMake

VectorGeometry

Vector2dMake

VectorGeometry

Vector2dMake

VectorGeometry

Vector2dMake

VectorGeometry

Vector2fMake

VectorGeometry

Vector2fMake

VectorGeometry

Vector2fMake

VectorGeometry

Vector2iMake

VectorGeometry

Vector2iMake

VectorGeometry

Vector2iMake

VectorGeometry

Vector2sMake

VectorGeometry

Vector2sMake

VectorGeometry

Vector2sMake

VectorGeometry

Vector3ADD

ODEImport

Vector3bMake

VectorGeometry

Vector3bMake

VectorGeometry

Vector3bMake

VectorGeometry

Vector3Cross

ODEImport

Vector3dMake

VectorGeometry

Vector3dMake

VectorGeometry

Vector3dMake

VectorGeometry

Vector3fMake

VectorGeometry

Vector3fMake

VectorGeometry

Vector3fMake

VectorGeometry

Vector3iMake

VectorGeometry

Vector3iMake

VectorGeometry

Vector3iMake

VectorGeometry

Vector3Length

ODEImport

Vector3Make

ODEImport

Vector3ScalarMul

ODEImport

Vector3sMake

VectorGeometry

Vector3sMake

VectorGeometry

Vector3sMake

VectorGeometry

Vector3SUB

ODEImport

Vector4bMake

VectorGeometry

Vector4bMake

VectorGeometry

Vector4bMake

VectorGeometry

Vector4dMake

VectorGeometry

Vector4dMake

VectorGeometry

Vector4dMake

VectorGeometry

Vector4fMake

VectorGeometry

Vector4fMake

VectorGeometry

Vector4fMake

VectorGeometry

Vector4iMake

VectorGeometry

Vector4iMake

VectorGeometry

Vector4iMake

VectorGeometry

Vector4sMake

VectorGeometry

Vector4sMake

VectorGeometry

Vector4sMake

VectorGeometry

VectorAbs

VectorGeometry

Returns a vector with components replaced by their Abs value. }

VectorAbs

VectorGeometry

Returns a vector with components replaced by their Abs value. }

VectorAdd

VectorGeometry

Returns the sum of two homogeneous vectors

VectorAdd

VectorGeometry

VectorAdd

VectorGeometry

VectorAdd

VectorGeometry

Sums up f to each component of the vector

VectorAdd

VectorGeometry

VectorAdd

VectorGeometry

Adds two vectors and places result in vr

VectorAdd

VectorGeometry

Sums up f to each component of the vector

VectorAdd

VectorGeometry

Returns the sum of two affine vectors

VectorAffineDblToFlt

VectorGeometry

VectorAffineFltToDbl

VectorGeometry

VectorAngleCombine

VectorGeometry

VectorAngleCosine

VectorGeometry

Calculates the cosine of the angle between Vector1 and Vector2.<p> Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))

VectorAngleCosine

VectorGeometry

Calculates the cosine of the angle between Vector1 and Vector2.<p> Result = DotProduct(V1, V2) / (Length(V1) * Length(V2))

VectorAngleLerp

VectorGeometry

VectorArrayAdd

VectorGeometry

Adds delta to nb vectors in src and places result in dest

VectorArrayLerp

VectorGeometry

VectorArrayLerp

VectorGeometry

VectorArrayLerp

VectorGeometry

Calculates linear interpolation between vector arrays

VectorCombine

VectorGeometry

Makes a linear combination of two vectors and place result in vr

VectorCombine

VectorGeometry

Makes a linear combination of two vectors and return the result

VectorCombine

VectorGeometry

Makes a linear combination of two vectors and place result in vr, F1=1.0

VectorCombine

VectorGeometry

Makes a linear combination of two vectors and return the result

VectorCombine

VectorGeometry

Makes a linear combination of two vectors and place result in vr

VectorCombine

VectorGeometry

Makes a linear combination of two vectors and return the result

VectorCombine3

VectorGeometry

VectorCombine3

VectorGeometry

Makes a linear combination of three vectors and return the result

VectorCombine3

VectorGeometry

Makes a linear combination of three vectors and return the result

VectorCombine3

VectorGeometry

Makes a linear combination of three vectors and return the result

VectorCrossProduct

VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr

VectorCrossProduct

VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr

VectorCrossProduct

VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr

VectorCrossProduct

VectorGeometry

Calculates the cross product between vector 1 and 2, place result in vr

VectorCrossProduct

VectorGeometry

Calculates the cross product between vector 1 and 2

VectorCrossProduct

VectorGeometry

Calculates the cross product between vector 1 and 2

VectorDblToFlt

VectorGeometry

VectorDistance

VectorGeometry

Calculates distance between two vectors.<p> ie. sqrt(sqr(v1[x]-v2[x])+...) (w component ignored)

VectorDistance

VectorGeometry

Calculates distance between two vectors.<p> ie. sqrt(sqr(v1[x]-v2[x])+...)

VectorDistance2

VectorGeometry

Calculates the "Norm 2" between two vectors.<p> ie. sqr(v1[x]-v2[x])+... (w component ignored)

VectorDistance2

VectorGeometry

Calculates the "Norm 2" between two vectors.<p> ie. sqr(v1[x]-v2[x])+...

VectorDivide

VectorGeometry

VectorDivide

GLEllipseCollision

VectorDivide

VectorGeometry

VectorDotProduct

VectorGeometry

Calculates the dot product between V1 and V2.<p> Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

VectorDotProduct

VectorGeometry

Calculates the dot product between V1 and V2.<p> Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

VectorDotProduct

VectorGeometry

Calculates the dot product between V1 and V2.<p> Result:=V1[X] * V2[X] + V1[Y] * V2[Y]

VectorDotProduct

VectorGeometry

Calculates the dot product between V1 and V2.<p> Result:=V1[X] * V2[X] + V1[Y] * V2[Y] + V1[Z] * V2[Z]

VectorEditorForm

FVectorEditor

VectorEditorForm

FVectorEditorLCL

VectorEquals

VectorGeometry

VectorEquals

VectorGeometry

VectorEquals

VectorGeometry

True if all components are equal.

VectorEquals

VectorGeometry

VectorEquals

VectorGeometry

VectorEquals

VectorGeometry

VectorEquals

VectorGeometry

VectorEquals

VectorGeometry

VectorEquals

VectorGeometry

VectorEquals

VectorGeometry

VectorEquals

VectorGeometry

VectorEquals

VectorGeometry

VectorEquals

VectorGeometry

True if all components are equal.

VectorEquals

VectorGeometry

VectorEquals

VectorGeometry

VectorFileFormatExtensionByIndex

GLVectorFileObjects

Returns an extension by its index in the vector files dialogs filter.<p> Use VectorFileFormatsFilter to obtain the filter.

VectorFileFormatsFilter

GLVectorFileObjects

A file extension filter suitable for dialog's 'Filter' property

VectorFileFormatsSaveFilter

GLVectorFileObjects

A file extension filter suitable for a savedialog's 'Filter' property

VectorFltToDbl

VectorGeometry

VectorIsNull

VectorGeometry

True if x=y=z=0, w ignored

VectorIsNull

VectorGeometry

True if x=y=z=0, w ignored

VectorLength

VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y).

VectorLength

VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z+w*w).

VectorLength

VectorGeometry

Calculates the length of a vector following the equation: sqrt(x*x+y*y+...).<p> Note: The parameter of this function is declared as open array. Thus there's no restriction about the number of the components of the vector.

VectorLength

VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y).

VectorLength

VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).

VectorLength

VectorGeometry

Calculates the length of a vector following the equation sqrt(x*x+y*y+z*z).

VectorLerp

VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr

VectorLerp

VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t

VectorLerp

VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t, places result in vr

VectorLerp

VectorGeometry

Calculates linear interpolation between vector1 and vector2 at point t

VectorLessEqualThen

VectorGeometry

VectorLessEqualThen

VectorGeometry

VectorLessEqualThen

VectorGeometry

VectorLessEqualThen

VectorGeometry

VectorLessEqualThen

VectorGeometry

VectorLessEqualThen

VectorGeometry

VectorLessEqualThen

VectorGeometry

VectorLessEqualThen

VectorGeometry

VectorLessEqualThen

VectorGeometry

VectorLessEqualThen

VectorGeometry

VectorLessEqualThen

VectorGeometry

VectorLessEqualThen

VectorGeometry

VectorLessThen

VectorGeometry

VectorLessThen

VectorGeometry

VectorLessThen

VectorGeometry

VectorLessThen

VectorGeometry

VectorLessThen

VectorGeometry

VectorLessThen

VectorGeometry

VectorLessThen

VectorGeometry

VectorLessThen

VectorGeometry

VectorLessThen

VectorGeometry

VectorLessThen

VectorGeometry

VectorLessThen

VectorGeometry

VectorLessThen

VectorGeometry

VectorMake

VectorGeometry

VectorMake

VectorGeometry

VectorMoreEqualThen

VectorGeometry

VectorMoreEqualThen

VectorGeometry

VectorMoreEqualThen

VectorGeometry

VectorMoreEqualThen

VectorGeometry

VectorMoreEqualThen

VectorGeometry

VectorMoreEqualThen

VectorGeometry

VectorMoreEqualThen

VectorGeometry

VectorMoreEqualThen

VectorGeometry

VectorMoreEqualThen

VectorGeometry

VectorMoreEqualThen

VectorGeometry

VectorMoreEqualThen

VectorGeometry

VectorMoreEqualThen

VectorGeometry

VectorMoreThen

VectorGeometry

VectorMoreThen

VectorGeometry

VectorMoreThen

VectorGeometry

VectorMoreThen

VectorGeometry

VectorMoreThen

VectorGeometry

VectorMoreThen

VectorGeometry

Vector comparison functions:

VectorMoreThen

VectorGeometry

VectorMoreThen

VectorGeometry

VectorMoreThen

VectorGeometry

VectorMoreThen

VectorGeometry

VectorMoreThen

VectorGeometry

VectorMoreThen

VectorGeometry

VectorNegate

VectorGeometry

VectorNegate

VectorGeometry

Negates the vector

VectorNorm

VectorGeometry

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z<p> Also known as "Norm 2" in the math world, this is sqr(VectorLength).

VectorNorm

VectorGeometry

Calculates norm of a vector which is defined as norm = x * x + y * y<p> Also known as "Norm 2" in the math world, this is sqr(VectorLength).

VectorNorm

VectorGeometry

Calculates norm of a vector which is defined as norm = v.V[0]*v.V[0] + ...<p> Also known as "Norm 2" in the math world, this is sqr(VectorLength).

VectorNorm

VectorGeometry

Calculates norm of a vector which is defined as norm = x*x + y*y + z*z<p> Also known as "Norm 2" in the math world, this is sqr(VectorLength).

VectorNormalize

VectorGeometry

Returns the vector transformed to unit length

VectorNormalize

VectorGeometry

Returns the vector transformed to unit length (w component dropped)

VectorNormalize

VectorGeometry

Returns the vector transformed to unit length

VectorPerpendicular

VectorGeometry

Calculates a vector perpendicular to N.<p> N is assumed to be of unit length, subtract out any component parallel to N

VectorReflect

VectorGeometry

Reflects vector V against N (assumes N is normalized)

VectorRotateAroundX

VectorGeometry

Returns given vector rotated around the X axis (alpha is in rad)

VectorRotateAroundY

VectorGeometry

Returns given vector rotated around the Y axis in vr (alpha is in rad)

VectorRotateAroundY

VectorGeometry

Returns given vector rotated around the Y axis (alpha is in rad)

VectorRotateAroundZ

VectorGeometry

Returns given vector rotated around the Z axis (alpha is in rad)

VectorScale

VectorGeometry

Returns a vector scaled by a factor

VectorScale

VectorGeometry

Scales a vector by a factor and places result in vr

VectorScale

VectorGeometry

Scales given vector by another vector

VectorScale

VectorGeometry

Returns a vector scaled by a factor

VectorScale

VectorGeometry

Returns a vector scaled by a factor

VectorScale

VectorGeometry

Scales a vector by a factor and places result in vr

VectorScale

VectorGeometry

Scales a vector by a factor and places result in vr

VectorScale

VectorGeometry

RScales given vector by another vector

VectorSpacing

VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".<p>

VectorSpacing

VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y])+..., also know as "Norm1".<p>

VectorSpacing

VectorGeometry

Calculates Abs(v1[x]-v2[x])+Abs(v1[y]-v2[y]), also know as "Norm1".<p>

VectorSubtract

VectorGeometry

Returns V1-V2

VectorSubtract

VectorGeometry

Returns V1-V2

VectorSubtract

VectorGeometry

Subtracts V2 from V1 and return value in result

VectorSubtract

VectorGeometry

Subtracts V2 from V1 and return value in result

VectorSubtract

VectorGeometry

Subtracts V2 from V1 and return value in result

VectorSubtract

VectorGeometry

Returns V1-V2

VectorSubtract

VectorGeometry

Subtracts V2 from V1 and return value in result

VectorSubtract

VectorGeometry

Subtracts V2 from V1 and return value in result

VectorSubtract

VectorGeometry

VectorSubtract

VectorGeometry

VectorTransform

VectorGeometry

Transforms a homogeneous vector by multiplying it with a matrix

VectorTransform

VectorGeometry

Transforms an affine vector by multiplying it with a matrix

VectorTransform

VectorGeometry

Transforms an affine vector by multiplying it with a matrix

VectorTransform

VectorGeometry

Transforms a homogeneous vector by multiplying it with a matrix

vEdgeInfoReserveSize

MeshUtils

VerifyDelphiODE

ODEImport

vFindCuFileFunc

GLSCUDACompiler

vFontManagerMsgID

GLSpaceText

vGhoul2LevelOfDetail

GLFileGL2

vGhoul2MaxBonesPerVertex

GLFileGL2

vGLFile3DSSceneObjects_RenderCameraAndLights

GLFile3DSSceneObjects

vGLFile3DS_EnableAnimation

GLFile3DS

If enabled, allows 3ds animation and fixes loading of some 3ds models, but has a few bugs: - TGLFreeForm.AutoCentering does now work correctly. - TMeshObject.vertices return values different from TMeshObject.ExtractTriangles()

vGLFile3DS_FixDefaultUpAxisY

GLFile3DS

If enabled, a -90 degrees (-PI/2) rotation will occured on X Axis. By design 3dsmax has a Z Up-Axis, after the rotation the Up axis will be Y. (Note: you need vGLFile3DS_EnableAnimation = true)

vGLFile3DS_LoadedStaticFrame

GLFile3DS

If >= 0, then the vertices list will be updated with selected frame animation data. (Note: you need vGLFile3DS_EnableAnimation = true). Be aware that in that case animation will not be usable, it is made to be used with a static mesh like GLFreeForm.

vGLFile3DS_UseTextureEx

GLFile3DS

If enabled, advanced parameters will be loaded from a 3ds file (TextureScale, TextureOffset), but it might break backwards compatibility. If disabled, it won't break anything, but some parameters will not be loaded correctly from a 3ds file. Also there is a significant drop in FPS when this option is on (for unknown reasons), so it is off by default.

vGLFileOBJ_SplitMesh

GLFileOBJ

If enabled, main mesh will be splitted into multiple mesh from facegroup data.

vGLFileOCTAllocateMaterials

GLFileOCT

vGLFileOCTLightmapBrightness

GLFileOCT

vGLFileOCTLightmapGammaCorrection

GLFileOCT

vGLFileQ3BSPLoadMaterials

GLFileQ3BSP

vGLODEObjectRegister

GLODEManager

vGLODERagdoll_cDensity

GLODERagdoll

vGLODERagdoll_cMass

GLODERagdoll

vGLVectorFileObjectsAllocateMaterials

GLVectorFileObjects

vGLVectorFileObjectsEnableVBOByDefault

GLVectorFileObjects

VGradientMax3DS

Const3DS

VGradientMin3DS

Const3DS

VHDR_DONE

GLSVfw

VHDR_INQUEUE

GLSVfw

VHDR_KEYFRAME

GLSVfw

VHDR_PREPARED

GLSVfw

VIDCF_COMPRESSFRAMES

GLSVfw

VIDCF_CRUNCH

GLSVfw

VIDCF_DRAW

GLSVfw

VIDCF_FASTTEMPORALC

GLSVfw

VIDCF_FASTTEMPORALD

GLSVfw

VIDCF_QUALITY

GLSVfw

VIDCF_TEMPORAL

GLSVfw

vIDELogProc

GLSLog

VideoForWindowsVersion

GLSVfw

VIDEO_CONFIGURE_CURRENT

GLSVfw

VIDEO_CONFIGURE_GET

GLSVfw

VIDEO_CONFIGURE_MAX

GLSVfw

VIDEO_CONFIGURE_MIN

GLSVfw

VIDEO_CONFIGURE_NOMINAL

GLSVfw

VIDEO_CONFIGURE_QUERY

GLSVfw

VIDEO_CONFIGURE_QUERYSIZE

GLSVfw

VIDEO_CONFIGURE_SET

GLSVfw

VIDEO_DLG_QUERY

GLSVfw

VIDEO_EXTERNALIN

GLSVfw

VIDEO_EXTERNALOUT

GLSVfw

VIDEO_IN

GLSVfw

VIDEO_OUT

GLSVfw

ViewCameraStrMax3DS

Const3DS

VIEWPORT_DATA

Const3DS

VIEWPORT_DATA_3

Const3DS

VIEWPORT_DATA_OLD

Const3DS

VIEWPORT_LAYOUT

Const3DS

VIEWPORT_LAYOUT_OLD

Const3DS

VIEWPORT_SIZE

Const3DS

VIEW_BACK

Const3DS

VIEW_BOTTOM

Const3DS

VIEW_CAMERA

Const3DS

VIEW_FRONT

Const3DS

VIEW_LEFT

Const3DS

VIEW_RIGHT

Const3DS

VIEW_TOP

Const3DS

VIEW_USER

Const3DS

VIEW_WINDOW

Const3DS

vIgnoreOpenGLErrors

OpenGL1x

vIgnoreOpenGLErrors

GLContext

vImageScaleFilterWidth

ImageUtils

vImprovedFixingOpenTriangleEdge

MeshUtils

VirtualKeyCodeToKeyName

GLKeyboard

Converts a virtual key code to its name.<p> The name is expressed using the locale windows options.

VK_MOUSEWHEELDOWN

GLKeyboard

VK_MOUSEWHEELUP

GLKeyboard

vLastWheelDelta

GLKeyboard

vLocalGL

GLPipelineTransformation

VMAP_TYPE_MNVW

LWObjects

VMAP_TYPE_MORF

LWObjects

VMAP_TYPE_PICK

LWObjects

VMAP_TYPE_RGB

LWObjects

VMAP_TYPE_RGBA

LWObjects

VMAP_TYPE_SPOT

LWObjects

VMAP_TYPE_TXUV

LWObjects

VMAP_TYPE_WGHT

LWObjects

vMD5TextureExtensions

GLFileMD5

vMultitextureCoordinatorClass

GLContext

vNumberVideoModes

GLScreen

VPDATA

Const3DS

vProjectTargetName

GLCrossPlatform

vQ3BSPLightmapBrightness

GLFileQ3BSP

vQ3BSPLightmapGammaCorrection

GLFileQ3BSP

vSIMD

VectorGeometry

vUseDefaultColorSets

GLColor

VUseDefaultCoordinateSets

GLCoordinates

vUseWindowTrackingHook

GLWin32Context

vVerboseGLSMErrors

GLSound

vVerticalFlipDDS

GLGraphics

vVideoModes

GLScreen

V_GRADIENT

Const3DS

WAVE_FORMAT_1M08

Bass

WAVE_FORMAT_1M16

Bass

WAVE_FORMAT_1S08

Bass

WAVE_FORMAT_1S16

Bass

WAVE_FORMAT_2M08

Bass

WAVE_FORMAT_2M16

Bass

WAVE_FORMAT_2S08

Bass

WAVE_FORMAT_2S16

Bass

WAVE_FORMAT_4M08

Bass

WAVE_FORMAT_4M16

Bass

WAVE_FORMAT_4S08

Bass

WAVE_FORMAT_4S16

Bass

WeldVertices

MeshUtils

Welds all vertices separated by a distance inferior to weldRadius.<p> Any two vertices whose distance is inferior to weldRadius will be merged (ie. one of them will be removed, and the other replaced by the barycenter).<p> The indicesMap is constructed to allow remapping of indices lists with the simple rule: newVertexIndex:=indicesMap[oldVertexIndex].<p> The logic is protected from chain welding, and only vertices that were initially closer than weldRadius will be welded in the same resulting vertex.<p> This procedure can be used for mesh simplification, but preferably at design-time for it is not optimized for speed. This is more a "fixing" utility for meshes exported from high-polycount CAD tools (to remove duplicate vertices, quantification errors, etc.)

wglAllocateMemoryNV

OpenGL1x

wglBindTexImageARB

OpenGL1x

wglChoosePixelFormatARB

OpenGL1x

wglCopyContext

OpenGL1x

wglCopyContext

OpenGLAdapter

wglCreateAffinityDCNV

OpenGL1x

wglCreateBufferRegionARB

OpenGL1x

wglCreateContext

OpenGL1x

wglCreateContext

OpenGLAdapter

wglCreateContextAttribsARB

OpenGL1x

wglCreateLayerContext

OpenGL1x

wglCreateLayerContext

OpenGLAdapter

wglCreatePbufferARB

OpenGL1x

wglDeleteBufferRegionARB

OpenGL1x

wglDeleteContext

OpenGLAdapter

wglDeleteContext

OpenGL1x

wglDeleteDCNV

OpenGL1x

wglDescribeLayerPlane

OpenGLAdapter

wglDescribeLayerPlane

OpenGL1x

wglDestroyPbufferARB

OpenGL1x

wglEnumGpuDevicesNV

OpenGL1x

wglEnumGpusFromAffinityDCNV

OpenGL1x

wglEnumGpusNV

OpenGL1x

wglFreeMemoryNV

OpenGL1x

wglGetCurrentContext

OpenGLAdapter

wglGetCurrentContext

OpenGL1x

wglGetCurrentDC

OpenGL1x

wglGetCurrentDC

OpenGLAdapter

wglGetCurrentReadDCARB

OpenGL1x

wglGetExtensionsStringARB

OpenGL1x

wglGetLayerPaletteEntries

OpenGLAdapter

wglGetLayerPaletteEntries

OpenGL1x

wglGetPbufferDCARB

OpenGL1x

wglGetPixelFormatAttribfvARB

OpenGL1x

wglGetPixelFormatAttribivARB

OpenGL1x

wglGetProcAddress

OpenGLAdapter

wglGetProcAddress

OpenGL1x

wglGetSwapIntervalEXT

OpenGL1x

wglMakeContextCurrentARB

OpenGL1x

wglMakeCurrent

OpenGLAdapter

wglMakeCurrent

OpenGL1x

wglQueryPbufferARB

OpenGL1x

wglRealizeLayerPalette

OpenGL1x

wglRealizeLayerPalette

OpenGLAdapter

wglReleasePbufferDCARB

OpenGL1x

wglReleaseTexImageARB

OpenGL1x

wglRestoreBufferRegionARB

OpenGL1x

wglSaveBufferRegionARB

OpenGL1x

wglSetLayerPaletteEntries

OpenGLAdapter

wglSetLayerPaletteEntries

OpenGL1x

wglSetPbufferAttribARB

OpenGL1x

wglShareLists

OpenGL1x

wglShareLists

OpenGLAdapter

WGLSWAP

OpenGLTokens

wglSwapIntervalEXT

OpenGL1x

wglSwapLayerBuffers

OpenGL1x

wglSwapLayerBuffers

OpenGLAdapter

wglSwapMultipleBuffers

OpenGL1x

wglSwapMultipleBuffers

OpenGLAdapter

wglUseFontBitmaps

OpenGL1x

wglUseFontBitmaps

OpenGLAdapter

wglUseFontBitmapsA

OpenGLAdapter

wglUseFontBitmapsA

OpenGL1x

wglUseFontBitmapsW

OpenGLAdapter

wglUseFontBitmapsW

OpenGL1x

wglUseFontOutlines

OpenGL1x

wglUseFontOutlines

OpenGLAdapter

wglUseFontOutlinesA

OpenGLAdapter

wglUseFontOutlinesA

OpenGL1x

wglUseFontOutlinesW

OpenGLAdapter

wglUseFontOutlinesW

OpenGL1x

WGL_ACCELERATION_ARB

OpenGLTokens

WGL_ACCESS_READ_ONLY_NV

OpenGLTokens

WGL_ACCESS_READ_WRITE_NV

OpenGLTokens

WGL_ACCESS_WRITE_DISCARD_NV

OpenGLTokens

WGL_ACCUM_ALPHA_BITS_ARB

OpenGLTokens

WGL_ACCUM_BITS_ARB

OpenGLTokens

WGL_ACCUM_BLUE_BITS_ARB

OpenGLTokens

WGL_ACCUM_GREEN_BITS_ARB

OpenGLTokens

WGL_ACCUM_RED_BITS_ARB

OpenGLTokens

WGL_ALPHA_BITS_ARB

OpenGLTokens

WGL_ALPHA_SHIFT_ARB

OpenGLTokens

WGL_ARB_buffer_region

OpenGL1x

WGL_ARB_create_context

OpenGL1x

WGL_ARB_create_context_profile

OpenGL1x

WGL_ARB_extensions_string

OpenGL1x

WGL_ARB_framebuffer_sRGB

OpenGL1x

WGL_ARB_make_current_read

OpenGL1x

WGL_ARB_multisample

OpenGL1x

WGL_ARB_pbuffer

OpenGL1x

WGL_ARB_pixel_format

OpenGL1x

WGL_ARB_pixel_format_float

OpenGL1x

WGL_ARB_render_texture

OpenGL1x

WGL_ATI_pixel_format_float

OpenGL1x

WGL_AUX0_ARB

OpenGLTokens

WGL_AUX1_ARB

OpenGLTokens

WGL_AUX2_ARB

OpenGLTokens

WGL_AUX3_ARB

OpenGLTokens

WGL_AUX4_ARB

OpenGLTokens

WGL_AUX5_ARB

OpenGLTokens

WGL_AUX6_ARB

OpenGLTokens

WGL_AUX7_ARB

OpenGLTokens

WGL_AUX8_ARB

OpenGLTokens

WGL_AUX9_ARB

OpenGLTokens

WGL_AUX_BUFFERS_ARB

OpenGLTokens

WGL_BACK_COLOR_BUFFER_BIT_ARB

OpenGLTokens

WGL_BACK_LEFT_ARB

OpenGLTokens

WGL_BACK_RIGHT_ARB

OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGBA_NV

OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RGB_NV

OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_RG_NV

OpenGLTokens

WGL_BIND_TO_TEXTURE_RECTANGLE_FLOAT_R_NV

OpenGLTokens

WGL_BIND_TO_TEXTURE_RGBA_ARB

OpenGLTokens

WGL_BIND_TO_TEXTURE_RGB_ARB

OpenGLTokens

WGL_BLUE_BITS_ARB

OpenGLTokens

WGL_BLUE_SHIFT_ARB

OpenGLTokens

WGL_COLOR_BITS_ARB

OpenGLTokens

WGL_COLOR_SAMPLES_NV

OpenGLTokens

WGL_CONTEXT_COMPATIBILITY_PROFILE_BIT_ARB

OpenGLTokens

WGL_CONTEXT_CORE_PROFILE_BIT_ARB

OpenGLTokens

WGL_CONTEXT_DEBUG_BIT_ARB

OpenGLTokens

WGL_CONTEXT_ES2_PROFILE_BIT_EXT

OpenGLTokens

WGL_CONTEXT_FLAGS_ARB

OpenGLTokens

WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB

OpenGLTokens

WGL_CONTEXT_LAYER_PLANE_ARB

OpenGLTokens

WGL_CONTEXT_MAJOR_VERSION_ARB

OpenGLTokens

WGL_CONTEXT_MINOR_VERSION_ARB

OpenGLTokens

WGL_CONTEXT_PROFILE_MASK_ARB

OpenGLTokens

WGL_CUBE_MAP_FACE_ARB

OpenGLTokens

WGL_DEPTH_BITS_ARB

OpenGLTokens

WGL_DEPTH_BUFFER_BIT_ARB

OpenGLTokens

WGL_DOUBLE_BUFFER_ARB

OpenGLTokens

WGL_DRAW_TO_BITMAP_ARB

OpenGLTokens

WGL_DRAW_TO_PBUFFER_ARB

OpenGLTokens

WGL_DRAW_TO_WINDOW_ARB

OpenGLTokens

WGL_EXT_framebuffer_sRGB

OpenGL1x

WGL_EXT_pixel_format_packed_float

OpenGL1x

WGL_EXT_swap_control

OpenGL1x

WGL_FLOAT_COMPONENTS_NV

OpenGLTokens

WGL_FRAMEBUFFER_SRGB_CAPABLE_ARB

OpenGLTokens

WGL_FRAMEBUFFER_SRGB_CAPABLE_EXT

OpenGLTokens

WGL_FRONT_COLOR_BUFFER_BIT_ARB

OpenGLTokens

WGL_FRONT_LEFT_ARB

OpenGLTokens

WGL_FRONT_RIGHT_ARB

OpenGLTokens

WGL_FULL_ACCELERATION_ARB

OpenGLTokens

WGL_GENERIC_ACCELERATION_ARB

OpenGLTokens

WGL_GREEN_BITS_ARB

OpenGLTokens

WGL_GREEN_SHIFT_ARB

OpenGLTokens

WGL_MAX_PBUFFER_HEIGHT_ARB

OpenGLTokens

WGL_MAX_PBUFFER_PIXELS_ARB

OpenGLTokens

WGL_MAX_PBUFFER_WIDTH_ARB

OpenGLTokens

WGL_MIPMAP_LEVEL_ARB

OpenGLTokens

WGL_MIPMAP_TEXTURE_ARB

OpenGLTokens

WGL_NEED_PALETTE_ARB

OpenGLTokens

WGL_NEED_SYSTEM_PALETTE_ARB

OpenGLTokens

WGL_NO_ACCELERATION_ARB

OpenGLTokens

WGL_NO_TEXTURE_ARB

OpenGLTokens

WGL_NUMBER_OVERLAYS_ARB

OpenGLTokens

WGL_NUMBER_PIXEL_FORMATS_ARB

OpenGLTokens

WGL_NUMBER_UNDERLAYS_ARB

OpenGLTokens

WGL_NV_gpu_affinity

OpenGL1x

WGL_PBUFFER_HEIGHT_ARB

OpenGLTokens

WGL_PBUFFER_LARGEST_ARB

OpenGLTokens

WGL_PBUFFER_LOST_ARB

OpenGLTokens

WGL_PBUFFER_WIDTH_ARB

OpenGLTokens

WGL_PIXEL_TYPE_ARB

OpenGLTokens

WGL_RED_BITS_ARB

OpenGLTokens

WGL_RED_SHIFT_ARB

OpenGLTokens

WGL_SAMPLES_ARB

OpenGLTokens

WGL_SAMPLES_EXT

OpenGLTokens

WGL_SAMPLE_BUFFERS_ARB

OpenGLTokens

WGL_SAMPLE_BUFFERS_EXT

OpenGLTokens

WGL_SHARE_ACCUM_ARB

OpenGLTokens

WGL_SHARE_DEPTH_ARB

OpenGLTokens

WGL_SHARE_STENCIL_ARB

OpenGLTokens

WGL_STENCIL_BITS_ARB

OpenGLTokens

WGL_STENCIL_BUFFER_BIT_ARB

OpenGLTokens

WGL_STEREO_ARB

OpenGLTokens

WGL_SUPPORT_GDI_ARB

OpenGLTokens

WGL_SUPPORT_OPENGL_ARB

OpenGLTokens

WGL_SWAP_COPY_ARB

OpenGLTokens

WGL_SWAP_EXCHANGE_ARB

OpenGLTokens

WGL_SWAP_LAYER_BUFFERS_ARB

OpenGLTokens

WGL_SWAP_MAIN_PLANE

GLWin32Context

WGL_SWAP_METHOD_ARB

OpenGLTokens

WGL_SWAP_OVERLAY1

GLWin32Context

WGL_SWAP_OVERLAY10

GLWin32Context

WGL_SWAP_OVERLAY11

GLWin32Context

WGL_SWAP_OVERLAY12

GLWin32Context

WGL_SWAP_OVERLAY13

GLWin32Context

WGL_SWAP_OVERLAY14

GLWin32Context

WGL_SWAP_OVERLAY15

GLWin32Context

WGL_SWAP_OVERLAY2

GLWin32Context

WGL_SWAP_OVERLAY3

GLWin32Context

WGL_SWAP_OVERLAY4

GLWin32Context

WGL_SWAP_OVERLAY5

GLWin32Context

WGL_SWAP_OVERLAY6

GLWin32Context

WGL_SWAP_OVERLAY7

GLWin32Context

WGL_SWAP_OVERLAY8

GLWin32Context

WGL_SWAP_OVERLAY9

GLWin32Context

WGL_SWAP_UNDEFINED_ARB

OpenGLTokens

WGL_SWAP_UNDERLAY1

GLWin32Context

WGL_SWAP_UNDERLAY10

GLWin32Context

WGL_SWAP_UNDERLAY11

GLWin32Context

WGL_SWAP_UNDERLAY12

GLWin32Context

WGL_SWAP_UNDERLAY13

GLWin32Context

WGL_SWAP_UNDERLAY14

GLWin32Context

WGL_SWAP_UNDERLAY15

GLWin32Context

WGL_SWAP_UNDERLAY2

GLWin32Context

WGL_SWAP_UNDERLAY3

GLWin32Context

WGL_SWAP_UNDERLAY4

GLWin32Context

WGL_SWAP_UNDERLAY5

GLWin32Context

WGL_SWAP_UNDERLAY6

GLWin32Context

WGL_SWAP_UNDERLAY7

GLWin32Context

WGL_SWAP_UNDERLAY8

GLWin32Context

WGL_SWAP_UNDERLAY9

GLWin32Context

WGL_TEXTURE_1D_ARB

OpenGLTokens

WGL_TEXTURE_2D_ARB

OpenGLTokens

WGL_TEXTURE_CUBE_MAP_ARB

OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_X_ARB

OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Y_ARB

OpenGLTokens

WGL_TEXTURE_CUBE_MAP_NEGATIVE_Z_ARB

OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_X_ARB

OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_Y_ARB

OpenGLTokens

WGL_TEXTURE_CUBE_MAP_POSITIVE_Z_ARB

OpenGLTokens

WGL_TEXTURE_FLOAT_RGBA_NV

OpenGLTokens

WGL_TEXTURE_FLOAT_RGB_NV

OpenGLTokens

WGL_TEXTURE_FLOAT_RG_NV

OpenGLTokens

WGL_TEXTURE_FLOAT_R_NV

OpenGLTokens

WGL_TEXTURE_FORMAT_ARB

OpenGLTokens

WGL_TEXTURE_RGBA_ARB

OpenGLTokens

WGL_TEXTURE_RGB_ARB

OpenGLTokens

WGL_TEXTURE_TARGET_ARB

OpenGLTokens

WGL_TRANSPARENT_ALPHA_VALUE_ARB

OpenGLTokens

WGL_TRANSPARENT_ARB

OpenGLTokens

WGL_TRANSPARENT_BLUE_VALUE_ARB

OpenGLTokens

WGL_TRANSPARENT_GREEN_VALUE_ARB

OpenGLTokens

WGL_TRANSPARENT_INDEX_VALUE_ARB

OpenGLTokens

WGL_TRANSPARENT_RED_VALUE_ARB

OpenGLTokens

WGL_TYPE_COLORINDEX_ARB

OpenGLTokens

WGL_TYPE_RGBA_ARB

OpenGLTokens

WGL_TYPE_RGBA_FLOAT_ARB

OpenGLTokens

WGL_TYPE_RGBA_FLOAT_ATI

OpenGLTokens

WGL_TYPE_RGBA_UNSIGNED_FLOAT_EXT

OpenGLTokens

WHmgPoint

VectorGeometry

WHmgVector

VectorGeometry

WM_CAP_ABORT

GLSVfw

WM_CAP_DLG_VIDEOCOMPRESSION

GLSVfw

WM_CAP_DLG_VIDEODISPLAY

GLSVfw

WM_CAP_DLG_VIDEOFORMAT

GLSVfw

WM_CAP_DLG_VIDEOSOURCE

GLSVfw

WM_CAP_DRIVER_CONNECT

GLSVfw

WM_CAP_DRIVER_DISCONNECT

GLSVfw

WM_CAP_DRIVER_GET_CAPS

GLSVfw

WM_CAP_DRIVER_GET_NAME

GLSVfw

WM_CAP_DRIVER_GET_NAMEA

GLSVfw

WM_CAP_DRIVER_GET_NAMEW

GLSVfw

WM_CAP_DRIVER_GET_VERSION

GLSVfw

WM_CAP_DRIVER_GET_VERSIONA

GLSVfw

WM_CAP_DRIVER_GET_VERSIONW

GLSVfw

WM_CAP_EDIT_COPY

GLSVfw

WM_CAP_END

GLSVfw

WM_CAP_FILE_ALLOCATE

GLSVfw

WM_CAP_FILE_GET_CAPTURE_FILE

GLSVfw

WM_CAP_FILE_GET_CAPTURE_FILEA

GLSVfw

WM_CAP_FILE_GET_CAPTURE_FILEW

GLSVfw

WM_CAP_FILE_SAVEAS

GLSVfw

WM_CAP_FILE_SAVEASA

GLSVfw

WM_CAP_FILE_SAVEASW

GLSVfw

WM_CAP_FILE_SAVEDIB

GLSVfw

WM_CAP_FILE_SAVEDIBA

GLSVfw

WM_CAP_FILE_SAVEDIBW

GLSVfw

WM_CAP_FILE_SET_CAPTURE_FILE

GLSVfw

WM_CAP_FILE_SET_CAPTURE_FILEA

GLSVfw

WM_CAP_FILE_SET_CAPTURE_FILEW

GLSVfw

WM_CAP_FILE_SET_INFOCHUNK

GLSVfw

WM_CAP_GET_AUDIOFORMAT

GLSVfw

WM_CAP_GET_CAPSTREAMPTR

GLSVfw

WM_CAP_GET_MCI_DEVICE

GLSVfw

WM_CAP_GET_MCI_DEVICEA

GLSVfw

WM_CAP_GET_MCI_DEVICEW

GLSVfw

WM_CAP_GET_SEQUENCE_SETUP

GLSVfw

WM_CAP_GET_STATUS

GLSVfw

WM_CAP_GET_USER_DATA

GLSVfw

WM_CAP_GET_VIDEOFORMAT

GLSVfw

WM_CAP_GRAB_FRAME

GLSVfw

WM_CAP_GRAB_FRAME_NOSTOP

GLSVfw

WM_CAP_PAL_AUTOCREATE

GLSVfw

WM_CAP_PAL_MANUALCREATE

GLSVfw

WM_CAP_PAL_OPEN

GLSVfw

WM_CAP_PAL_OPENA

GLSVfw

WM_CAP_PAL_OPENW

GLSVfw

WM_CAP_PAL_PASTE

GLSVfw

WM_CAP_PAL_SAVE

GLSVfw

WM_CAP_PAL_SAVEA

GLSVfw

WM_CAP_PAL_SAVEW

GLSVfw

WM_CAP_SEQUENCE

GLSVfw

WM_CAP_SEQUENCE_NOFILE

GLSVfw

WM_CAP_SET_AUDIOFORMAT

GLSVfw

WM_CAP_SET_CALLBACK_CAPCONTROL

GLSVfw

WM_CAP_SET_CALLBACK_ERROR

GLSVfw

WM_CAP_SET_CALLBACK_ERRORA

GLSVfw

WM_CAP_SET_CALLBACK_ERRORW

GLSVfw

WM_CAP_SET_CALLBACK_FRAME

GLSVfw

WM_CAP_SET_CALLBACK_STATUS

GLSVfw

WM_CAP_SET_CALLBACK_STATUSA

GLSVfw

WM_CAP_SET_CALLBACK_STATUSW

GLSVfw

WM_CAP_SET_CALLBACK_VIDEOSTREAM

GLSVfw

WM_CAP_SET_CALLBACK_WAVESTREAM

GLSVfw

WM_CAP_SET_CALLBACK_YIELD

GLSVfw

WM_CAP_SET_MCI_DEVICE

GLSVfw

WM_CAP_SET_MCI_DEVICEA

GLSVfw

WM_CAP_SET_MCI_DEVICEW

GLSVfw

WM_CAP_SET_OVERLAY

GLSVfw

WM_CAP_SET_PREVIEW

GLSVfw

WM_CAP_SET_PREVIEWRATE

GLSVfw

WM_CAP_SET_SCALE

GLSVfw

WM_CAP_SET_SCROLL

GLSVfw

WM_CAP_SET_SEQUENCE_SETUP

GLSVfw

WM_CAP_SET_USER_DATA

GLSVfw

WM_CAP_SET_VIDEOFORMAT

GLSVfw

WM_CAP_SINGLE_FRAME

GLSVfw

WM_CAP_SINGLE_FRAME_CLOSE

GLSVfw

WM_CAP_SINGLE_FRAME_OPEN

GLSVfw

WM_CAP_START

GLSVfw

WM_CAP_STOP

GLSVfw

WM_CAP_UNICODE_END

GLSVfw

WM_CAP_UNICODE_START

GLSVfw

WordToIntegerArray

GLUtils

Copies the values of Source to Dest (converting word values to integer values)

WriteCRLFString

GLUtils

Write the string and a CRLF in the stream

WriteModuleData

GLSModuleLoader

WriteMotorolaNumber

LWObjects

WriteS0

LWObjects

WriteU4AsVX

LWObjects

WriteXMLFile

GLSCrossXML

WriteXMLFile

GLSCrossXML

XCollectionEditor

FXCollectionEditorLCL

XCollectionEditor

FXCollectionEditor

XDATA_APPNAME

Const3DS

XDATA_DOUBLE

Const3DS

XDATA_ENTRY

Const3DS

XDATA_FLOAT

Const3DS

XDATA_GROUP

Const3DS

XDATA_LONG

Const3DS

XDATA_RFU1

Const3DS

XDATA_RFU2

Const3DS

XDATA_RFU3

Const3DS

XDATA_RFU4

Const3DS

XDATA_RFU5

Const3DS

XDATA_RFU6

Const3DS

XDATA_SECTION

Const3DS

XDATA_SHORT

Const3DS

XDATA_STRING

Const3DS

XDATA_VOID

Const3DS

xgl

XOpenGL

XHmgPoint

VectorGeometry

XHmgVector

VectorGeometry

XLATE_RANGE

Const3DS

XTexPoint

VectorGeometry

XVector

VectorGeometry

XYHmgVector

VectorGeometry

XYTexPoint

VectorGeometry

XYVector

VectorGeometry

XYZHmgVector

VectorGeometry

XYZVector

VectorGeometry

XYZWHmgVector

VectorGeometry

XZHmgVector

VectorGeometry

XZVector

VectorGeometry

XZ_CURVE

Const3DS

YHmgPoint

VectorGeometry

YHmgVector

VectorGeometry

YTexPoint

VectorGeometry

YVector

VectorGeometry

YZHmgVector

VectorGeometry

YZVector

VectorGeometry

YZ_CURVE

Const3DS

ZAdler32

GLSZLibEx

ZCompress

GLSZLibEx

ZCompress2

GLSZLibEx

ZCompressStr

GLSZLibEx

ZCompressStr2

GLSZLibEx

ZCompressStream

GLSZLibEx

ZCompressStream2

GLSZLibEx

ZCompressStreamWeb

GLSZLibEx

ZCompressStrEx

GLSZLibEx

ZCompressString

GLSZLibEx

ZCompressString

GLSZLibEx

ZCompressString2

GLSZLibEx

ZCompressString2

GLSZLibEx

ZCompressStringEx

GLSZLibEx

ZCompressStringEx

GLSZLibEx

ZCompressStringWeb

GLSZLibEx

ZCompressStringWeb

GLSZLibEx

ZCompressStrWeb

GLSZLibEx

ZCrc32

GLSZLibEx

ZDecompress

GLSZLibEx

ZDecompress2

GLSZLibEx

ZDecompressStr

GLSZLibEx

ZDecompressStr2

GLSZLibEx

ZDecompressStream

GLSZLibEx

ZDecompressStream2

GLSZLibEx

ZDecompressStrEx

GLSZLibEx

ZDecompressString

GLSZLibEx

ZDecompressString

GLSZLibEx

ZDecompressString2

GLSZLibEx

ZDecompressString2

GLSZLibEx

ZDecompressStringEx

GLSZLibEx

ZDecompressStringEx

GLSZLibEx

ZDeflate

GLSZLibEx

ZDeflateEnd

GLSZLibEx

ZDeflateEx

GLSZLibEx

ZDeflateInit

GLSZLibEx

ZDeflateInit2

GLSZLibEx

ZDeflateReset

GLSZLibEx

zErrorpchar

GLSZLibExApi

ZErrors

GLSZLibEx

ZFlushes

GLSZLibEx

zGetProcAddress

GLSZLibExApi

ZHmgPoint

VectorGeometry

ZHmgVector

VectorGeometry

ZInflate

GLSZLibEx

ZInflateEnd

GLSZLibEx

ZInflateEx

GLSZLibEx

ZInflateInit

GLSZLibEx

ZInflateInit2

GLSZLibEx

ZInflateReset

GLSZLibEx

ZLevels

GLSZLibEx

zlibVersion

GLSZLibExApi

zlibVersionpchar

GLSZLibExApi

ZLIB_VERSION

LIBPNG

ZLIB_VERSION

GLSZLibExApi

ZStrategies

GLSZLibEx

ZVector

VectorGeometry

Z_ASCII

GLSZLibExApi

Z_BEST_COMPRESSION

GLSZLibExApi

Z_BEST_SPEED

GLSZLibExApi

Z_BINARY

GLSZLibExApi

Z_BLOCK

GLSZLibExApi

Z_BUF_ERROR

GLSZLibExApi

Z_DATA_ERROR

GLSZLibExApi

Z_DEFAULT_COMPRESSION

GLSZLibExApi

Z_DEFAULT_STRATEGY

GLSZLibExApi

Z_DEFLATED

GLSZLibExApi

Z_ERRNO

GLSZLibExApi

Z_FILTERED

GLSZLibExApi

Z_FINISH

GLSZLibExApi

Z_FIXED

GLSZLibExApi

Z_FULL_FLUSH

GLSZLibExApi

Z_HUFFMAN_ONLY

GLSZLibExApi

Z_INFO_DEFAULT

GLSZLibExApi

Z_INFO_FLAG_ADLER

GLSZLibExApi

Z_INFO_FLAG_CRC

GLSZLibExApi

Z_INFO_FLAG_SIZE

GLSZLibExApi

Z_INFO_NONE

GLSZLibExApi

Z_MEM_ERROR

GLSZLibExApi

Z_NEED_DICT

GLSZLibExApi

Z_NO_COMPRESSION

GLSZLibExApi

Z_NO_FLUSH

GLSZLibExApi

Z_OK

GLSZLibExApi

Z_PARTIAL_FLUSH

GLSZLibExApi

Z_RLE

GLSZLibExApi

Z_STREAM_END

GLSZLibExApi

Z_STREAM_ERROR

GLSZLibExApi

Z_SYNC_FLUSH

GLSZLibExApi

Z_TEXT

GLSZLibExApi

Z_TREES

GLSZLibExApi

Z_UNKNOWN

GLSZLibExApi

Z_VERSION_ERROR

GLSZLibExApi

_EFXEAXREVERBPROPERTIES

openal

_EFXLOWPASSFILTER

openal

_png_access_version_number

LIBPNG

_png_build_grayscale_palette

LIBPNG

_png_check_sig

LIBPNG

_png_chunk_error

LIBPNG

_png_chunk_warning

LIBPNG

_png_convert_from_struct_tm

LIBPNG

_png_convert_from_time_t

LIBPNG

_png_convert_to_rfc1123

LIBPNG

_png_create_info_struct

LIBPNG

_png_create_read_struct

LIBPNG

_png_create_write_struct

LIBPNG

_png_data_freer

LIBPNG

_png_destroy_info_struct

LIBPNG

_png_destroy_read_struct

LIBPNG

_png_destroy_write_struct

LIBPNG

_png_error

LIBPNG

_png_free

LIBPNG

_png_free_data

LIBPNG

_png_get_bit_depth

LIBPNG

_png_get_bKGD

LIBPNG

_png_get_channels

LIBPNG

_png_get_cHRM

LIBPNG

_png_get_cHRM_fixed

LIBPNG

_png_get_color_type

LIBPNG

_png_get_compression_buffer_size

LIBPNG

_png_get_compression_type

LIBPNG

_png_get_error_ptr

LIBPNG

_png_get_filter_type

LIBPNG

_png_get_gAMA

LIBPNG

_png_get_gAMA_fixed

LIBPNG

_png_get_header_ver

LIBPNG

_png_get_header_version

LIBPNG

_png_get_hIST

LIBPNG

_png_get_iCCP

LIBPNG

_png_get_IHDR

LIBPNG

_png_get_image_height

LIBPNG

_png_get_image_width

LIBPNG

_png_get_interlace_type

LIBPNG

_png_get_io_ptr

LIBPNG

_png_get_libpng_ver

LIBPNG

_png_get_oFFs

LIBPNG

_png_get_pCAL

LIBPNG

_png_get_pHYs

LIBPNG

_png_get_pixels_per_meter

LIBPNG

_png_get_pixel_aspect_ratio

LIBPNG

_png_get_PLTE

LIBPNG

_png_get_progressive_ptr

LIBPNG

_png_get_rgb_to_gray_status

LIBPNG

_png_get_rowbytes

LIBPNG

_png_get_rows

LIBPNG

_png_get_sBIT

LIBPNG

_png_get_sCAL

LIBPNG

_png_get_signature

LIBPNG

_png_get_sPLT

LIBPNG

_png_get_sRGB

LIBPNG

_png_get_text

LIBPNG

_png_get_tIME

LIBPNG

_png_get_tRNS

LIBPNG

_png_get_unknown_chunks

LIBPNG

_png_get_user_chunk_ptr

LIBPNG

_png_get_user_transform_ptr

LIBPNG

_png_get_valid

LIBPNG

_png_get_x_offset_microns

LIBPNG

_png_get_x_offset_pixels

LIBPNG

_png_get_x_pixels_per_meter

LIBPNG

_png_get_y_offset_microns

LIBPNG

_png_get_y_offset_pixels

LIBPNG

_png_get_y_pixels_per_meter

LIBPNG

_png_info_init

LIBPNG

_png_init_io

LIBPNG

_png_malloc

LIBPNG

_png_memcpy_check

LIBPNG

_png_memset_check

LIBPNG

_png_permit_empty_plte

LIBPNG

_png_process_data

LIBPNG

_png_progressive_combine_row

LIBPNG

_png_read_destroy

LIBPNG

_png_read_end

LIBPNG

_png_read_image

LIBPNG

_png_read_info

LIBPNG

_png_read_png

LIBPNG

_png_read_row

LIBPNG

_png_read_rows

LIBPNG

_png_read_update_info

LIBPNG

_png_reset_zstream

LIBPNG

_png_set_background

LIBPNG

_png_set_bgr

LIBPNG

_png_set_bKGD

LIBPNG

_png_set_cHRM

LIBPNG

_png_set_cHRM_fixed

LIBPNG

_png_set_compression_buffer_size

LIBPNG

_png_set_compression_level

LIBPNG

_png_set_compression_mem_level

LIBPNG

_png_set_compression_method

LIBPNG

_png_set_compression_strategy

LIBPNG

_png_set_compression_window_bits

LIBPNG

_png_set_crc_action

LIBPNG

_png_set_dither

LIBPNG

_png_set_error_fn

LIBPNG

_png_set_expand

LIBPNG

_png_set_filler

LIBPNG

_png_set_filter

LIBPNG

_png_set_filter_heuristics

LIBPNG

_png_set_flush

LIBPNG

_png_set_gAMA

LIBPNG

_png_set_gAMA_fixed

LIBPNG

_png_set_gamma

LIBPNG

_png_set_gray_1_2_4_to_8

LIBPNG

_png_set_gray_to_rgb

LIBPNG

_png_set_hIST

LIBPNG

_png_set_iCCP

LIBPNG

_png_set_IHDR

LIBPNG

_png_set_interlace_handling

LIBPNG

_png_set_invalid

LIBPNG

_png_set_invert_alpha

LIBPNG

_png_set_invert_mono

LIBPNG

_png_set_keep_unknown_chunks

LIBPNG

_png_set_oFFs

LIBPNG

_png_set_packing

LIBPNG

_png_set_packswap

LIBPNG

_png_set_palette_to_rgb

LIBPNG

_png_set_pCAL

LIBPNG

_png_set_pHYs

LIBPNG

_png_set_PLTE

LIBPNG

_png_set_progressive_read_fn

LIBPNG

_png_set_read_fn

LIBPNG

_png_set_read_status_fn

LIBPNG

_png_set_read_user_chunk_fn

LIBPNG

_png_set_read_user_transform_fn

LIBPNG

_png_set_rgb_to_gray

LIBPNG

_png_set_rgb_to_gray_fixed

LIBPNG

_png_set_rows

LIBPNG

_png_set_sBIT

LIBPNG

_png_set_sCAL

LIBPNG

_png_set_sCAL_s

LIBPNG

_png_set_shift

LIBPNG

_png_set_sig_bytes

LIBPNG

_png_set_sPLT

LIBPNG

_png_set_sRGB

LIBPNG

_png_set_sRGB_gAMA_and_cHRM

LIBPNG

_png_set_strip_16

LIBPNG

_png_set_strip_alpha

LIBPNG

_png_set_swap

LIBPNG

_png_set_swap_alpha

LIBPNG

_png_set_text

LIBPNG

_png_set_tIME

LIBPNG

_png_set_tRNS

LIBPNG

_png_set_tRNS_to_alpha

LIBPNG

_png_set_unknown_chunks

LIBPNG

_png_set_unknown_chunk_location

LIBPNG

_png_set_user_transform_info

LIBPNG

_png_set_write_fn

LIBPNG

_png_set_write_status_fn

LIBPNG

_png_set_write_user_transform_fn

LIBPNG

_png_sig_cmp

LIBPNG

_png_start_read_image

LIBPNG

_png_warning

LIBPNG

_png_write_chunk

LIBPNG

_png_write_chunk_data

LIBPNG

_png_write_chunk_end

LIBPNG

_png_write_chunk_start

LIBPNG

_png_write_destroy

LIBPNG

_png_write_destroy_info

LIBPNG

_png_write_end

LIBPNG

_png_write_flush

LIBPNG

_png_write_image

LIBPNG

_png_write_info

LIBPNG

_png_write_info_before_PLTE

LIBPNG

_png_write_png

LIBPNG

_png_write_row

LIBPNG

_png_write_rows

LIBPNG

_priv_dParamLoStop

ODEImport

_priv_dParamLoStop2

ODEImport

_priv_dParamLoStop3

ODEImport

_putenv

GLSDL

_WGLSWAP

OpenGLTokens

_z_errmsg

GLSZLibExApi

__int16

NewtonImport

__int32

NewtonImport

__int64

NewtonImport

__int8

NewtonImport

Generated by PasDoc 0.11.0 on 2013-02-10 19:38:51


GLScene v.1.1.2: Legend

Legend

Marker | Visibility
Strict Private | Strict Private
Private | Private
Strict Protected | Strict Protected
Protected | Protected
Public | Public
Published | Published
Automated | Automated
Implicit | Implicit
Generated by PasDoc 0.11.0 on 2013-02-10 19:38:51


GLScene

Developers and Contributors

Aaron Hochwimmer

Adirex

Airatz

Alan Rose

Alejandro Leon Escalera

Alexandre Hirzel

Arvydas Juskevicius

Ast

Brian Johns

Burkhard Carstens

C4

Da Stranger

Daniel Bartlett

Dave Kerr

Degiovani

Eric Grange

Eric Pascual

Erick Schuitema

fig

filippo

J.Delauney

Joen A. Joensen

Joen Joensen

Kapitan

Kenneth Poulter

Lionel Reynaud

Lord Crc

Lukasz Sokol

mal

Marcus Oblak

Matheus Degiovani

Mattias Fagerlund

mif

Mike Lischke

Nelson Chu

overkrik

Pavel Vassiliev

Paul van Dinther

Peirick

Phil Scadden

Philipp Pammler

Pierre Lemerle

Piotr Szturmaj

Rene Lindsay

Roshal Sasha

Rustam Asmandiarov

Sandor Domokos

Solerman Kaplon

Sternas Stefanos

Stuart Gooding

Uwe

Uwe Raabe

YarUnderoaker

Zsolt Laky